A

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
A Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
ABOVE — Constant Static Property, class starling.filters.FragmentFilterMode
 | 滤镜在对象的上方显示
AbstractClassError — class, package starling.errors
 | 当您尝试创建一个抽象类的一个实例，就会抛出一个AbstractClassError。
AbstractClassError(message:any, id:any) — Constructor, class starling.errors.AbstractClassError
 | 创建一个新的AbstractClassError对象。
AbstractMethodError — class, package starling.errors
 | 当您尝试调用一个抽象方法，就会抛出一个AbstractMethodError。
AbstractMethodError(message:any, id:any) — Constructor, class starling.errors.AbstractMethodError
 | 创建一个新的AbstractMethodError对象。
activate(pass:int, context:flash.display3D:Context3D, texture:starling.textures:Texture) — method, class starling.filters.FragmentFilter
 | 子类必须覆盖这个方法，并且使用它来实现他们自己的片段和顶点着色程序。 'activate'方法的调用先于'context.drawTriangles'方法的调用。根据你的滤镜的需要设置上下文。下面的常量和属性会被自动设置： vertex constants 0-3: mvpMatrix (3D) vertex attribute 0: vertex position (FLOAT_2) vertex attribute 1: texture coordinates (FLOAT_2) texture 0: input texture
add(object:starling.animation:IAnimatable) — method, class starling.animation.Juggler
 | 向juggler添加一个对象.
ADD — Constant Static Property, class starling.display.BlendMode
 | 将显示对象的颜色值添加到背景的颜色里。
addChar(charID:int, bitmapChar:starling.text:BitmapChar) — method, class starling.text.BitmapFont
 | 根据指定的字符ID增加一个位图字符
addChild(child:starling.display:DisplayObject) — method, class starling.display.DisplayObjectContainer
 | 添加一个显示对象到容器，它将被添加到顶层。
addChildAt(child:starling.display:DisplayObject, index:int) — method, class starling.display.DisplayObjectContainer
 | 根据一个索引值添加一个显示对象到容器。
added — Event, class starling.display.DisplayObject
 | 当一个显示对象被添加到父级的时候派发。
ADDED — Constant Static Property, class starling.events.Event
 | 事件类型：一个显示对象被添加到了它的父级容器上。
addedToStage — Event, class starling.display.DisplayObject
 | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。
ADDED_TO_STAGE — Constant Static Property, class starling.events.Event
 | 事件类型：一个显示对象被添加到了舞台上。
addEventListener(type:String, listener:Function) — method, class starling.events.EventDispatcher
 | 在指定的对象上注册一个事件侦听器。
addFrame(texture:starling.textures:Texture, sound:flash.media:Sound, duration:Number) — method, class starling.display.MovieClip
 | 为影片剪辑添加一帧，可以传递声音和执行时间（可选）。 如果没有指定执行时间或者执行时间为负值，则使用默认帧频（构造函数里确定的帧频）。
addFrameAt(frameID:int, texture:starling.textures:Texture, sound:flash.media:Sound, duration:Number) — method, class starling.display.MovieClip
 | 根据指定的索引添加一帧，可以传递声音和执行时间（可选）。
addImage(image:starling.display:Image, parentAlpha:Number, modelViewMatrix:flash.geom:Matrix, blendMode:String) — method, class starling.display.QuadBatch
 | 向当前批次添加一个图像。 这个方法在内部调用'addQuad'方法，并传递关于纹理和平滑度的正确参数。
addKerning(charID:int, amount:Number) — method, class starling.text.BitmapChar
 | 根据特定的字符ID设定边距
addQuad(quad:starling.display:Quad, parentAlpha:Number, texture:starling.textures:Texture, smoothing:String, modelViewMatrix:flash.geom:Matrix, blendMode:String) — method, class starling.display.QuadBatch
 | 添加一个四边形到当前批次。 第一个四边形决定批次的状态。比如纹理的值，平滑度和混合模式。 当你添加自定义的四边形，请确保他们共享了这些状态（比如'isStageChange'方法），或者重置这个批次。
addQuadBatch(quadBatch:starling.display:QuadBatch, parentAlpha:Number, modelViewMatrix:flash.geom:Matrix, blendMode:String) — method, class starling.display.QuadBatch
 | 添加一个批次
addRegion(name:String, region:flash.geom:Rectangle, frame:flash.geom:Rectangle) — method, class starling.textures.TextureAtlas
 | 为一个subtexture(通过像素坐标系里的矩阵来描述)添加一个含名字的区域以及一个可选的frame参数。
addSound(name:String, sound:flash.media:Sound) — method, class starling.utils.AssetManager
 | 根据指定的名称注册一个声音。注册后立刻可用。
addTexture(name:String, texture:starling.textures:Texture) — method, class starling.utils.AssetManager
 | 根据指定的名称注册一个纹理。注册后立刻可用。
addTextureAtlas(name:String, atlas:starling.textures:TextureAtlas) — method, class starling.utils.AssetManager
 | 根据指定的名称注册一个纹理图集。注册后立刻可用。
adjustBrightness(value:Number) — method, class starling.filters.ColorMatrixFilter
 | 改变亮度。可选区间是(-1,1)。大于0的值会提高亮度，小于0的值会降低亮度。
adjustContrast(value:Number) — method, class starling.filters.ColorMatrixFilter
 | 改变对比度。可选区间是(-1,1)。大于0的值会提高对比度，小于0的值会降低对比度。
adjustHue(value:Number) — method, class starling.filters.ColorMatrixFilter
 | 改变图像的色调.
adjustSaturation(sat:Number) — method, class starling.filters.ColorMatrixFilter
 | 改变饱和度。可选区间是(-1,1)。大于0的值会提高饱和度，小于0的值会降低饱和度。'-1'会产生一个灰度图像。
adjustVertexData(vertexData:starling.utils:VertexData, vertexID:int, count:int) — method, class starling.textures.SubTexture
 | 转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
adjustVertexData(vertexData:starling.utils:VertexData, vertexID:int, count:int) — method, class starling.textures.Texture
 | 转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
advanceTime(time:Number) — method, class starling.animation.DelayedCall
 | 暂且把这个方法称之为"时间推送器"吧.
advanceTime(time:Number) — method, interface starling.animation.IAnimatable
 | 暂且把这个方法称之为"时间推送器"吧.
advanceTime(time:Number) — method, class starling.animation.Juggler
 | 在一定的时间内集中处理所有的对象(单位是秒)
advanceTime(time:Number) — method, class starling.animation.Tween
 | 暂且把这个方法称之为"时间推送器"吧.
advanceTime(passedTime:Number) — method, class starling.core.Starling
 | 在显示列表上派发ENTER_FRAME事件, 优化 Juggler 和 处理 触摸事件.
advanceTime(passedTime:Number) — method, class starling.display.MovieClip
 | 暂且把这个方法称之为"时间推送器"吧.
advanceTime(passedTime:Number) — method, class starling.display.Stage
agalcode — Property, class com.adobe.utils.AGALMiniAssembler
 | 编译后的AGAL字节
AGALMiniAssembler — class, package com.adobe.utils
 | AGAL(Adobe Graphics Assembly Language)是Adobe开发的图形汇编语言，汇编语言是仅高于计算机二进制机器码的低级语言，可以精确地操控机器硬件比如可编程显卡，PC的Dirext9、MAC的OpenGL以及移动设备中的OpenGL ES 2都是可编程显卡，并且都支持AGAL。通过Adobe官方提供的编译器AGALMiniAssembler（实际上是一个AS类库），我们可以通过字符串指令来获得一个AGAL二进制流，再通过context3D上传给显卡的编程管线。对于顶点以及片段的运算都是通过AGAL交由显卡来处理的，这就是传说中的GPU硬件加速。
AGALMiniAssembler(debugging:Boolean) — Constructor, class com.adobe.utils.AGALMiniAssembler
 | 构造函数
alpha — Property, class starling.display.DisplayObject
 | 显示对象的不透明度。 0 = 透明, 1 = 不透明。
alpha — Property, class starling.display.Quad
 | 显示对象的不透明度。 0 = 透明, 1 = 不透明。
alphaWhenDisabled — Property, class starling.display.Button
 | 当按钮被禁用时的透明度，默认为：0.5。
altKey — Property, class starling.events.KeyboardEvent
 | 判断Alt键（Windows或Linux）或Option键（Mac OS）是否被激活。按下为true，松开为false。
animate(property:String, targetValue:Number) — method, class starling.animation.Tween
 | "运动"某个对象的属性到目标值。你可以在一个tween上多次调用这个方法。
antiAliasing — Property, class starling.core.Starling
 | 抗锯齿层级.
append(data:starling.utils:VertexData) — method, class starling.utils.VertexData
 | 从另一个顶点数据对象中追加顶点.
applyBlendMode(premultipliedAlpha:Boolean) — method, class starling.core.RenderSupport
 | 在当前的渲染内容中使用合适的混合因数.
AQUA — Constant Static Property, class starling.utils.Color
argb(alpha:int, red:int, green:int, blue:int) — Static Method , class starling.utils.Color
 | 创建一个uint的ARGB颜色。各通道范围为0 - 255.
assemble(mode:String, source:String, version:uint, ignorelimits:Boolean) — method, class com.adobe.utils.AGALMiniAssembler
 | 将AGAL的代码片段编译为字节数组
assemble2(ctx3d:flash.display3D:Context3D, version:uint, vertexsrc:String, fragmentsrc:String) — method, class com.adobe.utils.AGALMiniAssembler
 | 新增的一个简化方法，可以通过传递顶点着色器源码和片段着色器源码，快捷生成Program3D对象
assembleAgal(vertexShader:String, fragmentShader:String, resultProgram:flash.display3D:Program3D) — Static Method , class starling.core.RenderSupport
 | 汇编通过字符串传递的片段和顶点着色器到Program3D中。如果你传递了一个'resultProgram'参数，那么结果就会上传到传入的这个Program3D对象中。 否则，将从当前的Stage3D上下文中，创建一个新的Program3D对象。
assembleAgal(fragmentShader:String, vertexShader:String) — method, class starling.filters.FragmentFilter
 | 将字符串格式的片段和顶点着色代码汇编到一个Program3D对象。如果有任何参数是null，就会采用默认值（STD_FRAGMENT_SHADER或STD_VERTEX_SHADER）来替代。
AssetManager — class, package starling.utils
 | AssetManager这个类用于处理加载和访问各种素菜类型。你可以直接添加一个素材（通过'add...'方法），或者通过一个异步队列。 这使得你可以用一种统一的方式来处理资源，不管它们是来自于一个外部加载的文件，一个目录，一个URL地址，还是一个嵌入对象。 如果你是从磁盘上加载文件，那么下面的类型是支持的：png, jpg, atf, mp3, xml, fnt
AssetManager(scaleFactor:Number, useMipmaps:Boolean) — Constructor, class starling.utils.AssetManager
 | 创建一个新的AssetManager实例。'scaleFactor' 和 'useMipmaps'这两个参数定义了队列中的位图如何转换为纹理。
AUTO — Constant Static Property, class starling.display.BlendMode
 | 继承这个显示对象的父级的混合模式。
autoScale — Property, class starling.text.TextField
 | 指示是否开启自动缩放，使文本可以完整的填充整个文字区域。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Starling中文站 翻译整理

Sat Jan 19 2013, 02:47 PM +08:00


All Classes

Starling API 1.3 | Starling中文站 | All Packages | Index | Frames No Frames | Adobe Logo
All Classes |

Documentation for classes includes syntax, usage information, and code samples for methods, properties, and event handlers and listeners for those APIs that belong to a specific class in ActionScript. The classes are listed alphabetically. If you are not sure to which class a certain method or property belongs, you can look it up in the Index.

Class Package Description
AbstractClassError
starling.errors 当您尝试创建一个抽象类的一个实例，就会抛出一个AbstractClassError。
AbstractMethodError
starling.errors 当您尝试调用一个抽象方法，就会抛出一个AbstractMethodError。
AGALMiniAssembler
com.adobe.utils AGAL(Adobe Graphics Assembly Language)是Adobe开发的图形汇编语言，汇编语言是仅高于计算机二进制机器码的低级语言，可以精确地操控机器硬件比如可编程显卡，PC的Dirext9、MAC的OpenGL以及移动设备中的OpenGL ES 2都是可编程显卡，并且都支持AGAL。通过Adobe官方提供的编译器AGALMiniAssembler（实际上是一个AS类库），我们可以通过字符串指令来获得一个AGAL二进制流，再通过context3D上传给显卡的编程管线。对于顶点以及片段的运算都是通过AGAL交由显卡来处理的，这就是传说中的GPU硬件加速。
AssetManager
starling.utils AssetManager这个类用于处理加载和访问各种素菜类型。你可以直接添加一个素材（通过'add...'方法），或者通过一个异步队列。 这使得你可以用一种统一的方式来处理资源，不管它们是来自于一个外部加载的文件，一个目录，一个URL地址，还是一个嵌入对象。 如果你是从磁盘上加载文件，那么下面的类型是支持的：png, jpg, atf, mp3, xml, fnt
BitmapChar
starling.text 一个 BitmapChar包含了位图字体的一个字符的相关信息。 在大多数情况下您不需要直接使用这个类。TextField类已经为您做了封装。
BitmapFont
starling.text BitmapFont类解析bitmap字体文件，并保存在一个字符表中。 这个类解析的XML格式的文件使用了 AngelCode Bitmap Font Generator or the Glyph Designer.
BlendMode
starling.display BlendMode类提供了混合模式视觉效果的常量。 一个混合模式，总是由两个'Context3DBlendFactor'值来定义。一个混合因素代表一个特定的四个数值的数组。 这个数组是根据源颜色和目标颜色用混合公式计算的，公式如下： result = source × sourceFactor + destination × destinationFactor 在这个公式里，源颜色是像素着色器的输出颜色，目标颜色是在上一次清除和绘制操作以后，颜色缓冲区中当前存在的颜色。 要注意的是，由于纹理类型的不同，混合因素产生产生的输出也不同。 纹理可能包含'预乘透明度'(pma)，意思就是它们的RGB色值是根据它们的颜色值分别相乘得到的（目的是节省计算时间）。 基于'BitmapData'的纹理，会含有预乘透明度值，ATF纹理没有这个值。 因此，一个混合模式可能会根据pma的值而拥有不同的混合因素。
BlurFilter
starling.filters BlurFilter用于在一个对象上创建高斯模糊效果。可以分别在x轴和y轴的方向上设置模糊的强度（全局坐标系）。 也可以设置为一个阴影或外发光滤镜。使用特定的静态方法来创建特定的滤镜。
Button
starling.display 一个简单的按钮由一张图片和一个可选的文本组成。 你可以分别为按钮构造函数传递up和down两种状态的纹理。 如果你没有指定一个down状态的纹理，按钮会采用默认的办法：被触碰的时候缩小一点。 此外，你可以在按钮上覆盖一个文本，要自定义这个文本，只需要提供和原来的基本相同的文本框即可。 你可以使用textBounds属性，将文本移动到一个指定的位置。 判断按钮是否被触碰，请使用triggered事件类型， 用这个事件来代替普通的触碰事件。也就是说，用户只要在松开手指或者鼠标之前，移动手指/鼠标离开按钮区域，就可以取消对该按钮的点击操作。
Color
starling.utils 一个非常有用的类，包含在不用颜色表现间转换的预定义颜色和方法.
ColorMatrixFilter
starling.filters ColorMatrixFilter(颜色矩阵滤镜)允许你为输入图片的每个像素的RGBA颜色值和透明度，应用一个4的矩阵变换，来产生一个新的包含RGBA颜色和透明度的数据集。 它允许你调整色相变化，饱和度，亮度调整，以及其它各种效果。 这个类包含了一些用于颜色调整的简便方法。所有这些方法都会改变当前的矩阵，这就意味着你可以很容易的把它们组合在一个滤镜里面: //用50%的饱和度和180度的色相旋转创建一个翻转滤镜 var filter:ColorMatrixFilter = new ColorMatrixFilter(); filter.invert(); filter.adjustSaturation(-0.5); filter.adjustHue(1.0); 如果你希望让颜色的变化产生动画效果，就在每一步重置滤镜，或者在每一步使用相同的调整值；这个改变就会逐渐累加。
ConcreteTexture
starling.textures 一个封装了Stage3D纹理对象的ConcreteTexture，用于存储纹理属性。
DelayedCall
starling.animation DelayedCall类允许你在一定的时间间隔之后去执行某个方法(和setTimeout有些类似)。由于这个类实现了IAnimatable接口，你可以把一个DelayedCall实例添加到juggler中。 在大部分情况下，你不需要直接使用这个类；Juggler类包含了一个方法来直接实现延迟调用这个功能。 当方法调用完毕之后，DelayedCall对象会派发一个类型是“Event.REMOVE_FROM_JUGGLER”的事件，然后如果不再需要它了，Juggler会自动将它删除。
DisplayObject
starling.display DisplayObject 类是所有可放在显示列表中，在屏幕上可以被渲染的对象的基类。 显示列表树 在Starling中，所有可显示对象都处于显示列表树中，只有属于显示列表树的成员才可以在屏幕上显示和渲染。 显示列表树由可以直接渲染到屏幕的叶子节点（Image, Quad）和容器节点（DisplayObjectContainer的子类，比如 Sprite）组成。 容器是一个包含子节点（子节点可以是叶子节点或者其他容器）的显示对象。 Stage处于显示列表树的顶级节点，同样也是一个容器。 要创建一个Starling应用，你需要创建一个自定义的Sprite的子类，Starling会添加一个该子类的实例对象到stage上。 一个显示对象有定义它自身相对于它的父级的位置的属性（x，y），有旋转和缩放参数（scaleX，scaleY）， 可以使用alpha 和 visible属性分别控制显示对象的透明度和可见性。 每个显示对象都有可能是触碰事件的目标，你可以设置"touchable"属性来禁止对象被触碰。 当它被设置为禁止触碰，对象本身和它的子对象都不会再响应触碰事件。 坐标转换 在显示坐标树里，每个对象都有自己的局部坐标系统，如果你旋转一个容器，意味着你旋转了整个容器的坐标 系统，并且影响到了容器的所有子对象。 有时候你需要知道某个点相对于其他坐标系的坐标，getTransformationMatrix函数实现了这个功能。 它将创建一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 子类 由于DisplayObject是抽象类,所以你不能直接实例化它，只能用某个它的子类。目前已经有很多这样的子类了， 大部分情况下它们应该能够满足你的需要了。 然而，你也可以自定义你自己的子类，要实现自定义的子类，你需要实现自定义的渲染方法，在你自定义的子类中 需要实现下面的方法： function render(support:RenderSupport, parentAlpha:Number):void function getBounds(targetSpace:DisplayObject, resultRect:Rectangle=null):Rectangle 请参阅Quad类，它对于"getBounds"方法有一个简单的实现。 一个简单的例子阐述如何创建自定义的渲染方法，你可以参考这个在Starling Wiki上的自定义显示对象 当你重载render方法时，请注意调用辅助对象(一个RenderSupport对象)的'finishQuadBatch'方法。 这将促使Starling使用不同的渲染方法来渲染之前累计的所有四边形（鉴于性能考虑），否则，z-ordering将会出错。
DisplayObjectContainer
starling.display 一个显示对象容器是一个包含了各种显示对象的集合。 这是所有容器类（包含其他显示对象的容器）的基类。它拥有一个有序列表来管理子级对象，并在显示对象树立定义了 所有子级的显示顺序。 一个容器本身是没有尺寸的，它的宽度和高度代表了子级的范围，改变这些属性会缩放它的所有子级。 由于DisplayObjectContainer是一个抽象类，你不能直接实例化它，而是应该使用它的子类。 其中最轻量级的容器子类是"Sprite"。 添加和删除子级 这个类包含了一些允许你添加和删除子级的方法。 当你添加一个子级，它会被添加到列表的最顶层，有可能会遮挡住前一个添加的子级。 你可以通过索引访问子级，第一个子级索引为0，第二个子级索引为1，以此类推。 向容器添加或者删对象会派发一些不冒泡的事件。 Event.ADDED: 对象被添加到了它的父级。 Event.ADDED_TO_STAGE: 对象被添加到了它的父级，并且父级已经被添加 到stage上，因此对象立即显示。 Event.REMOVED: 从对象的父级删除该对象。 Event.REMOVED_FROM_STAGE: 从对象的父级删除该对象，并且父级已经被添加 到stage上，因此对象立即不显示。 尤其是ADDED_TO_STAGE事件是非常有用的，因为它可以让你在一个对象第一次被渲染时自动执行一些逻辑（比如开始播放一段动画）。
EnterFrameEvent
starling.events 处于显示列表树中的所有显示对象，在每一帧都会派发一个EnterFrameEvent事件。 它包含了从上一帧到现在所经过的时间的信息。这样，您就可以轻松的通过帧频创建动画，传递经过的时间给它。
Event
starling.events 当事件派发时，事件对象会作为参数传递给事件侦听器。这是Flash Event类的Starling版本。 EventDispatcher对象会创建这个类的实例并将它派发到一个已注册的事件侦听器。 一个事件对象包含了作为这个事件特征的信息，其中非常重要的是事件类型，如果事件冒泡的话。 事件的目标(target)是派发这个事件的对象。 对于某些类型的事件，这些信息就足够了，其他事件可能需要更多的信息来传递给侦听器。 在这种情况下，您可以创建“事件”的子类，并添加您所需要的所有信息作为事件的属性。 “EnterFrameEvent”是这种做法的一个例子，它增加了一个属性用来表示已经执行的时间值。 此外，事件类包含的方法可以中断事件的派发，阻止事件被其它的侦听器接受。（ 包括完全阻止 或只是阻止进入下一个冒泡阶段）
EventDispatcher
starling.events EventDispatcher类是所有具备调度事件能力的类的基类。这是传统Flash里的EventDispatcher在Starling中的对应实现。 事件机制也是Starling架构的一个关键特性。通过事件对象可以互相通信。相比传统Flash的事件系统，Starling的事件 系统是经过简化的。 主要区别在于，Starling事件没有“捕捉”的阶段。这些事件只是简单的被一个对象派发，并可以选择 冒泡。他们不能向相反的方向传递。 就像传统的Flash类那样，显示对象只要继承EventDispatcher就可以派发事件。但要小心， Starling中的事件不能和传统Flash的事件混用。 Starling的显示对象会派发Starling事件，冒泡也是在Starling 显示对象中进行-但是他们不能派发或冒泡传统Flash显示对象的事件。
FragmentFilter
starling.filters FragmentFilter(片段滤镜)类是Starling中所有滤镜效果的基类。这个包中所有的其它滤镜都是扩展自这个类。 你可以通过使用属性'filter'，将这些滤镜附加到任何显示对象上。 一个片段滤镜是通过如下的方式工作的: 应用滤镜的对象会被渲染到一个纹理上 (在全局坐标系下). 然后这个纹理会被传递给第一个滤镜处理通道。 每一个通道使用片段着色器(或者额外再加一个顶点着色器)来处理纹理，实现特定的效果。 每一个通道的输出，将会作为下一个通道的输入。如果它是最终的通道，就会把它直接渲染到后台缓冲区。 所有的这些过程，都被抽象类FragmentFilter定义了。所有的子类只需要覆盖这几个方法： 'createPrograms', 'activate' 和 (可选) 'deactivate'，来创建和执行它的自定义着色代码。 每一个滤镜可以设置为取代原来的显示对象，或在显示对象的上层或下层绘制。这取决于'mode'属性的设置，可选值定义在'FragmentFilterMode'这个类中。 需要注意的是，在同一时刻，每一个滤镜只能应用于一个显示对象。否则，它就会变的很慢，需要更多的资源和缓存，并导致无法预料的后果。
FragmentFilterMode
starling.filters 这个类提供了一些静态变量来表示滤镜模式。 这些值用于FragmentFilter.mode属性，并且定义一个滤镜和一个原有对象结合后的呈现结果。
HAlign
starling.utils 提供物件水平方向上的对齐常量值.
IAnimatable
starling.animation IAnimatable接口定义了这样的一些对象：基于一个时间范围实现动画过程。任何实现了这个接口的类的实例，都可以被添加到juggler。 当一个对象不再需要运动的时候，你应当将它从juggler删除。要实现这一点，你可以手动执行这个方法：juggler.remove(object) 来删除它， 或者让这个对象派发一个事件来请求juggler删除自己，事件类型是Event.REMOVE_FROM_JUGGLER.
Image
starling.display 一个图片是一个映射了纹理的四边形。 Image类相当于Flash的Bitmap类的Starling版本，不过Starling是用纹理来代替BitmapData来提供图像的像素资源。 要显示一个纹理，你需要把它映射到一个四边形上--这就是Image类的功能。 因为"Image"是继承自"Quad",所以你可以给它设置颜色。 每个像素的颜色是根据纹理的颜色和四边形的颜色相乘得来的，这样，你就可以很容易的根据一个颜色改变纹理的色调。 此外，Image允许你对纹理坐标进行操作，你可以在不改变四边形任何顶点坐标的情况下，在图片的内部移动纹理。 你还可以使用这种功能以一个非常高效的方式创建一个矩形遮罩。
Juggler
starling.animation Juggler管理那些实现了IAnimatable接口的对象（比如Tweens）并执行它们。 一个juggler实例是一个非常简单的对象。它只是持有一个列表，列表里面是那些实现了IAnimatable接口的对象，并管理它们的执行时间（通过对象自己的advanceTime方法）。当动画播放完毕，就把这个对象抛出。 在Starling类中有一个默认的juggler变量: var juggler:Juggler = Starling.juggler; 你可以创建你自己的juggler对象，如果需要的话。这样，你就可以组合你的游戏到一些逻辑组件，并独立控制他们的动画。 你需要做的就是，在每一帧都调用你自定义的juggler的advanceTime方法。 juggler另一个很强的特性就是"delayCall"方法。使用它可以延迟执行某个方法。但是和传统的延迟调用(比如setTimeout)不同, 这个方法只有在juggler被时间推送器驱动的时候才会起作用，这可以让你更加完美的控制呼叫的逻辑。 下面是delayCall的一些示例： juggler.delayCall(object.removeFromParent, 1.0); juggler.delayCall(object.addChild, 2.0, theChild); juggler.delayCall(function():void { doSomethingFunny(); }, 3.0);
KeyboardEvent
starling.events 一个键盘事件的派发，是对用户使用键盘输入的回应。 这个类是Flash的键盘事件的Starling版本。它包含了和Flash的键盘事件相同的属性。 要捕获键盘事件，需要在Starling的stage上添加事件侦听。stage的子节点是不能获取到键盘事件的。 Starling并没有像传统Flash那样的“焦点”的概念。
MatrixUtil
starling.utils 一个包含矩阵相关方法的类
MissingContextError
starling.errors 当需要Context3D对象而它不存在或尚未准备好的时候，会抛出一个MissingContextError。
MovieClip
starling.display 一个影片剪辑(MovieClip)根据一个纹理集合来显示动画。 传入包含纹理的集合给MovieClip的构造函数作为影片剪辑的帧。影片剪辑会根据第一帧的纹理来确定影片的宽度和高度。 如果你使用纹理图集TextureAtlas（推荐使用此方法）来组织你的帧，请使用纹理图集的getTextures方法 获取正确(按字母次序的)的纹理顺序。 你可以在构造函数中指定一个特定的帧频，如果需要，你还可以设置每一帧的执行时间，或者在某一帧执行时播放一个声音。 play 和 pause 方法可以控制影片的播放，当影片播放完毕时，你会接收到一个Event.MovieCompleted 事件。如果影片是循环播放的，这个事件会在每一次循环都派发。 同其他动画对象一样，一个影片剪辑必须添加到一个juggler（或者是一个拥有自己的定时执行的advanceTime方法的对象）里来运行。 当影片剪辑播放完最后一帧时，会派发"Event.COMPLETE"事件。
Quad
starling.display 一个四边形代表了由单一颜色或者渐变颜色填充的矩形。 你可以设置每一个顶点的颜色。不同顶点的颜色会在颜色交汇的地方平滑的过度。 要让四边形显示一个线性的渐变颜色，需要给顶点0,1设置一个颜色，然后给顶点2,3设置另一个颜色。 四边形的四个顶点的位置是这样排列的: 0 - 1 | / | 2 - 3
QuadBatch
starling.display QuadBatch类用于优化渲染大量具备相同状态的四边形(Quad类).
RectangleUtil
starling.utils 一个增强Rectangle类功能的工具类.
RenderSupport
starling.core 这个类 包含了简化Stage3D渲染的辅助方法.
RenderTexture
starling.textures RenderTexture是一个能在其上绘制任何显示对象的动态纹理。 在创建一个RenderTexture对象后，仅需调用 drawObject 方法直接在纹理上渲染一个对象。 对象将会在当前位置，连带当前的旋转，缩放和透明值属性被绘制在纹理上。 绘制能够被高效的完成，因为它在显存中是直接发生的。绘制能够被高效的完成，因为它在显存中是直接发生的。 当你在纹理上绘制完对象后，不管你绘制了多少个对象，它的性能将和通常的纹理没什么区别。 如果你一次绘制许多的对象的话，推荐通过drawBundled方法把绘制调用捆绑在一个代码块中，像下面展示的一样。 那将会产生极大地提速，允许你迅速绘制几百个对象。 renderTexture.drawBundled(function():void { for (var i:int=0; i<numDrawings; ++i) { image.rotation = (2 * Math.PI / numDrawings) * i; renderTexture.draw(image); } }); 为了擦除一个经渲染纹理的一部分，你可以使用像“rubber”一样的任意显示对象通过设置它的混合模式为"BlendMode.ERASE"。 注意当Starling的渲染上下文丢失，渲染纹理就不能够被恢复。
ResizeEvent
starling.events 当Flash容器的尺寸改变后，stage会派发一个ResizeEvent。用这个值可以更新Starling的视口和stage的尺寸。 事件的属性包含了更新后的Flash Player的宽度和高度。如果您希望缩放stage上的内容来充满屏幕， 请更新 Starling.current.viewPort 矩形区域。如果您希望使用额外的屏幕区域， 请更新 stage.stageWidth 和 stage.stageHeight
ScaleMode
starling.utils 用于'RectangleUtil.fit' 方法的缩放模式常量值.
Sprite
starling.display Sprite是一个极其轻量，非抽象的容器类。 通常把Sprite作为一种把一组显示对象集中到一个坐标系内的简单手段，也可以把它用做自定义显示对象的基类。 "平面化" Sprite对象 flatten方法允许你在渲染时优化显示列表中的静态部分。 flatten 分析了添加到这个Sprite的显示列表的子对象，优化了渲染调用，极大的提高了渲染速度。 但是速度的大幅提升是要付出代价的：你将再也看不见子对象属性的任何变化（位置，旋转，透明等等）。 要更新这个sprite对象的显示，只需再一次调用flatten，或者unflatten这个对象。
Stage
starling.display Stage是显示列表树的根节点，只有直接或者间接放置到stage上的显示对象才会被渲染。 这个类相当于Starling版本的Stage，注意不要和传统的Flash里的Stage混淆。 传统的Flash里的Stage只能包含类型为flash.display.DisplayObject的对象， 而Starling里的Stage只能包含类型为starling.display.DisplayObject的对象， 由于Starling显示列表并不等同于传统Flash显示列表，所以这些类并不兼容，不能混用，也不能互相代替。 stage对象是被Starling类自动创建的，请不要手动创建一个stage对象。 键盘事件 在Starling中，键盘事件只能够在stage派发，所以，如果想捕获到派发的键盘事件，只能给stage添加键盘事件监听。 尺寸变化事件 当Flash player 尺寸变化时，stage会派发一个ResizeEvent事件。 这个事件的属性包含更新后的Flash player的宽度和高度。
Starling
starling.core Starling类展现了Starling框架的核心.
SubTexture
starling.textures 一个SubTexture用于表现另一个纹理的一部分。由于这是完全通过操作纹理坐标实现的，使得这个类非常高效。 注意：从子纹理继续创建子纹理也是允许的。
TextField
starling.text TextField类用来显示文本，使用标准的True Type字体或自定义位图字体。 您可以设置你用到的所有属性，比如字体名称和字号，颜色，横向和垂直对齐方式，等等。边框属性对于开发是非常有帮助的，因为这样可以让您看到文本的边界。 有两种类型的字体可以被显示: 标准的true type字体.
Texture
starling.textures 纹理是用来储存展示图像的信息。它不能直接被添加到显示列表；相应的它必须映射到一个显示对象上。 在Staring中那个显示对象就是“Image”类。 纹理格式 纹理能够由一个“BitmapData”对象创建，Starling能够支持任何Flash所支持的bitmap格式。 并且由于你能够将任何Flash显示对象转换为BitmapData对象，你就能够利用这点在Starling中 去显示非Starling内容,比如说Shape对象。 Starling同时支持ATF纹理（Adobe Texture Format），一个能够通过GPU高效渲染的被压缩纹理的容器。 Mip映射 MipMaps是按比例缩小的纹理类型。当一个图像被显示时小于它本来的尺寸时， GPU可能就会用mip maps去替代原生纹理。这就可以减少走样和加速渲染。当然这也需要额外的内存开销； 你可以权衡利弊之后选择是否使用它。 纹理框架 纹理的frame属性允许你设置纹理在image对象中的界限，在纹理周围留有透明空白区域。 frame矩形被指定在纹理的坐标系统中，而不是image: var frame:Rectangle = new Rectangle(-10, -10, 30, 30); var texture:Texture = Texture.fromTexture(anotherTexture, null, frame); var image:Image = new Image(texture); 这段代码会创建一个30x30大小的图像，纹理会被放置在图像x=10, y=10 的位置上（假设'anotherTexture'是一个宽高都为10像素的纹理，它将出现在图像的正中位置）。 纹理集就采用了这个特性，它允许裁剪一个纹理的透明边缘用来弥补由指定的原始纹理框架改变的尺寸。 可以使用TexturePacker这样的工具来优化纹理集。 纹理坐标系 假如，从另一方面讲，你只想在图像中显示纹理的一部分（就是说修剪这个纹理）， 你可以创建一个子纹理（通过方法'Texture.fromTexture()'然后指定一个限定范围的矩形）， 或者你也可以操作image对象的纹理坐标系。方法'image.setTexCoords'允许你那样做。
TextureAtlas
starling.textures 纹理集是一个将许多小的纹理整合到一张大图中。这个类是用来从一个纹理集中读取纹理。 使用纹理集能为你的纹理解决两个问题: 在一定的时间内，始终有一个纹理处于活动的。每当你改变了处于活动的纹理，一个 “纹理切换”就会执行，这个切换是需要时间的。 任何Stage3D纹理的边长都必须是2的幂数。Starling向你隐藏了这个限制，但这将带来 额外的图形存储成本。 通过使用纹理集，您可以避免使用纹理切换和取消2的幂数的限制。所有的纹理被集合在一 个“超级纹理”，并且Starling会确保纹理正确的部分被显示出来。 有几种方法来创建纹理集。一种是使用捆绑在Starling的姊妹框架 Sparrow framework。里的纹理集生成脚本。 尽管目前这个脚本只能运行在Mac OS X上。 另一个可供选择的出色工具 Texture Packer， 他是一个跨平台的商业软件。 无论您使用的工具是什么，Starling可以支持以下文档格式: <TextureAtlas imagePath='atlas.png'> <SubTexture name='texture_1' x='0' y='0' width='50' height='50'/> <SubTexture name='texture_2' x='50' y='0' width='20' height='30'/> </TextureAtlas> 如果你的图像在边缘具有透明区域，您可以使用Texture类的frame属性。 通过 去除纹理的透明边缘并且指定原始尺寸就像这样： <SubTexture name='trimmed' x='0' y='0' height='10' width='10' frameX='-10' frameY='-10' frameWidth='30' frameHeight='30'/>
TextureSmoothing
starling.textures 这个类为可能的材质平滑算法提供常量值。
Touch
starling.events 一个Touch对象包含了在屏幕上的一个手指或鼠标的相关信息（出现或移动）。 您将从TouchEvent中获取这个对象。当这样的事件被触发，您可以查询目前呈现在屏幕上的所有触碰。 一个Touch对象，包含了一个单指触碰的信息。一个Touch对象总是会通过TouchPhases的集合移动。请参阅TouchPhase类来获取更多信息。 触碰的位置 您可以用相应的属性，获取坐标系上的当前的和上一个位置。当然，在大部分情况下您希望能获取在一个不同的坐标系上的位置。 基于这个原因，这里有一些方法可以转换当前的和上一个位置到任何对象的局部坐标系。
TouchEvent
starling.events 一个TouchEvent是被手指触碰或鼠标输入来触发的。 在Starling中，无论是触碰事件还是鼠标事件，都统一封装为一个类：TouchEvent。 要处理用户在一个可触碰的屏幕或使用鼠标完成的输入， 您需要注册一个事件侦听器，来侦听类型是TouchEvent.TOUCH的事件。 这是唯一的您需要捕获的事件类型； 原有Flash里面的那个很长的事件类型列表，全都被映射到一个"TouchPhases"里面。 鼠标输入和触摸屏输入的区别是： 在某一时刻只有一个鼠标光标可以呈现 只有鼠标才可以"hover",即在没有按下按键的情况下滑过一个对象。 哪些对象能够接收触碰事件？ 在Starling中，任何一个显示对象都可以接受触碰事件，只要它的 touchable 属性，以及它的父级都是可用状态(true)。 在Starling中是没有"InteractiveObject"这个类的。 如何使用单个触碰对象 T事件包含了一个包括所有的触碰对象的列表。每一个独立的触碰都被保存在一个类型是"Touch"的对象里。 既然您通常只对在特定对象上发生的触碰感兴趣，您可以查询事件，传入一个具体的目标： var touches:Vector.<Touch> = touchEvent.getTouches(this); 这会返回附加在"this"或 它的子级上的所有触碰对象。如果您没有使用多点触碰，您也可以直接访问触碰对象，就像这样： var touch:Touch = touchEvent.getTouch(this);
TouchPhase
starling.events 这个类提供了描述触碰的各个阶段的常量值。 一个触碰，在它的生命周期内会遵循下面的过程： BEGAN(开始) -> MOVED(移动) -> ENDED(结束) 此外，一个触碰可能进入一个称之为STATIONARY(静止)的阶段。这一阶段本身不会触发触碰事件，并且它只能发生在多点触控环境。 在某些场合下需要一个解决方案，比如一个手指移动，另一个静止。这个时候，一个触碰事件必须由正在移动的手指下方的对象来派发。 在这个事件的触碰对象列表中，您将会找到第二个处于静止状态的触碰对象。 最后，还有一个称之为HOVER(悬停)的状态，这种情况只会发生在使用鼠标的情况下。 它是由Flash的MouseOver事件触发的，并且这个时候鼠标按键没有被按下。
Transitions
starling.animation Transitions(过渡)类包含了一些静态方法，来定义缓动相关的函数。这些函数被用在Tween类执行动画的时候。 关于transitions这里有一张很直观的图片描述： 你可以使用"registerTransition" 方法来自定义过渡方式.
Tween
starling.animation 一个Tween实例，将使用补间动画的方式，"运动"某个对象的属性(比如改变x坐标值，从1,2,3...一直到N，从而形成视觉上的动画效果)。 它可以使用不同的过渡方法，来实现不同的动画方式。 这个类的主要用途是实现标准的动画，比如移动，透明度渐变，旋转等等。但是"动画"的范围远远不止于此。只要你想"运动"的对象的属性值是数字 (int, uint, Number), Tween就能搞定它。 要了解Tween可以使用的过渡方法的列表，请参阅"Transitions"类。 下面是一个实例，展示了tween移动一个对象到右侧，旋转它，然后让它透明度逐渐降低而消失: var tween:Tween = new Tween(object, 2.0, Transitions.EASE_IN_OUT); tween.animate("x", object.x + 50); tween.animate("rotation", deg2rad(45)); tween.fadeTo(0); // 你也可以使用'animate("alpha", 0)'来代替 Starling.juggler.add(tween); 注意在上面的代码的最后，tween的实例被添加到了juggler。这是因为，只有tween自己的"advanceTime"方法被实际执行的时候，tween才会起作用。 这个工作juggler会帮你做的，而且它会自动在tween执行完毕的时候删除它。
VAlign
starling.utils 提供物件垂直方向上的对齐常量值.
VertexData
starling.utils 顶点数据类，它管理一个顶点信息的原始数据列表，允许直接上传到Stage3D顶点缓冲池中.


All Classes - Starling API 1.3 | Starling中文站

All Classes

AbstractClassError
AbstractMethodError
AGALMiniAssembler
AssetManager
BitmapChar
BitmapFont
BlendMode
BlurFilter
Button
Color
ColorMatrixFilter
ConcreteTexture
DelayedCall
DisplayObject
DisplayObjectContainer
EnterFrameEvent
Event
EventDispatcher
FragmentFilter
FragmentFilterMode
HAlign
IAnimatable
Image
Juggler
KeyboardEvent
MatrixUtil
MissingContextError
MovieClip
Quad
QuadBatch
RectangleUtil
RenderSupport
RenderTexture
ResizeEvent
ScaleMode
Sprite
Stage
Starling
SubTexture
TextField
Texture
TextureAtlas
TextureSmoothing
Touch
TouchEvent
TouchPhase
Transitions
Tween
VAlign
VertexData


All Packages

Starling API 1.3 | Starling中文站 | All Classes | Index | Frames No Frames | Adobe Logo
All Packages |

package | Description
com.adobe.utils |
starling.animation |
starling.core |
starling.display |
starling.errors |
starling.events |
starling.filters |
starling.text |
starling.textures |
starling.utils |


B

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
B Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
backBufferHeight — Property, class starling.core.RenderSupport
 | 后台缓冲区的高度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。
backBufferWidth — Property, class starling.core.RenderSupport
 | 后台缓冲区的宽度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。
base — Property, class starling.display.DisplayObject
 | 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。
base — Property, class starling.textures.ConcreteTexture
 | 纹理所基于的Stage3D纹理对象。
base — Property, class starling.textures.RenderTexture
 | 纹理所基于的Stage3D纹理对象。
base — Property, class starling.textures.SubTexture
 | 纹理所基于的Stage3D纹理对象。
base — Property, class starling.textures.Texture
 | 纹理所基于的Stage3D纹理对象。
baseline — Property, class starling.text.BitmapFont
 | 字体的基线.
baseTextureID — Property, class starling.filters.FragmentFilter
 | 输入纹理的ID(取样器)，包含上一个通道的输出
batchQuad(quad:starling.display:Quad, parentAlpha:Number, texture:starling.textures:Texture, smoothing:String) — method, class starling.core.RenderSupport
 | 在当前未渲染的四角面组中添加一个四角面.
BEGAN — Constant Static Property, class starling.events.TouchPhase
 | 当手指刚刚接触屏幕，或者鼠标按下。
BELOW — Constant Static Property, class starling.filters.FragmentFilterMode
 | 滤镜在对象的下方显示
BILINEAR — Constant Static Property, class starling.textures.TextureSmoothing
 | 双线性过滤。创建像素间的平滑过渡。
BitmapChar — class, package starling.text
 | 一个 BitmapChar包含了位图字体的一个字符的相关信息。 在大多数情况下您不需要直接使用这个类。TextField类已经为您做了封装。
BitmapChar(id:int, texture:starling.textures:Texture, xOffset:Number, yOffset:Number, xAdvance:Number) — Constructor, class starling.text.BitmapChar
 | 根据纹理和它的属性创建一个字符
BitmapFont — class, package starling.text
 | BitmapFont类解析bitmap字体文件，并保存在一个字符表中。 这个类解析的XML格式的文件使用了 AngelCode Bitmap Font Generator or the Glyph Designer.
BitmapFont(texture:starling.textures:Texture, fontXml:XML) — Constructor, class starling.text.BitmapFont
 | 通过解析XML文件创建一个位图字体，并使用指定的纹理。如果不传递任何数据，就使用内嵌的MINI字型。
BLACK — Constant Static Property, class starling.utils.Color
blendMode — Property, class starling.core.RenderSupport
 | 在渲染中将要使用的混合模式.要应用这个设置，你必须手工调用"applyBlendMode"方法(因为实际的混合因素依赖于对PMA模式)。
blendMode — Property, class starling.display.DisplayObject
 | 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。
BlendMode — class, package starling.display
 | BlendMode类提供了混合模式视觉效果的常量。 一个混合模式，总是由两个'Context3DBlendFactor'值来定义。一个混合因素代表一个特定的四个数值的数组。 这个数组是根据源颜色和目标颜色用混合公式计算的，公式如下： result = source × sourceFactor + destination × destinationFactor 在这个公式里，源颜色是像素着色器的输出颜色，目标颜色是在上一次清除和绘制操作以后，颜色缓冲区中当前存在的颜色。 要注意的是，由于纹理类型的不同，混合因素产生产生的输出也不同。 纹理可能包含'预乘透明度'(pma)，意思就是它们的RGB色值是根据它们的颜色值分别相乘得到的（目的是节省计算时间）。 基于'BitmapData'的纹理，会含有预乘透明度值，ATF纹理没有这个值。 因此，一个混合模式可能会根据pma的值而拥有不同的混合因素。
BLUE — Constant Static Property, class starling.utils.Color
BlurFilter — class, package starling.filters
 | BlurFilter用于在一个对象上创建高斯模糊效果。可以分别在x轴和y轴的方向上设置模糊的强度（全局坐标系）。 也可以设置为一个阴影或外发光滤镜。使用特定的静态方法来创建特定的滤镜。
BlurFilter(blurX:Number, blurY:Number, resolution:Number) — Constructor, class starling.filters.BlurFilter
 | 创建一个新的BlurFilter对象。对每个模糊的方向，所需的通道数量是Math.ceil(blur)。 blur = 0.5: 1 pass blur = 1.0: 1 pass blur = 1.5: 2 passes blur = 2.0: 2 passes etc. 你应该考虑降低分辨率，来代替提高通道的数量。较低的分辨率也会产生虚化的图像，并且这样可以同时降低渲染的成本。
blurX — Property, class starling.filters.BlurFilter
 | 在x轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。
blurY — Property, class starling.filters.BlurFilter
 | 在y轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。
bold — Property, class starling.text.TextField
 | 字体加粗.
border — Property, class starling.text.TextField
 | 围绕文本框绘制一个边框.
BOTTOM — Constant Static Property, class starling.utils.VAlign
 | 底对齐.
bounds — Property, class starling.display.DisplayObject
 | 返回显示对象相对于父级对象坐标系的矩形区域。
broadcastEvent(event:starling.events:Event) — method, class starling.display.DisplayObjectContainer
 | 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。
broadcastEventWith(type:String, data:Object) — method, class starling.display.DisplayObjectContainer
 | 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。
bubbles — Property, class starling.events.Event
 | 表示事件是否冒泡
Button — class, package starling.display
 | 一个简单的按钮由一张图片和一个可选的文本组成。 你可以分别为按钮构造函数传递up和down两种状态的纹理。 如果你没有指定一个down状态的纹理，按钮会采用默认的办法：被触碰的时候缩小一点。 此外，你可以在按钮上覆盖一个文本，要自定义这个文本，只需要提供和原来的基本相同的文本框即可。 你可以使用textBounds属性，将文本移动到一个指定的位置。 判断按钮是否被触碰，请使用triggered事件类型， 用这个事件来代替普通的触碰事件。也就是说，用户只要在松开手指或者鼠标之前，移动手指/鼠标离开按钮区域，就可以取消对该按钮的点击操作。
Button(upState:starling.textures:Texture, text:String, downState:starling.textures:Texture) — Constructor, class starling.display.Button
 | 创建一个按钮实例，设置它的up和down状态的纹理，以及文本。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


C

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
C Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
cache() — method, class starling.filters.FragmentFilter
 | 缓存滤镜输出到一个纹理。一个没有缓存的滤镜，会在每一帧进行渲染；而一个缓存的滤镜则只需要渲染一次。 当然，如果应用滤镜的对象或滤镜设置改变了，缓存也应该被更新；要做到这一点，可以再次调用'cache'方法。
CANCEL — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
CENTER — Constant Static Property, class starling.utils.HAlign
 | 居中对齐.
CENTER — Constant Static Property, class starling.utils.VAlign
 | 居中对齐.
CHANGE — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
charCode — Property, class starling.events.KeyboardEvent
 | 按键的字符代码。
charID — Property, class starling.text.BitmapChar
 | 字符的唯一标示.
clear(rgb:uint, alpha:Number) — method, class starling.core.RenderSupport
 | 以特定颜色和透明度清除渲染内容.
clear(rgb:uint, alpha:Number) — Static Method , class starling.core.RenderSupport
 | 以特定颜色和透明度清除渲染内容.
clear() — method, class starling.textures.RenderTexture
 | 清除纹理（恢复完整透明值）。
clearCache() — method, class starling.filters.FragmentFilter
 | 清理滤镜的缓存输出。在这个方法调用后，滤镜将会在每帧执行一次。
clipping — Property, class starling.textures.SubTexture
 | 一个在初始化时规定缩放到[0.0, 1.0]的裁剪矩形区域。
clone() — method, class starling.display.QuadBatch
 | 复制当前对象。
clone() — method, class starling.events.Touch
 | 创建这个一个Touch对象的副本
clone(vertexID:int, numVertices:int) — method, class starling.utils.VertexData
 | 创建一个完成顶点数据对象或子集的一个副本.
CLOSE — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
color — Property, class starling.display.Quad
 | 返回四边形的颜色，如果四边形存在多个颜色，返回第一个顶点的颜色。
color — Property, class starling.display.Stage
 | 舞台的背景颜色
color — Property, class starling.text.TextField
 | 字体颜色，在位图字体中，使用 Color.WHITE来代替默认的颜色.
Color — class, package starling.utils
 | 一个非常有用的类，包含在不用颜色表现间转换的预定义颜色和方法.
ColorMatrixFilter — class, package starling.filters
 | ColorMatrixFilter(颜色矩阵滤镜)允许你为输入图片的每个像素的RGBA颜色值和透明度，应用一个4的矩阵变换，来产生一个新的包含RGBA颜色和透明度的数据集。 它允许你调整色相变化，饱和度，亮度调整，以及其它各种效果。 这个类包含了一些用于颜色调整的简便方法。所有这些方法都会改变当前的矩阵，这就意味着你可以很容易的把它们组合在一个滤镜里面: //用50%的饱和度和180度的色相旋转创建一个翻转滤镜 var filter:ColorMatrixFilter = new ColorMatrixFilter(); filter.invert(); filter.adjustSaturation(-0.5); filter.adjustHue(1.0); 如果你希望让颜色的变化产生动画效果，就在每一步重置滤镜，或者在每一步使用相同的调整值；这个改变就会逐渐累加。
ColorMatrixFilter(matrix:Vector$Number) — Constructor, class starling.filters.ColorMatrixFilter
 | 根据传入的矩阵创建一个新的ColorMatrixFilter实例。
COLOR_OFFSET — Constant Static Property, class starling.utils.VertexData
 | 每个顶点内的颜色数据 (r, g, b, a) 偏移量.
com.adobe.utils — package
compile(object:starling.display:DisplayObject, quadBatches:Vector$starling.display:QuadBatch) — Static Method , class starling.display.QuadBatch
 | 分析一个专门由四边形（或者其他容器）组成的容器对象， 并且创建一个矢量数组(元素类型是QuadBatch)来代替容器。 这可以用来非常高效的渲染容器。 Sprite类的'flatten'方法在内部使用了这个方法。
complete — Event, class starling.display.MovieClip
 | 当影片剪辑播放完最后一帧时进行派发。
COMPLETE — Constant Static Property, class starling.events.Event
 | 事件类型：可以用在一些表示“完成”的场合。
concat(matrix:Vector$Number) — method, class starling.filters.ColorMatrixFilter
 | 将当前矩阵和另一个矩阵合并。
ConcreteTexture — class, package starling.textures
 | 一个封装了Stage3D纹理对象的ConcreteTexture，用于存储纹理属性。
ConcreteTexture(base:flash.display3D.textures:TextureBase, format:String, width:int, height:int, mipMapping:Boolean, premultipliedAlpha:Boolean, optimizedForRenderTexture:Boolean, scale:Number) — Constructor, class starling.textures.ConcreteTexture
 | 创建一个具有TextureBase和存储信息(关于尺寸,mip映射和该Texture对象的alpha通道是否被 预乘到RGB)的ConcreteTexture对象。
configureBackBuffer(width:int, height:int, antiAlias:int, enableDepthAndStencil:Boolean) — method, class starling.core.RenderSupport
 | 配置当前Context3D对象的后台缓冲区。 通过使用这个方法，Starling可以存储后台缓冲区的大小，并且在其它方法(比如矩形区域的裁切)中使用这个信息。 后台缓冲区的宽度和高度，可以在以后通过相同的属性名称来访问。
contains(object:starling.animation:IAnimatable) — method, class starling.animation.Juggler
 | 判断juggler是否持有对这个对象的引用.
contains(child:starling.display:DisplayObject) — method, class starling.display.DisplayObjectContainer
 | 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。
contentScaleFactor — Property, class starling.core.Starling
 | 渲染范围和舞台的比率。在针对不同分辨率选择不同材质时非常有用。
context — Property, class starling.core.Starling
 | 这个实例的渲染上下文.
context3DCreate — Event, class starling.core.Starling
 | 新的渲染环境创建后派发事件.
CONTEXT3D_CREATE — Constant Static Property, class starling.events.Event
 | 事件类型：表示创建(或重建)了Context3D实例。
contextData — Property, class starling.core.Starling
 | 一个字典对象，用于保存当前上下文相关的自定义数据。如果你需要把共享数据绑定到一个特定的Stage3D实例（比如纹理），可用使用这个字典来代替创建一个静态变量。 这个字典实际上是绑定到一个Stage3D的实例上，所以它的生命周期取决于这个Stage3D实例是否丢失。
convertTo3D(matrix:flash.geom:Matrix, resultMatrix:flash.geom:Matrix3D) — Static Method , class starling.utils.MatrixUtil
 | 2D矩阵转换为3D矩阵.如果传入'resultMatrix',则结果会存储在这个矩阵中，而不是创建一个新对象.
copyTo(targetData:starling.utils:VertexData, targetVertexID:int, vertexID:int, numVertices:int) — method, class starling.utils.VertexData
 | 拷贝改实例的顶点数据(或者它的一个范围，由'vertexID' 和 'numVertices'定义) 到另一个顶点数据对象，从某个确定索引算起.
copyVertexDataTo(targetData:starling.utils:VertexData, targetVertexID:int) — method, class starling.display.Image
 | 复制源顶点数据到一个VertexData实例。 纹理坐标已经存在于渲染所需的格式中。
copyVertexDataTo(targetData:starling.utils:VertexData, targetVertexID:int) — method, class starling.display.Quad
 | 拷贝四边形的顶点数据到一个新的顶点数据实例。
createDropShadow(distance:Number, angle:Number, color:uint, alpha:Number, blur:Number, resolution:Number) — Static Method , class starling.filters.BlurFilter
 | 创建一个模糊滤镜，并设置为阴影的效果。
createGlow(color:uint, alpha:Number, blur:Number, resolution:Number) — Static Method , class starling.filters.BlurFilter
 | 创建一个模糊滤镜，并设置为外发光的效果。
createImage() — method, class starling.text.BitmapChar
 | 据字符创建一个图片.
createPrograms() — method, class starling.filters.FragmentFilter
 | 子类必须覆盖这个方法，并且使用它来创建他们自己的片段和顶点着色程序
createSprite(width:Number, height:Number, text:String, fontSize:Number, color:uint, hAlign:String, vAlign:String, autoScale:Boolean, kerning:Boolean) — method, class starling.text.BitmapFont
 | 创建一个包含字符图片的Sprite对象
ctrlKey — Property, class starling.events.KeyboardEvent
 | 判断Ctrl键（Windows或Linux）或Ctrl/Command键（Mac OS）是否被激活，按下为true，松开为false。
ctrlKey — Property, class starling.events.TouchEvent
 | 表示，事件发生时ctrl键是否被按下。 (Mac OS: Cmd 或 Ctrl)
current — Static Property, class starling.core.Starling
 | 现在激活的 Starling 实例.
currentFrame — Property, class starling.display.MovieClip
 | 当前正在播放的帧的索引。
currentTarget — Property, class starling.events.Event
 | 当前事件已经冒泡到的对象。
currentTime — Property, class starling.animation.DelayedCall
 | 目前已经消逝的时间(单位是秒).
currentTime — Property, class starling.animation.Tween
 | 已经执行的时间(秒)
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


D

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
D Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
data — Property, class starling.events.Event
被添加到事件上的任意数据对象
deactivate(pass:int, context:flash.display3D:Context3D, texture:starling.textures:Texture) — method, class starling.filters.FragmentFilter
这个方法会在'context.drawTriangles'方法调用之后，被调用。如果你需要做一些诸如清理资源的工作，可以在这个方法里面来做。
deg2rad(deg:Number) — Package Function, starling.utils
角度转换为弧度.
delay — Property, class starling.animation.Tween
动画需要延迟多长时间才开始.默认是0
delayCall(call:Function, delay:Number, ... rest) — method, class starling.animation.Juggler
在一定的时间间隔之后执行指定的方法。方法会创建一个DelayedCall类的实例并返回。从juggler中删除这个实例即可取消调用。
DelayedCall — class, package starling.animation
DelayedCall类允许你在一定的时间间隔之后去执行某个方法(和setTimeout有些类似)。由于这个类实现了IAnimatable接口，你可以把一个DelayedCall实例添加到juggler中。 在大部分情况下，你不需要直接使用这个类；Juggler类包含了一个方法来直接实现延迟调用这个功能。 当方法调用完毕之后，DelayedCall对象会派发一个类型是“Event.REMOVE_FROM_JUGGLER”的事件，然后如果不再需要它了，Juggler会自动将它删除。
DelayedCall(call:Function, delay:Number, args:Array) — Constructor, class starling.animation.DelayedCall
创建一个延迟调用对象(DelayedCall的实例)
deleteProgram(name:String) — method, class starling.core.Starling
根据指定的名称，删除一个顶点着色程序和片段着色程序.
dispatchEvent(event:starling.events:Event) — method, class starling.events.EventDispatcher
派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。
dispatchEventWith(type:String, bubbles:Boolean, data:Object) — method, class starling.events.EventDispatcher
派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。
DisplayObject — class, package starling.display
DisplayObject 类是所有可放在显示列表中，在屏幕上可以被渲染的对象的基类。 显示列表树 在Starling中，所有可显示对象都处于显示列表树中，只有属于显示列表树的成员才可以在屏幕上显示和渲染。 显示列表树由可以直接渲染到屏幕的叶子节点（Image, Quad）和容器节点（DisplayObjectContainer的子类，比如 Sprite）组成。 容器是一个包含子节点（子节点可以是叶子节点或者其他容器）的显示对象。 Stage处于显示列表树的顶级节点，同样也是一个容器。 要创建一个Starling应用，你需要创建一个自定义的Sprite的子类，Starling会添加一个该子类的实例对象到stage上。 一个显示对象有定义它自身相对于它的父级的位置的属性（x，y），有旋转和缩放参数（scaleX，scaleY）， 可以使用alpha 和 visible属性分别控制显示对象的透明度和可见性。 每个显示对象都有可能是触碰事件的目标，你可以设置"touchable"属性来禁止对象被触碰。 当它被设置为禁止触碰，对象本身和它的子对象都不会再响应触碰事件。 坐标转换 在显示坐标树里，每个对象都有自己的局部坐标系统，如果你旋转一个容器，意味着你旋转了整个容器的坐标 系统，并且影响到了容器的所有子对象。 有时候你需要知道某个点相对于其他坐标系的坐标，getTransformationMatrix函数实现了这个功能。 它将创建一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 子类 由于DisplayObject是抽象类,所以你不能直接实例化它，只能用某个它的子类。目前已经有很多这样的子类了， 大部分情况下它们应该能够满足你的需要了。 然而，你也可以自定义你自己的子类，要实现自定义的子类，你需要实现自定义的渲染方法，在你自定义的子类中 需要实现下面的方法： function render(support:RenderSupport, parentAlpha:Number):void function getBounds(targetSpace:DisplayObject, resultRect:Rectangle=null):Rectangle 请参阅Quad类，它对于"getBounds"方法有一个简单的实现。 一个简单的例子阐述如何创建自定义的渲染方法，你可以参考这个在Starling Wiki上的自定义显示对象 当你重载render方法时，请注意调用辅助对象(一个RenderSupport对象)的'finishQuadBatch'方法。 这将促使Starling使用不同的渲染方法来渲染之前累计的所有四边形（鉴于性能考虑），否则，z-ordering将会出错。
DisplayObjectContainer — class, package starling.display
一个显示对象容器是一个包含了各种显示对象的集合。 这是所有容器类（包含其他显示对象的容器）的基类。它拥有一个有序列表来管理子级对象，并在显示对象树立定义了 所有子级的显示顺序。 一个容器本身是没有尺寸的，它的宽度和高度代表了子级的范围，改变这些属性会缩放它的所有子级。 由于DisplayObjectContainer是一个抽象类，你不能直接实例化它，而是应该使用它的子类。 其中最轻量级的容器子类是"Sprite"。 添加和删除子级 这个类包含了一些允许你添加和删除子级的方法。 当你添加一个子级，它会被添加到列表的最顶层，有可能会遮挡住前一个添加的子级。 你可以通过索引访问子级，第一个子级索引为0，第二个子级索引为1，以此类推。 向容器添加或者删对象会派发一些不冒泡的事件。 Event.ADDED: 对象被添加到了它的父级。 Event.ADDED_TO_STAGE: 对象被添加到了它的父级，并且父级已经被添加 到stage上，因此对象立即显示。 Event.REMOVED: 从对象的父级删除该对象。 Event.REMOVED_FROM_STAGE: 从对象的父级删除该对象，并且父级已经被添加 到stage上，因此对象立即不显示。 尤其是ADDED_TO_STAGE事件是非常有用的，因为它可以让你在一个对象第一次被渲染时自动执行一些逻辑（比如开始播放一段动画）。
dispose() — method, class starling.core.RenderSupport
删除所四角面.
dispose() — method, class starling.core.Starling
销毁stage的所有子级和渲染上下文，删除所有的事件侦听器
dispose() — method, class starling.display.DisplayObject
销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。
dispose() — method, class starling.display.DisplayObjectContainer
释放所有子级的资源。
dispose() — method, class starling.display.QuadBatch
销毁顶点和索引缓冲区。
dispose() — method, class starling.display.Sprite
释放所有子级的资源。
dispose() — method, class starling.filters.BlurFilter
销毁滤镜 (着色程序, 缓冲区, 纹理).
dispose() — method, class starling.filters.ColorMatrixFilter
销毁滤镜 (着色程序, 缓冲区, 纹理).
dispose() — method, class starling.filters.FragmentFilter
销毁滤镜 (着色程序, 缓冲区, 纹理).
dispose() — method, class starling.text.BitmapFont
销毁位图字体的纹理
dispose() — method, class starling.text.TextField
销毁纹理数据
dispose() — method, class starling.textures.ConcreteTexture
释放TextureBase对象的纹理数据。
dispose() — method, class starling.textures.RenderTexture
如果ownsParent为true释放父级纹理对象。
dispose() — method, class starling.textures.SubTexture
如果ownsParent为true释放父级纹理对象。
dispose() — method, class starling.textures.Texture
销毁基本纹理。注意并非所有的纹理都需要销毁：SubTextures(从'Texture.fromTexture'创建的)只是引用其它的纹理， 并且并不占用额外的资源空间；它可能是一个纹理图集的一部分。
dispose() — method, class starling.textures.TextureAtlas
释放纹理集。
dispose() — method, class starling.utils.AssetManager
销毁所有的纹理
downState — Property, class starling.display.Button
按钮被触碰时显示的纹理。
draw(object:starling.display:DisplayObject, matrix:flash.geom:Matrix, alpha:Number, antiAliasing:int) — method, class starling.textures.RenderTexture
绘制一个对象到纹理上。
drawBundled(drawingBlock:Function, antiAliasing:int) — method, class starling.textures.RenderTexture
把几个draw的调用一起捆绑在一个代码块中。这就避免了缓冲开关并且允许你绘制多 个对象到一个非持久（non-persistent）的纹理上。
drawCount — Property, class starling.core.RenderSupport
指出stage3D绘制调用次数.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


E

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
E Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
easeCombined(startFunc:Function, endFunc:Function, ratio:Number) — Static Method , class starling.animation.Transitions
easeIn(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN — Constant Static Property, class starling.animation.Transitions
easeInBack(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_BACK — Constant Static Property, class starling.animation.Transitions
easeInBounce(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_BOUNCE — Constant Static Property, class starling.animation.Transitions
easeInElastic(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_ELASTIC — Constant Static Property, class starling.animation.Transitions
easeInOut(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_OUT — Constant Static Property, class starling.animation.Transitions
easeInOutBack(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_OUT_BACK — Constant Static Property, class starling.animation.Transitions
easeInOutBounce(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_OUT_BOUNCE — Constant Static Property, class starling.animation.Transitions
easeInOutElastic(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_IN_OUT_ELASTIC — Constant Static Property, class starling.animation.Transitions
easeOut(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT — Constant Static Property, class starling.animation.Transitions
easeOutBack(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_BACK — Constant Static Property, class starling.animation.Transitions
easeOutBounce(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_BOUNCE — Constant Static Property, class starling.animation.Transitions
easeOutElastic(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_ELASTIC — Constant Static Property, class starling.animation.Transitions
easeOutIn(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_IN — Constant Static Property, class starling.animation.Transitions
easeOutInBack(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_IN_BACK — Constant Static Property, class starling.animation.Transitions
easeOutInBounce(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_IN_BOUNCE — Constant Static Property, class starling.animation.Transitions
easeOutInElastic(ratio:Number) — Static Method , class starling.animation.Transitions
EASE_OUT_IN_ELASTIC — Constant Static Property, class starling.animation.Transitions
elapsedTime — Property, class starling.animation.Juggler
 | 这个juggler对象截止到目前的存活时间累计.
ELEMENTS_PER_VERTEX — Constant Static Property, class starling.utils.VertexData
 | 存储每个顶点元素的总数量.
empty(width:int, height:int, premultipliedAlpha:Boolean, optimizeForRenderToTexture:Boolean, scale:Number) — Static Method , class starling.textures.Texture
 | 根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。
enabled — Property, class starling.display.Button
 | 按钮是否能够被触碰(即是否禁用)。
enableErrorChecking — Property, class starling.core.Starling
 | Stage3D 渲染方法是否报告发生的错误.
ENDED — Constant Static Property, class starling.events.TouchPhase
 | 手指离开屏幕或鼠标松开。
enqueue(... rest) — method, class starling.utils.AssetManager
 | 将一个或一组素材加入到队列中；只有在成功调用了"loadQueue"方法后这些资源才可用。这个方法可以接受下面这些类型： 使用字符串定义的URL，链接到一个本地或远程网络上的资源。支持类型: png, jpg, atf, mp3, fnt, xml (纹理图集). File类的实例 (只有AIR应用适用) 指定的一个目录或一个文件.如果是目录，则会自动扫描该目录下所有支持的文件类型。 包含静态成员结合Embed方式内嵌素材的类. 对象的名称会自动提取：比如一个文件名称是"image.png"，那么会自动将素材命名为"image"。如果是通过类的嵌入素材方式，那么变量名称就会使用嵌入时那个名称。 一个例外是纹理图集：他们将具备相同的名称（实际引用的那个纹理名称）。
enterFrame — Event, class starling.display.DisplayObject
 | 在每一帧派发给stage上的所有显示对象。
ENTER_FRAME — Constant Static Property, class starling.events.EnterFrameEvent
 | 一个显示对象进入了新的一帧。
ENTER_FRAME — Constant Static Property, class starling.events.Event
 | 事件类型：一个显示对象进入了新的一帧。
EnterFrameEvent — class, package starling.events
 | 处于显示列表树中的所有显示对象，在每一帧都会派发一个EnterFrameEvent事件。 它包含了从上一帧到现在所经过的时间的信息。这样，您就可以轻松的通过帧频创建动画，传递经过的时间给它。
EnterFrameEvent(type:String, passedTime:Number, bubbles:Boolean) — Constructor, class starling.events.EnterFrameEvent
 | 创建一个EnterFrameEvent实例
ERASE — Constant Static Property, class starling.display.BlendMode
 | 当绘制渲染纹理的时候擦除背景。
error — Property, class com.adobe.utils.AGALMiniAssembler
 | 错误信息
Event — class, package starling.events
 | 当事件派发时，事件对象会作为参数传递给事件侦听器。这是Flash Event类的Starling版本。 EventDispatcher对象会创建这个类的实例并将它派发到一个已注册的事件侦听器。 一个事件对象包含了作为这个事件特征的信息，其中非常重要的是事件类型，如果事件冒泡的话。 事件的目标(target)是派发这个事件的对象。 对于某些类型的事件，这些信息就足够了，其他事件可能需要更多的信息来传递给侦听器。 在这种情况下，您可以创建“事件”的子类，并添加您所需要的所有信息作为事件的属性。 “EnterFrameEvent”是这种做法的一个例子，它增加了一个属性用来表示已经执行的时间值。 此外，事件类包含的方法可以中断事件的派发，阻止事件被其它的侦听器接受。（ 包括完全阻止 或只是阻止进入下一个冒泡阶段）
Event(type:String, bubbles:Boolean, data:Object) — Constructor, class starling.events.Event
 | 创建一个作为参数传递给事件侦听器的 Event 对象。
EventDispatcher — class, package starling.events
 | EventDispatcher类是所有具备调度事件能力的类的基类。这是传统Flash里的EventDispatcher在Starling中的对应实现。 事件机制也是Starling架构的一个关键特性。通过事件对象可以互相通信。相比传统Flash的事件系统，Starling的事件 系统是经过简化的。 主要区别在于，Starling事件没有“捕捉”的阶段。这些事件只是简单的被一个对象派发，并可以选择 冒泡。他们不能向相反的方向传递。 就像传统的Flash类那样，显示对象只要继承EventDispatcher就可以派发事件。但要小心， Starling中的事件不能和传统Flash的事件混用。 Starling的显示对象会派发Starling事件，冒泡也是在Starling 显示对象中进行-但是他们不能派发或冒泡传统Flash显示对象的事件。
EventDispatcher() — Constructor, class starling.events.EventDispatcher
 | 创建一个EventDispatcher实例。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


F

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
F Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
fadeTo(alpha:Number) — method, class starling.animation.Tween
 | "运动"目标对象的'alpha'值，直到达到目标值。
fillQuadBatch(quadBatch:starling.display:QuadBatch, width:Number, height:Number, text:String, fontSize:Number, color:uint, hAlign:String, vAlign:String, autoScale:Boolean, kerning:Boolean) — method, class starling.text.BitmapFont
 | 将文本绘制成QuadBatch.
filter — Property, class starling.display.DisplayObject
 | 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。
finishQuadBatch() — method, class starling.core.RenderSupport
 | 渲染当前四角面组然后重置.
fit(rectangle:flash.geom:Rectangle, into:flash.geom:Rectangle, scaleMode:String, pixelPerfect:Boolean, resultRect:flash.geom:Rectangle) — Static Method , class starling.utils.RectangleUtil
 | 根据等比缩放的原则计算传入的'rectangle'(矩形)，并相对于'into'(矩形)来居中。 这个方法可用于根据指定的显示尺寸，计算最佳的viewPort区域。你可以使用不同的缩放模式，从而得到不同的计算结果。 此外，你可以通过只允许全数字相乘/相除(比如3，2，1，1/2，1/3)来避免像素排列错误。
flatten — Event, class starling.display.Sprite
 | 当"平面化"这个对象时，向对象的所有子级派发此事件。
flatten() — method, class starling.display.Sprite
 | 优化Sprite对象得到最佳渲染性能。 对于被"平面化"的Sprite，子对象的改变是不会有任何显示更新的。 要更新这个Sprite对象的显示，只需再一次调用flatten，或者对它进行unflatten。
FLATTEN — Constant Static Property, class starling.events.Event
 | 事件类型：一个即将被扁平化的对象派发。
fontBold — Property, class starling.display.Button
 | 文本字体是否加粗。
fontColor — Property, class starling.display.Button
 | 文本字体颜色。
fontName — Property, class starling.display.Button
 | 按钮上显示文本的字体名称。 可能是系统字体，或者已注册的位图字体。
fontName — Property, class starling.text.TextField
 | 字体名称 (true type字体或位图字体).
fontSize — Property, class starling.display.Button
 | 文本字体大小。
fontSize — Property, class starling.text.TextField
 | 字号，在位图字体中，使用BitmapFont.NATIVE_SIZE来代替原来的大小
format — Property, class starling.textures.ConcreteTexture
 | 基本纹理数据的Context3DTextureFormat。
format — Property, class starling.textures.SubTexture
 | 基本纹理数据的Context3DTextureFormat。
format — Property, class starling.textures.Texture
 | 基本纹理数据的Context3DTextureFormat。
formatString(format:String, ... rest) — Package Function, starling.utils
 | 格式化字符串.样式为配对的大括号(如"{0}").还不支持任何数字格式化选项.
fps — Property, class starling.display.MovieClip
 | 每秒播放的帧的默认数量。 不同的帧可以有不同的执行时间。 如果你改变fps,所有帧的执行时间将会相对于原来的值增加或减少。
FragmentFilter — class, package starling.filters
 | FragmentFilter(片段滤镜)类是Starling中所有滤镜效果的基类。这个包中所有的其它滤镜都是扩展自这个类。 你可以通过使用属性'filter'，将这些滤镜附加到任何显示对象上。 一个片段滤镜是通过如下的方式工作的: 应用滤镜的对象会被渲染到一个纹理上 (在全局坐标系下). 然后这个纹理会被传递给第一个滤镜处理通道。 每一个通道使用片段着色器(或者额外再加一个顶点着色器)来处理纹理，实现特定的效果。 每一个通道的输出，将会作为下一个通道的输入。如果它是最终的通道，就会把它直接渲染到后台缓冲区。 所有的这些过程，都被抽象类FragmentFilter定义了。所有的子类只需要覆盖这几个方法： 'createPrograms', 'activate' 和 (可选) 'deactivate'，来创建和执行它的自定义着色代码。 每一个滤镜可以设置为取代原来的显示对象，或在显示对象的上层或下层绘制。这取决于'mode'属性的设置，可选值定义在'FragmentFilterMode'这个类中。 需要注意的是，在同一时刻，每一个滤镜只能应用于一个显示对象。否则，它就会变的很慢，需要更多的资源和缓存，并导致无法预料的后果。
FragmentFilter(numPasses:int, resolution:Number) — Constructor, class starling.filters.FragmentFilter
 | 根据指定的通道数量和分辨率，创建一个新的片段滤镜。只有在子类的构造方法中，才能调用这个构造方法。
FragmentFilterMode — class, package starling.filters
 | 这个类提供了一些静态变量来表示滤镜模式。 这些值用于FragmentFilter.mode属性，并且定义一个滤镜和一个原有对象结合后的呈现结果。
frame — Property, class starling.textures.Texture
 | 纹理框架（参阅类描述）
fromAtfData(data:flash.utils:ByteArray, scale:Number, useMipMaps:Boolean, loadAsync:Function) — Static Method , class starling.textures.Texture
 | 通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。 如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;
fromBitmap(bitmap:flash.display:Bitmap, generateMipMaps:Boolean, scale:Number) — Static Method , class starling.display.Image
 | 根据传入的位图对象创建一个包含纹理的Image。
fromBitmap(data:flash.display:Bitmap, generateMipMaps:Boolean, optimizeForRenderToTexture:Boolean, scale:Number) — Static Method , class starling.textures.Texture
 | 通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
fromBitmapData(data:flash.display:BitmapData, generateMipMaps:Boolean, optimizeForRenderToTexture:Boolean, scale:Number) — Static Method , class starling.textures.Texture
 | 通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
fromColor(width:int, height:int, color:uint, optimizeForRenderToTexture:Boolean, scale:Number) — Static Method , class starling.textures.Texture
 | 创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。
fromTexture(texture:starling.textures:Texture, region:flash.geom:Rectangle, frame:flash.geom:Rectangle) — Static Method , class starling.textures.Texture
 | 从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。
FUCHSIA — Constant Static Property, class starling.utils.Color
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


G

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
G Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
getAlpha(color:uint) — Static Method , class starling.utils.Color
 | 返回ARGB的alpha部分(0 - 255).
getAlpha(vertexID:int) — method, class starling.utils.VertexData
 | 返回顶点Aplha值 (范围 0-1).
getBitmapFont(name:String) — Static Method , class starling.text.TextField
 | 获取一个位图纹理
getBlendFactors(mode:String, premultipliedAlpha:Boolean) — Static Method , class starling.display.BlendMode
 | 根据指定的模式名称和预乘透明度返回混合因素。 如果模式不存在，会抛出一个参数错误。
getBlue(color:uint) — Static Method , class starling.utils.Color
 | 返回(A)RGB的blue部分(0 - 255).
getBounds(targetSpace:starling.display:DisplayObject, resultRect:flash.geom:Rectangle) — method, class starling.display.DisplayObject
 | 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
getBounds(targetSpace:starling.display:DisplayObject, resultRect:flash.geom:Rectangle) — method, class starling.display.DisplayObjectContainer
 | 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
getBounds(targetSpace:starling.display:DisplayObject, resultRect:flash.geom:Rectangle) — method, class starling.display.Quad
 | 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
getBounds(targetSpace:starling.display:DisplayObject, resultRect:flash.geom:Rectangle) — method, class starling.display.QuadBatch
 | 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
getBounds(targetSpace:starling.display:DisplayObject, resultRect:flash.geom:Rectangle) — method, class starling.text.TextField
 | 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
getBounds(transformationMatrix:flash.geom:Matrix, vertexID:int, numVertices:int, resultRect:flash.geom:Rectangle) — method, class starling.utils.VertexData
 | 计算顶点范围，可以选择性的通过矩阵进行转换.
getChar(charID:int) — method, class starling.text.BitmapFont
 | 根据指定的字符ID返回一个位图字符
getChildAt(index:int) — method, class starling.display.DisplayObjectContainer
 | 根据指定的索引返回对应的子级对象。
getChildByName(name:String) — method, class starling.display.DisplayObjectContainer
 | 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。
getChildIndex(child:starling.display:DisplayObject) — method, class starling.display.DisplayObjectContainer
 | 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。
getColor(vertexID:int) — method, class starling.utils.VertexData
 | 返回顶点RGB值 (无alpha).
getFrame(name:String) — method, class starling.textures.TextureAtlas
 | 根据一个特定区域返回一个矩形框架,如果那个区域内没有框架就返回null。
getFrameDuration(frameID:int) — method, class starling.display.MovieClip
 | 返回指定索引的帧的执行时间（单位：秒）。
getFrameSound(frameID:int) — method, class starling.display.MovieClip
 | 根据帧索引返回其相对应的声音。
getFrameTexture(frameID:int) — method, class starling.display.MovieClip
 | 根据帧索引返回其相对应的纹理。
getGreen(color:uint) — Static Method , class starling.utils.Color
 | 返回(A)RGB的green部分(0 - 255).
getKerning(charID:int) — method, class starling.text.BitmapChar
 | 根据特定的字符ID返回边距
getLocation(space:starling.display:DisplayObject, resultPoint:flash.geom:Point) — method, class starling.events.Touch
 | 转换当前touch的位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。
getMovement(space:starling.display:DisplayObject, resultPoint:flash.geom:Point) — method, class starling.events.Touch
 | 返回从上一个位置到当前位置移动的距离。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。
getNames(prefix:String, result:Vector$String) — method, class starling.textures.TextureAtlas
 | 根据指定的起始字符串，返回符合条件的所有纹理名称，按字母顺序排序。
getNextPowerOfTwo(number:int) — Package Function, starling.utils
 | 返回大于或等于这个指定的数，这个数为紧接着的2的倍数.
getPosition(vertexID:int, position:flash.geom:Point) — method, class starling.utils.VertexData
 | 返回顶点位置.
getPreviousLocation(space:starling.display:DisplayObject, resultPoint:flash.geom:Point) — method, class starling.events.Touch
 | 转换touch的上一个位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。
getProgram(name:String) — method, class starling.core.Starling
 | 根据指定的名称，返回一个已注册的顶点着色程序和片段着色程序.
getRed(color:uint) — Static Method , class starling.utils.Color
 | 返回(A)RGB的red部分(0 - 255).
getRegion(name:String) — method, class starling.textures.TextureAtlas
 | 根据特定名称返回一个矩形区域。
getSound(name:String) — method, class starling.utils.AssetManager
 | 根据指定的名称返回一个声音
getSoundNames(prefix:String) — method, class starling.utils.AssetManager
 | 根据指定的字符串前缀返回符合条件的声音名称，按照字母排序。
getTexCoords(vertexID:int, resultPoint:flash.geom:Point) — method, class starling.display.Image
 | 获取一个顶点的纹理坐标，坐标范围：[0,1]。
getTexCoords(vertexID:int, texCoords:flash.geom:Point) — method, class starling.utils.VertexData
 | 返回顶点纹理坐标值 (范围 0-1).
getTexture(name:String) — method, class starling.textures.TextureAtlas
 | 根据名称返回一个子纹理。如果没有找到，就返回null。
getTexture(name:String) — method, class starling.utils.AssetManager
 | 根据指定的名称返回一个纹理。这个方法首先会查询所有直接添加进来的纹理； 如果找不到这个名称的纹理，则会继续从所有的纹理图集中继续查找。
getTextureAtlas(name:String) — method, class starling.utils.AssetManager
 | 根据指定的名称，返回一个纹理图集，找不到的话就返回null
getTextureNames(prefix:String, result:Vector$String) — method, class starling.utils.AssetManager
 | 根据一个指定的字符串前缀，返回所有符合条件的纹理名称，按照字母排序。
getTextures(prefix:String, result:Vector$starling.textures:Texture) — method, class starling.textures.TextureAtlas
 | 返回由一个指定的字符串开始按字母排序的所有纹理(这对"MovieClip"来说非常有用)。
getTextures(prefix:String, result:Vector$starling.textures:Texture) — method, class starling.utils.AssetManager
 | 根据指定的字符串前缀，返回所有符合条件的纹理，按照字母排序（对于"MovieClip"非常有用）。
getTouch(target:starling.display:DisplayObject, phase:String) — method, class starling.events.TouchEvent
 | 返回附加到指定对象上的一个触碰对象。
getTouches(target:starling.display:DisplayObject, phase:String, result:Vector$starling.events:Touch) — method, class starling.events.TouchEvent
 | 返回附加在指定的对象上的触碰对象数组。如果你传递一个'result'数组，那么会将touch对象添加到这个数组中来代替创建一个新的数组。
getTransformationMatrix(targetSpace:starling.display:DisplayObject, resultMatrix:flash.geom:Matrix) — method, class starling.display.DisplayObject
 | 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。
getTransition(name:String) — Static Method , class starling.animation.Transitions
 | 通过指定一个唯一的名称，获取过渡的实现方法
getVertexAlpha(vertexID:int) — method, class starling.display.Quad
 | 返回指定索引的顶点的透明度。
getVertexColor(vertexID:int) — method, class starling.display.Quad
 | 返回指定索引的顶点的颜色。
globalToLocal(globalPoint:flash.geom:Point, resultPoint:flash.geom:Point) — method, class starling.display.DisplayObject
 | 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。
globalX — Property, class starling.events.Touch
 | touch对象在stage坐标系的X坐标值。
globalY — Property, class starling.events.Touch
 | touch对象在stage坐标系的Y坐标值。
GRAY — Constant Static Property, class starling.utils.Color
GREEN — Constant Static Property, class starling.utils.Color
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


H

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
H Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
hAlign — Property, class starling.text.TextField
 | 文本的横向对齐方式.
HAlign — final class, package starling.utils
 | 提供物件水平方向上的对齐常量值.
handleLostContext — Static Property, class starling.core.Starling
 | 是否启用 “丢失内容修复功能 ”.在某些系统中，在进入屏保或者进入睡眠会禁用渲染，这个设置指示Starling是否 要解决这个问题。注意这项功能会消耗大量内存！建议在Android和Windows下启动，在Mac OS X和iOS中禁用。
hasEventListener(type:String) — method, class starling.events.EventDispatcher
 | 判断是否具备指定的事件类型的侦听器。
hasProgram(name:String) — method, class starling.core.Starling
 | 根据指定的名称，判断这个顶点着色程序和片段着色程序是否被注册.
hasVisibleArea — Property, class starling.display.DisplayObject
 | 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false)
height — Property, class starling.display.DisplayObject
 | 显示对象的高度。
height — Property, class starling.events.ResizeEvent
 | 播放器更新后的高度。
height — Property, class starling.events.Touch
 | 压力区域的高度。如果设备不支持压力，则这个值永远是1.0.
height — Property, class starling.text.BitmapChar
 | 字符高度.
height — Property, class starling.text.TextField
 | 显示对象的高度。
height — Property, class starling.textures.ConcreteTexture
 | 以像素为单位的纹理高度。
height — Property, class starling.textures.SubTexture
 | 以像素为单位的纹理高度。
height — Property, class starling.textures.Texture
 | 以像素为单位的纹理高度。
hitTest(localPoint:flash.geom:Point, forTouch:Boolean) — method, class starling.display.DisplayObject
 | 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。
hitTest(localPoint:flash.geom:Point, forTouch:Boolean) — method, class starling.display.DisplayObjectContainer
 | 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。
hitTest(localPoint:flash.geom:Point, forTouch:Boolean) — method, class starling.display.Stage
 | 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回Stage本身。
HOVER — Constant Static Property, class starling.events.TouchPhase
 | 只有鼠标模式下可用：当光标滑过一个对象，并且没有按下鼠标。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


I

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
I Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
IAnimatable — Interface, package starling.animation
 | IAnimatable接口定义了这样的一些对象：基于一个时间范围实现动画过程。任何实现了这个接口的类的实例，都可以被添加到juggler。 当一个对象不再需要运动的时候，你应当将它从juggler删除。要实现这一点，你可以手动执行这个方法：juggler.remove(object) 来删除它， 或者让这个对象派发一个事件来请求juggler删除自己，事件类型是Event.REMOVE_FROM_JUGGLER.
id — Property, class starling.events.Touch
 | 一个Touch对象的唯一标示.
Image — class, package starling.display
 | 一个图片是一个映射了纹理的四边形。 Image类相当于Flash的Bitmap类的Starling版本，不过Starling是用纹理来代替BitmapData来提供图像的像素资源。 要显示一个纹理，你需要把它映射到一个四边形上--这就是Image类的功能。 因为"Image"是继承自"Quad",所以你可以给它设置颜色。 每个像素的颜色是根据纹理的颜色和四边形的颜色相乘得来的，这样，你就可以很容易的根据一个颜色改变纹理的色调。 此外，Image允许你对纹理坐标进行操作，你可以在不改变四边形任何顶点坐标的情况下，在图片的内部移动纹理。 你还可以使用这种功能以一个非常高效的方式创建一个矩形遮罩。
Image(texture:starling.textures:Texture) — Constructor, class starling.display.Image
 | 创建一个具有纹理映射的四边形。
interactsWith(target:starling.display:DisplayObject) — method, class starling.events.TouchEvent
 | 判断目标显示对象是否正在被触碰或被鼠标滑过。
intersect(rect1:flash.geom:Rectangle, rect2:flash.geom:Rectangle, resultRect:flash.geom:Rectangle) — Static Method , class starling.utils.RectangleUtil
 | 计算在两个矩形的交集。如果矩形不相交，则此方法返回一个空的Rectangle对象，其属性设置为0。
invert() — method, class starling.filters.ColorMatrixFilter
 | 翻转颜色
isCached — Property, class starling.filters.FragmentFilter
 | 判断滤镜是否被缓存了 (通过"cache" 方法).
isComplete — Property, class starling.animation.DelayedCall
 | 用来确定调用是否已经完成，如果为true则代表已经过去了足够的时间，调用已经完成了
isComplete — Property, class starling.animation.Tween
 | 动画是否播放完毕
isComplete — Property, class starling.display.MovieClip
 | 判断一个不循环的影片剪辑是否已经播完最后一帧。
isFlattened — Property, class starling.display.Sprite
 | 判断这个对象是否经过"平面化"处理。
isPersistent — Property, class starling.textures.RenderTexture
 | 指明纹理在经过多次绘制之后是否是持久的。
isPlaying — Property, class starling.display.MovieClip
 | 判断影片剪辑是否正在播放。播放完毕时返回false。
isStarted — Property, class starling.core.Starling
 | Starling 实例是否启动.
isStateChange(tinted:Boolean, parentAlpha:Number, texture:starling.textures:Texture, smoothing:String, blendMode:String, numQuads:int) — method, class starling.display.QuadBatch
 | 判断如果一个四边形可以被添加到批次，会否引起状态的变化。 状态变化可能是由于四边形使用了不同的基础纹理，可能是有不同的"是否染色"，"平滑度"，"纹理是否平铺显示"，或者"混合模式"设置， 可能是因为批次满了（一个批次最多包含8192个四边形）。
isTouching(target:starling.display:DisplayObject) — method, class starling.events.Touch
 | 判断一个对象或它的子级显示对象是否被触碰了。
isValid(smoothing:String) — Static Method , class starling.textures.TextureSmoothing
 | 确定一个平滑值是否是有效的。
isValid(hAlign:String) — Static Method , class starling.utils.HAlign
 | 指定给出的对齐字符串是否合法.
isValid(scaleMode:String) — Static Method , class starling.utils.ScaleMode
 | 判断缩放模式是否合法
isValid(vAlign:String) — Static Method , class starling.utils.VAlign
 | 指定给出的对齐字符串是否合法.
italic — Property, class starling.text.TextField
 | 是否是斜体.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


J

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
J Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
juggler — Property, class starling.core.Starling
 | 这个实例上的默认juggler对象.
Juggler — class, package starling.animation
 | Juggler管理那些实现了IAnimatable接口的对象（比如Tweens）并执行它们。 一个juggler实例是一个非常简单的对象。它只是持有一个列表，列表里面是那些实现了IAnimatable接口的对象，并管理它们的执行时间（通过对象自己的advanceTime方法）。当动画播放完毕，就把这个对象抛出。 在Starling类中有一个默认的juggler变量: var juggler:Juggler = Starling.juggler; 你可以创建你自己的juggler对象，如果需要的话。这样，你就可以组合你的游戏到一些逻辑组件，并独立控制他们的动画。 你需要做的就是，在每一帧都调用你自定义的juggler的advanceTime方法。 juggler另一个很强的特性就是"delayCall"方法。使用它可以延迟执行某个方法。但是和传统的延迟调用(比如setTimeout)不同, 这个方法只有在juggler被时间推送器驱动的时候才会起作用，这可以让你更加完美的控制呼叫的逻辑。 下面是delayCall的一些示例： juggler.delayCall(object.removeFromParent, 1.0); juggler.delayCall(object.addChild, 2.0, theChild); juggler.delayCall(function():void { doSomethingFunny(); }, 3.0);
Juggler() — Constructor, class starling.animation.Juggler
 | 创建一个空的juggler实例.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


K

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
K Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
kerning — Property, class starling.text.TextField
 | 指示是否启用字距.
KeyboardEvent — class, package starling.events
 | 一个键盘事件的派发，是对用户使用键盘输入的回应。 这个类是Flash的键盘事件的Starling版本。它包含了和Flash的键盘事件相同的属性。 要捕获键盘事件，需要在Starling的stage上添加事件侦听。stage的子节点是不能获取到键盘事件的。 Starling并没有像传统Flash那样的“焦点”的概念。
KeyboardEvent(type:String, charCode:uint, keyCode:uint, keyLocation:uint, ctrlKey:Boolean, altKey:Boolean, shiftKey:Boolean) — Constructor, class starling.events.KeyboardEvent
 | 创建一个新的KeyboardEvent实例。
keyCode — Property, class starling.events.KeyboardEvent
 | 按键的标示符号。
keyDown — Event, class starling.display.Stage
 | 当键盘按键按下时进行派发。
KEY_DOWN — Constant Static Property, class starling.events.KeyboardEvent
 | 事件类型：当一个键被按下。
keyLocation — Property, class starling.events.KeyboardEvent
 | 按键在键盘上的区域。如果一个按键会在键盘上出现多次，这个属性将非常有用 。
keyUp — Event, class starling.display.Stage
 | 当键盘按键松开时进行派发。
KEY_UP — Constant Static Property, class starling.events.KeyboardEvent
 | 事件类型：当一个键被释放。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


L

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
L Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
LEFT — Constant Static Property, class starling.utils.HAlign
 | 左对齐.
LIME — Constant Static Property, class starling.utils.Color
linear(ratio:Number) — Static Method , class starling.animation.Transitions
LINEAR — Constant Static Property, class starling.animation.Transitions
lineHeight — Property, class starling.text.BitmapFont
 | 行高.
loadIdentity() — method, class starling.core.RenderSupport
 | 把模型视图矩阵变换为单位矩阵.
loadQueue(onProgress:Function) — method, class starling.utils.AssetManager
 | 异步加载所有处于队列中的素材。'onProgress'方法会在加载过程中不断调用，并传递一个'ratio'值，范围是'0.0' 到 '1.0'，'1.0'就代表加载完成了。
localToGlobal(localPoint:flash.geom:Point, resultPoint:flash.geom:Point) — method, class starling.display.DisplayObject
 | 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。
loop — Property, class starling.display.MovieClip
 | 影片剪辑是否可以循环播放。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


M

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
M Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
makeCurrent() — method, class starling.core.Starling
 | 让Starling实例成为 current 实例.
marginX — Property, class starling.filters.FragmentFilter
 | x余量将会沿着X的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。
marginY — Property, class starling.filters.FragmentFilter
 | y余量将会沿着Y的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。
MAROON — Constant Static Property, class starling.utils.Color
matrix — Property, class starling.filters.ColorMatrixFilter
 | 拥有20个项的 4x5 矩阵.
MatrixUtil — class, package starling.utils
 | 一个包含矩阵相关方法的类
MINI — Constant Static Property, class starling.text.BitmapFont
 | 内嵌的一个小巧的位图字体.
mipMapping — Property, class starling.textures.ConcreteTexture
 | 表明纹理是否包含mip映射集。
mipMapping — Property, class starling.textures.SubTexture
 | 表明纹理是否包含mip映射集。
mipMapping — Property, class starling.textures.Texture
 | 表明纹理是否包含mip映射集。
MissingContextError — class, package starling.errors
 | 当需要Context3D对象而它不存在或尚未准备好的时候，会抛出一个MissingContextError。
MissingContextError(message:any, id:any) — Constructor, class starling.errors.MissingContextError
 | 创建一个新的MissingContextError对象。
mode — Property, class starling.filters.FragmentFilter
 | 滤镜模式, 由"FragmentFilterMode" 定义。
modelViewMatrix — Property, class starling.core.RenderSupport
 | 返回当前模型视图矩阵.
MOVED — Constant Static Property, class starling.events.TouchPhase
 | 手指在屏幕上滑动，或者鼠标在按下的情况下在屏幕上滑动。
moveTo(x:Number, y:Number) — method, class starling.animation.Tween
 | 同时"运动"目标对象的'x' 和 'y'两个值。用这个方法移动对象。
MovieClip — class, package starling.display
 | 一个影片剪辑(MovieClip)根据一个纹理集合来显示动画。 传入包含纹理的集合给MovieClip的构造函数作为影片剪辑的帧。影片剪辑会根据第一帧的纹理来确定影片的宽度和高度。 如果你使用纹理图集TextureAtlas（推荐使用此方法）来组织你的帧，请使用纹理图集的getTextures方法 获取正确(按字母次序的)的纹理顺序。 你可以在构造函数中指定一个特定的帧频，如果需要，你还可以设置每一帧的执行时间，或者在某一帧执行时播放一个声音。 play 和 pause 方法可以控制影片的播放，当影片播放完毕时，你会接收到一个Event.MovieCompleted 事件。如果影片是循环播放的，这个事件会在每一次循环都派发。 同其他动画对象一样，一个影片剪辑必须添加到一个juggler（或者是一个拥有自己的定时执行的advanceTime方法的对象）里来运行。 当影片剪辑播放完最后一帧时，会派发"Event.COMPLETE"事件。
MovieClip(textures:Vector$starling.textures:Texture, fps:Number) — Constructor, class starling.display.MovieClip
 | 根据传入的纹理集合和帧频来创建一个影片剪辑。 影片剪辑会根据传入的第一帧纹理来确定自己的尺寸。
MULTIPLY — Constant Static Property, class starling.display.BlendMode
 | 将显示对象的颜色值与背景的颜色相乘。
multitouchEnabled — Static Property, class starling.core.Starling
 | 是否支持多点触摸.
mVertexData — Property, class starling.display.Quad
 | 四边形的原始顶点数据。
mvpConstantID — Property, class starling.filters.FragmentFilter
 | 模型投影常数(4矩阵)的第一个寄存器ID
mvpMatrix — Property, class starling.core.RenderSupport
 | 计算模型视图矩阵和映射矩阵的商.
mvpMatrix3D — Property, class starling.core.RenderSupport
 | 计算模型视图矩阵和映射矩阵的商保存到一个三维矩阵中.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Menu

Starling 中文站
  • Starling最新动态
  • 第一步
  • Starling手册
  • 教程和代码
  • Starling扩展
  • 成功案例
  • 站外资料


N

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
N Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
name — Property, class starling.display.DisplayObject
 | 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。
name — Property, class starling.text.BitmapFont
 | 字体名称
nativeFilters — Property, class starling.text.TextField
 | 当你使用默认字体（TrueType）类型的时候，你可以使用Flash原生的 BitmapFilters!
nativeHeight — Property, class starling.textures.ConcreteTexture
 | 纹理的像素高度(忽略缩放参数).
nativeHeight — Property, class starling.textures.SubTexture
 | 纹理的像素高度(忽略缩放参数).
nativeHeight — Property, class starling.textures.Texture
 | 纹理的像素高度(忽略缩放参数).
nativeOverlay — Property, class starling.core.Starling
 | 在Starling 上面的原生Flash Sprite.使用它显示Flash原生组件
NATIVE_SIZE — Constant Static Property, class starling.text.BitmapFont
 | 为TextField类的fontSize属性设置这个常量，让位图字体按照它的默认大小渲染
nativeStage — Property, class starling.core.Starling
 | Flash (2D) 舞台对象,Starling 在其下渲染.
nativeWidth — Property, class starling.textures.ConcreteTexture
 | 纹理的像素宽度(忽略缩放参数).
nativeWidth — Property, class starling.textures.SubTexture
 | 纹理的像素宽度(忽略缩放参数).
nativeWidth — Property, class starling.textures.Texture
 | 纹理的像素宽度(忽略缩放参数).
NAVY — Constant Static Property, class starling.utils.Color
nextFrame() — method, class starling.core.RenderSupport
 | 重置矩阵和混合模式堆，四角面组索引,和绘画计数。
nextFrame() — method, class starling.core.Starling
 | 调用 advanceTime() (上一帧到现在的渲染时间) 和 render().
nextTween — Property, class starling.animation.Tween
 | 当这个tween完成的时候，立刻开始执行下一个tween
NO_BORDER — Constant Static Property, class starling.utils.ScaleMode
 | 等比缩放，填充整体区域，不留空白区域，有可能会对显示内容进行裁剪
NONE — Constant Static Property, class starling.display.BlendMode
 | 停用混合，即禁止任何透明度。
NONE — Constant Static Property, class starling.textures.TextureSmoothing
 | 不具备平滑, 通常称之为"Nearest Neighbor"。像素将放大成大个的矩形。
NONE — Constant Static Property, class starling.utils.ScaleMode
 | 不缩放矩形，但是在整个区域中居中
NORMAL — Constant Static Property, class starling.display.BlendMode
 | 显示对象显示在背景的前面。
numChildren — Property, class starling.display.DisplayObjectContainer
 | 容器包含的子级数量。
numFrames — Property, class starling.display.MovieClip
 | 影片剪辑的总帧数。
numPasses — Property, class starling.filters.FragmentFilter
 | 滤镜应用的通道数量.
numQuads — Property, class starling.display.QuadBatch
 | 四边形的数量。
numVertices — Property, class starling.utils.VertexData
 | 顶点总数.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


O

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
O Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
offsetX — Property, class starling.filters.FragmentFilter
 | 滤镜的左右偏移量.
offsetY — Property, class starling.filters.FragmentFilter
 | 滤镜的上下偏移量
OLIVE — Constant Static Property, class starling.utils.Color
onComplete — Property, class starling.animation.Tween
 | 当tween执行完毕的时候会调用的方法.
onCompleteArgs — Property, class starling.animation.Tween
 | 需要传递给'onComplete' 方法的参数.
onRepeat — Property, class starling.animation.Tween
 | 当Tween完成每一次执行的时候，会调用的方法。 (除了最后一次调用，因为它会触发'onComplete').
onRepeatArgs — Property, class starling.animation.Tween
 | 需要传递给'onRepeat' 方法的参数.
onStart — Property, class starling.animation.Tween
 | 当tween开始动画的时候会执行的方法 (如果有延迟的话，则在延迟之后).
onStartArgs — Property, class starling.animation.Tween
 | 需要传递给 'onStart' 方法的参数.
onUpdate — Property, class starling.animation.Tween
 | 动画过程中的每一帧都会执行的方法.
onUpdateArgs — Property, class starling.animation.Tween
 | 需要传递给'onUpdate' 方法的参数.
onVertexDataChanged() — method, class starling.display.Image
 | 在手动改变'mVertexData'的内容后调用此方法。
onVertexDataChanged() — method, class starling.display.Quad
 | 在手动改变'mVertexData'的内容后调用此方法。
OPEN — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
optimizedForRenderTexture — Property, class starling.textures.ConcreteTexture
 | 表示当基础纹理进行纹理渲染时是否优化。
ownsParent — Property, class starling.textures.SubTexture
 | 指示父级纹理对象是否因当前子纹理对象的释放而释放。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


P

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
P Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
parent — Property, class starling.display.DisplayObject
 | 包含该显示对象的显示对象容器。
parent — Property, class starling.textures.SubTexture
 | 该子纹理所基于的纹理对象。
parseAtlasXml(atlasXml:XML) — method, class starling.textures.TextureAtlas
 | 这个函数被构造函数调用,并用Starling默认的纹理集格式解析XML,重写 这个方法去创建自定义逻辑(举例来说 去支持一个不同的文档格式)。
passedTime — Property, class starling.events.EnterFrameEvent
 | 从上一帧到现在所经过的时间。（以秒为单位）
pause() — method, class starling.display.MovieClip
 | 暂停播放。
phase — Property, class starling.events.Touch
 | 当前触碰所处的阶段。
pivotX — Property, class starling.display.DisplayObject
 | 显示对象在自己的坐标系的起始x坐标（默认：0）
pivotY — Property, class starling.display.DisplayObject
 | 显示对象在自己的坐标系的起始y坐标（默认：0）
play() — method, class starling.display.MovieClip
 | 开始播放影片剪辑， 请确保影片已被添加到了juggler！
playSound(name:String, startTime:Number, loops:int, transform:flash.media:SoundTransform) — method, class starling.utils.AssetManager
 | 创建一个新的SoundChannel对象来播放声音.这个方法返回一个SoundChannel对象，这样你就可以用来停止声音播放或调整音量。
PMA — Constant Property, class starling.filters.FragmentFilter
 | 所有的滤镜处理预计都会使用预乘透明度
popMatrix() — method, class starling.core.RenderSupport
 | 访问保存在堆中的模型视图矩阵.
POSITION_OFFSET — Constant Static Property, class starling.utils.VertexData
 | 每个顶点内的位置数据 (x, y) 偏移量.
premultipliedAlpha — Property, class starling.textures.ConcreteTexture
 | 表明透明值是否被预乘到了RGB值中。
premultipliedAlpha — Property, class starling.textures.SubTexture
 | 表明透明值是否被预乘到了RGB值中。
premultipliedAlpha — Property, class starling.textures.Texture
 | 表明透明值是否被预乘到了RGB值中。
premultipliedAlpha — Property, class starling.utils.VertexData
 | 返回存储的rgb值是否与此apha值左自乘.
prependMatrix(matrix:flash.geom:Matrix) — method, class starling.core.RenderSupport
 | 与另一矩阵相乘得到模型视图矩阵.
prependMatrix(base:flash.geom:Matrix, prep:flash.geom:Matrix) — Static Method , class starling.utils.MatrixUtil
 | 通过与另一矩阵相乘，追加矩阵到'base'.
prependRotation(matrix:flash.geom:Matrix, angle:Number) — Static Method , class starling.utils.MatrixUtil
 | 追加一个增量旋转到Matrix3D中.
prependScale(matrix:flash.geom:Matrix, sx:Number, sy:Number) — Static Method , class starling.utils.MatrixUtil
 | 追加一个增量缩放变换到矩阵中.
prependSkew(matrix:flash.geom:Matrix, skewX:Number, skewY:Number) — Static Method , class starling.utils.MatrixUtil
 | 追加一个倾斜变换到矩阵中.
prependTranslation(matrix:flash.geom:Matrix, tx:Number, ty:Number) — Static Method , class starling.utils.MatrixUtil
 | 追加一个增量位移到矩阵中.
pressure — Property, class starling.events.Touch
 | 触摸在设备上的压力值（从0.0到1.0）。如果设备不支持压力，则这个值永远是1.0
previousGlobalX — Property, class starling.events.Touch
 | touch对象的上一个位置在stage坐标系的X坐标值。
previousGlobalY — Property, class starling.events.Touch
 | touch对象的上一个位置在stage坐标系的Y坐标值。
profile — Property, class starling.core.Starling
 | 在构造方法中传入的Context3D渲染方式.
projectionMatrix — Property, class starling.core.RenderSupport
 | 返回当前映射矩阵.
purge() — method, class starling.animation.Juggler
 | 一次性删除所有的对象
purge() — method, class starling.utils.AssetManager
 | 删除所有的素材，并清空队列
PURPLE — Constant Static Property, class starling.utils.Color
pushMatrix() — method, class starling.core.RenderSupport
 | 把当前模型视图矩阵推入堆中以便随后访问.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Package List - Starling API 1.3 | Starling中文站

Packages

com.adobe.utils
starling.animation
starling.core
starling.display
starling.errors
starling.events
starling.filters
starling.text
starling.textures
starling.utils


Q

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
Q Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Quad — class, package starling.display
 | 一个四边形代表了由单一颜色或者渐变颜色填充的矩形。 你可以设置每一个顶点的颜色。不同顶点的颜色会在颜色交汇的地方平滑的过度。 要让四边形显示一个线性的渐变颜色，需要给顶点0,1设置一个颜色，然后给顶点2,3设置另一个颜色。 四边形的四个顶点的位置是这样排列的: 0 - 1 | / | 2 - 3
Quad(width:Number, height:Number, color:uint, premultipliedAlpha:Boolean) — Constructor, class starling.display.Quad
 | 根据指定的尺寸和颜色创建一个四边形。 最后一个参数决定是否在渲染的时候预乘透明度值，从而影响混合输出的颜色值，大多数情况下可以使用默认值。
QuadBatch — class, package starling.display
 | QuadBatch类用于优化渲染大量具备相同状态的四边形(Quad类).
QuadBatch() — Constructor, class starling.display.QuadBatch
 | 用空的四边形数据创建一个新的 QuadBatch实例。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


R

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
R Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
rad2deg(rad:Number) — Package Function, starling.utils
 | 弧度转换为角度.
raiseDrawCount(value:uint) — method, class starling.core.RenderSupport
 | 提升绘制计数特定的数值.在调用自定义渲染方法时调用这个方法来保持渲染数据的同步
rawData — Property, class starling.utils.VertexData
 | 原始顶点数据; 非克隆数据!
readjustSize() — method, class starling.display.Image
 | 根据图像当前的纹理调整图像的尺寸，在为图片设置了另外一个不同的纹理以后，需要调用这个方法来同步图像和纹理的尺寸。
RectangleUtil — class, package starling.utils
 | 一个增强Rectangle类功能的工具类.
RED — Constant Static Property, class starling.utils.Color
REGEXP_OUTER_SPACES — Constant Static Property, class com.adobe.utils.AGALMiniAssembler
register(name:String, func:Function) — Static Method , class starling.animation.Transitions
 | 通过指定一个唯一的名称，注册一个过渡的实现方法
register(name:String, sourceFactor:String, destFactor:String, premultipliedAlpha:Boolean) — Static Method , class starling.display.BlendMode
 | 根据指定的名称和预乘透明度（pma）值注册一个混合模式。 如果一个用其他pma值的模式尚未注册，则两个pma的设置都会应用这些因素。
registerBitmapFont(bitmapFont:starling.text:BitmapFont, name:String) — Static Method , class starling.text.TextField
 | 让位图字体可以应用在任何文本框。设置文本框的fontName属性为位图字体的name值，来使用位图字体进行渲染。
registerProgram(name:String, vertexProgram:flash.utils:ByteArray, fragmentProgram:flash.utils:ByteArray) — method, class starling.core.Starling
 | 根据一个指定的名称注册一个顶点和片段着色器程序。如果这个名称已经被使用了，那么上一个使用这个名称的程序将会被覆盖。
remove(object:starling.animation:IAnimatable) — method, class starling.animation.Juggler
 | 从juggler中删除一个对象.
removeChild(child:starling.display:DisplayObject, dispose:Boolean) — method, class starling.display.DisplayObjectContainer
 | 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。
removeChildAt(index:int, dispose:Boolean) — method, class starling.display.DisplayObjectContainer
 | 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。
removeChildren(beginIndex:int, endIndex:int, dispose:Boolean) — method, class starling.display.DisplayObjectContainer
 | 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。
removed — Event, class starling.display.DisplayObject
 | 当一个显示对象从父级删除的时候派发。
REMOVED — Constant Static Property, class starling.events.Event
 | 事件类型：一个显示对象从它的父级删除
removedFromStage — Event, class starling.display.DisplayObject
 | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。
REMOVED_FROM_STAGE — Constant Static Property, class starling.events.Event
 | 事件类型：一个显示对象从舞台上删除。
removeEventListener(type:String, listener:Function) — method, class starling.events.EventDispatcher
 | 在指定的对象上删除一个事件侦听器。
removeEventListeners(type:String) — method, class starling.events.EventDispatcher
 | 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。
removeFrameAt(frameID:int) — method, class starling.display.MovieClip
 | 从指定的索引处删除一帧。此帧后面的所有帧将前移。
REMOVE_FROM_JUGGLER — Constant Static Property, class starling.events.Event
 | 事件类型：当一个动画对象需要被Juggler删除的时候派发
removeFromParent(dispose:Boolean) — method, class starling.display.DisplayObject
 | 如果对象已经添加进显示列表，则从父容器中删除此对象。
removeRegion(name:String) — method, class starling.textures.TextureAtlas
 | 通过名字来删除一个区域。
removeSound(name:String) — method, class starling.utils.AssetManager
 | 删除一个声音
removeTexture(name:String, dispose:Boolean) — method, class starling.utils.AssetManager
 | 删除一个纹理，销毁它(可选)
removeTextureAtlas(name:String, dispose:Boolean) — method, class starling.utils.AssetManager
 | 删除一个纹理图集，销毁它(可选)
removeTweens(target:Object) — method, class starling.animation.Juggler
 | 删除一个对象上应用的所有的tween对象
render() — method, class starling.core.Starling
 | 渲染整个显示列表.
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.DisplayObject
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.DisplayObjectContainer
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.Image
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.Quad
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.QuadBatch
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.display.Sprite
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
render(object:starling.display:DisplayObject, support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.filters.FragmentFilter
 | 在指定的显示对象上应用滤镜，渲染输出结果到当前的渲染目标上。当Starling渲染一个附加了滤镜的对象时，会自动调用这个方法。
render(support:starling.core:RenderSupport, parentAlpha:Number) — method, class starling.text.TextField
 | 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
renderCustom(mvpMatrix:flash.geom:Matrix, parentAlpha:Number, blendMode:String) — method, class starling.display.QuadBatch
 | 结合对 模型-视图-投影矩阵，透明度和混合模式的自定义设置来渲染当前批次。 这样就使渲染那些不在显示列表的批次成为可能。
RenderSupport — class, package starling.core
 | 这个类 包含了简化Stage3D渲染的辅助方法.
RenderSupport() — Constructor, class starling.core.RenderSupport
 | 创建一个携带空矩阵堆的RenderSupport对象.
renderTarget — Property, class starling.core.RenderSupport
 | 当前即将被渲染的纹理，如果是'null'将渲染到后台缓冲区。如果你设置一个新对象，则它马上就会被启动。
RenderTexture — class, package starling.textures
 | RenderTexture是一个能在其上绘制任何显示对象的动态纹理。 在创建一个RenderTexture对象后，仅需调用 drawObject 方法直接在纹理上渲染一个对象。 对象将会在当前位置，连带当前的旋转，缩放和透明值属性被绘制在纹理上。 绘制能够被高效的完成，因为它在显存中是直接发生的。绘制能够被高效的完成，因为它在显存中是直接发生的。 当你在纹理上绘制完对象后，不管你绘制了多少个对象，它的性能将和通常的纹理没什么区别。 如果你一次绘制许多的对象的话，推荐通过drawBundled方法把绘制调用捆绑在一个代码块中，像下面展示的一样。 那将会产生极大地提速，允许你迅速绘制几百个对象。 renderTexture.drawBundled(function():void { for (var i:int=0; i<numDrawings; ++i) { image.rotation = (2 * Math.PI / numDrawings) * i; renderTexture.draw(image); } }); 为了擦除一个经渲染纹理的一部分，你可以使用像“rubber”一样的任意显示对象通过设置它的混合模式为"BlendMode.ERASE"。 注意当Starling的渲染上下文丢失，渲染纹理就不能够被恢复。
RenderTexture(width:int, height:int, persistent:Boolean, scale:Number) — Constructor, class starling.textures.RenderTexture
 | 创建一个某一尺寸的新RenderTexture对象。如果设置presistent为true，在每次调用绘制之后纹理的内容都会原封不动的 保留下来，允许你像使用画布一样使用纹理。相反的设为false，将会在每次调用绘制时先进行清除操作。 前一种会加倍所需要的显示内存！因此如果你只需一次绘制调用或一次块绘制调用，你应该停用它。
repeat — Property, class starling.textures.Texture
 | 确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。
repeatCount — Property, class starling.animation.DelayedCall
 | 方法调用将被重复的次数，设置为0则代表永远重复下去，默认值是1
repeatCount — Property, class starling.animation.Tween
 | 动画需要被执行的次数.0代表永不停止.
repeatDelay — Property, class starling.animation.Tween
 | 重复执行动画的时候，中间的时间间隔，单位是秒.
REPLACE — Constant Static Property, class starling.filters.FragmentFilterMode
 | 滤镜替换原有的对象
reset(call:Function, delay:Number, args:Array) — method, class starling.animation.DelayedCall
 | 重置这个延迟调用到它的初始状态，对于缓存池来说非常有用
reset(target:Object, time:Number, transition:Object) — method, class starling.animation.Tween
 | 把tween恢复到它的初始值.
reset() — method, class starling.display.QuadBatch
 | 重置当前批次。顶点和索引缓冲区仍保持原来的大小，以便能够很快被重用。
reset() — method, class starling.filters.ColorMatrixFilter
 | 重置矩阵
resetMatrix() — method, class starling.core.RenderSupport
 | 置空矩阵堆, 把模型视图矩阵重设为单位矩阵.
resize — Event, class starling.display.Stage
 | 当Flash容器的尺寸发生改变时进行派发。
RESIZE — Constant Static Property, class starling.events.Event
 | 事件类型：Flash Player尺寸改变。
RESIZE — Constant Static Property, class starling.events.ResizeEvent
 | 事件类型：Flash Player尺寸改变。
ResizeEvent — class, package starling.events
 | 当Flash容器的尺寸改变后，stage会派发一个ResizeEvent。用这个值可以更新Starling的视口和stage的尺寸。 事件的属性包含了更新后的Flash Player的宽度和高度。如果您希望缩放stage上的内容来充满屏幕， 请更新 Starling.current.viewPort 矩形区域。如果您希望使用额外的屏幕区域， 请更新 stage.stageWidth 和 stage.stageHeight
ResizeEvent(type:String, width:int, height:int, bubbles:Boolean) — Constructor, class starling.events.ResizeEvent
 | 创建一个新的ResizeEvent实例。
resolution — Property, class starling.filters.FragmentFilter
 | 滤镜纹理的分辨率。"1"代表stage分辨率，"0.5"代表stage分辨率的一半。一个较小的分辨率，可以节省存储空间和执行时间(取决于GPU)， 但是输出质量会降低。如果数值大于1也是允许的；当过滤器缩放时，这样的值可能是有意义的。
restoreOnLostContext(data:Object) — method, class starling.textures.ConcreteTexture
 | 指示此实例在上下文丢失时恢复其基本纹理。数据可以是BitmapData或包含ATF数据的ByteArray。
reverse — Property, class starling.animation.Tween
 | 设置当动画重复播放的时候，是否翻转执行.
rgb(red:int, green:int, blue:int) — Static Method , class starling.utils.Color
 | 创建一个uint的RGB颜色。各通道范围为0 - 255.
RIGHT — Constant Static Property, class starling.utils.HAlign
 | 右对齐.
root — Property, class starling.core.Starling
 | 构造中提供的根类的实例.'ROOT_CREATED'事件派发后可以使用.
root — Property, class starling.display.DisplayObject
 | 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。
root — Property, class starling.textures.ConcreteTexture
 | 作为基本(根节点)的那个符合2的幂数要求的纹理对象
root — Property, class starling.textures.RenderTexture
 | 作为基本(根节点)的那个符合2的幂数要求的纹理对象
root — Property, class starling.textures.SubTexture
 | 作为基本(根节点)的那个符合2的幂数要求的纹理对象
root — Property, class starling.textures.Texture
 | 作为基本(根节点)的那个符合2的幂数要求的纹理对象
rootCreated — Event, class starling.core.Starling
 | 根类创建后派发事件.
ROOT_CREATED — Constant Static Property, class starling.events.Event
 | 事件类型：表示最顶层的显示对象已被创建。
rotateMatrix(angle:Number) — method, class starling.core.RenderSupport
 | 根据相应旋转变化得到模型视图矩阵.
rotation — Property, class starling.display.DisplayObject
 | 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的)
roundToInt — Property, class starling.animation.Tween
 | 表示数字是否会被截取为整型.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


S

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
S Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
scale — Property, class starling.textures.ConcreteTexture
 | The scale factor, which influences width and height properties.
scale — Property, class starling.textures.SubTexture
 | 缩放比例因素,影响宽度和高度。
scale — Property, class starling.textures.Texture
 | 缩放比例因素,影响宽度和高度。
scaleAlpha(vertexID:int, alpha:Number, numVertices:int) — method, class starling.utils.VertexData
 | 对指定的顶点alpha值乘以某个delta.
scaleFactor — Property, class starling.utils.AssetManager
 | 无论是从位图创建的纹理，还是ATF格式的纹理，都会被分配一个缩放比例
scaleMatrix(sx:Number, sy:Number) — method, class starling.core.RenderSupport
 | 根据相应缩放变化得到模型视图矩阵.
ScaleMode — class, package starling.utils
 | 用于'RectangleUtil.fit' 方法的缩放模式常量值.
scaleTo(factor:Number) — method, class starling.animation.Tween
 | 同时"运动"目标对象的'scaleX' 和 'scaleY'两个值。用这个方法放大或缩小对象。
scaleWhenDown — Property, class starling.display.Button
 | 当按钮被触碰的时候的缩放参数。 默认情况下，如果按钮含有down状态的纹理，则不会被缩放。
scaleX — Property, class starling.display.DisplayObject
 | 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。
scaleY — Property, class starling.display.DisplayObject
 | 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。
scissorRectangle — Property, class starling.core.RenderSupport
 | 裁切矩形可以被用于限制当前渲染目标到一个指定的区域。 这个方法需要stage坐标系中的一个矩形(和Context3D的同名方法不同，它使用的是像素)。传递null将关闭裁剪。注意：这不是一个副本，小心使用！
SCREEN — Constant Static Property, class starling.display.BlendMode
 | 将显示对象颜色的补码（反码）与背景颜色的补码相乘，产生漂白效果。
SCROLL — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
SELECT — Constant Static Property, class starling.events.Event
 | 自定义事件需要的一个事件类型.
setAlpha(vertexID:int, alpha:Number) — method, class starling.utils.VertexData
 | 更新顶点Aplha值 (范围 0-1).
setBlendFactors(premultipliedAlpha:Boolean, blendMode:String) — Static Method , class starling.core.RenderSupport
 | 设置相应混合模式的混合参数.
setChildIndex(child:starling.display:DisplayObject, index:int) — method, class starling.display.DisplayObjectContainer
 | 移动一个子级到指定的索引，在它后面的子级将向后移动。
setColor(vertexID:int, color:uint) — method, class starling.utils.VertexData
 | 更新顶点RGB值.
setDefaultBlendFactors(premultipliedAlpha:Boolean) — Static Method , class starling.core.RenderSupport
 | 不再使用。调用'setBlendFactors'方法.
setFrameDuration(frameID:int, duration:Number) — method, class starling.display.MovieClip
 | 设置指定索引的帧的执行时间（单位：秒）。
setFrameSound(frameID:int, sound:flash.media:Sound) — method, class starling.display.MovieClip
 | 设置指定索引的帧的声音，当此帧显示时，声音就会播放。
setFrameTexture(frameID:int, texture:starling.textures:Texture) — method, class starling.display.MovieClip
 | 设置指定索引的帧的纹理。
setOrthographicProjection(x:Number, y:Number, width:Number, height:Number) — method, class starling.core.RenderSupport
 | 设置正面二维渲染的矩阵映射.
setPosition(vertexID:int, x:Number, y:Number) — method, class starling.utils.VertexData
 | 更新顶点位置.
setPremultipliedAlpha(value:Boolean, updateData:Boolean) — method, class starling.utils.VertexData
 | 改变alpha和颜色值的存储方式.
setTexCoords(vertexID:int, coords:flash.geom:Point) — method, class starling.display.Image
 | 设置一个顶点的纹理坐标，坐标范围：[0,1]。
setTexCoords(vertexID:int, u:Number, v:Number) — method, class starling.utils.VertexData
 | 更新顶点纹理坐标值 (范围 0-1).
setUniformAlpha(alpha:Number) — method, class starling.utils.VertexData
 | 对所有顶点设置相同的alpha值.
setUniformColor(enable:Boolean, color:uint, alpha:Number) — method, class starling.filters.BlurFilter
 | 使用同一颜色，将替换输入颜色的RGB值，并且透明度值将和指定的系数相乘。 在第一个参数上传递false，就可以取消同一颜色的效果。
setUniformColor(color:uint) — method, class starling.utils.VertexData
 | 对所有顶点设置相同的颜色值.
setVertexAlpha(vertexID:int, alpha:Number) — method, class starling.display.Quad
 | 设置指定索引的顶点的透明度。
setVertexColor(vertexID:int, color:uint) — method, class starling.display.Quad
 | 设置指定索引的顶点的颜色。
shareContext — Property, class starling.core.Starling
 | Context3D 渲染调用是否可以被Starling外部使用 , 是否可以让其它框架共享Stage3D对象
shiftKey — Property, class starling.events.KeyboardEvent
 | 判断Shift键是否被激活，按下为true，松开为false。
shiftKey — Property, class starling.events.TouchEvent
 | 表示，事件发生时shift键是否被按下。
SHOW_ALL — Constant Static Property, class starling.utils.ScaleMode
 | 等比缩放，保持显示区域完整可见，可能会在上下或左右两侧留下空白区域
showStats — Property, class starling.core.Starling
 | 是否显示数据统计 (FPS, 内存占用 和面数)。
showStatsAt(hAlign:String, vAlign:String, scale:Number) — method, class starling.core.Starling
 | 数据统计显示位置.
SILVER — Constant Static Property, class starling.utils.Color
simulateMultitouch — Property, class starling.core.Starling
 | 多点触摸模拟 "Shift" 和 "Ctrl"/"Cmd"-是否启用.
size — Property, class starling.text.BitmapFont
 | 字号
skew(matrix:flash.geom:Matrix, skewX:Number, skewY:Number) — Static Method , class starling.utils.MatrixUtil
 | 以一定的弧度附加一个扭曲转换到矩阵中.一个扭曲矩阵如下所示： | cos(skewY) -sin(skewX) 0 | | sin(skewY) cos(skewX) 0 | | 0 0 1 |
skewX — Property, class starling.display.DisplayObject
 | 显示对象水平方向的倾斜弧度。
skewY — Property, class starling.display.DisplayObject
 | 显示对象垂直方向的倾斜弧度。
smoothing — Property, class starling.display.Image
 | 用于纹理的平滑过滤方式，默认值为：bilinear。
smoothing — Property, class starling.display.QuadBatch
 | 平滑度。
smoothing — Property, class starling.text.BitmapFont
 | 是否开启平滑
sortChildren(compareFunction:Function) — method, class starling.display.DisplayObjectContainer
 | 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。
Sprite — class, package starling.display
 | Sprite是一个极其轻量，非抽象的容器类。 通常把Sprite作为一种把一组显示对象集中到一个坐标系内的简单手段，也可以把它用做自定义显示对象的基类。 "平面化" Sprite对象 flatten方法允许你在渲染时优化显示列表中的静态部分。 flatten 分析了添加到这个Sprite的显示列表的子对象，优化了渲染调用，极大的提高了渲染速度。 但是速度的大幅提升是要付出代价的：你将再也看不见子对象属性的任何变化（位置，旋转，透明等等）。 要更新这个sprite对象的显示，只需再一次调用flatten，或者unflatten这个对象。
Sprite() — Constructor, class starling.display.Sprite
 | 创建一个空的Sprite实例。
stage — Property, class starling.core.Starling
 | Starling 舞台对象, 是显示列表的根.
stage — Property, class starling.display.DisplayObject
 | 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。
Stage — class, package starling.display
 | Stage是显示列表树的根节点，只有直接或者间接放置到stage上的显示对象才会被渲染。 这个类相当于Starling版本的Stage，注意不要和传统的Flash里的Stage混淆。 传统的Flash里的Stage只能包含类型为flash.display.DisplayObject的对象， 而Starling里的Stage只能包含类型为starling.display.DisplayObject的对象， 由于Starling显示列表并不等同于传统Flash显示列表，所以这些类并不兼容，不能混用，也不能互相代替。 stage对象是被Starling类自动创建的，请不要手动创建一个stage对象。 键盘事件 在Starling中，键盘事件只能够在stage派发，所以，如果想捕获到派发的键盘事件，只能给stage添加键盘事件监听。 尺寸变化事件 当Flash player 尺寸变化时，stage会派发一个ResizeEvent事件。 这个事件的属性包含更新后的Flash player的宽度和高度。
stage3D — Property, class starling.core.Starling
 | Starling的渲染目标Flash Stage3D 对象
stageHeight — Property, class starling.display.Stage
 | 舞台坐标系的高度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。
stageWidth — Property, class starling.display.Stage
 | 舞台坐标系的宽度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。
Starling — class, package starling.core
 | Starling类展现了Starling框架的核心.
Starling(rootClass:Class, stage:flash.display:Stage, viewPort:flash.geom:Rectangle, stage3D:flash.display:Stage3D, renderMode:String, profile:String) — Constructor, class starling.core.Starling
 | 创建一个新的Starling实例.
starling.animation — package
starling.core — package
starling.display — package
starling.errors — package
starling.events — package
starling.filters — package
starling.text — package
starling.textures — package
starling.utils — package
start() — method, class starling.core.Starling
 | Starling启动后，它会对输入事件排队处理 (keyboard/mouse/touch); 另外, nextFrame方法 会在Flash Player中每一帧调用。 (如果 shareContext启用: 在这种情况, 你必须手动 调用这个方法.)
STATIONARY — Constant Static Property, class starling.events.TouchPhase
 | 手指或鼠标(按下) 没有移动。
STD_FRAGMENT_SHADER — Constant Property, class starling.filters.FragmentFilter
 | 标准的片段着色器代码.
STD_VERTEX_SHADER — Constant Property, class starling.filters.FragmentFilter
 | 标准的顶点着色代码。如果你没有创建自定义的顶点着色器，就会自动使用这个标准的着色代码。
stop() — method, class starling.core.Starling
 | 停止所有的逻辑处理，并冻结游戏的当前状态。但实际上每一帧仍然在渲染内容（只是看起来不更新了），因为如果不这样做的话，传统显示列表就无法更新。
stop() — method, class starling.display.MovieClip
 | 停止播放, 重置 "currentFrame" 为0。
stopImmediatePropagation() — method, class starling.events.Event
 | 阻止其他任何侦听器接收事件。
stopPropagation() — method, class starling.events.Event
 | 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。
SubTexture — class, package starling.textures
 | 一个SubTexture用于表现另一个纹理的一部分。由于这是完全通过操作纹理坐标实现的，使得这个类非常高效。 注意：从子纹理继续创建子纹理也是允许的。
SubTexture(parentTexture:starling.textures:Texture, region:flash.geom:Rectangle, ownsParent:Boolean) — Constructor, class starling.textures.SubTexture
 | 从一个父级纹理对象指定的区域（点）来创建一个新的SubTexture对象。 如果ownsParent设置为true，当子纹理被释放的时，父级纹理对象也会被释放。
swapChildren(child1:starling.display:DisplayObject, child2:starling.display:DisplayObject) — method, class starling.display.DisplayObjectContainer
 | 互换两个子级的索引。
swapChildrenAt(index1:int, index2:int) — method, class starling.display.DisplayObjectContainer
 | 互换两个子级的索引。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Starling API 1.3 | Starling中文站

Index

A | N
B | O
C | P
D | Q
E | R
F | S
G | T
H | U
I | V
J | W
K | X
L | Y
M | Z


Starling API 1.3 | Starling中文站

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Starling API 1.3 | Starling中文站

Starling API 1.3 | Starling中文站 All Packages | All Classes | Index | No Frames
Adobe Logo
Properties | Properties | Constructor | Methods | Functions | Events | Styles | Skin Parts | Skin States | Effects | Constants | Constants | Interfaces | Classes | Use | Examples


T

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
T Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
tapCount — Property, class starling.events.Touch
 | 手指在很短的时间内触碰屏幕的次数。可以用来判断双击等情况。
target — Property, class starling.animation.Tween
 | 当前"动画"要执行的对象
target — Property, class starling.events.Event
 | 派发这个事件的对象。
target — Property, class starling.events.Touch
 | 发生触碰的显示对象。
TEAL — Constant Static Property, class starling.utils.Color
TEXCOORD_OFFSET — Constant Static Property, class starling.utils.VertexData
 | 每个顶点内的坐标数据 (u, v) 偏移量.
texCoordsAtID — Property, class starling.filters.FragmentFilter
 | 存储了顶点坐标的顶点缓冲区属性的ID
text — Property, class starling.display.Button
 | 按钮上的显示文本。
text — Property, class starling.text.TextField
 | 显示的文本.
textBounds — Property, class starling.display.Button
 | 按钮上文本框的边界矩形。 允许移动文本到一个自定义的位置。
textBounds — Property, class starling.text.TextField
 | 返回文本框中的文本区域
TextField — class, package starling.text
 | TextField类用来显示文本，使用标准的True Type字体或自定义位图字体。 您可以设置你用到的所有属性，比如字体名称和字号，颜色，横向和垂直对齐方式，等等。边框属性对于开发是非常有帮助的，因为这样可以让您看到文本的边界。 有两种类型的字体可以被显示: 标准的true type字体.
TextField(width:int, height:int, text:String, fontName:String, fontSize:Number, color:uint, bold:Boolean) — Constructor, class starling.text.TextField
 | 根据给定的属性创建一个新的文本框
textHAlign — Property, class starling.display.Button
 | 按钮文本的水平对齐方式.
texture — Property, class starling.display.Image
 | 映射到四边形的纹理对象。
texture — Property, class starling.display.QuadBatch
 | 纹理。
texture — Property, class starling.text.BitmapChar
 | 这个字符的纹理.
Texture — class, package starling.textures
 | 纹理是用来储存展示图像的信息。它不能直接被添加到显示列表；相应的它必须映射到一个显示对象上。 在Staring中那个显示对象就是“Image”类。 纹理格式 纹理能够由一个“BitmapData”对象创建，Starling能够支持任何Flash所支持的bitmap格式。 并且由于你能够将任何Flash显示对象转换为BitmapData对象，你就能够利用这点在Starling中 去显示非Starling内容,比如说Shape对象。 Starling同时支持ATF纹理（Adobe Texture Format），一个能够通过GPU高效渲染的被压缩纹理的容器。 Mip映射 MipMaps是按比例缩小的纹理类型。当一个图像被显示时小于它本来的尺寸时， GPU可能就会用mip maps去替代原生纹理。这就可以减少走样和加速渲染。当然这也需要额外的内存开销； 你可以权衡利弊之后选择是否使用它。 纹理框架 纹理的frame属性允许你设置纹理在image对象中的界限，在纹理周围留有透明空白区域。 frame矩形被指定在纹理的坐标系统中，而不是image: var frame:Rectangle = new Rectangle(-10, -10, 30, 30); var texture:Texture = Texture.fromTexture(anotherTexture, null, frame); var image:Image = new Image(texture); 这段代码会创建一个30x30大小的图像，纹理会被放置在图像x=10, y=10 的位置上（假设'anotherTexture'是一个宽高都为10像素的纹理，它将出现在图像的正中位置）。 纹理集就采用了这个特性，它允许裁剪一个纹理的透明边缘用来弥补由指定的原始纹理框架改变的尺寸。 可以使用TexturePacker这样的工具来优化纹理集。 纹理坐标系 假如，从另一方面讲，你只想在图像中显示纹理的一部分（就是说修剪这个纹理）， 你可以创建一个子纹理（通过方法'Texture.fromTexture()'然后指定一个限定范围的矩形）， 或者你也可以操作image对象的纹理坐标系。方法'image.setTexCoords'允许你那样做。
TextureAtlas — class, package starling.textures
 | 纹理集是一个将许多小的纹理整合到一张大图中。这个类是用来从一个纹理集中读取纹理。 使用纹理集能为你的纹理解决两个问题: 在一定的时间内，始终有一个纹理处于活动的。每当你改变了处于活动的纹理，一个 “纹理切换”就会执行，这个切换是需要时间的。 任何Stage3D纹理的边长都必须是2的幂数。Starling向你隐藏了这个限制，但这将带来 额外的图形存储成本。 通过使用纹理集，您可以避免使用纹理切换和取消2的幂数的限制。所有的纹理被集合在一 个“超级纹理”，并且Starling会确保纹理正确的部分被显示出来。 有几种方法来创建纹理集。一种是使用捆绑在Starling的姊妹框架 Sparrow framework。里的纹理集生成脚本。 尽管目前这个脚本只能运行在Mac OS X上。 另一个可供选择的出色工具 Texture Packer， 他是一个跨平台的商业软件。 无论您使用的工具是什么，Starling可以支持以下文档格式: <TextureAtlas imagePath='atlas.png'> <SubTexture name='texture_1' x='0' y='0' width='50' height='50'/> <SubTexture name='texture_2' x='50' y='0' width='20' height='30'/> </TextureAtlas> 如果你的图像在边缘具有透明区域，您可以使用Texture类的frame属性。 通过 去除纹理的透明边缘并且指定原始尺寸就像这样： <SubTexture name='trimmed' x='0' y='0' height='10' width='10' frameX='-10' frameY='-10' frameWidth='30' frameHeight='30'/>
TextureAtlas(texture:starling.textures:Texture, atlasXml:XML) — Constructor, class starling.textures.TextureAtlas
 | 通过指定纹理和用于描述范围的XML来创建一个纹理集。
TextureSmoothing — class, package starling.textures
 | 这个类为可能的材质平滑算法提供常量值。
textVAlign — Property, class starling.display.Button
 | 按钮文本的垂直对齐方式.
timestamp — Property, class starling.events.Touch
 | 触碰发生时的时间（以秒为单位，自应用程序启动时算起）。
timestamp — Property, class starling.events.TouchEvent
 | 事件发生的时间（单位是秒，自应用启动时算起）。
tinted — Property, class starling.display.Quad
 | 一个布尔值，如果四边形（或者它的任意顶点）是非白色或者是透明的，返回true，否则返回 false。
tinted — Property, class starling.display.QuadBatch
 | 是否染色。
tinted — Property, class starling.utils.VertexData
 | 返回所有顶点是否非白或完全透明.
TOP — Constant Static Property, class starling.utils.VAlign
 | 顶部对齐.
toString() — method, class starling.events.Event
 | 返回事件的描述，包括类型及是否冒泡。
toString() — method, class starling.events.Touch
 | 返回这个对象的描述。
totalTime — Property, class starling.animation.DelayedCall
 | 要延迟的总时间 (单位是秒).
totalTime — Property, class starling.animation.Tween
 | 动画执行的总时间 (秒).
totalTime — Property, class starling.display.MovieClip
 | 影片剪辑总共需要播放的秒数。
touch — Event, class starling.display.DisplayObject
 | 当显示对象被触碰时派发，冒泡事件。
Touch — class, package starling.events
 | 一个Touch对象包含了在屏幕上的一个手指或鼠标的相关信息（出现或移动）。 您将从TouchEvent中获取这个对象。当这样的事件被触发，您可以查询目前呈现在屏幕上的所有触碰。 一个Touch对象，包含了一个单指触碰的信息。一个Touch对象总是会通过TouchPhases的集合移动。请参阅TouchPhase类来获取更多信息。 触碰的位置 您可以用相应的属性，获取坐标系上的当前的和上一个位置。当然，在大部分情况下您希望能获取在一个不同的坐标系上的位置。 基于这个原因，这里有一些方法可以转换当前的和上一个位置到任何对象的局部坐标系。
Touch(id:int, globalX:Number, globalY:Number, phase:String, target:starling.display:DisplayObject) — Constructor, class starling.events.Touch
 | 创建一个新的Touch对象。
TOUCH — Constant Static Property, class starling.events.TouchEvent
 | 触碰或鼠标输入的事件类型。
touchable — Property, class starling.display.DisplayObject
 | 是否禁止该对象和它的子对象响应触碰事件。
touches — Property, class starling.events.TouchEvent
 | 当前可用的所有触碰对象。
TouchEvent — class, package starling.events
 | 一个TouchEvent是被手指触碰或鼠标输入来触发的。 在Starling中，无论是触碰事件还是鼠标事件，都统一封装为一个类：TouchEvent。 要处理用户在一个可触碰的屏幕或使用鼠标完成的输入， 您需要注册一个事件侦听器，来侦听类型是TouchEvent.TOUCH的事件。 这是唯一的您需要捕获的事件类型； 原有Flash里面的那个很长的事件类型列表，全都被映射到一个"TouchPhases"里面。 鼠标输入和触摸屏输入的区别是： 在某一时刻只有一个鼠标光标可以呈现 只有鼠标才可以"hover",即在没有按下按键的情况下滑过一个对象。 哪些对象能够接收触碰事件？ 在Starling中，任何一个显示对象都可以接受触碰事件，只要它的 touchable 属性，以及它的父级都是可用状态(true)。 在Starling中是没有"InteractiveObject"这个类的。 如何使用单个触碰对象 T事件包含了一个包括所有的触碰对象的列表。每一个独立的触碰都被保存在一个类型是"Touch"的对象里。 既然您通常只对在特定对象上发生的触碰感兴趣，您可以查询事件，传入一个具体的目标： var touches:Vector.<Touch> = touchEvent.getTouches(this); 这会返回附加在"this"或 它的子级上的所有触碰对象。如果您没有使用多点触碰，您也可以直接访问触碰对象，就像这样： var touch:Touch = touchEvent.getTouch(this);
TouchEvent(type:String, touches:Vector$starling.events:Touch, shiftKey:Boolean, ctrlKey:Boolean, bubbles:Boolean) — Constructor, class starling.events.TouchEvent
 | 创建一个新的TouchEvent实例。
TouchPhase — final class, package starling.events
 | 这个类提供了描述触碰的各个阶段的常量值。 一个触碰，在它的生命周期内会遵循下面的过程： BEGAN(开始) -> MOVED(移动) -> ENDED(结束) 此外，一个触碰可能进入一个称之为STATIONARY(静止)的阶段。这一阶段本身不会触发触碰事件，并且它只能发生在多点触控环境。 在某些场合下需要一个解决方案，比如一个手指移动，另一个静止。这个时候，一个触碰事件必须由正在移动的手指下方的对象来派发。 在这个事件的触碰对象列表中，您将会找到第二个处于静止状态的触碰对象。 最后，还有一个称之为HOVER(悬停)的状态，这种情况只会发生在使用鼠标的情况下。 它是由Flash的MouseOver事件触发的，并且这个时候鼠标按键没有被按下。
transformationMatrix — Property, class starling.display.DisplayObject
 | 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。
transformCoords(matrix:flash.geom:Matrix, x:Number, y:Number, resultPoint:flash.geom:Point) — Package Function, starling.utils
 | 用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象.
transformCoords(matrix:flash.geom:Matrix, x:Number, y:Number, resultPoint:flash.geom:Point) — Static Method , class starling.utils.MatrixUtil
 | 用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象.
transformMatrix(object:starling.display:DisplayObject) — method, class starling.core.RenderSupport
 | 根据对象的坐标变换，缩放和旋转生成模型视图矩阵.
transformMatrixForObject(matrix:flash.geom:Matrix, object:starling.display:DisplayObject) — Static Method , class starling.core.RenderSupport
 | 把一个对象的位移，缩放和旋转转化为自定义矩阵.
transformVertex(vertexID:int, matrix:flash.geom:Matrix, numVertices:int) — method, class starling.utils.VertexData
 | 通过与一个转换矩阵来转换后面的顶点位置.
transition — Property, class starling.animation.Tween
 | 动画过程中用到的过渡方法.
transitionFunc — Property, class starling.animation.Tween
 | 可以传递一个方法来实现自定义的过渡过程
Transitions — class, package starling.animation
 | Transitions(过渡)类包含了一些静态方法，来定义缓动相关的函数。这些函数被用在Tween类执行动画的时候。 关于transitions这里有一张很直观的图片描述： 你可以使用"registerTransition" 方法来自定义过渡方式.
translateMatrix(dx:Number, dy:Number) — method, class starling.core.RenderSupport
 | 根据相应位移变化得到模型视图矩阵.
translateVertex(vertexID:int, deltaX:Number, deltaY:Number) — method, class starling.utils.VertexData
 | 以一定偏移量来移动顶点位置.
triggered — Event, class starling.display.Button
 | 当用户点击或者触碰了按钮时进行派发，冒泡事件。
TRIGGERED — Constant Static Property, class starling.events.Event
 | 事件类型：按钮点击。
TRILINEAR — Constant Static Property, class starling.textures.TextureSmoothing
 | 三线性过滤。通过考虑使用更高级别的MIP映射.实现最高级别的渲染质量。
tween(target:Object, time:Number, properties:Object) — method, class starling.animation.Juggler
 | 在指定的时间内，用一个补间动画(tween)去"运动"一个对象。在内部，这个方法使用一个tween的实例（从缓存池中获取的），然后添加到juggler里面。 这个方法是一个快捷机制，用来方便的创建一个tween并且使用它。 设置'properties'属性，可以用键值对的方式来定义tween和动画对象。这里是一个示例片段： juggler.tween(object, 2.0, { transition: Transitions.EASE_IN_OUT, delay: 20, // -> tween.delay = 20 x: 50 // -> tween.animate("x", 50) });
Tween — class, package starling.animation
 | 一个Tween实例，将使用补间动画的方式，"运动"某个对象的属性(比如改变x坐标值，从1,2,3...一直到N，从而形成视觉上的动画效果)。 它可以使用不同的过渡方法，来实现不同的动画方式。 这个类的主要用途是实现标准的动画，比如移动，透明度渐变，旋转等等。但是"动画"的范围远远不止于此。只要你想"运动"的对象的属性值是数字 (int, uint, Number), Tween就能搞定它。 要了解Tween可以使用的过渡方法的列表，请参阅"Transitions"类。 下面是一个实例，展示了tween移动一个对象到右侧，旋转它，然后让它透明度逐渐降低而消失: var tween:Tween = new Tween(object, 2.0, Transitions.EASE_IN_OUT); tween.animate("x", object.x + 50); tween.animate("rotation", deg2rad(45)); tween.fadeTo(0); // 你也可以使用'animate("alpha", 0)'来代替 Starling.juggler.add(tween); 注意在上面的代码的最后，tween的实例被添加到了juggler。这是因为，只有tween自己的"advanceTime"方法被实际执行的时候，tween才会起作用。 这个工作juggler会帮你做的，而且它会自动在tween执行完毕的时候删除它。
Tween(target:Object, time:Number, transition:Object) — Constructor, class starling.animation.Tween
 | 创建一个tween的实例， 同时设置目标对象, 时间 (单位是秒) 和过渡方式.
type — Property, class starling.events.Event
 | 这个事件的字符串类型。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


U

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
U Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
underline — Property, class starling.text.TextField
 | 是否具备下划线.
unflatten() — method, class starling.display.Sprite
 | 取消对这个Sprite的"平面化"渲染优化操作。 此时子对象的改变会使Sprite对象立即更新显示。
unregisterBitmapFont(name:String, dispose:Boolean) — Static Method , class starling.text.TextField
 | 取消注册一个位图字体，并销毁它（可选）.
upState — Property, class starling.display.Button
 | 按钮默认情况下显示的纹理（即没有被触碰的时候）。
useHandCursor — Property, class starling.display.Button
 | 当光标移动到按钮上时，是否显示手型光标，默认为：true。
useHandCursor — Property, class starling.display.DisplayObject
 | 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。
useMipMaps — Property, class starling.utils.AssetManager
 | 对于位图纹理，此标志表示，加载后创建的纹理是否使用MIP映射; 对于ATF格式的纹理，它表示使用的时候MIP映射是否有效。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


V

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
V Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
vAlign — Property, class starling.text.TextField
 | 文本的垂直对齐方式。
VAlign — final class, package starling.utils
 | 提供物件垂直方向上的对齐常量值.
verbose — Property, class com.adobe.utils.AGALMiniAssembler
verbose — Property, class starling.utils.AssetManager
 | 是否输出加载过程中的信息
VERSION — Constant Static Property, class starling.core.Starling
 | Starling framework的版本.
VertexData — class, package starling.utils
 | 顶点数据类，它管理一个顶点信息的原始数据列表，允许直接上传到Stage3D顶点缓冲池中.
VertexData(numVertices:int, premultipliedAlpha:Boolean) — Constructor, class starling.utils.VertexData
 | 用指定的顶点数创建一个新的顶点数据.
vertexPosAtID — Property, class starling.filters.FragmentFilter
 | 存储了顶点位置的顶点缓冲区属性的ID
viewPort — Property, class starling.core.Starling
 | Starling 内容渲染的区域.
visible — Property, class starling.display.DisplayObject
 | 显示对象是否可见。不可见的显示对象不能够被触碰。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


W

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
W Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
WHITE — Constant Static Property, class starling.utils.Color
width — Property, class starling.display.DisplayObject
 | 显示对象的宽度。
width — Property, class starling.events.ResizeEvent
 | 播放器更新后的宽度。
width — Property, class starling.events.Touch
 | 压力区域的宽度。如果设备不支持压力，则这个值永远是1.0.
width — Property, class starling.text.BitmapChar
 | 字符宽度.
width — Property, class starling.text.TextField
 | 显示对象的宽度。
width — Property, class starling.textures.ConcreteTexture
 | 以像素为单位的纹理宽度。
width — Property, class starling.textures.SubTexture
 | 以像素为单位的纹理宽度。
width — Property, class starling.textures.Texture
 | 以像素为单位的纹理宽度。
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


X

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
X Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
x — Property, class starling.display.DisplayObject
 | 显示对象相对于父级对象的局部坐标系的x坐标。
xAdvance — Property, class starling.text.BitmapChar
 | 光标移动到下一个字符时的偏移量
xOffset — Property, class starling.text.BitmapChar
 | 排列字符的时候在X方向上的偏移量.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Y

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
Y Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
y — Property, class starling.display.DisplayObject
 | 显示对象相对于父级对象的局部坐标系的y坐标。
YELLOW — Constant Static Property, class starling.utils.Color
yOffset — Property, class starling.text.BitmapChar
 | 排列字符的时候在Y方向上的偏移量.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Z

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Frames No Frames | Adobe Logo
Z Index |

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


com.adobe.utils - Starling API 1.3 | Starling中文站

Package com.adobe.utils

Classes
AGALMiniAssembler


com.adobe.utils Summary

Starling API 1.3 | Starling中文站 | All Packages | All Classes | Index | Frames No Frames | Adobe Logo
com.adobe.utils | Classes

Classes
Class | Description
AGALMiniAssembler | AGAL(Adobe Graphics Assembly Language)是Adobe开发的图形汇编语言，汇编语言是仅高于计算机二进制机器码的低级语言，可以精确地操控机器硬件比如可编程显卡，PC的Dirext9、MAC的OpenGL以及移动设备中的OpenGL ES 2都是可编程显卡，并且都支持AGAL。通过Adobe官方提供的编译器AGALMiniAssembler（实际上是一个AS类库），我们可以通过字符串指令来获得一个AGAL二进制流，再通过context3D上传给显卡的编程管线。对于顶点以及片段的运算都是通过AGAL交由显卡来处理的，这就是传说中的GPU硬件加速。


com.adobe.utils.AGALMiniAssembler

AGALMiniAssembler | Properties | Methods | Constants
Package | com.adobe.utils
Class | public class AGALMiniAssembler
Inheritance | AGALMiniAssembler Inheritance Object

AGAL(Adobe Graphics Assembly Language)是Adobe开发的图形汇编语言，汇编语言是仅高于计算机二进制机器码的低级语言，可以精确地操控机器硬件比如可编程显卡，PC的Dirext9、MAC的OpenGL以及移动设备中的OpenGL ES 2都是可编程显卡，并且都支持AGAL。通过Adobe官方提供的编译器AGALMiniAssembler（实际上是一个AS类库），我们可以通过字符串指令来获得一个AGAL二进制流，再通过context3D上传给显卡的编程管线。对于顶点以及片段的运算都是通过AGAL交由显卡来处理的，这就是传说中的GPU硬件加速。

Public Properties
Property |  | Defined By
 | agalcode : ByteArray [read-only] 编译后的AGAL字节 | AGALMiniAssembler
 | error : String [read-only] 错误信息 | AGALMiniAssembler
 | verbose : Boolean = false | AGALMiniAssembler
Public Methods
Method |  | Defined By
 | AGALMiniAssembler(debugging:Boolean = false) 构造函数 | AGALMiniAssembler
 | assemble(mode:String, source:String, version:uint = 1, ignorelimits:Boolean = false):ByteArray 将AGAL的代码片段编译为字节数组 | AGALMiniAssembler
 | assemble2(ctx3d:Context3D, version:uint, vertexsrc:String, fragmentsrc:String):Program3D 新增的一个简化方法，可以通过传递顶点着色器源码和片段着色器源码，快捷生成Program3D对象 | AGALMiniAssembler
Protected Constants
Constant |  | Defined By
 | REGEXP_OUTER_SPACES : RegExp [static] | AGALMiniAssembler
Property Detail
agalcode property
agalcode:ByteArray [read-only]

编译后的AGAL字节

Implementation
    public function get agalcode():ByteArray
error property
error:String [read-only]

错误信息

Implementation
    public function get error():String
verbose property
public var verbose:Boolean = false

Constructor Detail
AGALMiniAssembler () Constructor
public function AGALMiniAssembler(debugging:Boolean = false)

构造函数

Parameters
debugging:Boolean (default = false) — 是否开启调试模式
Method Detail
assemble () method
public function assemble(mode:String, source:String, version:uint = 1, ignorelimits:Boolean = false):ByteArray

将AGAL的代码片段编译为字节数组

Parameters

mode:String — 是顶点还是片段
source:String — 代码片段
version:uint (default = 1) — 版本号，默认为1
ignorelimits:Boolean (default = false) — 是否忽略限制，默认为否

Returns
ByteArray — 字节数组
assemble2 () method
public function assemble2(ctx3d:Context3D, version:uint, vertexsrc:String, fragmentsrc:String):Program3D

新增的一个简化方法，可以通过传递顶点着色器源码和片段着色器源码，快捷生成Program3D对象

Parameters

ctx3d:Context3D — Context3D实例
version:uint — 版本号
vertexsrc:String — 顶点着色器源码
fragmentsrc:String — 片段着色器源码

Returns
Program3D — Program3D对象
Constant Detail
REGEXP_OUTER_SPACES Constant
protected static const REGEXP_OUTER_SPACES:RegExp


starling.animation - Starling API 1.3 | Starling中文站

Package starling.animation

Interfaces
IAnimatable
Classes
DelayedCall
Juggler
Transitions
Tween


starling.animation Summary

starling.animation | Interfaces | Classes

Interfaces
Interface | Description
IAnimatable | IAnimatable接口定义了这样的一些对象：基于一个时间范围实现动画过程。任何实现了这个接口的类的实例，都可以被添加到juggler。 当一个对象不再需要运动的时候，你应当将它从juggler删除。要实现这一点，你可以手动执行这个方法：juggler.remove(object) 来删除它， 或者让这个对象派发一个事件来请求juggler删除自己，事件类型是Event.REMOVE_FROM_JUGGLER.
Classes
Class | Description
DelayedCall | DelayedCall类允许你在一定的时间间隔之后去执行某个方法(和setTimeout有些类似)。由于这个类实现了IAnimatable接口，你可以把一个DelayedCall实例添加到juggler中。 在大部分情况下，你不需要直接使用这个类；Juggler类包含了一个方法来直接实现延迟调用这个功能。 当方法调用完毕之后，DelayedCall对象会派发一个类型是“Event.REMOVE_FROM_JUGGLER”的事件，然后如果不再需要它了，Juggler会自动将它删除。
Juggler | Juggler管理那些实现了IAnimatable接口的对象（比如Tweens）并执行它们。 一个juggler实例是一个非常简单的对象。它只是持有一个列表，列表里面是那些实现了IAnimatable接口的对象，并管理它们的执行时间（通过对象自己的advanceTime方法）。当动画播放完毕，就把这个对象抛出。 在Starling类中有一个默认的juggler变量: var juggler:Juggler = Starling.juggler; 你可以创建你自己的juggler对象，如果需要的话。这样，你就可以组合你的游戏到一些逻辑组件，并独立控制他们的动画。 你需要做的就是，在每一帧都调用你自定义的juggler的advanceTime方法。 juggler另一个很强的特性就是"delayCall"方法。使用它可以延迟执行某个方法。但是和传统的延迟调用(比如setTimeout)不同, 这个方法只有在juggler被时间推送器驱动的时候才会起作用，这可以让你更加完美的控制呼叫的逻辑。 下面是delayCall的一些示例： juggler.delayCall(object.removeFromParent, 1.0); juggler.delayCall(object.addChild, 2.0, theChild); juggler.delayCall(function():void { doSomethingFunny(); }, 3.0);
Transitions | Transitions(过渡)类包含了一些静态方法，来定义缓动相关的函数。这些函数被用在Tween类执行动画的时候。 关于transitions这里有一张很直观的图片描述： 你可以使用"registerTransition" 方法来自定义过渡方式.
Tween | 一个Tween实例，将使用补间动画的方式，"运动"某个对象的属性(比如改变x坐标值，从1,2,3...一直到N，从而形成视觉上的动画效果)。 它可以使用不同的过渡方法，来实现不同的动画方式。 这个类的主要用途是实现标准的动画，比如移动，透明度渐变，旋转等等。但是"动画"的范围远远不止于此。只要你想"运动"的对象的属性值是数字 (int, uint, Number), Tween就能搞定它。 要了解Tween可以使用的过渡方法的列表，请参阅"Transitions"类。 下面是一个实例，展示了tween移动一个对象到右侧，旋转它，然后让它透明度逐渐降低而消失: var tween:Tween = new Tween(object, 2.0, Transitions.EASE_IN_OUT); tween.animate("x", object.x + 50); tween.animate("rotation", deg2rad(45)); tween.fadeTo(0); // 你也可以使用'animate("alpha", 0)'来代替 Starling.juggler.add(tween); 注意在上面的代码的最后，tween的实例被添加到了juggler。这是因为，只有tween自己的"advanceTime"方法被实际执行的时候，tween才会起作用。 这个工作juggler会帮你做的，而且它会自动在tween执行完毕的时候删除它。


starling.animation.DelayedCall

DelayedCall | Properties | Methods
Package | starling.animation
Class | public class DelayedCall
Inheritance | DelayedCall Inheritance EventDispatcher Inheritance Object
Implements | IAnimatable

DelayedCall类允许你在一定的时间间隔之后去执行某个方法(和setTimeout有些类似)。由于这个类实现了IAnimatable接口，你可以把一个DelayedCall实例添加到juggler中。 在大部分情况下，你不需要直接使用这个类；Juggler类包含了一个方法来直接实现延迟调用这个功能。

当方法调用完毕之后，DelayedCall对象会派发一个类型是“Event.REMOVE_FROM_JUGGLER”的事件，然后如果不再需要它了，Juggler会自动将它删除。

See also

Juggler

Public Properties
Property |  | Defined By
 | currentTime : Number [read-only] 目前已经消逝的时间(单位是秒). | DelayedCall
 | isComplete : Boolean [read-only] 用来确定调用是否已经完成，如果为true则代表已经过去了足够的时间，调用已经完成了 | DelayedCall
 | repeatCount : int 方法调用将被重复的次数，设置为0则代表永远重复下去，默认值是1 | DelayedCall
 | totalTime : Number [read-only] 要延迟的总时间 (单位是秒). | DelayedCall
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | DelayedCall(call:Function, delay:Number, args:Array = null) 创建一个延迟调用对象(DelayedCall的实例) | DelayedCall
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | advanceTime(time:Number):void 暂且把这个方法称之为"时间推送器"吧. | DelayedCall
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
 | reset(call:Function, delay:Number, args:Array = null):DelayedCall 重置这个延迟调用到它的初始状态，对于缓存池来说非常有用 | DelayedCall
Property Detail
currentTime property
currentTime:Number [read-only]

目前已经消逝的时间(单位是秒).

Implementation
    public function get currentTime():Number
isComplete property
isComplete:Boolean [read-only]

用来确定调用是否已经完成，如果为true则代表已经过去了足够的时间，调用已经完成了

Implementation
    public function get isComplete():Boolean
repeatCount property
repeatCount:int

方法调用将被重复的次数，设置为0则代表永远重复下去，默认值是1

Implementation
    public function get repeatCount():int
    public function set repeatCount(value:int):void
totalTime property
totalTime:Number [read-only]

要延迟的总时间 (单位是秒).

Implementation
    public function get totalTime():Number
Constructor Detail
DelayedCall () Constructor
public function DelayedCall(call:Function, delay:Number, args:Array = null)

创建一个延迟调用对象(DelayedCall的实例)

Parameters
call:Function — 需要延迟调用的方法
delay:Number — 延迟时间(秒为单位)
args:Array (default = null) — 传递给call这个方法的参数
Method Detail
advanceTime () method
public function advanceTime(time:Number):void

暂且把这个方法称之为"时间推送器"吧. 在Starling里面，这个方法一般会和EnterFrame事件绑定起来， 就是说，如果和EnterFrame绑定，每一帧都会调用这个方法，同时传递消逝的时间值。这个时间值非常重要， 比如当Starling停止渲染，然后恢复的时候，需要从正确的点开始执行动画。 当然你也可以手动控制什么时候调用这个方法，比如在EnterFrame回调方法里面加入一些条件判断，确定是否调用这个方法，来实现画面的暂停。

Parameters

time:Number — 已经流逝的时间(秒)

reset () method
public function reset(call:Function, delay:Number, args:Array = null):DelayedCall

重置这个延迟调用到它的初始状态，对于缓存池来说非常有用

Parameters

call:Function — 要调用的方法
delay:Number — 延迟时间
args:Array (default = null) — 要传递的参数

Returns
DelayedCall — DelayedCall实例


starling.animation.IAnimatable

IAnimatable | Methods
Package | starling.animation
Interface | public interface IAnimatable
Implementors | DelayedCall, Juggler, MovieClip, Tween

IAnimatable接口定义了这样的一些对象：基于一个时间范围实现动画过程。任何实现了这个接口的类的实例，都可以被添加到juggler。

当一个对象不再需要运动的时候，你应当将它从juggler删除。要实现这一点，你可以手动执行这个方法：juggler.remove(object) 来删除它， 或者让这个对象派发一个事件来请求juggler删除自己，事件类型是Event.REMOVE_FROM_JUGGLER. Tween类就是这样一个基于事件调度的类的例子，你不需要手动从juggler删除tween的实例。

See also

Juggler
Tween

Public Methods
Method |  | Defined By
 | advanceTime(time:Number):void 暂且把这个方法称之为"时间推送器"吧. | IAnimatable
Method Detail
advanceTime () method
public function advanceTime(time:Number):void

暂且把这个方法称之为"时间推送器"吧. 在Starling里面，这个方法一般会和EnterFrame事件绑定起来， 就是说，如果和EnterFrame绑定，每一帧都会调用这个方法，同时传递消逝的时间值。这个时间值非常重要， 比如当Starling停止渲染，然后恢复的时候，需要从正确的点开始执行动画。 当然你也可以手动控制什么时候调用这个方法，比如在EnterFrame回调方法里面加入一些条件判断，确定是否调用这个方法，来实现画面的暂停。

Parameters

time:Number — 已经流逝的时间(秒)


starling.animation.Juggler

Juggler | Properties | Methods
Package | starling.animation
Class | public class Juggler
Inheritance | Juggler Inheritance Object
Implements | IAnimatable

Juggler管理那些实现了IAnimatable接口的对象（比如Tweens）并执行它们。

一个juggler实例是一个非常简单的对象。它只是持有一个列表，列表里面是那些实现了IAnimatable接口的对象，并管理它们的执行时间（通过对象自己的advanceTime方法）。当动画播放完毕，就把这个对象抛出。

在Starling类中有一个默认的juggler变量:

      var juggler:Juggler = Starling.juggler;

你可以创建你自己的juggler对象，如果需要的话。这样，你就可以组合你的游戏到一些逻辑组件，并独立控制他们的动画。 你需要做的就是，在每一帧都调用你自定义的juggler的advanceTime方法。

juggler另一个很强的特性就是"delayCall"方法。使用它可以延迟执行某个方法。但是和传统的延迟调用(比如setTimeout)不同, 这个方法只有在juggler被时间推送器驱动的时候才会起作用，这可以让你更加完美的控制呼叫的逻辑。

下面是delayCall的一些示例：

      juggler.delayCall(object.removeFromParent, 1.0);
      juggler.delayCall(object.addChild, 2.0, theChild);
      juggler.delayCall(function():void { doSomethingFunny(); }, 3.0);

See also

Tween
DelayedCall

Public Properties
Property |  | Defined By
 | elapsedTime : Number [read-only] 这个juggler对象截止到目前的存活时间累计. | Juggler
Public Methods
Method |  | Defined By
 | Juggler() 创建一个空的juggler实例. | Juggler
 | add(object:IAnimatable):void 向juggler添加一个对象. | Juggler
 | advanceTime(time:Number):void 在一定的时间内集中处理所有的对象(单位是秒) | Juggler
 | contains(object:IAnimatable):Boolean 判断juggler是否持有对这个对象的引用. | Juggler
 | delayCall(call:Function, delay:Number, ... args):DelayedCall 在一定的时间间隔之后执行指定的方法。方法会创建一个DelayedCall类的实例并返回。从juggler中删除这个实例即可取消调用。 | Juggler
 | purge():void 一次性删除所有的对象 | Juggler
 | remove(object:IAnimatable):void 从juggler中删除一个对象. | Juggler
 | removeTweens(target:Object):void 删除一个对象上应用的所有的tween对象 | Juggler
 | tween(target:Object, time:Number, properties:Object):void 在指定的时间内，用一个补间动画(tween)去"运动"一个对象。在内部，这个方法使用一个tween的实例（从缓存池中获取的），然后添加到juggler里面。 这个方法是一个快捷机制，用来方便的创建一个tween并且使用它。 设置'properties'属性，可以用键值对的方式来定义tween和动画对象。这里是一个示例片段： juggler.tween(object, 2.0, { transition: Transitions.EASE_IN_OUT, delay: 20, // -> tween.delay = 20 x: 50 // -> tween.animate("x", 50) }); | Juggler
Property Detail
elapsedTime property
elapsedTime:Number [read-only]

这个juggler对象截止到目前的存活时间累计.

Implementation
    public function get elapsedTime():Number
Constructor Detail
Juggler () Constructor
public function Juggler()

创建一个空的juggler实例.

Method Detail
add () method
public function add(object:IAnimatable):void

向juggler添加一个对象.

Parameters

object:IAnimatable — 实现IAnimatable的类的实例

advanceTime () method
public function advanceTime(time:Number):void

在一定的时间内集中处理所有的对象(单位是秒)

Parameters

time:Number — 时间(单位是秒)

contains () method
public function contains(object:IAnimatable):Boolean

判断juggler是否持有对这个对象的引用.

Parameters

object:IAnimatable — 实现IAnimatable的类的实例

Returns
Boolean
delayCall () method
public function delayCall(call:Function, delay:Number, ... args):DelayedCall

在一定的时间间隔之后执行指定的方法。方法会创建一个DelayedCall类的实例并返回。从juggler中删除这个实例即可取消调用。

Parameters

call:Function — 回调方法
delay:Number — 延迟时间
... args — 传递给回调方法的参数

Returns
DelayedCall — DelayedCall实例
purge () method
public function purge():void

一次性删除所有的对象

remove () method
public function remove(object:IAnimatable):void

从juggler中删除一个对象.

Parameters

object:IAnimatable — 实现IAnimatable的类的实例

removeTweens () method
public function removeTweens(target:Object):void

删除一个对象上应用的所有的tween对象

Parameters

target:Object — 目标对象

tween () method
public function tween(target:Object, time:Number, properties:Object):void

在指定的时间内，用一个补间动画(tween)去"运动"一个对象。在内部，这个方法使用一个tween的实例（从缓存池中获取的），然后添加到juggler里面。 这个方法是一个快捷机制，用来方便的创建一个tween并且使用它。

设置'properties'属性，可以用键值对的方式来定义tween和动画对象。这里是一个示例片段：

          juggler.tween(object, 2.0, {
              transition: Transitions.EASE_IN_OUT,
              delay: 20, // -> tween.delay = 20
              x: 50      // -> tween.animate("x", 50)
          });

Parameters

target:Object — 目标对象
time:Number — 动画时长
properties:Object — 动画属性


starling.animation.Transitions

Transitions | Methods | Constants
Package | starling.animation
Class | public class Transitions
Inheritance | Transitions Inheritance Object

Transitions(过渡)类包含了一些静态方法，来定义缓动相关的函数。这些函数被用在Tween类执行动画的时候。

关于transitions这里有一张很直观的图片描述：

你可以使用"registerTransition" 方法来自定义过渡方式. 一个过渡的实现方法必须遵循下面的语法, 其中 ratio 的取值范围是 0-1:

function myTransition(ratio:Number):Number

Public Methods
Method |  | Defined By
 | getTransition(name:String):Function [static] 通过指定一个唯一的名称，获取过渡的实现方法 | Transitions
 | register(name:String, func:Function):void [static] 通过指定一个唯一的名称，注册一个过渡的实现方法 | Transitions
Protected Methods
Method |  | Defined By
 | easeCombined(startFunc:Function, endFunc:Function, ratio:Number):Number [static] | Transitions
 | easeIn(ratio:Number):Number [static] | Transitions
 | easeInBack(ratio:Number):Number [static] | Transitions
 | easeInBounce(ratio:Number):Number [static] | Transitions
 | easeInElastic(ratio:Number):Number [static] | Transitions
 | easeInOut(ratio:Number):Number [static] | Transitions
 | easeInOutBack(ratio:Number):Number [static] | Transitions
 | easeInOutBounce(ratio:Number):Number [static] | Transitions
 | easeInOutElastic(ratio:Number):Number [static] | Transitions
 | easeOut(ratio:Number):Number [static] | Transitions
 | easeOutBack(ratio:Number):Number [static] | Transitions
 | easeOutBounce(ratio:Number):Number [static] | Transitions
 | easeOutElastic(ratio:Number):Number [static] | Transitions
 | easeOutIn(ratio:Number):Number [static] | Transitions
 | easeOutInBack(ratio:Number):Number [static] | Transitions
 | easeOutInBounce(ratio:Number):Number [static] | Transitions
 | easeOutInElastic(ratio:Number):Number [static] | Transitions
 | linear(ratio:Number):Number [static] | Transitions
Public Constants
Constant |  | Defined By
 | EASE_IN : String = easeIn [static] | Transitions
 | EASE_IN_BACK : String = easeInBack [static] | Transitions
 | EASE_IN_BOUNCE : String = easeInBounce [static] | Transitions
 | EASE_IN_ELASTIC : String = easeInElastic [static] | Transitions
 | EASE_IN_OUT : String = easeInOut [static] | Transitions
 | EASE_IN_OUT_BACK : String = easeInOutBack [static] | Transitions
 | EASE_IN_OUT_BOUNCE : String = easeInOutBounce [static] | Transitions
 | EASE_IN_OUT_ELASTIC : String = easeInOutElastic [static] | Transitions
 | EASE_OUT : String = easeOut [static] | Transitions
 | EASE_OUT_BACK : String = easeOutBack [static] | Transitions
 | EASE_OUT_BOUNCE : String = easeOutBounce [static] | Transitions
 | EASE_OUT_ELASTIC : String = easeOutElastic [static] | Transitions
 | EASE_OUT_IN : String = easeOutIn [static] | Transitions
 | EASE_OUT_IN_BACK : String = easeOutInBack [static] | Transitions
 | EASE_OUT_IN_BOUNCE : String = easeOutInBounce [static] | Transitions
 | EASE_OUT_IN_ELASTIC : String = easeOutInElastic [static] | Transitions
 | LINEAR : String = linear [static] | Transitions
Method Detail
easeCombined () method
protected static function easeCombined(startFunc:Function, endFunc:Function, ratio:Number):Number

Parameters

startFunc:Function
endFunc:Function
ratio:Number

Returns
Number
easeIn () method
protected static function easeIn(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInBack () method
protected static function easeInBack(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInBounce () method
protected static function easeInBounce(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInElastic () method
protected static function easeInElastic(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInOut () method
protected static function easeInOut(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInOutBack () method
protected static function easeInOutBack(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInOutBounce () method
protected static function easeInOutBounce(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeInOutElastic () method
protected static function easeInOutElastic(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOut () method
protected static function easeOut(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutBack () method
protected static function easeOutBack(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutBounce () method
protected static function easeOutBounce(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutElastic () method
protected static function easeOutElastic(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutIn () method
protected static function easeOutIn(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutInBack () method
protected static function easeOutInBack(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutInBounce () method
protected static function easeOutInBounce(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
easeOutInElastic () method
protected static function easeOutInElastic(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
getTransition () method
public static function getTransition(name:String):Function

通过指定一个唯一的名称，获取过渡的实现方法

Parameters

name:String

Returns
Function
linear () method
protected static function linear(ratio:Number):Number

Parameters

ratio:Number

Returns
Number
register () method
public static function register(name:String, func:Function):void

通过指定一个唯一的名称，注册一个过渡的实现方法

Parameters

name:String
func:Function

Constant Detail
EASE_IN Constant
public static const EASE_IN:String = easeIn

EASE_IN_BACK Constant
public static const EASE_IN_BACK:String = easeInBack

EASE_IN_BOUNCE Constant
public static const EASE_IN_BOUNCE:String = easeInBounce

EASE_IN_ELASTIC Constant
public static const EASE_IN_ELASTIC:String = easeInElastic

EASE_IN_OUT Constant
public static const EASE_IN_OUT:String = easeInOut

EASE_IN_OUT_BACK Constant
public static const EASE_IN_OUT_BACK:String = easeInOutBack

EASE_IN_OUT_BOUNCE Constant
public static const EASE_IN_OUT_BOUNCE:String = easeInOutBounce

EASE_IN_OUT_ELASTIC Constant
public static const EASE_IN_OUT_ELASTIC:String = easeInOutElastic

EASE_OUT Constant
public static const EASE_OUT:String = easeOut

EASE_OUT_BACK Constant
public static const EASE_OUT_BACK:String = easeOutBack

EASE_OUT_BOUNCE Constant
public static const EASE_OUT_BOUNCE:String = easeOutBounce

EASE_OUT_ELASTIC Constant
public static const EASE_OUT_ELASTIC:String = easeOutElastic

EASE_OUT_IN Constant
public static const EASE_OUT_IN:String = easeOutIn

EASE_OUT_IN_BACK Constant
public static const EASE_OUT_IN_BACK:String = easeOutInBack

EASE_OUT_IN_BOUNCE Constant
public static const EASE_OUT_IN_BOUNCE:String = easeOutInBounce

EASE_OUT_IN_ELASTIC Constant
public static const EASE_OUT_IN_ELASTIC:String = easeOutInElastic

LINEAR Constant
public static const LINEAR:String = linear


starling.animation.Tween

Tween | Properties | Methods
Package | starling.animation
Class | public class Tween
Inheritance | Tween Inheritance EventDispatcher Inheritance Object
Implements | IAnimatable

一个Tween实例，将使用补间动画的方式，"运动"某个对象的属性(比如改变x坐标值，从1,2,3...一直到N，从而形成视觉上的动画效果)。 它可以使用不同的过渡方法，来实现不同的动画方式。

这个类的主要用途是实现标准的动画，比如移动，透明度渐变，旋转等等。但是"动画"的范围远远不止于此。只要你想"运动"的对象的属性值是数字 (int, uint, Number), Tween就能搞定它。 要了解Tween可以使用的过渡方法的列表，请参阅"Transitions"类。

下面是一个实例，展示了tween移动一个对象到右侧，旋转它，然后让它透明度逐渐降低而消失:

      var tween:Tween = new Tween(object, 2.0, Transitions.EASE_IN_OUT);
      tween.animate("x", object.x + 50);
      tween.animate("rotation", deg2rad(45));
      tween.fadeTo(0);    // 你也可以使用'animate("alpha", 0)'来代替
      Starling.juggler.add(tween);

注意在上面的代码的最后，tween的实例被添加到了juggler。这是因为，只有tween自己的"advanceTime"方法被实际执行的时候，tween才会起作用。 这个工作juggler会帮你做的，而且它会自动在tween执行完毕的时候删除它。

See also

Juggler
Transitions

Public Properties
Property |  | Defined By
 | currentTime : Number [read-only] 已经执行的时间(秒) | Tween
 | delay : Number 动画需要延迟多长时间才开始.默认是0 | Tween
 | isComplete : Boolean [read-only] 动画是否播放完毕 | Tween
 | nextTween : Tween 当这个tween完成的时候，立刻开始执行下一个tween | Tween
 | onComplete : Function 当tween执行完毕的时候会调用的方法. | Tween
 | onCompleteArgs : Array 需要传递给'onComplete' 方法的参数. | Tween
 | onRepeat : Function 当Tween完成每一次执行的时候，会调用的方法。 (除了最后一次调用，因为它会触发'onComplete'). | Tween
 | onRepeatArgs : Array 需要传递给'onRepeat' 方法的参数. | Tween
 | onStart : Function 当tween开始动画的时候会执行的方法 (如果有延迟的话，则在延迟之后). | Tween
 | onStartArgs : Array 需要传递给 'onStart' 方法的参数. | Tween
 | onUpdate : Function 动画过程中的每一帧都会执行的方法. | Tween
 | onUpdateArgs : Array 需要传递给'onUpdate' 方法的参数. | Tween
 | repeatCount : int 动画需要被执行的次数.0代表永不停止. | Tween
 | repeatDelay : Number 重复执行动画的时候，中间的时间间隔，单位是秒. | Tween
 | reverse : Boolean 设置当动画重复播放的时候，是否翻转执行. | Tween
 | roundToInt : Boolean 表示数字是否会被截取为整型. | Tween
 | target : Object [read-only] 当前"动画"要执行的对象 | Tween
 | totalTime : Number [read-only] 动画执行的总时间 (秒). | Tween
 | transition : String 动画过程中用到的过渡方法. | Tween
 | transitionFunc : Function 可以传递一个方法来实现自定义的过渡过程 | Tween
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Tween(target:Object, time:Number, transition:Object = linear) 创建一个tween的实例， 同时设置目标对象, 时间 (单位是秒) 和过渡方式. | Tween
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | advanceTime(time:Number):void 暂且把这个方法称之为"时间推送器"吧. | Tween
 | animate(property:String, targetValue:Number):void "运动"某个对象的属性到目标值。你可以在一个tween上多次调用这个方法。 | Tween
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | fadeTo(alpha:Number):void "运动"目标对象的'alpha'值，直到达到目标值。 | Tween
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | moveTo(x:Number, y:Number):void 同时"运动"目标对象的'x' 和 'y'两个值。用这个方法移动对象。 | Tween
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
 | reset(target:Object, time:Number, transition:Object = linear):Tween 把tween恢复到它的初始值. | Tween
 | scaleTo(factor:Number):void 同时"运动"目标对象的'scaleX' 和 'scaleY'两个值。用这个方法放大或缩小对象。 | Tween
Property Detail
currentTime property
currentTime:Number [read-only]

已经执行的时间(秒)

Implementation
    public function get currentTime():Number
delay property
delay:Number

动画需要延迟多长时间才开始.默认是0

Implementation
    public function get delay():Number
    public function set delay(value:Number):void
isComplete property
isComplete:Boolean [read-only]

动画是否播放完毕

Implementation
    public function get isComplete():Boolean
nextTween property
nextTween:Tween

当这个tween完成的时候，立刻开始执行下一个tween

Implementation
    public function get nextTween():Tween
    public function set nextTween(value:Tween):void
onComplete property
onComplete:Function

当tween执行完毕的时候会调用的方法.

Implementation
    public function get onComplete():Function
    public function set onComplete(value:Function):void
onCompleteArgs property
onCompleteArgs:Array

需要传递给'onComplete' 方法的参数.

Implementation
    public function get onCompleteArgs():Array
    public function set onCompleteArgs(value:Array):void
onRepeat property
onRepeat:Function

当Tween完成每一次执行的时候，会调用的方法。 (除了最后一次调用，因为它会触发'onComplete').

Implementation
    public function get onRepeat():Function
    public function set onRepeat(value:Function):void
onRepeatArgs property
onRepeatArgs:Array

需要传递给'onRepeat' 方法的参数.

Implementation
    public function get onRepeatArgs():Array
    public function set onRepeatArgs(value:Array):void
onStart property
onStart:Function

当tween开始动画的时候会执行的方法 (如果有延迟的话，则在延迟之后).

Implementation
    public function get onStart():Function
    public function set onStart(value:Function):void
onStartArgs property
onStartArgs:Array

需要传递给 'onStart' 方法的参数.

Implementation
    public function get onStartArgs():Array
    public function set onStartArgs(value:Array):void
onUpdate property
onUpdate:Function

动画过程中的每一帧都会执行的方法.

Implementation
    public function get onUpdate():Function
    public function set onUpdate(value:Function):void
onUpdateArgs property
onUpdateArgs:Array

需要传递给'onUpdate' 方法的参数.

Implementation
    public function get onUpdateArgs():Array
    public function set onUpdateArgs(value:Array):void
repeatCount property
repeatCount:int

动画需要被执行的次数.0代表永不停止. 默认是1

Implementation
    public function get repeatCount():int
    public function set repeatCount(value:int):void
repeatDelay property
repeatDelay:Number

重复执行动画的时候，中间的时间间隔，单位是秒. 默认是0

Implementation
    public function get repeatDelay():Number
    public function set repeatDelay(value:Number):void
reverse property
reverse:Boolean

设置当动画重复播放的时候，是否翻转执行. 如果设置为true，则重复的时候一直是翻转的. 默认是false

Implementation
    public function get reverse():Boolean
    public function set reverse(value:Boolean):void
roundToInt property
roundToInt:Boolean

表示数字是否会被截取为整型.

The default value is false.

Implementation
    public function get roundToInt():Boolean
    public function set roundToInt(value:Boolean):void
target property
target:Object [read-only]

当前"动画"要执行的对象

Implementation
    public function get target():Object
totalTime property
totalTime:Number [read-only]

动画执行的总时间 (秒).

Implementation
    public function get totalTime():Number
transition property
transition:String

动画过程中用到的过渡方法.

Implementation
    public function get transition():String
    public function set transition(value:String):void

See also

Transitions
transitionFunc property
transitionFunc:Function

可以传递一个方法来实现自定义的过渡过程

Implementation
    public function get transitionFunc():Function
    public function set transitionFunc(value:Function):void
Constructor Detail
Tween () Constructor
public function Tween(target:Object, time:Number, transition:Object = linear)

创建一个tween的实例， 同时设置目标对象, 时间 (单位是秒) 和过渡方式.

Parameters
target:Object — 目标
time:Number — 时间
transition:Object (default = linear) — 过渡方式，默认linear
Method Detail
advanceTime () method
public function advanceTime(time:Number):void

暂且把这个方法称之为"时间推送器"吧. 在Starling里面，这个方法一般会和EnterFrame事件绑定起来， 就是说，如果和EnterFrame绑定，每一帧都会调用这个方法，同时传递消逝的时间值。这个时间值非常重要， 比如当Starling停止渲染，然后恢复的时候，需要从正确的点开始执行动画。 当然你也可以手动控制什么时候调用这个方法，比如在EnterFrame回调方法里面加入一些条件判断，确定是否调用这个方法，来实现画面的暂停。

Parameters

time:Number — 已经流逝的时间(秒)

animate () method
public function animate(property:String, targetValue:Number):void

"运动"某个对象的属性到目标值。你可以在一个tween上多次调用这个方法。

Parameters

property:String — 属性值
targetValue:Number — 目标值

fadeTo () method
public function fadeTo(alpha:Number):void

"运动"目标对象的'alpha'值，直到达到目标值。

Parameters

alpha:Number — 透明度的目标值

moveTo () method
public function moveTo(x:Number, y:Number):void

同时"运动"目标对象的'x' 和 'y'两个值。用这个方法移动对象。

Parameters

x:Number — X坐标值
y:Number — Y坐标值

reset () method
public function reset(target:Object, time:Number, transition:Object = linear):Tween

把tween恢复到它的初始值. 对pooling tweens有用.

Parameters

target:Object — 目标
time:Number — 时间
transition:Object (default = linear) — 过渡方式，默认linear

Returns
Tween — Tween实例
scaleTo () method
public function scaleTo(factor:Number):void

同时"运动"目标对象的'scaleX' 和 'scaleY'两个值。用这个方法放大或缩小对象。

Parameters

factor:Number — 缩放值


starling.core - Starling API 1.3 | Starling中文站

Package starling.core

Classes
RenderSupport
Starling


starling.core Summary

starling.core | Classes

Classes
Class | Description
RenderSupport | 这个类 包含了简化Stage3D渲染的辅助方法.
Starling | Starling类展现了Starling框架的核心.


starling.core.RenderSupport

RenderSupport | Properties | Methods
Package | starling.core
Class | public class RenderSupport
Inheritance | RenderSupport Inheritance Object

这个类 包含了简化Stage3D渲染的辅助方法. RenderSupport实例可以被任意显示对象的“渲染”方法使用. 它可以对当前变换矩阵和其它帮助方法进行处理 (与OpenGL 1.x的变换矩阵方法类似).

Public Properties
Property |  | Defined By
 | backBufferHeight : int 后台缓冲区的高度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。 | RenderSupport
 | backBufferWidth : int 后台缓冲区的宽度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。 | RenderSupport
 | blendMode : String 在渲染中将要使用的混合模式.要应用这个设置，你必须手工调用"applyBlendMode"方法(因为实际的混合因素依赖于对PMA模式)。 | RenderSupport
 | drawCount : int [read-only] 指出stage3D绘制调用次数. | RenderSupport
 | modelViewMatrix : Matrix [read-only] 返回当前模型视图矩阵. | RenderSupport
 | mvpMatrix : Matrix [read-only] 计算模型视图矩阵和映射矩阵的商. | RenderSupport
 | mvpMatrix3D : Matrix3D [read-only] 计算模型视图矩阵和映射矩阵的商保存到一个三维矩阵中. | RenderSupport
 | projectionMatrix : Matrix [read-only] 返回当前映射矩阵. | RenderSupport
 | renderTarget : Texture 当前即将被渲染的纹理，如果是'null'将渲染到后台缓冲区。如果你设置一个新对象，则它马上就会被启动。 | RenderSupport
 | scissorRectangle : Rectangle 裁切矩形可以被用于限制当前渲染目标到一个指定的区域。 这个方法需要stage坐标系中的一个矩形(和Context3D的同名方法不同，它使用的是像素)。传递null将关闭裁剪。注意：这不是一个副本，小心使用！ | RenderSupport
Public Methods
Method |  | Defined By
 | RenderSupport() 创建一个携带空矩阵堆的RenderSupport对象. | RenderSupport
 | applyBlendMode(premultipliedAlpha:Boolean):void 在当前的渲染内容中使用合适的混合因数. | RenderSupport
 | assembleAgal(vertexShader:String, fragmentShader:String, resultProgram:Program3D = null):Program3D [static] 汇编通过字符串传递的片段和顶点着色器到Program3D中。如果你传递了一个'resultProgram'参数，那么结果就会上传到传入的这个Program3D对象中。 否则，将从当前的Stage3D上下文中，创建一个新的Program3D对象。 | RenderSupport
 | batchQuad(quad:Quad, parentAlpha:Number, texture:Texture = null, smoothing:String = null):void 在当前未渲染的四角面组中添加一个四角面. | RenderSupport
 | clear(rgb:uint = 0, alpha:Number = 0.0):void 以特定颜色和透明度清除渲染内容. | RenderSupport
 | clear(rgb:uint = 0, alpha:Number = 0.0):void [static] 以特定颜色和透明度清除渲染内容. | RenderSupport
 | configureBackBuffer(width:int, height:int, antiAlias:int, enableDepthAndStencil:Boolean):void 配置当前Context3D对象的后台缓冲区。 通过使用这个方法，Starling可以存储后台缓冲区的大小，并且在其它方法(比如矩形区域的裁切)中使用这个信息。 后台缓冲区的宽度和高度，可以在以后通过相同的属性名称来访问。 | RenderSupport
 | dispose():void 删除所四角面. | RenderSupport
 | finishQuadBatch():void 渲染当前四角面组然后重置. | RenderSupport
 | loadIdentity():void 把模型视图矩阵变换为单位矩阵. | RenderSupport
 | nextFrame():void 重置矩阵和混合模式堆，四角面组索引,和绘画计数。 | RenderSupport
 | popMatrix():void 访问保存在堆中的模型视图矩阵. | RenderSupport
 | prependMatrix(matrix:Matrix):void 与另一矩阵相乘得到模型视图矩阵. | RenderSupport
 | pushMatrix():void 把当前模型视图矩阵推入堆中以便随后访问. | RenderSupport
 | raiseDrawCount(value:uint = 1):void 提升绘制计数特定的数值.在调用自定义渲染方法时调用这个方法来保持渲染数据的同步 | RenderSupport
 | resetMatrix():void 置空矩阵堆, 把模型视图矩阵重设为单位矩阵. | RenderSupport
 | rotateMatrix(angle:Number):void 根据相应旋转变化得到模型视图矩阵. | RenderSupport
 | scaleMatrix(sx:Number, sy:Number):void 根据相应缩放变化得到模型视图矩阵. | RenderSupport
 | setBlendFactors(premultipliedAlpha:Boolean, blendMode:String = normal):void [static] 设置相应混合模式的混合参数. | RenderSupport
 | setDefaultBlendFactors(premultipliedAlpha:Boolean):void [static] 不再使用。调用'setBlendFactors'方法. | RenderSupport
 | setOrthographicProjection(x:Number, y:Number, width:Number, height:Number):void 设置正面二维渲染的矩阵映射. | RenderSupport
 | transformMatrix(object:DisplayObject):void 根据对象的坐标变换，缩放和旋转生成模型视图矩阵. | RenderSupport
 | transformMatrixForObject(matrix:Matrix, object:DisplayObject):void [static] 把一个对象的位移，缩放和旋转转化为自定义矩阵. | RenderSupport
 | translateMatrix(dx:Number, dy:Number):void 根据相应位移变化得到模型视图矩阵. | RenderSupport
Property Detail
backBufferHeight property
backBufferHeight:int

后台缓冲区的高度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。

Implementation
    public function get backBufferHeight():int
    public function set backBufferHeight(value:int):void
backBufferWidth property
backBufferWidth:int

后台缓冲区的宽度，它是被最后一次调用'RenderSupport.configureBackBuffer()'时确定的。 请注意：更改此值实际上并不会修改后台缓冲区的尺寸；setter方法只是用来通知Starling后台缓冲区的尺寸（它无法控制的情况，比如共享上下文的情况下）。

Implementation
    public function get backBufferWidth():int
    public function set backBufferWidth(value:int):void
blendMode property
blendMode:String

在渲染中将要使用的混合模式.要应用这个设置，你必须手工调用"applyBlendMode"方法(因为实际的混合因素依赖于对PMA模式)。

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void
drawCount property
drawCount:int [read-only]

指出stage3D绘制调用次数.

Implementation
    public function get drawCount():int
modelViewMatrix property
modelViewMatrix:Matrix [read-only]

返回当前模型视图矩阵. 注意：不是拷贝 - 小心使用!

Implementation
    public function get modelViewMatrix():Matrix
mvpMatrix property
mvpMatrix:Matrix [read-only]

计算模型视图矩阵和映射矩阵的商. 注意：不要保存这个对象的引用！每次调用实际返回的是同一实例。

Implementation
    public function get mvpMatrix():Matrix
mvpMatrix3D property
mvpMatrix3D:Matrix3D [read-only]

计算模型视图矩阵和映射矩阵的商保存到一个三维矩阵中. 注意：不要保存这个对象的引用！每次调用实际返回的是同一实例。

Implementation
    public function get mvpMatrix3D():Matrix3D
projectionMatrix property
projectionMatrix:Matrix [read-only]

返回当前映射矩阵. 注意：不是拷贝 - 小心使用!

Implementation
    public function get projectionMatrix():Matrix
renderTarget property
renderTarget:Texture

当前即将被渲染的纹理，如果是'null'将渲染到后台缓冲区。如果你设置一个新对象，则它马上就会被启动。

Implementation
    public function get renderTarget():Texture
    public function set renderTarget(value:Texture):void
scissorRectangle property
scissorRectangle:Rectangle

裁切矩形可以被用于限制当前渲染目标到一个指定的区域。 这个方法需要stage坐标系中的一个矩形(和Context3D的同名方法不同，它使用的是像素)。传递null将关闭裁剪。注意：这不是一个副本，小心使用！

Implementation
    public function get scissorRectangle():Rectangle
    public function set scissorRectangle(value:Rectangle):void
Constructor Detail
RenderSupport () Constructor
public function RenderSupport()

创建一个携带空矩阵堆的RenderSupport对象.

Method Detail
applyBlendMode () method
public function applyBlendMode(premultipliedAlpha:Boolean):void

在当前的渲染内容中使用合适的混合因数.

Parameters

premultipliedAlpha:Boolean

assembleAgal () method
public static function assembleAgal(vertexShader:String, fragmentShader:String, resultProgram:Program3D = null):Program3D

汇编通过字符串传递的片段和顶点着色器到Program3D中。如果你传递了一个'resultProgram'参数，那么结果就会上传到传入的这个Program3D对象中。 否则，将从当前的Stage3D上下文中，创建一个新的Program3D对象。

Parameters

vertexShader:String — 顶点着色器源码
fragmentShader:String — 片段着色器源码
resultProgram:Program3D (default = null) — Program3D对象

Returns
Program3D — Program3D对象
batchQuad () method
public function batchQuad(quad:Quad, parentAlpha:Number, texture:Texture = null, smoothing:String = null):void

在当前未渲染的四角面组中添加一个四角面. 如果当前状态改变则立即渲染之前组中四角面,然后重置当前组。

Parameters

quad:Quad
parentAlpha:Number
texture:Texture (default = null)
smoothing:String (default = null)

clear () method
public function clear(rgb:uint = 0, alpha:Number = 0.0):void

以特定颜色和透明度清除渲染内容.

Parameters

rgb:uint (default = 0) — RGB色值
alpha:Number (default = 0.0) — 透明度

clear () method
public static function clear(rgb:uint = 0, alpha:Number = 0.0):void

以特定颜色和透明度清除渲染内容.

Parameters

rgb:uint (default = 0) — RGB色值
alpha:Number (default = 0.0) — 透明度

configureBackBuffer () method
public function configureBackBuffer(width:int, height:int, antiAlias:int, enableDepthAndStencil:Boolean):void

配置当前Context3D对象的后台缓冲区。 通过使用这个方法，Starling可以存储后台缓冲区的大小，并且在其它方法(比如矩形区域的裁切)中使用这个信息。 后台缓冲区的宽度和高度，可以在以后通过相同的属性名称来访问。

Parameters

width:int — 宽度
height:int — 高度
antiAlias:int — 抗锯齿级别
enableDepthAndStencil:Boolean — 是否开启深度和印模缓冲区

dispose () method
public function dispose():void

删除所四角面.

finishQuadBatch () method
public function finishQuadBatch():void

渲染当前四角面组然后重置.

loadIdentity () method
public function loadIdentity():void

把模型视图矩阵变换为单位矩阵.

nextFrame () method
public function nextFrame():void

重置矩阵和混合模式堆，四角面组索引,和绘画计数。

popMatrix () method
public function popMatrix():void

访问保存在堆中的模型视图矩阵.

prependMatrix () method
public function prependMatrix(matrix:Matrix):void

与另一矩阵相乘得到模型视图矩阵.

Parameters

matrix:Matrix

pushMatrix () method
public function pushMatrix():void

把当前模型视图矩阵推入堆中以便随后访问.

raiseDrawCount () method
public function raiseDrawCount(value:uint = 1):void

提升绘制计数特定的数值.在调用自定义渲染方法时调用这个方法来保持渲染数据的同步

Parameters

value:uint (default = 1)

resetMatrix () method
public function resetMatrix():void

置空矩阵堆, 把模型视图矩阵重设为单位矩阵.

rotateMatrix () method
public function rotateMatrix(angle:Number):void

根据相应旋转变化得到模型视图矩阵.

Parameters

angle:Number

scaleMatrix () method
public function scaleMatrix(sx:Number, sy:Number):void

根据相应缩放变化得到模型视图矩阵.

Parameters

sx:Number
sy:Number

setBlendFactors () method
public static function setBlendFactors(premultipliedAlpha:Boolean, blendMode:String = normal):void

设置相应混合模式的混合参数.

Parameters

premultipliedAlpha:Boolean — 是否预乘透明度
blendMode:String (default = normal) — 混合模式，默认是normal

setDefaultBlendFactors () method
public static function setDefaultBlendFactors(premultipliedAlpha:Boolean):void

不再使用。调用'setBlendFactors'方法.

Parameters

premultipliedAlpha:Boolean

setOrthographicProjection () method
public function setOrthographicProjection(x:Number, y:Number, width:Number, height:Number):void

设置正面二维渲染的矩阵映射.

Parameters

x:Number
y:Number
width:Number
height:Number

transformMatrix () method
public function transformMatrix(object:DisplayObject):void

根据对象的坐标变换，缩放和旋转生成模型视图矩阵.

Parameters

object:DisplayObject

transformMatrixForObject () method
public static function transformMatrixForObject(matrix:Matrix, object:DisplayObject):void

把一个对象的位移，缩放和旋转转化为自定义矩阵.

Parameters

matrix:Matrix
object:DisplayObject

translateMatrix () method
public function translateMatrix(dx:Number, dy:Number):void

根据相应位移变化得到模型视图矩阵.

Parameters

dx:Number
dy:Number


starling.core.Starling

Starling | Properties | Methods | Events | Constants
Package | starling.core
Class | public class Starling
Inheritance | Starling Inheritance EventDispatcher Inheritance Object

Starling类展现了Starling框架的核心.

Starling框架让使用Stage3D技术(在flash player 11中引入)创建二维程序和游戏成为可能。 它实现了和Flash 一样的显示列表系统，同时使用先进的GPUs加速渲染.

Starling类展示了Flash显示列表和Starling显示列表之间的结构关系。创建一个Starling应用程序，你必须首先 创建一个Starling类的实例对象。

var starling:Starling = new Starling(Game, stage);

第一个参数必须是Starling的显示类。例如starling.display.Sprite的子类，在上面的例子 中，类“Game”是程序的根。当Starling初始化后“Game”的对象也随之创建。 第二个参数是FLash本身的stage对象，在默认情况下，Starling会在stage下层显示内容。

建议保存Starling对象作为成员变量，这样可以保证垃圾回收系统不会销毁它。在创建Starling对象后，你必须这样启动它：

starling.start();

现在它会按照为程序设置好帧频率（和设置Flash stage的方法一样）来渲染“Game”类的内容了.

访问Starling对象

在你的程序里，你可以在任意时间通过静态方法Starling.current访问当前的Starling对象。它会返回 当前活跃的Starling实例（实际上大多数程序只会有一个Starling对象）。

观察口，视口

即是Starling内容渲染显示的范围，默认情况下是舞台大小。但是，你可以使用“viewport”属性去改变它。当你只想在屏幕的一部分中 渲染，或者播放器大小改变时，这个属性非常有用。随后你可以监听由Starling舞台发出的RESIZE事件。

原生Flash叠加层

有时你会想在Starling上面显示一些原生Flash内容，这就是nativeOverlay属性的作用。它返回的是在Starling之上 的原生FLash Sprite。你可以在叠加层内添加原生Flash对象。

但是需要注意，在3D加速内容之上的原生Flash内容在某些（移动）平台上会有性能上的问题。因为这个原因，请注意删除这一层中所有 不需要和不再使用的对象。当这一层被置空后Starling会从显示列表中删除原生Flash叠加层。

多点触摸

对于提供支持多点触摸功能的设备，Starling也支持这项功能。在开发过程中，我们大多数基本上都是使用鼠标的键盘，Starling可以 在“Shift”和“Ctrl”的帮助下（Mac苹果机是“Cmd”）模拟实现多点触摸事件。启动simulateMultitouch属性就可以激活 这个功能。

处理丢失的渲染内容

在某些系统和某些条件下（例如，从系统睡眠中返回），Starling的stage3D渲染内容会丢失。如果类属性“handleLostContext” 设置为 “true” Starling会自动修复丢失内容。但是需要注意，这是以提高内存消耗为代价的。Starling会在内存中创建纹理缓存，这样 在内容丢失时才可以修复它。

如果你想和丢失的内容交互，Starling在这个内容修复时发送"Event.CONTEXT3D_CREATE"事件，你可以在相对应的事件监听器中重新 创建这些不可用资源.

共享三维加速内容

正常情况下，Starling是独立处理stage3d加速内容。如果你想让Starling和其它的stage3d引擎同时使用，可能会达不到你需要的效果。 在这种情况下，你可以使用shareContext属性:

  1. 手动创建和定义一个让两个框架公用的context3D对象 (通过stage3D.requestContext3D 和 context.configureBackBuffer)创建.
  2. 使用已经定义了的context3d对象的stage3d实例来初始化Starling。 这样做会自动启用 shareContext.
  3. 调用Starling实例的 start()(与往常一样). 这样做是让 Starling 对事件监听进行排队处理 (keyboard/mouse/touch).
  4. 创建一个游戏逻辑（例如，使用原生的ENTER_FRAME事件）然后让它调用Starling的 nextFrame同时调用其它Stage3D引擎的同功能方法 . 相关类型的方法还有context.clear() 和 context.present().

Public Properties
Property |  | Defined By
 | antiAliasing : int 抗锯齿层级. | Starling
 | contentScaleFactor : Number [read-only] 渲染范围和舞台的比率。在针对不同分辨率选择不同材质时非常有用。 | Starling
 | context : Context3D [read-only] 这个实例的渲染上下文. | Starling
 | contextData : Dictionary [read-only] 一个字典对象，用于保存当前上下文相关的自定义数据。如果你需要把共享数据绑定到一个特定的Stage3D实例（比如纹理），可用使用这个字典来代替创建一个静态变量。 这个字典实际上是绑定到一个Stage3D的实例上，所以它的生命周期取决于这个Stage3D实例是否丢失。 | Starling
 | current : Starling [static] [read-only] 现在激活的 Starling 实例. | Starling
 | enableErrorChecking : Boolean Stage3D 渲染方法是否报告发生的错误. | Starling
 | handleLostContext : Boolean [static] 是否启用 “丢失内容修复功能 ”.在某些系统中，在进入屏保或者进入睡眠会禁用渲染，这个设置指示Starling是否 要解决这个问题。注意这项功能会消耗大量内存！建议在Android和Windows下启动，在Mac OS X和iOS中禁用。 | Starling
 | isStarted : Boolean [read-only] Starling 实例是否启动. | Starling
 | juggler : Juggler [read-only] 这个实例上的默认juggler对象. | Starling
 | multitouchEnabled : Boolean [static] 是否支持多点触摸. | Starling
 | nativeOverlay : Sprite [read-only] 在Starling 上面的原生Flash Sprite.使用它显示Flash原生组件 | Starling
 | nativeStage : Stage [read-only] Flash (2D) 舞台对象,Starling 在其下渲染. | Starling
 | profile : String [read-only] 在构造方法中传入的Context3D渲染方式. | Starling
 | root : DisplayObject [read-only] 构造中提供的根类的实例.'ROOT_CREATED'事件派发后可以使用. | Starling
 | shareContext : Boolean Context3D 渲染调用是否可以被Starling外部使用 , 是否可以让其它框架共享Stage3D对象 | Starling
 | showStats : Boolean 是否显示数据统计 (FPS, 内存占用 和面数)。 | Starling
 | simulateMultitouch : Boolean 多点触摸模拟 "Shift" 和 "Ctrl"/"Cmd"-是否启用. | Starling
 | stage : Stage [read-only] Starling 舞台对象, 是显示列表的根. | Starling
 | stage3D : Stage3D [read-only] Starling的渲染目标Flash Stage3D 对象 | Starling
 | viewPort : Rectangle Starling 内容渲染的区域. | Starling
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Starling(rootClass:Class, stage:Stage, viewPort:Rectangle = null, stage3D:Stage3D = null, renderMode:String = auto, profile:String = baselineConstrained) 创建一个新的Starling实例. | Starling
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | advanceTime(passedTime:Number):void 在显示列表上派发ENTER_FRAME事件, 优化 Juggler 和 处理 触摸事件. | Starling
 | deleteProgram(name:String):void 根据指定的名称，删除一个顶点着色程序和片段着色程序. | Starling
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | dispose():void 销毁stage的所有子级和渲染上下文，删除所有的事件侦听器 | Starling
 | getProgram(name:String):Program3D 根据指定的名称，返回一个已注册的顶点着色程序和片段着色程序. | Starling
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | hasProgram(name:String):Boolean 根据指定的名称，判断这个顶点着色程序和片段着色程序是否被注册. | Starling
 | makeCurrent():void 让Starling实例成为 current 实例. | Starling
 | nextFrame():void 调用 advanceTime() (上一帧到现在的渲染时间) 和 render(). | Starling
 | registerProgram(name:String, vertexProgram:ByteArray, fragmentProgram:ByteArray):void 根据一个指定的名称注册一个顶点和片段着色器程序。如果这个名称已经被使用了，那么上一个使用这个名称的程序将会被覆盖。 | Starling
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
 | render():void 渲染整个显示列表. | Starling
 | showStatsAt(hAlign:String = left, vAlign:String = top, scale:Number = 1):void 数据统计显示位置. | Starling
 | start():void Starling启动后，它会对输入事件排队处理 (keyboard/mouse/touch); 另外, nextFrame方法 会在Flash Player中每一帧调用。 (如果 shareContext启用: 在这种情况, 你必须手动 调用这个方法.) | Starling
 | stop():void 停止所有的逻辑处理，并冻结游戏的当前状态。但实际上每一帧仍然在渲染内容（只是看起来不更新了），因为如果不这样做的话，传统显示列表就无法更新。 | Starling
Events
Event |  | Summary | Defined By
 | context3DCreate | 新的渲染环境创建后派发事件. | Starling
 | rootCreated | 根类创建后派发事件. | Starling
Public Constants
Constant |  | Defined By
 | VERSION : String = 1.3 [static] Starling framework的版本. | Starling
Property Detail
antiAliasing property
antiAliasing:int

抗锯齿层级. 0 - 没有抗锯齿, 16 - 最大程度的抗锯齿.

The default value is 0.

Implementation
    public function get antiAliasing():int
    public function set antiAliasing(value:int):void
contentScaleFactor property
contentScaleFactor:Number [read-only]

渲染范围和舞台的比率。在针对不同分辨率选择不同材质时非常有用。

Implementation
    public function get contentScaleFactor():Number
context property
context:Context3D [read-only]

这个实例的渲染上下文.

Implementation
    public function get context():Context3D
contextData property
contextData:Dictionary [read-only]

一个字典对象，用于保存当前上下文相关的自定义数据。如果你需要把共享数据绑定到一个特定的Stage3D实例（比如纹理），可用使用这个字典来代替创建一个静态变量。 这个字典实际上是绑定到一个Stage3D的实例上，所以它的生命周期取决于这个Stage3D实例是否丢失。

Implementation
    public function get contextData():Dictionary
current property
current:Starling [read-only]

现在激活的 Starling 实例.

Implementation
    public static function get current():Starling
enableErrorChecking property
enableErrorChecking:Boolean

Stage3D 渲染方法是否报告发生的错误. 需要时启用, 这个功能对性能有负面影响.

The default value is false.

Implementation
    public function get enableErrorChecking():Boolean
    public function set enableErrorChecking(value:Boolean):void
handleLostContext property
handleLostContext:Boolean

是否启用 “丢失内容修复功能 ”.在某些系统中，在进入屏保或者进入睡眠会禁用渲染，这个设置指示Starling是否 要解决这个问题。注意这项功能会消耗大量内存！建议在Android和Windows下启动，在Mac OS X和iOS中禁用。

The default value is false.

Implementation
    public static function get handleLostContext():Boolean
    public static function set handleLostContext(value:Boolean):void
isStarted property
isStarted:Boolean [read-only]

Starling 实例是否启动.

Implementation
    public function get isStarted():Boolean
juggler property
juggler:Juggler [read-only]

这个实例上的默认juggler对象. 这个对象将会在每一帧被调用.

Implementation
    public function get juggler():Juggler
multitouchEnabled property
multitouchEnabled:Boolean

是否支持多点触摸.

Implementation
    public static function get multitouchEnabled():Boolean
    public static function set multitouchEnabled(value:Boolean):void
nativeOverlay property
nativeOverlay:Sprite [read-only]

在Starling 上面的原生Flash Sprite.使用它显示Flash原生组件

Implementation
    public function get nativeOverlay():Sprite
nativeStage property
nativeStage:Stage [read-only]

Flash (2D) 舞台对象,Starling 在其下渲染.

Implementation
    public function get nativeStage():Stage
profile property
profile:String [read-only]

在构造方法中传入的Context3D渲染方式. 注意这可能是不准确的，因为有可能是共享的上下文.

Implementation
    public function get profile():String
root property
root:DisplayObject [read-only]

构造中提供的根类的实例.'ROOT_CREATED'事件派发后可以使用.

Implementation
    public function get root():DisplayObject
shareContext property
shareContext:Boolean

Context3D 渲染调用是否可以被Starling外部使用 , 是否可以让其它框架共享Stage3D对象

Implementation
    public function get shareContext():Boolean
    public function set shareContext(value:Boolean):void
showStats property
showStats:Boolean

是否显示数据统计 (FPS, 内存占用 和面数)。

Implementation
    public function get showStats():Boolean
    public function set showStats(value:Boolean):void
simulateMultitouch property
simulateMultitouch:Boolean

多点触摸模拟 "Shift" 和 "Ctrl"/"Cmd"-是否启用.

The default value is false.

Implementation
    public function get simulateMultitouch():Boolean
    public function set simulateMultitouch(value:Boolean):void
stage property
stage:Stage [read-only]

Starling 舞台对象, 是显示列表的根.

Implementation
    public function get stage():Stage
stage3D property
stage3D:Stage3D [read-only]

Starling的渲染目标Flash Stage3D 对象

Implementation
    public function get stage3D():Stage3D
viewPort property
viewPort:Rectangle

Starling 内容渲染的区域.

Implementation
    public function get viewPort():Rectangle
    public function set viewPort(value:Rectangle):void
Constructor Detail
Starling () Constructor
public function Starling(rootClass:Class, stage:Stage, viewPort:Rectangle = null, stage3D:Stage3D = null, renderMode:String = auto, profile:String = baselineConstrained)

创建一个新的Starling实例.

Parameters
rootClass:Class — Starling显示对象的子类。它将会在Starling 初始化完成后创建成为Starling舞台的第一个子对象
stage:Stage — Flash (2D) 舞台.
viewPort:Rectangle (default = null) — 一个显示内容的矩形区域.
stage3D:Stage3D (default = null) — 渲染内容的stage3D对象. 如果已经包含了 context, sharedContext将会被设置为 true.
renderMode:String (default = auto) — 用这个参数设置软件加速.
profile:String (default = baselineConstrained) — 要请求的 Context3DProfile 类型.
Method Detail
advanceTime () method
public function advanceTime(passedTime:Number):void

在显示列表上派发ENTER_FRAME事件, 优化 Juggler 和 处理 触摸事件.

Parameters

passedTime:Number

deleteProgram () method
public function deleteProgram(name:String):void

根据指定的名称，删除一个顶点着色程序和片段着色程序.

Parameters

name:String

dispose () method
public function dispose():void

销毁stage的所有子级和渲染上下文，删除所有的事件侦听器

getProgram () method
public function getProgram(name:String):Program3D

根据指定的名称，返回一个已注册的顶点着色程序和片段着色程序.

Parameters

name:String

Returns
Program3D
hasProgram () method
public function hasProgram(name:String):Boolean

根据指定的名称，判断这个顶点着色程序和片段着色程序是否被注册.

Parameters

name:String

Returns
Boolean
makeCurrent () method
public function makeCurrent():void

让Starling实例成为 current 实例.

nextFrame () method
public function nextFrame():void

调用 advanceTime() (上一帧到现在的渲染时间) 和 render().

registerProgram () method
public function registerProgram(name:String, vertexProgram:ByteArray, fragmentProgram:ByteArray):void

根据一个指定的名称注册一个顶点和片段着色器程序。如果这个名称已经被使用了，那么上一个使用这个名称的程序将会被覆盖。

Parameters

name:String — 名称
vertexProgram:ByteArray — 顶点着色程序
fragmentProgram:ByteArray — 片段着色程序

render () method
public function render():void

渲染整个显示列表. 在渲染之前, context会被清除; 在这之后, 才进行显示. 启用shareContext可以禁用这项功能.

showStatsAt () method
public function showStatsAt(hAlign:String = left, vAlign:String = top, scale:Number = 1):void

数据统计显示位置. 默认是左上角.

Parameters

hAlign:String (default = left)
vAlign:String (default = top)
scale:Number (default = 1)

start () method
public function start():void

Starling启动后，它会对输入事件排队处理 (keyboard/mouse/touch); 另外, nextFrame方法 会在Flash Player中每一帧调用。 (如果 shareContext启用: 在这种情况, 你必须手动 调用这个方法.)

stop () method
public function stop():void

停止所有的逻辑处理，并冻结游戏的当前状态。但实际上每一帧仍然在渲染内容（只是看起来不更新了），因为如果不这样做的话，传统显示列表就无法更新。

Event Detail
context3DCreate Event
Event Object Type: starling.events.Event

新的渲染环境创建后派发事件.

rootCreated Event
Event Object Type: starling.events.Event

根类创建后派发事件.

Constant Detail
VERSION Constant
public static const VERSION:String = 1.3

Starling framework的版本.


starling.display - Starling API 1.3 | Starling中文站

Package starling.display

Classes
BlendMode
Button
DisplayObject
DisplayObjectContainer
Image
MovieClip
Quad
QuadBatch
Sprite
Stage


starling.display Summary

starling.display | Classes

Classes
Class | Description
BlendMode | BlendMode类提供了混合模式视觉效果的常量。 一个混合模式，总是由两个'Context3DBlendFactor'值来定义。一个混合因素代表一个特定的四个数值的数组。 这个数组是根据源颜色和目标颜色用混合公式计算的，公式如下： result = source × sourceFactor + destination × destinationFactor 在这个公式里，源颜色是像素着色器的输出颜色，目标颜色是在上一次清除和绘制操作以后，颜色缓冲区中当前存在的颜色。 要注意的是，由于纹理类型的不同，混合因素产生产生的输出也不同。 纹理可能包含'预乘透明度'(pma)，意思就是它们的RGB色值是根据它们的颜色值分别相乘得到的（目的是节省计算时间）。 基于'BitmapData'的纹理，会含有预乘透明度值，ATF纹理没有这个值。 因此，一个混合模式可能会根据pma的值而拥有不同的混合因素。
Button | 一个简单的按钮由一张图片和一个可选的文本组成。 你可以分别为按钮构造函数传递up和down两种状态的纹理。 如果你没有指定一个down状态的纹理，按钮会采用默认的办法：被触碰的时候缩小一点。 此外，你可以在按钮上覆盖一个文本，要自定义这个文本，只需要提供和原来的基本相同的文本框即可。 你可以使用textBounds属性，将文本移动到一个指定的位置。 判断按钮是否被触碰，请使用triggered事件类型， 用这个事件来代替普通的触碰事件。也就是说，用户只要在松开手指或者鼠标之前，移动手指/鼠标离开按钮区域，就可以取消对该按钮的点击操作。
DisplayObject | DisplayObject 类是所有可放在显示列表中，在屏幕上可以被渲染的对象的基类。 显示列表树 在Starling中，所有可显示对象都处于显示列表树中，只有属于显示列表树的成员才可以在屏幕上显示和渲染。 显示列表树由可以直接渲染到屏幕的叶子节点（Image, Quad）和容器节点（DisplayObjectContainer的子类，比如 Sprite）组成。 容器是一个包含子节点（子节点可以是叶子节点或者其他容器）的显示对象。 Stage处于显示列表树的顶级节点，同样也是一个容器。 要创建一个Starling应用，你需要创建一个自定义的Sprite的子类，Starling会添加一个该子类的实例对象到stage上。 一个显示对象有定义它自身相对于它的父级的位置的属性（x，y），有旋转和缩放参数（scaleX，scaleY）， 可以使用alpha 和 visible属性分别控制显示对象的透明度和可见性。 每个显示对象都有可能是触碰事件的目标，你可以设置"touchable"属性来禁止对象被触碰。 当它被设置为禁止触碰，对象本身和它的子对象都不会再响应触碰事件。 坐标转换 在显示坐标树里，每个对象都有自己的局部坐标系统，如果你旋转一个容器，意味着你旋转了整个容器的坐标 系统，并且影响到了容器的所有子对象。 有时候你需要知道某个点相对于其他坐标系的坐标，getTransformationMatrix函数实现了这个功能。 它将创建一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 子类 由于DisplayObject是抽象类,所以你不能直接实例化它，只能用某个它的子类。目前已经有很多这样的子类了， 大部分情况下它们应该能够满足你的需要了。 然而，你也可以自定义你自己的子类，要实现自定义的子类，你需要实现自定义的渲染方法，在你自定义的子类中 需要实现下面的方法： function render(support:RenderSupport, parentAlpha:Number):void function getBounds(targetSpace:DisplayObject, resultRect:Rectangle=null):Rectangle 请参阅Quad类，它对于"getBounds"方法有一个简单的实现。 一个简单的例子阐述如何创建自定义的渲染方法，你可以参考这个在Starling Wiki上的自定义显示对象 当你重载render方法时，请注意调用辅助对象(一个RenderSupport对象)的'finishQuadBatch'方法。 这将促使Starling使用不同的渲染方法来渲染之前累计的所有四边形（鉴于性能考虑），否则，z-ordering将会出错。
DisplayObjectContainer | 一个显示对象容器是一个包含了各种显示对象的集合。 这是所有容器类（包含其他显示对象的容器）的基类。它拥有一个有序列表来管理子级对象，并在显示对象树立定义了 所有子级的显示顺序。 一个容器本身是没有尺寸的，它的宽度和高度代表了子级的范围，改变这些属性会缩放它的所有子级。 由于DisplayObjectContainer是一个抽象类，你不能直接实例化它，而是应该使用它的子类。 其中最轻量级的容器子类是"Sprite"。 添加和删除子级 这个类包含了一些允许你添加和删除子级的方法。 当你添加一个子级，它会被添加到列表的最顶层，有可能会遮挡住前一个添加的子级。 你可以通过索引访问子级，第一个子级索引为0，第二个子级索引为1，以此类推。 向容器添加或者删对象会派发一些不冒泡的事件。 Event.ADDED: 对象被添加到了它的父级。 Event.ADDED_TO_STAGE: 对象被添加到了它的父级，并且父级已经被添加 到stage上，因此对象立即显示。 Event.REMOVED: 从对象的父级删除该对象。 Event.REMOVED_FROM_STAGE: 从对象的父级删除该对象，并且父级已经被添加 到stage上，因此对象立即不显示。 尤其是ADDED_TO_STAGE事件是非常有用的，因为它可以让你在一个对象第一次被渲染时自动执行一些逻辑（比如开始播放一段动画）。
Image | 一个图片是一个映射了纹理的四边形。 Image类相当于Flash的Bitmap类的Starling版本，不过Starling是用纹理来代替BitmapData来提供图像的像素资源。 要显示一个纹理，你需要把它映射到一个四边形上--这就是Image类的功能。 因为"Image"是继承自"Quad",所以你可以给它设置颜色。 每个像素的颜色是根据纹理的颜色和四边形的颜色相乘得来的，这样，你就可以很容易的根据一个颜色改变纹理的色调。 此外，Image允许你对纹理坐标进行操作，你可以在不改变四边形任何顶点坐标的情况下，在图片的内部移动纹理。 你还可以使用这种功能以一个非常高效的方式创建一个矩形遮罩。
MovieClip | 一个影片剪辑(MovieClip)根据一个纹理集合来显示动画。 传入包含纹理的集合给MovieClip的构造函数作为影片剪辑的帧。影片剪辑会根据第一帧的纹理来确定影片的宽度和高度。 如果你使用纹理图集TextureAtlas（推荐使用此方法）来组织你的帧，请使用纹理图集的getTextures方法 获取正确(按字母次序的)的纹理顺序。 你可以在构造函数中指定一个特定的帧频，如果需要，你还可以设置每一帧的执行时间，或者在某一帧执行时播放一个声音。 play 和 pause 方法可以控制影片的播放，当影片播放完毕时，你会接收到一个Event.MovieCompleted 事件。如果影片是循环播放的，这个事件会在每一次循环都派发。 同其他动画对象一样，一个影片剪辑必须添加到一个juggler（或者是一个拥有自己的定时执行的advanceTime方法的对象）里来运行。 当影片剪辑播放完最后一帧时，会派发"Event.COMPLETE"事件。
Quad | 一个四边形代表了由单一颜色或者渐变颜色填充的矩形。 你可以设置每一个顶点的颜色。不同顶点的颜色会在颜色交汇的地方平滑的过度。 要让四边形显示一个线性的渐变颜色，需要给顶点0,1设置一个颜色，然后给顶点2,3设置另一个颜色。 四边形的四个顶点的位置是这样排列的: 0 - 1 | / | 2 - 3
QuadBatch | QuadBatch类用于优化渲染大量具备相同状态的四边形(Quad类).
Sprite | Sprite是一个极其轻量，非抽象的容器类。 通常把Sprite作为一种把一组显示对象集中到一个坐标系内的简单手段，也可以把它用做自定义显示对象的基类。 "平面化" Sprite对象 flatten方法允许你在渲染时优化显示列表中的静态部分。 flatten 分析了添加到这个Sprite的显示列表的子对象，优化了渲染调用，极大的提高了渲染速度。 但是速度的大幅提升是要付出代价的：你将再也看不见子对象属性的任何变化（位置，旋转，透明等等）。 要更新这个sprite对象的显示，只需再一次调用flatten，或者unflatten这个对象。
Stage | Stage是显示列表树的根节点，只有直接或者间接放置到stage上的显示对象才会被渲染。 这个类相当于Starling版本的Stage，注意不要和传统的Flash里的Stage混淆。 传统的Flash里的Stage只能包含类型为flash.display.DisplayObject的对象， 而Starling里的Stage只能包含类型为starling.display.DisplayObject的对象， 由于Starling显示列表并不等同于传统Flash显示列表，所以这些类并不兼容，不能混用，也不能互相代替。 stage对象是被Starling类自动创建的，请不要手动创建一个stage对象。 键盘事件 在Starling中，键盘事件只能够在stage派发，所以，如果想捕获到派发的键盘事件，只能给stage添加键盘事件监听。 尺寸变化事件 当Flash player 尺寸变化时，stage会派发一个ResizeEvent事件。 这个事件的属性包含更新后的Flash player的宽度和高度。


starling.display.BlendMode

BlendMode | Methods | Constants
Package | starling.display
Class | public class BlendMode
Inheritance | BlendMode Inheritance Object

BlendMode类提供了混合模式视觉效果的常量。

一个混合模式，总是由两个'Context3DBlendFactor'值来定义。一个混合因素代表一个特定的四个数值的数组。 这个数组是根据源颜色和目标颜色用混合公式计算的，公式如下：

result = source × sourceFactor + destination × destinationFactor

在这个公式里，源颜色是像素着色器的输出颜色，目标颜色是在上一次清除和绘制操作以后，颜色缓冲区中当前存在的颜色。

要注意的是，由于纹理类型的不同，混合因素产生产生的输出也不同。 纹理可能包含'预乘透明度'(pma)，意思就是它们的RGB色值是根据它们的颜色值分别相乘得到的（目的是节省计算时间）。 基于'BitmapData'的纹理，会含有预乘透明度值，ATF纹理没有这个值。 因此，一个混合模式可能会根据pma的值而拥有不同的混合因素。

See also

flash.display3D.Context3DBlendFactor

Public Methods
Method |  | Defined By
 | getBlendFactors(mode:String, premultipliedAlpha:Boolean = true):Array [static] 根据指定的模式名称和预乘透明度返回混合因素。 如果模式不存在，会抛出一个参数错误。 | BlendMode
 | register(name:String, sourceFactor:String, destFactor:String, premultipliedAlpha:Boolean = true):void [static] 根据指定的名称和预乘透明度（pma）值注册一个混合模式。 如果一个用其他pma值的模式尚未注册，则两个pma的设置都会应用这些因素。 | BlendMode
Public Constants
Constant |  | Defined By
 | ADD : String = add [static] 将显示对象的颜色值添加到背景的颜色里。 | BlendMode
 | AUTO : String = auto [static] 继承这个显示对象的父级的混合模式。 | BlendMode
 | ERASE : String = erase [static] 当绘制渲染纹理的时候擦除背景。 | BlendMode
 | MULTIPLY : String = multiply [static] 将显示对象的颜色值与背景的颜色相乘。 | BlendMode
 | NONE : String = none [static] 停用混合，即禁止任何透明度。 | BlendMode
 | NORMAL : String = normal [static] 显示对象显示在背景的前面。 | BlendMode
 | SCREEN : String = screen [static] 将显示对象颜色的补码（反码）与背景颜色的补码相乘，产生漂白效果。 | BlendMode
Method Detail
getBlendFactors () method
public static function getBlendFactors(mode:String, premultipliedAlpha:Boolean = true):Array

根据指定的模式名称和预乘透明度返回混合因素。 如果模式不存在，会抛出一个参数错误。

Parameters

mode:String — 模式
premultipliedAlpha:Boolean (default = true) — 预乘透明度

Returns
Array — Array

Throws
ArgumentError
register () method
public static function register(name:String, sourceFactor:String, destFactor:String, premultipliedAlpha:Boolean = true):void

根据指定的名称和预乘透明度（pma）值注册一个混合模式。 如果一个用其他pma值的模式尚未注册，则两个pma的设置都会应用这些因素。

Parameters

name:String — 名称
sourceFactor:String — 源因素
destFactor:String — 目标因素
premultipliedAlpha:Boolean (default = true) — 是否预乘透明度

Constant Detail
ADD Constant
public static const ADD:String = add

将显示对象的颜色值添加到背景的颜色里。

AUTO Constant
public static const AUTO:String = auto

继承这个显示对象的父级的混合模式。

ERASE Constant
public static const ERASE:String = erase

当绘制渲染纹理的时候擦除背景。

MULTIPLY Constant
public static const MULTIPLY:String = multiply

将显示对象的颜色值与背景的颜色相乘。

NONE Constant
public static const NONE:String = none

停用混合，即禁止任何透明度。

NORMAL Constant
public static const NORMAL:String = normal

显示对象显示在背景的前面。

SCREEN Constant
public static const SCREEN:String = screen

将显示对象颜色的补码（反码）与背景颜色的补码相乘，产生漂白效果。


starling.display.Button

Button | Properties | Methods | Events
Package | starling.display
Class | public class Button
Inheritance | Button Inheritance DisplayObjectContainer Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

一个简单的按钮由一张图片和一个可选的文本组成。

你可以分别为按钮构造函数传递up和down两种状态的纹理。 如果你没有指定一个down状态的纹理，按钮会采用默认的办法：被触碰的时候缩小一点。 此外，你可以在按钮上覆盖一个文本，要自定义这个文本，只需要提供和原来的基本相同的文本框即可。 你可以使用textBounds属性，将文本移动到一个指定的位置。

判断按钮是否被触碰，请使用triggered事件类型， 用这个事件来代替普通的触碰事件。也就是说，用户只要在松开手指或者鼠标之前，移动手指/鼠标离开按钮区域，就可以取消对该按钮的点击操作。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
 | alphaWhenDisabled : Number 当按钮被禁用时的透明度，默认为：0.5。 | Button
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
 | downState : Texture 按钮被触碰时显示的纹理。 | Button
 | enabled : Boolean 按钮是否能够被触碰(即是否禁用)。 | Button
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
 | fontBold : Boolean 文本字体是否加粗。 | Button
 | fontColor : uint 文本字体颜色。 | Button
 | fontName : String 按钮上显示文本的字体名称。 可能是系统字体，或者已注册的位图字体。 | Button
 | fontSize : Number 文本字体大小。 | Button
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
Inherited | numChildren : int [read-only] 容器包含的子级数量。 | DisplayObjectContainer
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
 | scaleWhenDown : Number 当按钮被触碰的时候的缩放参数。 默认情况下，如果按钮含有down状态的纹理，则不会被缩放。 | Button
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | text : String 按钮上的显示文本。 | Button
 | textBounds : Rectangle 按钮上文本框的边界矩形。 允许移动文本到一个自定义的位置。 | Button
 | textHAlign : String 按钮文本的水平对齐方式. | Button
 | textVAlign : String 按钮文本的垂直对齐方式. | Button
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
 | upState : Texture 按钮默认情况下显示的纹理（即没有被触碰的时候）。 | Button
 | useHandCursor : Boolean [override] 当光标移动到按钮上时，是否显示手型光标，默认为：true。 | Button
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Button(upState:Texture, text:String, downState:Texture = null) 创建一个按钮实例，设置它的up和down状态的纹理，以及文本。 | Button
Inherited | addChild(child:DisplayObject):DisplayObject 添加一个显示对象到容器，它将被添加到顶层。 | DisplayObjectContainer
Inherited | addChildAt(child:DisplayObject, index:int):DisplayObject 根据一个索引值添加一个显示对象到容器。 | DisplayObjectContainer
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
Inherited | broadcastEvent(event:Event):void 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。 | DisplayObjectContainer
Inherited | broadcastEventWith(type:String, data:Object = null):void 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。 | DisplayObjectContainer
Inherited | contains(child:DisplayObject):Boolean 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。 | DisplayObjectContainer
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | dispose():void [override] 释放所有子级的资源。 | DisplayObjectContainer
Inherited | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | DisplayObjectContainer
Inherited | getChildAt(index:int):DisplayObject 根据指定的索引返回对应的子级对象。 | DisplayObjectContainer
Inherited | getChildByName(name:String):DisplayObject 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。 | DisplayObjectContainer
Inherited | getChildIndex(child:DisplayObject):int 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。 | DisplayObjectContainer
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject [override] 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObjectContainer
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
Inherited | removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildAt(index:int, dispose:Boolean = false):DisplayObject 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。 | DisplayObjectContainer
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
Inherited | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | DisplayObjectContainer
Inherited | setChildIndex(child:DisplayObject, index:int):void 移动一个子级到指定的索引，在它后面的子级将向后移动。 | DisplayObjectContainer
Inherited | sortChildren(compareFunction:Function):void 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。 | DisplayObjectContainer
Inherited | swapChildren(child1:DisplayObject, child2:DisplayObject):void 互换两个子级的索引。 | DisplayObjectContainer
Inherited | swapChildrenAt(index1:int, index2:int):void 互换两个子级的索引。 | DisplayObjectContainer
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
 | triggered | 当用户点击或者触碰了按钮时进行派发，冒泡事件。 | Button
Property Detail
alphaWhenDisabled property
alphaWhenDisabled:Number

当按钮被禁用时的透明度，默认为：0.5。

Implementation
    public function get alphaWhenDisabled():Number
    public function set alphaWhenDisabled(value:Number):void
downState property
downState:Texture

按钮被触碰时显示的纹理。

Implementation
    public function get downState():Texture
    public function set downState(value:Texture):void
enabled property
enabled:Boolean

按钮是否能够被触碰(即是否禁用)。

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
fontBold property
fontBold:Boolean

文本字体是否加粗。

Implementation
    public function get fontBold():Boolean
    public function set fontBold(value:Boolean):void
fontColor property
fontColor:uint

文本字体颜色。

Implementation
    public function get fontColor():uint
    public function set fontColor(value:uint):void
fontName property
fontName:String

按钮上显示文本的字体名称。 可能是系统字体，或者已注册的位图字体。

Implementation
    public function get fontName():String
    public function set fontName(value:String):void
fontSize property
fontSize:Number

文本字体大小。

Implementation
    public function get fontSize():Number
    public function set fontSize(value:Number):void
scaleWhenDown property
scaleWhenDown:Number

当按钮被触碰的时候的缩放参数。 默认情况下，如果按钮含有down状态的纹理，则不会被缩放。

Implementation
    public function get scaleWhenDown():Number
    public function set scaleWhenDown(value:Number):void
text property
text:String

按钮上的显示文本。

Implementation
    public function get text():String
    public function set text(value:String):void
textBounds property
textBounds:Rectangle

按钮上文本框的边界矩形。 允许移动文本到一个自定义的位置。

Implementation
    public function get textBounds():Rectangle
    public function set textBounds(value:Rectangle):void
textHAlign property
textHAlign:String

按钮文本的水平对齐方式.

Implementation
    public function get textHAlign():String
    public function set textHAlign(value:String):void
textVAlign property
textVAlign:String

按钮文本的垂直对齐方式.

Implementation
    public function get textVAlign():String
    public function set textVAlign(value:String):void
upState property
upState:Texture

按钮默认情况下显示的纹理（即没有被触碰的时候）。

Implementation
    public function get upState():Texture
    public function set upState(value:Texture):void
useHandCursor property
useHandCursor:Boolean[override]

当光标移动到按钮上时，是否显示手型光标，默认为：true。

The default value is true.

Implementation
    public function get useHandCursor():Boolean
    public function set useHandCursor(value:Boolean):void
Constructor Detail
Button () Constructor
public function Button(upState:Texture, text:String, downState:Texture = null)

创建一个按钮实例，设置它的up和down状态的纹理，以及文本。

Parameters
upState:Texture — up状态纹理
text:String — 文本
downState:Texture (default = null) — down状态纹理，默认为:null

Throws
ArgumentError
Event Detail
triggered Event
Event Object Type: starling.events.Event

当用户点击或者触碰了按钮时进行派发，冒泡事件。


starling.display.DisplayObject

DisplayObject | Properties | Methods | Events
Package | starling.display
Class | public class DisplayObject
Inheritance | DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | DisplayObjectContainer, Quad, QuadBatch

DisplayObject 类是所有可放在显示列表中，在屏幕上可以被渲染的对象的基类。

显示列表树

在Starling中，所有可显示对象都处于显示列表树中，只有属于显示列表树的成员才可以在屏幕上显示和渲染。

显示列表树由可以直接渲染到屏幕的叶子节点（Image, Quad）和容器节点（DisplayObjectContainer的子类，比如 Sprite）组成。 容器是一个包含子节点（子节点可以是叶子节点或者其他容器）的显示对象。

Stage处于显示列表树的顶级节点，同样也是一个容器。 要创建一个Starling应用，你需要创建一个自定义的Sprite的子类，Starling会添加一个该子类的实例对象到stage上。

一个显示对象有定义它自身相对于它的父级的位置的属性（x，y），有旋转和缩放参数（scaleX，scaleY）， 可以使用alpha 和 visible属性分别控制显示对象的透明度和可见性。

每个显示对象都有可能是触碰事件的目标，你可以设置"touchable"属性来禁止对象被触碰。 当它被设置为禁止触碰，对象本身和它的子对象都不会再响应触碰事件。

坐标转换

在显示坐标树里，每个对象都有自己的局部坐标系统，如果你旋转一个容器，意味着你旋转了整个容器的坐标 系统，并且影响到了容器的所有子对象。

有时候你需要知道某个点相对于其他坐标系的坐标，getTransformationMatrix函数实现了这个功能。 它将创建一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。

子类

由于DisplayObject是抽象类,所以你不能直接实例化它，只能用某个它的子类。目前已经有很多这样的子类了， 大部分情况下它们应该能够满足你的需要了。

然而，你也可以自定义你自己的子类，要实现自定义的子类，你需要实现自定义的渲染方法，在你自定义的子类中 需要实现下面的方法：

  • function render(support:RenderSupport, parentAlpha:Number):void
  • function getBounds(targetSpace:DisplayObject, resultRect:Rectangle=null):Rectangle

请参阅Quad类，它对于"getBounds"方法有一个简单的实现。 一个简单的例子阐述如何创建自定义的渲染方法，你可以参考这个在Starling Wiki上的自定义显示对象

当你重载render方法时，请注意调用辅助对象(一个RenderSupport对象)的'finishQuadBatch'方法。 这将促使Starling使用不同的渲染方法来渲染之前累计的所有四边形（鉴于性能考虑），否则，z-ordering将会出错。

See also

DisplayObjectContainer
Sprite
Stage

Public Properties
Property |  | Defined By
 | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
 | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
 | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
 | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
 | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
 | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
 | height : Number 显示对象的高度。 | DisplayObject
 | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
 | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
 | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
 | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
 | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
 | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
 | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
 | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
 | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
 | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
 | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
 | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
 | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
 | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
 | width : Number 显示对象的宽度。 | DisplayObject
 | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
 | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | dispose():void 销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。 | DisplayObject
 | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | DisplayObject
 | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
 | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObject
 | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
 | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | DisplayObject
Events
Event |  | Summary | Defined By
 | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
 | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
 | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
 | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
 | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
 | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
alpha property
alpha:Number

显示对象的不透明度。 0 = 透明, 1 = 不透明。

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
base property
base:DisplayObject [read-only]

包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。

Implementation
    public function get base():DisplayObject
blendMode property
blendMode:String

混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。

The default value is auto.

Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void

See also

starling.display.BlendMode
bounds property
bounds:Rectangle [read-only]

返回显示对象相对于父级对象坐标系的矩形区域。

Implementation
    public function get bounds():Rectangle
filter property
filter:FragmentFilter

添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。

Implementation
    public function get filter():FragmentFilter
    public function set filter(value:FragmentFilter):void
hasVisibleArea property
hasVisibleArea:Boolean [read-only]

判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false)

Implementation
    public function get hasVisibleArea():Boolean
height property
height:Number

显示对象的高度。

Implementation
    public function get height():Number
    public function set height(value:Number):void
name property
name:String

显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。

Implementation
    public function get name():String
    public function set name(value:String):void
parent property
parent:DisplayObjectContainer [read-only]

包含该显示对象的显示对象容器。

Implementation
    public function get parent():DisplayObjectContainer
pivotX property
pivotX:Number

显示对象在自己的坐标系的起始x坐标（默认：0）

Implementation
    public function get pivotX():Number
    public function set pivotX(value:Number):void
pivotY property
pivotY:Number

显示对象在自己的坐标系的起始y坐标（默认：0）

Implementation
    public function get pivotY():Number
    public function set pivotY(value:Number):void
root property
root:DisplayObject [read-only]

包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。

Implementation
    public function get root():DisplayObject
rotation property
rotation:Number

显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的)

Implementation
    public function get rotation():Number
    public function set rotation(value:Number):void
scaleX property
scaleX:Number

显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number

显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
skewX property
skewX:Number

显示对象水平方向的倾斜弧度。

Implementation
    public function get skewX():Number
    public function set skewX(value:Number):void
skewY property
skewY:Number

显示对象垂直方向的倾斜弧度。

Implementation
    public function get skewY():Number
    public function set skewY(value:Number):void
stage property
stage:Stage [read-only]

与该显示对象关联的stage对象，如果还没有被添加到stage则为空。

Implementation
    public function get stage():Stage
touchable property
touchable:Boolean

是否禁止该对象和它的子对象响应触碰事件。

Implementation
    public function get touchable():Boolean
    public function set touchable(value:Boolean):void
transformationMatrix property
transformationMatrix:Matrix

返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。

Implementation
    public function get transformationMatrix():Matrix
    public function set transformationMatrix(value:Matrix):void
useHandCursor property
useHandCursor:Boolean

一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。

The default value is false.

Implementation
    public function get useHandCursor():Boolean
    public function set useHandCursor(value:Boolean):void
visible property
visible:Boolean

显示对象是否可见。不可见的显示对象不能够被触碰。

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
width property
width:Number

显示对象的宽度。

Implementation
    public function get width():Number
    public function set width(value:Number):void
x property
x:Number

显示对象相对于父级对象的局部坐标系的x坐标。

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number

显示对象相对于父级对象的局部坐标系的y坐标。

Implementation
    public function get y():Number
    public function set y(value:Number):void
Method Detail
dispose () method
public function dispose():void

销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。

getBounds () method
public function getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle

返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultRect:Rectangle (default = null) — 如果传入一个resultRect参数, 计算的结果将保存在这个矩形里，而不是重新创建一个Rectangle对象。

Returns
Rectangle — Rectangle

Throws
AbstractMethodError
getTransformationMatrix () method
public function getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix

返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultMatrix:Matrix (default = null) — 如果传入一个resultMatrix, 计算的结果将保存在这个矩阵里，而不是重新创建一个Matrix对象。

Returns
Matrix — Matrix

Throws
ArgumentError —
globalToLocal () method
public function globalToLocal(globalPoint:Point, resultPoint:Point = null):Point

将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。

Parameters

globalPoint:Point — 需要转换成局部坐标的全局坐标点。
resultPoint:Point (default = null) — 如果传入一个resultPoint, 计算的结果将保存在这个点里，而不是重新创建一个Point对象。

Returns
Point — Point
hitTest () method
public function hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject

返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。

Parameters

localPoint:Point — 局部坐标系的某点
forTouch:Boolean (default = false) — 是否只检测能够触碰到的对象。如果为ture，检测会忽略掉不可见和不可触碰的对象。

Returns
DisplayObject — DisplayObject
localToGlobal () method
public function localToGlobal(localPoint:Point, resultPoint:Point = null):Point

将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。

Parameters

localPoint:Point — 需要转换成全局坐标的局部坐标点。
resultPoint:Point (default = null) — 如果传入一个resultPoint, 计算的结果将保存在这个点里，而不是重新创建一个Point对象。

Returns
Point — Point
removeFromParent () method
public function removeFromParent(dispose:Boolean = false):void

如果对象已经添加进显示列表，则从父容器中删除此对象。

Parameters

dispose:Boolean (default = false) — 值为true时清除掉此对象的所有资源，值为false时不清除。

render () method
public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

Event Detail
added Event
Event Object Type: starling.events.Event

当一个显示对象被添加到父级的时候派发。

addedToStage Event
Event Object Type: starling.events.Event

当一个显示对象被添加到stage(直接的或者间接的)的时候派发。

enterFrame Event
Event Object Type: starling.events.EnterFrameEvent

在每一帧派发给stage上的所有显示对象。

removed Event
Event Object Type: starling.events.Event

当一个显示对象从父级删除的时候派发。

removedFromStage Event
Event Object Type: starling.events.Event

当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。

touch Event
Event Object Type: starling.events.TouchEvent

当显示对象被触碰时派发，冒泡事件。


starling.display.DisplayObjectContainer

DisplayObjectContainer | Properties | Methods | Events
Package | starling.display
Class | public class DisplayObjectContainer
Inheritance | DisplayObjectContainer Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Button, Sprite, Stage, TextField

一个显示对象容器是一个包含了各种显示对象的集合。 这是所有容器类（包含其他显示对象的容器）的基类。它拥有一个有序列表来管理子级对象，并在显示对象树立定义了 所有子级的显示顺序。

一个容器本身是没有尺寸的，它的宽度和高度代表了子级的范围，改变这些属性会缩放它的所有子级。

由于DisplayObjectContainer是一个抽象类，你不能直接实例化它，而是应该使用它的子类。 其中最轻量级的容器子类是"Sprite"。

添加和删除子级

这个类包含了一些允许你添加和删除子级的方法。 当你添加一个子级，它会被添加到列表的最顶层，有可能会遮挡住前一个添加的子级。 你可以通过索引访问子级，第一个子级索引为0，第二个子级索引为1，以此类推。

向容器添加或者删对象会派发一些不冒泡的事件。
  • Event.ADDED: 对象被添加到了它的父级。
  • Event.ADDED_TO_STAGE: 对象被添加到了它的父级，并且父级已经被添加 到stage上，因此对象立即显示。
  • Event.REMOVED: 从对象的父级删除该对象。
  • Event.REMOVED_FROM_STAGE: 从对象的父级删除该对象，并且父级已经被添加 到stage上，因此对象立即不显示。
尤其是ADDED_TO_STAGE事件是非常有用的，因为它可以让你在一个对象第一次被渲染时自动执行一些逻辑（比如开始播放一段动画）。

See also

Sprite
DisplayObject

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
 | numChildren : int [read-only] 容器包含的子级数量。 | DisplayObjectContainer
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | addChild(child:DisplayObject):DisplayObject 添加一个显示对象到容器，它将被添加到顶层。 | DisplayObjectContainer
 | addChildAt(child:DisplayObject, index:int):DisplayObject 根据一个索引值添加一个显示对象到容器。 | DisplayObjectContainer
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | broadcastEvent(event:Event):void 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。 | DisplayObjectContainer
 | broadcastEventWith(type:String, data:Object = null):void 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。 | DisplayObjectContainer
 | contains(child:DisplayObject):Boolean 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。 | DisplayObjectContainer
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | dispose():void [override] 释放所有子级的资源。 | DisplayObjectContainer
 | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | DisplayObjectContainer
 | getChildAt(index:int):DisplayObject 根据指定的索引返回对应的子级对象。 | DisplayObjectContainer
 | getChildByName(name:String):DisplayObject 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。 | DisplayObjectContainer
 | getChildIndex(child:DisplayObject):int 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。 | DisplayObjectContainer
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject [override] 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObjectContainer
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
 | removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。 | DisplayObjectContainer
 | removeChildAt(index:int, dispose:Boolean = false):DisplayObject 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。 | DisplayObjectContainer
 | removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。 | DisplayObjectContainer
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | DisplayObjectContainer
 | setChildIndex(child:DisplayObject, index:int):void 移动一个子级到指定的索引，在它后面的子级将向后移动。 | DisplayObjectContainer
 | sortChildren(compareFunction:Function):void 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。 | DisplayObjectContainer
 | swapChildren(child1:DisplayObject, child2:DisplayObject):void 互换两个子级的索引。 | DisplayObjectContainer
 | swapChildrenAt(index1:int, index2:int):void 互换两个子级的索引。 | DisplayObjectContainer
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
numChildren property
numChildren:int [read-only]

容器包含的子级数量。

Implementation
    public function get numChildren():int
Method Detail
addChild () method
public function addChild(child:DisplayObject):DisplayObject

添加一个显示对象到容器，它将被添加到顶层。

Parameters

child:DisplayObject — 子级显示对象

Returns
DisplayObject — DisplayObject
addChildAt () method
public function addChildAt(child:DisplayObject, index:int):DisplayObject

根据一个索引值添加一个显示对象到容器。

Parameters

child:DisplayObject — 子级显示对象
index:int — 索引

Returns
DisplayObject — DisplayObject

Throws
RangeError
broadcastEvent () method
public function broadcastEvent(event:Event):void

通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。

Parameters

event:Event — 事件

Throws
ArgumentError
broadcastEventWith () method
public function broadcastEventWith(type:String, data:Object = null):void

通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。

Parameters

type:String — 事件类型
data:Object (default = null) — 事件传递的数据

contains () method
public function contains(child:DisplayObject):Boolean

通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。

Parameters

child:DisplayObject — 子级显示对象

Returns
Boolean — Boolean
dispose () method
override public function dispose():void

释放所有子级的资源。

getBounds () method
override public function getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle

返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultRect:Rectangle (default = null) — 如果传入一个resultRect参数, 计算的结果将保存在这个矩形里，而不是重新创建一个Rectangle对象。

Returns
Rectangle — Rectangle
getChildAt () method
public function getChildAt(index:int):DisplayObject

根据指定的索引返回对应的子级对象。

Parameters

index:int — 索引

Returns
DisplayObject — DisplayObject

Throws
RangeError 抛出无效索引的错误。
getChildByName () method
public function getChildByName(name:String):DisplayObject

根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。

Parameters

name:String — 名称

Returns
DisplayObject — DisplayObject
getChildIndex () method
public function getChildIndex(child:DisplayObject):int

获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。

Parameters

child:DisplayObject — 子级显示对象

Returns
int — 索引
hitTest () method
override public function hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject

返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。

Parameters

localPoint:Point — 局部坐标系的某点
forTouch:Boolean (default = false) — 是否只检测能够触碰到的对象。如果为ture，检测会忽略掉不可见和不可触碰的对象。

Returns
DisplayObject — DisplayObject
removeChild () method
public function removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject

从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。

Parameters

child:DisplayObject — 子级显示对象
dispose:Boolean (default = false) — 是否释放子级对象的资源

Returns
DisplayObject — DisplayObject
removeChildAt () method
public function removeChildAt(index:int, dispose:Boolean = false):DisplayObject

根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。

Parameters

index:int — 索引
dispose:Boolean (default = false) — 是否释放子级对象的资源

Returns
DisplayObject — DisplayObject

Throws
RangeError 抛出无效索引的错误。
removeChildren () method
public function removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void

根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。

Parameters

beginIndex:int (default = 0) — 起始索引
endIndex:int (default = -1) — 结束索引
dispose:Boolean (default = false) — 是否释放子级对象的资源

render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

setChildIndex () method
public function setChildIndex(child:DisplayObject, index:int):void

移动一个子级到指定的索引，在它后面的子级将向后移动。

Parameters

child:DisplayObject — 子级显示对象
index:int — 索引

Throws
ArgumentError
sortChildren () method
public function sortChildren(compareFunction:Function):void

根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。

Parameters

compareFunction:Function — 排序方法

swapChildren () method
public function swapChildren(child1:DisplayObject, child2:DisplayObject):void

互换两个子级的索引。

Parameters

child1:DisplayObject — 子级显示对象1
child2:DisplayObject — 子级显示对象2

Throws
ArgumentError
swapChildrenAt () method
public function swapChildrenAt(index1:int, index2:int):void

互换两个子级的索引。

Parameters

index1:int — 索引1
index2:int — 索引2


starling.display.Image

Image | Properties | Methods | Events
Package | starling.display
Class | public class Image
Inheritance | Image Inheritance Quad Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | MovieClip

一个图片是一个映射了纹理的四边形。

Image类相当于Flash的Bitmap类的Starling版本，不过Starling是用纹理来代替BitmapData来提供图像的像素资源。 要显示一个纹理，你需要把它映射到一个四边形上--这就是Image类的功能。

因为"Image"是继承自"Quad",所以你可以给它设置颜色。 每个像素的颜色是根据纹理的颜色和四边形的颜色相乘得来的，这样，你就可以很容易的根据一个颜色改变纹理的色调。 此外，Image允许你对纹理坐标进行操作，你可以在不改变四边形任何顶点坐标的情况下，在图片的内部移动纹理。 你还可以使用这种功能以一个非常高效的方式创建一个矩形遮罩。

See also

starling.textures.Texture
Quad

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number [override] 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | Quad
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
Inherited | color : uint 返回四边形的颜色，如果四边形存在多个颜色，返回第一个顶点的颜色。 | Quad
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
 | smoothing : String 用于纹理的平滑过滤方式，默认值为：bilinear。 | Image
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | texture : Texture 映射到四边形的纹理对象。 | Image
Inherited | tinted : Boolean [read-only] 一个布尔值，如果四边形（或者它的任意顶点）是非白色或者是透明的，返回true，否则返回 false。 | Quad
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | mVertexData : VertexData 四边形的原始顶点数据。 | Quad
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Image(texture:Texture) 创建一个具有纹理映射的四边形。 | Image
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | copyVertexDataTo(targetData:VertexData, targetVertexID:int = 0):void [override] 复制源顶点数据到一个VertexData实例。 纹理坐标已经存在于渲染所需的格式中。 | Image
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | dispose():void 销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。 | DisplayObject
 | fromBitmap(bitmap:Bitmap, generateMipMaps:Boolean = true, scale:Number = 1):Image [static] 根据传入的位图对象创建一个包含纹理的Image。 | Image
Inherited | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | Quad
 | getTexCoords(vertexID:int, resultPoint:Point = null):Point 获取一个顶点的纹理坐标，坐标范围：[0,1]。 | Image
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | getVertexAlpha(vertexID:int):Number 返回指定索引的顶点的透明度。 | Quad
Inherited | getVertexColor(vertexID:int):uint 返回指定索引的顶点的颜色。 | Quad
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObject
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
 | readjustSize():void 根据图像当前的纹理调整图像的尺寸，在为图片设置了另外一个不同的纹理以后，需要调用这个方法来同步图像和纹理的尺寸。 | Image
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | Image
 | setTexCoords(vertexID:int, coords:Point):void 设置一个顶点的纹理坐标，坐标范围：[0,1]。 | Image
Inherited | setVertexAlpha(vertexID:int, alpha:Number):void 设置指定索引的顶点的透明度。 | Quad
Inherited | setVertexColor(vertexID:int, color:uint):void 设置指定索引的顶点的颜色。 | Quad
Protected Methods
Method |  | Defined By
 | onVertexDataChanged():void [override] 在手动改变'mVertexData'的内容后调用此方法。 | Image
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
smoothing property
smoothing:String

用于纹理的平滑过滤方式，默认值为：bilinear。

The default value is bilinear.

Implementation
    public function get smoothing():String
    public function set smoothing(value:String):void

See also

starling.textures.TextureSmoothing
texture property
texture:Texture

映射到四边形的纹理对象。

Implementation
    public function get texture():Texture
    public function set texture(value:Texture):void
Constructor Detail
Image () Constructor
public function Image(texture:Texture)

创建一个具有纹理映射的四边形。

Parameters
texture:Texture
Method Detail
copyVertexDataTo () method
override public function copyVertexDataTo(targetData:VertexData, targetVertexID:int = 0):void

复制源顶点数据到一个VertexData实例。 纹理坐标已经存在于渲染所需的格式中。

Parameters

targetData:VertexData — 目标VertexData实例
targetVertexID:int (default = 0) — 目标顶点的ID

fromBitmap () method
public static function fromBitmap(bitmap:Bitmap, generateMipMaps:Boolean = true, scale:Number = 1):Image

根据传入的位图对象创建一个包含纹理的Image。

Parameters

bitmap:Bitmap — 位图对象
generateMipMaps:Boolean (default = true)
scale:Number (default = 1)

Returns
Image — Image
getTexCoords () method
public function getTexCoords(vertexID:int, resultPoint:Point = null):Point

获取一个顶点的纹理坐标，坐标范围：[0,1]。

Parameters

vertexID:int — 顶点的ID
resultPoint:Point (default = null) — 如果传入一个resultPoint, 计算的结果将保存在resultPoint里，而不是重新创建一个Point对象。

Returns
Point — Point
onVertexDataChanged () method
override protected function onVertexDataChanged():void

在手动改变'mVertexData'的内容后调用此方法。

readjustSize () method
public function readjustSize():void

根据图像当前的纹理调整图像的尺寸，在为图片设置了另外一个不同的纹理以后，需要调用这个方法来同步图像和纹理的尺寸。

render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

setTexCoords () method
public function setTexCoords(vertexID:int, coords:Point):void

设置一个顶点的纹理坐标，坐标范围：[0,1]。

Parameters

vertexID:int — 顶点的ID
coords:Point — 坐标


starling.display.MovieClip

MovieClip | Properties | Methods | Events
Package | starling.display
Class | public class MovieClip
Inheritance | MovieClip Inheritance Image Inheritance Quad Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IAnimatable

一个影片剪辑(MovieClip)根据一个纹理集合来显示动画。

传入包含纹理的集合给MovieClip的构造函数作为影片剪辑的帧。影片剪辑会根据第一帧的纹理来确定影片的宽度和高度。 如果你使用纹理图集TextureAtlas（推荐使用此方法）来组织你的帧，请使用纹理图集的getTextures方法 获取正确(按字母次序的)的纹理顺序。

你可以在构造函数中指定一个特定的帧频，如果需要，你还可以设置每一帧的执行时间，或者在某一帧执行时播放一个声音。

play 和 pause 方法可以控制影片的播放，当影片播放完毕时，你会接收到一个Event.MovieCompleted 事件。如果影片是循环播放的，这个事件会在每一次循环都派发。

同其他动画对象一样，一个影片剪辑必须添加到一个juggler（或者是一个拥有自己的定时执行的advanceTime方法的对象）里来运行。 当影片剪辑播放完最后一帧时，会派发"Event.COMPLETE"事件。

See also

starling.textures.TextureAtlas

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number [override] 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | Quad
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
Inherited | color : uint 返回四边形的颜色，如果四边形存在多个颜色，返回第一个顶点的颜色。 | Quad
 | currentFrame : int 当前正在播放的帧的索引。 | MovieClip
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
 | fps : Number 每秒播放的帧的默认数量。 不同的帧可以有不同的执行时间。 如果你改变fps,所有帧的执行时间将会相对于原来的值增加或减少。 | MovieClip
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
 | isComplete : Boolean [read-only] 判断一个不循环的影片剪辑是否已经播完最后一帧。 | MovieClip
 | isPlaying : Boolean [read-only] 判断影片剪辑是否正在播放。播放完毕时返回false。 | MovieClip
 | loop : Boolean 影片剪辑是否可以循环播放。 | MovieClip
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
 | numFrames : int [read-only] 影片剪辑的总帧数。 | MovieClip
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | smoothing : String 用于纹理的平滑过滤方式，默认值为：bilinear。 | Image
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
Inherited | texture : Texture 映射到四边形的纹理对象。 | Image
Inherited | tinted : Boolean [read-only] 一个布尔值，如果四边形（或者它的任意顶点）是非白色或者是透明的，返回true，否则返回 false。 | Quad
 | totalTime : Number [read-only] 影片剪辑总共需要播放的秒数。 | MovieClip
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | mVertexData : VertexData 四边形的原始顶点数据。 | Quad
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | MovieClip(textures:Vector.<Texture>, fps:Number = 12) 根据传入的纹理集合和帧频来创建一个影片剪辑。 影片剪辑会根据传入的第一帧纹理来确定自己的尺寸。 | MovieClip
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | addFrame(texture:Texture, sound:Sound = null, duration:Number = -1):void 为影片剪辑添加一帧，可以传递声音和执行时间（可选）。 如果没有指定执行时间或者执行时间为负值，则使用默认帧频（构造函数里确定的帧频）。 | MovieClip
 | addFrameAt(frameID:int, texture:Texture, sound:Sound = null, duration:Number = -1):void 根据指定的索引添加一帧，可以传递声音和执行时间（可选）。 | MovieClip
 | advanceTime(passedTime:Number):void 暂且把这个方法称之为"时间推送器"吧. | MovieClip
Inherited | copyVertexDataTo(targetData:VertexData, targetVertexID:int = 0):void [override] 复制源顶点数据到一个VertexData实例。 纹理坐标已经存在于渲染所需的格式中。 | Image
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | dispose():void 销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。 | DisplayObject
Inherited | fromBitmap(bitmap:Bitmap, generateMipMaps:Boolean = true, scale:Number = 1):Image [static] 根据传入的位图对象创建一个包含纹理的Image。 | Image
Inherited | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | Quad
 | getFrameDuration(frameID:int):Number 返回指定索引的帧的执行时间（单位：秒）。 | MovieClip
 | getFrameSound(frameID:int):Sound 根据帧索引返回其相对应的声音。 | MovieClip
 | getFrameTexture(frameID:int):Texture 根据帧索引返回其相对应的纹理。 | MovieClip
Inherited | getTexCoords(vertexID:int, resultPoint:Point = null):Point 获取一个顶点的纹理坐标，坐标范围：[0,1]。 | Image
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | getVertexAlpha(vertexID:int):Number 返回指定索引的顶点的透明度。 | Quad
Inherited | getVertexColor(vertexID:int):uint 返回指定索引的顶点的颜色。 | Quad
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObject
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
 | pause():void 暂停播放。 | MovieClip
 | play():void 开始播放影片剪辑， 请确保影片已被添加到了juggler！ | MovieClip
Inherited | readjustSize():void 根据图像当前的纹理调整图像的尺寸，在为图片设置了另外一个不同的纹理以后，需要调用这个方法来同步图像和纹理的尺寸。 | Image
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
 | removeFrameAt(frameID:int):void 从指定的索引处删除一帧。此帧后面的所有帧将前移。 | MovieClip
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
Inherited | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | Image
 | setFrameDuration(frameID:int, duration:Number):void 设置指定索引的帧的执行时间（单位：秒）。 | MovieClip
 | setFrameSound(frameID:int, sound:Sound):void 设置指定索引的帧的声音，当此帧显示时，声音就会播放。 | MovieClip
 | setFrameTexture(frameID:int, texture:Texture):void 设置指定索引的帧的纹理。 | MovieClip
Inherited | setTexCoords(vertexID:int, coords:Point):void 设置一个顶点的纹理坐标，坐标范围：[0,1]。 | Image
Inherited | setVertexAlpha(vertexID:int, alpha:Number):void 设置指定索引的顶点的透明度。 | Quad
Inherited | setVertexColor(vertexID:int, color:uint):void 设置指定索引的顶点的颜色。 | Quad
 | stop():void 停止播放, 重置 "currentFrame" 为0。 | MovieClip
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | onVertexDataChanged():void [override] 在手动改变'mVertexData'的内容后调用此方法。 | Image
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
 | complete | 当影片剪辑播放完最后一帧时进行派发。 | MovieClip
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
currentFrame property
currentFrame:int

当前正在播放的帧的索引。

Implementation
    public function get currentFrame():int
    public function set currentFrame(value:int):void
fps property
fps:Number

每秒播放的帧的默认数量。 不同的帧可以有不同的执行时间。 如果你改变fps,所有帧的执行时间将会相对于原来的值增加或减少。

Implementation
    public function get fps():Number
    public function set fps(value:Number):void
isComplete property
isComplete:Boolean [read-only]

判断一个不循环的影片剪辑是否已经播完最后一帧。

Implementation
    public function get isComplete():Boolean
isPlaying property
isPlaying:Boolean [read-only]

判断影片剪辑是否正在播放。播放完毕时返回false。

Implementation
    public function get isPlaying():Boolean
loop property
loop:Boolean

影片剪辑是否可以循环播放。

Implementation
    public function get loop():Boolean
    public function set loop(value:Boolean):void
numFrames property
numFrames:int [read-only]

影片剪辑的总帧数。

Implementation
    public function get numFrames():int
totalTime property
totalTime:Number [read-only]

影片剪辑总共需要播放的秒数。

Implementation
    public function get totalTime():Number
Constructor Detail
MovieClip () Constructor
public function MovieClip(textures:Vector.<Texture>, fps:Number = 12)

根据传入的纹理集合和帧频来创建一个影片剪辑。 影片剪辑会根据传入的第一帧纹理来确定自己的尺寸。

Parameters
textures:Vector.<Texture> — 纹理集合
fps:Number (default = 12) — 帧频，默认为：12

Throws
ArgumentError
Method Detail
addFrame () method
public function addFrame(texture:Texture, sound:Sound = null, duration:Number = -1):void

为影片剪辑添加一帧，可以传递声音和执行时间（可选）。 如果没有指定执行时间或者执行时间为负值，则使用默认帧频（构造函数里确定的帧频）。

Parameters

texture:Texture — 纹理
sound:Sound (default = null) — 声音
duration:Number (default = -1) — 执行时间

addFrameAt () method
public function addFrameAt(frameID:int, texture:Texture, sound:Sound = null, duration:Number = -1):void

根据指定的索引添加一帧，可以传递声音和执行时间（可选）。

Parameters

frameID:int — 索引
texture:Texture — 纹理
sound:Sound (default = null) — 声音
duration:Number (default = -1) — 执行时间

Throws
ArgumentError
advanceTime () method
public function advanceTime(passedTime:Number):void

暂且把这个方法称之为"时间推送器"吧. 在Starling里面，这个方法一般会和EnterFrame事件绑定起来， 就是说，如果和EnterFrame绑定，每一帧都会调用这个方法，同时传递消逝的时间值。这个时间值非常重要， 比如当Starling停止渲染，然后恢复的时候，需要从正确的点开始执行动画。 当然你也可以手动控制什么时候调用这个方法，比如在EnterFrame回调方法里面加入一些条件判断，确定是否调用这个方法，来实现画面的暂停。

Parameters

passedTime:Number — 已经流逝的时间(秒)

getFrameDuration () method
public function getFrameDuration(frameID:int):Number

返回指定索引的帧的执行时间（单位：秒）。

Parameters

frameID:int — 索引

Returns
Number — Number

Throws
ArgumentError
getFrameSound () method
public function getFrameSound(frameID:int):Sound

根据帧索引返回其相对应的声音。

Parameters

frameID:int — 索引

Returns
Sound — Sound

Throws
ArgumentError
getFrameTexture () method
public function getFrameTexture(frameID:int):Texture

根据帧索引返回其相对应的纹理。

Parameters

frameID:int — 索引

Returns
Texture — Texture

Throws
ArgumentError
pause () method
public function pause():void

暂停播放。

play () method
public function play():void

开始播放影片剪辑， 请确保影片已被添加到了juggler！

removeFrameAt () method
public function removeFrameAt(frameID:int):void

从指定的索引处删除一帧。此帧后面的所有帧将前移。

Parameters

frameID:int — 索引

Throws
ArgumentError
IllegalOperationError
setFrameDuration () method
public function setFrameDuration(frameID:int, duration:Number):void

设置指定索引的帧的执行时间（单位：秒）。

Parameters

frameID:int — 索引
duration:Number — 执行时间

Throws
ArgumentError
setFrameSound () method
public function setFrameSound(frameID:int, sound:Sound):void

设置指定索引的帧的声音，当此帧显示时，声音就会播放。

Parameters

frameID:int — 索引
sound:Sound — 声音

Throws
ArgumentError
setFrameTexture () method
public function setFrameTexture(frameID:int, texture:Texture):void

设置指定索引的帧的纹理。

Parameters

frameID:int — 索引
texture:Texture — 纹理

Throws
ArgumentError
stop () method
public function stop():void

停止播放, 重置 "currentFrame" 为0。

Event Detail
complete Event
Event Object Type: starling.events.Event

当影片剪辑播放完最后一帧时进行派发。


starling.display.Quad

Quad | Properties | Methods | Events
Package | starling.display
Class | public class Quad
Inheritance | Quad Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Image

一个四边形代表了由单一颜色或者渐变颜色填充的矩形。

你可以设置每一个顶点的颜色。不同顶点的颜色会在颜色交汇的地方平滑的过度。 要让四边形显示一个线性的渐变颜色，需要给顶点0,1设置一个颜色，然后给顶点2,3设置另一个颜色。

四边形的四个顶点的位置是这样排列的:

      0 - 1
      | / |
      2 - 3

See also

Image

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | alpha : Number [override] 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | Quad
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
 | color : uint 返回四边形的颜色，如果四边形存在多个颜色，返回第一个顶点的颜色。 | Quad
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | tinted : Boolean [read-only] 一个布尔值，如果四边形（或者它的任意顶点）是非白色或者是透明的，返回true，否则返回 false。 | Quad
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Protected Properties
Property |  | Defined By
 | mVertexData : VertexData 四边形的原始顶点数据。 | Quad
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Quad(width:Number, height:Number, color:uint = 0xffffff, premultipliedAlpha:Boolean = true) 根据指定的尺寸和颜色创建一个四边形。 最后一个参数决定是否在渲染的时候预乘透明度值，从而影响混合输出的颜色值，大多数情况下可以使用默认值。 | Quad
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | copyVertexDataTo(targetData:VertexData, targetVertexID:int = 0):void 拷贝四边形的顶点数据到一个新的顶点数据实例。 | Quad
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | dispose():void 销毁掉该对象的所有资源。 释放GPU缓存，移除监听的事件，清除添加的滤镜。 | DisplayObject
 | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | Quad
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
 | getVertexAlpha(vertexID:int):Number 返回指定索引的顶点的透明度。 | Quad
 | getVertexColor(vertexID:int):uint 返回指定索引的顶点的颜色。 | Quad
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObject
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | Quad
 | setVertexAlpha(vertexID:int, alpha:Number):void 设置指定索引的顶点的透明度。 | Quad
 | setVertexColor(vertexID:int, color:uint):void 设置指定索引的顶点的颜色。 | Quad
Protected Methods
Method |  | Defined By
 | onVertexDataChanged():void 在手动改变'mVertexData'的内容后调用此方法。 | Quad
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
alpha property
alpha:Number[override]

显示对象的不透明度。 0 = 透明, 1 = 不透明。

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
color property
color:uint

返回四边形的颜色，如果四边形存在多个颜色，返回第一个顶点的颜色。

Implementation
    public function get color():uint
    public function set color(value:uint):void
mVertexData property
protected var mVertexData:VertexData

四边形的原始顶点数据。

tinted property
tinted:Boolean [read-only]

一个布尔值，如果四边形（或者它的任意顶点）是非白色或者是透明的，返回true，否则返回 false。

Implementation
    public function get tinted():Boolean
Constructor Detail
Quad () Constructor
public function Quad(width:Number, height:Number, color:uint = 0xffffff, premultipliedAlpha:Boolean = true)

根据指定的尺寸和颜色创建一个四边形。 最后一个参数决定是否在渲染的时候预乘透明度值，从而影响混合输出的颜色值，大多数情况下可以使用默认值。

Parameters
width:Number — 宽度
height:Number — 高度
color:uint (default = 0xffffff) — 填充颜色
premultipliedAlpha:Boolean (default = true) — 否在渲染的时候预乘透明度值，从而影响混合输出的颜色值，大多数情况下可以使用默认值。
Method Detail
copyVertexDataTo () method
public function copyVertexDataTo(targetData:VertexData, targetVertexID:int = 0):void

拷贝四边形的顶点数据到一个新的顶点数据实例。

Parameters

targetData:VertexData
targetVertexID:int (default = 0)

getBounds () method
override public function getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle

返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultRect:Rectangle (default = null) — 如果传入一个resultRect参数, 计算的结果将保存在这个矩形里，而不是重新创建一个Rectangle对象。

Returns
Rectangle — Rectangle
getVertexAlpha () method
public function getVertexAlpha(vertexID:int):Number

返回指定索引的顶点的透明度。

Parameters

vertexID:int — 顶点索引

Returns
Number — 顶点的透明度
getVertexColor () method
public function getVertexColor(vertexID:int):uint

返回指定索引的顶点的颜色。

Parameters

vertexID:int — 顶点索引

Returns
uint — 顶点的颜色
onVertexDataChanged () method
protected function onVertexDataChanged():void

在手动改变'mVertexData'的内容后调用此方法。

render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

setVertexAlpha () method
public function setVertexAlpha(vertexID:int, alpha:Number):void

设置指定索引的顶点的透明度。

Parameters

vertexID:int — 顶点索引
alpha:Number — 透明度

setVertexColor () method
public function setVertexColor(vertexID:int, color:uint):void

设置指定索引的顶点的颜色。

Parameters

vertexID:int — 顶点索引
color:uint — 颜色


starling.display.QuadBatch

QuadBatch | Properties | Methods | Events
Package | starling.display
Class | public class QuadBatch
Inheritance | QuadBatch Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

QuadBatch类用于优化渲染大量具备相同状态的四边形(Quad类).

Starling的大部分渲染对象都是四边形。实际上，Starling的所有默认叶子节点都是四边形（Image和Quad类）。 如果所有的具有相同状态的四边形可以只用一次请求就上传给GPU，那么渲染这些四边形的执行效率将会得到极大的提升。这就是QuadBatch类的作用。

Sprite类的'flatten'方法在内部使用了这个类来提升渲染效率。 大多数情况下，建议你使用"平面化"的对象，因为他们用起来很简单。不过有时，直接使用QuadBatch类效果会更好： 例如，你可以将一个四边形多次添加进一个四边形批次，但是，你只能添加它到一个sprite容器一次。 此外，当一个四边形被添加时，并不会派发ADDED 或者 ADDED_TO_STAGE 事件，这使得QuadBatch更加轻便。

一个QuadBatch对象只能有一个特定的渲染状态。 你添加到批次的第一个对象将决定QuadBatch的状态，包括：它的纹理，它的平滑度和混合设置， 它是否被染色（有色的顶点 和/或 透明的）。当你重置批次，它将会在添加下一个四边形时接受一个新的状态。

这个类继承了DisplayObject，但是你可以使用它，即使它没有被添加到显示列表树。 只需从另一个渲染方法调用'renderCustom'方法，并且传递适当的值（包括变换矩阵，透明度，混合模式）。

See also

Sprite

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
 | numQuads : int [read-only] 四边形的数量。 | QuadBatch
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
 | smoothing : String [read-only] 平滑度。 | QuadBatch
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | texture : Texture [read-only] 纹理。 | QuadBatch
 | tinted : Boolean [read-only] 是否染色。 | QuadBatch
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
QuadBatch()
用空的四边形数据创建一个新的 QuadBatch实例。
QuadBatch
Inherited
addEventListener(type:String, listener:Function):void
在指定的对象上注册一个事件侦听器。
EventDispatcher
addImage(image:Image, parentAlpha:Number = 1.0, modelViewMatrix:Matrix = null, blendMode:String = null):void
向当前批次添加一个图像。 这个方法在内部调用'addQuad'方法，并传递关于纹理和平滑度的正确参数。
QuadBatch
addQuad(quad:Quad, parentAlpha:Number = 1.0, texture:Texture = null, smoothing:String = null, modelViewMatrix:Matrix = null, blendMode:String = null):void
添加一个四边形到当前批次。 第一个四边形决定批次的状态。比如纹理的值，平滑度和混合模式。 当你添加自定义的四边形，请确保他们共享了这些状态（比如'isStageChange'方法），或者重置这个批次。
QuadBatch
addQuadBatch(quadBatch:QuadBatch, parentAlpha:Number = 1.0, modelViewMatrix:Matrix = null, blendMode:String = null):void
添加一个批次
QuadBatch
clone():QuadBatch
复制当前对象。
QuadBatch
compile(object:DisplayObject, quadBatches:Vector.<QuadBatch>):void
[static] 分析一个专门由四边形（或者其他容器）组成的容器对象， 并且创建一个矢量数组(元素类型是QuadBatch)来代替容器。 这可以用来非常高效的渲染容器。 Sprite类的'flatten'方法在内部使用了这个方法。
QuadBatch
Inherited
dispatchEvent(event:Event):void
派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。
EventDispatcher
Inherited
dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void
派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。
EventDispatcher
dispose():void
[override] 销毁顶点和索引缓冲区。
QuadBatch
getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle
[override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。
QuadBatch
Inherited
getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix
返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。
DisplayObject
Inherited
globalToLocal(globalPoint:Point, resultPoint:Point = null):Point
将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。
DisplayObject
Inherited
hasEventListener(type:String):Boolean
判断是否具备指定的事件类型的侦听器。
EventDispatcher
Inherited
hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject
返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。
DisplayObject
isStateChange(tinted:Boolean, parentAlpha:Number, texture:Texture, smoothing:String, blendMode:String, numQuads:int = 1):Boolean
判断如果一个四边形可以被添加到批次，会否引起状态的变化。 状态变化可能是由于四边形使用了不同的基础纹理，可能是有不同的"是否染色"，"平滑度"，"纹理是否平铺显示"，或者"混合模式"设置， 可能是因为批次满了（一个批次最多包含8192个四边形）。
QuadBatch
Inherited
localToGlobal(localPoint:Point, resultPoint:Point = null):Point
将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。
DisplayObject
Inherited
removeEventListener(type:String, listener:Function):void
在指定的对象上删除一个事件侦听器。
EventDispatcher
Inherited
removeEventListeners(type:String = null):void
根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。
EventDispatcher
Inherited
removeFromParent(dispose:Boolean = false):void
如果对象已经添加进显示列表，则从父容器中删除此对象。
DisplayObject
render(support:RenderSupport, parentAlpha:Number):void
[override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。
QuadBatch
renderCustom(mvpMatrix:Matrix, parentAlpha:Number = 1.0, blendMode:String = null):void
结合对 模型-视图-投影矩阵，透明度和混合模式的自定义设置来渲染当前批次。 这样就使渲染那些不在显示列表的批次成为可能。
QuadBatch
reset():void
重置当前批次。顶点和索引缓冲区仍保持原来的大小，以便能够很快被重用。
QuadBatch
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
numQuads property
numQuads:int [read-only]

四边形的数量。

Implementation
    public function get numQuads():int
smoothing property
smoothing:String [read-only]

平滑度。

Implementation
    public function get smoothing():String
texture property
texture:Texture [read-only]

纹理。

Implementation
    public function get texture():Texture
tinted property
tinted:Boolean [read-only]

是否染色。

Implementation
    public function get tinted():Boolean
Constructor Detail
QuadBatch () Constructor
public function QuadBatch()

用空的四边形数据创建一个新的 QuadBatch实例。

Method Detail
addImage () method
public function addImage(image:Image, parentAlpha:Number = 1.0, modelViewMatrix:Matrix = null, blendMode:String = null):void

向当前批次添加一个图像。 这个方法在内部调用'addQuad'方法，并传递关于纹理和平滑度的正确参数。

Parameters

image:Image — 图像
parentAlpha:Number (default = 1.0) — 父级的透明度
modelViewMatrix:Matrix (default = null) — 模型视图矩阵
blendMode:String (default = null) — 混合模式

addQuad () method
public function addQuad(quad:Quad, parentAlpha:Number = 1.0, texture:Texture = null, smoothing:String = null, modelViewMatrix:Matrix = null, blendMode:String = null):void

添加一个四边形到当前批次。 第一个四边形决定批次的状态。比如纹理的值，平滑度和混合模式。 当你添加自定义的四边形，请确保他们共享了这些状态（比如'isStageChange'方法），或者重置这个批次。

Parameters

quad:Quad — 四边形
parentAlpha:Number (default = 1.0) — 父级的透明度
texture:Texture (default = null) — 纹理
smoothing:String (default = null) — 平滑度
modelViewMatrix:Matrix (default = null) — 模型视图矩阵
blendMode:String (default = null) — 混合模式

addQuadBatch () method
public function addQuadBatch(quadBatch:QuadBatch, parentAlpha:Number = 1.0, modelViewMatrix:Matrix = null, blendMode:String = null):void

添加一个批次

Parameters

quadBatch:QuadBatch — QuadBatch对象
parentAlpha:Number (default = 1.0) — 父级的透明度
modelViewMatrix:Matrix (default = null) — 模型视图矩阵
blendMode:String (default = null) — 混合模式

clone () method
public function clone():QuadBatch

复制当前对象。

Returns
QuadBatch
compile () method
public static function compile(object:DisplayObject, quadBatches:Vector.<QuadBatch>):void

分析一个专门由四边形（或者其他容器）组成的容器对象， 并且创建一个矢量数组(元素类型是QuadBatch)来代替容器。 这可以用来非常高效的渲染容器。 Sprite类的'flatten'方法在内部使用了这个方法。

Parameters

object:DisplayObject — 容器
quadBatches:Vector.<QuadBatch> — 包含QuadBatch类型的矢量数组

dispose () method
override public function dispose():void

销毁顶点和索引缓冲区。

getBounds () method
override public function getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle

返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultRect:Rectangle (default = null) — 如果传入一个resultRect参数, 计算的结果将保存在这个矩形里，而不是重新创建一个Rectangle对象。

Returns
Rectangle — Rectangle
isStateChange () method
public function isStateChange(tinted:Boolean, parentAlpha:Number, texture:Texture, smoothing:String, blendMode:String, numQuads:int = 1):Boolean

判断如果一个四边形可以被添加到批次，会否引起状态的变化。 状态变化可能是由于四边形使用了不同的基础纹理，可能是有不同的"是否染色"，"平滑度"，"纹理是否平铺显示"，或者"混合模式"设置， 可能是因为批次满了（一个批次最多包含8192个四边形）。

Parameters

tinted:Boolean — 是否染色
parentAlpha:Number — 父级的透明度
texture:Texture — 纹理
smoothing:String — 平滑度
blendMode:String — 混合模式
numQuads:int (default = 1) — 四边形的数量

Returns
Boolean — 返回true 如果会引起状态变化，否则返回false
render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

renderCustom () method
public function renderCustom(mvpMatrix:Matrix, parentAlpha:Number = 1.0, blendMode:String = null):void

结合对 模型-视图-投影矩阵，透明度和混合模式的自定义设置来渲染当前批次。 这样就使渲染那些不在显示列表的批次成为可能。

Parameters

mvpMatrix:Matrix — 模型-视图-投影矩阵
parentAlpha:Number (default = 1.0) — 父级的透明度
blendMode:String (default = null) — 混合模式

reset () method
public function reset():void

重置当前批次。顶点和索引缓冲区仍保持原来的大小，以便能够很快被重用。


starling.display.Sprite

Sprite | Properties | Methods | Events
Package | starling.display
Class | public class Sprite
Inheritance | Sprite Inheritance DisplayObjectContainer Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Sprite是一个极其轻量，非抽象的容器类。

通常把Sprite作为一种把一组显示对象集中到一个坐标系内的简单手段，也可以把它用做自定义显示对象的基类。

"平面化" Sprite对象

flatten方法允许你在渲染时优化显示列表中的静态部分。

flatten 分析了添加到这个Sprite的显示列表的子对象，优化了渲染调用，极大的提高了渲染速度。 但是速度的大幅提升是要付出代价的：你将再也看不见子对象属性的任何变化（位置，旋转，透明等等）。 要更新这个sprite对象的显示，只需再一次调用flatten，或者unflatten这个对象。

See also

DisplayObject
DisplayObjectContainer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
 | isFlattened : Boolean [read-only] 判断这个对象是否经过"平面化"处理。 | Sprite
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
Inherited | numChildren : int [read-only] 容器包含的子级数量。 | DisplayObjectContainer
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | Sprite() 创建一个空的Sprite实例。 | Sprite
Inherited | addChild(child:DisplayObject):DisplayObject 添加一个显示对象到容器，它将被添加到顶层。 | DisplayObjectContainer
Inherited | addChildAt(child:DisplayObject, index:int):DisplayObject 根据一个索引值添加一个显示对象到容器。 | DisplayObjectContainer
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
Inherited | broadcastEvent(event:Event):void 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。 | DisplayObjectContainer
Inherited | broadcastEventWith(type:String, data:Object = null):void 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。 | DisplayObjectContainer
Inherited | contains(child:DisplayObject):Boolean 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。 | DisplayObjectContainer
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | dispose():void [override] 释放所有子级的资源。 | Sprite
 | flatten():void 优化Sprite对象得到最佳渲染性能。 对于被"平面化"的Sprite，子对象的改变是不会有任何显示更新的。 要更新这个Sprite对象的显示，只需再一次调用flatten，或者对它进行unflatten。 | Sprite
Inherited | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | DisplayObjectContainer
Inherited | getChildAt(index:int):DisplayObject 根据指定的索引返回对应的子级对象。 | DisplayObjectContainer
Inherited | getChildByName(name:String):DisplayObject 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。 | DisplayObjectContainer
Inherited | getChildIndex(child:DisplayObject):int 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。 | DisplayObjectContainer
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject [override] 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObjectContainer
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
Inherited | removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildAt(index:int, dispose:Boolean = false):DisplayObject 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。 | DisplayObjectContainer
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | Sprite
Inherited | setChildIndex(child:DisplayObject, index:int):void 移动一个子级到指定的索引，在它后面的子级将向后移动。 | DisplayObjectContainer
Inherited | sortChildren(compareFunction:Function):void 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。 | DisplayObjectContainer
Inherited | swapChildren(child1:DisplayObject, child2:DisplayObject):void 互换两个子级的索引。 | DisplayObjectContainer
Inherited | swapChildrenAt(index1:int, index2:int):void 互换两个子级的索引。 | DisplayObjectContainer
 | unflatten():void 取消对这个Sprite的"平面化"渲染优化操作。 此时子对象的改变会使Sprite对象立即更新显示。 | Sprite
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
 | flatten | 当"平面化"这个对象时，向对象的所有子级派发此事件。 | Sprite
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
isFlattened property
isFlattened:Boolean [read-only]

判断这个对象是否经过"平面化"处理。

Implementation
    public function get isFlattened():Boolean
Constructor Detail
Sprite () Constructor
public function Sprite()

创建一个空的Sprite实例。

Method Detail
dispose () method
override public function dispose():void

释放所有子级的资源。

flatten () method
public function flatten():void

优化Sprite对象得到最佳渲染性能。 对于被"平面化"的Sprite，子对象的改变是不会有任何显示更新的。 要更新这个Sprite对象的显示，只需再一次调用flatten，或者对它进行unflatten。

render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

unflatten () method
public function unflatten():void

取消对这个Sprite的"平面化"渲染优化操作。 此时子对象的改变会使Sprite对象立即更新显示。

Event Detail
flatten Event
Event Object Type: starling.events.Event

当"平面化"这个对象时，向对象的所有子级派发此事件。


starling.display.Stage

Stage | Properties | Methods | Events
Package | starling.display
Class | public class Stage
Inheritance | Stage Inheritance DisplayObjectContainer Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Stage是显示列表树的根节点，只有直接或者间接放置到stage上的显示对象才会被渲染。

这个类相当于Starling版本的Stage，注意不要和传统的Flash里的Stage混淆。 传统的Flash里的Stage只能包含类型为flash.display.DisplayObject的对象， 而Starling里的Stage只能包含类型为starling.display.DisplayObject的对象， 由于Starling显示列表并不等同于传统Flash显示列表，所以这些类并不兼容，不能混用，也不能互相代替。

stage对象是被Starling类自动创建的，请不要手动创建一个stage对象。

键盘事件

在Starling中，键盘事件只能够在stage派发，所以，如果想捕获到派发的键盘事件，只能给stage添加键盘事件监听。

尺寸变化事件

当Flash player 尺寸变化时，stage会派发一个ResizeEvent事件。 这个事件的属性包含更新后的Flash player的宽度和高度。

See also

starling.events.KeyboardEvent
starling.events.ResizeEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
 | color : uint 舞台的背景颜色 | Stage
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
Inherited | height : Number 显示对象的高度。 | DisplayObject
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
Inherited | numChildren : int [read-only] 容器包含的子级数量。 | DisplayObjectContainer
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | stageHeight : int 舞台坐标系的高度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。 | Stage
 | stageWidth : int 舞台坐标系的宽度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。 | Stage
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
Inherited | width : Number 显示对象的宽度。 | DisplayObject
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
Inherited | addChild(child:DisplayObject):DisplayObject 添加一个显示对象到容器，它将被添加到顶层。 | DisplayObjectContainer
Inherited | addChildAt(child:DisplayObject, index:int):DisplayObject 根据一个索引值添加一个显示对象到容器。 | DisplayObjectContainer
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | advanceTime(passedTime:Number):void | Stage
Inherited | broadcastEvent(event:Event):void 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。 | DisplayObjectContainer
Inherited | broadcastEventWith(type:String, data:Object = null):void 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。 | DisplayObjectContainer
Inherited | contains(child:DisplayObject):Boolean 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。 | DisplayObjectContainer
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
Inherited | dispose():void [override] 释放所有子级的资源。 | DisplayObjectContainer
Inherited | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | DisplayObjectContainer
Inherited | getChildAt(index:int):DisplayObject 根据指定的索引返回对应的子级对象。 | DisplayObjectContainer
Inherited | getChildByName(name:String):DisplayObject 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。 | DisplayObjectContainer
Inherited | getChildIndex(child:DisplayObject):int 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。 | DisplayObjectContainer
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject [override] 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回Stage本身。 | Stage
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
Inherited | removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildAt(index:int, dispose:Boolean = false):DisplayObject 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。 | DisplayObjectContainer
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
Inherited | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | DisplayObjectContainer
Inherited | setChildIndex(child:DisplayObject, index:int):void 移动一个子级到指定的索引，在它后面的子级将向后移动。 | DisplayObjectContainer
Inherited | sortChildren(compareFunction:Function):void 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。 | DisplayObjectContainer
Inherited | swapChildren(child1:DisplayObject, child2:DisplayObject):void 互换两个子级的索引。 | DisplayObjectContainer
Inherited | swapChildrenAt(index1:int, index2:int):void 互换两个子级的索引。 | DisplayObjectContainer
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
 | keyDown | 当键盘按键按下时进行派发。 | Stage
 | keyUp | 当键盘按键松开时进行派发。 | Stage
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
 | resize | 当Flash容器的尺寸发生改变时进行派发。 | Stage
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
color property
color:uint

舞台的背景颜色

Implementation
    public function get color():uint
    public function set color(value:uint):void
stageHeight property
stageHeight:int

舞台坐标系的高度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。

Implementation
    public function get stageHeight():int
    public function set stageHeight(value:int):void
stageWidth property
stageWidth:int

舞台坐标系的宽度。改变此值，将会缩放舞台的显示内容（相对于starling对象的viewPort属性）。

Implementation
    public function get stageWidth():int
    public function set stageWidth(value:int):void
Method Detail
advanceTime () method
public function advanceTime(passedTime:Number):void

Parameters

passedTime:Number

hitTest () method
override public function hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject

返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回Stage本身。

Parameters

localPoint:Point — 舞台坐标系的某点
forTouch:Boolean (default = false) — 是否只检测能够触碰到的对象。如果为ture，检测会忽略掉不可见和不可触碰的对象。

Returns
DisplayObject — DisplayObject
Event Detail
keyDown Event
Event Object Type: starling.events.KeyboardEvent

当键盘按键按下时进行派发。

keyUp Event
Event Object Type: starling.events.KeyboardEvent

当键盘按键松开时进行派发。

resize Event
Event Object Type: starling.events.ResizeEvent

当Flash容器的尺寸发生改变时进行派发。


starling.errors - Starling API 1.3 | Starling中文站

Package starling.errors

Classes
AbstractClassError
AbstractMethodError
MissingContextError


starling.errors Summary

starling.errors | Classes

Classes
Class | Description
AbstractClassError | 当您尝试创建一个抽象类的一个实例，就会抛出一个AbstractClassError。
AbstractMethodError | 当您尝试调用一个抽象方法，就会抛出一个AbstractMethodError。
MissingContextError | 当需要Context3D对象而它不存在或尚未准备好的时候，会抛出一个MissingContextError。


starling.errors.AbstractClassError

AbstractClassError | Methods
Package | starling.errors
Class | public class AbstractClassError
Inheritance | AbstractClassError Inheritance Error

当您尝试创建一个抽象类的一个实例，就会抛出一个AbstractClassError。

Public Methods
Method |  | Defined By
 | AbstractClassError(message:*, id:* = 0) 创建一个新的AbstractClassError对象。 | AbstractClassError
Constructor Detail
AbstractClassError () Constructor
public function AbstractClassError(message:*, id:* = 0)

创建一个新的AbstractClassError对象。

Parameters
message:*
id:* (default = 0)


starling.errors.AbstractMethodError

AbstractMethodError | Methods
Package | starling.errors
Class | public class AbstractMethodError
Inheritance | AbstractMethodError Inheritance Error

当您尝试调用一个抽象方法，就会抛出一个AbstractMethodError。

Public Methods
Method |  | Defined By
 | AbstractMethodError(message:*, id:* = 0) 创建一个新的AbstractMethodError对象。 | AbstractMethodError
Constructor Detail
AbstractMethodError () Constructor
public function AbstractMethodError(message:*, id:* = 0)

创建一个新的AbstractMethodError对象。

Parameters
message:*
id:* (default = 0)


starling.errors.MissingContextError

MissingContextError | Methods
Package | starling.errors
Class | public class MissingContextError
Inheritance | MissingContextError Inheritance Error

当需要Context3D对象而它不存在或尚未准备好的时候，会抛出一个MissingContextError。

Public Methods
Method |  | Defined By
 | MissingContextError(message:*, id:* = 0) 创建一个新的MissingContextError对象。 | MissingContextError
Constructor Detail
MissingContextError () Constructor
public function MissingContextError(message:*, id:* = 0)

创建一个新的MissingContextError对象。

Parameters
message:*
id:* (default = 0)


starling.events - Starling API 1.3 | Starling中文站

Package starling.events

Classes
EnterFrameEvent
Event
EventDispatcher
KeyboardEvent
ResizeEvent
Touch
TouchEvent
TouchPhase


starling.events Summary

starling.events | Classes

Classes
Class | Description
EnterFrameEvent | 处于显示列表树中的所有显示对象，在每一帧都会派发一个EnterFrameEvent事件。 它包含了从上一帧到现在所经过的时间的信息。这样，您就可以轻松的通过帧频创建动画，传递经过的时间给它。
Event | 当事件派发时，事件对象会作为参数传递给事件侦听器。这是Flash Event类的Starling版本。 EventDispatcher对象会创建这个类的实例并将它派发到一个已注册的事件侦听器。 一个事件对象包含了作为这个事件特征的信息，其中非常重要的是事件类型，如果事件冒泡的话。 事件的目标(target)是派发这个事件的对象。 对于某些类型的事件，这些信息就足够了，其他事件可能需要更多的信息来传递给侦听器。 在这种情况下，您可以创建“事件”的子类，并添加您所需要的所有信息作为事件的属性。 “EnterFrameEvent”是这种做法的一个例子，它增加了一个属性用来表示已经执行的时间值。 此外，事件类包含的方法可以中断事件的派发，阻止事件被其它的侦听器接受。（ 包括完全阻止 或只是阻止进入下一个冒泡阶段）
EventDispatcher | EventDispatcher类是所有具备调度事件能力的类的基类。这是传统Flash里的EventDispatcher在Starling中的对应实现。 事件机制也是Starling架构的一个关键特性。通过事件对象可以互相通信。相比传统Flash的事件系统，Starling的事件 系统是经过简化的。 主要区别在于，Starling事件没有“捕捉”的阶段。这些事件只是简单的被一个对象派发，并可以选择 冒泡。他们不能向相反的方向传递。 就像传统的Flash类那样，显示对象只要继承EventDispatcher就可以派发事件。但要小心， Starling中的事件不能和传统Flash的事件混用。 Starling的显示对象会派发Starling事件，冒泡也是在Starling 显示对象中进行-但是他们不能派发或冒泡传统Flash显示对象的事件。
KeyboardEvent | 一个键盘事件的派发，是对用户使用键盘输入的回应。 这个类是Flash的键盘事件的Starling版本。它包含了和Flash的键盘事件相同的属性。 要捕获键盘事件，需要在Starling的stage上添加事件侦听。stage的子节点是不能获取到键盘事件的。 Starling并没有像传统Flash那样的“焦点”的概念。
ResizeEvent | 当Flash容器的尺寸改变后，stage会派发一个ResizeEvent。用这个值可以更新Starling的视口和stage的尺寸。 事件的属性包含了更新后的Flash Player的宽度和高度。如果您希望缩放stage上的内容来充满屏幕， 请更新 Starling.current.viewPort 矩形区域。如果您希望使用额外的屏幕区域， 请更新 stage.stageWidth 和 stage.stageHeight
Touch | 一个Touch对象包含了在屏幕上的一个手指或鼠标的相关信息（出现或移动）。 您将从TouchEvent中获取这个对象。当这样的事件被触发，您可以查询目前呈现在屏幕上的所有触碰。 一个Touch对象，包含了一个单指触碰的信息。一个Touch对象总是会通过TouchPhases的集合移动。请参阅TouchPhase类来获取更多信息。 触碰的位置 您可以用相应的属性，获取坐标系上的当前的和上一个位置。当然，在大部分情况下您希望能获取在一个不同的坐标系上的位置。 基于这个原因，这里有一些方法可以转换当前的和上一个位置到任何对象的局部坐标系。
TouchEvent | 一个TouchEvent是被手指触碰或鼠标输入来触发的。 在Starling中，无论是触碰事件还是鼠标事件，都统一封装为一个类：TouchEvent。 要处理用户在一个可触碰的屏幕或使用鼠标完成的输入， 您需要注册一个事件侦听器，来侦听类型是TouchEvent.TOUCH的事件。 这是唯一的您需要捕获的事件类型； 原有Flash里面的那个很长的事件类型列表，全都被映射到一个"TouchPhases"里面。 鼠标输入和触摸屏输入的区别是： 在某一时刻只有一个鼠标光标可以呈现 只有鼠标才可以"hover",即在没有按下按键的情况下滑过一个对象。 哪些对象能够接收触碰事件？ 在Starling中，任何一个显示对象都可以接受触碰事件，只要它的 touchable 属性，以及它的父级都是可用状态(true)。 在Starling中是没有"InteractiveObject"这个类的。 如何使用单个触碰对象 T事件包含了一个包括所有的触碰对象的列表。每一个独立的触碰都被保存在一个类型是"Touch"的对象里。 既然您通常只对在特定对象上发生的触碰感兴趣，您可以查询事件，传入一个具体的目标： var touches:Vector.<Touch> = touchEvent.getTouches(this); 这会返回附加在"this"或 它的子级上的所有触碰对象。如果您没有使用多点触碰，您也可以直接访问触碰对象，就像这样： var touch:Touch = touchEvent.getTouch(this);
TouchPhase | 这个类提供了描述触碰的各个阶段的常量值。 一个触碰，在它的生命周期内会遵循下面的过程： BEGAN(开始) -> MOVED(移动) -> ENDED(结束) 此外，一个触碰可能进入一个称之为STATIONARY(静止)的阶段。这一阶段本身不会触发触碰事件，并且它只能发生在多点触控环境。 在某些场合下需要一个解决方案，比如一个手指移动，另一个静止。这个时候，一个触碰事件必须由正在移动的手指下方的对象来派发。 在这个事件的触碰对象列表中，您将会找到第二个处于静止状态的触碰对象。 最后，还有一个称之为HOVER(悬停)的状态，这种情况只会发生在使用鼠标的情况下。 它是由Flash的MouseOver事件触发的，并且这个时候鼠标按键没有被按下。


starling.events.EnterFrameEvent

EnterFrameEvent | Properties | Methods | Constants
Package | starling.events
Class | public class EnterFrameEvent
Inheritance | EnterFrameEvent Inheritance Event Inheritance Object

处于显示列表树中的所有显示对象，在每一帧都会派发一个EnterFrameEvent事件。 它包含了从上一帧到现在所经过的时间的信息。这样，您就可以轻松的通过帧频创建动画，传递经过的时间给它。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | bubbles : Boolean [read-only] 表示事件是否冒泡 | Event
Inherited | currentTarget : EventDispatcher [read-only] 当前事件已经冒泡到的对象。 | Event
Inherited | data : Object [read-only] 被添加到事件上的任意数据对象 | Event
 | passedTime : Number [read-only] 从上一帧到现在所经过的时间。（以秒为单位） | EnterFrameEvent
Inherited | target : EventDispatcher [read-only] 派发这个事件的对象。 | Event
Inherited | type : String [read-only] 这个事件的字符串类型。 | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | EnterFrameEvent(type:String, passedTime:Number, bubbles:Boolean = false) 创建一个EnterFrameEvent实例 | EnterFrameEvent
Inherited | stopImmediatePropagation():void 阻止其他任何侦听器接收事件。 | Event
Inherited | stopPropagation():void 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。 | Event
Inherited | toString():String 返回事件的描述，包括类型及是否冒泡。 | Event
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | ADDED : String = added [static] 事件类型：一个显示对象被添加到了它的父级容器上。 | Event
Inherited | ADDED_TO_STAGE : String = addedToStage [static] 事件类型：一个显示对象被添加到了舞台上。 | Event
Inherited | CANCEL : String = cancel [static] 自定义事件需要的一个事件类型. | Event
Inherited | CHANGE : String = change [static] 自定义事件需要的一个事件类型. | Event
Inherited | CLOSE : String = close [static] 自定义事件需要的一个事件类型. | Event
Inherited | COMPLETE : String = complete [static] 事件类型：可以用在一些表示“完成”的场合。 | Event
Inherited | CONTEXT3D_CREATE : String = context3DCreate [static] 事件类型：表示创建(或重建)了Context3D实例。 | Event
 | ENTER_FRAME : String = enterFrame [static] 一个显示对象进入了新的一帧。 | EnterFrameEvent
Inherited | FLATTEN : String = flatten [static] 事件类型：一个即将被扁平化的对象派发。 | Event
Inherited | OPEN : String = open [static] 自定义事件需要的一个事件类型. | Event
Inherited | REMOVED : String = removed [static] 事件类型：一个显示对象从它的父级删除 | Event
Inherited | REMOVED_FROM_STAGE : String = removedFromStage [static] 事件类型：一个显示对象从舞台上删除。 | Event
Inherited | REMOVE_FROM_JUGGLER : String = removeFromJuggler [static] 事件类型：当一个动画对象需要被Juggler删除的时候派发 | Event
Inherited | RESIZE : String = resize [static] 事件类型：Flash Player尺寸改变。 | Event
Inherited | ROOT_CREATED : String = rootCreated [static] 事件类型：表示最顶层的显示对象已被创建。 | Event
Inherited | SCROLL : String = scroll [static] 自定义事件需要的一个事件类型. | Event
Inherited | SELECT : String = select [static] 自定义事件需要的一个事件类型. | Event
Inherited | TRIGGERED : String = triggered [static] 事件类型：按钮点击。 | Event
Property Detail
passedTime property
passedTime:Number [read-only]

从上一帧到现在所经过的时间。（以秒为单位）

Implementation
    public function get passedTime():Number
Constructor Detail
EnterFrameEvent () Constructor
public function EnterFrameEvent(type:String, passedTime:Number, bubbles:Boolean = false)

创建一个EnterFrameEvent实例

Parameters
type:String
passedTime:Number
bubbles:Boolean (default = false)
Constant Detail
ENTER_FRAME Constant
public static const ENTER_FRAME:String = enterFrame

一个显示对象进入了新的一帧。


starling.events.Event

Event | Properties | Methods | Constants
Package | starling.events
Class | public class Event
Inheritance | Event Inheritance Object
Subclasses | EnterFrameEvent, KeyboardEvent, ResizeEvent, TouchEvent

当事件派发时，事件对象会作为参数传递给事件侦听器。这是Flash Event类的Starling版本。

EventDispatcher对象会创建这个类的实例并将它派发到一个已注册的事件侦听器。 一个事件对象包含了作为这个事件特征的信息，其中非常重要的是事件类型，如果事件冒泡的话。 事件的目标(target)是派发这个事件的对象。

对于某些类型的事件，这些信息就足够了，其他事件可能需要更多的信息来传递给侦听器。 在这种情况下，您可以创建“事件”的子类，并添加您所需要的所有信息作为事件的属性。 “EnterFrameEvent”是这种做法的一个例子，它增加了一个属性用来表示已经执行的时间值。

此外，事件类包含的方法可以中断事件的派发，阻止事件被其它的侦听器接受。（ 包括完全阻止 或只是阻止进入下一个冒泡阶段）

See also

EventDispatcher

Public Properties
Property |  | Defined By
 | bubbles : Boolean [read-only] 表示事件是否冒泡 | Event
 | currentTarget : EventDispatcher [read-only] 当前事件已经冒泡到的对象。 | Event
 | data : Object [read-only] 被添加到事件上的任意数据对象 | Event
 | target : EventDispatcher [read-only] 派发这个事件的对象。 | Event
 | type : String [read-only] 这个事件的字符串类型。 | Event
Public Methods
Method |  | Defined By
 | Event(type:String, bubbles:Boolean = false, data:Object = null) 创建一个作为参数传递给事件侦听器的 Event 对象。 | Event
 | stopImmediatePropagation():void 阻止其他任何侦听器接收事件。 | Event
 | stopPropagation():void 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。 | Event
 | toString():String 返回事件的描述，包括类型及是否冒泡。 | Event
Public Constants
Constant |  | Defined By
 | ADDED : String = added [static] 事件类型：一个显示对象被添加到了它的父级容器上。 | Event
 | ADDED_TO_STAGE : String = addedToStage [static] 事件类型：一个显示对象被添加到了舞台上。 | Event
 | CANCEL : String = cancel [static] 自定义事件需要的一个事件类型. | Event
 | CHANGE : String = change [static] 自定义事件需要的一个事件类型. | Event
 | CLOSE : String = close [static] 自定义事件需要的一个事件类型. | Event
 | COMPLETE : String = complete [static] 事件类型：可以用在一些表示“完成”的场合。 | Event
 | CONTEXT3D_CREATE : String = context3DCreate [static] 事件类型：表示创建(或重建)了Context3D实例。 | Event
 | ENTER_FRAME : String = enterFrame [static] 事件类型：一个显示对象进入了新的一帧。 | Event
 | FLATTEN : String = flatten [static] 事件类型：一个即将被扁平化的对象派发。 | Event
 | OPEN : String = open [static] 自定义事件需要的一个事件类型. | Event
 | REMOVED : String = removed [static] 事件类型：一个显示对象从它的父级删除 | Event
 | REMOVED_FROM_STAGE : String = removedFromStage [static] 事件类型：一个显示对象从舞台上删除。 | Event
 | REMOVE_FROM_JUGGLER : String = removeFromJuggler [static] 事件类型：当一个动画对象需要被Juggler删除的时候派发 | Event
 | RESIZE : String = resize [static] 事件类型：Flash Player尺寸改变。 | Event
 | ROOT_CREATED : String = rootCreated [static] 事件类型：表示最顶层的显示对象已被创建。 | Event
 | SCROLL : String = scroll [static] 自定义事件需要的一个事件类型. | Event
 | SELECT : String = select [static] 自定义事件需要的一个事件类型. | Event
 | TRIGGERED : String = triggered [static] 事件类型：按钮点击。 | Event
Property Detail
bubbles property
bubbles:Boolean [read-only]

表示事件是否冒泡

Implementation
    public function get bubbles():Boolean
currentTarget property
currentTarget:EventDispatcher [read-only]

当前事件已经冒泡到的对象。

Implementation
    public function get currentTarget():EventDispatcher
data property
data:Object [read-only]

被添加到事件上的任意数据对象

Implementation
    public function get data():Object
target property
target:EventDispatcher [read-only]

派发这个事件的对象。

Implementation
    public function get target():EventDispatcher
type property
type:String [read-only]

这个事件的字符串类型。

Implementation
    public function get type():String
Constructor Detail
Event () Constructor
public function Event(type:String, bubbles:Boolean = false, data:Object = null)

创建一个作为参数传递给事件侦听器的 Event 对象。

Parameters
type:String — 事件类型
bubbles:Boolean (default = false) — 是否冒泡，默认false
data:Object (default = null) — 附加数据，默认是null
Method Detail
stopImmediatePropagation () method
public function stopImmediatePropagation():void

阻止其他任何侦听器接收事件。

stopPropagation () method
public function stopPropagation():void

阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。

toString () method
public function toString():String

返回事件的描述，包括类型及是否冒泡。

Returns
String
Constant Detail
ADDED Constant
public static const ADDED:String = added

事件类型：一个显示对象被添加到了它的父级容器上。

ADDED_TO_STAGE Constant
public static const ADDED_TO_STAGE:String = addedToStage

事件类型：一个显示对象被添加到了舞台上。

CANCEL Constant
public static const CANCEL:String = cancel

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

CHANGE Constant
public static const CHANGE:String = change

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

CLOSE Constant
public static const CLOSE:String = close

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

COMPLETE Constant
public static const COMPLETE:String = complete

事件类型：可以用在一些表示“完成”的场合。

CONTEXT3D_CREATE Constant
public static const CONTEXT3D_CREATE:String = context3DCreate

事件类型：表示创建(或重建)了Context3D实例。

ENTER_FRAME Constant
public static const ENTER_FRAME:String = enterFrame

事件类型：一个显示对象进入了新的一帧。

FLATTEN Constant
public static const FLATTEN:String = flatten

事件类型：一个即将被扁平化的对象派发。

OPEN Constant
public static const OPEN:String = open

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

REMOVE_FROM_JUGGLER Constant
public static const REMOVE_FROM_JUGGLER:String = removeFromJuggler

事件类型：当一个动画对象需要被Juggler删除的时候派发

REMOVED Constant
public static const REMOVED:String = removed

事件类型：一个显示对象从它的父级删除

REMOVED_FROM_STAGE Constant
public static const REMOVED_FROM_STAGE:String = removedFromStage

事件类型：一个显示对象从舞台上删除。

RESIZE Constant
public static const RESIZE:String = resize

事件类型：Flash Player尺寸改变。

ROOT_CREATED Constant
public static const ROOT_CREATED:String = rootCreated

事件类型：表示最顶层的显示对象已被创建。

SCROLL Constant
public static const SCROLL:String = scroll

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

SELECT Constant
public static const SELECT:String = select

自定义事件需要的一个事件类型. 在现在的Starling版本中没有使用.

TRIGGERED Constant
public static const TRIGGERED:String = triggered

事件类型：按钮点击。


starling.events.EventDispatcher

EventDispatcher | Methods
Package | starling.events
Class | public class EventDispatcher
Inheritance | EventDispatcher Inheritance Object
Subclasses | DelayedCall, DisplayObject, Starling, Tween

EventDispatcher类是所有具备调度事件能力的类的基类。这是传统Flash里的EventDispatcher在Starling中的对应实现。

事件机制也是Starling架构的一个关键特性。通过事件对象可以互相通信。相比传统Flash的事件系统，Starling的事件 系统是经过简化的。 主要区别在于，Starling事件没有“捕捉”的阶段。这些事件只是简单的被一个对象派发，并可以选择 冒泡。他们不能向相反的方向传递。

就像传统的Flash类那样，显示对象只要继承EventDispatcher就可以派发事件。但要小心， Starling中的事件不能和传统Flash的事件混用。 Starling的显示对象会派发Starling事件，冒泡也是在Starling 显示对象中进行-但是他们不能派发或冒泡传统Flash显示对象的事件。

See also

Event
DisplayObject

Public Methods
Method |  | Defined By
 | EventDispatcher() 创建一个EventDispatcher实例。 | EventDispatcher
 | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
 | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
 | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
 | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
 | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Constructor Detail
EventDispatcher () Constructor
public function EventDispatcher()

创建一个EventDispatcher实例。

Method Detail
addEventListener () method
public function addEventListener(type:String, listener:Function):void

在指定的对象上注册一个事件侦听器。

Parameters

type:String — 事件类型
listener:Function — 侦听器

dispatchEvent () method
public function dispatchEvent(event:Event):void

派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。

Parameters

event:Event — Event

dispatchEventWith () method
public function dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void

派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。

Parameters

type:String — 事件类型
bubbles:Boolean (default = false) — 是否冒泡，默认false
data:Object (default = null) — 附加数据(可选)

hasEventListener () method
public function hasEventListener(type:String):Boolean

判断是否具备指定的事件类型的侦听器。

Parameters

type:String — 事件类型

Returns
Boolean
removeEventListener () method
public function removeEventListener(type:String, listener:Function):void

在指定的对象上删除一个事件侦听器。

Parameters

type:String — 事件类型
listener:Function — 侦听器

removeEventListeners () method
public function removeEventListeners(type:String = null):void

根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。

Parameters

type:String (default = null)


starling.events.KeyboardEvent

KeyboardEvent | Properties | Methods | Constants
Package | starling.events
Class | public class KeyboardEvent
Inheritance | KeyboardEvent Inheritance Event Inheritance Object

一个键盘事件的派发，是对用户使用键盘输入的回应。

这个类是Flash的键盘事件的Starling版本。它包含了和Flash的键盘事件相同的属性。

要捕获键盘事件，需要在Starling的stage上添加事件侦听。stage的子节点是不能获取到键盘事件的。 Starling并没有像传统Flash那样的“焦点”的概念。

See also

starling.display.Stage

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | altKey : Boolean [read-only] 判断Alt键（Windows或Linux）或Option键（Mac OS）是否被激活。按下为true，松开为false。 | KeyboardEvent
Inherited | bubbles : Boolean [read-only] 表示事件是否冒泡 | Event
 | charCode : uint [read-only] 按键的字符代码。 | KeyboardEvent
 | ctrlKey : Boolean [read-only] 判断Ctrl键（Windows或Linux）或Ctrl/Command键（Mac OS）是否被激活，按下为true，松开为false。 | KeyboardEvent
Inherited | currentTarget : EventDispatcher [read-only] 当前事件已经冒泡到的对象。 | Event
Inherited | data : Object [read-only] 被添加到事件上的任意数据对象 | Event
 | keyCode : uint [read-only] 按键的标示符号。 | KeyboardEvent
 | keyLocation : uint [read-only] 按键在键盘上的区域。如果一个按键会在键盘上出现多次，这个属性将非常有用 。 | KeyboardEvent
 | shiftKey : Boolean [read-only] 判断Shift键是否被激活，按下为true，松开为false。 | KeyboardEvent
Inherited | target : EventDispatcher [read-only] 派发这个事件的对象。 | Event
Inherited | type : String [read-only] 这个事件的字符串类型。 | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | KeyboardEvent(type:String, charCode:uint = 0, keyCode:uint = 0, keyLocation:uint = 0, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false) 创建一个新的KeyboardEvent实例。 | KeyboardEvent
Inherited | stopImmediatePropagation():void 阻止其他任何侦听器接收事件。 | Event
Inherited | stopPropagation():void 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。 | Event
Inherited | toString():String 返回事件的描述，包括类型及是否冒泡。 | Event
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | ADDED : String = added [static] 事件类型：一个显示对象被添加到了它的父级容器上。 | Event
Inherited | ADDED_TO_STAGE : String = addedToStage [static] 事件类型：一个显示对象被添加到了舞台上。 | Event
Inherited | CANCEL : String = cancel [static] 自定义事件需要的一个事件类型. | Event
Inherited | CHANGE : String = change [static] 自定义事件需要的一个事件类型. | Event
Inherited | CLOSE : String = close [static] 自定义事件需要的一个事件类型. | Event
Inherited | COMPLETE : String = complete [static] 事件类型：可以用在一些表示“完成”的场合。 | Event
Inherited | CONTEXT3D_CREATE : String = context3DCreate [static] 事件类型：表示创建(或重建)了Context3D实例。 | Event
Inherited | ENTER_FRAME : String = enterFrame [static] 事件类型：一个显示对象进入了新的一帧。 | Event
Inherited | FLATTEN : String = flatten [static] 事件类型：一个即将被扁平化的对象派发。 | Event
 | KEY_DOWN : String = keyDown [static] 事件类型：当一个键被按下。 | KeyboardEvent
 | KEY_UP : String = keyUp [static] 事件类型：当一个键被释放。 | KeyboardEvent
Inherited | OPEN : String = open [static] 自定义事件需要的一个事件类型. | Event
Inherited | REMOVED : String = removed [static] 事件类型：一个显示对象从它的父级删除 | Event
Inherited | REMOVED_FROM_STAGE : String = removedFromStage [static] 事件类型：一个显示对象从舞台上删除。 | Event
Inherited | REMOVE_FROM_JUGGLER : String = removeFromJuggler [static] 事件类型：当一个动画对象需要被Juggler删除的时候派发 | Event
Inherited | RESIZE : String = resize [static] 事件类型：Flash Player尺寸改变。 | Event
Inherited | ROOT_CREATED : String = rootCreated [static] 事件类型：表示最顶层的显示对象已被创建。 | Event
Inherited | SCROLL : String = scroll [static] 自定义事件需要的一个事件类型. | Event
Inherited | SELECT : String = select [static] 自定义事件需要的一个事件类型. | Event
Inherited | TRIGGERED : String = triggered [static] 事件类型：按钮点击。 | Event
Property Detail
altKey property
altKey:Boolean [read-only]

判断Alt键（Windows或Linux）或Option键（Mac OS）是否被激活。按下为true，松开为false。

Implementation
    public function get altKey():Boolean
charCode property
charCode:uint [read-only]

按键的字符代码。

Implementation
    public function get charCode():uint
ctrlKey property
ctrlKey:Boolean [read-only]

判断Ctrl键（Windows或Linux）或Ctrl/Command键（Mac OS）是否被激活，按下为true，松开为false。

Implementation
    public function get ctrlKey():Boolean
keyCode property
keyCode:uint [read-only]

按键的标示符号。

Implementation
    public function get keyCode():uint
keyLocation property
keyLocation:uint [read-only]

按键在键盘上的区域。如果一个按键会在键盘上出现多次，这个属性将非常有用 。

Implementation
    public function get keyLocation():uint

See also

Keylocation
shiftKey property
shiftKey:Boolean [read-only]

判断Shift键是否被激活，按下为true，松开为false。

Implementation
    public function get shiftKey():Boolean
Constructor Detail
KeyboardEvent () Constructor
public function KeyboardEvent(type:String, charCode:uint = 0, keyCode:uint = 0, keyLocation:uint = 0, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false)

创建一个新的KeyboardEvent实例。

Parameters
type:String
charCode:uint (default = 0)
keyCode:uint (default = 0)
keyLocation:uint (default = 0)
ctrlKey:Boolean (default = false)
altKey:Boolean (default = false)
shiftKey:Boolean (default = false)
Constant Detail
KEY_DOWN Constant
public static const KEY_DOWN:String = keyDown

事件类型：当一个键被按下。

KEY_UP Constant
public static const KEY_UP:String = keyUp

事件类型：当一个键被释放。


starling.events.ResizeEvent

ResizeEvent | Properties | Methods | Constants
Package | starling.events
Class | public class ResizeEvent
Inheritance | ResizeEvent Inheritance Event Inheritance Object

当Flash容器的尺寸改变后，stage会派发一个ResizeEvent。用这个值可以更新Starling的视口和stage的尺寸。

事件的属性包含了更新后的Flash Player的宽度和高度。如果您希望缩放stage上的内容来充满屏幕， 请更新 Starling.current.viewPort 矩形区域。如果您希望使用额外的屏幕区域， 请更新 stage.stageWidth 和 stage.stageHeight

See also

starling.display.Stage
starling.core.Starling

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | bubbles : Boolean [read-only] 表示事件是否冒泡 | Event
Inherited | currentTarget : EventDispatcher [read-only] 当前事件已经冒泡到的对象。 | Event
Inherited | data : Object [read-only] 被添加到事件上的任意数据对象 | Event
 | height : int [read-only] 播放器更新后的高度。 | ResizeEvent
Inherited | target : EventDispatcher [read-only] 派发这个事件的对象。 | Event
Inherited | type : String [read-only] 这个事件的字符串类型。 | Event
 | width : int [read-only] 播放器更新后的宽度。 | ResizeEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ResizeEvent(type:String, width:int, height:int, bubbles:Boolean = false) 创建一个新的ResizeEvent实例。 | ResizeEvent
Inherited | stopImmediatePropagation():void 阻止其他任何侦听器接收事件。 | Event
Inherited | stopPropagation():void 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。 | Event
Inherited | toString():String 返回事件的描述，包括类型及是否冒泡。 | Event
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | ADDED : String = added [static] 事件类型：一个显示对象被添加到了它的父级容器上。 | Event
Inherited | ADDED_TO_STAGE : String = addedToStage [static] 事件类型：一个显示对象被添加到了舞台上。 | Event
Inherited | CANCEL : String = cancel [static] 自定义事件需要的一个事件类型. | Event
Inherited | CHANGE : String = change [static] 自定义事件需要的一个事件类型. | Event
Inherited | CLOSE : String = close [static] 自定义事件需要的一个事件类型. | Event
Inherited | COMPLETE : String = complete [static] 事件类型：可以用在一些表示“完成”的场合。 | Event
Inherited | CONTEXT3D_CREATE : String = context3DCreate [static] 事件类型：表示创建(或重建)了Context3D实例。 | Event
Inherited | ENTER_FRAME : String = enterFrame [static] 事件类型：一个显示对象进入了新的一帧。 | Event
Inherited | FLATTEN : String = flatten [static] 事件类型：一个即将被扁平化的对象派发。 | Event
Inherited | OPEN : String = open [static] 自定义事件需要的一个事件类型. | Event
Inherited | REMOVED : String = removed [static] 事件类型：一个显示对象从它的父级删除 | Event
Inherited | REMOVED_FROM_STAGE : String = removedFromStage [static] 事件类型：一个显示对象从舞台上删除。 | Event
Inherited | REMOVE_FROM_JUGGLER : String = removeFromJuggler [static] 事件类型：当一个动画对象需要被Juggler删除的时候派发 | Event
 | RESIZE : String = resize [static] 事件类型：Flash Player尺寸改变。 | ResizeEvent
Inherited | ROOT_CREATED : String = rootCreated [static] 事件类型：表示最顶层的显示对象已被创建。 | Event
Inherited | SCROLL : String = scroll [static] 自定义事件需要的一个事件类型. | Event
Inherited | SELECT : String = select [static] 自定义事件需要的一个事件类型. | Event
Inherited | TRIGGERED : String = triggered [static] 事件类型：按钮点击。 | Event
Property Detail
height property
height:int [read-only]

播放器更新后的高度。

Implementation
    public function get height():int
width property
width:int [read-only]

播放器更新后的宽度。

Implementation
    public function get width():int
Constructor Detail
ResizeEvent () Constructor
public function ResizeEvent(type:String, width:int, height:int, bubbles:Boolean = false)

创建一个新的ResizeEvent实例。

Parameters
type:String
width:int
height:int
bubbles:Boolean (default = false)
Constant Detail
RESIZE Constant
public static const RESIZE:String = resize

事件类型：Flash Player尺寸改变。


starling.events.Touch

Touch | Properties | Methods
Package | starling.events
Class | public class Touch
Inheritance | Touch Inheritance Object

一个Touch对象包含了在屏幕上的一个手指或鼠标的相关信息（出现或移动）。

您将从TouchEvent中获取这个对象。当这样的事件被触发，您可以查询目前呈现在屏幕上的所有触碰。 一个Touch对象，包含了一个单指触碰的信息。一个Touch对象总是会通过TouchPhases的集合移动。请参阅TouchPhase类来获取更多信息。

触碰的位置

您可以用相应的属性，获取坐标系上的当前的和上一个位置。当然，在大部分情况下您希望能获取在一个不同的坐标系上的位置。 基于这个原因，这里有一些方法可以转换当前的和上一个位置到任何对象的局部坐标系。

See also

TouchEvent
TouchPhase

Public Properties
Property |  | Defined By
 | globalX : Number [read-only] touch对象在stage坐标系的X坐标值。 | Touch
 | globalY : Number [read-only] touch对象在stage坐标系的Y坐标值。 | Touch
 | height : Number [read-only] 压力区域的高度。如果设备不支持压力，则这个值永远是1.0. | Touch
 | id : int [read-only] 一个Touch对象的唯一标示. | Touch
 | phase : String [read-only] 当前触碰所处的阶段。 | Touch
 | pressure : Number [read-only] 触摸在设备上的压力值（从0.0到1.0）。如果设备不支持压力，则这个值永远是1.0 | Touch
 | previousGlobalX : Number [read-only] touch对象的上一个位置在stage坐标系的X坐标值。 | Touch
 | previousGlobalY : Number [read-only] touch对象的上一个位置在stage坐标系的Y坐标值。 | Touch
 | tapCount : int [read-only] 手指在很短的时间内触碰屏幕的次数。可以用来判断双击等情况。 | Touch
 | target : DisplayObject [read-only] 发生触碰的显示对象。 | Touch
 | timestamp : Number [read-only] 触碰发生时的时间（以秒为单位，自应用程序启动时算起）。 | Touch
 | width : Number [read-only] 压力区域的宽度。如果设备不支持压力，则这个值永远是1.0. | Touch
Public Methods
Method |  | Defined By
 | Touch(id:int, globalX:Number, globalY:Number, phase:String, target:DisplayObject) 创建一个新的Touch对象。 | Touch
 | clone():Touch 创建这个一个Touch对象的副本 | Touch
 | getLocation(space:DisplayObject, resultPoint:Point = null):Point 转换当前touch的位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。 | Touch
 | getMovement(space:DisplayObject, resultPoint:Point = null):Point 返回从上一个位置到当前位置移动的距离。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。 | Touch
 | getPreviousLocation(space:DisplayObject, resultPoint:Point = null):Point 转换touch的上一个位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。 | Touch
 | isTouching(target:DisplayObject):Boolean 判断一个对象或它的子级显示对象是否被触碰了。 | Touch
 | toString():String 返回这个对象的描述。 | Touch
Property Detail
globalX property
globalX:Number [read-only]

touch对象在stage坐标系的X坐标值。

Implementation
    public function get globalX():Number
globalY property
globalY:Number [read-only]

touch对象在stage坐标系的Y坐标值。

Implementation
    public function get globalY():Number
height property
height:Number [read-only]

压力区域的高度。如果设备不支持压力，则这个值永远是1.0.

Implementation
    public function get height():Number
id property
id:int [read-only]

一个Touch对象的唯一标示. '0' 代表鼠标事件, 正数用于touch事件。

Implementation
    public function get id():int
phase property
phase:String [read-only]

当前触碰所处的阶段。

Implementation
    public function get phase():String

See also

TouchPhase
pressure property
pressure:Number [read-only]

触摸在设备上的压力值（从0.0到1.0）。如果设备不支持压力，则这个值永远是1.0

Implementation
    public function get pressure():Number
previousGlobalX property
previousGlobalX:Number [read-only]

touch对象的上一个位置在stage坐标系的X坐标值。

Implementation
    public function get previousGlobalX():Number
previousGlobalY property
previousGlobalY:Number [read-only]

touch对象的上一个位置在stage坐标系的Y坐标值。

Implementation
    public function get previousGlobalY():Number
tapCount property
tapCount:int [read-only]

手指在很短的时间内触碰屏幕的次数。可以用来判断双击等情况。

Implementation
    public function get tapCount():int
target property
target:DisplayObject [read-only]

发生触碰的显示对象。

Implementation
    public function get target():DisplayObject
timestamp property
timestamp:Number [read-only]

触碰发生时的时间（以秒为单位，自应用程序启动时算起）。

Implementation
    public function get timestamp():Number
width property
width:Number [read-only]

压力区域的宽度。如果设备不支持压力，则这个值永远是1.0.

Implementation
    public function get width():Number
Constructor Detail
Touch () Constructor
public function Touch(id:int, globalX:Number, globalY:Number, phase:String, target:DisplayObject)

创建一个新的Touch对象。

Parameters
id:int — ID
globalX:Number — 全局X坐标
globalY:Number — 全局Y坐标
phase:String — 触碰阶段
target:DisplayObject — 目标对象
Method Detail
clone () method
public function clone():Touch

创建这个一个Touch对象的副本

Returns
Touch
getLocation () method
public function getLocation(space:DisplayObject, resultPoint:Point = null):Point

转换当前touch的位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。

Parameters

space:DisplayObject — 坐标系对象
resultPoint:Point (default = null) — 可选Point值

Returns
Point
getMovement () method
public function getMovement(space:DisplayObject, resultPoint:Point = null):Point

返回从上一个位置到当前位置移动的距离。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。

Parameters

space:DisplayObject — 坐标系对象
resultPoint:Point (default = null) — 可选Point值

Returns
Point
getPreviousLocation () method
public function getPreviousLocation(space:DisplayObject, resultPoint:Point = null):Point

转换touch的上一个位置到一个显示对象的局部坐标系。 如果你传递一个 resultPoint ，此方法的返回值会存储于这个Point对象中，而不是创建一个新的对象。

Parameters

space:DisplayObject — 坐标系对象
resultPoint:Point (default = null) — 可选Point值

Returns
Point
isTouching () method
public function isTouching(target:DisplayObject):Boolean

判断一个对象或它的子级显示对象是否被触碰了。

Parameters

target:DisplayObject — 目标对象

Returns
Boolean
toString () method
public function toString():String

返回这个对象的描述。

Returns
String


starling.events.TouchEvent

TouchEvent | Properties | Methods | Constants
Package | starling.events
Class | public class TouchEvent
Inheritance | TouchEvent Inheritance Event Inheritance Object

一个TouchEvent是被手指触碰或鼠标输入来触发的。

在Starling中，无论是触碰事件还是鼠标事件，都统一封装为一个类：TouchEvent。 要处理用户在一个可触碰的屏幕或使用鼠标完成的输入， 您需要注册一个事件侦听器，来侦听类型是TouchEvent.TOUCH的事件。 这是唯一的您需要捕获的事件类型； 原有Flash里面的那个很长的事件类型列表，全都被映射到一个"TouchPhases"里面。

鼠标输入和触摸屏输入的区别是：

  • 在某一时刻只有一个鼠标光标可以呈现
  • 只有鼠标才可以"hover",即在没有按下按键的情况下滑过一个对象。
哪些对象能够接收触碰事件？

在Starling中，任何一个显示对象都可以接受触碰事件，只要它的 touchable 属性，以及它的父级都是可用状态(true)。 在Starling中是没有"InteractiveObject"这个类的。

如何使用单个触碰对象

T事件包含了一个包括所有的触碰对象的列表。每一个独立的触碰都被保存在一个类型是"Touch"的对象里。 既然您通常只对在特定对象上发生的触碰感兴趣，您可以查询事件，传入一个具体的目标：

var touches:Vector.<Touch> = touchEvent.getTouches(this);

这会返回附加在"this"或 它的子级上的所有触碰对象。如果您没有使用多点触碰，您也可以直接访问触碰对象，就像这样：

var touch:Touch = touchEvent.getTouch(this);

See also

Touch
TouchPhase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | bubbles : Boolean [read-only] 表示事件是否冒泡 | Event
 | ctrlKey : Boolean [read-only] 表示，事件发生时ctrl键是否被按下。 (Mac OS: Cmd 或 Ctrl) | TouchEvent
Inherited | currentTarget : EventDispatcher [read-only] 当前事件已经冒泡到的对象。 | Event
Inherited | data : Object [read-only] 被添加到事件上的任意数据对象 | Event
 | shiftKey : Boolean [read-only] 表示，事件发生时shift键是否被按下。 | TouchEvent
Inherited | target : EventDispatcher [read-only] 派发这个事件的对象。 | Event
 | timestamp : Number [read-only] 事件发生的时间（单位是秒，自应用启动时算起）。 | TouchEvent
 | touches : Vector.<Touch> [read-only] 当前可用的所有触碰对象。 | TouchEvent
Inherited | type : String [read-only] 这个事件的字符串类型。 | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TouchEvent(type:String, touches:Vector.<Touch>, shiftKey:Boolean = false, ctrlKey:Boolean = false, bubbles:Boolean = true) 创建一个新的TouchEvent实例。 | TouchEvent
 | getTouch(target:DisplayObject, phase:String = null):Touch 返回附加到指定对象上的一个触碰对象。 | TouchEvent
 | getTouches(target:DisplayObject, phase:String = null, result:Vector.<Touch> = null):Vector.<Touch> 返回附加在指定的对象上的触碰对象数组。如果你传递一个'result'数组，那么会将touch对象添加到这个数组中来代替创建一个新的数组。 | TouchEvent
 | interactsWith(target:DisplayObject):Boolean 判断目标显示对象是否正在被触碰或被鼠标滑过。 | TouchEvent
Inherited | stopImmediatePropagation():void 阻止其他任何侦听器接收事件。 | Event
Inherited | stopPropagation():void 阻止事件进入下一个冒泡阶段，从而阻止它被下一个对象接收。 | Event
Inherited | toString():String 返回事件的描述，包括类型及是否冒泡。 | Event
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined By
Inherited | ADDED : String = added [static] 事件类型：一个显示对象被添加到了它的父级容器上。 | Event
Inherited | ADDED_TO_STAGE : String = addedToStage [static] 事件类型：一个显示对象被添加到了舞台上。 | Event
Inherited | CANCEL : String = cancel [static] 自定义事件需要的一个事件类型. | Event
Inherited | CHANGE : String = change [static] 自定义事件需要的一个事件类型. | Event
Inherited | CLOSE : String = close [static] 自定义事件需要的一个事件类型. | Event
Inherited | COMPLETE : String = complete [static] 事件类型：可以用在一些表示“完成”的场合。 | Event
Inherited | CONTEXT3D_CREATE : String = context3DCreate [static] 事件类型：表示创建(或重建)了Context3D实例。 | Event
Inherited | ENTER_FRAME : String = enterFrame [static] 事件类型：一个显示对象进入了新的一帧。 | Event
Inherited | FLATTEN : String = flatten [static] 事件类型：一个即将被扁平化的对象派发。 | Event
Inherited | OPEN : String = open [static] 自定义事件需要的一个事件类型. | Event
Inherited | REMOVED : String = removed [static] 事件类型：一个显示对象从它的父级删除 | Event
Inherited | REMOVED_FROM_STAGE : String = removedFromStage [static] 事件类型：一个显示对象从舞台上删除。 | Event
Inherited | REMOVE_FROM_JUGGLER : String = removeFromJuggler [static] 事件类型：当一个动画对象需要被Juggler删除的时候派发 | Event
Inherited | RESIZE : String = resize [static] 事件类型：Flash Player尺寸改变。 | Event
Inherited | ROOT_CREATED : String = rootCreated [static] 事件类型：表示最顶层的显示对象已被创建。 | Event
Inherited | SCROLL : String = scroll [static] 自定义事件需要的一个事件类型. | Event
Inherited | SELECT : String = select [static] 自定义事件需要的一个事件类型. | Event
 | TOUCH : String = touch [static] 触碰或鼠标输入的事件类型。 | TouchEvent
Inherited | TRIGGERED : String = triggered [static] 事件类型：按钮点击。 | Event
Property Detail
ctrlKey property
ctrlKey:Boolean [read-only]

表示，事件发生时ctrl键是否被按下。 (Mac OS: Cmd 或 Ctrl)

Implementation
    public function get ctrlKey():Boolean
shiftKey property
shiftKey:Boolean [read-only]

表示，事件发生时shift键是否被按下。

Implementation
    public function get shiftKey():Boolean
timestamp property
timestamp:Number [read-only]

事件发生的时间（单位是秒，自应用启动时算起）。

Implementation
    public function get timestamp():Number
touches property
touches:Vector.<Touch> [read-only]

当前可用的所有触碰对象。

Implementation
    public function get touches():Vector.<Touch>
Constructor Detail
TouchEvent () Constructor
public function TouchEvent(type:String, touches:Vector.<Touch>, shiftKey:Boolean = false, ctrlKey:Boolean = false, bubbles:Boolean = true)

创建一个新的TouchEvent实例。

Parameters
type:String — 事件类型
touches:Vector.<Touch> — 触碰对象数组
shiftKey:Boolean (default = false) — 是否按下了shift键
ctrlKey:Boolean (default = false) — 是否按下了ctrl键
bubbles:Boolean (default = true) — 是否冒泡
Method Detail
getTouch () method
public function getTouch(target:DisplayObject, phase:String = null):Touch

返回附加到指定对象上的一个触碰对象。

Parameters

target:DisplayObject — 目标对象
phase:String (default = null) — 阶段

Returns
Touch
getTouches () method
public function getTouches(target:DisplayObject, phase:String = null, result:Vector.<Touch> = null):Vector.<Touch>

返回附加在指定的对象上的触碰对象数组。如果你传递一个'result'数组，那么会将touch对象添加到这个数组中来代替创建一个新的数组。

Parameters

target:DisplayObject — 目标对象
phase:String (default = null) — 阶段
result:Vector.<Touch> (default = null) — 传递数组

Returns
Vector.<Touch> — Touch数组
interactsWith () method
public function interactsWith(target:DisplayObject):Boolean

判断目标显示对象是否正在被触碰或被鼠标滑过。

Parameters

target:DisplayObject

Returns
Boolean
Constant Detail
TOUCH Constant
public static const TOUCH:String = touch

触碰或鼠标输入的事件类型。


starling.events.TouchPhase

TouchPhase | Constants
Package | starling.events
Class | public final class TouchPhase
Inheritance | TouchPhase Inheritance Object

这个类提供了描述触碰的各个阶段的常量值。

一个触碰，在它的生命周期内会遵循下面的过程：

BEGAN(开始) -> MOVED(移动) -> ENDED(结束)

此外，一个触碰可能进入一个称之为STATIONARY(静止)的阶段。这一阶段本身不会触发触碰事件，并且它只能发生在多点触控环境。 在某些场合下需要一个解决方案，比如一个手指移动，另一个静止。这个时候，一个触碰事件必须由正在移动的手指下方的对象来派发。 在这个事件的触碰对象列表中，您将会找到第二个处于静止状态的触碰对象。

最后，还有一个称之为HOVER(悬停)的状态，这种情况只会发生在使用鼠标的情况下。 它是由Flash的MouseOver事件触发的，并且这个时候鼠标按键没有被按下。

Public Constants
Constant |  | Defined By
 | BEGAN : String = began [static] 当手指刚刚接触屏幕，或者鼠标按下。 | TouchPhase
 | ENDED : String = ended [static] 手指离开屏幕或鼠标松开。 | TouchPhase
 | HOVER : String = hover [static] 只有鼠标模式下可用：当光标滑过一个对象，并且没有按下鼠标。 | TouchPhase
 | MOVED : String = moved [static] 手指在屏幕上滑动，或者鼠标在按下的情况下在屏幕上滑动。 | TouchPhase
 | STATIONARY : String = stationary [static] 手指或鼠标(按下) 没有移动。 | TouchPhase
Constant Detail
BEGAN Constant
public static const BEGAN:String = began

当手指刚刚接触屏幕，或者鼠标按下。

ENDED Constant
public static const ENDED:String = ended

手指离开屏幕或鼠标松开。

HOVER Constant
public static const HOVER:String = hover

只有鼠标模式下可用：当光标滑过一个对象，并且没有按下鼠标。

MOVED Constant
public static const MOVED:String = moved

手指在屏幕上滑动，或者鼠标在按下的情况下在屏幕上滑动。

STATIONARY Constant
public static const STATIONARY:String = stationary

手指或鼠标(按下) 没有移动。


starling.filters - Starling API 1.3 | Starling中文站

Package starling.filters

Classes
BlurFilter
ColorMatrixFilter
FragmentFilter
FragmentFilterMode


starling.filters Summary

starling.filters | Classes

Classes
Class | Description
BlurFilter | BlurFilter用于在一个对象上创建高斯模糊效果。可以分别在x轴和y轴的方向上设置模糊的强度（全局坐标系）。 也可以设置为一个阴影或外发光滤镜。使用特定的静态方法来创建特定的滤镜。
ColorMatrixFilter | ColorMatrixFilter(颜色矩阵滤镜)允许你为输入图片的每个像素的RGBA颜色值和透明度，应用一个4的矩阵变换，来产生一个新的包含RGBA颜色和透明度的数据集。 它允许你调整色相变化，饱和度，亮度调整，以及其它各种效果。 这个类包含了一些用于颜色调整的简便方法。所有这些方法都会改变当前的矩阵，这就意味着你可以很容易的把它们组合在一个滤镜里面: //用50%的饱和度和180度的色相旋转创建一个翻转滤镜 var filter:ColorMatrixFilter = new ColorMatrixFilter(); filter.invert(); filter.adjustSaturation(-0.5); filter.adjustHue(1.0); 如果你希望让颜色的变化产生动画效果，就在每一步重置滤镜，或者在每一步使用相同的调整值；这个改变就会逐渐累加。
FragmentFilter | FragmentFilter(片段滤镜)类是Starling中所有滤镜效果的基类。这个包中所有的其它滤镜都是扩展自这个类。 你可以通过使用属性'filter'，将这些滤镜附加到任何显示对象上。 一个片段滤镜是通过如下的方式工作的: 应用滤镜的对象会被渲染到一个纹理上 (在全局坐标系下). 然后这个纹理会被传递给第一个滤镜处理通道。 每一个通道使用片段着色器(或者额外再加一个顶点着色器)来处理纹理，实现特定的效果。 每一个通道的输出，将会作为下一个通道的输入。如果它是最终的通道，就会把它直接渲染到后台缓冲区。 所有的这些过程，都被抽象类FragmentFilter定义了。所有的子类只需要覆盖这几个方法： 'createPrograms', 'activate' 和 (可选) 'deactivate'，来创建和执行它的自定义着色代码。 每一个滤镜可以设置为取代原来的显示对象，或在显示对象的上层或下层绘制。这取决于'mode'属性的设置，可选值定义在'FragmentFilterMode'这个类中。 需要注意的是，在同一时刻，每一个滤镜只能应用于一个显示对象。否则，它就会变的很慢，需要更多的资源和缓存，并导致无法预料的后果。
FragmentFilterMode | 这个类提供了一些静态变量来表示滤镜模式。 这些值用于FragmentFilter.mode属性，并且定义一个滤镜和一个原有对象结合后的呈现结果。


starling.filters.BlurFilter

BlurFilter | Properties | Methods
Package | starling.filters
Class | public class BlurFilter
Inheritance | BlurFilter Inheritance FragmentFilter Inheritance Object

BlurFilter用于在一个对象上创建高斯模糊效果。可以分别在x轴和y轴的方向上设置模糊的强度（全局坐标系）。 也可以设置为一个阴影或外发光滤镜。使用特定的静态方法来创建特定的滤镜。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | blurX : Number 在x轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。 | BlurFilter
 | blurY : Number 在y轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。 | BlurFilter
Inherited | isCached : Boolean [read-only] 判断滤镜是否被缓存了 (通过"cache" 方法). | FragmentFilter
Inherited | mode : String 滤镜模式, 由"FragmentFilterMode" 定义。 | FragmentFilter
Inherited | offsetX : Number 滤镜的左右偏移量. | FragmentFilter
Inherited | offsetY : Number 滤镜的上下偏移量 | FragmentFilter
Inherited | resolution : Number 滤镜纹理的分辨率。"1"代表stage分辨率，"0.5"代表stage分辨率的一半。一个较小的分辨率，可以节省存储空间和执行时间(取决于GPU)， 但是输出质量会降低。如果数值大于1也是允许的；当过滤器缩放时，这样的值可能是有意义的。 | FragmentFilter
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | baseTextureID : int 输入纹理的ID(取样器)，包含上一个通道的输出 | FragmentFilter
Inherited | marginX : Number x余量将会沿着X的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
Inherited | marginY : Number y余量将会沿着Y的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
Inherited | mvpConstantID : int 模型投影常数(4矩阵)的第一个寄存器ID | FragmentFilter
Inherited | numPasses : int 滤镜应用的通道数量. | FragmentFilter
Inherited | texCoordsAtID : int 存储了顶点坐标的顶点缓冲区属性的ID | FragmentFilter
Inherited | vertexPosAtID : int 存储了顶点位置的顶点缓冲区属性的ID | FragmentFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | BlurFilter(blurX:Number = 1, blurY:Number = 1, resolution:Number = 1) 创建一个新的BlurFilter对象。对每个模糊的方向，所需的通道数量是Math.ceil(blur)。 blur = 0.5: 1 pass blur = 1.0: 1 pass blur = 1.5: 2 passes blur = 2.0: 2 passes etc. 你应该考虑降低分辨率，来代替提高通道的数量。较低的分辨率也会产生虚化的图像，并且这样可以同时降低渲染的成本。 | BlurFilter
Inherited | cache():void 缓存滤镜输出到一个纹理。一个没有缓存的滤镜，会在每一帧进行渲染；而一个缓存的滤镜则只需要渲染一次。 当然，如果应用滤镜的对象或滤镜设置改变了，缓存也应该被更新；要做到这一点，可以再次调用'cache'方法。 | FragmentFilter
Inherited | clearCache():void 清理滤镜的缓存输出。在这个方法调用后，滤镜将会在每帧执行一次。 | FragmentFilter
 | createDropShadow(distance:Number = 4.0, angle:Number = 0.785, color:uint = 0x0, alpha:Number = 0.5, blur:Number = 1.0, resolution:Number = 0.5):BlurFilter [static] 创建一个模糊滤镜，并设置为阴影的效果。 | BlurFilter
 | createGlow(color:uint = 0xffff00, alpha:Number = 1.0, blur:Number = 1.0, resolution:Number = 0.5):BlurFilter [static] 创建一个模糊滤镜，并设置为外发光的效果。 | BlurFilter
 | dispose():void [override] 销毁滤镜 (着色程序, 缓冲区, 纹理). | BlurFilter
Inherited | render(object:DisplayObject, support:RenderSupport, parentAlpha:Number):void 在指定的显示对象上应用滤镜，渲染输出结果到当前的渲染目标上。当Starling渲染一个附加了滤镜的对象时，会自动调用这个方法。 | FragmentFilter
 | setUniformColor(enable:Boolean, color:uint = 0x0, alpha:Number = 1.0):void 使用同一颜色，将替换输入颜色的RGB值，并且透明度值将和指定的系数相乘。 在第一个参数上传递false，就可以取消同一颜色的效果。 | BlurFilter
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | activate(pass:int, context:Context3D, texture:Texture):void 子类必须覆盖这个方法，并且使用它来实现他们自己的片段和顶点着色程序。 'activate'方法的调用先于'context.drawTriangles'方法的调用。根据你的滤镜的需要设置上下文。下面的常量和属性会被自动设置： vertex constants 0-3: mvpMatrix (3D) vertex attribute 0: vertex position (FLOAT_2) vertex attribute 1: texture coordinates (FLOAT_2) texture 0: input texture | FragmentFilter
Inherited | assembleAgal(fragmentShader:String = null, vertexShader:String = null):Program3D 将字符串格式的片段和顶点着色代码汇编到一个Program3D对象。如果有任何参数是null，就会采用默认值（STD_FRAGMENT_SHADER或STD_VERTEX_SHADER）来替代。 | FragmentFilter
Inherited | createPrograms():void 子类必须覆盖这个方法，并且使用它来创建他们自己的片段和顶点着色程序 | FragmentFilter
Inherited | deactivate(pass:int, context:Context3D, texture:Texture):void 这个方法会在'context.drawTriangles'方法调用之后，被调用。如果你需要做一些诸如清理资源的工作，可以在这个方法里面来做。 | FragmentFilter
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | PMA : Boolean = true 所有的滤镜处理预计都会使用预乘透明度 | FragmentFilter
Inherited | STD_FRAGMENT_SHADER : String = tex oc, v0, fs0 <2d, clamp, linear, mipnone> 标准的片段着色器代码. | FragmentFilter
Inherited | STD_VERTEX_SHADER : String 标准的顶点着色代码。如果你没有创建自定义的顶点着色器，就会自动使用这个标准的着色代码。 | FragmentFilter
Property Detail
blurX property
blurX:Number

在x轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number

在y轴方向上的模糊系数(全局坐标系)。所需的通道数量将会是Math.ceil(value)。

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
Constructor Detail
BlurFilter () Constructor
public function BlurFilter(blurX:Number = 1, blurY:Number = 1, resolution:Number = 1)

创建一个新的BlurFilter对象。对每个模糊的方向，所需的通道数量是Math.ceil(blur)。

  • blur = 0.5: 1 pass
  • blur = 1.0: 1 pass
  • blur = 1.5: 2 passes
  • blur = 2.0: 2 passes
  • etc.

你应该考虑降低分辨率，来代替提高通道的数量。较低的分辨率也会产生虚化的图像，并且这样可以同时降低渲染的成本。

Parameters
blurX:Number (default = 1) — x强度
blurY:Number (default = 1) — y强度
resolution:Number (default = 1) — 分辨率
Method Detail
createDropShadow () method
public static function createDropShadow(distance:Number = 4.0, angle:Number = 0.785, color:uint = 0x0, alpha:Number = 0.5, blur:Number = 1.0, resolution:Number = 0.5):BlurFilter

创建一个模糊滤镜，并设置为阴影的效果。

Parameters

distance:Number (default = 4.0) — 距离
angle:Number (default = 0.785) — 角度
color:uint (default = 0x0) — 颜色
alpha:Number (default = 0.5) — 透明度
blur:Number (default = 1.0) — 模糊参数
resolution:Number (default = 0.5) — 分辨率

Returns
BlurFilter — BlurFilter
createGlow () method
public static function createGlow(color:uint = 0xffff00, alpha:Number = 1.0, blur:Number = 1.0, resolution:Number = 0.5):BlurFilter

创建一个模糊滤镜，并设置为外发光的效果。

Parameters

color:uint (default = 0xffff00) — 颜色
alpha:Number (default = 1.0) — 透明度
blur:Number (default = 1.0) — 模糊参数
resolution:Number (default = 0.5) — 分辨率

Returns
BlurFilter — BlurFilter
dispose () method
override public function dispose():void

销毁滤镜 (着色程序, 缓冲区, 纹理).

setUniformColor () method
public function setUniformColor(enable:Boolean, color:uint = 0x0, alpha:Number = 1.0):void

使用同一颜色，将替换输入颜色的RGB值，并且透明度值将和指定的系数相乘。 在第一个参数上传递false，就可以取消同一颜色的效果。

Parameters

enable:Boolean — 激活还是取消
color:uint (default = 0x0) — 颜色值
alpha:Number (default = 1.0) — 透明度


starling.filters.ColorMatrixFilter

ColorMatrixFilter | Properties | Methods
Package | starling.filters
Class | public class ColorMatrixFilter
Inheritance | ColorMatrixFilter Inheritance FragmentFilter Inheritance Object

ColorMatrixFilter(颜色矩阵滤镜)允许你为输入图片的每个像素的RGBA颜色值和透明度，应用一个4的矩阵变换，来产生一个新的包含RGBA颜色和透明度的数据集。 它允许你调整色相变化，饱和度，亮度调整，以及其它各种效果。

这个类包含了一些用于颜色调整的简便方法。所有这些方法都会改变当前的矩阵，这就意味着你可以很容易的把它们组合在一个滤镜里面:

      //用50%的饱和度和180度的色相旋转创建一个翻转滤镜
      var filter:ColorMatrixFilter = new ColorMatrixFilter();
      filter.invert();
      filter.adjustSaturation(-0.5);
      filter.adjustHue(1.0);

如果你希望让颜色的变化产生动画效果，就在每一步重置滤镜，或者在每一步使用相同的调整值；这个改变就会逐渐累加。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | isCached : Boolean [read-only] 判断滤镜是否被缓存了 (通过"cache" 方法). | FragmentFilter
 | matrix : Vector.<Number> 拥有20个项的 4x5 矩阵. | ColorMatrixFilter
Inherited | mode : String 滤镜模式, 由"FragmentFilterMode" 定义。 | FragmentFilter
Inherited | offsetX : Number 滤镜的左右偏移量. | FragmentFilter
Inherited | offsetY : Number 滤镜的上下偏移量 | FragmentFilter
Inherited | resolution : Number 滤镜纹理的分辨率。"1"代表stage分辨率，"0.5"代表stage分辨率的一半。一个较小的分辨率，可以节省存储空间和执行时间(取决于GPU)， 但是输出质量会降低。如果数值大于1也是允许的；当过滤器缩放时，这样的值可能是有意义的。 | FragmentFilter
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined By
Inherited | baseTextureID : int 输入纹理的ID(取样器)，包含上一个通道的输出 | FragmentFilter
Inherited | marginX : Number x余量将会沿着X的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
Inherited | marginY : Number y余量将会沿着Y的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
Inherited | mvpConstantID : int 模型投影常数(4矩阵)的第一个寄存器ID | FragmentFilter
Inherited | numPasses : int 滤镜应用的通道数量. | FragmentFilter
Inherited | texCoordsAtID : int 存储了顶点坐标的顶点缓冲区属性的ID | FragmentFilter
Inherited | vertexPosAtID : int 存储了顶点位置的顶点缓冲区属性的ID | FragmentFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | ColorMatrixFilter(matrix:Vector.<Number> = null) 根据传入的矩阵创建一个新的ColorMatrixFilter实例。 | ColorMatrixFilter
 | adjustBrightness(value:Number):void 改变亮度。可选区间是(-1,1)。大于0的值会提高亮度，小于0的值会降低亮度。 | ColorMatrixFilter
 | adjustContrast(value:Number):void 改变对比度。可选区间是(-1,1)。大于0的值会提高对比度，小于0的值会降低对比度。 | ColorMatrixFilter
 | adjustHue(value:Number):void 改变图像的色调. | ColorMatrixFilter
 | adjustSaturation(sat:Number):void 改变饱和度。可选区间是(-1,1)。大于0的值会提高饱和度，小于0的值会降低饱和度。'-1'会产生一个灰度图像。 | ColorMatrixFilter
Inherited | cache():void 缓存滤镜输出到一个纹理。一个没有缓存的滤镜，会在每一帧进行渲染；而一个缓存的滤镜则只需要渲染一次。 当然，如果应用滤镜的对象或滤镜设置改变了，缓存也应该被更新；要做到这一点，可以再次调用'cache'方法。 | FragmentFilter
Inherited | clearCache():void 清理滤镜的缓存输出。在这个方法调用后，滤镜将会在每帧执行一次。 | FragmentFilter
 | concat(matrix:Vector.<Number>):void 将当前矩阵和另一个矩阵合并。 | ColorMatrixFilter
 | dispose():void [override] 销毁滤镜 (着色程序, 缓冲区, 纹理). | ColorMatrixFilter
 | invert():void 翻转颜色 | ColorMatrixFilter
Inherited | render(object:DisplayObject, support:RenderSupport, parentAlpha:Number):void 在指定的显示对象上应用滤镜，渲染输出结果到当前的渲染目标上。当Starling渲染一个附加了滤镜的对象时，会自动调用这个方法。 | FragmentFilter
 | reset():void 重置矩阵 | ColorMatrixFilter
Protected Methods
Show Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined By
Inherited | activate(pass:int, context:Context3D, texture:Texture):void 子类必须覆盖这个方法，并且使用它来实现他们自己的片段和顶点着色程序。 'activate'方法的调用先于'context.drawTriangles'方法的调用。根据你的滤镜的需要设置上下文。下面的常量和属性会被自动设置： vertex constants 0-3: mvpMatrix (3D) vertex attribute 0: vertex position (FLOAT_2) vertex attribute 1: texture coordinates (FLOAT_2) texture 0: input texture | FragmentFilter
Inherited | assembleAgal(fragmentShader:String = null, vertexShader:String = null):Program3D 将字符串格式的片段和顶点着色代码汇编到一个Program3D对象。如果有任何参数是null，就会采用默认值（STD_FRAGMENT_SHADER或STD_VERTEX_SHADER）来替代。 | FragmentFilter
Inherited | createPrograms():void 子类必须覆盖这个方法，并且使用它来创建他们自己的片段和顶点着色程序 | FragmentFilter
Inherited | deactivate(pass:int, context:Context3D, texture:Texture):void 这个方法会在'context.drawTriangles'方法调用之后，被调用。如果你需要做一些诸如清理资源的工作，可以在这个方法里面来做。 | FragmentFilter
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined By
Inherited | PMA : Boolean = true 所有的滤镜处理预计都会使用预乘透明度 | FragmentFilter
Inherited | STD_FRAGMENT_SHADER : String = tex oc, v0, fs0 <2d, clamp, linear, mipnone> 标准的片段着色器代码. | FragmentFilter
Inherited | STD_VERTEX_SHADER : String 标准的顶点着色代码。如果你没有创建自定义的顶点着色器，就会自动使用这个标准的着色代码。 | FragmentFilter
Property Detail
matrix property
matrix:Vector.<Number>

拥有20个项的 4x5 矩阵.

Implementation
    public function get matrix():Vector.<Number>
    public function set matrix(value:Vector.<Number>):void
Constructor Detail
ColorMatrixFilter () Constructor
public function ColorMatrixFilter(matrix:Vector.<Number> = null)

根据传入的矩阵创建一个新的ColorMatrixFilter实例。

Parameters
matrix:Vector.<Number> (default = null) — 包含20个项的4的矩阵
Method Detail
adjustBrightness () method
public function adjustBrightness(value:Number):void

改变亮度。可选区间是(-1,1)。大于0的值会提高亮度，小于0的值会降低亮度。

Parameters

value:Number — 数值

adjustContrast () method
public function adjustContrast(value:Number):void

改变对比度。可选区间是(-1,1)。大于0的值会提高对比度，小于0的值会降低对比度。

Parameters

value:Number — 数值

adjustHue () method
public function adjustHue(value:Number):void

改变图像的色调. 可选区间是(-1,1)。

Parameters

value:Number

adjustSaturation () method
public function adjustSaturation(sat:Number):void

改变饱和度。可选区间是(-1,1)。大于0的值会提高饱和度，小于0的值会降低饱和度。'-1'会产生一个灰度图像。

Parameters

sat:Number — 数值

concat () method
public function concat(matrix:Vector.<Number>):void

将当前矩阵和另一个矩阵合并。

Parameters

matrix:Vector.<Number>

dispose () method
override public function dispose():void

销毁滤镜 (着色程序, 缓冲区, 纹理).

invert () method
public function invert():void

翻转颜色

reset () method
public function reset():void

重置矩阵


starling.filters.FragmentFilter

FragmentFilter | Properties | Methods | Constants
Package | starling.filters
Class | public class FragmentFilter
Inheritance | FragmentFilter Inheritance Object
Subclasses | BlurFilter, ColorMatrixFilter

FragmentFilter(片段滤镜)类是Starling中所有滤镜效果的基类。这个包中所有的其它滤镜都是扩展自这个类。 你可以通过使用属性'filter'，将这些滤镜附加到任何显示对象上。

一个片段滤镜是通过如下的方式工作的:

  1. 应用滤镜的对象会被渲染到一个纹理上 (在全局坐标系下).
  2. 然后这个纹理会被传递给第一个滤镜处理通道。
  3. 每一个通道使用片段着色器(或者额外再加一个顶点着色器)来处理纹理，实现特定的效果。
  4. 每一个通道的输出，将会作为下一个通道的输入。如果它是最终的通道，就会把它直接渲染到后台缓冲区。

所有的这些过程，都被抽象类FragmentFilter定义了。所有的子类只需要覆盖这几个方法： 'createPrograms', 'activate' 和 (可选) 'deactivate'，来创建和执行它的自定义着色代码。 每一个滤镜可以设置为取代原来的显示对象，或在显示对象的上层或下层绘制。这取决于'mode'属性的设置，可选值定义在'FragmentFilterMode'这个类中。

需要注意的是，在同一时刻，每一个滤镜只能应用于一个显示对象。否则，它就会变的很慢，需要更多的资源和缓存，并导致无法预料的后果。

Public Properties
Property |  | Defined By
 | isCached : Boolean [read-only] 判断滤镜是否被缓存了 (通过"cache" 方法). | FragmentFilter
 | mode : String 滤镜模式, 由"FragmentFilterMode" 定义。 | FragmentFilter
 | offsetX : Number 滤镜的左右偏移量. | FragmentFilter
 | offsetY : Number 滤镜的上下偏移量 | FragmentFilter
 | resolution : Number 滤镜纹理的分辨率。"1"代表stage分辨率，"0.5"代表stage分辨率的一半。一个较小的分辨率，可以节省存储空间和执行时间(取决于GPU)， 但是输出质量会降低。如果数值大于1也是允许的；当过滤器缩放时，这样的值可能是有意义的。 | FragmentFilter
Protected Properties
Property |  | Defined By
 | baseTextureID : int 输入纹理的ID(取样器)，包含上一个通道的输出 | FragmentFilter
 | marginX : Number x余量将会沿着X的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
 | marginY : Number y余量将会沿着Y的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。 | FragmentFilter
 | mvpConstantID : int 模型投影常数(4矩阵)的第一个寄存器ID | FragmentFilter
 | numPasses : int 滤镜应用的通道数量. | FragmentFilter
 | texCoordsAtID : int 存储了顶点坐标的顶点缓冲区属性的ID | FragmentFilter
 | vertexPosAtID : int 存储了顶点位置的顶点缓冲区属性的ID | FragmentFilter
Public Methods
Method |  | Defined By
 | FragmentFilter(numPasses:int = 1, resolution:Number = 1.0) 根据指定的通道数量和分辨率，创建一个新的片段滤镜。只有在子类的构造方法中，才能调用这个构造方法。 | FragmentFilter
 | cache():void 缓存滤镜输出到一个纹理。一个没有缓存的滤镜，会在每一帧进行渲染；而一个缓存的滤镜则只需要渲染一次。 当然，如果应用滤镜的对象或滤镜设置改变了，缓存也应该被更新；要做到这一点，可以再次调用'cache'方法。 | FragmentFilter
 | clearCache():void 清理滤镜的缓存输出。在这个方法调用后，滤镜将会在每帧执行一次。 | FragmentFilter
 | dispose():void 销毁滤镜 (着色程序, 缓冲区, 纹理). | FragmentFilter
 | render(object:DisplayObject, support:RenderSupport, parentAlpha:Number):void 在指定的显示对象上应用滤镜，渲染输出结果到当前的渲染目标上。当Starling渲染一个附加了滤镜的对象时，会自动调用这个方法。 | FragmentFilter
Protected Methods
Method |  | Defined By
 | activate(pass:int, context:Context3D, texture:Texture):void 子类必须覆盖这个方法，并且使用它来实现他们自己的片段和顶点着色程序。 'activate'方法的调用先于'context.drawTriangles'方法的调用。根据你的滤镜的需要设置上下文。下面的常量和属性会被自动设置： vertex constants 0-3: mvpMatrix (3D) vertex attribute 0: vertex position (FLOAT_2) vertex attribute 1: texture coordinates (FLOAT_2) texture 0: input texture | FragmentFilter
 | assembleAgal(fragmentShader:String = null, vertexShader:String = null):Program3D 将字符串格式的片段和顶点着色代码汇编到一个Program3D对象。如果有任何参数是null，就会采用默认值（STD_FRAGMENT_SHADER或STD_VERTEX_SHADER）来替代。 | FragmentFilter
 | createPrograms():void 子类必须覆盖这个方法，并且使用它来创建他们自己的片段和顶点着色程序 | FragmentFilter
 | deactivate(pass:int, context:Context3D, texture:Texture):void 这个方法会在'context.drawTriangles'方法调用之后，被调用。如果你需要做一些诸如清理资源的工作，可以在这个方法里面来做。 | FragmentFilter
Protected Constants
Constant |  | Defined By
 | PMA : Boolean = true 所有的滤镜处理预计都会使用预乘透明度 | FragmentFilter
 | STD_FRAGMENT_SHADER : String = tex oc, v0, fs0 <2d, clamp, linear, mipnone> 标准的片段着色器代码. | FragmentFilter
 | STD_VERTEX_SHADER : String 标准的顶点着色代码。如果你没有创建自定义的顶点着色器，就会自动使用这个标准的着色代码。 | FragmentFilter
Property Detail
baseTextureID property
baseTextureID:int

输入纹理的ID(取样器)，包含上一个通道的输出

Implementation
    protected function get baseTextureID():int
    protected function set baseTextureID(value:int):void
isCached property
isCached:Boolean [read-only]

判断滤镜是否被缓存了 (通过"cache" 方法).

Implementation
    public function get isCached():Boolean
marginX property
marginX:Number

x余量将会沿着X的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。

Implementation
    protected function get marginX():Number
    protected function set marginX(value:Number):void
marginY property
marginY:Number

y余量将会沿着Y的方法扩展滤镜纹理的尺寸，当使用外发光效果时非常有用。

Implementation
    protected function get marginY():Number
    protected function set marginY(value:Number):void
mode property
mode:String

滤镜模式, 由"FragmentFilterMode" 定义。

The default value is "replace".

Implementation
    public function get mode():String
    public function set mode(value:String):void
mvpConstantID property
mvpConstantID:int

模型投影常数(4矩阵)的第一个寄存器ID

Implementation
    protected function get mvpConstantID():int
    protected function set mvpConstantID(value:int):void
numPasses property
numPasses:int

滤镜应用的通道数量. "activate" 和 "deactivate" 方法会来调用。

Implementation
    protected function get numPasses():int
    protected function set numPasses(value:int):void
offsetX property
offsetX:Number

滤镜的左右偏移量.

Implementation
    public function get offsetX():Number
    public function set offsetX(value:Number):void
offsetY property
offsetY:Number

滤镜的上下偏移量

Implementation
    public function get offsetY():Number
    public function set offsetY(value:Number):void
resolution property
resolution:Number

滤镜纹理的分辨率。"1"代表stage分辨率，"0.5"代表stage分辨率的一半。一个较小的分辨率，可以节省存储空间和执行时间(取决于GPU)， 但是输出质量会降低。如果数值大于1也是允许的；当过滤器缩放时，这样的值可能是有意义的。

Implementation
    public function get resolution():Number
    public function set resolution(value:Number):void
texCoordsAtID property
texCoordsAtID:int

存储了顶点坐标的顶点缓冲区属性的ID

Implementation
    protected function get texCoordsAtID():int
    protected function set texCoordsAtID(value:int):void
vertexPosAtID property
vertexPosAtID:int

存储了顶点位置的顶点缓冲区属性的ID

Implementation
    protected function get vertexPosAtID():int
    protected function set vertexPosAtID(value:int):void
Constructor Detail
FragmentFilter () Constructor
public function FragmentFilter(numPasses:int = 1, resolution:Number = 1.0)

根据指定的通道数量和分辨率，创建一个新的片段滤镜。只有在子类的构造方法中，才能调用这个构造方法。

Parameters
numPasses:int (default = 1) — 通道数量
resolution:Number (default = 1.0) — 分辨率
Method Detail
activate () method
protected function activate(pass:int, context:Context3D, texture:Texture):void

子类必须覆盖这个方法，并且使用它来实现他们自己的片段和顶点着色程序。 'activate'方法的调用先于'context.drawTriangles'方法的调用。根据你的滤镜的需要设置上下文。下面的常量和属性会被自动设置：

  • vertex constants 0-3: mvpMatrix (3D)
  • vertex attribute 0: vertex position (FLOAT_2)
  • vertex attribute 1: texture coordinates (FLOAT_2)
  • texture 0: input texture

Parameters

pass:int — 当前的渲染通道，从'0'开始。多通道的滤镜可以为每一个通道提供不同的逻辑。
context:Context3D — 上下文 当前的context3D对象(实际上就是Starling.context，这里传递只是为了调用方便)
texture:Texture — 纹理 输入纹理，已经被绑定到采样器0

assembleAgal () method
protected function assembleAgal(fragmentShader:String = null, vertexShader:String = null):Program3D

将字符串格式的片段和顶点着色代码汇编到一个Program3D对象。如果有任何参数是null，就会采用默认值（STD_FRAGMENT_SHADER或STD_VERTEX_SHADER）来替代。

Parameters

fragmentShader:String (default = null) — 片段着色代码
vertexShader:String (default = null) — 顶点着色代码

Returns
Program3D — Program3D
cache () method
public function cache():void

缓存滤镜输出到一个纹理。一个没有缓存的滤镜，会在每一帧进行渲染；而一个缓存的滤镜则只需要渲染一次。 当然，如果应用滤镜的对象或滤镜设置改变了，缓存也应该被更新；要做到这一点，可以再次调用'cache'方法。

clearCache () method
public function clearCache():void

清理滤镜的缓存输出。在这个方法调用后，滤镜将会在每帧执行一次。

createPrograms () method
protected function createPrograms():void

子类必须覆盖这个方法，并且使用它来创建他们自己的片段和顶点着色程序

deactivate () method
protected function deactivate(pass:int, context:Context3D, texture:Texture):void

这个方法会在'context.drawTriangles'方法调用之后，被调用。如果你需要做一些诸如清理资源的工作，可以在这个方法里面来做。

Parameters

pass:int — 当前的渲染通道
context:Context3D — 上下文
texture:Texture — 纹理

dispose () method
public function dispose():void

销毁滤镜 (着色程序, 缓冲区, 纹理).

render () method
public function render(object:DisplayObject, support:RenderSupport, parentAlpha:Number):void

在指定的显示对象上应用滤镜，渲染输出结果到当前的渲染目标上。当Starling渲染一个附加了滤镜的对象时，会自动调用这个方法。

Parameters

object:DisplayObject — 显示对象
support:RenderSupport — 渲染辅助对象
parentAlpha:Number — 父级透明度

Constant Detail
PMA Constant
protected const PMA:Boolean = true

所有的滤镜处理预计都会使用预乘透明度

STD_FRAGMENT_SHADER Constant
protected const STD_FRAGMENT_SHADER:String = tex oc, v0, fs0 <2d, clamp, linear, mipnone>

标准的片段着色器代码. 它只是转发纹理颜色到输出端.

STD_VERTEX_SHADER Constant
protected const STD_VERTEX_SHADER:String

标准的顶点着色代码。如果你没有创建自定义的顶点着色器，就会自动使用这个标准的着色代码。


starling.filters.FragmentFilterMode

FragmentFilterMode | Constants
Package | starling.filters
Class | public class FragmentFilterMode
Inheritance | FragmentFilterMode Inheritance Object

这个类提供了一些静态变量来表示滤镜模式。 这些值用于FragmentFilter.mode属性，并且定义一个滤镜和一个原有对象结合后的呈现结果。

Public Constants
Constant |  | Defined By
 | ABOVE : String = above [static] 滤镜在对象的上方显示 | FragmentFilterMode
 | BELOW : String = below [static] 滤镜在对象的下方显示 | FragmentFilterMode
 | REPLACE : String = replace [static] 滤镜替换原有的对象 | FragmentFilterMode
Constant Detail
ABOVE Constant
public static const ABOVE:String = above

滤镜在对象的上方显示

BELOW Constant
public static const BELOW:String = below

滤镜在对象的下方显示

REPLACE Constant
public static const REPLACE:String = replace

滤镜替换原有的对象


starling.text - Starling API 1.3 | Starling中文站

Package starling.text

Classes
BitmapChar
BitmapFont
TextField


starling.text Summary

starling.text | Classes

Classes
Class | Description
BitmapChar | 一个 BitmapChar包含了位图字体的一个字符的相关信息。 在大多数情况下您不需要直接使用这个类。TextField类已经为您做了封装。
BitmapFont | BitmapFont类解析bitmap字体文件，并保存在一个字符表中。 这个类解析的XML格式的文件使用了 AngelCode Bitmap Font Generator or the Glyph Designer.
TextField | TextField类用来显示文本，使用标准的True Type字体或自定义位图字体。 您可以设置你用到的所有属性，比如字体名称和字号，颜色，横向和垂直对齐方式，等等。边框属性对于开发是非常有帮助的，因为这样可以让您看到文本的边界。 有两种类型的字体可以被显示: 标准的true type字体.


starling.text.BitmapChar

BitmapChar | Properties | Methods
Package | starling.text
Class | public class BitmapChar
Inheritance | BitmapChar Inheritance Object

一个 BitmapChar包含了位图字体的一个字符的相关信息。 在大多数情况下您不需要直接使用这个类。TextField类已经为您做了封装。

Public Properties
Property |  | Defined By
 | charID : int [read-only] 字符的唯一标示. | BitmapChar
 | height : Number [read-only] 字符高度. | BitmapChar
 | texture : Texture [read-only] 这个字符的纹理. | BitmapChar
 | width : Number [read-only] 字符宽度. | BitmapChar
 | xAdvance : Number [read-only] 光标移动到下一个字符时的偏移量 | BitmapChar
 | xOffset : Number [read-only] 排列字符的时候在X方向上的偏移量. | BitmapChar
 | yOffset : Number [read-only] 排列字符的时候在Y方向上的偏移量. | BitmapChar
Public Methods
Method |  | Defined By
 | BitmapChar(id:int, texture:Texture, xOffset:Number, yOffset:Number, xAdvance:Number) 根据纹理和它的属性创建一个字符 | BitmapChar
 | addKerning(charID:int, amount:Number):void 根据特定的字符ID设定边距 | BitmapChar
 | createImage():Image 据字符创建一个图片. | BitmapChar
 | getKerning(charID:int):Number 根据特定的字符ID返回边距 | BitmapChar
Property Detail
charID property
charID:int [read-only]

字符的唯一标示.

Implementation
    public function get charID():int
height property
height:Number [read-only]

字符高度.

Implementation
    public function get height():Number
texture property
texture:Texture [read-only]

这个字符的纹理.

Implementation
    public function get texture():Texture
width property
width:Number [read-only]

字符宽度.

Implementation
    public function get width():Number
xAdvance property
xAdvance:Number [read-only]

光标移动到下一个字符时的偏移量

Implementation
    public function get xAdvance():Number
xOffset property
xOffset:Number [read-only]

排列字符的时候在X方向上的偏移量.

Implementation
    public function get xOffset():Number
yOffset property
yOffset:Number [read-only]

排列字符的时候在Y方向上的偏移量.

Implementation
    public function get yOffset():Number
Constructor Detail
BitmapChar () Constructor
public function BitmapChar(id:int, texture:Texture, xOffset:Number, yOffset:Number, xAdvance:Number)

根据纹理和它的属性创建一个字符

Parameters
id:int — 唯一标示
texture:Texture — 纹理
xOffset:Number — X偏移量
yOffset:Number — Y偏移量
xAdvance:Number — 移动偏移量
Method Detail
addKerning () method
public function addKerning(charID:int, amount:Number):void

根据特定的字符ID设定边距

Parameters

charID:int — 字符ID
amount:Number — 边距

createImage () method
public function createImage():Image

据字符创建一个图片.

Returns
Image — Image
getKerning () method
public function getKerning(charID:int):Number

根据特定的字符ID返回边距

Parameters

charID:int — 字符ID

Returns
Number — 边距


starling.text.BitmapFont

BitmapFont | Properties | Methods | Constants
Package | starling.text
Class | public class BitmapFont
Inheritance | BitmapFont Inheritance Object

BitmapFont类解析bitmap字体文件，并保存在一个字符表中。 这个类解析的XML格式的文件使用了 AngelCode Bitmap Font Generator or the Glyph Designer. T这种格式看起来就像下面写的:

      <font>
        <info face="BranchingMouse" size="40" />
        <common lineHeight="40" />
        <pages>  <!-- currently, only one page is supported -->
          <page id="0" file="texture.png" />
        </pages>
        <chars>
          <char id="32" x="60" y="29" width="1" height="1" xoffset="0" yoffset="27" xadvance="8" />
          <char id="33" x="155" y="144" width="9" height="21" xoffset="0" yoffset="6" xadvance="9" />
        </chars>
        <kernings> <!-- Kerning is optional -->
          <kerning first="83" second="83" amount="-4"/>
        </kernings>
      </font>
通过TextField类的registerBitmapFont方法传递一个这个类的实例。 然后，设置文本字段的fontName属性为位图字体的名称值。这将使文本字段使用位图字体。

Public Properties
Property |  | Defined By
 | baseline : Number [read-only] 字体的基线. | BitmapFont
 | lineHeight : Number 行高. | BitmapFont
 | name : String [read-only] 字体名称 | BitmapFont
 | size : Number [read-only] 字号 | BitmapFont
 | smoothing : String 是否开启平滑 | BitmapFont
Public Methods
Method |  | Defined By
 | BitmapFont(texture:Texture = null, fontXml:XML = null) 通过解析XML文件创建一个位图字体，并使用指定的纹理。如果不传递任何数据，就使用内嵌的MINI字型。 | BitmapFont
 | addChar(charID:int, bitmapChar:BitmapChar):void 根据指定的字符ID增加一个位图字符 | BitmapFont
 | createSprite(width:Number, height:Number, text:String, fontSize:Number = -1, color:uint = 0xffffff, hAlign:String = center, vAlign:String = center, autoScale:Boolean = true, kerning:Boolean = true):Sprite 创建一个包含字符图片的Sprite对象 | BitmapFont
 | dispose():void 销毁位图字体的纹理 | BitmapFont
 | fillQuadBatch(quadBatch:QuadBatch, width:Number, height:Number, text:String, fontSize:Number = -1, color:uint = 0xffffff, hAlign:String = center, vAlign:String = center, autoScale:Boolean = true, kerning:Boolean = true):void 将文本绘制成QuadBatch. | BitmapFont
 | getChar(charID:int):BitmapChar 根据指定的字符ID返回一个位图字符 | BitmapFont
Public Constants
Constant |  | Defined By
 | MINI : String = mini [static] 内嵌的一个小巧的位图字体. | BitmapFont
 | NATIVE_SIZE : int = -1 [static] 为TextField类的fontSize属性设置这个常量，让位图字体按照它的默认大小渲染 | BitmapFont
Property Detail
baseline property
baseline:Number [read-only]

字体的基线.

Implementation
    public function get baseline():Number
lineHeight property
lineHeight:Number

行高.

Implementation
    public function get lineHeight():Number
    public function set lineHeight(value:Number):void
name property
name:String [read-only]

字体名称

Implementation
    public function get name():String
size property
size:Number [read-only]

字号

Implementation
    public function get size():Number
smoothing property
smoothing:String

是否开启平滑

Implementation
    public function get smoothing():String
    public function set smoothing(value:String):void
Constructor Detail
BitmapFont () Constructor
public function BitmapFont(texture:Texture = null, fontXml:XML = null)

通过解析XML文件创建一个位图字体，并使用指定的纹理。如果不传递任何数据，就使用内嵌的MINI字型。

Parameters
texture:Texture (default = null) — 纹理
fontXml:XML (default = null) — 字体XML
Method Detail
addChar () method
public function addChar(charID:int, bitmapChar:BitmapChar):void

根据指定的字符ID增加一个位图字符

Parameters

charID:int — 字符ID
bitmapChar:BitmapChar

createSprite () method
public function createSprite(width:Number, height:Number, text:String, fontSize:Number = -1, color:uint = 0xffffff, hAlign:String = center, vAlign:String = center, autoScale:Boolean = true, kerning:Boolean = true):Sprite

创建一个包含字符图片的Sprite对象

Parameters

width:Number — 宽度
height:Number — 高度
text:String — 文本内容
fontSize:Number (default = -1) — 文字大小
color:uint (default = 0xffffff) — 颜色
hAlign:String (default = center) — 水平对齐方式
vAlign:String (default = center) — 垂直对齐方式
autoScale:Boolean (default = true) — 自动缩放
kerning:Boolean (default = true) — 字距

Returns
Sprite — 绘制生成的Sprite对象
dispose () method
public function dispose():void

销毁位图字体的纹理

fillQuadBatch () method
public function fillQuadBatch(quadBatch:QuadBatch, width:Number, height:Number, text:String, fontSize:Number = -1, color:uint = 0xffffff, hAlign:String = center, vAlign:String = center, autoScale:Boolean = true, kerning:Boolean = true):void

将文本绘制成QuadBatch.

Parameters

quadBatch:QuadBatch — QuadBatch实例
width:Number — 宽度
height:Number — 高度
text:String — 文本
fontSize:Number (default = -1) — 字号
color:uint (default = 0xffffff) — 颜色
hAlign:String (default = center) — 水平对齐方式
vAlign:String (default = center) — 垂直对齐方式
autoScale:Boolean (default = true) — 自动缩放
kerning:Boolean (default = true) — 字距

getChar () method
public function getChar(charID:int):BitmapChar

根据指定的字符ID返回一个位图字符

Parameters

charID:int — 字符ID

Returns
BitmapChar — BitmapChar
Constant Detail
MINI Constant
public static const MINI:String = mini

内嵌的一个小巧的位图字体.

NATIVE_SIZE Constant
public static const NATIVE_SIZE:int = -1

为TextField类的fontSize属性设置这个常量，让位图字体按照它的默认大小渲染


starling.text.TextField

TextField | Properties | Methods | Events
Package | starling.text
Class | public class TextField
Inheritance | TextField Inheritance DisplayObjectContainer Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

TextField类用来显示文本，使用标准的True Type字体或自定义位图字体。

您可以设置你用到的所有属性，比如字体名称和字号，颜色，横向和垂直对齐方式，等等。边框属性对于开发是非常有帮助的，因为这样可以让您看到文本的边界。

有两种类型的字体可以被显示:

  • 标准的true type字体. 渲染这种类型的字体就像传统的Flash的文本框一样。建议您使用嵌入字体， 因为您无法确保客户端有哪些字体可用， 而且嵌入字体具有更好的渲染质量。只需要给相应的属性传入字体名称即可。
  • 位图字体. 如果您需要加速显示或希望使用很酷的样式，请使用位图字体。这是一种将字型渲染到纹理地图集的格式。 要使用位图字体，需要首先通过registerBitmapFont注册这个字体，然后传递字体名称到文本框相应的属性上。
对于位图字体来说，我们推荐下面的工具:
  • Windows: 位图字体生成器来自 Angel Code (免费). 导出字体数据为一个XML文件， 纹理导出为一个PNG图片，将白色的文字放在透明背景上(32位)。
  • Mac OS: Glyph Designer 来自 71squared 或者 bmGlyph (都是商业软件). 他们本身都支持Starling。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
Inherited | alpha : Number 显示对象的不透明度。 0 = 透明, 1 = 不透明。 | DisplayObject
 | autoScale : Boolean 指示是否开启自动缩放，使文本可以完整的填充整个文字区域。 | TextField
Inherited | base : DisplayObject [read-only] 包含该显示对象的显示列表树的顶级显示对象。对于在显示列表中的对象，其实就是Stage。 | DisplayObject
Inherited | blendMode : String 混合模式决定该对象和其之下的对象如何混合显示，默认为 auto。 | DisplayObject
 | bold : Boolean 字体加粗. | TextField
 | border : Boolean 围绕文本框绘制一个边框. | TextField
Inherited | bounds : Rectangle [read-only] 返回显示对象相对于父级对象坐标系的矩形区域。 | DisplayObject
 | color : uint 字体颜色，在位图字体中，使用 Color.WHITE来代替默认的颜色. | TextField
Inherited | filter : FragmentFilter 添加到该显示对象的滤镜或者滤镜集合。 starling.filters包提供了几个方便使用的特定滤镜。 鉴于性能方面的考虑，注意不要将同一个滤镜添加到多于一个显示对象上。 | DisplayObject
 | fontName : String 字体名称 (true type字体或位图字体). | TextField
 | fontSize : Number 字号，在位图字体中，使用BitmapFont.NATIVE_SIZE来代替原来的大小 | TextField
 | hAlign : String 文本的横向对齐方式. | TextField
Inherited | hasVisibleArea : Boolean [read-only] 判断这个显示对象是否具备可显示的区域。(导致不可见的原因可能是'alpha'，或'scaleX'和'scaleY'设置为0，或者'visible'设置为false) | DisplayObject
 | height : Number [override] 显示对象的高度。 | TextField
 | italic : Boolean 是否是斜体. | TextField
 | kerning : Boolean 指示是否启用字距. | TextField
Inherited | name : String 显示对象的名称(默认：null)。 显示对象容器的getChildByName方法调用的参数就是child显示对象的名称。 | DisplayObject
 | nativeFilters : Array 当你使用默认字体（TrueType）类型的时候，你可以使用Flash原生的 BitmapFilters! | TextField
Inherited | numChildren : int [read-only] 容器包含的子级数量。 | DisplayObjectContainer
Inherited | parent : DisplayObjectContainer [read-only] 包含该显示对象的显示对象容器。 | DisplayObject
Inherited | pivotX : Number 显示对象在自己的坐标系的起始x坐标（默认：0） | DisplayObject
Inherited | pivotY : Number 显示对象在自己的坐标系的起始y坐标（默认：0） | DisplayObject
Inherited | root : DisplayObject [read-only] 包含该显示对象的显示列表树的最顶级的对象（非stage, 例如:Starling构造函数里的rootClass对象）， 如果显示对象尚未添加到显示列表，则root 属性为null。 | DisplayObject
Inherited | rotation : Number 显示对象的旋转弧度。 (在Starling里，所有的角度值都是用弧度值来表示的) | DisplayObject
Inherited | scaleX : Number 显示对象水平方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | scaleY : Number 显示对象垂直方向的缩放参数。 '1' 表示没有缩放, 负值在缩放的同时会翻转对象。 | DisplayObject
Inherited | skewX : Number 显示对象水平方向的倾斜弧度。 | DisplayObject
Inherited | skewY : Number 显示对象垂直方向的倾斜弧度。 | DisplayObject
Inherited | stage : Stage [read-only] 与该显示对象关联的stage对象，如果还没有被添加到stage则为空。 | DisplayObject
 | text : String 显示的文本. | TextField
 | textBounds : Rectangle [read-only] 返回文本框中的文本区域 | TextField
Inherited | touchable : Boolean 是否禁止该对象和它的子对象响应触碰事件。 | DisplayObject
Inherited | transformationMatrix : Matrix 返回显示对象相对于父级对象坐标系的变换矩阵。 如果你指定一个变换矩阵，Starling会为（x, y, scaleX/Y, rotation 等）自动计算出合适的值。 警告：返回的是显示对象本身的变换矩阵，并不是副本。 | DisplayObject
 | underline : Boolean 是否具备下划线. | TextField
Inherited | useHandCursor : Boolean 一个布尔值，表示当鼠标滑过显示对象时是否显示手指形（手形光标），默认为 false。 | DisplayObject
 | vAlign : String 文本的垂直对齐方式。 | TextField
Inherited | visible : Boolean 显示对象是否可见。不可见的显示对象不能够被触碰。 | DisplayObject
 | width : Number [override] 显示对象的宽度。 | TextField
Inherited | x : Number 显示对象相对于父级对象的局部坐标系的x坐标。 | DisplayObject
Inherited | y : Number 显示对象相对于父级对象的局部坐标系的y坐标。 | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined By
 | TextField(width:int, height:int, text:String, fontName:String = Verdana, fontSize:Number = 12, color:uint = 0x0, bold:Boolean = false) 根据给定的属性创建一个新的文本框 | TextField
Inherited | addChild(child:DisplayObject):DisplayObject 添加一个显示对象到容器，它将被添加到顶层。 | DisplayObjectContainer
Inherited | addChildAt(child:DisplayObject, index:int):DisplayObject 根据一个索引值添加一个显示对象到容器。 | DisplayObjectContainer
Inherited | addEventListener(type:String, listener:Function):void 在指定的对象上注册一个事件侦听器。 | EventDispatcher
Inherited | broadcastEvent(event:Event):void 通过递归的方法，对所有的子级派发一个指定事件，此事件必须是非冒泡事件。 | DisplayObjectContainer
Inherited | broadcastEventWith(type:String, data:Object = null):void 通过递归的方法，对所有的子级派发一个包含数据的事件。 为了避免新的内存分配开销，此方法使用了内部的事件对象池。 | DisplayObjectContainer
Inherited | contains(child:DisplayObject):Boolean 通过递归的方法，判断一个指定的显示对象是否为容器的子级（直接或者间接的）。 | DisplayObjectContainer
Inherited | dispatchEvent(event:Event):void 派发事件到所有注册了这个事件类型侦听器的对象。如果一个事件开启了"冒泡"，它会沿着父级关系，一直向上，直到碰到了根节点，或者中间被手动停止它的传递。 | EventDispatcher
Inherited | dispatchEventWith(type:String, bubbles:Boolean = false, data:Object = null):void 派发一个包含了特定参数的事件到所有注册了特定类型侦听器的对象中。 这个方法使用了一个内部的事件对象池因避免重复的分配导致的额外开销。 | EventDispatcher
 | dispose():void [override] 销毁纹理数据 | TextField
 | getBitmapFont(name:String):BitmapFont [static] 获取一个位图纹理 | TextField
 | getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle [override] 返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。 | TextField
Inherited | getChildAt(index:int):DisplayObject 根据指定的索引返回对应的子级对象。 | DisplayObjectContainer
Inherited | getChildByName(name:String):DisplayObject 根据指定的名称返回对应的子级对象（非递归，只遍历容器本身的子对象）。 | DisplayObjectContainer
Inherited | getChildIndex(child:DisplayObject):int 获取指定子级对象在容器中的索引。如果没有找到，返回"-1"。 | DisplayObjectContainer
Inherited | getTransformationMatrix(targetSpace:DisplayObject, resultMatrix:Matrix = null):Matrix 返回一个矩阵，该矩阵表示从一个局部坐标系到另一个坐标系的转换。 | DisplayObject
Inherited | globalToLocal(globalPoint:Point, resultPoint:Point = null):Point 将一个点坐标从全局(stage)坐标系转换成为局部坐标系坐标 。 | DisplayObject
Inherited | hasEventListener(type:String):Boolean 判断是否具备指定的事件类型的侦听器。 | EventDispatcher
Inherited | hitTest(localPoint:Point, forTouch:Boolean = false):DisplayObject [override] 返回舞台坐标系某个点下方的最顶层的显示对象，如果没有找到任何对象，则返回null。 | DisplayObjectContainer
Inherited | localToGlobal(localPoint:Point, resultPoint:Point = null):Point 将一个点坐标从局部坐标系转换成全局(stage)坐标系坐标 。 | DisplayObject
 | registerBitmapFont(bitmapFont:BitmapFont, name:String = null):String [static] 让位图字体可以应用在任何文本框。设置文本框的fontName属性为位图字体的name值，来使用位图字体进行渲染。 | TextField
Inherited | removeChild(child:DisplayObject, dispose:Boolean = false):DisplayObject 从容器内删除一个显示对象，如果这个对象不是容器的子级，则什么都不会发生。 如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildAt(index:int, dispose:Boolean = false):DisplayObject 根据指定的索引值删除一个子级显示对象。 列表中这个对象上层的对象将往下移，如果需要，可以销毁这个对象。 | DisplayObjectContainer
Inherited | removeChildren(beginIndex:int = 0, endIndex:int = -1, dispose:Boolean = false):void 根据指定的范围删除容器内的一组对象（包括结束索引）。 如果没有传入参数，所有的子对象将被删除。 | DisplayObjectContainer
Inherited | removeEventListener(type:String, listener:Function):void 在指定的对象上删除一个事件侦听器。 | EventDispatcher
Inherited | removeEventListeners(type:String = null):void 根据指定的事件类型删除所有与这个事件类型有关的侦听器，如果传递null则删除所有的侦听器。 要小心进行删除所有侦听器的操作：您永远不知道还有谁在侦听。 | EventDispatcher
Inherited | removeFromParent(dispose:Boolean = false):void 如果对象已经添加进显示列表，则从父容器中删除此对象。 | DisplayObject
 | render(support:RenderSupport, parentAlpha:Number):void [override] 使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。 | TextField
Inherited | setChildIndex(child:DisplayObject, index:int):void 移动一个子级到指定的索引，在它后面的子级将向后移动。 | DisplayObjectContainer
Inherited | sortChildren(compareFunction:Function):void 根据指定的排序方法对所有子级进行排序（就像Vector类的排序功能一样）。 | DisplayObjectContainer
Inherited | swapChildren(child1:DisplayObject, child2:DisplayObject):void 互换两个子级的索引。 | DisplayObjectContainer
Inherited | swapChildrenAt(index1:int, index2:int):void 互换两个子级的索引。 | DisplayObjectContainer
 | unregisterBitmapFont(name:String, dispose:Boolean = true):void [static] 取消注册一个位图字体，并销毁它（可选）. | TextField
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined By
Inherited | added | 当一个显示对象被添加到父级的时候派发。 | DisplayObject
Inherited | addedToStage | 当一个显示对象被添加到stage(直接的或者间接的)的时候派发。 | DisplayObject
Inherited | enterFrame | 在每一帧派发给stage上的所有显示对象。 | DisplayObject
Inherited | removed | 当一个显示对象从父级删除的时候派发。 | DisplayObject
Inherited | removedFromStage | 当一个显示对象从stage删除(直接的或者间接的)的时候派发，此对象不再会被渲染。 | DisplayObject
Inherited | touch | 当显示对象被触碰时派发，冒泡事件。 | DisplayObject
Property Detail
autoScale property
autoScale:Boolean

指示是否开启自动缩放，使文本可以完整的填充整个文字区域。

The default value is false.

Implementation
    public function get autoScale():Boolean
    public function set autoScale(value:Boolean):void
bold property
bold:Boolean

字体加粗.

The default value is false.

Implementation
    public function get bold():Boolean
    public function set bold(value:Boolean):void
border property
border:Boolean

围绕文本框绘制一个边框.

The default value is false.

Implementation
    public function get border():Boolean
    public function set border(value:Boolean):void
color property
color:uint

字体颜色，在位图字体中，使用 Color.WHITE来代替默认的颜色.

The default value is black.

Implementation
    public function get color():uint
    public function set color(value:uint):void
fontName property
fontName:String

字体名称 (true type字体或位图字体).

Implementation
    public function get fontName():String
    public function set fontName(value:String):void
fontSize property
fontSize:Number

字号，在位图字体中，使用BitmapFont.NATIVE_SIZE来代替原来的大小

Implementation
    public function get fontSize():Number
    public function set fontSize(value:Number):void
hAlign property
hAlign:String

文本的横向对齐方式.

The default value is 居中对齐.

Implementation
    public function get hAlign():String
    public function set hAlign(value:String):void

See also

starling.utils.HAlign
height property
height:Number[override]

显示对象的高度。

Implementation
    public function get height():Number
    public function set height(value:Number):void
italic property
italic:Boolean

是否是斜体.

The default value is false.

Implementation
    public function get italic():Boolean
    public function set italic(value:Boolean):void
kerning property
kerning:Boolean

指示是否启用字距.

The default value is true.

Implementation
    public function get kerning():Boolean
    public function set kerning(value:Boolean):void
nativeFilters property
nativeFilters:Array

当你使用默认字体（TrueType）类型的时候，你可以使用Flash原生的 BitmapFilters!

Implementation
    public function get nativeFilters():Array
    public function set nativeFilters(value:Array):void
text property
text:String

显示的文本.

Implementation
    public function get text():String
    public function set text(value:String):void
textBounds property
textBounds:Rectangle [read-only]

返回文本框中的文本区域

Implementation
    public function get textBounds():Rectangle
underline property
underline:Boolean

是否具备下划线.

The default value is false.

Implementation
    public function get underline():Boolean
    public function set underline(value:Boolean):void
vAlign property
vAlign:String

文本的垂直对齐方式。

Implementation
    public function get vAlign():String
    public function set vAlign(value:String):void

See also

starling.utils.VAlign
width property
width:Number[override]

显示对象的宽度。

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor Detail
TextField () Constructor
public function TextField(width:int, height:int, text:String, fontName:String = Verdana, fontSize:Number = 12, color:uint = 0x0, bold:Boolean = false)

根据给定的属性创建一个新的文本框

Parameters
width:int — 宽度
height:int — 高度
text:String — 文本
fontName:String (default = Verdana) — 字体名称
fontSize:Number (default = 12) — 字号
color:uint (default = 0x0) — 颜色
bold:Boolean (default = false) — 是否加粗
Method Detail
dispose () method
override public function dispose():void

销毁纹理数据

getBitmapFont () method
public static function getBitmapFont(name:String):BitmapFont

获取一个位图纹理

Parameters

name:String — 字体名称

Returns
BitmapFont — BitmapFont
getBounds () method
override public function getBounds(targetSpace:DisplayObject, resultRect:Rectangle = null):Rectangle

返回一个矩形，该矩形定义相对于 targetSpace 对象坐标系的显示对象区域。

Parameters

targetSpace:DisplayObject — 定义要使用的坐标系的显示对象。
resultRect:Rectangle (default = null) — 如果传入一个resultRect参数, 计算的结果将保存在这个矩形里，而不是重新创建一个Rectangle对象。

Returns
Rectangle — Rectangle
registerBitmapFont () method
public static function registerBitmapFont(bitmapFont:BitmapFont, name:String = null):String

让位图字体可以应用在任何文本框。设置文本框的fontName属性为位图字体的name值，来使用位图字体进行渲染。

Parameters

bitmapFont:BitmapFont — 位图字体
name:String (default = null) — 名称

Returns
String — String
render () method
override public function render(support:RenderSupport, parentAlpha:Number):void

使用辅助对象来渲染显示对象，永远不要直接调用这个方法，除非在另外一个渲染方法里调用。

Parameters

support:RenderSupport — 为渲染显示对象提供一些实用方法。
parentAlpha:Number — 从显示对象的父级到stage的alpha值的累加值。

unregisterBitmapFont () method
public static function unregisterBitmapFont(name:String, dispose:Boolean = true):void

取消注册一个位图字体，并销毁它（可选）.

Parameters

name:String
dispose:Boolean (default = true)


starling.textures - Starling API 1.3 | Starling中文站

Package starling.textures

Classes
ConcreteTexture
RenderTexture
SubTexture
Texture
TextureAtlas
TextureSmoothing


starling.textures Summary

starling.textures | Classes

Classes
Class | Description
ConcreteTexture | 一个封装了Stage3D纹理对象的ConcreteTexture，用于存储纹理属性。
RenderTexture | RenderTexture是一个能在其上绘制任何显示对象的动态纹理。 在创建一个RenderTexture对象后，仅需调用 drawObject 方法直接在纹理上渲染一个对象。 对象将会在当前位置，连带当前的旋转，缩放和透明值属性被绘制在纹理上。 绘制能够被高效的完成，因为它在显存中是直接发生的。绘制能够被高效的完成，因为它在显存中是直接发生的。 当你在纹理上绘制完对象后，不管你绘制了多少个对象，它的性能将和通常的纹理没什么区别。 如果你一次绘制许多的对象的话，推荐通过drawBundled方法把绘制调用捆绑在一个代码块中，像下面展示的一样。 那将会产生极大地提速，允许你迅速绘制几百个对象。 renderTexture.drawBundled(function():void { for (var i:int=0; i<numDrawings; ++i) { image.rotation = (2 * Math.PI / numDrawings) * i; renderTexture.draw(image); } }); 为了擦除一个经渲染纹理的一部分，你可以使用像“rubber”一样的任意显示对象通过设置它的混合模式为"BlendMode.ERASE"。 注意当Starling的渲染上下文丢失，渲染纹理就不能够被恢复。
SubTexture | 一个SubTexture用于表现另一个纹理的一部分。由于这是完全通过操作纹理坐标实现的，使得这个类非常高效。 注意：从子纹理继续创建子纹理也是允许的。
Texture | 纹理是用来储存展示图像的信息。它不能直接被添加到显示列表；相应的它必须映射到一个显示对象上。 在Staring中那个显示对象就是“Image”类。 纹理格式 纹理能够由一个“BitmapData”对象创建，Starling能够支持任何Flash所支持的bitmap格式。 并且由于你能够将任何Flash显示对象转换为BitmapData对象，你就能够利用这点在Starling中 去显示非Starling内容,比如说Shape对象。 Starling同时支持ATF纹理（Adobe Texture Format），一个能够通过GPU高效渲染的被压缩纹理的容器。 Mip映射 MipMaps是按比例缩小的纹理类型。当一个图像被显示时小于它本来的尺寸时， GPU可能就会用mip maps去替代原生纹理。这就可以减少走样和加速渲染。当然这也需要额外的内存开销； 你可以权衡利弊之后选择是否使用它。 纹理框架 纹理的frame属性允许你设置纹理在image对象中的界限，在纹理周围留有透明空白区域。 frame矩形被指定在纹理的坐标系统中，而不是image: var frame:Rectangle = new Rectangle(-10, -10, 30, 30); var texture:Texture = Texture.fromTexture(anotherTexture, null, frame); var image:Image = new Image(texture); 这段代码会创建一个30x30大小的图像，纹理会被放置在图像x=10, y=10 的位置上（假设'anotherTexture'是一个宽高都为10像素的纹理，它将出现在图像的正中位置）。 纹理集就采用了这个特性，它允许裁剪一个纹理的透明边缘用来弥补由指定的原始纹理框架改变的尺寸。 可以使用TexturePacker这样的工具来优化纹理集。 纹理坐标系 假如，从另一方面讲，你只想在图像中显示纹理的一部分（就是说修剪这个纹理）， 你可以创建一个子纹理（通过方法'Texture.fromTexture()'然后指定一个限定范围的矩形）， 或者你也可以操作image对象的纹理坐标系。方法'image.setTexCoords'允许你那样做。
TextureAtlas | 纹理集是一个将许多小的纹理整合到一张大图中。这个类是用来从一个纹理集中读取纹理。 使用纹理集能为你的纹理解决两个问题: 在一定的时间内，始终有一个纹理处于活动的。每当你改变了处于活动的纹理，一个 “纹理切换”就会执行，这个切换是需要时间的。 任何Stage3D纹理的边长都必须是2的幂数。Starling向你隐藏了这个限制，但这将带来 额外的图形存储成本。 通过使用纹理集，您可以避免使用纹理切换和取消2的幂数的限制。所有的纹理被集合在一 个“超级纹理”，并且Starling会确保纹理正确的部分被显示出来。 有几种方法来创建纹理集。一种是使用捆绑在Starling的姊妹框架 Sparrow framework。里的纹理集生成脚本。 尽管目前这个脚本只能运行在Mac OS X上。 另一个可供选择的出色工具 Texture Packer， 他是一个跨平台的商业软件。 无论您使用的工具是什么，Starling可以支持以下文档格式: <TextureAtlas imagePath='atlas.png'> <SubTexture name='texture_1' x='0' y='0' width='50' height='50'/> <SubTexture name='texture_2' x='50' y='0' width='20' height='30'/> </TextureAtlas> 如果你的图像在边缘具有透明区域，您可以使用Texture类的frame属性。 通过 去除纹理的透明边缘并且指定原始尺寸就像这样： <SubTexture name='trimmed' x='0' y='0' height='10' width='10' frameX='-10' frameY='-10' frameWidth='30' frameHeight='30'/>
TextureSmoothing | 这个类为可能的材质平滑算法提供常量值。


starling.textures.ConcreteTexture

ConcreteTexture | Properties | Methods
Package | starling.textures
Class | public class ConcreteTexture
Inheritance | ConcreteTexture Inheritance Texture Inheritance Object

一个封装了Stage3D纹理对象的ConcreteTexture，用于存储纹理属性。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | base : TextureBase [override] [read-only] 纹理所基于的Stage3D纹理对象。 | ConcreteTexture
 | format : String [override] [read-only] 基本纹理数据的Context3DTextureFormat。 | ConcreteTexture
Inherited | frame : Rectangle [read-only] 纹理框架（参阅类描述） | Texture
 | height : Number [override] [read-only] 以像素为单位的纹理高度。 | ConcreteTexture
 | mipMapping : Boolean [override] [read-only] 表明纹理是否包含mip映射集。 | ConcreteTexture
 | nativeHeight : Number [override] [read-only] 纹理的像素高度(忽略缩放参数). | ConcreteTexture
 | nativeWidth : Number [override] [read-only] 纹理的像素宽度(忽略缩放参数). | ConcreteTexture
 | optimizedForRenderTexture : Boolean [read-only] 表示当基础纹理进行纹理渲染时是否优化。 | ConcreteTexture
 | premultipliedAlpha : Boolean [override] [read-only] 表明透明值是否被预乘到了RGB值中。 | ConcreteTexture
Inherited | repeat : Boolean 确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。 | Texture
 | root : ConcreteTexture [override] [read-only] 作为基本(根节点)的那个符合2的幂数要求的纹理对象 | ConcreteTexture
 | scale : Number [override] [read-only] The scale factor, which influences width and height properties. | ConcreteTexture
 | width : Number [override] [read-only] 以像素为单位的纹理宽度。 | ConcreteTexture
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
ConcreteTexture(base:TextureBase, format:String, width:int, height:int, mipMapping:Boolean, premultipliedAlpha:Boolean, optimizedForRenderTexture:Boolean = false, scale:Number = 1)
创建一个具有TextureBase和存储信息(关于尺寸,mip映射和该Texture对象的alpha通道是否被 预乘到RGB)的ConcreteTexture对象。
ConcreteTexture
Inherited
adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void
转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
Texture
dispose():void
[override] 释放TextureBase对象的纹理数据。
ConcreteTexture
Inherited
empty(width:int = 64, height:int = 64, premultipliedAlpha:Boolean = false, optimizeForRenderToTexture:Boolean = true, scale:Number = -1):Texture
[static] 根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。
Texture
Inherited
fromAtfData(data:ByteArray, scale:Number = 1, useMipMaps:Boolean = true, loadAsync:Function = null):Texture
[static] 通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。 如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;
Texture
Inherited
fromBitmap(data:Bitmap, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromBitmapData(data:BitmapData, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromColor(width:int, height:int, color:uint = 0xffffffff, optimizeForRenderToTexture:Boolean = false, scale:Number = -1):Texture
[static] 创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。
Texture
Inherited
fromTexture(texture:Texture, region:Rectangle = null, frame:Rectangle = null):Texture
[static] 从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。
Texture
restoreOnLostContext(data:Object):void
指示此实例在上下文丢失时恢复其基本纹理。数据可以是BitmapData或包含ATF数据的ByteArray。
ConcreteTexture
Property Detail
base property
base:TextureBase [read-only] [override]

纹理所基于的Stage3D纹理对象。

Implementation
    public function get base():TextureBase
format property
format:String [read-only] [override]

基本纹理数据的Context3DTextureFormat。

Implementation
    public function get format():String
height property
height:Number [read-only] [override]

以像素为单位的纹理高度。

Implementation
    public function get height():Number
mipMapping property
mipMapping:Boolean [read-only] [override]

表明纹理是否包含mip映射集。

Implementation
    public function get mipMapping():Boolean
nativeHeight property
nativeHeight:Number [read-only] [override]

纹理的像素高度(忽略缩放参数).

Implementation
    public function get nativeHeight():Number
nativeWidth property
nativeWidth:Number [read-only] [override]

纹理的像素宽度(忽略缩放参数).

Implementation
    public function get nativeWidth():Number
optimizedForRenderTexture property
optimizedForRenderTexture:Boolean [read-only]

表示当基础纹理进行纹理渲染时是否优化。

Implementation
    public function get optimizedForRenderTexture():Boolean
premultipliedAlpha property
premultipliedAlpha:Boolean [read-only] [override]

表明透明值是否被预乘到了RGB值中。

Implementation
    public function get premultipliedAlpha():Boolean
root property
root:ConcreteTexture [read-only] [override]

作为基本(根节点)的那个符合2的幂数要求的纹理对象

Implementation
    public function get root():ConcreteTexture
scale property
scale:Number [read-only] [override]

The scale factor, which influences width and height properties.

Implementation
    public function get scale():Number
width property
width:Number [read-only] [override]

以像素为单位的纹理宽度。

Implementation
    public function get width():Number
Constructor Detail
ConcreteTexture () Constructor
public function ConcreteTexture(base:TextureBase, format:String, width:int, height:int, mipMapping:Boolean, premultipliedAlpha:Boolean, optimizedForRenderTexture:Boolean = false, scale:Number = 1)

创建一个具有TextureBase和存储信息(关于尺寸,mip映射和该Texture对象的alpha通道是否被 预乘到RGB)的ConcreteTexture对象。

Parameters
base:TextureBase — TextureBase对象
format:String — 格式
width:int — 宽度
height:int — 高度
mipMapping:Boolean — mip映射
premultipliedAlpha:Boolean — 预乘透明度
optimizedForRenderTexture:Boolean (default = false) — 优化渲染
scale:Number (default = 1) — 缩放比例
Method Detail
dispose () method
override public function dispose():void

释放TextureBase对象的纹理数据。

restoreOnLostContext () method
public function restoreOnLostContext(data:Object):void

指示此实例在上下文丢失时恢复其基本纹理。数据可以是BitmapData或包含ATF数据的ByteArray。

Parameters

data:Object


starling.textures.RenderTexture

RenderTexture | Properties | Methods
Package | starling.textures
Class | public class RenderTexture
Inheritance | RenderTexture Inheritance SubTexture Inheritance Texture Inheritance Object

RenderTexture是一个能在其上绘制任何显示对象的动态纹理。

在创建一个RenderTexture对象后，仅需调用 drawObject 方法直接在纹理上渲染一个对象。 对象将会在当前位置，连带当前的旋转，缩放和透明值属性被绘制在纹理上。

绘制能够被高效的完成，因为它在显存中是直接发生的。绘制能够被高效的完成，因为它在显存中是直接发生的。 当你在纹理上绘制完对象后，不管你绘制了多少个对象，它的性能将和通常的纹理没什么区别。

如果你一次绘制许多的对象的话，推荐通过drawBundled方法把绘制调用捆绑在一个代码块中，像下面展示的一样。 那将会产生极大地提速，允许你迅速绘制几百个对象。

      renderTexture.drawBundled(function():void
      {
         for (var i:int=0; i<numDrawings; ++i)
         {
             image.rotation = (2 * Math.PI / numDrawings) * i;
             renderTexture.draw(image);
         }
      });

为了擦除一个经渲染纹理的一部分，你可以使用像“rubber”一样的任意显示对象通过设置它的混合模式为"BlendMode.ERASE"。

注意当Starling的渲染上下文丢失，渲染纹理就不能够被恢复。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | base : TextureBase [override] [read-only] 纹理所基于的Stage3D纹理对象。 | RenderTexture
Inherited | clipping : Rectangle [read-only] 一个在初始化时规定缩放到[0.0, 1.0]的裁剪矩形区域。 | SubTexture
Inherited | format : String [override] [read-only] 基本纹理数据的Context3DTextureFormat。 | SubTexture
Inherited | frame : Rectangle [read-only] 纹理框架（参阅类描述） | Texture
Inherited | height : Number [override] [read-only] 以像素为单位的纹理高度。 | SubTexture
 | isPersistent : Boolean [read-only] 指明纹理在经过多次绘制之后是否是持久的。 | RenderTexture
Inherited | mipMapping : Boolean [override] [read-only] 表明纹理是否包含mip映射集。 | SubTexture
Inherited | nativeHeight : Number [override] [read-only] 纹理的像素高度(忽略缩放参数). | SubTexture
Inherited | nativeWidth : Number [override] [read-only] 纹理的像素宽度(忽略缩放参数). | SubTexture
Inherited | ownsParent : Boolean [read-only] 指示父级纹理对象是否因当前子纹理对象的释放而释放。 | SubTexture
Inherited | parent : Texture [read-only] 该子纹理所基于的纹理对象。 | SubTexture
Inherited | premultipliedAlpha : Boolean [override] [read-only] 表明透明值是否被预乘到了RGB值中。 | SubTexture
Inherited | repeat : Boolean 确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。 | Texture
 | root : ConcreteTexture [override] [read-only] 作为基本(根节点)的那个符合2的幂数要求的纹理对象 | RenderTexture
Inherited | scale : Number [override] [read-only] 缩放比例因素,影响宽度和高度。 | SubTexture
Inherited | width : Number [override] [read-only] 以像素为单位的纹理宽度。 | SubTexture
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
RenderTexture(width:int, height:int, persistent:Boolean = true, scale:Number = -1)
创建一个某一尺寸的新RenderTexture对象。如果设置presistent为true，在每次调用绘制之后纹理的内容都会原封不动的 保留下来，允许你像使用画布一样使用纹理。相反的设为false，将会在每次调用绘制时先进行清除操作。 前一种会加倍所需要的显示内存！因此如果你只需一次绘制调用或一次块绘制调用，你应该停用它。
RenderTexture
Inherited
adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void
[override] 转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
SubTexture
clear():void
清除纹理（恢复完整透明值）。
RenderTexture
dispose():void
[override] 如果ownsParent为true释放父级纹理对象。
RenderTexture
draw(object:DisplayObject, matrix:Matrix = null, alpha:Number = 1.0, antiAliasing:int = 0):void
绘制一个对象到纹理上。
RenderTexture
drawBundled(drawingBlock:Function, antiAliasing:int = 0):void
把几个draw的调用一起捆绑在一个代码块中。这就避免了缓冲开关并且允许你绘制多 个对象到一个非持久（non-persistent）的纹理上。
RenderTexture
Inherited
empty(width:int = 64, height:int = 64, premultipliedAlpha:Boolean = false, optimizeForRenderToTexture:Boolean = true, scale:Number = -1):Texture
[static] 根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。
Texture
Inherited
fromAtfData(data:ByteArray, scale:Number = 1, useMipMaps:Boolean = true, loadAsync:Function = null):Texture
[static] 通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。 如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;
Texture
Inherited
fromBitmap(data:Bitmap, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromBitmapData(data:BitmapData, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromColor(width:int, height:int, color:uint = 0xffffffff, optimizeForRenderToTexture:Boolean = false, scale:Number = -1):Texture
[static] 创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。
Texture
Inherited
fromTexture(texture:Texture, region:Rectangle = null, frame:Rectangle = null):Texture
[static] 从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。
Texture
Property Detail
base property
base:TextureBase [read-only] [override]

纹理所基于的Stage3D纹理对象。

Implementation
    public function get base():TextureBase
isPersistent property
isPersistent:Boolean [read-only]

指明纹理在经过多次绘制之后是否是持久的。

Implementation
    public function get isPersistent():Boolean
root property
root:ConcreteTexture [read-only] [override]

作为基本(根节点)的那个符合2的幂数要求的纹理对象

Implementation
    public function get root():ConcreteTexture
Constructor Detail
RenderTexture () Constructor
public function RenderTexture(width:int, height:int, persistent:Boolean = true, scale:Number = -1)

创建一个某一尺寸的新RenderTexture对象。如果设置presistent为true，在每次调用绘制之后纹理的内容都会原封不动的 保留下来，允许你像使用画布一样使用纹理。相反的设为false，将会在每次调用绘制时先进行清除操作。 前一种会加倍所需要的显示内存！因此如果你只需一次绘制调用或一次块绘制调用，你应该停用它。

Parameters
width:int — 宽度
height:int — 高度
persistent:Boolean (default = true) — 是否保留原内容
scale:Number (default = -1) — 缩放比例
Method Detail
clear () method
public function clear():void

清除纹理（恢复完整透明值）。

dispose () method
override public function dispose():void

如果ownsParent为true释放父级纹理对象。

draw () method
public function draw(object:DisplayObject, matrix:Matrix = null, alpha:Number = 1.0, antiAliasing:int = 0):void

绘制一个对象到纹理上。

Parameters

object:DisplayObject — 要绘制的对象。
matrix:Matrix (default = null) — 如果matrix参数为空，对象绘制时将采用它的位置，缩放和旋转属性。如果不为空， 对象将会根据matrix的描述来绘制。
alpha:Number (default = 1.0) — 对象的透明度将被乘以这个值。
antiAliasing:int (default = 0) — 这个参数目前被Stage3D忽略。

drawBundled () method
public function drawBundled(drawingBlock:Function, antiAliasing:int = 0):void

把几个draw的调用一起捆绑在一个代码块中。这就避免了缓冲开关并且允许你绘制多 个对象到一个非持久（non-persistent）的纹理上。

Parameters

drawingBlock:Function — 代码块
antiAliasing:int (default = 0) — 抗锯齿层级


starling.textures.SubTexture

SubTexture | Properties | Methods
Package | starling.textures
Class | public class SubTexture
Inheritance | SubTexture Inheritance Texture Inheritance Object
Subclasses | RenderTexture

一个SubTexture用于表现另一个纹理的一部分。由于这是完全通过操作纹理坐标实现的，使得这个类非常高效。

注意：从子纹理继续创建子纹理也是允许的。

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined By
 | base : TextureBase [override] [read-only] 纹理所基于的Stage3D纹理对象。 | SubTexture
 | clipping : Rectangle [read-only] 一个在初始化时规定缩放到[0.0, 1.0]的裁剪矩形区域。 | SubTexture
 | format : String [override] [read-only] 基本纹理数据的Context3DTextureFormat。 | SubTexture
Inherited | frame : Rectangle [read-only] 纹理框架（参阅类描述） | Texture
 | height : Number [override] [read-only] 以像素为单位的纹理高度。 | SubTexture
 | mipMapping : Boolean [override] [read-only] 表明纹理是否包含mip映射集。 | SubTexture
 | nativeHeight : Number [override] [read-only] 纹理的像素高度(忽略缩放参数). | SubTexture
 | nativeWidth : Number [override] [read-only] 纹理的像素宽度(忽略缩放参数). | SubTexture
 | ownsParent : Boolean [read-only] 指示父级纹理对象是否因当前子纹理对象的释放而释放。 | SubTexture
 | parent : Texture [read-only] 该子纹理所基于的纹理对象。 | SubTexture
 | premultipliedAlpha : Boolean [override] [read-only] 表明透明值是否被预乘到了RGB值中。 | SubTexture
Inherited | repeat : Boolean 确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。 | Texture
 | root : ConcreteTexture [override] [read-only] 作为基本(根节点)的那个符合2的幂数要求的纹理对象 | SubTexture
 | scale : Number [override] [read-only] 缩放比例因素,影响宽度和高度。 | SubTexture
 | width : Number [override] [read-only] 以像素为单位的纹理宽度。 | SubTexture
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined By
SubTexture(parentTexture:Texture, region:Rectangle, ownsParent:Boolean = false)
从一个父级纹理对象指定的区域（点）来创建一个新的SubTexture对象。 如果ownsParent设置为true，当子纹理被释放的时，父级纹理对象也会被释放。
SubTexture
adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void
[override] 转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
SubTexture
dispose():void
[override] 如果ownsParent为true释放父级纹理对象。
SubTexture
Inherited
empty(width:int = 64, height:int = 64, premultipliedAlpha:Boolean = false, optimizeForRenderToTexture:Boolean = true, scale:Number = -1):Texture
[static] 根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。
Texture
Inherited
fromAtfData(data:ByteArray, scale:Number = 1, useMipMaps:Boolean = true, loadAsync:Function = null):Texture
[static] 通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。 如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;
Texture
Inherited
fromBitmap(data:Bitmap, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromBitmapData(data:BitmapData, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
Inherited
fromColor(width:int, height:int, color:uint = 0xffffffff, optimizeForRenderToTexture:Boolean = false, scale:Number = -1):Texture
[static] 创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。
Texture
Inherited
fromTexture(texture:Texture, region:Rectangle = null, frame:Rectangle = null):Texture
[static] 从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。
Texture
Property Detail
base property
base:TextureBase [read-only] [override]

纹理所基于的Stage3D纹理对象。

Implementation
    public function get base():TextureBase
clipping property
clipping:Rectangle [read-only]

一个在初始化时规定缩放到[0.0, 1.0]的裁剪矩形区域。

Implementation
    public function get clipping():Rectangle
format property
format:String [read-only] [override]

基本纹理数据的Context3DTextureFormat。

Implementation
    public function get format():String
height property
height:Number [read-only] [override]

以像素为单位的纹理高度。

Implementation
    public function get height():Number
mipMapping property
mipMapping:Boolean [read-only] [override]

表明纹理是否包含mip映射集。

Implementation
    public function get mipMapping():Boolean
nativeHeight property
nativeHeight:Number [read-only] [override]

纹理的像素高度(忽略缩放参数).

Implementation
    public function get nativeHeight():Number
nativeWidth property
nativeWidth:Number [read-only] [override]

纹理的像素宽度(忽略缩放参数).

Implementation
    public function get nativeWidth():Number
ownsParent property
ownsParent:Boolean [read-only]

指示父级纹理对象是否因当前子纹理对象的释放而释放。

Implementation
    public function get ownsParent():Boolean
parent property
parent:Texture [read-only]

该子纹理所基于的纹理对象。

Implementation
    public function get parent():Texture
premultipliedAlpha property
premultipliedAlpha:Boolean [read-only] [override]

表明透明值是否被预乘到了RGB值中。

Implementation
    public function get premultipliedAlpha():Boolean
root property
root:ConcreteTexture [read-only] [override]

作为基本(根节点)的那个符合2的幂数要求的纹理对象

Implementation
    public function get root():ConcreteTexture
scale property
scale:Number [read-only] [override]

缩放比例因素,影响宽度和高度。

Implementation
    public function get scale():Number
width property
width:Number [read-only] [override]

以像素为单位的纹理宽度。

Implementation
    public function get width():Number
Constructor Detail
SubTexture () Constructor
public function SubTexture(parentTexture:Texture, region:Rectangle, ownsParent:Boolean = false)

从一个父级纹理对象指定的区域（点）来创建一个新的SubTexture对象。 如果ownsParent设置为true，当子纹理被释放的时，父级纹理对象也会被释放。

Parameters
parentTexture:Texture — 父级Texture对象
region:Rectangle — 区域
ownsParent:Boolean (default = false) — 是否连带释放
Method Detail
adjustVertexData () method
override public function adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void

转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。

Parameters

vertexData:VertexData — 顶点数据
vertexID:int — 顶点ID
count:int — 计数器

dispose () method
override public function dispose():void

如果ownsParent为true释放父级纹理对象。


starling.textures.Texture

Texture | Properties | Methods
Package | starling.textures
Class | public class Texture
Inheritance | Texture Inheritance Object
Subclasses | ConcreteTexture, SubTexture

纹理是用来储存展示图像的信息。它不能直接被添加到显示列表；相应的它必须映射到一个显示对象上。 在Staring中那个显示对象就是“Image”类。

纹理格式

纹理能够由一个“BitmapData”对象创建，Starling能够支持任何Flash所支持的bitmap格式。 并且由于你能够将任何Flash显示对象转换为BitmapData对象，你就能够利用这点在Starling中 去显示非Starling内容,比如说Shape对象。

Starling同时支持ATF纹理（Adobe Texture Format），一个能够通过GPU高效渲染的被压缩纹理的容器。

Mip映射

MipMaps是按比例缩小的纹理类型。当一个图像被显示时小于它本来的尺寸时， GPU可能就会用mip maps去替代原生纹理。这就可以减少走样和加速渲染。当然这也需要额外的内存开销； 你可以权衡利弊之后选择是否使用它。

纹理框架

纹理的frame属性允许你设置纹理在image对象中的界限，在纹理周围留有透明空白区域。 frame矩形被指定在纹理的坐标系统中，而不是image:

      var frame:Rectangle = new Rectangle(-10, -10, 30, 30);
      var texture:Texture = Texture.fromTexture(anotherTexture, null, frame);
      var image:Image = new Image(texture);

这段代码会创建一个30x30大小的图像，纹理会被放置在图像x=10, y=10 的位置上（假设'anotherTexture'是一个宽高都为10像素的纹理，它将出现在图像的正中位置）。

纹理集就采用了这个特性，它允许裁剪一个纹理的透明边缘用来弥补由指定的原始纹理框架改变的尺寸。 可以使用TexturePacker这样的工具来优化纹理集。

纹理坐标系

假如，从另一方面讲，你只想在图像中显示纹理的一部分（就是说修剪这个纹理）， 你可以创建一个子纹理（通过方法'Texture.fromTexture()'然后指定一个限定范围的矩形）， 或者你也可以操作image对象的纹理坐标系。方法'image.setTexCoords'允许你那样做。

See also

starling.display.Image
TextureAtlas

Public Properties
Property |  | Defined By
 | base : TextureBase [read-only] 纹理所基于的Stage3D纹理对象。 | Texture
 | format : String [read-only] 基本纹理数据的Context3DTextureFormat。 | Texture
 | frame : Rectangle [read-only] 纹理框架（参阅类描述） | Texture
 | height : Number [read-only] 以像素为单位的纹理高度。 | Texture
 | mipMapping : Boolean [read-only] 表明纹理是否包含mip映射集。 | Texture
 | nativeHeight : Number [read-only] 纹理的像素高度(忽略缩放参数). | Texture
 | nativeWidth : Number [read-only] 纹理的像素宽度(忽略缩放参数). | Texture
 | premultipliedAlpha : Boolean [read-only] 表明透明值是否被预乘到了RGB值中。 | Texture
 | repeat : Boolean 确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。 | Texture
 | root : ConcreteTexture [read-only] 作为基本(根节点)的那个符合2的幂数要求的纹理对象 | Texture
 | scale : Number [read-only] 缩放比例因素,影响宽度和高度。 | Texture
 | width : Number [read-only] 以像素为单位的纹理宽度。 | Texture
Public Methods
Method Defined By
adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void
转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。
Texture
dispose():void
销毁基本纹理。注意并非所有的纹理都需要销毁：SubTextures(从'Texture.fromTexture'创建的)只是引用其它的纹理， 并且并不占用额外的资源空间；它可能是一个纹理图集的一部分。
Texture
empty(width:int = 64, height:int = 64, premultipliedAlpha:Boolean = false, optimizeForRenderToTexture:Boolean = true, scale:Number = -1):Texture
[static] 根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。
Texture
fromAtfData(data:ByteArray, scale:Number = 1, useMipMaps:Boolean = true, loadAsync:Function = null):Texture
[static] 通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。 如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;
Texture
fromBitmap(data:Bitmap, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
fromBitmapData(data:BitmapData, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture
[static] 通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。
Texture
fromColor(width:int, height:int, color:uint = 0xffffffff, optimizeForRenderToTexture:Boolean = false, scale:Number = -1):Texture
[static] 创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。
Texture
fromTexture(texture:Texture, region:Rectangle = null, frame:Rectangle = null):Texture
[static] 从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。
Texture
Property Detail
base property
base:TextureBase [read-only]

纹理所基于的Stage3D纹理对象。

Implementation
    public function get base():TextureBase
format property
format:String [read-only]

基本纹理数据的Context3DTextureFormat。

Implementation
    public function get format():String
frame property
frame:Rectangle [read-only]

纹理框架（参阅类描述）

Implementation
    public function get frame():Rectangle
height property
height:Number [read-only]

以像素为单位的纹理高度。

Implementation
    public function get height():Number
mipMapping property
mipMapping:Boolean [read-only]

表明纹理是否包含mip映射集。

Implementation
    public function get mipMapping():Boolean
nativeHeight property
nativeHeight:Number [read-only]

纹理的像素高度(忽略缩放参数).

Implementation
    public function get nativeHeight():Number
nativeWidth property
nativeWidth:Number [read-only]

纹理的像素宽度(忽略缩放参数).

Implementation
    public function get nativeWidth():Number
premultipliedAlpha property
premultipliedAlpha:Boolean [read-only]

表明透明值是否被预乘到了RGB值中。

Implementation
    public function get premultipliedAlpha():Boolean
repeat property
repeat:Boolean

确定纹理是否应该像墙纸一样平铺或者拉伸最外面的像素点。 注意：只有当纹理边长是2的幂数并且不是从一个纹理集（即无子纹理）中加载的才有效。

Implementation
    public function get repeat():Boolean
    public function set repeat(value:Boolean):void
root property
root:ConcreteTexture [read-only]

作为基本(根节点)的那个符合2的幂数要求的纹理对象

Implementation
    public function get root():ConcreteTexture
scale property
scale:Number [read-only]

缩放比例因素,影响宽度和高度。

Implementation
    public function get scale():Number
width property
width:Number [read-only]

以像素为单位的纹理宽度。

Implementation
    public function get width():Number
Method Detail
adjustVertexData () method
public function adjustVertexData(vertexData:VertexData, vertexID:int, count:int):void

转换纹理的坐标系和原始顶点位置数据为渲染所需要的格式。

Parameters

vertexData:VertexData — 顶点数据
vertexID:int — 顶点ID
count:int — 计数器

dispose () method
public function dispose():void

销毁基本纹理。注意并非所有的纹理都需要销毁：SubTextures(从'Texture.fromTexture'创建的)只是引用其它的纹理， 并且并不占用额外的资源空间；它可能是一个纹理图集的一部分。

empty () method
public static function empty(width:int = 64, height:int = 64, premultipliedAlpha:Boolean = false, optimizeForRenderToTexture:Boolean = true, scale:Number = -1):Texture

根据指定的尺寸创建一个空纹理。主要用于渲染纹理的时候。注意纹理只能在你上传一些颜色数据或清除纹理才能被使用，尽管它实际上是一个渲染目标。

Parameters

width:int (default = 64) — 点数，实际像素宽度取决于缩放比例
height:int (default = 64) — 点数，实际像素高度取决于缩放比例
premultipliedAlpha:Boolean (default = false) — 预乘透明度
optimizeForRenderToTexture:Boolean (default = true) — 表示这个纹理是否会被用来作为渲染目标
scale:Number (default = -1) — 如果省略该参数，"Starling.contentScaleFactor"将被使用。

Returns
Texture
fromAtfData () method
public static function fromAtfData(data:ByteArray, scale:Number = 1, useMipMaps:Boolean = true, loadAsync:Function = null):Texture

通过压缩的ATF格式来创建纹理对象。如果你不想使用嵌入的mip映射，可以通过设置"useMipMaps" 为 false来禁用。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。

如果你通过'loadAsync'参数传递了一个方法，这个方法会被立刻返回，然后纹理将会被异步创建。它可以被用来快速执行一个回调。这个方法的定义应该是这个格式： function(texture:Texture):void;

Parameters

data:ByteArray — 包含压缩纹理的字节数组
scale:Number (default = 1) — 缩放比例
useMipMaps:Boolean (default = true) — 是否使用mip映射
loadAsync:Function (default = null) — 异步加载方法

Returns
Texture — Texture
fromBitmap () method
public static function fromBitmap(data:Bitmap, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture

通过一个bitmap来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。

Parameters

data:Bitmap — Bitmap对象
generateMipMaps:Boolean (default = true) — 生成mip映射
optimizeForRenderToTexture:Boolean (default = false) — 优化渲染
scale:Number (default = 1) — 缩放比例

Returns
Texture — Texture
fromBitmapData () method
public static function fromBitmapData(data:BitmapData, generateMipMaps:Boolean = true, optimizeForRenderToTexture:Boolean = false, scale:Number = 1):Texture

通过一个BitmapData来创建纹理对象。 注意：如果Starling需要处理一个丢失的设备上下文，那么不允许你释放纹理数据。

Parameters

data:BitmapData — BitmapData对象
generateMipMaps:Boolean (default = true) — 生成mip映射
optimizeForRenderToTexture:Boolean (default = false) — 优化渲染
scale:Number (default = 1) — 缩放比例

Returns
Texture — Texture
fromColor () method
public static function fromColor(width:int, height:int, color:uint = 0xffffffff, optimizeForRenderToTexture:Boolean = false, scale:Number = -1):Texture

创建某一尺寸、颜色的空纹理。颜色参数需要制定为ARGB格式。

Parameters

width:int — 点数，实际像素宽度取决于缩放比例
height:int — 点数，实际像素高度取决于缩放比例
color:uint (default = 0xffffffff) — 使用的是ARGB格式 (包含透明度!)
optimizeForRenderToTexture:Boolean (default = false) — 表示这个纹理是否会被用来作为渲染目标
scale:Number (default = -1) — 如果省略该参数，"Starling.contentScaleFactor"将被使用。

Returns
Texture
fromTexture () method
public static function fromTexture(texture:Texture, region:Rectangle = null, frame:Rectangle = null):Texture

从另一个纹理创建一个限定范围的纹理（以像素为单位）。 这个新的纹理将会引用基础纹理；没有复制数据。

Parameters

texture:Texture — 原纹理对象
region:Rectangle (default = null) — 区域
frame:Rectangle (default = null) — 外框

Returns
Texture — Texture


starling.textures.TextureAtlas

TextureAtlas | Methods
Package | starling.textures
Class | public class TextureAtlas
Inheritance | TextureAtlas Inheritance Object

纹理集是一个将许多小的纹理整合到一张大图中。这个类是用来从一个纹理集中读取纹理。

使用纹理集能为你的纹理解决两个问题:

  • 在一定的时间内，始终有一个纹理处于活动的。每当你改变了处于活动的纹理，一个 “纹理切换”就会执行，这个切换是需要时间的。
  • 任何Stage3D纹理的边长都必须是2的幂数。Starling向你隐藏了这个限制，但这将带来 额外的图形存储成本。

通过使用纹理集，您可以避免使用纹理切换和取消2的幂数的限制。所有的纹理被集合在一 个“超级纹理”，并且Starling会确保纹理正确的部分被显示出来。

有几种方法来创建纹理集。一种是使用捆绑在Starling的姊妹框架 Sparrow framework。里的纹理集生成脚本。 尽管目前这个脚本只能运行在Mac OS X上。 另一个可供选择的出色工具 Texture Packer， 他是一个跨平台的商业软件。

无论您使用的工具是什么，Starling可以支持以下文档格式:

         <TextureAtlas imagePath='atlas.png'>
           <SubTexture name='texture_1' x='0'  y='0' width='50' height='50'/>
           <SubTexture name='texture_2' x='50' y='0' width='20' height='30'/>
         </TextureAtlas>

如果你的图像在边缘具有透明区域，您可以使用Texture类的frame属性。 通过 去除纹理的透明边缘并且指定原始尺寸就像这样：

         <SubTexture name='trimmed' x='0' y='0' height='10' width='10'
             frameX='-10' frameY='-10' frameWidth='30' frameHeight='30'/>

Public Methods
Method |  | Defined By
 | TextureAtlas(texture:Texture, atlasXml:XML = null) 通过指定纹理和用于描述范围的XML来创建一个纹理集。 | TextureAtlas
 | addRegion(name:String, region:Rectangle, frame:Rectangle = null):void 为一个subtexture(通过像素坐标系里的矩阵来描述)添加一个含名字的区域以及一个可选的frame参数。 | TextureAtlas
 | dispose():void 释放纹理集。 | TextureAtlas
 | getFrame(name:String):Rectangle 根据一个特定区域返回一个矩形框架,如果那个区域内没有框架就返回null。 | TextureAtlas
 | getNames(prefix:String, result:Vector.<String> = null):Vector.<String> 根据指定的起始字符串，返回符合条件的所有纹理名称，按字母顺序排序。 | TextureAtlas
 | getRegion(name:String):Rectangle 根据特定名称返回一个矩形区域。 | TextureAtlas
 | getTexture(name:String):Texture 根据名称返回一个子纹理。如果没有找到，就返回null。 | TextureAtlas
 | getTextures(prefix:String, result:Vector.<Texture> = null):Vector.<Texture> 返回由一个指定的字符串开始按字母排序的所有纹理(这对"MovieClip"来说非常有用)。 | TextureAtlas
 | removeRegion(name:String):void 通过名字来删除一个区域。 | TextureAtlas
Protected Methods
Method |  | Defined By
 | parseAtlasXml(atlasXml:XML):void 这个函数被构造函数调用,并用Starling默认的纹理集格式解析XML,重写 这个方法去创建自定义逻辑(举例来说 去支持一个不同的文档格式)。 | TextureAtlas
Constructor Detail
TextureAtlas () Constructor
public function TextureAtlas(texture:Texture, atlasXml:XML = null)

通过指定纹理和用于描述范围的XML来创建一个纹理集。

Parameters
texture:Texture — 纹理对象
atlasXml:XML (default = null) — 纹理XML描述
Method Detail
addRegion () method
public function addRegion(name:String, region:Rectangle, frame:Rectangle = null):void

为一个subtexture(通过像素坐标系里的矩阵来描述)添加一个含名字的区域以及一个可选的frame参数。

Parameters

name:String
region:Rectangle
frame:Rectangle (default = null)

dispose () method
public function dispose():void

释放纹理集。

getFrame () method
public function getFrame(name:String):Rectangle

根据一个特定区域返回一个矩形框架,如果那个区域内没有框架就返回null。

Parameters

name:String

Returns
Rectangle
getNames () method
public function getNames(prefix:String, result:Vector.<String> = null):Vector.<String>

根据指定的起始字符串，返回符合条件的所有纹理名称，按字母顺序排序。

Parameters

prefix:String
result:Vector.<String> (default = null)

Returns
Vector.<String>
getRegion () method
public function getRegion(name:String):Rectangle

根据特定名称返回一个矩形区域。

Parameters

name:String

Returns
Rectangle
getTexture () method
public function getTexture(name:String):Texture

根据名称返回一个子纹理。如果没有找到，就返回null。

Parameters

name:String

Returns
Texture
getTextures () method
public function getTextures(prefix:String, result:Vector.<Texture> = null):Vector.<Texture>

返回由一个指定的字符串开始按字母排序的所有纹理(这对"MovieClip"来说非常有用)。

Parameters

prefix:String
result:Vector.<Texture> (default = null)

Returns
Vector.<Texture>
parseAtlasXml () method
protected function parseAtlasXml(atlasXml:XML):void

这个函数被构造函数调用,并用Starling默认的纹理集格式解析XML,重写 这个方法去创建自定义逻辑(举例来说 去支持一个不同的文档格式)。

Parameters

atlasXml:XML

removeRegion () method
public function removeRegion(name:String):void

通过名字来删除一个区域。

Parameters

name:String


starling.textures.TextureSmoothing

TextureSmoothing | Methods | Constants
Package | starling.textures
Class | public class TextureSmoothing
Inheritance | TextureSmoothing Inheritance Object

这个类为可能的材质平滑算法提供常量值。

Public Methods
Method |  | Defined By
 | isValid(smoothing:String):Boolean [static] 确定一个平滑值是否是有效的。 | TextureSmoothing
Public Constants
Constant |  | Defined By
 | BILINEAR : String = bilinear [static] 双线性过滤。创建像素间的平滑过渡。 | TextureSmoothing
 | NONE : String = none [static] 不具备平滑, 通常称之为"Nearest Neighbor"。像素将放大成大个的矩形。 | TextureSmoothing
 | TRILINEAR : String = trilinear [static] 三线性过滤。通过考虑使用更高级别的MIP映射.实现最高级别的渲染质量。 | TextureSmoothing
Method Detail
isValid () method
public static function isValid(smoothing:String):Boolean

确定一个平滑值是否是有效的。

Parameters

smoothing:String

Returns
Boolean
Constant Detail
BILINEAR Constant
public static const BILINEAR:String = bilinear

双线性过滤。创建像素间的平滑过渡。

NONE Constant
public static const NONE:String = none

不具备平滑, 通常称之为"Nearest Neighbor"。像素将放大成大个的矩形。

TRILINEAR Constant
public static const TRILINEAR:String = trilinear

三线性过滤。通过考虑使用更高级别的MIP映射.实现最高级别的渲染质量。


starling.utils - Starling API 1.3 | Starling中文站

Package starling.utils

Functions
deg2rad()
formatString()
getNextPowerOfTwo()
rad2deg()
transformCoords()
Classes
AssetManager
Color
HAlign
MatrixUtil
RectangleUtil
ScaleMode
VAlign
VertexData


starling.utils Details

Package | Functions

Public Methods
Function |  | Defined By
 | deg2rad(deg:Number):Number 角度转换为弧度. | starling.utils
 | formatString(format:String, ... args):String 格式化字符串.样式为配对的大括号(如"{0}").还不支持任何数字格式化选项. | starling.utils
 | getNextPowerOfTwo(number:int):int 返回大于或等于这个指定的数，这个数为紧接着的2的倍数. | starling.utils
 | rad2deg(rad:Number):Number 弧度转换为角度. | starling.utils
 | transformCoords(matrix:Matrix, x:Number, y:Number, resultPoint:Point = null):Point 用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象. | starling.utils
Function detail
deg2rad () function
public function deg2rad(deg:Number):Number

角度转换为弧度.

Parameters

deg:Number

Returns
Number
formatString () function
public function formatString(format:String, ... args):String

格式化字符串.样式为配对的大括号(如"{0}").还不支持任何数字格式化选项.

Parameters

format:String
... args

Returns
String
getNextPowerOfTwo () function
public function getNextPowerOfTwo(number:int):int

返回大于或等于这个指定的数，这个数为紧接着的2的倍数. 比如，getNextPowerOfTwo(3)返回4；getNextPowerOfTwo(8)返回8；getNextPowerOfTwo(9)返回16

Parameters

number:int

Returns
int
rad2deg () function
public function rad2deg(rad:Number):Number

弧度转换为角度.

Parameters

rad:Number

Returns
Number
transformCoords () function
public function transformCoords(matrix:Matrix, x:Number, y:Number, resultPoint:Point = null):Point

用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象.

Parameters

matrix:Matrix
x:Number
y:Number
resultPoint:Point (default = null)

Returns
Point


starling.utils Summary

starling.utils | Functions | Classes

Functions
Function | Description
deg2rad | 角度转换为弧度.
formatString | 格式化字符串.样式为配对的大括号(如"{0}").还不支持任何数字格式化选项.
getNextPowerOfTwo | 返回大于或等于这个指定的数，这个数为紧接着的2的倍数.
rad2deg | 弧度转换为角度.
transformCoords | 用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象.
Classes
Class | Description
AssetManager | AssetManager这个类用于处理加载和访问各种素菜类型。你可以直接添加一个素材（通过'add...'方法），或者通过一个异步队列。 这使得你可以用一种统一的方式来处理资源，不管它们是来自于一个外部加载的文件，一个目录，一个URL地址，还是一个嵌入对象。 如果你是从磁盘上加载文件，那么下面的类型是支持的：png, jpg, atf, mp3, xml, fnt
Color | 一个非常有用的类，包含在不用颜色表现间转换的预定义颜色和方法.
HAlign | 提供物件水平方向上的对齐常量值.
MatrixUtil | 一个包含矩阵相关方法的类
RectangleUtil | 一个增强Rectangle类功能的工具类.
ScaleMode | 用于'RectangleUtil.fit' 方法的缩放模式常量值.
VAlign | 提供物件垂直方向上的对齐常量值.
VertexData | 顶点数据类，它管理一个顶点信息的原始数据列表，允许直接上传到Stage3D顶点缓冲池中.


starling.utils.Color

Color | Methods | Constants
Package | starling.utils
Class | public class Color
Inheritance | Color Inheritance Object

一个非常有用的类，包含在不用颜色表现间转换的预定义颜色和方法.

Public Methods
Method |  | Defined By
 | argb(alpha:int, red:int, green:int, blue:int):uint [static] 创建一个uint的ARGB颜色。各通道范围为0 - 255. | Color
 | getAlpha(color:uint):int [static] 返回ARGB的alpha部分(0 - 255). | Color
 | getBlue(color:uint):int [static] 返回(A)RGB的blue部分(0 - 255). | Color
 | getGreen(color:uint):int [static] 返回(A)RGB的green部分(0 - 255). | Color
 | getRed(color:uint):int [static] 返回(A)RGB的red部分(0 - 255). | Color
 | rgb(red:int, green:int, blue:int):uint [static] 创建一个uint的RGB颜色。各通道范围为0 - 255. | Color
Public Constants
Constant |  | Defined By
 | AQUA : uint = 0x00ffff [static] | Color
 | BLACK : uint = 0x000000 [static] | Color
 | BLUE : uint = 0x0000ff [static] | Color
 | FUCHSIA : uint = 0xff00ff [static] | Color
 | GRAY : uint = 0x808080 [static] | Color
 | GREEN : uint = 0x008000 [static] | Color
 | LIME : uint = 0x00ff00 [static] | Color
 | MAROON : uint = 0x800000 [static] | Color
 | NAVY : uint = 0x000080 [static] | Color
 | OLIVE : uint = 0x808000 [static] | Color
 | PURPLE : uint = 0x800080 [static] | Color
 | RED : uint = 0xff0000 [static] | Color
 | SILVER : uint = 0xc0c0c0 [static] | Color
 | TEAL : uint = 0x008080 [static] | Color
 | WHITE : uint = 0xffffff [static] | Color
 | YELLOW : uint = 0xffff00 [static] | Color
Method Detail
argb () method
public static function argb(alpha:int, red:int, green:int, blue:int):uint

创建一个uint的ARGB颜色。各通道范围为0 - 255.

Parameters

alpha:int
red:int
green:int
blue:int

Returns
uint
getAlpha () method
public static function getAlpha(color:uint):int

返回ARGB的alpha部分(0 - 255).

Parameters

color:uint

Returns
int
getBlue () method
public static function getBlue(color:uint):int

返回(A)RGB的blue部分(0 - 255).

Parameters

color:uint

Returns
int
getGreen () method
public static function getGreen(color:uint):int

返回(A)RGB的green部分(0 - 255).

Parameters

color:uint

Returns
int
getRed () method
public static function getRed(color:uint):int

返回(A)RGB的red部分(0 - 255).

Parameters

color:uint

Returns
int
rgb () method
public static function rgb(red:int, green:int, blue:int):uint

创建一个uint的RGB颜色。各通道范围为0 - 255.

Parameters

red:int
green:int
blue:int

Returns
uint
Constant Detail
AQUA Constant
public static const AQUA:uint = 0x00ffff

BLACK Constant
public static const BLACK:uint = 0x000000

BLUE Constant
public static const BLUE:uint = 0x0000ff

FUCHSIA Constant
public static const FUCHSIA:uint = 0xff00ff

GRAY Constant
public static const GRAY:uint = 0x808080

GREEN Constant
public static const GREEN:uint = 0x008000

LIME Constant
public static const LIME:uint = 0x00ff00

MAROON Constant
public static const MAROON:uint = 0x800000

NAVY Constant
public static const NAVY:uint = 0x000080

OLIVE Constant
public static const OLIVE:uint = 0x808000

PURPLE Constant
public static const PURPLE:uint = 0x800080

RED Constant
public static const RED:uint = 0xff0000

SILVER Constant
public static const SILVER:uint = 0xc0c0c0

TEAL Constant
public static const TEAL:uint = 0x008080

WHITE Constant
public static const WHITE:uint = 0xffffff

YELLOW Constant
public static const YELLOW:uint = 0xffff00


starling.utils.HAlign

HAlign | Methods | Constants
Package | starling.utils
Class | public final class HAlign
Inheritance | HAlign Inheritance Object

提供物件水平方向上的对齐常量值.

Public Methods
Method |  | Defined By
 | isValid(hAlign:String):Boolean [static] 指定给出的对齐字符串是否合法. | HAlign
Public Constants
Constant |  | Defined By
 | CENTER : String = center [static] 居中对齐. | HAlign
 | LEFT : String = left [static] 左对齐. | HAlign
 | RIGHT : String = right [static] 右对齐. | HAlign
Method Detail
isValid () method
public static function isValid(hAlign:String):Boolean

指定给出的对齐字符串是否合法.

Parameters

hAlign:String

Returns
Boolean
Constant Detail
CENTER Constant
public static const CENTER:String = center

居中对齐.

LEFT Constant
public static const LEFT:String = left

左对齐.

RIGHT Constant
public static const RIGHT:String = right

右对齐.


starling.utils.MatrixUtil

MatrixUtil | Methods
Package | starling.utils
Class | public class MatrixUtil
Inheritance | MatrixUtil Inheritance Object

一个包含矩阵相关方法的类

Public Methods
Method |  | Defined By
 | convertTo3D(matrix:Matrix, resultMatrix:Matrix3D = null):Matrix3D [static] 2D矩阵转换为3D矩阵.如果传入'resultMatrix',则结果会存储在这个矩阵中，而不是创建一个新对象. | MatrixUtil
 | prependMatrix(base:Matrix, prep:Matrix):void [static] 通过与另一矩阵相乘，追加矩阵到'base'. | MatrixUtil
 | prependRotation(matrix:Matrix, angle:Number):void [static] 追加一个增量旋转到Matrix3D中. | MatrixUtil
 | prependScale(matrix:Matrix, sx:Number, sy:Number):void [static] 追加一个增量缩放变换到矩阵中. | MatrixUtil
 | prependSkew(matrix:Matrix, skewX:Number, skewY:Number):void [static] 追加一个倾斜变换到矩阵中. | MatrixUtil
 | prependTranslation(matrix:Matrix, tx:Number, ty:Number):void [static] 追加一个增量位移到矩阵中. | MatrixUtil
 | skew(matrix:Matrix, skewX:Number, skewY:Number):void [static] 以一定的弧度附加一个扭曲转换到矩阵中.一个扭曲矩阵如下所示： | cos(skewY) -sin(skewX) 0 | | sin(skewY) cos(skewX) 0 | | 0 0 1 | | MatrixUtil
 | transformCoords(matrix:Matrix, x:Number, y:Number, resultPoint:Point = null):Point [static] 用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象. | MatrixUtil
Method Detail
convertTo3D () method
public static function convertTo3D(matrix:Matrix, resultMatrix:Matrix3D = null):Matrix3D

2D矩阵转换为3D矩阵.如果传入'resultMatrix',则结果会存储在这个矩阵中，而不是创建一个新对象.

Parameters

matrix:Matrix
resultMatrix:Matrix3D (default = null)

Returns
Matrix3D
prependMatrix () method
public static function prependMatrix(base:Matrix, prep:Matrix):void

通过与另一矩阵相乘，追加矩阵到'base'.

Parameters

base:Matrix
prep:Matrix

prependRotation () method
public static function prependRotation(matrix:Matrix, angle:Number):void

追加一个增量旋转到Matrix3D中.

Parameters

matrix:Matrix
angle:Number

prependScale () method
public static function prependScale(matrix:Matrix, sx:Number, sy:Number):void

追加一个增量缩放变换到矩阵中.

Parameters

matrix:Matrix
sx:Number
sy:Number

prependSkew () method
public static function prependSkew(matrix:Matrix, skewX:Number, skewY:Number):void

追加一个倾斜变换到矩阵中. 倾斜矩阵的格式如下:

          | cos(skewY)  -sin(skewX)  0 |
          | sin(skewY)   cos(skewX)  0 |
          |     0            0       1 |

Parameters

matrix:Matrix
skewX:Number
skewY:Number

prependTranslation () method
public static function prependTranslation(matrix:Matrix, tx:Number, ty:Number):void

追加一个增量位移到矩阵中.

Parameters

matrix:Matrix
tx:Number
ty:Number

skew () method
public static function skew(matrix:Matrix, skewX:Number, skewY:Number):void

以一定的弧度附加一个扭曲转换到矩阵中.一个扭曲矩阵如下所示：

          | cos(skewY)  -sin(skewX)  0 |
          | sin(skewY)   cos(skewX)  0 |
          |     0            0       1 |

Parameters

matrix:Matrix
skewX:Number
skewY:Number

transformCoords () method
public static function transformCoords(matrix:Matrix, x:Number, y:Number, resultPoint:Point = null):Point

用一个矩阵转换2D坐标到另一个不同的空间.如果传入'resultPoint',则结果会存储在这个点里，而不是创建一个新对象.

Parameters

matrix:Matrix
x:Number
y:Number
resultPoint:Point (default = null)

Returns
Point


starling.utils.VAlign

VAlign | Methods | Constants
Package | starling.utils
Class | public final class VAlign
Inheritance | VAlign Inheritance Object

提供物件垂直方向上的对齐常量值.

Public Methods
Method |  | Defined By
 | isValid(vAlign:String):Boolean [static] 指定给出的对齐字符串是否合法. | VAlign
Public Constants
Constant |  | Defined By
 | BOTTOM : String = bottom [static] 底对齐. | VAlign
 | CENTER : String = center [static] 居中对齐. | VAlign
 | TOP : String = top [static] 顶部对齐. | VAlign
Method Detail
isValid () method
public static function isValid(vAlign:String):Boolean

指定给出的对齐字符串是否合法.

Parameters

vAlign:String

Returns
Boolean
Constant Detail
BOTTOM Constant
public static const BOTTOM:String = bottom

底对齐.

CENTER Constant
public static const CENTER:String = center

居中对齐.

TOP Constant
public static const TOP:String = top

顶部对齐.


starling.utils.VertexData

VertexData | Properties | Methods | Constants
Package | starling.utils
Class | public class VertexData
Inheritance | VertexData Inheritance Object

顶点数据类，它管理一个顶点信息的原始数据列表，允许直接上传到Stage3D顶点缓冲池中. 如果想用自定义渲染函数创建显示对象，则必须使用此类。如果不打算这种做，你可以安全的忽略它。

要用Stage3D渲染对象，你得组织顶点数据到所谓的顶点缓冲池中。 这些缓冲池位于图像内存中，并可以非常高效的被GPU访问。 在你把数据放入顶点缓冲池之前，你得把它设置到普通内存中 - 也就是在一个矢量对象中。 这个矢量包括所有顶点信息 (坐标，颜色，纹理坐标) - 一个顶点接下一个顶点。

为了简化和工作一个如此庞大的列表，需要创建这个顶点数据类。它包括指定和修改顶点数据的方法。 这个原始矢量由很容易上传到顶点缓冲池的类管理

自左乘Alpha

"BitmapData"对象的颜色值包括自左乘alpha值，这意味着rgb值在保存前，会与alpha相乘。 自从纹理从位图数据中被创建，他们包括同样格式的值。当渲染的时候，它会以alpha值被保存的方式产生差异； 出于这个原因，顶点数据类模拟了这个行为。你可以选择这个alpha应该通过premultipliedAlpha属性被如何处理。

Public Properties
Property |  | Defined By
 | numVertices : int 顶点总数. | VertexData
 | premultipliedAlpha : Boolean [read-only] 返回存储的rgb值是否与此apha值左自乘. | VertexData
 | rawData : Vector.<Number> [read-only] 原始顶点数据; 非克隆数据! | VertexData
 | tinted : Boolean [read-only] 返回所有顶点是否非白或完全透明. | VertexData
Public Methods
Method |  | Defined By
 | VertexData(numVertices:int, premultipliedAlpha:Boolean = false) 用指定的顶点数创建一个新的顶点数据. | VertexData
 | append(data:VertexData):void 从另一个顶点数据对象中追加顶点. | VertexData
 | clone(vertexID:int = 0, numVertices:int = -1):VertexData 创建一个完成顶点数据对象或子集的一个副本. | VertexData
 | copyTo(targetData:VertexData, targetVertexID:int = 0, vertexID:int = 0, numVertices:int = -1):void 拷贝改实例的顶点数据(或者它的一个范围，由'vertexID' 和 'numVertices'定义) 到另一个顶点数据对象，从某个确定索引算起. | VertexData
 | getAlpha(vertexID:int):Number 返回顶点Aplha值 (范围 0-1). | VertexData
 | getBounds(transformationMatrix:Matrix = null, vertexID:int = 0, numVertices:int = -1, resultRect:Rectangle = null):Rectangle 计算顶点范围，可以选择性的通过矩阵进行转换. | VertexData
 | getColor(vertexID:int):uint 返回顶点RGB值 (无alpha). | VertexData
 | getPosition(vertexID:int, position:Point):void 返回顶点位置. | VertexData
 | getTexCoords(vertexID:int, texCoords:Point):void 返回顶点纹理坐标值 (范围 0-1). | VertexData
 | scaleAlpha(vertexID:int, alpha:Number, numVertices:int = 1):void 对指定的顶点alpha值乘以某个delta. | VertexData
 | setAlpha(vertexID:int, alpha:Number):void 更新顶点Aplha值 (范围 0-1). | VertexData
 | setColor(vertexID:int, color:uint):void 更新顶点RGB值. | VertexData
 | setPosition(vertexID:int, x:Number, y:Number):void 更新顶点位置. | VertexData
 | setPremultipliedAlpha(value:Boolean, updateData:Boolean = true):void 改变alpha和颜色值的存储方式. | VertexData
 | setTexCoords(vertexID:int, u:Number, v:Number):void 更新顶点纹理坐标值 (范围 0-1). | VertexData
 | setUniformAlpha(alpha:Number):void 对所有顶点设置相同的alpha值. | VertexData
 | setUniformColor(color:uint):void 对所有顶点设置相同的颜色值. | VertexData
 | transformVertex(vertexID:int, matrix:Matrix, numVertices:int = 1):void 通过与一个转换矩阵来转换后面的顶点位置. | VertexData
 | translateVertex(vertexID:int, deltaX:Number, deltaY:Number):void 以一定偏移量来移动顶点位置. | VertexData
Public Constants
Constant |  | Defined By
 | COLOR_OFFSET : int = 2 [static] 每个顶点内的颜色数据 (r, g, b, a) 偏移量. | VertexData
 | ELEMENTS_PER_VERTEX : int = 8 [static] 存储每个顶点元素的总数量. | VertexData
 | POSITION_OFFSET : int = 0 [static] 每个顶点内的位置数据 (x, y) 偏移量. | VertexData
 | TEXCOORD_OFFSET : int = 6 [static] 每个顶点内的坐标数据 (u, v) 偏移量. | VertexData
Property Detail
numVertices property
numVertices:int

顶点总数.

Implementation
    public function get numVertices():int
    public function set numVertices(value:int):void
premultipliedAlpha property
premultipliedAlpha:Boolean [read-only]

返回存储的rgb值是否与此apha值左自乘.

Implementation
    public function get premultipliedAlpha():Boolean
rawData property
rawData:Vector.<Number> [read-only]

原始顶点数据; 非克隆数据!

Implementation
    public function get rawData():Vector.<Number>
tinted property
tinted:Boolean [read-only]

返回所有顶点是否非白或完全透明.

Implementation
    public function get tinted():Boolean
Constructor Detail
VertexData () Constructor
public function VertexData(numVertices:int, premultipliedAlpha:Boolean = false)

用指定的顶点数创建一个新的顶点数据.

Parameters
numVertices:int
premultipliedAlpha:Boolean (default = false)
Method Detail
append () method
public function append(data:VertexData):void

从另一个顶点数据对象中追加顶点.

Parameters

data:VertexData

clone () method
public function clone(vertexID:int = 0, numVertices:int = -1):VertexData

创建一个完成顶点数据对象或子集的一个副本. 克隆所有顶点，'numVertices'值默认为 '-1'.

Parameters

vertexID:int (default = 0)
numVertices:int (default = -1)

Returns
VertexData
copyTo () method
public function copyTo(targetData:VertexData, targetVertexID:int = 0, vertexID:int = 0, numVertices:int = -1):void

拷贝改实例的顶点数据(或者它的一个范围，由'vertexID' 和 'numVertices'定义) 到另一个顶点数据对象，从某个确定索引算起.

Parameters

targetData:VertexData
targetVertexID:int (default = 0)
vertexID:int (default = 0)
numVertices:int (default = -1)

getAlpha () method
public function getAlpha(vertexID:int):Number

返回顶点Aplha值 (范围 0-1).

Parameters

vertexID:int

Returns
Number
getBounds () method
public function getBounds(transformationMatrix:Matrix = null, vertexID:int = 0, numVertices:int = -1, resultRect:Rectangle = null):Rectangle

计算顶点范围，可以选择性的通过矩阵进行转换. 如果传递resultRect，结果会保存在这个矩阵中，而不会创建一个新对象. 要给所有顶点计算，设置'numVertices' 为 '-1'.

Parameters

transformationMatrix:Matrix (default = null)
vertexID:int (default = 0)
numVertices:int (default = -1)
resultRect:Rectangle (default = null)

Returns
Rectangle
getColor () method
public function getColor(vertexID:int):uint

返回顶点RGB值 (无alpha).

Parameters

vertexID:int

Returns
uint
getPosition () method
public function getPosition(vertexID:int, position:Point):void

返回顶点位置.

Parameters

vertexID:int
position:Point

getTexCoords () method
public function getTexCoords(vertexID:int, texCoords:Point):void

返回顶点纹理坐标值 (范围 0-1).

Parameters

vertexID:int
texCoords:Point

scaleAlpha () method
public function scaleAlpha(vertexID:int, alpha:Number, numVertices:int = 1):void

对指定的顶点alpha值乘以某个delta.

Parameters

vertexID:int
alpha:Number
numVertices:int (default = 1)

setAlpha () method
public function setAlpha(vertexID:int, alpha:Number):void

更新顶点Aplha值 (范围 0-1).

Parameters

vertexID:int
alpha:Number

setColor () method
public function setColor(vertexID:int, color:uint):void

更新顶点RGB值.

Parameters

vertexID:int
color:uint

setPosition () method
public function setPosition(vertexID:int, x:Number, y:Number):void

更新顶点位置.

Parameters

vertexID:int
x:Number
y:Number

setPremultipliedAlpha () method
public function setPremultipliedAlpha(value:Boolean, updateData:Boolean = true):void

改变alpha和颜色值的存储方式. 更新所有存在的顶点.

Parameters

value:Boolean
updateData:Boolean (default = true)

setTexCoords () method
public function setTexCoords(vertexID:int, u:Number, v:Number):void

更新顶点纹理坐标值 (范围 0-1).

Parameters

vertexID:int
u:Number
v:Number

setUniformAlpha () method
public function setUniformAlpha(alpha:Number):void

对所有顶点设置相同的alpha值.

Parameters

alpha:Number

setUniformColor () method
public function setUniformColor(color:uint):void

对所有顶点设置相同的颜色值.

Parameters

color:uint

transformVertex () method
public function transformVertex(vertexID:int, matrix:Matrix, numVertices:int = 1):void

通过与一个转换矩阵来转换后面的顶点位置.

Parameters

vertexID:int
matrix:Matrix
numVertices:int (default = 1)

translateVertex () method
public function translateVertex(vertexID:int, deltaX:Number, deltaY:Number):void

以一定偏移量来移动顶点位置.

Parameters

vertexID:int
deltaX:Number
deltaY:Number

Constant Detail
COLOR_OFFSET Constant
public static const COLOR_OFFSET:int = 2

每个顶点内的颜色数据 (r, g, b, a) 偏移量.

ELEMENTS_PER_VERTEX Constant
public static const ELEMENTS_PER_VERTEX:int = 8

存储每个顶点元素的总数量.

POSITION_OFFSET Constant
public static const POSITION_OFFSET:int = 0

每个顶点内的位置数据 (x, y) 偏移量.

TEXCOORD_OFFSET Constant
public static const TEXCOORD_OFFSET:int = 6

每个顶点内的坐标数据 (u, v) 偏移量.


starling.utils.AssetManager

AssetManager | Properties | Methods
Package | starling.utils
Class | public class AssetManager
Inheritance | AssetManager Inheritance Object

AssetManager这个类用于处理加载和访问各种素菜类型。你可以直接添加一个素材（通过'add...'方法），或者通过一个异步队列。 这使得你可以用一种统一的方式来处理资源，不管它们是来自于一个外部加载的文件，一个目录，一个URL地址，还是一个嵌入对象。

如果你是从磁盘上加载文件，那么下面的类型是支持的：png, jpg, atf, mp3, xml, fnt

Public Properties
Property |  | Defined By
 | scaleFactor : Number 无论是从位图创建的纹理，还是ATF格式的纹理，都会被分配一个缩放比例 | AssetManager
 | useMipMaps : Boolean 对于位图纹理，此标志表示，加载后创建的纹理是否使用MIP映射; 对于ATF格式的纹理，它表示使用的时候MIP映射是否有效。 | AssetManager
 | verbose : Boolean 是否输出加载过程中的信息 | AssetManager
Public Methods
Method |  | Defined By
 | AssetManager(scaleFactor:Number = -1, useMipmaps:Boolean = false) 创建一个新的AssetManager实例。'scaleFactor' 和 'useMipmaps'这两个参数定义了队列中的位图如何转换为纹理。 | AssetManager
 | addSound(name:String, sound:Sound):void 根据指定的名称注册一个声音。注册后立刻可用。 | AssetManager
 | addTexture(name:String, texture:Texture):void 根据指定的名称注册一个纹理。注册后立刻可用。 | AssetManager
 | addTextureAtlas(name:String, atlas:TextureAtlas):void 根据指定的名称注册一个纹理图集。注册后立刻可用。 | AssetManager
 | dispose():void 销毁所有的纹理 | AssetManager
 | enqueue(... rawAssets):void 将一个或一组素材加入到队列中；只有在成功调用了"loadQueue"方法后这些资源才可用。这个方法可以接受下面这些类型： 使用字符串定义的URL，链接到一个本地或远程网络上的资源。支持类型: png, jpg, atf, mp3, fnt, xml (纹理图集). File类的实例 (只有AIR应用适用) 指定的一个目录或一个文件.如果是目录，则会自动扫描该目录下所有支持的文件类型。 包含静态成员结合Embed方式内嵌素材的类. 对象的名称会自动提取：比如一个文件名称是"image.png"，那么会自动将素材命名为"image"。如果是通过类的嵌入素材方式，那么变量名称就会使用嵌入时那个名称。 一个例外是纹理图集：他们将具备相同的名称（实际引用的那个纹理名称）。 | AssetManager
 | getSound(name:String):Sound 根据指定的名称返回一个声音 | AssetManager
 | getSoundNames(prefix:String):Vector.<String> 根据指定的字符串前缀返回符合条件的声音名称，按照字母排序。 | AssetManager
 | getTexture(name:String):Texture 根据指定的名称返回一个纹理。这个方法首先会查询所有直接添加进来的纹理； 如果找不到这个名称的纹理，则会继续从所有的纹理图集中继续查找。 | AssetManager
 | getTextureAtlas(name:String):TextureAtlas 根据指定的名称，返回一个纹理图集，找不到的话就返回null | AssetManager
 | getTextureNames(prefix:String, result:Vector.<String> = null):Vector.<String> 根据一个指定的字符串前缀，返回所有符合条件的纹理名称，按照字母排序。 | AssetManager
 | getTextures(prefix:String, result:Vector.<Texture> = null):Vector.<Texture> 根据指定的字符串前缀，返回所有符合条件的纹理，按照字母排序（对于"MovieClip"非常有用）。 | AssetManager
 | loadQueue(onProgress:Function):void 异步加载所有处于队列中的素材。'onProgress'方法会在加载过程中不断调用，并传递一个'ratio'值，范围是'0.0' 到 '1.0'，'1.0'就代表加载完成了。 | AssetManager
 | playSound(name:String, startTime:Number = 0, loops:int = 0, transform:SoundTransform = null):SoundChannel 创建一个新的SoundChannel对象来播放声音.这个方法返回一个SoundChannel对象，这样你就可以用来停止声音播放或调整音量。 | AssetManager
 | purge():void 删除所有的素材，并清空队列 | AssetManager
 | removeSound(name:String):void 删除一个声音 | AssetManager
 | removeTexture(name:String, dispose:Boolean = true):void 删除一个纹理，销毁它(可选) | AssetManager
 | removeTextureAtlas(name:String, dispose:Boolean = true):void 删除一个纹理图集，销毁它(可选) | AssetManager
Property Detail
scaleFactor property
scaleFactor:Number

无论是从位图创建的纹理，还是ATF格式的纹理，都会被分配一个缩放比例

Implementation
    public function get scaleFactor():Number
    public function set scaleFactor(value:Number):void
useMipMaps property
useMipMaps:Boolean

对于位图纹理，此标志表示，加载后创建的纹理是否使用MIP映射; 对于ATF格式的纹理，它表示使用的时候MIP映射是否有效。

Implementation
    public function get useMipMaps():Boolean
    public function set useMipMaps(value:Boolean):void
verbose property
verbose:Boolean

是否输出加载过程中的信息

Implementation
    public function get verbose():Boolean
    public function set verbose(value:Boolean):void
Constructor Detail
AssetManager () Constructor
public function AssetManager(scaleFactor:Number = -1, useMipmaps:Boolean = false)

创建一个新的AssetManager实例。'scaleFactor' 和 'useMipmaps'这两个参数定义了队列中的位图如何转换为纹理。

Parameters
scaleFactor:Number (default = -1) — 缩放比例，默认-1
useMipmaps:Boolean (default = false) — 是否使用mip映射，默认false
Method Detail
addSound () method
public function addSound(name:String, sound:Sound):void

根据指定的名称注册一个声音。注册后立刻可用。

Parameters

name:String — 名称
sound:Sound — 声音

addTexture () method
public function addTexture(name:String, texture:Texture):void

根据指定的名称注册一个纹理。注册后立刻可用。

Parameters

name:String — 名称
texture:Texture — 纹理

addTextureAtlas () method
public function addTextureAtlas(name:String, atlas:TextureAtlas):void

根据指定的名称注册一个纹理图集。注册后立刻可用。

Parameters

name:String — 名称
atlas:TextureAtlas — 图集

dispose () method
public function dispose():void

销毁所有的纹理

enqueue () method
public function enqueue(... rawAssets):void

将一个或一组素材加入到队列中；只有在成功调用了"loadQueue"方法后这些资源才可用。这个方法可以接受下面这些类型：

  • 使用字符串定义的URL，链接到一个本地或远程网络上的资源。支持类型: png, jpg, atf, mp3, fnt, xml (纹理图集).
  • File类的实例 (只有AIR应用适用) 指定的一个目录或一个文件.如果是目录，则会自动扫描该目录下所有支持的文件类型。
  • 包含静态成员结合Embed方式内嵌素材的类.
对象的名称会自动提取：比如一个文件名称是"image.png"，那么会自动将素材命名为"image"。如果是通过类的嵌入素材方式，那么变量名称就会使用嵌入时那个名称。 一个例外是纹理图集：他们将具备相同的名称（实际引用的那个纹理名称）。

Parameters

... rawAssets

getSound () method
public function getSound(name:String):Sound

根据指定的名称返回一个声音

Parameters

name:String — 名称

Returns
Sound — Sound
getSoundNames () method
public function getSoundNames(prefix:String):Vector.<String>

根据指定的字符串前缀返回符合条件的声音名称，按照字母排序。

Parameters

prefix:String — 前缀

Returns
Vector.<String> — 名称数组
getTexture () method
public function getTexture(name:String):Texture

根据指定的名称返回一个纹理。这个方法首先会查询所有直接添加进来的纹理； 如果找不到这个名称的纹理，则会继续从所有的纹理图集中继续查找。

Parameters

name:String — 名称

Returns
Texture — Texture
getTextureAtlas () method
public function getTextureAtlas(name:String):TextureAtlas

根据指定的名称，返回一个纹理图集，找不到的话就返回null

Parameters

name:String — 名称

Returns
TextureAtlas — 纹理图集
getTextureNames () method
public function getTextureNames(prefix:String, result:Vector.<String> = null):Vector.<String>

根据一个指定的字符串前缀，返回所有符合条件的纹理名称，按照字母排序。

Parameters

prefix:String — 前缀
result:Vector.<String> (default = null) — 存储结果的数组

Returns
Vector.<String> — 名称数组
getTextures () method
public function getTextures(prefix:String, result:Vector.<Texture> = null):Vector.<Texture>

根据指定的字符串前缀，返回所有符合条件的纹理，按照字母排序（对于"MovieClip"非常有用）。

Parameters

prefix:String — 前缀
result:Vector.<Texture> (default = null) — 返回数组

Returns
Vector.<Texture> — 纹理数组
loadQueue () method
public function loadQueue(onProgress:Function):void

异步加载所有处于队列中的素材。'onProgress'方法会在加载过程中不断调用，并传递一个'ratio'值，范围是'0.0' 到 '1.0'，'1.0'就代表加载完成了。

Parameters

onProgress:Function — function(ratio:Number):void;

playSound () method
public function playSound(name:String, startTime:Number = 0, loops:int = 0, transform:SoundTransform = null):SoundChannel

创建一个新的SoundChannel对象来播放声音.这个方法返回一个SoundChannel对象，这样你就可以用来停止声音播放或调整音量。

Parameters

name:String — 名称
startTime:Number (default = 0) — 起始时间
loops:int (default = 0) — 循环次数
transform:SoundTransform (default = null) — 声音变换控制

Returns
SoundChannel — SoundChannel
purge () method
public function purge():void

删除所有的素材，并清空队列

removeSound () method
public function removeSound(name:String):void

删除一个声音

Parameters

name:String — 名称

removeTexture () method
public function removeTexture(name:String, dispose:Boolean = true):void

删除一个纹理，销毁它(可选)

Parameters

name:String — 名称
dispose:Boolean (default = true) — 是否销毁

removeTextureAtlas () method
public function removeTextureAtlas(name:String, dispose:Boolean = true):void

删除一个纹理图集，销毁它(可选)

Parameters

name:String — 名称
dispose:Boolean (default = true) — 是否销毁


starling.utils.RectangleUtil

RectangleUtil | Methods
Package | starling.utils
Class | public class RectangleUtil
Inheritance | RectangleUtil Inheritance Object

一个增强Rectangle类功能的工具类.

Public Methods
Method Defined By
fit(rectangle:Rectangle, into:Rectangle, scaleMode:String = showAll, pixelPerfect:Boolean = false, resultRect:Rectangle = null):Rectangle
[static] 根据等比缩放的原则计算传入的'rectangle'(矩形)，并相对于'into'(矩形)来居中。 这个方法可用于根据指定的显示尺寸，计算最佳的viewPort区域。你可以使用不同的缩放模式，从而得到不同的计算结果。 此外，你可以通过只允许全数字相乘/相除(比如3，2，1，1/2，1/3)来避免像素排列错误。
RectangleUtil
intersect(rect1:Rectangle, rect2:Rectangle, resultRect:Rectangle = null):Rectangle
[static] 计算在两个矩形的交集。如果矩形不相交，则此方法返回一个空的Rectangle对象，其属性设置为0。
RectangleUtil
Method Detail
fit () method
public static function fit(rectangle:Rectangle, into:Rectangle, scaleMode:String = showAll, pixelPerfect:Boolean = false, resultRect:Rectangle = null):Rectangle

根据等比缩放的原则计算传入的'rectangle'(矩形)，并相对于'into'(矩形)来居中。

这个方法可用于根据指定的显示尺寸，计算最佳的viewPort区域。你可以使用不同的缩放模式，从而得到不同的计算结果。 此外，你可以通过只允许全数字相乘/相除(比如3，2，1，1/2，1/3)来避免像素排列错误。

Parameters

rectangle:Rectangle — 原显示尺寸
into:Rectangle — 屏幕可用区域
scaleMode:String (default = showAll) — 缩放模式
pixelPerfect:Boolean (default = false) — 避免像素排列错误
resultRect:Rectangle (default = null) — 如果设置了这个选项，则结果存储在这个对象中

Returns
Rectangle — Rectangle

See also

starling.utils.ScaleMode
intersect () method
public static function intersect(rect1:Rectangle, rect2:Rectangle, resultRect:Rectangle = null):Rectangle

计算在两个矩形的交集。如果矩形不相交，则此方法返回一个空的Rectangle对象，其属性设置为0。

Parameters

rect1:Rectangle — 矩形1
rect2:Rectangle — 矩形2
resultRect:Rectangle (default = null) — 返回的矩形

Returns
Rectangle — Rectangle


starling.utils.ScaleMode

ScaleMode | Methods | Constants
Package | starling.utils
Class | public class ScaleMode
Inheritance | ScaleMode Inheritance Object

用于'RectangleUtil.fit' 方法的缩放模式常量值.

Public Methods
Method |  | Defined By
 | isValid(scaleMode:String):Boolean [static] 判断缩放模式是否合法 | ScaleMode
Public Constants
Constant |  | Defined By
 | NO_BORDER : String = noBorder [static] 等比缩放，填充整体区域，不留空白区域，有可能会对显示内容进行裁剪 | ScaleMode
 | NONE : String = none [static] 不缩放矩形，但是在整个区域中居中 | ScaleMode
 | SHOW_ALL : String = showAll [static] 等比缩放，保持显示区域完整可见，可能会在上下或左右两侧留下空白区域 | ScaleMode
Method Detail
isValid () method
public static function isValid(scaleMode:String):Boolean

判断缩放模式是否合法

Parameters

scaleMode:String

Returns
Boolean
Constant Detail
NO_BORDER Constant
public static const NO_BORDER:String = noBorder

等比缩放，填充整体区域，不留空白区域，有可能会对显示内容进行裁剪

NONE Constant
public static const NONE:String = none

不缩放矩形，但是在整个区域中居中

SHOW_ALL Constant
public static const SHOW_ALL:String = showAll

等比缩放，保持显示区域完整可见，可能会在上下或左右两侧留下空白区域