注册表超级全攻略v1.0
注册表超级全攻略是藏陋网 开发的一本共享电子书籍！收录的是大量简单,通俗易懂而又确实实用的windows系列注册表修改技巧,不但对电脑初学者有很大的帮助,而且对老鸟也很有参考价值！内容含盖了win98,NT,2K,XP全套注册表修改实用技巧。
本软件为共享软件，所有内容都可以免费使用，但不可修改！
藏陋网对该书籍拥有完全版权和著作权，解释权归藏陋网所有。
如果你使用本书籍，说明你接受以上协议。
软件作者：藏陋网 xiaofei
联系：http://www.canglou.com
藏陋网，解决电脑故障！
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！
http://www.canglou.com/bbs/


注册表超级全攻略v1.0
注册表超级全攻略是藏陋网 开发的一本共享电子书籍！收录的是大量简单,通俗易懂而又确实实用的windows系列注册表修改技巧,不但对电脑初学者有很大的帮助,而且对老鸟也很有参考价值！内容含盖了win98,NT,2K,XP全套注册表修改实用技巧。
本软件为共享软件，所有内容都可以免费使用，但不可修改！
藏陋网对该书籍拥有完全版权和著作权，解释权归藏陋网所有。
如果你使用本书籍，说明你接受以上协议。
软件作者：藏陋网 xiaofei
联系：http://www.canglou.com
藏陋网，解决电脑故障！
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！


11111111122222222

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！http://www.canglou.com/bbs/

什么是注册表（英文名称为Registry）？中文 Windows为什么会引入这一特殊数据记录方式？注册表和.INI文件相比到底有何不同？我们该如何有针对性地对其进行修改？


111

藏陋网，解决电脑故障！ http://www.canglou.com/

IBM PC机及其操作系统（如Windows 3.x、中文Windows 98）的一个特点就是允许用户按照自己的要求对计算机系统的硬件和软件进行灵活配置。在Windows 3.x中，对软硬件工作环境灵活配置的特点主要表现在采用了后缀为.INI的文件（如System.ini，Win.ini等）来登录硬件和软件的各种初始化信息，以便系统建立符合要求的工作环境。因为每一个设备或者应用程序都可以建立自己的INI文件，所以造成INI文件众多，这为INI文件的管理增加了难度。特别是由于这些配置文件的存储都采用局域化方式，因此要在网络上实现远程访问几乎是不可能的。

为了克服上述问题，我们就必须建立一个统一管理各种信息资源的机构来集中存储各种配置信息，按照这一原则，在中文Windows 98中采用了注册表方式。所谓“注册表”实际上是一个庞大的数据库，其中容纳了应用程序和计算机系统的全部配置信息，中文Windows 98系统和应用程序的初始化信息，应用程序和文档文件的关联关系，硬件设备的说明、状态和属性以及各种状态信息和数据，如图1-1所示。

从一般用户的角度看，注册表系统由两个部分组成：注册表数据库和注册表编辑器。其中注册表数据库包括两个文件：SYSTEM.DAT和USER.DAT。

SYSTEM.DAT用来保存微机的系统信息，如安装的硬件和设备驱动程序的有关信息等。这个文件必须放在中文Windows 98目录下。

USER.DAT用来保存每个用户特有的信息，如桌面设置、墙纸或窗口的颜色设置等。这个文件可以放在中文Windows 98目录下，也可以放在网络磁盘上。

在中文Windows 98下，使用注册表编辑器(Regedit.exe)可以实现注册表的各种编辑工作。


112

注册表与Windows 98之间的关系，我们可以概括为如图1-2所示的样子。

下面详细解释图1-2中的各个选项之间的关系。

Windows 98的各个组件以下述方法使用注册表Registry。

1. 硬件数据(NTDETECT)

在启动Windows 98时，Registry接收易失硬件配置数据——计算机检测到的硬件信息。

2. Windows 98内核(98OSKRNL)

在Windows 98启动期间，Windows 98内核从Registry中选取信息，包括要装入什么设备驱动程序，以及用什么次序装入，内核传送回它自身的信息，如版权号等。

3. 设备驱动程序

设备驱动程序也向Registry传送数据，并从Registry接收装入和配置参数。性能良好的设备驱动程序告诉Registry它在使用什么系统资源，如硬件中断或DMA通道等。另外，设备驱动程序还报告所发现的配置数据。

4. 管理/配置工具

Windows 98还提供了大量其他接口，允许用户修改系统配置数据，如控制面板、设置程序等。

5. 设置程序

为应用程序或硬件运行Windows 98的设置程序或其他设置程序时，程序可以对Registry增加新的配置数据。

6. Win 16应用程序

中文Windows 98为了与一些应用程序和相关工具兼容，也支持INI文件。因为一些应用程序，特别是16位Windows应用程序在现阶段仍将继续使用INI文件。Autoexec.bat和Config.sys文件也将存在，以提供对MS-DOS和Windows 3.x应用程序的兼容。当安装一个基于Windows 3.x的应用程序时，应用程序的安装程序Setup像在Windows中一样创建它自己的INI文件或在Win.ini或System.ini文件创建入口。


113

为了保持Windows系统的向下兼容性，中文Windows 98中保留了INI文件。在形式上，注册表与INI文件有5个显著的特点：

(1) 注册表采用的是二进制形式登录数据，INI文件采用的则是简单的文本形式登录数据。

(2) 注册表支持子关键字，各级子关键字都有自己的“键值”；INI文件中则支持小节以及小节中的设置行参数。

(3) Registry可以包括子键，而INI文件不支持小节的嵌套。

(4) Registry中的键值项还可以包含可执行代码，而在INI文件中设置项只是简单的字串。

(5) 在同一台计算机上有多个用户，Registry可以存储每个用户的特性，而INI文件中却不可能。

在功能上，注册表与.INI文件相比，主要有以下3个特点：

(1) 注册表允许对硬件、某些操作系统参数、应用程序和设备驱动程序进行跟踪配置，这使得某些配置的改变（如“控制面板”中的选项等）可以在不重新启动系统的情况下立即生效。

(2) 注册表中登录的硬件部分数据可以用来支持Windows 98的即插即用特性。当Windows 98检测到机器上的各种设备时，就把有关数据保存到注册表中。通常是在安装时进行这种检测的，但Windows 98启动或原有配置改变时，也要进行检测。如安装一个新的硬件时，Windows 98将检查注册表，以便确定哪些资源已被占用，这样就可以避免新设备与原有设备之间的资源冲突。

(3) 通过注册表，管理人员和用户可以在网络上检查系统的配置和设置，使得远程管理得以实现。


114

注册表是为Windows NT和Windows95中所有32位硬件/驱动和32位应用程序设计的数据文件。16位驱动在Windows NT下无法工作，所以所有设备都通过注册表来控制，一般这些是通过BIOS来控制的。在Win9x下，16位驱动会继续以实模式方式设备工作，它们使用system.ini来控制。16位应用程序会工作在NT或者Win9x 下，它们的程序仍然会参考win.ini和system.ini文件获得信息和控制。
    在没有注册表的情况下，操作系统不会获得必须的信息来运行和控制附属的设备和应用程序及正确响应用户的输入。

    在系统中注册表是一个记录32位驱动的设置和位置的数据库。当操作系统需要存取硬件设备，它使用驱动程序，甚至设备是一个BIOS支持的设备。无BIOS支持的设备安装时必须需要驱动，这个驱动是独立于操作系统的，但是操作系统需要知道从哪里找到它们，文件名、版本号、其他设置和信息，没有注册表对设备的记录，它们就不能被使用。

    当一个用户准备运行一个应用程序，注册表提供应用程序信息给操作系统，这样应用程序可以被找到，正确数据文件的位置被规定，其他设置也都可以被使用。

    注册表保存关于缺省数据和辅助文件的位置信息、菜单、按钮条、窗口状态和其他可选项。它同样也保存了安装信息（比如说日期），安装软件的用户，软件版本号和日期，序列号等。根据安装软件的不同，它包括的信息也不同。

    然而，一般来说，注册表控制所有32位应用程序和驱动，控制的方法是基于用户和计算机的，而不依赖于应用程序或驱动，每个注册表的参数项控制了一个用户的功能或者计算机功能。用户功能可能包括了桌面外观和用户目录。所以，计算机功能和安装的硬件和软件有关，对所以用户来说项都是公用的。

    有些程序功能对用户有影响，有些时作用于计算机而不是为个人设置的，同样的，驱动可能是用户指定的，但在很多时候，它们在计算机中是通用的。


115

如今使用的Pc操作系统经历了从DOS到 windows的发展过程。在DOS年代，系统中的硬件设备必须通过Confis.sys和Autoexec.bat两个配置文件在系统初始化过程中加载驱动程序来运行。而软件的配置信息，通常是由软件的编写者根据他自己所喜好的方式加以保存。随后出现的windows 3.x系统，使得这种情况发生了改变。
在windows 3.x中，系统通过Win.ini、System.ini、Control.ini、program.ini等INI文件来保存所有有关操作系统和应用程序的配置信息。其中前两者的作用尤为重要，System.ini负责配置硬件，而win.ini负责桌面设置和应用程序的运行等工作。 随着windows的普及，一些开发者过去没有注意到的问题也逐渐浮现出来。由于各个应用程序不断地往INI文件中添加自己的配置信息，而从不负责删除各INI文件中那些过时、无用的信息，所以随着系统内应用程序数量不断增加，INI文件就变得越来越大，在INI文件中查找相应信息的速度也越来越慢，再加上INI文件最大不能超过64KB，很快这种公用System.ini、Win.ini的管理方式就受到极大的挑战与质疑。
于是，人们在原有基础上提出了改进的方法。各个应用程序开始使用自己的INI文件来解决容量问题，比如Word 6．0就使用Word6.ini存放其配置信息。这样一来，INI文件大小的限制被很好解决了。但这样做又带来了新的麻烦，系统中出现了太多的INI文件，要想集中管理，而且搞清楚它们之间的关系变成了非常困难的事情。INI文件的另外—个致命缺陷仍然没有好的解决办法。由于INI文件是—个文本文件，所以任何用户都可以使用任意的文本编辑器来编辑它。如果用户在编辑INI文件时不小心修改了它的内容和格式，或者被不负责任的程序胡乱修改了其他应用程序所需要的数据，就有可能导致非常严重的后果。系统会出现许多莫名其妙的错误，死机、无法启动。因为这是系统结构性的弊端，所以在windows 95问世以前，大家都没有很好的解决方法。
在windows 3.x的升级版Windows 95出现时，微软决定把Windows NT中得到成功应用的注册表概念引入进来。其实质就是利用一个功能强大的注册表数据库来统—集中地管理系统硬件设施、软件配置等信息，从而方便管理并增强系统的稳定性


116

注册表（Registry）是一个什么样的表格呀？嘿嘿！傻了吧。注册表它不是一个什么表格，而是Windows的一个内部数据库，是一个巨大的树状分层的数据库，它是微软专门为其32位操作系统（如Windows NT、Windows 98等）设计的一个系统管理数据库。

注册表记录了用户安装在机器上的软件和每个程序的相互关联关系；记录了计算机的硬件配置，包括自动配置的即插即用的设备和已有的各种设备。

注册表中存放着各种参数，直接控制着 Windows 的启动、硬件驱动程序的装载以及一些 Windows 应用程序的运行，从而在整个系统中起着核心作用。它包括:

(1)软、硬件的有关配置和状态信息，注册表中保存有应用程序和资源管理器外壳的初始条件、首选项和卸载数据。

(2)联网计算机的整个系统的设置和各种许可,文件扩展名与应用程序的关联，硬件部件的描述、状态和属性。

(3)性能记录和其它底层的系统状态信息，以及其它数据。

如果注册表受到了破坏，轻者使 Windows 的启动过程出现异常，重者可能会导致整个系统的完全瘫痪。因此正确地认识、使用，特别是及时备份以及有问题时恢复注册表，对Windows用户来说就显得非常重要。

总的来说，注册表实际上就是一个以层次结构保存和检索的复杂的数据库，它包含了应用程序和系统软硬件的全部配置、初始化信息以及其他重要数据。从一般用户的角度看，注册表系统由注册表数据库和注册表编辑器两部分组成。

注册表编辑器（Regedit.exe）是一个专门用来编辑注册表的程序，没有它我们根本无法进行注册表的基本的浏览、编辑和修改。


117

藏陋网，解决电脑故障！ http://www.canglou.com/

注册表是windows操作系统中的一个核心数据库，其中存放着各种参数，直接控制着windows的启动、硬件驱动程序的装载以及一些windows应用程序的运行，从而在整个系统中起着核心作用。 这些作用包括了软、硬件的相关配置和状态信息，比如注册表中保存有应用程序和资源管理器外壳的初始条件、首选项和卸载数据等，联网计算机的整个系统的设置和各种许可，文件扩展名与应用程序的关联，硬件部件的描述、状态和属性，性能记录和其他底层的系统状态信息，以及其他数据等。

具体来说，在启动Windows时，Registry会对照已有硬件配置数据，检测新的硬件信息；系统内核从Resistry中选取信息，包括要装入什么设备驱动程序，以及依什么次序装入，内核传送回它自身的信息，例如版权号等；同时设备驱动程序也向Registry传送数据，并从Registry接收装入和配置参数，一个好的设备驱动程序会告诉Resistry它在使用什么系统资源，例如硬件中断或DMA通道等，另外，设备驱动程序还要报告所发现的配置数据；为应用程序或硬件的运行提供增加新的配置数据的服务。配合INI文件兼容16位Windows应用程序，当安装—个基于Windows 3.x的应用程序时，应用程序的安装程序Setup像在windows中—样创建它自己的INI文件或在Win.ini和System.ini文件中创建入口；同时windows还提供了大量其他接口，允许用户修改系统配置数据，例如控制面板、设置程序等。
如果注册表受到了破坏，轻则使windOWS的启动过程出现异常，重则可能会导致整个windows系统的完全瘫痪。因此正确地认识、使用，特别是及时备份以及有问题恢复注册表对windows用户来说就显得非常重要。


118

INI文件是早期Windows 3.X系统下对系统软件和硬件进行配置的文件,主要包括了System.ini和Win.ini，在其中保存了登录硬件和软件的各种初始化信息，以便系统建立符合要求的工作环境。因为每一个设备或者应用程序都可以建立自己的INI文件，所以造成INI文件众多，为INI文件的管理增加了难度，特别是其配置都是采用局域化的方式，因此要在网络上实现远程访问几乎是不可能的。

为了克服上述问题，从Windows95起引进了注册表。为了保持Windows系统的向下兼容性，Windows9x中仍然保留了INI文件。在形式上，注册表与INI文件的区别主要有以下几点：
1、注册表采用的是二进制数据，INI文件是简单的文本形式；显然INI文件能够被众多文本编辑器所修改，所以 用起来很方便，但稳固性却由此丧失掉了，再加上文本组成的数据本身在组成更高级的数据结构方面有缺陷，许多在数据库中很容易实现的功能，在这里就变得相当麻烦了，反观二进制的方式由于必须经由专门的注册表编辑软件才能 够查询或修改信息，相对就更加安全可靠。
2、注册表支持子关键字，各级子关键字都有自己的“键值”，INI文件支持小节以及小节中的设置行参数；
3、注册表支持键下的子键，而INI文件不允许小节中再有小节；注册表中每个键都可以包括子键，从而形成目录树的结构以方便使用， 而INI文件却无法支持小节之间的嵌套，也就是说小节与小节之间都只能是平 行的关系，非常不利于信息的表达。
4、注册表的键值项可以包含可执行代码，而在INI文件中设置项只是简单的字符串；
5、注册表可以包含多拥护设置，而INI文件却不能。在Windows 3.x时 代，我们几乎没有办法在同一台计算机上实现有个性的多用户使用，而到了 windows 9x以后，这样的多用户情形就变得非常普遍了

从功能上来说，注册表相对于INI文件具有以下优点：
1、注册表允许对软硬件和配置参数进行跟踪配置，以更好的适应软硬件；
2、注册表中登录的硬件数据可以用来支持即插即用特性；通常是在安装时进行这种检测的，但windows 98启动或原有配置改变时， 也要进行这种检测。如安装—一个新硬件时，Windows 98将检查注册表，以便确 定哪些资源已被占用，这样就可以避免新设备与原有设备之间的资源冲突。
3、注册表中的配置数据由于可以灵活的改变，因此可以更好的适应网络发展。管理人员和用户可以在网络上检查系统的配置和设置， 使得远程管理能够得以实现


119

Windows操作系统是由许多文件组成的，注册表也不例外，对于Windows 9x系统，注册表底层是由System.dat和User.dat两个文件组成的。它们是二进制文件，不能用文本编辑器查看。它们一般存放于Windows目录下，具有隐含、系统、只读属性。
System.dat包含了计算机特定的配置数据，User.dat包含了用户特定的数据。User.dat文件的位置在以某个用户名登录时，其位于C:\Windows\profiles\用户名目录下，系统同时在C:\Windows目录下保留了一个缺省的User.dat文件，以备新用户使用。
 另外一个文件Config.pol影响着注册表中用户看到的设置，但其并不真正是注册表的一部分。
 Windows NT/2000/XP中的注册表文件在多数情况下存放于%SystemRoots%\System32\Config文件夹中(%SystemRoot%指系统根目录)。其中包括Default、Sam、security、Software、System和以log、sav为扩展名的同名文件。而每个计算机用户的用户配置文件信息(包括Ntuser.dat和Ntuser.dat.log)的位置在Windows NT中是%SystemRoot%\profiles\Username，比如用户public的Ntuser.dat文件就存放于C:\winnt\profiles\public。Windows 2000则取决于是全新安装还是从windows 95/98或windows NT升级安装。
 在全新安装以及从Windows 95/98升级安装的情况下，Ntuser.dar和Ntuset.dar.log文件存储在%SystemDriye%\Documents and Settings\username文件夹中。
 在从 Windows NT升级的安装中，Ntuser.dat和Ntuser.dat.log文件存储在%SystemRoot%\Profiles\username文件夹中。
 注：System.dao和User.dao这两个文件属于Windows95，是注册表的备份文件，它们在每次系统成功启动后创建。在Windows98中，注册表检查器将备份文件作成CAB文件

①、注册表：是一个树状分层的数据库。从物理上讲，它是System.dat和User.dat两个文件；从逻辑上讲，它是用户在注册表编辑器中看到的配置数据。
②、HKEY ：“根键”。Windows98将注册表分为六个部分，并称之为 HKEY_name，它意味着某一键的句柄。
③、key(键)：它包含了附加的文件夹和一个或多个值。
④、subkey（子键）：在某一个键（父键）下面出现的键（了键）。
⑤、branch（分支）：代表一个特定的子键及其所包含的一切。一个分支可以从每个注册表的顶端开始，但通常用以说明一个键和其所有内容。
⑥、value entry（值项）：带有一个名称和一个值的有序值。每个键都可包含任何数量的值项。每个值项均由三部分组成：名称，数据类型，数据。
★ 名称：不包括反斜杠的字符、数字、代表符、空格的任意组合。同一键中不可有相同的名称。
★ 数据类型：包括字符串、二进制、双字三种。
字符串：如“Hello World”，是一串文字或词组。注册表总是在引号内显示字符串。
二进制：如 F03D990000BC ，是没有限制的二进制数值，用16进制显示。
双 字：如 D1234567 ，以8位16进制数表示的数。
★ 数据： 值项的具体值，它可以占用到64KB。
⑦、 Default（缺省值）：每一个键至少包括一个值项，称为缺省值（Default），它总是一个字串


1110

Win9X篇
C:\Windows\SYSTEM.DAT和C:\Windows\USER.DAT 这2个就是注册表文件
另外，系统每天启动的第一次都会做一个备份，储存在C:\WINDOWS\SYSBCKUP下，以rb***.cab命名，在DOS下可以用scanreg /restore还原。

第一次安装完以后，在C盘根目录下还有一个SYSTEM.1ST文件作为第一次启动的备份。

Win2000/XP/NET篇
其中用户配置文件保存在根目录“Documents and Settings”下用户名的目录中，包括两个隐藏文件：NTUSER.DAT、NTUSER.INI 及 ntuser.dat.LOG 日志文件。系统配置文件位于 Windows 2000 系统目录下的“SYSTEM32\CONFIG”中，包括 DEFAULT、SOFTWARE、SYSTEM、AppEvent.Evt、SecEvent.Evt、SysEvent.Evt 等多个隐藏文件及其相应的 .LOG（日志）文件和 .SAV 文件。这些注册表文件在 Windows 2000 运行时无法使用其它工具打开，这一点与 Windows 9x 下的 system.dat 及 user.dat 不同。

备份文件位于WINDOWS\Repair下面。


1111

藏陋网，解决电脑故障！ http://www.canglou.com/


1112

藏陋网，解决电脑故障！ http://www.canglou.com/


1113

藏陋网，解决电脑故障！ http://www.canglou.com/


1114

藏陋网，解决电脑故障！ http://www.canglou.com/


12

藏陋网，解决电脑故障！ http://www.canglou.com/

知道注册表的结构是如何的嘛？


121

藏陋网，解决电脑故障！ http://www.canglou.com/

在中文Windows 系统中，注册表采用“关键字”及其“键值”来描述登录项及其数据。所有的关键字都是以“HKEY”作为前缀开头。实际上，“关键字”是一个句柄。这种约定使得系统及应用程序开发人员可以在使用注册表API函数时把它用于应用程序的开发之中。为此，中文Windows 提供了若干个Win32 API函数，以便在开发中文Windows 应用程序时添加、修改、查询和删除注册表的登录项。

在注册表中，关键字可以分为两类：一类是由系统定义的，通常称为“预定义关键字”；另一类是由应用程序定义的，安装的应用软件不同，其登录项也就不同。


122

1. HKEY_CLASSES_ROOT

该主关键字（或称为“根键”）包含了有关的OLE信息，以便在系统工作过程中实现对各种文件和文档信息的访问，如图1-4所示。其具体的内容有已经注册的文件扩展名、文件类型、文件图标等。

2. HKEY_USERS

PC用户都可以在这里设置自己的关键字和子关键字，根据当前登录的用户不同，这个关键字又可以指向不同的分支部分。这个分支部分将映射到HKEY_CURRENT_USER主关键字中，用户根据个人爱好设置的诸如桌面、背景、开始菜单程序项、应用程序快捷键、显示字体、屏幕节电设置等信息均可以在这个关键字中找到。该主关键字中的大部分设置都可以通过“控制面板”来修改，如果用户登录到系统中的信息没有预定义的登录项，则采用该关键字下面的“.Default”子关键字。

3. HKEY_CURRENT_USER

HKEY_CURRENT_USER主关键字是一个指向HKEY_USERS结构中某个分支的指针，它包含当前用户的登录信息，实际上它就是HKEY_USERS＼.Default下面的一部分内容。如果在HKEY_USERS＼.Default下面没有用户登录的其他内容，那么这两个主关键字包含的内容是完全相同的。

4. HKEY_LOCAL_MACHINE

该主关键字包含了本地计算机（相对网络环境而言）的硬件和软件的全部信息，如图1-9所示。当系统的配置和设置发生变化时，本关键字下面的登录项也将随之改变。

5. HKEY_CURRENT_CONFIG

这个主关键字实际上也是指向HKEY_LOCAL _MACHINE＼Config结构中的某个分支的指针，如图1-10所示。

HKEY_CURRENT_CONFIG下面的子关键字及内容与HKEY_LOCAL _MACHINE＼Config＼0001分支下面的子关键字及内容是完全相同的。

该主关键字包含的主要内容是计算机的当前配置情况，如显示器、打印机等可选外部设备及其设置信息等，而且这个配置信息均将根据当前连接的网络类型、硬件配置以及应用软件的安装不同而有所变化。

6. HKEY_DYN_DATA

顾名思义，该主关键字包含了系统运行中的动态数据，即已发生的事件的有关信息，如图1-11所示。因此，这个主关键字的内容不仅包含系统硬件的当前状态，也包含了那些需要更新和检索的数据。这些数据都是动态变化的，它们总是最新的信息。中文Windows 98每次启动时都将重新建立这个主关键字。

为了提高工作速度，HKEY_DYN_DATA实际上是存放在内存（RAM）中的，因此，如果发生了对于注册表内容的修改，则不必立即写入磁盘，这对于提高系统的速度是十分必要的。


123

在注册表中经常出现双重入口（分支），例如，有一些在HKEY_CLASSES_ROOT中的键同样会在HKEY_LOCAL_MACHINE中出现，
如果这些相同的分支出现在两个不同的根键中，那么哪个根键有效呢?注册表的子键都有严格的组织。如果相同的信息出现在超过一个的子键中，假如你只修改了一个子键，那么该修改是否作用于系统依赖于该子键的等级呢？一般来说，系统信息优先于用户等级。例如，一个设置项同时出现在HKEY_LOCAL_MACHINE和HKEY_USER子键中，通常由HKEY_LOCAL_MACHINE中的数据起作用。要注意的是，这种情况只发生在你直接编辑注册表时。如果你从“控制面板”中更改系统配置，则所有出现该设置项的地方均会发生相应的改变。

例如，你可以通过注册表设置文件关联，即将一个带有特殊后缀的文件连接到一个应用程序上。在注册表中，有4个子键都保存了文件管理的数据，它们分别是HKEY_CLASSES_ROOT，HKEY_CURRENT_USER，HKEY_LOCAL_MACHINE和HKEY_USER。在缺省情况下，所有后缀为1ST的文件都被连接到记事本程序（Notepad）上。如果你在Windows资源管理器双击该后缀的文件，系统将激活记事本，同时将此文件调入编辑。但是你也可将此文件关联从Notepad改为Lotus Ami Pro（这也是一个字处理程序），则你在双击后缀为1ST的文件时将激活Lotus Ami Pro程序，同时编辑此文件。但是，如果你在直接编辑注册表时只修改一个子键，则会出现如下4种情况：

(1) 如果只修改HKEY_CLASSES_ROOT中的1ST项，则在双击1ST后缀的文件时将激活Lotus Ami Pro。

(2) 如果只修改HKEY_CURRENT_USER中的1ST项，则在双击1ST后缀的文件时将激活Notepad。

(3) 如果只修改HKEY_LOCAL_MACHINE中的1ST项，则在双击1ST后缀的文件时将激活Lotus Ami Pro。

(4) 如果只修改HKEY_USER中的1ST项，则在双击1ST后缀的文件时将激活Notepad。

在上面的例子中，HKEY_CLASSES_ROOT子键和HKEY_LOCAL_MACHINE子键看起来在控制文件关联上相互独立，这似乎有些自相矛盾，但是，要知道HKEY_ CLASSES_ROOT根键就是HKEY_LOCAL_MACHINE\Software\Classes，因此，改变HKEY_CLASSES_ROOT根键就是改变HKEY_LOCAL_MACHINE。


124

藏陋网，解决电脑故障！ http://www.canglou.com/

注册表通过主键（最上层的为“根键”）和子键来管理各种信息。但是，注册表中的所有信息是以各种形式的“键值项数据”保存下来，如图

在注册表的左窗格中，所有的数据都是通过一种树状结构以键和子键的方式组织起来的，十分类似于目录结构。每个键都包含了一组特定的信息，每个键的键名都是和它所包含的信息相关的。如果这个键包含子键，则在注册表编辑器窗口中代表这个键的文件夹的左边将有“+”符号，以表示在这个文件夹中有更多的内容。如果这个文件夹被用户打开了，那么这个“+”就会变成“-”.


125

藏陋网，解决电脑故障！ http://www.canglou.com/

在注册表编辑器右窗格中保存的都是“键值项数据”。在注册表中，“键值项数据”包含“键值名”（即“名称”栏下面的部分）与“键值”（即“数据”栏下面的部分），如图


126

在注册表中，“键值项数据”可分为如下三种类型（在右窗格内右击鼠标，则在弹出的快捷菜单中将可以看到这三种类型，如图

(1) 字符串值

在注册表中，字符串值一般用来表示文件的描述、硬件的标识等。通常它由字母和数字组成，最大长度不能超过255个字符。在图1-20中，“D:\pwin98\trident”即为键值名“a”的键值，它是一种字符串值类型的。同样地，“ba”也为键值名“MRUList”的键值。通过键值名、键值就可以组成一种键值项数据，这就相当于Win.ini，System.ini文件中小节下的设置行。其实，使用注册表编辑器将这些键值项数据导出后，其形式与.INI文件中的设置行完全相同了。

(2) 二进制值

在注册表中，二进制值是没有长度限制的，可以是任意个字节长。在注册表编辑器中，二进制以十六进制的方式显示出来.

在图中，键值名“wizard”的键值“80 00 00 00”就是一个二进制值数据。双击键值,在“编辑二进制值”对话框中，在编辑框的左边输入十六进制数时，其右边将会显示相应的ASCII码。

(3) DWORD值

DWORD值是一个32位（4个字节，即双字）长度的数值。在注册表编辑器中，你将发现系统会以十六进制的方式显示DWORD值,在编辑DWORD数值时，可以选择用十进制还是16进制的方式进行输入.


127

注册表以类似磁盘上的目录和文件那样的层次结构进行组织，如图2-3所示。

表2-1详细地解释了图2-3中的各个层次项的含义。

表2-1 上图中的各个层次项的含义

层 次 | 说 明
子树 | 子树（又称为“子树关键字”，而在Windows 95/98下称为“根键”）类似于磁盘上的根目录。 注册表有如下4个预定义的子树： l HKEY_LOCAL_MACHINE l HKEY_USERS l HKEY_CURRENT_USER l HKEY_CLASSES_ROOT
配置元 | 一个配置元是关键字、子关键字和键值项的分离体。每个配置元具有一个相应的文件和.LOG文件。.LOG文件用于保证自动发生关键字值的改变。这些文件放在目录\winnt\SYSTEM32\CONFIG中
关键字和子关键字 | 关键字和子关键字类似于Windows 3.x中“文件管理器”（File Manager）或Windows 95/98中“Windows资源管理器”中看到的目录结构，每个配置元都可以包括关键字和子关键字，这就像目录可以包含子目录一样
键值项 | 键值项类似层次末端的文件，关键字和子关键字可以包括一个或者多个键值项。键值项主要由键值名、数据类型和值三部分组成，其格式为：键值名：数据类型：值

续表

层 次 | 说 明
值数据类型 | Windows2000中的值数据类型包含如下5种： l REG_DWORD：只允许一个值，并且为1～8个16进制数据串 l REG_SZ：只允许一个值，并且作为存储的串来解释 l REG_EXPAND_SZ：类似REG_SZ，只是文本可包含替换的变量 l REG_BINARY：只允许一个值，是16进制数字串，每对作为一个字节值来解释 l REG_MULTI_SZ：允许多个值，每个值作为MULTI_SZ的一个成分

Windows 2000注册表

子树

配置元

关键字

子关键字

键值项

键值项

图2-3

注册表与Windows 3.x中的.INI文件有许多相似之处。关键字类似于.INI文件的小节，一个键值项对应于一个.INI文件中小节里一条设置项。然而，注册表可以包含子关键字，而.INI文件不支持小节的嵌套。注册表中的键值项还可以包含可执行代码，而在.INI文件中设置项只是简单的串。

另外，在同一台计算机上有多个用户，注册表可以存储每个用户的特性，而.INI文件中却不可能。


128

.1 HKEY_LOCAL_MACHINE

该子树存放包括有关本地机器的所有配置信息及硬件、操作系统的数据等，如系统内存、驱动程序、安全数据库、系统配置等信息,这个子树不管哪个用户登录以及使用什么软件而保留机器的信息。在这个子树中的信息由应用程序、设备驱动程序和Windows 2000操作系统使用，以确定本地机器的配置数据。其中部分信息用于引导Windows 2000操作系统。

HKEY_LOCAL_MACHINE关键字有5个子关键字，它们分别是：

(1) HARDWARE：该子关键字是注册表的一个动态分支，每当计算机引导时，就要对它重新计算。其包含的信息又可进一步地分为3个分支：DESCRIPTION，DEVICEMAP，RESOURCEMAP。这些分支包含了Windows 2000将用户计算机引导到登录屏幕所需要的信息，它们描述了用户计算机中的所有硬件、有关每个设备的辅助信息以及每个设备需要的资源等。
(2) Security Acccount Manager（SAM）：该分支包含了用户与用户组账户的数据，这些数据统称为SAM数据库，如图2-6所示。此处所包含的数据与HKEY_LOCAL_ MACHINE\Security\SAM中的相同。
(3) SECCURITY：该分支包含与完全性相关的信息，如用户的访问权、口令原则和本机用户组的成员等
(4) SOFTWARE：该分支包含了计算机中安装的软件信息，这些信息属于一般性的配置信息。它又可进一步地分为Classes，Program Groups，Secure，Description等分支。Classes包含数据与HKEY_CLASSES_ROOT中的相同。Program Group包含了计算机中安装的软件名称和版本号等信息。

(5) SYSTEM：该分支包含了计算机启动时需要的各种计算机信息，如图2-9所示。

其中后4个子关键字都可以看作是配置元。因为它们在\winnt\SYSTEM32\CONFIG目录中都有相应的文件。应用程序可以查询所有这5个关键字，但只可以对Software和System关键字增加配置信息。

2 HKEY_USERS

该子树容纳了当前登录用户的配置设置和缺省的用户配置文件。因此HKEY_USERS关键字包括DEFAULT子关键字和一个或者多个以用户的SIDs（这是Windows 2000用以识别用户的安全身份号码）为名称的子关键字。

DEFAULT关键字分配信息给本地机器上的新用户，它对应的文件为\winnt \SYSTEM32\CONFIG目录下的USERDEF文件。注册表中的每个用户信息分别保存在\winnt\SYSTEM32

\CONFIG目录下的USERxxx和USERxxx.LOG文件中。当一个用户登录时，用户的配置信息将被拷贝到HKEY_CURRENT_USER子树中，直到用户退出登录为止。在这期间，用户改变的任何设置都将记录在HKEY_CURRENT_USER和HKEY_USERS子树的相应的键值项数据中。

在缺省情况下，用户的配置文件保存在\winnt\SYSTEM32\CONFIG目录中，但对于Windows 2000 Advanced Server（高级服务器版本）的域管理，它们可以放在本地机器上或者存储在远程主机上。

3 HKEY_CURRENT_USER

该子树记录了当前登录到机器上用户的有关信息。

这些信息以前是存储在Win.ini初始化文件中的。这个子树有一份拷贝作为单个文件或者配置元存储在机器上。当一个用户登录时，用户的安全身份号码（SID）与注册表中的已知的SIDs进行比较。如果系统识别了用户登录的SID，则系统就装载这个用户的配置数据，否则系统将使用在HKEY_USERS\.DEFAULT配置元中的配置信息。

HKEY_CURRENT_USER关键字由以下子关键字组成：

(1) AppEvents; (2) Console; (3) Control Panel ;(4) Environment ; (5) EUDC ; (6) Keyboard Layout ;(7) Software ; (8) UNICODE Program Groups ; (9) Volatile Environment ;.

4 HKEY_CLASSES_ROOT

此子键提供了入口来定义资源类型以及与这些类相关的特殊信息，主要包括软件配置信息，特别是对象链接与嵌入（OLE）和Windows 2000外壳应用程序使用的信息等
在此子树中，每个扩展名与能使用这种类型文件的应用程序相关联，如HKEY_CLASSES_ROOT关键字中包括.avi、.bmp和.DOC等许多子关键字。这个子树的目的是提供与Windows 3.x注册数据库Reg.dat的兼容性


13

藏陋网，解决电脑故障！ http://www.canglou.com/

windows就自带了注册表编辑器，下面我们就来介绍他的用法！


NewTopic

藏陋网，解决电脑故障！ http://www.canglou.com/

在使用注册表编辑器之前，首先必须启动注册表编辑器。 单击“开始”按钮，然后单击“运行”，在“打开”框内输入regedit 或者 regedit.exe或者C:\windows\regedit.exe !即可打开注册表!
也可以进入系统盘系统目录双击regedit 程序即可打开!


132

一旦注册表出现问题或者为达到某种目的（如屏蔽某些自启动程序等），则需要修改或者修复注册表。首先你必须对注册表结构有个整体的了解，然后根据提示信息或者错误现象分析可能是注册表中哪些地方出现了问题。

例如，在启动Windows 98时，可能会出现如下提示信息：(想必这样屏幕很多人都见过吧?是不是措手不及?)

    Cannot find a device file that may be needed to run Windows or a windows application.

    The Windows Registry or System.ini file refers to this device file，

 But the device file no longer exists

If you deleted this file on purpose，try uninsalling the associated application using its uninstall

Or Setup program.

If  you still want to use the application associared with this device file，

Try  reinstalling the application to replace the missing file.

Ndskwan.vxd

    Press a key to continue.

或者在启动后出现如图所示的提示信息框，则说明你已经误删除了应用程序或者驱动程序，但是这些程序在注册表中的键值数据仍存在，因而Windows 98会给出提示信息。

为了从注册表中删除这些程序对应的子键或者键值数据，可使用下面两种方法：

(1) 使用“注册表编辑器”的“编辑”菜单中的“查找”命令。操作步骤如下：

1 启动注册表编辑器。

2 在“编辑”菜单中选择“查找”命令，则弹出“查找”对话框。

3 在“查看”框中选择“主键”、“键值”或者“数据”。

4 如果要精确地查找，请单击“只匹配整个字符串”复选框。

5 在“查找目标”框中输入提示信息中所提到的程序，如上面的ndiskwan.vxd或者CPUIDLE.DLL。

6 单击“查找下一个”按钮，或者按回车键，系统将开始在注册表中查找.

在查找过程中，你可以单击“取消”按钮，以便取消当前的查找进程。

系统在查找时，若查找到指定的匹配字符串，则系统将快速地定位到这些程序对应的子键或者键值数据，右击这些子键或者键值数据，再从弹出的快捷菜单中单击“删除”即可。

7 单击“查找下一个”按钮，或者按F3键，将进入下一个匹配字符串的查找进程。

8 在完成了所有的匹配字符串的查找进程后，将弹出完成查找的对话框。

单击“确定”按钮，则完成了整个查找过程。
(2) 根据提示信息中的文件名确定此文件在注册表中的位置。例如，ndiskwan.vxd是一个网络协议文件，它应该在HKEY_LOCAL_MACHINE\System\Current ControlSet\ Services\VXD分支上.

你可以打开此分支，然后找到此文件所在的注册项。

又如，上面的CPUIDLE.DLL文件通常是一个软件的动态链接库文件，它通常位于HKEY_LOCAL_MACHINE\Software分支下。你可以顺着此分支查找下去，就能找到此文件对应的注册项，然后删除之即可。


133

在注册表编辑器中，“文件”菜单下的“引入注册表文件”菜单项的主要功能就是将现在的注册表文本文件转换为系统注册表数据库。

下面介绍此菜单项的具体操作过程。

(1) 在执行该菜单项后，将出打开对话框。

(2) 在“文件名”文本框中输入注册表文件，例如，我们输入reg（后缀默认为.reg），按回车键或单击“打开”按钮，则出现如图1-60所示的“引入注册表文件”进程窗口。该窗口显示了注册表文件Reg.reg转换为系统注册表数据库的过程.
在转换结束后，将出现导入成功的提示窗口，然后单击“确定”按钮，引入注册表文件结束

下面介绍注册表文件Reg.reg的基本格式。Reg.reg基本格式如下所示：

     REGEDIT4

     [HKEY_CURRENT_USER\CGJ\CCED]

     @=”CCED 6.0”

     [HKEY_LOCAL_MACHINE\WJ\WINCCED]

     “ WINCCED”=”CCED for Windows98 6.0”

其中第一行一定是“REGEDIT4”，必须全部大写。

第二行为空行。

第三行使用[ ]括起子键分支，如HKEY_CURRENT_USER\CGJ\CCED就是一个子键分支。

第四行为该子键分支下的设置数据。这里“@”表示的是“注册表编辑器”右窗格中的“ ”，这说明子键使用默认值。“@=”右边的“CCED 6.0”为子键的默认值。若为字符串值，需使用一对双引号括起。

第五行为HKEY_LOCAL_MACHINE\WJ\WINCCED子键分支。

第六行为该子键分支的设置数据。

以上Reg.reg必须使用文本编辑器编辑。例如，我们常用“附件”组中的“记事本”编辑，在“文件”菜单上单击“保存”则将以上注册表设置保存到Reg.reg文件中。在使用“注册表编辑器”的“注册表”菜单中的“引入注册表文件”命令后，将Reg.reg引入到注册表中


134

我们可以利用此菜单项，将系统注册表数据库全部或某一个分支转换为文本注册表文件，其操作步骤如下：

1 在“注册表”菜单上单击“导出注册表文件”，则出现保存对话框

2 在“文件名”文本框中输入导出注册表后的文本文件名称，在“存为类型”列表框中选择“注册表文件”。

3 在“导出范围”框中选择导出注册表的范围全身“全部”或者“选定的分支”。默认为导出分支。

若你想研究Windows 98的注册表数据库的结构，则可选择“全部”。若你只是看一下某一个分支的子关键字之间的连接关系，则可选择“选定的分支”。

下面简要地介绍一下当注册表导出文本注册表文件时的文本文件的格式。

导出的文本注册表文件大体有如下格式：

REGEDIT4

[HKEY_CURRENT_USER]

[HKEY_CURRENT_USER\Control Panel]

[HKEY_CURRENT_USER\Control Panel\Appearance]

"Current"="Windows 标准"

"CustomColors"=hex:ff，ff，ff，00，ff，ff，ff

 @=”控制面板的外观”

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\双拼]

"词语联想"=dword:00000001

从上面的格式中我们首先发现文本注册表文件采用层次结构，每个层次下都有若干个键值数据。表1-3解释了层次结构与键值数据涉及到的格式。

表1-3 层次结构与键值数据涉及到格式

格 式 | 说 明 | 举 例
[键名] | 主键或者子键 | [HKEY_CURRENT_USER] [HKEY_CURRENT_USER\Control Panel]
“ 键值名”= | 键值的名称（此名称位于“注册表编辑器”右窗格的“名称”栏下） | "Current"=、"CustomColors"、"词语联想"
@= | 指定主键或者子键的默认值， 它在“注册表编辑器”右窗格的“名称”栏下以“ ”（以后用“＠默认”形式）显示出来 | @=“控制面板的外观”
=”键值” | 指定字符串值的内容 | ="Windows 标准"
=hex: | 以十六进制串显示二进制值 | = hex:ff，ff，ff，00，ff，ff，ff
=dword: | 以十六进制显示双字数值 | =dword:00000001


135

注册表本身就是一个大数据库，必须要有专门的编辑器才能打开它，同时注册表又很脆弱，它的一点问题都可能导致系统的崩溃，所以用好注册表编辑器浏览、修改注册表就成了一门基本功，这对提高使用注册表的水平是必不可少的。

微软为windows操作系统提供了两个注册表编辑器，一个是Regedit.exe，在Windows 95/98/Me/NT/2000中使用；另—个是Regedt32.exe，是一个纯32位的程序，只在Windows NT/2000中使用。

这两种windows自带的注册表编辑器各有所长。Regedit.exe的显示界面更符合人们的使用习惯，搜索功能也比较强大；而Regedt32.exe支持的键值数据类型更多，功能也更完善。

当windows操作系统升级到Windows XP的时候，这两个程序仍然存在，但实际上它们已经结合各自的长处合二为一了。这个新的注册表编辑器结合了Regedit.exe浏览器的显示界面、强大的搜索功能和Regedt32.exe提供的注册表权限控制两方面的优势


136

藏陋网，解决电脑故障！ http://www.canglou.com/


137

藏陋网，解决电脑故障！ http://www.canglou.com/


NewTopic

藏陋网，解决电脑故障！ http://www.canglou.com/

如何修改注册表的键值呢？各个键值代表的又是什么？请看下面... ...


141

在注册表中， 注册表编辑器左窗格显示主键或者子键的分层次关系。但是，你也可以在左窗格内创建新的主键（或子键）。

例如，我们需要在HKEY_CURRENT_USER\Software分支下创建一个HHSW主键，其操作步骤如下：

1 打开指向要创建新主键的位置的注册表，如HKEY_CURRENT_USER\Software分支。

2 在左窗格内单击鼠标右键，弹出如图所示的快捷菜单。

注意：也可以在“编辑”菜单中选择“新建”命令.
3 在该快捷菜单中指向“新建”，然后单击“主键”，则在Software主键下面创建了一个新的主键（或子键）“新建 #1”
4 在此“新建 #1”框内输入新主键的名称，如“HHSW”，然后按 Enter 键


142

你可以为新创建的主键或者已有的主键（子键）重新换名。例如，我们可以将前面创建的“HHSW”主键换名为“黄后软件工作室”。下面为操作步骤：

1 打开要换名的HKEY_CURRENT_USER\Software\HHSW分支。

2 按鼠标右键，则弹出的快捷菜单,选择“重命名”。

你也可以在“编辑”菜单中单击“重命名”命令.
3 在该快捷菜单中选择“重命名”命令，则在要重命名的主键四周出现一个矩形框
4 在矩形框内输入新的主键名称，如“黄后软件工作室”，然后按Enter键，则完成了主键的重命名操作.


143

例如，我们要在“HKEY_CURRENT_USER\Software\ 藏陋网”分支中加入“RegistryInfo=xiaofei”的键值项数据，可执行如下操作步骤：

1 在注册表中打开“HKEY_CURRENT_USER\Software\藏陋网”分支。

2 在右窗格内右键单击要添加新键值项数据的位置，则弹出一个快捷菜单。
3 在该快捷菜单中指向“新建”，然后单击要添加键值项数据的类型：字符串值、二进制值或DWORD值。例如，我们选择了“字符串值”，此时新键值项数据将以“新值 #1”显示出来.
4 在“新值 #1”框内键入新的键值的名称，如“RegistryInfo”，然后按Enter 键.
5 双击新添加的键值名“RegistryInfo”，则弹出如图1-36所示的对话框。
在“键值”框内输入“xiaofei”（这是键值项数据中的“键值”部分值），然后单击“确定”按钮.


144

前面已经简要地介绍了在注册表中更改键值项数据的方法。但是，你还可以修改“键值名”的名称，或者“键值”数据，同时还可以根据需要删除选定的键值项数据。

(1) 修改键值项数据

例如，我们需要将前面所创建的键值项数据“RegistryInfo=曹国钧”改为“RegistryInformation＝王健”，其操作步骤如下：

1 选择键值项数据“RegistryInfo=曹国钧”。

2 在“RegsitryInfo”键值名上单击鼠标右键，则弹出快捷菜单。
3 在该快捷菜单中选择“重命名”命令，则在“RegistryInfo”周围出现一个矩形框.
4 在此矩形框内输入“RegistryInformation”，则为原键值名换名了.
5 双击“RegistryInformation”键值名，在如图1-41所示的对话框的“键值”框内输入新的键值，如“王一健”，然后单击“确定”按钮，则完成了键值的修改工作。


145

例如，我们需要将上面创建的键值项数据删除，则需执行如下操作步骤：

1 选定要删除的键值项数据。

2 按Del键或者按右键的快捷菜单中选择“删除”命令，系统将弹出删除确认对话框。
单击“是（Y）”按钮，则将此键值项数据从注册表中删除了


146

我们可以将注册表减“瘦”，其操作方法是删除某些不重要的主键（或者子键）分支。但在删除这些分支之前，要确认这些分支是无用的或者冗余的。例如，我们要删除“HKEY_CURRENT_USER\Software\黄后软件工作室”分支，请执行如下操作步骤：

1 选定“HKEY_CURRENT_USER\Software\黄后软件工作室”分支。

2 按Del键，或者单击鼠标右键，在弹出的快捷菜单中选择“删除”命令。
3 在弹出的确认对话框中单击“是（Y）”按钮，则将选定的主键删除掉


147

我们可以使用注册表编辑器查看键值及其形式。 键值有多种形式，如开关型（On/Off、0/1）、数值型（二进制、DWORD值）以及字符串型。开关型主要用于系统的复选框、检查框等，而数值型用于控制选项的数值。字符串型通常用于系统显示信息。这些键值的修改可参见前面的介绍。

通常情况下，与“控制面板”中的图标有关的注册表选项，在修改后可以立即发生作用。例如，你可以在注册表中的HKEY_ CURRENT_USER\Control Panel\keyboard分支下修改KeyboardDelay，KeyboardSpeed键值数值（见图1-53），然后在“控制面板”的“键盘”图标中查看键盘速度.

我们发现，它们之间的变化是同步的。同样地，在图1-53中，修改PowerCfg主键下的键值数据也会同时修改电源管理方案中的有关选项。

但是，有关硬件、网络、服务、输入法等安装方面的键值数据，必须重新启动Windows 98系统才能发生作用。如HKEY_LOCAL_MACHINE\System\CurrentControlSet \Services分支下（的键值数据就需要重新启动才能对Windows98发生作用。


148

其实，不重新启动Windows 98系统或者计算机，也能快速地更新注册表，从而使用修改后的键值项数据。下面介绍这种操作方法。

1 按下Ctrl+Alt+Del组合键

2 在该对话框中单击“Explorer”选项，然后单击“结束任务”按钮，出现“关闭Windows”对话框。

3 单击“否(N)”按钮，系统过一会儿将出现结束程序的对话框.

单击“结束任务(E)”按钮，则返回到Windows 98系统环境中。

另外，还有一种方法也能快速地重启Windows 98而使注册表得到更新，不过此方法比上面介绍的方法要慢一些。

1 单击“开始”按钮，然后单击“关闭系统”命令，出现如图1-57所示的“关闭Windows”对话框。

2 单击“重新启动计算机”选项。

3 按住Shift键，然后单击“是”按钮，则关闭Windows 98，然后出现“Restarting Windows…”而重新启动计算机。


149

HKEY_CLASSES_ROOT/Paint.Picture/DefaultIcon，

其操作方法如下：

1 双击右窗格的默认字符串，在对话框中删除原来的“键值”，再输入%1。
2 重新启动系统后，在“我的电脑”窗口中打开Windows目录。3 在“查看”菜单下选择“大图标”，则所有的文件夹或者文件将以“大图标”方式显示出来，此时，你将看到Bmp文件的图标再也不是千篇一律的MSPAINT图标了，而是每个Bmp文件的略图（前提是未安装ACDSee等看图软件）


1410

1. HKEY_CURRENT_USER\Control Panel\desktop

操作方法如下：

1 在该分支的右窗格内新建一个串值名“MenuShowDelay”，

2 双击“MenuShowDelay”键值，在如图1-70所示的对话框的“键值”框内输入0。

在经过上面的设置后，系统可使“开始”菜单中子菜单的弹出速度提高。

2. HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics

操作方法如下：

1 在该分支的右窗格内新建一个串值名“MinAnimate”，
2 双击“MinAnimate”键值，在对话框的“键值”框内输入一数值。若该数值为1，则启动动画效果开关窗口；若数值为0，则取消动画效果。


1411

(1) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer \User Shell Folders：保存个人文件夹、收藏夹的路径。

(2) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\KeyboardLayouts：保存键盘使用的语言以及各种中文输入法，
(3) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall：保存已安装的Windows应用程序卸载信息
(4) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class ：保存“控制面板”窗口中的“添加新硬件”的“硬件类型”目录
(5) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update ：立即刷新设置
(6) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run：保存由“控制面板”设定的计算机启动时运行程序的名称
(7) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\ Ratings：保存IE4.0的“Internet属性”对话框的“内容”选项页中的“分级审查”中设置的口令(此口令数据已加密)

(8) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer

\Desktop\NameSpace：保存中文Windows 98桌面中特殊的图标，如回收站、收件箱、MS Network等


1412

(1) HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer\TypedURLs：

保存IE4.0浏览器“地址栏”中输入的URL地址列表信息
(2) HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer \MenuOrder\Start Menu：保留“程序”菜单的排序信息
(3) HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\Currentversion\Explorer \RunMRU：保存“运行”对话框中运行过的程序列表信息
(4) HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer \RecentDocs：保存最近使用的15个文档的快捷方式
(5) HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets：保存Windows应用程序的记录数据
(6) HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run：保存由用户设定的计算机启动时运行程序的名称。启动后的程序图标显示在任务栏右侧。


1413

藏陋网，解决电脑故障！ http://www.canglou.com/


2222222221111111111

藏陋网，解决电脑故障！ http://www.canglou.com/

虽然中文Windows 98系统对注册表有很多保护措施，例如，在系统启动后，除非用户使用合法的工具，否则就无法拷贝、删除、修改注册表。所以，注册表错误很少产生。但是，如果注册表遭到破坏，那么系统可能无法访问硬件设备，无法运行应用程序，应用程序运行不正常，甚至于系统无法启动，系统、应用程序、数据等遭到毁坏。 如何安全防范这样的事情发生呢?请看下面... ...


211

操作步骤如下：

1 运行注册表编辑器。

2 打开HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Explorer

\RunMRU分支。该分支记录了“开始”菜单下的“运行”命令的程序执行列表。

在HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Explorer分支下，你还可以使用相同的方法清除系统的各类文件打开的历史记录，一些常用软件也用各自的文件打开历史记录，可结合具体的情况进行删除。


21a

Windows 在启动时按下相应的键可实现多制式启动，这些键为：

F4 | 以原 DOS 启动（适用于 Win 95） | F5 Shift | 进入安全模式
F8 Ctrl | 显示启动菜单 | Shift + F8 | 逐行提示执行配置文件
Shift + F5 | 用 Windows 自带的 DOS 7.0 启动 |  |

按 F8 或 Ctrl 时将显示如下菜单：

1. Normal | 默认，即一般的 Windows 启动
2. Logged (\BOOTLOG.TXT) | 同上，但将驱动程序的装入记录入 C:\Bootlog.txt
3. Safe mode | 安全模式 同 F5、Shift 键
4. Step-by-step confirmaficn | 逐行提示是否执行配置文件 同 Shift + F8
5. Command prompt only | 用自带的 DOS 7.0 启动 同 Shift + F5
6. Safe mode command prompt only | 跳过配置文件进入 DOS，即安全模式的 DOS
7. Previous version of MS-DOS | 以原 DOS 启动（适用于 Win 95） 同 F4

若用户自行改变 MSDOS.SYS 文件的设定，可能上述功能将被屏蔽。

MSDOS.SYS 文件格式

在C:\目录中有一MSDOS.SYS文件，它是用来规定 Windows9x 的各种启动设置，是文本文件。

格式如下：
[PATH] 路径段
WinDir=C:\WINDOWS 说明 Win9x 的所在目录（不能认为改了它就能改Win9x的系统目录，它只是一个简单说明）
WinBootDir=C:\WINDOWS 启动 Win9X 图形界面文件的目录（即Win.COM文件所在目录）
HostWinBootDrv=C 指定系统启动文件的盘符（IO.SYS、COMMAND.COM）

[Options] 选项段（为 1 时启用，为 0 时禁用，下例给出的为推荐设置值）
BootMulti=0 是否设为双重启动（原DOS 6.22 系统应存在，一般只在Win95中使用）
BootWin=1 是否以Win9x启动，同BootMulti一起决定是用DOS还是用Win9x启动系统
BootGUI=1 是否进入 Win9x 的图形界面
DoubleBuffer=1 是否设置双缓冲
AutoScan=1 是否启动时加入自动扫描硬盘程序
BootMenu=0 是否自动显示启动菜单
BootKeys=1 是否使用 F4、F8
BootDelay=n 用一整数设置开机时显示"Starting Windows9x..."的时间，当=0 时F4、F8键失效
BootFailSafe=1 启动出错时用安全模式进入Win9x
Logo=1 是否显示开机画面
WinVer=4.10.1998 Win9x 的版本

还有一些不常用的选项就不例出了，而上述选项也不一定全有，但可手动加入。

在文件后有许多以“;”开始的行，请不要删除，因为该文件要求要大于1024字节，它们是用来充数的。
最后还要注意的一点是该文件是系统文件，不能直接用“记事本”来修改，在保存之前要记得先修改它的文件属性，否则无法保存！


212

在通常情况下，注册表被破坏后，系统会有如下现象发生：

(1) 系统无法启动。例如，在启动Windows 98时，将出现如图1-97所示的对话框。单击“确定”按钮后，系统即将死机。有时也会出现如图1-98所示的对话框。如果单击“关闭”按钮，则系统将死机。如果单击“详细资料”按钮，则将给出Mprexe.exe程序无法运行的原因与地址（这里的Mprexe.exe程序是Windows 98正常启动的启动程序）

(2) 无法运行合法的应用程序。

(3) 应用程序无法正常运行。

(4) 找不到相应的文件。

例如，在启动Windows 98时，可能会出现如下提示信息：

    Cannot find a device file that may be needed to run Windows or a windows application.

    The Windows Registry or System.ini file refers to this device file，

 but the device file no longer exists

If you deleted this file on purpose，try uninsalling the associated application using its uninstall

Or Setup program.

If  you still want to use the application associared with this device file，

Try  reinstalling the application to replace the missing file.

Ndskwan.vxd

    Press a key to continue.

(5) 没有访问应用程序的权限。

(6) 驱动程序不能正确被安装。

(7) 无法调入驱动程序。

(8) 不能进行网络连接。

(9) 注册表条目有误。
在启动Windows 98后，可能会出现错误对话框!


21b

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Run 下添加"ScanRegistry"，值为字符串"C:\Windows\Scanregw.exe /autorun"若不添加这项功能则删除这个串值就可以了。所备份的文件有： system.dat,win.ini,system.ini 及 user.dat .它们备份于 "C:\Windows\BackUp"或"C:\Windows\BAK"目录下。


213

破坏注册表的主要途径可以归结为如下三大类：

1. 向系统中添加应用程序和驱动程序

由于用户经常地在Windows 98上添加或者删除各种应用程序和驱动程序，因此，基于以下几种情况，注册表有被破坏的可能：

(1) 应用程序的错误

在实际使用过程中，很少有完全没有错误的应用程序。最好的情况就是用户在使用软件过程中没有遇到错误，而且那些看似微小的错误，可能会导致非常严重的后果。同时，当今的软件的数目是如此的繁多，谁也不能确定当多个软件安装在一个系统里以后，是否能正常运行，彼此间是否毫无冲突。那些做Beta测试的软件，就是因为系统还没有定型，还有相当多的错误，希望被测试用户在使用的过程中发现。

(2) 驱动程序的不兼容性

虽然驱动程序一般都经过了比较周密的测试，但是由于PC的体系结构是一个开放性的体系结构，谁也不能确认每个驱动程序会和哪些其他程序协同工作。因此，谁也不可能测试所有的可能性，这样就有不兼容的可能性存在。

(3) 使用了错误的驱动程序

某些驱动程序是16位的，在安装到32位的Windows 98操作系统后，可能出现不兼容的情况。

(4) 应用程序在注册表中添加了错误的内容

某些应用程序在修改注册表时，增加了不该增加的内容，或者将原来正确的注册表内容修改为不正确的内容。

(5) 应用程序添加了错误的数据文件和应用程序之间的关联。

2. 硬件被更换或者被损坏

如果计算机系统本身出现了问题，常常会导致注册表的毁坏。下面列出的几种原因会导致计算机系统出现问题：

(1) 病毒 现在一些病毒（如CIH病毒等）可以更改系统的BIOS程序，使BIOS程序受到破坏。还有一些病毒可能会隐藏在Cache中，使系统运行不正常。某些CMOS病毒能够清除CMOS存储器所保存的硬件数据。

(2) 断电 在非正常断电情况下，可能会烧毁主板或者其他硬件设备。

(3) CPU烧毁 在CPU超频情况下，可能会烧毁CPU。另外，在夏天工作时，由于温度过高，发热量较大的CPU（如AMD，Cyrix，IBM，WinChip等）极易烧毁。

(4) 硬盘错误 由于硬盘质量不稳定，导致系统受到破坏。

3. 用户手工修改注册表

由于注册表中的数据是非常复杂的，所以用户在手工修改注册表的时候，经常导致注册表中的内容的毁坏。

有时，用户会将另一台计算机上的注册表覆盖到本地计算机上的注册表文件，但是由于一个注册表在一台计算机上使用正常，并不等于它会在其他计算机上也使用正常，这样做极易破坏整个系统。


214

1 重新启动系统

Windows 98注册表中的许多信息是保存在内存中的，如HKEY_DYN_DATA根键中的子键信息等。用户可以通过重新将硬盘中的信息调入内存来修正各种错误。每次启动系统时，注册表都会把硬盘中的信息调入内存。

例如，在启动Windows 98时出现"系统访问注册表错误,需要重新启动"的错误信息时，单击“确定”按钮，Windows 98将首先修复注册表，然后进入启动过程。

2 使用安全模式启动

如果在启动Windows 98系统时遇到注册表错误，可以在安全模式下启动，即在启动时按F5键，Windows 98将在安全模式下启动，此时系统可以自动修复注册表问题。在安全模式下启动Windows 98成功后，即可在正常模式（Normal）下启动Windows 98。

注意：由于在安全模式下Windows 98并没有将注册表文件锁住，所以用户可以这种方式拷贝注册表文件，其方法是在安全模式的Windows 98下，用户修改完System.dat和User.dat的文件属性后就可以拷贝这两个文件。在拷贝完以后，请将文件属性修改回去。

3 重新检测设备

如果注册表中关于某种设备的信息发生错误，那么这个系统就无法正确管理这个设备。这时，用户可以移去这个设备，再安装一次，或者让Windows 98重新检测这个设备。下面介绍几种方法。

1. 使用“控制面板”窗口中的“添加新硬件”图标

在删除（或者拨掉）即插即用硬件设备后，可以使用下面两种常用方法安装：

(1) 自动检测法

Windows 98在启动计算机时可以自动检测即插即用硬件设备，然后从Windows 98安装光盘中安装相关设备驱动程序。其操作步骤如下：

1 关闭计算机。

2 将硬件设备连接到计算机上。

3 打开计算机，并启动Windows 98，此时Windows 98将自动检测新的“即插即用”设备，并安装所需的驱动程序。

这种方法对于所有用户都是适用的。

在使用这种方法时应注意的是，如果 Windows 98没有检测到新的“即插即用”设备，则设备本身没有正常工作、没有正确安装或者根本没有安装，此时请不要使用“添加新硬件”向导。因为“添加新硬件”向导不能解决此处所提的任何问题。

(2) 使用“添加新硬件”向导

有时，在计算机检测到新硬件时没有及时安装驱动程序，但是需要在Windows 98中使用该设备，此时就需要使用“添加新硬件”向导了

2. 利用“设备管理器”重新安装设备

Windows 98提供了功能强大的“设备管理器”，该管理器可以查看与管理硬件设备。下面介绍利用“设备管理器”重新安装设备的操作步骤。

1 在“控制面板”窗口中双击“系统”图标，出现“系统属性”对话框。

2 单击“设备管理器”选项卡，出现如图1-105所示的对话框。

3 在图1-105中选择注册表中有问题的设备，然后单击“删除”按钮，出现确认对话框。单击“确定”按钮，删除此设备。

4 在删除了设备后，单击“刷新”按钮，“设备管理器”将重新检测所有的设备，并且安装相应的设备驱动程序。

5 重新启动计算机后，即可对有问题的注册表进行更新。


215

如果Windows 98启动或者运行时故障太多，以前又忘记了给Windows 98运行最正常时的系统注册表作过备份，或者根本启动不了Windows 98，我们可以使用System.1ST恢复系统注册表。

细心的Windows 98用户应该知道，Windows 98在成功地安装后会把第一次正常运行的Windows98系统信息保存在启动盘（通常为C盘）根目录下的System.1ST这个HSR（隐藏、系统、只读）属性的文件中，并且不会随Windows 98的系统配置改变而改变。因此，我们在没有其他办法的情况下，使用这个文件进行最保守的恢复。

下面介绍使用System.1ST恢复系统注册表的操作步骤（假定Windows 98安装在C:\Windows目录下）。

1 在DOS环境下执行如下系列命令：

Attrib  -h  -r  -s  C:\Systerm.1st

Attrib  -h  -r  -s  C:\Windows\System.dat

Copy  C:\System.1ST    C:\Windows\Systerm.dat

Attrib  +h  +r  +s  C:\Systerm.1st

Attrib  +h  +r  +s  C:\Windows\System.dat

2 重新启动Windows 98。

由于System.1st保存的是Windows 98第一次正常运行时的系统信息，后面更改的Windows 98软硬件配置信息未被更新到这个文件中，因此此方法只能进行最保守的恢复。


216

当用户很难找到导致注册表毁坏的原因时，可以重新安装驱动程序、应用程序或者Windows 98。虽然重新安装Windows 98会花费比较长的时间，但是与查找注册表中的错误相比，能节省不少的时间。

为了帮助用户快速地安装Windows 98，下面给出一种简单的方法：

1 将Windows 98光盘中的\Win 98下的所有文件拷贝到D:\PWIN98目录中。

2 在DOS提示符键入Smartdrv 10240 10240 （创建10MB的磁盘高速缓冲区）。

3 在DOS提示符下键入D:\PWIN98\Setup /is/iq命令，则开始安装Windows 98。


217

在运行Windows 98系统时，经常会出现注册表错误，例如，在使用过程中会突然出现一个如图1-106所示的“注册表问题”窗口。

如果单击“重启动Windows窗口”按钮，系统会重新启动。如果这种错误出现一次，不采取切实可行的措施，系统以后还会出现这种错误。如何解决这种错误呢？

图1-106

在Windows 98系统中，注册表中包含的是关于如何运行计算机的重要信息，通过修改它可以实现Windows 98的某些性能，但在注册表有问题时，会造成系统发生问题甚至瘫痪。注册表信息存放在Windows 98系统目录下的SYSTEM.DAT和USER.DAT文件中。从上面的故障现象可以得出结论，注册表已被破坏，应用正确的注册表来代替损坏的注册表，其操作步骤如下：

(1) 首先在安全模式下导出，然后再引入注册表文件。

1 关闭计算机后，重新启动，在出现“Starting Windows 95”或者“Starting Windows 98”时按F8键，在启动菜单中选择“Safe mode command prompt only”，则系统进入安全模式下。

2 执行如下命令（命令后面的括号为注释）：

regedit /l:c:\windows\system.dat /e c:\system.txt       （导出注册表）

cd\windows                       （Windows 98系统目录）

attrib -s -h -r system.dat       （去掉SYSTEM.DAT的系统、隐含、只读属性）

ren system.dat system.old      （将当前的SYSTEM.DAT文件改名）

regedit /l:c:\windows\system.dat /c c:\system.txt      （引入注册表）

3 重新启动计算机，以正常方式启动Windows 98系统，如果错误仍出现，可以在安全模式下使用如下命令：

regedit /l:c:\windows\user.dat /e c:\user.txt     （导出注册表）

cd\windows

attrib -s -h -r user.dat          （去掉USER.DAT的系统、隐含、只读属性）

ren user.dat user.old                （将当前的USER.DAT文件改名）

regedit /l:c:\windows\user.dat /c c:\user.txt      （引入注册表）

(2) 重新启动计算机，以正常方式运行Windows 98 系统，如果错误仍出现，可以恢复系统至最后一次成功运行时的注册表。

1 关闭计算机后重新运行，在出现“Starting Windows 98”时按F8键，在启动菜单中选择“Safe mode command prompt only”进入安全模式。

2 执行如下的命令：

 cd\windows

 attrib -s -h -r system.dat  （去掉SYSTEM.DAT的系统、隐含、只读属性）

 ren system.dat system.bad      （将当前的SYSTEM.DAT文件改名）

3 重新启动Windows 98系统，在启动时系统如果没有发现system.dat文件，就会使用System.da0文件，系统会自动将System.da0文件改名为system.dat。

(3) 如果仍有错误出现，则恢复系统至第一次成功运行时的注册表。

1 关闭计算机后重新启动，在出现“Starting Windows 95””或者“Starting Windows 98”，时按F8键，在启动菜单中选择“Safe mode command prompt only”进入安全模式。

2 执行如下命令：

cd \windows

attrib -s -h -r system.dat         （去掉SYSTEM.DAT的系统、隐含、只读属性）

ren system.dat system.xxx     （将当前的SYSTEM.DAT文件改名）

cd \

attrib -s -h -r system.1st        （此文件在启动盘的根目录下，通常在C:\）

copy system.lst c:\windows\system.dat   （使用system.lst替代system.dat）

attrib +s +h +r system.lst                            （加上属性）

(4) 重新启动Windows 98系统，如果仍有错误发生，则可以重新安装Windows 98系统。

1 重新启动，在出现“Starting Windows 98”时，按F8键，在启动菜单中选择“Command prompt only”进入命令方式。

2 使用下面的命令，将注册表文件改名保存。

deltree c:\windows\profiles

（删除此目录及包含的所有子目录，这里的Profiles子目录下保存策略文件）

cd \windows

attrib -s -h -r system.dat

ren system.dat system.xxx

attrib -s -h -r user.dat

ren user.dat user.xxx

attrib -s -h -r system.da0

ren system.da0 system.yyy

attrib -s -h -r user.da0

ren user.da0 user.yyy

cd \

attrib -s -h -r system.lst

ren system.lst system.zzz

3 运行Windows 98光盘中的Setup.exe安装程序。


218

如何方便地设置普通用户与系统管理员的权限。

设置步骤如下：

1 在“控制面板”窗口中单击“用户”图标，打开添加用户对话框，按提示一步步操作，建立两个新用户名：“普通用户”和“系统管理员”，并且设置好各自的密码。

2 重启系统。

3 在系统启动完毕后，将出现如图4-2所示的登录对话框，在此对话框中输入用户名与密码。

如果上面的登录对话框未出现，请按照下面的步骤修改注册表：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion

\Network\RealModeNet分支。

3 在右窗格中建立一个二进制串“AutoLogon”。

4 将此串的键值设为01,00,00,00。


232

如何隐藏“我的电脑”中的驱动器盘符。

隐藏方法如下：

1 启动注册表编辑器。

2 进入HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer子键分支。

3 在右窗格内新建一个二进制串值“Nodrives”，缺省值是00000000，表示不隐藏任何驱动器。键值由4个字节组成，每个字节的每一位（bit）对应从A：到Z：的一个盘，当相应位为1时，“我的电脑”中的相应驱动器就被隐藏了。

第一个字节代表从A到H的8个盘，即01为A、02为B、04为C……依此类推，第二个字节代表I到P；第三个字节代表Q到X；第四个字节代表Y和Z。

4 双击“Nodrivesr”键值，在对话框的“键值”框内输入“Ff Ff FF FF”

若要关闭C盘，将键值改为04000000；要关闭D盘，改为08000000。

5 关闭注册表编辑器即可生效。

其修改步骤如下：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft \Windows\CurrentVersion\Policies

\Explorer子键分支。

3 在右窗格内新建一个“二进制值”的键值名“NoDrives”，那么如何确定“NoDrives”的键值呢？

4 根据分析，驱动器A～Z的值依次为2的0至25次方，把要禁止的驱动器的值相加，再转换为十六进制，就是NoDrives的键值了。如要禁止A、D、E，则此键值应为1+8+16=25，转换为十六进制数为19，修改“NoDrives”的键值为“19 00 00 00”即可


233

如何为驱动程序设置数字签证。

在中文Windows 98中，数字签名提供了三个安全级别，如果是0级，任何驱动程序均可安装；如果是1级，Windows 98在安装时会检查驱动程序是否经过签名，如果没有，会向安装者发出警告，但经过确认后仍完成安装；如果是2级，Windows 98将拒绝安装任何未经WHQL签名的驱动程序。

Windows 98在缺省状态下，将级别设为0级，但我们可以直接在注册表中修改它。

1 使用注册表编辑器打开注册表。

2 找到HKEY_LOCAL_MACHINE\Software\Microsoft\Driver Signing子键分支
你会看到原来的键值是00，你可根据需要改成01或02。其中01代表1级，02代表2级；1级就是如果没有注册标志时仅仅提示你，但允许继续安装，2级则绝不允许安装没有认证的驱动程序

为了判断某个程序是否经过数字签名，Windows 98提供了签名校验工具，其方法是：

1 在“运行”框中键入“sigverif.exe”，出现搜索对话框
2 用户可以搜索当前系统中经过签名或未有签名的驱动程序。例如，在图4-9中显示了已经签过证的文件列表


248

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

防止非法用户在登录时按Esc键进入Windows 98系统中。

你可以修改注册表，其操作步骤如下：

1 打开注册表编辑器。

2 查找注册表中的HKEY_LOCAL_MACHINE\Network\Logon分支，如图4-11所示。

3 在该分支的右窗格中创建一个DOWRD值“MustBeValidated”。

4 将此键值设为1

在使用此方法时，应注意如下问题：

l 如果你用的是单机系统，则以上做法不成立。

l 如果你用的微机在Windows 98对等网中，则以上做法成立，但是，由于对等网中没有“域”，因此永远也找不到“域”，因此永远也进不了Windows 98系统。即便是有口令也不行，从而也就没有任何实际价值。如果你使用的是对等网，则只能使用安全模式重新启动，然后在注册表中将上面设置的DWORD键值“MustBeValidated”删除掉，而后再进入到Windows 98系统中。

如果你使用的微机在有网络服务器的环境下，由于网络服务器分配给你一个用户名和口令来登录，而网络服务器上也有你的“域”，因而在系统要求输入“域”时请输入此域名。


219

禁止普通用户使用注册表编辑器编辑注册表。

请执行如下操作步骤：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\System分支。

注意：如果Policies主键下没有System 子键，则可以新建此子键。

3 在右窗格内新建一个DWORD值“DisableRegistryTools”，然后双击“DisableRegistryTools”键值，则在对话框的“键值”框内输入1。


2110

从注册表中分析屏幕保护程序的密码，然后设置其安全。

下面我们首先来看看Windows 98是怎么加密屏幕保护程序的密码吧！微软内置了16个字节的密钥：48 EE 76 1D 67 69 A1 1B 7A 8C 47 F8 54 95 97 5F。对你所键入的密码用这个密钥进行加密。

假设你使用的密码是king，其ASCII码值为4B 49 4E 47（所有的小写字母自动转为大写字母），Windows 98把它们与密钥的前4位逐位异或后得到03 A7 38 5A，再把求得的每一个十六进制数字当成ASCII码，转化为对应的十六进制值：30 33 41 37 33 38 35 41，然后加上00作为结束标志，存放注册表HKEY_CURRENT_USER\ControlPanel\desktop的键值ScreenSave_Data中

此时你只要做异或运算的逆运算就是异或本身，这就给解密带来了极大的方便，其方法如下：

1 启动注册表编辑器。

2 打开注册表HKEY_CURRENT_USER\ControlPanel\desktop子键分支。

3 在右边的ScreenSave_Data键值中找到加密的屏幕保护程序的密码。该键值为二进制值（十六进制数据），结束的字节必定是结束标志00。假定我们打开注册表，找到该项的值为31 39 44 46 32 32 25 33 34 34 36 36 35 34 39 00，先去掉结束标志00，再把余下的字节转换为对应的ASCII码：19 DF 22 25 34 46 F5 49。显然，密码共8位，把它与密钥的前8位逐位异或（可使用Windows自带的计算器计算），得51 31 54 38 53 2F 54 52，把这串十六进制数转换为对应的ASCII码——Q1T8S/TR。就这么简单，我们就解开了密码！

或许有人会说，我已经禁用了注册表编辑器。实际上，不用注册表编辑器也可以很容易地找到加密后的屏保密码，其方法如下：找到Windows目录或者“Windows\Profiles\用户名”目录下的User.dat，用十六进制编辑器打开（任何十六进制编辑器都可以，如果对付的计算机硬盘大小不超过2GB，你甚至可以使用PCTOOLS 5.0），然后查找ASCII字符串ScreenSave_Data，紧接着该字符串后面的就是前面在注册表里找到的数据。

只要微软没有改变加密的方法，哪怕更换了加密所用的密钥，也可以参考上面的过程通过试验找出密钥来。因此，对一些无关紧要的程序最好不要多此一举地设置什么密码，千万不要对不同的程序使用相同的密码。


2111

Windows 98系统的网络资源共享有两种级别：一种是“共享级”（Share Level），另一种是“用户级”（User Level）。当设置为共享级别时，若将某个目录设置为共享，则共享对话框中将有两个共享口令编辑框。为了使共享口令在口令编辑框中可以“*******”形式显示出来，请执行如下操作步骤：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies

\Network分支，

3 在此分支下，在右窗格内创建一个二进制串值“HideSharePwds”。

4 双击“HideSharePwds”键值，在对话框的“键值”框内输入“01 00 00 00”。如果此键值为“00 00 00 00”，共享口令将以正常字符方式显示在共享口令编辑框中。

5 退出注册表编辑器。

注意：将“HideSharePwds”键值删除也不会隐藏共享口令。


2112

如果你在使用Windows 98系统时遗忘了共享口令，则可以解密此共享口令，其操作步骤如下：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion

\Network\Lanman分支，

3 该分支下面的主键为共享资源的名称，它们的值为共享目录的属性。例如：

l Parm2enc：为Read-Only的共享口令。

l Parm1enc：Full Access的共享口令。

以上两个口令值是真正的口令（口令中的小写字符自动转为大写字符）与“35,9A,4D,A6,53,A9,D4,6A”异或后得到的，因此，只需将加密口令与“35,9A,4D,A6, 53,A9,D4,6A”一一对应异或即可得到真正口令的ASCII码。例如，Parm1enc内容为“74,D8,0E,E2,16,EF”，将其与“35,9A,4D,A6,53,A9,D4,6A”异或得到“41,42,43,44,45,46”，它就是“ABCDEF”的ASCII码，所以得到共享口令为“ABCDEF”。

l Path：共享目录的目录名（包含路径）。

Remark：共享目录的描述内容。


2113

当网络与Windows 98口令保存为*.PWL文件后，有的计算机高手会解密此文件，得到网络与Windows口令。为保证网络安全，要求Windows 98将网络口令保存在服务器中，而不能将口令保存在*.PWL中。为此，请执行如下操作步骤：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Net- work \Lanman分支。

3 在右窗格内新建一个二进制串值“DisablePwdCaching”。

4 双击“DisablePwdCaching”键值，在对话框的“键值”框内输入“01 00 00 00”。

5 退出注册表编辑器。

通过上面的设置后，登录的计算机就不会将网络和Windows口令保存为*.PWL了。

在做了上面的步骤后，最好将msconfig.exe程序从系统中删除或者改名放到其他自己知道的地方。


2114

其操作方法为：

(1) 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders分支

(2) 你可以更改该分支所对应的右窗格的如下字符串值，改为欲指向的路径（越隐蔽越好）：

1 “Desktop”：桌面设置所指向的目录。

2 “History”：用户历史记录所指向的目录。

3 “NetHood”：“网上邻居”所指向的目录。

4 “Personal”：“我的文档”（My Documents）所指向的目录。

5 “Program”：“开始”菜单中的“程序”菜单项所指向的目录。

6 “SendTo”：右键菜单中的“发送”菜单项所指向的目录。

7 “Startup”：“开始”菜单中“启动”菜单项所指向的目录。

8 “Recent”：“开始”菜单中的“文档”菜单项所指向的目录。

(3) 经过上面的设置修改后，在重启系统后将会发现以上各项的确指向欲指向的目录，不过在“程序”项上会多出另一个“程序”项，必须将之删除。你可以这样操作：

1 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\Explorer分支。

2在右窗格内新建一个DWORD键值“NoStartMenuSubFolders”，双击“NoStartMenuSubFolders”键值，在对话框的“键值”框内输入1。


23

给Windows 98加上一道“防火墙”，即警告信息框，让“非法入侵者”还没有进入系统就被可怕的警告信息吓得逃之夭夭。

当然，这需要祭出“Regedit大法”，请按如下操作进行：

1 启动注册表编辑器。

2 依次进入HKEY_LOCAL_MACHINE \ Software \ Microsoft\ Windows \Current Version \Winlogon子键分支。

注意：如果Winlogon 主键不存在，请新建之。

3 在此主键Winlogon下面建立一个新的字符串值“LegalNoticeCaption”，其内容为登录前的提示对话框的标题，例如，我们可以将它设为“欢迎使用xiaofei的计算机”
4 再在此主键Winlogon下面建立一个新的字符串值“LegalNoticeText”，其内容为登录前的提示对话框的内容，例如，我们将此内容设为“非法使用者，请登陆www.canglou.com与系统管理员联系！”
操作完毕后退出注册表编辑器，然后重新启动系统。怎么样，你看到刚才定义的那个信息框了吗？你自己可不要被吓倒喔！


249

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

禁用Windows 98系统中的“任务栏属性”功能。

为了禁止普通用户使用“任务栏属性”功能，请执行如下操作步骤：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\Explorer分支。

3 在右窗格内新建一个DWORD值“NoSetTaskbar”，然后双击“NoSetTaskbar”键值，在对话框的“键值”框内输入1


2410

隐藏Windows 98桌面上所有图标。

操作步骤如下：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\Explorer分支。

3 在右窗格内新建一个DOWRD值“NoDesktop”，然后双击“NoDesktop”键值，对话框的“键值”框内输入1。


2411

虽然我们在“我的电脑”中隐藏了所有的驱动器，但是用户仍可以利用MS DOS方式进入到各个驱动器，因此，为安全起见，我们还得禁用MS-DOS方式。

操作步骤如下：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies分支。

3 在该分支下新建一个主键“WinOldApp”，然后单击此主键。

4 在右窗格内新建一个DOWRD值“Disabled”，然后双击“Disabled”键值，在对话框的“键值”框内输入1。

图4-18

5 为了防止用户在重启系统时进入“重启计算机并切换到MS-DOS方式”，你还得在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp分支的右窗格中创建一个DOWRD键值“NoRealMode”， 然后双击“NoRealMode ”键值，在如图4-19所示的对话框的“键值”框内输入1


2412

禁用Windows 98内置的“查找”功能。

其操作步骤如下：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\Explorer分支。

3 在右窗格内新建一个DOWRD值“NoFind”，然后双击“NoFind”键值，在对话框的“键值”框内输入1。


21c

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值"NoRecentDocsMenu"，并设值为1。


2115

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个 DWORD 值“NoRun”，并设值为“1”。


21d

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Network 下
在右边的窗口中新建 DWORD 值NoEntireNetwork,并设其值为1。


21f

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 下
在右边的窗口中新建一个二进制值NoWindowsUpdate，并设值为1。


21g

藏陋网，解决电脑故障！ http://www.canglou.com/

把 c:\windows\system 下的名为 inetcpl.cpl 更名为 inetcpl.old 或则别的名字后就会出现禁止使用的情况
把名字再换回来，就可以恢复使用。


21h

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个DWORD值“NoClose”，并设值为“1”。


21i

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Shutdown下

在右边的窗口中修改一个字符串值：“FastReboot”，并将其值设为“0”。


21j

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制"NoSetFolders",并将其值设为"01 00 00 00"。


21k

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
在右边的窗口中创建一个DOWRD值：“NoDispCPL”，并将其值设为“1”。


21l

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值“NoRealMode”，并设其值为“1”。


21m

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Control Panel\Sound
在右边的窗口中，把字符串“Beep”的值改为“No”。


21n

 禁止在“显示属性”中出现“屏幕保护程序”这个分菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

在右边的窗口中新建一个DWORD值：“NoDispScrSavPage”，并设其值为“1”。

禁止在“显示属性”中出现“效果，web，设置”这三个分菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

在右边的窗口中新建一个DWORD值：“NoDispSettingsPage”，并设其值为“1”。

禁止在“系统属性”中出现“虚拟内存”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoVirtMemPage”，并设其值为“1”。

禁止在“系统属性”中出现“设备管理器”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

在右边的窗口中新建一个DWORD值：“NoDevMgrPage”，并设其值为“1”。

禁止在“系统属性”中出现“硬件配置文件”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

在右边的窗口中新建一个DWORD值：“NoConfigPage”，并设其值为“1”。


21o

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoAddPrinter”，并设其值为“1”。


21p

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoDeletePrinter”，并设其值为“1”。


21q

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
在右边的窗口中新建一个二进制值“link”，并设其值为“00 00 00 00”。


21q

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoSetTaskBar”，并设其值为“1”。


21s

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
下，在右边的窗口中新建DWORD值“NoProfilePage”，并设其值为“1”。


21t

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
下，在右边的窗口中新建DWORD值“NoSecCPL”，并设其值为“1”。


21u

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
点击“ProductKey”，即可看到。


21v

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System下
在右边的窗口中新建一个DWORD值“NoAdminPage”，并设值为“1”。


21w

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制值“NoLogOff”，并设值为“01 00 00 00”。


21x

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个值“NoFavoritesMenu”，并设值为“1”。


21y

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\CLASSES\.inf下
在右边的窗口中更改“默认”值为“txtfile”


21z

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\CLASSES\.reg下
在右边的窗口中更改“默认”值为“txtfile”


21aa

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\FindExtensions\Static\WabFind
下，删除主键“WabFind”。


21ab

藏陋网，解决电脑故障！ http://www.canglou.com/

修改路径：在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon下


21ac

在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制值“NoViewContextMenu”，并设值为“01 00 00 00”。
修改后需重新启动WINDOWS，启动后，你将不能在桌面，驱动器，文件夹等地方使用鼠标右键

键值4:"NoTrayContextMenu"=dword:00000001 作用:禁止在任务栏中使用右键菜单


21ad

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer加入DWORD值为"1"的 "NoSaveSetting"。但这项功能不是很好用，只能恢复对一些WIN参数的设置，对于文件及文件夹就无能为力了。在HKEY_USERS子树下的设置是对应于当前用户的，若要针对所有用户，则要在HKEY_CURRENT_USER相应的目录下更改。


21af

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policie\Explorer 添加相应的DWORD值，其中可以删除的子项有：收藏夹、文档、控制面板、查找、运行、注销、关闭系统及单击从这里开始的活动图标，相应的键为："NoFaroritesMenu"、"NoRecentDocsHistory"、

"NoSetFolders"、"NoFind"、 "NoRun"、"NoLogoff"、"NoClose" 及 "NoStartBanner"，所有的键值均是"1"是有效，"0"无效（即原WINDOWS默认状况）。


21ag

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 下新建二进制串"NoActiveDesktop" 改值为"01 00 00 00"。


21ah

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Doc Find Spec MRU下
删除右边窗口中的键。


21ai

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下

在右边的窗口中新建一个DWORD值“NoChangeStartMenu”，并设值为“1”。


21aj

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:新建"HideSharePwds"
数据类型:DWORD
键 值:"键值"框内输入1。


21ak

作 用:禁止"系统"中出现"设备管理器"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoDevMgrPage
数据类型:DWORD
键 值:1
备 注:
作 用:禁止"系统"中出现"文件系统"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoFileSysPage
数据类型:DWORD
键 值:1
备 注:
作 用:禁止"系统"中出现"虚拟内存"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoVirtMemPage
数据类型:DWORD
键 值:1
备 注:
作 用:禁止"系统"中出现"硬件配置文件"选项
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:NoConfigPage
数据类型:DWORD
键 值:1
备 注:
作 用:禁止在"系统属性"中出现"设备管理器"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoDevMgrPage"
数据类型:DWORD
键 值:设其值为"1"
备 注:
作 用:禁止在"系统属性"中出现"文件系统"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoFileSysPage"
数据类型:DWORD
键 值:设其值为"1"
备 注:
作 用:禁止在"系统属性"中出现"虚拟内存"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoVirtMemPage"
数据类型:DWORD
键 值:设其值为"1"
备 注:
作 用:禁止在"系统属性"中出现"硬件配置文件"的菜单
路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
键值名称:新建 "NoConfigPage"
数据类型:DWORD
键 值:设其值为"1"
备 注:


22

藏陋网，解决电脑故障！ http://www.canglou.com/

由于注册表和某些重要应用软件具有的特点，注册表在使用过程中会越来越庞大，致使系统启动和运行速度变慢.有必要对注册表进行清理了,这部分介绍系统的优化,可以删除很多不必要的注册表信息!


221

这种方法适用于某些不带Uninstall程序，或一些不用安装即可在中文Windows 98下直接运行的程序，如“网络计费器”Encounter、“下载专家”Download以及许多小型游戏程序等。它们一般只有一个可执行程序，运行时不会向中文Windows 98中加入DLL文件，但是它们仍然要利用注册表记录程序运行需要的参数，如计费准则、下载文件存放位置、利用键盘还是游戏杆进行操作等。如果不再需要它们，可以直接将文件删除，而且也不会在系统中遗留DLL之类的垃圾。但是注册表中仍然留有其主键以及键值，而且它们不能用工具软件清除。

清除此类程序主键的操作方法如下：

1 启动注册表编辑器。

2 单击“编辑”菜单下的“查找”命令，然后将“查找”对话框中的“主键”、“键值”项选中。

3 在“查找目标”框内输入可执行程序名。

4 单击“查找下一个”按钮，系统将在注册表中开始查找。在找到后选中主键，按Del键将其删除。

5 为保险起见，应单击“编辑”菜单下的“查找下一个”命令，系统将可能的其他主键全部找出来（这类软件一般只有一个主键），例如，“下载专家”Download的主键为HKEY_CURRENT_USER\Software\Ying，“网络计费器”Encounter的主键为HKEY_ CURRENT_USER\Software\e-port。


222

中文Windows 98为了适应不同国家和地区的需要，可以设置多种“键盘布局”，针对不同地区进行“区域设置”。这中间的绝大多数内容是我们不需要的，我们可以对它们进行精简。

1. 精简布局

下面为“精简布局”的操作方法：

1 运行注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\keyboard layout分支。

3 用鼠标左键依次单击左窗格keyboard layouts下的各个子键，将它们展开，同时在右窗格中即可看到它们属于何种键盘布局，但必须将“美国101”、“全拼输入法”、“微软拼音输入法”等需要的保留，其他不需要的选中，然后按Del键将其删除。

2. 精简区域

下面为“精简区域”的操作方法：

1 运行注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Nls\Locale分支
3 用鼠标左键依次单击左窗格的“Locale”子键，在右窗格中即可看到它们属于何种区域的键值数据，但必须将“中文（中国）”、“英语（美国）”、“英语（英国）”、“繁体中文（台湾）”等需要的保留，其他不需要的选中，然后按Del键将其删除。


223

下面为“精简Windows 98的小窍门”的操作方法：

1 运行注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer \tips，在此分支的右窗格内列出了一些运行Windows 98的小窍门.
3 你可以按Del键将tips主键删除。


224

下面为“删除时区设置”的操作步骤：

1 运行注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Time Zones分支
3 如果你在中文Windows 98中只使用北京时间，则可以只保留该分支下面的“China”主键，其余的时区设置可以删除掉。


225

注册表文件有关文件关联的内容存储在HKEY_CLASSES_ROOT根键下。该根键可以大致看成两部分：第一部分（按字母顺序A～Z）用来定义文件类型；第二部分（按字母顺序A～Z）与第一部分一一对应，用于记录打开文件的应用程序
一般来说，在第二部分中展开可疑键值后，如果在子键“command”下无内容，则说明该键为空键。例如HKEY_CLASSES_ROOT \cgjfile\shell分支下面的“command”子键中无内容，我们可以将此分支删除
更直观的方法是：打开“Windows资源管理器”，然后在“查看”菜单中选择“文件夹选项”，再在“文件夹选项”对话框中单击“文件类型”选项卡，其实可以看作是 HKEY_CLASSES_ROOT根键的一个图形界面。我们重点的是查看那些使用“通用文件图标”（白底上带一个Windows标志“ ”）的选项。如果确信用来打开文件的程序已经不存在，则可将该项删除。

上面两种方法可以配合使用。对不熟悉注册表编辑和文件关联概念的用户这部分内容有一定的危险性，你一定要小心！

注意：其实，HKEY_CLASSES_ROOT与 HKEY_LOCAL_MACHINE\Software \Classes下的内容完全一致，可视为它的一个副本。中文Windows 98在启动时真正用到的只有HKEY_LOCAL_MACHINE与 HKEY_USERS这两大主键，其他各项均由这两项衍生或是动态生成。对于单用户的系统，注册表文件的清理工作集中在这两项即可。


226

操作步骤如下：

1 运行注册表编辑器。

2 打开HKEY_CURRENT_USER\Control Panel\Appearance\Schemes分支

3 在该分支的右窗格内列出了中文Windows 98列出的窗口配色方案。通常只保留“Windows 标准”即可。

更直观的方法是：打开“控制面板”窗口中的“显示”，然后在“显示属性”对话框中单击“外观”选项卡，在窗口配色“方案”下拉列表中进行选择


227

藏陋网，解决电脑故障！ http://www.canglou.com/

许多应用软件在卸载之后仍会在注册表文件内留下一些无用信息。比较集中的地方在HKEY_LOCAL_MACHINE\Software，HKEY_CURRENT_USER\Software和HKEY _USERS\.Default\Software。这几项里面的内容基本上一致，在其中一处作查找删除就差不多了。

例如，进入HKEY_LOCAL_MACHINE\Software分支中，然后重点查找那些已经确信被安全卸载了的软件的残留信息，在确认无误后删除。


228

注册表文件采取了类似 FoxPro的数据记录方式。为了加快处理速度，系统在删除注册表中某一键值时只将该项的标识删除，但实际信息仍然保留在注册表文件中，其所占空间自然也不会释放出来。这样的结果便是Windows在经过一段时间的使用后，特别是反复安装/删除软件、硬件后，其体积会有明显的增长。根目录下的系统隐含文件system.1st是第一次安装Windows后产生的注册表文件的备份文件，拿它与Windows目录下的System.dat比较一下大小，就会对注册表文件的增长速度有深刻体会了。臃肿的注册表文件不仅浪费磁盘空间，而且会影响系统的启动速度及系统运行中对注册表的存取效率，因此有必要适当控制其大小的增长。

为此，清除带有删除标记的主键也可以精简注册表。

下面为具体操作步骤：

(1) 运行注册表编辑器。

(2) 单击“注册表”菜单中的“导出注册表文件”命令，在“导出注册表文件”对话框中执行如下操作：

1 将“导出范围”选项中的“全部”选项选中，系统将备份整个注册表。

2 在“保存在”下拉列表框中选择存盘路径（如C:\REG）。

3 在“保存类型”下拉列表框中选择“注册表文件”。

4 在“文件名”框中输入一个文件名（如BF）。

5 单击“保存”按钮。

(3) 重新启动系统，在启动时按F8键，在弹出的启动菜单中选择“Command Prompt Only”选项，则进入了纯DOS环境下。

注意：在纯DOS环境下加载磁盘高速缓存程序Smartdrv，否则在导入注册表时将很慢。

(4) 在中文Windows 98的系统目录C:\Windows下执行如下命令：

Attrih  -s  -h  -r  system.dat

Attrih  -s  -h  -r  user.dat

Del  system.dat

Del  user.dat

在执行了上述命令后，将原注册表删除掉。

(5) 执行如下命令：

Regedit /c c:\reg\bf.reg

则在C:\Windows目录中生成新的注册表。


229

每次在窗口添加一个文件夹或删除一个对象后，须要按F5键对窗口进行重新刷新，很麻烦。

通过修改注册表可以达到自动刷新的目的。

1 启动注册表编辑器。

2 在注册表中单击HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control

\Update子键分支
3 在对话框中修改“UpdateMode”值，由“1”改为“0”


22a

Windows 98第二版在启动时能自动加载一些程序运行，有的程序放在“开始”菜单中的启动组里，一些重要的、不须用户干预的系统程序，则存放在注册表中。

如果你想加快Windows 98第二版的启动速度，可以适当地删除这些程序。在启动组中的程序可以通过“任务栏”很方便地删除。如果程序不在启动组中，则需要通过修改注册表来删除，其方法如下：

1 启动注册表编辑器。

2 在注册表中单击HKEY_LOCAL_MACHINESoftware\Microsoft\Windows\ Current Version\Run子键分支

3 选择右边窗口中出现的开机自启动程序，将之删除即可。

你也可以使用系统配置程序MSCONFIG中的“启动”选项卡的相应选项删除自启动程序，如图6-4所示。

4 在注册表中单击HKEY_LOCAL_ MACHINE\Software\Microsoft\ Windows\CurrentVersion\RunServices子键分支，

5 单击右边窗口中出现的开机自启动程序，将之删除。

注意：Run和RunServices的区别是，Run中的程序是Windows初始化后才运行的，而RunService中的程序是在操作系统启动时就开始运行的，也就是说RunServices中的程序先于Run中的程序运行，如电源管理程序。
加快Windows 98的启动速度

你可以使用下面的方法：

1 删除Config.sys和Autoexec.bat文件，如果有必要，也可以保留部分项目。

2 如果在Config.sys文件中有关于光驱驱动程序的配置项，将其删除，因为它的存在使系统增加了一次检测光驱的过程，浪费了启动时间。

3 在不使用CD-ROM时，将其中的光盘取出，否则Windows 98在启动中会有一个认盘的过程。

4 删除启动程序组中的项。

5 清除Win.ini中的有关“run”或“load”指定的运行程序，因为它们在系统启动时将自动运行。

6 在注册表中的HKEY_LOCAL_MACHINE\software\microsoft\windows\CurrentVerson

\run位置处删除相应的程序项目。

7 口令的检测将影响启动速度，普通的口令可通过控制面版的“密码”功能进行修改。

8 在“屏幕属性”设置中不使用屏幕保护程序。系统在初始化图形界面后，要加载屏幕保护程序，它将浪费启动时间。或在系统初始化图形界面后按住Shift键，系统将不加载屏幕保护程序。

9 清除注册表中的无用信息。Windows 98的注册表是以数据库形式保存系统的软硬件信息的，为了加快处理速度，注册表仅仅在已删除的表项上加上标记而不是真正地删除。所以，在经过多次的删除和安装程序之后，在注册表中会有很多无用的信息，造成系统启动速度的减慢。


22b

为光驱增加缓存是提高光驱读写速度的一个有效方法。Windows 98第二版推荐使用四倍速或更高速的光驱访问方式，与目前所流行的光驱不相符合。为了适应当今流行的16倍速以上的光驱，我们可以通过修改注册表来提高光驱缓存的大小和预读取性能，以加快光驱的运行速度，将光驱性能发挥到极限。

下面为修改步骤：

1 运行注册表编辑器。

2 在注册表中单击HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Control\FileSystem\CDFS子键分支

3 在该项右边窗口中找到CacheSize和Prefetch两项。如果选择的是Windows 98第二版推荐的四倍速或更高速的光驱访问方式，这两项的值分别是“6B020000”和“E4000000”。这时可以针对光驱的实际使用情况来修改，如果光驱常用于多媒体的播放，可以把CacheSize值修改为“D6040000”。“AC090000”是光驱缓存的最大值。为保证高速光驱始终如一的速度，你可以对Prefetch值进行修改，如8倍速为“C0010000”，16倍速为“80030000”，24倍速为“40050000”，32倍速以上为“00070000”。

注意：如果修改了两个键值导致光驱不能正常工作，如不能正常播放VCD，请降低一个档次的值。


22c

“控制面板”是用户最常用的组件之一。为了能够经常地访问此组件，你可以在桌面上为此组件创建一个快捷方式。如果你的桌面是IE4.0的活动桌面风格（或者使用的Windows 98操作系统），则可以很容易地创建控制面板的快捷方式。

下面为创建步骤：

1 在桌面的任意空白位置右击鼠标，然后选择“新建”下的“文件夹”，则在桌面上新建一个新的文件夹图标。

2 将该文件夹命名为：“控制面板.{21EC2020-3AEA-1069-A2DD-08002B 30309D}”，这里的“{21EC2020-3AEA-1069-A2DD-08002B30309D}”为“控制面板”在注册表中的类标识（CLSID）。

这样，我们就在桌面上建立了一个“控制面板”的快捷方式。


22d

在机器所配置的驱动器中，恐怕软盘驱动器的读写速度最慢，除了由物理方面的性质所决定之外，也跟Windows 98第二版系统采用默认FIFO来管理软盘驱动器，使之不具备后台存储管理功能有关，因此可以通过修改注册表来优化软盘驱动器的性能。

修改方法如下：

1 启动注册表编辑器。

2 在注册表中单击HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ Class\Fdc\0000子键分支
3 在该项右边窗口的空白处单击鼠标右键，选择“新建”菜单中的“DWORD值”命令，命名为“ForeFifo”

4 在如图6-9所示的对话框中修改值为“0”。

5 关闭注册表编辑器。

6 重启Windows 98第二版系统即可使设置生效。


22e

在Windows 98上面，开始菜单的显示延迟都是一样的——默认值为200毫秒。如果要运行的程序在菜单的深处，那么我们花在上面的时间就不少了。加快菜单的显示速度不但可以改善这种情况，而且还给人一种机器速度快的感觉。

我们可以通过修改注册表达到此目的，下面为修改步骤：

1 运行注册表编辑器。

2 请展开HKEY_CURRENT_USER\Control Panel\desktop键值。

3 使用鼠标右击，选“新建/字符串值”，且命名为MenushowDelay。

4 在的对话框中把它的值改为50，或者100。
5 然后重新启动，一点“开始”菜单你就会有全新的感觉。


22f

Windows 98默认值对四速及其以上速度的光驱都是用1238KB内存作为缓存，对现在的32X、40X及其他高速的光驱来说就显得捉襟见肘了。更何况我们现在已是32MB、64MB的内存，更不怕把缓存加大从而提高光驱的读盘效率了。要知道现在一些先进一点的操作系统如Linux，都会自动把剩余内存作为磁盘的缓存了。

下面为修改步骤：

1 启动注册表编辑器。

2 请打开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem

\CDFS键值

3 串值CacheSize是缓存的大小。在更改时，建议选十进制，24X建议为1536K，32X为2048K。

Prefetch是预读文件的大小，24X建议为512K，32X为768K
4 重启计算机


22g

用过Linux的朋友对它的后台写盘印象很深吧，它会把写盘操作记住，在系统空闲的时候再写盘。

其实，在Windows 98里面一样可以做到。下面为修改方法：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\fdc键值，下面的0000键值指第一软驱，0001指第二软驱。

3 在要修改软驱的键值下新建一个DWORD值，改名为ForeFifo，值为0。

4 关闭注册表编辑器。

5 重启计算机。


22h

根据注册表清理动态链接库DLL。

清理方法如下：

1 在“开始/运行”中键入Regedit.exe。

2 在注册表中打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\SharedDLLs子键分支
在此子键的右窗格内有.DLL文件信息。如果键值为01 00 00 00，则说明共享，如为00 00 00 00，则删去主键。如果用户觉得太麻烦，不妨下载一个Clean System Directory的共享软件，它会帮你找到无用的DLL文件


22i

如何清理“开始”菜单中的“收藏夹”命令？

如果你没有上网，那么“开始”菜单里的“收藏夹”命令对你毫无用处，下面告诉你如何将其去掉。

1 启动注册表编辑器。

2 进入HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\Explorer子键分支。

3 新建一项命名为NoFavoritesMenu的键值，并将其键值改为1，这样就大功告成了，如图6-41所示。

4 关闭注册表编辑器。


22j

如何清理“开始”菜单中的“撤消”命令？

你真的需要“撤消”命令吗？若你在家用机上联网，那它并非必要，可以将其去掉。

1 启动注册表编辑器。

2 进入下列关键字：HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Policies\Explorer。

3 新建一项命名为NoLogOff，将值设置为01000000


22k

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom

在右边的窗口中，把DWORD值“Autorun”改为“0”。“1”表示自动运行。


22l

藏陋网，解决电脑故障！ http://www.canglou.com/

WIND9X系统只提供到最大为 8X CDROM的CACHE设置，在 HKEY_LOCAL_MACHINE\System\Current

ControlSet\Control\FileSystem\CDFS中有两个DWORD值"CacheSize"与"Prefetch"若系统设置里为"4倍速或更高倍速"则这两个值为"0000026b"和"000000e4"。"CacheSize"的可认值有："0000026b"、"000004d6"、"000009ac""Prefectch"的值有：4X 000000e4 8X 000001c0 16X 00000380 24X 00000540 32X 00000700 这两项的值视你机子的配置更改。


22m

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\FS Templates 下有三个主键Desktop、Mobile、Server，分别对应于台式机、便携式、网络服务器三个设置项。对台式机进行设置，更改Desktop主键下的"NameCache"值为"80 00 00 00"（提供128个缓冲文件夹），"PathCache"值为"00 10 00 00"（提供4096个8.3格式的文件名，约占用48KB常规内存）。


22n

藏陋网，解决电脑故障！ http://www.canglou.com/

打开 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs 主键下，可以删除值为"00 00 00 00"的文件（该值为系统中调用该库的应用程序个数，00为没有应用程序调用，所以可删除）。


22o

藏陋网，解决电脑故障！ http://www.canglou.com/

更改 HKEY_CURRENT_CONFIG\Display\Settings 下的"ReFreshRate"的值，若要改成85HZ的就改成"85"，小心点不能乱来哟，要考虑到你的显示器是否受得了。


22p

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_CLASSES_ROOT\CLSID中查找关键字"控制面板"，找到时记下相应的主键值 （本人系统内的键值为{21EC2020-3AEA-1069-A2DD-08002B30309D}）然后在C:\WINDOWS\STARMENU中建立名为"控制面板 {21EC2020-3AEA-1069-A2DD-08002B30309D}"的文件夹即可。


22q

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_CLASSES_ROOT\* 下单击 * 新建主键并命名为"shell"，用右键单击"shell"再新建一主键输入自已喜欢的名字，这里以打开方式为例，再用右键单击"打开方式"新建一主键名为"command"编辑"默认"输入"rundll32.exe shell32.dll,OpenAs_RunDLL %1"，以后有BMP文件时，点击图标用鼠标右键，则在弹出的菜单中会多出一个我们刚建成的"打开方式"，点击它你就会发现用处了。


22r

藏陋网，解决电脑故障！ http://www.canglou.com/

立即刷新模式（免去手动F5 刷新）在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update中将"UpdateMode"改键值为"00"。


22s

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall 中删去相应的主键即可。


22t

藏陋网，解决电脑故障！ http://www.canglou.com/

删除HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Desktop\NameSpace 中对应的分支主键。


22u

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion 选"Version"项，修改键值为所需即可。


22v

 当程序中的菜单过多时，往往一页显示不出来，这时使用下面的功能实现菜单多页面显示
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Advanced下
在右边的窗口中新建字符串值“StartMenuScrollPrograms”，并设值为“false”。
要取消这项功能，只需删除该字符串。


22w

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MinAnimate”，数据为“0”表示不显示过程，“1”表示显示。


22x

在“我的电脑”中显示“计划任务”

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\MyComputer\NameSpace
在该分支下创建一个主键“{D6277990-4C6A-11CF-8D87-00AA0060F5BF}”，在右边的窗口中创建字符串“默认”，设值为“Scheduled Tasks”。

在“我的电脑”中显示“拨号网络”

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\MyComputer\NameSpace
在此分支下新建一个主键“{992CFFA0-F557-101A-88EC-00DD010CCC48}”，单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为"拨号网络"。

在我的电脑中显示“打印机”

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\MyComputer\NameSpace
在此分支下新建一个主键“{2227A280-3AEA-1069-A2DE-08002B30309D}”，单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为“打印机”。


22y

改变“字体”的目录
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Fonts"的数值为新的目录路径, 如 C:\tt，
记住要把原目录里的文件复制到新的目录。

改变“发送到”的目录

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"SendTo"的数值为新的目录路径, 如 C:\tt，
记住要把原目录里的文件复制到新的目录。

改变“通用文件夹”目录

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
在右边的窗口中修改字符串"CommonFilesDir"为新的目录路径,如 C:\tt，
记住要把原目录里的文件复制到新的目录。

改变“启动”的目录

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Startup"的数值为新的目录路径, 缺省值为C:\WIN98\Start Menu\Programs\启动
记住要把原目录里的文件复制到新的目录。

更改“网页的历史记录”目录

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"History"的数值为新的目录路径, 如 C:\tt
记住要把原目录里的文件复制到新的目录。

更改"我的文档"目录

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Personal"的数值为新的目录路径, 如 C:\tt
记住要把原目录里的文件复制到新的目录。


22z

在我们运行程序的时候，有时会遇到软件程序没反映的现象，于是我们按CTRL+ALT+DEL来关闭系统，
而当我们按下后，系统会叫我们退出前要使软件程序退出，使用本功能可允许强制关闭系统。
在HKEY_USERS\.DEFAULT\Control Panel\desktop下，在右边的窗口中创建一个字符串值：
“AutoEndTasks”，并将其值设为“1”。


22aa

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
在右边的窗口中创建一个DWORD值：“ConfigFileAllocSize”，并设为“1f4”。


22ab

以下有几项方法可以改变上网速度：
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
在右边的窗口中把“DefaultRcvWindow”的值改为“6400”，把“DefaultTTL”改为“128”。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans
在右边窗口中创建字符串值“MaxMTU”,“MaxMSS”，并设“MaxMTU”为“576”，设“MaxMSS”为“536”。


22ac

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_USERS\.DEFAULT\Control Panel\desktop
把二进制值“UserPreferencemask”改为“AF 00 00 00”。


22ad

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders下 ,找到字符串值“Favorites”,并设其值为你想要的下载路径,如C:\WINDOWS\Favorite。
在此窗口中可更改桌面的路径、Cookies的路径、启动的路径、历史记录的路径。


22ae

藏陋网，解决电脑故障！ http://www.canglou.com/

依次展开 HKEY_CURRENT_USER\Keyboard layout\Preload ，在其下可以见到键名从数字 1 开始依次递增的多个子键名称，具体子键个数与系统已安装的输入法种数相一一对应。现假如要将子键名为“ 2 ”所对应的输入法与子键名为“ 5 ”所对应的输入法互换，即将子键名“ 5 ”所对应的输入法前移至第二位，方法如下：右击子键“ 2 ”选“重命名”将子键“ 2 ”改名为“ 22 ”或其它不存在之名称，接着将子键“ 5 ”重命名为“ 2 ”，最后将子键“ 22 ”改名为“ 5 ”。您可以将所有输入法按自已的需要重新排序。


22af

有时电脑关机后，电脑却长时停留在“您现在可以安全的关闭计算机了”的关机画面上，电脑不能实行自动关机，怎么办？通过修改注册表可使这一问题得到解决。方法是：

打开HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon，双击右边窗口中的"powerdownAfterShutdown"，将数值数据改为1即可。

2、电脑关机又重新开机的修改

许多朋友遇过电脑关了又重新开机的情况，我也遇过一次，其实解决这一问题很简单，只要通过修改注册表就能得到解决。方法是：

打开HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\control\Shutdown子项，在右边窗口中新建一个“字符串值”，命为“FastReboot",同时将“数值数据”设为0即可。


22ag

藏陋网，解决电脑故障！ http://www.canglou.com/

方法一：打开控制面板\系统\性能\文件系统，将“本机主要用于”下拉列表框改为“网络服务器”，打开“应用”，重新启动计算机。

方法二：打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\FS Templates\Server子键，将Namecache和PathCache的二进制值改为a9 0a 00 00和40 00 00 00，退出注册表并重新启动计算机。


网络设置

藏陋网，解决电脑故障！ http://www.canglou.com/

win98/me网络设置的修改... ...


234

使用过IE浏览器的朋友都知道，在进入IE时，在地址一栏后面有一个下拉列表（如图5-17所示），保留有所有访问过的站点URL记录，我们可以随时在下拉列表中点取某一网址，很方便。是否可以清除下拉列表中的几项URL记录呢?

答案是肯定的，其修改方法如下：

1 启动注册表编辑器。

注意：在修改注册表前，最好将原注册表备份一份：在“文件”菜单中选取“导出注册表”，键入一个文件名，然后单击“保存”按钮，则在你的硬盘上会生成一个后缀名为“REG”的文件。如果注册表出现问题，可以将注册表文件导入。

2 备份完后，在注册表中依次单击HKEY_CURRENT_USER\Software\Microsoft \Internet Explorer\TypedURLs子键分支

3 此时，在右边窗口将出现：

url1 “http://www.canglou.com"

url2 “http://www.cctv.com"

url3 “http://www.sohu.com"

……

4 单击欲删除的URL地址，按DEL键，然后选确认，重新进入IE，删除过的URL记录已经不在列表中了。


235

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在 HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\UrlTemplate 下新建字符串值如，名字只要是数字即可，串值如，想让IE默认的后缀名为".edu.cn"则设串值为"www.%s.com.cn"。


236

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows \CurrentVersion\Explorer\User ShellFolders下
更改“Cache”的路径即可。


237

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer下
在右边的窗口中新建DWORD值“Download Directory”,并设其值为你想要的下载路径,如C:\My Documents。


238

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

我们在使用IE上网时输入的网址，会在注册表里面留下一些记录，记录着你输入过那些网址，当你下次再输入该网址时，只需输入几个字母，IE就会自动的输入完整的网址，大大方便了我们，在以下的方法中，我们可以手动的在WINDOWS的注册表中增加一些网址URL，使上网时更方便。
依次展开在HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs下
在右边的窗口中按url1、url2、url3......顺序排列着一些URL,修改，增加，删除这些url的值
即可达到修改，增加，删除URL的功能。


239

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

修改hkey_users\.default(可改为特定的用户名)\software\macrosoft\

windows\currenversion\internet settings\zones\3\1803下的0x00000000(0) 改为0x00000003(3)


2310

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在[HKEY_current_user\software\microsoft\

windows\currentversion\policies\explorer]下新建\"NoRun\"=dword:00000001即可禁止ie访问硬盘资源。
同时屏蔽开始菜单的“运行”项。


2311

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

代理服务器的用途很大，比如可以使原来只能国内站点的电脑，在使用代理服务器后，能访问国外站点，
但代理服务器的使用也会带来不利的地方，因此，我们可以通过注册表来禁止使用代理服务器,
在HKEY_LOCAL_MACHINE\Config\0001\Software\Microsoft\windows\CurrentVersion\Internet Settings下
在右边的窗口中新建二进制值“ProxyEnable”的键值为"00 00 00 00"。


2312

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer\Main下

在右边的窗口中修改字符串“Show_URLToolBar”的键值为"no"。


2313

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer\Main下

在右边的窗口中修改字符串“Show_StatusBar”的键值为"no"。


2314

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Microsoft\

Internet Explorer\Search”，在右侧窗口中把“CustomizeSearch”、“SearchAssistant”改为我们定义的搜索引擎，如http://www.canglou.com/，以后当我们每次点IE5.0的搜索引擎时，即可自动调出我们定义的搜索引擎，如上面设定的藏陋网。


2315

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs

在右边的窗口中删除想要删除的网址。


2316

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

先打开注册表编辑器，在 HKEY_LOCAL_MACHINE\System\CurrentControlSet \ServicesClass\NetTrans 这个目录下的几个目录（如000，001，002，003什么的是用于存储协议安装的情况），寻找主键 DriverDesc ，找到它的键值为"TCP/IP"的那个目录，修改该目录下的 IPAdress 和 IPMask 的两键。
例： 原 IPAdress 键值为 "210.34.50.16"
IPMask 键值为 "255.255.255.0"
则可以修改为：IPAdress 键值为 "210.34.50.16,210.34.50.253"
IPMask 键值为 "255.255.255.0,255.255.255.0"
表示你的机子同时拥有两个IP地址： 210.34.50.16 与 210.34.50.253
这种方法也可用于多个IP，只要在键值里多加一个逗号再加入下一个IP及网关IP就可以了。


2317

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

更改 Internet Explorer 的图标

在 HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon
下，在右边的窗口中修改字符串值(默认)为新图标的路径，如：C:\w.ico,0。

更改Internet Explorer的标题
在HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main下在右边的窗口中修改字符串值“Window Title”为新标题的名字。


2318

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边窗口中创建DWORD值“NoNetHood”，并设为“1”。


2319

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建DWORD值“NoNetSetup",并设其值为“1”。


2320

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

Windows\CurrentVersion\Policies\Network下
在右边的窗口中新建DWORD值“NoNetSetupIDPage”,并设其值为“1”。


2321

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Network下
在右边的窗口中新建DWORD值“NoEntireNetwork”,并设其值为“1”。


2322

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路径:[HKEY_CURRENT_USER\Software\Microsoft

\Windows\CurrentVersion\Policies\Networkr]

键值"NoPrintSharingControl"=dword:00000001

作用:禁止打印机共享

键值"NoFileSharingControl"=dword:00000001

作用:禁止文件共享


2323

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

在HEKY_CURRENT_USER/Network/Recent下
删除下面的主键。


2325

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

作 用:设置IE的自动拨号功能
路 径:HKEY_CURRENT_CONFIG\Software\Windows\CurrentVersion\Internet Settings
键值名称:"EnableAutoDial"
数据类型:二进制 键 值:值改为01 00 00 00


2326

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CURRENT_USER\ Software\Microsoft\Internet Explorer\Default HTML Editor\shell\edit
键值名称:command
键 值:将其值修改为DreamWeaver的绝对地址，并加上%1
备 注:如"c:\program files\macromedia\ dreamweaver 2\dreamweaver.exe %1"。


2327

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CURRENT_USER\Identities\{4C44D002-7BCF-11D3-9957-AB53DA238B0C}\Software\Microsoft\Outlook Express\5.0
键值名称:新建"windowTitle"
数据类型:字符串
键 值:输入你想要的名称，如"XX的信箱"


2328

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar
键值名称:新建BackBitmap
数据类型:字符串
键 值:"BMP文件路径"


2328

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CURRENT_USER\Software\Microsoft\Outlook Express
键值名称:NoSplash
数据类型:DWORD
键 值:1


2330

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer
键值名称:Version
数据类型:字符串
键 值:表示ＩＥ的版本号，改小一点儿就行了


2331

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main
键值名称:新建"window Title"
数据类型:字符串
键 值:串值内容改为你想要的文字


2332

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CLASSES_ROOT\CLSID\{992CFFA0-F557-101A-88EC-00DD010CCC48
键值名称:"默认"
数据类型:
键 值:值更改为需要的键值


2333

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\MyComputer\NameSpace]
键值名称:{992CFFA0-F557-101A-88EC-00DD010CCC48}
数据类型:
键 值:删除


2334

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\RealModeNet
键值名称:Autologon
数据类型:Dword
键 值:数值改为 "01 00 00 00 00"


2335

欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/

路 径:HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\main
键值名称:Ancher Underline
数据类型:
键 值:值改为no


2336

藏陋网，解决电脑故障！ http://www.canglou.com/
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！ http://www.canglou.com/bbs/


24

藏陋网，解决电脑故障！ http://www.canglou.com/

修改win98/me的各个部分... ...


24

修改Windows 98桌面上“回收站”的名字及图标。

修改步骤如下：

1 启动注册表编辑器。

2 单击“编辑”菜单中的“查找”命令，弹出“查找”对话框

3 复选“查看”框下面的“数据”选项（即让“数据”前面的白框有个钩“√”）。

4 在“查找目标”框内键入“回收站”。

5 单击“查找下一个”按钮，或者按回车键，系统将在注册表中查找“回收站”字符串，
6 双击“回收站”左边的“@默认”键值，然后在弹出的对话框中输入想要修改的名字，如“垃圾筒”
在重启系统后，桌面上的“回收站”将变成“垃圾筒”了

7 按下Tab键，光标移到左窗格中，此时光标将放在HKEY_CLASSES_ROOT \CLSID\{645FF040-5081-101B-9F08-00AA002F954E}分支上。

8 单击{645FF040-5081-101B-9F08-00AA002F954E}前面的“+”，展开此主键，我们发现在其下面还有一个子键DefaultIcon，然后单击此子键，在右窗格中的“数据”栏下将出现3个图标文件名，分别为“@默认”、“Empty”（空）、“Full”（满）的回收站图标
9 这3个图标包含在动态链接库Shell32.dll文件里面，分别是序号31，31，32的图标资源，其数据表现形式为“C:\Windows\System\Shel32.dll,31”等。如果你想把它改成自己的图标，只要将此数据改为自己图标的路径及文件名即可，如“C:\Windows \help.ico”，

如果想调用某些动态链接库中的图标资源，只需在其后加上“,”和其序号。

注意：你必须重新启动 Windows 98，修改后的图标才发生作用。

另外，Windows 98桌面上有的图标是可以直接修改的，因而在注册表中没有记载。例如某快捷方式，我们可以这样修改它的图标：

1 右键单击此图标，则弹出一个快捷菜单。

2 在该快捷菜单中选择“属性”选项，弹出该快捷方式的属性对话框，如图3-7所示。

3 在“快捷方式”选项卡中单击“更改图标”按钮，弹出对话框。
我们在该对话框中发现文本框是包含图标的文件名，在下面的框内列出该文件名所包含的图标。单击“浏览”按钮，可以从“更改图标”对话框中选出想要的文件名
使用上面的方法，还可以查看动态链接库的图标资源。对话框中列出了Shell32.dll库文件中的所有图标资源


242

在编辑以.DOC为扩展名的文档时，若想用写字板打开，而又不想去找这个程序，就可以使用快捷菜单来解决这个问题。

为了解决此问题，需要修改注册表，其修改步骤如下：

1 启动注册表编辑器。

2 在“查找”对话框的“查找目标”框内输入“.DOC”，在“查看”框内复选“主键”，然后按回车键，系统开始在注册表中查找“.DOC”字符串。在找到后，我们发现该主键的“@默认”的键值数据是“word.DocuEment.8”
3 使用同样的方法，在注册表中查找“word.docuement.8”。要注意的是，所找到的主键必须与“.DOC”是兄弟关系，因此第一个发现的不是要找的，按F3键查找下一个匹配的主键
4 在找到后，右键单击其子键shell，依次选“新建”、“主键”，然后将此新建的主键重新命名为你想在快捷菜单中出现的名称，如“用写字板打开”
5 右键单击“用写字板打开”，依次选择“新建”、“主键”，然后将新建的主键命名为“command”，再将“command”主键的“@默认”数据设为“c:\windows\write.exe %1”（其中write.exe是写字板的执行程序，%1为.DOC文件名参数）
此时，在Windows资源管理器中右击扩展名为.DOC的文件，在其快捷菜单中已经增加了一项“用写字板打开”

选定它后，此文件就被写字板打开了。不过用Word编辑的文档，被写字板打开后可能会发现是一堆乱码，这是因为写字板无法辨识Word中某些特殊控制格式。

在知道了在快捷菜单中增加选项的操作方法后，我们只要单击鼠标右键就可以实现很多操作。我们曾为一个电脑初学者做了一个快捷菜单，只要右键单击“我的电脑”，在快捷菜单中就会显示他想玩的各种游戏及软件，他只需选定其中的选项就可以了，其制作方法如下：

1 启动注册表编辑器。
2 在“查找”对话框中复选“数据”，在“查找目标”框内输入“我的电脑”，然后按回车键，系统将在注册表中查找“我的电脑”这个字符串。找到后，光标将放在“我的电脑”这个键值数据对应的主键上
3 单击此主键，则展开此主键。在此主键的Shell子键下面建立“游戏1”、“游戏2”、……“Word97”等子键，然后在它们下面分别建立“command”子键，并将要运行的程序名称写入其键值数据中


243

当遇到这种情况时，可执行如下操作步骤：

1 首先要把屏幕上所提示的找不到的设备文件或者系统文件记录下来。

2 打开System.ini文件，在此文件中查找是否有这样的文件存在。如果有，请将有关行删除或者屏蔽掉。如果没有，则在注册表中查找这样的文件，一般都能找到，然后将有关数据及键值删除，再重新启动就会发现问题已解决了。

注意：在对注册表和系统文件进行操作时，一定要备份，以防不测。

另外，在卸载软件不干净、而在“添加/删除程序”里残留一些时，也可使用此方法，其操作方法如下：

1 启动注册表编辑器。

2 在注册表中查找“Uninstall”主键。

3 找到后，展开它，里面的主键对应着“添加/删除程序”里的内容，将不需要的主键删除就是了。


244

如果在中文Windows 98系统中安装了“Microsoft Plus!”软件，则会发现有的修改无效了，其原因是“Microsoft Plus!”软件重新改写了注册表里的有关值。

查找“Microsoft Plus!”软件在注册表中的修改值。

为了查找这些值，请执行如下操作步骤：

1 启动注册表编辑器。

2 打开HKEY_CURREENT_USER\Software\Classes\CLSID分支。在此分支下面有几个类似{87CA6F04-49E4-11CF-A3FE-00AA003735BE}的长串数字，任意展开一个，就会发现其下级主键DefaultIcon。

3 使用鼠标左键单击DefaultIcon，在右窗格内将显示出当前显示的图标。你可以修改此图标。


245

我们曾经遇到这样的现象：在安装完Windows 98中文版以后，操作系统工作正常，运转良好，但在运行某些程序时，程序窗口或字体选择框却会出现汉字乱码，有的甚至完全不能显示汉字。

首先，我们打开注册表编辑器，按HKEY_LOCAL_MACHINE\System\Current ControlSet\Control\fontassoc分支展开后，会发现不是缺少了“Associated DefaultFonts”和“Associated CharSet”两个子键，就是虽有这两个子键，但“Associated DefaultFonts”子键下只有“默认”和“AssocSystemFont”等两个键值数据，“Associated CharSet”子键下只有“默认”一个键值数据，其他应有的内容则不翼而飞。这就是造成乱码的根本原因。下面介绍一种用手工进行修复的方法：

(1) 启动注册表编辑器。

(2) 按照HKEY_LOCAL _MACHINE\System\CurrentControlSet\Control\fontassoc分支展开，看其下面是否有“Associated CharSet”和“Associated DefaultFont” 等两个子键

(3) 如果有，则单击“Associated CharSet”子键，然后在右窗格中增加下列键值数据内容：

ANSI（00）＝“yes”

GB2312（86）＝“yes”

OEM（FF）＝“yes”

SYMBOL（02）＝“on”

按上述方法，单击“Associated DefaultFonts”子键，然后在右窗格中增加下列键值数据内容：

AssocSystemFont＝“sim sun.ttf”

FontPackageDecorative＝“宋体”

FontPackageDontCare＝“宋体”

FontPackageModern＝“宋体”

FontPackageRoman＝“宋体”

FontPackageScript＝“宋体”

FontPackageSwiss＝“宋体”

(4) 如果没有“Associated CharSet”和“Associated DefaultFonts”两个子键，则可先通过下述步骤来增加这两个子键：

1 单击“Fontassoc”子键，在“编辑”菜单的“新建”菜单下单击“主键”，在所出现的对话框中分别键入以上两个子键名称。

2 按上述第3步为其增加相应键值数据内容。

(5) 关闭系统，重新启动计算机。

另外，使用下面的方法可以更方便地恢复注册表中的子键或者键值数据：

(1) 用文本编辑器创建一个文本,如HANZI.REG，其内容如下:

REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\fontassoc]

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\fontassoc\AssociatedDefaultFonts]"AssocSystemFont"="simsun.ttf"

"FontPackageDontCare"="宋体"

"FontPackageRoman"="宋体"

"FontPackageSwiss"="宋体"

"FontPackageModern"="宋体"

"FontPackageScript"="宋体"

"FontPackageDecorative"="宋体"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\fontassoc\AssociatedCharSet]"GB2312(86)"="yes"

"ANSI(00)"="yes"

"OEM(FF)"="yes"

"SYMBOL(02)"="no"

(2) 启动注册表编辑器。

(3) 在“注册表”菜单中选取“导入注册表文件”,然后在所出现的对话框的文件列表框中选取hanzi.REG，单击“打开”按钮。

(4) 关闭注册表编辑器。

(5) 关闭Windows 98系统,重新启动即可。


246

当我们在Word文档的顶部或底部插入日期时，通常的格式是：MM/DD/YY。其实，你可以通过修改注册表的方式改变日期的显示模式，比如可以将07/13/98改成：July13,1998。

下面就是实现的方法：

1 打开记事本，然后输入下面的代码：

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\Options]

“DateFormat”=“MMMMD,yyyy”

2 将此文件取名为dodate.reg，可以放于任何一个目录下。

3 在“Windows资源管理器”中找到该文件，用鼠标左键双击该文件，系统应当会显示该文件已成功输入注册表的提示信息。

4 下次在Word中插入日期时，一定就是你所希望的格式了。


启动不备份注册表

不让注册表检查器在启动时检查和备份Windows 98系统设置。

设置步骤如下：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\CurrentVersion\Run子键分支，
③ 在右边会看到“ScanRegistry”，它的值是“C:\WINDOWS\scanregw.exe /autorun”，把它删除。如果你只是不想备份，而又想它在启动时检查注册表，请用记事本打开Windows 98目录下的SCANREG.INI，找到Backup=1 这一行，改为Backup=0 就行了


147

藏陋网，解决电脑故障！ http://www.canglou.com/


2413

尽管我们可以通过控制面板中的“键盘”设置项来调整光标闪烁的速度，但我们却无法利用它来彻底禁止光标的闪烁。

为此，我们可执行如下步骤：

1 启动注册表编辑器。

2 在注册表编辑器中依次展开HKEY_CURRENT_USER\Control Panel\desktop子键。

3 在desktop子键分支中新建一个名为“CursorBlinkRate”的“字符串”，并将其值设置为“－1”，


2414

Window 98是如何实现AutoRun功能的呢？能否使用注册表注销此功能呢?

原来，Windows 98的文件系统核心部分有一个叫“卷跟踪”的虚拟设备驱动程序（VxD），它负责监视软盘、CD-ROM等可移动介质是否会改变。如果这些介质上的文件在被打开以后还没有关闭就取走这些介质，卷跟踪程序就会检测到这一点，立即向用户发出警告（显示器变“蓝脸”），要求用户插入原盘。当用户将光盘放入CD-ROM驱动器时，“卷跟踪” 虚拟设备驱动程序就会自动检测光盘的类型，如果是CD盘，系统就会自动调出CD Player来播放CD；如系统检测到光盘具有PC文件系统，系统就会继续检测光盘上是否具有AutoRun.inf文件，该文件指定了AutoPlay运行的程序。通过在autorun.inf中指定文件，你可以运行光盘上的任何应用程序，当然最典型的应用程序还是应用软件的启动和安装功能。

所有的Inf文件的内容都是ASCII文本，用来为Setup程序提供安装信息，在C:\Windows\System 子目录下就有很多inf文件。Inf文件像INI文件一样分成许多节，且内容也很多。但是AutoRun.inf文件则比较简单，只有[autorun]一节，在这一节中最基本的命令就是open，用它来指示Windows 98系统自动运行哪个程序，例如：

[AUTORUN]

open=setup.exe

这时，Windows 98在插入光盘时就会自动执行Setup.exe这个应用程序，Open命令指出自动运行的程序的路径和文件名。另外一个常用的命令就是icon，为光盘指定一个图标的文件名，格式为：icon=文件名，其中文件名可以指定一个图标、一个位图、一个可执行文件甚至一个动态链接库，如果指定的文件中包含不止一个图标资源，可以在文件名中加一个数字（即索引值，从“0”开始）表示第几个图标，文件名和数字之间用“，”分开。一旦为光盘指定图标后，在“资源管理器”和“我的电脑”中，光盘的图标都将变成你指定的这个图标。例如：icon=pname.exe，3，即使用pname.exe 文件中的第4个图标作为光盘驱动器的图标。

如果在光盘上的根目录下有autorun.inf文件，Windows 98还会在光盘图标的右键快捷菜单中添加一个AutoPlay缺省选项。如果使用的是Windows 98的中文版，在弹出的快捷菜单中显示则是“自动播放”选项，这样即使在“自动插入通告”设置被关闭的情况下，只要光驱中放有带autorun.inf文件的光盘，双击光驱图标就能执行open命令指定的应用程序。

除了open和icon命令之外，在autorun.inf文件中还可以使用shell命令，用来向光盘图标的弹出菜单中添加更多的自定义菜单项。下面的两行语句为快捷菜单中添加了Demo选项，并且为菜单项设置快捷键“D”：

shell\verb\command=pname.exe

shell\verb=＆Demo

其中，第一行定义了verb的动作，第二行指明了执行动作的菜单选项，这个动词“verb”可由光盘生产者自己指定，但一定要保证前后定义的一致性和命令的完整性。在一般情况下，自动播放（AutoPlay）是弹出菜单的缺省选项，你也可以用shell命令将AutoPlay命令更改为特殊的命令。

其实，自动运行（Autoplay）不仅可以在光盘上实现。也可以在软盘、硬盘甚至虚拟盘和网络驱动器上实现。但是这得修改Windows 98注册表的有关信息才能实现，其修改方法如下：

1 运行注册表编辑器。

2 打开HKEY_CURRENT_USER\SoftWare\Microsoft\Windows\CurrentVerson\Picilies \Explorer子键分支。

3 右窗格内的NoDriveTypeAutoRun是一个四个二进制数据组成的键值，其中第一个字节表示哪些驱动器的自动播放（Autoplay）有效，表6-1就是这一字节的8位二进制数的具体含义。

注意：二进制数为0时有效，为1 时无效。

表6-1 NoDriveTypeAutoRun字节各位含义

位 | 位屏蔽常数 | 含 义
0（低位） | DRIVE_UNKNOWN | 不识别的驱动器类型
1 | DRIVE_NO_ROOT_DIR | 根目录不存在
2 | DRIVE_REMOVEABLE | 软盘
3 | DRIVE_FIXED | 硬盘
4 | DRIVE_REMOTE | 网络驱动器
5 | DRIVE_CDROM | CD-ROM
6 | DRIVE_RAMDISK | 虚拟盘
7（高位） | 保留

所以，你只要修改其中的某一位，就能使对应的驱动器AutoPlay有效。如果你想使软盘的AutoPlay有效，请按下面的步骤进行：

1 启动注册表编辑器。

2 使用“编辑”菜单中的“查找”命令，在“查找目标”对话框中输入“NoDrive TypeAutoRun”，单击“查找下一个”。

3 在找到的“NoDriveTypeAutoRun”上双击，将其值由00 00 95 00 00 00 （系统的缺省二进制值）更改为00 00 91 00 00 00 ，在确定以后退出注册表编辑器，重新启动计算机使更改生效。

在你的软盘根目录下存放一个Autorun.inf文件，将open和icon命令各指向一个存在的文件，双击“我的电脑”或“资源管理器”中的软盘驱动器图标，看一看效果如何。

由表6-1不难看出，系统的缺省设置是光驱、硬盘虚拟盘的自动播放有效，所以你想要屏蔽所有的驱动器的自动播放功能，只要将“NoDriveTypeAutoRun”的值改为0000 FF 00 00 00 即可。

AutoPlay的确给我们带来了许多方便，我们可以利用它的这一特性使我们的硬盘、软盘、虚拟盘及网络盘在“资源管理器”和“我的电脑”中有不同的表现，最大限度地方便我们的使用。


2215

由于误操作或者系统错误，导致了桌面上的“网上邻居”图标不见了，这样就使用户无法上网。

下面介绍恢复“网上邻居”图标的操作步骤：

1 启动注册表编辑器。

2 打开HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion

\Policies\Explorer分支

3 选中右窗格中“NoNetHood”的键值名，将其删除。

4 重启机器即可。


2216

下面为修改步骤。

1 启动注册表编辑器。

2 在注册表中进入如下子键分支：

HKEY_LOCAL_MACHINE\Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}

或者

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}。

如图8-1所示。

3 修改Default Icon下的“默认”键值（原为“explorer.exe,0”，使用Windows资源管理器中的第一个图标），如修改为“C:\Windows\mycomputer.ico,0”，即可改变桌面上“我的电脑”的图标


2217

在缺省情况下，单击“我的电脑”图标将打开“我的电脑”窗口。但是，我们可以通过修改注册表来更改此打开方式

下面为修改步骤。

1 启动注册表编辑器。

2 进入HKEY_LOCAL_MACHINE\Software\Classes\CLSID\{20D04FE0-3AEA-

1069-A2D8-08002B30309D}子键分支中。

3 在Shell子键下新建一个主键Open，再在Open下建立一个主键Command
4 在右窗格内双击“默认”，则在如图8-4所示的对话框中修改“默认”键值为“Explorer.exe”，则就可用“Windows资源管理器”来打开“我的电脑”了
若将“默认”键值修改为“WinFile.exe”，则可用“文件管理器”打开“我的电脑”。如果你想用其他程序来打开“我的电脑”，只需在该主键的“默认”键值上进行修改即可，如将默认键值改为“D:\Wintools\ACDSee32\ ACDSee32.exe”，那么，当你双击桌面上“我的电脑”的图标时，就会启用ACDSee32来打开“我的电脑”了。


2218

其删除步骤如下：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion

\explorer\Desktop\NameSpace子键分支
3 将该子键分支下面的主键“{645FF040-5081-101B-9F08-00AA002F954E}”删除掉，则可从桌面上删去“回收站”图标


2219

你可以扩展此快捷菜单中的选项，如在此菜单添加“删除”、“重命名”等选项。通过修改注册表可以达到此目的。

下面为修改步骤。

1 启动注册表编辑器。

2 打开HKEY_CLASSES_ROOT \CLSID \ {645FF040-5081- 101B-9F08-00AA002F954E} \ShellFolder子键分支

3 在右窗格双击“Attributes”，然后在如图8-22所示的对话框中，将其数据由“40 01 00 20”改为“70 01 00 20”。

4 退出注册表编辑器。

5 在桌面上右击“回收站”，则在如图8-23所示的快捷菜单中添加了“删除”、“重命名”及其他选项。

你可以将一些命令添加到“回收站”菜单中。

下面为添加方法。

1 启动注册表编辑器。

2 打开HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}

\Shell子键分支，。

如果没有发现Shell主键，就增加一个。

3 在Shell下面增加一个新主键， 名称为要在快捷菜单中出现内容，如“DOS方式”。

4 在此新主键下增加一个Command 主键
5 设置Command 主键的“默认”键值内容为要启动的命令或可执行文件名，如C:\Command.com或者C:\Windows\Command.com

6 关闭注册表。

7 马上在“回收站”图标上按鼠标右键，就会发现多了一项“DOS方式”菜单，如图8-27所示。单击此菜单项，则可以进入到DOS方式窗口中


2220

你可以让“开始”菜单具有一定程度的敏捷性，这样就可以立即得到放在各种各样特殊文件夹中的关键性项目，而不必每次都打开一个窗口。为了达到此目的，可以用特殊的文件夹名称在“开始”菜单上创建快捷方式。

下面是特殊文件夹名称的列表，请将其精确而完整地复制，包括连字符。请注意，在每个文件夹名的后面、大括号的前面有一个英文句号。

Dun.{992CFFA0-F557-101A-88EC-00DD010CCC48}

Briefcase.{85BBD920-42A0-1069-A2E4-08002B30309D}

Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}

Desktop.{00021400-0000-0000-C000-000000000046}

Dial-Up Networking.{992CFFA0-F557-101A-88EC-00DD010CCC48}

Fonts.{BD84B380-8CA2-1069-AB1D-08000948F534}

My Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}

Network Neighborhood.{208D2C60-3AEA-1069-A2D7-08002B30309D}

Printers.{2227A280-3AEA-1069-A2DE-08002B30309D}

Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}

你可在注册表的HKEY_CLASSES_ROOT\CLSID子键下面查出特殊文件夹的类标识符（CLSID）， 各机器的值可能会有所不同，应以查到的结果为准。

注意：当为每个特殊文件夹创建快捷方式并按回车键之后，大括号中的部分就从屏幕上消失了，这是正常的。

如果我们把控制面板中的各个组件直接加到“运行”菜单中，使用起来就会方便得多，其操作方法是：

1 启动Windows资源管理器。

2 在C:\Windows\Start Menu下建立一个名为 “Control Panel.{21EC2020-3AEA-1069 -A2DD-08002B30309d}”的文件夹

注意：你也可将“Control Panel”改为“控制面板”。

这样在“开始”菜单中就多出了一个叫“Control Panel”（或者“控制面板”）的子菜单，下面有控制面板的各个组件

用同样的技巧，你可以把全部的拨号连接放到“开始”菜单中，操作同上，只要把文件夹命名为：

Dun.{992CFFA0-F557-101A-88EC-00DD010CCC48}

若想把打印机加到“开始”菜单中吗?把文件夹命名为：

Printers.{2227A280-3AEA-1069-A2DE-08002B30309D}


2221

关闭机器是日常使用频率最高的操作之一，你通过右击“开始”菜单简化关机过程。

设置方法如下：

1 启动注册表编辑器。

2 打开HKEY_CLASSES_ROOT\Directory\shell子键分支。

3 选择“编辑/新建主键”，将其新建主键后命名为“Close”。

4 双击“Close”子键窗口右面的“默认”处，并在“键值”栏内输入“关闭计算机”，它就是在右键快捷菜单中出现的提示信息，如省略此项将在右键菜单中显示主键名称“Close”， 用&隔开可定义快捷键，如&Close

5 在“Close”主键下建立下一级子键“Command”。

6 双击Command子键窗口右面的“默认”处，并在“键值”栏内输入“Rundll32.exe User.exe,ExitWindows”字符串
7 直接右击“开始”菜单选“关闭计算机”就可关闭你的机器


2222

对于使用在特殊场合的计算机，如果不希望普通用户启动“关闭系统”项而导致退出Windows 98，此时可以通过利用注册表编辑器来修改注册表数据的方法，来屏蔽“开始”菜单中的“关闭系统”项，从而可以有效地防止别人随意退出系统。

操作方法如下。

1 选择“开始/运行”，键入“regedit” 命令，打开注册表编辑器。

2 在“注册表编辑器”界面中，使用鼠标左键依次单击左边窗口的各主键HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer。

3 展开Explorer分支，然后使用鼠标右键单击右边窗口中的任意空白位置，接着在出现的快捷菜单中依次选择“新建/DWORD值”项，此时系统就会自动在Explorer分支中建立一个缺省的名称为“新值#1”的新DWORD值，随后将其改名为“NoClose”。

4 使用鼠标左键双击“NoClose”项，即可进入如图8-36所示的“编辑DWORD值”对话框，然后将“键值”栏中的数字由0改为1，接着单击“确定”按钮返回到“注册表编辑器”界面。

5 退出注册表编辑器。

在完成上述修改之后，不必重新启动计算机即可使注册表数据立即生效。虽然此时在“开始”菜单中仍然存在“关闭系统”项，但是执行该命令项之后却会出现提示信息。

当重新启动Windows 98之后，“关闭系统”项就会在“开始”菜单中消失。此时除了无法直接利用“开始”菜单中的“关闭系统”项来退出Windows 98之外，甚至连按下Ctrl+Alt+Del组合键也没有什么效果，使得普通用户无法直接退出系统，从而达到了有效地预防别人随意关闭Windows 98的目的。
如果需要正常退出Windows 98时，只需要按照上述步骤重新设置Noclose的值为0（或者删除该项），即可使用“关闭系统”项出现在“开始”菜单中发挥以往的作用


2223

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个二进制值：“NoStartBanner”，设值为“01 00 00 00”。


2225

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder下
修改右边的窗口中的二近制值"Attributes",设其值为"70 01 00 20"。


2224

我们单击C，D盘，然后点击鼠标右键，会弹出菜单,要把Browse wth ACDSee去掉，打开HKEY_CLASSES_ROOT\Drive\shell
我们可看到有主键Browse with ACDSee，把该主键删除，即可把菜单中的Browse with ACDSee去掉。

在gif类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\GIFFILE\SHELL中，可按上述
方法修改。在cda类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\CDAFILE\SHELL中，
可按上述方法修改。要找某种类型的菜单中，可在HKEY_CALSSES_ROOT\???FILE\SHELL，???代表所
要找的文件类型。


2226

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_CLASSES_ROOT\Directory\shell下创建一个主键“CommandPrompt”，在右边窗口中把
“默认”的值改为：“Command”（或你喜欢的字符，此字符将显示在右键菜单中）并在此主键
下创建一个主键“command”，在右边窗口中把“默认”的值改为“command.com /k cd "%1"。


2227

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY\SHELL下
新建主键"快速关闭电脑",在右边的窗口中"默认"为"快速关闭电脑"。

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY\SHELL\快速关闭电脑下,新建主键"COMMAND"，在右边的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWS"。


2228

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell下
新建主键“快速启动系统”，在右边的窗口中修改“默认”为“快速启动系统”

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY\SHELL\快速启动系统 下,新建主键"COMMAND"，在右边的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWSEXEC"。


2229

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\Shell Icons
下，在右边的窗口中新建字符串值"6",并设其值为新图标的路径。


2230

给回收站改名、改图标

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E} 在右边的窗口中找到字符串值：默认，把回收站改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon 在右边的窗口中修改图标的路径。

给我的电脑改名、改图标

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D} 在右边的窗口中找到字符串值：默认，把我的电脑改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon 在右边的窗口中修改图标的路径

给我的文档改名、改图标

在右边的窗口中找到字符串值：默认，把我的文档改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\DefaultIcon 在右边的窗口中修改图标的路径。

给“控制面板”改名、改图标

在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}下 在右边的窗口中修改字符串值“(默认)”为新的名称 改图标:在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon下 在右边的窗口中修改字符串值“(默认)”为新图标的路径。


2231

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_LOCAL_MACHINE\Software\CLASSES

\CLSID\{85BBD920-42A0-1069-A2E4-08002B30309D}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。


2232

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{D6277990-4C6A-11CF-8D87-

00AA0060F5BF}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。


2233

藏陋网，解决电脑故障！ http://www.canglou.com/

在 HKEY_CURRENT_USER\Control Panel\International 下新建字符串值 "sTimeFormat"="HH：MM：SS TT"，"s1159"="HI!"，"s2359"="Hello!"。则在 12：00前显示"HI！"，后显示"HELLO！"。


2234

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值即改变图标大小，缺省值为“32”。


2235

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon BPP”，并设其值为“16”。


2236

藏陋网，解决电脑故障！ http://www.canglou.com/

将IE浏览器右上角的图标换成自己的图标，步骤如下：首先制作一个32*32大小的BMP图片，并放置在C根目录下。接着进入注册表编辑器，找到"HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main"，里面有"SmallBitmap"，将它的内容改成"c:XXX.bmp"，再次启动IE后，你就会看见右上角的图标已经改变了。


2237

藏陋网，解决电脑故障！ http://www.canglou.com/

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets\Hearts下

在右边窗口中新建字符串"zb"，设其值为"42"。


2238

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\ CurrentVersion\explorer\Shell Icons

新建或修改字符串"29",设置其值为你的图标路径。


2239

藏陋网，解决电脑故障！ http://www.canglou.com/

HKEY_CLASSES_ROOT\Paint. Picture\DefaultIcon

在右边的窗口中，找到字符串“默认”，修改值为“%1”。


2240

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CLASSES_ROOT\*
键值名称:新建"shell"子键，在其下新建"wordpad"子键
键 值:双击该键右面窗口的 "默认"处并在"键值"栏内输入"写字板"，接着在"wordpad"子键下建立下一级子键"command",在"默认"的 "键值"栏内输入"c:\program files\accessories\wordpad.exe %1"


2241

藏陋网，解决电脑故障！ http://www.canglou.com/


2242

藏陋网，解决电脑故障！ http://www.canglou.com/


2243

藏陋网，解决电脑故障！ http://www.canglou.com/


3333331111111

藏陋网，解决电脑故障！ http://www.canglou.com/

基于NT内核的系统，安全更加重要，如果修改以达到更为安全的目的呢？


311

Windows 2000通过配置设置来维护注册表的完整性。

配置设置可以简单地认为是一组系统参数。Windows 2000工作站有两套配置设置：CurrentControlSet和LastKnownGood（简称为LKG），这就好比你有两个Config.sys文件。

CurrentControlSet是HKEY_LOCAL_MACHINE子树中SYSTEM配置元下的一个关键字，链接启动系统的配置设置

这些设置反映当前控制状态。

LastKnownGood是HKEY_LOCAL_MACHINE子树中SYSTEM配置元下Select关键字中的一个键值项，它反映了最后一次成功启动期间使用的配置设置。它起备份作用，用于当前配置不能启动系统时。当完成系统登录后才认为是成功启动的，这时创建了LastKnownGood配置。

在Windows 2000系统中，可以有两种途径使用LKG，一是自动转换，一是手工执行。在启动期间，任何服务器遇到问题时，它将自动地告诉系统转换用LKG系统参数。如果在启动菜单中选择“Microsoft Windows 2000 Professional”后快速地按空格键，将出现一个新的菜单，此时可以从这个菜单中选择一种启动数据，用当前配置设置还是用LKG来启动Windows 2000系统。

在\winnt\SYSTEM32\CONFIG目录中还有一个文件SYSTEM.ALT,此文件对注册表起维护作用。
SYSTEM.ALT是SYSTEM配置元（SYSTEM文件）的备份文件，以防止SYSTEM这个文件存储在坏扇区上。如果Windows 2000在启动时不能顺利地获得系统配置元，它将自动地去读SYSTEM.ALT文件。


312

路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:ScreenSaveUsePassword和ScreenSave_Data
数据类型:二进制
键 值:ScreenSaveUsePassword为1表示设定密码保护，为0表示不设定密码保护，ScreenSave_Data表示的是密码加密后的值，将ScreenSaveUsePassword的值修改为0或将ScreenSave_Data删除都可以删除屏幕保护的密码。


323

藏陋网，解决电脑故障！ http://www.canglou.com/

路 径:HKEY_CURRENT_USER\InstallLocationsMRU
键值名称:除(默认) 外所有的项目
键 值:删除


314

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:新建NoTrayContextMenu
数据类型:DWORD
键 值:值设为"1"时为有效


315

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:新建"RestrictRun"
数据类型:DWORD
键 值:并设其值为"1"
备 注:在RestrictRun的主键下分别添加名为"1"、"2"、"3"等字符串值，然后将"1"，"2"、"3"等字符串的值设置为允许使用的程序名。例如将"1"、"2"、"3"分别设置为MSHEARTS.EXE、FREECELL.EXE、SOL.EXE，则用户只能使用红心打战、空档接龙、纸牌程序。


316

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp]
键值名称:"Disabled"
数据类型:DWORD
键 值:00000001


317

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:新建"MinPwdLen"
数据类型:DWORD
键 值:"键值"框内输入n
备 注:n大于等于0小于等于8。


318

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:新建"AlphanumPwds"
数据类型:DWORD
键 值:"键值"框内输入1。


319

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
键值名称:新建"NoFileSharing"
数据类型:DWORD
键 值:"键值"框内输入1。


3110

藏陋网，解决电脑故障！ http://www.canglou.com/

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
键 值:找到你的程序，选择"删除"。


3111

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
键值名称:"ClearRecentDocsonExit"
数据类型:十六进制
键 值:01,00,00,00


3112

藏陋网，解决电脑故障！ http://www.canglou.com/


3113

藏陋网，解决电脑故障！ http://www.canglou.com/


3114

藏陋网，解决电脑故障！ http://www.canglou.com/


3115

藏陋网，解决电脑故障！ http://www.canglou.com/


32

藏陋网，解决电脑故障！ http://www.canglou.com/

比起娇小的win98来，win2000算是庞大的身躯了，如何优化系统达到最好的效果？？？


NewTopic

在Windows 2000下修改Autorun属性，就可以使光驱的Autorun功能失效。

其操作步骤如下：

1 启动注册表编辑器。

2 选择HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlset\Services\Cdrom分支
3 在右窗格选中“Autorun”键值，使之数值1变为0


322

如果在安装Windows 2000后，升级了光驱，那么在安装软件时都要输入新的光盘盘符，非常不便。此时，您可以改变放在注册表中的缺省安装设备，修改缺省目录。

其修改步骤如下：

1 启动注册表编辑器。

2 打开HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion分支，如图11-23所示。

3 在右窗格内双击“SourcePath”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入所需的设备和Windows 2000源软件的路径，如G:\NTWRK4，然后单击“确定”按钮
注意：在进行上述修改前，应对注册表数据库system.dat和user.dat进行备份，可在因误修改注册表数据库而导致系统不启动时，用软盘启动DOS后，恢复该注册表数据库。
4 退出注册表编辑器，重启系统后就可以使用新的缺省安装目录了。


333

操作方法如下：

1 启动注册表编辑器。

2 找到子键分支HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\ Current Version\Winlogon。

3 将键值名为“PowerDownAfterShuwDown”的数据改为1后,即可使系统在关闭系统后自动关机。

注意：该功能需要机器支持软关机，否则系统将会重新启动。


324

修改方法如下：

1 启动注册表编辑器。

2 进入注册表，找到如下子键分支：

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session anager\Memory Management。

3 将该子键分支下的“ClearPageFileAtShutDown”的数据设置为1后，在关闭系统时将自动删除PAGEFILE.SYS。这对于Windows 2000和Windows 98安装在同一磁盘分区的FAT16格式很有好处，即系统关机后即删除交换文件，方便磁盘空间充分利用。


325

路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:新建"WaitToKillAppTimeOut"
数据类型:字符串值
键 值:"键值"框中输入10000（单位为ms，缺省值为20000ms，即20秒）
备 注:　　为了缩短系统关闭应用的等待时间，您可以将此等待时间降低为20000ms以下，如10000ms、15000ms等。


326

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:ScreenSaveActive指屏幕保护功能是否可用
键 值:值为0或1，0为不用屏幕保护功能，1为可用。


327

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:ScreenSaveUsePassword指屏幕保护是否使用密码
键 值:值为0或1，0为不设密码，1则使用预设的密码。


328

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:ScreenSaveTimeOut指屏幕保护的延时
键 值:值为一数值，单位是秒，最小值是60秒。


329

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:WaitToKillAppTimeout指当用Ctrl＋Alt＋Del来关闭一个应用程序时出现提示"等待"时选择"等待"的等待时间
键 值:单位是毫秒，默认值是10000，可以减小以缩短等待时间。


3210

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics
键值名称:MinAnimate
键 值:为"0"可取消动画效果


3210

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\keyboard layout\preload
备 注:有1到5甚至更多，你所有的输入法顺序就是从1往下排的，它们的默认值是16进制的数字。Win98 自带的各个输入法的值：英语00000409 微软拼音E00E0804 全拼E0010804 郑码E0030804 智能ABCE0040804 改变顺序时，只要将它们的序号重新命名即可


3212

路 径:HKEY_LOCAL_MACHINE\Enum\SCSI
键值名称:主键下的所有子键
键 值:删除,
备 注:删除了物理光驱和虚拟光驱的信息，重新启动，系统自动找到物理光驱，并且重新在上述子键下加入了物理光驱信息，问题解决。


3213

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
键值名称:查找要删除的软件
键 值:整个删掉


3214

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes
键值名称:删除字符串键ftp，当敲入命令"FTP ftp.regedit.com"将运行FTP


3215

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTRO LSET\CONTROL\UPDATE
键值名称:"UPDATEMODE"
键 值:"1"改为"0"。


3216

路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem\CDFS
键值名称:"Prefetch"
数据类型:DWORD
键 值:4倍速:000000e4(默认值) 8倍速:000001c0 16倍速:00000380 24倍速:00000540 32倍速:00000700 36倍速:00000750 40倍速:00000800 48倍速:00000800注意:(如果修改以上两个键值导致CDROM工作不正常,如:播放VCD时找不到VCD碟,请降低一个级别)


3217

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Keyboard Layouts
键值名称:大多数布局
键 值:删掉它们的键


3218

藏陋网，解决电脑故障！ http://www.canglou.com/


3219

藏陋网，解决电脑故障！ http://www.canglou.com/


33

藏陋网，解决电脑故障！ http://www.canglou.com/

win2000做为网络操作系统，我们怎么能不了解他的网络设置？


33

利用NetWare目录服务管理器（DSMN），Windows 2000可将NetWare服务器置入NT域，所有用户和组都自动成为域的一部分，服务器依然可以正常运转，而且无需运行任何NetWare客户端软件。为访问这种服务器，在Windows 20000 PDC（主域控制器）里进行简单的登录即可，利用Windows 2000客户机（CSNW）和网关（GSNW）能直接提供对NetWare 4.X支持。只有当它们运行于装订仿真模式下（使其表面上像3.x服务器）DSMN才能同它们通信。但是，在尝试连接一台NetWare 4.X服务器时，即使正在装订仿真模式下运行，都会得到一个出错提示，告诉您不能建立连接。

我们利用以下技巧对注册表进行修改后，就可以避免这个问题，正常建立连接。

1 启动注册表编辑器。

2 在“我的电脑\HKEY_LOCAL_MACHINE根键“下定位如下注册表分支：SYSTEM\CurrentControlSet\Services\MSSYNC\Parameters。

3 在单击Parameters文件夹后，在右窗格栏中右单击鼠标键，在弹出的“新建”菜单中选择“双字串值”，并输入值名为Allow4X。

4 双击其图标将Allow4X的值设为1。

5 在重新启动系统后，运行DSMN的系统就能正常识别运行在装订仿真模式下的NetWare 4.X服务器。


332

即使我们选择在登录时重新连接，网络共享卷有时仍然无法继续使用。浏览网络的时候，可看到它们，而且也可以连接，但我们最希望的自动连接却没有任何动静。

以下介绍修改注册表的方法，就能够按自己的意愿工作。

1 启动注册表编辑器。

2 打开注册表分支寻找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Control\NetworkProvider子键分支。

3 查找“Restore Connection”键值名（如它不存在，则自行添加并指定为“双字节值”类型）。

4 在“Restore Connection”图标上，单击鼠标右键，在弹出的菜单项中选择“修改”，在弹出的对话框中输入1，确保连接能够自动恢复。

5 重新启动系统即可生效。


333

随着因特网变得越来越拥挤，全球资讯网(World Wide Web)正在变成全球塞车网(World Wide Wait)。我们在同远程系统连接的时候，如花费的时间过长，就会出现无情的超时错误。此外，如到达目标系统之前经历的“跳跃”数量过多也会出现这种错误。为增大允许的跳跃次数或延长超时错误出现之前的等待时间，可对注册表进行修改。

1 启动注册表编辑器。

2 打开注册表分支寻找HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet

\Services\Tcpip\Parameters子键分支。

3 找到键值名“DefaultTTL”，其默认键值是32。该条目取值范围1到255之间，如在连接因持网服务的时候经常出现超时错误，可试着增大这个数字。通常，64这个设置对于几乎所有应用来说都应该足够了。

4 重新启动系统使修改生效。


334

您可以通过修改注册表达到此目的。

1 启动注册表编辑器。

2 在HKEY_LOCAL_MACHINE根键下面，展开如下注册表分支：SYSTEM\Current ControlSet\Services\Tcpip\Parameters。

3 在“Parameters”文件夹中找到“EnableDeadGWDetect”(这是“双字节值”类型)。

4 双击其图标在弹出的对话框中输入1，这表示打开，相当于指示对死锁的网关进行侦测。若设为0，则将其关闭。


335

在每次重新同服务器连接的时候，以前的连接都会重新建立，这会花去相当多的时间，作为一种备用方案，我们也可以对连接进行“虚拟”(或称为“鬼魂”连接)。也就是说，这些连接表面看似乎是已经建好，但在正式使用它们之前，实际并不会真正激活。

我们可以通过修改注册表建立其“鬼魂”。

1 启动注册表编辑器。

2 在HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider子键分支中，在右窗格栏中右单击鼠标键，在弹出的“新建”中选择“双字节值”项，输入RestoreConnection键值名。

3 在其图标上双击，在弹出的对话框中输入1，它代表开启自动恢复连接的系统。如设为0，亦即关闭RestoreConnection设置，这指示Windows 2000建立虚无“鬼魂”连接。


336

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:NoInternetIcon
数据类型:
键 值:值设为0，可以关闭这些功能；设置为1，可以激活它。


337

路 径:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名称:NoNetHood
数据类型:DWORD值
键 值:1


338

藏陋网，解决电脑故障！ http://www.canglou.com/


34

藏陋网，解决电脑故障！ http://www.canglou.com/

为win2000/nt改头换面！


341

每次当Windows 2000启动时，它都会显示“请按Ctrl+Alt+Delete键来登录”的信息，而你希望用户在按完Ctrl+Alt+Delete键后，画面上自动显示一些你希望用户看到的信息。

您可以利用以下方法修改注册表达到此目的：

1 启动注册表编辑器。

2 选择以下子键分支HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon。

3 在右窗格内双击“LegalNoticeCaption”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入信息窗口的标题，例如“自定义启动信息”。

4 在右窗格内双击“LegalNoticeText”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入信息窗口的内容，例如“Win NT欢迎您！”
5 在注销（Logoff）后，重新登录（Logon），就可看到所设置的启动信息


342

你可以选择登录时的背景图案，也就是设置当启动屏幕上出现“开始登录”对话框，并要求按“Ctrl+Alt+Delete”键以登录Windows 2000网络时的背景图案。

其操作方法如下：

1 启动注册表编辑器。

2 选择以下分支HKEY_USERS\.DEFAULT\Control Panel\Desktop
3 双击右窗格的“Wallpaper”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入背景图案的图形文件名称，如C:\Winnt\Swimming Pool.bmp。
4 双击右窗格“TileWallpaper”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入１（或其他非０的数值）。注销后重新登录，你就会发现登录时的背景图案已改变


343

当启动屏幕上出现“开始登录”的对话框时，你必须同时按Ctrl+Alt+ Delete组合键，然后输入名称与密码，以便登录Windows 2000 Server。如果你此时并不想登录而直接关闭系统（ShutDown），可以吗？

是的，你可以更改设置，使其在登录对话框中增加一个“关闭系统”的按钮选项。不过此方法带来的结果就是，任何人都可以关闭系统。

注意：在Windows 2000 Professional是自动出现此“关闭系统”按钮，但是在Windows 2000 Sever 中则必须自己添加。其操作方法如下：

1 启动注册表编辑器。

2 选择以下子键分支HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\ CurrentVersion\Winlogon
3 双击右窗格内的“ShutdownWithoutLogon”数值名称，当出现如图11-9所示的“编辑字符串”对话框时，请在“数值数据”框中输１。
4 在注销后重新登录，在登录的画面上会多出一个“关闭系统”的按钮。


344

在一般的情况下，你必须自己输入用户名称与密码，才可登录Windows 2000网络，可是Windows 2000也提供你在启动时，自动以某组用户名称与密码登录的功能，而不需要手工输入。

其设置方法如下：

1 启动注册表编辑器。

2 选择以下子键分支HKEY_LOCAL_MACHINE\software\Microsoft\Windows NT\ CurrentVersion\Winlogon。

3 在“注册表编辑器”主菜单中，选择“编辑”菜单的“新建”下的“串值”命令，在右窗格内新建了一个名称为“AutoAdminLogon”的数值名称
4 双击“AutoAdminLogon”，则弹出“编辑字符串”对话框，请在“数值数据”框中输入１。
5 在右窗格内双击“DefaultDomainName”数值名称，然后在对话框的“数值数据”框中输入所要登录域名称或本机计算机名称，例如“Domain”域或“HHSW”计算机，然后单击“确定”按钮。
6 在右窗格内双击“DefaultUserName”数值名称，当出现“编辑字符串”对话框时，请在“数值数据”框中输入登录的用户名称，例如“Administrator”，然后单击“确定”按钮。

7 在“注册表编辑器”的主菜单中，选择“编辑”菜单的“新建”下的“串值”命令，在右窗格内新建一个名称为“DefaultPassword”的数值名称，数值类型为“字符串值”。

8 当出现“编辑字符串”对话框时，请在“数值数据”框中输入用户的密码，然后单击“确定”按钮。
10 在注销后重新登录，就不需要手工输入用户名称与密码了


345

从“资源管理器”中删除“查看/选项”菜单。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Po- licies\Explorer。

键值名：NoOptions。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“资源管理器”中删除“查看”/“转到”菜单。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Po- licies\Explorer。

键值名：NoGoTo。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“资源管理器”中删除其中文件菜单。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Po- licies\Explorer。

键值名：NoFileMenu。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。


346

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CLASSES_ROOT\.BMP
备 注:找到默认值（例如Paint.Picture)；再找到HKEY_CLASSES_ROOT\Paint.Picture,打开或创建新键DefaultIcon，将其值改为%1。


347

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CLASSES_ROOT\.lnk ( Windows 程序的快捷方式)或者选择 HKEY_CLASSES_ROOT\.pif ( DOS程序的快捷方式)
键值名称:IsShortcut
键 值:删除


348

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CLASSES_ROOT\batfile\shell
键值名称:"默认"
键 值:值由"open"改为"edit"


349

藏陋网，解决电脑故障！ http://www.canglou.com/
路径:HKEY_CURRENT_USER\.Default\SoftWare\Microsoft\Windows\CurrentVersion\Explorer\DocFind SpecMRU
键 值:在右窗格中除第一、二和最后一个不能删除外，将其它删除即可


3410

路 径:HKEY_CURRENT_USER\Control Panel\desktop
键值名称:新建"WallpaperOriginX":表示墙纸左侧的水平坐标（单位：象素） "WallpaperOriginY":表示墙纸顶边的垂直坐标（单位：象素）
数据类型:字符串值
键 值:如果将键值分别设为"400"、"50"，重新启动电脑后，墙纸就到了屏幕的右上角。


3411

路 径:HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
键值名称:"HideFileExt"
数据类型:DWORD
键 值:值由1改为0后即可显示文件的扩展名


3412

路 径:HKEY_CURRENT_USER\Control Panel\International
键值名称:键值：sTimeFormat="HH:mm:ss tt"，s1159="xiaofei"，s2359="HELLO"
数据类型:
键 值:说明：12点之前，在系统任务栏中显示xiaofei，之后则显示HELLO，可任意设置以达到自己的效果


3413

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\DEVEOPER\SETUP
键值名称:想修改的键名
数据类型:字符串
键 值:输入修改值


3414

路 径:HKEY_CLASSES_ROOT\.ext （ext为欲修改的文件的扩展名）
键值名称:查找与.ext文件相关的程序数据名（如与.bat文件相关的程序数据名为"batfile"）
键 值:打开HKEY_CLASSES_ROOT\batfile\DefaultIcon（"batfile"为上一步找出的程序数据名）将DefaultIcon的缺省数据修改为你喜欢的图标所在的位置
备 注:要从Windows目录下删除ShellIconCache文件。此文件为图标文件缓冲，它的存在可使系统不必在文件的初始位置加载图标，而只需从此图标缓存中加载，加快了桌面和资源管理器中显示图标的速度。


3415

路 径:HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
键值名称:"默认"
键 值:将右边的（默认）改成你的图标文件名（包含路径）。

作 用:更改"我的电脑"图标的提示信息
路 径:HKEY_CLASSES_ROOT\CLSID\{20D0FE0-3AEA-1069-A2D8-08002B3030D9}
键值名称:InfoTip
键 值:修改键值内容


3416

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CLASSES_ROOT\CLSID\系统文件夹的ID
键值名称:DefaultIcon
键 值:缺省数据修改为你喜欢的图标所在的位置。


3417

藏陋网，解决电脑故障！ http://www.canglou.com/
路 径:HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
键值名称:"Shell Icon Size"
键 值:改变其值即改变图标大小，缺省值为"32"


3418

路 径:HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics
键值名称:IconSpacing和IconVerticalSpacing
数据类型:
键 值:修改值可以更改图标的间距。
备 注:两个键值用于设定图标的水平和垂直间距，其绝对值越大间距越大。


3419

路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:新建串值，把新建串值名改为8
数据类型:
键 值:想要的图标的路径，如"d:\icon\hd.ico"


3420

作 用:改变帮助图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"23"
键 值:路径及文件名
作 用:改变查找图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"22"
键 值:路径及文件名
作 用:改变程序图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"19"
键 值:路径及文件名
作 用:改变关机图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"27"
键 值:路径及文件名
作 用:改变设置图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"21"
键 值:路径及文件名
作 用:改变收藏夹图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"43"
键 值:路径及文件名
作 用:改变文档图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"20
键 值:路径及文件名
作 用:改变运行图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"24"
键 值:路径及文件名
作 用:改变注销图标
路 径:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Shell Icons
键值名称:"44"
键 值:路径及文件名


NewTopic

藏陋网，解决电脑故障！ http://www.canglou.com/

[ ]里面为路径
＝号左边为键名，右边为键值！
豪华的xp，安全性更高了！... ...


511

禁止共享驱动器
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters]
"AutoShareServer"=dword:0

禁止共享admin$
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters]
"AutoShareWks"=dword:0


512

开始，运行，msconfig，启动，可以查看
注册表在下面的项目查看
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"KvMonXP"="C:\KV2004\KVMONXP.KXP /AUTO"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"KvXP"="C:\KV2004\KVXP.KXP /SCANBOOT /SCANSYS"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
"SKYNET Personal FireWall"="C:\PROGRAM FILES\SKYNET\FIREWALL\PFWMAIN.EXE"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
"ctfmon.exe"="C:\WINDOWS\SYSTEM32\CTFMON.EXE"


513

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoFileMenu"=dword:1


514

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop]
"NoChangingWallPaper"=dword:1


515

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CLASSES_ROOT\.reg]
@="TXTFILE"


516

藏陋网，解决电脑故障！ http://www.canglou.com/

 [HKEY_CLASSES_ROOT\.inf]
@="TXTFILE"


517

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoPropertiesMyComputer"=dword:1


518

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoViewContextMenu"=hex:1,0,00,00


519

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoTrayContextMenu"=hex:1,0,00,00


5110

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp]
"NoRealMode"=dword:1


5111

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp]
"Disabled"=dword:1


5112

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:1


5113

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"DisableMyPicturesDirChange"=dword:1

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"DisableMyPicturesDirChange"=dword:1


5114

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
"LegalNoticeCaption"="启动要显示的标题"
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
"LegalNoticeText"="启动要显示的信息"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"System"="启动要运行的程序路径"


5115

禁止显示辅助项目
[HKEY_CURRENT_USER\Control Panel\don't load]
"access.cpl"="NO"

添加删除程序
[HKEY_CURRENT_USER\Control Panel\don't load]
"appwiz.cpl"="NO"

显示器
[HKEY_CURRENT_USER\Control Panel\don't load]
"desk.cpl"="NO"

添加硬件向导
[HKEY_CURRENT_USER\Control Panel\don't load]
"hdwwiz.cpl"="NO"

internt选项
[HKEY_CURRENT_USER\Control Panel\don't load]
"inetcpl.cpl"="NO"

区域设置属性
[HKEY_CURRENT_USER\Control Panel\don't load]
"intl.cpl"="NO"

游戏控制器
[HKEY_CURRENT_USER\Control Panel\don't load]
"joy.cpl"="NO"

鼠标属性
[HKEY_CURRENT_USER\Control Panel\don't load]
"main.cpl"="NO"

多媒体
[HKEY_CURRENT_USER\Control Panel\don't load]
"mmsys.cpl"="NO"

网络连接
[HKEY_CURRENT_USER\Control Panel\don't load]
"ncpa.cpl"="NO"

用户帐户
[HKEY_CURRENT_USER\Control Panel\don't load]
"nusrmgr.cpl"="NO"

nwc
[HKEY_CURRENT_USER\Control Panel\don't load]
"nwc.cpl"="NO"

odbc数据源管理器
[HKEY_CURRENT_USER\Control Panel\don't load]
"odbccp32.cpl"="NO"

电源管理
[HKEY_CURRENT_USER\Control Panel\don't load]
"powercfg.cpl"="NO"

系统
[HKEY_CURRENT_USER\Control Panel\don't load]
"sysdm.cpl"="NO"

电话
[HKEY_CURRENT_USER\Control Panel\don't load]
"telephon.cpl"="NO"

日期和时间
[HKEY_CURRENT_USER\Control Panel\don't load]
"timedate.cpl"="NO"


5116

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_LOCAL_MACHINE\Hardware\Description\System\CentralProcessor\0]
"VendorIdentifier"="CPU商家标识"


5117

藏陋网，解决电脑故障！ http://www.canglou.com/


5118

藏陋网，解决电脑故障！ http://www.canglou.com/


52

藏陋网，解决电脑故障！ http://www.canglou.com/

[ ]里面为路径
＝号左边为键名，右边为键值！

优化一下你的xp吧！


521

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
"AutoChkTimeOut"=dword:10


522

改使用者名字
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"RegisteredOwner"="XIAOFEI"

使用者单位
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"RegisteredOrganization"="WWW.CANGLOU.COM"

安装盘位置
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
"SourcePath"="H:\I386"

产品名称
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"ProductName"="CANGLOU WINDOWS XP"

版本名称
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"CurrentVersion"="5.1"

版本号
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion]
"CurrentBuildNumber"="2600"


523

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\\0000]
"EnableUDMA66"=dword:1

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\\0001]
"EnableUDMA66"=dword:1

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\\0002]
"EnableUDMA66"=dword:1


524

加速中止程序时间
[HKEY_CURRENT_USER\Control Panel\desktop]
"AutoEndTasks"=dword:1

中止程序等待时间
[HKEY_CURRENT_USER\Control Panel\desktop]
"WaitToKillAppTimeout"="5000"

不响应程序等待时间
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"WaitToKillServiceTimeout"="1000"

中止服务等待时间
[HKEY_CURRENT_USER\Control Panel\desktop]
"HungAppTimeout"="1000"


525

藏陋网，解决电脑故障！ http://www.canglou.com/


53

藏陋网，解决电脑故障！ http://www.canglou.com/

[ ]里面为路径
＝号左边为键名，右边为键值！

用xp，更好的上宽带？看吧～


531

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
"Window Title"="藏陋网 HTTP://WWW.CANGLOU.COM"

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Window Title"="藏陋网 HTTP://WWW.CANGLOU.COM"


532

[HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]
"WindowTitle"=www.canglou.com

[HKEY_CURRENT_USER\Identities\{1FA40848-0443-493A-9004-C1A4F2116CA4}\Software\Microsoft\Outlook Express\5.0]
"WindowTitle"=www.canglou.com


533

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Start Page"="HTTP://WWW.CANGLOU.COM"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main]
"Search Page"="WWW.CANGLOU.COM"

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main]
"Search Page"="WWW.CANGLOU.COM"


534

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Search]
"SearchAssistant"="WWW.CANGLOU.COM"

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Search]
"CustomizeSearch"="WWW.CANGLOU.COM"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search]
"SearchAssistant"="WWW.CANGLOU.COM"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Search]
"CustomizeSearch"="WWW.CANGLOU.COM"


535

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer]
"Download Directory"="F:\DOWNLOADS"


536

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"FormSuggest Passwords"="NO"


537

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer]
"Version"="6.00"


538

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt\使用影音传送带下载]
@="D:\PROGRA~1\XI\NETTRA~1\NTADDLINK.HTML"


539

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"GeneralTab"=dword:0


5310

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"HomePage"=dword:0


5311

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Settings"=dword:0


5312

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Cache"=dword:0


5313

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"History"=dword:0


5314

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Colors"=dword:0


5315

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Links"=dword:0


5316

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Fonts"=dword:0


5317

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Languages"=dword:0


5318

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"Accessibility"=dword:0


5319

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"SecurityTab"=dword:0


5320

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"ContentTab"=dword:0


5321

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"ConnectionsTab"=dword:0


5322

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"ProgramsTab"=dword:0


5323

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]
"AdvancedTab"=dword:0


5324

禁止使用新建
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoFileNew"=dword:0

禁止使用打开
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoFileOpen"=dword:0

禁止使用另存为
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserSaveAs"=dword:0

禁止使用另外为web页，全部
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions]
"NoBrowserSaveWebComplete"=dword:0

禁止使用关闭
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserClose"=dword:0


5325

禁止使用 自定义工具栏
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoToolbarCustomize"=dword:0

禁止使用 自定义工具栏的按钮
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoBandCustomize"=dword:0

禁止使用查看源文件
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoViewSource"=dword:0

禁止使用全屏
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoTheaterMode"=dword:0


5326

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoFavorites"=dword:0


5327

藏陋网，解决电脑故障！ http://www.canglou.com/

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserOptions"=dword:0


5328

禁止使用每日提示
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoHelpItemTipOfTheDay"=dword:0

禁止使用netscape用户
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoHelpItemNetscapeHelp"=dword:0

禁止使用教程
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoHelpItemTutorial"=dword:0

禁止使用发送反馈信息
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoHelpItemSendFeedback"=dword:0


5329

以上局域网宽带的例子来优化！
使用最大传输单元，1500（以太网）
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPerServer"=dword:16

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPer1_0Server"=dword:16

[HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPerServer"=dword:16

[HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPer1_0Server"=dword:16

域名服务器超时 3000
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
"NameSrvQueryTimeout"=dword:3000

[HKEY_LOCAL_MACHINE\System\ControlSet001\Services\VxD\MSTCP]
"NameSrvQueryTimeout"=dword:3000

加速TCP/IP
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"TCPWindowSize"=dword:372300

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
"TCPWindowSize"=dword:372300

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"GlobalMaxTcpWindowSize"=dword:372300

TCP分组寿命
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"DefaultTTL"=dword:64

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
"DefaultTTL"=dword:64

MTU自动探测
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnablePMTUDiscovery"=dword:1

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
"EnablePMTUDiscovery"=dword:1

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"SackOpts"=dword:1

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
"SackOpts"=dword:1

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"Tcp1323Opts"=dword:3

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters]
"Tcp1323Opts"=dword:3

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TelnetServer\1.0]
"MaxConnections"=dword:2

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TelnetServer\1.0\Performance]
"NumThreadsPerProcessor"=dword:16

加速telnet
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update]
"UpdateMode"=dword:1

[HKEY_LOCAL_MACHINE\System\ControlSet001\Control\Update]
"UpdateMode"=dword:1


5330

藏陋网，解决电脑故障！ http://www.canglou.com/


5331

藏陋网，解决电脑故障！ http://www.canglou.com/


5332

藏陋网，解决电脑故障！ http://www.canglou.com/


NewTopic

注册表超级全攻略v1.0
注册表超级全攻略是藏陋网 开发的一本共享电子书籍！收录的是大量简单,通俗易懂而又确实实用的windows系列注册表修改技巧,不但对电脑初学者有很大的帮助,而且对老鸟也很有参考价值！内容含盖了win98,NT,2K,XP全套注册表修改实用技巧。
本软件为共享软件，所有内容都可以免费使用，但不可修改！
藏陋网对该书籍拥有完全版权和著作权，解释权归藏陋网所有。
如果你使用本书籍，说明你接受以上协议。
软件作者：藏陋网 xiaofei
联系：http://www.canglou.com
藏陋网，解决电脑故障！
欢迎到藏陋论坛提问电脑故障，交流电脑经验技巧！


71

从“开始”菜单中删除“运行”命令。

Windows 98/2000只能部分限制运行应用程序，而应用程序仍然可以从资源管理器中运行。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoRun。

类型：REG_DWORD (双字值)。

数据：0=无效，1=有效。

从“开始”菜单中删除“查找”命令。

在Windows 98/2000资源管理器中也将“查找”功能删除，这意味着不能对硬盘进行搜索。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoFind。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“开始”菜单中删除“注销到”命令。

在Windows 2000上，“注销”按钮将不起作用。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoLogOff。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

禁用“关闭系统”命令。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoClose。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“开始设置”菜单中删除“任务栏”以外的其他菜单项。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoSetFolders。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“开始”/“设置”菜单中删除“任务栏和开始菜单”命令。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoSetTaskbar。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

从“开始”菜单删除“公用程序组”。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoCommonGroups。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。


72

隐藏“我的电脑”中的驱动器。

在隐藏“我的电脑”中的驱动器后，在“资源管理器”中也看不到任何驱动器。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoDrives。

类型：REG_DWORD (双字值)。

数据：0x03FFFFFF（十六进制）或67108863（十进制）。

注意：NoDrives 从最低位开始，每一位对应于一个驱动器。

隐藏“网上邻居”。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoNetHood。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“网上邻居”中“整个网络”。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoEntireNetwork。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“桌面”上所有图标。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoDesktop。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“显示属性”对话框上“背景”选项卡。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \System。

键值名：NoDispBackgroundPage。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“显示属性”对话框上“屏幕保护程序”选项卡。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \System。

键值名：NoDispScrSavPage。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“显示属性”对话框上“外观”选项卡。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \System。

键值名：NoDisAppearancePage。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“显示属性”对话框上“设置”选项卡。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \System。

键值名：NoDispSettingsPage。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。

隐藏“开始”菜单子文件夹。

子键分支：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies \Explorer。

键值名：NoStartMenuSubFolders。

类型：REG_DWORD (双字值)。

数据：0=无效；1=有效。


73

             ——初识知识表

    作为 Windows 的核心之一，注册表（Registry）尤如整个系统的大脑，控制着计算机的各种硬件设备和软件配置，其重要性是不言而喻的。而有关注册表的修改也一直是个十分热门的话题，许多朋友都不满足于微软强加给我们的安排，很想当个Win Hacker。因此，在各大电脑报刊上，注册表修改文章屡见不鲜。不过，对于一般的用户来说，尤其是广大的电脑初学者们，对注册表的理解还是很浅的，有的甚至还认为是很神秘，高深莫不可测。所以在这儿，我想拿出平生之所学，简单地给大家作一个注册表普及教育，也算是要消除注册表“文盲”吧。如果说本文能把您领进注册表这扇神秘的大门的话，那我这个老师也算是没有白当。（咚咚…….只见几个臭鸡蛋飞过来。什么水平！还想当老师……）

    好！（从鸡蛋堆里爬出来后，整一整衣冠）废话少说，开始本文主题。

    早在Dos和Win3.x的时代，大部分的应用程序都是采用了 ini 文件（初始化文件）来保存一些配置信息，如设置路径，环境变量等。但ini文件有大小64k的限制，而许多程序都喜欢向win.ini文件中加入各自的配置，时间一长，系统难免不受到影响。再者，太多的ini文件也不便于集中管理。所以Windows 95从 NT中引入了注册表的概念，利用一个功能强大的注册表数据库来统一集中地管理系统硬件设施，软件配置等信息，从而方便了管理，增强了系统的稳定性。最直观的一个实例就是，为什么windows下的不同用户可以拥有各自的个性化设置，如不同的墙纸，不同的桌面。这就是通过注册表来实现的。

    要了解注册表的结构，我们首先需要借助于一款能够查看修改注册表的工具，而这种工具我们也不必急着四处去找。其实，微软早已为我们准备好了，windows目录下的名为regedit.exe的文件便是，"注册表编辑器"。也许微软认为修改注册表对一般的用户来说太具风险性，所以并未在开始菜单中提供它的快捷方式，因此为了以后的修改方便，我们有必要自己动手为它在桌面上建一个快捷方式，要不，您每次要打开“注册表编辑器”（以后简称为regedit）时，都需要先打开开始菜单，然后打开运行再输入regedit，回车后才能启动regedit。这岂不很麻烦？

    在具体讲解注册表结构之前，我们还要先掌握几个基本名词，这在以后的使用中是经常要提到的。

    主键：（在NT下又称为项）您可以认为这是整个注册表结构中的一层，有点儿类似于资源管理器中的目录树结构。所以它的图标与文件夹的图标有点儿想像。

    字符串值：顾名思义，一串ASCII码字符。

    DWORD值：从字面上理解应该是Double Word ，双字节值。由1-8个十六进制数据组成，我们可用以十六进制或十进制的方式来编辑。

    二进制值：这没啥多说的，0101呗！

    搞清这几个概念后，我们开始研究。

    打开regedit后，我们会看到主窗口一分为二，左边为主键的目录树结构，右边显示键名和键值。主键的名称前会有一 + 或 - 号，表示可以折叠或展开。这种显示方式十分接近于资源管理器的风格，所以相当直观，也很容易让初学者上手。

    在"我的电脑"下，我们会看到六大主键（这儿也可称为根键），这六大主键分别为：

    HKEY_CLASSES_ROOT：这儿记录着各种文件的关联信息（即打开方式），还有一些类标识和OLE、DDE之类的信息（这些我也是半瓶醋，那就不多说了）。举个例子，文本文件的扩展名为txt，在用"详细资料"方式查看时，文件类型显示为“文本文件”，图标为一张纸的图案。双击一个文本文件时，系统会自动调用"记事本"来打开。这些信息都是从该键下反映出来的，同理，其它类型的文件也都是注册在这里。

    HKEY_CURRENT_USER：在这下面保存着当前登录用户的各种个性化配置，如桌面，墙纸等。许多应用程序都会在这儿保存一些用户使用界面设置，如窗口的大小，工具栏的位置，最近打开过的文档。Windows的多用户设置就是在这里实现的。

    HLEY_LOCAL_MACHINE：这里是整个注册表的核心部分，各种硬件软件的配置都存放在了这里，其下还可以具体分为： 　　Config 配置 　Driver 驱动程序　 Enum 即插即用　 Hardware 硬件 　　Network 网络 　Security 安全 　Software 软件 System 系统 　　这八个部分，每部分还可再分为更细的内容。

    HLEY_USERS： 显示当前登录用户和默认用户的配置。

    HKEY_CURREN_CONFIG： 为当前硬件配置信息。这是因为windows可以以不同的配件配置情况启动。因此使用不用配置时这里的内容也会不同，不过，对于大多数用户来说，这儿的作用不大，很少有人会电脑有两种以上的配置。

    HKEY_DYN_DATA：这里的内容是由系统启动时随机生成的，主要包括那些windows用来操作各种硬件的动态信息，每次启动时的内容都会不同。一般来说，这儿我们也很少动。

    以上只是简单介绍了一下六大主键，其实下面还有更多更细的分枝，限于篇幅，我不可能每点都介绍到（要真是如此，恐怕要写成一本书了）。需注意一点的是虽然我们看到的是六大主键，但实际上有几项是重复的，如HKEY_CLASSES_ROOT和 HKEY_LOCAL_MACHINE\Software\CLASSES下的内容完全相同，这里注册表提供了双重入口，虽然看起来地址不太一样，但实际都指向同一位置。这也许是为了修改方便吧。所以真正常用到修改的地方只是HKEY_CLASSES_ROOT、 HKEY_CURRENT_USER和 HKEY_LOACAL_MACHINE 这三处。

    不知一下说了这么多，您能理解了多少？下一次我们将做几个简单的修改实例，在实际应用于中掌握有关注册表的修改技巧。


74

  ——小试牛刀

    这一次我们将通过几个修改实例来学习注册表的一些小技巧。

    在修改之前，我们先要学会注册表的备份。这点儿很重要，尤其是在我们不小心改错的时候，利用备份可以尽可能地还原到修改前的状况。

    说了这么长时间的注册表，注册表到底放在哪儿呢？其实注册表可分为两个文件，分别为 system.dat 和user.dat。注册表中的大部分内容是以二进制的形式放在了system.dat文件里，该文件在windows目录下；而HKEY_CURRENT_USER下的信息保存在user.dat文件里，该文件一般在windows\profiles\用户名\下，所以谈到注册表的备份实际上就是对这两个文件的备份。

    具体的备份方法可分为自动和手工两种，而自动的方法又有两种。一种是在系统成功地启动后，windows会自动把这两个文件分别改名为system.dao，user.dao。所以当windows因为造访注册表出错而无法正常启动时，我们可以退到完全模式下，删去system.dat 和user.dat文件，然后把system.da0改名system.dat、user.da0为改为user.dat，重启之后便可修复好注册表的错误了；另一种方法就是Win98引入了的注册表扫描工具ScanReg，在启动时，它会自动对注册表进行扫描，并对系统文件及时备份（当然包括这两下文件）。在windows\sysbacup 目录下您会发现诸如rb000.cab和rb001.cab之类的压缩文件，这几个就是最近的五个系统备份，当系统出错后，我们可以用WinZip或WinRAR从中提出这两个文件，按照前面的方法，还原注册表。手工的方法应该说是实用的了，利用注册表编辑器的导入导出功能，我们可以对注册表的全部或是某一主键下的内容进行备份（以扩展名为reg的文件保存，实质上是个带特定格式的文本文件）。这也样，在修改某一键值或删除某一主健时，我们可以先将此处内容导出到一个安全的地方，然后再进行修改。万一改错了，也不必害怕，再把这个文件导回来就可以恢复了。这种方法虽然对修改多处时有点儿麻烦，但绝对安全可靠。

    学会了注册表的备份与恢复后，我们就开始动手改注册表吧。动手之前您可别忘了备份噢！

    例一，给“回收站”改名。

    桌面上的大部分图标都可以直接重命名，而“回收站”就是不行，所以我只有动用“注册表”了。打开Regedit, 展开HKEY_CLASSES_ROOT，再展开CLSID，找到名为{645FF040-5081-101B-9F08-00AA002F954E}的主键，其右窗口中的默认值便是回收站的名称。双击其图标，在弹出的编辑框里将其改名为“垃圾筒”。切换回桌面，按F5刷新一下。看看它的名字是不是变成了“垃圾筒”了？大功告成！其实我们也不必这么麻烦非要记作那长长的一串，一点一点去找。利用 regedi t查找功能就可以帮我们快速定位了。按下F3，在查找目标一栏里填上“回收站”，回车。Regedit 便会自动帮您找到并定位到这个位置了。

    例二，美化您的“开始”。

    1． 加快菜单的弹出速度

    在开始菜单中，下级菜单的弹出总是有点儿延迟，鼠标放上去后总是要等那一会儿才肯找开下一级的菜单。不过我们可以修改注册表来加快这个弹出的速度。打开Regedit，定位到HKEY_CURRENT_USER\Control Panel\desktop下，在右边新建一个名为MenuShowDelay 的DWORD值，将其值设为1（1为弹出速度最快）。重启之后，您便会发现开始菜单的弹出速度比以前快多了。

    2． 去除"收藏夹"

    在Windows98下的开始菜单中会有一个"收藏夹"的菜单，不过对于许多未上网的朋友来说，很少用到，放在这儿又占地方，所以我们可以动手删掉它，在HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer下，新建一名为NoFavoritesMenu的二进制值,并设为1。重启之后，收藏便从比在开始菜单中消失啦 ！当然如果您又想找回"收藏夹"的话，把值改为0就行了。同理我们还可以去掉开始菜单中的"文档（NoRecentDocs），"查找（nofind），"注销"（NoLogOff）和"关闭"（NoShutDown）等。

    三．给IE标题改名

    您见过别人的IE标题栏上的" XX专用浏览器"吗？其实这不难，您也能做到。在HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main下，找到一个名为 Window Title 的字符串，这儿就是IE标题所显示的字样，将此改名为“ XX专用浏览器”。重启 IE之后，您便能看到自己的大作了。

    同理OutLook Express 的标题也可以修改，地址是在HKEY_CURRENT_USER\Identities\{4C44D002-7BCF-11D3-9957-AB53DA238B0C}\Software\Microsoft\Outlook Express\5.0下的一个名为windowtitle的字符串值（注：{}中的字符不一定完全相同）。

    做了这几个小实验后，您是不是已体验到了修改注册表的一种成就感呢？改注册表其实就这么简单，关键的还是需要事先知道这些秘密，要不您随便改了半天，也不见得会有什么效果。

    下一次我们开始将介绍几款常用的注册表工具。


75

     ——傻瓜工具

    俗话说，“工欲善其事，必先利其器”。要修改注册表，准备一些好的工具还是很必要的。所以从今天开始，我将分两次给大家介绍一些有关注册表的工具。今天嘛先给大家送上几个“傻瓜”。

    说是“傻瓜”，但你我都不傻。这类工具的最大特点就是无须您要知道多少有关注册表的知识（当然知道一点那更好），所以说“傻瓜”也可以完成有关注册表的许多繁杂的修改，要做的也只是打打勾填填字而已。

    第一位出场的乃是当今红遍国内江山的一只小兔子——“超级兔仔魔法设置器”。这款由国人蔡旋朋友编写的系统修改工具。凭借了极其友好的界面，方便直观的修改，丰富的修改内容曾在国内各大软件下载排行榜上居高不下，而且赢得了近五百人的注册（注册费用为10元）（好大的一笔收入啊，惹得我等小辈眼红）。的确，这个小东东确实很好使，我们只用填几个字，打几个勾就可以完成有关注册表中高深修改，让我们体验了一种Win Hacker的感觉。

    同类产品还有“侠客系统修改”，“豪侠99”及国外的WinHacker 95等。由于功能相近，使用也很简单，这儿就不多废口舌了。

    第二位露面的也是近期排行榜上排名前几位的一只“小猫咪”——“快猫加鞭”。对于大多数拨号上网的朋友来说，如何让自己的小猫跑快一点儿，一直是很关心，也很着急的。虽然我们可以通过修改注册表中的MTU值来优化转输速率，但对于大多数人来说还是有点儿高深复杂。所以左轻候朋友的"快猫加鞭"的推出，吸收了一大批“傻瓜”。一个按纽便将整个优化全部搞定（唉呀！我都要变“傻”了）。 　　同类的工具还有MTUSpeed、NetSonic等，它们都提供了对注册表中的某一方面的优化。

    第三位见面的其实应该说是注册表工具的老前辈了，经典工具了--Regclean。由注册表"娘家"微软推出的东东我们还有什么可怀疑的，一个按纽便可完成对注册表的清理工作，您想干点活儿它都不让。不过它的BUG似乎也不少，而且也已经好久没升级了。

    怎么样，用过了以上几个傻瓜工具后您是不是也变"傻"了一点儿？“兄弟”提醒您一句，这类工具您还是少用一点，要不时间一长，您什么都不想，那不真的要变傻了吗？（当头一棒）所以下次我将给您介绍几款高级工具，从而更加体现出您老鸟级的水平。


76

                   ——老鸟必备

    上回介绍的几款傻瓜工具不知大家用后感觉如何？如果您是一只老鸟的话，那它们肯定满足不了您的需求，如果您还是想做一些更深一层次的研究，那请跟我吧（回头一看，怎么没人跟上来???……）

    第一位兄弟乃是名气响当当的RegMon——注册表监视器（什么？您没听过？我倒…）。想玩好注册表，这个工具您可一定要玩通了。利用其强大的监视功能，我们可以对一些程序进行跟踪，看看程序都在注册表里干了些什么（怎么像是在解密？）。无论是读操作，还是写改操作都逃不过它那双慧眼，统统记录在案，想逃都逃不掉。也许您会问“监视这些到底有啥用呀？”“喂，兄弟！你可别搞错了，怎可能没用呢？”要知道，注册表中可藏有好多秘密啊！注册表中有许多内容就像有些WINAPI函数一样，是未公开过的。既然微软不肯告诉我们，那我们只有自己动手去找了呗。而且……（小声地说）而且我们还可以借此机会当一回儿Cracker了（详情请听下回分解）!

    由于其使用起来有点复杂，限于篇幅，这儿就只作一些简单的功能上的介绍，具体的使用大家可参阅我的网站。同类的工具还有RegSnap——注册表快照，它可比较出软件安装前后注册表中的变化，也挺实用的。

    第二位而是在注册表工具市场中突然冒出的一颗灿烂的新星——Resplendent Registrar。Resplendent Regsitrar以其强大的功能，可以说是有史以来最好的一款注册表工具，当然体积也有点儿大（1.3M）。首先得感谢Resplendent Sp公司为我们带来了这么好的佳品。它最大的一个特点就是其风格上十分接近于资源管理器。在RegEdit中，右窗口只能显示键名和键值，而Resplendent Retgistrar（以下简称为RR）可以在右窗口同时显示该级下的主键，这样使用起来就像是资源管理器了。主界面上还有工具栏，地址栏和描述栏。在地址栏中您甚至可以像输入网址一样地输入注册表中的地址。回车后，RR 会自动帮您定位到这。描述栏里也对一些常用的地址给了一个简要的描述，更加方便了初学者，只可惜是英文的。除此之外还有极强的书签，历史记录和查找功能。利用书签，我们可以尽情地在注册表的数据库海洋里尽情邀游了；而历史记录的功能更是方便了用户，无论您是老鸟还是菜鸟，改错注册表是再所难免的，而在RegEdit中连个最基本的撤消功能都没有(哪怕只能恢复一步也行啊！)。在RR中就不存在这问题，您甚至可以恢复24小时之内的每一次操作，而且只要您愿意，设为10000天都可以（不过估计您的Windows连100天都撑不了）。我的天啊！这下我们可放心大胆地改注册表了，当然这一切前提是在您是使用RR改注册表的。

    怎么样？光这几个功能就足以让您心动，更何况它在其它各个细节的精心设计。内置了一个专门编辑注册表文件的编辑器（它可比记事本来编辑强多了），安装后会自动加入到开始菜单中的查找中去等等，所以我敢说它是目前最好的注册表工具，regedit，您就让它到一边稍息去吧。

    同类的工具还有Regview，也是一个挺有创意的编辑工具，我们可以以“大图标”，“小图标”，“列表”和“详细资料”四种不同的方向来查看注册表，是不是也很像资源管理器。要是RR能把这功能也加进来那就更好了。同时RegView还有一个相当不错的功能，具体是什么，你自己试试看就知道了，绝您不会失望的。

    如果您还舍不得放弃regedit，那就请个Registry Studio吧。喝咖啡时我们常常会加点儿咖啡伴侣，所以用RegEdit时，您一定要试试Registry Studio（以下简称RS）。启动 RS 时，它会先调出RegEdit，然后把自己内嵌进去，这样原先的RegEdit的界面上有了很大的改观了。菜单栏下多了一条工具栏,很是方便。而最有特色的一项功能便是右窗口上下一分为二，在增加出来的下窗口里显示一些“书签”。利用这书签，您就可以快速地在注册表里定位了，双击其中一只，它便会自动帮您展开到这位置，而且展开的速度还特别快。

    同类的工具还有RegEditX，它可以为RegEditX增加一个地址栏，也是挺有创意的。不过它和RS不能同时使用，否则会出现一些不正常现象。

    上面所介绍的只是注册表工具类的一部分，其它种类的还很多，我不能一一概尽，所以只挑选了其中几款我认为是不错的拿出来重点向大家介绍。想知道更多更详细的内容，欢迎大家访问我的站点。同时我也提供了上述工具的本地下载，大家不必四处去找了。 　　下一回我们将谈一谈（声音变小）如何当一回cracker。


77

     ——当一回Cracker

    现在大部分的共享软件都会有个使用时间的限制，一般为三十天试用期，试用期满之后，它便拒绝为你服务了。为此，不少朋友想尽了各种办法来对付这时间问题。比如常用的一种方法就是调整系统的日期。不过我认为这种修改时间的方法并不太好，最多也只是个下策。如果今天为了使用这个软件，把时间调一下，明天又是为了那个软件再把时间调一下，几次下来，岂不太混乱了？（噢！这儿犯了错误，对这台机子来说已经没有今天，明天的概念，鬼才知道它具体是哪一天呢！）所以我推荐您另一种方法，不需要改系统时间，所做的只是改几个字节就可以延长软件的使用时间了。

    首先，我先介绍一下工作原理。

    一般来说，许多软件在第一次运行时，会自动地将当前的时间记录在注册表中。以后的每一次运行，都会先从注册表中读出这个时间，然后再和当前的时间作经比较，一量发现发现超过试用期限，那就……嘿嘿……Game Over。所以我们修改的方法有两种，一种就是前面所述的改系统时间，另一种则是改注册表中的这个时间。两种方法孰好孰坏，想必不用我多说，大家心知肚明。

    下面我就以最新版的Paint Shop Pro 6.0 （Evalution版而不是Beta之类的版式本）为例，介绍一下具体修改过程。

    修改之前您先要作好以下几个准备工作，第一，准备好RegMon（上次介绍的注册表监视器）；第二，安装好Paint Shop Pro ;第三，（可选）挑几个好一点儿的注册表编辑工具。准备好这些后，那我们开始出发。打开Regmon，在过滤设置中填上psp（Paint Shop Pro 的执行文件名），表示只对PSP文件进行监视。设好过滤之后，开始监视。打开PSP，在出现启动画面和显示已使用时间的时候停止监视。想想在这一段时间里，PSP会从注册表中读取哪些信息呢？然后仔细分析一下监视到的结果（重点在后一部分，想一想这是为什么？）。由于软件把这个时间是以加密的形式存放在注册表中，所以regmon监视到的数据中有一串很奇怪的字符便是这时间了。虽然我们并不知道它具体的加密算法，但最简单的一个删除不就解决问题了吗？双击监视到的这个数据，直接让步RegMon打开RegEdit，定位到HKEY_CLASSES_ROOT\CLSID\{ADBB2D80-5DFD-11D2-A00C-00104B65AAF5}\MS，将右窗口中的iPID60u值删掉。重启PSP，这时您便会发现它又从第一天开始计时了。修改起来就是这么简单。

    怎么样，您是不是找到了一种Cracker的感觉？不过在这里提醒您一句，对于修改软件的使用时间您最好只板是个人研究，切记不可用作商业用途。毕竟这是违反软件的版权法的，我们不花钱一直免费试用，心中也不安心啊！


78

第一步：安全第一

先给注册表保留一个备份。将Windows目录下的System.dat和User.dat复制到安全地带，或
运行注册表编辑器后在文件选单中的“注册表”下选“导出注册表文件”，便可以放心地修改
以下内容。

第二步：指定人员上机

运行Regedit后依次打开HKEY_LOCAL_MACHINE\Network\Logon，然后，新建DWORD值Mustbe
validated值为1。

再依次打开HKEY_LOCAL_MACHINE\-SOFTWARE\Microsoft\Windows\-CurrentVersion\Winlo
gon，建字符串值：
1.Legalnoticecaption值为“浙西计算机学校警告”（引号内内容自定，表示提示标题栏
）； 2.Legalnoticetext 值为“请认真学习”（引号内内容也自定，表示提示信息的内容
）。

该步修改后用户按ESC不能进入Windows 98，只有输入正确密码后方可以进入。

第三步：禁止控制面板的一切修改

依次打开HKEY_CURRENT_USER\Software-\Microsoft\Windows\CurrentVersion\policies\
Explorer，新建DWORD值Nosetfoldersl值为1，便可解决上述问题。

第四步：禁止查找功能

虽说Word可以加个密码，但时间久了忘了怎么办？你可以将自己的文件保存在秘密的目录
里将其隐藏，然后把Find功能关闭，就不会轻易被发现了。打开HKEY_CURRENT_USER\Software
-\Microsoft\Windows\CurrentVersion\Explorer，新建DWORD值Nofind值为1。

第五步：禁止普通用户使用注册表编辑器

打开HKEY_CURRENT_USER\Software-\Microsoft\Windows\CurrentVersion\policies\Syst
em，新建DWORD值 Disableregistrytools 值为 1。这样，除自己外，别人只能看不能修改。

第六步：隐藏C驱动器

Windows 98及一些重要的数据一般都在C盘。若让人误删了文件，那就惨了。这里教你一招
。

打开HKEY_CURRENT_USER\Software-\Microsoft\Windows\CurrentVersion\Explorer，新建
二进制值Nodrives值为03000000，怎么样，找不到C盘了吧!

第七步：禁止对打印机配置进行更改

打开HKEY_CURRENT_USER\Software-\Microsoft\Windows\CurrentVersion\Explorer，新建
DWORD值Noprintertabs值为1。

第八步：最后一招

把Windows下的Regedit.exe复制到软盘上，将Windows文件夹下的Regedit.exe删除。这样
，一般用户想改也改不了。

以上八招为笔者减轻了许多负担，令笔者工作更轻松。如果你也有同样的遭遇，不妨试试
。


79

我们知道在注册表的“HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer”子键下通过建立新的项及设置不同的键值可以禁用“我的电脑”中的驱动器，禁用“查找”、“运行”等功能，其实在这个子键下还可以通过新建其它一些键值来禁用更多的功能，下面将部分禁用的项目简介如下，供有兴趣的朋友参考。
1．新建二进制键值NoDriveTypeAutoRun，设置键值为b5，00，00，00，禁用光盘自动运行；
2．新建dword键值EditLevel，设置键值为1，禁用开始菜单中“程序”上的水平线；
3．新建二进制键值NoStartBanner，设置键值为01，00，00，00，禁用单击“从这里开始”动画箭头；
4．新建dword键值NoFavoritesMenu，设置键值为1，禁用开始菜单中的“收藏夹”；
5．新建dword键值NoRecentDocsMenu，设置键值为1，禁用开始菜单中的“文档”；
6．新建dword键值Nofind，设置键值为1，禁用开始菜单中的“查找”；
7．新建dword键值NoRun，设置键值为1，禁用开始菜单中的“运行”；
8．新建dword键值NoLogOff，设置键值为1，禁用开始菜单中的“注销”；
9．新建dword键值NoClose，设置键值为1，禁用开始菜单中的“关闭”；
10．新建二进制键值NoRecentDocsHistory，设置键值为01，00，00，00，不保存新近打开的文档历史记录；
11．新建二进制键值ClearRecentDocsonExit，设置键值为01，00，00，00，退出时自动删除“运行”、“查找”中的历史记录，与第10项一起设置，自动清除新近打开的所有文档的历史记录；
12．新建dword键值NoNetHood，设置键值为1，禁用“网上邻居”图标；
13．新建dword键值NoInternetIcon，设置键值为1，禁用IE浏览器图标；
14．新建dword键值NoSaveSettings，设置键值为1，禁用退出时保存设置(锁定桌面)；
15．新建二进制键值NoDrives，键值设置为01，00，00，00禁用A驱动器，设置为ffffffff禁用所有驱动器；
16．新建dword键值NoFileMenu，设置键值为1，禁用“我的电脑”、“资源管理器”及“我的文档”中的“文件”菜单；
17．新建dword键值NoActiveDesktop，设置键值为1，禁用显示属性中的“Web”选项卡；
18．新建dword键值NoChangeStartMenu，设置键值为1，禁用在开始菜单中拖放快捷菜单；
19．新建dword键值NoViewContextMenu，设置键值为1，禁用右键快捷菜单；
20．新建dword键值NoTrayContextMenu，设置键值为1，禁用任务栏的快捷菜单；
21．新建dword键值NoDesktop，设置键值为1，禁用桌面上的所有图标选项；
22．新建dword键值NoAddPrinter，设置键值为1，在打印机文件夹中禁用“添加打印机”；
23．新建dword键值NoDeletePrinter，设置键值为1，在打印机文件夹中禁用“删除打印机”；
24．新建dword键值NoPrinterTabs，设置键值为1，禁用打印机属性中的“常规”和“详细”选项卡；
25．新建dword键值NoSetFolders，设置键值为1，禁用“设置”中的“控制面板”和“打印机”
26．新建dword键值NoSetTaskbar，设置键值为1，禁用“设置”中的“任务栏属性和开始菜单”；
27．新建dword键值NofolderOptions，设置键值为1，禁用“设置”菜单中的“文件夹选项”；
28．新建dword键值NoSetActiveDesktop，设置键值为1，禁用“设置”菜单中的“活动桌面”；
29．新建dword键值NoWindowsUpdate，设置键值为1，禁用“设置”菜单中的“WindowsUpdate”选项；
30．上述第25、26、27、28、29五项全部禁用后则可以在开始菜单中删除“设置”选项。
如果你的注册表过于庞大而且杂乱，那么在进行上述设置时，个别项目可能无法设置成功，只要你下决心重装一遍系统，在新的注册表中，均可成功进行。以上设置在Windows98第二版中测试通过


7a

注册表的文件关联及应用
    喜欢使用Windows右键快捷菜单的朋友可能知道，当你选择了一个文件（或者是文件夹或是系统图标）再单击鼠标右键，系统就会弹出一个菜单，菜单上面的各种“功能”（或称“操作”）任你选择，但是你是否注意到，当你安装一些应用软件之后，你的右键菜单是不是膨胀，以winzip为例，安装winzip之后，文件或文件夹的右键菜单当中就增加了功能选择项"Add to Zip"和"Add to xxx.zip",如图一，看到这个变化，我们不禁要问，这些选择项是怎么加入的，可不可以自己来添加。带着这些问题，我们再来看Windows的文件关联。
    什么是文件关联呢？通俗地说，就是选择不同类型的文件时，在其右键菜单上显示的各功能项。每个功能项即对应一个关联。选择了某一功能（操作），系统就去执行相应的处理程序。至于对什么文件的什么操作对应什么样的处理程序，那都记录在系统注册表中。因此，要真正弄清文件关联，必须深入研究注册表。这个问题解决了，我们就可以利用注册表随心所欲地为文件建立，修改，删除关联。
    既然关联信息都写在注册表中，那么它在注册表中又是怎样构成的呢？我们不妨打开注册表，观察根键HKEY_CLASSES_ROOT之下的各个主键。（这样或许更易说明这一点）你是不是看到了很多前面有一个点（.），后面好象是文件扩展名的主键，如图二所示
如.bat,.txt,.lnk,.bmp等。我们把这一类的主键称之为“扩展名主键”，每个扩展名主键都有一个默认键值。如：主键.bat的默认值为batfile； .lnk主键的默认值为lnkfile。举了这两个例子，你是否看出了其中的规律。即：若“扩展名主键”名为.xxx(xxx为某一类文件的扩展名），那么它的默认键值就为xxxfile。当然并不是所有的默认值都是这样，也可能多个主键对应同一默认值。比如：主键.jpeg和主键.jpg，它们的默认值jpgfile;.html和htm的默认值都为htmlfile。为什么要说这么多的扩展名主键的默认值呢？其中原因且听我慢慢道来。这个默认键值的作用就非同小可了，它可是文件关联的桥梁和纽带，是它将文件的类型（以扩展名来标识文件类型）与文件的关联联系起来。不信，你可以将某一“扩展名主键”的默认键值乱改一通，你就会发现，该类文件的许多关联项在右键菜单中消失了。既然这个重要的默认键值起了一个桥梁的作用，那么桥梁的另一端――文件的关联又是如何定义的呢？我们继续看注册表，让它来给我们解释。依然是在HKEY_CLASSES_ROOT根键之下。我们可以看到该根键之下有如下主键。如：batfile,txtfile,lnkfile 等。（如图三）看到没有
这些主键好象都是刚才我们所说的“扩展名主键”的默认值。不错，上述默认值在此处正好变成了主键名――这就是桥梁。我们把这一类的主键称为“标识主键”。一般而言，在“标识主键”之下有以下几个重要主键：（如图四）
  DefaultIcon主键，它的功能是定义该类文件的默认图标。Shell主键，它的功能是本文讨论的中心――文件关联之“命根”所在。文件的各种关联都寄生在此“根”之下，正是它定义了该类文件与多个程序相关联。它的默认值也很有用，你是否还记得双击文件可以将文件打开(对于已注册的文件)，这种打开就是利用了系统注册表所设定的默认打开方式，即由shell主键的默认键值来控制。它之下的每个主键，都可称作是“关联主键”(如图4)。“关联主键”的键名是任意的(建议用英文)，它的默认键值也是我们感兴趣的。因为这一默认键
值会直接显示在右键菜单中，并且每个“关联主键”之下都有一个command主键，这个主键定义的就是“该关联对应的执行程序”。如图5所示，到此文件关联已昭然若揭。
图5
    下面我们就以.reg文件(注册表的脚本文件)为例来说明其关联过程。
图6
    首先.reg文件在HKEY_CLASSES_ROOT根键之下有一个“扩展名主键”。.reg其默认值为regfile,说明reg类型文件关联的主键是regfile。再在该根键之下找“标识主键”regfile,regfile主键之下有一个DfaultIcon主键，作用是定义reg文件的默认图标。其默认键就是图标的全路径文件名。如: C:windows egedit.exe,1(表示的是regedit.exe中的第2个图标)。regfile主键之下还有一个上文称之为“命根”的主键shell,reg文件的关联就记录在shell之中。下面我们就为regt建立一个关联。步骤为：在shell主键之下，新建主键xxf(名任意),置其默认值为：“徐喜峰的文本编辑器”，再在xxf主键之下新建主键command,置其默认值为C:WindowsNotepad.exe %1,该默认值的意义为：用记事本来打开当前reg文件。若没有%1参数，则只运行记事本程序，而不打开当前文件。设置完毕，你再看看reg文件的“右键菜单”，是不是多了一个“徐喜峰的文本编辑器”选项(如图6)，爽吧！~
以上所说的只是作用于普通文件的关联，然而在Windows中，除了文件，还有文件夹及特殊的文档(如我的电脑，驱动器，回收站等)。那么这些又该如何设置关联呢？那就请大家记住在HKEY_CLASSES_ROOT根键之下还有以下几个重要的系统关联主键：
    *：作用于所有文件，它与“标识主键”的关联方法一样。

    Directory：作用于一般文件夹。
    Folder：作用于所有文件夹，包括特殊文件，如：控制面板，回收站等。
    Drive：作用于驱动器，如A驱，B驱，C驱。
    Unknow：作用于系统不能识别的文件类型，即没有注册的文件类型。
    最基本的文件关联就谈到此处，下面来看看文件关联的应用。
    应用之一：让MS-DOS方式无处不在。
    经常用到DOS方式的朋友可能有些厌烦，因为每次进入DOS方式，都要选择“开始程序MS-DOS方式”。利用文件关联，我们可以将MS-DOS方式添加到任何文件的“右键菜单”中，这样就省事多了，方法为：将注册表展开到HKEY_CLASSES_ROOT*shell分支。(在所有文件的“右键菜单”中添加MS-DOS方式)新建主键“MS-DOS"，置其默认值为“进入MS-DOS方式”，在MS-DOS主键之下新建command主键，置其默认值为：“C:Windowsmmand.com”。另注册表展开到HKEY_CLASSES_ROOTFoldershell分支，(在所有文件夹的“右键菜单”中添加MS-DOS方式)设置同上。
    应用之二：隐去快捷方式图标中的小箭头。
    如果你觉得快捷方式图标中的小箭头有点障眼，那么利用关联，可以将之去掉，将注册表展开到HKEY_CLASSES_ROOTnkfile分支，将lnkfile主键之下的键值Isshortcut删除，再将注册表展开到HKEY_CLASSES_ROOTpiffile分支，将piffile主键之下的键值Isshortcut删除，即大功告成。
    应用之三：用记事本来编辑bat文件。
    有时想编辑bat文件，而习惯性地双击它，这一双击，并没有将它打开编辑，而是将它执行，让人甚为恼火。利用注册表的文件关联，可以将之改变。将注册表展开到HKEY_CLASSES_ROOTatfileshell分支，将shell主键的默认值由open改为edit即可。
    应用之四：更改某类文件的默认图标。
    以txt文件为例，将txt文件的图标改为“我的电脑”的图标。将注册表展开到HKEY_CLASSES_ROOT xtfileDefaultIcon分支，将主键DefautIcon的默认键值改为："C:Windowsxplorer.exe,0"即可。
    应用之五：为所有文件增加“打开方式”。
    将注册表展开到HKEY_CLASSES_ROOT*shell分支，新建主键open_as,置其默认值为“选择打开方式”，在Open_As主键之下新建主键command,置其默认值为："C:Windows undll32.exe shell32.dll , openAs_RunDll %1"
    应用之六：将“关机”加入到右键菜单。
    将注册表展开到HEKY_CLASSES_ROOTDirectoryshell分支，新建主键close,置其默认值为“关闭系统”，再在close主键之下，新建主键command,置其默认值为："C:Windows undll32.exe user.exe, exitwindows"
    以上六例应用，总体上能够概述文件关联的基本结构和基本框架，弄清了文件关联的结构与框架，自己再增加关联就是小菜一碟了。只要你有兴趣，你可以将你的右键菜单加得满满的。如果你想了解更深一层次的文件关联，那就请你参阅有关windows注册表方面的书籍与资料，或与我联系，我的Email是amen.twty@china.net。在文章结束之前，还告诉大家一点小小的诀窍：那就是注册表在作过修改之后，很多场合需要重新启动才能生效。这里我告诉大家一个不需要重启但又能快速更改注册表的方法：选择“开始关闭系统”，在弹出“关闭系统”框之后，按Ctrl+Alt+Del组合键，出现“结束任务”框，选择其中的“Explorer”，再单击“结束任务”，等待一会儿(10秒左右),就会出现一个“结束任务”确认框，点击“结束任务”按钮即可。


7b

藏陋网，解决电脑故障！ http://www.canglou.com/

详细内容请看网站！http://www.canglou.com/ 软件故障，注册表


7c

最近一些网页为了达到宣传的目的，利用IE的漏洞修改浏览者的注册表，肆意修改IE的首页、标题栏等内容，令人憎恶。本文按直接修改注册表和用MagicSet修改两个方法说明如何去除这些内容及防范。如果你对注册表比较熟悉，可参考本文所述的键值直接对其修改，如果对注册表不熟的话建议使用MagicSet即超级兔子魔法设置软件来改，安全且方便，本文以3.92版为例。

一、修改IE的标题栏

即在IE浏览器最上方的蓝色横条里做广告，而不是显示默认的“Microsoft Internet Explorer”。这种修改非常常见，有人也特意针对它编制了反修改的程序。

1.注册表法

HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main在注册表中找到以上两处主键，将其下的“Window Title”主键删除，并关闭所有打开的IE浏览器窗口再重新打开就能看到效果。

2.MagicSet法

点击“IE 4/5”，点击与“IE 标题”字体平行的“复原”按钮即可。

二、修改IE的首页

这个改回来很方便，在IE的设置里就有。比较麻烦的是某些网页在浏览者的硬盘里写入程序，使重启计算机后首页设置又被改了回去，这时可使用“系统配置实用程序”来解决。开始—运行，键入msconfig点击“确定”，在弹出的窗口中切换到“启动”选项卡，禁用可疑程序启动项。

三、在Windows启动时显示一个窗口，点确定才能进去

这个设置其实与IE无关，而是Windows的登录提示窗口，不过最近有些网页对它动上了脑筋，在这个窗口里做广告。

1.注册表法

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon在注册表中找到此主键，将其下的“LegalNoticeCaption”和“LegalNoticeText”主键删除即可

2.MagicSet法

点击“安全与多用户”，再点击左上角的“+”切换窗口后，清除“启动时要显示的标题”和“启动时要显示的信息”两项内容即可。

四、在IE里点击鼠标右键。在弹出的菜单里显示网页广告

这种情况很少见，我还没碰到过，不过解决方法也不复杂。

1.注册表法

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt在IE中显示的附加右键菜单都在这里设置，常见的网络蚂蚁和网际快车点击右键下载的信息也存放在这里，只需找到显示广告的主键条目删除即可。

2.MagicSet法

点击“IE 4/5”，再点击左上角的“+”切换窗口后，在上方的列表窗口中即可修改、删除IE的附加右键菜单项。

五、防范

1.因为修改注册表设置都是用的＆#106avascript脚本语言，所以只需禁用它即可。但这种脚本语言应用广泛，所以建议在IE的设置中将脚本设为“提示”。

2.建议使用一些单窗口多页面的浏览器如NetCaptor等，因为它们往往能更方便地切换脚本设置，象我常用的NetCaptor，用工具栏中的“安全”按钮能很方便地设置脚本、ActiveX和Cookie的启用情况。

3.使用IE6.0，虽然迟迟看不到这个浏览器的正式版本，而且测试版问题很多，但据用过的人说使用它浏览网页，将无法再随意修改你的注册表。

4.使用Win2000的朋友，只需在“控制面板”—“管理工具”—“服务”中禁用Remote Registry Service服务，也无法通过浏览网页来修改你的注册表了。

5.使用Norton AntiVirus 2002 v8.0杀毒软件，这个版本新增Script Blocking功能，将通过IE修改注册表的代码定义为Trojan.Offensive并予以拦截。

六、相关软件

1.MagicSet2002 （超级兔子魔法设置）
藏陋网“软件下载”中提供下载。

2.IE浏览器状态恢复器 V1.2 Build 1210
在此下载
智能删除IE右键中的链接、IE工具栏中的链接和Windows自动运行中的链接，恢复IE右键的功能。

七、快速恢复

将以下内容复制粘贴到记事本，并存为UnDoIE.reg文件，注意在保存时选“保存类型”为所有文件，这样它在保存时就不会自动加上.txt的后缀名了。

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
"Window Title"="Microsoft Internet Explorer"
"Start Page"="about＆#58blank"

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Window Title"="Microsoft Internet Explorer"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon]
"LegalNoticeCaption"=""
"LegalNoticeText"=""

在发现上述IE相关设置被网页修改后，双击UnDoIE.reg即可将上述一、二及三项同时复原了。


7d

世界万事万物都是在不断的发展，不停地变化的,搞恶作剧的人也是诡计多端，招数层出不穷！对 IE 的修改，把自己的网站强硬推荐给别人的手法时时换新，防不胜防！同时，恶作剧的人数也越来越多，各类型的网站都参加了进去，除了原来的黄色网站、美女图库网站以外，又增加了笑话网站、注册表网站、一些乱七八糟的个人网站，包罗万象，数不胜数！也就是说，整个互联网几乎都是这样的陷井，只要你上了网，就有可能中招，就有可能掉进去！

在此希望恶作剧的网友们手下留情、放过许许多多的无辜大众，错全是微软的错，有本事讨伐微软去！

闲话少说，言归正传。

面对招术的多样化，也限于笔者能力，本文只能对“矛”的“硬度”，“矛尖”的“粗细”，“矛”的使用方法作一个详细的剖析说明，以供网友们作马后炮用。

现行招术主要有三种：一、修改 IE 标题栏；二、修改 IE 右键菜单；三、在 windows 启动时增加一个弹出窗口。接下来一一为大家剖析。

一、IE 标题栏被修改

    根据网友们的来信与及自己遭遇的情况（有的网友写得清楚明白，有的只提供网址，作者根据网址自己去测试），恶作剧的手法多数是修改注册表中“IE”的两个键值，一个是：“Windows Title”，另一个是：“StartPage”，尽管只是修改此两个键值，但这两个键值可以存放于三个位置，分别是:

    1.[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

    2.[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]

    3.[HKEY_USERs\.DEFAULT\Software\Microsoft\Internet Explorer\Main]

    也就是说，只要修改此三个位置的任何一个都可使得IE浏览器标题栏发生改变。

    在早期，恶作剧的人一般只是修改第二个位置的键值，所以笔者之前做的注册表文件也只适用于这种修改的情况。

    现在，修改任意位置的都有，有些每个位置只修改一个键值，有的更是绝，全部键值都被修改了，于是，当我们只是恢复单个位置的注册表键值时，并没有完全恢复 IE的标题栏。

    所以，针对目前的情况，作者做了三个位置的注册表，先把内容提供给网友，让大家了解了解它的原理，内容如下：

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Window Title"="Microsoft Internet Explorer"

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Start Page"="about:blank"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]

"Window Title"="Microsoft Internet Explorer"

[HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]

"Start Page"="about:blank"

[HKEY_USERs\.DEFAULT\Software\Microsoft\Internet Explorer\Main]

"Window Title"="Microsoft Internet Explorer"

[HKEY_USER\.DEFAULT\Software\Microsoft\Internet Explorer\Main]

"Start Page"="about:blank"

    喜欢研究注册表的网友自己通过“开始 -> 运行 -> regedit”进入注册表相应位置，直接修改。也可以参看此文：“浏览一些网站，为什么IE被修改？”。

    不过还是提醒对注册表没有一定了解的网友不要按照此种方式去操作，一个误操作，可能会引起整个系统的崩溃。尽管可以恢复，但无疑会耽误了对您的时间，影响了您的工作。

简单的解决办法有两个：

    1.修改注册表法

    点击这里下载笔者做好的注册表文件。

    2.兔子魔法(MagicSet)法

    本法是基于超级兔子魔法设置 3.92 ，网友们可以去下载安装程序：

    也可以到软件作者的网址去下载最新的版本：

    下面笔者以自己中招之后的修改过程作介绍。

    安装完成之后，启动兔子魔法，显示了主界面：

    点击“IE”图标民，软件将弹出如下图所示的设置窗口。

    笔者的 IE 被修改了默认打开的网页，需要把它改回本机网站“127.0.0.1”，那么直接在此栏输入“127.0.0.1”，点击“保存”按钮，即可完成恢复。网友们可以输入其它网址，把它改成自己上网常常访问的网站。

    如果不希望改成其它网站，点击“使用空白页”按钮，当打开 IE 时，显示的是什么内容也没有的空白网页。

    如果 IE 标题也被修改了，那么请点击“复原”按钮。

    如果 IE 版本号被修改，只能直接在输入框中输入来恢复。

    都时我们也注意到，Outlook 微软的收取邮件软件也可以被修改，兔子魔法为大家考虑非常周到，按照上述方法，大家一样可以使它复原。

二、修改 IE 右键菜单

    这种情况很少见，没有看到网友来信，笔者也没碰到过。也许众多的恶作剧的人还不会这种方法，我们也有理由相信，真正的高手不会整广大访问他们网站的网友，另外，如果网站做得好，根本不需要在网页中加入个性别人电脑来增加访问量，网友们自动就会把它加入收藏夹！！！

    这是通过修改注册表的“HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt”，在此位置添加键值来实现的，在IE中显示的附加右键菜单都在这里设置，认识了原理，解决问题就简单多了。

    1.注册表法

    通过“开始 -> 运行 -> regedit”进入注册表，来到“HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt”位置，点击文件夹的“＋”号，我们可以看到常见的下载软件网际快车右键下载和“添加QQ网络收藏夹”等等的信息

    选中不需要的主键，右击鼠标，选择删除命令，重新启动 IE 浏览器即可看到效果。笔者不是 QQ 会员，“QQ网络收藏夹”也用不上，就按图中的方法，把它删除了。让我们来作个修改前后的对比：

    2.兔子魔法(MagicSet)法

    启动兔子魔法，点击 IE 图标按钮，在弹出的窗口左上方有一个“＋”按钮 ，点击此按钮即可进入到 IE 的深入设置窗口。在“IE5 的新增的右键菜单”栏把 IE 的相应附加右键菜单项删除，然后点击“保存”按钮确定修改。

    如果你没有注册，软件不提供此项功能，弹出的窗口文字呈灰色，全部不可选。

    现在有一种最最可恶的改变别人电脑的方法，那就是：

    三、在 windows 启动时弹出一个窗口

    这种个修改方法并不是修改了IE，但都是利用了 IE 的漏洞，运行 Script 脚本，修改了注册表。当 windows 启动时，弹出一个窗口，必须点击确定才能进入操作系统，与此同时，自动运行 IE 并访问某个网站。实质上，它修改了下面的注册表键值：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    在此仍然提供两种解决方法。

    1.注册表法

    选择“开始 -> 运行 -> regedit”，进入注册表，来到：

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon

    在此项右栏找到“LegalNoticeCaption”和“LegalNoticeText”主键，把它们删除即可。

    注意，在非 winNT 系列中，就是在上面的分支中寻找需要删除的主键，但在 winNT 系统中，Winlogon在下面的分支中：

“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon”

    另外笔者注意到，恶作剧的代码对于 windows 2000 server 无效，其它的 windows NT 版本笔者没有测试过。因为读者来信写到他的 windows 98 系统遭到了修改，当笔者访问来信提供的网址时，没有发生任何变化。如果有网友被修改了，可以按类似的方法来修复。

    简单方便的方法当然是：

    2.兔子魔法(MagicSet)法

    启动兔子魔法后，点击“安全与多用户”，再点击左上部的“+”号按钮，来到如下图所示的窗口：

    把“启动时要显示的标题”和“启动时要显示的信息”两项内容删除，按“保存”按钮，重新启动操作系统，你将不再看到弹出的窗口。

    预防方法是：

“1.到IE里禁止javascript脚本的运行，因为脚本没有运行，就写不了信息到注册表，不过其它的脚本也运行不了了，对于另一些加了脚本才能正常显示的网页就不好了，那样浏览者将看不到网页设计者的愿意，或者网页提供的某些功能使用不上。

2.把上页生成的iechange.reg注册表文件保存起来，遇到情况运行此文件。

3.把IE版本升级到IE6.0，因为该脚本对IE6.0不起作用。”

    上述方法中的第一条对于三者都适用，第二条对于前两者适用，第三条的 IE 6.0 新版本已经抵抗不了三类恶作剧了，估计是之前所说的 IE 6.0 版本不支持恶作剧脚本，所以修改情况没有发生。

    有矛就有盾，有盾矛更尖，矛尖盾更硬！

    针对上述的恶作剧，网友们也想出了相应的解决办法：

四、预防方法

    1.到IE里禁止javascript脚本的运行。由于现在的网页多数插入了脚本，以达到一定的功能和实现相应的效果，因此，这种喝鸠解渴的方法并实用，建议在IE的设置中将脚本设为“提示”。

    2.使用 Windows 2000 系列操作系统，可在一定的程度上遏制恶作剧，比如禁止启动时弹出窗口。

    3.在 Win2000 操作系列中，为了增强安全性能，设置有管理工具，我们进入“控制面板” ->“管理工具” -> “服务”，把 Remote Registry Service 服务禁止，浏览网页时恶作剧无法修改注册表了。

    注：此法对于某些情况可能无效。

    4.建议安装 Norton AntiVirus 2002 v8.0 杀毒软件，此软件已经把通过IE修改注册表的代码定义为 Trojan.Offensive ，增加了 Script Blocking 功能，它将对此类恶作剧进行监控，并予以拦截。它也是目前最好的解决方法。

    5.下载这个文件至桌面，当IE被修改时请双击


7e

一天，朋友打电话求援，计算机启动后自动打开一连串的网页，并限制对主页属性窗口的修改等，让他很是苦恼。笔者快速地赶到，修复了机器。若问是如何妙手回春，请听我细细道来。

    亡羊补牢

    1、解开被禁用的注册表

    执行软盘中的“unlockreg.reg”文件，此文件是用记事本建立一个以REG为后缀名的文件，文件名可自定义，内容如下：

    REGEDIT4

    空一行[HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System] "DisableRegistryTools"=dword:00000000

    要注意的是，在“REGEDIT4”一定要大写(如果你是Windows 2000或Windows XP用户，请将“REGEDIT4”写为“Windows Registry Editor Version 5.00)”，且后面要空一行，并且“REGEDIT4”中“T”和“4”之间一定不能有空格，否则……

    注册表解开了，下面就要对症下药，对注册表进行修改了。

    2、解决IE属性主页不能修改

    打开注册表，展开注册表到

    HKEY_USERS＼.DEFAULT＼Software＼Policies＼Microsoft＼Internet Explorer＼Control Panel下，将“homepage”的键值由原来的“1”修改为“0”即可，或干脆将“Control Panel”删除就可以了!

    3、修改IE的标题栏

    HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Main HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main

    在注册表中找到以上两处主键，将其下的“Window Title”主键值更改为“Microsoft Internet Explorer”即可。

    4、IE默认连接首页被修改

    被更改的注册表项目为：HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main＼Start Page将键值修改为自己喜欢的网址即可。

    5、删除自运行程序

    打开“HKEY_CURRENT_USER＼ Software＼ Microsoft＼ Windows＼ CurrentVesion＼”及“＼HKEY_LOCALMA CHINE＼Software＼Microsoft＼ Windows＼CurrentVersion＼”，在其下的RUN文件夹中，有许多Windows启动时便开始运行的程序，但是在菜单“开始/程序/启动”中却找不到。把自运行程序删除就可以了。

    6、右键菜单中的网页广告

    将注册表展开到HKEY_CURRENT_ USER＼Software＼Microsoft＼Internet Explorer＼MenuExt，在IE中显示的附加右键菜单都在这里设置，常见的“网络蚂蚁”和“网际快车”点击右键下载的信息也存放在这里，只需找到显示广告的主键条目删除即可。

    7、启动时的提示窗口

    这个设置其实与IE无关，而是Windows的登录提示窗口，不过最近有些网页对它动上了脑筋，在这个窗口里做广告。

    受到更改的注册表项目为：HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Winlogon在其下被建立了字符串“LegalNotice-Caption”和“LegalNoticeText”，其中“LegalNoticeCaption”是提示框的标题，“LegalNoticeText”是提示框的文本内容。这就使得我们每次登录到Windows桌面前都出现一个提示窗口，显示那些网页的广告信息。

    8、恢复“运行”选项

    在注册表中展开至HKEY_USERS/.DEFAULT/Software/Microsoft/Windows/CurrentVersion/Policies/Explorer，在右侧栏中将“NoRun”的键值由“1”修改为“0”即可，或者将“NoRun”删除也可。

    经过一番辛苦的修改，完全解除了某些网站上的恶意程序对系统的限制，可是如果不小心又访问了该网站，岂不是又重蹈覆辙，其实，你可以在IE中做一些设置以便永远不进入该站点：打开IE，点击“工具→Internet选项→内容→分级审查”，点击[启用]按钮，会调出“分级审查”对话框，然后点击“许可站点”标签，输入不想去的网站网址，按[从不]按钮，再点击[确定]即大功告成！

    防患未然

    上面的解决方法乃下策，要想不发生类似的情况，上策是加强预防，对于预防的方法笔者提如下几点建议：

    1、要避免中招，关键是不要轻易去一些自己并不了解的站点，特别是那些看上去美丽诱人的网址更不要贸然前往，否则吃亏的往往是你。

    2、由于该类网页是含有有害代码的ActiveX网页文件，因此在IE设置中将ActiveX插件和控件、Java脚本等全部禁止就可以避免中招。具体方法是：在IE窗口中点击“工具→Internet选项”，在弹出的对话框中选择“安全”标签，再点击［自定义级别］按钮，就会弹出“安全设置”对话框，把其中所有ActiveX插件和控件以及Java相关全部选择“禁用”即可。不过，这样做在以后的网页浏览过程中可能会造成一些正常使用ActiveX的网站无法浏览。有利就有弊，你还是自己看着办吧。

    3、建议安装Norton AntiVirus 2002 V8.0杀毒软件，此软件已经把通过IE修改注册表的代码定义为Trojan.Offensive ，增加了Script Blocking功能，它将对此类恶作剧进行监控，并予以拦截。

    4、既然这类网页是通过修改注册表来破坏我们的系统，那么我们可以事先把注册表加锁：禁止修改注册表，这样就可以达到预防的目的。不过，自己要使用注册表编辑器Regedit.exe该怎么办呢？因此我们还要在此前事先准备一把“钥匙”，以便打开这把“锁”！

    加锁方法如下：

    展开注册表到HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System下，新建一个名为DisableRegistryTools的DWORD值，并将其值改为“1”，即可禁止使用注册表编辑器Regedit.exe。

    5、对Windows 2000用户，还可以通过在Windows 2000下把服务里面的远程注册表操作服务“Remote Registry Service”禁用，来对付该类网页。具体方法是：点击“管理工具→服务→Remote Registry Service(允许远程注册表操作)”，将这一项禁用即可。

    6、升级你的IE为6.0版本，可以有效防范上面这些症状。

    7、下载微软最新的Microsoft Windows Script 5.6，可以预防上面所说的现象，更可预防目前流行的、可恶的混客绝情炸弹


7f

 最近，一些朋友说，他们的IE默认主页被设置成其它网站，在IE里怎么也改不过来，有的，甚至改了IE标题栏，很让人厌烦。我最近研究了一下，发现这些网友一般都访问了一个嵌入了可修改注册表的Java Applet程序的网页所致（恕我不能提供给你代码）。所以，要彻底修改的话，还得修改注册表。有一位网友为此写了他的遭遇与解决办法。如果你遇到了这种情况的话，就不妨改注册表里的HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main里的相关键值，另外，如果注册表还是不行的话，就要查一查有没有所谓的vbs文件，然后再改注册表。

    最近，我的电脑发生了一个奇怪的现象，浏览器的默认主页被自动设为http://www.globesearch.com/，一开始我并没有留意，心想只要在IE的"Internet选项"中修改回原来的设置就可以了，修改后，果然没事了，但第二天开机，又被改回去了。细想一下，这也难不住我，肯定是把默认主页信息写在注册表中，只要找到它，删除不就行了。于是，使用REGEDIT命令打开注册表，按Ctrl+F搜索字符串http://www.globesearch.com/，果然找到了两处，就在IE的设置中，一项为"Start Page"，另一项是，"Default_Page_URL"，不禁心中一喜，原来这么简单，删除它们。再打开浏览器，果然消除了这个诡异添加的默认主页。这么简单的问题，难不住我的，哈哈。

    可是，当我再次打开电脑，默认主页又变成http://www.globesearch.com/，这次还有点把我难住了，再仔细一想，又明白了，肯定是在我的机器上安装了什么可执行文件，在windows启动时，自动执行，这个可扫行文件自动又把注册表的Internet Explorer设置改回去了，想到这里，立即动手，打开注册表，找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run一项，里面没有什么特别的东西，再找HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx，还是没有。

    不过这也难不住我，毕竟是有4年网龄的老网虫了，遇到问题，我喜欢使用搜索引擎查一下，看一看别人是否遇到过同类问题，总应该有高手想到解决办法了吧！经过几次搜索和查找，我有些失望了，查到了内容都是介绍这种现象的，说是一种新型病毒，一些杀毒软件可以查杀，可我试过几种都不行。难道要我重新安装windows吗？我用的可是windows 2000 professional，安装一次要费我多少时间，何况还有那么多的软件和资料需要备份，哎，还是自己想想办法吧！

    几经努力，终于彻底解决了这个小难题，现整理出来，或许对大家有所帮助。下面介绍一下在windows 2000 下的解决方法：在"我的电脑"上单击右键，执行"管理"命令选单，找到"系统工具－系统信息－软件环境－启动程序"一项单击，在列出的启动所项中，是不是有一个奇怪的执行系统目录中一个扩展名为.vbs文件的项目，哈哈，就是它。看一看它在注册表中位置，找到并删除它。然后再把这个.vbs文件删除，你成功了。最后别忘了删除HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main中的"Start Page"和"Default_Page_URL"两项。重新启动windows，诡异添加的默认主页不再出现了。

    我没有在windows98上进行测试，不过方法应该大同小异，关键是如何找到这个.vbs文件，我想最简单的办法就是利用windows提供的查找工具，找到文件内容包含那个默认主页网址的文件，然后删除它，并在注册表中搜索包含那个文件名的项，找到后删除，就可以解决了


NewTopic

藏陋网，解决电脑故障！ http://www.canglou.com/

超级兔子魔法设置 2004 完全版
1、全新的操作界面，轻松使用、管理所有的超级兔子软件，提供在线升级功能。2、修正魔法设置多个原有的小错误，如：清除搜索的记录；同时添加识别更多的自动运行程序。3、内带超级兔子软件优化 v5.2，修正原有的重复搜索错误。4、内带超级兔子注册表优化 v5.35，修正原有的无法还原错误。5、内带超级兔子修理专家3.91，支持winxp sp1，可以将ie6快捷网址.com.cn和.co.cn改成.com。6、内带超级兔子ie保护器 v3.92，修正无法清除多个自动运行的错误。7、内带超级兔子内存整理 v2.5。8，超级兔子系统检测 v2.6 等。
点击下载


优化大师

windows优化大师 5.71 build 1030 注册版
从桌面到网络，从注册表清理到垃圾文件扫除，从黑客搜索到系统检测，windows优化大师都给您比较全面的解决方案。

最新功能：
windows优化大师 5.71 build 1030版更新如下：
1、修正了部分系统第一次运行windows优化大师后第二次无法进入的错误。
2、修正了注册表清理的兼容性问题。
3、修正了垃圾文件清理模块检测文件是否正被使用的参数传递错误。
4、修正了目录统计在统计超过5g的目录显示容量越界的错误。
5、集成了windows系统医生等配套软件的最新版本。

windows优化大师 5.7 build 1023版更新如下：
1、改进了注册表清理，提高了兼容性、稳定性和易用性。
2、改进了系统信息检测，能更加准确地检测更多新硬件。
3、改进了软件智能卸载，能智能分析更多的可卸载内容。
4、改进了冗余dll清理，提高了兼容性。
5、改进了磁盘缓存优化，提高了兼容性。
6、改进了系统磁盘医生，提高了可靠性。
7、集成了windows内存整理的最新版。
8、集成了windows系统医生的最新版。
9、集成了windows进程管理和windows文件粉碎机的改进版。
点击下载


63

藏陋网，解决电脑故障！ http://www.canglou.com/

本软件是一个注册表修改软件!使用本软件可轻松地修改Win98系统设置。使您立刻成为注册表专家！通过本软件你将不用使用繁杂的注册表编辑，而是通过图形化的界面让您直观的定制自已的操作系统，扩展Windows系统功能，建立完全个性的应用界面，方便自已的日常操作和管理。V0.4是一次较大的升级！改进了软件的界面，感觉更酷，使用起来更加方便。对于WINDOWS界面图标的修改不用重新启动即刻就可生效。增加了一些新功能。


开发过程

第一次认识注册表，已经不知道是什么时候的事情了，经常为别人解决电脑故障，要修改注册表的地方也颇为不少，于是除了自己实践，还经常上网找资料，但是结果总是不够令人满意，几乎没有一个非常完全详细的介绍注册表的中文网站，都是零零碎碎的东一些，西一些，比较难找。还有的介绍注册表的电子书籍不是不完善就是要收费，甚是可恼，于是这本《注册表超级全攻略》就诞生了萌芽，后来经过几个星期的不眠之夜,终于完成了这个算是比较完善的注册表超级全攻略! 其中winXP部分全部为原创，因为这么新的注册表文章难以找到，其他部分有原创也有转载。本书内容全面，修改系统项目近一千项，可操作性强，从简入难，即使没有动过注册表的也可以照着一步一步做，是一本不可多得的注册表与深入系统的实用技术手册，适合于广大计算机爱好者。
最后，希望大家努力支持我们的藏陋网 ！

作者：xiaofei
联系：http://www.canglou.com


7g

藏陋网，解决电脑故障！ http://www.canglou.com/


7h

藏陋网，解决电脑故障！ http://www.canglou.com/