注册表之芝麻开门

注册表之天下无敌

2000-09-22· 毛金波整理
江南工作室

    注册表是Windows系统存储关于计算机配置信息的数据库，包括了系统运行时需要调用的运行方式的设置。但其烦琐的芝麻型结构导致我们“望表而退”。所以，在这里我们准备用这把钥匙来打开整个注册表，来了解注册表。这样我们便可以修改注册表或使用一些注册表工具来优化我们的系统。


注册表由来
2000-06-20· 生哥·yesky

PC机及其操作系统的一个特点就是允许用户按照自己的要求对计算机系统的硬件和软件进行各种各样的配置。早期的图形操作系统，如Win3.x中，对软硬件工作环境的配置是通过对扩展名为.ini的文件进行修改来完成的，但INI文件管理起来很不方便，因为每种设备或应用程序都得有自己的INI文件，并且在网络上难以实现远程访问。

为了克服上述这些问题，在Windows 95及其后继版本中，采用了一种叫做“注册表”的数据库来统一进行管理，将各种信息资源集中起来并存储各种配置信息。按照这一原则，Windows各版本中都采用了将应用程序和计算机系统全部配置信息容纳在一起的注册表，用来管理应用程序和文件的关联、硬件设备说明、状态属性以及各种状态信息和数据等。

与INI文件不同的是：
1.注册表采用了二进制形式登录数据；
2.注册表支持子键，各级子关键字都有自己的“键值”；
3.注册表中的键值项可以包含可执行代码，而不是简单的字串；
4.在同一台计算机上，注册表可以存储多个用户的特性。

注册表的特点有：
1.注册表允许对硬件、系统参数、应用程序和设备驱动程序进行跟踪配置，这使得修改某些设置后不用重新启动成为可能。
2.注册表中登录的硬件部分数据可以支持高版本Windows的即插即用特性。当Windows检测到机器上的新设备时，就把有关数据保存到注册表中，另外，还可以避免新设备与原有设备之间的资源冲突。
3.管理人员和用户通过注册表可以在网络上检查系统的配置和设置，使得远程管理得以实现。

我们在前面已经详细介绍了注册表的由来与基本结构。发现注册表比较复杂，但又安排得非常有条理，能有效地提高工作效率，为系统的维护提供了必要条件。由于注册表是一个二进制的配置数据库文件（Windows的命根子），因而，用户无法直接存取注册表。为了让高级用户能够编辑注册表,Windows2000提供了注册表编辑器“c”和“Regedt32”。对这种只使用Windows提供的注册表编辑器进行编辑的操作。

编辑器在安装Windows时已经被安装到硬盘中了，但是并未在“附件”程序组中建有快捷方式。用户如果需要使用注册表编辑器，可以在“运行”对话框内输入Regedt32或Regedit即可打开注册表编辑器，如图：

    或者在“命令提示符”中执行Regedt32.exe也可以进入注册表编辑器，
    如图：

    后面的内容将介绍注册表编辑器的使用方法，如创建删除主键、子键以及键值等，同时还将给出一些修改注册表的实例。


注册表数据结构(一）
2000-06-20· 生哥·yesky

    使用注册表编辑器之前，首先得了解注册表的数据结构，例如注册表的显示方式、主键与子键、键值项数据的类型等等。

注册表显示方式
在Windows系统中，注册表是采用“关键字”及其“键值”来描述登录项及其数据的。所有的关键字都是以“HKEY”作为前缀开头。实际上，“关键字”是一个句柄。这种约定使得系统及应用程序的开发人员，可以在使用注册表中的API函数时把它用于应用程序的开发中。为此，Windows提供了若干API函数，以便在开发 for Windows 应用程序时添加、修改、查询和删除注册表的登录项。

在注册表中，关键字可以分为两类：一类是由系统定义的，一般都称为“预定义关键字”；另一类是由应用程序定义的，由于安装的应用软件不同，其登录项也就不同。在Windows系统中，打开注册表编辑器，可以看到注册表中的关键字，如图:

    注册表通过主关键字（最上层的为“根键”，例如下图中的HKEY_CURRENT_USERS就是一个根键，标题栏上也有显示）和子键来管理各种信息，下图中的“Keyboard Layout”是一个主键，展开后就可以看到它里面的子键。注册表中的所有信息是以各种形式的“键值项数据”保存下来，如下图中的键值项Attributes的数据为“REG_DWORD:0”。其中“REG_DWORD”是该键值的数据类型；“0”是代表该键值被赋予的数值。

    在注册表的左边窗口中，所有的数据都是通过一种树状结构，以键和子键的方式组织起来，十分类似于资源管理器内的目录结构，如下图。每个键都包含有一组特定的信息，每个键的键名都是与它所包含的信息相关的（注册表内是以英文的方式出现，比如‘Control Panel’表示的是控制面板内的一些内容）。

    如果这个键包含子键，则在注册表编辑器窗口的左边出现一个“＋”号，用来表示在这个文件夹内还有好多内容。如果这个文件夹被用户打开了，那么“＋”号就变为“－”号，与我们使用资源管理器的方法是一样的，如图:


注册表数据类型(二）
2000-06-21· 生哥·Yesky

注册表中的“键值数据项”的类型
     在注册表中，“键值项数据”可分为下面三种类型。

二进制(BINARY)
     在注册表中，二进制是没有长度限制的，可以是任意个字节的长度。在注册表编辑器中，二进制数据以十六进制的方式显示出来，如下图中的“CustomColors”的键值就是一个二进制数据，
如图:

    双击键值名，出现如下图所示的“编辑二进制数值”对话框，我们可以在二进制和十六进制之间进行切换。

DWORD值(DWORD)
     DWORD值是一个32位（4个字节，即双字）长度的数值。在注册表编辑器中，你将会发现系统以十六进制的方式显示DWORD值，如图:

    在编辑DWORD数值时，可以选择用二进制、十进制或是十六进制的方式进行输入，如图:

字符串值(SZ)
     在注册表中，字符串值一般用来表示文件的描述、硬件的标识等。通常它由字母和数字组成。下图文本输入栏中的内容即为一个键值，它是一种字符串值类型。通过键值名、键值就可以组成一种键值项数据，这就相当于Win.ini、System.ini文件中小节下的设置行。其实，使用注册表编辑器将这些键值项数据导出后，其形式与.ini文件中的设置完全一样。

注册表数据类型
     注册表的键中包含着各种不同格式的数据。数据类型可以这样来分类：

通用数据类型－－RegEdit、RegEdt32及其它绝大多数注册表工具都支持，并能够对之进行编辑的数据类型。
Windows NT 专用数据类型－－RegEdt32和另外几个注册表工具支持，并能够对其进行编辑的数据类型。
组件／应用程序专用的特殊数据类型－－注册表工具支持这些数据类型，但是对于程序而言是有限度的。
用户则只能将其作为二进制数进行编辑。

    实际上，注册表工具也可以对不支持的数据类型进行编辑，包括那些显示为REG_UNKNOWN类型的数据。但是编辑仅能在二进制模式下进行，这就需要用户对数据对象的格式非常了解。对于那些需要手工修改注册表的用户来说，理解每一种数据类型以及每一种类型数据的存储格式是非常重要的。

现有注册表数据类型

类 型 | 类型索引 | 大 小 | 说 明
REG_BINARY | 3 | 0~多个字节 | 可以包含任何数据的二进制对象颜色描述
REG_COLOR_RGB | * | 4字节 | 颜色描述
REG_DWORD | 4 | 4字节 | DWORD值
REG_DWORD_BIG_ENDIAN | 5 | 4字节 | 一个DWORD值的逆序存储形式
REG_DWORD_LITTLE_ENDIAN | 4 | 4字节 | DWORD值
REG_EXPAND_SZ | 2 | 0~多个字节 | 包含环境变量占位符的字符串
REG_FILE_NAME | * | 0~多个字节 | 文件名
REG_FILE_TIME | * | 未知 | 文件时间
REG_FULL_RESOURCE_DESCRIPTOR | 9 | 未知 | 硬件资源列表
REG_LINK | 6 | 0~多个字节 | 命名一个符号链接(symbolic link)的Unicode串
REG_MULTI_SZ | 7 | 0~多个字节 | 以null字符分隔的字符串集合，集合中的最后一个字符串以两个null字符结尾
REG_NONE | 0 | 未知 | REG_NONE类型的对象无须分类，它与REG_UNKNOWN类型不同
REG_RESOURCE_LIST | 8 | 未知 | 设备使用的资源列表
REG_RESOURCE_REQUIREMENTS_ LIST | 10 | 未知 | 驱动程序要求的资源列表
REG_SZ | 1 | 0~多个字节 | 以一个null字符线的字符串
REG_UNKNOWN | （未定义） | 未知 | 因为数据类型索引无效而无法确定的对象类型


编辑主键与键值
2000-06-25· 生哥·yesky

使用注册表编辑器，你可以在注册表中编辑主键（或子键），同时也可以修改键值项数据。

建立主键（或子键）
 在注册表中，注册表编辑器左窗格显示主键或者子键的分层次关系。除此之外，你还可以在左窗格内创建新的主键（或子键）。

例如，我们需要在HKEY_CURRENT_USER\Software分支下创建一个“电脑世界”的主键（或子键）。

首先用注册表编辑工具打开注册表，然后再找到HKEY_CURRENT_USER\Software分支；再单击“编辑”菜单下的“添加项”命令，如图:

弹出“添加项”对话框，我们在项名称文本输入框内输入“电脑世界”，然后再单击“确定”按钮，如图：

在Software主键下将出现新建立的“电脑世界”主键（或子键），如图：

建立注册表键值项数据
 建立键值项的方法非常简单，例如在注册表中打开“HKEY_CURRENT_USER\Software\电脑世界”分支；再单击“编辑”菜单下的“添加数值”命令，如图：

弹出“添加数值”对话框，在数值名称文本框内输入“RegisterNewInfo”；在数据类型下拉列表中选择数据类型，如图：

单击数据类型下拉列表，弹出各种数据类型，如图：

我们选择REG_SZ字符串类型，在字符串文本框内输入内容，再单击“确定”按钮，如图：

这样就建立好了一个键值，它出现在窗口的右边，如图：

删除主键（或子键）
 如果我们需要将一个键值项删除掉。首先选择该键值，然后再单击“编辑”菜单下的“删除”按钮，弹出确认删除的对话框，如图：

单击“是（Y）”按钮，该键值项数据将从注册表中被删除掉。

删除无用的主键（或子键），是一个减少注册表大小的好方法，先选择好要删除的某些不重要的主键（或者子键）分支，在删除这些分支之前，确认这些分支是否无用或者冗余。然后再单击“编辑”菜单下的“删除”命令，弹出如下图的对话框。

单击“是(Y)”按钮后，该主键（或子键）将从注册表中删除掉。


导出与引入注册表
2000-06-27· 生哥·yesky

导出与引入注册表
    注册表是以二进制方式存储在硬盘上。我们在修改注册表的时候难免会引起一些问题，甚至是致命的故障。那么对注册表文件进行备份和恢复就具有非常的意义。除此之外，你还可以将注册表中的某一主键或子键保存为文本文件，并且打印出来，用来研究注册表的结构。

导出注册表文件
    作为备份功能，我们可以在Regedit编辑器下单击“注册表”菜单下的“导出注册表文件”命令，并选择导出范围为“全部”，将注册表文件备份在硬盘上。而作为一般的备份工作，在Regedt32中就可以完成了，比如保存一个根键，或者一个主键（子键）。

    在注册表编辑器Regedt32中保存注册表内的数据，可以保存根键、主键或一个子键。先选择要保存的主键或子键，然后再单击“注册表／保存项”命令，如图：

    接着弹出“保存项”对话框，在这里输入要保存的注册表文件的文件名，扩展名一般都使用REG，如图：

    至于某些主键或子键，因为其使用的用户不同，或者是该主键或子键正在被系统使用，会提示禁止访问的警告，如图：

    如果你是系统管理员，对某些主键或子键可以为其赋予权限，比如在注册表编辑中为一个用户设置修改打印机的权限。操作时请单击“安全”菜单下的“权限”命令，如图：

    出现“注册表项的权限”对话框，在名称中选择某一个用户，然后在“访问类型”下拉列表中选择访问类型，如图：

    访问类型一共有三种，分别是：“读取”、“完全控制”、“选择性访问”。选择好后完全控制后再单击“确定”按钮。
    如果要查看能修改某一个主键或子键的所有者名字，请在“安全”菜单下选择“所有者”命令，将弹出如下图所示的对话框，如果你使用系统的权限比该用户的权限更高，请单击“取得所有权”按钮，就能对该主键或子键进行修改，如图：

    否则只能查看该所有者，然后再单击“关闭”按钮退出。

    我们还可以将注册表文件导出为文本文件，操作的方法是用鼠标选择“注册表／将子目录树另存为”命令，并将其命名为扩展名为TXT的文件后，再单击“保存”按钮。这样我们就可以使用Windwos的写字板或记事本来查看。

引入注册表文件
    引入注册表文件有两种方法，一种是将现有的一个主键进行还原，就是利用以前备份的注册表文件或通过其它渠道获得的注册表文件，来覆盖现有的主键。

    操作时请单击“注册表”菜单下的“还原”命令，并在“还原项”窗口中选择要还原的注册表文件（注意被选择的文件是与现在所选择的主键内容相同的），最后单击“打开”按钮，如图：

    将弹出一个“警告”对话框，如图：

    对话框内询问是否进行覆盖现有主键的操作，注意是将还原该项到当前选定的项上，两项内容必须吻合。
    另外一种引入的方法是加载配置单元，请先用鼠标选择一个主键，再选择“注册表”菜单下的“加载配置单元”命令（与还原不同的是，它引入的主键可能是注册表内没有的内容，请注意两者的区别），如图：

    接着在“加载配置单元”对话框内选择要加载的注册表文件，如图：

    单击“打开”按钮后，出现“加载配置单元”对话框，在对话框的“项名称”文本输入框内输入新主键的名称，如图：

    再单击“确定”按钮，这样你就发现在当前主键的下面出现了一个新的主键（.NEWUSER），如图：

    而要卸载该配置单元非常的简单（注意在卸载前先将该主键进行备份），选中该主键后，单击“注册表／卸载配置单元”命令，如图：

    编辑程序会提示你是否进行卸载操作，如图：

    单击“是(Y)”按钮即将该主键从注册表中删除掉（但注意一些重要的软件、硬件信息是不能卸载掉的）。


查找与修改
2000-06-25· 生哥·yesky

    一旦注册表出现问题或者需要调整设置，这里就需要修改注册表内的键值项数据。一般的故障都可以根据自己的经验来找到注册表中相应的位置，而查找这些键值也不是一件容易的事，除非你对注册表中的每一个子键都了如指掌。

使用注册表编辑器内的查找命令，可以方便、快捷地在注册表内找到任意能与之相匹配的键值。

首先在一个根键的窗口内选中该根键，如“HKEY_LOCAL_MACHINE”根键；然后再单击“查看”菜单下的“搜索项”命令。

出现“查找”对话框，请在查找内容文本框内输入要查找的内容，例如“director”，然后再单击“查找下一个(F)”按钮。

查找时鼠标会变为一个“沙漏”的形状，表示程序现在正查找与之匹配的内容；如果该主键内容比较多，可能查找的时间会很长，这下就要看你在Windows中安装了多少软件和硬件设置啦！但是千万不要以为是死机了，请耐心等一下。

在查找前，我们可以选择“向上(U)”或“向下(D)”来控制查找的顺序；如果选择“全字匹配(W)”，表示要查找的内容必须与文本框内的字符一样，否则会将包含有文本框内字符的内容一并找出；“区分大小写(C)”与全字匹配一样，也是用来设定查找精度的，它会对要查找的英文字母进行大小写的区分。

需要注意的是：在Regedt32中只能查找到主键或根键，如果需要查找键值名或键值项数据，可以在Rededit（另外一款32位的注册表编辑器，打开的方法与Regedt32编辑器一样）内使用查找命令，然后将查找到的结果（即主键或子键名）放到Regedt32中再进行查找，这样我们就可以得到所要查找的键值名或键值项数据啦！

如果已经查找到所需要的内容，即可单击“取消”按钮，对其进行修改，否则再单击“查找下一个(F)”按钮继续查找（因为与所要查找字符匹配的内容不止一个）。

整个根键搜索完毕后，会弹出一个“警告”对话框，表示已经查找完毕，再也找不到所匹配的内容。

在Regedt32注册表编辑器中，五个不同的根键是用不同的窗口出现的，如果在该窗口内没有找到所需内容，请切换到其他的几个窗口中再进行查找，所以在查找前应确认查找内容所在的根键位置。

尽管在这些窗口内进行查找十分不便，但作为一个注册表高手，在查找前一定会对注册表内容有一定的了解（在第三部分中有详细的讲解），对要查找的内容做到心中有数，知道自己能在哪个根键内能找到所需的内容。

我们还可以使用注册表编辑器来查看键值及其类型。键值具有多种类型，如开关型（ON/OFF、0/1）、数值型（二进制、十进制、十六进制、DWORD值等）以及字符串型。开关型主要用于系统的复选框、检查框等，而数值型用于控制选项的数值。字符串型通常用于系统显示信息。

通常地，与“控制面板”中的图标相关的注册表选项，在修改后可以立即发生作用。例如，你可以找到注册表中的HKEY_CURRENT_USER\Control Panel\Keyboard分支下修改KeyboardDelay（重复延迟时间）、KeyboardSpeed（重复率速度）键值数值。

下面我们来修改一下键盘的“重复延迟”，用鼠标双击KeyboardDelay:REG_SZ:1，弹出键值编辑窗口。

将原来的值“1”改为“3”，然后再单击“确定”按钮，这时你会发现硬盘会发生响应，将修改后的键值保存到注册表数据库内（在控制面板内我们如果修改了设置后，也会出现类似情况，这表明系统正将你所作的修改保存到注册表内）。

接着再打开控制面板下的 [image] 项目，弹出如下图所示的设置键盘对话框。

在速度标签下，我们会找到设置“重复延迟”的地方，原来停留在第三格的标记现在被放到了第一格上，即键盘的重复延迟被延长啦！

同时我们还发现注册表与控制面板内的设置变化是同步的。但是，有关硬件、网络、输入法等安装方面的键值数据，必须要重新启动系统后才能发生改变。


HKEY_LOCAL_MACHINE根键（一）
2000-06-27· 生哥·yesky

    HKEY_LOCAL_MACHIN根键中存放的是用来控制系统和软件的设置。由于这些设置是针对那些使用Windows系统的用户而设置的，所以它与具体用户无关，它是一个公共配置信息，大家只须作一个了解就可以了。

    HKEY_LOCAL_MACHINE包括了如下五个子键，如图:

HARDWARE子键：

    该子键下面存放一些有关超文本终端、数学协处理器和串口等信息。HARDWARE子键下面包括两个子键DEVICEMAP（用于存放设备映象）、DESCRIPTION（存放有关系统信息）。DEVICEMAP子键的层次结构如下:

HKEY_LOCAL_MACHINE\HARDWARE
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM

    在HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM分支下面包括如下设置内容：

*COM1=COM1：指定COM1端口。
*COM2=COM2：指定COM2端口。

  DESCRIPTION子键的层次结构如下：

HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION
HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System
HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\FloatingPointProcessor
HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\FloatingPointProcessor\0

*SAM子键：系统自动将其保护起来。
*SECURITY子键：包含了安全设置的信息，同样也让系统保护起来。
*SOFTWARE子键：包含了系统软件、当前安装的应用软件及用户的有关信息。
*SYSTEM子键：

    该子键存放的是启动时所使用的信息和修复系统时所需的信息，其中包括各个驱动程序的描述信息和配置信息等。System子键下面只有一个CurrentControlSet子键，系统在这个子键下保存了当前的驱动程序控制集的信息。这里介绍CurrentControlSet子键下面的Control和Services子键。

Control子键

    这个子键中保存的是由控制面板中各个图标程序设置的信息。由于控制面板中的各个图标程序可能会把信息写在不同的子键下，所以用户最好不要通过注册表编辑器来修改这些信息，否则容易
引起系统死机。

(1) fontassoc子键
    该子键存放的是有关字体设置信息（如缺省字体、替代字体以及字符集等）。在HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ fontassoc分支下还有两个子键Associated DefaultFonts、Associated CharSet。

  Associated DefaultFonts子键
    在HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ fontassoc\Associated DefaultFonts分支下有如下设置信息：

*AssocSystemFont=simsun.ttf：定义系统字体。simsun.ttf为TrueType宋体字库文件。
*FontPackageDontCare=宋体：以下行设置了已安装的套装字体（FontPackage），在Win3.x中，这些设置在Wifeman.ini文件的[FontPackages]小节中列出。
*FontPackageRoman=宋体
*FontPackageSwiss=宋体
*FontPackageModern=宋体
*FontPackageScript=宋体
*FontPackageDecorative=宋体 Associated CharSet子键 在HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ fontassoc\Associated CharSet分支下是关于一些系统字体的设置。

(2) Nls子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ Nls分支中，它是用来设置Windows的语言特性，如代码页、EUDC内码范围、语言分类等。

(3) SessionManager子键
    该子键用于管理系统的会话，它包括三个主键和八个子键。

  KnownDLLs子键
    该子键下包含了Windows中32位Dll文件以及标识，如图：

  CheckBadApps子键
    该子键用于检查有问题的16位应用程序，这些应用程序在Windows中运行会出现莫名其妙的问题，甚至引起系统的崩溃。该子键下面有许多应用程序的可执行文件的子键，如PPower.exe是
MS DOS 6.x一个用于便携机电源管理的程序，它在注册表中的分支是 HKEY_LOCAL_MACHINE
\System\ CurrentControlSet\control\SessionManager\CheckBadApps\ POWER.EXE。
通常这个分支下有几个子键！

  CheckBadApps400子键
    该子键用于检查有问题的32位应用程序，它在注册表的分支是HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ SessionManager\CheckBadApps400。
    该分支下面有许多应用程序的子键，这些子键有这些应用程序的相应运行设置，例如，
UltraEdit32是一个32位的多功能编辑器，其可执行文件为Ui32.exe，它在注册表的分支是HKEY_LOCAL_MACHINE\System\ CurrentControlSet\control\SessionManager\CheckBadApps400
\ UE32.EXE。在该分支下面有Ui32.exe的运行设置（包括可执行文件Ui32.exe本身的检查标志、
版本检查标志以及其标志位等）。

  AppPatches子键
    该子键用于应用程序的补丁，使这些应用程序能够很好地运行在Windows中。在Windows 3.x时
代，这些补丁是放在Win.ini文件中。该子键位于注册表的HKEY_LOCAL_MACHINE\System
\CurrentControlSet\ control\SessionManager\AppPatches分支上。在该分支下面有许多应用
程序的子键及其设置内容。例如，在该分支下有一个Setup的应用程序，其位置是
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ SessionManager\AppPatches\SETUP。

(4) MediaResources子键
    该子键用于设置多媒体资源，其位置在HKEY_LOCAL_MACHINE\System\ CurrentControlSet\control\MediaResources分支上。该分支下还包括DirectSound、Joystick、MIDINonGeneralMIDIDriverList子键及其设置，如图:

(5)MediaProperties子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ Media-Properties
分支上，用于设置多媒体的属性。

(6)FileSystem子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ FileSystem分支上，
主要对Windows的NTFS及Win31、Win9.x文件系统进行设置，如图:

(7) Shutdown子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ Shutdown分支上，用于对Windows关机时的设置，一般里面有一个快速关机的设置，如图:

(8)keyboard layouts子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ keyboard layouts
分支上，主要对Windows的键盘布局（Keyboard Layouts）或者键盘语言进行设置。该子键下面包括多个关于键盘语言（也包括汉字输入法）的子键，这些子键使用数值表示出来，如图:

(9) Update子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ Update分支上，
用于确定“控制面板”窗口是否被刷新，此子键的功能与“控制面板”窗口中的“查看”
菜单中的“刷新”相同。

(10) TimeZoneInformation子键
该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ TimeZoneInformation分支上，用于设置时区信息，如图:

(11) Print子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ Print分支上，用于设置打印机，如图:

(12)IDConfigDB子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ IDConfigDB分支上，用于显示硬件配置文件的配置数据、配置名称等其他信息，如图:

(13)ComputerName子键
    该子键下面具有如下分层结构：

HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ ComputerName\ActiveComputerName
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ ComputerName\ComputerName

    该分层结构用于设置计算机名称。

(14)SecurityProviders子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\ SecurityProviders分支上，用于设置网络供应商的安全功能，如图:

Services子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services分支上。该子键中存放了Windows中各项服务的信息，有些是自带的，有些是随后安装的。在该子键下面的每个子键中存放相应服务的配置和描述信息。

(1) Class子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class分支上。该子键中保存的是Windows支持的不同种类硬件的信息，它下面的子键与“控制面板”中添加新硬件的分类类似。 下面简单介绍几种硬件分类子键。

    ① 1394子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services \Class\1394，用于配置满足IEEE 1394规范的“1394总线控制器”。 * @=1394 总线控制器：指定1394子键的描述名称。

* Icon=-21：指定图标标识。
* Link={6BDD1FC1-810F-11D0-BEC7-08002BE2092F：指定“1394总线控制器”的连接。该连接将在{6BDD1FC1-810F-11D0-BEC7-08002BE2092F子键中定义。

     ② {6BDD1FC1-810F-11D0-BEC7-08002BE2092F}子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\ {6BDD1FC1-810F-11D0-BEC7-08002BE2092F}分支上，用于配置“1394总线控制器”的连接。

*Link=1394：指定连接为“1394”。
*Class=1394：指定“1394总线控制器”类为“1394”。

    ③Adapter子键
该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\Adapter分支上，用于配置“CD-ROM 控制器”。

*@=CD-ROM 控制器：指定该子键的描述名称。
*Icon=-9：指定图标标识。
*Link={4d36e964-e325-11ce-bfc1-08002be10318}：指定“CD-ROM 控制器”的连接，由
{4d36e964-e325-11ce-bfc1-08002be10318}子键进一步地定义。

     ④{4d36e964-e325-11ce-bfc1-08002be10318}子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\ {4d36e964-e325-11ce-bfc1-08002be10318}分支上，用于配置“CD-ROM 控制器”的连接。

*Link=Adapter：指定连接为“Adapter”。
*Class=Adapter：指定类为“Adapter”。

    ⑤Printer子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\Printer分支上，用于配置“打印机”。

*@=打印机：指定该子键的描述名称。
*Installer=MSPRINT.DLL：指定“打印机”的安装程序为“MSPRINT.DLL”。
*Icon=-4：指定图标标识。
*NoDisplayClass=1：确定是否显示类。若为1，则不显示类。若为0，则显示类。
*Link={4d36e979-e325-11ce-bfc1-08002be10318}：指定“打印机”的连接。

    ⑥ MEDIA子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class \MEDIA分支上，用于配置多媒体设备，包括声音卡、视频卡和游戏控制器等。

*@=声音、视频和游戏控制器：指定该子键的描述。
*Link={4d36e96c-e325-11ce-bfc1-08002be10318：指定“多媒体”的连接，
  参见{4d36e96c-e325-11ce-bfc1-08002be10318}子键。
*Icon=0：指定图标标识。
*Installer=mmci.dll：指定“多媒体”设备的安装程序为“MMCI.DLL”。

(2) VxD子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD分支上。该子键保存了Windows中所有虚拟设备驱动程序的信息。由于Windows系统能够自动管理这些信息，因此，在通常情况下最好不要通过注册表编辑器来修改这些信息，但是了解此子键下的信息是有好处的，因为有一些功能（如拨号网络提速）必须修改此子键下的信息。

    ① Winsock子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\Winsock分支上，用于设置WinSock。 *IrSockets=wsirda.vxd：指定Winsock的虚拟驱动程序为wsirda.vxd。

    ② VNETSUP子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\VNETSUP分支上，用于设置网络的标识以及初始化数值。

*ComputerName=caogjwj：计算机名称。
*Workgroup=cgj：工作组名字。
*Comment=CAO GUO JUN：计算机描述。
*StaticVxD=vnetsup.vxd：静态虚拟设备驱动程序为vnetsup.vxd。
*Start=hex:00：设置初始化数值。
*NetClean=hex:01：确定是否清理网络。若为01，则清理网络。若为00，则不清理网络。*MaintainServerList=2：设置浏览主控服务器的属性值。
*LMAnnounce=0：设置LM广播（LMAnnounce）属性值。

    为了进一步地配置网络服务，在Ndi子键下面将有如下子键结构： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\ VNETSUP\Ndi
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\ VNETSUP\Ndi\params params子键用于进一步地设置浏览主控服务器、LM广播的属性值。


HKEY_LOCAL_MACHINE根键（二）
2000-06-27· 生哥·yesky

   a.MaintainServerList子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD \VNETSUP\Ndi\params\MaintainServerList分支上，用于设置浏览主控服务器的属性值。在Windows中，浏览服务是由一个浏览主控服务器和一个浏览备份服务器来管理浏览列表。您可以使用net view命令来获得浏览主控服务器的机器列表。

*default=2：缺省属性值为2。
*ParamDesc=浏览主控服务器：属性描述。
*type=enum：属性值类型为枚举型。
*@=2：缺省值为2。

    以上枚举型由enum子键定义。enum位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP\Ndi\params\MaintainServerList\enum分支上。

*2=自动：使用“自动”选项，则系统将允许该终端变成一个合格的浏览主控服务器。
*1=启用：使用“启用”选项，则系统将允许该工作站将成为浏览主控服务器。
*0=禁用：使用“禁用”选项，则系统将使此机器不可能成为浏览主控服务器。

  b.LMAnnounce子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\VNETSUP\Ndi\params\LMAnnounce分支上，用于设置LM广播的属性值。LM广播设置用于LAN Manager网络
环境，它要求每个工作站必须向网络上的其他工作站广播自己的存在。

*default=0：缺省属性值为0。
*ParamDesc=LM 广播：属性描述。
*type=enum：属性类型为枚举型。
*@=0：缺省值为0。

    枚举型是由enum子键定义的。enum位于HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Services\VxD\VNETSUP\Ndi\params\LMAnnounce\ enum分支上。

*1=是：使用“是”选项，则LAN Manager就会开始广播，这会增加用户的网络冲突。
*0=否：如果在用户的网络环境中不需要LM广播性能,则选择“否”选项。

  ③ NDIS子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\NDIS分支上，用于设置NIDS。

*Start=hex:00：初始化值为00。
*NetClean=hex:01：确定是否清理网络。
*StaticVxD=ndis.vxd,ndis2sup.vxd：静态虚拟设备驱动程序为ndis.vxd、ndis2sup.vxd。*DeviceVxDs=ndiswmi.sys：NIDS的设备驱动程序为ndiswmi.sys。

  ④ JAVASUP子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\JAVASUP分支上，用于设置JAVASUP（Java服务）。

*Start=hex:00：初始化值为00。
*StaticVxD=JAVASUP.VXD：静态虚拟设备驱动程序为JAVASUP.VXD。

  ⑤ CONFIGMG子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\CONFIGMG分支上，用于所有系统设备的管理。

*StaticVxD=*CONFIGMG：静态虚拟设备驱动程序为*CONFIGMG。
*Start=hex:00：初始化值为00。
*SysDM=SYSDM.CPL：由SYSDM.CPL启动系统设备管理器。
*SysDMFunc=DMSetupDevnode：由DMSetupDevnode启动系统设备管理器功能。
*Detect=SYSDM.CPL：由SYSDM.CPL自动检测系统设备。
*DetectFunc=DMRedetect：由DMRedetect启动自动检测功能。
*Private=SYSDM.CPL：由SYSDM.CPL启动私有设备管理器。
*PrivateFunc=DMPrivateProblem：由DMPrivateProblem启动私有设备管理器功能。
*RemoveRomOkay=SYSDM.CPL：由SYSDM.CPL确定ROM中内容删除是否成功。
*RemoveRomOkayFunc=DMRemoveRomOkay：由DMRemoveRomOkay启动ROM删除功能。
*AskForConfig=SYSDM.CPL：使用SYSDM.CPL查询系统设备的设置。*AskForConfigFunc=DMAskForConfig：由DMAskForConfig启动系统设备的查询功能。
*AskForUndock=SYSDM.CPL：使用SYSDM.CPL查询设备出坞情况。
*AskForUndockFunc=DMAskForUndock：由DMAskForUndock启动设备出坞查询功能。

    在CONIFGMG子键下面还有两个子键，用于设置系统总线。

  a.SpannableBus子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\CONFIGMG\SpannableBus分支上，用于设置可扩展的总线（Spannable Bus）的个数。

*PCI=hex:00：设置可扩展的PCI总线个数。
*ISAPNP=hex:00：设置可扩展的即插即用ISA总线的个数。

  b.PnPBus子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\CONFIGMG
\PnPBus分支上，用于设置即插即用总线（PnP Bus）的个数。

*PCI=hex:00：设置PCI总线的个数。
*BIOS=hex:00：设置BIOS总线的个数。
*EISA=hex:00：设置EISA总线的个数。
*USB=hex:00：设置USB总线的个数。
*HID=hex:00：设置HID总线的个数。
*1394=hex:00：设置1394总线的个数。
*ISAPNP=hex:00：设置ISAPNP总线的个数。
*MF=hex:00：设置MF总线的个数。
*ACPI=hex:00：设置ACPI总线的个数。

  ⑥ NTKern子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\NTKern分支上，用于设置NTKern。

*StaticVxD=*NTKERN：静态虚拟驱动程序为*NTKERN。
*Start=hex:00：设置初始化数值。

(3) WinSock子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Winsock分支上，存放的是当系统连接Internet时使用的WinSock的信息。 在该子键下面有如下两个子键：

   ① Autodial子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Winsock\Autodial分支上，用于设置Autodial（自动拨号）。

*AutodialDllName32=wininet.dll：启动自动拨号功能的32位DLL驱动程序为wininet.dll
*AutodialFcnName32=InternetAutodialCallback：设置自动拨号的回调功能。

   ② Parameters子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Winsock\Parameters分支上，用于设置WinSock参数。

* MSTCP=：使用HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\MSTCP\Parameters\Winsock分支中的参数设置WinSock。

(4) WDMFS子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\WDMFS分支上，用于设置WDMFS（WDM文件系统）。

*ImagePath=\\SystemRoot\\System32\\Drivers\\wdmfs.sys：WDMFS驱动程序为wdmfs.sys。
*ErrorControl=hex:01,00,00,00：设置错误控制码。
*Start=hex:00：设置初始化数值。
*Type=hex:01,00,00,00：设置WDMFS的类型。
*DisplayName=WDM Windows File System Mapper：显示WDMFS的名称。

(5) UPDATE子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\UPDATE分支上，用于设置UPDATE（更新服务）。

*ImagePath=\\SystemRoot\\System32\\Drivers\\update.sys：UPDATE服务的驱动程序为update.sys。
*ErrorControl=hex:01,00,00,00：设置错误控制码。
*Start=hex:00：设置初始化数值。
*Type=hex:01,00,00,00：设置UPDATE服务的类型。
*DisplayName=Intel Update Driver：UPDATE服务的显示名称。

(6) RemoteAccess子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\RemoteAccess分支上，存放的是和Windows拨号网络有关的信息。

*Version=1.2c：版本号。
*Remote Connection=hex:00,00,00,00：设置远程连接。 在该子键下面有如下两个子键：

  ① Authentication子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services \RemoteAccess\Authentication分支上，用于设置拨号网络的验证信息（如服务器类型、协议等）。

  ② NetworkProvider子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services \RemoteAccess
\NetworkProvider分支上，用于设置拨号网络的驱动程序。

(7) MSNP32子键
    该子键具有如下子键结构： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSNP32

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSNP32\NetworkProvider NetworkProvider子键用于保存Microsoft网络用户的验证信息。

*GroupFcn=GROUPPOL.DLL,NTGetUserGroups：由GROUPPOL.DLL、NTGetUserGroups设置组功能。
*AuthenticatingAgent=：设置验证代理。若为空，则使用缺省的验证代理。
*LogonDisconnected=hex:00,00,00,00：设置登录断开标志。
*Name=Microsoft Network：设置名称。
*ProviderPath=msnp32.dll：“Microsoft网络用户”的驱动程序为msnp32.dll。
*Description=Microsoft Network：设置“Microsoft网络用户”的描述。
*NetID=hex:00,00,01,00：网络标识号。
*CallOrder=hex:00,00,00,40：设置调用顺序。

(8) NWNP32子键
    该子键下面具有如下子键结构： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider NetworkProvider子键中存放的是Microsoft网络用户针对Netware网络时的验证信息。

*GroupFcn=GROUPPOL.DLL,NWGetUserGroups:由GROUPPOL.DLL、NWGetUserGroups设置组功能。

(9) Arbitrators子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Arbitrators
分支上。该子键中保存的信息是用来解决不同的设备间资源冲突的问题，它的四个子键中分别保
存了内存区域、DMA、I/O端口和中断的信息。

  ① IRQArb子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Arbitrators
\IRQArb分支上，主要用于保存保留的中断信息。

  ② DMAArb子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Arbitrators
\DMAArb分支上，主要用于保存保留的DMA信息。

  ③ AddrArb子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Arbitrators
\AddrArb分支上，用于保存保留的内存区域列表。

  ④ IOArb子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Arbitrators
\IOArb分支上，用于保存保留的I/O端口列表。

(10) WinSock2子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\WinSock2分支上，
用于存放与Internet连接时WinSock 2.0版本的有关信息。

  ① Parameters子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\WinSock2\Parameters分支上，用于存放WinSock 2.0版的有关参数，如注册版本号、协议目录、名字空间目录等。

   ② Providers子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\WinSock2\Providers分支上，用于存放WinSock 2.0的提供商信息。在该子键下面还提供了一个INET子键，用于存放提供商名称。

(11) wdmaud子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\wdmaud分支上，
用于存放WDM Audio（WDM音频）信息。

*Group=Base：设置WDM Audio所属组（基组）。
*ImagePath=\\SystemRoot\\system32\\drivers\\wdmaud.sys：WDM Audio驱动程序为wdmaud.sys。
*Start=hex:03,00,00,00：设置初始化值。
*Type=hex:01,00,00,00：设置类型值。
*ErrorControl=hex:01,00,00,00：设置错误控制代码。 类似于wdmaud子键设置的还有redbook、sbemul、swmidi等子键。

(12) NPSTUB子键
    该子键具有如下子键结构： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NPSTUB
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NPSTUB\NetworkProvider NetworkProvider子键用于存放“Microsoft友好登录”的有关信息。

*Name=Microsoft 友好登录：名称。
*ProviderPath=ienpstub.dll：32位保护模式驱动程序为ienpstub.dll。
*RealDLL=mslocusr.dll：实模式DLL驱动程序为mslocusr.dll。
*Description=Microsoft 友好登录：描述。
*NetID=hex:00,00,01,00：设置网络标识。
*CallOrder=hex:00,00,00,40：设置调用顺序。 （13) ProtectedStorage子键
    该子键位于HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\ProtectedStorage分支上，用于存放ProtectedStorage（受保护的系统存储）信息。
    在该子键下面有一个Parameters子键，它位于HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\ProtectedStorage\Parameters分支上，用于设置受保护的系统存储参数。

*ImagePath=C:\\WINDOWS\\SYSTEM\\PSTORES.EXE：启动保护的系统存储功能的程序为PSTORES.EXE。
*AuthCodeCfg=dword:00000001：设置验证代码值。
*Configuration=dword:00000001：设置配置值。

    另外，Parameters子键下面还有一个S子键，该子键位于HKEY_LOCAL_MACHINE \System\CurrentControlSet\Services\ ProtectedStorage\Parameters\S分支上，用于进一步地设置pstores.exe、psbase.dll系统参数值。

*pstores.exe=hex:13,ff,e7,bb,a3,f2,01,1e,87,.......：设置pstores.exe系统参数值。
*psbase.dll=hex:d0,08,ef,10,2b,bf,b2,f2,23,.......：设置psbase.dll系统参数值。

(14) WebPost子键
    该子键具有如下子键结构： HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WebPost
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WebPost\Providers
    Providers子键下面保存了所有与Internet Mail（这是Outlook Express软件中的一个电子邮件管理程序）有关的信息。


HKEY_CLASSES_ROOT根键
2000-06-27· 生哥·yesky

扩展名与应用程序的对应关系
    Windows所支持的文件类型（这些文件具有一定的文件扩展名）在HKEY_CLASSES_ROOT根键下定义。下表中列出了HKEY_CLASSES_ROOT根键中的文件扩展名和文件类型之间的关系。

                      文件扩展名和文件类型间的关系

文件扩展名 | 文件类型 | 文件扩展名 | 文件类型
.386 | vxd文件（这是一个虚拟设备驱动程序） | .ADM | ADM_auto_文件
.ai | application/postscript文件 | .aif | aiff文件
.aifc | aiff文件 | .aiff | aiff文件
.ani | ani文件（光标动画文件） | .art | art文件
.au | au文件（用于Internet传输的声音文件） | .awd | FaxView文档（用于传真的显示）
.snd | au文件 | .avi | avi文件（由Video forWindows支持）
.bat | bat文件（DOS、Windows下的批处理文件） | .bfc | Briefcase（这是一种公文包文件）
.bmp | Paint.picture（这是一个由画图附件所产生的图片文件） | .cda | cda文件
.cnf | Conferencelink（这是一个会议连接） | .crt | certificate 文件（这是一 个用于安全方 面的证书认证 文件）
.der | certificate文件 | .clp | Clipboard文件（用于保存剪贴板中的内容）
.cmd | cmd文件（这是一个文本文件，主要用于命令解释） | .com | com文件（这是DOS、Windows上一个命令解释程序，如command.com、win.co等）
.cpl | cpl文件 | .css | text/css文件
.cur | cur文件（用于存放光标资源） | .dat | DAT_auto_文件
.dcx | DCXImage.Document（这是一个DCXImage产生的文档） | .DIC | Txt文件
.dll | dll文件（这是一个Windows上使用的动态链接库文件） | .shb | DocShortCut（这是DOC文件的快捷方式）
.drv | drv文件（Windows上的设备驱动程序） | .xla | EXCEL.Addin
.xlk | Excel.Backup | .xlc | Excel.Chart.5
.csv | Excel.CSV | .xld | Excel.Dialog
.dif | Excel.DIF | .xlb | Excel.Sheet.5
.xls | Excel.Sheet.5 | .slk | Excel.SLK
.xlt | Excel.Template | .xlv | Excel.VBAModule
.xlw | Excel.Workspace | .xll | Excel.XLL
.xlm | Excel.Macro.Sheet | .xif | XIFImage.Document（这是一个XIFImage 产生的文档）
.exe | exe文件（这是DOS、Windows下可执行文件） | .fnd | fnd文件
.fon | fon文件（这是Windows的TTF字库的索引文件） | .gif | gif文件
.goc | gocserve | .hlp | help文件（Windows下帮助文件）
.ht | ht文件 | .htm | html文件（这是超文本标记语言文件）
.html | html文件 | .ico | ico文件（这是Windows的图标文件）
.inf | inf文件（这是一个信息安装文件） | .ini | ini文件（Windows的初始化文件）
.url | InternetShortcut（这是Internet上URL地址的快捷方式） | .job | JobObject
.jfif | jpeg文件 | .jpe | jpeg文件
.jpg | jpeg文件 | .lnk | lnk文件（这是Windows上的快捷方式）
.mid | mid文件 | .mmm | MPlayer
.mlv | MPEG文件（这是一 个视频文件） | .mak | mak文件
.man | application/x-trof-man格式的文件 | .MAPI Mail | CLSID\{9E56BE60-C50F-11CF-9A2C-00A0C90A90CE}（这是一个类标识）
.mcc | Dialer10CallingCard（这是一个电话卡文件） | .mov | mov文件（这是一个由QuickTime for Windows支持的视频文件）
.mov ie | video/x-sgi-movie格式文件 | .mp2 | MPEG文件
.mpa | MPEG文件 | .mpe | MPEG文件
.mpeg | MPEG文件 | .mpg | MPEG文件
.msn | MS.Network.Document（这 是一个MSN软件产生的文件） | .rmi | mid文件
.gra | MSGraph.Chart.5 | .grp | MSProgramGroup（这是一个由程序管理器产生的组窗口文件）
.obd | Office.Binder.95 | .obt | Office.Binder.Template
.obz | Office.Binder.Wizard | .ofn | Office.File.New（这是一个由Office新 创建的文件
.PBK | MSN_PhoneBook | .pcx | PCXImage.Document
.nws | MicrosoftInternet News Message | .pif | pif文件
.pma | Perf文件 | .ps | application/postscript格式文件
.pmc | Perf文件 | .pml | Perf文件
.pmr | Perf文件 | .pmw | Perf文件
.pfm | pfm文件 | .pnf | pnf文件
.que | QueueObject | .qt | MOV文件
.ra | ReadAudio文件 | .ram | ReadAudio文件
.reg | reg文件（注册表文件） | .rnk | rnk文件
.rpm | audio/x-pn-realaudio- plugin格式文件 | .rtf | Word.RTF
.scr | scr文件 | .shs | ShellScrap
.sit | application/x-stuffit格式文件 | .sys | sys文件
.tif | TIFImage.Document | .tiff | TIFImage.Document
.ttf | ttf文件 | .ttc | ttc文件
.EXC | txt文件 | .log | txt文件
.scp | txt文件（脚本文件） | .txt | txt文件
.pic | ViewerFrameClass | .vir | vir文件
.vsd | Visio.Drawing.4 | .vss | Visio.Drawing.4
.vst | Visio.Drawing.4 | .vsw | Visio.Drawing.4
.wav | wav文件 | .ARC | Winzip
.ARJ | Winzip | .gz | Winzip
.LZH | Winzip | .tar | Winzip
.taz | Winzip | .tgz | Winzip
.z | Winzip | .zip | Winzip
.wll | Word.Addin | wbk | Word.Backup
.DOT | Word.Template | .wiz | Word.Wizard
.doc | Word.Document | .wri | wri文件
.xbm | xbm文件(image/x-xbitmap格式文件) | .xif | XIFImage. Document
.uls | uls文件（ text/iuls格式文件） | .WHT | Whiteboard
.WPS | wps文件 |  |

特殊扩展名与应用程序的对应关系
    我们在注册表编辑器中可以发现，HKEY_CLASSES_ROOT根键下的文件扩展名子键（如*、bas等）前面有“+”符号，而且在此文件扩展名中没有对应的应用程序。为了查明这些文件后缀与应用程序之间的关系，我们必须单击“+”一次或者几次，才可以看到它们的关系。

下面简要地介绍这些特殊的文件后缀子键。

*子键
     *子键下面具有如下层次结构：

HKEY_CLASSES_ROOT\*
HKEY_CLASSES_ROOT\*\shellex
HKEY_CLASSES_ROOT\*\shellex\PropertySheetHandlers
HKEY_CLASSES_ROOT\*\shellex\PropertySheetHandlers\{3EA48300-8CF6-101B-84FB-666CCB9BCD32}

    此层次结构说明了*子键的文件类型与 Windows系统中的外壳扩展中的属性页句柄建立了一种关联。

bas子键

    .bas子键下面具有如下层次结构：

HKEY_CLASSES_ROOT\.bas
HKEY_CLASSES_ROOT\.bas\shell
HKEY_CLASSES_ROOT\.bas\shell \open
HKEY_CLASSES_ROOT\.bas\shell \open \command

    此层次结构说明了bas子键与command子键所指定的应用程序建立了关联。在command子键中还有如下设置：

#@=E:\VB\vb.exe %1

    也就是说，bas文件后缀与E:\VB\vb.exe关联。

bmp子键

    bmp子键下面具有如下层次结构：

HKEY_CLASSES_ROOT\.bmp
HKEY_CLASSES_ROOT\.bmp \ShellNew

    在ShellNew子键下面只有一个设置：

#NullFile=：将NullFile设置为空串，以便能将.bmp文件扩展名添加到系统的新建菜单中。


HKEY_CURRENT_CONFIG根键
2000-06-27· 生哥·yesky

    如果您在Windows中设置了两套或者两套以上的硬件配置文件（Hardware Configuration file），则在系统启动时将会让用户选择使用哪套配置文件。而HKEY_CURRENT_CONFIG根键中存放的正是当前配置文件的所有信息，如图：

HKEY_CURRENT_CONFIG根键包含的内容
    在Windows系统启动以后，任何对配置文件的修改都会同时影响到HKEY_LOCAL_MACHINE\Config分支、HKEY_LOCAL_MACHINE\Enum分支和HKEY_CURRENT_CONFIG中的相应内容。有关HKEY_CURRENT_CONFIG中子键的详细情况请参见前面的HKEY_LOCAL_MACHINE\Config分支HKEY_LOCAL_MACHINE\Enum分支。

如何设置硬件配置文件
    在Windows中文版中，当可用设备发生变化时，硬件配置文件指示Windows加载正确的驱动程序。例如，对应计算机的安装与否，便携机的可用硬件也会各不相同。Windows将只加载正确的硬件配置文件所需的驱动程序。使用硬件配置文件，可以在启动Windows中文版时选择适当的配置环境。另外，使用硬件配置文件，可以将系统恢复到刚安装Windows时的系统环境。


HKEY_CURRENT_USER根键
2000-06-27· 生哥·yesky

    HKEY_CURRENT_USER根键中保存的信息（当前用户的子键信息）与HKEY_USERS\.Default分支中所保存的信息是相同的，如图：

  任何对HKEY_CURRENT_USER根键中的信息的修改都会导致对HKEY_USERS\.Default中子键信息的修改，反之也是如此。


HKEY_USER 根键(一）
2000-06-27· 生哥·yesky

AppEvents子键
    HKEY_USERS根键中保存的是默认用户（.DEFAULT）、当前登录用户（如ws）与软件（Software）的信息，如图：

注意：HKEY_USERS\Software中保存的软件信息与HKEY_LOCAL_MACHINE\Software相同。

    HKEY_CURRENT_USER\.DEFAULT下面有八个子键。其中除RemoteAccess子键外，下面是其中几个系统预定义的子键。

# AppEvents：登录已注册的各种应用事件。
# Control Panel：与控制面板设置有关的内容。
# keyboard layout：键盘设置信息。
# Software：软件的有关信息。

    .DEFAULT子键的配置是针对未来将会被创建的新用户的。新用户根据默认用户的配置信息来生成自己的配置文件，该配置文件包括环境、屏幕、声音等多种信息。

Control子键
    Control Panel子键位于HKEY_USERS\.DEFAULT\Control Panel分支上，它所包含的内容与桌面、光标、键盘和鼠标等设置有关。改变它们的键值就将改变对应的工作环境或参数，如下图所示的就是Control Panel的子键结构。

    在图中，我们可以看到，Control Panel子键下面又有二十几个子键，在这里可能看到全部的子键，你可以打开注册表编辑器加以检证。根据系统配置和设置情况的不同，子键的数目也会不同。例如有的系统中没有Mouse子键，这并不是表示计算机中没有安装鼠标，而是指您从来没有对鼠标器作过任何设置，Windows系统完全采用默认值。

    虽然Control Panel子键中的键值与环境和特性有直接关系，但很多参数的改变并不要求用户通过修改注册表来实现，而只需通过“控制面板”即可进行修改。也有一些环境特性的改变只能通过修改注册表来实现，例如，改变菜单的弹出延迟时间。

Accessibility子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Accessibility分支上，如图:

    该子键包含如下两个配置数据：

#　Keyboard Preference=0：禁止使用键盘性能功能。
#　Blind Access=0：禁止闪烁存取功能。

    Accessibility子键还包含了十个子键，多数子键在“控制面板”窗口的“辅助选项”图标中都有对应的选项。这些子键的键值名中一般都有一个“On”。当其键值为0时，表示此设置无效；而当其键值为1时，则表示此设置生效。

Appearance子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Appearance分支上，该子键下的键值中列出了可供选择的各种颜色和图案。您可以在“控制面板”的“显示属性”对话框的“外观”选项下的“方案”下拉菜单中，看到这些颜色和图案的中文名称，如图:

    在Appearance子键下还有一个Scheme子键，用于设置配色方案的，这些图案使用十六进制数值表示出来。

Cursors子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Cursors分支，它的键值中列出了光标图案所在的文件路径。您可以在“控制面板”的“鼠标”对话框中的“指针”选项下的“方案”下拉菜单中，看到这些颜色和图案的中文名称并进行设置。

Colors子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Colors分支上，用于设置桌面上各种项目（如图标、菜单等）的颜色。您可以在“控制面板”的“显示属性”对话框中的“外观”选项下的“颜色”框内，看到这些项目所设置的颜色，如图:

如：Scrollbar=192 192 192：设置滚动条的颜色，其中部分设置可以在显示属性窗口内进行设置。其颜色使用RGB格式来组合颜色值。

desktop子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\desktop分支上，该子键的键值中列出了桌面和窗口中的各种部件，如窗口边界、标题、图标、菜单、滚动条、消息框的长度、宽度和字体等数据。这些数据可以在“控制面板“的“显示属性”对话框中进行修改，如图:

Desktop子键具有如下的设置数据：

#　DragFullWindows=0：确定在拖动窗口时是否显示全窗口形状。若为0，则不显示全窗口。若为1，则显示全窗口。
#　FontSmoothing=0：确定是否让字体平滑地显示。若为0，则字体不平滑显示。若为1，则字体平滑地显示。
#　Wallpaper=：设置墙纸。
#　TileWallpaper=0：设置墙纸的显示方式。
#　ScreenSaveTimeOut=840：启动屏幕保护程序的等待时间为840毫秒。
#　UserPreferencemask=hex:ae,00,00,00：设置用户的显示性能掩码。此掩码使用十六进制数值表示。
#　WallpaperStyle=0：设置用于填充墙纸的周围剩余空间的Active Desktop样式。
#　ScreenSaveLowPowerActive=0：确定是否进入屏幕保护的低功耗状态。若为0，则不进入屏幕保护的低功耗状态。
#　ScreenSavePowerOffActive=0：确定在进入屏幕保护状态时，是否关闭监视器。若为0，则关闭监视器。
#　CursorBlinkRate=500：设置光标闪烁速率。
#　MenuShowDelay=400：设置菜单显示的延迟时间。
#　ScreenSaveActive=0：确定是否启用屏幕保护程序。若为0，则禁用屏幕保护程序。
#　ScreenSaveUsePassword=dword:00000000：确定屏幕保护程序是否使用密码。若为0，则不使用密码。若为1，则使用密码。

在desktop子键下面还有一个子键：

WindowMetrics子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\desktop\WindowMetrics分支上，该子键保存了如何显示窗口的信息，如图:

这些信息显示如下：

# IconSpacingFactor=100：设置图标间距因子。
# ScrollWidth=-270：设置滚动宽度。
# ScrollHeight=-270：设置滚动高度。
# IconSpacing=-1155：设置图标间距。
# IconVerticalSpacing=-1125：设置图标垂直间距。
# IconFont=hex:09,00,00,00,00,00,00,00,90,01,00,00,... ... ：设置图标字体。此字体使用十六进制表示出来。
# CaptionFont=hex:09,00,00,00,00,00,00,00,90,01,00,00,00,... ... ：设置标题字体。
# MenuFont=hex:09,00,00,00,00,00,00,00,90,} 01,00,00,00,00,... ... ：设置菜单字体。
# SmCaptionFont=hex:09,00,00,00,00,00,00,00,bc,02,00,00,... ... ：设置调色板标题字体。
# StatusFont=hex:09,00,00,00,00,00,00,00,90,01,00,00,00,86,00,... ... ：设置状态栏字体。
# MessageFont=hex:09,00,00,00,00,00,00,00,90,01,00,00,00,86,00,... ... ：设置信息字体。
# BorderWidth=-15：设置边框宽度。
# CaptionWidth=-270：设置标题宽度。
# CaptionHeight=-270：设置标题高度。
# SmCaptionWidth=-210：设置调色板标题的宽度。
# SmCaptionHeight=-210：设置调色板标题的高度。
# MenuWidth=-270：设置菜单宽度。
# MenuHeight=-270：设置菜单的高度。
# Shell Icon Size=32：图标尺寸为32× 32。

Input Method子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Input Method，该子键的键值中登录了输入方法切换热键的有关数据。这些数据您可以在“控制面板”中打开“输入法”对话框中的
“热键”选项下进行修改，如图:

Input Method子键下有如下配置数据：

# Show Status=1：确定是否显示输入法状态。
# Parallel Distance=hex:00,00,00,00：设置输入法状态图标与输入法图标之间的水平距离。
# Perpendicular Distance=hex:10,00,00,00：设置输入法状态图标与输入法图标之间的垂直距离。
# Parallel Tolerance=hex:38,00,00,00：设置输入法状态图标与输入法图标之间的最大的水平距离。
# Perpendicular Tolerance=hex:10,00,00,00：设置输入法状态图标与输入法图标之间的最大的垂直距离。

    在Input Method子键下面还有一个Hot Keys子键，它位于HKEY_USERS\.DEFAULT\Control Panel\Input Method\Hot Keys分支上，用于设置输入法的热键。根据系统中所安装的输入法的个数，在Hot Keys子键下面将有多个用于设置热键的子键，但是其设置方法是类似的。例如，“微软拼音输入法1.5”的热键设置子键位于HKEY_USERS\.DEFAULT\Control Panel\Input Method\Hot Keys\00000011分支上，其键值数据如下：

#　Key Modifiers=hex:04,c0,00,00：设置键盘修改符。
# Target IME=hex:00,00,00,00：设置目标IME。
# Virtual Key=hex:20,00,00,00L：设置虚拟键。

International子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\International分支上，该子键的键值中登录了表示时间的“上午”和“下午”的数据。这些数据可以在“控制面板”中打开“区域设置”对话框中的“时间”选项下进行修改，如图:

Keyboard子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Keyboard，该子键的键值中登录了击键时的重复延时和重复速率。这些数据可以在“控制面板”中打开“键盘”对话框中的“速度”选项下进行修改，如图:

keyboard子键下具有如下键值数据：

#　KeyboardSpeed=31：设置键盘的字符重复输入速度。
#　KeyboardDelay=0：设置键盘的字符重复的延缓时间。

Mouse子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\Mouse分支上，该子键的键值中登录了鼠标的双击速度和指针的移动速度。这些数据可以在“控制面板”中打开“鼠标”对话框中的“按钮”和“移动”选项下进行修改，如图：

Mouse子键下面具有如下设置数据：

# MouseThreshold1=4：设置鼠标双击速度。
# MouseThreshold2=12：设置鼠标指针轨迹移动速度。
# MouseSpeed=2：设置鼠标速度。 PowerCfg子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg分支上，用于设置电源管理的有关数据。这些数据可以在“控制面板”中打开“电源管理”对话框中的“电源方案”选项下进行修改。

PowerCfg子键具有如下键值数据：

# CurrentPowerPolicy=0：设置电源方案为“家庭/办公室桌面”。电源方案的序号由PowerPolicies子键下的子键内容确定。

PowerCfg子键下面还有如下两个子键：

(1) GlobalPowerPolicy 子键

    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\GlobalPowerPolicy分支上，用于设置全局电源方案。该方案是由该子键下面的键值数据确定的：

# Policies=hex:01,00,00,00,06,00,00,00,03,00,00,00,00,...... ：设置全局电源方案数据。

(2) PowerPolicies 子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\PowerPolicies分支上，用于设置电源方案的序号以及方案数据。

①0子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\PowerPolicies\0分支上，用于设置“家庭/办公室桌面”的电源方案。

# Name=家庭/办公室桌面：电源方案的名称。
# Description=此方案适用于大多数整天不关电源的家用或桌面计算机。电源方案的描述。#
# Policies=hex:01,00,00,00,02,00,00,00,01,00,00,00,00,00,......。电源方案数据。

②1子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\PowerPolicies\1分支上，用于设置“便携型/膝上型”的电源方案。

# Name=便携型/膝上型：电源方案的名字。
# Description=此方案是为延长旅途中使用的便携机电池寿命而设计。：该电源方案的描述。
# Policies=hex:01,00,00,00,02,00,00,00,01,00,00,00,00,...... ：电源方案数据。

③3子键
    该子键位于HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\PowerPolicies\3分支上，用于设置“始终打开”的电源方案。

# Name=始终打开：电源方案的名称。
# Description=此方案使计算机保持运行，这样，他人可从网络访问该计算机。如果您没有网络唤醒硬件，请使用此方案。：该电源方案的描述。
# Policies=hex:01,00,00,00,00,00,00,00,01,00,00,00,00,00,... ...：电源方案数据。

Keyboard子键
    该子键位于HKEY_USERS\.DEFAULT\keyboard layout分支上，用于设置键盘的布局，如键盘语言的加载顺序等，如图。

    该子键下面提供有如下三个子键：

preload子键
    该子键位于HKEY_USERS\.DEFAULT\keyboard layout\preload分支上，用于设置键盘语言的加载序。Preload子键下面的子键个数与您在系统中所安装的键盘语言有关。

Substitutes子键
    该子键位于HKEY_USERS\.DEFAULT\keyboard layout\substitutes分支，用于设置可替换的键盘语言布局。在通常情况下，此子键的设置是空的。

Toggle子键
    该子键位于HKEY_USERS\.DEFAULT\keyboard layout\toggle分支上，用于选择键盘语言。

Software子键
    Software子键对于不同的机器其键值数据是不同的。此子键其实是HKEY_LOCAL_MACHINE\Software分支的一部分，因为这里只涉及Microsoft公司开发的程序以及Netscape公司开发的Navagiator浏览器 ，而HKEY_LOCAL_MACHINE\Software分支则包括了其他应用程序（如Adobe、Corel、Autodesk等）和Microsoft公司开发的应用程序及Netscape公司的Navagiator浏览器的键值数据。由于Windows中文版内嵌了许多Microsoft公司开发的应用程序（如Internet Explorer 5.0、NetMeeting、FrontPage Express等），因此，该子键在注册表中就显得十分重要。通过修改该子键下，就可以实现Windows的某些重要功能。


HKEY_USER 根键(二）
2000-06-27· 生哥·yesky

Microsoft子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft分支上，用于设置Microsoft公司开发的应用程序的键值数据。

(1) Internet Explorer子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer分支上，用于设置Internet Explorer 5.0的键值数据。

Internet Explorer子键还有一个子键：

Main子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer\Main分支上，用于设置Internet Explorer 5.0软件的主操作界面。

(2) Java VM子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Java VM分支上，用于设置Java虚拟机（VM）。

# EnableJIT=hex:01,00,00,00：确定是否允许使用JIT（Java Internet Toolbar）。如果为
“01,00,00,00”，则允许使用JIT。如果为“00,00,00,00”，则禁止使用JIT。
# EnableLogging=hex:00,00,00,00：确定是否允许登录。如果为“01,00,00,00”，则允许使用登录 。如果为“00,00,00,00”，则禁止使用登录。

(3) Windows子键

该子键下面如下子键结构：

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion

CurrentVersion子键用于设置当前Windows版本。其下面有如下子键：

①Applets子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Applets分支上，用于设置Java Applets（Java小程序）。

②Multimedia子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Multimedia分支上，用于设置多媒体驱动程序与应用程序。

(4) Outlook Express子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Outlook Express分支上，用于设置Outlook Express，如图：

(5) Active Setup子键
    该子键具有如下子键结构：

HKEY_USERS\.DEFAULT\Software\Microsoft\Active Setup
HKEY_USERS\.DEFAULT\Software\Microsoft\Active Setup\Installed Components

    该子键中存储了使用Active Setup程序安装组件的信息。Active Setup是Windows最新提供的活动桌面设置程序，如图：

(6) Conferencing子键
    该子键下面具有如下子键结构：
HKEY_USERS\.DEFAULT\Software\Microsoft\Conferencing
HKEY_USERS\.DEFAULT\Software\Microsoft\Conferencing\UI
HKEY_USERS\.DEFAULT\Software\Microsoft\Conferencing\UI\Directory

    Directory子键用于设置Micrososft NetMeeting程序的预设目录服务器个数及其URL地址，如图:

# Count=hex:09,00,00,00：预设的目录服务器的个数（缺省为9个）。

(7) WebPost子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\WebPost分支上，用于设置WebPost程序（这是一个Web发布向导程序，使用此程序可以将FrontPage生成的网页发布到Internet服务器上）。

该子键下面有如下两个子键：

①Logging子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\WebPost\Logging分支上，用于设置WebPost的登录信息。

# LoggingDir=C:\\PROGRA~1\\WebPub~1：设置登录目录。
# WizardLogging=No：确定Web发布向导是否需要登录。若为yes，则需要登录。若为no，则不需要登录。
# WebPostLogging=No：确定WebPost程序是否需要登录。若为yes，则需要登录。若为no，则不需要登录。

②FrontPageWPP子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\WebPost\FrontPageWPP分支上，用于存储FrontPage生成的WebPost的网页（WebPost Page）。

(8) SystemCertificates子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\SystemCertificates分支上，用
于存储系统验证信息，如图:

(9) Internet Account Manager子键
    该子键位于 HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Account Manager分支上，用于设置Internet帐号管理器（InternetAccount Manager）。

# Server ID=dword:0000006b：设置服务器标识。
# Account Name=dword:0000000c：设置帐号名字。
# Default LDAP Account=00000001：设置LDAP（目录服务器）的帐号。
# Default Mail Account=00000008L：设置缺省的电子邮件帐号。
# Default News Account=0000000b：设置缺省的新闻组服务器帐号。

    在该子键下面有一个Accounts子键，用于进一步地设置各种服务器的帐号。对于每种服务器，将在Accounts子键下面提供了类似00000001、00000002等子键，在这些子键中，包含了LDAP目录服务器、电子邮件服务器等。其中LDAP服务器的设置是类似的，而电子邮件服务器的设置也是类似的。在本机器中，00000001子键、00000002子键、......、00000007子键为LDAP服务器，而00000008子键、00000009、0000000a子键为电子邮件服务器。

    下面我们以00000001、00000008子键分别说明LDAP服务器、电子邮件服务器的设置。

①00000001 子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Account Manager\Accounts\00000001分支上，用于设置SwitchBoard目录服务器有关参数。

# Account Name=SwitchBoard：设置帐号。
# LDAP Server=ldap.switchboard.com：设置目录服务器地址。
# LDAP Authentication=dword:00000000：确定是否需要安全验证。若为0，则不需要安全验证
# LDAP Timeout=dword:00000003：设置连接失败时重试的次数（缺省为3次）。
# LDAP Search Return=dword:00000064：设置目录服务器在搜索时的返回地址。
# LDAP Server ID=dword:00000064：设置目录服务器的标识。
# LDAP Resolve Flag=dword:00000000：设置目录服务器的分析标志。
# LDAP URL=http://www.switchboard.com：设置目录服务器的URL地址。
# LDAP Port=dword:00000185：设置目录服务器的端口地址（缺省为185）。
# LDAP Secure Connection=dword:00000000：确定是否设置安全连接。若为0，则不设置安全连接。
# LDAP Logo=C:\\PROGRA~1\\COMMON~1\\Services\\swtchbrd.bmp：设置SwitchBoard目录服务器的显示微标。
# LDAP Bind DN=dword:00000000：确定是否设置绑定（Bind）域名服务器（DN）。若为0，则不绑定域名服务器。
# LDAP Simple Search=dword:00000000：确定是否执行简单搜索。若为0，则不执行简单搜索。

          Accounts子键下面其他子键所对应LDAP服务器的帐号

Accounts子键下面其他LDAP服务器的子键 | 帐 号 | LDAP服务器 | LDAP的URL 地址
00000 002子键 | Yahoo! People Search | ldap.yahoo.com | Http：//www.yahoo.com/search/people/
00000 003子键 | Info Space | ldap.infospace.com | Http://www.infospace.com
0000 0004子键 | Info Space Business | ldapbiz.infospace.com | Http://www.infospace.com
00000 005子键 | Bigfoot | ldap.bigfoot.com | http://www.bigfoot.com
0000 0006子键 | WhoWhere | ldap.whowhere.com | http://www.whowhere.com
0000 0007子键 | Verisign | directory.verisign.com | Http://www.verisign.com

②00000008子键
    该子键位于HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Account Manager\Accounts\00000008分支上，用于设置电子邮件服务器的有关参数。

# Account Name=163.net：设置邮件服务器的帐号名称。
# Connection Type=dword:00000002：指定连接类型（此类型由“Internet连接向导”指定）。
# Connectoid=CQ163：设置连接标识。
# POP3 Server=pop.163.net：设置POP3服务器地址。
# POP3 User Name=Wanji：指定POP3用户名称。
# POP3 Password2=hex:01,01,07,00,00,00,16,7f,7f,77,00,00,63：指定POP3服务器的密码。
# POP3 Use Sicily=dword:00000000：确定是否使用“安全密码验证（SPA）”登录。若为0，则不使用“安全密码验证”登录。
# SMTP Server=public.cta.gz.cn：设置SMTP服务器地址。此地址可为本地SMTP服务器的地址。
# SMTP Display Name=王晶：SMTP显示名字。
# SMTP Email Address=Wanji@163.net：指定SMTP电子邮件地址。

Accounts子键下面其他子键所对应电子邮件服务器的帐号

子键 名称 | 帐 号 | POP3 服务器 | POP3 用户 名 | POP3密码 | SMPT
0000 0009 子键 | CQ 163 | Public.cta.gz.cn | Wanji | hex:01,01,07,00,00,00,16,7f,7f,77,00,00,63 | public.cta.gz.cn
000 0000a 子键 | 263 NET | pop.263.net | Wan ji_1 | hex:01,01,07,00,00,00,16,7f,7f,77,00,00,63 | Public.cta.gz.cn


注册表有关桌面的修改项
2000-07-30· 不详·YESKY

路径:[HKEY_CURRENT_USER\Control Panel\Desktop]

键值1:　"PaintDesktopVersion"="1" or "0"
作用: 　在桌面上是否显示Win98版本号

键值2:　"MenuShowDelay"="0"
作用: 　将开始菜单的响应速度设置为最快

路径:[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

键值1:　"NoActiveDesktop"=hex:01, 00,00,00
作用: 　禁止活动桌面(Active Desktop)功能

键值2:　"NoSaveSettings"=hex:01,00,00,00
作用:　 不管你如何修改桌面配置，重启Windows后都将恢复原来的桌面

键值3: "Nodesktop"=hex:01,00,00,00
作用: 　隐藏桌面上的图标

键值4:　"NoStartBanner"=hex:01,00,00,00
作用:　去除"单击这里开始"箭头

路径:[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Desktop\NameSpace]

删除主键　{450d8fba-ad25-11d0-98a8-0800361b1103}
作用:　　　隐藏"回收站"

删除主键　{645FF040-5081-101B-9F08-00AA002F954E}
作用:　　　隐藏"我的文档"

删除主键　{208D2C60-3AEA-1069-A2D7-08002B30309D}
作用:　　　隐藏"网上邻居"

路径:[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]

键值1:　"Attributes"=hex:50,01,00,20
作用:　　为回收站增加"重命名"选项

路径:[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\InProcServer32]

键值1:"默认"="shell32.dll-" 作用:锁定回收站

路径:[HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\InProcServer32]

键值1:"默认"="shell32.dll-" 作用:锁定控制面板

路径:[HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\InProcServer32]

键值1:"默认"="shell32.dll-" 作用:锁定我的文档

路径:[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\InProcServer32]

键值1:"默认"="shell32.dll-" 作用:锁定我的电脑

路径:[HKEY_CURRENT_USER\Control Panel\Colors]

键值1:"Bottontext"="RRGGBB"(RGB) 作用:任意定制窗口颜色

路径:[HKEY_CURRENT_USER\Control Panel\Desktop]

键值1:　"MenuDropAlignment"="0"或"1"
作用:　　设置右键菜单的对齐方式(0左对齐;1右对齐)


注册表开始菜单修改项
2000-07-30· 不详·YESKY

路径:[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

键值1："NoRecentDocsMenu"=hex:01,00,00,00
作用：　隐藏文档(Documents)菜单

键值2："ClearRecentDocsOnExit"=hex:01,00,00,00
作用：　在每次退出系统时，自动清除文档菜单中的历史记录

键值3：″NoRecentDocsHistory″=hex:01,00,00,00
作用：　禁止将最近操作过的文档放入文档菜单历史记录中

键值4：″NoFind″=hex:01,00,00,00 　作用：隐藏查找(Find)菜单

键值5：″NoRun″=hex:01,00,00,00 　 作用：隐藏运行(Run)菜单

键值6：″NoLogOff″=hex:01,00,00,00 作用：隐藏注销到…(LogOff)菜单

键值7：″NoClose″=hex:01,00,00,00 　作用：隐匿关闭系统(ShutDown)菜单

键值8：″NoSetFolders″=Hex:01,00,00,00
作用：　隐匿设置(Setting)菜单中的控制面板＆打印机

键值9：″NoFavoritesMenu″=hex:01,00,00,00 作用：隐匿收藏夹(Favorite)菜单

键值10：″NoStartBanner″=hex:01,00,00,00
作用：　禁止任务栏上"单击这里开始"的提示

键值11："NoSetTaskbar"=hex:01,00,00,00
作用：　禁止设置(Setting)菜单中的任务栏合开始菜单

路径:[HKEY_CLASSES_ROOT\Directory\shell\find\ddeexec]

默认="[FindFolder("路径", 路径)]"
作用:　改变"查找"对话框中的默认搜索路径

路径:[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Shell Icons]

键值："19"="c:\icon\icon1.ico"(图标文件)
键值："43"="c:\icon\icon2.ico"
键值："20"="c:\icon\icon3.ico"
键值："21"="c:\icon\icon4.ico"
键值："22"="c:\icon\icon5.ico"
键值："23"="c:\icon\icon6.ico"
键值："24"="c:\icon\icon7.ico"
键值："44"="c:\icon\icon8.ico"
键值："27"="c:\icon\icon9.ico"
其他还有：6(软驱);8(硬盘);11(光驱);等等...

注意：修改完后，进入windows文件夹， 删除ShellIconCache文件(属性隐藏)，然后重新启动。

改变程序图标
改变收藏夹图标
改变文档图标
改变设置图标
改变查找图标
改变帮助图标
改变运行图标
改变注销图标
改变关机图标


注册表系统优化修改项
2000-07-30· 不详·YESKY

路径:[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem\CDFS]

键值1:"Prefetch"=dword:000000e4(默认值)
作用: 根据您的CDROM速度优化CDROM预读取性能.
注意:(如果修改以上两个键值导致CDROM工作不正常,如:播放VCD时找不到VCD碟,请降低一个级别)
4倍速:000000e4(默认值)
8倍速:000001c0
16倍速:00000380
24倍速:00000540
32倍速:00000700
36倍速:00000750
40倍速:00000800
48倍速:00000800

键值2: "CacheSize"=dword:0000026b(默认值)

作用:根据你的CDROM用途来确定缓存大小
0000026b(默认值)
000004d6(适中)
000009ac(最大)

路径:[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\fdc\0000]

键值1:"ForceFIFO"=dword:00000001
作用:提高软驱读写缓冲性能

路径:[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]

键值1:"ConfigFileAllocSize"=dword:000001f4
作用:优化文件系统


注册表控制面板的修改项
2000-07-30· 不详·YESKY

路径:[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]

键值1:"NoSecCPL"=dword:00000001 作用:禁用"密码"控制面板

键值2:"NoDispCPL"=dword:00000001 作用:禁用"显示"控制面板

键值3:"NoDispBackgroundPage"=dword:00000001
作用:禁用"显示"控制面板中"背景"

键值4:"NoDispScrSavPage"=dword:00000001
作用:禁用"显示"控制面板中"屏幕保护程序"

键值5:"NoDispAppearancePage"=dword:00000001
作用:禁用"显示"控制面板中"外观"

键值6:"NoDispSettingsPage"=dword:00000001
作用:禁用"显示"控制面板中"效果","Web"和"设置"

键值7:"NoDevMgrPage"=dword:00000001
作用:禁用"系统"控制面板中"设备管理器"

键值8:"NoConfigPage"=dword:00000001
作用:禁用"系统"控制面板中"硬件配置文件"

键值9:"NoVirtMemPage"=dword:00000001
作用:禁用"系统"控制面板中"性能"中"虚拟内存"

键值10:"NoFileSysPage"=dword:00000001
作用:禁用"系统"控制面板中"性能"中"文件系统"

路径:[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Network]

键值1:"NoNetSetup"=dword:00000001 作用:禁用"网络"控制面板

键值2:"NoNetSetupIDPage"=dword:00000001
作用:禁用"网络"控制面板中"标识"

键值3:"NoNetSetupSecurityPage"=dword:00000001
作用:禁用"网络"控制面板中"访问控制"

键值4:"NoWorkgroupContents"=dword:00000001
作用:禁用"网络"控制面板中"工作组内容"

键值5:"NoEntireNetwork"=dword:00000001
作用:禁用"网络"控制面板中"整个网络"

键值6:"NoFileSharingControl"=dword:00000001
作用:禁用"网络"控制面板中"文件与打印机共享"


巧改注册表来增强网络功能
2000-08-07· 周勇生·YESKY

    １、指定首选的网络服务器

    在注册表中依次展开[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider]，并在其主键下创建或更改串值AuthenticatingAgent，附值为指定的服务器

    ２、禁止自动登陆网络

    在注册表中依次展开[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider]，同时在下面主键下创建DWORE值DisableDefaultPasswords，（1=取消自动登陆，0=自动登陆）

    ３、显示域名登陆确认

    在注册表中依次打开[HKEY_LOCAL_MACHINE\Network\Logon]在下面主键下创建或更改DWORD值DomainLogonMessage,(0=取消，1=启用)

    ４、清理访问“网络邻居”后留下的字句信息

    使用局域网的用户在访问网络邻居时，注册表会在HEKY_CURRENT_USER/Network/Recent主键项中记录下一系列命令操作的信息，包含被访问机器的名字、访问过的应用程序及文件名等，如：主键Recent包含一名为\ierl_server\software的子主键项，表示你曾访问过名为ierl_server的服务器中的software文件夹，点击此项后编辑器右窗显示此项的名称及键值。这些内容基本没有用途，可以适当的清理一下。打开注册表编辑器后，按以下顺序依次打开各级主键：HEKY_CURRENT_USER、Network、Recent,然后把主键Recent的子项删除即可。

    ５、更改IE4.0的安全口令

    您可以在IE4.0的“Internet选项”对话框的“内容”选项页的“分级审查”框中设置口令，这样，在显示有ActiveX的页面时，总会出现“分级审查不允许查看”的提示信息，然后弹出口令对话框，要求您输入监护人口令。如果口令不对，则将停止浏览。但是，如果此口令遗忘了，则无法浏览这些特征的页面。在口令遗忘后，重装IE4.0也无法去掉安全口令。这时只有求助于注册表了：
    打开HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Windows\CurrentVersion\Policies分支，在Policies子键下选择“Ratings”子键，按Del键将其删除，由于Ratings子键下的Key键值数据就是经过加密后的口令，删除了这一项，IE4.0自然就认为您没有设置口令了。

    ６、从Netscape中清除曾到过的网址

    为了保密起见，您可以清除Netscape的“Address”框的下拉式菜单内的网址，这样别人就无法获得您曾到过的网站。
    （１）在Netscape 3.x中，您必须通过注册表编辑器修改注册表达到此目的，其操作步骤如下：打开HKEY_CURRENT_USER\Software\Netscape\NetscapeNavigator\URLHistory分支。在右窗格中我们可看到这些曾到过的网址的列表清单，选择要删除的网址选项，然后按Del键即可。
    （２）在Netscape 4.x中，首先用记事本中打开文件C:\Program
    Files\Netscape\Users\caogjwj\prefs.js假定您的注册名称为zys666），此文件的内容通常是这样的：user_pref（“browser.url_history.URL_2"，“http://pcworld.com.cn/"）
    在此文件中删除其中您想要隐藏的网址整行，然后存盘退出即可。
    为了让Netscape 4.x不再向prefs.js文件中写入任何网址，将此文件的属性改为只读即可。

    ７、为一台机器设置两个IP地址

    一般情况下只能为一个网络适配器配置一个IP地址，但通过修改系统注册表，却可以为一个网卡配置多个IP地址：运行注册表编辑器，找到HKEY_LOCAL_MACHINE\System\Cu rrentControlSet\Services\Class\NetTrans，在此目录中可以看到多个名为0000、0001、0002…的目录，它们用于记录协议的安装情况。在它们中间找到DriverDesc为“TCP/IP”的目录，修改IPAddress和IPMask两个键。其中IPAddress为用逗号隔开的多个IP地址，I PMask是对应的掩码。例如设置IPAddress为“2１0.７３.１４０.３，２１０.７３.１４０.５”，IPMask为“255.255.255.192，255.255.255.192”时，表示为系统设置了两个IP地址2１0.７３.１４０.３和２１０.７３.１４０.５。

    ８、加快网络传输速度

    Windows操作系统在网络拨号设计上有加强的余地，只需增加MaxMTU、MaxSSS、DefaultRcvWindow及DefaultTTL就能加快网上奔驰的速度。
    a.修改MaxMTU及MaxSSS启动注册表编辑器，找出以下关键字：HKEY_LOCAL_MACHINE\System\Current
    Control Set\Services\Class\NetTrans\000n（n表示个别拔号网络连接项号码）。例如0002，在***n右面Windows会有一些如DeviceVxDs、IpAddress等名称，在右边窗口任意空白外点击，在菜单上选“编辑”→“新增”→“字符串值”，右边窗口就会多出一个新字符串，把它命名为“MaxMTU”，再双按这个字符串值并把它设定为“576”。同样，在右边窗口加上“MaxSSS”字符串值并将它的值设定为“536”。
    b.修改DefaultRcvWindow及DefaultTTL启动注册表编辑器，找出以下关键字：HKEY_LOCAL_MACHINE\System\Current Control Set\Services\VxD\MSTCP在右边窗口加上字符串值“DefaultRcvWindow”并把它的值设定为“2144”，再增加另一字符串值“DefaultTTL”并把它的值设定为“60”至“64”（注：60是最小值，64是最大值，只要填上其中一个值就可），完成後关闭注册表编辑器并重新启动Win95即可。

    ９、修改IE5.0的搜索引擎

    在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Microsoft\Internet
    Explorer\Search”，在右侧窗口中把“CustomizeSearch”、“SearchAssistant”改为你定义的搜索引擎，如http://www.yeah.net/，以后当你每次点IE5.0的搜索引擎时，即可自动调出你定义的搜索引擎，如上面设定的中文搜狐。

    １０、解决局域网中启动直接登录问题

    有时重新安装了操作系统后，启动时不能直接登录局域网，而只能通过按“开始”/注销，才能出现登录界面，解决方法是在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real
    Mode Net”，将右侧窗口中的AutoLogon删除即可。

    １１、定制IE地址

    用过IE的人都遇到过“取消操作”提示，还有“Web页不可脱机使用”，“警告：网页已经过期”等情况，但是你有没有注意到出现提示页时地址栏中显示的是什么，URL为“about:xxxxxxx”。about是除了“http”、“ftp”、“mailto”、“gopher”外的特殊协议，利用它可以使用别名调阅特定的网页，比如IE的空白页，则的URL栏中打入about:blank即可，blank即为空白页的别名。
    利用这可通过创建类似的别名，指向我指定的网页地址，在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Microsoft\Internet
    Explorer\AboutURLs”，在右侧窗口中单击鼠标右键，从弹出的快捷菜单中，选择“新建”、“串值”，然后将“新值#1”更名为你要给指向的网页（网址）取的名字，右击该名字，再将其值设置为你想要指向的网址，注意不能省了“http://”。
    你也可以用此法给硬盘上常用网页取个别名，填上路径即可方便打开了。

    １２、防止他人获取对Web页面的访问信息

    通过修改注册表我们可以隐藏曾浏览过的URL地址。其方法如下：
    对于Netscap的用户：在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Netscape\Netscape
    Navigator”分支，删除其下的URL子键的所有内容。
    对于IE用户：在注册表中依次展开“HKEY_CURRENT_USER\Software\Microsoft\Internet
    Explorer\TypedURLs”分支，删除其下的URL子键的所有内容。

    １３、更改Outlook Express信箱存放路径

    如果您想修改Outlook Express信箱存放路径，可以在HKEY_CURRENT_USER\Identities\{4C44D002-7BCF-11D3-9957-AB53DA238B0C}\Software\Microsoft\Outlook
    Express\5.0下修改“Store Root”字符串值为要修改的路径。

    １４、增加IE4.0自动识别功能

    经常上网的朋友知道，您要访问形如www.ＸＸＸ.com这样的网站时，只要在地址框中直接键入ＸＸＸ，IE就会自动加上.com的后缀进行访问，省去了很多麻烦。但是如果您想访问www.ＸＸＸ.com.cn这样的网站就没那么方便了，因为IE未包含.cn后缀的自动连接功能。
    为了能够增加上述的识别功能，用户可以依次打开注册表HKEY_LOCAL_MACHINE\Software\Microsoft\Internet
    Explorer\Main\UrlTemplate，点击右键，选择新建字符串，输入www..%s.com.cn即可添加。


神奇注册表

给“控制面板”改名、改图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}下在右边的窗口中修改字符串值“(默认)”为新的名称改图标:在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon下,在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改“打印机”图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{2227A280-3AEA-1069-A2DE-08002B30309D}\DefaultIcon
下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改Internet Explorer的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon下，在右边的窗口中修改字符串值“(默认)”为新图标的路径，如：“C:\w.ico,0”。

在桌面上显示WINDOWS版本标志
HKEY_USERS\.DEFAULT\Control Panel\desktop
在右边的窗口中新建一个字符串值：“PaintDesktopVersion”，并设其值为“1”。

禁止在桌面上显示图标
我们安装了许多软件后，往往会在系统的桌面上出现许多图标，点击这些图标可以启动相应的软件程序，过多的图标使桌面变得花花绿绿，想恢复原来清洁的桌面，又不想删除这些图标，就可以使用一下的方法，把桌面上的所有图标都隐藏起来。
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建一个DWORD值：“NoDestop”，并设其值为“1”。

禁止显示提示
当我们把鼠标指向“我的电脑”，“我的文件夹”,“回收站”等图标时往往会出现一些提示信息，这些 信息对一个熟悉WINDOWS的操作者来讲，是不必要的，我们想禁止显示这些提示，可使用下面的方法。
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\Advanced下在右边的窗口中修改DWORD值“ShowInfoTip”，设其值为“0”。

禁止使用任务栏
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个DWORD值：“NoSetTaskBar”，并设其值为“1”。
此条技巧的作用是当我们在系统的任务栏上点击鼠标右键，再选择“属性”时，将会出现以下的提示信息： “本次操作由于这台计算机的限制而被取消。请与你的系统管理员联系”。

高彩色显示图标
当我们按照完windows后，windows的图标都是用位数较小的色彩来显示图标的，使用下面的方法可以用16位色显示图标,运行注册表编辑器，依次展开到 HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon BPP”，并设其值为“16”。

改变图标大小
HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值即改变图标大小，缺省值为“32”。

进入WINDOWS98时显示欢迎提示
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Run 在右边的窗口中新建一个字符串值：“Welcome”，设值为“Welcome.exe /R”。

以12小时制显示时间
HKEY_USERS\.DEFAULT\Control Panel\International在右边的窗口中找到字符串值：“sTimeFormat”，改其值为“h:mm tt”。

给“回收站”改名、改图标
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
在右边的窗口中找到字符串值：“默认”，把“回收站”改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的电脑”改名、改图标
HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}
在右边的窗口中找到字符串值：“默认”，把“我的电脑”改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的文档”改名、改图标
在右边的窗口中找到字符串值：“默认”，把“我的文档”改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\DefaultIcon

隐藏快捷方式的小箭头
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\Explorer\Shell Icons
在右边的窗口中新建字符串值：“29”，数据内容空白。

禁止名称有“快捷方式”四个字
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Explorer
在右边的窗口中新建一个二进制值“link”，并设其值为“00 00 00 00”。

使用三键鼠标
在HKEY_LOCAL_MACHINE\SOFTWARE\Logitech\ouseWare
\CurrentVersion \SerialV \0000下 ，改为DoubleClick to 001。

更改WINDOWS系统的产品名
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion下 在右边的窗口中找到字符串值“ProductName”，更改键值即可。打开系统属性看看效果

更改WINDOWS系统的用户名
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion下 在右边的窗口中找到字符串值“RegisteredOwner”，更改键值即可。打开系统属性看看效果。


神奇注册表

预防BackDoor的破坏
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Run 若在右边窗口中如发现了“Notepad”键值，就将它删除。

预防WinNuke的破坏
在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
\VxD\MSTCP下 在右边的窗口中新建或修改字符串“BSDUrgent”，设其值为0。

预防KeyboardGhost的破坏
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\RunServices下 如发现KG.EXE这一键值，就将它删除，并查找KG.exe文件和kg.dat文件，将它们都删除

查找NetSpy黑客程序
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Run下, 在右边的窗口中寻找键"NetSpy",如果存在,就说明已经装有NetSpy黑客程序,把它删除.

清理访问“网络邻居”后留下的字句信息
在HEKY_CURRENT_USER/Network/Recent下删除下面的主键。

取消登陆时自动拨号
在HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/
CurrentVersion/Network/RealModeNet下 修改右边窗口中的“autologon”为“01 00 00 00 00”。

取消登录时选择用户
已经删除了所有用户，但登录时还要选择用户，我们要取消登录时选择用户，就要在HKEY_LOCAL_MACHINE\Network\Logon下在右边的窗口中,修改"UserProfiles"值为"0"。

隐藏上机用户登录的名字
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下 在右边的窗口中新建字符串"DontDisplayLastUserName",设值为"1"。


神奇注册表

更改网络工作组图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons下在右边的窗口中新建字符串值"2",并设其值为新图标的路径。

更改WEB文件夹图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{BDEADF00-C265-11D0-BCED-00A0C90AB50F}\DefaultIcon下,在右边的窗口中修改"默认"为新图标的路径。

更改DOS程序的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons下，在右边的窗口中新建字符串值"2",并设其值为新图标的路径。

更改5寸软盘的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"5",并设其值为新图标的路径。

更改可移动驱动器的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer\Shell Icons下
下，在右边的窗口中新建字符串值"5",并设其值为新图标的路径。

更改"注销"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"44",并设其值为新图标的路径。

更改"运行"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"24",并设其值为新图标的路径。

更改"关闭系统"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"27",并设其值为新图标的路径。

更改"收藏夹"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"43",并设其值为新图标的路径。

更改"查找"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons下，在右边的窗口中新建字符串值"22",并设其值为新图标的路径。

更改"开始"菜单中"程序"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons下，在右边的窗口中新建字符串值"19",并设其值为新图标的路径。

更改pbl文件的图标
在HKEY_CLASSES_ROOT下查找键值"pblfile", 并在这个主键的\DefaultIcon,修改右边窗口中的“默认”值为新图标的路径.

更改Internet Explorer的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon下，在右边的窗口中修改字符串值“(默认)”为新图标的路径，如：“C:\w.ico,0”。

更改"打开的文件夹"的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"4",并设其值为新图标的路径。

更改3寸软盘的图标
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Shell Icons 下，在右边的窗口中新建字符串值"6",并设其值为新图标的路径。

更改IE的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改"我的公文包"的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{85BBD920-42A0-1069-A2E4-08002B30309D}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改“计划任务”的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改“收件箱”的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{00020D75-0000-0000-C000-000000000046}\DefaultIcon
下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

给“控制面板”改名、改图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}下 在右边的窗口中修改字符串值“(默认)”为新的名称
改图标:在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon下,在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改“打印机”图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{2227A280-3AEA-1069-A2DE-08002B30309D}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

给“回收站”改名、改图标
HKEY_CLASSES_ROOT\CLSID
\{645FF040-5081-101B-9F08-00AA002F954E}
在右边的窗口中找到字符串值：“默认”，把“回收站”改为其它名称。
HKEY_CLASSES_ROOT\CLSID
\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的电脑”改名、改图标
HKEY_CLASSES_ROOT\CLSID
\{20D04FE0-3AEA-1069-A2D8-08002B30309D}
在右边的窗口中找到字符串值：“默认”，把“我的电脑”改为其它名称。 HKEY_CLASSES_ROOT\CLSID
\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的文档”改名、改图标
在右边的窗口中找到字符串值：“默认”，把“我的文档”改为其它名称。 HKEY_CLASSES_ROOT\CLSID
\{450D8FBA-AD25-11D0-98A8-0800361B1103}\DefaultIcon
在右边的窗口中修改图标的路径


神奇注册表

禁止磁盘空间不足时的警告
我们在安装软件的过程中，往往不能预料软件需要使用多大的磁盘空间，当空间不够的时候，就会弹出一个空间不足的警告框，使用以下方法就是避免出现这个对话框逐渐展开到HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\FileSystem下在右边的窗口中新建一个二进制值“DisableLowDiskSpaceBroadcast”，并设值为“FF FF FF FF”，
如果想恢复出现这个警告框，只需删除此键。

禁止显示"远程管理"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System下在右边的窗口中新建一个DWORD值“NoAdminPage”，并设值为“1”。

禁止显示“注销”菜单
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建一个二进制值“NoLogOff”，并设值为“01 00 00 00”。

禁止显示“开始”菜单中“收藏夹”菜单
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建一个值“NoFavoritesMenu”，并设值为“1”。

禁止使用inf文件
在HKEY_LOCAL_MACHINE\Software\CLASSES\.inf下在右边的窗口中更改“默认”值为“txtfile”

禁止使用reg文件
在HKEY_LOCAL_MACHINE\Software\CLASSES\.reg下在右边的窗口中更改“默认”值为“txtfile”

禁用"打印机"中的"删除打印机"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 下，在右边的窗口中新建DWORD值“NoDeletePrinter”，并设其值为“1”。

禁用"打印机"中的"添加打印机"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 下，在右边的窗口中新建DWORD值“NoAddPrinter”，并设其值为“1”。

禁用“网络”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Network\System 下，在右边的窗口中新建DWORD值“NoNetSetup”，并设其值为“1”。

禁用“用户”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 下，在右边的窗口中新建DWORD值“NoProfilePage”，并设其值为“1”。

禁用“密码”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 下，在右边的窗口中新建DWORD值“NoSecCPL”，并设其值为“1”。

禁止修改开始菜单
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中创建一个DOWRD值："NoChangeStartMenu",并将其值设为“1”。

禁止修改“控制面版”
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建一个二进制"NoSetFolders",并将其值设为"01 00 00 00"。

禁止快速启动
在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\Shutdown下在右边的窗口中修改一个字符串值：“FastReboot”，并将其值设为“0”。

在退出WINDOWS时清除“文档”中的记录
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建一个二进制"ClearRecentDocsOnExit",并将其值设为"01 00 00 00"。

允许按ESC取消登录
在HKEY_LOCAL_MACHINE\Network\Logon下在右边的窗口中创建一个DOWRD值：“MustBeValidated”，并将其值设为“1”。

禁止使用注册表编辑文件regedit.exe
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中创建一个DOWRD值："DisableRegistryTools"，并将其值设为“1”。

禁止更改控制面板和打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DOWRD值：“NoSetFolders”，并将其值设为“1”。

禁止修改显示属性
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中创建一个DOWRD值：“NoDispCPL”，并将其值设为“1”。

隐藏我的电脑中的驱动器
隐藏所有驱动器：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“FFFFFFFF”；
隐藏E盘：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“10”；
隐藏D盘：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“8”；
隐藏C盘 ：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“4”。
隐藏A盘 ：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“1”。

退出不保存设置
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
把二进制值“NoSaveSettings”改为“01 00 00 00”。

禁用MS—DOS方式
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在该分支下新建主键“WinOlaApp"，然后点击该主键，在右边的窗口中创建一个DWORD值“Disabled", 并设其值为“1”。

禁止“重新启动计算机切换到MS-DOS方式”
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值“NoRealMode”，并设其值为“1”。

在“我的电脑”中显示“计划任务”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace
在该分支下创建一个主键
“{D6277990-4C6A-11CF-8D87-00AA0060F5BF}”，
在右边的窗口中创建字符串“默认”，设值为“Scheduled Tasks”。

在“我的电脑”中显示“拨号网络”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace在此分支下新建一个主键
“{992CFFA0-F557-101A-88EC-00DD010CCC48}”，
单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为"拨号网络"。

在我的电脑中显示“打印机”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace在此分支下新建一个主键
“{2227A280-3AEA-1069-A2DE-08002B30309D}”，
单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为“打印机”。

禁止PC在出错时发出声音
HKEY_CURRENT_USER\Control Panel\Sound
在右边的窗口中，把字符串“Beep”的值改为“No”。

禁止CD-ROM自动运行
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
\Services\CDRom 在右边的窗口中，把DWORD值“Autorun”改为“0”。“1”表示自动运行。

禁止改变打印机设置
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边窗口中创建DWORD值：“NoPrinters”，并设值为“1”。

禁止出现“点击这里开始”的提示
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个二进制值：“NoStartBanner”，设值为“01 00 00 00”。


神奇注册表

开始菜单使用多页面显示
但程序中的菜单过多时，往往一页显示不出来，这时使用下面的功能实现菜单多页面显示
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\Advanced下 在右边的窗口中新建字符串值“StartMenuScrollPrograms”，并设值为“false”。
要取消这项功能，只需删除该字符串。

禁止显示"开始"菜单中的"windows升级菜单"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个二进制值“NoWindowsUpdate”，并设值为“1”。

不允许改变启动菜单
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个DWORD值“NoChangeStartMenu”，并设值为“1”。

调整双击灵敏度的区域
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“DoubleClickHeight”和“DoubleClickWidth”的值，即可改变区域大小。

改变菜单的显示速度
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MenuShowDelay”，其值范围为0-999，0表示最快。

窗口打开、缩小、关闭时是否显示动画过程
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MinAnimate”，数据为“0”表示不显示过程，“1”表示显示。

禁止“关闭系统”菜单
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个DWORD值“NoClose”，并设值为“1”。

禁止WINDOWS平滑卷动
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“SmoothScroll”，设其值为“0”，若允许则设值为“1”。

禁止“查找”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值“NoFind”，并设值为“1”。

禁止“文档”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值“NoRecentDocsMenu”，并设值为“1”。

禁止“运行”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值“NoRun”，并设值为“1”。

在开始菜单中创建“控制面板”等菜单
下面是相应的名称
打印机.{2227A280-3AEA-1069-A2DE-08002B30309D}
控制面板.{21EC2020-3AEA-1069-A2DD-08002B30309D}
我的电脑.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
回收站.{645FF040-5081-101B-9F08-00AA002F954E}

去掉“开始”选单中的“登录”项。
HKEY_CURRENT_USER\Software\Microsoft\Windwos
\CurrnetVersion\Ploicies\Explorer 在右边窗口中创建二进制值：“NoLogOff”，并设其值为“01 00 00 00”。

禁止向“开始”中的“文档”保留历史记录
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边窗口中创建DWORD值：“NoRecentDocsHistory”，并设其值为“1”。


神奇注册表

禁止使用代理服务器
代理服务器的用途很大，比如可以使原来只能国内站点的电脑，在使用代理服务器后，能访问国外站点，但代理服务器的使用也会带来不利的地方，因此，我们可以通过注册表来禁止使用代理服务器,
在HKEY_LOCAL_MACHINE\Config\0001\Software\Microsoft
\windows\CurrentVersion\Internet Settings下在右边的窗口中新建二进制值“ProxyEnable”的键值为"00 00 00 00"。

在IE中禁止显示工具栏
在 HKEY_USERS\.DEFAULT\Software\Microsoft
\Internet Explorer\Main 下在右边的窗口中修改字符串“Show_URLToolBar”的键值为"no"。

在IE中禁止显示状态栏
在 HKEY_USERS\.DEFAULT\Software\Microsoft
\Internet Explorer\Main 下在右边的窗口中修改字符串“Show_StatusBar”的键值为"no"。

更改"应用程序"的文件夹的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders
下，在右边的窗口中修改字符串“Recent”的键值为新的文件夹路径，如:C:\cpu ,注意：cpu这个文件夹必须是存在的，否则新建一个文件夹。

更改"应用程序数据"的文件夹路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders
下，在右边的窗口中修改字符串“AppData”的键值为新的文件夹路径。

预防BackDoor的破坏
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Run 若在右边窗口中如发现了“Notepad”键值，就将它删除。

预防WinNuke的破坏
在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\VxD\MSTCP下在右边的窗口中新建或修改字符串“BSDUrgent”，设其值为0。

预防KeyboardGhost的破坏
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\RunServices下 如发现KG.EXE这一键值，就将它删除，并查找KG.exe文件和kg.dat文件，将它们都删除

为同一部电脑设置2个IP地址
在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\Class\NetTrans下点击0000、0001，0002.....留意右边的窗口，当你发现右边窗口中的字符串"DriverDesc"的值
为"TCP/IP",修改同一窗口中的字符串"IPAddress"和"IPMask",把IPAddress设为IP地址
如"198.0.1.9,198.0.1.7",把"IPMask"设为对应的掩码,如"255.255.255.0,255.255.255.0"

查找NetSpy黑客程序
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\Run下,在右边的窗口中寻找键"NetSpy",如果存在,就说明已经装有NetSpy黑客程序,把它删除.

更改Internet Explorer的标题
在HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main下
在右边的窗口中修改字符串值“Window Title”为新标题的名字。

更改outlook express的标题
在HKEY_USERS\.DEFAULT\Software\Microsoft\Outlook Express下在右边的窗口中修改字符串值“WindowTitle”为新的标题名字。

改变“超级链接”处点击前后的颜色
在HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Settings下在右边的窗口中修改“Anchor Color”和“Anchor Color Visited”的值即可修改修改点击前后的颜色。

清理访问“网络邻居”后留下的字句信息
在HEKY_CURRENT_USER/Network/Recent下删除下面的主键。

取消登陆时自动拨号
在HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows
/CurrentVersion/Network/RealModeNet下修改右边窗口中的“autologon”为“01 00 00 00 00”。

加快上网速度
以下有几项方法可以改变上网速度：
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\VxD\MSTCP 在右边的窗口中把“DefaultRcvWindow”的值改为“6400”，把“DefaultTTL”改为“128”。
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\Class\NetTrans 在右边窗口中创建字符串值“MaxMTU”,“MaxMSS”，并设“MaxMTU”为“576”，设“MaxMSS”为“536”。

禁止使用网上邻居
在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下
在右边窗口中创建DWORD值“NoNetHood”，并设为“1”。

改变和增加IE自动搜索的顺序
在HKEY_LOCAL_MACHINE\Software\Microsoft
\Internet Explorer\Main\UrlTemplate下在右边窗口中，我们可以看到有几个字符串，IE按照1,2,3,4....的顺序进行自动搜索，调整1，2，3，4...字符串的键值互相交换，即可调整自动搜索的顺序，亦可新建字符串,增加自动搜索的内容。

在“开始”菜单中增加“网上邻居”
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\NetworkNeighborhood
下新建主键“NameSpace”，然后在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\MenuOrder\Start Menu\
下新建主键“网上邻居”。

禁止在"控制面板"中显示"网络"属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建DWORD值“NoNetSetup",并设其值为“1”。

禁止在“网络”中显示“标识”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下在右边的窗口中新建DWORD值“NoNetSetupIDPage”,并设其值为“1”。

禁止在“网络”中显示“整个网络”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下在右边的窗口中新建DWORD值“NoEntireNetwork”,并设其值为“1”。

更改IE的缓冲的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders下更改“Cache”的路径即可。

改变下载的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer下在右边的窗口中新建DWORD值“Download Directory”,并设其值为你想要的下载路径,如C:\My Documents。

禁止查找用户
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\FindExtensions
\Static\WabFind下，删除主键“WabFind”。

改变收藏夹、Cookies、启动、历史记录的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders下找到字符串值“Favorites”,并设其值为你想要的下载路径,如C:\WINDOWS\Favorite。
在此窗口中可更改桌面的路径、Cookies的路径、启动的路径、历史记录的路径。

创建"拨号网络"在开始菜单中
打开任务栏和开始菜单，选择“高级”，在右边的窗口中新建文件夹 “拨号网络.
{992CFFA0-F557-101A-88EC-00DD010CCC48}”。

网址URL的调整
我们在使用IE上网时输入的网址，会在注册表里面留下一些记录，记录着你输入过那些网址，当你下次再输入该网址时，只需输入几个字母，IE就会自动的输入完整的网址，大大方便了我们，在以下的方法中，我们可以手动的在WINDOWS的注册表中增加一些网址URL，使上网时更方便。依次展开在HKEY_CURRENT_USER\Software\Microsoft
\Internet Explorer\TypedURLs下在右边的窗口中按url1、url2、url3......顺序排列着一些URL,修改，增加，删除这些url的值即可达到修改，增加，删除URL的功能。

取消登录时选择用户
已经删除了所有用户，但登录时还要选择用户，我们要取消登录时选择用户，就要在HKEY_LOCAL_MACHINE\Network\Logon下， 在右边的窗口中,修改"UserProfiles"值为"0"。重新启动WINDOWS，使这条技巧生效。

隐藏上机用户登录的名字
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下在右边的窗口中新建字符串"DontDisplayLastUserName",设值为"1"。

显示“频道栏”
在HKEY_CURRENT_USER\Software\Microsoft
\Internet Explorer\Main下在右边的窗口中修改字符串"Show_ChannelBand"为"yes"。


神奇注册表

 允许强制关闭系统
在我们运行程序的时候，有时会遇到软件程序没反映的现象，于是我们按CTRL+ALT+DEL来关闭系统，而当我们按下后，系统会叫我们退出前要使软件程序退出，使用本功能可允许强制关闭系统。在HKEY_USERS\.DEFAULT\Control Panel\desktop下，在右边的窗口中创建一个字符串值： “AutoEndTasks”，并将其值设为“1”。

禁止光标闪动
在HKEY_USERS\.DEFAULT\Control Panel\desktop下在右边的窗口中创建一个字符串值：“CursorBlinkRate”，并将其值设为“-1”。

删除“查找”命令保留在注册表中的搜索结果
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\Doc Find Spec MRU下删除右边窗口中的键

进入Win98前给出警告信息
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下 键值：″LegalNoticeCaption″=″问候″
说明：这是信息框的标题。
键值：″LegalNoticeText″=″欢迎光临″ 说明：这是信息框的文本内容。

WINDOWS98登录口令
HKEY_LOCAL_MACHINE\Network\Logon
在右边的窗口中创建一个DOWRD值："MustBeValidated"，并将其值设为“1”，在启动WINDOWS98后按ESC键将不能显示画面。

开机时进行“多用户登录”选择
在HKEY_LOCAL_MACHINE\Network\Logon下在右边的窗口中创建一个DOWRD值：“UserProfiles”，并将其值设为“1”。

开机时自动登录系统
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下在右边的窗口中创建字符串值：“AutoAdminLogon”，并将其值设为“1”；还创建字符串值“DefaultPassword”，其值为登录时的密码，创建字符串值：“DefaultUserName”，其值为登录时所用的用户名。对单机用户有意义

自动更新
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\Update把二进制值“UpdateMode”改为“00 00 00 00”。

鼠标自动激活当前窗口
HKEY_USERS\.DEFAULT\Control Panel\desktop
把二进制值“UserPreferencemask”改为“AF 00 00 00”。

查看安装时输入的WIN98密码
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion 点击“ProductKey”，即可看到。

改变WINDOWS有关文件的安装路径
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Setup 在右边的窗口中，有“BootHost”、“BootDir”、“SourcePath”、“MediaPath”.....
改变其数据内容,就可改变相关文件的路径。

设立缺省的用户名和公司名称
HKEY_CURRENT_USER\Software\Microsoft
\MS Setup (ACME)\User Info 在右边窗口中找到字符串值：“DefCompany”，“DefName”，DefCompany是指公司名称，
DefName是指用户名。

注册你的WINDOWS98。
HKEY_LOCAL_MACHINE\SOFTWARE\Miscrosoft\Windows
\CurrentVersion\在右边的窗口中将“Regdone”的值改为“1”

自动运行光碟
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个二进制值：“NoDriveTypeAutoRun”，并将其值设为“95 00 00 00”想禁止自动运行,只需改为"b5 00 00 00"。

自动播放光碟
在HKEY_CLASSES_ROOT\AudioCD\shell下在右边的窗口中修改字符串值：“默认”，改其值为空格.

直接显示图片内容
HKEY_CLASSES_ROOT\Paint. Picture\DefaultIcon 在右边的窗口中，找到字符串“默认”，修改值为“%1”。

添加或删除启动时自动运行的程序
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\下，把鼠标点击“RUN”，在右边的窗口中，按相应的方法添加或删除启动时自动运行的程序。


神奇注册表

禁用控制面板的“显示”设置项中的“外观”选项卡
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System下在右边的窗口中新建一个DWORD值：“NoDispAppearancePage”，并设其值为“1”。

禁用控制面板的“显示”设置项
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System下在右边的窗口中新建一个DWORD值：“NoDispCPL”，并设其值为“1”。

禁止在“显示属性”中出现“屏幕保护程序”这个分菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDispScrSavPage”，并设其值为“1”。

禁止在“显示属性”中出现“效果，web，设置”这三个分菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDispSettingsPage”，并设其值为“1”。

禁止修改“开始”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explore 在右边的窗口中新建一个DWORD值：“NoChangeStartMenu”，并设其值为“1”。

禁止在“系统属性”中出现“文件系统”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoFileSysPage”，并设其值为“1”。

禁止在“系统属性”中出现“虚拟内存”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoVirtMemPage”，并设其值为“1”。

禁止在“系统属性”中出现“设备管理器”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDevMgrPage”，并设其值为“1”。

禁止在“系统属性”中出现“硬件配置文件”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoConfigPage”，并设其值为“1”。

禁止添加打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoAddPrinter”，并设其值为“1”。

禁止删除打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoDeletePrinter”，并设其值为“1”。

改变“控制面板”中的“添加/删除程序”的“安全/卸载”中的列表内容
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Uninstall下有许多主键，要删除
“安全/卸载”列表中的某条内容，只要删除相对应的主键即可。

禁止在"控制面板"中显示"网络"属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下在右边的窗口中新建DWORD值“NoNetSetup",并设其值为“1”。

禁止在“网络”中显示“标识”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下在右边的窗口中新建DWORD值“NoNetSetupIDPage”,并设其值为“1”。

禁止在“网络”中显示“整个网络”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下在右边的窗口中新建DWORD值“NoEntireNetwork”,并设其值为“1”。


神奇注册表

为右键菜单增加“在新窗口中打开”的命令
我们往往在“文件夹选项”中选择了在同一窗口中打开文件夹 ，但我们在浏览文件夹的时候，有时想比较一下两个文件夹的不同，或想开多个窗口浏览文件夹内容，可用到下面的方法。
逐渐展开到HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell
下， 创建一个主键“NewWindow”在右边窗口中把“默认”的值改为：“在新窗口中打开” ,并在此主键“NewWindow”下创建一个主键“command”，单击“command”,在右边窗口中把“默认”的值改为“explorer.exe %1"。

为“回收站”右键菜单增加“删除”和“重命名”的命令
在HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder下 修改右边的窗口中的二近制值"Attributes",设其值为"70 01 00 20"。

修改鼠标右键弹出菜单
当我们单击C，D盘，然后点击鼠标右键，会弹出菜单(如左图)
要把Browse wth ACDSee去掉，打开HKEY_CLASSES_ROOT\Drive\shell我们可看到有主键
Browse with ACDSee，

shell.jpg (3060 字节)

把该主键删除，即可把菜单中的Browse with ACDSee去掉。

old1.jpg (5091 字节)

new.gif (1057 字节)

在gif类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\GIFFILE\SHELL中，可按上述方法
修改。 在cda类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\CDAFILE\SHELL中，可按上述方法修改。
要找某种类型的菜单中，可在HKEY_CALSSES_ROOT\???FILE\SHELL，
???代表所要找的文件类型。

为文件夹的右键菜单添加运行DOS的命令
在HKEY_CLASSES_ROOT\Directory\shell下创建一个主键“CommandPrompt”，在右边窗口中把 “默认”的值改为：“Command”（或你喜欢的字符，此字符将显示在右键菜单中）并在此主键 下创建一个主键“command”，在右边窗口中把“默认”的值改为“command.com /k cd "%1"。

输入汉字时自动添加一个空格
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion下可以看到有全拼，微软拼音，英文，智能ABC等等输入法，单击某个输入法的主键，我们可以看到在右边的窗口中有“插空格”这个DWORD值，其值为“0”时表示不添加空格，为“1”时则表示输入汉字时自动添加一个空格。

改变输入法的排列顺序
我们按Ctrl+Space选择输入法时往往要切换几次才能找到我们所须的输入法,输入法的排列顺序如图
pingyin.gif (1577 字节)

要改变顺序可通过修改注册表。在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\Keyboard Layouts下有关于键盘和输入法的主键，其主键和输入法对应如下：

在HKEY_USERS\.DEFAULT\keyboard layout\preload下有1,2,3,4......等主键
1,2,3,4.....则代表输入法的排序,单击1,2,3,4....可在右边的窗口中看到相应的输入法的键值,改动键值,即可改变输入法的顺序。

增加“快速启动”的选项
在HKEY_LOCAL_MACHINE\Software\CLASSES\Directory
\shell下新建主键“快速启动系统”，在右边的窗口中修改“默认”为“快速启动系统”在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY
\SHELL\快速启动系统 下,新建主键"COMMAND"，在右边的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWSEXEC"。

增加“关闭系统”的选项
 在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY\SHELL下
新建主键"快速关闭电脑",在右边的窗口中"默认"为"快速关闭电脑"。
在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\DIRECTORY
\SHELL\快速关闭电脑 下,新建主键"COMMAND"，在右边的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWS"。


神奇注册表

给“回收站”改名、改图标
HKEY_CLASSES_ROOT\CLSID
\{645FF040-5081-101B-9F08-00AA002F954E}
在右边的窗口中找到字符串值：“默认”，把“回收站”改为其它名称。
HKEY_CLASSES_ROOT\CLSID
\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的电脑”改名、改图标
HKEY_CLASSES_ROOT\CLSID
\{20D04FE0-3AEA-1069-A2D8-08002B30309D}
在右边的窗口中找到字符串值：“默认”，把“我的电脑”改为其它名称。
HKEY_CLASSES_ROOT\CLSID
\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
在右边的窗口中修改图标的路径。

给“我的文档”改名、改图标
在右边的窗口中找到字符串值：“默认”，把“我的文档”改为其它名称。
HKEY_CLASSES_ROOT\CLSID
\{450D8FBA-AD25-11D0-98A8-0800361B1103}\DefaultIcon
在右边的窗口中修改图标的路径。

直接显示图片内容
HKEY_CLASSES_ROOT\Paint. Picture\DefaultIcon
在右边的窗口中，找到字符串“默认”，修改值为“%1”。

修改鼠标右键弹出菜单
当我们单击C，D盘，然后点击鼠标右键，会弹出菜单(如左图)
要把Browse wth ACDSee去掉，打开HKEY_CLASSES_ROOT\Drive\shell我们可看到有主键Browse with ACDSee，

把该主键删除，即可把菜单中的Browse with ACDSee去掉。

old1.jpg (5091 字节)

在gif类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\GIFFILE\SHELL中，可按上述方法修改。
在cda类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\CDAFILE\SHELL中，可按上述方法修改。
要找某种类型的菜单中，可在HKEY_CALSSES_ROOT\???FILE\SHELL，???代表所要找的文件类型。

为文件夹的右键菜单添加运行DOS的命令
在HKEY_CLASSES_ROOT\Directory\shell下创建一个主键“CommandPrompt”，在右边窗口中把“默认”的值改为：“Command”（或你喜欢的字符，此字符将显示在右键菜单中）并在此主键下创建一个主键“command”，在右边窗口中把“默认”的值改为“command.com /k cd "%1"。


神奇注册表

禁止WINDOWS平滑卷动
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“SmoothScroll”，设其值为“0”，若允许则设值为“1”。

禁止“查找”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值“NoFind”，并设值为“1”。

调整双击灵敏度的区域
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“DoubleClickHeight”和“DoubleClickWidth”的值，即可改变区域大小。

改变菜单的显示速度
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MenuShowDelay”，其值范围为0-999，0表示最快。

窗口打开、缩小、关闭时是否显示动画过程
HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MinAnimate”，数据为“0”表示不显示过程，“1”表示显示。

禁用控制面板的“显示”设置项中的“外观”选项卡
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System下 在右边的窗口中新建一个DWORD值：“NoDispAppearancePage”，并设其值为“1”。

禁用控制面板的“显示”设置项
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System下 在右边的窗口中新建一个DWORD值：“NoDispCPL”，并设其值为“1”。

禁止在“显示属性”中出现“屏幕保护程序”这个分菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDispScrSavPage”，并设其值为“1”。

禁止在“显示属性”中出现“效果，web，设置”这三个分菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDispSettingsPage”，并设其值为“1”。

禁止修改“开始”菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explore 在右边的窗口中新建一个DWORD值：“NoChangeStartMenu”，并设其值为“1”。

禁止在“系统属性”中出现“文件系统”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoFileSysPage”，并设其值为“1”。

禁止在“系统属性”中出现“虚拟内存”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoVirtMemPage”，并设其值为“1”。

禁止在“系统属性”中出现“设备管理器”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoDevMgrPage”，并设其值为“1”。

禁止在“系统属性”中出现“硬件配置文件”的菜单
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中新建一个DWORD值：“NoConfigPage”，并设其值为“1”。

禁止添加打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoAddPrinter”，并设其值为“1”。

禁止删除打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoDeletePrinter”，并设其值为“1”。

禁止名称有“快捷方式”四个字
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Explorer 在右边的窗口中新建一个二进制值“link”，并设其值为“00 00 00 00”。

禁止使用任务栏
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoSetTaskBar”，并设其值为“1”。

高彩色显示图标
HKEY_CURRENT_USER\Control Panel\Desktop
\WindowMetrics 在右边的窗口中找到字符串值：“Shell Icon BPP”，并设其值为“16”。

改变图标大小
HKEY_CURRENT_USER\Control Panel\Desktop
\WindowMetrics 在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值即改变图标大小，缺省值为“32”。

设立缺省的用户名和公司名称
HKEY_CURRENT_USER\Software\Microsoft
\MS Setup (ACME)\User Info 在右边窗口中找到字符串值：“DefCompany”，“DefName”，DefCompany是指公司名称， DefName是指用户名。

清除“开始”中的“运行”的历史记录
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Explorer\RunMRU 删除右边窗口中的“a,b,c,d.....”，即可删除历史记录。

禁止修改开始菜单
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中创建一个DOWRD值："NoChangeStartMenu",并将其值设为“1”。

禁止修改“控制面版”
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个二进制"NoSetFolders",并将其值设为"01 00 00 00"。

在退出WINDOWS时清除“文档”中的记录
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个二进制"ClearRecentDocsOnExit",并将其值设为"01 00 00 00"。

禁止更改控制面板和打印机
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DOWRD值：“NoSetFolders”，并将其值设为“1”。

禁止修改显示属性
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中创建一个DOWRD值：“NoDispCPL”，并将其值设为“1”。

隐藏我的电脑中的驱动器
隐藏所有驱动器：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“FFFFFFFF”；
隐藏E盘：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“10”；
隐藏D盘：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“8”；
隐藏C盘 ：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“4”。
隐藏A盘 ：HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“1”。

禁用MS—DOS方式
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在该分支下新建主键“WinOlaApp"，然后点击该主键，在右边的窗口中创建一个DWORD值“Disabled",
并设其值为“1”。

禁止“重新启动计算机切换到MS-DOS方式”
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个DWORD值“NoRealMode”，并设其值为“1”。

禁止PC在出错时发出声音
HKEY_CURRENT_USER\Control Panel\Sound
在右边的窗口中，把字符串“Beep”的值改为“No”。

禁止改变打印机设置
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边窗口中创建DWORD值：“NoPrinters”，并设值为“1”。

禁止出现“点击这里开始”的提示
HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个二进制值：“NoStartBanner”，设值为“01 00 00 00”。


神奇注册表

禁止CD-ROM自动运行
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
\Services\CDRom 在右边的窗口中，把DWORD值“Autorun”改为“0”。“1”表示自动运行。

在“我的电脑”中显示“计划任务”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace 在该分支下创建一个主键“{D6277990-4C6A-11CF-8D87-00AA0060F5BF}”，在右边的窗口中创建字符串 “默认”，设值为“Scheduled Tasks”。

在“我的电脑”中显示“拨号网络”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace在此分支下新建一个主键“{992CFFA0-F557-101A-88EC-00DD010CCC48}”，单击此主键， 在右边的窗口中创建一个字符串值：“默认”，并设值为"拨号网络"。

在我的电脑中显示“打印机”
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer\MyComputer\NameSpace在此分支下新建一个主键“{2227A280-3AEA-1069-A2DE-08002B30309D}”，单击此主键， 在右边的窗口中创建一个字符串值：“默认”，并设值为“打印机”。

允许按ESC取消登录
在HKEY_LOCAL_MACHINE\Network\Logon下 在右边的窗口中创建一个DOWRD值：“MustBeValidated”，并将其值设为“1”。

禁止快速启动
在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\Shutdown下在右边的窗口中修改一个字符串值：“FastReboot”，并将其值设为“0”。

隐藏快捷方式的小箭头
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\Explorer\Shell Icons 在右边的窗口中新建字符串值：“29”，数据内容空白。

更改“打印机”图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{2227A280-3AEA-1069-A2DE-08002B30309D}\DefaultIcon
下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改Internet Explorer的图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon下，在右边的窗口中修改字符串值“(默认)”为新图标的路径，如：“C:\w.ico,0”。

给“控制面板”改名、改图标
在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}下
在右边的窗口中修改字符串值“(默认)”为新的名称
改图标:在HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID
\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon下,在右边的窗口中修改字符串值“(默认)”为新图标的路径。

更改Internet Explorer的标题
在HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main下在右边的窗口中修改字符串值“Window Title”为新标题的名字。

查找NetSpy黑客程序
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\Run下, 在右边的窗口中寻找键"NetSpy",如果存在,就说明已经装有NetSpy黑客程序,把它删除.

添加或删除启动时自动运行的程序
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\下，把鼠标点击“RUN”， 在右边的窗口中，按相应的方法添加或删除启动时自动运行的程序。

注册你的WINDOWS98。
HKEY-LOCAL-MACHINE\SOFTWARE\Miscrosoft\Windows
\CurrentVersion\
在右边的窗口中将“Regdone”的值改为“1”

改变WINDOWS有关文件的安装路径
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Setup 在右边的窗口中，有“BootHost”、“BootDir”、“SourcePath”、“MediaPath”.....
改变其数据内容,就可改变相关文件的路径。

查看安装时输入的WIN98密码
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion
点击“ProductKey”，即可看到。

自动更新
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\Update 把二进制值“UpdateMode”改为
“00 00 00 00”。

开机时自动登录系统
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下在右边的窗口中创建字符串值：“AutoAdminLogon”，并将其值设为“1”；还创建字符串值“DefaultPassword”，其值为登录时的密码，创建字符串值：“DefaultUserName”，其值为登录时
所用的用户名。

开机时进行“多用户登录”选择
在HKEY_LOCAL_MACHINE\Network\Logon下
在右边的窗口中创建一个DOWRD值：“UserProfiles”，并将其值设为“1”。

WINDOWS98登录口令
HKEY_LOCAL_MACHINE\Network\Logon
在右边的窗口中创建一个DOWRD值："MustBeValidated"，并将其值设为“1”，在启动WINDOWS98后按ESC键将不能显示画面。

进入Win98前给出警告信息
在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Winlogon下 键值：″LegalNoticeCaption″=″问候″
说明：这是信息框的标题。
键值：″LegalNoticeText″=″欢迎光临″ 说明：这是信息框的文本内容。

优化硬盘驱动器
在HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\FileSystem下
在右边的窗口中创建二进制值"NameCache",NameCache是文件名缓存，32MB系统建议值为800000， 64MB系统建议值为0F00000；PathCache是路径缓存，32MB系统建议为008000，64MB系统建议为0F0000。

超频Trident Imagine 9750系列显卡
在HKEY_LOCAL_MACHINE\SOFTWARE\Trident Microsystems下
找到文件夹“D3DPerformance”，修改“D3DPerf”为5或7，修改“CkBlinerOn”为2，

改变最大图标缓冲
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\explorer 在右边的窗口中找到字符串值：“Max Cached Icons”，设其值为“7500”。

优化软盘驱动器的性能
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\Class\fdc\0000 在右边的窗口中创建一个字符串值：“ForceFIFO”，设值为“0”。

优化文件系统
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Control\FileSystem 在右边的窗口中创建一个DWORD值：“ConfigFileAllocSize”，并设为“1f4”。

加快上网速度
以下有几项方法可以改变上网速度：
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\VxD\MSTCP 在右边的窗口中把“DefaultRcvWindow”的值改为“6400”，把“DefaultTTL”改为“128”。
HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\Class\NetTrans 在右边窗口中创建字符串值“MaxMTU”,“MaxMSS”，并设“MaxMTU”为“576”，设“MaxMSS”
为“536”。

巧解IE的分级审查口令
首先备份注册表文件，然后通过运行regedit来打开注册表。定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
\CurrentVersion\Policies\Ratings，用鼠标选中右半窗口里的名称记录，按下Del键进行删除。退出注册表，然后重新启动，就可以解开分级审查的口令了。


神奇注册表

鼠标自动激活当前窗口
HKEY_USERS\.DEFAULT\Control Panel\desktop
把二进制值“UserPreferencemask”改为“AF 00 00 00”。

自动运行光碟
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中创建一个二进制值：“NoDriveTypeAutoRun”，并将其值设为“b5 00 00 00”。

更改outlook express的标题
在HKEY_USERS\.DEFAULT\Software\Microsoft\Outlook Express下在右边的窗口中修改字符串值“WindowTitle”为新的标题名字。

禁止使用网上邻居
在 HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边窗口中创建DWORD值“NoNetHood”，并设为“1”

禁止在"控制面板"中显示"网络"属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建DWORD值“NoNetSetup",并设其值为“1”。

禁止在“网络”中显示“标识”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下 在右边的窗口中新建DWORD值“NoNetSetupIDPage”,并设其值为“1”。

禁止在“网络”中显示“整个网络”属性
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Network下 在右边的窗口中新建DWORD值“NoEntireNetwork”,并设其值为“1”。

更改IE的缓冲的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders下更改“Cache”的路径即可。

改变下载的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer下
在右边的窗口中新建DWORD值“Download Directory”,并设其值为你想要的下载路径,如C:\My Documents。

改变收藏夹、Cookies、启动、历史记录的路径
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\User Shell Folders下 找到字符串值“Favorites”,并设其值为你想要的下载路径,如C:\WINDOWS\Favorite。 在此窗口中可更改桌面的路径、Cookies的路径、启动的路径、历史记录的路径。

在桌面上显示WINDOWS版本标志
HKEY_USERS\.DEFAULT\Control Panel\desktop 在右边的窗口中新建一个字符串值：“PaintDesktopVersion”，并设其值为“1”。

禁止在桌面上显示图标
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个DWORD值：“NoDestop”，并设其值为“1”。

禁止显示提示
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Explorer\Advanced “ShowInfoTip”，并设其值为“0”。

以12小时制显示时间
HKEY_USERS\.DEFAULT\Control Panel\International
在右边的窗口中找到字符串值：“sTimeFormat”，改其值为“h:mm tt”。

不允许改变启动菜单
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个DWORD值“NoChangeStartMenu”，并设值为“1”。

禁用"打印机"中的"删除打印机"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 下，在右边的窗口中新建DWORD值“NoDeletePrinter”，并设其值为“1”。

禁用"打印机"中的"添加打印机"
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 下，在右边的窗口中新建DWORD值“NoAddPrinter”，并设其值为“1”。

禁用“网络”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Network\System 下，在右边的窗口中新建DWORD值“NoNetSetup”，并设其值为“1”。

禁用“用户”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 下，在右边的窗口中新建DWORD值“NoProfilePage”，并设其值为“1”。

禁用“密码”控制面板
在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 下，在右边的窗口中新建DWORD值“NoSecCPL”，并设其值为“1”。

禁止修改开始菜单
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中创建一个DOWRD值："NoChangeStartMenu",并将其值设为“1”。

禁止修改“控制面版”
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个二进制"NoSetFolders",并将其值设为"01 00 00 00"。

禁止快速启动
在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
\Shutdown下 在右边的窗口中修改一个字符串值：“FastReboot”，并将其值设为“0”。

在退出WINDOWS时清除“文档”中的记录
在HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer下 在右边的窗口中新建一个二进制"ClearRecentDocsOnExit",并将其值设为"01 00 00 00"。

允许按ESC取消登录
在HKEY_LOCAL_MACHINE\Network\Logon下在右边的窗口中创建一个DOWRD值：“MustBeValidated”，并将其值设为“1”。

禁止使用注册表编辑文件regedit.exe
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\System 在右边的窗口中创建一个DOWRD值："DisableRegistryTools"，并将其值设为“1”。

退出不保存设置
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows
\CurrentVersion\Policies\Explorer 把二进制值“NoSaveSettings”改为“01 00 00 00”。


注册表应用实例集锦(一)

    随着对Windows 95/98了解的深入，用户越来越认识到注册表对于整个操作系统的重要性。对普通用户来说，注册表好像有点深不可测，本文将按照Windows 9X注册表六大根键的功能分类介绍注册表的具体应用，使大家初步了解注册表各分支结构的功能和常用键值。不过，在修改注册表前，一定要做好注册表的备份，这样，即使由于误改注册表而造成系统运行不正常或崩溃也可以及时恢复！具体备份和恢复注册表的方法请参见本书第39页的《有备无患话备份》。

一、 HKEY_CLASSES_ROOT根键
    此根键中主要记录着Windows 95/98中所有的文件类型，包括安装操作系统时约定注册的和由于以后安装软件而新加载的各种文件类型，并将不同的文件类型与相应的应用程序关联起来。
1. 在已定义的很多文件类型中都可以找到shell＼open＼command这个主键，其键值决定了双击此类型文件后，系统将自动调用哪个应用程序将其打开。
应用实例
◆定义.JPG格式文件的默认打开程序为ACDSee
    将HKEY_CLASSES_ROOT＼jpegfile＼shell＼open＼command的“默认”键值改为“D:＼Program Files＼ACDSee32＼Acdsee32.exe %1”，以后只要双击.JPG文件，就将自动调用ACDSee把它打开。
◆在.JPG文件的右键菜单中增加“打印”选项
    在Windows 9X中，只有少数文件的右键菜单中会出现“打印”选项，用下面的方法你可以为任意文件的右键菜单增加“打印”命令。这里我们以给.JPG文件的右键菜单中增加“打印”选项为例:在HKEY_CLASSES_ROOT＼jpegfile＼shell下新建一主键，将其命名为“print”，在该主键下再新建“command”主键，将其“默认”键值改为“D:＼Adobe＼Photoshop＼Photoshop.exe %1”。以后只要选中.JPG文件，单击鼠标右键，然后在出现的右键菜单中选择“打印”命令，就将自动调用Photoshop对该.JPG文件进行打印。
◆双击“我的电脑”图标打开资源管理器
    大家知道，在按住Shift键的同时，双击“我的电脑”图标可迅速打开Windows的资源管理器。其实，我们也可以通过修改注册表来实现这一功能。方法是:在HKEY_CLASSES_ROOT＼CLSID＼{20D04FEO-3AEA-1069-A2D8-08002B30309D}＼shell下新建一个“open” 主键，在此“open”主键下新建一个“command”主键，将command主键的键值改为“explorer /e，c:\”，关闭注册表编辑器后修改即可生效。

2．某一文件类型或系统文件夹的主键中，包含着表示该文件类型或系统文件夹的一些文本显示信息。我们可以根据自己的需要对其进行修改。
应用实例
◆更改.MOV文件属性中的类型显示信息
将HKEY_CLASSES_ROOT＼movfile主键的默认键值由原来的“视频剪辑”改为“VCD视频剪辑”。退出注册表编辑器后，用鼠标右键单击一个.mov文件，可以看到其“属性”中的文件类型已被改为“VCD视频剪辑”。
修改前 修改后
◆更改“控制面板”的名称及文本提示信息
在HKEY_CLASSES_ROOT＼CLSID＼{21EC2020-3AEA-A2DD-08002B30309D}中有“默认”和“InfoTip”两个字符串值。其中“默认”值对应的是系统文件夹“控制面板”的名称，而“InfoTip”值则对应选中“控制面板”后，在Web查看方式下出现在文件夹窗口左边的提示信息。我们可以对二者进行任意修改，如把“控制面板”改为“系统设置”，提示信息改为:利用该文件夹中的组件可以改变系统中的一些默认设置。
◆更改“我的电脑”图标的提示信息
当鼠标指针放于“我的电脑”图标上一定时间后会出现“显示计算机中的内容”的提示信息，我们可对此段提示信息进行修改。方法为:展开HKEY_CLASSES_ROOT＼CLSID＼{20D04FEO-3AEA-1069-A2D8-08002B30309D}，更改其下的“InfoTip”的键值为所需的内容即可。
◆更改桌面上“我的文档”的名称
展开HKEY_CLASSES_ROOT＼CLSID＼{450d8fba-ad25-11d0-98a8-080036161103}，将“默认”键值项的值改成所需的名称即可。

3. 我们知道，使用鼠标的右键弹出菜单可以方便操作。一般文件类型、一般文件夹和系统文件夹（如“我的电脑”、“控制面板”）的右键弹出菜单，其内容都包含在HKEY_CLASSES_ROOT根键下，在此一一说明。展开某文件类型扩展名的主键，其shell主键下的各子键即为此类型文件的右键弹出菜单中的部分内容。HKEY_CLASSES_ROOT＼Directory＼shell主键下各子键是一般文件夹右键弹出菜单中的部分内容。HKEY_CLASSES_ROOT＼Folder＼shell主键下的内容对一般文件夹和系统文件夹的右键弹出菜单都起作用。另外，某文件类型主键下的ShellNew子键定义了将此文件类型加入到桌面右键弹出菜单的“新建”子菜单中。知道了上述关系，我们就可以修改相应的右键弹出菜单。
应用实例
◆在软驱的右键菜单中添加“清空A盘”命令
展开HKEY_CLASSES_ROOT＼Drive＼Shell主键，在其下新建“EmptyA”子键，将其“默认”键值改为“清空A盘”，在此“EmptyA”子键下新建“command”子键，将其“默认”键值改为“deltree.exe /y a:”。关闭注册表编辑器后，你就可以像清空回收站那样方便地清空A盘中的内容了。
◆在右键菜单中加入“关机”和“重新启动”选项
在HKEY_CLASSES_ROOT＼Folder＼shell主键下新建“close”和“restart”两个子键，将其“默认”键值分别改为“关闭计算机”和“重新启动计算机”。在“close”下新建“command”子键，改其“默认”键值为“Rundll.exe user.exe，exitwindows”；在“restart”下新建“command”子键，改其“默认”键值为“Rundll.exe user.exe，exitwindowsexec”。 关闭注册表编辑器，即可看见右键菜单中已多了“关闭计算机”和“重新启动计算机”两项。
◆删除和增加“新建”菜单中的内容
展开HKEY_CLASSES_ROOT＼.psd主键，将ShellNew子键删除后即可发现“新建”菜单中已无“Adobe Photoshop Image”这一项。要将已注册的文件类型（注意是已注册的）如.mov加入到“新建”菜单中去，只要找到HKEY_CLASSES_ROOT＼.mov主键，在其下新建“ShellNew”子键，在此子键下新建“NullFile”字符串，确定其键值为空（即“”）即可。
◆在右键菜单中加入“清空回收站”选项
在HKEY_CLASSES_ROOT＼*＼shellex＼ContextMenuHandlers下新建“{645FF040-5081-101B-9F08-00AA002F954E}”子键并关闭注册表编辑器后，右击桌面上任意一个图标，在弹出菜单中就会出现“清空回收站”的选项。
◆在右键菜单中加入“打开方式”命令
在文件的右键菜单中加入“打开方式”命令可以灵活地选用不同的程序来打开某一类型的文件。方法为:在HKEY_CLASSES_ROOT＼*下新建一个shell主键，在Shell主键下新建“OpenWith”子键，改其“默认”键值为“打开方式”,然后在“OpenWith”下新建“command”子键，改其“默认”键值为“C:＼WINDOWS＼rundll32.exe shell32.dll，OpenAs_RunDLL %1”。
◆控制CD的自动播放功能
展开HKEY_CLASSES_ROOT＼AudioCD＼shell主键，其“默认”键值为“play”则允许CD自动播放;为空则取消自动播放功能。
◆消除快捷方式图标上的小箭头
展开HKEY_CLASSES_ROOT＼lnkfile主键，将名为“IsShortCut”的字符串值删除即可。
◆用记事本快速打开Html文件
在HKEY_CLASSES_ROOT＼htmlfile＼shell下新建“QuickEdit”子键，改其“默认”键值为“快速编辑”。在此“QuickEdit”子键下新建“command”子键，改其“默认”键值为“notepad.exe %1”。关闭注册表编辑器，用鼠标右键单击Html文件，然后在弹出的菜单中选择“快速编辑”选项即可用记事本打开html文件。


注册表应用实例集锦(二)

二、 HKEY_CURRENT_USER根键
    此根键中记录的是当前用户的配置数据信息，用户可以利用此根键下的子键修改Windows的许多环境配置。
1．在整个系统中，许多事件都可以设定相对应的声音方案。HKEY_CURRENT_USER＼AppEvents中保存着各事件的名称及相应声音方案的配置信息，我们可对其进行修改。
应用实例
◆更改Go!Zilla下载完毕的提示声音
用过Go!Zilla的朋友们都知道，当下载完一个文件后，Go!Zilla会发出一声怪兽巨吼来作为提示。虽说为用户想得较为周到，但你是否觉得这怪兽声稍恐怖了一点，至少笔者第一次使用时被吓了一跳。其实，只要展开HKEY_CURRENT_USER＼AppEvents＼Schemes＼App＼GoZilla＼Download Success＼.current，改其“默认”键值为自己喜欢的.wav文件（包括文件路径）即可修改Go!Zilla下载完毕的提示声音。
◆在窗口最大化时加入提示声
展开HKEY_CURRENT_USER＼AppEvents＼Schemes＼App＼.Default＼Maximize＼.current，改其“默认”键值为所需的wav文件即可。
◆为网络蚂蚁的下载过程加入提示声
展开HKEY_CURRENT_USER＼AppEvents＼Schemes＼App＼Netants主键，其下有NAAddFile、NADownloadFail和NADownloadSuccess三个子键，分别表示Netants中加入下载文件、下载失败和下载成功这三个事件。只要将其下的.current子键的“默认”键值改为自己喜欢的wav文件即可。

2. HKEY_CURRENT_USER根键下的“Control Panel”子键，其下许多键值与“控制面板”中的部分内容相对应，如定制鼠标、时间、桌面、电源管理、外观等，但也有一些设置只能通过修改注册表来实现。
应用实例
◆更改鼠标的速度设置
展开HKEY_CURRENT_USER＼Control Panel＼Mouse，更改“DoubleClickSpeed”的值可改变鼠标的双击速度，最快为100毫秒，最慢为900毫秒;更改MouseSpeed的值可改变鼠标的移动速度（最快为2，最慢为0）。（注:系统安装好后，如果从来没有对“控制面板”中的“鼠标”选项进行过设置，则HKEY_CURRENT_USER＼Control Panel下不会有Mouse子键和DoubleClickSpeed、MouseSpeed键值，这个时候请自己建立。）
◆在任务栏系统区中的时间前加上文字信息
展开HKEY_CURRENT_USER＼Control Panel＼International，新建字符串值“StimeFormat”，改其值为“北京时间:hh:mm”。关闭注册表编辑器并重新启动系统，即可发现任务栏上的时间前面加上了“北京时间:”的文本信息。
◆设置“开始”菜单中子菜单弹出的延迟时间
HKEY_CURRENT_USER＼Control Panel＼desktop下字符串值“MenuShowDelay”（若没有可新建一个）的值用于设置“开始”菜单中子菜单弹出的延迟时间，取值范围为1~10。值设得小一点可加快子菜单的响应速度。
◆更改图标间距
在HKEY_CURRENT_USER＼Control Panel＼desktop＼WindowsMetrics下有“IconSpacing”和“IconVerticalSpacing”两个字符串值，用于设定图标间的水平和垂直间距，其绝对值越大间距越大。
◆改变桌面上图标的大小
桌面上图标大小的默认值为32×32，展开HKEY_CURRENT_USER＼Control Panel＼desktop＼WindowMetrics，修改其下字符串“Shell Icon Size”的值可以更改桌面上图标的大小。（注:Shell Icon Size串值的三个英文单词之间有空格隔开。）
◆更改窗口标题栏的高度与宽度
展开HKEY_CURRENT_USER＼Control Panel＼desktop＼WindowMetrics，其下“CaptionHight”和“CaptionWidth”的值分别决定窗口标题栏的高度与宽度。
◆设置电源方案
HKEY_CURRENT_USER＼Control Panel＼PoweCfg主键下的“PowerPolicies”子键表示系统可以采用的所有电源方案，如“家庭/办公室桌面”方案、“便携型/膝上型”方案、“始终打开”方案。HKEY_CURRENT_USER＼Control Panel＼PoweCfg下的字符串“CurrentPowerPolicy”表示当前正在使用的电源方案，其值与“PowerPolicies”子键的电源方案值相对应。

3.我们知道，当系统中某个应用程序出错或无响应被关闭时都会有一定的等待时间，通过修改注册表可以缩短等待时间，提高系统的响应能力。
应用实例
◆更改用Ctrl+Alt+Del关闭无响应程序的等待时间
在HKEY_CURRENT_USER＼Control Panel＼desktop下新建“WaitToKillAppTimeout”字符串值，其值表示等待时间，单位为毫秒，数值越小反应越快，我们可以根据需要作相应的修改。
◆更改应用程序出错时的等待响应时间
为了在某个应用程序出错时减少等待响应时间，可以在HKEY_CURRENT_USER＼Control Panel＼desktop下新建“HungAppTimeout”字符串值，其值决定等待响应时间，单位为毫秒，数值越小反应越快。

4. HKEY_CURRENT_USER＼Software主键下包含着系统中所安装软件的部分信息（还有更多的信息可在HKEY_LOCAL_MACHINE＼Software中找到），特别要提到的是其下Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer子键下包含着许多关于定制Windows的信息，用户可以通过新增或修改其中的键值来屏蔽系统的常用功能、图标和系统文件夹，以利于机器在多用户下的安全使用。
编者注:关于这一部分的应用实例可以参考第4页的《Windows 98安全技巧大全》一文。

5. HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer主键下定义了许多已集成在Windows 98中的IE浏览器的设置。
应用实例
◆设置IE的缺省下载目录
HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer下的字符串值“DownLoad Directory”的值决定用IE下载文件后文件的保存路径，用户可以根据需要进行修改，如可以改为“E:＼mydownload”，这样用IE下载的文件就将自动保存到E:＼mydownload文件夹中。
◆在IE中显示URL地址全名
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer，将“Show_FullURL”的值改为yes即可。
◆取消URL地址下的下划线
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main，将其下“Ancher Underline”的值改为no即可。
◆退出IE时保存历史网址内容
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Main，将“Save_Session_History_On_Exit”的值改为yes即可。
◆设定“超级链接”处点击前后的颜色
HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Explorer＼Settings下的“Anchor Color”和“Anchor Color Visited”的值分别表示点击前后的颜色，用RGB值表示。

6. 某些对话框 (如“运行”对话框和“查找”对话框)的下拉列表中会记录下用户曾经执行过的项目，浏览器的网址输入下拉列表中也会记录下用户曾经访问过的网址，我们有时出于清理或保密的原因，须要删除下拉列表中的项目。
应用实例
◆清除IE网址输入下拉列表中的网址
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Inertnet Explorer＼TypedURLs，删除其下对应的网址即可。
◆清除Netscape Navigator网址输入下拉列表中的网址
展开HKEY_CURRENT_USER＼Software＼Netscape＼Netscape Navigator＼URLHistory，删除其下对应的网址即可。
编者注:对于“查找”对话框下拉列表中的项目、“运行” 对话框下拉列表中的项目的删除，可以参考第4页的《Windows 98安全技巧大全》一文。

7. Windows 95/98 中有时会有一些没有多大用处的动画效果，我们可以通过修改注册表将其去掉，以提高系统性能。
应用实例
◆取消“开始”按钮的动画提示信息
要取消“开始”按钮旁那一行“单击这里开始”的动画提示信息，我们只须将HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer下的二进制值“NoStartBanner”（若没有则新建一个）的值改为01 00 00 00即可。
◆取消窗口缩放时的动画效果
Windows 95/98 中窗口打开、最大化和最小化的过程都是以动画效果显示，要取消此动画效果，只要在HKEY_CURRENT_USER＼Control Panel＼desktop＼WindowsMetrics下新建“MinAnimate”字符串值，设其值为1即可。

8. Windows95/98中对输入法的设置。
应用实例
◆调整输入法的载入顺序
进入Windows 9X后，系统默认的输入法为“En英语”，要切换到其他的输入法须用Ctrl+Shift键。其实，我们可以通过修改注册表来调整各输入法之间的载入顺序。展开HKEY_CURRENT_USER＼Keyboard layout＼preload主键下的1、2、3、4等子键，其中1、2、3、4……表示各输入法的载入顺序。每一个子键的“默认”键值对应一种输入法，修改其“默认”键值即可调整各输入法的载入顺序。
注:“En英语”对应的字符串值为“00000409”;“微软拼音输入法”为“E00E0804”、“全拼输入法”为“E0010804”、“郑码输入法”为“E0030804”、“智能ABC输入法”为“E0040804”、王码五笔为“E0200804”。
◆输入汉字时在汉字后加入空格
有时我们输入汉字时须要在汉字后面加入空格，只要在HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion下的相应输入法中，将“插空格”的键值改为1后，我们在输入汉字时系统就会自动在汉字后面插入一个空格。
◆更改输入法所选用的字符集
HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion下的相应输入法子键中的“GB/GBK”值表示输入法所选用的字符集，0表示选用GBK字符集，1表示选用GB2312字符集。
◆用Outlook Express收信时跳过无法收取的帐号
打开Outlook Express后，Outlook Express会自动对用户所设定的每个帐号进行邮件收发。如果其中一个帐号由于某些原因而无法收取邮件，就会搁置其后帐号的收发，所以我们有必要将无法顺利收取邮件的帐号跳过，方法为:展开HKEY_CURRENT_USER＼Software＼Microsoft＼Internet Account Manager主键，再展开其下那个须跳过的帐号所对应的子键，将其下“POP3 Skip Account”的值（DWORD值）由0改为1。
◆更改Outlook Express的邮件存放目录
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Outlook Express，将其下“Store Root”的值改为所需的文件路径即可。`
◆在“红心大战”中作弊
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Applets＼Hearts，新建“zb”字符串值，设其值为42。此后，在“红心大战”游戏中你只须按下Ctrl+Alt+Shift+F12即可查看其他三家的牌，是不是很耍赖？
◆设定“星际争霸”地图编辑器中的撤消次数
展开HKEY_CURRENT_USER＼Software＼Blizzard Entertainment＼Starcrft＼StarEdit＼Settings，其下“UndoLevels”（DWORD值）的值即为地图编辑器中的撤消（Undo）次数，默认为32（十进制）次，我们可以根据需要修改其值。
◆取消光盘的自动运行功能
当光盘插入光驱后，如果光盘的根目录中有Autorun.inf文件，Windows会自动执行此文件。如果我们想取消光盘的自动运行功能，可以采用下面两种方法:1. 插入光盘时按住Shift键不放;2. 展开HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer，将其下“NoDriveTypeAutoRun”的值由95 00 00 00改为b5 00 00 00。
◆检查Foxmail是否为系统默认的邮件软件
展开HKEY_CURRENT_USER＼Software＼Aerofox＼Foxmail＼General，将“CheckMailer”的键值改为1即可检查Foxmail是否为系统默认的邮件软件。
◆更改Photoshop安装时的登记信息
在HKEY_CURRENT_USER＼Software＼Adobe＼Registration＼User下保存着用户安装时的登记信息，如用户名、公司名等;在HKEY_CURRENT_USER＼Software＼Adobe＼Photoshop＼5.0＼Registration下保存着Photoshop的序列号、版本号等信息，大家可以作适当的修改。
◆启用Word 97中的宏病毒保护功能
展开HKEY_CURRENT_USER＼Software＼Microsoft＼Office＼8.0＼Word＼Options，将“EnableMacroVirusProtection”的值改为1即可。


注册表应用实例集锦(三)

三、 HKEYLOCAL_MACHINE根键
    此根键中保存着计算机的所有硬件设置，如IRQ、网卡、视频设备等，它还保存了所有用户都常用到的软件配置信息，如协议、计算机标识等。
1. 几乎系统中的所有硬件信息都包含在此根键下。大家可以在其“Config”、“Enum”、“Hardware”、“System”等子键下查看到。
应用实例
◆提高软驱读写缓冲性能
在HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Services＼Class＼fdc＼0000下新建DWORD值“ForeFifo”，设其值为1即可。
◆设置用软盘快速启动系统的功能
展开HKEY_LOCAL_MACHINE＼Config＼0001＼Enum＼Bios＼*PNP0700＼0B，设定其下“FloppyFastBoost”的值为01 00 00 00即可用软盘快速启动系统。
◆查看系统分配给光驱的可用盘符
HKEY_LOCAL_MACHINE＼Enum＼SCSI主键下记录着机器上所安装的光驱信息，逐层展开后，找到字符串值“UserDriveLetterAssignment”，其值即表示系统分配给光驱的可用盘符，如为“HZ”，表示盘符A到G已被软驱和硬盘所占据，盘符H到Z可分配给光驱（包括虚拟光驱）。
注:如果从没有在“系统属性”中设置过光驱盘符，UserDriveLetterAssignment串值可能不会出现。
◆提高光驱的缓存大小和预读性能
展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼Filesystem＼CDFS，其下DWORD值“CacheSize”和“Prefetch”的值分别定义光驱的缓存大小和预读性能。“CacheSize”的值最高可为“0x000009ac”;“Prefetch”的建议值:8速为“0x000001c0”、16速为“0x00000380”、24速为“0x00000540”、32速以上为“0x00000700”。
◆删除虚拟光驱后原光驱无法使用
笔者曾在删除虚拟光驱Virtual CD-ROM后，发现原光驱无法使用，并给出“设备尚未准备好”的提示，后将HKEY_LOCAL_MACHINE＼Enum＼SCSI主键下的所有子键删除，从而删除了物理光驱和虚拟光驱的信息。重新启动，系统找到物理光驱，并重新在上述子键下加入了物理光驱的信息，问题解决。
◆安装虚拟光驱后光盘游戏无法运行
安装了虚拟光驱后，物理光驱的盘符会向后移，导致原先已安装的光盘版游戏无法运行，并会给出诸如“确定光盘已在光驱中”、“请插入光盘”等提示。解决方法如下:
方法1．卸载后重装游戏。
方法2．在HKEY_LOCAL_MACHINE＼Software主键下找到此游戏子键，逐层展开后，一般可找到表示安装光驱盘符的键值项，将其值改为现在物理光驱的盘符即可。
◆更改“设备管理”中的硬件设备图标
在HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Services＼Class主键下代表各硬件设备的子键中找到字符串值“Icon”，修改其值即可。
◆在Windows中使用多重配置
HKEY_LOCAL_MACHINE＼Config下的“0001”、“0002”……等子键表示系统中所设置的多重配置。另外，在HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼IDConfigDB中保存着各种配置文件标识号(即“0001”、“0002”等)和配置文件名。

2. 右击“我的电脑”图标，选“属性”，在弹出的“系统属性”对话框中的“常规”卡中有着注册用户及系统的一些信息。用户信息是由用户在安装操作系统时填写的，系统信息是由系统自身检测到的，通过修改注册表可以更改这些信息。
应用实例
◆更改注册组织名
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion，将其下“RegisteredOrganization”的值改为所需的名称，如“新潮电子杂志社”即可。
◆更改注册用户名
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion，将其下“RegisteredOwner”的值改为所需的用户名即可。
◆自己注册Windows 98
微软官方站点上的某些内容是只向注册用户提供的，我们只须展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion，将其下“RegDone”的值改为1即可完成自己注册。
◆如何查找系统的安装注册码
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion，其下“ProductKey”的值即是系统安装时必不可少的注册码。
◆更改芯片的认证标识
展开HKEY_LOCAL_MACHINE＼Hardware＼Description＼System＼CentralProcessor＼0，改动其下“VendorIdentifier”的值，如由“CyrixInstead”改为“Intel CPU”后，再看看“系统属性”对话框，哈哈，可不要给自己骗喽！

3. 每个用户都希望保证自己机器里内容的安全，我们可以在HKEY_LOCAL_MACHINE主键下的一些子键中进行设置。
应用实例
◆不让匿名用户随意进入系统
我们知道Windows中登录密码有些形同虚设，匿名用户只要按Esc键即可进入系统。为防止匿名用户随意登录，展开HKEY_LOCAL_MACHINE＼Network＼Logon，新建DWORD值“MustBeValidated”，设其值为1即可。
◆在登录窗口中加入警告信息
对于匿名用户的非法登录，我们可以在登录窗口中加入警告信息。展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Winlogon，新建“LegalNoticeCaption”字符串值，改其值为警告窗口的标题。再新建“LegalNoticeText”字符串值，改其值为警告窗口的正文内容，如“开机者未经授权，不得进入本机系统，请退出”。
◆查找BO黑客程序
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼RunServices，若发现“.EXE”键值项，说明系统已被安装上了BO服务器，应将其删除。
◆查找NetSpy黑客程序
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run， 若发现“NetSpy”键值项，说明系统已被安装上了NetSpy，应将其删除。
◆查找BackDoor黑客程序
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run， 若发现“Notepad”键值项，说明系统已被安装上了BackDoor，将其删除。

4. Windows95/98中的一些网络参数的默认值设得不十分合理，通过注册表可以对其进行优化，从而提高网上的数据传输效率。
应用实例
◆更改MaxMTU的值
在HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Services＼Class＼NetTrans下，展开表示TCP/IP协议的那个子键（可从子键下“DriveDesc”的值来判断，如0000），在其下新建“MaxMTU”字符串值，设其值为576。
注:MaxMTU，即最大的TCP/IP传输单元。网络中，应用程序把数据分割为较小的组进行传输，标准的分组大小应为576字节。如果MaxMTU 的值大于576，系统传输时就须要重新分组，这样就降低了传输效率。Windows 9X的缺省值为1500，这是以太网的标准分组值。
◆更改DefaultRcvWindow的值
展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Services＼VxD＼MSTCP，改“DefaultRcvWindow”键值为6144。
注:DefaultRcvWindow的中文意思为缺省的传输单元接收缓冲区的大小。DefaultRcvWindow的值太大，一个分组出错后将导致整个缓冲区中的分组数据丢失并重发，值太小，将导致分组阻塞，降低速度，因此，该缓冲区的取值大小最好是512字节的4~12倍，33.6KB的MODEM最好为6144字节。
◆更改DefaultTTL的值
展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Services＼VxD＼MSTCP，改“DefaultTTL”键值为255。
注:DefaultTTL的中文意思是TCP/IP的分组寿命，这主要是防止TCP/IP分组在Internet中被无限复制。Windows 9X的缺省值为32，加大该值，可以使TCP/IP分组通过Internet传输到更远的目的地。

5．HKEY_LOCAL_MACHINE＼Software下包含了许多系统中的文件类型和软件设置信息，其实HKEY_CLASSES_ROOT根键、HKEY_CURRENT_USER根键、HKEY_CURRENT_CONFIG根键中的许多内容都是其下的映射，这里再作一些补充。
应用实例
◆取消应用程序的自启动
有些应用程序安装后会在“开始”菜单的“启动”组中加入内容，以实现每次开机时的自启动。对于加入到“启动”组中的应用程序，要取消其自启动，只要将C:＼WINDOWS＼Start Menu＼Programs＼启动中的对应项目删除即可。对于未在“启动”组中加入内容的自启动程序（如“超级解霸”的光盘插入探针）须要通过修改注册表来取消其自启动，方法为:将HKEY_LOCAL_ MACHINE＼Software＼Microsoft＼Windows＼CurrentV ersion＼Run下的对应键值项删除即可。
◆更改标准时间的名称
展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼TimeZoneInfor mation，修改“StandardName”的值即可，如将“中国标准时间”改为“北京标准时间”。
◆通过查看注册表为系统减肥
当我们安装应用程序时，经常会在c:＼Windows＼System目录下加入一些.dll(动态链接)文件，而删除应用程序时，有些在安装时加入的.dll文件并没有被一起删除（或是我们为了安全起见而选择保留.dll文件），时间一长，在c:＼Windows＼System目录下便会留下许多无用的.dll文件，我们可以通过查看注册表来判断哪些.dll文件是无用的，从而将其删除。方法是:展开HKEY_LOCAL_MACHINE＼Software＼Micro soft＼Windows＼CurrentVersion＼Shareddlls，其下保存着系统中每个.dll文件被多少个应用程序共同使用的信息，我们只须将键值为0的.dll文件删除即可。
◆查看系统中的16位和32位.dll文件
Windows 95/98中的动态链接文件有16位和32位之分，展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼SessionManager，其下子键“Known16DLLs”和“KnownDLLs”分别包含了系统中的16位和32位.dll文件，用户可以对应查找。
◆删除桌面上的“我的文档”图标
桌面上的“我的文档”图标是无法按Del键来删除的，但只要展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer＼Desktop＼Namespace ，删除子键{450d8fba-ad25-11d0-98a8-080036161103}就可将其删除。
注:Windows 98可以是用鼠标右键单击“我的文档”，然后选择弹出菜单中的“从桌面上删除”命令删除。
◆使Windows具有自动刷新功能
我们通常用F5键对屏幕、窗口进行刷新，如果你觉得麻烦，可以通过修改注册表来添加自动刷新功能。方法为:展开HKEY_LOCAL_MACHINE＼System＼Current ControlSet＼Control＼Update,将二进制值“Update Mode”（如没有则新建一个）的值改为00 00 00 00即可（注:其实选择右键菜单中的“排列图标/自动排列”也可以实现自动刷新功能）。
◆删除“添加/删除程序”中的多余项
有时我们会发现一些程序明明被删除了，但却仍保留在“添加/删除程序”的软件列表中，要删除这些多余项，只须展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Uninstall，将其下的相应子键删除即可。
◆解决一些英文软件出现乱码的问题
展开HKEY_LOCAL_MACHINE＼System＼CurrentControlSet＼Control＼fontassoc＼Associated CharSet，将“GB2312(86)”的值由yes改为no。
◆取消IE中的“分级审查”设置
展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Ratings，将其下的键值项删除即可。
◆增强IE中的网址自动探测功能
大家知道在IE的地址栏中输入microsoft后，IE会自动将地址补全为www.microsoft.com， 要使IE对.org、.net、.edu等后缀有自动探测功能，只须在HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Internet Explorer＼Main＼UrlTemplate中新建三个名为“2”、“3”、“4”的字符串值，并分别更改键值为“www.%s.org”、“ www.%s.net”、“ www.%s.edu”即可。
◆更改Windows安装源文件的默认位置
我们时常会遇到系统要求插入Windows安装光盘的情况，所以有些硬盘够大的朋友们为了方便干脆将安装光盘中的内容全部复制到硬盘上。通过修改注册表可以指定Windows安装源文件的默认位置。方法为:展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Setup，将其下“SourcePath”的值由原先的光驱盘符改为复制到硬盘上的Windows安装源文件的目录路径即可。
◆设置Winamp的视频插件
Geissplugin是一个被评为五星级的Winamp视频插件。但若你的机子配置较低，运行起来就会有停滞现象。展开HKEY_LOCAL_MACHINE＼Software＼Extensis＼geissplugin，将其下用于设定色深位数的“Z_BitDepth”的值改为8，将用于设定播放窗口占全屏百分比的“Screen_Vsize_Percent”的值适当改小，即可使此插件在低配置的机子上流畅运行。


注册表应用实例集锦(四)

四、HKEY_USERS根键

此根键中记录着系统中当前用户和默认用户的信息，前面所述的HKEY_CURRENT_USER根键即为其下.DEFAULT子键的完全映射。在此仅补充一些应用实例。
应用实例
◆禁用Windows98中的活动桌面
展开HKEY_ USER＼.DEFAULT＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer，在其下新建“NoActiveDesktop”的二进制值，改其值为01 00 00 00。
◆消除屏幕右下角Windows 98的版本号
展开HKEY_ USER＼.DEFAULT＼Control Panel＼desktop，将其下“PaintDesktopVersion”的值改为0或删除即可。
◆使文件显示扩展名
Windows 95/98文件的默认显示方式为只显示文件名，而不显示扩展名。我们可以通过将HKEY_ USER＼.DEFAULT＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer＼Advanced下的DWORD值“HideFileExt”的值由1改为0后即可显示文件的扩展名。
◆设置Word中的文件保存路径
保存新建的Word文件时，其默认的保存路径为“我的文档”，其实，该默认路径是可以自己设置的:展开HKEY_ USER＼.DEFAULT＼Software＼Microsoft＼Office＼8.0＼Word＼Options，将其下的字符串值“DOC-PATH”（若没有则新建一个）改为所需的路径即可。
◆在“横扫千军之王国风云”中启用作弊模式
将HKEY_USER＼.DEFAULT＼Software＼Cavedog Entertainment＼Kingdoms＼Skirmish GameOptions 下的“AllowCheating”的值由0改为1即可启用“横扫千军之王国风云”中的作弊模式。


注册表应用实例集锦(五)

五、HKEY_CURRENT_CONFIG根键
此根键下的内容是HKEY_LOCAL_MACHINE＼Config键的映射。
应用实例
◆设置显示色彩位数
HKEY_CURRENT_CONFIG＼Display＼Settings下的“BitPerPixel”的值即为所使用的显示色彩位数。
◆设置IE的自动拨号功能
展开HKEY_CURRENT_CONFIG＼Software＼Microsoft＼Windows＼CurrentVersion＼Internet Settings，将二进制值“EnableAutoDial”的值改为01 00 00 00即可。
◆允许IE使用代理服务器
展开HKEY_CURRENT_CONFIG＼Software＼Microsoft＼Windows＼CurrentVersion＼Internet Settings，将DWORD值“ProxyEnable”的值改为01 00 00 00即可。

六、 HKEY_DYN_DATA根键
此根键下记录的是系统硬件动态信息，这些信息均驻留于RAM中，以便系统快速访问。其中Config Manager子键处理硬件配置，PerfStats子键维护网络组件的统计数据。用户一般不要对这部分进行修改。


注册表修改指南（一）
2000-06-27· 生哥·yesky

1 提高子菜单速度
位 置：HKEY_CURRENT_USER\Control Panel\Desktop
键值名：Menushowdelay
    双击键值Menushowdelay后，弹出该键值的编辑窗口，在文本输入框内输入“0”后，再单击“确定”按钮即可。注意在系统默认的菜单弹出效果下，不易感觉到菜单弹出速度的提高；这时，请在桌面上单击“属性”命令，弹出“显示 属性”窗口，然后在“效果”标签下将“动画显示菜单和工具提示”下的“淡入淡出效果”改为“滚动效果”。

2 去掉“关闭系统”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoClose
取 值：1为隐藏、0为显示

3 自动刷新窗口内容
位 置：HKEY_LOCAL_MACHINE\System\Currentcontrolset\Control\Update
键值名：UpdateMode
取 值：0、1
若“UpdateMode”键值为0，则设置为自动刷新，
若“UpdateMode”键值为1，则设置为手工刷新；
这等于在资源管理器窗口内按“F5”键或者在“查看”菜单中选择“刷新”命令。

4 去掉“设置”
一 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetFolders
取 值：1为隐藏、0为显示
二 位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoSetTaskbar
取 值：1为隐藏、0为显示

5 去掉升级
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoCommonGroups
取 值：1为隐藏、0为显示

6 去掉“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsMenu
取 值：1为隐藏、0为显示

7 自动清除“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：ClearRecentDocsOnExit
取 值：1为自动清除、0为不自动清除

8 去掉“查找”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoFind
取 值：1为隐藏、0为显示

9 锁定“文档”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRecentDocsHistory
取 值：1为锁定、0为不锁定

10 去掉“运行”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoRun
取 值：1为隐藏、0为显示


注册表修改指南（二）
2000-06-27· 生哥·yesky

11 搜索“自启动”程序
位 置：HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run
在注册表内，我们可以查询系统启动后加载了哪些程序。单击注册表内的目录树，这里最重要的是“装载源”，从“软件环境”、“启动程序”显示的结果看，绝大多数“自启动”程序都是通过注册表加载的，即“装载源”显示为“Registry （Machine Run）”的程序。

12 去掉“注销”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoLogOff
取 值：1为隐藏、0为显示

13 缩短“新建”选项
当你用鼠标右键点击资源管理器空白处，并选取新建菜单时，会弹出建立多种程序文件的菜单，但是里面有一些你可能并不常用，比如现在我要去除掉菜单中的“Wave Sound”项目，来缩短菜单。 打开注册表，请选择查看下的搜索项，然后输入“shellnew”，并选择“全字匹配”选项；在HKEY_LOCAL_MACHINE与HKEY_LOCAL_ROOT下进行查找，找到后将该其下面的shellnew子键删除掉即可。

14 清除配色方案
位 置：HKEY_CURRENT_USER\Control Panel\Appearance\Schemes
首先请找到该子键，在窗口的右边会出现系统自带的各种配色方案，将你认为无用的配色方案删除掉，一般只保留“Windows默认”一项。 然后再打开“控制面板”窗口中的“显示”，然后在“显示 属性”窗口中单击“外观”标签，在“窗口配色方案”下拉列表中进行查看。

15 修改桌面图标
例如，我们修改Windows桌面上“回收站”的名字及图标，可执行如下操作步骤。
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
    先打开注册表编辑器；然后根据上面提供的位置找到该主键，双击窗口右边的“回收站”，弹出字符串编辑器， 然后在文本输入框内，将“回收站”改为“垃圾筒”， 重新启动机器后，桌面上的回收站就变成了垃圾筒，但图标依旧！单击{645FF040-5081-101B-9F08-00AA002F954E}前面的“+”，则展开这个主键，在它下面还有一个子键DefaultIcon。然后单击此子键，在右窗格中的“数据”栏下将出现三个图标文件名，分别为“<未命名>”、“Full”（满）、“Empty”（空）的回收站图标，这三个图标包含在动态链接库Shell32.dll文件里面，图标资源所在的序号分别是31、31、32， 其数据格式是“C:\Windows\System\Shell32.dll,31”等（调用动态链接库中的图标资源，采用这种格式就可以啦！）。如果您想把它改成自己的图标，则只要将此数据改为自己图标或者动态链接库即可，例如使用图标文件为“C:\Windows\help.ico”，这样再重新启动机器就可以看到垃圾筒的图标被改变了。利用同样的方法可以修改桌面上其它的图标和文字。

16 删除“系统”
    当你想删除桌面上的“回收站”、“Internet Explorer”等图标时，会发现它们不能用一般的方法删除。这时还可以通过修改注册表来办到。
位 置：HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace在该分支下面有多个子键，这些子键将对应桌面上的“系统”图标，在窗口右边你就可以看到。删除不需要的图标，即对应的键值；重新启动后，会看到桌面上的一些图标不见啦！

17 隐藏桌面
位 置：HKEY_CURRENT_USER\Software\Microsoft
\Windows\CurrentVersion \Policies\Explorer
键值名：NoDesktop
取 值：0、1
    这种隐藏桌面图标的方法与简单地在“显示 属性”窗口内，使用“Active desktop”下的隐藏图标的方法不一样。这里的隐藏除了将图标隐藏外，连整个桌面都一并隐藏了起来，并且同时禁止了在桌面上点击鼠标右键功能。

18 去掉“网上邻居”
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoNetHood
取 值：1为隐藏、0为显示

19 关闭系统版本号
位 置：HKEY_CURRENT_USER\Control Panel\desktop
键值名：PaintDesktopVersion
取 值：0为隐藏、1为显示
说 明：它能把你的Windows的版本号在桌面的右下角显示出来，如果你使用的是测试版， 那么就可以将桌面右下角的文字去掉。

20 隐藏指定驱动器
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
键值名：NoDrives
取 值：需要说明一下，在这里使用的是2的N次方来代表一个驱动器名称，而非寻常的A、B、C、D……，下面就给出各驱动器名与2的N次方的对应关系，以方便读者：A: 1, B: 2,C: 4, D: 8, E: 16, F: 32, G: 64,H: 128, I: 256,J: 512,K: 1024, L: 2048, M: 4096, N: 8192,O: 16384, P: 32768, Q:65536,R: 131072,S: 262144,T: 524288, U: 1048576, V: 2097152, W:4194304,X: 8388608, Y: 16777216, Z: 33554432按照上面的取值规则，如果你要隐藏A、B、C三个驱动器，输入7即可，因为7=1+2+4，如果你要隐藏所有驱动器，输入67108863。


注册表修改指南（三）
2000-06-27· 生哥·yesky

21 修改“回收站”
位 置：HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
键值名：Attributes
取 值：40 01 00 20、70 01 00 20
说 明：缺省情况下是40 01 00 20，把它改为70 01 00 20后，就可以把桌面上的“回收站”象资源管理器内的文件一样，能任意地更名或者删除了。

22 修改桌面
位 置：HKEY_CURRENT_USER\ControlPanel\desktop
说 明：打开注册表编辑器，然后打开该分支。在此分支右窗格内可以看到一些项目，现介绍几个如下：HungAppTimeout：这是指一个应用程序出错时试图等待响应的时间，值为毫秒，缺省值为5000毫秒(即5秒)，可以减少为3000毫秒，以加快系统的响应能力。MenuShowDelay：这是指“开始”菜单中当鼠标指向一个具有下级 菜单的菜单项时等待出现下级菜单的延迟时间，单位也是毫秒，可以设成100，即等待0.1秒就会出现（前面已经提到过）。ScreenSaveActive：这是现在屏幕保护功能是否可用，值为0或1，0即为不用屏幕保护功能，1为可用，但必须你已经使用了屏幕保护功能。ScreenSaveTimeOut：这是指屏幕保护的延时，值类型为一个数值。单位是秒，最小值是60秒，但必须你已经使用了屏幕保护功能；如果你将数值改为1，那么每停顿1秒钟，便会启动屏幕保护。WaitToKillAppTimeout：这是指当按下 Crtl+Alt+Del后以后，出现“关闭程序”对话框，出现提示“结束任务”、“等待”时选择“等待”的等待时间，单位是毫秒，默认值是10000。可以减少等待时间。

23 定制按钮颜色
    尽管Windows在外观中可以定义多种窗口显示方案,但要定义某一个部位的颜色，如将黑色的按钮字体改变为其它的颜色， 它就无能为力啦！通过修改注册表能很容易实现。 在注册表内找到HKEY_CURRENT_USER\Control Panel\Colors的子键，然后将窗口右边的“Bottontext”键值由原来的“0 0 0”改为“255 0 0”（代表红色）。

24 汉字后加空格
位 置：HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion
键值名：插空格
取 值：0不插入空格、1插入空格

25 活用Enter键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion键值名：
取 值：0保留原功能，输入法不处理、1等同于Esc键，用于清除当前外码输入状态说 明：当取值为1时，如果有候选窗口，会自动隐藏输入窗口，清除所有外码，但不隐藏外码输入窗口。当无候选窗口，清除外码，并隐藏外码输入窗口。

26 活用Space键
位 置：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion键值名：
取 值：0指明这是作为结束外码输入的标志键，这种设置适合于形码、1指明这是作为候选选择键，这种设置适合于音码。

27 系统时间格式
位 置：HKEY_CURRENT_USER\ControlPanel\International键值名：sTimeFormat
取 值：H:mm:ss、HHmm不等
说 明：在通常情况下，Windows在任务栏中使用“23:12”的时间格式来显示时间， 但是您可以通过修改注册表编辑器来更改此时间格式。

28 更改登录背景
位 置：HKEY_USERS\.DEFAULT\Control Panel\Desktop
键值名：Wallpaper
取 值：目标背景图文件路径

29 修改注册码
位 置：HKEY_LOCALMACHINE\Software\Microsoft\Windows\CurrentVersion
键值名：ProductId
取 值：任意字符

30 禁止自动运行
    在通常情况下，绝大多数在Windows启动时自动运行的应用程序有如下两种设置办法：在“启动”程序组中添加快捷方式 如果使用的是这种方法。则我们只需将它们的快捷方式从 “启动”程序组中删除即可达到禁止它们自动运行的目的。修改Windows的注册表数据库如果您使用过一些诸如CD播放机等的用户都知道，在使用这些软件时，都将在任务栏右边 将出现一个图标，这有时会带来不便。其实，这些软件的自启动程序的注册项放在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run分支中。您只要到此分支中找出对应的自启动程序即可，另外，在“Run”主键下还可能有“SysExplr”子键。如果有该子键，可以将其中的内容清空，同样也能取消Windows启动时自启动的程序。那么反过来，我们怎样在注册表内添加自启动程序呢？先找到 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run主键，然后在它的窗口右边建立一 个名为“SysExplorer”的键值名，并将其值设为“Explorer.exe”，退出注册表编辑器，注销用户后重新启动计算机，系统将自动运行资源管理器。 另外Windows还提供了一次性的自启动功能。紧跟在“Run”主键后面有一个“RunOnce”和“RunOnceEx”子键，你可以在这两个子键内设置新的键值，让系统自动运行一次某个程序，即仅在下一次启动Windows时才有效。


注册表修改指南（四）
2000-06-27· 生哥·yesky

31 软件显示乱码
     解决的方法是在注册表内找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\fontassoc\Associated CharSet位置，将窗口右边内的“SYMBOL(02)” 键值（这是系统的机内码）改为“NO”即可。

32 删除软件的残骸
    每一个Windows操作系统的的使用者可能都有这样的经历，由于种种原因直接在硬盘中删除了某个文件夹，或者是在“添加／删除程序”里面对一些软件进行反安装。但是有些程序却还有注册信息留在注册表内，当你再次从“添加/删除程序”中卸载该程序时，老是提示“试图删除XXXXXX时出错，放弃卸载”，从而导致了卸载程序错误。当机器中安装大量的软件后随着时间的后移，就在系统的注册表中就形成了垃圾，影响了机器的运行速度。下面介绍彻底清除这些垃圾的方法。用注册表编辑器来清除注册表中关于卸载应用程序的相关键值数据HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall位置，一般的软件在注册表内的反安装子键里有“DisplayName”、“UninstallString”这两个键值，第一个显示的是软件的名称、第二个 显示的是反安装的一些信息。双击第二个键值后，便会明白反安装是怎么回事，反安装实际上是你所安装的软件自带有一个反安装程序，在安装该软件时，它会自己记录一些安装信息存放Install.log文件中，卸载时用这个反安装程序再带上.log文件的参数即可。另外，有些软件反安装时使用的是系统提供的反安装程序。再如，许多应用软件在卸载之后仍会在注册表文件内留下一些无用信息。比较集中的地方在HKEY_LOCAL_MACHINE\Software、HKEY_CURRENT_USER\Software和HKEY_USERS\.Default \Software。这几项里面的内容基本上一致，在其中一处作查找删除就行了。比较常用到的方法是进入HKEY_LOCAL_MACHINE\Software分支中，然后重点查找那些已经确信被安全卸载了的软件的残留信息，在确认无误后删除。

33 恢复CD Key
    如果你不小心将Windows的CDKey丢失了，担心在以后需要安装系统时会遇到什么麻烦。我该如何才能找回它呢？您可以从NT的注册表中找到这个CDKey。打开注册表，然后再找到“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion”位置，在右侧的ProductId键值中，就包含了CDKey的信息，另外，如果您所使用的NT是OEM版本，则有可能整个ProductId的串值就是CDKey！

34 加入登录信息
    因为加入这样的功能需要修改NT的注册表，所以请您小心并做好备份。首先在注册表中的找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon子键，然后在窗口右边找到“LegalNoticeCaption”和“LegalNoticeText”两个键值。如果没有， 请添加这两个键值。然后在这两个键值内分别输入“这是我的服务器”、“欢迎光临！”。关闭注册表，重启机器，这次您就看到在登录窗口之前，将会出现一个新的窗口，包含上面您所输入的这两条信息。

35 防范非法入侵
    介绍如何防止本地用户非法入侵 Windows NT 系统的文章已经并不少见，但如何防范远程用户呢？当然，一般的做法是，可以在用户拨号进入系统（或通过局域网进入系统）时限制其对文件的访问权限，以达到保护文件的目的。但毕竟这种安全级别不够高，如何能将这些用户锁在系统的门外，以达到绝对安全的目的呢？NT为驱动器和系统目录创建默认共享的目的，是为了使系统管理员、备份程序和其他授权用户及服务性工作能顺利访问其他个人用户的文件。当其他用户访问您的系统时这些共享对象并不显现出来。但是任何一个远程 用户只要知道这些共享对象的确切名称，并且有访问权的话，他就可以与这些共享对象建立连接。令人遗憾的是，NT系统的安全机制非常脆弱。虽然SecurityPack5的出台为老用户提高到管理员水平而提供了一些补漏措施，并且还 有一些NT的安全检查方法，但仍然还会有其他漏洞存在。所以如果您的计算机在局域网上，或者是通过Modem连接 上网的，那么可通过取消这些组件的共享来保护数据。 为了达到此目的，打开NT的注册表编辑器。在注册表编辑 器中，将当前目录定位在HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanagerserver\parameters，如果没有AutoShareWks键值名，那么请你新建立一个；然后再双击它并输入“3D0”，最后单 “确定”按钮、关闭注册表编辑器，然后重新启动计算机。

36 ICQ中有“漏洞”
    ICQ是由以色列一家叫Mirabilis的公司出品的网络软件，其作用是为Internet上的用户提供实时的信息传递服务。有了它，你就可以同千里之外的朋友交流信息，还可以在对方不在线的情况下“呼叫” 他（她）上线，难怪广大网友都亲切地叫它“网络寻呼机”。但是，你是否知道在ICQ for Windows版本中 有一个“漏洞”。ICQ在Windows注册表中有一个键值被称为“Auto Update”（自动更新）。如果该键值被设 置成“Yes”，那么每一次登录到服务器的时候，就会将你的计算机中一些重要信息发送到登录的服务器上。 这些信息包括：你正在使用的操作系统类型、版本、序列号、用户登记名称、公司名称、所使用的浏览器版本等等。这些重要信息的发送可能会被黑客或某些别有心的人所利用，给你带来不必要的麻烦。为了避免此问题的发生可采用修改注册表关掉ICQ的“自动更新”功能。首先在注册表内找到 HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs位置，并在窗口右边找到“Auto Update”键值； 将“Auto Update”键值由“Yes”修改为“No”即可。为了你系统的稳定性，在进行修改时请注意要在关闭ICQ 应用程序的情况下进行修改。修改完毕后，请重新启动计算机。

37 增加执行文件路径
    如果需要运行的程序不在指定的目录中，则DOS系统一般采用在自动批处理文件中设置路径的方法来达到自动寻找此程序的目的；在Windows中则可以更秘密地增加程序路径，而不是通过设置自动批处理的方式，这就需要通过修改注册表来实现上述目的。 比如要为“C:\ProgramFiles\pdoc\pdoc.exe”文件增加路径。先打开注册表，然后找到HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths的位置，在窗口右边新建一个名为“pdoc.exe”的主键，选择该主键，将其默认值设为“C:\ProgramFiles\pdoc\pdoc.exe”；再新建名为“Path”的主键，将其设为“C:\ProgramFiles\pdoc”。这样就可以通过在“运行”命令行中键入“pdoc.exe” 或“pdoc”来运行该程序了。另外你还可以为已经存在的程序设置新的主键，比如可以为MicrosoftWord 97添加名称为“Word.exe”的主键。假设Word 97安装在“C:\ProgramFiles\MicrosoftOffice\Office\”目录中，则其操作为：打开注册表，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\AppPaths”，新建名称为“Word.exe”主键，选择该主键，将其默认值设为“C:\ProgramFiles\MicrosoftOffice\Office\Winword.exe”即可，建立执行目录的方法与上例一样。

38 更改系统安装目录
    如果使用光盘安装Windows，当添加新的硬件时，系统配置驱动程序时会提醒需要在光驱中插入Win 98光盘，而且每次都 要这样做，的确太麻烦了。您可以将Win 98安装盘中的所有“*.CAB”文件都拷贝到硬盘的某个目录下，比如“D:\Backup\PWin98”，然后运行注册表编辑器，在“我的电脑”文件夹中依次选择“HKEY_LOCAL_MACHINE”、“Software”、“Microsoft”、“Windows”、“CurrentVersion”、“Setup”，将“SourcePath”主键的值改为“D:\Backup\PWin98\”，
重新启动计算机即可。 如果网络上有一个文件服务器，假定Win98安装盘备份在“D:\Backup\PWin98\”目录中，文件服务器的机器名为“MMX233”，D盘共 享名为“DiskD”，则将“SourcePath”主键值改为“\\MMX233\DiskD\Backup\PWin98\”，注销用户或重新启动Windows即可。

39 去掉IE内的分级审查口令
    首先找到在注册表的HKEY_LOCAL_MACHINE\Software\Microsoft\Windows \Currentversion\Policies\Ratings位置，这里保存的是IE下“Internet属性”对话框的“内容”选项页中的“分级审查”中的口令，该口令是经过加密的，在下图中你可以看到记录该口令的有两个键值，而二进制的“key”键值则是加过密的，去掉口令的方法即是将子键下的这两个键值删除，如果没有口令，这个子键无键值。下次进入IE，你就可以安全地进入分级审查，并且可以直接跳过输入“旧密码”，直接加入密码即可.

40 设置中文Windows内的系统语言
    如果你安装了一个英文游戏，并且不支持中文，例如QUAKE。就可以将中文Windows内的汉字按照英文一样来处理。比如每个汉字都被当成了两个字符来处理，删掉一个汉字也需要按两下删除键，而且每到行末，就会出现汉字丢掉一半的奇怪现象。如果遇到这样的情况，千万别着急重新安装Windwos，你还可以先试一试下面的方法。首先在注册找到HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Nls\Locale的位置，将原来的“00000804”改为默认的“00000409”（系统默认使用的语言系统）.


注册表修改指南（五）
2000-06-27· 生哥·yesky

41 更改IE标题栏中的文字
    首先在注册表中找到下面的位置HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main，然后再新建一个字符串值，将其命名为Window Title
(注意两个词中间有一个空格）.

42 如何删除多余的DLL文件
    在WIN98的System子目录下存有大量的DLL文件，这些文件可能被系统或应用程序共享。但是由于经常安装和卸载软件，就会在System目录下留下一些DLL垃圾文件。它们不但占用了硬盘空间，而且还降低系统的运行速度。删除它们的步骤如下：
    1．运行“REGEDIT”， 打开注册表编辑器。
    2．打开
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SharedDLLs分支。
    这里SharedDLLs子键记录的就是有关程序共享的DLL信息，每个DLL文件的键值说明它已被几个应用程序共享。如果是二进制键值为“00 00 00 00”，则表明不被任何程序共享。（另外“0x00000001 （1）”是十六进制表示法）
    3．System目录中删除对应的文件。

43 去掉桌面快捷方式的小箭头
    在一些程序的安装过程中，会自动在桌面上创建该程序的快捷方式，方便了我们的使用。但是那个小箭头不太好看。我们可以利用修改注册表来去掉它。首先要注意此快捷方式是什么类型的，一般说来以.LNK居多，也有一些是.PIF（指向MS－DOS程序的快捷方式）。具体步骤如下：
    1．运行注册表编辑器，打开HKEY_CLASSES_ROOT\lnkfile分支。
    2．在lnkfile子键下面找到一个名为“IsShortcut”的键值，它表示在桌面的.LNK快捷方式图标上将出现一个小箭头。右键单击“IsShortcut”，然后从弹出的菜单中选择“删除”，将该键值删除。
    3．关闭注册表编辑器，重新启动Win98，就可发现快捷方式图标上已经没有小箭头了。
    同理，对指向MS－DOS程序的快捷方式（即.PIF）图标上的小箭头，则除了是打开HKEY_CLASSES_ROOT\piffile分支外，其余同上。


巧用注册表实现信息提示

     笔者所在单位的计算中心是公用机房，以前是采用Novell公司的NetWare3.12网络操作系统，前段时间把网络操作系统改用Windows NT Server4.0，客户机采用Windows98。因是公用机房，人员流动性较大，希望能在用户进入Win98操作系统前给上机者一些提示信息。
    下面先简单介绍一下在NetWare环境下如何实现此功能：在系统登录稿(System Login Script)中加入一外部可执行命令，如：# P:\rule.exe （“#”是NetWare的外部命令执行符号，P为网络盘符），其中rule.exe文件包含您想要实现的信息提示，然后把文件拷入P盘下即可。可是在Win98环境下要么是直接进入操作系统，要么您得选择用户并输入相应的密码，不易在开机时实现一些信息的提示。后来笔者发现，只要对注册表进行修改，也能达到同样的效果。
    在“开始/运行”中输入regedit以启动注册表编辑器，再打开“我的电脑\HKEY＿LOCAL＿MACHINE\ Software\Microsoft\Windows\CurrentVersion\Winlogon”子键。在其右边框中空白处点击鼠标右键，选择“新建\字符串值”，分别新建两字符串LegalNoticeCaption和LegalNoticeText，然后编辑该字符串的值。其中LegalNoticeCaption的值表示将出现提示框的标题，即图中的“欢迎您来计算中心上机”；LegalNoticeText的值表示您想实现的信息提示，即图中的“请大家遵守学校和本机房...”。这样，当用户进入Win98系统之前，将出现如图所示的对话框，用户必须点击“确定”按钮后才能进入系统，从而通过修改一下注册表就达到了信息提示的目的。


研究Netants时的发现

我们都知道，在浏览网页时，如果你单击鼠标右键的话，会出来一个快捷菜单，一般是如下左图所示。
你们再看看右边的那幅图，是我的浏览器所出现的快捷菜单。不太一样，是吧。也就是把左图的英文
进行了一点“汉化”，并且添加了两个新的--写信给我和到我家看看。是如何实现的呢？很简单，请跟我来。

old.jpg (12567 bytes)
修改前的快捷菜单

new.jpg (12333 bytes)
修改后的快捷菜单

照例要修改注册表的一些东西，备份的话我就不想再提了。
运行注册表编辑器程序regedit.exe。找到主键HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt，我们会看到两个已经有的子键：

Name Default Value
&Download by NetAnts C:\PROGRA~1\NETANTS\NAGet.htm
Download &All by NetAnts C:\PROGRA~1\NETANTS\NAGetAll.htm

我们所要做的就是按照上面的样子建新的子键，并且赋予相应的缺省值就行了。
就以我的快捷菜单为例子吧。

Name Default Value
我要下载 C:\PROGRA~1\NETANTS\NAGet.htm
把它们全扛回家 C:\PROGRA~1\NETANTS\NAGetAll.htm
写信给我 到我家看看 C:\Program Files\NetAnts\home.htm

注：hongqt311@china.com是我的e_mail信箱，你把它换成你自己的就行了。

其中，home.htm文件的内容就是弹出一个新的窗口的javascript代码。很简单的，相信大家都掌握了这样
的技术。不过我还是把它的内容列在下面吧。

home.htm文件的内容：
-----------------------------------
<script language="JavaScript">
<!--
window.open('http://127.0.0.1','','toolbar,menubar,scrollbars,
resizable,status,location,directories,copyhistory,height=800,
width=600');

// -->
</script>
---------------------------------

其中的http://127.0.0.1就换成你自己的站点或者你很喜欢的站点就行了。不过你可不要恶意的整人，将一些黄色站点或者是黑客站点连接放到这里哦。我测试了一下，可以将一个可执行程序放到这里，不过Ie在打开这个文件时会询问用户是打开这个文件还是先把它保存起来。这样的话好象用处不是太大，除非你自己写一段javascript程序，让用户在点击时自动下载并执行相应的你指定的文件。这个应该是可行，可惜我没学会。让大家自己去想吧，如果知道怎么做，可别忘了告诉我哦。


用脚本文件简单修改注册表
2000-08-15· 张良·YESKY

    用.VBS脚本，也就是SCRIPT 脚本文件对注册表进行修改。如果您的爱机不支持VBSCRIPT，那么请您直接阅读第二部分。下面我通过一个例子自来解释脚本文件：

' Windows Script Host Sample Script

' You have a royalty-free right to use, modify, reproduce and distribute

' the Sample Application Files (and/or any modified version) in any way

' you find useful, provided that you agree that Microsoft has no warranty,

' obligations or liability for any Sample Application Files.

' ------------------------------------------------------------------------

'

' This sample demonstrates how to write/delete entries in the registry.

L_Welcome_MsgBox_Message_Text = "此脚本显示如何创建和删除注册表项。"

L_Welcome_MsgBox_Title_Text = "Windows Scripting Host 范例"

Call Welcome()

' ********************************************************************************

' *

' * Registry related methods.

' *

Dim WSHShell

Set WSHShell = WScript.CreateObject("WScript.Shell")

WSHShell.Popup "创建项 HKCU\MyRegKey 数值为 'Top level key'"

WSHShell.RegWrite "HKCU\MyRegKey\", "Top level key"

WSHShell.Popup "创建项 HKCU\MyRegKey\Entry 数值为 'Second level key'"

WSHShell.RegWrite "HKCU\MyRegKey\Entry\", "Second level key"

WSHShell.Popup "将数值项 HKCU\MyRegKey\Value 设为 REG_SZ 1"

WSHShell.RegWrite "HKCU\MyRegKey\Value", 1

WSHShell.Popup "将数值项 HKCU\MyRegKey\Entry 设为 REG_DWORD 2"

WSHShell.RegWrite "HKCU\MyRegKey\Entry", 2, "REG_DWORD"

WSHShell.Popup "将数值项 HKCU\MyRegKey\Entry\Value1 设为 REG_BINARY 3"

WSHShell.RegWrite "HKCU\MyRegKey\Entry\Value1", 3, "REG_BINARY"

WSHShell.Popup "删除 HKCU\MyRegKey\Entry\Value1 数值"

WSHShell.RegDelete "HKCU\MyRegKey\Entry\Value1"

WSHShell.Popup "删除 HKCU\MyRegKey\Entry 项"

WSHShell.RegDelete "HKCU\MyRegKey\Entry\"

WSHShell.Popup "删除 HKCU\MyRegKey 项"

WSHShell.RegDelete "HKCU\MyRegKey\"

' ********************************************************************************

' *

' * Welcome

' *

Sub Welcome()

Dim intDoIt

intDoIt = MsgBox(L_Welcome_MsgBox_Message_Text, _

vbOKCancel + vbInformation, _

L_Welcome_MsgBox_Title_Text )

If intDoIt = vbCancel Then

WScript.Quit

End If

End Sub

1.在上例中,单引号后面是注释.

2. L_Welcome_MsgBox_Message_Text = "此脚本显示如何创建和删除注册表项。"

L_Welcome_MsgBox_Title_Text = "Windows Scripting Host 范例"

这两句是提示.

3. 用 Set WSHShell = WScript.CreateObject("WScript.Shell"),定义一个对象WSHSHELL 为WScript.Shell,

4.WELCOME()是一个确认对话框.

5. WSHShell.Popup "创建项 HKCU\MyRegKey 数值为 'Top level key'" 是声明要修改的注册表项.

WSHShell.RegWrite "HKCU\MyRegKey\", "Top level key" 在HKCU下面创建MYREGKEY子键,读者也可以根据自己实际情况修改键名、指定路径。

6、REG_SZ为字符串,要用引号引起来,REG_DWORD 为0—2147483647之间整数,REG_BINARY与之范围相同。

7、需要注意的是，若结尾是“\”则创建一个主键（项），将其默认值设为逗号后面的值项，若结尾不是“\”，则在前一个“\”后面的项中建立所设立的VALUE，逗号后面为其值。

8、WSHShell.RegDelete与WSHShell.RegWrite大致相同，只是功能相反。

各位可以将上面文档复制，存为FILENAME.VBS，然后双击即可。

用INF 脚本修改注册表。同样我先举一个例子，然后做详细讲解。

[VERSION]

SIGNATURE=$CHICAGO$

[DEFAULTINSTALL]

ADDREG=MY.ADD.REG

DELREG=MY.DEL.REG

[MY.ADD.REG]

HKLM,SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\WINLOGON,AUTOADMINLOGON,0,”0”

HKCU,CONTROL PANEL\DESKTOP,SMOOTHSCROLL,1,01,00,00,00

HKCU,CONTROL PANEL\DESKTOP,SCREENSAVEUSEPASSWORD,1,00,00,00,00

[MY.DEL.REG]

HKCU,MYKEY

HKLM,SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\WINLOGON,DEFAULTUSERNAME

HKLM,SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\WINLOGON,DEFAULTUSERNAME

1.[VERSION] 是文件头。

SIGNATURE=$CHICAGO$ 是指针对WINDOWS（CHICAGO是WINDOWS95的内部名称）

要编辑注册表必须以这两句开头。

    2、[DEFAULTINSTALL]段指出INF文件包含的其他段，ADDREG 和DELREG是键，有特殊意义，他指出要添加或删除的注册表项段名

    3、WINDOWS98总是先处理DELREG段，后处理ADDREG段，这可能会对我们的应用有所帮助。

    [MY.ADD.REG]

    HKCU，MYKEY，MYVALUE，0，“STRING” 添加名为MYVALUE的字符串值项到键MYKEY下，其值设为STRING

    HKCU，MYKEY，MYVALUE，，STRING 添加名为MYVALUE的字符串值项到MYKEY，将其值设为STRING

    HKCU，MYKEY，MYVALUE，1，77，34，05，20添加名为MYVALUE的二进制值项到键MYKEY下，其值设为二进制值77，34，05，20

    HKCU,MYKEY,0,”DEFAULT VALUE” 设置键MYKEY的缺省值项为字符串DEFAULT VALUE

    HKCU,MYKEY,,”DEFAULT VALUE” 设置键MYKEY的缺省值项并将其值设为字符串DEFAULT VALUE

    HKCU,MYKEY 添加注册表键MYKEY但不设置其值

    [MY.DEL.REG]

    HKCU,MYKEY,MYVALUE 从键MYKEY 中删除值项MYVALUE

    HKCU,MYKEY 删除键MYKEY及其全部子键,即删除全部分支.

    下面是一个自动清除MRU记录的INF文件:

    CLEAN.INF

    [VERSION]

    SIGNATURE=$CHICAGO$

    [DEFAULTINSTALL]

    DELREG=DELTEGKEY

    [DELREGKEY]

    HKCU,”SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\EXPLORER\DOC FIND SPEC MRU”,

    HKCU, SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\EXPLORER\FINDCOMPUTERMRU,

    HKCU, SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\EXPLORER\RECENTDOCS,

    HKCU, SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\EXPLORER\RUNMRU

    清除MRU和WINDOWS\RENCENT 的批处理文件

    CLEAN.BAT

    @ECHO OFF

    C:\WINDOWS\RUNDLL.EXE SETUPX.DLL,INSTALLHINFSECTION DEFAULTINSTALL 132 CLEAN.INF

    ECHOY |ERASE C:\WINDOWS\RECENT

    各位可将CLEAN.BAT 加入HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\RUN中让电脑自动在启动时完成任务.


在IE 的工具栏上自定义按钮
2000-06-28· 覃世勇·yesky

    看到一些应用软件，如NetAnts等，在安装完成后，就会在IE 的工具栏上添加一个按钮，点击该按钮以后，就可以打开对应的软件，省时省力，非常方便。特别对于广大的"网虫"来说，把一些经常用到的软件"连接" 到IE的工具栏的按钮，点击后，所对应的软件就会执行，岂不是一件好事？现在，打开你的爱机，运行注册表的编辑软件：REGEDIT，打开注册表，按照如下的路径： HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\ 新建一个主键：{11111111-F40A-11D1-B792-444553540001}该主键的命名规则为：前面的八位为自定义的十六进制数位（从0~9的数字，a~e的字母，该例为：11111111），如果要定义多个按钮，前八位的定义不能相同，后面的字串必须原封不动的抄下来。然后，在新建的主键中，再新建一系列的字符串值（注意：是字符串型的），具体的名称、数据如以下：

（默认） ""

1 "CLSID" "{1FBA04EE-3024-11D2-8F1F-0000F87ABD16}"：没什么解释，必须照般，千万不能改，否则下面的工作就白费劲了。

2 "Default Visible" "Yes"：在鼠标移到自定义按钮上时，按钮上所显示的图标。（图一）

3 "HotIcon" "D:\handshak.ico"：决定在IE的工具栏中，是否显示自定义按钮。

4 "Icon" "D:\skyline.ico"：在正常状态时，按钮上的图标。（图二）

5 "Exec" "D:\program.exe"：自定义按钮被按下时，所执行的应用程序。

6 "ButtonText" "hello"：在鼠标移到自定义按钮上时，浮现的提示文字。

7 "MenuText" "&Hello"：点击"工具"菜单后，菜单中所显示的自定义菜单项（&N表示N为加速键。图三所示）

8 "MenuStatusBar" "How Are You"：当鼠标指向自定义菜单项时,在IE中的状态栏中显示的提示文字。（图四）

最后的注册表如图五。

    现在，可以关闭注册表编辑器，打开IE 浏览器，应该可以看到自定义的按钮。如果没有，可以通过以下的方法把自定义的按钮显示到工具栏上：查看->工具栏->自定义，把一些不需要的按钮去掉就可以了。


常见注册方式
2000-06-28· 生哥·yesky

    读者可能会认为这部分有些多余，也许会说：“既然我已经学会修改注册表，还有什么不能做的呢？”其实不然，学海无涯，不应该这样满足。

    这里我们只是简单地为你介绍方法，起着抛砖引玉的作用，如果要深入，还得靠自己！

    由于我们经常使用D版光盘中的共享软件（Shareware）、自由软件（Freeware）、游戏以及商业软件的试用版一般都必须注册才能使用，特别是从网络上下载的或用户自己开发的某些开发工具的控件（例如Delphi、VC++等），不少都是需要注册的，某些独立的控件（例如Delphi、PowerBuilder），需要注册才能让开发的程序独立运行，减少安装过程，节省硬盘。这时候需要进行注册，一般来说注册有手工注册和程序自动注册两种。

    无论是手工注册还是程序自动注册，你都还有一些工作要做：那就是备份注册表。一旦注册失败，还有挽救的可能性。

手工注册
    手工注册就是通过修改注册表直接注册（注册方法前面有详细的描述）。
    但是该种注册方法必须首先了解该注册的键以及子键（确切地说，就是找到需要注册的位置），否则将注册失败。

程序自动注册
    程序自动注册大约有以下几种情况：

    （1）如果是系统软件、工具软件、商用软件、游戏或平台开发工具，启动其安装程序，正常安装结束，通常能注册成功。当然不排除某些需要手工做细微的修改的可能性，否则哪有所谓的Cracker和Hacker呢？
    （2）如果是自己开发的应用程序，最好的方法是利用开发平台中的“系统安装程序”生成工具制作安装盘，因为安装程序生成工具将根据当前开发系统所使用的资源，自动将需要注册的信息写入文件中，这样当其他用户使用的时候，启动安装程序直接安装，自动注册。
    （3）编制程序实现注册。

    编制程序实现注册最大的好处就是方便，减少不必要的资源开销。注册表的操作实际上是通过系列注册表函数来进行的，因此无论使用的什么开发工具（以VC++最多），其API函数多以Reg为前缀。

    由于编程实现注册所涉及的内容太复杂，这里不再介绍。


win98注册表妙用
2000-06-28· 邹琳·cpcw

一、锁定桌面

    桌面设置包括壁纸、图标以及快捷方式，它们的设置一般都是我们经过精心选择才设定好的。大多数情况下，我们不希望他人随意修改桌面设置或随意删除快捷方式。怎么办?其实修改注册表可以帮你锁定桌面，这里“锁定”的含义是对他人的修改不做储存，不管别人怎么改，只要重新启动计算机，你的设置就会原封不动地出现在你面前。

    1.运行regedit进入注册表编辑器，找到如下分支：Hkey－Users\Software\Microsoft\Windows\CurentVersion\Polioies\Explores;
    2.双击“No Save Setting”，并将其键值从0改为1；
    3.确认后退出注册表编辑器，重新启动即可。

    上面的修改是把计算机上所有用户的桌面设置全部锁定了，如果你只想锁定你自己的桌面，而不理会别人的设置是否被修改，可以在下面的路径中执行相同的操作：Hkey－Current－User\Software\Microsoft\Windows\Current Version\Policies\Explores。

二、关闭“单击从这里开始”动画箭头

    Win98开机时，有时候屏幕底部的任务条中会出现一个从右到左的动画箭头，指示“单击从这里开始”，用下面方法可以使它禁止显示：

    1)打开注册表，进入下面路径：Hkey－Current－User\Software\Microsoft\Windows\Current Version\Policies\Explores;
    2)建立一个二进制键名：“No Start Banner”；
    3)双击该键名，并输入键值“01000000”；
    4)确认后退出，并重新启动计算机

    如果想使这个修改对所有用户生效，可到下面路径中执行相同的操作：Microsoft\Windows\Current\Current Version\Policies\Explores。

    注：如果你的电脑开机时没这个动画箭头，一定是计算机在开机时自动加载了某个应用程序。

三、防止菜单随鼠标移动
    在Win98中当你把鼠标指向下拉级联菜单的标题稍作停留，其下一级子菜单会自动弹出。有时候这个性能也会有“副作用”—在鼠标移动过程中，稍不留意，按一下左键，就可能启动一个你并不需要的窗口。可以修改注册表关闭这项功能，使单击该菜单才弹出其下一级子菜单：

    1)打开注册表，进入下面目录：Hkey－Current－User\Control Pannel\Desktop;
    2)添加一个键名：“Menu Show Delay”；
    3)输入键值“65534”；
    4)确认后重启计算机。


Win 9X注册表内的安全和用户权限设置
2000-06-28· 刘昌松·cpcw

    一、限制控制面板

    1． 打开注册表 中的主键[HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrenVersion\Policies\System]（“用户名”指建立了多用户的系统中，相应的用户的名称，如果未建立多用户则为“.Default”），其下如果有下列DWORD值，则该用户的相应的控制面板项被禁止：
    “NoDispAppearancePage”=1(禁用“显示器”属性)
    “NoDispBackgroundPage”=1（隐藏“显示器”属性中的“背景”页）
    “NoDispCPL”=1（隐藏“显示器”属性中的“屏幕保护程序”页）
    “NoDispScrSavPage”=1（隐藏“显示器”属性中的“外观”页）

    2．[ HKEY_USERS\用户名\Software\Microsoft\Windows\CurrentVersion\Policies\Network]下如有下列DWORD值，则该用户相应的控制面板项被限制：
    “NoNetSetup”=1（禁用“网络”属性）
    “NoNetSetupIDPage”=1（隐藏“网络”属性中的“标识”页）
    “NoNetSetupSecurityPage”=1（隐藏“网络”属性中的“访问控制”页）

    3．[HKEY_USERS\用户名\Software\Microsoft\Windows\CurrentVersion\Policies\System]下如有下列DWORD值，则该用户相应的控制面板项被限制：
    “NoSecCPL”=1（禁用“密码”属性）
    “NoPwdPage”=1（隐藏“密码”属性中的“更改密码”页）
    “NoAdminPage”=1（隐藏“远程管理”页）
    “NoProfilePage”=1（隐藏“系统”属性中的“用户配置文件”页）
    “NoDevMgrPage”=1（隐藏“系统”属性中的“设备管理”页）
    “NoConfigPage”=1（隐藏“系统”属性中的“硬件配置文件”页）
    “NoFileSysPage”=1（隐藏“系统”属性“性能”页中的“文件系统”按钮）
    “NoVirtMemPage”=1（隐藏“系统”属性“性能”页中的“虚拟内存”按钮）

    二、限制开始菜单

    如果在[HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]下有DWORD值“NoRun”=1时，则该用户的开始菜单中的“运行”命令被禁止；
    如果有DWORD值“NoSetFolders”=1时，则该用户的开始菜单中的“设置\文件夹选项”命令被禁止；
    如果有DWORD“NoSetTaskbar”=1时，则该用户的开始菜单中的“设置\任务栏和开始菜单”命令被禁止；
    如果有DWORD值“NoFind”=1时，则该用户的开始菜单中的“查找”命令被禁止； 如果有DWORD值“NoStartMenuSubFolders”=1，则该用户“开始”菜单中的子文件夹被隐藏；
    如果有DWORD值“NoClose”=1时，则该用户的开始菜单中的“关闭系统”命令被禁止；

    三、网络和用户设置

    1．如果在[HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]下有DWORD值“NoDrives”=1时，则该用户“我的电脑”中的所有驱动器被隐藏；
    如果有DWORD值“NoNetHooD”=1时，则该用户的“网上邻居”被隐藏；
    如果有DWORD值“NoEntioeNetwork”=1时，则该用户的“网上邻居”中 “整个网络” 被隐藏；
    如果有字符串值“NoWorkgroupContents”=1时，则该用户的“网上邻居”中工作组目录被隐藏；
    如果有DWORD值“NoDesktop”=1时，则该用户的桌面上所有的程序组被隐藏（即没有桌面）；
    如果有DWORD值“NoSaveSettings”=1时，则该用户退出系统时所作的设置不被保存。

    2．拨号网络和共享设置：在[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
\Windows\CurrentVersion\Policies\Network]下建立以下DWORD值，则相应的限制有效：
    “NoDialIn”=1（禁止拨入）
    “NoFileSharing”=1（禁用文件共享）

    3.只运行允许的Windows程序的列表：
    [HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]下如有主键“RestrictRun”，则其下的字符串值表示允许该用户只能运行的Windows程序的列表。

    四、口令设置

    在[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network]下建立以下DWORD值，则相应的设置有效：
    “HideSharePwds”=1（使用星号（＊）隐藏共享口令）
    “DisablePwdCaching”=1（禁用口令缓存；注意！请慎用此项设置，此时控制面板中的“密码”属性中无法更改密码，登录时该用户使用任何一个密码或不用密码就可以登录。）
    “AlphanumPwds”=1（使Windows口令必须为数字和字母）
    “MinPwdLen”=n（设置Windows口令的最小长度，n大于等于0小于等于8）

    五、禁用注册表编辑器

    [HKEY_USERS\“用户名”\Software\Microsoft\Windows\CurrentVersion\Policies\System\]下如果有DWORD值“DisableRegstryTools”=1，则禁止该用户使用注册表编辑工具。

    六、禁用“MSDOS”方式、禁用单一模式的MSDOS应用程序

    [HKEY_USERS\‘用户名’\Software\Microsoft\Windows\CurrentVersion\Policies\System]下如果有主键“WinOldApp”其下有DWORD值“Disabled”=1，则该用户的“MSDOS”方式被禁止；“WinOldApp”下如有DWORD值“NoRealMode”=1，则该用户单一模式的MSDOS应用程序被禁用。

    七、自启动的程序

    [HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\Run]其下的字符串值表示通过注册表自启动的程序；
    [HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunOnce]其下的字符串值表示只自启动一次的程序；
    [HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunServices]其下的字符串值表示通过注册表自启动的服务程序；
    [HKEY_LOCAL_MACHINE\SOFTWARE\Mic rosoft\Windows\CurrentVersion\RunServicesOnce]其下的字符串值表示只启动一次的服务程序。

    由此，我们可以看出上面所有的DWORD值，如果其值为“1”时表示该值有效，其值为“0”时表示该值无效；我们可以通过改变DWORD值或删除该DWORD，来轻松地使相应的限制有效或无效。


管理Win 9X注册表
2000-06-28· cpcw·cpcw

    1．注册表的备份及恢复

    注册表被破坏时就会导致系统发生问题甚至瘫痪，所以需要备份注册表以便在注册表受到破坏时恢复它。常见的注册表备份方法有三种：

    （1） 直接将注册表文件System.dat和User.dat拷贝到硬盘指定的目录下或直接拷贝到软盘上作为备份。恢复时将该备份替换覆盖回原处即可。
    （2） 运行Regedit.exe。打开注册表编辑器后，利用菜单的“导出”及“引入”功能来备份、恢复注册表信息。具体方法为：打开“注册表”下拉菜单，单击“导出注册表文件”项，在出现的对话框中键入欲备份注册表的文件名及其保存位置，再单击“保存”即可。需要恢复注册表时，用同样的方法打开注册表编辑器，打开“注册表”下拉菜单后点击“引入注册表文件”，在出现的对话框中选中需恢复的备份文件，再按“打开”按钮即可将该注册表备份文件恢复到系统中。
    （3）Win98新增的自动备份注册表功能可自动备份注册表。在用户每天第一次开机时，Win98将自动把系统中原来的注册表信息压缩成.cab文件，以rb00＊.cab之名存放在Windows\Sysbackup目录下，系统自动保存最近五次开机时的注册表数据。需要恢复时，可以用Windows自带的Extract.exe（在Windows\Command目录下）解开该压缩文件，恢复替换回原注册表文件即可。另外，还可用WinZip7.0等压缩软件解开所需的rb00＊.cab备份压缩文件，将它覆盖回原位置即可。

    2．修改注册表

    为了充分发挥系统的性能，有必要对注册表进行适当的修改（但是，如果你对注册表不太熟悉的话，请不要轻易修改它）。例如，通过修改注册表可以加快网络传输速度。具体操作如下：运行Windows目录下的Regedit.exe，出现编辑窗口时单击“编辑”菜单的“查找”命令，在查找框内键入“MaxMTU”后回车，找到该键值名后，右击它，在快捷菜单中单击“修改”，将其值设为576；用同样的方法将该窗口的“MaxMSS”值设为536；将“DefaultRcv Windows”的值设为3216；将“Default TTL”的值设为64。如果该窗口中缺少某一项，就右击窗口右边空白处，在快捷菜单中单击“新建／字符串值”，键入相应的名字，再将其值设为上面数据即可。关于注册表更详细的修改方法见《1999年电脑报合订本》（上）附录。

    3．对Win95／97注册表的管理

    目前很多系统仍使用Win95／97，但它对系统没什么保护功能。在Win98中，微软新增了一个注册表检测软件：ScanReg。当注册表出现问题时，它会提示你重新启动系统恢复注册表。目前注册表检测软件分为DOS版的ScanReg.exe和Windows版的ScanRegw.exe，只要输入ScanReg，系统就启动相应版本，对注册表进行压缩备份，并将备份存放在Windows\Sysbackup目录下，当注册表出错时，就使用备份文件覆盖掉坏注册表文件。把Win98的ScanReg拷贝到Win95／97中使用仍可以实现对系统注册表的保护。具体方法为：把Win98的Windows\Command目录下的ScanReg.exe和Windows目录下的ScanReg.ini、ScanRegw.exe拷贝到Win95／97的相应目录中。为了达到每次启动Win95／97就检测和自动保存，我们要做一个快捷方式到“启动组”中，在“开始”按钮上单击鼠标右键，选择“打开”，一层层打开到“启动组”文件夹，把刚才做好的ScanReg快捷方式放进去，这样，Win95／97就和Win98的注册表保护功能完全一样。

    4．用软件管理注册表

    现在有很多用于管理注册表的软件，例如：注册表修改软件Reg2000；注册表监视软件Regmon；注册表清理软件Regclean等。下面以微软公司开发的Regclean为例说明用软件对注册表的管理。在频繁的安装和卸载一些软件时，注册表中会留下许多垃圾信息，你可以通过运行Regclean删除这些无用的表项，并把所做的修改存放在一个Undo文件中，用户可随时恢复。经过Regclean的处理，系统性能得到很大的提升，尤其是缩短了系统的启动时间。而且只要系统一启动，Regclean就会搜索注册表，如果发现错误，只要按一下FixError就大功告成了。Regclean清理注册表后，会产生一个＊.reg文件，里面的内容是刚被清理出的注册表项，可以用各种字处理软件打开查看，但请注意：不能直接选“打开”（即：把它们加入注册表），否则这些垃圾信息就会重新登录到注册表中，刚才的FixError工作就白做了。


Windows2000注册表的备份与恢复
2000-06-28· 林斌·cpcw

     Windows 2000 将它的配置信息存储在名为注册表的数据库中，其中包含了每个计算机用户的配置文件，以及有关系统硬件、已安装的程序和属性设置等信息，Windows 2000 在运行过程中要一直引用这些信息。注册表是以二进制形式存储在硬盘上，错误地编辑注册表可能会严重损坏系统。所以，在更改注册表之前，强烈建议备份注册表信息。为了防止在修改注册表的时候发生致命错误，有必要了解一下注册表文件的备份和恢复方法。除此之外，为了研究注册表的结构，还可以将注册表中的某一主键或子键保存为文本文件，或者打印出来，这项工作同样需要了解注册表文件的导入与导出方法。

    一、完全备份／恢复注册表
    如果要完全备份注册表，可以在注册表编辑器Regedit.exe中单击“注册表”菜单下的“导出注册表文件”命令，并选择导出范围为“全部”，将注册表文件（＊.reg）保存在硬盘上即可。要完全还原注册表的方法同上，只需要单击“注册表”菜单下的“导入注册表文件”命令，然后选择硬盘上相应的备份注册表文件即可。顺便提一下，Regedit.exe（16位的注册表编辑器）包含在 Windows 2000 中的主要原因是其搜索功能比较强，用户同样可以使用 Regedit.exe 更改注册表，但其功能不够全面（如无法设置注册表项的权限），可能无法正确查看或编辑个别数据类型。因此，建议只将 Regedit.exe 用于搜索及注册表的完全备份，在需要编辑注册表时，使用system32目录下的 Regedt32.exe（它是32位注册表编辑器，提供了一些高级功能，采用多窗口格式显示各预定义项，查看起来比较方便）。

    二、部分备份注册表
    如果只需要保存一个根键或者一个主键（子键）等一般的备份，在Regedt32中就可以比较方便地完成。首先选择要保存的主键或子键，然后再单击“注册表”菜单下“保存项”命令，在弹出的“保存项”对话框中输入要保存的注册表文件的文件名，扩展名建议使用“reg”，便于今后查找。

    在保存某些主键或子键时，因为其使用的用户不同，或者是该主键或子键正在被系统使用，会出现禁止访问的警告：“权限不足，无法保存项”。这时系统管理员可以使用“安全”菜单下的“权限”命令，对这些主键或子键的用户赋予“完全控制”的权限（具体操作参见第15期《电脑报》软件世界中“Windows 2000 注册表直通车（上）”一文），然后就可以保存该项了。

    将注册表主键或子键保存为“项”文件，无法直接用文本编辑器打开查看，所以想研究注册表的结构的话，可以将注册表文件导出为文本文件，操作的方法是选择“注册表”菜单下“将子目录树另存为”命令，将其命名为扩展名为TXT的文件后，再单击“保存”按钮即可。以后我们就可以使用Windows的写字板或记事本来查看这个文本文件了。如果需要，也可以使用同一菜单下的“打印子目录树”命令来打印。

    三、部分恢复／导入注册表
    部分恢复／导入注册表有两种方法，第一种是还原“项”，即使用以前备份的注册表文件或其它注册表文件来覆盖现有的主键。首先在Regedt32注册表编辑器中，将光标移至要还原的主键上，再选择“注册表”菜单下的“还原”命令，并在“还原项”窗口中选择要还原的注册表文件，单击“打开”按钮，确认覆盖现有主键后，即可还原该项到当前选定的项上。注意：被选择还原的文件必须与注册表编辑器中所选择的主键内容吻合，即原先保存的注册表“项”只能还原到原先的位置。

    另外一种方法是加载配置单元。“加载配置单元”和“卸载配置单元”。这两个命令只有在 [image] [HKEY_USERS]或[HKEY_LOCAL_MACHINE]这两个预定义项窗口中才有效，将配置单元加载到注册表中后，配置单元成为其中一个项的子项。具体做法是在Regedt32注册表编辑器中，先用鼠标选择上述两个预定义项中的一个主键，再选择“注册表”菜单下的“加载配置单元”命令，接着在“加载配置单元”对话框内选择要加载的注册表文件，单击“打开”按钮后出现“加载配置单元”对话框，在对话框的“项名称”文本框内输入新主键的名称，如“.ChenNai”，再单击“确定”按钮，这样你就发现在当前主键的下面出现了一个新的主键（.ChenNai）。如果要卸载该配置单元，也很简单，选中该主键后，选择“注册表”菜单下“卸载配置单元”命令即可。

    上述两种方法的不同之处在于“加载配置单元”引入的主键可以是注册表内原先没有的内容。

    最后说一下，Windows 2000中注册表文件的位置，同Windows 9X一样，Windows 2000的注册表也分为两个部分，但包括多个文件，其中用户配置文件保存在根目录“Documents and Settings”下用户名的目录中，包括两个隐藏文件：NTUSER.DAT、NTUSER.INI及ntuser.dat.LOG日志文件。系统配置文件位于Windows 2000系统目录下的“SYSTEM32\CONFIG”中，包括DEFAULT、SOFTWARE、SYSTEM、AppEvent.Evt、SecEvent.Evt、SysEvent.Evt等多个隐藏文件及其相应的.LOG（日志）文件和.SAV文件。这些注册表文件在Windows 2000运行时无法使用其它工具打开，这一点与Windows 9X下的system.dat及user.dat不同。


系统启动选项修改大法
2000-08-06· 张宏·YESKY

    现在的软件是越来越多,软件商也是越来越聪明了,为了让用户多用他们的软件,经常在用户安装时,直接将软件设置为系统默认的启动程序,有的还征求一下用户的意见问是否同意这样设置,另外在以后还可以更改,但是有的就比较横了,不但不问你,连改都不让改,导致系统启动时间长,还老是占用宝贵的系统资源!为此,本人亲自尝试并总结了几种修改大法,希望与大家交流一下!

一.利用Windows自带的系统配置程序Msconfig设置
    在Windows98中有一个名为Msconfig.exe的系统配置应用程序,利用它可以实现Config.sys、Autoexec.bat、System.ini、Win.ini、"启动"等系统的设置,这里我们使用的"启动"选项,首先是单击开始,选择运行,键入msconfig(如下图),

1.jpg (15587 字节)

    发现会弹出一个窗口,这就是位于Windows/system目录下的Msconfig.exe文件了,在上面一栏会出现"常规"、"Config.sys"、"Autoexec.bat"、"System.ini"、"Win.ini"、"启动"等选项卡(如下图),

2.jpg (40306 字节)

    单击"启动"选项卡随后在下面的方框栏中会出现系统所有默认启动的程序,其中一些如internat.exe、ScanRegistry等是运行系统是必须的程序,还有就是用户安装的程序,我的Mirabilis ICQ,SoniqueQuickStart等就在里面(如下图),

3.jpg (46752 字节)

    如果你不想让某个用户程序在开机时启动,可以在该程序名左面的方框内将对号去掉(单击即可).这样就可以避免不必要的程序在进入系统时自己启动了而占用资源了!但是一定要注意一点:有一些是系统必须程序,千万不要动它们,要不然当机了可别来找我!最后单击确定,然后重启计算机,你会发现系统会按照你所选定的程序启动了!

二.利用"超级兔子"设置
    "超级兔子"系列软件作为国产软件已经是相当不错了,其中有一个名为"超级兔子魔法设置"的软件,我用的是3.0版本,首先双击"超级兔子魔法设置"图标打开,随后出现了该软件的界面(如下图),

4.jpg (74739 字节)

    选中"自动运行"一项,则弹出"自动运行"对话框,这个界面和Msconfig的界面差不多,不过多了不少功能,有"新建"、"执行"、"删除"、"更改"等选项(如下图),

5.jpg (36015 字节)

    同样在每个程序名之前都有一个方框,选中则为启动系统时同时启动该软件,若去掉对号,则不启动,设置好以后,单击保存项退出,重新启动计算机后,你会发现系统也是会按照你选定的程序启动了!该软件的网址是http://www.superr.net,需要该软件的朋友可以到此网站下载!如果还有不明白的地方,可以发mail给我:flyhong@371.net,我的网址是http://fashion.allyes.com,大家交流一下!（在MYDOWN下载）


注册表“监视员”Regmon
2000-06-28· 胡锦承·cpcw

    众所周知，注册表数据库是Windows 9X的“命根子”，硬件设备的调整、应用程序的增删、系统运行状态的修改等内容都保存在注册表数据库中，它一旦被破坏，整个系统就会瘫痪！别着急，Regmon可替我们妥善地解决这一问题。

    Regmon（Registry Monitor）是一个出色的注册表数据库监视软件，它将与注册表数据库相关的一切操作（如读取、修改、出错信息等）全部记录下来以供用户参考，并允许用户对记录的信息进行保存、过滤、查找等处理，这就为用户对系统的维护提供了极大的便利。Regmon的使用非常简单，我们只需运行该程序即可启动它的系统监视功能，自动将系统对注册表数据库的读取、修改等操作逐笔记录下来，此后我们就可以凭借它所做的记录从事有关系统维护操作了。具体来说，Regmon所做的记录非常全面，我们可利用它完成许多系统设置工作。如，Windows 98在开始菜单上新增了一个名为“收藏夹”的子菜单，它主要针对网络用户，对未上网的用户而言没有多大实用价值，因此这部分用户就希望能取消开始菜单中的“收藏夹”子菜单。为此，我们可事先启动Regmon，激活其注册表数据库的监视功能，然后启动TweakUI等软件，利用它们的设置功能取消Windows 9X的“收藏夹”子菜单。切换回Regmon之后，我们就可以从它所做的记录中，发现TweakUI是通过将注册表数据库“HKEY_CURRENT_USER\Software \Microsoft \Windows \CurrentVersion \Policies \Explorer”主键下的“NoFavoritesMenu”的“dword”值由0改为1来达到取消“收藏夹”子菜单的目的。再如，当我们在安装某些不具备自动卸载功能的应用软件并手工将其删除之后，该程序就会在注册表数据库中留下一些残余信息，从而影响系统的安全运行，手工修改也比较困难，而利用Regmon则可轻易解决这一问题。我们只需在安装有关软件之前先行启动Regmon程序，将该软件在安装过程中对注册表数据库的修改全部记录下来，然后在卸载该程序时再手工清除注册表数据库中的残余信息即可，从而满足了用户的需要，提高了系统的安全性。

    需要说明的是，缺省情况下Regmon会同时对注册表数据库的读取、修改、错误信息等内容进行监视，其中后两项的监视当然是非常必要的，但对读取功能的监视却值得商讨。其实我们可采取平常不对读取操作进行监视，以加快系统运行速度，而在某些特殊情况下再临时打开读取监视功能，以充分发挥Regmon监视作用的变通方法。为此，我们只需执行“Events”菜单的“Filter”命令，打开“Regmon Filter”设置框，然后取消“Log reads”选项即可。另外，我们还可以利用“Regmon Filter”设置框对监视过程、路径范围、监视的级别层次等选项加以设置，以便更好地满足日常操作的需要。

    从上面的介绍中可以看出，充分利用Regmon的注册表数据库监视功能对于简化我们对系统的维护操作、提高系统运行效率是非常有利的，况且它还是一个免费软件！怎么样？赶快到(在MYDOWN下载)下载一个试试吧！


快照 RegSnap
2000-06-28· 生哥·yesky

    Regsnap 2.6是一个注册表分析工具，别看其瘦小，只有264KB，其功能可谓强大。Regsnap可以对系统注册表文件以及Windows目录、System目录下的文件照一张快照，这个快照以.reg为扩展名的文件保存在Regsnap所在的目录下，你可以在安装或卸载软件前后各生成一个快照，由Regsnap的compare（比较）功能，看该软件对注册表等关键文件的所有改动，包括键的修改、删除和增加，这些变化就可以清楚地展现在你的眼前。

    Regsnap生成的快照文件.reg可以用文字处理软件阅读，也可以用“Windows资源管理器”打开它。

启动Regsnap
    运行Regsnap后，程序自动进入“开始向导视窗，如图：

    向导内主要有两个命令：建立一个新的快照（New Snap）和对比快照（Compare）。

两个主要命令的使用

New Snap(建立新快照)

    建立新快照最简单的方法是在向导里请单击“New Snap”按钮，除此之外，你也可以选择“File”菜单下的“New”命令。使用时首先要选择建立快照的模式，如图：

这里有三种模式，其含义为：
    Snap All：在选择该项后，Regsnap将对Windows目录和Windows System目录下的文件的INI文件（主要是win.ini和system.ini）和注册表文件建立一个快照。通常情况我们选择此项（虽然生成的快照文件较大），目的是为了防范于未然，减少修改注册表的风险！

    Registry Only：选择该选项是仅对系统注册表建立快照；优点是建立快照文件的速度快，只能监测到软件对系统注册表的修改，而对其他文件的修改毫无办法。

    Registry From Remote PC：选择该选项，可以对远程PC机的注册表建立快照文件，仅仅对网络中的计算机有用。

    选择“Snap All”，按“OK”按钮后，弹出创建进程对话框，如图：

    然后弹出一个详细的列表对话框，该对话框给出了快照所包含的键值数据个数及其他注册表信息，如图：

    单击“确定”按钮后，将出现一些快照保存的信息，如图：

    快照建立好后，只能代表你当时注册表内的情况；当你在软件的安装或卸载后如果再做一个快照。那么就要进行下一步：比较两个快照文件。

Compare snapshot（比较快照）

    比较两个注册表快照的异同，你可以选择“File”菜单中的“Compare”(比较)的命令，或者直接在工具栏上单击 [image] 按钮，弹出比较对话框，如图：

    在“First Snapshot”中选择你建立的第一个注册表快照文件名，您可以用“Browser”（浏览）命令选择文件。在“Second snapshot”中选择你建立的第二个注册表快照文件名（注意该功能不能比较同一个文件）。在快照文件选择完后，就可以选择输出的报告文件了，在输出文件时有如下两个选项：

    Show modified key name only(仅仅显示修改的键的名字)：在选择该选项后，只能在输出的报告中看到修改的键名，具体如何修改和修改成什么键值就看不到了，并且报告较小，如果想详细了解软件对注册表的修改，就要用第二个选项。

    Show modified key name and key values(显示修改的键的名字和键值)：以上选项选择结束后，就可以选择输出报告的名字，如果不选择的话，直接用系统默认的好了。单击“OK”按钮，则可以输出报告了。该报告是文本文件，Regsnap直接调用记事本打开这个报告，你就可以详细地看看软件安装或卸载前后对注册表和Windows系统的修改，在“Output file”选项中可以选择是用文本文件或进行是用HTML文件来查看，选择用文本查看“Plain text”选项后单击“OK”按钮。

    接着出现比较的工作进度显示，如图：

    比较完后，程序自动将生成的结果文件打开，如图：

    由此可见，Regsnap是Windows注册表的照相机，充分的利用这个照相机，可以随时视软件对注册表的修改，为我们提供确切的报告，不至于注册表出了错误还不知道发生在什么地方。在Regsnap生成的报告中，我们可以清楚地看到安装或卸载的软件对Windows注册表的修改和Windows目录下增加或删除的文件。


修改工具 TweakII
2000-06-28· 生哥·yesky

    这是一款跨越Win9.x、NT、2000平台的注册表修改工具，它具有强大的修改功能，能根据你使用的不同平台而提供一些修改功能，修改的功能有一百项之多。同时还支持修改Word的一些功能。进入该软件后，出现该软件的主界面，如图：

Security（安全）
    程序主界内分为几个不同类别的标签，首先出现的标签是“Security”（安全）标签。在这里你可以对Windows进行一些安全上的设置。
    按照从左至右、从上至下的顺序。安全方面的设置可分为：

Remove Desktop icons：去掉桌面图标
Remove 'File' menu in Explorer：去掉资源管理器内的文件菜单
Remove Taskbar from Start Menu：去掉任务栏
Disable 'Task Manager' option：取消任务管理器功能
Disable 'Change Password' button：取消改变密码按钮功能
Disable 'Lock Workstation' button：取消锁定工作站按钮功能
Remove 'Run' command from Start Menu：去掉开始菜单下的运行命令
Remove 'Find' command from Start Menu：去掉搜索命令
Remove 'Shut Down' button from Start Menu：去掉关机命令
Remove Program Groups common to all users：去掉程序组下的所有用户
Removie 'Network Neighborhood' from Desktop：去掉桌面上的网上邻居
Remove right click functionality from all components of Taskbar：去掉右键点击任务栏后弹出菜单中的所有功能
Remove right click functionality from Desktop & Explorer's results pane：去掉右键点击资源管理器和桌面后弹出菜单中的所有功能
Remove Control Panel, Printers & My Computer from Explorer and Start Menu：从开始菜单或资源管理器中去掉控制面板、打印机及我的电脑
Deny remote administrator access to floppy drive：拒绝管理员使用软驱
Deny remote administrator access to CD-ROM：拒绝管理员使用光驱
Restrict information for NULL logon in NT (SP3+)：禁止显示一些无效的信息
Remove Dial-Up Adapter from My Computer：去掉我的电脑中的拨号上网
Remvoe Scheduled Tasks from My Computer：去掉我的电脑中的预定计划
Clear document history from Start Menu at reboot：重新启动时清除开始菜单下的文档记录
Clear IE's typed URL list at reboot：启动后清除IE中地址栏内的地址列表
Clear history from Run command at reboot：启动后清除运行命令中的所有记录
Clear all MRU lists at reboot：启动后清除所有的列表
Clear document history from Start Menu now：立即清除开始菜单中的文档记录
Clear IE's typed URL list now：立即清除IE中地址栏内的地址列表
Clear history from Run command now：立即清除运行命令中的所有记录
Clear all MRU lists now：立即清除所有的列表

    当单击最后几项立即清除的按钮后，会弹出一个对话框要求你确认现在的操作，如图：

    在安全标签右下角，还有一个“选择更多的安全设置”按钮，如图：

    会弹出一个被另外放在一边的安全设置，因为这些设置会影响到系统的正常使用，如图：

Hide Control Panel's 'Display' applet：隐藏控制面板内的显示属性
Hide Display applet 'Appearance' tab：隐藏显示属性内的外观
Hide Display applet 'Background' tab：隐藏显示属性内的背景
Hide Display applet 'Screen Saver' tab：隐藏显示属性内的屏幕保护
Hide 'Entire Network' in Network Neighborhood：隐藏网上邻居内的所有网络
Hide workgroup contents in Network Neighborhood：隐藏网上邻居下工作组内的所有内容
Use approved shell extensions only：只允许使用共享终端
Disable Add Printer：取消增加打印机功能
Disable printer removal：取消删除打印机功能
Disable registry editing tools：取消注册表编辑工具使用
Hide all drives but C: in Explorer：隐藏资源管理器内除C驱外所有的驱动器

Win Tweaks(Win设置)
    在这里你可以设置一些与窗口操作有关的一些设置，如图：

Place cascading Control Panel on Start Menu：将控制面板内的项目放入开始菜单
Place cascading Printer folder on Start Menu：将打印机组内的项目放入开始菜单
Remove Favorites folder：去掉收藏夹
Remove Documents folder：去掉文档文件夹
Remove 'Log Off' option：去掉注销
Force Start Menu items to be alphabetical：将开始菜单内的菜单按字母重新排序
Speed up the Start Menu：开始菜单弹出速度
Disable CD-ROM auto play：取消光驱自动播放功能

    接下来是“Select for more WinTweaks”（更多的关于Win的设置）按钮，如图：

    单击后弹出设置对话框，如图：

    在这里，我们再来看看它为我们提供了哪些功能：

Add right click menu for DOS Box：在DOS提示符下支持鼠标右键菜单
Enable smooth scrolling：在IE内使用平滑滚动
Disable disk caching：取消磁盘缓冲功能
Change Internet Explorer title bar：改变IE标题栏
Create moniker for IE Favorite bookmark：在IE中建立新书签
Change IE's default search engine：改变IE默认的搜索引擎
Remove entry from Control Panel's Add/Remove applet：在控制面板的增加／删除中删除无用的项目
Remove shortcut arrows：去掉快捷方式图标中的箭头
Increase Icon cache size：增加图标缓冲区容量
Rebuild icon cache：重新图标缓冲区

    接下来应该介绍Windows 9x，但是我使用的平台为NT，所以进入该标签后，里面所有的功能都被取消，关于这部分的内容在这里略过！

NT4/Win2K（NT4.0和解决Win2K问题的设置）
    现在进入的标签是“NT4/Win2K”，在这里，程序为我们提供了一些专门针对NT和Win2K问题的解决方法，还有一些折衷的方法及网络设置，如图：

    该标签内，还有一些关于NT服务器和解决NT故障的一些功能，初学者可以不用了解这部分，所以在这里全部略过。

MS Office（关于Office一些设置）
    进入该标签后，只发现一个“Select for MS Office tweaks”按钮，如图：

    如果你未安装Office，该按钮内的功能设置将无效。请单击该按钮，弹出对Office设置的对话框，如图：

Disable Tips of the Day：取消进入时的提示，即小技巧
Disable feature and suggestion tips：取消Office特征和技巧提示
Disable tips for keyboard shortcuts：取消快捷键
Disable watch of mouse commands with tips：取消鼠标命令
Show Office Assistant when pressing F1：当按下F1键后显示Office助手
Disable Office Assistant help messages：取消Office助手的帮助信息
Disable context sensitive help from Assistant：取消来自助手的上下文帮助
Show only high priority tips：始终显示最高优先级的提示
Allow tips with most Office Wizards：允许使用多个向导提示
Disable the Assistant：取消助手
Change the current Actor：改变当前表演者
Assistant moves when in the way：当等待时显示助手动画
Disable Assistant sounds：取消助手的音效
Disable the Cliopboard toolbar triggers：取消粘贴板触发器

Option（关于系统的一些选择性设置）

Never show confirmations before actions：不显示确定动作时的提示按钮
Never show reboot request：不显示需要重新启动的提示
Don't save widow position when closing：关闭系统后不保存系统的设置
Don't remember last tab used：不保存最后一个使用者的记录.
    每次设置好，别忘记了单击窗口下边的“Apply”按钮，令刚才的设置生效。如果你忘记这些设置的初始状态是什么，没关系！请你再单击窗口下边的“Restore Defaults”来恢复这些设置的默认值即可。(在MYDOWN下载)


新编辑工具 RR107
2000-06-28· 生哥·yesky

    是新一代的注册表编辑器, 它使用类资源管理器的界面, 可以拷贝和移动关键字设置, 支持拖放功能。

    进入RR后，首先出现在我们面前的是主界面，菜单栏下面是地址栏，地址栏内的地址可以具有记录功能。再下面的“Description”内记录的是该键的种类；再往下是RR的工具栏，这里为我们提供了许多的工具，复制、查找、快照等应有尽有；最下面的是被编辑注册表的内容。在这里，注册表还是以树状的结构呈现在我们的面前，在树状结构内，红色代表的是受保护的主键，蓝色代表的是当前的位置，如图：

    要编辑其中的键值非常的简单，进入子键后，窗口右边会弹出这个子键下的所有键值，如图：

    键值列出的结构与注册表编辑器内的结构基本一样，有键值名、数值、类型。双击其中的键值进入该键值的属性对话框，在这里我们可以对该键值进行编辑，如图：

    在键值的属性对话框里，列出了该键值的名字、值、类型及它的大小等数据，将键值所需的内容都集中在一个窗口中，为我们修改注册表提供了周到的服务。(在MYDOWN下载)


其他辅助工具
2000-06-28· cpcw·cpcw

一、注册表清理工具CleanReg

    CleanReg是一个专门的Windows注册表监测清理工具，该工具的界面设计和操作方法与我们常见的工具有所不同，程序可以自动分析系统注册表中的错误或者是无用的设置，并且可以协助你将这些设置从系统注册表中直接删除。比如将系统中安装的应用程序删除了，而这些程序可能在系统注册表中遗留下一些无用的设置，CleanReg的功能就是将这些无用设置提供给你，供你选择删除。

    CleanReg的使用方法是非常简单的，程序启动后会自动扫描当前系统注册表的所有设置，之后在界面窗口中给出相关的窗口，其中包括：CleanReg、Undo、Registry、All Files in Registry、List of Ingore Objects等，此时程序当前显示的窗口内容是“CleanReg”，其中的列表项就是程序找到的注册表无用设置。现在你可以选择该窗口中的所有无用设置列表项，然后单击“Delete key from Registry”按钮将其删除即可。对于删除的注册表项目，程序会进行备份，这样如果出现失误，以后可以顺利恢复。此外，CleanReg提供了可忽略扫描的应用程序或文件过滤功能、提供直接在程序界面中编辑当前系统注册表功能、提供直接给出需要删除的键值在系统注册表的准确位置功能、提供了以关键字方式快速查找注册表中的键值或主键功能等等，用户使用起来会感觉非常顺手，使用效果也很好。

    CleanReg是共享软件，程序提供全功能试用版本，该工具的官方站点是www.cleanreg.com，在此你可以得到程序的最新版本以及升级信息。(在MYDOWN下载)

    二、注册表编辑器辅助工具Registry Crawler

    Registry Crawler是一个Windows注册表的增强工具，通过该工具可以在很大程度上增强系统的注册表编辑器的查找功能。该工具提供了一个非常强大的搜索引擎，并以关键字方式查找，这似乎并没有什么特殊之处。该工具的突出特点是可以一次将所有扫描到的符合扫描条件的全部注册表设置在界面窗口中给出，你也可以非常方便、直观地找到自己需要的设置项，这一点与Windows提供的注册表编辑器的逐个查找功能相比要强大许多倍，也是我们推荐它的一个主要原因。

    Registry Crawler的使用方法是非常简单的，直接在程序界面中的“Search”文本框中输入需要查找的关键字，然后在“Where to search”项中设置可以扫描的注册表范围，在“How to search”项中设置扫描方式，之后单击“Go”按钮即可。扫描完成后程序会在界面窗口中给出符合条件的结果列表，现在你可以选择自己需要的东西了。对于扫描结果列表，程序提供了直接调用Windows注册表编辑器打开当前键值或主键所在位置（单击“Goto Key”按钮），或者是复制到系统剪贴板（单击“Copy”按钮）、设置当前位置书签（单击“Bookmark”按钮）等功能，如果需要调试注册表设置或者是进行反复编辑修改，使用这些功能是非常合适的。此外，Registry Crawler也提供了将当前的扫描结果输出为HTML格式文件和TXT格式文件功能，这样你可以打印出来慢慢研究。如果需要使用创建的书签项，可切换到“Bookmarks”标签项，程序会在界面窗口中给出所有设置的书签列表，你可以快速选择需要使用的主键或键值。

    Registry Crawler是共享软件，程序提供全功能试用版本，该工具的官方站点是http:∥www.4developers.com，在此你可以得到程序的最新版本以及升级信息。(在MYDOWN下载)

    三、注册表隐含设置编辑器Registry Tune

    Registry Tune是一个用于编辑Windows注册表编辑工具。不过该工具有些特别，它提供的功能是编辑注册表中的隐含设置或键值设置，程序在界面中给出了详细的各种设置项目树形列表，并针对每个列表项给出了详细的说明。程序提供额度编辑项目几乎涵盖了Windows注册表的所有位置，如我们常用的调整Modem拨号上网设置、调整NT登录方式和登录用户设置、鼠标滚动、允许或禁止显示的系统级文件夹和图标设置、系统路径、桌面、资源管理器、Web浏览器、安全等等。程序在界面中直接提供了基于Win9x和基于NT的设置，全部设置项目加起来有好几百项，远比目前常见的各种Windows注册表隐含属性修改工具要多。而且程序会给出每个设置项目在系统注册表中的详细位置，以及如何设置才是正确的，如何设置可以取得各种效果，这些都是用户学习Windows注册表的最好方式。

    Registry Tune的使用方法极为简单，程序以双窗口界面形式出现。在左边窗口中给出的是所有可供选择的设置项目列表，右边给出的是相关项目的说明和设置界面，你可以根据程序的提示进行设置。之后，单击程序界面按钮条中的“Make changes to Registry”按钮添加到注册表中即可。在程序界面中还提供了简单的以关键字方式查找注册表列表项目功能，这样更加便于快速定位需要查找的项目。

    Registry Tune是共享软件，程序提供全功能试用版本，该工具的官方站点是http:∥kslsoft.virtualave.net，在此你可以得到程序的最新版本以及升级信息。


Windows 98安全技巧大全(一)

    如何让我们的计算机更好地，安全地运行，是每一个用户都在思考的问题，本文下面将介绍如何利用Windows 98自身的功能实现对系统的安全控制，希望对广大用户的数据安全有所帮助。

一、对系统进行安全控制的基本思路

    公用微机的操作者一般分为三大类:第一类是系统管理员，他们拥有对系统的绝对控制权，一般来说没有必要对他们的权限进行限制;第二类是普通用户，他们使用计算机完成各种工作，因此必须获得一定的权限，不过也要防止他们超越权限或破坏系统;第三类为非法入侵者，他们根本无权使用计算机，对他们一定要将系统的一切功能全部屏蔽，使之无隙可乘。
    按照这个思路，我们首先必须对Windows 98的正常操作人员（包括超级用户）进行设置，将操作人员名单全部输入到系统中，然后分别对他们的权限进行适当设置，这样既保证了他们的安全，又禁止他们越权操作，最后便是采取措施，防止非法用户“入侵”，确保系统安全。

二、微机操作人员的设置

    Windows 95系统是一个多用户操作系统，但它在用户管理方面却非常混乱，非法入侵者甚至可以在启动时通过密码确认框直接添加新的用户，这对我们控制系统带来了很大的不便。不过Windows 98对此进行了改进，它提供了用户名的选择性登录功能，我们可事先将所有用户全部添加到系统中，然后由系统在启动时将这些用户列表显示出来，不同用户从中选择自己的用户名并输入相应的密码之后即可以自己的名义启动系统，而非法用户则无法通过密码确认框直接创建新用户，他们只能通过按下“取消”按钮或Esc键来进入系统。这样，机器便能明确地区分正常用户（包括超级用户和普通用户）与非法入侵者——通过登录框选择用户名并输入密码进入的是正常用户，使用“取消”按钮进入的是非法入侵者，我们可以据此分别对他们的权限进行限制。
    须要说明的是，Windows 98在默认情况下仍然采用与Windows 95相同的“老式”用户名登录方式，我们想要使用用户名选择性登录方式则应执行如下步骤:
    下面1～4步骤主要用于在Windows 98中设置用户名及密码，若用户已经设置过，则可跳过这些步骤，直接从第5步开始。
    1.双击Windows 98“控制面板”中的“密码”图标，打开“密码属性”设置框。
    2.复选“用户可自定义首选项及桌面设置，登录时，Windows将自动启用个人设置”选项（如图1）。
    3.根据需要决定是否选择将“开始”菜单添加到用户的自定义设置中（一般应选择“是”），然后单击“确定”按钮，接着根据屏幕提示设置适当的用户密码。
    4.单击“确定”按钮退出设置框。
    重新启动计算机，此时系统就会弹出一个常规性的密码设置窗口，我们可输入刚设置的用户名及密码，按正常方式启动Windows 98。
    5.启动“控制面板”，双击“网络”图标，打开“网络”设置框。
    6.在“网络”设置框中选择“配置”选项卡。
    7.从“主网络登录”列表框中选择“Microsoft友好登录”选项（如图2）。
    8.单击“确定”按钮并重新启动计算机。
    此后，Windows 98启动时弹出的密码设置框就会发生根本性的变化，它会将所有已经添加的用户名全部以列表方式显示出来（如图3），广大用户只须在“选择用户名”列表框中选择自己的名称，然后再在“密码”框中输入相应的密码即可启动各自的系统配置。
    执行上述步骤之后，系统安装用户（超级用户）已经被添加到了Windows 98中，接下来我们就应将操作用户（普通用户）添加到Windows 98中。由于采用选择性登录方式，系统不允许直接在Windows 98的用户登录窗口中创建新的用户，我们必须通过双击“控制面板”中的“用户”图标，打开“添加用户”窗口（如图4），并在“添加用户”向导的帮助下逐步将本台计算机上所有普通用户的用户名及密码逐一添加到系统中（此后他们就会出现在Windows 98的启动登录框中），然后我们就可以分别对这些用户的权限进行设置了。


Windows 98安全技巧大全(二)

三、对超级用户权限的设置

    对超级用户而言，其操作权限一般不应作太多限制（否则谁来对系统进行控制呢?），不过我们仍须对电源管理、屏幕保护等功能设置必要的密码，以维护自己离机时系统的安全，防止其他用户非法入侵。为此，我们可重新启动计算机，当系统弹出用户登录框时选择自己的名字并输入相应的密码，采用超级用户身份登录系统，然后根据需要分别对有关密码进行设置。

(一)为Windows 98的电源管理功能设置密码

1.单击“开始”按钮，然后依次选择“设置”、“控制面板”，启动Windows 98的控制面板。
2.双击“控制面板”中的“电源管理”图标，打开“电源管理属性”设置框。
3.从“电源管理属性”设置框中选择“高级”标签。
4.复选“计算机退出待机状态时提示输入密码”选项（如图5）。
5.选择“电源管理属性”设置框中的“电源方案”标签。
6.在“系统等待状态”列表框中选择计算机在没有操作多长时间之后自动启动电源管理功能（即进入“挂起”状态），主要有“从1分钟之后”到“从不”等多种选项，我们应根据需要选择不同的选项，笔者建议选择“从10分钟之后”。
7.为关闭监视器和关闭硬盘设置合适的时间间隔。
8.单击“确定”按钮，关闭“电源管理属性”设置框。
这样我们就启动了Windows 98的电源管理功能，并为其设置了保护的密码，今后如果用户在指定的时间（10分钟）内没有对计算机进行任何操作（包括移动键盘和鼠标），计算机就将自动进入“挂起”状态，以便节省电力消耗（注：单击“开始”按钮并选择“关闭系统”命令，然后从弹出的“关闭系统”对话框中选择“将您的计算机转入睡眠状态”也可达到同样的目的），而后用户通过敲击键盘或移动鼠标来激活计算机时，系统将会要求用户输入密码（如图6），不输入密码将不能返回正常状态，这就进一步保护了用户数据的安全。注意，Windows 98电源管理功能并没有自己单独的密码，它的密码与用户的启动密码相同，你到时候可别以为自己忘了密码哦！

(二)为屏幕保护程序设置密码

1.用鼠标右键单击桌面空白处，然后从弹出的快捷菜单中执行“属性”命令，打开“显示属性”设置框。
2.单击“屏幕保护程序”标签，然后从“屏幕保护程序”列表框中选择所需的屏幕保护程序，复选“密码保护”选项。
3.单击“更改”按钮，打开“更改密码”对话框（如图7），重复两次输入密码并单击“确定”按钮，关闭“更改密码”对话框。
4.单击“设置”按钮，对屏幕保护的有关功能进行适当设置:在“等待”框中设置多长时间不使用计算机后系统自动启动屏幕保护（一般可选择5分钟）。
5.单击“确定”按钮，保存设置并关闭“显示属性”设置框。
    这样，我们就达到了为屏幕保护设置密码的目的。此后只要我们离开计算机（即不操作计算机）的时间达到5分钟，系统就会自动启动屏幕保护程序，而当用户移动鼠标或敲击键盘想返回正常工作状态时，系统就会打开一个密码确认框（如图8），只有输入正确的密码之后才能返回系统,不知道密码的用户将无法进入工作状态，从而保护了数据的安全。须要说明的是，部分设计不完善的屏幕保护程序没有屏蔽系统的Ctrl+Alt+Del组合键，非法用户只要按下Ctrl+Alt+Del键即可强行将这些屏幕保护程序关闭，从而使其失去应有的保护作用。判断一个屏幕保护程序是否屏蔽了Ctrl+Alt+Del组合键,可采用如下办法：为其设置密码后激活它，然后移动鼠标，打开它的密码确认框,再按下Ctrl+Alt+Del键。若能弹出“关闭程序”对话框则表明该程序没有屏蔽Ctrl+Alt+Del键,我们不能使用;若无法弹出“关闭程序”对话框则表明该程序屏蔽了Ctrl+Alt+Del键，可放心使用。
    屏幕保护最快只能在用户离开1分钟之后自动启动，这就存在一个时间差的问题!难道我们必须坐在计算机旁等待X分钟看到屏幕保护激活之后才能再离开吗？当然不是!我们只须打开Windows 98的SYSTEM子目录，找到相应的屏幕保护程序(*.SCR文件),按住鼠标右键将它们拖曳到桌面上,选择弹出菜单中的“在当前位置创建快捷方式”命令,在桌面上为这些屏幕保护程序建立一个快捷方式。此后,我们在离开计算机时双击这个快捷方式即可快速启动屏幕保护。
    另外，利用屏幕保护程序的密码保护功能，我们还可令Windows 98一启动就自动运行屏幕保护程序，此后只有输入密码才能启动计算机。不过此功能绝对不能通过Windows 98的“启动”程序组来实现(Windows 98“启动”程序组中的所有程序在启动时都可通过按下Ctrl键跳过，从而无法启动屏幕保护功能)，只有通过修改注册表数据才能确保设置万无一失。具体步骤为:
1.运行regedit命令，打开注册表编辑器;
2.展开HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run分支;
3.在Run主键中新建一个名为“密码确认”的字符串值;
4.双击新建的“密码确认”字符串，打开“编辑字符串”对话框;
5.在“编辑字符串”对话框的“键值”栏中输入相应的屏幕保护程序名及所在的路径（如图9）。
    通过这样的设置，此后每次启动Windows 98时屏幕保护程序都会自动运行（利用Ctrl键试图跳过启动程序和按Ctrl+Alt+Del试图强行关闭系统都无能为力），只有在输入密码之后才能使用，从而确保了系统的安全。
    注:电源管理密码和屏幕保护密码的作用基本类似，但各有优势。如电源管理功能的密码可区分不同用户，适合于多用户同时使用，而屏幕保护功能则无法设置多用户，不同用户必须设置不同的屏幕保护程序，操作不太方便;另一方面，屏幕保护功能的运用比较灵活（如我们可实现一开机就进入屏幕保护状态），而电源管理功能在这方面相对要差一些，用户应根据自己的实际情况选用其一。

(三)禁止光盘的自动运行功能

    为屏幕保护设置密码之后我们就万无一失了吗？不!光盘的自动运行功能会给我们带来麻烦。众所周知，Windows 98具有自动运行光盘的功能，当我们在光驱中插入CD之后，CD会自动进行播放，而当我们插入根目录中带有AUTORUN.INF文件的光盘之后,光盘也会自动运行。Windows 98的屏幕保护功能并没有禁止光盘的自动运行功能，也就是说即使处于屏幕保护程序密码的控制之下，用户在插入一张根目录中含有AUTORUN.INF文件的光盘之后，系统仍会自动运行，这就给恶意攻击者带来了可乘之机（据说市面上已经出现了一种专门用于破解屏幕保护程序密码的自动运行光盘，插入该光盘后，系统就会自动对屏幕保护功能的密码进行分析并破译出密码，然后再将密码写到软盘上，接下来……），因此我们必须将光盘的自动运行功能关闭，让屏幕保护真正发挥它应有的安全保护作用。关闭光盘的自动运行功能,可以按如下步骤操作:
1.用鼠标右键单击“我的电脑”图标,然后从弹出的快捷菜单中执行“属性”命令,打开“系统属性”设置框;
2.单击“设备管理器”标签;
3.展开CDROM分支,从中选择用户所使用的光驱;
4.单击“属性”按钮,打开光驱属性设置框；
5.单击“属性”标签;
6.取消“自动插入功能”选项（如图10）;
7.连续单击两次“确定”按钮,保存设置并退出所有对话框。
    执行上述步骤后,无论谁在光驱中插入根目录中含有AUTORUN. INF文件的光盘之后,系统都不会自动运行。美中不足的是，本方法非常“霸道”——除光盘的自动运行功能之外，CD的自动播放功能也将被“牵连”，也就是说设置此功能后，系统将不会再自动播放插入的CD。有没有两全其美的办法呢？回答是肯定的，下面的步骤可为我们排忧解难:
1.重复执行前述步骤，并在第6步中复选“自动插入功能”选项;
2.运行regedit命令，打开注册表编辑器;
3.展开HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支;
4.在Explorer主键中新建一个DWORD值，取名为“NoDriveTypeAutoRun”并将其值设置为1;
5.这样，光盘的自动运行功能将被禁止，插入根目录中含有AUTORUN.INF文件的光盘后将不会发生任何作用，而CD的自动播放功能则得以保存。


Windows 98安全技巧大全(三)

四、对普通用户权限的限制

    现在，我们来设置普通用户的权限。对这些用户，我们一方面应根据工作需要赋予他们适当的权限，如启动计算机，打开相应的应用程序，对自己的数据文件进行拷贝、删除等操作，以保证他们工作的正常开展;另一方面，为了防止他们对系统进行修改而破坏整个系统，必须对他们的权限进行必要的限制，如不允许他们使用控制面板中的某些设置项目以防任意修改系统;不允许使用注册表编辑器、隐藏系统文件所在的分区以防意外等。
    对普通用户权限进行设置的步骤为:
    启动Windows 98，系统弹出启动登录框后从中选择须要限制其权限的普通用户，并输入相应的密码，以该用户的身份进入系统。参照超级用户的有关步骤对电源管理、屏幕保护等项目设置密码，然后根据需要对他们的权限进行必要的限制（注意，由于工作原因，不同普通用户可能须要拥有不同的操作权限，因此我们在对他们的权限进行设置时必须根据实际情况有选择地加以限制），最后将启动密码、电源管理及屏幕保护的密码通知相应用户，要求其独立对这些初识密码进行更改。至此，我们对相应用户权限的限制工作也告完成，此后即可由他们在限制的权限内正常对计算机进行操作。对普通用户的权限进行限制的措施主要包括:

(一)删除“开始”菜单中的有关命令和项目

    为了防止用户利用Windows 98“开始”菜单上的“查找”、“运行”等命令来运行一些特殊的应用程序，我们必须采用适当方法将它们删除:
◆对“开始”菜单中“收藏夹”选项的操作:
1.运行Regedit命令，打开注册表编辑器;
2.展开HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支;
3.在Explorer主键下新建一个名为NoFavoritesMenu的DWORD值，双击该值，在“编辑DWORD值”对话框中将键值由0改为1;
4.单击“确定”按钮，关闭“编辑DWORD值”对话框，重新启动Windows 98，“开始”菜单中的“收藏夹”选项就会消失。
◆对“开始”菜单中“文档”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoRecentDocsHistory”的DWORD值,并将其值修改为1,则“文档”菜单中的内容不能被修改;在Explorer主键下新建一个名为“ClearRecentDocs OnExit”的DWORD值,并将其值修改为1,则每次退出系统时,Windows 98将自动清除文档菜单中的历史记录,在Explorer主键下新建一个名为“NoRecentDocs Menu”的二进制值,并将其值修改为“01 00 00 00”，则“文档”菜单将从Windows的“开始”菜单中消失。
◆对“开始”菜单中“运行”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoRun”的DWORD值,并将其值修改为1,则“运行”命令将从Windows 98的“开始”菜单中消失。
◆对“开始”菜单中“设置”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoSetFolders”的二进制值，并将其值修改为“01 00 00 00”，则“设置”子菜单将从Windows 98的“开始”菜单中消失;在Explorer主键下新建一个名为“NoSetTaskbar”的二进制值，并将其值修改为“01 00 00 00”,我们将不能再对Windows 98的任务栏属性进行设置(前面设置了“NoSetFolders”二进制值之后,Windows 98的“设置”菜单不复存在,不过我们仍可通过右击Windows 98任务栏,并执行“属性”命令打开“任务栏”属性对话框,这显然不能满足我们关闭“任务栏”属性的要求,而设置此参数后，右击任务栏的方法也将失效)。
◆对“开始”菜单中“查找”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoFind”的DWORD值,并将其值修改为1,“开始”菜单中的“查找”子菜单就会消失。
◆对“开始”菜单中“关闭系统”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoClose”的DWORD值，并将其值修改为1，“关闭系统”命令就将从“开始”菜单中消失。
◆对“开始”菜单中“注销”选项的操作:
    利用上面相同的方法，在Explorer主键下新建一个名为“NoLogOff”的二进制值,并将其值修改为“01 00 00 00”,则“注销”命令将从Windows 98的“开始”菜单中消失。
◆取消用户的环境设置:
    利用上面相同的方法,在Explorer主键下新建一个名为“NoSaveSettings”的二进制值,并将其值修改为“01 00 00 00”,此后每次退出Windows 98时系统都不会保存用户对环境所作的设置。
经过上述设置后,可以满足不同用户的需要。

(二)隐藏“开始”菜单中的应用程序

    对于普通用户,我们可能要防止他们使用某些应用程序，这时就应采用下面的方法将Windows 98“开始”菜单中的应用程序隐藏起来:
1.用鼠标右键单击“开始”菜单,从弹出的快捷菜单中执行“打开”命令,打开“Start Menu”文件夹窗口;
2.在“Start Menu”文件夹窗口中找到希望隐藏的应用程序的快捷方式。
3.右击该快捷方式,然后从弹出的快捷菜单中执行“属性”命令,打开相应快捷方式的属性设置框。
4.复选“隐藏”选项，然后单击“确定”按钮，关闭所有对话框。
    此后，这些隐藏的快捷方式就会从Windows 98的“开始”菜单中消失，从而在一定程度上达到了保密的目的（取消这些快捷方式的隐藏属性后即可令其重新显示）。

(三)删除“网上邻居”等系统图标的技巧

    基于某些特殊需要，我们可能须要禁止普通用户使用桌面上的“网上邻居”、“我的文档”、“回收站”等系统图标，而它们又不能采用常规方法删除。为此，我们可执行如下步骤:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer＼Desktop＼Namespace主键;
3.此时我们可以从NameSpace 主键中看到“网上邻居”、“我的文档”、“回收站”等分支，只须删除这些分支即可达到删除桌面上相应系统图标的目的。

(四)在图形界面下隐藏某个驱动器图标

    为防止普通用户的破坏，我们可能希望将保存系统文件的磁盘分区（如C盘）以及光驱、软驱等隐藏起来，不允许他们对这些磁盘分区进行访问。为此我们可以进行下面的操作:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支;
3.用鼠标右键单击桌面空白处，然后执行快捷菜单中“新建”子菜单中的“二进制值”命令，创建一个名为“NoDrives”的二进制值。该二进制值(“NoDrives”)就是用于设置是否隐藏某个驱动器的，它由四个二进制字节构成(缺省值为00 00 00 00)，每个字节的每一位都分别对应一个磁盘驱动器的盘符。当某位为1时，资源管理器及“我的电脑”中的相应驱动器图标即会隐藏起来。驱动器的值是这样确定的:A~Z的值依次为2的0至25次方，把要禁止的驱动器的值相加，转换为十六进制，就是NoDrives的键值。如要禁止A、D、E，则为1+8+16=25，转换为十六进制数19，修改NoDrives的值为“19 00 00 00”即可。
    完成上述操作后，相应的磁盘驱动器图标就会从Windows 98的图形界面中消失，我们无论是从“资源管理器”、“我的电脑”及有关文件的打开、关闭对话框还是在其它外挂文件管理器（如Windows Commander等）中都无法发现这些隐藏了的磁盘分区的踪迹，从而满足了防止普通用户对系统文件进行破坏的需要，同时也使得他们不能使用任何外来程序（光驱、软驱都不能访问，光驱的自动运行功能又被禁止，有谁还能安装、运行其它程序呢），很好地保护了系统的安全。

(五)禁止使用MS-DOS方式的技巧

    采用前述方式隐藏某个磁盘分区的作用仅限于图形界面(如“资源管理器”、“我的电脑”、“Windows Commander”及其它对话框等),但它对字符方式，如MS-DOS方式无效。也就是说普通用户只要启动MS-DOS方式即可对隐藏的磁盘分区进行任意操作,这就是一大漏洞,因此我们必须采用适当办法禁止普通用户使用Windows 98的MS-DOS方式。具体步骤为:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼SoftWare＼Microsoft＼Windows＼CurrentVersion＼Policies分支;
3.在Policies主键下新建一个名为WinOldApp的主键;
4.在WinOldApp主键下新建一个名为Disabled的DWORD值,并将其值设置为1(该项用于禁止用户进入Windows 98的MS-DOS窗口);
5.在WinOldApp主键下新建一个名为NoRealMode的DWORD值，并将其值设置为1(该项用于禁止用户在关闭系统时选择“重新启动计算机并且切换至MS-DOS状态)。
    这样,我们就实现了在Windows 98中禁止使用MS-DOS方式的目的，此后用户在试图进入MS-DOS方式(包括运行那些基于DOS平台的应用程序)时，系统就会弹出一个MS-DOS受到限制的对话框(如图11)，不允许用户进入DOS方式，从而达到了保密的目的。
    须要说明的是,当我们对某个普通用户的磁盘分区进行隐藏时,必须同时禁止该用户使用MS-DOS方式!反之却不存在必要的对应关系,也就是说我们可单独禁止某普通用户使用MS-DOS方式的权限,而不必对该用户的某个磁盘分区进行隐藏。

(六)禁止使用控制面板中的某些特殊功能

    前面我们介绍了通过“NoSetFolders”二进制值可禁止显示Windows 98“开始”菜单中的“设置”选项,不过有时我们并不希望关闭“控制面板”,而只是希望禁止普通用户使用其中的部分功能(如禁止他们对“系统属性”进行设置等)。我们可以利用Windows 98目录下的CONTROL.INI文件来达到这个目的:
1.双击C:\windows文件夹中的CONTROL.INI;
2.在CONTROL.INI文件的[don't load]一节中加上“*.CPL=NO”命令,则相应的系统控制项目就会从“控制面板”中消失,如我们加上“SYSDM.CPL=NO”之后,“控制面板”中的“系统”项目就会消失。有关CPL文件与Windows 98“控制面板”中相应控制项目的对应关系如下。注意,部分CPL文件同时对应“控制面板”中的几个设制项目,如SYSDM.CPL就同时对应“控制面板”中的“系统”和“添加新硬件”两个设置项目,当我们在CONTROL.INI文件中对这些CPL文件设置“*.CPL=NO”命令后,“控制面板”中它所对应的所有设制项目都会消失。
ACCESS.CPL 辅助选项
APPWIZ.CPL 添加/删除应用程序
DESK.CPL 显示器
INETCPL.CPL Internet属性
INTL.CPL 区域
JOY.CPL 游戏控制器
MAIN.CPL 鼠标、打印机、键盘、输入法、
字体
MMSYS.CPL 多媒体、声音
MODEM.CPL 调制解调器
NETCPL.CPL 网络
PASSWORD.CPL 密码
POWERCFG.CPL 电源管理
STICPL.CPL 扫描仪与数码相机
SYSDM.CPL 系统、添加新硬件
TIMEDATE.CPL 日期和时间
ODBCCP32.CPL ODBC数据源管理器
TELEPHON.CPL 电话
THEMES.CPL 桌面主体
MLCFG32.CPL 电子邮件
FINDFAST.CPL 文件检索
TOGMOUSE.CPL ToggleMOUSE鼠标设置
TWEAKUI.CPL TWEAK UI设置软件
    经过上述设置后,“控制面板”中的相应项目就不会出现。不过,只要上述文件还保存在计算机中，我们就仍然可以运行,如只须用鼠标右键单击“桌面”、“我的电脑”、“网上邻居”并执行“属性”命令，或双击系统“托盘”中的“时间”、“声音”等项目即可对显示属性、系统属性、网络属性、时区、输入法、声音等项目进行设置!另外,如果没有隐藏Windows 98的系统文件所在的磁盘分区,任何人只要打开Windows 98的SYSTEM目录,用鼠标右键单击相应的CPL文件并执行快捷菜单中的“用控制面板打开”命令，都可达到启动“控制面板”中有关设置项目的目的。因此CONTROL.INI文件的控制功能是不完善的,想真正做到“万无一失”,应通过修改注册表数据库进行控制:
1.运行注册表编辑器Regedit打开注册表。
2.展开注册表数据库的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System分支。
◆在System主键下新建一个名为NoVirt MemPage的DWORD值,并将其值设置为1,则“控制面板/系统”设置项中的“虚拟内存”选项失效。
◆在System主键下新建一个名为NoFile SysPage的DWORD值,并将其值设置为1,则“控制面板/系统”设置项中的“文件系统”选项失效。
◆在System主键下新建一个名为NoConfig Page的DWORD值，并将其值设置为1，则“控制面板/系统”设置项中的“硬件配置文件”选项卡失效。
◆在System主键下新建一个名为NoDev MgrPage的DWORD值,并将其值设置为1,则“控制面板/系统”设置项中的“设备管理”选项卡失效。
◆在System主键下新建一个名为NoDisp Backgro undPage的DWORD值，并将其值设置为1,则“控制面板/显示”设置项中的“背景”选项卡失效。
◆在System主键下新建一个名为NoDisp ScrSav Page的DWORD值,并将其值设置为1,则“控制面板/显示”设置项中的“屏幕保护”选项卡失效。
◆在System主键下新建一个名为NoDisp Appearan cePage的DWORD值,并将其值设置为1,则“控制面板/显示”设置项中的“外观”选项卡失效。
◆在System主键下新建一个名为NoDisp Setti ngsPage的DWORD值,并将其值设置为1,则“控制面板/显示”设置项中的“设置”、“外观”、“Web页”选项卡失效。
◆在System主键下新建一个名为NoDispCPL的DWORD值,并将其值设置为1,则“控制面板/显示”设置项将被禁止。
设置完上述选项后,相应用户的这些功能就会受到限制,如当我们新建了NoDispCPL值之后,用户无论采用什么方法（无论是从“控制面板”中启动“显示”项,用鼠标右键单击桌面空白处后选择弹出菜单中的“属性”项、还是直接运行DESK.CPL文件）,系统都会弹出一个“管理员已经禁止使用‘显示’控制面板”的对话框（如图12）,禁止该用户使用显示器属性设置框,这就从根本上达到了限制普通用户权限的目的。不过Windows 98注册表数据库对控制面板的限制功能并不完善,它仅能限制上述设置项目,而对其它一些设置项目（如电话、网络、密码等）则无能为力，我们若拟完全禁止普通用户使用这些功能,唯一的办法就是切换到Windows 98的SYSTEM子目录,删除相应的控制面板文件(*.CPL文件)。但应注意不要将PASSWORD.CPL文件(即密码控制器)也删除掉(具体原因后面会详细说明)!

(七)禁止自启动应用程序

    某些开机时自动运行的应用程序可能会给系统带来不安全的隐患，因此我们必须采用适当的方法禁止它们。
◆取消“启动”程序组中的启动程序
绝大多数Windows应用程序都是通过“启动”程序组来实现自动运行目的的,对此我们可采用如下方法加以禁止:
1.用鼠标右键单击Windows 98任务栏空白处，然后执行快捷菜单中的“属性”命令;
2.在弹出的“任务栏属性”对话框中单击“开始菜单程序”标签;
3.单击“删除”按钮，系统弹出“删除快捷方式/文件夹”对话框;
4.选择“启动”程序组中欲禁止在Windows 98启动时自动运行的应用程序的快捷方式,然后单击“删除”按钮。
◆取消WIN.INI文件中的自启动选项
许多老版本应用程序都是通过WIN.INI文件中的“RUN”和“LOAD”命令来实现在Windows启动时自动运行的功能的,对于这些应用程序，我们只须利用记事本打开WIN.INI文件,找到“RUN=”或“LOAD=”行,然后将调用这些应用程序的命令行删除即可。
◆取消Autoexec.bat文件中的自启动命令行
通过Autoexec.BAT文件实现系统启动时程序自动运行是许多DOS程序常采用的简便方法,对于它们，我们只须利用记事本打开Autoexec.bat文件,然后将调用这些应用程序的命令行删除即可。
◆修改注册表中的自启动选项
在Windows 98中,系统新增了通过注册表数据库实现在启动时自动运行应用程序的功能,对于采用这一功能的应用程序，我们可采用如下方法:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_LOCAL_MACHINE＼Software＼Microsoft＼Windows＼CurrentVersion＼Run分支;
3.Run主键中保存的就是所有通过注册表数据库实现在Windows 98启动时自动运行的应用程序,我们只须从中删除拟禁止的应用程序即可。

(八)删除“新建”子菜单中的命令

    一般来说,单击鼠标右键都会从弹出的快捷菜单中发现一个“新建”子菜单（如图13）,我们可以通过该菜单下的命令快速实现文本文件、图形文件等的创建，非常方便。不过有时为了安全起见,我们可能需要删除普通用户“新建”子菜单中的某些新建命令。对此,我们可采用如下方法:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CLASSES_ROOT主键，在HKEY_CLASSES_ROOT主键下找到要删除的新建文件类型的次级主键（如“.ZIP”次级主键）;
3.展开该次级主键下的“ShellNew”分支（HKEY_CLASSES_ROOT主键下以文档扩展名为名的次级主键中大多都有“ShellNew”分支,这些分支就是专门用于指定采用那个应用程序来创建相应数据文档的,我们只须删除它们即可达到禁止“新建”命令的目的）;
4.将“ShellNew”分支下除“默认”项之外的所有键值全部删除;
这样，我们就删除了“新建”菜单中的“新建WinZip文档”命令,从而达到了保密的要求。用类似方法将“新建”菜单中的无用命令一一删除。

(九)清除“运行”等对话框中的历史记录

    一般来说，当我们在Windows 98中使用“运行”、“查找”等功能之后，系统就会将查找、运行的内容“记忆”下来,以简化再次运行的步骤,不过这也带来了“泄密”的可能。为保密起见，可采用下述方法将这些历史纪录删除:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Explorer分支;
3.该主键的RunMru分支是用于显示系统“运行”对话框中的历史记录的,只须从中选择不需要的历史记录并单击Del键即可删除这些记录;
4.该主键的DocFindSpecMRU分支用于显示系统开始菜单的“查找”子菜单中“查找文件或文件夹”对话框中的历史记录的,同样可从中删除不需要的历史记录;
5.展开注册表数据库的HEKY_CURRENT_USER＼Network＼Recent分支;
6.Recent主键就是用于显示系统“文档”对话框中的历史记录的,将其内容全部删除即可清除全部历史记录。
另外还有一种最简单的办法:
1.用鼠标右键单击“任务栏”的空白处,在弹出的菜单中选择“属性”选项;
2.选择“开始菜单”选项卡,然后点击“文档菜单”框中的“清除”按钮即可清除“运行”、“文档”、“历史记录”框中的历史记录。

(十)禁止使用注册表编辑器

    从上面的介绍中可以看出,注册表编辑器的作用非常之强大,许多系统控制功能都是通过它来实现的，普通用户若能使用注册表编辑器,则我们所做的一些控制就将付之东流。因此我们只有禁止普通用户对注册表编辑器的调用才能真正确保对他们权限的控制!为此,我们可采用如下方法:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System主键;
3.在System主键下新建一个名为Disable RegistryTools的DWORD值，并将其值设置为1。
这样我们就实现了禁止运行Windows 98的注册表编辑器的目的,极大地保护了系统的安全。
经过上述步骤后,我们就达到了对相应普通用户的权限进行设置的目的。重复上述操作,可对所有普通用户的权限逐一进行设置（不同用户设置权限的范围可能不一样,有些用户的权限可能要大一些、另外一些用户可能要小一些,主要取决于普通用户的操作需要）。设置完毕后,我们应将不同用户的开机密码、电源管理密码、屏幕保护密码分别告知他们,并指导他们利用“控制面板”中的“密码”设置框对各自的密码进行修改（这也就是为什么前面谈到不能删除PASSWORD.CPL文件的原因）。至此,对所有普通用户的权限设置工作即告完成。


Windows 98安全技巧大全(四)

五、对非法用户的权限进行限制

    对超级用户和普通用户的权限设置完后,剩下的事情就是“对付”那些通过在用户名选择框中单击“取消”按钮或按Esc键进入系统的非法用户了。对于他们的权限，我们应最大限度地限制，最好是让他们什么也干不成！为此，我们可重新启动计算机，并在系统弹出的用户名选择框中按下Esc键，以非法用户的身份进入系统，然后对其权限进行限制。

(一)隐藏Windows 98桌面上的所有图标

为了防止非法用户随便乱动，一般应将桌面上的所有图标全部隐藏起来，具体步骤为:
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支;
3.在Explorer主键下新建一个名为Nodesktop的DWORD值，并将其值设置为1。

(二)删除“开始”菜单中的所有命令

    可按照前面对普通用户权限设置的有关方法将非法用户“开始”菜单中的所有命令(包括运行、关闭系统、查找、文档、设置、收藏夹等项目)全部删除,然后将“程序”菜单中的所有程序项全部删除,这样整个“开始”菜单中除了帮助之外什么也没有……让非法用户对着光秃秃的桌面、孤零零的“开始”菜单发愣去吧!

(三)禁止使用任何程序

    有了前面的两项限制措施,我们即可达到对一般非法入侵者进行控制的目的,不过对那些高级别的入侵者,上面两项控制是远远不够的,他们仍可通过种种方法对系统进行破坏,而真正最彻底的控制则是不允许他们运行任何程序(包括记事本、画笔、系统查找功能、系统设置功能等等),这样才能从根本上保护系统的安全(假如不允许使用Word，那么有谁能查看计算机上Word文档中的内容呢?)。为此,我们可采用如下方法。
1.运行注册表编辑器Regedit打开注册表;
2.展开注册表数据库的HKEY_CURRENT_USER＼SOFTWARE＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支;
3.在Explorer分支下新建一个名为RestrictRun的DWORD值，并将其值设置为1。
这样我们就实现了禁止在Windows 98中运行任何程序的目的。关闭注册表编辑器之后系统设置即告生效，此时我们无论是启动Windows 98的任何一个程序(包括记事本、画笔、资源管理器及我的电脑),还是使用它的查找、设置等功能,系统都会提示该程序不能运行(如图14),也就是说非法入侵者除了晃晃鼠标之外什么也不能做，这就真正达到了将非法入侵者“置之于死地”的目的。对不起,非法用户们千万别怨我的“馊主意”,谁让你总是干些“偷鸡摸狗”的事呢?
若是你心地善良,不忍让非法入侵者太过尴尬，允许他们使用某些对系统没有任何危害的小程序(如Windows 98自带的几个游戏等),这也是可以办到的，具体步骤为:
1.重复执行前述限制任何程序运行的步骤;
2.在HKEY_CURRENT_USER＼SOFTWARE＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer分支下新建一个名为RestrictRun的主键;
3.在RestrictRun的主键下分别添加名为“1”、“2”、“3”等的字符串值;
4.将“1”、“2”、“3”……等字符串的值设置为允许非法用户使用的应用程序名(只输入文件名，无须指定路径)。如将“1”设置为“网上红心大战”的程序MSHEARTS.EXE、“2”设置为“空档接龙”的程序FREECELL.EXE、“3”设置为“扫雷程序”WINMINE.EXE、“4”设置为“纸牌程序”SOL.EXE(如图15)。
5.设置完毕,关闭注册表编辑器。此后非法用户进入系统后就只能玩这4个游戏,其它程序均不能运行。当然,也可按照上述方法自行确定允许非法用户使用的程序,不过千万注意不要将REGEDIT及其它可以对注册表数据库进行修改的任何程序(如TWEAKUI等）添加进去，否则可能会重现“农夫与蛇”的悲剧。

六、关键性的系统控制措施

    看完前面的介绍,有些读者可能认为系统已经万无一失了,不过事实却并非如此!还有很多“后门”可以为入侵者提供方便,如开机功能键、软盘启动、网络及电子邮件等，我们必须将这些“后门”一一关闭(注意,这些功能的关闭将对所有的Windows用户，包括超级用户、普通用户及非法入侵者起着同样的限制作用)。

(一)禁止系统启动功能键

    大家知道,我们只须在Windows 98启动时按下F8键即可打开系统功能菜单,进入DOS状态，此时系统就有可能遭到破坏(如我只须建立一个用于关闭系统控制功能的“.REG”注册表文件,然后在DOS下利用REGEDIT将这个REG文件导入到注册表数据库中即可达到解除所有限制的目的,另外我还可以通过密码破译器对Windows 98保存密码的文件进行分析,找出系统密码后直接以系统管理员的身份进行入侵……),因此我们必须将系统启动功能键予以关闭,以防止非法用户进入DOS状态。为此,我们可打开Windows 98的MSDOS.SYS文件,在其中加入(或将原有内容改为)如下内容:
BootDelay=0:开机时不显示“Starting Windows 98”,免去延迟时间
BootGUI=1:直接进入Windows 98图形界面，而不是DOS状态
BootKeys=0:禁止F4、F5、F8等开机功能键
BootMenu=0:不显示开机菜单
BootMulti=0:不允许双引导
BootWin=1:直接启动Windows 98，而不进入老版本DOS环境
这样我们就达到了禁止使用功能键进入DOS状态的目的(无论是老版本的DOS 6.X，还是Windows 98内置的DOS 7.X),从而保证了系统安全。

(二)禁止进入安全模式

Windows 98提供的安全模式也是一个“祸根”，尽管我们可利用它在系统发生故障时对系统进行设置，但由于此时Windows 98几乎不设防（前面所设的多数控制措施都将失效），因此它也给非法入侵用户带来可乘之机，我们必须将其禁止。须要说明的是，尽管我们一般是通过F5来进入安全模式的，但这并不是唯一途径（如我们只须在系统启动时按下Ctrl+Alt+Del重新启动计算机，下一次启动时系统就会自动采用安全模式），因此尽管前面已经禁止了Windows 98的启动功能键，但我们仍有必要对能否进入安全模式进行一番专门设置。为此我们只需打开Windows 98的MSDOS.SYS文件，然后在其中加入一条BootFailSafe=0（禁止安全模式）命令即可。

(三)禁止采用软盘及光盘启动计算机

很显然，非法用户若能以软盘及光盘启动计算机，那他就可以随意在DOS状态下对系统进行攻击，因此我们必须关闭软盘及光盘的启动功能。为此，我们应重新启动计算机，并在系统自检时按下Del键，进入系统的CMOS设置功能，然后将系统的启动选项设置为“C only”（即仅允许从C盘启动），并同时为CMOS设置必要的密码。

(四)防止网络及电子邮件的入侵

    随着网络的流行，各种黑客程序也越来越多，非法入侵者完全可通过网络的形式在你的计算机中安上一个“后门”，然后入侵你的系统，并且采用此方式入侵时往往具有极高的权限，危害相当大。这样的“后门”不是手工所能堵住的，必须使用专门的杀毒软件或反黑客软件对系统进行扫描，清除已有的黑客程序;安装诸如KILL、MCAFEE之类的病毒防火墙预防黑客程序及病毒的入侵;同时还应及时对杀毒软件进行升级以保证杀毒软件的效力等。

    至此，我们对Windows 98进行安全控制的有关步骤即介绍完毕，超级用户、普通用户及非法用户都只能按照自己的权限使用计算机，任何人（包括我在内）都无法对你的系统进行攻击，从而达到了很好的安全保护效果，有兴趣的读者不妨一试。
最后须要说明的是，Windows 98毕竟是一个针对家庭用户的操作系统，在系统安全性方面有着固有的缺陷，用户若对系统安全有较高要求，则应选择安全性、稳定性都非常高（当然对系统硬件要求也较高）的Windows NT。


Windows NT 4.0的用户权力

用户权力使登录到某帐号的用户有权在系统上完成某些操作。如果用户没有相应的权力，则执行这些操作的尝试是被禁止的。权力适用于整个系统，它不同于权限。因为后者只适用于具体的对象。
    组成员拥有授予该组的所有权力。在大多数情况下，提供权力的最简易的方法是将用户帐号添加到已有所需权力的内置组中，而不用去管理用户权力规则。但是有时需要建立一些特殊权力的用户，就需要分配用户权力。

一.分配用户权力的方法：
    1。在域用户管理器的“规则”菜单上，单击“用户权力”。
    2。选择“权力”框中列出的用户权力。“许可”框下出现当前具有该权力的组和用户帐号。
    3。要将选定权力授予其它组或用户帐号，单击“添加”，然后完成“添加用户和组”对话框。
    4。要从列表中删除组或用户帐号，请在“许可”框中选定名称，然后单击“删除”。
    5。如果要管理高级用户权力，选择“显示高级用户权力”复选框。（高级权力主要被为运行 Windows NT Workstation及 Windows NT 　　Server 的计算机编写应用程序的程序员所使用，一般不会授予组或用户。关于高级用户权力的详细信息，请参阅 Win32 SDK 文档中的“Win32 程序员参考”。这里我只介绍一般的用户权力。） 二.用户权力详细介绍：

从网络访问这台计算机

    允许用户通过网络连接到计算机。是对从其他域控制器的工作站登录到某个域的简单权力。缺省情况下，该权力赋予Everyone组。 将工作站添加到域

    允许用户将先前未知的工作站添加到域。将工作站添加到域使得工作站能够识别域用户和全局组帐号。
由于该工作站获得了对该域用户了全局清单的访问权，因此会造成安全风险。缺省情况下，权限清单里没有组，但是域 Administrator 组成员和 Account Operator 组成员具有将工作站添加到域的权力。该权力无法取消。他们也可以将这些权利授予其他用户。 备份文件和目录

    允许用户访问该域控制器上的文件和备份文件和目录。该权力优先于文件和目录权限。这是一种危险的权限，因为它不管赋予文件系统的权限如何都允许对所有文件的读出访问。缺省情况下，该权限赋予Administrator ，Backup Operators和Server Operators组。 更改系统时间

    允许用户设置计算机内部时钟的时间。虽然设置时间不算很大的安全风险，但是对于一个稳定的系统，时间的同步还是很重要的，却省情况下，该权限赋予Administrator和Server Operators组。 强制从远程系统关机

    该权力在NT4.0和以前的版本都没有实现。微软保留它以备将来使用。理论上可以让用户从远程关闭计算机，所以危险性还是比较大的。缺省情况下，把这个没有实权的权力赋予Administrator和Server Operators组。 加载和卸载设备驱动程序

    允许用户动态地加载和卸载设备驱动程序。缺省情况只允许Administrator组拥有该权力。 本地登录

    允许用户在域控制器本身或在工作组系统中的工作站上登录。在用户可以使用于控制器的小型网络中可能具有这种权限。缺省情况下赋予Administrator组和所有的Operators组。 管理审核和安全性日志

    允许用户管理文件、目录和其它对象的审核。具有该权力的用户可以使用“属性”对话框中的“安全性”标签为所选对象、用户和组以及访问类型指定审核选项。该权力并不能使用户使用“规则”菜单上的“审核”以配置被审核的安全性事件。只有 Administrator 才具备该能力。 恢复文件和目录

    允许用户恢复该计算机的文件和目录。该权力优先于文件和目录权限。该权限是对“备份文件和目录”去权限的补充。该权限允许用户覆盖系统中没有相应文件系统权限的任何文件，这样危险性很高。缺省情况下，该权限赋予Administrator ，Backup Operators和Server Operators组。 关闭系统

    允许用户关闭运行 Windows NT Workstation 或 Windows NT Server 的计算机。在域系统中这只适用于域控制器；用户可以关闭不受限制的工作站。缺省情况下赋予Administrator组和所有的Operators组。
获得文件或其它对象的所属权

    允许用户获得文件、目录和其它对象的所属权。如果文件的原拥有者被删除或者暂停了账号，这种权限有用。缺省情况只允许Administrator组拥有该权力。
注意：
    管理域时，这些权力适用于域的主域控制器和备份域控制器。
    管理运行 Windows NT Workstation 或 Windows NT Server 的非域控制器计算机时，这些权力仅限于该计算机。