使 用 说 明

  • 本手册全称“注册表实用手册”，收录的是大量简单,通俗易懂而又确实实用的windows系列注册表修改技巧.经实践证明,不但对电脑初学者有很大的帮助,对"大哥级"的电脑爱好者也有很高的参考价值.毫不夸大的说,这是一本非常实用的windows系列注册表工具书,是你学习和维护电脑的好帮手.到目前为止,手册收录了绝大部分注册表的修改技巧,并且不断充实升级,争取最大限度地收录注册表的修改技巧,使手册日趋完美.
  • 当前版本是： v5.4 免费版,包括win98,2K,NT,XP，2003的注册表修改技巧。
  • 本人力求手册完美，但因有些内容涉及系统内核，所以对使用本手册造成的可能损失由使用者承担，本人不保证所有内容都准确无误。
  • 由于手册内容太多，时间又有限，如果你在使用中发现有什么错误，请来信指正!如果你对本手册有什么好的建议和见解，欢迎来信交流！
  • 本手册由本站独立制作维护，您可以免费使用，自由传播，但请保留其版权。

编辑制作：姚 辉

制作日期：2006年10月

http://www.happydrips.com


注册表有什么用？

新手篇--注册表的用途

这是写给电脑初学者的文章，目的是让大家对注册表有所了解，如果你是高手可以跳过：）。注册表是windows的命根，里面储存着大量的系统信息，说白了就是一个庞大的数据库。如果你不懂什么是数据库，那没关系，不影响你了解注册表，不过最好对数据库有所了解。注册表里面所有的信息平时都是由windows操作系统自主管理的，也可以通过软件或手工修改。注册表里面有很多系统的重要信息，包括外设，驱动程序，软件，用户记录等等，注册表在很大程度上“指挥”电脑怎样工作。

注册表有很大的用处，功能非常强大，是windows的核心。通过修改注册表，我们可以对系统进行限制、优化等等。比如我们不想让别人用“开始”菜单，我们可以修改注册表来达到目的。除此之外，还有很多了，你可以参考本手册进行修改，里面的内容很详尽，并随时间而充实。注册表修改主要是多练习，细心观察，认真思考，就会慢慢掌握的。

特别值得一提的是，学知识是为了运用，所以并不要求对每一条命令都记住，因为太多了，时间一长容易忘记，况且这又不是考试，缓和，呵呵。你只要知道修改方法，熟练运用就可以了，好了，限于时间，本文章到此，祝学有所成！

作者：姚辉

2002/10/11


注册表修改快速入门

根据本人经验，修改注册表有三种方法，归纳如下：

在这里提醒大家一句，如果你没有把握，切记在修改之前，一定要备份注册表。

一.用windows的注册表修改器--regedit.exe

方法是在windows的左下角开始菜单里，点击运行，然后键入regedit,回车即可。你可以在打开的修改器里查找所需要修改的注册表修改项。比如要禁止“开始”菜单里的查找功能，我们知道修改的内容为：HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer，在右边的窗口中新建一个DWORD值"NoFind"，并设值为1.（查阅本手册即可找到）。那么我们打开注册表修改器，可以看到有HKEY_CURRENT_USER这个根键，左边还有一个"+"号，点击"+"号展开下面的目录树，找到Software,再展开找Microsoft,这样一层一层地展开，直到找到Explorer项，看右边的窗口，你会发现有不少的键值，恭喜你，你快成功了。然后在右边的窗口中单击鼠标右键，选择新建DWORD值，输入NoFind,注意大小写，你会发现右边窗口中多了一个名为NoFind的键名，OK,我们给它赋值，在NoFind上双击，然后在弹出的窗口中将原来默认的0改成1，最后，重新启动计算机后，你会发现开始菜单里的“查找”消失了，如果你想把它改回来，那么按上面的方法，把1改成0,然后重新启动就可以了。是不是很简单？其他的修改也差不多了，关键是要找到修改的内容，这就是本手册所提供的强大功能了。呵呵，相信能给你带来很大的帮助。

二.用专门的修改软件

如果你很懒，不想知道究竟要修改什么内容。那么就用专门的注册表修改软件了，比较有名气的是“超级兔子魔法”，还有“windows优化大师”，在这里评价一下，windows优化大师名字响，可是不好用。我本人比较喜欢的是另外一个叫“注册终结者”的修改器，主要是界面友好，功能多而不容易出错。现在随着winXP的推出，各种修改器也随之更新，可是功能还有待改进。现在新出的“神奇注册表”修改器，可以修改winXP等，大家可以试试看。这些修改器都很容易上手，修改起来很方便。不过你如果想深入学习注册表，最好还是手动修改了，不然你学不到多少东西的了。

三.手工写.reg注册表文件

这是修改注册表的高级技巧了.有没有试过自己写注册表文件？不用任何修改器？直接把写好的注册表文件——.reg倒入注册表？呵呵，这项技巧并不需要每个人都知道了，你只要知道上面的两个就可以了。当然，如果你是电脑迷，我们赞成深入学习。

现在我们来看看.reg文件的结构如何。

.reg文件的标准格式如下：

REGEDIT4

[路径] （注意用大小写）
"键名"="键值" （针对字符串型键值）
"键名"=hex:键值 （针对二进制型键值）
"键名"=dword:键值 （针对DWORD键值）

括号里面的内容为本人的注释，写文件的时候就不需要那些小括号了，其他上面所列的都必须包括。注意引号输入时不能用中文输入的引号，必须用英文的引号，否则会出错。

那么，怎么写.reg文件呢？我们需要一个文本编辑器，用windows的记事本就可以了。单击鼠标右键，选择新建文本文档，然后在生成的文本文件里输入上面规格的内容就可以了，最后，选择另存为，输入你想要的文件名+.reg保存即可。比如你要生成test.reg,输入test.reg保存即可，你可以看到生成了一个带图标的test.reg.双击运行这个test.reg文件就能相应的修改注册表了，系统会提示“是否导入注册表”之类的信息，确定就可以了。OK,我们可以手动写注册表了，是不是感觉很酷？

先别急，我们来看看一个标准范例，这是从注册表里面导出来的，大家慢慢学习，跟着模仿一下就能写出自己的.reg文件了。

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRun"=dword:00000000
"NoRecentDocsMenu"=hex:01,00,00,00
"NoFavoritesMenu"=dword:00000000
"user"="sundrink"

大家可以看到，dword是16进制，hex是二进制，字符串则可以直接赋值。只要将上面的内容复制保存到文本文档里，然后另存为你想要的.reg文件运行就可以了。呵呵，原来也不是很难嘛，耐心一点就可以了。当然，你要模仿，要自己动手写.reg文件，用记事本就可以了。

说多两句，为什么要手写注册表？因为有时候我们会碰到一台锁定regedit的机子，有什么办法解开呢？呵呵，如果你会手写注册表文件的话，那很简单了......大家发挥想象吧!用不了很长时间的。

最后在文章结尾，提醒大家，注册表修改可不是闹着玩的，其中有些键值是不能随便改的，因为如果你没有备份，而又不知道怎么改回来的话，那就麻烦了，我也帮不了你。所以奉劝各位在修改注册表之前一定要记得备份，切记！

作者：姚辉

2002/9/15


初步认识win98注册表

从Windows 95开始，Microsoft在Windows中引入了注册表（英文为REGISTRY）的概念（实际上原来在Windows NT中已有此概念）。注册表是Windows 95及Windows 98的核心数据库，表中存放着各种参数，直接控制着Windows的启动、硬件驱动程序的装载以及一些Windows应用程序运行的正常与否，如果该注册表由于某种原因受到了破坏，轻者使Windows的启动过程出现异常，重者可能会导致整个Windows系统的完全瘫痪。因此正确地认识、修改、及时地备份以及有问题时恢复注册表，对Windows用户来说就显得非常重要了。

切记：在改动注册表前务必进行备份，以防不测。

而当Windows 98不能正常启动时，可在DOS方式下运行Scanreg/Restore，以恢复注册表。 如果你只是想修改系统设置，最好使用专门的工具软件；如果你确实要手工修改注册表，建议在修改前做好备份。如果注册表遭到破坏,Windows将不能正常运行,所以我们必须经常的备份注册表.(其实Windows在每次启动成功时都会备份注册表)。

常用的注册表备份方法和工具很多，大家可以根据个人选择一个。如利用注册表编辑器中的"导出注册表文件"即可导出一份扩展名为.REG的文件. 向大家推荐一个好用的备份工具--Windows光盘上:Other\Misc\ERU\ERU.EXE--紧急事故恢复工具(Emergency Recovery Utility). 如果光盘上没有，在我的网站上有，大家可以去下载。该工具小巧，功能却不错，很实用，可以备份sysytem.ini、win.ini、msodos.sys、System.dat等所有的系统文件。使用方法很简单，运行ERU,选择一路径（默认是A盘）如：C：\ERD备份，以后如需恢复，则在DOS下进入C:\erd目录，运行ERD.EXE,就可完整恢复整个系统配制文件。一点说明，ERU.EXE是备份用的，而ERD则是还原的时候用的。

另外，谈一下整个windows系统备份。因为我们平时安装软件，不用的时候会删除，虽然现在软件基本能反删除，但总是有软件会留些垃圾下来的，所以时间一长，你的windows就越来越庞大了，整个系统的性能下降。

现在的备份软件很多，也很方便，如ghost等，所以还是根据自己的习惯选择。在windows下有两个简单的备份办法：

一是在windows下的dos窗口用xcopy命令，
xcopy c:\windows\*.* c:\winbak/s/e/h/k/y/c,各参数意思大家用xcopy/？理解。这样你的系统就备份在winbak目录下了。注意：该命令需在windows的dos窗口下运行，因为你在纯dos下运行，xcopy或xcopy32将不支持长文件名和h参数下的拷贝隐含和系统文件。

二是打开资源管理器，选择菜单的“查看”→“选项”→“查看”选中“显示所有文件”，也就是说在资源管理器下能查看所有的文件（系统、隐含、只读、等）。好己完成一半了，然后进入windows目录，你会看到所有的文件，然后选定全部所有的文件（ctrl+A)，（是不是有人在笑，这招我早试过，不行），哈，当然这样你复制系统不到一半就会保护性中断，到底是什么原因导致复制中断呢？我们知道windows系统使用临时文件作为虚拟内存，明白了吧，关键在此，这文件是WIN386.SWP，刚才复制到这个文件中断了，下面就简单了，在windows下全选中后，找到WIN386.SWP文件，按住CTRL键同时，用鼠标点一下，结果是除了这文件外别的都选中。然后复制到事先建好一目录下。这样widnows系统备份结束，这是你比较两个目录大小不一样，没关系，因为你没复制WIN386.SWP，所以有差别，这是临时文件，不影响系统完整。下次你要重装系统时只要在纯dos下用ren 命令改两个目录名称就行了。另外有点要注意，我们没备份C盘根目录下的配制文件，最好备份一下，用ERU或手动。别看啰啰唆唆说了一大堆，做起来，两三下就解决。你完成备份后一定要验证一下，不然没有备份完全就死定了。验证方法：在纯DOS下用REN命令改目录名，如：ren windows win,ren winbak windows即可，这里假设winbak是你刚备份的目录。

本人推荐大家用第二种方法，这种方法简单，并且不容易出错，你以后再也不用重装系统了，第一次装好windows后，赶紧备份一个windows复本，这样会节省你的不少保贵时间。当然你要备份整个硬盘还是用专业的软件，如：ghost，不然速度慢。

下面就接触一下注册表，可以在“开始”菜单中，“运行”按钮，键入regedit就可打开注册表，再次强调一下，不要乱改，它是你windows的命根子，改之前一定要备份。

认 识 注 册 表

六大根键的作用

在注册表中，所有的数据都是通过一种树状结构以键和子键的方式组织起来，十分类似于目录结构。每个键都包含了一组特定的信息，每个键的键名都是 和它所包含的信息相关的。如果这个键包含子键，则在注册表编辑器窗口中代表这个键的文件夹的左边将有“＋”符号，以表示在这个文件夹中有更多的内容。如果这个文件夹被用户打开了，那么这个“＋”就会变成“－”。

1.HKEY_USERS

该根键保存了存放在本地计算机口令列表中的用户标识和密码列表。每个用户的预配置信息都存储在 HKEY_USERS 根键中。 HKEY_USERS 是远程计算机中访问的根键之一。

2.HKEY_CURRENT_USER

该根键包含本地工作站中存放的当前登录的用户信息 , 包括用户登录用户名和暂存的密码 ( 注：此密码在输入时是隐藏的 ) 。用户登录 Windows 98 时，其信息从 HKEY_USERS 中相应的项拷贝到 HKEY_CURRENT_USER 中。

3.HKEY_CURRENT_CONFIG

该根键存放着定义当前用户桌面配置 ( 如显示器等 ) 的数据 , 最后使用的文档列表（ MRU ）和其他有关当前用户的 Windows 98 中文版的安装的信息。

4.HKEY_CLASSES_ROOT

包含注册的所有ole信息和文档类型，是从 hkey_local_machine\software\classes复制的。根据在 Windows 98 中文版中安装的应用程序的扩展名 , 该根键指明其文件类型的名称 。

5.HKEY_LOCAL_MACHINE

该根键存放本地计算机硬件数据 , 此根键下的子关键字包括在 SYSTEM.DAT 中 , 用来提供 HKEY_LOCAL_MACHINE 所需的信息 , 或者在远程计算机中可访问的一组键中。

该根键中的许多子键与 System.ini 文件中设置项类似。

6.HKEY_DYN_DATA

该根键存放了系统在运行时动态数据，此数据在每次显示时都是变化的，因此，此根键下的信息没有放在注册表中。

认识键和子键

注册表通过键和子键来管理各种信息。但是，注册表中的所有信息是以各种形式的键值项数据保存下来。在注册表编辑器右窗格中，保存的都是键值项数据。这些键值项数据可分为如下三种类型：

1. 字符串值

在注册表中，字符串值一般用来表示文件的描述、硬件的标识等。通常它由字母和数字组成，最大长度不能超过 255 个字符。比如“ D:\pwin98\trident ”即为键值名“ a ”的键值，它是一种字符串值类型的。同样地，“ ba ”也为键值名“ MRUList ”的键值。通过键值名、键值就可以组成一种键值项数据，这就相当于 Win.ini 、 Ssyt-em.ini 文件中小节下的设置行。其实，使用注册表编辑器将这些键值项数据导出后，其形式与 INI 文件中的设置行完全相同。

2. 二进制值

在注册表中，二进制值是没有长度限制的，可以是任意个字节长。在注册表编辑器中，二进制以十六进制的方式显示出来。比如键值名 Wizard 的键值“ 80 00 00 00 ”就是一个二进制。

3. DWORD 值

DWORD 值是一个 32 位（ 4 个字节，即双字）长度的数值。在注册表编辑器中，您将发现系统会以十六进制的方式显示 DWORD 值。在编辑 DWORD 数值时，可以选择用十进制还是 16 进制的方式进行输入。

另外：对注册表信息的注册和修改,一般由以下几点实现:

安装Win9X时,由安装程序注册系统信息;
安装应用程序时,由安装程序注册该程序的配置信息;
添加新硬件时,由系统即插即用功能监测并注册的信息;
通过控制面板或属性对话框改变系统属性与设置而实现的信息变更;
通过注册表编辑器对信息进行手工修改.


win95/win98注册表修改技巧

Windows 95/98中文版注册表结构

1.注册表Reigstry的层次结构

注册表Reigstry的层次结构类似于硬盘中的目录树,我们可参见图1.2。

┌──────┐
│ 注册表 │
│ Registry │
└──┬───┘
│
│ ┌────┐
├─┤ 根键 │
│ └─┬──┘
│ ┌────┐
├──┤ 子键 │
│ └─┬──┘
│ ┌────┐
├──┤ 子键 │
│ └─┬──┘
│ ┌───┐
├─┤键值项│
│ └───┘
图1.2

表1.1是对图1.2中的Registry层次结构的解释。

表1.1 图1.2中的Registry层次结构的解释

层次

说 明

根键

根键类似于硬盘上的根目录。 Registry有四个预定义的根键：

1.HKEY_LOCAL_MACHINE

2.HKEY_USERS

3.HKEY_CURRENT_USER

4.HKEY_CLASSES_ROOT

键与子键

键和子键类似于文件管理器中看到的目录结构,在键下面是子键,就象目录可以包含子目录一样

键值项

键值项类似硬盘上树型目录的末端文件，键和子键可以包括一个或多个键值项。键值项由键值名、数据类型和键值三部分组成，其格式为：“键值名：数据类型：键值”。

键值类型

Registry中有如下三种键值类型:

  1. DWORD值：只允许一个键值,并且必须为1-8个16进制数据（即双字）。
  2. 字符串值：只允许一个键值,并且作为要存储的字符串来解释。

二进制值：只允许一个值,是16进制数字串,每对作为一个字节值解释。

2.Registry与INI文件之间的关系

Registry与Windows 98中的INI文件有许多相似之处。键或子键类似于INI文件中的小节,一个键值项对应于INI文件中小节里的一条设置项。然而,Registry可以包括子键,而INI文件不支持小节的嵌套。

Registry中的键值项还可以包含可执行代码,而在INI文件中设置项只是简单的字串。

在同一台计算机上有多个用户,Registry可以存储每个用户的特性,而INI文件中却不可能。

如果您在Windows 3.x上升级为Windows 98，则安装程序会从System.ini和Win.ini文件文件中选择一些延续信息放入到注册表中。不过，为了与以前的Windows版本上的老式16位应用程序保持兼容，INI文件中的有些设置项不能迁移到Windows 98的注册表中。有关Win.ini、System.ini文件的结构与设置项信息详见附录A。

1.注册表中Win.ini信息

表1.2列出了Windows 98在升级安装过程中，从Win.ini文件中移出的部分设置项，以及在注册表中的位置。所有的子键都处于注册表的HKEY_CURRENT_USER根键中。

表1.2 注册表中Win.ini信息

小节 | 设置项 | HKEY_CURRENT_USER中的子键分支
[desktop] | GridGranularity | Control Panel\desktop
 | Pattern | Control Panel\desktop
 | TileWallPaper | Control Panel\desktop
[windows] | ScreenSaveActive | Control Panel\desktop
 | ScreenSaveTimeOut | Control Panel\desktop
[Sounds] | Sound Event Name | AppEvents\Schemes\Apps\.Default\Sound Event Name\.current
[Hearts] | Name | Software\Microsoft\Windows\CurrentVersion\Applets\Hearts

2.注册表中的System.ini信息

表1.3列出了Windows 98在升级安装过程中从System.ini文件中移出的设置项，以及在注册表中的位置，这些子键都处于注册表的HKEY_LOCAL_MACHINE根键中。根据机器的网络配置，有些系统可能不会出现某些子键。

表1.3 注册表中的System.ini信息

小节 | 设置项 | HKEY_LOCAL_MACHINE内的子键分支
[Network] | Comment | System\CurrentControlSet\Services\VxD\VNETUP
 | ComputerName | System\CurrentControlSet\Control\ComputerName\ComputerName
 | EnableSharing | 没有子键入口
 | LMAnnounce | System\CurrentControlSet\Services\VxD\VNETUP
 | LogonDomain | 没有子键入口
 | Logon Validated | 没有子键入口
 | MaintainServerList | System\CurrentControlSet\Control\ComputerName\ComputerName
 | Reconnect Reshare | 没有子键入口
 |  | 没有子键入口
 | Username | Network\Logon
 | Workgroup | System\CurrentControlSet\Control\ComputerName\ComputerName
[386Enh] | Network | 没有子键入口
 | Transport | Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net

1.2 注册表Registry的组成

我们知道,在Windows 3.x中,提供了一个注册数据库Reg.dat,它是一个一般二进制文件,它可用Regedit.exe程序来维护。Reg.dat是一个十分软弱的数据文件,在Windows 3.x中增加或删除O LE应用程序时,经常受到不同程度的破坏。

Windows 98改变了Windows 3.x的做法,采用了一种强大的注册表Registry,它要比Reg.dat更为可靠。

3.注册表的文件组成

  注册表Registry由五个文件组成的。介绍如下。

1.系统配置注册表文件System.dat

在Windows 98的系统目录中有一个隐含、系统、只读文件System.dat,它是Windows 98注册表的一部分,该文件具有如下作用:

● 描述单一的PC配置。

● 描述安装在一单独的PC上的消息。

● 安装即插即用类型的设备硬件配置,如设备的I/O地址、IRQ级和DM A通道等。

该文件的作用有点类似Windows 3.x中的System.ini文件。

该文件在Windows 98的网络运行状态时,保存在本地的工作站或本地PC机中。

在Windows 98安装期间,Setup将检查您的计算机上已安装的硬件,然后在System.dat中建立适当的配置项。若从现有的Windows 3.x中安装Windows 98,则Setup将把现有的System.ini、Reg.dat文件中的部分设置项拷贝到System.dat中，详见1.1.3节。

在您使用“控制面板”的“系统”图标查看硬件配置时,其窗口中所显示的选项都是从System.dat中读取的,如图1.3所示。

图1.3

2.系统配置注册表备份文件System.da0

Windows 98的注册表的一个主要特点就是可靠性强,不易损坏。这个特点靠的就是注册表有备份文件。

系统配置注册表System.dat的备份文件为System.da0,该文件在System.dat文件遭到意外破坏时,将由系统自动拷贝为System.dat。

3.用户平台配置注册表文件User.dat

在Windows 98的系统目录中有一个隐含、系统、只读文件User.dat,它也是Windows 98的注册表的一部分,该文件具有如下作用：

● 它定义用户优先权,如用户平台配置等。

● 特定于某一个用户的应用程序的安装信息。

该文件的作为类似于Windows 3.xWin.ini文件。

当您在Windows 98中使用网络时,User.dat必须放在网络服务器上。

在您第一次输入用户标识和密码时,安装程序将把这些信息存储在User.dat中。您的Windows 98的系列号也存储在USER.DAT中。

如果用户在“控制面板”的“密码”图标中选择了“用户可自定义首选项及桌面设置登录时，Windows自动启用个人设置”这个选项后（参见图1.4所示），系统就会为每个用户创建他自己的User.Dat，并且把它保存为C:\Windows\Profiles\用户名\User.dat。用户每次登录后，他自给的User.dat会被调入到系统中。

图1.4

4.用户平台配置注册表备份文件User.da0

用户平台配置注册表文件User.dat也有一个备份文件User.da0。当User.dat遭到意外破坏时,将由系统将User.da0拷贝为User.dat,从而使User.dat得到了恢复。

5.网络管理注册表文件Config.pol

若您在Windows 98安装了“系统策略编辑器”后，则用户可以使用Config.pol文件中的限制来决定系统如修改注册表，也就是说，系统根据Config.pol中的设置对网络用户的操作作一些限制，这种限制在Windows 98被称为“策略”。Config.pol文件也是一个隐含、系统、只读文件，它主要用于Windows 98的网络用户的管理方面的策略。

6.网络管理注册表备份文件Config.po0

同System.dat、User.dat有备份文件一样,Config.pol也有一个备份文件Config.po0,它是一个隐含、系统、只读文件。它存放在网络服务器中。

1.2.2 注册表中的根键

使用注册表编辑器可以观察注册表中的根键，如图1.5所示。

图1.5

注意：在“运行”对话框中输入RegEdit，然后单击“确定”按钮，则可以运行注册表编辑器，详见第2章介绍。

图1.5显示了Windows 98中文版的注册表Registry(System.dat、User.dat、Config.pol)的数据组织结构。

图1.5左窗格显示的是注册表的根键，这样的根键共六个。这些根键都是大写的,并以HKEY_为前缀,这种命令约定是以Win32 API的Registry函数的关键字的符号变量为基础的。

虽然在注册表中，六个根键看上去处于一种并列的地位，彼此毫无关系。但事实上，HKEY_CLASSES_ROOT和HKEY_CURRENT_CONFIG中存放的信息都是HKEY_LOCAL_MACHINE中存放的信息的一部分，而HKEY_CURRENT_USER中存放的信息只是HKEY_USERS存放的信息的一部分。

HKEY_LOCAL_MACHINE包括HKEY_CLASSES_ROOT和HKEY_CURRENT_USER中所有的信息。在每次系统启动后，系统就映射出HKEY_CURRENT_USER中的信息，使得用户可以查看和编辑其中的信息。

实际上，HKEY_LOCAL_MACHINE\SOFTWARE\Classes就是HKEY_CLASSES_ROOT，为了用户便于查看和编辑，系统专门把它作为一个根键。同理，HKEY_CURRENT_CONFIG\SYSTEM\Current Control就是HKEY_LOCAL_MACHINE\SYSTEM\Current Control。

HKEY_USERS中保存了默认用户和当前登录用户的用户信息。HKEY_CURRENT_USER中保存了当前登录用户的用户信息。

HKEY_DYN_DATA保存了系统运行时的动态数据，它反映出系统的当前状态，在每次运行时都是不一样的，即便是在同一台机器上。

根据上面的分析，注册表中的信息可以分为HKEY_LOCAL_MACHINE和HKEY_USERS两大类，这两大类的详细介绍参见第3章。

1.2.3 注册表中的键与子键

在注册表中（参见图1.5所示），所有的数据都是通过一种树状结构以键和子键的方式组织起来，十分类似于目录结构。每个键都包含了一组特定的信息，每个键的键名都是 和它所的信息相关的。如果这个键包含子键，则在注册表编辑器窗口中代表这个键的文件夹的左边将有“＋”符号，以表示在这个文件夹中有更多的内容。如果这个文件夹被用户打开了，那么这个“＋”就会变成“－”，如图1.6所示。

图1.6

1.HKEY_USERS

该根键保存了存放在本地计算机口令列表中的用户标识和密码列表。每个用户的预配置信息都存储在HKEY_USERS根键中。HKEY_USERS是远程计算机中访问的根键之一。图1.7为HKEY_USER子关键字连接情况。

图1.7

2.HKEY_CURRENT_USER

该根键包含本地工作站中存放的当前登录的用户信息,包括用户登录用户名和暂存的密码(注：此密码在输入时是隐藏的)。用户登录Windows 98时,其信息从HKEY_USERS中相应的项拷贝到HKEY_CURRENT_USER中。图1.8为HKEY_CURRENT_USER根键下各个键之间连接的情况。

图1.8

3.HKEY_CURRENT_CONFIG

该根键存放着定义当前用户桌面配置(如显示器等)的数据,以及最后使用的文档列表（MRU）,和其他有关当前用户的Windows 98中文版的安装的信息.

图1.9为HKEY_CURRENT_CONFIG子关键字之间的连接情况。

图1.9

4.HKEY_CLASSES_ROOT

根据在Windows 98中文版中安装的应用程序的扩展名,该根键指明其文件类型的名称。

在第一次安装Windows 98中文版时,RTF(Rich Text Format)文件与写字板(WordPad)联系起来,但在以后安装了中文Word 6.0后,双击一个RTF文件时,将自动激活Word。存放在SYSTEM.DAT中的HKEY_CLASSES_ROOT,将替代WIN.INI文件中的[Extensions]小节中的设置项,它把应用程序与文件扩展名联系起来,它也替代了Windows 3.x中的Reg.dat文件中的相似的设置项。图1.10显示了HKEY_CLASSES_ROOT根键中包括的文件扩展名的情况。

图1.10

5.HKEY_LOCAL_MACHINE

该根键存放本地计算机硬件数据,此根键下的子关键字包括在SYSTEM.DAT中,用来提供HKEY_LOCAL_MACHINE所需的信息,或者在远程计算机中可访问的一组键中。

该根键中的许多子键与System.ini文件中设置项类似。

图1.11显示了HKEY_LOCAL_MACHINE根键下的各个子键之间的情况。

图1.11

6.HKEY_DYN_DATA

该根键存放了系统在运行时动态数据，此数据在每次显示时都是变化的，因此，此根键下的信息没有放在注册表中。图1.12显示了HKEY_DYN_DATA根键下的各个子键的情况。

图1.12

1.2.4 注册表中的键值项数据

注册表通过键和子键来管理各种信息。但是，注册表中的所有信息是以各种形式的键值项数据保存下来。在注册表编辑器右窗格中，保存的都是键值项数据。这些键值项数据可分为如下三种类型：

1.字符串值

在注册表中，字符串值一般用来表示文件的描述、硬件的标识等。通常它由字母和数字组成，最大长度不能超过255个字符。在图1.13所示中，“D:\pwin98\trident”即为键值名“a”的键值，它是一种字符串值类型的。同样地，“ba”也为键值名“MRUList”的键值。通过键值名、键值就可以组成一种键值项数据，这就相当于Win.ini、Ssytem.ini文件中小节下的设置行。其实，使用注册表编辑器将这些键值项数据导出后，其形式与INI文件中的设置行完全相同了。详见第3章。

图1.13

2.二进制值

在注册表中，二进制值是没有长度限制的，可以是任意个字节长。在注册表编辑器中，二进制以十六进制的方式显示出来，如图1.14所示。

图1.14

在图1.14中，键值名Wizard的键值“80 00 00 00”就是一个二进制

注意：在如图1.15所示的“编辑二进制值”对话框时，在编辑框的左边输入十六进制数时，其右边将会显示相应的ASCII码。

图1.15

3.DWORD值

DWORD值是一个32位（4个字节，即双字）长度的数值。在注册表编辑器中，您将
图1.16

发现系统会以十六进制的方式显示DWORD值，如图1.16所示。

注意：在编辑DWORD数值时，可以选择用十进制还是16进制的方式进行输入，如图1.17所示。

图1.17

1.3 注册表的双重入口

在注册表中经常出现双重入口（分支），例如，有一些在HKEY_CLASSES_ROOT中的键同样会在HKEY_LOCAL_MACHINE中出现，如图1.18所示。

图1.18

如果这些相同的分支出现在两个不同的根键中，那么，哪个根键有效呢?

注册表的子键都有严格的组织。如果相同的信息出现在超过一个的子键中，如果您只修改了一个子键，那么该修改是否作用于系统依赖于该子键的等级。一般来说，系统信息优先于用户等级。例如，一个设置项同时出现在HKEY_LOCAL_MACHINE和HKEY_USER子键中，通常由HKEY_LOCAL_MACHINE中的数据起作用。要注意的是，这种情况只发生在您直接编辑注册表时。如果您从“控制面板”中更改系统配置，则所有出现该设置项的地方均会发生相应的改变。

例如，您可以通过注册表设置文件关联，即将一个带有特殊后缀的文件连接到一个应用程序上。在注册表中，有四个子键都保存了文件管理的数据，它们分别是：HKEY_CLASSES_ROOT、HKEY_CURRENT_USER、HKEY_LOCAL_MACHINE、HKEY_USER。在缺省情况下，所有后缀为1ST的文件都被连接到记事本程序（Notepad）上。如果您在Windows资源管理器双击该后缀的文件，则系统将激活记事本，同时将此文件调入编辑。但是您也可此文件关联从Notepad改为Lotus Ami Pro（这也是一个字处理程序），则您在双击后缀为1ST的文件时，将激活Lotus Ami Pro程序，同时编辑此文件。但是，如果您在直接编辑注册表时只修改一个子键，则会出现如下四种情况：

● 如果只修改HKEY_CLASSES_ROOT中的1ST项，则在双击1ST后缀的文件时将激活Lotus Ami Pro。

● 如果只修改HKEY_CURRENT_USER中的1ST项，则在双击1ST后缀的文件时将激活Notepad。

● 如果只修改HKEY_LOCAL_MACHINE中的1ST项，则在双击1ST后缀的文件时将激活Lotus Ami Pro。

● 如果只修改HKEY_USER中的1ST项，则在双击1ST后缀的文件时将激活Notepad。

在上面的例子中，HKEY_CLASSES_ROOT子键和HKEY_LOCAL_MACHINE子键看起来在控制文件关联上相互独立，这似乎有些自相矛盾，但是，要知道HKEY_CLASSES_ROOT根键就是HKEY_LOCAL_MACHINE\Software\Classes，因此，在改变HKEY_CLASSES_ROOT根键就是改变HKEY_LOCAL_MACHINE。


分析工具

一是:tianwei 的 RegShot；

二是:Regsnap 2.6。

这两个都不错。它们可以详细地向你报告注册表及其他与系统有关项目的修改变化情况。 RegSnap 对系统的比较报告非常具体，对注册表可报告修改了哪些键，修改前后的值各是多少；增加和删除了哪些键以及这些键的值。报告结果既可以以纯文本的方式，也可以html网页的方式显示，非常方便。


DOS下维护注册表的高级技巧

  现在随着电脑应用知识的普及，我想，很多朋友对WINDOWS注册表的修改已经有不少经验和心得。在图形界面下对注册表的维护和修改，就不必再提了，但有时候，我们可能会遇到更辣手的事情，如由于人为错误操作或者恶性病毒感染而使系统切底崩溃，不能进入WINDOWS图形界面时，我们对此是否只有重装这种方法呢？本文将就在DOS下面尽量挽救系统这方面作出阐述。

一、使用scanreg/restore

我想这种方法大家也比较熟悉了，只要在DOS界面下输入该命令，就可以在最近的5个注册表备份里恢复，如果幸运的话，系统就可以马上恢复。但，事实上，用这种方法有个致命的缺陷就是你只有最近5天的注册表备份可以选择。因为控制着自动备份的scanreg.exe只会在每天第一次启动电脑时备份，如果哪天你安装的程序或者对注册表的修改比较多，那么你的努力就大多白费了。这种方法就正如是眉毛胡子一起抓，正确和错误的都一起改掉，是否能为恢复系统帮上忙，总有一种听天由命的感觉。所以，笔者鼓励大家使用第二种方法。

二、使用DOS界面的regedit.exe

如果把scanreg/restore比作是一刀切的话，这种方法更像是一次高明的外科手术，只一矢中的地针对病，把错误修复而完全不影响注册表的其他健康部分。这样，我们就能在最大限度上保留我们的工作成果了。使用regedit.exe对注册表实行局部修改的思路是：首先，把注册表里有嫌疑的分支导出；然后，使用edit对它进行分析和修改；最后，把健康的分支重新导入注册表里。好了，我们来看看整个过程的具体操作。

1 导出注册表分支

在DOS下导出注册表分支的命令格式是：Regedit[/L:system] [/R:user] /E filename [regpath1]。/L：system是指定system.dat的路径，/R：user是指定user.dat的路径，如果不说明，系统就会在默认的路径下找；/E：是导出注册表分支的文件名，regpath1是要导出的注册表分支。比如，我们要导出默认注册表关于控制系统启动的分支到test.reg里，命令如下：regedit /e test.reg HKEY－LOCAL－MACHINE\Software\Microsoft\Windows\CurrentVersion\Run。

2 对注册表进行分析、修改

在DOS下面只要运行edit就能对＊.reg文件进行编辑了，因为我们导出的注册表实际上就是文本文件。不过，要正确找出引起错误的地方并修改，需要我们平时对注册表积累的经验。下面，我们看一下它的基本结构，以使我们在对它的修改时可以有的放矢。

我们知道，注册表里面有6个主分支，其中容易引起致命错误而使WINDOWS不能正常启动的分支有： 　　[HKEY_LOCAL_MACHINE]，记录着本地机器的硬件配置以及安装的相应软件，特别是[HKEY－LOCAL－MACHINE\Enum\PCI]这个分支下面的主键值，一旦出错，WINDOWS往往不能启动。如[HKEY－LOCAL－MACHINE\Enum\PCI\VEN_8086＆DEV－7111＆SUBSYS_00000000＆REV－01\BUS_00＆DEV_07＆FUNC－01]记录的是硬盘控制器的详细信息，下面的Logconfig记录着它的各种参数；[HKEY_LOCAL－MACHINE\Enum\PCI\VEN－1002＆DEV－4C42＆SUBSYS_4C421071＆REV－DC\000800]记录的则是显示卡的重要资料和参数，一旦这里出错，往往会导致WINDOWS在启动时黑屏，然后死掉。

另外还有[HKEY－LOCAL－M ACHINE\Software\Microsoft\Windows\CurrentVersion]里记录着WINDOWS当前版本的信息以及启动时执行的程序等，这是病毒最爱攻击和修改的地方。

至于还有[HKEY－CLASS－ROOT]是记录文件种类及其关联信息的，[HKEY－CURRENT－USER]里记录着当前用户的各种信息，包括登陆的密码和各方面的设置等，这些一般不会引起WINDOWS的致命错误，这里也不再详细分析了。

当我们对这些键值分析和修改时，如果碰到什么不清处的地方，可以通过第1点的导出注册表方法，把一些备份注册表的相应分支导出，进行比较。WINDOWS的注册表备份都放在C:\windows\sysbackup里面，如我们要导出第一个注册表备份的[HKEY_LOCAL_MACHINE]分支，那么我们可以先进入该目录，然后键入命令：extract /e rb000.cab ＊.＊，先把system.dat和user.dat解压出来，再键入命令：regedit /L:system.dat /R:user.dat /e backup.reg HKEY－LOCAL－MACHINE。 笔者在这里提醒一下，这是一个很好的解决问题的方法，再用上一些文件比较软件可以很快的找出错误的，请诸位慢慢体会。

3 把修改好的注册表分支重新导入

命令的格式为：regedit /L:system /R:user file1.reg file2.reg。我们一般都要修改默认的注册表文件，所以在实际使用中只需键入：regedit file1.reg就行了。

好了，讲了这么久，我们看看一个具体的案例。

学院机房里的一台机器在重新启动后，无论用正常模式或者安全模式都不能进入WINDOWS界面，表现为启动过程中硬盘突然不读。用SCANDISK检查过硬盘，并没有发现问题。在启动过程中选择生成BOOTLOG.TXT文件，发现启动到硬盘控制器后就断掉了。本来想用scanreg/restore恢复备份的注册表，可是该机器为了加快启动，并没有自动备份。于是，用regedit把[HKEY－LOCAL－MACHINE\Enum\PCI]分支导出，键入：regedit /e hdc.reg HKEY－LOCAL－MACHINE\Enum\PCI；接着用EDIT查看关于硬盘控制器的部分，发现有"ChannelOptions"=hex:00，问题到这里终于发现了，原来是有人把IDE控制器设置成不使用，造成在加载硬盘控制器后，系统不能访问硬盘，所以把它改为：hex:02；再键入命令：regedit hdc.reg，把修改后的信息导入。重新启动机器，一切正常运行了。

这样，在不损坏任何数据的情况下，就把问题解决了。希望这个例子能给大家带来这种DOS下维护注册表技巧的启发，毕竟，我们硬盘上面有很多都是无价的数据。

本文出自《21CN科技中心》

作者：杭州梁俊清

http://sidecity.go.163.com IT认证书库站长


不用重启使注册表修改生效的方法

For win98/me

按下 CTRL + ALT + DELETE, 弹出 Windows 任务列表。高亮选择 "Explorer", 然后单击"结束任务", 如果显示关闭计算机画面, 单击 "取消"。在几秒钟之后, 将会弹出一个错误消息, 单击 "结束任务", Windows 资源管理器将与任何新的注册表设置一起重新加载。

For winNT/2K/XP

按下 Ctrl + Alt + Delete , 然后选择"任务管理器"。选择"进程"标签, 然后定位到 "explorer.exe" 进程, 高亮选择它, 单击"结束进程"。 选择"文件 -> 新任务", 然后输入 "explorer", 单击"确定"。

使用上述方法将不用重新启动计算机而使注册表设置生效。

http://www.happydrips.com


注册表开锁小工具

如果您电脑中的“注册表编辑器”被锁住了，可以选择下载本站制作的几个小文件进行解锁。

1. 恢复“开始”菜单中的“运行”选项

2. 解除“禁止使用注册表编辑器”的限制

说明：如果被隐藏了“运行”选项，请下载文件1并运行，会提示是否“。。。添加到注册表。。”，按“确认”导入注册表文件。

下载并运行文件2解除注册表编辑器限制。

如果系统同时禁止了使用.reg文件，请下载上述文件后，点击文件鼠标右键，在弹出的菜单中选择“打开方式”，选择“regedit.exe”文件执行该下载文件就可成功导入注册表。

下面的文件则相反：

1.1 隐藏“开始”菜单中的“运行”选项

2.2 禁止使用注册表编辑器

下载相应文件并导入注册表就可实现其不同的功能。

上述文件适合所有windows版本，导入后，您可能需要重新启动计算机使设置生效。

http://www.happydrips.com


Windows 启动菜单

Windows 在启动时按下相应的键可实现多制式启动，这些键为：

F4

以原 DOS 启动（适用于 Win 95）

F5
Shift

进入安全模式

F8
Ctrl

显示启动菜单

Shift + F8

逐行提示执行配置文件

Shift + F5

用 Windows 自带的 DOS 7.0 启动

按 F8 或 Ctrl 时将显示如下菜单：

1. Normal

默认，即一般的 Windows 启动

2. Logged (\BOOTLOG.TXT)

同上，但将驱动程序的装入记录入 C:\Bootlog.txt

3. Safe mode

安全模式 同 F5、Shift 键

4. Step-by-step confirmaficn

逐行提示是否执行配置文件 同 Shift + F8

5. Command prompt only

用自带的 DOS 7.0 启动 同 Shift + F5

6. Safe mode command prompt only

跳过配置文件进入 DOS，即安全模式的 DOS

7. Previous version of MS-DOS

以原 DOS 启动（适用于 Win 95） 同 F4

若用户自行改变 MSDOS.SYS 文件的设定，可能上述功能将被屏蔽。

MSDOS.SYS 文件格式

在C:\目录中有一MSDOS.SYS文件，它是用来规定 Windows9x 的各种启动设置，是文本文件。

格式如下：
[PATH] 路径段
WinDir=C:\WINDOWS 说明 Win9x 的所在目录（不能认为改了它就能改Win9x的系统目录，它只是一个简单说明）
WinBootDir=C:\WINDOWS 启动 Win9X 图形界面文件的目录（即Win.COM文件所在目录）
HostWinBootDrv=C 指定系统启动文件的盘符（IO.SYS、COMMAND.COM）

[Options] 选项段（为 1 时启用，为 0 时禁用，下例给出的为推荐设置值）
BootMulti=0 是否设为双重启动（原DOS 6.22 系统应存在，一般只在Win95中使用）
BootWin=1 是否以Win9x启动，同BootMulti一起决定是用DOS还是用Win9x启动系统
BootGUI=1 是否进入 Win9x 的图形界面
DoubleBuffer=1 是否设置双缓冲
AutoScan=1 是否启动时加入自动扫描硬盘程序
BootMenu=0 是否自动显示启动菜单
BootKeys=1 是否使用 F4、F8
BootDelay=n 用一整数设置开机时显示"Starting Windows9x..."的时间，当=0 时F4、F8键失效
BootFailSafe=1 启动出错时用安全模式进入Win9x
Logo=1 是否显示开机画面
WinVer=4.10.1998 Win9x 的版本

还有一些不常用的选项就不例出了，而上述选项也不一定全有，但可手动加入。

在文件后有许多以“;”开始的行，请不要删除，因为该文件要求要大于1024字节，它们是用来充数的。
最后还要注意的一点是该文件是系统文件，不能直接用“记事本”来修改，在保存之前要记得先修改它的文件属性，否则无法保存！


有关 WIN98 启动时的注册表备份

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Run 下添加"ScanRegistry"，值为字符串"C:\Windows\Scanregw.exe /autorun"若不添加这项功能则删除这个串值就可以了。所备份的文件有： system.dat,win.ini,system.ini 及 user.dat .它们备份于 "C:\Windows\BackUp"或"C:\Windows\BAK"目录下。


禁止查找菜单

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个 DWORD 值"NoFind"，并设值为1.


禁止文档菜单

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个 DWORD 值"NoRecentDocsMenu"，并设值为1。


禁止“运行”菜单

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 在右边的窗口中新建一个 DWORD 值“NoRun”，并设值为“1”。


禁止在网络中显示整个网络属性

在 HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Network 下
在右边的窗口中新建 DWORD 值NoEntireNetwork,并设其值为1。


禁止显示开始菜单里的windows升级菜单

禁止显示"开始"菜单中的"windows 升级菜单"

在 HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 下
在右边的窗口中新建一个二进制值NoWindowsUpdate，并设值为1。


禁止出现IE工具栏的internet选项

禁止出现 IE 菜单中工具栏里interner选项

把 c:\windows\system 下的名为 inetcpl.cpl 更名为 inetcpl.old 或则别的名字后就会出现禁止使用的情况
把名字再换回来，就可以恢复使用。


禁止按“取消”登陆系统

在HKEY_LOCAL_MACHINE\Network\Logon下
在右边的窗口中创建一个DOWRD值：“MustBeValidated”，并将其值设为“1”。


禁止使用注册表编辑文件

禁止使用注册表编辑文件 regedit.exe

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\System 下
在右边的窗口中创建一个DOWRD值："DisableRegistryTools"，并将其值设为“1”。


禁止“关闭系统”菜单

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个DWORD值“NoClose”，并设值为“1”。


禁止平滑卷动

禁止 WINDOWS 平滑卷动

HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“SmoothScroll”，设其值为“0”，若允许则设值为“1”。


禁止改变打印机设置

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边窗口中创建DWORD值：“NoPrinters”，并设值为“1”。


禁止出现“点击这里开始”的提示

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个二进制值：“NoStartBanner”，设值为“01 00 00 00”。


禁止 CD-ROM 自动运行

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl

Set\Services\CDRom

在右边的窗口中，把DWORD值“Autorun”改为“0”。“1”表示自动运行。


禁止快速启动

在HKEY_LOCAL_MACHINE\System\CurrentControl

Set\Control\Shutdown下

在右边的窗口中修改一个字符串值：“FastReboot”，并将其值设为“0”。


禁止修改“控制面版”

在HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制"NoSetFolders",并将其值设为"01 00 00 00"。


禁止修改显示属性

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\System
在右边的窗口中创建一个DOWRD值：“NoDispCPL”，并将其值设为“1”。


禁用MS-DOS方式

HKEY_CURRENT_USER\Software\Microsoft\Windows\

CurrentVersion\Policies\Explorer
在该分支下新建主键“WinOlaApp"，然后点击该主键，在右边的窗口中创建一个DWORD值“Disabled"，并设其值为“1”。

键值2:"NoRealMode"=dword:00000001 作用:禁止使用实模式DOS程序


禁止“重新启动计算机切换到 MS-DOS 方式”

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值“NoRealMode”，并设其值为“1”。


禁止 PC 在出错时发出声音

HKEY_CURRENT_USER\Control Panel\Sound
在右边的窗口中，把字符串“Beep”的值改为“No”。


禁止在“显示属性”中出现“屏幕保护程序”这个分菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoDispScrSavPage”，并设其值为“1”。


禁止在“显示属性”中出现“效果，web，设置”这三个分菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoDispSettingsPage”，并设其值为“1”。


禁止在“系统属性”中出现“文件系统”的菜单

禁止在“显示属性”中出现“效果，web，设置”这三个分菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoFileSysPage”，并设其值为“1”。


禁止在“系统属性”中出现“虚拟内存”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoVirtMemPage”，并设其值为“1”。


禁止在“系统属性”中出现“设备管理器”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoDevMgrPage”，并设其值为“1”。


禁止在“系统属性”中出现“硬件配置文件”的菜单

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

Policies\System

在右边的窗口中新建一个DWORD值：“NoConfigPage”，并设其值为“1”。


禁止添加打印机

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoAddPrinter”，并设其值为“1”。


禁止删除打印机

HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoDeletePrinter”，并设其值为“1”。


禁止名称有“快捷方式”四个字

HKEY_CURRENT_USER\Software\Microsoft

\Windows\CurrentVersion\Explorer
在右边的窗口中新建一个二进制值“Link”，并设其值为“00 00 00 00”。


禁止使用任务栏

HKEY_CURRENT_USER\Software\Microsoft

\Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoSetTaskBar”，并设其值为“1”。


禁用“用户”控制面板

在HKEY_USERS\.DEFAULT\Software\Microsoft

\Windows\CurrentVersion\Policies\System
下，在右边的窗口中新建DWORD值“NoProfilePage”，并设其值为“1”。


禁用“密码”控制面板

在HKEY_USERS\.DEFAULT\Software\Microsoft

\Windows\CurrentVersion\Policies\System
下，在右边的窗口中新建DWORD值“NoSecCPL”，并设其值为“1”。


查看安装时输入的 WIN98 密码

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion
点击“ProductKey”，即可看到。


禁止显示"远程管理"

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\System下
在右边的窗口中新建一个DWORD值“NoAdminPage”，并设值为“1”。


禁止显示“注销”菜单

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制值“NoLogOff”，并设值为“01 00 00 00”。


禁止显示“开始”菜单中“收藏夹”菜单

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个值“NoFavoritesMenu”，并设值为“1”。


禁止使用 inf 文件

在HKEY_LOCAL_MACHINE\Software\CLASSES\.inf下
在右边的窗口中更改“默认”值为“txtfile”


禁止使用 reg 文件

在HKEY_LOCAL_MACHINE\Software\CLASSES\.reg下
在右边的窗口中更改“默认”值为“txtfile”


禁止查找用户

在 HKEY_LOCAL_MACHINE\Software\Microsoft

\Windows\CurrentVersion\explorer

\FindExtensions\Static\WabFind

下，删除主键“WabFind”。


隐藏上机用户登录的名字

修改路径：在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Winlogon下

新建 DWORD键值：DontDisplayLastUserName

赋值为 1


禁止使用鼠标右键

在HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建一个二进制值“NoViewContextMenu”，并设值为“01 00 00 00”。
修改后需重新启动WINDOWS，启动后，你将不能在桌面，驱动器，文件夹等地方使用鼠标右键

键值4:"NoTrayContextMenu"=dword:00000001 作用:禁止在任务栏中使用右键菜单


预防 BackDoor 的破坏

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Run 下
若在右边窗口中如发现了Notepad键值，就将它删除。


预防 WinNuke 的破坏

在 HKEY_LOCAL_MACHINE\System\Current

ControlSet\Services\VxD\MSTCP 下
在右边的窗口中新建或修改字符串“BSDUrgent”，设其值为 0。


锁定桌面，防止意外的改动

在HKEY_USERS\DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer加入DWORD值为"1"的 "NoSaveSetting"。但这项功能不是很好用，只能恢复对一些WIN参数的设置，对于文件及文件夹就无能为力了。在HKEY_USERS子树下的设置是对应于当前用户的，若要针对所有用户，则要在HKEY_CURRENT_USER相应的目录下更改。


删除开始菜单中不需要的子项

在HKEY_USERS\DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policie\Explorer 添加相应的DWORD值，其中可以删除的子项有：收藏夹、文档、控制面板、查找、运行、注销、关闭系统及单击从这里开始的活动图标，相应的键为："NoFaroritesMenu"、"NoRecentDocsHistory"、

"NoSetFolders"、"NoFind"、 "NoRun"、"NoLogoff"、"NoClose" 及 "NoStartBanner"，所有的键值均是"1"是有效，"0"无效（即原WINDOWS默认状况）。


隐藏驱动器

在 HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 下新建二进制串值 "NoDrives" 二进制值与相应隐藏的驱动器关系有： "01 00 00 00"为隐藏A驱，"02 00 00 00"为B驱，"04 00 00 00"为C驱，"05 00 00 00"为D驱，隐藏全部的为"FF FF FF FF"。


隐藏我的电脑中的驱动器

隐藏所有驱动器：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“FFFFFFFF”；
隐藏E盘：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“10”；
隐藏D盘：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“8”；
隐藏C盘 ：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“4”。
隐藏A盘 ：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个DWORD值：“NoDrives”，并将其值设为“1”。


关闭活动桌面

在 HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 下新建二进制串"NoActiveDesktop" 改值为"01 00 00 00"。


关闭桌面上显示 WIN98 版本号

在 HKEY_CURRENT_USER\Control Panel\desktop 新建DWORD值"PaintDesktopVersion"="0"。


自动清除或固定文档中的历史记录

在 HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 下新建DWORD值 "ClearRecentDocsOnExit"并设值为"1"。

要固定的话为新建"NoRecentDocsHistory"并设值为"1"。


删除“查找”命令保留在注册表中的搜索结果

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\Doc Find Spec MRU下
删除右边窗口中的键。


防止 CD 的自动播放

在HKEY_LOCAL_MACHINE\Enum\SCSI\MATSHITACD-ROM_CR-588___LMF&CH主键中的AutoInserNotification的值为 00。


禁止AUTORUN,但保留CD的自动播放

禁止 AUTORUN，但保留 CD 的自动播放

在HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer 下将串"NoDriveTypeAutoRun"的值改为 "bd 00 00 00"。


退出不保存设置

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
把二进制值“NoSaveSettings”改为“01 00 00 00”。


不允许改变启动菜单

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下

在右边的窗口中新建一个DWORD值“NoChangeStartMenu”，并设值为“1”。


禁止在“网络”中显示“整个网络”属性

在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\RunMru 中删去不需要的键值即可


为 CDROM 增加 CACHE

WIND9X系统只提供到最大为 8X CDROM的CACHE设置，在 HKEY_LOCAL_MACHINE\System\Current

ControlSet\Control\FileSystem\CDFS中有两个DWORD值"CacheSize"与"Prefetch"若系统设置里为"4倍速或更高倍速"则这两个值为"0000026b"和"000000e4"。"CacheSize"的可认值有："0000026b"、"000004d6"、"000009ac""Prefectch"的值有：4X 000000e4 8X 000001c0 16X 00000380 24X 00000540 32X 00000700 这两项的值视你机子的配置更改。


增加文件系统的 CACHE

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\FS Templates 下有三个主键Desktop、Mobile、Server，分别对应于台式机、便携式、网络服务器三个设置项。对台式机进行设置，更改Desktop主键下的"NameCache"值为"80 00 00 00"（提供128个缓冲文件夹），"PathCache"值为"00 10 00 00"（提供4096个8.3格式的文件名，约占用48KB常规内存）。


清除不要的动态链接库

清除不要的动态链接库 DLL

打开 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\SharedDLLs 主键下，可以删除值为"00 00 00 00"的文件（该值为系统中调用该库的应用程序个数，00为没有应用程序调用，所以可删除）。


更改显示器的刷新速率

更改 HKEY_CURRENT_CONFIG\Display\Settings 下的"ReFreshRate"的值，若要改成85HZ的就改成"85"，小心点不能乱来哟，要考虑到你的显示器是否受得了。


添加控制面板中的组件到开始菜单中

在HKEY_CLASSES_ROOT\CLSID中查找关键字"控制面板"，找到时记下相应的主键值 （本人系统内的键值为{21EC2020-3AEA-1069-A2DD-08002B30309D}）然后在C:\WINDOWS\STARMENU中建立名为"控制面板 {21EC2020-3AEA-1069-A2DD-08002B30309D}"的文件夹即可。


关联文件的多路打开

关联文件的多路打开（以 BMP 文件为例）

在HKEY_CLASSES_ROOT\* 下单击 * 新建主键并命名为"shell"，用右键单击"shell"再新建一主键输入自已喜欢的名字，这里以打开方式为例，再用右键单击"打开方式"新建一主键名为"command"编辑"默认"输入"rundll32.exe shell32.dll,OpenAs_RunDLL %1"，以后有BMP文件时，点击图标用鼠标右键，则在弹出的菜单中会多出一个我们刚建成的"打开方式"，点击它你就会发现用处了。


立即刷新模式

立即刷新模式（免去手动 F5 刷新）

在HKEY_LOCAL_MACHINE\System\Current

ControlSet\Control\Update中将"UpdateMode"改键值为"00"。


删除不完全删除的软件讯息

在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Uninstall 中删去相应的主键即可。


在95（或未安装桌面主题的98）中修改系统快捷方式图标（如回收站、我的电脑等）

在 95（或未安装桌面主题的 98）中修改系

统快捷方式图标（如回收站、我的电脑等）

先到HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID 中，再查找要个修改的图标名字，找到后再选相应的DiaultIcon选项，修改栏中的相应图标的完整路径文件名。


系统级图标的删除

删除HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\Desktop\

NameSpace 中对应的分支主键。


对 WIN98 的改名

在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion 选"Version"项，修改键值为所需即可。


开始菜单使用多页面显示

当程序中的菜单过多时，往往一页显示不出来，这时使用下面的功能实现菜单多页面显示
在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\Advanced下
在右边的窗口中新建字符串值“StartMenuScrollPrograms”，并设值为“false”。
要取消这项功能，只需删除该字符串。


调整双击灵敏度的区域

HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中修改“DoubleClickHeight”和“DoubleClickWidth”的值，即可改变区域大小。


改变菜单的显示速度

HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MenuShowDelay”，其值范围为0-999，0表示最快。


窗口打开、缩小、关闭时是否显示动画过程

HKEY_CURRENT_USER\Control Panel\Desktop
在右边的窗口中新建一个字符串值：“MinAnimate”，数据为“0”表示不显示过程，“1”表示显示。


在“我的电脑”中显示“计划任务”

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\MyComputer\

NameSpace
在该分支下创建一个主键“{D6277990-4C6A-11CF-8D87-00AA0060F5BF}”，在右边的窗口中创建字符串“默认”，设值为“Scheduled Tasks”。


在“我的电脑”中显示“拨号网络”

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\MyComputer\

NameSpace
在此分支下新建一个主键“{992CFFA0-F557-101A-88EC-00DD010CCC48}”，单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为"拨号网络"。


在我的电脑中显示“打印机”

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\MyComputer\

NameSpace
在此分支下新建一个主键“{2227A280-3AEA-1069-A2DE-08002B30309D}”，单击此主键，在右边的窗口中创建一个字符串值：“默认”，并设值为“打印机”。


改变“字体”的目录

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Fonts"的数值为新的目录路径, 如 C:\tt，
记住要把原目录里的文件复制到新的目录。


改变“发送到”的目录

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"SendTo"的数值为新的目录路径, 如 C:\tt，
记住要把原目录里的文件复制到新的目录。


改变“通用文件夹”目录

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion
在右边的窗口中修改字符串"CommonFilesDir"为新的目录路径,如 C:\tt，
记住要把原目录里的文件复制到新的目录。


改变“启动”的目录

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Startup"的数值为新的目录路径, 缺省值为C:\WIN98\Start Menu\Programs\启动
记住要把原目录里的文件复制到新的目录。


更改“网页的历史记录”目录

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"History"的数值为新的目录路径, 如 C:\tt
记住要把原目录里的文件复制到新的目录。


更改我的文档的目录

更改"我的文档"目录

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders
在右边窗口中更改字符串"Personal"的数值为新的目录路径, 如 C:\tt
记住要把原目录里的文件复制到新的目录。


允许强制关闭系统

在我们运行程序的时候，有时会遇到软件程序没反映的现象，于是我们按CTRL+ALT+DEL来关闭系统，
而当我们按下后，系统会叫我们退出前要使软件程序退出，使用本功能可允许强制关闭系统。
在HKEY_USERS\.DEFAULT\Control Panel\desktop下，在右边的窗口中创建一个字符串值：
“AutoEndTasks”，并将其值设为“1”。


优化文件系统

HKEY_LOCAL_MACHINE\System\Current

ControlSet\Control\FileSystem
在右边的窗口中创建一个DWORD值：“ConfigFileAllocSize”，并设为“1f4”。


加快上网速度

以下有几项方法可以改变上网速度：
HKEY_LOCAL_MACHINE\System\Current

ControlSet\Services\VxD\MSTCP
在右边的窗口中把“DefaultRcvWindow”的值改为“6400”，把“DefaultTTL”改为“128”。
HKEY_LOCAL_MACHINE\System\Current

ControlSet\Services\Class\NetTrans
在右边窗口中创建字符串值“MaxMTU”,“MaxMSS”，并设“MaxMTU”为“576”，设“MaxMSS”为“536”。


鼠标自动激活当前窗口

HKEY_USERS\.DEFAULT\Control Panel\desktop
把二进制值“UserPreferencemask”改为“AF 00 00 00”。


改变收藏夹、Cookies、启动、历史记录的路径

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\User Shell Folders下
找到字符串值“Favorites”,并设其值为你想要的下载路径,如C:\WINDOWS\Favorite。
在此窗口中可更改桌面的路径、Cookies的路径、启动的路径、历史记录的路径。


为“回收站”右键菜单中增加“删除”和“重命名”的命令

为“回收站”右键菜单中增加

“删除”和“重命名”的命令

在HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder下
修改右边的窗口中的二近制值"Attributes",设其值为"70 01 00 20"。


修改鼠标右键弹出菜单

我们单击C，D盘，然后点击鼠标右键，会弹出菜单,要把Browse wth ACDSee去掉，打开HKEY_CLASSES_ROOT\Drive\shell
我们可看到有主键Browse with ACDSee，把该主键删除，即可把菜单中的Browse with ACDSee去掉。

在gif类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\GIFFILE\SHELL中，可按上述
方法修改。在cda类型的文件名上点击鼠标右键弹出的菜单在HKEY_CLASSES_ROOT\CDAFILE\SHELL中，
可按上述方法修改。要找某种类型的菜单中，可在HKEY_CALSSES_ROOT\???FILE\SHELL，???代表所
要找的文件类型。


为文件夹的右键菜单添加运行 DOS 的命令

在HKEY_CLASSES_ROOT\Directory\shell下创建一个主键“CommandPrompt”，在右边窗口中把
“默认”的值改为：“Command”（或你喜欢的字符，此字符将显示在右键菜单中）并在此主键
下创建一个主键“command”，在右边窗口中把“默认”的值改为“command.com /k cd "%1"。


增加“关闭系统”的选项

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\

DIRECTORY\SHELL下
新建主键"快速关闭电脑",在右边的窗口中"默认"为"快速关闭电脑"。

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\

DIRECTORY\SHELL\快速关闭电脑下,新建主键"COMMAND"，在右边
的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWS"。


增加“快速启动”的选项

在HKEY_LOCAL_MACHINE\Software\CLASSES\

Directory\shell下
新建主键“快速启动系统”，在右边的窗口中修改“默认”为“快速启动系统”

在HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\

DIRECTORY\SHELL\快速启动系统 下,新建主键"COMMAND"，在右
边的窗口中修改“默认”为"C:\WINDOWS\RUNDLL.EXE USER.EXE,EXITWINDOWSEXEC"。


减少鼠标右键菜单中“新建”菜单的长度

      当我们使用了系统一段时间，装了很多的程序，常常会造成鼠标右键菜单中“新建”菜单的长度增加，
      这时，我们想减轻“新建”菜单的负担，我们可以修改注册表，现举例说明：

      如修改注册表前右键“新建”菜单如图一

图一

如果我们想删除右键菜单中的一些目，首先，我们要知道欲删除的这个项目新建的是什么类型的文件，如"WinZip File"新建的文件的扩展名是.zip,要删除“新建”菜单中的“WinZip File”，我们可以运行注册表编辑器，然后查找“.zip”，找到.zip这个主键后我们发现它的下面还有名称为“ShellNew”的主键，把这个键删除后，即可删除“新建”菜单中的“WinZip File”，删除后的效果如图二

图二


重排输入法

依次展开 HKEY_CURRENT_USER\Keyboard layout\Preload ，在其下可以见到键名从数字 1 开始依次递增的多个子键名称，具体子键个数与系统已安装的输入法种数相一一对应。现假如要将子键名为“ 2 ”所对应的输入法与子键名为“ 5 ”所对应的输入法互换，即将子键名“ 5 ”所对应的输入法前移至第二位，方法如下：右击子键“ 2 ”选“重命名”将子键“ 2 ”改名为“ 22 ”或其它不存在之名称，接着将子键“ 5 ”重命名为“ 2 ”，最后将子键“ 22 ”改名为“ 5 ”。您可以将所有输入法按自已的需要重新排序。


增加 IE 的默认字符串

在 HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\UrlTemplate 下新建字符串值如，名字只要是数字即可，串值如，想让IE默认的后缀名为".edu.cn"则设串值为"www.%s.com.cn"。


更改IE的缓冲的路径

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows

\CurrentVersion\Explorer\User Shell Folders下
更改“Cache”的路径即可。


改变下载的路径

在HKEY_USERS\.DEFAULT\Software\Microsoft\Internet Explorer下
在右边的窗口中新建DWORD值“Download Directory”,并设其值为你想要的下载路径,如C:\My Documents。


网址 URL 的调整

我们在使用IE上网时输入的网址，会在注册表里面留下一些记录，记录着你输入过那些网址，当你下次再
输入该网址时，只需输入几个字母，IE就会自动的输入完整的网址，大大方便了我们，在以下的方法中，
我们可以手动的在WINDOWS的注册表中增加一些网址URL，使上网时更方便。
依次展开在HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs下
在右边的窗口中按url1、url2、url3......顺序排列着一些URL,修改，增加，删除这些url的值
即可达到修改，增加，删除URL的功能。


显示“频道栏”

在HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main下
在右边的窗口中修改字符串"Show_ChannelBand"为"yes"。


禁止 IE 显示“工具”中“INTERNET 选项”

在HKEY_CURRENT_USER\Software\Microsoft\Windows

\CurrentVersion\Policies\Explorer下

在右边的窗口中新建一个二进制值“NoFolderOptions”，

并设值为“01 00 00 00”。


禁止IE下载

修改hkey_users\.default(可改为特定的用户名)\software\macrosoft\

windows\currenversion\internet settings\zones\3\1803下的0x00000000(0) 改为0x00000003(3)


禁止IE访问硬盘资源

在[HKEY_current_user\software\microsoft\

windows\currentversion\policies\explorer]下新建\"NoRun\"=dword:00000001即可禁止ie访问硬盘资源。
同时屏蔽开始菜单的“运行”项。


禁止使用代理服务器

代理服务器的用途很大，比如可以使原来只能国内站点的电脑，在使用代理服务器后，能访问国外站点，
但代理服务器的使用也会带来不利的地方，因此，我们可以通过注册表来禁止使用代理服务器,
在HKEY_LOCAL_MACHINE\Config\0001\Software\Microsoft\windows\CurrentVersion\Internet Settings下
在右边的窗口中新建二进制值“ProxyEnable”的键值为"00 00 00 00"。


在 IE 中禁止显示工具栏

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Internet Explorer\Main下

在右边的窗口中修改字符串“Show_URLToolBar”的键值为"no"。


在 IE 中禁止显示状态栏

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Internet Explorer\Main下

在右边的窗口中修改字符串“Show_StatusBar”的键值为"no"。


改变“超级链接”处点击前后的颜色

在HKEY_CURRENT_USER\Software\Microsoft\

Internet Explorer\Settings下

在右边的窗口中修改“Anchor Color”和“Anchor Color Visited”的值即可修改修改点击前后的颜色。


修改IE5.0的搜索引擎

在注册表中依次展开“HKEY_LOCAL_MACHINE\Software\Microsoft\

Internet Explorer\Search”，在右侧窗口中把“CustomizeSearch”、“SearchAssistant”改为我们定义的搜索引擎，如http://www.chinayancheng.net/，以后当我们每次点IE5.0的搜索引擎时，即可自动调出我们定义的搜索引擎，如上面设定的中国盐城。


清理IE网址列表

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs

在右边的窗口中删除想要删除的网址。


一台机子多个IP

一台机子（WIN98 系统下）多个 IP

先打开注册表编辑器，在 HKEY_LOCAL_MACHINE\System\CurrentControlSet \ServicesClass\NetTrans 这个目录下的几个目录（如000，001，002，003什么的是用于存储协议安装的情况），寻找主键 DriverDesc ，找到它的键值为"TCP/IP"的那个目录，修改该目录下的 IPAdress 和 IPMask 的两键。
例： 原 IPAdress 键值为 "210.34.50.16"
IPMask 键值为 "255.255.255.0"
则可以修改为：IPAdress 键值为 "210.34.50.16,210.34.50.253"
IPMask 键值为 "255.255.255.0,255.255.255.0"
表示你的机子同时拥有两个IP地址： 210.34.50.16 与 210.34.50.253
这种方法也可用于多个IP，只要在键值里多加一个逗号再加入下一个IP及网关IP就可以了。


更改IE图标

更改 Internet Explorer 的图标

在 HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{871C5380-42A0-1069-A2EA-08002B30309D}\DefaultIcon
下，在右边的窗口中修改字符串值(默认)为新图标的路径，如：C:\w.ico,0。


更改Internet Explorer的标题

在HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main下在右边的窗口中修改字符串值“Window Title”为新标题的名字。


禁用“网络”控制面板

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Network\System
下，在右边的窗口中新建DWORD值“NoNetSetup”，并设其值为“1”。


巧解 IE 的分级审查口令

首先备份注册表文件，然后通过运行regedit来打开注册表。定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows\CurrentVersion\Policies\Ratings
用鼠标选中右半窗口里的名称记录，按下Del键进行删除。退出注册表，然后重新启动，就可以解开分级审查的口令了。


更改Outlook Express 信箱存放路径

如果我们想修改Outlook Express 信箱存放路径，可以在HKEY_CURRENT_USER\Identities\{4C44D002-7BCF-11D3-9957-AB53DA238B0C}\Software\Microsoft\Outlook Express\5.0下修改“Store Root”字符串值为要修改的路径。


禁止使用网上邻居

在 HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边窗口中创建DWORD值“NoNetHood”，并设为“1”。


禁止在"控制面板"中显示"网络"属性

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer下
在右边的窗口中新建DWORD值“NoNetSetup",并设其值为“1”。


禁止在“网络”中显示“标识”属性

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Network下
在右边的窗口中新建DWORD值“NoNetSetupIDPage”,并设其值为“1”。


禁止在“网络”中显示“整个网络”属性

在HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Network下
在右边的窗口中新建DWORD值“NoEntireNetwork”,并设其值为“1”。


禁止打印机和文件夹共享

路径:[HKEY_CURRENT_USER\Software\Microsoft

\Windows\CurrentVersion\Policies\Networkr]

键值"NoPrintSharingControl"=dword:00000001

作用:禁止打印机共享

键值"NoFileSharingControl"=dword:00000001

作用:禁止文件共享


清理访问“网络邻居”后留下的字句信息

在HEKY_CURRENT_USER/Network/Recent下
删除下面的主键。


更改记事本的默认字体

在 HKEY_LOCAL_MACHINE\Config 下修改


启动时的问候信息

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Winlogon 下新建军字符串，"LegalNoticCaption"的值设为 "问候"，"LegalNoticeText"="Welcome You!"。


开始菜单使用多页面显示

在程序中的菜单过多时，往往一页显示不出来，这时使用下面的功能实现菜单多页面显示
在 HKEY_LOCAL_MACHINE\Software\Microsoft

\Windows\CurrentVersion\explorer\Advanced 下
在右边的窗口中新建字符串值StartMenuScrollPrograms，并设值为false。
要取消这项功能，只需删除该字符串。


更改“打开的文件夹”的图标

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\Shell Icons
下，在右边的窗口中新建字符串值"4",并设其值为新图标的路径。


更改软盘的图标

更改 3 寸软盘的图标

在 HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\explorer\Shell Icons
下，在右边的窗口中新建字符串值"6",并设其值为新图标的路径。


回收站改名、改图标

给回收站改名、改图标

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E} 在右边的窗口中找到字符串值：默认，把回收站改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon 在右边的窗口中修改图标的路径。


给我的电脑改名、改图标

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D} 在右边的窗口中找到字符串值：默认，把我的电脑改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon 在右边的窗口中修改图标的路径


给我的文档改名、改图标

在右边的窗口中找到字符串值：默认，把我的文档改为其它名称。
HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\DefaultIcon 在右边的窗口中修改图标的路径。


给“控制面板”改名、改图标

在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}下 在右边的窗口中修改字符串值“(默认)”为新的名称 改图标:在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}\DefaultIcon下 在右边的窗口中修改字符串值“(默认)”为新图标的路径。


更改"我的公文包"的图标

在 HKEY_LOCAL_MACHINE\Software\CLASSES

\CLSID\{85BBD920-42A0-1069-A2E4-08002B30309D}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。


更改“计划任务”的图标

在HKEY_LOCAL_MACHINE\Software\CLASSES\

CLSID\{D6277990-4C6A-11CF-8D87-

00AA0060F5BF}\DefaultIcon 下，在右边的窗口中修改字符串值“(默认)”为新图标的路径。


关闭一点活动子菜单随鼠标弹出（使等待时间为最长）

关闭一点活动子菜单随鼠标弹出

（使等待时间为最长）

在 HKEY_USERS\.DEFAULT\Control Panel\desktop下添加DWORD值"MenuShowDelay"，并设为十进制"65534"。


固定窗口的大小

在 HKEY_USERS\.DEFAULT\Control Panel\desktop\WindowMetrics 下添加DWORD值，当该值为"0"时为不可变化，为"1"时为可变大小的。


删除快捷方式的图标中的箭头

删除HKEY_CLASSES_ROOT\piffile键下的主键"Inshortcut"与 HKEY_CLASSES_ROOT\lnkfile键下的主键"Inshortcut"。


制定任意窗口的颜色

在 HKEY_CURRENT_USERS\Control Panel\Colors中选所想制定的窗口，再将键值改为所需的RGB值。不过在 HKEY_CURRENT_USER子树下的设置均为对所有用户桌面，若想只修改当前用户设置的话应该更改 HKEY_USER\.Default下相应的设置，如只改变当前用户桌面的窗口颜色，刚在HKEY_USER\.Default\Control Panel\Colors下更改。（下同）
如：将非活动窗口的颜色改为红的话，则选"InactiveTilte"改值为"255 0 0"。


改变窗口的动感效果

在 HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics中新建串值"Minanimat"与"Maxanimat"并设值为"0"，为"1"时在窗口最大最小化切换时有递变的效果。


在任务栏上加入信息

在 HKEY_CURRENT_USER\Control Panel\International 下新建字符串值 "sTimeFormat"="HH：MM：SS TT"，"s1159"="HI!"，"s2359"="Hello!"。则在 12：00前显示"HI！"，后显示"HELLO！"。


改变图标大小

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon Size”，改变其值即改变图标大小，缺省值为“32”。


高彩色显示图标

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
在右边的窗口中找到字符串值：“Shell Icon BPP”，并设其值为“16”。


设立缺省的用户名和公司名称

HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info
在右边窗口中找到字符串值：“DefCompany”，“DefName”，DefCompany是指公司名称，
DefName是指用户名。


改变WINDOWS有关文件的安装路径

HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Setup
在右边的窗口中，有“BootHost”、“BootDir”、“SourcePath”、“MediaPath”.....
改变其数据内容，就可改变相关文件的路径。


禁止磁盘空间不足时的警告

我们在安装软件的过程中，往往不能预料软件需要使用多大的磁盘空间，当空间不够的时候，
就会弹出一个空间不足的警告框，使用以下方法就是避免出现这个对话框
逐渐展开到HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Control\FileSystem下
在右边的窗口中新建一个二进制值“DisableLowDiskSpaceBroadcast”，并设值为“FF FF FF FF”，
如果想恢复出现这个警告框，只需删除此键。


禁止光标闪动

在HKEY_USERS\.DEFAULT\Control Panel\desktop下
在右边的窗口中创建一个字符串值：“CursorBlinkRate”，并将其值设为“-1”。


禁止显示提示

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Explorer\Advanced
“ShowInfoTip”，并设其值为“0”。


以12小时制显示时间

HKEY_USERS\.DEFAULT\Control Panel\International
在右边的窗口中找到字符串值：“sTimeFormat”，改其值为“h:mm tt”。


自动运行光碟

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中创建一个二进制值：“NoDriveTypeAutoRun”，并将其值设为“b5 00 00 00”。


更改outlook express的标题

在HKEY_USERS\.DEFAULT\Software\

Microsoft\Outlook Express下
在右边的窗口中修改字符串值“WindowTitle”为新的标题名字。


在桌面上显示 WINDOWS 版本标志

HKEY_USERS\.DEFAULT\Control Panel\desktop
在右边的窗口中新建一个字符串值：“PaintDesktopVersion”，并设其值为“1”。


禁止在桌面上显示图标

HKEY_USERS\.DEFAULT\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer
在右边的窗口中新建一个DWORD值：“NoDestop”，并设其值为“1”。


开机时自动登录系统

在HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Winlogon下 在右边的窗口中创建字符串值：“AutoAdminLogon”，并将其值设为“1”； 还创建字符串值“DefaultPassword”，其值为登录时的密码，创建字符串值：“DefaultUserName”，其值为登录时所用的用户名。


修改IE右上角的图标

将IE浏览器右上角的图标换成自己的图标，步骤如下：首先制作一个32*32大小的BMP图片，并放置在C根目录下。接着进入注册表编辑器，找到"HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main"，里面有"SmallBitmap"，将它的内容改成"c:XXX.bmp"，再次启动IE后，你就会看见右上角的图标已经改变了。


把IE中自动保存的网页密码去掉

有时候一不小心，让IE把邮箱的用户名和密码记录下来了怎办？

在HKEY_USERS\.default\software\microsoft\Internet Explore\Intelliforms\spw下

把相应的键值删除就可以了。（注意：.default可以为相应的用户名）


非常特殊的IE全屏幕模式

我们都知道，在IE里只要按下F11就可以快速切换到全屏幕模式，但是我们所说的全屏幕模式则指是一个不包括工具列、状态栏等的纯全屏模式。要达到这种效果，在支持IE时需加上一个参数，为了操作方便，可以建立一个快捷方式，在命令行里输入："C:/Program Files/Microsoft Internet/IEXPLORE.EXE" -k，以后只要双击这个快捷就可以打开一个全屏幕的IE。


在IE中打印出最佳效果

常常会碰上某些网页的背景是黑色或深色，此时如果打印的话，就会是漆黑一片，修改IE中的设置，以获得最佳的打印效果，选择工具--Internet选项--高级，去除"打印背景颜色和图片"前的复选框，现在遇上黑色背景的网页你也不用怕了。


“红心接龙”游戏作弊



“红心接龙”游戏作弊

在HKEY_USERS\.DEFAULT\Software\Microsoft\Windows

\CurrentVersion\Applets\Hearts下

在右边窗口中新建字符串"zb"，设其值为"42"。


禁止使用任务栏

HKEY_CURRENT_USER\Software\Microsoft\Windows\

CurrentVersion\Policies\Explorer下在右边的窗口中新建一个DWORD值：“NoSetTaskBar”，并设其值为“1”。

此条技巧的作用是当我们在系统的任务栏上点击鼠标右键，再选择“属性”时，将会出现以下的提示信息：

“本次操作由于这台计算机的限制而被取消。请与你的系统管理员联系”。


隐藏快捷方式的小箭头

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\

CurrentVersion\Explorer\Shell Icons

在右边的窗口中新建字符串值：“29”，设置其值为:%WINDIR%\SYSTEM\docprop.dll,1”。


把快捷方式的小箭头更改为其它图标

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\

CurrentVersion\explorer\Shell Icons

新建或修改字符串"29",设置其值为你的图标路径。


为快捷方式的图标加上小箭头

去掉了小箭头，怎么办，别急，按以下办法可以做上

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\

CurrentVersion\explorer\Shell Icons

在右边窗口中删除字符串"29"。


直接显示图片内容

HKEY_CLASSES_ROOT\Paint. Picture\DefaultIcon

在右边的窗口中，找到字符串“默认”，修改值为“%1”。


隐藏“文档”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRecentDocsMenu”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 NoRecentDocsMenu”键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


隐藏“查找”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoFind”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 NoFind键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


隐藏“运行”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRun”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将NoRun键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


隐藏“注销”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoLogOff”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将NoLogOff键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


去掉“设置”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoSetFolders”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将NoSetFolders键值设为“1”，最后单击“确定”按钮并重新启动系统即可


隐藏“关闭系统”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoClose”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将NoClose键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


自动清除“文档”菜单内容

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“ClearRecentDocsOnExit”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 ClearRecentDocsOnExit键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


删除桌面上的系统图标

当你想删除桌面上的“回收站”、“Internet Explorer”等系统设定的图标时，会发现它们不能用一般的方法删除。这时你可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows\CurrentVersion\Explorer\Desktop\

NameSpace分支，在该分支下面有多个子键，这些子键对应桌面上的“系统”图标，在右边窗口你可以看到，如“Internet Explorer”等。要删除不需要的图标，只须删除对应的键值，再重新启动系统即可。


去掉“网上邻居”图标

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoNetHood”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将NoNetHood键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


隐藏指定的驱动器

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoDrives”的数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。在接下来弹出的DWORD值编辑器对话框的“基数”分组框中选择“十进制”单选钮，在“数据”编辑框中输入你要隐藏的驱动器号并确定，重新启动系统后相应的驱动器即被隐藏。
注意：在这里使用2的N次方（N=1，2，3，……）来代表一个驱动器号，如：A为 1, B为 2, C为 4, D为 8, E为 16, F为 32, G为 64……还有，如果你要隐藏A、B、C三个驱动器，输入7即可，因为7=1＋2＋4。


屏蔽桌面上的特殊项

特殊项包括“我的电脑”，“网上邻居”，“回收站”等。
(1)新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼Explorer＼NoNetHood，修改其值为1，可以屏蔽掉桌面上的“网上邻居”。
(2)新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼Explorer＼NoInternetIcon，修改其值为1，可以屏蔽掉桌面上的“Internet Explorer”。
(3)新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼Explorer＼NoNetConnectDisconnect，修改其值为1，可以屏蔽掉桌面上“网上邻居”快捷菜单中的“映射网络驱动器”和“断开网络驱动器”项。
(4)新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼Explorer＼NoComputersNearMe，修改其值为1，可以屏蔽掉桌面上“网上邻居”里的“邻近的计算机”项。


隐藏文件夹下的内容

如果想隐藏你的文件夹，通过将文件夹的属性设置为“隐藏”是没有用的。只需在文件夹的“查看”菜单中，选择“文件夹选项”单击“查看”选项卡，选择“显示所有的文件和文件夹”项，就可显示出所有具有隐藏属性的文件夹和文件。可以利用类标识符作为文件夹名的文件扩展名。例如我们想保护文件夹c:＼mydata。首先在注册表项HKEY＿CLASSES＿ROOT下找到该文件类型的CLSID，将c:＼mydata的名称修改为“c:＼mydata. {00022603-0000-0000-C000-000000000046}”。此时c:＼mydata的图标就变成了MIDI文件的图标。在资源管理器中双击该图标，系统会报告该MIDI文件内容错误，无法播放(系统将文件夹当做MIDI文件处理了)，因此用户无法进入c:＼mydata，也就无法查看该文件夹下的内容。唯一能够查看文件夹内容的方法是：在命令解释器窗口中，使用CD命令进入到该文件夹。


屏蔽“控制面板”中的指定项目

屏蔽掉“控制面板”中的某些项目，以防止用户进行任意设置。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼

Windows＼CurrentVersion＼Policies＼ Explorer＼DisallowCpl,修改其值为1。然后新建一个注册表项HKEY＿CURRENT＿USER＼Software＼Microsoft＼

Windows＼CurrentVersion＼Policies＼Explorer＼ DisallowCpl，在该项下新建若干个字符串(REG＿SZ)值项，形式为“序号＝控制面板项对应的文件名”。如想屏蔽控制面板中的“显示”和“系统”两项，可以在该项下新建两个值项“1”和“2”，值分别为“desk.cpl?显示项对应的文件)和sysdm.cpl(系统项对应的文件)。重启桌面使更改生效。


指定“控制面板”中显示的项目

在“控制面板”中只显示指定的项目，对于没有指定的项目则不显示。新建一个双字节(REG＿DWORD)类型的值项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼Explore＼RestrictCpl，修改其值为1，然后新建一个注册表项HKEY＿CURRENT＿USER＼Software＼ Microsoft＼Windows＼Current Version＼Policies＼ Explore＼RestrictCpl，在该项下新建若干个字符串(REG＿SZ)值项，形式为“序号＝控制面板项对应的文件名”。如只允许用户使用控制面板中的“显示”和“系统”两项，可以在该项下新建两个值项“1”和“2”，值分别为“desk.cpl”和sysdm.cpl。重启桌面使更改生效。
注意：使用“屏蔽控制面板中的指定项目”和“指定控制面板中显示的项目”都可以定制控制面板中项目的显示，但是这两个方法有可能发生冲突。如果发生冲突，则“屏蔽控制面板中的指定项目”方法优先。


禁用控制面板中的“显示”项

禁止使用“控制面板”中的显示项。虽然该项仍然会出现在“控制面板”中，但是却不能使用。新建一个双字节(REG＿DWORD)的值项HKEY＿CURRENT＿USER＼ Software＼Microsoft＼Windows＼Current Version＼Policies＼System＼NoDispCPL，修改其值为1。这时进入“控制面板”，双击“显示”项，系统会出现一个消息框提示用户不可以进行此操作。


屏蔽“显示”项中的“背景”选项卡

通过屏蔽“背景”选项卡，可以避免用户更改桌面的墙纸。新建一个双字节值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼Current Version＼Policies＼system＼NoDispBackgr oundPage，修改其值为1。重启桌面使更改生效。


禁止“显示”项里的“背景”选项卡

通过禁止“显示”项里的“背景”选项卡，“背景”页中的各个按钮和选择项都变成不可选状态，这样用户将无法更改当前的墙纸和背景。新建一个双字节值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼Current Version＼Policies＼ActiveDesktop＼No ChangingWallPaper，修改其值为1。


屏蔽“显示”项中的“外观”选项卡

新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼Current Version＼Policies＼system＼NoDispAppearancePage，修改其值为1。重启动桌面使更改生效。


屏蔽“打印机”中的“添加打印机”

可以去除“打印机”项中的“添加打印机”，以防止用户任意配置新的打印机。新建一个字符串(REG＿SZ)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼Current Version＼Policies＼Explorer＼NoAddPrinter”，修改其值为1。


禁止用户锁定计算机

用户在Windows安全窗口中(同时按下Ctrl+Alt+DELETE键)可以单击“锁定计算机”键，使用户不能够使用计算机，除非键入用户密码解除锁定。通过修改注册表，可以禁止用户锁定计算机。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼System＼DisableLockWorkstation，修改其值为1。


禁止用户使用“任务管理器”

用户可以使用“任务管理器”对话框来启动和结束本地进程，查看和管理其他计算机上的进程，改变进程的优先级。通过修改注册表，可以禁止用户使用“任务管理器”。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼CurrentVersion＼Policies＼System＼DisableTaskMgr，修改其值为1。


禁止查看指定磁盘驱动器的内容

如果某个磁盘驱动器中存放了重要的数据，不希望用户查看该驱动器的内容，可以使用此方法来禁止察看该驱动器的内容。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼Current Version＼Policies＼Explorer＼NoViewOnDrive。该值项从最低位(第0位)到第25位，共26个字位，分别代表驱动器A到驱动器Z。例如我们想禁止用户使用软盘驱动器A和B，以及驱动器D，可以修改“NoViewOnDrive”的值为“0000000b?第0、1、3位的值为1)。
修改后需要重启桌面使更改生效。这时再进入到“我的电脑”，双击驱动器D，系统会弹出一个消息框，告诉用户不能进行此操作。但是应用程序仍然可以访问被禁止的驱动器。被禁止的驱动器图标并没有被删除，仍然出现在“我的电脑”和“资源管理器”中。


禁止运行命令解释器和批处理文件

通过修改注册表，可以禁止用户使用命令解释器(CMD.exe)和运行批处理文件(.bat文件)。新建一个双字节(REG＿DWORD)执行HKEY＿CURRENT＿USER＼Software＼Policies＼ Microsoft＼Windows＼System＼DisableCMD，修改其值为2，命令解释器和批处理文件都不能被运行。修改其值为1，则只是禁止命令解释器的运行。


禁止使用注册表编辑器

修改注册表是复杂和危险的，所以不希望用户去修改注册表。通过修改注册表，可以禁止用户运行系统提供的两个注册表编辑器。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼

Windows＼CurrentVersion＼Policies＼System＼DisableRegistryTools，修改其值为1。这样，用户就不能启动注册表编辑器了。
注意：使用此功能要小心，最好作个注册表备份，或者准备一个其他的注册表修改工具。因为当你禁止使用注册表编辑器后，就不能再使用该注册表编辑器将值项改回了。


禁止用户更改口令

用户在Windows安全窗口中(同时按下Ctrl+Alt+DELETE键)可以单击“更改密码”按钮来更改用户口令。通过修改注册表，可以禁止用户更改口令。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼CurrentVersion＼Policies＼System＼DisableChangePassword，修改其值为1。这样，Windows安全窗口中的“更改密码”按钮变成了不可选状态，用户无法更改口令。


关闭 Windows 时删除页面文件

您可能想从系统中删除页面文件，以避免其他人看到您的个人数据。这个过程将使 Windows关闭的时间延长，但可以确保这些数据不会保留在计算机中。启动"注册表编辑器"。定位到 HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\

Session Manager\Memory Management，将注册表项 ClearPageFileAtShutdown 设置为 1，以启用它。 关闭"注册表编辑器"并重新启动计算机，以使更改生效。（也适用于winXP）


禁止使用域的组策略

在HKEY_LOCAL_MACHINE\Software\Policies\

Microsoft\Windows\System下新建一 DisableGPO 的dword值，值为1。


禁止在“打印机”项中删除打印机

新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼Current Version＼Policies＼Explorer＼NoDeletePrinter，修改其值为1。这时进入“控制面板”，选定一个打印机，单击鼠标右键，选择快捷菜单中的“删除”，系统会弹出一个消息框，提示用户不能进行删除打印机的操作。


待续

欢迎使用本手册!

手册将不定期更新,请留意本站动态。

http://www.happydrips.com


加速菜单显示

win2000默认的菜单显示效果为"淡入淡出"，在这种菜单显示速度并不明显，所以请先将"淡入淡出效果"改为"滚动效果"。方法先在“显示属性”中的修改标签下将“动画显示菜单和工具提示”右边的"淡入淡出效果"改为"滚动效果"。然后定位到HKEY_CURRENT_USER\Control Panel\Desktop\分支，在右边窗口中双击键值名“Menushowdelay”，将默认的值改为0或比400小的数值即可。


为 “新建”菜单减肥

鼠标右键的快捷菜单中，“新建”菜单的子菜单随着你安装应用程序的增加，会变得越来越长，如果你想为它减肥，可以选择“本地机器上的HKEY_LOCAL_MACHINE”及“本地机器上的HKEY_LOCAL_ROOT”子窗口，选择“查看／搜索项”菜单，然后在查找对话框中输入“shellnew”，并选中“全字匹配”复选框，然后开始查找。找到对应程序项后将下面的shellnew子键删除掉即可。


去掉“Windows Update”菜单

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoCommonGroups”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮,再将NoCommonGroups键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


加快网上邻居（局域网）浏览速度

因为通过网上邻居浏览其它计算机的时候，2000会县搜索自己的共享目录和可作为网络共享的打印机以及计划任务中和网络相关的计划任务，所以导致速度慢。

启动注册表编辑器regedit

找到　HKEY_LOCAL_MACHINE/sofeware/Microsoft/

Windows/CurrentVersion/Explore/RemoteComputer

/NameSpace

删除{2227A280-3AEA-1069-A2DE08002B30309D}（打印机）
删除{D6277990-4C6A-11CF8D87-00AA0060F5BF}（计划任务）
再次打开的时候就会发现速度比以前提高很多了。


让 IE 使用多线程下载

找到HKEY_current_user\Software\Microsoft\

Windows\CurrentVersion\Internet Settings, 加入2个DWORD机码。
首先加入名为MaxConnectionsPerServer的DWORD机码值, 这一项的作用是决定最大同步下载的连线数目，一般来说，5-8个连线数目足够了.
另外，对于HTTP 1.0 Server,可以加入名为MaxConnectionsPer1_0Server的DWORD机码值, 其预设值也是改为最大同步下载的数目.


消除软件显示乱码

选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\System\CurrentControlSet\

Control\fontassoc\Associated CharSet分支。将右边窗口内的“SYMBOL(02)”的键值（这是系统的机内码）改为“NO”即可。


删除多余的配色方案

打开“控制面板”窗口中的“显示”，然后在“显示属性”窗口中选择“外观”选项卡，在“方案”下拉列表框中，你可以看到多种配色方案，你可以删除不需要的方案。方法是选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Control Panel\Appearance\Schemes分支，这时在窗口的右边会出现系统自带的各种配色方案。
将你认为无用的配色方案删除掉，但注意保留“Windows默认”一项即可。


启动后自动登录

如果是在公用机房等环境下，希望用户不需要输入用户名和用户密码就可以注册进入Windows 2000。在注册表项HKEY＿LOCAL＿MACHINE＼SOFTWARE＼Microsoft＼

Windows NT＼Current Version＼Winlogon下创建几个值项。
创建一个双字节(REG＿DWORD)值项AutoAdminLogon。值为1表示启用自动登录功能，值为0或值项不存在表示不使用自动登录功能。修改字符串值项DefaultDomainName的值为默认的域名。如果该机器不在域中，则该值项的值为该计算机的名称。修改字符串值项DefaultUserName的值为默认的用户名。修改字符串值项DefaultPassword的值为默认的口令。重新启动使更改生效。


为何每个盘符都不能正常打开

文件类型的driver被修改，打开注册表，将HKEY_CLASSES_ROOT\Drive\shel的默认值改为none即可。


设定“开始”菜单的“文档”项最大记录数

“开始”菜单的“文档”项在默认情况下，可以最多存放15条记录。通过修改注册表，可以设定“文档”中可以存放的记录数。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Explorer＼MaxRecentDocs，修改其值为新的最大记录数。重启桌面使更改生效。
注意：修改数值并重启桌面后，“文档”中原先的记录会全部丢失。


登陆以后Num Lock键自动打开

在HKEY_CURRENT_USER\Control Panel\Keyboard 修改右边的InitialKeyboardIndicators 的值
0 - all indicators off
1 - Caps Lock on
2 - Num Lock on
4 - Scroll Lock on


regedit.exe的参数

filename 导入 .reg 文件进注册表
/s 导入 .reg 文件进注册表（安静模式）
/e 导出注册表文件（例：regedit /e filename.reg HKEY_LOCAL_MACHINE\SYSTEM）
/L:system 指定 system.dat
/R:user 指定 user.dat
/C 压缩 [文件名] (Windows 98)
还有一些参数也是可以用的，比如/a，但是我尝试后发现功能无非就是上述这些！而且测试参数很容易导致你的注册表加倍庞大，实在是一个很危险的工作。不过也不会导致系统崩溃，大家胆子大的就大胆去try吧！


建立注册DLL和反注册DLL文件的快捷方式

有的程序员经常要注册或者反注册自己写的dll文件，加一个快捷方式会减少自己的工作量：[HKEY_CLASSES_ROOT\dllfile\shell\Unregister]
"Command"="regsvr32 %1 /u"

[HKEY_CLASSES_ROOT\dllfile\shell\Register]
"Command"="regsvr32 %1"
当我们需要注册或者反注册dll时，只要在该dll文件上按下鼠标右键即可！


自动刷新窗口内容

选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\System\Currentcontrolset\

Control\Update分支，在右边窗口中可以看到DWORD型键值 “UpdateMode”。若将它的值设为0，则表示自动刷新；若将它的值设为1，则表示手工刷新，相当于在资源管理器窗口内按“F5”键或者在“查看”菜单中选择“刷新”命令。
    双击该键值，你就可以在“DWORD值编辑器”内设定它的值为“1”或“0”,最后再单击“确定”按钮即可。


更改登陆背景

打开注册表编辑器，定位到HKEY_USERS\.DEFAULT\Control Panel\Desktop分支，在右边窗口中双击键值名“Wallpaper” ，在文本输入框内将默认值“无”改为背景图片文件所在的路径位置既可。


定制“开始”按钮



定制“开始”按钮

如^00100003c^表列出的值项全部位于HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼ CurrentVersion＼Policies＼Explorer注册表项中。默认情况下，这些值项都不存在。


让桌面显示Windows 2000版本号



让桌面显示Windows 2000版本号

通过修改注册表，可以让桌面在右下角显示出Windows的版本号。修改双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Control Panel＼desktop＼ PaintDesktopVersion的值为1。注销后重新登录以使更改生效。


修改系统的注册信息

在“我的电脑”上单击鼠标右键，选择“属性”，在“常规”选项卡中可以看到注册信息。进入注册表项HKEY＿LOCAL＿MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼ CurrentVersion中，修改字符串(REG＿SZ)值项RegisteredOwner和RegisteredOrganization的值。RegisteredOwner值项存放了个人信息，RegisteredOrganization值项存放着组织单位信息。


让“文档”菜单中只显示你常用到的文件

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer分支，再选择“编辑”菜单下的“添加数值”命令，弹出添加数值窗口。在数值名称中输入“NoRecentDocsHistory”，在数据类型下拉列表框中选择“REG_DWORD”，单击“确定”按钮。再将 “NoRecentDocsHistory” 键值设为“1”，最后单击“确定”按钮并重新启动系统即可。


查看“自启动”程序

绝大多数“自启动”程序都是通过注册表加载的，而它们在“开始／程序／启动”菜单中是看不到的。这时，你可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\Run分支查看，也可以删除右边窗口中的一些键值而达到禁止某些程序自启动的目的。


找回丢失的安装密码

如果你不小心将Windows 2000的安装密码弄丢了，找回它的办法是：选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

WindowsNT\CurrentVersion分支，在窗口右边的ProductId键值中，就包含了安装密码的信息。


增加执行文件路径

类似于在DOS中通过Autoexec.bat给执行文件增加path路径，你可以在Windows 2000中通过修改注册表增加执行文件路径。比如要为“C:\Program Files\abc\abc.exe”文件增加路径，可以选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\CurrentVersion\AppPaths分支，在窗口右边新建一个名为“abc.exe”的主键，选择该主键，将其默认值设为“C:\ProgramFiles\abc\abc.exe”；再新建名为“Path”的主键，将其值设为“C:\ProgramFiles\abc"。这样就可以通过在“运行”命令行中键入“abc.exe”或“abc”来运行该程序了。


去掉IE内的分级审查口令

选择“本地机器上的HKEY_LOCAL_MACHINE”子窗口，定位到HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows\Currentversion\Policies\Ratings分支，这里保存的是IE下“Internet属性”对话框的“内容”选项卡中的“分级审查”中的口令，该口令是经过加密的。窗口右边记录该口令有两个键值FileName0和Key，且二进制的“key”键值是加过密的。去掉口令的方法即是将Ratings子键下的这两个键值删除，如果没有口令，这个子键无键值。
下次进入IE，你就可以安全地进入分级审查，并且可以直接跳过输入“旧密码”，加入新密码即可。


改变浏览器标题栏的内容

改变IE浏览器标题栏的内容

在IE浏览器窗口的标题栏中，显示的格式是“WEB页面标题＋IE浏览器标题”。通过修改注册表，可以更换IE浏览器标题栏的字符串。搜索字符串值项Window Title(注意有空格，且分别在HKEY＿CURRENT＿USER和HKEY_LOCAL_MACHINE下个有一个！)，或在相应的位置新建，修改其值为你喜欢的文字，重新启动IE浏览器后，在IE浏览器窗口的标题栏中，显示信息已更改成你修改的文字


给浏览器的工具栏选择背景图案

给IE浏览器的工具栏选择背景图案

通常IE浏览器的工具栏是没有背景图案的，通过注册表我们可以给它加上背景图案。新建一个字符串(REG＿SZ)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Internet Explorer＼ToolBar＼BackBitmap(或者是BackBitmapIE5)，修改其值为某个BMP文件的路径。重新启动IE浏览器后，IE浏览器的工具栏就有了背景图案。


使IE窗口打开后即为最大化

有时在我们使用IE浏览器时，不知道什么原因窗口就变小了，每次重新启动IE都是一个小窗口，即使用“最大化”还是无济于事。其实这是IE所具有的一种“记忆”结果，即下次重新开启的窗口默认是最前一次关闭的状态。要使它重新变大，可进入注册表，依次选择："HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\"在右边删除"Windows_Placement"键。另外，在"HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Old Work-areas"右边的窗口中删除"OldWorkAreaRects"键，关闭注册表，重新启动计算机，连续两次最大化IE（即“最大化”-“最小化”-“最大化”），再次重启IE，就OK了。


禁用更改连接设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Connection Settings的DWORD，然后赋值为: 1


禁用Internet连接向导

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Connwiz Admin Lock的DWORD，然后赋值为: 1


禁用代理服务器设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Proxy的DWORD，然后赋值为: 1


显示有关代理脚本下载失败的出错信息

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Windows\CurrentVersion\

Internet Settings下新建一个名为DisplayScriptDownloadFailureUI的DWORD，然后赋值为: 1


禁用程序选项

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为ProgramsTab的DWORD，然后赋值为: 1s


禁用默认浏览器检查

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Check_If_Default的DWORD，然后赋值为: 1


禁用日历和联系人设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为CalendarContact的DWORD，然后赋值为: 1


禁止邮件设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Messaging的DWORD，然后赋值为: 1


禁用“重置Web设置”功能

在HKEY_LOCAL_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel下新建一个名为ResetWebSettings的DWORD，然后赋值为: 1


禁用高级选项

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为AdvancedTab的DWORD，然后赋值为: 1


禁用内容选项

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为ContentTab的DWORD，然后赋值为: 1


禁用更改分级设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Ratings的DWORD，然后赋值为: 1


禁用更改证书设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Certificates的DWORD，然后赋值为: 1


禁用表单的自动完成功能

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为FormSuggest的DWORD，然后赋值为: 1


禁用自动完成保存密码

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为FormSuggest Passwords的DWORD，然后赋值为: 1


禁用更改高级页设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Advanced的DWORD，然后赋值为1.


禁止更改配置文件助理设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Profiles的DWORD，然后赋值为: 1


禁用连接选项

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为ConnectionsTab的DWORD，然后赋值为: 1


对拨号连接实行“自动检测”

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Windows\CurrentVersion\Internet Settings下新建一个名为DialupAutodetect的DWORD，然后赋值为: 1


禁用缓存自动代理脚本

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Windows\CurrentVersion\Internet Settings下新建一个名为EnableAutoProxyResultCache的DWORD，然后赋值为: 0


禁用安全选项

在 HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为SecurityTab的DWORD，然后赋值为: 1 (0x1)


禁用更改历史纪录设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为History的DWORD，然后赋值为: 1


禁用更改链接颜色

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为links的DWORD，然后赋值为: 1


禁止通过网络访问软盘

为了防止病毒入侵整个网络，导致整个网络处于瘫痪状态，所以我们必须严格管理计算机的输入设备，以断绝病毒的源头，为此就要禁止通过网络访问软盘。设置时，首先单击开始按钮，从弹出的菜单中选择运行命令；随后，程序将弹出一个运行对话框，在该对话框中输入regedit命令，然后在打开的注册表编辑器中依次打开键值[HKEY_LOCAL_MACHINE＼SOFTWARE＼Microsoft＼Windows NT＼CurrentVersion＼Winlogon]，在右边的窗口中看看有没有键值AllocateFloppies，如果没有请创建DWORD值，名字取为AllocateFloppies，把它的值修改为０或１，其中0代表可被域内所有管理员访问，1代表仅可被当地登陆者访问。


禁用更改主页设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为HomePage的DWORD，然后赋值为: 1


禁用更改辅助功能设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Accessibility的DWORD，然后赋值为: 1


禁用更改临时文件的设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Cache的DWORD，然后赋值为: 1


禁用更改颜色设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Colors的DWORD，然后赋值为: 1


禁用更改字体设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Fonts的DWORD，然后赋值为: 1


禁用更改语言设置

在HKEY_LOCAL_USER\Software\Policies\

Microsoft\Internet Explorer\Control Panel下新建一个名为Languages的DWORD，然后赋值为: 1


为“回收站”改名

选择“本地机器上的HKEY_CLASSES_ROOT”子窗口，定位到HKEY_CLASSES_ROOT\CLSID\

{645FF040－5081－101B－9F08－00AA002F954E}分支。双击右边窗口的“回收站”，弹出字符串编辑器，然后在文本输入框内，将“回收站”改为你喜欢的名字如“垃圾筒”并重新启动机器即可。


在汉字后加空格

你可以通过修改注册表，在Windows 2000中文版中实现在汉字后面加上空格的功能，以帮助某些英文排版软件（如PageMaker 6.5等）切词。方法是：选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USERS\Software\Microsoft\

Windows\CurrentVersion分支，在该分支的下一级分支中，你可以看见许多种输入法，如：全拼、智能ABC、郑码等。单击它们之一，如：全拼，你就可以在右边窗口中看到键值名“插空格”，它的值可以为0（表示不插入空格）或1（表示插入空格）,双击“插空格”，把它的键值修改为1即可。对于其它的输入法，如果它们没有“插空格”的键值名，可以新建并把它的键值设为1。


定制资源管理器

如^00100003d^表中的值项位于注册表项HKEY＿CURRENT＿USER＼Software＼Microsoft＼

Windows＼ Current Version＼Policies＼Explorer中。


定制按钮字体颜色

选择“本地机器上的HKEY_CURRENT_USER”子窗口，定位到HKEY_CURRENT_USER\Control Panel\Colors分支，然后双击右边窗口中的“Bottontext”，将它的键值由原来的“0 0 0”改为“255 0 0”（代表红色）。关闭注册表编辑器重新启动系统后，按钮上的字体将显示为红色。


利用注册表删除RealPlayer的操作记录

RealPlayer跟Windwos下的很多软件一样，会记录最近几次操作的文件名称，也就是Recent Files，有时，出于隐私的考虑，我们不希望别人看到我的使用记录，这种情况下，我们就要Cut掉那些记录。
在RealPlayer里面，View-->Preferences对话框有个Recent Clips,那个可以选择1－10，就是选择希望保留的记录数，不可以填入0。现在利用注册表来删除掉那些记录：
HKEY_CLASSES_ROOT\Software\RealNetworks\

RealPlayer\6.0\Preferences（这里面放的就是RealPlayer的基本选项）然后找到一个MostRecentClips的东西，在那里面放的就是RealPlayer的操作记录，你就可以有选择的删除了。
当然还有一种方法是查找你的这个操作文件名。


缩短桌面上"新建"的选项

当你用鼠标右键点击桌面上空白处,选新建时,会弹出建立多种程序文件的菜单，有些你可能并不常用，如Access数据库，你一定想删掉它，缩短菜单。现在就动手吧，打开注册表编辑器，定位到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Explorer\Discardable\

PostSetup\ShellNew，找到适合的文件类型后，删掉整个shellnew分支即可。


禁止用户运行任务管理器

如果要禁止用户运行任务管理器，找到HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System主键下，找到名为DisableTaskManager的子键，将其键值设置为1，注销以后重新登录即可。


禁止用户在控制面板中改变显示模式

如果要禁止用户在控制面板中改变显示模式，找到HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System主键下，找到名为NoDispAppearancePage的子键，将其键值设置为1，注销以后重新登录即可。


禁止用户改变桌面背景和墙纸

如果禁止用户改变桌面背景和墙纸，找到HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System主键下，找到名为NoDispBackgroundPage的子键，将其键值设置为1，注销以后重新登录即可。


隐藏控制面板中的“显示器”设置

如果禁止用户改变桌面背景和墙纸，找到HKEY_CURRENT_USER\Software\Microsoft\Windows
\CurrentVersion\Policies\System主键下，找到名为NoDispBackgroundPage的子键，将其键值设置为1，注销以后重新登录即可。


关闭“显示器”属性中的“屏幕保护程序”标签

如果要“显示器”属性中不会出现“屏幕保护程序”标签，找到HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\System主键下， 找到名为NoDispScrSavPage的子键，将其键值设置为1，注销以后重新登录即可。


禁止远程调用command shell

找到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\W3SVC\Parameters主键下，找到名为SSIEnableCmdDirective的子键，将其键值设置为1，则禁止远程调用command shell。


删除你的网络共享

你可以使用这样的命令net share /d删除你的网络共享，但是那些为了管理而设置的共享就必须通过修改注册表的方法来实现了。找到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Services\LanmanServer\

Parameters主键下，找到名为 AutoShareServer的子键，将其键值设置为0，注销后，重新登录即可。


隐藏前一个登录者的账号名称

当你要登录NT，按下“Ctrl＋Alt＋Delete”键后，系统要求你输入用户名称和密码，WindowsNt缺省会自动将前一个登录者的名称显示在“用户名”框中，若你想隐藏此名称，
在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curre－ntVersion\Winlogon主键下
找到名为“DontDisplayLastUserName”的子键，其键值类型为REG_SZ，将其键值设置为1。
注销以后重新登录即可。


禁止允许未认证的用户进入网络列举域内用户

Windows NT 有这样一个特征，他允许未认证的用户进入网络列举域内用户，如果你要禁止这个功能，这需要在HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Control\LSA 主键下，找到名为RestrictAnonymous的子键，将其键值改为1，注销以后重新登录即可。


禁止RDS的支持

如果您想Windows NT禁止RDS的支持，这需要在
HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\W3SVC\ Parameters\ADCLaunch主键下，分别将 RDSServer.DataFactory 、AdvancedDataFactory 和VbBusObj.VbBusObjCls等三个子键删除。 注销以后重新登录即可。


禁止 CD-ROM 的 AUTORUN 功能

在[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ CDRom]，更改AUTORUN 的键值。 ＂0＂为禁止，"１"为启用


屏蔽资源管理器中文件菜单

在[HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CirrentVersion \ Poliicies \ Explorer]，增加 DWORD 值"NOFileMenu", 赋值"0"为 Disabled（屏蔽）,"1"为 Enabled（启用）.


在浏览器列表中隐藏服务器

在[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ LanmanServer \ Parameters，增加 DWORD 值"Hidden",并赋值为"1".


禁用 Windows NT "安全策略窗口"中锁定工作站

禁用 Windows NT "安全策略窗口"

中锁定工作站

在[HKEY_LOCAL_MACHINE_MACHINE \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ System]，增加 DWORD 的值"DisabledLockWorkstation" , 赋值为"1".


禁止用户密码保存在其本地的机器上

在:[HKEY_LOCAL_MACHINE \ Software \ Windows \ CurrentVersion \Policies \ Network]，增加 DWORD 的值"DisablePwdCaching" , 赋值为 "1 "。


限制 CD-ROM 的共享

在:[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ WindowsNT \ CurrentVersion \ Policies \ Network]，增加二进制值"AllocateCDRoms", 健值为"0"不共享，健值为"1" 本地用户有效.


Windows NT 有效密码的设置

在:[HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ Network]，增加 DWORD 值"Alphan-umPwds" 赋值为"1"。以后系统密码就不能为"空"了，必须是数字或字母或它们的混合。


禁止短的文件扩展名

在:HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\FileSystem，增加 DWORD 值Win95TruncatedExtensions， 赋值为"1"，可防止运行'del *.htm'连'*.html'也被删除


允许异步执行登陆脚本

在：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows NT\CurrentVersion\Winlogon RunLogonScriptSync(DWORD)=1


禁止任务栏的上下文菜单

在：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer

新建dword值NoTrayContextMenu，值为1。


禁止桌面及浏览器内的上下文菜单

在：HKEY_CURRENT_USER\Software\Microsoft\

Windows\CurrentVersion\Policies\Explorer

新建dword值NoViewContextMenu，值为1


快速运行屏幕保护程序

如果您想通过点击某个快捷方式立即运行一个屏幕保护程序的话，找到HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows主键下，找到名为Programs的子键，将其键值设置为scr，注销后重新登录到Windows NT，在资源管理器中选择想要运行的屏幕保护程序，创建一个快捷方式，并且加参数/S，其中/S参数表示立即运行此屏幕保护程序即可。


删除登陆和退出系统时的LOGON画面

您想让进入WINDOWS NT后以及退出系统前的那个LOGON画面不再出现。找到HKEY_LOCAL_MACHINE\Software\

Windows NT\Winlogon主键下，找到名为“Windows NT Auto Logon”的子键，键值类型为REG SZ，将其键值改成“0”，另外，在同一主键下找到名为“ShutdownWithoutLogon”的子键，将其键值改成“1”，重新启动时您就会发现登陆和退出系统时的LOGON画面不见了。


自动登录

在一般的情况下，你必须自己输入用户名称与密码，才可登录Window NT网络，如果你想在启动时，自动以某用户名称与密码登录的功能，而不需要手工输入。
找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows NT\Curre-ntVersion\Winlogon主键下，
找到名为“AutoAdminLogon”的子键，键值类型为“REG_SZ”，将其键值设置为１。然后在同一主键下找到“DefaultDom-ainName”的子键，将其键值设置为所要登录域名称或本机计算机名称，例如“Admin”域或“cwm”计算机。还是在同一主键下找到名为“DefaultUserName”的子键，将其键值设置为输入登录的用户名称，例如“chenweiming”，然后单击“确定”按钮。最后还是在同一主键下找到名为“DefaultPassword”的子键，键值类型为“REG_SZ”，在其键值下输入用户的密码，然后单击“确定”按钮。
注销后重新登录，就不需要手工输入用户名称与密码了。


自动关闭电源

在关闭系统后WINDOWS NT并不会自动关闭电源，（对于ATX电源）这似乎也是一个缺憾，其实只要作一个小小的改动，它同样可以完成这项工作。首先在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

WindowsNT\CurrentVersion\Winlogon主键下，找到名为“PowerdownAfter Shutdown”子键，键值类型为DWORD，并将其值改成“1”，确定后重新启动即可。


改变特定打印机的缺省假脱机打印目录

如果您要改变特定打印机的缺省假脱机打印目录：找到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Print\Printers主键下，找到名为SpoolDirectory的子键。键值类型为REG_SZ，将其键值设置为您需要的新目录的路径，注销以后重新登录即可。


改变所有打印机的缺省假脱机打印目录

如果您要改变所有打印机的缺省假脱机打印目录，找到在HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Print\Printers键值下选择DefaultSpoolDirectory的子键，键值类型为REG_SZ，将其键值设置为您需要的新目录的路径，注销以后重新登录即可。


让NT4.0关机时能够自动关闭ATX的电源

NT最令人头疼的就是关机。如今我们大家的机箱电源都是ATX结构的，但NT 4.0却偏偏不支持ATX的电源管理。每回关机时都要按一下电源开关。一是麻烦，二是机箱不是白买了吗?没关系，Microsoft早已想到了这一点。在SP4(SP5、SP6)中包含了一个名为HAL.DLL.SOFTEX的文件可以解决这个问题。我们先把WINNT\SYSTEM32\目录下的HAL.DLL改名为HAL.DLL.OLD。并且把HAL.DLL.SOFTEX拷贝到该目录下，并改名为HAL.DLL。光这些还不行，还要修改一下注册表(REGEDIT.EXE)：进到键HKEY_LOCAL_MACHINE\Software\Microsoft\

Windows NT\CurrentVersion\Winlogon，如果存在值PowerdownAfterShutdown，则将其值改为"1"。如果不存在，则按类型REG_SZ添加一个，并设其值为"1"。最后关闭注册表编辑器，重新启动计算机。
这里还要注意一下，如果修改HAL.DLL后，再安装Service Pack则会报错:电源管理程序与之不兼容。解决方法是:把HAL.DLL改名为HAL.DLL.NEW，把HAL.DLL.OLD改名为HAL.DLL，再进行安装。安装完后，将其改回。


修改分区上磁盘空间不足的告警(For NT 4.0)

缺省情况下，当分区的磁盘空间小于10％时，Windows NT将提出警告，但可以修改告警的磁盘用量百分比。
(1)启动注册表编辑器(REGEDIT.EXE)。
(2)进到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\LanmanServer\Parameters。
(3)如果存在值DiskSpaceThreshold，则修改这个值。如果不存在则按DWORD Value创建该值。
(4)设置base为decimal，输入一个值(0－99)。（如让分区的磁盘空间小于5％时，Windows NT提出警告，则设其值为“5" 。）
(5)关闭注册表编辑器，重新启动计算机。


配置NotePad为自动换行方式

缺省情况下，NotePad为不自动换行，可以利用修改注册表方法来修改这个缺省。

(1)启动注册表编辑器(REGEDIT.EXE)。
(2)进到HKEY_CURRENT_USER\Software\Microsoft\NotePad。
(3)修改Wrap值为1。
(4)关闭注册表编辑器，重新启动计算机。


使Dr.Watson失效(For NT 4.0)

Dr.Watson在程序崩溃时显示。但有时很讨厌。如果需要取消，可使用注册表编辑器：进到HKEY－LOCAL－MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\AUTO，将其设置为0。
要使Dr.Watson生效，键入“drwtsn32 －i"命令。


提高调制解调器连接到Internet的性能

缺省情况下，NT使用一个大小为576的Maximum Transmission Unit（最大传输单元，MTU，即数据包的大小）向远程主机发送信息。如果数据经过的路由不可处理如此大的数据包，而将数据包分为若干碎片传输，则可能出现问题。
可以修改注册表，强制NT寻找所有连接中具有最大MTU的连接。
    (1)启动注册表编辑器(REGEDIT.EXE)。
    (2)进到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\Tcpip\Parameters。
    (3)创建EnablePMTUDiscovery(DWORD Value)，并设其值为1。
    (4)关闭注册表编辑器，重新启动计算机。
通过搜索不同路径中的MTU并将TCP段限制为该MTU大小，路径上连接不同MTUs的路由器中TCP数据包的碎片将减少。数据包的碎片化将极大地降低TCP的传输性能并造成网络拥塞。


清除在成功登录系统后的对话窗口

在[HKEY_LOCAL_MACHINE \ Network \ Logon]，增加 DWORD 值"DomainLogonMessage"，赋值"1"为Enabled(清除对话窗口),"0"为Disabled(不清除对话窗口).


启用关闭系统"自动关闭任务"功能

在[HKEY_CURRENT_USER \ Control Panel \ Desktop]，修改＂AutoEndTasks＂的DWORD值为１．也可以在 "WaitToKillAppTimeout" 下设置自动结束的时间，默认为 "20000".


解决*.html和*.htm文件扩展名的问题

在[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Policies \Explorer]，修改 "Win95TruncatedExtensions" 的健值为"0".


禁止保存文件上次更新时间(可提高系统性能)

禁止保存文件上次更新时间

(可提高系统性能)

在:HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\FileSystem，增加 DWORD 值NtfsDisableLastAccessUpdate，赋值为"1"。


允许自动关闭无响应的应用程序

在:HKEY_USERS\.DEFAULT\Control Panel\Desktop,AutoEndTasks(字串)=“1”


设定“蓝屏死”时自启动

在:HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\CrashControl,AutoReboot(DWORD)=1


优化二级缓存L2 Cache

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Session Manager\Memory Management SecondLevelDataCache(DWORD)=十进制数(in Kb)


加速文件系统缓冲

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Session Manager\Memory Management 内存 (MB) IoPageLockLimit(DWORD) 32　　　　4096000 64　　　　8192000 128　　　16384000 256+　　65536000


连续文件分配大小

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\FileSystem ContigFileAllocSize(DWORD)＝200(hex)


支持NetWare 4.x服务器

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\MSSYNC\Parameters ，新建dword值Allow4X，值为1，重启后运行DSMN的系统就能正常识别运行在装订仿真模式下的NetWare4.X服务器


登录时恢复连接

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\ControlNetworkProvider，新建dword值Restore Connection，值为1


指定标准因特网数据库路径

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\Tcpip\Parameters ，DatabasePath(字串)=HOST、LMHOSTS、NETWORKS以及PROTOCOLS文件的路径


侦测死锁网关

HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\Tcpip\Parameters， EnableDeadGWDetect(DWORD)=1


在“网上邻居”中隐藏服务器

如果您想Windows NT的“网上邻居”中隐藏服务器，，找到HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\LanmanServer\Parameters主键下，找到名为Hidden的子键，其键值类型为REG_DWORD，将其键值设置为1，注销以后重新登录即可。


移动Windows NT中的Microsoft Mail邮局

要移动Microsoft Mail邮局，首先将其所在目录及所有子目录移动到一个共享权限为完全控制的新目录下，然后打开注册表编辑器，找到HKEY_CURRENT_USER\Software\

Microsoft\Mail\Microsoft Mail主键下，找到名为ServerPath的子键，将其键值值设置为新的路径，注销以后重新登录即可。


删除Windows NT中的Microsoft Mail邮局

要删除Microsoft Mail邮局，找到HKEY_CURRENT_USER\Software\

Microsoft\Mail\Microsoft Mail主键下，删除Microsoft Mail的所有子键，注销以后重新登录即可。


IE 工具栏右上角 IE 活动图标的更改

进入: [ HKEY_CURRENT_USET \ Software \ Microsoft \ Internet Explorer \ Toolbar ]。-》增加字符串-》"SmBrandBitmap",其键值为代换图标的完整路径（如：c:\Program Files \ Common Files \ MicrosoftShared \ Grphflt \ ms.bmp ).<注：该bmp要与原图标大小一致


为 IE 的工具栏添加背景图

进入:[HKEY_CURRENT_USER \ Software \ microsoft \ Internet Explorer \ Toolbar]。-》增加字符串-》“backbitmap",并在键值中指明该文件的完整路径。


更改 IE 的窗口标题

在[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Interner Explorer \ Main]下，增加字符串"WindowTitle"，键值为你想要的文字。


更改 OUTLOOK 的窗口标题

在[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Interner Explorer \ OutLook Express]下增加字符串"WindowTitle"，其键值为你想要的文字。


寻找网络映射列表

网络映射列表在HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\Persistent Connections下。


设定局域网自动断开的时间

在:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Services\LanmanServer\Parameters，增加 DWORD 值Autodisconnect,赋值为设定的分钟数。


慢速网络连接超时设定

在:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows NT\CurrentVersion\Winlogon，增加 DWORD 值SlowLinkTimeOut，赋值为设定的毫秒数，默认2000.


TCP/IP设置

在：HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Services\{Adapter}\Parameters\Tcpip IPAddress=IP地址;SubnetMask=子网掩码;DefaultGateway=默认网关


设置Windows NT启动信息

每次当Windows NT启动时，它都会显示“请按Ctrl+Alt+Delete键来登录”的信息，而你希望用户在按完Ctrl+Alt+Delete键后，画面上自动显示一些你希望用户看到的信息。
找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curr-entVersion\Winlogon主键下，找到名为
“LegalNoticeCaption”的子键，此键值代表的是信息窗口的标题，我们可以输入例如“欢迎信息”。然后在同一主键下找到“LegalNoticeText”的子值，此键值代表的是信息窗口的内容，我们可以输入例如“欢迎您！请使用伟明的电脑。”。
注销后重新登录，就可看到所设置的启动信息。


更改登录时的背景图案

你可以选择登录时的背景图案，也就是设置当启动屏幕上出现“开始登录”对话框，并要求按“Ctrl+Alt+Delete”键以登录Windows NT网络时的背景图案，找到HKEY_USERS\DEFAULT\Control Panel\Desktop主键下，找到名为“Wallpaper”的子键，键值类型为REG SZ，将其键值设置为作背景的位图文件的完整路径及文件名。然后在同一主键下找到找到名为“TileWallpaper”的子键，将其值设置为１。注销后，重新登录时的背景图案已改变。


改变登录时的背景色

如果要改变登录时的背景色，可以在HKEY_USERS\.Default\ControlPanel\Colors主键下，找到找到名为“Background”的子键，其键值默认为“0 128 128”，这三个数值表示的是背景颜色的RGB值，您可以通过修改它来改变背景颜色。


不登录而直接关闭系统

当启动屏幕上出现“开始登录”的对话框时，你必须同时按“Ctrl+Alt+Delete”键，然后输入名称与密码，以便登录Windows NT Server。如果你此时并不想登录而直接关闭系统，你可以更改设置，使其在登录对话框中增加一个“关闭系统”的按钮选项。
找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Curren-tVersion\Winlogon主键下，
找到名为“Shutdown-WithoutLogon”的子键，将其键值设置为１。注销后重新登录，在登录的画面上会多出一个“关闭系统”的按钮。这时候只要你用鼠标单击“关闭系统”按钮，系统就会直接关闭。


关闭NTFS的8.3格式文件识别

如果您要关闭NTFS对8.3格式文件的识别，这需要在HKEY_LOCAL_MACHINE\SYSTEM \Current

ControlSet\ Control\FileSystem主键下，找到名为NtfsDisable8dot3NameCreation的子键，将其键值设置为“1”， 注销以后重新登录即可。


在你的logon对话框中把"Shutdown"按钮移走

如果想在你的logon对话框中把"Shutdown"按钮移走，这需要在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

WindowsNT\Current Version\Winlogon主键下，找到名为 ShutdownWithoutLogon的子键，将其键值改为0，注销以后重新登录即可。


改变登录窗口的提示信息

在:[ HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ WindowsNT \ CurrentVersion \ Winlogon]，增加二进制值"LogonPromt ", 键值为自己想在登录窗口的标题栏上设置些提示信息的内容。


改变登录窗口的提示信息

登录后自动执行程序的重新指定

在:[HKEY_LOCAL_MACHINE \ SOFTWARE \ WindowsNT \ CurrentVersion \ Winlogon]，增加字符串的值"System" , 键值为你想指定执行程序的完整路径以及名称


禁用启动出错时的提示窗口

在:[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Windows]，增加 DWORD 的值"NoPopupsOnBoot " , 键值为：1。


设置是否分析AUTOEXEC.BAT

在:[HKEY_CURRENT_USET \ Software \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon]，增加 DWORD 的值"PanseAutoexec " , 键值为：0（=disable）、1（=Enable）.

括号内为注释。


更改锁定工作站时的延迟时间

在:[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon]，增加 DWORD 的值DcacheMinInterval 键值为：120-86400 （时间单位为秒）。


设定自动检测

在：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows NT\CurrentVersion\Winlogon，增加 DWORD 值SlowLinkDetectEnabled赋值为"1"。


用“TAB”键完成命令行剩余部分

在:HKEY_CURRENT_USER\Software\

Microsoft\Command Processor,增加 DWORD 值CompletionChar,赋值为09


改变压缩的文件及文件夹显示颜色

在:HKEY_CURRENT_USER\Software\Microsoft

\Windows\CurrentVersion\Explorer,AltColor(BINARY)，默认00 00 ff 00


改变命令行状态下的显示颜色

在:HKEY_CURRENT_USER\Software\

Microsoft\Command Processor，建DefaultColor(为DWORD值)，第一个字节是背景色，第二个为前景色


允许16位程序使用独立的虚拟机

在:HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\WOW，DefaultSeparateVDM(字串)=“yes”


用户配置对话框超时

在：HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

Windows NT\CurrentVersion\Winlogon ProfileDlgTimeOut(DWORD)=1到600秒


隐藏回收站

隐藏回收站 ，是指不会显示在桌面及资源管理器里，隐藏并不等于停止这个功能，如使用登录文件更改者请先汇出有关登录文件作备份，登录文件更改 (适用于 Windows XP 家用及商业版本)：
在[开始]-->[运行]-->键入[Regedit]-->[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Explorer]-->[Desktop]-->[NameSpace]，将[{645FF040-5081-101B-9F08-00AA002F954E}]删除便可重新登录后生效。


关闭自动重新启动功能

当 Windows XP 遇到严重问题时便会突然重新启动，按下更改可以取消此功能：
在[开始]-->[运行]-->键入[regedit]-->选[HKEY_LOCAL_MACHINE]-->[SYSTEM]-->[CurrentControlSet]-->[Control]-->[CrashControl]，将[AutoReboot]dword 值更改为[0]，重新启动生效。


删除共享分享及用户活页夹

除正常[我的文件]及[共享文件夹]外，每个用户都会有一个独立的活页夹，按如下设定则只会保留我的活页夹，其余的不会显示出来：
在[开始]-->[运行]-->键入[regedit]-->选[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Explorer]-->[MyComputer]-->[NameSpace]，在[DelegateFolders]下删除[{59031a47-3f72-44a7-89c5-5595fe6b30ee}]项 。


停止“磁盘空间不足”的通知功能

当磁盘驱动器的容量少于 200MB 时 Windows XP 便会发出“磁盘空间不足”的通知，如需停止此功能,可按下程序更改登录文件：
在[开始]-->[运行]-->键入[Regedit]-->[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]，在[Policies]下增加一个项名[Explorer](如果已有就不用增加了)，在[Explorer]增加一个 DWORD 值，[NoLowDiskSpaceChecks]数值资料为[1]= 停止通知，值资料为[0]= 默认值启动通知。


临时关闭登录用户

在[开始]-->[运行]-->键入[regedit]-->[HKEY_LOCAL_MACHINE]--> [SOFTWARE]-->[Microsoft]-->[Windows NT]-->[CurrentVersion]-->[Winlogon]-->[SpecialAccounts]-->[UserList]，增加一个[DWORD]值，[数值名称]为需要关闭用户的登录名称，数值数据为0，如需重开此用户只需将数值数据更改为1即可。


把 管理员Administrator 加回在登录选单内

在[开始]-->[运行]-->键入[regedit]-->[HKEY_LOCAL_MACHINE]--> [SOFTWARE]-->[Microsoft]-->[Windows NT]-->[CurrentVersion]-->[Winlogon]-->[SpecialAccounts]-->在[UserList]增加一个[DWORD]值，数值名称为[Administrator]，数值数据为[1]= 显示，[0]=隐藏。


在我的电脑上隐藏磁盘驱动器

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。
另在[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->[Explorer]-->增加一个 DWORD 值，[NoDrives]的数值数据请使用十进制及如下设定：隐藏 A 盘为[1]，隐藏 B 盘为 A 盘的一倍即[2]，隐藏 C 盘为 B 盘的一倍即[4]，如此类推，如全部隐藏则为[67108863]。


让登录[Regedit]时保持在根目录状态

Windows XP 在打开[Regedit]时会停留在上次使用时的位置，可按下列修改后打开Regedit时便会停在根目录上：
在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Applets]-->[Regedit]-->选择[LastKey]，清除其有关数值数据，然后在左边窗口上的[Regedit]右点鼠标，择选[权限]，在[Administrators 的权限]上全部选[拒绝]。


自动登录 Windows XP

在[开始]-->[运行]-->键入[regedit]-->选 [HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Windows NT]-->[CurrentVersion]-->将[Winlogon]右边窗口的[AutoAdminLogon]数值数据改为[1]及将[DefaultUserName]的数值数据改为[设定自动登录使用者帐户的名称]，另增加一个字符串值[DefaultPassword]数值数据为[设定自动登录使用者帐户的密码]。


修改其它用户的登录文件

在[开始]-->[运行]-->键入[regedit]-->选[HKEY_USERS]，然后按的[文件]-->[加载配置单元]打开[Documents and Settings用户名]的文件夹选[NTUSER.DAT ]（注：[用户名]为需修改登录文件的用户，[NTUSER.DAT ]是隐藏档。）

然后按[开始]后会弹出对话窗口在[项名称]

在框内输入用户名称或任何自定义名称后在[HKEY_USERS]下便多了一个刚才输入[项名称]的文件夹，这个文件夹便是所需修改的用户登录文件，修改完毕后选回刚才输入[项名称]的文件夹，然后选择注册表编辑器的[文件]-->[卸载配置单元]，即可。


禁止在[开始]菜单上显示[运行]选项

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]-->在[Explorer]右窗口增加一个[DWORD]值，[NoRun] 数值资料[1]为隐藏[运行]，[0]为显示[运行]。

另更改：[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]，然后在[Policies]增加一个项名为[Explorer]，在[Explorer]右窗口增加一个[DWORD]值，[NoRun]数值资料：[1]为隐藏[运行]，[0]为显示[运行]，重新登录或启动后生效。


禁止在[开始]菜单上显示用户名称

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]，然后在[Explorer]右窗口增加一个[DWORD]值，[NoUserNameInStartMenu]数值资料[1]为隐藏用户名，[0]为显示用户名。

另更改：[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]，在[Policies]增加一个项名为[Explorer]，在[Explorer]右窗口增加一个[DWORD]值，[NoUserNameInStartMenu]数值资料[1]为隐藏用户名，[0]为显示用户名，重新登录或启动即可。


禁止在[开始]菜单上显示经常使用的程序

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]，在[Explorer]右窗口增加一个[DWORD]值，[NoStartMenuMFUprogramsList]数值资料[1]为隐藏经常使用的程序，[0]为显示经常使用的程序。

另更改：[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]，在[Policies]增加一个项名为[Explorer]，在[Explorer]右窗口增加一个[DWORD]值，[NoStartMenuMFUprogramsList]数值资料[1]为隐藏经常使用的程序，[0]为显示经常使用的程序，重新登录或启动后生效。


禁止在[开始]菜单上显示[所有程序]菜单

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Policies]，在[Explorer]右窗口增加一个[DWORD]值，[NoStartMenuMorePrograms]，数值资料[1]为隐藏[所有程序]菜单，[0]为显示[所有程序]菜单。

另更改：[HKEY_LOCAL_MACHINE]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->在[Policies]增加一个项名为[Explorer]，在[Explorer]右窗口增加一个[DWORD]值，[NoStartMenuMorePrograms]数值资料[1]为隐藏[所有程序]菜单，[0]为显示[所有程序]菜单，重新登录或启动后生效。


关闭桌面上显示WIN98版本号

关闭桌面上显示 WINXP 版本号

在 HKEY_CURRENT_USER\Control Panel\desktop 新建DWORD值"PaintDesktopVersion"="0"。


加快窗口显示速度

我们可以通过修改注册表来改变窗口从任务栏弹出，以及最小化回归任务栏的动作，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics子键分支，在右边的窗口中找到MinAniMate键值，其类型为REG_SZ，默认情况下此健值的值为1，表示打开窗口显示的动画，把它改为0，则禁止动画的显示，接下来从开始菜单中选择“注销”命令，激活刚才所作的修改即可。


修改cpu的二级缓存

在正常情况下，xp会自动识别cpu的二级缓存。但有时xp不会这样做，这样就需要手动优化以改善cpu的性能。
1.运行"regedit";
2.去"[HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Session Manager\Memory Management\SecondLevelDataCache]";
3. 修改他的十进制:
    AMD Duron: 64(kb);
    CeleronA/celeron2:128;
    PII mobile/PIII E(EB)/P4/AMD K6-3/AMD THUNDERBird/Cyrix III:256;
    AMD K6-2/PII/PIII katmai/AMD Athlon:512;
    PII Xeon/PIII Xeon:1024;
4.重启。


优化ntfs文件系统

ntfs的好处不用说了吧，但也有不足。取消更新最后一次磁盘访问，这样对于容量大的分区，会减慢速度。运行“regedit”，在HKEY_LOCAL_MACHINE\SYSTEM\Current

ContolSet\Control\Filesystem)中，加DWORD，数值为1。


卸载无用的动态链接

资源管理器经常在内存中留下无用的动态链接，为了消除这种现象，你可以打开注册表编辑器，设置键值：HKEY_LOCAL_MACHINE\ SOFTWARE \Microsoft\Windows\ CurrentVersion\Explorer
AlwaysUnloadDLL=DWORD: 1将其设为0，这一功能就会被关闭。注意：为了让设置生效，需要重新启动计算机。


修改磁盘缓存以加速xp

磁盘缓存对xp运行起着至关重要的作用，但是默认的I/O页面文件比较保守。所以，对于不同的内存，采用不同的磁盘缓存是比较好的做法。
1.运行 "regedit";
2.去[HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Session Manager\Memory Management\IoPageLockLimit];
3.根据你的内存修改其十六进制值:
    64M: 1000;
    128M: 4000;
    256M: 10000;
    512M或更大: 40000.
4.重启


预读设置以提高速度

xp使用预读设置这一新技术，以提高系统速度。如果你拥有PIII 800, 512M内存以上，推荐一下修改：
1.运行“egedit”
2.去[HKEY_LOCAL_MACHINE\SYSTEM\Current

ControlSet\Control\Session Manager\Memory Management\

PrefetchParameters\EnablePrefetcher];
3.设置数值0，1，2，3。0-Disable,1-预读应用程序,2-启动预读,3-前两者皆预读 ("3"，推荐使用)。
4.重启。
这样可以减少启动时间。


关闭磁盘索引

Xp纪录了所有文件以便快速搜索，如果你不经常查找文件，可将它关闭。
1.打开我的电脑
2.右击驱动器，选“属性”。
3.取消“使用索引以便快速查找文件”。


清除预读文件

当xp使用一段时间后，预读文件夹里的文件会变的很大，里面会有死链文件，这会减慢系统时间。建议，定期删除这些文件。（c:\windows\prefetch）


缩短系统启动时 chkdsk 的等待时间

在不正常关机后重新启动 XP 时会出现 chdsk 来检查系统，但等待响应时间预设为10秒，按下办法更改可设定等待响应的时间：
在[开始]-->[运行]-->键入[regedit]-->选
[HKEY_LOCAL_MACHINE]-->[SYSTEM]-->[CurrentControlSet]-->[Control]-->[Session Manager]，然后更改[AutoChkTimeOut]内的 dword 数值数据：原数值数据为["AutoChkTimeOut"=dword:00000010]，如缩短等待时间为 3 秒者，则更改 "dword" 的数值为3，如此类推。


随时可使用记事本打开文件

当在资源管理器浏览文件时,有时需要用记事本来打开文件，如按下修改可随时点击鼠标右键，便出现“使用记事本打开”的选择 在[开始]-->[运行]-->键入[regedit]-->选[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Classes]-->[*]，在此新增一个[项]，命名为[shell]，在[shell ]下再增加一个[项]，命名为[OpenInNotepad]，在[OpenInNotepad]增加一个字符串值，数值数据为使用记事本打开，再在[OpenInNotepad]下再增加一个[项]，命名为[command]，在[command]增加一个字符串值，数值数据为[notepad.exe "%1"]。


在指定的目录下打开 Command Prompt

在[开始]-->[运行]-->键入[regedit]-->选[HKEY_CLASSES_ROOT]-->[Directory]-->[shell]-->增加一个项[CommandPrompt]默认值为[在 Command Prompt 打开]，再在[CommandPrompt]下增加一个项[command]默认值为[cmd.exe cd %1]，完成后在资源管理器任何文件夹下右点鼠标便会出现[在 Command Prompt 打开]的选项，如不明怎样修改，可以将下面的内容拷入记事本，然后命名这**.reg，最后双击即可：
Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOTDirectoryshell

CommandPrompt]
@="在 Command Prompt 打开"
[HKEY_CLASSES_ROOTDirectoryshell

CommandPromptcommand]
@="cmd.exe cd %1"


加快开机及关机速度

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Control Panel]-->[Desktop]，将字符串值[HungAppTimeout]的数值数据更改为[200],将字符串值[WaitToKillAppTimeout]的数值数据更改为1000.
另外在[HKEY_LOCAL_MACHINE]-->[System]-->[CurrentControlSet]-->[Control]，将字符串值[HungAppTimeout]的数值数据更改为[200]，将字符串值[WaitToKillServiceTimeout]的数值数据更改1000.


自动关闭停止响应程序

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_CURRENT_USER]-->[Control Panel]-->[Desktop]，将字符串值[AutoEndTasks]的数值数据更改为1，重新启动即可。


加快宽带接入速度

（1）家用版本：
在[开始]-->[运行]-->键入[regedit]-->在[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Policies]-->[Microsoft] -->[Windows]，增加一个名为[Psched]的项，在[Psched]右面窗口增加一个 Dword 值[NonBestEffortLimit]数值数据为0。

（2）商业版本：
在[开始]-->[运行]-->键入[gpedit.msc]，打开本地计算机策略，在左边窗口中选取[计算机配置]-->[管理模板]-->[网络]-->[QoS数据包调度程序]，在右边的窗口中双击"限制可保留的带宽"，选择"已启用"并将"带宽限制(%)"设为0应用-->确定，重启动即可。


加快自动刷新率

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_LOCAL_MACHINE]-->[System]-->[CurrentControlSet]-->[Control]-->[Update]，将 Dword[UpdateMode]的数值数据更改为[０]，重新启动即可。


加快预读能力改善开机速度

Windows XP 预读设定可提高系统速度，加快开机速度。按下修改可进一步善用 CPU 的效率：在[开始]-->[运行]-->键入[Regedit]-->[HKEY_LOCAL_MACHINE]-->[SYSTEM]-->[CurrentControlSet]-->[Control]-->[SessionManager]-->[MemoryManagement]，在[PrefetchParameters]右边窗口，将[EnablePrefetcher]的数值数据如下更改，如使用 PIII 800MHz CPU 以上的建议将数值数据更改为4或5，否则建议保留数值数据为默认值即3。


在启动计算机时运行 Defrag 程序

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Dfrg]-->[BootOptimizeFunction ]，将字符串值[Enable]设定为：Y等于开启而设定为N等于关闭。


关机时自动关闭停止响应程序

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_USERS]-->[.DEFAULT]-->[Control Panel]，然后在[Desktop]右面窗口将[AutoEndTasks]的数值数据改为1，注销或重新启动。


修改或个性化IE的标题列

原[Microsoft Internet Explorer]的标题列可根据下列办法更改为个人喜爱的名称，同样如经一些网站非法更改[Internet Explorer ]的标题后也可按此办法还原。修改或个性化 Internet Explorer 的 标题列：
在[开始]-->[运行]-->键入[regedit]——> [HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Internet Explorer]-->[Main],在名称栏中找到[Window Title]，将其数值数据更改为个性化字符串，如果没有[Window Title]，在[名称]内增加一个[字符串值]为[Window Title],[数值数据]="你想要的名字"


彻底删除 Internet Explorer 工具列表上其它图标

彻底删除 Internet Explorer

工具列表上其它图标

在[开始]-->[运行]-->键入[regedit]选[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[InternetExplorer]-->[Extensions]，检查各数字文件夹的内容将不需要的整个文件夹删除便可。


删除 Internet Explorer 工具栏上其它工具项目

删除 Internet Explorer

工具栏上其它工具项目

在[开始]-->[运行]-->键入[regedit]-->[ HKEY_LOCAL_MACHINE]-->[ SOFTWARE]-->[ Microsoft]-->[Internet Explorer]-->[ toolbar]，检查各项内容将不需要的项目删除便可。


重新安装 Internet Explorer

在[开始]-->[运行]-->键入[regedit] --> [HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Active Setup]-->[Installed Components]-->[{89820200-ECBD-11cf-8B85-00AA005B4383} ]，将[IsInstalled]的 DWORD 资料数值改为[0]，这样更改使系统认识IE尚未安装，退出[Regedit]及下载及安装 Internet Explorer。


个性化 Outlook Express 的标题列

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Identities]-->选数字值[xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx]只有这一组，[Software]-->[Microsoft]-->[Outlook Express]-->[5.0]，在右边窗口内容找[WindowTitle]="更改为个性化字符串"如果没有[WindowTitle]-->在[内容]内增加一个[字符串值]为[Window Title],[数值数据]="个性化字符串"，如还原[Outlook Express ] 的默认值则将[WindowTitle ]的整个[字符串值]删除便可。


更改工具列背景

先预备一个Bitmap格式图片，最好使用网页背景用可拼合的图：
在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Internet Explorer]-->在[Toolbar]右边窗口增加一个字符串值名为[BackBitmapIE5]，数值数据为[文件位置及名称 例如 C:Windowsabc.bmp]，重新打开 Internet Explorer 即可。


恢复IE的首页设置

在浏览一些不良网址时可能强将首页的设定更改如无法在 Internet Explorer内修改时可按下修正：
在[开始]-->[运行]-->键入[regedit]-->[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Internet Explorer]-->[Main]，将[Start Page]及[Default_Page_URL](如有) 的数值数据更改为所选首页画面的网址，继续更改[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Internet Explorer]-->[Main]，同样将[Start Page]及[Default_Page_URL](如有) 的数值数据更改为所选首页画面的网址。


让 IE6 可以同时下载超过两个文件

在常规下，Internet Explorer 6 同时最多只可以下载两个文件，通过下面的修改可同时下载多达十个文件：
在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[InternetSettings]，在右边窗口增加下列两个[Dword]值，[MaxConnectionsPer1_0Server]数值数据为[0000000a]即十进制[10]，[MaxConnectionsPerServer]数值数据为[0000000a]即十进制[10]，重新启动即可。


任意定制按钮颜色

尽管Windows XP本身带有多种窗口显示方案，但用户想定义某一个部位的颜色，比如把按钮的颜色由黑色改为蓝色或红色，这时就需要修改注册表了，步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USER\Control Panel\Colors子键分支，双击在它下面的Bottontext，在打开的对话框中将其键值改为你想要颜色的值，比如红色255 0 0，单击“确定”按钮，并重新启动系统即可看到效果了，此时按钮上的文字颜色将变成红色，此外你还可以修改按钮的宽度和高度及背景等参数。


修改鼠标右键菜单

我们知道在98下可以通过注册表来修改鼠标右键菜单，其实在WinXP中也可以。方法如下：这里以在鼠标右键菜单上添加“用DOS窗口在这里浏览”为例。
1)打开注册表编辑器，找到HKEY_CLASSES_ROOT\Directory\shell，然后选中它，点击鼠标右键，新建一个主键，取名为“DOS”，然后选中新建的主键，在右边双击默认字符串值，在弹出的对话框中输入“用DOS窗口在这里浏览”，然后选中新建的主键，再建立一个主键，取名为“command”，选中“command”主键，修改默认值为“cmd.exe /k "cd %L"”即可。
2)检查：在任意一个文件夹上按下鼠标右键，可以在弹出的菜单里面看到“用DOS窗口在这里浏览”，选择用DOS窗口在这里浏览，按下鼠标左键，看到没有，DOS窗口弹了出来！


修改Windows XP的登录背景图案

面对长久不变的单调的登录图案，你可能日久生厌，我们可以通过注册表来把它换成自己喜欢的图案，步骤如下：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Desktop子键分支，双击wallpaper，键入你选择好的图片的路径，如：c:\Documents and Settings\My Documents\My Pictures\mypic.bmp，点击“确定”，然后找到Tilewallpaper，双击它输入键值“1”，重新启动系统即可看到效果。


每次启动时保持桌面设置不变

我们可以通过修改注册表来保护我们的桌面设置，无论做了什么样的修改，只要重新启动之后桌面就会恢复原样。步骤如下：打开注册表编辑器，找到HKEY_CURRENT_USERS\Software\Microsoft\

Windows\CurrentVersion\Polices\Explorer子键分支，在它的下面找到NoSaveSettings，其类型为REG_SZ，将其键值改为“0”，或者直接删除该键值项，重新启动系统使设置生效。


修改登录时的背景色

如果你还想修改登录时的背景颜色，可以按以下步骤操作：打开注册表编辑器，找到HKEY_USERS\.DEFAULT\Control Panel\Colors子键分支，双击子键分支下的Background键值名，出现“编辑字符串”对话框，在“数值数据”文本框中输入代表颜色的键值（比如黑色的RGB值为000，白色的RGB值为255 255 255，系统默认值是58 110 165），点击“确定”按钮，重新启动系统即可。


取消快捷方式图标上的箭头

以前这项功能的实现是比较麻烦的，现在好了，只需要在HKEY_CURRENT_USER\Software\

Microsoft\Windows\CurrentVersion\Explorer,里面新建2进制值Link，并修改为00 00 00 00就可以实现了。 (Smallfrogs )


取消资源管理器和查看图片的关联

在我的电脑和 资源管理器看图时均以Windows 图片及传真查看器为默认值 ，如需取消此项默认值，可按下修改：
在[开始]-->[运行]-->键入[regedit]-->选[HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Classes]-->[CLSID]-->[{e84fda7c-1d6a-45f6-b725-cb260c236066}]-->[shellex]，删除[MayChangeDefaultMenu]的项便可。


更改文件管理器 Thumbnail 的大小

在[开始]-->[运行]-->键入[regedit]-->选择[HKEY_CURRENT_USER]-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Explorer],增加[dword][thumbnailSize]=数值数据，数值在32~256之间（基数为十进制）。


登录画面时打开数字键

在[开始]-->[运行]-->键入[Regedit]-->[HKEY_USERS]-->[.Default]-->[Control Panel]-->[Keyboard]-->将数值名称[InitialKeyboardIndicators]资料值更改为2。


更改winxp注册用户和组织名称

在[开始]-->[运行]-->键入[regedit]-->选 [HKEY_LOCAL_MACHINE]-->[SOFTWARE]-->[Microsoft]-->[Windows NT]-->[CurrentVersion]，然后更改[RegisteredOwner]的资料值为新登记人姓名，更改[RegisteredOrganization]的资料值为新登记组织名称。


隐藏快捷方式图标上的箭头

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CLASSES_ROOT]-->[lnkfile]删除[IsShortcut]一栏，重新启动电脑。


隐藏桌面上图标下文字的底色

在[开始]-->[运行]-->键入[regedit]-->[HKEY_USERS]-->[S-1-5-21-515967899-706699826-1957994488-1005]（注：使用版本不同，此值也不同。）-->[Software]-->[Microsoft]-->[Windows]-->[CurrentVersion]-->[Explorer]-->[Advanced]，将[ShowCompColor]=[dword:00000001]更改为[dword:00000000]，将[ListviewShadow]=[dword:00000000]更改为[dword:00000001]。


隐藏桌面上图标下文字的底色

在桌面上显示系统版本

在[开始]-->[运行]-->键入[regedit]-->[HKEY_CURRENT_USER]-->[Control Panel]-->[Desktop]，将右面窗口的[PaintDesktopVersion]数值资料更改为[1]，重新启动后操作系统的版本便会显示在桌面的右下角。


禁用“文件”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Folders , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“编辑”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Edit , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“收藏”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Favorites , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“工具”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Tools , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“后退”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Back , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“前进”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Forward , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“停止”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Stop , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“刷新”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Refresh , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“主页”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Home , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“搜索”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Search , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“媒体”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Media , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“历史”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_History , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“全屏”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Fullscreen , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“大小”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Size , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“打印”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Print , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“讨论”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Discussions , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“编码”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Encoding , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“打印预览”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_PrintPreview , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“邮件和新闻”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_MailNews , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“转到”按钮

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] 下：

创建一个新的名为 "ShowGoButton" 的字符串值, 设置它的值为 "no" 。

如值为“yes”则允许显示。

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“Internet选项”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为NoBrowserOptions的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“常规”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 GeneralTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“连接”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 ConnectionsTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“安全”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 SecurityTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“程序”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 ProgramsTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“高级”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 AdvancedTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“内容”选项

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 ContentTab 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止更改主页设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 HomePage 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止使用代理服务器

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Proxy 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止IE的分级设置功能

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Ratings 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用临时文件设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Cache 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用历史记录设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 History 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用更改颜色设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Colors 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用更改字体设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Fonts 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用更改语言设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Languages 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用更改辅助功能设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Accessibility 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“重置web设置”功能

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 ResetWebSettings 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用更改证书设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Control Panel 下

新建一个名为 Certificates 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“另存为……”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoBrowserSaveAs 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用另存为“Web页，全部”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoBrowserSaveWebComplete 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用关闭浏览器

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoBrowserClose 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“新建”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoFileNew 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“打开”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoFileOpen 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“剪切”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Cut , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“复制”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Copy , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“粘贴”按钮

隐藏和禁用 Internet Explorer 工具栏上特定的按钮。

打开你的注册表 , 查找下面的主键, 如果不存在, 则创建它。

在 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] 下：

创建一个新的名为 "SpecifyDefaultButtons" 的 DWORD 值, 设置它的值为 "1" ，允许删除按钮。

另外创建一个新的 DWORD 值 Btn_Paste , 设置它的值为 "2"。

参考图片：

备注: 这些设置也可以在 HKEY_LOCAL_MACHINE 根键下面指定, 成为系统级限制。

http://www.happydrips.com


禁用“全屏”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoTheaterMode 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“源文件”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoViewSource 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用自定义工具栏的按钮

在

HKEY_CURRENT_USER\Software\Microsoft\Windows\

CurrentVersion\Policies\Explorer 下

新建一个名为 NoBandCustomize 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用自定义工具栏的按钮

禁用自定义工具栏

在

HKEY_CURRENT_USER\Software\Microsoft\Windows\

CurrentVersion\Policies\Explorer 下

新建一个名为 NoToolbarCustomize 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“收藏”菜单

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoFavorites 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用添加频道

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoAddingChannels 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用添加脱机页计划

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoAddingSubscriptions 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用脱机页记数

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoChannelLogging 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用频道界面

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoChannelUI 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用编辑和创建计划组

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoEditingScheduleGroups 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用编辑脱机页计划

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoEditingSubscriptions 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用删除频道

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoRemovingChannels 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用删除脱机页计划

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoRemovingSubscriptions 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用所有已计划的脱机页

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoScheduledUpdates 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用下载站点预定内容

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoSubscriptionContent 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“Netscape用户”菜单

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoHelpItemNetscapeHelp 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“每日提示”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoHelpItemTipOfTheDay 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“教程”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoHelpItemTutorial 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“发送反馈意见”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions 下

新建一个名为 NoHelpItemSendFeedback 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


更改IE的窗口标题

在

HKEY_CURRENT_USER\Software\Microsof\

Internet Explorer\Main 下

找到“Window Title”，将其数值数据更改为你想要的字符串；如果没有“Window Title”，在[名称]内增加一个[字符串值]为[Window Title],[数值数据]="你想要的名字"

http://www.happydrips.com


注册表实用技术文集

IE奥秘——添加新菜单项（推荐）

本文将介绍如何添加一个菜单项到微软Internet Explorer浏览器的“工具”（Tools）下拉菜单中，这个新添加的菜单项表示运行一个Microsoft Win32应用程序，或者表示运行一个脚本程序。

    需要的基础知识与环境
    如果想在Internet Explorer中准确地完成在“工具”菜单下添加菜单项目的功能，你必须要熟悉注册表的操作。
    而且，这里讨论的方法，要求浏览器是Internet Explorer 版本5 或者更高版本。

    通用步骤
    这一节描述的步骤必须严格执行，如果省略任何一个步骤（除去可选的），最终都不会达到添加菜单项的目的。
    注意：下面描述的添加菜单项的步骤都是针对访问机器的全部用户而言的，如果想为每一个不同用户添加菜单，可以在下面的步骤中用HKEY_CURRENT_USER替换HKEY_LOCAL_MACHINE。
    建立一个正确的全局唯一表示符，即GUID。
    使用上面的GUID，在下面的注册表项目下建立一个新的键值：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    （可选步骤）在下面的注册表项目下，建立一个新的字符串数值 MenuCustomize ：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\\MenuCustomize
    如果需要添加的新菜单项出现在浏览器的“帮助”（HELP）菜单下，就设置MenuCustomize的数值为“help”。如果设置成其他数值，或者根本没有设置MenuCustomize，菜单项将最终出现在“工具”（Tools）菜单下面。
    在下面的注册表项目下，创建一个新的字符串数值 CLSID ：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >\CLSID
    设置CLSID的数值为 {1FBA04EE-3024-11d2-8F1F-0000F87ABD16}。
    在下面的注册表项目下，创建一个新的字符串数值 MenuText ：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >\MenuText
    将MenuText的数值设置为在工具菜单中显示的文字。注意，文字不支持任何为了实现快捷键而需要的下划线。
    （可选步骤） 在下面的注册表项目下，创建一个新的字符串数值 MenuStatusBar ：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\\MenuStatusBar
    MenuStatusBar中设置的文字，表示当菜单项高亮度选中时，在浏览器的状态栏中显示的信息，为了给用户一个明白的意思，请设置文字为该菜单项执行程序或者执行脚本的确切含义。

    添加细节
    完成了上面的初始步骤后，就需要进一步添加键的数值。具体的数值以及下面的其他步骤要依赖于菜单项表示的实际运行程序的类型。下面将讨论可能的几个程序类型及其添加细节：

    COM对象
    下面的步骤将实现在浏览器的“工具”菜单下创建一个执行COM对象的菜单项。同样，如果省略任何一个步骤（除去可选的），最终都不会达到添加菜单项的目的。而且，描述的步骤都是针对访问机器的全部用户而言的，如果想为每一个不同用户添加菜单，可以在下面的步骤中用HKEY_CURRENT_USER替换HKEY_LOCAL_MACHINE。
    注册COM对象。
    在下面的注册表项目下，创建一个新的字符串数值 ClsidExtension ：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >\ClsidExtension
    将ClsidExtension 设置为COM对象的GUID。
    而且，COM对象必须执行IOleCommandTarget。如果COM对象需要访问页面上的DHTML对象模型，就必须执行 IObjectWithSite。

    脚本
    下面的步骤将实现在浏览器的“工具”菜单下创建一个执行脚本程序的菜单项。同样，如果省略任何一个步骤（除去可选的），最终都不会达到添加菜单项的目的。而且，描述的步骤都是针对访问机器的全部用户而言的，如果想为每一个不同用户添加菜单，可以在下面的步骤中用HKEY_CURRENT_USER替换HKEY_LOCAL_MACHINE。
    在下面的注册表项目下，创建一个新的字符串数值 Script :
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >\Script
    设置Script的数值为要运行脚本的全路径。

    执行程序
    下面的步骤将实现在浏览器的“工具”菜单下创建一个执行.exe文件的菜单项。同样，如果省略任何一个步骤（除去可选的），最终都不会达到添加菜单项的目的。而且，描述的步骤都是针对访问机器的全部用户而言的，如果想为每一个不同用户添加菜单，可以在下面的步骤中用HKEY_CURRENT_USER替换HKEY_LOCAL_MACHINE。
    在下面的注册表项目下，创建一个新的字符串数值 Exec :
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >
    建立正确后，就象下面一样：
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Extensions\< Your GUID >\Exec
    设置Script的数值为要运行.exe文件的全路径。


禁用缓存自动代理脚本

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Windows\CurrentVersion\Internet Settings 下

新建一个名为 EnableAutoProxyResultCache 的DWORD，然后赋值为: 0 即可

http://www.happydrips.com


禁止浏览网页时使用鼠标右键

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Restrictions 下

新建一个名为 NoBrowserContextMenu 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“在新窗口打开”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Restrictions 下

新建一个名为 NoOpeninNewWnd 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用“将该程序保存到磁盘”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Restrictions 下

新建一个名为 NoSelectDownloadDir 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用自定义搜索

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoSearchCustomization 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用IE的外部商标

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Restrictions 下

新建一个名为 NoExternalBranding 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用F3的查找功能

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Restrictions 下

新建一个名为 NoFindFiles 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用IE组件自动安装

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoJITSetup 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用显示初始屏幕

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoSplash 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止IE版本升级更新

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Infodelivery\Restrictions 下

新建一个名为 NoUpdateCheck 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止IE下载文件

在

HKEY_CURRENT_USER\Macrosoft\Windows

\CurrentVersion\Internet Settings\Zones\3

下

将1803的初始键值：0x00000000(0)改为0x00000003(3)

http://www.happydrips.com


显示友好的 HTTP 出错信息

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main 下

新建或修改字符串值 Friendly http errors，赋值为: Yes，或者设置为 "No" 禁用

http://www.happydrips.com


更改IE右上角的活动图标

当你使用 Internet Explorer 浏览 Internet 阅读消息时, 显示一个指示是否处于活动状态的 Logo 。使用这个技巧, 你可以修改显示哪一个 Logo, 定制它或者重置它为默认值。

使用你自己的动画 Logo
有两个位图文件用于显示动画 Logo, 除了大小之外, 它们可以是同一个图像, 一个宽度是 38 像素, 而另一个是 22 像素。

使用一个图像编辑器, 例如微软的画笔程序, 创建一个类似于滚动电影胶片的图像, 其中相同大小的"帧"垂直堆叠在一个较大的图像中。例如, 一个大图标, 包含 10 帧, 应该是 38 像素宽度和 380 像素高度(38 像素 x 10 帧 = 380 像素高度)。

当处于活动状态时, Logo 就会动起来, 首先显示顶部的帧, 然后是下一个, 依此类推, 直到到达最后一帧, 图像开始循环。同样, 当应用程序空闲时, 静止显示第一帧, 直到下一次活动状态, 除非已经使用下面的技巧指定了一个可选的非活动 Logo 。

一旦创建了图标, 你需要通过打开注册表中的 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] 主键注册它们。

接下来创建两个新的字符串键值, 或者修改名为 "SmBrandBitmap" 和 "BrandBitmap" 的现有值, 设置它们的键值分别等于小图像(22 像素)和大图像(38 像素)的完整文件名。

使用你自己的非动画 Logo
当应用程序空闲时, 显示这些图像, 和上面的方法一样, 有两个图像, 一个是 22 x 22 像素的小图像, 一个是 38 x 38 像素的大图像。要激活它们, 打开 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] 主键, 创建两个字符串键值, 名称分别为 "SmallBitmap" 和 "BigBitmap", 设置键值分别等于图像的文件名。

重置为默认 Logo
要恢复默认的动画 Logo, 删除在注册表主键 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] 下面找到的 "BrandBitmap" 和 "SmBrandBitmap" 字符串键值。

要恢复默认的空闲 Logo, 删除在注册表主键 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] 下面找到的 "SmallBitmap" 和 "BigBitmap" 字符串键值。

要使更改生效, 重新启动 Internet Explorer 。

参考图片：

http://www.happydrips.com


使IE工具栏显示自定义的背景图片

在

HKEY_CURRENT_USER\Software\

Microsoft\Internet Explorer\Toolbar 下

添加一个新的字符串键值, 或者修改现有的“BackBitmap”(适用于 IE4) 或者"BackBitmapIE5"(适用于 IE5)的现有值, 设置键值为你希望使用的位图文件的路径和文件名(例如: "C:\WINDOWS\CLOUDS.BMP")。

http://www.happydrips.com


禁止/允许自动调整图片大小

这个设置控制 Internet Explorer 是否尝试自动调整一个图像的大小适合窗口。

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main 下

新建或修改字符串值 Enable AutoImageResize，赋值为: Yes，或者设置为 "No" 禁用

http://www.happydrips.com


使IE窗口打开时自动最大化

有时在我们使用IE浏览器时，不知道什么原因窗口就变小了，每次重新启动IE都是一个小窗口，即使用“最大化”还是无济于事。其实这是IE所具有的一种“记忆”结果，即下次重新开启的窗口默认是最前一次关闭的状态。要使它重新变大，可进入注册表，

依次选择："HKEY_CURRENT_USER\Software\

Microsoft\Internet Explorer\Main\"在右边删除"Windows_Placement"键。

另外，在"HKEY_CURRENT_USER\Software\Microsoft\

Internet Explorer\Desktop\Old WorkAreas"右边的窗口中删除"OldWorkAreaRects"键，关闭注册表，重新启动计算机，连续两次最大化IE（即“最大化”-“最小化”-“最大化”），再次重启IE，就OK了。

http://www.happydrips.com


从 Internet Explorer 中删除 Windows Messenger

这个技巧可以用于从 Internet Explorer 中删除 Windows Messenger 集成。它将同时删除工具栏图标和工具菜单项目。

打开注册表 , 查找下面的主键。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Extensions\
{FB5F1910-F110-11d2-BB9E-00C04F795683}]

高亮选择主键, 然后选择 "编辑 | 重命名", 在主键名称的开始添加一个减号("-"), 现在它应该被称为 "-{FB5F1910-F110-11d2-BB9E-00C04F795683}"。

要使更改生效, 重新启动 Internet Explorer 。要重新启用 Messenger 集成, 重命名主键, 并删除"-"号。

http://www.happydrips.com


更改 Internet Explorer 搜索引擎

正常情况下, 当你在 Internet Explorer 地址栏中输入 "go [关键词]"时, IE 将使用一个 Microsoft 选择的搜索引擎搜索 Web 。通过修改这个主键, 你可以选择要使用哪一个搜索引擎。

打开你的 注册表 , 查找下面的主键。

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl]

修改 "默认" 键值等于你想要使用的搜索引擎的 URL , 替换 "%s" 代表关键词。

例如, 要使用 AltaVista , 键值应该是:
http://www.altavista.com/cgi-bin/query?q=%s

而要使用 Yahoo! 键值应该是:
http://search.yahoo.com/bin/search?p=%s

http://www.happydrips.com


更改IE的默认缓冲路径

在

HKEY_CURRENT_USER\Software\Microsoft\Windows\

CurrentVersion\Explorer\User Shell Folders

更改“Cache”的路径即可。

http://www.happydrips.com


更改IE的默认下载路径

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer下

在右边的窗口中新建DWORD值“Download Directory”,并设其值为你想要的下载路径,如C:\My Documents。

http://www.happydrips.com


调整IE的网址列表

我们在使用IE上网时输入的网址，会在注册表里面留下一些记录，记录着你输入过那些网址，当你下次再
输入该网址时，只需输入几个字母，IE就会自动的输入完整的网址，大大方便了我们，在以下的方法中，
我们可以手动的在WINDOWS的注册表中增加一些网址URL，使上网时更方便。
依次展开在HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs下
在右边的窗口中按url1、url2、url3......顺序排列着一些URL,修改，增加，删除这些url的值
即可达到修改，增加，删除URL的功能。

http://www.happydrips.com


禁止IE显示“频道”栏

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main 下

新建或修改字符串值 Show_ChannelBand，赋值为: No，或者设置为 "Yes" 允许显示

http://www.happydrips.com


禁止IE显示“工具”栏

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main 下

新建或修改字符串值 Show_URLToolBar，赋值为: No，或者设置为 "Yes" 允许显示

http://www.happydrips.com


禁止IE显示“工具”栏

在

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main 下

新建或修改字符串值 Show_StatusBar，赋值为: No，或者设置为 "Yes" 允许显示

http://www.happydrips.com


禁用Internet连接向导

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 Connwiz Admin Lock 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用默认浏览器检查

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 Check_If_Default 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止邮件设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 Messaging 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用日历和联系人设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 CalendarContact 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用表单的自动完成功能

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 FormSuggest 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁用自动完成保存密码

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 FormSuggest Passwords 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


禁止更改配置文件助理设置

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 Profiles 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


对拨号连接实行“自动检测”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Windows\CurrentVersion\Internet Settings 下

新建一个名为 DialupAutodetect 的DWORD，然后赋值为: 1 (0x1)即可

http://www.happydrips.com


对拨号连接实行“自动检测”

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Windows\CurrentVersion\Internet Settings 下

新建一个名为 EnableAutoProxyResultCache 的DWORD，然后赋值为: 0 即可

http://www.happydrips.com


禁用更改链接颜色

在

HKEY_CURRENT_USER\Software\Policies\Microsoft

\Internet Explorer\Control Panel 下

新建一个名为 Links 的DWORD，然后赋值为: 1(0x1) 即可

http://www.happydrips.com


删除OutLook Express 的启动画面

是否厌倦了每一次启动 Outlook Express 时显示的启动画面? 这个提示将帮助你删除它。

打开注册表 , 在下面的主键中

[HKEY_CURRENT_USER\Identities\{UniqueIdentity}\Software\Microsoft\Outlook Express\5.0]

UniqueIdentity为您的注册表中的具体值，通常为一串数字。

创建一个名为 "NoSplash" 的 DWORD 键值。

更改键值等于 "1" 禁用启动画面。

退出注册表, 重新启动 Outlook Express 。

注释: 对于 Outlook 4.0 和更低版本, 这个主键是 [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]。

http://www.happydrips.com


从 Outlook Express 中删除 Windows Messenger

这个技巧用于从 Outlook Express 中删除 MSN Instant Messenger 功能和集成。

打开注册表 , 查找下面的主键。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]

创建一个新的 DWORD 值 Hide Messenger , 或者修改现有值，将 Hide Messenger 的值设为 2 。（＝删除）

退出你的注册表, 要使更改生效, 你可能需要重新启动或者注销 Windows 。

http://www.happydrips.com


禁止用户更改帐号

这个设置在 Outlook Express 中禁用用户创建或修改任何邮件, 新闻或目录帐号的功能。

打开注册表 , 查找下面的主键。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]

创建一个新的名为 "No Modify Accts" 的 DWORD 值, 设置它的为 "1" 启用限制, 或者设置为 "0" 允许用户修改帐号。

要使更改生效, 重新启动 Outlook Express 。

http://www.happydrips.com


更改OutLook Express 的启动页面

这个设置可以用于更改 Outlook Express 第一次启动时在右边的窗口中加载的页面。

打开注册表 , 查找下面的主键。

[HKEY_CURRENT_USER\Identities\[Identity]\Software\Microsoft\
Outlook Express\5.0]

创建一个新的字符串值 "FrontPagePath", 或者修改原有值，设置它的值为指定的URL 或文件名。

例如："http://www.microsoft.com/china"

要使更改生效, 重新启动 Outlook Express 。

http://www.happydrips.com


禁止/允许使用 Http 邮件功能

这个技巧用于指定在 Outlook Express 中是否可以使用或者创建 HTTP 邮件服务器(例如: Hotmail)。

打开注册表 , 查找下面的主键。

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]

创建一个新的 DWORD 值 "HTTP Mail Enable", 或者修改原有值，设置它的值为 0 禁止，1 允许。

http://www.happydrips.com


修改OutLook右上角的活动图标

当你使用 Outlook Express 阅读消息时, 显示一个指示是否处于活动状态的 Logo 。使用这个技巧, 你可以修改显示哪一个 Logo, 定制它或者重置它为默认值。

使用你自己的动画 Logo
有两个位图文件用于显示动画 Logo, 除了大小之外, 它们可以是同一个图像, 一个宽度是 38 像素, 而另一个是 22 像素。

使用一个图像编辑器, 例如微软的画笔程序, 创建一个类似于滚动电影胶片的图像, 其中相同大小的"帧"垂直堆叠在一个较大的图像中。例如, 一个大图标, 包含 10 帧, 应该是 38 像素宽度和 380 像素高度(38 像素 x 10 帧 = 380 像素高度)。

当处于活动状态时, Logo 就会动起来, 首先显示顶部的帧, 然后是下一个, 依此类推, 直到到达最后一帧, 图像开始循环。同样, 当应用程序空闲时, 静止显示第一帧, 直到下一次活动状态, 除非已经使用下面的技巧指定了一个可选的非活动 Logo 。

一旦创建了图标, 你需要通过打开注册表中的 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] 主键注册它们。

接下来创建两个新的字符串键值, 或者修改名为 "SmBrandBitmap" 和 "BrandBitmap" 的现有值, 设置它们的键值分别等于小图像(22 像素)和大图像(38 像素)的完整文件名。

使用你自己的非动画 Logo
当应用程序空闲时, 显示这些图像, 和上面的方法一样, 有两个图像, 一个是 22 x 22 像素的小图像, 一个是 38 x 38 像素的大图像。要激活它们, 打开 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] 主键, 创建两个字符串键值, 名称分别为 "SmallBitmap" 和 "BigBitmap", 设置键值分别等于图像的文件名。

重置为默认 Logo
要恢复默认的动画 Logo, 删除在注册表主键 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] 下面找到的 "BrandBitmap" 和 "SmBrandBitmap" 字符串键值。

要恢复默认的空闲 Logo, 删除在注册表主键 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] 下面找到的 "SmallBitmap" 和 "BigBitmap" 字符串键值。

要使更改生效, 重新启动 Outlook Express 。

参考图片：

http://www.happydrips.com


修改OutLook的标题

这个设置允许你通过使用你自己的窗口标题自定义 Outlook Express 。例如, 你可以重命名 Outlook Express 为 "我的邮件阅读器" 或者其他任何你喜欢的东西!

打开注册表 , 查找下面的主键：

[HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0]。

Identity ID 为您的注册表中的特定值，通常为一串数字。

创建一个新的 字符串 值 "WindowTitle", 或者修改原有值，设置它的值为您想要的名称，如"我的邮件阅读器"等。

http://www.happydrips.com


配置NetMeeting使用一个网关

这些设置允许你配置 Netmeeting 使用一个 H.323 网关, 通过 PSTN 转移呼叫到一个标准的电话机上。

打开注册表 , 查找下面的主键。

[HKEY_CURRENT_USER\Software\Microsoft\Conferencing]

创建一个新的名为 "Enable H.323 Gateway" 的二进制键值, 设置它的值为 "01 00 00 00" 启用网关, 或者设置为 "00 00 00 00" 禁用它。

创建一个新的名为 "H.323 Gateway" 的字符串值, 设置它的值为 H.323 网关的 IP 地址或主机名。

要使更改生效, 重新启动 Netmeeting 。

http://www.happydrips.com


清除呼叫历史列表

这个技巧允许你清除保存在 Netmeeting 下拉列表中的呼叫历史。

打开注册表 , 删除下面的主键。

[HKEY_CURRENT_USER\Software\Microsoft

\Conferencing\UI\CallMRU]

要使更改生效, 重新启动 Netmeeting 。

http://www.happydrips.com


NetMeeting的策略和限制

这些限制和策略可以用于禁用或者限制访问 Windows Netmeeting 的特定功能。

打开注册表 , 查找下面的主键。

[HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Conferencing]

创建一个新的 DWORD 值, 根据下面的键值列表命名它。设置它的值等于 "1" 启用设置。

  • CallSecurity

  • IntranetWebDirURL

  • MaximumBandwidth

  • NoAddingDirectoryServers

  • NoAdvancedAudio

  • NoAdvancedCalling

  • NoAllowControl

  • NoAppSharing

  • NoAudio

  • NoAudioPage

  • NoAutoAcceptCalls

  • NoChangeDirectSound

  • NoChangingCallMode

  • NoChat

  • NoDirectoryServices

  • NoFullDuplex

  • NoGeneralPage

  • NoNewWhiteBoard

  • NoOldWhiteBoard

  • NoReceivingFiles

  • NoReceivingVideo

  • NoSecurityPage

  • NoSendingFiles

  • NoSendingVideo

  • NoSharing

  • NoSharingDesktop

  • NoSharingDosWindows

  • NoSharingExplorer

  • NoTrueColorSharing

  • NoVideoPage

  • NoWebDirectory

  • ShowFirstTimeURL

  • Use AutoConfig

要使更改生效, 重新启动 Netmeeting 。

http://www.happydrips.com


NetMeeting 日志

这个设置在 Microsoft Netmeeting 中启用调试日志功能。它在诊断错误或者连接问题时可能有用。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

\Conferencing\Debug]

创建一个新的名为 "RetailLog" 的 DWORD 值, 设置它的值为 "1" 启用日志。

要使更改生效, 重新启动 Netmeeting 。

备注: 日志文件将写入 [NM_Directory]/nmLog.txt

http://www.happydrips.com


指定NetMeeting的用户信息

这些键值允许你指定在 Netmeeting 中使用的用户信息, 例如名字, E-mail 和帐号。

打开注册表 , 查找下面的主键。

[HKEY_CURRENT_USER\Software\Microsoft\

User Location Service\Client]

创建一个新的字符串值, 或者修改现有值, 为下面列表中的每一个项目设置相应的键值数据。

  • Account - 帐号名称(用于登录到 Gatekeeper)

  • Comments - 常规注释字段

  • Email Name - E-mail 地址

  • First Name - 姓

  • Last Name - 名

  • Location - 位置

  • Phonenum - 电话号码(用于登录到 Gatekeeper)

  • User Name - 连接到其他 H.323 设备时显示的用户名

要使更改生效, 重新启动 Netmeeting 。

http://www.happydrips.com


清除播放历史列表

这个技巧允许你清除 Windows Media Player 中的最近使用的文件和 URL 历史。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\

MediaPlayer\Player]

要删除从一个特定网站流入的内容, 清除 [...\RecentURLList] 子键。

要删除你最近播放的整个文件列表, 清除 [...\RecentFileList] 子键。

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


锁定播放器外观

这个限制允许你定义和锁定 Windows Media Player 的外观。此外, 用户不能够切换播放器到完整模式或者使用在指定的外观中不可用的任何功能。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]

创建一个新的名为 "DefaultSkin" 的字符串值, 设置它的值等于所需外观的文件名。

创建一个新的名为 "SetAndLockSkin" 的 DWORD 值, 设置它的值为 "1" 启用限制。

参考图片：

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


隐藏锚窗口

这个设置隐藏正常情况下在紧凑模式或者外观模式下使用 Windows Media Player 时显示的锚窗口。它同时也限制用户重新激活这个窗口。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Policies

\Microsoft\WindowsMediaPlayer]

创建一个新的 DWORD 值 "DoNotShowAnchor"，值为1 禁止显示，0 解除限制。

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


启用播放DVD功能

这个设置允许你使用 Microsoft Media Player 播放和打开 DVD 。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft

\MediaPlayer\Player\Settings]

创建一个新的名为 "EnableDVDUI" 的字符串值, 设置它的值为 "yes" 启用 DVD 功能，"No"禁用

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


禁止播放器版本更新消息

这个设置允许你禁用当一个新版本的播放器发布时显示的 Media Player 自动更新消息。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

\MediaPlayer\PlayerUpgrade]

创建一个新的名为 "AskMeAgain" 的字符串值, 设置它的值为 "No" 禁用，"Yes"解除限制。

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


删除收音机等项目

这个技巧允许你从 Windows Media Player 中删除收音机栏, 媒体收藏夹和查找新站台。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Policies

\Microsoft\WindowsMediaPlayer]

创建相应的 DWORD 值，根据下表， 设置它的值等于 "1" 禁用。

NoRadioBar，禁止收音机

NoMediaFavorites，禁止收藏夹

NoFindNewStations，禁止查找新站台。

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


禁止播放器版本更新消息

这个技巧允许你自定义显示在 Windows Media Player 上的标题栏文本。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Policies

\Microsoft\WindowsMediaPlayer]

创建一个新的名为 "TitleBar" 的字符串值, 设置它的值为你想要显示在标题栏中的文本。

要使更改生效, 重新启动 Windows Media Player

http://www.happydrips.com


禁用密码缓存

正常情况下, Office 2000 在建立外部数据源连接时试图缓存用户授权信息。因为密码保存在一个文本文件中, 这会导致一个潜在的安全问题。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Microsoft\Office

\9.0\Common\Security]

创建一个新的 DWORD 值 "DisablePwdCaching", 或修改现有值，设为 1 禁用，0 允许。

要使更改生效, 您可能需要重新启动或者注销

http://www.happydrips.com


禁用性能调整

这个设置用于禁用 Office 2000 自动性能调整功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Microsoft\Office

\9.0\Common\TuneUp]

创建一个新的 DWORD 值 "Disabled", 或修改现有值，设为 1 禁用，0 允许。

要使更改生效,可能需要重新启动或者注销 Windows

http://www.happydrips.com


禁用Office助手

你是否被那些在你最不希望它们出现的时候总是会跳出来的 Office 助手所困扰? 这个技巧将让你一劳永逸地删除它们!

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office

\[ver]\Common\Assistant]

其中 [ver] 是 Office 的版本号("8.0" = Office 97, "9.0" = Office 2000 和 "10.0" = Office XP)。然后删除这个主键下面的所有键值。

要使更改生效, 可能需要重新启动或者注销

http://www.happydrips.com


控制Office助手的行为

这些设置控制在 Office 97, 2000 和 XP 中的助手的功能和行为。

Office XP
打开注册表 , 查找主键:
[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Assistant]。

Office 2000
打开注册表 , 查找主键:
[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Assistant]。

Office 97
打开注册表 , 查找主键:
[HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Common\Assistant]。

根据下面的列表, 创建一个新的 DWORD 键值, 或者修改现有值，值为 1 允许，0 禁止。

  • AsstAssistWithWizards - 允许助手帮助使用 Office 向导。

  • AsstAssistWithHelp - 允许助手使用帮助助理。

  • AsstAssistWithAlerts - 允许助手为 Office 警告打开。

  • AsstGuessHelp - 允许助手推测会显示哪一个帮助主题。

  • AsstKeyboardShortcutTips - 指定是否显示有关键盘快捷方式的提示。

  • AsstFeatureTips - 指定是否显示有关更有效地使用功能的提示。

  • AsstMouseTips - 指定是否显示有关更有效地使用鼠标的提示。

  • AsstMoveWhenInTheWay - 允许助手被阻挡时移动。

  • AsstOnlyHighPriorityTips - 指定是否只显示高优先级的提示。

  • AsstSearchInProgram - 指定助手在设计模式下是否可以搜索产品帮助。

  • AsstShowTipOfDay - 启动时显示"每日提示"。

  • AsstSounds - 指定助手是否能够发声。

  • AsstTipTimeout - 指定提示气泡下落之前的时间(秒)。

  • AsstTop - 指定位于窗口顶部。

  • AsstLeft - 指定位于窗口左边。

要使更改生效, 重新启动任意一个 Office 应用程序。

http://www.happydrips.com


在Microsoft Word中使用实时卷动

正常情况下, 当你使用滚动条浏览一个 Word 文档时, 在释放鼠标按钮之前页面不会更新。使用这个技巧, 在你移动滚动条的时候, 文档位置被更新。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office

\[Office Version]\Word\Options]

其中 [Office Version] 是 Office 的版本号("8.0" = Office 97, "9.0" = Office 2000 和 "10.0" = Office XP)。

对于 Word 97 和 2000, 创建一个新的字符串值, 或者修改名为 "LiveScrolling" 的现有值, 设置它的值等于 "1" 启用实时卷动, 或者设置为 "0" 禁用它。

对于 Word 2002, 创建一个新的 DWORD 值, 或者修改名为 "NoLiveScrolling" 的现有值, 设置它的值等于 "0" 启用实时卷动, 或者设置为 "1" 禁用它。

参考图片：

关闭注册表, 然后重新启动 Word 。

http://www.happydrips.com


修改Office的注册用户信息

对于 Microsoft Office 的前期版本, 要更改显示在启动画面上和关于对话框中的注册公司, 必须重新安装 Office 。对于 Office 2000 和 XP , 可以在注册表中更改它。

打开 注册表 , 查找下面对应版本的主键。

Office 2000
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ Uninstall\{00000409-78E1-11D2-B60F-006097C998E7}]

Office XP
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ Uninstall\{90280409-6000-11D3-8CFE-0050048383C9}]

更改键值 "RegCompany" 和 "RegOwner" 为所需的注册公司和用户名。

接下来查找下面对应于你的 Office 版本的注册表主键。

Office 2000
[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common]

Office XP
[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common]

然后重命名名为 "UserInfo" 和 "OldUserInfo" 的子键。

退出注册表, 关闭所有 Office 程序, 然后重新启动一个。现在, 启动画面上和关于对话框中的注册公司应该都被更改。

http://www.happydrips.com


隐藏Office XP工具栏帮助

这些设置可以用于隐藏在 Office XP 应用程序中的工具栏帮助功能。正常情况下, 它显示在右上角, 允许用户"输入一个问题寻求帮助"。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office

\10.0\Common\Toolbars\Settings]

从下表中为每一个要隐藏工具栏帮助的应用程序创建一个新的 DWORD 值。

  • Microsoft Access AWDropdownHidden - 在 Microsoft Access 中隐藏

  • Microsoft Excel AWDropdownHidden - 在 Microsoft Excel 中隐藏

  • Microsoft Outlook AWDropdownHidden - 在 Microsoft Outlook 中隐藏

  • Microsoft Powerpoint AWDropdownHidden - 在 Microsoft Powerpoint 中隐藏

  • Microsoft Word AWDropdownHidden - 在 Microsoft Word 中隐藏

值为 1 隐藏，0 显示

http://www.happydrips.com


控制Office XP的错误报告

Office XP 包含一个功能, 如果在一个 Office XP 应用程序中发生一个错误, 它将发送调试信息到 Microsoft 。使用这个技巧可以禁用它。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies

\Microsoft\Office\10.0\Common]

创建下列 DWORD 键值, 设置它们的值为 "1"禁用。

  • DWNeverUpload

  • DWNoExternalURL

  • DWNoFileCollection

  • DWNoSecondLevelCollection

要使更改生效, 重新启动 Office 。

http://www.happydrips.com


使OutLook最小化到系统托盘（时钟旁）

正常情况下, Outlook 2002(来自 Office XP)和大多数应用程序一样, 将最小化到任务栏。这个设置更改默认行为, 使它变为最小化到系统托盘(时钟旁边)。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0

\Outlook\Preferences]

创建一个新的 DWORD 值 "MinToTray"，赋值为 1，为 0 时表示最小化到任务栏。

要使更改生效, 可能需要重新启动或者注销 Windows

http://www.happydrips.com


禁止剪贴板工具栏的出现

当你在任意一个 Microsoft Office 程序中复制多个项目时, 出现 Office 剪贴板, 允许你收集和粘贴保存在工具栏中的多个项目。这个技巧允许你阻止工具栏自动出现。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0

\Common\General]

创建一个新的 DWORD 值 "AcbControl"，赋值为 1，为 0 时解除限制。

要使更改生效, 可能需要重新启动或者注销 Windows

http://www.happydrips.com


使用系统标准字体

这个设置让 Microsoft office 为用户界面使用标准系统字体代替默认 Office 字体。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0

\Common\General]

创建一个新的 DWORD 值 "UseOfficeUIFont"，赋值为 1，为 0 时表示使用默认 Office 字体。

要使更改生效, 可能需要重新启动或者注销 Windows

http://www.happydrips.com


在OutLook2003中启用 Internet Mail 日志

为了帮助诊断 POP3, SMTP 和 Internet mail 问题, Microsoft 在 Outlook 2000 中包含了一个日志选项。可以通过注册表启用这个功能。

打开注册表 , 查找下面的主键

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0

\Outlook\Options\Mail]

创建一个新的 DWORD 值 "Logging"，设置它的值为 "1" 启用日志, 或者设置为 "0" 禁用日志。

重新启动 Outlook

备注: 在你建立或者尝试建立一个 Internet Mail 进程之后, 将会创建三个文件。这些文件的位置取决于你正在运行的操作系统: Windows 98/Me - "C:\Windows\Temp\Outlook Logging" 或 Windows NT/2000/XP - "C:\Documents and Settings\USERNAME\Local Settings\Temp\Outlook Logging\ProfileName"。

http://www.happydrips.com


禁用 MSN Instant Messenger

这个限制用于禁用运行 Microsoft MSN Instant Messenger 客户端的功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

从下表中为每一个可选的限制创建一个新的 DWORD 值。设置键值为 "1" 启用限制, 或者设置为 "0" 禁用它。

  • PreventAutoRun - 禁止自动启动 Messenger

  • PreventRun - 禁止运行 Messenger

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


更改 MSN Messenger 背景图像

这个技巧允许你更改在 MSN Messenger 服务中的背景位图图像。

在你的系统上定位 MSN Messenger 安装目录(例如: "C:\Program Files\Messenger")。这个位置也可以在注册表中 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

\MessengerService] 下面的 "InstallationDirectory" 键值中找到。

重命名安装目录中的 "lvback.gif" 文件为 "lvback.old"。然后复制新的背景 GIF 文件到同一个目录并且重命名为 "lvback.gif"。

要使更改生效, 重新启动 MSN Messenger 。

http://www.happydrips.com


禁止/允许文件传输

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 DisableFileTransfer , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


禁止/允许语音聊天

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 DisablePC2PCAudio , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


禁止/允许视频聊天

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 DisableVideo , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


禁止/允许版本自动更新

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 PreventAutoUpdate , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


禁止/允许显示版本号

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 PreventConsumerVersion , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


禁止/允许背景下载

这些限制用于禁用 Microsoft MSN Instant Messenger 客户端的各种功能。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft

\Messenger\Client]

创建一个新的 DWORD 值 PreventBackgroundDownload , 设置键值为 "1" 启用限制，"0"解除限制

要使更改生效, 重新启动 MSN Messenger

http://www.happydrips.com


查看主板BIOS的信息

这个注册表主键存储有关系统 BIOS 的信息, 包括发布日期, 版本号和视频 BIOS 日期。

打开注册表 , 查找下面的主键, 获取系统BIOS的信息

[HKEY_LOCAL_MACHINE\HARDWARE\Description\System]

这些值是只读的, 不能被更改。

SystemBiosDate，BIOS日期

SystemBiosVersion，BIOS版本

VideoBiosDate，显卡BIOS版本

适用：(Windows NT/2000/XP)

http://www.happydrips.com


查看中央处理器CPU的信息

这些键值包含有关系统处理器的信息, 包括速度, 品牌和型号。

打开注册表 , 查找下面的主键, 获取系统BIOS的信息

[HKEY_LOCAL_MACHINE\HARDWARE\Description\System\CentralProcessor\0]

这些值是只读的, 不能被更改。

适用：(Windows NT/2000/XP)

http://www.happydrips.com


优化超过 256K 的 L2 缓存

默认情况下, Windows NT 针对 256K 大小的 L2 缓存进行优化。由于现在大多数计算机拥有的 L2 缓存大于 256K, 值得花一些时间更改 SecondLevelDataCache 的设置, 使它符合已经安装的 L2 缓存的大小。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

创建一个新的 DWORD 值 SecondLevelDataCache ，设置它的值等于你的 L2 缓存大小(Kb, 十进制)。

适用：(Windows NT)

http://www.happydrips.com


启用 Intel 芯片组上的 UDMA66 模式

如果你有一台使用支持 UDMA66 的 Intel 芯片组的计算机, 你会发现在使用 Windows 2000 的计算机上, 默认情况下 UDMA66 模式仍然被禁用。这个技巧允许你启用 或者禁用它。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\

Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000]

创建一个新的名为 "EnableUDMA66" 的 DWORD 值, 设置它的值为 "1" 启用 UDMA66, 或者设置为 "0" 禁用它。

适用：(Windows 2000/XP)

http://www.happydrips.com


提升系统内核的性能

在拥有大量内存的系统上, 这个技巧可以强制内核 Windows 系统驻留在内存中而不是以页面方式映射到磁盘。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

\Session Manager\Memory Management]

创建一个新的名为 "DisablePagingExecutive" 的 DWORD 值, 设置它的值为 "1" 停用内核进程页面, 或者设置为 "0" 使用默认值。

适用：(Windows NT/2000/XP)

http://www.happydrips.com


修正 AMD Athlon AGP 页面溢出

如果你使用 AMD Athlon 处理器, 基于 Windows 2000 的计算机在使用一个加速图形端口(AGP)程序时可能会停止响应。这是因为由视频适配器驱动程序分配的内存损坏了。这个注册表技巧将修正这个问题。

打开注册表 , 查找下面的主键

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

\Session Manager\Memory Management]

创建一个新的名为 "LargePageMinimum" 的 DWORD 值, 设置它的值等于 "ffffffff"。

适用：(Windows 2000)

http://www.happydrips.com


加快win2000/xp关机速度

在 [HKEY_CURRENT_USER\Control Panel\Desktop]设置下面的键值：
"AutoEndTasks"="1"（自动关闭停止响应的程序）
"HungAppTimeout"="200"（程序出错时等待时间，单位：毫秒，默认值5000）
"WaitToKillAppTimeout"="1000"（关闭程序时等待时间，单位：毫秒，默认值20000）
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
"WaitToKillServiceTimeout"="1000"（关闭服务时等待时间，单位：毫秒，默认值20000）

http://www.happydrips.com


减少WINXP开机滚动条时间

在 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Control\Session Manager\Memory Management

\PrefetchParameters]下，设置

"EnablePrefetcher"=dword:00000001

http://www.happydrips.com


提升系统内核的性能

（WINNT/2000/XP/2003适用）

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"DisablePagingExecutive"=dword:00000001
[注]默认情况下，Windows会把系统内核写入硬盘，这个设置就是通过禁用内存页面调度（Paging Executive），让数据保留在内存中，从而提升系统性能。建议拥有很多内存的用户（256M以上）使用这个设置。

http://www.happydrips.com


提升系统缓存

在[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]设置：
"LargeSystemCache"=dword:00000001

[注]通常来说，该优化会使系统性能得到相当的提升，但也有可能会使某些应用程序性能降低。需要注意的是必须有256M以上的内存，激活LargeSystemCache才能起到正面作用。

http://www.happydrips.com


增加磁盘缓存

在[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]设置，适用于winnt内核系统：

"IoPageLockLimit"=dword:xxxxxxxx（单位：KB）
[注]不同内存取不同的数值，64M：00001000；128M：00004000；256M：00010000；512M或更大：00040000。据说此法可以降低BT下载对硬盘的伤害。

http://www.happydrips.com


WINXPSP2多用户同时登录

在[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\

Terminal Server\Licensing Core]设置：

"EnableConcurrentSessions"=dword:00000001
[注]这样的并发连接最多支持两个用户同时登录一个系统，并且不能使用相同的帐号。利用该功能，在本地电脑使用Windows XP的同时，可允许另外一个用户通过远程桌面进入系统同时使用Windows XP，而不必在远程桌面登录时让本地用户退出。

http://www.happydrips.com


程序出错时系统自动重新启动外壳程序

（WIN2000/XP/2003）

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"AutoRestartShell"=dword:00000001（默认值）

http://www.happydrips.com


解决无法实现软关机的故障

（WINNT/2000/XP/2003）

在[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]下，设置：

"PowerdownAfterShutdown"="1"

http://www.happydrips.com


解决汉字乱码现象

（WIN2000/XP）

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet

\Control\FontAssoc]

[操作]可能是注册表中与字体相关的数据出错所致，简便方法是：在另一台正常显示的计算机中将上面的内容导出到一个reg文件中，然后将该文件拷贝导出现乱码的计算机中，双击该文件将其导入注册表即可。

http://www.happydrips.com


禁止IE自动安装组件

在[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft

\Internet Explorer\Infodelivery\Restrictions]设置：

"NoJITSetup"=dword:00000001

http://www.happydrips.com


定制IE地址简写名称

在[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AboutURLS]设置：

[操作]新建字符串值，名称为网址简写名称，数据为要转到的网址。以后在IE地址栏输入：about:<简称>，就可以直接到达该网址。
[注]IE的空白网页，取消浏览的网页，出错网页等都在这里定义。

http://www.happydrips.com


重新安装IE（适用于不同版本）">

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer]

[操作]把字符串"Version"的数据值改成比要安装的版本小。

http://www.happydrips.com


重新安装IE（适用于同一版本）

设置下面的键值：

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{89820200-ECBD-11cf-8B85-00AA005B4383}]

"IsInstalled"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{44BBA840-CC51-11CF-AAFA-00AA00B6015C}]

"IsInstalled"=dword:00000000

http://www.happydrips.com


IE打开网页时的默认前缀

在 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\

CurrentVersion\URL\Prefixes]

"www"="http://"（以www开头的网址）
"ftp"="ftp://"（以ftp开头的网址）

在 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\

CurrentVersion\URL\DefaultPrefix]

@="http://"（以其它字符开头的网址）

http://www.happydrips.com


自动清除内存中不被使用的DLL文件

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

\CurrentVersion\Explorer\AlwaysUnloadDLL]

[操作]"默认"值设为"1"

http://www.happydrips.com


在"服务"中删除不需要的服务

在下面的路径中设置：

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services]

[操作]删除相关子键,重新启动生效。

http://www.happydrips.com


去掉 win2003 关机事件跟踪

打开开始-->运行-->键入gpedit.msc，按回车后打开组策略编辑器，双击管理模版菜单--选择系统下拉菜单，在工作区找到“显示‘关闭事件跟踪程序’”，双击“显示‘关闭事件跟踪程序’”项，在设置选项卡里把“已启用”改为“已禁用”，确定完成。

http://www.happydrips.com


手 册 纪 念

本手册发行于2001/6/6日.这是本人辛勤劳动的成果。手册发行后一年多来，深受各位网友的喜欢，本人也感到欣慰。手册的发行得到中华电脑书库(www.pcbookcn.com)站长的大力支持,在此表示感谢。本手册的实用性和知识性有目共睹,已成为互联网上注册表领域的代表书籍。这本手册收录的资料部分来源于网上，部分为本人原创，本手册以技术教程为主。这本手册是为网友提供方便的，希望本手册的发行能对大家进一步学习注册表有所帮助，同时也为中国互联网发展事业贡献自己的一点力量。本手册会不断地完善。欢迎各位网友向朋友推荐本手册。最后，祝大家学习进步，学有所成！

此致

手册作者：姚 辉

http://www.happydrips.com


vipbook1

注册说明

1.说明

本手册为共享软件，未注册用户也可以使用其全部功能，注册用户可以获得更多的服务，包括：可以获得作者的直接技术支持，可以获得作者制作的更多的电子图书和教程等，更多信息请访问作者主页。

2.怎样注册？

您可以在本页面注册，或者，您也可以登陆作者主页或本手册内提供的“注册页面”链接进行注册。注册请填写您的姓名和注册信箱，如有必要，可以留下您的地址和联系电话等，具体视各人喜好而定。注意：请务必提供准确有效的电子信箱，以便本站能准确及时地将注册码和相关信息发往您的注册信箱。

3.可以使用何种方式支付注册费？

一般地，本站提供普通邮局，银行汇款，网上支付等多种注册方式，请选择合适的一种。

4.怎样获取更多的付费服务？

注册后，一封包含注册码和注册帐号的Email会发往您的信箱。您可以在作者主页的“登陆”页面填写发给您的注册帐号，通过系统认证后就可下载本站提供的更多的技术资料和教程。


使用说明

请访问作者主页获取手册的最新版本

http://www.happydrips.com


禁止运行/允许运行程序

HKEY_USERS\sundrink\Software\Microsoft\Windows\CurrentVersion\Policies\

Explorer\下，

（其中sundrink应该改为指定的用户名）将RestrictRun的十六进制键值改为1即可，反之，如果要运行所有程序，只需将RestrictRun的键值改为0即可。

如果要指定除了某个程序外，其他的程序都不可以运行，可在

HKEY_USERS\sundrink\Software\Microsoft\Windows\CurrentVersion\Policies\

Explorer\RestrictRun\

下新建字符串，其中默认的键值名所对应的程序无论在禁止运行所有程序或者是允许运行所有程序时都可以运行。

例：

如果要指定只能运行ACDSee32.exe程序（除了运行默认的程序外，建议在修改该项之前备份注册表！！！

或者将默认的键值赋予某个注册表修改程序，否则什么程序都运行不了不能骂我！！）

（默认） "注册终结者.exe"

0 "ACDSee32.exe"

如果允许运行其他的程序，只须再建一个字符串值1，键值设为对应的应用程序名。

如果有多个程序，则字符串值为2，3，4，5。。。。，依次类推，键值设为对应的程序名即可。


升 级 方 法

感谢你的注册支持!本手册将不断更新完善，为你提供更多的帮助.手册升级信息将发到你的注册信箱,请注意查收.

更多情况请访问：

http://www.happydrips.com


广告

广 告 服 务 协 议

  • 本手册提供有偿广告服务.

  • 有意使用本手册广告服务者,请来信联系.

  • 具体细节双方商定.

  • 因某些非人力,不可抗拒因素而导致合作终止,双方不付责任.

    我的E-mail是: yshot@263.net

姚 辉

2002/9/5


改变“控制面板”中的“添加删除程序”的“安全卸载”中的列表内容



改变“控制面板”中的“添加/

删除程序”的“安全/卸载”中的

列表内容

在HKEY_LOCAL_MACHINE\Software\Microsoft\Windows

\CurrentVersion\Uninstall下

有许多主键，要删除“安全/卸载”列表中的某条内容，只要删除相对应的主键即可。


合 作 协 议

  • 本手册发行量大，前景广阔。为了更好的推广本手册，欲真诚与各位下载站站长合作。

  • 和本手册合作的网站，本人将免费在手册明显处按加入者的意愿标明合作网站名称和详细说明，以使你的网站得到更好的宣传，同时要求合作方能在自己的网站上给予适当的宣传。合作站点必须保证本手册一定的下载量.

  • 合作为双方自愿，互惠互利。如果原合作站点不愿继续合作，本人有权将其网站信息从手册处删除，并且收回手册下载权.

  • 合作站点必须按本站意愿更新手册,以维护其他合作站点的利益。对不愿经常更新本手册的合作网站，本人有权单方删除其信息。

  • 为保护本手册利益,合作站点只能提供免费试用版本下载.对私自提供完全正式版本下载的,将追究其法律责任.

  • 本次合作对双方都是免费的。

  • 为保证宣传效果，限制合作网站数量，额满为止。

合作协议双方自觉遵守。

因某些非人力,不可抗拒因素而导致合作终止,双方不付责任.

如果有意合作，请来信联系.

我的联系信箱： yshot@263.net.

姚 辉

2002/8/23


屏蔽“添加/删除”项

通过“控制面板”中的“添加/删除”项，用户可以安装和卸载Windows 2000的应用程序，还可以添加和删除Windows 2000的功能组件。
新建一个字符串(REG＿SZ)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼Current Version＼Policies＼Uninstall＼NoAddRemovePrograms，修改其值为1。这时再进入到“控制面板”中，可以看到“添加/删除”图标不见了。


屏蔽“添加删除”项目“添加新程序”中的“从光盘或软盘添加程序”

屏蔽“添加/删除”项目“添加新

程序”中的“从光盘或软盘添加程序”

通过“添加/删除”项中的“添加新程序”，用户可以安装新的Windows 2000应用程序。我们可以去除掉“从光盘或软盘添加程序”方式。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼Current Version＼Policies＼Uninstall＼NoAddFromCDor Floppy，修改其值为1。


屏蔽“添加/删除”项中的“添加新程序”

可以通过屏蔽掉“添加/删除”项中的“添加新程序”以阻止用户添加新程序。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼ Windows＼Current Version＼Policies＼Uninstall＼NoAddPage，修改其值为1。


屏蔽“添加删除”项中的“添加删除组件”

屏蔽“添加/删除”项中的

“添加/删除Windows组件”

我们可以屏蔽掉“添加/删除”项中的“添加/删除Windows组件”。使用户不能通过“添加/删除”项中的“添加/删除Windows组件”安装新的Windows 2000应用程序。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼

Windows＼Current Version＼Policies＼Uninstall＼NoWindowsSetupPage，修改其值为1。


屏蔽“添加删除”项中的“更改或删除程序”选项

屏蔽“添加/删除”项中

的“更改或删除程序”选项

我们可以屏蔽掉“添加/删除”项中的“更改或删除程序”阻止用户更改或删除程序。新建一个双字节(REG＿DWORD)值项HKEY＿CURRENT＿USER＼Software＼Microsoft＼Windows＼CurrentVersion＼Policies＼Uninstall＼NoRemovePage，修改其值为1。刷新桌面使更改生效


作者简介

本人，男，1980年生，现就读于中国科技大学地球和空间科学系。我的家乡--广西北海，为风景优美的旅游城市，著名的南珠之乡，全国23个沿海开放城市之一。

本人为人脚踏实地，兴趣广泛，尤其热衷于生物和计算机，有一颗不知疲倦的心。如果你也喜欢生物或者计算机，不妨来信交流。

个人观点：人生有很多的无奈，但不妨碍我们去努力追求拓新；平凡而充实的人生才可以真实地享受生活。

http://www.happydrips.com

E-Mail: yshot@263.net

手册作者：姚辉