目 录

目 录

第1章 迎娶Windows XP

1.1 常规安装过程

1.1.1 安装前该做些什么

1.1.2 常规安装 3

1.2 自动安装 4

1.2.1 带参数的安装

1.2.2 无人值守安装

1.3 多系统安装

1.3.1 为Linux准备空间

1.3.2 用分区魔术师准备Linux空间

1.3.3 实战Windows XP/Linux双系统

1.3.4 用NTLDR实现多重引导

1.3.5 Windows与Linux资源共享

实例1:找回被Ghost误克隆的分区

实例2:跟我学做启动盘

实例3:卸载Windows，真的是一个问题吗

实例4:Windows Installer出错引起的安装故障

实例5:多系统安装又一法

实例6:从安装光盘中恢复安装IE 6.0

实例7:Windows补丁下载、批量安装、局域网分发一条龙

实例8:不用软件把Windows 2000彻底搬家到新分区

实例9:微软的软件安装也这么难

实例10:Windows的救命大师—原位升级

问答·技巧

第2章 安全，安全，还是安全

2.1 系统安全概述

2.2 系统保护

2.2.1 扫描系统漏洞与不安全设置

2.2.2 定时升级、更新系统

2.2.3 保护不安全端口

2.3 系统维护

2.3.1 系统监视

2.3.2 系统加密与隐藏

2.3.3 系统功能限制

2.4 病毒防范

2.4.1 病毒的手工清除

2.4.2 使用杀毒软件清除病毒

2.4.3 进行病毒监控

2.4.4 要建立好的防毒习惯

实例1:病毒库最快升级全方案

实例2:Windows 2000/XP安全设防三要素

实例3:乔装成DLL文件的新型恶意网页病毒

实例4:网络安全攻防拆解

实例5:光盘刻进病毒真的只能报废吗？

实例6:关好“比尔”家的后门——系统后门大揭秘

第3章 自古用机谁无死

3.1 Windows XP常见问题排困解难

3.1.1 软件故障的排困解难

3.1.2 硬件故障的排困解难

3.2 芝麻开门——无法进入Windows的解决方案

3.2.1 Windows XP 系统还原

3.2.2 使用Windows XP故障恢复控制台

3.3 Windows XP超级替补──维护磁盘面对面

3.3.1 超级巨无霸——ERD Commander 2003

3.3.2 四两拨千斤──超级通用DOS 7.10启动盘

实例1:当故障恢复控制台失效的时候……

实例2:遭遇系统故障该怎样有效提问(上)

实例3:遭遇系统故障该怎样有效提问(下)

实例4:常见Windows故障消息及解决流程

问答·技巧

第4章 备份与修复

4.1 数据备份

4.1.1 什么情况下需要数据备份

4.1.2 硬盘及分区备份

4.1.3 系统备份

4.1.4 邮件档案备份

4.1.5 数字证书备份

4.1.6 注册表备份

4.1.7 系统配置文件的备份

4.1.8 MSN和QQ相关资料的备份

4.2 系统修复

4.2.1 修复注册表

4.2.2 修复操作系统

4.2.3 修复被破坏的硬盘

4.2.4 常见存储介质 CD、CD-R、CD-RW、U盘和数码相机内存卡的修复

4.2.5 常用邮件、图片、影像、 ZIP、MS Office、声音文件的修复

实例1:系统恢复与备份一键搞定—史上最完美的一键恢复、备份系统

实例2:Windows 2000/XP注册表终极备份与恢复

实例3:DIY一劳永逸的日期备份工具

实例4:最简单的全自动备份工具来了

实例5:拿什么来拯救你—硬盘损坏与坏道修复全接触

实例6:把大象装进冰箱—700MB刻录盘也能备份DVD

实例7:一个命令搞定Ghost备份与恢复

实例8:输入法图标故障修复两则

实例9:把个人数据轻松移出危险地带

问答·技巧

第5章 Windows XP极品优化

5.1 启动过程优化

5.1.1 硬盘子系统的正确设置

5.1.2 用户自动登录

5.1.3 手动设置网卡的IP地址

5.1.4 Bootvis真的可以优化Windows XP启动过程吗？

5.1.5 清除开机加载程序

5.1.6 配置预读取（Prefetch）功能

5.2 磁盘子系统性能优化

5.2.1 磁盘缓存的优化

5.2.2 磁盘碎片整理

5.2.3 优化虚拟内存设置

5.3 注册表优化设置

5.4 Windows XP 瘦身有术

5.4.1 删除不必要的Windows组件

5.4.2 取消休眠功能

5.4.3 删除驱动程序备份

5.4.4 取消系统文件备份

5.4.5 优化“视觉效果”设置

5.4.6 铅华洗尽的Windows XP

5.5 应用程序优化

5.5.1 把优化进行到底──Windows优化大师

5.5.2 哈立波特的魔法衣——超级兔子魔法设置

实例1:向资源管理器“讨回”移动硬盘

实例2:输入法里的烦恼,都是CTFMON惹的祸

实例3:开机后自动进入system32系统文件夹问题的解决

实例4:神秘的自启动程序都藏在哪儿？

实例5:Windows XP自作主张关机重启

实例6:关机的故障解决与技巧

实例7:运行自己创建的命令行

实例8:节省系统资源新方案—上网一键通，下线一键关

实例9:通过注册表进行系统内存优化

实例10:木马引起的应用程序关联错误

问答·技巧

第6章 网络设置和应用

6.1 配置Windows 98/Me对等网

6.1.1 网络协议的配置

6.1.2 设置文件共享

6.1.3 设置打印机共享

6.2 配置Windows 2000/XP对等网

6.2.1 网络协议的配置

6.2.2 设置文件共享

6.2.3 设置打印机共享

6.2.4 共享网络资源

6.3 共享数据的安全

6.3.1 共享文件夹的隐藏

6.3.2 共享文件夹的加密

6.3.3 共享文件夹的访问控制

6.4 SOHO和家庭网络共享Internet接入

6.4.1 共享Internet网络的连接

6.4.2 将 Windows 98/Me/2000/XP设置为ICS服务器

6.4.3 Windows 98/Me/2000/XP客户端的设置

6.5 对远程计算机的控制

6.5.1 远程控制的功能和应用

6.5.2 Windows XP远程桌面

6.5.3 远程桌面的实现

6.5.4 对内部网络计算机的控制

实例1:全面解决邻里不合──局域网经典故障解决

实例2:一招实现远程唤醒与远程关机

实例3:相约局域网，大片共欣赏

实例4:远程创建/删除FTP服务

对等网络常见故障的解决

第7章 系统高手之多媒体篇

7.1 音频播放

7.1.1 Windows系统之音频相关功能概述

7.1.2 Windows Media Player 音频功能的设置和优化

7.1.3 相关组件

7.1.4 音频娱乐 实例篇

实例1:让音乐更加动听

实例2:酷一族——播放OGG、APE音乐

实例3:连通四海收听——网络电台

实例4:打造你的音乐专辑

实例5:制作CD音乐盘

实例6:CD瘦身进硬盘

实例7:录制声音

7.2 视频播放

7.2.1 Windows 系统视频功能概述

7.2.2 Windows Media Player 视频功能的设置和优化

7.2.3 相关多媒体组件介绍

7.2.4 视频娱乐 实例篇

实例1:播放DVD

实例2:武装Windows Media Player，欣赏DVDrip大片

实例3:播放RM、RMVB影片

实例4:让影片效果更完美

实例5:数码吧——制作电子相册

实例6:DV吧——制作属于你的视频

实例7:在网络上发布自己的视频作品

7.3 图形图像处理

7.3.1 相关功能和组件介绍

7.3.2 数码相片的导入和编排

7.3.3 查看数码相片的拍摄信息

附录 BIOS相关设置

1.1 BIOS知识点滴

1.1.1 认识BIOS与CMOS

1.1.2 BIOS如何工作

1.1.3 BIOS设置的作用

1.1.4 BIOS设置程序简介

1.2 BIOS设置经典案例

1.2.1 检测篇

1.2.2 提速篇

1.2.3 防护篇

1.2.4 应用篇

1.2.5 故障排除篇

1.3 升升不息——升级BIOS

1.3.1 升级主板BIOS

1.3.2 升级显示卡BIOS

1.3.3 升级光驱、刻录机、DVD光驱Firmware

1.3.4 升级Modem Firmware

1.3.5 升级数码相机 Firmware

1.3.6 升级 MP3播放机Firmware

1.3.7 升级笔记本电脑 BIOS


3

3.1.1 软件故障的排困解难

祖国医学讲究“望、闻、问、切”四字诀，对于Windows XP，我们也可以对其进行“望、闻、问、切”。尽管Windows的问题不少，但是常见病无非也就是以下三大类。

1．系统资源不足

Windows从98、2000升级如今的XP，尽管功能、稳定性得到了很大的提升，但是同时系统资源消耗也很大。尤其是还在用着古董型机器的朋友，往往会整个系统就象老牛拉破车一样，其慢无比。任何一个鼠标、键盘操作要等半天才有反应。桌面上程序的界面就好像被毁容了一样，惨不忍睹。更有甚者，系统就干脆来个蓝屏，彻底瘫痪，任你千呼万唤，就是不出来，只好重新启动了事。

解决方法除了进行软件优化（参见本书前面的XP优化章节）外，最彻底的方法就是升级硬件了，而升级硬件无非就是升级CPU（考虑主板的支持）、内存和硬盘了。为了把钱用在刀口上，我们应该确定哪个部件才是整个系统的瓶颈。这里介绍如何用Windows XP自带的“性能”控制台来找出整个系统的薄弱环节。

要访问Windows XP自带的“性能”控制台，可以进行以下操作步骤：

（1）单击“开始”菜单→“运行”菜单项，即可打开“运行”对话框；

（2）在“运行”对话框里输入perfmon.msc并回车，即可打开“性能”管理单元窗口，如图3-1所示。

图3-1 “性能”控制台

可以看到里面默认有三个计数器，分别监视这三个设备参数：

（1）％Processor Time：测试CPU响应系统请求所化的时间百分比。

（2）％Pages/Sec：每秒钟发生的页面错误的次数，也就是所请求的页不在内存中，而需要到硬盘里去读取的计数。

（3）％Disk Time：硬盘忙于为读或写入请求提供服务所用时间的百分比。

除了这三个默认的计数器之外，我们还可以添加别的计数器，以得到更加详细的性能评估结果：

（1）单击如图3-1所示窗口右侧的“添加”按钮 [image] ，即可打开如图3-2所示的“添加计数器”对话框；

图3-2 添加计数器

（2）在“性能对象”下拉列表框里指定所需检测的性能对象，并选定某个或者全部适用的计数器，然后单击“添加”按钮；

（3）继续添加计数器，最后单击“关闭”按钮关闭对话框。

现在“血检化验单”已经出来了，但总得读懂它呀，这样才能找出系统性能瓶颈的所在。下面对所监视的性能对象作分别阐述：

（1）处理器：通常不会成为系统瓶颈。可以用一些比较耗处理器的活动来验证一下，比如说打开一个3D的屏幕保护程序（或者干脆运行一些CPU测试工具），可以看到“％Processor Time”计数器迅速达到峰值。如果“％Processor Time”计数器经常大于80％才会考虑可能有处理器瓶颈，如果Interrupt/Sec计数器经常高于3500，则要考虑可能是程序或硬件有问题，以至于产生大量的“伪中断”。

（2）内存：最有可能造成系统瓶颈，如果内存容量太低，则需要经常读写硬盘，大家都知道，硬盘速度远低于内存，从而导致整个系统性能低下。可以用一些活动来验证，比如说打开一个WORD文档，然后关闭再打开，可以发现第一次打开时，“Pages/Sec”计数器达到峰值，第二次则要低得多，这是因为首次打开WORD文档需要从硬盘读取，而第二次则只需从内存读取，前后两次的Available Mbytes计数器值应该差不多。如果Available Mbytes的值经常小于4兆，则需要增加内存，而Pages/Sec的值应该小于20，最好是在4到5之间（看看你的电脑，是不是这个数值？）。

（3）硬盘：可以用一些引起磁盘活动的事件来验证，比如说在不同分区之间粘贴、拷贝一些文档，如果％Disk Time计数器的平均值小于90％、而Avg.Current Disk Queue Length计数器的平均值小于2，则说明没有对硬盘产生过量请求。

使用“性能日志与警报”，还可以连续监视一段时间系统性能的变化，还可以设置当某一监视对象的计数器达到阀值时发出警报。有了“性能”控制台，相信大家一定可以用最少的钱获得最大的性能！

2．系统文件破坏

尽管微软吹嘘Windows XP是有史以来最稳定的视窗操作系统，这话倒不是在夸张，因为Windows XP采用了系统文件保护机制。然而，Windows XP并非固若金汤，尽管不象它的前辈Windows 98一样经常板个“蓝脸”给你看，但是一旦摊上了这种倒霉事也不是闹着玩的。常见问题有：

（1）丢失了重要的系统文件，比如一些动态链接库文件等，造成系统不稳定。

（2）有些朋友为了节省磁盘空间，用sfc /PURGECACHE清空系统文件保护缓存，从而导致系统文件被误删、替换等。

我们可以在DOS命令行窗口输入“SFC /scannow”命令并回车对当前的系统文件进行扫描，并根据屏幕提示插入Windows XP安装光盘。一旦发现哪个文件的数字签名被破坏，即可进行恢复。

如果知道哪个系统文件被破坏，还可以用“系统配置实用程序”来提取指定的文件，比如说查出系统文件Cfgmgr32.dll（位于C:\WINDOWS\System32\目录）丢失了，可以采用以下方法进行恢复：

（1）单击“开始”菜单→“运行”菜单项，即可打开“运行”对话框；

（2）在“运行”对话框里输入msconfig.exe并回车，即可打开“系统配置实用程序”窗口；

（3）切换到“常规”标签页，然后单击“展开文件”按钮；

（4）在弹出的“从安装源位置展开一个文件”对话框里，在“要还原的文件”文本框里输入文件名cfgmgr32.dll，在“还原自”文本框里输入安装光盘路径“X:\I386”（此处的 X用光驱盘符代替），在“保存文件到”文本框里输入文件的还原位置“C:\WINDOWS\System32”，然后单击“展开”按钮即可。

图3-3 用msconfig提取系统文件

3．注册表破坏

Windows XP的注册表被破坏主要发生在手动修改注册表的时候，大家知道Windows XP的注册表编辑器的功能很弱，其自带的备份/恢复功能并不尽如人意，所以我们必须借助本书第二章所介绍的方法对注册表进行备份，除此之外，还可以利用一些第三方注册表编辑器，这里给大家推荐一款Resplendent Registrar。

除了具有更强的搜索、拷贝、粘贴、拖曳功能之外，Resplendent Registrar还可以像Microsoft Office一样可以撤销以前的操作。每一次创建、删除注册表键值的操作都会被Resplendent Registrar记录。单击程序窗口上的“撤销”菜单→“撤销历史”菜单项，即可打开“撤销历史”对话框，在这里我们可以看到以前所作的每一步修改，如果想要恢复，只需单击工具栏上的“撤销”按钮即可。

图3-4 撤销先前所作的注册表修改


3

3.2.1 Windows XP系统还原

还记得《大话西游》里的月光宝盒吗，有了它就可以回到从前，所有的灾难都好像从来没有发生过。现在Windows XP里“系统还原”功能就起到月光宝盒的作用。它可以撤消掉对系统的有害操作从而返回到一个正常的状态下，同时又不会丢失个人文件！

1．几种不同的还原点

还原点实际上就是建立一个系统快照（SnapShot），当系统出现严重问题时，可以轻松恢复到创建系统快照时的状态。在以下七种情况下，Windows XP会自动创建为我们创建还原点：

（1）初始系统还原点

将Windows XP迎娶进我们的计算机后，就会自动创建该还原点。选择该还原点可以将操作系统和程序还原到最初状态。

（2）系统检查点

该还原点会每隔24小时自动创建（超过24小时则在下次启动计算机时创建），而不管系统有没有更改。

（3）程序安装还原点

当用 InstallShield 和 Windows XP 安装程序等最新的安装程序安装一个程序时，会自动创建一个还原点（以该程序为名）。可以用这些还原点将计算机还原到安装那个程序之前的状态。

注意：

一些老的应用程序不能自动触发Windows XP创建还原点，我们必须手动创建还原点。

（4）自动更新还原点

如果使用Windows XP的自动更新功能来接受下载的更新，则“系统还原”会在安装更新软件之前创建一个还原点。

（5）还原操作还原点

还原操作本身也有还原点。这样我们可以使用这些特殊的还原点来撤销以前的还原操作。

（6）未标记的设备驱动程序还原点

微软建议用户最好只安装经过WHQL（Windows 硬件质量实验室）认证的设备驱动程序，如果将未经WHQL验证的驱动程序安装到计算机上，Windows XP就会自动创建还原点。这样一旦系统发生了问题就可以将计算机还原到安装驱动程序之前的状态。

（7）备份恢复还原点

当用备份工具执行恢复时，“系统还原”会立即在过程开始之前创建一个还原点。如果备份恢复导致计算机出错，则可以将计算机还原到执行恢复前的状态。

2．手工创建还原点

尽管Windows XP会替我们自动创建还原点，但是有时候还是需要我们自己创建还原点。创建还原点时需要注意必须是在系统稳定的时候，并且确保系统没有感染病毒、木马，否则恢复的时候就会把这些“糟粕”也带回来！下面介绍如何手工创建还原点。

（1）依次进入“开始”菜单→所有程序→附件→系统工具→“系统还原”菜单项，打开系统还原向导。

（2）在其上单击“创建一个还原点”单选框，即可出现如图3-7所示的页面。我们只需要对该还原点进行命名就行了，注意为了今后选择还原点的方便，这里最好不要胡乱命名一下了事，应该以具体事件进行命名，例如刚安装了一个硬件、应用程序等；；

图3-7 命名还原点

（3）单击“创建”按钮即可看到如图3-8所示的完成页面，单击其上的“关闭”按钮，即可成功创建还原点。

3．释放磁盘空间

系统还原功能很实用，等于给我们的Windows XP吃了一颗“定心丸”，但是这一切都是以牺牲系统资源为代价的！系统还原使用最多达12％的磁盘空间！每个分区根目录下的“System Volume Information”文件夹就是系统还原所使用的工作目录，这个目录常常会占据数百MB、乃至上GB的磁盘空间。单击“系统还原向导”页面左侧的“系统还原设置”命令，可以重新设置系统还原所使用的磁盘空间，还可以关闭除C盘外所有驱动器的系统还原功能。

还可以通过删除所有其他还原点（除了最近的一次还原点以外），来释放更多磁盘空间。有两种方法，一种是利用Windows XP自带的磁盘清理组件，还一种是直接进入系统还原所使用的工作目录“System Volume Information”进行操作。

（1）磁盘清理

利用Windows XP自带的磁盘清理组件，我们可以删除所有的还原点，除了最近的一次还原点之外：

Step1：依次单击“开始”菜单→所有程序→附件→系统工具→“磁盘清理”菜单项，在弹出的“选择驱动器”对话框里，选中C盘。

Step2：然后单击“确定”按钮，打开磁盘清理对话框，并切换到“其它选项”标签页，单击底部“系统还原”部分的“清理”按钮，然后回车即可，如图3-9所示。

图3-9 清理老的还原点

（2）直接操作系统还原的工作目录

系统还原的工作目录位于所在分区的根目录下的“System Volume Information”文件夹，该文件夹具有系统、隐藏属性，而且缺省只有System权限才可以访问。这里我们介绍一款超强的第三方文件管理器Total Commander 6.01汉化版，利用它可以轻松显示隐藏文件，同时只需轻点鼠标，即可更改目录的权限设置！这里以C:\ System Volume Information为例进行介绍。

Step1：用Total Commander 6.01汉化版打开C盘根目录，即可看到其下的System Volume Information文件夹。如图3-10所示，可以看到该System Volume Information文件夹具有hs属性。

注意：

h：hide，代表隐藏属性；s：system，代表系统属性。

图3-10 System Volume Information文件夹

Step2：为了查看、修改C:\ System Volume Information文件夹的内容，我们必须“夺取”该文件夹的权限，对于Total Commander，是小菜一碟！很简单，依次单击“网络”命令→NTFS权限设置→“取得所有权”菜单项，如图3-11所示；

图3-11 单击“取得所有权”菜单项

Step3：即可弹出如图3-12所示的对话框，单击其上的“取得所有权”按钮，然后根据屏幕提示依次进行操作即可让管理员组的帐户获得对该文件夹的所有权。

图3-12取得所有权

Step4：现在可以进入C:\ System Volume Information文件夹了，可以看到其下还有类似于_restore{8C21D936-1AD0-4DE0-A8AB-0EAB6136AA60}这样的子目录，其下便是当前系统拥有的还原点，如图3-13所示。可以根据需要删除其中任意的还原点，以节省磁盘空间。

图3-13 删除任意还原点

4．安全模式下的系统还原

如果无法正常进入Windows XP环境，自然也无法使用Windows XP的系统还原功能。不过我们可以进入安全模式，然后使用系统还原功能恢复到先前的稳定状态。

（1）开机引导计算机时，按F8键进入“Windows高级选项菜单”，如图3-14所示，然后选中“安全模式”并回车；

图3-14选中“安全模式”

（2）进入安全模式后，选择adminisrator帐户，并键入合适的密码进行登录，如图3-15所示；

图3-15选择adminisrator帐户

（3）然后系统会弹出消息框，提示可以单击“否”按钮启用系统还原功能，单击“否”按钮即可打开系统还原窗口。

（4）在打开的系统还原窗口单击“下一步”按钮，接下来选择一个合适的还原点，如图3-18所示，然后单击“下一步”按钮；

图3-18 选择合适的还原点

（5）然后系统会显示本次还原的一些详细事项，根据屏幕提示，一路回车，很快即可开始系统还原；

（7）系统还原结束后，计算机自动重新启动，进入桌面之前，会显示恢复完成的详细信息，单击其上的“确定”按钮，即可完成本次系统还原。

5．命令行下的系统还原

如果系统已经崩溃，连安全模式也无法进入，但能进入“带命令行提示的安全模式”，如图3-14所示。我们可以在命令行提示符后面输入“C:\windows\system32\restore\rstrui”并回车（实际输入时不带引号），也可打开系统还原窗口，如图3-20所示。接下来的操作不再赘述。

图3-20带命令行提示的安全模式访问系统还原


4

4.2.4常见存储介质CD、CD-R、CD-RW、U盘和数码相机内存卡的修复

这里所说的保存介质是指便携式的保存介质，例如我们常说的光盘，CD、CD-R、CD-RW，还有U盘，以及使用比较多的数码相机的内存卡，这些在我们日常的工作中使用频率比较高，因此，一旦出现问题，就会有数据丢失，无法挽回，造成损失。这往往是让人非常心痛的。其实，对于这些无法读取的重要的数据，并非完全无无能为力，借助第三方软件，我们是可以发挥“回天之力”的。

一）故障出现的主要原因

在介绍如何挽回数据之前，我们先分析一下对于上述的几种存储介质而言，如果出现数据无法读取，都有哪些主要的原因。

1. CD、CD-R、CD-RW

光盘的数据和文件读取不出来，或者光盘已经不能被识别，排除是因为某些光驱对盘片比较“挑剔”的原因以外，有几个主要的原因：

1）光盘的表面有污渍

当光盘沾染到一些污渍，例如灰尘、油渍等等，光盘内的文件就有可能无法读取。用专门的无尘纸擦拭就可以解决，如果污渍比较顽固，可以稍微站一点酒精进行擦拭。而平时清洁所用的一些洗涤剂是不可以用的，它们内含酸或者是碱性物质，对于光盘的表面有腐蚀作用，会更加深光盘的损害。

2）光盘有损伤

这可能是非常常见的原因，而且通常比较明显，有时候在光盘表面就可以看到有划痕和刮伤。

3）光驱温度过高

如果你的光盘在刚刚开始用的时候可以读取，使用正常，而在连续使用一段时间以后却无法读取光盘了，有可能是因为光驱在连续工作以后温度过高，以致无法读取光盘。

4）光驱的读写头脏了

使用一段时间以后，光驱的读写头有可能脏了，也会造成无法读取光驱。读写头因为在光驱的内部，不好作清洁，只有把光驱的外壳拆下来，用棉签站酒精擦拭读写头。反复多擦几次，会有效果。

2. U盘和USB设备

自从1998年USB接口出现以来，非常迅速地普及开来，几乎所有的新的机型都配备了USB接口。尤其是在U盘或者称为闪盘以其体积小、携带方便，而且它128MB或者256MB的容量，也能够满足日常操作的需要。因此迅速成为存储介质的主流，取代了ZIP盘和很多以前出现的类似存储介质。尽管 U盘的可靠性比较高，但是有时也会出现无法读取的情况。如果出现这种情况，排除没有插好的情况以外，主要的原因有几个：

1）没有安装或者安装了不正确的驱动程序。对于Windows 而言，不同版本会存在一些差异，对于Wiindows ME、Wiindows 2000/XP来说，系统一般都带有相应的驱动程序，因此可以放心使用，而Wiindows 98的兼容性差一些，需要使用U盘自己带的驱动程序，才可能正常使用。如果是这种情况，表现为系统显示没有找到U盘。

2）USB端口出现了问题，虽然这种几率不太高，但还是有可能的，可以换一个端口试试。

3）U盘或者文件有部分损坏，无法读取文件。

3. 数码相机的内存卡

数码相机获得越来越多的人的青睐，因此如果数码相机出了问题，可是会损失多多，那么多美好的瞬间就会稍纵即逝。所以数码相机的内存卡一定要妥善保管。内存卡现在很多，不管是CompactFlash卡，还是MemoryFlash卡，或者是SmartMedia卡，都需要提过计算机处理保存，因此，在读入过程中就可能出现无法读取的情况。如果出现这种情况，可能的原因和U盘一样：驱动程序不正确或者没有安装，USB端口有问题，或者是内存卡或者损坏。

在发现文件无法读取以后，要先确定一个问题，是存储介质出现问题还是文件被损坏了？如果介质上的文件还能够复制到其他存储介质上，只是文件无法打开，那么说明是文件受到损坏，如果文件不能打开，也不能复制到别处，则说明有可能是存储介质被损坏，出了问题。所以第一步，要迅速确定你面临的问题是下面两种情况中的哪一种。

1. 修复受到损坏或者被删除的文件

2. 修复受到损坏的介质中的文件

二）修复文件和存储介质

正如前面所述，要解决上面的问题，仅仅靠系统自身提供的工具是无法完全解决的，在这里，我们推荐一个第三方软件，BadCopy pro 3.75。这个软件是一个使用简单、功能强劲的数据修复工具，它可以恢复多种存储介质中的数据，包括软盘、光盘、USB、ZIP盘、数码相机的CF卡等等。

下面我们按照前面说的两种情况来一步一步来操作。

1. 文件已经被删除或者光盘被严重损坏已经完全不可读

采用BadCopy的恢复模式：Rescue Lost Files－Mode #2

首先，运行BadCopy。

1）出现第一个窗口，图7-2-1 。在窗口左边是软件可以修复的介质的类型，我们选择CD-ROM,CD-R/W；选择要进行修复的光驱所在的盘符；在修复模式recovery Mode一栏选择“Rescue Lost Files－Mode #2”单击“next”。

图7-2-1 BadCopy的主窗口

如果是数码相机内存卡，存储介质选择“Digital Media CF/SM/MMC”。

如果是U盘，存储介质选择“Other Media &Storage”，然后在盘符中选择U盘所在的盘符。这种方法也可以用于挽回其它盘符如硬盘中的数据。

2）出现第二个窗口，图7-2-2。说明修复回来的文件会暂时命名为file1，file2等。可以在保存的时候另外命名。同时说明，除了你希望恢复的文件，可能还会有另外的文件被恢复，包括已经被删除的文件。单击“OK”。

图7-2-2 修复模式的说明

3）出现第三个窗口，单击“start”开始恢复文件。

4）出现第四个窗口，如图7-2-3。单击“scan range”选项，勾选“Full scan”全面扫描，单击“start”。

图 7-2-3 扫描文件

5）出现第五个窗口，如图7-2-4。开始察看已经被删除的文件。被找到文件显示在中间的文件框内。完成后单击“next”。

图 7-2-4 显示被挽回的文件列表

6）出现第六个窗口，如图7-2-5，Recovery Reprot一栏中列出已经被恢复的文件，选择其中的某一个文件，按下“Browse”按钮，选择一个盘符和文件夹将挽救回来的文件保存到该处。单击“next”。

图7-2-5 选择文件夹保存被修复的文件

7）出现第七个窗口，如图7-2-6，开始保存，如果是试用版，则无法保存，很遗憾！保存结束，关闭窗口。

图7-2-6 保存文件

几个注意事项：

有可能希望挽回的被删除文件已经被之后新复制的文件覆盖，这样便无法恢复。

Badcopy不能完全识别所有文件的类型和格式，因此可能出现将这些文件视为EXE文件的可能。

2. 修复受到损坏的介质中的文件

这次我们以U盘作为例子介绍。首先，运行BadCopy。

采用BadCopy的恢复模式：Rescue Corrupted Files。这种模式适合存储介质的部分损坏，也就是说在读盘的时候仍然可以读出，只是部分文件无法读取。如果存储介质损坏严重，根本无法读出，即使你选择Rescue Lost Files－Mode #2方式恢复，软件也会提示你损坏严重，建议选择另一种恢复模式，见前面“文件已经被删除或者光盘被严重损坏已经完全不可读“。

出现的第一个窗口，左边的恢复来源中选择“Other Media &Storage”，然后在盘符中选择U盘所在的盘符I。这种方法也可以用于挽回其它盘符如硬盘中的数据。如图7-2-7 。

图7-2-7 选择被恢复的存储介质

出现第二个窗口，中间的文件框列出了当前I盘中所有的文件，选择那个你无法读出的文件名，在“Recovery Option”中选择“Max Data”，单击“Next”，如图7-2-8。

图7-2-8 选择修复相关的设置

出现第三个窗口，显示当前的恢复进程，如图7-2-9。

图7-2-9 修复进程

出现第四个窗口，显示所有恢复回来的数据。如图7-2-10，单击“Next”。

图7-2-10 显示修复的数据

出现第五个窗口，一个一个地选择恢复回来的文件，分别保存到你选择好的位置。如图7-2-11，单击“Next”。

图7-2-11 选择文件夹保存被修复的文件

7）出现第六个窗口，开始保存，如果是试用版，则无法保存，很遗憾！保存结束，关闭窗口。


4

4.2.5 常用邮件、图片、影像、ZIP、MS Office、声音文件的修复

现在人们越来越多使用电子邮件进行联系，所以电子邮件包含了很多非常重要的个人信息，一旦出现问题，无法打开，损失非常大。因此，掌握一些关于修复故障邮件的办法非常重要。

这里向大家推荐一款非常好的数据修复软件FinalData，具有非常强的修复功能，能修复包括文件分配表FAT、主引导记录MBR、引导扇区、MS Office 文件、影像文件、邮件等对系统和对我们日常工作非常重要的信息。FinalData是一个商业软件，功能最强的是它的企业版，比其它版本对了对于MS Office 文件和邮件的恢复功能。它的下载地址是：http://www.FinalData.com/

因为FinalData是一个具有非常强劲功能的综合软件，因此在本书的很多修复方式都会涉及它，讲述相关的修复方法。

首先，运行FinalData 2.0 企业版，主界面如图 7-2-12。从界面上的主菜单中可以看到有“Office File Recovery”和“Email Recovery”两项，说明软件提供了对于Office文件和邮件的恢复功能。下面我们分别从几类常见的文件如何修复进行讲解。

图 7-2-12 FinalData的主界面

1.邮件文件的修复

第一步，单击“Email Recovery”，选择“Start Email Recovery”，选择所修复的邮件所在的驱动器和文件夹，例如“C:\Program Files\Outlook Express\”，如图 7-2-13，单击“OK”。开始查找所有被删除的邮件。

图 7-2-13 确定需要修复的邮件文件

第二步，查找结束，出现下一个窗口，把窗口的“END”滑杆拉到最右边，获得恢复的最大值，如图 7-2-14，单击“OK”。

图 7-2-14 选择查找范围

第三步，开始扫描之前删除的邮件文件，如图 7-2-15。

图 7-2-15 扫描被删除的文件

第四步，确定你要修复的邮件软件，从邮件文件列表中选择要恢复的邮件文件，因为从列表上看不出邮件的具体信息，无法确定是否恢复。因此，选定一个文件，单击鼠标右键，选择“Recover Message”，以便查看邮件内容。

第五步，邮件文件的列表显示出来，如图 7-2-16。选择一个邮件，单击“view message”，以便查看邮件内容。用同样的方法一个一个地查看文件。

图 7-2-16 显示被删除的文件列表

第六步，提过查看邮件的内容，确定需要恢复的邮件，然后单击“Recover”按钮，在随后出现的窗口中选择保存邮件的文件夹，但不要在删除以前所保存的位置，开始恢复。

第七步，进入Outlook Express，打开刚才所保存的文件，在再次查看邮件信息是否正确，如果确实无误，单击菜单“打开”中的“移动到文件夹”，接着选择“收信箱”，单击“确定”，将刚才的邮件恢复到原来的收件箱。

这样，一个邮件文件就被恢复了。

2. MS Office 文件的修复

第一步，在FinalData的主界面，单击图标栏的第一个图标或者在菜单“file”中选择“open”，在随后出现的窗口中选择目标驱动器。

第二步，开始扫描磁盘相关数据，将选择范围调至最大，如同上例，如图 7-2-17。

图 7-2-17 扫描范围调至最大

第三步，开始查找已经被删除的文件和文件夹。然后显示查找结果，如图 7-2-18。

图 7-2-18 显示查找结果

第四步，选择要修复的文件，然后根据这个文件的类型从菜单项“Office File Recovery”中选择对应的恢复项目，例如Word文件对应菜单选项是“Microsoft Word File Recovery”，其他的菜单选项还有Powerpoint和Excel。

随后出现的窗口显示该文件的基本数据，单击“下一步”，出现文件损坏程度检查窗口，单击“check rate”检查文件损坏程度，显示在右边的小窗口，窗口下部是对于损坏等级的说明，如图 7-2-19，单击“下一步”。

图 7-2-19 显示文件被破坏的等级

第五步，出现保存窗口，选择文件夹保存这个文件，勾选“Recover All Format”，单击“Start Recovery”，如图 7-2-20，开始恢复文件。

图 7-2-20 保存修复的文件

第六步，检查一下恢复以后的文件，是否信息完全正确。

3.影像文件的修复

常用的影像文件格式有DivX、AVI、ASF、WMV、WMA、RM等，而这些文件的恢复需要专门针对图像文件的修复软件Video Fixer，但是MPEG格式的文件无法用Video Fixer修复，可以用前面介绍的FinalData修复。

运行Video Fixer，单击窗口左侧的第一个按钮“Add”添加要修复的影像文件，然后单击“fix”修复，窗口下方会显示修复信息和进度，如图 7-2-21，最后如果修复成功就保存起来。

图 7-2-21 显示修复影像文件的进度

4.修复MPEG1和MPEG2文件

修复修复MPEG1和MPEG2文件仍然用FinalData，而且在选择需要修复的文件驱动器和扫描、查找方式都和修复Office文件类似，只是在选定要修复的文件以后，针对文件类型选择修复方式时，要单击 “Tools” 下的菜单项“Recover a file Partially Damaged”的子菜单“Recover MPEG File”，如图 7-2-22。其余过程和修复Office文件一样。

图 7-2-22 选择修复的文件类型

5. 修复ZIP文件

为了节省空间，常用压缩文件的形式保存文件。而压缩文件如果出现故障，无法打开，就会造成数据损失。压缩软件本身没有提供修复功能，因此必须借助第三方软件。在这里我们推荐ZIPRepair。它修复压缩包的方式很简单，将原来无法打开的文件包中可以正常使用的数据单独拿出来另外存为一个文件，而且使用简单至极，只要单击界面窗口的“Repair Zip File”按钮，然后选择要修复的ZIP压缩包，随即开始修复，如图 7-2-23。

图 7-2-23 修复ZIP文件

6. 常见图片文件的修复

大多数人的机器中都存储有很多精美的图片，可能是自己到处精心搜集的，或者是用数码相机拍摄，让美好的赏心悦目的瞬间感觉成为永恒。但是图片文件和其他类型的文件一样，一个误删除，或者数码相机的内存卡出现一些问题，都会让这些美丽的图片瞬间消失。所以你也需要有一个针对这些图片文件的修复工具，有备无患。

这里向大家推荐的是Photo Recovery，以前是一个免费软件，叫做Digita Image Recovery，现在开始收费了。这可是一个功能非常强劲的修复工具，能够修复很多类型的内存卡，包括Flash Card、SmartMedia、SONY Memory Stick、IBM Micro Drive、Multimedia Card、Secure Digital Card 以及 Compact disc，而它能修复的图片文件类型包括：

图片，有JPEG、exif、TIFF、PNG、GIF、BMP、Canon CRW；

音乐影像文件，AVI、MOV、WAV。

Photo Recovery修复图片文件的唯一前提是需要把数码相机的内存卡作为一个独立的驱动器。

Photo Recovery使用非常简单，运行它并找到数码相机内存卡所在的盘符，确定要修复的文件，单击“START”，然后就是耐心等待修复结果了。

下载地址：http://www.le-tech.com/

Photo Recovery也有一个令人遗憾的地方，无法修复因为数据写入时数码相机断电所导致的数据丢失。因此我们另外推荐一个软件ImageRecall Lite Edition。这个软件专门修复内存卡因为读取错误而无法读取文件的情况，针对数码相机内存卡特有的问题进行修复。

下载地址http://www.imagerecall.com/


5

5.4 Windows XP瘦身有术

给Windows XP减肥并不是很复杂，有了给Windows 9X/2000做“手术”的经验，相信大家很快就能够上手。那么还等什么，难道还想让你的硬盘继续忍受它的折磨吗？不过，最好GHOST 2003做一个系统克隆，万一Windows XP被我们庸医误治，还可以吃回头草。

5.4.1 删除不必要的Windows组件

在Windows XP里呆得时间长了，还真有点怀念以前Windows 98的日子。它虽然简陋了些，毕竟我们对它的组件掌有“生杀大权”。不但可以在安装时选择诸如“典型”、“最小”等安装类型，如果不满意还可以在安装之后在“添加/删除程序”里进行增删。而到了Windows XP，我们的这些权利几乎全被剥夺了。在安装的时候，安装程序根本不会征求我们的意见，就把所有的组件全部灌到我们的硬盘里。以后想删除？没门！虽然Windows XP“装模作样”地设置了一个“添加/删除Windows组件”的功能，但是真正重量级的Windows组件，我们根本奈何它不得！

下面就教大家一个“妙门”，保准让这些隐藏组件个个显出原形！

要想让隐藏组件现形，得借助一位隐秘高人的帮忙，这个隐秘高人就是sysoc.inf文件。要请它出山，首先得知道它的“隐居”之所。原来它位于C:\Windows\inf文件夹下，具有隐藏、系统属性，无法直接找到它。不过好办，可以用winrar让它现出原形……

用winrar打开C:\Windows\inf目录，即可看到其下的sysoc.inf文件，如图5-35所示。

图5-35 借助winrar看到隐藏的sysoc.inf文件

这样我们就可以拿到进入C:\Windows\inf文件夹的“通行证”了，找到该sysoc.inf文件，先别急着对它“动手术”，应该备份一下该sysoc.inf文件，以免到时候“手术”失败，还有后悔药可吃。

双击该文件，即可用记事本打开sysoc.inf文件，然后单击“编辑”菜单、“替换”菜单项，即可打开替换对话框。在“查找内容”文本框里输入“hide”（不加引号），在“替换为”文本框里留空，然后单击“全部替换”按钮，如图5-36所示。这样该文件里的所有“hide”都会被删除。

图5-36 删除sysoc.inf里的hide

接下来别忘了保存修改后的文件，然后我们就可以让哪些光占地盘不干活的主儿“下岗”了，步骤如下：

单击“开始”菜单→控制面板→“添加或删除程序”菜单项，然后在打开的对话框上单击左侧的“添加/删除Windows组件”按钮，即可打开如图5-37所示的“Windows组件向导”对话框。

图5-37 Windows组件向导

借助了sysoc.onf这双“慧眼”，现在我们能够把隐藏的Windows组件看得清清楚楚、明明白白了，象什么“MSN Explorer”、“Windows Messenger”等等，都可以把它们扫地出门。

5.4.2 取消休眠功能

随着科学技术的发展，计算机日益成为耗电大户，看看现在的主流的计算机，都是奔腾四＋256MB内存＋80GB/7200转硬盘，再加上显示卡、打印机等耗电大户，乖乖，厉害，难怪现在的P4电源都是300W级的！要从这头“电老虎”的嘴里省出点电费，是非常有必要的。尤其是笔记本电脑，那更加是当务之急─总不想让心爱的本本只用一个多小时就罢工吧？

目前Windows XP所支持的省电模式有两种（当然首先要有BIOS、主板的支持）：一种是挂起到内存（STR：Suspend to RAM），还有一种是挂起到硬盘（STD：Suspend to Disk），就是我们通常所说的休眠功能。

休眠（STD）把当前会话数据存储到硬盘（而非内存）。大家知道硬盘是“不挥发性”的存储器，不需要加电也可以保存数据，所以休眠完成以后可以直接关闭电源（这和睡眠是不同的）。休眠的实质是将当前物理内存的会话数据复制到C盘根目录下的hiberfil.sys文件（具有隐藏属性），同时该文件的大小将和物理内存的大小一样，例如物理内存是512MB，则该文件就要占据512MB磁盘空间（不管是否进行过休眠操作）！

所以，为了节省C盘的磁盘空间，我们应该取消Windows XP默认启用的休眠功能。不过不能直接删除该hiberfil.sys文件（就算是在实模式DOS下删除也不行），应该借助以下步骤：

（1）单击“开始”菜单、“控制面板”菜单项，打开“控制面板”窗口；

（2）在控制面板窗口里单击“性能和维护”任务链接打开“性能和维护”组件窗口，然后在其下单击“电源选项”任务链接；

（3）在打开的“电源选项属性”对话框上，切换到“休眠”标签页，然后确保清空“启用休眠”复选框。

现在回到C盘根目录下看看，那个休眠文件hiberfil.sys应该消失了！

5.4.3 删除驱动程序备份

熟悉Windows 9X的朋友都有这样的经历，有时候更新驱动程序、或者升级硬件的时候，不仅仅需要驱动程序盘，还需要插入Windows 9X的安装盘。这是因为Windows 9X并没有把通用驱动程序拷贝到系统目录，而到了Windows 2000/XP年代，这种情况就成了历史─现在再也不需要插入安装光盘了！然而凡事有利必有弊，由于Windows XP把通用驱动程序拷贝到系统目录，就会占据C盘约75MB的位置，这对于磁盘空间紧张的朋友来讲是一场小小的灾难。

如果不是经常需要升级驱动程序、更新硬件的话，完全可以把驱动程序备份删除，当需要的时候插入安装光盘即可。Windows XP的驱动程序备份位于C:\Windows\driver cache\i386\Driver.cab，直接把这个Driver.cab删除即可（当然也可以把这个文件搬家）。

5.4.4 取消系统文件备份

Windows XP和Windows 2000一样，会把安装时的系统文件备份到“系统分区\Windows\System32\Dllcache”文件夹下面（具有隐藏、系统属性）。这样做的目的是万一有哪个应用程序自作主张把你的系统文件掉包了，系统能够自动、或者让你通过在命令行下打SFC命令手动恢复，如果你不想使用这个功能，也可以让它们走开，方法是在命令提示符下输入SFC /purgecache，方法是：

（1）单击“开始”菜单→所有程序→附件→“命令提示符”菜单项，打开命令提示符窗口；

（2）在命令提示符下输入“SFC /purgecache”命令并回车即可清除系统文件备份。

使用“SFC /?”命令可以获得SFC命令的帮助信息，如图5-39所示。

图5-39 SFC命令的帮助信息

5.4.5 优化“视觉效果”设置

Windows XP相对于Windows 2000，除了多媒体支持更好之外，最重要的变化就是“面目”有了很大的变化，然而这种变化是以极大地消耗系统资源作为代价的！如果老是觉得系统资源不够用，那么就要考虑关闭Windows XP的视觉特效。方法很简单，可以分为两步走：

1．系统属性调整

先是需要在系统属性对话框里设置，关闭所有的视觉特效。

（1）依次单击“开始”菜单、控制面板、“系统”菜单项，即可打开系统属性对话框；

由于Windows XP默认将“控制面板”显示为链接，这对于经常需要修改系统设置的朋友来讲，显得很不方便。所以我们应该让它显示为菜单。

鼠标右键单击任务栏空白处，然后单击弹出菜单上的“属性”菜单项，将会打开一个属性对话框；

单击“开始菜单”选项后的“自定义”按钮，即可弹出自定义对话框，在该对话框上切换到“高级”标签页；

（4）确保选中“控制面板”部分的“显示为菜单”单选框，如图5-40所示。然后依次单击“确定”按钮保存设置即可。

图5-40 控制面板显示为菜单

（2）在打开的“系统属性”对话框上切换到“高级”标签页，单击“性能”框架右侧的“设置”按钮；

（3）在打开的“性能选项”对话框上切换到“视觉效果”标签页，单击其上的“调整为最佳性能”单选框，如图5-41所示；

图5-41调整为最佳性能

（4）如果还要想保留Windows XP的独特风格，则只需单击选中“自定义”单选框，然后确保勾选“在窗口和按钮上使用视觉模式”复选框。为了方便执行目录管理任务，还可以勾选“在文件夹中使用常见任务”复选框。

2．关闭主题服务

如果已经选择“调整为最佳性能”选项，则还可以关闭主题服务（Themes服务），具体方法如下：

（1）在“运行”对话框里输入“services.msc”并回车即可打开服务控制台；

（2）在服务控制台窗口右侧双击Themes服务列表项，即可打开“Themes的属性”对话框；

（3）在“Themes的属性”对话框的“启动类型”下拉列表框里选中“已禁用”列表项，并单击“停止”按钮，然后单击“确定”按钮保存设置，如图5-42所示。

图5-42 禁用Themes服务

这样，下次启动Windows XP，将不会加载Themes服务，整个桌面元素的风格类似于Windows 2000，从而节省了宝贵的系统资源。

5.4.6 铅华洗尽的Windows XP

大凡初学者，总喜欢不加甄选，什么软件都往爱机肚子里灌，生怕爱机患上营养不良之症。反正现在硬盘堪称海量，却忘了“坐吃山空”这四字真言，长此以往，爱机难免会消化不良，于是各种症状纷纷出现，或是爱机慢如牛爬，或是系统死机频仍。不管你用的是爷爷级的Windows 9X，还是当红小生Windows XP，几乎所有版本的Windows都有一个遗传病，就是使用时间长了，系统运行速度就会越来越慢──网上流传着这样一个笑话来夸张Windows速度之慢：鼠标双击某个Word文档，然后上街逛上两圈，等你回来时，这个Word文档才刚打开……

其实没必要样样都要追求大而全，就好像没必要什么场合都穿晚礼服，有时候一件贴肉布衫就够了。同样铅华洗尽的系统比满头珠翠的系统更稳定、更实用。

1．取缔尸位素餐的系统服务

在Windows 2000/XP里，有很多系统服务是随Windows而启动的。在这些系统服务中，有些是不可或缺的关键部分，还有一些是滥竽充数的，留着只会白白浪费内存和资源，影响系统启动速度，而且还可能影响系统安全。下面就以Windows XP为例，就将这些光吃饭不干活的家伙一一“褫其华衮、现其本相”。

Human Interface Device Access：如果没有那些所谓的智能接口设备，那么大胆地禁用它吧。

Messenger：注意这可不是Windows自带的MSN Messenger服务，它是用来传输“Net Send”命令Alerter服务消息的，很多JS就是通过它来向互联网上的用户乱发广告，我们可以坚决禁用它。

Print Spooler：打印机的内存缓冲池机制，没有打印机的话，当然应该禁用。

Remote Registry：为了防止被恶意网页修改注册表，应该禁用它。

Task Scheduler：一般可以禁用它，可以在需要时手动运行某个任务。

Windows Time：主要用于本地机器与Internet时间服务器之间的同步，如果不是对时间特别敏感的人，完全可以禁用它。

Wireless Zero Configuration：无线网络设置服务，如果你没有无线局域网设备，大胆禁用吧。

Automatic Updates：Windows自动更新，一般可以禁用它，当需要的时候可以手动运行更新程序。

IPSEC Services：普通用户很少有机会能够接触它。

SSDP Discovery Service：用来探测家庭网络上的UPnP设备，一般可以禁用它。

System Restore Service：系统还原服务，完全可以禁用。仅当需要的时候再手动运行。

Themes：主题服务，如果可以忍受我们的Windows XP长得和Windows 2000一样“丑陋”，则可以禁用此服务。

当然具体要禁用某个系统服务，还要根据我们的实际情况，具体问题、具体分析。不能不加分析、盲目扩大打击面。否则一旦误伤了关键服务，那可够咱们喝一壶的，而且这种问题还很难被发现。例如有朋友反映说无法正确地访问网页，老是提示无法解析域名，后来一查原来他听信别人的“谗言”，误将有用的“DNS Client”给冤枉“砍杀”了，所以导致无法正常使用ISP提供的域名解析服务！

要禁用某个系统服务，很简单，可以按照以下步骤：

（1）在“运行”对话框里输入“services.msc”命令，按回车键打开服务控制台。

（2）鼠标右键单击某个要禁用的系统服务，此处以“Task Scheduler”为例，然后选择“属性”菜单项。

（3）在打开的属性对话框的“启动类型”下拉对话框里选中“已禁用”列表项，然后单击“确定”按钮即可。

（4）下一次系统启动时，该“Task Scheduler”服务就不会随系统而启动了，如图5-43所示。

图5-43 禁用Task Scheduler服务

2．只求最合适，不求最新潮

很多朋友是狂热的“追新族”，一看到有更新版本的应用程序出来，就会迫不及待地下载升级。由于新的应用程序可能会带来新的Bug（尤其是一些Beta版的测试程序），所以喜新厌旧的结果可能导致系统不稳定。据统计，对于某个工具软件来说，80%的用户只使用其20%的功能，所以在给软件升级的时候，我们要盘算一下，为这些根本用不上的功能付出那么大的代价是否合适。

比如说我们常用的看图软件ACDSee，虽然功能越来越花哨，但是老版本的ACDSee更加实用却是不争的事实。确实相对于新版本的软件，老版本占用的硬盘空间、系统资源更少，功能更加成熟，使用方法也更加熟悉。这样的例子还有Winamp、超级解霸，尽管升级版的功能更加强劲，但还是老版本更具亲和力。

对于硬件驱动这类关键的系统程序，就更加不能草率行事，原因有四：

（1）新版的驱动并不一定针对我们的显卡进行优化。比如显卡是TNT级的芯片，nVIDIA正式声明从12.41版以后的驱动程序不再对TNT作优化！所以对于TNT用户来讲，应该选择12.41版以前的驱动程序。具体选择哪一版，根据权威测试机构的检测，Windows 98用户可以选择3.84版的驱动，Windows 2000/XP用户可以选择11.01版驱动。所谓“桃源虽好终非计”，最新的驱动总是为最新的设备服务的，像我们这样的老显卡就只能看着别人不断的升级而干咽唾沫了。

（2）新版的驱动消耗系统资源更大。笔者自己的Geforce 2MX显卡，原本用的是21.88版的雷管驱动，后来喜新厌旧升级为30.82版的，感觉性能没有什么提高，反而系统资源下降。想想也是新版的驱动为了实现更多的功能，必然容量更大，可惜这些功能大多是专门为新显卡而开发的，老显卡非但享受不到这些功能，反而还要“陪太子读书”，白白浪费那么多系统资源，真是划不来。

（3）新版驱动不一定带来更高的性能。著名的PC游戏杂志《Cgonline》曾经刊登过一篇对Dwight Diercks（nVIDIA软件工程部副总）的访谈文章。大意是nVIDIA一般一年发布两次驱动，开始为了占领市场，新版驱动更加强调稳定性和兼容性，反而会适当降低显卡性能，只有市场稳固了，新版驱动的重点才会放在性能上。所以热衷于榨干显卡最后一滴油水的发烧友们要注意了，在决定更新驱动之前，最好参考一下权威评测机构的测试报告，推荐你参考驱动之家的硬件评测栏目http://hardware.mydrivers.com/。

（4）最新版本的驱动程序不一定通过微软兼容性测试，其稳定性值得怀疑。对于一些古董级的硬件，还是推荐使用Windows自带的驱动程序，其安全性是毋庸置疑的。

综上所述，如果不是硬件发烧友，应该尽量使用微软自带的驱动程序，就是要升级，也应该使用经过WHQL认证的驱动程序。

3．量入而出，不求全责备

很多朋友安装机器的时候，通常会贪大求全，狠不得将所有的系统组件和应用软件都装将进去，从而导致导致资源和硬盘空间的浪费。举一个最简单的例子，很多朋友在安装Microsoft Office的时候，会接受默认值，将所有的组件都请到系统里去，而不会考虑自己是否真正需要这些劳什子。假设你平时不用PowerPoint、Access、Outlook等组件，那么就别让它们霸占硬盘空间，在安装的时候选择“自定义”，指定取消某个组件的安装，图5-44显示不安装Access组件。

图5-44 不安装Access组件

那么如果今后需要某个Office组件，那该怎么办呢？其实并不一定需要重新安装该组件，有时候可以用一个插件来替代它的功能。例如需要观看某个幻灯片文档，但是手头又没有安装PowerPoint，则可以下载一个PPTView程序来替代它的功能。该程序只有2.75MB （http://www.itraining.net.cn/downsoft/ppview97.exe），相对PowerPoint可以说是身材苗条，但是功能却不遑多让，用来观看幻灯片绰绰有余。


6

6.4.2 将Windows 98/Me/2000/XP设置为ICS服务器

1. Windows XP连接共享

Windows XP连接共享的服务透明地运行以支持其他程序，客户端根本感觉不到ICS的存在。从Web、Mail、FTP、ICQ、QQ等各种应用程序，到网上邻居和远程桌面，都跟直接接入Internet完全相同。服务器的功能更加强大，客户端的设置更加简单，而且集成了Internet防火墙（ICF）。

（1）Internet连接共享主机的初次配置

第1步，在“控制面板”的经典视图下，双击“网络连接”图标，显示“网络连接”窗口，如图 6-4-78所示。

图6-4-78 “网络连接”窗口

第2步，在左侧的“网络任务”栏中单击“设置家庭和小型办公网络”超级连接，运行“网络安装向导”，如图 6-4-79所示。

图6-4-79 网络安装向导之一

第3步，单击“下一步”按钮，显示如图 6-4-80所示“继续之前”页，请用户确认已经安装了网卡和调制解调器，网络已经正确连接并能够接入Internet，各设备的电源已经打开。

图6-4-80 网络安装向导之二

第3步，单击“下一步”按钮，显示如图 6-4-81所示“选择连接方法”页。选择“这台计算机直接连接到Internet。我的网络上的其他计算机通过这台计算机连接到Internet”选项。

图6-4-81 网络安装向导之三

第4步，单击“下一步”按钮，显示如图 6-4-82所示“选择Internet连接”页。选择已经能够连接至Internet的连接。通常情况下，采用系统选择的默认值即可，因为Windows已经对Internet连接进行了测试。

图6-4-82 网络安装向导之四

第5步，单击“下一步”按钮，显示如图 6-4-83所示“给这台计算机提供描述和名称”页。通常情况下，可采用默认值。

图6-4-83 网络安装向导之五

如果计算机拥有多个Internet连接，将显示如图 6-4-84所示“你的计算机有多个连接”页面。可选择“代我决定合适的连接（推荐）”选项。

图6-4-84 网络安装向导之六

第6步，单击“下一步”按钮，显示如图 6-4-85所示“命名的网络”页。如果在“工作组名”框中显示的名称与网络中的其他计算机不在同一工作组，应当在此进行修改。

图6-4-85 网络安装向导之七

第7步，单击“下一步”按钮，显示如图 6-4-86所示“准备应用网络设置”页，显示Internet连接设置情况。

图6-4-86 网络安装向导之八

第8步，单击“下一步”按钮，显示如图 6-4-87所示“请稍侯”页，向导开始为这台计算机配置家庭或小型办公网络。

图6-4-87 网络安装向导之九

而后，显示如图 6-4-88所示“快完成了”页，提示需要在网络上的每台计算机上运行一次网络安装向导。如果非Windows XP操作系统的计算机上运行该向导，既可以在这里选择“创建网络安装磁盘”选项，制作一张安装磁盘，然后在其他计算机上运行该磁盘中的netsetup.exe，也可以选择“使用Windows XP CD”选项，直接使用Windows XP安装光盘执行安装。本例选中“使用Windows XP CD”选项。

图6-4-88 网络安装向导之十

第9步，单击“下一步”按钮，显示如图 6-4-89所示“要用Windows XP CD来运行向导”页，提示用户必须使用Windows XP CD在网络上的每一台计算机上运行一次网络安装向导。具体操作为将CD插入欲共享Internet接入的计算机，在出现的CD菜单中单击“执行其他任务”，然后，再在显示的下一个菜单上单击“安装家庭或小型办公网络”。

图6-4-89 网络安装向导之十一

第10步，单击“下一步”按钮，显示如图 6-4-90所示“正在完成网络安装向导”页，单击“Finish”按钮，结束Internet连接共享主机（ICS）的安装。

图6-4-90 网络安装向导之十二

（2）Internet连接共享主机的简单配置

当需要将该计算机作为Internet连接共享主机时，先为其安装并配置好Internet连接。然后，执行下述操作：

第1步，在“控制面板”中双击“网络连接”图标，打开如图 6-4-91所示“网络属性”窗口。

图6-4-91 “网络属性”窗口

第2步，右击直接连接到局域网的连接，在快捷菜单中选择“属性”，显示如图 6-4-92所示“本地连接 属性”对话框。

图6-4-92 “本地连接 属性”对话框

第3步，在“此连接使用下列项目”列表框中选择“Internet协议（TCP/IP）”，单击“属性”按钮，显示“Internet协议（TCP/IP）”对话框。在“常规”选项卡中，确认选中了“自动获得IP地址”和“自动获得DNS服务器地址”两个选项，如图 6-4-93所示。

图6-4-93 “Internet协议（TCP/IP）”对话框

第4步，单击“确定”按钮，返回“网络连接”窗口。

第5步，右击直接连接到Internet的Internet连接，在快捷菜单中选择“属性”，显示如图 6-4-94所示连接属性对话框。

图6-4-94 连接属性对话框

第6步，选择“高级”选项卡（如图 6-4-95所示），选中“允许其他网络用户通过此计算机的Internet连接来连接”复选框，将该连接作为Internet连接，并选中“允许其他网络用户控制或禁用共享的Internet连接”复选框，使客户端可借助于“Internet 连接共享 (ICS) 发现和控制”监视和管理共享的Internet连接。如果计算机安装有多块网卡，在“家庭网络连接”下拉列表中选择到局域网的连接。

图6-4-95 “高级”选项卡

若欲停止该计算机作为Internet连接共享主机，只需取消对“允许其他网络用户通过此计算机的Internet连接来连接”复选框的选中即可。

第7步，单击“确定”按钮，系统显示如图 6-4-96所示IP地址自动修改提示框。提示用户连接到局域网的网卡的IP地址将被设置成为192.168.0.1。

图6-4-96 IP地址自动修改提示框

第8步，单击“是”按钮，ICS设置完成。

2. Windows 2000 Professional连接共享

Windows 2000 Professional的连接共享完全可以与Windows XP的连接共享相媲美，无论是所提供的性能上，还是设置的简便性上。从设置的傻瓜化程度上看，似乎倒是Windows 2000 Professional更胜一筹。

第1步，在“控制面板”中双击“网络和拔号连接”图标，显示如图 6-4-97所示。

图6-4-97 “网络和拔号连接”窗口

第2步，右击用于局域网连接的本地连接，在快捷菜单中选择“属性”，显示如图 6-4-98所示网络属性对话框。

图6-4-98 网络属性对话框

第3步，在“引连接使用下列选定的组件”列表框中选择“Internet协议（TCP/IP）”，单击“属性”按钮，显示如图 6-4-99所示“Internet协议（TCP/IP）属性”对话框。确认该网卡的IP地址信息为“自动获得IP地址”和“自动获得DNS服务器地址”。

图6-4-99 “Internet协议（TCP/IP）属性”对话框

第4步，单击“确定”按钮，返回“网络和拔号连接”窗口。

第5步，选择已建立的Internet连接，单击鼠标右键，在出现的快捷菜单中选择“属性”一项，出现拨号连接“属性”对话框（如图 6-4-100所示）。

图6-4-100 拨号连接“属性”对话框

第6步，选择“共享”选项卡（如图 6-4-101所示），选择“共享访问”下方的“启用此连接的Internet连接共享”选项。若欲实现网络上的任何一台计算机访问外部资源时都能自动拨号（适用于需要拔号的Internet连接方式，如普通拔号、ISDN、ADSL等），可选取“启用请求拨号”一项。如果计算机中安装有多块网卡，应当在“对于局域网”下拉列表中选择用于连接至局域网的本地连接。

图6-4-101 “共享”选项卡

需要注意的是，当授予局域网用户访问Internet权限后，选择“启用请求拨号”复选框非常有必要。其意义在于，当没有用户访问Internet时，过一段时间后服务器可自动切断与Internet的连接，以节省费用。而一旦用户有Internet访问需求，则服务器将立即拨号以实现Internet连接。当然，若欲控制用户对Internet的访问，则不能选择“启用请求拨号”复选框。

第4步，单击“确定”后，弹出如图 6-4-102所示的提示框。提示服务器的IP地址将被自动设置为“192.168.0.1”，要求局域网中的其他计算机的IP地址设置为“自动获得”。

图6-4-102 自动设置IP地址提示框

第5步，单击“是”按钮，设置结束。

3. Windows Me连接共享

Windows Me的“Internet连接共享”在使用时也非常简单。只是作为服务器必须安装Windows Me操作系统，并能够实现与Internet的连接。而且连接方式并不像在Windows 98中那样仅限于电话拨号和ISDN，而可以多样化，如DDN、ADSL等等。作为客户机的计算机既可安装Windows Me，也可安装Windows95/98等操作系统。

首先选一台安装有Windows Me的计算机，并且该计算机可以实现单机拨号上网。然后在该计算机上进行以下的操作。

第1步，在安装Windows Me时，在缺省情况下“家庭网络向导”都会安装，所以，可以依次选择“开始→程序→附件→通讯→家庭网络向导”，显示“家庭网络向导”（如图 6-4-103所示）。

图6-4-103 家庭网络向导之一

第2步，单击“下一步”按钮，在“安装选项”页（如图 6-4-104所示）中选择“我想在本机上编辑家庭网络的设置”选项。

图6-4-104 家庭网络向导之二

第3步，单击“下一步”后，显示“Internet连接”页（如图 6-4-105所示），选择“是，本机使用下列连接”一项，并在“使用下列设置直接连接到我的ISP”下拉列表中选择已经设置的单机拨号连接名称。

图6-4-105 家庭网络向导之三

注意 在进行“家庭网络向导”设置之前一定要确保该计算机已经能够连接至Internet，否则将影响后面的操作。在这里所选择的设备，是直接连接至ISP的网络适配器。

第4步，单击“下一步”按钮，显示“Internet连接共享”页（如图 6-4-106所示）。由于我们现在设置的是服务器，所以必须选择“是”，在“选择将此计算机连接到家庭网络的设备”下方将会显示本机中已经安装的网卡名称。

图6-4-106 家庭网络向导之四

第5步，单击“下一步”按钮，显示“正在建立Internet连接”页（如图 6-4-107所示），为了减少在客户机端的操作，可选择系统缺省的“否，任何其它……”选项。当然，为了限制用户对Internet的访问，也可以选择“是，自动连接至Internet”选项，并指定访问Internet的用户名和密码。

图6-4-107 家庭网络向导之五

第6步，单击“下一步”按钮，显示“计算机和工作组名称”页（如图 6-4-108所示），在“计算机名”后输入这台计算机的名称。这个名称是供家庭网络中其他计算机使用的名称，为了避免多个计算机使用同一名称，所以在同一网络中每一台计算机必须分配一个唯一的名字。接着在“使用此工作组”名后输入家庭网络的工作组名，“工作组名”在这里可以理解为网络名，即大家共用的一个名字。

图6-4-108 家庭网络向导之六

注意 在同一家庭网络（或共享Internet接入的小型网络）中必须保证每一台计算机使用的工作组名完全相同，否则计算机之间彼此都不能发现对方。

第7步，单击“下一步”按钮，显示“共享文件和打印机”页（如图 6-4-109所示）。只有选中“我的文档文件及其所有了文件夹”复选框，才能共享本地计算机中的文件夹，网络中其他的计算机才可以访问到。若欲限制用户对该文件夹的访问权限，可单击旁边的“密码”按钮设置口令。这样，当别人需要访问该计算机上的资源时，系统将首先要求对方输入密码，密码错误时将拒绝访问，从而保证了共享文件夹的安全。另外，当这台计算机上安装有打印机时，将会在中间的对话框中显示出来，若欲将这台打印机提供给网上的其他计算机使用，可以选中此打印机。

图6-4-109 家庭网络向导之七

第8步，单击“下一步”按钮，显示如图 6-4-110所示“家庭网络安装盘”页，系统询问要不要创建“家庭网络安装盘”。为了使网络中其他Windows9x计算机共享Internet接入，请选择“是，创建家庭网络安装盘”一项。如果曾经创建过网络安装盘，可选择“否，不创建家庭网络安装盘”。本例选择创建家庭网络安装盘，以供安装有Windows9x的计算机使用家庭网络功能。

图6-4-110 家庭网络向导之八

注意 如果此时不创建，当需要时也可以利用“家庭网络向导”重新制作。

第9步，当选择了“是，创建家庭网络安装盘”选项后，显示“正在创建家庭网络安装盘”页（如图 6-4-111所示）。根据提示在软驱中插入一张已格式化过的软盘。

图6-4-111 家庭网络向导之九

第10步，单击“下一步”按钮，系统开始向软盘复制所需的程序。结束后，显示如图 6-4-112所示的提示信息。

图6-4-113 家庭网络向导之十

第11步，单击“完成”按钮，并重新启动计算机后，使新配置生效。

第12步，重新启动计算机后，显示如图 6-4-113所示提示信息，提请用户在其他计算机上如何安装家庭网络，并在任务样右下角显示一个表示网络连接的图标。

图6-4-113 家庭网络向导之十一

4. Windows98 SE连接共享

在Windows 98 SE（即第二版，第一版可没有这个功能）中不仅可以共享文件和打印机，而且还可以共享Internet连接，利用一条电话线、ISDN或ADSL等链路，即可将网络中所有的用户连接至Internet。

若欲共享Internet连接，必须将网络中的一台计算机配置为Internet连接共享计算机，即代理服务器。当然，该计算机必须安装有Modem或其他Internet连接设备，并能够正常连接至Internet。在下述操作中，假定已经成功地组建了局域网，为所有的计算机都安装好了TCP/IP协议，并设置了正确的IP地址信息。

操作如下：

第1步，在“控制面版”面板中双击“添加/删除程序”图标，显示“添加/删除程序 属性”对话框（如图 6-4-114所示）。

图6-4-114 “添加/删除程序 属性”对话框

第2步，单击“Windows安装程序”选项卡，在“组件”列表中选择“Internet工具”项，单击“详细资料”按钮，显示“Internet工具”对话框。

第3步，在“组件”列表中选择“Internet连接共享”复选框（如图 6-4-115所示），单击“确定”按钮，返回至“添加/删除程序 属性”对话框。

图6-4-115 选择“Internet连接共享”复选框

第4步，单击“确定”按钮，根据系统提示插入Windows 98安装盘，系统自动运行“Internet连接共享向导”（如图 6-4-116所示）。

图6-4-116 Internet连接共享向导之一

第5步，单击“下一步”按钮，系统将请用户选择使用哪种方式接入Internet（如图 6-4-117所示）。一种是拨号连接（如使用调制解调器和电话线或使用ISDN）；一种是高速连接（如使用网络适配器、ADSL或Cable Modem等）。用户可以根据自己的需要进行选择。本例采用拨号连接方式。

图6-4-117 Internet连接共享向导之二

第6步，单击“下一步”按钮，显示如图 6-4-118所示页面，选择欲使用的Internet连接。

图6-4-118 Internet连接共享向导之三

第7步，单击“下一步”按钮，显示如图 6-4-119所示页面，选择实现与Internet实际连接在一起的网络适配器。对于通过Modem连接至Internet的计算机而言，当然应当选择Modem。其他连接方式，请选择相应的连接设备。

图6-4-119 Internet连接共享向导之四

第8步，单击“下一步”按钮，显示如图 6-4-120所示页面，系统提示将创建用户配置磁盘。

图6-4-120 Internet连接共享向导之五

第9步，单击“下一步”按钮，计算机开始创建用户配置磁盘。根据系统提示（如图 6-4-121所示）将格式化好的磁盘插入到计算机软驱中，并单击“确定”按钮。

图6-4-121 系统提示插入磁盘

第10步，磁盘制作完毕后，显示如图 6-4-122所示页面。单击“完成”按钮，重新启动计算机。

图6-4-122 Internet连接共享向导之六

第11步，校验。在控制面板中双击“网络”图标，显示“网络”对话框（如图 6-4-123所示）。“配置”选项卡的“已经安装了下列网络组件”列表框中应当列出“Internet连接共享”、“Internet连接共享（协议）→Internet连接共享”、“TCP/IP→Internet连接共享”等项。

图6-4-123 增加了Internet连接共享

需要注意的是，提供文件和打印共享的计算机不能作为连接共享计算机。


1

1.3.5 升级数码相机Firmware

如今，数码相机的发展速度也不亚于CPU的发展速度，笔者在去年年底购买的尼康COOLPIX 995当时还算得上高档机型，如今，600万像素，甚至千万像素级的数码相机都陆续上市。为了更好地提升你手

中的数码相机的性能，你也可以升级它的Firmware。升级Firmware的目的，主要是改善原有的问题和增加新功能。下面，笔者就以尼康COOLPIX 995数码相机为例。

Step1：与其他数码设备一样，并不是所有的数码相机都可以支持Firmware升级，就算可以升级还要视厂商是否有开发新版本的Firmware。当然，我们还是直接到官方网站上浏览一下。笔者直驱尼康欧洲的官方网站，终于找到适用尼康COOLPIX 995数码相机的最新1.7版本Firmware。这里要提醒大家一点，要下载英文版的Firmware，而且不要忘了下载新版本的驱动程序。

小提示

如何检测数码相机的当前Firmware版本？

不同数码相机检测Firmware的方法也不尽相同，现以尼康COOLPIX 995为例。先关闭COOLPIX995的电源，然后在开机前按住“Menu”按键不放，再开机。这时就会在液晶屏当中显示当前的版本号，见图106所示（如图 1-3-43 所示）的“E995 V1.6”说明这台数码相机的Firmware版本为1.6。最后，关闭COOLPIX995的电源，完成Firmware版本检测过程。

Step2：将下载回来的e995v17en.zip压缩包解压缩到硬盘的临时文件夹当中，如：C：\temp。这个压缩包当中共有三个文件，分别是：Firmware.bin（Firmware文件）、Uploader.exe（升级程序，只可以Windows下运行）、Readme.htm（说明文件）。

Step3：在升级前，要确定数码相机有充足的电源，例如使用数码相机附带的Nikon EN-EL1充电锂电池时，要保证充满电；或者使用Nikon EH-21 AC适配器。

总之要保证在升级过程中决不会断电，否则将造成严重后果。再把一张可以正常使用的Compact Flash卡插入到数码相机，将Nikon UC-E1 USB数据线分别插入数码相机和计算机的USB接口中。

小提示

如果你是第一次将尼康COOLPIX 995数码相机连接到Windows 98SE/Me的电脑当中，必须先安装驱动程序。如果你是使用Windows 2000/XP，则不需要安装驱动程序，系统会自动识别。

Step4：将数码相机的模式转盘置于“Play”模式（见图107）（如图 1-3-44 所示）。

Step5：然后双击Uploader升级程序的图标，将检测数码相机，并出现见图108所示（如图 1-3-45 所示）的界面。单击“Upload”按钮，进行升级Firmware操作。

Step6：在升级过程中，会在界面中显示升级的进度栏，并出现警告的字句。大约过1分钟左右，出现见图109所示（如图 1-3-46 所示）的画面，说明升级过程已完成。单击“Close”按钮退出。

Step7：关闭数码相机的电源，并将数码相机从计算机当中移开。接着还是先按住“Menu”按键，再打开数码相机电源查看是否已升级到最新版本。


1

1.3.6 升级MP3播放机Firmware

通过升级MP3播放机的Firmware，除了可以除Bug外，还可以获得更多的应用范围，例如：能够支持更多的音乐格式，支持多语言等。只不过大家对MP3播放机的Firmware升级了解甚少，下面我们就以创新NOMAD Jukebox 3为例，向大家讲述如何刷新MP3播放器。

Step1：并不是所有的MP3播放机都能支持升级Firmware，一般可以到官方网站上确认自己使用的MP3播放机是否支持升级Firmware。如果支持升级Firmware的话，检查符合自己机型的最新Firmware版本的升级文件。

小提示

如何检测创新NOMAD Jukebox 3 MP3播放机的Firmware版本？

要验证NOMAD Jukebox 3的Firmware版本，主要有两种方法。第一种方法是打开NOMAD Jukebox 3的电源，然后按“MENU”按键，再通过右侧的滚轮按键选择“Jukebox Settings”，进而选择“Jukebox information”，这时在NOMAD Jukebox 3的液晶屏上就会显示 1.10.06 就是当前的Firmware版本（见图110）（如图 1-3-47 所示）。第二种方法是通过下载的新版本Firmware升级程序，运行JB3PCFW_1_11_07.exe，自解压缩后，再双击“JB3Upgrade_1_11_07”图标，在“Current Firmware Version”中就是当前的Firmware版本（见图111）（如图1-3-48所示）。

Step2：如果有比自己所使用的MP3播放机更新版本的Firmware，将其下载回来。如本例中下载回来的是JB3PCFW_1_11_07.exe自解压程序，双击后会自动解压缩并保存在当前文件夹中。共有三个文件，分别是：Disk.id、JB3Upgrade_1_11_07.exe（升级程序）、Readme.txt。

Step3：确认已成功安装NOMAD Jukebox 3的驱动程序（不然的话，系统不能识别是什么设备，又怎么能升级呢），然后将电池插入了NOMAD Jukebox 3并且连接电源适配器。再将USB或SB1394数据线将NOMAD Jukebox 3连接到计算机的USB或IEEE 1394接口。不要忘了打开MP3播放机的电源按键哦！

Step4：在升级之前，关闭其他应用程序，并禁用屏幕保护及电源管理功能。再运行JB3Upgrade_1_11_07.exe，如果能成功检测出MP3播放机，会出现见图111所示（如图 1-3-48 所示）界面。“Current Firmware Version”是显示当前的Firmware版本，“Current File Version”是显示欲升级的Firmware版本。同时，在NOMAD Jukebox 3的液晶屏中也会显示正在与计算机通讯的画面。

Step5：单击“Upgrade”按钮，升级程序将自动升级Firmware（见图112）（如图 1-3-49 所示）。注意在整个刷新过程中，计算机和MP3播放机绝对不可以断电，否则会造成升级失败。

Step6：升级完毕后，NOMAD Jukebox 3 MP3播放机将自动重启。接着，升级程序会出现“Firmware upgrade completed!”提示信息，单击“Close”关闭此对话框（见图113）（如图 1-3-50 所示）。

Step7：再重新验证创新NOMAD Jukebox 3的Firmware版本是不是变成 1.11.07 版本，如果是的话，说明升级成功！


1

1.3.7 升级笔记本电脑BIOS

众所周知，笔记本电脑也跟台式机一样，都可以升级BIOS。但是笔记本电脑的BIOS和台式机的BIOS有很大的不同，台式机的BIOS主要是以Award和AMI为主，而笔记本电脑的BIOS则是主要以Phoniex为主，也有部份厂家开发专用的BIOS。由于笔记本电脑已经是集成系统，所以升级BIOS时要特别注意，不单单是不同品牌的笔记本电脑的升级BIOS过程有很大差别，就是同一品牌不同型号的笔记本电脑都可能有差别。今天我们就以东芝Satellite 3000笔记本电脑为例，向大家讲述升级笔记本电脑BIOS的过程。

Step1：首先我们要确认笔记本电脑的BIOS版本。打开笔记本电脑的电源开关后，当屏幕出现“Press <F2> to enter SETUP，Press <C> to boot from CD-ROM”时，按“F2”键进入CMOS设置程序，在“Main”菜单的“BIOS Ver.”显示当前的BIOS版本号（见图114）（如图 1-3-51 所示）。然后用方向键移动到“Exit”菜单，选择“Exit Saving Changes”并按下回车键，再选择“Yes”，再次按下回车键退出CMOS设置程序。或者打开笔记本电脑的电源开关后，当屏幕出现“Press <F2> to enter SETUP，Press <C> to boot from CD-ROM”时，按“ESC”键进行开机自检，在画面左上角会显示“BIOS Version V1.90”表示当前BIOS的版本号（见图115）（如图1-3-52所示）。

小提示

如何进入各品牌的笔记本电脑的CMOS设置程序？

一般来说，采Phoniex BIOS公版基本上设计的BIOS，一般是在开机或重新启动时按“F2”键，这是Phoniex BIOS默认进入CMOS设置程序的方式。不同品牌的笔记本电脑进入CMOS设置程序的方法可能有所不同，下面将列出主要品牌笔记本电脑进入CMOS设置程序的方法：IBM是开机后按“F1”键（部份机型号可以在重新启动时按“F1”键，还有些机型进入CMOS设置程序更为特殊）；SONY（索尼）是开机或重启时按“F2”键；Dell（戴尔）是开机或重启时按“F2”键（部份机型可以在Windows下按“FN+F2”组合键）；HP（惠普）是开机或重启时按“F2”键；Acer（宏碁）开机或重启时按“F2”键；Toshiba（东芝）是开机时按“ESC”键然后按“F1”键（部份机型是开机或重启时按“F2”键）；Compaq（康柏）是开机时按“F10”键；Fujitsu（富士通）开机或重启时按“F2”键；绝大多数祖国大陆的品牌和我国台湾的品牌是开机或重启时按“F2”键。

Step2：从官方网站下载对应型号的最新版BIOS文件，如本例是从东芝亚洲网站下载东芝Satellite 3000（机型代码：PS300x-xxxx）笔记本电脑的2.30版BIOS的3000B230.zip压缩包。下载前一定要核对笔记本电脑的型号（有些品牌的笔记本电脑还需对应机型代码）和所下载的BIOS是否对应，千万不可以弄错。

小提示

笔记本电脑的型号和机型代码一般可在背面的标识上找到（见图116）（如图 1-3-53 所示）。

Step3：将3.5英寸的1.44MB软驱与光驱对换（此机型支持热插拔交换），然后开机进入Windows操作系统，将一张格式化好的1.44MB空白软盘放入软驱，并在Windows 98下将这张软盘格式化成启动盘。

Step4：将下载回来的BIOS升级文件的压缩包解压缩到A盘。这时不要取出软盘，因为此软盘支持启动并能自动刷新BIOS。

重要提示：正式升级BIOS前的注意事项

在进行升级操作前，请先确认电脑正在使用电源适配器供电，千万不可以在电池供电方式下升级BIOS。另外，电池必须充满电，如果电池电力不足，即使使用电源适配器供电系统也会拒绝升级请求。同时还须确认没有正在运行的其他应用程序，如有请将它们全部关闭。

Step5：然后重新启动计算机，并确认已在CMOS设置程序中设置第一启动顺序为A盘，否则要进入CMOS设置程序重新进行设置。

Step6：这时系统将从软盘启动，成功启动后屏幕将出现见图117所示（如图 1-3-54 所示）的画面，然后输入“1”。

Step7：系统将运行PhoniexPhlash Utility程序（见图118）（如图 1-3-55 所示），并自动进行升级BIOS操作，此过程一般为将近1分钟。在刷新过程中，软盘的读写灯会点亮，在灯没有熄灭之前，千万不可以关闭计算机的电源或取出软盘。

Step8：刷新结束后，会自动关闭计算机。到这个步骤时，先把软驱内的软盘取出，然后重新打开笔记本电脑的电源开关。成功启动计算机后，就会发现BIOS已升级到2.30版，至此，BIOS升级成功完成。


“由0晋身200%系统高手”

作 者：一流作者阵容，确保内容精彩

盆 盆，微软专家

梁 振，微软专家

张晓兵，瑞星公司工程师

王寒晖，电脑爱好者硬件栏目资深编辑，“小怪座谈”主持人

刘晓辉，知名作者，著有《局域网一点通》之三，《局域网一点通火力加强版》

《局域网一点通高级版》等畅销书

王志坚，知名撰稿人

创新内容模式：基本知识讲解＋常见案例分析＋技巧＋故障

环环相扣的系统理论讲解，透彻剖析系统脉络

超过 50 例的精选案例分析，超过100 例故障分析，超过200 例技巧

“电脑爱好者”杂志精彩栏目“系统应用”和“傻博士”

2003全年、2004年全部文章

超先享受：
    现在邮购，仅需23元（原价25元）！
    邮购本书，不但可以让您第一时间体验本书的精彩内容，更可以8折优惠购买最新上市之《电脑爱好者合订本2004》（上）或者电脑爱好者2004增刊！
    邮购代码：SK0190（请务必在汇款单留言栏内注明“SK0190“或《由0晋身200％系统高手》）
    汇款地址：
    北京9615信箱（100086）　牛万华收
    邮购查询：010-62161332，010-82515474

更多优惠：
本书读者将获得下列软件三月免费使用权（过期后可以优惠价注册）
超级兔子魔法设置　 电子文档处理器　 我爱背单词　 超级特工　 加密金刚锁
疯狂单词　 数码故事